nxsdDataDictionary.TnxIndexDescriptor.Desc

NexusDB - Class Reference
nxsdDataDictionary.TnxIndexDescriptor.Desc
Send Feedback

A description for the index.

Made with [image] Doc-O-Matic.
Copyright (c) 2019. All rights reserved.
Contents | Index | Home
What do you think about this topic? Send feedback!


nxsdDataDictionary.TnxIndexDescriptor.Dups

nxsdDataDictionary.TnxIndexDescriptor.Dups
Send Feedback

Set to true if the index allows duplicates.


nxsdDataDictionary.TnxIndexDescriptor.FileNumber

nxsdDataDictionary.TnxIndexDescriptor.FileNumber
Send Feedback

The file number where the index is stored.


nxsdDataDictionary.TnxIndexDescriptor.idDesc

nxsdDataDictionary.TnxIndexDescriptor.idDesc
Send Feedback

..description of index.


nxsdDataDictionary.TnxIndexDescriptor.idFileNumber

nxsdDataDictionary.TnxIndexDescriptor.idFileNumber
Send Feedback

..number of file containing index.


nxsdDataDictionary.TnxIndexDescriptor.idIndexEngine

nxsdDataDictionary.TnxIndexDescriptor.idIndexEngine
Send Feedback

..name of index engine.


nxsdDataDictionary.TnxIndexDescriptor.idName

nxsdDataDictionary.TnxIndexDescriptor.idName
Send Feedback

..name of index.


nxsdDataDictionary.TnxIndexDescriptor.IndexEngine

nxsdDataDictionary.TnxIndexDescriptor.IndexEngine
Send Feedback

The Name of the Index Engine used to create access the index.


nxsdDataDictionary.TnxIndexDescriptor.IndexFile

nxsdDataDictionary.TnxIndexDescriptor.IndexFile
Send Feedback

The File Descriptor if the Index is stored in an extra file.


nxsdDataDictionary.TnxIndexDescriptor.Name

nxsdDataDictionary.TnxIndexDescriptor.Name
Send Feedback

The name of the Index.


nxsdDataDictionary.TnxIndexDescriptor.Number

nxsdDataDictionary.TnxIndexDescriptor.Number
Send Feedback

The number of the Index in the list of indices of the ParentDataDictionary.


CocoaBase Namespace

CocoaBase Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace CocoaBase.

Classes
Name | Description
TBaseParser | This is class CocoaBase.TBaseParser.
TBaseTokenizer | This is class CocoaBase.TBaseTokenizer.
TTernaryTree | This is class CocoaBase.TTernaryTree.
TTokenList | This is class CocoaBase.TTokenList.
TTokenPage | This is class CocoaBase.TTokenPage.
Constants
Name | Description
MaxEmptyScopeNesting | This is constant CocoaBase.MaxEmptyScopeNesting.
MaxParserStack | these two tweaked to give exactly 4K for a parser instance
MaxSiblings | max number of token alternatives at any given point
MaxTokenizerStack | This is constant CocoaBase.MaxTokenizerStack.
TokensPerPage | gives exactly 4K to the page
Functions
Name | Description
TokensIdentical | This is function CocoaBase.TokensIdentical.
TokenToInt | This is function CocoaBase.TokenToInt.
TokenToLocationStr | This is function CocoaBase.TokenToLocationStr.
TokenToStr | This is function CocoaBase.TokenToStr.
TokenToStrStripQ | This is function CocoaBase.TokenToStrStripQ.
Structs, Records, Enums
Name | Description
TParseStackRec | This is record CocoaBase.TParseStackRec.
TScopeStackRec | This is record CocoaBase.TScopeStackRec.
TSyntaxNode | This is record CocoaBase.TSyntaxNode.
TTernaryNode | This is record CocoaBase.TTernaryNode.
TTokenRecord | This is record CocoaBase.TTokenRecord.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PTernaryNode | This is type CocoaBase.PTernaryNode.
PTokenRecord | This is type CocoaBase.PTokenRecord.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes CocoaBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TBaseParser | This is class CocoaBase.TBaseParser.
TBaseTokenizer | This is class CocoaBase.TBaseTokenizer.
TTernaryTree | This is class CocoaBase.TTernaryTree.
TTokenList | This is class CocoaBase.TTokenList.
TTokenPage | This is class CocoaBase.TTokenPage.
Namespace

CocoaBase Namespace

Links
Classes, CocoaBase Namespace, Legend


TBaseParser Class

TBaseParser Class
TBaseParser Fields TBaseParser Methods TBaseParser Properties TBaseParser Members CocoaBase Classes Send Feedback
Class Hierarchy
CocoaBase_TBaseParser
Syntax
Delphi
TBaseParser = class;
File

CocoaBase

Description

This is class CocoaBase.TBaseParser.

Group

Classes

Links
TBaseParser Fields, TBaseParser Methods, TBaseParser Properties, TBaseParser Members, CocoaBase, Classes


TBaseParser Members

TBaseParser Members
TBaseParser Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TBaseParser.

Class

TBaseParser Class

Protected Fields
Name | Description
CodePtr | This is CodePtr, a member of class TBaseParser.
ExpectedTokenList | This is ExpectedTokenList, a member of class TBaseParser.
FCodes | This is FCodes, a member of class TBaseParser.
FExpectedTokenCount | This is FExpectedTokenCount, a member of class TBaseParser.
FFailedTokenIndex | This is FFailedTokenIndex, a member of class TBaseParser.
FSource | This is FSource, a member of class TBaseParser.
FTokens | This is FTokens, a member of class TBaseParser.
HighTokenPtr | This is HighTokenPtr, a member of class TBaseParser.
ScopeStack | This is ScopeStack, a member of class TBaseParser.
SSTP | This is SSTP, a member of class TBaseParser.
Stack | This is Stack, a member of class TBaseParser.
STP | This is STP, a member of class TBaseParser.
TokenPtr | This is TokenPtr, a member of class TBaseParser.
Protected Methods
Name | Description
AddCode | TBaseParser
Advance | This is Advance, a member of class TBaseParser.
Compile | This is Compile, a member of class TBaseParser.
Drop | This is Drop, a member of class TBaseParser.
Ensure | This is Ensure, a member of class TBaseParser.
Error | This is Error, a member of class TBaseParser.
GetCode | This is GetCode, a member of class TBaseParser.
GetExpectedToken | function GetExpectedTokenCount: Integer; function TBaseParser.GetExpectedTokenCount: Integer; begin if ExpectedTokenList <> nil then
IfDropElsePop | This is IfDropElsePop, a member of class TBaseParser.
LexInt | This is LexInt, a member of class TBaseParser.
LexInt64 | This is LexInt64, a member of class TBaseParser.
LexString | This is LexString, a member of class TBaseParser.
Match | This is Match, a member of class TBaseParser.
MatchInterval | This is MatchInterval, a member of class TBaseParser.
Parse | This is Parse, a member of class TBaseParser.
Pop | This is Pop, a member of class TBaseParser.
PopAddCode | This is PopAddCode, a member of class TBaseParser.
PopAddCode_0 | This is PopAddCode_0, a member of class TBaseParser.
PopPush | This is PopPush, a member of class TBaseParser.
PopPushAddCode | This is PopPushAddCode, a member of class TBaseParser.
PopScope | This is PopScope, a member of class TBaseParser.
Push | This is Push, a member of class TBaseParser.
PushAddCode | This is PushAddCode, a member of class TBaseParser.
PushAddCode_0 | This is PushAddCode_0, a member of class TBaseParser.
PushAddCode_1 | This is PushAddCode_1, a member of class TBaseParser.
PushAddCode_2 | This is PushAddCode_2, a member of class TBaseParser.
PushScope | This is PushScope, a member of class TBaseParser.
StoreExpectedToken | This is StoreExpectedToken, a member of class TBaseParser.
TokenStr | This is TokenStr, a member of class TBaseParser.
Public Methods
Name | Description
CurToken | This is CurToken, a member of class TBaseParser.
CurTokenPtr | This is CurTokenPtr, a member of class TBaseParser.
Destroy | This is Destroy, a member of class TBaseParser.
DumpCodes | property ExpectedToken: Integer read FExpectedToken;
ExpectedTokensString | This is ExpectedTokensString, a member of class TBaseParser.
Public Properties
Name | Description
ExpectedToken | This is ExpectedToken, a member of class TBaseParser.
ExpectedTokenCount | This is ExpectedTokenCount, a member of class TBaseParser.
FailedTokenIndex | This is FailedTokenIndex, a member of class TBaseParser.
Source | This is Source, a member of class TBaseParser.
TokenList | This is TokenList, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TBaseParser.Destroy Destructor

TBaseParser.Destroy Destructor
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TBaseParser.

Class

TBaseParser Class

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Class


TBaseParser Fields

TBaseParser Fields
TBaseParser Class Legend Protected Fields Send Feedback

The fields of the TBaseParser class are listed here.

Class

TBaseParser Class

Protected Fields
Name | Description
CodePtr | This is CodePtr, a member of class TBaseParser.
ExpectedTokenList | This is ExpectedTokenList, a member of class TBaseParser.
FCodes | This is FCodes, a member of class TBaseParser.
FExpectedTokenCount | This is FExpectedTokenCount, a member of class TBaseParser.
FFailedTokenIndex | This is FFailedTokenIndex, a member of class TBaseParser.
FSource | This is FSource, a member of class TBaseParser.
FTokens | This is FTokens, a member of class TBaseParser.
HighTokenPtr | This is HighTokenPtr, a member of class TBaseParser.
ScopeStack | This is ScopeStack, a member of class TBaseParser.
SSTP | This is SSTP, a member of class TBaseParser.
Stack | This is Stack, a member of class TBaseParser.
STP | This is STP, a member of class TBaseParser.
TokenPtr | This is TokenPtr, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Fields


TBaseParser.CodePtr Field

TBaseParser.CodePtr Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
CodePtr: Integer;
Description

This is CodePtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.ExpectedTokenList Field

TBaseParser.ExpectedTokenList Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
ExpectedTokenList: array[0..MaxSiblings-1] of Integer;
Description

This is ExpectedTokenList, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.FCodes Field

TBaseParser.FCodes Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FCodes: TList;
Description

This is FCodes, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.FExpectedTokenCount Field

TBaseParser.FExpectedTokenCount Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FExpectedTokenCount: Integer;
Description

This is FExpectedTokenCount, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.FFailedTokenIndex Field

TBaseParser.FFailedTokenIndex Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FFailedTokenIndex: Integer;
Description

This is FFailedTokenIndex, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.FSource Field

TBaseParser.FSource Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FSource: string;
Description

This is FSource, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.FTokens Field

TBaseParser.FTokens Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FTokens: TTokenList;
Description

This is FTokens, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.HighTokenPtr Field

TBaseParser.HighTokenPtr Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
HighTokenPtr: Integer;
Description

This is HighTokenPtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.ScopeStack Field

TBaseParser.ScopeStack Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
ScopeStack: array[0..MaxParserStack - 1] of TScopeStackRec;
Description

This is ScopeStack, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.SSTP Field

TBaseParser.SSTP Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
SSTP: Integer;
Description

This is SSTP, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.Stack Field

TBaseParser.Stack Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
Stack: array[0..MaxParserStack - 1] of TParseStackRec;
Description

This is Stack, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.STP Field

TBaseParser.STP Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
STP: Integer;
Description

This is STP, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser.TokenPtr Field

TBaseParser.TokenPtr Field
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
TokenPtr: Integer;
Description

This is TokenPtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Fields


TBaseParser Methods

TBaseParser Methods
TBaseParser Class Legend Protected Methods Public Methods Send Feedback

The methods of the TBaseParser class are listed here.

Class

TBaseParser Class

Protected Methods
Name | Description
AddCode | TBaseParser
Advance | This is Advance, a member of class TBaseParser.
Compile | This is Compile, a member of class TBaseParser.
Drop | This is Drop, a member of class TBaseParser.
Ensure | This is Ensure, a member of class TBaseParser.
Error | This is Error, a member of class TBaseParser.
GetCode | This is GetCode, a member of class TBaseParser.
GetExpectedToken | function GetExpectedTokenCount: Integer; function TBaseParser.GetExpectedTokenCount: Integer; begin if ExpectedTokenList <> nil then
IfDropElsePop | This is IfDropElsePop, a member of class TBaseParser.
LexInt | This is LexInt, a member of class TBaseParser.
LexInt64 | This is LexInt64, a member of class TBaseParser.
LexString | This is LexString, a member of class TBaseParser.
Match | This is Match, a member of class TBaseParser.
MatchInterval | This is MatchInterval, a member of class TBaseParser.
Parse | This is Parse, a member of class TBaseParser.
Pop | This is Pop, a member of class TBaseParser.
PopAddCode | This is PopAddCode, a member of class TBaseParser.
PopAddCode_0 | This is PopAddCode_0, a member of class TBaseParser.
PopPush | This is PopPush, a member of class TBaseParser.
PopPushAddCode | This is PopPushAddCode, a member of class TBaseParser.
PopScope | This is PopScope, a member of class TBaseParser.
Push | This is Push, a member of class TBaseParser.
PushAddCode | This is PushAddCode, a member of class TBaseParser.
PushAddCode_0 | This is PushAddCode_0, a member of class TBaseParser.
PushAddCode_1 | This is PushAddCode_1, a member of class TBaseParser.
PushAddCode_2 | This is PushAddCode_2, a member of class TBaseParser.
PushScope | This is PushScope, a member of class TBaseParser.
StoreExpectedToken | This is StoreExpectedToken, a member of class TBaseParser.
TokenStr | This is TokenStr, a member of class TBaseParser.
Public Methods
Name | Description
CurToken | This is CurToken, a member of class TBaseParser.
CurTokenPtr | This is CurTokenPtr, a member of class TBaseParser.
DumpCodes | property ExpectedToken: Integer read FExpectedToken;
ExpectedTokensString | This is ExpectedTokensString, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Methods, Public Methods


TBaseParser.AddCode Method

TBaseParser.AddCode Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function AddCode(C: Integer): Boolean;
Description

TBaseParser

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Advance Method

TBaseParser.Advance Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Advance;
Description

This is Advance, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Compile Method

TBaseParser.Compile Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Compile; virtual; abstract;
Description

This is Compile, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.CurToken Method

TBaseParser.CurToken Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function CurToken: Integer;
Description

This is CurToken, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.CurTokenPtr Method

TBaseParser.CurTokenPtr Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function CurTokenPtr: PTokenRecord;
Description

This is CurTokenPtr, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Drop Method

TBaseParser.Drop Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Drop;
Description

This is Drop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.DumpCodes Method

TBaseParser.DumpCodes Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure DumpCodes;
Description

property ExpectedToken: Integer read FExpectedToken;

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Ensure Method

TBaseParser.Ensure Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Ensure(Token: Integer);
Description

This is Ensure, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Error Method

TBaseParser.Error Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Error(const Msg: string);
Description

This is Error, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.ExpectedTokensString Method

TBaseParser.ExpectedTokensString Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function ExpectedTokensString: string;
Description

This is ExpectedTokensString, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.GetCode Method

TBaseParser.GetCode Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function GetCode: Integer;
Description

This is GetCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.GetExpectedToken Method

TBaseParser.GetExpectedToken Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function GetExpectedToken(Index: Integer): Integer;
Returns

= ExpectedTokenList.Count else

= 0; end;

Description

function GetExpectedTokenCount: Integer;

function TBaseParser.GetExpectedTokenCount: Integer; begin if ExpectedTokenList <> nil then

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.IfDropElsePop Method

TBaseParser.IfDropElsePop Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure IfDropElsePop(B: Boolean);
Description

This is IfDropElsePop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.LexInt Method

TBaseParser.LexInt Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexInt: Integer;
Description

This is LexInt, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.LexInt64 Method

TBaseParser.LexInt64 Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexInt64: int64;
Description

This is LexInt64, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.LexString Method

TBaseParser.LexString Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexString: string;
Description

This is LexString, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Match Method

TBaseParser.Match Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function Match(Token: Integer): Boolean;
Description

This is Match, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.MatchInterval Method

TBaseParser.MatchInterval Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function MatchInterval(Token1: Integer; Token2: Integer): Boolean;
Description

This is MatchInterval, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Parse Method

TBaseParser.Parse Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function Parse: Boolean; virtual; abstract;
Description

This is Parse, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Pop Method

TBaseParser.Pop Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Pop;
Description

This is Pop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PopAddCode Method

TBaseParser.PopAddCode Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopAddCode(C: Integer);
Description

This is PopAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PopAddCode_0 Method

TBaseParser.PopAddCode_0 Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopAddCode_0;
Description

This is PopAddCode_0, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PopPush Method

TBaseParser.PopPush Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopPush;
Description

This is PopPush, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PopPushAddCode Method

TBaseParser.PopPushAddCode Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopPushAddCode(C: Integer);
Description

This is PopPushAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PopScope Method

TBaseParser.PopScope Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopScope(ScopeID: Integer);
Description

This is PopScope, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.Push Method

TBaseParser.Push Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Push;
Description

This is Push, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PushAddCode Method

TBaseParser.PushAddCode Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode(C: Integer);
Description

This is PushAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PushAddCode_0 Method

TBaseParser.PushAddCode_0 Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_0;
Description

This is PushAddCode_0, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PushAddCode_1 Method

TBaseParser.PushAddCode_1 Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_1;
Description

This is PushAddCode_1, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PushAddCode_2 Method

TBaseParser.PushAddCode_2 Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_2;
Description

This is PushAddCode_2, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.PushScope Method

TBaseParser.PushScope Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function PushScope(ScopeID: Integer): Boolean;
Description

This is PushScope, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.StoreExpectedToken Method

TBaseParser.StoreExpectedToken Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure StoreExpectedToken(ExpectedToken: Integer);
Description

This is StoreExpectedToken, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser.TokenStr Method

TBaseParser.TokenStr Method
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function TokenStr(Token: Integer): string; virtual; abstract;
Description

This is TokenStr, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Methods


TBaseParser Properties

TBaseParser Properties
TBaseParser Class Legend Public Properties Send Feedback

The properties of the TBaseParser class are listed here.

Class

TBaseParser Class

Public Properties
Name | Description
ExpectedToken | This is ExpectedToken, a member of class TBaseParser.
ExpectedTokenCount | This is ExpectedTokenCount, a member of class TBaseParser.
FailedTokenIndex | This is FailedTokenIndex, a member of class TBaseParser.
Source | This is Source, a member of class TBaseParser.
TokenList | This is TokenList, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Public Properties


TBaseParser.ExpectedToken Property

TBaseParser.ExpectedToken Property
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property ExpectedToken [Index: Integer]: Integer;
Description

This is ExpectedToken, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Properties


TBaseParser.ExpectedTokenCount Property

TBaseParser.ExpectedTokenCount Property
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property ExpectedTokenCount: Integer;
Description

This is ExpectedTokenCount, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Properties


TBaseParser.FailedTokenIndex Property

TBaseParser.FailedTokenIndex Property
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property FailedTokenIndex: Integer;
Description

This is FailedTokenIndex, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Properties


TBaseParser.Source Property

TBaseParser.Source Property
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property Source: string;
Description

This is Source, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Properties


TBaseParser.TokenList Property

TBaseParser.TokenList Property
TBaseParser Class TBaseParser Members CocoaBase Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property TokenList: TTokenList;
Description

This is TokenList, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBase Namespace, TBaseParser Properties


TBaseTokenizer Class

TBaseTokenizer Class
TBaseTokenizer Fields TBaseTokenizer Methods TBaseTokenizer Members CocoaBase Classes Send Feedback
Class Hierarchy
CocoaBase_TBaseTokenizer
Syntax
Delphi
TBaseTokenizer = class;
File

CocoaBase

Description

This is class CocoaBase.TBaseTokenizer.

Group

Classes

Links
TBaseTokenizer Fields, TBaseTokenizer Methods, TBaseTokenizer Members, CocoaBase, Classes


TBaseTokenizer Members

TBaseTokenizer Members
TBaseTokenizer Class Legend Protected Fields Protected Methods Send Feedback

The following tables list the members exposed by TBaseTokenizer.

Class

TBaseTokenizer Class

Protected Fields
Name | Description
CurLine | This is CurLine, a member of class TBaseTokenizer.
CurPos | This is CurPos, a member of class TBaseTokenizer.
CurPtr | This is CurPtr, a member of class TBaseTokenizer.
EndPtr | This is EndPtr, a member of class TBaseTokenizer.
LineStack | This is LineStack, a member of class TBaseTokenizer.
PosStack | This is PosStack, a member of class TBaseTokenizer.
PtrStack | This is PtrStack, a member of class TBaseTokenizer.
StartLine | This is StartLine, a member of class TBaseTokenizer.
StartPos | This is StartPos, a member of class TBaseTokenizer.
StartPtr | This is StartPtr, a member of class TBaseTokenizer.
STP | This is STP, a member of class TBaseTokenizer.
Protected Methods
Name | Description
Advance | This is the overview for the Advance method overload.
Drop | This is Drop, a member of class TBaseTokenizer.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseTokenizer.
NextChar | This is NextChar, a member of class TBaseTokenizer.
Peek | This is the overview for the Peek method overload.
Pop | This is Pop, a member of class TBaseTokenizer.
Push | This is Push, a member of class TBaseTokenizer.
Tokenize | This is Tokenize, a member of class TBaseTokenizer.
Links
TBaseTokenizer Class, Legend, Protected Fields, Protected Methods


TBaseTokenizer Fields

TBaseTokenizer Fields
TBaseTokenizer Class Legend Protected Fields Send Feedback

The fields of the TBaseTokenizer class are listed here.

Class

TBaseTokenizer Class

Protected Fields
Name | Description
CurLine | This is CurLine, a member of class TBaseTokenizer.
CurPos | This is CurPos, a member of class TBaseTokenizer.
CurPtr | This is CurPtr, a member of class TBaseTokenizer.
EndPtr | This is EndPtr, a member of class TBaseTokenizer.
LineStack | This is LineStack, a member of class TBaseTokenizer.
PosStack | This is PosStack, a member of class TBaseTokenizer.
PtrStack | This is PtrStack, a member of class TBaseTokenizer.
StartLine | This is StartLine, a member of class TBaseTokenizer.
StartPos | This is StartPos, a member of class TBaseTokenizer.
StartPtr | This is StartPtr, a member of class TBaseTokenizer.
STP | This is STP, a member of class TBaseTokenizer.
Links
TBaseTokenizer Class, Legend, Protected Fields


TBaseTokenizer.CurLine Field

TBaseTokenizer.CurLine Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurLine: Integer;
Description

This is CurLine, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.CurPos Field

TBaseTokenizer.CurPos Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurPos: Integer;
Description

This is CurPos, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.CurPtr Field

TBaseTokenizer.CurPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurPtr: PChar;
Description

This is CurPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.EndPtr Field

TBaseTokenizer.EndPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
EndPtr: PChar;
Description

This is EndPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.LineStack Field

TBaseTokenizer.LineStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
LineStack: array[0..MaxTokenizerStack] of Integer;
Description

This is LineStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.PosStack Field

TBaseTokenizer.PosStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
PosStack: array[0..MaxTokenizerStack] of Integer;
Description

This is PosStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.PtrStack Field

TBaseTokenizer.PtrStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
PtrStack: array[0..MaxTokenizerStack] of PChar;
Description

This is PtrStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartLine Field

TBaseTokenizer.StartLine Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartLine: Integer;
Description

This is StartLine, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartPos Field

TBaseTokenizer.StartPos Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartPos: Integer;
Description

This is StartPos, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartPtr Field

TBaseTokenizer.StartPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartPtr: PChar;
Description

This is StartPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer.STP Field

TBaseTokenizer.STP Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
STP: Integer;
Description

This is STP, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Fields


TBaseTokenizer Methods

TBaseTokenizer Methods
TBaseTokenizer Class Legend Protected Methods Send Feedback

The methods of the TBaseTokenizer class are listed here.

Class

TBaseTokenizer Class

Protected Methods
Name | Description
Advance | This is the overview for the Advance method overload.
Drop | This is Drop, a member of class TBaseTokenizer.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseTokenizer.
NextChar | This is NextChar, a member of class TBaseTokenizer.
Peek | This is the overview for the Peek method overload.
Pop | This is Pop, a member of class TBaseTokenizer.
Push | This is Push, a member of class TBaseTokenizer.
Tokenize | This is Tokenize, a member of class TBaseTokenizer.
Links
TBaseTokenizer Class, Legend, Protected Methods


Advance Method

Advance Method
TBaseTokenizer Methods Send Feedback

This is the overview for the Advance method overload.

Overload List
Name | Description
TBaseTokenizer.Advance () | This is Advance, a member of class TBaseTokenizer.
TBaseTokenizer.Advance (DWord) | TBaseTokenizer
Group

TBaseTokenizer Methods

Links
TBaseTokenizer Methods


TBaseTokenizer.Advance Method ()

TBaseTokenizer.Advance Method ()
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace Advance Method Send Feedback
Syntax
Delphi
procedure Advance; overload;
Description

This is Advance, a member of class TBaseTokenizer.

Group

Advance Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, Advance Method


TBaseTokenizer.Advance Method (DWord)

TBaseTokenizer.Advance Method (DWord)
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace Advance Method Send Feedback
Syntax
Delphi
procedure Advance(Offset: DWord); overload;
Description

TBaseTokenizer

Group

Advance Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, Advance Method


TBaseTokenizer.Drop Method

TBaseTokenizer.Drop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Drop;
Description

This is Drop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


TBaseTokenizer.IfDropElsePop Method

TBaseTokenizer.IfDropElsePop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure IfDropElsePop(B: Boolean);
Description

This is IfDropElsePop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


TBaseTokenizer.NextChar Method

TBaseTokenizer.NextChar Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function NextChar: Char;
Description

This is NextChar, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


Peek Method

Peek Method
TBaseTokenizer Methods Send Feedback

This is the overview for the Peek method overload.

Overload List
Name | Description
TBaseTokenizer.Peek () | This is Peek, a member of class TBaseTokenizer.
TBaseTokenizer.Peek (DWord) | This is Peek, a member of class TBaseTokenizer.
Group

TBaseTokenizer Methods

Links
TBaseTokenizer Methods


TBaseTokenizer.Peek Method ()

TBaseTokenizer.Peek Method ()
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace Peek Method Send Feedback
Syntax
Delphi
function Peek: Char; overload;
Description

This is Peek, a member of class TBaseTokenizer.

Group

Peek Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, Peek Method


TBaseTokenizer.Peek Method (DWord)

TBaseTokenizer.Peek Method (DWord)
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace Peek Method Send Feedback
Syntax
Delphi
function Peek(Offset: DWord): Char; overload;
Description

This is Peek, a member of class TBaseTokenizer.

Group

Peek Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, Peek Method


TBaseTokenizer.Pop Method

TBaseTokenizer.Pop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Pop;
Description

This is Pop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


TBaseTokenizer.Push Method

TBaseTokenizer.Push Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Push;
Description

This is Push, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


TBaseTokenizer.Tokenize Method

TBaseTokenizer.Tokenize Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBase Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function Tokenize(BufferPtr: PChar; BufferLength: Integer; IncludeComments: Boolean; IncludeWhitespace: Boolean; var Tokens: TTokenList): Boolean; virtual; abstract;
Description

This is Tokenize, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBase Namespace, TBaseTokenizer Methods


TTernaryTree Class

TTernaryTree Class
TTernaryTree Methods TTernaryTree Members CocoaBase Classes Send Feedback
Class Hierarchy
CocoaBase_TTernaryTree
Syntax
Delphi
TTernaryTree = class;
File

CocoaBase

Description

This is class CocoaBase.TTernaryTree.

Group

Classes

Links
TTernaryTree Methods, TTernaryTree Members, CocoaBase, Classes


TTernaryTree Members

TTernaryTree Members
TTernaryTree Class Legend Public Methods Send Feedback

The following tables list the members exposed by TTernaryTree.

Class

TTernaryTree Class

Public Methods
Name | Description
Destroy | This is Destroy, a member of class TTernaryTree.
InsertStr | This is InsertStr, a member of class TTernaryTree.
Search | This is Search, a member of class TTernaryTree.
SearchUC | This is SearchUC, a member of class TTernaryTree.
Links
TTernaryTree Class, Legend, Public Methods


TTernaryTree.Destroy Destructor

TTernaryTree.Destroy Destructor
TTernaryTree Class TTernaryTree Members CocoaBase Namespace TTernaryTree Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TTernaryTree.

Class

TTernaryTree Class

Links
TTernaryTree Class, TTernaryTree Members, CocoaBase Namespace, TTernaryTree Class


TTernaryTree Methods

TTernaryTree Methods
TTernaryTree Class Legend Public Methods Send Feedback

The methods of the TTernaryTree class are listed here.

Class

TTernaryTree Class

Public Methods
Name | Description
InsertStr | This is InsertStr, a member of class TTernaryTree.
Search | This is Search, a member of class TTernaryTree.
SearchUC | This is SearchUC, a member of class TTernaryTree.
Links
TTernaryTree Class, Legend, Public Methods


TTernaryTree.InsertStr Method

TTernaryTree.InsertStr Method
TTernaryTree Class TTernaryTree Members CocoaBase Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
procedure InsertStr(C: PChar; Val: Integer);
Description

This is InsertStr, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBase Namespace, TTernaryTree Methods


TTernaryTree.Search Method

TTernaryTree.Search Method
TTernaryTree Class TTernaryTree Members CocoaBase Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
function Search(C: PChar): Integer;
Description

This is Search, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBase Namespace, TTernaryTree Methods


TTernaryTree.SearchUC Method

TTernaryTree.SearchUC Method
TTernaryTree Class TTernaryTree Members CocoaBase Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
function SearchUC(C: PChar): Integer;
Description

This is SearchUC, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBase Namespace, TTernaryTree Methods


TTokenList Class

TTokenList Class
TTokenList Methods TTokenList Properties TTokenList Members CocoaBase Classes Send Feedback
Class Hierarchy
CocoaBase_TTokenList
Syntax
Delphi
TTokenList = class;
File

CocoaBase

Description

This is class CocoaBase.TTokenList.

Group

Classes

Links
TTokenList Methods, TTokenList Properties, TTokenList Members, CocoaBase, Classes


TTokenList Members

TTokenList Members
TTokenList Class Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by TTokenList.

Class

TTokenList Class

Public Methods
Name | Description
AddToken | TTokenList
Destroy | This is Destroy, a member of class TTokenList.
TokenAsInt | This is TokenAsInt, a member of class TTokenList.
TokenAsInt64 | This is TokenAsInt64, a member of class TTokenList.
TokenIndexFromLineAndPos | This is TokenIndexFromLineAndPos, a member of class TTokenList.
TokenPtr | This is TokenPtr, a member of class TTokenList.
TokenStr | This is TokenStr, a member of class TTokenList.
Public Properties
Name | Description
TokenBufferEnd | This is TokenBufferEnd, a member of class TTokenList.
TokenBufferStart | This is TokenBufferStart, a member of class TTokenList.
TokenCount | This is TokenCount, a member of class TTokenList.
TokenEndLine | This is TokenEndLine, a member of class TTokenList.
TokenEndPos | This is TokenEndPos, a member of class TTokenList.
TokenStartLine | This is TokenStartLine, a member of class TTokenList.
TokenStartPos | This is TokenStartPos, a member of class TTokenList.
TokenType | This is TokenType, a member of class TTokenList.
Links
TTokenList Class, Legend, Public Methods, Public Properties


TTokenList.Destroy Destructor

TTokenList.Destroy Destructor
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TTokenList.

Class

TTokenList Class

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Class


TTokenList Methods

TTokenList Methods
TTokenList Class Legend Public Methods Send Feedback

The methods of the TTokenList class are listed here.

Class

TTokenList Class

Public Methods
Name | Description
AddToken | TTokenList
TokenAsInt | This is TokenAsInt, a member of class TTokenList.
TokenAsInt64 | This is TokenAsInt64, a member of class TTokenList.
TokenIndexFromLineAndPos | This is TokenIndexFromLineAndPos, a member of class TTokenList.
TokenPtr | This is TokenPtr, a member of class TTokenList.
TokenStr | This is TokenStr, a member of class TTokenList.
Links
TTokenList Class, Legend, Public Methods


TTokenList.AddToken Method

TTokenList.AddToken Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
procedure AddToken(aBufferStart: PChar; aBufferEnd: PChar; aStartLine: Integer; aEndLine: Integer; aStartPos: Integer; aEndPos: Integer; aTokenType: Integer);
Description

TTokenList

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList.TokenAsInt Method

TTokenList.TokenAsInt Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenAsInt(T: Integer): Integer;
Description

This is TokenAsInt, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList.TokenAsInt64 Method

TTokenList.TokenAsInt64 Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenAsInt64(T: Integer): Int64;
Description

This is TokenAsInt64, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList.TokenIndexFromLineAndPos Method

TTokenList.TokenIndexFromLineAndPos Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenIndexFromLineAndPos(Line: Integer; Pos: Integer): Integer;
Description

This is TokenIndexFromLineAndPos, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList.TokenPtr Method

TTokenList.TokenPtr Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenPtr(T: Integer): PTokenRecord;
Description

This is TokenPtr, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList.TokenStr Method

TTokenList.TokenStr Method
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenStr(T: Integer): string;
Description

This is TokenStr, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Methods


TTokenList Properties

TTokenList Properties
TTokenList Class Legend Public Properties Send Feedback

The properties of the TTokenList class are listed here.

Class

TTokenList Class

Public Properties
Name | Description
TokenBufferEnd | This is TokenBufferEnd, a member of class TTokenList.
TokenBufferStart | This is TokenBufferStart, a member of class TTokenList.
TokenCount | This is TokenCount, a member of class TTokenList.
TokenEndLine | This is TokenEndLine, a member of class TTokenList.
TokenEndPos | This is TokenEndPos, a member of class TTokenList.
TokenStartLine | This is TokenStartLine, a member of class TTokenList.
TokenStartPos | This is TokenStartPos, a member of class TTokenList.
TokenType | This is TokenType, a member of class TTokenList.
Links
TTokenList Class, Legend, Public Properties


TTokenList.TokenBufferEnd Property

TTokenList.TokenBufferEnd Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenBufferEnd [Index: Integer]: PChar;
Description

This is TokenBufferEnd, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenBufferStart Property

TTokenList.TokenBufferStart Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenBufferStart [Index: Integer]: PChar;
Description

This is TokenBufferStart, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenCount Property

TTokenList.TokenCount Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenCount: Integer;
Description

This is TokenCount, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenEndLine Property

TTokenList.TokenEndLine Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenEndLine [Index: Integer]: Integer;
Description

This is TokenEndLine, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenEndPos Property

TTokenList.TokenEndPos Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenEndPos [Index: Integer]: Integer;
Description

This is TokenEndPos, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenStartLine Property

TTokenList.TokenStartLine Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenStartLine [Index: Integer]: Integer;
Description

This is TokenStartLine, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenStartPos Property

TTokenList.TokenStartPos Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenStartPos [Index: Integer]: Integer;
Description

This is TokenStartPos, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenList.TokenType Property

TTokenList.TokenType Property
TTokenList Class TTokenList Members CocoaBase Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenType [Index: Integer]: Integer;
Description

This is TokenType, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBase Namespace, TTokenList Properties


TTokenPage Class

TTokenPage Class
TTokenPage Fields TTokenPage Members CocoaBase Classes Send Feedback
Class Hierarchy
CocoaBase_TTokenPage
Syntax
Delphi
TTokenPage = class;
File

CocoaBase

Description

This is class CocoaBase.TTokenPage.

Group

Classes

Links
TTokenPage Fields, TTokenPage Members, CocoaBase, Classes


TTokenPage Members

TTokenPage Members
TTokenPage Class Legend Public Fields Send Feedback

The following tables list the members exposed by TTokenPage.

Class

TTokenPage Class

Public Fields
Name | Description
Filler | This is Filler, a member of class TTokenPage.
Next | This is Next, a member of class TTokenPage.
TokenCount | This is TokenCount, a member of class TTokenPage.
Tokens | This is Tokens, a member of class TTokenPage.
Links
TTokenPage Class, Legend, Public Fields


TTokenPage Fields

TTokenPage Fields
TTokenPage Class Legend Public Fields Send Feedback

The fields of the TTokenPage class are listed here.

Class

TTokenPage Class

Public Fields
Name | Description
Filler | This is Filler, a member of class TTokenPage.
Next | This is Next, a member of class TTokenPage.
TokenCount | This is TokenCount, a member of class TTokenPage.
Tokens | This is Tokens, a member of class TTokenPage.
Links
TTokenPage Class, Legend, Public Fields


TTokenPage.Filler Field

TTokenPage.Filler Field
TTokenPage Class TTokenPage Members CocoaBase Namespace TTokenPage Fields Send Feedback
Syntax
Delphi
Filler: array[0..23] of byte;
Description

This is Filler, a member of class TTokenPage.

Group

TTokenPage Fields

Links
TTokenPage Class, TTokenPage Members, CocoaBase Namespace, TTokenPage Fields


TTokenPage.Next Field

TTokenPage.Next Field
TTokenPage Class TTokenPage Members CocoaBase Namespace TTokenPage Fields Send Feedback
Syntax
Delphi
Next: TTokenPage;
Description

This is Next, a member of class TTokenPage.

Group

TTokenPage Fields

Links
TTokenPage Class, TTokenPage Members, CocoaBase Namespace, TTokenPage Fields


TTokenPage.TokenCount Field

TTokenPage.TokenCount Field
TTokenPage Class TTokenPage Members CocoaBase Namespace TTokenPage Fields Send Feedback
Syntax
Delphi
TokenCount: Integer;
Description

This is TokenCount, a member of class TTokenPage.

Group

TTokenPage Fields

Links
TTokenPage Class, TTokenPage Members, CocoaBase Namespace, TTokenPage Fields


TTokenPage.Tokens Field

TTokenPage.Tokens Field
TTokenPage Class TTokenPage Members CocoaBase Namespace TTokenPage Fields Send Feedback
Syntax
Delphi
Tokens: array[0..TokensPerPage - 1] of TTokenRecord;
Description

This is Tokens, a member of class TTokenPage.

Group

TTokenPage Fields

Links
TTokenPage Class, TTokenPage Members, CocoaBase Namespace, TTokenPage Fields


Functions

Functions
Functions CocoaBase Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
TokensIdentical | This is function CocoaBase.TokensIdentical.
TokenToInt | This is function CocoaBase.TokenToInt.
TokenToLocationStr | This is function CocoaBase.TokenToLocationStr.
TokenToStr | This is function CocoaBase.TokenToStr.
TokenToStrStripQ | This is function CocoaBase.TokenToStrStripQ.
Namespace

CocoaBase Namespace

Links
Functions, CocoaBase Namespace, Legend


CocoaBase.TokensIdentical Function

CocoaBase.TokensIdentical Function
CocoaBase Functions Send Feedback
Syntax
Delphi
function TokensIdentical(T1: PTokenRecord; T2: PTokenRecord): Boolean;
File

CocoaBase

Description

This is function CocoaBase.TokensIdentical.

Group

Functions

Links
CocoaBase, Functions


CocoaBase.TokenToInt Function

CocoaBase.TokenToInt Function
CocoaBase Functions Send Feedback
Syntax
Delphi
function TokenToInt(T: PTokenRecord): Integer;
File

CocoaBase

Description

This is function CocoaBase.TokenToInt.

Group

Functions

Links
CocoaBase, Functions


CocoaBase.TokenToLocationStr Function

CocoaBase.TokenToLocationStr Function
CocoaBase Functions Send Feedback
Syntax
Delphi
function TokenToLocationStr(T: PTokenRecord): string;
File

CocoaBase

Description

This is function CocoaBase.TokenToLocationStr.

Group

Functions

Links
CocoaBase, Functions


CocoaBase.TokenToStr Function

CocoaBase.TokenToStr Function
CocoaBase Functions Send Feedback
Syntax
Delphi
function TokenToStr(T: PTokenRecord): string;
File

CocoaBase

Description

This is function CocoaBase.TokenToStr.

Group

Functions

Links
CocoaBase, Functions


CocoaBase.TokenToStrStripQ Function

CocoaBase.TokenToStrStripQ Function
CocoaBase Functions Send Feedback
Syntax
Delphi
function TokenToStrStripQ(T: PTokenRecord): string;
File

CocoaBase

Description

This is function CocoaBase.TokenToStrStripQ.

Group

Functions

Links
CocoaBase, Functions


Structs, Records, Enums

Structs, Records, Enums
CocoaBase Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

CocoaBase Namespace

Records
Name | Description
TParseStackRec | This is record CocoaBase.TParseStackRec.
TScopeStackRec | This is record CocoaBase.TScopeStackRec.
TSyntaxNode | This is record CocoaBase.TSyntaxNode.
TTernaryNode | This is record CocoaBase.TTernaryNode.
TTokenRecord | This is record CocoaBase.TTokenRecord.
Links
CocoaBase Namespace, Legend, Records


CocoaBase.TParseStackRec Record

CocoaBase.TParseStackRec Record
CocoaBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TParseStackRec = record
  sCodePtr: Integer;
  sTokenPtr: Integer;
end;
File

CocoaBase

Description

This is record CocoaBase.TParseStackRec.

Group

Structs, Records, Enums

Links
CocoaBase, Structs, Records, Enums


CocoaBase.TScopeStackRec Record

CocoaBase.TScopeStackRec Record
CocoaBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TScopeStackRec = record
  sScopeID: Integer;
  sTokenPtr: Integer;
end;
File

CocoaBase

Description

This is record CocoaBase.TScopeStackRec.

Group

Structs, Records, Enums

Links
CocoaBase, Structs, Records, Enums


CocoaBase.TSyntaxNode Record

CocoaBase.TSyntaxNode Record
CocoaBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TSyntaxNode = record
  Follow: Integer;
  Alternative: Integer;
  IsTerminal: Boolean;
  Symbol: Integer;
end;
File

CocoaBase

Members
Members | Description
Follow: Integer; | points to next TSyntaxNode entry for sequences of elements
Alternative: Integer; | points to next alternative in choice lists
Symbol: Integer; | if IsTerminal, denotes the terminal symbol if not IsTerminal, denotes the non-terminal represented by this node
Description

This is record CocoaBase.TSyntaxNode.

Group

Structs, Records, Enums

Links
CocoaBase, Structs, Records, Enums


CocoaBase.TTernaryNode Record

CocoaBase.TTernaryNode Record
CocoaBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TTernaryNode = record
  EqKid: PTernaryNode;
  HiKid: PTernaryNode;
  LoKid: PTernaryNode;
  Val: Integer;
  SplitChar: Char;
end;
File

CocoaBase

Description

This is record CocoaBase.TTernaryNode.

Group

Structs, Records, Enums

Links
CocoaBase, Structs, Records, Enums


CocoaBase.TTokenRecord Record

CocoaBase.TTokenRecord Record
CocoaBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TTokenRecord = record
  BufferStart: PChar;
  BufferEnd: PChar;
  EndLine: Integer;
  EndPos: Integer;
  StartLine: Integer;
  StartPos: Integer;
  TokenType: Integer;
end;
File

CocoaBase

Description

This is record CocoaBase.TTokenRecord.

Group

Structs, Records, Enums

Links
CocoaBase, Structs, Records, Enums


Types

Types
CocoaBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

CocoaBase Namespace

Types
Name | Description
PTernaryNode | This is type CocoaBase.PTernaryNode.
PTokenRecord | This is type CocoaBase.PTokenRecord.
Links
CocoaBase Namespace, Types


CocoaBase.PTernaryNode Type

CocoaBase.PTernaryNode Type
CocoaBase Types Send Feedback
Syntax
Delphi
PTernaryNode = ^TTernaryNode;
File

CocoaBase

Description

This is type CocoaBase.PTernaryNode.

Group

Types

Links
CocoaBase, Types


CocoaBase.PTokenRecord Type

CocoaBase.PTokenRecord Type
CocoaBase Types Send Feedback
Syntax
Delphi
PTokenRecord = ^TTokenRecord;
File

CocoaBase

Description

This is type CocoaBase.PTokenRecord.

Group

Types

Links
CocoaBase, Types


Constants

Constants
Constants CocoaBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
MaxEmptyScopeNesting | This is constant CocoaBase.MaxEmptyScopeNesting.
MaxParserStack | these two tweaked to give exactly 4K for a parser instance
MaxSiblings | max number of token alternatives at any given point
MaxTokenizerStack | This is constant CocoaBase.MaxTokenizerStack.
TokensPerPage | gives exactly 4K to the page
Namespace

CocoaBase Namespace

Links
Constants, CocoaBase Namespace


CocoaBase.MaxEmptyScopeNesting Constant

CocoaBase.MaxEmptyScopeNesting Constant
CocoaBase Constants Send Feedback
Syntax
Delphi
MaxEmptyScopeNesting = 1;
File

CocoaBase

Description

This is constant CocoaBase.MaxEmptyScopeNesting.

Group

Constants

Links
CocoaBase, Constants


CocoaBase.MaxParserStack Constant

CocoaBase.MaxParserStack Constant
CocoaBase Constants Send Feedback
Syntax
Delphi
MaxParserStack = 189;
File

CocoaBase

Description

these two tweaked to give exactly 4K for a parser instance

Group

Constants

Links
CocoaBase, Constants


CocoaBase.MaxSiblings Constant

CocoaBase.MaxSiblings Constant
CocoaBase Constants Send Feedback
Syntax
Delphi
MaxSiblings = 257;
File

CocoaBase

Description

max number of token alternatives at any given point

Group

Constants

Links
CocoaBase, Constants


CocoaBase.MaxTokenizerStack Constant

CocoaBase.MaxTokenizerStack Constant
CocoaBase Constants Send Feedback
Syntax
Delphi
MaxTokenizerStack = 4;
File

CocoaBase

Description

This is constant CocoaBase.MaxTokenizerStack.

Group

Constants

Links
CocoaBase, Constants


CocoaBase.TokensPerPage Constant

CocoaBase.TokensPerPage Constant
CocoaBase Constants Send Feedback
Syntax
Delphi
TokensPerPage = 145;
File

CocoaBase

Description

gives exactly 4K to the page

Group

Constants

Links
CocoaBase, Constants


CocoaBaseW Namespace

CocoaBaseW Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace CocoaBaseW.

Classes
Name | Description
TBaseParser | This is class CocoaBaseW.TBaseParser.
TBaseTokenizer | This is class CocoaBaseW.TBaseTokenizer.
TTernaryTree | This is class CocoaBaseW.TTernaryTree.
TTokenList | This is class CocoaBaseW.TTokenList.
Constants
Name | Description
MaxEmptyScopeNesting | This is constant CocoaBaseW.MaxEmptyScopeNesting.
MaxParserStack | these two tweaked to give exactly 4K for a parser instance
MaxSiblings | max number of token alternatives at any given point
MaxTokenizerStack | (
TokensPerPage | calculate array size to keep TTokenPage within 64KB size; eg 64KB - SizeOf(TTokenPage)
Functions
Name | Description
StartLineFromToken | This is function CocoaBaseW.StartLineFromToken.
TokensIdentical | This is function CocoaBaseW.TokensIdentical.
TokenToInt | This is function CocoaBaseW.TokenToInt.
TokenToLocationStr | This is function CocoaBaseW.TokenToLocationStr.
TokenToLocationStrA | This is function CocoaBaseW.TokenToLocationStrA.
TokenToLocationStrW | This is function CocoaBaseW.TokenToLocationStrW.
TokenToStr | This is function CocoaBaseW.TokenToStr.
TokenToStrA | This is function CocoaBaseW.TokenToStrA.
TokenToStrStripQ | This is function CocoaBaseW.TokenToStrStripQ.
TokenToStrStripQA | This is function CocoaBaseW.TokenToStrStripQA.
TokenToStrStripQW | CU := WideChar(UpCase(AnsiChar(C^)));
TokenToStrW | This is function CocoaBaseW.TokenToStrW.
Structs, Records, Enums
Name | Description
TParseStackRec | This is record CocoaBaseW.TParseStackRec.
TScopeStackRec | This is record CocoaBaseW.TScopeStackRec.
TTernaryNode | This is record CocoaBaseW.TTernaryNode.
TTokenPage | This is record CocoaBaseW.TTokenPage.
TTokenRecord | This is record CocoaBaseW.TTokenRecord.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PTernaryNode | This is type CocoaBaseW.PTernaryNode.
PTokenPage | *) const TokensPerPage = 8190; {gives exactly 64K to the page} MaxTokenizerStack = 4; MaxParserStack = 350; //these two tweaked to give exactly 4K for a parser instance MaxSiblings = 312; {max number of token alternatives at any given point} MaxEmptyScopeNesting = 1; type PTokenRecord = ^TTokenRecord; TTokenRecord = packed record BufferStart: PWideChar; TokenType2: Word; Len2: Word; // upper 6 bits of TokenType are actually bits 32 through 37 of length end;
PTokenRecord | This is type CocoaBaseW.PTokenRecord.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes CocoaBaseW Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TBaseParser | This is class CocoaBaseW.TBaseParser.
TBaseTokenizer | This is class CocoaBaseW.TBaseTokenizer.
TTernaryTree | This is class CocoaBaseW.TTernaryTree.
TTokenList | This is class CocoaBaseW.TTokenList.
Namespace

CocoaBaseW Namespace

Links
Classes, CocoaBaseW Namespace, Legend


TBaseParser Class

TBaseParser Class
TBaseParser Fields TBaseParser Methods TBaseParser Properties TBaseParser Members CocoaBaseW Classes Send Feedback
Class Hierarchy
CocoaBaseW_TBaseParser
Syntax
Delphi
TBaseParser = class;
File

CocoaBaseW

Description

This is class CocoaBaseW.TBaseParser.

Group

Classes

Links
TBaseParser Fields, TBaseParser Methods, TBaseParser Properties, TBaseParser Members, CocoaBaseW, Classes


TBaseParser Members

TBaseParser Members
TBaseParser Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TBaseParser.

Class

TBaseParser Class

Protected Fields
Name | Description
ActualToken | This is ActualToken, a member of class TBaseParser.
ActualTokenIndex | This is ActualTokenIndex, a member of class TBaseParser.
CodePtr | This is CodePtr, a member of class TBaseParser.
ExpectedTokenList | This is ExpectedTokenList, a member of class TBaseParser.
FCodes | This is FCodes, a member of class TBaseParser.
FExpectedTokenCount | This is FExpectedTokenCount, a member of class TBaseParser.
FFailedTokenIndex | This is FFailedTokenIndex, a member of class TBaseParser.
FSource | This is FSource, a member of class TBaseParser.
FTokens | This is FTokens, a member of class TBaseParser.
HighTokenPtr | This is HighTokenPtr, a member of class TBaseParser.
SSTP | This is SSTP, a member of class TBaseParser.
Stack | This is Stack, a member of class TBaseParser.
STP | This is STP, a member of class TBaseParser.
TokenPtr | This is TokenPtr, a member of class TBaseParser.
Protected Methods
Name | Description
AddCode | TBaseParser
Advance | This is Advance, a member of class TBaseParser.
Compile | This is Compile, a member of class TBaseParser.
Drop | This is Drop, a member of class TBaseParser.
Ensure | This is Ensure, a member of class TBaseParser.
Error | This is Error, a member of class TBaseParser.
GetCode | This is GetCode, a member of class TBaseParser.
GetExpectedToken | This is GetExpectedToken, a member of class TBaseParser.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseParser.
LexInt | This is LexInt, a member of class TBaseParser.
LexInt64 | This is LexInt64, a member of class TBaseParser.
LexString | This is LexString, a member of class TBaseParser.
Match | This is Match, a member of class TBaseParser.
MatchInterval | This is MatchInterval, a member of class TBaseParser.
Parse | This is Parse, a member of class TBaseParser.
Pop | This is Pop, a member of class TBaseParser.
PopAddCode | This is PopAddCode, a member of class TBaseParser.
PopAddCode_0 | This is PopAddCode_0, a member of class TBaseParser.
PopPush | This is PopPush, a member of class TBaseParser.
PopPushAddCode | This is PopPushAddCode, a member of class TBaseParser.
Push | This is Push, a member of class TBaseParser.
PushAddCode | This is PushAddCode, a member of class TBaseParser.
PushAddCode_0 | This is PushAddCode_0, a member of class TBaseParser.
PushAddCode_1 | This is PushAddCode_1, a member of class TBaseParser.
PushAddCode_2 | This is PushAddCode_2, a member of class TBaseParser.
StoreExpectedToken | This is StoreExpectedToken, a member of class TBaseParser.
TokenStr | This is TokenStr, a member of class TBaseParser.
Public Methods
Name | Description
CurToken | This is CurToken, a member of class TBaseParser.
CurTokenPtr | This is CurTokenPtr, a member of class TBaseParser.
Destroy | This is Destroy, a member of class TBaseParser.
DumpCodes | This is DumpCodes, a member of class TBaseParser.
ExpectedTokensString | This is the overview for the ExpectedTokensString method overload.
SourceExtract | This is SourceExtract, a member of class TBaseParser.
Public Properties
Name | Description
ExpectedToken | This is ExpectedToken, a member of class TBaseParser.
ExpectedTokenCount | This is ExpectedTokenCount, a member of class TBaseParser.
FailedTokenIndex | This is FailedTokenIndex, a member of class TBaseParser.
Source | This is Source, a member of class TBaseParser.
TokenList | This is TokenList, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TBaseParser.Destroy Destructor

TBaseParser.Destroy Destructor
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TBaseParser.

Class

TBaseParser Class

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Class


TBaseParser Fields

TBaseParser Fields
TBaseParser Class Legend Protected Fields Send Feedback

The fields of the TBaseParser class are listed here.

Class

TBaseParser Class

Protected Fields
Name | Description
ActualToken | This is ActualToken, a member of class TBaseParser.
ActualTokenIndex | This is ActualTokenIndex, a member of class TBaseParser.
CodePtr | This is CodePtr, a member of class TBaseParser.
ExpectedTokenList | This is ExpectedTokenList, a member of class TBaseParser.
FCodes | This is FCodes, a member of class TBaseParser.
FExpectedTokenCount | This is FExpectedTokenCount, a member of class TBaseParser.
FFailedTokenIndex | This is FFailedTokenIndex, a member of class TBaseParser.
FSource | This is FSource, a member of class TBaseParser.
FTokens | This is FTokens, a member of class TBaseParser.
HighTokenPtr | This is HighTokenPtr, a member of class TBaseParser.
SSTP | This is SSTP, a member of class TBaseParser.
Stack | This is Stack, a member of class TBaseParser.
STP | This is STP, a member of class TBaseParser.
TokenPtr | This is TokenPtr, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Fields


TBaseParser.ActualToken Field

TBaseParser.ActualToken Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
ActualToken: Integer;
Description

This is ActualToken, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.ActualTokenIndex Field

TBaseParser.ActualTokenIndex Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
ActualTokenIndex: Integer;
Description

This is ActualTokenIndex, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.CodePtr Field

TBaseParser.CodePtr Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
CodePtr: Integer;
Description

This is CodePtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.ExpectedTokenList Field

TBaseParser.ExpectedTokenList Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
ExpectedTokenList: array[0..MaxSiblings-1] of Integer;
Description

This is ExpectedTokenList, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.FCodes Field

TBaseParser.FCodes Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FCodes: TList;
Description

This is FCodes, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.FExpectedTokenCount Field

TBaseParser.FExpectedTokenCount Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FExpectedTokenCount: Integer;
Description

This is FExpectedTokenCount, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.FFailedTokenIndex Field

TBaseParser.FFailedTokenIndex Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FFailedTokenIndex: Integer;
Description

This is FFailedTokenIndex, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.FSource Field

TBaseParser.FSource Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FSource: UnicodeString;
Description

This is FSource, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.FTokens Field

TBaseParser.FTokens Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
FTokens: TTokenList;
Description

This is FTokens, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.HighTokenPtr Field

TBaseParser.HighTokenPtr Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
HighTokenPtr: Integer;
Description

This is HighTokenPtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.SSTP Field

TBaseParser.SSTP Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
SSTP: Integer;
Description

This is SSTP, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.Stack Field

TBaseParser.Stack Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
Stack: array[0..MaxParserStack - 1] of TParseStackRec;
Description

This is Stack, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.STP Field

TBaseParser.STP Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
STP: Integer;
Description

This is STP, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser.TokenPtr Field

TBaseParser.TokenPtr Field
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Fields Send Feedback
Syntax
Delphi
TokenPtr: Integer;
Description

This is TokenPtr, a member of class TBaseParser.

Group

TBaseParser Fields

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Fields


TBaseParser Methods

TBaseParser Methods
TBaseParser Class Legend Protected Methods Public Methods Send Feedback

The methods of the TBaseParser class are listed here.

Class

TBaseParser Class

Protected Methods
Name | Description
AddCode | TBaseParser
Advance | This is Advance, a member of class TBaseParser.
Compile | This is Compile, a member of class TBaseParser.
Drop | This is Drop, a member of class TBaseParser.
Ensure | This is Ensure, a member of class TBaseParser.
Error | This is Error, a member of class TBaseParser.
GetCode | This is GetCode, a member of class TBaseParser.
GetExpectedToken | This is GetExpectedToken, a member of class TBaseParser.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseParser.
LexInt | This is LexInt, a member of class TBaseParser.
LexInt64 | This is LexInt64, a member of class TBaseParser.
LexString | This is LexString, a member of class TBaseParser.
Match | This is Match, a member of class TBaseParser.
MatchInterval | This is MatchInterval, a member of class TBaseParser.
Parse | This is Parse, a member of class TBaseParser.
Pop | This is Pop, a member of class TBaseParser.
PopAddCode | This is PopAddCode, a member of class TBaseParser.
PopAddCode_0 | This is PopAddCode_0, a member of class TBaseParser.
PopPush | This is PopPush, a member of class TBaseParser.
PopPushAddCode | This is PopPushAddCode, a member of class TBaseParser.
Push | This is Push, a member of class TBaseParser.
PushAddCode | This is PushAddCode, a member of class TBaseParser.
PushAddCode_0 | This is PushAddCode_0, a member of class TBaseParser.
PushAddCode_1 | This is PushAddCode_1, a member of class TBaseParser.
PushAddCode_2 | This is PushAddCode_2, a member of class TBaseParser.
StoreExpectedToken | This is StoreExpectedToken, a member of class TBaseParser.
TokenStr | This is TokenStr, a member of class TBaseParser.
Public Methods
Name | Description
CurToken | This is CurToken, a member of class TBaseParser.
CurTokenPtr | This is CurTokenPtr, a member of class TBaseParser.
DumpCodes | This is DumpCodes, a member of class TBaseParser.
ExpectedTokensString | This is the overview for the ExpectedTokensString method overload.
SourceExtract | This is SourceExtract, a member of class TBaseParser.
Links
TBaseParser Class, Legend, Protected Methods, Public Methods


TBaseParser.AddCode Method

TBaseParser.AddCode Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function AddCode(C: Integer): Boolean;
Description

TBaseParser

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Advance Method

TBaseParser.Advance Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Advance;
Description

This is Advance, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Compile Method

TBaseParser.Compile Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Compile; virtual; abstract;
Description

This is Compile, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.CurToken Method

TBaseParser.CurToken Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function CurToken: Integer;
Description

This is CurToken, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.CurTokenPtr Method

TBaseParser.CurTokenPtr Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function CurTokenPtr: PTokenRecord;
Description

This is CurTokenPtr, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Drop Method

TBaseParser.Drop Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Drop;
Description

This is Drop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.DumpCodes Method

TBaseParser.DumpCodes Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure DumpCodes;
Description

This is DumpCodes, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Ensure Method

TBaseParser.Ensure Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Ensure(Token: Integer);
Description

This is Ensure, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Error Method

TBaseParser.Error Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Error(const Msg: UnicodeString);
Description

This is Error, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


ExpectedTokensString Method

ExpectedTokensString Method
TBaseParser Methods Send Feedback

This is the overview for the ExpectedTokensString method overload.

Overload List
Name | Description
TBaseParser.ExpectedTokensString () | This is ExpectedTokensString, a member of class TBaseParser.
TBaseParser.ExpectedTokensString (UnicodeString, Integer) | This is ExpectedTokensString, a member of class TBaseParser.
Group

TBaseParser Methods

Links
TBaseParser Methods


TBaseParser.ExpectedTokensString Method ()

TBaseParser.ExpectedTokensString Method ()
TBaseParser Class TBaseParser Members CocoaBaseW Namespace ExpectedTokensString Method Send Feedback
Syntax
Delphi
function ExpectedTokensString: UnicodeString; overload;
Description

This is ExpectedTokensString, a member of class TBaseParser.

Group

ExpectedTokensString Method

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, ExpectedTokensString Method


TBaseParser.ExpectedTokensString Method (UnicodeString, Integer)

TBaseParser.ExpectedTokensString Method (UnicodeString, Integer)
TBaseParser Class TBaseParser Members CocoaBaseW Namespace ExpectedTokensString Method Send Feedback
Syntax
Delphi
function ExpectedTokensString(var FoundToken: UnicodeString; var FoundTokenIndex: Integer): UnicodeString; overload;
Description

This is ExpectedTokensString, a member of class TBaseParser.

Group

ExpectedTokensString Method

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, ExpectedTokensString Method


TBaseParser.GetCode Method

TBaseParser.GetCode Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function GetCode: Integer;
Description

This is GetCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.GetExpectedToken Method

TBaseParser.GetExpectedToken Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function GetExpectedToken(Index: Integer): Integer;
Description

This is GetExpectedToken, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.IfDropElsePop Method

TBaseParser.IfDropElsePop Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure IfDropElsePop(B: Boolean);
Description

This is IfDropElsePop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.LexInt Method

TBaseParser.LexInt Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexInt: Integer;
Description

This is LexInt, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.LexInt64 Method

TBaseParser.LexInt64 Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexInt64: int64;
Description

This is LexInt64, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.LexString Method

TBaseParser.LexString Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function LexString: UnicodeString;
Description

This is LexString, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Match Method

TBaseParser.Match Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function Match(Token: Integer): Boolean;
Description

This is Match, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.MatchInterval Method

TBaseParser.MatchInterval Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function MatchInterval(Token1: Integer; Token2: Integer): Boolean;
Description

This is MatchInterval, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Parse Method

TBaseParser.Parse Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function Parse: Boolean; virtual; abstract;
Description

This is Parse, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Pop Method

TBaseParser.Pop Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Pop;
Description

This is Pop, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PopAddCode Method

TBaseParser.PopAddCode Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopAddCode(C: Integer);
Description

This is PopAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PopAddCode_0 Method

TBaseParser.PopAddCode_0 Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopAddCode_0;
Description

This is PopAddCode_0, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PopPush Method

TBaseParser.PopPush Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopPush;
Description

This is PopPush, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PopPushAddCode Method

TBaseParser.PopPushAddCode Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PopPushAddCode(C: Integer);
Description

This is PopPushAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.Push Method

TBaseParser.Push Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure Push;
Description

This is Push, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PushAddCode Method

TBaseParser.PushAddCode Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode(C: Integer);
Description

This is PushAddCode, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PushAddCode_0 Method

TBaseParser.PushAddCode_0 Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_0;
Description

This is PushAddCode_0, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PushAddCode_1 Method

TBaseParser.PushAddCode_1 Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_1;
Description

This is PushAddCode_1, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.PushAddCode_2 Method

TBaseParser.PushAddCode_2 Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure PushAddCode_2;
Description

This is PushAddCode_2, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.SourceExtract Method

TBaseParser.SourceExtract Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function SourceExtract(FirstToken: Integer; LastToken: Integer): UnicodeString;
Description

This is SourceExtract, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.StoreExpectedToken Method

TBaseParser.StoreExpectedToken Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
procedure StoreExpectedToken(ExpectedToken: Integer; aActualToken: Integer);
Description

This is StoreExpectedToken, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.TokenStr Method

TBaseParser.TokenStr Method
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Methods Send Feedback
Syntax
Delphi
function TokenStr(Token: Integer): UnicodeString; virtual; abstract;
Description

This is TokenStr, a member of class TBaseParser.

Group

TBaseParser Methods

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Methods


TBaseParser.ExpectedToken Property

TBaseParser.ExpectedToken Property
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property ExpectedToken [Index: Integer]: Integer;
Description

This is ExpectedToken, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Properties


TBaseParser.ExpectedTokenCount Property

TBaseParser.ExpectedTokenCount Property
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property ExpectedTokenCount: Integer;
Description

This is ExpectedTokenCount, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Properties


TBaseParser.FailedTokenIndex Property

TBaseParser.FailedTokenIndex Property
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property FailedTokenIndex: Integer;
Description

This is FailedTokenIndex, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Properties


TBaseParser.Source Property

TBaseParser.Source Property
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property Source: UnicodeString;
Description

This is Source, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Properties


TBaseParser.TokenList Property

TBaseParser.TokenList Property
TBaseParser Class TBaseParser Members CocoaBaseW Namespace TBaseParser Properties Send Feedback
Syntax
Delphi
property TokenList: TTokenList;
Description

This is TokenList, a member of class TBaseParser.

Group

TBaseParser Properties

Links
TBaseParser Class, TBaseParser Members, CocoaBaseW Namespace, TBaseParser Properties


TBaseTokenizer Class

TBaseTokenizer Class
TBaseTokenizer Fields TBaseTokenizer Methods TBaseTokenizer Members CocoaBaseW Classes Send Feedback
Class Hierarchy
CocoaBaseW_TBaseTokenizer
Syntax
Delphi
TBaseTokenizer = class;
File

CocoaBaseW

Description

This is class CocoaBaseW.TBaseTokenizer.

Group

Classes

Links
TBaseTokenizer Fields, TBaseTokenizer Methods, TBaseTokenizer Members, CocoaBaseW, Classes


TBaseTokenizer Members

TBaseTokenizer Members
TBaseTokenizer Class Legend Protected Fields Protected Methods Send Feedback

The following tables list the members exposed by TBaseTokenizer.

Class

TBaseTokenizer Class

Protected Fields
Name | Description
CurLine | This is CurLine, a member of class TBaseTokenizer.
CurPos | This is CurPos, a member of class TBaseTokenizer.
CurPtr | This is CurPtr, a member of class TBaseTokenizer.
EndPtr | This is EndPtr, a member of class TBaseTokenizer.
LineStack | This is LineStack, a member of class TBaseTokenizer.
PosStack | This is PosStack, a member of class TBaseTokenizer.
PtrStack | This is PtrStack, a member of class TBaseTokenizer.
StartLine | This is StartLine, a member of class TBaseTokenizer.
StartPos | This is StartPos, a member of class TBaseTokenizer.
StartPtr | This is StartPtr, a member of class TBaseTokenizer.
STP | This is STP, a member of class TBaseTokenizer.
Protected Methods
Name | Description
Advance | This is the overview for the Advance method overload.
Drop | This is Drop, a member of class TBaseTokenizer.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseTokenizer.
NextChar | This is NextChar, a member of class TBaseTokenizer.
Peek | This is the overview for the Peek method overload.
PeekIs | This is PeekIs, a member of class TBaseTokenizer.
PeekIsNot | This is PeekIsNot, a member of class TBaseTokenizer.
Pop | This is Pop, a member of class TBaseTokenizer.
Push | This is Push, a member of class TBaseTokenizer.
Tokenize | This is Tokenize, a member of class TBaseTokenizer.
Links
TBaseTokenizer Class, Legend, Protected Fields, Protected Methods


TBaseTokenizer.CurLine Field

TBaseTokenizer.CurLine Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurLine: Integer;
Description

This is CurLine, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.CurPos Field

TBaseTokenizer.CurPos Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurPos: Integer;
Description

This is CurPos, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.CurPtr Field

TBaseTokenizer.CurPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
CurPtr: PWideChar;
Description

This is CurPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.EndPtr Field

TBaseTokenizer.EndPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
EndPtr: PWideChar;
Description

This is EndPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.LineStack Field

TBaseTokenizer.LineStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
LineStack: array[0..MaxTokenizerStack] of Integer;
Description

This is LineStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.PosStack Field

TBaseTokenizer.PosStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
PosStack: array[0..MaxTokenizerStack] of Integer;
Description

This is PosStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.PtrStack Field

TBaseTokenizer.PtrStack Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
PtrStack: array[0..MaxTokenizerStack] of PWideChar;
Description

This is PtrStack, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartLine Field

TBaseTokenizer.StartLine Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartLine: Integer;
Description

This is StartLine, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartPos Field

TBaseTokenizer.StartPos Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartPos: Integer;
Description

This is StartPos, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.StartPtr Field

TBaseTokenizer.StartPtr Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
StartPtr: PWideChar;
Description

This is StartPtr, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer.STP Field

TBaseTokenizer.STP Field
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Fields Send Feedback
Syntax
Delphi
STP: Integer;
Description

This is STP, a member of class TBaseTokenizer.

Group

TBaseTokenizer Fields

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Fields


TBaseTokenizer Methods

TBaseTokenizer Methods
TBaseTokenizer Class Legend Protected Methods Send Feedback

The methods of the TBaseTokenizer class are listed here.

Class

TBaseTokenizer Class

Protected Methods
Name | Description
Advance | This is the overview for the Advance method overload.
Drop | This is Drop, a member of class TBaseTokenizer.
IfDropElsePop | This is IfDropElsePop, a member of class TBaseTokenizer.
NextChar | This is NextChar, a member of class TBaseTokenizer.
Peek | This is the overview for the Peek method overload.
PeekIs | This is PeekIs, a member of class TBaseTokenizer.
PeekIsNot | This is PeekIsNot, a member of class TBaseTokenizer.
Pop | This is Pop, a member of class TBaseTokenizer.
Push | This is Push, a member of class TBaseTokenizer.
Tokenize | This is Tokenize, a member of class TBaseTokenizer.
Links
TBaseTokenizer Class, Legend, Protected Methods


Advance Method

Advance Method
TBaseTokenizer Methods Send Feedback

This is the overview for the Advance method overload.

Overload List
Name | Description
TBaseTokenizer.Advance () | This is Advance, a member of class TBaseTokenizer.
TBaseTokenizer.Advance (TnxNativeUInt) | TBaseTokenizer
Group

TBaseTokenizer Methods

Links
TBaseTokenizer Methods


TBaseTokenizer.Advance Method ()

TBaseTokenizer.Advance Method ()
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace Advance Method Send Feedback
Syntax
Delphi
procedure Advance; overload;
Description

This is Advance, a member of class TBaseTokenizer.

Group

Advance Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, Advance Method


TBaseTokenizer.Advance Method (TnxNativeUInt)

TBaseTokenizer.Advance Method (TnxNativeUInt)
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace Advance Method Send Feedback
Syntax
Delphi
procedure Advance(Offset: TnxNativeUInt); overload;
Description

TBaseTokenizer

Group

Advance Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, Advance Method


TBaseTokenizer.Drop Method

TBaseTokenizer.Drop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Drop;
Description

This is Drop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.IfDropElsePop Method

TBaseTokenizer.IfDropElsePop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure IfDropElsePop(B: Boolean);
Description

This is IfDropElsePop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.NextChar Method

TBaseTokenizer.NextChar Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function NextChar: WideChar;
Description

This is NextChar, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


Peek Method

Peek Method
TBaseTokenizer Methods Send Feedback

This is the overview for the Peek method overload.

Overload List
Name | Description
TBaseTokenizer.Peek () | This is Peek, a member of class TBaseTokenizer.
TBaseTokenizer.Peek (TnxNativeUInt) | This is Peek, a member of class TBaseTokenizer.
Group

TBaseTokenizer Methods

Links
TBaseTokenizer Methods


TBaseTokenizer.Peek Method ()

TBaseTokenizer.Peek Method ()
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace Peek Method Send Feedback
Syntax
Delphi
function Peek: WideChar; overload;
Description

This is Peek, a member of class TBaseTokenizer.

Group

Peek Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, Peek Method


TBaseTokenizer.Peek Method (TnxNativeUInt)

TBaseTokenizer.Peek Method (TnxNativeUInt)
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace Peek Method Send Feedback
Syntax
Delphi
function Peek(Offset: TnxNativeUInt): WideChar; overload;
Description

This is Peek, a member of class TBaseTokenizer.

Group

Peek Method

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, Peek Method


TBaseTokenizer.PeekIs Method

TBaseTokenizer.PeekIs Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function PeekIs(C: WideChar): Boolean;
Description

This is PeekIs, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.PeekIsNot Method

TBaseTokenizer.PeekIsNot Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function PeekIsNot(C: WideChar): Boolean;
Description

This is PeekIsNot, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.Pop Method

TBaseTokenizer.Pop Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Pop;
Description

This is Pop, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.Push Method

TBaseTokenizer.Push Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
procedure Push;
Description

This is Push, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TBaseTokenizer.Tokenize Method

TBaseTokenizer.Tokenize Method
TBaseTokenizer Class TBaseTokenizer Members CocoaBaseW Namespace TBaseTokenizer Methods Send Feedback
Syntax
Delphi
function Tokenize(BufferPtr: PWideChar; BufferLength: Integer; IncludeComments: Boolean; IncludeWhitespace: Boolean; var Tokens: TTokenList): Boolean; virtual; abstract;
Description

This is Tokenize, a member of class TBaseTokenizer.

Group

TBaseTokenizer Methods

Links
TBaseTokenizer Class, TBaseTokenizer Members, CocoaBaseW Namespace, TBaseTokenizer Methods


TTernaryTree Class

TTernaryTree Class
TTernaryTree Methods TTernaryTree Members CocoaBaseW Classes Send Feedback
Class Hierarchy
CocoaBaseW_TTernaryTree
Syntax
Delphi
TTernaryTree = class;
File

CocoaBaseW

Description

This is class CocoaBaseW.TTernaryTree.

Group

Classes

Links
TTernaryTree Methods, TTernaryTree Members, CocoaBaseW, Classes


TTernaryTree.Destroy Destructor

TTernaryTree.Destroy Destructor
TTernaryTree Class TTernaryTree Members CocoaBaseW Namespace TTernaryTree Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TTernaryTree.

Class

TTernaryTree Class

Links
TTernaryTree Class, TTernaryTree Members, CocoaBaseW Namespace, TTernaryTree Class


TTernaryTree.InsertStr Method

TTernaryTree.InsertStr Method
TTernaryTree Class TTernaryTree Members CocoaBaseW Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
procedure InsertStr(C: PWideChar; Val: Integer);
Description

This is InsertStr, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBaseW Namespace, TTernaryTree Methods


TTernaryTree.Search Method

TTernaryTree.Search Method
TTernaryTree Class TTernaryTree Members CocoaBaseW Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
function Search(C: PWideChar): Integer;
Description

This is Search, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBaseW Namespace, TTernaryTree Methods


TTernaryTree.SearchUC Method

TTernaryTree.SearchUC Method
TTernaryTree Class TTernaryTree Members CocoaBaseW Namespace TTernaryTree Methods Send Feedback
Syntax
Delphi
function SearchUC(C: PWideChar): Integer;
Description

This is SearchUC, a member of class TTernaryTree.

Group

TTernaryTree Methods

Links
TTernaryTree Class, TTernaryTree Members, CocoaBaseW Namespace, TTernaryTree Methods


TTokenList Class

TTokenList Class
TTokenList Methods TTokenList Properties TTokenList Members CocoaBaseW Classes Send Feedback
Class Hierarchy
CocoaBaseW_TTokenList
Syntax
Delphi
TTokenList = class;
File

CocoaBaseW

Description

This is class CocoaBaseW.TTokenList.

Group

Classes

Links
TTokenList Methods, TTokenList Properties, TTokenList Members, CocoaBaseW, Classes


TTokenList Members

TTokenList Members
TTokenList Class Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by TTokenList.

Class

TTokenList Class

Public Methods
Name | Description
AddToken | TTokenList
Destroy | This is Destroy, a member of class TTokenList.
TokenAsInt | This is TokenAsInt, a member of class TTokenList.
TokenAsInt64 | This is TokenAsInt64, a member of class TTokenList.
TokenIndexFromLineAndPos | This is TokenIndexFromLineAndPos, a member of class TTokenList.
TokenPtr | This is TokenPtr, a member of class TTokenList.
TokenStr | This is the overview for the TokenStr method overload.
Public Properties
Name | Description
TokenBufferEnd | This is TokenBufferEnd, a member of class TTokenList.
TokenBufferStart | This is TokenBufferStart, a member of class TTokenList.
TokenCount | This is TokenCount, a member of class TTokenList.
TokenEndLine | This is TokenEndLine, a member of class TTokenList.
TokenEndPos | This is TokenEndPos, a member of class TTokenList.
TokenStartLine | This is TokenStartLine, a member of class TTokenList.
TokenStartPos | This is TokenStartPos, a member of class TTokenList.
TokenType | This is TokenType, a member of class TTokenList.
Links
TTokenList Class, Legend, Public Methods, Public Properties


TTokenList.Destroy Destructor

TTokenList.Destroy Destructor
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TTokenList.

Class

TTokenList Class

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Class


TTokenList Methods

TTokenList Methods
TTokenList Class Legend Public Methods Send Feedback

The methods of the TTokenList class are listed here.

Class

TTokenList Class

Public Methods
Name | Description
AddToken | TTokenList
TokenAsInt | This is TokenAsInt, a member of class TTokenList.
TokenAsInt64 | This is TokenAsInt64, a member of class TTokenList.
TokenIndexFromLineAndPos | This is TokenIndexFromLineAndPos, a member of class TTokenList.
TokenPtr | This is TokenPtr, a member of class TTokenList.
TokenStr | This is the overview for the TokenStr method overload.
Links
TTokenList Class, Legend, Public Methods


TTokenList.AddToken Method

TTokenList.AddToken Method
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Methods Send Feedback
Syntax
Delphi
procedure AddToken(aBufferStart: PWideChar; aBufferEnd: PWideChar; aStartLine: Integer; aEndLine: Integer; aStartPos: Integer; aEndPos: Integer; aTokenType: Integer);
Description

TTokenList

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Methods


TTokenList.TokenAsInt Method

TTokenList.TokenAsInt Method
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenAsInt(T: Integer): Integer;
Description

This is TokenAsInt, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Methods


TTokenList.TokenAsInt64 Method

TTokenList.TokenAsInt64 Method
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenAsInt64(T: Integer): Int64;
Description

This is TokenAsInt64, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Methods


TTokenList.TokenIndexFromLineAndPos Method

TTokenList.TokenIndexFromLineAndPos Method
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenIndexFromLineAndPos(Line: Integer; Pos: Integer): Integer;
Description

This is TokenIndexFromLineAndPos, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Methods


TTokenList.TokenPtr Method

TTokenList.TokenPtr Method
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Methods Send Feedback
Syntax
Delphi
function TokenPtr(T: Integer): PTokenRecord;
Description

This is TokenPtr, a member of class TTokenList.

Group

TTokenList Methods

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Methods


TokenStr Method

TokenStr Method
TTokenList Methods Send Feedback

This is the overview for the TokenStr method overload.

Overload List
Name | Description
TTokenList.TokenStr (Integer) | This is TokenStr, a member of class TTokenList.
TTokenList.TokenStr (Integer, Integer) | This is TokenStr, a member of class TTokenList.
Group

TTokenList Methods

Links
TTokenList Methods


TTokenList.TokenStr Method (Integer)

TTokenList.TokenStr Method (Integer)
TTokenList Class TTokenList Members CocoaBaseW Namespace TokenStr Method Send Feedback
Syntax
Delphi
function TokenStr(T: Integer): UnicodeString; overload;
Description

This is TokenStr, a member of class TTokenList.

Group

TokenStr Method

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TokenStr Method


TTokenList.TokenStr Method (Integer, Integer)

TTokenList.TokenStr Method (Integer, Integer)
TTokenList Class TTokenList Members CocoaBaseW Namespace TokenStr Method Send Feedback
Syntax
Delphi
function TokenStr(T1: Integer; T2: Integer): UnicodeString; overload;
Description

This is TokenStr, a member of class TTokenList.

Group

TokenStr Method

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TokenStr Method


TTokenList.TokenBufferEnd Property

TTokenList.TokenBufferEnd Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenBufferEnd [Index: Integer]: PWideChar;
Description

This is TokenBufferEnd, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenBufferStart Property

TTokenList.TokenBufferStart Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenBufferStart [Index: Integer]: PWideChar;
Description

This is TokenBufferStart, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenCount Property

TTokenList.TokenCount Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenCount: Integer;
Description

This is TokenCount, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenEndLine Property

TTokenList.TokenEndLine Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenEndLine [Index: Integer]: Integer;
Description

This is TokenEndLine, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenEndPos Property

TTokenList.TokenEndPos Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenEndPos [Index: Integer]: Integer;
Description

This is TokenEndPos, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenStartLine Property

TTokenList.TokenStartLine Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenStartLine [Index: Integer]: Integer;
Description

This is TokenStartLine, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenStartPos Property

TTokenList.TokenStartPos Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenStartPos [Index: Integer]: Integer;
Description

This is TokenStartPos, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


TTokenList.TokenType Property

TTokenList.TokenType Property
TTokenList Class TTokenList Members CocoaBaseW Namespace TTokenList Properties Send Feedback
Syntax
Delphi
property TokenType [Index: Integer]: Integer;
Description

This is TokenType, a member of class TTokenList.

Group

TTokenList Properties

Links
TTokenList Class, TTokenList Members, CocoaBaseW Namespace, TTokenList Properties


Functions

Functions
Functions CocoaBaseW Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
StartLineFromToken | This is function CocoaBaseW.StartLineFromToken.
TokensIdentical | This is function CocoaBaseW.TokensIdentical.
TokenToInt | This is function CocoaBaseW.TokenToInt.
TokenToLocationStr | This is function CocoaBaseW.TokenToLocationStr.
TokenToLocationStrA | This is function CocoaBaseW.TokenToLocationStrA.
TokenToLocationStrW | This is function CocoaBaseW.TokenToLocationStrW.
TokenToStr | This is function CocoaBaseW.TokenToStr.
TokenToStrA | This is function CocoaBaseW.TokenToStrA.
TokenToStrStripQ | This is function CocoaBaseW.TokenToStrStripQ.
TokenToStrStripQA | This is function CocoaBaseW.TokenToStrStripQA.
TokenToStrStripQW | CU := WideChar(UpCase(AnsiChar(C^)));
TokenToStrW | This is function CocoaBaseW.TokenToStrW.
Namespace

CocoaBaseW Namespace

Links
Functions, CocoaBaseW Namespace, Legend


CocoaBaseW.StartLineFromToken Function

CocoaBaseW.StartLineFromToken Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function StartLineFromToken(Token: PTokenRecord): Integer;
File

CocoaBaseW

Description

This is function CocoaBaseW.StartLineFromToken.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokensIdentical Function

CocoaBaseW.TokensIdentical Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokensIdentical(T1: PTokenRecord; T2: PTokenRecord): Boolean;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokensIdentical.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToInt Function

CocoaBaseW.TokenToInt Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToInt(T: PTokenRecord): Integer;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToInt.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToLocationStr Function

CocoaBaseW.TokenToLocationStr Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToLocationStr(T: PTokenRecord): string;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToLocationStr.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToLocationStrA Function

CocoaBaseW.TokenToLocationStrA Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToLocationStrA(T: PTokenRecord): AnsiString;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToLocationStrA.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToLocationStrW Function

CocoaBaseW.TokenToLocationStrW Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToLocationStrW(T: PTokenRecord): UnicodeString;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToLocationStrW.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStr Function

CocoaBaseW.TokenToStr Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStr(T: PTokenRecord): string;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToStr.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStrA Function

CocoaBaseW.TokenToStrA Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStrA(T: PTokenRecord): AnsiString;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToStrA.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStrStripQ Function

CocoaBaseW.TokenToStrStripQ Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStrStripQ(T: PTokenRecord): string;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToStrStripQ.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStrStripQA Function

CocoaBaseW.TokenToStrStripQA Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStrStripQA(T: PTokenRecord): AnsiString;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToStrStripQA.

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStrStripQW Function

CocoaBaseW.TokenToStrStripQW Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStrStripQW(T: PTokenRecord): UnicodeString;
File

CocoaBaseW

Description

CU := WideChar(UpCase(AnsiChar(C^)));

Group

Functions

Links
CocoaBaseW, Functions


CocoaBaseW.TokenToStrW Function

CocoaBaseW.TokenToStrW Function
CocoaBaseW Functions Send Feedback
Syntax
Delphi
function TokenToStrW(T: PTokenRecord): UnicodeString;
File

CocoaBaseW

Description

This is function CocoaBaseW.TokenToStrW.

Group

Functions

Links
CocoaBaseW, Functions


Structs, Records, Enums

Structs, Records, Enums
CocoaBaseW Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

CocoaBaseW Namespace

Records
Name | Description
TParseStackRec | This is record CocoaBaseW.TParseStackRec.
TScopeStackRec | This is record CocoaBaseW.TScopeStackRec.
TTernaryNode | This is record CocoaBaseW.TTernaryNode.
TTokenPage | This is record CocoaBaseW.TTokenPage.
TTokenRecord | This is record CocoaBaseW.TTokenRecord.
Links
CocoaBaseW Namespace, Legend, Records


CocoaBaseW.TParseStackRec Record

CocoaBaseW.TParseStackRec Record
CocoaBaseW Structs, Records, Enums Send Feedback
Syntax
Delphi
TParseStackRec = record
  sCodePtr: Integer;
  sTokenPtr: Integer;
end;
File

CocoaBaseW

Description

This is record CocoaBaseW.TParseStackRec.

Group

Structs, Records, Enums

Links
CocoaBaseW, Structs, Records, Enums


CocoaBaseW.TScopeStackRec Record

CocoaBaseW.TScopeStackRec Record
CocoaBaseW Structs, Records, Enums Send Feedback
Syntax
Delphi
TScopeStackRec = record
  sScopeID: Integer;
  sTokenPtr: Integer;
end;
File

CocoaBaseW

Description

This is record CocoaBaseW.TScopeStackRec.

Group

Structs, Records, Enums

Links
CocoaBaseW, Structs, Records, Enums


CocoaBaseW.TTernaryNode Record

CocoaBaseW.TTernaryNode Record
CocoaBaseW Structs, Records, Enums Send Feedback
Syntax
Delphi
TTernaryNode = record
  EqKid: PTernaryNode;
  HiKid: PTernaryNode;
  LoKid: PTernaryNode;
  Val: Integer;
  SplitChar: WideChar;
end;
File

CocoaBaseW

Description

This is record CocoaBaseW.TTernaryNode.

Group

Structs, Records, Enums

Links
CocoaBaseW, Structs, Records, Enums


CocoaBaseW.TTokenPage Record

CocoaBaseW.TTokenPage Record
CocoaBaseW Structs, Records, Enums Send Feedback
Syntax
Delphi
TTokenPage = packed record
  Next: PTokenPage;
  TokenCount: Integer;
  StartLineFirst: Integer;
  StartPosFirst: Integer;
  Tokens: array[0..TokensPerPage - 1] of TTokenRecord;
end;
File

CocoaBaseW

Description

This is record CocoaBaseW.TTokenPage.

Group

Structs, Records, Enums

Links
CocoaBaseW, Structs, Records, Enums


CocoaBaseW.TTokenRecord Record

CocoaBaseW.TTokenRecord Record
CocoaBaseW Structs, Records, Enums Send Feedback
Syntax
Delphi
TTokenRecord = packed record
  BufferStart: PWideChar;
  TokenType2: Word;
  Len2: Cardinal;
end;
File

CocoaBaseW

Description

This is record CocoaBaseW.TTokenRecord.

Group

Structs, Records, Enums

Links
CocoaBaseW, Structs, Records, Enums


Types

Types
CocoaBaseW Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

CocoaBaseW Namespace

Types
Name | Description
PTernaryNode | This is type CocoaBaseW.PTernaryNode.
PTokenPage | *) const TokensPerPage = 8190; {gives exactly 64K to the page} MaxTokenizerStack = 4; MaxParserStack = 350; //these two tweaked to give exactly 4K for a parser instance MaxSiblings = 312; {max number of token alternatives at any given point} MaxEmptyScopeNesting = 1; type PTokenRecord = ^TTokenRecord; TTokenRecord = packed record BufferStart: PWideChar; TokenType2: Word; Len2: Word; // upper 6 bits of TokenType are actually bits 32 through 37 of length end;
PTokenRecord | This is type CocoaBaseW.PTokenRecord.
Links
CocoaBaseW Namespace, Types


CocoaBaseW.PTernaryNode Type

CocoaBaseW.PTernaryNode Type
CocoaBaseW Types Send Feedback
Syntax
Delphi
PTernaryNode = ^TTernaryNode;
File

CocoaBaseW

Description

This is type CocoaBaseW.PTernaryNode.

Group

Types

Links
CocoaBaseW, Types


CocoaBaseW.PTokenPage Type

CocoaBaseW.PTokenPage Type
CocoaBaseW Types Send Feedback
Syntax
Delphi
PTokenPage = ^TTokenPage;
File

CocoaBaseW

Description

*)

const TokensPerPage = 8190; {gives exactly 64K to the page} MaxTokenizerStack = 4; MaxParserStack = 350; //these two tweaked to give exactly 4K for a parser instance MaxSiblings = 312; {max number of token alternatives at any given point} MaxEmptyScopeNesting = 1; type PTokenRecord = ^TTokenRecord; TTokenRecord = packed record BufferStart: PWideChar; TokenType2: Word; Len2: Word; // upper 6 bits of TokenType are actually bits 32 through 37 of length end;

Group

Types

Links
CocoaBaseW, Types


CocoaBaseW.PTokenRecord Type

CocoaBaseW.PTokenRecord Type
CocoaBaseW Types Send Feedback
Syntax
Delphi
PTokenRecord = ^TTokenRecord;
File

CocoaBaseW

Description

This is type CocoaBaseW.PTokenRecord.

Group

Types

Links
CocoaBaseW, Types


Constants

Constants
Constants CocoaBaseW Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
MaxEmptyScopeNesting | This is constant CocoaBaseW.MaxEmptyScopeNesting.
MaxParserStack | these two tweaked to give exactly 4K for a parser instance
MaxSiblings | max number of token alternatives at any given point
MaxTokenizerStack | (
TokensPerPage | calculate array size to keep TTokenPage within 64KB size; eg 64KB - SizeOf(TTokenPage)
Namespace

CocoaBaseW Namespace

Links
Constants, CocoaBaseW Namespace


CocoaBaseW.MaxEmptyScopeNesting Constant

CocoaBaseW.MaxEmptyScopeNesting Constant
CocoaBaseW Constants Send Feedback
Syntax
Delphi
MaxEmptyScopeNesting = 1;
File

CocoaBaseW

Description

This is constant CocoaBaseW.MaxEmptyScopeNesting.

Group

Constants

Links
CocoaBaseW, Constants


CocoaBaseW.MaxParserStack Constant

CocoaBaseW.MaxParserStack Constant
CocoaBaseW Constants Send Feedback
Syntax
Delphi
MaxParserStack = 350;
File

CocoaBaseW

Description

these two tweaked to give exactly 4K for a parser instance

Group

Constants

Links
CocoaBaseW, Constants


CocoaBaseW.MaxSiblings Constant

CocoaBaseW.MaxSiblings Constant
CocoaBaseW Constants Send Feedback
Syntax
Delphi
MaxSiblings = 312;
File

CocoaBaseW

Description

max number of token alternatives at any given point

Group

Constants

Links
CocoaBaseW, Constants


CocoaBaseW.MaxTokenizerStack Constant

CocoaBaseW.MaxTokenizerStack Constant
CocoaBaseW Constants Send Feedback
Syntax
Delphi
MaxTokenizerStack = 4;
File

CocoaBaseW

Description

(

Group

Constants

Links
CocoaBaseW, Constants


CocoaBaseW.TokensPerPage Constant

CocoaBaseW.TokensPerPage Constant
CocoaBaseW Constants Send Feedback
Syntax
Delphi
TokensPerPage = ((65536 - SizeOf(Pointer) - (SizeOf(Integer) * 3)) div SizeOf(TTokenRecord));
File

CocoaBaseW

Description

calculate array size to keep TTokenPage within 64KB size; eg 64KB - SizeOf(TTokenPage)

Group

Constants

Links
CocoaBaseW, Constants


Fmx Namespace

Fmx Namespace
Namespaces Send Feedback

This is namespace Fmx.

Namespaces
Name | Description
nxpvAboutFrm | This is namespace Fmx.nxpvAboutFrm.
nxpvJournalFrm | This is namespace Fmx.nxpvJournalFrm.
nxpvLoginFrm | This is namespace Fmx.nxpvLoginFrm.
nxpvPickServerFrm | This is namespace Fmx.nxpvPickServerFrm.
nxpvPlatformImplementation | This is namespace Fmx.nxpvPlatformImplementation.
nxpvServiceInstallForm | This is namespace Fmx.nxpvServiceInstallForm.
nxpvWindowHandle | This is namespace Fmx.nxpvWindowHandle.
Links
Namespaces


Fmx.nxpvAboutFrm Namespace

Fmx.nxpvAboutFrm Namespace
Classes Constants Functions Fmx Namespace Legend Topics Send Feedback

This is namespace Fmx.nxpvAboutFrm.

Classes
Name | Description
TnxAboutFrm | This is class Fmx.nxpvAboutFrm.TnxAboutFrm.
Constants
Name | Description
cnxBrowserError | This is constant Fmx.nxpvAboutFrm.cnxBrowserError.
cnxNewsClientError | This is constant Fmx.nxpvAboutFrm.cnxNewsClientError.
Domains | TnxObject
Functions
Name | Description
ShellToNews |
ShellToWWW | ShellTo functions
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Functions, Fmx Namespace, Legend, Topics


Classes

Classes
Classes Fmx.nxpvAboutFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAboutFrm | This is class Fmx.nxpvAboutFrm.TnxAboutFrm.
Namespace

Fmx.nxpvAboutFrm Namespace

Links
Classes, Fmx.nxpvAboutFrm Namespace, Legend


TnxAboutFrm Class

TnxAboutFrm Class
TnxAboutFrm Fields TnxAboutFrm Methods TnxAboutFrm Members Fmx.nxpvAboutFrm Classes Send Feedback
Class Hierarchy
Fmx_nxpvAboutFrm_TnxAboutFrm
Syntax
Delphi
TnxAboutFrm = class(TForm);
File

Fmx.nxpvAboutFrm

Description

This is class Fmx.nxpvAboutFrm.TnxAboutFrm.

Group

Classes

Links
TnxAboutFrm Fields, TnxAboutFrm Methods, TnxAboutFrm Members, Fmx.nxpvAboutFrm, Classes


TnxAboutFrm Members

TnxAboutFrm Members
TnxAboutFrm Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxAboutFrm.

Class

TnxAboutFrm Class

Public Fields
Name | Description
Image1 | This is Image1, a member of class TnxAboutFrm.
IsServer | Public declarations
Label3 | This is Label3, a member of class TnxAboutFrm.
Label4 | This is Label4, a member of class TnxAboutFrm.
laCopyright | This is laCopyright, a member of class TnxAboutFrm.
lbClose | This is lbClose, a member of class TnxAboutFrm.
lblNewsGeneral | This is lblNewsGeneral, a member of class TnxAboutFrm.
lblNexusLink | This is lblNexusLink, a member of class TnxAboutFrm.
Panel1 | This is Panel1, a member of class TnxAboutFrm.
Panel2 | This is Panel2, a member of class TnxAboutFrm.
ProgramName | This is ProgramName, a member of class TnxAboutFrm.
VersionNumber | This is VersionNumber, a member of class TnxAboutFrm.
Public Methods
Name | Description
FormActivate | This is FormActivate, a member of class TnxAboutFrm.
FormKeyDown | This is FormKeyDown, a member of class TnxAboutFrm.
FormShow | This is FormShow, a member of class TnxAboutFrm.
lbCloseClick | This is lbCloseClick, a member of class TnxAboutFrm.
lblNewsGeneralClick | This is lblNewsGeneralClick, a member of class TnxAboutFrm.
lblNewsGeneralMouseEnter | This is lblNewsGeneralMouseEnter, a member of class TnxAboutFrm.
lblNewsGeneralMouseLeave | This is lblNewsGeneralMouseLeave, a member of class TnxAboutFrm.
lblNexusLinkClick | This is lblNexusLinkClick, a member of class TnxAboutFrm.
lblNexusLinkMouseEnter | This is lblNexusLinkMouseEnter, a member of class TnxAboutFrm.
lblNexusLinkMouseLeave | This is lblNexusLinkMouseLeave, a member of class TnxAboutFrm.
Panel2Click | This is Panel2Click, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Fields, Public Methods


TnxAboutFrm Fields

TnxAboutFrm Fields
TnxAboutFrm Class Legend Public Fields Send Feedback

The fields of the TnxAboutFrm class are listed here.

Class

TnxAboutFrm Class

Public Fields
Name | Description
Image1 | This is Image1, a member of class TnxAboutFrm.
IsServer | Public declarations
Label3 | This is Label3, a member of class TnxAboutFrm.
Label4 | This is Label4, a member of class TnxAboutFrm.
laCopyright | This is laCopyright, a member of class TnxAboutFrm.
lbClose | This is lbClose, a member of class TnxAboutFrm.
lblNewsGeneral | This is lblNewsGeneral, a member of class TnxAboutFrm.
lblNexusLink | This is lblNexusLink, a member of class TnxAboutFrm.
Panel1 | This is Panel1, a member of class TnxAboutFrm.
Panel2 | This is Panel2, a member of class TnxAboutFrm.
ProgramName | This is ProgramName, a member of class TnxAboutFrm.
VersionNumber | This is VersionNumber, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Fields


TnxAboutFrm.Image1 Field

TnxAboutFrm.Image1 Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Image1: TImage;
Description

This is Image1, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.IsServer Field

TnxAboutFrm.IsServer Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
IsServer: boolean;
Description

Public declarations

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Label3 Field

TnxAboutFrm.Label3 Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Label3: TLabel;
Description

This is Label3, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Label4 Field

TnxAboutFrm.Label4 Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Label4: TLabel;
Description

This is Label4, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.laCopyright Field

TnxAboutFrm.laCopyright Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
laCopyright: TLabel;
Description

This is laCopyright, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lbClose Field

TnxAboutFrm.lbClose Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lbClose: TLabel;
Description

This is lbClose, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lblNewsGeneral Field

TnxAboutFrm.lblNewsGeneral Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lblNewsGeneral: TLabel;
Description

This is lblNewsGeneral, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lblNexusLink Field

TnxAboutFrm.lblNexusLink Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lblNexusLink: TLabel;
Description

This is lblNexusLink, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Panel1 Field

TnxAboutFrm.Panel1 Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Panel2 Field

TnxAboutFrm.Panel2 Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Panel2: TPanel;
Description

This is Panel2, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.ProgramName Field

TnxAboutFrm.ProgramName Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
ProgramName: TLabel;
Description

This is ProgramName, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.VersionNumber Field

TnxAboutFrm.VersionNumber Field
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
VersionNumber: TLabel;
Description

This is VersionNumber, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm Methods

TnxAboutFrm Methods
TnxAboutFrm Class Legend Public Methods Send Feedback

The methods of the TnxAboutFrm class are listed here.

Class

TnxAboutFrm Class

Public Methods
Name | Description
FormActivate | This is FormActivate, a member of class TnxAboutFrm.
FormKeyDown | This is FormKeyDown, a member of class TnxAboutFrm.
FormShow | This is FormShow, a member of class TnxAboutFrm.
lbCloseClick | This is lbCloseClick, a member of class TnxAboutFrm.
lblNewsGeneralClick | This is lblNewsGeneralClick, a member of class TnxAboutFrm.
lblNewsGeneralMouseEnter | This is lblNewsGeneralMouseEnter, a member of class TnxAboutFrm.
lblNewsGeneralMouseLeave | This is lblNewsGeneralMouseLeave, a member of class TnxAboutFrm.
lblNexusLinkClick | This is lblNexusLinkClick, a member of class TnxAboutFrm.
lblNexusLinkMouseEnter | This is lblNexusLinkMouseEnter, a member of class TnxAboutFrm.
lblNexusLinkMouseLeave | This is lblNexusLinkMouseLeave, a member of class TnxAboutFrm.
Panel2Click | This is Panel2Click, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Methods


TnxAboutFrm.FormActivate Method

TnxAboutFrm.FormActivate Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormActivate(Sender: TObject);
Description

This is FormActivate, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.FormKeyDown Method

TnxAboutFrm.FormKeyDown Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormKeyDown(Sender: TObject; var Key: Word; var KeyChar: Char; Shift: TShiftState);
Description

This is FormKeyDown, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.FormShow Method

TnxAboutFrm.FormShow Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Description

This is FormShow, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lbCloseClick Method

TnxAboutFrm.lbCloseClick Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lbCloseClick(Sender: TObject);
Description

This is lbCloseClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNewsGeneralClick Method

TnxAboutFrm.lblNewsGeneralClick Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNewsGeneralClick(Sender: TObject);
Description

This is lblNewsGeneralClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNewsGeneralMouseEnter Method

TnxAboutFrm.lblNewsGeneralMouseEnter Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNewsGeneralMouseEnter(Sender: TObject);
Description

This is lblNewsGeneralMouseEnter, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNewsGeneralMouseLeave Method

TnxAboutFrm.lblNewsGeneralMouseLeave Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNewsGeneralMouseLeave(Sender: TObject);
Description

This is lblNewsGeneralMouseLeave, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNexusLinkClick Method

TnxAboutFrm.lblNexusLinkClick Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNexusLinkClick(Sender: TObject);
Description

This is lblNexusLinkClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNexusLinkMouseEnter Method

TnxAboutFrm.lblNexusLinkMouseEnter Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNexusLinkMouseEnter(Sender: TObject);
Description

This is lblNexusLinkMouseEnter, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNexusLinkMouseLeave Method

TnxAboutFrm.lblNexusLinkMouseLeave Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNexusLinkMouseLeave(Sender: TObject);
Description

This is lblNexusLinkMouseLeave, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.Panel2Click Method

TnxAboutFrm.Panel2Click Method
TnxAboutFrm Class TnxAboutFrm Members Fmx.nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure Panel2Click(Sender: TObject);
Description

This is Panel2Click, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, Fmx.nxpvAboutFrm Namespace, TnxAboutFrm Methods


Functions

Functions
Functions Fmx.nxpvAboutFrm Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ShellToNews |
ShellToWWW | ShellTo functions
Namespace

Fmx.nxpvAboutFrm Namespace

Links
Functions, Fmx.nxpvAboutFrm Namespace, Legend


Fmx.nxpvAboutFrm.ShellToNews Function

Fmx.nxpvAboutFrm.ShellToNews Function
Fmx.nxpvAboutFrm Functions Send Feedback
Syntax
Delphi
procedure ShellToNews;
File

Fmx.nxpvAboutFrm

Group

Functions

Links
Fmx.nxpvAboutFrm, Functions


Fmx.nxpvAboutFrm.ShellToWWW Function

Fmx.nxpvAboutFrm.ShellToWWW Function
Fmx.nxpvAboutFrm Functions Send Feedback
Syntax
Delphi
procedure ShellToWWW;
File

Fmx.nxpvAboutFrm

Description

ShellTo functions

Group

Functions

Links
Fmx.nxpvAboutFrm, Functions


Constants

Constants
Constants Fmx.nxpvAboutFrm Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cnxBrowserError | This is constant Fmx.nxpvAboutFrm.cnxBrowserError.
cnxNewsClientError | This is constant Fmx.nxpvAboutFrm.cnxNewsClientError.
Domains | TnxObject
Namespace

Fmx.nxpvAboutFrm Namespace

Links
Constants, Fmx.nxpvAboutFrm Namespace


Fmx.nxpvAboutFrm.cnxBrowserError Constant

Fmx.nxpvAboutFrm.cnxBrowserError Constant
Fmx.nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
cnxBrowserError = 'Unable to start Web browser. Make sure you have it properly setup on your system.';
File

Fmx.nxpvAboutFrm

Description

This is constant Fmx.nxpvAboutFrm.cnxBrowserError.

Group

Constants

Links
Fmx.nxpvAboutFrm, Constants


Fmx.nxpvAboutFrm.cnxNewsClientError Constant

Fmx.nxpvAboutFrm.cnxNewsClientError Constant
Fmx.nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
cnxNewsClientError = 'Unable to start News client. Make sure you have it properly setup on your system.';
File

Fmx.nxpvAboutFrm

Description

This is constant Fmx.nxpvAboutFrm.cnxNewsClientError.

Group

Constants

Links
Fmx.nxpvAboutFrm, Constants


Fmx.nxpvAboutFrm.Domains Constant

Fmx.nxpvAboutFrm.Domains Constant
Fmx.nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
Domains: array [boolean] of string[6] = ('Client', 'Server');
File

Fmx.nxpvAboutFrm

Description

TnxObject

Group

Constants

Links
Fmx.nxpvAboutFrm, Constants


Fmx.nxpvJournalFrm Namespace

Fmx.nxpvJournalFrm Namespace
Classes Fmx Namespace Legend Topics Send Feedback

This is namespace Fmx.nxpvJournalFrm.

Classes
Name | Description
TfrmJournal | This is class Fmx.nxpvJournalFrm.TfrmJournal.
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Fmx Namespace, Legend, Topics


Classes

Classes
Classes Fmx.nxpvJournalFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmJournal | This is class Fmx.nxpvJournalFrm.TfrmJournal.
Namespace

Fmx.nxpvJournalFrm Namespace

Links
Classes, Fmx.nxpvJournalFrm Namespace, Legend


TfrmJournal Class

TfrmJournal Class
TfrmJournal Fields TfrmJournal Methods TfrmJournal Members Fmx.nxpvJournalFrm Classes Send Feedback
Class Hierarchy
Fmx_nxpvJournalFrm_TfrmJournal
Syntax
Delphi
TfrmJournal = class(TForm);
File

Fmx.nxpvJournalFrm

Description

This is class Fmx.nxpvJournalFrm.TfrmJournal.

Group

Classes

Links
TfrmJournal Fields, TfrmJournal Methods, TfrmJournal Members, Fmx.nxpvJournalFrm, Classes


TfrmJournal Members

TfrmJournal Members
TfrmJournal Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TfrmJournal.

Class

TfrmJournal Class

Public Fields
Name | Description
ActionLabel | This is ActionLabel, a member of class TfrmJournal.
AliasLabel | This is AliasLabel, a member of class TfrmJournal.
Bevel1 | This is Bevel1, a member of class TfrmJournal.
CompletenessLabel | This is CompletenessLabel, a member of class TfrmJournal.
ExceptionLabel | This is ExceptionLabel, a member of class TfrmJournal.
FilenameLabel | This is FilenameLabel, a member of class TfrmJournal.
OKBtn | This is OKBtn, a member of class TfrmJournal.
Panel1 | This is Panel1, a member of class TfrmJournal.
Panel2 | This is Panel2, a member of class TfrmJournal.
PathLabel | This is PathLabel, a member of class TfrmJournal.
PrintBtn | This is PrintBtn, a member of class TfrmJournal.
RollbackBtn | This is RollbackBtn, a member of class TfrmJournal.
Public Methods
Name | Description
PrintBtnClick | This is PrintBtnClick, a member of class TfrmJournal.
Setup | Public declarations
Links
TfrmJournal Class, Legend, Public Fields, Public Methods


TfrmJournal Fields

TfrmJournal Fields
TfrmJournal Class Legend Public Fields Send Feedback

The fields of the TfrmJournal class are listed here.

Class

TfrmJournal Class

Public Fields
Name | Description
ActionLabel | This is ActionLabel, a member of class TfrmJournal.
AliasLabel | This is AliasLabel, a member of class TfrmJournal.
Bevel1 | This is Bevel1, a member of class TfrmJournal.
CompletenessLabel | This is CompletenessLabel, a member of class TfrmJournal.
ExceptionLabel | This is ExceptionLabel, a member of class TfrmJournal.
FilenameLabel | This is FilenameLabel, a member of class TfrmJournal.
OKBtn | This is OKBtn, a member of class TfrmJournal.
Panel1 | This is Panel1, a member of class TfrmJournal.
Panel2 | This is Panel2, a member of class TfrmJournal.
PathLabel | This is PathLabel, a member of class TfrmJournal.
PrintBtn | This is PrintBtn, a member of class TfrmJournal.
RollbackBtn | This is RollbackBtn, a member of class TfrmJournal.
Links
TfrmJournal Class, Legend, Public Fields


TfrmJournal.ActionLabel Field

TfrmJournal.ActionLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
ActionLabel: TLabel;
Description

This is ActionLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.AliasLabel Field

TfrmJournal.AliasLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
AliasLabel: TLabel;
Description

This is AliasLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Bevel1 Field

TfrmJournal.Bevel1 Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Bevel1: TPanel;
Description

This is Bevel1, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.CompletenessLabel Field

TfrmJournal.CompletenessLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
CompletenessLabel: TLabel;
Description

This is CompletenessLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.ExceptionLabel Field

TfrmJournal.ExceptionLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
ExceptionLabel: TLabel;
Description

This is ExceptionLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.FilenameLabel Field

TfrmJournal.FilenameLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
FilenameLabel: TLabel;
Description

This is FilenameLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.OKBtn Field

TfrmJournal.OKBtn Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
OKBtn: TButton;
Description

This is OKBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Panel1 Field

TfrmJournal.Panel1 Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Panel2 Field

TfrmJournal.Panel2 Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Panel2: TPanel;
Description

This is Panel2, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.PathLabel Field

TfrmJournal.PathLabel Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
PathLabel: TLabel;
Description

This is PathLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.PrintBtn Field

TfrmJournal.PrintBtn Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
PrintBtn: TButton;
Description

This is PrintBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.RollbackBtn Field

TfrmJournal.RollbackBtn Field
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
RollbackBtn: TButton;
Description

This is RollbackBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal Methods

TfrmJournal Methods
TfrmJournal Class Legend Public Methods Send Feedback

The methods of the TfrmJournal class are listed here.

Class

TfrmJournal Class

Public Methods
Name | Description
PrintBtnClick | This is PrintBtnClick, a member of class TfrmJournal.
Setup | Public declarations
Links
TfrmJournal Class, Legend, Public Methods


TfrmJournal.PrintBtnClick Method

TfrmJournal.PrintBtnClick Method
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Methods Send Feedback
Syntax
Delphi
procedure PrintBtnClick(Sender: TObject);
Description

This is PrintBtnClick, a member of class TfrmJournal.

Group

TfrmJournal Methods

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Methods


TfrmJournal.Setup Method

TfrmJournal.Setup Method
TfrmJournal Class TfrmJournal Members Fmx.nxpvJournalFrm Namespace TfrmJournal Methods Send Feedback
Syntax
Delphi
procedure Setup(aJournalState: TnxJournalState; aAlias: string; aPath: string; aFilename: string; aExceptionString: string);
Description

Public declarations

Group

TfrmJournal Methods

Links
TfrmJournal Class, TfrmJournal Members, Fmx.nxpvJournalFrm Namespace, TfrmJournal Methods


Fmx.nxpvLoginFrm Namespace

Fmx.nxpvLoginFrm Namespace
Classes Fmx Namespace Legend Topics Send Feedback

This is namespace Fmx.nxpvLoginFrm.

Classes
Name | Description
TfrmLogin | This is class Fmx.nxpvLoginFrm.TfrmLogin.
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Fmx Namespace, Legend, Topics


Classes

Classes
Classes Fmx.nxpvLoginFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmLogin | This is class Fmx.nxpvLoginFrm.TfrmLogin.
Namespace

Fmx.nxpvLoginFrm Namespace

Links
Classes, Fmx.nxpvLoginFrm Namespace, Legend


TfrmLogin Class

TfrmLogin Class
TfrmLogin Fields TfrmLogin Methods TfrmLogin Properties TfrmLogin Members Fmx.nxpvLoginFrm Classes Send Feedback
Class Hierarchy
Fmx_nxpvLoginFrm_TfrmLogin
Syntax
Delphi
TfrmLogin = class(TForm);
File

Fmx.nxpvLoginFrm

Description

This is class Fmx.nxpvLoginFrm.TfrmLogin.

Group

Classes

Links
TfrmLogin Fields, TfrmLogin Methods, TfrmLogin Properties, TfrmLogin Members, Fmx.nxpvLoginFrm, Classes


TfrmLogin Members

TfrmLogin Members
TfrmLogin Class Legend Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TfrmLogin.

Class

TfrmLogin Class

Public Fields
Name | Description
btnCancel | This is btnCancel, a member of class TfrmLogin.
btnOK | This is btnOK, a member of class TfrmLogin.
edPassword | This is edPassword, a member of class TfrmLogin.
edUserName | This is edUserName, a member of class TfrmLogin.
laDescription | This is laDescription, a member of class TfrmLogin.
lbPassword | This is lbPassword, a member of class TfrmLogin.
lbUsername | This is lbUsername, a member of class TfrmLogin.
Panel1 | This is Panel1, a member of class TfrmLogin.
paTop | This is paTop, a member of class TfrmLogin.
Public Methods
Name | Description
btnOKClick | TnxLoginDialog
FormShow |
Public Properties
Name | Description
Password | This is Password, a member of class TfrmLogin.
UserName | This is UserName, a member of class TfrmLogin.
Links
TfrmLogin Class, Legend, Public Fields, Public Methods, Public Properties


TfrmLogin Fields

TfrmLogin Fields
TfrmLogin Class Legend Public Fields Send Feedback

The fields of the TfrmLogin class are listed here.

Class

TfrmLogin Class

Public Fields
Name | Description
btnCancel | This is btnCancel, a member of class TfrmLogin.
btnOK | This is btnOK, a member of class TfrmLogin.
edPassword | This is edPassword, a member of class TfrmLogin.
edUserName | This is edUserName, a member of class TfrmLogin.
laDescription | This is laDescription, a member of class TfrmLogin.
lbPassword | This is lbPassword, a member of class TfrmLogin.
lbUsername | This is lbUsername, a member of class TfrmLogin.
Panel1 | This is Panel1, a member of class TfrmLogin.
paTop | This is paTop, a member of class TfrmLogin.
Links
TfrmLogin Class, Legend, Public Fields


TfrmLogin.btnCancel Field

TfrmLogin.btnCancel Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
btnCancel: TButton;
Description

This is btnCancel, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.btnOK Field

TfrmLogin.btnOK Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
btnOK: TButton;
Description

This is btnOK, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.edPassword Field

TfrmLogin.edPassword Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
edPassword: TEdit;
Description

This is edPassword, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.edUserName Field

TfrmLogin.edUserName Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
edUserName: TEdit;
Description

This is edUserName, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.laDescription Field

TfrmLogin.laDescription Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
laDescription: TLabel;
Description

This is laDescription, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.lbPassword Field

TfrmLogin.lbPassword Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
lbPassword: TLabel;
Description

This is lbPassword, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.lbUsername Field

TfrmLogin.lbUsername Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
lbUsername: TLabel;
Description

This is lbUsername, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.Panel1 Field

TfrmLogin.Panel1 Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.paTop Field

TfrmLogin.paTop Field
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
paTop: TPanel;
Description

This is paTop, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin Methods

TfrmLogin Methods
TfrmLogin Class Legend Public Methods Send Feedback

The methods of the TfrmLogin class are listed here.

Class

TfrmLogin Class

Public Methods
Name | Description
btnOKClick | TnxLoginDialog
FormShow |
Links
TfrmLogin Class, Legend, Public Methods


TfrmLogin.btnOKClick Method

TfrmLogin.btnOKClick Method
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Methods Send Feedback
Syntax
Delphi
procedure btnOKClick(Sender: TObject);
Description

TnxLoginDialog

Group

TfrmLogin Methods

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Methods


TfrmLogin.FormShow Method

TfrmLogin.FormShow Method
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Group

TfrmLogin Methods

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Methods


TfrmLogin Properties

TfrmLogin Properties
TfrmLogin Class Legend Public Properties Send Feedback

The properties of the TfrmLogin class are listed here.

Class

TfrmLogin Class

Public Properties
Name | Description
Password | This is Password, a member of class TfrmLogin.
UserName | This is UserName, a member of class TfrmLogin.
Links
TfrmLogin Class, Legend, Public Properties


TfrmLogin.Password Property

TfrmLogin.Password Property
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is Password, a member of class TfrmLogin.

Group

TfrmLogin Properties

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Properties


TfrmLogin.UserName Property

TfrmLogin.UserName Property
TfrmLogin Class TfrmLogin Members Fmx.nxpvLoginFrm Namespace TfrmLogin Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This is UserName, a member of class TfrmLogin.

Group

TfrmLogin Properties

Links
TfrmLogin Class, TfrmLogin Members, Fmx.nxpvLoginFrm Namespace, TfrmLogin Properties


Fmx.nxpvPickServerFrm Namespace

Fmx.nxpvPickServerFrm Namespace
Classes Fmx Namespace Legend Topics Send Feedback

This is namespace Fmx.nxpvPickServerFrm.

Classes
Name | Description
TfrmPickServer | This is class Fmx.nxpvPickServerFrm.TfrmPickServer.
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Fmx Namespace, Legend, Topics


Classes

Classes
Classes Fmx.nxpvPickServerFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmPickServer | This is class Fmx.nxpvPickServerFrm.TfrmPickServer.
Namespace

Fmx.nxpvPickServerFrm Namespace

Links
Classes, Fmx.nxpvPickServerFrm Namespace, Legend


TfrmPickServer Class

TfrmPickServer Class
TfrmPickServer Fields TfrmPickServer Members Fmx.nxpvPickServerFrm Classes Send Feedback
Class Hierarchy
Fmx_nxpvPickServerFrm_TfrmPickServer
Syntax
Delphi
TfrmPickServer = class(TForm);
File

Fmx.nxpvPickServerFrm

Description

This is class Fmx.nxpvPickServerFrm.TfrmPickServer.

Group

Classes

Links
TfrmPickServer Fields, TfrmPickServer Members, Fmx.nxpvPickServerFrm, Classes


TfrmPickServer Members

TfrmPickServer Members
TfrmPickServer Class Legend Public Fields Send Feedback

The following tables list the members exposed by TfrmPickServer.

Class

TfrmPickServer Class

Public Fields
Name | Description
Bevel1 | This is Bevel1, a member of class TfrmPickServer.
Button1 | This is Button1, a member of class TfrmPickServer.
CBNames | This is CBNames, a member of class TfrmPickServer.
Label1 | This is Label1, a member of class TfrmPickServer.
OKBtn | This is OKBtn, a member of class TfrmPickServer.
Links
TfrmPickServer Class, Legend, Public Fields


TfrmPickServer Fields

TfrmPickServer Fields
TfrmPickServer Class Legend Public Fields Send Feedback

The fields of the TfrmPickServer class are listed here.

Class

TfrmPickServer Class

Public Fields
Name | Description
Bevel1 | This is Bevel1, a member of class TfrmPickServer.
Button1 | This is Button1, a member of class TfrmPickServer.
CBNames | This is CBNames, a member of class TfrmPickServer.
Label1 | This is Label1, a member of class TfrmPickServer.
OKBtn | This is OKBtn, a member of class TfrmPickServer.
Links
TfrmPickServer Class, Legend, Public Fields


TfrmPickServer.Bevel1 Field

TfrmPickServer.Bevel1 Field
TfrmPickServer Class TfrmPickServer Members Fmx.nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Bevel1: TPanel;
Description

This is Bevel1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, Fmx.nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.Button1 Field

TfrmPickServer.Button1 Field
TfrmPickServer Class TfrmPickServer Members Fmx.nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Button1: TButton;
Description

This is Button1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, Fmx.nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.CBNames Field

TfrmPickServer.CBNames Field
TfrmPickServer Class TfrmPickServer Members Fmx.nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
CBNames: TComboBox;
Description

This is CBNames, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, Fmx.nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.Label1 Field

TfrmPickServer.Label1 Field
TfrmPickServer Class TfrmPickServer Members Fmx.nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Label1: TLabel;
Description

This is Label1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, Fmx.nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.OKBtn Field

TfrmPickServer.OKBtn Field
TfrmPickServer Class TfrmPickServer Members Fmx.nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
OKBtn: TButton;
Description

This is OKBtn, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, Fmx.nxpvPickServerFrm Namespace, TfrmPickServer Fields


Fmx.nxpvPlatformImplementation Namespace

Fmx.nxpvPlatformImplementation Namespace
Classes Functions Fmx Namespace Legend Topics Variables Send Feedback

This is namespace Fmx.nxpvPlatformImplementation.

Classes
Name | Description
TnxTerminateHelper |
TnxTimer | TnxTimer
Functions
Name | Description
AddRef | This is function Fmx.nxpvPlatformImplementation.AddRef.
Release | This is function Fmx.nxpvPlatformImplementation.Release.
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_RefCount | This is variable Fmx.nxpvPlatformImplementation._RefCount.
Links
Classes, Functions, Fmx Namespace, Legend, Topics, Variables


Classes

Classes
Classes Fmx.nxpvPlatformImplementation Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxTerminateHelper |
TnxTimer | TnxTimer
Namespace

Fmx.nxpvPlatformImplementation Namespace

Links
Classes, Fmx.nxpvPlatformImplementation Namespace, Legend


TnxTerminateHelper Class

TnxTerminateHelper Class
TnxTerminateHelper Methods TnxTerminateHelper Members Fmx.nxpvPlatformImplementation Classes Send Feedback
Class Hierarchy
Fmx_nxpvPlatformImplementation_TnxTerminateHelper
Syntax
Delphi
TnxTerminateHelper = class;
File

Fmx.nxpvPlatformImplementation

Group

Classes

Links
TnxTerminateHelper Methods, TnxTerminateHelper Members, Fmx.nxpvPlatformImplementation, Classes


TnxTerminateHelper Members

TnxTerminateHelper Members
TnxTerminateHelper Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxTerminateHelper.

Class

TnxTerminateHelper Class

Public Methods
Name | Description
Terminate | This is Terminate, a member of class TnxTerminateHelper.
Links
TnxTerminateHelper Class, Legend, Public Methods


TnxTerminateHelper Methods

TnxTerminateHelper Methods
TnxTerminateHelper Class Legend Public Methods Send Feedback

The methods of the TnxTerminateHelper class are listed here.

Class

TnxTerminateHelper Class

Public Methods
Name | Description
Terminate | This is Terminate, a member of class TnxTerminateHelper.
Links
TnxTerminateHelper Class, Legend, Public Methods


TnxTerminateHelper.Terminate Method

TnxTerminateHelper.Terminate Method
TnxTerminateHelper Class TnxTerminateHelper Members Fmx.nxpvPlatformImplementation Namespace TnxTerminateHelper Methods Send Feedback
Syntax
Delphi
class procedure Terminate;
Description

This is Terminate, a member of class TnxTerminateHelper.

Group

TnxTerminateHelper Methods

Links
TnxTerminateHelper Class, TnxTerminateHelper Members, Fmx.nxpvPlatformImplementation Namespace, TnxTerminateHelper Methods


TnxTimer Class

TnxTimer Class
TnxTimer Fields TnxTimer Methods TnxTimer Members Fmx.nxpvPlatformImplementation Classes Send Feedback
Class Hierarchy
Fmx_nxpvPlatformImplementation_TnxTimer
Syntax
Delphi
TnxTimer = class(TInterfacedObject, InxTimer);
File

Fmx.nxpvPlatformImplementation

Description

TnxTimer

Group

Classes

Links
TnxTimer Fields, TnxTimer Methods, TnxTimer Members, Fmx.nxpvPlatformImplementation, Classes


TnxTimer Members

TnxTimer Members
TnxTimer Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTimer.

Class

TnxTimer Class

Protected Fields
Name | Description
ftTimer | private
Protected Methods
Name | Description
ftGetEnabled | InxTimer
ftGetInterval |
ftGetOnTimer |
ftSetEnabled |
ftSetInterval |
ftSetOnTimer |
Public Methods
Name | Description
Create |
Destroy |
Links
TnxTimer Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxTimer.Create Constructor

TnxTimer.Create Constructor
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxTimer Class

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Class


TnxTimer.Destroy Destructor

TnxTimer.Destroy Destructor
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTimer Class

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Class


TnxTimer Fields

TnxTimer Fields
TnxTimer Class Legend Protected Fields Send Feedback

The fields of the TnxTimer class are listed here.

Class

TnxTimer Class

Protected Fields
Name | Description
ftTimer | private
Links
TnxTimer Class, Legend, Protected Fields


TnxTimer.ftTimer Field

TnxTimer.ftTimer Field
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Fields Send Feedback
Syntax
Delphi
ftTimer: TTimer;
Description

private

Group

TnxTimer Fields

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Fields


TnxTimer Methods

TnxTimer Methods
TnxTimer Class Legend Protected Methods Send Feedback

The methods of the TnxTimer class are listed here.

Class

TnxTimer Class

Protected Methods
Name | Description
ftGetEnabled | InxTimer
ftGetInterval |
ftGetOnTimer |
ftSetEnabled |
ftSetInterval |
ftSetOnTimer |
Links
TnxTimer Class, Legend, Protected Methods


TnxTimer.ftGetEnabled Method

TnxTimer.ftGetEnabled Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetEnabled: Boolean;
Description

InxTimer

Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftGetInterval Method

TnxTimer.ftGetInterval Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetInterval: Cardinal;
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftGetOnTimer Method

TnxTimer.ftGetOnTimer Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetOnTimer: TNotifyEvent;
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetEnabled Method

TnxTimer.ftSetEnabled Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetEnabled(aEnabled: Boolean);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetInterval Method

TnxTimer.ftSetInterval Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetInterval(aInterval: Cardinal);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetOnTimer Method

TnxTimer.ftSetOnTimer Method
TnxTimer Class TnxTimer Members Fmx.nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetOnTimer(aOnTimer: TNotifyEvent);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, Fmx.nxpvPlatformImplementation Namespace, TnxTimer Methods


Functions

Functions
Functions Fmx.nxpvPlatformImplementation Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function Fmx.nxpvPlatformImplementation.AddRef.
Release | This is function Fmx.nxpvPlatformImplementation.Release.
Namespace

Fmx.nxpvPlatformImplementation Namespace

Links
Functions, Fmx.nxpvPlatformImplementation Namespace, Legend


Fmx.nxpvPlatformImplementation.AddRef Function

Fmx.nxpvPlatformImplementation.AddRef Function
Fmx.nxpvPlatformImplementation Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

Fmx.nxpvPlatformImplementation

Description

This is function Fmx.nxpvPlatformImplementation.AddRef.

Group

Functions

Links
Fmx.nxpvPlatformImplementation, Functions


Fmx.nxpvPlatformImplementation.Release Function

Fmx.nxpvPlatformImplementation.Release Function
Fmx.nxpvPlatformImplementation Functions Send Feedback
Syntax
Delphi
procedure Release;
File

Fmx.nxpvPlatformImplementation

Description

This is function Fmx.nxpvPlatformImplementation.Release.

Group

Functions

Links
Fmx.nxpvPlatformImplementation, Functions


Variables

Variables
Fmx.nxpvPlatformImplementation Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

Fmx.nxpvPlatformImplementation Namespace

Variables
Name | Description
_RefCount | This is variable Fmx.nxpvPlatformImplementation._RefCount.
Links
Fmx.nxpvPlatformImplementation Namespace, Variables


Fmx.nxpvPlatformImplementation._RefCount Variable

Fmx.nxpvPlatformImplementation._RefCount Variable
Fmx.nxpvPlatformImplementation Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

Fmx.nxpvPlatformImplementation

Description

This is variable Fmx.nxpvPlatformImplementation._RefCount.

Group

Variables

Links
Fmx.nxpvPlatformImplementation, Variables


Fmx.nxpvServiceInstallForm Namespace

Fmx.nxpvServiceInstallForm Namespace
Classes Fmx Namespace Legend Topics Send Feedback

This is namespace Fmx.nxpvServiceInstallForm.

Classes
Name | Description
TfrmServiceInstall | This is class Fmx.nxpvServiceInstallForm.TfrmServiceInstall.
Namespace

Fmx Namespace

Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Fmx Namespace, Legend, Topics


Classes

Classes
Classes Fmx.nxpvServiceInstallForm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmServiceInstall | This is class Fmx.nxpvServiceInstallForm.TfrmServiceInstall.
Namespace

Fmx.nxpvServiceInstallForm Namespace

Links
Classes, Fmx.nxpvServiceInstallForm Namespace, Legend


TfrmServiceInstall Class

TfrmServiceInstall Class
TfrmServiceInstall Fields TfrmServiceInstall Methods TfrmServiceInstall Properties TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Classes Send Feedback
Class Hierarchy
Fmx_nxpvServiceInstallForm_TfrmServiceInstall
Syntax
Delphi
TfrmServiceInstall = class(TForm);
File

Fmx.nxpvServiceInstallForm

Description

This is class Fmx.nxpvServiceInstallForm.TfrmServiceInstall.

Group

Classes

Links
TfrmServiceInstall Fields, TfrmServiceInstall Methods, TfrmServiceInstall Properties, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm, Classes


TfrmServiceInstall Members

TfrmServiceInstall Members
TfrmServiceInstall Class Legend Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TfrmServiceInstall.

Class

TfrmServiceInstall Class

Public Fields
Name | Description
btnCancel | This is btnCancel, a member of class TfrmServiceInstall.
btnOK | This is btnOK, a member of class TfrmServiceInstall.
Button1 | This is Button1, a member of class TfrmServiceInstall.
cxLocalHost | This is cxLocalHost, a member of class TfrmServiceInstall.
edPassword | This is edPassword, a member of class TfrmServiceInstall.
edUserName | This is edUserName, a member of class TfrmServiceInstall.
Label1 | This is Label1, a member of class TfrmServiceInstall.
laDescription | This is laDescription, a member of class TfrmServiceInstall.
lbPassword | This is lbPassword, a member of class TfrmServiceInstall.
lbUsername | This is lbUsername, a member of class TfrmServiceInstall.
Panel1 | This is Panel1, a member of class TfrmServiceInstall.
paTop | This is paTop, a member of class TfrmServiceInstall.
Public Methods
Name | Description
btnOKClick | TnxLoginDialog
Button1Click |
FormCreate | This is FormCreate, a member of class TfrmServiceInstall.
FormShow |
Public Properties
Name | Description
Password | This is Password, a member of class TfrmServiceInstall.
UserName | This is UserName, a member of class TfrmServiceInstall.
Links
TfrmServiceInstall Class, Legend, Public Fields, Public Methods, Public Properties


TfrmServiceInstall Fields

TfrmServiceInstall Fields
TfrmServiceInstall Class Legend Public Fields Send Feedback

The fields of the TfrmServiceInstall class are listed here.

Class

TfrmServiceInstall Class

Public Fields
Name | Description
btnCancel | This is btnCancel, a member of class TfrmServiceInstall.
btnOK | This is btnOK, a member of class TfrmServiceInstall.
Button1 | This is Button1, a member of class TfrmServiceInstall.
cxLocalHost | This is cxLocalHost, a member of class TfrmServiceInstall.
edPassword | This is edPassword, a member of class TfrmServiceInstall.
edUserName | This is edUserName, a member of class TfrmServiceInstall.
Label1 | This is Label1, a member of class TfrmServiceInstall.
laDescription | This is laDescription, a member of class TfrmServiceInstall.
lbPassword | This is lbPassword, a member of class TfrmServiceInstall.
lbUsername | This is lbUsername, a member of class TfrmServiceInstall.
Panel1 | This is Panel1, a member of class TfrmServiceInstall.
paTop | This is paTop, a member of class TfrmServiceInstall.
Links
TfrmServiceInstall Class, Legend, Public Fields


TfrmServiceInstall.btnCancel Field

TfrmServiceInstall.btnCancel Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
btnCancel: TButton;
Description

This is btnCancel, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.btnOK Field

TfrmServiceInstall.btnOK Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
btnOK: TButton;
Description

This is btnOK, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Button1 Field

TfrmServiceInstall.Button1 Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Button1: TButton;
Description

This is Button1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.cxLocalHost Field

TfrmServiceInstall.cxLocalHost Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
cxLocalHost: TCheckBox;
Description

This is cxLocalHost, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.edPassword Field

TfrmServiceInstall.edPassword Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
edPassword: TEdit;
Description

This is edPassword, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.edUserName Field

TfrmServiceInstall.edUserName Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
edUserName: TEdit;
Description

This is edUserName, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Label1 Field

TfrmServiceInstall.Label1 Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Label1: TLabel;
Description

This is Label1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.laDescription Field

TfrmServiceInstall.laDescription Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
laDescription: TLabel;
Description

This is laDescription, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.lbPassword Field

TfrmServiceInstall.lbPassword Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
lbPassword: TLabel;
Description

This is lbPassword, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.lbUsername Field

TfrmServiceInstall.lbUsername Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
lbUsername: TLabel;
Description

This is lbUsername, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Panel1 Field

TfrmServiceInstall.Panel1 Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.paTop Field

TfrmServiceInstall.paTop Field
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
paTop: TPanel;
Description

This is paTop, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall Methods

TfrmServiceInstall Methods
TfrmServiceInstall Class Legend Public Methods Send Feedback

The methods of the TfrmServiceInstall class are listed here.

Class

TfrmServiceInstall Class

Public Methods
Name | Description
btnOKClick | TnxLoginDialog
Button1Click |
FormCreate | This is FormCreate, a member of class TfrmServiceInstall.
FormShow |
Links
TfrmServiceInstall Class, Legend, Public Methods


TfrmServiceInstall.btnOKClick Method

TfrmServiceInstall.btnOKClick Method
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure btnOKClick(Sender: TObject);
Description

TnxLoginDialog

Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.Button1Click Method

TfrmServiceInstall.Button1Click Method
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure Button1Click(Sender: TObject);
Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.FormCreate Method

TfrmServiceInstall.FormCreate Method
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure FormCreate(Sender: TObject);
Description

This is FormCreate, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.FormShow Method

TfrmServiceInstall.FormShow Method
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall Properties

TfrmServiceInstall Properties
TfrmServiceInstall Class Legend Public Properties Send Feedback

The properties of the TfrmServiceInstall class are listed here.

Class

TfrmServiceInstall Class

Public Properties
Name | Description
Password | This is Password, a member of class TfrmServiceInstall.
UserName | This is UserName, a member of class TfrmServiceInstall.
Links
TfrmServiceInstall Class, Legend, Public Properties


TfrmServiceInstall.Password Property

TfrmServiceInstall.Password Property
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is Password, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Properties

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Properties


TfrmServiceInstall.UserName Property

TfrmServiceInstall.UserName Property
TfrmServiceInstall Class TfrmServiceInstall Members Fmx.nxpvServiceInstallForm Namespace TfrmServiceInstall Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This is UserName, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Properties

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, Fmx.nxpvServiceInstallForm Namespace, TfrmServiceInstall Properties


Fmx.nxpvWindowHandle Namespace

Fmx.nxpvWindowHandle Namespace
Constants Functions Fmx Namespace Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace Fmx.nxpvWindowHandle.

Constants
Name | Description
CM_BASE | This is constant Fmx.nxpvWindowHandle.CM_BASE.
CM_RELEASE | This is constant Fmx.nxpvWindowHandle.CM_RELEASE.
CodeBytes | This is constant Fmx.nxpvWindowHandle.CodeBytes.
InstanceCount | This is constant Fmx.nxpvWindowHandle.InstanceCount.
Functions
Name | Description
nxAllocateHWnd | This is function Fmx.nxpvWindowHandle.nxAllocateHWnd.
nxDeallocateHWnd | This is function Fmx.nxpvWindowHandle.nxDeallocateHWnd.
nxDefWindowProc | This is function Fmx.nxpvWindowHandle.nxDefWindowProc.
Namespace

Fmx Namespace

Structs, Records, Enums
Name | Description
TnxInstanceBlock | This is record Fmx.nxpvWindowHandle.TnxInstanceBlock.
TnxObjectInstance | This is record Fmx.nxpvWindowHandle.TnxObjectInstance.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxInstanceBlock | This is type Fmx.nxpvWindowHandle.PnxInstanceBlock.
PnxObjectInstance | This is type Fmx.nxpvWindowHandle.PnxObjectInstance.
Variables
Name | Description
_InstBlockList | This is variable Fmx.nxpvWindowHandle._InstBlockList.
_InstFreeList | This is variable Fmx.nxpvWindowHandle._InstFreeList.
_InstPadlock | This is variable Fmx.nxpvWindowHandle._InstPadlock.
Msg | In R11 = Address of method pointer Out RAX = Result
nxUtilWindowClass | This is variable Fmx.nxpvWindowHandle.nxUtilWindowClass.
Links
Constants, Functions, Fmx Namespace, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions Fmx.nxpvWindowHandle Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxAllocateHWnd | This is function Fmx.nxpvWindowHandle.nxAllocateHWnd.
nxDeallocateHWnd | This is function Fmx.nxpvWindowHandle.nxDeallocateHWnd.
nxDefWindowProc | This is function Fmx.nxpvWindowHandle.nxDefWindowProc.
Namespace

Fmx.nxpvWindowHandle Namespace

Links
Functions, Fmx.nxpvWindowHandle Namespace, Legend


Fmx.nxpvWindowHandle.nxAllocateHWnd Function

Fmx.nxpvWindowHandle.nxAllocateHWnd Function
Fmx.nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
function nxAllocateHWnd(aMethod: TWndMethod): HWND;
File

Fmx.nxpvWindowHandle

Description

This is function Fmx.nxpvWindowHandle.nxAllocateHWnd.

Group

Functions

Links
Fmx.nxpvWindowHandle, Functions


Fmx.nxpvWindowHandle.nxDeallocateHWnd Function

Fmx.nxpvWindowHandle.nxDeallocateHWnd Function
Fmx.nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
procedure nxDeallocateHWnd(aWnd: HWND);
File

Fmx.nxpvWindowHandle

Description

This is function Fmx.nxpvWindowHandle.nxDeallocateHWnd.

Group

Functions

Links
Fmx.nxpvWindowHandle, Functions


Fmx.nxpvWindowHandle.nxDefWindowProc Function

Fmx.nxpvWindowHandle.nxDefWindowProc Function
Fmx.nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
function nxDefWindowProc(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): LRESULT; stdcall;
File

Fmx.nxpvWindowHandle

Description

This is function Fmx.nxpvWindowHandle.nxDefWindowProc.

Group

Functions

Links
Fmx.nxpvWindowHandle, Functions


Structs, Records, Enums

Structs, Records, Enums
Fmx.nxpvWindowHandle Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

Fmx.nxpvWindowHandle Namespace

Records
Name | Description
TnxInstanceBlock | This is record Fmx.nxpvWindowHandle.TnxInstanceBlock.
TnxObjectInstance | This is record Fmx.nxpvWindowHandle.TnxObjectInstance.
Links
Fmx.nxpvWindowHandle Namespace, Legend, Records


Fmx.nxpvWindowHandle.TnxInstanceBlock Record

Fmx.nxpvWindowHandle.TnxInstanceBlock Record
Fmx.nxpvWindowHandle Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInstanceBlock = packed record
  ibNext: PnxInstanceBlock;
  ibCode: array[1..CodeBytes] of Byte;
  ibWndProcPtr: Pointer;
  ibInstances: array[0..InstanceCount] of TnxObjectInstance;
end;
File

Fmx.nxpvWindowHandle

Description

This is record Fmx.nxpvWindowHandle.TnxInstanceBlock.

Group

Structs, Records, Enums

Links
Fmx.nxpvWindowHandle, Structs, Records, Enums


Fmx.nxpvWindowHandle.TnxObjectInstance Record

Fmx.nxpvWindowHandle.TnxObjectInstance Record
Fmx.nxpvWindowHandle Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxObjectInstance = packed record
  oiThreadID: Cardinal;
  oiCode: Byte;
  oiOffset: Integer;
  case Integer of
    0: (oiNext: PnxObjectInstance;);
    1: (oiMethod: TWndMethod;);
end;
File

Fmx.nxpvWindowHandle

Description

This is record Fmx.nxpvWindowHandle.TnxObjectInstance.

Group

Structs, Records, Enums

Links
Fmx.nxpvWindowHandle, Structs, Records, Enums


Types

Types
Fmx.nxpvWindowHandle Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

Fmx.nxpvWindowHandle Namespace

Types
Name | Description
PnxInstanceBlock | This is type Fmx.nxpvWindowHandle.PnxInstanceBlock.
PnxObjectInstance | This is type Fmx.nxpvWindowHandle.PnxObjectInstance.
Links
Fmx.nxpvWindowHandle Namespace, Types


Fmx.nxpvWindowHandle.PnxInstanceBlock Type

Fmx.nxpvWindowHandle.PnxInstanceBlock Type
Fmx.nxpvWindowHandle Types Send Feedback
Syntax
Delphi
PnxInstanceBlock = ^TnxInstanceBlock;
File

Fmx.nxpvWindowHandle

Description

This is type Fmx.nxpvWindowHandle.PnxInstanceBlock.

Group

Types

Links
Fmx.nxpvWindowHandle, Types


Fmx.nxpvWindowHandle.PnxObjectInstance Type

Fmx.nxpvWindowHandle.PnxObjectInstance Type
Fmx.nxpvWindowHandle Types Send Feedback
Syntax
Delphi
PnxObjectInstance = ^TnxObjectInstance;
File

Fmx.nxpvWindowHandle

Description

This is type Fmx.nxpvWindowHandle.PnxObjectInstance.

Group

Types

Links
Fmx.nxpvWindowHandle, Types


Variables

Variables
Fmx.nxpvWindowHandle Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

Fmx.nxpvWindowHandle Namespace

Variables
Name | Description
_InstBlockList | This is variable Fmx.nxpvWindowHandle._InstBlockList.
_InstFreeList | This is variable Fmx.nxpvWindowHandle._InstFreeList.
_InstPadlock | This is variable Fmx.nxpvWindowHandle._InstPadlock.
Msg | In R11 = Address of method pointer Out RAX = Result
nxUtilWindowClass | This is variable Fmx.nxpvWindowHandle.nxUtilWindowClass.
Links
Fmx.nxpvWindowHandle Namespace, Variables


Fmx.nxpvWindowHandle._InstBlockList Variable

Fmx.nxpvWindowHandle._InstBlockList Variable
Fmx.nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstBlockList: PnxInstanceBlock;
File

Fmx.nxpvWindowHandle

Description

This is variable Fmx.nxpvWindowHandle._InstBlockList.

Group

Variables

Links
Fmx.nxpvWindowHandle, Variables


Fmx.nxpvWindowHandle._InstFreeList Variable

Fmx.nxpvWindowHandle._InstFreeList Variable
Fmx.nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstFreeList: PnxObjectInstance;
File

Fmx.nxpvWindowHandle

Description

This is variable Fmx.nxpvWindowHandle._InstFreeList.

Group

Variables

Links
Fmx.nxpvWindowHandle, Variables


Fmx.nxpvWindowHandle._InstPadlock Variable

Fmx.nxpvWindowHandle._InstPadlock Variable
Fmx.nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstPadlock: TnxPadlock;
File

Fmx.nxpvWindowHandle

Description

This is variable Fmx.nxpvWindowHandle._InstPadlock.

Group

Variables

Links
Fmx.nxpvWindowHandle, Variables


Fmx.nxpvWindowHandle.Msg Variable

Fmx.nxpvWindowHandle.Msg Variable
Fmx.nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
Msg: TMessage;
File

Fmx.nxpvWindowHandle

Description

In R11 = Address of method pointer Out RAX = Result

Group

Variables

Links
Fmx.nxpvWindowHandle, Variables


Fmx.nxpvWindowHandle.nxUtilWindowClass Variable

Fmx.nxpvWindowHandle.nxUtilWindowClass Variable
Fmx.nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
nxUtilWindowClass: TWndClass = ( style: 0; lpfnWndProc: @nxDefWindowProc; cbClsExtra: 0; cbWndExtra: 0; hInstance: 0; hIcon: 0; hCursor: 0; hbrBackground: 0; lpszMenuName: nil; lpszClassName: 'nxUtilWindow');
File

Fmx.nxpvWindowHandle

Description

This is variable Fmx.nxpvWindowHandle.nxUtilWindowClass.

Group

Variables

Links
Fmx.nxpvWindowHandle, Variables


Constants

Constants
Constants Fmx.nxpvWindowHandle Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
CM_BASE | This is constant Fmx.nxpvWindowHandle.CM_BASE.
CM_RELEASE | This is constant Fmx.nxpvWindowHandle.CM_RELEASE.
CodeBytes | This is constant Fmx.nxpvWindowHandle.CodeBytes.
InstanceCount | This is constant Fmx.nxpvWindowHandle.InstanceCount.
Namespace

Fmx.nxpvWindowHandle Namespace

Links
Constants, Fmx.nxpvWindowHandle Namespace


Fmx.nxpvWindowHandle.CM_BASE Constant

Fmx.nxpvWindowHandle.CM_BASE Constant
Fmx.nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
CM_BASE = $B000;
File

Fmx.nxpvWindowHandle

Description

This is constant Fmx.nxpvWindowHandle.CM_BASE.

Group

Constants

Links
Fmx.nxpvWindowHandle, Constants


Fmx.nxpvWindowHandle.CM_RELEASE Constant

Fmx.nxpvWindowHandle.CM_RELEASE Constant
Fmx.nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
CM_RELEASE = CM_BASE + 33;
File

Fmx.nxpvWindowHandle

Description

This is constant Fmx.nxpvWindowHandle.CM_RELEASE.

Group

Constants

Links
Fmx.nxpvWindowHandle, Constants


Fmx.nxpvWindowHandle.CodeBytes Constant

Fmx.nxpvWindowHandle.CodeBytes Constant
Fmx.nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
CodeBytes = 8;
File

Fmx.nxpvWindowHandle

Description

This is constant Fmx.nxpvWindowHandle.CodeBytes.

Group

Constants

Links
Fmx.nxpvWindowHandle, Constants


Fmx.nxpvWindowHandle.InstanceCount Constant

Fmx.nxpvWindowHandle.InstanceCount Constant
Fmx.nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
InstanceCount = ((64 * 1024) - 64 ) div SizeOf(TnxObjectInstance);
File

Fmx.nxpvWindowHandle

Description

This is constant Fmx.nxpvWindowHandle.InstanceCount.

Group

Constants

Links
Fmx.nxpvWindowHandle, Constants


nxBaseServerComp Namespace

nxBaseServerComp Namespace
Classes Constants Legend Topics Types Send Feedback

.$DEFINE AlwaysSaveSettingsToFile

Classes
Name | Description
TnxBaseServer | A base server component that encapsulates generic server behavior and actions. This component on it own does nothing. Look TnxServerComp for a functioning descendant.
Constants
Name | Description
nxc_MainSettingsExtension | The default extension of the current server settings file
resscFileDoesNotExist | This is constant nxBaseServerComp.resscFileDoesNotExist.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TNotifyErrorEvent | The type used for error the error notification event.
TnxLoginCallback | This is the call back type for TnxBaseServer.OnShowLogin.
Links
Classes, Constants, Legend, Topics, Types


Classes

Classes
Classes nxBaseServerComp Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBaseServer | A base server component that encapsulates generic server behavior and actions. This component on it own does nothing. Look TnxServerComp for a functioning descendant.
Namespace

nxBaseServerComp Namespace

Links
Classes, nxBaseServerComp Namespace, Legend


TnxBaseServer Class

TnxBaseServer Class
TnxBaseServer Fields TnxBaseServer Methods TnxBaseServer Properties TnxBaseServer Events TnxBaseServer Members nxBaseServerComp Classes Send Feedback
Class Hierarchy
nxBaseServerComp_TnxBaseServernxBaseServerComp_TnxBaseServernxBaseServerComp_TnxBaseServernxBaseServerComp_TnxBaseServer
Syntax
Delphi
TnxBaseServer = class(TnxComponent);
File

nxBaseServerComp

Description

A base server component that encapsulates generic server behavior and actions. This component on it own does nothing. Look TnxServerComp for a functioning descendant.

Group

Classes

Links
TnxBaseServer Fields, TnxBaseServer Methods, TnxBaseServer Properties, TnxBaseServer Events, TnxBaseServer Members, nxBaseServerComp, Classes


TnxBaseServer Members

TnxBaseServer Members
TnxBaseServer Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBaseServer.

Class

TnxBaseServer Class

Protected Fields
Name | Description
bsAutoSaveConfig | This is bsAutoSaveConfig, a member of class TnxBaseServer.
bsErrors | This is bsErrors, a member of class TnxBaseServer.
bsIsSecure | This is bsIsSecure, a member of class TnxBaseServer.
bsLoginTries | This is bsLoginTries, a member of class TnxBaseServer.
bsLogonFailed | This is bsLogonFailed, a member of class TnxBaseServer.
bsMaxUserCount | This is bsMaxUserCount, a member of class TnxBaseServer.
bsOnError | This is bsOnError, a member of class TnxBaseServer.
bsOnLoginError | This is bsOnLoginError, a member of class TnxBaseServer.
bsOnShowLogin | This is bsOnShowLogin, a member of class TnxBaseServer.
bsPassword | This is bsPassword, a member of class TnxBaseServer.
bsServerConfig | This is bsServerConfig, a member of class TnxBaseServer.
bsServerConfigINI | This is bsServerConfigINI, a member of class TnxBaseServer.
bsServerEngine | This is bsServerEngine, a member of class TnxBaseServer.
bsServerName | This is bsServerName, a member of class TnxBaseServer.
bsSettingsFileName | This is bsSettingsFileName, a member of class TnxBaseServer.
bsSQLEngine | This is bsSQLEngine, a member of class TnxBaseServer.
bsUserName | This is bsUserName, a member of class TnxBaseServer.
ConvertLock | This is ConvertLock, a member of class TnxBaseServer.
MustConvert | This is MustConvert, a member of class TnxBaseServer.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
bsDoInitComponents |
bsDoLogin | This is bsDoLogin, a member of class TnxBaseServer.
bsGetSecureServer |
bsGetSecurityMonitor |
bsSetServerEngine | This is bsSetServerEngine, a member of class TnxBaseServer.
bsSetSqlEngine | This is bsSetSqlEngine, a member of class TnxBaseServer.
CheckValidServerEngine |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
Notification |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Methods
Name | Description
ActivateAll | Calling this method activates all components that are descendent on the server engine.
Authenticate | This function initiates a logon. If OnShowLogin is assigned it is called and the username/password validated. If it's ok the function returns true otherwise it tries again for up to aTries times. If the last try fails too it returns false.
BeforeDestruction | see TComponent.BeforeDestruction
ClearAllStats | As the name tells, this methods clears the stats of all dependent components.
ClearStats | Resets all internal stats.
Create | constructor.
DeActivateAll | Call this method to de-activate all components that are descendent on the server engine.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
HasSettings | This is HasSettings, a member of class TnxBaseServer.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettings | Calling this, stops all activated components, loads the settings from the specified file and re-starts the components.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettings | This methods saves the settings of ALL dependent components based on TnxComponent to the specified.
SaveSettingsToStream | Persists settings. (legacy V1)
StartStoppedModules | This method re-starts the components that where de-activated with StopStartedModules
StopStartedModules | Stops all activated modules and flags them to be re-startable by StartStoppedModules.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
SecureServer | Set this property to true if the server should enforce logins for the GUI and sessions that want to connect. Please make sure to have at least one Admin user in the user list of the SecurityMonitor otherwise the user gets locked out of the server GUI.
SecurityMonitor | This property returns the attached Security Monitor, if any. It does this by iterating through the dependents list of the server engine and returning the FIRST found instance derived from TnxAbstractSecurityMonitor.
SettingsFileName | This current settings filename.
Published Events
Name | Description
OnError | This event is triggered if an error occurs in the internal processing.
OnShowLogin | Assign an event handler here if you want to have your own input or check. If the default platform implementations unit is linked into the project, you don't need a handler for showing the ling dialog.
Published Properties
Name | Description
AutoSaveConfig | Set AutoSaveConfig to false if the configuration should not be saved on exit and re-loaded on startup. The default is true.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
IsServerActive | This is IsServerActive, a member of class TnxBaseServer.
LoginTries | Set the number of login tries possible. Only valid if SecureServer is active.
MaxUserCount | The number of users that are allowed to be logged on to the server at any time.
OnLoginError | This is triggered every time the Security Monitor tries to validate an invalid username/password configuration.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Password | This is the password for logging onto the GUI of the server. Only valid if SecureServer is active.
ServerConfiguration | This is ServerConfiguration, a member of class TnxBaseServer.
Username | This is the username for logging onto the GUI of the server. Only valid if SecureServer is active.
Version | Version of the component.
Links
TnxBaseServer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxBaseServer.Create Constructor

TnxBaseServer.Create Constructor
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Class Send Feedback
Syntax
Delphi
constructor Create(Sender: TComponent); override;
Description

constructor.

Class

TnxBaseServer Class

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Class


TnxBaseServer.Destroy Destructor

TnxBaseServer.Destroy Destructor
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseServer Class

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Class


TnxBaseServer Fields

TnxBaseServer Fields
TnxBaseServer Class Legend Protected Fields Send Feedback

The fields of the TnxBaseServer class are listed here.

Class

TnxBaseServer Class

Protected Fields
Name | Description
bsAutoSaveConfig | This is bsAutoSaveConfig, a member of class TnxBaseServer.
bsErrors | This is bsErrors, a member of class TnxBaseServer.
bsIsSecure | This is bsIsSecure, a member of class TnxBaseServer.
bsLoginTries | This is bsLoginTries, a member of class TnxBaseServer.
bsLogonFailed | This is bsLogonFailed, a member of class TnxBaseServer.
bsMaxUserCount | This is bsMaxUserCount, a member of class TnxBaseServer.
bsOnError | This is bsOnError, a member of class TnxBaseServer.
bsOnLoginError | This is bsOnLoginError, a member of class TnxBaseServer.
bsOnShowLogin | This is bsOnShowLogin, a member of class TnxBaseServer.
bsPassword | This is bsPassword, a member of class TnxBaseServer.
bsServerConfig | This is bsServerConfig, a member of class TnxBaseServer.
bsServerConfigINI | This is bsServerConfigINI, a member of class TnxBaseServer.
bsServerEngine | This is bsServerEngine, a member of class TnxBaseServer.
bsServerName | This is bsServerName, a member of class TnxBaseServer.
bsSettingsFileName | This is bsSettingsFileName, a member of class TnxBaseServer.
bsSQLEngine | This is bsSQLEngine, a member of class TnxBaseServer.
bsUserName | This is bsUserName, a member of class TnxBaseServer.
ConvertLock | This is ConvertLock, a member of class TnxBaseServer.
MustConvert | This is MustConvert, a member of class TnxBaseServer.
Links
TnxBaseServer Class, Legend, Protected Fields


TnxBaseServer.bsAutoSaveConfig Field

TnxBaseServer.bsAutoSaveConfig Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsAutoSaveConfig: Boolean;
Description

This is bsAutoSaveConfig, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsErrors Field

TnxBaseServer.bsErrors Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsErrors: string;
Description

This is bsErrors, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsIsSecure Field

TnxBaseServer.bsIsSecure Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsIsSecure: Boolean;
Description

This is bsIsSecure, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsLoginTries Field

TnxBaseServer.bsLoginTries Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsLoginTries: Integer;
Description

This is bsLoginTries, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsLogonFailed Field

TnxBaseServer.bsLogonFailed Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsLogonFailed: Boolean;
Description

This is bsLogonFailed, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsMaxUserCount Field

TnxBaseServer.bsMaxUserCount Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsMaxUserCount: integer;
Description

This is bsMaxUserCount, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsOnError Field

TnxBaseServer.bsOnError Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsOnError: TNotifyErrorEvent;
Description

This is bsOnError, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsOnLoginError Field

TnxBaseServer.bsOnLoginError Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsOnLoginError: TNotifyEvent;
Description

This is bsOnLoginError, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsOnShowLogin Field

TnxBaseServer.bsOnShowLogin Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsOnShowLogin: TnxLoginCallback;
Description

This is bsOnShowLogin, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsPassword Field

TnxBaseServer.bsPassword Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsPassword: UnicodeString;
Description

This is bsPassword, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsServerConfig Field

TnxBaseServer.bsServerConfig Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsServerConfig: TnxDBServerConfiguration;
Description

This is bsServerConfig, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsServerConfigINI Field

TnxBaseServer.bsServerConfigINI Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsServerConfigINI: TnxINIServerConfiguration;
Description

This is bsServerConfigINI, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsServerEngine Field

TnxBaseServer.bsServerEngine Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsServerEngine: TnxBaseServerEngine;
Description

This is bsServerEngine, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsServerName Field

TnxBaseServer.bsServerName Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsServerName: string;
Description

This is bsServerName, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsSettingsFileName Field

TnxBaseServer.bsSettingsFileName Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsSettingsFileName: string;
Description

This is bsSettingsFileName, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsSQLEngine Field

TnxBaseServer.bsSQLEngine Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsSQLEngine: TnxBaseSqlEngine;
Description

This is bsSQLEngine, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.bsUserName Field

TnxBaseServer.bsUserName Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
bsUserName: UnicodeString;
Description

This is bsUserName, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.ConvertLock Field

TnxBaseServer.ConvertLock Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
ConvertLock: TnxPadlock;
Description

This is ConvertLock, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer.MustConvert Field

TnxBaseServer.MustConvert Field
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Fields Send Feedback
Syntax
Delphi
MustConvert: boolean;
Description

This is MustConvert, a member of class TnxBaseServer.

Group

TnxBaseServer Fields

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Fields


TnxBaseServer Methods

TnxBaseServer Methods
TnxBaseServer Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseServer class are listed here.

Class

TnxBaseServer Class

Protected Methods
Name | Description
bsDoInitComponents |
bsDoLogin | This is bsDoLogin, a member of class TnxBaseServer.
bsGetSecureServer |
bsGetSecurityMonitor |
bsSetServerEngine | This is bsSetServerEngine, a member of class TnxBaseServer.
bsSetSqlEngine | This is bsSetSqlEngine, a member of class TnxBaseServer.
CheckValidServerEngine |
Notification |
nxcNotification |
Public Methods
Name | Description
ActivateAll | Calling this method activates all components that are descendent on the server engine.
Authenticate | This function initiates a logon. If OnShowLogin is assigned it is called and the username/password validated. If it's ok the function returns true otherwise it tries again for up to aTries times. If the last try fails too it returns false.
ClearAllStats | As the name tells, this methods clears the stats of all dependent components.
DeActivateAll | Call this method to de-activate all components that are descendent on the server engine.
HasSettings | This is HasSettings, a member of class TnxBaseServer.
LoadSettings | Calling this, stops all activated components, loads the settings from the specified file and re-starts the components.
SaveSettings | This methods saves the settings of ALL dependent components based on TnxComponent to the specified.
StartStoppedModules | This method re-starts the components that where de-activated with StopStartedModules
StopStartedModules | Stops all activated modules and flags them to be re-startable by StartStoppedModules.
Links
TnxBaseServer Class, Legend, Protected Methods, Public Methods


TnxBaseServer.ActivateAll Method

TnxBaseServer.ActivateAll Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure ActivateAll; virtual;
Description

Calling this method activates all components that are descendent on the server engine.

See Also

DeActivateAll, StartStoppedModules, StopStartedModules.

TnxBaseServer

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.Authenticate Method

TnxBaseServer.Authenticate Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
function Authenticate(aTries: Integer = 3; aForce: Boolean = False): Boolean;
Description

This function initiates a logon. If OnShowLogin is assigned it is called and the username/password validated. If it's ok the function returns true otherwise it tries again for up to aTries times. If the last try fails too it returns false.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.bsDoInitComponents Method

TnxBaseServer.bsDoInitComponents Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure bsDoInitComponents; virtual;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.bsDoLogin Method

TnxBaseServer.bsDoLogin Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
function bsDoLogin(aForce: Boolean): Boolean; virtual;
Description

This is bsDoLogin, a member of class TnxBaseServer.

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.bsGetSecureServer Method

TnxBaseServer.bsGetSecureServer Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
function bsGetSecureServer: Boolean; virtual;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.bsGetSecurityMonitor Method

TnxBaseServer.bsGetSecurityMonitor Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
function bsGetSecurityMonitor: TnxAbstractSecurityMonitor;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.bsSetServerEngine Method

TnxBaseServer.bsSetServerEngine Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure bsSetServerEngine(aServerEngine: TnxBaseServerEngine);
Description

This is bsSetServerEngine, a member of class TnxBaseServer.

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.bsSetSqlEngine Method

TnxBaseServer.bsSetSqlEngine Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure bsSetSqlEngine(aSqlEngine: TnxBaseSqlEngine);
Description

This is bsSetSqlEngine, a member of class TnxBaseServer.

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.CheckValidServerEngine Method

TnxBaseServer.CheckValidServerEngine Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure CheckValidServerEngine;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.ClearAllStats Method

TnxBaseServer.ClearAllStats Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure ClearAllStats;
Description

As the name tells, this methods clears the stats of all dependent components.

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.DeActivateAll Method

TnxBaseServer.DeActivateAll Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure DeActivateAll; virtual;
Description

Call this method to de-activate all components that are descendent on the server engine.

See Also

ActivateAll, StartStoppedModules, StopStartedModules

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.HasSettings Method

TnxBaseServer.HasSettings Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
function HasSettings(aFileName: string): Boolean; virtual;
Description

This is HasSettings, a member of class TnxBaseServer.

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.LoadSettings Method

TnxBaseServer.LoadSettings Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure LoadSettings(aFileName: string; aComponent: TnxComponent = nil); virtual;
Description

Calling this, stops all activated components, loads the settings from the specified file and re-starts the components.

See Also

LoadSettings, SaveSettings, AutoSaveConfig

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.Notification Method

TnxBaseServer.Notification Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.nxcNotification Method

TnxBaseServer.nxcNotification Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods


TnxBaseServer.SaveSettings Method

TnxBaseServer.SaveSettings Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure SaveSettings(aFileName: string; aComponent: TnxComponent = nil); virtual;
Description

This methods saves the settings of ALL dependent components based on TnxComponent to the specified.

See Also

LoadSettings, SaveSettings, AutoSaveConfig

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.StartStoppedModules Method

TnxBaseServer.StartStoppedModules Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure StartStoppedModules; virtual;
Description

This method re-starts the components that where de-activated with StopStartedModules

See Also

ActivateAll, DeActivateAll, StartStoppedModules, StopStartedModules

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer.StopStartedModules Method

TnxBaseServer.StopStartedModules Method
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Methods See Also Send Feedback
Syntax
Delphi
procedure StopStartedModules; virtual;
Description

Stops all activated modules and flags them to be re-startable by StartStoppedModules.

See Also

ActivateAll, DeActivateAll, StartStoppedModules, StopStartedModules

Group

TnxBaseServer Methods

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Methods, See Also


TnxBaseServer Properties

TnxBaseServer Properties
TnxBaseServer Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBaseServer class are listed here.

Class

TnxBaseServer Class

Public Properties
Name | Description
SecureServer | Set this property to true if the server should enforce logins for the GUI and sessions that want to connect. Please make sure to have at least one Admin user in the user list of the SecurityMonitor otherwise the user gets locked out of the server GUI.
SecurityMonitor | This property returns the attached Security Monitor, if any. It does this by iterating through the dependents list of the server engine and returning the FIRST found instance derived from TnxAbstractSecurityMonitor.
SettingsFileName | This current settings filename.
Published Properties
Name | Description
AutoSaveConfig | Set AutoSaveConfig to false if the configuration should not be saved on exit and re-loaded on startup. The default is true.
IsServerActive | This is IsServerActive, a member of class TnxBaseServer.
LoginTries | Set the number of login tries possible. Only valid if SecureServer is active.
MaxUserCount | The number of users that are allowed to be logged on to the server at any time.
OnLoginError | This is triggered every time the Security Monitor tries to validate an invalid username/password configuration.
Password | This is the password for logging onto the GUI of the server. Only valid if SecureServer is active.
ServerConfiguration | This is ServerConfiguration, a member of class TnxBaseServer.
Username | This is the username for logging onto the GUI of the server. Only valid if SecureServer is active.
Links
TnxBaseServer Class, Legend, Public Properties, Published Properties


TnxBaseServer.AutoSaveConfig Property

TnxBaseServer.AutoSaveConfig Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property AutoSaveConfig: Boolean;
Description

Set AutoSaveConfig to false if the configuration should not be saved on exit and re-loaded on startup. The default is true.

See Also

LoadSettings, SaveSettings, AutoSaveConfig

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.IsServerActive Property

TnxBaseServer.IsServerActive Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties Send Feedback
Syntax
Delphi
property IsServerActive: Boolean;
Description

This is IsServerActive, a member of class TnxBaseServer.

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties


TnxBaseServer.LoginTries Property

TnxBaseServer.LoginTries Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property LoginTries: Integer;
Description

Set the number of login tries possible. Only valid if SecureServer is active.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.MaxUserCount Property

TnxBaseServer.MaxUserCount Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties Send Feedback
Syntax
Delphi
property MaxUserCount: integer;
Description

The number of users that are allowed to be logged on to the server at any time.

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties


TnxBaseServer.OnLoginError Property

TnxBaseServer.OnLoginError Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property OnLoginError: TNotifyEvent;
Description

This is triggered every time the Security Monitor tries to validate an invalid username/password configuration.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.Password Property

TnxBaseServer.Password Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is the password for logging onto the GUI of the server. Only valid if SecureServer is active.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.SecureServer Property

TnxBaseServer.SecureServer Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property SecureServer: Boolean;
Description

Set this property to true if the server should enforce logins for the GUI and sessions that want to connect. Please make sure to have at least one Admin user in the user list of the SecurityMonitor otherwise the user gets locked out of the server GUI.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError , Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.SecurityMonitor Property

TnxBaseServer.SecurityMonitor Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property SecurityMonitor: TnxAbstractSecurityMonitor;
Description

This property returns the attached Security Monitor, if any. It does this by iterating through the dependents list of the server engine and returning the FIRST found instance derived from TnxAbstractSecurityMonitor.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.ServerConfiguration Property

TnxBaseServer.ServerConfiguration Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties Send Feedback
Syntax
Delphi
property ServerConfiguration: TnxBaseServerConfiguration;
Description

This is ServerConfiguration, a member of class TnxBaseServer.

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties


TnxBaseServer.SettingsFileName Property

TnxBaseServer.SettingsFileName Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property SettingsFileName: string;
Description

This current settings filename.

See Also

LoadSettings, SaveSettings, AutoSaveConfig

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer.Username Property

TnxBaseServer.Username Property
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Properties See Also Send Feedback
Syntax
Delphi
property Username: UnicodeString;
Description

This is the username for logging onto the GUI of the server. Only valid if SecureServer is active.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Properties

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Properties, See Also


TnxBaseServer Events

TnxBaseServer Events
TnxBaseServer Class Legend Published Events Send Feedback

The events of the TnxBaseServer class are listed here.

Class

TnxBaseServer Class

Published Events
Name | Description
OnError | This event is triggered if an error occurs in the internal processing.
OnShowLogin | Assign an event handler here if you want to have your own input or check. If the default platform implementations unit is linked into the project, you don't need a handler for showing the ling dialog.
Links
TnxBaseServer Class, Legend, Published Events


TnxBaseServer.OnError Event

TnxBaseServer.OnError Event
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Events Send Feedback
Syntax
Delphi
property OnError: TNotifyErrorEvent;
Description

This event is triggered if an error occurs in the internal processing.

Group

TnxBaseServer Events

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Events


TnxBaseServer.OnShowLogin Event

TnxBaseServer.OnShowLogin Event
TnxBaseServer Class TnxBaseServer Members nxBaseServerComp Namespace TnxBaseServer Events See Also Send Feedback
Syntax
Delphi
property OnShowLogin: TnxLoginCallback;
Description

Assign an event handler here if you want to have your own input or check. If the default platform implementations unit is linked into the project, you don't need a handler for showing the ling dialog.

See Also

SecureServer, SecurityMonitor, UserName, Password, LoginTries, OnShowLogin, OnLoginError, Authenticate

Group

TnxBaseServer Events

Links
TnxBaseServer Class, TnxBaseServer Members, nxBaseServerComp Namespace, TnxBaseServer Events, See Also


Types

Types
nxBaseServerComp Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxBaseServerComp Namespace

Types
Name | Description
TNotifyErrorEvent | The type used for error the error notification event.
TnxLoginCallback | This is the call back type for TnxBaseServer.OnShowLogin.
Links
nxBaseServerComp Namespace, Types


nxBaseServerComp.TNotifyErrorEvent Type

nxBaseServerComp.TNotifyErrorEvent Type
nxBaseServerComp Types Send Feedback
Syntax
Delphi
TNotifyErrorEvent = procedure (Sender: TObject; const anError: String) of object;
File

nxBaseServerComp

Description

The type used for error the error notification event.

Group

Types

Links
nxBaseServerComp, Types


nxBaseServerComp.TnxLoginCallback Type

nxBaseServerComp.TnxLoginCallback Type
nxBaseServerComp Types Send Feedback
Syntax
Delphi
TnxLoginCallback = procedure (aSender : TnxBaseServer; var aUserName : UnicodeString; var aPassword : UnicodeString) of object;
File

nxBaseServerComp

Parameters
Parameters | Description
aSender | the component that triggered the event
aUserName | the user name for logging on to the server, might be reinitialized.
aPassword | the fitting password
Description

This is the call back type for TnxBaseServer.OnShowLogin.

Group

Types

Links
nxBaseServerComp, Types


Constants

Constants
Constants nxBaseServerComp Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_MainSettingsExtension | The default extension of the current server settings file
resscFileDoesNotExist | This is constant nxBaseServerComp.resscFileDoesNotExist.
Namespace

nxBaseServerComp Namespace

Links
Constants, nxBaseServerComp Namespace


nxBaseServerComp.nxc_MainSettingsExtension Constant

nxBaseServerComp.nxc_MainSettingsExtension Constant
nxBaseServerComp Constants Send Feedback
Syntax
Delphi
nxc_MainSettingsExtension = '.nxdbworksettings';
File

nxBaseServerComp

Description

The default extension of the current server settings file

Group

Constants

Links
nxBaseServerComp, Constants


nxBaseServerComp.resscFileDoesNotExist Constant

nxBaseServerComp.resscFileDoesNotExist Constant
nxBaseServerComp Constants Send Feedback
Syntax
Delphi
resscFileDoesNotExist = 'Settings file "%s" does not exist';
File

nxBaseServerComp

Description

This is constant nxBaseServerComp.resscFileDoesNotExist.

Group

Constants

Links
nxBaseServerComp, Constants


nxCaptureOutput Namespace

nxCaptureOutput Namespace
Functions Legend Topics Send Feedback

This is namespace nxCaptureOutput.

Functions
Name | Description
nxCaptureConsoleOutput | based on code from http://www.delphi3000.com/articles/article_3361.asp
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Links
Functions, Legend, Topics


Functions

Functions
Functions nxCaptureOutput Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCaptureConsoleOutput | based on code from http://www.delphi3000.com/articles/article_3361.asp
Namespace

nxCaptureOutput Namespace

Links
Functions, nxCaptureOutput Namespace, Legend


nxCaptureOutput.nxCaptureConsoleOutput Function

nxCaptureOutput.nxCaptureConsoleOutput Function
nxCaptureOutput Functions Send Feedback
Syntax
Delphi
procedure nxCaptureConsoleOutput(DosApp: string; AStringList: TStrings);
File

nxCaptureOutput

Description

based on code from http://www.delphi3000.com/articles/article_3361.asp

Group

Functions

Links
nxCaptureOutput, Functions


nxchCommandHandler Namespace

nxchCommandHandler Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxchCommandHandler.

Classes
Name | Description
TnxServerCommandHandler | The main handler of messages from clients. Accepts messages delivered via transports and hands them off to a serverengine or other commandhandlers for processing.
Constants
Name | Description
cmBmKeyVar | This is constant nxchCommandHandler.cmBmKeyVar.
csAction | Logging constants
csAlias | This is constant nxchCommandHandler.csAlias.
csAliasType | This is constant nxchCommandHandler.csAliasType.
csAllLocks | This is constant nxchCommandHandler.csAllLocks.
csAutoInc | This is constant nxchCommandHandler.csAutoInc.
csBlobLength | This is constant nxchCommandHandler.csBlobLength.
csBlobNr | This is constant nxchCommandHandler.csBlobNr.
csBmDeleted | This is constant nxchCommandHandler.csBmDeleted.
csBmFill1 | This is constant nxchCommandHandler.csBmFill1.
csBmHash | This is constant nxchCommandHandler.csBmHash.
csBmIndexID | This is constant nxchCommandHandler.csBmIndexID.
csBmKey | This is constant nxchCommandHandler.csBmKey.
csBmKeyLen | This is constant nxchCommandHandler.csBmKeyLen.
csBmKeyValid | This is constant nxchCommandHandler.csBmKeyValid.
csBmPos | This is constant nxchCommandHandler.csBmPos.
csBmRefNr | This is constant nxchCommandHandler.csBmRefNr.
csBMSize | This is constant nxchCommandHandler.csBMSize.
csBookmark | This is constant nxchCommandHandler.csBookmark.
csBookmkSize | This is constant nxchCommandHandler.csBookmkSize.
csBytesRead | This is constant nxchCommandHandler.csBytesRead.
csCheckValFields | This is constant nxchCommandHandler.csCheckValFields.
csClientVersion | This is constant nxchCommandHandler.csClientVersion.
csCompRslt | This is constant nxchCommandHandler.csCompRslt.
csCursorID | This is constant nxchCommandHandler.csCursorID.
csDatabaseID | This is constant nxchCommandHandler.csDatabaseID.
csDestCurID | This is constant nxchCommandHandler.csDestCurID.
csDirectKey | This is constant nxchCommandHandler.csDirectKey.
csDirectKey1 | This is constant nxchCommandHandler.csDirectKey1.
csDirectKey2 | This is constant nxchCommandHandler.csDirectKey2.
csEnforce | This is constant nxchCommandHandler.csEnforce.
csErr | This is constant nxchCommandHandler.csErr.
csEstimate | This is constant nxchCommandHandler.csEstimate.
csExists | This is constant nxchCommandHandler.csExists.
csFailSafe | This is constant nxchCommandHandler.csFailSafe.
csField | This is constant nxchCommandHandler.csField.
csFieldNo | This is constant nxchCommandHandler.csFieldNo.
csFileName | This is constant nxchCommandHandler.csFileName.
csFilterID | This is constant nxchCommandHandler.csFilterID.
csFirstCall | This is constant nxchCommandHandler.csFirstCall.
csFldCount | This is constant nxchCommandHandler.csFldCount.
csFldCount1 | This is constant nxchCommandHandler.csFldCount1.
csFldCount2 | This is constant nxchCommandHandler.csFldCount2.
csForceRecheck | This is constant nxchCommandHandler.csForceRecheck.
csFreeSpace | This is constant nxchCommandHandler.csFreeSpace.
csIndexID | This is constant nxchCommandHandler.csIndexID.
csIndexName | This is constant nxchCommandHandler.csIndexName.
csKeyFilterID | This is constant nxchCommandHandler.csKeyFilterID.
csKeyIncl1 | This is constant nxchCommandHandler.csKeyIncl1.
csKeyIncl2 | This is constant nxchCommandHandler.csKeyIncl2.
csKeyLen1 | This is constant nxchCommandHandler.csKeyLen1.
csKeyLen2 | This is constant nxchCommandHandler.csKeyLen2.
csLen | This is constant nxchCommandHandler.csLen.
csLength | This is constant nxchCommandHandler.csLength.
csLockPrsnt | This is constant nxchCommandHandler.csLockPrsnt.
csLockType | This is constant nxchCommandHandler.csLockType.
csMatchFirst | This is constant nxchCommandHandler.csMatchFirst.
csMaxTransSz | This is constant nxchCommandHandler.csMaxTransSz.
csName | This is constant nxchCommandHandler.csName.
csNewCurID | This is constant nxchCommandHandler.csNewCurID.
csNewName | This is constant nxchCommandHandler.csNewName.
csNewPath | This is constant nxchCommandHandler.csNewPath.
csOffset | This is constant nxchCommandHandler.csOffset.
csOK |
csOldName | This is constant nxchCommandHandler.csOldName.
csOpenMode | This is constant nxchCommandHandler.csOpenMode.
csOption | This is constant nxchCommandHandler.csOption.
csOverwrite | This is constant nxchCommandHandler.csOverwrite.
csPartLen | This is constant nxchCommandHandler.csPartLen.
csPartLen1 | This is constant nxchCommandHandler.csPartLen1.
csPartLen2 | This is constant nxchCommandHandler.csPartLen2.
csPath | This is constant nxchCommandHandler.csPath.
csPosnOnRec | This is constant nxchCommandHandler.csPosnOnRec.
csQueryText | This is constant nxchCommandHandler.csQueryText.
csRaw | This is constant nxchCommandHandler.csRaw.
csReadOrg | This is constant nxchCommandHandler.csReadOrg.
csRecCount | This is constant nxchCommandHandler.csRecCount.
csRecNo | This is constant nxchCommandHandler.csRecNo.
csRecord | This is constant nxchCommandHandler.csRecord.
csRecordSize | This is constant nxchCommandHandler.csRecordSize.
csRecSize | This is constant nxchCommandHandler.csRecSize.
csReleaseLck | This is constant nxchCommandHandler.csReleaseLck.
csSessionID | This is constant nxchCommandHandler.csSessionID.
csShareMode | This is constant nxchCommandHandler.csShareMode.
csSnapshot | This is constant nxchCommandHandler.csSnapshot.
csSourceID | This is constant nxchCommandHandler.csSourceID.
csStatementID | This is constant nxchCommandHandler.csStatementID.
csSubEngine | This is constant nxchCommandHandler.csSubEngine.
csTableName | This is constant nxchCommandHandler.csTableName.
csTableScope | This is constant nxchCommandHandler.csTableScope.
csTargetDatabaseID | This is constant nxchCommandHandler.csTargetDatabaseID.
csTaskID | This is constant nxchCommandHandler.csTaskID.
csTimeout | This is constant nxchCommandHandler.csTimeout.
csTransContextID | This is constant nxchCommandHandler.csTransContextID.
csTransLvl | This is constant nxchCommandHandler.csTransLvl.
csUserID | This is constant nxchCommandHandler.csUserID.
csValue | This is constant nxchCommandHandler.csValue.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxchCommandHandler Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxServerCommandHandler | The main handler of messages from clients. Accepts messages delivered via transports and hands them off to a serverengine or other commandhandlers for processing.
Namespace

nxchCommandHandler Namespace

Links
Classes, nxchCommandHandler Namespace, Legend


TnxServerCommandHandler Class

TnxServerCommandHandler Class
TnxServerCommandHandler Fields TnxServerCommandHandler Methods TnxServerCommandHandler Properties TnxServerCommandHandler Members nxchCommandHandler Classes Send Feedback
Class Hierarchy
nxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandlernxchCommandHandler_TnxServerCommandHandler
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxServerCommandHandler = class(TnxBaseCommandHandler);
File

nxchCommandHandler

Description

The main handler of messages from clients. Accepts messages delivered via transports and hands them off to a serverengine or other commandhandlers for processing.

Group

Classes

Links
TnxServerCommandHandler Fields, TnxServerCommandHandler Methods, TnxServerCommandHandler Properties, TnxServerCommandHandler Members, nxchCommandHandler, Classes


TnxServerCommandHandler Members

TnxServerCommandHandler Members
TnxServerCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxServerCommandHandler.

Class

TnxServerCommandHandler Class

Protected Fields
Name | Description
bchPlugins | This is bchPlugins, a member of class TnxBaseCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
schMessageHandlers | This is schMessageHandlers, a member of class TnxServerCommandHandler.
schServerEngine | private
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bchAddSession | inherited client handling TnxServerCommandHandler
bchGetServerGuid |
bchGetServerName |
bchNotifyPluginsAddSession |
bchNotifyPluginsRemoveSession |
bchNotifyPluginsSessionFailed |
bchProcess |
bchRemoveSession |
bchSessionFailed |
chLogBookmark |
chLogInfo | This is the overview for the chLogInfo method overload.
chLogRecord |
chStatus | logging
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nmCursorAutoIncGet | autoinc
nmCursorAutoIncSet |
nmCursorBlobCreate | blob managment
nmCursorBlobCreate2 |
nmCursorBlobCreateFile |
nmCursorBlobCreateFile2 |
nmCursorBlobDelete |
nmCursorBlobDelete2 |
nmCursorBlobFree |
nmCursorBlobFree2 |
nmCursorBlobGetLength |
nmCursorBlobGetLength2 |
nmCursorBlobGetLengthEx |
nmCursorBlobRead |
nmCursorBlobRead2 |
nmCursorBlobTruncate |
nmCursorBlobTruncate2 |
nmCursorBlobWrite |
nmCursorBlobWrite2 |
nmCursorChangePassword |
nmCursorClose |
nmCursorCompareBookmarks |
nmCursorCompareKeys |
nmCursorCopyRecords |
nmCursorCopyRecordsEx |
nmCursorCreateInstanceFor | remoting integration
nmCursorDeleteRecords |
nmCursorDuplicate | misc
nmCursorFilterActivate |
nmCursorFilterAddCustom | filters
nmCursorFilterDeactivate |
nmCursorFilterRemove |
nmCursorFilterSetTimeout |
nmCursorGetBookmark | bookmarks
nmCursorGetIndexID |
nmCursorGetRecordCount | information
nmCursorGetRecordCountAsync |
nmCursorGetRecordCountEx |
nmCursorGetRecordCountExAsync |
nmCursorKeyFilterActivate |
nmCursorKeyFilterAddCustom | filters
nmCursorKeyFilterDeactivate |
nmCursorKeyFilterRemove |
nmCursorOptionClear | options
nmCursorOptionGet |
nmCursorOptionGetEffective |
nmCursorOptionList |
nmCursorOptionListEffective |
nmCursorOptionSet |
nmCursorRangeReset |
nmCursorRangeSet |
nmCursorRecNoGet | recno support
nmCursorRecNoSet |
nmCursorRecordDelete |
nmCursorRecordGet | record retrival
nmCursorRecordGetBatch | batch operations
nmCursorRecordGetBatch2 |
nmCursorRecordGetForKey |
nmCursorRecordGetNext |
nmCursorRecordGetPrior |
nmCursorRecordInsert | record manipulation
nmCursorRecordInsertBatch |
nmCursorRecordIsLocked | record locks
nmCursorRecordLockRelease |
nmCursorRecordModify |
nmCursorSetTimeout | general
nmCursorSetToBegin | == cursor == -- navigation
nmCursorSetToBookmark |
nmCursorSetToCursor |
nmCursorSetToEnd |
nmCursorSetToFilter |
nmCursorSetToKey |
nmCursorSwitchToIndex | index support
nmCursorSwitchToIndex3 |
nmCursorTableIsLocked | table locls
nmCursorTableLockAcquire |
nmCursorTableLockRelease |
nmCursorTableStreamDelete |
nmCursorTableStreamDelete3 |
nmCursorTableStreamGetList | table streams
nmCursorTableStreamGetList3 |
nmCursorTableStreamRead |
nmCursorTableStreamRead3 |
nmCursorTableStreamWrite |
nmDatabaseClose |
nmDatabaseCloseV1 |
nmDatabaseCreateInstanceFor | remoting integration
nmDatabaseCursorOpen | cursor
nmDatabaseCursorOpen2 |
nmDatabaseGetChangedTables |
nmDatabaseGetFreeSpace | info
nmDatabaseGetPath |
nmDatabaseGetPath3 |
nmDatabaseOptionClear | options
nmDatabaseOptionGet |
nmDatabaseOptionGetEffective |
nmDatabaseOptionList |
nmDatabaseOptionListEffective |
nmDatabaseOptionSet |
nmDatabaseSetTimeout | general
nmDatabaseStatementAlloc | statement
nmDatabaseStatementExecDirect |
nmDatabaseTableAddField |
nmDatabaseTableAddIndex |
nmDatabaseTableAutoIncGet |
nmDatabaseTableBackup |
nmDatabaseTableBuild | table managmenet
nmDatabaseTableChangePassword |
nmDatabaseTableDelete |
nmDatabaseTableDelete2 |
nmDatabaseTableDropIndex |
nmDatabaseTableDropIndex2 |
nmDatabaseTableEmpty |
nmDatabaseTableEmpty2 |
nmDatabaseTableExists | table information
nmDatabaseTableExists2 |
nmDatabaseTableGetDictionary |
nmDatabaseTableGetDictionary2 |
nmDatabaseTableGetList |
nmDatabaseTablePack |
nmDatabaseTablePack2 |
nmDatabaseTableRebuildIndex |
nmDatabaseTableRebuildIndex2 |
nmDatabaseTableRecover |
nmDatabaseTableRecover2 |
nmDatabaseTableRename |
nmDatabaseTableRename2 |
nmDatabaseTableRestructure |
nmDatabaseTableRestructure2 |
nmDatabaseTableVerifyChecksum |
nmDatabaseTransactionCommit |
nmDatabaseTransactionCorrupted |
nmDatabaseTransactionGetLevel |
nmDatabaseTransactionRollback |
nmDatabaseTransactionStart | == database == -- transaction management
nmDatabaseTransactionStartWith |
nmSessionAliasAdd | == session == -- alias handling
nmSessionAliasAdd3 |
nmSessionAliasDelete |
nmSessionAliasDelete3 |
nmSessionAliasGetList |
nmSessionAliasGetPath |
nmSessionAliasGetPath3 |
nmSessionAliasModify |
nmSessionAliasModify3 |
nmSessionCloseInactiveFolders | table/folder managment
nmSessionCloseInactiveTables |
nmSessionCreateInstanceFor | remoting integration
nmSessionDatabaseOpen | database managment
nmSessionDatabaseOpen2 |
nmSessionFailed |
nmSessionFailedPermanent |
nmSessionGetRegisteredClassList | engine managment
nmSessionOptionClear | options
nmSessionOptionGet |
nmSessionOptionGetEffective |
nmSessionOptionList |
nmSessionOptionListEffective |
nmSessionOptionSet |
nmSessionPasswordAdd | password management
nmSessionPasswordRemove |
nmSessionPasswordRemoveAll |
nmSessionSetTimeout | general
nmSessionTransContextCreate | transaction context managment
nmStatementClose |
nmStatementCreateInstanceFor | remoting integration
nmStatementExec |
nmStatementGetParams |
nmStatementOptionClear | options
nmStatementOptionGet |
nmStatementOptionGetEffective |
nmStatementOptionList |
nmStatementOptionListEffective |
nmStatementOptionSet |
nmStatementPrepare | statement
nmStatementSetParams |
nmStatementSetTimeout | general
nmTaskCancel |
nmTaskClose | general
nmTaskCreateInstanceFor | remoting integration
nmTaskGetStatus | task info
nmTaskGetStatus30500 |
nmTaskOptionClear | options
nmTaskOptionGet |
nmTaskOptionGetEffective |
nmTaskOptionList |
nmTaskOptionListEffective |
nmTaskOptionSet |
nmTransContextClose |
nmTransContextCreateInstanceFor | remoting integration
nmTransContextOptionClear | options
nmTransContextOptionGet |
nmTransContextOptionGetEffective |
nmTransContextOptionList |
nmTransContextOptionListEffective |
nmTransContextOptionSet |
nmTransContextSetTimeout | general
nmTransContextTransactionCommit |
nmTransContextTransactionCorrupted |
nmTransContextTransactionGetLevel |
nmTransContextTransactionRollback |
nmTransContextTransactionStart | == transaction context == -- transaction management
nmTransContextTransactionStartWith |
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
schDispatch |
schSetServerEngine |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create |
DefaultHandler |
Destroy | denstructor
Destroy | destructor
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UISettingsVisible | Result is always set to false, cause the command handler settings are never visible in the UI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | Set this property to the TnxServerEngine on your datamodule.
Version | Version of the component.
Links
TnxServerCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxServerCommandHandler.Create Constructor

TnxServerCommandHandler.Create Constructor
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxServerCommandHandler Class

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Class


TnxServerCommandHandler Fields

TnxServerCommandHandler Fields
TnxServerCommandHandler Class Legend Protected Fields Send Feedback

The fields of the TnxServerCommandHandler class are listed here.

Class

TnxServerCommandHandler Class

Protected Fields
Name | Description
schMessageHandlers | This is schMessageHandlers, a member of class TnxServerCommandHandler.
schServerEngine | private
Links
TnxServerCommandHandler Class, Legend, Protected Fields


TnxServerCommandHandler.schMessageHandlers Field

TnxServerCommandHandler.schMessageHandlers Field
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Fields Send Feedback
Syntax
Delphi
schMessageHandlers: array [$0000..$0FFF] of Pointer;
Description

This is schMessageHandlers, a member of class TnxServerCommandHandler.

Group

TnxServerCommandHandler Fields

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Fields


TnxServerCommandHandler.schServerEngine Field

TnxServerCommandHandler.schServerEngine Field
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Fields Send Feedback
Syntax
Delphi
schServerEngine: TnxBaseServerEngine;
Description

private

Group

TnxServerCommandHandler Fields

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Fields


TnxServerCommandHandler Methods

TnxServerCommandHandler Methods
TnxServerCommandHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxServerCommandHandler class are listed here.

Class

TnxServerCommandHandler Class

Protected Methods
Name | Description
bchAddSession | inherited client handling TnxServerCommandHandler
bchGetServerGuid |
bchGetServerName |
bchProcess |
bchRemoveSession |
bchSessionFailed |
chLogBookmark |
chLogInfo | This is the overview for the chLogInfo method overload.
chLogRecord |
chStatus | logging
nmCursorAutoIncGet | autoinc
nmCursorAutoIncSet |
nmCursorBlobCreate | blob managment
nmCursorBlobCreate2 |
nmCursorBlobCreateFile |
nmCursorBlobCreateFile2 |
nmCursorBlobDelete |
nmCursorBlobDelete2 |
nmCursorBlobFree |
nmCursorBlobFree2 |
nmCursorBlobGetLength |
nmCursorBlobGetLength2 |
nmCursorBlobGetLengthEx |
nmCursorBlobRead |
nmCursorBlobRead2 |
nmCursorBlobTruncate |
nmCursorBlobTruncate2 |
nmCursorBlobWrite |
nmCursorBlobWrite2 |
nmCursorChangePassword |
nmCursorClose |
nmCursorCompareBookmarks |
nmCursorCompareKeys |
nmCursorCopyRecords |
nmCursorCopyRecordsEx |
nmCursorCreateInstanceFor | remoting integration
nmCursorDeleteRecords |
nmCursorDuplicate | misc
nmCursorFilterActivate |
nmCursorFilterAddCustom | filters
nmCursorFilterDeactivate |
nmCursorFilterRemove |
nmCursorFilterSetTimeout |
nmCursorGetBookmark | bookmarks
nmCursorGetIndexID |
nmCursorGetRecordCount | information
nmCursorGetRecordCountAsync |
nmCursorGetRecordCountEx |
nmCursorGetRecordCountExAsync |
nmCursorKeyFilterActivate |
nmCursorKeyFilterAddCustom | filters
nmCursorKeyFilterDeactivate |
nmCursorKeyFilterRemove |
nmCursorOptionClear | options
nmCursorOptionGet |
nmCursorOptionGetEffective |
nmCursorOptionList |
nmCursorOptionListEffective |
nmCursorOptionSet |
nmCursorRangeReset |
nmCursorRangeSet |
nmCursorRecNoGet | recno support
nmCursorRecNoSet |
nmCursorRecordDelete |
nmCursorRecordGet | record retrival
nmCursorRecordGetBatch | batch operations
nmCursorRecordGetBatch2 |
nmCursorRecordGetForKey |
nmCursorRecordGetNext |
nmCursorRecordGetPrior |
nmCursorRecordInsert | record manipulation
nmCursorRecordInsertBatch |
nmCursorRecordIsLocked | record locks
nmCursorRecordLockRelease |
nmCursorRecordModify |
nmCursorSetTimeout | general
nmCursorSetToBegin | == cursor == -- navigation
nmCursorSetToBookmark |
nmCursorSetToCursor |
nmCursorSetToEnd |
nmCursorSetToFilter |
nmCursorSetToKey |
nmCursorSwitchToIndex | index support
nmCursorSwitchToIndex3 |
nmCursorTableIsLocked | table locls
nmCursorTableLockAcquire |
nmCursorTableLockRelease |
nmCursorTableStreamDelete |
nmCursorTableStreamDelete3 |
nmCursorTableStreamGetList | table streams
nmCursorTableStreamGetList3 |
nmCursorTableStreamRead |
nmCursorTableStreamRead3 |
nmCursorTableStreamWrite |
nmDatabaseClose |
nmDatabaseCloseV1 |
nmDatabaseCreateInstanceFor | remoting integration
nmDatabaseCursorOpen | cursor
nmDatabaseCursorOpen2 |
nmDatabaseGetChangedTables |
nmDatabaseGetFreeSpace | info
nmDatabaseGetPath |
nmDatabaseGetPath3 |
nmDatabaseOptionClear | options
nmDatabaseOptionGet |
nmDatabaseOptionGetEffective |
nmDatabaseOptionList |
nmDatabaseOptionListEffective |
nmDatabaseOptionSet |
nmDatabaseSetTimeout | general
nmDatabaseStatementAlloc | statement
nmDatabaseStatementExecDirect |
nmDatabaseTableAddField |
nmDatabaseTableAddIndex |
nmDatabaseTableAutoIncGet |
nmDatabaseTableBackup |
nmDatabaseTableBuild | table managmenet
nmDatabaseTableChangePassword |
nmDatabaseTableDelete |
nmDatabaseTableDelete2 |
nmDatabaseTableDropIndex |
nmDatabaseTableDropIndex2 |
nmDatabaseTableEmpty |
nmDatabaseTableEmpty2 |
nmDatabaseTableExists | table information
nmDatabaseTableExists2 |
nmDatabaseTableGetDictionary |
nmDatabaseTableGetDictionary2 |
nmDatabaseTableGetList |
nmDatabaseTablePack |
nmDatabaseTablePack2 |
nmDatabaseTableRebuildIndex |
nmDatabaseTableRebuildIndex2 |
nmDatabaseTableRecover |
nmDatabaseTableRecover2 |
nmDatabaseTableRename |
nmDatabaseTableRename2 |
nmDatabaseTableRestructure |
nmDatabaseTableRestructure2 |
nmDatabaseTableVerifyChecksum |
nmDatabaseTransactionCommit |
nmDatabaseTransactionCorrupted |
nmDatabaseTransactionGetLevel |
nmDatabaseTransactionRollback |
nmDatabaseTransactionStart | == database == -- transaction management
nmDatabaseTransactionStartWith |
nmSessionAliasAdd | == session == -- alias handling
nmSessionAliasAdd3 |
nmSessionAliasDelete |
nmSessionAliasDelete3 |
nmSessionAliasGetList |
nmSessionAliasGetPath |
nmSessionAliasGetPath3 |
nmSessionAliasModify |
nmSessionAliasModify3 |
nmSessionCloseInactiveFolders | table/folder managment
nmSessionCloseInactiveTables |
nmSessionCreateInstanceFor | remoting integration
nmSessionDatabaseOpen | database managment
nmSessionDatabaseOpen2 |
nmSessionFailed |
nmSessionFailedPermanent |
nmSessionGetRegisteredClassList | engine managment
nmSessionOptionClear | options
nmSessionOptionGet |
nmSessionOptionGetEffective |
nmSessionOptionList |
nmSessionOptionListEffective |
nmSessionOptionSet |
nmSessionPasswordAdd | password management
nmSessionPasswordRemove |
nmSessionPasswordRemoveAll |
nmSessionSetTimeout | general
nmSessionTransContextCreate | transaction context managment
nmStatementClose |
nmStatementCreateInstanceFor | remoting integration
nmStatementExec |
nmStatementGetParams |
nmStatementOptionClear | options
nmStatementOptionGet |
nmStatementOptionGetEffective |
nmStatementOptionList |
nmStatementOptionListEffective |
nmStatementOptionSet |
nmStatementPrepare | statement
nmStatementSetParams |
nmStatementSetTimeout | general
nmTaskCancel |
nmTaskClose | general
nmTaskCreateInstanceFor | remoting integration
nmTaskGetStatus | task info
nmTaskGetStatus30500 |
nmTaskOptionClear | options
nmTaskOptionGet |
nmTaskOptionGetEffective |
nmTaskOptionList |
nmTaskOptionListEffective |
nmTaskOptionSet |
nmTransContextClose |
nmTransContextCreateInstanceFor | remoting integration
nmTransContextOptionClear | options
nmTransContextOptionGet |
nmTransContextOptionGetEffective |
nmTransContextOptionList |
nmTransContextOptionListEffective |
nmTransContextOptionSet |
nmTransContextSetTimeout | general
nmTransContextTransactionCommit |
nmTransContextTransactionCorrupted |
nmTransContextTransactionGetLevel |
nmTransContextTransactionRollback |
nmTransContextTransactionStart | == transaction context == -- transaction management
nmTransContextTransactionStartWith |
nxcNotification |
schDispatch |
schSetServerEngine |
scIsStateParent |
Public Methods
Name | Description
DefaultHandler |
Links
TnxServerCommandHandler Class, Legend, Protected Methods, Public Methods


TnxServerCommandHandler.bchAddSession Method

TnxServerCommandHandler.bchAddSession Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function bchAddSession(aTransport: TnxBaseTransport; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: Integer; aClientVersion: Integer; out aSessionID: TnxSessionID; out aServerVersion: Integer): TnxResult; override;
Description

inherited client handling

TnxServerCommandHandler

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.bchGetServerGuid Method

TnxServerCommandHandler.bchGetServerGuid Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function bchGetServerGuid: TnxGuid; override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.bchGetServerName Method

TnxServerCommandHandler.bchGetServerName Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function bchGetServerName: string; override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.bchProcess Method

TnxServerCommandHandler.bchProcess Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchProcess(aMsg: PnxDataMessage); override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.bchRemoveSession Method

TnxServerCommandHandler.bchRemoveSession Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function bchRemoveSession(aTransport: TnxBaseTransport; aSessionID: TnxSessionID): TnxResult; override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.bchSessionFailed Method

TnxServerCommandHandler.bchSessionFailed Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchSessionFailed(aTransport: TnxBaseTransport; aSessionID: TnxSessionID); override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.chLogBookmark Method

TnxServerCommandHandler.chLogBookmark Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure chLogBookmark(aCursor: TnxAbstractCursor; const aBuffer; aBufferSize: Integer);
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


chLogInfo Method

chLogInfo Method
TnxServerCommandHandler Methods Send Feedback

This is the overview for the chLogInfo method overload.

Overload List
Name | Description
TnxServerCommandHandler.chLogInfo (array of string) |
TnxServerCommandHandler.chLogInfo (string) |
TnxServerCommandHandler.chLogInfo (string, , TnxMemSize) |
TnxServerCommandHandler.chLogInfo (string, array of const) |
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Methods


TnxServerCommandHandler.chLogInfo Method (array of string)

TnxServerCommandHandler.chLogInfo Method (array of string)
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace chLogInfo Method Send Feedback
Syntax
Delphi
procedure chLogInfo(const aMsgs: array of string); overload;
Group

chLogInfo Method

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, chLogInfo Method


TnxServerCommandHandler.chLogInfo Method (string)

TnxServerCommandHandler.chLogInfo Method (string)
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace chLogInfo Method Send Feedback
Syntax
Delphi
procedure chLogInfo(const aMsg: string); overload;
Group

chLogInfo Method

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, chLogInfo Method


TnxServerCommandHandler.chLogInfo Method (string, , TnxMemSize)

TnxServerCommandHandler.chLogInfo Method (string, , TnxMemSize)
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace chLogInfo Method Send Feedback
Syntax
Delphi
procedure chLogInfo(const aMsg: string; const aData; aDataLen: TnxMemSize); overload;
Group

chLogInfo Method

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, chLogInfo Method


TnxServerCommandHandler.chLogInfo Method (string, array of const)

TnxServerCommandHandler.chLogInfo Method (string, array of const)
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace chLogInfo Method Send Feedback
Syntax
Delphi
procedure chLogInfo(const aMsg: string; const aArgs: array of const); overload;
Group

chLogInfo Method

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, chLogInfo Method


TnxServerCommandHandler.chLogRecord Method

TnxServerCommandHandler.chLogRecord Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure chLogRecord(aCursor: TnxAbstractCursor; const aBuffer; aBufferSize: Integer);
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.chStatus Method

TnxServerCommandHandler.chStatus Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function chStatus(const ErrCode: TnxResult): Boolean;
Description

logging

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.DefaultHandler Method

TnxServerCommandHandler.DefaultHandler Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure DefaultHandler(var Message); override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorAutoIncGet Method

TnxServerCommandHandler.nmCursorAutoIncGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorAutoIncGet(var Msg: TnxDataMessage); message nxnmCursorAutoIncGet;
Description

autoinc

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorAutoIncSet Method

TnxServerCommandHandler.nmCursorAutoIncSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorAutoIncSet(var Msg: TnxDataMessage); message nxnmCursorAutoIncSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobCreate Method

TnxServerCommandHandler.nmCursorBlobCreate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobCreate(var Msg: TnxDataMessage); message nxnmCursorBlobCreate;
Description

blob managment

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobCreate2 Method

TnxServerCommandHandler.nmCursorBlobCreate2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobCreate2(var Msg: TnxDataMessage); message nxnmCursorBlobCreate2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobCreateFile Method

TnxServerCommandHandler.nmCursorBlobCreateFile Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobCreateFile(var Msg: TnxDataMessage); message nxnmCursorBlobCreateFile;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobCreateFile2 Method

TnxServerCommandHandler.nmCursorBlobCreateFile2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobCreateFile2(var Msg: TnxDataMessage); message nxnmCursorBlobCreateFile2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobDelete Method

TnxServerCommandHandler.nmCursorBlobDelete Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobDelete(var Msg: TnxDataMessage); message nxnmCursorBlobDelete;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobDelete2 Method

TnxServerCommandHandler.nmCursorBlobDelete2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobDelete2(var Msg: TnxDataMessage); message nxnmCursorBlobDelete2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobFree Method

TnxServerCommandHandler.nmCursorBlobFree Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobFree(var Msg: TnxDataMessage); message nxnmCursorBlobFree;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobFree2 Method

TnxServerCommandHandler.nmCursorBlobFree2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobFree2(var Msg: TnxDataMessage); message nxnmCursorBlobFree2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobGetLength Method

TnxServerCommandHandler.nmCursorBlobGetLength Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobGetLength(var Msg: TnxDataMessage); message nxnmCursorBlobGetLength;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobGetLength2 Method

TnxServerCommandHandler.nmCursorBlobGetLength2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobGetLength2(var Msg: TnxDataMessage); message nxnmCursorBlobGetLength2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobGetLengthEx Method

TnxServerCommandHandler.nmCursorBlobGetLengthEx Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobGetLengthEx(var Msg: TnxDataMessage); message nxnmCursorBlobGetLengthEx;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobRead Method

TnxServerCommandHandler.nmCursorBlobRead Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobRead(var Msg: TnxDataMessage); message nxnmCursorBlobRead;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobRead2 Method

TnxServerCommandHandler.nmCursorBlobRead2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobRead2(var Msg: TnxDataMessage); message nxnmCursorBlobRead2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobTruncate Method

TnxServerCommandHandler.nmCursorBlobTruncate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobTruncate(var Msg: TnxDataMessage); message nxnmCursorBlobTruncate;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobTruncate2 Method

TnxServerCommandHandler.nmCursorBlobTruncate2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobTruncate2(var Msg: TnxDataMessage); message nxnmCursorBlobTruncate2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobWrite Method

TnxServerCommandHandler.nmCursorBlobWrite Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobWrite(var Msg: TnxDataMessage); message nxnmCursorBlobWrite;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorBlobWrite2 Method

TnxServerCommandHandler.nmCursorBlobWrite2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorBlobWrite2(var Msg: TnxDataMessage); message nxnmCursorBlobWrite2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorChangePassword Method

TnxServerCommandHandler.nmCursorChangePassword Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorChangePassword(var Msg: TnxDataMessage); message nxnmCursorChangePassword;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorClose Method

TnxServerCommandHandler.nmCursorClose Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorClose(var Msg: TnxDataMessage); message nxnmCursorClose;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorCompareBookmarks Method

TnxServerCommandHandler.nmCursorCompareBookmarks Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorCompareBookmarks(var Msg: TnxDataMessage); message nxnmCursorCompareBookmarks;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorCompareKeys Method

TnxServerCommandHandler.nmCursorCompareKeys Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorCompareKeys(var Msg: TnxDataMessage); message nxnmCursorCompareKeys;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorCopyRecords Method

TnxServerCommandHandler.nmCursorCopyRecords Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorCopyRecords(var Msg: TnxDataMessage); message nxnmCursorCopyRecords;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorCopyRecordsEx Method

TnxServerCommandHandler.nmCursorCopyRecordsEx Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorCopyRecordsEx(var Msg: TnxDataMessage); message nxnmCursorCopyRecordsEx;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorCreateInstanceFor Method

TnxServerCommandHandler.nmCursorCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorCreateInstanceFor(var Msg: TnxDataMessage); message nxnmCursorCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorDeleteRecords Method

TnxServerCommandHandler.nmCursorDeleteRecords Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorDeleteRecords(var Msg: TnxDataMessage); message nxnmCursorDeleteRecords;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorDuplicate Method

TnxServerCommandHandler.nmCursorDuplicate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorDuplicate(var Msg: TnxDataMessage); message nxnmCursorDuplicate;
Description

misc

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorFilterActivate Method

TnxServerCommandHandler.nmCursorFilterActivate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorFilterActivate(var Msg: TnxDataMessage); message nxnmCursorFilterActivate;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorFilterAddCustom Method

TnxServerCommandHandler.nmCursorFilterAddCustom Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorFilterAddCustom(var Msg: TnxDataMessage); message nxnmCursorFilterAddCustom;
Description

filters

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorFilterDeactivate Method

TnxServerCommandHandler.nmCursorFilterDeactivate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorFilterDeactivate(var Msg: TnxDataMessage); message nxnmCursorFilterDeactivate;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorFilterRemove Method

TnxServerCommandHandler.nmCursorFilterRemove Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorFilterRemove(var Msg: TnxDataMessage); message nxnmCursorFilterRemove;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorFilterSetTimeout Method

TnxServerCommandHandler.nmCursorFilterSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorFilterSetTimeout(var Msg: TnxDataMessage); message nxnmCursorFilterSetTimeout;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetBookmark Method

TnxServerCommandHandler.nmCursorGetBookmark Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetBookmark(var Msg: TnxDataMessage); message nxnmCursorGetBookmark;
Description

bookmarks

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetIndexID Method

TnxServerCommandHandler.nmCursorGetIndexID Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetIndexID(var Msg: TnxDataMessage); message nxnmCursorGetIndexID;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetRecordCount Method

TnxServerCommandHandler.nmCursorGetRecordCount Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetRecordCount(var Msg: TnxDataMessage); message nxnmCursorGetRecordCount;
Description

information

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetRecordCountAsync Method

TnxServerCommandHandler.nmCursorGetRecordCountAsync Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetRecordCountAsync(var Msg: TnxDataMessage); message nxnmCursorGetRecordCountAsync;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetRecordCountEx Method

TnxServerCommandHandler.nmCursorGetRecordCountEx Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetRecordCountEx(var Msg: TnxDataMessage); message nxnmCursorGetRecordCountEx;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorGetRecordCountExAsync Method

TnxServerCommandHandler.nmCursorGetRecordCountExAsync Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorGetRecordCountExAsync(var Msg: TnxDataMessage); message nxnmCursorGetRecordCountExAsync;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorKeyFilterActivate Method

TnxServerCommandHandler.nmCursorKeyFilterActivate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorKeyFilterActivate(var Msg: TnxDataMessage); message nxnmCursorKeyFilterActivate;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorKeyFilterAddCustom Method

TnxServerCommandHandler.nmCursorKeyFilterAddCustom Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorKeyFilterAddCustom(var Msg: TnxDataMessage); message nxnmCursorKeyFilterAddCustom;
Description

filters

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorKeyFilterDeactivate Method

TnxServerCommandHandler.nmCursorKeyFilterDeactivate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorKeyFilterDeactivate(var Msg: TnxDataMessage); message nxnmCursorKeyFilterDeactivate;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorKeyFilterRemove Method

TnxServerCommandHandler.nmCursorKeyFilterRemove Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorKeyFilterRemove(var Msg: TnxDataMessage); message nxnmCursorKeyFilterRemove;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionClear Method

TnxServerCommandHandler.nmCursorOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionClear(var Msg: TnxDataMessage); message nxnmCursorOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionGet Method

TnxServerCommandHandler.nmCursorOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionGet(var Msg: TnxDataMessage); message nxnmCursorOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionGetEffective Method

TnxServerCommandHandler.nmCursorOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionGetEffective(var Msg: TnxDataMessage); message nxnmCursorOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionList Method

TnxServerCommandHandler.nmCursorOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionList(var Msg: TnxDataMessage); message nxnmCursorOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionListEffective Method

TnxServerCommandHandler.nmCursorOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionListEffective(var Msg: TnxDataMessage); message nxnmCursorOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorOptionSet Method

TnxServerCommandHandler.nmCursorOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorOptionSet(var Msg: TnxDataMessage); message nxnmCursorOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRangeReset Method

TnxServerCommandHandler.nmCursorRangeReset Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRangeReset(var Msg: TnxDataMessage); message nxnmCursorRangeReset;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRangeSet Method

TnxServerCommandHandler.nmCursorRangeSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRangeSet(var Msg: TnxDataMessage); message nxnmCursorRangeSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecNoGet Method

TnxServerCommandHandler.nmCursorRecNoGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecNoGet(var Msg: TnxDataMessage); message nxnmCursorRecNoGet;
Description

recno support

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecNoSet Method

TnxServerCommandHandler.nmCursorRecNoSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecNoSet(var Msg: TnxDataMessage); message nxnmCursorRecNoSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordDelete Method

TnxServerCommandHandler.nmCursorRecordDelete Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordDelete(var Msg: TnxDataMessage); message nxnmCursorRecordDelete;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGet Method

TnxServerCommandHandler.nmCursorRecordGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGet(var Msg: TnxDataMessage); message nxnmCursorRecordGet;
Description

record retrival

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGetBatch Method

TnxServerCommandHandler.nmCursorRecordGetBatch Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGetBatch(var Msg: TnxDataMessage); message nxnmCursorRecordGetBatch;
Description

batch operations

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGetBatch2 Method

TnxServerCommandHandler.nmCursorRecordGetBatch2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGetBatch2(var Msg: TnxDataMessage); message nxnmCursorRecordGetBatch2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGetForKey Method

TnxServerCommandHandler.nmCursorRecordGetForKey Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGetForKey(var Msg: TnxDataMessage); message nxnmCursorRecordGetForKey;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGetNext Method

TnxServerCommandHandler.nmCursorRecordGetNext Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGetNext(var Msg: TnxDataMessage); message nxnmCursorRecordGetNext;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordGetPrior Method

TnxServerCommandHandler.nmCursorRecordGetPrior Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordGetPrior(var Msg: TnxDataMessage); message nxnmCursorRecordGetPrior;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordInsert Method

TnxServerCommandHandler.nmCursorRecordInsert Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordInsert(var Msg: TnxDataMessage); message nxnmCursorRecordInsert;
Description

record manipulation

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordInsertBatch Method

TnxServerCommandHandler.nmCursorRecordInsertBatch Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordInsertBatch(var Msg: TnxDataMessage); message nxnmCursorRecordInsertBatch;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordIsLocked Method

TnxServerCommandHandler.nmCursorRecordIsLocked Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordIsLocked(var Msg: TnxDataMessage); message nxnmCursorRecordIsLocked;
Description

record locks

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordLockRelease Method

TnxServerCommandHandler.nmCursorRecordLockRelease Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordLockRelease(var Msg: TnxDataMessage); message nxnmCursorRecordLockRelease;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorRecordModify Method

TnxServerCommandHandler.nmCursorRecordModify Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorRecordModify(var Msg: TnxDataMessage); message nxnmCursorRecordModify;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetTimeout Method

TnxServerCommandHandler.nmCursorSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetTimeout(var Msg: TnxDataMessage); message nxnmCursorSetTimeout;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToBegin Method

TnxServerCommandHandler.nmCursorSetToBegin Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToBegin(var Msg: TnxDataMessage); message nxnmCursorSetToBegin;
Description

== cursor == -- navigation

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToBookmark Method

TnxServerCommandHandler.nmCursorSetToBookmark Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToBookmark(var Msg: TnxDataMessage); message nxnmCursorSetToBookmark;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToCursor Method

TnxServerCommandHandler.nmCursorSetToCursor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToCursor(var Msg: TnxDataMessage); message nxnmCursorSetToCursor;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToEnd Method

TnxServerCommandHandler.nmCursorSetToEnd Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToEnd(var Msg: TnxDataMessage); message nxnmCursorSetToEnd;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToFilter Method

TnxServerCommandHandler.nmCursorSetToFilter Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToFilter(var Msg: TnxDataMessage); message nxnmCursorSetToFilter;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSetToKey Method

TnxServerCommandHandler.nmCursorSetToKey Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSetToKey(var Msg: TnxDataMessage); message nxnmCursorSetToKey;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSwitchToIndex Method

TnxServerCommandHandler.nmCursorSwitchToIndex Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSwitchToIndex(var Msg: TnxDataMessage); message nxnmCursorSwitchToIndex;
Description

index support

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorSwitchToIndex3 Method

TnxServerCommandHandler.nmCursorSwitchToIndex3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorSwitchToIndex3(var Msg: TnxDataMessage); message nxnmCursorSwitchToIndex3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableIsLocked Method

TnxServerCommandHandler.nmCursorTableIsLocked Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableIsLocked(var Msg: TnxDataMessage); message nxnmCursorTableIsLocked;
Description

table locls

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableLockAcquire Method

TnxServerCommandHandler.nmCursorTableLockAcquire Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableLockAcquire(var Msg: TnxDataMessage); message nxnmCursorTableLockAcquire;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableLockRelease Method

TnxServerCommandHandler.nmCursorTableLockRelease Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableLockRelease(var Msg: TnxDataMessage); message nxnmCursorTableLockRelease;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamDelete Method

TnxServerCommandHandler.nmCursorTableStreamDelete Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamDelete(var Msg: TnxDataMessage); message nxnmCursorTableStreamDelete;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamDelete3 Method

TnxServerCommandHandler.nmCursorTableStreamDelete3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamDelete3(var Msg: TnxDataMessage); message nxnmCursorTableStreamDelete3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamGetList Method

TnxServerCommandHandler.nmCursorTableStreamGetList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamGetList(var Msg: TnxDataMessage); message nxnmCursorTableStreamGetList;
Description

table streams

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamGetList3 Method

TnxServerCommandHandler.nmCursorTableStreamGetList3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamGetList3(var Msg: TnxDataMessage); message nxnmCursorTableStreamGetList3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamRead Method

TnxServerCommandHandler.nmCursorTableStreamRead Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamRead(var Msg: TnxDataMessage); message nxnmCursorTableStreamRead;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamRead3 Method

TnxServerCommandHandler.nmCursorTableStreamRead3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamRead3(var Msg: TnxDataMessage); message nxnmCursorTableStreamRead3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmCursorTableStreamWrite Method

TnxServerCommandHandler.nmCursorTableStreamWrite Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmCursorTableStreamWrite(var Msg: TnxDataMessage); message nxnmCursorTableStreamWrite;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseClose Method

TnxServerCommandHandler.nmDatabaseClose Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseClose(var Msg: TnxDataMessage); message nxnmDatabaseClose;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseCloseV1 Method

TnxServerCommandHandler.nmDatabaseCloseV1 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseCloseV1(var Msg: TnxDataMessage); message nxnmDatabaseCloseV1;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseCreateInstanceFor Method

TnxServerCommandHandler.nmDatabaseCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseCreateInstanceFor(var Msg: TnxDataMessage); message nxnmDatabaseCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseCursorOpen Method

TnxServerCommandHandler.nmDatabaseCursorOpen Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseCursorOpen(var Msg: TnxDataMessage); message nxnmDatabaseCursorOpen;
Description

cursor

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseCursorOpen2 Method

TnxServerCommandHandler.nmDatabaseCursorOpen2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseCursorOpen2(var Msg: TnxDataMessage); message nxnmDatabaseCursorOpen2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseGetChangedTables Method

TnxServerCommandHandler.nmDatabaseGetChangedTables Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseGetChangedTables(var Msg: TnxDataMessage); message nxnmDatabaseGetChangedTables;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseGetFreeSpace Method

TnxServerCommandHandler.nmDatabaseGetFreeSpace Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseGetFreeSpace(var Msg: TnxDataMessage); message nxnmDatabaseGetFreeSpace;
Description

info

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseGetPath Method

TnxServerCommandHandler.nmDatabaseGetPath Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseGetPath(var Msg: TnxDataMessage); message nxnmDatabaseGetPath;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseGetPath3 Method

TnxServerCommandHandler.nmDatabaseGetPath3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseGetPath3(var Msg: TnxDataMessage); message nxnmDatabaseGetPath3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionClear Method

TnxServerCommandHandler.nmDatabaseOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionClear(var Msg: TnxDataMessage); message nxnmDatabaseOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionGet Method

TnxServerCommandHandler.nmDatabaseOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionGet(var Msg: TnxDataMessage); message nxnmDatabaseOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionGetEffective Method

TnxServerCommandHandler.nmDatabaseOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionGetEffective(var Msg: TnxDataMessage); message nxnmDatabaseOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionList Method

TnxServerCommandHandler.nmDatabaseOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionList(var Msg: TnxDataMessage); message nxnmDatabaseOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionListEffective Method

TnxServerCommandHandler.nmDatabaseOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionListEffective(var Msg: TnxDataMessage); message nxnmDatabaseOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseOptionSet Method

TnxServerCommandHandler.nmDatabaseOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseOptionSet(var Msg: TnxDataMessage); message nxnmDatabaseOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseSetTimeout Method

TnxServerCommandHandler.nmDatabaseSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseSetTimeout(var Msg: TnxDataMessage); message nxnmDatabaseSetTimeout;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseStatementAlloc Method

TnxServerCommandHandler.nmDatabaseStatementAlloc Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseStatementAlloc(var Msg: TnxDataMessage); message nxnmDatabaseStatementAlloc;
Description

statement

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseStatementExecDirect Method

TnxServerCommandHandler.nmDatabaseStatementExecDirect Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseStatementExecDirect(var Msg: TnxDataMessage); message nxnmDatabaseStatementExecDirect;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableAddField Method

TnxServerCommandHandler.nmDatabaseTableAddField Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableAddField(var Msg: TnxDataMessage); message nxnmDatabaseTableAddField;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableAddIndex Method

TnxServerCommandHandler.nmDatabaseTableAddIndex Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableAddIndex(var Msg: TnxDataMessage); message nxnmDatabaseTableAddIndex;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableAutoIncGet Method

TnxServerCommandHandler.nmDatabaseTableAutoIncGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableAutoIncGet(var Msg: TnxDataMessage); message nxnmDatabaseTableAutoIncGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableBackup Method

TnxServerCommandHandler.nmDatabaseTableBackup Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableBackup(var Msg: TnxDataMessage); message nxnmDatabaseTableBackup;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableBuild Method

TnxServerCommandHandler.nmDatabaseTableBuild Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableBuild(var Msg: TnxDataMessage); message nxnmDatabaseTableBuild;
Description

table managmenet

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableChangePassword Method

TnxServerCommandHandler.nmDatabaseTableChangePassword Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableChangePassword(var Msg: TnxDataMessage); message nxnmDatabaseTableChangePassword;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableDelete Method

TnxServerCommandHandler.nmDatabaseTableDelete Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableDelete(var Msg: TnxDataMessage); message nxnmDatabaseTableDelete;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableDelete2 Method

TnxServerCommandHandler.nmDatabaseTableDelete2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableDelete2(var Msg: TnxDataMessage); message nxnmDatabaseTableDelete2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableDropIndex Method

TnxServerCommandHandler.nmDatabaseTableDropIndex Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableDropIndex(var Msg: TnxDataMessage); message nxnmDatabaseTableDropIndex;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableDropIndex2 Method

TnxServerCommandHandler.nmDatabaseTableDropIndex2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableDropIndex2(var Msg: TnxDataMessage); message nxnmDatabaseTableDropIndex2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableEmpty Method

TnxServerCommandHandler.nmDatabaseTableEmpty Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableEmpty(var Msg: TnxDataMessage); message nxnmDatabaseTableEmpty;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableEmpty2 Method

TnxServerCommandHandler.nmDatabaseTableEmpty2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableEmpty2(var Msg: TnxDataMessage); message nxnmDatabaseTableEmpty2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableExists Method

TnxServerCommandHandler.nmDatabaseTableExists Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableExists(var Msg: TnxDataMessage); message nxnmDatabaseTableExists;
Description

table information

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableExists2 Method

TnxServerCommandHandler.nmDatabaseTableExists2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableExists2(var Msg: TnxDataMessage); message nxnmDatabaseTableExists2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableGetDictionary Method

TnxServerCommandHandler.nmDatabaseTableGetDictionary Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableGetDictionary(var Msg: TnxDataMessage); message nxnmDatabaseTableGetDictionary;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableGetDictionary2 Method

TnxServerCommandHandler.nmDatabaseTableGetDictionary2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableGetDictionary2(var Msg: TnxDataMessage); message nxnmDatabaseTableGetDictionary2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableGetList Method

TnxServerCommandHandler.nmDatabaseTableGetList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableGetList(var Msg: TnxDataMessage); message nxnmDatabaseTableGetList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTablePack Method

TnxServerCommandHandler.nmDatabaseTablePack Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTablePack(var Msg: TnxDataMessage); message nxnmDatabaseTablePack;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTablePack2 Method

TnxServerCommandHandler.nmDatabaseTablePack2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTablePack2(var Msg: TnxDataMessage); message nxnmDatabaseTablePack2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRebuildIndex Method

TnxServerCommandHandler.nmDatabaseTableRebuildIndex Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRebuildIndex(var Msg: TnxDataMessage); message nxnmDatabaseTableRebuildIndex;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRebuildIndex2 Method

TnxServerCommandHandler.nmDatabaseTableRebuildIndex2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRebuildIndex2(var Msg: TnxDataMessage); message nxnmDatabaseTableRebuildIndex2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRecover Method

TnxServerCommandHandler.nmDatabaseTableRecover Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRecover(var Msg: TnxDataMessage); message nxnmDatabaseTableRecover;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRecover2 Method

TnxServerCommandHandler.nmDatabaseTableRecover2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRecover2(var Msg: TnxDataMessage); message nxnmDatabaseTableRecover2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRename Method

TnxServerCommandHandler.nmDatabaseTableRename Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRename(var Msg: TnxDataMessage); message nxnmDatabaseTableRename;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRename2 Method

TnxServerCommandHandler.nmDatabaseTableRename2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRename2(var Msg: TnxDataMessage); message nxnmDatabaseTableRename2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRestructure Method

TnxServerCommandHandler.nmDatabaseTableRestructure Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRestructure(var Msg: TnxDataMessage); message nxnmDatabaseTableRestructure;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableRestructure2 Method

TnxServerCommandHandler.nmDatabaseTableRestructure2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableRestructure2(var Msg: TnxDataMessage); message nxnmDatabaseTableRestructure2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTableVerifyChecksum Method

TnxServerCommandHandler.nmDatabaseTableVerifyChecksum Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTableVerifyChecksum(var Msg: TnxDataMessage); message nxnmDatabaseTableVerifyChecksum;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionCommit Method

TnxServerCommandHandler.nmDatabaseTransactionCommit Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionCommit(var Msg: TnxDataMessage); message nxnmDatabaseTransactionCommit;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionCorrupted Method

TnxServerCommandHandler.nmDatabaseTransactionCorrupted Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionCorrupted(var Msg: TnxDataMessage); message nxnmDatabaseTransactionCorrupted;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionGetLevel Method

TnxServerCommandHandler.nmDatabaseTransactionGetLevel Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionGetLevel(var Msg: TnxDataMessage); message nxnmDatabaseTransactionGetLevel;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionRollback Method

TnxServerCommandHandler.nmDatabaseTransactionRollback Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionRollback(var Msg: TnxDataMessage); message nxnmDatabaseTransactionRollback;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionStart Method

TnxServerCommandHandler.nmDatabaseTransactionStart Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionStart(var Msg: TnxDataMessage); message nxnmDatabaseTransactionStart;
Description

== database == -- transaction management

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmDatabaseTransactionStartWith Method

TnxServerCommandHandler.nmDatabaseTransactionStartWith Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmDatabaseTransactionStartWith(var Msg: TnxDataMessage); message nxnmDatabaseTransactionStartWith;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasAdd Method

TnxServerCommandHandler.nmSessionAliasAdd Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasAdd(var Msg: TnxDataMessage); message nxnmSessionAliasAdd;
Description

== session == -- alias handling

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasAdd3 Method

TnxServerCommandHandler.nmSessionAliasAdd3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasAdd3(var Msg: TnxDataMessage); message nxnmSessionAliasAdd3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasDelete Method

TnxServerCommandHandler.nmSessionAliasDelete Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasDelete(var Msg: TnxDataMessage); message nxnmSessionAliasDelete;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasDelete3 Method

TnxServerCommandHandler.nmSessionAliasDelete3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasDelete3(var Msg: TnxDataMessage); message nxnmSessionAliasDelete3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasGetList Method

TnxServerCommandHandler.nmSessionAliasGetList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasGetList(var Msg: TnxDataMessage); message nxnmSessionAliasGetList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasGetPath Method

TnxServerCommandHandler.nmSessionAliasGetPath Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasGetPath(var Msg: TnxDataMessage); message nxnmSessionAliasGetPath;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasGetPath3 Method

TnxServerCommandHandler.nmSessionAliasGetPath3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasGetPath3(var Msg: TnxDataMessage); message nxnmSessionAliasGetPath3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasModify Method

TnxServerCommandHandler.nmSessionAliasModify Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasModify(var Msg: TnxDataMessage); message nxnmSessionAliasModify;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionAliasModify3 Method

TnxServerCommandHandler.nmSessionAliasModify3 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionAliasModify3(var Msg: TnxDataMessage); message nxnmSessionAliasModify3;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionCloseInactiveFolders Method

TnxServerCommandHandler.nmSessionCloseInactiveFolders Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionCloseInactiveFolders(var Msg: TnxDataMessage); message nxnmSessionCloseInactiveFolders;
Description

table/folder managment

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionCloseInactiveTables Method

TnxServerCommandHandler.nmSessionCloseInactiveTables Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionCloseInactiveTables(var Msg: TnxDataMessage); message nxnmSessionCloseInactiveTables;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionCreateInstanceFor Method

TnxServerCommandHandler.nmSessionCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionCreateInstanceFor(var Msg: TnxDataMessage); message nxnmSessionCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionDatabaseOpen Method

TnxServerCommandHandler.nmSessionDatabaseOpen Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionDatabaseOpen(var Msg: TnxDataMessage); message nxnmSessionDatabaseOpen;
Description

database managment

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionDatabaseOpen2 Method

TnxServerCommandHandler.nmSessionDatabaseOpen2 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionDatabaseOpen2(var Msg: TnxDataMessage); message nxnmSessionDatabaseOpen2;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionFailed Method

TnxServerCommandHandler.nmSessionFailed Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionFailed(var Msg: TnxDataMessage); message nxnmSessionFailed;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionFailedPermanent Method

TnxServerCommandHandler.nmSessionFailedPermanent Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionFailedPermanent(var Msg: TnxDataMessage); message nxnmSessionFailedPermanent;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionGetRegisteredClassList Method

TnxServerCommandHandler.nmSessionGetRegisteredClassList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionGetRegisteredClassList(var Msg: TnxDataMessage); message nxnmSessionGetRegisteredClassList;
Description

engine managment

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionClear Method

TnxServerCommandHandler.nmSessionOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionClear(var Msg: TnxDataMessage); message nxnmSessionOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionGet Method

TnxServerCommandHandler.nmSessionOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionGet(var Msg: TnxDataMessage); message nxnmSessionOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionGetEffective Method

TnxServerCommandHandler.nmSessionOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionGetEffective(var Msg: TnxDataMessage); message nxnmSessionOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionList Method

TnxServerCommandHandler.nmSessionOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionList(var Msg: TnxDataMessage); message nxnmSessionOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionListEffective Method

TnxServerCommandHandler.nmSessionOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionListEffective(var Msg: TnxDataMessage); message nxnmSessionOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionOptionSet Method

TnxServerCommandHandler.nmSessionOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionOptionSet(var Msg: TnxDataMessage); message nxnmSessionOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionPasswordAdd Method

TnxServerCommandHandler.nmSessionPasswordAdd Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionPasswordAdd(var Msg: TnxDataMessage); message nxnmSessionPasswordAdd;
Description

password management

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionPasswordRemove Method

TnxServerCommandHandler.nmSessionPasswordRemove Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionPasswordRemove(var Msg: TnxDataMessage); message nxnmSessionPasswordRemove;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionPasswordRemoveAll Method

TnxServerCommandHandler.nmSessionPasswordRemoveAll Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionPasswordRemoveAll(var Msg: TnxDataMessage); message nxnmSessionPasswordRemoveAll;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionSetTimeout Method

TnxServerCommandHandler.nmSessionSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionSetTimeout(var Msg: TnxDataMessage); message nxnmSessionSetTimeout;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmSessionTransContextCreate Method

TnxServerCommandHandler.nmSessionTransContextCreate Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmSessionTransContextCreate(var Msg: TnxDataMessage); message nxnmSessionTransContextCreate;
Description

transaction context managment

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementClose Method

TnxServerCommandHandler.nmStatementClose Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementClose(var Msg: TnxDataMessage); message nxnmStatementClose;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementCreateInstanceFor Method

TnxServerCommandHandler.nmStatementCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementCreateInstanceFor(var Msg: TnxDataMessage); message nxnmStatementCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementExec Method

TnxServerCommandHandler.nmStatementExec Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementExec(var Msg: TnxDataMessage); message nxnmStatementExec;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementGetParams Method

TnxServerCommandHandler.nmStatementGetParams Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementGetParams(var Msg: TnxDataMessage); message nxnmStatementGetParams;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionClear Method

TnxServerCommandHandler.nmStatementOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionClear(var Msg: TnxDataMessage); message nxnmStatementOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionGet Method

TnxServerCommandHandler.nmStatementOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionGet(var Msg: TnxDataMessage); message nxnmStatementOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionGetEffective Method

TnxServerCommandHandler.nmStatementOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionGetEffective(var Msg: TnxDataMessage); message nxnmStatementOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionList Method

TnxServerCommandHandler.nmStatementOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionList(var Msg: TnxDataMessage); message nxnmStatementOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionListEffective Method

TnxServerCommandHandler.nmStatementOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionListEffective(var Msg: TnxDataMessage); message nxnmStatementOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementOptionSet Method

TnxServerCommandHandler.nmStatementOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementOptionSet(var Msg: TnxDataMessage); message nxnmStatementOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementPrepare Method

TnxServerCommandHandler.nmStatementPrepare Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementPrepare(var Msg: TnxDataMessage); message nxnmStatementPrepare;
Description

statement

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementSetParams Method

TnxServerCommandHandler.nmStatementSetParams Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementSetParams(var Msg: TnxDataMessage); message nxnmStatementSetParams;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmStatementSetTimeout Method

TnxServerCommandHandler.nmStatementSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmStatementSetTimeout(var Msg: TnxDataMessage); message nxnmStatementSetTimeout;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskCancel Method

TnxServerCommandHandler.nmTaskCancel Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskCancel(var Msg: TnxDataMessage); message nxnmTaskCancel;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskClose Method

TnxServerCommandHandler.nmTaskClose Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskClose(var Msg: TnxDataMessage); message nxnmTaskClose;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskCreateInstanceFor Method

TnxServerCommandHandler.nmTaskCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskCreateInstanceFor(var Msg: TnxDataMessage); message nxnmTaskCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskGetStatus Method

TnxServerCommandHandler.nmTaskGetStatus Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskGetStatus(var Msg: TnxDataMessage); message nxnmTaskGetStatus;
Description

task info

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskGetStatus30500 Method

TnxServerCommandHandler.nmTaskGetStatus30500 Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskGetStatus30500(var Msg: TnxDataMessage); message nxnmTaskGetStatus30500;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionClear Method

TnxServerCommandHandler.nmTaskOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionClear(var Msg: TnxDataMessage); message nxnmTaskOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionGet Method

TnxServerCommandHandler.nmTaskOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionGet(var Msg: TnxDataMessage); message nxnmTaskOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionGetEffective Method

TnxServerCommandHandler.nmTaskOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionGetEffective(var Msg: TnxDataMessage); message nxnmTaskOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionList Method

TnxServerCommandHandler.nmTaskOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionList(var Msg: TnxDataMessage); message nxnmTaskOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionListEffective Method

TnxServerCommandHandler.nmTaskOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionListEffective(var Msg: TnxDataMessage); message nxnmTaskOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTaskOptionSet Method

TnxServerCommandHandler.nmTaskOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTaskOptionSet(var Msg: TnxDataMessage); message nxnmTaskOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextClose Method

TnxServerCommandHandler.nmTransContextClose Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextClose(var Msg: TnxDataMessage); message nxnmTransContextClose;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextCreateInstanceFor Method

TnxServerCommandHandler.nmTransContextCreateInstanceFor Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextCreateInstanceFor(var Msg: TnxDataMessage); message nxnmTransContextCreateInstanceFor;
Description

remoting integration

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionClear Method

TnxServerCommandHandler.nmTransContextOptionClear Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionClear(var Msg: TnxDataMessage); message nxnmTransContextOptionClear;
Description

options

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionGet Method

TnxServerCommandHandler.nmTransContextOptionGet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionGet(var Msg: TnxDataMessage); message nxnmTransContextOptionGet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionGetEffective Method

TnxServerCommandHandler.nmTransContextOptionGetEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionGetEffective(var Msg: TnxDataMessage); message nxnmTransContextOptionGetEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionList Method

TnxServerCommandHandler.nmTransContextOptionList Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionList(var Msg: TnxDataMessage); message nxnmTransContextOptionList;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionListEffective Method

TnxServerCommandHandler.nmTransContextOptionListEffective Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionListEffective(var Msg: TnxDataMessage); message nxnmTransContextOptionListEffective;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextOptionSet Method

TnxServerCommandHandler.nmTransContextOptionSet Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextOptionSet(var Msg: TnxDataMessage); message nxnmTransContextOptionSet;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextSetTimeout Method

TnxServerCommandHandler.nmTransContextSetTimeout Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextSetTimeout(var Msg: TnxDataMessage); message nxnmTransContextSetTimeout;
Description

general

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionCommit Method

TnxServerCommandHandler.nmTransContextTransactionCommit Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionCommit(var Msg: TnxDataMessage); message nxnmTransContextTransactionCommit;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionCorrupted Method

TnxServerCommandHandler.nmTransContextTransactionCorrupted Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionCorrupted(var Msg: TnxDataMessage); message nxnmTransContextTransactionCorrupted;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionGetLevel Method

TnxServerCommandHandler.nmTransContextTransactionGetLevel Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionGetLevel(var Msg: TnxDataMessage); message nxnmTransContextTransactionGetLevel;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionRollback Method

TnxServerCommandHandler.nmTransContextTransactionRollback Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionRollback(var Msg: TnxDataMessage); message nxnmTransContextTransactionRollback;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionStart Method

TnxServerCommandHandler.nmTransContextTransactionStart Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionStart(var Msg: TnxDataMessage); message nxnmTransContextTransactionStart;
Description

== transaction context == -- transaction management

Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nmTransContextTransactionStartWith Method

TnxServerCommandHandler.nmTransContextTransactionStartWith Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmTransContextTransactionStartWith(var Msg: TnxDataMessage); message nxnmTransContextTransactionStartWith;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.nxcNotification Method

TnxServerCommandHandler.nxcNotification Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.schDispatch Method

TnxServerCommandHandler.schDispatch Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure schDispatch(var Message); register;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.schSetServerEngine Method

TnxServerCommandHandler.schSetServerEngine Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
procedure schSetServerEngine(anEngine: TnxBaseServerEngine); virtual;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler.scIsStateParent Method

TnxServerCommandHandler.scIsStateParent Method
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxServerCommandHandler Methods

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Methods


TnxServerCommandHandler Properties

TnxServerCommandHandler Properties
TnxServerCommandHandler Class Legend Published Properties Send Feedback

The properties of the TnxServerCommandHandler class are listed here.

Class

TnxServerCommandHandler Class

Published Properties
Name | Description
ServerEngine | Set this property to the TnxServerEngine on your datamodule.
Links
TnxServerCommandHandler Class, Legend, Published Properties


TnxServerCommandHandler.ServerEngine Property

TnxServerCommandHandler.ServerEngine Property
TnxServerCommandHandler Class TnxServerCommandHandler Members nxchCommandHandler Namespace TnxServerCommandHandler Properties See Also Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

Set this property to the TnxServerEngine on your datamodule.

See Also

TnxServerEngine

Group

TnxServerCommandHandler Properties

Links
TnxServerCommandHandler Class, TnxServerCommandHandler Members, nxchCommandHandler Namespace, TnxServerCommandHandler Properties, See Also


Constants

Constants
Constants nxchCommandHandler Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cmBmKeyVar | This is constant nxchCommandHandler.cmBmKeyVar.
csAction | Logging constants
csAlias | This is constant nxchCommandHandler.csAlias.
csAliasType | This is constant nxchCommandHandler.csAliasType.
csAllLocks | This is constant nxchCommandHandler.csAllLocks.
csAutoInc | This is constant nxchCommandHandler.csAutoInc.
csBlobLength | This is constant nxchCommandHandler.csBlobLength.
csBlobNr | This is constant nxchCommandHandler.csBlobNr.
csBmDeleted | This is constant nxchCommandHandler.csBmDeleted.
csBmFill1 | This is constant nxchCommandHandler.csBmFill1.
csBmHash | This is constant nxchCommandHandler.csBmHash.
csBmIndexID | This is constant nxchCommandHandler.csBmIndexID.
csBmKey | This is constant nxchCommandHandler.csBmKey.
csBmKeyLen | This is constant nxchCommandHandler.csBmKeyLen.
csBmKeyValid | This is constant nxchCommandHandler.csBmKeyValid.
csBmPos | This is constant nxchCommandHandler.csBmPos.
csBmRefNr | This is constant nxchCommandHandler.csBmRefNr.
csBMSize | This is constant nxchCommandHandler.csBMSize.
csBookmark | This is constant nxchCommandHandler.csBookmark.
csBookmkSize | This is constant nxchCommandHandler.csBookmkSize.
csBytesRead | This is constant nxchCommandHandler.csBytesRead.
csCheckValFields | This is constant nxchCommandHandler.csCheckValFields.
csClientVersion | This is constant nxchCommandHandler.csClientVersion.
csCompRslt | This is constant nxchCommandHandler.csCompRslt.
csCursorID | This is constant nxchCommandHandler.csCursorID.
csDatabaseID | This is constant nxchCommandHandler.csDatabaseID.
csDestCurID | This is constant nxchCommandHandler.csDestCurID.
csDirectKey | This is constant nxchCommandHandler.csDirectKey.
csDirectKey1 | This is constant nxchCommandHandler.csDirectKey1.
csDirectKey2 | This is constant nxchCommandHandler.csDirectKey2.
csEnforce | This is constant nxchCommandHandler.csEnforce.
csErr | This is constant nxchCommandHandler.csErr.
csEstimate | This is constant nxchCommandHandler.csEstimate.
csExists | This is constant nxchCommandHandler.csExists.
csFailSafe | This is constant nxchCommandHandler.csFailSafe.
csField | This is constant nxchCommandHandler.csField.
csFieldNo | This is constant nxchCommandHandler.csFieldNo.
csFileName | This is constant nxchCommandHandler.csFileName.
csFilterID | This is constant nxchCommandHandler.csFilterID.
csFirstCall | This is constant nxchCommandHandler.csFirstCall.
csFldCount | This is constant nxchCommandHandler.csFldCount.
csFldCount1 | This is constant nxchCommandHandler.csFldCount1.
csFldCount2 | This is constant nxchCommandHandler.csFldCount2.
csForceRecheck | This is constant nxchCommandHandler.csForceRecheck.
csFreeSpace | This is constant nxchCommandHandler.csFreeSpace.
csIndexID | This is constant nxchCommandHandler.csIndexID.
csIndexName | This is constant nxchCommandHandler.csIndexName.
csKeyFilterID | This is constant nxchCommandHandler.csKeyFilterID.
csKeyIncl1 | This is constant nxchCommandHandler.csKeyIncl1.
csKeyIncl2 | This is constant nxchCommandHandler.csKeyIncl2.
csKeyLen1 | This is constant nxchCommandHandler.csKeyLen1.
csKeyLen2 | This is constant nxchCommandHandler.csKeyLen2.
csLen | This is constant nxchCommandHandler.csLen.
csLength | This is constant nxchCommandHandler.csLength.
csLockPrsnt | This is constant nxchCommandHandler.csLockPrsnt.
csLockType | This is constant nxchCommandHandler.csLockType.
csMatchFirst | This is constant nxchCommandHandler.csMatchFirst.
csMaxTransSz | This is constant nxchCommandHandler.csMaxTransSz.
csName | This is constant nxchCommandHandler.csName.
csNewCurID | This is constant nxchCommandHandler.csNewCurID.
csNewName | This is constant nxchCommandHandler.csNewName.
csNewPath | This is constant nxchCommandHandler.csNewPath.
csOffset | This is constant nxchCommandHandler.csOffset.
csOK |
csOldName | This is constant nxchCommandHandler.csOldName.
csOpenMode | This is constant nxchCommandHandler.csOpenMode.
csOption | This is constant nxchCommandHandler.csOption.
csOverwrite | This is constant nxchCommandHandler.csOverwrite.
csPartLen | This is constant nxchCommandHandler.csPartLen.
csPartLen1 | This is constant nxchCommandHandler.csPartLen1.
csPartLen2 | This is constant nxchCommandHandler.csPartLen2.
csPath | This is constant nxchCommandHandler.csPath.
csPosnOnRec | This is constant nxchCommandHandler.csPosnOnRec.
csQueryText | This is constant nxchCommandHandler.csQueryText.
csRaw | This is constant nxchCommandHandler.csRaw.
csReadOrg | This is constant nxchCommandHandler.csReadOrg.
csRecCount | This is constant nxchCommandHandler.csRecCount.
csRecNo | This is constant nxchCommandHandler.csRecNo.
csRecord | This is constant nxchCommandHandler.csRecord.
csRecordSize | This is constant nxchCommandHandler.csRecordSize.
csRecSize | This is constant nxchCommandHandler.csRecSize.
csReleaseLck | This is constant nxchCommandHandler.csReleaseLck.
csSessionID | This is constant nxchCommandHandler.csSessionID.
csShareMode | This is constant nxchCommandHandler.csShareMode.
csSnapshot | This is constant nxchCommandHandler.csSnapshot.
csSourceID | This is constant nxchCommandHandler.csSourceID.
csStatementID | This is constant nxchCommandHandler.csStatementID.
csSubEngine | This is constant nxchCommandHandler.csSubEngine.
csTableName | This is constant nxchCommandHandler.csTableName.
csTableScope | This is constant nxchCommandHandler.csTableScope.
csTargetDatabaseID | This is constant nxchCommandHandler.csTargetDatabaseID.
csTaskID | This is constant nxchCommandHandler.csTaskID.
csTimeout | This is constant nxchCommandHandler.csTimeout.
csTransContextID | This is constant nxchCommandHandler.csTransContextID.
csTransLvl | This is constant nxchCommandHandler.csTransLvl.
csUserID | This is constant nxchCommandHandler.csUserID.
csValue | This is constant nxchCommandHandler.csValue.
Namespace

nxchCommandHandler Namespace

Links
Constants, nxchCommandHandler Namespace


nxchCommandHandler.cmBmKeyVar Constant

nxchCommandHandler.cmBmKeyVar Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
cmBmKeyVar = ' Decoded:[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.cmBmKeyVar.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csAction Constant

nxchCommandHandler.csAction Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csAction = ' Action [%s]';
File

nxchCommandHandler

Description

Logging constants

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csAlias Constant

nxchCommandHandler.csAlias Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csAlias = ' Alias [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csAlias.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csAliasType Constant

nxchCommandHandler.csAliasType Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csAliasType = ' AliasType [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csAliasType.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csAllLocks Constant

nxchCommandHandler.csAllLocks Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csAllLocks = ' AllLocks [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csAllLocks.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csAutoInc Constant

nxchCommandHandler.csAutoInc Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csAutoInc = ' AutoInc [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csAutoInc.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBlobLength Constant

nxchCommandHandler.csBlobLength Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBlobLength = ' BlobLength[%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBlobLength.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBlobNr Constant

nxchCommandHandler.csBlobNr Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBlobNr = ' BlobNr [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBlobNr.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmDeleted Constant

nxchCommandHandler.csBmDeleted Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmDeleted = ' bmDeleted [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmDeleted.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmFill1 Constant

nxchCommandHandler.csBmFill1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmFill1 = ' bmFill1 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmFill1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmHash Constant

nxchCommandHandler.csBmHash Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmHash = ' bmHash [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmHash.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmIndexID Constant

nxchCommandHandler.csBmIndexID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmIndexID = ' bmIndexID [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmIndexID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmKey Constant

nxchCommandHandler.csBmKey Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmKey = ' bmKey';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmKey.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmKeyLen Constant

nxchCommandHandler.csBmKeyLen Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmKeyLen = ' bmKeyLen [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmKeyLen.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmKeyValid Constant

nxchCommandHandler.csBmKeyValid Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmKeyValid = ' bmKeyValid[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmKeyValid.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmPos Constant

nxchCommandHandler.csBmPos Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmPos = ' bmPos [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmPos.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBmRefNr Constant

nxchCommandHandler.csBmRefNr Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBmRefNr = ' bmRefNr [%d -> %d:%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBmRefNr.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBMSize Constant

nxchCommandHandler.csBMSize Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBMSize = ' BMSize [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBMSize.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBookmark Constant

nxchCommandHandler.csBookmark Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBookmark = ' Bookmark';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBookmark.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBookmkSize Constant

nxchCommandHandler.csBookmkSize Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBookmkSize = ' BookmkSize[%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBookmkSize.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csBytesRead Constant

nxchCommandHandler.csBytesRead Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csBytesRead = ' BytesRead [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csBytesRead.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csCheckValFields Constant

nxchCommandHandler.csCheckValFields Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csCheckValFields = ' ChkValFld [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csCheckValFields.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csClientVersion Constant

nxchCommandHandler.csClientVersion Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csClientVersion = ' ClientVers[%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csClientVersion.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csCompRslt Constant

nxchCommandHandler.csCompRslt Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csCompRslt = ' CompRslt [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csCompRslt.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csCursorID Constant

nxchCommandHandler.csCursorID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csCursorID = ' CursorID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csCursorID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csDatabaseID Constant

nxchCommandHandler.csDatabaseID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csDatabaseID = ' DBaseID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csDatabaseID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csDestCurID Constant

nxchCommandHandler.csDestCurID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csDestCurID = ' DestCurID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csDestCurID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csDirectKey Constant

nxchCommandHandler.csDirectKey Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csDirectKey = ' DirectKey [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csDirectKey.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csDirectKey1 Constant

nxchCommandHandler.csDirectKey1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csDirectKey1 = ' DirectKey1[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csDirectKey1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csDirectKey2 Constant

nxchCommandHandler.csDirectKey2 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csDirectKey2 = ' DirectKey2[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csDirectKey2.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csEnforce Constant

nxchCommandHandler.csEnforce Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csEnforce = ' Enforce [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csEnforce.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csErr Constant

nxchCommandHandler.csErr Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csErr = '*ERROR* $%x [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csErr.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csEstimate Constant

nxchCommandHandler.csEstimate Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csEstimate = ' Estimate [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csEstimate.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csExists Constant

nxchCommandHandler.csExists Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csExists = ' Exists [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csExists.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFailSafe Constant

nxchCommandHandler.csFailSafe Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFailSafe = ' FailSafe [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFailSafe.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csField Constant

nxchCommandHandler.csField Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csField = ' Field #%d "%s" %s [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csField.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFieldNo Constant

nxchCommandHandler.csFieldNo Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFieldNo = ' FieldNo [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFieldNo.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFileName Constant

nxchCommandHandler.csFileName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFileName = ' FileName [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFileName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFilterID Constant

nxchCommandHandler.csFilterID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFilterID = ' FilterID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFilterID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFirstCall Constant

nxchCommandHandler.csFirstCall Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFirstCall = ' FirstCall [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFirstCall.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFldCount Constant

nxchCommandHandler.csFldCount Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFldCount = ' FldCount [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFldCount.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFldCount1 Constant

nxchCommandHandler.csFldCount1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFldCount1 = ' FldCount1 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFldCount1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFldCount2 Constant

nxchCommandHandler.csFldCount2 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFldCount2 = ' FldCount2 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFldCount2.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csForceRecheck Constant

nxchCommandHandler.csForceRecheck Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csForceRecheck = ' ForceRechk[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csForceRecheck.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csFreeSpace Constant

nxchCommandHandler.csFreeSpace Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csFreeSpace = ' FreeSpace [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csFreeSpace.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csIndexID Constant

nxchCommandHandler.csIndexID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csIndexID = ' IndexID [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csIndexID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csIndexName Constant

nxchCommandHandler.csIndexName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csIndexName = ' IndexName [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csIndexName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csKeyFilterID Constant

nxchCommandHandler.csKeyFilterID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csKeyFilterID = ' KeyFltrID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csKeyFilterID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csKeyIncl1 Constant

nxchCommandHandler.csKeyIncl1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csKeyIncl1 = ' KeyIncl1 [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csKeyIncl1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csKeyIncl2 Constant

nxchCommandHandler.csKeyIncl2 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csKeyIncl2 = ' KeyIncl2 [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csKeyIncl2.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csKeyLen1 Constant

nxchCommandHandler.csKeyLen1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csKeyLen1 = ' KeyLen1 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csKeyLen1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csKeyLen2 Constant

nxchCommandHandler.csKeyLen2 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csKeyLen2 = ' KeyLen2 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csKeyLen2.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csLen Constant

nxchCommandHandler.csLen Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csLen = ' Len [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csLen.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csLength Constant

nxchCommandHandler.csLength Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csLength = ' Length [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csLength.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csLockPrsnt Constant

nxchCommandHandler.csLockPrsnt Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csLockPrsnt = ' LockPrsnt [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csLockPrsnt.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csLockType Constant

nxchCommandHandler.csLockType Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csLockType = ' LockType [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csLockType.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csMatchFirst Constant

nxchCommandHandler.csMatchFirst Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csMatchFirst = ' MatchFirst[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csMatchFirst.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csMaxTransSz Constant

nxchCommandHandler.csMaxTransSz Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csMaxTransSz = ' MaxTransSz[%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csMaxTransSz.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csName Constant

nxchCommandHandler.csName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csName = ' Name [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csNewCurID Constant

nxchCommandHandler.csNewCurID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csNewCurID = ' NewCurID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csNewCurID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csNewName Constant

nxchCommandHandler.csNewName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csNewName = ' NewName [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csNewName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csNewPath Constant

nxchCommandHandler.csNewPath Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csNewPath = ' NewPath [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csNewPath.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOffset Constant

nxchCommandHandler.csOffset Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOffset = ' Offset [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csOffset.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOK Constant

nxchCommandHandler.csOK Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOK = '-OK-';
File

nxchCommandHandler

Notes

do not use %p in the list above.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOldName Constant

nxchCommandHandler.csOldName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOldName = ' OldName [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csOldName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOpenMode Constant

nxchCommandHandler.csOpenMode Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOpenMode = ' OpenMode [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csOpenMode.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOption Constant

nxchCommandHandler.csOption Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOption = ' Option [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csOption.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csOverwrite Constant

nxchCommandHandler.csOverwrite Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csOverwrite = ' Overwrite [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csOverwrite.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csPartLen Constant

nxchCommandHandler.csPartLen Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csPartLen = ' PartLen [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csPartLen.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csPartLen1 Constant

nxchCommandHandler.csPartLen1 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csPartLen1 = ' PartLen1 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csPartLen1.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csPartLen2 Constant

nxchCommandHandler.csPartLen2 Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csPartLen2 = ' PartLen2 [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csPartLen2.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csPath Constant

nxchCommandHandler.csPath Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csPath = ' Path [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csPath.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csPosnOnRec Constant

nxchCommandHandler.csPosnOnRec Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csPosnOnRec = ' PosnOnRec [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csPosnOnRec.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csQueryText Constant

nxchCommandHandler.csQueryText Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csQueryText = ' QueryText [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csQueryText.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRaw Constant

nxchCommandHandler.csRaw Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRaw = ' Raw [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRaw.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csReadOrg Constant

nxchCommandHandler.csReadOrg Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csReadOrg = ' ReadOrg [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csReadOrg.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRecCount Constant

nxchCommandHandler.csRecCount Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRecCount = ' RecCount [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRecCount.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRecNo Constant

nxchCommandHandler.csRecNo Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRecNo = ' RecNo [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRecNo.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRecord Constant

nxchCommandHandler.csRecord Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRecord = ' Record';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRecord.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRecordSize Constant

nxchCommandHandler.csRecordSize Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRecordSize = ' RecordSize[%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRecordSize.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csRecSize Constant

nxchCommandHandler.csRecSize Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csRecSize = ' RecSize [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csRecSize.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csReleaseLck Constant

nxchCommandHandler.csReleaseLck Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csReleaseLck = ' ReleaseLck[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csReleaseLck.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csSessionID Constant

nxchCommandHandler.csSessionID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csSessionID = ' SessionID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csSessionID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csShareMode Constant

nxchCommandHandler.csShareMode Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csShareMode = ' ShareMode [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csShareMode.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csSnapshot Constant

nxchCommandHandler.csSnapshot Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csSnapshot = ' Snapshot [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csSnapshot.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csSourceID Constant

nxchCommandHandler.csSourceID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csSourceID = ' SourceID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csSourceID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csStatementID Constant

nxchCommandHandler.csStatementID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csStatementID = ' StmtID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csStatementID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csSubEngine Constant

nxchCommandHandler.csSubEngine Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csSubEngine = ' SubEngine [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csSubEngine.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTableName Constant

nxchCommandHandler.csTableName Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTableName = ' TableName [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTableName.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTableScope Constant

nxchCommandHandler.csTableScope Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTableScope = ' TableScope[%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTableScope.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTargetDatabaseID Constant

nxchCommandHandler.csTargetDatabaseID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTargetDatabaseID = ' TrgDBaseID[%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTargetDatabaseID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTaskID Constant

nxchCommandHandler.csTaskID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTaskID = ' TaskID [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTaskID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTimeout Constant

nxchCommandHandler.csTimeout Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTimeout = ' Timeout [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTimeout.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTransContextID Constant

nxchCommandHandler.csTransContextID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTransContextID = ' TransCtx [%x]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTransContextID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csTransLvl Constant

nxchCommandHandler.csTransLvl Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csTransLvl = ' TransLvl [%d]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csTransLvl.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csUserID Constant

nxchCommandHandler.csUserID Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csUserID = ' UserID [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csUserID.

Group

Constants

Links
nxchCommandHandler, Constants


nxchCommandHandler.csValue Constant

nxchCommandHandler.csValue Constant
nxchCommandHandler Constants Send Feedback
Syntax
Delphi
csValue = ' Value [%s]';
File

nxchCommandHandler

Description

This is constant nxchCommandHandler.csValue.

Group

Constants

Links
nxchCommandHandler, Constants


nxCodeSiteHelper Namespace

nxCodeSiteHelper Namespace
Classes Topics Send Feedback

This is namespace nxCodeSiteHelper.

Classes
Name | Description
TnxCodeSiteLoggerHelper | This is class nxCodeSiteHelper.TnxCodeSiteLoggerHelper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Topics


Classes

Classes
Class Helpers nxCodeSiteHelper Namespace Send Feedback

The following table lists classes in this documentation.

Class Helpers
Name | Description
TnxCodeSiteLoggerHelper | This is class nxCodeSiteHelper.TnxCodeSiteLoggerHelper.
Namespace

nxCodeSiteHelper Namespace

Links
Class Helpers, nxCodeSiteHelper Namespace


TnxCodeSiteLoggerHelper Class Helper

TnxCodeSiteLoggerHelper Class Helper
TnxCodeSiteLoggerHelper Methods TnxCodeSiteLoggerHelper Members nxCodeSiteHelper Classes Send Feedback
Class Hierarchy
nxCodeSiteHelper_TnxCodeSiteLoggerHelper
Syntax
Delphi
TnxCodeSiteLoggerHelper = class helper for TCodeSiteLogger;
File

nxCodeSiteHelper

Description

This is class nxCodeSiteHelper.TnxCodeSiteLoggerHelper.

Group

Classes

Links
TnxCodeSiteLoggerHelper Methods, TnxCodeSiteLoggerHelper Members, nxCodeSiteHelper, Classes


TnxCodeSiteLoggerHelper Members

TnxCodeSiteLoggerHelper Members
TnxCodeSiteLoggerHelper Class Helper Legend Public Methods Send Feedback

The following tables list the members exposed by TnxCodeSiteLoggerHelper.

Class Helper

TnxCodeSiteLoggerHelper Class Helper

Public Methods
Name | Description
_SendT | This is _SendT, a member of class TnxCodeSiteLoggerHelper.
SendT | TnxCodeSiteLoggerHelper
Links
TnxCodeSiteLoggerHelper Class Helper, Legend, Public Methods


TnxCodeSiteLoggerHelper Methods

TnxCodeSiteLoggerHelper Methods
TnxCodeSiteLoggerHelper Class Helper Legend Public Methods Send Feedback

The methods of the TnxCodeSiteLoggerHelper class are listed here.

Class Helper

TnxCodeSiteLoggerHelper Class Helper

Public Methods
Name | Description
_SendT | This is _SendT, a member of class TnxCodeSiteLoggerHelper.
SendT | TnxCodeSiteLoggerHelper
Links
TnxCodeSiteLoggerHelper Class Helper, Legend, Public Methods


TnxCodeSiteLoggerHelper._SendT Method

TnxCodeSiteLoggerHelper._SendT Method
TnxCodeSiteLoggerHelper Class Helper TnxCodeSiteLoggerHelper Members nxCodeSiteHelper Namespace TnxCodeSiteLoggerHelper Methods Send Feedback
Syntax
Delphi
procedure _SendT(const aMsg: string; aType: PTypeInfo; aValue: Pointer);
Description

This is _SendT, a member of class TnxCodeSiteLoggerHelper.

Group

TnxCodeSiteLoggerHelper Methods

Links
TnxCodeSiteLoggerHelper Class Helper, TnxCodeSiteLoggerHelper Members, nxCodeSiteHelper Namespace, TnxCodeSiteLoggerHelper Methods


TnxCodeSiteLoggerHelper.SendT Method

TnxCodeSiteLoggerHelper.SendT Method
TnxCodeSiteLoggerHelper Class Helper TnxCodeSiteLoggerHelper Members nxCodeSiteHelper Namespace TnxCodeSiteLoggerHelper Methods Send Feedback
Syntax
Delphi
procedure SendT<T>(const aMsg: string; const aValue: T);
Description

TnxCodeSiteLoggerHelper

Group

TnxCodeSiteLoggerHelper Methods

Links
TnxCodeSiteLoggerHelper Class Helper, TnxCodeSiteLoggerHelper Members, nxCodeSiteHelper Namespace, TnxCodeSiteLoggerHelper Methods


nxConfigSettingsDB Namespace

nxConfigSettingsDB Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxConfigSettingsDB.

Classes
Name | Description
TnxDBComponentConfiguration | This is class nxConfigSettingsDB.TnxDBComponentConfiguration.
TnxDBServerConfiguration | This is class nxConfigSettingsDB.TnxDBServerConfiguration.
Constants
Name | Description
EncryptionKey | TnxComponentConfiguration
rServerSettingsTableName | This is constant nxConfigSettingsDB.rServerSettingsTableName.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxConfigSettingsDB Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxDBComponentConfiguration | This is class nxConfigSettingsDB.TnxDBComponentConfiguration.
TnxDBServerConfiguration | This is class nxConfigSettingsDB.TnxDBServerConfiguration.
Namespace

nxConfigSettingsDB Namespace

Links
Classes, nxConfigSettingsDB Namespace, Legend


TnxDBComponentConfiguration Class

TnxDBComponentConfiguration Class
TnxDBComponentConfiguration Fields TnxDBComponentConfiguration Methods TnxDBComponentConfiguration Members nxConfigSettingsDB Classes Send Feedback
Class Hierarchy
nxConfigSettingsDB_TnxDBComponentConfigurationnxConfigSettingsDB_TnxDBComponentConfiguration
Syntax
Delphi
TnxDBComponentConfiguration = class(TnxBaseComponentConfiguration);
File

nxConfigSettingsDB

Description

This is class nxConfigSettingsDB.TnxDBComponentConfiguration.

Group

Classes

Links
TnxDBComponentConfiguration Fields, TnxDBComponentConfiguration Methods, TnxDBComponentConfiguration Members, nxConfigSettingsDB, Classes


TnxDBComponentConfiguration Members

TnxDBComponentConfiguration Members
TnxDBComponentConfiguration Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDBComponentConfiguration.

Class

TnxDBComponentConfiguration Class

Protected Fields
Name | Description
fBlowFish | This is fBlowFish, a member of class TnxDBComponentConfiguration.
fComponent | This is fComponent, a member of class TnxDBComponentConfiguration.
fConfig | This is fConfig, a member of class TnxBaseComponentConfiguration.
fServerConfiguration | This is fServerConfiguration, a member of class TnxDBComponentConfiguration.
Protected Methods
Name | Description
Decrypt | TnxDBComponentConfiguration
Encrypt | This is Encrypt, a member of class TnxDBComponentConfiguration.
Public Methods
Name | Description
Create | TnxBaseComponentConfiguration
CreateWithComponent | This is CreateWithComponent, a member of class TnxDBComponentConfiguration.
Destroy | This is Destroy, a member of class TnxDBComponentConfiguration.
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Public Properties
Name | Description
Config | This is Config, a member of class TnxBaseComponentConfiguration.
Links
TnxDBComponentConfiguration Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDBComponentConfiguration.CreateWithComponent Constructor

TnxDBComponentConfiguration.CreateWithComponent Constructor
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Class Send Feedback
Syntax
Delphi
constructor CreateWithComponent(aServerConfiguration: TnxDBServerConfiguration; aComponent: String);
Description

This is CreateWithComponent, a member of class TnxDBComponentConfiguration.

Class

TnxDBComponentConfiguration Class

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Class


TnxDBComponentConfiguration.Destroy Destructor

TnxDBComponentConfiguration.Destroy Destructor
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxDBComponentConfiguration.

Class

TnxDBComponentConfiguration Class

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Class


TnxDBComponentConfiguration Fields

TnxDBComponentConfiguration Fields
TnxDBComponentConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxDBComponentConfiguration class are listed here.

Class

TnxDBComponentConfiguration Class

Protected Fields
Name | Description
fBlowFish | This is fBlowFish, a member of class TnxDBComponentConfiguration.
fComponent | This is fComponent, a member of class TnxDBComponentConfiguration.
fServerConfiguration | This is fServerConfiguration, a member of class TnxDBComponentConfiguration.
Links
TnxDBComponentConfiguration Class, Legend, Protected Fields


TnxDBComponentConfiguration.fBlowFish Field

TnxDBComponentConfiguration.fBlowFish Field
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Fields Send Feedback
Syntax
Delphi
fBlowFish: TnxBlowFishRC4;
Description

This is fBlowFish, a member of class TnxDBComponentConfiguration.

Group

TnxDBComponentConfiguration Fields

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Fields


TnxDBComponentConfiguration.fComponent Field

TnxDBComponentConfiguration.fComponent Field
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Fields Send Feedback
Syntax
Delphi
fComponent: string;
Description

This is fComponent, a member of class TnxDBComponentConfiguration.

Group

TnxDBComponentConfiguration Fields

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Fields


TnxDBComponentConfiguration.fServerConfiguration Field

TnxDBComponentConfiguration.fServerConfiguration Field
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Fields Send Feedback
Syntax
Delphi
fServerConfiguration: TnxDBServerConfiguration;
Description

This is fServerConfiguration, a member of class TnxDBComponentConfiguration.

Group

TnxDBComponentConfiguration Fields

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Fields


TnxDBComponentConfiguration Methods

TnxDBComponentConfiguration Methods
TnxDBComponentConfiguration Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDBComponentConfiguration class are listed here.

Class

TnxDBComponentConfiguration Class

Protected Methods
Name | Description
Decrypt | TnxDBComponentConfiguration
Encrypt | This is Encrypt, a member of class TnxDBComponentConfiguration.
Public Methods
Name | Description
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Links
TnxDBComponentConfiguration Class, Legend, Protected Methods, Public Methods


TnxDBComponentConfiguration.Decrypt Method

TnxDBComponentConfiguration.Decrypt Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure Decrypt(aBuffer: PAnsiChar; aSize: integer);
Description

TnxDBComponentConfiguration

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBComponentConfiguration.Encrypt Method

TnxDBComponentConfiguration.Encrypt Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure Encrypt(aBuffer: PAnsiChar; aSize: integer);
Description

This is Encrypt, a member of class TnxDBComponentConfiguration.

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBComponentConfiguration.GetValue Method

TnxDBComponentConfiguration.GetValue Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
function GetValue(aName: String; aDefault: Variant): Variant; override;
Description

Get the value associated with aName as Variant.

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBComponentConfiguration.GetValueStream Method

TnxDBComponentConfiguration.GetValueStream Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure GetValueStream(aName: String; aStream: TStream); override;
Description

Get the value associated with aName as stream.

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBComponentConfiguration.SetValue Method

TnxDBComponentConfiguration.SetValue Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValue(aName: String; aValue: Variant); override;
Description

Set the value associated with aName as Variant.

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBComponentConfiguration.SetValueStream Method

TnxDBComponentConfiguration.SetValueStream Method
TnxDBComponentConfiguration Class TnxDBComponentConfiguration Members nxConfigSettingsDB Namespace TnxDBComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValueStream(aName: String; aStream: TStream); override;
Description

Set the value associated with aName as stream.

Group

TnxDBComponentConfiguration Methods

Links
TnxDBComponentConfiguration Class, TnxDBComponentConfiguration Members, nxConfigSettingsDB Namespace, TnxDBComponentConfiguration Methods


TnxDBServerConfiguration Class

TnxDBServerConfiguration Class
TnxDBServerConfiguration Fields TnxDBServerConfiguration Methods TnxDBServerConfiguration Members nxConfigSettingsDB Classes Send Feedback
Class Hierarchy
nxConfigSettingsDB_TnxDBServerConfigurationnxConfigSettingsDB_TnxDBServerConfiguration
Syntax
Delphi
TnxDBServerConfiguration = class(TnxBaseServerConfiguration);
File

nxConfigSettingsDB

Description

This is class nxConfigSettingsDB.TnxDBServerConfiguration.

Group

Classes

Links
TnxDBServerConfiguration Fields, TnxDBServerConfiguration Methods, TnxDBServerConfiguration Members, nxConfigSettingsDB, Classes


TnxDBServerConfiguration Members

TnxDBServerConfiguration Members
TnxDBServerConfiguration Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDBServerConfiguration.

Class

TnxDBServerConfiguration Class

Protected Fields
Name | Description
fConfigErrors | This is fConfigErrors, a member of class TnxBaseServerConfiguration.
fFileName | This is fFileName, a member of class TnxBaseServerConfiguration.
fTable | This is fTable, a member of class TnxDBServerConfiguration.
SystemDatabase | This is SystemDatabase, a member of class TnxDBServerConfiguration.
Public Methods
Name | Description
Create | TnxDBServerConfiguration
Destroy | This is Destroy, a member of class TnxDBServerConfiguration.
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
EnsureStorage | returns true if the storage was just created;
Flush | This is Flush, a member of class TnxDBServerConfiguration.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Lock | This is Lock, a member of class TnxDBServerConfiguration.
Save | This is Save, a member of class TnxDBServerConfiguration.
Unlock | This is Unlock, a member of class TnxDBServerConfiguration.
Public Properties
Name | Description
Errors | This is Errors, a member of class TnxBaseServerConfiguration.
FileName | This is FileName, a member of class TnxBaseServerConfiguration.
ReportErrors | This is ReportErrors, a member of class TnxBaseServerConfiguration.
Links
TnxDBServerConfiguration Class, Legend, Protected Fields, Public Methods, Public Properties


TnxDBServerConfiguration.Create Constructor

TnxDBServerConfiguration.Create Constructor
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Class Send Feedback
Syntax
Delphi
constructor Create(aFileName: String); override;
Description

TnxDBServerConfiguration

Class

TnxDBServerConfiguration Class

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Class


TnxDBServerConfiguration.Destroy Destructor

TnxDBServerConfiguration.Destroy Destructor
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxDBServerConfiguration.

Class

TnxDBServerConfiguration Class

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Class


TnxDBServerConfiguration Fields

TnxDBServerConfiguration Fields
TnxDBServerConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxDBServerConfiguration class are listed here.

Class

TnxDBServerConfiguration Class

Protected Fields
Name | Description
fTable | This is fTable, a member of class TnxDBServerConfiguration.
SystemDatabase | This is SystemDatabase, a member of class TnxDBServerConfiguration.
Links
TnxDBServerConfiguration Class, Legend, Protected Fields


TnxDBServerConfiguration.fTable Field

TnxDBServerConfiguration.fTable Field
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Fields Send Feedback
Syntax
Delphi
fTable: TnxsdCursorWrapper;
Description

This is fTable, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Fields

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Fields


TnxDBServerConfiguration.SystemDatabase Field

TnxDBServerConfiguration.SystemDatabase Field
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Fields Send Feedback
Syntax
Delphi
SystemDatabase: TnxSystemDatabase;
Description

This is SystemDatabase, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Fields

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Fields


TnxDBServerConfiguration Methods

TnxDBServerConfiguration Methods
TnxDBServerConfiguration Class Legend Public Methods Send Feedback

The methods of the TnxDBServerConfiguration class are listed here.

Class

TnxDBServerConfiguration Class

Public Methods
Name | Description
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
EnsureStorage | returns true if the storage was just created;
Flush | This is Flush, a member of class TnxDBServerConfiguration.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Lock | This is Lock, a member of class TnxDBServerConfiguration.
Save | This is Save, a member of class TnxDBServerConfiguration.
Unlock | This is Unlock, a member of class TnxDBServerConfiguration.
Links
TnxDBServerConfiguration Class, Legend, Public Methods


TnxDBServerConfiguration.EnsureComponentConfiguration Method

TnxDBServerConfiguration.EnsureComponentConfiguration Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure EnsureComponentConfiguration(aComponent: string; aSettings: TnxBaseSettings); override;
Description

The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.EnsureStorage Method

TnxDBServerConfiguration.EnsureStorage Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
function EnsureStorage: boolean;
Description

returns true if the storage was just created;

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.Flush Method

TnxDBServerConfiguration.Flush Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Flush;
Description

This is Flush, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.GetComponentConfiguration Method

TnxDBServerConfiguration.GetComponentConfiguration Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
function GetComponentConfiguration(aComponent: string): TnxBaseComponentConfiguration; override;
Description

Has to return a TnBaseComponentConfiguration instance for the given Component.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.Lock Method

TnxDBServerConfiguration.Lock Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Lock;
Description

This is Lock, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.Save Method

TnxDBServerConfiguration.Save Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Save; override;
Description

This is Save, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


TnxDBServerConfiguration.Unlock Method

TnxDBServerConfiguration.Unlock Method
TnxDBServerConfiguration Class TnxDBServerConfiguration Members nxConfigSettingsDB Namespace TnxDBServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Unlock;
Description

This is Unlock, a member of class TnxDBServerConfiguration.

Group

TnxDBServerConfiguration Methods

Links
TnxDBServerConfiguration Class, TnxDBServerConfiguration Members, nxConfigSettingsDB Namespace, TnxDBServerConfiguration Methods


Constants

Constants
Constants nxConfigSettingsDB Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EncryptionKey | TnxComponentConfiguration
rServerSettingsTableName | This is constant nxConfigSettingsDB.rServerSettingsTableName.
Namespace

nxConfigSettingsDB Namespace

Links
Constants, nxConfigSettingsDB Namespace


nxConfigSettingsDB.EncryptionKey Constant

nxConfigSettingsDB.EncryptionKey Constant
nxConfigSettingsDB Constants Send Feedback
Syntax
Delphi
EncryptionKey: AnsiString = 'WERYKTJREW$^T#$%Y$THth2456NexusRox!wefrgsdhtg@#$^erghsdftj4w5tyfgvg';
File

nxConfigSettingsDB

Description

TnxComponentConfiguration

Group

Constants

Links
nxConfigSettingsDB, Constants


nxConfigSettingsDB.rServerSettingsTableName Constant

nxConfigSettingsDB.rServerSettingsTableName Constant
nxConfigSettingsDB Constants Send Feedback
Syntax
Delphi
rServerSettingsTableName = '$SERVER$SYSTEMSETTINGS';
File

nxConfigSettingsDB

Description

This is constant nxConfigSettingsDB.rServerSettingsTableName.

Group

Constants

Links
nxConfigSettingsDB, Constants


nxdb Namespace

nxdb Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxdb.

Classes
Name | Description
TnxBaseBlobStream | Base class for NexusDB blob streams. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBaseSession | The mother of all sessions. It implements a component that is used the same way as Borland's TSession and adds some features unique to NexusDB.
TnxBaseSessionPool | Base class for session pools
TnxBaseUpdateHandler | DOM-IGNORE-BEGIN
TnxBaseUpdateObject | Base Update object for cached datasets.
TnxBatchAppendBlobStream | This class is used if the dataset is in batch append mode. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBlobStream | This class is used to access a blob directly. All calls are directly passed through to the server engine. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBlockModeBlobStream | This class is used if the dataset is in block read mode. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxCachedDataSet | A natively caching Dataset. Attach a TnxSqlUpdateObject for allowing writeback to underlying datasets.
TnxCachedDataSetCursor | DOM-IGNORE-BEGIN
TnxCachedDataSetCursorExtender | This is class nxdb.TnxCachedDataSetCursorExtender.
TnxCachedDataSetDatabaseExtender | DOM-IGNORE-BEGIN
TnxCursor | Client side base dataset cursor class.
TnxDataAccessStateComponent | The base class for all client side data components
TnxDatabase | Implementation of a TDatabase similar component.
TnxDataset | TnxDataset is the base class for all TDataset compatible Nexus components. Most methods and properties work exactly the same as Borland's implementation.
TnxIndexDataSet | TnxIndexDataSet adds support for indexing to TnxDataset.
TnxIndexDef | This is class nxdb.TnxIndexDef.
TnxIndexDefs | This is class nxdb.TnxIndexDefs.
TnxKeyAsVariantField | Field class that can correctly get a nx internal keyvalue as variant.
TnxLargeintField | This is class nxdb.TnxLargeintField.
TnxMemoBlobStream | This class is used to access memo blobs if Transliterate is true. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxMemoField | Extended field class for memo fields.
TnxMemoryStreamHacker |
TnxMemTable | A memory table.
TnxPooledSession | A pooled, reference counted Session for use with session pools (TnxBaseSessionPool)
TnxQuery | This is the client side representation of a SQL query. It's very similar to the VCL TQuery class.
TnxSession | A BDE compatible implementation of a NexusDB session.
TnxSessionOwnedDataAccessStateComponent | Base class for all stateful components owned by a session, e.g. databases
TnxSessionPool | A threadsafe session pool.
TnxSqlUpdateHandler | DOM-IGNORE-BEGIN
TnxSqlUpdateObject | Update Object for updating a cached datasets source datasets using SQL Statements.
TnxStatementDataSet | TQuery compatible implementation of a Nexus Sql Query
TnxStatementDataSetDataLink | DOM-IGNORE-BEGIN Used internally by the query, if you set TnxStatementDataSet.DataSource. This object is used to manage that link.
TnxStoredProc | This class is the client side representation of a stored procedure.
TnxStringField | Extended field class for string fields.
TnxTable | TnxTable is a TTable compatible implementation of a NexusDB dataset.
TnxThreadWithDatabase | A thread with an automatically created TnxSession and TnxDatabase instance.
TnxThreadWithSession | A thread with an automatically created TnxSession instance.
TnxThreadWithTable | A thread with an automatically created TnxSession, TnxDatabase and TnxTable instance.
TnxTransContext | Container for a Transaction Context.
Constants
Name | Description
EmptySetKeyOptions | This is constant nxdb.EmptySetKeyOptions.
FldTypeMap | 49..51
nxMaxBlobChunk | The maximum number of bytes read/written to the server at once. 0 means do not limit "chunk" sizes, any other value determines the number of bytes.
ParamTypeFromNexusDB | This is constant nxdb.ParamTypeFromNexusDB.
ParamTypeToNexusDB | This is constant nxdb.ParamTypeToNexusDB.
rsCreateTableExNotSupported | This is constant nxdb.rsCreateTableExNotSupported.
rsDsCreateLookupFilterNotSupported | This is constant nxdb.rsDsCreateLookupFilterNotSupported.
rsFilterTypeNotSupported | This is constant nxdb.rsFilterTypeNotSupported.
rsGetBookmarkFlagNotSupported | This is constant nxdb.rsGetBookmarkFlagNotSupported.
rsGetBookmarkIsNotSupported | This is constant nxdb.rsGetBookmarkIsNotSupported.
rsGetBookmarkStrIsNotSupported | This is constant nxdb.rsGetBookmarkStrIsNotSupported.
rsKeyAsVariantIsNotSupported | This is constant nxdb.rsKeyAsVariantIsNotSupported.
rsPSGetDefaultOrderNotSupported | This is constant nxdb.rsPSGetDefaultOrderNotSupported.
rsPSGetIndexDefsNotSupported | This is constant nxdb.rsPSGetIndexDefsNotSupported.
rsPSGetTableNameNotSupported | This is constant nxdb.rsPSGetTableNameNotSupported.
rsRecRevRequired | This is constant nxdb.rsRecRevRequired.
SFieldIndexError | This is constant nxdb.SFieldIndexError.
SFieldValueError | This is constant nxdb.SFieldValueError.
SIndexFieldMissing | This is constant nxdb.SIndexFieldMissing.
SNoFieldIndexes | This is constant nxdb.SNoFieldIndexes.
SNotEditing | This is constant nxdb.SNotEditing.
SNotIndexField | This is constant nxdb.SNotIndexField.
Functions
Name | Description
AssignValuesToParams |
AssignValueToParam |
ValuesFromParams |
Structs, Records, Enums
Name | Description
TnxCachedDataSetOption | Possible options for a cached dataset.
TnxDataSetInternalState | Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.
TnxDataSetOption | Dataset options definition
TnxFilterType | Possible Filter types for TnxDataset.Filter
TnxKeyBuffer | Used internally to address the different key buffers.
TnxKeyIndex | Used internally to address the different key buffers.
TnxRecordInfos | This is record nxdb.TnxRecordInfos.
TnxSetKeyOption | SetKey option
TnxTargetDatabase | DOM-IGNORE-END
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBaseSession | Pointer to TnxBaseSession.
PnxKeyBuffer | Used internally to address the different key buffers.
PnxRecordInfos | TnxDataset
TBookmarkOrPointer | This is type nxdb.TBookmarkOrPointer.
TFieldDefClass | A Class of TFieldDef (needed for abstraction purposes only.)
TFieldMap | This is type nxdb.TFieldMap.
TnxBaseUpdateHandlerClass | Class defintion for TnxBaseUpdateHandler.
TnxCachedDataSetOptions | Set of TnxCachedDataSetOption
TnxCreateTableEvent | Method defintion for CreateTable callback event.
TnxCursorClass | Class defintion for Cursors.
TnxDataSetInternalStates | Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.
TnxDataSetOptions | Blob Cache Options.
TnxDirectKeySetFieldsMethod | Method defintion for DirectKeySetFields callback method.
TnxFieldList | This is type nxdb.TnxFieldList.
TnxLoginEvent | An event to get a user name and password for login purposes. Called from TnxBaseSession.
TnxRecordBuffer | This is type nxdb.TnxRecordBuffer.
TnxServerFilterTimeoutEvent | This is an event handler definition for Filter timeouts. It gives the programmer a chance to commence with a filtering even if the filter timeout is reached.
TnxSetKeyOptions | Set of SetKey options.
Variables
Name | Description
EmptyOpenArray | This is variable nxdb.EmptyOpenArray.
nxDefaultSimpleExpressionFilterClass | the default Filter class.
nxDefaultSqlFilterClass | This is variable nxdb.nxDefaultSqlFilterClass.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxdb Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBaseBlobStream | Base class for NexusDB blob streams. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBaseSession | The mother of all sessions. It implements a component that is used the same way as Borland's TSession and adds some features unique to NexusDB.
TnxBaseSessionPool | Base class for session pools
TnxBaseUpdateHandler | DOM-IGNORE-BEGIN
TnxBaseUpdateObject | Base Update object for cached datasets.
TnxBatchAppendBlobStream | This class is used if the dataset is in batch append mode. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBlobStream | This class is used to access a blob directly. All calls are directly passed through to the server engine. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxBlockModeBlobStream | This class is used if the dataset is in block read mode. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxCachedDataSet | A natively caching Dataset. Attach a TnxSqlUpdateObject for allowing writeback to underlying datasets.
TnxCachedDataSetCursor | DOM-IGNORE-BEGIN
TnxCachedDataSetCursorExtender | This is class nxdb.TnxCachedDataSetCursorExtender.
TnxCachedDataSetDatabaseExtender | DOM-IGNORE-BEGIN
TnxCursor | Client side base dataset cursor class.
TnxDataAccessStateComponent | The base class for all client side data components
TnxDatabase | Implementation of a TDatabase similar component.
TnxDataset | TnxDataset is the base class for all TDataset compatible Nexus components. Most methods and properties work exactly the same as Borland's implementation.
TnxIndexDataSet | TnxIndexDataSet adds support for indexing to TnxDataset.
TnxIndexDef | This is class nxdb.TnxIndexDef.
TnxIndexDefs | This is class nxdb.TnxIndexDefs.
TnxKeyAsVariantField | Field class that can correctly get a nx internal keyvalue as variant.
TnxLargeintField | This is class nxdb.TnxLargeintField.
TnxMemoBlobStream | This class is used to access memo blobs if Transliterate is true. Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
TnxMemoField | Extended field class for memo fields.
TnxMemoryStreamHacker |
TnxMemTable | A memory table.
TnxPooledSession | A pooled, reference counted Session for use with session pools (TnxBaseSessionPool)
TnxQuery | This is the client side representation of a SQL query. It's very similar to the VCL TQuery class.
TnxSession | A BDE compatible implementation of a NexusDB session.
TnxSessionOwnedDataAccessStateComponent | Base class for all stateful components owned by a session, e.g. databases
TnxSessionPool | A threadsafe session pool.
TnxSqlUpdateHandler | DOM-IGNORE-BEGIN
TnxSqlUpdateObject | Update Object for updating a cached datasets source datasets using SQL Statements.
TnxStatementDataSet | TQuery compatible implementation of a Nexus Sql Query
TnxStatementDataSetDataLink | DOM-IGNORE-BEGIN Used internally by the query, if you set TnxStatementDataSet.DataSource. This object is used to manage that link.
TnxStoredProc | This class is the client side representation of a stored procedure.
TnxStringField | Extended field class for string fields.
TnxTable | TnxTable is a TTable compatible implementation of a NexusDB dataset.
TnxThreadWithDatabase | A thread with an automatically created TnxSession and TnxDatabase instance.
TnxThreadWithSession | A thread with an automatically created TnxSession instance.
TnxThreadWithTable | A thread with an automatically created TnxSession, TnxDatabase and TnxTable instance.
TnxTransContext | Container for a Transaction Context.
Namespace

nxdb Namespace

Links
Classes, nxdb Namespace, Legend


TnxBaseBlobStream Class

TnxBaseBlobStream Class
TnxBaseBlobStream Fields TnxBaseBlobStream Methods TnxBaseBlobStream Members nxdb Classes See Also Send Feedback
Class Hierarchy
nxdb_TnxBaseBlobStream
Syntax
Delphi
TnxBaseBlobStream = class(TStream);
File

nxdb

Description

Base class for NexusDB blob streams.

Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TnxDataSet.CreateBlobStream TnxBlobStream TnxBlockModeBlobStream TnxBatchAppendBlobStream TnxMemoBlobStream

Group

Classes

Links
TnxBaseBlobStream Fields, TnxBaseBlobStream Methods, TnxBaseBlobStream Members, nxdb, Classes, See Also


TnxBaseBlobStream Members

TnxBaseBlobStream Members
TnxBaseBlobStream Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseBlobStream.

Class

TnxBaseBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
Create | constructor.
Public Methods
Name | Description
Destroy | destructor.
Truncate | This method truncates the blob data at the current position.
Links
TnxBaseBlobStream Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseBlobStream.Create Constructor

TnxBaseBlobStream.Create Constructor
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Class Send Feedback
Syntax
Delphi
constructor Create(aField: TBlobField; aMode: TBlobStreamMode); virtual;
Description

constructor.

Class

TnxBaseBlobStream Class

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Class


TnxBaseBlobStream.Destroy Destructor

TnxBaseBlobStream.Destroy Destructor
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseBlobStream Class

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Class


TnxBaseBlobStream Fields

TnxBaseBlobStream Fields
TnxBaseBlobStream Class Legend Protected Fields Send Feedback

The fields of the TnxBaseBlobStream class are listed here.

Class

TnxBaseBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
Links
TnxBaseBlobStream Class, Legend, Protected Fields


TnxBaseBlobStream.bbsDataset Field

TnxBaseBlobStream.bbsDataset Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsDataset: TnxDataset;
Description

This is bbsDataset, a member of class TnxBaseBlobStream.

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream.bbsDataSetNext Field

TnxBaseBlobStream.bbsDataSetNext Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsDataSetNext: TnxBaseBlobStream;
Description

This is bbsDataSetNext, a member of class TnxBaseBlobStream.

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream.bbsDataSetPrev Field

TnxBaseBlobStream.bbsDataSetPrev Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsDataSetPrev: TnxBaseBlobStream;
Description

This is bbsDataSetPrev, a member of class TnxBaseBlobStream.

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream.bbsField Field

TnxBaseBlobStream.bbsField Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsField: TBlobField;
Description

private

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream.bbsFieldNo Field

TnxBaseBlobStream.bbsFieldNo Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsFieldNo: TnxWord32;
Description

This is bbsFieldNo, a member of class TnxBaseBlobStream.

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream.bbsMode Field

TnxBaseBlobStream.bbsMode Field
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Fields Send Feedback
Syntax
Delphi
bbsMode: TBlobStreamMode;
Description

This is bbsMode, a member of class TnxBaseBlobStream.

Group

TnxBaseBlobStream Fields

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Fields


TnxBaseBlobStream Methods

TnxBaseBlobStream Methods
TnxBaseBlobStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseBlobStream class are listed here.

Class

TnxBaseBlobStream Class

Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
Public Methods
Name | Description
Truncate | This method truncates the blob data at the current position.
Links
TnxBaseBlobStream Class, Legend, Protected Methods, Public Methods


TnxBaseBlobStream.bbsAddToDataSet Method

TnxBaseBlobStream.bbsAddToDataSet Method
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Methods Send Feedback
Syntax
Delphi
procedure bbsAddToDataSet;
Description

TnxBaseBlobStream

Group

TnxBaseBlobStream Methods

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Methods


TnxBaseBlobStream.bbsCheck Method

TnxBaseBlobStream.bbsCheck Method
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Methods Send Feedback
Syntax
Delphi
procedure bbsCheck(const aErrorCode: TnxResult);
Group

TnxBaseBlobStream Methods

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Methods


TnxBaseBlobStream.bbsRemoveFromDataSet Method

TnxBaseBlobStream.bbsRemoveFromDataSet Method
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Methods Send Feedback
Syntax
Delphi
procedure bbsRemoveFromDataSet;
Group

TnxBaseBlobStream Methods

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Methods


TnxBaseBlobStream.Truncate Method

TnxBaseBlobStream.Truncate Method
TnxBaseBlobStream Class TnxBaseBlobStream Members nxdb Namespace TnxBaseBlobStream Methods Send Feedback
Syntax
Delphi
procedure Truncate; virtual; abstract;
Description

This method truncates the blob data at the current position.

Group

TnxBaseBlobStream Methods

Links
TnxBaseBlobStream Class, TnxBaseBlobStream Members, nxdb Namespace, TnxBaseBlobStream Methods


TnxBaseSession Class

TnxBaseSession Class
TnxBaseSession Fields TnxBaseSession Methods TnxBaseSession Properties TnxBaseSession Events TnxBaseSession Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSessionnxdb_TnxBaseSession
Syntax
Delphi
TnxBaseSession = class(TnxDataAccessStateComponent, InxInterface, InxSessionRequests, InxSessionNotifications, InxSessionNotifier, InxRemoteTaskInfoCreator, InxClassActivator);
File

nxdb

Description

The mother of all sessions. It implements a component that is used the same way as Borland's TSession and adds some features unique to NexusDB.

Group

Classes

Links
TnxBaseSession Fields, TnxBaseSession Methods, TnxBaseSession Properties, TnxBaseSession Events, TnxBaseSession Members, nxdb, Classes


TnxBaseSession Members

TnxBaseSession Members
TnxBaseSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBaseSession.

Class

TnxBaseSession Class

Protected Fields
Name | Description
bsAbstractSession | private
bsBeepOnLoginError | This is bsBeepOnLoginError, a member of class TnxBaseSession.
bsClientLocaleAsDefault | This is bsClientLocaleAsDefault, a member of class TnxBaseSession.
bsCurrentUserName | This is bsCurrentUserName, a member of class TnxBaseSession.
bsDatabases | This is bsDatabases, a member of class TnxBaseSession.
bsDefaultDatabase | This is bsDefaultDatabase, a member of class TnxBaseSession.
bsDefaultRef | This is bsDefaultRef, a member of class TnxBaseSession.
bsDefaultTransContext | This is bsDefaultTransContext, a member of class TnxBaseSession.
bsOnLogin | This is bsOnLogin, a member of class TnxBaseSession.
bsPassword | This is bsPassword, a member of class TnxBaseSession.
bsPasswordRetries | This is bsPasswordRetries, a member of class TnxBaseSession.
bsSessionNotifications | This is bsSessionNotifications, a member of class TnxBaseSession.
bsTempDatabases | This is bsTempDatabases, a member of class TnxBaseSession.
bsTimeout | This is bsTimeout, a member of class TnxBaseSession.
bsTransContexts | This is bsTransContexts, a member of class TnxBaseSession.
bsUserName | This is bsUserName, a member of class TnxBaseSession.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bsCheckServerEngine |
bsDoLogin |
bsGetDatabase |
bsGetDatabaseCount |
bsGetDefault |
bsGetImplicitDatabase |
bsGetServerEngine | This is bsGetServerEngine, a member of class TnxBaseSession.
bsGetServerVersion |
bsGetSessionNotifications |
bsGetTimeout |
bsGetTransContext |
bsGetTransContextCount |
bsRefreshTimeout |
bsSetClientLocaleAsDefault |
bsSetDefault |
bsSetPassword |
bsSetTimeout |
bsSetUserName |
CreateInstance | InxClassActivator
CreateRemoteTaskInfo | InxRemoteTaskInfoCreator
dascExceptionClass |
Disconnected | InxSessionNotifier
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
AddAlias | Adds a new alias. If an error occurs, it triggers an exception.
AddAliasEx | Adds a new alias and returns the error code.
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
CancelProcessing | This procedure can be called from another thread to terminate any currently ongoing processing.
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
CloseInactiveFolders | This method closes all folders of the session that were kept open by the server caching mechanism.
CloseInactiveLocalDatabases | This method closes all temp databases of the session that are have no active local Tables
CloseInactiveTables | This method closes all tables of the session that were kept open by the server caching mechanism.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
DefaultDatabase | Returns the default database for this session or nil if non exist.
DefaultSession | Returns the default session for the current thread or nil if non exist.
DefaultTransContext | Returns the default TransContext for this session or nil if non exist.
DeleteAlias | Deletes the given alias. Triggers an exception if it fails.
DeleteAliasEx | Deletes the given alias and returns the error code.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindDatabase | Returns the implicit database for the given Alias. May return nil. The returned database may be closed.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetAliasNames | Fills the given list with all alias names.
GetAliasNamesEx | Fills the given list with all alias names and returns the error code.
GetAliasPath | Returns the path an alias points to. Remember that this is always a server relative path! The method triggers an exception if it fails.
GetAliasPathEx | Returns the path an alias points to. Remember that this is always a server relative path! It returns the error code as function result.
GetChangedTables | Returns the changed tables of an alias in the given list.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetRegisteredClassList | Returns a list of engines or descriptors of a particular type from the server.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored functions of a database/alias.
GetStoredFuncParams | Returns the parameter defintions for a named stored functions of the given Alias.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of a database/alias.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure of the given Alias.
GetTableNames | Returns the tables of an alias in the given list.
IsAlias | Returns true if an alias with the given name exists, otherwise false.
IsConnected | This function returns true if the session is active/connected.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LoggedInAdministrator | Returns the InxLoggedInAdministrator31000 of this session if available
LoggedInUser | Returns the InxLoggedInUser31000 of this session if available
LookupByComponentID |
ModifyAlias | This function allows to change the name and/or path of an alias. It triggers an exception if it fails.
ModifyAliasEx | This function allows to change the name and/or path of an alias and returns the error code.
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
OpenDatabase | Returns the implicit database for the given Alias, creates it if required. The returned database is guaranteed to be open.
PasswordAdd | Adds a password to the session password list.
PasswordRemove | Remove a password to the session password list.
PasswordRemoveAll | Clear the session password list.
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TableExists | Checks if a table exist in a specific alias.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
AbstractSession | This property gives direct access to the internal session state.
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DatabaseCount | Returns the number of tnxDatabase instances assigned to the session.
Databases | Returns the instance of tnxDatabase with index aInx in the list of assigned databases.
SavedActive | Can be used to save a certain state.
ServerEngine | Returns the Server Engine the session is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.
ServerVersion | Returns the Version of the server engine.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TransContextCount | Returns the number of TnxTransContext instances assigned to the session.
TransContexts | Returns the instance of TnxTransContext with index aInx in the list of assigned TransContexts.
Published Events
Name | Description
OnLogin | This event is triggered whenever the session is set to active and the connected server engine is in secure mode, thus requesting users to logon.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
BeepOnLoginError | If true, a Beep is triggered whenever a failed Login occurs.
ClientLocaleAsDefault | This is ClientLocaleAsDefault, a member of class TnxBaseSession.
CurrentUserName | The user name used for logging in this session. It is only assigned while the session is active.
Default | If true this session is the default session for the current thread.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | The password for the session. It is only used when the connected Server Engine is in secure mode.
PasswordRetries | The number of retries for logon before the session returns a DBIERR_INVALIDUSRPASS error is triggered.
SessionNotifications | This is SessionNotifications, a member of class TnxBaseSession.
Timeout | Sets the Timeout for the Session commands (in ms).
UserName | The user name for the session. It is only used when the connected Server Engine is in secure mode.
Version | Version of the component.
Links
TnxBaseSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxBaseSession.Create Constructor

TnxBaseSession.Create Constructor
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxBaseSession Class

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Class


TnxBaseSession.Destroy Destructor

TnxBaseSession.Destroy Destructor
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseSession Class

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Class


TnxBaseSession Fields

TnxBaseSession Fields
TnxBaseSession Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSession class are listed here.

Class

TnxBaseSession Class

Protected Fields
Name | Description
bsAbstractSession | private
bsBeepOnLoginError | This is bsBeepOnLoginError, a member of class TnxBaseSession.
bsClientLocaleAsDefault | This is bsClientLocaleAsDefault, a member of class TnxBaseSession.
bsCurrentUserName | This is bsCurrentUserName, a member of class TnxBaseSession.
bsDatabases | This is bsDatabases, a member of class TnxBaseSession.
bsDefaultDatabase | This is bsDefaultDatabase, a member of class TnxBaseSession.
bsDefaultRef | This is bsDefaultRef, a member of class TnxBaseSession.
bsDefaultTransContext | This is bsDefaultTransContext, a member of class TnxBaseSession.
bsOnLogin | This is bsOnLogin, a member of class TnxBaseSession.
bsPassword | This is bsPassword, a member of class TnxBaseSession.
bsPasswordRetries | This is bsPasswordRetries, a member of class TnxBaseSession.
bsSessionNotifications | This is bsSessionNotifications, a member of class TnxBaseSession.
bsTempDatabases | This is bsTempDatabases, a member of class TnxBaseSession.
bsTimeout | This is bsTimeout, a member of class TnxBaseSession.
bsTransContexts | This is bsTransContexts, a member of class TnxBaseSession.
bsUserName | This is bsUserName, a member of class TnxBaseSession.
Links
TnxBaseSession Class, Legend, Protected Fields


TnxBaseSession.bsAbstractSession Field

TnxBaseSession.bsAbstractSession Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsAbstractSession: TnxAbstractSession;
Description

private

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsBeepOnLoginError Field

TnxBaseSession.bsBeepOnLoginError Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsBeepOnLoginError: Boolean;
Description

This is bsBeepOnLoginError, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsClientLocaleAsDefault Field

TnxBaseSession.bsClientLocaleAsDefault Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsClientLocaleAsDefault: Boolean;
Description

This is bsClientLocaleAsDefault, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsCurrentUserName Field

TnxBaseSession.bsCurrentUserName Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsCurrentUserName: UnicodeString;
Description

This is bsCurrentUserName, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsDatabases Field

TnxBaseSession.bsDatabases Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsDatabases: TnxSortedList;
Description

This is bsDatabases, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsDefaultDatabase Field

TnxBaseSession.bsDefaultDatabase Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsDefaultDatabase: TnxDatabase;
Description

This is bsDefaultDatabase, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsDefaultRef Field

TnxBaseSession.bsDefaultRef Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsDefaultRef: PnxBaseSession;
Description

This is bsDefaultRef, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsDefaultTransContext Field

TnxBaseSession.bsDefaultTransContext Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsDefaultTransContext: TnxTransContext;
Description

This is bsDefaultTransContext, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsOnLogin Field

TnxBaseSession.bsOnLogin Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsOnLogin: TnxLoginEvent;
Description

This is bsOnLogin, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsPassword Field

TnxBaseSession.bsPassword Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsPassword: UnicodeString;
Description

This is bsPassword, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsPasswordRetries Field

TnxBaseSession.bsPasswordRetries Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsPasswordRetries: Integer;
Description

This is bsPasswordRetries, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsSessionNotifications Field

TnxBaseSession.bsSessionNotifications Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsSessionNotifications: TnxSessionNotifications;
Description

This is bsSessionNotifications, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsTempDatabases Field

TnxBaseSession.bsTempDatabases Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsTempDatabases: TStringList;
Description

This is bsTempDatabases, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsTimeout Field

TnxBaseSession.bsTimeout Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsTimeout: Integer;
Description

This is bsTimeout, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsTransContexts Field

TnxBaseSession.bsTransContexts Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsTransContexts: TnxSortedList;
Description

This is bsTransContexts, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession.bsUserName Field

TnxBaseSession.bsUserName Field
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Fields Send Feedback
Syntax
Delphi
bsUserName: UnicodeString;
Description

This is bsUserName, a member of class TnxBaseSession.

Group

TnxBaseSession Fields

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Fields


TnxBaseSession Methods

TnxBaseSession Methods
TnxBaseSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSession class are listed here.

Class

TnxBaseSession Class

Protected Methods
Name | Description
bsCheckServerEngine |
bsDoLogin |
bsGetDatabase |
bsGetDatabaseCount |
bsGetDefault |
bsGetImplicitDatabase |
bsGetServerEngine | This is bsGetServerEngine, a member of class TnxBaseSession.
bsGetServerVersion |
bsGetSessionNotifications |
bsGetTimeout |
bsGetTransContext |
bsGetTransContextCount |
bsRefreshTimeout |
bsSetClientLocaleAsDefault |
bsSetDefault |
bsSetPassword |
bsSetTimeout |
bsSetUserName |
CreateInstance | InxClassActivator
CreateRemoteTaskInfo | InxRemoteTaskInfoCreator
Disconnected | InxSessionNotifier
nxcAddDependent |
nxcRemoveDependent |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
scInitializing |
scStarting |
scStopping |
Public Methods
Name | Description
AddAlias | Adds a new alias. If an error occurs, it triggers an exception.
AddAliasEx | Adds a new alias and returns the error code.
CancelProcessing | This procedure can be called from another thread to terminate any currently ongoing processing.
CloseInactiveFolders | This method closes all folders of the session that were kept open by the server caching mechanism.
CloseInactiveLocalDatabases | This method closes all temp databases of the session that are have no active local Tables
CloseInactiveTables | This method closes all tables of the session that were kept open by the server caching mechanism.
DefaultDatabase | Returns the default database for this session or nil if non exist.
DefaultSession | Returns the default session for the current thread or nil if non exist.
DefaultTransContext | Returns the default TransContext for this session or nil if non exist.
DeleteAlias | Deletes the given alias. Triggers an exception if it fails.
DeleteAliasEx | Deletes the given alias and returns the error code.
FindDatabase | Returns the implicit database for the given Alias. May return nil. The returned database may be closed.
GetAliasNames | Fills the given list with all alias names.
GetAliasNamesEx | Fills the given list with all alias names and returns the error code.
GetAliasPath | Returns the path an alias points to. Remember that this is always a server relative path! The method triggers an exception if it fails.
GetAliasPathEx | Returns the path an alias points to. Remember that this is always a server relative path! It returns the error code as function result.
GetChangedTables | Returns the changed tables of an alias in the given list.
GetRegisteredClassList | Returns a list of engines or descriptors of a particular type from the server.
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored functions of a database/alias.
GetStoredFuncParams | Returns the parameter defintions for a named stored functions of the given Alias.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of a database/alias.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure of the given Alias.
GetTableNames | Returns the tables of an alias in the given list.
IsAlias | Returns true if an alias with the given name exists, otherwise false.
IsConnected | This function returns true if the session is active/connected.
LoggedInAdministrator | Returns the InxLoggedInAdministrator31000 of this session if available
LoggedInUser | Returns the InxLoggedInUser31000 of this session if available
ModifyAlias | This function allows to change the name and/or path of an alias. It triggers an exception if it fails.
ModifyAliasEx | This function allows to change the name and/or path of an alias and returns the error code.
OpenDatabase | Returns the implicit database for the given Alias, creates it if required. The returned database is guaranteed to be open.
PasswordAdd | Adds a password to the session password list.
PasswordRemove | Remove a password to the session password list.
PasswordRemoveAll | Clear the session password list.
TableExists | Checks if a table exist in a specific alias.
Links
TnxBaseSession Class, Legend, Protected Methods, Public Methods


TnxBaseSession.AddAlias Method

TnxBaseSession.AddAlias Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure AddAlias(const aName: string; const aPath: string; aEnforce: Boolean = False);
Parameters
Parameters | Description
const aName: string | Aliasname
const aPath: string | Path the alias should point to
aEnforce: Boolean = False | If true, the path will be created
Description

Adds a new alias. If an error occurs, it triggers an exception.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.AddAliasEx Method

TnxBaseSession.AddAliasEx Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function AddAliasEx(const aName: string; const aPath: string; aEnforce: Boolean = False): TnxResult;
Parameters
Parameters | Description
const aName: string | Aliasname
const aPath: string | Path the alias should point to
aEnforce: Boolean = False | If true, the path will be created
Description

Adds a new alias and returns the error code.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.bsCheckServerEngine Method

TnxBaseSession.bsCheckServerEngine Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsCheckServerEngine; virtual;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsDoLogin Method

TnxBaseSession.bsDoLogin Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsDoLogin(var aUserName: UnicodeString; var aPassword: UnicodeString): Boolean;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetDatabase Method

TnxBaseSession.bsGetDatabase Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetDatabase(aInx: Integer): TnxDatabase;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetDatabaseCount Method

TnxBaseSession.bsGetDatabaseCount Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetDatabaseCount: Integer;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetDefault Method

TnxBaseSession.bsGetDefault Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetDefault: Boolean;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetImplicitDatabase Method

TnxBaseSession.bsGetImplicitDatabase Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetImplicitDatabase(const aAliasName: string; aCreate: Boolean = True): TnxDataBase;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetServerEngine Method

TnxBaseSession.bsGetServerEngine Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetServerEngine: TnxBaseServerEngine; virtual; abstract;
Description

This is bsGetServerEngine, a member of class TnxBaseSession.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetServerVersion Method

TnxBaseSession.bsGetServerVersion Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetServerVersion: Integer;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetSessionNotifications Method

TnxBaseSession.bsGetSessionNotifications Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetSessionNotifications: InxSessionNotifications;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetTimeout Method

TnxBaseSession.bsGetTimeout Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetTimeout: Integer; virtual;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetTransContext Method

TnxBaseSession.bsGetTransContext Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetTransContext(aInx: Integer): TnxTransContext;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsGetTransContextCount Method

TnxBaseSession.bsGetTransContextCount Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function bsGetTransContextCount: Integer;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsRefreshTimeout Method

TnxBaseSession.bsRefreshTimeout Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsRefreshTimeout; virtual;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsSetClientLocaleAsDefault Method

TnxBaseSession.bsSetClientLocaleAsDefault Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsSetClientLocaleAsDefault(const Value: Boolean);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsSetDefault Method

TnxBaseSession.bsSetDefault Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsSetDefault(const Value: Boolean);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsSetPassword Method

TnxBaseSession.bsSetPassword Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsSetPassword(const aValue: UnicodeString);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsSetTimeout Method

TnxBaseSession.bsSetTimeout Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsSetTimeout(aTimeout: Integer);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.bsSetUserName Method

TnxBaseSession.bsSetUserName Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure bsSetUserName(const aValue: UnicodeString);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CancelProcessing Method

TnxBaseSession.CancelProcessing Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure CancelProcessing;
Description

This procedure can be called from another thread to terminate any currently ongoing processing.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CloseInactiveFolders Method

TnxBaseSession.CloseInactiveFolders Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure CloseInactiveFolders;
Description

This method closes all folders of the session that were kept open by the server caching mechanism.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CloseInactiveLocalDatabases Method

TnxBaseSession.CloseInactiveLocalDatabases Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure CloseInactiveLocalDatabases;
Description

This method closes all temp databases of the session that are have no active local Tables

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CloseInactiveTables Method

TnxBaseSession.CloseInactiveTables Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure CloseInactiveTables;
Description

This method closes all tables of the session that were kept open by the server caching mechanism.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CreateInstance Method

TnxBaseSession.CreateInstance Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT;
Description

InxClassActivator

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.CreateRemoteTaskInfo Method

TnxBaseSession.CreateRemoteTaskInfo Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function CreateRemoteTaskInfo(const aTaskID: TnxTaskID): TnxAbstractTaskInfo;
Description

InxRemoteTaskInfoCreator

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.DefaultDatabase Method

TnxBaseSession.DefaultDatabase Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function DefaultDatabase: TnxDatabase;
Description

Returns the default database for this session or nil if non exist.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.DefaultSession Method

TnxBaseSession.DefaultSession Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
class function DefaultSession: TnxBaseSession;
Description

Returns the default session for the current thread or nil if non exist.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.DefaultTransContext Method

TnxBaseSession.DefaultTransContext Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function DefaultTransContext: TnxTransContext;
Description

Returns the default TransContext for this session or nil if non exist.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.DeleteAlias Method

TnxBaseSession.DeleteAlias Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure DeleteAlias(const aName: string);
Parameters
Parameters | Description
const aName: string | Aliasname
Description

Deletes the given alias. Triggers an exception if it fails.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.DeleteAliasEx Method

TnxBaseSession.DeleteAliasEx Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function DeleteAliasEx(const aName: string): TnxResult;
Parameters
Parameters | Description
const aName: string | Aliasname
Description

Deletes the given alias and returns the error code.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.Disconnected Method

TnxBaseSession.Disconnected Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

InxSessionNotifier

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.FindDatabase Method

TnxBaseSession.FindDatabase Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function FindDatabase(const aAliasName: string): TnxDatabase; virtual;
Description

Returns the implicit database for the given Alias. May return nil. The returned database may be closed.

do not free the returned database

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetAliasNames Method

TnxBaseSession.GetAliasNames Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure GetAliasNames(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the call; must not be nil; always clears the list before adding the names
Description

Fills the given list with all alias names.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.GetAliasNamesEx Method

TnxBaseSession.GetAliasNamesEx Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function GetAliasNamesEx(aList: TStrings; aEmptyList: Boolean): TnxResult;
Parameters
Parameters | Description
aList: TStrings | will hold the names after the call; must no be nil
aEmptyList: Boolean | clears the list before adding, if true
Description

Fills the given list with all alias names and returns the error code.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.GetAliasPath Method

TnxBaseSession.GetAliasPath Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure GetAliasPath(const aName: string; out aPath: string);
Parameters
Parameters | Description
const aName: string | AliasName
out aPath: string | will hold the path after the method returns
Description

Returns the path an alias points to. Remember that this is always a server relative path! The method triggers an exception if it fails.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.GetAliasPathEx Method

TnxBaseSession.GetAliasPathEx Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function GetAliasPathEx(const aName: string; out aPath: string): TnxResult;
Parameters
Parameters | Description
const aName: string | AliasName
out aPath: string | will hold the path after the method returns
Description

Returns the path an alias points to. Remember that this is always a server relative path! It returns the error code as function result.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.GetChangedTables Method

TnxBaseSession.GetChangedTables Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetChangedTables(const aAliasName: string; aList: TStrings);
Parameters
Parameters | Description
const aAliasName: string | the name of the alias
aList: TStrings | the list to hold the names; must not be nil
Description

Returns the changed tables of an alias in the given list.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetRegisteredClassList Method

TnxBaseSession.GetRegisteredClassList Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure GetRegisteredClassList(const aClassListType: TnxClassListType; aList: TStrings);
Parameters
Parameters | Description
const aClassListType: TnxClassListType | the type of engines or descriptors list to return
aList: TStrings | an instance of a TStrings descendant; will hold the list on return
Description

Returns a list of engines or descriptors of a particular type from the server.

See Also

TnxClassListType

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.GetStoredFuncNames Method

TnxBaseSession.GetStoredFuncNames Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetStoredFuncNames(const aAliasName: string; aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetStoredFuncNames returns a list of all stored functions of a database/alias.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetStoredFuncParams Method

TnxBaseSession.GetStoredFuncParams Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetStoredFuncParams(const aAliasName: string; const aStoredFuncName: string; out aParams: TnxStoredProcParamList);
Description

Returns the parameter defintions for a named stored functions of the given Alias.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetStoredProcNames Method

TnxBaseSession.GetStoredProcNames Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetStoredProcNames(const aAliasName: string; aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetStoredProcNames returns a list of all stored procedures of a database/alias.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetStoredProcParams Method

TnxBaseSession.GetStoredProcParams Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetStoredProcParams(const aAliasName: string; const aStoredProcName: string; out aParams: TnxStoredProcParamList);
Description

Returns the parameter defintions for a named stored procedure of the given Alias.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.GetTableNames Method

TnxBaseSession.GetTableNames Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure GetTableNames(const aAliasName: string; aList: TStrings);
Parameters
Parameters | Description
const aAliasName: string | the name of the alias
aList: TStrings | the list to hold the names; must not be nil
Description

Returns the tables of an alias in the given list.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.IsAlias Method

TnxBaseSession.IsAlias Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function IsAlias(const aName: string): Boolean;
Parameters
Parameters | Description
const aName: string | AliasName
Description

Returns true if an alias with the given name exists, otherwise false.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.IsConnected Method

TnxBaseSession.IsConnected Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function IsConnected: Boolean;
Description

This function returns true if the session is active/connected.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.LoggedInAdministrator Method

TnxBaseSession.LoggedInAdministrator Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function LoggedInAdministrator: InxLoggedInAdministrator31000;
Description

Returns the InxLoggedInAdministrator31000 of this session if available

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.LoggedInUser Method

TnxBaseSession.LoggedInUser Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function LoggedInUser: InxLoggedInUser31000;
Description

Returns the InxLoggedInUser31000 of this session if available

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.ModifyAlias Method

TnxBaseSession.ModifyAlias Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
procedure ModifyAlias(const aName: string; const aNewName: string; const aNewPath: string; aEnforce: Boolean = False);
Parameters
Parameters | Description
const aName: string | Aliasname
const aNewName: string | new Name of the Alias
const aNewPath: string | new Path of the Alias
aEnforce: Boolean = False | If true, the new path will be created
Description

This function allows to change the name and/or path of an alias.

It triggers an exception if it fails.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.ModifyAliasEx Method

TnxBaseSession.ModifyAliasEx Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods See Also Send Feedback
Syntax
Delphi
function ModifyAliasEx(const aName: string; const aNewName: string; const aNewPath: string; aEnforce: Boolean = False): TnxResult;
Parameters
Parameters | Description
const aName: string | Aliasname
const aNewName: string | new Name of the Alias
const aNewPath: string | new Path of the Alias
aEnforce: Boolean = False | If true, the new path will be created
Description

This function allows to change the name and/or path of an alias and returns the error code.

See Also

AddAliasEx, DeleteAlias, DeleteAliasEx, ModifyAlias, ModifyAliasEx, GetAliasNames, GetAliasNamesEx, GetAliasPath, GetAliasPathEx, IsAlias

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods, See Also


TnxBaseSession.nxcAddDependent Method

TnxBaseSession.nxcAddDependent Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.nxcRemoveDependent Method

TnxBaseSession.nxcRemoveDependent Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.OpenDatabase Method

TnxBaseSession.OpenDatabase Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function OpenDatabase(const aAliasName: string): TnxDatabase; virtual;
Description

Returns the implicit database for the given Alias, creates it if required. The returned database is guaranteed to be open.

do not free the returned database

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.PasswordAdd Method

TnxBaseSession.PasswordAdd Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure PasswordAdd(const aPassword: UnicodeString);
Description

Adds a password to the session password list.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.PasswordRemove Method

TnxBaseSession.PasswordRemove Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure PasswordRemove(const aPassword: UnicodeString);
Description

Remove a password to the session password list.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.PasswordRemoveAll Method

TnxBaseSession.PasswordRemoveAll Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure PasswordRemoveAll;
Description

Clear the session password list.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.ProcessPost Method

TnxBaseSession.ProcessPost Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.ProcessRequest Method

TnxBaseSession.ProcessRequest Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

InxSessionRequests.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.ProcessRequestDirect Method

TnxBaseSession.ProcessRequestDirect Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.scInitializing Method

TnxBaseSession.scInitializing Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.scStarting Method

TnxBaseSession.scStarting Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.scStopping Method

TnxBaseSession.scStopping Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession.TableExists Method

TnxBaseSession.TableExists Method
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Methods Send Feedback
Syntax
Delphi
function TableExists(const aAliasName: string; const aTableName: string; const aPassword: UnicodeString): Boolean;
Parameters
Parameters | Description
const aAliasName: string | the name of the alias
const aTableName: string | the name of the table
Description

Checks if a table exist in a specific alias.

Group

TnxBaseSession Methods

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Methods


TnxBaseSession Properties

TnxBaseSession Properties
TnxBaseSession Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBaseSession class are listed here.

Class

TnxBaseSession Class

Public Properties
Name | Description
AbstractSession | This property gives direct access to the internal session state.
DatabaseCount | Returns the number of tnxDatabase instances assigned to the session.
Databases | Returns the instance of tnxDatabase with index aInx in the list of assigned databases.
ServerEngine | Returns the Server Engine the session is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.
ServerVersion | Returns the Version of the server engine.
TransContextCount | Returns the number of TnxTransContext instances assigned to the session.
TransContexts | Returns the instance of TnxTransContext with index aInx in the list of assigned TransContexts.
Published Properties
Name | Description
BeepOnLoginError | If true, a Beep is triggered whenever a failed Login occurs.
ClientLocaleAsDefault | This is ClientLocaleAsDefault, a member of class TnxBaseSession.
CurrentUserName | The user name used for logging in this session. It is only assigned while the session is active.
Default | If true this session is the default session for the current thread.
Password | The password for the session. It is only used when the connected Server Engine is in secure mode.
PasswordRetries | The number of retries for logon before the session returns a DBIERR_INVALIDUSRPASS error is triggered.
SessionNotifications | This is SessionNotifications, a member of class TnxBaseSession.
Timeout | Sets the Timeout for the Session commands (in ms).
UserName | The user name for the session. It is only used when the connected Server Engine is in secure mode.
Links
TnxBaseSession Class, Legend, Public Properties, Published Properties


TnxBaseSession.AbstractSession Property

TnxBaseSession.AbstractSession Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property AbstractSession: TnxAbstractSession;
Description

This property gives direct access to the internal session state.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.BeepOnLoginError Property

TnxBaseSession.BeepOnLoginError Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property BeepOnLoginError: Boolean;
Description

If true, a Beep is triggered whenever a failed Login occurs.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.ClientLocaleAsDefault Property

TnxBaseSession.ClientLocaleAsDefault Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property ClientLocaleAsDefault: Boolean;
Description

This is ClientLocaleAsDefault, a member of class TnxBaseSession.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.CurrentUserName Property

TnxBaseSession.CurrentUserName Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property CurrentUserName: UnicodeString;
Description

The user name used for logging in this session. It is only assigned while the session is active.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.DatabaseCount Property

TnxBaseSession.DatabaseCount Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property DatabaseCount: Integer;
Description

Returns the number of tnxDatabase instances assigned to the session.

See Also

Databases

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.Databases Property

TnxBaseSession.Databases Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property Databases [aInx: Integer]: TnxDatabase;
Description

Returns the instance of tnxDatabase with index aInx in the list of assigned databases.

See Also

DatabaseCount

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.Default Property

TnxBaseSession.Default Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property Default: Boolean;
Description

If true this session is the default session for the current thread.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.Password Property

TnxBaseSession.Password Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

The password for the session. It is only used when the connected Server Engine is in secure mode.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.PasswordRetries Property

TnxBaseSession.PasswordRetries Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property PasswordRetries: Integer;
Description

The number of retries for logon before the session returns a DBIERR_INVALIDUSRPASS error is triggered.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.ServerEngine Property

TnxBaseSession.ServerEngine Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

Returns the Server Engine the session is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.ServerVersion Property

TnxBaseSession.ServerVersion Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property ServerVersion: Integer;
Description

Returns the Version of the server engine.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.SessionNotifications Property

TnxBaseSession.SessionNotifications Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property SessionNotifications: InxSessionNotifications;
Description

This is SessionNotifications, a member of class TnxBaseSession.

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.Timeout Property

TnxBaseSession.Timeout Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties Send Feedback
Syntax
Delphi
property Timeout: Integer;
Description

Sets the Timeout for the Session commands (in ms).

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties


TnxBaseSession.TransContextCount Property

TnxBaseSession.TransContextCount Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property TransContextCount: Integer;
Description

Returns the number of TnxTransContext instances assigned to the session.

See Also

TransContexts

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.TransContexts Property

TnxBaseSession.TransContexts Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property TransContexts [aInx: Integer]: TnxTransContext;
Description

Returns the instance of TnxTransContext with index aInx in the list of assigned TransContexts.

See Also

TransContextCount

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession.UserName Property

TnxBaseSession.UserName Property
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Properties See Also Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

The user name for the session. It is only used when the connected Server Engine is in secure mode.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Properties

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Properties, See Also


TnxBaseSession Events

TnxBaseSession Events
TnxBaseSession Class Legend Published Events Send Feedback

The events of the TnxBaseSession class are listed here.

Class

TnxBaseSession Class

Published Events
Name | Description
OnLogin | This event is triggered whenever the session is set to active and the connected server engine is in secure mode, thus requesting users to logon.
Links
TnxBaseSession Class, Legend, Published Events


TnxBaseSession.OnLogin Event

TnxBaseSession.OnLogin Event
TnxBaseSession Class TnxBaseSession Members nxdb Namespace TnxBaseSession Events See Also Send Feedback
Syntax
Delphi
property OnLogin: TnxLoginEvent;
Parameters
Parameters | Description
aSender | the session calling the event
aUserName | the username supplied to the Session, change if wanted/needed
aPassword | the password supplied to the Session, change if wanted/needed
aResult | return true for successful logon, false if you want the logon to fail
Description

This event is triggered whenever the session is set to active and the connected server engine is in secure mode, thus requesting users to logon.

See Also

UserName, BeepOnLoginError, Password, OnLogin, PasswordRetries

Group

TnxBaseSession Events

Links
TnxBaseSession Class, TnxBaseSession Members, nxdb Namespace, TnxBaseSession Events, See Also


TnxBaseSessionPool Class

TnxBaseSessionPool Class
TnxBaseSessionPool Fields TnxBaseSessionPool Methods TnxBaseSessionPool Properties TnxBaseSessionPool Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPoolnxdb_TnxBaseSessionPool
Syntax
Delphi
TnxBaseSessionPool = class(TnxDataAccessStateComponent, IUnknown, InxSessionRequests);
File

nxdb

Description

Base class for session pools

Group

Classes

Links
TnxBaseSessionPool Fields, TnxBaseSessionPool Methods, TnxBaseSessionPool Properties, TnxBaseSessionPool Members, nxdb, Classes


TnxBaseSessionPool Members

TnxBaseSessionPool Members
TnxBaseSessionPool Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseSessionPool.

Class

TnxBaseSessionPool Class

Protected Fields
Name | Description
bspOutstandingSessions | This is bspOutstandingSessions, a member of class TnxBaseSessionPool.
bspPassword | This is bspPassword, a member of class TnxBaseSessionPool.
bspPool | This is bspPool, a member of class TnxBaseSessionPool.
bspPool2 | This is bspPool2, a member of class TnxBaseSessionPool.
bspSessions | private
bspTimeout | This is bspTimeout, a member of class TnxBaseSessionPool.
bspUserName | This is bspUserName, a member of class TnxBaseSessionPool.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bspCheckServerEngine |
bspCreateSession |
bspGetServerEngine | This is bspGetServerEngine, a member of class TnxBaseSessionPool.
bspGetTimeout |
bspReturn |
bspSetPassword |
bspSetTimeout |
bspSetUserName |
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
AcquireSession | Returns a free session out of the pool. TnxBaseSessionPool
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
ServerEngine | Returns the Server Engine the session pool is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | The password for the session pool. It is only used when the connected Server Engine is in secure mode.
Timeout | Sets the Timeout for the Session pool commands (in ms).
UserName | The user name for the session pool. It is only used when the connected Server Engine is in secure mode.
Version | Version of the component.
Links
TnxBaseSessionPool Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseSessionPool.Create Constructor

TnxBaseSessionPool.Create Constructor
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxBaseSessionPool Class

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Class


TnxBaseSessionPool.Destroy Destructor

TnxBaseSessionPool.Destroy Destructor
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseSessionPool Class

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Class


TnxBaseSessionPool Fields

TnxBaseSessionPool Fields
TnxBaseSessionPool Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSessionPool class are listed here.

Class

TnxBaseSessionPool Class

Protected Fields
Name | Description
bspOutstandingSessions | This is bspOutstandingSessions, a member of class TnxBaseSessionPool.
bspPassword | This is bspPassword, a member of class TnxBaseSessionPool.
bspPool | This is bspPool, a member of class TnxBaseSessionPool.
bspPool2 | This is bspPool2, a member of class TnxBaseSessionPool.
bspSessions | private
bspTimeout | This is bspTimeout, a member of class TnxBaseSessionPool.
bspUserName | This is bspUserName, a member of class TnxBaseSessionPool.
Links
TnxBaseSessionPool Class, Legend, Protected Fields


TnxBaseSessionPool.bspOutstandingSessions Field

TnxBaseSessionPool.bspOutstandingSessions Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspOutstandingSessions: Integer;
Description

This is bspOutstandingSessions, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspPassword Field

TnxBaseSessionPool.bspPassword Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspPassword: UnicodeString;
Description

This is bspPassword, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspPool Field

TnxBaseSessionPool.bspPool Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspPool: TnxThreadSafeStack;
Description

This is bspPool, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspPool2 Field

TnxBaseSessionPool.bspPool2 Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspPool2: TnxThreadSafeStack;
Description

This is bspPool2, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspSessions Field

TnxBaseSessionPool.bspSessions Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspSessions: TnxListPortal;
Description

private

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspTimeout Field

TnxBaseSessionPool.bspTimeout Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspTimeout: Integer;
Description

This is bspTimeout, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool.bspUserName Field

TnxBaseSessionPool.bspUserName Field
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Fields Send Feedback
Syntax
Delphi
bspUserName: UnicodeString;
Description

This is bspUserName, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Fields

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Fields


TnxBaseSessionPool Methods

TnxBaseSessionPool Methods
TnxBaseSessionPool Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSessionPool class are listed here.

Class

TnxBaseSessionPool Class

Protected Methods
Name | Description
bspCheckServerEngine |
bspCreateSession |
bspGetServerEngine | This is bspGetServerEngine, a member of class TnxBaseSessionPool.
bspGetTimeout |
bspReturn |
bspSetPassword |
bspSetTimeout |
bspSetUserName |
nxcAddDependent |
nxcRemoveDependent |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
scInitializing |
scStarting |
scStopping |
Public Methods
Name | Description
AcquireSession | Returns a free session out of the pool. TnxBaseSessionPool
Links
TnxBaseSessionPool Class, Legend, Protected Methods, Public Methods


TnxBaseSessionPool.AcquireSession Method

TnxBaseSessionPool.AcquireSession Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function AcquireSession: TnxPooledSession;
Description

Returns a free session out of the pool.

TnxBaseSessionPool

Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspCheckServerEngine Method

TnxBaseSessionPool.bspCheckServerEngine Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure bspCheckServerEngine; virtual;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspCreateSession Method

TnxBaseSessionPool.bspCreateSession Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function bspCreateSession: TnxPooledSession; virtual;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspGetServerEngine Method

TnxBaseSessionPool.bspGetServerEngine Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function bspGetServerEngine: TnxBaseServerEngine; virtual; abstract;
Description

This is bspGetServerEngine, a member of class TnxBaseSessionPool.

Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspGetTimeout Method

TnxBaseSessionPool.bspGetTimeout Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function bspGetTimeout: Integer;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspReturn Method

TnxBaseSessionPool.bspReturn Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function bspReturn(aSession: TnxPooledSession): Boolean; virtual;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspSetPassword Method

TnxBaseSessionPool.bspSetPassword Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure bspSetPassword(const aValue: UnicodeString);
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspSetTimeout Method

TnxBaseSessionPool.bspSetTimeout Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure bspSetTimeout(aTimeout: Integer);
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.bspSetUserName Method

TnxBaseSessionPool.bspSetUserName Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure bspSetUserName(const aValue: UnicodeString);
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.nxcAddDependent Method

TnxBaseSessionPool.nxcAddDependent Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.nxcRemoveDependent Method

TnxBaseSessionPool.nxcRemoveDependent Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.ProcessPost Method

TnxBaseSessionPool.ProcessPost Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.ProcessRequest Method

TnxBaseSessionPool.ProcessRequest Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

InxSessionRequests.

Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.ProcessRequestDirect Method

TnxBaseSessionPool.ProcessRequestDirect Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.scInitializing Method

TnxBaseSessionPool.scInitializing Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.scStarting Method

TnxBaseSessionPool.scStarting Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool.scStopping Method

TnxBaseSessionPool.scStopping Method
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxBaseSessionPool Methods

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Methods


TnxBaseSessionPool Properties

TnxBaseSessionPool Properties
TnxBaseSessionPool Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBaseSessionPool class are listed here.

Class

TnxBaseSessionPool Class

Public Properties
Name | Description
ServerEngine | Returns the Server Engine the session pool is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.
Published Properties
Name | Description
Password | The password for the session pool. It is only used when the connected Server Engine is in secure mode.
Timeout | Sets the Timeout for the Session pool commands (in ms).
UserName | The user name for the session pool. It is only used when the connected Server Engine is in secure mode.
Links
TnxBaseSessionPool Class, Legend, Public Properties, Published Properties


TnxBaseSessionPool.Password Property

TnxBaseSessionPool.Password Property
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Properties See Also Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

The password for the session pool. It is only used when the connected Server Engine is in secure mode.

See Also

UserName, Password

Group

TnxBaseSessionPool Properties

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Properties, See Also


TnxBaseSessionPool.ServerEngine Property

TnxBaseSessionPool.ServerEngine Property
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

Returns the Server Engine the session pool is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.

Group

TnxBaseSessionPool Properties

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Properties


TnxBaseSessionPool.Timeout Property

TnxBaseSessionPool.Timeout Property
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Properties Send Feedback
Syntax
Delphi
property Timeout: Integer;
Description

Sets the Timeout for the Session pool commands (in ms).

Group

TnxBaseSessionPool Properties

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Properties


TnxBaseSessionPool.UserName Property

TnxBaseSessionPool.UserName Property
TnxBaseSessionPool Class TnxBaseSessionPool Members nxdb Namespace TnxBaseSessionPool Properties See Also Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

The user name for the session pool. It is only used when the connected Server Engine is in secure mode.

See Also

UserName, Password

Group

TnxBaseSessionPool Properties

Links
TnxBaseSessionPool Class, TnxBaseSessionPool Members, nxdb Namespace, TnxBaseSessionPool Properties, See Also


TnxBaseUpdateHandler Class

TnxBaseUpdateHandler Class
TnxBaseUpdateHandler Fields TnxBaseUpdateHandler Methods TnxBaseUpdateHandler Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandlernxdb_TnxBaseUpdateHandler
Syntax
Delphi
TnxBaseUpdateHandler = class(TnxDataAccessStateComponent);
File

nxdb

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
TnxBaseUpdateHandler Fields, TnxBaseUpdateHandler Methods, TnxBaseUpdateHandler Members, nxdb, Classes


TnxBaseUpdateHandler Members

TnxBaseUpdateHandler Members
TnxBaseUpdateHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseUpdateHandler.

Class

TnxBaseUpdateHandler Class

Protected Fields
Name | Description
buhCachedDataSet | This is buhCachedDataSet, a member of class TnxBaseUpdateHandler.
buhDatabase | This is buhDatabase, a member of class TnxBaseUpdateHandler.
buhFree | This is buhFree, a member of class TnxBaseUpdateHandler.
buhUpdateObject | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
buhNotifyDelete | This is buhNotifyDelete, a member of class TnxBaseUpdateHandler.
buhNotifyInsert | This is buhNotifyInsert, a member of class TnxBaseUpdateHandler.
buhNotifyModify | This is buhNotifyModify, a member of class TnxBaseUpdateHandler.
Create |
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
AfterConstruction | TnxBaseUpdateHandler
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBaseUpdateHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseUpdateHandler.Create Constructor

TnxBaseUpdateHandler.Create Constructor
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Class Send Feedback
Syntax
Delphi
constructor Create(aUpdateObject: TnxBaseUpdateObject; aCachedDataSet: TnxCachedDataSet); virtual; reintroduce;
Class

TnxBaseUpdateHandler Class

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Class


TnxBaseUpdateHandler Fields

TnxBaseUpdateHandler Fields
TnxBaseUpdateHandler Class Legend Protected Fields Send Feedback

The fields of the TnxBaseUpdateHandler class are listed here.

Class

TnxBaseUpdateHandler Class

Protected Fields
Name | Description
buhCachedDataSet | This is buhCachedDataSet, a member of class TnxBaseUpdateHandler.
buhDatabase | This is buhDatabase, a member of class TnxBaseUpdateHandler.
buhFree | This is buhFree, a member of class TnxBaseUpdateHandler.
buhUpdateObject | private
Links
TnxBaseUpdateHandler Class, Legend, Protected Fields


TnxBaseUpdateHandler.buhCachedDataSet Field

TnxBaseUpdateHandler.buhCachedDataSet Field
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Fields Send Feedback
Syntax
Delphi
buhCachedDataSet: TnxCachedDataSet;
Description

This is buhCachedDataSet, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Fields

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Fields


TnxBaseUpdateHandler.buhDatabase Field

TnxBaseUpdateHandler.buhDatabase Field
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Fields Send Feedback
Syntax
Delphi
buhDatabase: TnxDatabase;
Description

This is buhDatabase, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Fields

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Fields


TnxBaseUpdateHandler.buhFree Field

TnxBaseUpdateHandler.buhFree Field
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Fields Send Feedback
Syntax
Delphi
buhFree: Boolean;
Description

This is buhFree, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Fields

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Fields


TnxBaseUpdateHandler.buhUpdateObject Field

TnxBaseUpdateHandler.buhUpdateObject Field
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Fields Send Feedback
Syntax
Delphi
buhUpdateObject: TnxBaseUpdateObject;
Description

private

Group

TnxBaseUpdateHandler Fields

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Fields


TnxBaseUpdateHandler Methods

TnxBaseUpdateHandler Methods
TnxBaseUpdateHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseUpdateHandler class are listed here.

Class

TnxBaseUpdateHandler Class

Protected Methods
Name | Description
buhNotifyDelete | This is buhNotifyDelete, a member of class TnxBaseUpdateHandler.
buhNotifyInsert | This is buhNotifyInsert, a member of class TnxBaseUpdateHandler.
buhNotifyModify | This is buhNotifyModify, a member of class TnxBaseUpdateHandler.
nxcNotification |
scIsStateParent |
scSetState |
Public Methods
Name | Description
AfterConstruction | TnxBaseUpdateHandler
Links
TnxBaseUpdateHandler Class, Legend, Protected Methods, Public Methods


TnxBaseUpdateHandler.AfterConstruction Method

TnxBaseUpdateHandler.AfterConstruction Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxBaseUpdateHandler

Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.buhNotifyDelete Method

TnxBaseUpdateHandler.buhNotifyDelete Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyDelete(aCursor: TnxAbstractCursor; aOldRecord: PnxByteArray); virtual; abstract;
Description

This is buhNotifyDelete, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.buhNotifyInsert Method

TnxBaseUpdateHandler.buhNotifyInsert Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyInsert(aCursor: TnxAbstractCursor; aNewRecord: PnxByteArray); virtual; abstract;
Description

This is buhNotifyInsert, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.buhNotifyModify Method

TnxBaseUpdateHandler.buhNotifyModify Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyModify(aCursor: TnxAbstractCursor; aNewRecord: PnxByteArray; aOldRecord: PnxByteArray); virtual; abstract;
Description

This is buhNotifyModify, a member of class TnxBaseUpdateHandler.

Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.nxcNotification Method

TnxBaseUpdateHandler.nxcNotification Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.scIsStateParent Method

TnxBaseUpdateHandler.scIsStateParent Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateHandler.scSetState Method

TnxBaseUpdateHandler.scSetState Method
TnxBaseUpdateHandler Class TnxBaseUpdateHandler Members nxdb Namespace TnxBaseUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure scSetState(aState: TnxState); override;
Group

TnxBaseUpdateHandler Methods

Links
TnxBaseUpdateHandler Class, TnxBaseUpdateHandler Members, nxdb Namespace, TnxBaseUpdateHandler Methods


TnxBaseUpdateObject Class

TnxBaseUpdateObject Class
TnxBaseUpdateObject Fields TnxBaseUpdateObject Methods TnxBaseUpdateObject Properties TnxBaseUpdateObject Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxBaseUpdateObjectnxdb_TnxBaseUpdateObjectnxdb_TnxBaseUpdateObjectnxdb_TnxBaseUpdateObject
Syntax
Delphi
TnxBaseUpdateObject = class(TnxComponent);
File

nxdb

Description

Base Update object for cached datasets.

Group

Classes

Links
TnxBaseUpdateObject Fields, TnxBaseUpdateObject Methods, TnxBaseUpdateObject Properties, TnxBaseUpdateObject Members, nxdb, Classes


TnxBaseUpdateObject Members

TnxBaseUpdateObject Members
TnxBaseUpdateObject Class Legend Protected Fields Protected Methods Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxBaseUpdateObject.

Class

TnxBaseUpdateObject Class

Protected Fields
Name | Description
buoTargetDatabase | private
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
buoGetHandlerClass | This is buoGetHandlerClass, a member of class TnxBaseUpdateObject.
buoSetTargetDatabase |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
TargetDatabase | This is TargetDatabase, a member of class TnxBaseUpdateObject.
Version | Version of the component.
Links
TnxBaseUpdateObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Properties


TnxBaseUpdateObject Fields

TnxBaseUpdateObject Fields
TnxBaseUpdateObject Class Legend Protected Fields Send Feedback

The fields of the TnxBaseUpdateObject class are listed here.

Class

TnxBaseUpdateObject Class

Protected Fields
Name | Description
buoTargetDatabase | private
Links
TnxBaseUpdateObject Class, Legend, Protected Fields


TnxBaseUpdateObject.buoTargetDatabase Field

TnxBaseUpdateObject.buoTargetDatabase Field
TnxBaseUpdateObject Class TnxBaseUpdateObject Members nxdb Namespace TnxBaseUpdateObject Fields Send Feedback
Syntax
Delphi
buoTargetDatabase: TnxTargetDatabase;
Description

private

Group

TnxBaseUpdateObject Fields

Links
TnxBaseUpdateObject Class, TnxBaseUpdateObject Members, nxdb Namespace, TnxBaseUpdateObject Fields


TnxBaseUpdateObject Methods

TnxBaseUpdateObject Methods
TnxBaseUpdateObject Class Legend Protected Methods Send Feedback

The methods of the TnxBaseUpdateObject class are listed here.

Class

TnxBaseUpdateObject Class

Protected Methods
Name | Description
buoGetHandlerClass | This is buoGetHandlerClass, a member of class TnxBaseUpdateObject.
buoSetTargetDatabase |
Links
TnxBaseUpdateObject Class, Legend, Protected Methods


TnxBaseUpdateObject.buoGetHandlerClass Method

TnxBaseUpdateObject.buoGetHandlerClass Method
TnxBaseUpdateObject Class TnxBaseUpdateObject Members nxdb Namespace TnxBaseUpdateObject Methods Send Feedback
Syntax
Delphi
function buoGetHandlerClass: TnxBaseUpdateHandlerClass; virtual; abstract;
Description

This is buoGetHandlerClass, a member of class TnxBaseUpdateObject.

Group

TnxBaseUpdateObject Methods

Links
TnxBaseUpdateObject Class, TnxBaseUpdateObject Members, nxdb Namespace, TnxBaseUpdateObject Methods


TnxBaseUpdateObject.buoSetTargetDatabase Method

TnxBaseUpdateObject.buoSetTargetDatabase Method
TnxBaseUpdateObject Class TnxBaseUpdateObject Members nxdb Namespace TnxBaseUpdateObject Methods Send Feedback
Syntax
Delphi
procedure buoSetTargetDatabase(const Value: TnxTargetDatabase); virtual;
Group

TnxBaseUpdateObject Methods

Links
TnxBaseUpdateObject Class, TnxBaseUpdateObject Members, nxdb Namespace, TnxBaseUpdateObject Methods


TnxBaseUpdateObject Properties

TnxBaseUpdateObject Properties
TnxBaseUpdateObject Class Legend Published Properties Send Feedback

The properties of the TnxBaseUpdateObject class are listed here.

Class

TnxBaseUpdateObject Class

Published Properties
Name | Description
TargetDatabase | This is TargetDatabase, a member of class TnxBaseUpdateObject.
Links
TnxBaseUpdateObject Class, Legend, Published Properties


TnxBaseUpdateObject.TargetDatabase Property

TnxBaseUpdateObject.TargetDatabase Property
TnxBaseUpdateObject Class TnxBaseUpdateObject Members nxdb Namespace TnxBaseUpdateObject Properties Send Feedback
Syntax
Delphi
property TargetDatabase: TnxTargetDatabase;
Description

This is TargetDatabase, a member of class TnxBaseUpdateObject.

Group

TnxBaseUpdateObject Properties

Links
TnxBaseUpdateObject Class, TnxBaseUpdateObject Members, nxdb Namespace, TnxBaseUpdateObject Properties


TnxBatchAppendBlobStream Class

TnxBatchAppendBlobStream Class
TnxBatchAppendBlobStream Methods TnxBatchAppendBlobStream Members nxdb Classes See Also Send Feedback
Class Hierarchy
nxdb_TnxBatchAppendBlobStreamnxdb_TnxBatchAppendBlobStream
Syntax
Delphi
TnxBatchAppendBlobStream = class(TnxBaseBlobStream);
File

nxdb

Description

This class is used if the dataset is in batch append mode.

Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TnxDataSet.CreateBlobStream TnxBaseBlobStream TnxBlobStream TnxBlockModeBlobStream TnxMemoBlobStream

Group

Classes

Links
TnxBatchAppendBlobStream Methods, TnxBatchAppendBlobStream Members, nxdb, Classes, See Also


TnxBatchAppendBlobStream Members

TnxBatchAppendBlobStream Members
TnxBatchAppendBlobStream Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBatchAppendBlobStream.

Class

TnxBatchAppendBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
Create | constructor. TnxBatchAppendBlobStream
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Destroy | destructor.
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxBatchAppendBlobStream Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBatchAppendBlobStream.Create Constructor

TnxBatchAppendBlobStream.Create Constructor
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Class Send Feedback
Syntax
Delphi
constructor Create(aField: TBlobField; aMode: TBlobStreamMode); override;
Description

constructor.

TnxBatchAppendBlobStream

Class

TnxBatchAppendBlobStream Class

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Class


TnxBatchAppendBlobStream.Destroy Destructor

TnxBatchAppendBlobStream.Destroy Destructor
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBatchAppendBlobStream Class

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Class


TnxBatchAppendBlobStream Methods

TnxBatchAppendBlobStream Methods
TnxBatchAppendBlobStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBatchAppendBlobStream class are listed here.

Class

TnxBatchAppendBlobStream Class

Protected Methods
Name | Description
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxBatchAppendBlobStream Class, Legend, Protected Methods, Public Methods


TnxBatchAppendBlobStream.Read Method

TnxBatchAppendBlobStream.Read Method
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
var aBuffer | variable to store the read bytes
aCount: Integer | number of bytes to read
Description

With this method you can read a number of bytes of the blob data.

Group

TnxBatchAppendBlobStream Methods

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Methods


TnxBatchAppendBlobStream.Seek Method

TnxBatchAppendBlobStream.Seek Method
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Integer; aOrigin: Word): Integer; override;
Parameters
Parameters | Description
aOffset: Integer | the offset in bytes to move the pointer
aOrigin: Word | the origin of the aOffset
Description

Seek sets the current position in the blob stream.

Group

TnxBatchAppendBlobStream Methods

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Methods


SetSize Method

SetSize Method
TnxBatchAppendBlobStream Methods Send Feedback

This is the overview for the SetSize method overload.

Overload List
Name | Description
TnxBatchAppendBlobStream.SetSize (Int64) |
TnxBatchAppendBlobStream.SetSize (Longint) | This is SetSize, a member of class TnxBatchAppendBlobStream.
Group

TnxBatchAppendBlobStream Methods

Links
TnxBatchAppendBlobStream Methods


TnxBatchAppendBlobStream.SetSize Method (Int64)

TnxBatchAppendBlobStream.SetSize Method (Int64)
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(const NewSize: Int64); override; overload;
Group

SetSize Method

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, SetSize Method


TnxBatchAppendBlobStream.SetSize Method (Longint)

TnxBatchAppendBlobStream.SetSize Method (Longint)
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(NewSize: Longint); override; overload;
Description

This is SetSize, a member of class TnxBatchAppendBlobStream.

Group

SetSize Method

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, SetSize Method


TnxBatchAppendBlobStream.Truncate Method

TnxBatchAppendBlobStream.Truncate Method
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Methods Send Feedback
Syntax
Delphi
procedure Truncate; override;
Description

This method truncates the blob data at the current position.

Group

TnxBatchAppendBlobStream Methods

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Methods


TnxBatchAppendBlobStream.Write Method

TnxBatchAppendBlobStream.Write Method
TnxBatchAppendBlobStream Class TnxBatchAppendBlobStream Members nxdb Namespace TnxBatchAppendBlobStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
const aBuffer | data to be written
aCount: Integer | number of bytes to write
Description

Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.

Group

TnxBatchAppendBlobStream Methods

Links
TnxBatchAppendBlobStream Class, TnxBatchAppendBlobStream Members, nxdb Namespace, TnxBatchAppendBlobStream Methods


TnxBlobStream Class

TnxBlobStream Class
TnxBlobStream Fields TnxBlobStream Methods TnxBlobStream Properties TnxBlobStream Members nxdb Classes See Also Send Feedback
Class Hierarchy
nxdb_TnxBlobStreamnxdb_TnxBlobStream
Syntax
Delphi
TnxBlobStream = class(TnxBaseBlobStream);
File

nxdb

Description

This class is used to access a blob directly. All calls are directly passed through to the server engine.

Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TnxDataSet.CreateBlobStream TnxBaseBlobStream TnxBlockModeBlobStream TnxBatchAppendBlobStream TnxMemoBlobStream

Group

Classes

Links
TnxBlobStream Fields, TnxBlobStream Methods, TnxBlobStream Properties, TnxBlobStream Members, nxdb, Classes, See Also


TnxBlobStream Members

TnxBlobStream Members
TnxBlobStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBlobStream.

Class

TnxBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
bsBuffer | private
bsChunkSize | This is bsChunkSize, a member of class TnxBlobStream.
bsModified | This is bsModified, a member of class TnxBlobStream.
bsOpened | This is bsOpened, a member of class TnxBlobStream.
bsPosition | This is bsPosition, a member of class TnxBlobStream.
bsReadOrg | This is bsReadOrg, a member of class TnxBlobStream.
Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
bsGetBlobSize |
bsHasRecordChangedAtServer |
bsShouldRetry |
Create | constructor.
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Destroy | destructor.
Read | With this method you can read a number of bytes of the blob data.
Seek | This is the overview for the Seek method overload.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Public Properties
Name | Description
ChunkSize | Chunksize specifies the number of byte that are read/written in one file access.
Links
TnxBlobStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBlobStream.Create Constructor

TnxBlobStream.Create Constructor
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Class Send Feedback
Syntax
Delphi
constructor Create(aField: TBlobField; aMode: TBlobStreamMode; aReadOrg: Boolean); reintroduce;
Description

constructor.

Class

TnxBlobStream Class

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Class


TnxBlobStream.Destroy Destructor

TnxBlobStream.Destroy Destructor
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBlobStream Class

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Class


TnxBlobStream Fields

TnxBlobStream Fields
TnxBlobStream Class Legend Protected Fields Send Feedback

The fields of the TnxBlobStream class are listed here.

Class

TnxBlobStream Class

Protected Fields
Name | Description
bsBuffer | private
bsChunkSize | This is bsChunkSize, a member of class TnxBlobStream.
bsModified | This is bsModified, a member of class TnxBlobStream.
bsOpened | This is bsOpened, a member of class TnxBlobStream.
bsPosition | This is bsPosition, a member of class TnxBlobStream.
bsReadOrg | This is bsReadOrg, a member of class TnxBlobStream.
Links
TnxBlobStream Class, Legend, Protected Fields


TnxBlobStream.bsBuffer Field

TnxBlobStream.bsBuffer Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsBuffer: TnxRecordBuffer;
Description

private

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream.bsChunkSize Field

TnxBlobStream.bsChunkSize Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsChunkSize: Integer;
Description

This is bsChunkSize, a member of class TnxBlobStream.

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream.bsModified Field

TnxBlobStream.bsModified Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsModified: Boolean;
Description

This is bsModified, a member of class TnxBlobStream.

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream.bsOpened Field

TnxBlobStream.bsOpened Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsOpened: Boolean;
Description

This is bsOpened, a member of class TnxBlobStream.

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream.bsPosition Field

TnxBlobStream.bsPosition Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsPosition: TnxInt64;
Description

This is bsPosition, a member of class TnxBlobStream.

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream.bsReadOrg Field

TnxBlobStream.bsReadOrg Field
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Fields Send Feedback
Syntax
Delphi
bsReadOrg: Boolean;
Description

This is bsReadOrg, a member of class TnxBlobStream.

Group

TnxBlobStream Fields

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Fields


TnxBlobStream Methods

TnxBlobStream Methods
TnxBlobStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBlobStream class are listed here.

Class

TnxBlobStream Class

Protected Methods
Name | Description
bsGetBlobSize |
bsHasRecordChangedAtServer |
bsShouldRetry |
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Read | With this method you can read a number of bytes of the blob data.
Seek | This is the overview for the Seek method overload.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxBlobStream Class, Legend, Protected Methods, Public Methods


TnxBlobStream.bsGetBlobSize Method

TnxBlobStream.bsGetBlobSize Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
function bsGetBlobSize: TnxWord32;
Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


TnxBlobStream.bsHasRecordChangedAtServer Method

TnxBlobStream.bsHasRecordChangedAtServer Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
function bsHasRecordChangedAtServer(var aStatus: TnxResult): Boolean;
Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


TnxBlobStream.bsShouldRetry Method

TnxBlobStream.bsShouldRetry Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
function bsShouldRetry(var aStatus: TnxResult): Boolean;
Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


TnxBlobStream.Read Method

TnxBlobStream.Read Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
var aBuffer | variable to store the read bytes
aCount: Integer | number of bytes to read
Description

With this method you can read a number of bytes of the blob data.

Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


Seek Method

Seek Method
TnxBlobStream Methods Send Feedback

This is the overview for the Seek method overload.

Overload List
Name | Description
TnxBlobStream.Seek (Int64, TSeekOrigin) | Seek sets the current position in the blob stream.
TnxBlobStream.Seek (Integer, Word) | Seek sets the current position in the blob stream.
Group

TnxBlobStream Methods

Links
TnxBlobStream Methods


TnxBlobStream.Seek Method (Int64, TSeekOrigin)

TnxBlobStream.Seek Method (Int64, TSeekOrigin)
TnxBlobStream Class TnxBlobStream Members nxdb Namespace Seek Method Send Feedback
Syntax
Delphi
function Seek(const aOffset: Int64; aOrigin: TSeekOrigin): Int64; override;
Parameters
Parameters | Description
const aOffset: Int64 | the offset in bytes to move the pointer
aOrigin: TSeekOrigin | the origin of the aOffset
Description

Seek sets the current position in the blob stream.

Group

Seek Method

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, Seek Method


TnxBlobStream.Seek Method (Integer, Word)

TnxBlobStream.Seek Method (Integer, Word)
TnxBlobStream Class TnxBlobStream Members nxdb Namespace Seek Method Send Feedback
Syntax
Delphi
function Seek(aOffset: Integer; aOrigin: Word): Integer; override;
Parameters
Parameters | Description
aOffset: Integer | the offset in bytes to move the pointer
aOrigin: Word | the origin of the aOffset
Description

Seek sets the current position in the blob stream.

Group

Seek Method

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, Seek Method


SetSize Method

SetSize Method
TnxBlobStream Methods Send Feedback

This is the overview for the SetSize method overload.

Overload List
Name | Description
TnxBlobStream.SetSize (Int64) |
TnxBlobStream.SetSize (Longint) | This is SetSize, a member of class TnxBlobStream.
Group

TnxBlobStream Methods

Links
TnxBlobStream Methods


TnxBlobStream.SetSize Method (Int64)

TnxBlobStream.SetSize Method (Int64)
TnxBlobStream Class TnxBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(const NewSize: Int64); override; overload;
Group

SetSize Method

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, SetSize Method


TnxBlobStream.SetSize Method (Longint)

TnxBlobStream.SetSize Method (Longint)
TnxBlobStream Class TnxBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(NewSize: Longint); override; overload;
Description

This is SetSize, a member of class TnxBlobStream.

Group

SetSize Method

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, SetSize Method


TnxBlobStream.Truncate Method

TnxBlobStream.Truncate Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
procedure Truncate; override;
Description

This method truncates the blob data at the current position.

Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


TnxBlobStream.Write Method

TnxBlobStream.Write Method
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
const aBuffer | data to be written
aCount: Integer | number of bytes to write
Description

Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.

Group

TnxBlobStream Methods

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Methods


TnxBlobStream Properties

TnxBlobStream Properties
TnxBlobStream Class Legend Public Properties Send Feedback

The properties of the TnxBlobStream class are listed here.

Class

TnxBlobStream Class

Public Properties
Name | Description
ChunkSize | Chunksize specifies the number of byte that are read/written in one file access.
Links
TnxBlobStream Class, Legend, Public Properties


TnxBlobStream.ChunkSize Property

TnxBlobStream.ChunkSize Property
TnxBlobStream Class TnxBlobStream Members nxdb Namespace TnxBlobStream Properties Send Feedback
Syntax
Delphi
property ChunkSize: Integer;
Description

Chunksize specifies the number of byte that are read/written in one file access.

Group

TnxBlobStream Properties

Links
TnxBlobStream Class, TnxBlobStream Members, nxdb Namespace, TnxBlobStream Properties


TnxBlockModeBlobStream Class

TnxBlockModeBlobStream Class
TnxBlockModeBlobStream Fields TnxBlockModeBlobStream Methods TnxBlockModeBlobStream Members nxdb Classes See Also Send Feedback
Class Hierarchy
nxdb_TnxBlockModeBlobStreamnxdb_TnxBlockModeBlobStream
Syntax
Delphi
TnxBlockModeBlobStream = class(TnxBaseBlobStream);
File

nxdb

Description

This class is used if the dataset is in block read mode.

Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TnxDataSet.CreateBlobStream TnxBaseBlobStream TnxBlobStream TnxBatchAppendBlobStream TnxMemoBlobStream

Group

Classes

Links
TnxBlockModeBlobStream Fields, TnxBlockModeBlobStream Methods, TnxBlockModeBlobStream Members, nxdb, Classes, See Also


TnxBlockModeBlobStream Members

TnxBlockModeBlobStream Members
TnxBlockModeBlobStream Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBlockModeBlobStream.

Class

TnxBlockModeBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
bmbsBlob | This is bmbsBlob, a member of class TnxBlockModeBlobStream.
bmbsPosition | private
Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
Create | constructor. TnxBlockModeBlobStream
Public Methods
Name | Description
Destroy | destructor.
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxBlockModeBlobStream Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBlockModeBlobStream.Create Constructor

TnxBlockModeBlobStream.Create Constructor
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Class Send Feedback
Syntax
Delphi
constructor Create(aField: TBlobField; aMode: TBlobStreamMode); override;
Description

constructor.

TnxBlockModeBlobStream

Class

TnxBlockModeBlobStream Class

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Class


TnxBlockModeBlobStream Fields

TnxBlockModeBlobStream Fields
TnxBlockModeBlobStream Class Legend Protected Fields Send Feedback

The fields of the TnxBlockModeBlobStream class are listed here.

Class

TnxBlockModeBlobStream Class

Protected Fields
Name | Description
bmbsBlob | This is bmbsBlob, a member of class TnxBlockModeBlobStream.
bmbsPosition | private
Links
TnxBlockModeBlobStream Class, Legend, Protected Fields


TnxBlockModeBlobStream.bmbsBlob Field

TnxBlockModeBlobStream.bmbsBlob Field
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Fields Send Feedback
Syntax
Delphi
bmbsBlob: Pointer;
Description

This is bmbsBlob, a member of class TnxBlockModeBlobStream.

Group

TnxBlockModeBlobStream Fields

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Fields


TnxBlockModeBlobStream.bmbsPosition Field

TnxBlockModeBlobStream.bmbsPosition Field
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Fields Send Feedback
Syntax
Delphi
bmbsPosition: Integer;
Description

private

Group

TnxBlockModeBlobStream Fields

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Fields


TnxBlockModeBlobStream Methods

TnxBlockModeBlobStream Methods
TnxBlockModeBlobStream Class Legend Public Methods Send Feedback

The methods of the TnxBlockModeBlobStream class are listed here.

Class

TnxBlockModeBlobStream Class

Public Methods
Name | Description
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxBlockModeBlobStream Class, Legend, Public Methods


TnxBlockModeBlobStream.Read Method

TnxBlockModeBlobStream.Read Method
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
var aBuffer | variable to store the read bytes
aCount: Integer | number of bytes to read
Description

With this method you can read a number of bytes of the blob data.

Group

TnxBlockModeBlobStream Methods

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Methods


TnxBlockModeBlobStream.Seek Method

TnxBlockModeBlobStream.Seek Method
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Integer; aOrigin: Word): Integer; override;
Parameters
Parameters | Description
aOffset: Integer | the offset in bytes to move the pointer
aOrigin: Word | the origin of the aOffset
Description

Seek sets the current position in the blob stream.

Group

TnxBlockModeBlobStream Methods

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Methods


TnxBlockModeBlobStream.Truncate Method

TnxBlockModeBlobStream.Truncate Method
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Methods Send Feedback
Syntax
Delphi
procedure Truncate; override;
Description

This method truncates the blob data at the current position.

Group

TnxBlockModeBlobStream Methods

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Methods


TnxBlockModeBlobStream.Write Method

TnxBlockModeBlobStream.Write Method
TnxBlockModeBlobStream Class TnxBlockModeBlobStream Members nxdb Namespace TnxBlockModeBlobStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
const aBuffer | data to be written
aCount: Integer | number of bytes to write
Description

Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.

Group

TnxBlockModeBlobStream Methods

Links
TnxBlockModeBlobStream Class, TnxBlockModeBlobStream Members, nxdb Namespace, TnxBlockModeBlobStream Methods


TnxCachedDataSet Class

TnxCachedDataSet Class
TnxCachedDataSet Fields TnxCachedDataSet Methods TnxCachedDataSet Properties TnxCachedDataSet Events TnxCachedDataSet Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxCachedDataSetnxdb_TnxCachedDataSetnxdb_TnxCachedDataSet
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxCachedDataSet = class(TnxIndexDataSet);
File

nxdb

Description

A natively caching Dataset. Attach a TnxSqlUpdateObject for allowing writeback to underlying datasets.

Group

Classes

Links
TnxCachedDataSet Fields, TnxCachedDataSet Methods, TnxCachedDataSet Properties, TnxCachedDataSet Events, TnxCachedDataSet Members, nxdb, Classes


TnxCachedDataSet Members

TnxCachedDataSet Members
TnxCachedDataSet Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxCachedDataSet.

Class

TnxCachedDataSet Class

Protected Fields
Name | Description
cdsAddFieldDefs | This is cdsAddFieldDefs, a member of class TnxCachedDataSet.
cdsAddIndexDefs | This is cdsAddIndexDefs, a member of class TnxCachedDataSet.
cdsBatchSize | This is cdsBatchSize, a member of class TnxCachedDataSet.
cdsOnCreateTable | This is cdsOnCreateTable, a member of class TnxCachedDataSet.
cdsOptions | This is cdsOptions, a member of class TnxCachedDataSet.
cdsReadOnly | private
cdsSourceDataSet | This is cdsSourceDataSet, a member of class TnxCachedDataSet.
cdsTableName | This is cdsTableName, a member of class TnxCachedDataSet.
cdsUpdateHandler | This is cdsUpdateHandler, a member of class TnxCachedDataSet.
cdsUpdateObject | This is cdsUpdateObject, a member of class TnxCachedDataSet.
cdsUsedTableName | This is cdsUsedTableName, a member of class TnxCachedDataSet.
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
idDefaultIndex | This is idDefaultIndex, a member of class TnxIndexDataSet.
idDirectKeySetFields | This is idDirectKeySetFields, a member of class TnxIndexDataSet.
idFieldsIndex | current index.
idIndexDefs | private index management.
idIndexDirectKey | This is idIndexDirectKey, a member of class TnxIndexDataSet.
idIndexFieldMap | This is idIndexFieldMap, a member of class TnxIndexDataSet.
idIndexFieldMapNC | This is idIndexFieldMapNC, a member of class TnxIndexDataSet.
idIndexFieldNames | This is idIndexFieldNames, a member of class TnxIndexDataSet.
idIndexKeySize | This is idIndexKeySize, a member of class TnxIndexDataSet.
idIndexName | This is idIndexName, a member of class TnxIndexDataSet.
idKeyBuffer | This is idKeyBuffer, a member of class TnxIndexDataSet.
idKeyBuffers | This is idKeyBuffers, a member of class TnxIndexDataSet.
idKeyBufferSize | key buffers.
idLookupCaseIns | This is idLookupCaseIns, a member of class TnxIndexDataSet.
idLookupCursorID | This is idLookupCursorID, a member of class TnxIndexDataSet.
idLookupFieldNames | lookup/locate.
idMasterLink | master/detail support.
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
cdsAddFieldDefsStored |
cdsAddIndexDefsStored | TnxCachedDataSet
cdsGetDatabaseExtender |
cdsHandleError | This is the overview for the cdsHandleError method overload.
cdsSetAddFieldDefs | AddFieldDefs.
cdsSetAddIndexDefs | AddIndexDefs.
cdsSetReadOnly | property access methods == StoreDefs.
cdsSetSourceDataSet |
cdsSetTableName |
cdsSetUpdateObject |
cdsUpdateHandlerCreated |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DataEvent | == virtual TDataSet methods == info.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
DoOnNewRecord | record access/update.
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsApplyMasterRange | master/detail support.
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDestroyLookupCursor | locate/lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetActiveKeyBuffer | buffer management.
dsGetBlobNr |
dsGetCursorClass | internal functions == open/close.
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitBookmarkSize | internal functions == init.
dsInitKeyBuffers | key buffers.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateOrdinalPartialMatchRecord | This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.
dsLocateRecord |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID |
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | == virtual TDataSet methods == -- info
GetDataSource | master/detail support.
GetFieldClass |
GetIsIndexField |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
idAddIndexDefsToIndicesDesc |
idAddIndexDefToIndicesDesc |
idAfterGetRecordForKey |
idBeforeGetRecordForKey |
idCheckSetKeyMode | key managment.
idFieldDefsStored | == property access methods == FieldDefs.
idGetIndexField | IndexFields.
idGetIndexFieldCount | IndexFieldCount.
idGetIndexFieldNames | IndexFieldNames.
idGetIndexName | IndexName.
idGetKeyBuffer |
idGetKeyExclusive | KeyExclusive.
idGetKeyFieldCount | KeyFieldCount.
idGetKeyPartialLen | KeyPartialLen.
idGetLookupCursor |
idGetMasterFields | master/detail support.
idGetMasterSource |
idGetRecordForKey |
idHasActiveRange |
idHasActiveRangeEnd |
idHasActiveRangeStart | range managment.
idIndexDefsStored |
idInitIndexMap |
idInitKeyBuffer |
idMapsToIndex |
idMasterChanged |
idMasterDisabled |
idPostKeyBuffer |
idRefIndexSetFields | ref index support
idResetCursorRange |
idResolveIndexName |
idSetCursorRange |
idSetIndex | index managment.
idSetIndexDefs | IndexDefs.
idSetIndexField |
idSetIndexFieldNames |
idSetIndexName |
idSetKeyBuffer |
idSetKeyExclusive |
idSetKeyFieldCount |
idSetKeyFields | This is the overview for the idSetKeyFields method overload.
idSetKeyPartialLen |
idSetLinkRange |
idSetMasterFields |
idSetMasterSource |
idSwitchToIndex |
idTokenIndexSetFields | token index support
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSGetDefaultOrder | IProviderSupport.
PSGetIndexDefs |
PSGetKeyFields |
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
UpdateIndexDefs | index managment.
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
ApplyRange | see tTable.ApplyRange. TnxIndexDataSet
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
Cancel | see tDataSet.Cancel.
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CancelRange | see tTable.CancelRange.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EditKey | see tTable.EditKey.
EditRangeEnd | see tTable.EditRangeEnd.
EditRangeStart | see tTable.EditRangeStart.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FindKey | This is the overview for the FindKey method overload.
FindNearest | This is the overview for the FindNearest method overload.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetIndexNames | see tTable.GetIndexNames.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
GotoKey | see tTable.GotoKey.
GotoNearest | see tTable.GotoNearest
GotoNearestBackward | see tTable.GotoNearest
HasActiveRange |
HasActiveRangeEnd |
HasActiveRangeStart |
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
Post | == virtual TDataSet methods == -- navigation
Post | see tDataSet.Post.
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
SetKey | see tTable.FindNearest.
SetRange | This is the overview for the SetRange method overload.
SetRangeEnd | see tTable.SetRangeEnd.
SetRangeShared | This is the overview for the SetRangeShared method overload.
SetRangeSimple | Sets a normal simple Range (as opposed to SetRangeShared).
SetRangeStart | see tTable.SetRangeStart.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
ActiveIndexName | This is ActiveIndexName, a member of class TnxIndexDataSet.
FieldDefs | see tTable.FieldDefs
FieldsDescriptor | Returns the Fields Descriptor of the current table.
IndexDefs | see tTable.IndexDefs.
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnCreateTable | This event is fired before the local table is create by the server.
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AddFieldDefs | Used to define additional fields that should be added to the cached table
AddIndexDefs | Used to define additional indicies that should be added to the cached table
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BatchSize | Batch/Block size for in bytes.
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | Options for the cached dataset.
ReadOnly | see tTable.ReadOnly
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
SourceDataSet | The dataset the data is fetched from.
TableName | Original Tablename. ???
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
UpdateObject | The object responsible for updating the underlying datasets.
UsedTableName | ???
Version | The version information for the current dataset.
Links
TnxCachedDataSet Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxCachedDataSet.Create Constructor

TnxCachedDataSet.Create Constructor
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxCachedDataSet Class

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Class


TnxCachedDataSet.Destroy Destructor

TnxCachedDataSet.Destroy Destructor
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxCachedDataSet Class

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Class


TnxCachedDataSet Fields

TnxCachedDataSet Fields
TnxCachedDataSet Class Legend Protected Fields Send Feedback

The fields of the TnxCachedDataSet class are listed here.

Class

TnxCachedDataSet Class

Protected Fields
Name | Description
cdsAddFieldDefs | This is cdsAddFieldDefs, a member of class TnxCachedDataSet.
cdsAddIndexDefs | This is cdsAddIndexDefs, a member of class TnxCachedDataSet.
cdsBatchSize | This is cdsBatchSize, a member of class TnxCachedDataSet.
cdsOnCreateTable | This is cdsOnCreateTable, a member of class TnxCachedDataSet.
cdsOptions | This is cdsOptions, a member of class TnxCachedDataSet.
cdsReadOnly | private
cdsSourceDataSet | This is cdsSourceDataSet, a member of class TnxCachedDataSet.
cdsTableName | This is cdsTableName, a member of class TnxCachedDataSet.
cdsUpdateHandler | This is cdsUpdateHandler, a member of class TnxCachedDataSet.
cdsUpdateObject | This is cdsUpdateObject, a member of class TnxCachedDataSet.
cdsUsedTableName | This is cdsUsedTableName, a member of class TnxCachedDataSet.
Links
TnxCachedDataSet Class, Legend, Protected Fields


TnxCachedDataSet.cdsAddFieldDefs Field

TnxCachedDataSet.cdsAddFieldDefs Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsAddFieldDefs: TFieldDefs;
Description

This is cdsAddFieldDefs, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsAddIndexDefs Field

TnxCachedDataSet.cdsAddIndexDefs Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsAddIndexDefs: TIndexDefs;
Description

This is cdsAddIndexDefs, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsBatchSize Field

TnxCachedDataSet.cdsBatchSize Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsBatchSize: Integer;
Description

This is cdsBatchSize, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsOnCreateTable Field

TnxCachedDataSet.cdsOnCreateTable Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsOnCreateTable: TnxCreateTableEvent;
Description

This is cdsOnCreateTable, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsOptions Field

TnxCachedDataSet.cdsOptions Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsOptions: TnxCachedDataSetOptions;
Description

This is cdsOptions, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsReadOnly Field

TnxCachedDataSet.cdsReadOnly Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsReadOnly: Boolean;
Description

private

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsSourceDataSet Field

TnxCachedDataSet.cdsSourceDataSet Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsSourceDataSet: TnxDataSet;
Description

This is cdsSourceDataSet, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsTableName Field

TnxCachedDataSet.cdsTableName Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsTableName: string;
Description

This is cdsTableName, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsUpdateHandler Field

TnxCachedDataSet.cdsUpdateHandler Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsUpdateHandler: TnxBaseUpdateHandler;
Description

This is cdsUpdateHandler, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsUpdateObject Field

TnxCachedDataSet.cdsUpdateObject Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsUpdateObject: TnxBaseUpdateObject;
Description

This is cdsUpdateObject, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet.cdsUsedTableName Field

TnxCachedDataSet.cdsUsedTableName Field
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Fields Send Feedback
Syntax
Delphi
cdsUsedTableName: string;
Description

This is cdsUsedTableName, a member of class TnxCachedDataSet.

Group

TnxCachedDataSet Fields

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Fields


TnxCachedDataSet Methods

TnxCachedDataSet Methods
TnxCachedDataSet Class Legend Protected Methods Send Feedback

The methods of the TnxCachedDataSet class are listed here.

Class

TnxCachedDataSet Class

Protected Methods
Name | Description
cdsAddFieldDefsStored |
cdsAddIndexDefsStored | TnxCachedDataSet
cdsGetDatabaseExtender |
cdsHandleError | This is the overview for the cdsHandleError method overload.
cdsSetAddFieldDefs | AddFieldDefs.
cdsSetAddIndexDefs | AddIndexDefs.
cdsSetReadOnly | property access methods == StoreDefs.
cdsSetSourceDataSet |
cdsSetTableName |
cdsSetUpdateObject |
cdsUpdateHandlerCreated |
CreateFields |
dsCloseCursorID |
dsGetCursorClass | internal functions == open/close.
dsOpenCursorID |
GetCanModify | == virtual TDataSet methods == -- info
Notification |
Links
TnxCachedDataSet Class, Legend, Protected Methods


TnxCachedDataSet.cdsAddFieldDefsStored Method

TnxCachedDataSet.cdsAddFieldDefsStored Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
function cdsAddFieldDefsStored: Boolean; virtual;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsAddIndexDefsStored Method

TnxCachedDataSet.cdsAddIndexDefsStored Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
function cdsAddIndexDefsStored: Boolean; virtual;
Description

TnxCachedDataSet

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsGetDatabaseExtender Method

TnxCachedDataSet.cdsGetDatabaseExtender Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
function cdsGetDatabaseExtender: TnxCachedDataSetDatabaseExtender;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


cdsHandleError Method

cdsHandleError Method
TnxCachedDataSet Methods Send Feedback

This is the overview for the cdsHandleError method overload.

Overload List
Name | Description
TnxCachedDataSet.cdsHandleError (TnxResult, PResStringRec, TStream) |
TnxCachedDataSet.cdsHandleError (TnxResult, string, TStream) |
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Methods


TnxCachedDataSet.cdsHandleError Method (TnxResult, PResStringRec, TStream)

TnxCachedDataSet.cdsHandleError Method (TnxResult, PResStringRec, TStream)
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace cdsHandleError Method Send Feedback
Syntax
Delphi
procedure cdsHandleError(aResult: TnxResult; aMsgRes: PResStringRec; aStream: TStream); overload;
Group

cdsHandleError Method

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, cdsHandleError Method


TnxCachedDataSet.cdsHandleError Method (TnxResult, string, TStream)

TnxCachedDataSet.cdsHandleError Method (TnxResult, string, TStream)
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace cdsHandleError Method Send Feedback
Syntax
Delphi
procedure cdsHandleError(aResult: TnxResult; const aMsg: string; aStream: TStream); overload;
Group

cdsHandleError Method

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, cdsHandleError Method


TnxCachedDataSet.cdsSetAddFieldDefs Method

TnxCachedDataSet.cdsSetAddFieldDefs Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetAddFieldDefs(Value: TFieldDefs);
Description

AddFieldDefs.

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsSetAddIndexDefs Method

TnxCachedDataSet.cdsSetAddIndexDefs Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetAddIndexDefs(Value: TIndexDefs);
Description

AddIndexDefs.

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsSetReadOnly Method

TnxCachedDataSet.cdsSetReadOnly Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetReadOnly(const Value: Boolean);
Description

property access methods == StoreDefs.

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsSetSourceDataSet Method

TnxCachedDataSet.cdsSetSourceDataSet Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetSourceDataSet(const Value: TnxDataSet);
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsSetTableName Method

TnxCachedDataSet.cdsSetTableName Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetTableName(const Value: string);
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsSetUpdateObject Method

TnxCachedDataSet.cdsSetUpdateObject Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsSetUpdateObject(const Value: TnxBaseUpdateObject);
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.cdsUpdateHandlerCreated Method

TnxCachedDataSet.cdsUpdateHandlerCreated Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure cdsUpdateHandlerCreated(aUpdateHandler: TnxBaseUpdateHandler);
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.CreateFields Method

TnxCachedDataSet.CreateFields Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure CreateFields; override;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.dsCloseCursorID Method

TnxCachedDataSet.dsCloseCursorID Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure dsCloseCursorID; override;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.dsGetCursorClass Method

TnxCachedDataSet.dsGetCursorClass Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
function dsGetCursorClass: TnxCursorClass; override;
Description

internal functions == open/close.

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.dsOpenCursorID Method

TnxCachedDataSet.dsOpenCursorID Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure dsOpenCursorID; override;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.GetCanModify Method

TnxCachedDataSet.GetCanModify Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
function GetCanModify: Boolean; override;
Description

== virtual TDataSet methods == -- info

Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet.Notification Method

TnxCachedDataSet.Notification Method
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Methods Send Feedback
Syntax
Delphi
procedure Notification(aComponent: TComponent; aOperation: TOperation); override;
Group

TnxCachedDataSet Methods

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Methods


TnxCachedDataSet Properties

TnxCachedDataSet Properties
TnxCachedDataSet Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxCachedDataSet class are listed here.

Class

TnxCachedDataSet Class

Public Properties
Name | Description
FieldDefs | see tTable.FieldDefs
IndexDefs | see tTable.IndexDefs.
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
Published Properties
Name | Description
AddFieldDefs | Used to define additional fields that should be added to the cached table
AddIndexDefs | Used to define additional indicies that should be added to the cached table
BatchSize | Batch/Block size for in bytes.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
Options | Options for the cached dataset.
ReadOnly | see tTable.ReadOnly
SourceDataSet | The dataset the data is fetched from.
TableName | Original Tablename. ???
UpdateObject | The object responsible for updating the underlying datasets.
UsedTableName | ???
Links
TnxCachedDataSet Class, Legend, Public Properties, Published Properties


TnxCachedDataSet.AddFieldDefs Property

TnxCachedDataSet.AddFieldDefs Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property AddFieldDefs: TFieldDefs;
Description

Used to define additional fields that should be added to the cached table

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.AddIndexDefs Property

TnxCachedDataSet.AddIndexDefs Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property AddIndexDefs: TIndexDefs;
Description

Used to define additional indicies that should be added to the cached table

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.BatchSize Property

TnxCachedDataSet.BatchSize Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property BatchSize: Integer;
Description

Batch/Block size for in bytes.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.FieldDefs Property

TnxCachedDataSet.FieldDefs Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property FieldDefs;
Description

see tTable.FieldDefs

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.IndexDefs Property

TnxCachedDataSet.IndexDefs Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property IndexDefs: TIndexDefs;
Description

see tTable.IndexDefs.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.IndexFieldCount Property

TnxCachedDataSet.IndexFieldCount Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property IndexFieldCount: Integer;
Description

see tTable.IndexFieldCount.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.IndexFieldNames Property

TnxCachedDataSet.IndexFieldNames Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property IndexFieldNames: string;
Description

see tTable.IndexFieldNames

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.IndexFields Property

TnxCachedDataSet.IndexFields Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property IndexFields [aIndex: Integer]: TField;
Description

see tTable.IndexFields

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.IndexName Property

TnxCachedDataSet.IndexName Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property IndexName: string;
Description

see tTable.IndexName

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.KeyExclusive Property

TnxCachedDataSet.KeyExclusive Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property KeyExclusive: Boolean;
Description

see tTable.KeyExclusive

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.KeyFieldCount Property

TnxCachedDataSet.KeyFieldCount Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property KeyFieldCount: Integer;
Description

see tTable.KeyFieldCount

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.KeyPartialLen Property

TnxCachedDataSet.KeyPartialLen Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property KeyPartialLen: Integer;
Description

see tTable.KeyPartialLen

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.MasterFields Property

TnxCachedDataSet.MasterFields Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property MasterFields: string;
Description

see tTable.MasterFields

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.MasterSource Property

TnxCachedDataSet.MasterSource Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property MasterSource: TDataSource;
Description

see tTable.MasterSource

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.Options Property

TnxCachedDataSet.Options Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property Options: TnxCachedDataSetOptions;
Description

Options for the cached dataset.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.ReadOnly Property

TnxCachedDataSet.ReadOnly Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property ReadOnly: Boolean;
Description

see tTable.ReadOnly

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.SourceDataSet Property

TnxCachedDataSet.SourceDataSet Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property SourceDataSet: TnxDataSet;
Description

The dataset the data is fetched from.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.TableName Property

TnxCachedDataSet.TableName Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property TableName: string;
Description

Original Tablename. ???

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.UpdateObject Property

TnxCachedDataSet.UpdateObject Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property UpdateObject: TnxBaseUpdateObject;
Description

The object responsible for updating the underlying datasets.

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet.UsedTableName Property

TnxCachedDataSet.UsedTableName Property
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Properties Send Feedback
Syntax
Delphi
property UsedTableName: string;
Description

???

Group

TnxCachedDataSet Properties

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Properties


TnxCachedDataSet Events

TnxCachedDataSet Events
TnxCachedDataSet Class Legend Published Events Send Feedback

The events of the TnxCachedDataSet class are listed here.

Class

TnxCachedDataSet Class

Published Events
Name | Description
OnCreateTable | This event is fired before the local table is create by the server.
Links
TnxCachedDataSet Class, Legend, Published Events


TnxCachedDataSet.OnCreateTable Event

TnxCachedDataSet.OnCreateTable Event
TnxCachedDataSet Class TnxCachedDataSet Members nxdb Namespace TnxCachedDataSet Events Send Feedback
Syntax
Delphi
property OnCreateTable: TnxCreateTableEvent;
Description

This event is fired before the local table is create by the server.

Group

TnxCachedDataSet Events

Links
TnxCachedDataSet Class, TnxCachedDataSet Members, nxdb Namespace, TnxCachedDataSet Events


TnxCachedDataSetCursor Class

TnxCachedDataSetCursor Class
TnxCachedDataSetCursor Fields TnxCachedDataSetCursor Methods TnxCachedDataSetCursor Properties TnxCachedDataSetCursor Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursornxdb_TnxCachedDataSetCursor
Syntax
Delphi
TnxCachedDataSetCursor = class(TnxCursor);
File

nxdb

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
TnxCachedDataSetCursor Fields, TnxCachedDataSetCursor Methods, TnxCachedDataSetCursor Properties, TnxCachedDataSetCursor Members, nxdb, Classes


TnxCachedDataSetCursor Members

TnxCachedDataSetCursor Members
TnxCachedDataSetCursor Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxCachedDataSetCursor.

Class

TnxCachedDataSetCursor Class

Protected Fields
Name | Description
crDatabase | This is crDatabase, a member of class TnxCursor.
crDataSet | private
crUpdateHandler | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
crCheckDatabase | TnxCursor
crRefreshTimeout |
crSetDatabase |
crSetUpdateHandler | TnxCachedDataSetCursor
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Create | constructor
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Database | The database the cursor belongs to.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
UpdateHandler | The UpdateHandler the cursor belongs to.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxCachedDataSetCursor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxCachedDataSetCursor Fields

TnxCachedDataSetCursor Fields
TnxCachedDataSetCursor Class Legend Protected Fields Send Feedback

The fields of the TnxCachedDataSetCursor class are listed here.

Class

TnxCachedDataSetCursor Class

Protected Fields
Name | Description
crUpdateHandler | private
Links
TnxCachedDataSetCursor Class, Legend, Protected Fields


TnxCachedDataSetCursor.crUpdateHandler Field

TnxCachedDataSetCursor.crUpdateHandler Field
TnxCachedDataSetCursor Class TnxCachedDataSetCursor Members nxdb Namespace TnxCachedDataSetCursor Fields Send Feedback
Syntax
Delphi
crUpdateHandler: TnxBaseUpdateHandler;
Description

private

Group

TnxCachedDataSetCursor Fields

Links
TnxCachedDataSetCursor Class, TnxCachedDataSetCursor Members, nxdb Namespace, TnxCachedDataSetCursor Fields


TnxCachedDataSetCursor Methods

TnxCachedDataSetCursor Methods
TnxCachedDataSetCursor Class Legend Protected Methods Send Feedback

The methods of the TnxCachedDataSetCursor class are listed here.

Class

TnxCachedDataSetCursor Class

Protected Methods
Name | Description
crSetUpdateHandler | TnxCachedDataSetCursor
nxcNotification |
scIsStateParent |
Links
TnxCachedDataSetCursor Class, Legend, Protected Methods


TnxCachedDataSetCursor.crSetUpdateHandler Method

TnxCachedDataSetCursor.crSetUpdateHandler Method
TnxCachedDataSetCursor Class TnxCachedDataSetCursor Members nxdb Namespace TnxCachedDataSetCursor Methods Send Feedback
Syntax
Delphi
procedure crSetUpdateHandler(const Value: TnxBaseUpdateHandler);
Description

TnxCachedDataSetCursor

Group

TnxCachedDataSetCursor Methods

Links
TnxCachedDataSetCursor Class, TnxCachedDataSetCursor Members, nxdb Namespace, TnxCachedDataSetCursor Methods


TnxCachedDataSetCursor.nxcNotification Method

TnxCachedDataSetCursor.nxcNotification Method
TnxCachedDataSetCursor Class TnxCachedDataSetCursor Members nxdb Namespace TnxCachedDataSetCursor Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxCachedDataSetCursor Methods

Links
TnxCachedDataSetCursor Class, TnxCachedDataSetCursor Members, nxdb Namespace, TnxCachedDataSetCursor Methods


TnxCachedDataSetCursor.scIsStateParent Method

TnxCachedDataSetCursor.scIsStateParent Method
TnxCachedDataSetCursor Class TnxCachedDataSetCursor Members nxdb Namespace TnxCachedDataSetCursor Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxCachedDataSetCursor Methods

Links
TnxCachedDataSetCursor Class, TnxCachedDataSetCursor Members, nxdb Namespace, TnxCachedDataSetCursor Methods


TnxCachedDataSetCursor Properties

TnxCachedDataSetCursor Properties
TnxCachedDataSetCursor Class Legend Public Properties Send Feedback

The properties of the TnxCachedDataSetCursor class are listed here.

Class

TnxCachedDataSetCursor Class

Public Properties
Name | Description
UpdateHandler | The UpdateHandler the cursor belongs to.
Links
TnxCachedDataSetCursor Class, Legend, Public Properties


TnxCachedDataSetCursor.UpdateHandler Property

TnxCachedDataSetCursor.UpdateHandler Property
TnxCachedDataSetCursor Class TnxCachedDataSetCursor Members nxdb Namespace TnxCachedDataSetCursor Properties Send Feedback
Syntax
Delphi
property UpdateHandler: TnxBaseUpdateHandler;
Description

The UpdateHandler the cursor belongs to.

Group

TnxCachedDataSetCursor Properties

Links
TnxCachedDataSetCursor Class, TnxCachedDataSetCursor Members, nxdb Namespace, TnxCachedDataSetCursor Properties


TnxCachedDataSetCursorExtender Class

TnxCachedDataSetCursorExtender Class
TnxCachedDataSetCursorExtender Fields TnxCachedDataSetCursorExtender Methods TnxCachedDataSetCursorExtender Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxCachedDataSetCursorExtendernxdb_TnxCachedDataSetCursorExtendernxdb_TnxCachedDataSetCursorExtendernxdb_TnxCachedDataSetCursorExtendernxdb_TnxCachedDataSetCursorExtender
Syntax
Delphi
TnxCachedDataSetCursorExtender = class(TnxBaseEngineExtender);
File

nxdb

Description

This is class nxdb.TnxCachedDataSetCursorExtender.

Group

Classes

Links
TnxCachedDataSetCursorExtender Fields, TnxCachedDataSetCursorExtender Methods, TnxCachedDataSetCursorExtender Members, nxdb, Classes


TnxCachedDataSetCursorExtender Members

TnxCachedDataSetCursorExtender Members
TnxCachedDataSetCursorExtender Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCachedDataSetCursorExtender.

Class

TnxCachedDataSetCursorExtender Class

Protected Fields
Name | Description
beeActions | This is beeActions, a member of class TnxBaseEngineExtender.
beeExtendableObject | This is beeExtendableObject, a member of class TnxBaseEngineExtender.
beeExtendableObjectNext | This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.
beeExtendableObjectPrev | This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.
beeMonitor | private
beeMonitorNext | This is beeMonitorNext, a member of class TnxBaseEngineExtender.
beeMonitorPrev | This is beeMonitorPrev, a member of class TnxBaseEngineExtender.
cdsceUpdateHandler | This is cdsceUpdateHandler, a member of class TnxCachedDataSetCursorExtender.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
beeAddToExtendableObject |
beeAddToMonitor |
beeCreateInstance |
beeRemoveFromExtendableObject |
beeRemoveFromMonitor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxCachedDataSetCursorExtender
Destroy | destructor.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Notify |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Public Properties
Name | Description
ExtendableObject | This property returns the server object the extender extends.
Monitor | This property returns the Monitor the extender was created from.
Links
TnxCachedDataSetCursorExtender Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCachedDataSetCursorExtender.Create Constructor

TnxCachedDataSetCursorExtender.Create Constructor
TnxCachedDataSetCursorExtender Class TnxCachedDataSetCursorExtender Members nxdb Namespace TnxCachedDataSetCursorExtender Class Send Feedback
Syntax
Delphi
constructor Create(aCursor: TnxAbstractCursor; aUpdateHandler: TnxBaseUpdateHandler);
Description

TnxCachedDataSetCursorExtender

Class

TnxCachedDataSetCursorExtender Class

Links
TnxCachedDataSetCursorExtender Class, TnxCachedDataSetCursorExtender Members, nxdb Namespace, TnxCachedDataSetCursorExtender Class


TnxCachedDataSetCursorExtender Fields

TnxCachedDataSetCursorExtender Fields
TnxCachedDataSetCursorExtender Class Legend Protected Fields Send Feedback

The fields of the TnxCachedDataSetCursorExtender class are listed here.

Class

TnxCachedDataSetCursorExtender Class

Protected Fields
Name | Description
cdsceUpdateHandler | This is cdsceUpdateHandler, a member of class TnxCachedDataSetCursorExtender.
Links
TnxCachedDataSetCursorExtender Class, Legend, Protected Fields


TnxCachedDataSetCursorExtender.cdsceUpdateHandler Field

TnxCachedDataSetCursorExtender.cdsceUpdateHandler Field
TnxCachedDataSetCursorExtender Class TnxCachedDataSetCursorExtender Members nxdb Namespace TnxCachedDataSetCursorExtender Fields Send Feedback
Syntax
Delphi
cdsceUpdateHandler: TnxBaseUpdateHandler;
Description

This is cdsceUpdateHandler, a member of class TnxCachedDataSetCursorExtender.

Group

TnxCachedDataSetCursorExtender Fields

Links
TnxCachedDataSetCursorExtender Class, TnxCachedDataSetCursorExtender Members, nxdb Namespace, TnxCachedDataSetCursorExtender Fields


TnxCachedDataSetCursorExtender Methods

TnxCachedDataSetCursorExtender Methods
TnxCachedDataSetCursorExtender Class Legend Public Methods Send Feedback

The methods of the TnxCachedDataSetCursorExtender class are listed here.

Class

TnxCachedDataSetCursorExtender Class

Public Methods
Name | Description
Notify |
Links
TnxCachedDataSetCursorExtender Class, Legend, Public Methods


TnxCachedDataSetCursorExtender.Notify Method

TnxCachedDataSetCursorExtender.Notify Method
TnxCachedDataSetCursorExtender Class TnxCachedDataSetCursorExtender Members nxdb Namespace TnxCachedDataSetCursorExtender Methods Send Feedback
Syntax
Delphi
function Notify(aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult; override;
Group

TnxCachedDataSetCursorExtender Methods

Links
TnxCachedDataSetCursorExtender Class, TnxCachedDataSetCursorExtender Members, nxdb Namespace, TnxCachedDataSetCursorExtender Methods


TnxCachedDataSetDatabaseExtender Class

TnxCachedDataSetDatabaseExtender Class
TnxCachedDataSetDatabaseExtender Fields TnxCachedDataSetDatabaseExtender Methods TnxCachedDataSetDatabaseExtender Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxCachedDataSetDatabaseExtendernxdb_TnxCachedDataSetDatabaseExtendernxdb_TnxCachedDataSetDatabaseExtendernxdb_TnxCachedDataSetDatabaseExtendernxdb_TnxCachedDataSetDatabaseExtender
Syntax
Delphi
TnxCachedDataSetDatabaseExtender = class(TnxBaseEngineExtender);
File

nxdb

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
TnxCachedDataSetDatabaseExtender Fields, TnxCachedDataSetDatabaseExtender Methods, TnxCachedDataSetDatabaseExtender Members, nxdb, Classes


TnxCachedDataSetDatabaseExtender Members

TnxCachedDataSetDatabaseExtender Members
TnxCachedDataSetDatabaseExtender Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCachedDataSetDatabaseExtender.

Class

TnxCachedDataSetDatabaseExtender Class

Protected Fields
Name | Description
beeActions | This is beeActions, a member of class TnxBaseEngineExtender.
beeExtendableObject | This is beeExtendableObject, a member of class TnxBaseEngineExtender.
beeExtendableObjectNext | This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.
beeExtendableObjectPrev | This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.
beeMonitor | private
beeMonitorNext | This is beeMonitorNext, a member of class TnxBaseEngineExtender.
beeMonitorPrev | This is beeMonitorPrev, a member of class TnxBaseEngineExtender.
cdsdeDataSets | This is cdsdeDataSets, a member of class TnxCachedDataSetDatabaseExtender.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
beeAddToExtendableObject |
beeAddToMonitor |
beeCreateInstance |
beeRemoveFromExtendableObject |
beeRemoveFromMonitor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AddDataSet | TnxCachedDataSetDatabaseExtender
BeforeDestruction | TnxLifetimeTrackedPersistent
Create |
Destroy |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Notify |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
RemoveDataSet |
Public Properties
Name | Description
ExtendableObject | This property returns the server object the extender extends.
Monitor | This property returns the Monitor the extender was created from.
Links
TnxCachedDataSetDatabaseExtender Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCachedDataSetDatabaseExtender.Create Constructor

TnxCachedDataSetDatabaseExtender.Create Constructor
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Class Send Feedback
Syntax
Delphi
constructor Create(aDatabase: TnxAbstractDatabase);
Class

TnxCachedDataSetDatabaseExtender Class

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Class


TnxCachedDataSetDatabaseExtender.Destroy Destructor

TnxCachedDataSetDatabaseExtender.Destroy Destructor
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxCachedDataSetDatabaseExtender Class

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Class


TnxCachedDataSetDatabaseExtender Fields

TnxCachedDataSetDatabaseExtender Fields
TnxCachedDataSetDatabaseExtender Class Legend Protected Fields Send Feedback

The fields of the TnxCachedDataSetDatabaseExtender class are listed here.

Class

TnxCachedDataSetDatabaseExtender Class

Protected Fields
Name | Description
cdsdeDataSets | This is cdsdeDataSets, a member of class TnxCachedDataSetDatabaseExtender.
Links
TnxCachedDataSetDatabaseExtender Class, Legend, Protected Fields


TnxCachedDataSetDatabaseExtender.cdsdeDataSets Field

TnxCachedDataSetDatabaseExtender.cdsdeDataSets Field
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Fields Send Feedback
Syntax
Delphi
cdsdeDataSets: TStringList;
Description

This is cdsdeDataSets, a member of class TnxCachedDataSetDatabaseExtender.

Group

TnxCachedDataSetDatabaseExtender Fields

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Fields


TnxCachedDataSetDatabaseExtender Methods

TnxCachedDataSetDatabaseExtender Methods
TnxCachedDataSetDatabaseExtender Class Legend Public Methods Send Feedback

The methods of the TnxCachedDataSetDatabaseExtender class are listed here.

Class

TnxCachedDataSetDatabaseExtender Class

Public Methods
Name | Description
AddDataSet | TnxCachedDataSetDatabaseExtender
Notify |
RemoveDataSet |
Links
TnxCachedDataSetDatabaseExtender Class, Legend, Public Methods


TnxCachedDataSetDatabaseExtender.AddDataSet Method

TnxCachedDataSetDatabaseExtender.AddDataSet Method
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Methods Send Feedback
Syntax
Delphi
procedure AddDataSet(aDataSet: TnxCachedDataSet);
Description

TnxCachedDataSetDatabaseExtender

Group

TnxCachedDataSetDatabaseExtender Methods

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Methods


TnxCachedDataSetDatabaseExtender.Notify Method

TnxCachedDataSetDatabaseExtender.Notify Method
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Methods Send Feedback
Syntax
Delphi
function Notify(aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult; override;
Group

TnxCachedDataSetDatabaseExtender Methods

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Methods


TnxCachedDataSetDatabaseExtender.RemoveDataSet Method

TnxCachedDataSetDatabaseExtender.RemoveDataSet Method
TnxCachedDataSetDatabaseExtender Class TnxCachedDataSetDatabaseExtender Members nxdb Namespace TnxCachedDataSetDatabaseExtender Methods Send Feedback
Syntax
Delphi
procedure RemoveDataSet(aDataSet: TnxCachedDataSet);
Group

TnxCachedDataSetDatabaseExtender Methods

Links
TnxCachedDataSetDatabaseExtender Class, TnxCachedDataSetDatabaseExtender Members, nxdb Namespace, TnxCachedDataSetDatabaseExtender Methods


TnxCursor Class

TnxCursor Class
TnxCursor Fields TnxCursor Methods TnxCursor Properties TnxCursor Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxCursornxdb_TnxCursornxdb_TnxCursornxdb_TnxCursornxdb_TnxCursornxdb_TnxCursornxdb_TnxCursornxdb_TnxCursor
Syntax
Delphi
TnxCursor = class(TnxDataAccessStateComponent);
File

nxdb

Description

Client side base dataset cursor class.

Group

Classes

Links
TnxCursor Fields, TnxCursor Methods, TnxCursor Properties, TnxCursor Members, nxdb, Classes


TnxCursor Members

TnxCursor Members
TnxCursor Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxCursor.

Class

TnxCursor Class

Protected Fields
Name | Description
crDatabase | This is crDatabase, a member of class TnxCursor.
crDataSet | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
crCheckDatabase | TnxCursor
crRefreshTimeout |
crSetDatabase |
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Database | The database the cursor belongs to.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxCursor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxCursor.Create Constructor

TnxCursor.Create Constructor
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Class Send Feedback
Syntax
Delphi
constructor Create(aDataSet: TnxDataset); reintroduce;
Description

constructor.

Class

TnxCursor Class

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Class


TnxCursor Fields

TnxCursor Fields
TnxCursor Class Legend Protected Fields Send Feedback

The fields of the TnxCursor class are listed here.

Class

TnxCursor Class

Protected Fields
Name | Description
crDatabase | This is crDatabase, a member of class TnxCursor.
crDataSet | private
Links
TnxCursor Class, Legend, Protected Fields


TnxCursor.crDatabase Field

TnxCursor.crDatabase Field
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Fields Send Feedback
Syntax
Delphi
crDatabase: TnxDatabase;
Description

This is crDatabase, a member of class TnxCursor.

Group

TnxCursor Fields

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Fields


TnxCursor.crDataSet Field

TnxCursor.crDataSet Field
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Fields Send Feedback
Syntax
Delphi
crDataSet: TnxDataset;
Description

private

Group

TnxCursor Fields

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Fields


TnxCursor Methods

TnxCursor Methods
TnxCursor Class Legend Protected Methods Send Feedback

The methods of the TnxCursor class are listed here.

Class

TnxCursor Class

Protected Methods
Name | Description
crCheckDatabase | TnxCursor
crRefreshTimeout |
crSetDatabase |
nxcNotification |
scCheckInactive |
scInitializing |
scIsStateParent |
scStopping |
Links
TnxCursor Class, Legend, Protected Methods


TnxCursor.crCheckDatabase Method

TnxCursor.crCheckDatabase Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure crCheckDatabase;
Description

TnxCursor

Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.crRefreshTimeout Method

TnxCursor.crRefreshTimeout Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure crRefreshTimeout;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.crSetDatabase Method

TnxCursor.crSetDatabase Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure crSetDatabase(const Value: TnxDatabase);
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.nxcNotification Method

TnxCursor.nxcNotification Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.scCheckInactive Method

TnxCursor.scCheckInactive Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure scCheckInactive; override;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.scInitializing Method

TnxCursor.scInitializing Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.scIsStateParent Method

TnxCursor.scIsStateParent Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor.scStopping Method

TnxCursor.scStopping Method
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxCursor Methods

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Methods


TnxCursor Properties

TnxCursor Properties
TnxCursor Class Legend Public Properties Send Feedback

The properties of the TnxCursor class are listed here.

Class

TnxCursor Class

Public Properties
Name | Description
Database | The database the cursor belongs to.
Links
TnxCursor Class, Legend, Public Properties


TnxCursor.Database Property

TnxCursor.Database Property
TnxCursor Class TnxCursor Members nxdb Namespace TnxCursor Properties Send Feedback
Syntax
Delphi
property Database: TnxDatabase;
Description

The database the cursor belongs to.

Group

TnxCursor Properties

Links
TnxCursor Class, TnxCursor Members, nxdb Namespace, TnxCursor Properties


TnxDataAccessStateComponent Class

TnxDataAccessStateComponent Class
TnxDataAccessStateComponent Methods TnxDataAccessStateComponent Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponentnxdb_TnxDataAccessStateComponent
Syntax
Delphi
TnxDataAccessStateComponent = class(TnxStateComponent);
File

nxdb

Description

The base class for all client side data components

Group

Classes

Links
TnxDataAccessStateComponent Methods, TnxDataAccessStateComponent Members, nxdb, Classes


TnxDataAccessStateComponent Members

TnxDataAccessStateComponent Members
TnxDataAccessStateComponent Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxDataAccessStateComponent.

Class

TnxDataAccessStateComponent Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxDataAccessStateComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxDataAccessStateComponent Methods

TnxDataAccessStateComponent Methods
TnxDataAccessStateComponent Class Legend Protected Methods Send Feedback

The methods of the TnxDataAccessStateComponent class are listed here.

Class

TnxDataAccessStateComponent Class

Protected Methods
Name | Description
dascExceptionClass |
nxcCheck |
nxcError | This is the overview for the nxcError method overload.
Links
TnxDataAccessStateComponent Class, Legend, Protected Methods


TnxDataAccessStateComponent.dascExceptionClass Method

TnxDataAccessStateComponent.dascExceptionClass Method
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace TnxDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
class function dascExceptionClass: EnxDatabaseErrorClass; virtual;
Group

TnxDataAccessStateComponent Methods

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, TnxDataAccessStateComponent Methods


TnxDataAccessStateComponent.nxcCheck Method

TnxDataAccessStateComponent.nxcCheck Method
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace TnxDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure nxcCheck(const aErrorCode: TnxResult); override;
Group

TnxDataAccessStateComponent Methods

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, TnxDataAccessStateComponent Methods


nxcError Method

nxcError Method
TnxDataAccessStateComponent Methods Send Feedback

This is the overview for the nxcError method overload.

Overload List
Name | Description
TnxDataAccessStateComponent.nxcError (PResStringRec) |
TnxDataAccessStateComponent.nxcError (PResStringRec, array of const) |
TnxDataAccessStateComponent.nxcError (string) |
TnxDataAccessStateComponent.nxcError (string, array of const) |
TnxDataAccessStateComponent.nxcError (TnxResult) |
TnxDataAccessStateComponent.nxcError (TnxResult, PResStringRec) |
TnxDataAccessStateComponent.nxcError (TnxResult, PResStringRec, array of const) |
TnxDataAccessStateComponent.nxcError (TnxResult, string) |
TnxDataAccessStateComponent.nxcError (TnxResult, string, array of const) |
Group

TnxDataAccessStateComponent Methods

Links
TnxDataAccessStateComponent Methods


TnxDataAccessStateComponent.nxcError Method (PResStringRec)

TnxDataAccessStateComponent.nxcError Method (PResStringRec)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(aMsgRes: PResStringRec); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (PResStringRec, array of const)

TnxDataAccessStateComponent.nxcError Method (PResStringRec, array of const)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(aMsgRes: PResStringRec; const aArgs: array of const); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (TnxResult)

TnxDataAccessStateComponent.nxcError Method (TnxResult)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (TnxResult, PResStringRec)

TnxDataAccessStateComponent.nxcError Method (TnxResult, PResStringRec)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; aAltMsgRes: PResStringRec); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (TnxResult, PResStringRec, array of const)

TnxDataAccessStateComponent.nxcError Method (TnxResult, PResStringRec, array of const)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; aAltMsgRes: PResStringRec; const aArgs: array of const); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (TnxResult, string)

TnxDataAccessStateComponent.nxcError Method (TnxResult, string)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; const aAltMsg: string); overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (TnxResult, string, array of const)

TnxDataAccessStateComponent.nxcError Method (TnxResult, string, array of const)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const); overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (string)

TnxDataAccessStateComponent.nxcError Method (string)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aMsg: string); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDataAccessStateComponent.nxcError Method (string, array of const)

TnxDataAccessStateComponent.nxcError Method (string, array of const)
TnxDataAccessStateComponent Class TnxDataAccessStateComponent Members nxdb Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aMsg: string; const aArgs: array of const); override; overload;
Group

nxcError Method

Links
TnxDataAccessStateComponent Class, TnxDataAccessStateComponent Members, nxdb Namespace, nxcError Method


TnxDatabase Class

TnxDatabase Class
TnxDatabase Fields TnxDatabase Methods TnxDatabase Properties TnxDatabase Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabasenxdb_TnxDatabase
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxDatabase = class(TnxSessionOwnedDataAccessStateComponent);
File

nxdb

Description

Implementation of a TDatabase similar component.

Group

Classes

Links
TnxDatabase Fields, TnxDatabase Methods, TnxDatabase Properties, TnxDatabase Members, nxdb, Classes


TnxDatabase Members

TnxDatabase Members
TnxDatabase Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxDatabase.

Class

TnxDatabase Class

Protected Fields
Name | Description
dbAbstractDatabase | This is dbAbstractDatabase, a member of class TnxDatabase.
dbAbstractDatabase31000 | This is dbAbstractDatabase31000, a member of class TnxDatabase.
dbAliasName | This is dbAliasName, a member of class TnxDatabase.
dbAliasPath | This is dbAliasPath, a member of class TnxDatabase.
dbDataSets | This is dbDataSets, a member of class TnxDatabase.
dbExclusive | This is dbExclusive, a member of class TnxDatabase.
dbFailSafe | This is dbFailSafe, a member of class TnxDatabase.
dbImplicit | This is dbImplicit, a member of class TnxDatabase.
dbLoadedDefault | This is dbLoadedDefault, a member of class TnxDatabase.
dbNotifyList | >>> te 18.01.05
dbQueries | This is dbQueries, a member of class TnxDatabase.
dbReadOnly | This is dbReadOnly, a member of class TnxDatabase.
dbTables | This is dbTables, a member of class TnxDatabase.
dbTransContext | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
soSession | private
soTimeout | This is soTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
Protected Methods
Name | Description
dascExceptionClass |
dbAcquireInterfaces |
dbCheckAlias |
dbGetCursor |
dbGetCursorCount |
dbGetDataSet |
dbGetDataSetCount |
dbGetDefault |
dbGetInTransaction |
dbGetPath |
dbGetQuery |
dbGetQueryCount |
dbGetTable |
dbGetTableCount |
dbIsAliasNameStored |
dbIsAliasPathStored |
dbSetAliasName |
dbSetAliasPath |
dbSetDefault |
dbSetExclusive |
dbSetFailSafe |
dbSetReadOnly |
dbSetTransContext |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
soCheckDefaults |
soCheckSession |
soGetTimeout |
soRefreshTimeout |
soSetSession | <<<
soSetTimeout |
Protected Properties
Name | Description
CursorCount | This is CursorCount, a member of class TnxDatabase.
Cursors | This is Cursors, a member of class TnxDatabase.
Public Methods
Name | Description
AddFieldToTable | TnxDatabase
AfterConstruction | see TDataset.AfterConstruction TnxSessionOwnedDataAccessStateComponent
BackupTable | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Raises an exception on failure.
BackupTableEx | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Returns an error code on failure.
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ChangePassword | Changes the password of a table and triggers an exception if it failed.
ChangePasswordEx | Changes the password of a table and returns an error if failed.
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Commit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case. For more info see the nexus manual.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
CreateTable | Use CreateTable to create a new table with the structure defined by the given dictionary. Raises an exception on failure.
CreateTableEx | Use CreateTable to create a new table with the structure defined by the given dictionary. Returns an error code on failure.
DeleteTable | This method deletes the table with the given name.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
EmptyTable | EmptyTable deletes all records of the given table.
ExecQuery |
ExecQueryFromFile | Executes a SQL query and returns it's result.
ExecQueryFromStream | Executes a SQL query and returns it's result.
ExecStoredProc | Executes a SQL Stored Procedure and returns it's result.
Exists | Returns true if the database exists.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetAutoIncValue | Returns the next AutoInc value for the given table.
GetChangedTables | GetChangedTables returns a list of all open tables in this database that have changed since the function was last called.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDataDictionary | The method returns the data dictionary of a given table. Raises an exception on failure.
GetDataDictionaryEx | The method returns the data dictionary of a given table. Returns an error code on failure.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFreeDiskSpace | This method returns the remaining disk space for the disk this database/alias is stored on.
GetFreeDiskSpaceEx | This method returns the remaining disk space for the disk this database/alias is stored on.
GetLifetimeMontior |
GetPath | Returns the full (server based!) system path of the database.
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored function of the database.
GetStoredFuncParams | Returns the parameter defintions for a named stored function.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of the database.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure.
GetTableNames | GetTableNames returns a list of all tables of the database.
GetTablesNeedingPack | GetTablesNeedingPack returns a list of all tables that need to be packed.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
OpenQuery | Executes a SQL query and returns a cursor (if applicaple)
OpenStoredProc | Opens SQL Stored Procedure and returns it's local instance
OpenTable | Opens a Table.
PackTable | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Raises an exception on failure.
PackTableEx | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Returns an error code on failure.
RecoverTable | The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Triggers and exception on failure. Unrecoverable records are placed in a new table named TableName_Failed.
RecoverTableEx | The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Returns an error value on failure. Unrecoverable records are placed in a new table named TableName_Failed.
ReIndexTable | This is the overview for the ReIndexTable method overload.
ReIndexTableEx | This is the overview for the ReIndexTableEx method overload.
RenameTable | RenameTable changes the name of a table.
RestructureTable | With this method you can start an asynchronous restructure of a given table. Raises an exception on failure.
RestructureTableEx | With this method you can start an asynchronous restructure of a given table. Returns an error code on failure.
Rollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
StartTransaction | StartTransaction tries to start a transaction. If it fails an exception is triggered.
StartTransactionWith | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.
StartTransactionWithEx | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TableExists | This function returns true if a table with the given name exists otherwise false.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.
TryStartTransaction | Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by this database instance or triggers an exception if an error occurs.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
VerifyChecksumTable | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
VerifyChecksumTableEx | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
Public Properties
Name | Description
AbstractDatabase | This is AbstractDatabase, a member of class TnxDatabase.
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DataSetCount | Returns the number of dataset instances attached to this database.
DataSets | Returns the dataset with index aInx out of the list of attached dataset instances.
Implicit | Implicit is true if the database instance was create implicitly, e.g by using tnxTable directly without assigning it to a database.
InTransaction | Returns true if a transaction for the current database is active otherwise false.
Path | Returns the file system path of this database.
Queries | Returns the query with index aInx out of the list of attached query instances.
QueryCount | Returns the number of (client-side) query instances attached to the database component.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TableCount | Returns the number of (client-side) table instances attached to the database component.
Tables | Returns the table with index aInx out of the list of attached table instances.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
AliasName | The alias name the database is connected to. Either AliasName or AliasPath must be set.
AliasPath | The (local server) path the database is connected to. Either AliasName or AliasPath must be set.
Default | If true this Database is the default database for it's session.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
Exclusive | If a database is exclusively opened, only ONE client has access at a time.
FailSafe | Sets failsafe mode on or off. For more info see NexusDB manual.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ReadOnly | With this property a database can be set to read only.
Session | The session the database is attached to. This property must be set for the component to work properly.
Timeout | Set the timeout for the component in ms. If -1 is specified the component inherits the value of the session it is connected to.
TransContext | The transaction context the database is attached to. This property can be nil.
Version | Version of the component.
Links
TnxDatabase Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxDatabase.Create Constructor

TnxDatabase.Create Constructor
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxDatabase Class

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Class


TnxDatabase.Destroy Destructor

TnxDatabase.Destroy Destructor
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxDatabase Class

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Class


TnxDatabase Fields

TnxDatabase Fields
TnxDatabase Class Legend Protected Fields Send Feedback

The fields of the TnxDatabase class are listed here.

Class

TnxDatabase Class

Protected Fields
Name | Description
dbAbstractDatabase | This is dbAbstractDatabase, a member of class TnxDatabase.
dbAbstractDatabase31000 | This is dbAbstractDatabase31000, a member of class TnxDatabase.
dbAliasName | This is dbAliasName, a member of class TnxDatabase.
dbAliasPath | This is dbAliasPath, a member of class TnxDatabase.
dbDataSets | This is dbDataSets, a member of class TnxDatabase.
dbExclusive | This is dbExclusive, a member of class TnxDatabase.
dbFailSafe | This is dbFailSafe, a member of class TnxDatabase.
dbImplicit | This is dbImplicit, a member of class TnxDatabase.
dbLoadedDefault | This is dbLoadedDefault, a member of class TnxDatabase.
dbNotifyList | >>> te 18.01.05
dbQueries | This is dbQueries, a member of class TnxDatabase.
dbReadOnly | This is dbReadOnly, a member of class TnxDatabase.
dbTables | This is dbTables, a member of class TnxDatabase.
dbTransContext | private
Links
TnxDatabase Class, Legend, Protected Fields


TnxDatabase.dbAbstractDatabase Field

TnxDatabase.dbAbstractDatabase Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbAbstractDatabase: TnxAbstractDatabase;
Description

This is dbAbstractDatabase, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbAbstractDatabase31000 Field

TnxDatabase.dbAbstractDatabase31000 Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbAbstractDatabase31000: InxAbstractDatabase31000;
Description

This is dbAbstractDatabase31000, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbAliasName Field

TnxDatabase.dbAliasName Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbAliasName: string;
Description

This is dbAliasName, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbAliasPath Field

TnxDatabase.dbAliasPath Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbAliasPath: string;
Description

This is dbAliasPath, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbDataSets Field

TnxDatabase.dbDataSets Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbDataSets: TnxSortedList;
Description

This is dbDataSets, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbExclusive Field

TnxDatabase.dbExclusive Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbExclusive: Boolean;
Description

This is dbExclusive, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbFailSafe Field

TnxDatabase.dbFailSafe Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbFailSafe: Boolean;
Description

This is dbFailSafe, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbImplicit Field

TnxDatabase.dbImplicit Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbImplicit: Boolean;
Description

This is dbImplicit, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbLoadedDefault Field

TnxDatabase.dbLoadedDefault Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbLoadedDefault: Boolean;
Description

This is dbLoadedDefault, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbNotifyList Field

TnxDatabase.dbNotifyList Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbNotifyList: TStringList;
Description

>>> te 18.01.05

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbQueries Field

TnxDatabase.dbQueries Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbQueries: TnxSortedList;
Description

This is dbQueries, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbReadOnly Field

TnxDatabase.dbReadOnly Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbReadOnly: Boolean;
Description

This is dbReadOnly, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbTables Field

TnxDatabase.dbTables Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbTables: TnxSortedList;
Description

This is dbTables, a member of class TnxDatabase.

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase.dbTransContext Field

TnxDatabase.dbTransContext Field
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Fields Send Feedback
Syntax
Delphi
dbTransContext: TnxTransContext;
Description

private

Group

TnxDatabase Fields

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Fields


TnxDatabase Methods

TnxDatabase Methods
TnxDatabase Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDatabase class are listed here.

Class

TnxDatabase Class

Protected Methods
Name | Description
dbAcquireInterfaces |
dbCheckAlias |
dbGetCursor |
dbGetCursorCount |
dbGetDataSet |
dbGetDataSetCount |
dbGetDefault |
dbGetInTransaction |
dbGetPath |
dbGetQuery |
dbGetQueryCount |
dbGetTable |
dbGetTableCount |
dbIsAliasNameStored |
dbIsAliasPathStored |
dbSetAliasName |
dbSetAliasPath |
dbSetDefault |
dbSetExclusive |
dbSetFailSafe |
dbSetReadOnly |
dbSetTransContext |
Loaded |
nxcAddDependent |
nxcNotification |
nxcRemoveDependent |
scInitializing |
scIsStateParent |
scStarting |
scStopping |
soCheckDefaults |
soRefreshTimeout |
soSetSession | <<<
Public Methods
Name | Description
AddFieldToTable | TnxDatabase
BackupTable | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Raises an exception on failure.
BackupTableEx | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Returns an error code on failure.
ChangePassword | Changes the password of a table and triggers an exception if it failed.
ChangePasswordEx | Changes the password of a table and returns an error if failed.
Commit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case. For more info see the nexus manual.
CreateTable | Use CreateTable to create a new table with the structure defined by the given dictionary. Raises an exception on failure.
CreateTableEx | Use CreateTable to create a new table with the structure defined by the given dictionary. Returns an error code on failure.
DeleteTable | This method deletes the table with the given name.
EmptyTable | EmptyTable deletes all records of the given table.
ExecQuery |
ExecQueryFromFile | Executes a SQL query and returns it's result.
ExecQueryFromStream | Executes a SQL query and returns it's result.
ExecStoredProc | Executes a SQL Stored Procedure and returns it's result.
Exists | Returns true if the database exists.
GetAutoIncValue | Returns the next AutoInc value for the given table.
GetChangedTables | GetChangedTables returns a list of all open tables in this database that have changed since the function was last called.
GetDataDictionary | The method returns the data dictionary of a given table. Raises an exception on failure.
GetDataDictionaryEx | The method returns the data dictionary of a given table. Returns an error code on failure.
GetFreeDiskSpace | This method returns the remaining disk space for the disk this database/alias is stored on.
GetFreeDiskSpaceEx | This method returns the remaining disk space for the disk this database/alias is stored on.
GetPath | Returns the full (server based!) system path of the database.
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored function of the database.
GetStoredFuncParams | Returns the parameter defintions for a named stored function.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of the database.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure.
GetTableNames | GetTableNames returns a list of all tables of the database.
GetTablesNeedingPack | GetTablesNeedingPack returns a list of all tables that need to be packed.
OpenQuery | Executes a SQL query and returns a cursor (if applicaple)
OpenStoredProc | Opens SQL Stored Procedure and returns it's local instance
OpenTable | Opens a Table.
PackTable | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Raises an exception on failure.
PackTableEx | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Returns an error code on failure.
RecoverTable | The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Triggers and exception on failure. Unrecoverable records are placed in a new table named TableName_Failed.
RecoverTableEx | The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Returns an error value on failure. Unrecoverable records are placed in a new table named TableName_Failed.
ReIndexTable | This is the overview for the ReIndexTable method overload.
ReIndexTableEx | This is the overview for the ReIndexTableEx method overload.
RenameTable | RenameTable changes the name of a table.
RestructureTable | With this method you can start an asynchronous restructure of a given table. Raises an exception on failure.
RestructureTableEx | With this method you can start an asynchronous restructure of a given table. Returns an error code on failure.
Rollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.
StartTransaction | StartTransaction tries to start a transaction. If it fails an exception is triggered.
StartTransactionWith | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.
StartTransactionWithEx | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.
TableExists | This function returns true if a table with the given name exists otherwise false.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.
TryStartTransaction | Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by this database instance or triggers an exception if an error occurs.
VerifyChecksumTable | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
VerifyChecksumTableEx | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
Links
TnxDatabase Class, Legend, Protected Methods, Public Methods


TnxDatabase.AddFieldToTable Method

TnxDatabase.AddFieldToTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function AddFieldToTable(const aTableName: string; const aPassword: UnicodeString; aFieldDesc: TnxFieldDescriptor): TnxResult;
Description

TnxDatabase

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.BackupTable Method

TnxDatabase.BackupTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function BackupTable(const aTableName: string; const aPassword: UnicodeString; aTarget: TnxDatabase): TnxAbstractTaskInfo;
Parameters
Parameters | Description
aTarget: TnxDatabase | the database where the backup is created
aName | table name
Description

This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Raises an exception on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTableEx, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.BackupTableEx Method

TnxDatabase.BackupTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function BackupTableEx(const aTableName: string; const aPassword: UnicodeString; aTarget: TnxDatabase; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.ChangePassword Method

TnxDatabase.ChangePassword Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure ChangePassword(const aTableName: string; const aOldPassword: UnicodeString; const aNewPassword: UnicodeString);
Description

Changes the password of a table and triggers an exception if it failed.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.ChangePasswordEx Method

TnxDatabase.ChangePasswordEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function ChangePasswordEx(const aTableName: string; const aOldPassword: UnicodeString; const aNewPassword: UnicodeString): TnxResult;
Description

Changes the password of a table and returns an error if failed.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.Commit Method

TnxDatabase.Commit Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure Commit;
Description

This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case.

For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.CreateTable Method

TnxDatabase.CreateTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure CreateTable(aOverWrite: Boolean; const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aTableScope: TnxTableScope = tsPersistent);
Parameters
Parameters | Description
aOverWrite: Boolean | if true, an existing table is overwritten if it is not in use
const aTableName: string | the name of the new table
aDictionary: TnxDataDictionary | the dictionary that defines the table and index structure
Description

Use CreateTable to create a new table with the structure defined by the given dictionary. Raises an exception on failure.

See Also

DeleteTable, CreateTableEx, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.CreateTableEx Method

TnxDatabase.CreateTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function CreateTableEx(aOverWrite: Boolean; const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aTableScope: TnxTableScope = tsPersistent): TnxResult;
Parameters
Parameters | Description
aOverWrite: Boolean | if true, an existing table is overwritten if it is not in use
const aTableName: string | the name of the new table
aDictionary: TnxDataDictionary | the dictionary that defines the table and index structure
Description

Use CreateTable to create a new table with the structure defined by the given dictionary. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.dbAcquireInterfaces Method

TnxDatabase.dbAcquireInterfaces Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbAcquireInterfaces;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbCheckAlias Method

TnxDatabase.dbCheckAlias Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbCheckAlias;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetCursor Method

TnxDatabase.dbGetCursor Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetCursor(aInx: Integer): TnxCursor;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetCursorCount Method

TnxDatabase.dbGetCursorCount Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetCursorCount: Integer;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetDataSet Method

TnxDatabase.dbGetDataSet Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetDataSet(aInx: Integer): TnxDataset;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetDataSetCount Method

TnxDatabase.dbGetDataSetCount Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetDataSetCount: Integer;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetDefault Method

TnxDatabase.dbGetDefault Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetDefault: Boolean;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetInTransaction Method

TnxDatabase.dbGetInTransaction Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetInTransaction: Boolean;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetPath Method

TnxDatabase.dbGetPath Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetPath: string;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetQuery Method

TnxDatabase.dbGetQuery Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetQuery(aInx: Integer): TnxStatementDataSet;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetQueryCount Method

TnxDatabase.dbGetQueryCount Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetQueryCount: Integer;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetTable Method

TnxDatabase.dbGetTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetTable(aInx: Integer): TnxTable;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbGetTableCount Method

TnxDatabase.dbGetTableCount Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbGetTableCount: Integer;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbIsAliasNameStored Method

TnxDatabase.dbIsAliasNameStored Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbIsAliasNameStored: Boolean;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbIsAliasPathStored Method

TnxDatabase.dbIsAliasPathStored Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function dbIsAliasPathStored: Boolean;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetAliasName Method

TnxDatabase.dbSetAliasName Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetAliasName(Value: string);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetAliasPath Method

TnxDatabase.dbSetAliasPath Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetAliasPath(Value: string);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetDefault Method

TnxDatabase.dbSetDefault Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetDefault(const Value: Boolean);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetExclusive Method

TnxDatabase.dbSetExclusive Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetExclusive(Value: Boolean);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetFailSafe Method

TnxDatabase.dbSetFailSafe Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetFailSafe(Value: Boolean);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetReadOnly Method

TnxDatabase.dbSetReadOnly Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetReadOnly(Value: Boolean);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.dbSetTransContext Method

TnxDatabase.dbSetTransContext Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure dbSetTransContext(Value: TnxTransContext);
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.DeleteTable Method

TnxDatabase.DeleteTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure DeleteTable(const aTableName: string; const aPassword: UnicodeString);
Parameters
Parameters | Description
const aTableName: string | table name
Description

This method deletes the table with the given name.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.EmptyTable Method

TnxDatabase.EmptyTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure EmptyTable(const aTableName: string; const aPassword: UnicodeString);
Parameters
Parameters | Description
const aTableName: string | table name
Description

EmptyTable deletes all records of the given table.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.ExecQuery Method

TnxDatabase.ExecQuery Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function ExecQuery(const aQuery: string; const aParams: array of const): TnxDynVariantArray;
Parameters
Parameters | Description
const aQuery: string | the SQL query as string
const aParams: array of const | an array of parameter values
Description
- statement support -

Executes a SQL query and returns it's result.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.ExecQueryFromFile Method

TnxDatabase.ExecQueryFromFile Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function ExecQueryFromFile(const aFileName: string; const aParams: array of const): TnxDynVariantArray;
Parameters
Parameters | Description
const aFileName: string | the file containing the query
const aParams: array of const | an array of parameter values
Description

Executes a SQL query and returns it's result.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.ExecQueryFromStream Method

TnxDatabase.ExecQueryFromStream Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function ExecQueryFromStream(aStream: TStream; const aParams: array of const): TnxDynVariantArray;
Parameters
Parameters | Description
aStream: TStream | the stream containing the query
const aParams: array of const | an array of parameter values
Description

Executes a SQL query and returns it's result.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.ExecStoredProc Method

TnxDatabase.ExecStoredProc Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function ExecStoredProc(const aStoredProcName: string; const aParams: array of const): TnxDynVariantArray;
Parameters
Parameters | Description
const aStoredProcName: string | the name of the procedure
const aParams: array of const | an array of parameter values
Description

Executes a SQL Stored Procedure and returns it's result.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.Exists Method

TnxDatabase.Exists Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function Exists: Boolean;
Description

Returns true if the database exists.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetAutoIncValue Method

TnxDatabase.GetAutoIncValue Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetAutoIncValue(const aTableName: string; const aPassword: UnicodeString; out aValue: TnxWord32);
Description

Returns the next AutoInc value for the given table.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetChangedTables Method

TnxDatabase.GetChangedTables Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetChangedTables(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetChangedTables returns a list of all open tables in this database that have changed since the function was last called.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetDataDictionary Method

TnxDatabase.GetDataDictionary Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetDataDictionary(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary);
Parameters
Parameters | Description
const aTableName: string | table name
aDictionary: TnxDataDictionary | will hold the dictionary after the method returns; must not be nil
Description

The method returns the data dictionary of a given table. Raises an exception on failure.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetDataDictionaryEx Method

TnxDatabase.GetDataDictionaryEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function GetDataDictionaryEx(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary): TnxResult;
Parameters
Parameters | Description
const aTableName: string | table name
aDictionary: TnxDataDictionary | will hold the dictionary after the method returns; must not be nil
Description

The method returns the data dictionary of a given table. Returns an error code on failure.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetFreeDiskSpace Method

TnxDatabase.GetFreeDiskSpace Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function GetFreeDiskSpace: TnxInt64;
Parameters
Parameters | Description
aFreeSpace | will hold the free space info after the method returns
Description

This method returns the remaining disk space for the disk this database/alias is stored on.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetFreeDiskSpaceEx Method

TnxDatabase.GetFreeDiskSpaceEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function GetFreeDiskSpaceEx(out aFreeSpace: TnxInt64): TnxResult;
Parameters
Parameters | Description
out aFreeSpace: TnxInt64 | will hold the free space info after the method returns
Description

This method returns the remaining disk space for the disk this database/alias is stored on.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetPath Method

TnxDatabase.GetPath Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function GetPath: string;
Description

Returns the full (server based!) system path of the database.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetStoredFuncNames Method

TnxDatabase.GetStoredFuncNames Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetStoredFuncNames(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetStoredFuncNames returns a list of all stored function of the database.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetStoredFuncParams Method

TnxDatabase.GetStoredFuncParams Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetStoredFuncParams(const aStoredFuncName: string; out aParams: TnxStoredProcParamList);
Description

Returns the parameter defintions for a named stored function.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetStoredProcNames Method

TnxDatabase.GetStoredProcNames Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetStoredProcNames(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetStoredProcNames returns a list of all stored procedures of the database.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetStoredProcParams Method

TnxDatabase.GetStoredProcParams Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetStoredProcParams(const aStoredProcName: string; out aParams: TnxStoredProcParamList);
Description

Returns the parameter defintions for a named stored procedure.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetTableNames Method

TnxDatabase.GetTableNames Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetTableNames(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetTableNames returns a list of all tables of the database.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.GetTablesNeedingPack Method

TnxDatabase.GetTablesNeedingPack Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure GetTablesNeedingPack(aList: TStrings);
Parameters
Parameters | Description
aList: TStrings | will hold the names after the method returns; must not be nil
Description

GetTablesNeedingPack returns a list of all tables that need to be packed.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.Loaded Method

TnxDatabase.Loaded Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.nxcAddDependent Method

TnxDatabase.nxcAddDependent Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.nxcNotification Method

TnxDatabase.nxcNotification Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.nxcRemoveDependent Method

TnxDatabase.nxcRemoveDependent Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.OpenQuery Method

TnxDatabase.OpenQuery Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function OpenQuery(const aQuery: string; const aParams: array of const; aBlockReadSize: Integer = 0; aRequestLive: Boolean = False): TnxQuery;
Parameters
Parameters | Description
const aQuery: string | the SQL query as string
const aParams: array of const | array of parameter values
aBlockReadSize: Integer = 0 | if > 0 then it's the size in bytes for block reading the resulting cursor
aRequestLive: Boolean = False | if true then tries to get a live result set
Description

Executes a SQL query and returns a cursor (if applicaple)

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.OpenStoredProc Method

TnxDatabase.OpenStoredProc Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function OpenStoredProc(const aStoredProcName: string; const aParams: array of const; aBlockReadSize: Integer = 0): TnxStoredProc;
Parameters
Parameters | Description
const aStoredProcName: string | the name of the procedure
const aParams: array of const | an array of parameter values
Description

Opens SQL Stored Procedure and returns it's local instance

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.OpenTable Method

TnxDatabase.OpenTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function OpenTable(const aTableName: string; const aIndexName: string = ''; aBlockReadSize: Integer = 0): TnxTable;
Parameters
Parameters | Description
const aTableName: string | the name of the table
const aIndexName: string = '' | the name of the index
aBlockReadSize: Integer = 0 | if > 0 then it's the size in bytes for block reading the resulting cursor
Description

Opens a Table.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.PackTable Method

TnxDatabase.PackTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function PackTable(const aTableName: string; const aPassword: UnicodeString): TnxAbstractTaskInfo;
Parameters
Parameters | Description
aName | table name
aTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Raises an exception on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTableEx, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.PackTableEx Method

TnxDatabase.PackTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function PackTableEx(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.RecoverTable Method

TnxDatabase.RecoverTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function RecoverTable(const aTableName: string; const aPassword: UnicodeString): TnxAbstractTaskInfo;
Parameters
Parameters | Description
const aTableName: string | table name
const aPassword: UnicodeString | table password
Description

The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Triggers and exception on failure. Unrecoverable records are placed in a new table named TableName_Failed.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.RecoverTableEx Method

TnxDatabase.RecoverTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function RecoverTableEx(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
const aTableName: string | table name
const aPassword: UnicodeString | table password
out aTaskInfo: TnxAbstractTaskInfo | returned task info, needs to be freed after use
Description

The method attempts to recover records from a broken table. Recovered records are placed in a new table named TableName_Recovered. Returns an error value on failure. Unrecoverable records are placed in a new table named TableName_Failed.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


ReIndexTable Method

ReIndexTable Method
TnxDatabase Methods Send Feedback

This is the overview for the ReIndexTable method overload.

Overload List
Name | Description
TnxDatabase.ReIndexTable (string, UnicodeString, Integer) | ReindexTable starts an asynchronous re indexing of a certain index of a table. Raises an exception on failure.
TnxDatabase.ReIndexTable (string, UnicodeString, string) | ReIndexTable starts an asynchronous re indexing of a certain index of a table. Raises an exception on failure.
Group

TnxDatabase Methods

Links
TnxDatabase Methods


TnxDatabase.ReIndexTable Method (string, UnicodeString, Integer)

TnxDatabase.ReIndexTable Method (string, UnicodeString, Integer)
TnxDatabase Class TnxDatabase Members nxdb Namespace ReIndexTable Method See Also Send Feedback
Syntax
Delphi
function ReIndexTable(const aTableName: string; const aPassword: UnicodeString; aIndexNum: Integer): TnxAbstractTaskInfo; overload;
Parameters
Parameters | Description
aIndexNum: Integer | the index number of the index in the list of indexes
aName | table name
aTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

ReindexTable starts an asynchronous re indexing of a certain index of a table. Raises an exception on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable ReIndexTableEx, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

ReIndexTable Method

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, ReIndexTable Method, See Also


TnxDatabase.ReIndexTable Method (string, UnicodeString, string)

TnxDatabase.ReIndexTable Method (string, UnicodeString, string)
TnxDatabase Class TnxDatabase Members nxdb Namespace ReIndexTable Method See Also Send Feedback
Syntax
Delphi
function ReIndexTable(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string): TnxAbstractTaskInfo; overload;
Parameters
Parameters | Description
const aIndexName: string | the name of the index
aName | table name
aTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

ReIndexTable starts an asynchronous re indexing of a certain index of a table. Raises an exception on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTableEx, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

ReIndexTable Method

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, ReIndexTable Method, See Also


ReIndexTableEx Method

ReIndexTableEx Method
TnxDatabase Methods Send Feedback

This is the overview for the ReIndexTableEx method overload.

Overload List
Name | Description
TnxDatabase.ReIndexTableEx (string, UnicodeString, Integer, TnxAbstractTaskInfo) | ReindexTableEx starts an asynchronous re indexing of a certain index of a table. Returns an error code on failure.
TnxDatabase.ReIndexTableEx (string, UnicodeString, string, TnxAbstractTaskInfo) | ReIndexTableEx starts an asynchronous re indexing of a certain index of a table. Returns an error code on failure.
Group

TnxDatabase Methods

Links
TnxDatabase Methods


TnxDatabase.ReIndexTableEx Method (string, UnicodeString, Integer, TnxAbstractTaskInfo)

TnxDatabase.ReIndexTableEx Method (string, UnicodeString, Integer, TnxAbstractTaskInfo)
TnxDatabase Class TnxDatabase Members nxdb Namespace ReIndexTableEx Method See Also Send Feedback
Syntax
Delphi
function ReIndexTableEx(const aTableName: string; const aPassword: UnicodeString; aIndexNum: Integer; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; overload;
Parameters
Parameters | Description
aIndexNum: Integer | the index number of the index in the list of indexes
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

ReindexTableEx starts an asynchronous re indexing of a certain index of a table. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

ReIndexTableEx Method

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, ReIndexTableEx Method, See Also


TnxDatabase.ReIndexTableEx Method (string, UnicodeString, string, TnxAbstractTaskInfo)

TnxDatabase.ReIndexTableEx Method (string, UnicodeString, string, TnxAbstractTaskInfo)
TnxDatabase Class TnxDatabase Members nxdb Namespace ReIndexTableEx Method See Also Send Feedback
Syntax
Delphi
function ReIndexTableEx(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; overload;
Parameters
Parameters | Description
const aIndexName: string | the name of the index
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

ReIndexTableEx starts an asynchronous re indexing of a certain index of a table. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

ReIndexTableEx Method

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, ReIndexTableEx Method, See Also


TnxDatabase.RenameTable Method

TnxDatabase.RenameTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure RenameTable(const aOldName: string; const aNewName: string; const aPassword: UnicodeString);
Parameters
Parameters | Description
const aOldName: string | name of existing table
const aNewName: string | new name for the table
Description

RenameTable changes the name of a table.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.RestructureTable Method

TnxDatabase.RestructureTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function RestructureTable(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor): TnxAbstractTaskInfo;
Parameters
Parameters | Description
aDictionary: TnxDataDictionary | new dictionary of the table
aName | table name
aFieldName | defines how fields are mapped from the old to the new structure
aTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

With this method you can start an asynchronous restructure of a given table. Raises an exception on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.RestructureTableEx Method

TnxDatabase.RestructureTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function RestructureTableEx(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
aDictionary: TnxDataDictionary | new dictionary of the table
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
aFieldName | defines how fields are mapped from the old to the new structure
Description

With this method you can start an asynchronous restructure of a given table. Returns an error code on failure.

See Also

DeleteTable, CreateTable, EmptyTable, RenameTable, PackTable, ReIndexTable, RestructureTable, TnxAbstractTaskInfo, GetStatus

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.Rollback Method

TnxDatabase.Rollback Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure Rollback;
Description

Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.scInitializing Method

TnxDatabase.scInitializing Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.scIsStateParent Method

TnxDatabase.scIsStateParent Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.scStarting Method

TnxDatabase.scStarting Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.scStopping Method

TnxDatabase.scStopping Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.soCheckDefaults Method

TnxDatabase.soCheckDefaults Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure soCheckDefaults; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.soRefreshTimeout Method

TnxDatabase.soRefreshTimeout Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure soRefreshTimeout; override;
Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.soSetSession Method

TnxDatabase.soSetSession Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
procedure soSetSession(Value: TnxBaseSession); override;
Description

<<<

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.StartTransaction Method

TnxDatabase.StartTransaction Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure StartTransaction(aSnapShot: Boolean = False);
Parameters
Parameters | Description
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

StartTransaction tries to start a transaction. If it fails an exception is triggered.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.StartTransactionWith Method

TnxDatabase.StartTransactionWith Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure StartTransactionWith(const aTables: array of TnxTable; aSnapShot: Boolean = False);
Parameters
Parameters | Description
const aTables: array of TnxTable | the tables that should be part of the transaction
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.StartTransactionWithEx Method

TnxDatabase.StartTransactionWithEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function StartTransactionWithEx(const aTables: array of TnxTable; aSnapShot: Boolean = False): TnxResult;
Parameters
Parameters | Description
const aTables: array of TnxTable | the tables that should be part of the transaction
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.TableExists Method

TnxDatabase.TableExists Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function TableExists(const aTableName: string; const aPassword: UnicodeString): Boolean;
Parameters
Parameters | Description
const aTableName: string | table name
Description

This function returns true if a table with the given name exists otherwise false.

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.TransactionCorrupted Method

TnxDatabase.TransactionCorrupted Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
procedure TransactionCorrupted;
Description

This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.TryStartTransaction Method

TnxDatabase.TryStartTransaction Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods See Also Send Feedback
Syntax
Delphi
function TryStartTransaction(aSnapShot: Boolean = False): Boolean;
Parameters
Parameters | Description
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by this database instance or triggers an exception if an error occurs.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods, See Also


TnxDatabase.VerifyChecksumTable Method

TnxDatabase.VerifyChecksumTable Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function VerifyChecksumTable(const aTableName: string; const aPassword: UnicodeString; aRaw: Boolean; aForceRecheck: Boolean): TnxAbstractTaskInfo;
Parameters
Parameters | Description
const aTableName: string | table name
const aPassword: UnicodeString | table password
aRaw: Boolean | use raw, encoded blocks instead of decoding them
aForceRecheck: Boolean | check all blocks again, even if already successfully checked since the server opened the table
Description

This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase.VerifyChecksumTableEx Method

TnxDatabase.VerifyChecksumTableEx Method
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Methods Send Feedback
Syntax
Delphi
function VerifyChecksumTableEx(const aTableName: string; const aPassword: UnicodeString; aRaw: Boolean; aForceRecheck: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
const aTableName: string | table name
const aPassword: UnicodeString | table password
aRaw: Boolean | use raw, encoded blocks instead of decoding them
aForceRecheck: Boolean | check all blocks again, even if already successfully checked since the server opened the table
out aTaskInfo: TnxAbstractTaskInfo | returned task info, needs to be freed after use
Description

This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).

Group

TnxDatabase Methods

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Methods


TnxDatabase Properties

TnxDatabase Properties
TnxDatabase Class Legend Protected Properties Public Properties Published Properties Send Feedback

The properties of the TnxDatabase class are listed here.

Class

TnxDatabase Class

Protected Properties
Name | Description
CursorCount | This is CursorCount, a member of class TnxDatabase.
Cursors | This is Cursors, a member of class TnxDatabase.
Public Properties
Name | Description
AbstractDatabase | This is AbstractDatabase, a member of class TnxDatabase.
DataSetCount | Returns the number of dataset instances attached to this database.
DataSets | Returns the dataset with index aInx out of the list of attached dataset instances.
Implicit | Implicit is true if the database instance was create implicitly, e.g by using tnxTable directly without assigning it to a database.
InTransaction | Returns true if a transaction for the current database is active otherwise false.
Path | Returns the file system path of this database.
Queries | Returns the query with index aInx out of the list of attached query instances.
QueryCount | Returns the number of (client-side) query instances attached to the database component.
TableCount | Returns the number of (client-side) table instances attached to the database component.
Tables | Returns the table with index aInx out of the list of attached table instances.
Published Properties
Name | Description
AliasName | The alias name the database is connected to. Either AliasName or AliasPath must be set.
AliasPath | The (local server) path the database is connected to. Either AliasName or AliasPath must be set.
Default | If true this Database is the default database for it's session.
Exclusive | If a database is exclusively opened, only ONE client has access at a time.
FailSafe | Sets failsafe mode on or off. For more info see NexusDB manual.
ReadOnly | With this property a database can be set to read only.
TransContext | The transaction context the database is attached to. This property can be nil.
Links
TnxDatabase Class, Legend, Protected Properties, Public Properties, Published Properties


TnxDatabase.AbstractDatabase Property

TnxDatabase.AbstractDatabase Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property AbstractDatabase: TnxAbstractDatabase;
Description

This is AbstractDatabase, a member of class TnxDatabase.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.AliasName Property

TnxDatabase.AliasName Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property AliasName: string;
Description

The alias name the database is connected to. Either AliasName or AliasPath must be set.

See Also

AliasPath

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.AliasPath Property

TnxDatabase.AliasPath Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property AliasPath: string;
Description

The (local server) path the database is connected to. Either AliasName or AliasPath must be set.

See Also

AliasName

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.CursorCount Property

TnxDatabase.CursorCount Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property CursorCount: Integer;
Description

This is CursorCount, a member of class TnxDatabase.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.Cursors Property

TnxDatabase.Cursors Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property Cursors [aInx: Integer]: TnxCursor;
Description

This is Cursors, a member of class TnxDatabase.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.DataSetCount Property

TnxDatabase.DataSetCount Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property DataSetCount: Integer;
Description

Returns the number of dataset instances attached to this database.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.DataSets Property

TnxDatabase.DataSets Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property DataSets [aInx: Integer]: TnxDataset;
Description

Returns the dataset with index aInx out of the list of attached dataset instances.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.Default Property

TnxDatabase.Default Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property Default: Boolean;
Description

If true this Database is the default database for it's session.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.Exclusive Property

TnxDatabase.Exclusive Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property Exclusive: Boolean;
Description

If a database is exclusively opened, only ONE client has access at a time.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.FailSafe Property

TnxDatabase.FailSafe Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property FailSafe: Boolean;
Description

Sets failsafe mode on or off. For more info see NexusDB manual.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.Implicit Property

TnxDatabase.Implicit Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property Implicit: Boolean;
Description

Implicit is true if the database instance was create implicitly, e.g by using tnxTable directly without assigning it to a database.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.InTransaction Property

TnxDatabase.InTransaction Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property InTransaction: Boolean;
Description

Returns true if a transaction for the current database is active otherwise false.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.Path Property

TnxDatabase.Path Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property Path: string;
Description

Returns the file system path of this database.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.Queries Property

TnxDatabase.Queries Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property Queries [aInx: Integer]: TnxStatementDataSet;
Description

Returns the query with index aInx out of the list of attached query instances.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.QueryCount Property

TnxDatabase.QueryCount Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property QueryCount: Integer;
Description

Returns the number of (client-side) query instances attached to the database component.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.ReadOnly Property

TnxDatabase.ReadOnly Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property ReadOnly: Boolean;
Description

With this property a database can be set to read only.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDatabase.TableCount Property

TnxDatabase.TableCount Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property TableCount: Integer;
Description

Returns the number of (client-side) table instances attached to the database component.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.Tables Property

TnxDatabase.Tables Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties See Also Send Feedback
Syntax
Delphi
property Tables [aInx: Integer]: TnxTable;
Description

Returns the table with index aInx out of the list of attached table instances.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties, See Also


TnxDatabase.TransContext Property

TnxDatabase.TransContext Property
TnxDatabase Class TnxDatabase Members nxdb Namespace TnxDatabase Properties Send Feedback
Syntax
Delphi
property TransContext: TnxTransContext;
Description

The transaction context the database is attached to. This property can be nil.

Group

TnxDatabase Properties

Links
TnxDatabase Class, TnxDatabase Members, nxdb Namespace, TnxDatabase Properties


TnxDataset Class

TnxDataset Class
TnxDataset Fields TnxDataset Methods TnxDataset Properties TnxDataset Events TnxDataset Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxDataset
Syntax
Delphi
TnxDataset = class(TDataSet);
File

nxdb

Description

TnxDataset is the base class for all TDataset compatible Nexus components. Most methods and properties work exactly the same as Borland's implementation.

Group

Classes

Links
TnxDataset Fields, TnxDataset Methods, TnxDataset Properties, TnxDataset Events, TnxDataset Members, nxdb, Classes


TnxDataset Members

TnxDataset Members
TnxDataset Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxDataset.

Class

TnxDataset Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | open/close.
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | info.
GetFieldClass |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
Post | == virtual TDataSet methods == -- navigation
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxDataset Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxDataset.Create Constructor

TnxDataset.Create Constructor
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxDataset Class

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Class


TnxDataset.Destroy Destructor

TnxDataset.Destroy Destructor
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxDataset Class

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Class


TnxDataset Fields

TnxDataset Fields
TnxDataset Class Legend Protected Fields Send Feedback

The fields of the TnxDataset class are listed here.

Class

TnxDataset Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
Links
TnxDataset Class, Legend, Protected Fields


TnxDataset.ds_Dictionary Field

TnxDataset.ds_Dictionary Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
ds_Dictionary: TnxDataDictionary;
Description

This is ds_Dictionary, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsAbstractCursor Field

TnxDataset.dsAbstractCursor Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsAbstractCursor: TnxAbstractCursor;
Description

This is dsAbstractCursor, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsActiveDesigntime Field

TnxDataset.dsActiveDesigntime Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsActiveDesigntime: Boolean;
Description

This is dsActiveDesigntime, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsActiveRuntime Field

TnxDataset.dsActiveRuntime Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsActiveRuntime: Boolean;
Description

private

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsAliasName Field

TnxDataset.dsAliasName Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsAliasName: string;
Description

This is dsAliasName, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppend Field

TnxDataset.dsBatchAppend Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppend: Integer;
Description

batch append.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppendBlobs Field

TnxDataset.dsBatchAppendBlobs Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppendBlobs: array of TnxMemoryStream;
Description

This is dsBatchAppendBlobs, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppendCutoff Field

TnxDataset.dsBatchAppendCutoff Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppendCutoff: Integer;
Description

This is dsBatchAppendCutoff, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppendData Field

TnxDataset.dsBatchAppendData Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppendData: TnxMemoryStream;
Description

This is dsBatchAppendData, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppendRecordCount Field

TnxDataset.dsBatchAppendRecordCount Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppendRecordCount: array of integer;
Description

This is dsBatchAppendRecordCount, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBatchAppendStartOffset Field

TnxDataset.dsBatchAppendStartOffset Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBatchAppendStartOffset: array of int64;
Description

This is dsBatchAppendStartOffset, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlobFields Field

TnxDataset.dsBlobFields Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlobFields: array of TBlobField;
Description

This is dsBlobFields, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlobStreamsHead Field

TnxDataset.dsBlobStreamsHead Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlobStreamsHead: TnxBaseBlobStream;
Description

blob streams.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlobStreamsTail Field

TnxDataset.dsBlobStreamsTail Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlobStreamsTail: TnxBaseBlobStream;
Description

This is dsBlobStreamsTail, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadCount Field

TnxDataset.dsBlockReadCount Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadCount: Integer;
Description

This is dsBlockReadCount, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadEof Field

TnxDataset.dsBlockReadEof Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadEof: Boolean;
Description

This is dsBlockReadEof, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadOptions Field

TnxDataset.dsBlockReadOptions Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadOptions: TnxRecordGetBatchExOptions;
Description

This is dsBlockReadOptions, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadPos Field

TnxDataset.dsBlockReadPos Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadPos: Integer;
Description

This is dsBlockReadPos, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadSize Field

TnxDataset.dsBlockReadSize Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadSize: Integer;
Description

block read mode.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBlockReadStream Field

TnxDataset.dsBlockReadStream Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBlockReadStream: TnxMemoryStream;
Description

This is dsBlockReadStream, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsBof Field

TnxDataset.dsBof Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsBof: PBoolean;
Description

This is dsBof, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsCursor Field

TnxDataset.dsCursor Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsCursor: TnxCursor;
Description

cursor.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsDeactivating Field

TnxDataset.dsDeactivating Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsDeactivating: Boolean;
Description

This is dsDeactivating, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsDefaultValueHandler Field

TnxDataset.dsDefaultValueHandler Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsDefaultValueHandler: TnxDefaultValueHandler;
Description

This is dsDefaultValueHandler, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsEof Field

TnxDataset.dsEof Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsEof: PBoolean;
Description

This is dsEof, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsExprFilter Field

TnxDataset.dsExprFilter Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsExprFilter: TnxFilterID;
Description

This is dsExprFilter, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFieldsDescriptor Field

TnxDataset.dsFieldsDescriptor Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFieldsDescriptor: TnxFieldsDescriptor;
Description

This is dsFieldsDescriptor, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFilterResync Field

TnxDataset.dsFilterResync Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFilterResync: Boolean;
Description

filter.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFilterTimeout Field

TnxDataset.dsFilterTimeout Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFilterTimeout: TnxWord32;
Description

This is dsFilterTimeout, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFilterType Field

TnxDataset.dsFilterType Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFilterType: TnxFilterType;
Description

This is dsFilterType, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFlipOrder Field

TnxDataset.dsFlipOrder Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFlipOrder: Boolean;
Description

This is dsFlipOrder, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsFuncFilter Field

TnxDataset.dsFuncFilter Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsFuncFilter: TnxFilterID;
Description

This is dsFuncFilter, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsIgnoreDataEvents Field

TnxDataset.dsIgnoreDataEvents Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsIgnoreDataEvents: Boolean;
Description

This is dsIgnoreDataEvents, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsIgnoreReadOnly Field

TnxDataset.dsIgnoreReadOnly Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsIgnoreReadOnly: Integer;
Description

This is dsIgnoreReadOnly, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsInsideScroll Field

TnxDataset.dsInsideScroll Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsInsideScroll: Boolean;
Description

workarounds for crappy Borland bugs

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsInternalState Field

TnxDataset.dsInternalState Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsInternalState: TnxDataSetInternalStates;
Description

This is dsInternalState, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsInternalWriteOnly Field

TnxDataset.dsInternalWriteOnly Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsInternalWriteOnly: Boolean;
Description

This is dsInternalWriteOnly, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsLookupOptions Field

TnxDataset.dsLookupOptions Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsLookupOptions: TLocateOptions;
Description

lookup

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsMapperFieldOffset Field

TnxDataset.dsMapperFieldOffset Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsMapperFieldOffset: array of Integer;
Description

This is dsMapperFieldOffset, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsMapperList Field

TnxDataset.dsMapperList Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsMapperList: TObjectList;
Description

This is dsMapperList, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsMapperNexusToVcl Field

TnxDataset.dsMapperNexusToVcl Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsMapperNexusToVcl: TnxDynMapperMethodArray;
Description

field access.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsMappers Field

TnxDataset.dsMappers Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsMappers: array of TnxBaseVclFieldMapper;
Description

This is dsMappers, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsMapperVclToNexus Field

TnxDataset.dsMapperVclToNexus Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsMapperVclToNexus: TnxDynMapperMethodArray;
Description

This is dsMapperVclToNexus, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOffsetBookmark Field

TnxDataset.dsOffsetBookmark Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOffsetBookmark: Integer;
Description

This is dsOffsetBookmark, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOffsetCalcFlds Field

TnxDataset.dsOffsetCalcFlds Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOffsetCalcFlds: Integer;
Description

This is dsOffsetCalcFlds, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOffsetRecInfos Field

TnxDataset.dsOffsetRecInfos Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOffsetRecInfos: Integer;
Description

This is dsOffsetRecInfos, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOldValuesBuffer Field

TnxDataset.dsOldValuesBuffer Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOldValuesBuffer: TnxRecordBuffer;
Description

This is dsOldValuesBuffer, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOnServerFilterTimeout Field

TnxDataset.dsOnServerFilterTimeout Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOnServerFilterTimeout: TnxServerFilterTimeoutEvent;
Description

This is dsOnServerFilterTimeout, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsOptions Field

TnxDataset.dsOptions Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsOptions: TnxDataSetOptions;
Description

state.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecordBufferCount Field

TnxDataset.dsRecordBufferCount Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecordBufferCount: Integer;
Description

This is dsRecordBufferCount, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecordBufferPool Field

TnxDataset.dsRecordBufferPool Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecordBufferPool: TnxMemoryPool;
Description

This is dsRecordBufferPool, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecordBufferSize Field

TnxDataset.dsRecordBufferSize Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecordBufferSize: Integer;
Description

This is dsRecordBufferSize, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecordLength Field

TnxDataset.dsRecordLength Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecordLength: Integer;
Description

record buffer.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecordToFilter Field

TnxDataset.dsRecordToFilter Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecordToFilter: Pointer;
Description

This is dsRecordToFilter, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsRecRevField Field

TnxDataset.dsRecRevField Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsRecRevField: Boolean;
Description

This is dsRecRevField, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsSession Field

TnxDataset.dsSession Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsSession: TnxBaseSession;
Description

This is dsSession, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsSimpleExpressionFilterClass Field

TnxDataset.dsSimpleExpressionFilterClass Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsSimpleExpressionFilterClass: TnxSimpleExpressionFilterDescriptorClass;
Description

This is dsSimpleExpressionFilterClass, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsSqlFilterClass Field

TnxDataset.dsSqlFilterClass Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsSqlFilterClass: TnxSqlFilterDescriptorClass;
Description

This is dsSqlFilterClass, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsTableDescriptor Field

TnxDataset.dsTableDescriptor Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsTableDescriptor: TnxBaseTableDescriptor;
Description

This is dsTableDescriptor, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsTimeout Field

TnxDataset.dsTimeout Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsTimeout: Integer;
Description

This is dsTimeout, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsValidationsHandler Field

TnxDataset.dsValidationsHandler Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsValidationsHandler: TnxValidationsHandler;
Description

This is dsValidationsHandler, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset.dsWriteOnly Field

TnxDataset.dsWriteOnly Field
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Fields Send Feedback
Syntax
Delphi
dsWriteOnly: Boolean;
Description

This is dsWriteOnly, a member of class TnxDataset.

Group

TnxDataset Fields

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Fields


TnxDataset Methods

TnxDataset Methods
TnxDataset Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDataset class are listed here.

Class

TnxDataset Class

Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | open/close.
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | info.
GetFieldClass |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
Post | == virtual TDataSet methods == -- navigation
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Links
TnxDataset Class, Legend, Protected Methods, Public Methods


TnxDataset.AddFileBlob Method

TnxDataset.AddFileBlob Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure AddFileBlob(aField: TField; const aFileName: string);
Parameters
Parameters | Description
aField: TField | the blob field you want the file associated with
const aFileName: string | the file name
Description

AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.AddFileBlobEx Method

TnxDataset.AddFileBlobEx Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function AddFileBlobEx(aField: TField; const aFileName: string): TnxResult;
Parameters
Parameters | Description
aField: TField | the blob field you want the file associated with
const aFileName: string | the file name
Description

AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.AfterConstruction Method

TnxDataset.AfterConstruction Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TDataSet.AfterConstruction

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.AllocRecordBuffer Method

TnxDataset.AllocRecordBuffer Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function AllocRecordBuffer: TnxRecordBuffer; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.BatchPost Method

TnxDataset.BatchPost Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure BatchPost;
Description

Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.

See Also

FlushBatchAppend, EndBatchAppend, BeginBatchAppend, BatchPost, InBatchAppend, CancelBatchAppend

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.BeginBatchAppend Method

TnxDataset.BeginBatchAppend Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure BeginBatchAppend(aCutoffSize: Integer);
Parameters
Parameters | Description
aCutoffSize: Integer | the size in bytes when a batch is send to the server.
Description

Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend.

Please note that batch writing to blob fields is fully supported!

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.BlockReadNext Method

TnxDataset.BlockReadNext Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure BlockReadNext; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.BookmarkValid Method

TnxDataset.BookmarkValid Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function BookmarkValid(aBookmark: TBookmark): Boolean; override;
Description

see TDataSet.BookmarkValid

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CancelBatchAppend Method

TnxDataset.CancelBatchAppend Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure CancelBatchAppend;
Description

This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.

See Also

FlushBatchAppend, EndBatchAppend, BeginBatchAppend, BatchPost, InBatchAppend, CancelBatchAppend

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.CheckFieldCompatibility Method

TnxDataset.CheckFieldCompatibility Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CheckFieldCompatibility(aField: TField; aFieldDef: TFieldDef); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.ClearCalcFields Method

TnxDataset.ClearCalcFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure ClearCalcFields(aBuffer: TnxRecordBuffer); override;
Description

field access.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CloseBlob Method

TnxDataset.CloseBlob Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CloseBlob(aField: TField); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CloseCursor Method

TnxDataset.CloseCursor Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CloseCursor; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CompareBookmarks Method

TnxDataset.CompareBookmarks Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function CompareBookmarks(aBookmark1: TBookmark; aBookmark2: TBookmark): Integer; override;
Description

see TDataSet.CompareBookmarks

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CopyRecords Method

TnxDataset.CopyRecords Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CopyRecords(aSrcTable: TnxDataset; aCopyBLOBs: Boolean; aMaxTransSize: Integer = 0);
Parameters
Parameters | Description
aSrcTable: TnxDataset | the dataset the records are coming from. apply filters/ranges if you want to restrict the records
aCopyBLOBs: Boolean | set to true if you want to copy the blob fields too
aMaxTransSize: Integer = 0 | number of dirty mem blocks to copy in one transaction
Description

The method copies all visible records from the source dataset to the current table.

It correctly uses the ranges/filters on the source table.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CopyRecordsEx Method

TnxDataset.CopyRecordsEx Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CopyRecordsEx(aSrcTable: TnxDataset; aCopyBLOBs: Boolean; aMaxTransSize: Integer = 0; aCheckValFields: Boolean = True);
Parameters
Parameters | Description
aSrcTable: TnxDataset | the dataset the records are coming from. apply filters/ranges if you want to restrict the records
aCopyBLOBs: Boolean | set to true if you want to copy the blob fields too
aMaxTransSize: Integer = 0 | number of dirty mem blocks to copy in one transaction
aCheckValFields: Boolean = True | Wether or not to enforce field validation checks
Description

The method copies all visible records from the source dataset to the current table.

It correctly uses the ranges/filters on the source table.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.CreateBlobStream Method

TnxDataset.CreateBlobStream Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
function CreateBlobStream(aField: TField; aMode: TBlobStreamMode): TStream; override;
Description

This function creates the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TDataSet.CreateBlobStream TnxBaseBlobStream TnxBlobStream TnxBlockModeBlobStream TnxBatchAppendBlobStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.CreateFields Method

TnxDataset.CreateFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure CreateFields; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DataConvert Method

TnxDataset.DataConvert Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DataConvert(aField: TField; aSource: Pointer; aDest: Pointer; aToNative: Boolean); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DataEvent Method

TnxDataset.DataEvent Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DataEvent(aEvent: TDataEvent; aInfo: TnxNativeInt); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DeleteRecords Method

TnxDataset.DeleteRecords Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DeleteRecords;
Description

This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DeleteStream Method

TnxDataset.DeleteStream Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure DeleteStream(const aName: string);
Parameters
Parameters | Description
const aName: string | Name of the stream
Description

Use this to delete the streams.

NEVER EVER DELETE THE DICT STREAM!

See Also

GetStreamList, WriteStream, ReadStream, DeleteStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.DoAfterOpen Method

TnxDataset.DoAfterOpen Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoAfterOpen; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoAfterScroll Method

TnxDataset.DoAfterScroll Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoAfterScroll; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeCancel Method

TnxDataset.DoBeforeCancel Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeCancel; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeClose Method

TnxDataset.DoBeforeClose Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeClose; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeDelete Method

TnxDataset.DoBeforeDelete Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeDelete; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeEdit Method

TnxDataset.DoBeforeEdit Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeEdit; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeInsert Method

TnxDataset.DoBeforeInsert Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeInsert; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforePost Method

TnxDataset.DoBeforePost Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforePost; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeRefresh Method

TnxDataset.DoBeforeRefresh Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeRefresh; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.DoBeforeScroll Method

TnxDataset.DoBeforeScroll Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure DoBeforeScroll; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsActivateFilter Method

TnxDataset.dsActivateFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsActivateFilter(aFilterID: TnxFilterID): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsActivateFilters Method

TnxDataset.dsActivateFilters Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsActivateFilters; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsApplyMasterRange Method

TnxDataset.dsApplyMasterRange Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsApplyMasterRange; virtual;
Description
*

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsBindBlobFields Method

TnxDataset.dsBindBlobFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsBindBlobFields(Binding: Boolean); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsBindFields Method

TnxDataset.dsBindFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsBindFields(Binding: Boolean); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsBindMappers Method

TnxDataset.dsBindMappers Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsBindMappers(Binding: Boolean); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCancelServerFilter Method

TnxDataset.dsCancelServerFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsCancelServerFilter: Boolean; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


dsCheck Method

dsCheck Method
TnxDataset Methods Send Feedback

This is the overview for the dsCheck method overload.

Overload List
Name | Description
TnxDataset.dsCheck (TField, TnxResult) |
TnxDataset.dsCheck (TnxResult) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.dsCheck Method (TField, TnxResult)

TnxDataset.dsCheck Method (TField, TnxResult)
TnxDataset Class TnxDataset Members nxdb Namespace dsCheck Method Send Feedback
Syntax
Delphi
procedure dsCheck(aField: TField; const aErrorCode: TnxResult); overload;
Group

dsCheck Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsCheck Method


TnxDataset.dsCheck Method (TnxResult)

TnxDataset.dsCheck Method (TnxResult)
TnxDataset Class TnxDataset Members nxdb Namespace dsCheck Method Send Feedback
Syntax
Delphi
procedure dsCheck(const aErrorCode: TnxResult); overload;
Group

dsCheck Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsCheck Method


TnxDataset.dsCheckDefaults Method

TnxDataset.dsCheckDefaults Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCheckDefaults; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCheckInactiveFromCursor Method

TnxDataset.dsCheckInactiveFromCursor Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCheckInactiveFromCursor; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCheckOpenBlobStreams Method

TnxDataset.dsCheckOpenBlobStreams Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCheckOpenBlobStreams;
Description

blobs.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCheckOperation Method

TnxDataset.dsCheckOperation Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCheckOperation(aOperation: TDataOperation; aErrorEvent: TDataSetErrorEvent);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCloseCursorID Method

TnxDataset.dsCloseCursorID Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCloseCursorID; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCreateExprFilter Method

TnxDataset.dsCreateExprFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCreateExprFilter(const aText: string; aOpts: TFilterOptions);
Description

filter.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCreateFuncFilter Method

TnxDataset.dsCreateFuncFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsCreateFuncFilter(aFilterFunc: TnxFilterCallback);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsCreateLookupFilter Method

TnxDataset.dsCreateLookupFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsCreateLookupFilter(aFields: TnxFieldList; const aValues: Variant; aOptions: TLocateOptions): TnxBaseFilterDescriptor;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsDeactivateFilter Method

TnxDataset.dsDeactivateFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsDeactivateFilter(aFilterID: TnxFilterID): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsDeactivateFilters Method

TnxDataset.dsDeactivateFilters Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsDeactivateFilters; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsDestroyLookupCursor Method

TnxDataset.dsDestroyLookupCursor Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsDestroyLookupCursor; virtual;
Description

lookup support.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsDropFilter Method

TnxDataset.dsDropFilter Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsDropFilter(aFilterID: TnxFilterID): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsDropFilters Method

TnxDataset.dsDropFilters Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsDropFilters;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


dsError Method

dsError Method
TnxDataset Methods Send Feedback

This is the overview for the dsError method overload.

Overload List
Name | Description
TnxDataset.dsError (PResStringRec) |
TnxDataset.dsError (PResStringRec, array of const) |
TnxDataset.dsError (string) |
TnxDataset.dsError (string, array of const) |
TnxDataset.dsError (TnxResult) |
TnxDataset.dsError (TnxResult, PResStringRec) |
TnxDataset.dsError (TnxResult, PResStringRec, array of const) |
TnxDataset.dsError (TnxResult, string) |
TnxDataset.dsError (TnxResult, string, array of const) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.dsError Method (PResStringRec)

TnxDataset.dsError Method (PResStringRec)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(aMsgRes: PResStringRec); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (PResStringRec, array of const)

TnxDataset.dsError Method (PResStringRec, array of const)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(aMsgRes: PResStringRec; const aArgs: array of const); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (TnxResult)

TnxDataset.dsError Method (TnxResult)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aErrorCode: TnxResult); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (TnxResult, PResStringRec)

TnxDataset.dsError Method (TnxResult, PResStringRec)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aErrorCode: TnxResult; aAltMsgRes: PResStringRec); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (TnxResult, PResStringRec, array of const)

TnxDataset.dsError Method (TnxResult, PResStringRec, array of const)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aErrorCode: TnxResult; aAltMsgRes: PResStringRec; const aArgs: array of const); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (TnxResult, string)

TnxDataset.dsError Method (TnxResult, string)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aErrorCode: TnxResult; const aAltMsg: string); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (TnxResult, string, array of const)

TnxDataset.dsError Method (TnxResult, string, array of const)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (string)

TnxDataset.dsError Method (string)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aMsg: string); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsError Method (string, array of const)

TnxDataset.dsError Method (string, array of const)
TnxDataset Class TnxDataset Members nxdb Namespace dsError Method Send Feedback
Syntax
Delphi
procedure dsError(const aMsg: string; const aArgs: array of const); overload;
Group

dsError Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, dsError Method


TnxDataset.dsExceptionClass Method

TnxDataset.dsExceptionClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
class function dsExceptionClass: EnxDatabaseErrorClass; virtual;
Description

error handling.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsFieldDefCreated Method

TnxDataset.dsFieldDefCreated Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsFieldDefCreated(aFieldDef: TFieldDef; aFieldDescriptor: TnxFieldDescriptor); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsForceBlobNr Method

TnxDataset.dsForceBlobNr Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsForceBlobNr(aBuffer: Pointer; aField: TField; out aBlobNr: TnxInt64): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsFreeBlob Method

TnxDataset.dsFreeBlob Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsFreeBlob(aBuffer: Pointer; aField: TField): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsFreeKeyBuffers Method

TnxDataset.dsFreeKeyBuffers Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsFreeKeyBuffers; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsFreeMappers Method

TnxDataset.dsFreeMappers Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsFreeMappers; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetActiveBuffer Method

TnxDataset.dsGetActiveBuffer Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetActiveBuffer(var aBuffer: TnxRecordBuffer): Boolean; virtual;
Description

buffer management.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetActiveKeyBuffer Method

TnxDataset.dsGetActiveKeyBuffer Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetActiveKeyBuffer(var aBuffer: TnxRecordBuffer): Boolean; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetBlobNr Method

TnxDataset.dsGetBlobNr Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetBlobNr(aBuffer: Pointer; aField: TField; out aIsNull: Boolean; out aBlobNr: TnxInt64): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetCursorClass Method

TnxDataset.dsGetCursorClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetCursorClass: TnxCursorClass; virtual;
Description

internal functions

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetDataBase Method

TnxDataset.dsGetDataBase Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetDataBase: TnxDatabase;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetFieldDefClass Method

TnxDataset.dsGetFieldDefClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetFieldDefClass: TFieldDefClass; virtual;
Description

field managment.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetNextRecord Method

TnxDataset.dsGetNextRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetNextRecord(aLock: TnxLockType; aBuffer: Pointer): TnxResult; virtual;
Description

navigation.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetPriorRecord Method

TnxDataset.dsGetPriorRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetPriorRecord(aLock: TnxLockType; aBuffer: Pointer): TnxResult; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetRecord Method

TnxDataset.dsGetRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetRecord(aLock: TnxLockType; aBuffer: Pointer): TnxResult; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetSession Method

TnxDataset.dsGetSession Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetSession: TnxBaseSession;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetSimpleExpressionFilterClass Method

TnxDataset.dsGetSimpleExpressionFilterClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetSimpleExpressionFilterClass: TnxSimpleExpressionFilterDescriptorClass; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetSqlFilterClass Method

TnxDataset.dsGetSqlFilterClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetSqlFilterClass: TnxSqlFilterDescriptorClass; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetTimeout Method

TnxDataset.dsGetTimeout Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetTimeout: Integer;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsGetVersion Method

TnxDataset.dsGetVersion Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsGetVersion: string;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsInitBookmarkSize Method

TnxDataset.dsInitBookmarkSize Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsInitBookmarkSize; virtual;
Description

init.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsInitKeyBuffers Method

TnxDataset.dsInitKeyBuffers Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsInitKeyBuffers; virtual;
Description

key buffers.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsInitMappers Method

TnxDataset.dsInitMappers Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsInitMappers; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsInitOffsets Method

TnxDataset.dsInitOffsets Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsInitOffsets; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsInitPersistentFields Method

TnxDataset.dsInitPersistentFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsInitPersistentFields;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsIsAliasNameStored Method

TnxDataset.dsIsAliasNameStored Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsIsAliasNameStored: Boolean;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsIsDatabaseStored Method

TnxDataset.dsIsDatabaseStored Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsIsDatabaseStored: Boolean;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsIsSessionStored Method

TnxDataset.dsIsSessionStored Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsIsSessionStored: Boolean;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsLocateRecord Method

TnxDataset.dsLocateRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsLocateRecord(const aKeyFields: string; const aKeyValues: Variant; aOptions: TLocateOptions; aSyncCursor: Boolean): Boolean; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsOnFilterRecordCallback Method

TnxDataset.dsOnFilterRecordCallback Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsOnFilterRecordCallback(aRecord: PnxByteArray): Boolean; register;
Parameters
Parameters | Description
aRecord: PnxByteArray | aCookie : Integer = Self
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsOpenCursorID Method

TnxDataset.dsOpenCursorID Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsOpenCursorID; virtual; abstract;
Description

open/close.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsRefreshTimeout Method

TnxDataset.dsRefreshTimeout Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsRefreshTimeout; virtual;
Description

misc.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsResolveDatabase Method

TnxDataset.dsResolveDatabase Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsResolveDatabase;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetActiveDesigntime Method

TnxDataset.dsSetActiveDesigntime Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetActiveDesigntime(const Value: Boolean);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetActiveRuntime Method

TnxDataset.dsSetActiveRuntime Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetActiveRuntime(const Value: Boolean);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetAliasName Method

TnxDataset.dsSetAliasName Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetAliasName(Value: string);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetBlobNr Method

TnxDataset.dsSetBlobNr Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetBlobNr(aBuffer: Pointer; aField: TField; aBlobNr: TnxInt64);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetDataBase Method

TnxDataset.dsSetDataBase Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetDataBase(const Value: TnxDatabase); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetFilterData Method

TnxDataset.dsSetFilterData Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetFilterData(aType: TnxFilterType; const aText: string; aOpts: TFilterOptions);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetFilterTimeout Method

TnxDataset.dsSetFilterTimeout Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetFilterTimeout(aTimeout: TnxWord32);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetFilterType Method

TnxDataset.dsSetFilterType Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetFilterType(const Value: TnxFilterType);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetFlipOrder Method

TnxDataset.dsSetFlipOrder Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetFlipOrder(const Value: Boolean);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetOptions Method

TnxDataset.dsSetOptions Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetOptions(Value: TnxDataSetOptions);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetSession Method

TnxDataset.dsSetSession Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetSession(const Value: TnxBaseSession);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetTableLock Method

TnxDataset.dsSetTableLock Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetTableLock(aLockType: TnxLockType; aLock: Boolean); virtual;
Description

locking.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetTimeout Method

TnxDataset.dsSetTimeout Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetTimeout(const Value: Integer);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsSetVersion Method

TnxDataset.dsSetVersion Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsSetVersion(const Value: string);
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsShutdownFromCursor Method

TnxDataset.dsShutdownFromCursor Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure dsShutdownFromCursor; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.dsTruncateBlob Method

TnxDataset.dsTruncateBlob Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function dsTruncateBlob(aBuffer: Pointer; aField: TField; aLength: Integer): TnxResult;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.EndBatchAppend Method

TnxDataset.EndBatchAppend Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure EndBatchAppend;
Description

This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.

See Also

FlushBatchAppend, EndBatchAppend, BeginBatchAppend, BatchPost, InBatchAppend, CancelBatchAppend

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.Exists Method

TnxDataset.Exists Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function Exists: Boolean; dynamic;
Description

Exists returns true if this table exists, in the given session/database context.

It can be called without opening the table.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.FindRecord Method

TnxDataset.FindRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function FindRecord(aRestart: Boolean; aGoForward: Boolean): Boolean; override;
Description

record access/naviagtion.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.FlushBatchAppend Method

TnxDataset.FlushBatchAppend Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure FlushBatchAppend;
Parameters
Parameters | Description
aCutoffSize | the size in bytes when a batch is send to the server.
Description

Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.

See Also

FlushBatchAppend, EndBatchAppend, BeginBatchAppend, BatchPost, InBatchAppend, CancelBatchAppend

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.FreeRecordBuffer Method

TnxDataset.FreeRecordBuffer Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure FreeRecordBuffer(var aBuffer: TnxRecordBuffer); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetAutoIncValue Method

TnxDataset.GetAutoIncValue Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure GetAutoIncValue(out aValue: TnxWord32);
Parameters
Parameters | Description
out aValue: TnxWord32 | holds the highest AutoInc value after the method returns
Description

GetAutoincValue gets the last used value of the AutoInc field of this dataset.

this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.

See Also

SetAutoIncValue

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.GetBookmark Method

TnxDataset.GetBookmark Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetBookmark: TBookmark; override;
Description

see TDataSet.GetBookmark

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


GetBookmarkData Method

GetBookmarkData Method
TnxDataset Methods Send Feedback

This is the overview for the GetBookmarkData method overload.

Overload List
Name | Description
TnxDataset.GetBookmarkData (TnxRecordBuffer, Pointer) |
TnxDataset.GetBookmarkData (TnxRecordBuffer, TBookmark) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.GetBookmarkData Method (TnxRecordBuffer, Pointer)

TnxDataset.GetBookmarkData Method (TnxRecordBuffer, Pointer)
TnxDataset Class TnxDataset Members nxdb Namespace GetBookmarkData Method Send Feedback
Syntax
Delphi
procedure GetBookmarkData(aBuffer: TnxRecordBuffer; aData: Pointer); override;
Group

GetBookmarkData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, GetBookmarkData Method


TnxDataset.GetBookmarkData Method (TnxRecordBuffer, TBookmark)

TnxDataset.GetBookmarkData Method (TnxRecordBuffer, TBookmark)
TnxDataset Class TnxDataset Members nxdb Namespace GetBookmarkData Method Send Feedback
Syntax
Delphi
procedure GetBookmarkData(aBuffer: TnxRecordBuffer; aData: TBookmark); override; overload;
Group

GetBookmarkData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, GetBookmarkData Method


TnxDataset.GetBookmarkFlag Method

TnxDataset.GetBookmarkFlag Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetBookmarkFlag(aBuffer: TnxRecordBuffer): TBookmarkFlag; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetBookmarkStr Method

TnxDataset.GetBookmarkStr Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetBookmarkStr: TBookmarkStr; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetCanModify Method

TnxDataset.GetCanModify Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetCanModify: Boolean; override;
Description

info.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetCurrentRecord Method

TnxDataset.GetCurrentRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetCurrentRecord(aBuffer: TnxRecordBuffer): Boolean; override;
Description

see TDataSet.GetCurrentRecord

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetFieldClass Method

TnxDataset.GetFieldClass Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetFieldClass(FieldType: TFieldType): TFieldClass; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


GetFieldData Method

GetFieldData Method
TnxDataset Methods Send Feedback

This is the overview for the GetFieldData method overload.

Overload List
Name | Description
TnxDataset.GetFieldData (TField, Pointer) |
TnxDataset.GetFieldData (TField, TValueBuffer) | see TDataSet.GetFieldData
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.GetFieldData Method (TField, Pointer)

TnxDataset.GetFieldData Method (TField, Pointer)
TnxDataset Class TnxDataset Members nxdb Namespace GetFieldData Method Send Feedback
Syntax
Delphi
function GetFieldData(aField: TField; aBuffer: Pointer): Boolean; override;
Group

GetFieldData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, GetFieldData Method


TnxDataset.GetFieldData Method (TField, TValueBuffer)

TnxDataset.GetFieldData Method (TField, TValueBuffer)
TnxDataset Class TnxDataset Members nxdb Namespace GetFieldData Method Send Feedback
Syntax
Delphi
function GetFieldData(aField: TField; var aBuffer: TValueBuffer): Boolean; override; overload;
Description

see TDataSet.GetFieldData

Group

GetFieldData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, GetFieldData Method


TnxDataset.GetRecNo Method

TnxDataset.GetRecNo Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetRecNo: Integer; override;
Description

recno support.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetRecord Method

TnxDataset.GetRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetRecord(aBuffer: TnxRecordBuffer; aGetMode: TGetMode; aDoCheck: Boolean): TGetResult; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetRecordCount Method

TnxDataset.GetRecordCount Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetRecordCount: Integer; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetRecordSize Method

TnxDataset.GetRecordSize Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function GetRecordSize: Word; override;
Description

record buffer management.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.GetStreamList Method

TnxDataset.GetStreamList Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure GetStreamList(aStreams: TStrings);
Parameters
Parameters | Description
aStreams: TStrings | string list that will hold the names; must not be nil
Description

GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.

See Also

GetStreamList, WriteStream, ReadStream, DeleteStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.GotoCurrent Method

TnxDataset.GotoCurrent Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure GotoCurrent(aDataSet: TnxDataset); dynamic;
Parameters
Parameters | Description
aDataSet: TnxDataset | the dataset the current one is synchronized with
Description

GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InBatchAppend Method

TnxDataset.InBatchAppend Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
function InBatchAppend: Boolean;
Description

This function returns true if a Batch Append is open.

See Also

FlushBatchAppend, EndBatchAppend, BeginBatchAppend, BatchPost, InBatchAppend, CancelBatchAppend

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


InternalAddRecord Method

InternalAddRecord Method
TnxDataset Methods Send Feedback

This is the overview for the InternalAddRecord method overload.

Overload List
Name | Description
TnxDataset.InternalAddRecord (Pointer, Boolean) |
TnxDataset.InternalAddRecord (TnxRecordBuffer, Boolean) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.InternalAddRecord Method (Pointer, Boolean)

TnxDataset.InternalAddRecord Method (Pointer, Boolean)
TnxDataset Class TnxDataset Members nxdb Namespace InternalAddRecord Method Send Feedback
Syntax
Delphi
procedure InternalAddRecord(aBuffer: Pointer; aAppend: Boolean); override;
Group

InternalAddRecord Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, InternalAddRecord Method


TnxDataset.InternalAddRecord Method (TnxRecordBuffer, Boolean)

TnxDataset.InternalAddRecord Method (TnxRecordBuffer, Boolean)
TnxDataset Class TnxDataset Members nxdb Namespace InternalAddRecord Method Send Feedback
Syntax
Delphi
procedure InternalAddRecord(Buffer: TnxRecordBuffer; Append: Boolean); override; overload;
Group

InternalAddRecord Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, InternalAddRecord Method


TnxDataset.InternalCancel Method

TnxDataset.InternalCancel Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalCancel; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalClose Method

TnxDataset.InternalClose Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalClose; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalDelete Method

TnxDataset.InternalDelete Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalDelete; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalEdit Method

TnxDataset.InternalEdit Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalEdit; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalFirst Method

TnxDataset.InternalFirst Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalFirst; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


InternalGotoBookmark Method

InternalGotoBookmark Method
TnxDataset Methods Send Feedback

This is the overview for the InternalGotoBookmark method overload.

Overload List
Name | Description
TnxDataset.InternalGotoBookmark (TBookmark) |
TnxDataset.InternalGotoBookmark (TBookmarkOrPointer) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.InternalGotoBookmark Method (TBookmark)

TnxDataset.InternalGotoBookmark Method (TBookmark)
TnxDataset Class TnxDataset Members nxdb Namespace InternalGotoBookmark Method Send Feedback
Syntax
Delphi
procedure InternalGotoBookmark(aBookmark: TBookmark); override; overload;
Group

InternalGotoBookmark Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, InternalGotoBookmark Method


TnxDataset.InternalGotoBookmark Method (TBookmarkOrPointer)

TnxDataset.InternalGotoBookmark Method (TBookmarkOrPointer)
TnxDataset Class TnxDataset Members nxdb Namespace InternalGotoBookmark Method Send Feedback
Syntax
Delphi
procedure InternalGotoBookmark(aBookmark: TBookmarkOrPointer); override;
Group

InternalGotoBookmark Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, InternalGotoBookmark Method


TnxDataset.InternalHandleException Method

TnxDataset.InternalHandleException Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalHandleException; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalInitFieldDefs Method

TnxDataset.InternalInitFieldDefs Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalInitFieldDefs; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalInitRecord Method

TnxDataset.InternalInitRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalInitRecord(aBuffer: TnxRecordBuffer); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalLast Method

TnxDataset.InternalLast Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalLast; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalOpen Method

TnxDataset.InternalOpen Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalOpen; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalPost Method

TnxDataset.InternalPost Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalPost; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalPostAndEdit Method

TnxDataset.InternalPostAndEdit Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalPostAndEdit; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalPostImpl Method

TnxDataset.InternalPostImpl Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalPostImpl(aKeepLock: Boolean); virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.InternalSetToRecord Method

TnxDataset.InternalSetToRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure InternalSetToRecord(aBuffer: TnxRecordBuffer); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.IsCursorOpen Method

TnxDataset.IsCursorOpen Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function IsCursorOpen: Boolean; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.IsRecordLocked Method

TnxDataset.IsRecordLocked Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function IsRecordLocked: TnxLockPresent;
Description

Returns the current Record's lock status.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.IsSequenced Method

TnxDataset.IsSequenced Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function IsSequenced: Boolean; override;
Description

see TDataSet.IsSequenced

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.IsTableLocked Method

TnxDataset.IsTableLocked Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function IsTableLocked(aLockType: TnxLockType): TnxLockPresent;
Description

Returns the state of a lock of the certain type is active on the current table

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.KeyAsVariant Method

TnxDataset.KeyAsVariant Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function KeyAsVariant: Variant; virtual;
Description

Returns a key for the current record.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.Loaded Method

TnxDataset.Loaded Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.Locate Method

TnxDataset.Locate Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function Locate(const aKeyFields: string; const aKeyValues: Variant; aOptions: TLocateOptions): Boolean; override;
Description

see TDataSet.Locate

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.LockTable Method

TnxDataset.LockTable Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure LockTable(aLockType: TnxLockType);
Parameters
Parameters | Description
aLockType: TnxLockType | the type of lock you want to acquire
Description

LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table.

These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.

See Also

UnlockTable, UnlockTableAll

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.Lookup Method

TnxDataset.Lookup Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function Lookup(const aKeyFields: string; const aKeyValues: Variant; const aResultFields: string): Variant; override;
Description

see TDataSet.Lookup

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.Notification Method

TnxDataset.Notification Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure Notification(aComponent: TComponent; aOperation: TOperation); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.OpenCursor Method

TnxDataset.OpenCursor Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure OpenCursor(aInfoQuery: Boolean); override;
Description

open / close cursor

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.Post Method

TnxDataset.Post Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure Post; override;
Description

== virtual TDataSet methods == -- navigation

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PostAndEdit Method

TnxDataset.PostAndEdit Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure PostAndEdit; virtual;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSEndTransaction Method

TnxDataset.PSEndTransaction Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure PSEndTransaction(Commit: Boolean); override;
Description

see TDataset.PSEndTransaction

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


PSExecuteStatement Method

PSExecuteStatement Method
TnxDataset Methods Send Feedback

This is the overview for the PSExecuteStatement method overload.

Overload List
Name | Description
TnxDataset.PSExecuteStatement (string, TParams) | see TDataset.PSExecuteStatement
TnxDataset.PSExecuteStatement (string, TParams, Pointer) |
TnxDataset.PSExecuteStatement (string, TParams, TDataSet) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.PSExecuteStatement Method (string, TParams)

TnxDataset.PSExecuteStatement Method (string, TParams)
TnxDataset Class TnxDataset Members nxdb Namespace PSExecuteStatement Method Send Feedback
Syntax
Delphi
function PSExecuteStatement(const aSQL: string; aParams: TParams): Integer; override; overload;
Description

see TDataset.PSExecuteStatement

Group

PSExecuteStatement Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, PSExecuteStatement Method


TnxDataset.PSExecuteStatement Method (string, TParams, Pointer)

TnxDataset.PSExecuteStatement Method (string, TParams, Pointer)
TnxDataset Class TnxDataset Members nxdb Namespace PSExecuteStatement Method Send Feedback
Syntax
Delphi
function PSExecuteStatement(const aSQL: string; aParams: TParams; ResultSet: Pointer = nil): Integer; override; overload;
Group

PSExecuteStatement Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, PSExecuteStatement Method


TnxDataset.PSExecuteStatement Method (string, TParams, TDataSet)

TnxDataset.PSExecuteStatement Method (string, TParams, TDataSet)
TnxDataset Class TnxDataset Members nxdb Namespace PSExecuteStatement Method Send Feedback
Syntax
Delphi
function PSExecuteStatement(const aSQL: string; aParams: TParams; var ResultSet: TDataSet): Integer; override; overload;
Group

PSExecuteStatement Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, PSExecuteStatement Method


TnxDataset.PSGetQuoteChar Method

TnxDataset.PSGetQuoteChar Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function PSGetQuoteChar: string; override;
Description

see TDataset.PSGetQuoteChar

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSGetUpdateException Method

TnxDataset.PSGetUpdateException Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function PSGetUpdateException(E: Exception; Prev: EUpdateError): EUpdateError; override;
Description

see TDataset.PSGetUpdateException

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSInTransaction Method

TnxDataset.PSInTransaction Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function PSInTransaction: Boolean; override;
Description

see TDataset.PSInTransaction

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSIsSQLBased Method

TnxDataset.PSIsSQLBased Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function PSIsSQLBased: Boolean; override;
Description

see TDataset.PSIsSQLBased

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSIsSQLSupported Method

TnxDataset.PSIsSQLSupported Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
function PSIsSQLSupported: Boolean; override;
Description

see TDataset.PSIsSQLSupported

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSReset Method

TnxDataset.PSReset Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure PSReset; override;
Description

see TDataset.PSReset

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.PSStartTransaction Method

TnxDataset.PSStartTransaction Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure PSStartTransaction; override;
Description

see TDataset.PSStartTransaction

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.ReadStream Method

TnxDataset.ReadStream Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure ReadStream(const aName: string; aStream: TStream);
Parameters
Parameters | Description
const aName: string | Name of the Stream
aStream: TStream | the stream to read into; must not be nil
Description

Use this method to read a certain stream. It raises exception if not the stream is not found.

See Also

GetStreamList, WriteStream, ReadStream, DeleteStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.ReadStreamEx Method

TnxDataset.ReadStreamEx Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
function ReadStreamEx(const aName: string; aStream: TStream): TnxResult;
Parameters
Parameters | Description
const aName: string | Name of the Stream
aStream: TStream | the stream to read into; must not be nil
Returns

0 if all is ok, otherwise an error code

Description

Use this method to read a certain stream. It raises exception if not the stream is not found.

See Also

GetStreamList, WriteStream, ReadStream, DeleteStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.RecordCountAsync Method

TnxDataset.RecordCountAsync Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure RecordCountAsync(out aTaskInfo: TnxAbstractTaskInfo);
Parameters
Parameters | Description
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.

See Also

TnxAbstractTaskInfo, GetStatus

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.RefreshInternalCalcFields Method

TnxDataset.RefreshInternalCalcFields Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure RefreshInternalCalcFields(Buffer: TnxRecordBuffer); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.ResetBlockReadStream Method

TnxDataset.ResetBlockReadStream Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure ResetBlockReadStream;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetActive Method

TnxDataset.SetActive Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetActive(Value: Boolean); override;
Description

property access methods.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetAutoIncValue Method

TnxDataset.SetAutoIncValue Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure SetAutoIncValue(aValue: TnxWord32);
Parameters
Parameters | Description
aValue: TnxWord32 | the value you want to the AutoInc value to
Description

Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.

See Also

GetAutoIncValue

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.SetBlockReadSize Method

TnxDataset.SetBlockReadSize Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetBlockReadSize(Value: Integer); override;
Description

block read mode.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


SetBookmarkData Method

SetBookmarkData Method
TnxDataset Methods Send Feedback

This is the overview for the SetBookmarkData method overload.

Overload List
Name | Description
TnxDataset.SetBookmarkData (TnxRecordBuffer, Pointer) |
TnxDataset.SetBookmarkData (TnxRecordBuffer, TBookmark) | bookmarks.
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.SetBookmarkData Method (TnxRecordBuffer, Pointer)

TnxDataset.SetBookmarkData Method (TnxRecordBuffer, Pointer)
TnxDataset Class TnxDataset Members nxdb Namespace SetBookmarkData Method Send Feedback
Syntax
Delphi
procedure SetBookmarkData(aBuffer: TnxRecordBuffer; aData: Pointer); override;
Group

SetBookmarkData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, SetBookmarkData Method


TnxDataset.SetBookmarkData Method (TnxRecordBuffer, TBookmark)

TnxDataset.SetBookmarkData Method (TnxRecordBuffer, TBookmark)
TnxDataset Class TnxDataset Members nxdb Namespace SetBookmarkData Method Send Feedback
Syntax
Delphi
procedure SetBookmarkData(aBuffer: TnxRecordBuffer; aData: TBookmark); override; overload;
Description

bookmarks.

Group

SetBookmarkData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, SetBookmarkData Method


TnxDataset.SetBookmarkFlag Method

TnxDataset.SetBookmarkFlag Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetBookmarkFlag(aBuffer: TnxRecordBuffer; aValue: TBookmarkFlag); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


SetFieldData Method

SetFieldData Method
TnxDataset Methods Send Feedback

This is the overview for the SetFieldData method overload.

Overload List
Name | Description
TnxDataset.SetFieldData (TField, Pointer) |
TnxDataset.SetFieldData (TField, TValueBuffer) |
Group

TnxDataset Methods

Links
TnxDataset Methods


TnxDataset.SetFieldData Method (TField, Pointer)

TnxDataset.SetFieldData Method (TField, Pointer)
TnxDataset Class TnxDataset Members nxdb Namespace SetFieldData Method Send Feedback
Syntax
Delphi
procedure SetFieldData(aField: TField; aBuffer: Pointer); override;
Group

SetFieldData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, SetFieldData Method


TnxDataset.SetFieldData Method (TField, TValueBuffer)

TnxDataset.SetFieldData Method (TField, TValueBuffer)
TnxDataset Class TnxDataset Members nxdb Namespace SetFieldData Method Send Feedback
Syntax
Delphi
procedure SetFieldData(aField: TField; aBuffer: TValueBuffer); override; overload;
Group

SetFieldData Method

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, SetFieldData Method


TnxDataset.SetFiltered Method

TnxDataset.SetFiltered Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetFiltered(Value: Boolean); override;
Description

filter.

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetFilterOptions Method

TnxDataset.SetFilterOptions Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetFilterOptions(Value: TFilterOptions); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetFilterText Method

TnxDataset.SetFilterText Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetFilterText(const Value: string); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetName Method

TnxDataset.SetName Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetName(const NewName: TComponentName); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetOnFilterRecord Method

TnxDataset.SetOnFilterRecord Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetOnFilterRecord(const Value: TFilterRecordEvent); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.SetRecNo Method

TnxDataset.SetRecNo Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods Send Feedback
Syntax
Delphi
procedure SetRecNo(Value: Integer); override;
Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods


TnxDataset.UnlockTable Method

TnxDataset.UnlockTable Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure UnlockTable(aLockType: TnxLockType);
Parameters
Parameters | Description
aLockType: TnxLockType | the type of lock you want to release
Description

Remove the given lock from the dataset with this method.

See Also

LockTable, UnlockTableAll

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.UnlockTableAll Method

TnxDataset.UnlockTableAll Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure UnlockTableAll;
Description

UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.

See Also

LockTable, UnlockTable

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset.WriteStream Method

TnxDataset.WriteStream Method
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Methods See Also Send Feedback
Syntax
Delphi
procedure WriteStream(const aName: string; aStream: TStream);
Parameters
Parameters | Description
const aName: string | Name of the Stream
aStream: TStream | the stream to write
Description

This method stores aStream in the table and overwrites any existing stream of that name.

NEVER EVER OVERWRITE THE DICT STREAM!

See Also

GetStreamList, WriteStream, ReadStream, DeleteStream

Group

TnxDataset Methods

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Methods, See Also


TnxDataset Properties

TnxDataset Properties
TnxDataset Class Legend Protected Properties Public Properties Published Properties Send Feedback

The properties of the TnxDataset class are listed here.

Class

TnxDataset Class

Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxDataset Class, Legend, Protected Properties, Public Properties, Published Properties


TnxDataset._Dictionary Property

TnxDataset._Dictionary Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property _Dictionary: TnxDataDictionary;
Description

The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AbstractCursor Property

TnxDataset.AbstractCursor Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AbstractCursor: TnxAbstractCursor;
Description

This is a pointer to the current cursor of this dataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.ActiveDesigntime Property

TnxDataset.ActiveDesigntime Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property ActiveDesigntime: Boolean;
Description

Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.

See Also

ActiveRuntime

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.ActiveRuntime Property

TnxDataset.ActiveRuntime Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property ActiveRuntime: Boolean;
Description

Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.

See Also

ActiveDesigntime

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.AfterCancel Property

TnxDataset.AfterCancel Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterCancel;
Description

see TDataSet.AfterCancel.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterClose Property

TnxDataset.AfterClose Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterClose;
Description

see TDataSet.AfterClose.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterDelete Property

TnxDataset.AfterDelete Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterDelete;
Description

see TDataSet.AfterDelete

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterEdit Property

TnxDataset.AfterEdit Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterEdit;
Description

see TDataSet.AfterEdit

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterInsert Property

TnxDataset.AfterInsert Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterInsert;
Description

see TDataSet.AfterInsert

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterOpen Property

TnxDataset.AfterOpen Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterOpen;
Description

see TDataSet.AfterOpen

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterPost Property

TnxDataset.AfterPost Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterPost;
Description

see TDataSet.AfterPost

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterRefresh Property

TnxDataset.AfterRefresh Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterRefresh;
Description

see TDataSet.AfterRefresh

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AfterScroll Property

TnxDataset.AfterScroll Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AfterScroll;
Description

see TDataSet.AfterScroll

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AliasName Property

TnxDataset.AliasName Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AliasName: string;
Description

AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths!

Please not that Session must be assigned for this to work.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.AutoCalcFields Property

TnxDataset.AutoCalcFields Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property AutoCalcFields;
Description

see TDataSet.AutoCalcFields

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeCancel Property

TnxDataset.BeforeCancel Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeCancel;
Description

see TDataSet.BeforeCancel

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeClose Property

TnxDataset.BeforeClose Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeClose;
Description

see TDataSet.BeforeClose

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeDelete Property

TnxDataset.BeforeDelete Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeDelete;
Description

see TDataSet.BeforeDelete

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeEdit Property

TnxDataset.BeforeEdit Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeEdit;
Description

see TDataSet.BeforeEdit

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeInsert Property

TnxDataset.BeforeInsert Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeInsert;
Description

see TDataSet.BeforeInsert

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeOpen Property

TnxDataset.BeforeOpen Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeOpen;
Description

see TDataSet.BeforeOpen

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforePost Property

TnxDataset.BeforePost Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforePost;
Description

see TDataSet.BeforePost

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeRefresh Property

TnxDataset.BeforeRefresh Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeRefresh;
Description

see TDataSet.BeforeRefresh

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BeforeScroll Property

TnxDataset.BeforeScroll Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BeforeScroll;
Description

see TDataSet.BeforeScroll

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BlockReadOptions Property

TnxDataset.BlockReadOptions Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BlockReadOptions: TnxRecordGetBatchExOptions;
Description

Use BlockReadOptions to set how block/batch operations work.

If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads.

If gboBlob is true, blobs are processed in the batch modes.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.BlockReadSize Property

TnxDataset.BlockReadSize Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property BlockReadSize: Integer;
Description

This is BlockReadSize, a member of class TnxDataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Bof Property

TnxDataset.Bof Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Bof;
Description

This is Bof, a member of class TnxDataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Database Property

TnxDataset.Database Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Database: TnxDatabase;
Description

This is database the dataset is linked to. Either AliasName or Database must be set.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Eof Property

TnxDataset.Eof Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Eof;
Description

This is Eof, a member of class TnxDataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.FieldsDescriptor Property

TnxDataset.FieldsDescriptor Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property FieldsDescriptor: TnxFieldsDescriptor;
Description

Returns the Fields Descriptor of the current table.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Filter Property

TnxDataset.Filter Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property Filter;
Description

see TDataset.Filter

See Also

Filter, Filtered, FilterTimeout, OnServerFilterTimeout, FilterOptions

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.Filtered Property

TnxDataset.Filtered Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property Filtered;
Description

see TDataset.Filtered

See Also

Filter, Filtered, FilterTimeout, OnServerFilterTimeout, FilterOptions

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.FilterOptions Property

TnxDataset.FilterOptions Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property FilterOptions;
Description

see TDataset.FilterOptions

See Also

Filter, Filtered, FilterTimeout, OnServerFilterTimeout, FilterOptions

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.FilterResync Property

TnxDataset.FilterResync Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property FilterResync: boolean;
Description

When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.FilterTimeout Property

TnxDataset.FilterTimeout Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property FilterTimeout: TnxWord32;
Description

This is the timeout in ms for Filter operations.

See Also

Filter, Filtered, FilterTimeout, OnServerFilterTimeout, FilterOptions

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.FilterType Property

TnxDataset.FilterType Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property FilterType: TnxFilterType;
Description

The type of filter to use.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.FlipOrder Property

TnxDataset.FlipOrder Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property FlipOrder: Boolean;
Description

Flips the navigation order for normal navigation as well as calls to key lookups.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.LookupOptions Property

TnxDataset.LookupOptions Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property LookupOptions: TLocateOptions;
Description

These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnCalcFields Property

TnxDataset.OnCalcFields Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnCalcFields;
Description

see TDataSet.OnCalcFields

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnDeleteError Property

TnxDataset.OnDeleteError Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnDeleteError;
Description

see TDataSet.OnDeleteError

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnEditError Property

TnxDataset.OnEditError Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnEditError;
Description

see TDataSet.OnEditError

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnFilterRecord Property

TnxDataset.OnFilterRecord Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnFilterRecord;
Description

see TDataSet.OnFilterRecord

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnNewRecord Property

TnxDataset.OnNewRecord Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnNewRecord;
Description

see TDataSet.OnNewRecord

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.OnPostError Property

TnxDataset.OnPostError Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property OnPostError;
Description

see TDataSet.OnPostError

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Options Property

TnxDataset.Options Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Options: TnxDataSetOptions;
Description

The options of the current dataset

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Session Property

TnxDataset.Session Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Session: TnxBaseSession;
Description

This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.SimpleExpressionFilterClass Property

TnxDataset.SimpleExpressionFilterClass Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property SimpleExpressionFilterClass: TnxSimpleExpressionFilterDescriptorClass;
Description

The Filter class the dataset creates an instance of for each Filter evaluation set

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.SqlFilterClass Property

TnxDataset.SqlFilterClass Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property SqlFilterClass: TnxSqlFilterDescriptorClass;
Description

the Filter class the dataset creates an instance of for each Filter evaluation set

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.TableDescriptor Property

TnxDataset.TableDescriptor Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property TableDescriptor: TnxBaseTableDescriptor;
Description

Returns the Table Descriptor of the data dictionary.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset.Timeout Property

TnxDataset.Timeout Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties See Also Send Feedback
Syntax
Delphi
property Timeout: Integer;
Description

The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.

See Also

FilterTimeout

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties, See Also


TnxDataset.Version Property

TnxDataset.Version Property
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Properties Send Feedback
Syntax
Delphi
property Version: string;
Description

The version information for the current dataset.

Group

TnxDataset Properties

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Properties


TnxDataset Events

TnxDataset Events
TnxDataset Class Legend Published Events Send Feedback

The events of the TnxDataset class are listed here.

Class

TnxDataset Class

Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Links
TnxDataset Class, Legend, Published Events


TnxDataset.OnServerFilterTimeout Event

TnxDataset.OnServerFilterTimeout Event
TnxDataset Class TnxDataset Members nxdb Namespace TnxDataset Events See Also Send Feedback
Syntax
Delphi
property OnServerFilterTimeout: TnxServerFilterTimeoutEvent;
Description

The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.

See Also

Filter, Filtered, FilterTimeout, OnServerFilterTimeout, FilterOptions

Group

TnxDataset Events

Links
TnxDataset Class, TnxDataset Members, nxdb Namespace, TnxDataset Events, See Also


TnxIndexDataSet Class

TnxIndexDataSet Class
TnxIndexDataSet Fields TnxIndexDataSet Methods TnxIndexDataSet Properties TnxIndexDataSet Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxIndexDataSetnxdb_TnxIndexDataSet
Syntax
Delphi
TnxIndexDataSet = class(TnxDataset);
File

nxdb

Description

TnxIndexDataSet adds support for indexing to TnxDataset.

Group

Classes

Links
TnxIndexDataSet Fields, TnxIndexDataSet Methods, TnxIndexDataSet Properties, TnxIndexDataSet Members, nxdb, Classes


TnxIndexDataSet Members

TnxIndexDataSet Members
TnxIndexDataSet Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxIndexDataSet.

Class

TnxIndexDataSet Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
idDefaultIndex | This is idDefaultIndex, a member of class TnxIndexDataSet.
idDirectKeySetFields | This is idDirectKeySetFields, a member of class TnxIndexDataSet.
idFieldsIndex | current index.
idIndexDefs | private index management.
idIndexDirectKey | This is idIndexDirectKey, a member of class TnxIndexDataSet.
idIndexFieldMap | This is idIndexFieldMap, a member of class TnxIndexDataSet.
idIndexFieldMapNC | This is idIndexFieldMapNC, a member of class TnxIndexDataSet.
idIndexFieldNames | This is idIndexFieldNames, a member of class TnxIndexDataSet.
idIndexKeySize | This is idIndexKeySize, a member of class TnxIndexDataSet.
idIndexName | This is idIndexName, a member of class TnxIndexDataSet.
idKeyBuffer | This is idKeyBuffer, a member of class TnxIndexDataSet.
idKeyBuffers | This is idKeyBuffers, a member of class TnxIndexDataSet.
idKeyBufferSize | key buffers.
idLookupCaseIns | This is idLookupCaseIns, a member of class TnxIndexDataSet.
idLookupCursorID | This is idLookupCursorID, a member of class TnxIndexDataSet.
idLookupFieldNames | lookup/locate.
idMasterLink | master/detail support.
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent | == virtual TDataSet methods == info.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
DoOnNewRecord | record access/update.
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange | master/detail support.
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | locate/lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer | buffer management.
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | internal functions == init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateOrdinalPartialMatchRecord | This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | open/close.
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | info.
GetDataSource | master/detail support.
GetFieldClass |
GetIsIndexField |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
idAddIndexDefsToIndicesDesc |
idAddIndexDefToIndicesDesc |
idAfterGetRecordForKey |
idBeforeGetRecordForKey |
idCheckSetKeyMode | key managment.
idFieldDefsStored | == property access methods == FieldDefs.
idGetIndexField | IndexFields.
idGetIndexFieldCount | IndexFieldCount.
idGetIndexFieldNames | IndexFieldNames.
idGetIndexName | IndexName.
idGetKeyBuffer |
idGetKeyExclusive | KeyExclusive.
idGetKeyFieldCount | KeyFieldCount.
idGetKeyPartialLen | KeyPartialLen.
idGetLookupCursor |
idGetMasterFields | master/detail support.
idGetMasterSource |
idGetRecordForKey |
idHasActiveRange |
idHasActiveRangeEnd |
idHasActiveRangeStart | range managment.
idIndexDefsStored |
idInitIndexMap |
idInitKeyBuffer |
idMapsToIndex |
idMasterChanged |
idMasterDisabled |
idPostKeyBuffer |
idRefIndexSetFields | ref index support
idResetCursorRange |
idResolveIndexName |
idSetCursorRange |
idSetIndex | index managment.
idSetIndexDefs | IndexDefs.
idSetIndexField |
idSetIndexFieldNames |
idSetIndexName |
idSetKeyBuffer |
idSetKeyExclusive |
idSetKeyFieldCount |
idSetKeyFields | This is the overview for the idSetKeyFields method overload.
idSetKeyPartialLen |
idSetLinkRange |
idSetMasterFields |
idSetMasterSource |
idSwitchToIndex |
idTokenIndexSetFields | token index support
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSGetDefaultOrder | IProviderSupport.
PSGetIndexDefs |
PSGetKeyFields |
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
UpdateIndexDefs | index managment.
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
ApplyRange | see tTable.ApplyRange. TnxIndexDataSet
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
Cancel | see tDataSet.Cancel.
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CancelRange | see tTable.CancelRange.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EditKey | see tTable.EditKey.
EditRangeEnd | see tTable.EditRangeEnd.
EditRangeStart | see tTable.EditRangeStart.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FindKey | This is the overview for the FindKey method overload.
FindNearest | This is the overview for the FindNearest method overload.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetIndexNames | see tTable.GetIndexNames.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
GotoKey | see tTable.GotoKey.
GotoNearest | see tTable.GotoNearest
GotoNearestBackward | see tTable.GotoNearest
HasActiveRange |
HasActiveRangeEnd |
HasActiveRangeStart |
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
Post | see tDataSet.Post.
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
SetKey | see tTable.FindNearest.
SetRange | This is the overview for the SetRange method overload.
SetRangeEnd | see tTable.SetRangeEnd.
SetRangeShared | This is the overview for the SetRangeShared method overload.
SetRangeSimple | Sets a normal simple Range (as opposed to SetRangeShared).
SetRangeStart | see tTable.SetRangeStart.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
ActiveIndexName | This is ActiveIndexName, a member of class TnxIndexDataSet.
FieldDefs | additional properties.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
IndexDefs | This is IndexDefs, a member of class TnxIndexDataSet.
IndexFieldCount | This is IndexFieldCount, a member of class TnxIndexDataSet.
IndexFieldNames | This is IndexFieldNames, a member of class TnxIndexDataSet.
IndexFields | This is IndexFields, a member of class TnxIndexDataSet.
IndexName | This is IndexName, a member of class TnxIndexDataSet.
KeyExclusive | This is KeyExclusive, a member of class TnxIndexDataSet.
KeyFieldCount | This is KeyFieldCount, a member of class TnxIndexDataSet.
KeyPartialLen | This is KeyPartialLen, a member of class TnxIndexDataSet.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxIndexDataSet Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxIndexDataSet.Create Constructor

TnxIndexDataSet.Create Constructor
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxIndexDataSet Class

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Class


TnxIndexDataSet.Destroy Destructor

TnxIndexDataSet.Destroy Destructor
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxIndexDataSet Class

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Class


TnxIndexDataSet Fields

TnxIndexDataSet Fields
TnxIndexDataSet Class Legend Protected Fields Send Feedback

The fields of the TnxIndexDataSet class are listed here.

Class

TnxIndexDataSet Class

Protected Fields
Name | Description
idDefaultIndex | This is idDefaultIndex, a member of class TnxIndexDataSet.
idDirectKeySetFields | This is idDirectKeySetFields, a member of class TnxIndexDataSet.
idFieldsIndex | current index.
idIndexDefs | private index management.
idIndexDirectKey | This is idIndexDirectKey, a member of class TnxIndexDataSet.
idIndexFieldMap | This is idIndexFieldMap, a member of class TnxIndexDataSet.
idIndexFieldMapNC | This is idIndexFieldMapNC, a member of class TnxIndexDataSet.
idIndexFieldNames | This is idIndexFieldNames, a member of class TnxIndexDataSet.
idIndexKeySize | This is idIndexKeySize, a member of class TnxIndexDataSet.
idIndexName | This is idIndexName, a member of class TnxIndexDataSet.
idKeyBuffer | This is idKeyBuffer, a member of class TnxIndexDataSet.
idKeyBuffers | This is idKeyBuffers, a member of class TnxIndexDataSet.
idKeyBufferSize | key buffers.
idLookupCaseIns | This is idLookupCaseIns, a member of class TnxIndexDataSet.
idLookupCursorID | This is idLookupCursorID, a member of class TnxIndexDataSet.
idLookupFieldNames | lookup/locate.
idMasterLink | master/detail support.
Links
TnxIndexDataSet Class, Legend, Protected Fields


TnxIndexDataSet.idDefaultIndex Field

TnxIndexDataSet.idDefaultIndex Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idDefaultIndex: Boolean;
Description

This is idDefaultIndex, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idDirectKeySetFields Field

TnxIndexDataSet.idDirectKeySetFields Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idDirectKeySetFields: TnxDirectKeySetFieldsMethod;
Description

This is idDirectKeySetFields, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idFieldsIndex Field

TnxIndexDataSet.idFieldsIndex Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idFieldsIndex: Boolean;
Description

current index.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexDefs Field

TnxIndexDataSet.idIndexDefs Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexDefs: TnxIndexDefs;
Description

private index management.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexDirectKey Field

TnxIndexDataSet.idIndexDirectKey Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexDirectKey: Boolean;
Description

This is idIndexDirectKey, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexFieldMap Field

TnxIndexDataSet.idIndexFieldMap Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexFieldMap: array of Integer;
Description

This is idIndexFieldMap, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexFieldMapNC Field

TnxIndexDataSet.idIndexFieldMapNC Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexFieldMapNC: array of Boolean;
Description

This is idIndexFieldMapNC, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexFieldNames Field

TnxIndexDataSet.idIndexFieldNames Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexFieldNames: string;
Description

This is idIndexFieldNames, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexKeySize Field

TnxIndexDataSet.idIndexKeySize Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexKeySize: Integer;
Description

This is idIndexKeySize, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idIndexName Field

TnxIndexDataSet.idIndexName Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idIndexName: string;
Description

This is idIndexName, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idKeyBuffer Field

TnxIndexDataSet.idKeyBuffer Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idKeyBuffer: PnxKeyBuffer;
Description

This is idKeyBuffer, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idKeyBuffers Field

TnxIndexDataSet.idKeyBuffers Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idKeyBuffers: array[TnxKeyIndex] of PnxKeyBuffer;
Description

This is idKeyBuffers, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idKeyBufferSize Field

TnxIndexDataSet.idKeyBufferSize Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idKeyBufferSize: Integer;
Description

key buffers.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idLookupCaseIns Field

TnxIndexDataSet.idLookupCaseIns Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idLookupCaseIns: Boolean;
Description

This is idLookupCaseIns, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idLookupCursorID Field

TnxIndexDataSet.idLookupCursorID Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idLookupCursorID: TnxAbstractCursor;
Description

This is idLookupCursorID, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idLookupFieldNames Field

TnxIndexDataSet.idLookupFieldNames Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idLookupFieldNames: string;
Description

lookup/locate.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet.idMasterLink Field

TnxIndexDataSet.idMasterLink Field
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Fields Send Feedback
Syntax
Delphi
idMasterLink: TMasterDataLink;
Description

master/detail support.

Group

TnxIndexDataSet Fields

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Fields


TnxIndexDataSet Methods

TnxIndexDataSet Methods
TnxIndexDataSet Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxIndexDataSet class are listed here.

Class

TnxIndexDataSet Class

Protected Methods
Name | Description
DataEvent | == virtual TDataSet methods == info.
DoOnNewRecord | record access/update.
dsApplyMasterRange | master/detail support.
dsDestroyLookupCursor | locate/lookup support.
dsFreeKeyBuffers |
dsGetActiveKeyBuffer | buffer management.
dsInitBookmarkSize | internal functions == init.
dsInitKeyBuffers | key buffers.
dsLocateOrdinalPartialMatchRecord | This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.
dsLocateRecord |
GetDataSource | master/detail support.
GetIsIndexField |
idAddIndexDefsToIndicesDesc |
idAddIndexDefToIndicesDesc |
idAfterGetRecordForKey |
idBeforeGetRecordForKey |
idCheckSetKeyMode | key managment.
idFieldDefsStored | == property access methods == FieldDefs.
idGetIndexField | IndexFields.
idGetIndexFieldCount | IndexFieldCount.
idGetIndexFieldNames | IndexFieldNames.
idGetIndexName | IndexName.
idGetKeyBuffer |
idGetKeyExclusive | KeyExclusive.
idGetKeyFieldCount | KeyFieldCount.
idGetKeyPartialLen | KeyPartialLen.
idGetLookupCursor |
idGetMasterFields | master/detail support.
idGetMasterSource |
idGetRecordForKey |
idHasActiveRange |
idHasActiveRangeEnd |
idHasActiveRangeStart | range managment.
idIndexDefsStored |
idInitIndexMap |
idInitKeyBuffer |
idMapsToIndex |
idMasterChanged |
idMasterDisabled |
idPostKeyBuffer |
idRefIndexSetFields | ref index support
idResetCursorRange |
idResolveIndexName |
idSetCursorRange |
idSetIndex | index managment.
idSetIndexDefs | IndexDefs.
idSetIndexField |
idSetIndexFieldNames |
idSetIndexName |
idSetKeyBuffer |
idSetKeyExclusive |
idSetKeyFieldCount |
idSetKeyFields | This is the overview for the idSetKeyFields method overload.
idSetKeyPartialLen |
idSetLinkRange |
idSetMasterFields |
idSetMasterSource |
idSwitchToIndex |
idTokenIndexSetFields | token index support
InternalClose |
PSGetDefaultOrder | IProviderSupport.
PSGetIndexDefs |
PSGetKeyFields |
PSSetParams |
SetFieldData | This is the overview for the SetFieldData method overload.
UpdateIndexDefs | index managment.
Public Methods
Name | Description
ApplyRange | see tTable.ApplyRange. TnxIndexDataSet
Cancel | see tDataSet.Cancel.
CancelRange | see tTable.CancelRange.
EditKey | see tTable.EditKey.
EditRangeEnd | see tTable.EditRangeEnd.
EditRangeStart | see tTable.EditRangeStart.
FindKey | This is the overview for the FindKey method overload.
FindNearest | This is the overview for the FindNearest method overload.
GetIndexNames | see tTable.GetIndexNames.
GotoKey | see tTable.GotoKey.
GotoNearest | see tTable.GotoNearest
GotoNearestBackward | see tTable.GotoNearest
HasActiveRange |
HasActiveRangeEnd |
HasActiveRangeStart |
Post | see tDataSet.Post.
SetKey | see tTable.FindNearest.
SetRange | This is the overview for the SetRange method overload.
SetRangeEnd | see tTable.SetRangeEnd.
SetRangeShared | This is the overview for the SetRangeShared method overload.
SetRangeSimple | Sets a normal simple Range (as opposed to SetRangeShared).
SetRangeStart | see tTable.SetRangeStart.
Links
TnxIndexDataSet Class, Legend, Protected Methods, Public Methods


TnxIndexDataSet.ApplyRange Method

TnxIndexDataSet.ApplyRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure ApplyRange;
Description

see tTable.ApplyRange.

TnxIndexDataSet

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.Cancel Method

TnxIndexDataSet.Cancel Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure Cancel; override;
Description

see tDataSet.Cancel.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.CancelRange Method

TnxIndexDataSet.CancelRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure CancelRange;
Description

see tTable.CancelRange.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.DataEvent Method

TnxIndexDataSet.DataEvent Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure DataEvent(aEvent: TDataEvent; aInfo: TnxNativeInt); override;
Description

== virtual TDataSet methods == info.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.DoOnNewRecord Method

TnxIndexDataSet.DoOnNewRecord Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure DoOnNewRecord; override;
Description

record access/update.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsApplyMasterRange Method

TnxIndexDataSet.dsApplyMasterRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure dsApplyMasterRange; override;
Description

master/detail support.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsDestroyLookupCursor Method

TnxIndexDataSet.dsDestroyLookupCursor Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure dsDestroyLookupCursor; override;
Description

locate/lookup support.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsFreeKeyBuffers Method

TnxIndexDataSet.dsFreeKeyBuffers Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure dsFreeKeyBuffers; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsGetActiveKeyBuffer Method

TnxIndexDataSet.dsGetActiveKeyBuffer Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function dsGetActiveKeyBuffer(var aBuffer: TnxRecordBuffer): Boolean; override;
Description

buffer management.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsInitBookmarkSize Method

TnxIndexDataSet.dsInitBookmarkSize Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure dsInitBookmarkSize; override;
Description

internal functions == init.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsInitKeyBuffers Method

TnxIndexDataSet.dsInitKeyBuffers Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure dsInitKeyBuffers; override;
Description

key buffers.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsLocateOrdinalPartialMatchRecord Method

TnxIndexDataSet.dsLocateOrdinalPartialMatchRecord Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function dsLocateOrdinalPartialMatchRecord(Buffer: TnxRecordBuffer; Fields: TnxFieldList; LookupCursor: TnxAbstractCursor; const aKeyValues: Variant): TnxResult;
Description

This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.dsLocateRecord Method

TnxIndexDataSet.dsLocateRecord Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function dsLocateRecord(const aKeyFields: string; const aKeyValues: Variant; aOptions: TLocateOptions; aSyncCursor: Boolean): Boolean; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.EditKey Method

TnxIndexDataSet.EditKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure EditKey;
Description

see tTable.EditKey.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.EditRangeEnd Method

TnxIndexDataSet.EditRangeEnd Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure EditRangeEnd;
Description

see tTable.EditRangeEnd.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.EditRangeStart Method

TnxIndexDataSet.EditRangeStart Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure EditRangeStart;
Description

see tTable.EditRangeStart.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


FindKey Method

FindKey Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the FindKey method overload.

Overload List
Name | Description
TnxIndexDataSet.FindKey (array of const) | see tTable.FindKey.
TnxIndexDataSet.FindKey (array of const, TnxSetKeyOptions) | see tTable.FindKey.
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.FindKey Method (array of const)

TnxIndexDataSet.FindKey Method (array of const)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace FindKey Method Send Feedback
Syntax
Delphi
function FindKey(const aKeyValues: array of const): Boolean; overload;
Description

see tTable.FindKey.

Group

FindKey Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, FindKey Method


TnxIndexDataSet.FindKey Method (array of const, TnxSetKeyOptions)

TnxIndexDataSet.FindKey Method (array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace FindKey Method Send Feedback
Syntax
Delphi
function FindKey(const aKeyValues: array of const; aOptions: TnxSetKeyOptions): Boolean; overload;
Description

see tTable.FindKey.

Group

FindKey Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, FindKey Method


FindNearest Method

FindNearest Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the FindNearest method overload.

Overload List
Name | Description
TnxIndexDataSet.FindNearest (array of const) | see tTable.FindNearest.
TnxIndexDataSet.FindNearest (array of const, TnxSetKeyOptions) | see tTable.FindNearest.
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.FindNearest Method (array of const)

TnxIndexDataSet.FindNearest Method (array of const)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace FindNearest Method Send Feedback
Syntax
Delphi
procedure FindNearest(const aKeyValues: array of const); overload;
Description

see tTable.FindNearest.

Group

FindNearest Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, FindNearest Method


TnxIndexDataSet.FindNearest Method (array of const, TnxSetKeyOptions)

TnxIndexDataSet.FindNearest Method (array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace FindNearest Method Send Feedback
Syntax
Delphi
procedure FindNearest(const aKeyValues: array of const; aOptions: TnxSetKeyOptions); overload;
Description

see tTable.FindNearest.

Group

FindNearest Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, FindNearest Method


TnxIndexDataSet.GetDataSource Method

TnxIndexDataSet.GetDataSource Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function GetDataSource: TDataSource; override;
Description

master/detail support.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.GetIndexNames Method

TnxIndexDataSet.GetIndexNames Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure GetIndexNames(aList: TStrings);
Description

see tTable.GetIndexNames.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.GetIsIndexField Method

TnxIndexDataSet.GetIsIndexField Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function GetIsIndexField(Field: TField): Boolean; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.GotoKey Method

TnxIndexDataSet.GotoKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function GotoKey: Boolean;
Description

see tTable.GotoKey.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.GotoNearest Method

TnxIndexDataSet.GotoNearest Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure GotoNearest;
Description

see tTable.GotoNearest

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.GotoNearestBackward Method

TnxIndexDataSet.GotoNearestBackward Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure GotoNearestBackward;
Description

see tTable.GotoNearest

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.HasActiveRange Method

TnxIndexDataSet.HasActiveRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function HasActiveRange: Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.HasActiveRangeEnd Method

TnxIndexDataSet.HasActiveRangeEnd Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function HasActiveRangeEnd: Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.HasActiveRangeStart Method

TnxIndexDataSet.HasActiveRangeStart Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function HasActiveRangeStart: Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idAddIndexDefsToIndicesDesc Method

TnxIndexDataSet.idAddIndexDefsToIndicesDesc Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idAddIndexDefsToIndicesDesc(aIndexDefs: TIndexDefs; aIndices: TnxMainIndicesDescriptor);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idAddIndexDefToIndicesDesc Method

TnxIndexDataSet.idAddIndexDefToIndicesDesc Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idAddIndexDefToIndicesDesc(aIndexDef: TIndexDef; aIndices: TnxMainIndicesDescriptor);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idAfterGetRecordForKey Method

TnxIndexDataSet.idAfterGetRecordForKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idAfterGetRecordForKey; virtual;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idBeforeGetRecordForKey Method

TnxIndexDataSet.idBeforeGetRecordForKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idBeforeGetRecordForKey; virtual;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idCheckSetKeyMode Method

TnxIndexDataSet.idCheckSetKeyMode Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idCheckSetKeyMode;
Description

key managment.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idFieldDefsStored Method

TnxIndexDataSet.idFieldDefsStored Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idFieldDefsStored: Boolean; virtual;
Description

== property access methods == FieldDefs.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetIndexField Method

TnxIndexDataSet.idGetIndexField Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetIndexField(aInx: Integer): TField;
Description

IndexFields.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetIndexFieldCount Method

TnxIndexDataSet.idGetIndexFieldCount Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetIndexFieldCount: Integer;
Description

IndexFieldCount.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetIndexFieldNames Method

TnxIndexDataSet.idGetIndexFieldNames Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetIndexFieldNames: string;
Description

IndexFieldNames.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetIndexName Method

TnxIndexDataSet.idGetIndexName Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetIndexName: string;
Description

IndexName.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetKeyBuffer Method

TnxIndexDataSet.idGetKeyBuffer Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetKeyBuffer(aKeyIndex: TnxKeyIndex): PnxKeyBuffer;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetKeyExclusive Method

TnxIndexDataSet.idGetKeyExclusive Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetKeyExclusive: Boolean;
Description

KeyExclusive.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetKeyFieldCount Method

TnxIndexDataSet.idGetKeyFieldCount Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetKeyFieldCount: Integer;
Description

KeyFieldCount.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetKeyPartialLen Method

TnxIndexDataSet.idGetKeyPartialLen Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetKeyPartialLen: Integer;
Description

KeyPartialLen.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetLookupCursor Method

TnxIndexDataSet.idGetLookupCursor Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetLookupCursor(const aFieldNames: string; aFields: TnxFieldList; aCaseInsensitive: Boolean): TnxAbstractCursor;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetMasterFields Method

TnxIndexDataSet.idGetMasterFields Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetMasterFields: string;
Description

master/detail support.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetMasterSource Method

TnxIndexDataSet.idGetMasterSource Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetMasterSource: TDataSource;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idGetRecordForKey Method

TnxIndexDataSet.idGetRecordForKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idGetRecordForKey(aCursor: TnxAbstractCursor; aFields: Integer; aPartialLength: Integer; aDirectKey: Boolean; aInBuffer: Pointer; aOutBuffer: Pointer): TnxResult;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idHasActiveRange Method

TnxIndexDataSet.idHasActiveRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idHasActiveRange: Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idHasActiveRangeEnd Method

TnxIndexDataSet.idHasActiveRangeEnd Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idHasActiveRangeEnd: Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idHasActiveRangeStart Method

TnxIndexDataSet.idHasActiveRangeStart Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idHasActiveRangeStart: Boolean;
Description

range managment.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idIndexDefsStored Method

TnxIndexDataSet.idIndexDefsStored Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idIndexDefsStored: Boolean; virtual;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idInitIndexMap Method

TnxIndexDataSet.idInitIndexMap Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idInitIndexMap;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idInitKeyBuffer Method

TnxIndexDataSet.idInitKeyBuffer Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idInitKeyBuffer(aBuffer: PnxKeyBuffer): PnxKeyBuffer;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idMapsToIndex Method

TnxIndexDataSet.idMapsToIndex Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idMapsToIndex(aFields: TnxFieldList; aCaseInsensitive: Boolean): Boolean;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idMasterChanged Method

TnxIndexDataSet.idMasterChanged Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idMasterChanged(Sender: TObject);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idMasterDisabled Method

TnxIndexDataSet.idMasterDisabled Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idMasterDisabled(Sender: TObject);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idPostKeyBuffer Method

TnxIndexDataSet.idPostKeyBuffer Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idPostKeyBuffer(aCommit: Boolean);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idRefIndexSetFields Method

TnxIndexDataSet.idRefIndexSetFields Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idRefIndexSetFields(const aValues1: array of const; const aValues2: array of const; aOptions: TnxSetKeyOptions);
Description

ref index support

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idResetCursorRange Method

TnxIndexDataSet.idResetCursorRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idResetCursorRange: Boolean; virtual;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idResolveIndexName Method

TnxIndexDataSet.idResolveIndexName Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idResolveIndexName(const aValue: string; aFieldsIndex: Boolean): string;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetCursorRange Method

TnxIndexDataSet.idSetCursorRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function idSetCursorRange: Boolean; virtual;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetIndex Method

TnxIndexDataSet.idSetIndex Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetIndex(const aValue: string; aFieldsIndex: Boolean);
Description

index managment.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetIndexDefs Method

TnxIndexDataSet.idSetIndexDefs Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetIndexDefs(Value: TIndexDefs);
Description

IndexDefs.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetIndexField Method

TnxIndexDataSet.idSetIndexField Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetIndexField(aInx: Integer; const aValue: TField);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetIndexFieldNames Method

TnxIndexDataSet.idSetIndexFieldNames Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetIndexFieldNames(const aValue: string);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetIndexName Method

TnxIndexDataSet.idSetIndexName Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetIndexName(const aValue: string);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetKeyBuffer Method

TnxIndexDataSet.idSetKeyBuffer Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetKeyBuffer(aKeyIndex: TnxKeyIndex; aClear: Boolean);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetKeyExclusive Method

TnxIndexDataSet.idSetKeyExclusive Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetKeyExclusive(const aValue: Boolean);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetKeyFieldCount Method

TnxIndexDataSet.idSetKeyFieldCount Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetKeyFieldCount(const aValue: Integer);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


idSetKeyFields Method

idSetKeyFields Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the idSetKeyFields method overload.

Overload List
Name | Description
TnxIndexDataSet.idSetKeyFields (TnxKeyIndex, array of const, array of const, TnxSetKeyOptions) |
TnxIndexDataSet.idSetKeyFields (TnxKeyIndex, array of const, TnxSetKeyOptions) |
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.idSetKeyFields Method (TnxKeyIndex, array of const, TnxSetKeyOptions)

TnxIndexDataSet.idSetKeyFields Method (TnxKeyIndex, array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace idSetKeyFields Method Send Feedback
Syntax
Delphi
procedure idSetKeyFields(aKeyIndex: TnxKeyIndex; const aValues: array of const; aOptions: TnxSetKeyOptions); overload;
Group

idSetKeyFields Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, idSetKeyFields Method


TnxIndexDataSet.idSetKeyFields Method (TnxKeyIndex, array of const, array of const, TnxSetKeyOptions)

TnxIndexDataSet.idSetKeyFields Method (TnxKeyIndex, array of const, array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace idSetKeyFields Method Send Feedback
Syntax
Delphi
procedure idSetKeyFields(aKeyIndex: TnxKeyIndex; const aValues1: array of const; const aValues2: array of const; aOptions: TnxSetKeyOptions); virtual; overload;
Group

idSetKeyFields Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, idSetKeyFields Method


TnxIndexDataSet.idSetKeyPartialLen Method

TnxIndexDataSet.idSetKeyPartialLen Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetKeyPartialLen(const aValue: Integer);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetLinkRange Method

TnxIndexDataSet.idSetLinkRange Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetLinkRange(aMasterFields: TnxFieldList);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetMasterFields Method

TnxIndexDataSet.idSetMasterFields Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetMasterFields(const aValue: string);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSetMasterSource Method

TnxIndexDataSet.idSetMasterSource Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSetMasterSource(const aValue: TDataSource);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idSwitchToIndex Method

TnxIndexDataSet.idSwitchToIndex Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idSwitchToIndex(const aIndexName: string);
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.idTokenIndexSetFields Method

TnxIndexDataSet.idTokenIndexSetFields Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure idTokenIndexSetFields(const aValues1: array of const; const aValues2: array of const; aOptions: TnxSetKeyOptions);
Description

token index support

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.InternalClose Method

TnxIndexDataSet.InternalClose Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure InternalClose; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.Post Method

TnxIndexDataSet.Post Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure Post; override;
Description

see tDataSet.Post.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.PSGetDefaultOrder Method

TnxIndexDataSet.PSGetDefaultOrder Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function PSGetDefaultOrder: TIndexDef; override;
Description

IProviderSupport.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.PSGetIndexDefs Method

TnxIndexDataSet.PSGetIndexDefs Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function PSGetIndexDefs(IndexTypes: TIndexOptions): TIndexDefs; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.PSGetKeyFields Method

TnxIndexDataSet.PSGetKeyFields Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
function PSGetKeyFields: string; override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.PSSetParams Method

TnxIndexDataSet.PSSetParams Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure PSSetParams(aParams: TParams); override;
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


SetFieldData Method

SetFieldData Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the SetFieldData method overload.

Overload List
Name | Description
TnxIndexDataSet.SetFieldData (TField, Pointer) |
TnxIndexDataSet.SetFieldData (TField, TValueBuffer) | field access.
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.SetFieldData Method (TField, Pointer)

TnxIndexDataSet.SetFieldData Method (TField, Pointer)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetFieldData Method Send Feedback
Syntax
Delphi
procedure SetFieldData(aField: TField; aBuffer: Pointer); override;
Group

SetFieldData Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetFieldData Method


TnxIndexDataSet.SetFieldData Method (TField, TValueBuffer)

TnxIndexDataSet.SetFieldData Method (TField, TValueBuffer)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetFieldData Method Send Feedback
Syntax
Delphi
procedure SetFieldData(aField: TField; aBuffer: TValueBuffer); override;
Description

field access.

Group

SetFieldData Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetFieldData Method


TnxIndexDataSet.SetKey Method

TnxIndexDataSet.SetKey Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure SetKey;
Description

see tTable.FindNearest.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


SetRange Method

SetRange Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the SetRange method overload.

Overload List
Name | Description
TnxIndexDataSet.SetRange (array of const, array of const) | see tTable.SetRange.
TnxIndexDataSet.SetRange (array of const, array of const, TnxSetKeyOptions) | see tTable.SetRange.
TnxIndexDataSet.SetRange (array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions) | see tTable.SetRange.
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.SetRange Method (array of const, array of const)

TnxIndexDataSet.SetRange Method (array of const, array of const)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetRange Method Send Feedback
Syntax
Delphi
procedure SetRange(const aStartValues: array of const; const aEndValues: array of const); overload;
Description

see tTable.SetRange.

Group

SetRange Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetRange Method


TnxIndexDataSet.SetRange Method (array of const, array of const, TnxSetKeyOptions)

TnxIndexDataSet.SetRange Method (array of const, array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetRange Method Send Feedback
Syntax
Delphi
procedure SetRange(const aStartValues: array of const; const aEndValues: array of const; aOptions: TnxSetKeyOptions); overload;
Description

see tTable.SetRange.

Group

SetRange Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetRange Method


TnxIndexDataSet.SetRange Method (array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions)

TnxIndexDataSet.SetRange Method (array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetRange Method Send Feedback
Syntax
Delphi
procedure SetRange(const aStartValues: array of const; const aEndValues: array of const; aStartOptions: TnxSetKeyOptions; aEndOptions: TnxSetKeyOptions); overload;
Description

see tTable.SetRange.

Group

SetRange Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetRange Method


TnxIndexDataSet.SetRangeEnd Method

TnxIndexDataSet.SetRangeEnd Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure SetRangeEnd;
Description

see tTable.SetRangeEnd.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


SetRangeShared Method

SetRangeShared Method
TnxIndexDataSet Methods Send Feedback

This is the overview for the SetRangeShared method overload.

Overload List
Name | Description
TnxIndexDataSet.SetRangeShared (array of const, array of const, array of const, TnxSetKeyOptions) | ???
TnxIndexDataSet.SetRangeShared (array of const, array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions) | ???
Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Methods


TnxIndexDataSet.SetRangeShared Method (array of const, array of const, array of const, TnxSetKeyOptions)

TnxIndexDataSet.SetRangeShared Method (array of const, array of const, array of const, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetRangeShared Method Send Feedback
Syntax
Delphi
procedure SetRangeShared(const aSharedValue: array of const; const aStartValues: array of const; const aEndValues: array of const; aOptions: TnxSetKeyOptions = []); overload;
Description

???

Group

SetRangeShared Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetRangeShared Method


TnxIndexDataSet.SetRangeShared Method (array of const, array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions)

TnxIndexDataSet.SetRangeShared Method (array of const, array of const, array of const, TnxSetKeyOptions, TnxSetKeyOptions)
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace SetRangeShared Method Send Feedback
Syntax
Delphi
procedure SetRangeShared(const aSharedValue: array of const; const aStartValues: array of const; const aEndValues: array of const; aStartOptions: TnxSetKeyOptions; aEndOptions: TnxSetKeyOptions); overload;
Description

???

Group

SetRangeShared Method

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, SetRangeShared Method


TnxIndexDataSet.SetRangeSimple Method

TnxIndexDataSet.SetRangeSimple Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure SetRangeSimple(const aValue: array of const; aOptions: TnxSetKeyOptions = []); overload;
Description

Sets a normal simple Range (as opposed to SetRangeShared).

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.SetRangeStart Method

TnxIndexDataSet.SetRangeStart Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure SetRangeStart;
Description

see tTable.SetRangeStart.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet.UpdateIndexDefs Method

TnxIndexDataSet.UpdateIndexDefs Method
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Methods Send Feedback
Syntax
Delphi
procedure UpdateIndexDefs; override;
Description

index managment.

Group

TnxIndexDataSet Methods

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Methods


TnxIndexDataSet Properties

TnxIndexDataSet Properties
TnxIndexDataSet Class Legend Public Properties Send Feedback

The properties of the TnxIndexDataSet class are listed here.

Class

TnxIndexDataSet Class

Public Properties
Name | Description
ActiveIndexName | This is ActiveIndexName, a member of class TnxIndexDataSet.
FieldDefs | additional properties.
IndexDefs | This is IndexDefs, a member of class TnxIndexDataSet.
IndexFieldCount | This is IndexFieldCount, a member of class TnxIndexDataSet.
IndexFieldNames | This is IndexFieldNames, a member of class TnxIndexDataSet.
IndexFields | This is IndexFields, a member of class TnxIndexDataSet.
IndexName | This is IndexName, a member of class TnxIndexDataSet.
KeyExclusive | This is KeyExclusive, a member of class TnxIndexDataSet.
KeyFieldCount | This is KeyFieldCount, a member of class TnxIndexDataSet.
KeyPartialLen | This is KeyPartialLen, a member of class TnxIndexDataSet.
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
Links
TnxIndexDataSet Class, Legend, Public Properties


TnxIndexDataSet.ActiveIndexName Property

TnxIndexDataSet.ActiveIndexName Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property ActiveIndexName: string;
Description

This is ActiveIndexName, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.FieldDefs Property

TnxIndexDataSet.FieldDefs Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property FieldDefs;
Description

additional properties.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.IndexDefs Property

TnxIndexDataSet.IndexDefs Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property IndexDefs: TIndexDefs;
Description

This is IndexDefs, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.IndexFieldCount Property

TnxIndexDataSet.IndexFieldCount Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property IndexFieldCount: Integer;
Description

This is IndexFieldCount, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.IndexFieldNames Property

TnxIndexDataSet.IndexFieldNames Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property IndexFieldNames: string;
Description

This is IndexFieldNames, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.IndexFields Property

TnxIndexDataSet.IndexFields Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property IndexFields [aIndex: Integer]: TField;
Description

This is IndexFields, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.IndexName Property

TnxIndexDataSet.IndexName Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property IndexName: string;
Description

This is IndexName, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.KeyExclusive Property

TnxIndexDataSet.KeyExclusive Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property KeyExclusive: Boolean;
Description

This is KeyExclusive, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.KeyFieldCount Property

TnxIndexDataSet.KeyFieldCount Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property KeyFieldCount: Integer;
Description

This is KeyFieldCount, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.KeyPartialLen Property

TnxIndexDataSet.KeyPartialLen Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property KeyPartialLen: Integer;
Description

This is KeyPartialLen, a member of class TnxIndexDataSet.

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.MasterFields Property

TnxIndexDataSet.MasterFields Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property MasterFields: string;
Description

see tTable.MasterFields

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDataSet.MasterSource Property

TnxIndexDataSet.MasterSource Property
TnxIndexDataSet Class TnxIndexDataSet Members nxdb Namespace TnxIndexDataSet Properties Send Feedback
Syntax
Delphi
property MasterSource: TDataSource;
Description

see tTable.MasterSource

Group

TnxIndexDataSet Properties

Links
TnxIndexDataSet Class, TnxIndexDataSet Members, nxdb Namespace, TnxIndexDataSet Properties


TnxIndexDef Class

TnxIndexDef Class
TnxIndexDef Properties TnxIndexDef Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxIndexDef
Syntax
Delphi
TnxIndexDef = class(TIndexDef);
File

nxdb

Description

This is class nxdb.TnxIndexDef.

Group

Classes

Links
TnxIndexDef Properties, TnxIndexDef Members, nxdb, Classes


TnxIndexDef Members

TnxIndexDef Members
TnxIndexDef Class Legend Public Properties Send Feedback

The following tables list the members exposed by TnxIndexDef.

Class

TnxIndexDef Class

Public Properties
Name | Description
FilterExpression | This is FilterExpression, a member of class TnxIndexDef.
FilterType | This is FilterType, a member of class TnxIndexDef.
Links
TnxIndexDef Class, Legend, Public Properties


TnxIndexDef Properties

TnxIndexDef Properties
TnxIndexDef Class Legend Public Properties Send Feedback

The properties of the TnxIndexDef class are listed here.

Class

TnxIndexDef Class

Public Properties
Name | Description
FilterExpression | This is FilterExpression, a member of class TnxIndexDef.
FilterType | This is FilterType, a member of class TnxIndexDef.
Links
TnxIndexDef Class, Legend, Public Properties


TnxIndexDef.FilterExpression Property

TnxIndexDef.FilterExpression Property
TnxIndexDef Class TnxIndexDef Members nxdb Namespace TnxIndexDef Properties Send Feedback
Syntax
Delphi
property FilterExpression: string;
Description

This is FilterExpression, a member of class TnxIndexDef.

Group

TnxIndexDef Properties

Links
TnxIndexDef Class, TnxIndexDef Members, nxdb Namespace, TnxIndexDef Properties


TnxIndexDef.FilterType Property

TnxIndexDef.FilterType Property
TnxIndexDef Class TnxIndexDef Members nxdb Namespace TnxIndexDef Properties Send Feedback
Syntax
Delphi
property FilterType: TnxFilterType;
Description

This is FilterType, a member of class TnxIndexDef.

Group

TnxIndexDef Properties

Links
TnxIndexDef Class, TnxIndexDef Members, nxdb Namespace, TnxIndexDef Properties


TnxIndexDefs Class

TnxIndexDefs Class
TnxIndexDefs Methods TnxIndexDefs Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxIndexDefs
Syntax
Delphi
TnxIndexDefs = class(TIndexDefs);
File

nxdb

Description

This is class nxdb.TnxIndexDefs.

Group

Classes

Links
TnxIndexDefs Methods, TnxIndexDefs Members, nxdb, Classes


TnxIndexDefs Members

TnxIndexDefs Members
TnxIndexDefs Class Legend Protected Methods Send Feedback

The following tables list the members exposed by TnxIndexDefs.

Class

TnxIndexDefs Class

Protected Methods
Name | Description
GetIndexDefClass | TnxIndexDefs
Links
TnxIndexDefs Class, Legend, Protected Methods


TnxIndexDefs Methods

TnxIndexDefs Methods
TnxIndexDefs Class Legend Protected Methods Send Feedback

The methods of the TnxIndexDefs class are listed here.

Class

TnxIndexDefs Class

Protected Methods
Name | Description
GetIndexDefClass | TnxIndexDefs
Links
TnxIndexDefs Class, Legend, Protected Methods


TnxIndexDefs.GetIndexDefClass Method

TnxIndexDefs.GetIndexDefClass Method
TnxIndexDefs Class TnxIndexDefs Members nxdb Namespace TnxIndexDefs Methods Send Feedback
Syntax
Delphi
function GetIndexDefClass: TIndexDefClass; override;
Description

TnxIndexDefs

Group

TnxIndexDefs Methods

Links
TnxIndexDefs Class, TnxIndexDefs Members, nxdb Namespace, TnxIndexDefs Methods


TnxKeyAsVariantField Class

TnxKeyAsVariantField Class
TnxKeyAsVariantField Methods TnxKeyAsVariantField Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxKeyAsVariantField
Syntax
Delphi
TnxKeyAsVariantField = class(TVariantField);
File

nxdb

Description

Field class that can correctly get a nx internal keyvalue as variant.

Group

Classes

Links
TnxKeyAsVariantField Methods, TnxKeyAsVariantField Members, nxdb, Classes


TnxKeyAsVariantField Members

TnxKeyAsVariantField Members
TnxKeyAsVariantField Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxKeyAsVariantField.

Class

TnxKeyAsVariantField Class

Protected Methods
Name | Description
GetAsString |
GetAsVariant |
GetAsWideString |
SetVarValue |
Public Methods
Name | Description
Create | constructor TnxKeyAsVariantField
Links
TnxKeyAsVariantField Class, Legend, Protected Methods, Public Methods


TnxKeyAsVariantField.Create Constructor

TnxKeyAsVariantField.Create Constructor
TnxKeyAsVariantField Class TnxKeyAsVariantField Members nxdb Namespace TnxKeyAsVariantField Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor

TnxKeyAsVariantField

Class

TnxKeyAsVariantField Class

Links
TnxKeyAsVariantField Class, TnxKeyAsVariantField Members, nxdb Namespace, TnxKeyAsVariantField Class


TnxKeyAsVariantField Methods

TnxKeyAsVariantField Methods
TnxKeyAsVariantField Class Legend Protected Methods Send Feedback

The methods of the TnxKeyAsVariantField class are listed here.

Class

TnxKeyAsVariantField Class

Protected Methods
Name | Description
GetAsString |
GetAsVariant |
GetAsWideString |
SetVarValue |
Links
TnxKeyAsVariantField Class, Legend, Protected Methods


TnxKeyAsVariantField.GetAsString Method

TnxKeyAsVariantField.GetAsString Method
TnxKeyAsVariantField Class TnxKeyAsVariantField Members nxdb Namespace TnxKeyAsVariantField Methods Send Feedback
Syntax
Delphi
function GetAsString: string; override;
Group

TnxKeyAsVariantField Methods

Links
TnxKeyAsVariantField Class, TnxKeyAsVariantField Members, nxdb Namespace, TnxKeyAsVariantField Methods


TnxKeyAsVariantField.GetAsVariant Method

TnxKeyAsVariantField.GetAsVariant Method
TnxKeyAsVariantField Class TnxKeyAsVariantField Members nxdb Namespace TnxKeyAsVariantField Methods Send Feedback
Syntax
Delphi
function GetAsVariant: Variant; override;
Group

TnxKeyAsVariantField Methods

Links
TnxKeyAsVariantField Class, TnxKeyAsVariantField Members, nxdb Namespace, TnxKeyAsVariantField Methods


TnxKeyAsVariantField.GetAsWideString Method

TnxKeyAsVariantField.GetAsWideString Method
TnxKeyAsVariantField Class TnxKeyAsVariantField Members nxdb Namespace TnxKeyAsVariantField Methods Send Feedback
Syntax
Delphi
function GetAsWideString: UnicodeString; override;
Group

TnxKeyAsVariantField Methods

Links
TnxKeyAsVariantField Class, TnxKeyAsVariantField Members, nxdb Namespace, TnxKeyAsVariantField Methods


TnxKeyAsVariantField.SetVarValue Method

TnxKeyAsVariantField.SetVarValue Method
TnxKeyAsVariantField Class TnxKeyAsVariantField Members nxdb Namespace TnxKeyAsVariantField Methods Send Feedback
Syntax
Delphi
procedure SetVarValue(const Value: Variant); override;
Group

TnxKeyAsVariantField Methods

Links
TnxKeyAsVariantField Class, TnxKeyAsVariantField Members, nxdb Namespace, TnxKeyAsVariantField Methods


TnxLargeintField Class

TnxLargeintField Class
TnxLargeintField Methods TnxLargeintField Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxLargeintField
Syntax
Delphi
TnxLargeintField = class(TLargeintField);
File

nxdb

Description

This is class nxdb.TnxLargeintField.

Group

Classes

Links
TnxLargeintField Methods, TnxLargeintField Members, nxdb, Classes


TnxLargeintField Members

TnxLargeintField Members
TnxLargeintField Class Legend Protected Methods Send Feedback

The following tables list the members exposed by TnxLargeintField.

Class

TnxLargeintField Class

Protected Methods
Name | Description
GetAsBCD | TnxLargeintField
SetAsBCD |
Links
TnxLargeintField Class, Legend, Protected Methods


TnxLargeintField Methods

TnxLargeintField Methods
TnxLargeintField Class Legend Protected Methods Send Feedback

The methods of the TnxLargeintField class are listed here.

Class

TnxLargeintField Class

Protected Methods
Name | Description
GetAsBCD | TnxLargeintField
SetAsBCD |
Links
TnxLargeintField Class, Legend, Protected Methods


TnxLargeintField.GetAsBCD Method

TnxLargeintField.GetAsBCD Method
TnxLargeintField Class TnxLargeintField Members nxdb Namespace TnxLargeintField Methods Send Feedback
Syntax
Delphi
function GetAsBCD: TBcd; override;
Description

TnxLargeintField

Group

TnxLargeintField Methods

Links
TnxLargeintField Class, TnxLargeintField Members, nxdb Namespace, TnxLargeintField Methods


TnxLargeintField.SetAsBCD Method

TnxLargeintField.SetAsBCD Method
TnxLargeintField Class TnxLargeintField Members nxdb Namespace TnxLargeintField Methods Send Feedback
Syntax
Delphi
procedure SetAsBCD(const Value: TBcd); override;
Group

TnxLargeintField Methods

Links
TnxLargeintField Class, TnxLargeintField Members, nxdb Namespace, TnxLargeintField Methods


TnxMemoBlobStream Class

TnxMemoBlobStream Class
TnxMemoBlobStream Methods TnxMemoBlobStream Members nxdb Classes See Also Send Feedback
Class Hierarchy
nxdb_TnxMemoBlobStreamnxdb_TnxMemoBlobStream
Syntax
Delphi
TnxMemoBlobStream = class(TnxBaseBlobStream);
File

nxdb

Description

This class is used to access memo blobs if Transliterate is true.

Never create instances directly! Always use TnxDataSet.CreateBlobStream, which will create the right type of blob stream based on the state of the dataset.

The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.

See Also

TnxDataSet.CreateBlobStream TnxBaseBlobStream TnxBlobStream TnxBlockModeBlobStream

Group

Classes

Links
TnxMemoBlobStream Methods, TnxMemoBlobStream Members, nxdb, Classes, See Also


TnxMemoBlobStream Members

TnxMemoBlobStream Members
TnxMemoBlobStream Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMemoBlobStream.

Class

TnxMemoBlobStream Class

Protected Fields
Name | Description
bbsDataset | This is bbsDataset, a member of class TnxBaseBlobStream.
bbsDataSetNext | This is bbsDataSetNext, a member of class TnxBaseBlobStream.
bbsDataSetPrev | This is bbsDataSetPrev, a member of class TnxBaseBlobStream.
bbsField | private
bbsFieldNo | This is bbsFieldNo, a member of class TnxBaseBlobStream.
bbsMode | This is bbsMode, a member of class TnxBaseBlobStream.
Protected Methods
Name | Description
bbsAddToDataSet | TnxBaseBlobStream
bbsCheck |
bbsRemoveFromDataSet |
Create | constructor. TnxMemoBlobStream
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Destroy | destructor.
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxMemoBlobStream Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxMemoBlobStream.Create Constructor

TnxMemoBlobStream.Create Constructor
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Class Send Feedback
Syntax
Delphi
constructor Create(aField: TBlobField; aMode: TBlobStreamMode; aInnerStream: TnxBaseBlobStream); reintroduce;
Description

constructor.

TnxMemoBlobStream

Class

TnxMemoBlobStream Class

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Class


TnxMemoBlobStream.Destroy Destructor

TnxMemoBlobStream.Destroy Destructor
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxMemoBlobStream Class

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Class


TnxMemoBlobStream Methods

TnxMemoBlobStream Methods
TnxMemoBlobStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMemoBlobStream class are listed here.

Class

TnxMemoBlobStream Class

Protected Methods
Name | Description
SetSize | This is the overview for the SetSize method overload.
Public Methods
Name | Description
Read | With this method you can read a number of bytes of the blob data.
Seek | Seek sets the current position in the blob stream.
Truncate | This method truncates the blob data at the current position.
Write | Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.
Links
TnxMemoBlobStream Class, Legend, Protected Methods, Public Methods


TnxMemoBlobStream.Read Method

TnxMemoBlobStream.Read Method
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
var aBuffer | variable to store the read bytes
aCount: Integer | number of bytes to read
Description

With this method you can read a number of bytes of the blob data.

Group

TnxMemoBlobStream Methods

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Methods


TnxMemoBlobStream.Seek Method

TnxMemoBlobStream.Seek Method
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Integer; aOrigin: Word): Integer; override;
Parameters
Parameters | Description
aOffset: Integer | the offset in bytes to move the pointer
aOrigin: Word | the origin of the aOffset
Description

Seek sets the current position in the blob stream.

Group

TnxMemoBlobStream Methods

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Methods


SetSize Method

SetSize Method
TnxMemoBlobStream Methods Send Feedback

This is the overview for the SetSize method overload.

Overload List
Name | Description
TnxMemoBlobStream.SetSize (Int64) |
TnxMemoBlobStream.SetSize (Longint) | This is SetSize, a member of class TnxMemoBlobStream.
Group

TnxMemoBlobStream Methods

Links
TnxMemoBlobStream Methods


TnxMemoBlobStream.SetSize Method (Int64)

TnxMemoBlobStream.SetSize Method (Int64)
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(const NewSize: Int64); override; overload;
Group

SetSize Method

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, SetSize Method


TnxMemoBlobStream.SetSize Method (Longint)

TnxMemoBlobStream.SetSize Method (Longint)
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace SetSize Method Send Feedback
Syntax
Delphi
procedure SetSize(NewSize: Longint); override; overload;
Description

This is SetSize, a member of class TnxMemoBlobStream.

Group

SetSize Method

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, SetSize Method


TnxMemoBlobStream.Truncate Method

TnxMemoBlobStream.Truncate Method
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Methods Send Feedback
Syntax
Delphi
procedure Truncate; override;
Description

This method truncates the blob data at the current position.

Group

TnxMemoBlobStream Methods

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Methods


TnxMemoBlobStream.Write Method

TnxMemoBlobStream.Write Method
TnxMemoBlobStream Class TnxMemoBlobStream Members nxdb Namespace TnxMemoBlobStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Parameters
Parameters | Description
const aBuffer | data to be written
aCount: Integer | number of bytes to write
Description

Use Write to write a number of bytes to the blob at the current position. Take care to not accidentally overwrite data by not positioning with Seek first.

Group

TnxMemoBlobStream Methods

Links
TnxMemoBlobStream Class, TnxMemoBlobStream Members, nxdb Namespace, TnxMemoBlobStream Methods


TnxMemoField Class

TnxMemoField Class
TnxMemoField Fields TnxMemoField Methods TnxMemoField Properties TnxMemoField Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxMemoField
Syntax
Delphi
TnxMemoField = class(TMemoField);
File

nxdb

Description

Extended field class for memo fields.

Group

Classes

Links
TnxMemoField Fields, TnxMemoField Methods, TnxMemoField Properties, TnxMemoField Members, nxdb, Classes


TnxMemoField Members

TnxMemoField Members
TnxMemoField Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMemoField.

Class

TnxMemoField Class

Protected Fields
Name | Description
mfCodePage | This is mfCodePage, a member of class TnxMemoField.
mfIsWide | private
Protected Methods
Name | Description
Bind | TnxMemoField
Public Methods
Name | Description
GetAsAnsiString |
GetAsString |
GetAsVariant |
GetAsWideString |
SetAsAnsiString |
SetAsString |
SetAsWideString |
SetVarValue |
Public Properties
Name | Description
AsWideString | Returns the Value as UnicodeString.
Links
TnxMemoField Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMemoField Fields

TnxMemoField Fields
TnxMemoField Class Legend Protected Fields Send Feedback

The fields of the TnxMemoField class are listed here.

Class

TnxMemoField Class

Protected Fields
Name | Description
mfCodePage | This is mfCodePage, a member of class TnxMemoField.
mfIsWide | private
Links
TnxMemoField Class, Legend, Protected Fields


TnxMemoField.mfCodePage Field

TnxMemoField.mfCodePage Field
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Fields Send Feedback
Syntax
Delphi
mfCodePage: Word;
Description

This is mfCodePage, a member of class TnxMemoField.

Group

TnxMemoField Fields

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Fields


TnxMemoField.mfIsWide Field

TnxMemoField.mfIsWide Field
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Fields Send Feedback
Syntax
Delphi
mfIsWide: Boolean;
Description

private

Group

TnxMemoField Fields

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Fields


TnxMemoField Methods

TnxMemoField Methods
TnxMemoField Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMemoField class are listed here.

Class

TnxMemoField Class

Protected Methods
Name | Description
Bind | TnxMemoField
Public Methods
Name | Description
GetAsAnsiString |
GetAsString |
GetAsVariant |
GetAsWideString |
SetAsAnsiString |
SetAsString |
SetAsWideString |
SetVarValue |
Links
TnxMemoField Class, Legend, Protected Methods, Public Methods


TnxMemoField.Bind Method

TnxMemoField.Bind Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
procedure Bind(Binding: Boolean); override;
Description

TnxMemoField

Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.GetAsAnsiString Method

TnxMemoField.GetAsAnsiString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
function GetAsAnsiString: AnsiString; override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.GetAsString Method

TnxMemoField.GetAsString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
function GetAsString: string; override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.GetAsVariant Method

TnxMemoField.GetAsVariant Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
function GetAsVariant: Variant; override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.GetAsWideString Method

TnxMemoField.GetAsWideString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
function GetAsWideString: UnicodeString; override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.SetAsAnsiString Method

TnxMemoField.SetAsAnsiString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
procedure SetAsAnsiString(const Value: AnsiString); override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.SetAsString Method

TnxMemoField.SetAsString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
procedure SetAsString(const Value: string); override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.SetAsWideString Method

TnxMemoField.SetAsWideString Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
procedure SetAsWideString(const Value: UnicodeString); override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField.SetVarValue Method

TnxMemoField.SetVarValue Method
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Methods Send Feedback
Syntax
Delphi
procedure SetVarValue(const Value: Variant); override;
Group

TnxMemoField Methods

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Methods


TnxMemoField Properties

TnxMemoField Properties
TnxMemoField Class Legend Public Properties Send Feedback

The properties of the TnxMemoField class are listed here.

Class

TnxMemoField Class

Public Properties
Name | Description
AsWideString | Returns the Value as UnicodeString.
Links
TnxMemoField Class, Legend, Public Properties


TnxMemoField.AsWideString Property

TnxMemoField.AsWideString Property
TnxMemoField Class TnxMemoField Members nxdb Namespace TnxMemoField Properties Send Feedback
Syntax
Delphi
property AsWideString: UnicodeString;
Description

Returns the Value as UnicodeString.

Group

TnxMemoField Properties

Links
TnxMemoField Class, TnxMemoField Members, nxdb Namespace, TnxMemoField Properties


TnxMemoryStreamHacker Class

TnxMemoryStreamHacker Class
nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxMemoryStreamHackernxdb_TnxMemoryStreamHackernxdb_TnxMemoryStreamHacker
Syntax
Delphi
TnxMemoryStreamHacker = class(TnxMemoryStream);
File

nxdb

Group

Classes

Links
nxdb, Classes


TnxMemTable Class

TnxMemTable Class
TnxMemTable Fields TnxMemTable Methods TnxMemTable Properties TnxMemTable Events TnxMemTable Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxMemTablenxdb_TnxMemTablenxdb_TnxMemTable
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxMemTable = class(TnxIndexDataSet);
File

nxdb

Description

A memory table.

Group

Classes

Links
TnxMemTable Fields, TnxMemTable Methods, TnxMemTable Properties, TnxMemTable Events, TnxMemTable Members, nxdb, Classes


TnxMemTable Members

TnxMemTable Members
TnxMemTable Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxMemTable.

Class

TnxMemTable Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
idDefaultIndex | This is idDefaultIndex, a member of class TnxIndexDataSet.
idDirectKeySetFields | This is idDirectKeySetFields, a member of class TnxIndexDataSet.
idFieldsIndex | current index.
idIndexDefs | private index management.
idIndexDirectKey | This is idIndexDirectKey, a member of class TnxIndexDataSet.
idIndexFieldMap | This is idIndexFieldMap, a member of class TnxIndexDataSet.
idIndexFieldMapNC | This is idIndexFieldMapNC, a member of class TnxIndexDataSet.
idIndexFieldNames | This is idIndexFieldNames, a member of class TnxIndexDataSet.
idIndexKeySize | This is idIndexKeySize, a member of class TnxIndexDataSet.
idIndexName | This is idIndexName, a member of class TnxIndexDataSet.
idKeyBuffer | This is idKeyBuffer, a member of class TnxIndexDataSet.
idKeyBuffers | This is idKeyBuffers, a member of class TnxIndexDataSet.
idKeyBufferSize | key buffers.
idLookupCaseIns | This is idLookupCaseIns, a member of class TnxIndexDataSet.
idLookupCursorID | This is idLookupCursorID, a member of class TnxIndexDataSet.
idLookupFieldNames | lookup/locate.
idMasterLink | master/detail support.
mtOnCreateTable | This is mtOnCreateTable, a member of class TnxMemTable.
mtStoreDefs | This is mtStoreDefs, a member of class TnxMemTable.
mtTableName | This is mtTableName, a member of class TnxMemTable.
mtUsedTableName | private
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DataEvent | == virtual TDataSet methods == info.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
DoOnNewRecord | record access/update.
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsApplyMasterRange | master/detail support.
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDestroyLookupCursor | locate/lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetActiveKeyBuffer | buffer management.
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitBookmarkSize | internal functions == init.
dsInitKeyBuffers | key buffers.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateOrdinalPartialMatchRecord | This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.
dsLocateRecord |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | internal functions == open/close.
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | == virtual TDataSet methods == -- info
GetDataSource | master/detail support.
GetFieldClass |
GetIsIndexField |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
idAddIndexDefsToIndicesDesc |
idAddIndexDefToIndicesDesc |
idAfterGetRecordForKey |
idBeforeGetRecordForKey |
idCheckSetKeyMode | key managment.
idFieldDefsStored | property access methods == StoreDefs.
idGetIndexField | IndexFields.
idGetIndexFieldCount | IndexFieldCount.
idGetIndexFieldNames | IndexFieldNames.
idGetIndexName | IndexName.
idGetKeyBuffer |
idGetKeyExclusive | KeyExclusive.
idGetKeyFieldCount | KeyFieldCount.
idGetKeyPartialLen | KeyPartialLen.
idGetLookupCursor |
idGetMasterFields | master/detail support.
idGetMasterSource |
idGetRecordForKey |
idHasActiveRange |
idHasActiveRangeEnd |
idHasActiveRangeStart | range managment.
idIndexDefsStored |
idInitIndexMap |
idInitKeyBuffer |
idMapsToIndex |
idMasterChanged |
idMasterDisabled |
idPostKeyBuffer |
idRefIndexSetFields | ref index support
idResetCursorRange |
idResolveIndexName |
idSetCursorRange |
idSetIndex | index managment.
idSetIndexDefs | IndexDefs.
idSetIndexField |
idSetIndexFieldNames |
idSetIndexName |
idSetKeyBuffer |
idSetKeyExclusive |
idSetKeyFieldCount |
idSetKeyFields | This is the overview for the idSetKeyFields method overload.
idSetKeyPartialLen |
idSetLinkRange |
idSetMasterFields |
idSetMasterSource |
idSwitchToIndex |
idTokenIndexSetFields | token index support
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
mtSetTableName | property access methods == StoreDefs. TnxMemTable
Notification |
OpenCursor | open / close cursor
PSGetDefaultOrder | IProviderSupport.
PSGetIndexDefs |
PSGetKeyFields |
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
UpdateIndexDefs | index managment.
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
ApplyRange | see tTable.ApplyRange. TnxIndexDataSet
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
Cancel | see tDataSet.Cancel.
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CancelRange | see tTable.CancelRange.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EditKey | see tTable.EditKey.
EditRangeEnd | see tTable.EditRangeEnd.
EditRangeStart | see tTable.EditRangeStart.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FindKey | This is the overview for the FindKey method overload.
FindNearest | This is the overview for the FindNearest method overload.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetIndexNames | see tTable.GetIndexNames.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
GotoKey | see tTable.GotoKey.
GotoNearest | see tTable.GotoNearest
GotoNearestBackward | see tTable.GotoNearest
HasActiveRange |
HasActiveRangeEnd |
HasActiveRangeStart |
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
Post | == virtual TDataSet methods == -- navigation
Post | see tDataSet.Post.
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
SetKey | see tTable.FindNearest.
SetRange | This is the overview for the SetRange method overload.
SetRangeEnd | see tTable.SetRangeEnd.
SetRangeShared | This is the overview for the SetRangeShared method overload.
SetRangeSimple | Sets a normal simple Range (as opposed to SetRangeShared).
SetRangeStart | see tTable.SetRangeStart.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
ActiveIndexName | This is ActiveIndexName, a member of class TnxIndexDataSet.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnCreateTable | This event is fired before the table is create. It allows modification of the data dictionary that will be used to create the table.
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
FieldDefs | see tTable.FieldDefs
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
IndexDefs | see tTable.IndexDefs.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
StoreDefs | see tTable.StoreDefs
TableName | Optional. When specified the name must be unique in the database. If a name is specified it is possible to access the mem table using other TnxTable and TnxQuery components connected to the same database under this name while the mem table is active.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
UsedTableName | Only valid while the table is active. If a TableName was specified UsedTableName will be equal to TableName. Otherwise it will contain the unique name that was created for this mem table. Other TnxTable and TnxQuery components connected to the same database will be able to access the mem table under this name while it is active.
Version | The version information for the current dataset.
Links
TnxMemTable Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxMemTable.Create Constructor

TnxMemTable.Create Constructor
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxMemTable Class

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Class


TnxMemTable.Destroy Destructor

TnxMemTable.Destroy Destructor
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxMemTable Class

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Class


TnxMemTable Fields

TnxMemTable Fields
TnxMemTable Class Legend Protected Fields Send Feedback

The fields of the TnxMemTable class are listed here.

Class

TnxMemTable Class

Protected Fields
Name | Description
mtOnCreateTable | This is mtOnCreateTable, a member of class TnxMemTable.
mtStoreDefs | This is mtStoreDefs, a member of class TnxMemTable.
mtTableName | This is mtTableName, a member of class TnxMemTable.
mtUsedTableName | private
Links
TnxMemTable Class, Legend, Protected Fields


TnxMemTable.mtOnCreateTable Field

TnxMemTable.mtOnCreateTable Field
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Fields Send Feedback
Syntax
Delphi
mtOnCreateTable: TnxCreateTableEvent;
Description

This is mtOnCreateTable, a member of class TnxMemTable.

Group

TnxMemTable Fields

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Fields


TnxMemTable.mtStoreDefs Field

TnxMemTable.mtStoreDefs Field
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Fields Send Feedback
Syntax
Delphi
mtStoreDefs: Boolean;
Description

This is mtStoreDefs, a member of class TnxMemTable.

Group

TnxMemTable Fields

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Fields


TnxMemTable.mtTableName Field

TnxMemTable.mtTableName Field
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Fields Send Feedback
Syntax
Delphi
mtTableName: string;
Description

This is mtTableName, a member of class TnxMemTable.

Group

TnxMemTable Fields

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Fields


TnxMemTable.mtUsedTableName Field

TnxMemTable.mtUsedTableName Field
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Fields Send Feedback
Syntax
Delphi
mtUsedTableName: string;
Description

private

Group

TnxMemTable Fields

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Fields


TnxMemTable Methods

TnxMemTable Methods
TnxMemTable Class Legend Protected Methods Send Feedback

The methods of the TnxMemTable class are listed here.

Class

TnxMemTable Class

Protected Methods
Name | Description
dsCloseCursorID |
dsOpenCursorID | internal functions == open/close.
GetCanModify | == virtual TDataSet methods == -- info
idFieldDefsStored | property access methods == StoreDefs.
idIndexDefsStored |
mtSetTableName | property access methods == StoreDefs. TnxMemTable
Links
TnxMemTable Class, Legend, Protected Methods


TnxMemTable.dsCloseCursorID Method

TnxMemTable.dsCloseCursorID Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
procedure dsCloseCursorID; override;
Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable.dsOpenCursorID Method

TnxMemTable.dsOpenCursorID Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
procedure dsOpenCursorID; override;
Description

internal functions == open/close.

Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable.GetCanModify Method

TnxMemTable.GetCanModify Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
function GetCanModify: Boolean; override;
Description

== virtual TDataSet methods == -- info

Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable.idFieldDefsStored Method

TnxMemTable.idFieldDefsStored Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
function idFieldDefsStored: Boolean; override;
Description

property access methods == StoreDefs.

Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable.idIndexDefsStored Method

TnxMemTable.idIndexDefsStored Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
function idIndexDefsStored: Boolean; override;
Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable.mtSetTableName Method

TnxMemTable.mtSetTableName Method
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Methods Send Feedback
Syntax
Delphi
procedure mtSetTableName(const Value: string);
Description

property access methods == StoreDefs.

TnxMemTable

Group

TnxMemTable Methods

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Methods


TnxMemTable Properties

TnxMemTable Properties
TnxMemTable Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxMemTable class are listed here.

Class

TnxMemTable Class

Public Properties
Name | Description
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
Published Properties
Name | Description
FieldDefs | see tTable.FieldDefs
IndexDefs | see tTable.IndexDefs.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
StoreDefs | see tTable.StoreDefs
TableName | Optional. When specified the name must be unique in the database. If a name is specified it is possible to access the mem table using other TnxTable and TnxQuery components connected to the same database under this name while the mem table is active.
UsedTableName | Only valid while the table is active. If a TableName was specified UsedTableName will be equal to TableName. Otherwise it will contain the unique name that was created for this mem table. Other TnxTable and TnxQuery components connected to the same database will be able to access the mem table under this name while it is active.
Links
TnxMemTable Class, Legend, Public Properties, Published Properties


TnxMemTable.FieldDefs Property

TnxMemTable.FieldDefs Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property FieldDefs;
Description

see tTable.FieldDefs

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.IndexDefs Property

TnxMemTable.IndexDefs Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property IndexDefs: TIndexDefs;
Description

see tTable.IndexDefs.

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.IndexFieldCount Property

TnxMemTable.IndexFieldCount Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property IndexFieldCount: Integer;
Description

see tTable.IndexFieldCount.

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.IndexFieldNames Property

TnxMemTable.IndexFieldNames Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property IndexFieldNames: string;
Description

see tTable.IndexFieldNames

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.IndexFields Property

TnxMemTable.IndexFields Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property IndexFields [aIndex: Integer]: TField;
Description

see tTable.IndexFields

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.IndexName Property

TnxMemTable.IndexName Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property IndexName: string;
Description

see tTable.IndexName

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.KeyExclusive Property

TnxMemTable.KeyExclusive Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property KeyExclusive: Boolean;
Description

see tTable.KeyExclusive

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.KeyFieldCount Property

TnxMemTable.KeyFieldCount Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property KeyFieldCount: Integer;
Description

see tTable.KeyFieldCount

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.KeyPartialLen Property

TnxMemTable.KeyPartialLen Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property KeyPartialLen: Integer;
Description

see tTable.KeyPartialLen

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.MasterFields Property

TnxMemTable.MasterFields Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property MasterFields: string;
Description

see tTable.MasterFields

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.MasterSource Property

TnxMemTable.MasterSource Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property MasterSource: TDataSource;
Description

see tTable.MasterSource

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.StoreDefs Property

TnxMemTable.StoreDefs Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property StoreDefs: Boolean;
Description

see tTable.StoreDefs

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.TableName Property

TnxMemTable.TableName Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property TableName: string;
Description

Optional. When specified the name must be unique in the database. If a name is specified it is possible to access the mem table using other TnxTable and TnxQuery components connected to the same database under this name while the mem table is active.

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable.UsedTableName Property

TnxMemTable.UsedTableName Property
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Properties Send Feedback
Syntax
Delphi
property UsedTableName: string;
Description

Only valid while the table is active. If a TableName was specified UsedTableName will be equal to TableName. Otherwise it will contain the unique name that was created for this mem table. Other TnxTable and TnxQuery components connected to the same database will be able to access the mem table under this name while it is active.

Group

TnxMemTable Properties

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Properties


TnxMemTable Events

TnxMemTable Events
TnxMemTable Class Legend Published Events Send Feedback

The events of the TnxMemTable class are listed here.

Class

TnxMemTable Class

Published Events
Name | Description
OnCreateTable | This event is fired before the table is create. It allows modification of the data dictionary that will be used to create the table.
Links
TnxMemTable Class, Legend, Published Events


TnxMemTable.OnCreateTable Event

TnxMemTable.OnCreateTable Event
TnxMemTable Class TnxMemTable Members nxdb Namespace TnxMemTable Events Send Feedback
Syntax
Delphi
property OnCreateTable: TnxCreateTableEvent;
Description

This event is fired before the table is create. It allows modification of the data dictionary that will be used to create the table.

Group

TnxMemTable Events

Links
TnxMemTable Class, TnxMemTable Members, nxdb Namespace, TnxMemTable Events


TnxPooledSession Class

TnxPooledSession Class
TnxPooledSession Fields TnxPooledSession Methods TnxPooledSession Properties TnxPooledSession Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSessionnxdb_TnxPooledSession
Syntax
Delphi
TnxPooledSession = class(TnxBaseSession);
File

nxdb

Description

A pooled, reference counted Session for use with session pools (TnxBaseSessionPool)

Group

Classes

Links
TnxPooledSession Fields, TnxPooledSession Methods, TnxPooledSession Properties, TnxPooledSession Members, nxdb, Classes


TnxPooledSession Members

TnxPooledSession Members
TnxPooledSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxPooledSession.

Class

TnxPooledSession Class

Protected Fields
Name | Description
bsAbstractSession | private
bsBeepOnLoginError | This is bsBeepOnLoginError, a member of class TnxBaseSession.
bsClientLocaleAsDefault | This is bsClientLocaleAsDefault, a member of class TnxBaseSession.
bsCurrentUserName | This is bsCurrentUserName, a member of class TnxBaseSession.
bsDatabases | This is bsDatabases, a member of class TnxBaseSession.
bsDefaultDatabase | This is bsDefaultDatabase, a member of class TnxBaseSession.
bsDefaultRef | This is bsDefaultRef, a member of class TnxBaseSession.
bsDefaultTransContext | This is bsDefaultTransContext, a member of class TnxBaseSession.
bsOnLogin | This is bsOnLogin, a member of class TnxBaseSession.
bsPassword | This is bsPassword, a member of class TnxBaseSession.
bsPasswordRetries | This is bsPasswordRetries, a member of class TnxBaseSession.
bsSessionNotifications | This is bsSessionNotifications, a member of class TnxBaseSession.
bsTempDatabases | This is bsTempDatabases, a member of class TnxBaseSession.
bsTimeout | This is bsTimeout, a member of class TnxBaseSession.
bsTransContexts | This is bsTransContexts, a member of class TnxBaseSession.
bsUserName | This is bsUserName, a member of class TnxBaseSession.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
psInPool | This is psInPool, a member of class TnxPooledSession.
psOwningThread | This is psOwningThread, a member of class TnxPooledSession.
psRefCount | This is psRefCount, a member of class TnxPooledSession.
psSessionPool | private
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bsCheckServerEngine |
bsDoLogin |
bsGetDatabase |
bsGetDatabaseCount |
bsGetDefault |
bsGetImplicitDatabase |
bsGetServerEngine |
bsGetServerVersion |
bsGetSessionNotifications |
bsGetTimeout |
bsGetTransContext |
bsGetTransContextCount |
bsRefreshTimeout |
bsSetClientLocaleAsDefault |
bsSetDefault |
bsSetPassword |
bsSetTimeout |
bsSetUserName |
CreateInstance | InxClassActivator
CreateRemoteTaskInfo | InxRemoteTaskInfoCreator
dascExceptionClass |
Disconnected | InxSessionNotifier
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
psCheckNoThread |
psCheckNotReferenced |
psCheckThread |
psSetSessionPool |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
AddAlias | Adds a new alias. If an error occurs, it triggers an exception.
AddAliasEx | Adds a new alias and returns the error code.
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
AddRef | DOM-IGNORE-BEGIN TnxPooledSession
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
CancelProcessing | This procedure can be called from another thread to terminate any currently ongoing processing.
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
CloseInactiveFolders | This method closes all folders of the session that were kept open by the server caching mechanism.
CloseInactiveLocalDatabases | This method closes all temp databases of the session that are have no active local Tables
CloseInactiveTables | This method closes all tables of the session that were kept open by the server caching mechanism.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Create | constructor
Create | constructor
CreateInstance | This is CreateInstance, a member of class InxClassActivator.
CreateRemoteTaskInfo | This is CreateRemoteTaskInfo, a member of class InxRemoteTaskInfoCreator.
DefaultDatabase | Returns the default database for this session or nil if non exist.
DefaultSession | Returns the default session for the current thread or nil if non exist.
DefaultTransContext | Returns the default TransContext for this session or nil if non exist.
DeleteAlias | Deletes the given alias. Triggers an exception if it fails.
DeleteAliasEx | Deletes the given alias and returns the error code.
Destroy | destructor.
Disconnected | Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindDatabase | Returns the implicit database for the given Alias. May return nil. The returned database may be closed.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetAliasNames | Fills the given list with all alias names.
GetAliasNamesEx | Fills the given list with all alias names and returns the error code.
GetAliasPath | Returns the path an alias points to. Remember that this is always a server relative path! The method triggers an exception if it fails.
GetAliasPathEx | Returns the path an alias points to. Remember that this is always a server relative path! It returns the error code as function result.
GetChangedTables | Returns the changed tables of an alias in the given list.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetRegisteredClassList | Returns a list of engines or descriptors of a particular type from the server.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored functions of a database/alias.
GetStoredFuncParams | Returns the parameter defintions for a named stored functions of the given Alias.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of a database/alias.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure of the given Alias.
GetTableNames | Returns the tables of an alias in the given list.
IsAlias | Returns true if an alias with the given name exists, otherwise false.
IsConnected | This function returns true if the session is active/connected.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LoggedInAdministrator | Returns the InxLoggedInAdministrator31000 of this session if available
LoggedInUser | Returns the InxLoggedInUser31000 of this session if available
LookupByComponentID |
ModifyAlias | This function allows to change the name and/or path of an alias. It triggers an exception if it fails.
ModifyAliasEx | This function allows to change the name and/or path of an alias and returns the error code.
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
OpenDatabase | Returns the implicit database for the given Alias, creates it if required. The returned database is guaranteed to be open.
PasswordAdd | Adds a password to the session password list.
PasswordRemove | Remove a password to the session password list.
PasswordRemoveAll | Clear the session password list.
ProcessPost | This is ProcessPost, a member of class InxSessionRequests.
ProcessRequest | This is ProcessRequest, a member of class InxSessionRequests.
ProcessRequestDirect | This is ProcessRequestDirect, a member of class InxSessionRequests.
Release |
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TableExists | Checks if a table exist in a specific alias.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
AbstractSession | This property gives direct access to the internal session state.
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DatabaseCount | Returns the number of tnxDatabase instances assigned to the session.
Databases | Returns the instance of tnxDatabase with index aInx in the list of assigned databases.
SavedActive | Can be used to save a certain state.
ServerEngine | Returns the Server Engine the session is connected to. Note, that this is read only in the base class. The Set method might be implemented in descendants.
ServerVersion | Returns the Version of the server engine.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TransContextCount | Returns the number of TnxTransContext instances assigned to the session.
TransContexts | Returns the instance of TnxTransContext with index aInx in the list of assigned TransContexts.
Published Events
Name | Description
OnLogin | This event is triggered whenever the session is set to active and the connected server engine is in secure mode, thus requesting users to logon.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
BeepOnLoginError | If true, a Beep is triggered whenever a failed Login occurs.
ClientLocaleAsDefault | This is ClientLocaleAsDefault, a member of class TnxBaseSession.
CurrentUserName | The user name used for logging in this session. It is only assigned while the session is active.
Default | If true this session is the default session for the current thread.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | The password for the session. It is only used when the connected Server Engine is in secure mode.
PasswordRetries | The number of retries for logon before the session returns a DBIERR_INVALIDUSRPASS error is triggered.
SessionNotifications | This is SessionNotifications, a member of class TnxBaseSession.
SessionPool | The session pool the session belongs to.
Timeout | Sets the Timeout for the Session commands (in ms).
UserName | The user name for the session. It is only used when the connected Server Engine is in secure mode.
Version | Version of the component.
Links
TnxPooledSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxPooledSession.Destroy Destructor

TnxPooledSession.Destroy Destructor
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxPooledSession Class

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Class


TnxPooledSession Fields

TnxPooledSession Fields
TnxPooledSession Class Legend Protected Fields Send Feedback

The fields of the TnxPooledSession class are listed here.

Class

TnxPooledSession Class

Protected Fields
Name | Description
psInPool | This is psInPool, a member of class TnxPooledSession.
psOwningThread | This is psOwningThread, a member of class TnxPooledSession.
psRefCount | This is psRefCount, a member of class TnxPooledSession.
psSessionPool | private
Links
TnxPooledSession Class, Legend, Protected Fields


TnxPooledSession.psInPool Field

TnxPooledSession.psInPool Field
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Fields Send Feedback
Syntax
Delphi
psInPool: Boolean;
Description

This is psInPool, a member of class TnxPooledSession.

Group

TnxPooledSession Fields

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Fields


TnxPooledSession.psOwningThread Field

TnxPooledSession.psOwningThread Field
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Fields Send Feedback
Syntax
Delphi
psOwningThread: Cardinal;
Description

This is psOwningThread, a member of class TnxPooledSession.

Group

TnxPooledSession Fields

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Fields


TnxPooledSession.psRefCount Field

TnxPooledSession.psRefCount Field
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Fields Send Feedback
Syntax
Delphi
psRefCount: Integer;
Description

This is psRefCount, a member of class TnxPooledSession.

Group

TnxPooledSession Fields

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Fields


TnxPooledSession.psSessionPool Field

TnxPooledSession.psSessionPool Field
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Fields Send Feedback
Syntax
Delphi
psSessionPool: TnxBaseSessionPool;
Description

private

Group

TnxPooledSession Fields

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Fields


TnxPooledSession Methods

TnxPooledSession Methods
TnxPooledSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxPooledSession class are listed here.

Class

TnxPooledSession Class

Protected Methods
Name | Description
bsGetServerEngine |
bsGetTimeout |
nxcNotification |
psCheckNoThread |
psCheckNotReferenced |
psCheckThread |
psSetSessionPool |
scIsStateParent |
scStopping |
Public Methods
Name | Description
AddRef | DOM-IGNORE-BEGIN TnxPooledSession
Release |
Links
TnxPooledSession Class, Legend, Protected Methods, Public Methods


TnxPooledSession.AddRef Method

TnxPooledSession.AddRef Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure AddRef;
Description

DOM-IGNORE-BEGIN

TnxPooledSession

Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.bsGetServerEngine Method

TnxPooledSession.bsGetServerEngine Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
function bsGetServerEngine: TnxBaseServerEngine; override;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.bsGetTimeout Method

TnxPooledSession.bsGetTimeout Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
function bsGetTimeout: Integer; override;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.nxcNotification Method

TnxPooledSession.nxcNotification Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.psCheckNoThread Method

TnxPooledSession.psCheckNoThread Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure psCheckNoThread;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.psCheckNotReferenced Method

TnxPooledSession.psCheckNotReferenced Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure psCheckNotReferenced;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.psCheckThread Method

TnxPooledSession.psCheckThread Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure psCheckThread;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.psSetSessionPool Method

TnxPooledSession.psSetSessionPool Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure psSetSessionPool(aSessionPool: TnxBaseSessionPool);
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.Release Method

TnxPooledSession.Release Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure Release;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.scIsStateParent Method

TnxPooledSession.scIsStateParent Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession.scStopping Method

TnxPooledSession.scStopping Method
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxPooledSession Methods

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Methods


TnxPooledSession Properties

TnxPooledSession Properties
TnxPooledSession Class Legend Published Properties Send Feedback

The properties of the TnxPooledSession class are listed here.

Class

TnxPooledSession Class

Published Properties
Name | Description
SessionPool | The session pool the session belongs to.
Links
TnxPooledSession Class, Legend, Published Properties


TnxPooledSession.SessionPool Property

TnxPooledSession.SessionPool Property
TnxPooledSession Class TnxPooledSession Members nxdb Namespace TnxPooledSession Properties Send Feedback
Syntax
Delphi
property SessionPool: TnxBaseSessionPool;
Description

The session pool the session belongs to.

Group

TnxPooledSession Properties

Links
TnxPooledSession Class, TnxPooledSession Members, nxdb Namespace, TnxPooledSession Properties


TnxQuery Class

TnxQuery Class
TnxQuery Fields TnxQuery Methods TnxQuery Properties TnxQuery Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxQuerynxdb_TnxQuerynxdb_TnxQuery
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxQuery = class(TnxStatementDataSet);
File

nxdb

Description

This is the client side representation of a SQL query. It's very similar to the VCL TQuery class.

Group

Classes

Links
TnxQuery Fields, TnxQuery Methods, TnxQuery Properties, TnxQuery Members, nxdb, Classes


TnxQuery Members

TnxQuery Members
TnxQuery Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxQuery.

Class

TnxQuery Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
quParamCheck | This is quParamCheck, a member of class TnxQuery.
quSql | This is quSql, a member of class TnxQuery.
quText | private
sdAbstractStatement | private
sdCanModify | This is sdCanModify, a member of class TnxStatementDataSet.
sdDataLink | This is sdDataLink, a member of class TnxStatementDataSet.
sdExecuted | This is sdExecuted, a member of class TnxStatementDataSet.
sdLog | This is sdLog, a member of class TnxStatementDataSet.
sdNoResultSetNeeded | This is sdNoResultSetNeeded, a member of class TnxStatementDataSet.
sdParams | This is sdParams, a member of class TnxStatementDataSet.
sdReadOnly | This is sdReadOnly, a member of class TnxStatementDataSet.
sdRecordsRead | This is sdRecordsRead, a member of class TnxStatementDataSet.
sdRequestLive | This is sdRequestLive, a member of class TnxStatementDataSet.
sdRowsAffected | This is sdRowsAffected, a member of class TnxStatementDataSet.
sdWasPrepared | This is sdWasPrepared, a member of class TnxStatementDataSet.
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DefineProperties | virtual TComponent methods == custom properties.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | open/close.
dsOpenCursorID | == internal functions == -- open/close
dsRefreshTimeout | misc.
dsRefreshTimeout | misc
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | info.
GetCanModify | == virtual TDataSet methods == -- info
GetFieldClass |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSExecute | IProviderSupport
PSGetDefaultOrder | == virtual TDataSet methods == -- IProviderSupport
PSGetParams |
PSGetTableName |
PSSetCommandText |
PSSetParams |
quParseSql | params.
quSetSql | property access methods.
quSqlChanged |
RefreshInternalCalcFields |
ResetBlockReadStream |
sdApplyParams |
sdBuildParams |
sdExec |
sdGetDataSource |
sdGetParamCount |
sdGetPrepared | property access methods.
sdGetQueryInfo | misc
sdHandleError | This is the overview for the sdHandleError method overload.
sdReadParams | custom properties.
sdRefreshParams | params.
sdSetDataSource |
sdSetParams |
sdSetParamsFromCursor |
sdSetPrepared |
sdSetRequestLive |
sdWriteParams |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor. TnxQuery
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
ExecSQL | see tQuery.ExecSql
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
ParamByName | see tQuery.ParamByName
Post | == virtual TDataSet methods == -- navigation
PostAndEdit |
Prepare | see tQuery.Prepare
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
Unprepare | see tQuery.UnPrepare
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
Log | Log returns a detailed analysis of the Query. You need to at least Prepare the Query for Log to be updated.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
ParamCount | see tQuery.ParamCount
Prepared | see tQuery.Prepared
RecordsRead | RecordsRead is set after calling ExecSql and the value indicates how many records were read.
RowsAffected | see tQuery.RowsAffected
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Text | see tQuery.Text
Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
DataSource | see tQuery.DataSource.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
ParamCheck | see tQuery.ParamCheck
Params | see tQuery.Params
ReadOnly | Prevents modification of a live result set.
RequestLive | Only supported for "SELECT * FROM tablename" type queries currently.
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
SQL | see tQuery.SQL
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxQuery Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxQuery.Create Constructor

TnxQuery.Create Constructor
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

TnxQuery

Class

TnxQuery Class

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Class


TnxQuery.Destroy Destructor

TnxQuery.Destroy Destructor
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxQuery Class

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Class


TnxQuery Fields

TnxQuery Fields
TnxQuery Class Legend Protected Fields Send Feedback

The fields of the TnxQuery class are listed here.

Class

TnxQuery Class

Protected Fields
Name | Description
quParamCheck | This is quParamCheck, a member of class TnxQuery.
quSql | This is quSql, a member of class TnxQuery.
quText | private
Links
TnxQuery Class, Legend, Protected Fields


TnxQuery.quParamCheck Field

TnxQuery.quParamCheck Field
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Fields Send Feedback
Syntax
Delphi
quParamCheck: Boolean;
Description

This is quParamCheck, a member of class TnxQuery.

Group

TnxQuery Fields

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Fields


TnxQuery.quSql Field

TnxQuery.quSql Field
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Fields Send Feedback
Syntax
Delphi
quSql: TStrings;
Description

This is quSql, a member of class TnxQuery.

Group

TnxQuery Fields

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Fields


TnxQuery.quText Field

TnxQuery.quText Field
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Fields Send Feedback
Syntax
Delphi
quText: UnicodeString;
Description

private

Group

TnxQuery Fields

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Fields


TnxQuery Methods

TnxQuery Methods
TnxQuery Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxQuery class are listed here.

Class

TnxQuery Class

Protected Methods
Name | Description
PSGetDefaultOrder | == virtual TDataSet methods == -- IProviderSupport
PSGetTableName |
PSSetCommandText |
quParseSql | params.
quSetSql | property access methods.
quSqlChanged |
sdGetQueryInfo | misc
Public Methods
Name | Description
ExecSQL | see tQuery.ExecSql
Links
TnxQuery Class, Legend, Protected Methods, Public Methods


TnxQuery.ExecSQL Method

TnxQuery.ExecSQL Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
procedure ExecSQL;
Description

see tQuery.ExecSql

Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.PSGetDefaultOrder Method

TnxQuery.PSGetDefaultOrder Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
function PSGetDefaultOrder: TIndexDef; override;
Description

== virtual TDataSet methods == -- IProviderSupport

Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.PSGetTableName Method

TnxQuery.PSGetTableName Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
function PSGetTableName: string; override;
Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.PSSetCommandText Method

TnxQuery.PSSetCommandText Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
procedure PSSetCommandText(const aCommandText: string); override;
Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.quParseSql Method

TnxQuery.quParseSql Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
function quParseSql(const aStmt: UnicodeString; aCreateParams: boolean; aParams: TParams): UnicodeString;
Description

params.

Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.quSetSql Method

TnxQuery.quSetSql Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
procedure quSetSql(aValue: TStrings);
Description

property access methods.

Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.quSqlChanged Method

TnxQuery.quSqlChanged Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
procedure quSqlChanged(Sender: TObject);
Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery.sdGetQueryInfo Method

TnxQuery.sdGetQueryInfo Method
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Methods Send Feedback
Syntax
Delphi
function sdGetQueryInfo(out aText: UnicodeString): TnxStatementType; override;
Description

misc

Group

TnxQuery Methods

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Methods


TnxQuery Properties

TnxQuery Properties
TnxQuery Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxQuery class are listed here.

Class

TnxQuery Class

Public Properties
Name | Description
Text | see tQuery.Text
Published Properties
Name | Description
ParamCheck | see tQuery.ParamCheck
SQL | see tQuery.SQL
Links
TnxQuery Class, Legend, Public Properties, Published Properties


TnxQuery.ParamCheck Property

TnxQuery.ParamCheck Property
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Properties Send Feedback
Syntax
Delphi
property ParamCheck: boolean;
Description

see tQuery.ParamCheck

Group

TnxQuery Properties

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Properties


TnxQuery.SQL Property

TnxQuery.SQL Property
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Properties Send Feedback
Syntax
Delphi
property SQL: TStrings;
Description

see tQuery.SQL

Group

TnxQuery Properties

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Properties


TnxQuery.Text Property

TnxQuery.Text Property
TnxQuery Class TnxQuery Members nxdb Namespace TnxQuery Properties Send Feedback
Syntax
Delphi
property Text: UnicodeString;
Description

see tQuery.Text

Group

TnxQuery Properties

Links
TnxQuery Class, TnxQuery Members, nxdb Namespace, TnxQuery Properties


TnxSession Class

TnxSession Class
TnxSession Fields TnxSession Methods TnxSession Properties TnxSession Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSessionnxdb_TnxSession
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSession = class(TnxBaseSession);
File

nxdb

Description

A BDE compatible implementation of a NexusDB session.

Group

Classes

Links
TnxSession Fields, TnxSession Methods, TnxSession Properties, TnxSession Members, nxdb, Classes


TnxSession Members

TnxSession Members
TnxSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxSession.

Class

TnxSession Class

Protected Fields
Name | Description
bsAbstractSession | private
bsBeepOnLoginError | This is bsBeepOnLoginError, a member of class TnxBaseSession.
bsClientLocaleAsDefault | This is bsClientLocaleAsDefault, a member of class TnxBaseSession.
bsCurrentUserName | This is bsCurrentUserName, a member of class TnxBaseSession.
bsDatabases | This is bsDatabases, a member of class TnxBaseSession.
bsDefaultDatabase | This is bsDefaultDatabase, a member of class TnxBaseSession.
bsDefaultRef | This is bsDefaultRef, a member of class TnxBaseSession.
bsDefaultTransContext | This is bsDefaultTransContext, a member of class TnxBaseSession.
bsOnLogin | This is bsOnLogin, a member of class TnxBaseSession.
bsPassword | This is bsPassword, a member of class TnxBaseSession.
bsPasswordRetries | This is bsPasswordRetries, a member of class TnxBaseSession.
bsSessionNotifications | This is bsSessionNotifications, a member of class TnxBaseSession.
bsTempDatabases | This is bsTempDatabases, a member of class TnxBaseSession.
bsTimeout | This is bsTimeout, a member of class TnxBaseSession.
bsTransContexts | This is bsTransContexts, a member of class TnxBaseSession.
bsUserName | This is bsUserName, a member of class TnxBaseSession.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
sesServerEngine | private
Protected Methods
Name | Description
bsCheckServerEngine |
bsDoLogin |
bsGetDatabase |
bsGetDatabaseCount |
bsGetDefault |
bsGetImplicitDatabase |
bsGetServerEngine | TnxSession
bsGetServerVersion |
bsGetSessionNotifications |
bsGetTimeout |
bsGetTransContext |
bsGetTransContextCount |
bsRefreshTimeout |
bsSetClientLocaleAsDefault |
bsSetDefault |
bsSetPassword |
bsSetTimeout |
bsSetUserName |
CreateInstance | InxClassActivator
CreateRemoteTaskInfo | InxRemoteTaskInfoCreator
dascExceptionClass |
Disconnected | InxSessionNotifier
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
sesSetServerEngine |
Public Methods
Name | Description
AddAlias | Adds a new alias. If an error occurs, it triggers an exception.
AddAliasEx | Adds a new alias and returns the error code.
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
CancelProcessing | This procedure can be called from another thread to terminate any currently ongoing processing.
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
CloseInactiveFolders | This method closes all folders of the session that were kept open by the server caching mechanism.
CloseInactiveLocalDatabases | This method closes all temp databases of the session that are have no active local Tables
CloseInactiveTables | This method closes all tables of the session that were kept open by the server caching mechanism.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Create | constructor
Create | constructor
CreateInstance | This is CreateInstance, a member of class InxClassActivator.
CreateRemoteTaskInfo | This is CreateRemoteTaskInfo, a member of class InxRemoteTaskInfoCreator.
DefaultDatabase | Returns the default database for this session or nil if non exist.
DefaultSession | Returns the default session for the current thread or nil if non exist.
DefaultTransContext | Returns the default TransContext for this session or nil if non exist.
DeleteAlias | Deletes the given alias. Triggers an exception if it fails.
DeleteAliasEx | Deletes the given alias and returns the error code.
Destroy | destructor.
Disconnected | Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindDatabase | Returns the implicit database for the given Alias. May return nil. The returned database may be closed.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetAliasNames | Fills the given list with all alias names.
GetAliasNamesEx | Fills the given list with all alias names and returns the error code.
GetAliasPath | Returns the path an alias points to. Remember that this is always a server relative path! The method triggers an exception if it fails.
GetAliasPathEx | Returns the path an alias points to. Remember that this is always a server relative path! It returns the error code as function result.
GetChangedTables | Returns the changed tables of an alias in the given list.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetRegisteredClassList | Returns a list of engines or descriptors of a particular type from the server.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
GetStoredFuncNames | GetStoredFuncNames returns a list of all stored functions of a database/alias.
GetStoredFuncParams | Returns the parameter defintions for a named stored functions of the given Alias.
GetStoredProcNames | GetStoredProcNames returns a list of all stored procedures of a database/alias.
GetStoredProcParams | Returns the parameter defintions for a named stored procedure of the given Alias.
GetTableNames | Returns the tables of an alias in the given list.
IsAlias | Returns true if an alias with the given name exists, otherwise false.
IsConnected | This function returns true if the session is active/connected.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LoggedInAdministrator | Returns the InxLoggedInAdministrator31000 of this session if available
LoggedInUser | Returns the InxLoggedInUser31000 of this session if available
LookupByComponentID |
ModifyAlias | This function allows to change the name and/or path of an alias. It triggers an exception if it fails.
ModifyAliasEx | This function allows to change the name and/or path of an alias and returns the error code.
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
OpenDatabase | Returns the implicit database for the given Alias, creates it if required. The returned database is guaranteed to be open.
PasswordAdd | Adds a password to the session password list.
PasswordRemove | Remove a password to the session password list.
PasswordRemoveAll | Clear the session password list.
ProcessPost | This is ProcessPost, a member of class InxSessionRequests.
ProcessRequest | This is ProcessRequest, a member of class InxSessionRequests.
ProcessRequestDirect | This is ProcessRequestDirect, a member of class InxSessionRequests.
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TableExists | Checks if a table exist in a specific alias.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
AbstractSession | This property gives direct access to the internal session state.
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DatabaseCount | Returns the number of tnxDatabase instances assigned to the session.
Databases | Returns the instance of tnxDatabase with index aInx in the list of assigned databases.
SavedActive | Can be used to save a certain state.
ServerVersion | Returns the Version of the server engine.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TransContextCount | Returns the number of TnxTransContext instances assigned to the session.
TransContexts | Returns the instance of TnxTransContext with index aInx in the list of assigned TransContexts.
Published Events
Name | Description
OnLogin | This event is triggered whenever the session is set to active and the connected server engine is in secure mode, thus requesting users to logon.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
BeepOnLoginError | If true, a Beep is triggered whenever a failed Login occurs.
ClientLocaleAsDefault | This is ClientLocaleAsDefault, a member of class TnxBaseSession.
CurrentUserName | The user name used for logging in this session. It is only assigned while the session is active.
Default | If true this session is the default session for the current thread.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | The password for the session. It is only used when the connected Server Engine is in secure mode.
PasswordRetries | The number of retries for logon before the session returns a DBIERR_INVALIDUSRPASS error is triggered.
ServerEngine | The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened
SessionNotifications | This is SessionNotifications, a member of class TnxBaseSession.
Timeout | Sets the Timeout for the Session commands (in ms).
UserName | The user name for the session. It is only used when the connected Server Engine is in secure mode.
Version | Version of the component.
Links
TnxSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxSession.Destroy Destructor

TnxSession.Destroy Destructor
TnxSession Class TnxSession Members nxdb Namespace TnxSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxSession Class

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Class


TnxSession Fields

TnxSession Fields
TnxSession Class Legend Protected Fields Send Feedback

The fields of the TnxSession class are listed here.

Class

TnxSession Class

Protected Fields
Name | Description
sesServerEngine | private
Links
TnxSession Class, Legend, Protected Fields


TnxSession.sesServerEngine Field

TnxSession.sesServerEngine Field
TnxSession Class TnxSession Members nxdb Namespace TnxSession Fields Send Feedback
Syntax
Delphi
sesServerEngine: TnxBaseServerEngine;
Description

private

Group

TnxSession Fields

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Fields


TnxSession Methods

TnxSession Methods
TnxSession Class Legend Protected Methods Send Feedback

The methods of the TnxSession class are listed here.

Class

TnxSession Class

Protected Methods
Name | Description
bsGetServerEngine | TnxSession
nxcNotification |
scIsStateParent |
sesSetServerEngine |
Links
TnxSession Class, Legend, Protected Methods


TnxSession.bsGetServerEngine Method

TnxSession.bsGetServerEngine Method
TnxSession Class TnxSession Members nxdb Namespace TnxSession Methods Send Feedback
Syntax
Delphi
function bsGetServerEngine: TnxBaseServerEngine; override;
Description

TnxSession

Group

TnxSession Methods

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Methods


TnxSession.nxcNotification Method

TnxSession.nxcNotification Method
TnxSession Class TnxSession Members nxdb Namespace TnxSession Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxSession Methods

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Methods


TnxSession.scIsStateParent Method

TnxSession.scIsStateParent Method
TnxSession Class TnxSession Members nxdb Namespace TnxSession Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxSession Methods

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Methods


TnxSession.sesSetServerEngine Method

TnxSession.sesSetServerEngine Method
TnxSession Class TnxSession Members nxdb Namespace TnxSession Methods Send Feedback
Syntax
Delphi
procedure sesSetServerEngine(aServerEngine: TnxBaseServerEngine); virtual;
Group

TnxSession Methods

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Methods


TnxSession Properties

TnxSession Properties
TnxSession Class Legend Published Properties Send Feedback

The properties of the TnxSession class are listed here.

Class

TnxSession Class

Published Properties
Name | Description
ServerEngine | The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened
Links
TnxSession Class, Legend, Published Properties


TnxSession.ServerEngine Property

TnxSession.ServerEngine Property
TnxSession Class TnxSession Members nxdb Namespace TnxSession Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened

Group

TnxSession Properties

Links
TnxSession Class, TnxSession Members, nxdb Namespace, TnxSession Properties


TnxSessionOwnedDataAccessStateComponent Class

TnxSessionOwnedDataAccessStateComponent Class
TnxSessionOwnedDataAccessStateComponent Fields TnxSessionOwnedDataAccessStateComponent Methods TnxSessionOwnedDataAccessStateComponent Properties TnxSessionOwnedDataAccessStateComponent Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponentnxdb_TnxSessionOwnedDataAccessStateComponent
Syntax
Delphi
TnxSessionOwnedDataAccessStateComponent = class(TnxDataAccessStateComponent);
File

nxdb

Description

Base class for all stateful components owned by a session, e.g. databases

Group

Classes

Links
TnxSessionOwnedDataAccessStateComponent Fields, TnxSessionOwnedDataAccessStateComponent Methods, TnxSessionOwnedDataAccessStateComponent Properties, TnxSessionOwnedDataAccessStateComponent Members, nxdb, Classes


TnxSessionOwnedDataAccessStateComponent Members

TnxSessionOwnedDataAccessStateComponent Members
TnxSessionOwnedDataAccessStateComponent Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSessionOwnedDataAccessStateComponent.

Class

TnxSessionOwnedDataAccessStateComponent Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
soSession | private
soTimeout | This is soTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
Protected Methods
Name | Description
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
soCheckDefaults |
soCheckSession |
soGetTimeout |
soRefreshTimeout | This is soRefreshTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
soSetSession |
soSetTimeout |
Public Methods
Name | Description
AfterConstruction | see TDataset.AfterConstruction TnxSessionOwnedDataAccessStateComponent
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Session | The session the database is attached to. This property must be set for the component to work properly.
Timeout | Set the timeout for the component in ms. If -1 is specified the component inherits the value of the session it is connected to.
Version | Version of the component.
Links
TnxSessionOwnedDataAccessStateComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxSessionOwnedDataAccessStateComponent.Create Constructor

TnxSessionOwnedDataAccessStateComponent.Create Constructor
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor

Class

TnxSessionOwnedDataAccessStateComponent Class

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Class


TnxSessionOwnedDataAccessStateComponent Fields

TnxSessionOwnedDataAccessStateComponent Fields
TnxSessionOwnedDataAccessStateComponent Class Legend Protected Fields Send Feedback

The fields of the TnxSessionOwnedDataAccessStateComponent class are listed here.

Class

TnxSessionOwnedDataAccessStateComponent Class

Protected Fields
Name | Description
soSession | private
soTimeout | This is soTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
Links
TnxSessionOwnedDataAccessStateComponent Class, Legend, Protected Fields


TnxSessionOwnedDataAccessStateComponent.soSession Field

TnxSessionOwnedDataAccessStateComponent.soSession Field
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Fields Send Feedback
Syntax
Delphi
soSession: TnxBaseSession;
Description

private

Group

TnxSessionOwnedDataAccessStateComponent Fields

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Fields


TnxSessionOwnedDataAccessStateComponent.soTimeout Field

TnxSessionOwnedDataAccessStateComponent.soTimeout Field
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Fields Send Feedback
Syntax
Delphi
soTimeout: Integer;
Description

This is soTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.

Group

TnxSessionOwnedDataAccessStateComponent Fields

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Fields


TnxSessionOwnedDataAccessStateComponent Methods

TnxSessionOwnedDataAccessStateComponent Methods
TnxSessionOwnedDataAccessStateComponent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSessionOwnedDataAccessStateComponent class are listed here.

Class

TnxSessionOwnedDataAccessStateComponent Class

Protected Methods
Name | Description
Loaded |
nxcNotification |
scIsStateParent |
soCheckDefaults |
soCheckSession |
soGetTimeout |
soRefreshTimeout | This is soRefreshTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
soSetSession |
soSetTimeout |
Public Methods
Name | Description
AfterConstruction | see TDataset.AfterConstruction TnxSessionOwnedDataAccessStateComponent
Links
TnxSessionOwnedDataAccessStateComponent Class, Legend, Protected Methods, Public Methods


TnxSessionOwnedDataAccessStateComponent.AfterConstruction Method

TnxSessionOwnedDataAccessStateComponent.AfterConstruction Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TDataset.AfterConstruction

TnxSessionOwnedDataAccessStateComponent

Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.Loaded Method

TnxSessionOwnedDataAccessStateComponent.Loaded Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.nxcNotification Method

TnxSessionOwnedDataAccessStateComponent.nxcNotification Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.scIsStateParent Method

TnxSessionOwnedDataAccessStateComponent.scIsStateParent Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soCheckDefaults Method

TnxSessionOwnedDataAccessStateComponent.soCheckDefaults Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure soCheckDefaults; virtual;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soCheckSession Method

TnxSessionOwnedDataAccessStateComponent.soCheckSession Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure soCheckSession;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soGetTimeout Method

TnxSessionOwnedDataAccessStateComponent.soGetTimeout Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
function soGetTimeout: Integer;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soRefreshTimeout Method

TnxSessionOwnedDataAccessStateComponent.soRefreshTimeout Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure soRefreshTimeout; virtual; abstract;
Description

This is soRefreshTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.

Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soSetSession Method

TnxSessionOwnedDataAccessStateComponent.soSetSession Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure soSetSession(Value: TnxBaseSession); virtual;
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent.soSetTimeout Method

TnxSessionOwnedDataAccessStateComponent.soSetTimeout Method
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Methods Send Feedback
Syntax
Delphi
procedure soSetTimeout(Value: Integer);
Group

TnxSessionOwnedDataAccessStateComponent Methods

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Methods


TnxSessionOwnedDataAccessStateComponent Properties

TnxSessionOwnedDataAccessStateComponent Properties
TnxSessionOwnedDataAccessStateComponent Class Legend Published Properties Send Feedback

The properties of the TnxSessionOwnedDataAccessStateComponent class are listed here.

Class

TnxSessionOwnedDataAccessStateComponent Class

Published Properties
Name | Description
Session | The session the database is attached to. This property must be set for the component to work properly.
Timeout | Set the timeout for the component in ms. If -1 is specified the component inherits the value of the session it is connected to.
Links
TnxSessionOwnedDataAccessStateComponent Class, Legend, Published Properties


TnxSessionOwnedDataAccessStateComponent.Session Property

TnxSessionOwnedDataAccessStateComponent.Session Property
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Properties Send Feedback
Syntax
Delphi
property Session: TnxBaseSession;
Description

The session the database is attached to. This property must be set for the component to work properly.

Group

TnxSessionOwnedDataAccessStateComponent Properties

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Properties


TnxSessionOwnedDataAccessStateComponent.Timeout Property

TnxSessionOwnedDataAccessStateComponent.Timeout Property
TnxSessionOwnedDataAccessStateComponent Class TnxSessionOwnedDataAccessStateComponent Members nxdb Namespace TnxSessionOwnedDataAccessStateComponent Properties Send Feedback
Syntax
Delphi
property Timeout: Integer;
Description

Set the timeout for the component in ms. If -1 is specified the component inherits the value of the session it is connected to.

Group

TnxSessionOwnedDataAccessStateComponent Properties

Links
TnxSessionOwnedDataAccessStateComponent Class, TnxSessionOwnedDataAccessStateComponent Members, nxdb Namespace, TnxSessionOwnedDataAccessStateComponent Properties


TnxSessionPool Class

TnxSessionPool Class
TnxSessionPool Fields TnxSessionPool Methods TnxSessionPool Properties TnxSessionPool Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPoolnxdb_TnxSessionPool
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSessionPool = class(TnxBaseSessionPool);
File

nxdb

Description

A threadsafe session pool.

Group

Classes

Links
TnxSessionPool Fields, TnxSessionPool Methods, TnxSessionPool Properties, TnxSessionPool Members, nxdb, Classes


TnxSessionPool Members

TnxSessionPool Members
TnxSessionPool Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSessionPool.

Class

TnxSessionPool Class

Protected Fields
Name | Description
bspOutstandingSessions | This is bspOutstandingSessions, a member of class TnxBaseSessionPool.
bspPassword | This is bspPassword, a member of class TnxBaseSessionPool.
bspPool | This is bspPool, a member of class TnxBaseSessionPool.
bspPool2 | This is bspPool2, a member of class TnxBaseSessionPool.
bspSessions | private
bspTimeout | This is bspTimeout, a member of class TnxBaseSessionPool.
bspUserName | This is bspUserName, a member of class TnxBaseSessionPool.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
spServerEngine | private
Protected Methods
Name | Description
bspCheckServerEngine |
bspCreateSession |
bspGetServerEngine | TnxSessionPool
bspGetTimeout |
bspReturn |
bspSetPassword |
bspSetTimeout |
bspSetUserName |
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests.
ProcessRequestDirect |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
spSetServerEngine |
Public Methods
Name | Description
AcquireSession | Returns a free session out of the pool. TnxBaseSessionPool
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Create | constructor
Create | constructor
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
ProcessPost | This is ProcessPost, a member of class InxSessionRequests.
ProcessRequest | This is ProcessRequest, a member of class InxSessionRequests.
ProcessRequestDirect | This is ProcessRequestDirect, a member of class InxSessionRequests.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | The password for the session pool. It is only used when the connected Server Engine is in secure mode.
ServerEngine | The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened
Timeout | Sets the Timeout for the Session pool commands (in ms).
UserName | The user name for the session pool. It is only used when the connected Server Engine is in secure mode.
Version | Version of the component.
Links
TnxSessionPool Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxSessionPool.Destroy Destructor

TnxSessionPool.Destroy Destructor
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxSessionPool Class

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Class


TnxSessionPool Fields

TnxSessionPool Fields
TnxSessionPool Class Legend Protected Fields Send Feedback

The fields of the TnxSessionPool class are listed here.

Class

TnxSessionPool Class

Protected Fields
Name | Description
spServerEngine | private
Links
TnxSessionPool Class, Legend, Protected Fields


TnxSessionPool.spServerEngine Field

TnxSessionPool.spServerEngine Field
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Fields Send Feedback
Syntax
Delphi
spServerEngine: TnxBaseServerEngine;
Description

private

Group

TnxSessionPool Fields

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Fields


TnxSessionPool Methods

TnxSessionPool Methods
TnxSessionPool Class Legend Protected Methods Send Feedback

The methods of the TnxSessionPool class are listed here.

Class

TnxSessionPool Class

Protected Methods
Name | Description
bspGetServerEngine | TnxSessionPool
nxcNotification |
scIsStateParent |
spSetServerEngine |
Links
TnxSessionPool Class, Legend, Protected Methods


TnxSessionPool.bspGetServerEngine Method

TnxSessionPool.bspGetServerEngine Method
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Methods Send Feedback
Syntax
Delphi
function bspGetServerEngine: TnxBaseServerEngine; override;
Description

TnxSessionPool

Group

TnxSessionPool Methods

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Methods


TnxSessionPool.nxcNotification Method

TnxSessionPool.nxcNotification Method
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxSessionPool Methods

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Methods


TnxSessionPool.scIsStateParent Method

TnxSessionPool.scIsStateParent Method
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxSessionPool Methods

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Methods


TnxSessionPool.spSetServerEngine Method

TnxSessionPool.spSetServerEngine Method
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Methods Send Feedback
Syntax
Delphi
procedure spSetServerEngine(aServerEngine: TnxBaseServerEngine); virtual;
Group

TnxSessionPool Methods

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Methods


TnxSessionPool Properties

TnxSessionPool Properties
TnxSessionPool Class Legend Published Properties Send Feedback

The properties of the TnxSessionPool class are listed here.

Class

TnxSessionPool Class

Published Properties
Name | Description
ServerEngine | The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened
Links
TnxSessionPool Class, Legend, Published Properties


TnxSessionPool.ServerEngine Property

TnxSessionPool.ServerEngine Property
TnxSessionPool Class TnxSessionPool Members nxdb Namespace TnxSessionPool Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

The connected Server Engine. Please note that every Session must(!) be connected to a Server engine before it can be opened

Group

TnxSessionPool Properties

Links
TnxSessionPool Class, TnxSessionPool Members, nxdb Namespace, TnxSessionPool Properties


TnxSqlUpdateHandler Class

TnxSqlUpdateHandler Class
TnxSqlUpdateHandler Fields TnxSqlUpdateHandler Methods TnxSqlUpdateHandler Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandlernxdb_TnxSqlUpdateHandler
Syntax
Delphi
TnxSqlUpdateHandler = class(TnxBaseUpdateHandler);
File

nxdb

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
TnxSqlUpdateHandler Fields, TnxSqlUpdateHandler Methods, TnxSqlUpdateHandler Members, nxdb, Classes


TnxSqlUpdateHandler Members

TnxSqlUpdateHandler Members
TnxSqlUpdateHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSqlUpdateHandler.

Class

TnxSqlUpdateHandler Class

Protected Fields
Name | Description
buhCachedDataSet | This is buhCachedDataSet, a member of class TnxBaseUpdateHandler.
buhDatabase | This is buhDatabase, a member of class TnxBaseUpdateHandler.
buhFree | This is buhFree, a member of class TnxBaseUpdateHandler.
buhUpdateObject | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
suhSqlParamCP | This is suhSqlParamCP, a member of class TnxSqlUpdateHandler.
suhSqlParamFields | = normal buffer, - = OldBuffer for modify
suhSqlParams | This is suhSqlParams, a member of class TnxSqlUpdateHandler.
suhSqlText | private
suhStatements | This is suhStatements, a member of class TnxSqlUpdateHandler.
Protected Methods
Name | Description
buhNotifyDelete | TnxSqlUpdateHandler
buhNotifyInsert |
buhNotifyModify |
Create |
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
suhExecStatement |
suhParseSql |
Public Methods
Name | Description
AfterConstruction | TnxBaseUpdateHandler
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxSqlUpdateHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxSqlUpdateHandler.Create Constructor

TnxSqlUpdateHandler.Create Constructor
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Class Send Feedback
Syntax
Delphi
constructor Create(aUpdateObject: TnxBaseUpdateObject; aCachedDataSet: TnxCachedDataSet); override;
Class

TnxSqlUpdateHandler Class

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Class


TnxSqlUpdateHandler Fields

TnxSqlUpdateHandler Fields
TnxSqlUpdateHandler Class Legend Protected Fields Send Feedback

The fields of the TnxSqlUpdateHandler class are listed here.

Class

TnxSqlUpdateHandler Class

Protected Fields
Name | Description
suhSqlParamCP | This is suhSqlParamCP, a member of class TnxSqlUpdateHandler.
suhSqlParamFields | = normal buffer, - = OldBuffer for modify
suhSqlParams | This is suhSqlParams, a member of class TnxSqlUpdateHandler.
suhSqlText | private
suhStatements | This is suhStatements, a member of class TnxSqlUpdateHandler.
Links
TnxSqlUpdateHandler Class, Legend, Protected Fields


TnxSqlUpdateHandler.suhSqlParamCP Field

TnxSqlUpdateHandler.suhSqlParamCP Field
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Fields Send Feedback
Syntax
Delphi
suhSqlParamCP: array[TUpdateKind] of array of Word;
Description

This is suhSqlParamCP, a member of class TnxSqlUpdateHandler.

Group

TnxSqlUpdateHandler Fields

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Fields


TnxSqlUpdateHandler.suhSqlParamFields Field

TnxSqlUpdateHandler.suhSqlParamFields Field
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Fields Send Feedback
Syntax
Delphi
suhSqlParamFields: array[TUpdateKind] of array of Integer;
Description

= normal buffer, - = OldBuffer for modify

Group

TnxSqlUpdateHandler Fields

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Fields


TnxSqlUpdateHandler.suhSqlParams Field

TnxSqlUpdateHandler.suhSqlParams Field
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Fields Send Feedback
Syntax
Delphi
suhSqlParams: array[TUpdateKind] of TnxSqlParamList;
Description

This is suhSqlParams, a member of class TnxSqlUpdateHandler.

Group

TnxSqlUpdateHandler Fields

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Fields


TnxSqlUpdateHandler.suhSqlText Field

TnxSqlUpdateHandler.suhSqlText Field
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Fields Send Feedback
Syntax
Delphi
suhSqlText: array[TUpdateKind] of UnicodeString;
Description

private

Group

TnxSqlUpdateHandler Fields

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Fields


TnxSqlUpdateHandler.suhStatements Field

TnxSqlUpdateHandler.suhStatements Field
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Fields Send Feedback
Syntax
Delphi
suhStatements: array[TUpdateKind] of TnxAbstractStatement;
Description

This is suhStatements, a member of class TnxSqlUpdateHandler.

Group

TnxSqlUpdateHandler Fields

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Fields


TnxSqlUpdateHandler Methods

TnxSqlUpdateHandler Methods
TnxSqlUpdateHandler Class Legend Protected Methods Send Feedback

The methods of the TnxSqlUpdateHandler class are listed here.

Class

TnxSqlUpdateHandler Class

Protected Methods
Name | Description
buhNotifyDelete | TnxSqlUpdateHandler
buhNotifyInsert |
buhNotifyModify |
scStarting |
scStopping |
suhExecStatement |
suhParseSql |
Links
TnxSqlUpdateHandler Class, Legend, Protected Methods


TnxSqlUpdateHandler.buhNotifyDelete Method

TnxSqlUpdateHandler.buhNotifyDelete Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyDelete(aCursor: TnxAbstractCursor; aOldRecord: PnxByteArray); override;
Description

TnxSqlUpdateHandler

Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.buhNotifyInsert Method

TnxSqlUpdateHandler.buhNotifyInsert Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyInsert(aCursor: TnxAbstractCursor; aNewRecord: PnxByteArray); override;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.buhNotifyModify Method

TnxSqlUpdateHandler.buhNotifyModify Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure buhNotifyModify(aCursor: TnxAbstractCursor; aNewRecord: PnxByteArray; aOldRecord: PnxByteArray); override;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.scStarting Method

TnxSqlUpdateHandler.scStarting Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.scStopping Method

TnxSqlUpdateHandler.scStopping Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.suhExecStatement Method

TnxSqlUpdateHandler.suhExecStatement Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
procedure suhExecStatement(aUpdateKind: TUpdateKind; aCursor: TnxAbstractCursor; aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); virtual;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateHandler.suhParseSql Method

TnxSqlUpdateHandler.suhParseSql Method
TnxSqlUpdateHandler Class TnxSqlUpdateHandler Members nxdb Namespace TnxSqlUpdateHandler Methods Send Feedback
Syntax
Delphi
function suhParseSql(const aStmt: UnicodeString; out aParams: TnxSqlParamList): UnicodeString;
Group

TnxSqlUpdateHandler Methods

Links
TnxSqlUpdateHandler Class, TnxSqlUpdateHandler Members, nxdb Namespace, TnxSqlUpdateHandler Methods


TnxSqlUpdateObject Class

TnxSqlUpdateObject Class
TnxSqlUpdateObject Fields TnxSqlUpdateObject Methods TnxSqlUpdateObject Properties TnxSqlUpdateObject Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxSqlUpdateObjectnxdb_TnxSqlUpdateObjectnxdb_TnxSqlUpdateObjectnxdb_TnxSqlUpdateObjectnxdb_TnxSqlUpdateObject
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSqlUpdateObject = class(TnxBaseUpdateObject);
File

nxdb

Description

Update Object for updating a cached datasets source datasets using SQL Statements.

Group

Classes

Links
TnxSqlUpdateObject Fields, TnxSqlUpdateObject Methods, TnxSqlUpdateObject Properties, TnxSqlUpdateObject Members, nxdb, Classes


TnxSqlUpdateObject Members

TnxSqlUpdateObject Members
TnxSqlUpdateObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSqlUpdateObject.

Class

TnxSqlUpdateObject Class

Protected Fields
Name | Description
buoTargetDatabase | private
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
suoParams | This is suoParams, a member of class TnxSqlUpdateObject.
suoSqlText | private
Protected Methods
Name | Description
buoGetHandlerClass | TnxSqlUpdateObject
buoSetTargetDatabase |
DefineProperties |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
suoGetSql |
suoGetSqlIndex |
suoReadParams |
suoSetParams |
suoSetSql |
suoSetSqlIndex |
suoWriteParams |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create | constructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Sql | Gets/Sets the SQL statement for the given aUpdateKind.
Published Properties
Name | Description
DeleteSql | SQL script used to delete records from underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
InsertSql | SQL script used to insert new records to underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
ModifySql | SQL script used to update trecords of underlying datasets use :old$fieldname, :new$fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Params | see tQuery.Params
TargetDatabase | This is TargetDatabase, a member of class TnxBaseUpdateObject.
Version | Version of the component.
Links
TnxSqlUpdateObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxSqlUpdateObject.Create Constructor

TnxSqlUpdateObject.Create Constructor
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor

Class

TnxSqlUpdateObject Class

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Class


TnxSqlUpdateObject.Destroy Destructor

TnxSqlUpdateObject.Destroy Destructor
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor

Class

TnxSqlUpdateObject Class

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Class


TnxSqlUpdateObject Fields

TnxSqlUpdateObject Fields
TnxSqlUpdateObject Class Legend Protected Fields Send Feedback

The fields of the TnxSqlUpdateObject class are listed here.

Class

TnxSqlUpdateObject Class

Protected Fields
Name | Description
suoParams | This is suoParams, a member of class TnxSqlUpdateObject.
suoSqlText | private
Links
TnxSqlUpdateObject Class, Legend, Protected Fields


TnxSqlUpdateObject.suoParams Field

TnxSqlUpdateObject.suoParams Field
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Fields Send Feedback
Syntax
Delphi
suoParams: TParams;
Description

This is suoParams, a member of class TnxSqlUpdateObject.

Group

TnxSqlUpdateObject Fields

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Fields


TnxSqlUpdateObject.suoSqlText Field

TnxSqlUpdateObject.suoSqlText Field
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Fields Send Feedback
Syntax
Delphi
suoSqlText: array[TUpdateKind] of TStrings;
Description

private

Group

TnxSqlUpdateObject Fields

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Fields


TnxSqlUpdateObject Methods

TnxSqlUpdateObject Methods
TnxSqlUpdateObject Class Legend Protected Methods Send Feedback

The methods of the TnxSqlUpdateObject class are listed here.

Class

TnxSqlUpdateObject Class

Protected Methods
Name | Description
buoGetHandlerClass | TnxSqlUpdateObject
DefineProperties |
suoGetSql |
suoGetSqlIndex |
suoReadParams |
suoSetParams |
suoSetSql |
suoSetSqlIndex |
suoWriteParams |
Links
TnxSqlUpdateObject Class, Legend, Protected Methods


TnxSqlUpdateObject.buoGetHandlerClass Method

TnxSqlUpdateObject.buoGetHandlerClass Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
function buoGetHandlerClass: TnxBaseUpdateHandlerClass; override;
Description

TnxSqlUpdateObject

Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.DefineProperties Method

TnxSqlUpdateObject.DefineProperties Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure DefineProperties(Filer: TFiler); override;
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoGetSql Method

TnxSqlUpdateObject.suoGetSql Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
function suoGetSql(aUpdateKind: TUpdateKind): TStrings;
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoGetSqlIndex Method

TnxSqlUpdateObject.suoGetSqlIndex Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
function suoGetSqlIndex(aIndex: Integer): TStrings;
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoReadParams Method

TnxSqlUpdateObject.suoReadParams Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure suoReadParams(Reader: TReader);
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoSetParams Method

TnxSqlUpdateObject.suoSetParams Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure suoSetParams(aParams: TParams);
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoSetSql Method

TnxSqlUpdateObject.suoSetSql Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure suoSetSql(aUpdateKind: TUpdateKind; aValue: TStrings);
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoSetSqlIndex Method

TnxSqlUpdateObject.suoSetSqlIndex Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure suoSetSqlIndex(aIndex: Integer; aValue: TStrings);
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject.suoWriteParams Method

TnxSqlUpdateObject.suoWriteParams Method
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Methods Send Feedback
Syntax
Delphi
procedure suoWriteParams(Writer: TWriter);
Group

TnxSqlUpdateObject Methods

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Methods


TnxSqlUpdateObject Properties

TnxSqlUpdateObject Properties
TnxSqlUpdateObject Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxSqlUpdateObject class are listed here.

Class

TnxSqlUpdateObject Class

Public Properties
Name | Description
Sql | Gets/Sets the SQL statement for the given aUpdateKind.
Published Properties
Name | Description
DeleteSql | SQL script used to delete records from underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
InsertSql | SQL script used to insert new records to underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
ModifySql | SQL script used to update trecords of underlying datasets use :old$fieldname, :new$fieldname for specifying fieldvalues as parameters and param$paramname for original parameters
Params | see tQuery.Params
Links
TnxSqlUpdateObject Class, Legend, Public Properties, Published Properties


TnxSqlUpdateObject.DeleteSql Property

TnxSqlUpdateObject.DeleteSql Property
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Properties Send Feedback
Syntax
Delphi
property DeleteSql: TStrings;
Description

SQL script used to delete records from underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters

Group

TnxSqlUpdateObject Properties

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Properties


TnxSqlUpdateObject.InsertSql Property

TnxSqlUpdateObject.InsertSql Property
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Properties Send Feedback
Syntax
Delphi
property InsertSql: TStrings;
Description

SQL script used to insert new records to underlying datasets use $fieldname for specifying fieldvalues as parameters and param$paramname for original parameters

Group

TnxSqlUpdateObject Properties

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Properties


TnxSqlUpdateObject.ModifySql Property

TnxSqlUpdateObject.ModifySql Property
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Properties Send Feedback
Syntax
Delphi
property ModifySql: TStrings;
Description

SQL script used to update trecords of underlying datasets use :old$fieldname, :new$fieldname for specifying fieldvalues as parameters and param$paramname for original parameters

Group

TnxSqlUpdateObject Properties

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Properties


TnxSqlUpdateObject.Params Property

TnxSqlUpdateObject.Params Property
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace TnxSqlUpdateObject Properties Send Feedback
Syntax
Delphi
property Params: TParams;
Description

see tQuery.Params

Group

TnxSqlUpdateObject Properties

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, TnxSqlUpdateObject Properties


TnxSqlUpdateObject.Sql Property

TnxSqlUpdateObject.Sql Property
TnxSqlUpdateObject Class TnxSqlUpdateObject Members nxdb Namespace Example TnxSqlUpdateObject Properties Send Feedback
Syntax
Delphi
property Sql [aUpdateKind: TUpdateKind]: TStrings;
Description

Gets/Sets the SQL statement for the given aUpdateKind.

Example

query (in TnxQuery connected via SourceDataSet): SELECT OrderID, CustomerID FROM Orders WHERE ShipVia = 2 insert: INSERT INTO Orders (OrderID, CustomerID, ShipVia) VALUES (:OrderID, :CustomerID, :param$ShipVia) modify: UPDATE Orders SET OrderID = :OrderID; Customer = :CustomerID WHERE OrderID = :old$OrderID delete: DELETE FROM Orders WHERE OrderID = :OrderID

and add to the Params collection a param called "ShipVia", type ftInteger, value 2

Group

TnxSqlUpdateObject Properties

Links
TnxSqlUpdateObject Class, TnxSqlUpdateObject Members, nxdb Namespace, Example, TnxSqlUpdateObject Properties


TnxStatementDataSet Class

TnxStatementDataSet Class
TnxStatementDataSet Fields TnxStatementDataSet Methods TnxStatementDataSet Properties TnxStatementDataSet Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxStatementDataSetnxdb_TnxStatementDataSet
Syntax
Delphi
TnxStatementDataSet = class(TnxDataset);
File

nxdb

Description

TQuery compatible implementation of a Nexus Sql Query

Group

Classes

Links
TnxStatementDataSet Fields, TnxStatementDataSet Methods, TnxStatementDataSet Properties, TnxStatementDataSet Members, nxdb, Classes


TnxStatementDataSet Members

TnxStatementDataSet Members
TnxStatementDataSet Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxStatementDataSet.

Class

TnxStatementDataSet Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
sdAbstractStatement | private
sdCanModify | This is sdCanModify, a member of class TnxStatementDataSet.
sdDataLink | This is sdDataLink, a member of class TnxStatementDataSet.
sdExecuted | This is sdExecuted, a member of class TnxStatementDataSet.
sdLog | This is sdLog, a member of class TnxStatementDataSet.
sdNoResultSetNeeded | This is sdNoResultSetNeeded, a member of class TnxStatementDataSet.
sdParams | This is sdParams, a member of class TnxStatementDataSet.
sdReadOnly | This is sdReadOnly, a member of class TnxStatementDataSet.
sdRecordsRead | This is sdRecordsRead, a member of class TnxStatementDataSet.
sdRequestLive | This is sdRequestLive, a member of class TnxStatementDataSet.
sdRowsAffected | This is sdRowsAffected, a member of class TnxStatementDataSet.
sdWasPrepared | This is sdWasPrepared, a member of class TnxStatementDataSet.
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DefineProperties | virtual TComponent methods == custom properties.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | == internal functions == -- open/close
dsRefreshTimeout | misc
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | == virtual TDataSet methods == -- info
GetFieldClass |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSExecute | IProviderSupport
PSGetParams |
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
sdApplyParams |
sdBuildParams |
sdExec |
sdGetDataSource |
sdGetParamCount |
sdGetPrepared | property access methods.
sdGetQueryInfo | This is sdGetQueryInfo, a member of class TnxStatementDataSet.
sdHandleError | This is the overview for the sdHandleError method overload.
sdReadParams | custom properties.
sdRefreshParams | params.
sdSetDataSource |
sdSetParams |
sdSetParamsFromCursor |
sdSetPrepared |
sdSetRequestLive |
sdWriteParams |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor. TnxStatementDataSet
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
ParamByName | see tQuery.ParamByName
Post | == virtual TDataSet methods == -- navigation
PostAndEdit |
Prepare | see tQuery.Prepare
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
Unprepare | see tQuery.UnPrepare
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
Log | Log returns a detailed analysis of the Query. You need to at least Prepare the Query for Log to be updated.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
ParamCount | see tQuery.ParamCount
Prepared | see tQuery.Prepared
RecordsRead | RecordsRead is set after calling ExecSql and the value indicates how many records were read.
RowsAffected | see tQuery.RowsAffected
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
DataSource | see tQuery.DataSource.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Params | see tQuery.Params
ReadOnly | Prevents modification of a live result set.
RequestLive | Only supported for "SELECT * FROM tablename" type queries currently.
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxStatementDataSet Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxStatementDataSet.Create Constructor

TnxStatementDataSet.Create Constructor
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

TnxStatementDataSet

Class

TnxStatementDataSet Class

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Class


TnxStatementDataSet.Destroy Destructor

TnxStatementDataSet.Destroy Destructor
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxStatementDataSet Class

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Class


TnxStatementDataSet Fields

TnxStatementDataSet Fields
TnxStatementDataSet Class Legend Protected Fields Send Feedback

The fields of the TnxStatementDataSet class are listed here.

Class

TnxStatementDataSet Class

Protected Fields
Name | Description
sdAbstractStatement | private
sdCanModify | This is sdCanModify, a member of class TnxStatementDataSet.
sdDataLink | This is sdDataLink, a member of class TnxStatementDataSet.
sdExecuted | This is sdExecuted, a member of class TnxStatementDataSet.
sdLog | This is sdLog, a member of class TnxStatementDataSet.
sdNoResultSetNeeded | This is sdNoResultSetNeeded, a member of class TnxStatementDataSet.
sdParams | This is sdParams, a member of class TnxStatementDataSet.
sdReadOnly | This is sdReadOnly, a member of class TnxStatementDataSet.
sdRecordsRead | This is sdRecordsRead, a member of class TnxStatementDataSet.
sdRequestLive | This is sdRequestLive, a member of class TnxStatementDataSet.
sdRowsAffected | This is sdRowsAffected, a member of class TnxStatementDataSet.
sdWasPrepared | This is sdWasPrepared, a member of class TnxStatementDataSet.
Links
TnxStatementDataSet Class, Legend, Protected Fields


TnxStatementDataSet.sdAbstractStatement Field

TnxStatementDataSet.sdAbstractStatement Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdAbstractStatement: TnxAbstractStatement;
Description

private

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdCanModify Field

TnxStatementDataSet.sdCanModify Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdCanModify: Boolean;
Description

This is sdCanModify, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdDataLink Field

TnxStatementDataSet.sdDataLink Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdDataLink: TnxStatementDataSetDataLink;
Description

This is sdDataLink, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdExecuted Field

TnxStatementDataSet.sdExecuted Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdExecuted: Boolean;
Description

This is sdExecuted, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdLog Field

TnxStatementDataSet.sdLog Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdLog: TStringList;
Description

This is sdLog, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdNoResultSetNeeded Field

TnxStatementDataSet.sdNoResultSetNeeded Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdNoResultSetNeeded: Boolean;
Description

This is sdNoResultSetNeeded, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdParams Field

TnxStatementDataSet.sdParams Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdParams: TParams;
Description

This is sdParams, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdReadOnly Field

TnxStatementDataSet.sdReadOnly Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdReadOnly: Boolean;
Description

This is sdReadOnly, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdRecordsRead Field

TnxStatementDataSet.sdRecordsRead Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdRecordsRead: Integer;
Description

This is sdRecordsRead, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdRequestLive Field

TnxStatementDataSet.sdRequestLive Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdRequestLive: Boolean;
Description

This is sdRequestLive, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdRowsAffected Field

TnxStatementDataSet.sdRowsAffected Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdRowsAffected: Integer;
Description

This is sdRowsAffected, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet.sdWasPrepared Field

TnxStatementDataSet.sdWasPrepared Field
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Fields Send Feedback
Syntax
Delphi
sdWasPrepared: Boolean;
Description

This is sdWasPrepared, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Fields

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Fields


TnxStatementDataSet Methods

TnxStatementDataSet Methods
TnxStatementDataSet Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStatementDataSet class are listed here.

Class

TnxStatementDataSet Class

Protected Methods
Name | Description
DefineProperties | virtual TComponent methods == custom properties.
dsCheckInactiveFromCursor |
dsOpenCursorID | == internal functions == -- open/close
dsRefreshTimeout | misc
dsShutdownFromCursor |
GetCanModify | == virtual TDataSet methods == -- info
PSExecute | IProviderSupport
PSGetParams |
PSSetParams |
sdApplyParams |
sdBuildParams |
sdExec |
sdGetDataSource |
sdGetParamCount |
sdGetPrepared | property access methods.
sdGetQueryInfo | This is sdGetQueryInfo, a member of class TnxStatementDataSet.
sdHandleError | This is the overview for the sdHandleError method overload.
sdReadParams | custom properties.
sdRefreshParams | params.
sdSetDataSource |
sdSetParams |
sdSetParamsFromCursor |
sdSetPrepared |
sdSetRequestLive |
sdWriteParams |
Public Methods
Name | Description
ParamByName | see tQuery.ParamByName
Prepare | see tQuery.Prepare
Unprepare | see tQuery.UnPrepare
Links
TnxStatementDataSet Class, Legend, Protected Methods, Public Methods


TnxStatementDataSet.DefineProperties Method

TnxStatementDataSet.DefineProperties Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure DefineProperties(Filer: TFiler); override;
Description

virtual TComponent methods == custom properties.

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.dsCheckInactiveFromCursor Method

TnxStatementDataSet.dsCheckInactiveFromCursor Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure dsCheckInactiveFromCursor; override;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.dsOpenCursorID Method

TnxStatementDataSet.dsOpenCursorID Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure dsOpenCursorID; override;
Description

== internal functions == -- open/close

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.dsRefreshTimeout Method

TnxStatementDataSet.dsRefreshTimeout Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure dsRefreshTimeout; override;
Description

misc

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.dsShutdownFromCursor Method

TnxStatementDataSet.dsShutdownFromCursor Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure dsShutdownFromCursor; override;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.GetCanModify Method

TnxStatementDataSet.GetCanModify Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function GetCanModify: Boolean; override;
Description

== virtual TDataSet methods == -- info

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.ParamByName Method

TnxStatementDataSet.ParamByName Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function ParamByName(const aName: string): TParam;
Description

see tQuery.ParamByName

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.Prepare Method

TnxStatementDataSet.Prepare Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure Prepare; virtual;
Description

see tQuery.Prepare

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.PSExecute Method

TnxStatementDataSet.PSExecute Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure PSExecute; override;
Description

IProviderSupport

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.PSGetParams Method

TnxStatementDataSet.PSGetParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function PSGetParams: TParams; override;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.PSSetParams Method

TnxStatementDataSet.PSSetParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure PSSetParams(aParams: TParams); override;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdApplyParams Method

TnxStatementDataSet.sdApplyParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdApplyParams(const aParamsList: TnxSqlParamList);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdBuildParams Method

TnxStatementDataSet.sdBuildParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdBuildParams(var aParamsList: TnxSqlParamList; var aNeedsGet: Boolean);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdExec Method

TnxStatementDataSet.sdExec Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdExec;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdGetDataSource Method

TnxStatementDataSet.sdGetDataSource Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function sdGetDataSource: TDataSource;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdGetParamCount Method

TnxStatementDataSet.sdGetParamCount Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function sdGetParamCount: Word;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdGetPrepared Method

TnxStatementDataSet.sdGetPrepared Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function sdGetPrepared: Boolean;
Description

property access methods.

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdGetQueryInfo Method

TnxStatementDataSet.sdGetQueryInfo Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
function sdGetQueryInfo(out aText: UnicodeString): TnxStatementType; abstract; dynamic;
Description

This is sdGetQueryInfo, a member of class TnxStatementDataSet.

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


sdHandleError Method

sdHandleError Method
TnxStatementDataSet Methods Send Feedback

This is the overview for the sdHandleError method overload.

Overload List
Name | Description
TnxStatementDataSet.sdHandleError (TnxResult, PResStringRec, TStream) |
TnxStatementDataSet.sdHandleError (TnxResult, string, TStream) |
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Methods


TnxStatementDataSet.sdHandleError Method (TnxResult, PResStringRec, TStream)

TnxStatementDataSet.sdHandleError Method (TnxResult, PResStringRec, TStream)
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace sdHandleError Method Send Feedback
Syntax
Delphi
procedure sdHandleError(aResult: TnxResult; aMsgRes: PResStringRec; aStream: TStream); overload;
Group

sdHandleError Method

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, sdHandleError Method


TnxStatementDataSet.sdHandleError Method (TnxResult, string, TStream)

TnxStatementDataSet.sdHandleError Method (TnxResult, string, TStream)
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace sdHandleError Method Send Feedback
Syntax
Delphi
procedure sdHandleError(aResult: TnxResult; const aMsg: string; aStream: TStream); overload;
Group

sdHandleError Method

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, sdHandleError Method


TnxStatementDataSet.sdReadParams Method

TnxStatementDataSet.sdReadParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdReadParams(Reader: TReader);
Description

custom properties.

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdRefreshParams Method

TnxStatementDataSet.sdRefreshParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdRefreshParams;
Description

params.

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdSetDataSource Method

TnxStatementDataSet.sdSetDataSource Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdSetDataSource(aDataSource: TDataSource);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdSetParams Method

TnxStatementDataSet.sdSetParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdSetParams(aParams: TParams);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdSetParamsFromCursor Method

TnxStatementDataSet.sdSetParamsFromCursor Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdSetParamsFromCursor;
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdSetPrepared Method

TnxStatementDataSet.sdSetPrepared Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdSetPrepared(aValue: Boolean);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdSetRequestLive Method

TnxStatementDataSet.sdSetRequestLive Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdSetRequestLive(aValue: Boolean);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.sdWriteParams Method

TnxStatementDataSet.sdWriteParams Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure sdWriteParams(Writer: TWriter);
Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet.Unprepare Method

TnxStatementDataSet.Unprepare Method
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Methods Send Feedback
Syntax
Delphi
procedure Unprepare;
Description

see tQuery.UnPrepare

Group

TnxStatementDataSet Methods

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Methods


TnxStatementDataSet Properties

TnxStatementDataSet Properties
TnxStatementDataSet Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxStatementDataSet class are listed here.

Class

TnxStatementDataSet Class

Public Properties
Name | Description
Log | Log returns a detailed analysis of the Query. You need to at least Prepare the Query for Log to be updated.
ParamCount | see tQuery.ParamCount
Prepared | see tQuery.Prepared
RecordsRead | RecordsRead is set after calling ExecSql and the value indicates how many records were read.
RowsAffected | see tQuery.RowsAffected
Published Properties
Name | Description
DataSource | see tQuery.DataSource.
Params | see tQuery.Params
ReadOnly | Prevents modification of a live result set.
RequestLive | Only supported for "SELECT * FROM tablename" type queries currently.
Links
TnxStatementDataSet Class, Legend, Public Properties, Published Properties


TnxStatementDataSet.DataSource Property

TnxStatementDataSet.DataSource Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property DataSource: TDataSource;
Description

see tQuery.DataSource.

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.Log Property

TnxStatementDataSet.Log Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property Log: TStringList;
Description

Log returns a detailed analysis of the Query. You need to at least Prepare the Query for Log to be updated.

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.ParamCount Property

TnxStatementDataSet.ParamCount Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property ParamCount: Word;
Description

see tQuery.ParamCount

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.Params Property

TnxStatementDataSet.Params Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property Params: TParams;
Description

see tQuery.Params

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.Prepared Property

TnxStatementDataSet.Prepared Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property Prepared: Boolean;
Description

see tQuery.Prepared

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.ReadOnly Property

TnxStatementDataSet.ReadOnly Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property ReadOnly: Boolean;
Description

Prevents modification of a live result set.

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.RecordsRead Property

TnxStatementDataSet.RecordsRead Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property RecordsRead: Integer;
Description

RecordsRead is set after calling ExecSql and the value indicates how many records were read.

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.RequestLive Property

TnxStatementDataSet.RequestLive Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property RequestLive: boolean;
Description

Only supported for "SELECT * FROM tablename" type queries currently.

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSet.RowsAffected Property

TnxStatementDataSet.RowsAffected Property
TnxStatementDataSet Class TnxStatementDataSet Members nxdb Namespace TnxStatementDataSet Properties Send Feedback
Syntax
Delphi
property RowsAffected: Integer;
Description

see tQuery.RowsAffected

Group

TnxStatementDataSet Properties

Links
TnxStatementDataSet Class, TnxStatementDataSet Members, nxdb Namespace, TnxStatementDataSet Properties


TnxStatementDataSetDataLink Class

TnxStatementDataSetDataLink Class
TnxStatementDataSetDataLink Fields TnxStatementDataSetDataLink Methods TnxStatementDataSetDataLink Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxStatementDataSetDataLink
Syntax
Delphi
TnxStatementDataSetDataLink = class(TDetailDataLink);
File

nxdb

Description

DOM-IGNORE-BEGIN Used internally by the query, if you set TnxStatementDataSet.DataSource. This object is used to manage that link.

Group

Classes

Links
TnxStatementDataSetDataLink Fields, TnxStatementDataSetDataLink Methods, TnxStatementDataSetDataLink Members, nxdb, Classes


TnxStatementDataSetDataLink Members

TnxStatementDataSetDataLink Members
TnxStatementDataSetDataLink Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxStatementDataSetDataLink.

Class

TnxStatementDataSetDataLink Class

Protected Fields
Name | Description
sddlStatementDataSet | private
Protected Methods
Name | Description
ActiveChanged | TnxStatementDataSetDataLink
CheckBrowseMode |
GetDetailDataSet |
RecordChanged |
Public Methods
Name | Description
Create | constructor.
Links
TnxStatementDataSetDataLink Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxStatementDataSetDataLink.Create Constructor

TnxStatementDataSetDataLink.Create Constructor
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Class Send Feedback
Syntax
Delphi
constructor Create(aStatementDataSet: TnxStatementDataSet);
Description

constructor.

Class

TnxStatementDataSetDataLink Class

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Class


TnxStatementDataSetDataLink Fields

TnxStatementDataSetDataLink Fields
TnxStatementDataSetDataLink Class Legend Protected Fields Send Feedback

The fields of the TnxStatementDataSetDataLink class are listed here.

Class

TnxStatementDataSetDataLink Class

Protected Fields
Name | Description
sddlStatementDataSet | private
Links
TnxStatementDataSetDataLink Class, Legend, Protected Fields


TnxStatementDataSetDataLink.sddlStatementDataSet Field

TnxStatementDataSetDataLink.sddlStatementDataSet Field
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Fields Send Feedback
Syntax
Delphi
sddlStatementDataSet: TnxStatementDataSet;
Description

private

Group

TnxStatementDataSetDataLink Fields

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Fields


TnxStatementDataSetDataLink Methods

TnxStatementDataSetDataLink Methods
TnxStatementDataSetDataLink Class Legend Protected Methods Send Feedback

The methods of the TnxStatementDataSetDataLink class are listed here.

Class

TnxStatementDataSetDataLink Class

Protected Methods
Name | Description
ActiveChanged | TnxStatementDataSetDataLink
CheckBrowseMode |
GetDetailDataSet |
RecordChanged |
Links
TnxStatementDataSetDataLink Class, Legend, Protected Methods


TnxStatementDataSetDataLink.ActiveChanged Method

TnxStatementDataSetDataLink.ActiveChanged Method
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Methods Send Feedback
Syntax
Delphi
procedure ActiveChanged; override;
Description

TnxStatementDataSetDataLink

Group

TnxStatementDataSetDataLink Methods

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Methods


TnxStatementDataSetDataLink.CheckBrowseMode Method

TnxStatementDataSetDataLink.CheckBrowseMode Method
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Methods Send Feedback
Syntax
Delphi
procedure CheckBrowseMode; override;
Group

TnxStatementDataSetDataLink Methods

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Methods


TnxStatementDataSetDataLink.GetDetailDataSet Method

TnxStatementDataSetDataLink.GetDetailDataSet Method
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Methods Send Feedback
Syntax
Delphi
function GetDetailDataSet: TDataSet; override;
Group

TnxStatementDataSetDataLink Methods

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Methods


TnxStatementDataSetDataLink.RecordChanged Method

TnxStatementDataSetDataLink.RecordChanged Method
TnxStatementDataSetDataLink Class TnxStatementDataSetDataLink Members nxdb Namespace TnxStatementDataSetDataLink Methods Send Feedback
Syntax
Delphi
procedure RecordChanged(Field: TField); override;
Group

TnxStatementDataSetDataLink Methods

Links
TnxStatementDataSetDataLink Class, TnxStatementDataSetDataLink Members, nxdb Namespace, TnxStatementDataSetDataLink Methods


TnxStoredProc Class

TnxStoredProc Class
TnxStoredProc Fields TnxStoredProc Methods TnxStoredProc Properties TnxStoredProc Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxStoredProcnxdb_TnxStoredProcnxdb_TnxStoredProc
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxStoredProc = class(TnxStatementDataSet);
File

nxdb

Description

This class is the client side representation of a stored procedure.

Group

Classes

Links
TnxStoredProc Fields, TnxStoredProc Methods, TnxStoredProc Properties, TnxStoredProc Members, nxdb, Classes


TnxStoredProc Members

TnxStoredProc Members
TnxStoredProc Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxStoredProc.

Class

TnxStoredProc Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
sdAbstractStatement | private
sdCanModify | This is sdCanModify, a member of class TnxStatementDataSet.
sdDataLink | This is sdDataLink, a member of class TnxStatementDataSet.
sdExecuted | This is sdExecuted, a member of class TnxStatementDataSet.
sdLog | This is sdLog, a member of class TnxStatementDataSet.
sdNoResultSetNeeded | This is sdNoResultSetNeeded, a member of class TnxStatementDataSet.
sdParams | This is sdParams, a member of class TnxStatementDataSet.
sdReadOnly | This is sdReadOnly, a member of class TnxStatementDataSet.
sdRecordsRead | This is sdRecordsRead, a member of class TnxStatementDataSet.
sdRequestLive | This is sdRequestLive, a member of class TnxStatementDataSet.
sdRowsAffected | This is sdRowsAffected, a member of class TnxStatementDataSet.
sdWasPrepared | This is sdWasPrepared, a member of class TnxStatementDataSet.
spStoredProcName | private
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DefineProperties | virtual TComponent methods == custom properties.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | open/close.
dsOpenCursorID | == internal functions == -- open/close
dsRefreshTimeout | misc.
dsRefreshTimeout | misc
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | info.
GetCanModify | == virtual TDataSet methods == -- info
GetFieldClass |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSExecute | IProviderSupport
PSGetParams |
PSSetCommandText | == virtual TDataSet methods == -- IProviderSupport
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
sdApplyParams |
sdBuildParams |
sdExec |
sdGetDataSource |
sdGetParamCount |
sdGetPrepared | property access methods.
sdGetQueryInfo | misc
sdHandleError | This is the overview for the sdHandleError method overload.
sdReadParams | custom properties.
sdRefreshParams | params.
sdSetDataSource |
sdSetParams |
sdSetParamsFromCursor |
sdSetPrepared |
sdSetRequestLive |
sdWriteParams |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
spCreateParams | params
spSetStoredProcName |
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AfterConstruction | see TDataSet.AfterConstruction
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
Create | constructor. TnxStatementDataSet
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
Destroy | destructor.
Destroy | destructor.
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
ExecProc | see tQuery.ExecSql TnxStoredProc
Exists | Exists returns true if this table exists, in the given session/database context. It can be called without opening the table.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
ParamByName | see tQuery.ParamByName
Post | == virtual TDataSet methods == -- navigation
PostAndEdit |
Prepare | see tQuery.Prepare
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
RefreshParam | Refreshed all Parameters.
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
Unprepare | see tQuery.UnPrepare
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
Log | Log returns a detailed analysis of the Query. You need to at least Prepare the Query for Log to be updated.
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
ParamCount | see tQuery.ParamCount
Prepared | see tQuery.Prepared
RecordsRead | RecordsRead is set after calling ExecSql and the value indicates how many records were read.
RowsAffected | see tQuery.RowsAffected
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
DataSource | see tQuery.DataSource.
Eof | This is Eof, a member of class TnxDataset.
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Params | see tQuery.Params
ReadOnly | Prevents modification of a live result set.
RequestLive | Only supported for "SELECT * FROM tablename" type queries currently.
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
StoredProcName | The SQL name of the procedure.
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
Links
TnxStoredProc Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxStoredProc Fields

TnxStoredProc Fields
TnxStoredProc Class Legend Protected Fields Send Feedback

The fields of the TnxStoredProc class are listed here.

Class

TnxStoredProc Class

Protected Fields
Name | Description
spStoredProcName | private
Links
TnxStoredProc Class, Legend, Protected Fields


TnxStoredProc.spStoredProcName Field

TnxStoredProc.spStoredProcName Field
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Fields Send Feedback
Syntax
Delphi
spStoredProcName: string;
Description

private

Group

TnxStoredProc Fields

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Fields


TnxStoredProc Methods

TnxStoredProc Methods
TnxStoredProc Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStoredProc class are listed here.

Class

TnxStoredProc Class

Protected Methods
Name | Description
PSSetCommandText | == virtual TDataSet methods == -- IProviderSupport
sdGetQueryInfo | misc
spCreateParams | params
spSetStoredProcName |
Public Methods
Name | Description
ExecProc | see tQuery.ExecSql TnxStoredProc
Prepare | see tQuery.Prepare
RefreshParam | Refreshed all Parameters.
Links
TnxStoredProc Class, Legend, Protected Methods, Public Methods


TnxStoredProc.ExecProc Method

TnxStoredProc.ExecProc Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure ExecProc;
Description

see tQuery.ExecSql

TnxStoredProc

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.Prepare Method

TnxStoredProc.Prepare Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure Prepare; override;
Description

see tQuery.Prepare

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.PSSetCommandText Method

TnxStoredProc.PSSetCommandText Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure PSSetCommandText(const aCommandText: string); override;
Description

== virtual TDataSet methods == -- IProviderSupport

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.RefreshParam Method

TnxStoredProc.RefreshParam Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure RefreshParam; virtual;
Description

Refreshed all Parameters.

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.sdGetQueryInfo Method

TnxStoredProc.sdGetQueryInfo Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
function sdGetQueryInfo(out aText: UnicodeString): TnxStatementType; override;
Description

misc

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.spCreateParams Method

TnxStoredProc.spCreateParams Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure spCreateParams;
Description

params

Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc.spSetStoredProcName Method

TnxStoredProc.spSetStoredProcName Method
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Methods Send Feedback
Syntax
Delphi
procedure spSetStoredProcName(const Value: string);
Group

TnxStoredProc Methods

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Methods


TnxStoredProc Properties

TnxStoredProc Properties
TnxStoredProc Class Legend Published Properties Send Feedback

The properties of the TnxStoredProc class are listed here.

Class

TnxStoredProc Class

Published Properties
Name | Description
StoredProcName | The SQL name of the procedure.
Links
TnxStoredProc Class, Legend, Published Properties


TnxStoredProc.StoredProcName Property

TnxStoredProc.StoredProcName Property
TnxStoredProc Class TnxStoredProc Members nxdb Namespace TnxStoredProc Properties Send Feedback
Syntax
Delphi
property StoredProcName: string;
Description

The SQL name of the procedure.

Group

TnxStoredProc Properties

Links
TnxStoredProc Class, TnxStoredProc Members, nxdb Namespace, TnxStoredProc Properties


TnxStringField Class

TnxStringField Class
TnxStringField Fields TnxStringField Methods TnxStringField Properties TnxStringField Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxStringField
Syntax
Delphi
TnxStringField = class(TStringField);
File

nxdb

Description

Extended field class for string fields.

Group

Classes

Links
TnxStringField Fields, TnxStringField Methods, TnxStringField Properties, TnxStringField Members, nxdb, Classes


TnxStringField Members

TnxStringField Members
TnxStringField Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxStringField.

Class

TnxStringField Class

Protected Fields
Name | Description
sfCodePage | private
Protected Methods
Name | Description
Bind | TnxStringField
Public Methods
Name | Description
GetAsAnsiString |
GetAsString |
GetAsVariant |
GetAsWideString |
SetAsAnsiString |
SetAsString |
SetAsWideString |
SetVarValue |
Public Properties
Name | Description
AsWideString | Returns the Value as UnicodeString.
Links
TnxStringField Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxStringField Fields

TnxStringField Fields
TnxStringField Class Legend Protected Fields Send Feedback

The fields of the TnxStringField class are listed here.

Class

TnxStringField Class

Protected Fields
Name | Description
sfCodePage | private
Links
TnxStringField Class, Legend, Protected Fields


TnxStringField.sfCodePage Field

TnxStringField.sfCodePage Field
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Fields Send Feedback
Syntax
Delphi
sfCodePage: Word;
Description

private

Group

TnxStringField Fields

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Fields


TnxStringField Methods

TnxStringField Methods
TnxStringField Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStringField class are listed here.

Class

TnxStringField Class

Protected Methods
Name | Description
Bind | TnxStringField
Public Methods
Name | Description
GetAsAnsiString |
GetAsString |
GetAsVariant |
GetAsWideString |
SetAsAnsiString |
SetAsString |
SetAsWideString |
SetVarValue |
Links
TnxStringField Class, Legend, Protected Methods, Public Methods


TnxStringField.Bind Method

TnxStringField.Bind Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
procedure Bind(Binding: Boolean); override;
Description

TnxStringField

Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.GetAsAnsiString Method

TnxStringField.GetAsAnsiString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
function GetAsAnsiString: AnsiString; override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.GetAsString Method

TnxStringField.GetAsString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
function GetAsString: string; override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.GetAsVariant Method

TnxStringField.GetAsVariant Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
function GetAsVariant: Variant; override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.GetAsWideString Method

TnxStringField.GetAsWideString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
function GetAsWideString: UnicodeString; override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.SetAsAnsiString Method

TnxStringField.SetAsAnsiString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
procedure SetAsAnsiString(const Value: AnsiString); override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.SetAsString Method

TnxStringField.SetAsString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
procedure SetAsString(const Value: string); override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.SetAsWideString Method

TnxStringField.SetAsWideString Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
procedure SetAsWideString(const Value: UnicodeString); override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField.SetVarValue Method

TnxStringField.SetVarValue Method
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Methods Send Feedback
Syntax
Delphi
procedure SetVarValue(const Value: Variant); override;
Group

TnxStringField Methods

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Methods


TnxStringField Properties

TnxStringField Properties
TnxStringField Class Legend Public Properties Send Feedback

The properties of the TnxStringField class are listed here.

Class

TnxStringField Class

Public Properties
Name | Description
AsWideString | Returns the Value as UnicodeString.
Links
TnxStringField Class, Legend, Public Properties


TnxStringField.AsWideString Property

TnxStringField.AsWideString Property
TnxStringField Class TnxStringField Members nxdb Namespace TnxStringField Properties Send Feedback
Syntax
Delphi
property AsWideString: UnicodeString;
Description

Returns the Value as UnicodeString.

Group

TnxStringField Properties

Links
TnxStringField Class, TnxStringField Members, nxdb Namespace, TnxStringField Properties


TnxTable Class

TnxTable Class
TnxTable Fields TnxTable Methods TnxTable Properties TnxTable Events TnxTable Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxTablenxdb_TnxTablenxdb_TnxTable
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxTable = class(TnxIndexDataSet);
File

nxdb

Description

TnxTable is a TTable compatible implementation of a NexusDB dataset.

Group

Classes

Links
TnxTable Fields, TnxTable Methods, TnxTable Properties, TnxTable Events, TnxTable Members, nxdb, Classes


TnxTable Members

TnxTable Members
TnxTable Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxTable.

Class

TnxTable Class

Protected Fields
Name | Description
ds_Dictionary | This is ds_Dictionary, a member of class TnxDataset.
dsAbstractCursor | This is dsAbstractCursor, a member of class TnxDataset.
dsActiveDesigntime | This is dsActiveDesigntime, a member of class TnxDataset.
dsActiveRuntime | private
dsAliasName | This is dsAliasName, a member of class TnxDataset.
dsBatchAppend | batch append.
dsBatchAppendBlobs | This is dsBatchAppendBlobs, a member of class TnxDataset.
dsBatchAppendCutoff | This is dsBatchAppendCutoff, a member of class TnxDataset.
dsBatchAppendData | This is dsBatchAppendData, a member of class TnxDataset.
dsBatchAppendRecordCount | This is dsBatchAppendRecordCount, a member of class TnxDataset.
dsBatchAppendStartOffset | This is dsBatchAppendStartOffset, a member of class TnxDataset.
dsBlobFields | This is dsBlobFields, a member of class TnxDataset.
dsBlobStreamsHead | blob streams.
dsBlobStreamsTail | This is dsBlobStreamsTail, a member of class TnxDataset.
dsBlockReadCount | This is dsBlockReadCount, a member of class TnxDataset.
dsBlockReadEof | This is dsBlockReadEof, a member of class TnxDataset.
dsBlockReadOptions | This is dsBlockReadOptions, a member of class TnxDataset.
dsBlockReadPos | This is dsBlockReadPos, a member of class TnxDataset.
dsBlockReadSize | block read mode.
dsBlockReadStream | This is dsBlockReadStream, a member of class TnxDataset.
dsBof | This is dsBof, a member of class TnxDataset.
dsCursor | cursor.
dsDeactivating | This is dsDeactivating, a member of class TnxDataset.
dsDefaultValueHandler | This is dsDefaultValueHandler, a member of class TnxDataset.
dsEof | This is dsEof, a member of class TnxDataset.
dsExprFilter | This is dsExprFilter, a member of class TnxDataset.
dsFieldsDescriptor | This is dsFieldsDescriptor, a member of class TnxDataset.
dsFilterResync | filter.
dsFilterTimeout | This is dsFilterTimeout, a member of class TnxDataset.
dsFilterType | This is dsFilterType, a member of class TnxDataset.
dsFlipOrder | This is dsFlipOrder, a member of class TnxDataset.
dsFuncFilter | This is dsFuncFilter, a member of class TnxDataset.
dsIgnoreDataEvents | This is dsIgnoreDataEvents, a member of class TnxDataset.
dsIgnoreReadOnly | This is dsIgnoreReadOnly, a member of class TnxDataset.
dsInsideScroll | workarounds for crappy Borland bugs
dsInternalState | This is dsInternalState, a member of class TnxDataset.
dsInternalWriteOnly | This is dsInternalWriteOnly, a member of class TnxDataset.
dsLookupOptions | lookup
dsMapperFieldOffset | This is dsMapperFieldOffset, a member of class TnxDataset.
dsMapperList | This is dsMapperList, a member of class TnxDataset.
dsMapperNexusToVcl | field access.
dsMappers | This is dsMappers, a member of class TnxDataset.
dsMapperVclToNexus | This is dsMapperVclToNexus, a member of class TnxDataset.
dsOffsetBookmark | This is dsOffsetBookmark, a member of class TnxDataset.
dsOffsetCalcFlds | This is dsOffsetCalcFlds, a member of class TnxDataset.
dsOffsetRecInfos | This is dsOffsetRecInfos, a member of class TnxDataset.
dsOldValuesBuffer | This is dsOldValuesBuffer, a member of class TnxDataset.
dsOnServerFilterTimeout | This is dsOnServerFilterTimeout, a member of class TnxDataset.
dsOptions | state.
dsRecordBufferCount | This is dsRecordBufferCount, a member of class TnxDataset.
dsRecordBufferPool | This is dsRecordBufferPool, a member of class TnxDataset.
dsRecordBufferSize | This is dsRecordBufferSize, a member of class TnxDataset.
dsRecordLength | record buffer.
dsRecordToFilter | This is dsRecordToFilter, a member of class TnxDataset.
dsRecRevField | This is dsRecRevField, a member of class TnxDataset.
dsSession | This is dsSession, a member of class TnxDataset.
dsSimpleExpressionFilterClass | This is dsSimpleExpressionFilterClass, a member of class TnxDataset.
dsSqlFilterClass | This is dsSqlFilterClass, a member of class TnxDataset.
dsTableDescriptor | This is dsTableDescriptor, a member of class TnxDataset.
dsTimeout | This is dsTimeout, a member of class TnxDataset.
dsValidationsHandler | This is dsValidationsHandler, a member of class TnxDataset.
dsWriteOnly | This is dsWriteOnly, a member of class TnxDataset.
idDefaultIndex | This is idDefaultIndex, a member of class TnxIndexDataSet.
idDirectKeySetFields | This is idDirectKeySetFields, a member of class TnxIndexDataSet.
idFieldsIndex | current index.
idIndexDefs | private index management.
idIndexDirectKey | This is idIndexDirectKey, a member of class TnxIndexDataSet.
idIndexFieldMap | This is idIndexFieldMap, a member of class TnxIndexDataSet.
idIndexFieldMapNC | This is idIndexFieldMapNC, a member of class TnxIndexDataSet.
idIndexFieldNames | This is idIndexFieldNames, a member of class TnxIndexDataSet.
idIndexKeySize | This is idIndexKeySize, a member of class TnxIndexDataSet.
idIndexName | This is idIndexName, a member of class TnxIndexDataSet.
idKeyBuffer | This is idKeyBuffer, a member of class TnxIndexDataSet.
idKeyBuffers | This is idKeyBuffers, a member of class TnxIndexDataSet.
idKeyBufferSize | key buffers.
idLookupCaseIns | This is idLookupCaseIns, a member of class TnxIndexDataSet.
idLookupCursorID | This is idLookupCursorID, a member of class TnxIndexDataSet.
idLookupFieldNames | lookup/locate.
idMasterLink | master/detail support.
tbExclusive | This is tbExclusive, a member of class TnxTable.
tbOnCreateTable | This is tbOnCreateTable, a member of class TnxTable.
tbPassword | This is tbPassword, a member of class TnxTable.
tbReadOnly | mode.
tbStoreDefs | This is tbStoreDefs, a member of class TnxTable.
tbTableName | private
Protected Methods
Name | Description
AllocRecordBuffer |
BlockReadNext |
CheckFieldCompatibility |
ClearCalcFields | field access.
CloseBlob |
CloseCursor |
CreateFields |
DataConvert |
DataEvent |
DataEvent | == virtual TDataSet methods == info.
DoAfterOpen |
DoAfterScroll |
DoBeforeCancel |
DoBeforeClose |
DoBeforeDelete |
DoBeforeEdit |
DoBeforeInsert |
DoBeforePost |
DoBeforeRefresh |
DoBeforeScroll |
DoOnNewRecord | record access/update.
dsActivateFilter |
dsActivateFilters |
dsApplyMasterRange |
dsApplyMasterRange | master/detail support.
dsBindBlobFields |
dsBindFields |
dsBindMappers |
dsCancelServerFilter |
dsCheck | This is the overview for the dsCheck method overload.
dsCheckDefaults |
dsCheckInactiveFromCursor |
dsCheckOpenBlobStreams | blobs.
dsCheckOperation |
dsCloseCursorID |
dsCreateExprFilter | filter.
dsCreateFuncFilter |
dsCreateLookupFilter |
dsDeactivateFilter |
dsDeactivateFilters |
dsDestroyLookupCursor | lookup support.
dsDestroyLookupCursor | locate/lookup support.
dsDropFilter |
dsDropFilters |
dsError | This is the overview for the dsError method overload.
dsExceptionClass | error handling.
dsFieldDefCreated |
dsForceBlobNr |
dsFreeBlob |
dsFreeKeyBuffers |
dsFreeKeyBuffers |
dsFreeMappers |
dsGetActiveBuffer | buffer management.
dsGetActiveKeyBuffer |
dsGetActiveKeyBuffer | buffer management.
dsGetBlobNr |
dsGetCursorClass | internal functions
dsGetDataBase |
dsGetFieldDefClass | field managment.
dsGetNextRecord | navigation.
dsGetPriorRecord |
dsGetRecord |
dsGetSession |
dsGetSimpleExpressionFilterClass |
dsGetSqlFilterClass |
dsGetTimeout |
dsGetVersion |
dsInitBookmarkSize | init.
dsInitBookmarkSize | internal functions == init.
dsInitKeyBuffers | key buffers.
dsInitKeyBuffers | key buffers.
dsInitMappers |
dsInitOffsets |
dsInitPersistentFields |
dsIsAliasNameStored |
dsIsDatabaseStored |
dsIsSessionStored |
dsLocateOrdinalPartialMatchRecord | This is dsLocateOrdinalPartialMatchRecord, a member of class TnxIndexDataSet.
dsLocateRecord |
dsLocateRecord |
dsOnFilterRecordCallback |
dsOpenCursorID | internal functions == open/close.
dsRefreshTimeout | misc.
dsResolveDatabase |
dsSetActiveDesigntime |
dsSetActiveRuntime |
dsSetAliasName |
dsSetBlobNr |
dsSetDataBase |
dsSetFilterData |
dsSetFilterTimeout |
dsSetFilterType |
dsSetFlipOrder |
dsSetOptions |
dsSetSession |
dsSetTableLock | locking.
dsSetTimeout |
dsSetVersion |
dsShutdownFromCursor |
dsTruncateBlob |
FindRecord | record access/naviagtion.
FreeRecordBuffer |
GetBookmarkData | This is the overview for the GetBookmarkData method overload.
GetBookmarkFlag |
GetBookmarkStr |
GetCanModify | == virtual TDataSet methods == -- info
GetDataSource | master/detail support.
GetFieldClass |
GetIsIndexField |
GetRecNo | recno support.
GetRecord |
GetRecordCount |
GetRecordSize | record buffer management.
idAddIndexDefsToIndicesDesc |
idAddIndexDefToIndicesDesc |
idAfterGetRecordForKey |
idBeforeGetRecordForKey |
idCheckSetKeyMode | key managment.
idFieldDefsStored | property access methods == StoreDefs.
idGetIndexField | IndexFields.
idGetIndexFieldCount | IndexFieldCount.
idGetIndexFieldNames | IndexFieldNames.
idGetIndexName | IndexName.
idGetKeyBuffer |
idGetKeyExclusive | KeyExclusive.
idGetKeyFieldCount | KeyFieldCount.
idGetKeyPartialLen | KeyPartialLen.
idGetLookupCursor |
idGetMasterFields | master/detail support.
idGetMasterSource |
idGetRecordForKey |
idHasActiveRange |
idHasActiveRangeEnd |
idHasActiveRangeStart | range managment.
idIndexDefsStored |
idInitIndexMap |
idInitKeyBuffer |
idMapsToIndex |
idMasterChanged |
idMasterDisabled |
idPostKeyBuffer |
idRefIndexSetFields | ref index support
idResetCursorRange |
idResolveIndexName |
idSetCursorRange |
idSetIndex | index managment.
idSetIndexDefs | IndexDefs.
idSetIndexField |
idSetIndexFieldNames |
idSetIndexName |
idSetKeyBuffer |
idSetKeyExclusive |
idSetKeyFieldCount |
idSetKeyFields | This is the overview for the idSetKeyFields method overload.
idSetKeyPartialLen |
idSetLinkRange |
idSetMasterFields |
idSetMasterSource |
idSwitchToIndex |
idTokenIndexSetFields | token index support
InternalAddRecord | This is the overview for the InternalAddRecord method overload.
InternalCancel |
InternalClose |
InternalClose |
InternalDelete |
InternalEdit |
InternalFirst |
InternalGotoBookmark | This is the overview for the InternalGotoBookmark method overload.
InternalHandleException |
InternalInitFieldDefs |
InternalInitRecord |
InternalLast |
InternalOpen |
InternalPost |
InternalPostAndEdit |
InternalPostImpl |
InternalSetToRecord |
IsCursorOpen |
Loaded |
Notification |
OpenCursor | open / close cursor
PSGetDefaultOrder | IProviderSupport.
PSGetIndexDefs |
PSGetKeyFields |
PSGetTableName | IProviderSupport.
PSSetCommandText |
PSSetParams |
RefreshInternalCalcFields |
ResetBlockReadStream |
SetActive | property access methods.
SetBlockReadSize | block read mode.
SetBookmarkData | This is the overview for the SetBookmarkData method overload.
SetBookmarkFlag |
SetFieldData | This is the overview for the SetFieldData method overload.
SetFieldData | This is the overview for the SetFieldData method overload.
SetFiltered | filter.
SetFilterOptions |
SetFilterText |
SetName |
SetOnFilterRecord |
SetRecNo |
tbSetExclusive |
tbSetPassword |
tbSetReadOnly | mode.
tbSetTableName |
tbSetWriteOnly |
UpdateIndexDefs | index managment.
Protected Properties
Name | Description
BlockReadSize | This is BlockReadSize, a member of class TnxDataset.
Public Methods
Name | Description
AddFileBlob | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddFileBlobEx | AddFileBlob adds a blob linked to real file. Please keep in mind that the file and it's name are server based and that NexusDB is not responsible for this file.
AddIndex | see tTable.AddIndex
AddIndexEx | With AddIndexEx you can use a complete index descriptor instead of just field names to define the index. This gives you much more control over the type of index created. The index creation will be executed asynchronously.
AfterConstruction | see TDataSet.AfterConstruction
ApplyRange | see tTable.ApplyRange. TnxIndexDataSet
BatchPost | Only call BatchPost in batch append mode. It copies the current record buffer into the internal batch append buffer and posts the internal batch append buffer if its size is bigger than aCutoffSize defined in BeginBatchAppend.
BeginBatchAppend | Use BeginBatchAppend to start batch append mode. In this mode the only allowed actions are: setting field values, BatchPost, EndBatchAppend. Please note that batch writing to blob fields is fully supported!
BookmarkValid | see TDataSet.BookmarkValid
Cancel | see tDataSet.Cancel.
CancelBatchAppend | This method terminates the batch append mode. It cancels internal batch append buffer WITHOUT sending it tp the server.
CancelRange | see tTable.CancelRange.
ChangePassword | Changes the password of the table.
CompareBookmarks | see TDataSet.CompareBookmarks
CopyRecords | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
CopyRecordsEx | The method copies all visible records from the source dataset to the current table. It correctly uses the ranges/filters on the source table.
Create | constructor.
CreateBlobStream | This function creates the right type of blob stream based on the state of the dataset. The blob stream should be freed again as soon as possible. It must be freed before calling Post or moving to another record.
CreateTable | see tTable.CreateTable
CreateTableEx | CreateTableEx is the same as CreateTable, but with the possibility to set the BlockSize for the new table.
DeleteIndex | see tTable.DeleteIndex
DeleteRecords | This method deletes all visible records of the current table. You can use filters/ranges to restrict the functionality to a subset of records.
DeleteStream | Use this to delete the streams. NEVER EVER DELETE THE DICT STREAM!
DeleteTable | see tTable.DeleteTable
Destroy | destructor.
EditKey | see tTable.EditKey.
EditRangeEnd | see tTable.EditRangeEnd.
EditRangeStart | see tTable.EditRangeStart.
EmptyTable | see tTable.EmptyTable
EndBatchAppend | This method terminates the batch append mode. It sends the internal batch append buffer to the server if required.
Exists | same as TnxDataset.Exists
FindKey | This is the overview for the FindKey method overload.
FindNearest | This is the overview for the FindNearest method overload.
FlushBatchAppend | Only call in batch append mode. It forces the dataset to post the current internal batch append buffer.
GetAutoIncValue | GetAutoincValue gets the last used value of the AutoInc field of this dataset. this function works even if there is no autoinc field declared in the table, because Nexus always tracks a "highest autoinc" value in the header.
GetBookmark | see TDataSet.GetBookmark
GetCurrentRecord | see TDataSet.GetCurrentRecord
GetFieldData | This is the overview for the GetFieldData method overload.
GetIndexNames | see tTable.GetIndexNames.
GetStreamList | GetStreamList returns a list of the "table streams" saved in the table. A "table stream" is a delphi stream of system or user defined data that can be saved with a table. All tables contain a stream called DICT which contain the data dictionary.
GotoCurrent | GotoCurrent synchronizes a dataset with the given one or in other words positions the dataset on the same record as aDataSet. This method will result in an error if that record is currently not visible (range/filter) or if aDataSet is not positioned on a valid record
GotoKey | see tTable.GotoKey.
GotoNearest | see tTable.GotoNearest
GotoNearestBackward | see tTable.GotoNearest
HasActiveRange |
HasActiveRangeEnd |
HasActiveRangeStart |
InBatchAppend | This function returns true if a Batch Append is open.
IsRecordLocked | Returns the current Record's lock status.
IsSequenced | see TDataSet.IsSequenced
IsTableLocked | Returns the state of a lock of the certain type is active on the current table
KeyAsVariant | Returns a key for the current record.
Locate | see TDataSet.Locate
LockTable | LockTable locks the dataset for the given operation. Make sure to keep these locks as short as possible, because it might otherwise interfere with the functionality/access of other instances to the table. These locks interact directly with record locks, e.g. you can't acquire a table lock while anyone else has a record lock.
Lookup | see TDataSet.Lookup
PackTable | See tnxDatabase.PackTable
PackTableEx | See tnxDatabase.PackTable
Post | == virtual TDataSet methods == -- navigation
Post | see tDataSet.Post.
PostAndEdit |
PSEndTransaction | see TDataset.PSEndTransaction
PSExecuteStatement | This is the overview for the PSExecuteStatement method overload.
PSGetQuoteChar | see TDataset.PSGetQuoteChar
PSGetUpdateException | see TDataset.PSGetUpdateException
PSInTransaction | see TDataset.PSInTransaction
PSIsSQLBased | see TDataset.PSIsSQLBased
PSIsSQLSupported | see TDataset.PSIsSQLSupported
PSReset | see TDataset.PSReset
PSStartTransaction | see TDataset.PSStartTransaction
ReadStream | Use this method to read a certain stream. It raises exception if not the stream is not found.
ReadStreamEx | Use this method to read a certain stream. It raises exception if not the stream is not found.
RecordCountAsync | This method starts an asynchronous RecordCount. Very useful if there's for example a filter applied and the serves needs to iterate through all records to find out the count. Use TaskInfo.GetStatus to find out the status of the operation.
ReIndexTable | This is the overview for the ReIndexTable method overload.
ReIndexTableEx | This is the overview for the ReIndexTableEx method overload.
RenameTable | see tTable.RenameTable
RestructureTable | See tnxDatabase.RestructureTable
RestructureTableEx | See tnxDatabase.RestructureTable
SetAutoIncValue | Use this method to set the AutoInc field's value; be very careful with this because it might break referential integrity based on these values and also might lead to posting errors due to unique field violations.
SetKey | see tTable.FindNearest.
SetRange | This is the overview for the SetRange method overload.
SetRangeEnd | see tTable.SetRangeEnd.
SetRangeShared | This is the overview for the SetRangeShared method overload.
SetRangeSimple | Sets a normal simple Range (as opposed to SetRangeShared).
SetRangeStart | see tTable.SetRangeStart.
UnlockTable | Remove the given lock from the dataset with this method.
UnlockTableAll | UnlockTableAll releases all cursor based locks of this dataset, but this does not include record locks.
WriteStream | This method stores aStream in the table and overwrites any existing stream of that name. NEVER EVER OVERWRITE THE DICT STREAM!
Public Properties
Name | Description
_Dictionary | The Dictionary holds all field and index definitions as well as full information on how to access and read the data file.
AbstractCursor | This is a pointer to the current cursor of this dataset.
ActiveIndexName | This is ActiveIndexName, a member of class TnxIndexDataSet.
FieldsDescriptor | Returns the Fields Descriptor of the current table.
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
LookupOptions | These options are used when Lookup is being called, either explicitly or implicitly by the use of lookup fields in other datasets connected to this dataset.
SimpleExpressionFilterClass | The Filter class the dataset creates an instance of for each Filter evaluation set
SqlFilterClass | the Filter class the dataset creates an instance of for each Filter evaluation set
TableDescriptor | Returns the Table Descriptor of the data dictionary.
Published Events
Name | Description
OnCreateTable | This event is fired before the table is create by the server.
OnServerFilterTimeout | The event is triggered if the FilterTimeout time has passed since activating a filter. Set cancel to false to give the server another FilterTimeout period of time to finish the filtering.
Published Properties
Name | Description
ActiveDesigntime | Set ActiveDesigntime to true if the dataset should be automatically opened at design time. Very handy to use in combination with ActiveRuntime if you need the dataset open at design time, but sometimes forget to close it before creating a shipping version.
ActiveRuntime | Set ActiveRuntime to true if the dataset should be automatically opened at runtime. Take care that this needs a fully set up chain of components otherwise you very likely get an "could not connect to server" error on application startup.
AfterCancel | see TDataSet.AfterCancel.
AfterClose | see TDataSet.AfterClose.
AfterDelete | see TDataSet.AfterDelete
AfterEdit | see TDataSet.AfterEdit
AfterInsert | see TDataSet.AfterInsert
AfterOpen | see TDataSet.AfterOpen
AfterPost | see TDataSet.AfterPost
AfterRefresh | see TDataSet.AfterRefresh
AfterScroll | see TDataSet.AfterScroll
AliasName | AliasName is a quick way to access an alias without a connected tnxDatabase. AliasName does NOT support direct paths! Please not that Session must be assigned for this to work.
AutoCalcFields | see TDataSet.AutoCalcFields
BeforeCancel | see TDataSet.BeforeCancel
BeforeClose | see TDataSet.BeforeClose
BeforeDelete | see TDataSet.BeforeDelete
BeforeEdit | see TDataSet.BeforeEdit
BeforeInsert | see TDataSet.BeforeInsert
BeforeOpen | see TDataSet.BeforeOpen
BeforePost | see TDataSet.BeforePost
BeforeRefresh | see TDataSet.BeforeRefresh
BeforeScroll | see TDataSet.BeforeScroll
BlockReadOptions | Use BlockReadOptions to set how block/batch operations work. If gboBookmarks is true, bookmarks are received from the server as well as records. The Borland's implementation in TTable doesn't support bookmarks during batch reads. If gboBlob is true, blobs are processed in the batch modes.
Bof | This is Bof, a member of class TnxDataset.
Database | This is database the dataset is linked to. Either AliasName or Database must be set.
Eof | This is Eof, a member of class TnxDataset.
Exclusive | see tTable.Exclusive
FieldDefs | see tTable.FieldDefs
Filter | see TDataset.Filter
Filtered | see TDataset.Filtered
FilterOptions | see TDataset.FilterOptions
FilterResync | When this property is set to True, changing the Filter property causes the server to refresh the dataset. Set this property to False when you don't want the server to refresh the dataset.
FilterTimeout | This is the timeout in ms for Filter operations.
FilterType | The type of filter to use.
FlipOrder | Flips the navigation order for normal navigation as well as calls to key lookups.
IndexDefs | see tTable.IndexDefs.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
OnCalcFields | see TDataSet.OnCalcFields
OnDeleteError | see TDataSet.OnDeleteError
OnEditError | see TDataSet.OnEditError
OnFilterRecord | see TDataSet.OnFilterRecord
OnNewRecord | see TDataSet.OnNewRecord
OnPostError | see TDataSet.OnPostError
Options | The options of the current dataset
Password | The password of the current table.
ReadOnly | see tTable.ReadOnly
Session | This is the session the dataset is linked to. You only need to set this if you want to use AliasName, otherwise (when using an explicit database component) it is automatically set internally.
StoreDefs | see tTable.StoreDefs
TableName | see tTable.TableName
Timeout | The is the timeout in ms used for communication with the server. If it -1 the timeout is inherited from Database.
Version | The version information for the current dataset.
WriteOnly | This property can only be changed if the table is inactive. It prevents the table from ever trying to read records from the server. This improves performance for tables that are only used to insert records.
Links
TnxTable Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxTable.Create Constructor

TnxTable.Create Constructor
TnxTable Class TnxTable Members nxdb Namespace TnxTable Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxTable Class

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Class


TnxTable.Destroy Destructor

TnxTable.Destroy Destructor
TnxTable Class TnxTable Members nxdb Namespace TnxTable Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxTable Class

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Class


TnxTable Fields

TnxTable Fields
TnxTable Class Legend Protected Fields Send Feedback

The fields of the TnxTable class are listed here.

Class

TnxTable Class

Protected Fields
Name | Description
tbExclusive | This is tbExclusive, a member of class TnxTable.
tbOnCreateTable | This is tbOnCreateTable, a member of class TnxTable.
tbPassword | This is tbPassword, a member of class TnxTable.
tbReadOnly | mode.
tbStoreDefs | This is tbStoreDefs, a member of class TnxTable.
tbTableName | private
Links
TnxTable Class, Legend, Protected Fields


TnxTable.tbExclusive Field

TnxTable.tbExclusive Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbExclusive: Boolean;
Description

This is tbExclusive, a member of class TnxTable.

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable.tbOnCreateTable Field

TnxTable.tbOnCreateTable Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbOnCreateTable: TnxCreateTableEvent;
Description

This is tbOnCreateTable, a member of class TnxTable.

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable.tbPassword Field

TnxTable.tbPassword Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbPassword: UnicodeString;
Description

This is tbPassword, a member of class TnxTable.

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable.tbReadOnly Field

TnxTable.tbReadOnly Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbReadOnly: Boolean;
Description

mode.

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable.tbStoreDefs Field

TnxTable.tbStoreDefs Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbStoreDefs: Boolean;
Description

This is tbStoreDefs, a member of class TnxTable.

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable.tbTableName Field

TnxTable.tbTableName Field
TnxTable Class TnxTable Members nxdb Namespace TnxTable Fields Send Feedback
Syntax
Delphi
tbTableName: string;
Description

private

Group

TnxTable Fields

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Fields


TnxTable Methods

TnxTable Methods
TnxTable Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTable class are listed here.

Class

TnxTable Class

Protected Methods
Name | Description
dsOpenCursorID | internal functions == open/close.
GetCanModify | == virtual TDataSet methods == -- info
idFieldDefsStored | property access methods == StoreDefs.
idIndexDefsStored |
PSGetTableName | IProviderSupport.
PSSetCommandText |
tbSetExclusive |
tbSetPassword |
tbSetReadOnly | mode.
tbSetTableName |
tbSetWriteOnly |
Public Methods
Name | Description
AddIndex | see tTable.AddIndex
AddIndexEx | With AddIndexEx you can use a complete index descriptor instead of just field names to define the index. This gives you much more control over the type of index created. The index creation will be executed asynchronously.
ChangePassword | Changes the password of the table.
CreateTable | see tTable.CreateTable
CreateTableEx | CreateTableEx is the same as CreateTable, but with the possibility to set the BlockSize for the new table.
DeleteIndex | see tTable.DeleteIndex
DeleteTable | see tTable.DeleteTable
EmptyTable | see tTable.EmptyTable
Exists | same as TnxDataset.Exists
PackTable | See tnxDatabase.PackTable
PackTableEx | See tnxDatabase.PackTable
ReIndexTable | This is the overview for the ReIndexTable method overload.
ReIndexTableEx | This is the overview for the ReIndexTableEx method overload.
RenameTable | see tTable.RenameTable
RestructureTable | See tnxDatabase.RestructureTable
RestructureTableEx | See tnxDatabase.RestructureTable
Links
TnxTable Class, Legend, Protected Methods, Public Methods


TnxTable.AddIndex Method

TnxTable.AddIndex Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
procedure AddIndex(const aName: string; const aFields: string; aOptions: TIndexOptions; const aCaseInsFields: string = ''; const aDescFields: string = ''; aNewPrimary: Boolean = False);
Description

see tTable.AddIndex

See Also

AddIndex, AddIndexEx, DeleteIndex

TnxTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.AddIndexEx Method

TnxTable.AddIndexEx Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
function AddIndexEx(aIndexDesc: TnxIndexDescriptor; aNewPrimary: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Parameters
Parameters | Description
aIndexDesc: TnxIndexDescriptor | a full index descriptor for the new index
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
Description

With AddIndexEx you can use a complete index descriptor instead of just field names to define the index. This gives you much more control over the type of index created. The index creation will be executed asynchronously.

See Also

AddIndex, AddIndexEx, DeleteIndex, TnxAbstractTaskInfo, GetStatus

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.ChangePassword Method

TnxTable.ChangePassword Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure ChangePassword(const aNewPassword: UnicodeString);
Description

Changes the password of the table.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.CreateTable Method

TnxTable.CreateTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure CreateTable(aTableScope: TnxTableScope = tsPersistent; aNoIndices: Boolean = False);
Description

see tTable.CreateTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.CreateTableEx Method

TnxTable.CreateTableEx Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure CreateTableEx(aBlockSize: TnxBlockSize; aTableScope: TnxTableScope = tsPersistent; aNoIndices: Boolean = False);
Parameters
Parameters | Description
aBlockSize: TnxBlockSize | block size for the newly created table
Description

CreateTableEx is the same as CreateTable, but with the possibility to set the BlockSize for the new table.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.DeleteIndex Method

TnxTable.DeleteIndex Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
procedure DeleteIndex(const aIndexName: string);
Description

see tTable.DeleteIndex

See Also

AddIndex, AddIndexEx, DeleteIndex

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.DeleteTable Method

TnxTable.DeleteTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure DeleteTable;
Description

see tTable.DeleteTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.dsOpenCursorID Method

TnxTable.dsOpenCursorID Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure dsOpenCursorID; override;
Description

internal functions == open/close.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.EmptyTable Method

TnxTable.EmptyTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure EmptyTable;
Description

see tTable.EmptyTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.Exists Method

TnxTable.Exists Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
function Exists: Boolean; override;
Description

same as TnxDataset.Exists

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.GetCanModify Method

TnxTable.GetCanModify Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
function GetCanModify: Boolean; override;
Description

== virtual TDataSet methods == -- info

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.idFieldDefsStored Method

TnxTable.idFieldDefsStored Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
function idFieldDefsStored: Boolean; override;
Description

property access methods == StoreDefs.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.idIndexDefsStored Method

TnxTable.idIndexDefsStored Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
function idIndexDefsStored: Boolean; override;
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.PackTable Method

TnxTable.PackTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
function PackTable: TnxAbstractTaskInfo;
Description

See tnxDatabase.PackTable

See Also

TnxBaseSession.PackTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.PackTableEx Method

TnxTable.PackTableEx Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
function PackTableEx(out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Description

See tnxDatabase.PackTable

See Also

TnxBaseSession.PackTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.PSGetTableName Method

TnxTable.PSGetTableName Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
function PSGetTableName: string; override;
Description

IProviderSupport.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.PSSetCommandText Method

TnxTable.PSSetCommandText Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure PSSetCommandText(const CommandText: string); override;
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


ReIndexTable Method

ReIndexTable Method
TnxTable Methods Send Feedback

This is the overview for the ReIndexTable method overload.

Overload List
Name | Description
TnxTable.ReIndexTable (Integer) | See tnxDatabase.ReIndexTable
TnxTable.ReIndexTable (string) | See tnxDatabase.ReIndexTable
Group

TnxTable Methods

Links
TnxTable Methods


TnxTable.ReIndexTable Method (Integer)

TnxTable.ReIndexTable Method (Integer)
TnxTable Class TnxTable Members nxdb Namespace ReIndexTable Method See Also Send Feedback
Syntax
Delphi
function ReIndexTable(aIndexNum: Integer): TnxAbstractTaskInfo; overload;
Description

See tnxDatabase.ReIndexTable

See Also

TnxDatabase.ReIndexTable

Group

ReIndexTable Method

Links
TnxTable Class, TnxTable Members, nxdb Namespace, ReIndexTable Method, See Also


TnxTable.ReIndexTable Method (string)

TnxTable.ReIndexTable Method (string)
TnxTable Class TnxTable Members nxdb Namespace ReIndexTable Method See Also Send Feedback
Syntax
Delphi
function ReIndexTable(const aIndexName: string): TnxAbstractTaskInfo; overload;
Description

See tnxDatabase.ReIndexTable

See Also

TnxDatabase.ReIndexTable

Group

ReIndexTable Method

Links
TnxTable Class, TnxTable Members, nxdb Namespace, ReIndexTable Method, See Also


ReIndexTableEx Method

ReIndexTableEx Method
TnxTable Methods Send Feedback

This is the overview for the ReIndexTableEx method overload.

Overload List
Name | Description
TnxTable.ReIndexTableEx (Integer, TnxAbstractTaskInfo) | See tnxDatabase.ReIndexTable
TnxTable.ReIndexTableEx (string, TnxAbstractTaskInfo) | See tnxDatabase.ReIndexTable
Group

TnxTable Methods

Links
TnxTable Methods


TnxTable.ReIndexTableEx Method (Integer, TnxAbstractTaskInfo)

TnxTable.ReIndexTableEx Method (Integer, TnxAbstractTaskInfo)
TnxTable Class TnxTable Members nxdb Namespace ReIndexTableEx Method See Also Send Feedback
Syntax
Delphi
function ReIndexTableEx(aIndexNum: Integer; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; overload;
Description

See tnxDatabase.ReIndexTable

See Also

TnxDatabase.ReIndexTable

Group

ReIndexTableEx Method

Links
TnxTable Class, TnxTable Members, nxdb Namespace, ReIndexTableEx Method, See Also


TnxTable.ReIndexTableEx Method (string, TnxAbstractTaskInfo)

TnxTable.ReIndexTableEx Method (string, TnxAbstractTaskInfo)
TnxTable Class TnxTable Members nxdb Namespace ReIndexTableEx Method See Also Send Feedback
Syntax
Delphi
function ReIndexTableEx(const aIndexName: string; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; overload;
Description

See tnxDatabase.ReIndexTable

See Also

TnxDatabase.ReIndexTable

Group

ReIndexTableEx Method

Links
TnxTable Class, TnxTable Members, nxdb Namespace, ReIndexTableEx Method, See Also


TnxTable.RenameTable Method

TnxTable.RenameTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure RenameTable(const aNewTableName: string);
Description

see tTable.RenameTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.RestructureTable Method

TnxTable.RestructureTable Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
function RestructureTable(aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor): TnxAbstractTaskInfo;
Description

See tnxDatabase.RestructureTable

See Also

TnxDatabase.RestructureTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.RestructureTableEx Method

TnxTable.RestructureTableEx Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods See Also Send Feedback
Syntax
Delphi
function RestructureTableEx(aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor; out aTaskInfo: TnxAbstractTaskInfo): TnxResult;
Description

See tnxDatabase.RestructureTable

See Also

TnxDatabase.RestructureTable

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods, See Also


TnxTable.tbSetExclusive Method

TnxTable.tbSetExclusive Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure tbSetExclusive(const Value: Boolean);
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.tbSetPassword Method

TnxTable.tbSetPassword Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure tbSetPassword(const Value: UnicodeString); virtual;
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.tbSetReadOnly Method

TnxTable.tbSetReadOnly Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure tbSetReadOnly(const Value: Boolean);
Description

mode.

Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.tbSetTableName Method

TnxTable.tbSetTableName Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure tbSetTableName(const Value: string); virtual;
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable.tbSetWriteOnly Method

TnxTable.tbSetWriteOnly Method
TnxTable Class TnxTable Members nxdb Namespace TnxTable Methods Send Feedback
Syntax
Delphi
procedure tbSetWriteOnly(const Value: Boolean);
Group

TnxTable Methods

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Methods


TnxTable Properties

TnxTable Properties
TnxTable Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxTable class are listed here.

Class

TnxTable Class

Public Properties
Name | Description
IndexFieldCount | see tTable.IndexFieldCount.
IndexFields | see tTable.IndexFields
KeyExclusive | see tTable.KeyExclusive
KeyFieldCount | see tTable.KeyFieldCount
KeyPartialLen | see tTable.KeyPartialLen
Published Properties
Name | Description
Exclusive | see tTable.Exclusive
FieldDefs | see tTable.FieldDefs
IndexDefs | see tTable.IndexDefs.
IndexFieldNames | see tTable.IndexFieldNames
IndexName | see tTable.IndexName
MasterFields | see tTable.MasterFields
MasterSource | see tTable.MasterSource
Password | The password of the current table.
ReadOnly | see tTable.ReadOnly
StoreDefs | see tTable.StoreDefs
TableName | see tTable.TableName
WriteOnly | This property can only be changed if the table is inactive. It prevents the table from ever trying to read records from the server. This improves performance for tables that are only used to insert records.
Links
TnxTable Class, Legend, Public Properties, Published Properties


TnxTable.Exclusive Property

TnxTable.Exclusive Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property Exclusive: Boolean;
Description

see tTable.Exclusive

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.FieldDefs Property

TnxTable.FieldDefs Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property FieldDefs;
Description

see tTable.FieldDefs

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.IndexDefs Property

TnxTable.IndexDefs Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property IndexDefs: TIndexDefs;
Description

see tTable.IndexDefs.

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.IndexFieldCount Property

TnxTable.IndexFieldCount Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property IndexFieldCount: Integer;
Description

see tTable.IndexFieldCount.

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.IndexFieldNames Property

TnxTable.IndexFieldNames Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property IndexFieldNames: string;
Description

see tTable.IndexFieldNames

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.IndexFields Property

TnxTable.IndexFields Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property IndexFields [aIndex: Integer]: TField;
Description

see tTable.IndexFields

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.IndexName Property

TnxTable.IndexName Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property IndexName: string;
Description

see tTable.IndexName

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.KeyExclusive Property

TnxTable.KeyExclusive Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property KeyExclusive: Boolean;
Description

see tTable.KeyExclusive

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.KeyFieldCount Property

TnxTable.KeyFieldCount Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property KeyFieldCount: Integer;
Description

see tTable.KeyFieldCount

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.KeyPartialLen Property

TnxTable.KeyPartialLen Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property KeyPartialLen: Integer;
Description

see tTable.KeyPartialLen

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.MasterFields Property

TnxTable.MasterFields Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property MasterFields: string;
Description

see tTable.MasterFields

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.MasterSource Property

TnxTable.MasterSource Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property MasterSource: TDataSource;
Description

see tTable.MasterSource

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.Password Property

TnxTable.Password Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

The password of the current table.

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.ReadOnly Property

TnxTable.ReadOnly Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property ReadOnly: Boolean;
Description

see tTable.ReadOnly

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.StoreDefs Property

TnxTable.StoreDefs Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property StoreDefs: Boolean;
Description

see tTable.StoreDefs

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.TableName Property

TnxTable.TableName Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property TableName: string;
Description

see tTable.TableName

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable.WriteOnly Property

TnxTable.WriteOnly Property
TnxTable Class TnxTable Members nxdb Namespace TnxTable Properties Send Feedback
Syntax
Delphi
property WriteOnly: Boolean;
Description

This property can only be changed if the table is inactive. It prevents the table from ever trying to read records from the server. This improves performance for tables that are only used to insert records.

Group

TnxTable Properties

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Properties


TnxTable Events

TnxTable Events
TnxTable Class Legend Published Events Send Feedback

The events of the TnxTable class are listed here.

Class

TnxTable Class

Published Events
Name | Description
OnCreateTable | This event is fired before the table is create by the server.
Links
TnxTable Class, Legend, Published Events


TnxTable.OnCreateTable Event

TnxTable.OnCreateTable Event
TnxTable Class TnxTable Members nxdb Namespace TnxTable Events Send Feedback
Syntax
Delphi
property OnCreateTable: TnxCreateTableEvent;
Description

This event is fired before the table is create by the server.

Group

TnxTable Events

Links
TnxTable Class, TnxTable Members, nxdb Namespace, TnxTable Events


TnxThreadWithDatabase Class

TnxThreadWithDatabase Class
TnxThreadWithDatabase Fields TnxThreadWithDatabase Methods TnxThreadWithDatabase Properties TnxThreadWithDatabase Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxThreadWithDatabasenxdb_TnxThreadWithDatabasenxdb_TnxThreadWithDatabasenxdb_TnxThreadWithDatabasenxdb_TnxThreadWithDatabasenxdb_TnxThreadWithDatabase
Syntax
Delphi
TnxThreadWithDatabase = class(TnxThreadWithSession);
File

nxdb

Description

A thread with an automatically created TnxSession and TnxDatabase instance.

Group

Classes

Links
TnxThreadWithDatabase Fields, TnxThreadWithDatabase Methods, TnxThreadWithDatabase Properties, TnxThreadWithDatabase Members, nxdb, Classes


TnxThreadWithDatabase Members

TnxThreadWithDatabase Members
TnxThreadWithDatabase Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxThreadWithDatabase.

Class

TnxThreadWithDatabase Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
twdAlias | private
twdDatabase | This is twdDatabase, a member of class TnxThreadWithDatabase.
twsSession | This is twsSession, a member of class TnxThreadWithSession.
twsSessionPool | private
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | Constructor.
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
Database | The auto created database which is only valid in the Execute environment!
Session | The auto created session which is only valid in the Execute environment!
Links
TnxThreadWithDatabase Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties


TnxThreadWithDatabase.Create Constructor

TnxThreadWithDatabase.Create Constructor
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority; aSessionPool: TnxBaseSessionPool; const aAlias: string);
Parameters
Parameters | Description
aThreadPriority: TThreadPriority | priority of the created Thread
aSessionPool: TnxBaseSessionPool | pool where the session is acquired from (MUST not be nil)
const aAlias: string | the alias the database instance should point to TnxThreadWithDatabase
Description

Constructor.

Class

TnxThreadWithDatabase Class

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Class


TnxThreadWithDatabase Fields

TnxThreadWithDatabase Fields
TnxThreadWithDatabase Class Legend Protected Fields Send Feedback

The fields of the TnxThreadWithDatabase class are listed here.

Class

TnxThreadWithDatabase Class

Protected Fields
Name | Description
twdAlias | private
twdDatabase | This is twdDatabase, a member of class TnxThreadWithDatabase.
Links
TnxThreadWithDatabase Class, Legend, Protected Fields


TnxThreadWithDatabase.twdAlias Field

TnxThreadWithDatabase.twdAlias Field
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Fields Send Feedback
Syntax
Delphi
twdAlias: string;
Description

private

Group

TnxThreadWithDatabase Fields

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Fields


TnxThreadWithDatabase.twdDatabase Field

TnxThreadWithDatabase.twdDatabase Field
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Fields Send Feedback
Syntax
Delphi
twdDatabase: TnxDatabase;
Description

This is twdDatabase, a member of class TnxThreadWithDatabase.

Group

TnxThreadWithDatabase Fields

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Fields


TnxThreadWithDatabase Methods

TnxThreadWithDatabase Methods
TnxThreadWithDatabase Class Legend Protected Methods Send Feedback

The methods of the TnxThreadWithDatabase class are listed here.

Class

TnxThreadWithDatabase Class

Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
Links
TnxThreadWithDatabase Class, Legend, Protected Methods


TnxThreadWithDatabase.DoAfterExecute Method

TnxThreadWithDatabase.DoAfterExecute Method
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; override;
Group

TnxThreadWithDatabase Methods

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Methods


TnxThreadWithDatabase.DoBeforeExecute Method

TnxThreadWithDatabase.DoBeforeExecute Method
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxThreadWithDatabase Methods

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Methods


TnxThreadWithDatabase Properties

TnxThreadWithDatabase Properties
TnxThreadWithDatabase Class Legend Public Properties Send Feedback

The properties of the TnxThreadWithDatabase class are listed here.

Class

TnxThreadWithDatabase Class

Public Properties
Name | Description
Database | The auto created database which is only valid in the Execute environment!
Links
TnxThreadWithDatabase Class, Legend, Public Properties


TnxThreadWithDatabase.Database Property

TnxThreadWithDatabase.Database Property
TnxThreadWithDatabase Class TnxThreadWithDatabase Members nxdb Namespace TnxThreadWithDatabase Properties Send Feedback
Syntax
Delphi
property Database: TnxDatabase;
Description

The auto created database which is only valid in the Execute environment!

Group

TnxThreadWithDatabase Properties

Links
TnxThreadWithDatabase Class, TnxThreadWithDatabase Members, nxdb Namespace, TnxThreadWithDatabase Properties


TnxThreadWithSession Class

TnxThreadWithSession Class
TnxThreadWithSession Fields TnxThreadWithSession Methods TnxThreadWithSession Properties TnxThreadWithSession Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxThreadWithSessionnxdb_TnxThreadWithSessionnxdb_TnxThreadWithSessionnxdb_TnxThreadWithSessionnxdb_TnxThreadWithSession
Syntax
Delphi
TnxThreadWithSession = class(TnxInitThread);
File

nxdb

Description

A thread with an automatically created TnxSession instance.

Group

Classes

Links
TnxThreadWithSession Fields, TnxThreadWithSession Methods, TnxThreadWithSession Properties, TnxThreadWithSession Members, nxdb, Classes


TnxThreadWithSession Members

TnxThreadWithSession Members
TnxThreadWithSession Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxThreadWithSession.

Class

TnxThreadWithSession Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
twsSession | This is twsSession, a member of class TnxThreadWithSession.
twsSessionPool | private
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | Constructor.
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
Session | The auto created session which is only valid in the Execute environment!
Links
TnxThreadWithSession Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties


TnxThreadWithSession.Create Constructor

TnxThreadWithSession.Create Constructor
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority; aSessionPool: TnxBaseSessionPool);
Parameters
Parameters | Description
aThreadPriority: TThreadPriority | priority of the created Thread
aSessionPool: TnxBaseSessionPool | pool where the session is acquired from (MUST not be nil) TnxThreadWithSession
Description

Constructor.

Class

TnxThreadWithSession Class

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Class


TnxThreadWithSession Fields

TnxThreadWithSession Fields
TnxThreadWithSession Class Legend Protected Fields Send Feedback

The fields of the TnxThreadWithSession class are listed here.

Class

TnxThreadWithSession Class

Protected Fields
Name | Description
twsSession | This is twsSession, a member of class TnxThreadWithSession.
twsSessionPool | private
Links
TnxThreadWithSession Class, Legend, Protected Fields


TnxThreadWithSession.twsSession Field

TnxThreadWithSession.twsSession Field
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Fields Send Feedback
Syntax
Delphi
twsSession: TnxPooledSession;
Description

This is twsSession, a member of class TnxThreadWithSession.

Group

TnxThreadWithSession Fields

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Fields


TnxThreadWithSession.twsSessionPool Field

TnxThreadWithSession.twsSessionPool Field
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Fields Send Feedback
Syntax
Delphi
twsSessionPool: TnxBaseSessionPool;
Description

private

Group

TnxThreadWithSession Fields

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Fields


TnxThreadWithSession Methods

TnxThreadWithSession Methods
TnxThreadWithSession Class Legend Protected Methods Send Feedback

The methods of the TnxThreadWithSession class are listed here.

Class

TnxThreadWithSession Class

Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
Links
TnxThreadWithSession Class, Legend, Protected Methods


TnxThreadWithSession.DoAfterExecute Method

TnxThreadWithSession.DoAfterExecute Method
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; override;
Group

TnxThreadWithSession Methods

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Methods


TnxThreadWithSession.DoBeforeExecute Method

TnxThreadWithSession.DoBeforeExecute Method
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxThreadWithSession Methods

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Methods


TnxThreadWithSession Properties

TnxThreadWithSession Properties
TnxThreadWithSession Class Legend Public Properties Send Feedback

The properties of the TnxThreadWithSession class are listed here.

Class

TnxThreadWithSession Class

Public Properties
Name | Description
Session | The auto created session which is only valid in the Execute environment!
Links
TnxThreadWithSession Class, Legend, Public Properties


TnxThreadWithSession.Session Property

TnxThreadWithSession.Session Property
TnxThreadWithSession Class TnxThreadWithSession Members nxdb Namespace TnxThreadWithSession Properties Send Feedback
Syntax
Delphi
property Session: TnxBaseSession;
Description

The auto created session which is only valid in the Execute environment!

Group

TnxThreadWithSession Properties

Links
TnxThreadWithSession Class, TnxThreadWithSession Members, nxdb Namespace, TnxThreadWithSession Properties


TnxThreadWithTable Class

TnxThreadWithTable Class
TnxThreadWithTable Fields TnxThreadWithTable Methods TnxThreadWithTable Properties TnxThreadWithTable Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxThreadWithTablenxdb_TnxThreadWithTablenxdb_TnxThreadWithTablenxdb_TnxThreadWithTablenxdb_TnxThreadWithTablenxdb_TnxThreadWithTablenxdb_TnxThreadWithTable
Syntax
Delphi
TnxThreadWithTable = class(TnxThreadWithDatabase);
File

nxdb

Description

A thread with an automatically created TnxSession, TnxDatabase and TnxTable instance.

Group

Classes

Links
TnxThreadWithTable Fields, TnxThreadWithTable Methods, TnxThreadWithTable Properties, TnxThreadWithTable Members, nxdb, Classes


TnxThreadWithTable Members

TnxThreadWithTable Members
TnxThreadWithTable Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxThreadWithTable.

Class

TnxThreadWithTable Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
twdAlias | private
twdDatabase | This is twdDatabase, a member of class TnxThreadWithDatabase.
twsSession | This is twsSession, a member of class TnxThreadWithSession.
twsSessionPool | private
twtIndexName | This is twtIndexName, a member of class TnxThreadWithTable.
twtPassword | This is twtPassword, a member of class TnxThreadWithTable.
twtTable | This is twtTable, a member of class TnxThreadWithTable.
twtTableName | private
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | Constructor.
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
Database | The auto created database which is only valid in the Execute environment!
Session | The auto created session which is only valid in the Execute environment!
Table | The auto created table which is only valid in the Execute environment!
Links
TnxThreadWithTable Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties


TnxThreadWithTable.Create Constructor

TnxThreadWithTable.Create Constructor
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority; aSessionPool: TnxBaseSessionPool; const aAlias: string; const aTableName: string; const aIndexName: string; const aPassword: UnicodeString);
Parameters
Parameters | Description
aThreadPriority: TThreadPriority | priority of the created Thread
aSessionPool: TnxBaseSessionPool | pool where the session is acquired from (MUST not be nil)
const aAlias: string | the alias the database instance should point to
const aTableName: string | the name of the table to attach to
const aIndexName: string | the initial set index
const aPassword: UnicodeString | the password needed to open the table TnxThreadWithTable
Description

Constructor.

Class

TnxThreadWithTable Class

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Class


TnxThreadWithTable Fields

TnxThreadWithTable Fields
TnxThreadWithTable Class Legend Protected Fields Send Feedback

The fields of the TnxThreadWithTable class are listed here.

Class

TnxThreadWithTable Class

Protected Fields
Name | Description
twtIndexName | This is twtIndexName, a member of class TnxThreadWithTable.
twtPassword | This is twtPassword, a member of class TnxThreadWithTable.
twtTable | This is twtTable, a member of class TnxThreadWithTable.
twtTableName | private
Links
TnxThreadWithTable Class, Legend, Protected Fields


TnxThreadWithTable.twtIndexName Field

TnxThreadWithTable.twtIndexName Field
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Fields Send Feedback
Syntax
Delphi
twtIndexName: string;
Description

This is twtIndexName, a member of class TnxThreadWithTable.

Group

TnxThreadWithTable Fields

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Fields


TnxThreadWithTable.twtPassword Field

TnxThreadWithTable.twtPassword Field
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Fields Send Feedback
Syntax
Delphi
twtPassword: UnicodeString;
Description

This is twtPassword, a member of class TnxThreadWithTable.

Group

TnxThreadWithTable Fields

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Fields


TnxThreadWithTable.twtTable Field

TnxThreadWithTable.twtTable Field
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Fields Send Feedback
Syntax
Delphi
twtTable: TnxTable;
Description

This is twtTable, a member of class TnxThreadWithTable.

Group

TnxThreadWithTable Fields

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Fields


TnxThreadWithTable.twtTableName Field

TnxThreadWithTable.twtTableName Field
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Fields Send Feedback
Syntax
Delphi
twtTableName: string;
Description

private

Group

TnxThreadWithTable Fields

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Fields


TnxThreadWithTable Methods

TnxThreadWithTable Methods
TnxThreadWithTable Class Legend Protected Methods Send Feedback

The methods of the TnxThreadWithTable class are listed here.

Class

TnxThreadWithTable Class

Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
Links
TnxThreadWithTable Class, Legend, Protected Methods


TnxThreadWithTable.DoAfterExecute Method

TnxThreadWithTable.DoAfterExecute Method
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; override;
Group

TnxThreadWithTable Methods

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Methods


TnxThreadWithTable.DoBeforeExecute Method

TnxThreadWithTable.DoBeforeExecute Method
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxThreadWithTable Methods

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Methods


TnxThreadWithTable Properties

TnxThreadWithTable Properties
TnxThreadWithTable Class Legend Public Properties Send Feedback

The properties of the TnxThreadWithTable class are listed here.

Class

TnxThreadWithTable Class

Public Properties
Name | Description
Table | The auto created table which is only valid in the Execute environment!
Links
TnxThreadWithTable Class, Legend, Public Properties


TnxThreadWithTable.Table Property

TnxThreadWithTable.Table Property
TnxThreadWithTable Class TnxThreadWithTable Members nxdb Namespace TnxThreadWithTable Properties Send Feedback
Syntax
Delphi
property Table: TnxTable;
Description

The auto created table which is only valid in the Execute environment!

Group

TnxThreadWithTable Properties

Links
TnxThreadWithTable Class, TnxThreadWithTable Members, nxdb Namespace, TnxThreadWithTable Properties


TnxTransContext Class

TnxTransContext Class
TnxTransContext Fields TnxTransContext Methods TnxTransContext Properties TnxTransContext Members nxdb Classes Send Feedback
Class Hierarchy
nxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContextnxdb_TnxTransContext
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxTransContext = class(TnxSessionOwnedDataAccessStateComponent);
File

nxdb

Description

Container for a Transaction Context.

Group

Classes

Links
TnxTransContext Fields, TnxTransContext Methods, TnxTransContext Properties, TnxTransContext Members, nxdb, Classes


TnxTransContext Members

TnxTransContext Members
TnxTransContext Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxTransContext.

Class

TnxTransContext Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
soSession | private
soTimeout | This is soTimeout, a member of class TnxSessionOwnedDataAccessStateComponent.
tcAbstractTransContext | private
tcDatabases | This is tcDatabases, a member of class TnxTransContext.
tcFailSafe | This is tcFailSafe, a member of class TnxTransContext.
tcLoadedDefault | This is tcLoadedDefault, a member of class TnxTransContext.
Protected Methods
Name | Description
dascExceptionClass |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
soCheckDefaults |
soCheckSession |
soGetTimeout |
soRefreshTimeout |
soSetSession |
soSetTimeout |
tcGetDatabase |
tcGetDatabaseCount |
tcGetDefault |
tcGetInTransaction |
tcSetDefault |
tcSetFailSafe |
Public Methods
Name | Description
AfterConstruction | see TDataset.AfterConstruction TnxSessionOwnedDataAccessStateComponent
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Commit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case. For more info see the nexus manual.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
Rollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
StartTransaction | StartTransaction tries to start a transaction. If it fails an exception is triggered.
StartTransactionWith | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.
StartTransactionWithEx | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.
TryStartTransaction | Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by in this context or triggers an exception if an error occurs.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DatabaseCount | Returns the number of dataset instances attached to this database.
Databases | Returns the dataset with index aInx out of the list of attached dataset instances.
InTransaction | Returns true if a transaction for the current database is active otherwise false.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
Default | Returns true if the current instance is the automatically created default Context for the owning session. Setting this property makes that context the default for all TnxDatabase that are attached to that session afterwards.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
FailSafe | Sets failsafe mode on or off. For more info see NexusDB manual.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Session | The session the database is attached to. This property must be set for the component to work properly.
Timeout | Set the timeout for the component in ms. If -1 is specified the component inherits the value of the session it is connected to.
Version | Version of the component.
Links
TnxTransContext Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxTransContext.Create Constructor

TnxTransContext.Create Constructor
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor.

Class

TnxTransContext Class

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Class


TnxTransContext.Destroy Destructor

TnxTransContext.Destroy Destructor
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxTransContext Class

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Class


TnxTransContext Fields

TnxTransContext Fields
TnxTransContext Class Legend Protected Fields Send Feedback

The fields of the TnxTransContext class are listed here.

Class

TnxTransContext Class

Protected Fields
Name | Description
tcAbstractTransContext | private
tcDatabases | This is tcDatabases, a member of class TnxTransContext.
tcFailSafe | This is tcFailSafe, a member of class TnxTransContext.
tcLoadedDefault | This is tcLoadedDefault, a member of class TnxTransContext.
Links
TnxTransContext Class, Legend, Protected Fields


TnxTransContext.tcAbstractTransContext Field

TnxTransContext.tcAbstractTransContext Field
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Fields Send Feedback
Syntax
Delphi
tcAbstractTransContext: TnxAbstractTransContext;
Description

private

Group

TnxTransContext Fields

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Fields


TnxTransContext.tcDatabases Field

TnxTransContext.tcDatabases Field
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Fields Send Feedback
Syntax
Delphi
tcDatabases: TnxSortedList;
Description

This is tcDatabases, a member of class TnxTransContext.

Group

TnxTransContext Fields

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Fields


TnxTransContext.tcFailSafe Field

TnxTransContext.tcFailSafe Field
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Fields Send Feedback
Syntax
Delphi
tcFailSafe: Boolean;
Description

This is tcFailSafe, a member of class TnxTransContext.

Group

TnxTransContext Fields

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Fields


TnxTransContext.tcLoadedDefault Field

TnxTransContext.tcLoadedDefault Field
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Fields Send Feedback
Syntax
Delphi
tcLoadedDefault: Boolean;
Description

This is tcLoadedDefault, a member of class TnxTransContext.

Group

TnxTransContext Fields

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Fields


TnxTransContext Methods

TnxTransContext Methods
TnxTransContext Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTransContext class are listed here.

Class

TnxTransContext Class

Protected Methods
Name | Description
Loaded |
nxcAddDependent |
nxcRemoveDependent |
scInitializing |
scStarting |
scStopping |
soRefreshTimeout |
tcGetDatabase |
tcGetDatabaseCount |
tcGetDefault |
tcGetInTransaction |
tcSetDefault |
tcSetFailSafe |
Public Methods
Name | Description
Commit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case. For more info see the nexus manual.
Rollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.
StartTransaction | StartTransaction tries to start a transaction. If it fails an exception is triggered.
StartTransactionWith | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.
StartTransactionWithEx | Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.
TryStartTransaction | Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by in this context or triggers an exception if an error occurs.
Links
TnxTransContext Class, Legend, Protected Methods, Public Methods


TnxTransContext.Commit Method

TnxTransContext.Commit Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
procedure Commit;
Description

This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back. You have to call Rollback in that case.

For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

TnxTransContext

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.Loaded Method

TnxTransContext.Loaded Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.nxcAddDependent Method

TnxTransContext.nxcAddDependent Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.nxcRemoveDependent Method

TnxTransContext.nxcRemoveDependent Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.Rollback Method

TnxTransContext.Rollback Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
procedure Rollback;
Description

Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost. For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.scInitializing Method

TnxTransContext.scInitializing Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.scStarting Method

TnxTransContext.scStarting Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.scStopping Method

TnxTransContext.scStopping Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.soRefreshTimeout Method

TnxTransContext.soRefreshTimeout Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure soRefreshTimeout; override;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.StartTransaction Method

TnxTransContext.StartTransaction Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
procedure StartTransaction(aSnapShot: Boolean = False);
Parameters
Parameters | Description
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

StartTransaction tries to start a transaction. If it fails an exception is triggered.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.StartTransactionWith Method

TnxTransContext.StartTransactionWith Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
procedure StartTransactionWith(const aTables: array of TnxTable; aSnapShot: Boolean = False);
Parameters
Parameters | Description
const aTables: array of TnxTable | the tables that should be part of the transaction
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an exception is raised.

See Also

StartTransaction, StartTransactionWithEx, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.StartTransactionWithEx Method

TnxTransContext.StartTransactionWithEx Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
function StartTransactionWithEx(const aTables: array of TnxTable; aSnapShot: Boolean = False): TnxResult;
Parameters
Parameters | Description
const aTables: array of TnxTable | the tables that should be part of the transaction
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Start a transaction if an exclusive lock can be granted on all specified tables. If the grant fails one or more tables or an error occurs, an error code is returned.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.tcGetDatabase Method

TnxTransContext.tcGetDatabase Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
function tcGetDatabase(aInx: Integer): TnxDatabase;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.tcGetDatabaseCount Method

TnxTransContext.tcGetDatabaseCount Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
function tcGetDatabaseCount: Integer;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.tcGetDefault Method

TnxTransContext.tcGetDefault Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
function tcGetDefault: Boolean;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.tcGetInTransaction Method

TnxTransContext.tcGetInTransaction Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
function tcGetInTransaction: Boolean;
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.tcSetDefault Method

TnxTransContext.tcSetDefault Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure tcSetDefault(const Value: Boolean);
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.tcSetFailSafe Method

TnxTransContext.tcSetFailSafe Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods Send Feedback
Syntax
Delphi
procedure tcSetFailSafe(Value: Boolean);
Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods


TnxTransContext.TransactionCorrupted Method

TnxTransContext.TransactionCorrupted Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
procedure TransactionCorrupted;
Description

This method marks the transaction (level) as corrupted and thus preventing it from ever being committed. For more info see the nexus manual.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext.TryStartTransaction Method

TnxTransContext.TryStartTransaction Method
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Methods See Also Send Feedback
Syntax
Delphi
function TryStartTransaction(aSnapShot: Boolean = False): Boolean;
Parameters
Parameters | Description
aSnapShot: Boolean = False | if true it is handled as a SnapshotTransaction; for more info see the nexus manual
Description

Tries start a transaction (if none was started by the current TnxDatabase), returns true if a new transaction was started, false if a transaction was already started by in this context or triggers an exception if an error occurs.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Methods

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Methods, See Also


TnxTransContext Properties

TnxTransContext Properties
TnxTransContext Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxTransContext class are listed here.

Class

TnxTransContext Class

Public Properties
Name | Description
DatabaseCount | Returns the number of dataset instances attached to this database.
Databases | Returns the dataset with index aInx out of the list of attached dataset instances.
InTransaction | Returns true if a transaction for the current database is active otherwise false.
Published Properties
Name | Description
Default | Returns true if the current instance is the automatically created default Context for the owning session. Setting this property makes that context the default for all TnxDatabase that are attached to that session afterwards.
FailSafe | Sets failsafe mode on or off. For more info see NexusDB manual.
Links
TnxTransContext Class, Legend, Public Properties, Published Properties


TnxTransContext.DatabaseCount Property

TnxTransContext.DatabaseCount Property
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Properties See Also Send Feedback
Syntax
Delphi
property DatabaseCount: Integer;
Description

Returns the number of dataset instances attached to this database.

See Also

DataSetCount, DataSets, TableCount, Tables, QueryCount, Queries

Group

TnxTransContext Properties

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Properties, See Also


TnxTransContext.Databases Property

TnxTransContext.Databases Property
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Properties See Also Send Feedback
Syntax
Delphi
property Databases [aInx: Integer]: TnxDatabase;
Description

Returns the dataset with index aInx out of the list of attached dataset instances.

See Also

DatabaseCount, Databases, TableCount, Tables, QueryCount, Queries

Group

TnxTransContext Properties

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Properties, See Also


TnxTransContext.Default Property

TnxTransContext.Default Property
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Properties Send Feedback
Syntax
Delphi
property Default: Boolean;
Description

Returns true if the current instance is the automatically created default Context for the owning session. Setting this property makes that context the default for all TnxDatabase that are attached to that session afterwards.

Group

TnxTransContext Properties

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Properties


TnxTransContext.FailSafe Property

TnxTransContext.FailSafe Property
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Properties Send Feedback
Syntax
Delphi
property FailSafe: Boolean;
Description

Sets failsafe mode on or off. For more info see NexusDB manual.

Group

TnxTransContext Properties

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Properties


TnxTransContext.InTransaction Property

TnxTransContext.InTransaction Property
TnxTransContext Class TnxTransContext Members nxdb Namespace TnxTransContext Properties See Also Send Feedback
Syntax
Delphi
property InTransaction: Boolean;
Description

Returns true if a transaction for the current database is active otherwise false.

See Also

StartTransaction, StartTransactionWith, TryStartTransaction, Commit, Rollback, InTransaction, TransactionCorrupted

Group

TnxTransContext Properties

Links
TnxTransContext Class, TnxTransContext Members, nxdb Namespace, TnxTransContext Properties, See Also


Functions

Functions
Functions nxdb Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AssignValuesToParams |
AssignValueToParam |
ValuesFromParams |
Namespace

nxdb Namespace

Links
Functions, nxdb Namespace, Legend


nxdb.AssignValuesToParams Function

nxdb.AssignValuesToParams Function
nxdb Functions Send Feedback
Syntax
Delphi
procedure AssignValuesToParams(aParams: TParams; const aValues: array of const);
File

nxdb

Group

Functions

Links
nxdb, Functions


nxdb.AssignValueToParam Function

nxdb.AssignValueToParam Function
nxdb Functions Send Feedback
Syntax
Delphi
procedure AssignValueToParam(aParam: TParam; const aValue: TVarRec);
File

nxdb

Group

Functions

Links
nxdb, Functions


nxdb.ValuesFromParams Function

nxdb.ValuesFromParams Function
nxdb Functions Send Feedback
Syntax
Delphi
function ValuesFromParams(aParams: TParams): TnxDynVariantArray;
File

nxdb

Group

Functions

Links
nxdb, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxdb Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxCachedDataSetOption | Possible options for a cached dataset.
TnxDataSetInternalState | Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.
TnxDataSetOption | Dataset options definition
TnxFilterType | Possible Filter types for TnxDataset.Filter
TnxKeyIndex | Used internally to address the different key buffers.
TnxSetKeyOption | SetKey option
TnxTargetDatabase | DOM-IGNORE-END
Namespace

nxdb Namespace

Records
Name | Description
TnxKeyBuffer | Used internally to address the different key buffers.
TnxRecordInfos | This is record nxdb.TnxRecordInfos.
Links
Enumerations, nxdb Namespace, Legend, Records


nxdb.TnxCachedDataSetOption Enumeration

nxdb.TnxCachedDataSetOption Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCachedDataSetOption = ( cdsoCopyIndices, cdsoSetVisibleFields );
File

nxdb

Members
Members | Description
cdsoCopyIndices | copy indices from source.
cdsoSetVisibleFields | Set the field visible flags.
Description

Possible options for a cached dataset.

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxDataSetInternalState Enumeration

nxdb.TnxDataSetInternalState Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDataSetInternalState = ( disClosing, disShutdownFromCursor, disIndexInvalid );
File

nxdb

Members
Members | Description
disClosing | internal use only.
disShutdownFromCursor | internal use only.
disIndexInvalid | internal use only.
Description

Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxDataSetOption Enumeration

nxdb.TnxDataSetOption Enumeration
nxdb Structs, Records, Enums See Also Send Feedback
Syntax
Delphi
TnxDataSetOption = ( dsoOptimisticLocks, dsoAddKeyAsVariantField, dsoRecNoSupport, dsoSetKeyFieldCountForPSSetParams, dsoKeepExistingRangeForPSSetParams, dsoAllowPartialMatchIndexedLocateForIntegers );
File

nxdb

Members
Members | Description
dsoOptimisticLocks | Use optimistic record locks for edit.
dsoAddKeyAsVariantField | Adds a field to access the current key value as variant
dsoRecNoSupport | Allows use of RecNo if the table supports it
dsoSetKeyFieldCountForPSSetParams | Sets KeyFieldCount in PSSetParams if not all KeyFields have been set
dsoKeepExistingRangeForPSSetParams | Prevents PSSetParams from calling CancelRange if aParams.Count = 0
dsoAllowPartialMatchIndexedLocateForIntegers | Allows PartialMatch Locate calls for integers if the locate is using an index
Description

Dataset options definition

See Also

TnxDataset.Options

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums, See Also


nxdb.TnxFilterType Enumeration

nxdb.TnxFilterType Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxFilterType = ( ftSimple, ftSqlWhere );
File

nxdb

Members
Members | Description
ftSimple | Use simple expression filter
ftSqlWhere | Use SQL WHERE based filter
Description

Possible Filter types for TnxDataset.Filter

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxKeyBuffer Record

nxdb.TnxKeyBuffer Record
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxKeyBuffer = packed record
  kbModified: Boolean;
  kbExclusive: Boolean;
  kbFieldCount: Integer;
  kbPartialLen: Integer;
end;
File

nxdb

Members
Members | Description
kbModified: Boolean; | internal use only.
kbExclusive: Boolean; | internal use only.
kbFieldCount: Integer; | internal use only.
kbPartialLen: Integer; | internal use only.
Description

Used internally to address the different key buffers.

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxKeyIndex Enumeration

nxdb.TnxKeyIndex Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxKeyIndex = ( kiLookup, kiRangeStart, kiRangeEnd, kiCurRangeStart, kiCurRangeEnd, kiSave );
File

nxdb

Members
Members | Description
kiLookup | internal use only
kiRangeStart | internal use only
kiRangeEnd | internal use only
kiCurRangeStart | internal use only
kiCurRangeEnd | internal use only.
kiSave | internal use only
Description

Used internally to address the different key buffers.

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxRecordInfos Record

nxdb.TnxRecordInfos Record
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRecordInfos = packed record
  riRecNo: TnxWord32;
  riBookmarkFlag: TBookmarkFlag;
end;
File

nxdb

Description

This is record nxdb.TnxRecordInfos.

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxSetKeyOption Enumeration

nxdb.TnxSetKeyOption Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSetKeyOption = ( skoExclusive, skoPartialMatch );
File

nxdb

Members
Members | Description
skoExclusive | exclusive full match
skoPartialMatch | partial match
Description

SetKey option

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


nxdb.TnxTargetDatabase Enumeration

nxdb.TnxTargetDatabase Enumeration
nxdb Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTargetDatabase = ( tdSameAsSourceDataSet, tdSameAsCachedDataSet, tdSpecified );
File

nxdb

Description

DOM-IGNORE-END

Group

Structs, Records, Enums

Links
nxdb, Structs, Records, Enums


Types

Types
nxdb Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdb Namespace

Types
Name | Description
PnxBaseSession | Pointer to TnxBaseSession.
PnxKeyBuffer | Used internally to address the different key buffers.
PnxRecordInfos | TnxDataset
TBookmarkOrPointer | This is type nxdb.TBookmarkOrPointer.
TFieldDefClass | A Class of TFieldDef (needed for abstraction purposes only.)
TFieldMap | This is type nxdb.TFieldMap.
TnxBaseUpdateHandlerClass | Class defintion for TnxBaseUpdateHandler.
TnxCachedDataSetOptions | Set of TnxCachedDataSetOption
TnxCreateTableEvent | Method defintion for CreateTable callback event.
TnxCursorClass | Class defintion for Cursors.
TnxDataSetInternalStates | Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.
TnxDataSetOptions | Blob Cache Options.
TnxDirectKeySetFieldsMethod | Method defintion for DirectKeySetFields callback method.
TnxFieldList | This is type nxdb.TnxFieldList.
TnxLoginEvent | An event to get a user name and password for login purposes. Called from TnxBaseSession.
TnxRecordBuffer | This is type nxdb.TnxRecordBuffer.
TnxServerFilterTimeoutEvent | This is an event handler definition for Filter timeouts. It gives the programmer a chance to commence with a filtering even if the filter timeout is reached.
TnxSetKeyOptions | Set of SetKey options.
Links
nxdb Namespace, Types


nxdb.PnxBaseSession Type

nxdb.PnxBaseSession Type
nxdb Types Send Feedback
Syntax
Delphi
PnxBaseSession = ^TnxBaseSession;
File

nxdb

Description

Pointer to TnxBaseSession.

Group

Types

Links
nxdb, Types


nxdb.PnxKeyBuffer Type

nxdb.PnxKeyBuffer Type
nxdb Types Send Feedback
Syntax
Delphi
PnxKeyBuffer = ^TnxKeyBuffer;
File

nxdb

Description

Used internally to address the different key buffers.

Group

Types

Links
nxdb, Types


nxdb.PnxRecordInfos Type

nxdb.PnxRecordInfos Type
nxdb Types Send Feedback
Syntax
Delphi
PnxRecordInfos = ^TnxRecordInfos;
File

nxdb

Description

TnxDataset

Group

Types

Links
nxdb, Types


nxdb.TBookmarkOrPointer Type

nxdb.TBookmarkOrPointer Type
nxdb Types Send Feedback
Syntax
Delphi
TBookmarkOrPointer = Pointer TBookmark ;
File

nxdb

Description

This is type nxdb.TBookmarkOrPointer.

Group

Types

Links
nxdb, Types


nxdb.TFieldDefClass Type

nxdb.TFieldDefClass Type
nxdb Types Send Feedback
Syntax
Delphi
TFieldDefClass = class of TFieldDef;
File

nxdb

Description

A Class of TFieldDef (needed for abstraction purposes only.)

Group

Types

Links
nxdb, Types


nxdb.TFieldMap Type

nxdb.TFieldMap Type
nxdb Types Send Feedback
Syntax
Delphi
TFieldMap = array[TFieldType] of Byte;
File

nxdb

Description

This is type nxdb.TFieldMap.

Group

Types

Links
nxdb, Types


nxdb.TnxBaseUpdateHandlerClass Type

nxdb.TnxBaseUpdateHandlerClass Type
nxdb Types Send Feedback
Syntax
Delphi
TnxBaseUpdateHandlerClass = class of TnxBaseUpdateHandler;
File

nxdb

Description

Class defintion for TnxBaseUpdateHandler.

Group

Types

Links
nxdb, Types


nxdb.TnxCachedDataSetOptions Type

nxdb.TnxCachedDataSetOptions Type
nxdb Types Send Feedback
Syntax
Delphi
TnxCachedDataSetOptions = set of TnxCachedDataSetOption;
File

nxdb

Description

Set of TnxCachedDataSetOption

Group

Types

Links
nxdb, Types


nxdb.TnxCreateTableEvent Type

nxdb.TnxCreateTableEvent Type
nxdb Types Send Feedback
Syntax
Delphi
TnxCreateTableEvent = procedure (aSender : TnxDataSet; aDictionary : TnxDataDictionary) of object;
File

nxdb

Description

Method defintion for CreateTable callback event.

Group

Types

Links
nxdb, Types


nxdb.TnxCursorClass Type

nxdb.TnxCursorClass Type
nxdb Types Send Feedback
Syntax
Delphi
TnxCursorClass = class of TnxCursor;
File

nxdb

Description

Class defintion for Cursors.

Group

Types

Links
nxdb, Types


nxdb.TnxDataSetInternalStates Type

nxdb.TnxDataSetInternalStates Type
nxdb Types Send Feedback
Syntax
Delphi
TnxDataSetInternalStates = set of TnxDataSetInternalState;
File

nxdb

Description

Dataset states are used internally by the dataset class. There's no need for developers to manipulate these.

Group

Types

Links
nxdb, Types


nxdb.TnxDataSetOptions Type

nxdb.TnxDataSetOptions Type
nxdb Types Send Feedback
Syntax
Delphi
TnxDataSetOptions = set of TnxDataSetOption;
File

nxdb

Description

Blob Cache Options.

Group

Types

Links
nxdb, Types


nxdb.TnxDirectKeySetFieldsMethod Type

nxdb.TnxDirectKeySetFieldsMethod Type
nxdb Types Send Feedback
Syntax
Delphi
TnxDirectKeySetFieldsMethod = procedure (const aValues1 : array of const; const aValues2 : array of const; aOptions : TnxSetKeyOptions) of object;
File

nxdb

Description

Method defintion for DirectKeySetFields callback method.

Group

Types

Links
nxdb, Types


nxdb.TnxFieldList Type

nxdb.TnxFieldList Type
nxdb Types Send Feedback
Syntax
Delphi
TnxFieldList = TList <TField> ;
File

nxdb

Description

This is type nxdb.TnxFieldList.

Group

Types

Links
nxdb, Types


nxdb.TnxLoginEvent Type

nxdb.TnxLoginEvent Type
nxdb Types Send Feedback
Syntax
Delphi
TnxLoginEvent = procedure (aSender : TnxBaseSession; var aUserName : UnicodeString; var aPassword : UnicodeString; var aResult : Boolean) of object;
File

nxdb

Description

An event to get a user name and password for login purposes. Called from TnxBaseSession.

Group

Types

Links
nxdb, Types


nxdb.TnxRecordBuffer Type

nxdb.TnxRecordBuffer Type
nxdb Types Send Feedback
Syntax
Delphi
TnxRecordBuffer = TRecordBuffer PByte PChar ;
File

nxdb

Description

This is type nxdb.TnxRecordBuffer.

Group

Types

Links
nxdb, Types


nxdb.TnxServerFilterTimeoutEvent Type

nxdb.TnxServerFilterTimeoutEvent Type
nxdb Types See Also Send Feedback
Syntax
Delphi
TnxServerFilterTimeoutEvent = procedure (Sender : TnxDataset; var Cancel : Boolean) of object;
File

nxdb

Description

This is an event handler definition for Filter timeouts. It gives the programmer a chance to commence with a filtering even if the filter timeout is reached.

See Also

TnxDataset.FilterTimeout

Group

Types

Links
nxdb, Types, See Also


nxdb.TnxSetKeyOptions Type

nxdb.TnxSetKeyOptions Type
nxdb Types Send Feedback
Syntax
Delphi
TnxSetKeyOptions = set of TnxSetKeyOption;
File

nxdb

Description

Set of SetKey options.

Group

Types

Links
nxdb, Types


Variables

Variables
nxdb Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxdb Namespace

Variables
Name | Description
EmptyOpenArray | This is variable nxdb.EmptyOpenArray.
nxDefaultSimpleExpressionFilterClass | the default Filter class.
nxDefaultSqlFilterClass | This is variable nxdb.nxDefaultSqlFilterClass.
Links
nxdb Namespace, Variables


nxdb.EmptyOpenArray Variable

nxdb.EmptyOpenArray Variable
nxdb Variables Send Feedback
Syntax
Delphi
EmptyOpenArray: array of TVarRec;
File

nxdb

Description

This is variable nxdb.EmptyOpenArray.

Group

Variables

Links
nxdb, Variables


nxdb.nxDefaultSimpleExpressionFilterClass Variable

nxdb.nxDefaultSimpleExpressionFilterClass Variable
nxdb Variables Send Feedback
Syntax
Delphi
nxDefaultSimpleExpressionFilterClass: TnxSimpleExpressionFilterDescriptorClass = nil;
File

nxdb

Description

the default Filter class.

Group

Variables

Links
nxdb, Variables


nxdb.nxDefaultSqlFilterClass Variable

nxdb.nxDefaultSqlFilterClass Variable
nxdb Variables Send Feedback
Syntax
Delphi
nxDefaultSqlFilterClass: TnxSqlFilterDescriptorClass = nil;
File

nxdb

Description

This is variable nxdb.nxDefaultSqlFilterClass.

Group

Variables

Links
nxdb, Variables


Constants

Constants
Constants nxdb Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EmptySetKeyOptions | This is constant nxdb.EmptySetKeyOptions.
FldTypeMap | 49..51
nxMaxBlobChunk | The maximum number of bytes read/written to the server at once. 0 means do not limit "chunk" sizes, any other value determines the number of bytes.
ParamTypeFromNexusDB | This is constant nxdb.ParamTypeFromNexusDB.
ParamTypeToNexusDB | This is constant nxdb.ParamTypeToNexusDB.
rsCreateTableExNotSupported | This is constant nxdb.rsCreateTableExNotSupported.
rsDsCreateLookupFilterNotSupported | This is constant nxdb.rsDsCreateLookupFilterNotSupported.
rsFilterTypeNotSupported | This is constant nxdb.rsFilterTypeNotSupported.
rsGetBookmarkFlagNotSupported | This is constant nxdb.rsGetBookmarkFlagNotSupported.
rsGetBookmarkIsNotSupported | This is constant nxdb.rsGetBookmarkIsNotSupported.
rsGetBookmarkStrIsNotSupported | This is constant nxdb.rsGetBookmarkStrIsNotSupported.
rsKeyAsVariantIsNotSupported | This is constant nxdb.rsKeyAsVariantIsNotSupported.
rsPSGetDefaultOrderNotSupported | This is constant nxdb.rsPSGetDefaultOrderNotSupported.
rsPSGetIndexDefsNotSupported | This is constant nxdb.rsPSGetIndexDefsNotSupported.
rsPSGetTableNameNotSupported | This is constant nxdb.rsPSGetTableNameNotSupported.
rsRecRevRequired | This is constant nxdb.rsRecRevRequired.
SFieldIndexError | This is constant nxdb.SFieldIndexError.
SFieldValueError | This is constant nxdb.SFieldValueError.
SIndexFieldMissing | This is constant nxdb.SIndexFieldMissing.
SNoFieldIndexes | This is constant nxdb.SNoFieldIndexes.
SNotEditing | This is constant nxdb.SNotEditing.
SNotIndexField | This is constant nxdb.SNotIndexField.
Namespace

nxdb Namespace

Links
Constants, nxdb Namespace


nxdb.EmptySetKeyOptions Constant

nxdb.EmptySetKeyOptions Constant
nxdb Constants Send Feedback
Syntax
Delphi
EmptySetKeyOptions: TnxSetKeyOptions = [];
File

nxdb

Description

This is constant nxdb.EmptySetKeyOptions.

Group

Constants

Links
nxdb, Constants


nxdb.FldTypeMap Constant

nxdb.FldTypeMap Constant
nxdb Constants Send Feedback
Syntax
Delphi
FldTypeMap: TFieldMap = ( fldUNKNOWN, fldZSTRING, fldINT16, fldINT32, fldUINT16, fldBOOL, fldFLOAT, fldFLOAT, fldBCD, fldDATE, fldTIME, fldTIMESTAMP, fldBYTES, fldVARBYTES, fldINT32, fldBLOB, fldBLOB, fldBLOB, fldBLOB, fldBLOB, fldBLOB, fldBLOB, fldCURSOR, fldZSTRING, fldZSTRING, fldINT64, fldADT, fldArray, fldREF, fldTABLE, fldBLOB, fldBLOB, fldUNKNOWN, fldUNKNOWN, fldUNKNOWN, fldZSTRING, fldDATETIME, fldBCD, fldZSTRING, fldBLOB, fldDATETIME, fldINT32, fldINT32, fldINT16, fldUINT16, fldFLOAT, fldUNKNOWN , fldUNKNOWN , fldUNKNOWN , fldDATETIMEOFFSET , fldUNKNOWN , fldSINGLE );
File

nxdb

Description

49..51

Group

Constants

Links
nxdb, Constants


nxdb.nxMaxBlobChunk Constant

nxdb.nxMaxBlobChunk Constant
nxdb Constants Send Feedback
Syntax
Delphi
nxMaxBlobChunk: Integer = 512 * 1024;
File

nxdb

Description

The maximum number of bytes read/written to the server at once.

0 means do not limit "chunk" sizes, any other value determines the number of bytes.

Group

Constants

Links
nxdb, Constants


nxdb.ParamTypeFromNexusDB Constant

nxdb.ParamTypeFromNexusDB Constant
nxdb Constants Send Feedback
Syntax
Delphi
ParamTypeFromNexusDB: array[TnxParamType] of TParamType = ( ptUnknown, ptInput, ptOutput, ptInputOutput, ptResult );
File

nxdb

Description

This is constant nxdb.ParamTypeFromNexusDB.

Group

Constants

Links
nxdb, Constants


nxdb.ParamTypeToNexusDB Constant

nxdb.ParamTypeToNexusDB Constant
nxdb Constants Send Feedback
Syntax
Delphi
ParamTypeToNexusDB: array[TParamType] of TnxParamType = ( nxptUnknown, nxptInput, nxptOutput, nxptInputOutput, nxptResult );
File

nxdb

Description

This is constant nxdb.ParamTypeToNexusDB.

Group

Constants

Links
nxdb, Constants


nxdb.rsCreateTableExNotSupported Constant

nxdb.rsCreateTableExNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsCreateTableExNotSupported = 'CreateTableEx is not supported in FPC witho' + 'ut having FieldDefs specified';
File

nxdb

Description

This is constant nxdb.rsCreateTableExNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsDsCreateLookupFilterNotSupported Constant

nxdb.rsDsCreateLookupFilterNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsDsCreateLookupFilterNotSupported = 'dsCreateLookupFilter is not supporte' + 'd under FPC';
File

nxdb

Description

This is constant nxdb.rsDsCreateLookupFilterNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsFilterTypeNotSupported Constant

nxdb.rsFilterTypeNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsFilterTypeNotSupported = 'FilterType not supported';
File

nxdb

Description

This is constant nxdb.rsFilterTypeNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsGetBookmarkFlagNotSupported Constant

nxdb.rsGetBookmarkFlagNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsGetBookmarkFlagNotSupported = 'GetBookmarkFlag is not supported in Block' + 'Read mode';
File

nxdb

Description

This is constant nxdb.rsGetBookmarkFlagNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsGetBookmarkIsNotSupported Constant

nxdb.rsGetBookmarkIsNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsGetBookmarkIsNotSupported = 'GetBookmark is not supported in BlockRead m' + 'ode without specifying gboBookmarks in BlockReadOptions';
File

nxdb

Description

This is constant nxdb.rsGetBookmarkIsNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsGetBookmarkStrIsNotSupported Constant

nxdb.rsGetBookmarkStrIsNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsGetBookmarkStrIsNotSupported = 'GetBookmarkStr is not supported in BlockRead m' + 'ode without specifying gboBookmarks in BlockReadOptions';
File

nxdb

Description

This is constant nxdb.rsGetBookmarkStrIsNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsKeyAsVariantIsNotSupported Constant

nxdb.rsKeyAsVariantIsNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsKeyAsVariantIsNotSupported = 'KeyAsVariant is not supported in BlockRead m' + 'ode without specifying gboBookmarks in BlockReadOptions';
File

nxdb

Description

This is constant nxdb.rsKeyAsVariantIsNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsPSGetDefaultOrderNotSupported Constant

nxdb.rsPSGetDefaultOrderNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsPSGetDefaultOrderNotSupported = 'PSGetDefaultOrder not supported in FPC';
File

nxdb

Description

This is constant nxdb.rsPSGetDefaultOrderNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsPSGetIndexDefsNotSupported Constant

nxdb.rsPSGetIndexDefsNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsPSGetIndexDefsNotSupported = 'PSGetIndexDefs is not supported in FPC';
File

nxdb

Description

This is constant nxdb.rsPSGetIndexDefsNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsPSGetTableNameNotSupported Constant

nxdb.rsPSGetTableNameNotSupported Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsPSGetTableNameNotSupported = 'PSGetTableName is not supported in FPC';
File

nxdb

Description

This is constant nxdb.rsPSGetTableNameNotSupported.

Group

Constants

Links
nxdb, Constants


nxdb.rsRecRevRequired Constant

nxdb.rsRecRevRequired Constant
nxdb Constants Send Feedback
Syntax
Delphi
rsRecRevRequired = 'A RecRev field is required for optimistic locking';
File

nxdb

Description

This is constant nxdb.rsRecRevRequired.

Group

Constants

Links
nxdb, Constants


nxdb.SFieldIndexError Constant

nxdb.SFieldIndexError Constant
nxdb Constants Send Feedback
Syntax
Delphi
SFieldIndexError = 'Field index out of range';
File

nxdb

Description

This is constant nxdb.SFieldIndexError.

Group

Constants

Links
nxdb, Constants


nxdb.SFieldValueError Constant

nxdb.SFieldValueError Constant
nxdb Constants Send Feedback
Syntax
Delphi
SFieldValueError = 'Invalid value for field ''%s''';
File

nxdb

Description

This is constant nxdb.SFieldValueError.

Group

Constants

Links
nxdb, Constants


nxdb.SIndexFieldMissing Constant

nxdb.SIndexFieldMissing Constant
nxdb Constants Send Feedback
Syntax
Delphi
SIndexFieldMissing = 'Cannot access index field ''%s''';
File

nxdb

Description

This is constant nxdb.SIndexFieldMissing.

Group

Constants

Links
nxdb, Constants


nxdb.SNoFieldIndexes Constant

nxdb.SNoFieldIndexes Constant
nxdb Constants Send Feedback
Syntax
Delphi
SNoFieldIndexes = 'No index currently active';
File

nxdb

Description

This is constant nxdb.SNoFieldIndexes.

Group

Constants

Links
nxdb, Constants


nxdb.SNotEditing Constant

nxdb.SNotEditing Constant
nxdb Constants Send Feedback
Syntax
Delphi
SNotEditing = 'Dataset not in edit or insert mode';
File

nxdb

Description

This is constant nxdb.SNotEditing.

Group

Constants

Links
nxdb, Constants


nxdb.SNotIndexField Constant

nxdb.SNotIndexField Constant
nxdb Constants Send Feedback
Syntax
Delphi
SNotIndexField = 'Field ''%s'' is not indexed and cannot be modified';
File

nxdb

Description

This is constant nxdb.SNotIndexField.

Group

Constants

Links
nxdb, Constants


nxdbBackupController Namespace

nxdbBackupController Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxdbBackupController.

Classes
Name | Description
TnxBackupController | Component to do backup and restore of tables. The Backup and restore alias can not be the same. Backup is performed using a snapshot transaction, it is therefore safe to use it even if the database is being modified by other users while the backup is running. The backup is a snapshot of the state the database was in when the process started. Restore should be performed only while no other user has access to the database. The Restore process replaces the tables and does not currently support incremental restore. NOTE: To save storage space and execution time, the backed... more
Constants
Name | Description
rsCopyingDictionaries | This is constant nxdbBackupController.rsCopyingDictionaries.
rsCopyingRecords | This is constant nxdbBackupController.rsCopyingRecords.
rsRebuildingIndexes | This is constant nxdbBackupController.rsRebuildingIndexes.
Structs, Records, Enums
Name | Description
TnxbcMode | This is record nxdbBackupController.TnxbcMode.
TnxbcOption | bcoCloseInactiveOnSource : calls CloseInactiveTables/Folders on source database after backup bcoCloseInactiveOnTarget : calls CloseInactiveTables/Folders on target database after backup
TnxErrorAction | This is record nxdbBackupController.TnxErrorAction.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxAfterTableOpenEvent | Event called after source or destination table is opened. Called from TnxBackupController.
TnxbcOptions | This is type nxdbBackupController.TnxbcOptions.
TnxOnGetEncryptionEngineEvent | Event called before the creation of the target table to get the encryption engine to use. Called from TnxBackupController. Only called if EncryptionEngine property is blank.
TnxOnGetPasswordEvent | Event called before the creation of the target table to get the password to use. Called from TnxBackupController. Only called if BackupPassword property is blank.
TnxOnReportErrorEvent | Event that is called if any exception is triggered during backup or restore of a table. Called from TnxBackupController.
TnxOnTableNameEvent | Event used to decide wether or not to backup or restore a table. Called from TnxBackupController.
TnxOnTableProgressEvent | Event called during the copying of a single table to inform about copy progressing. Called from TnxBackupController.
TnxStringArray | This is type nxdbBackupController.TnxStringArray.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxdbBackupController Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBackupController | Component to do backup and restore of tables. The Backup and restore alias can not be the same. Backup is performed using a snapshot transaction, it is therefore safe to use it even if the database is being modified by other users while the backup is running. The backup is a snapshot of the state the database was in when the process started. Restore should be performed only while no other user has access to the database. The Restore process replaces the tables and does not currently support incremental restore. NOTE: To save storage space and execution time, the backed... more
Namespace

nxdbBackupController Namespace

Links
Classes, nxdbBackupController Namespace, Legend


TnxBackupController Class

TnxBackupController Class
TnxBackupController Fields TnxBackupController Methods TnxBackupController Properties TnxBackupController Events TnxBackupController Members nxdbBackupController Classes Send Feedback
Class Hierarchy
nxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupControllernxdbBackupController_TnxBackupController
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxBackupController = class(TnxDataAccessStateComponent);
File

nxdbBackupController

Description

Component to do backup and restore of tables. The Backup and restore alias can not be the same.

Backup is performed using a snapshot transaction, it is therefore safe to use it even if the database is being modified by other users while the backup is running. The backup is a snapshot of the state the database was in when the process started.

Restore should be performed only while no other user has access to the database. The Restore process replaces the tables and does not currently support incremental restore.

NOTE: To save storage space and execution time, the backed up tables are copied without indexes. To be able to restore the exact original table, the original dictionary is stored as a named stream in the backup copy. When the Restore process runs, it detects the original dictionary named stream, and recreates it before copying back records.

Group

Classes

Links
TnxBackupController Fields, TnxBackupController Methods, TnxBackupController Properties, TnxBackupController Events, TnxBackupController Members, nxdbBackupController, Classes


TnxBackupController Members

TnxBackupController Members
TnxBackupController Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBackupController.

Class

TnxBackupController Class

Protected Fields
Name | Description
bcAfterTableOpen | This is bcAfterTableOpen, a member of class TnxBackupController.
bcBackupPassword | This is bcBackupPassword, a member of class TnxBackupController.
bcBatchSize | This is bcBatchSize, a member of class TnxBackupController.
bcCloneDatabase | This is bcCloneDatabase, a member of class TnxBackupController.
bcCurrentAction | This is bcCurrentAction, a member of class TnxBackupController.
bcEncryptionEngine | This is bcEncryptionEngine, a member of class TnxBackupController.
bcIncludeTable | This is bcIncludeTable, a member of class TnxBackupController.
bcInCopyRecordsEx | This is bcInCopyRecordsEx, a member of class TnxBackupController.
bcKeepIndexes | This is bcKeepIndexes, a member of class TnxBackupController.
bcMaxTransSizeMB | This is bcMaxTransSizeMB, a member of class TnxBackupController.
bcMode | This is bcMode, a member of class TnxBackupController.
bcOnGetEncryptionEngine | This is bcOnGetEncryptionEngine, a member of class TnxBackupController.
bcOnGetPassword | This is bcOnGetPassword, a member of class TnxBackupController.
bcOnReportError | This is bcOnReportError, a member of class TnxBackupController.
bcOnTableProgress | This is bcOnTableProgress, a member of class TnxBackupController.
bcOptions | This is bcOptions, a member of class TnxBackupController.
bcOriginalDatabase | private
bcOverwriteTable | This is bcOverwriteTable, a member of class TnxBackupController.
bcProcessedNoError | This is bcProcessedNoError, a member of class TnxBackupController.
bcSkippedTablesCount | This is bcSkippedTablesCount, a member of class TnxBackupController.
bcSourceThreadPriority | This is bcSourceThreadPriority, a member of class TnxBackupController.
bcTablesToProcess | This is bcTablesToProcess, a member of class TnxBackupController.
bcTargetThreadPriority | This is bcTargetThreadPriority, a member of class TnxBackupController.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bcSetCloneDatabase |
bcSetKeepIndexes |
bcSetOriginalDatabase |
dascExceptionClass |
Execute |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
IncludeTable |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
OverwriteTable |
rcRegister |
rcUnregister |
ReportError |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
Backup | Call this function to initiate a backup. The source and target databases must be assigned. TnxBackupController
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create |
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
Restore | Call this function to initiate a restore. The source and target databases must be assigned.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
SetTableList | Call this method to preset the list of tables to be backed up before running. If a table is not in this list, it is not backed up.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
CurrentAction | This is CurrentAction, a member of class TnxBackupController.
InCopyRecordsEx | This is InCopyRecordsEx, a member of class TnxBackupController.
Mode | Determines if the component is in backup or restore mode.
ProcessedNoError | After processing, the number of tables that was successfully processed during the operation.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Events
Name | Description
OnAfterTableOpen | Event called after source or destination table is opened. Use if you need special processing for a table before backing up or restoring.
OnGetEncryptionEngine | Called to get an (optional) encryption engine for the target table(s). Only called if EncryptionEngine is blank.
OnGetPasswordEvent | Called to get an (optional) password for the target table(s). Only called if BackupPassword is blank.
OnIncludeTable | Event used to decide wether or not to backup or restore a table. As default, all tables are included.
OnOverwriteTable | Event used to decide wether or not to overwrite a table.
OnReportError | Event that is called if any exception is triggered during backup or restore of a table. The aAction parameter works as follows: If set to eaFail, reraises the exception (and ends the backup/restore process) If set to eaAbort, raises the silent Abort exception (and ends the backup/restore process) If set to eaTryNext, ignores the exception and tries the next table in sequence.
OnTableProgress | Event called during the copying of a single table to inform about copy progressing. Note that if source and target databases use the same NexusDB Server, then the copying is done in a single step and only 0% and 100% events will be triggered.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
BackupPassword | (Optional) Password for the target table(s).
BatchSize | The size of the batch operations used, in bytes.
CloneDatabase | The database where the backed up data is stored (in other words the target when backing up, or the source when restoring).
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EncryptionEngine | The encryption engine to use for the backup tables.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
KeepIndexes | As default, the backup operation does not keep indexes in the backup tables, in order to save space and backup time. Set KeepIndexes to True if you wish to keep indexes in the backup tables.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
MaxTransSizeMB | Maximum size of transactions used, in megabytes.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Options | Backupcontroller options See Also: TnxbcOptions
OriginalDatabase | The database where the original data is stored (in other words the source when backing up, or the target when restoring).
SkippedTablesCount | This is SkippedTablesCount, a member of class TnxBackupController.
SourceThreadPriority | The priority of the backup process in the connected server(s)
TargetThreadPriority | This is TargetThreadPriority, a member of class TnxBackupController.
Version | Version of the component.
Links
TnxBackupController Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxBackupController.Create Constructor

TnxBackupController.Create Constructor
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Class

TnxBackupController Class

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Class


TnxBackupController Fields

TnxBackupController Fields
TnxBackupController Class Legend Protected Fields Send Feedback

The fields of the TnxBackupController class are listed here.

Class

TnxBackupController Class

Protected Fields
Name | Description
bcAfterTableOpen | This is bcAfterTableOpen, a member of class TnxBackupController.
bcBackupPassword | This is bcBackupPassword, a member of class TnxBackupController.
bcBatchSize | This is bcBatchSize, a member of class TnxBackupController.
bcCloneDatabase | This is bcCloneDatabase, a member of class TnxBackupController.
bcCurrentAction | This is bcCurrentAction, a member of class TnxBackupController.
bcEncryptionEngine | This is bcEncryptionEngine, a member of class TnxBackupController.
bcIncludeTable | This is bcIncludeTable, a member of class TnxBackupController.
bcInCopyRecordsEx | This is bcInCopyRecordsEx, a member of class TnxBackupController.
bcKeepIndexes | This is bcKeepIndexes, a member of class TnxBackupController.
bcMaxTransSizeMB | This is bcMaxTransSizeMB, a member of class TnxBackupController.
bcMode | This is bcMode, a member of class TnxBackupController.
bcOnGetEncryptionEngine | This is bcOnGetEncryptionEngine, a member of class TnxBackupController.
bcOnGetPassword | This is bcOnGetPassword, a member of class TnxBackupController.
bcOnReportError | This is bcOnReportError, a member of class TnxBackupController.
bcOnTableProgress | This is bcOnTableProgress, a member of class TnxBackupController.
bcOptions | This is bcOptions, a member of class TnxBackupController.
bcOriginalDatabase | private
bcOverwriteTable | This is bcOverwriteTable, a member of class TnxBackupController.
bcProcessedNoError | This is bcProcessedNoError, a member of class TnxBackupController.
bcSkippedTablesCount | This is bcSkippedTablesCount, a member of class TnxBackupController.
bcSourceThreadPriority | This is bcSourceThreadPriority, a member of class TnxBackupController.
bcTablesToProcess | This is bcTablesToProcess, a member of class TnxBackupController.
bcTargetThreadPriority | This is bcTargetThreadPriority, a member of class TnxBackupController.
Links
TnxBackupController Class, Legend, Protected Fields


TnxBackupController.bcAfterTableOpen Field

TnxBackupController.bcAfterTableOpen Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcAfterTableOpen: TnxAfterTableOpenEvent;
Description

This is bcAfterTableOpen, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcBackupPassword Field

TnxBackupController.bcBackupPassword Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcBackupPassword: UnicodeString;
Description

This is bcBackupPassword, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcBatchSize Field

TnxBackupController.bcBatchSize Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcBatchSize: TnxWord32;
Description

This is bcBatchSize, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcCloneDatabase Field

TnxBackupController.bcCloneDatabase Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcCloneDatabase: TnxDatabase;
Description

This is bcCloneDatabase, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcCurrentAction Field

TnxBackupController.bcCurrentAction Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcCurrentAction: String;
Description

This is bcCurrentAction, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcEncryptionEngine Field

TnxBackupController.bcEncryptionEngine Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcEncryptionEngine: string;
Description

This is bcEncryptionEngine, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcIncludeTable Field

TnxBackupController.bcIncludeTable Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcIncludeTable: TnxOnTableNameEvent;
Description

This is bcIncludeTable, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcInCopyRecordsEx Field

TnxBackupController.bcInCopyRecordsEx Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcInCopyRecordsEx: Boolean;
Description

This is bcInCopyRecordsEx, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcKeepIndexes Field

TnxBackupController.bcKeepIndexes Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcKeepIndexes: Boolean;
Description

This is bcKeepIndexes, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcMaxTransSizeMB Field

TnxBackupController.bcMaxTransSizeMB Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcMaxTransSizeMB: TnxWord32;
Description

This is bcMaxTransSizeMB, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcMode Field

TnxBackupController.bcMode Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcMode: TnxbcMode;
Description

This is bcMode, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOnGetEncryptionEngine Field

TnxBackupController.bcOnGetEncryptionEngine Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOnGetEncryptionEngine: TnxOnGetEncryptionEngineEvent;
Description

This is bcOnGetEncryptionEngine, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOnGetPassword Field

TnxBackupController.bcOnGetPassword Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOnGetPassword: TnxOnGetPasswordEvent;
Description

This is bcOnGetPassword, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOnReportError Field

TnxBackupController.bcOnReportError Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOnReportError: TnxOnReportErrorEvent;
Description

This is bcOnReportError, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOnTableProgress Field

TnxBackupController.bcOnTableProgress Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOnTableProgress: TnxOnTableProgressEvent;
Description

This is bcOnTableProgress, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOptions Field

TnxBackupController.bcOptions Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOptions: TnxbcOptions;
Description

This is bcOptions, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOriginalDatabase Field

TnxBackupController.bcOriginalDatabase Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOriginalDatabase: TnxDatabase;
Description

private

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcOverwriteTable Field

TnxBackupController.bcOverwriteTable Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcOverwriteTable: TnxOnTableNameEvent;
Description

This is bcOverwriteTable, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcProcessedNoError Field

TnxBackupController.bcProcessedNoError Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcProcessedNoError: Integer;
Description

This is bcProcessedNoError, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcSkippedTablesCount Field

TnxBackupController.bcSkippedTablesCount Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcSkippedTablesCount: Integer;
Description

This is bcSkippedTablesCount, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcSourceThreadPriority Field

TnxBackupController.bcSourceThreadPriority Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcSourceThreadPriority: TnxThreadPriority;
Description

This is bcSourceThreadPriority, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcTablesToProcess Field

TnxBackupController.bcTablesToProcess Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcTablesToProcess: TnxStringArray;
Description

This is bcTablesToProcess, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController.bcTargetThreadPriority Field

TnxBackupController.bcTargetThreadPriority Field
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Fields Send Feedback
Syntax
Delphi
bcTargetThreadPriority: TnxThreadPriority;
Description

This is bcTargetThreadPriority, a member of class TnxBackupController.

Group

TnxBackupController Fields

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Fields


TnxBackupController Methods

TnxBackupController Methods
TnxBackupController Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBackupController class are listed here.

Class

TnxBackupController Class

Protected Methods
Name | Description
bcSetCloneDatabase |
bcSetKeepIndexes |
bcSetOriginalDatabase |
Execute |
IncludeTable |
OverwriteTable |
ReportError |
scInitializing |
scIsStateParent |
Public Methods
Name | Description
Backup | Call this function to initiate a backup. The source and target databases must be assigned. TnxBackupController
Restore | Call this function to initiate a restore. The source and target databases must be assigned.
SetTableList | Call this method to preset the list of tables to be backed up before running. If a table is not in this list, it is not backed up.
Links
TnxBackupController Class, Legend, Protected Methods, Public Methods


TnxBackupController.Backup Method

TnxBackupController.Backup Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure Backup;
Description

Call this function to initiate a backup. The source and target databases must be assigned.

TnxBackupController

Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.bcSetCloneDatabase Method

TnxBackupController.bcSetCloneDatabase Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure bcSetCloneDatabase(Value: TnxDatabase);
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.bcSetKeepIndexes Method

TnxBackupController.bcSetKeepIndexes Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure bcSetKeepIndexes(Value: Boolean);
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.bcSetOriginalDatabase Method

TnxBackupController.bcSetOriginalDatabase Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure bcSetOriginalDatabase(Value: TnxDatabase);
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.Execute Method

TnxBackupController.Execute Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure Execute(bcSourceDatabase: TnxDatabase; bcTargetDatabase: TnxDatabase);
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.IncludeTable Method

TnxBackupController.IncludeTable Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
function IncludeTable(const aTableName: string): Boolean;
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.OverwriteTable Method

TnxBackupController.OverwriteTable Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
function OverwriteTable(const aTableName: string): Boolean;
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.ReportError Method

TnxBackupController.ReportError Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
function ReportError(const aTableName: string; aException: Exception): TnxErrorAction;
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.Restore Method

TnxBackupController.Restore Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure Restore;
Description

Call this function to initiate a restore. The source and target databases must be assigned.

Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.scInitializing Method

TnxBackupController.scInitializing Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.scIsStateParent Method

TnxBackupController.scIsStateParent Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController.SetTableList Method

TnxBackupController.SetTableList Method
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Methods Send Feedback
Syntax
Delphi
procedure SetTableList(const aList: TnxStringArray);
Description

Call this method to preset the list of tables to be backed up before running. If a table is not in this list, it is not backed up.

Notes

If this method is called with a non-empty list, then the OnIncludeTable event is disabled and will not be called during running.

Group

TnxBackupController Methods

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Methods


TnxBackupController Properties

TnxBackupController Properties
TnxBackupController Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBackupController class are listed here.

Class

TnxBackupController Class

Public Properties
Name | Description
CurrentAction | This is CurrentAction, a member of class TnxBackupController.
InCopyRecordsEx | This is InCopyRecordsEx, a member of class TnxBackupController.
Mode | Determines if the component is in backup or restore mode.
ProcessedNoError | After processing, the number of tables that was successfully processed during the operation.
Published Properties
Name | Description
BackupPassword | (Optional) Password for the target table(s).
BatchSize | The size of the batch operations used, in bytes.
CloneDatabase | The database where the backed up data is stored (in other words the target when backing up, or the source when restoring).
EncryptionEngine | The encryption engine to use for the backup tables.
KeepIndexes | As default, the backup operation does not keep indexes in the backup tables, in order to save space and backup time. Set KeepIndexes to True if you wish to keep indexes in the backup tables.
MaxTransSizeMB | Maximum size of transactions used, in megabytes.
Options | Backupcontroller options See Also: TnxbcOptions
OriginalDatabase | The database where the original data is stored (in other words the source when backing up, or the target when restoring).
SkippedTablesCount | This is SkippedTablesCount, a member of class TnxBackupController.
SourceThreadPriority | The priority of the backup process in the connected server(s)
TargetThreadPriority | This is TargetThreadPriority, a member of class TnxBackupController.
Links
TnxBackupController Class, Legend, Public Properties, Published Properties


TnxBackupController.BackupPassword Property

TnxBackupController.BackupPassword Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property BackupPassword: UnicodeString;
Description

(Optional) Password for the target table(s).

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.BatchSize Property

TnxBackupController.BatchSize Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property BatchSize: TnxWord32;
Description

The size of the batch operations used, in bytes.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.CloneDatabase Property

TnxBackupController.CloneDatabase Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property CloneDatabase: TnxDatabase;
Description

The database where the backed up data is stored (in other words the target when backing up, or the source when restoring).

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.CurrentAction Property

TnxBackupController.CurrentAction Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property CurrentAction: String;
Description

This is CurrentAction, a member of class TnxBackupController.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.EncryptionEngine Property

TnxBackupController.EncryptionEngine Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property EncryptionEngine: string;
Description

The encryption engine to use for the backup tables.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.InCopyRecordsEx Property

TnxBackupController.InCopyRecordsEx Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property InCopyRecordsEx: Boolean;
Description

This is InCopyRecordsEx, a member of class TnxBackupController.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.KeepIndexes Property

TnxBackupController.KeepIndexes Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property KeepIndexes: Boolean;
Description

As default, the backup operation does not keep indexes in the backup tables, in order to save space and backup time. Set KeepIndexes to True if you wish to keep indexes in the backup tables.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.MaxTransSizeMB Property

TnxBackupController.MaxTransSizeMB Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property MaxTransSizeMB: TnxWord32;
Description

Maximum size of transactions used, in megabytes.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.Mode Property

TnxBackupController.Mode Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property Mode: TnxbcMode;
Description

Determines if the component is in backup or restore mode.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.Options Property

TnxBackupController.Options Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property Options: TnxbcOptions;
Description

Backupcontroller options

See Also: TnxbcOptions

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.OriginalDatabase Property

TnxBackupController.OriginalDatabase Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property OriginalDatabase: TnxDatabase;
Description

The database where the original data is stored (in other words the source when backing up, or the target when restoring).

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.ProcessedNoError Property

TnxBackupController.ProcessedNoError Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property ProcessedNoError: Integer;
Description

After processing, the number of tables that was successfully processed during the operation.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.SkippedTablesCount Property

TnxBackupController.SkippedTablesCount Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property SkippedTablesCount: Integer;
Description

This is SkippedTablesCount, a member of class TnxBackupController.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.SourceThreadPriority Property

TnxBackupController.SourceThreadPriority Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property SourceThreadPriority: TnxThreadPriority;
Description

The priority of the backup process in the connected server(s)

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController.TargetThreadPriority Property

TnxBackupController.TargetThreadPriority Property
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Properties Send Feedback
Syntax
Delphi
property TargetThreadPriority: TnxThreadPriority;
Description

This is TargetThreadPriority, a member of class TnxBackupController.

Group

TnxBackupController Properties

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Properties


TnxBackupController Events

TnxBackupController Events
TnxBackupController Class Legend Published Events Send Feedback

The events of the TnxBackupController class are listed here.

Class

TnxBackupController Class

Published Events
Name | Description
OnAfterTableOpen | Event called after source or destination table is opened. Use if you need special processing for a table before backing up or restoring.
OnGetEncryptionEngine | Called to get an (optional) encryption engine for the target table(s). Only called if EncryptionEngine is blank.
OnGetPasswordEvent | Called to get an (optional) password for the target table(s). Only called if BackupPassword is blank.
OnIncludeTable | Event used to decide wether or not to backup or restore a table. As default, all tables are included.
OnOverwriteTable | Event used to decide wether or not to overwrite a table.
OnReportError | Event that is called if any exception is triggered during backup or restore of a table. The aAction parameter works as follows: If set to eaFail, reraises the exception (and ends the backup/restore process) If set to eaAbort, raises the silent Abort exception (and ends the backup/restore process) If set to eaTryNext, ignores the exception and tries the next table in sequence.
OnTableProgress | Event called during the copying of a single table to inform about copy progressing. Note that if source and target databases use the same NexusDB Server, then the copying is done in a single step and only 0% and 100% events will be triggered.
Links
TnxBackupController Class, Legend, Published Events


TnxBackupController.OnAfterTableOpen Event

TnxBackupController.OnAfterTableOpen Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnAfterTableOpen: TnxAfterTableOpenEvent;
Parameters
Parameters | Description
aTable | the TnxTable that just was opened
aIsSource | True if the table is a source table
Description

Event called after source or destination table is opened. Use if you need special processing for a table before backing up or restoring.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnGetEncryptionEngine Event

TnxBackupController.OnGetEncryptionEngine Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnGetEncryptionEngine: TnxOnGetEncryptionEngineEvent;
Description

Called to get an (optional) encryption engine for the target table(s). Only called if EncryptionEngine is blank.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnGetPasswordEvent Event

TnxBackupController.OnGetPasswordEvent Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnGetPasswordEvent: TnxOnGetPasswordEvent;
Description

Called to get an (optional) password for the target table(s). Only called if BackupPassword is blank.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnIncludeTable Event

TnxBackupController.OnIncludeTable Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnIncludeTable: TnxOnTableNameEvent;
Parameters
Parameters | Description
aTableName | Name of the table to be included or not
aUseTable | True if the table should be included
Description

Event used to decide wether or not to backup or restore a table. As default, all tables are included.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnOverwriteTable Event

TnxBackupController.OnOverwriteTable Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnOverwriteTable: TnxOnTableNameEvent;
Description

Event used to decide wether or not to overwrite a table.

Notes

not yet implemented.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnReportError Event

TnxBackupController.OnReportError Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnReportError: TnxOnReportErrorEvent;
Parameters
Parameters | Description
aTableName | Name of the table the exception occurred on
aException | the exception that was raised
aAction | Determines how the process progresses after the exception. Note: In version 1, aAction was defined as TDataAction. See Also: TnxOnReportErrorEvent
Description

Event that is called if any exception is triggered during backup or restore of a table.

The aAction parameter works as follows: If set to eaFail, reraises the exception (and ends the backup/restore process) If set to eaAbort, raises the silent Abort exception (and ends the backup/restore process) If set to eaTryNext, ignores the exception and tries the next table in sequence.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


TnxBackupController.OnTableProgress Event

TnxBackupController.OnTableProgress Event
TnxBackupController Class TnxBackupController Members nxdbBackupController Namespace TnxBackupController Events Send Feedback
Syntax
Delphi
property OnTableProgress: TnxOnTableProgressEvent;
Description

Event called during the copying of a single table to inform about copy progressing. Note that if source and target databases use the same NexusDB Server, then the copying is done in a single step and only 0% and 100% events will be triggered.

Group

TnxBackupController Events

Links
TnxBackupController Class, TnxBackupController Members, nxdbBackupController Namespace, TnxBackupController Events


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxdbBackupController Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxbcMode | This is record nxdbBackupController.TnxbcMode.
TnxbcOption | bcoCloseInactiveOnSource : calls CloseInactiveTables/Folders on source database after backup bcoCloseInactiveOnTarget : calls CloseInactiveTables/Folders on target database after backup
TnxErrorAction | This is record nxdbBackupController.TnxErrorAction.
Namespace

nxdbBackupController Namespace

Links
Enumerations, nxdbBackupController Namespace, Legend


nxdbBackupController.TnxbcMode Enumeration

nxdbBackupController.TnxbcMode Enumeration
nxdbBackupController Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxbcMode = ( bcmNone, bcmBackup, bcmRestore );
File

nxdbBackupController

Description

This is record nxdbBackupController.TnxbcMode.

Group

Structs, Records, Enums

Links
nxdbBackupController, Structs, Records, Enums


nxdbBackupController.TnxbcOption Enumeration

nxdbBackupController.TnxbcOption Enumeration
nxdbBackupController Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxbcOption = ( bcoCloseInactiveOnSource, bcoCloseInactiveOnTarget );
File

nxdbBackupController

Description

bcoCloseInactiveOnSource : calls CloseInactiveTables/Folders on source database after backup bcoCloseInactiveOnTarget : calls CloseInactiveTables/Folders on target database after backup

Group

Structs, Records, Enums

Links
nxdbBackupController, Structs, Records, Enums


nxdbBackupController.TnxErrorAction Enumeration

nxdbBackupController.TnxErrorAction Enumeration
nxdbBackupController Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxErrorAction = ( eaFail, eaAbort, eaTryNext );
File

nxdbBackupController

Description

This is record nxdbBackupController.TnxErrorAction.

Group

Structs, Records, Enums

Links
nxdbBackupController, Structs, Records, Enums


Types

Types
nxdbBackupController Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdbBackupController Namespace

Types
Name | Description
TnxAfterTableOpenEvent | Event called after source or destination table is opened. Called from TnxBackupController.
TnxbcOptions | This is type nxdbBackupController.TnxbcOptions.
TnxOnGetEncryptionEngineEvent | Event called before the creation of the target table to get the encryption engine to use. Called from TnxBackupController. Only called if EncryptionEngine property is blank.
TnxOnGetPasswordEvent | Event called before the creation of the target table to get the password to use. Called from TnxBackupController. Only called if BackupPassword property is blank.
TnxOnReportErrorEvent | Event that is called if any exception is triggered during backup or restore of a table. Called from TnxBackupController.
TnxOnTableNameEvent | Event used to decide wether or not to backup or restore a table. Called from TnxBackupController.
TnxOnTableProgressEvent | Event called during the copying of a single table to inform about copy progressing. Called from TnxBackupController.
TnxStringArray | This is type nxdbBackupController.TnxStringArray.
Links
nxdbBackupController Namespace, Types


nxdbBackupController.TnxAfterTableOpenEvent Type

nxdbBackupController.TnxAfterTableOpenEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxAfterTableOpenEvent = procedure (aSender : TnxBackupController; aTable : TnxTable; aIsSource : Boolean) of object;
File

nxdbBackupController

Description

Event called after source or destination table is opened. Called from TnxBackupController.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxbcOptions Type

nxdbBackupController.TnxbcOptions Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxbcOptions = set of TnxbcOption;
File

nxdbBackupController

Description

This is type nxdbBackupController.TnxbcOptions.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxOnGetEncryptionEngineEvent Type

nxdbBackupController.TnxOnGetEncryptionEngineEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxOnGetEncryptionEngineEvent = procedure (aSender : TnxBackupController; const aTableName : UnicodeString; var aEncryptionEngine : UnicodeString) of object;
File

nxdbBackupController

Description

Event called before the creation of the target table to get the encryption engine to use. Called from TnxBackupController. Only called if EncryptionEngine property is blank.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxOnGetPasswordEvent Type

nxdbBackupController.TnxOnGetPasswordEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxOnGetPasswordEvent = procedure (aSender : TnxBackupController; const aTableName : UnicodeString; var aTablePassword : UnicodeString) of object;
File

nxdbBackupController

Description

Event called before the creation of the target table to get the password to use. Called from TnxBackupController. Only called if BackupPassword property is blank.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxOnReportErrorEvent Type

nxdbBackupController.TnxOnReportErrorEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxOnReportErrorEvent = procedure (aSender : TnxBackupController; const aTableName : string; aException : Exception; var aAction : TnxErrorAction) of object;
File

nxdbBackupController

Description

Event that is called if any exception is triggered during backup or restore of a table. Called from TnxBackupController.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxOnTableNameEvent Type

nxdbBackupController.TnxOnTableNameEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxOnTableNameEvent = procedure (aSender : TnxBackupController; const aTableName : string; var aUseTable : Boolean) of object;
File

nxdbBackupController

Description

Event used to decide wether or not to backup or restore a table. Called from TnxBackupController.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxOnTableProgressEvent Type

nxdbBackupController.TnxOnTableProgressEvent Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxOnTableProgressEvent = procedure (aSender : TnxBackupController; aPercentDone : Integer) of object;
File

nxdbBackupController

Description

Event called during the copying of a single table to inform about copy progressing. Called from TnxBackupController.

Group

Types

Links
nxdbBackupController, Types


nxdbBackupController.TnxStringArray Type

nxdbBackupController.TnxStringArray Type
nxdbBackupController Types Send Feedback
Syntax
Delphi
TnxStringArray = array of string;
File

nxdbBackupController

Description

This is type nxdbBackupController.TnxStringArray.

Group

Types

Links
nxdbBackupController, Types


Constants

Constants
Constants nxdbBackupController Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsCopyingDictionaries | This is constant nxdbBackupController.rsCopyingDictionaries.
rsCopyingRecords | This is constant nxdbBackupController.rsCopyingRecords.
rsRebuildingIndexes | This is constant nxdbBackupController.rsRebuildingIndexes.
Namespace

nxdbBackupController Namespace

Links
Constants, nxdbBackupController Namespace


nxdbBackupController.rsCopyingDictionaries Constant

nxdbBackupController.rsCopyingDictionaries Constant
nxdbBackupController Constants Send Feedback
Syntax
Delphi
rsCopyingDictionaries = 'Copying data dictionary ...';
File

nxdbBackupController

Description

This is constant nxdbBackupController.rsCopyingDictionaries.

Group

Constants

Links
nxdbBackupController, Constants


nxdbBackupController.rsCopyingRecords Constant

nxdbBackupController.rsCopyingRecords Constant
nxdbBackupController Constants Send Feedback
Syntax
Delphi
rsCopyingRecords = 'Copying records...';
File

nxdbBackupController

Description

This is constant nxdbBackupController.rsCopyingRecords.

Group

Constants

Links
nxdbBackupController, Constants


nxdbBackupController.rsRebuildingIndexes Constant

nxdbBackupController.rsRebuildingIndexes Constant
nxdbBackupController Constants Send Feedback
Syntax
Delphi
rsRebuildingIndexes = 'Rebuilding Table Indexes...';
File

nxdbBackupController

Description

This is constant nxdbBackupController.rsRebuildingIndexes.

Group

Constants

Links
nxdbBackupController, Constants


nxdbBase Namespace

nxdbBase Namespace
Classes Functions Legend Topics Types Send Feedback

This is namespace nxdbBase.

Classes
Name | Description
EnxDatabaseError | This is class nxdbBase.EnxDatabaseError.
Functions
Name | Description
Check | Interfaced helper routines
nxCreateOSError | HPPEMIT 'namespace Nxdbbase' HPPEMIT '{' HPPEMIT 'class DELPHICLASS EnxDatabaseError;' HPPEMIT 'class PASCALIMPLEMENTATION EnxDatabaseError : public Db::EDatabaseError' HPPEMIT '{' HPPEMIT ' typedef Db::EDatabaseError inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' int deErrorCode;' HPPEMIT ' AnsiString deErrorString;' HPPEMIT ' bool deExtendedMsg;' HPPEMIT ' Classes::TStrings* deCustomInfos;' HPPEMIT ' unsigned deOSError;' HPPEMIT ' HRESULT __stdcall QueryInterface(const GUID &IID, /* out */ void *Obj);' HPPEMIT ' int __stdcall _AddRef(void);' HPPEMIT ' int __stdcall _Release(void);' HPPEMIT ' Nxlltypes::TnxResult __fastcall GetErrorCode(void);' HPPEMIT ' AnsiString __fastcall GetErrorString();' HPPEMIT ' AnsiString __fastcall GetProcessedErrorString();' HPPEMIT ' bool __fastcall GetExtendedMsg(void);' HPPEMIT... more
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
EnxDatabaseErrorClass | This is type nxdbBase.EnxDatabaseErrorClass.
Links
Classes, Functions, Legend, Topics, Types


Classes

Classes
Classes nxdbBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxDatabaseError | This is class nxdbBase.EnxDatabaseError.
Namespace

nxdbBase Namespace

Links
Classes, nxdbBase Namespace, Legend


EnxDatabaseError Class

EnxDatabaseError Class
nxcCreate Constructor nxCreate Constructor EnxDatabaseError Fields EnxDatabaseError Methods EnxDatabaseError Properties EnxDatabaseError Members nxdbBase Classes Send Feedback
Class Hierarchy
nxdbBase_EnxDatabaseErrornxdbBase_EnxDatabaseErrornxdbBase_EnxDatabaseError
Syntax
Delphi
EnxDatabaseError = class(EDatabaseError, InxInterface, InxBaseException, InxException);
File

nxdbBase

Description

This is class nxdbBase.EnxDatabaseError.

Group

Classes

Links
nxcCreate Constructor, nxCreate Constructor, EnxDatabaseError Fields, EnxDatabaseError Methods, EnxDatabaseError Properties, EnxDatabaseError Members, nxdbBase, Classes


EnxDatabaseError Members

EnxDatabaseError Members
EnxDatabaseError Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by EnxDatabaseError.

Class

EnxDatabaseError Class

Protected Fields
Name | Description
deCustomInfos | This is deCustomInfos, a member of class EnxDatabaseError.
deErrorCode | private
deErrorString | This is deErrorString, a member of class EnxDatabaseError.
deExceptionData | This is deExceptionData, a member of class EnxDatabaseError.
deExtendedMsg | This is deExtendedMsg, a member of class EnxDatabaseError.
deOSError | This is deOSError, a member of class EnxDatabaseError.
Protected Methods
Name | Description
_AddRef | This is _AddRef, a member of class EnxDatabaseError.
_Release | This is _Release, a member of class EnxDatabaseError.
deGetComponentName |
deMsgForErrorCode |
deProcessTemplate | This is deProcessTemplate, a member of class EnxDatabaseError.
deStripCustomInfos | This is deStripCustomInfos, a member of class EnxDatabaseError.
GetCustomInfos | This is GetCustomInfos, a member of class EnxDatabaseError.
GetErrorCode | InxException
GetErrorString | This is GetErrorString, a member of class EnxDatabaseError.
GetExceptionData | This is GetExceptionData, a member of class EnxDatabaseError.
GetExtendedMsg | This is GetExtendedMsg, a member of class EnxDatabaseError.
GetOSError | This is GetOSError, a member of class EnxDatabaseError.
GetProcessedErrorString | This is GetProcessedErrorString, a member of class EnxDatabaseError.
QueryInterface | InxInterface
Public Methods
Name | Description
Destroy |
nxcCreate | This is the overview for the nxcCreate constructor overload.
nxCreate | This is the overview for the nxCreate constructor overload.
Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class EnxDatabaseError.
ErrorCode | This is ErrorCode, a member of class EnxDatabaseError.
ErrorString | This is ErrorString, a member of class EnxDatabaseError.
ExceptionData | This is ExceptionData, a member of class EnxDatabaseError.
ExtendedMsg | This is ExtendedMsg, a member of class EnxDatabaseError.
OSError | This is OSError, a member of class EnxDatabaseError.
ProcessedErrorString | This is ProcessedErrorString, a member of class EnxDatabaseError.
Links
EnxDatabaseError Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


EnxDatabaseError.Destroy Destructor

EnxDatabaseError.Destroy Destructor
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

EnxDatabaseError Class

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Class


nxcCreate Constructor

nxcCreate Constructor
EnxDatabaseError Class Send Feedback

This is the overview for the nxcCreate constructor overload.

Overload List
Name | Description
EnxDatabaseError.nxcCreate (TComponent, PResStringRec) |
EnxDatabaseError.nxcCreate (TComponent, PResStringRec, array of const) |
EnxDatabaseError.nxcCreate (TComponent, string) |
EnxDatabaseError.nxcCreate (TComponent, string, array of const) |
EnxDatabaseError.nxcCreate (TComponent, TnxResult) |
EnxDatabaseError.nxcCreate (TComponent, TnxResult, string) |
EnxDatabaseError.nxcCreate (TComponent, TnxResult, string, array of const) |
Class

EnxDatabaseError Class

Links
EnxDatabaseError Class


EnxDatabaseError.nxcCreate Constructor (TComponent, PResStringRec)

EnxDatabaseError.nxcCreate Constructor (TComponent, PResStringRec)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aMsgRes: PResStringRec); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, PResStringRec, array of const)

EnxDatabaseError.nxcCreate Constructor (TComponent, PResStringRec, array of const)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aMsgRes: PResStringRec; const aArgs: array of const); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult)

EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult, string)

EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult, string)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; const aAltMsg: string); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult, string, array of const)

EnxDatabaseError.nxcCreate Constructor (TComponent, TnxResult, string, array of const)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, string)

EnxDatabaseError.nxcCreate Constructor (TComponent, string)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; const aMsg: string); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


EnxDatabaseError.nxcCreate Constructor (TComponent, string, array of const)

EnxDatabaseError.nxcCreate Constructor (TComponent, string, array of const)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; const aMsg: string; const aArgs: array of const); overload;
Group

nxcCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxcCreate Constructor


nxCreate Constructor

nxCreate Constructor
EnxDatabaseError Class Send Feedback

This is the overview for the nxCreate constructor overload.

Overload List
Name | Description
EnxDatabaseError.nxCreate (string) |
EnxDatabaseError.nxCreate (string, array of const) |
EnxDatabaseError.nxCreate (TnxResult) |
EnxDatabaseError.nxCreate (TnxResult, string) |
EnxDatabaseError.nxCreate (TnxResult, string, array of const) |
Class

EnxDatabaseError Class

Links
EnxDatabaseError Class


EnxDatabaseError.nxCreate Constructor (TnxResult)

EnxDatabaseError.nxCreate Constructor (TnxResult)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxCreate Constructor Send Feedback
Syntax
Delphi
constructor nxCreate(aErrorCode: TnxResult); overload;
Group

nxCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxCreate Constructor


EnxDatabaseError.nxCreate Constructor (TnxResult, string)

EnxDatabaseError.nxCreate Constructor (TnxResult, string)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxCreate Constructor Send Feedback
Syntax
Delphi
constructor nxCreate(aErrorCode: TnxResult; const aAltMsg: string); overload;
Group

nxCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxCreate Constructor


EnxDatabaseError.nxCreate Constructor (TnxResult, string, array of const)

EnxDatabaseError.nxCreate Constructor (TnxResult, string, array of const)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxCreate Constructor Send Feedback
Syntax
Delphi
constructor nxCreate(aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const); overload;
Group

nxCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxCreate Constructor


EnxDatabaseError.nxCreate Constructor (string)

EnxDatabaseError.nxCreate Constructor (string)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxCreate Constructor Send Feedback
Syntax
Delphi
constructor nxCreate(const aMsg: string); overload;
Group

nxCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxCreate Constructor


EnxDatabaseError.nxCreate Constructor (string, array of const)

EnxDatabaseError.nxCreate Constructor (string, array of const)
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace nxCreate Constructor Send Feedback
Syntax
Delphi
constructor nxCreate(const aMsg: string; const aArgs: array of const); overload;
Group

nxCreate Constructor

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, nxCreate Constructor


EnxDatabaseError Fields

EnxDatabaseError Fields
EnxDatabaseError Class Legend Protected Fields Send Feedback

The fields of the EnxDatabaseError class are listed here.

Class

EnxDatabaseError Class

Protected Fields
Name | Description
deCustomInfos | This is deCustomInfos, a member of class EnxDatabaseError.
deErrorCode | private
deErrorString | This is deErrorString, a member of class EnxDatabaseError.
deExceptionData | This is deExceptionData, a member of class EnxDatabaseError.
deExtendedMsg | This is deExtendedMsg, a member of class EnxDatabaseError.
deOSError | This is deOSError, a member of class EnxDatabaseError.
Links
EnxDatabaseError Class, Legend, Protected Fields


EnxDatabaseError.deCustomInfos Field

EnxDatabaseError.deCustomInfos Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deCustomInfos: TStrings;
Description

This is deCustomInfos, a member of class EnxDatabaseError.

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError.deErrorCode Field

EnxDatabaseError.deErrorCode Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deErrorCode: Integer;
Description

private

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError.deErrorString Field

EnxDatabaseError.deErrorString Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deErrorString: string;
Description

This is deErrorString, a member of class EnxDatabaseError.

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError.deExceptionData Field

EnxDatabaseError.deExceptionData Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deExceptionData: InxExceptionDataContainer;
Description

This is deExceptionData, a member of class EnxDatabaseError.

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError.deExtendedMsg Field

EnxDatabaseError.deExtendedMsg Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deExtendedMsg: Boolean;
Description

This is deExtendedMsg, a member of class EnxDatabaseError.

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError.deOSError Field

EnxDatabaseError.deOSError Field
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Fields Send Feedback
Syntax
Delphi
deOSError: Cardinal;
Description

This is deOSError, a member of class EnxDatabaseError.

Group

EnxDatabaseError Fields

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Fields


EnxDatabaseError Methods

EnxDatabaseError Methods
EnxDatabaseError Class Legend Protected Methods Send Feedback

The methods of the EnxDatabaseError class are listed here.

Class

EnxDatabaseError Class

Protected Methods
Name | Description
_AddRef | This is _AddRef, a member of class EnxDatabaseError.
_Release | This is _Release, a member of class EnxDatabaseError.
deGetComponentName |
deMsgForErrorCode |
deProcessTemplate | This is deProcessTemplate, a member of class EnxDatabaseError.
deStripCustomInfos | This is deStripCustomInfos, a member of class EnxDatabaseError.
GetCustomInfos | This is GetCustomInfos, a member of class EnxDatabaseError.
GetErrorCode | InxException
GetErrorString | This is GetErrorString, a member of class EnxDatabaseError.
GetExceptionData | This is GetExceptionData, a member of class EnxDatabaseError.
GetExtendedMsg | This is GetExtendedMsg, a member of class EnxDatabaseError.
GetOSError | This is GetOSError, a member of class EnxDatabaseError.
GetProcessedErrorString | This is GetProcessedErrorString, a member of class EnxDatabaseError.
QueryInterface | InxInterface
Links
EnxDatabaseError Class, Legend, Protected Methods


EnxDatabaseError._AddRef Method

EnxDatabaseError._AddRef Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Description

This is _AddRef, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError._Release Method

EnxDatabaseError._Release Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Description

This is _Release, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.deGetComponentName Method

EnxDatabaseError.deGetComponentName Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
class function deGetComponentName(aComponent: TComponent): string; virtual;
Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.deMsgForErrorCode Method

EnxDatabaseError.deMsgForErrorCode Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
class function deMsgForErrorCode(aErrorCode: TnxResult): string; virtual;
Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.deProcessTemplate Method

EnxDatabaseError.deProcessTemplate Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function deProcessTemplate(const aMsg: string): string;
Description

This is deProcessTemplate, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.deStripCustomInfos Method

EnxDatabaseError.deStripCustomInfos Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function deStripCustomInfos(const aMsg: string): string;
Description

This is deStripCustomInfos, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetCustomInfos Method

EnxDatabaseError.GetCustomInfos Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetCustomInfos: TStrings;
Description

This is GetCustomInfos, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetErrorCode Method

EnxDatabaseError.GetErrorCode Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetErrorCode: TnxResult;
Description

InxException

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetErrorString Method

EnxDatabaseError.GetErrorString Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetErrorString: string;
Description

This is GetErrorString, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetExceptionData Method

EnxDatabaseError.GetExceptionData Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetExceptionData: InxExceptionDataContainer;
Description

This is GetExceptionData, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetExtendedMsg Method

EnxDatabaseError.GetExtendedMsg Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetExtendedMsg: Boolean;
Description

This is GetExtendedMsg, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetOSError Method

EnxDatabaseError.GetOSError Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetOSError: Cardinal;
Description

This is GetOSError, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.GetProcessedErrorString Method

EnxDatabaseError.GetProcessedErrorString Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function GetProcessedErrorString: string;
Description

This is GetProcessedErrorString, a member of class EnxDatabaseError.

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError.QueryInterface Method

EnxDatabaseError.QueryInterface Method
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

EnxDatabaseError Methods

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Methods


EnxDatabaseError Properties

EnxDatabaseError Properties
EnxDatabaseError Class Legend Public Properties Send Feedback

The properties of the EnxDatabaseError class are listed here.

Class

EnxDatabaseError Class

Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class EnxDatabaseError.
ErrorCode | This is ErrorCode, a member of class EnxDatabaseError.
ErrorString | This is ErrorString, a member of class EnxDatabaseError.
ExceptionData | This is ExceptionData, a member of class EnxDatabaseError.
ExtendedMsg | This is ExtendedMsg, a member of class EnxDatabaseError.
OSError | This is OSError, a member of class EnxDatabaseError.
ProcessedErrorString | This is ProcessedErrorString, a member of class EnxDatabaseError.
Links
EnxDatabaseError Class, Legend, Public Properties


EnxDatabaseError.CustomInfos Property

EnxDatabaseError.CustomInfos Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property CustomInfos: TStrings;
Description

This is CustomInfos, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.ErrorCode Property

EnxDatabaseError.ErrorCode Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property ErrorCode: Integer;
Description

This is ErrorCode, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.ErrorString Property

EnxDatabaseError.ErrorString Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property ErrorString: string;
Description

This is ErrorString, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.ExceptionData Property

EnxDatabaseError.ExceptionData Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property ExceptionData: InxExceptionDataContainer;
Description

This is ExceptionData, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.ExtendedMsg Property

EnxDatabaseError.ExtendedMsg Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property ExtendedMsg: Boolean;
Description

This is ExtendedMsg, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.OSError Property

EnxDatabaseError.OSError Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property OSError: Cardinal;
Description

This is OSError, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


EnxDatabaseError.ProcessedErrorString Property

EnxDatabaseError.ProcessedErrorString Property
EnxDatabaseError Class EnxDatabaseError Members nxdbBase Namespace EnxDatabaseError Properties Send Feedback
Syntax
Delphi
property ProcessedErrorString: string;
Description

This is ProcessedErrorString, a member of class EnxDatabaseError.

Group

EnxDatabaseError Properties

Links
EnxDatabaseError Class, EnxDatabaseError Members, nxdbBase Namespace, EnxDatabaseError Properties


Functions

Functions
Functions nxdbBase Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
Check | Interfaced helper routines
nxCreateOSError | HPPEMIT 'namespace Nxdbbase' HPPEMIT '{' HPPEMIT 'class DELPHICLASS EnxDatabaseError;' HPPEMIT 'class PASCALIMPLEMENTATION EnxDatabaseError : public Db::EDatabaseError' HPPEMIT '{' HPPEMIT ' typedef Db::EDatabaseError inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' int deErrorCode;' HPPEMIT ' AnsiString deErrorString;' HPPEMIT ' bool deExtendedMsg;' HPPEMIT ' Classes::TStrings* deCustomInfos;' HPPEMIT ' unsigned deOSError;' HPPEMIT ' HRESULT __stdcall QueryInterface(const GUID &IID, /* out */ void *Obj);' HPPEMIT ' int __stdcall _AddRef(void);' HPPEMIT ' int __stdcall _Release(void);' HPPEMIT ' Nxlltypes::TnxResult __fastcall GetErrorCode(void);' HPPEMIT ' AnsiString __fastcall GetErrorString();' HPPEMIT ' AnsiString __fastcall GetProcessedErrorString();' HPPEMIT ' bool __fastcall GetExtendedMsg(void);' HPPEMIT... more
Namespace

nxdbBase Namespace

Links
Functions, nxdbBase Namespace, Legend


nxdbBase.Check Function

nxdbBase.Check Function
nxdbBase Functions Send Feedback
Syntax
Delphi
procedure Check(const aStatus: TnxResult);
File

nxdbBase

Description

Interfaced helper routines

Group

Functions

Links
nxdbBase, Functions


nxdbBase.nxCreateOSError Function

nxdbBase.nxCreateOSError Function
nxdbBase Functions Send Feedback
Syntax
Delphi
function nxCreateOSError(aExceptionClass: EnxDatabaseErrorClass; const aAction: string): EnxDatabaseError;
File

nxdbBase

Description

HPPEMIT 'namespace Nxdbbase' HPPEMIT '{' HPPEMIT 'class DELPHICLASS EnxDatabaseError;' HPPEMIT 'class PASCALIMPLEMENTATION EnxDatabaseError : public Db::EDatabaseError' HPPEMIT '{' HPPEMIT ' typedef Db::EDatabaseError inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' int deErrorCode;' HPPEMIT ' AnsiString deErrorString;' HPPEMIT ' bool deExtendedMsg;' HPPEMIT ' Classes::TStrings* deCustomInfos;' HPPEMIT ' unsigned deOSError;' HPPEMIT ' HRESULT __stdcall QueryInterface(const GUID &IID, /* out */ void *Obj);' HPPEMIT ' int __stdcall _AddRef(void);' HPPEMIT ' int __stdcall _Release(void);' HPPEMIT ' Nxlltypes::TnxResult __fastcall GetErrorCode(void);' HPPEMIT ' AnsiString __fastcall GetErrorString();' HPPEMIT ' AnsiString __fastcall GetProcessedErrorString();' HPPEMIT ' bool __fastcall GetExtendedMsg(void);' HPPEMIT ' unsigned __fastcall GetOSError(void);' HPPEMIT ' Classes::TStrings* __fastcall GetCustomInfos(void);' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* virtual class method */ virtual AnsiString __fastcall deMsgForErrorCode(Nxlltypes::TnxResult aErrorCode) { return deMsgForErrorCode(__classid(EnxDatabaseError), aErrorCode); }' HPPEMIT ' #pragma option pop' HPPEMIT ' /* class method */ static AnsiString __fastcall deMsgForErrorCode(TMetaClass* vmt, Nxlltypes::TnxResult aErrorCode);' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* virtual class method */ virtual AnsiString __fastcall deGetComponentName(Classes::TComponent* aComponent) { return deGetComponentName(__classid(EnxDatabaseError), aComponent); }' HPPEMIT ' #pragma option pop' HPPEMIT ' /* class method */ static AnsiString __fastcall deGetComponentName(TMetaClass* vmt, Classes::TComponent* aComponent);' HPPEMIT ' AnsiString __fastcall deStripCustomInfos(const AnsiString aMsg);' HPPEMIT ' AnsiString __fastcall deProcessTemplate(const AnsiString aMsg);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' __fastcall virtual ~EnxDatabaseError(void);' HPPEMIT ' __fastcall EnxDatabaseError(Nxlltypes::TnxResult aErrorCode)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Nxlltypes::TnxResult aErrorCode, const AnsiString aAltMsg)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Nxlltypes::TnxResult aErrorCode, const AnsiString aAltMsg, System::TVarRec const * aArgs, const int aArgs_Size)/* overload */;' HPPEMIT ' //__fastcall EnxDatabaseError(const AnsiString aMsg)/* overload */;' HPPEMIT ' //__fastcall EnxDatabaseError(const AnsiString aMsg, System::TVarRec const * aArgs, const int aArgs_Size)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, Nxlltypes::TnxResult aErrorCode)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, Nxlltypes::TnxResult aErrorCode, const AnsiString aAltMsg)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, Nxlltypes::TnxResult aErrorCode, const AnsiString aAltMsg, System::TVarRec const * aArgs, const int aArgs_Size)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, const AnsiString aMsg)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, const AnsiString aMsg, System::TVarRec const * aArgs, const int aArgs_Size)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, System::PResStringRec aMsgRes)/* overload */;' HPPEMIT ' __fastcall EnxDatabaseError(Classes::TComponent* aComponent, System::PResStringRec aMsgRes, System::TVarRec const * aArgs, const int aArgs_Size)/* overload */;' HPPEMIT ' __property int ErrorCode = {read=deErrorCode, nodefault};' HPPEMIT ' __property AnsiString ErrorString = {read=deErrorString};' HPPEMIT ' __property AnsiString ProcessedErrorString = {read=GetProcessedErrorString};' HPPEMIT ' __property bool ExtendedMsg = {read=deExtendedMsg, nodefault};' HPPEMIT ' __property unsigned OSError = {read=deOSError, nodefault};' HPPEMIT ' __property Classes::TStrings* CustomInfos = {read=GetCustomInfos};' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.Create */ inline __fastcall EnxDatabaseError(const AnsiString Msg) : Db::EDatabaseError(Msg) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateFmt */ inline __fastcall EnxDatabaseError(const AnsiString Msg, System::TVarRec const * Args, const int Args_Size) : Db::EDatabaseError(Msg, Args, Args_Size) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateRes */ inline __fastcall EnxDatabaseError(int Ident)/* overload */ : Db::EDatabaseError(Ident) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateResFmt */ inline __fastcall EnxDatabaseError(int Ident, System::TVarRec const * Args, const int Args_Size)/* overload */ : Db::EDatabaseError(Ident, Args, Args_Size) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateHelp */ inline __fastcall EnxDatabaseError(const AnsiString Msg, int AHelpContext) : Db::EDatabaseError(Msg, AHelpContext) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateFmtHelp */ inline __fastcall EnxDatabaseError(const AnsiString Msg, System::TVarRec const * Args, const int Args_Size, int AHelpContext) : Db::EDatabaseError(Msg, Args, Args_Size, AHelpContext) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateResHelp */ inline __fastcall EnxDatabaseError(int Ident, int AHelpContext)/* overload */ : Db::EDatabaseError(Ident, AHelpContext) { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* Exception.CreateResFmtHelp */ inline __fastcall EnxDatabaseError(System::PResStringRec ResStringRec, System::TVarRec const * Args, const int Args_Size, int AHelpContext)/* overload */ : ' HPPEMIT ' Db::EDatabaseError(ResStringRec, Args, Args_Size, AHelpContext) { }' HPPEMIT ' #pragma option pop' HPPEMIT '' HPPEMIT 'private:' HPPEMIT ' void *__InxException; /* Nxllexception::InxException */' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' operator InxException*(void) { return (InxException* )&__InxException; }' HPPEMIT ' operator IInterface*(void) { return (IInterface* )&__InxException; }' HPPEMIT '};' HPPEMIT '} /* namespace Nxdbbase */' HPPEMIT ''

Group

Functions

Links
nxdbBase, Functions


Types

Types
nxdbBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdbBase Namespace

Types
Name | Description
EnxDatabaseErrorClass | This is type nxdbBase.EnxDatabaseErrorClass.
Links
nxdbBase Namespace, Types


nxdbBase.EnxDatabaseErrorClass Type

nxdbBase.EnxDatabaseErrorClass Type
nxdbBase Types Send Feedback
Syntax
Delphi
EnxDatabaseErrorClass = class of EnxDatabaseError;
File

nxdbBase

Description

This is type nxdbBase.EnxDatabaseErrorClass.

Group

Types

Links
nxdbBase, Types


nxdbBatchMove Namespace

nxdbBatchMove Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxdbBatchMove.

Classes
Name | Description
TnxBatchMove | This is class nxdbBatchMove.TnxBatchMove.
TnxBatchMoveThread | This is class nxdbBatchMove.TnxBatchMoveThread.
Structs, Records, Enums
Name | Description
TnxBatchMoveType | This is record nxdbBatchMove.TnxBatchMoveType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxKeyErrorEvent | This is type nxdbBatchMove.TnxKeyErrorEvent.
TnxOnExceptionEvent | This is type nxdbBatchMove.TnxOnExceptionEvent.
TnxProgressEvent | This is type nxdbBatchMove.TnxProgressEvent.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxdbBatchMove Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBatchMove | This is class nxdbBatchMove.TnxBatchMove.
TnxBatchMoveThread | This is class nxdbBatchMove.TnxBatchMoveThread.
Namespace

nxdbBatchMove Namespace

Links
Classes, nxdbBatchMove Namespace, Legend


TnxBatchMove Class

TnxBatchMove Class
TnxBatchMove Fields TnxBatchMove Methods TnxBatchMove Properties TnxBatchMove Events TnxBatchMove Members nxdbBatchMove Classes Send Feedback
Class Hierarchy
nxdbBatchMove_TnxBatchMove
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxBatchMove = class(TComponent);
File

nxdbBatchMove

Description

This is class nxdbBatchMove.TnxBatchMove.

Group

Classes

Links
TnxBatchMove Fields, TnxBatchMove Methods, TnxBatchMove Properties, TnxBatchMove Events, TnxBatchMove Members, nxdbBatchMove, Classes


TnxBatchMove Members

TnxBatchMove Members
TnxBatchMove Class Legend Protected Methods Public Fields Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBatchMove.

Class

TnxBatchMove Class

Protected Methods
Name | Description
Notification | This is Notification, a member of class TnxBatchMove.
Public Fields
Name | Description
MoveThread | This is MoveThread, a member of class TnxBatchMove.
Public Methods
Name | Description
Abort | This is Abort, a member of class TnxBatchMove.
Create | TnxBatchMove
Destroy | This is Destroy, a member of class TnxBatchMove.
Execute | This is Execute, a member of class TnxBatchMove.
Public Properties
Name | Description
Aborted | This is Aborted, a member of class TnxBatchMove.
AffectedCount | This is AffectedCount, a member of class TnxBatchMove.
ExecutionTime | This is ExecutionTime, a member of class TnxBatchMove.
FailedCount | This is FailedCount, a member of class TnxBatchMove.
IsExecuting | This is IsExecuting, a member of class TnxBatchMove.
ProcessedCount | This is ProcessedCount, a member of class TnxBatchMove.
ThreadActive | This is ThreadActive, a member of class TnxBatchMove.
Published Events
Name | Description
OnException | This is OnException, a member of class TnxBatchMove.
OnKeyError | This is OnKeyError, a member of class TnxBatchMove.
OnMoveProgress | This is OnMoveProgress, a member of class TnxBatchMove.
Published Properties
Name | Description
AbortOnKeyError | This is AbortOnKeyError, a member of class TnxBatchMove.
AllowTruncating | This is AllowTruncating, a member of class TnxBatchMove.
CommitInterval | This is CommitInterval, a member of class TnxBatchMove.
FieldMappings | This is FieldMappings, a member of class TnxBatchMove.
LockTarget | This is LockTarget, a member of class TnxBatchMove.
MaxRecords | This is MaxRecords, a member of class TnxBatchMove.
Mode | This is Mode, a member of class TnxBatchMove.
OnThreadDone | This is OnThreadDone, a member of class TnxBatchMove.
RunThreaded | This is RunThreaded, a member of class TnxBatchMove.
Source | This is Source, a member of class TnxBatchMove.
Target | This is Target, a member of class TnxBatchMove.
Links
TnxBatchMove Class, Legend, Protected Methods, Public Fields, Public Methods, Public Properties, Published Events, Published Properties


TnxBatchMove.Create Constructor

TnxBatchMove.Create Constructor
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

TnxBatchMove

Class

TnxBatchMove Class

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Class


TnxBatchMove.Destroy Destructor

TnxBatchMove.Destroy Destructor
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxBatchMove.

Class

TnxBatchMove Class

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Class


TnxBatchMove Fields

TnxBatchMove Fields
TnxBatchMove Class Legend Public Fields Send Feedback

The fields of the TnxBatchMove class are listed here.

Class

TnxBatchMove Class

Public Fields
Name | Description
MoveThread | This is MoveThread, a member of class TnxBatchMove.
Links
TnxBatchMove Class, Legend, Public Fields


TnxBatchMove.MoveThread Field

TnxBatchMove.MoveThread Field
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Fields Send Feedback
Syntax
Delphi
MoveThread: TnxBatchMoveThread;
Description

This is MoveThread, a member of class TnxBatchMove.

Group

TnxBatchMove Fields

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Fields


TnxBatchMove Methods

TnxBatchMove Methods
TnxBatchMove Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBatchMove class are listed here.

Class

TnxBatchMove Class

Protected Methods
Name | Description
Notification | This is Notification, a member of class TnxBatchMove.
Public Methods
Name | Description
Abort | This is Abort, a member of class TnxBatchMove.
Execute | This is Execute, a member of class TnxBatchMove.
Links
TnxBatchMove Class, Legend, Protected Methods, Public Methods


TnxBatchMove.Abort Method

TnxBatchMove.Abort Method
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Methods Send Feedback
Syntax
Delphi
procedure Abort;
Description

This is Abort, a member of class TnxBatchMove.

Group

TnxBatchMove Methods

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Methods


TnxBatchMove.Execute Method

TnxBatchMove.Execute Method
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Methods Send Feedback
Syntax
Delphi
procedure Execute;
Description

This is Execute, a member of class TnxBatchMove.

Group

TnxBatchMove Methods

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Methods


TnxBatchMove.Notification Method

TnxBatchMove.Notification Method
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Methods Send Feedback
Syntax
Delphi
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

This is Notification, a member of class TnxBatchMove.

Group

TnxBatchMove Methods

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Methods


TnxBatchMove Properties

TnxBatchMove Properties
TnxBatchMove Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBatchMove class are listed here.

Class

TnxBatchMove Class

Public Properties
Name | Description
Aborted | This is Aborted, a member of class TnxBatchMove.
AffectedCount | This is AffectedCount, a member of class TnxBatchMove.
ExecutionTime | This is ExecutionTime, a member of class TnxBatchMove.
FailedCount | This is FailedCount, a member of class TnxBatchMove.
IsExecuting | This is IsExecuting, a member of class TnxBatchMove.
ProcessedCount | This is ProcessedCount, a member of class TnxBatchMove.
ThreadActive | This is ThreadActive, a member of class TnxBatchMove.
Published Properties
Name | Description
AbortOnKeyError | This is AbortOnKeyError, a member of class TnxBatchMove.
AllowTruncating | This is AllowTruncating, a member of class TnxBatchMove.
CommitInterval | This is CommitInterval, a member of class TnxBatchMove.
FieldMappings | This is FieldMappings, a member of class TnxBatchMove.
LockTarget | This is LockTarget, a member of class TnxBatchMove.
MaxRecords | This is MaxRecords, a member of class TnxBatchMove.
Mode | This is Mode, a member of class TnxBatchMove.
OnThreadDone | This is OnThreadDone, a member of class TnxBatchMove.
RunThreaded | This is RunThreaded, a member of class TnxBatchMove.
Source | This is Source, a member of class TnxBatchMove.
Target | This is Target, a member of class TnxBatchMove.
Links
TnxBatchMove Class, Legend, Public Properties, Published Properties


TnxBatchMove.Aborted Property

TnxBatchMove.Aborted Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property Aborted: Boolean;
Description

This is Aborted, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.AbortOnKeyError Property

TnxBatchMove.AbortOnKeyError Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property AbortOnKeyError: Boolean;
Description

This is AbortOnKeyError, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.AffectedCount Property

TnxBatchMove.AffectedCount Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property AffectedCount: Integer;
Description

This is AffectedCount, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.AllowTruncating Property

TnxBatchMove.AllowTruncating Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property AllowTruncating: Boolean;
Description

This is AllowTruncating, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.CommitInterval Property

TnxBatchMove.CommitInterval Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property CommitInterval: Integer;
Description

This is CommitInterval, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.ExecutionTime Property

TnxBatchMove.ExecutionTime Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property ExecutionTime: TDateTime;
Description

This is ExecutionTime, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.FailedCount Property

TnxBatchMove.FailedCount Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property FailedCount: Integer;
Description

This is FailedCount, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.FieldMappings Property

TnxBatchMove.FieldMappings Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property FieldMappings: TStrings;
Description

This is FieldMappings, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.IsExecuting Property

TnxBatchMove.IsExecuting Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property IsExecuting: Boolean;
Description

This is IsExecuting, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.LockTarget Property

TnxBatchMove.LockTarget Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property LockTarget: Boolean;
Description

This is LockTarget, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.MaxRecords Property

TnxBatchMove.MaxRecords Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property MaxRecords: Integer;
Description

This is MaxRecords, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.Mode Property

TnxBatchMove.Mode Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property Mode: TnxBatchMoveType;
Description

This is Mode, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.OnThreadDone Property

TnxBatchMove.OnThreadDone Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property OnThreadDone: TNotifyEvent;
Description

This is OnThreadDone, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.ProcessedCount Property

TnxBatchMove.ProcessedCount Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property ProcessedCount: Integer;
Description

This is ProcessedCount, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.RunThreaded Property

TnxBatchMove.RunThreaded Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property RunThreaded: Boolean;
Description

This is RunThreaded, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.Source Property

TnxBatchMove.Source Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property Source: TDataSet;
Description

This is Source, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.Target Property

TnxBatchMove.Target Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property Target: TnxTable;
Description

This is Target, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove.ThreadActive Property

TnxBatchMove.ThreadActive Property
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Properties Send Feedback
Syntax
Delphi
property ThreadActive: Boolean;
Description

This is ThreadActive, a member of class TnxBatchMove.

Group

TnxBatchMove Properties

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Properties


TnxBatchMove Events

TnxBatchMove Events
TnxBatchMove Class Legend Published Events Send Feedback

The events of the TnxBatchMove class are listed here.

Class

TnxBatchMove Class

Published Events
Name | Description
OnException | This is OnException, a member of class TnxBatchMove.
OnKeyError | This is OnKeyError, a member of class TnxBatchMove.
OnMoveProgress | This is OnMoveProgress, a member of class TnxBatchMove.
Links
TnxBatchMove Class, Legend, Published Events


TnxBatchMove.OnException Event

TnxBatchMove.OnException Event
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Events Send Feedback
Syntax
Delphi
property OnException: TnxOnExceptionEvent;
Description

This is OnException, a member of class TnxBatchMove.

Group

TnxBatchMove Events

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Events


TnxBatchMove.OnKeyError Event

TnxBatchMove.OnKeyError Event
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Events Send Feedback
Syntax
Delphi
property OnKeyError: TnxKeyErrorEvent;
Description

This is OnKeyError, a member of class TnxBatchMove.

Group

TnxBatchMove Events

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Events


TnxBatchMove.OnMoveProgress Event

TnxBatchMove.OnMoveProgress Event
TnxBatchMove Class TnxBatchMove Members nxdbBatchMove Namespace TnxBatchMove Events Send Feedback
Syntax
Delphi
property OnMoveProgress: TnxProgressEvent;
Description

This is OnMoveProgress, a member of class TnxBatchMove.

Group

TnxBatchMove Events

Links
TnxBatchMove Class, TnxBatchMove Members, nxdbBatchMove Namespace, TnxBatchMove Events


TnxBatchMoveThread Class

TnxBatchMoveThread Class
TnxBatchMoveThread Methods TnxBatchMoveThread Members nxdbBatchMove Classes Send Feedback
Class Hierarchy
nxdbBatchMove_TnxBatchMoveThreadnxdbBatchMove_TnxBatchMoveThread
Syntax
Delphi
TnxBatchMoveThread = class(TnxThread);
File

nxdbBatchMove

Description

This is class nxdbBatchMove.TnxBatchMoveThread.

Group

Classes

Links
TnxBatchMoveThread Methods, TnxBatchMoveThread Members, nxdbBatchMove, Classes


TnxBatchMoveThread Members

TnxBatchMoveThread Members
TnxBatchMoveThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBatchMoveThread.

Class

TnxBatchMoveThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
DoExecute |
DoHandleException |
DoTerminate |
Execute |
HandleException | This is HandleException, a member of class TnxBatchMoveThread.
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxBatchMoveThread
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxBatchMoveThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBatchMoveThread.Create Constructor

TnxBatchMoveThread.Create Constructor
TnxBatchMoveThread Class TnxBatchMoveThread Members nxdbBatchMove Namespace TnxBatchMoveThread Class Send Feedback
Syntax
Delphi
constructor Create(Sender: TnxBatchMove); dynamic;
Description

TnxBatchMoveThread

Class

TnxBatchMoveThread Class

Links
TnxBatchMoveThread Class, TnxBatchMoveThread Members, nxdbBatchMove Namespace, TnxBatchMoveThread Class


TnxBatchMoveThread.Destroy Destructor

TnxBatchMoveThread.Destroy Destructor
TnxBatchMoveThread Class TnxBatchMoveThread Members nxdbBatchMove Namespace TnxBatchMoveThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBatchMoveThread Class

Links
TnxBatchMoveThread Class, TnxBatchMoveThread Members, nxdbBatchMove Namespace, TnxBatchMoveThread Class


TnxBatchMoveThread Methods

TnxBatchMoveThread Methods
TnxBatchMoveThread Class Legend Protected Methods Send Feedback

The methods of the TnxBatchMoveThread class are listed here.

Class

TnxBatchMoveThread Class

Protected Methods
Name | Description
Execute |
HandleException | This is HandleException, a member of class TnxBatchMoveThread.
Links
TnxBatchMoveThread Class, Legend, Protected Methods


TnxBatchMoveThread.Execute Method

TnxBatchMoveThread.Execute Method
TnxBatchMoveThread Class TnxBatchMoveThread Members nxdbBatchMove Namespace TnxBatchMoveThread Methods Send Feedback
Syntax
Delphi
procedure Execute; override;
Group

TnxBatchMoveThread Methods

Links
TnxBatchMoveThread Class, TnxBatchMoveThread Members, nxdbBatchMove Namespace, TnxBatchMoveThread Methods


TnxBatchMoveThread.HandleException Method

TnxBatchMoveThread.HandleException Method
TnxBatchMoveThread Class TnxBatchMoveThread Members nxdbBatchMove Namespace TnxBatchMoveThread Methods Send Feedback
Syntax
Delphi
procedure HandleException;
Description

This is HandleException, a member of class TnxBatchMoveThread.

Group

TnxBatchMoveThread Methods

Links
TnxBatchMoveThread Class, TnxBatchMoveThread Members, nxdbBatchMove Namespace, TnxBatchMoveThread Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxdbBatchMove Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBatchMoveType | This is record nxdbBatchMove.TnxBatchMoveType.
Namespace

nxdbBatchMove Namespace

Links
Enumerations, nxdbBatchMove Namespace, Legend


nxdbBatchMove.TnxBatchMoveType Enumeration

nxdbBatchMove.TnxBatchMoveType Enumeration
nxdbBatchMove Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBatchMoveType = ( bmtAppend, bmtUpdate, bmtAppendUpdate, bmtDelete, bmtCopy );
File

nxdbBatchMove

Description

This is record nxdbBatchMove.TnxBatchMoveType.

Group

Structs, Records, Enums

Links
nxdbBatchMove, Structs, Records, Enums


Types

Types
nxdbBatchMove Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdbBatchMove Namespace

Types
Name | Description
TnxKeyErrorEvent | This is type nxdbBatchMove.TnxKeyErrorEvent.
TnxOnExceptionEvent | This is type nxdbBatchMove.TnxOnExceptionEvent.
TnxProgressEvent | This is type nxdbBatchMove.TnxProgressEvent.
Links
nxdbBatchMove Namespace, Types


nxdbBatchMove.TnxKeyErrorEvent Type

nxdbBatchMove.TnxKeyErrorEvent Type
nxdbBatchMove Types Send Feedback
Syntax
Delphi
TnxKeyErrorEvent = procedure (Sender: TObject; Source: TDataSet; Target: TnxTable; var Abort: Boolean) of object;
File

nxdbBatchMove

Description

This is type nxdbBatchMove.TnxKeyErrorEvent.

Group

Types

Links
nxdbBatchMove, Types


nxdbBatchMove.TnxOnExceptionEvent Type

nxdbBatchMove.TnxOnExceptionEvent Type
nxdbBatchMove Types Send Feedback
Syntax
Delphi
TnxOnExceptionEvent = procedure (Sender: TObject; E: Exception) of object;
File

nxdbBatchMove

Description

This is type nxdbBatchMove.TnxOnExceptionEvent.

Group

Types

Links
nxdbBatchMove, Types


nxdbBatchMove.TnxProgressEvent Type

nxdbBatchMove.TnxProgressEvent Type
nxdbBatchMove Types Send Feedback
Syntax
Delphi
TnxProgressEvent = procedure (Sender: TObject; PercentDone: Word) of object;
File

nxdbBatchMove

Description

This is type nxdbBatchMove.TnxProgressEvent.

Group

Types

Links
nxdbBatchMove, Types


nxdbConversion Namespace

nxdbConversion Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxdbConversion.

Classes
Name | Description
TnxAnsiCharVclFieldMapper | This is class nxdbConversion.TnxAnsiCharVclFieldMapper.
TnxAutoIncVclFieldMapper | This is class nxdbConversion.TnxAutoIncVclFieldMapper.
TnxBaseBlobVclFieldMapper | This is class nxdbConversion.TnxBaseBlobVclFieldMapper.
TnxBaseCharVclFieldMapper | This is class nxdbConversion.TnxBaseCharVclFieldMapper.
TnxBaseDateTimeVclFieldMapper | This is class nxdbConversion.TnxBaseDateTimeVclFieldMapper.
TnxBaseFloatVclFieldMapper | This is class nxdbConversion.TnxBaseFloatVclFieldMapper.
TnxBasePaddingVclFieldMapper | This is class nxdbConversion.TnxBasePaddingVclFieldMapper.
TnxBaseStringVclFieldMapper | This is class nxdbConversion.TnxBaseStringVclFieldMapper.
TnxBaseVclFieldMapper | This is class nxdbConversion.TnxBaseVclFieldMapper.
TnxBcdVclFieldMapper | This is class nxdbConversion.TnxBcdVclFieldMapper.
TnxBlobVclFieldMapper | This is class nxdbConversion.TnxBlobVclFieldMapper.
TnxBooleanVclFieldMapper | This is class nxdbConversion.TnxBooleanVclFieldMapper.
TnxByte8VclFieldMapper | This is class nxdbConversion.TnxByte8VclFieldMapper.
TnxByteArrayVclFieldMapper | This is class nxdbConversion.TnxByteArrayVclFieldMapper.
TnxCurrencyVclFieldMapper | This is class nxdbConversion.TnxCurrencyVclFieldMapper.
TnxDateTimeVclFieldMapper | This is class nxdbConversion.TnxDateTimeVclFieldMapper.
TnxDateVclFieldMapper | This is class nxdbConversion.TnxDateVclFieldMapper.
TnxDoubleVclFieldMapper | This is class nxdbConversion.TnxDoubleVclFieldMapper.
TnxExtendedVclFieldMapper | This is class nxdbConversion.TnxExtendedVclFieldMapper.
TnxFmtBcdVclFieldMapper | This is class nxdbConversion.TnxFmtBcdVclFieldMapper.
TnxGraphicVclFieldMapper | This is class nxdbConversion.TnxGraphicVclFieldMapper.
TnxGuidVclFieldMapper | This is class nxdbConversion.TnxGuidVclFieldMapper.
TnxInstantiatedVclFieldMapper | This is class nxdbConversion.TnxInstantiatedVclFieldMapper.
TnxInt16VclFieldMapper | This is class nxdbConversion.TnxInt16VclFieldMapper.
TnxInt32VclFieldMapper | This is class nxdbConversion.TnxInt32VclFieldMapper.
TnxInt64VclFieldMapper | This is class nxdbConversion.TnxInt64VclFieldMapper.
TnxInt8VclFieldMapper | This is class nxdbConversion.TnxInt8VclFieldMapper.
TnxIntervalVclFieldMapper | This is class nxdbConversion.TnxIntervalVclFieldMapper.
TnxMemoVclFieldMapper | This is class nxdbConversion.TnxMemoVclFieldMapper.
TnxNullStringVclFieldMapper | This is class nxdbConversion.TnxNullStringVclFieldMapper.
TnxRecRevVclFieldMapper | This is class nxdbConversion.TnxRecRevVclFieldMapper.
TnxShortStringVclFieldMapper | This is class nxdbConversion.TnxShortStringVclFieldMapper.
TnxSingleVclFieldMapper | This is class nxdbConversion.TnxSingleVclFieldMapper.
TnxStaticVclFieldMapper | This is class nxdbConversion.TnxStaticVclFieldMapper.
TnxTimeVclFieldMapper | This is class nxdbConversion.TnxTimeVclFieldMapper.
TnxVariableSizeVclFieldMapper | This is class nxdbConversion.TnxVariableSizeVclFieldMapper.
TnxWideCharVclFieldMapper | This is class nxdbConversion.TnxWideCharVclFieldMapper.
TnxWideMemoVclFieldMapper | This is class nxdbConversion.TnxWideMemoVclFieldMapper.
TnxWideStringVclFieldMapper | This is class nxdbConversion.TnxWideStringVclFieldMapper.
TnxWord16VclFieldMapper | This is class nxdbConversion.TnxWord16VclFieldMapper.
TnxWord32VclFieldMapper | This is class nxdbConversion.TnxWord32VclFieldMapper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxBaseVclFieldMapperClass | This is type nxdbConversion.TnxBaseVclFieldMapperClass.
TnxDynMapperMethodArray | This is type nxdbConversion.TnxDynMapperMethodArray.
TnxVclMapperMethod | This is type nxdbConversion.TnxVclMapperMethod.
Variables
Name | Description
_MapperClassesNexusToVcl | This is variable nxdbConversion._MapperClassesNexusToVcl.
_MapperClassesVclToNexus | This is variable nxdbConversion._MapperClassesVclToNexus.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxdbConversion Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAnsiCharVclFieldMapper | This is class nxdbConversion.TnxAnsiCharVclFieldMapper.
TnxAutoIncVclFieldMapper | This is class nxdbConversion.TnxAutoIncVclFieldMapper.
TnxBaseBlobVclFieldMapper | This is class nxdbConversion.TnxBaseBlobVclFieldMapper.
TnxBaseCharVclFieldMapper | This is class nxdbConversion.TnxBaseCharVclFieldMapper.
TnxBaseDateTimeVclFieldMapper | This is class nxdbConversion.TnxBaseDateTimeVclFieldMapper.
TnxBaseFloatVclFieldMapper | This is class nxdbConversion.TnxBaseFloatVclFieldMapper.
TnxBasePaddingVclFieldMapper | This is class nxdbConversion.TnxBasePaddingVclFieldMapper.
TnxBaseStringVclFieldMapper | This is class nxdbConversion.TnxBaseStringVclFieldMapper.
TnxBaseVclFieldMapper | This is class nxdbConversion.TnxBaseVclFieldMapper.
TnxBcdVclFieldMapper | This is class nxdbConversion.TnxBcdVclFieldMapper.
TnxBlobVclFieldMapper | This is class nxdbConversion.TnxBlobVclFieldMapper.
TnxBooleanVclFieldMapper | This is class nxdbConversion.TnxBooleanVclFieldMapper.
TnxByte8VclFieldMapper | This is class nxdbConversion.TnxByte8VclFieldMapper.
TnxByteArrayVclFieldMapper | This is class nxdbConversion.TnxByteArrayVclFieldMapper.
TnxCurrencyVclFieldMapper | This is class nxdbConversion.TnxCurrencyVclFieldMapper.
TnxDateTimeVclFieldMapper | This is class nxdbConversion.TnxDateTimeVclFieldMapper.
TnxDateVclFieldMapper | This is class nxdbConversion.TnxDateVclFieldMapper.
TnxDoubleVclFieldMapper | This is class nxdbConversion.TnxDoubleVclFieldMapper.
TnxExtendedVclFieldMapper | This is class nxdbConversion.TnxExtendedVclFieldMapper.
TnxFmtBcdVclFieldMapper | This is class nxdbConversion.TnxFmtBcdVclFieldMapper.
TnxGraphicVclFieldMapper | This is class nxdbConversion.TnxGraphicVclFieldMapper.
TnxGuidVclFieldMapper | This is class nxdbConversion.TnxGuidVclFieldMapper.
TnxInstantiatedVclFieldMapper | This is class nxdbConversion.TnxInstantiatedVclFieldMapper.
TnxInt16VclFieldMapper | This is class nxdbConversion.TnxInt16VclFieldMapper.
TnxInt32VclFieldMapper | This is class nxdbConversion.TnxInt32VclFieldMapper.
TnxInt64VclFieldMapper | This is class nxdbConversion.TnxInt64VclFieldMapper.
TnxInt8VclFieldMapper | This is class nxdbConversion.TnxInt8VclFieldMapper.
TnxIntervalVclFieldMapper | This is class nxdbConversion.TnxIntervalVclFieldMapper.
TnxMemoVclFieldMapper | This is class nxdbConversion.TnxMemoVclFieldMapper.
TnxNullStringVclFieldMapper | This is class nxdbConversion.TnxNullStringVclFieldMapper.
TnxRecRevVclFieldMapper | This is class nxdbConversion.TnxRecRevVclFieldMapper.
TnxShortStringVclFieldMapper | This is class nxdbConversion.TnxShortStringVclFieldMapper.
TnxSingleVclFieldMapper | This is class nxdbConversion.TnxSingleVclFieldMapper.
TnxStaticVclFieldMapper | This is class nxdbConversion.TnxStaticVclFieldMapper.
TnxTimeVclFieldMapper | This is class nxdbConversion.TnxTimeVclFieldMapper.
TnxVariableSizeVclFieldMapper | This is class nxdbConversion.TnxVariableSizeVclFieldMapper.
TnxWideCharVclFieldMapper | This is class nxdbConversion.TnxWideCharVclFieldMapper.
TnxWideMemoVclFieldMapper | This is class nxdbConversion.TnxWideMemoVclFieldMapper.
TnxWideStringVclFieldMapper | This is class nxdbConversion.TnxWideStringVclFieldMapper.
TnxWord16VclFieldMapper | This is class nxdbConversion.TnxWord16VclFieldMapper.
TnxWord32VclFieldMapper | This is class nxdbConversion.TnxWord32VclFieldMapper.
Namespace

nxdbConversion Namespace

Links
Classes, nxdbConversion Namespace, Legend


TnxAnsiCharVclFieldMapper Class

TnxAnsiCharVclFieldMapper Class
TnxAnsiCharVclFieldMapper Methods TnxAnsiCharVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxAnsiCharVclFieldMappernxdbConversion_TnxAnsiCharVclFieldMappernxdbConversion_TnxAnsiCharVclFieldMappernxdbConversion_TnxAnsiCharVclFieldMappernxdbConversion_TnxAnsiCharVclFieldMapper
Syntax
Delphi
TnxAnsiCharVclFieldMapper = class(TnxBaseCharVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxAnsiCharVclFieldMapper.

Group

Classes

Links
TnxAnsiCharVclFieldMapper Methods, TnxAnsiCharVclFieldMapper Members, nxdbConversion, Classes


TnxAnsiCharVclFieldMapper Members

TnxAnsiCharVclFieldMapper Members
TnxAnsiCharVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxAnsiCharVclFieldMapper.

Class

TnxAnsiCharVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxAnsiCharVclFieldMapper
GetVclSize | TnxBaseCharVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxAnsiCharVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxAnsiCharVclFieldMapper Methods

TnxAnsiCharVclFieldMapper Methods
TnxAnsiCharVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxAnsiCharVclFieldMapper class are listed here.

Class

TnxAnsiCharVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxAnsiCharVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxAnsiCharVclFieldMapper Class, Legend, Protected Methods


TnxAnsiCharVclFieldMapper.GetNexusType Method

TnxAnsiCharVclFieldMapper.GetNexusType Method
TnxAnsiCharVclFieldMapper Class TnxAnsiCharVclFieldMapper Members nxdbConversion Namespace TnxAnsiCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxAnsiCharVclFieldMapper

Group

TnxAnsiCharVclFieldMapper Methods

Links
TnxAnsiCharVclFieldMapper Class, TnxAnsiCharVclFieldMapper Members, nxdbConversion Namespace, TnxAnsiCharVclFieldMapper Methods


TnxAnsiCharVclFieldMapper.GetVclType Method

TnxAnsiCharVclFieldMapper.GetVclType Method
TnxAnsiCharVclFieldMapper Class TnxAnsiCharVclFieldMapper Members nxdbConversion Namespace TnxAnsiCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxAnsiCharVclFieldMapper Methods

Links
TnxAnsiCharVclFieldMapper Class, TnxAnsiCharVclFieldMapper Members, nxdbConversion Namespace, TnxAnsiCharVclFieldMapper Methods


TnxAnsiCharVclFieldMapper.MapNexusDataToVcl Method

TnxAnsiCharVclFieldMapper.MapNexusDataToVcl Method
TnxAnsiCharVclFieldMapper Class TnxAnsiCharVclFieldMapper Members nxdbConversion Namespace TnxAnsiCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxAnsiCharVclFieldMapper Methods

Links
TnxAnsiCharVclFieldMapper Class, TnxAnsiCharVclFieldMapper Members, nxdbConversion Namespace, TnxAnsiCharVclFieldMapper Methods


TnxAnsiCharVclFieldMapper.MapVclDataToNexus Method

TnxAnsiCharVclFieldMapper.MapVclDataToNexus Method
TnxAnsiCharVclFieldMapper Class TnxAnsiCharVclFieldMapper Members nxdbConversion Namespace TnxAnsiCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxAnsiCharVclFieldMapper Methods

Links
TnxAnsiCharVclFieldMapper Class, TnxAnsiCharVclFieldMapper Members, nxdbConversion Namespace, TnxAnsiCharVclFieldMapper Methods


TnxAutoIncVclFieldMapper Class

TnxAutoIncVclFieldMapper Class
TnxAutoIncVclFieldMapper Methods TnxAutoIncVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxAutoIncVclFieldMappernxdbConversion_TnxAutoIncVclFieldMappernxdbConversion_TnxAutoIncVclFieldMappernxdbConversion_TnxAutoIncVclFieldMappernxdbConversion_TnxAutoIncVclFieldMapper
Syntax
Delphi
TnxAutoIncVclFieldMapper = class(TnxWord32VclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxAutoIncVclFieldMapper.

Group

Classes

Links
TnxAutoIncVclFieldMapper Methods, TnxAutoIncVclFieldMapper Members, nxdbConversion, Classes


TnxAutoIncVclFieldMapper Members

TnxAutoIncVclFieldMapper Members
TnxAutoIncVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxAutoIncVclFieldMapper.

Class

TnxAutoIncVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxAutoIncVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapNexusDataToVcl |
MapVclDataToNexus | abstract;
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxAutoIncVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxAutoIncVclFieldMapper Methods

TnxAutoIncVclFieldMapper Methods
TnxAutoIncVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxAutoIncVclFieldMapper class are listed here.

Class

TnxAutoIncVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxAutoIncVclFieldMapper
GetVclType |
Links
TnxAutoIncVclFieldMapper Class, Legend, Protected Methods


TnxAutoIncVclFieldMapper.GetNexusType Method

TnxAutoIncVclFieldMapper.GetNexusType Method
TnxAutoIncVclFieldMapper Class TnxAutoIncVclFieldMapper Members nxdbConversion Namespace TnxAutoIncVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxAutoIncVclFieldMapper

Group

TnxAutoIncVclFieldMapper Methods

Links
TnxAutoIncVclFieldMapper Class, TnxAutoIncVclFieldMapper Members, nxdbConversion Namespace, TnxAutoIncVclFieldMapper Methods


TnxAutoIncVclFieldMapper.GetVclType Method

TnxAutoIncVclFieldMapper.GetVclType Method
TnxAutoIncVclFieldMapper Class TnxAutoIncVclFieldMapper Members nxdbConversion Namespace TnxAutoIncVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxAutoIncVclFieldMapper Methods

Links
TnxAutoIncVclFieldMapper Class, TnxAutoIncVclFieldMapper Members, nxdbConversion Namespace, TnxAutoIncVclFieldMapper Methods


TnxBaseBlobVclFieldMapper Class

TnxBaseBlobVclFieldMapper Class
nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseBlobVclFieldMappernxdbConversion_TnxBaseBlobVclFieldMappernxdbConversion_TnxBaseBlobVclFieldMappernxdbConversion_TnxBaseBlobVclFieldMappernxdbConversion_TnxBaseBlobVclFieldMapper
Syntax
Delphi
TnxBaseBlobVclFieldMapper = class(TnxInt64VclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseBlobVclFieldMapper.

Group

Classes

Links
nxdbConversion, Classes


TnxBaseCharVclFieldMapper Class

TnxBaseCharVclFieldMapper Class
TnxBaseCharVclFieldMapper Methods TnxBaseCharVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseCharVclFieldMappernxdbConversion_TnxBaseCharVclFieldMappernxdbConversion_TnxBaseCharVclFieldMappernxdbConversion_TnxBaseCharVclFieldMapper
Syntax
Delphi
TnxBaseCharVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseCharVclFieldMapper.

Group

Classes

Links
TnxBaseCharVclFieldMapper Methods, TnxBaseCharVclFieldMapper Members, nxdbConversion, Classes


TnxBaseCharVclFieldMapper Members

TnxBaseCharVclFieldMapper Members
TnxBaseCharVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseCharVclFieldMapper.

Class

TnxBaseCharVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
GetVclSize | TnxBaseCharVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBaseCharVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseCharVclFieldMapper Methods

TnxBaseCharVclFieldMapper Methods
TnxBaseCharVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBaseCharVclFieldMapper class are listed here.

Class

TnxBaseCharVclFieldMapper Class

Protected Methods
Name | Description
GetVclSize | TnxBaseCharVclFieldMapper
Links
TnxBaseCharVclFieldMapper Class, Legend, Protected Methods


TnxBaseCharVclFieldMapper.GetVclSize Method

TnxBaseCharVclFieldMapper.GetVclSize Method
TnxBaseCharVclFieldMapper Class TnxBaseCharVclFieldMapper Members nxdbConversion Namespace TnxBaseCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclSize: TnxWord16; override;
Description

TnxBaseCharVclFieldMapper

Group

TnxBaseCharVclFieldMapper Methods

Links
TnxBaseCharVclFieldMapper Class, TnxBaseCharVclFieldMapper Members, nxdbConversion Namespace, TnxBaseCharVclFieldMapper Methods


TnxBaseDateTimeVclFieldMapper Class

TnxBaseDateTimeVclFieldMapper Class
TnxBaseDateTimeVclFieldMapper Methods TnxBaseDateTimeVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseDateTimeVclFieldMappernxdbConversion_TnxBaseDateTimeVclFieldMappernxdbConversion_TnxBaseDateTimeVclFieldMappernxdbConversion_TnxBaseDateTimeVclFieldMapper
Syntax
Delphi
TnxBaseDateTimeVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseDateTimeVclFieldMapper.

Group

Classes

Links
TnxBaseDateTimeVclFieldMapper Methods, TnxBaseDateTimeVclFieldMapper Members, nxdbConversion, Classes


TnxBaseDateTimeVclFieldMapper Members

TnxBaseDateTimeVclFieldMapper Members
TnxBaseDateTimeVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseDateTimeVclFieldMapper.

Class

TnxBaseDateTimeVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseDateTimeVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBaseDateTimeVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseDateTimeVclFieldMapper Methods

TnxBaseDateTimeVclFieldMapper Methods
TnxBaseDateTimeVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBaseDateTimeVclFieldMapper class are listed here.

Class

TnxBaseDateTimeVclFieldMapper Class

Protected Methods
Name | Description
GetVclType | TnxBaseDateTimeVclFieldMapper
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxBaseDateTimeVclFieldMapper Class, Legend, Protected Methods


TnxBaseDateTimeVclFieldMapper.GetVclType Method

TnxBaseDateTimeVclFieldMapper.GetVclType Method
TnxBaseDateTimeVclFieldMapper Class TnxBaseDateTimeVclFieldMapper Members nxdbConversion Namespace TnxBaseDateTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Description

TnxBaseDateTimeVclFieldMapper

Group

TnxBaseDateTimeVclFieldMapper Methods

Links
TnxBaseDateTimeVclFieldMapper Class, TnxBaseDateTimeVclFieldMapper Members, nxdbConversion Namespace, TnxBaseDateTimeVclFieldMapper Methods


TnxBaseDateTimeVclFieldMapper.MapNexusDataToVcl Method

TnxBaseDateTimeVclFieldMapper.MapNexusDataToVcl Method
TnxBaseDateTimeVclFieldMapper Class TnxBaseDateTimeVclFieldMapper Members nxdbConversion Namespace TnxBaseDateTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxBaseDateTimeVclFieldMapper Methods

Links
TnxBaseDateTimeVclFieldMapper Class, TnxBaseDateTimeVclFieldMapper Members, nxdbConversion Namespace, TnxBaseDateTimeVclFieldMapper Methods


TnxBaseDateTimeVclFieldMapper.MapVclDataToNexus Method

TnxBaseDateTimeVclFieldMapper.MapVclDataToNexus Method
TnxBaseDateTimeVclFieldMapper Class TnxBaseDateTimeVclFieldMapper Members nxdbConversion Namespace TnxBaseDateTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxBaseDateTimeVclFieldMapper Methods

Links
TnxBaseDateTimeVclFieldMapper Class, TnxBaseDateTimeVclFieldMapper Members, nxdbConversion Namespace, TnxBaseDateTimeVclFieldMapper Methods


TnxBaseFloatVclFieldMapper Class

TnxBaseFloatVclFieldMapper Class
TnxBaseFloatVclFieldMapper Methods TnxBaseFloatVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseFloatVclFieldMappernxdbConversion_TnxBaseFloatVclFieldMappernxdbConversion_TnxBaseFloatVclFieldMappernxdbConversion_TnxBaseFloatVclFieldMapper
Syntax
Delphi
TnxBaseFloatVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseFloatVclFieldMapper.

Group

Classes

Links
TnxBaseFloatVclFieldMapper Methods, TnxBaseFloatVclFieldMapper Members, nxdbConversion, Classes


TnxBaseFloatVclFieldMapper Members

TnxBaseFloatVclFieldMapper Members
TnxBaseFloatVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFloatVclFieldMapper.

Class

TnxBaseFloatVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseFloatVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBaseFloatVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseFloatVclFieldMapper Methods

TnxBaseFloatVclFieldMapper Methods
TnxBaseFloatVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBaseFloatVclFieldMapper class are listed here.

Class

TnxBaseFloatVclFieldMapper Class

Protected Methods
Name | Description
GetVclType | TnxBaseFloatVclFieldMapper
Links
TnxBaseFloatVclFieldMapper Class, Legend, Protected Methods


TnxBaseFloatVclFieldMapper.GetVclType Method

TnxBaseFloatVclFieldMapper.GetVclType Method
TnxBaseFloatVclFieldMapper Class TnxBaseFloatVclFieldMapper Members nxdbConversion Namespace TnxBaseFloatVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Description

TnxBaseFloatVclFieldMapper

Group

TnxBaseFloatVclFieldMapper Methods

Links
TnxBaseFloatVclFieldMapper Class, TnxBaseFloatVclFieldMapper Members, nxdbConversion Namespace, TnxBaseFloatVclFieldMapper Methods


TnxBasePaddingVclFieldMapper Class

TnxBasePaddingVclFieldMapper Class
TnxBasePaddingVclFieldMapper Fields TnxBasePaddingVclFieldMapper Methods TnxBasePaddingVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBasePaddingVclFieldMappernxdbConversion_TnxBasePaddingVclFieldMappernxdbConversion_TnxBasePaddingVclFieldMappernxdbConversion_TnxBasePaddingVclFieldMapper
Syntax
Delphi
TnxBasePaddingVclFieldMapper = class(TnxVariableSizeVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBasePaddingVclFieldMapper.

Group

Classes

Links
TnxBasePaddingVclFieldMapper Fields, TnxBasePaddingVclFieldMapper Methods, TnxBasePaddingVclFieldMapper Members, nxdbConversion, Classes


TnxBasePaddingVclFieldMapper Members

TnxBasePaddingVclFieldMapper Members
TnxBasePaddingVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBasePaddingVclFieldMapper.

Class

TnxBasePaddingVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | abstract;
GetUnitsFromParamSize | abstract;
GetVclType | abstract;
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | This is MapNexusDataToVcl, a member of class TnxVariableSizeVclFieldMapper.
MapNexusDataToVclPadded | This is MapNexusDataToVclPadded, a member of class TnxBasePaddingVclFieldMapper.
MapVclDataToNexus | This is MapVclDataToNexus, a member of class TnxVariableSizeVclFieldMapper.
MapVclDataToNexusPadded | This is MapVclDataToNexusPadded, a member of class TnxBasePaddingVclFieldMapper.
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBasePaddingVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBasePaddingVclFieldMapper Fields

TnxBasePaddingVclFieldMapper Fields
TnxBasePaddingVclFieldMapper Class Legend Protected Fields Send Feedback

The fields of the TnxBasePaddingVclFieldMapper class are listed here.

Class

TnxBasePaddingVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
Links
TnxBasePaddingVclFieldMapper Class, Legend, Protected Fields


TnxBasePaddingVclFieldMapper.bpvfmPadding Field

TnxBasePaddingVclFieldMapper.bpvfmPadding Field
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Fields Send Feedback
Syntax
Delphi
bpvfmPadding: Word;
Description

private

Group

TnxBasePaddingVclFieldMapper Fields

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Fields


TnxBasePaddingVclFieldMapper Methods

TnxBasePaddingVclFieldMapper Methods
TnxBasePaddingVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBasePaddingVclFieldMapper class are listed here.

Class

TnxBasePaddingVclFieldMapper Class

Protected Methods
Name | Description
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
MapNexusDataToVclPadded | This is MapNexusDataToVclPadded, a member of class TnxBasePaddingVclFieldMapper.
MapVclDataToNexusPadded | This is MapVclDataToNexusPadded, a member of class TnxBasePaddingVclFieldMapper.
Links
TnxBasePaddingVclFieldMapper Class, Legend, Protected Methods


TnxBasePaddingVclFieldMapper.InternalAddDescriptorForFieldDef Method

TnxBasePaddingVclFieldMapper.InternalAddDescriptorForFieldDef Method
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalAddDescriptorForFieldDef(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDef: TFieldDef): TnxFieldDescriptor; override;
Description

CreateTable

TnxBasePaddingVclFieldMapper

Group

TnxBasePaddingVclFieldMapper Methods

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Methods


TnxBasePaddingVclFieldMapper.InternalGetMapperForDescriptor Method

TnxBasePaddingVclFieldMapper.InternalGetMapperForDescriptor Method
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; override;
Description

GetFieldData / SetFieldData

Group

TnxBasePaddingVclFieldMapper Methods

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Methods


TnxBasePaddingVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxBasePaddingVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); override;
Description

InitFieldDefs

Group

TnxBasePaddingVclFieldMapper Methods

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Methods


TnxBasePaddingVclFieldMapper.MapNexusDataToVclPadded Method

TnxBasePaddingVclFieldMapper.MapNexusDataToVclPadded Method
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclPadded(const aFrom; out aTo); virtual; abstract;
Description

This is MapNexusDataToVclPadded, a member of class TnxBasePaddingVclFieldMapper.

Group

TnxBasePaddingVclFieldMapper Methods

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Methods


TnxBasePaddingVclFieldMapper.MapVclDataToNexusPadded Method

TnxBasePaddingVclFieldMapper.MapVclDataToNexusPadded Method
TnxBasePaddingVclFieldMapper Class TnxBasePaddingVclFieldMapper Members nxdbConversion Namespace TnxBasePaddingVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusPadded(const aFrom; out aTo); virtual; abstract;
Description

This is MapVclDataToNexusPadded, a member of class TnxBasePaddingVclFieldMapper.

Group

TnxBasePaddingVclFieldMapper Methods

Links
TnxBasePaddingVclFieldMapper Class, TnxBasePaddingVclFieldMapper Members, nxdbConversion Namespace, TnxBasePaddingVclFieldMapper Methods


TnxBaseStringVclFieldMapper Class

TnxBaseStringVclFieldMapper Class
TnxBaseStringVclFieldMapper Fields TnxBaseStringVclFieldMapper Methods TnxBaseStringVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseStringVclFieldMappernxdbConversion_TnxBaseStringVclFieldMappernxdbConversion_TnxBaseStringVclFieldMappernxdbConversion_TnxBaseStringVclFieldMappernxdbConversion_TnxBaseStringVclFieldMapper
Syntax
Delphi
TnxBaseStringVclFieldMapper = class(TnxBasePaddingVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseStringVclFieldMapper.

Group

Classes

Links
TnxBaseStringVclFieldMapper Fields, TnxBaseStringVclFieldMapper Methods, TnxBaseStringVclFieldMapper Members, nxdbConversion, Classes


TnxBaseStringVclFieldMapper Members

TnxBaseStringVclFieldMapper Members
TnxBaseStringVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseStringVclFieldMapper.

Class

TnxBaseStringVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
bsvfmField | private
bsvfmStorageCodepage | This is bsvfmStorageCodepage, a member of class TnxBaseStringVclFieldMapper.
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | abstract;
GetUnitsFromParamSize |
GetVclType |
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | This is MapNexusDataToVcl, a member of class TnxVariableSizeVclFieldMapper.
MapNexusDataToVclPadded | This is MapNexusDataToVclPadded, a member of class TnxBasePaddingVclFieldMapper.
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexus | This is MapVclDataToNexus, a member of class TnxVariableSizeVclFieldMapper.
MapVclDataToNexusPadded | This is MapVclDataToNexusPadded, a member of class TnxBasePaddingVclFieldMapper.
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind | TnxBaseStringVclFieldMapper
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBaseStringVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseStringVclFieldMapper Fields

TnxBaseStringVclFieldMapper Fields
TnxBaseStringVclFieldMapper Class Legend Protected Fields Send Feedback

The fields of the TnxBaseStringVclFieldMapper class are listed here.

Class

TnxBaseStringVclFieldMapper Class

Protected Fields
Name | Description
bsvfmField | private
bsvfmStorageCodepage | This is bsvfmStorageCodepage, a member of class TnxBaseStringVclFieldMapper.
Links
TnxBaseStringVclFieldMapper Class, Legend, Protected Fields


TnxBaseStringVclFieldMapper.bsvfmField Field

TnxBaseStringVclFieldMapper.bsvfmField Field
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Fields Send Feedback
Syntax
Delphi
bsvfmField: TStringField;
Description

private

Group

TnxBaseStringVclFieldMapper Fields

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Fields


TnxBaseStringVclFieldMapper.bsvfmStorageCodepage Field

TnxBaseStringVclFieldMapper.bsvfmStorageCodepage Field
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Fields Send Feedback
Syntax
Delphi
bsvfmStorageCodepage: Word;
Description

This is bsvfmStorageCodepage, a member of class TnxBaseStringVclFieldMapper.

Group

TnxBaseStringVclFieldMapper Fields

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Fields


TnxBaseStringVclFieldMapper Methods

TnxBaseStringVclFieldMapper Methods
TnxBaseStringVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseStringVclFieldMapper class are listed here.

Class

TnxBaseStringVclFieldMapper Class

Protected Methods
Name | Description
GetUnitsFromParamSize |
GetVclType |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
Public Methods
Name | Description
Bind | TnxBaseStringVclFieldMapper
Links
TnxBaseStringVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseStringVclFieldMapper.Bind Method

TnxBaseStringVclFieldMapper.Bind Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure Bind(aField: TField); override;
Description

TnxBaseStringVclFieldMapper

Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.GetUnitsFromParamSize Method

TnxBaseStringVclFieldMapper.GetUnitsFromParamSize Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetUnitsFromParamSize(aParamSize: Integer): Integer; override;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.GetVclType Method

TnxBaseStringVclFieldMapper.GetVclType Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.InternalGetMapperForDescriptor Method

TnxBaseStringVclFieldMapper.InternalGetMapperForDescriptor Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; override;
Description

GetFieldData / SetFieldData

Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.MapNexusDataToVclTranslate Method

TnxBaseStringVclFieldMapper.MapNexusDataToVclTranslate Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslate(const aFrom; out aTo); virtual;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method

TnxBaseStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslatePadded(const aFrom; out aTo); virtual;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.MapVclDataToNexusTranslate Method

TnxBaseStringVclFieldMapper.MapVclDataToNexusTranslate Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslate(const aFrom; out aTo); virtual;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method

TnxBaseStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method
TnxBaseStringVclFieldMapper Class TnxBaseStringVclFieldMapper Members nxdbConversion Namespace TnxBaseStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslatePadded(const aFrom; out aTo); virtual;
Group

TnxBaseStringVclFieldMapper Methods

Links
TnxBaseStringVclFieldMapper Class, TnxBaseStringVclFieldMapper Members, nxdbConversion Namespace, TnxBaseStringVclFieldMapper Methods


TnxBaseVclFieldMapper Class

TnxBaseVclFieldMapper Class
TnxBaseVclFieldMapper Methods TnxBaseVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBaseVclFieldMappernxdbConversion_TnxBaseVclFieldMapper
Syntax
Delphi
TnxBaseVclFieldMapper = class(TnxObject);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBaseVclFieldMapper.

Group

Classes

Links
TnxBaseVclFieldMapper Methods, TnxBaseVclFieldMapper Members, nxdbConversion, Classes


TnxBaseVclFieldMapper Members

TnxBaseVclFieldMapper Members
TnxBaseVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseVclFieldMapper.

Class

TnxBaseVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusToParamType | abstract;
InternalMapParamTypeAndSizeToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBaseVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseVclFieldMapper Methods

TnxBaseVclFieldMapper Methods
TnxBaseVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseVclFieldMapper class are listed here.

Class

TnxBaseVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusToParamType | abstract;
InternalMapParamTypeAndSizeToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
Links
TnxBaseVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseVclFieldMapper.AddDescriptorForFieldDef Method

TnxBaseVclFieldMapper.AddDescriptorForFieldDef Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function AddDescriptorForFieldDef(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDef: TFieldDef): TnxFieldDescriptor;
Description

CreateTable

TnxBaseVclFieldMapper

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.Bind Method

TnxBaseVclFieldMapper.Bind Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure Bind(aField: TField); virtual;
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.GetMapperForDescriptor Method

TnxBaseVclFieldMapper.GetMapperForDescriptor Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper;
Description

GetFieldData / SetFieldData

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.GetNexusType Method

TnxBaseVclFieldMapper.GetNexusType Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; virtual;
Description

abstract;

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.InternalAddDescriptorForFieldDef Method

TnxBaseVclFieldMapper.InternalAddDescriptorForFieldDef Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalAddDescriptorForFieldDef(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDef: TFieldDef): TnxFieldDescriptor; virtual;
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.InternalGetMapperForDescriptor Method

TnxBaseVclFieldMapper.InternalGetMapperForDescriptor Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; virtual;
Description

abstract; -- CreateTable

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxBaseVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); virtual;
Description

abstract;

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.InternalMapNexusToParamType Method

TnxBaseVclFieldMapper.InternalMapNexusToParamType Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalMapNexusToParamType(aNexusType: TnxFieldType): TFieldType; virtual;
Description

abstract;

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method

TnxBaseVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapParamTypeAndSizeToNexus(aParamType: TFieldType; aParamSize: Integer; out aNexusType: TnxFieldType; out aNexusSize: TnxWord32); virtual;
Description

abstract;

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.MapNexusDescriptorToVcl Method

TnxBaseVclFieldMapper.MapNexusDescriptorToVcl Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes);
Description

InitFieldDefs

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.MapNexusToParamType Method

TnxBaseVclFieldMapper.MapNexusToParamType Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function MapNexusToParamType(aNexusType: TnxFieldType): TFieldType;
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.MapParamTypeAndSizeToNexus Method

TnxBaseVclFieldMapper.MapParamTypeAndSizeToNexus Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapParamTypeAndSizeToNexus(aParamType: TFieldType; aParamSize: Integer; out aNexusType: TnxFieldType; out aNexusSize: TnxWord32);
Description

TParam support

Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.RegisterNexus Method

TnxBaseVclFieldMapper.RegisterNexus Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure RegisterNexus;
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.RegisterVcl Method

TnxBaseVclFieldMapper.RegisterVcl Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure RegisterVcl(aFieldType: TFieldType);
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBaseVclFieldMapper.UnRegister Method

TnxBaseVclFieldMapper.UnRegister Method
TnxBaseVclFieldMapper Class TnxBaseVclFieldMapper Members nxdbConversion Namespace TnxBaseVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure UnRegister;
Group

TnxBaseVclFieldMapper Methods

Links
TnxBaseVclFieldMapper Class, TnxBaseVclFieldMapper Members, nxdbConversion Namespace, TnxBaseVclFieldMapper Methods


TnxBcdVclFieldMapper Class

TnxBcdVclFieldMapper Class
TnxBcdVclFieldMapper Fields TnxBcdVclFieldMapper Methods TnxBcdVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBcdVclFieldMappernxdbConversion_TnxBcdVclFieldMappernxdbConversion_TnxBcdVclFieldMappernxdbConversion_TnxBcdVclFieldMapper
Syntax
Delphi
TnxBcdVclFieldMapper = class(TnxInstantiatedVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBcdVclFieldMapper.

Group

Classes

Links
TnxBcdVclFieldMapper Fields, TnxBcdVclFieldMapper Methods, TnxBcdVclFieldMapper Members, nxdbConversion, Classes


TnxBcdVclFieldMapper Members

TnxBcdVclFieldMapper Members
TnxBcdVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBcdVclFieldMapper.

Class

TnxBcdVclFieldMapper Class

Protected Fields
Name | Description
bcdfmDecimals | This is bcdfmDecimals, a member of class TnxBcdVclFieldMapper.
bcdfmNeedNormalize | This is bcdfmNeedNormalize, a member of class TnxBcdVclFieldMapper.
bcdfmPrecision | private
Protected Methods
Name | Description
GetNexusType |
GetVclSize |
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxBcdVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBcdVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBcdVclFieldMapper.Create Constructor

TnxBcdVclFieldMapper.Create Constructor
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Class Send Feedback
Syntax
Delphi
constructor Create(aFieldDescriptor: TnxFieldDescriptor); override;
Description

TnxBcdVclFieldMapper

Class

TnxBcdVclFieldMapper Class

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Class


TnxBcdVclFieldMapper Fields

TnxBcdVclFieldMapper Fields
TnxBcdVclFieldMapper Class Legend Protected Fields Send Feedback

The fields of the TnxBcdVclFieldMapper class are listed here.

Class

TnxBcdVclFieldMapper Class

Protected Fields
Name | Description
bcdfmDecimals | This is bcdfmDecimals, a member of class TnxBcdVclFieldMapper.
bcdfmNeedNormalize | This is bcdfmNeedNormalize, a member of class TnxBcdVclFieldMapper.
bcdfmPrecision | private
Links
TnxBcdVclFieldMapper Class, Legend, Protected Fields


TnxBcdVclFieldMapper.bcdfmDecimals Field

TnxBcdVclFieldMapper.bcdfmDecimals Field
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
bcdfmDecimals: Integer;
Description

This is bcdfmDecimals, a member of class TnxBcdVclFieldMapper.

Group

TnxBcdVclFieldMapper Fields

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Fields


TnxBcdVclFieldMapper.bcdfmNeedNormalize Field

TnxBcdVclFieldMapper.bcdfmNeedNormalize Field
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
bcdfmNeedNormalize: Boolean;
Description

This is bcdfmNeedNormalize, a member of class TnxBcdVclFieldMapper.

Group

TnxBcdVclFieldMapper Fields

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Fields


TnxBcdVclFieldMapper.bcdfmPrecision Field

TnxBcdVclFieldMapper.bcdfmPrecision Field
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
bcdfmPrecision: Integer;
Description

private

Group

TnxBcdVclFieldMapper Fields

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Fields


TnxBcdVclFieldMapper Methods

TnxBcdVclFieldMapper Methods
TnxBcdVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBcdVclFieldMapper class are listed here.

Class

TnxBcdVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType |
GetVclType |
InternalAddDescriptorForFieldDef |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxBcdVclFieldMapper Class, Legend, Protected Methods


TnxBcdVclFieldMapper.GetNexusType Method

TnxBcdVclFieldMapper.GetNexusType Method
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Group

TnxBcdVclFieldMapper Methods

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Methods


TnxBcdVclFieldMapper.GetVclType Method

TnxBcdVclFieldMapper.GetVclType Method
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxBcdVclFieldMapper Methods

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Methods


TnxBcdVclFieldMapper.InternalAddDescriptorForFieldDef Method

TnxBcdVclFieldMapper.InternalAddDescriptorForFieldDef Method
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalAddDescriptorForFieldDef(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDef: TFieldDef): TnxFieldDescriptor; override;
Group

TnxBcdVclFieldMapper Methods

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Methods


TnxBcdVclFieldMapper.MapNexusDataToVcl Method

TnxBcdVclFieldMapper.MapNexusDataToVcl Method
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxBcdVclFieldMapper Methods

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Methods


TnxBcdVclFieldMapper.MapVclDataToNexus Method

TnxBcdVclFieldMapper.MapVclDataToNexus Method
TnxBcdVclFieldMapper Class TnxBcdVclFieldMapper Members nxdbConversion Namespace TnxBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxBcdVclFieldMapper Methods

Links
TnxBcdVclFieldMapper Class, TnxBcdVclFieldMapper Members, nxdbConversion Namespace, TnxBcdVclFieldMapper Methods


TnxBlobVclFieldMapper Class

TnxBlobVclFieldMapper Class
TnxBlobVclFieldMapper Methods TnxBlobVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBlobVclFieldMappernxdbConversion_TnxBlobVclFieldMappernxdbConversion_TnxBlobVclFieldMappernxdbConversion_TnxBlobVclFieldMappernxdbConversion_TnxBlobVclFieldMappernxdbConversion_TnxBlobVclFieldMapper
Syntax
Delphi
TnxBlobVclFieldMapper = class(TnxBaseBlobVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBlobVclFieldMapper.

Group

Classes

Links
TnxBlobVclFieldMapper Methods, TnxBlobVclFieldMapper Members, nxdbConversion, Classes


TnxBlobVclFieldMapper Members

TnxBlobVclFieldMapper Members
TnxBlobVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBlobVclFieldMapper.

Class

TnxBlobVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxBlobVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBlobVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBlobVclFieldMapper Methods

TnxBlobVclFieldMapper Methods
TnxBlobVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBlobVclFieldMapper class are listed here.

Class

TnxBlobVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxBlobVclFieldMapper
GetVclType |
Links
TnxBlobVclFieldMapper Class, Legend, Protected Methods


TnxBlobVclFieldMapper.GetNexusType Method

TnxBlobVclFieldMapper.GetNexusType Method
TnxBlobVclFieldMapper Class TnxBlobVclFieldMapper Members nxdbConversion Namespace TnxBlobVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxBlobVclFieldMapper

Group

TnxBlobVclFieldMapper Methods

Links
TnxBlobVclFieldMapper Class, TnxBlobVclFieldMapper Members, nxdbConversion Namespace, TnxBlobVclFieldMapper Methods


TnxBlobVclFieldMapper.GetVclType Method

TnxBlobVclFieldMapper.GetVclType Method
TnxBlobVclFieldMapper Class TnxBlobVclFieldMapper Members nxdbConversion Namespace TnxBlobVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxBlobVclFieldMapper Methods

Links
TnxBlobVclFieldMapper Class, TnxBlobVclFieldMapper Members, nxdbConversion Namespace, TnxBlobVclFieldMapper Methods


TnxBooleanVclFieldMapper Class

TnxBooleanVclFieldMapper Class
TnxBooleanVclFieldMapper Methods TnxBooleanVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxBooleanVclFieldMappernxdbConversion_TnxBooleanVclFieldMappernxdbConversion_TnxBooleanVclFieldMappernxdbConversion_TnxBooleanVclFieldMapper
Syntax
Delphi
TnxBooleanVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxBooleanVclFieldMapper.

Group

Classes

Links
TnxBooleanVclFieldMapper Methods, TnxBooleanVclFieldMapper Members, nxdbConversion, Classes


TnxBooleanVclFieldMapper Members

TnxBooleanVclFieldMapper Members
TnxBooleanVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBooleanVclFieldMapper.

Class

TnxBooleanVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxBooleanVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxBooleanVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBooleanVclFieldMapper Methods

TnxBooleanVclFieldMapper Methods
TnxBooleanVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBooleanVclFieldMapper class are listed here.

Class

TnxBooleanVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxBooleanVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxBooleanVclFieldMapper Class, Legend, Protected Methods


TnxBooleanVclFieldMapper.GetNexusType Method

TnxBooleanVclFieldMapper.GetNexusType Method
TnxBooleanVclFieldMapper Class TnxBooleanVclFieldMapper Members nxdbConversion Namespace TnxBooleanVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxBooleanVclFieldMapper

Group

TnxBooleanVclFieldMapper Methods

Links
TnxBooleanVclFieldMapper Class, TnxBooleanVclFieldMapper Members, nxdbConversion Namespace, TnxBooleanVclFieldMapper Methods


TnxBooleanVclFieldMapper.GetVclType Method

TnxBooleanVclFieldMapper.GetVclType Method
TnxBooleanVclFieldMapper Class TnxBooleanVclFieldMapper Members nxdbConversion Namespace TnxBooleanVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxBooleanVclFieldMapper Methods

Links
TnxBooleanVclFieldMapper Class, TnxBooleanVclFieldMapper Members, nxdbConversion Namespace, TnxBooleanVclFieldMapper Methods


TnxBooleanVclFieldMapper.MapNexusDataToVcl Method

TnxBooleanVclFieldMapper.MapNexusDataToVcl Method
TnxBooleanVclFieldMapper Class TnxBooleanVclFieldMapper Members nxdbConversion Namespace TnxBooleanVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxBooleanVclFieldMapper Methods

Links
TnxBooleanVclFieldMapper Class, TnxBooleanVclFieldMapper Members, nxdbConversion Namespace, TnxBooleanVclFieldMapper Methods


TnxBooleanVclFieldMapper.MapVclDataToNexus Method

TnxBooleanVclFieldMapper.MapVclDataToNexus Method
TnxBooleanVclFieldMapper Class TnxBooleanVclFieldMapper Members nxdbConversion Namespace TnxBooleanVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxBooleanVclFieldMapper Methods

Links
TnxBooleanVclFieldMapper Class, TnxBooleanVclFieldMapper Members, nxdbConversion Namespace, TnxBooleanVclFieldMapper Methods


TnxByte8VclFieldMapper Class

TnxByte8VclFieldMapper Class
TnxByte8VclFieldMapper Methods TnxByte8VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxByte8VclFieldMappernxdbConversion_TnxByte8VclFieldMappernxdbConversion_TnxByte8VclFieldMappernxdbConversion_TnxByte8VclFieldMapper
Syntax
Delphi
TnxByte8VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxByte8VclFieldMapper.

Group

Classes

Links
TnxByte8VclFieldMapper Methods, TnxByte8VclFieldMapper Members, nxdbConversion, Classes


TnxByte8VclFieldMapper Members

TnxByte8VclFieldMapper Members
TnxByte8VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxByte8VclFieldMapper.

Class

TnxByte8VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxByte8VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxByte8VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxByte8VclFieldMapper Methods

TnxByte8VclFieldMapper Methods
TnxByte8VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxByte8VclFieldMapper class are listed here.

Class

TnxByte8VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxByte8VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxByte8VclFieldMapper Class, Legend, Protected Methods


TnxByte8VclFieldMapper.GetNexusType Method

TnxByte8VclFieldMapper.GetNexusType Method
TnxByte8VclFieldMapper Class TnxByte8VclFieldMapper Members nxdbConversion Namespace TnxByte8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxByte8VclFieldMapper

Group

TnxByte8VclFieldMapper Methods

Links
TnxByte8VclFieldMapper Class, TnxByte8VclFieldMapper Members, nxdbConversion Namespace, TnxByte8VclFieldMapper Methods


TnxByte8VclFieldMapper.GetVclType Method

TnxByte8VclFieldMapper.GetVclType Method
TnxByte8VclFieldMapper Class TnxByte8VclFieldMapper Members nxdbConversion Namespace TnxByte8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxByte8VclFieldMapper Methods

Links
TnxByte8VclFieldMapper Class, TnxByte8VclFieldMapper Members, nxdbConversion Namespace, TnxByte8VclFieldMapper Methods


TnxByte8VclFieldMapper.MapNexusDataToVcl Method

TnxByte8VclFieldMapper.MapNexusDataToVcl Method
TnxByte8VclFieldMapper Class TnxByte8VclFieldMapper Members nxdbConversion Namespace TnxByte8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxByte8VclFieldMapper Methods

Links
TnxByte8VclFieldMapper Class, TnxByte8VclFieldMapper Members, nxdbConversion Namespace, TnxByte8VclFieldMapper Methods


TnxByte8VclFieldMapper.MapVclDataToNexus Method

TnxByte8VclFieldMapper.MapVclDataToNexus Method
TnxByte8VclFieldMapper Class TnxByte8VclFieldMapper Members nxdbConversion Namespace TnxByte8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxByte8VclFieldMapper Methods

Links
TnxByte8VclFieldMapper Class, TnxByte8VclFieldMapper Members, nxdbConversion Namespace, TnxByte8VclFieldMapper Methods


TnxByteArrayVclFieldMapper Class

TnxByteArrayVclFieldMapper Class
TnxByteArrayVclFieldMapper Methods TnxByteArrayVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxByteArrayVclFieldMappernxdbConversion_TnxByteArrayVclFieldMappernxdbConversion_TnxByteArrayVclFieldMappernxdbConversion_TnxByteArrayVclFieldMapper
Syntax
Delphi
TnxByteArrayVclFieldMapper = class(TnxVariableSizeVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxByteArrayVclFieldMapper.

Group

Classes

Links
TnxByteArrayVclFieldMapper Methods, TnxByteArrayVclFieldMapper Members, nxdbConversion, Classes


TnxByteArrayVclFieldMapper Members

TnxByteArrayVclFieldMapper Members
TnxByteArrayVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxByteArrayVclFieldMapper.

Class

TnxByteArrayVclFieldMapper Class

Protected Fields
Name | Description
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | TnxByteArrayVclFieldMapper
GetUnitsFromParamSize |
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxByteArrayVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxByteArrayVclFieldMapper Methods

TnxByteArrayVclFieldMapper Methods
TnxByteArrayVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxByteArrayVclFieldMapper class are listed here.

Class

TnxByteArrayVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxByteArrayVclFieldMapper
GetUnitsFromParamSize |
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxByteArrayVclFieldMapper Class, Legend, Protected Methods


TnxByteArrayVclFieldMapper.GetNexusType Method

TnxByteArrayVclFieldMapper.GetNexusType Method
TnxByteArrayVclFieldMapper Class TnxByteArrayVclFieldMapper Members nxdbConversion Namespace TnxByteArrayVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxByteArrayVclFieldMapper

Group

TnxByteArrayVclFieldMapper Methods

Links
TnxByteArrayVclFieldMapper Class, TnxByteArrayVclFieldMapper Members, nxdbConversion Namespace, TnxByteArrayVclFieldMapper Methods


TnxByteArrayVclFieldMapper.GetUnitsFromParamSize Method

TnxByteArrayVclFieldMapper.GetUnitsFromParamSize Method
TnxByteArrayVclFieldMapper Class TnxByteArrayVclFieldMapper Members nxdbConversion Namespace TnxByteArrayVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetUnitsFromParamSize(aParamSize: Integer): Integer; override;
Group

TnxByteArrayVclFieldMapper Methods

Links
TnxByteArrayVclFieldMapper Class, TnxByteArrayVclFieldMapper Members, nxdbConversion Namespace, TnxByteArrayVclFieldMapper Methods


TnxByteArrayVclFieldMapper.GetVclType Method

TnxByteArrayVclFieldMapper.GetVclType Method
TnxByteArrayVclFieldMapper Class TnxByteArrayVclFieldMapper Members nxdbConversion Namespace TnxByteArrayVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxByteArrayVclFieldMapper Methods

Links
TnxByteArrayVclFieldMapper Class, TnxByteArrayVclFieldMapper Members, nxdbConversion Namespace, TnxByteArrayVclFieldMapper Methods


TnxByteArrayVclFieldMapper.MapNexusDataToVcl Method

TnxByteArrayVclFieldMapper.MapNexusDataToVcl Method
TnxByteArrayVclFieldMapper Class TnxByteArrayVclFieldMapper Members nxdbConversion Namespace TnxByteArrayVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxByteArrayVclFieldMapper Methods

Links
TnxByteArrayVclFieldMapper Class, TnxByteArrayVclFieldMapper Members, nxdbConversion Namespace, TnxByteArrayVclFieldMapper Methods


TnxByteArrayVclFieldMapper.MapVclDataToNexus Method

TnxByteArrayVclFieldMapper.MapVclDataToNexus Method
TnxByteArrayVclFieldMapper Class TnxByteArrayVclFieldMapper Members nxdbConversion Namespace TnxByteArrayVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxByteArrayVclFieldMapper Methods

Links
TnxByteArrayVclFieldMapper Class, TnxByteArrayVclFieldMapper Members, nxdbConversion Namespace, TnxByteArrayVclFieldMapper Methods


TnxCurrencyVclFieldMapper Class

TnxCurrencyVclFieldMapper Class
TnxCurrencyVclFieldMapper Methods TnxCurrencyVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxCurrencyVclFieldMappernxdbConversion_TnxCurrencyVclFieldMappernxdbConversion_TnxCurrencyVclFieldMappernxdbConversion_TnxCurrencyVclFieldMapper
Syntax
Delphi
TnxCurrencyVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxCurrencyVclFieldMapper.

Group

Classes

Links
TnxCurrencyVclFieldMapper Methods, TnxCurrencyVclFieldMapper Members, nxdbConversion, Classes


TnxCurrencyVclFieldMapper Members

TnxCurrencyVclFieldMapper Members
TnxCurrencyVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCurrencyVclFieldMapper.

Class

TnxCurrencyVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxCurrencyVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxCurrencyVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxCurrencyVclFieldMapper Methods

TnxCurrencyVclFieldMapper Methods
TnxCurrencyVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxCurrencyVclFieldMapper class are listed here.

Class

TnxCurrencyVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxCurrencyVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxCurrencyVclFieldMapper Class, Legend, Protected Methods


TnxCurrencyVclFieldMapper.GetNexusType Method

TnxCurrencyVclFieldMapper.GetNexusType Method
TnxCurrencyVclFieldMapper Class TnxCurrencyVclFieldMapper Members nxdbConversion Namespace TnxCurrencyVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxCurrencyVclFieldMapper

Group

TnxCurrencyVclFieldMapper Methods

Links
TnxCurrencyVclFieldMapper Class, TnxCurrencyVclFieldMapper Members, nxdbConversion Namespace, TnxCurrencyVclFieldMapper Methods


TnxCurrencyVclFieldMapper.GetVclType Method

TnxCurrencyVclFieldMapper.GetVclType Method
TnxCurrencyVclFieldMapper Class TnxCurrencyVclFieldMapper Members nxdbConversion Namespace TnxCurrencyVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxCurrencyVclFieldMapper Methods

Links
TnxCurrencyVclFieldMapper Class, TnxCurrencyVclFieldMapper Members, nxdbConversion Namespace, TnxCurrencyVclFieldMapper Methods


TnxCurrencyVclFieldMapper.MapNexusDataToVcl Method

TnxCurrencyVclFieldMapper.MapNexusDataToVcl Method
TnxCurrencyVclFieldMapper Class TnxCurrencyVclFieldMapper Members nxdbConversion Namespace TnxCurrencyVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxCurrencyVclFieldMapper Methods

Links
TnxCurrencyVclFieldMapper Class, TnxCurrencyVclFieldMapper Members, nxdbConversion Namespace, TnxCurrencyVclFieldMapper Methods


TnxCurrencyVclFieldMapper.MapVclDataToNexus Method

TnxCurrencyVclFieldMapper.MapVclDataToNexus Method
TnxCurrencyVclFieldMapper Class TnxCurrencyVclFieldMapper Members nxdbConversion Namespace TnxCurrencyVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxCurrencyVclFieldMapper Methods

Links
TnxCurrencyVclFieldMapper Class, TnxCurrencyVclFieldMapper Members, nxdbConversion Namespace, TnxCurrencyVclFieldMapper Methods


TnxDateTimeVclFieldMapper Class

TnxDateTimeVclFieldMapper Class
TnxDateTimeVclFieldMapper Methods TnxDateTimeVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxDateTimeVclFieldMappernxdbConversion_TnxDateTimeVclFieldMappernxdbConversion_TnxDateTimeVclFieldMappernxdbConversion_TnxDateTimeVclFieldMappernxdbConversion_TnxDateTimeVclFieldMapper
Syntax
Delphi
TnxDateTimeVclFieldMapper = class(TnxBaseDateTimeVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxDateTimeVclFieldMapper.

Group

Classes

Links
TnxDateTimeVclFieldMapper Methods, TnxDateTimeVclFieldMapper Members, nxdbConversion, Classes


TnxDateTimeVclFieldMapper Members

TnxDateTimeVclFieldMapper Members
TnxDateTimeVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDateTimeVclFieldMapper.

Class

TnxDateTimeVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDateTimeVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseDateTimeVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxDateTimeVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxDateTimeVclFieldMapper Methods

TnxDateTimeVclFieldMapper Methods
TnxDateTimeVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDateTimeVclFieldMapper class are listed here.

Class

TnxDateTimeVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDateTimeVclFieldMapper
Links
TnxDateTimeVclFieldMapper Class, Legend, Protected Methods


TnxDateTimeVclFieldMapper.GetNexusType Method

TnxDateTimeVclFieldMapper.GetNexusType Method
TnxDateTimeVclFieldMapper Class TnxDateTimeVclFieldMapper Members nxdbConversion Namespace TnxDateTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxDateTimeVclFieldMapper

Group

TnxDateTimeVclFieldMapper Methods

Links
TnxDateTimeVclFieldMapper Class, TnxDateTimeVclFieldMapper Members, nxdbConversion Namespace, TnxDateTimeVclFieldMapper Methods


TnxDateVclFieldMapper Class

TnxDateVclFieldMapper Class
TnxDateVclFieldMapper Methods TnxDateVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxDateVclFieldMappernxdbConversion_TnxDateVclFieldMappernxdbConversion_TnxDateVclFieldMappernxdbConversion_TnxDateVclFieldMapper
Syntax
Delphi
TnxDateVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxDateVclFieldMapper.

Group

Classes

Links
TnxDateVclFieldMapper Methods, TnxDateVclFieldMapper Members, nxdbConversion, Classes


TnxDateVclFieldMapper Members

TnxDateVclFieldMapper Members
TnxDateVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDateVclFieldMapper.

Class

TnxDateVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDateVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxDateVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxDateVclFieldMapper Methods

TnxDateVclFieldMapper Methods
TnxDateVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDateVclFieldMapper class are listed here.

Class

TnxDateVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDateVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxDateVclFieldMapper Class, Legend, Protected Methods


TnxDateVclFieldMapper.GetNexusType Method

TnxDateVclFieldMapper.GetNexusType Method
TnxDateVclFieldMapper Class TnxDateVclFieldMapper Members nxdbConversion Namespace TnxDateVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxDateVclFieldMapper

Group

TnxDateVclFieldMapper Methods

Links
TnxDateVclFieldMapper Class, TnxDateVclFieldMapper Members, nxdbConversion Namespace, TnxDateVclFieldMapper Methods


TnxDateVclFieldMapper.GetVclType Method

TnxDateVclFieldMapper.GetVclType Method
TnxDateVclFieldMapper Class TnxDateVclFieldMapper Members nxdbConversion Namespace TnxDateVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxDateVclFieldMapper Methods

Links
TnxDateVclFieldMapper Class, TnxDateVclFieldMapper Members, nxdbConversion Namespace, TnxDateVclFieldMapper Methods


TnxDateVclFieldMapper.MapNexusDataToVcl Method

TnxDateVclFieldMapper.MapNexusDataToVcl Method
TnxDateVclFieldMapper Class TnxDateVclFieldMapper Members nxdbConversion Namespace TnxDateVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxDateVclFieldMapper Methods

Links
TnxDateVclFieldMapper Class, TnxDateVclFieldMapper Members, nxdbConversion Namespace, TnxDateVclFieldMapper Methods


TnxDateVclFieldMapper.MapVclDataToNexus Method

TnxDateVclFieldMapper.MapVclDataToNexus Method
TnxDateVclFieldMapper Class TnxDateVclFieldMapper Members nxdbConversion Namespace TnxDateVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxDateVclFieldMapper Methods

Links
TnxDateVclFieldMapper Class, TnxDateVclFieldMapper Members, nxdbConversion Namespace, TnxDateVclFieldMapper Methods


TnxDoubleVclFieldMapper Class

TnxDoubleVclFieldMapper Class
TnxDoubleVclFieldMapper Methods TnxDoubleVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxDoubleVclFieldMappernxdbConversion_TnxDoubleVclFieldMappernxdbConversion_TnxDoubleVclFieldMappernxdbConversion_TnxDoubleVclFieldMappernxdbConversion_TnxDoubleVclFieldMapper
Syntax
Delphi
TnxDoubleVclFieldMapper = class(TnxBaseFloatVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxDoubleVclFieldMapper.

Group

Classes

Links
TnxDoubleVclFieldMapper Methods, TnxDoubleVclFieldMapper Members, nxdbConversion, Classes


TnxDoubleVclFieldMapper Members

TnxDoubleVclFieldMapper Members
TnxDoubleVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDoubleVclFieldMapper.

Class

TnxDoubleVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDoubleVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseFloatVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxDoubleVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxDoubleVclFieldMapper Methods

TnxDoubleVclFieldMapper Methods
TnxDoubleVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDoubleVclFieldMapper class are listed here.

Class

TnxDoubleVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxDoubleVclFieldMapper
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxDoubleVclFieldMapper Class, Legend, Protected Methods


TnxDoubleVclFieldMapper.GetNexusType Method

TnxDoubleVclFieldMapper.GetNexusType Method
TnxDoubleVclFieldMapper Class TnxDoubleVclFieldMapper Members nxdbConversion Namespace TnxDoubleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxDoubleVclFieldMapper

Group

TnxDoubleVclFieldMapper Methods

Links
TnxDoubleVclFieldMapper Class, TnxDoubleVclFieldMapper Members, nxdbConversion Namespace, TnxDoubleVclFieldMapper Methods


TnxDoubleVclFieldMapper.MapNexusDataToVcl Method

TnxDoubleVclFieldMapper.MapNexusDataToVcl Method
TnxDoubleVclFieldMapper Class TnxDoubleVclFieldMapper Members nxdbConversion Namespace TnxDoubleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxDoubleVclFieldMapper Methods

Links
TnxDoubleVclFieldMapper Class, TnxDoubleVclFieldMapper Members, nxdbConversion Namespace, TnxDoubleVclFieldMapper Methods


TnxDoubleVclFieldMapper.MapVclDataToNexus Method

TnxDoubleVclFieldMapper.MapVclDataToNexus Method
TnxDoubleVclFieldMapper Class TnxDoubleVclFieldMapper Members nxdbConversion Namespace TnxDoubleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxDoubleVclFieldMapper Methods

Links
TnxDoubleVclFieldMapper Class, TnxDoubleVclFieldMapper Members, nxdbConversion Namespace, TnxDoubleVclFieldMapper Methods


TnxExtendedVclFieldMapper Class

TnxExtendedVclFieldMapper Class
TnxExtendedVclFieldMapper Methods TnxExtendedVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxExtendedVclFieldMappernxdbConversion_TnxExtendedVclFieldMappernxdbConversion_TnxExtendedVclFieldMappernxdbConversion_TnxExtendedVclFieldMappernxdbConversion_TnxExtendedVclFieldMapper
Syntax
Delphi
TnxExtendedVclFieldMapper = class(TnxBaseFloatVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxExtendedVclFieldMapper.

Group

Classes

Links
TnxExtendedVclFieldMapper Methods, TnxExtendedVclFieldMapper Members, nxdbConversion, Classes


TnxExtendedVclFieldMapper Members

TnxExtendedVclFieldMapper Members
TnxExtendedVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxExtendedVclFieldMapper.

Class

TnxExtendedVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxExtendedVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxExtendedVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxExtendedVclFieldMapper Methods

TnxExtendedVclFieldMapper Methods
TnxExtendedVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxExtendedVclFieldMapper class are listed here.

Class

TnxExtendedVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxExtendedVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxExtendedVclFieldMapper Class, Legend, Protected Methods


TnxExtendedVclFieldMapper.GetNexusType Method

TnxExtendedVclFieldMapper.GetNexusType Method
TnxExtendedVclFieldMapper Class TnxExtendedVclFieldMapper Members nxdbConversion Namespace TnxExtendedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxExtendedVclFieldMapper

Group

TnxExtendedVclFieldMapper Methods

Links
TnxExtendedVclFieldMapper Class, TnxExtendedVclFieldMapper Members, nxdbConversion Namespace, TnxExtendedVclFieldMapper Methods


TnxExtendedVclFieldMapper.GetVclType Method

TnxExtendedVclFieldMapper.GetVclType Method
TnxExtendedVclFieldMapper Class TnxExtendedVclFieldMapper Members nxdbConversion Namespace TnxExtendedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxExtendedVclFieldMapper Methods

Links
TnxExtendedVclFieldMapper Class, TnxExtendedVclFieldMapper Members, nxdbConversion Namespace, TnxExtendedVclFieldMapper Methods


TnxExtendedVclFieldMapper.MapNexusDataToVcl Method

TnxExtendedVclFieldMapper.MapNexusDataToVcl Method
TnxExtendedVclFieldMapper Class TnxExtendedVclFieldMapper Members nxdbConversion Namespace TnxExtendedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxExtendedVclFieldMapper Methods

Links
TnxExtendedVclFieldMapper Class, TnxExtendedVclFieldMapper Members, nxdbConversion Namespace, TnxExtendedVclFieldMapper Methods


TnxExtendedVclFieldMapper.MapVclDataToNexus Method

TnxExtendedVclFieldMapper.MapVclDataToNexus Method
TnxExtendedVclFieldMapper Class TnxExtendedVclFieldMapper Members nxdbConversion Namespace TnxExtendedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxExtendedVclFieldMapper Methods

Links
TnxExtendedVclFieldMapper Class, TnxExtendedVclFieldMapper Members, nxdbConversion Namespace, TnxExtendedVclFieldMapper Methods


TnxFmtBcdVclFieldMapper Class

TnxFmtBcdVclFieldMapper Class
TnxFmtBcdVclFieldMapper Fields TnxFmtBcdVclFieldMapper Methods TnxFmtBcdVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxFmtBcdVclFieldMappernxdbConversion_TnxFmtBcdVclFieldMappernxdbConversion_TnxFmtBcdVclFieldMappernxdbConversion_TnxFmtBcdVclFieldMapper
Syntax
Delphi
TnxFmtBcdVclFieldMapper = class(TnxInstantiatedVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxFmtBcdVclFieldMapper.

Group

Classes

Links
TnxFmtBcdVclFieldMapper Fields, TnxFmtBcdVclFieldMapper Methods, TnxFmtBcdVclFieldMapper Members, nxdbConversion, Classes


TnxFmtBcdVclFieldMapper Members

TnxFmtBcdVclFieldMapper Members
TnxFmtBcdVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFmtBcdVclFieldMapper.

Class

TnxFmtBcdVclFieldMapper Class

Protected Fields
Name | Description
fbfmDecimals | This is fbfmDecimals, a member of class TnxFmtBcdVclFieldMapper.
fbfmLength | This is fbfmLength, a member of class TnxFmtBcdVclFieldMapper.
fbfmPrecision | private
Protected Methods
Name | Description
GetNexusType |
GetVclSize |
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxFmtBcdVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxFmtBcdVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxFmtBcdVclFieldMapper.Create Constructor

TnxFmtBcdVclFieldMapper.Create Constructor
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Class Send Feedback
Syntax
Delphi
constructor Create(aFieldDescriptor: TnxFieldDescriptor); override;
Description

TnxFmtBcdVclFieldMapper

Class

TnxFmtBcdVclFieldMapper Class

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Class


TnxFmtBcdVclFieldMapper Fields

TnxFmtBcdVclFieldMapper Fields
TnxFmtBcdVclFieldMapper Class Legend Protected Fields Send Feedback

The fields of the TnxFmtBcdVclFieldMapper class are listed here.

Class

TnxFmtBcdVclFieldMapper Class

Protected Fields
Name | Description
fbfmDecimals | This is fbfmDecimals, a member of class TnxFmtBcdVclFieldMapper.
fbfmLength | This is fbfmLength, a member of class TnxFmtBcdVclFieldMapper.
fbfmPrecision | private
Links
TnxFmtBcdVclFieldMapper Class, Legend, Protected Fields


TnxFmtBcdVclFieldMapper.fbfmDecimals Field

TnxFmtBcdVclFieldMapper.fbfmDecimals Field
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
fbfmDecimals: Integer;
Description

This is fbfmDecimals, a member of class TnxFmtBcdVclFieldMapper.

Group

TnxFmtBcdVclFieldMapper Fields

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Fields


TnxFmtBcdVclFieldMapper.fbfmLength Field

TnxFmtBcdVclFieldMapper.fbfmLength Field
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
fbfmLength: Integer;
Description

This is fbfmLength, a member of class TnxFmtBcdVclFieldMapper.

Group

TnxFmtBcdVclFieldMapper Fields

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Fields


TnxFmtBcdVclFieldMapper.fbfmPrecision Field

TnxFmtBcdVclFieldMapper.fbfmPrecision Field
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Fields Send Feedback
Syntax
Delphi
fbfmPrecision: Integer;
Description

private

Group

TnxFmtBcdVclFieldMapper Fields

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Fields


TnxFmtBcdVclFieldMapper Methods

TnxFmtBcdVclFieldMapper Methods
TnxFmtBcdVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxFmtBcdVclFieldMapper class are listed here.

Class

TnxFmtBcdVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType |
GetVclType |
InternalAddDescriptorForFieldDef |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxFmtBcdVclFieldMapper Class, Legend, Protected Methods


TnxFmtBcdVclFieldMapper.GetNexusType Method

TnxFmtBcdVclFieldMapper.GetNexusType Method
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Group

TnxFmtBcdVclFieldMapper Methods

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Methods


TnxFmtBcdVclFieldMapper.GetVclType Method

TnxFmtBcdVclFieldMapper.GetVclType Method
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxFmtBcdVclFieldMapper Methods

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Methods


TnxFmtBcdVclFieldMapper.InternalAddDescriptorForFieldDef Method

TnxFmtBcdVclFieldMapper.InternalAddDescriptorForFieldDef Method
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalAddDescriptorForFieldDef(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDef: TFieldDef): TnxFieldDescriptor; override;
Group

TnxFmtBcdVclFieldMapper Methods

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Methods


TnxFmtBcdVclFieldMapper.MapNexusDataToVcl Method

TnxFmtBcdVclFieldMapper.MapNexusDataToVcl Method
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxFmtBcdVclFieldMapper Methods

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Methods


TnxFmtBcdVclFieldMapper.MapVclDataToNexus Method

TnxFmtBcdVclFieldMapper.MapVclDataToNexus Method
TnxFmtBcdVclFieldMapper Class TnxFmtBcdVclFieldMapper Members nxdbConversion Namespace TnxFmtBcdVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxFmtBcdVclFieldMapper Methods

Links
TnxFmtBcdVclFieldMapper Class, TnxFmtBcdVclFieldMapper Members, nxdbConversion Namespace, TnxFmtBcdVclFieldMapper Methods


TnxGraphicVclFieldMapper Class

TnxGraphicVclFieldMapper Class
TnxGraphicVclFieldMapper Methods TnxGraphicVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxGraphicVclFieldMappernxdbConversion_TnxGraphicVclFieldMappernxdbConversion_TnxGraphicVclFieldMappernxdbConversion_TnxGraphicVclFieldMappernxdbConversion_TnxGraphicVclFieldMappernxdbConversion_TnxGraphicVclFieldMapper
Syntax
Delphi
TnxGraphicVclFieldMapper = class(TnxBaseBlobVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxGraphicVclFieldMapper.

Group

Classes

Links
TnxGraphicVclFieldMapper Methods, TnxGraphicVclFieldMapper Members, nxdbConversion, Classes


TnxGraphicVclFieldMapper Members

TnxGraphicVclFieldMapper Members
TnxGraphicVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxGraphicVclFieldMapper.

Class

TnxGraphicVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxGraphicVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxGraphicVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxGraphicVclFieldMapper Methods

TnxGraphicVclFieldMapper Methods
TnxGraphicVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxGraphicVclFieldMapper class are listed here.

Class

TnxGraphicVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxGraphicVclFieldMapper
GetVclType |
Links
TnxGraphicVclFieldMapper Class, Legend, Protected Methods


TnxGraphicVclFieldMapper.GetNexusType Method

TnxGraphicVclFieldMapper.GetNexusType Method
TnxGraphicVclFieldMapper Class TnxGraphicVclFieldMapper Members nxdbConversion Namespace TnxGraphicVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxGraphicVclFieldMapper

Group

TnxGraphicVclFieldMapper Methods

Links
TnxGraphicVclFieldMapper Class, TnxGraphicVclFieldMapper Members, nxdbConversion Namespace, TnxGraphicVclFieldMapper Methods


TnxGraphicVclFieldMapper.GetVclType Method

TnxGraphicVclFieldMapper.GetVclType Method
TnxGraphicVclFieldMapper Class TnxGraphicVclFieldMapper Members nxdbConversion Namespace TnxGraphicVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxGraphicVclFieldMapper Methods

Links
TnxGraphicVclFieldMapper Class, TnxGraphicVclFieldMapper Members, nxdbConversion Namespace, TnxGraphicVclFieldMapper Methods


TnxGuidVclFieldMapper Class

TnxGuidVclFieldMapper Class
TnxGuidVclFieldMapper Methods TnxGuidVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxGuidVclFieldMappernxdbConversion_TnxGuidVclFieldMappernxdbConversion_TnxGuidVclFieldMappernxdbConversion_TnxGuidVclFieldMapper
Syntax
Delphi
TnxGuidVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxGuidVclFieldMapper.

Group

Classes

Links
TnxGuidVclFieldMapper Methods, TnxGuidVclFieldMapper Members, nxdbConversion, Classes


TnxGuidVclFieldMapper Members

TnxGuidVclFieldMapper Members
TnxGuidVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxGuidVclFieldMapper.

Class

TnxGuidVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxGuidVclFieldMapper
GetVclSize |
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxGuidVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxGuidVclFieldMapper Methods

TnxGuidVclFieldMapper Methods
TnxGuidVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxGuidVclFieldMapper class are listed here.

Class

TnxGuidVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxGuidVclFieldMapper
GetVclSize |
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxGuidVclFieldMapper Class, Legend, Protected Methods


TnxGuidVclFieldMapper.GetNexusType Method

TnxGuidVclFieldMapper.GetNexusType Method
TnxGuidVclFieldMapper Class TnxGuidVclFieldMapper Members nxdbConversion Namespace TnxGuidVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxGuidVclFieldMapper

Group

TnxGuidVclFieldMapper Methods

Links
TnxGuidVclFieldMapper Class, TnxGuidVclFieldMapper Members, nxdbConversion Namespace, TnxGuidVclFieldMapper Methods


TnxGuidVclFieldMapper.GetVclSize Method

TnxGuidVclFieldMapper.GetVclSize Method
TnxGuidVclFieldMapper Class TnxGuidVclFieldMapper Members nxdbConversion Namespace TnxGuidVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclSize: TnxWord16; override;
Group

TnxGuidVclFieldMapper Methods

Links
TnxGuidVclFieldMapper Class, TnxGuidVclFieldMapper Members, nxdbConversion Namespace, TnxGuidVclFieldMapper Methods


TnxGuidVclFieldMapper.GetVclType Method

TnxGuidVclFieldMapper.GetVclType Method
TnxGuidVclFieldMapper Class TnxGuidVclFieldMapper Members nxdbConversion Namespace TnxGuidVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxGuidVclFieldMapper Methods

Links
TnxGuidVclFieldMapper Class, TnxGuidVclFieldMapper Members, nxdbConversion Namespace, TnxGuidVclFieldMapper Methods


TnxGuidVclFieldMapper.MapNexusDataToVcl Method

TnxGuidVclFieldMapper.MapNexusDataToVcl Method
TnxGuidVclFieldMapper Class TnxGuidVclFieldMapper Members nxdbConversion Namespace TnxGuidVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxGuidVclFieldMapper Methods

Links
TnxGuidVclFieldMapper Class, TnxGuidVclFieldMapper Members, nxdbConversion Namespace, TnxGuidVclFieldMapper Methods


TnxGuidVclFieldMapper.MapVclDataToNexus Method

TnxGuidVclFieldMapper.MapVclDataToNexus Method
TnxGuidVclFieldMapper Class TnxGuidVclFieldMapper Members nxdbConversion Namespace TnxGuidVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxGuidVclFieldMapper Methods

Links
TnxGuidVclFieldMapper Class, TnxGuidVclFieldMapper Members, nxdbConversion Namespace, TnxGuidVclFieldMapper Methods


TnxInstantiatedVclFieldMapper Class

TnxInstantiatedVclFieldMapper Class
TnxInstantiatedVclFieldMapper Methods TnxInstantiatedVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxInstantiatedVclFieldMappernxdbConversion_TnxInstantiatedVclFieldMappernxdbConversion_TnxInstantiatedVclFieldMapper
Syntax
Delphi
TnxInstantiatedVclFieldMapper = class(TnxBaseVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxInstantiatedVclFieldMapper.

Group

Classes

Links
TnxInstantiatedVclFieldMapper Methods, TnxInstantiatedVclFieldMapper Members, nxdbConversion, Classes


TnxInstantiatedVclFieldMapper Members

TnxInstantiatedVclFieldMapper Members
TnxInstantiatedVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInstantiatedVclFieldMapper.

Class

TnxInstantiatedVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
GetVclSize |
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxInstantiatedVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxInstantiatedVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxInstantiatedVclFieldMapper.Create Constructor

TnxInstantiatedVclFieldMapper.Create Constructor
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Class Send Feedback
Syntax
Delphi
constructor Create(aFieldDescriptor: TnxFieldDescriptor); virtual;
Description

TnxInstantiatedVclFieldMapper

Class

TnxInstantiatedVclFieldMapper Class

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Class


TnxInstantiatedVclFieldMapper Methods

TnxInstantiatedVclFieldMapper Methods
TnxInstantiatedVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxInstantiatedVclFieldMapper class are listed here.

Class

TnxInstantiatedVclFieldMapper Class

Protected Methods
Name | Description
GetVclSize |
GetVclType | abstract;
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
Links
TnxInstantiatedVclFieldMapper Class, Legend, Protected Methods


TnxInstantiatedVclFieldMapper.GetVclSize Method

TnxInstantiatedVclFieldMapper.GetVclSize Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclSize: TnxWord16; virtual;
Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.GetVclType Method

TnxInstantiatedVclFieldMapper.GetVclType Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; virtual;
Description

abstract;

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.InternalGetMapperForDescriptor Method

TnxInstantiatedVclFieldMapper.InternalGetMapperForDescriptor Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; override;
Description

GetFieldData / SetFieldData

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxInstantiatedVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); override;
Description

InitFieldDefs

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.InternalMapNexusToParamType Method

TnxInstantiatedVclFieldMapper.InternalMapNexusToParamType Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalMapNexusToParamType(aNexusType: TnxFieldType): TFieldType; override;
Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method

TnxInstantiatedVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapParamTypeAndSizeToNexus(aParamType: TFieldType; aParamSize: Integer; out aNexusType: TnxFieldType; out aNexusSize: TnxWord32); override;
Description

TParam support

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.MapNexusDataToVcl Method

TnxInstantiatedVclFieldMapper.MapNexusDataToVcl Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); virtual;
Description

abstract;

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInstantiatedVclFieldMapper.MapVclDataToNexus Method

TnxInstantiatedVclFieldMapper.MapVclDataToNexus Method
TnxInstantiatedVclFieldMapper Class TnxInstantiatedVclFieldMapper Members nxdbConversion Namespace TnxInstantiatedVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); virtual;
Description

abstract;

Group

TnxInstantiatedVclFieldMapper Methods

Links
TnxInstantiatedVclFieldMapper Class, TnxInstantiatedVclFieldMapper Members, nxdbConversion Namespace, TnxInstantiatedVclFieldMapper Methods


TnxInt16VclFieldMapper Class

TnxInt16VclFieldMapper Class
TnxInt16VclFieldMapper Methods TnxInt16VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxInt16VclFieldMappernxdbConversion_TnxInt16VclFieldMappernxdbConversion_TnxInt16VclFieldMappernxdbConversion_TnxInt16VclFieldMapper
Syntax
Delphi
TnxInt16VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxInt16VclFieldMapper.

Group

Classes

Links
TnxInt16VclFieldMapper Methods, TnxInt16VclFieldMapper Members, nxdbConversion, Classes


TnxInt16VclFieldMapper Members

TnxInt16VclFieldMapper Members
TnxInt16VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt16VclFieldMapper.

Class

TnxInt16VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt16VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxInt16VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxInt16VclFieldMapper Methods

TnxInt16VclFieldMapper Methods
TnxInt16VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt16VclFieldMapper class are listed here.

Class

TnxInt16VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt16VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxInt16VclFieldMapper Class, Legend, Protected Methods


TnxInt16VclFieldMapper.GetNexusType Method

TnxInt16VclFieldMapper.GetNexusType Method
TnxInt16VclFieldMapper Class TnxInt16VclFieldMapper Members nxdbConversion Namespace TnxInt16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxInt16VclFieldMapper

Group

TnxInt16VclFieldMapper Methods

Links
TnxInt16VclFieldMapper Class, TnxInt16VclFieldMapper Members, nxdbConversion Namespace, TnxInt16VclFieldMapper Methods


TnxInt16VclFieldMapper.GetVclType Method

TnxInt16VclFieldMapper.GetVclType Method
TnxInt16VclFieldMapper Class TnxInt16VclFieldMapper Members nxdbConversion Namespace TnxInt16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxInt16VclFieldMapper Methods

Links
TnxInt16VclFieldMapper Class, TnxInt16VclFieldMapper Members, nxdbConversion Namespace, TnxInt16VclFieldMapper Methods


TnxInt16VclFieldMapper.MapNexusDataToVcl Method

TnxInt16VclFieldMapper.MapNexusDataToVcl Method
TnxInt16VclFieldMapper Class TnxInt16VclFieldMapper Members nxdbConversion Namespace TnxInt16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxInt16VclFieldMapper Methods

Links
TnxInt16VclFieldMapper Class, TnxInt16VclFieldMapper Members, nxdbConversion Namespace, TnxInt16VclFieldMapper Methods


TnxInt16VclFieldMapper.MapVclDataToNexus Method

TnxInt16VclFieldMapper.MapVclDataToNexus Method
TnxInt16VclFieldMapper Class TnxInt16VclFieldMapper Members nxdbConversion Namespace TnxInt16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxInt16VclFieldMapper Methods

Links
TnxInt16VclFieldMapper Class, TnxInt16VclFieldMapper Members, nxdbConversion Namespace, TnxInt16VclFieldMapper Methods


TnxInt32VclFieldMapper Class

TnxInt32VclFieldMapper Class
TnxInt32VclFieldMapper Methods TnxInt32VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxInt32VclFieldMappernxdbConversion_TnxInt32VclFieldMappernxdbConversion_TnxInt32VclFieldMappernxdbConversion_TnxInt32VclFieldMapper
Syntax
Delphi
TnxInt32VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxInt32VclFieldMapper.

Group

Classes

Links
TnxInt32VclFieldMapper Methods, TnxInt32VclFieldMapper Members, nxdbConversion, Classes


TnxInt32VclFieldMapper Members

TnxInt32VclFieldMapper Members
TnxInt32VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt32VclFieldMapper.

Class

TnxInt32VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt32VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxInt32VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxInt32VclFieldMapper Methods

TnxInt32VclFieldMapper Methods
TnxInt32VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt32VclFieldMapper class are listed here.

Class

TnxInt32VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt32VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxInt32VclFieldMapper Class, Legend, Protected Methods


TnxInt32VclFieldMapper.GetNexusType Method

TnxInt32VclFieldMapper.GetNexusType Method
TnxInt32VclFieldMapper Class TnxInt32VclFieldMapper Members nxdbConversion Namespace TnxInt32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxInt32VclFieldMapper

Group

TnxInt32VclFieldMapper Methods

Links
TnxInt32VclFieldMapper Class, TnxInt32VclFieldMapper Members, nxdbConversion Namespace, TnxInt32VclFieldMapper Methods


TnxInt32VclFieldMapper.GetVclType Method

TnxInt32VclFieldMapper.GetVclType Method
TnxInt32VclFieldMapper Class TnxInt32VclFieldMapper Members nxdbConversion Namespace TnxInt32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxInt32VclFieldMapper Methods

Links
TnxInt32VclFieldMapper Class, TnxInt32VclFieldMapper Members, nxdbConversion Namespace, TnxInt32VclFieldMapper Methods


TnxInt32VclFieldMapper.MapNexusDataToVcl Method

TnxInt32VclFieldMapper.MapNexusDataToVcl Method
TnxInt32VclFieldMapper Class TnxInt32VclFieldMapper Members nxdbConversion Namespace TnxInt32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxInt32VclFieldMapper Methods

Links
TnxInt32VclFieldMapper Class, TnxInt32VclFieldMapper Members, nxdbConversion Namespace, TnxInt32VclFieldMapper Methods


TnxInt32VclFieldMapper.MapVclDataToNexus Method

TnxInt32VclFieldMapper.MapVclDataToNexus Method
TnxInt32VclFieldMapper Class TnxInt32VclFieldMapper Members nxdbConversion Namespace TnxInt32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxInt32VclFieldMapper Methods

Links
TnxInt32VclFieldMapper Class, TnxInt32VclFieldMapper Members, nxdbConversion Namespace, TnxInt32VclFieldMapper Methods


TnxInt64VclFieldMapper Class

TnxInt64VclFieldMapper Class
TnxInt64VclFieldMapper Methods TnxInt64VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxInt64VclFieldMappernxdbConversion_TnxInt64VclFieldMappernxdbConversion_TnxInt64VclFieldMappernxdbConversion_TnxInt64VclFieldMapper
Syntax
Delphi
TnxInt64VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxInt64VclFieldMapper.

Group

Classes

Links
TnxInt64VclFieldMapper Methods, TnxInt64VclFieldMapper Members, nxdbConversion, Classes


TnxInt64VclFieldMapper Members

TnxInt64VclFieldMapper Members
TnxInt64VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt64VclFieldMapper.

Class

TnxInt64VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt64VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxInt64VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxInt64VclFieldMapper Methods

TnxInt64VclFieldMapper Methods
TnxInt64VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt64VclFieldMapper class are listed here.

Class

TnxInt64VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt64VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxInt64VclFieldMapper Class, Legend, Protected Methods


TnxInt64VclFieldMapper.GetNexusType Method

TnxInt64VclFieldMapper.GetNexusType Method
TnxInt64VclFieldMapper Class TnxInt64VclFieldMapper Members nxdbConversion Namespace TnxInt64VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxInt64VclFieldMapper

Group

TnxInt64VclFieldMapper Methods

Links
TnxInt64VclFieldMapper Class, TnxInt64VclFieldMapper Members, nxdbConversion Namespace, TnxInt64VclFieldMapper Methods


TnxInt64VclFieldMapper.GetVclType Method

TnxInt64VclFieldMapper.GetVclType Method
TnxInt64VclFieldMapper Class TnxInt64VclFieldMapper Members nxdbConversion Namespace TnxInt64VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxInt64VclFieldMapper Methods

Links
TnxInt64VclFieldMapper Class, TnxInt64VclFieldMapper Members, nxdbConversion Namespace, TnxInt64VclFieldMapper Methods


TnxInt64VclFieldMapper.MapNexusDataToVcl Method

TnxInt64VclFieldMapper.MapNexusDataToVcl Method
TnxInt64VclFieldMapper Class TnxInt64VclFieldMapper Members nxdbConversion Namespace TnxInt64VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxInt64VclFieldMapper Methods

Links
TnxInt64VclFieldMapper Class, TnxInt64VclFieldMapper Members, nxdbConversion Namespace, TnxInt64VclFieldMapper Methods


TnxInt64VclFieldMapper.MapVclDataToNexus Method

TnxInt64VclFieldMapper.MapVclDataToNexus Method
TnxInt64VclFieldMapper Class TnxInt64VclFieldMapper Members nxdbConversion Namespace TnxInt64VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxInt64VclFieldMapper Methods

Links
TnxInt64VclFieldMapper Class, TnxInt64VclFieldMapper Members, nxdbConversion Namespace, TnxInt64VclFieldMapper Methods


TnxInt8VclFieldMapper Class

TnxInt8VclFieldMapper Class
TnxInt8VclFieldMapper Methods TnxInt8VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxInt8VclFieldMappernxdbConversion_TnxInt8VclFieldMappernxdbConversion_TnxInt8VclFieldMappernxdbConversion_TnxInt8VclFieldMapper
Syntax
Delphi
TnxInt8VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxInt8VclFieldMapper.

Group

Classes

Links
TnxInt8VclFieldMapper Methods, TnxInt8VclFieldMapper Members, nxdbConversion, Classes


TnxInt8VclFieldMapper Members

TnxInt8VclFieldMapper Members
TnxInt8VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt8VclFieldMapper.

Class

TnxInt8VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt8VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxInt8VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxInt8VclFieldMapper Methods

TnxInt8VclFieldMapper Methods
TnxInt8VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt8VclFieldMapper class are listed here.

Class

TnxInt8VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxInt8VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxInt8VclFieldMapper Class, Legend, Protected Methods


TnxInt8VclFieldMapper.GetNexusType Method

TnxInt8VclFieldMapper.GetNexusType Method
TnxInt8VclFieldMapper Class TnxInt8VclFieldMapper Members nxdbConversion Namespace TnxInt8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxInt8VclFieldMapper

Group

TnxInt8VclFieldMapper Methods

Links
TnxInt8VclFieldMapper Class, TnxInt8VclFieldMapper Members, nxdbConversion Namespace, TnxInt8VclFieldMapper Methods


TnxInt8VclFieldMapper.GetVclType Method

TnxInt8VclFieldMapper.GetVclType Method
TnxInt8VclFieldMapper Class TnxInt8VclFieldMapper Members nxdbConversion Namespace TnxInt8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxInt8VclFieldMapper Methods

Links
TnxInt8VclFieldMapper Class, TnxInt8VclFieldMapper Members, nxdbConversion Namespace, TnxInt8VclFieldMapper Methods


TnxInt8VclFieldMapper.MapNexusDataToVcl Method

TnxInt8VclFieldMapper.MapNexusDataToVcl Method
TnxInt8VclFieldMapper Class TnxInt8VclFieldMapper Members nxdbConversion Namespace TnxInt8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxInt8VclFieldMapper Methods

Links
TnxInt8VclFieldMapper Class, TnxInt8VclFieldMapper Members, nxdbConversion Namespace, TnxInt8VclFieldMapper Methods


TnxInt8VclFieldMapper.MapVclDataToNexus Method

TnxInt8VclFieldMapper.MapVclDataToNexus Method
TnxInt8VclFieldMapper Class TnxInt8VclFieldMapper Members nxdbConversion Namespace TnxInt8VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxInt8VclFieldMapper Methods

Links
TnxInt8VclFieldMapper Class, TnxInt8VclFieldMapper Members, nxdbConversion Namespace, TnxInt8VclFieldMapper Methods


TnxIntervalVclFieldMapper Class

TnxIntervalVclFieldMapper Class
TnxIntervalVclFieldMapper Methods TnxIntervalVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxIntervalVclFieldMappernxdbConversion_TnxIntervalVclFieldMappernxdbConversion_TnxIntervalVclFieldMappernxdbConversion_TnxIntervalVclFieldMappernxdbConversion_TnxIntervalVclFieldMapper
Syntax
Delphi
TnxIntervalVclFieldMapper = class(TnxBaseDateTimeVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxIntervalVclFieldMapper.

Group

Classes

Links
TnxIntervalVclFieldMapper Methods, TnxIntervalVclFieldMapper Members, nxdbConversion, Classes


TnxIntervalVclFieldMapper Members

TnxIntervalVclFieldMapper Members
TnxIntervalVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxIntervalVclFieldMapper.

Class

TnxIntervalVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxIntervalVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseDateTimeVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxIntervalVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxIntervalVclFieldMapper Methods

TnxIntervalVclFieldMapper Methods
TnxIntervalVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxIntervalVclFieldMapper class are listed here.

Class

TnxIntervalVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxIntervalVclFieldMapper
Links
TnxIntervalVclFieldMapper Class, Legend, Protected Methods


TnxIntervalVclFieldMapper.GetNexusType Method

TnxIntervalVclFieldMapper.GetNexusType Method
TnxIntervalVclFieldMapper Class TnxIntervalVclFieldMapper Members nxdbConversion Namespace TnxIntervalVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxIntervalVclFieldMapper

Group

TnxIntervalVclFieldMapper Methods

Links
TnxIntervalVclFieldMapper Class, TnxIntervalVclFieldMapper Members, nxdbConversion Namespace, TnxIntervalVclFieldMapper Methods


TnxMemoVclFieldMapper Class

TnxMemoVclFieldMapper Class
TnxMemoVclFieldMapper Methods TnxMemoVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxMemoVclFieldMappernxdbConversion_TnxMemoVclFieldMappernxdbConversion_TnxMemoVclFieldMappernxdbConversion_TnxMemoVclFieldMappernxdbConversion_TnxMemoVclFieldMappernxdbConversion_TnxMemoVclFieldMapper
Syntax
Delphi
TnxMemoVclFieldMapper = class(TnxBaseBlobVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxMemoVclFieldMapper.

Group

Classes

Links
TnxMemoVclFieldMapper Methods, TnxMemoVclFieldMapper Members, nxdbConversion, Classes


TnxMemoVclFieldMapper Members

TnxMemoVclFieldMapper Members
TnxMemoVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMemoVclFieldMapper.

Class

TnxMemoVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxMemoVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxMemoVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxMemoVclFieldMapper Methods

TnxMemoVclFieldMapper Methods
TnxMemoVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxMemoVclFieldMapper class are listed here.

Class

TnxMemoVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxMemoVclFieldMapper
GetVclType |
Links
TnxMemoVclFieldMapper Class, Legend, Protected Methods


TnxMemoVclFieldMapper.GetNexusType Method

TnxMemoVclFieldMapper.GetNexusType Method
TnxMemoVclFieldMapper Class TnxMemoVclFieldMapper Members nxdbConversion Namespace TnxMemoVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxMemoVclFieldMapper

Group

TnxMemoVclFieldMapper Methods

Links
TnxMemoVclFieldMapper Class, TnxMemoVclFieldMapper Members, nxdbConversion Namespace, TnxMemoVclFieldMapper Methods


TnxMemoVclFieldMapper.GetVclType Method

TnxMemoVclFieldMapper.GetVclType Method
TnxMemoVclFieldMapper Class TnxMemoVclFieldMapper Members nxdbConversion Namespace TnxMemoVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxMemoVclFieldMapper Methods

Links
TnxMemoVclFieldMapper Class, TnxMemoVclFieldMapper Members, nxdbConversion Namespace, TnxMemoVclFieldMapper Methods


TnxNullStringVclFieldMapper Class

TnxNullStringVclFieldMapper Class
TnxNullStringVclFieldMapper Methods TnxNullStringVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxNullStringVclFieldMappernxdbConversion_TnxNullStringVclFieldMappernxdbConversion_TnxNullStringVclFieldMappernxdbConversion_TnxNullStringVclFieldMappernxdbConversion_TnxNullStringVclFieldMappernxdbConversion_TnxNullStringVclFieldMapper
Syntax
Delphi
TnxNullStringVclFieldMapper = class(TnxBaseStringVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxNullStringVclFieldMapper.

Group

Classes

Links
TnxNullStringVclFieldMapper Methods, TnxNullStringVclFieldMapper Members, nxdbConversion, Classes


TnxNullStringVclFieldMapper Members

TnxNullStringVclFieldMapper Members
TnxNullStringVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNullStringVclFieldMapper.

Class

TnxNullStringVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
bsvfmField | private
bsvfmStorageCodepage | This is bsvfmStorageCodepage, a member of class TnxBaseStringVclFieldMapper.
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | TnxNullStringVclFieldMapper
GetUnitsFromParamSize |
GetUnitsFromParamSize | abstract;
GetVclType |
GetVclType | abstract;
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind | TnxBaseStringVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxNullStringVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNullStringVclFieldMapper Methods

TnxNullStringVclFieldMapper Methods
TnxNullStringVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxNullStringVclFieldMapper class are listed here.

Class

TnxNullStringVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxNullStringVclFieldMapper
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
Links
TnxNullStringVclFieldMapper Class, Legend, Protected Methods


TnxNullStringVclFieldMapper.GetNexusType Method

TnxNullStringVclFieldMapper.GetNexusType Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxNullStringVclFieldMapper

Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapNexusDataToVcl Method

TnxNullStringVclFieldMapper.MapNexusDataToVcl Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapNexusDataToVclPadded Method

TnxNullStringVclFieldMapper.MapNexusDataToVclPadded Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclPadded(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapNexusDataToVclTranslate Method

TnxNullStringVclFieldMapper.MapNexusDataToVclTranslate Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslate(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method

TnxNullStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslatePadded(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapVclDataToNexus Method

TnxNullStringVclFieldMapper.MapVclDataToNexus Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapVclDataToNexusPadded Method

TnxNullStringVclFieldMapper.MapVclDataToNexusPadded Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusPadded(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapVclDataToNexusTranslate Method

TnxNullStringVclFieldMapper.MapVclDataToNexusTranslate Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslate(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxNullStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method

TnxNullStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method
TnxNullStringVclFieldMapper Class TnxNullStringVclFieldMapper Members nxdbConversion Namespace TnxNullStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslatePadded(const aFrom; out aTo); override;
Group

TnxNullStringVclFieldMapper Methods

Links
TnxNullStringVclFieldMapper Class, TnxNullStringVclFieldMapper Members, nxdbConversion Namespace, TnxNullStringVclFieldMapper Methods


TnxRecRevVclFieldMapper Class

TnxRecRevVclFieldMapper Class
TnxRecRevVclFieldMapper Methods TnxRecRevVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxRecRevVclFieldMappernxdbConversion_TnxRecRevVclFieldMappernxdbConversion_TnxRecRevVclFieldMappernxdbConversion_TnxRecRevVclFieldMappernxdbConversion_TnxRecRevVclFieldMapper
Syntax
Delphi
TnxRecRevVclFieldMapper = class(TnxWord32VclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxRecRevVclFieldMapper.

Group

Classes

Links
TnxRecRevVclFieldMapper Methods, TnxRecRevVclFieldMapper Members, nxdbConversion, Classes


TnxRecRevVclFieldMapper Members

TnxRecRevVclFieldMapper Members
TnxRecRevVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRecRevVclFieldMapper.

Class

TnxRecRevVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxRecRevVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType | abstract;
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxRecRevVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxRecRevVclFieldMapper Methods

TnxRecRevVclFieldMapper Methods
TnxRecRevVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxRecRevVclFieldMapper class are listed here.

Class

TnxRecRevVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxRecRevVclFieldMapper
InternalMapNexusDescriptorToVcl | InitFieldDefs
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxRecRevVclFieldMapper Class, Legend, Protected Methods


TnxRecRevVclFieldMapper.GetNexusType Method

TnxRecRevVclFieldMapper.GetNexusType Method
TnxRecRevVclFieldMapper Class TnxRecRevVclFieldMapper Members nxdbConversion Namespace TnxRecRevVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxRecRevVclFieldMapper

Group

TnxRecRevVclFieldMapper Methods

Links
TnxRecRevVclFieldMapper Class, TnxRecRevVclFieldMapper Members, nxdbConversion Namespace, TnxRecRevVclFieldMapper Methods


TnxRecRevVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxRecRevVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxRecRevVclFieldMapper Class TnxRecRevVclFieldMapper Members nxdbConversion Namespace TnxRecRevVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); override;
Description

InitFieldDefs

Group

TnxRecRevVclFieldMapper Methods

Links
TnxRecRevVclFieldMapper Class, TnxRecRevVclFieldMapper Members, nxdbConversion Namespace, TnxRecRevVclFieldMapper Methods


TnxRecRevVclFieldMapper.MapNexusDataToVcl Method

TnxRecRevVclFieldMapper.MapNexusDataToVcl Method
TnxRecRevVclFieldMapper Class TnxRecRevVclFieldMapper Members nxdbConversion Namespace TnxRecRevVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); static;
Group

TnxRecRevVclFieldMapper Methods

Links
TnxRecRevVclFieldMapper Class, TnxRecRevVclFieldMapper Members, nxdbConversion Namespace, TnxRecRevVclFieldMapper Methods


TnxRecRevVclFieldMapper.MapVclDataToNexus Method

TnxRecRevVclFieldMapper.MapVclDataToNexus Method
TnxRecRevVclFieldMapper Class TnxRecRevVclFieldMapper Members nxdbConversion Namespace TnxRecRevVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxRecRevVclFieldMapper Methods

Links
TnxRecRevVclFieldMapper Class, TnxRecRevVclFieldMapper Members, nxdbConversion Namespace, TnxRecRevVclFieldMapper Methods


TnxShortStringVclFieldMapper Class

TnxShortStringVclFieldMapper Class
TnxShortStringVclFieldMapper Methods TnxShortStringVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxShortStringVclFieldMappernxdbConversion_TnxShortStringVclFieldMappernxdbConversion_TnxShortStringVclFieldMappernxdbConversion_TnxShortStringVclFieldMappernxdbConversion_TnxShortStringVclFieldMappernxdbConversion_TnxShortStringVclFieldMapper
Syntax
Delphi
TnxShortStringVclFieldMapper = class(TnxBaseStringVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxShortStringVclFieldMapper.

Group

Classes

Links
TnxShortStringVclFieldMapper Methods, TnxShortStringVclFieldMapper Members, nxdbConversion, Classes


TnxShortStringVclFieldMapper Members

TnxShortStringVclFieldMapper Members
TnxShortStringVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxShortStringVclFieldMapper.

Class

TnxShortStringVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
bsvfmField | private
bsvfmStorageCodepage | This is bsvfmStorageCodepage, a member of class TnxBaseStringVclFieldMapper.
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | TnxShortStringVclFieldMapper
GetUnitsFromParamSize |
GetUnitsFromParamSize | abstract;
GetVclType |
GetVclType | abstract;
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind | TnxBaseStringVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxShortStringVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxShortStringVclFieldMapper Methods

TnxShortStringVclFieldMapper Methods
TnxShortStringVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxShortStringVclFieldMapper class are listed here.

Class

TnxShortStringVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxShortStringVclFieldMapper
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapNexusDataToVclTranslate |
MapNexusDataToVclTranslatePadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
MapVclDataToNexusTranslate |
MapVclDataToNexusTranslatePadded |
Links
TnxShortStringVclFieldMapper Class, Legend, Protected Methods


TnxShortStringVclFieldMapper.GetNexusType Method

TnxShortStringVclFieldMapper.GetNexusType Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxShortStringVclFieldMapper

Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapNexusDataToVcl Method

TnxShortStringVclFieldMapper.MapNexusDataToVcl Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapNexusDataToVclPadded Method

TnxShortStringVclFieldMapper.MapNexusDataToVclPadded Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclPadded(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapNexusDataToVclTranslate Method

TnxShortStringVclFieldMapper.MapNexusDataToVclTranslate Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslate(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method

TnxShortStringVclFieldMapper.MapNexusDataToVclTranslatePadded Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclTranslatePadded(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapVclDataToNexus Method

TnxShortStringVclFieldMapper.MapVclDataToNexus Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapVclDataToNexusPadded Method

TnxShortStringVclFieldMapper.MapVclDataToNexusPadded Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusPadded(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapVclDataToNexusTranslate Method

TnxShortStringVclFieldMapper.MapVclDataToNexusTranslate Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslate(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxShortStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method

TnxShortStringVclFieldMapper.MapVclDataToNexusTranslatePadded Method
TnxShortStringVclFieldMapper Class TnxShortStringVclFieldMapper Members nxdbConversion Namespace TnxShortStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusTranslatePadded(const aFrom; out aTo); override;
Group

TnxShortStringVclFieldMapper Methods

Links
TnxShortStringVclFieldMapper Class, TnxShortStringVclFieldMapper Members, nxdbConversion Namespace, TnxShortStringVclFieldMapper Methods


TnxSingleVclFieldMapper Class

TnxSingleVclFieldMapper Class
TnxSingleVclFieldMapper Methods TnxSingleVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxSingleVclFieldMappernxdbConversion_TnxSingleVclFieldMappernxdbConversion_TnxSingleVclFieldMappernxdbConversion_TnxSingleVclFieldMappernxdbConversion_TnxSingleVclFieldMapper
Syntax
Delphi
TnxSingleVclFieldMapper = class(TnxBaseFloatVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxSingleVclFieldMapper.

Group

Classes

Links
TnxSingleVclFieldMapper Methods, TnxSingleVclFieldMapper Members, nxdbConversion, Classes


TnxSingleVclFieldMapper Members

TnxSingleVclFieldMapper Members
TnxSingleVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSingleVclFieldMapper.

Class

TnxSingleVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxSingleVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType | TnxBaseFloatVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxSingleVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxSingleVclFieldMapper Methods

TnxSingleVclFieldMapper Methods
TnxSingleVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxSingleVclFieldMapper class are listed here.

Class

TnxSingleVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxSingleVclFieldMapper
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxSingleVclFieldMapper Class, Legend, Protected Methods


TnxSingleVclFieldMapper.GetNexusType Method

TnxSingleVclFieldMapper.GetNexusType Method
TnxSingleVclFieldMapper Class TnxSingleVclFieldMapper Members nxdbConversion Namespace TnxSingleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxSingleVclFieldMapper

Group

TnxSingleVclFieldMapper Methods

Links
TnxSingleVclFieldMapper Class, TnxSingleVclFieldMapper Members, nxdbConversion Namespace, TnxSingleVclFieldMapper Methods


TnxSingleVclFieldMapper.MapNexusDataToVcl Method

TnxSingleVclFieldMapper.MapNexusDataToVcl Method
TnxSingleVclFieldMapper Class TnxSingleVclFieldMapper Members nxdbConversion Namespace TnxSingleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxSingleVclFieldMapper Methods

Links
TnxSingleVclFieldMapper Class, TnxSingleVclFieldMapper Members, nxdbConversion Namespace, TnxSingleVclFieldMapper Methods


TnxSingleVclFieldMapper.MapVclDataToNexus Method

TnxSingleVclFieldMapper.MapVclDataToNexus Method
TnxSingleVclFieldMapper Class TnxSingleVclFieldMapper Members nxdbConversion Namespace TnxSingleVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxSingleVclFieldMapper Methods

Links
TnxSingleVclFieldMapper Class, TnxSingleVclFieldMapper Members, nxdbConversion Namespace, TnxSingleVclFieldMapper Methods


TnxStaticVclFieldMapper Class

TnxStaticVclFieldMapper Class
TnxStaticVclFieldMapper Methods TnxStaticVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxStaticVclFieldMappernxdbConversion_TnxStaticVclFieldMappernxdbConversion_TnxStaticVclFieldMapper
Syntax
Delphi
TnxStaticVclFieldMapper = class(TnxBaseVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxStaticVclFieldMapper.

Group

Classes

Links
TnxStaticVclFieldMapper Methods, TnxStaticVclFieldMapper Members, nxdbConversion, Classes


TnxStaticVclFieldMapper Members

TnxStaticVclFieldMapper Members
TnxStaticVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxStaticVclFieldMapper.

Class

TnxStaticVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | abstract;
GetVclSize | TnxStaticVclFieldMapper
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxStaticVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxStaticVclFieldMapper Methods

TnxStaticVclFieldMapper Methods
TnxStaticVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxStaticVclFieldMapper class are listed here.

Class

TnxStaticVclFieldMapper Class

Protected Methods
Name | Description
GetVclSize | TnxStaticVclFieldMapper
GetVclType | abstract;
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | abstract;
MapVclDataToNexus | abstract;
Links
TnxStaticVclFieldMapper Class, Legend, Protected Methods


TnxStaticVclFieldMapper.GetVclSize Method

TnxStaticVclFieldMapper.GetVclSize Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclSize: TnxWord16; virtual;
Description

TnxStaticVclFieldMapper

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.GetVclType Method

TnxStaticVclFieldMapper.GetVclType Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; virtual;
Description

abstract;

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.InternalGetMapperForDescriptor Method

TnxStaticVclFieldMapper.InternalGetMapperForDescriptor Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; override;
Description

GetFieldData / SetFieldData

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxStaticVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); override;
Description

InitFieldDefs

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.InternalMapNexusToParamType Method

TnxStaticVclFieldMapper.InternalMapNexusToParamType Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalMapNexusToParamType(aNexusType: TnxFieldType): TFieldType; override;
Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method

TnxStaticVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapParamTypeAndSizeToNexus(aParamType: TFieldType; aParamSize: Integer; out aNexusType: TnxFieldType; out aNexusSize: TnxWord32); override;
Description

TParam support

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.MapNexusDataToVcl Method

TnxStaticVclFieldMapper.MapNexusDataToVcl Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); virtual;
Description

abstract;

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxStaticVclFieldMapper.MapVclDataToNexus Method

TnxStaticVclFieldMapper.MapVclDataToNexus Method
TnxStaticVclFieldMapper Class TnxStaticVclFieldMapper Members nxdbConversion Namespace TnxStaticVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); virtual;
Description

abstract;

Group

TnxStaticVclFieldMapper Methods

Links
TnxStaticVclFieldMapper Class, TnxStaticVclFieldMapper Members, nxdbConversion Namespace, TnxStaticVclFieldMapper Methods


TnxTimeVclFieldMapper Class

TnxTimeVclFieldMapper Class
TnxTimeVclFieldMapper Methods TnxTimeVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxTimeVclFieldMappernxdbConversion_TnxTimeVclFieldMappernxdbConversion_TnxTimeVclFieldMappernxdbConversion_TnxTimeVclFieldMapper
Syntax
Delphi
TnxTimeVclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxTimeVclFieldMapper.

Group

Classes

Links
TnxTimeVclFieldMapper Methods, TnxTimeVclFieldMapper Members, nxdbConversion, Classes


TnxTimeVclFieldMapper Members

TnxTimeVclFieldMapper Members
TnxTimeVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTimeVclFieldMapper.

Class

TnxTimeVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxTimeVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxTimeVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxTimeVclFieldMapper Methods

TnxTimeVclFieldMapper Methods
TnxTimeVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxTimeVclFieldMapper class are listed here.

Class

TnxTimeVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxTimeVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxTimeVclFieldMapper Class, Legend, Protected Methods


TnxTimeVclFieldMapper.GetNexusType Method

TnxTimeVclFieldMapper.GetNexusType Method
TnxTimeVclFieldMapper Class TnxTimeVclFieldMapper Members nxdbConversion Namespace TnxTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxTimeVclFieldMapper

Group

TnxTimeVclFieldMapper Methods

Links
TnxTimeVclFieldMapper Class, TnxTimeVclFieldMapper Members, nxdbConversion Namespace, TnxTimeVclFieldMapper Methods


TnxTimeVclFieldMapper.GetVclType Method

TnxTimeVclFieldMapper.GetVclType Method
TnxTimeVclFieldMapper Class TnxTimeVclFieldMapper Members nxdbConversion Namespace TnxTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxTimeVclFieldMapper Methods

Links
TnxTimeVclFieldMapper Class, TnxTimeVclFieldMapper Members, nxdbConversion Namespace, TnxTimeVclFieldMapper Methods


TnxTimeVclFieldMapper.MapNexusDataToVcl Method

TnxTimeVclFieldMapper.MapNexusDataToVcl Method
TnxTimeVclFieldMapper Class TnxTimeVclFieldMapper Members nxdbConversion Namespace TnxTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxTimeVclFieldMapper Methods

Links
TnxTimeVclFieldMapper Class, TnxTimeVclFieldMapper Members, nxdbConversion Namespace, TnxTimeVclFieldMapper Methods


TnxTimeVclFieldMapper.MapVclDataToNexus Method

TnxTimeVclFieldMapper.MapVclDataToNexus Method
TnxTimeVclFieldMapper Class TnxTimeVclFieldMapper Members nxdbConversion Namespace TnxTimeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxTimeVclFieldMapper Methods

Links
TnxTimeVclFieldMapper Class, TnxTimeVclFieldMapper Members, nxdbConversion Namespace, TnxTimeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper Class

TnxVariableSizeVclFieldMapper Class
TnxVariableSizeVclFieldMapper Fields TnxVariableSizeVclFieldMapper Methods TnxVariableSizeVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxVariableSizeVclFieldMappernxdbConversion_TnxVariableSizeVclFieldMappernxdbConversion_TnxVariableSizeVclFieldMapper
Syntax
Delphi
TnxVariableSizeVclFieldMapper = class(TnxBaseVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxVariableSizeVclFieldMapper.

Group

Classes

Links
TnxVariableSizeVclFieldMapper Fields, TnxVariableSizeVclFieldMapper Methods, TnxVariableSizeVclFieldMapper Members, nxdbConversion, Classes


TnxVariableSizeVclFieldMapper Members

TnxVariableSizeVclFieldMapper Members
TnxVariableSizeVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxVariableSizeVclFieldMapper.

Class

TnxVariableSizeVclFieldMapper Class

Protected Fields
Name | Description
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | abstract;
GetUnitsFromParamSize | abstract;
GetVclType | abstract;
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | This is MapNexusDataToVcl, a member of class TnxVariableSizeVclFieldMapper.
MapVclDataToNexus | This is MapVclDataToNexus, a member of class TnxVariableSizeVclFieldMapper.
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxVariableSizeVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxVariableSizeVclFieldMapper.Create Constructor

TnxVariableSizeVclFieldMapper.Create Constructor
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Class Send Feedback
Syntax
Delphi
constructor Create(aUnits: Integer); virtual;
Description

TnxVariableSizeVclFieldMapper

Class

TnxVariableSizeVclFieldMapper Class

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Class


TnxVariableSizeVclFieldMapper Fields

TnxVariableSizeVclFieldMapper Fields
TnxVariableSizeVclFieldMapper Class Legend Protected Fields Send Feedback

The fields of the TnxVariableSizeVclFieldMapper class are listed here.

Class

TnxVariableSizeVclFieldMapper Class

Protected Fields
Name | Description
vsvfmUnits | private
Links
TnxVariableSizeVclFieldMapper Class, Legend, Protected Fields


TnxVariableSizeVclFieldMapper.vsvfmUnits Field

TnxVariableSizeVclFieldMapper.vsvfmUnits Field
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Fields Send Feedback
Syntax
Delphi
vsvfmUnits: Integer;
Description

private

Group

TnxVariableSizeVclFieldMapper Fields

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Fields


TnxVariableSizeVclFieldMapper Methods

TnxVariableSizeVclFieldMapper Methods
TnxVariableSizeVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxVariableSizeVclFieldMapper class are listed here.

Class

TnxVariableSizeVclFieldMapper Class

Protected Methods
Name | Description
GetUnitsFromParamSize | abstract;
GetVclType | abstract;
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl | This is MapNexusDataToVcl, a member of class TnxVariableSizeVclFieldMapper.
MapVclDataToNexus | This is MapVclDataToNexus, a member of class TnxVariableSizeVclFieldMapper.
Links
TnxVariableSizeVclFieldMapper Class, Legend, Protected Methods


TnxVariableSizeVclFieldMapper.GetUnitsFromParamSize Method

TnxVariableSizeVclFieldMapper.GetUnitsFromParamSize Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetUnitsFromParamSize(aParamSize: Integer): Integer; virtual;
Description

abstract;

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.GetVclType Method

TnxVariableSizeVclFieldMapper.GetVclType Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; virtual;
Description

abstract;

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.InternalGetMapperForDescriptor Method

TnxVariableSizeVclFieldMapper.InternalGetMapperForDescriptor Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalGetMapperForDescriptor(aFieldDescriptor: TnxFieldDescriptor; out aMapperNexusToVcl: TnxVclMapperMethod; out aMapperVclToNexus: TnxVclMapperMethod): TnxBaseVclFieldMapper; override;
Description

GetFieldData / SetFieldData

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.InternalMapNexusDescriptorToVcl Method

TnxVariableSizeVclFieldMapper.InternalMapNexusDescriptorToVcl Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapNexusDescriptorToVcl(aFieldDescriptor: TnxFieldDescriptor; out aFieldType: TFieldType; out aSize: TnxWord16; out aAttributes: TFieldAttributes); override;
Description

InitFieldDefs

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.InternalMapNexusToParamType Method

TnxVariableSizeVclFieldMapper.InternalMapNexusToParamType Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalMapNexusToParamType(aNexusType: TnxFieldType): TFieldType; override;
Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method

TnxVariableSizeVclFieldMapper.InternalMapParamTypeAndSizeToNexus Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure InternalMapParamTypeAndSizeToNexus(aParamType: TFieldType; aParamSize: Integer; out aNexusType: TnxFieldType; out aNexusSize: TnxWord32); override;
Description

TParam support

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.MapNexusDataToVcl Method

TnxVariableSizeVclFieldMapper.MapNexusDataToVcl Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); virtual; abstract;
Description

This is MapNexusDataToVcl, a member of class TnxVariableSizeVclFieldMapper.

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxVariableSizeVclFieldMapper.MapVclDataToNexus Method

TnxVariableSizeVclFieldMapper.MapVclDataToNexus Method
TnxVariableSizeVclFieldMapper Class TnxVariableSizeVclFieldMapper Members nxdbConversion Namespace TnxVariableSizeVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); virtual; abstract;
Description

This is MapVclDataToNexus, a member of class TnxVariableSizeVclFieldMapper.

Group

TnxVariableSizeVclFieldMapper Methods

Links
TnxVariableSizeVclFieldMapper Class, TnxVariableSizeVclFieldMapper Members, nxdbConversion Namespace, TnxVariableSizeVclFieldMapper Methods


TnxWideCharVclFieldMapper Class

TnxWideCharVclFieldMapper Class
TnxWideCharVclFieldMapper Methods TnxWideCharVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxWideCharVclFieldMappernxdbConversion_TnxWideCharVclFieldMappernxdbConversion_TnxWideCharVclFieldMappernxdbConversion_TnxWideCharVclFieldMappernxdbConversion_TnxWideCharVclFieldMapper
Syntax
Delphi
TnxWideCharVclFieldMapper = class(TnxBaseCharVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxWideCharVclFieldMapper.

Group

Classes

Links
TnxWideCharVclFieldMapper Methods, TnxWideCharVclFieldMapper Members, nxdbConversion, Classes


TnxWideCharVclFieldMapper Members

TnxWideCharVclFieldMapper Members
TnxWideCharVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideCharVclFieldMapper.

Class

TnxWideCharVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWideCharVclFieldMapper
GetVclSize | TnxBaseCharVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxWideCharVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxWideCharVclFieldMapper Methods

TnxWideCharVclFieldMapper Methods
TnxWideCharVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideCharVclFieldMapper class are listed here.

Class

TnxWideCharVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWideCharVclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxWideCharVclFieldMapper Class, Legend, Protected Methods


TnxWideCharVclFieldMapper.GetNexusType Method

TnxWideCharVclFieldMapper.GetNexusType Method
TnxWideCharVclFieldMapper Class TnxWideCharVclFieldMapper Members nxdbConversion Namespace TnxWideCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxWideCharVclFieldMapper

Group

TnxWideCharVclFieldMapper Methods

Links
TnxWideCharVclFieldMapper Class, TnxWideCharVclFieldMapper Members, nxdbConversion Namespace, TnxWideCharVclFieldMapper Methods


TnxWideCharVclFieldMapper.GetVclType Method

TnxWideCharVclFieldMapper.GetVclType Method
TnxWideCharVclFieldMapper Class TnxWideCharVclFieldMapper Members nxdbConversion Namespace TnxWideCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxWideCharVclFieldMapper Methods

Links
TnxWideCharVclFieldMapper Class, TnxWideCharVclFieldMapper Members, nxdbConversion Namespace, TnxWideCharVclFieldMapper Methods


TnxWideCharVclFieldMapper.MapNexusDataToVcl Method

TnxWideCharVclFieldMapper.MapNexusDataToVcl Method
TnxWideCharVclFieldMapper Class TnxWideCharVclFieldMapper Members nxdbConversion Namespace TnxWideCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxWideCharVclFieldMapper Methods

Links
TnxWideCharVclFieldMapper Class, TnxWideCharVclFieldMapper Members, nxdbConversion Namespace, TnxWideCharVclFieldMapper Methods


TnxWideCharVclFieldMapper.MapVclDataToNexus Method

TnxWideCharVclFieldMapper.MapVclDataToNexus Method
TnxWideCharVclFieldMapper Class TnxWideCharVclFieldMapper Members nxdbConversion Namespace TnxWideCharVclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxWideCharVclFieldMapper Methods

Links
TnxWideCharVclFieldMapper Class, TnxWideCharVclFieldMapper Members, nxdbConversion Namespace, TnxWideCharVclFieldMapper Methods


TnxWideMemoVclFieldMapper Class

TnxWideMemoVclFieldMapper Class
TnxWideMemoVclFieldMapper Methods TnxWideMemoVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMappernxdbConversion_TnxWideMemoVclFieldMapper
Syntax
Delphi
TnxWideMemoVclFieldMapper = class(TnxMemoVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxWideMemoVclFieldMapper.

Group

Classes

Links
TnxWideMemoVclFieldMapper Methods, TnxWideMemoVclFieldMapper Members, nxdbConversion, Classes


TnxWideMemoVclFieldMapper Members

TnxWideMemoVclFieldMapper Members
TnxWideMemoVclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideMemoVclFieldMapper.

Class

TnxWideMemoVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWideMemoVclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVcl | abstract;
MapVclDataToNexus |
MapVclDataToNexus | abstract;
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxWideMemoVclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxWideMemoVclFieldMapper Methods

TnxWideMemoVclFieldMapper Methods
TnxWideMemoVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideMemoVclFieldMapper class are listed here.

Class

TnxWideMemoVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWideMemoVclFieldMapper
GetVclType |
Links
TnxWideMemoVclFieldMapper Class, Legend, Protected Methods


TnxWideMemoVclFieldMapper.GetNexusType Method

TnxWideMemoVclFieldMapper.GetNexusType Method
TnxWideMemoVclFieldMapper Class TnxWideMemoVclFieldMapper Members nxdbConversion Namespace TnxWideMemoVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxWideMemoVclFieldMapper

Group

TnxWideMemoVclFieldMapper Methods

Links
TnxWideMemoVclFieldMapper Class, TnxWideMemoVclFieldMapper Members, nxdbConversion Namespace, TnxWideMemoVclFieldMapper Methods


TnxWideMemoVclFieldMapper.GetVclType Method

TnxWideMemoVclFieldMapper.GetVclType Method
TnxWideMemoVclFieldMapper Class TnxWideMemoVclFieldMapper Members nxdbConversion Namespace TnxWideMemoVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxWideMemoVclFieldMapper Methods

Links
TnxWideMemoVclFieldMapper Class, TnxWideMemoVclFieldMapper Members, nxdbConversion Namespace, TnxWideMemoVclFieldMapper Methods


TnxWideStringVclFieldMapper Class

TnxWideStringVclFieldMapper Class
TnxWideStringVclFieldMapper Methods TnxWideStringVclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxWideStringVclFieldMappernxdbConversion_TnxWideStringVclFieldMappernxdbConversion_TnxWideStringVclFieldMappernxdbConversion_TnxWideStringVclFieldMappernxdbConversion_TnxWideStringVclFieldMapper
Syntax
Delphi
TnxWideStringVclFieldMapper = class(TnxBasePaddingVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxWideStringVclFieldMapper.

Group

Classes

Links
TnxWideStringVclFieldMapper Methods, TnxWideStringVclFieldMapper Members, nxdbConversion, Classes


TnxWideStringVclFieldMapper Members

TnxWideStringVclFieldMapper Members
TnxWideStringVclFieldMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideStringVclFieldMapper.

Class

TnxWideStringVclFieldMapper Class

Protected Fields
Name | Description
bpvfmPadding | private
vsvfmUnits | private
Protected Methods
Name | Description
GetNexusType | TnxWideStringVclFieldMapper
GetUnitsFromParamSize |
GetVclType |
InternalAddDescriptorForFieldDef | CreateTable TnxBasePaddingVclFieldMapper
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
Create | TnxVariableSizeVclFieldMapper
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxWideStringVclFieldMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWideStringVclFieldMapper Methods

TnxWideStringVclFieldMapper Methods
TnxWideStringVclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringVclFieldMapper class are listed here.

Class

TnxWideStringVclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWideStringVclFieldMapper
GetUnitsFromParamSize |
GetVclType |
MapNexusDataToVcl |
MapNexusDataToVclPadded |
MapVclDataToNexus |
MapVclDataToNexusPadded |
Links
TnxWideStringVclFieldMapper Class, Legend, Protected Methods


TnxWideStringVclFieldMapper.GetNexusType Method

TnxWideStringVclFieldMapper.GetNexusType Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxWideStringVclFieldMapper

Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.GetUnitsFromParamSize Method

TnxWideStringVclFieldMapper.GetUnitsFromParamSize Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetUnitsFromParamSize(aParamSize: Integer): Integer; override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.GetVclType Method

TnxWideStringVclFieldMapper.GetVclType Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.MapNexusDataToVcl Method

TnxWideStringVclFieldMapper.MapNexusDataToVcl Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.MapNexusDataToVclPadded Method

TnxWideStringVclFieldMapper.MapNexusDataToVclPadded Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapNexusDataToVclPadded(const aFrom; out aTo); override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.MapVclDataToNexus Method

TnxWideStringVclFieldMapper.MapVclDataToNexus Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWideStringVclFieldMapper.MapVclDataToNexusPadded Method

TnxWideStringVclFieldMapper.MapVclDataToNexusPadded Method
TnxWideStringVclFieldMapper Class TnxWideStringVclFieldMapper Members nxdbConversion Namespace TnxWideStringVclFieldMapper Methods Send Feedback
Syntax
Delphi
procedure MapVclDataToNexusPadded(const aFrom; out aTo); override;
Group

TnxWideStringVclFieldMapper Methods

Links
TnxWideStringVclFieldMapper Class, TnxWideStringVclFieldMapper Members, nxdbConversion Namespace, TnxWideStringVclFieldMapper Methods


TnxWord16VclFieldMapper Class

TnxWord16VclFieldMapper Class
TnxWord16VclFieldMapper Methods TnxWord16VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxWord16VclFieldMappernxdbConversion_TnxWord16VclFieldMappernxdbConversion_TnxWord16VclFieldMappernxdbConversion_TnxWord16VclFieldMapper
Syntax
Delphi
TnxWord16VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxWord16VclFieldMapper.

Group

Classes

Links
TnxWord16VclFieldMapper Methods, TnxWord16VclFieldMapper Members, nxdbConversion, Classes


TnxWord16VclFieldMapper Members

TnxWord16VclFieldMapper Members
TnxWord16VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWord16VclFieldMapper.

Class

TnxWord16VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWord16VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxWord16VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxWord16VclFieldMapper Methods

TnxWord16VclFieldMapper Methods
TnxWord16VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWord16VclFieldMapper class are listed here.

Class

TnxWord16VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWord16VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxWord16VclFieldMapper Class, Legend, Protected Methods


TnxWord16VclFieldMapper.GetNexusType Method

TnxWord16VclFieldMapper.GetNexusType Method
TnxWord16VclFieldMapper Class TnxWord16VclFieldMapper Members nxdbConversion Namespace TnxWord16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxWord16VclFieldMapper

Group

TnxWord16VclFieldMapper Methods

Links
TnxWord16VclFieldMapper Class, TnxWord16VclFieldMapper Members, nxdbConversion Namespace, TnxWord16VclFieldMapper Methods


TnxWord16VclFieldMapper.GetVclType Method

TnxWord16VclFieldMapper.GetVclType Method
TnxWord16VclFieldMapper Class TnxWord16VclFieldMapper Members nxdbConversion Namespace TnxWord16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxWord16VclFieldMapper Methods

Links
TnxWord16VclFieldMapper Class, TnxWord16VclFieldMapper Members, nxdbConversion Namespace, TnxWord16VclFieldMapper Methods


TnxWord16VclFieldMapper.MapNexusDataToVcl Method

TnxWord16VclFieldMapper.MapNexusDataToVcl Method
TnxWord16VclFieldMapper Class TnxWord16VclFieldMapper Members nxdbConversion Namespace TnxWord16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxWord16VclFieldMapper Methods

Links
TnxWord16VclFieldMapper Class, TnxWord16VclFieldMapper Members, nxdbConversion Namespace, TnxWord16VclFieldMapper Methods


TnxWord16VclFieldMapper.MapVclDataToNexus Method

TnxWord16VclFieldMapper.MapVclDataToNexus Method
TnxWord16VclFieldMapper Class TnxWord16VclFieldMapper Members nxdbConversion Namespace TnxWord16VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxWord16VclFieldMapper Methods

Links
TnxWord16VclFieldMapper Class, TnxWord16VclFieldMapper Members, nxdbConversion Namespace, TnxWord16VclFieldMapper Methods


TnxWord32VclFieldMapper Class

TnxWord32VclFieldMapper Class
TnxWord32VclFieldMapper Methods TnxWord32VclFieldMapper Members nxdbConversion Classes Send Feedback
Class Hierarchy
nxdbConversion_TnxWord32VclFieldMappernxdbConversion_TnxWord32VclFieldMappernxdbConversion_TnxWord32VclFieldMappernxdbConversion_TnxWord32VclFieldMapper
Syntax
Delphi
TnxWord32VclFieldMapper = class(TnxStaticVclFieldMapper);
File

nxdbConversion

Description

This is class nxdbConversion.TnxWord32VclFieldMapper.

Group

Classes

Links
TnxWord32VclFieldMapper Methods, TnxWord32VclFieldMapper Members, nxdbConversion, Classes


TnxWord32VclFieldMapper Members

TnxWord32VclFieldMapper Members
TnxWord32VclFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWord32VclFieldMapper.

Class

TnxWord32VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWord32VclFieldMapper
GetVclSize | TnxStaticVclFieldMapper
GetVclType |
InternalAddDescriptorForFieldDef |
InternalGetMapperForDescriptor | abstract; -- CreateTable
InternalGetMapperForDescriptor | GetFieldData / SetFieldData
InternalMapNexusDescriptorToVcl | abstract;
InternalMapNexusDescriptorToVcl | InitFieldDefs
InternalMapNexusToParamType | abstract;
InternalMapNexusToParamType |
InternalMapParamTypeAndSizeToNexus | abstract;
InternalMapParamTypeAndSizeToNexus | TParam support
MapNexusDataToVcl |
MapVclDataToNexus |
RegisterNexus |
RegisterVcl |
UnRegister |
Public Methods
Name | Description
AddDescriptorForFieldDef | CreateTable TnxBaseVclFieldMapper
Bind |
FreeInstance |
GetMapperForDescriptor | GetFieldData / SetFieldData
MapNexusDescriptorToVcl | InitFieldDefs
MapNexusToParamType |
MapParamTypeAndSizeToNexus | TParam support
NewInstance | TnxObject
Links
TnxWord32VclFieldMapper Class, Legend, Protected Methods, Public Methods


TnxWord32VclFieldMapper Methods

TnxWord32VclFieldMapper Methods
TnxWord32VclFieldMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWord32VclFieldMapper class are listed here.

Class

TnxWord32VclFieldMapper Class

Protected Methods
Name | Description
GetNexusType | TnxWord32VclFieldMapper
GetVclType |
MapNexusDataToVcl |
MapVclDataToNexus |
Links
TnxWord32VclFieldMapper Class, Legend, Protected Methods


TnxWord32VclFieldMapper.GetNexusType Method

TnxWord32VclFieldMapper.GetNexusType Method
TnxWord32VclFieldMapper Class TnxWord32VclFieldMapper Members nxdbConversion Namespace TnxWord32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetNexusType: TnxFieldType; override;
Description

TnxWord32VclFieldMapper

Group

TnxWord32VclFieldMapper Methods

Links
TnxWord32VclFieldMapper Class, TnxWord32VclFieldMapper Members, nxdbConversion Namespace, TnxWord32VclFieldMapper Methods


TnxWord32VclFieldMapper.GetVclType Method

TnxWord32VclFieldMapper.GetVclType Method
TnxWord32VclFieldMapper Class TnxWord32VclFieldMapper Members nxdbConversion Namespace TnxWord32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class function GetVclType: TFieldType; override;
Group

TnxWord32VclFieldMapper Methods

Links
TnxWord32VclFieldMapper Class, TnxWord32VclFieldMapper Members, nxdbConversion Namespace, TnxWord32VclFieldMapper Methods


TnxWord32VclFieldMapper.MapNexusDataToVcl Method

TnxWord32VclFieldMapper.MapNexusDataToVcl Method
TnxWord32VclFieldMapper Class TnxWord32VclFieldMapper Members nxdbConversion Namespace TnxWord32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapNexusDataToVcl(const aFrom; out aTo); override;
Group

TnxWord32VclFieldMapper Methods

Links
TnxWord32VclFieldMapper Class, TnxWord32VclFieldMapper Members, nxdbConversion Namespace, TnxWord32VclFieldMapper Methods


TnxWord32VclFieldMapper.MapVclDataToNexus Method

TnxWord32VclFieldMapper.MapVclDataToNexus Method
TnxWord32VclFieldMapper Class TnxWord32VclFieldMapper Members nxdbConversion Namespace TnxWord32VclFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure MapVclDataToNexus(const aFrom; out aTo); override;
Group

TnxWord32VclFieldMapper Methods

Links
TnxWord32VclFieldMapper Class, TnxWord32VclFieldMapper Members, nxdbConversion Namespace, TnxWord32VclFieldMapper Methods


Types

Types
nxdbConversion Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdbConversion Namespace

Types
Name | Description
TnxBaseVclFieldMapperClass | This is type nxdbConversion.TnxBaseVclFieldMapperClass.
TnxDynMapperMethodArray | This is type nxdbConversion.TnxDynMapperMethodArray.
TnxVclMapperMethod | This is type nxdbConversion.TnxVclMapperMethod.
Links
nxdbConversion Namespace, Types


nxdbConversion.TnxBaseVclFieldMapperClass Type

nxdbConversion.TnxBaseVclFieldMapperClass Type
nxdbConversion Types Send Feedback
Syntax
Delphi
TnxBaseVclFieldMapperClass = class of TnxBaseVclFieldMapper;
File

nxdbConversion

Description

This is type nxdbConversion.TnxBaseVclFieldMapperClass.

Group

Types

Links
nxdbConversion, Types


nxdbConversion.TnxDynMapperMethodArray Type

nxdbConversion.TnxDynMapperMethodArray Type
nxdbConversion Types Send Feedback
Syntax
Delphi
TnxDynMapperMethodArray = array of TnxVclMapperMethod;
File

nxdbConversion

Description

This is type nxdbConversion.TnxDynMapperMethodArray.

Group

Types

Links
nxdbConversion, Types


nxdbConversion.TnxVclMapperMethod Type

nxdbConversion.TnxVclMapperMethod Type
nxdbConversion Types Send Feedback
Syntax
Delphi
TnxVclMapperMethod = procedure (const aFrom; out aTo) of object;
File

nxdbConversion

Description

This is type nxdbConversion.TnxVclMapperMethod.

Group

Types

Links
nxdbConversion, Types


Variables

Variables
nxdbConversion Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxdbConversion Namespace

Variables
Name | Description
_MapperClassesNexusToVcl | This is variable nxdbConversion._MapperClassesNexusToVcl.
_MapperClassesVclToNexus | This is variable nxdbConversion._MapperClassesVclToNexus.
Links
nxdbConversion Namespace, Variables


nxdbConversion._MapperClassesNexusToVcl Variable

nxdbConversion._MapperClassesNexusToVcl Variable
nxdbConversion Variables Send Feedback
Syntax
Delphi
_MapperClassesNexusToVcl: array [TnxFieldType] of TnxBaseVclFieldMapperClass;
File

nxdbConversion

Description

This is variable nxdbConversion._MapperClassesNexusToVcl.

Group

Variables

Links
nxdbConversion, Variables


nxdbConversion._MapperClassesVclToNexus Variable

nxdbConversion._MapperClassesVclToNexus Variable
nxdbConversion Variables Send Feedback
Syntax
Delphi
_MapperClassesVclToNexus: array [TFieldType] of TnxBaseVclFieldMapperClass;
File

nxdbConversion

Description

This is variable nxdbConversion._MapperClassesVclToNexus.

Group

Variables

Links
nxdbConversion, Variables


nxdbDatabaseMapper Namespace

nxdbDatabaseMapper Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxdbDatabaseMapper.

Classes
Name | Description
TnxBaseSessionHacker | This is class nxdbDatabaseMapper.TnxBaseSessionHacker.
TnxDatabaseMapper | Component that wraps a collection of database connections. The collection is used to create a unique namespace from database aliases that are not necessarily unique, for instance if you have the same aliasname in both a local and remote server, and want to use a report engine that needs database name uniqueness (e.g. ReportBuilder). There are two ways of creating the collection; either set the DefaultSession property, which reads in the list of databases connected to the session, or create entries in the Mappings collection.
TnxDatabaseMapping | The items in the TnxDatabaseMappings collection. Each item maps a unique Name to either a Session component and an AliasName, or a Database component.
TnxDatabaseMappings | The collection class used by the TnxDatabaseMapper component.
Structs, Records, Enums
Name | Description
TnxDatabaseMapperOption | This is record nxdbDatabaseMapper.TnxDatabaseMapperOption.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxDatabaseMapperOptions | This is type nxdbDatabaseMapper.TnxDatabaseMapperOptions.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxdbDatabaseMapper Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBaseSessionHacker | This is class nxdbDatabaseMapper.TnxBaseSessionHacker.
TnxDatabaseMapper | Component that wraps a collection of database connections. The collection is used to create a unique namespace from database aliases that are not necessarily unique, for instance if you have the same aliasname in both a local and remote server, and want to use a report engine that needs database name uniqueness (e.g. ReportBuilder). There are two ways of creating the collection; either set the DefaultSession property, which reads in the list of databases connected to the session, or create entries in the Mappings collection.
TnxDatabaseMapping | The items in the TnxDatabaseMappings collection. Each item maps a unique Name to either a Session component and an AliasName, or a Database component.
TnxDatabaseMappings | The collection class used by the TnxDatabaseMapper component.
Namespace

nxdbDatabaseMapper Namespace

Links
Classes, nxdbDatabaseMapper Namespace, Legend


TnxBaseSessionHacker Class

TnxBaseSessionHacker Class
nxdbDatabaseMapper Classes Send Feedback
Class Hierarchy
nxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHackernxdbDatabaseMapper_TnxBaseSessionHacker
Syntax
Delphi
TnxBaseSessionHacker = class(TnxBaseSession);
File

nxdbDatabaseMapper

Description

This is class nxdbDatabaseMapper.TnxBaseSessionHacker.

Group

Classes

Links
nxdbDatabaseMapper, Classes


TnxDatabaseMapper Class

TnxDatabaseMapper Class
TnxDatabaseMapper Fields TnxDatabaseMapper Methods TnxDatabaseMapper Properties TnxDatabaseMapper Members nxdbDatabaseMapper Classes See Also Send Feedback
Class Hierarchy
nxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMappernxdbDatabaseMapper_TnxDatabaseMapper
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxDatabaseMapper = class(TnxStateComponent);
File

nxdbDatabaseMapper

Description

Component that wraps a collection of database connections. The collection is used to create a unique namespace from database aliases that are not necessarily unique, for instance if you have the same aliasname in both a local and remote server, and want to use a report engine that needs database name uniqueness (e.g. ReportBuilder).

There are two ways of creating the collection; either set the DefaultSession property, which reads in the list of databases connected to the session, or create entries in the Mappings collection.

See Also

DefaultSession

Group

Classes

Links
TnxDatabaseMapper Fields, TnxDatabaseMapper Methods, TnxDatabaseMapper Properties, TnxDatabaseMapper Members, nxdbDatabaseMapper, Classes, See Also


TnxDatabaseMapper Members

TnxDatabaseMapper Members
TnxDatabaseMapper Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxDatabaseMapper.

Class

TnxDatabaseMapper Class

Protected Fields
Name | Description
dmDefaultSession | private
dmMappings | This is dmMappings, a member of class TnxDatabaseMapper.
dmOptions | This is dmOptions, a member of class TnxDatabaseMapper.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
dmIsLinked | This is dmIsLinked, a member of class TnxDatabaseMapper.
dmLinkDatabase | This is dmLinkDatabase, a member of class TnxDatabaseMapper.
dmLinkSession | This is dmLinkSession, a member of class TnxDatabaseMapper.
dmSetDefaultSession | This is dmSetDefaultSession, a member of class TnxDatabaseMapper.
dmSetMappings | This is dmSetMappings, a member of class TnxDatabaseMapper.
dmSetOptions | This is dmSetOptions, a member of class TnxDatabaseMapper.
dmUnLinkDatabase | This is dmUnLinkDatabase, a member of class TnxDatabaseMapper.
dmUnLinkSession | This is dmUnLinkSession, a member of class TnxDatabaseMapper.
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | TnxDatabaseMapper
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDatabaseForName | From a Mapping Name, returns the corresponding TnxDatabase component.
GetDatabaseNames | Gets the list of Mapping Names (not the real database aliases).
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DefaultSession | Set this if you have one session only in your application. The Mappings list is populated from the connected databases.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
Mappings | The collection of mappings between unique Mapping Names and databases.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Options | This is Options, a member of class TnxDatabaseMapper.
Version | Version of the component.
Links
TnxDatabaseMapper Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxDatabaseMapper.Create Constructor

TnxDatabaseMapper.Create Constructor
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

TnxDatabaseMapper

Class

TnxDatabaseMapper Class

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Class


TnxDatabaseMapper.Destroy Destructor

TnxDatabaseMapper.Destroy Destructor
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor

Class

TnxDatabaseMapper Class

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Class


TnxDatabaseMapper Fields

TnxDatabaseMapper Fields
TnxDatabaseMapper Class Legend Protected Fields Send Feedback

The fields of the TnxDatabaseMapper class are listed here.

Class

TnxDatabaseMapper Class

Protected Fields
Name | Description
dmDefaultSession | private
dmMappings | This is dmMappings, a member of class TnxDatabaseMapper.
dmOptions | This is dmOptions, a member of class TnxDatabaseMapper.
Links
TnxDatabaseMapper Class, Legend, Protected Fields


TnxDatabaseMapper.dmDefaultSession Field

TnxDatabaseMapper.dmDefaultSession Field
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Fields Send Feedback
Syntax
Delphi
dmDefaultSession: TnxSession;
Description

private

Group

TnxDatabaseMapper Fields

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Fields


TnxDatabaseMapper.dmMappings Field

TnxDatabaseMapper.dmMappings Field
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Fields Send Feedback
Syntax
Delphi
dmMappings: TnxDatabaseMappings;
Description

This is dmMappings, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Fields

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Fields


TnxDatabaseMapper.dmOptions Field

TnxDatabaseMapper.dmOptions Field
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Fields Send Feedback
Syntax
Delphi
dmOptions: TnxDatabaseMapperOptions;
Description

This is dmOptions, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Fields

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Fields


TnxDatabaseMapper Methods

TnxDatabaseMapper Methods
TnxDatabaseMapper Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDatabaseMapper class are listed here.

Class

TnxDatabaseMapper Class

Protected Methods
Name | Description
dmIsLinked | This is dmIsLinked, a member of class TnxDatabaseMapper.
dmLinkDatabase | This is dmLinkDatabase, a member of class TnxDatabaseMapper.
dmLinkSession | This is dmLinkSession, a member of class TnxDatabaseMapper.
dmSetDefaultSession | This is dmSetDefaultSession, a member of class TnxDatabaseMapper.
dmSetMappings | This is dmSetMappings, a member of class TnxDatabaseMapper.
dmSetOptions | This is dmSetOptions, a member of class TnxDatabaseMapper.
dmUnLinkDatabase | This is dmUnLinkDatabase, a member of class TnxDatabaseMapper.
dmUnLinkSession | This is dmUnLinkSession, a member of class TnxDatabaseMapper.
nxcNotification |
scIsStateParent |
Public Methods
Name | Description
GetDatabaseForName | From a Mapping Name, returns the corresponding TnxDatabase component.
GetDatabaseNames | Gets the list of Mapping Names (not the real database aliases).
Links
TnxDatabaseMapper Class, Legend, Protected Methods, Public Methods


TnxDatabaseMapper.dmIsLinked Method

TnxDatabaseMapper.dmIsLinked Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
function dmIsLinked(aComponent: TnxStateComponent): Boolean; virtual;
Description

This is dmIsLinked, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmLinkDatabase Method

TnxDatabaseMapper.dmLinkDatabase Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmLinkDatabase, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmLinkSession Method

TnxDatabaseMapper.dmLinkSession Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmLinkSession(aSession: TnxSession);
Description

This is dmLinkSession, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmSetDefaultSession Method

TnxDatabaseMapper.dmSetDefaultSession Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmSetDefaultSession(aSession: TnxSession);
Description

This is dmSetDefaultSession, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmSetMappings Method

TnxDatabaseMapper.dmSetMappings Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmSetMappings(aMappings: TnxDatabaseMappings);
Description

This is dmSetMappings, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmSetOptions Method

TnxDatabaseMapper.dmSetOptions Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmSetOptions(aOptions: TnxDatabaseMapperOptions);
Description

This is dmSetOptions, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmUnLinkDatabase Method

TnxDatabaseMapper.dmUnLinkDatabase Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmUnLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmUnLinkDatabase, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.dmUnLinkSession Method

TnxDatabaseMapper.dmUnLinkSession Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure dmUnLinkSession(aSession: TnxSession);
Description

This is dmUnLinkSession, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.GetDatabaseForName Method

TnxDatabaseMapper.GetDatabaseForName Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods See Also Send Feedback
Syntax
Delphi
function GetDatabaseForName(const aName: String): TnxDatabase;
Description

From a Mapping Name, returns the corresponding TnxDatabase component.

See Also

TnxDatabase

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods, See Also


TnxDatabaseMapper.GetDatabaseNames Method

TnxDatabaseMapper.GetDatabaseNames Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure GetDatabaseNames(aList: TStrings);
Description

Gets the list of Mapping Names (not the real database aliases).

Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.nxcNotification Method

TnxDatabaseMapper.nxcNotification Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper.scIsStateParent Method

TnxDatabaseMapper.scIsStateParent Method
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxDatabaseMapper Methods

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Methods


TnxDatabaseMapper Properties

TnxDatabaseMapper Properties
TnxDatabaseMapper Class Legend Published Properties Send Feedback

The properties of the TnxDatabaseMapper class are listed here.

Class

TnxDatabaseMapper Class

Published Properties
Name | Description
DefaultSession | Set this if you have one session only in your application. The Mappings list is populated from the connected databases.
Mappings | The collection of mappings between unique Mapping Names and databases.
Options | This is Options, a member of class TnxDatabaseMapper.
Links
TnxDatabaseMapper Class, Legend, Published Properties


TnxDatabaseMapper.DefaultSession Property

TnxDatabaseMapper.DefaultSession Property
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Properties Send Feedback
Syntax
Delphi
property DefaultSession: TnxSession;
Description

Set this if you have one session only in your application. The Mappings list is populated from the connected databases.

Group

TnxDatabaseMapper Properties

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Properties


TnxDatabaseMapper.Mappings Property

TnxDatabaseMapper.Mappings Property
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Properties Send Feedback
Syntax
Delphi
property Mappings: TnxDatabaseMappings;
Description

The collection of mappings between unique Mapping Names and databases.

Group

TnxDatabaseMapper Properties

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Properties


TnxDatabaseMapper.Options Property

TnxDatabaseMapper.Options Property
TnxDatabaseMapper Class TnxDatabaseMapper Members nxdbDatabaseMapper Namespace TnxDatabaseMapper Properties Send Feedback
Syntax
Delphi
property Options: TnxDatabaseMapperOptions;
Description

This is Options, a member of class TnxDatabaseMapper.

Group

TnxDatabaseMapper Properties

Links
TnxDatabaseMapper Class, TnxDatabaseMapper Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapper Properties


TnxDatabaseMapping Class

TnxDatabaseMapping Class
TnxDatabaseMapping Fields TnxDatabaseMapping Methods TnxDatabaseMapping Properties TnxDatabaseMapping Members nxdbDatabaseMapper Classes See Also Send Feedback
Class Hierarchy
nxdbDatabaseMapper_TnxDatabaseMapping
Syntax
Delphi
TnxDatabaseMapping = class(TCollectionItem);
File

nxdbDatabaseMapper

Description

The items in the TnxDatabaseMappings collection. Each item maps a unique Name to either a Session component and an AliasName, or a Database component.

See Also

TnxSession, TnxDatabase, TnxDatabaseMappings

Group

Classes

Links
TnxDatabaseMapping Fields, TnxDatabaseMapping Methods, TnxDatabaseMapping Properties, TnxDatabaseMapping Members, nxdbDatabaseMapper, Classes, See Also


TnxDatabaseMapping Members

TnxDatabaseMapping Members
TnxDatabaseMapping Class Legend Protected Fields Protected Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxDatabaseMapping.

Class

TnxDatabaseMapping Class

Protected Fields
Name | Description
dmiAliasName | This is dmiAliasName, a member of class TnxDatabaseMapping.
dmiDatabase | This is dmiDatabase, a member of class TnxDatabaseMapping.
dmiName | private
dmiSession | This is dmiSession, a member of class TnxDatabaseMapping.
Protected Methods
Name | Description
dmiGetDatabase | TnxDatabaseMapping
dmiGetMapper | This is dmiGetMapper, a member of class TnxDatabaseMapping.
dmiGetMappings | This is dmiGetMappings, a member of class TnxDatabaseMapping.
dmiIsLinked | This is dmiIsLinked, a member of class TnxDatabaseMapping.
dmiLinkDatabase | This is dmiLinkDatabase, a member of class TnxDatabaseMapping.
dmiLinkSession | This is dmiLinkSession, a member of class TnxDatabaseMapping.
dmiNotification | This is dmiNotification, a member of class TnxDatabaseMapping.
dmiSetAliasName | This is dmiSetAliasName, a member of class TnxDatabaseMapping.
dmiSetDatabase | This is dmiSetDatabase, a member of class TnxDatabaseMapping.
dmiSetSession | This is dmiSetSession, a member of class TnxDatabaseMapping.
dmiUnLinkDatabase | This is dmiUnLinkDatabase, a member of class TnxDatabaseMapping.
dmiUnLinkSession | This is dmiUnLinkSession, a member of class TnxDatabaseMapping.
GetDisplayName | This is GetDisplayName, a member of class TnxDatabaseMapping.
SetDisplayName | This is SetDisplayName, a member of class TnxDatabaseMapping.
Public Properties
Name | Description
Mapper | This is Mapper, a member of class TnxDatabaseMapping.
Mappings | This is Mappings, a member of class TnxDatabaseMapping.
Published Properties
Name | Description
AliasName | This is AliasName, a member of class TnxDatabaseMapping.
Database | This is Database, a member of class TnxDatabaseMapping.
Name | This is Name, a member of class TnxDatabaseMapping.
Session | This is Session, a member of class TnxDatabaseMapping.
Links
TnxDatabaseMapping Class, Legend, Protected Fields, Protected Methods, Public Properties, Published Properties


TnxDatabaseMapping Fields

TnxDatabaseMapping Fields
TnxDatabaseMapping Class Legend Protected Fields Send Feedback

The fields of the TnxDatabaseMapping class are listed here.

Class

TnxDatabaseMapping Class

Protected Fields
Name | Description
dmiAliasName | This is dmiAliasName, a member of class TnxDatabaseMapping.
dmiDatabase | This is dmiDatabase, a member of class TnxDatabaseMapping.
dmiName | private
dmiSession | This is dmiSession, a member of class TnxDatabaseMapping.
Links
TnxDatabaseMapping Class, Legend, Protected Fields


TnxDatabaseMapping.dmiAliasName Field

TnxDatabaseMapping.dmiAliasName Field
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Fields Send Feedback
Syntax
Delphi
dmiAliasName: string;
Description

This is dmiAliasName, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Fields

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Fields


TnxDatabaseMapping.dmiDatabase Field

TnxDatabaseMapping.dmiDatabase Field
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Fields Send Feedback
Syntax
Delphi
dmiDatabase: TnxDatabase;
Description

This is dmiDatabase, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Fields

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Fields


TnxDatabaseMapping.dmiName Field

TnxDatabaseMapping.dmiName Field
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Fields Send Feedback
Syntax
Delphi
dmiName: string;
Description

private

Group

TnxDatabaseMapping Fields

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Fields


TnxDatabaseMapping.dmiSession Field

TnxDatabaseMapping.dmiSession Field
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Fields Send Feedback
Syntax
Delphi
dmiSession: TnxSession;
Description

This is dmiSession, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Fields

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Fields


TnxDatabaseMapping Methods

TnxDatabaseMapping Methods
TnxDatabaseMapping Class Legend Protected Methods Send Feedback

The methods of the TnxDatabaseMapping class are listed here.

Class

TnxDatabaseMapping Class

Protected Methods
Name | Description
dmiGetDatabase | TnxDatabaseMapping
dmiGetMapper | This is dmiGetMapper, a member of class TnxDatabaseMapping.
dmiGetMappings | This is dmiGetMappings, a member of class TnxDatabaseMapping.
dmiIsLinked | This is dmiIsLinked, a member of class TnxDatabaseMapping.
dmiLinkDatabase | This is dmiLinkDatabase, a member of class TnxDatabaseMapping.
dmiLinkSession | This is dmiLinkSession, a member of class TnxDatabaseMapping.
dmiNotification | This is dmiNotification, a member of class TnxDatabaseMapping.
dmiSetAliasName | This is dmiSetAliasName, a member of class TnxDatabaseMapping.
dmiSetDatabase | This is dmiSetDatabase, a member of class TnxDatabaseMapping.
dmiSetSession | This is dmiSetSession, a member of class TnxDatabaseMapping.
dmiUnLinkDatabase | This is dmiUnLinkDatabase, a member of class TnxDatabaseMapping.
dmiUnLinkSession | This is dmiUnLinkSession, a member of class TnxDatabaseMapping.
GetDisplayName | This is GetDisplayName, a member of class TnxDatabaseMapping.
SetDisplayName | This is SetDisplayName, a member of class TnxDatabaseMapping.
Links
TnxDatabaseMapping Class, Legend, Protected Methods


TnxDatabaseMapping.dmiGetDatabase Method

TnxDatabaseMapping.dmiGetDatabase Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
function dmiGetDatabase: TnxDatabase;
Description

TnxDatabaseMapping

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiGetMapper Method

TnxDatabaseMapping.dmiGetMapper Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
function dmiGetMapper: TnxDatabaseMapper;
Description

This is dmiGetMapper, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiGetMappings Method

TnxDatabaseMapping.dmiGetMappings Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
function dmiGetMappings: TnxDatabaseMappings;
Description

This is dmiGetMappings, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiIsLinked Method

TnxDatabaseMapping.dmiIsLinked Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
function dmiIsLinked(aComponent: TnxStateComponent): Boolean; virtual;
Description

This is dmiIsLinked, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiLinkDatabase Method

TnxDatabaseMapping.dmiLinkDatabase Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmiLinkDatabase, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiLinkSession Method

TnxDatabaseMapping.dmiLinkSession Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiLinkSession(aSession: TnxSession);
Description

This is dmiLinkSession, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiNotification Method

TnxDatabaseMapping.dmiNotification Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); virtual;
Description

This is dmiNotification, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiSetAliasName Method

TnxDatabaseMapping.dmiSetAliasName Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiSetAliasName(const aAliasName: string);
Description

This is dmiSetAliasName, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiSetDatabase Method

TnxDatabaseMapping.dmiSetDatabase Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiSetDatabase(aDatabase: TnxDatabase);
Description

This is dmiSetDatabase, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiSetSession Method

TnxDatabaseMapping.dmiSetSession Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiSetSession(aSession: TnxSession);
Description

This is dmiSetSession, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiUnLinkDatabase Method

TnxDatabaseMapping.dmiUnLinkDatabase Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiUnLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmiUnLinkDatabase, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.dmiUnLinkSession Method

TnxDatabaseMapping.dmiUnLinkSession Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure dmiUnLinkSession(aSession: TnxSession);
Description

This is dmiUnLinkSession, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.GetDisplayName Method

TnxDatabaseMapping.GetDisplayName Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
function GetDisplayName: string; override;
Description

This is GetDisplayName, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping.SetDisplayName Method

TnxDatabaseMapping.SetDisplayName Method
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Methods Send Feedback
Syntax
Delphi
procedure SetDisplayName(const aName: string); override;
Description

This is SetDisplayName, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Methods

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Methods


TnxDatabaseMapping Properties

TnxDatabaseMapping Properties
TnxDatabaseMapping Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxDatabaseMapping class are listed here.

Class

TnxDatabaseMapping Class

Public Properties
Name | Description
Mapper | This is Mapper, a member of class TnxDatabaseMapping.
Mappings | This is Mappings, a member of class TnxDatabaseMapping.
Published Properties
Name | Description
AliasName | This is AliasName, a member of class TnxDatabaseMapping.
Database | This is Database, a member of class TnxDatabaseMapping.
Name | This is Name, a member of class TnxDatabaseMapping.
Session | This is Session, a member of class TnxDatabaseMapping.
Links
TnxDatabaseMapping Class, Legend, Public Properties, Published Properties


TnxDatabaseMapping.AliasName Property

TnxDatabaseMapping.AliasName Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property AliasName: string;
Description

This is AliasName, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMapping.Database Property

TnxDatabaseMapping.Database Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property Database: TnxDatabase;
Description

This is Database, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMapping.Mapper Property

TnxDatabaseMapping.Mapper Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property Mapper: TnxDatabaseMapper;
Description

This is Mapper, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMapping.Mappings Property

TnxDatabaseMapping.Mappings Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property Mappings: TnxDatabaseMappings;
Description

This is Mappings, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMapping.Name Property

TnxDatabaseMapping.Name Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is Name, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMapping.Session Property

TnxDatabaseMapping.Session Property
TnxDatabaseMapping Class TnxDatabaseMapping Members nxdbDatabaseMapper Namespace TnxDatabaseMapping Properties Send Feedback
Syntax
Delphi
property Session: TnxSession;
Description

This is Session, a member of class TnxDatabaseMapping.

Group

TnxDatabaseMapping Properties

Links
TnxDatabaseMapping Class, TnxDatabaseMapping Members, nxdbDatabaseMapper Namespace, TnxDatabaseMapping Properties


TnxDatabaseMappings Class

TnxDatabaseMappings Class
TnxDatabaseMappings Methods TnxDatabaseMappings Properties TnxDatabaseMappings Members nxdbDatabaseMapper Classes See Also Send Feedback
Class Hierarchy
nxdbDatabaseMapper_TnxDatabaseMappings
Syntax
Delphi
TnxDatabaseMappings = class(TOwnedCollection);
File

nxdbDatabaseMapper

Description

The collection class used by the TnxDatabaseMapper component.

See Also

TnxDatabaseMapper

Group

Classes

Links
TnxDatabaseMappings Methods, TnxDatabaseMappings Properties, TnxDatabaseMappings Members, nxdbDatabaseMapper, Classes, See Also


TnxDatabaseMappings Members

TnxDatabaseMappings Members
TnxDatabaseMappings Class Legend Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxDatabaseMappings.

Class

TnxDatabaseMappings Class

Protected Methods
Name | Description
dmcGetMapper | private
dmcIsLinked | This is dmcIsLinked, a member of class TnxDatabaseMappings.
dmcLinkDatabase | This is dmcLinkDatabase, a member of class TnxDatabaseMappings.
dmcLinkSession | This is dmcLinkSession, a member of class TnxDatabaseMappings.
dmcNotification | This is dmcNotification, a member of class TnxDatabaseMappings.
dmcUnLinkDatabase | This is dmcUnLinkDatabase, a member of class TnxDatabaseMappings.
dmcUnLinkSession | This is dmcUnLinkSession, a member of class TnxDatabaseMappings.
SetItemName | This is SetItemName, a member of class TnxDatabaseMappings.
Protected Properties
Name | Description
Mapper | This is Mapper, a member of class TnxDatabaseMappings.
Public Methods
Name | Description
Create | TnxDatabaseMappings
Find | This is Find, a member of class TnxDatabaseMappings.
GetItemNames | This is GetItemNames, a member of class TnxDatabaseMappings.
IndexOf | This is IndexOf, a member of class TnxDatabaseMappings.
Links
TnxDatabaseMappings Class, Legend, Protected Methods, Protected Properties, Public Methods


TnxDatabaseMappings.Create Constructor

TnxDatabaseMappings.Create Constructor
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TnxDatabaseMapper);
Description

TnxDatabaseMappings

Class

TnxDatabaseMappings Class

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Class


TnxDatabaseMappings Methods

TnxDatabaseMappings Methods
TnxDatabaseMappings Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDatabaseMappings class are listed here.

Class

TnxDatabaseMappings Class

Protected Methods
Name | Description
dmcGetMapper | private
dmcIsLinked | This is dmcIsLinked, a member of class TnxDatabaseMappings.
dmcLinkDatabase | This is dmcLinkDatabase, a member of class TnxDatabaseMappings.
dmcLinkSession | This is dmcLinkSession, a member of class TnxDatabaseMappings.
dmcNotification | This is dmcNotification, a member of class TnxDatabaseMappings.
dmcUnLinkDatabase | This is dmcUnLinkDatabase, a member of class TnxDatabaseMappings.
dmcUnLinkSession | This is dmcUnLinkSession, a member of class TnxDatabaseMappings.
SetItemName | This is SetItemName, a member of class TnxDatabaseMappings.
Public Methods
Name | Description
Find | This is Find, a member of class TnxDatabaseMappings.
GetItemNames | This is GetItemNames, a member of class TnxDatabaseMappings.
IndexOf | This is IndexOf, a member of class TnxDatabaseMappings.
Links
TnxDatabaseMappings Class, Legend, Protected Methods, Public Methods


TnxDatabaseMappings.dmcGetMapper Method

TnxDatabaseMappings.dmcGetMapper Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
function dmcGetMapper: TnxDatabaseMapper;
Description

private

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcIsLinked Method

TnxDatabaseMappings.dmcIsLinked Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
function dmcIsLinked(aComponent: TnxStateComponent): Boolean; virtual;
Description

This is dmcIsLinked, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcLinkDatabase Method

TnxDatabaseMappings.dmcLinkDatabase Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure dmcLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmcLinkDatabase, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcLinkSession Method

TnxDatabaseMappings.dmcLinkSession Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure dmcLinkSession(aSession: TnxSession);
Description

This is dmcLinkSession, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcNotification Method

TnxDatabaseMappings.dmcNotification Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure dmcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); virtual;
Description

This is dmcNotification, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcUnLinkDatabase Method

TnxDatabaseMappings.dmcUnLinkDatabase Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure dmcUnLinkDatabase(aDatabase: TnxDatabase);
Description

This is dmcUnLinkDatabase, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.dmcUnLinkSession Method

TnxDatabaseMappings.dmcUnLinkSession Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure dmcUnLinkSession(aSession: TnxSession);
Description

This is dmcUnLinkSession, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.Find Method

TnxDatabaseMappings.Find Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
function Find(const aName: string): TnxDatabaseMapping;
Description

This is Find, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.GetItemNames Method

TnxDatabaseMappings.GetItemNames Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure GetItemNames(aList: TStrings);
Description

This is GetItemNames, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.IndexOf Method

TnxDatabaseMappings.IndexOf Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
function IndexOf(const aName: string): Integer;
Description

This is IndexOf, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings.SetItemName Method

TnxDatabaseMappings.SetItemName Method
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Methods Send Feedback
Syntax
Delphi
procedure SetItemName(aItem: TCollectionItem); override;
Description

This is SetItemName, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Methods

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Methods


TnxDatabaseMappings Properties

TnxDatabaseMappings Properties
TnxDatabaseMappings Class Legend Protected Properties Send Feedback

The properties of the TnxDatabaseMappings class are listed here.

Class

TnxDatabaseMappings Class

Protected Properties
Name | Description
Mapper | This is Mapper, a member of class TnxDatabaseMappings.
Links
TnxDatabaseMappings Class, Legend, Protected Properties


TnxDatabaseMappings.Mapper Property

TnxDatabaseMappings.Mapper Property
TnxDatabaseMappings Class TnxDatabaseMappings Members nxdbDatabaseMapper Namespace TnxDatabaseMappings Properties Send Feedback
Syntax
Delphi
property Mapper: TnxDatabaseMapper;
Description

This is Mapper, a member of class TnxDatabaseMappings.

Group

TnxDatabaseMappings Properties

Links
TnxDatabaseMappings Class, TnxDatabaseMappings Members, nxdbDatabaseMapper Namespace, TnxDatabaseMappings Properties


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxdbDatabaseMapper Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxDatabaseMapperOption | This is record nxdbDatabaseMapper.TnxDatabaseMapperOption.
Namespace

nxdbDatabaseMapper Namespace

Links
Enumerations, nxdbDatabaseMapper Namespace, Legend


nxdbDatabaseMapper.TnxDatabaseMapperOption Enumeration

nxdbDatabaseMapper.TnxDatabaseMapperOption Enumeration
nxdbDatabaseMapper Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDatabaseMapperOption = ( dmoAddAliasNames );
File

nxdbDatabaseMapper

Description

This is record nxdbDatabaseMapper.TnxDatabaseMapperOption.

Group

Structs, Records, Enums

Links
nxdbDatabaseMapper, Structs, Records, Enums


Types

Types
nxdbDatabaseMapper Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdbDatabaseMapper Namespace

Types
Name | Description
TnxDatabaseMapperOptions | This is type nxdbDatabaseMapper.TnxDatabaseMapperOptions.
Links
nxdbDatabaseMapper Namespace, Types


nxdbDatabaseMapper.TnxDatabaseMapperOptions Type

nxdbDatabaseMapper.TnxDatabaseMapperOptions Type
nxdbDatabaseMapper Types Send Feedback
Syntax
Delphi
TnxDatabaseMapperOptions = set of TnxDatabaseMapperOption;
File

nxdbDatabaseMapper

Description

This is type nxdbDatabaseMapper.TnxDatabaseMapperOptions.

Group

Types

Links
nxdbDatabaseMapper, Types


nxdbStrings Namespace

nxdbStrings Namespace
Constants Topics Send Feedback

This is namespace nxdbStrings.

Constants
Name | Description
rsAliasNameOrPathRequired | This is constant nxdbStrings.rsAliasNameOrPathRequired.
rsAliasNoChangeForImplicitDatabase | This is constant nxdbStrings.rsAliasNoChangeForImplicitDatabase.
rsBeginBatchAppendNotCalled | This is constant nxdbStrings.rsBeginBatchAppendNotCalled.
rsBlobAccessNoMatch | This is constant nxdbStrings.rsBlobAccessNoMatch.
rsBlobTblNoEdit | This is constant nxdbStrings.rsBlobTblNoEdit.
rsCachedDataSetCantReferenceItself | This is constant nxdbStrings.rsCachedDataSetCantReferenceItself.
rsDataSetCantGetBuf | This is constant nxdbStrings.rsDataSetCantGetBuf.
rsDataSetCantOpenDatabase | This is constant nxdbStrings.rsDataSetCantOpenDatabase.
rsDataSetEditing | This is constant nxdbStrings.rsDataSetEditing.
rsDataSetNotEditing | This is constant nxdbStrings.rsDataSetNotEditing.
rsEmptySQLStatement | This is constant nxdbStrings.rsEmptySQLStatement.
rsFltNoFldAccess | This is constant nxdbStrings.rsFltNoFldAccess.
rsInvalidFieldType | This is constant nxdbStrings.rsInvalidFieldType.
rsMustFreeBlobStreams | This is constant nxdbStrings.rsMustFreeBlobStreams.
rsNoFldBuffAccess | This is constant nxdbStrings.rsNoFldBuffAccess.
rsNoOwningSession | This is constant nxdbStrings.rsNoOwningSession.
rsParamValueError | This is constant nxdbStrings.rsParamValueError.
rsQueryExecFail | This is constant nxdbStrings.rsQueryExecFail.
rsQueryGetParamsFail | This is constant nxdbStrings.rsQueryGetParamsFail.
rsQueryPrepareFail | This is constant nxdbStrings.rsQueryPrepareFail.
rsQuerySetParamsFail | This is constant nxdbStrings.rsQuerySetParamsFail.
rsStreamDisconnected | This is constant nxdbStrings.rsStreamDisconnected.
rsTableMustBeActive | This is constant nxdbStrings.rsTableMustBeActive.
rsTblCircDataLink | This is constant nxdbStrings.rsTblCircDataLink.
rsUnnamedParam | This is constant nxdbStrings.rsUnnamedParam.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxdbStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsAliasNameOrPathRequired | This is constant nxdbStrings.rsAliasNameOrPathRequired.
rsAliasNoChangeForImplicitDatabase | This is constant nxdbStrings.rsAliasNoChangeForImplicitDatabase.
rsBeginBatchAppendNotCalled | This is constant nxdbStrings.rsBeginBatchAppendNotCalled.
rsBlobAccessNoMatch | This is constant nxdbStrings.rsBlobAccessNoMatch.
rsBlobTblNoEdit | This is constant nxdbStrings.rsBlobTblNoEdit.
rsCachedDataSetCantReferenceItself | This is constant nxdbStrings.rsCachedDataSetCantReferenceItself.
rsDataSetCantGetBuf | This is constant nxdbStrings.rsDataSetCantGetBuf.
rsDataSetCantOpenDatabase | This is constant nxdbStrings.rsDataSetCantOpenDatabase.
rsDataSetEditing | This is constant nxdbStrings.rsDataSetEditing.
rsDataSetNotEditing | This is constant nxdbStrings.rsDataSetNotEditing.
rsEmptySQLStatement | This is constant nxdbStrings.rsEmptySQLStatement.
rsFltNoFldAccess | This is constant nxdbStrings.rsFltNoFldAccess.
rsInvalidFieldType | This is constant nxdbStrings.rsInvalidFieldType.
rsMustFreeBlobStreams | This is constant nxdbStrings.rsMustFreeBlobStreams.
rsNoFldBuffAccess | This is constant nxdbStrings.rsNoFldBuffAccess.
rsNoOwningSession | This is constant nxdbStrings.rsNoOwningSession.
rsParamValueError | This is constant nxdbStrings.rsParamValueError.
rsQueryExecFail | This is constant nxdbStrings.rsQueryExecFail.
rsQueryGetParamsFail | This is constant nxdbStrings.rsQueryGetParamsFail.
rsQueryPrepareFail | This is constant nxdbStrings.rsQueryPrepareFail.
rsQuerySetParamsFail | This is constant nxdbStrings.rsQuerySetParamsFail.
rsStreamDisconnected | This is constant nxdbStrings.rsStreamDisconnected.
rsTableMustBeActive | This is constant nxdbStrings.rsTableMustBeActive.
rsTblCircDataLink | This is constant nxdbStrings.rsTblCircDataLink.
rsUnnamedParam | This is constant nxdbStrings.rsUnnamedParam.
Namespace

nxdbStrings Namespace

Links
Constants, nxdbStrings Namespace


nxdbStrings.rsAliasNameOrPathRequired Constant

nxdbStrings.rsAliasNameOrPathRequired Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsAliasNameOrPathRequired = 'AliasName or AliasPath must be specified';
File

nxdbStrings

Description

This is constant nxdbStrings.rsAliasNameOrPathRequired.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsAliasNoChangeForImplicitDatabase Constant

nxdbStrings.rsAliasNoChangeForImplicitDatabase Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsAliasNoChangeForImplicitDatabase = 'AliasName can''t be changed for an implicit database';
File

nxdbStrings

Description

This is constant nxdbStrings.rsAliasNoChangeForImplicitDatabase.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsBeginBatchAppendNotCalled Constant

nxdbStrings.rsBeginBatchAppendNotCalled Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsBeginBatchAppendNotCalled = 'BeginBatchAppend was not called';
File

nxdbStrings

Description

This is constant nxdbStrings.rsBeginBatchAppendNotCalled.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsBlobAccessNoMatch Constant

nxdbStrings.rsBlobAccessNoMatch Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsBlobAccessNoMatch = 'The field is readonly but BLOB stream is being opened for read/write access';
File

nxdbStrings

Description

This is constant nxdbStrings.rsBlobAccessNoMatch.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsBlobTblNoEdit Constant

nxdbStrings.rsBlobTblNoEdit Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsBlobTblNoEdit = 'The BLOB stream is being opened for read/write access but the DataSet is not being edited';
File

nxdbStrings

Description

This is constant nxdbStrings.rsBlobTblNoEdit.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsCachedDataSetCantReferenceItself Constant

nxdbStrings.rsCachedDataSetCantReferenceItself Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsCachedDataSetCantReferenceItself = 'TnxCachedDataSet cant reference itself';
File

nxdbStrings

Description

This is constant nxdbStrings.rsCachedDataSetCantReferenceItself.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsDataSetCantGetBuf Constant

nxdbStrings.rsDataSetCantGetBuf Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsDataSetCantGetBuf = 'Could not retrieve the active buffer';
File

nxdbStrings

Description

This is constant nxdbStrings.rsDataSetCantGetBuf.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsDataSetCantOpenDatabase Constant

nxdbStrings.rsDataSetCantOpenDatabase Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsDataSetCantOpenDatabase = 'DataSet cannot open its database';
File

nxdbStrings

Description

This is constant nxdbStrings.rsDataSetCantOpenDatabase.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsDataSetEditing Constant

nxdbStrings.rsDataSetEditing Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsDataSetEditing = 'DataSet in editing mode';
File

nxdbStrings

Description

This is constant nxdbStrings.rsDataSetEditing.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsDataSetNotEditing Constant

nxdbStrings.rsDataSetNotEditing Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsDataSetNotEditing = 'DataSet not in editing mode';
File

nxdbStrings

Description

This is constant nxdbStrings.rsDataSetNotEditing.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsEmptySQLStatement Constant

nxdbStrings.rsEmptySQLStatement Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsEmptySQLStatement = 'No SQL statement specified';
File

nxdbStrings

Description

This is constant nxdbStrings.rsEmptySQLStatement.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsFltNoFldAccess Constant

nxdbStrings.rsFltNoFldAccess Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsFltNoFldAccess = 'No access to field whilst DataSet is being filtered';
File

nxdbStrings

Description

This is constant nxdbStrings.rsFltNoFldAccess.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsInvalidFieldType Constant

nxdbStrings.rsInvalidFieldType Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsInvalidFieldType = 'Field type "%s" specified for field "%s" is not supported';
File

nxdbStrings

Description

This is constant nxdbStrings.rsInvalidFieldType.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsMustFreeBlobStreams Constant

nxdbStrings.rsMustFreeBlobStreams Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsMustFreeBlobStreams = 'All BLOB streams must be freed before executing this operation';
File

nxdbStrings

Description

This is constant nxdbStrings.rsMustFreeBlobStreams.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsNoFldBuffAccess Constant

nxdbStrings.rsNoFldBuffAccess Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsNoFldBuffAccess = 'No access to field buffer';
File

nxdbStrings

Description

This is constant nxdbStrings.rsNoFldBuffAccess.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsNoOwningSession Constant

nxdbStrings.rsNoOwningSession Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsNoOwningSession = 'No owning session';
File

nxdbStrings

Description

This is constant nxdbStrings.rsNoOwningSession.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsParamValueError Constant

nxdbStrings.rsParamValueError Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsParamValueError = 'Invalid value for param ''%s''';
File

nxdbStrings

Description

This is constant nxdbStrings.rsParamValueError.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsQueryExecFail Constant

nxdbStrings.rsQueryExecFail Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsQueryExecFail = 'Query execution failed: %s%s';
File

nxdbStrings

Description

This is constant nxdbStrings.rsQueryExecFail.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsQueryGetParamsFail Constant

nxdbStrings.rsQueryGetParamsFail Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsQueryGetParamsFail = 'Query get parameters failed: %s%s';
File

nxdbStrings

Description

This is constant nxdbStrings.rsQueryGetParamsFail.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsQueryPrepareFail Constant

nxdbStrings.rsQueryPrepareFail Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsQueryPrepareFail = 'Query preparation failed: %s%s';
File

nxdbStrings

Description

This is constant nxdbStrings.rsQueryPrepareFail.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsQuerySetParamsFail Constant

nxdbStrings.rsQuerySetParamsFail Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsQuerySetParamsFail = 'Query set parameters failed: %s%s';
File

nxdbStrings

Description

This is constant nxdbStrings.rsQuerySetParamsFail.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsStreamDisconnected Constant

nxdbStrings.rsStreamDisconnected Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsStreamDisconnected = 'The stream has been disconnected';
File

nxdbStrings

Description

This is constant nxdbStrings.rsStreamDisconnected.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsTableMustBeActive Constant

nxdbStrings.rsTableMustBeActive Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsTableMustBeActive = 'Table %d (%s) must be active';
File

nxdbStrings

Description

This is constant nxdbStrings.rsTableMustBeActive.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsTblCircDataLink Constant

nxdbStrings.rsTblCircDataLink Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsTblCircDataLink = 'Circular data link with data source [%s]';
File

nxdbStrings

Description

This is constant nxdbStrings.rsTblCircDataLink.

Group

Constants

Links
nxdbStrings, Constants


nxdbStrings.rsUnnamedParam Constant

nxdbStrings.rsUnnamedParam Constant
nxdbStrings Constants Send Feedback
Syntax
Delphi
rsUnnamedParam = '<UnnamedParam:%d>';
File

nxdbStrings

Description

This is constant nxdbStrings.rsUnnamedParam.

Group

Constants

Links
nxdbStrings, Constants


nxdvBDSIdeSplash Namespace

nxdvBDSIdeSplash Namespace
Topics Types Variables Send Feedback

This is namespace nxdvBDSIdeSplash.

Topics
Name | Description
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TStartCheckProc | This is type nxdvBDSIdeSplash.TStartCheckProc.
Variables
Name | Description
AboutBoxIndex | This is variable nxdvBDSIdeSplash.AboutBoxIndex.
AboutBoxServices | This is variable nxdvBDSIdeSplash.AboutBoxServices.
DLLModule | This is variable nxdvBDSIdeSplash.DLLModule.
OldMode | This is variable nxdvBDSIdeSplash.OldMode.
s | This is variable nxdvBDSIdeSplash.s.
StartCheck | This is variable nxdvBDSIdeSplash.StartCheck.
Links
Topics, Types, Variables


Types

Types
nxdvBDSIdeSplash Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdvBDSIdeSplash Namespace

Types
Name | Description
TStartCheckProc | This is type nxdvBDSIdeSplash.TStartCheckProc.
Links
nxdvBDSIdeSplash Namespace, Types


nxdvBDSIdeSplash.TStartCheckProc Type

nxdvBDSIdeSplash.TStartCheckProc Type
nxdvBDSIdeSplash Types Send Feedback
Syntax
Delphi
TStartCheckProc = procedure (aInfo : PChar);
File

nxdvBDSIdeSplash

Description

This is type nxdvBDSIdeSplash.TStartCheckProc.

Group

Types

Links
nxdvBDSIdeSplash, Types


Variables

Variables
nxdvBDSIdeSplash Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxdvBDSIdeSplash Namespace

Variables
Name | Description
AboutBoxIndex | This is variable nxdvBDSIdeSplash.AboutBoxIndex.
AboutBoxServices | This is variable nxdvBDSIdeSplash.AboutBoxServices.
DLLModule | This is variable nxdvBDSIdeSplash.DLLModule.
OldMode | This is variable nxdvBDSIdeSplash.OldMode.
s | This is variable nxdvBDSIdeSplash.s.
StartCheck | This is variable nxdvBDSIdeSplash.StartCheck.
Links
nxdvBDSIdeSplash Namespace, Variables


nxdvBDSIdeSplash.AboutBoxIndex Variable

nxdvBDSIdeSplash.AboutBoxIndex Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
AboutBoxIndex: Integer = -1;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.AboutBoxIndex.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvBDSIdeSplash.AboutBoxServices Variable

nxdvBDSIdeSplash.AboutBoxServices Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
AboutBoxServices: IOTAAboutBoxServices = nil;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.AboutBoxServices.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvBDSIdeSplash.DLLModule Variable

nxdvBDSIdeSplash.DLLModule Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
DLLModule: HMODULE;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.DLLModule.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvBDSIdeSplash.OldMode Variable

nxdvBDSIdeSplash.OldMode Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
OldMode: UINT;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.OldMode.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvBDSIdeSplash.s Variable

nxdvBDSIdeSplash.s Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
s: string;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.s.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvBDSIdeSplash.StartCheck Variable

nxdvBDSIdeSplash.StartCheck Variable
nxdvBDSIdeSplash Variables Send Feedback
Syntax
Delphi
StartCheck: TStartCheckProc;
File

nxdvBDSIdeSplash

Description

This is variable nxdvBDSIdeSplash.StartCheck.

Group

Variables

Links
nxdvBDSIdeSplash, Variables


nxdvOnCompileHelper Namespace

nxdvOnCompileHelper Namespace
Classes Legend Topics Variables Send Feedback

This is namespace nxdvOnCompileHelper.

Classes
Name | Description
TnxIDENotifier | This is class nxdvOnCompileHelper.TnxIDENotifier.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_NotifierReference | This is variable nxdvOnCompileHelper._NotifierReference.
Links
Classes, Legend, Topics, Variables


Classes

Classes
Classes nxdvOnCompileHelper Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxIDENotifier | This is class nxdvOnCompileHelper.TnxIDENotifier.
Namespace

nxdvOnCompileHelper Namespace

Links
Classes, nxdvOnCompileHelper Namespace, Legend


TnxIDENotifier Class

TnxIDENotifier Class
TnxIDENotifier Methods TnxIDENotifier Members nxdvOnCompileHelper Classes Send Feedback
Class Hierarchy
nxdvOnCompileHelper_TnxIDENotifier
Syntax
Delphi
TnxIDENotifier = class(TInterfacedObject, IOTANotifier, IOTAIDENotifier, IOTAIDENotifier50);
File

nxdvOnCompileHelper

Description

This is class nxdvOnCompileHelper.TnxIDENotifier.

Group

Classes

Links
TnxIDENotifier Methods, TnxIDENotifier Members, nxdvOnCompileHelper, Classes


TnxIDENotifier Members

TnxIDENotifier Members
TnxIDENotifier Class Legend Protected Methods Send Feedback

The following tables list the members exposed by TnxIDENotifier.

Class

TnxIDENotifier Class

Protected Methods
Name | Description
AfterCompile | This is the overview for the AfterCompile method overload.
AfterSave | IOTANotifier
BeforeCompile | This is the overview for the BeforeCompile method overload.
BeforeSave | This is BeforeSave, a member of class TnxIDENotifier.
Destroyed | This is Destroyed, a member of class TnxIDENotifier.
FileNotification | IOTAIDENotifier
Modified | This is Modified, a member of class TnxIDENotifier.
Links
TnxIDENotifier Class, Legend, Protected Methods


TnxIDENotifier Methods

TnxIDENotifier Methods
TnxIDENotifier Class Legend Protected Methods Send Feedback

The methods of the TnxIDENotifier class are listed here.

Class

TnxIDENotifier Class

Protected Methods
Name | Description
AfterCompile | This is the overview for the AfterCompile method overload.
AfterSave | IOTANotifier
BeforeCompile | This is the overview for the BeforeCompile method overload.
BeforeSave | This is BeforeSave, a member of class TnxIDENotifier.
Destroyed | This is Destroyed, a member of class TnxIDENotifier.
FileNotification | IOTAIDENotifier
Modified | This is Modified, a member of class TnxIDENotifier.
Links
TnxIDENotifier Class, Legend, Protected Methods


AfterCompile Method

AfterCompile Method
TnxIDENotifier Methods Send Feedback

This is the overview for the AfterCompile method overload.

Overload List
Name | Description
TnxIDENotifier.AfterCompile (Boolean) | This is AfterCompile, a member of class TnxIDENotifier.
TnxIDENotifier.AfterCompile (Boolean, Boolean) | TnxIDENotifier
Group

TnxIDENotifier Methods

Links
TnxIDENotifier Methods


TnxIDENotifier.AfterCompile Method (Boolean)

TnxIDENotifier.AfterCompile Method (Boolean)
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace AfterCompile Method Send Feedback
Syntax
Delphi
procedure AfterCompile(Succeeded: Boolean); overload;
Description

This is AfterCompile, a member of class TnxIDENotifier.

Group

AfterCompile Method

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, AfterCompile Method


TnxIDENotifier.AfterCompile Method (Boolean, Boolean)

TnxIDENotifier.AfterCompile Method (Boolean, Boolean)
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace AfterCompile Method Send Feedback
Syntax
Delphi
procedure AfterCompile(Succeeded: Boolean; IsCodeInsight: Boolean); overload;
Description

TnxIDENotifier

Group

AfterCompile Method

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, AfterCompile Method


TnxIDENotifier.AfterSave Method

TnxIDENotifier.AfterSave Method
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace TnxIDENotifier Methods Send Feedback
Syntax
Delphi
procedure AfterSave;
Description

IOTANotifier

Group

TnxIDENotifier Methods

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, TnxIDENotifier Methods


BeforeCompile Method

BeforeCompile Method
TnxIDENotifier Methods Send Feedback

This is the overview for the BeforeCompile method overload.

Overload List
Name | Description
TnxIDENotifier.BeforeCompile (IOTAProject, Boolean) | This is BeforeCompile, a member of class TnxIDENotifier.
TnxIDENotifier.BeforeCompile (IOTAProject, Boolean, Boolean) | IOTAIDENotifier50
Group

TnxIDENotifier Methods

Links
TnxIDENotifier Methods


TnxIDENotifier.BeforeCompile Method (IOTAProject, Boolean)

TnxIDENotifier.BeforeCompile Method (IOTAProject, Boolean)
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace BeforeCompile Method Send Feedback
Syntax
Delphi
procedure BeforeCompile(const Project: IOTAProject; var Cancel: Boolean); overload;
Description

This is BeforeCompile, a member of class TnxIDENotifier.

Group

BeforeCompile Method

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, BeforeCompile Method


TnxIDENotifier.BeforeCompile Method (IOTAProject, Boolean, Boolean)

TnxIDENotifier.BeforeCompile Method (IOTAProject, Boolean, Boolean)
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace BeforeCompile Method Send Feedback
Syntax
Delphi
procedure BeforeCompile(const Project: IOTAProject; IsCodeInsight: Boolean; var Cancel: Boolean); overload;
Description

IOTAIDENotifier50

Group

BeforeCompile Method

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, BeforeCompile Method


TnxIDENotifier.BeforeSave Method

TnxIDENotifier.BeforeSave Method
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace TnxIDENotifier Methods Send Feedback
Syntax
Delphi
procedure BeforeSave;
Description

This is BeforeSave, a member of class TnxIDENotifier.

Group

TnxIDENotifier Methods

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, TnxIDENotifier Methods


TnxIDENotifier.Destroyed Method

TnxIDENotifier.Destroyed Method
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace TnxIDENotifier Methods Send Feedback
Syntax
Delphi
procedure Destroyed;
Description

This is Destroyed, a member of class TnxIDENotifier.

Group

TnxIDENotifier Methods

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, TnxIDENotifier Methods


TnxIDENotifier.FileNotification Method

TnxIDENotifier.FileNotification Method
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace TnxIDENotifier Methods Send Feedback
Syntax
Delphi
procedure FileNotification(NotifyCode: TOTAFileNotification; const FileName: string; var Cancel: Boolean);
Description

IOTAIDENotifier

Group

TnxIDENotifier Methods

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, TnxIDENotifier Methods


TnxIDENotifier.Modified Method

TnxIDENotifier.Modified Method
TnxIDENotifier Class TnxIDENotifier Members nxdvOnCompileHelper Namespace TnxIDENotifier Methods Send Feedback
Syntax
Delphi
procedure Modified;
Description

This is Modified, a member of class TnxIDENotifier.

Group

TnxIDENotifier Methods

Links
TnxIDENotifier Class, TnxIDENotifier Members, nxdvOnCompileHelper Namespace, TnxIDENotifier Methods


Variables

Variables
nxdvOnCompileHelper Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxdvOnCompileHelper Namespace

Variables
Name | Description
_NotifierReference | This is variable nxdvOnCompileHelper._NotifierReference.
Links
nxdvOnCompileHelper Namespace, Variables


nxdvOnCompileHelper._NotifierReference Variable

nxdvOnCompileHelper._NotifierReference Variable
nxdvOnCompileHelper Variables Send Feedback
Syntax
Delphi
_NotifierReference: Integer;
File

nxdvOnCompileHelper

Description

This is variable nxdvOnCompileHelper._NotifierReference.

Group

Variables

Links
nxdvOnCompileHelper, Variables


nxdvPluginWizard Namespace

nxdvPluginWizard Namespace
Classes Functions Interfaces Legend Topics Types Send Feedback

This is namespace nxdvPluginWizard.

Classes
Name | Description
TnxApplicationProjectCreator | This is class nxdvPluginWizard.TnxApplicationProjectCreator.
TnxBasePackageProjectCreator | This is class nxdvPluginWizard.TnxBasePackageProjectCreator.
TnxBaseUnitModuleCreator | This is class nxdvPluginWizard.TnxBaseUnitModuleCreator.
TnxClientPackageProjectCreator | This is class nxdvPluginWizard.TnxClientPackageProjectCreator.
TnxClientUnitModuleCreator | This is class nxdvPluginWizard.TnxClientUnitModuleCreator.
TnxCommandHandlerPackageProjectCreator | This is class nxdvPluginWizard.TnxCommandHandlerPackageProjectCreator.
TnxCommandHandlerUnitModuleCreator | This is class nxdvPluginWizard.TnxCommandHandlerUnitModuleCreator.
TnxCreator | This is class nxdvPluginWizard.TnxCreator.
TnxDesignPackageProjectCreator | This is class nxdvPluginWizard.TnxDesignPackageProjectCreator.
TnxDesignUnitModuleCreator | This is class nxdvPluginWizard.TnxDesignUnitModuleCreator.
TnxFile | This is class nxdvPluginWizard.TnxFile.
TnxFormModuleCreator | This is class nxdvPluginWizard.TnxFormModuleCreator.
TnxMessagesPackageProjectCreator | This is class nxdvPluginWizard.TnxMessagesPackageProjectCreator.
TnxMessagesUnitModuleCreator | This is class nxdvPluginWizard.TnxMessagesUnitModuleCreator.
TnxModuleCreator | This is class nxdvPluginWizard.TnxModuleCreator.
TnxPackageProjectCreator | This is class nxdvPluginWizard.TnxPackageProjectCreator.
TnxPluginWizard | This is class nxdvPluginWizard.TnxPluginWizard.
TnxProjectCreator | This is class nxdvPluginWizard.TnxProjectCreator.
TnxProjectGroupCreator | This is class nxdvPluginWizard.TnxProjectGroupCreator.
TnxServerPackageProjectCreator | This is class nxdvPluginWizard.TnxServerPackageProjectCreator.
TnxServerUnitModuleCreator | This is class nxdvPluginWizard.TnxServerUnitModuleCreator.
TnxSharedPackageProjectCreator | This is class nxdvPluginWizard.TnxSharedPackageProjectCreator.
TnxTestClientApplicationProjectCreator | This is class nxdvPluginWizard.TnxTestClientApplicationProjectCreator.
TnxTestClientFormModuleCreator | This is class nxdvPluginWizard.TnxTestClientFormModuleCreator.
TnxTestServerApplicationProjectCreator | This is class nxdvPluginWizard.TnxTestServerApplicationProjectCreator.
TnxTestServerFormModuleCreator | This is class nxdvPluginWizard.TnxTestServerFormModuleCreator.
TnxUnitModuleCreator | This is class nxdvPluginWizard.TnxUnitModuleCreator.
Functions
Name | Description
Register | This is function nxdvPluginWizard.Register.
Interfaces
Name | Description
InxCreationInfo | This is class nxdvPluginWizard.InxCreationInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxUnitModuleCreatorClass | This is type nxdvPluginWizard.TnxUnitModuleCreatorClass.
Links
Classes, Functions, Interfaces, Legend, Topics, Types


Classes

Classes
Classes nxdvPluginWizard Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxApplicationProjectCreator | This is class nxdvPluginWizard.TnxApplicationProjectCreator.
TnxBasePackageProjectCreator | This is class nxdvPluginWizard.TnxBasePackageProjectCreator.
TnxBaseUnitModuleCreator | This is class nxdvPluginWizard.TnxBaseUnitModuleCreator.
TnxClientPackageProjectCreator | This is class nxdvPluginWizard.TnxClientPackageProjectCreator.
TnxClientUnitModuleCreator | This is class nxdvPluginWizard.TnxClientUnitModuleCreator.
TnxCommandHandlerPackageProjectCreator | This is class nxdvPluginWizard.TnxCommandHandlerPackageProjectCreator.
TnxCommandHandlerUnitModuleCreator | This is class nxdvPluginWizard.TnxCommandHandlerUnitModuleCreator.
TnxCreator | This is class nxdvPluginWizard.TnxCreator.
TnxDesignPackageProjectCreator | This is class nxdvPluginWizard.TnxDesignPackageProjectCreator.
TnxDesignUnitModuleCreator | This is class nxdvPluginWizard.TnxDesignUnitModuleCreator.
TnxFile | This is class nxdvPluginWizard.TnxFile.
TnxFormModuleCreator | This is class nxdvPluginWizard.TnxFormModuleCreator.
TnxMessagesPackageProjectCreator | This is class nxdvPluginWizard.TnxMessagesPackageProjectCreator.
TnxMessagesUnitModuleCreator | This is class nxdvPluginWizard.TnxMessagesUnitModuleCreator.
TnxModuleCreator | This is class nxdvPluginWizard.TnxModuleCreator.
TnxPackageProjectCreator | This is class nxdvPluginWizard.TnxPackageProjectCreator.
TnxPluginWizard | This is class nxdvPluginWizard.TnxPluginWizard.
TnxProjectCreator | This is class nxdvPluginWizard.TnxProjectCreator.
TnxProjectGroupCreator | This is class nxdvPluginWizard.TnxProjectGroupCreator.
TnxServerPackageProjectCreator | This is class nxdvPluginWizard.TnxServerPackageProjectCreator.
TnxServerUnitModuleCreator | This is class nxdvPluginWizard.TnxServerUnitModuleCreator.
TnxSharedPackageProjectCreator | This is class nxdvPluginWizard.TnxSharedPackageProjectCreator.
TnxTestClientApplicationProjectCreator | This is class nxdvPluginWizard.TnxTestClientApplicationProjectCreator.
TnxTestClientFormModuleCreator | This is class nxdvPluginWizard.TnxTestClientFormModuleCreator.
TnxTestServerApplicationProjectCreator | This is class nxdvPluginWizard.TnxTestServerApplicationProjectCreator.
TnxTestServerFormModuleCreator | This is class nxdvPluginWizard.TnxTestServerFormModuleCreator.
TnxUnitModuleCreator | This is class nxdvPluginWizard.TnxUnitModuleCreator.
Namespace

nxdvPluginWizard Namespace

Links
Classes, nxdvPluginWizard Namespace, Legend


TnxApplicationProjectCreator Class

TnxApplicationProjectCreator Class
TnxApplicationProjectCreator Methods TnxApplicationProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxApplicationProjectCreatornxdvPluginWizard_TnxApplicationProjectCreatornxdvPluginWizard_TnxApplicationProjectCreator
Syntax
Delphi
TnxApplicationProjectCreator = class(TnxProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxApplicationProjectCreator.

Group

Classes

Links
TnxApplicationProjectCreator Methods, TnxApplicationProjectCreator Members, nxdvPluginWizard, Classes


TnxApplicationProjectCreator Members

TnxApplicationProjectCreator Members
TnxApplicationProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxApplicationProjectCreator.

Class

TnxApplicationProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxApplicationProjectCreator
GetBaseFileName | This is GetBaseFileName, a member of class TnxApplicationProjectCreator.
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxApplicationProjectCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxApplicationProjectCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxApplicationProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxApplicationProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
Public Methods
Name | Description
Create | TnxCreator
Links
TnxApplicationProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxApplicationProjectCreator Methods

TnxApplicationProjectCreator Methods
TnxApplicationProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxApplicationProjectCreator class are listed here.

Class

TnxApplicationProjectCreator Class

Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxApplicationProjectCreator
GetBaseFileName | This is GetBaseFileName, a member of class TnxApplicationProjectCreator.
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxApplicationProjectCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxApplicationProjectCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxApplicationProjectCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxApplicationProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewProjectSource | IOTAProjectCreator
Links
TnxApplicationProjectCreator Class, Legend, Protected Methods


TnxApplicationProjectCreator.GetApplicationType Method

TnxApplicationProjectCreator.GetApplicationType Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetApplicationType: string; virtual;
Description

TnxPackageProjectCreator

TnxApplicationProjectCreator

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetBaseFileName Method

TnxApplicationProjectCreator.GetBaseFileName Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetBaseFileName: string; virtual;
Description

This is GetBaseFileName, a member of class TnxApplicationProjectCreator.

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetBaseFileNameForType Method

TnxApplicationProjectCreator.GetBaseFileNameForType Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetBaseFileNameForType(const aType: string): string; virtual;
Description

This is GetBaseFileNameForType, a member of class TnxApplicationProjectCreator.

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetCreatorType Method

TnxApplicationProjectCreator.GetCreatorType Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetCreatorType: string; override;
Description

IOTACreator

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetDescription Method

TnxApplicationProjectCreator.GetDescription Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; virtual;
Description

This is GetDescription, a member of class TnxApplicationProjectCreator.

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetFileName Method

TnxApplicationProjectCreator.GetFileName Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetFileName: string; override;
Description

IOTAProjectCreator

TnxProjectCreator

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.GetUnitCreatorClass Method

TnxApplicationProjectCreator.GetUnitCreatorClass Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; virtual;
Description

This is GetUnitCreatorClass, a member of class TnxApplicationProjectCreator.

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.NeedsAllEngines Method

TnxApplicationProjectCreator.NeedsAllEngines Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function NeedsAllEngines: Boolean; virtual;
Description

This is NeedsAllEngines, a member of class TnxApplicationProjectCreator.

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.NewDefaultProjectModule Method

TnxApplicationProjectCreator.NewDefaultProjectModule Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxApplicationProjectCreator.NewProjectSource Method

TnxApplicationProjectCreator.NewProjectSource Method
TnxApplicationProjectCreator Class TnxApplicationProjectCreator Members nxdvPluginWizard Namespace TnxApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function NewProjectSource(const ProjectName: string): IOTAFile; override;
Description

IOTAProjectCreator

Group

TnxApplicationProjectCreator Methods

Links
TnxApplicationProjectCreator Class, TnxApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxApplicationProjectCreator Methods


TnxBasePackageProjectCreator Class

TnxBasePackageProjectCreator Class
TnxBasePackageProjectCreator Methods TnxBasePackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxBasePackageProjectCreatornxdvPluginWizard_TnxBasePackageProjectCreatornxdvPluginWizard_TnxBasePackageProjectCreatornxdvPluginWizard_TnxBasePackageProjectCreator
Syntax
Delphi
TnxBasePackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxBasePackageProjectCreator.

Group

Classes

Links
TnxBasePackageProjectCreator Methods, TnxBasePackageProjectCreator Members, nxdvPluginWizard, Classes


TnxBasePackageProjectCreator Members

TnxBasePackageProjectCreator Members
TnxBasePackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBasePackageProjectCreator.

Class

TnxBasePackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxBasePackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxBasePackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxBasePackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBasePackageProjectCreator Methods

TnxBasePackageProjectCreator Methods
TnxBasePackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxBasePackageProjectCreator class are listed here.

Class

TnxBasePackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxBasePackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxBasePackageProjectCreator.
Links
TnxBasePackageProjectCreator Class, Legend, Protected Methods


TnxBasePackageProjectCreator.GetDescription Method

TnxBasePackageProjectCreator.GetDescription Method
TnxBasePackageProjectCreator Class TnxBasePackageProjectCreator Members nxdvPluginWizard Namespace TnxBasePackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxBasePackageProjectCreator

Group

TnxBasePackageProjectCreator Methods

Links
TnxBasePackageProjectCreator Class, TnxBasePackageProjectCreator Members, nxdvPluginWizard Namespace, TnxBasePackageProjectCreator Methods


TnxBasePackageProjectCreator.GetPackageType Method

TnxBasePackageProjectCreator.GetPackageType Method
TnxBasePackageProjectCreator Class TnxBasePackageProjectCreator Members nxdvPluginWizard Namespace TnxBasePackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxBasePackageProjectCreator Methods

Links
TnxBasePackageProjectCreator Class, TnxBasePackageProjectCreator Members, nxdvPluginWizard Namespace, TnxBasePackageProjectCreator Methods


TnxBasePackageProjectCreator.GetUnitCreatorClass Method

TnxBasePackageProjectCreator.GetUnitCreatorClass Method
TnxBasePackageProjectCreator Class TnxBasePackageProjectCreator Members nxdvPluginWizard Namespace TnxBasePackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxBasePackageProjectCreator.

Group

TnxBasePackageProjectCreator Methods

Links
TnxBasePackageProjectCreator Class, TnxBasePackageProjectCreator Members, nxdvPluginWizard Namespace, TnxBasePackageProjectCreator Methods


TnxBaseUnitModuleCreator Class

TnxBaseUnitModuleCreator Class
TnxBaseUnitModuleCreator Methods TnxBaseUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxBaseUnitModuleCreatornxdvPluginWizard_TnxBaseUnitModuleCreatornxdvPluginWizard_TnxBaseUnitModuleCreatornxdvPluginWizard_TnxBaseUnitModuleCreator
Syntax
Delphi
TnxBaseUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxBaseUnitModuleCreator.

Group

Classes

Links
TnxBaseUnitModuleCreator Methods, TnxBaseUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxBaseUnitModuleCreator Members

TnxBaseUnitModuleCreator Members
TnxBaseUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseUnitModuleCreator.

Class

TnxBaseUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxBaseUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxBaseUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseUnitModuleCreator Methods

TnxBaseUnitModuleCreator Methods
TnxBaseUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxBaseUnitModuleCreator class are listed here.

Class

TnxBaseUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxBaseUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxBaseUnitModuleCreator Class, Legend, Protected Methods


TnxBaseUnitModuleCreator.GetDescription Method

TnxBaseUnitModuleCreator.GetDescription Method
TnxBaseUnitModuleCreator Class TnxBaseUnitModuleCreator Members nxdvPluginWizard Namespace TnxBaseUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxBaseUnitModuleCreator

Group

TnxBaseUnitModuleCreator Methods

Links
TnxBaseUnitModuleCreator Class, TnxBaseUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxBaseUnitModuleCreator Methods


TnxBaseUnitModuleCreator.GetUnitType Method

TnxBaseUnitModuleCreator.GetUnitType Method
TnxBaseUnitModuleCreator Class TnxBaseUnitModuleCreator Members nxdvPluginWizard Namespace TnxBaseUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxBaseUnitModuleCreator Methods

Links
TnxBaseUnitModuleCreator Class, TnxBaseUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxBaseUnitModuleCreator Methods


TnxBaseUnitModuleCreator.NewImplSource Method

TnxBaseUnitModuleCreator.NewImplSource Method
TnxBaseUnitModuleCreator Class TnxBaseUnitModuleCreator Members nxdvPluginWizard Namespace TnxBaseUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxBaseUnitModuleCreator Methods

Links
TnxBaseUnitModuleCreator Class, TnxBaseUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxBaseUnitModuleCreator Methods


TnxClientPackageProjectCreator Class

TnxClientPackageProjectCreator Class
TnxClientPackageProjectCreator Methods TnxClientPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxClientPackageProjectCreatornxdvPluginWizard_TnxClientPackageProjectCreatornxdvPluginWizard_TnxClientPackageProjectCreatornxdvPluginWizard_TnxClientPackageProjectCreator
Syntax
Delphi
TnxClientPackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxClientPackageProjectCreator.

Group

Classes

Links
TnxClientPackageProjectCreator Methods, TnxClientPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxClientPackageProjectCreator Members

TnxClientPackageProjectCreator Members
TnxClientPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxClientPackageProjectCreator.

Class

TnxClientPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxClientPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxClientPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxClientPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxClientPackageProjectCreator Methods

TnxClientPackageProjectCreator Methods
TnxClientPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxClientPackageProjectCreator class are listed here.

Class

TnxClientPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxClientPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxClientPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxClientPackageProjectCreator Class, Legend, Protected Methods


TnxClientPackageProjectCreator.GetDescription Method

TnxClientPackageProjectCreator.GetDescription Method
TnxClientPackageProjectCreator Class TnxClientPackageProjectCreator Members nxdvPluginWizard Namespace TnxClientPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxClientPackageProjectCreator

Group

TnxClientPackageProjectCreator Methods

Links
TnxClientPackageProjectCreator Class, TnxClientPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxClientPackageProjectCreator Methods


TnxClientPackageProjectCreator.GetPackageType Method

TnxClientPackageProjectCreator.GetPackageType Method
TnxClientPackageProjectCreator Class TnxClientPackageProjectCreator Members nxdvPluginWizard Namespace TnxClientPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxClientPackageProjectCreator Methods

Links
TnxClientPackageProjectCreator Class, TnxClientPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxClientPackageProjectCreator Methods


TnxClientPackageProjectCreator.GetUnitCreatorClass Method

TnxClientPackageProjectCreator.GetUnitCreatorClass Method
TnxClientPackageProjectCreator Class TnxClientPackageProjectCreator Members nxdvPluginWizard Namespace TnxClientPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxClientPackageProjectCreator.

Group

TnxClientPackageProjectCreator Methods

Links
TnxClientPackageProjectCreator Class, TnxClientPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxClientPackageProjectCreator Methods


TnxClientPackageProjectCreator.NewDefaultProjectModule Method

TnxClientPackageProjectCreator.NewDefaultProjectModule Method
TnxClientPackageProjectCreator Class TnxClientPackageProjectCreator Members nxdvPluginWizard Namespace TnxClientPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxClientPackageProjectCreator Methods

Links
TnxClientPackageProjectCreator Class, TnxClientPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxClientPackageProjectCreator Methods


TnxClientUnitModuleCreator Class

TnxClientUnitModuleCreator Class
TnxClientUnitModuleCreator Methods TnxClientUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxClientUnitModuleCreatornxdvPluginWizard_TnxClientUnitModuleCreatornxdvPluginWizard_TnxClientUnitModuleCreatornxdvPluginWizard_TnxClientUnitModuleCreator
Syntax
Delphi
TnxClientUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxClientUnitModuleCreator.

Group

Classes

Links
TnxClientUnitModuleCreator Methods, TnxClientUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxClientUnitModuleCreator Members

TnxClientUnitModuleCreator Members
TnxClientUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxClientUnitModuleCreator.

Class

TnxClientUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxClientUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxClientUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxClientUnitModuleCreator Methods

TnxClientUnitModuleCreator Methods
TnxClientUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxClientUnitModuleCreator class are listed here.

Class

TnxClientUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxClientUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxClientUnitModuleCreator Class, Legend, Protected Methods


TnxClientUnitModuleCreator.GetDescription Method

TnxClientUnitModuleCreator.GetDescription Method
TnxClientUnitModuleCreator Class TnxClientUnitModuleCreator Members nxdvPluginWizard Namespace TnxClientUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxClientUnitModuleCreator

Group

TnxClientUnitModuleCreator Methods

Links
TnxClientUnitModuleCreator Class, TnxClientUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxClientUnitModuleCreator Methods


TnxClientUnitModuleCreator.GetUnitType Method

TnxClientUnitModuleCreator.GetUnitType Method
TnxClientUnitModuleCreator Class TnxClientUnitModuleCreator Members nxdvPluginWizard Namespace TnxClientUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxClientUnitModuleCreator Methods

Links
TnxClientUnitModuleCreator Class, TnxClientUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxClientUnitModuleCreator Methods


TnxClientUnitModuleCreator.NewImplSource Method

TnxClientUnitModuleCreator.NewImplSource Method
TnxClientUnitModuleCreator Class TnxClientUnitModuleCreator Members nxdvPluginWizard Namespace TnxClientUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxClientUnitModuleCreator Methods

Links
TnxClientUnitModuleCreator Class, TnxClientUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxClientUnitModuleCreator Methods


TnxCommandHandlerPackageProjectCreator Class

TnxCommandHandlerPackageProjectCreator Class
TnxCommandHandlerPackageProjectCreator Methods TnxCommandHandlerPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxCommandHandlerPackageProjectCreatornxdvPluginWizard_TnxCommandHandlerPackageProjectCreatornxdvPluginWizard_TnxCommandHandlerPackageProjectCreatornxdvPluginWizard_TnxCommandHandlerPackageProjectCreator
Syntax
Delphi
TnxCommandHandlerPackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxCommandHandlerPackageProjectCreator.

Group

Classes

Links
TnxCommandHandlerPackageProjectCreator Methods, TnxCommandHandlerPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxCommandHandlerPackageProjectCreator Members

TnxCommandHandlerPackageProjectCreator Members
TnxCommandHandlerPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCommandHandlerPackageProjectCreator.

Class

TnxCommandHandlerPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxCommandHandlerPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxCommandHandlerPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxCommandHandlerPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCommandHandlerPackageProjectCreator Methods

TnxCommandHandlerPackageProjectCreator Methods
TnxCommandHandlerPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxCommandHandlerPackageProjectCreator class are listed here.

Class

TnxCommandHandlerPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxCommandHandlerPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxCommandHandlerPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxCommandHandlerPackageProjectCreator Class, Legend, Protected Methods


TnxCommandHandlerPackageProjectCreator.GetDescription Method

TnxCommandHandlerPackageProjectCreator.GetDescription Method
TnxCommandHandlerPackageProjectCreator Class TnxCommandHandlerPackageProjectCreator Members nxdvPluginWizard Namespace TnxCommandHandlerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxCommandHandlerPackageProjectCreator

Group

TnxCommandHandlerPackageProjectCreator Methods

Links
TnxCommandHandlerPackageProjectCreator Class, TnxCommandHandlerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerPackageProjectCreator Methods


TnxCommandHandlerPackageProjectCreator.GetPackageType Method

TnxCommandHandlerPackageProjectCreator.GetPackageType Method
TnxCommandHandlerPackageProjectCreator Class TnxCommandHandlerPackageProjectCreator Members nxdvPluginWizard Namespace TnxCommandHandlerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxCommandHandlerPackageProjectCreator Methods

Links
TnxCommandHandlerPackageProjectCreator Class, TnxCommandHandlerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerPackageProjectCreator Methods


TnxCommandHandlerPackageProjectCreator.GetUnitCreatorClass Method

TnxCommandHandlerPackageProjectCreator.GetUnitCreatorClass Method
TnxCommandHandlerPackageProjectCreator Class TnxCommandHandlerPackageProjectCreator Members nxdvPluginWizard Namespace TnxCommandHandlerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxCommandHandlerPackageProjectCreator.

Group

TnxCommandHandlerPackageProjectCreator Methods

Links
TnxCommandHandlerPackageProjectCreator Class, TnxCommandHandlerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerPackageProjectCreator Methods


TnxCommandHandlerPackageProjectCreator.NewDefaultProjectModule Method

TnxCommandHandlerPackageProjectCreator.NewDefaultProjectModule Method
TnxCommandHandlerPackageProjectCreator Class TnxCommandHandlerPackageProjectCreator Members nxdvPluginWizard Namespace TnxCommandHandlerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxCommandHandlerPackageProjectCreator Methods

Links
TnxCommandHandlerPackageProjectCreator Class, TnxCommandHandlerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerPackageProjectCreator Methods


TnxCommandHandlerUnitModuleCreator Class

TnxCommandHandlerUnitModuleCreator Class
TnxCommandHandlerUnitModuleCreator Methods TnxCommandHandlerUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxCommandHandlerUnitModuleCreatornxdvPluginWizard_TnxCommandHandlerUnitModuleCreatornxdvPluginWizard_TnxCommandHandlerUnitModuleCreatornxdvPluginWizard_TnxCommandHandlerUnitModuleCreator
Syntax
Delphi
TnxCommandHandlerUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxCommandHandlerUnitModuleCreator.

Group

Classes

Links
TnxCommandHandlerUnitModuleCreator Methods, TnxCommandHandlerUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxCommandHandlerUnitModuleCreator Members

TnxCommandHandlerUnitModuleCreator Members
TnxCommandHandlerUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCommandHandlerUnitModuleCreator.

Class

TnxCommandHandlerUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxCommandHandlerUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxCommandHandlerUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCommandHandlerUnitModuleCreator Methods

TnxCommandHandlerUnitModuleCreator Methods
TnxCommandHandlerUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxCommandHandlerUnitModuleCreator class are listed here.

Class

TnxCommandHandlerUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxCommandHandlerUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxCommandHandlerUnitModuleCreator Class, Legend, Protected Methods


TnxCommandHandlerUnitModuleCreator.GetDescription Method

TnxCommandHandlerUnitModuleCreator.GetDescription Method
TnxCommandHandlerUnitModuleCreator Class TnxCommandHandlerUnitModuleCreator Members nxdvPluginWizard Namespace TnxCommandHandlerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxCommandHandlerUnitModuleCreator

Group

TnxCommandHandlerUnitModuleCreator Methods

Links
TnxCommandHandlerUnitModuleCreator Class, TnxCommandHandlerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerUnitModuleCreator Methods


TnxCommandHandlerUnitModuleCreator.GetUnitType Method

TnxCommandHandlerUnitModuleCreator.GetUnitType Method
TnxCommandHandlerUnitModuleCreator Class TnxCommandHandlerUnitModuleCreator Members nxdvPluginWizard Namespace TnxCommandHandlerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxCommandHandlerUnitModuleCreator Methods

Links
TnxCommandHandlerUnitModuleCreator Class, TnxCommandHandlerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerUnitModuleCreator Methods


TnxCommandHandlerUnitModuleCreator.NewImplSource Method

TnxCommandHandlerUnitModuleCreator.NewImplSource Method
TnxCommandHandlerUnitModuleCreator Class TnxCommandHandlerUnitModuleCreator Members nxdvPluginWizard Namespace TnxCommandHandlerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxCommandHandlerUnitModuleCreator Methods

Links
TnxCommandHandlerUnitModuleCreator Class, TnxCommandHandlerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxCommandHandlerUnitModuleCreator Methods


TnxCreator Class

TnxCreator Class
TnxCreator Fields TnxCreator Methods TnxCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxCreator
Syntax
Delphi
TnxCreator = class(TNotifierObject, IOTACreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxCreator.

Group

Classes

Links
TnxCreator Fields, TnxCreator Methods, TnxCreator Members, nxdvPluginWizard, Classes


TnxCreator Members

TnxCreator Members
TnxCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCreator.

Class

TnxCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetCreatorType | IOTACreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCreator.Create Constructor

TnxCreator.Create Constructor
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Class Send Feedback
Syntax
Delphi
constructor Create(aInfo: InxCreationInfo; aOwner: IOTAModule); virtual;
Description

TnxCreator

Class

TnxCreator Class

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Class


TnxCreator Fields

TnxCreator Fields
TnxCreator Class Legend Protected Fields Send Feedback

The fields of the TnxCreator class are listed here.

Class

TnxCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Links
TnxCreator Class, Legend, Protected Fields


TnxCreator.crInfo Field

TnxCreator.crInfo Field
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Fields Send Feedback
Syntax
Delphi
crInfo: InxCreationInfo;
Description

private

Group

TnxCreator Fields

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Fields


TnxCreator.crOwner Field

TnxCreator.crOwner Field
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Fields Send Feedback
Syntax
Delphi
crOwner: IOTAModule;
Description

This is crOwner, a member of class TnxCreator.

Group

TnxCreator Fields

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Fields


TnxCreator Methods

TnxCreator Methods
TnxCreator Class Legend Protected Methods Send Feedback

The methods of the TnxCreator class are listed here.

Class

TnxCreator Class

Protected Methods
Name | Description
GetCreatorType | IOTACreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
Links
TnxCreator Class, Legend, Protected Methods


TnxCreator.GetCreatorType Method

TnxCreator.GetCreatorType Method
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Methods Send Feedback
Syntax
Delphi
function GetCreatorType: string; virtual;
Description

IOTACreator

Group

TnxCreator Methods

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Methods


TnxCreator.GetExisting Method

TnxCreator.GetExisting Method
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Methods Send Feedback
Syntax
Delphi
function GetExisting: Boolean; virtual;
Description

This is GetExisting, a member of class TnxCreator.

Group

TnxCreator Methods

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Methods


TnxCreator.GetFileSystem Method

TnxCreator.GetFileSystem Method
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Methods Send Feedback
Syntax
Delphi
function GetFileSystem: string; virtual;
Description

This is GetFileSystem, a member of class TnxCreator.

Group

TnxCreator Methods

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Methods


TnxCreator.GetOwner Method

TnxCreator.GetOwner Method
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Methods Send Feedback
Syntax
Delphi
function GetOwner: IOTAModule; virtual;
Description

This is GetOwner, a member of class TnxCreator.

Group

TnxCreator Methods

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Methods


TnxCreator.GetUnnamed Method

TnxCreator.GetUnnamed Method
TnxCreator Class TnxCreator Members nxdvPluginWizard Namespace TnxCreator Methods Send Feedback
Syntax
Delphi
function GetUnnamed: Boolean; virtual;
Description

This is GetUnnamed, a member of class TnxCreator.

Group

TnxCreator Methods

Links
TnxCreator Class, TnxCreator Members, nxdvPluginWizard Namespace, TnxCreator Methods


TnxDesignPackageProjectCreator Class

TnxDesignPackageProjectCreator Class
TnxDesignPackageProjectCreator Methods TnxDesignPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxDesignPackageProjectCreatornxdvPluginWizard_TnxDesignPackageProjectCreatornxdvPluginWizard_TnxDesignPackageProjectCreatornxdvPluginWizard_TnxDesignPackageProjectCreator
Syntax
Delphi
TnxDesignPackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxDesignPackageProjectCreator.

Group

Classes

Links
TnxDesignPackageProjectCreator Methods, TnxDesignPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxDesignPackageProjectCreator Members

TnxDesignPackageProjectCreator Members
TnxDesignPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDesignPackageProjectCreator.

Class

TnxDesignPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxDesignPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxDesignPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxDesignPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxDesignPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxDesignPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDesignPackageProjectCreator Methods

TnxDesignPackageProjectCreator Methods
TnxDesignPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxDesignPackageProjectCreator class are listed here.

Class

TnxDesignPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxDesignPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxDesignPackageProjectCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxDesignPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxDesignPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxDesignPackageProjectCreator Class, Legend, Protected Methods


TnxDesignPackageProjectCreator.GetDescription Method

TnxDesignPackageProjectCreator.GetDescription Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxDesignPackageProjectCreator

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignPackageProjectCreator.GetPackageType Method

TnxDesignPackageProjectCreator.GetPackageType Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignPackageProjectCreator.GetUnitCreatorClass Method

TnxDesignPackageProjectCreator.GetUnitCreatorClass Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxDesignPackageProjectCreator.

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignPackageProjectCreator.IsDesignTime Method

TnxDesignPackageProjectCreator.IsDesignTime Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function IsDesignTime: Boolean; override;
Description

This is IsDesignTime, a member of class TnxDesignPackageProjectCreator.

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignPackageProjectCreator.IsRunTime Method

TnxDesignPackageProjectCreator.IsRunTime Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function IsRunTime: Boolean; override;
Description

This is IsRunTime, a member of class TnxDesignPackageProjectCreator.

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignPackageProjectCreator.NewDefaultProjectModule Method

TnxDesignPackageProjectCreator.NewDefaultProjectModule Method
TnxDesignPackageProjectCreator Class TnxDesignPackageProjectCreator Members nxdvPluginWizard Namespace TnxDesignPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxDesignPackageProjectCreator Methods

Links
TnxDesignPackageProjectCreator Class, TnxDesignPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxDesignPackageProjectCreator Methods


TnxDesignUnitModuleCreator Class

TnxDesignUnitModuleCreator Class
TnxDesignUnitModuleCreator Methods TnxDesignUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxDesignUnitModuleCreatornxdvPluginWizard_TnxDesignUnitModuleCreatornxdvPluginWizard_TnxDesignUnitModuleCreatornxdvPluginWizard_TnxDesignUnitModuleCreator
Syntax
Delphi
TnxDesignUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxDesignUnitModuleCreator.

Group

Classes

Links
TnxDesignUnitModuleCreator Methods, TnxDesignUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxDesignUnitModuleCreator Members

TnxDesignUnitModuleCreator Members
TnxDesignUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDesignUnitModuleCreator.

Class

TnxDesignUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxDesignUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxDesignUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDesignUnitModuleCreator Methods

TnxDesignUnitModuleCreator Methods
TnxDesignUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxDesignUnitModuleCreator class are listed here.

Class

TnxDesignUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxDesignUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxDesignUnitModuleCreator Class, Legend, Protected Methods


TnxDesignUnitModuleCreator.GetDescription Method

TnxDesignUnitModuleCreator.GetDescription Method
TnxDesignUnitModuleCreator Class TnxDesignUnitModuleCreator Members nxdvPluginWizard Namespace TnxDesignUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxDesignUnitModuleCreator

Group

TnxDesignUnitModuleCreator Methods

Links
TnxDesignUnitModuleCreator Class, TnxDesignUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxDesignUnitModuleCreator Methods


TnxDesignUnitModuleCreator.GetUnitType Method

TnxDesignUnitModuleCreator.GetUnitType Method
TnxDesignUnitModuleCreator Class TnxDesignUnitModuleCreator Members nxdvPluginWizard Namespace TnxDesignUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxDesignUnitModuleCreator Methods

Links
TnxDesignUnitModuleCreator Class, TnxDesignUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxDesignUnitModuleCreator Methods


TnxDesignUnitModuleCreator.NewImplSource Method

TnxDesignUnitModuleCreator.NewImplSource Method
TnxDesignUnitModuleCreator Class TnxDesignUnitModuleCreator Members nxdvPluginWizard Namespace TnxDesignUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxDesignUnitModuleCreator Methods

Links
TnxDesignUnitModuleCreator Class, TnxDesignUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxDesignUnitModuleCreator Methods


TnxFile Class

TnxFile Class
TnxFile Methods TnxFile Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxFile
Syntax
Delphi
TnxFile = class(TNotifierObject, IOTAFile);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxFile.

Group

Classes

Links
TnxFile Methods, TnxFile Members, nxdvPluginWizard, Classes


TnxFile Members

TnxFile Members
TnxFile Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFile.

Class

TnxFile Class

Protected Methods
Name | Description
GetAge | This is GetAge, a member of class TnxFile.
GetSource | IOTAFile
Public Methods
Name | Description
Create | TnxFile
Links
TnxFile Class, Legend, Protected Methods, Public Methods


TnxFile.Create Constructor

TnxFile.Create Constructor
TnxFile Class TnxFile Members nxdvPluginWizard Namespace TnxFile Class Send Feedback
Syntax
Delphi
constructor Create(aSource: string; aAge: TDateTime);
Description

TnxFile

Class

TnxFile Class

Links
TnxFile Class, TnxFile Members, nxdvPluginWizard Namespace, TnxFile Class


TnxFile Methods

TnxFile Methods
TnxFile Class Legend Protected Methods Send Feedback

The methods of the TnxFile class are listed here.

Class

TnxFile Class

Protected Methods
Name | Description
GetAge | This is GetAge, a member of class TnxFile.
GetSource | IOTAFile
Links
TnxFile Class, Legend, Protected Methods


TnxFile.GetAge Method

TnxFile.GetAge Method
TnxFile Class TnxFile Members nxdvPluginWizard Namespace TnxFile Methods Send Feedback
Syntax
Delphi
function GetAge: TDateTime;
Description

This is GetAge, a member of class TnxFile.

Group

TnxFile Methods

Links
TnxFile Class, TnxFile Members, nxdvPluginWizard Namespace, TnxFile Methods


TnxFile.GetSource Method

TnxFile.GetSource Method
TnxFile Class TnxFile Members nxdvPluginWizard Namespace TnxFile Methods Send Feedback
Syntax
Delphi
function GetSource: string;
Description

IOTAFile

Group

TnxFile Methods

Links
TnxFile Class, TnxFile Members, nxdvPluginWizard Namespace, TnxFile Methods


TnxFormModuleCreator Class

TnxFormModuleCreator Class
TnxFormModuleCreator Methods TnxFormModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxFormModuleCreatornxdvPluginWizard_TnxFormModuleCreatornxdvPluginWizard_TnxFormModuleCreatornxdvPluginWizard_TnxFormModuleCreator
Syntax
Delphi
TnxFormModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxFormModuleCreator.

Group

Classes

Links
TnxFormModuleCreator Methods, TnxFormModuleCreator Members, nxdvPluginWizard, Classes


TnxFormModuleCreator Members

TnxFormModuleCreator Members
TnxFormModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFormModuleCreator.

Class

TnxFormModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator TnxFormModuleCreator
GetDescription | This is GetDescription, a member of class TnxUnitModuleCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxFormModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | This is NewImplSource, a member of class TnxModuleCreator.
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxFormModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxFormModuleCreator Methods

TnxFormModuleCreator Methods
TnxFormModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxFormModuleCreator class are listed here.

Class

TnxFormModuleCreator Class

Protected Methods
Name | Description
GetCreatorType | IOTACreator TnxFormModuleCreator
GetFormName | This is GetFormName, a member of class TnxFormModuleCreator.
Links
TnxFormModuleCreator Class, Legend, Protected Methods


TnxFormModuleCreator.GetCreatorType Method

TnxFormModuleCreator.GetCreatorType Method
TnxFormModuleCreator Class TnxFormModuleCreator Members nxdvPluginWizard Namespace TnxFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetCreatorType: string; override;
Description

IOTACreator

TnxFormModuleCreator

Group

TnxFormModuleCreator Methods

Links
TnxFormModuleCreator Class, TnxFormModuleCreator Members, nxdvPluginWizard Namespace, TnxFormModuleCreator Methods


TnxFormModuleCreator.GetFormName Method

TnxFormModuleCreator.GetFormName Method
TnxFormModuleCreator Class TnxFormModuleCreator Members nxdvPluginWizard Namespace TnxFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetFormName: string; override;
Description

This is GetFormName, a member of class TnxFormModuleCreator.

Group

TnxFormModuleCreator Methods

Links
TnxFormModuleCreator Class, TnxFormModuleCreator Members, nxdvPluginWizard Namespace, TnxFormModuleCreator Methods


TnxMessagesPackageProjectCreator Class

TnxMessagesPackageProjectCreator Class
TnxMessagesPackageProjectCreator Methods TnxMessagesPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxMessagesPackageProjectCreatornxdvPluginWizard_TnxMessagesPackageProjectCreatornxdvPluginWizard_TnxMessagesPackageProjectCreatornxdvPluginWizard_TnxMessagesPackageProjectCreator
Syntax
Delphi
TnxMessagesPackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxMessagesPackageProjectCreator.

Group

Classes

Links
TnxMessagesPackageProjectCreator Methods, TnxMessagesPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxMessagesPackageProjectCreator Members

TnxMessagesPackageProjectCreator Members
TnxMessagesPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMessagesPackageProjectCreator.

Class

TnxMessagesPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxMessagesPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxMessagesPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxMessagesPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxMessagesPackageProjectCreator Methods

TnxMessagesPackageProjectCreator Methods
TnxMessagesPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxMessagesPackageProjectCreator class are listed here.

Class

TnxMessagesPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxMessagesPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxMessagesPackageProjectCreator.
Links
TnxMessagesPackageProjectCreator Class, Legend, Protected Methods


TnxMessagesPackageProjectCreator.GetDescription Method

TnxMessagesPackageProjectCreator.GetDescription Method
TnxMessagesPackageProjectCreator Class TnxMessagesPackageProjectCreator Members nxdvPluginWizard Namespace TnxMessagesPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxMessagesPackageProjectCreator

Group

TnxMessagesPackageProjectCreator Methods

Links
TnxMessagesPackageProjectCreator Class, TnxMessagesPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxMessagesPackageProjectCreator Methods


TnxMessagesPackageProjectCreator.GetPackageType Method

TnxMessagesPackageProjectCreator.GetPackageType Method
TnxMessagesPackageProjectCreator Class TnxMessagesPackageProjectCreator Members nxdvPluginWizard Namespace TnxMessagesPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxMessagesPackageProjectCreator Methods

Links
TnxMessagesPackageProjectCreator Class, TnxMessagesPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxMessagesPackageProjectCreator Methods


TnxMessagesPackageProjectCreator.GetUnitCreatorClass Method

TnxMessagesPackageProjectCreator.GetUnitCreatorClass Method
TnxMessagesPackageProjectCreator Class TnxMessagesPackageProjectCreator Members nxdvPluginWizard Namespace TnxMessagesPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxMessagesPackageProjectCreator.

Group

TnxMessagesPackageProjectCreator Methods

Links
TnxMessagesPackageProjectCreator Class, TnxMessagesPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxMessagesPackageProjectCreator Methods


TnxMessagesUnitModuleCreator Class

TnxMessagesUnitModuleCreator Class
TnxMessagesUnitModuleCreator Methods TnxMessagesUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxMessagesUnitModuleCreatornxdvPluginWizard_TnxMessagesUnitModuleCreatornxdvPluginWizard_TnxMessagesUnitModuleCreatornxdvPluginWizard_TnxMessagesUnitModuleCreator
Syntax
Delphi
TnxMessagesUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxMessagesUnitModuleCreator.

Group

Classes

Links
TnxMessagesUnitModuleCreator Methods, TnxMessagesUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxMessagesUnitModuleCreator Members

TnxMessagesUnitModuleCreator Members
TnxMessagesUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMessagesUnitModuleCreator.

Class

TnxMessagesUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxMessagesUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxMessagesUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxMessagesUnitModuleCreator Methods

TnxMessagesUnitModuleCreator Methods
TnxMessagesUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxMessagesUnitModuleCreator class are listed here.

Class

TnxMessagesUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxMessagesUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxMessagesUnitModuleCreator Class, Legend, Protected Methods


TnxMessagesUnitModuleCreator.GetDescription Method

TnxMessagesUnitModuleCreator.GetDescription Method
TnxMessagesUnitModuleCreator Class TnxMessagesUnitModuleCreator Members nxdvPluginWizard Namespace TnxMessagesUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxMessagesUnitModuleCreator

Group

TnxMessagesUnitModuleCreator Methods

Links
TnxMessagesUnitModuleCreator Class, TnxMessagesUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxMessagesUnitModuleCreator Methods


TnxMessagesUnitModuleCreator.GetUnitType Method

TnxMessagesUnitModuleCreator.GetUnitType Method
TnxMessagesUnitModuleCreator Class TnxMessagesUnitModuleCreator Members nxdvPluginWizard Namespace TnxMessagesUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxMessagesUnitModuleCreator Methods

Links
TnxMessagesUnitModuleCreator Class, TnxMessagesUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxMessagesUnitModuleCreator Methods


TnxMessagesUnitModuleCreator.NewImplSource Method

TnxMessagesUnitModuleCreator.NewImplSource Method
TnxMessagesUnitModuleCreator Class TnxMessagesUnitModuleCreator Members nxdvPluginWizard Namespace TnxMessagesUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxMessagesUnitModuleCreator Methods

Links
TnxMessagesUnitModuleCreator Class, TnxMessagesUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxMessagesUnitModuleCreator Methods


TnxModuleCreator Class

TnxModuleCreator Class
TnxModuleCreator Methods TnxModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxModuleCreatornxdvPluginWizard_TnxModuleCreator
Syntax
Delphi
TnxModuleCreator = class(TnxCreator, IOTAModuleCreator, IOTAAdditionalFilesModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxModuleCreator.

Group

Classes

Links
TnxModuleCreator Methods, TnxModuleCreator Members, nxdvPluginWizard, Classes


TnxModuleCreator Members

TnxModuleCreator Members
TnxModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxModuleCreator.

Class

TnxModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetCreatorType | IOTACreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | This is NewImplSource, a member of class TnxModuleCreator.
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxModuleCreator Methods

TnxModuleCreator Methods
TnxModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxModuleCreator class are listed here.

Class

TnxModuleCreator Class

Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | This is NewImplSource, a member of class TnxModuleCreator.
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Links
TnxModuleCreator Class, Legend, Protected Methods


TnxModuleCreator.FormCreated Method

TnxModuleCreator.FormCreated Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
procedure FormCreated(const FormEditor: IOTAFormEditor); virtual;
Description

TnxModuleCreator

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetAdditionalFileExt Method

TnxModuleCreator.GetAdditionalFileExt Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetAdditionalFileExt(I: Integer): string; virtual;
Description

This is GetAdditionalFileExt, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetAdditionalFileName Method

TnxModuleCreator.GetAdditionalFileName Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetAdditionalFileName(I: Integer): string; virtual;
Description

This is GetAdditionalFileName, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetAdditionalFilesCount Method

TnxModuleCreator.GetAdditionalFilesCount Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetAdditionalFilesCount: Integer; virtual;
Description

IOTAAdditionalFilesModuleCreator

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetAncestorName Method

TnxModuleCreator.GetAncestorName Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetAncestorName: string; virtual;
Description

IOTAModuleCreator

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetFormName Method

TnxModuleCreator.GetFormName Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetFormName: string; virtual;
Description

This is GetFormName, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetImplFileName Method

TnxModuleCreator.GetImplFileName Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetImplFileName: string; virtual;
Description

This is GetImplFileName, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetIntfFileName Method

TnxModuleCreator.GetIntfFileName Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetIntfFileName: string; virtual;
Description

This is GetIntfFileName, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetMainForm Method

TnxModuleCreator.GetMainForm Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetMainForm: Boolean; virtual;
Description

This is GetMainForm, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetShowForm Method

TnxModuleCreator.GetShowForm Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetShowForm: Boolean; virtual;
Description

This is GetShowForm, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.GetShowSource Method

TnxModuleCreator.GetShowSource Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function GetShowSource: Boolean; virtual;
Description

This is GetShowSource, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.NewAdditionalFileSource Method

TnxModuleCreator.NewAdditionalFileSource Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function NewAdditionalFileSource(I: Integer; const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; virtual;
Description

This is NewAdditionalFileSource, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.NewFormFile Method

TnxModuleCreator.NewFormFile Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function NewFormFile(const FormIdent: string; const AncestorIdent: string): IOTAFile; virtual;
Description

This is NewFormFile, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.NewImplSource Method

TnxModuleCreator.NewImplSource Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; virtual;
Description

This is NewImplSource, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxModuleCreator.NewIntfSource Method

TnxModuleCreator.NewIntfSource Method
TnxModuleCreator Class TnxModuleCreator Members nxdvPluginWizard Namespace TnxModuleCreator Methods Send Feedback
Syntax
Delphi
function NewIntfSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; virtual;
Description

This is NewIntfSource, a member of class TnxModuleCreator.

Group

TnxModuleCreator Methods

Links
TnxModuleCreator Class, TnxModuleCreator Members, nxdvPluginWizard Namespace, TnxModuleCreator Methods


TnxPackageProjectCreator Class

TnxPackageProjectCreator Class
TnxPackageProjectCreator Methods TnxPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxPackageProjectCreatornxdvPluginWizard_TnxPackageProjectCreatornxdvPluginWizard_TnxPackageProjectCreator
Syntax
Delphi
TnxPackageProjectCreator = class(TnxProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxPackageProjectCreator.

Group

Classes

Links
TnxPackageProjectCreator Methods, TnxPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxPackageProjectCreator Members

TnxPackageProjectCreator Members
TnxPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPackageProjectCreator.

Class

TnxPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxPackageProjectCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
Public Methods
Name | Description
Create | TnxCreator
Links
TnxPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxPackageProjectCreator Methods

TnxPackageProjectCreator Methods
TnxPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxPackageProjectCreator class are listed here.

Class

TnxPackageProjectCreator Class

Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxPackageProjectCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxPackageProjectCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewProjectSource | IOTAProjectCreator
Links
TnxPackageProjectCreator Class, Legend, Protected Methods


TnxPackageProjectCreator.GetBaseFileName Method

TnxPackageProjectCreator.GetBaseFileName Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetBaseFileName: string; virtual;
Description

TnxPackageProjectCreator

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetBaseFileNameForType Method

TnxPackageProjectCreator.GetBaseFileNameForType Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetBaseFileNameForType(const aType: string): string; virtual;
Description

This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetCreatorType Method

TnxPackageProjectCreator.GetCreatorType Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetCreatorType: string; override;
Description

IOTACreator

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetDescription Method

TnxPackageProjectCreator.GetDescription Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; virtual;
Description

This is GetDescription, a member of class TnxPackageProjectCreator.

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetFileName Method

TnxPackageProjectCreator.GetFileName Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetFileName: string; override;
Description

IOTAProjectCreator

TnxProjectCreator

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetPackageType Method

TnxPackageProjectCreator.GetPackageType Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; virtual;
Description

TnxPackageProjectCreator

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.GetUnitCreatorClass Method

TnxPackageProjectCreator.GetUnitCreatorClass Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; virtual;
Description

This is GetUnitCreatorClass, a member of class TnxPackageProjectCreator.

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.IsDesignTime Method

TnxPackageProjectCreator.IsDesignTime Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function IsDesignTime: Boolean; virtual;
Description

This is IsDesignTime, a member of class TnxPackageProjectCreator.

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.IsRunTime Method

TnxPackageProjectCreator.IsRunTime Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function IsRunTime: Boolean; virtual;
Description

This is IsRunTime, a member of class TnxPackageProjectCreator.

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.NewDefaultProjectModule Method

TnxPackageProjectCreator.NewDefaultProjectModule Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPackageProjectCreator.NewProjectSource Method

TnxPackageProjectCreator.NewProjectSource Method
TnxPackageProjectCreator Class TnxPackageProjectCreator Members nxdvPluginWizard Namespace TnxPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function NewProjectSource(const ProjectName: string): IOTAFile; override;
Description

IOTAProjectCreator

Group

TnxPackageProjectCreator Methods

Links
TnxPackageProjectCreator Class, TnxPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxPackageProjectCreator Methods


TnxPluginWizard Class

TnxPluginWizard Class
TnxPluginWizard Methods TnxPluginWizard Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxPluginWizard
Syntax
Delphi
TnxPluginWizard = class(TNotifierObject, IOTAWizard, IOTARepositoryWizard, IOTARepositoryWizard60, IOTARepositoryWizard80, IOTAProjectWizard);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxPluginWizard.

Group

Classes

Links
TnxPluginWizard Methods, TnxPluginWizard Members, nxdvPluginWizard, Classes


TnxPluginWizard Members

TnxPluginWizard Members
TnxPluginWizard Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPluginWizard.

Class

TnxPluginWizard Class

Protected Methods
Name | Description
Execute | This is Execute, a member of class TnxPluginWizard.
GetAuthor | IOTARepositoryWizard
GetComment | This is GetComment, a member of class TnxPluginWizard.
GetDesigner | IOTARepositoryWizard60
GetGalleryCategory | IOTARepositoryWizard80
GetGlyph | This is GetGlyph, a member of class TnxPluginWizard.
GetIDString | IOTAWizard
GetName | This is GetName, a member of class TnxPluginWizard.
GetPage | This is GetPage, a member of class TnxPluginWizard.
GetPersonality | This is GetPersonality, a member of class TnxPluginWizard.
GetState | This is GetState, a member of class TnxPluginWizard.
Public Methods
Name | Description
Create | TnxPluginWizard
Links
TnxPluginWizard Class, Legend, Protected Methods, Public Methods


TnxPluginWizard.Create Constructor

TnxPluginWizard.Create Constructor
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxPluginWizard

Class

TnxPluginWizard Class

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Class


TnxPluginWizard Methods

TnxPluginWizard Methods
TnxPluginWizard Class Legend Protected Methods Send Feedback

The methods of the TnxPluginWizard class are listed here.

Class

TnxPluginWizard Class

Protected Methods
Name | Description
Execute | This is Execute, a member of class TnxPluginWizard.
GetAuthor | IOTARepositoryWizard
GetComment | This is GetComment, a member of class TnxPluginWizard.
GetDesigner | IOTARepositoryWizard60
GetGalleryCategory | IOTARepositoryWizard80
GetGlyph | This is GetGlyph, a member of class TnxPluginWizard.
GetIDString | IOTAWizard
GetName | This is GetName, a member of class TnxPluginWizard.
GetPage | This is GetPage, a member of class TnxPluginWizard.
GetPersonality | This is GetPersonality, a member of class TnxPluginWizard.
GetState | This is GetState, a member of class TnxPluginWizard.
Links
TnxPluginWizard Class, Legend, Protected Methods


TnxPluginWizard.Execute Method

TnxPluginWizard.Execute Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
procedure Execute;
Description

This is Execute, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetAuthor Method

TnxPluginWizard.GetAuthor Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetAuthor: string;
Description

IOTARepositoryWizard

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetComment Method

TnxPluginWizard.GetComment Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetComment: string;
Description

This is GetComment, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetDesigner Method

TnxPluginWizard.GetDesigner Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetDesigner: string;
Description

IOTARepositoryWizard60

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetGalleryCategory Method

TnxPluginWizard.GetGalleryCategory Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetGalleryCategory: IOTAGalleryCategory;
Description

IOTARepositoryWizard80

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetGlyph Method

TnxPluginWizard.GetGlyph Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetGlyph: Cardinal;
Description

This is GetGlyph, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetIDString Method

TnxPluginWizard.GetIDString Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetIDString: string;
Description

IOTAWizard

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetName Method

TnxPluginWizard.GetName Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetName: string;
Description

This is GetName, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetPage Method

TnxPluginWizard.GetPage Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetPage: string;
Description

This is GetPage, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetPersonality Method

TnxPluginWizard.GetPersonality Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetPersonality: string;
Description

This is GetPersonality, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxPluginWizard.GetState Method

TnxPluginWizard.GetState Method
TnxPluginWizard Class TnxPluginWizard Members nxdvPluginWizard Namespace TnxPluginWizard Methods Send Feedback
Syntax
Delphi
function GetState: TWizardState;
Description

This is GetState, a member of class TnxPluginWizard.

Group

TnxPluginWizard Methods

Links
TnxPluginWizard Class, TnxPluginWizard Members, nxdvPluginWizard Namespace, TnxPluginWizard Methods


TnxProjectCreator Class

TnxProjectCreator Class
TnxProjectCreator Methods TnxProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxProjectCreatornxdvPluginWizard_TnxProjectCreator
Syntax
Delphi
TnxProjectCreator = class(TnxCreator, IOTAProjectCreator, IOTAProjectCreator50, IOTAProjectCreator80);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxProjectCreator.

Group

Classes

Links
TnxProjectCreator Methods, TnxProjectCreator Members, nxdvPluginWizard, Classes


TnxProjectCreator Members

TnxProjectCreator Members
TnxProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxProjectCreator.

Class

TnxProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetCreatorType | IOTACreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxProjectCreator Methods

TnxProjectCreator Methods
TnxProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxProjectCreator class are listed here.

Class

TnxProjectCreator Class

Protected Methods
Name | Description
GetFileName | IOTAProjectCreator TnxProjectCreator
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Links
TnxProjectCreator Class, Legend, Protected Methods


TnxProjectCreator.GetFileName Method

TnxProjectCreator.GetFileName Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function GetFileName: string; virtual;
Description

IOTAProjectCreator

TnxProjectCreator

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.GetOptionFileName Method

TnxProjectCreator.GetOptionFileName Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function GetOptionFileName: string;
Description

This is GetOptionFileName, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.GetProjectPersonality Method

TnxProjectCreator.GetProjectPersonality Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function GetProjectPersonality: string; virtual;
Description

IOTAProjectCreator80

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.GetShowSource Method

TnxProjectCreator.GetShowSource Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function GetShowSource: Boolean; virtual;
Description

This is GetShowSource, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.NewDefaultModule Method

TnxProjectCreator.NewDefaultModule Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultModule;
Description

This is NewDefaultModule, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.NewDefaultProjectModule Method

TnxProjectCreator.NewDefaultProjectModule Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); virtual;
Description

IOTAProjectCreator50

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.NewOptionSource Method

TnxProjectCreator.NewOptionSource Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function NewOptionSource(const ProjectName: string): IOTAFile;
Description

This is NewOptionSource, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.NewProjectResource Method

TnxProjectCreator.NewProjectResource Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewProjectResource(const Project: IOTAProject); virtual;
Description

This is NewProjectResource, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectCreator.NewProjectSource Method

TnxProjectCreator.NewProjectSource Method
TnxProjectCreator Class TnxProjectCreator Members nxdvPluginWizard Namespace TnxProjectCreator Methods Send Feedback
Syntax
Delphi
function NewProjectSource(const ProjectName: string): IOTAFile; virtual;
Description

This is NewProjectSource, a member of class TnxProjectCreator.

Group

TnxProjectCreator Methods

Links
TnxProjectCreator Class, TnxProjectCreator Members, nxdvPluginWizard Namespace, TnxProjectCreator Methods


TnxProjectGroupCreator Class

TnxProjectGroupCreator Class
TnxProjectGroupCreator Methods TnxProjectGroupCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxProjectGroupCreatornxdvPluginWizard_TnxProjectGroupCreator
Syntax
Delphi
TnxProjectGroupCreator = class(TnxCreator, IOTAProjectGroupCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxProjectGroupCreator.

Group

Classes

Links
TnxProjectGroupCreator Methods, TnxProjectGroupCreator Members, nxdvPluginWizard, Classes


TnxProjectGroupCreator Members

TnxProjectGroupCreator Members
TnxProjectGroupCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxProjectGroupCreator.

Class

TnxProjectGroupCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetCreatorType | IOTACreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectGroupCreator TnxProjectGroupCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowSource | This is GetShowSource, a member of class TnxProjectGroupCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewProjectGroupSource | This is NewProjectGroupSource, a member of class TnxProjectGroupCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxProjectGroupCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxProjectGroupCreator Methods

TnxProjectGroupCreator Methods
TnxProjectGroupCreator Class Legend Protected Methods Send Feedback

The methods of the TnxProjectGroupCreator class are listed here.

Class

TnxProjectGroupCreator Class

Protected Methods
Name | Description
GetFileName | IOTAProjectGroupCreator TnxProjectGroupCreator
GetShowSource | This is GetShowSource, a member of class TnxProjectGroupCreator.
NewProjectGroupSource | This is NewProjectGroupSource, a member of class TnxProjectGroupCreator.
Links
TnxProjectGroupCreator Class, Legend, Protected Methods


TnxProjectGroupCreator.GetFileName Method

TnxProjectGroupCreator.GetFileName Method
TnxProjectGroupCreator Class TnxProjectGroupCreator Members nxdvPluginWizard Namespace TnxProjectGroupCreator Methods Send Feedback
Syntax
Delphi
function GetFileName: string; virtual;
Description

IOTAProjectGroupCreator

TnxProjectGroupCreator

Group

TnxProjectGroupCreator Methods

Links
TnxProjectGroupCreator Class, TnxProjectGroupCreator Members, nxdvPluginWizard Namespace, TnxProjectGroupCreator Methods


TnxProjectGroupCreator.GetShowSource Method

TnxProjectGroupCreator.GetShowSource Method
TnxProjectGroupCreator Class TnxProjectGroupCreator Members nxdvPluginWizard Namespace TnxProjectGroupCreator Methods Send Feedback
Syntax
Delphi
function GetShowSource: Boolean; virtual;
Description

This is GetShowSource, a member of class TnxProjectGroupCreator.

Group

TnxProjectGroupCreator Methods

Links
TnxProjectGroupCreator Class, TnxProjectGroupCreator Members, nxdvPluginWizard Namespace, TnxProjectGroupCreator Methods


TnxProjectGroupCreator.NewProjectGroupSource Method

TnxProjectGroupCreator.NewProjectGroupSource Method
TnxProjectGroupCreator Class TnxProjectGroupCreator Members nxdvPluginWizard Namespace TnxProjectGroupCreator Methods Send Feedback
Syntax
Delphi
function NewProjectGroupSource(const ProjectGroupName: string): IOTAFile;
Description

This is NewProjectGroupSource, a member of class TnxProjectGroupCreator.

Group

TnxProjectGroupCreator Methods

Links
TnxProjectGroupCreator Class, TnxProjectGroupCreator Members, nxdvPluginWizard Namespace, TnxProjectGroupCreator Methods


TnxServerPackageProjectCreator Class

TnxServerPackageProjectCreator Class
TnxServerPackageProjectCreator Methods TnxServerPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxServerPackageProjectCreatornxdvPluginWizard_TnxServerPackageProjectCreatornxdvPluginWizard_TnxServerPackageProjectCreatornxdvPluginWizard_TnxServerPackageProjectCreator
Syntax
Delphi
TnxServerPackageProjectCreator = class(TnxPackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxServerPackageProjectCreator.

Group

Classes

Links
TnxServerPackageProjectCreator Methods, TnxServerPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxServerPackageProjectCreator Members

TnxServerPackageProjectCreator Members
TnxServerPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxServerPackageProjectCreator.

Class

TnxServerPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxServerPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxServerPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxServerPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxServerPackageProjectCreator Methods

TnxServerPackageProjectCreator Methods
TnxServerPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxServerPackageProjectCreator class are listed here.

Class

TnxServerPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxServerPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxServerPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxServerPackageProjectCreator Class, Legend, Protected Methods


TnxServerPackageProjectCreator.GetDescription Method

TnxServerPackageProjectCreator.GetDescription Method
TnxServerPackageProjectCreator Class TnxServerPackageProjectCreator Members nxdvPluginWizard Namespace TnxServerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxServerPackageProjectCreator

Group

TnxServerPackageProjectCreator Methods

Links
TnxServerPackageProjectCreator Class, TnxServerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxServerPackageProjectCreator Methods


TnxServerPackageProjectCreator.GetPackageType Method

TnxServerPackageProjectCreator.GetPackageType Method
TnxServerPackageProjectCreator Class TnxServerPackageProjectCreator Members nxdvPluginWizard Namespace TnxServerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxServerPackageProjectCreator Methods

Links
TnxServerPackageProjectCreator Class, TnxServerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxServerPackageProjectCreator Methods


TnxServerPackageProjectCreator.GetUnitCreatorClass Method

TnxServerPackageProjectCreator.GetUnitCreatorClass Method
TnxServerPackageProjectCreator Class TnxServerPackageProjectCreator Members nxdvPluginWizard Namespace TnxServerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxServerPackageProjectCreator.

Group

TnxServerPackageProjectCreator Methods

Links
TnxServerPackageProjectCreator Class, TnxServerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxServerPackageProjectCreator Methods


TnxServerPackageProjectCreator.NewDefaultProjectModule Method

TnxServerPackageProjectCreator.NewDefaultProjectModule Method
TnxServerPackageProjectCreator Class TnxServerPackageProjectCreator Members nxdvPluginWizard Namespace TnxServerPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxServerPackageProjectCreator Methods

Links
TnxServerPackageProjectCreator Class, TnxServerPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxServerPackageProjectCreator Methods


TnxServerUnitModuleCreator Class

TnxServerUnitModuleCreator Class
TnxServerUnitModuleCreator Methods TnxServerUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxServerUnitModuleCreatornxdvPluginWizard_TnxServerUnitModuleCreatornxdvPluginWizard_TnxServerUnitModuleCreatornxdvPluginWizard_TnxServerUnitModuleCreator
Syntax
Delphi
TnxServerUnitModuleCreator = class(TnxUnitModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxServerUnitModuleCreator.

Group

Classes

Links
TnxServerUnitModuleCreator Methods, TnxServerUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxServerUnitModuleCreator Members

TnxServerUnitModuleCreator Members
TnxServerUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxServerUnitModuleCreator.

Class

TnxServerUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxServerUnitModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxServerUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxServerUnitModuleCreator Methods

TnxServerUnitModuleCreator Methods
TnxServerUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxServerUnitModuleCreator class are listed here.

Class

TnxServerUnitModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxServerUnitModuleCreator
GetUnitType | TnxUnitModuleCreator
NewImplSource | IOTAModuleCreator
Links
TnxServerUnitModuleCreator Class, Legend, Protected Methods


TnxServerUnitModuleCreator.GetDescription Method

TnxServerUnitModuleCreator.GetDescription Method
TnxServerUnitModuleCreator Class TnxServerUnitModuleCreator Members nxdvPluginWizard Namespace TnxServerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxServerUnitModuleCreator

Group

TnxServerUnitModuleCreator Methods

Links
TnxServerUnitModuleCreator Class, TnxServerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxServerUnitModuleCreator Methods


TnxServerUnitModuleCreator.GetUnitType Method

TnxServerUnitModuleCreator.GetUnitType Method
TnxServerUnitModuleCreator Class TnxServerUnitModuleCreator Members nxdvPluginWizard Namespace TnxServerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxServerUnitModuleCreator Methods

Links
TnxServerUnitModuleCreator Class, TnxServerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxServerUnitModuleCreator Methods


TnxServerUnitModuleCreator.NewImplSource Method

TnxServerUnitModuleCreator.NewImplSource Method
TnxServerUnitModuleCreator Class TnxServerUnitModuleCreator Members nxdvPluginWizard Namespace TnxServerUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxServerUnitModuleCreator Methods

Links
TnxServerUnitModuleCreator Class, TnxServerUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxServerUnitModuleCreator Methods


TnxSharedPackageProjectCreator Class

TnxSharedPackageProjectCreator Class
TnxSharedPackageProjectCreator Methods TnxSharedPackageProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxSharedPackageProjectCreatornxdvPluginWizard_TnxSharedPackageProjectCreatornxdvPluginWizard_TnxSharedPackageProjectCreatornxdvPluginWizard_TnxSharedPackageProjectCreatornxdvPluginWizard_TnxSharedPackageProjectCreator
Syntax
Delphi
TnxSharedPackageProjectCreator = class(TnxBasePackageProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxSharedPackageProjectCreator.

Group

Classes

Links
TnxSharedPackageProjectCreator Methods, TnxSharedPackageProjectCreator Members, nxdvPluginWizard, Classes


TnxSharedPackageProjectCreator Members

TnxSharedPackageProjectCreator Members
TnxSharedPackageProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSharedPackageProjectCreator.

Class

TnxSharedPackageProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetBaseFileName | TnxPackageProjectCreator
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxPackageProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | TnxSharedPackageProjectCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetPackageType | TnxPackageProjectCreator
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxBasePackageProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxPackageProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
IsDesignTime | This is IsDesignTime, a member of class TnxSharedPackageProjectCreator.
IsRunTime | This is IsRunTime, a member of class TnxPackageProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxSharedPackageProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSharedPackageProjectCreator Methods

TnxSharedPackageProjectCreator Methods
TnxSharedPackageProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxSharedPackageProjectCreator class are listed here.

Class

TnxSharedPackageProjectCreator Class

Protected Methods
Name | Description
GetDescription | TnxSharedPackageProjectCreator
GetPackageType | TnxPackageProjectCreator
IsDesignTime | This is IsDesignTime, a member of class TnxSharedPackageProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxSharedPackageProjectCreator Class, Legend, Protected Methods


TnxSharedPackageProjectCreator.GetDescription Method

TnxSharedPackageProjectCreator.GetDescription Method
TnxSharedPackageProjectCreator Class TnxSharedPackageProjectCreator Members nxdvPluginWizard Namespace TnxSharedPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxSharedPackageProjectCreator

Group

TnxSharedPackageProjectCreator Methods

Links
TnxSharedPackageProjectCreator Class, TnxSharedPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxSharedPackageProjectCreator Methods


TnxSharedPackageProjectCreator.GetPackageType Method

TnxSharedPackageProjectCreator.GetPackageType Method
TnxSharedPackageProjectCreator Class TnxSharedPackageProjectCreator Members nxdvPluginWizard Namespace TnxSharedPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function GetPackageType: string; override;
Description

TnxPackageProjectCreator

Group

TnxSharedPackageProjectCreator Methods

Links
TnxSharedPackageProjectCreator Class, TnxSharedPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxSharedPackageProjectCreator Methods


TnxSharedPackageProjectCreator.IsDesignTime Method

TnxSharedPackageProjectCreator.IsDesignTime Method
TnxSharedPackageProjectCreator Class TnxSharedPackageProjectCreator Members nxdvPluginWizard Namespace TnxSharedPackageProjectCreator Methods Send Feedback
Syntax
Delphi
function IsDesignTime: Boolean; override;
Description

This is IsDesignTime, a member of class TnxSharedPackageProjectCreator.

Group

TnxSharedPackageProjectCreator Methods

Links
TnxSharedPackageProjectCreator Class, TnxSharedPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxSharedPackageProjectCreator Methods


TnxSharedPackageProjectCreator.NewDefaultProjectModule Method

TnxSharedPackageProjectCreator.NewDefaultProjectModule Method
TnxSharedPackageProjectCreator Class TnxSharedPackageProjectCreator Members nxdvPluginWizard Namespace TnxSharedPackageProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxSharedPackageProjectCreator Methods

Links
TnxSharedPackageProjectCreator Class, TnxSharedPackageProjectCreator Members, nxdvPluginWizard Namespace, TnxSharedPackageProjectCreator Methods


TnxTestClientApplicationProjectCreator Class

TnxTestClientApplicationProjectCreator Class
TnxTestClientApplicationProjectCreator Methods TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxTestClientApplicationProjectCreatornxdvPluginWizard_TnxTestClientApplicationProjectCreatornxdvPluginWizard_TnxTestClientApplicationProjectCreatornxdvPluginWizard_TnxTestClientApplicationProjectCreator
Syntax
Delphi
TnxTestClientApplicationProjectCreator = class(TnxApplicationProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxTestClientApplicationProjectCreator.

Group

Classes

Links
TnxTestClientApplicationProjectCreator Methods, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard, Classes


TnxTestClientApplicationProjectCreator Members

TnxTestClientApplicationProjectCreator Members
TnxTestClientApplicationProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTestClientApplicationProjectCreator.

Class

TnxTestClientApplicationProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxTestClientApplicationProjectCreator
GetBaseFileName | This is GetBaseFileName, a member of class TnxApplicationProjectCreator.
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxApplicationProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxTestClientApplicationProjectCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxTestClientApplicationProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxTestClientApplicationProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxTestClientApplicationProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxTestClientApplicationProjectCreator Methods

TnxTestClientApplicationProjectCreator Methods
TnxTestClientApplicationProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxTestClientApplicationProjectCreator class are listed here.

Class

TnxTestClientApplicationProjectCreator Class

Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxTestClientApplicationProjectCreator
GetDescription | This is GetDescription, a member of class TnxTestClientApplicationProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxTestClientApplicationProjectCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxTestClientApplicationProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxTestClientApplicationProjectCreator Class, Legend, Protected Methods


TnxTestClientApplicationProjectCreator.GetApplicationType Method

TnxTestClientApplicationProjectCreator.GetApplicationType Method
TnxTestClientApplicationProjectCreator Class TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestClientApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetApplicationType: string; override;
Description

TnxPackageProjectCreator

TnxTestClientApplicationProjectCreator

Group

TnxTestClientApplicationProjectCreator Methods

Links
TnxTestClientApplicationProjectCreator Class, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestClientApplicationProjectCreator Methods


TnxTestClientApplicationProjectCreator.GetDescription Method

TnxTestClientApplicationProjectCreator.GetDescription Method
TnxTestClientApplicationProjectCreator Class TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestClientApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

This is GetDescription, a member of class TnxTestClientApplicationProjectCreator.

Group

TnxTestClientApplicationProjectCreator Methods

Links
TnxTestClientApplicationProjectCreator Class, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestClientApplicationProjectCreator Methods


TnxTestClientApplicationProjectCreator.GetUnitCreatorClass Method

TnxTestClientApplicationProjectCreator.GetUnitCreatorClass Method
TnxTestClientApplicationProjectCreator Class TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestClientApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxTestClientApplicationProjectCreator.

Group

TnxTestClientApplicationProjectCreator Methods

Links
TnxTestClientApplicationProjectCreator Class, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestClientApplicationProjectCreator Methods


TnxTestClientApplicationProjectCreator.NeedsAllEngines Method

TnxTestClientApplicationProjectCreator.NeedsAllEngines Method
TnxTestClientApplicationProjectCreator Class TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestClientApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function NeedsAllEngines: Boolean; override;
Description

This is NeedsAllEngines, a member of class TnxTestClientApplicationProjectCreator.

Group

TnxTestClientApplicationProjectCreator Methods

Links
TnxTestClientApplicationProjectCreator Class, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestClientApplicationProjectCreator Methods


TnxTestClientApplicationProjectCreator.NewDefaultProjectModule Method

TnxTestClientApplicationProjectCreator.NewDefaultProjectModule Method
TnxTestClientApplicationProjectCreator Class TnxTestClientApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestClientApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxTestClientApplicationProjectCreator Methods

Links
TnxTestClientApplicationProjectCreator Class, TnxTestClientApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestClientApplicationProjectCreator Methods


TnxTestClientFormModuleCreator Class

TnxTestClientFormModuleCreator Class
nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxTestClientFormModuleCreatornxdvPluginWizard_TnxTestClientFormModuleCreatornxdvPluginWizard_TnxTestClientFormModuleCreatornxdvPluginWizard_TnxTestClientFormModuleCreatornxdvPluginWizard_TnxTestClientFormModuleCreator
Syntax
Delphi
TnxTestClientFormModuleCreator = class(TnxFormModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxTestClientFormModuleCreator.

Group

Classes

Links
nxdvPluginWizard, Classes


TnxTestServerApplicationProjectCreator Class

TnxTestServerApplicationProjectCreator Class
TnxTestServerApplicationProjectCreator Methods TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxTestServerApplicationProjectCreatornxdvPluginWizard_TnxTestServerApplicationProjectCreatornxdvPluginWizard_TnxTestServerApplicationProjectCreatornxdvPluginWizard_TnxTestServerApplicationProjectCreator
Syntax
Delphi
TnxTestServerApplicationProjectCreator = class(TnxApplicationProjectCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxTestServerApplicationProjectCreator.

Group

Classes

Links
TnxTestServerApplicationProjectCreator Methods, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard, Classes


TnxTestServerApplicationProjectCreator Members

TnxTestServerApplicationProjectCreator Members
TnxTestServerApplicationProjectCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTestServerApplicationProjectCreator.

Class

TnxTestServerApplicationProjectCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxTestServerApplicationProjectCreator
GetBaseFileName | This is GetBaseFileName, a member of class TnxApplicationProjectCreator.
GetBaseFileNameForType | This is GetBaseFileNameForType, a member of class TnxApplicationProjectCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxTestServerApplicationProjectCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileName | IOTAProjectCreator TnxProjectCreator
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetOptionFileName | This is GetOptionFileName, a member of class TnxProjectCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetProjectPersonality | IOTAProjectCreator80
GetShowSource | This is GetShowSource, a member of class TnxProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxTestServerApplicationProjectCreator.
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxTestServerApplicationProjectCreator.
NewDefaultModule | This is NewDefaultModule, a member of class TnxProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
NewOptionSource | This is NewOptionSource, a member of class TnxProjectCreator.
NewProjectResource | This is NewProjectResource, a member of class TnxProjectCreator.
NewProjectSource | IOTAProjectCreator
NewProjectSource | This is NewProjectSource, a member of class TnxProjectCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxTestServerApplicationProjectCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxTestServerApplicationProjectCreator Methods

TnxTestServerApplicationProjectCreator Methods
TnxTestServerApplicationProjectCreator Class Legend Protected Methods Send Feedback

The methods of the TnxTestServerApplicationProjectCreator class are listed here.

Class

TnxTestServerApplicationProjectCreator Class

Protected Methods
Name | Description
GetApplicationType | TnxPackageProjectCreator TnxTestServerApplicationProjectCreator
GetDescription | This is GetDescription, a member of class TnxTestServerApplicationProjectCreator.
GetUnitCreatorClass | This is GetUnitCreatorClass, a member of class TnxTestServerApplicationProjectCreator.
NeedsAllEngines | This is NeedsAllEngines, a member of class TnxTestServerApplicationProjectCreator.
NewDefaultProjectModule | IOTAProjectCreator50
Links
TnxTestServerApplicationProjectCreator Class, Legend, Protected Methods


TnxTestServerApplicationProjectCreator.GetApplicationType Method

TnxTestServerApplicationProjectCreator.GetApplicationType Method
TnxTestServerApplicationProjectCreator Class TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestServerApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetApplicationType: string; override;
Description

TnxPackageProjectCreator

TnxTestServerApplicationProjectCreator

Group

TnxTestServerApplicationProjectCreator Methods

Links
TnxTestServerApplicationProjectCreator Class, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestServerApplicationProjectCreator Methods


TnxTestServerApplicationProjectCreator.GetDescription Method

TnxTestServerApplicationProjectCreator.GetDescription Method
TnxTestServerApplicationProjectCreator Class TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestServerApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

This is GetDescription, a member of class TnxTestServerApplicationProjectCreator.

Group

TnxTestServerApplicationProjectCreator Methods

Links
TnxTestServerApplicationProjectCreator Class, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestServerApplicationProjectCreator Methods


TnxTestServerApplicationProjectCreator.GetUnitCreatorClass Method

TnxTestServerApplicationProjectCreator.GetUnitCreatorClass Method
TnxTestServerApplicationProjectCreator Class TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestServerApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function GetUnitCreatorClass: TnxUnitModuleCreatorClass; override;
Description

This is GetUnitCreatorClass, a member of class TnxTestServerApplicationProjectCreator.

Group

TnxTestServerApplicationProjectCreator Methods

Links
TnxTestServerApplicationProjectCreator Class, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestServerApplicationProjectCreator Methods


TnxTestServerApplicationProjectCreator.NeedsAllEngines Method

TnxTestServerApplicationProjectCreator.NeedsAllEngines Method
TnxTestServerApplicationProjectCreator Class TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestServerApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
function NeedsAllEngines: Boolean; override;
Description

This is NeedsAllEngines, a member of class TnxTestServerApplicationProjectCreator.

Group

TnxTestServerApplicationProjectCreator Methods

Links
TnxTestServerApplicationProjectCreator Class, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestServerApplicationProjectCreator Methods


TnxTestServerApplicationProjectCreator.NewDefaultProjectModule Method

TnxTestServerApplicationProjectCreator.NewDefaultProjectModule Method
TnxTestServerApplicationProjectCreator Class TnxTestServerApplicationProjectCreator Members nxdvPluginWizard Namespace TnxTestServerApplicationProjectCreator Methods Send Feedback
Syntax
Delphi
procedure NewDefaultProjectModule(const Project: IOTAProject); override;
Description

IOTAProjectCreator50

Group

TnxTestServerApplicationProjectCreator Methods

Links
TnxTestServerApplicationProjectCreator Class, TnxTestServerApplicationProjectCreator Members, nxdvPluginWizard Namespace, TnxTestServerApplicationProjectCreator Methods


TnxTestServerFormModuleCreator Class

TnxTestServerFormModuleCreator Class
TnxTestServerFormModuleCreator Methods TnxTestServerFormModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxTestServerFormModuleCreatornxdvPluginWizard_TnxTestServerFormModuleCreatornxdvPluginWizard_TnxTestServerFormModuleCreatornxdvPluginWizard_TnxTestServerFormModuleCreatornxdvPluginWizard_TnxTestServerFormModuleCreator
Syntax
Delphi
TnxTestServerFormModuleCreator = class(TnxFormModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxTestServerFormModuleCreator.

Group

Classes

Links
TnxTestServerFormModuleCreator Methods, TnxTestServerFormModuleCreator Members, nxdvPluginWizard, Classes


TnxTestServerFormModuleCreator Members

TnxTestServerFormModuleCreator Members
TnxTestServerFormModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTestServerFormModuleCreator.

Class

TnxTestServerFormModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetCreatorType | IOTACreator TnxFormModuleCreator
GetCreatorType | IOTACreator
GetDescription | TnxTestServerFormModuleCreator
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxFormModuleCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxTestServerFormModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxTestServerFormModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxTestServerFormModuleCreator.
NewImplSource | IOTAModuleCreator
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxTestServerFormModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxTestServerFormModuleCreator Methods

TnxTestServerFormModuleCreator Methods
TnxTestServerFormModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxTestServerFormModuleCreator class are listed here.

Class

TnxTestServerFormModuleCreator Class

Protected Methods
Name | Description
GetDescription | TnxTestServerFormModuleCreator
GetMainForm | This is GetMainForm, a member of class TnxTestServerFormModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxTestServerFormModuleCreator.
GetUnitType | TnxUnitModuleCreator
NewFormFile | This is NewFormFile, a member of class TnxTestServerFormModuleCreator.
NewImplSource | IOTAModuleCreator
Links
TnxTestServerFormModuleCreator Class, Legend, Protected Methods


TnxTestServerFormModuleCreator.GetDescription Method

TnxTestServerFormModuleCreator.GetDescription Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; override;
Description

TnxTestServerFormModuleCreator

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxTestServerFormModuleCreator.GetMainForm Method

TnxTestServerFormModuleCreator.GetMainForm Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetMainForm: Boolean; override;
Description

This is GetMainForm, a member of class TnxTestServerFormModuleCreator.

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxTestServerFormModuleCreator.GetShowSource Method

TnxTestServerFormModuleCreator.GetShowSource Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetShowSource: Boolean; override;
Description

This is GetShowSource, a member of class TnxTestServerFormModuleCreator.

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxTestServerFormModuleCreator.GetUnitType Method

TnxTestServerFormModuleCreator.GetUnitType Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; override;
Description

TnxUnitModuleCreator

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxTestServerFormModuleCreator.NewFormFile Method

TnxTestServerFormModuleCreator.NewFormFile Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function NewFormFile(const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

This is NewFormFile, a member of class TnxTestServerFormModuleCreator.

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxTestServerFormModuleCreator.NewImplSource Method

TnxTestServerFormModuleCreator.NewImplSource Method
TnxTestServerFormModuleCreator Class TnxTestServerFormModuleCreator Members nxdvPluginWizard Namespace TnxTestServerFormModuleCreator Methods Send Feedback
Syntax
Delphi
function NewImplSource(const ModuleIdent: string; const FormIdent: string; const AncestorIdent: string): IOTAFile; override;
Description

IOTAModuleCreator

Group

TnxTestServerFormModuleCreator Methods

Links
TnxTestServerFormModuleCreator Class, TnxTestServerFormModuleCreator Members, nxdvPluginWizard Namespace, TnxTestServerFormModuleCreator Methods


TnxUnitModuleCreator Class

TnxUnitModuleCreator Class
TnxUnitModuleCreator Methods TnxUnitModuleCreator Members nxdvPluginWizard Classes Send Feedback
Class Hierarchy
nxdvPluginWizard_TnxUnitModuleCreatornxdvPluginWizard_TnxUnitModuleCreatornxdvPluginWizard_TnxUnitModuleCreator
Syntax
Delphi
TnxUnitModuleCreator = class(TnxModuleCreator);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.TnxUnitModuleCreator.

Group

Classes

Links
TnxUnitModuleCreator Methods, TnxUnitModuleCreator Members, nxdvPluginWizard, Classes


TnxUnitModuleCreator Members

TnxUnitModuleCreator Members
TnxUnitModuleCreator Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxUnitModuleCreator.

Class

TnxUnitModuleCreator Class

Protected Fields
Name | Description
crInfo | private
crOwner | This is crOwner, a member of class TnxCreator.
Protected Methods
Name | Description
FormCreated | TnxModuleCreator
GetAdditionalFileExt | This is GetAdditionalFileExt, a member of class TnxModuleCreator.
GetAdditionalFileName | This is GetAdditionalFileName, a member of class TnxModuleCreator.
GetAdditionalFilesCount | IOTAAdditionalFilesModuleCreator
GetAncestorName | IOTAModuleCreator
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxUnitModuleCreator.
GetExisting | This is GetExisting, a member of class TnxCreator.
GetFileSystem | This is GetFileSystem, a member of class TnxCreator.
GetFormName | This is GetFormName, a member of class TnxModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetIntfFileName | This is GetIntfFileName, a member of class TnxModuleCreator.
GetMainForm | This is GetMainForm, a member of class TnxModuleCreator.
GetOwner | This is GetOwner, a member of class TnxCreator.
GetShowForm | This is GetShowForm, a member of class TnxModuleCreator.
GetShowSource | This is GetShowSource, a member of class TnxModuleCreator.
GetUnitType | TnxUnitModuleCreator
GetUnnamed | This is GetUnnamed, a member of class TnxCreator.
NewAdditionalFileSource | This is NewAdditionalFileSource, a member of class TnxModuleCreator.
NewFormFile | This is NewFormFile, a member of class TnxModuleCreator.
NewImplSource | This is NewImplSource, a member of class TnxModuleCreator.
NewIntfSource | This is NewIntfSource, a member of class TnxModuleCreator.
Public Methods
Name | Description
Create | TnxCreator
Links
TnxUnitModuleCreator Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxUnitModuleCreator Methods

TnxUnitModuleCreator Methods
TnxUnitModuleCreator Class Legend Protected Methods Send Feedback

The methods of the TnxUnitModuleCreator class are listed here.

Class

TnxUnitModuleCreator Class

Protected Methods
Name | Description
GetBaseImplFileName | TnxUnitModuleCreator
GetBaseImplFileNameForType | This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.
GetClassName | This is GetClassName, a member of class TnxUnitModuleCreator.
GetClassNameForType | This is GetClassNameForType, a member of class TnxUnitModuleCreator.
GetCreatorType | IOTACreator
GetDescription | This is GetDescription, a member of class TnxUnitModuleCreator.
GetImplFileName | This is GetImplFileName, a member of class TnxUnitModuleCreator.
GetUnitType | TnxUnitModuleCreator
Links
TnxUnitModuleCreator Class, Legend, Protected Methods


TnxUnitModuleCreator.GetBaseImplFileName Method

TnxUnitModuleCreator.GetBaseImplFileName Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetBaseImplFileName: string; virtual;
Description

TnxUnitModuleCreator

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetBaseImplFileNameForType Method

TnxUnitModuleCreator.GetBaseImplFileNameForType Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetBaseImplFileNameForType(const aType: string): string; virtual;
Description

This is GetBaseImplFileNameForType, a member of class TnxUnitModuleCreator.

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetClassName Method

TnxUnitModuleCreator.GetClassName Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetClassName: string; virtual;
Description

This is GetClassName, a member of class TnxUnitModuleCreator.

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetClassNameForType Method

TnxUnitModuleCreator.GetClassNameForType Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetClassNameForType(const aType: string): string; virtual;
Description

This is GetClassNameForType, a member of class TnxUnitModuleCreator.

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetCreatorType Method

TnxUnitModuleCreator.GetCreatorType Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetCreatorType: string; override;
Description

IOTACreator

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetDescription Method

TnxUnitModuleCreator.GetDescription Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetDescription: string; virtual;
Description

This is GetDescription, a member of class TnxUnitModuleCreator.

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetImplFileName Method

TnxUnitModuleCreator.GetImplFileName Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetImplFileName: string; override;
Description

This is GetImplFileName, a member of class TnxUnitModuleCreator.

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


TnxUnitModuleCreator.GetUnitType Method

TnxUnitModuleCreator.GetUnitType Method
TnxUnitModuleCreator Class TnxUnitModuleCreator Members nxdvPluginWizard Namespace TnxUnitModuleCreator Methods Send Feedback
Syntax
Delphi
function GetUnitType: string; virtual;
Description

TnxUnitModuleCreator

Group

TnxUnitModuleCreator Methods

Links
TnxUnitModuleCreator Class, TnxUnitModuleCreator Members, nxdvPluginWizard Namespace, TnxUnitModuleCreator Methods


Interfaces

Interfaces
nxdvPluginWizard Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxdvPluginWizard Namespace

Interfaces
Name | Description
InxCreationInfo | This is class nxdvPluginWizard.InxCreationInfo.
Links
nxdvPluginWizard Namespace, Interfaces, Legend


InxCreationInfo Interface

InxCreationInfo Interface
InxCreationInfo Methods InxCreationInfo Members nxdvPluginWizard Interfaces Send Feedback
Class Hierarchy
nxdvPluginWizard_InxCreationInfo
Syntax
Delphi
InxCreationInfo = interface(InxInterface);
File

nxdvPluginWizard

Description

This is class nxdvPluginWizard.InxCreationInfo.

Group

Interfaces

Links
InxCreationInfo Methods, InxCreationInfo Members, nxdvPluginWizard, Interfaces


InxCreationInfo Members

InxCreationInfo Members
InxCreationInfo Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxCreationInfo.

Interface

InxCreationInfo Interface

Public Methods
Name | Description
BaseName | base name for packages, units and classes, e.g. 'EventManager
BasePath | Base path including trailing where the project is supposed to go.
Copyright | copyright, e.g. "NexusDB Pty. Ltd 2003-2199
IncludeDependencies | Should project dependencies be included?
IncludeExample | Should example code be included?
IncludeTests | Should test projects be included?
Name | name for descriptions in packages, units and classes, e.g. 'Event Manager
SharedPackage | should all units be combined in a single package?
ShortBaseName | short base name for packages, units and classes, e.g. 'em
TypePrefix | Prefix to be used for types, e.g. 'nx
Version | version number for descriptions, e.g. 2.06
VersionName | version number for names, e.g. 2.06
Links
InxCreationInfo Interface, Legend, Public Methods


InxCreationInfo Methods

InxCreationInfo Methods
InxCreationInfo Interface Legend Public Methods Send Feedback

The methods of the InxCreationInfo class are listed here.

Interface

InxCreationInfo Interface

Public Methods
Name | Description
BaseName | base name for packages, units and classes, e.g. 'EventManager
BasePath | Base path including trailing where the project is supposed to go.
Copyright | copyright, e.g. "NexusDB Pty. Ltd 2003-2199
IncludeDependencies | Should project dependencies be included?
IncludeExample | Should example code be included?
IncludeTests | Should test projects be included?
Name | name for descriptions in packages, units and classes, e.g. 'Event Manager
SharedPackage | should all units be combined in a single package?
ShortBaseName | short base name for packages, units and classes, e.g. 'em
TypePrefix | Prefix to be used for types, e.g. 'nx
Version | version number for descriptions, e.g. 2.06
VersionName | version number for names, e.g. 2.06
Links
InxCreationInfo Interface, Legend, Public Methods


InxCreationInfo.BaseName Method

InxCreationInfo.BaseName Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function BaseName: string;
Description

base name for packages, units and classes, e.g. 'EventManager

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.BasePath Method

InxCreationInfo.BasePath Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function BasePath: string;
Description

Base path including trailing where the project is supposed to go.

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.Copyright Method

InxCreationInfo.Copyright Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function Copyright: string;
Description

copyright, e.g. "NexusDB Pty. Ltd 2003-2199

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.IncludeDependencies Method

InxCreationInfo.IncludeDependencies Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function IncludeDependencies: Boolean;
Description

Should project dependencies be included?

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.IncludeExample Method

InxCreationInfo.IncludeExample Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function IncludeExample: Boolean;
Description

Should example code be included?

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.IncludeTests Method

InxCreationInfo.IncludeTests Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function IncludeTests: Boolean;
Description

Should test projects be included?

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.Name Method

InxCreationInfo.Name Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function Name: string;
Description

name for descriptions in packages, units and classes, e.g. 'Event Manager

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.SharedPackage Method

InxCreationInfo.SharedPackage Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function SharedPackage: Boolean;
Description

should all units be combined in a single package?

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.ShortBaseName Method

InxCreationInfo.ShortBaseName Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function ShortBaseName: string;
Description

short base name for packages, units and classes, e.g. 'em

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.TypePrefix Method

InxCreationInfo.TypePrefix Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function TypePrefix: string;
Description

Prefix to be used for types, e.g. 'nx

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.Version Method

InxCreationInfo.Version Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function Version: string;
Description

version number for descriptions, e.g. 2.06

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


InxCreationInfo.VersionName Method

InxCreationInfo.VersionName Method
InxCreationInfo Interface InxCreationInfo Members nxdvPluginWizard Namespace InxCreationInfo Methods Send Feedback
Syntax
Delphi
function VersionName: string;
Description

version number for names, e.g. 2.06

Group

InxCreationInfo Methods

Links
InxCreationInfo Interface, InxCreationInfo Members, nxdvPluginWizard Namespace, InxCreationInfo Methods


Functions

Functions
Functions nxdvPluginWizard Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
Register | This is function nxdvPluginWizard.Register.
Namespace

nxdvPluginWizard Namespace

Links
Functions, nxdvPluginWizard Namespace, Legend


nxdvPluginWizard.Register Function

nxdvPluginWizard.Register Function
nxdvPluginWizard Functions Send Feedback
Syntax
Delphi
procedure Register;
File

nxdvPluginWizard

Description

This is function nxdvPluginWizard.Register.

Group

Functions

Links
nxdvPluginWizard, Functions


Types

Types
nxdvPluginWizard Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxdvPluginWizard Namespace

Types
Name | Description
TnxUnitModuleCreatorClass | This is type nxdvPluginWizard.TnxUnitModuleCreatorClass.
Links
nxdvPluginWizard Namespace, Types


nxdvPluginWizard.TnxUnitModuleCreatorClass Type

nxdvPluginWizard.TnxUnitModuleCreatorClass Type
nxdvPluginWizard Types Send Feedback
Syntax
Delphi
TnxUnitModuleCreatorClass = class of TnxUnitModuleCreator;
File

nxdvPluginWizard

Description

This is type nxdvPluginWizard.TnxUnitModuleCreatorClass.

Group

Types

Links
nxdvPluginWizard, Types


nxdvPluginWizardFrm Namespace

nxdvPluginWizardFrm Namespace
Classes Legend Topics Send Feedback

This is namespace nxdvPluginWizardFrm.

Classes
Name | Description
TfrmPluginWizard | This is class nxdvPluginWizardFrm.TfrmPluginWizard.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxdvPluginWizardFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmPluginWizard | This is class nxdvPluginWizardFrm.TfrmPluginWizard.
Namespace

nxdvPluginWizardFrm Namespace

Links
Classes, nxdvPluginWizardFrm Namespace, Legend


TfrmPluginWizard Class

TfrmPluginWizard Class
TfrmPluginWizard Fields TfrmPluginWizard Methods TfrmPluginWizard Members nxdvPluginWizardFrm Classes Send Feedback
Class Hierarchy
nxdvPluginWizardFrm_TfrmPluginWizardnxdvPluginWizardFrm_TfrmPluginWizard
Syntax
Delphi
TfrmPluginWizard = class(TForm, InxCreationInfo);
File

nxdvPluginWizardFrm

Description

This is class nxdvPluginWizardFrm.TfrmPluginWizard.

Group

Classes

Links
TfrmPluginWizard Fields, TfrmPluginWizard Methods, TfrmPluginWizard Members, nxdvPluginWizardFrm, Classes


TfrmPluginWizard Members

TfrmPluginWizard Members
TfrmPluginWizard Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TfrmPluginWizard.

Class

TfrmPluginWizard Class

Public Fields
Name | Description
BitBtn2 | This is BitBtn2, a member of class TfrmPluginWizard.
bnOk | This is bnOk, a member of class TfrmPluginWizard.
chkDependencies | This is chkDependencies, a member of class TfrmPluginWizard.
chkExample | This is chkExample, a member of class TfrmPluginWizard.
chkSharedPackage | This is chkSharedPackage, a member of class TfrmPluginWizard.
chkTestApplications | This is chkTestApplications, a member of class TfrmPluginWizard.
edBaseName | This is edBaseName, a member of class TfrmPluginWizard.
edCopyright | This is edCopyright, a member of class TfrmPluginWizard.
edName | This is edName, a member of class TfrmPluginWizard.
edPath | This is edPath, a member of class TfrmPluginWizard.
edShortBaseName | This is edShortBaseName, a member of class TfrmPluginWizard.
edTypePrefix | This is edTypePrefix, a member of class TfrmPluginWizard.
edVersion | This is edVersion, a member of class TfrmPluginWizard.
edVersionName | This is edVersionName, a member of class TfrmPluginWizard.
Public Methods
Name | Description
BaseName | TForm1
BasePath | InxCreationInfo
Copyright | copyright, e.g. "NexusDB Pty. Ltd 2003-2199
edChange | This is edChange, a member of class TfrmPluginWizard.
IncludeDependencies | Should project dependencies be included?
IncludeExample | Should example code be included?
IncludeTests | Should test projects be included?
Name | name for descriptions in packages, units and classes, e.g. 'Event Manager
SharedPackage | should all units be combined in a single package?
ShortBaseName | short base name for packages, units and classes, e.g. 'em
TypePrefix | Prefix to be used for types, e.g. 'nx
Version | version number for descriptions, e.g. 2.06
VersionName | version number for names, e.g. 2.06
Links
TfrmPluginWizard Class, Legend, Public Fields, Public Methods


TfrmPluginWizard Fields

TfrmPluginWizard Fields
TfrmPluginWizard Class Legend Public Fields Send Feedback

The fields of the TfrmPluginWizard class are listed here.

Class

TfrmPluginWizard Class

Public Fields
Name | Description
BitBtn2 | This is BitBtn2, a member of class TfrmPluginWizard.
bnOk | This is bnOk, a member of class TfrmPluginWizard.
chkDependencies | This is chkDependencies, a member of class TfrmPluginWizard.
chkExample | This is chkExample, a member of class TfrmPluginWizard.
chkSharedPackage | This is chkSharedPackage, a member of class TfrmPluginWizard.
chkTestApplications | This is chkTestApplications, a member of class TfrmPluginWizard.
edBaseName | This is edBaseName, a member of class TfrmPluginWizard.
edCopyright | This is edCopyright, a member of class TfrmPluginWizard.
edName | This is edName, a member of class TfrmPluginWizard.
edPath | This is edPath, a member of class TfrmPluginWizard.
edShortBaseName | This is edShortBaseName, a member of class TfrmPluginWizard.
edTypePrefix | This is edTypePrefix, a member of class TfrmPluginWizard.
edVersion | This is edVersion, a member of class TfrmPluginWizard.
edVersionName | This is edVersionName, a member of class TfrmPluginWizard.
Links
TfrmPluginWizard Class, Legend, Public Fields


TfrmPluginWizard.BitBtn2 Field

TfrmPluginWizard.BitBtn2 Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
BitBtn2: TBitBtn;
Description

This is BitBtn2, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.bnOk Field

TfrmPluginWizard.bnOk Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
bnOk: TBitBtn;
Description

This is bnOk, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.chkDependencies Field

TfrmPluginWizard.chkDependencies Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
chkDependencies: TCheckBox;
Description

This is chkDependencies, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.chkExample Field

TfrmPluginWizard.chkExample Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
chkExample: TCheckBox;
Description

This is chkExample, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.chkSharedPackage Field

TfrmPluginWizard.chkSharedPackage Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
chkSharedPackage: TCheckBox;
Description

This is chkSharedPackage, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.chkTestApplications Field

TfrmPluginWizard.chkTestApplications Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
chkTestApplications: TCheckBox;
Description

This is chkTestApplications, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edBaseName Field

TfrmPluginWizard.edBaseName Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edBaseName: TLabeledEdit;
Description

This is edBaseName, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edCopyright Field

TfrmPluginWizard.edCopyright Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edCopyright: TLabeledEdit;
Description

This is edCopyright, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edName Field

TfrmPluginWizard.edName Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edName: TLabeledEdit;
Description

This is edName, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edPath Field

TfrmPluginWizard.edPath Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edPath: TLabeledEdit;
Description

This is edPath, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edShortBaseName Field

TfrmPluginWizard.edShortBaseName Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edShortBaseName: TLabeledEdit;
Description

This is edShortBaseName, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edTypePrefix Field

TfrmPluginWizard.edTypePrefix Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edTypePrefix: TLabeledEdit;
Description

This is edTypePrefix, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edVersion Field

TfrmPluginWizard.edVersion Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edVersion: TLabeledEdit;
Description

This is edVersion, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard.edVersionName Field

TfrmPluginWizard.edVersionName Field
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Fields Send Feedback
Syntax
Delphi
edVersionName: TLabeledEdit;
Description

This is edVersionName, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Fields

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Fields


TfrmPluginWizard Methods

TfrmPluginWizard Methods
TfrmPluginWizard Class Legend Public Methods Send Feedback

The methods of the TfrmPluginWizard class are listed here.

Class

TfrmPluginWizard Class

Public Methods
Name | Description
BaseName | TForm1
BasePath | InxCreationInfo
Copyright | copyright, e.g. "NexusDB Pty. Ltd 2003-2199
edChange | This is edChange, a member of class TfrmPluginWizard.
IncludeDependencies | Should project dependencies be included?
IncludeExample | Should example code be included?
IncludeTests | Should test projects be included?
Name | name for descriptions in packages, units and classes, e.g. 'Event Manager
SharedPackage | should all units be combined in a single package?
ShortBaseName | short base name for packages, units and classes, e.g. 'em
TypePrefix | Prefix to be used for types, e.g. 'nx
Version | version number for descriptions, e.g. 2.06
VersionName | version number for names, e.g. 2.06
Links
TfrmPluginWizard Class, Legend, Public Methods


TfrmPluginWizard.BaseName Method

TfrmPluginWizard.BaseName Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function BaseName: string;
Description

TForm1

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.BasePath Method

TfrmPluginWizard.BasePath Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function BasePath: string;
Description

InxCreationInfo

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.Copyright Method

TfrmPluginWizard.Copyright Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function Copyright: string;
Description

copyright, e.g. "NexusDB Pty. Ltd 2003-2199

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.edChange Method

TfrmPluginWizard.edChange Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
procedure edChange(Sender: TObject);
Description

This is edChange, a member of class TfrmPluginWizard.

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.IncludeDependencies Method

TfrmPluginWizard.IncludeDependencies Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function IncludeDependencies: Boolean;
Description

Should project dependencies be included?

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.IncludeExample Method

TfrmPluginWizard.IncludeExample Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function IncludeExample: Boolean;
Description

Should example code be included?

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.IncludeTests Method

TfrmPluginWizard.IncludeTests Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function IncludeTests: Boolean;
Description

Should test projects be included?

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.Name Method

TfrmPluginWizard.Name Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function Name: string;
Description

name for descriptions in packages, units and classes, e.g. 'Event Manager

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.SharedPackage Method

TfrmPluginWizard.SharedPackage Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function SharedPackage: Boolean;
Description

should all units be combined in a single package?

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.ShortBaseName Method

TfrmPluginWizard.ShortBaseName Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function ShortBaseName: string;
Description

short base name for packages, units and classes, e.g. 'em

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.TypePrefix Method

TfrmPluginWizard.TypePrefix Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function TypePrefix: string;
Description

Prefix to be used for types, e.g. 'nx

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.Version Method

TfrmPluginWizard.Version Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function Version: string;
Description

version number for descriptions, e.g. 2.06

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


TfrmPluginWizard.VersionName Method

TfrmPluginWizard.VersionName Method
TfrmPluginWizard Class TfrmPluginWizard Members nxdvPluginWizardFrm Namespace TfrmPluginWizard Methods Send Feedback
Syntax
Delphi
function VersionName: string;
Description

version number for names, e.g. 2.06

Group

TfrmPluginWizard Methods

Links
TfrmPluginWizard Class, TfrmPluginWizard Members, nxdvPluginWizardFrm Namespace, TfrmPluginWizard Methods


nxdvRegister Namespace

nxdvRegister Namespace
Classes Functions Legend Topics Variables Send Feedback

This is namespace nxdvRegister.

Classes
Name | Description
TnxBackupControllerEncryptionEngineNameProperty | TnxBackupControllerEncryptionEngineNameProperty
TnxComponentProperty | TnxComponentProperty
TnxDatabaseAliasNameProperty | TnxDatabaseAliasNameProperty
TnxDatabaseAliasPathProperty | TnxDatabaseAliasPathProperty
TnxDatabaseMappingAliasNameProperty | TnxDatabaseMappingAliasNameProperty
TnxDataSetAliasNameProperty | TnxDataSetAliasNameProperty
TnxDataSetDatabaseProperty | TnxDataSetDatabaseProperty
TnxDataSetProperty | TnxDataSetProperty
TnxIndexFieldNamesProperty | TnxIndexFieldNamesProperty
TnxIndexNameProperty | TnxIndexNameProperty
TnxInterfacedComponentProperty | TnxInterfacedComponentProperty
TnxQueryParamsProperty | TnxQueryParamsProperty
TnxSessionRequestInterfacedComponentProperty | TnxSessionRequestInterfacedComponentProperty
TnxSimpleAddStringList | TnxSimpleAddStringList
TnxStoredProcNameProperty | TnxStoredProcNameProperty
TnxTableFieldLinkProperty | TnxTableFieldLinkProperty
TnxTableNameProperty | TnxTableNameProperty
TnxThreadPriorityProperty |
Functions
Name | Description
Register | Register
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_PlatformAddRef |
Links
Classes, Functions, Legend, Topics, Variables


Classes

Classes
Classes nxdvRegister Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBackupControllerEncryptionEngineNameProperty | TnxBackupControllerEncryptionEngineNameProperty
TnxComponentProperty | TnxComponentProperty
TnxDatabaseAliasNameProperty | TnxDatabaseAliasNameProperty
TnxDatabaseAliasPathProperty | TnxDatabaseAliasPathProperty
TnxDatabaseMappingAliasNameProperty | TnxDatabaseMappingAliasNameProperty
TnxDataSetAliasNameProperty | TnxDataSetAliasNameProperty
TnxDataSetDatabaseProperty | TnxDataSetDatabaseProperty
TnxDataSetProperty | TnxDataSetProperty
TnxIndexFieldNamesProperty | TnxIndexFieldNamesProperty
TnxIndexNameProperty | TnxIndexNameProperty
TnxInterfacedComponentProperty | TnxInterfacedComponentProperty
TnxQueryParamsProperty | TnxQueryParamsProperty
TnxSessionRequestInterfacedComponentProperty | TnxSessionRequestInterfacedComponentProperty
TnxSimpleAddStringList | TnxSimpleAddStringList
TnxStoredProcNameProperty | TnxStoredProcNameProperty
TnxTableFieldLinkProperty | TnxTableFieldLinkProperty
TnxTableNameProperty | TnxTableNameProperty
TnxThreadPriorityProperty |
Namespace

nxdvRegister Namespace

Links
Classes, nxdvRegister Namespace, Legend


TnxBackupControllerEncryptionEngineNameProperty Class

TnxBackupControllerEncryptionEngineNameProperty Class
TnxBackupControllerEncryptionEngineNameProperty Methods TnxBackupControllerEncryptionEngineNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxBackupControllerEncryptionEngineNameProperty
Syntax
Delphi
TnxBackupControllerEncryptionEngineNameProperty = class(TDBStringProperty);
File

nxdvRegister

Description

TnxBackupControllerEncryptionEngineNameProperty

Group

Classes

Links
TnxBackupControllerEncryptionEngineNameProperty Methods, TnxBackupControllerEncryptionEngineNameProperty Members, nxdvRegister, Classes


TnxBackupControllerEncryptionEngineNameProperty Members

TnxBackupControllerEncryptionEngineNameProperty Members
TnxBackupControllerEncryptionEngineNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxBackupControllerEncryptionEngineNameProperty.

Class

TnxBackupControllerEncryptionEngineNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxBackupControllerEncryptionEngineNameProperty Class, Legend, Public Methods


TnxBackupControllerEncryptionEngineNameProperty Methods

TnxBackupControllerEncryptionEngineNameProperty Methods
TnxBackupControllerEncryptionEngineNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxBackupControllerEncryptionEngineNameProperty class are listed here.

Class

TnxBackupControllerEncryptionEngineNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxBackupControllerEncryptionEngineNameProperty Class, Legend, Public Methods


TnxBackupControllerEncryptionEngineNameProperty.AutoFill Method

TnxBackupControllerEncryptionEngineNameProperty.AutoFill Method
TnxBackupControllerEncryptionEngineNameProperty Class TnxBackupControllerEncryptionEngineNameProperty Members nxdvRegister Namespace TnxBackupControllerEncryptionEngineNameProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxBackupControllerEncryptionEngineNameProperty Methods

Links
TnxBackupControllerEncryptionEngineNameProperty Class, TnxBackupControllerEncryptionEngineNameProperty Members, nxdvRegister Namespace, TnxBackupControllerEncryptionEngineNameProperty Methods


TnxBackupControllerEncryptionEngineNameProperty.GetValueList Method

TnxBackupControllerEncryptionEngineNameProperty.GetValueList Method
TnxBackupControllerEncryptionEngineNameProperty Class TnxBackupControllerEncryptionEngineNameProperty Members nxdvRegister Namespace TnxBackupControllerEncryptionEngineNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxBackupControllerEncryptionEngineNameProperty Methods

Links
TnxBackupControllerEncryptionEngineNameProperty Class, TnxBackupControllerEncryptionEngineNameProperty Members, nxdvRegister Namespace, TnxBackupControllerEncryptionEngineNameProperty Methods


TnxComponentProperty Class

TnxComponentProperty Class
nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxComponentProperty
Syntax
Delphi
TnxComponentProperty = class(TComponentProperty);
File

nxdvRegister

Description

TnxComponentProperty

Group

Classes

Links
nxdvRegister, Classes


TnxDatabaseAliasNameProperty Class

TnxDatabaseAliasNameProperty Class
TnxDatabaseAliasNameProperty Methods TnxDatabaseAliasNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDatabaseAliasNameProperty
Syntax
Delphi
TnxDatabaseAliasNameProperty = class(TDBStringProperty);
File

nxdvRegister

Description

TnxDatabaseAliasNameProperty

Group

Classes

Links
TnxDatabaseAliasNameProperty Methods, TnxDatabaseAliasNameProperty Members, nxdvRegister, Classes


TnxDatabaseAliasNameProperty Members

TnxDatabaseAliasNameProperty Members
TnxDatabaseAliasNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxDatabaseAliasNameProperty.

Class

TnxDatabaseAliasNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxDatabaseAliasNameProperty Class, Legend, Public Methods


TnxDatabaseAliasNameProperty Methods

TnxDatabaseAliasNameProperty Methods
TnxDatabaseAliasNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxDatabaseAliasNameProperty class are listed here.

Class

TnxDatabaseAliasNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxDatabaseAliasNameProperty Class, Legend, Public Methods


TnxDatabaseAliasNameProperty.AutoFill Method

TnxDatabaseAliasNameProperty.AutoFill Method
TnxDatabaseAliasNameProperty Class TnxDatabaseAliasNameProperty Members nxdvRegister Namespace TnxDatabaseAliasNameProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxDatabaseAliasNameProperty Methods

Links
TnxDatabaseAliasNameProperty Class, TnxDatabaseAliasNameProperty Members, nxdvRegister Namespace, TnxDatabaseAliasNameProperty Methods


TnxDatabaseAliasNameProperty.GetValueList Method

TnxDatabaseAliasNameProperty.GetValueList Method
TnxDatabaseAliasNameProperty Class TnxDatabaseAliasNameProperty Members nxdvRegister Namespace TnxDatabaseAliasNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxDatabaseAliasNameProperty Methods

Links
TnxDatabaseAliasNameProperty Class, TnxDatabaseAliasNameProperty Members, nxdvRegister Namespace, TnxDatabaseAliasNameProperty Methods


TnxDatabaseAliasPathProperty Class

TnxDatabaseAliasPathProperty Class
TnxDatabaseAliasPathProperty Methods TnxDatabaseAliasPathProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDatabaseAliasPathProperty
Syntax
Delphi
TnxDatabaseAliasPathProperty = class(TStringProperty);
File

nxdvRegister

Description

TnxDatabaseAliasPathProperty

Group

Classes

Links
TnxDatabaseAliasPathProperty Methods, TnxDatabaseAliasPathProperty Members, nxdvRegister, Classes


TnxDatabaseAliasPathProperty Members

TnxDatabaseAliasPathProperty Members
TnxDatabaseAliasPathProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxDatabaseAliasPathProperty.

Class

TnxDatabaseAliasPathProperty Class

Public Methods
Name | Description
Edit |
GetAttributes |
Links
TnxDatabaseAliasPathProperty Class, Legend, Public Methods


TnxDatabaseAliasPathProperty Methods

TnxDatabaseAliasPathProperty Methods
TnxDatabaseAliasPathProperty Class Legend Public Methods Send Feedback

The methods of the TnxDatabaseAliasPathProperty class are listed here.

Class

TnxDatabaseAliasPathProperty Class

Public Methods
Name | Description
Edit |
GetAttributes |
Links
TnxDatabaseAliasPathProperty Class, Legend, Public Methods


TnxDatabaseAliasPathProperty.Edit Method

TnxDatabaseAliasPathProperty.Edit Method
TnxDatabaseAliasPathProperty Class TnxDatabaseAliasPathProperty Members nxdvRegister Namespace TnxDatabaseAliasPathProperty Methods Send Feedback
Syntax
Delphi
procedure Edit; override;
Group

TnxDatabaseAliasPathProperty Methods

Links
TnxDatabaseAliasPathProperty Class, TnxDatabaseAliasPathProperty Members, nxdvRegister Namespace, TnxDatabaseAliasPathProperty Methods


TnxDatabaseAliasPathProperty.GetAttributes Method

TnxDatabaseAliasPathProperty.GetAttributes Method
TnxDatabaseAliasPathProperty Class TnxDatabaseAliasPathProperty Members nxdvRegister Namespace TnxDatabaseAliasPathProperty Methods Send Feedback
Syntax
Delphi
function GetAttributes: TPropertyAttributes; override;
Group

TnxDatabaseAliasPathProperty Methods

Links
TnxDatabaseAliasPathProperty Class, TnxDatabaseAliasPathProperty Members, nxdvRegister Namespace, TnxDatabaseAliasPathProperty Methods


TnxDatabaseMappingAliasNameProperty Class

TnxDatabaseMappingAliasNameProperty Class
TnxDatabaseMappingAliasNameProperty Methods TnxDatabaseMappingAliasNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDatabaseMappingAliasNamePropertynxdvRegister_TnxDatabaseMappingAliasNameProperty
Syntax
Delphi
TnxDatabaseMappingAliasNameProperty = class(TnxDataSetProperty);
File

nxdvRegister

Description

TnxDatabaseMappingAliasNameProperty

Group

Classes

Links
TnxDatabaseMappingAliasNameProperty Methods, TnxDatabaseMappingAliasNameProperty Members, nxdvRegister, Classes


TnxDatabaseMappingAliasNameProperty Members

TnxDatabaseMappingAliasNameProperty Members
TnxDatabaseMappingAliasNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxDatabaseMappingAliasNameProperty.

Class

TnxDatabaseMappingAliasNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxDatabaseMappingAliasNameProperty Class, Legend, Public Methods


TnxDatabaseMappingAliasNameProperty Methods

TnxDatabaseMappingAliasNameProperty Methods
TnxDatabaseMappingAliasNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxDatabaseMappingAliasNameProperty class are listed here.

Class

TnxDatabaseMappingAliasNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxDatabaseMappingAliasNameProperty Class, Legend, Public Methods


TnxDatabaseMappingAliasNameProperty.AutoFill Method

TnxDatabaseMappingAliasNameProperty.AutoFill Method
TnxDatabaseMappingAliasNameProperty Class TnxDatabaseMappingAliasNameProperty Members nxdvRegister Namespace TnxDatabaseMappingAliasNameProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxDatabaseMappingAliasNameProperty Methods

Links
TnxDatabaseMappingAliasNameProperty Class, TnxDatabaseMappingAliasNameProperty Members, nxdvRegister Namespace, TnxDatabaseMappingAliasNameProperty Methods


TnxDatabaseMappingAliasNameProperty.GetValueList Method

TnxDatabaseMappingAliasNameProperty.GetValueList Method
TnxDatabaseMappingAliasNameProperty Class TnxDatabaseMappingAliasNameProperty Members nxdvRegister Namespace TnxDatabaseMappingAliasNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxDatabaseMappingAliasNameProperty Methods

Links
TnxDatabaseMappingAliasNameProperty Class, TnxDatabaseMappingAliasNameProperty Members, nxdvRegister Namespace, TnxDatabaseMappingAliasNameProperty Methods


TnxDataSetAliasNameProperty Class

TnxDataSetAliasNameProperty Class
TnxDataSetAliasNameProperty Methods TnxDataSetAliasNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDataSetAliasNamePropertynxdvRegister_TnxDataSetAliasNameProperty
Syntax
Delphi
TnxDataSetAliasNameProperty = class(TnxDataSetProperty);
File

nxdvRegister

Description

TnxDataSetAliasNameProperty

Group

Classes

Links
TnxDataSetAliasNameProperty Methods, TnxDataSetAliasNameProperty Members, nxdvRegister, Classes


TnxDataSetAliasNameProperty Members

TnxDataSetAliasNameProperty Members
TnxDataSetAliasNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxDataSetAliasNameProperty.

Class

TnxDataSetAliasNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxDataSetAliasNameProperty Class, Legend, Public Methods


TnxDataSetAliasNameProperty Methods

TnxDataSetAliasNameProperty Methods
TnxDataSetAliasNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxDataSetAliasNameProperty class are listed here.

Class

TnxDataSetAliasNameProperty Class

Public Methods
Name | Description
GetValueList |
Links
TnxDataSetAliasNameProperty Class, Legend, Public Methods


TnxDataSetAliasNameProperty.GetValueList Method

TnxDataSetAliasNameProperty.GetValueList Method
TnxDataSetAliasNameProperty Class TnxDataSetAliasNameProperty Members nxdvRegister Namespace TnxDataSetAliasNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxDataSetAliasNameProperty Methods

Links
TnxDataSetAliasNameProperty Class, TnxDataSetAliasNameProperty Members, nxdvRegister Namespace, TnxDataSetAliasNameProperty Methods


TnxDataSetDatabaseProperty Class

TnxDataSetDatabaseProperty Class
TnxDataSetDatabaseProperty Methods TnxDataSetDatabaseProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDataSetDatabasePropertynxdvRegister_TnxDataSetDatabaseProperty
Syntax
Delphi
TnxDataSetDatabaseProperty = class(TnxComponentProperty);
File

nxdvRegister

Description

TnxDataSetDatabaseProperty

Group

Classes

Links
TnxDataSetDatabaseProperty Methods, TnxDataSetDatabaseProperty Members, nxdvRegister, Classes


TnxDataSetDatabaseProperty Members

TnxDataSetDatabaseProperty Members
TnxDataSetDatabaseProperty Class Legend Protected Methods Send Feedback

The following tables list the members exposed by TnxDataSetDatabaseProperty.

Class

TnxDataSetDatabaseProperty Class

Protected Methods
Name | Description
GetComponentReference |
Links
TnxDataSetDatabaseProperty Class, Legend, Protected Methods


TnxDataSetDatabaseProperty Methods

TnxDataSetDatabaseProperty Methods
TnxDataSetDatabaseProperty Class Legend Protected Methods Send Feedback

The methods of the TnxDataSetDatabaseProperty class are listed here.

Class

TnxDataSetDatabaseProperty Class

Protected Methods
Name | Description
GetComponentReference |
Links
TnxDataSetDatabaseProperty Class, Legend, Protected Methods


TnxDataSetDatabaseProperty.GetComponentReference Method

TnxDataSetDatabaseProperty.GetComponentReference Method
TnxDataSetDatabaseProperty Class TnxDataSetDatabaseProperty Members nxdvRegister Namespace TnxDataSetDatabaseProperty Methods Send Feedback
Syntax
Delphi
function GetComponentReference: TComponent; override;
Group

TnxDataSetDatabaseProperty Methods

Links
TnxDataSetDatabaseProperty Class, TnxDataSetDatabaseProperty Members, nxdvRegister Namespace, TnxDataSetDatabaseProperty Methods


TnxDataSetProperty Class

TnxDataSetProperty Class
TnxDataSetProperty Methods TnxDataSetProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxDataSetProperty
Syntax
Delphi
TnxDataSetProperty = class(TDBStringProperty);
File

nxdvRegister

Description

TnxDataSetProperty

Group

Classes

Links
TnxDataSetProperty Methods, TnxDataSetProperty Members, nxdvRegister, Classes


TnxDataSetProperty Members

TnxDataSetProperty Members
TnxDataSetProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxDataSetProperty.

Class

TnxDataSetProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxDataSetProperty Class, Legend, Public Methods


TnxDataSetProperty Methods

TnxDataSetProperty Methods
TnxDataSetProperty Class Legend Public Methods Send Feedback

The methods of the TnxDataSetProperty class are listed here.

Class

TnxDataSetProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxDataSetProperty Class, Legend, Public Methods


TnxDataSetProperty.AutoFill Method

TnxDataSetProperty.AutoFill Method
TnxDataSetProperty Class TnxDataSetProperty Members nxdvRegister Namespace TnxDataSetProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxDataSetProperty Methods

Links
TnxDataSetProperty Class, TnxDataSetProperty Members, nxdvRegister Namespace, TnxDataSetProperty Methods


TnxIndexFieldNamesProperty Class

TnxIndexFieldNamesProperty Class
TnxIndexFieldNamesProperty Methods TnxIndexFieldNamesProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxIndexFieldNamesProperty
Syntax
Delphi
TnxIndexFieldNamesProperty = class(TIndexFieldNamesProperty);
File

nxdvRegister

Description

TnxIndexFieldNamesProperty

Group

Classes

Links
TnxIndexFieldNamesProperty Methods, TnxIndexFieldNamesProperty Members, nxdvRegister, Classes


TnxIndexFieldNamesProperty Members

TnxIndexFieldNamesProperty Members
TnxIndexFieldNamesProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxIndexFieldNamesProperty.

Class

TnxIndexFieldNamesProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxIndexFieldNamesProperty Class, Legend, Public Methods


TnxIndexFieldNamesProperty Methods

TnxIndexFieldNamesProperty Methods
TnxIndexFieldNamesProperty Class Legend Public Methods Send Feedback

The methods of the TnxIndexFieldNamesProperty class are listed here.

Class

TnxIndexFieldNamesProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxIndexFieldNamesProperty Class, Legend, Public Methods


TnxIndexFieldNamesProperty.AutoFill Method

TnxIndexFieldNamesProperty.AutoFill Method
TnxIndexFieldNamesProperty Class TnxIndexFieldNamesProperty Members nxdvRegister Namespace TnxIndexFieldNamesProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxIndexFieldNamesProperty Methods

Links
TnxIndexFieldNamesProperty Class, TnxIndexFieldNamesProperty Members, nxdvRegister Namespace, TnxIndexFieldNamesProperty Methods


TnxIndexNameProperty Class

TnxIndexNameProperty Class
TnxIndexNameProperty Methods TnxIndexNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxIndexNameProperty
Syntax
Delphi
TnxIndexNameProperty = class(TIndexNameProperty);
File

nxdvRegister

Description

TnxIndexNameProperty

Group

Classes

Links
TnxIndexNameProperty Methods, TnxIndexNameProperty Members, nxdvRegister, Classes


TnxIndexNameProperty Members

TnxIndexNameProperty Members
TnxIndexNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxIndexNameProperty.

Class

TnxIndexNameProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxIndexNameProperty Class, Legend, Public Methods


TnxIndexNameProperty Methods

TnxIndexNameProperty Methods
TnxIndexNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxIndexNameProperty class are listed here.

Class

TnxIndexNameProperty Class

Public Methods
Name | Description
AutoFill |
Links
TnxIndexNameProperty Class, Legend, Public Methods


TnxIndexNameProperty.AutoFill Method

TnxIndexNameProperty.AutoFill Method
TnxIndexNameProperty Class TnxIndexNameProperty Members nxdvRegister Namespace TnxIndexNameProperty Methods Send Feedback
Syntax
Delphi
function AutoFill: Boolean; override;
Group

TnxIndexNameProperty Methods

Links
TnxIndexNameProperty Class, TnxIndexNameProperty Members, nxdvRegister Namespace, TnxIndexNameProperty Methods


TnxInterfacedComponentProperty Class

TnxInterfacedComponentProperty Class
TnxInterfacedComponentProperty Methods TnxInterfacedComponentProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxInterfacedComponentPropertynxdvRegister_TnxInterfacedComponentProperty
Syntax
Delphi
TnxInterfacedComponentProperty = class(TnxComponentProperty);
File

nxdvRegister

Description

TnxInterfacedComponentProperty

Group

Classes

Links
TnxInterfacedComponentProperty Methods, TnxInterfacedComponentProperty Members, nxdvRegister, Classes


TnxInterfacedComponentProperty Members

TnxInterfacedComponentProperty Members
TnxInterfacedComponentProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxInterfacedComponentProperty.

Class

TnxInterfacedComponentProperty Class

Public Methods
Name | Description
GetIID | This is GetIID, a member of class TnxInterfacedComponentProperty.
GetValues |
SetValue |
Links
TnxInterfacedComponentProperty Class, Legend, Public Methods


TnxInterfacedComponentProperty Methods

TnxInterfacedComponentProperty Methods
TnxInterfacedComponentProperty Class Legend Public Methods Send Feedback

The methods of the TnxInterfacedComponentProperty class are listed here.

Class

TnxInterfacedComponentProperty Class

Public Methods
Name | Description
GetIID | This is GetIID, a member of class TnxInterfacedComponentProperty.
GetValues |
SetValue |
Links
TnxInterfacedComponentProperty Class, Legend, Public Methods


TnxInterfacedComponentProperty.GetIID Method

TnxInterfacedComponentProperty.GetIID Method
TnxInterfacedComponentProperty Class TnxInterfacedComponentProperty Members nxdvRegister Namespace TnxInterfacedComponentProperty Methods Send Feedback
Syntax
Delphi
function GetIID: TGUID; virtual; abstract;
Description

This is GetIID, a member of class TnxInterfacedComponentProperty.

Group

TnxInterfacedComponentProperty Methods

Links
TnxInterfacedComponentProperty Class, TnxInterfacedComponentProperty Members, nxdvRegister Namespace, TnxInterfacedComponentProperty Methods


TnxInterfacedComponentProperty.GetValues Method

TnxInterfacedComponentProperty.GetValues Method
TnxInterfacedComponentProperty Class TnxInterfacedComponentProperty Members nxdvRegister Namespace TnxInterfacedComponentProperty Methods Send Feedback
Syntax
Delphi
procedure GetValues(Proc: TGetStrProc); override;
Group

TnxInterfacedComponentProperty Methods

Links
TnxInterfacedComponentProperty Class, TnxInterfacedComponentProperty Members, nxdvRegister Namespace, TnxInterfacedComponentProperty Methods


TnxInterfacedComponentProperty.SetValue Method

TnxInterfacedComponentProperty.SetValue Method
TnxInterfacedComponentProperty Class TnxInterfacedComponentProperty Members nxdvRegister Namespace TnxInterfacedComponentProperty Methods Send Feedback
Syntax
Delphi
procedure SetValue(const Value: string); override;
Group

TnxInterfacedComponentProperty Methods

Links
TnxInterfacedComponentProperty Class, TnxInterfacedComponentProperty Members, nxdvRegister Namespace, TnxInterfacedComponentProperty Methods


TnxQueryParamsProperty Class

TnxQueryParamsProperty Class
TnxQueryParamsProperty Methods TnxQueryParamsProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxQueryParamsProperty
Syntax
Delphi
TnxQueryParamsProperty = class(TCollectionProperty);
File

nxdvRegister

Description

TnxQueryParamsProperty

Group

Classes

Links
TnxQueryParamsProperty Methods, TnxQueryParamsProperty Members, nxdvRegister, Classes


TnxQueryParamsProperty Members

TnxQueryParamsProperty Members
TnxQueryParamsProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxQueryParamsProperty.

Class

TnxQueryParamsProperty Class

Public Methods
Name | Description
GetColOptions |
Links
TnxQueryParamsProperty Class, Legend, Public Methods


TnxQueryParamsProperty Methods

TnxQueryParamsProperty Methods
TnxQueryParamsProperty Class Legend Public Methods Send Feedback

The methods of the TnxQueryParamsProperty class are listed here.

Class

TnxQueryParamsProperty Class

Public Methods
Name | Description
GetColOptions |
Links
TnxQueryParamsProperty Class, Legend, Public Methods


TnxQueryParamsProperty.GetColOptions Method

TnxQueryParamsProperty.GetColOptions Method
TnxQueryParamsProperty Class TnxQueryParamsProperty Members nxdvRegister Namespace TnxQueryParamsProperty Methods Send Feedback
Syntax
Delphi
function GetColOptions: TColOptions; override;
Group

TnxQueryParamsProperty Methods

Links
TnxQueryParamsProperty Class, TnxQueryParamsProperty Members, nxdvRegister Namespace, TnxQueryParamsProperty Methods


TnxSessionRequestInterfacedComponentProperty Class

TnxSessionRequestInterfacedComponentProperty Class
TnxSessionRequestInterfacedComponentProperty Methods TnxSessionRequestInterfacedComponentProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxSessionRequestInterfacedComponentPropertynxdvRegister_TnxSessionRequestInterfacedComponentPropertynxdvRegister_TnxSessionRequestInterfacedComponentProperty
Syntax
Delphi
TnxSessionRequestInterfacedComponentProperty = class(TnxInterfacedComponentProperty);
File

nxdvRegister

Description

TnxSessionRequestInterfacedComponentProperty

Group

Classes

Links
TnxSessionRequestInterfacedComponentProperty Methods, TnxSessionRequestInterfacedComponentProperty Members, nxdvRegister, Classes


TnxSessionRequestInterfacedComponentProperty Members

TnxSessionRequestInterfacedComponentProperty Members
TnxSessionRequestInterfacedComponentProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxSessionRequestInterfacedComponentProperty.

Class

TnxSessionRequestInterfacedComponentProperty Class

Public Methods
Name | Description
GetIID |
GetValues |
SetValue |
Links
TnxSessionRequestInterfacedComponentProperty Class, Legend, Public Methods


TnxSessionRequestInterfacedComponentProperty Methods

TnxSessionRequestInterfacedComponentProperty Methods
TnxSessionRequestInterfacedComponentProperty Class Legend Public Methods Send Feedback

The methods of the TnxSessionRequestInterfacedComponentProperty class are listed here.

Class

TnxSessionRequestInterfacedComponentProperty Class

Public Methods
Name | Description
GetIID |
Links
TnxSessionRequestInterfacedComponentProperty Class, Legend, Public Methods


TnxSessionRequestInterfacedComponentProperty.GetIID Method

TnxSessionRequestInterfacedComponentProperty.GetIID Method
TnxSessionRequestInterfacedComponentProperty Class TnxSessionRequestInterfacedComponentProperty Members nxdvRegister Namespace TnxSessionRequestInterfacedComponentProperty Methods Send Feedback
Syntax
Delphi
function GetIID: TGUID; override;
Group

TnxSessionRequestInterfacedComponentProperty Methods

Links
TnxSessionRequestInterfacedComponentProperty Class, TnxSessionRequestInterfacedComponentProperty Members, nxdvRegister Namespace, TnxSessionRequestInterfacedComponentProperty Methods


TnxSimpleAddStringList Class

TnxSimpleAddStringList Class
TnxSimpleAddStringList Methods TnxSimpleAddStringList Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxSimpleAddStringList
Syntax
Delphi
TnxSimpleAddStringList = class(TStringList);
File

nxdvRegister

Description

TnxSimpleAddStringList

Group

Classes

Links
TnxSimpleAddStringList Methods, TnxSimpleAddStringList Members, nxdvRegister, Classes


TnxSimpleAddStringList Members

TnxSimpleAddStringList Members
TnxSimpleAddStringList Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxSimpleAddStringList.

Class

TnxSimpleAddStringList Class

Public Methods
Name | Description
SimpleAdd |
Links
TnxSimpleAddStringList Class, Legend, Public Methods


TnxSimpleAddStringList Methods

TnxSimpleAddStringList Methods
TnxSimpleAddStringList Class Legend Public Methods Send Feedback

The methods of the TnxSimpleAddStringList class are listed here.

Class

TnxSimpleAddStringList Class

Public Methods
Name | Description
SimpleAdd |
Links
TnxSimpleAddStringList Class, Legend, Public Methods


TnxSimpleAddStringList.SimpleAdd Method

TnxSimpleAddStringList.SimpleAdd Method
TnxSimpleAddStringList Class TnxSimpleAddStringList Members nxdvRegister Namespace TnxSimpleAddStringList Methods Send Feedback
Syntax
Delphi
procedure SimpleAdd(const s: string);
Group

TnxSimpleAddStringList Methods

Links
TnxSimpleAddStringList Class, TnxSimpleAddStringList Members, nxdvRegister Namespace, TnxSimpleAddStringList Methods


TnxStoredProcNameProperty Class

TnxStoredProcNameProperty Class
TnxStoredProcNameProperty Methods TnxStoredProcNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxStoredProcNamePropertynxdvRegister_TnxStoredProcNameProperty
Syntax
Delphi
TnxStoredProcNameProperty = class(TnxDataSetProperty);
File

nxdvRegister

Description

TnxStoredProcNameProperty

Group

Classes

Links
TnxStoredProcNameProperty Methods, TnxStoredProcNameProperty Members, nxdvRegister, Classes


TnxStoredProcNameProperty Members

TnxStoredProcNameProperty Members
TnxStoredProcNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxStoredProcNameProperty.

Class

TnxStoredProcNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
SetValue |
Links
TnxStoredProcNameProperty Class, Legend, Public Methods


TnxStoredProcNameProperty Methods

TnxStoredProcNameProperty Methods
TnxStoredProcNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxStoredProcNameProperty class are listed here.

Class

TnxStoredProcNameProperty Class

Public Methods
Name | Description
GetValueList |
SetValue |
Links
TnxStoredProcNameProperty Class, Legend, Public Methods


TnxStoredProcNameProperty.GetValueList Method

TnxStoredProcNameProperty.GetValueList Method
TnxStoredProcNameProperty Class TnxStoredProcNameProperty Members nxdvRegister Namespace TnxStoredProcNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxStoredProcNameProperty Methods

Links
TnxStoredProcNameProperty Class, TnxStoredProcNameProperty Members, nxdvRegister Namespace, TnxStoredProcNameProperty Methods


TnxStoredProcNameProperty.SetValue Method

TnxStoredProcNameProperty.SetValue Method
TnxStoredProcNameProperty Class TnxStoredProcNameProperty Members nxdvRegister Namespace TnxStoredProcNameProperty Methods Send Feedback
Syntax
Delphi
procedure SetValue(const Value: string); override;
Group

TnxStoredProcNameProperty Methods

Links
TnxStoredProcNameProperty Class, TnxStoredProcNameProperty Members, nxdvRegister Namespace, TnxStoredProcNameProperty Methods


TnxTableFieldLinkProperty Class

TnxTableFieldLinkProperty Class
TnxTableFieldLinkProperty Methods TnxTableFieldLinkProperty Properties TnxTableFieldLinkProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxTableFieldLinkProperty
Syntax
Delphi
TnxTableFieldLinkProperty = class(TFieldLinkProperty);
File

nxdvRegister

Description

TnxTableFieldLinkProperty

Group

Classes

Links
TnxTableFieldLinkProperty Methods, TnxTableFieldLinkProperty Properties, TnxTableFieldLinkProperty Members, nxdvRegister, Classes


TnxTableFieldLinkProperty Members

TnxTableFieldLinkProperty Members
TnxTableFieldLinkProperty Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTableFieldLinkProperty.

Class

TnxTableFieldLinkProperty Class

Protected Methods
Name | Description
GetFieldNamesForIndex |
GetIndexBased |
GetIndexDefs |
GetIndexFieldNames |
GetIndexName |
GetMasterFields |
SetIndexFieldNames |
SetIndexName |
SetMasterFields |
Public Methods
Name | Description
Edit |
Public Properties
Name | Description
IndexBased | This is IndexBased, a member of class TnxTableFieldLinkProperty.
IndexDefs | This is IndexDefs, a member of class TnxTableFieldLinkProperty.
IndexFieldNames | This is IndexFieldNames, a member of class TnxTableFieldLinkProperty.
IndexName | This is IndexName, a member of class TnxTableFieldLinkProperty.
MasterFields | This is MasterFields, a member of class TnxTableFieldLinkProperty.
Links
TnxTableFieldLinkProperty Class, Legend, Protected Methods, Public Methods, Public Properties


TnxTableFieldLinkProperty Methods

TnxTableFieldLinkProperty Methods
TnxTableFieldLinkProperty Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTableFieldLinkProperty class are listed here.

Class

TnxTableFieldLinkProperty Class

Protected Methods
Name | Description
GetFieldNamesForIndex |
GetIndexBased |
GetIndexDefs |
GetIndexFieldNames |
GetIndexName |
GetMasterFields |
SetIndexFieldNames |
SetIndexName |
SetMasterFields |
Public Methods
Name | Description
Edit |
Links
TnxTableFieldLinkProperty Class, Legend, Protected Methods, Public Methods


TnxTableFieldLinkProperty.Edit Method

TnxTableFieldLinkProperty.Edit Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
procedure Edit; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetFieldNamesForIndex Method

TnxTableFieldLinkProperty.GetFieldNamesForIndex Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
procedure GetFieldNamesForIndex(List: TStrings); override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetIndexBased Method

TnxTableFieldLinkProperty.GetIndexBased Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
function GetIndexBased: Boolean; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetIndexDefs Method

TnxTableFieldLinkProperty.GetIndexDefs Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
function GetIndexDefs: TIndexDefs; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetIndexFieldNames Method

TnxTableFieldLinkProperty.GetIndexFieldNames Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
function GetIndexFieldNames: string; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetIndexName Method

TnxTableFieldLinkProperty.GetIndexName Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
function GetIndexName: string; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.GetMasterFields Method

TnxTableFieldLinkProperty.GetMasterFields Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
function GetMasterFields: string; override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.SetIndexFieldNames Method

TnxTableFieldLinkProperty.SetIndexFieldNames Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
procedure SetIndexFieldNames(const Value: string); override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.SetIndexName Method

TnxTableFieldLinkProperty.SetIndexName Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
procedure SetIndexName(const Value: string); override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty.SetMasterFields Method

TnxTableFieldLinkProperty.SetMasterFields Method
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Methods Send Feedback
Syntax
Delphi
procedure SetMasterFields(const Value: string); override;
Group

TnxTableFieldLinkProperty Methods

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Methods


TnxTableFieldLinkProperty Properties

TnxTableFieldLinkProperty Properties
TnxTableFieldLinkProperty Class Legend Public Properties Send Feedback

The properties of the TnxTableFieldLinkProperty class are listed here.

Class

TnxTableFieldLinkProperty Class

Public Properties
Name | Description
IndexBased | This is IndexBased, a member of class TnxTableFieldLinkProperty.
IndexDefs | This is IndexDefs, a member of class TnxTableFieldLinkProperty.
IndexFieldNames | This is IndexFieldNames, a member of class TnxTableFieldLinkProperty.
IndexName | This is IndexName, a member of class TnxTableFieldLinkProperty.
MasterFields | This is MasterFields, a member of class TnxTableFieldLinkProperty.
Links
TnxTableFieldLinkProperty Class, Legend, Public Properties


TnxTableFieldLinkProperty.IndexBased Property

TnxTableFieldLinkProperty.IndexBased Property
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Properties Send Feedback
Syntax
Delphi
property IndexBased: Boolean;
Description

This is IndexBased, a member of class TnxTableFieldLinkProperty.

Group

TnxTableFieldLinkProperty Properties

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Properties


TnxTableFieldLinkProperty.IndexDefs Property

TnxTableFieldLinkProperty.IndexDefs Property
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Properties Send Feedback
Syntax
Delphi
property IndexDefs: TIndexDefs;
Description

This is IndexDefs, a member of class TnxTableFieldLinkProperty.

Group

TnxTableFieldLinkProperty Properties

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Properties


TnxTableFieldLinkProperty.IndexFieldNames Property

TnxTableFieldLinkProperty.IndexFieldNames Property
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Properties Send Feedback
Syntax
Delphi
property IndexFieldNames: string;
Description

This is IndexFieldNames, a member of class TnxTableFieldLinkProperty.

Group

TnxTableFieldLinkProperty Properties

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Properties


TnxTableFieldLinkProperty.IndexName Property

TnxTableFieldLinkProperty.IndexName Property
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Properties Send Feedback
Syntax
Delphi
property IndexName: string;
Description

This is IndexName, a member of class TnxTableFieldLinkProperty.

Group

TnxTableFieldLinkProperty Properties

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Properties


TnxTableFieldLinkProperty.MasterFields Property

TnxTableFieldLinkProperty.MasterFields Property
TnxTableFieldLinkProperty Class TnxTableFieldLinkProperty Members nxdvRegister Namespace TnxTableFieldLinkProperty Properties Send Feedback
Syntax
Delphi
property MasterFields: string;
Description

This is MasterFields, a member of class TnxTableFieldLinkProperty.

Group

TnxTableFieldLinkProperty Properties

Links
TnxTableFieldLinkProperty Class, TnxTableFieldLinkProperty Members, nxdvRegister Namespace, TnxTableFieldLinkProperty Properties


TnxTableNameProperty Class

TnxTableNameProperty Class
TnxTableNameProperty Methods TnxTableNameProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxTableNamePropertynxdvRegister_TnxTableNameProperty
Syntax
Delphi
TnxTableNameProperty = class(TnxDataSetProperty);
File

nxdvRegister

Description

TnxTableNameProperty

Group

Classes

Links
TnxTableNameProperty Methods, TnxTableNameProperty Members, nxdvRegister, Classes


TnxTableNameProperty Members

TnxTableNameProperty Members
TnxTableNameProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxTableNameProperty.

Class

TnxTableNameProperty Class

Public Methods
Name | Description
AutoFill |
GetValueList |
Links
TnxTableNameProperty Class, Legend, Public Methods


TnxTableNameProperty Methods

TnxTableNameProperty Methods
TnxTableNameProperty Class Legend Public Methods Send Feedback

The methods of the TnxTableNameProperty class are listed here.

Class

TnxTableNameProperty Class

Public Methods
Name | Description
GetValueList |
Links
TnxTableNameProperty Class, Legend, Public Methods


TnxTableNameProperty.GetValueList Method

TnxTableNameProperty.GetValueList Method
TnxTableNameProperty Class TnxTableNameProperty Members nxdvRegister Namespace TnxTableNameProperty Methods Send Feedback
Syntax
Delphi
procedure GetValueList(List: TStrings); override;
Group

TnxTableNameProperty Methods

Links
TnxTableNameProperty Class, TnxTableNameProperty Members, nxdvRegister Namespace, TnxTableNameProperty Methods


TnxThreadPriorityProperty Class

TnxThreadPriorityProperty Class
TnxThreadPriorityProperty Methods TnxThreadPriorityProperty Members nxdvRegister Classes Send Feedback
Class Hierarchy
nxdvRegister_TnxThreadPriorityProperty
Syntax
Delphi
TnxThreadPriorityProperty = class(TIntegerProperty);
File

nxdvRegister

Group

Classes

Links
TnxThreadPriorityProperty Methods, TnxThreadPriorityProperty Members, nxdvRegister, Classes


TnxThreadPriorityProperty Members

TnxThreadPriorityProperty Members
TnxThreadPriorityProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxThreadPriorityProperty.

Class

TnxThreadPriorityProperty Class

Public Methods
Name | Description
GetAttributes |
GetValue |
GetValues |
SetValue |
Links
TnxThreadPriorityProperty Class, Legend, Public Methods


TnxThreadPriorityProperty Methods

TnxThreadPriorityProperty Methods
TnxThreadPriorityProperty Class Legend Public Methods Send Feedback

The methods of the TnxThreadPriorityProperty class are listed here.

Class

TnxThreadPriorityProperty Class

Public Methods
Name | Description
GetAttributes |
GetValue |
GetValues |
SetValue |
Links
TnxThreadPriorityProperty Class, Legend, Public Methods


TnxThreadPriorityProperty.GetAttributes Method

TnxThreadPriorityProperty.GetAttributes Method
TnxThreadPriorityProperty Class TnxThreadPriorityProperty Members nxdvRegister Namespace TnxThreadPriorityProperty Methods Send Feedback
Syntax
Delphi
function GetAttributes: TPropertyAttributes; override;
Group

TnxThreadPriorityProperty Methods

Links
TnxThreadPriorityProperty Class, TnxThreadPriorityProperty Members, nxdvRegister Namespace, TnxThreadPriorityProperty Methods


TnxThreadPriorityProperty.GetValue Method

TnxThreadPriorityProperty.GetValue Method
TnxThreadPriorityProperty Class TnxThreadPriorityProperty Members nxdvRegister Namespace TnxThreadPriorityProperty Methods Send Feedback
Syntax
Delphi
function GetValue: string; override;
Group

TnxThreadPriorityProperty Methods

Links
TnxThreadPriorityProperty Class, TnxThreadPriorityProperty Members, nxdvRegister Namespace, TnxThreadPriorityProperty Methods


TnxThreadPriorityProperty.GetValues Method

TnxThreadPriorityProperty.GetValues Method
TnxThreadPriorityProperty Class TnxThreadPriorityProperty Members nxdvRegister Namespace TnxThreadPriorityProperty Methods Send Feedback
Syntax
Delphi
procedure GetValues(Proc: TGetStrProc); override;
Group

TnxThreadPriorityProperty Methods

Links
TnxThreadPriorityProperty Class, TnxThreadPriorityProperty Members, nxdvRegister Namespace, TnxThreadPriorityProperty Methods


TnxThreadPriorityProperty.SetValue Method

TnxThreadPriorityProperty.SetValue Method
TnxThreadPriorityProperty Class TnxThreadPriorityProperty Members nxdvRegister Namespace TnxThreadPriorityProperty Methods Send Feedback
Syntax
Delphi
procedure SetValue(const Value: string); override;
Group

TnxThreadPriorityProperty Methods

Links
TnxThreadPriorityProperty Class, TnxThreadPriorityProperty Members, nxdvRegister Namespace, TnxThreadPriorityProperty Methods


Functions

Functions
Functions nxdvRegister Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
Register | Register
Namespace

nxdvRegister Namespace

Links
Functions, nxdvRegister Namespace, Legend


nxdvRegister.Register Function

nxdvRegister.Register Function
nxdvRegister Functions Send Feedback
Syntax
Delphi
procedure Register;
File

nxdvRegister

Description

Register

Group

Functions

Links
nxdvRegister, Functions


Variables

Variables
nxdvRegister Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxdvRegister Namespace

Variables
Name | Description
_PlatformAddRef |
Links
nxdvRegister Namespace, Variables


nxdvRegister._PlatformAddRef Variable

nxdvRegister._PlatformAddRef Variable
nxdvRegister Variables Send Feedback
Syntax
Delphi
_PlatformAddRef: Integer;
File

nxdvRegister

Group

Variables

Links
nxdvRegister, Variables


nxdvVersionProperty Namespace

nxdvVersionProperty Namespace
Classes Legend Topics Send Feedback

This is namespace nxdvVersionProperty.

Classes
Name | Description
TnxVersionProperty | This is class nxdvVersionProperty.TnxVersionProperty.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxdvVersionProperty Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxVersionProperty | This is class nxdvVersionProperty.TnxVersionProperty.
Namespace

nxdvVersionProperty Namespace

Links
Classes, nxdvVersionProperty Namespace, Legend


TnxVersionProperty Class

TnxVersionProperty Class
TnxVersionProperty Methods TnxVersionProperty Members nxdvVersionProperty Classes Send Feedback
Class Hierarchy
nxdvVersionProperty_TnxVersionProperty
Syntax
Delphi
TnxVersionProperty = class(TStringProperty);
File

nxdvVersionProperty

Description

This is class nxdvVersionProperty.TnxVersionProperty.

Group

Classes

Links
TnxVersionProperty Methods, TnxVersionProperty Members, nxdvVersionProperty, Classes


TnxVersionProperty Members

TnxVersionProperty Members
TnxVersionProperty Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxVersionProperty.

Class

TnxVersionProperty Class

Public Methods
Name | Description
Edit |
GetAttributes | TnxVersionProperty
Links
TnxVersionProperty Class, Legend, Public Methods


TnxVersionProperty Methods

TnxVersionProperty Methods
TnxVersionProperty Class Legend Public Methods Send Feedback

The methods of the TnxVersionProperty class are listed here.

Class

TnxVersionProperty Class

Public Methods
Name | Description
Edit |
GetAttributes | TnxVersionProperty
Links
TnxVersionProperty Class, Legend, Public Methods


TnxVersionProperty.Edit Method

TnxVersionProperty.Edit Method
TnxVersionProperty Class TnxVersionProperty Members nxdvVersionProperty Namespace TnxVersionProperty Methods Send Feedback
Syntax
Delphi
procedure Edit; override;
Group

TnxVersionProperty Methods

Links
TnxVersionProperty Class, TnxVersionProperty Members, nxdvVersionProperty Namespace, TnxVersionProperty Methods


TnxVersionProperty.GetAttributes Method

TnxVersionProperty.GetAttributes Method
TnxVersionProperty Class TnxVersionProperty Members nxdvVersionProperty Namespace TnxVersionProperty Methods Send Feedback
Syntax
Delphi
function GetAttributes: TPropertyAttributes; override;
Description

TnxVersionProperty

Group

TnxVersionProperty Methods

Links
TnxVersionProperty Class, TnxVersionProperty Members, nxdvVersionProperty Namespace, TnxVersionProperty Methods


nxExceptionHook Namespace

nxExceptionHook Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxExceptionHook.

Classes
Name | Description
TCSCracker | This is class nxExceptionHook.TCSCracker.
TnxExceptionHook | This is class nxExceptionHook.TnxExceptionHook.
Constants
Name | Description
EXCEPTION_CONTINUE_SEARCH | This is constant nxExceptionHook.EXCEPTION_CONTINUE_SEARCH.
nxMaxFilesKept | number of files kept - set to 1 to always grow the log file
nxMaxLogSize | max log size in bytes
UnicodeBOF | This is constant nxExceptionHook.UnicodeBOF.
Structs, Records, Enums
Name | Description
_EXCEPTION_POINTERS | This is record nxExceptionHook._EXCEPTION_POINTERS.
_EXCEPTION_RECORD | This is record nxExceptionHook._EXCEPTION_RECORD.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EXCEPTION_POINTERS | This is type nxExceptionHook.EXCEPTION_POINTERS.
EXCEPTION_RECORD | This is type nxExceptionHook.EXCEPTION_RECORD.
LONG | This is type nxExceptionHook.LONG.
PEXCEPTION_POINTERS | This is type nxExceptionHook.PEXCEPTION_POINTERS.
PEXCEPTION_RECORD | This is type nxExceptionHook.PEXCEPTION_RECORD.
PExceptionPointers | This is type nxExceptionHook.PExceptionPointers.
PExceptionRecord | This is type nxExceptionHook.PExceptionRecord.
PVECTORED_EXCEPTION_HANDLER | This is type nxExceptionHook.PVECTORED_EXCEPTION_HANDLER.
PVectoredExceptionHandler | This is type nxExceptionHook.PVectoredExceptionHandler.
PVOID | This is type nxExceptionHook.PVOID.
TExceptionPointers | This is type nxExceptionHook.TExceptionPointers.
TExceptionRecord | This is type nxExceptionHook.TExceptionRecord.
TnxAddVectoredExceptionHandler | This is type nxExceptionHook.TnxAddVectoredExceptionHandler.
TnxExceptionHookEvent | This is type nxExceptionHook.TnxExceptionHookEvent.
TnxRemoveVectoredExceptionHandler | This is type nxExceptionHook.TnxRemoveVectoredExceptionHandler.
ULONG_PTR | This is type nxExceptionHook.ULONG_PTR.
Variables
Name | Description
_AddVectoredExceptionHandler | This is variable nxExceptionHook._AddVectoredExceptionHandler.
_ExceptionHook | This is variable nxExceptionHook._ExceptionHook.
_InVectoredHandler | This is variable nxExceptionHook._InVectoredHandler.
_RemoveVectoredExceptionHandler | This is variable nxExceptionHook._RemoveVectoredExceptionHandler.
_VectoredHandlerHandle | This is variable nxExceptionHook._VectoredHandlerHandle.
clientinfoList | This is variable nxExceptionHook.clientinfoList.
HasVectoredExceptionHandling | This is variable nxExceptionHook.HasVectoredExceptionHandling.
lFile | This is variable nxExceptionHook.lFile.
lSize | This is variable nxExceptionHook.lSize.
nxEHAppVersion | This is variable nxExceptionHook.nxEHAppVersion.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxExceptionHook Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TCSCracker | This is class nxExceptionHook.TCSCracker.
TnxExceptionHook | This is class nxExceptionHook.TnxExceptionHook.
Namespace

nxExceptionHook Namespace

Links
Classes, nxExceptionHook Namespace, Legend


TCSCracker Class

TCSCracker Class
nxExceptionHook Classes Send Feedback
Class Hierarchy
nxExceptionHook_TCSCracker
Syntax
Delphi
TCSCracker = class(TCodeSiteObject);
File

nxExceptionHook

Description

This is class nxExceptionHook.TCSCracker.

Group

Classes

Links
nxExceptionHook, Classes


TnxExceptionHook Class

TnxExceptionHook Class
TnxExceptionHook Methods TnxExceptionHook Events TnxExceptionHook Members nxExceptionHook Classes Send Feedback
Class Hierarchy
nxExceptionHook_TnxExceptionHook
Syntax
Delphi
TnxExceptionHook = class(TObject);
File

nxExceptionHook

Description

This is class nxExceptionHook.TnxExceptionHook.

Group

Classes

Links
TnxExceptionHook Methods, TnxExceptionHook Events, TnxExceptionHook Members, nxExceptionHook, Classes


TnxExceptionHook Members

TnxExceptionHook Members
TnxExceptionHook Class Legend Protected Methods Public Events Public Methods Send Feedback

The following tables list the members exposed by TnxExceptionHook.

Class

TnxExceptionHook Class

Protected Methods
Name | Description
ExceptionHook | This is ExceptionHook, a member of class TnxExceptionHook.
LogException | This is LogException, a member of class TnxExceptionHook.
Public Events
Name | Description
OnException | This is OnException, a member of class TnxExceptionHook.
Public Methods
Name | Description
Create | TnxExceptionHook
Destroy | This is Destroy, a member of class TnxExceptionHook.
Links
TnxExceptionHook Class, Legend, Protected Methods, Public Events, Public Methods


TnxExceptionHook.Create Constructor

TnxExceptionHook.Create Constructor
TnxExceptionHook Class TnxExceptionHook Members nxExceptionHook Namespace TnxExceptionHook Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxExceptionHook

Class

TnxExceptionHook Class

Links
TnxExceptionHook Class, TnxExceptionHook Members, nxExceptionHook Namespace, TnxExceptionHook Class


TnxExceptionHook.Destroy Destructor

TnxExceptionHook.Destroy Destructor
TnxExceptionHook Class TnxExceptionHook Members nxExceptionHook Namespace TnxExceptionHook Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxExceptionHook.

Class

TnxExceptionHook Class

Links
TnxExceptionHook Class, TnxExceptionHook Members, nxExceptionHook Namespace, TnxExceptionHook Class


TnxExceptionHook Methods

TnxExceptionHook Methods
TnxExceptionHook Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionHook class are listed here.

Class

TnxExceptionHook Class

Protected Methods
Name | Description
ExceptionHook | This is ExceptionHook, a member of class TnxExceptionHook.
LogException | This is LogException, a member of class TnxExceptionHook.
Links
TnxExceptionHook Class, Legend, Protected Methods


TnxExceptionHook.ExceptionHook Method

TnxExceptionHook.ExceptionHook Method
TnxExceptionHook Class TnxExceptionHook Members nxExceptionHook Namespace TnxExceptionHook Methods Send Feedback
Syntax
Delphi
procedure ExceptionHook(ExceptObj: TObject; ExceptAddr: Pointer; OSException: Boolean);
Description

This is ExceptionHook, a member of class TnxExceptionHook.

Group

TnxExceptionHook Methods

Links
TnxExceptionHook Class, TnxExceptionHook Members, nxExceptionHook Namespace, TnxExceptionHook Methods


TnxExceptionHook.LogException Method

TnxExceptionHook.LogException Method
TnxExceptionHook Class TnxExceptionHook Members nxExceptionHook Namespace TnxExceptionHook Methods Send Feedback
Syntax
Delphi
procedure LogException(ExceptObj: TObject; ExceptAddr: Pointer; OSException: Boolean; ExceptionInfo: PEXCEPTION_POINTERS; StackInfoFrames: TJclStackInfoList; StackInfoRaw: TJclStackInfoList);
Description

This is LogException, a member of class TnxExceptionHook.

Group

TnxExceptionHook Methods

Links
TnxExceptionHook Class, TnxExceptionHook Members, nxExceptionHook Namespace, TnxExceptionHook Methods


TnxExceptionHook Events

TnxExceptionHook Events
TnxExceptionHook Class Legend Public Events Send Feedback

The events of the TnxExceptionHook class are listed here.

Class

TnxExceptionHook Class

Public Events
Name | Description
OnException | This is OnException, a member of class TnxExceptionHook.
Links
TnxExceptionHook Class, Legend, Public Events


TnxExceptionHook.OnException Event

TnxExceptionHook.OnException Event
TnxExceptionHook Class TnxExceptionHook Members nxExceptionHook Namespace TnxExceptionHook Events Send Feedback
Syntax
Delphi
property OnException: TnxExceptionHookEvent;
Description

This is OnException, a member of class TnxExceptionHook.

Group

TnxExceptionHook Events

Links
TnxExceptionHook Class, TnxExceptionHook Members, nxExceptionHook Namespace, TnxExceptionHook Events


Structs, Records, Enums

Structs, Records, Enums
nxExceptionHook Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxExceptionHook Namespace

Records
Name | Description
_EXCEPTION_POINTERS | This is record nxExceptionHook._EXCEPTION_POINTERS.
_EXCEPTION_RECORD | This is record nxExceptionHook._EXCEPTION_RECORD.
Links
nxExceptionHook Namespace, Legend, Records


nxExceptionHook._EXCEPTION_POINTERS Record

nxExceptionHook._EXCEPTION_POINTERS Record
nxExceptionHook Structs, Records, Enums Send Feedback
Syntax
Delphi
_EXCEPTION_POINTERS = record
  ExceptionRecord: PEXCEPTION_RECORD;
  ContextRecord: PCONTEXT;
end;
File

nxExceptionHook

Description

This is record nxExceptionHook._EXCEPTION_POINTERS.

Group

Structs, Records, Enums

Links
nxExceptionHook, Structs, Records, Enums


nxExceptionHook._EXCEPTION_RECORD Record

nxExceptionHook._EXCEPTION_RECORD Record
nxExceptionHook Structs, Records, Enums Send Feedback
Syntax
Delphi
_EXCEPTION_RECORD = record
  ExceptionCode: DWORD;
  ExceptionFlags: DWORD;
  ExceptionRecord: PEXCEPTION_RECORD;
  ExceptionAddress: Pointer;
  NumberParameters: DWORD;
  ExceptionInformation: array [0..EXCEPTION_MAXIMUM_PARAMETERS - 1] of ULONG_PTR;
end;
File

nxExceptionHook

Description

This is record nxExceptionHook._EXCEPTION_RECORD.

Group

Structs, Records, Enums

Links
nxExceptionHook, Structs, Records, Enums


Types

Types
nxExceptionHook Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxExceptionHook Namespace

Types
Name | Description
EXCEPTION_POINTERS | This is type nxExceptionHook.EXCEPTION_POINTERS.
EXCEPTION_RECORD | This is type nxExceptionHook.EXCEPTION_RECORD.
LONG | This is type nxExceptionHook.LONG.
PEXCEPTION_POINTERS | This is type nxExceptionHook.PEXCEPTION_POINTERS.
PEXCEPTION_RECORD | This is type nxExceptionHook.PEXCEPTION_RECORD.
PExceptionPointers | This is type nxExceptionHook.PExceptionPointers.
PExceptionRecord | This is type nxExceptionHook.PExceptionRecord.
PVECTORED_EXCEPTION_HANDLER | This is type nxExceptionHook.PVECTORED_EXCEPTION_HANDLER.
PVectoredExceptionHandler | This is type nxExceptionHook.PVectoredExceptionHandler.
PVOID | This is type nxExceptionHook.PVOID.
TExceptionPointers | This is type nxExceptionHook.TExceptionPointers.
TExceptionRecord | This is type nxExceptionHook.TExceptionRecord.
TnxAddVectoredExceptionHandler | This is type nxExceptionHook.TnxAddVectoredExceptionHandler.
TnxExceptionHookEvent | This is type nxExceptionHook.TnxExceptionHookEvent.
TnxRemoveVectoredExceptionHandler | This is type nxExceptionHook.TnxRemoveVectoredExceptionHandler.
ULONG_PTR | This is type nxExceptionHook.ULONG_PTR.
Links
nxExceptionHook Namespace, Types


nxExceptionHook.EXCEPTION_POINTERS Type

nxExceptionHook.EXCEPTION_POINTERS Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
EXCEPTION_POINTERS = _EXCEPTION_POINTERS;
File

nxExceptionHook

Description

This is type nxExceptionHook.EXCEPTION_POINTERS.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.EXCEPTION_RECORD Type

nxExceptionHook.EXCEPTION_RECORD Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
EXCEPTION_RECORD = _EXCEPTION_RECORD;
File

nxExceptionHook

Description

This is type nxExceptionHook.EXCEPTION_RECORD.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.LONG Type

nxExceptionHook.LONG Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
LONG = Cardinal;
File

nxExceptionHook

Description

This is type nxExceptionHook.LONG.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PEXCEPTION_POINTERS Type

nxExceptionHook.PEXCEPTION_POINTERS Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PEXCEPTION_POINTERS = ^EXCEPTION_POINTERS;
File

nxExceptionHook

Description

This is type nxExceptionHook.PEXCEPTION_POINTERS.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PEXCEPTION_RECORD Type

nxExceptionHook.PEXCEPTION_RECORD Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PEXCEPTION_RECORD = ^EXCEPTION_RECORD;
File

nxExceptionHook

Description

This is type nxExceptionHook.PEXCEPTION_RECORD.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PExceptionPointers Type

nxExceptionHook.PExceptionPointers Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PExceptionPointers = ^TExceptionPointers;
File

nxExceptionHook

Description

This is type nxExceptionHook.PExceptionPointers.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PExceptionRecord Type

nxExceptionHook.PExceptionRecord Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PExceptionRecord = PEXCEPTION_RECORD;
File

nxExceptionHook

Description

This is type nxExceptionHook.PExceptionRecord.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PVECTORED_EXCEPTION_HANDLER Type

nxExceptionHook.PVECTORED_EXCEPTION_HANDLER Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PVECTORED_EXCEPTION_HANDLER = function (ExceptionInfo: PEXCEPTION_POINTERS): LONG;
File

nxExceptionHook

Description

This is type nxExceptionHook.PVECTORED_EXCEPTION_HANDLER.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PVectoredExceptionHandler Type

nxExceptionHook.PVectoredExceptionHandler Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PVectoredExceptionHandler = PVECTORED_EXCEPTION_HANDLER;
File

nxExceptionHook

Description

This is type nxExceptionHook.PVectoredExceptionHandler.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.PVOID Type

nxExceptionHook.PVOID Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
PVOID = Pointer;
File

nxExceptionHook

Description

This is type nxExceptionHook.PVOID.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.TExceptionPointers Type

nxExceptionHook.TExceptionPointers Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
TExceptionPointers = EXCEPTION_POINTERS;
File

nxExceptionHook

Description

This is type nxExceptionHook.TExceptionPointers.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.TExceptionRecord Type

nxExceptionHook.TExceptionRecord Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
TExceptionRecord = EXCEPTION_RECORD;
File

nxExceptionHook

Description

This is type nxExceptionHook.TExceptionRecord.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.TnxAddVectoredExceptionHandler Type

nxExceptionHook.TnxAddVectoredExceptionHandler Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
TnxAddVectoredExceptionHandler = function (FirstHandler : ULONG; VectoredHandler : PVECTORED_EXCEPTION_HANDLER) : PVOID;
File

nxExceptionHook

Description

This is type nxExceptionHook.TnxAddVectoredExceptionHandler.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.TnxExceptionHookEvent Type

nxExceptionHook.TnxExceptionHookEvent Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
TnxExceptionHookEvent = procedure (ExceptObj: TObject; ExceptAddr: Pointer; OSException: Boolean; var WriteToLog : Boolean) of object;
File

nxExceptionHook

Description

This is type nxExceptionHook.TnxExceptionHookEvent.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.TnxRemoveVectoredExceptionHandler Type

nxExceptionHook.TnxRemoveVectoredExceptionHandler Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
TnxRemoveVectoredExceptionHandler = function (VectoredHandlerHandle : PVOID) : ULONG;
File

nxExceptionHook

Description

This is type nxExceptionHook.TnxRemoveVectoredExceptionHandler.

Group

Types

Links
nxExceptionHook, Types


nxExceptionHook.ULONG_PTR Type

nxExceptionHook.ULONG_PTR Type
nxExceptionHook Types Send Feedback
Syntax
Delphi
ULONG_PTR = LongWord;
File

nxExceptionHook

Description

This is type nxExceptionHook.ULONG_PTR.

Group

Types

Links
nxExceptionHook, Types


Variables

Variables
nxExceptionHook Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxExceptionHook Namespace

Variables
Name | Description
_AddVectoredExceptionHandler | This is variable nxExceptionHook._AddVectoredExceptionHandler.
_ExceptionHook | This is variable nxExceptionHook._ExceptionHook.
_InVectoredHandler | This is variable nxExceptionHook._InVectoredHandler.
_RemoveVectoredExceptionHandler | This is variable nxExceptionHook._RemoveVectoredExceptionHandler.
_VectoredHandlerHandle | This is variable nxExceptionHook._VectoredHandlerHandle.
clientinfoList | This is variable nxExceptionHook.clientinfoList.
HasVectoredExceptionHandling | This is variable nxExceptionHook.HasVectoredExceptionHandling.
lFile | This is variable nxExceptionHook.lFile.
lSize | This is variable nxExceptionHook.lSize.
nxEHAppVersion | This is variable nxExceptionHook.nxEHAppVersion.
Links
nxExceptionHook Namespace, Variables


nxExceptionHook._AddVectoredExceptionHandler Variable

nxExceptionHook._AddVectoredExceptionHandler Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
_AddVectoredExceptionHandler: TnxAddVectoredExceptionHandler;
File

nxExceptionHook

Description

This is variable nxExceptionHook._AddVectoredExceptionHandler.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook._ExceptionHook Variable

nxExceptionHook._ExceptionHook Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
_ExceptionHook: TnxExceptionHook;
File

nxExceptionHook

Description

This is variable nxExceptionHook._ExceptionHook.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook._InVectoredHandler Variable

nxExceptionHook._InVectoredHandler Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
_InVectoredHandler: Boolean;
File

nxExceptionHook

Description

This is variable nxExceptionHook._InVectoredHandler.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook._RemoveVectoredExceptionHandler Variable

nxExceptionHook._RemoveVectoredExceptionHandler Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
_RemoveVectoredExceptionHandler: TnxRemoveVectoredExceptionHandler;
File

nxExceptionHook

Description

This is variable nxExceptionHook._RemoveVectoredExceptionHandler.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook._VectoredHandlerHandle Variable

nxExceptionHook._VectoredHandlerHandle Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
_VectoredHandlerHandle: PVOID;
File

nxExceptionHook

Description

This is variable nxExceptionHook._VectoredHandlerHandle.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook.clientinfoList Variable

nxExceptionHook.clientinfoList Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
clientinfoList: TStringlist;
File

nxExceptionHook

Description

This is variable nxExceptionHook.clientinfoList.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook.HasVectoredExceptionHandling Variable

nxExceptionHook.HasVectoredExceptionHandling Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
HasVectoredExceptionHandling: Boolean;
File

nxExceptionHook

Description

This is variable nxExceptionHook.HasVectoredExceptionHandling.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook.lFile Variable

nxExceptionHook.lFile Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
lFile: THandle;
File

nxExceptionHook

Description

This is variable nxExceptionHook.lFile.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook.lSize Variable

nxExceptionHook.lSize Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
lSize: DWord;
File

nxExceptionHook

Description

This is variable nxExceptionHook.lSize.

Group

Variables

Links
nxExceptionHook, Variables


nxExceptionHook.nxEHAppVersion Variable

nxExceptionHook.nxEHAppVersion Variable
nxExceptionHook Variables Send Feedback
Syntax
Delphi
nxEHAppVersion: string = '';
File

nxExceptionHook

Description

This is variable nxExceptionHook.nxEHAppVersion.

Group

Variables

Links
nxExceptionHook, Variables


Constants

Constants
Constants nxExceptionHook Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EXCEPTION_CONTINUE_SEARCH | This is constant nxExceptionHook.EXCEPTION_CONTINUE_SEARCH.
nxMaxFilesKept | number of files kept - set to 1 to always grow the log file
nxMaxLogSize | max log size in bytes
UnicodeBOF | This is constant nxExceptionHook.UnicodeBOF.
Namespace

nxExceptionHook Namespace

Links
Constants, nxExceptionHook Namespace


nxExceptionHook.EXCEPTION_CONTINUE_SEARCH Constant

nxExceptionHook.EXCEPTION_CONTINUE_SEARCH Constant
nxExceptionHook Constants Send Feedback
Syntax
Delphi
EXCEPTION_CONTINUE_SEARCH = 0;
File

nxExceptionHook

Description

This is constant nxExceptionHook.EXCEPTION_CONTINUE_SEARCH.

Group

Constants

Links
nxExceptionHook, Constants


nxExceptionHook.nxMaxFilesKept Constant

nxExceptionHook.nxMaxFilesKept Constant
nxExceptionHook Constants Send Feedback
Syntax
Delphi
nxMaxFilesKept = 3;
File

nxExceptionHook

Description

number of files kept - set to 1 to always grow the log file

Group

Constants

Links
nxExceptionHook, Constants


nxExceptionHook.nxMaxLogSize Constant

nxExceptionHook.nxMaxLogSize Constant
nxExceptionHook Constants Send Feedback
Syntax
Delphi
nxMaxLogSize = 50 * 1024 * 1024;
File

nxExceptionHook

Description

max log size in bytes

Group

Constants

Links
nxExceptionHook, Constants


nxExceptionHook.UnicodeBOF Constant

nxExceptionHook.UnicodeBOF Constant
nxExceptionHook Constants Send Feedback
Syntax
Delphi
UnicodeBOF: array[0..1] of byte = ($FF, $FE);
File

nxExceptionHook

Description

This is constant nxExceptionHook.UnicodeBOF.

Group

Constants

Links
nxExceptionHook, Constants


nxExeConst Namespace

nxExeConst Namespace
Constants Topics Send Feedback

This is namespace nxExeConst.

Constants
Name | Description
nxAppDataSubdirVista | This is constant nxExeConst.nxAppDataSubdirVista.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxExeConst Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxAppDataSubdirVista | This is constant nxExeConst.nxAppDataSubdirVista.
Namespace

nxExeConst Namespace

Links
Constants, nxExeConst Namespace


nxExeConst.nxAppDataSubdirVista Constant

nxExeConst.nxAppDataSubdirVista Constant
nxExeConst Constants Send Feedback
Syntax
Delphi
nxAppDataSubdirVista: string = 'NexusDB4\Default';
File

nxExeConst

Description

This is constant nxExeConst.nxAppDataSubdirVista.

Group

Constants

Links
nxExeConst, Constants


nxivIntfInfo Namespace

nxivIntfInfo Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Variables Send Feedback

This is namespace nxivIntfInfo.

Classes
Name | Description
EInterfaceRTTIException | This is class nxivIntfInfo.EInterfaceRTTIException.
Constants
Name | Description
CCMap | This is constant nxivIntfInfo.CCMap.
csHRESULT | This is constant nxivIntfInfo.csHRESULT.
csResult | This is constant nxivIntfInfo.csResult.
csSafeResult | This is constant nxivIntfInfo.csSafeResult.
rsNoRTTIParam | This is constant nxivIntfInfo.rsNoRTTIParam.
Functions
Name | Description
DecodeRTTIString | This is function nxivIntfInfo.DecodeRTTIString.
nxGetIntfMetaData | This is function nxivIntfInfo.nxGetIntfMetaData.
nxGetIntfMetaData | This is function nxivIntfInfo.nxGetIntfMetaData.
Structs, Records, Enums
Name | Description
TnxFillMethodArrayOpt | Governs how the MDA array is filled
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
Context | This is variable nxivIntfInfo.Context.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Variables


Classes

Classes
Classes nxivIntfInfo Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EInterfaceRTTIException | This is class nxivIntfInfo.EInterfaceRTTIException.
Namespace

nxivIntfInfo Namespace

Links
Classes, nxivIntfInfo Namespace, Legend


EInterfaceRTTIException Class

EInterfaceRTTIException Class
nxivIntfInfo Classes Send Feedback
Class Hierarchy
nxivIntfInfo_EInterfaceRTTIException
Syntax
Delphi
EInterfaceRTTIException = class(Exception);
File

nxivIntfInfo

Description

This is class nxivIntfInfo.EInterfaceRTTIException.

Group

Classes

Links
nxivIntfInfo, Classes


Functions

Functions
Functions nxivIntfInfo Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
DecodeRTTIString | This is function nxivIntfInfo.DecodeRTTIString.
nxGetIntfMetaData | This is function nxivIntfInfo.nxGetIntfMetaData.
nxGetIntfMetaData | This is function nxivIntfInfo.nxGetIntfMetaData.
Namespace

nxivIntfInfo Namespace

Links
Functions, nxivIntfInfo Namespace, Legend


nxivIntfInfo.DecodeRTTIString Function

nxivIntfInfo.DecodeRTTIString Function
nxivIntfInfo Functions Send Feedback
Syntax
Delphi
function DecodeRTTIString(const s: ShortString): string;
File

nxivIntfInfo

Description

This is function nxivIntfInfo.DecodeRTTIString.

Group

Functions

Links
nxivIntfInfo, Functions


nxivIntfInfo.nxGetIntfMetaData Function

nxivIntfInfo.nxGetIntfMetaData Function
nxivIntfInfo Functions Send Feedback
Syntax
Delphi
procedure nxGetIntfMetaData(Info: PTypeInfo; var IntfMD: TnxIntfMetaData; IncludeAllAncMethods: Boolean = False); overload;
File

nxivIntfInfo

Description

This is function nxivIntfInfo.nxGetIntfMetaData.

Group

Functions

Links
nxivIntfInfo, Functions


nxivIntfInfo.nxGetIntfMetaData Function

nxivIntfInfo.nxGetIntfMetaData Function
nxivIntfInfo Functions Send Feedback
Syntax
Delphi
procedure nxGetIntfMetaData(Info: PTypeInfo; var IntfMD: TnxIntfMetaData; MethodArrayOpt: TnxFillMethodArrayOpt); overload;
File

nxivIntfInfo

Description

This is function nxivIntfInfo.nxGetIntfMetaData.

Group

Functions

Links
nxivIntfInfo, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxivIntfInfo Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxFillMethodArrayOpt | Governs how the MDA array is filled
Namespace

nxivIntfInfo Namespace

Links
Enumerations, nxivIntfInfo Namespace, Legend


nxivIntfInfo.TnxFillMethodArrayOpt Enumeration

nxivIntfInfo.TnxFillMethodArrayOpt Enumeration
nxivIntfInfo Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxFillMethodArrayOpt = ( fmoAllBaseMethods, fmoRTTIBaseMethods, fmoNoBaseMethods );
File

nxivIntfInfo

Description

Governs how the MDA array is filled

Group

Structs, Records, Enums

Links
nxivIntfInfo, Structs, Records, Enums


Variables

Variables
nxivIntfInfo Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxivIntfInfo Namespace

Variables
Name | Description
Context | This is variable nxivIntfInfo.Context.
Links
nxivIntfInfo Namespace, Variables


nxivIntfInfo.Context Variable

nxivIntfInfo.Context Variable
nxivIntfInfo Variables Send Feedback
Syntax
Delphi
Context: TRttiContext;
File

nxivIntfInfo

Description

This is variable nxivIntfInfo.Context.

Group

Variables

Links
nxivIntfInfo, Variables


Constants

Constants
Constants nxivIntfInfo Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
CCMap | This is constant nxivIntfInfo.CCMap.
csHRESULT | This is constant nxivIntfInfo.csHRESULT.
csResult | This is constant nxivIntfInfo.csResult.
csSafeResult | This is constant nxivIntfInfo.csSafeResult.
rsNoRTTIParam | This is constant nxivIntfInfo.rsNoRTTIParam.
Namespace

nxivIntfInfo Namespace

Links
Constants, nxivIntfInfo Namespace


nxivIntfInfo.CCMap Constant

nxivIntfInfo.CCMap Constant
nxivIntfInfo Constants Send Feedback
Syntax
Delphi
CCMap: array[0..4] of TnxCallConv = (ccReg, ccCdecl, ccPascal, ccStdCall, ccSafeCall);
File

nxivIntfInfo

Description

This is constant nxivIntfInfo.CCMap.

Group

Constants

Links
nxivIntfInfo, Constants


nxivIntfInfo.csHRESULT Constant

nxivIntfInfo.csHRESULT Constant
nxivIntfInfo Constants Send Feedback
Syntax
Delphi
csHRESULT: string[7] = 'HRESULT';
File

nxivIntfInfo

Description

This is constant nxivIntfInfo.csHRESULT.

Group

Constants

Links
nxivIntfInfo, Constants


nxivIntfInfo.csResult Constant

nxivIntfInfo.csResult Constant
nxivIntfInfo Constants Send Feedback
Syntax
Delphi
csResult: string[10] = '__Result__';
File

nxivIntfInfo

Description

This is constant nxivIntfInfo.csResult.

Group

Constants

Links
nxivIntfInfo, Constants


nxivIntfInfo.csSafeResult Constant

nxivIntfInfo.csSafeResult Constant
nxivIntfInfo Constants Send Feedback
Syntax
Delphi
csSafeResult: string[14] = '__SafeResult__';
File

nxivIntfInfo

Description

This is constant nxivIntfInfo.csSafeResult.

Group

Constants

Links
nxivIntfInfo, Constants


nxivIntfInfo.rsNoRTTIParam Constant

nxivIntfInfo.rsNoRTTIParam Constant
nxivIntfInfo Constants Send Feedback
Syntax
Delphi
rsNoRTTIParam = 'Parameter "%s" on Method "%s" of Interface "%s.%s" has no RTTI';
File

nxivIntfInfo

Description

This is constant nxivIntfInfo.rsNoRTTIParam.

Group

Constants

Links
nxivIntfInfo, Constants


nxivRegistry Namespace

nxivRegistry Namespace
Classes Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxivRegistry.

Classes
Name | Description
TnxAllocatedCallFrame | This is class nxivRegistry.TnxAllocatedCallFrame.
TnxAllocatedDispatchedCallFrame | This is class nxivRegistry.TnxAllocatedDispatchedCallFrame.
TnxBaseCallFrame | This is class nxivRegistry.TnxBaseCallFrame.
TnxCodeGen | This is class nxivRegistry.TnxCodeGen.
TnxDispatchedCallFrame | This is class nxivRegistry.TnxDispatchedCallFrame.
TnxDynamicInvokeProxy | This is class nxivRegistry.TnxDynamicInvokeProxy.
TnxDynamicInvokeProxyFactory | This is class nxivRegistry.TnxDynamicInvokeProxyFactory.
TnxDynamicInvokeStub | This is class nxivRegistry.TnxDynamicInvokeStub.
TnxDynamicInvokeStubFactory | This is class nxivRegistry.TnxDynamicInvokeStubFactory.
TnxGeneratedInvokeProxy | This is class nxivRegistry.TnxGeneratedInvokeProxy.
TnxGeneratedInvokeProxyDispatcher | This is class nxivRegistry.TnxGeneratedInvokeProxyDispatcher.
TnxGeneratedInvokeProxyFactory | This is class nxivRegistry.TnxGeneratedInvokeProxyFactory.
TnxGeneratedInvokeStub | This is class nxivRegistry.TnxGeneratedInvokeStub.
TnxGeneratedInvokeStubFactory | This is class nxivRegistry.TnxGeneratedInvokeStubFactory.
TnxInvokeRegistry | This is class nxivRegistry.TnxInvokeRegistry.
TnxInvokeWrapper | This is class nxivRegistry.TnxInvokeWrapper.
TnxInvokeWrapperDispatcher | This is class nxivRegistry.TnxInvokeWrapperDispatcher.
TnxRTTIInvokeStub | This is class nxivRegistry.TnxRTTIInvokeStub.
TnxRTTIInvokeStub_ | This is class nxivRegistry.TnxRTTIInvokeStub_.
TnxRTTIInvokeStubFactory | This is class nxivRegistry.TnxRTTIInvokeStubFactory.
Structs, Records, Enums
Name | Description
TnxCodeStore | This is record nxivRegistry.TnxCodeStore.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxCodeStore | TnxCodeGen
PnxGeneratedInvokeProxyHandlers | This is type nxivRegistry.PnxGeneratedInvokeProxyHandlers.
TnxGeneratedInvokeProxyHandler | This is type nxivRegistry.TnxGeneratedInvokeProxyHandler.
TnxGeneratedInvokeProxyHandlers | This is type nxivRegistry.TnxGeneratedInvokeProxyHandlers.
TnxGeneratedInvokeStubClass | This is type nxivRegistry.TnxGeneratedInvokeStubClass.
Variables
Name | Description
_StubAddRef | This is variable nxivRegistry._StubAddRef.
_StubEntry | This is variable nxivRegistry._StubEntry.
_StubQueryInterface | This is variable nxivRegistry._StubQueryInterface.
_StubRelease | This is variable nxivRegistry._StubRelease.
_StubVTableOffset | This is variable nxivRegistry._StubVTableOffset.
Args | This is variable nxivRegistry.Args.
i | This is variable nxivRegistry.i.
Instance | This is variable nxivRegistry.Instance.
Params | This is variable nxivRegistry.Params.
pCodeStoreHead | This is variable nxivRegistry.pCodeStoreHead.
plCodeStore | This is variable nxivRegistry.plCodeStore.
Res | This is variable nxivRegistry.Res.
ResultIdx | This is variable nxivRegistry.ResultIdx.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxivRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAllocatedCallFrame | This is class nxivRegistry.TnxAllocatedCallFrame.
TnxAllocatedDispatchedCallFrame | This is class nxivRegistry.TnxAllocatedDispatchedCallFrame.
TnxBaseCallFrame | This is class nxivRegistry.TnxBaseCallFrame.
TnxCodeGen | This is class nxivRegistry.TnxCodeGen.
TnxDispatchedCallFrame | This is class nxivRegistry.TnxDispatchedCallFrame.
TnxDynamicInvokeProxy | This is class nxivRegistry.TnxDynamicInvokeProxy.
TnxDynamicInvokeProxyFactory | This is class nxivRegistry.TnxDynamicInvokeProxyFactory.
TnxDynamicInvokeStub | This is class nxivRegistry.TnxDynamicInvokeStub.
TnxDynamicInvokeStubFactory | This is class nxivRegistry.TnxDynamicInvokeStubFactory.
TnxGeneratedInvokeProxy | This is class nxivRegistry.TnxGeneratedInvokeProxy.
TnxGeneratedInvokeProxyDispatcher | This is class nxivRegistry.TnxGeneratedInvokeProxyDispatcher.
TnxGeneratedInvokeProxyFactory | This is class nxivRegistry.TnxGeneratedInvokeProxyFactory.
TnxGeneratedInvokeStub | This is class nxivRegistry.TnxGeneratedInvokeStub.
TnxGeneratedInvokeStubFactory | This is class nxivRegistry.TnxGeneratedInvokeStubFactory.
TnxInvokeRegistry | This is class nxivRegistry.TnxInvokeRegistry.
TnxInvokeWrapper | This is class nxivRegistry.TnxInvokeWrapper.
TnxInvokeWrapperDispatcher | This is class nxivRegistry.TnxInvokeWrapperDispatcher.
TnxRTTIInvokeStub | This is class nxivRegistry.TnxRTTIInvokeStub.
TnxRTTIInvokeStub_ | This is class nxivRegistry.TnxRTTIInvokeStub_.
TnxRTTIInvokeStubFactory | This is class nxivRegistry.TnxRTTIInvokeStubFactory.
Namespace

nxivRegistry Namespace

Links
Classes, nxivRegistry Namespace, Legend


TnxAllocatedCallFrame Class

TnxAllocatedCallFrame Class
TnxAllocatedCallFrame Fields TnxAllocatedCallFrame Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFramenxivRegistry_TnxAllocatedCallFrame
Syntax
Delphi
TnxAllocatedCallFrame = class(TnxBaseCallFrame);
File

nxivRegistry

Description

This is class nxivRegistry.TnxAllocatedCallFrame.

Group

Classes

Links
TnxAllocatedCallFrame Fields, TnxAllocatedCallFrame Members, nxivRegistry, Classes


TnxAllocatedCallFrame Members

TnxAllocatedCallFrame Members
TnxAllocatedCallFrame Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAllocatedCallFrame.

Class

TnxAllocatedCallFrame Class

Protected Fields
Name | Description
acfBuffer | This is acfBuffer, a member of class TnxAllocatedCallFrame.
acfParams | private
bcfCode | This is bcfCode, a member of class TnxBaseCallFrame.
bcfInterface | This is bcfInterface, a member of class TnxBaseCallFrame.
bcfMetaData | private
bcfMethod | This is bcfMethod, a member of class TnxBaseCallFrame.
bcfParams | This is bcfParams, a member of class TnxBaseCallFrame.
bcfSelfParam | This is bcfSelfParam, a member of class TnxBaseCallFrame.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyFrom | InxCallFrame TnxBaseCallFrame
GetIntfMetaData | InxInvokeHasIntfMetaData
GetIntfMethEntry | InxInvokeHasIntfMethEntry
ioDeactivate |
MakeCall | This is MakeCall, a member of class TnxBaseCallFrame.
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
CopyFrom | This is CopyFrom, a member of class InxCallFrame.
Create | TnxAllocatedCallFrame
Destroy | This is Destroy, a member of class TnxAllocatedCallFrame.
Free |
FreeInstance |
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
MakeCall | This is MakeCall, a member of class InxCallFrame.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxAllocatedCallFrame Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAllocatedCallFrame.Create Constructor

TnxAllocatedCallFrame.Create Constructor
TnxAllocatedCallFrame Class TnxAllocatedCallFrame Members nxivRegistry Namespace TnxAllocatedCallFrame Class Send Feedback
Syntax
Delphi
constructor Create(const aMetaData: PnxIntfMetaData; const aMethod: PnxIntfMethEntry; out aParams: PnxPointerArray; const aInterface: InxInterface);
Description

TnxAllocatedCallFrame

Class

TnxAllocatedCallFrame Class

Links
TnxAllocatedCallFrame Class, TnxAllocatedCallFrame Members, nxivRegistry Namespace, TnxAllocatedCallFrame Class


TnxAllocatedCallFrame.Destroy Destructor

TnxAllocatedCallFrame.Destroy Destructor
TnxAllocatedCallFrame Class TnxAllocatedCallFrame Members nxivRegistry Namespace TnxAllocatedCallFrame Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxAllocatedCallFrame.

Class

TnxAllocatedCallFrame Class

Links
TnxAllocatedCallFrame Class, TnxAllocatedCallFrame Members, nxivRegistry Namespace, TnxAllocatedCallFrame Class


TnxAllocatedCallFrame Fields

TnxAllocatedCallFrame Fields
TnxAllocatedCallFrame Class Legend Protected Fields Send Feedback

The fields of the TnxAllocatedCallFrame class are listed here.

Class

TnxAllocatedCallFrame Class

Protected Fields
Name | Description
acfBuffer | This is acfBuffer, a member of class TnxAllocatedCallFrame.
acfParams | private
Links
TnxAllocatedCallFrame Class, Legend, Protected Fields


TnxAllocatedCallFrame.acfBuffer Field

TnxAllocatedCallFrame.acfBuffer Field
TnxAllocatedCallFrame Class TnxAllocatedCallFrame Members nxivRegistry Namespace TnxAllocatedCallFrame Fields Send Feedback
Syntax
Delphi
acfBuffer: TnxDynByteArray;
Description

This is acfBuffer, a member of class TnxAllocatedCallFrame.

Group

TnxAllocatedCallFrame Fields

Links
TnxAllocatedCallFrame Class, TnxAllocatedCallFrame Members, nxivRegistry Namespace, TnxAllocatedCallFrame Fields


TnxAllocatedCallFrame.acfParams Field

TnxAllocatedCallFrame.acfParams Field
TnxAllocatedCallFrame Class TnxAllocatedCallFrame Members nxivRegistry Namespace TnxAllocatedCallFrame Fields Send Feedback
Syntax
Delphi
acfParams: TnxDynPointerArray;
Description

private

Group

TnxAllocatedCallFrame Fields

Links
TnxAllocatedCallFrame Class, TnxAllocatedCallFrame Members, nxivRegistry Namespace, TnxAllocatedCallFrame Fields


TnxAllocatedDispatchedCallFrame Class

TnxAllocatedDispatchedCallFrame Class
TnxAllocatedDispatchedCallFrame Fields TnxAllocatedDispatchedCallFrame Methods TnxAllocatedDispatchedCallFrame Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFramenxivRegistry_TnxAllocatedDispatchedCallFrame
Syntax
Delphi
TnxAllocatedDispatchedCallFrame = class(TnxAllocatedCallFrame, InxCallFrame);
File

nxivRegistry

Description

This is class nxivRegistry.TnxAllocatedDispatchedCallFrame.

Group

Classes

Links
TnxAllocatedDispatchedCallFrame Fields, TnxAllocatedDispatchedCallFrame Methods, TnxAllocatedDispatchedCallFrame Members, nxivRegistry, Classes


TnxAllocatedDispatchedCallFrame Members

TnxAllocatedDispatchedCallFrame Members
TnxAllocatedDispatchedCallFrame Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAllocatedDispatchedCallFrame.

Class

TnxAllocatedDispatchedCallFrame Class

Protected Fields
Name | Description
acfBuffer | This is acfBuffer, a member of class TnxAllocatedCallFrame.
acfParams | private
adcfDispatcher | private
bcfCode | This is bcfCode, a member of class TnxBaseCallFrame.
bcfInterface | This is bcfInterface, a member of class TnxBaseCallFrame.
bcfMetaData | private
bcfMethod | This is bcfMethod, a member of class TnxBaseCallFrame.
bcfParams | This is bcfParams, a member of class TnxBaseCallFrame.
bcfSelfParam | This is bcfSelfParam, a member of class TnxBaseCallFrame.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyFrom | InxCallFrame TnxBaseCallFrame
GetIntfMetaData | InxInvokeHasIntfMetaData
GetIntfMethEntry | InxInvokeHasIntfMethEntry
ioDeactivate |
MakeCall | InxCallFrame
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
CopyFrom | This is CopyFrom, a member of class InxCallFrame.
Create | TnxAllocatedDispatchedCallFrame
Destroy | This is Destroy, a member of class TnxAllocatedCallFrame.
Free |
FreeInstance |
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxAllocatedDispatchedCallFrame Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAllocatedDispatchedCallFrame.Create Constructor

TnxAllocatedDispatchedCallFrame.Create Constructor
TnxAllocatedDispatchedCallFrame Class TnxAllocatedDispatchedCallFrame Members nxivRegistry Namespace TnxAllocatedDispatchedCallFrame Class Send Feedback
Syntax
Delphi
constructor Create(const aMetaData: PnxIntfMetaData; const aMethod: PnxIntfMethEntry; out aParams: PnxPointerArray; const aInterface: InxInterface; const aDispatcher: InxInvokeDispatcher);
Description

TnxAllocatedDispatchedCallFrame

Class

TnxAllocatedDispatchedCallFrame Class

Links
TnxAllocatedDispatchedCallFrame Class, TnxAllocatedDispatchedCallFrame Members, nxivRegistry Namespace, TnxAllocatedDispatchedCallFrame Class


TnxAllocatedDispatchedCallFrame Fields

TnxAllocatedDispatchedCallFrame Fields
TnxAllocatedDispatchedCallFrame Class Legend Protected Fields Send Feedback

The fields of the TnxAllocatedDispatchedCallFrame class are listed here.

Class

TnxAllocatedDispatchedCallFrame Class

Protected Fields
Name | Description
adcfDispatcher | private
Links
TnxAllocatedDispatchedCallFrame Class, Legend, Protected Fields


TnxAllocatedDispatchedCallFrame.adcfDispatcher Field

TnxAllocatedDispatchedCallFrame.adcfDispatcher Field
TnxAllocatedDispatchedCallFrame Class TnxAllocatedDispatchedCallFrame Members nxivRegistry Namespace TnxAllocatedDispatchedCallFrame Fields Send Feedback
Syntax
Delphi
adcfDispatcher: InxInvokeDispatcher;
Description

private

Group

TnxAllocatedDispatchedCallFrame Fields

Links
TnxAllocatedDispatchedCallFrame Class, TnxAllocatedDispatchedCallFrame Members, nxivRegistry Namespace, TnxAllocatedDispatchedCallFrame Fields


TnxAllocatedDispatchedCallFrame Methods

TnxAllocatedDispatchedCallFrame Methods
TnxAllocatedDispatchedCallFrame Class Legend Protected Methods Send Feedback

The methods of the TnxAllocatedDispatchedCallFrame class are listed here.

Class

TnxAllocatedDispatchedCallFrame Class

Protected Methods
Name | Description
MakeCall | InxCallFrame
Links
TnxAllocatedDispatchedCallFrame Class, Legend, Protected Methods


TnxAllocatedDispatchedCallFrame.MakeCall Method

TnxAllocatedDispatchedCallFrame.MakeCall Method
TnxAllocatedDispatchedCallFrame Class TnxAllocatedDispatchedCallFrame Members nxivRegistry Namespace TnxAllocatedDispatchedCallFrame Methods Send Feedback
Syntax
Delphi
function MakeCall: HRESULT;
Description

InxCallFrame

Group

TnxAllocatedDispatchedCallFrame Methods

Links
TnxAllocatedDispatchedCallFrame Class, TnxAllocatedDispatchedCallFrame Members, nxivRegistry Namespace, TnxAllocatedDispatchedCallFrame Methods


TnxBaseCallFrame Class

TnxBaseCallFrame Class
TnxBaseCallFrame Fields TnxBaseCallFrame Methods TnxBaseCallFrame Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxBaseCallFramenxivRegistry_TnxBaseCallFramenxivRegistry_TnxBaseCallFramenxivRegistry_TnxBaseCallFramenxivRegistry_TnxBaseCallFramenxivRegistry_TnxBaseCallFrame
Syntax
Delphi
TnxBaseCallFrame = class(TnxInterfacedObject, InxInterface, InxInvokeHasIntfMetaData, InxInvokeHasIntfMethEntry, InxCallFrame);
File

nxivRegistry

Description

This is class nxivRegistry.TnxBaseCallFrame.

Group

Classes

Links
TnxBaseCallFrame Fields, TnxBaseCallFrame Methods, TnxBaseCallFrame Members, nxivRegistry, Classes


TnxBaseCallFrame Members

TnxBaseCallFrame Members
TnxBaseCallFrame Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseCallFrame.

Class

TnxBaseCallFrame Class

Protected Fields
Name | Description
bcfCode | This is bcfCode, a member of class TnxBaseCallFrame.
bcfInterface | This is bcfInterface, a member of class TnxBaseCallFrame.
bcfMetaData | private
bcfMethod | This is bcfMethod, a member of class TnxBaseCallFrame.
bcfParams | This is bcfParams, a member of class TnxBaseCallFrame.
bcfSelfParam | This is bcfSelfParam, a member of class TnxBaseCallFrame.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyFrom | InxCallFrame TnxBaseCallFrame
GetIntfMetaData | InxInvokeHasIntfMetaData
GetIntfMethEntry | InxInvokeHasIntfMethEntry
ioDeactivate |
MakeCall | This is MakeCall, a member of class TnxBaseCallFrame.
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | This is Create, a member of class TnxBaseCallFrame.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxBaseCallFrame Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseCallFrame.Create Constructor

TnxBaseCallFrame.Create Constructor
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Class Send Feedback
Syntax
Delphi
constructor Create(const aMetaData: PnxIntfMetaData; const aMethod: PnxIntfMethEntry; const aParams: PnxPointerArray; const aInterface: InxInterface);
Description

This is Create, a member of class TnxBaseCallFrame.

Class

TnxBaseCallFrame Class

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Class


TnxBaseCallFrame Fields

TnxBaseCallFrame Fields
TnxBaseCallFrame Class Legend Protected Fields Send Feedback

The fields of the TnxBaseCallFrame class are listed here.

Class

TnxBaseCallFrame Class

Protected Fields
Name | Description
bcfCode | This is bcfCode, a member of class TnxBaseCallFrame.
bcfInterface | This is bcfInterface, a member of class TnxBaseCallFrame.
bcfMetaData | private
bcfMethod | This is bcfMethod, a member of class TnxBaseCallFrame.
bcfParams | This is bcfParams, a member of class TnxBaseCallFrame.
bcfSelfParam | This is bcfSelfParam, a member of class TnxBaseCallFrame.
Links
TnxBaseCallFrame Class, Legend, Protected Fields


TnxBaseCallFrame.bcfCode Field

TnxBaseCallFrame.bcfCode Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfCode: Pointer;
Description

This is bcfCode, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame.bcfInterface Field

TnxBaseCallFrame.bcfInterface Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfInterface: InxInterface;
Description

This is bcfInterface, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame.bcfMetaData Field

TnxBaseCallFrame.bcfMetaData Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfMetaData: PnxIntfMetaData;
Description

private

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame.bcfMethod Field

TnxBaseCallFrame.bcfMethod Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfMethod: PnxIntfMethEntry;
Description

This is bcfMethod, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame.bcfParams Field

TnxBaseCallFrame.bcfParams Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfParams: PnxPointerArray;
Description

This is bcfParams, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame.bcfSelfParam Field

TnxBaseCallFrame.bcfSelfParam Field
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Fields Send Feedback
Syntax
Delphi
bcfSelfParam: Pointer;
Description

This is bcfSelfParam, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Fields

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Fields


TnxBaseCallFrame Methods

TnxBaseCallFrame Methods
TnxBaseCallFrame Class Legend Protected Methods Send Feedback

The methods of the TnxBaseCallFrame class are listed here.

Class

TnxBaseCallFrame Class

Protected Methods
Name | Description
CopyFrom | InxCallFrame TnxBaseCallFrame
GetIntfMetaData | InxInvokeHasIntfMetaData
GetIntfMethEntry | InxInvokeHasIntfMethEntry
MakeCall | This is MakeCall, a member of class TnxBaseCallFrame.
Links
TnxBaseCallFrame Class, Legend, Protected Methods


TnxBaseCallFrame.CopyFrom Method

TnxBaseCallFrame.CopyFrom Method
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Methods Send Feedback
Syntax
Delphi
function CopyFrom(aParams: PnxPointerArray): HRESULT;
Description

InxCallFrame

TnxBaseCallFrame

Group

TnxBaseCallFrame Methods

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Methods


TnxBaseCallFrame.GetIntfMetaData Method

TnxBaseCallFrame.GetIntfMetaData Method
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

InxInvokeHasIntfMetaData

Group

TnxBaseCallFrame Methods

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Methods


TnxBaseCallFrame.GetIntfMethEntry Method

TnxBaseCallFrame.GetIntfMethEntry Method
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Methods Send Feedback
Syntax
Delphi
function GetIntfMethEntry: PnxIntfMethEntry;
Description

InxInvokeHasIntfMethEntry

Group

TnxBaseCallFrame Methods

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Methods


TnxBaseCallFrame.MakeCall Method

TnxBaseCallFrame.MakeCall Method
TnxBaseCallFrame Class TnxBaseCallFrame Members nxivRegistry Namespace TnxBaseCallFrame Methods Send Feedback
Syntax
Delphi
function MakeCall: HRESULT;
Description

This is MakeCall, a member of class TnxBaseCallFrame.

Group

TnxBaseCallFrame Methods

Links
TnxBaseCallFrame Class, TnxBaseCallFrame Members, nxivRegistry Namespace, TnxBaseCallFrame Methods


TnxCodeGen Class

TnxCodeGen Class
TnxCodeGen Fields TnxCodeGen Methods TnxCodeGen Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxCodeGen
Syntax
Delphi
TnxCodeGen = class(TObject);
File

nxivRegistry

Description

This is class nxivRegistry.TnxCodeGen.

Group

Classes

Links
TnxCodeGen Fields, TnxCodeGen Methods, TnxCodeGen Members, nxivRegistry, Classes


TnxCodeGen Members

TnxCodeGen Members
TnxCodeGen Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCodeGen.

Class

TnxCodeGen Class

Protected Fields
Name | Description
cgBuffer | This is cgBuffer, a member of class TnxCodeGen.
cgPos | This is cgPos, a member of class TnxCodeGen.
Protected Methods
Name | Description
WriteByte | This is WriteByte, a member of class TnxCodeGen.
WriteCardinal | This is WriteCardinal, a member of class TnxCodeGen.
Public Methods
Name | Description
Alloc | This is Alloc, a member of class TnxCodeGen.
Call | This is Call, a member of class TnxCodeGen.
LeaECXESPPlus | This is LeaECXESPPlus, a member of class TnxCodeGen.
MovEAXESPPlus | This is MovEAXESPPlus, a member of class TnxCodeGen.
MovECXESP | This is MovECXESP, a member of class TnxCodeGen.
MovEDX | This is MovEDX, a member of class TnxCodeGen.
PopECX | This is PopECX, a member of class TnxCodeGen.
PushEAX | This is PushEAX, a member of class TnxCodeGen.
PushECX | This is PushECX, a member of class TnxCodeGen.
PushEDX | This is PushEDX, a member of class TnxCodeGen.
Ret | This is Ret, a member of class TnxCodeGen.
SubEAX | This is SubEAX, a member of class TnxCodeGen.
Links
TnxCodeGen Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCodeGen Fields

TnxCodeGen Fields
TnxCodeGen Class Legend Protected Fields Send Feedback

The fields of the TnxCodeGen class are listed here.

Class

TnxCodeGen Class

Protected Fields
Name | Description
cgBuffer | This is cgBuffer, a member of class TnxCodeGen.
cgPos | This is cgPos, a member of class TnxCodeGen.
Links
TnxCodeGen Class, Legend, Protected Fields


TnxCodeGen.cgBuffer Field

TnxCodeGen.cgBuffer Field
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Fields Send Feedback
Syntax
Delphi
cgBuffer: array[0..511] of Byte;
Description

This is cgBuffer, a member of class TnxCodeGen.

Group

TnxCodeGen Fields

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Fields


TnxCodeGen.cgPos Field

TnxCodeGen.cgPos Field
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Fields Send Feedback
Syntax
Delphi
cgPos: Integer;
Description

This is cgPos, a member of class TnxCodeGen.

Group

TnxCodeGen Fields

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Fields


TnxCodeGen Methods

TnxCodeGen Methods
TnxCodeGen Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCodeGen class are listed here.

Class

TnxCodeGen Class

Protected Methods
Name | Description
WriteByte | This is WriteByte, a member of class TnxCodeGen.
WriteCardinal | This is WriteCardinal, a member of class TnxCodeGen.
Public Methods
Name | Description
Alloc | This is Alloc, a member of class TnxCodeGen.
Call | This is Call, a member of class TnxCodeGen.
LeaECXESPPlus | This is LeaECXESPPlus, a member of class TnxCodeGen.
MovEAXESPPlus | This is MovEAXESPPlus, a member of class TnxCodeGen.
MovECXESP | This is MovECXESP, a member of class TnxCodeGen.
MovEDX | This is MovEDX, a member of class TnxCodeGen.
PopECX | This is PopECX, a member of class TnxCodeGen.
PushEAX | This is PushEAX, a member of class TnxCodeGen.
PushECX | This is PushECX, a member of class TnxCodeGen.
PushEDX | This is PushEDX, a member of class TnxCodeGen.
Ret | This is Ret, a member of class TnxCodeGen.
SubEAX | This is SubEAX, a member of class TnxCodeGen.
Links
TnxCodeGen Class, Legend, Protected Methods, Public Methods


TnxCodeGen.Alloc Method

TnxCodeGen.Alloc Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
function Alloc: Pointer;
Description

This is Alloc, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.Call Method

TnxCodeGen.Call Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure Call(aPointer: Pointer);
Description

This is Call, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.LeaECXESPPlus Method

TnxCodeGen.LeaECXESPPlus Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure LeaECXESPPlus(aByte: Byte);
Description

This is LeaECXESPPlus, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.MovEAXESPPlus Method

TnxCodeGen.MovEAXESPPlus Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure MovEAXESPPlus(aByte: Byte);
Description

This is MovEAXESPPlus, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.MovECXESP Method

TnxCodeGen.MovECXESP Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure MovECXESP;
Description

This is MovECXESP, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.MovEDX Method

TnxCodeGen.MovEDX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure MovEDX(aCardinal: Cardinal);
Description

This is MovEDX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.PopECX Method

TnxCodeGen.PopECX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure PopECX;
Description

This is PopECX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.PushEAX Method

TnxCodeGen.PushEAX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure PushEAX;
Description

This is PushEAX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.PushECX Method

TnxCodeGen.PushECX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure PushECX;
Description

This is PushECX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.PushEDX Method

TnxCodeGen.PushEDX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure PushEDX;
Description

This is PushEDX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.Ret Method

TnxCodeGen.Ret Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure Ret(aBytesToCleanUp: Word);
Description

This is Ret, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.SubEAX Method

TnxCodeGen.SubEAX Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure SubEAX(aByte: Byte);
Description

This is SubEAX, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.WriteByte Method

TnxCodeGen.WriteByte Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure WriteByte(aByte: Byte);
Description

This is WriteByte, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxCodeGen.WriteCardinal Method

TnxCodeGen.WriteCardinal Method
TnxCodeGen Class TnxCodeGen Members nxivRegistry Namespace TnxCodeGen Methods Send Feedback
Syntax
Delphi
procedure WriteCardinal(aCardinal: Cardinal);
Description

This is WriteCardinal, a member of class TnxCodeGen.

Group

TnxCodeGen Methods

Links
TnxCodeGen Class, TnxCodeGen Members, nxivRegistry Namespace, TnxCodeGen Methods


TnxDispatchedCallFrame Class

TnxDispatchedCallFrame Class
TnxDispatchedCallFrame Fields TnxDispatchedCallFrame Methods TnxDispatchedCallFrame Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFramenxivRegistry_TnxDispatchedCallFrame
Syntax
Delphi
TnxDispatchedCallFrame = class(TnxBaseCallFrame, InxCallFrame);
File

nxivRegistry

Description

This is class nxivRegistry.TnxDispatchedCallFrame.

Group

Classes

Links
TnxDispatchedCallFrame Fields, TnxDispatchedCallFrame Methods, TnxDispatchedCallFrame Members, nxivRegistry, Classes


TnxDispatchedCallFrame Members

TnxDispatchedCallFrame Members
TnxDispatchedCallFrame Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDispatchedCallFrame.

Class

TnxDispatchedCallFrame Class

Protected Fields
Name | Description
bcfCode | This is bcfCode, a member of class TnxBaseCallFrame.
bcfInterface | This is bcfInterface, a member of class TnxBaseCallFrame.
bcfMetaData | private
bcfMethod | This is bcfMethod, a member of class TnxBaseCallFrame.
bcfParams | This is bcfParams, a member of class TnxBaseCallFrame.
bcfSelfParam | This is bcfSelfParam, a member of class TnxBaseCallFrame.
dcfDispatcher | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyFrom | InxCallFrame TnxBaseCallFrame
GetIntfMetaData | InxInvokeHasIntfMetaData
GetIntfMethEntry | InxInvokeHasIntfMethEntry
ioDeactivate |
MakeCall | InxCallFrame
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
CopyFrom | This is CopyFrom, a member of class InxCallFrame.
Create | TnxDispatchedCallFrame
Free |
FreeInstance |
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxDispatchedCallFrame Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDispatchedCallFrame.Create Constructor

TnxDispatchedCallFrame.Create Constructor
TnxDispatchedCallFrame Class TnxDispatchedCallFrame Members nxivRegistry Namespace TnxDispatchedCallFrame Class Send Feedback
Syntax
Delphi
constructor Create(const aMetaData: PnxIntfMetaData; const aMethod: PnxIntfMethEntry; const aParams: PnxPointerArray; const aInterface: InxInterface; const aDispatcher: InxInvokeDispatcher);
Description

TnxDispatchedCallFrame

Class

TnxDispatchedCallFrame Class

Links
TnxDispatchedCallFrame Class, TnxDispatchedCallFrame Members, nxivRegistry Namespace, TnxDispatchedCallFrame Class


TnxDispatchedCallFrame Fields

TnxDispatchedCallFrame Fields
TnxDispatchedCallFrame Class Legend Protected Fields Send Feedback

The fields of the TnxDispatchedCallFrame class are listed here.

Class

TnxDispatchedCallFrame Class

Protected Fields
Name | Description
dcfDispatcher | private
Links
TnxDispatchedCallFrame Class, Legend, Protected Fields


TnxDispatchedCallFrame.dcfDispatcher Field

TnxDispatchedCallFrame.dcfDispatcher Field
TnxDispatchedCallFrame Class TnxDispatchedCallFrame Members nxivRegistry Namespace TnxDispatchedCallFrame Fields Send Feedback
Syntax
Delphi
dcfDispatcher: InxInvokeDispatcher;
Description

private

Group

TnxDispatchedCallFrame Fields

Links
TnxDispatchedCallFrame Class, TnxDispatchedCallFrame Members, nxivRegistry Namespace, TnxDispatchedCallFrame Fields


TnxDispatchedCallFrame Methods

TnxDispatchedCallFrame Methods
TnxDispatchedCallFrame Class Legend Protected Methods Send Feedback

The methods of the TnxDispatchedCallFrame class are listed here.

Class

TnxDispatchedCallFrame Class

Protected Methods
Name | Description
MakeCall | InxCallFrame
Links
TnxDispatchedCallFrame Class, Legend, Protected Methods


TnxDispatchedCallFrame.MakeCall Method

TnxDispatchedCallFrame.MakeCall Method
TnxDispatchedCallFrame Class TnxDispatchedCallFrame Members nxivRegistry Namespace TnxDispatchedCallFrame Methods Send Feedback
Syntax
Delphi
function MakeCall: HRESULT;
Description

InxCallFrame

Group

TnxDispatchedCallFrame Methods

Links
TnxDispatchedCallFrame Class, TnxDispatchedCallFrame Members, nxivRegistry Namespace, TnxDispatchedCallFrame Methods


TnxDynamicInvokeProxy Class

TnxDynamicInvokeProxy Class
TnxDynamicInvokeProxy Fields TnxDynamicInvokeProxy Methods TnxDynamicInvokeProxy Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxDynamicInvokeProxynxivRegistry_TnxDynamicInvokeProxynxivRegistry_TnxDynamicInvokeProxynxivRegistry_TnxDynamicInvokeProxynxivRegistry_TnxDynamicInvokeProxy
Syntax
Delphi
TnxDynamicInvokeProxy = class(TnxInterfacedObject, InxInterface, InxInvokeHasIntfMetaData, InxInvokeProxy);
File

nxivRegistry

Description

This is class nxivRegistry.TnxDynamicInvokeProxy.

Group

Classes

Links
TnxDynamicInvokeProxy Fields, TnxDynamicInvokeProxy Methods, TnxDynamicInvokeProxy Members, nxivRegistry, Classes


TnxDynamicInvokeProxy Members

TnxDynamicInvokeProxy Members
TnxDynamicInvokeProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDynamicInvokeProxy.

Class

TnxDynamicInvokeProxy Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
ipDispatcher | This is ipDispatcher, a member of class TnxDynamicInvokeProxy.
ipInterface | This is ipInterface, a member of class TnxDynamicInvokeProxy.
ipMetaData | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyCallFrame | TnxDynamicInvokeProxy
CreateCallFrame | InxInvokeProxy
GetIntfMetaData | InxInvokeHasIntfMetaData
ioDeactivate |
OpenCallFrame | This is OpenCallFrame, a member of class TnxDynamicInvokeProxy.
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | This is Create, a member of class TnxDynamicInvokeProxy.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxDynamicInvokeProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDynamicInvokeProxy.Create Constructor

TnxDynamicInvokeProxy.Create Constructor
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData; const aInterface: InxInterface); virtual;
Description

This is Create, a member of class TnxDynamicInvokeProxy.

Class

TnxDynamicInvokeProxy Class

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Class


TnxDynamicInvokeProxy Fields

TnxDynamicInvokeProxy Fields
TnxDynamicInvokeProxy Class Legend Protected Fields Send Feedback

The fields of the TnxDynamicInvokeProxy class are listed here.

Class

TnxDynamicInvokeProxy Class

Protected Fields
Name | Description
ipDispatcher | This is ipDispatcher, a member of class TnxDynamicInvokeProxy.
ipInterface | This is ipInterface, a member of class TnxDynamicInvokeProxy.
ipMetaData | private
Links
TnxDynamicInvokeProxy Class, Legend, Protected Fields


TnxDynamicInvokeProxy.ipDispatcher Field

TnxDynamicInvokeProxy.ipDispatcher Field
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Fields Send Feedback
Syntax
Delphi
ipDispatcher: InxInvokeDispatcher;
Description

This is ipDispatcher, a member of class TnxDynamicInvokeProxy.

Group

TnxDynamicInvokeProxy Fields

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Fields


TnxDynamicInvokeProxy.ipInterface Field

TnxDynamicInvokeProxy.ipInterface Field
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Fields Send Feedback
Syntax
Delphi
ipInterface: InxInterface;
Description

This is ipInterface, a member of class TnxDynamicInvokeProxy.

Group

TnxDynamicInvokeProxy Fields

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Fields


TnxDynamicInvokeProxy.ipMetaData Field

TnxDynamicInvokeProxy.ipMetaData Field
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Fields Send Feedback
Syntax
Delphi
ipMetaData: PnxIntfMetaData;
Description

private

Group

TnxDynamicInvokeProxy Fields

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Fields


TnxDynamicInvokeProxy Methods

TnxDynamicInvokeProxy Methods
TnxDynamicInvokeProxy Class Legend Protected Methods Send Feedback

The methods of the TnxDynamicInvokeProxy class are listed here.

Class

TnxDynamicInvokeProxy Class

Protected Methods
Name | Description
CopyCallFrame | TnxDynamicInvokeProxy
CreateCallFrame | InxInvokeProxy
GetIntfMetaData | InxInvokeHasIntfMetaData
OpenCallFrame | This is OpenCallFrame, a member of class TnxDynamicInvokeProxy.
Links
TnxDynamicInvokeProxy Class, Legend, Protected Methods


TnxDynamicInvokeProxy.CopyCallFrame Method

TnxDynamicInvokeProxy.CopyCallFrame Method
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Methods Send Feedback
Syntax
Delphi
function CopyCallFrame(const aMethod: PnxIntfMethEntry; const aSrcParams: PnxPointerArray; out aDstParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

TnxDynamicInvokeProxy

Group

TnxDynamicInvokeProxy Methods

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Methods


TnxDynamicInvokeProxy.CreateCallFrame Method

TnxDynamicInvokeProxy.CreateCallFrame Method
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Methods Send Feedback
Syntax
Delphi
function CreateCallFrame(aMethodNumber: Integer; out aMethod: PnxIntfMethEntry; out aParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

InxInvokeProxy

Group

TnxDynamicInvokeProxy Methods

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Methods


TnxDynamicInvokeProxy.GetIntfMetaData Method

TnxDynamicInvokeProxy.GetIntfMetaData Method
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

InxInvokeHasIntfMetaData

Group

TnxDynamicInvokeProxy Methods

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Methods


TnxDynamicInvokeProxy.OpenCallFrame Method

TnxDynamicInvokeProxy.OpenCallFrame Method
TnxDynamicInvokeProxy Class TnxDynamicInvokeProxy Members nxivRegistry Namespace TnxDynamicInvokeProxy Methods Send Feedback
Syntax
Delphi
function OpenCallFrame(const aMethod: PnxIntfMethEntry; const aParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

This is OpenCallFrame, a member of class TnxDynamicInvokeProxy.

Group

TnxDynamicInvokeProxy Methods

Links
TnxDynamicInvokeProxy Class, TnxDynamicInvokeProxy Members, nxivRegistry Namespace, TnxDynamicInvokeProxy Methods


TnxDynamicInvokeProxyFactory Class

TnxDynamicInvokeProxyFactory Class
TnxDynamicInvokeProxyFactory Fields TnxDynamicInvokeProxyFactory Methods TnxDynamicInvokeProxyFactory Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxDynamicInvokeProxyFactorynxivRegistry_TnxDynamicInvokeProxyFactorynxivRegistry_TnxDynamicInvokeProxyFactory
Syntax
Delphi
TnxDynamicInvokeProxyFactory = class(TInterfacedObject, InxInvokeProxyFactory);
File

nxivRegistry

Description

This is class nxivRegistry.TnxDynamicInvokeProxyFactory.

Group

Classes

Links
TnxDynamicInvokeProxyFactory Fields, TnxDynamicInvokeProxyFactory Methods, TnxDynamicInvokeProxyFactory Members, nxivRegistry, Classes


TnxDynamicInvokeProxyFactory Members

TnxDynamicInvokeProxyFactory Members
TnxDynamicInvokeProxyFactory Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDynamicInvokeProxyFactory.

Class

TnxDynamicInvokeProxyFactory Class

Protected Fields
Name | Description
dipfMetaData | private
Protected Methods
Name | Description
CreateInvokeProxy | InxInvokeProxyFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxDynamicInvokeProxyFactory.
Public Methods
Name | Description
Create | TnxDynamicInvokeProxyFactory
Links
TnxDynamicInvokeProxyFactory Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDynamicInvokeProxyFactory.Create Constructor

TnxDynamicInvokeProxyFactory.Create Constructor
TnxDynamicInvokeProxyFactory Class TnxDynamicInvokeProxyFactory Members nxivRegistry Namespace TnxDynamicInvokeProxyFactory Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData);
Description

TnxDynamicInvokeProxyFactory

Class

TnxDynamicInvokeProxyFactory Class

Links
TnxDynamicInvokeProxyFactory Class, TnxDynamicInvokeProxyFactory Members, nxivRegistry Namespace, TnxDynamicInvokeProxyFactory Class


TnxDynamicInvokeProxyFactory Fields

TnxDynamicInvokeProxyFactory Fields
TnxDynamicInvokeProxyFactory Class Legend Protected Fields Send Feedback

The fields of the TnxDynamicInvokeProxyFactory class are listed here.

Class

TnxDynamicInvokeProxyFactory Class

Protected Fields
Name | Description
dipfMetaData | private
Links
TnxDynamicInvokeProxyFactory Class, Legend, Protected Fields


TnxDynamicInvokeProxyFactory.dipfMetaData Field

TnxDynamicInvokeProxyFactory.dipfMetaData Field
TnxDynamicInvokeProxyFactory Class TnxDynamicInvokeProxyFactory Members nxivRegistry Namespace TnxDynamicInvokeProxyFactory Fields Send Feedback
Syntax
Delphi
dipfMetaData: PnxIntfMetaData;
Description

private

Group

TnxDynamicInvokeProxyFactory Fields

Links
TnxDynamicInvokeProxyFactory Class, TnxDynamicInvokeProxyFactory Members, nxivRegistry Namespace, TnxDynamicInvokeProxyFactory Fields


TnxDynamicInvokeProxyFactory Methods

TnxDynamicInvokeProxyFactory Methods
TnxDynamicInvokeProxyFactory Class Legend Protected Methods Send Feedback

The methods of the TnxDynamicInvokeProxyFactory class are listed here.

Class

TnxDynamicInvokeProxyFactory Class

Protected Methods
Name | Description
CreateInvokeProxy | InxInvokeProxyFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxDynamicInvokeProxyFactory.
Links
TnxDynamicInvokeProxyFactory Class, Legend, Protected Methods


TnxDynamicInvokeProxyFactory.CreateInvokeProxy Method

TnxDynamicInvokeProxyFactory.CreateInvokeProxy Method
TnxDynamicInvokeProxyFactory Class TnxDynamicInvokeProxyFactory Members nxivRegistry Namespace TnxDynamicInvokeProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeProxy(const aInterface: InxInterface; out aInvokeProxy: InxInvokeProxy): HRESULT;
Description

InxInvokeProxyFactory

Group

TnxDynamicInvokeProxyFactory Methods

Links
TnxDynamicInvokeProxyFactory Class, TnxDynamicInvokeProxyFactory Members, nxivRegistry Namespace, TnxDynamicInvokeProxyFactory Methods


TnxDynamicInvokeProxyFactory.GetIntfMetaData Method

TnxDynamicInvokeProxyFactory.GetIntfMetaData Method
TnxDynamicInvokeProxyFactory Class TnxDynamicInvokeProxyFactory Members nxivRegistry Namespace TnxDynamicInvokeProxyFactory Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class TnxDynamicInvokeProxyFactory.

Group

TnxDynamicInvokeProxyFactory Methods

Links
TnxDynamicInvokeProxyFactory Class, TnxDynamicInvokeProxyFactory Members, nxivRegistry Namespace, TnxDynamicInvokeProxyFactory Methods


TnxDynamicInvokeStub Class

TnxDynamicInvokeStub Class
TnxDynamicInvokeStub Fields TnxDynamicInvokeStub Methods TnxDynamicInvokeStub Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxDynamicInvokeStubnxivRegistry_TnxDynamicInvokeStubnxivRegistry_TnxDynamicInvokeStubnxivRegistry_TnxDynamicInvokeStubnxivRegistry_TnxDynamicInvokeStub
Syntax
Delphi
TnxDynamicInvokeStub = class(TnxInterfacedObject, InxInterface, InxInvokeHasIntfMetaData, InxInvokeStub);
File

nxivRegistry

Description

This is class nxivRegistry.TnxDynamicInvokeStub.

Group

Classes

Links
TnxDynamicInvokeStub Fields, TnxDynamicInvokeStub Methods, TnxDynamicInvokeStub Members, nxivRegistry, Classes


TnxDynamicInvokeStub Members

TnxDynamicInvokeStub Members
TnxDynamicInvokeStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDynamicInvokeStub.

Class

TnxDynamicInvokeStub Class

Protected Fields
Name | Description
disDispatcher | This is disDispatcher, a member of class TnxDynamicInvokeStub.
disMetaData | This is disMetaData, a member of class TnxDynamicInvokeStub.
disMethods | This is disMethods, a member of class TnxDynamicInvokeStub.
disVTable | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxDynamicInvokeStub
_Release |
disStubAddRef | This is disStubAddRef, a member of class TnxDynamicInvokeStub.
disStubQueryInterface | This is disStubQueryInterface, a member of class TnxDynamicInvokeStub.
disStubRelease | This is disStubRelease, a member of class TnxDynamicInvokeStub.
GetIntfMetaData | InxInvokeHasIntfMetaData
ioDeactivate |
QueryInterface | InxInterface, InxInvokeStub
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | This is Create, a member of class TnxDynamicInvokeStub.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxDynamicInvokeStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDynamicInvokeStub.Create Constructor

TnxDynamicInvokeStub.Create Constructor
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Class Send Feedback
Syntax
Delphi
constructor Create(aVTable: Pointer; aMetaData: PnxIntfMetaData; const aDispatcher: InxInvokeDispatcher); virtual;
Description

This is Create, a member of class TnxDynamicInvokeStub.

Class

TnxDynamicInvokeStub Class

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Class


TnxDynamicInvokeStub Fields

TnxDynamicInvokeStub Fields
TnxDynamicInvokeStub Class Legend Protected Fields Send Feedback

The fields of the TnxDynamicInvokeStub class are listed here.

Class

TnxDynamicInvokeStub Class

Protected Fields
Name | Description
disDispatcher | This is disDispatcher, a member of class TnxDynamicInvokeStub.
disMetaData | This is disMetaData, a member of class TnxDynamicInvokeStub.
disMethods | This is disMethods, a member of class TnxDynamicInvokeStub.
disVTable | private
Links
TnxDynamicInvokeStub Class, Legend, Protected Fields


TnxDynamicInvokeStub.disDispatcher Field

TnxDynamicInvokeStub.disDispatcher Field
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Fields Send Feedback
Syntax
Delphi
disDispatcher: Pointer;
Description

This is disDispatcher, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Fields

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Fields


TnxDynamicInvokeStub.disMetaData Field

TnxDynamicInvokeStub.disMetaData Field
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Fields Send Feedback
Syntax
Delphi
disMetaData: PnxIntfMetaData;
Description

This is disMetaData, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Fields

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Fields


TnxDynamicInvokeStub.disMethods Field

TnxDynamicInvokeStub.disMethods Field
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Fields Send Feedback
Syntax
Delphi
disMethods: PnxIntfMethEntry;
Description

This is disMethods, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Fields

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Fields


TnxDynamicInvokeStub.disVTable Field

TnxDynamicInvokeStub.disVTable Field
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Fields Send Feedback
Syntax
Delphi
disVTable: Pointer;
Description

private

Group

TnxDynamicInvokeStub Fields

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Fields


TnxDynamicInvokeStub Methods

TnxDynamicInvokeStub Methods
TnxDynamicInvokeStub Class Legend Protected Methods Send Feedback

The methods of the TnxDynamicInvokeStub class are listed here.

Class

TnxDynamicInvokeStub Class

Protected Methods
Name | Description
_AddRef | TnxDynamicInvokeStub
_Release |
disStubAddRef | This is disStubAddRef, a member of class TnxDynamicInvokeStub.
disStubQueryInterface | This is disStubQueryInterface, a member of class TnxDynamicInvokeStub.
disStubRelease | This is disStubRelease, a member of class TnxDynamicInvokeStub.
GetIntfMetaData | InxInvokeHasIntfMetaData
QueryInterface | InxInterface, InxInvokeStub
Links
TnxDynamicInvokeStub Class, Legend, Protected Methods


TnxDynamicInvokeStub._AddRef Method

TnxDynamicInvokeStub._AddRef Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; virtual; stdcall;
Description

TnxDynamicInvokeStub

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub._Release Method

TnxDynamicInvokeStub._Release Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function _Release: Integer; virtual; stdcall;
Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub.disStubAddRef Method

TnxDynamicInvokeStub.disStubAddRef Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function disStubAddRef: Integer; virtual; stdcall;
Description

This is disStubAddRef, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub.disStubQueryInterface Method

TnxDynamicInvokeStub.disStubQueryInterface Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function disStubQueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall;
Description

This is disStubQueryInterface, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub.disStubRelease Method

TnxDynamicInvokeStub.disStubRelease Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function disStubRelease: Integer; virtual; stdcall;
Description

This is disStubRelease, a member of class TnxDynamicInvokeStub.

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub.GetIntfMetaData Method

TnxDynamicInvokeStub.GetIntfMetaData Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

InxInvokeHasIntfMetaData

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStub.QueryInterface Method

TnxDynamicInvokeStub.QueryInterface Method
TnxDynamicInvokeStub Class TnxDynamicInvokeStub Members nxivRegistry Namespace TnxDynamicInvokeStub Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall;
Description

InxInterface, InxInvokeStub

Group

TnxDynamicInvokeStub Methods

Links
TnxDynamicInvokeStub Class, TnxDynamicInvokeStub Members, nxivRegistry Namespace, TnxDynamicInvokeStub Methods


TnxDynamicInvokeStubFactory Class

TnxDynamicInvokeStubFactory Class
TnxDynamicInvokeStubFactory Fields TnxDynamicInvokeStubFactory Methods TnxDynamicInvokeStubFactory Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxDynamicInvokeStubFactorynxivRegistry_TnxDynamicInvokeStubFactorynxivRegistry_TnxDynamicInvokeStubFactory
Syntax
Delphi
TnxDynamicInvokeStubFactory = class(TInterfacedObject, InxInvokeStubFactory);
File

nxivRegistry

Description

This is class nxivRegistry.TnxDynamicInvokeStubFactory.

Group

Classes

Links
TnxDynamicInvokeStubFactory Fields, TnxDynamicInvokeStubFactory Methods, TnxDynamicInvokeStubFactory Members, nxivRegistry, Classes


TnxDynamicInvokeStubFactory Members

TnxDynamicInvokeStubFactory Members
TnxDynamicInvokeStubFactory Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDynamicInvokeStubFactory.

Class

TnxDynamicInvokeStubFactory Class

Protected Fields
Name | Description
disfMetaData | This is disfMetaData, a member of class TnxDynamicInvokeStubFactory.
disfVTable | private
Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxDynamicInvokeStubFactory.
Public Methods
Name | Description
Create | TnxDynamicInvokeStubFactory
Links
TnxDynamicInvokeStubFactory Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDynamicInvokeStubFactory.Create Constructor

TnxDynamicInvokeStubFactory.Create Constructor
TnxDynamicInvokeStubFactory Class TnxDynamicInvokeStubFactory Members nxivRegistry Namespace TnxDynamicInvokeStubFactory Class Send Feedback
Syntax
Delphi
constructor Create(aVTable: Pointer; aMetaData: PnxIntfMetaData);
Description

TnxDynamicInvokeStubFactory

Class

TnxDynamicInvokeStubFactory Class

Links
TnxDynamicInvokeStubFactory Class, TnxDynamicInvokeStubFactory Members, nxivRegistry Namespace, TnxDynamicInvokeStubFactory Class


TnxDynamicInvokeStubFactory Fields

TnxDynamicInvokeStubFactory Fields
TnxDynamicInvokeStubFactory Class Legend Protected Fields Send Feedback

The fields of the TnxDynamicInvokeStubFactory class are listed here.

Class

TnxDynamicInvokeStubFactory Class

Protected Fields
Name | Description
disfMetaData | This is disfMetaData, a member of class TnxDynamicInvokeStubFactory.
disfVTable | private
Links
TnxDynamicInvokeStubFactory Class, Legend, Protected Fields


TnxDynamicInvokeStubFactory.disfMetaData Field

TnxDynamicInvokeStubFactory.disfMetaData Field
TnxDynamicInvokeStubFactory Class TnxDynamicInvokeStubFactory Members nxivRegistry Namespace TnxDynamicInvokeStubFactory Fields Send Feedback
Syntax
Delphi
disfMetaData: PnxIntfMetaData;
Description

This is disfMetaData, a member of class TnxDynamicInvokeStubFactory.

Group

TnxDynamicInvokeStubFactory Fields

Links
TnxDynamicInvokeStubFactory Class, TnxDynamicInvokeStubFactory Members, nxivRegistry Namespace, TnxDynamicInvokeStubFactory Fields


TnxDynamicInvokeStubFactory.disfVTable Field

TnxDynamicInvokeStubFactory.disfVTable Field
TnxDynamicInvokeStubFactory Class TnxDynamicInvokeStubFactory Members nxivRegistry Namespace TnxDynamicInvokeStubFactory Fields Send Feedback
Syntax
Delphi
disfVTable: Pointer;
Description

private

Group

TnxDynamicInvokeStubFactory Fields

Links
TnxDynamicInvokeStubFactory Class, TnxDynamicInvokeStubFactory Members, nxivRegistry Namespace, TnxDynamicInvokeStubFactory Fields


TnxDynamicInvokeStubFactory Methods

TnxDynamicInvokeStubFactory Methods
TnxDynamicInvokeStubFactory Class Legend Protected Methods Send Feedback

The methods of the TnxDynamicInvokeStubFactory class are listed here.

Class

TnxDynamicInvokeStubFactory Class

Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxDynamicInvokeStubFactory.
Links
TnxDynamicInvokeStubFactory Class, Legend, Protected Methods


TnxDynamicInvokeStubFactory.CreateInvokeStub Method

TnxDynamicInvokeStubFactory.CreateInvokeStub Method
TnxDynamicInvokeStubFactory Class TnxDynamicInvokeStubFactory Members nxivRegistry Namespace TnxDynamicInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

InxInvokeStubFactory

Group

TnxDynamicInvokeStubFactory Methods

Links
TnxDynamicInvokeStubFactory Class, TnxDynamicInvokeStubFactory Members, nxivRegistry Namespace, TnxDynamicInvokeStubFactory Methods


TnxDynamicInvokeStubFactory.GetIntfMetaData Method

TnxDynamicInvokeStubFactory.GetIntfMetaData Method
TnxDynamicInvokeStubFactory Class TnxDynamicInvokeStubFactory Members nxivRegistry Namespace TnxDynamicInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class TnxDynamicInvokeStubFactory.

Group

TnxDynamicInvokeStubFactory Methods

Links
TnxDynamicInvokeStubFactory Class, TnxDynamicInvokeStubFactory Members, nxivRegistry Namespace, TnxDynamicInvokeStubFactory Methods


TnxGeneratedInvokeProxy Class

TnxGeneratedInvokeProxy Class
TnxGeneratedInvokeProxy Fields TnxGeneratedInvokeProxy Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxGeneratedInvokeProxynxivRegistry_TnxGeneratedInvokeProxynxivRegistry_TnxGeneratedInvokeProxynxivRegistry_TnxGeneratedInvokeProxynxivRegistry_TnxGeneratedInvokeProxynxivRegistry_TnxGeneratedInvokeProxy
Syntax
Delphi
TnxGeneratedInvokeProxy = class(TnxDynamicInvokeProxy);
File

nxivRegistry

Description

This is class nxivRegistry.TnxGeneratedInvokeProxy.

Group

Classes

Links
TnxGeneratedInvokeProxy Fields, TnxGeneratedInvokeProxy Members, nxivRegistry, Classes


TnxGeneratedInvokeProxy Members

TnxGeneratedInvokeProxy Members
TnxGeneratedInvokeProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxGeneratedInvokeProxy.

Class

TnxGeneratedInvokeProxy Class

Protected Fields
Name | Description
gipHandlers | This is gipHandlers, a member of class TnxGeneratedInvokeProxy.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
ipDispatcher | This is ipDispatcher, a member of class TnxDynamicInvokeProxy.
ipInterface | This is ipInterface, a member of class TnxDynamicInvokeProxy.
ipMetaData | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CopyCallFrame | TnxDynamicInvokeProxy
CreateCallFrame | InxInvokeProxy
GetIntfMetaData | InxInvokeHasIntfMetaData
ioDeactivate |
OpenCallFrame | This is OpenCallFrame, a member of class TnxDynamicInvokeProxy.
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
CopyCallFrame | This is CopyCallFrame, a member of class InxInvokeProxy.
Create | TnxGeneratedInvokeProxy
CreateCallFrame | This is CreateCallFrame, a member of class InxInvokeProxy.
Free |
FreeInstance |
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
NewInstance |
NewInstance | TnxObject
OpenCallFrame | This is OpenCallFrame, a member of class InxInvokeProxy.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxGeneratedInvokeProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxGeneratedInvokeProxy.Create Constructor

TnxGeneratedInvokeProxy.Create Constructor
TnxGeneratedInvokeProxy Class TnxGeneratedInvokeProxy Members nxivRegistry Namespace TnxGeneratedInvokeProxy Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData; const aInterface: InxInterface; aHandlers: PnxGeneratedInvokeProxyHandlers); reintroduce;
Description

TnxGeneratedInvokeProxy

Class

TnxGeneratedInvokeProxy Class

Links
TnxGeneratedInvokeProxy Class, TnxGeneratedInvokeProxy Members, nxivRegistry Namespace, TnxGeneratedInvokeProxy Class


TnxGeneratedInvokeProxy Fields

TnxGeneratedInvokeProxy Fields
TnxGeneratedInvokeProxy Class Legend Protected Fields Send Feedback

The fields of the TnxGeneratedInvokeProxy class are listed here.

Class

TnxGeneratedInvokeProxy Class

Protected Fields
Name | Description
gipHandlers | This is gipHandlers, a member of class TnxGeneratedInvokeProxy.
Links
TnxGeneratedInvokeProxy Class, Legend, Protected Fields


TnxGeneratedInvokeProxy.gipHandlers Field

TnxGeneratedInvokeProxy.gipHandlers Field
TnxGeneratedInvokeProxy Class TnxGeneratedInvokeProxy Members nxivRegistry Namespace TnxGeneratedInvokeProxy Fields Send Feedback
Syntax
Delphi
gipHandlers: PnxGeneratedInvokeProxyHandlers;
Description

This is gipHandlers, a member of class TnxGeneratedInvokeProxy.

Group

TnxGeneratedInvokeProxy Fields

Links
TnxGeneratedInvokeProxy Class, TnxGeneratedInvokeProxy Members, nxivRegistry Namespace, TnxGeneratedInvokeProxy Fields


TnxGeneratedInvokeProxyDispatcher Class

TnxGeneratedInvokeProxyDispatcher Class
TnxGeneratedInvokeProxyDispatcher Fields TnxGeneratedInvokeProxyDispatcher Methods TnxGeneratedInvokeProxyDispatcher Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxGeneratedInvokeProxyDispatchernxivRegistry_TnxGeneratedInvokeProxyDispatchernxivRegistry_TnxGeneratedInvokeProxyDispatchernxivRegistry_TnxGeneratedInvokeProxyDispatcher
Syntax
Delphi
TnxGeneratedInvokeProxyDispatcher = class(TnxInterfacedObject, InxInvokeDispatcher);
File

nxivRegistry

Description

This is class nxivRegistry.TnxGeneratedInvokeProxyDispatcher.

Group

Classes

Links
TnxGeneratedInvokeProxyDispatcher Fields, TnxGeneratedInvokeProxyDispatcher Methods, TnxGeneratedInvokeProxyDispatcher Members, nxivRegistry, Classes


TnxGeneratedInvokeProxyDispatcher Members

TnxGeneratedInvokeProxyDispatcher Members
TnxGeneratedInvokeProxyDispatcher Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxGeneratedInvokeProxyDispatcher.

Class

TnxGeneratedInvokeProxyDispatcher Class

Protected Fields
Name | Description
gipdProxy | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
DispatchInvoke | InxInvokeDispatcher
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxGeneratedInvokeProxyDispatcher
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxGeneratedInvokeProxyDispatcher Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxGeneratedInvokeProxyDispatcher.Create Constructor

TnxGeneratedInvokeProxyDispatcher.Create Constructor
TnxGeneratedInvokeProxyDispatcher Class TnxGeneratedInvokeProxyDispatcher Members nxivRegistry Namespace TnxGeneratedInvokeProxyDispatcher Class Send Feedback
Syntax
Delphi
constructor Create(aInvokeProxy: TnxGeneratedInvokeProxy);
Description

TnxGeneratedInvokeProxyDispatcher

Class

TnxGeneratedInvokeProxyDispatcher Class

Links
TnxGeneratedInvokeProxyDispatcher Class, TnxGeneratedInvokeProxyDispatcher Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyDispatcher Class


TnxGeneratedInvokeProxyDispatcher Fields

TnxGeneratedInvokeProxyDispatcher Fields
TnxGeneratedInvokeProxyDispatcher Class Legend Protected Fields Send Feedback

The fields of the TnxGeneratedInvokeProxyDispatcher class are listed here.

Class

TnxGeneratedInvokeProxyDispatcher Class

Protected Fields
Name | Description
gipdProxy | private
Links
TnxGeneratedInvokeProxyDispatcher Class, Legend, Protected Fields


TnxGeneratedInvokeProxyDispatcher.gipdProxy Field

TnxGeneratedInvokeProxyDispatcher.gipdProxy Field
TnxGeneratedInvokeProxyDispatcher Class TnxGeneratedInvokeProxyDispatcher Members nxivRegistry Namespace TnxGeneratedInvokeProxyDispatcher Fields Send Feedback
Syntax
Delphi
gipdProxy: TnxGeneratedInvokeProxy;
Description

private

Group

TnxGeneratedInvokeProxyDispatcher Fields

Links
TnxGeneratedInvokeProxyDispatcher Class, TnxGeneratedInvokeProxyDispatcher Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyDispatcher Fields


TnxGeneratedInvokeProxyDispatcher Methods

TnxGeneratedInvokeProxyDispatcher Methods
TnxGeneratedInvokeProxyDispatcher Class Legend Protected Methods Send Feedback

The methods of the TnxGeneratedInvokeProxyDispatcher class are listed here.

Class

TnxGeneratedInvokeProxyDispatcher Class

Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
Links
TnxGeneratedInvokeProxyDispatcher Class, Legend, Protected Methods


TnxGeneratedInvokeProxyDispatcher.DispatchInvoke Method

TnxGeneratedInvokeProxyDispatcher.DispatchInvoke Method
TnxGeneratedInvokeProxyDispatcher Class TnxGeneratedInvokeProxyDispatcher Members nxivRegistry Namespace TnxGeneratedInvokeProxyDispatcher Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

InxInvokeDispatcher

Group

TnxGeneratedInvokeProxyDispatcher Methods

Links
TnxGeneratedInvokeProxyDispatcher Class, TnxGeneratedInvokeProxyDispatcher Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyDispatcher Methods


TnxGeneratedInvokeProxyFactory Class

TnxGeneratedInvokeProxyFactory Class
TnxGeneratedInvokeProxyFactory Fields TnxGeneratedInvokeProxyFactory Methods TnxGeneratedInvokeProxyFactory Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxGeneratedInvokeProxyFactorynxivRegistry_TnxGeneratedInvokeProxyFactorynxivRegistry_TnxGeneratedInvokeProxyFactory
Syntax
Delphi
TnxGeneratedInvokeProxyFactory = class(TInterfacedObject, InxInvokeProxyFactory);
File

nxivRegistry

Description

This is class nxivRegistry.TnxGeneratedInvokeProxyFactory.

Group

Classes

Links
TnxGeneratedInvokeProxyFactory Fields, TnxGeneratedInvokeProxyFactory Methods, TnxGeneratedInvokeProxyFactory Members, nxivRegistry, Classes


TnxGeneratedInvokeProxyFactory Members

TnxGeneratedInvokeProxyFactory Members
TnxGeneratedInvokeProxyFactory Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxGeneratedInvokeProxyFactory.

Class

TnxGeneratedInvokeProxyFactory Class

Protected Fields
Name | Description
gipfHandlers | This is gipfHandlers, a member of class TnxGeneratedInvokeProxyFactory.
gipfMetaData | private
Protected Methods
Name | Description
CreateInvokeProxy | InxInvokeProxyFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeProxyFactory.
Public Methods
Name | Description
Create | TnxGeneratedInvokeProxyFactory
Links
TnxGeneratedInvokeProxyFactory Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxGeneratedInvokeProxyFactory.Create Constructor

TnxGeneratedInvokeProxyFactory.Create Constructor
TnxGeneratedInvokeProxyFactory Class TnxGeneratedInvokeProxyFactory Members nxivRegistry Namespace TnxGeneratedInvokeProxyFactory Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData; aHandlers: PnxGeneratedInvokeProxyHandlers);
Description

TnxGeneratedInvokeProxyFactory

Class

TnxGeneratedInvokeProxyFactory Class

Links
TnxGeneratedInvokeProxyFactory Class, TnxGeneratedInvokeProxyFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyFactory Class


TnxGeneratedInvokeProxyFactory Fields

TnxGeneratedInvokeProxyFactory Fields
TnxGeneratedInvokeProxyFactory Class Legend Protected Fields Send Feedback

The fields of the TnxGeneratedInvokeProxyFactory class are listed here.

Class

TnxGeneratedInvokeProxyFactory Class

Protected Fields
Name | Description
gipfHandlers | This is gipfHandlers, a member of class TnxGeneratedInvokeProxyFactory.
gipfMetaData | private
Links
TnxGeneratedInvokeProxyFactory Class, Legend, Protected Fields


TnxGeneratedInvokeProxyFactory.gipfHandlers Field

TnxGeneratedInvokeProxyFactory.gipfHandlers Field
TnxGeneratedInvokeProxyFactory Class TnxGeneratedInvokeProxyFactory Members nxivRegistry Namespace TnxGeneratedInvokeProxyFactory Fields Send Feedback
Syntax
Delphi
gipfHandlers: PnxGeneratedInvokeProxyHandlers;
Description

This is gipfHandlers, a member of class TnxGeneratedInvokeProxyFactory.

Group

TnxGeneratedInvokeProxyFactory Fields

Links
TnxGeneratedInvokeProxyFactory Class, TnxGeneratedInvokeProxyFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyFactory Fields


TnxGeneratedInvokeProxyFactory.gipfMetaData Field

TnxGeneratedInvokeProxyFactory.gipfMetaData Field
TnxGeneratedInvokeProxyFactory Class TnxGeneratedInvokeProxyFactory Members nxivRegistry Namespace TnxGeneratedInvokeProxyFactory Fields Send Feedback
Syntax
Delphi
gipfMetaData: PnxIntfMetaData;
Description

private

Group

TnxGeneratedInvokeProxyFactory Fields

Links
TnxGeneratedInvokeProxyFactory Class, TnxGeneratedInvokeProxyFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyFactory Fields


TnxGeneratedInvokeProxyFactory Methods

TnxGeneratedInvokeProxyFactory Methods
TnxGeneratedInvokeProxyFactory Class Legend Protected Methods Send Feedback

The methods of the TnxGeneratedInvokeProxyFactory class are listed here.

Class

TnxGeneratedInvokeProxyFactory Class

Protected Methods
Name | Description
CreateInvokeProxy | InxInvokeProxyFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeProxyFactory.
Links
TnxGeneratedInvokeProxyFactory Class, Legend, Protected Methods


TnxGeneratedInvokeProxyFactory.CreateInvokeProxy Method

TnxGeneratedInvokeProxyFactory.CreateInvokeProxy Method
TnxGeneratedInvokeProxyFactory Class TnxGeneratedInvokeProxyFactory Members nxivRegistry Namespace TnxGeneratedInvokeProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeProxy(const aInterface: InxInterface; out aInvokeProxy: InxInvokeProxy): HRESULT;
Description

InxInvokeProxyFactory

Group

TnxGeneratedInvokeProxyFactory Methods

Links
TnxGeneratedInvokeProxyFactory Class, TnxGeneratedInvokeProxyFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyFactory Methods


TnxGeneratedInvokeProxyFactory.GetIntfMetaData Method

TnxGeneratedInvokeProxyFactory.GetIntfMetaData Method
TnxGeneratedInvokeProxyFactory Class TnxGeneratedInvokeProxyFactory Members nxivRegistry Namespace TnxGeneratedInvokeProxyFactory Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class TnxGeneratedInvokeProxyFactory.

Group

TnxGeneratedInvokeProxyFactory Methods

Links
TnxGeneratedInvokeProxyFactory Class, TnxGeneratedInvokeProxyFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeProxyFactory Methods


TnxGeneratedInvokeStub Class

TnxGeneratedInvokeStub Class
TnxGeneratedInvokeStub Methods TnxGeneratedInvokeStub Properties TnxGeneratedInvokeStub Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxGeneratedInvokeStubnxivRegistry_TnxGeneratedInvokeStubnxivRegistry_TnxGeneratedInvokeStubnxivRegistry_TnxGeneratedInvokeStubnxivRegistry_TnxGeneratedInvokeStubnxivRegistry_TnxGeneratedInvokeStub
Syntax
Delphi
TnxGeneratedInvokeStub = class(TnxAggregatableObject, InxInvokeHasIntfMetaData, InxInvokeStub);
File

nxivRegistry

Description

This is class nxivRegistry.TnxGeneratedInvokeStub.

Group

Classes

Links
TnxGeneratedInvokeStub Methods, TnxGeneratedInvokeStub Properties, TnxGeneratedInvokeStub Members, nxivRegistry, Classes


TnxGeneratedInvokeStub Members

TnxGeneratedInvokeStub Members
TnxGeneratedInvokeStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxGeneratedInvokeStub.

Class

TnxGeneratedInvokeStub Class

Protected Fields
Name | Description
aoHost | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
GetIntfMetaData_InxInvokeHasIntfMetaData | This is GetIntfMetaData_InxInvokeHasIntfMetaData, a member of class TnxGeneratedInvokeStub.
gsFixupSafeCall | This is gsFixupSafeCall, a member of class TnxGeneratedInvokeStub.
gsGetDispatcher | private
InternalAddRef |
InternalQueryInterface |
InternalRelease |
ioDeactivate |
QueryInterface | will be used by other interfaces defined on this object
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxGeneratedInvokeStub
FixupSafeCalls | This is FixupSafeCalls, a member of class TnxGeneratedInvokeStub.
Free |
FreeInstance |
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeStub.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
Dispatcher | This is Dispatcher, a member of class TnxGeneratedInvokeStub.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxGeneratedInvokeStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxGeneratedInvokeStub.Create Constructor

TnxGeneratedInvokeStub.Create Constructor
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Class Send Feedback
Syntax
Delphi
constructor Create(const aDispatcher: InxInvokeDispatcher); virtual;
Description

TnxGeneratedInvokeStub

Class

TnxGeneratedInvokeStub Class

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Class


TnxGeneratedInvokeStub Methods

TnxGeneratedInvokeStub Methods
TnxGeneratedInvokeStub Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxGeneratedInvokeStub class are listed here.

Class

TnxGeneratedInvokeStub Class

Protected Methods
Name | Description
GetIntfMetaData_InxInvokeHasIntfMetaData | This is GetIntfMetaData_InxInvokeHasIntfMetaData, a member of class TnxGeneratedInvokeStub.
gsFixupSafeCall | This is gsFixupSafeCall, a member of class TnxGeneratedInvokeStub.
gsGetDispatcher | private
QueryInterface | will be used by other interfaces defined on this object
Public Methods
Name | Description
FixupSafeCalls | This is FixupSafeCalls, a member of class TnxGeneratedInvokeStub.
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeStub.
Links
TnxGeneratedInvokeStub Class, Legend, Protected Methods, Public Methods


TnxGeneratedInvokeStub.FixupSafeCalls Method

TnxGeneratedInvokeStub.FixupSafeCalls Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
class procedure FixupSafeCalls; virtual;
Description

This is FixupSafeCalls, a member of class TnxGeneratedInvokeStub.

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub.GetIntfMetaData Method

TnxGeneratedInvokeStub.GetIntfMetaData Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
class function GetIntfMetaData: PnxIntfMetaData; virtual;
Description

This is GetIntfMetaData, a member of class TnxGeneratedInvokeStub.

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub.GetIntfMetaData_InxInvokeHasIntfMetaData Method

TnxGeneratedInvokeStub.GetIntfMetaData_InxInvokeHasIntfMetaData Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData_InxInvokeHasIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData_InxInvokeHasIntfMetaData, a member of class TnxGeneratedInvokeStub.

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub.gsFixupSafeCall Method

TnxGeneratedInvokeStub.gsFixupSafeCall Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
class procedure gsFixupSafeCall(aEntryPoint: Pointer; aImplementation: Pointer);
Description

This is gsFixupSafeCall, a member of class TnxGeneratedInvokeStub.

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub.gsGetDispatcher Method

TnxGeneratedInvokeStub.gsGetDispatcher Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
function gsGetDispatcher: InxInvokeDispatcher;
Description

private

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub.QueryInterface Method

TnxGeneratedInvokeStub.QueryInterface Method
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; override; stdcall;
Description

will be used by other interfaces defined on this object

Group

TnxGeneratedInvokeStub Methods

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Methods


TnxGeneratedInvokeStub Properties

TnxGeneratedInvokeStub Properties
TnxGeneratedInvokeStub Class Legend Public Properties Send Feedback

The properties of the TnxGeneratedInvokeStub class are listed here.

Class

TnxGeneratedInvokeStub Class

Public Properties
Name | Description
Dispatcher | This is Dispatcher, a member of class TnxGeneratedInvokeStub.
Links
TnxGeneratedInvokeStub Class, Legend, Public Properties


TnxGeneratedInvokeStub.Dispatcher Property

TnxGeneratedInvokeStub.Dispatcher Property
TnxGeneratedInvokeStub Class TnxGeneratedInvokeStub Members nxivRegistry Namespace TnxGeneratedInvokeStub Properties Send Feedback
Syntax
Delphi
property Dispatcher: InxInvokeDispatcher;
Description

This is Dispatcher, a member of class TnxGeneratedInvokeStub.

Group

TnxGeneratedInvokeStub Properties

Links
TnxGeneratedInvokeStub Class, TnxGeneratedInvokeStub Members, nxivRegistry Namespace, TnxGeneratedInvokeStub Properties


TnxGeneratedInvokeStubFactory Class

TnxGeneratedInvokeStubFactory Class
TnxGeneratedInvokeStubFactory Fields TnxGeneratedInvokeStubFactory Methods TnxGeneratedInvokeStubFactory Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxGeneratedInvokeStubFactorynxivRegistry_TnxGeneratedInvokeStubFactorynxivRegistry_TnxGeneratedInvokeStubFactory
Syntax
Delphi
TnxGeneratedInvokeStubFactory = class(TInterfacedObject, InxInvokeStubFactory);
File

nxivRegistry

Description

This is class nxivRegistry.TnxGeneratedInvokeStubFactory.

Group

Classes

Links
TnxGeneratedInvokeStubFactory Fields, TnxGeneratedInvokeStubFactory Methods, TnxGeneratedInvokeStubFactory Members, nxivRegistry, Classes


TnxGeneratedInvokeStubFactory Members

TnxGeneratedInvokeStubFactory Members
TnxGeneratedInvokeStubFactory Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxGeneratedInvokeStubFactory.

Class

TnxGeneratedInvokeStubFactory Class

Protected Fields
Name | Description
gisfClass | private
Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeStubFactory.
Public Methods
Name | Description
Create | TnxGeneratedInvokeStubFactory
Links
TnxGeneratedInvokeStubFactory Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxGeneratedInvokeStubFactory.Create Constructor

TnxGeneratedInvokeStubFactory.Create Constructor
TnxGeneratedInvokeStubFactory Class TnxGeneratedInvokeStubFactory Members nxivRegistry Namespace TnxGeneratedInvokeStubFactory Class Send Feedback
Syntax
Delphi
constructor Create(aClass: TnxGeneratedInvokeStubClass);
Description

TnxGeneratedInvokeStubFactory

Class

TnxGeneratedInvokeStubFactory Class

Links
TnxGeneratedInvokeStubFactory Class, TnxGeneratedInvokeStubFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeStubFactory Class


TnxGeneratedInvokeStubFactory Fields

TnxGeneratedInvokeStubFactory Fields
TnxGeneratedInvokeStubFactory Class Legend Protected Fields Send Feedback

The fields of the TnxGeneratedInvokeStubFactory class are listed here.

Class

TnxGeneratedInvokeStubFactory Class

Protected Fields
Name | Description
gisfClass | private
Links
TnxGeneratedInvokeStubFactory Class, Legend, Protected Fields


TnxGeneratedInvokeStubFactory.gisfClass Field

TnxGeneratedInvokeStubFactory.gisfClass Field
TnxGeneratedInvokeStubFactory Class TnxGeneratedInvokeStubFactory Members nxivRegistry Namespace TnxGeneratedInvokeStubFactory Fields Send Feedback
Syntax
Delphi
gisfClass: TnxGeneratedInvokeStubClass;
Description

private

Group

TnxGeneratedInvokeStubFactory Fields

Links
TnxGeneratedInvokeStubFactory Class, TnxGeneratedInvokeStubFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeStubFactory Fields


TnxGeneratedInvokeStubFactory Methods

TnxGeneratedInvokeStubFactory Methods
TnxGeneratedInvokeStubFactory Class Legend Protected Methods Send Feedback

The methods of the TnxGeneratedInvokeStubFactory class are listed here.

Class

TnxGeneratedInvokeStubFactory Class

Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxGeneratedInvokeStubFactory.
Links
TnxGeneratedInvokeStubFactory Class, Legend, Protected Methods


TnxGeneratedInvokeStubFactory.CreateInvokeStub Method

TnxGeneratedInvokeStubFactory.CreateInvokeStub Method
TnxGeneratedInvokeStubFactory Class TnxGeneratedInvokeStubFactory Members nxivRegistry Namespace TnxGeneratedInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

InxInvokeStubFactory

Group

TnxGeneratedInvokeStubFactory Methods

Links
TnxGeneratedInvokeStubFactory Class, TnxGeneratedInvokeStubFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeStubFactory Methods


TnxGeneratedInvokeStubFactory.GetIntfMetaData Method

TnxGeneratedInvokeStubFactory.GetIntfMetaData Method
TnxGeneratedInvokeStubFactory Class TnxGeneratedInvokeStubFactory Members nxivRegistry Namespace TnxGeneratedInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class TnxGeneratedInvokeStubFactory.

Group

TnxGeneratedInvokeStubFactory Methods

Links
TnxGeneratedInvokeStubFactory Class, TnxGeneratedInvokeStubFactory Members, nxivRegistry Namespace, TnxGeneratedInvokeStubFactory Methods


TnxInvokeRegistry Class

TnxInvokeRegistry Class
TnxInvokeRegistry Fields TnxInvokeRegistry Methods TnxInvokeRegistry Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxInvokeRegistrynxivRegistry_TnxInvokeRegistrynxivRegistry_TnxInvokeRegistrynxivRegistry_TnxInvokeRegistry
Syntax
Delphi
TnxInvokeRegistry = class(TnxInterfacedObject, InxInvokeRegistry);
File

nxivRegistry

Description

This is class nxivRegistry.TnxInvokeRegistry.

Group

Classes

Links
TnxInvokeRegistry Fields, TnxInvokeRegistry Methods, TnxInvokeRegistry Members, nxivRegistry, Classes


TnxInvokeRegistry Members

TnxInvokeRegistry Members
TnxInvokeRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInvokeRegistry.

Class

TnxInvokeRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
irInterfaceIDs | private
irIntfMetaData | This is irIntfMetaData, a member of class TnxInvokeRegistry.
irIntfVTable | This is irIntfVTable, a member of class TnxInvokeRegistry.
irPortal | This is irPortal, a member of class TnxInvokeRegistry.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
AddInterface | TnxInvokeRegistry
AddProxyFactory | This is AddProxyFactory, a member of class TnxInvokeRegistry.
AddStubFactory | This is AddStubFactory, a member of class TnxInvokeRegistry.
CreateInvokeProxy | This is CreateInvokeProxy, a member of class TnxInvokeRegistry.
CreateInvokeStub | This is CreateInvokeStub, a member of class TnxInvokeRegistry.
CreateInvokeWrapper | This is CreateInvokeWrapper, a member of class TnxInvokeRegistry.
CreateMethodStub | This is CreateMethodStub, a member of class TnxInvokeRegistry.
CreateVTable | This is CreateVTable, a member of class TnxInvokeRegistry.
ioDeactivate |
Iterate | This is Iterate, a member of class TnxInvokeRegistry.
QueryInterface |
RegisterInterface | InxInvokeRegistry
RegisterProxyFactory | This is RegisterProxyFactory, a member of class TnxInvokeRegistry.
RegisterStubFactory | This is RegisterStubFactory, a member of class TnxInvokeRegistry.
Supports | This is Supports, a member of class TnxInvokeRegistry.
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | This is Create, a member of class TnxInvokeRegistry.
Destroy | This is Destroy, a member of class TnxInvokeRegistry.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInvokeRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInvokeRegistry.Create Constructor

TnxInvokeRegistry.Create Constructor
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

This is Create, a member of class TnxInvokeRegistry.

Class

TnxInvokeRegistry Class

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Class


TnxInvokeRegistry.Destroy Destructor

TnxInvokeRegistry.Destroy Destructor
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxInvokeRegistry.

Class

TnxInvokeRegistry Class

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Class


TnxInvokeRegistry Fields

TnxInvokeRegistry Fields
TnxInvokeRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxInvokeRegistry class are listed here.

Class

TnxInvokeRegistry Class

Protected Fields
Name | Description
irInterfaceIDs | private
irIntfMetaData | This is irIntfMetaData, a member of class TnxInvokeRegistry.
irIntfVTable | This is irIntfVTable, a member of class TnxInvokeRegistry.
irPortal | This is irPortal, a member of class TnxInvokeRegistry.
Links
TnxInvokeRegistry Class, Legend, Protected Fields


TnxInvokeRegistry.irInterfaceIDs Field

TnxInvokeRegistry.irInterfaceIDs Field
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Fields Send Feedback
Syntax
Delphi
irInterfaceIDs: TnxFastStringListCS;
Description

private

Group

TnxInvokeRegistry Fields

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Fields


TnxInvokeRegistry.irIntfMetaData Field

TnxInvokeRegistry.irIntfMetaData Field
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Fields Send Feedback
Syntax
Delphi
irIntfMetaData: array of PnxIntfMetaData;
Description

This is irIntfMetaData, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Fields

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Fields


TnxInvokeRegistry.irIntfVTable Field

TnxInvokeRegistry.irIntfVTable Field
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Fields Send Feedback
Syntax
Delphi
irIntfVTable: array of TnxDynPointerArray;
Description

This is irIntfVTable, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Fields

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Fields


TnxInvokeRegistry.irPortal Field

TnxInvokeRegistry.irPortal Field
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Fields Send Feedback
Syntax
Delphi
irPortal: TnxReadWritePortal;
Description

This is irPortal, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Fields

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Fields


TnxInvokeRegistry Methods

TnxInvokeRegistry Methods
TnxInvokeRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeRegistry class are listed here.

Class

TnxInvokeRegistry Class

Protected Methods
Name | Description
AddInterface | TnxInvokeRegistry
AddProxyFactory | This is AddProxyFactory, a member of class TnxInvokeRegistry.
AddStubFactory | This is AddStubFactory, a member of class TnxInvokeRegistry.
CreateInvokeProxy | This is CreateInvokeProxy, a member of class TnxInvokeRegistry.
CreateInvokeStub | This is CreateInvokeStub, a member of class TnxInvokeRegistry.
CreateInvokeWrapper | This is CreateInvokeWrapper, a member of class TnxInvokeRegistry.
CreateMethodStub | This is CreateMethodStub, a member of class TnxInvokeRegistry.
CreateVTable | This is CreateVTable, a member of class TnxInvokeRegistry.
Iterate | This is Iterate, a member of class TnxInvokeRegistry.
RegisterInterface | InxInvokeRegistry
RegisterProxyFactory | This is RegisterProxyFactory, a member of class TnxInvokeRegistry.
RegisterStubFactory | This is RegisterStubFactory, a member of class TnxInvokeRegistry.
Supports | This is Supports, a member of class TnxInvokeRegistry.
Links
TnxInvokeRegistry Class, Legend, Protected Methods


TnxInvokeRegistry.AddInterface Method

TnxInvokeRegistry.AddInterface Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function AddInterface(aTypeInfo: PTypeInfo): Integer;
Description

TnxInvokeRegistry

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.AddProxyFactory Method

TnxInvokeRegistry.AddProxyFactory Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function AddProxyFactory(const aFactory: InxInvokeProxyFactory): Integer;
Description

This is AddProxyFactory, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.AddStubFactory Method

TnxInvokeRegistry.AddStubFactory Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function AddStubFactory(const aFactory: InxInvokeStubFactory): Integer;
Description

This is AddStubFactory, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.CreateInvokeProxy Method

TnxInvokeRegistry.CreateInvokeProxy Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeProxy(const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInvokeProxy: InxInvokeProxy): HRESULT;
Description

This is CreateInvokeProxy, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.CreateInvokeStub Method

TnxInvokeRegistry.CreateInvokeStub Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aInterfaceID: TnxGuid; const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

This is CreateInvokeStub, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.CreateInvokeWrapper Method

TnxInvokeRegistry.CreateInvokeWrapper Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeWrapper(const aInterface: InxInterface; const aInterceptor: InxInvokeInterceptor; out aWrappedIntf: InxInterface): HRESULT;
Description

This is CreateInvokeWrapper, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.CreateMethodStub Method

TnxInvokeRegistry.CreateMethodStub Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateMethodStub(var aMethod: TnxIntfMethEntry): Pointer;
Description

This is CreateMethodStub, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.CreateVTable Method

TnxInvokeRegistry.CreateVTable Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure CreateVTable(aIndex: Integer; aParentIndex: Integer);
Description

This is CreateVTable, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.Iterate Method

TnxInvokeRegistry.Iterate Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function Iterate(const aInvokeRegistryIterator: InxInvokeRegistryIterator): HRESULT;
Description

This is Iterate, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.RegisterInterface Method

TnxInvokeRegistry.RegisterInterface Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterInterface(aTypeInfo: PTypeInfo);
Description

InxInvokeRegistry

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.RegisterProxyFactory Method

TnxInvokeRegistry.RegisterProxyFactory Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterProxyFactory(const aFactory: InxInvokeProxyFactory);
Description

This is RegisterProxyFactory, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.RegisterStubFactory Method

TnxInvokeRegistry.RegisterStubFactory Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterStubFactory(const aFactory: InxInvokeStubFactory);
Description

This is RegisterStubFactory, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeRegistry.Supports Method

TnxInvokeRegistry.Supports Method
TnxInvokeRegistry Class TnxInvokeRegistry Members nxivRegistry Namespace TnxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function Supports(const aInterfaceID: TnxGuid): HRESULT;
Description

This is Supports, a member of class TnxInvokeRegistry.

Group

TnxInvokeRegistry Methods

Links
TnxInvokeRegistry Class, TnxInvokeRegistry Members, nxivRegistry Namespace, TnxInvokeRegistry Methods


TnxInvokeWrapper Class

TnxInvokeWrapper Class
TnxInvokeWrapper Fields TnxInvokeWrapper Methods TnxInvokeWrapper Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxInvokeWrappernxivRegistry_TnxInvokeWrappernxivRegistry_TnxInvokeWrapper
Syntax
Delphi
TnxInvokeWrapper = class(TnxInterfacedObject, InxInterface);
File

nxivRegistry

Description

This is class nxivRegistry.TnxInvokeWrapper.

Group

Classes

Links
TnxInvokeWrapper Fields, TnxInvokeWrapper Methods, TnxInvokeWrapper Members, nxivRegistry, Classes


TnxInvokeWrapper Members

TnxInvokeWrapper Members
TnxInvokeWrapper Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInvokeWrapper.

Class

TnxInvokeWrapper Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
iwDispRefs | This is iwDispRefs, a member of class TnxInvokeWrapper.
iwInterceptor | This is iwInterceptor, a member of class TnxInvokeWrapper.
iwInterface | private
iwPortal | This is iwPortal, a member of class TnxInvokeWrapper.
iwStubRefs | This is iwStubRefs, a member of class TnxInvokeWrapper.
iwStubs | This is iwStubs, a member of class TnxInvokeWrapper.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
iwCreateWrapper | TnxInvokeWrapper
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInvokeWrapper
Destroy | This is Destroy, a member of class TnxInvokeWrapper.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInvokeWrapper Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInvokeWrapper.Create Constructor

TnxInvokeWrapper.Create Constructor
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Class Send Feedback
Syntax
Delphi
constructor Create(const aInterface: InxInterface; const aInterceptor: InxInvokeInterceptor);
Description

TnxInvokeWrapper

Class

TnxInvokeWrapper Class

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Class


TnxInvokeWrapper.Destroy Destructor

TnxInvokeWrapper.Destroy Destructor
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxInvokeWrapper.

Class

TnxInvokeWrapper Class

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Class


TnxInvokeWrapper Fields

TnxInvokeWrapper Fields
TnxInvokeWrapper Class Legend Protected Fields Send Feedback

The fields of the TnxInvokeWrapper class are listed here.

Class

TnxInvokeWrapper Class

Protected Fields
Name | Description
iwDispRefs | This is iwDispRefs, a member of class TnxInvokeWrapper.
iwInterceptor | This is iwInterceptor, a member of class TnxInvokeWrapper.
iwInterface | private
iwPortal | This is iwPortal, a member of class TnxInvokeWrapper.
iwStubRefs | This is iwStubRefs, a member of class TnxInvokeWrapper.
iwStubs | This is iwStubs, a member of class TnxInvokeWrapper.
Links
TnxInvokeWrapper Class, Legend, Protected Fields


TnxInvokeWrapper.iwDispRefs Field

TnxInvokeWrapper.iwDispRefs Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwDispRefs: array of InxInterface;
Description

This is iwDispRefs, a member of class TnxInvokeWrapper.

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper.iwInterceptor Field

TnxInvokeWrapper.iwInterceptor Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwInterceptor: InxInvokeInterceptor;
Description

This is iwInterceptor, a member of class TnxInvokeWrapper.

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper.iwInterface Field

TnxInvokeWrapper.iwInterface Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwInterface: InxInterface;
Description

private

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper.iwPortal Field

TnxInvokeWrapper.iwPortal Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwPortal: TnxReadWritePortal;
Description

This is iwPortal, a member of class TnxInvokeWrapper.

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper.iwStubRefs Field

TnxInvokeWrapper.iwStubRefs Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwStubRefs: array of InxInvokeStub;
Description

This is iwStubRefs, a member of class TnxInvokeWrapper.

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper.iwStubs Field

TnxInvokeWrapper.iwStubs Field
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Fields Send Feedback
Syntax
Delphi
iwStubs: TnxFastStringListCS;
Description

This is iwStubs, a member of class TnxInvokeWrapper.

Group

TnxInvokeWrapper Fields

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Fields


TnxInvokeWrapper Methods

TnxInvokeWrapper Methods
TnxInvokeWrapper Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeWrapper class are listed here.

Class

TnxInvokeWrapper Class

Protected Methods
Name | Description
iwCreateWrapper | TnxInvokeWrapper
QueryInterface | InxInterface
Links
TnxInvokeWrapper Class, Legend, Protected Methods


TnxInvokeWrapper.iwCreateWrapper Method

TnxInvokeWrapper.iwCreateWrapper Method
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Methods Send Feedback
Syntax
Delphi
function iwCreateWrapper(const IID: TGUID; out Obj): HResult;
Description

TnxInvokeWrapper

Group

TnxInvokeWrapper Methods

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Methods


TnxInvokeWrapper.QueryInterface Method

TnxInvokeWrapper.QueryInterface Method
TnxInvokeWrapper Class TnxInvokeWrapper Members nxivRegistry Namespace TnxInvokeWrapper Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInvokeWrapper Methods

Links
TnxInvokeWrapper Class, TnxInvokeWrapper Members, nxivRegistry Namespace, TnxInvokeWrapper Methods


TnxInvokeWrapperDispatcher Class

TnxInvokeWrapperDispatcher Class
TnxInvokeWrapperDispatcher Fields TnxInvokeWrapperDispatcher Methods TnxInvokeWrapperDispatcher Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxInvokeWrapperDispatchernxivRegistry_TnxInvokeWrapperDispatchernxivRegistry_TnxInvokeWrapperDispatchernxivRegistry_TnxInvokeWrapperDispatcher
Syntax
Delphi
TnxInvokeWrapperDispatcher = class(TnxInterfacedObject, InxInvokeDispatcher);
File

nxivRegistry

Description

This is class nxivRegistry.TnxInvokeWrapperDispatcher.

Group

Classes

Links
TnxInvokeWrapperDispatcher Fields, TnxInvokeWrapperDispatcher Methods, TnxInvokeWrapperDispatcher Members, nxivRegistry, Classes


TnxInvokeWrapperDispatcher Members

TnxInvokeWrapperDispatcher Members
TnxInvokeWrapperDispatcher Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInvokeWrapperDispatcher.

Class

TnxInvokeWrapperDispatcher Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
iwdInterceptor | This is iwdInterceptor, a member of class TnxInvokeWrapperDispatcher.
iwdProxy | This is iwdProxy, a member of class TnxInvokeWrapperDispatcher.
iwdWrapper | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
DispatcherAddRef | This is DispatcherAddRef, a member of class TnxInvokeWrapperDispatcher.
DispatcherQueryInterface | This is DispatcherQueryInterface, a member of class TnxInvokeWrapperDispatcher.
DispatcherRelease | This is DispatcherRelease, a member of class TnxInvokeWrapperDispatcher.
DispatchInvoke | This is DispatchInvoke, a member of class TnxInvokeWrapperDispatcher.
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInvokeWrapperDispatcher
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInvokeWrapperDispatcher Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInvokeWrapperDispatcher.Create Constructor

TnxInvokeWrapperDispatcher.Create Constructor
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Class Send Feedback
Syntax
Delphi
constructor Create(const aWrapper: InxInterface; const aInterceptor: InxInvokeInterceptor; const aInvokeProxy: InxInvokeProxy);
Description

TnxInvokeWrapperDispatcher

Class

TnxInvokeWrapperDispatcher Class

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Class


TnxInvokeWrapperDispatcher Fields

TnxInvokeWrapperDispatcher Fields
TnxInvokeWrapperDispatcher Class Legend Protected Fields Send Feedback

The fields of the TnxInvokeWrapperDispatcher class are listed here.

Class

TnxInvokeWrapperDispatcher Class

Protected Fields
Name | Description
iwdInterceptor | This is iwdInterceptor, a member of class TnxInvokeWrapperDispatcher.
iwdProxy | This is iwdProxy, a member of class TnxInvokeWrapperDispatcher.
iwdWrapper | private
Links
TnxInvokeWrapperDispatcher Class, Legend, Protected Fields


TnxInvokeWrapperDispatcher.iwdInterceptor Field

TnxInvokeWrapperDispatcher.iwdInterceptor Field
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Fields Send Feedback
Syntax
Delphi
iwdInterceptor: InxInvokeInterceptor;
Description

This is iwdInterceptor, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Fields

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Fields


TnxInvokeWrapperDispatcher.iwdProxy Field

TnxInvokeWrapperDispatcher.iwdProxy Field
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Fields Send Feedback
Syntax
Delphi
iwdProxy: InxInvokeProxy;
Description

This is iwdProxy, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Fields

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Fields


TnxInvokeWrapperDispatcher.iwdWrapper Field

TnxInvokeWrapperDispatcher.iwdWrapper Field
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Fields Send Feedback
Syntax
Delphi
iwdWrapper: Pointer;
Description

private

Group

TnxInvokeWrapperDispatcher Fields

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Fields


TnxInvokeWrapperDispatcher Methods

TnxInvokeWrapperDispatcher Methods
TnxInvokeWrapperDispatcher Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeWrapperDispatcher class are listed here.

Class

TnxInvokeWrapperDispatcher Class

Protected Methods
Name | Description
DispatcherAddRef | This is DispatcherAddRef, a member of class TnxInvokeWrapperDispatcher.
DispatcherQueryInterface | This is DispatcherQueryInterface, a member of class TnxInvokeWrapperDispatcher.
DispatcherRelease | This is DispatcherRelease, a member of class TnxInvokeWrapperDispatcher.
DispatchInvoke | This is DispatchInvoke, a member of class TnxInvokeWrapperDispatcher.
Links
TnxInvokeWrapperDispatcher Class, Legend, Protected Methods


TnxInvokeWrapperDispatcher.DispatcherAddRef Method

TnxInvokeWrapperDispatcher.DispatcherAddRef Method
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Methods Send Feedback
Syntax
Delphi
function DispatcherAddRef: Integer; stdcall;
Description

This is DispatcherAddRef, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Methods

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Methods


TnxInvokeWrapperDispatcher.DispatcherQueryInterface Method

TnxInvokeWrapperDispatcher.DispatcherQueryInterface Method
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Methods Send Feedback
Syntax
Delphi
function DispatcherQueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

This is DispatcherQueryInterface, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Methods

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Methods


TnxInvokeWrapperDispatcher.DispatcherRelease Method

TnxInvokeWrapperDispatcher.DispatcherRelease Method
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Methods Send Feedback
Syntax
Delphi
function DispatcherRelease: Integer; stdcall;
Description

This is DispatcherRelease, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Methods

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Methods


TnxInvokeWrapperDispatcher.DispatchInvoke Method

TnxInvokeWrapperDispatcher.DispatchInvoke Method
TnxInvokeWrapperDispatcher Class TnxInvokeWrapperDispatcher Members nxivRegistry Namespace TnxInvokeWrapperDispatcher Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

This is DispatchInvoke, a member of class TnxInvokeWrapperDispatcher.

Group

TnxInvokeWrapperDispatcher Methods

Links
TnxInvokeWrapperDispatcher Class, TnxInvokeWrapperDispatcher Members, nxivRegistry Namespace, TnxInvokeWrapperDispatcher Methods


TnxRTTIInvokeStub Class

TnxRTTIInvokeStub Class
TnxRTTIInvokeStub Methods TnxRTTIInvokeStub Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxRTTIInvokeStubnxivRegistry_TnxRTTIInvokeStubnxivRegistry_TnxRTTIInvokeStubnxivRegistry_TnxRTTIInvokeStub
Syntax
Delphi
TnxRTTIInvokeStub = class(TnxRTTIInvokeStub_, InxInterface, InxInvokeHasIntfMetaData, InxInvokeStub);
File

nxivRegistry

Description

This is class nxivRegistry.TnxRTTIInvokeStub.

Group

Classes

Links
TnxRTTIInvokeStub Methods, TnxRTTIInvokeStub Members, nxivRegistry, Classes


TnxRTTIInvokeStub Members

TnxRTTIInvokeStub Members
TnxRTTIInvokeStub Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRTTIInvokeStub.

Class

TnxRTTIInvokeStub Class

Protected Fields
Name | Description
risDispatcher | This is risDispatcher, a member of class TnxRTTIInvokeStub_.
risMetaData | This is risMetaData, a member of class TnxRTTIInvokeStub_.
Protected Methods
Name | Description
GetIntfMetaData | InxInvokeHasIntfMetaData
OrgAddRef | This is OrgAddRef, a member of class TnxRTTIInvokeStub_.
OrgQueryInterface | This is OrgQueryInterface, a member of class TnxRTTIInvokeStub_.
OrgRelease | This is OrgRelease, a member of class TnxRTTIInvokeStub_.
risInvoke | This is risInvoke, a member of class TnxRTTIInvokeStub_.
Public Methods
Name | Description
_AddRef | This is _AddRef, a member of class TnxRTTIInvokeStub.
_Release | This is _Release, a member of class TnxRTTIInvokeStub.
Create | TnxRTTIInvokeStub
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
QueryInterface | InxInterface, InxInvokeStub TnxRTTIInvokeStub
Links
TnxRTTIInvokeStub Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxRTTIInvokeStub Methods

TnxRTTIInvokeStub Methods
TnxRTTIInvokeStub Class Legend Public Methods Send Feedback

The methods of the TnxRTTIInvokeStub class are listed here.

Class

TnxRTTIInvokeStub Class

Public Methods
Name | Description
_AddRef | This is _AddRef, a member of class TnxRTTIInvokeStub.
_Release | This is _Release, a member of class TnxRTTIInvokeStub.
QueryInterface | InxInterface, InxInvokeStub TnxRTTIInvokeStub
Links
TnxRTTIInvokeStub Class, Legend, Public Methods


TnxRTTIInvokeStub._AddRef Method

TnxRTTIInvokeStub._AddRef Method
TnxRTTIInvokeStub Class TnxRTTIInvokeStub Members nxivRegistry Namespace TnxRTTIInvokeStub Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; virtual; stdcall; reintroduce;
Description

This is _AddRef, a member of class TnxRTTIInvokeStub.

Group

TnxRTTIInvokeStub Methods

Links
TnxRTTIInvokeStub Class, TnxRTTIInvokeStub Members, nxivRegistry Namespace, TnxRTTIInvokeStub Methods


TnxRTTIInvokeStub._Release Method

TnxRTTIInvokeStub._Release Method
TnxRTTIInvokeStub Class TnxRTTIInvokeStub Members nxivRegistry Namespace TnxRTTIInvokeStub Methods Send Feedback
Syntax
Delphi
function _Release: Integer; virtual; stdcall; reintroduce;
Description

This is _Release, a member of class TnxRTTIInvokeStub.

Group

TnxRTTIInvokeStub Methods

Links
TnxRTTIInvokeStub Class, TnxRTTIInvokeStub Members, nxivRegistry Namespace, TnxRTTIInvokeStub Methods


TnxRTTIInvokeStub.QueryInterface Method

TnxRTTIInvokeStub.QueryInterface Method
TnxRTTIInvokeStub Class TnxRTTIInvokeStub Members nxivRegistry Namespace TnxRTTIInvokeStub Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall; reintroduce;
Description

InxInterface, InxInvokeStub

TnxRTTIInvokeStub

Group

TnxRTTIInvokeStub Methods

Links
TnxRTTIInvokeStub Class, TnxRTTIInvokeStub Members, nxivRegistry Namespace, TnxRTTIInvokeStub Methods


TnxRTTIInvokeStub_ Class

TnxRTTIInvokeStub_ Class
TnxRTTIInvokeStub_ Fields TnxRTTIInvokeStub_ Methods TnxRTTIInvokeStub_ Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxRTTIInvokeStub_
Syntax
Delphi
TnxRTTIInvokeStub_ = class(TVirtualInterface);
File

nxivRegistry

Description

This is class nxivRegistry.TnxRTTIInvokeStub_.

Group

Classes

Links
TnxRTTIInvokeStub_ Fields, TnxRTTIInvokeStub_ Methods, TnxRTTIInvokeStub_ Members, nxivRegistry, Classes


TnxRTTIInvokeStub_ Members

TnxRTTIInvokeStub_ Members
TnxRTTIInvokeStub_ Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRTTIInvokeStub_.

Class

TnxRTTIInvokeStub_ Class

Protected Fields
Name | Description
risDispatcher | This is risDispatcher, a member of class TnxRTTIInvokeStub_.
risMetaData | This is risMetaData, a member of class TnxRTTIInvokeStub_.
Protected Methods
Name | Description
_AddRef | This is _AddRef, a member of class TnxRTTIInvokeStub_.
_Release | This is _Release, a member of class TnxRTTIInvokeStub_.
GetIntfMetaData | InxInvokeHasIntfMetaData
OrgAddRef | This is OrgAddRef, a member of class TnxRTTIInvokeStub_.
OrgQueryInterface | This is OrgQueryInterface, a member of class TnxRTTIInvokeStub_.
OrgRelease | This is OrgRelease, a member of class TnxRTTIInvokeStub_.
risInvoke | This is risInvoke, a member of class TnxRTTIInvokeStub_.
Public Methods
Name | Description
Create | TnxRTTIInvokeStub
QueryInterface | This is QueryInterface, a member of class TnxRTTIInvokeStub_.
Links
TnxRTTIInvokeStub_ Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxRTTIInvokeStub_.Create Constructor

TnxRTTIInvokeStub_.Create Constructor
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData; const aDispatcher: InxInvokeDispatcher); virtual;
Description

TnxRTTIInvokeStub

Class

TnxRTTIInvokeStub_ Class

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Class


TnxRTTIInvokeStub_ Fields

TnxRTTIInvokeStub_ Fields
TnxRTTIInvokeStub_ Class Legend Protected Fields Send Feedback

The fields of the TnxRTTIInvokeStub_ class are listed here.

Class

TnxRTTIInvokeStub_ Class

Protected Fields
Name | Description
risDispatcher | This is risDispatcher, a member of class TnxRTTIInvokeStub_.
risMetaData | This is risMetaData, a member of class TnxRTTIInvokeStub_.
Links
TnxRTTIInvokeStub_ Class, Legend, Protected Fields


TnxRTTIInvokeStub_.risDispatcher Field

TnxRTTIInvokeStub_.risDispatcher Field
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Fields Send Feedback
Syntax
Delphi
risDispatcher: Pointer;
Description

This is risDispatcher, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Fields

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Fields


TnxRTTIInvokeStub_.risMetaData Field

TnxRTTIInvokeStub_.risMetaData Field
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Fields Send Feedback
Syntax
Delphi
risMetaData: PnxIntfMetaData;
Description

This is risMetaData, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Fields

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Fields


TnxRTTIInvokeStub_ Methods

TnxRTTIInvokeStub_ Methods
TnxRTTIInvokeStub_ Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRTTIInvokeStub_ class are listed here.

Class

TnxRTTIInvokeStub_ Class

Protected Methods
Name | Description
_AddRef | This is _AddRef, a member of class TnxRTTIInvokeStub_.
_Release | This is _Release, a member of class TnxRTTIInvokeStub_.
GetIntfMetaData | InxInvokeHasIntfMetaData
OrgAddRef | This is OrgAddRef, a member of class TnxRTTIInvokeStub_.
OrgQueryInterface | This is OrgQueryInterface, a member of class TnxRTTIInvokeStub_.
OrgRelease | This is OrgRelease, a member of class TnxRTTIInvokeStub_.
risInvoke | This is risInvoke, a member of class TnxRTTIInvokeStub_.
Public Methods
Name | Description
QueryInterface | This is QueryInterface, a member of class TnxRTTIInvokeStub_.
Links
TnxRTTIInvokeStub_ Class, Legend, Protected Methods, Public Methods


TnxRTTIInvokeStub_._AddRef Method

TnxRTTIInvokeStub_._AddRef Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; override; stdcall;
Description

This is _AddRef, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_._Release Method

TnxRTTIInvokeStub_._Release Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function _Release: Integer; override; stdcall;
Description

This is _Release, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.GetIntfMetaData Method

TnxRTTIInvokeStub_.GetIntfMetaData Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

InxInvokeHasIntfMetaData

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.OrgAddRef Method

TnxRTTIInvokeStub_.OrgAddRef Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function OrgAddRef: Integer; stdcall;
Description

This is OrgAddRef, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.OrgQueryInterface Method

TnxRTTIInvokeStub_.OrgQueryInterface Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function OrgQueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Description

This is OrgQueryInterface, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.OrgRelease Method

TnxRTTIInvokeStub_.OrgRelease Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function OrgRelease: Integer; stdcall;
Description

This is OrgRelease, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.QueryInterface Method

TnxRTTIInvokeStub_.QueryInterface Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
function QueryInterface(const IID: TGUID; out Obj): HResult; override; stdcall;
Description

This is QueryInterface, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStub_.risInvoke Method

TnxRTTIInvokeStub_.risInvoke Method
TnxRTTIInvokeStub_ Class TnxRTTIInvokeStub_ Members nxivRegistry Namespace TnxRTTIInvokeStub_ Methods Send Feedback
Syntax
Delphi
procedure risInvoke(Method: TRttiMethod; const Args: TArray<TValue>; out Result: TValue);
Description

This is risInvoke, a member of class TnxRTTIInvokeStub_.

Group

TnxRTTIInvokeStub_ Methods

Links
TnxRTTIInvokeStub_ Class, TnxRTTIInvokeStub_ Members, nxivRegistry Namespace, TnxRTTIInvokeStub_ Methods


TnxRTTIInvokeStubFactory Class

TnxRTTIInvokeStubFactory Class
TnxRTTIInvokeStubFactory Fields TnxRTTIInvokeStubFactory Methods TnxRTTIInvokeStubFactory Members nxivRegistry Classes Send Feedback
Class Hierarchy
nxivRegistry_TnxRTTIInvokeStubFactorynxivRegistry_TnxRTTIInvokeStubFactorynxivRegistry_TnxRTTIInvokeStubFactory
Syntax
Delphi
TnxRTTIInvokeStubFactory = class(TInterfacedObject, InxInvokeStubFactory);
File

nxivRegistry

Description

This is class nxivRegistry.TnxRTTIInvokeStubFactory.

Group

Classes

Links
TnxRTTIInvokeStubFactory Fields, TnxRTTIInvokeStubFactory Methods, TnxRTTIInvokeStubFactory Members, nxivRegistry, Classes


TnxRTTIInvokeStubFactory Members

TnxRTTIInvokeStubFactory Members
TnxRTTIInvokeStubFactory Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRTTIInvokeStubFactory.

Class

TnxRTTIInvokeStubFactory Class

Protected Fields
Name | Description
risfMetaData | private
Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxRTTIInvokeStubFactory.
Public Methods
Name | Description
Create | TnxRTTIInvokeStubFactory
Links
TnxRTTIInvokeStubFactory Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxRTTIInvokeStubFactory.Create Constructor

TnxRTTIInvokeStubFactory.Create Constructor
TnxRTTIInvokeStubFactory Class TnxRTTIInvokeStubFactory Members nxivRegistry Namespace TnxRTTIInvokeStubFactory Class Send Feedback
Syntax
Delphi
constructor Create(aMetaData: PnxIntfMetaData);
Description

TnxRTTIInvokeStubFactory

Class

TnxRTTIInvokeStubFactory Class

Links
TnxRTTIInvokeStubFactory Class, TnxRTTIInvokeStubFactory Members, nxivRegistry Namespace, TnxRTTIInvokeStubFactory Class


TnxRTTIInvokeStubFactory Fields

TnxRTTIInvokeStubFactory Fields
TnxRTTIInvokeStubFactory Class Legend Protected Fields Send Feedback

The fields of the TnxRTTIInvokeStubFactory class are listed here.

Class

TnxRTTIInvokeStubFactory Class

Protected Fields
Name | Description
risfMetaData | private
Links
TnxRTTIInvokeStubFactory Class, Legend, Protected Fields


TnxRTTIInvokeStubFactory.risfMetaData Field

TnxRTTIInvokeStubFactory.risfMetaData Field
TnxRTTIInvokeStubFactory Class TnxRTTIInvokeStubFactory Members nxivRegistry Namespace TnxRTTIInvokeStubFactory Fields Send Feedback
Syntax
Delphi
risfMetaData: PnxIntfMetaData;
Description

private

Group

TnxRTTIInvokeStubFactory Fields

Links
TnxRTTIInvokeStubFactory Class, TnxRTTIInvokeStubFactory Members, nxivRegistry Namespace, TnxRTTIInvokeStubFactory Fields


TnxRTTIInvokeStubFactory Methods

TnxRTTIInvokeStubFactory Methods
TnxRTTIInvokeStubFactory Class Legend Protected Methods Send Feedback

The methods of the TnxRTTIInvokeStubFactory class are listed here.

Class

TnxRTTIInvokeStubFactory Class

Protected Methods
Name | Description
CreateInvokeStub | InxInvokeStubFactory
GetIntfMetaData | This is GetIntfMetaData, a member of class TnxRTTIInvokeStubFactory.
Links
TnxRTTIInvokeStubFactory Class, Legend, Protected Methods


TnxRTTIInvokeStubFactory.CreateInvokeStub Method

TnxRTTIInvokeStubFactory.CreateInvokeStub Method
TnxRTTIInvokeStubFactory Class TnxRTTIInvokeStubFactory Members nxivRegistry Namespace TnxRTTIInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

InxInvokeStubFactory

Group

TnxRTTIInvokeStubFactory Methods

Links
TnxRTTIInvokeStubFactory Class, TnxRTTIInvokeStubFactory Members, nxivRegistry Namespace, TnxRTTIInvokeStubFactory Methods


TnxRTTIInvokeStubFactory.GetIntfMetaData Method

TnxRTTIInvokeStubFactory.GetIntfMetaData Method
TnxRTTIInvokeStubFactory Class TnxRTTIInvokeStubFactory Members nxivRegistry Namespace TnxRTTIInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class TnxRTTIInvokeStubFactory.

Group

TnxRTTIInvokeStubFactory Methods

Links
TnxRTTIInvokeStubFactory Class, TnxRTTIInvokeStubFactory Members, nxivRegistry Namespace, TnxRTTIInvokeStubFactory Methods


Structs, Records, Enums

Structs, Records, Enums
nxivRegistry Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxivRegistry Namespace

Records
Name | Description
TnxCodeStore | This is record nxivRegistry.TnxCodeStore.
Links
nxivRegistry Namespace, Legend, Records


nxivRegistry.TnxCodeStore Record

nxivRegistry.TnxCodeStore Record
nxivRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCodeStore = record
  csNext: PnxCodeStore;
  csPos: Integer;
  csPadding: array[0..7] of Byte;
  csData: array[0..High(Word)-16] of Byte;
end;
File

nxivRegistry

Description

This is record nxivRegistry.TnxCodeStore.

Group

Structs, Records, Enums

Links
nxivRegistry, Structs, Records, Enums


Types

Types
nxivRegistry Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxivRegistry Namespace

Types
Name | Description
PnxCodeStore | TnxCodeGen
PnxGeneratedInvokeProxyHandlers | This is type nxivRegistry.PnxGeneratedInvokeProxyHandlers.
TnxGeneratedInvokeProxyHandler | This is type nxivRegistry.TnxGeneratedInvokeProxyHandler.
TnxGeneratedInvokeProxyHandlers | This is type nxivRegistry.TnxGeneratedInvokeProxyHandlers.
TnxGeneratedInvokeStubClass | This is type nxivRegistry.TnxGeneratedInvokeStubClass.
Links
nxivRegistry Namespace, Types


nxivRegistry.PnxCodeStore Type

nxivRegistry.PnxCodeStore Type
nxivRegistry Types Send Feedback
Syntax
Delphi
PnxCodeStore = ^TnxCodeStore;
File

nxivRegistry

Description

TnxCodeGen

Group

Types

Links
nxivRegistry, Types


nxivRegistry.PnxGeneratedInvokeProxyHandlers Type

nxivRegistry.PnxGeneratedInvokeProxyHandlers Type
nxivRegistry Types Send Feedback
Syntax
Delphi
PnxGeneratedInvokeProxyHandlers = ^TnxGeneratedInvokeProxyHandlers;
File

nxivRegistry

Description

This is type nxivRegistry.PnxGeneratedInvokeProxyHandlers.

Group

Types

Links
nxivRegistry, Types


nxivRegistry.TnxGeneratedInvokeProxyHandler Type

nxivRegistry.TnxGeneratedInvokeProxyHandler Type
nxivRegistry Types Send Feedback
Syntax
Delphi
TnxGeneratedInvokeProxyHandler = procedure (aInterface : Pointer; aMethod : PnxIntfMethEntry; aParams : PnxPointerArray);
File

nxivRegistry

Description

This is type nxivRegistry.TnxGeneratedInvokeProxyHandler.

Group

Types

Links
nxivRegistry, Types


nxivRegistry.TnxGeneratedInvokeProxyHandlers Type

nxivRegistry.TnxGeneratedInvokeProxyHandlers Type
nxivRegistry Types Send Feedback
Syntax
Delphi
TnxGeneratedInvokeProxyHandlers = array[0..Pred(High(Integer) div SizeOf(Pointer))] of TnxGeneratedInvokeProxyHandler;
File

nxivRegistry

Description

This is type nxivRegistry.TnxGeneratedInvokeProxyHandlers.

Group

Types

Links
nxivRegistry, Types


nxivRegistry.TnxGeneratedInvokeStubClass Type

nxivRegistry.TnxGeneratedInvokeStubClass Type
nxivRegistry Types Send Feedback
Syntax
Delphi
TnxGeneratedInvokeStubClass = class of TnxGeneratedInvokeStub;
File

nxivRegistry

Description

This is type nxivRegistry.TnxGeneratedInvokeStubClass.

Group

Types

Links
nxivRegistry, Types


Variables

Variables
nxivRegistry Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxivRegistry Namespace

Variables
Name | Description
_StubAddRef | This is variable nxivRegistry._StubAddRef.
_StubEntry | This is variable nxivRegistry._StubEntry.
_StubQueryInterface | This is variable nxivRegistry._StubQueryInterface.
_StubRelease | This is variable nxivRegistry._StubRelease.
_StubVTableOffset | This is variable nxivRegistry._StubVTableOffset.
Args | This is variable nxivRegistry.Args.
i | This is variable nxivRegistry.i.
Instance | This is variable nxivRegistry.Instance.
Params | This is variable nxivRegistry.Params.
pCodeStoreHead | This is variable nxivRegistry.pCodeStoreHead.
plCodeStore | This is variable nxivRegistry.plCodeStore.
Res | This is variable nxivRegistry.Res.
ResultIdx | This is variable nxivRegistry.ResultIdx.
Links
nxivRegistry Namespace, Variables


nxivRegistry._StubAddRef Variable

nxivRegistry._StubAddRef Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
_StubAddRef: Pointer;
File

nxivRegistry

Description

This is variable nxivRegistry._StubAddRef.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry._StubEntry Variable

nxivRegistry._StubEntry Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
_StubEntry: Pointer;
File

nxivRegistry

Description

This is variable nxivRegistry._StubEntry.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry._StubQueryInterface Variable

nxivRegistry._StubQueryInterface Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
_StubQueryInterface: Pointer;
File

nxivRegistry

Description

This is variable nxivRegistry._StubQueryInterface.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry._StubRelease Variable

nxivRegistry._StubRelease Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
_StubRelease: Pointer;
File

nxivRegistry

Description

This is variable nxivRegistry._StubRelease.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry._StubVTableOffset Variable

nxivRegistry._StubVTableOffset Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
_StubVTableOffset: Integer;
File

nxivRegistry

Description

This is variable nxivRegistry._StubVTableOffset.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.Args Variable

nxivRegistry.Args Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
Args: array of TValue;
File

nxivRegistry

Description

This is variable nxivRegistry.Args.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.i Variable

nxivRegistry.i Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
i: Integer;
File

nxivRegistry

Description

This is variable nxivRegistry.i.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.Instance Variable

nxivRegistry.Instance Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
Instance: TValue;
File

nxivRegistry

Description

This is variable nxivRegistry.Instance.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.Params Variable

nxivRegistry.Params Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
Params: TArray<TRttiParameter>;
File

nxivRegistry

Description

This is variable nxivRegistry.Params.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.pCodeStoreHead Variable

nxivRegistry.pCodeStoreHead Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
pCodeStoreHead: PnxCodeStore;
File

nxivRegistry

Description

This is variable nxivRegistry.pCodeStoreHead.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.plCodeStore Variable

nxivRegistry.plCodeStore Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
plCodeStore: TnxPadlock;
File

nxivRegistry

Description

This is variable nxivRegistry.plCodeStore.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.Res Variable

nxivRegistry.Res Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
Res: TValue;
File

nxivRegistry

Description

This is variable nxivRegistry.Res.

Group

Variables

Links
nxivRegistry, Variables


nxivRegistry.ResultIdx Variable

nxivRegistry.ResultIdx Variable
nxivRegistry Variables Send Feedback
Syntax
Delphi
ResultIdx: Integer;
File

nxivRegistry

Description

This is variable nxivRegistry.ResultIdx.

Group

Variables

Links
nxivRegistry, Variables


nxivSourceGen Namespace

nxivSourceGen Namespace
Classes Functions Legend Topics Send Feedback

This is namespace nxivSourceGen.

Classes
Name | Description
TnxInvokeSourceGen | This is class nxivSourceGen.TnxInvokeSourceGen.
Functions
Name | Description
nxGenerateAllInvokeSources | This is function nxivSourceGen.nxGenerateAllInvokeSources.
nxGenerateInvokeSource | This is function nxivSourceGen.nxGenerateInvokeSource.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Links
Classes, Functions, Legend, Topics


Classes

Classes
Classes nxivSourceGen Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInvokeSourceGen | This is class nxivSourceGen.TnxInvokeSourceGen.
Namespace

nxivSourceGen Namespace

Links
Classes, nxivSourceGen Namespace, Legend


TnxInvokeSourceGen Class

TnxInvokeSourceGen Class
TnxInvokeSourceGen Methods TnxInvokeSourceGen Members nxivSourceGen Classes Send Feedback
Class Hierarchy
nxivSourceGen_TnxInvokeSourceGennxivSourceGen_TnxInvokeSourceGen
Syntax
Delphi
TnxInvokeSourceGen = class(TnxInterfacedObject, InxInvokeRegistryIterator);
File

nxivSourceGen

Description

This is class nxivSourceGen.TnxInvokeSourceGen.

Group

Classes

Links
TnxInvokeSourceGen Methods, TnxInvokeSourceGen Members, nxivSourceGen, Classes


TnxInvokeSourceGen Members

TnxInvokeSourceGen Members
TnxInvokeSourceGen Class Legend Protected Methods Send Feedback

The following tables list the members exposed by TnxInvokeSourceGen.

Class

TnxInvokeSourceGen Class

Protected Methods
Name | Description
Callback | InxInvokeRegistryIterator TnxInvokeSourceGen
Links
TnxInvokeSourceGen Class, Legend, Protected Methods


TnxInvokeSourceGen Methods

TnxInvokeSourceGen Methods
TnxInvokeSourceGen Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeSourceGen class are listed here.

Class

TnxInvokeSourceGen Class

Protected Methods
Name | Description
Callback | InxInvokeRegistryIterator TnxInvokeSourceGen
Links
TnxInvokeSourceGen Class, Legend, Protected Methods


TnxInvokeSourceGen.Callback Method

TnxInvokeSourceGen.Callback Method
TnxInvokeSourceGen Class TnxInvokeSourceGen Members nxivSourceGen Namespace TnxInvokeSourceGen Methods Send Feedback
Syntax
Delphi
function Callback(aInterface: PnxIntfMetaData): HRESULT;
Description

InxInvokeRegistryIterator

TnxInvokeSourceGen

Group

TnxInvokeSourceGen Methods

Links
TnxInvokeSourceGen Class, TnxInvokeSourceGen Members, nxivSourceGen Namespace, TnxInvokeSourceGen Methods


Functions

Functions
Functions nxivSourceGen Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxGenerateAllInvokeSources | This is function nxivSourceGen.nxGenerateAllInvokeSources.
nxGenerateInvokeSource | This is function nxivSourceGen.nxGenerateInvokeSource.
Namespace

nxivSourceGen Namespace

Links
Functions, nxivSourceGen Namespace, Legend


nxivSourceGen.nxGenerateAllInvokeSources Function

nxivSourceGen.nxGenerateAllInvokeSources Function
nxivSourceGen Functions Send Feedback
Syntax
Delphi
function nxGenerateAllInvokeSources: HRESULT;
File

nxivSourceGen

Description

This is function nxivSourceGen.nxGenerateAllInvokeSources.

Group

Functions

Links
nxivSourceGen, Functions


nxivSourceGen.nxGenerateInvokeSource Function

nxivSourceGen.nxGenerateInvokeSource Function
nxivSourceGen Functions Send Feedback
Syntax
Delphi
function nxGenerateInvokeSource(aInterface: PnxIntfMetaData): HRESULT;
File

nxivSourceGen

Description

This is function nxivSourceGen.nxGenerateInvokeSource.

Group

Functions

Links
nxivSourceGen, Functions


nxivTypes Namespace

nxivTypes Namespace
Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxivTypes.

Constants
Name | Description
rsInterfaceNotRegistered | This is constant nxivTypes.rsInterfaceNotRegistered.
Functions
Name | Description
nxInvokeRegistry | This is function nxivTypes.nxInvokeRegistry.
Interfaces
Name | Description
InxCallFrame | This is class nxivTypes.InxCallFrame.
InxInvokeDispatcher | This is class nxivTypes.InxInvokeDispatcher.
InxInvokeHasIntfMetaData | This is class nxivTypes.InxInvokeHasIntfMetaData.
InxInvokeHasIntfMethEntry | This is class nxivTypes.InxInvokeHasIntfMethEntry.
InxInvokeInterceptor | This is class nxivTypes.InxInvokeInterceptor.
InxInvokeProxy | This is class nxivTypes.InxInvokeProxy.
InxInvokeProxyFactory | This is class nxivTypes.InxInvokeProxyFactory.
InxInvokeRegistry | This is class nxivTypes.InxInvokeRegistry.
InxInvokeRegistryIterator | This is class nxivTypes.InxInvokeRegistryIterator.
InxInvokeStub | This is class nxivTypes.InxInvokeStub.
InxInvokeStubFactory | This is class nxivTypes.InxInvokeStubFactory.
Structs, Records, Enums
Name | Description
TnxCallConv | This is record nxivTypes.TnxCallConv.
TnxIntfMetaData | This is record nxivTypes.TnxIntfMetaData.
TnxIntfMethEntry | This is record nxivTypes.TnxIntfMethEntry.
TnxIntfParamEntry | This is record nxivTypes.TnxIntfParamEntry.
TnxPassInRegister | This is record nxivTypes.TnxPassInRegister.
TnxResultIn | This is record nxivTypes.TnxResultIn.
Topics
Name | Description
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxIntfMetaData | This is type nxivTypes.PnxIntfMetaData.
PnxIntfMethEntry | This is type nxivTypes.PnxIntfMethEntry.
PnxIntfParamEntry | This is type nxivTypes.PnxIntfParamEntry.
TnxIntfMethEntryArray | This is type nxivTypes.TnxIntfMethEntryArray.
TnxIntfParamEntryArray | This is type nxivTypes.TnxIntfParamEntryArray.
Variables
Name | Description
_InvokeRegistry | This is variable nxivTypes._InvokeRegistry.
Links
Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Interfaces

Interfaces
nxivTypes Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxivTypes Namespace

Interfaces
Name | Description
InxCallFrame | This is class nxivTypes.InxCallFrame.
InxInvokeDispatcher | This is class nxivTypes.InxInvokeDispatcher.
InxInvokeHasIntfMetaData | This is class nxivTypes.InxInvokeHasIntfMetaData.
InxInvokeHasIntfMethEntry | This is class nxivTypes.InxInvokeHasIntfMethEntry.
InxInvokeInterceptor | This is class nxivTypes.InxInvokeInterceptor.
InxInvokeProxy | This is class nxivTypes.InxInvokeProxy.
InxInvokeProxyFactory | This is class nxivTypes.InxInvokeProxyFactory.
InxInvokeRegistry | This is class nxivTypes.InxInvokeRegistry.
InxInvokeRegistryIterator | This is class nxivTypes.InxInvokeRegistryIterator.
InxInvokeStub | This is class nxivTypes.InxInvokeStub.
InxInvokeStubFactory | This is class nxivTypes.InxInvokeStubFactory.
Links
nxivTypes Namespace, Interfaces, Legend


InxCallFrame Interface

InxCallFrame Interface
InxCallFrame Methods InxCallFrame Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxCallFramenxivTypes_InxCallFramenxivTypes_InxCallFrame
Syntax
Delphi
InxCallFrame = interface(InxInvokeHasIntfMethEntry);
File

nxivTypes

Description

This is class nxivTypes.InxCallFrame.

Group

Interfaces

Links
InxCallFrame Methods, InxCallFrame Members, nxivTypes, Interfaces


InxCallFrame Members

InxCallFrame Members
InxCallFrame Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxCallFrame.

Interface

InxCallFrame Interface

Public Methods
Name | Description
CopyFrom | This is CopyFrom, a member of class InxCallFrame.
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
MakeCall | This is MakeCall, a member of class InxCallFrame.
Links
InxCallFrame Interface, Legend, Public Methods


InxCallFrame Methods

InxCallFrame Methods
InxCallFrame Interface Legend Public Methods Send Feedback

The methods of the InxCallFrame class are listed here.

Interface

InxCallFrame Interface

Public Methods
Name | Description
CopyFrom | This is CopyFrom, a member of class InxCallFrame.
MakeCall | This is MakeCall, a member of class InxCallFrame.
Links
InxCallFrame Interface, Legend, Public Methods


InxCallFrame.CopyFrom Method

InxCallFrame.CopyFrom Method
InxCallFrame Interface InxCallFrame Members nxivTypes Namespace InxCallFrame Methods Send Feedback
Syntax
Delphi
function CopyFrom(aParams: PnxPointerArray): HRESULT;
Description

This is CopyFrom, a member of class InxCallFrame.

Group

InxCallFrame Methods

Links
InxCallFrame Interface, InxCallFrame Members, nxivTypes Namespace, InxCallFrame Methods


InxCallFrame.MakeCall Method

InxCallFrame.MakeCall Method
InxCallFrame Interface InxCallFrame Members nxivTypes Namespace InxCallFrame Methods Send Feedback
Syntax
Delphi
function MakeCall: HRESULT;
Description

This is MakeCall, a member of class InxCallFrame.

Group

InxCallFrame Methods

Links
InxCallFrame Interface, InxCallFrame Members, nxivTypes Namespace, InxCallFrame Methods


InxInvokeDispatcher Interface

InxInvokeDispatcher Interface
InxInvokeDispatcher Methods InxInvokeDispatcher Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeDispatcher
Syntax
Delphi
InxInvokeDispatcher = interface(InxInterface);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeDispatcher.

Group

Interfaces

Links
InxInvokeDispatcher Methods, InxInvokeDispatcher Members, nxivTypes, Interfaces


InxInvokeDispatcher Members

InxInvokeDispatcher Members
InxInvokeDispatcher Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeDispatcher.

Interface

InxInvokeDispatcher Interface

Public Methods
Name | Description
DispatchInvoke | This is DispatchInvoke, a member of class InxInvokeDispatcher.
Links
InxInvokeDispatcher Interface, Legend, Public Methods


InxInvokeDispatcher Methods

InxInvokeDispatcher Methods
InxInvokeDispatcher Interface Legend Public Methods Send Feedback

The methods of the InxInvokeDispatcher class are listed here.

Interface

InxInvokeDispatcher Interface

Public Methods
Name | Description
DispatchInvoke | This is DispatchInvoke, a member of class InxInvokeDispatcher.
Links
InxInvokeDispatcher Interface, Legend, Public Methods


InxInvokeDispatcher.DispatchInvoke Method

InxInvokeDispatcher.DispatchInvoke Method
InxInvokeDispatcher Interface InxInvokeDispatcher Members nxivTypes Namespace InxInvokeDispatcher Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

This is DispatchInvoke, a member of class InxInvokeDispatcher.

Group

InxInvokeDispatcher Methods

Links
InxInvokeDispatcher Interface, InxInvokeDispatcher Members, nxivTypes Namespace, InxInvokeDispatcher Methods


InxInvokeHasIntfMetaData Interface

InxInvokeHasIntfMetaData Interface
InxInvokeHasIntfMetaData Methods InxInvokeHasIntfMetaData Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeHasIntfMetaData
Syntax
Delphi
InxInvokeHasIntfMetaData = interface(InxInterface);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeHasIntfMetaData.

Group

Interfaces

Links
InxInvokeHasIntfMetaData Methods, InxInvokeHasIntfMetaData Members, nxivTypes, Interfaces


InxInvokeHasIntfMetaData Members

InxInvokeHasIntfMetaData Members
InxInvokeHasIntfMetaData Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeHasIntfMetaData.

Interface

InxInvokeHasIntfMetaData Interface

Public Methods
Name | Description
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
Links
InxInvokeHasIntfMetaData Interface, Legend, Public Methods


InxInvokeHasIntfMetaData Methods

InxInvokeHasIntfMetaData Methods
InxInvokeHasIntfMetaData Interface Legend Public Methods Send Feedback

The methods of the InxInvokeHasIntfMetaData class are listed here.

Interface

InxInvokeHasIntfMetaData Interface

Public Methods
Name | Description
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
Links
InxInvokeHasIntfMetaData Interface, Legend, Public Methods


InxInvokeHasIntfMetaData.GetIntfMetaData Method

InxInvokeHasIntfMetaData.GetIntfMetaData Method
InxInvokeHasIntfMetaData Interface InxInvokeHasIntfMetaData Members nxivTypes Namespace InxInvokeHasIntfMetaData Methods Send Feedback
Syntax
Delphi
function GetIntfMetaData: PnxIntfMetaData;
Description

This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.

Group

InxInvokeHasIntfMetaData Methods

Links
InxInvokeHasIntfMetaData Interface, InxInvokeHasIntfMetaData Members, nxivTypes Namespace, InxInvokeHasIntfMetaData Methods


InxInvokeHasIntfMethEntry Interface

InxInvokeHasIntfMethEntry Interface
InxInvokeHasIntfMethEntry Methods InxInvokeHasIntfMethEntry Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeHasIntfMethEntrynxivTypes_InxInvokeHasIntfMethEntry
Syntax
Delphi
InxInvokeHasIntfMethEntry = interface(InxInvokeHasIntfMetaData);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeHasIntfMethEntry.

Group

Interfaces

Links
InxInvokeHasIntfMethEntry Methods, InxInvokeHasIntfMethEntry Members, nxivTypes, Interfaces


InxInvokeHasIntfMethEntry Members

InxInvokeHasIntfMethEntry Members
InxInvokeHasIntfMethEntry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeHasIntfMethEntry.

Interface

InxInvokeHasIntfMethEntry Interface

Public Methods
Name | Description
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
Links
InxInvokeHasIntfMethEntry Interface, Legend, Public Methods


InxInvokeHasIntfMethEntry Methods

InxInvokeHasIntfMethEntry Methods
InxInvokeHasIntfMethEntry Interface Legend Public Methods Send Feedback

The methods of the InxInvokeHasIntfMethEntry class are listed here.

Interface

InxInvokeHasIntfMethEntry Interface

Public Methods
Name | Description
GetIntfMethEntry | This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.
Links
InxInvokeHasIntfMethEntry Interface, Legend, Public Methods


InxInvokeHasIntfMethEntry.GetIntfMethEntry Method

InxInvokeHasIntfMethEntry.GetIntfMethEntry Method
InxInvokeHasIntfMethEntry Interface InxInvokeHasIntfMethEntry Members nxivTypes Namespace InxInvokeHasIntfMethEntry Methods Send Feedback
Syntax
Delphi
function GetIntfMethEntry: PnxIntfMethEntry;
Description

This is GetIntfMethEntry, a member of class InxInvokeHasIntfMethEntry.

Group

InxInvokeHasIntfMethEntry Methods

Links
InxInvokeHasIntfMethEntry Interface, InxInvokeHasIntfMethEntry Members, nxivTypes Namespace, InxInvokeHasIntfMethEntry Methods


InxInvokeInterceptor Interface

InxInvokeInterceptor Interface
InxInvokeInterceptor Methods InxInvokeInterceptor Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeInterceptor
Syntax
Delphi
InxInvokeInterceptor = interface(InxInterface);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeInterceptor.

Group

Interfaces

Links
InxInvokeInterceptor Methods, InxInvokeInterceptor Members, nxivTypes, Interfaces


InxInvokeInterceptor Members

InxInvokeInterceptor Members
InxInvokeInterceptor Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeInterceptor.

Interface

InxInvokeInterceptor Interface

Public Methods
Name | Description
InterceptInvoke | This is InterceptInvoke, a member of class InxInvokeInterceptor.
Links
InxInvokeInterceptor Interface, Legend, Public Methods


InxInvokeInterceptor Methods

InxInvokeInterceptor Methods
InxInvokeInterceptor Interface Legend Public Methods Send Feedback

The methods of the InxInvokeInterceptor class are listed here.

Interface

InxInvokeInterceptor Interface

Public Methods
Name | Description
InterceptInvoke | This is InterceptInvoke, a member of class InxInvokeInterceptor.
Links
InxInvokeInterceptor Interface, Legend, Public Methods


InxInvokeInterceptor.InterceptInvoke Method

InxInvokeInterceptor.InterceptInvoke Method
InxInvokeInterceptor Interface InxInvokeInterceptor Members nxivTypes Namespace InxInvokeInterceptor Methods Send Feedback
Syntax
Delphi
function InterceptInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray; const aCallFrame: InxCallFrame): HRESULT;
Description

This is InterceptInvoke, a member of class InxInvokeInterceptor.

Group

InxInvokeInterceptor Methods

Links
InxInvokeInterceptor Interface, InxInvokeInterceptor Members, nxivTypes Namespace, InxInvokeInterceptor Methods


InxInvokeProxy Interface

InxInvokeProxy Interface
InxInvokeProxy Methods InxInvokeProxy Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeProxynxivTypes_InxInvokeProxy
Syntax
Delphi
InxInvokeProxy = interface(InxInvokeHasIntfMetaData);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeProxy.

Group

Interfaces

Links
InxInvokeProxy Methods, InxInvokeProxy Members, nxivTypes, Interfaces


InxInvokeProxy Members

InxInvokeProxy Members
InxInvokeProxy Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeProxy.

Interface

InxInvokeProxy Interface

Public Methods
Name | Description
CopyCallFrame | This is CopyCallFrame, a member of class InxInvokeProxy.
CreateCallFrame | This is CreateCallFrame, a member of class InxInvokeProxy.
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
OpenCallFrame | This is OpenCallFrame, a member of class InxInvokeProxy.
Links
InxInvokeProxy Interface, Legend, Public Methods


InxInvokeProxy Methods

InxInvokeProxy Methods
InxInvokeProxy Interface Legend Public Methods Send Feedback

The methods of the InxInvokeProxy class are listed here.

Interface

InxInvokeProxy Interface

Public Methods
Name | Description
CopyCallFrame | This is CopyCallFrame, a member of class InxInvokeProxy.
CreateCallFrame | This is CreateCallFrame, a member of class InxInvokeProxy.
OpenCallFrame | This is OpenCallFrame, a member of class InxInvokeProxy.
Links
InxInvokeProxy Interface, Legend, Public Methods


InxInvokeProxy.CopyCallFrame Method

InxInvokeProxy.CopyCallFrame Method
InxInvokeProxy Interface InxInvokeProxy Members nxivTypes Namespace InxInvokeProxy Methods Send Feedback
Syntax
Delphi
function CopyCallFrame(const aMethod: PnxIntfMethEntry; const aSrcParams: PnxPointerArray; out aDstParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

This is CopyCallFrame, a member of class InxInvokeProxy.

Group

InxInvokeProxy Methods

Links
InxInvokeProxy Interface, InxInvokeProxy Members, nxivTypes Namespace, InxInvokeProxy Methods


InxInvokeProxy.CreateCallFrame Method

InxInvokeProxy.CreateCallFrame Method
InxInvokeProxy Interface InxInvokeProxy Members nxivTypes Namespace InxInvokeProxy Methods Send Feedback
Syntax
Delphi
function CreateCallFrame(aMethodNumber: Integer; out aMethod: PnxIntfMethEntry; out aParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

This is CreateCallFrame, a member of class InxInvokeProxy.

Group

InxInvokeProxy Methods

Links
InxInvokeProxy Interface, InxInvokeProxy Members, nxivTypes Namespace, InxInvokeProxy Methods


InxInvokeProxy.OpenCallFrame Method

InxInvokeProxy.OpenCallFrame Method
InxInvokeProxy Interface InxInvokeProxy Members nxivTypes Namespace InxInvokeProxy Methods Send Feedback
Syntax
Delphi
function OpenCallFrame(const aMethod: PnxIntfMethEntry; const aParams: PnxPointerArray; out aCallFrame: InxCallFrame): HRESULT;
Description

This is OpenCallFrame, a member of class InxInvokeProxy.

Group

InxInvokeProxy Methods

Links
InxInvokeProxy Interface, InxInvokeProxy Members, nxivTypes Namespace, InxInvokeProxy Methods


InxInvokeProxyFactory Interface

InxInvokeProxyFactory Interface
InxInvokeProxyFactory Methods InxInvokeProxyFactory Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeProxyFactorynxivTypes_InxInvokeProxyFactory
Syntax
Delphi
InxInvokeProxyFactory = interface(InxInvokeHasIntfMetaData);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeProxyFactory.

Group

Interfaces

Links
InxInvokeProxyFactory Methods, InxInvokeProxyFactory Members, nxivTypes, Interfaces


InxInvokeProxyFactory Members

InxInvokeProxyFactory Members
InxInvokeProxyFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeProxyFactory.

Interface

InxInvokeProxyFactory Interface

Public Methods
Name | Description
CreateInvokeProxy | This is CreateInvokeProxy, a member of class InxInvokeProxyFactory.
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
Links
InxInvokeProxyFactory Interface, Legend, Public Methods


InxInvokeProxyFactory Methods

InxInvokeProxyFactory Methods
InxInvokeProxyFactory Interface Legend Public Methods Send Feedback

The methods of the InxInvokeProxyFactory class are listed here.

Interface

InxInvokeProxyFactory Interface

Public Methods
Name | Description
CreateInvokeProxy | This is CreateInvokeProxy, a member of class InxInvokeProxyFactory.
Links
InxInvokeProxyFactory Interface, Legend, Public Methods


InxInvokeProxyFactory.CreateInvokeProxy Method

InxInvokeProxyFactory.CreateInvokeProxy Method
InxInvokeProxyFactory Interface InxInvokeProxyFactory Members nxivTypes Namespace InxInvokeProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeProxy(const aInterface: InxInterface; out aInvokeProxy: InxInvokeProxy): HRESULT;
Description

This is CreateInvokeProxy, a member of class InxInvokeProxyFactory.

Group

InxInvokeProxyFactory Methods

Links
InxInvokeProxyFactory Interface, InxInvokeProxyFactory Members, nxivTypes Namespace, InxInvokeProxyFactory Methods


InxInvokeRegistry Interface

InxInvokeRegistry Interface
InxInvokeRegistry Methods InxInvokeRegistry Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeRegistry
Syntax
Delphi
InxInvokeRegistry = interface(InxInterface);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeRegistry.

Group

Interfaces

Links
InxInvokeRegistry Methods, InxInvokeRegistry Members, nxivTypes, Interfaces


InxInvokeRegistry Members

InxInvokeRegistry Members
InxInvokeRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeRegistry.

Interface

InxInvokeRegistry Interface

Public Methods
Name | Description
CreateInvokeProxy | This is CreateInvokeProxy, a member of class InxInvokeRegistry.
CreateInvokeStub | This is CreateInvokeStub, a member of class InxInvokeRegistry.
CreateInvokeWrapper | This is CreateInvokeWrapper, a member of class InxInvokeRegistry.
Iterate | This is Iterate, a member of class InxInvokeRegistry.
RegisterInterface | This is RegisterInterface, a member of class InxInvokeRegistry.
RegisterProxyFactory | This is RegisterProxyFactory, a member of class InxInvokeRegistry.
RegisterStubFactory | This is RegisterStubFactory, a member of class InxInvokeRegistry.
Supports | This is Supports, a member of class InxInvokeRegistry.
Links
InxInvokeRegistry Interface, Legend, Public Methods


InxInvokeRegistry Methods

InxInvokeRegistry Methods
InxInvokeRegistry Interface Legend Public Methods Send Feedback

The methods of the InxInvokeRegistry class are listed here.

Interface

InxInvokeRegistry Interface

Public Methods
Name | Description
CreateInvokeProxy | This is CreateInvokeProxy, a member of class InxInvokeRegistry.
CreateInvokeStub | This is CreateInvokeStub, a member of class InxInvokeRegistry.
CreateInvokeWrapper | This is CreateInvokeWrapper, a member of class InxInvokeRegistry.
Iterate | This is Iterate, a member of class InxInvokeRegistry.
RegisterInterface | This is RegisterInterface, a member of class InxInvokeRegistry.
RegisterProxyFactory | This is RegisterProxyFactory, a member of class InxInvokeRegistry.
RegisterStubFactory | This is RegisterStubFactory, a member of class InxInvokeRegistry.
Supports | This is Supports, a member of class InxInvokeRegistry.
Links
InxInvokeRegistry Interface, Legend, Public Methods


InxInvokeRegistry.CreateInvokeProxy Method

InxInvokeRegistry.CreateInvokeProxy Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeProxy(const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInvokeProxy: InxInvokeProxy): HRESULT;
Description

This is CreateInvokeProxy, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.CreateInvokeStub Method

InxInvokeRegistry.CreateInvokeStub Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aInterfaceID: TnxGuid; const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

This is CreateInvokeStub, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.CreateInvokeWrapper Method

InxInvokeRegistry.CreateInvokeWrapper Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function CreateInvokeWrapper(const aInterface: InxInterface; const aInterceptor: InxInvokeInterceptor; out aWrappedIntf: InxInterface): HRESULT;
Description

This is CreateInvokeWrapper, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.Iterate Method

InxInvokeRegistry.Iterate Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function Iterate(const aInvokeRegistryIterator: InxInvokeRegistryIterator): HRESULT;
Description

This is Iterate, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.RegisterInterface Method

InxInvokeRegistry.RegisterInterface Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterInterface(aTypeInfo: PTypeInfo);
Description

This is RegisterInterface, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.RegisterProxyFactory Method

InxInvokeRegistry.RegisterProxyFactory Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterProxyFactory(const aFactory: InxInvokeProxyFactory);
Description

This is RegisterProxyFactory, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.RegisterStubFactory Method

InxInvokeRegistry.RegisterStubFactory Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
procedure RegisterStubFactory(const aFactory: InxInvokeStubFactory);
Description

This is RegisterStubFactory, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistry.Supports Method

InxInvokeRegistry.Supports Method
InxInvokeRegistry Interface InxInvokeRegistry Members nxivTypes Namespace InxInvokeRegistry Methods Send Feedback
Syntax
Delphi
function Supports(const aInterfaceID: TnxGuid): HRESULT;
Description

This is Supports, a member of class InxInvokeRegistry.

Group

InxInvokeRegistry Methods

Links
InxInvokeRegistry Interface, InxInvokeRegistry Members, nxivTypes Namespace, InxInvokeRegistry Methods


InxInvokeRegistryIterator Interface

InxInvokeRegistryIterator Interface
InxInvokeRegistryIterator Methods InxInvokeRegistryIterator Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeRegistryIterator
Syntax
Delphi
InxInvokeRegistryIterator = interface(InxInterface);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeRegistryIterator.

Group

Interfaces

Links
InxInvokeRegistryIterator Methods, InxInvokeRegistryIterator Members, nxivTypes, Interfaces


InxInvokeRegistryIterator Members

InxInvokeRegistryIterator Members
InxInvokeRegistryIterator Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeRegistryIterator.

Interface

InxInvokeRegistryIterator Interface

Public Methods
Name | Description
Callback | This is Callback, a member of class InxInvokeRegistryIterator.
Links
InxInvokeRegistryIterator Interface, Legend, Public Methods


InxInvokeRegistryIterator Methods

InxInvokeRegistryIterator Methods
InxInvokeRegistryIterator Interface Legend Public Methods Send Feedback

The methods of the InxInvokeRegistryIterator class are listed here.

Interface

InxInvokeRegistryIterator Interface

Public Methods
Name | Description
Callback | This is Callback, a member of class InxInvokeRegistryIterator.
Links
InxInvokeRegistryIterator Interface, Legend, Public Methods


InxInvokeRegistryIterator.Callback Method

InxInvokeRegistryIterator.Callback Method
InxInvokeRegistryIterator Interface InxInvokeRegistryIterator Members nxivTypes Namespace InxInvokeRegistryIterator Methods Send Feedback
Syntax
Delphi
function Callback(aInterface: PnxIntfMetaData): HRESULT;
Description

This is Callback, a member of class InxInvokeRegistryIterator.

Group

InxInvokeRegistryIterator Methods

Links
InxInvokeRegistryIterator Interface, InxInvokeRegistryIterator Members, nxivTypes Namespace, InxInvokeRegistryIterator Methods


InxInvokeStub Interface

InxInvokeStub Interface
nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeStubnxivTypes_InxInvokeStub
Syntax
Delphi
InxInvokeStub = interface(InxInvokeHasIntfMetaData);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeStub.

Group

Interfaces

Links
nxivTypes, Interfaces


InxInvokeStubFactory Interface

InxInvokeStubFactory Interface
InxInvokeStubFactory Methods InxInvokeStubFactory Members nxivTypes Interfaces Send Feedback
Class Hierarchy
nxivTypes_InxInvokeStubFactorynxivTypes_InxInvokeStubFactory
Syntax
Delphi
InxInvokeStubFactory = interface(InxInvokeHasIntfMetaData);
File

nxivTypes

Description

This is class nxivTypes.InxInvokeStubFactory.

Group

Interfaces

Links
InxInvokeStubFactory Methods, InxInvokeStubFactory Members, nxivTypes, Interfaces


InxInvokeStubFactory Members

InxInvokeStubFactory Members
InxInvokeStubFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeStubFactory.

Interface

InxInvokeStubFactory Interface

Public Methods
Name | Description
CreateInvokeStub | This is CreateInvokeStub, a member of class InxInvokeStubFactory.
GetIntfMetaData | This is GetIntfMetaData, a member of class InxInvokeHasIntfMetaData.
Links
InxInvokeStubFactory Interface, Legend, Public Methods


InxInvokeStubFactory Methods

InxInvokeStubFactory Methods
InxInvokeStubFactory Interface Legend Public Methods Send Feedback

The methods of the InxInvokeStubFactory class are listed here.

Interface

InxInvokeStubFactory Interface

Public Methods
Name | Description
CreateInvokeStub | This is CreateInvokeStub, a member of class InxInvokeStubFactory.
Links
InxInvokeStubFactory Interface, Legend, Public Methods


InxInvokeStubFactory.CreateInvokeStub Method

InxInvokeStubFactory.CreateInvokeStub Method
InxInvokeStubFactory Interface InxInvokeStubFactory Members nxivTypes Namespace InxInvokeStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInvokeStub(const aDispatcher: InxInvokeDispatcher; out aInvokeStub: InxInvokeStub): HRESULT;
Description

This is CreateInvokeStub, a member of class InxInvokeStubFactory.

Group

InxInvokeStubFactory Methods

Links
InxInvokeStubFactory Interface, InxInvokeStubFactory Members, nxivTypes Namespace, InxInvokeStubFactory Methods


Functions

Functions
Functions nxivTypes Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxInvokeRegistry | This is function nxivTypes.nxInvokeRegistry.
Namespace

nxivTypes Namespace

Links
Functions, nxivTypes Namespace, Legend


nxivTypes.nxInvokeRegistry Function

nxivTypes.nxInvokeRegistry Function
nxivTypes Functions Send Feedback
Syntax
Delphi
function nxInvokeRegistry: InxInvokeRegistry;
File

nxivTypes

Description

This is function nxivTypes.nxInvokeRegistry.

Group

Functions

Links
nxivTypes, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxivTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxCallConv | This is record nxivTypes.TnxCallConv.
TnxPassInRegister | This is record nxivTypes.TnxPassInRegister.
TnxResultIn | This is record nxivTypes.TnxResultIn.
Namespace

nxivTypes Namespace

Records
Name | Description
TnxIntfMetaData | This is record nxivTypes.TnxIntfMetaData.
TnxIntfMethEntry | This is record nxivTypes.TnxIntfMethEntry.
TnxIntfParamEntry | This is record nxivTypes.TnxIntfParamEntry.
Links
Enumerations, nxivTypes Namespace, Legend, Records


nxivTypes.TnxCallConv Enumeration

nxivTypes.TnxCallConv Enumeration
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCallConv = ( ccReg, ccCdecl, ccPascal, ccStdCall, ccSafeCall );
File

nxivTypes

Description

This is record nxivTypes.TnxCallConv.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


nxivTypes.TnxIntfMetaData Record

nxivTypes.TnxIntfMetaData Record
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIntfMetaData = record
  imdName: PShortString;
  imdUnitName: PShortString;
  imdHasRTTI: Boolean;
  imdMethods: TnxIntfMethEntryArray;
  imdInterfaceID: TGUID;
  imdInfo: PTypeInfo;
  imdData: PTypeData;
  imdAncInfo: PTypeInfo;
  imdNumAnc: Integer;
  imdRtti: TRttiInterfaceType;
  imdContainsSafeCall: Boolean;
  imdInvokeStubFactory: InxInvokeStubFactory;
  imdInvokeProxyFactory: InxInvokeProxyFactory;
end;
File

nxivTypes

Members
Members | Description
imdNumAnc: Integer; | Methods in base interfaces
Description

This is record nxivTypes.TnxIntfMetaData.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


nxivTypes.TnxIntfMethEntry Record

nxivTypes.TnxIntfMethEntry Record
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIntfMethEntry = packed record
  imeName: PShortString;
  imePos: Cardinal;
  imeParams: TnxIntfParamEntryArray;
  imeParamOffsets: TnxDynIntegerArray;
  imeResult: TnxIntfParamEntry;
  imeSizeOnStack: Cardinal;
  imeParamCount: Cardinal;
  imeByRefFlags: Cardinal;
  imeBufferSize: Cardinal;
  imeResultIn: TnxResultIn;
  imeHasRTTI: Boolean;
  imeCC: TnxCallConv;
  imeSelfParam: Byte;
  imeRtti: TRttiMethod;
end;
File

nxivTypes

Members
Members | Description
imePos: Cardinal; | Index (relative to whole interface VMT)
imeCC: TnxCallConv; | Calling convention
Description

This is record nxivTypes.TnxIntfMethEntry.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


nxivTypes.TnxIntfParamEntry Record

nxivTypes.TnxIntfParamEntry Record
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIntfParamEntry = record
  ipeName: PShortString;
  ipeTypeName: PShortString;
  ipeTypeUnitName: PShortString;
  ipeOrgPos: Smallint;
  ipePos: Smallint;
  ipeInfo: PTypeInfo;
  ipeData: PTypeData;
  ipeSize: Integer;
  ipeAlignedSize: Integer;
  ipeSizeOnStack: Integer;
  ipeBufferOffset: Integer;
  ipeFlags: TParamFlags;
  ipeByRef: Boolean;
  ipeCanPassInRegister: Boolean;
  ipePassInRegister: TnxPassInRegister;
end;
File

nxivTypes

Members
Members | Description
ipeTypeUnitName: PShortString; | can be nil
ipeOrgPos: Smallint; | 1 = Self, -2 = Result
ipePos: Smallint; | 1 = Self, -2 = Result
Description

This is record nxivTypes.TnxIntfParamEntry.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


nxivTypes.TnxPassInRegister Enumeration

nxivTypes.TnxPassInRegister Enumeration
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxPassInRegister = ( pirNone, irEAX, pirEDX, pirECX );
File

nxivTypes

Description

This is record nxivTypes.TnxPassInRegister.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


nxivTypes.TnxResultIn Enumeration

nxivTypes.TnxResultIn Enumeration
nxivTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxResultIn = ( riNone, riInParam, riEAX, riEAXHRESULT, riEAXEDX, riST0 );
File

nxivTypes

Description

This is record nxivTypes.TnxResultIn.

Group

Structs, Records, Enums

Links
nxivTypes, Structs, Records, Enums


Types

Types
nxivTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxivTypes Namespace

Types
Name | Description
PnxIntfMetaData | This is type nxivTypes.PnxIntfMetaData.
PnxIntfMethEntry | This is type nxivTypes.PnxIntfMethEntry.
PnxIntfParamEntry | This is type nxivTypes.PnxIntfParamEntry.
TnxIntfMethEntryArray | This is type nxivTypes.TnxIntfMethEntryArray.
TnxIntfParamEntryArray | This is type nxivTypes.TnxIntfParamEntryArray.
Links
nxivTypes Namespace, Types


nxivTypes.PnxIntfMetaData Type

nxivTypes.PnxIntfMetaData Type
nxivTypes Types Send Feedback
Syntax
Delphi
PnxIntfMetaData = ^TnxIntfMetaData;
File

nxivTypes

Description

This is type nxivTypes.PnxIntfMetaData.

Group

Types

Links
nxivTypes, Types


nxivTypes.PnxIntfMethEntry Type

nxivTypes.PnxIntfMethEntry Type
nxivTypes Types Send Feedback
Syntax
Delphi
PnxIntfMethEntry = ^TnxIntfMethEntry;
File

nxivTypes

Description

This is type nxivTypes.PnxIntfMethEntry.

Group

Types

Links
nxivTypes, Types


nxivTypes.PnxIntfParamEntry Type

nxivTypes.PnxIntfParamEntry Type
nxivTypes Types Send Feedback
Syntax
Delphi
PnxIntfParamEntry = ^TnxIntfParamEntry;
File

nxivTypes

Description

This is type nxivTypes.PnxIntfParamEntry.

Group

Types

Links
nxivTypes, Types


nxivTypes.TnxIntfMethEntryArray Type

nxivTypes.TnxIntfMethEntryArray Type
nxivTypes Types Send Feedback
Syntax
Delphi
TnxIntfMethEntryArray = array of TnxIntfMethEntry;
File

nxivTypes

Description

This is type nxivTypes.TnxIntfMethEntryArray.

Group

Types

Links
nxivTypes, Types


nxivTypes.TnxIntfParamEntryArray Type

nxivTypes.TnxIntfParamEntryArray Type
nxivTypes Types Send Feedback
Syntax
Delphi
TnxIntfParamEntryArray = array of TnxIntfParamEntry;
File

nxivTypes

Description

This is type nxivTypes.TnxIntfParamEntryArray.

Group

Types

Links
nxivTypes, Types


Variables

Variables
nxivTypes Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxivTypes Namespace

Variables
Name | Description
_InvokeRegistry | This is variable nxivTypes._InvokeRegistry.
Links
nxivTypes Namespace, Variables


nxivTypes._InvokeRegistry Variable

nxivTypes._InvokeRegistry Variable
nxivTypes Variables Send Feedback
Syntax
Delphi
_InvokeRegistry: InxInvokeRegistry;
File

nxivTypes

Description

This is variable nxivTypes._InvokeRegistry.

Group

Variables

Links
nxivTypes, Variables


Constants

Constants
Constants nxivTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsInterfaceNotRegistered | This is constant nxivTypes.rsInterfaceNotRegistered.
Namespace

nxivTypes Namespace

Links
Constants, nxivTypes Namespace


nxivTypes.rsInterfaceNotRegistered Constant

nxivTypes.rsInterfaceNotRegistered Constant
nxivTypes Constants Send Feedback
Syntax
Delphi
rsInterfaceNotRegistered = 'Interface not registered';
File

nxivTypes

Description

This is constant nxivTypes.rsInterfaceNotRegistered.

Group

Constants

Links
nxivTypes, Constants


nxlgEventBasedLog Namespace

nxlgEventBasedLog Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxlgEventBasedLog.

Classes
Name | Description
TnxEventBasedLog | This is class nxlgEventBasedLog.TnxEventBasedLog.
TnxSyncMainThread | This is class nxlgEventBasedLog.TnxSyncMainThread.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxOnPersistLogData | This is type nxlgEventBasedLog.TnxOnPersistLogData.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxlgEventBasedLog Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxEventBasedLog | This is class nxlgEventBasedLog.TnxEventBasedLog.
TnxSyncMainThread | This is class nxlgEventBasedLog.TnxSyncMainThread.
Namespace

nxlgEventBasedLog Namespace

Links
Classes, nxlgEventBasedLog Namespace, Legend


TnxEventBasedLog Class

TnxEventBasedLog Class
TnxEventBasedLog Fields TnxEventBasedLog Methods TnxEventBasedLog Properties TnxEventBasedLog Events TnxEventBasedLog Members nxlgEventBasedLog Classes Send Feedback
Class Hierarchy
nxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLognxlgEventBasedLog_TnxEventBasedLog
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxEventBasedLog = class(TnxCachedEventLog);
File

nxlgEventBasedLog

Description

This is class nxlgEventBasedLog.TnxEventBasedLog.

Group

Classes

Links
TnxEventBasedLog Fields, TnxEventBasedLog Methods, TnxEventBasedLog Properties, TnxEventBasedLog Events, TnxEventBasedLog Members, nxlgEventBasedLog, Classes


TnxEventBasedLog Members

TnxEventBasedLog Members
TnxEventBasedLog Class Legend Protected Fields Protected Methods Protected Properties Public Methods Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxEventBasedLog.

Class

TnxEventBasedLog Class

Protected Fields
Name | Description
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
eblOnPersistLogData | private
eblSyncMainThread | This is eblSyncMainThread, a member of class TnxEventBasedLog.
eblSyncWithMainThread | This is eblSyncWithMainThread, a member of class TnxEventBasedLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | TnxEventBasedLog
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
eblSetSyncWithMainThread |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
SynchPersistLogData |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxEventBasedLog.
OnPersistLogData | This is OnPersistLogData, a member of class TnxEventBasedLog.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxEventBasedLog.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxEventBasedLog.
SyncWithMainThread | This is SyncWithMainThread, a member of class TnxEventBasedLog.
Version | Version of the component.
Links
TnxEventBasedLog Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Published Events, Published Properties


TnxEventBasedLog.Create Constructor

TnxEventBasedLog.Create Constructor
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxEventBasedLog Class

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Class


TnxEventBasedLog.Destroy Destructor

TnxEventBasedLog.Destroy Destructor
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxEventBasedLog Class

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Class


TnxEventBasedLog Fields

TnxEventBasedLog Fields
TnxEventBasedLog Class Legend Protected Fields Send Feedback

The fields of the TnxEventBasedLog class are listed here.

Class

TnxEventBasedLog Class

Protected Fields
Name | Description
eblOnPersistLogData | private
eblSyncMainThread | This is eblSyncMainThread, a member of class TnxEventBasedLog.
eblSyncWithMainThread | This is eblSyncWithMainThread, a member of class TnxEventBasedLog.
Links
TnxEventBasedLog Class, Legend, Protected Fields


TnxEventBasedLog.eblOnPersistLogData Field

TnxEventBasedLog.eblOnPersistLogData Field
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Fields Send Feedback
Syntax
Delphi
eblOnPersistLogData: TnxOnPersistLogData;
Description

private

Group

TnxEventBasedLog Fields

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Fields


TnxEventBasedLog.eblSyncMainThread Field

TnxEventBasedLog.eblSyncMainThread Field
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Fields Send Feedback
Syntax
Delphi
eblSyncMainThread: TnxSyncMainThread;
Description

This is eblSyncMainThread, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Fields

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Fields


TnxEventBasedLog.eblSyncWithMainThread Field

TnxEventBasedLog.eblSyncWithMainThread Field
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Fields Send Feedback
Syntax
Delphi
eblSyncWithMainThread: Boolean;
Description

This is eblSyncWithMainThread, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Fields

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Fields


TnxEventBasedLog Methods

TnxEventBasedLog Methods
TnxEventBasedLog Class Legend Protected Methods Send Feedback

The methods of the TnxEventBasedLog class are listed here.

Class

TnxEventBasedLog Class

Protected Methods
Name | Description
clRawWrite | TnxEventBasedLog
eblSetSyncWithMainThread |
PersistLogData |
SynchPersistLogData |
Links
TnxEventBasedLog Class, Legend, Protected Methods


TnxEventBasedLog.clRawWrite Method

TnxEventBasedLog.clRawWrite Method
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); override;
Description

TnxEventBasedLog

Group

TnxEventBasedLog Methods

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Methods


TnxEventBasedLog.eblSetSyncWithMainThread Method

TnxEventBasedLog.eblSetSyncWithMainThread Method
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Methods Send Feedback
Syntax
Delphi
procedure eblSetSyncWithMainThread(const Value: Boolean);
Group

TnxEventBasedLog Methods

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Methods


TnxEventBasedLog.PersistLogData Method

TnxEventBasedLog.PersistLogData Method
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Methods Send Feedback
Syntax
Delphi
procedure PersistLogData(const LogData: InxLogData); override;
Group

TnxEventBasedLog Methods

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Methods


TnxEventBasedLog.SynchPersistLogData Method

TnxEventBasedLog.SynchPersistLogData Method
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Methods Send Feedback
Syntax
Delphi
procedure SynchPersistLogData(const LogData: InxLogData);
Group

TnxEventBasedLog Methods

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Methods


TnxEventBasedLog Properties

TnxEventBasedLog Properties
TnxEventBasedLog Class Legend Published Properties Send Feedback

The properties of the TnxEventBasedLog class are listed here.

Class

TnxEventBasedLog Class

Published Properties
Name | Description
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxEventBasedLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxEventBasedLog.
SyncWithMainThread | This is SyncWithMainThread, a member of class TnxEventBasedLog.
Links
TnxEventBasedLog Class, Legend, Published Properties


TnxEventBasedLog.Enabled Property

TnxEventBasedLog.Enabled Property
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxEventBasedLog Properties

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Properties


TnxEventBasedLog.EventDispatcher Property

TnxEventBasedLog.EventDispatcher Property
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Properties Send Feedback
Syntax
Delphi
property EventDispatcher: TnxBaseEventLogDispatcher;
Description

This is EventDispatcher, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Properties

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Properties


TnxEventBasedLog.PrioritiesToLog Property

TnxEventBasedLog.PrioritiesToLog Property
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Properties Send Feedback
Syntax
Delphi
property PrioritiesToLog: TnxLogPriorities;
Description

This is PrioritiesToLog, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Properties

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Properties


TnxEventBasedLog.SyncWithMainThread Property

TnxEventBasedLog.SyncWithMainThread Property
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Properties Send Feedback
Syntax
Delphi
property SyncWithMainThread: Boolean;
Description

This is SyncWithMainThread, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Properties

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Properties


TnxEventBasedLog Events

TnxEventBasedLog Events
TnxEventBasedLog Class Legend Published Events Send Feedback

The events of the TnxEventBasedLog class are listed here.

Class

TnxEventBasedLog Class

Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxEventBasedLog.
OnPersistLogData | This is OnPersistLogData, a member of class TnxEventBasedLog.
Links
TnxEventBasedLog Class, Legend, Published Events


TnxEventBasedLog.OnLogDataFilter Event

TnxEventBasedLog.OnLogDataFilter Event
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Events Send Feedback
Syntax
Delphi
property OnLogDataFilter: TnxLogDataFilterEvent;
Description

This is OnLogDataFilter, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Events

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Events


TnxEventBasedLog.OnPersistLogData Event

TnxEventBasedLog.OnPersistLogData Event
TnxEventBasedLog Class TnxEventBasedLog Members nxlgEventBasedLog Namespace TnxEventBasedLog Events Send Feedback
Syntax
Delphi
property OnPersistLogData: TnxOnPersistLogData;
Description

This is OnPersistLogData, a member of class TnxEventBasedLog.

Group

TnxEventBasedLog Events

Links
TnxEventBasedLog Class, TnxEventBasedLog Members, nxlgEventBasedLog Namespace, TnxEventBasedLog Events


TnxSyncMainThread Class

TnxSyncMainThread Class
TnxSyncMainThread Methods TnxSyncMainThread Members nxlgEventBasedLog Classes Send Feedback
Class Hierarchy
nxlgEventBasedLog_TnxSyncMainThreadnxlgEventBasedLog_TnxSyncMainThreadnxlgEventBasedLog_TnxSyncMainThreadnxlgEventBasedLog_TnxSyncMainThreadnxlgEventBasedLog_TnxSyncMainThreadnxlgEventBasedLog_TnxSyncMainThread
Syntax
Delphi
TnxSyncMainThread = class(TnxTimerThread);
File

nxlgEventBasedLog

Description

This is class nxlgEventBasedLog.TnxSyncMainThread.

Group

Classes

Links
TnxSyncMainThread Methods, TnxSyncMainThread Members, nxlgEventBasedLog, Classes


TnxSyncMainThread Members

TnxSyncMainThread Members
TnxSyncMainThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxSyncMainThread.

Class

TnxSyncMainThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
DoTimer |
EmptyQueue |
Execute |
InnerExecute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxSyncMainThread
Destroy |
FreeInstance |
NewInstance |
PushLogData |
WaitForEx |
Links
TnxSyncMainThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxSyncMainThread.Create Constructor

TnxSyncMainThread.Create Constructor
TnxSyncMainThread Class TnxSyncMainThread Members nxlgEventBasedLog Namespace TnxSyncMainThread Class Send Feedback
Syntax
Delphi
constructor Create(aPersistLogData: TnxOnPersistLogData; const aInterval: Integer; const aThreadPriority: TThreadPriority);
Description

TnxSyncMainThread

Class

TnxSyncMainThread Class

Links
TnxSyncMainThread Class, TnxSyncMainThread Members, nxlgEventBasedLog Namespace, TnxSyncMainThread Class


TnxSyncMainThread.Destroy Destructor

TnxSyncMainThread.Destroy Destructor
TnxSyncMainThread Class TnxSyncMainThread Members nxlgEventBasedLog Namespace TnxSyncMainThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSyncMainThread Class

Links
TnxSyncMainThread Class, TnxSyncMainThread Members, nxlgEventBasedLog Namespace, TnxSyncMainThread Class


TnxSyncMainThread Methods

TnxSyncMainThread Methods
TnxSyncMainThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSyncMainThread class are listed here.

Class

TnxSyncMainThread Class

Protected Methods
Name | Description
DoTimer |
EmptyQueue |
Public Methods
Name | Description
PushLogData |
Links
TnxSyncMainThread Class, Legend, Protected Methods, Public Methods


TnxSyncMainThread.DoTimer Method

TnxSyncMainThread.DoTimer Method
TnxSyncMainThread Class TnxSyncMainThread Members nxlgEventBasedLog Namespace TnxSyncMainThread Methods Send Feedback
Syntax
Delphi
procedure DoTimer; override;
Group

TnxSyncMainThread Methods

Links
TnxSyncMainThread Class, TnxSyncMainThread Members, nxlgEventBasedLog Namespace, TnxSyncMainThread Methods


TnxSyncMainThread.EmptyQueue Method

TnxSyncMainThread.EmptyQueue Method
TnxSyncMainThread Class TnxSyncMainThread Members nxlgEventBasedLog Namespace TnxSyncMainThread Methods Send Feedback
Syntax
Delphi
procedure EmptyQueue;
Group

TnxSyncMainThread Methods

Links
TnxSyncMainThread Class, TnxSyncMainThread Members, nxlgEventBasedLog Namespace, TnxSyncMainThread Methods


TnxSyncMainThread.PushLogData Method

TnxSyncMainThread.PushLogData Method
TnxSyncMainThread Class TnxSyncMainThread Members nxlgEventBasedLog Namespace TnxSyncMainThread Methods Send Feedback
Syntax
Delphi
procedure PushLogData(LogData: InxLogData);
Group

TnxSyncMainThread Methods

Links
TnxSyncMainThread Class, TnxSyncMainThread Members, nxlgEventBasedLog Namespace, TnxSyncMainThread Methods


Types

Types
nxlgEventBasedLog Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxlgEventBasedLog Namespace

Types
Name | Description
TnxOnPersistLogData | This is type nxlgEventBasedLog.TnxOnPersistLogData.
Links
nxlgEventBasedLog Namespace, Types


nxlgEventBasedLog.TnxOnPersistLogData Type

nxlgEventBasedLog.TnxOnPersistLogData Type
nxlgEventBasedLog Types Send Feedback
Syntax
Delphi
TnxOnPersistLogData = procedure (const LogData: InxLogData) of object;
File

nxlgEventBasedLog

Description

This is type nxlgEventBasedLog.TnxOnPersistLogData.

Group

Types

Links
nxlgEventBasedLog, Types


nxlgEventLog Namespace

nxlgEventLog Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxlgEventLog.

Classes
Name | Description
TnxBaseEventLogDispatcher | This is class nxlgEventLog.TnxBaseEventLogDispatcher.
TnxBaseLogDataFormatter | LogData Formatters
TnxBaseLogDataHandler | This is class nxlgEventLog.TnxBaseLogDataHandler.
TnxCachedEventLog | This is class nxlgEventLog.TnxCachedEventLog.
TnxCachedLogDataHandler | This is class nxlgEventLog.TnxCachedLogDataHandler.
TnxConsoleEventLog | This is class nxlgEventLog.TnxConsoleEventLog.
TnxCustomLog | This is class nxlgEventLog.TnxCustomLog.
TnxDirectLogDataHandler | This is class nxlgEventLog.TnxDirectLogDataHandler.
TnxEventLog | Component to write log entries into a text file. Entries are stamped with time and thread ID.
TnxLogData | This is class nxlgEventLog.TnxLogData.
TnxLogDataQueue | This is class nxlgEventLog.TnxLogDataQueue.
TnxLogDispatchThread | This is class nxlgEventLog.TnxLogDispatchThread.
TnxLogQueueItem | This is class nxlgEventLog.TnxLogQueueItem.
TnxPatternedLogDataFormatter | This is class nxlgEventLog.TnxPatternedLogDataFormatter.
TnxStreamEventLog | This is class nxlgEventLog.TnxStreamEventLog.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxLogDataFilterEvent | This is type nxlgEventLog.TnxLogDataFilterEvent.
TnxLogDataFormatterClass | This is type nxlgEventLog.TnxLogDataFormatterClass.
TnxLogDataHandlerClass | This is type nxlgEventLog.TnxLogDataHandlerClass.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxlgEventLog Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBaseEventLogDispatcher | This is class nxlgEventLog.TnxBaseEventLogDispatcher.
TnxBaseLogDataFormatter | LogData Formatters
TnxBaseLogDataHandler | This is class nxlgEventLog.TnxBaseLogDataHandler.
TnxCachedEventLog | This is class nxlgEventLog.TnxCachedEventLog.
TnxCachedLogDataHandler | This is class nxlgEventLog.TnxCachedLogDataHandler.
TnxConsoleEventLog | This is class nxlgEventLog.TnxConsoleEventLog.
TnxCustomLog | This is class nxlgEventLog.TnxCustomLog.
TnxDirectLogDataHandler | This is class nxlgEventLog.TnxDirectLogDataHandler.
TnxEventLog | Component to write log entries into a text file. Entries are stamped with time and thread ID.
TnxLogData | This is class nxlgEventLog.TnxLogData.
TnxLogDataQueue | This is class nxlgEventLog.TnxLogDataQueue.
TnxLogDispatchThread | This is class nxlgEventLog.TnxLogDispatchThread.
TnxLogQueueItem | This is class nxlgEventLog.TnxLogQueueItem.
TnxPatternedLogDataFormatter | This is class nxlgEventLog.TnxPatternedLogDataFormatter.
TnxStreamEventLog | This is class nxlgEventLog.TnxStreamEventLog.
Namespace

nxlgEventLog Namespace

Links
Classes, nxlgEventLog Namespace, Legend


TnxBaseEventLogDispatcher Class

TnxBaseEventLogDispatcher Class
TnxBaseEventLogDispatcher Fields TnxBaseEventLogDispatcher Methods TnxBaseEventLogDispatcher Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatchernxlgEventLog_TnxBaseEventLogDispatcher
Syntax
Delphi
TnxBaseEventLogDispatcher = class(TnxCachedEventLog);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxBaseEventLogDispatcher.

Group

Classes

Links
TnxBaseEventLogDispatcher Fields, TnxBaseEventLogDispatcher Methods, TnxBaseEventLogDispatcher Members, nxlgEventLog, Classes


TnxBaseEventLogDispatcher Members

TnxBaseEventLogDispatcher Members
TnxBaseEventLogDispatcher Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseEventLogDispatcher.

Class

TnxBaseEventLogDispatcher Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Protected Fields
Name | Description
beldLoggers | This is beldLoggers, a member of class TnxBaseEventLogDispatcher.
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | This is clRawWrite, a member of class TnxCustomLog.
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
AddLogger | TnxBaseEventLogDispatcher
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
RemoveLogger |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxBaseEventLogDispatcher Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxBaseEventLogDispatcher.Create Constructor

TnxBaseEventLogDispatcher.Create Constructor
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxBaseEventLogDispatcher Class

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Class


TnxBaseEventLogDispatcher.Destroy Destructor

TnxBaseEventLogDispatcher.Destroy Destructor
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseEventLogDispatcher Class

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Class


TnxBaseEventLogDispatcher Fields

TnxBaseEventLogDispatcher Fields
TnxBaseEventLogDispatcher Class Legend Protected Fields Send Feedback

The fields of the TnxBaseEventLogDispatcher class are listed here.

Class

TnxBaseEventLogDispatcher Class

Protected Fields
Name | Description
beldLoggers | This is beldLoggers, a member of class TnxBaseEventLogDispatcher.
Links
TnxBaseEventLogDispatcher Class, Legend, Protected Fields


TnxBaseEventLogDispatcher.beldLoggers Field

TnxBaseEventLogDispatcher.beldLoggers Field
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Fields Send Feedback
Syntax
Delphi
beldLoggers: TnxListPadlock;
Description

This is beldLoggers, a member of class TnxBaseEventLogDispatcher.

Group

TnxBaseEventLogDispatcher Fields

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Fields


TnxBaseEventLogDispatcher Methods

TnxBaseEventLogDispatcher Methods
TnxBaseEventLogDispatcher Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseEventLogDispatcher class are listed here.

Class

TnxBaseEventLogDispatcher Class

Protected Methods
Name | Description
nxcNotification |
Public Methods
Name | Description
AddLogger | TnxBaseEventLogDispatcher
RemoveLogger |
Links
TnxBaseEventLogDispatcher Class, Legend, Protected Methods, Public Methods


TnxBaseEventLogDispatcher.AddLogger Method

TnxBaseEventLogDispatcher.AddLogger Method
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure AddLogger(aLogger: TnxCustomLog);
Description

TnxBaseEventLogDispatcher

Group

TnxBaseEventLogDispatcher Methods

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Methods


TnxBaseEventLogDispatcher.nxcNotification Method

TnxBaseEventLogDispatcher.nxcNotification Method
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBaseEventLogDispatcher Methods

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Methods


TnxBaseEventLogDispatcher.RemoveLogger Method

TnxBaseEventLogDispatcher.RemoveLogger Method
TnxBaseEventLogDispatcher Class TnxBaseEventLogDispatcher Members nxlgEventLog Namespace TnxBaseEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure RemoveLogger(aLogger: TnxCustomLog);
Group

TnxBaseEventLogDispatcher Methods

Links
TnxBaseEventLogDispatcher Class, TnxBaseEventLogDispatcher Members, nxlgEventLog Namespace, TnxBaseEventLogDispatcher Methods


TnxBaseLogDataFormatter Class

TnxBaseLogDataFormatter Class
TnxBaseLogDataFormatter Fields TnxBaseLogDataFormatter Methods TnxBaseLogDataFormatter Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxBaseLogDataFormatternxlgEventLog_TnxBaseLogDataFormatter
Syntax
Delphi
TnxBaseLogDataFormatter = class(TnxObject);
File

nxlgEventLog

Description

LogData Formatters

Group

Classes

Links
TnxBaseLogDataFormatter Fields, TnxBaseLogDataFormatter Methods, TnxBaseLogDataFormatter Members, nxlgEventLog, Classes


TnxBaseLogDataFormatter Members

TnxBaseLogDataFormatter Members
TnxBaseLogDataFormatter Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseLogDataFormatter.

Class

TnxBaseLogDataFormatter Class

Protected Fields
Name | Description
bldfPrefix | This is bldfPrefix, a member of class TnxBaseLogDataFormatter.
bldfSuffix | This is bldfSuffix, a member of class TnxBaseLogDataFormatter.
Protected Methods
Name | Description
GetDateFormatString | make this non-abstract, return standard format
GetFormatString | This is GetFormatString, a member of class TnxBaseLogDataFormatter.
Public Methods
Name | Description
Create | TnxBaseLogDataFormatter
FormatDataChanged |
FormatLogData |
FreeInstance |
NewInstance | TnxObject
PriorityToStr |
Links
TnxBaseLogDataFormatter Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseLogDataFormatter.Create Constructor

TnxBaseLogDataFormatter.Create Constructor
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Class Send Feedback
Syntax
Delphi
constructor Create(const aPrefix: string; const aSuffix: string); virtual;
Description

TnxBaseLogDataFormatter

Class

TnxBaseLogDataFormatter Class

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Class


TnxBaseLogDataFormatter Fields

TnxBaseLogDataFormatter Fields
TnxBaseLogDataFormatter Class Legend Protected Fields Send Feedback

The fields of the TnxBaseLogDataFormatter class are listed here.

Class

TnxBaseLogDataFormatter Class

Protected Fields
Name | Description
bldfPrefix | This is bldfPrefix, a member of class TnxBaseLogDataFormatter.
bldfSuffix | This is bldfSuffix, a member of class TnxBaseLogDataFormatter.
Links
TnxBaseLogDataFormatter Class, Legend, Protected Fields


TnxBaseLogDataFormatter.bldfPrefix Field

TnxBaseLogDataFormatter.bldfPrefix Field
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Fields Send Feedback
Syntax
Delphi
bldfPrefix: string;
Description

This is bldfPrefix, a member of class TnxBaseLogDataFormatter.

Group

TnxBaseLogDataFormatter Fields

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Fields


TnxBaseLogDataFormatter.bldfSuffix Field

TnxBaseLogDataFormatter.bldfSuffix Field
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Fields Send Feedback
Syntax
Delphi
bldfSuffix: string;
Description

This is bldfSuffix, a member of class TnxBaseLogDataFormatter.

Group

TnxBaseLogDataFormatter Fields

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Fields


TnxBaseLogDataFormatter Methods

TnxBaseLogDataFormatter Methods
TnxBaseLogDataFormatter Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseLogDataFormatter class are listed here.

Class

TnxBaseLogDataFormatter Class

Protected Methods
Name | Description
GetDateFormatString | make this non-abstract, return standard format
GetFormatString | This is GetFormatString, a member of class TnxBaseLogDataFormatter.
Public Methods
Name | Description
FormatDataChanged |
FormatLogData |
PriorityToStr |
Links
TnxBaseLogDataFormatter Class, Legend, Protected Methods, Public Methods


TnxBaseLogDataFormatter.FormatDataChanged Method

TnxBaseLogDataFormatter.FormatDataChanged Method
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Methods Send Feedback
Syntax
Delphi
procedure FormatDataChanged(const aFormatString: string; const aDateFormatString: string); virtual;
Group

TnxBaseLogDataFormatter Methods

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Methods


TnxBaseLogDataFormatter.FormatLogData Method

TnxBaseLogDataFormatter.FormatLogData Method
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Methods Send Feedback
Syntax
Delphi
function FormatLogData(const aLogData: InxLogData): string; virtual;
Group

TnxBaseLogDataFormatter Methods

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Methods


TnxBaseLogDataFormatter.GetDateFormatString Method

TnxBaseLogDataFormatter.GetDateFormatString Method
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Methods Send Feedback
Syntax
Delphi
function GetDateFormatString: string; virtual; abstract;
Description

make this non-abstract, return standard format

Group

TnxBaseLogDataFormatter Methods

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Methods


TnxBaseLogDataFormatter.GetFormatString Method

TnxBaseLogDataFormatter.GetFormatString Method
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Methods Send Feedback
Syntax
Delphi
function GetFormatString: string; virtual; abstract;
Description

This is GetFormatString, a member of class TnxBaseLogDataFormatter.

Group

TnxBaseLogDataFormatter Methods

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Methods


TnxBaseLogDataFormatter.PriorityToStr Method

TnxBaseLogDataFormatter.PriorityToStr Method
TnxBaseLogDataFormatter Class TnxBaseLogDataFormatter Members nxlgEventLog Namespace TnxBaseLogDataFormatter Methods Send Feedback
Syntax
Delphi
class function PriorityToStr(const aPriority: TnxLogPriority): string;
Group

TnxBaseLogDataFormatter Methods

Links
TnxBaseLogDataFormatter Class, TnxBaseLogDataFormatter Members, nxlgEventLog Namespace, TnxBaseLogDataFormatter Methods


TnxBaseLogDataHandler Class

TnxBaseLogDataHandler Class
TnxBaseLogDataHandler Fields TnxBaseLogDataHandler Methods TnxBaseLogDataHandler Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxBaseLogDataHandlernxlgEventLog_TnxBaseLogDataHandler
Syntax
Delphi
TnxBaseLogDataHandler = class(TnxObject);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxBaseLogDataHandler.

Group

Classes

Links
TnxBaseLogDataHandler Fields, TnxBaseLogDataHandler Methods, TnxBaseLogDataHandler Members, nxlgEventLog, Classes


TnxBaseLogDataHandler Members

TnxBaseLogDataHandler Members
TnxBaseLogDataHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseLogDataHandler.

Class

TnxBaseLogDataHandler Class

Protected Fields
Name | Description
bldhLogger | This is bldhLogger, a member of class TnxBaseLogDataHandler.
Protected Methods
Name | Description
LoggerPersistLogData |
Public Methods
Name | Description
Create | TnxBaseLogDataHandler
DoLogData | This is DoLogData, a member of class TnxBaseLogDataHandler.
Flush |
FreeInstance |
NewInstance | TnxObject
Links
TnxBaseLogDataHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseLogDataHandler.Create Constructor

TnxBaseLogDataHandler.Create Constructor
TnxBaseLogDataHandler Class TnxBaseLogDataHandler Members nxlgEventLog Namespace TnxBaseLogDataHandler Class Send Feedback
Syntax
Delphi
constructor Create(const aLogger: TnxCustomLog); virtual;
Description

TnxBaseLogDataHandler

Class

TnxBaseLogDataHandler Class

Links
TnxBaseLogDataHandler Class, TnxBaseLogDataHandler Members, nxlgEventLog Namespace, TnxBaseLogDataHandler Class


TnxBaseLogDataHandler Fields

TnxBaseLogDataHandler Fields
TnxBaseLogDataHandler Class Legend Protected Fields Send Feedback

The fields of the TnxBaseLogDataHandler class are listed here.

Class

TnxBaseLogDataHandler Class

Protected Fields
Name | Description
bldhLogger | This is bldhLogger, a member of class TnxBaseLogDataHandler.
Links
TnxBaseLogDataHandler Class, Legend, Protected Fields


TnxBaseLogDataHandler.bldhLogger Field

TnxBaseLogDataHandler.bldhLogger Field
TnxBaseLogDataHandler Class TnxBaseLogDataHandler Members nxlgEventLog Namespace TnxBaseLogDataHandler Fields Send Feedback
Syntax
Delphi
bldhLogger: TnxCustomLog;
Description

This is bldhLogger, a member of class TnxBaseLogDataHandler.

Group

TnxBaseLogDataHandler Fields

Links
TnxBaseLogDataHandler Class, TnxBaseLogDataHandler Members, nxlgEventLog Namespace, TnxBaseLogDataHandler Fields


TnxBaseLogDataHandler Methods

TnxBaseLogDataHandler Methods
TnxBaseLogDataHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseLogDataHandler class are listed here.

Class

TnxBaseLogDataHandler Class

Protected Methods
Name | Description
LoggerPersistLogData |
Public Methods
Name | Description
DoLogData | This is DoLogData, a member of class TnxBaseLogDataHandler.
Flush |
Links
TnxBaseLogDataHandler Class, Legend, Protected Methods, Public Methods


TnxBaseLogDataHandler.DoLogData Method

TnxBaseLogDataHandler.DoLogData Method
TnxBaseLogDataHandler Class TnxBaseLogDataHandler Members nxlgEventLog Namespace TnxBaseLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure DoLogData(const aLogData: InxLogData); virtual; abstract;
Description

This is DoLogData, a member of class TnxBaseLogDataHandler.

Group

TnxBaseLogDataHandler Methods

Links
TnxBaseLogDataHandler Class, TnxBaseLogDataHandler Members, nxlgEventLog Namespace, TnxBaseLogDataHandler Methods


TnxBaseLogDataHandler.Flush Method

TnxBaseLogDataHandler.Flush Method
TnxBaseLogDataHandler Class TnxBaseLogDataHandler Members nxlgEventLog Namespace TnxBaseLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure Flush; virtual;
Group

TnxBaseLogDataHandler Methods

Links
TnxBaseLogDataHandler Class, TnxBaseLogDataHandler Members, nxlgEventLog Namespace, TnxBaseLogDataHandler Methods


TnxBaseLogDataHandler.LoggerPersistLogData Method

TnxBaseLogDataHandler.LoggerPersistLogData Method
TnxBaseLogDataHandler Class TnxBaseLogDataHandler Members nxlgEventLog Namespace TnxBaseLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure LoggerPersistLogData(const aLogData: InxLogData);
Group

TnxBaseLogDataHandler Methods

Links
TnxBaseLogDataHandler Class, TnxBaseLogDataHandler Members, nxlgEventLog Namespace, TnxBaseLogDataHandler Methods


TnxCachedEventLog Class

TnxCachedEventLog Class
TnxCachedEventLog Fields TnxCachedEventLog Methods TnxCachedEventLog Properties TnxCachedEventLog Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLognxlgEventLog_TnxCachedEventLog
Syntax
Delphi
TnxCachedEventLog = class(TnxCustomLog);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxCachedEventLog.

Group

Classes

Links
TnxCachedEventLog Fields, TnxCachedEventLog Methods, TnxCachedEventLog Properties, TnxCachedEventLog Members, nxlgEventLog, Classes


TnxCachedEventLog Members

TnxCachedEventLog Members
TnxCachedEventLog Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxCachedEventLog.

Class

TnxCachedEventLog Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Protected Fields
Name | Description
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | This is clRawWrite, a member of class TnxCustomLog.
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create | TnxCachedEventLog
Destroy |
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxCachedEventLog Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxCachedEventLog.Create Constructor

TnxCachedEventLog.Create Constructor
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

TnxCachedEventLog

Class

TnxCachedEventLog Class

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Class


TnxCachedEventLog Fields

TnxCachedEventLog Fields
TnxCachedEventLog Class Legend Protected Fields Send Feedback

The fields of the TnxCachedEventLog class are listed here.

Class

TnxCachedEventLog Class

Protected Fields
Name | Description
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
Links
TnxCachedEventLog Class, Legend, Protected Fields


TnxCachedEventLog.celCache Field

TnxCachedEventLog.celCache Field
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Fields Send Feedback
Syntax
Delphi
celCache: Boolean;
Description

private

Group

TnxCachedEventLog Fields

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Fields


TnxCachedEventLog.celDiscardOnDestruction Field

TnxCachedEventLog.celDiscardOnDestruction Field
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Fields Send Feedback
Syntax
Delphi
celDiscardOnDestruction: Boolean;
Description

This is celDiscardOnDestruction, a member of class TnxCachedEventLog.

Group

TnxCachedEventLog Fields

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Fields


TnxCachedEventLog Methods

TnxCachedEventLog Methods
TnxCachedEventLog Class Legend Protected Methods Send Feedback

The methods of the TnxCachedEventLog class are listed here.

Class

TnxCachedEventLog Class

Protected Methods
Name | Description
celSetCache |
clGetLogDataHandler |
Links
TnxCachedEventLog Class, Legend, Protected Methods


TnxCachedEventLog.celSetCache Method

TnxCachedEventLog.celSetCache Method
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Methods Send Feedback
Syntax
Delphi
procedure celSetCache(const Value: Boolean);
Group

TnxCachedEventLog Methods

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Methods


TnxCachedEventLog.clGetLogDataHandler Method

TnxCachedEventLog.clGetLogDataHandler Method
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Methods Send Feedback
Syntax
Delphi
function clGetLogDataHandler: TnxBaseLogDataHandler; override;
Group

TnxCachedEventLog Methods

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Methods


TnxCachedEventLog Properties

TnxCachedEventLog Properties
TnxCachedEventLog Class Legend Protected Properties Published Properties Send Feedback

The properties of the TnxCachedEventLog class are listed here.

Class

TnxCachedEventLog Class

Protected Properties
Name | Description
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
Links
TnxCachedEventLog Class, Legend, Protected Properties, Published Properties


TnxCachedEventLog.CacheEnabled Property

TnxCachedEventLog.CacheEnabled Property
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Properties Send Feedback
Syntax
Delphi
property CacheEnabled: Boolean;
Description

This is CacheEnabled, a member of class TnxCachedEventLog.

Group

TnxCachedEventLog Properties

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Properties


TnxCachedEventLog.DiscardOnDestruction Property

TnxCachedEventLog.DiscardOnDestruction Property
TnxCachedEventLog Class TnxCachedEventLog Members nxlgEventLog Namespace TnxCachedEventLog Properties Send Feedback
Syntax
Delphi
property DiscardOnDestruction: Boolean;
Description

This is DiscardOnDestruction, a member of class TnxCachedEventLog.

Group

TnxCachedEventLog Properties

Links
TnxCachedEventLog Class, TnxCachedEventLog Members, nxlgEventLog Namespace, TnxCachedEventLog Properties


TnxCachedLogDataHandler Class

TnxCachedLogDataHandler Class
TnxCachedLogDataHandler Methods TnxCachedLogDataHandler Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxCachedLogDataHandlernxlgEventLog_TnxCachedLogDataHandlernxlgEventLog_TnxCachedLogDataHandler
Syntax
Delphi
TnxCachedLogDataHandler = class(TnxBaseLogDataHandler);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxCachedLogDataHandler.

Group

Classes

Links
TnxCachedLogDataHandler Methods, TnxCachedLogDataHandler Members, nxlgEventLog, Classes


TnxCachedLogDataHandler Members

TnxCachedLogDataHandler Members
TnxCachedLogDataHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCachedLogDataHandler.

Class

TnxCachedLogDataHandler Class

Protected Fields
Name | Description
bldhLogger | This is bldhLogger, a member of class TnxBaseLogDataHandler.
Protected Methods
Name | Description
LoggerPersistLogData |
Public Methods
Name | Description
Create | TnxCachedLogDataHandler
Destroy |
DoLogData |
Flush |
FreeInstance |
NewInstance | TnxObject
Links
TnxCachedLogDataHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCachedLogDataHandler.Create Constructor

TnxCachedLogDataHandler.Create Constructor
TnxCachedLogDataHandler Class TnxCachedLogDataHandler Members nxlgEventLog Namespace TnxCachedLogDataHandler Class Send Feedback
Syntax
Delphi
constructor Create(const aLogger: TnxCustomLog); override;
Description

TnxCachedLogDataHandler

Class

TnxCachedLogDataHandler Class

Links
TnxCachedLogDataHandler Class, TnxCachedLogDataHandler Members, nxlgEventLog Namespace, TnxCachedLogDataHandler Class


TnxCachedLogDataHandler.Destroy Destructor

TnxCachedLogDataHandler.Destroy Destructor
TnxCachedLogDataHandler Class TnxCachedLogDataHandler Members nxlgEventLog Namespace TnxCachedLogDataHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxCachedLogDataHandler Class

Links
TnxCachedLogDataHandler Class, TnxCachedLogDataHandler Members, nxlgEventLog Namespace, TnxCachedLogDataHandler Class


TnxCachedLogDataHandler Methods

TnxCachedLogDataHandler Methods
TnxCachedLogDataHandler Class Legend Public Methods Send Feedback

The methods of the TnxCachedLogDataHandler class are listed here.

Class

TnxCachedLogDataHandler Class

Public Methods
Name | Description
DoLogData |
Flush |
Links
TnxCachedLogDataHandler Class, Legend, Public Methods


TnxCachedLogDataHandler.DoLogData Method

TnxCachedLogDataHandler.DoLogData Method
TnxCachedLogDataHandler Class TnxCachedLogDataHandler Members nxlgEventLog Namespace TnxCachedLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure DoLogData(const aLogData: InxLogData); override;
Group

TnxCachedLogDataHandler Methods

Links
TnxCachedLogDataHandler Class, TnxCachedLogDataHandler Members, nxlgEventLog Namespace, TnxCachedLogDataHandler Methods


TnxCachedLogDataHandler.Flush Method

TnxCachedLogDataHandler.Flush Method
TnxCachedLogDataHandler Class TnxCachedLogDataHandler Members nxlgEventLog Namespace TnxCachedLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure Flush; override;
Group

TnxCachedLogDataHandler Methods

Links
TnxCachedLogDataHandler Class, TnxCachedLogDataHandler Members, nxlgEventLog Namespace, TnxCachedLogDataHandler Methods


TnxConsoleEventLog Class

TnxConsoleEventLog Class
TnxConsoleEventLog Methods TnxConsoleEventLog Properties TnxConsoleEventLog Events TnxConsoleEventLog Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLognxlgEventLog_TnxConsoleEventLog
Syntax
Delphi
TnxConsoleEventLog = class(TnxCustomLog);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxConsoleEventLog.

Group

Classes

Links
TnxConsoleEventLog Methods, TnxConsoleEventLog Properties, TnxConsoleEventLog Events, TnxConsoleEventLog Members, nxlgEventLog, Classes


TnxConsoleEventLog Members

TnxConsoleEventLog Members
TnxConsoleEventLog Class Legend Protected Fields Protected Methods Public Methods Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxConsoleEventLog.

Class

TnxConsoleEventLog Class

Protected Fields
Name | Description
blEnabled | private
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
clGetLogDataFormatter |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | TnxConsoleEventLog
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Create | constructor
Destroy |
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxConsoleEventLog.
Published Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxConsoleEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxConsoleEventLog.
FormatString | This is FormatString, a member of class TnxConsoleEventLog.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxConsoleEventLog.
Version | Version of the component.
WriteBlockData | This is WriteBlockData, a member of class TnxConsoleEventLog.
Links
TnxConsoleEventLog Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Events, Published Properties


TnxConsoleEventLog Methods

TnxConsoleEventLog Methods
TnxConsoleEventLog Class Legend Protected Methods Send Feedback

The methods of the TnxConsoleEventLog class are listed here.

Class

TnxConsoleEventLog Class

Protected Methods
Name | Description
clRawWrite | TnxConsoleEventLog
Links
TnxConsoleEventLog Class, Legend, Protected Methods


TnxConsoleEventLog.clRawWrite Method

TnxConsoleEventLog.clRawWrite Method
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); override;
Description

TnxConsoleEventLog

Group

TnxConsoleEventLog Methods

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Methods


TnxConsoleEventLog Properties

TnxConsoleEventLog Properties
TnxConsoleEventLog Class Legend Published Properties Send Feedback

The properties of the TnxConsoleEventLog class are listed here.

Class

TnxConsoleEventLog Class

Published Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxConsoleEventLog.
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxConsoleEventLog.
FormatString | This is FormatString, a member of class TnxConsoleEventLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxConsoleEventLog.
WriteBlockData | This is WriteBlockData, a member of class TnxConsoleEventLog.
Links
TnxConsoleEventLog Class, Legend, Published Properties


TnxConsoleEventLog.DateFormatString Property

TnxConsoleEventLog.DateFormatString Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property DateFormatString: string;
Description

This is DateFormatString, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog.Enabled Property

TnxConsoleEventLog.Enabled Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog.EventDispatcher Property

TnxConsoleEventLog.EventDispatcher Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property EventDispatcher: TnxBaseEventLogDispatcher;
Description

This is EventDispatcher, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog.FormatString Property

TnxConsoleEventLog.FormatString Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property FormatString: string;
Description

This is FormatString, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog.PrioritiesToLog Property

TnxConsoleEventLog.PrioritiesToLog Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property PrioritiesToLog: TnxLogPriorities;
Description

This is PrioritiesToLog, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog.WriteBlockData Property

TnxConsoleEventLog.WriteBlockData Property
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Properties Send Feedback
Syntax
Delphi
property WriteBlockData: Boolean;
Description

This is WriteBlockData, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Properties

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Properties


TnxConsoleEventLog Events

TnxConsoleEventLog Events
TnxConsoleEventLog Class Legend Published Events Send Feedback

The events of the TnxConsoleEventLog class are listed here.

Class

TnxConsoleEventLog Class

Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxConsoleEventLog.
Links
TnxConsoleEventLog Class, Legend, Published Events


TnxConsoleEventLog.OnLogDataFilter Event

TnxConsoleEventLog.OnLogDataFilter Event
TnxConsoleEventLog Class TnxConsoleEventLog Members nxlgEventLog Namespace TnxConsoleEventLog Events Send Feedback
Syntax
Delphi
property OnLogDataFilter: TnxLogDataFilterEvent;
Description

This is OnLogDataFilter, a member of class TnxConsoleEventLog.

Group

TnxConsoleEventLog Events

Links
TnxConsoleEventLog Class, TnxConsoleEventLog Members, nxlgEventLog Namespace, TnxConsoleEventLog Events


TnxCustomLog Class

TnxCustomLog Class
TnxCustomLog Fields TnxCustomLog Methods TnxCustomLog Properties TnxCustomLog Events TnxCustomLog Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxCustomLognxlgEventLog_TnxCustomLognxlgEventLog_TnxCustomLognxlgEventLog_TnxCustomLognxlgEventLog_TnxCustomLognxlgEventLog_TnxCustomLog
Syntax
Delphi
TnxCustomLog = class(TnxBaseLog);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxCustomLog.

Group

Classes

Links
TnxCustomLog Fields, TnxCustomLog Methods, TnxCustomLog Properties, TnxCustomLog Events, TnxCustomLog Members, nxlgEventLog, Classes


TnxCustomLog Members

TnxCustomLog Members
TnxCustomLog Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxCustomLog.

Class

TnxCustomLog Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Protected Fields
Name | Description
blEnabled | private
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blUnlockLog |
clGetLogDataFormatter |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | This is clRawWrite, a member of class TnxCustomLog.
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteLogData |
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxCustomLog Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxCustomLog.Create Constructor

TnxCustomLog.Create Constructor
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxCustomLog Class

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Class


TnxCustomLog.Destroy Destructor

TnxCustomLog.Destroy Destructor
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxCustomLog Class

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Class


TnxCustomLog Fields

TnxCustomLog Fields
TnxCustomLog Class Legend Protected Fields Send Feedback

The fields of the TnxCustomLog class are listed here.

Class

TnxCustomLog Class

Protected Fields
Name | Description
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
Links
TnxCustomLog Class, Legend, Protected Fields


TnxCustomLog.clDateFormatString Field

TnxCustomLog.clDateFormatString Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clDateFormatString: string;
Description

This is clDateFormatString, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clEventDispatcher Field

TnxCustomLog.clEventDispatcher Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clEventDispatcher: TnxBaseEventLogDispatcher;
Description

This is clEventDispatcher, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clFormatString Field

TnxCustomLog.clFormatString Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clFormatString: string;
Description

This is clFormatString, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clLogDataFormatter Field

TnxCustomLog.clLogDataFormatter Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clLogDataFormatter: TnxBaseLogDataFormatter;
Description

This is clLogDataFormatter, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clLogDataHandler Field

TnxCustomLog.clLogDataHandler Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clLogDataHandler: TnxBaseLogDataHandler;
Description

This is clLogDataHandler, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clOnLogDataFilter Field

TnxCustomLog.clOnLogDataFilter Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clOnLogDataFilter: TnxLogDataFilterEvent;
Description

This is clOnLogDataFilter, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clPrioritiesToLog Field

TnxCustomLog.clPrioritiesToLog Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clPrioritiesToLog: TnxLogPriorities;
Description

This is clPrioritiesToLog, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clStorageLock Field

TnxCustomLog.clStorageLock Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clStorageLock: TnxPadLock;
Description

This is clStorageLock, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog.clWriteBlockData Field

TnxCustomLog.clWriteBlockData Field
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Fields Send Feedback
Syntax
Delphi
clWriteBlockData: Boolean;
Description

This is clWriteBlockData, a member of class TnxCustomLog.

Group

TnxCustomLog Fields

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Fields


TnxCustomLog Methods

TnxCustomLog Methods
TnxCustomLog Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomLog class are listed here.

Class

TnxCustomLog Class

Protected Methods
Name | Description
BlockToStrings |
blSetEnabled |
clGetLogDataFormatter |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | This is clRawWrite, a member of class TnxCustomLog.
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
nxcNotification |
PersistLogData |
Public Methods
Name | Description
Clear |
Flush |
WriteBlock |
WriteLogData |
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
Links
TnxCustomLog Class, Legend, Protected Methods, Public Methods


TnxCustomLog.BlockToStrings Method

TnxCustomLog.BlockToStrings Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure BlockToStrings(const S: string; Buf: Pointer; BufLen: TnxMemSize; Msgs: TStrings); virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.blSetEnabled Method

TnxCustomLog.blSetEnabled Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure blSetEnabled(const Value: Boolean); override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.Clear Method

TnxCustomLog.Clear Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure Clear; override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clGetLogDataFormatter Method

TnxCustomLog.clGetLogDataFormatter Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
function clGetLogDataFormatter: TnxBaseLogDataFormatter; virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clGetLogDataHandler Method

TnxCustomLog.clGetLogDataHandler Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
function clGetLogDataHandler: TnxBaseLogDataHandler; virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clLockStorage Method

TnxCustomLog.clLockStorage Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clLockStorage;
Description

TnxCustomLog

Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clRawWrite Method

TnxCustomLog.clRawWrite Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); virtual; abstract;
Description

This is clRawWrite, a member of class TnxCustomLog.

Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clSetDateFormatString Method

TnxCustomLog.clSetDateFormatString Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clSetDateFormatString(const Value: string);
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clSetEventDispatcher Method

TnxCustomLog.clSetEventDispatcher Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clSetEventDispatcher(const Value: TnxBaseEventLogDispatcher);
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clSetFormatString Method

TnxCustomLog.clSetFormatString Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clSetFormatString(const Value: string);
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.clUnlockStorage Method

TnxCustomLog.clUnlockStorage Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure clUnlockStorage;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.DoClear Method

TnxCustomLog.DoClear Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure DoClear; virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.DoFlush Method

TnxCustomLog.DoFlush Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure DoFlush; virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.FilterLogData Method

TnxCustomLog.FilterLogData Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
function FilterLogData(const LogData: InxLogData): Boolean; virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.Flush Method

TnxCustomLog.Flush Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure Flush; override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.nxcNotification Method

TnxCustomLog.nxcNotification Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.PersistLogData Method

TnxCustomLog.PersistLogData Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure PersistLogData(const LogData: InxLogData); virtual;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.WriteBlock Method

TnxCustomLog.WriteBlock Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure WriteBlock(const S: string; Buf: Pointer; BufLen: TnxMemSize; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog.WriteLogData Method

TnxCustomLog.WriteLogData Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure WriteLogData(LogData: InxLogData); override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


WriteString Method

WriteString Method
TnxCustomLog Methods Send Feedback

This is the overview for the WriteString method overload.

Overload List
Name | Description
TnxCustomLog.WriteString (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer) |
TnxCustomLog.WriteString (string, Cardinal, TnxLogPriority, string, TDateTime, Integer) |
Group

TnxCustomLog Methods

Links
TnxCustomLog Methods


TnxCustomLog.WriteString Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxCustomLog.WriteString Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace WriteString Method Send Feedback
Syntax
Delphi
procedure WriteString(const aMsg: string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); override; overload;
Group

WriteString Method

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, WriteString Method


TnxCustomLog.WriteString Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxCustomLog.WriteString Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace WriteString Method Send Feedback
Syntax
Delphi
procedure WriteString(const aMsg: string; const aArgs: array of const; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); override; overload;
Group

WriteString Method

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, WriteString Method


TnxCustomLog.WriteStrings Method

TnxCustomLog.WriteStrings Method
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Methods Send Feedback
Syntax
Delphi
procedure WriteStrings(const aMsgs: array of string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); override;
Group

TnxCustomLog Methods

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Methods


TnxCustomLog Properties

TnxCustomLog Properties
TnxCustomLog Class Legend Protected Properties Send Feedback

The properties of the TnxCustomLog class are listed here.

Class

TnxCustomLog Class

Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Links
TnxCustomLog Class, Legend, Protected Properties


TnxCustomLog.DateFormatString Property

TnxCustomLog.DateFormatString Property
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Properties Send Feedback
Syntax
Delphi
property DateFormatString: string;
Description

This is DateFormatString, a member of class TnxCustomLog.

Group

TnxCustomLog Properties

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Properties


TnxCustomLog.EventDispatcher Property

TnxCustomLog.EventDispatcher Property
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Properties Send Feedback
Syntax
Delphi
property EventDispatcher: TnxBaseEventLogDispatcher;
Description

This is EventDispatcher, a member of class TnxCustomLog.

Group

TnxCustomLog Properties

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Properties


TnxCustomLog.FormatString Property

TnxCustomLog.FormatString Property
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Properties Send Feedback
Syntax
Delphi
property FormatString: string;
Description

This is FormatString, a member of class TnxCustomLog.

Group

TnxCustomLog Properties

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Properties


TnxCustomLog.PrioritiesToLog Property

TnxCustomLog.PrioritiesToLog Property
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Properties Send Feedback
Syntax
Delphi
property PrioritiesToLog: TnxLogPriorities;
Description

This is PrioritiesToLog, a member of class TnxCustomLog.

Group

TnxCustomLog Properties

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Properties


TnxCustomLog.WriteBlockData Property

TnxCustomLog.WriteBlockData Property
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Properties Send Feedback
Syntax
Delphi
property WriteBlockData: Boolean;
Description

This is WriteBlockData, a member of class TnxCustomLog.

Group

TnxCustomLog Properties

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Properties


TnxCustomLog Events

TnxCustomLog Events
TnxCustomLog Class Legend Protected Events Send Feedback

The events of the TnxCustomLog class are listed here.

Class

TnxCustomLog Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Links
TnxCustomLog Class, Legend, Protected Events


TnxCustomLog.OnLogDataFilter Event

TnxCustomLog.OnLogDataFilter Event
TnxCustomLog Class TnxCustomLog Members nxlgEventLog Namespace TnxCustomLog Events Send Feedback
Syntax
Delphi
property OnLogDataFilter: TnxLogDataFilterEvent;
Description

This is OnLogDataFilter, a member of class TnxCustomLog.

Group

TnxCustomLog Events

Links
TnxCustomLog Class, TnxCustomLog Members, nxlgEventLog Namespace, TnxCustomLog Events


TnxDirectLogDataHandler Class

TnxDirectLogDataHandler Class
TnxDirectLogDataHandler Methods TnxDirectLogDataHandler Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxDirectLogDataHandlernxlgEventLog_TnxDirectLogDataHandlernxlgEventLog_TnxDirectLogDataHandler
Syntax
Delphi
TnxDirectLogDataHandler = class(TnxBaseLogDataHandler);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxDirectLogDataHandler.

Group

Classes

Links
TnxDirectLogDataHandler Methods, TnxDirectLogDataHandler Members, nxlgEventLog, Classes


TnxDirectLogDataHandler Members

TnxDirectLogDataHandler Members
TnxDirectLogDataHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDirectLogDataHandler.

Class

TnxDirectLogDataHandler Class

Protected Fields
Name | Description
bldhLogger | This is bldhLogger, a member of class TnxBaseLogDataHandler.
Protected Methods
Name | Description
LoggerPersistLogData |
Public Methods
Name | Description
Create | TnxBaseLogDataHandler
DoLogData | TnxDirectLogDataHandler
Flush |
FreeInstance |
NewInstance | TnxObject
Links
TnxDirectLogDataHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDirectLogDataHandler Methods

TnxDirectLogDataHandler Methods
TnxDirectLogDataHandler Class Legend Public Methods Send Feedback

The methods of the TnxDirectLogDataHandler class are listed here.

Class

TnxDirectLogDataHandler Class

Public Methods
Name | Description
DoLogData | TnxDirectLogDataHandler
Links
TnxDirectLogDataHandler Class, Legend, Public Methods


TnxDirectLogDataHandler.DoLogData Method

TnxDirectLogDataHandler.DoLogData Method
TnxDirectLogDataHandler Class TnxDirectLogDataHandler Members nxlgEventLog Namespace TnxDirectLogDataHandler Methods Send Feedback
Syntax
Delphi
procedure DoLogData(const aLogData: InxLogData); override;
Description

TnxDirectLogDataHandler

Group

TnxDirectLogDataHandler Methods

Links
TnxDirectLogDataHandler Class, TnxDirectLogDataHandler Members, nxlgEventLog Namespace, TnxDirectLogDataHandler Methods


TnxEventLog Class

TnxEventLog Class
TnxEventLog Fields TnxEventLog Methods TnxEventLog Properties TnxEventLog Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLognxlgEventLog_TnxEventLog
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxEventLog = class(TnxStreamEventLog);
File

nxlgEventLog

Description

Component to write log entries into a text file. Entries are stamped with time and thread ID.

Group

Classes

Links
TnxEventLog Fields, TnxEventLog Methods, TnxEventLog Properties, TnxEventLog Members, nxlgEventLog, Classes


TnxEventLog Members

TnxEventLog Members
TnxEventLog Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxEventLog.

Class

TnxEventLog Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Protected Fields
Name | Description
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
elFileName | private
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
REMOVEMaxSize | This is REMOVEMaxSize, a member of class TnxEventLog.
selCurrentRotation | This is selCurrentRotation, a member of class TnxStreamEventLog.
selNumRotations | This is selNumRotations, a member of class TnxStreamEventLog.
selPersistStream | This is selPersistStream, a member of class TnxStreamEventLog.
selRotationSize | This is selRotationSize, a member of class TnxStreamEventLog.
selStreamSize | This is selStreamSize, a member of class TnxStreamEventLog.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | This is clRawWrite, a member of class TnxCustomLog.
clRawWrite | TnxStreamEventLog
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
DoFlush |
elGetFileName |
elSetFileName |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
GetInternalFileName |
GetStream |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create | TnxEventLog
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadConfig |
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig |
SaveSettingsToStream |
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxStreamEventLog.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DateFormatString | This is DateFormatString, a member of class TnxStreamEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxStreamEventLog.
FileName | This is FileName, a member of class TnxEventLog.
FormatString | This is FormatString, a member of class TnxStreamEventLog.
MaxSize | This is MaxSize, a member of class TnxEventLog.
NumRotations | This is NumRotations, a member of class TnxEventLog.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxStreamEventLog.
RotationSize | This is RotationSize, a member of class TnxEventLog.
Version | Version of the component.
Links
TnxEventLog Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxEventLog.Create Constructor

TnxEventLog.Create Constructor
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

TnxEventLog

Class

TnxEventLog Class

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Class


TnxEventLog.Destroy Destructor

TnxEventLog.Destroy Destructor
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxEventLog Class

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Class


TnxEventLog Fields

TnxEventLog Fields
TnxEventLog Class Legend Protected Fields Send Feedback

The fields of the TnxEventLog class are listed here.

Class

TnxEventLog Class

Protected Fields
Name | Description
elFileName | private
REMOVEMaxSize | This is REMOVEMaxSize, a member of class TnxEventLog.
Links
TnxEventLog Class, Legend, Protected Fields


TnxEventLog.elFileName Field

TnxEventLog.elFileName Field
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Fields Send Feedback
Syntax
Delphi
elFileName: TFileName;
Description

private

Group

TnxEventLog Fields

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Fields


TnxEventLog.REMOVEMaxSize Field

TnxEventLog.REMOVEMaxSize Field
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Fields Send Feedback
Syntax
Delphi
REMOVEMaxSize: integer;
Description

This is REMOVEMaxSize, a member of class TnxEventLog.

Group

TnxEventLog Fields

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Fields


TnxEventLog Methods

TnxEventLog Methods
TnxEventLog Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxEventLog class are listed here.

Class

TnxEventLog Class

Protected Methods
Name | Description
DoClear |
elGetFileName |
elSetFileName |
GetInternalFileName |
GetStream |
Public Methods
Name | Description
GetConfigSettings |
LoadConfig |
LoadSettingsFromStream |
SaveConfig |
SaveSettingsToStream |
Links
TnxEventLog Class, Legend, Protected Methods, Public Methods


TnxEventLog.DoClear Method

TnxEventLog.DoClear Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure DoClear; override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.elGetFileName Method

TnxEventLog.elGetFileName Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
function elGetFileName: TFileName;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.elSetFileName Method

TnxEventLog.elSetFileName Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure elSetFileName(const Value: TFileName); virtual;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.GetConfigSettings Method

TnxEventLog.GetConfigSettings Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.GetInternalFileName Method

TnxEventLog.GetInternalFileName Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
function GetInternalFileName: TFileName;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.GetStream Method

TnxEventLog.GetStream Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
function GetStream: TStream; override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.LoadConfig Method

TnxEventLog.LoadConfig Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.LoadSettingsFromStream Method

TnxEventLog.LoadSettingsFromStream Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.SaveConfig Method

TnxEventLog.SaveConfig Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog.SaveSettingsToStream Method

TnxEventLog.SaveSettingsToStream Method
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); override;
Group

TnxEventLog Methods

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Methods


TnxEventLog Properties

TnxEventLog Properties
TnxEventLog Class Legend Published Properties Send Feedback

The properties of the TnxEventLog class are listed here.

Class

TnxEventLog Class

Published Properties
Name | Description
FileName | This is FileName, a member of class TnxEventLog.
MaxSize | This is MaxSize, a member of class TnxEventLog.
NumRotations | This is NumRotations, a member of class TnxEventLog.
RotationSize | This is RotationSize, a member of class TnxEventLog.
Links
TnxEventLog Class, Legend, Published Properties


TnxEventLog.FileName Property

TnxEventLog.FileName Property
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Properties Send Feedback
Syntax
Delphi
property FileName: TFileName;
Description

This is FileName, a member of class TnxEventLog.

Group

TnxEventLog Properties

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Properties


TnxEventLog.MaxSize Property

TnxEventLog.MaxSize Property
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Properties Send Feedback
Syntax
Delphi
property MaxSize: integer;
Description

This is MaxSize, a member of class TnxEventLog.

Group

TnxEventLog Properties

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Properties


TnxEventLog.NumRotations Property

TnxEventLog.NumRotations Property
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Properties Send Feedback
Syntax
Delphi
property NumRotations: integer;
Description

This is NumRotations, a member of class TnxEventLog.

Group

TnxEventLog Properties

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Properties


TnxEventLog.RotationSize Property

TnxEventLog.RotationSize Property
TnxEventLog Class TnxEventLog Members nxlgEventLog Namespace TnxEventLog Properties Send Feedback
Syntax
Delphi
property RotationSize: Int64;
Description

This is RotationSize, a member of class TnxEventLog.

Group

TnxEventLog Properties

Links
TnxEventLog Class, TnxEventLog Members, nxlgEventLog Namespace, TnxEventLog Properties


TnxLogData Class

TnxLogData Class
TnxLogData Fields TnxLogData Methods TnxLogData Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxLogDatanxlgEventLog_TnxLogDatanxlgEventLog_TnxLogDatanxlgEventLog_TnxLogData
Syntax
Delphi
TnxLogData = class(TnxInterfacedObject, InxLogData);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxLogData.

Group

Classes

Links
TnxLogData Fields, TnxLogData Methods, TnxLogData Members, nxlgEventLog, Classes


TnxLogData Members

TnxLogData Members
TnxLogData Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLogData.

Class

TnxLogData Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
ldCategory | This is ldCategory, a member of class TnxLogData.
ldMsg | This is ldMsg, a member of class TnxLogData.
ldMsgNumber | This is ldMsgNumber, a member of class TnxLogData.
ldPriority | This is ldPriority, a member of class TnxLogData.
ldThreadID | This is ldThreadID, a member of class TnxLogData.
ldWhen | This is ldWhen, a member of class TnxLogData.
ldWhenBias | This is ldWhenBias, a member of class TnxLogData.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxLogData
Free |
FreeInstance |
GetCategory |
GetMsg |
GetMsgNumber |
GetPriority |
GetThreadID |
GetUTCWhen |
GetWhen |
GetWhenBias |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
Category | A Category name (for display purposes)
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
Msg | Message to log, e.g. ErrorMessage
MsgNumber | Number of the message to log, e.g. ErrorCode
Priority | The Priority of the message
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ThreadID | Thread ID
UTCWhen | UTC date/time of the message to log
When | date/time for the message to log
WhenBias | Timezone offset of the When Date/Time
Links
TnxLogData Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLogData.Create Constructor

TnxLogData.Create Constructor
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Class Send Feedback
Syntax
Delphi
constructor Create(const aMsg: string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED; const aThreadID: Cardinal = 0);
Description

TnxLogData

Class

TnxLogData Class

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Class


TnxLogData Fields

TnxLogData Fields
TnxLogData Class Legend Protected Fields Send Feedback

The fields of the TnxLogData class are listed here.

Class

TnxLogData Class

Protected Fields
Name | Description
ldCategory | This is ldCategory, a member of class TnxLogData.
ldMsg | This is ldMsg, a member of class TnxLogData.
ldMsgNumber | This is ldMsgNumber, a member of class TnxLogData.
ldPriority | This is ldPriority, a member of class TnxLogData.
ldThreadID | This is ldThreadID, a member of class TnxLogData.
ldWhen | This is ldWhen, a member of class TnxLogData.
ldWhenBias | This is ldWhenBias, a member of class TnxLogData.
Links
TnxLogData Class, Legend, Protected Fields


TnxLogData.ldCategory Field

TnxLogData.ldCategory Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldCategory: string;
Description

This is ldCategory, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldMsg Field

TnxLogData.ldMsg Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldMsg: string;
Description

This is ldMsg, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldMsgNumber Field

TnxLogData.ldMsgNumber Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldMsgNumber: Cardinal;
Description

This is ldMsgNumber, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldPriority Field

TnxLogData.ldPriority Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldPriority: TnxLogPriority;
Description

This is ldPriority, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldThreadID Field

TnxLogData.ldThreadID Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldThreadID: Cardinal;
Description

This is ldThreadID, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldWhen Field

TnxLogData.ldWhen Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldWhen: TDateTime;
Description

This is ldWhen, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData.ldWhenBias Field

TnxLogData.ldWhenBias Field
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Fields Send Feedback
Syntax
Delphi
ldWhenBias: Integer;
Description

This is ldWhenBias, a member of class TnxLogData.

Group

TnxLogData Fields

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Fields


TnxLogData Methods

TnxLogData Methods
TnxLogData Class Legend Public Methods Send Feedback

The methods of the TnxLogData class are listed here.

Class

TnxLogData Class

Public Methods
Name | Description
GetCategory |
GetMsg |
GetMsgNumber |
GetPriority |
GetThreadID |
GetUTCWhen |
GetWhen |
GetWhenBias |
Links
TnxLogData Class, Legend, Public Methods


TnxLogData.GetCategory Method

TnxLogData.GetCategory Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetCategory: string;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetMsg Method

TnxLogData.GetMsg Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetMsg: string;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetMsgNumber Method

TnxLogData.GetMsgNumber Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetMsgNumber: Cardinal;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetPriority Method

TnxLogData.GetPriority Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetPriority: TnxLogPriority;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetThreadID Method

TnxLogData.GetThreadID Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetThreadID: Cardinal;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetUTCWhen Method

TnxLogData.GetUTCWhen Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetUTCWhen: TDateTime;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetWhen Method

TnxLogData.GetWhen Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetWhen: TDateTime;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogData.GetWhenBias Method

TnxLogData.GetWhenBias Method
TnxLogData Class TnxLogData Members nxlgEventLog Namespace TnxLogData Methods Send Feedback
Syntax
Delphi
function GetWhenBias: Integer;
Group

TnxLogData Methods

Links
TnxLogData Class, TnxLogData Members, nxlgEventLog Namespace, TnxLogData Methods


TnxLogDataQueue Class

TnxLogDataQueue Class
TnxLogDataQueue Methods TnxLogDataQueue Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxLogDataQueuenxlgEventLog_TnxLogDataQueuenxlgEventLog_TnxLogDataQueue
Syntax
Delphi
TnxLogDataQueue = class(TnxQueue);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxLogDataQueue.

Group

Classes

Links
TnxLogDataQueue Methods, TnxLogDataQueue Members, nxlgEventLog, Classes


TnxLogDataQueue Members

TnxLogDataQueue Members
TnxLogDataQueue Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxLogDataQueue.

Class

TnxLogDataQueue Class

Protected Fields
Name | Description
tsqItemsHead | private
tsqItemsTail | This is tsqItemsTail, a member of class TnxQueue.
Public Methods
Name | Description
Create | TnxLogDataQueue
Dequeue | TnxQueue
Destroy |
FreeInstance |
Lock |
NewInstance | TnxObject
UnLock |
Links
TnxLogDataQueue Class, Legend, Protected Fields, Public Methods


TnxLogDataQueue.Create Constructor

TnxLogDataQueue.Create Constructor
TnxLogDataQueue Class TnxLogDataQueue Members nxlgEventLog Namespace TnxLogDataQueue Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxLogDataQueue

Class

TnxLogDataQueue Class

Links
TnxLogDataQueue Class, TnxLogDataQueue Members, nxlgEventLog Namespace, TnxLogDataQueue Class


TnxLogDataQueue.Destroy Destructor

TnxLogDataQueue.Destroy Destructor
TnxLogDataQueue Class TnxLogDataQueue Members nxlgEventLog Namespace TnxLogDataQueue Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxLogDataQueue Class

Links
TnxLogDataQueue Class, TnxLogDataQueue Members, nxlgEventLog Namespace, TnxLogDataQueue Class


TnxLogDataQueue Methods

TnxLogDataQueue Methods
TnxLogDataQueue Class Legend Public Methods Send Feedback

The methods of the TnxLogDataQueue class are listed here.

Class

TnxLogDataQueue Class

Public Methods
Name | Description
Lock |
UnLock |
Links
TnxLogDataQueue Class, Legend, Public Methods


TnxLogDataQueue.Lock Method

TnxLogDataQueue.Lock Method
TnxLogDataQueue Class TnxLogDataQueue Members nxlgEventLog Namespace TnxLogDataQueue Methods Send Feedback
Syntax
Delphi
procedure Lock;
Group

TnxLogDataQueue Methods

Links
TnxLogDataQueue Class, TnxLogDataQueue Members, nxlgEventLog Namespace, TnxLogDataQueue Methods


TnxLogDataQueue.UnLock Method

TnxLogDataQueue.UnLock Method
TnxLogDataQueue Class TnxLogDataQueue Members nxlgEventLog Namespace TnxLogDataQueue Methods Send Feedback
Syntax
Delphi
procedure UnLock;
Group

TnxLogDataQueue Methods

Links
TnxLogDataQueue Class, TnxLogDataQueue Members, nxlgEventLog Namespace, TnxLogDataQueue Methods


TnxLogDispatchThread Class

TnxLogDispatchThread Class
TnxLogDispatchThread Methods TnxLogDispatchThread Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxLogDispatchThreadnxlgEventLog_TnxLogDispatchThreadnxlgEventLog_TnxLogDispatchThreadnxlgEventLog_TnxLogDispatchThreadnxlgEventLog_TnxLogDispatchThreadnxlgEventLog_TnxLogDispatchThread
Syntax
Delphi
TnxLogDispatchThread = class(TnxTimerThread);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxLogDispatchThread.

Group

Classes

Links
TnxLogDispatchThread Methods, TnxLogDispatchThread Members, nxlgEventLog, Classes


TnxLogDispatchThread Members

TnxLogDispatchThread Members
TnxLogDispatchThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxLogDispatchThread.

Class

TnxLogDispatchThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
DoTimer |
Execute |
InnerExecute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxLogDispatchThread
Destroy |
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxLogDispatchThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxLogDispatchThread.Create Constructor

TnxLogDispatchThread.Create Constructor
TnxLogDispatchThread Class TnxLogDispatchThread Members nxlgEventLog Namespace TnxLogDispatchThread Class Send Feedback
Syntax
Delphi
constructor Create(aOnDispatch: TnxSimpleEvent; const aInterval: integer; const aThreadPriority: TThreadPriority);
Description

TnxLogDispatchThread

Class

TnxLogDispatchThread Class

Links
TnxLogDispatchThread Class, TnxLogDispatchThread Members, nxlgEventLog Namespace, TnxLogDispatchThread Class


TnxLogDispatchThread Methods

TnxLogDispatchThread Methods
TnxLogDispatchThread Class Legend Protected Methods Send Feedback

The methods of the TnxLogDispatchThread class are listed here.

Class

TnxLogDispatchThread Class

Protected Methods
Name | Description
DoTimer |
Links
TnxLogDispatchThread Class, Legend, Protected Methods


TnxLogDispatchThread.DoTimer Method

TnxLogDispatchThread.DoTimer Method
TnxLogDispatchThread Class TnxLogDispatchThread Members nxlgEventLog Namespace TnxLogDispatchThread Methods Send Feedback
Syntax
Delphi
procedure DoTimer; override;
Group

TnxLogDispatchThread Methods

Links
TnxLogDispatchThread Class, TnxLogDispatchThread Members, nxlgEventLog Namespace, TnxLogDispatchThread Methods


TnxLogQueueItem Class

TnxLogQueueItem Class
TnxLogQueueItem Methods TnxLogQueueItem Properties TnxLogQueueItem Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxLogQueueItemnxlgEventLog_TnxLogQueueItem
Syntax
Delphi
TnxLogQueueItem = class(TnxQueueItem);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxLogQueueItem.

Group

Classes

Links
TnxLogQueueItem Methods, TnxLogQueueItem Properties, TnxLogQueueItem Members, nxlgEventLog, Classes


TnxLogQueueItem Members

TnxLogQueueItem Members
TnxLogQueueItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLogQueueItem.

Class

TnxLogQueueItem Class

Protected Fields
Name | Description
qiQueue | private
qiQueueNext | This is qiQueueNext, a member of class TnxQueueItem.
qiQueuePrev | This is qiQueuePrev, a member of class TnxQueueItem.
Protected Methods
Name | Description
qiAddToQueue |
qiRemoveFromQueue |
Requeue |
SetLogData |
Public Methods
Name | Description
Create | TnxLogQueueItem
Destroy |
Public Properties
Name | Description
LogData | This is LogData, a member of class TnxLogQueueItem.
Links
TnxLogQueueItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLogQueueItem.Create Constructor

TnxLogQueueItem.Create Constructor
TnxLogQueueItem Class TnxLogQueueItem Members nxlgEventLog Namespace TnxLogQueueItem Class Send Feedback
Syntax
Delphi
constructor Create(aQueue: TnxQueue; aLogData: InxLogData);
Description

TnxLogQueueItem

Class

TnxLogQueueItem Class

Links
TnxLogQueueItem Class, TnxLogQueueItem Members, nxlgEventLog Namespace, TnxLogQueueItem Class


TnxLogQueueItem Methods

TnxLogQueueItem Methods
TnxLogQueueItem Class Legend Protected Methods Send Feedback

The methods of the TnxLogQueueItem class are listed here.

Class

TnxLogQueueItem Class

Protected Methods
Name | Description
Requeue |
SetLogData |
Links
TnxLogQueueItem Class, Legend, Protected Methods


TnxLogQueueItem.Requeue Method

TnxLogQueueItem.Requeue Method
TnxLogQueueItem Class TnxLogQueueItem Members nxlgEventLog Namespace TnxLogQueueItem Methods Send Feedback
Syntax
Delphi
procedure Requeue(aQueue: TnxQueue);
Group

TnxLogQueueItem Methods

Links
TnxLogQueueItem Class, TnxLogQueueItem Members, nxlgEventLog Namespace, TnxLogQueueItem Methods


TnxLogQueueItem.SetLogData Method

TnxLogQueueItem.SetLogData Method
TnxLogQueueItem Class TnxLogQueueItem Members nxlgEventLog Namespace TnxLogQueueItem Methods Send Feedback
Syntax
Delphi
procedure SetLogData(const Value: InxLogData);
Group

TnxLogQueueItem Methods

Links
TnxLogQueueItem Class, TnxLogQueueItem Members, nxlgEventLog Namespace, TnxLogQueueItem Methods


TnxLogQueueItem Properties

TnxLogQueueItem Properties
TnxLogQueueItem Class Legend Public Properties Send Feedback

The properties of the TnxLogQueueItem class are listed here.

Class

TnxLogQueueItem Class

Public Properties
Name | Description
LogData | This is LogData, a member of class TnxLogQueueItem.
Links
TnxLogQueueItem Class, Legend, Public Properties


TnxLogQueueItem.LogData Property

TnxLogQueueItem.LogData Property
TnxLogQueueItem Class TnxLogQueueItem Members nxlgEventLog Namespace TnxLogQueueItem Properties Send Feedback
Syntax
Delphi
property LogData: InxLogData;
Description

This is LogData, a member of class TnxLogQueueItem.

Group

TnxLogQueueItem Properties

Links
TnxLogQueueItem Class, TnxLogQueueItem Members, nxlgEventLog Namespace, TnxLogQueueItem Properties


TnxPatternedLogDataFormatter Class

TnxPatternedLogDataFormatter Class
TnxPatternedLogDataFormatter Methods TnxPatternedLogDataFormatter Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxPatternedLogDataFormatternxlgEventLog_TnxPatternedLogDataFormatternxlgEventLog_TnxPatternedLogDataFormatter
Syntax
Delphi
TnxPatternedLogDataFormatter = class(TnxBaseLogDataFormatter);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxPatternedLogDataFormatter.

Group

Classes

Links
TnxPatternedLogDataFormatter Methods, TnxPatternedLogDataFormatter Members, nxlgEventLog, Classes


TnxPatternedLogDataFormatter Members

TnxPatternedLogDataFormatter Members
TnxPatternedLogDataFormatter Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPatternedLogDataFormatter.

Class

TnxPatternedLogDataFormatter Class

Protected Fields
Name | Description
bldfPrefix | This is bldfPrefix, a member of class TnxBaseLogDataFormatter.
bldfSuffix | This is bldfSuffix, a member of class TnxBaseLogDataFormatter.
Protected Methods
Name | Description
GetDateFormatString |
GetFormatString |
Public Methods
Name | Description
Create | TnxBaseLogDataFormatter
FormatDataChanged | TnxPatternedLogDataFormatter
FormatLogData |
FreeInstance |
NewInstance | TnxObject
PriorityToStr |
Links
TnxPatternedLogDataFormatter Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxPatternedLogDataFormatter Methods

TnxPatternedLogDataFormatter Methods
TnxPatternedLogDataFormatter Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxPatternedLogDataFormatter class are listed here.

Class

TnxPatternedLogDataFormatter Class

Protected Methods
Name | Description
GetDateFormatString |
GetFormatString |
Public Methods
Name | Description
FormatDataChanged | TnxPatternedLogDataFormatter
Links
TnxPatternedLogDataFormatter Class, Legend, Protected Methods, Public Methods


TnxPatternedLogDataFormatter.FormatDataChanged Method

TnxPatternedLogDataFormatter.FormatDataChanged Method
TnxPatternedLogDataFormatter Class TnxPatternedLogDataFormatter Members nxlgEventLog Namespace TnxPatternedLogDataFormatter Methods Send Feedback
Syntax
Delphi
procedure FormatDataChanged(const aFormatString: string; const aDateFormatString: string); override;
Description

TnxPatternedLogDataFormatter

Group

TnxPatternedLogDataFormatter Methods

Links
TnxPatternedLogDataFormatter Class, TnxPatternedLogDataFormatter Members, nxlgEventLog Namespace, TnxPatternedLogDataFormatter Methods


TnxPatternedLogDataFormatter.GetDateFormatString Method

TnxPatternedLogDataFormatter.GetDateFormatString Method
TnxPatternedLogDataFormatter Class TnxPatternedLogDataFormatter Members nxlgEventLog Namespace TnxPatternedLogDataFormatter Methods Send Feedback
Syntax
Delphi
function GetDateFormatString: string; override;
Group

TnxPatternedLogDataFormatter Methods

Links
TnxPatternedLogDataFormatter Class, TnxPatternedLogDataFormatter Members, nxlgEventLog Namespace, TnxPatternedLogDataFormatter Methods


TnxPatternedLogDataFormatter.GetFormatString Method

TnxPatternedLogDataFormatter.GetFormatString Method
TnxPatternedLogDataFormatter Class TnxPatternedLogDataFormatter Members nxlgEventLog Namespace TnxPatternedLogDataFormatter Methods Send Feedback
Syntax
Delphi
function GetFormatString: string; override;
Group

TnxPatternedLogDataFormatter Methods

Links
TnxPatternedLogDataFormatter Class, TnxPatternedLogDataFormatter Members, nxlgEventLog Namespace, TnxPatternedLogDataFormatter Methods


TnxStreamEventLog Class

TnxStreamEventLog Class
TnxStreamEventLog Fields TnxStreamEventLog Methods TnxStreamEventLog Properties TnxStreamEventLog Events TnxStreamEventLog Members nxlgEventLog Classes Send Feedback
Class Hierarchy
nxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLognxlgEventLog_TnxStreamEventLog
Syntax
Delphi
TnxStreamEventLog = class(TnxCachedEventLog);
File

nxlgEventLog

Description

This is class nxlgEventLog.TnxStreamEventLog.

Group

Classes

Links
TnxStreamEventLog Fields, TnxStreamEventLog Methods, TnxStreamEventLog Properties, TnxStreamEventLog Events, TnxStreamEventLog Members, nxlgEventLog, Classes


TnxStreamEventLog Members

TnxStreamEventLog Members
TnxStreamEventLog Class Legend Protected Fields Protected Methods Protected Properties Public Methods Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxStreamEventLog.

Class

TnxStreamEventLog Class

Protected Fields
Name | Description
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
selCurrentRotation | This is selCurrentRotation, a member of class TnxStreamEventLog.
selNumRotations | This is selNumRotations, a member of class TnxStreamEventLog.
selPersistStream | This is selPersistStream, a member of class TnxStreamEventLog.
selRotationSize | This is selRotationSize, a member of class TnxStreamEventLog.
selStreamSize | This is selStreamSize, a member of class TnxStreamEventLog.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | TnxStreamEventLog
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
GetStream | This is GetStream, a member of class TnxStreamEventLog.
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
NumRotations | This is NumRotations, a member of class TnxStreamEventLog.
RotationSize | This is RotationSize, a member of class TnxStreamEventLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxStreamEventLog.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DateFormatString | This is DateFormatString, a member of class TnxStreamEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxStreamEventLog.
FormatString | This is FormatString, a member of class TnxStreamEventLog.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxStreamEventLog.
Version | Version of the component.
Links
TnxStreamEventLog Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Published Events, Published Properties


TnxStreamEventLog.Create Constructor

TnxStreamEventLog.Create Constructor
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxStreamEventLog Class

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Class


TnxStreamEventLog.Destroy Destructor

TnxStreamEventLog.Destroy Destructor
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxStreamEventLog Class

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Class


TnxStreamEventLog Fields

TnxStreamEventLog Fields
TnxStreamEventLog Class Legend Protected Fields Send Feedback

The fields of the TnxStreamEventLog class are listed here.

Class

TnxStreamEventLog Class

Protected Fields
Name | Description
selCurrentRotation | This is selCurrentRotation, a member of class TnxStreamEventLog.
selNumRotations | This is selNumRotations, a member of class TnxStreamEventLog.
selPersistStream | This is selPersistStream, a member of class TnxStreamEventLog.
selRotationSize | This is selRotationSize, a member of class TnxStreamEventLog.
selStreamSize | This is selStreamSize, a member of class TnxStreamEventLog.
Links
TnxStreamEventLog Class, Legend, Protected Fields


TnxStreamEventLog.selCurrentRotation Field

TnxStreamEventLog.selCurrentRotation Field
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Fields Send Feedback
Syntax
Delphi
selCurrentRotation: integer;
Description

This is selCurrentRotation, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Fields

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Fields


TnxStreamEventLog.selNumRotations Field

TnxStreamEventLog.selNumRotations Field
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Fields Send Feedback
Syntax
Delphi
selNumRotations: integer;
Description

This is selNumRotations, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Fields

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Fields


TnxStreamEventLog.selPersistStream Field

TnxStreamEventLog.selPersistStream Field
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Fields Send Feedback
Syntax
Delphi
selPersistStream: TStream;
Description

This is selPersistStream, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Fields

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Fields


TnxStreamEventLog.selRotationSize Field

TnxStreamEventLog.selRotationSize Field
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Fields Send Feedback
Syntax
Delphi
selRotationSize: Int64;
Description

This is selRotationSize, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Fields

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Fields


TnxStreamEventLog.selStreamSize Field

TnxStreamEventLog.selStreamSize Field
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Fields Send Feedback
Syntax
Delphi
selStreamSize: Int64;
Description

This is selStreamSize, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Fields

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Fields


TnxStreamEventLog Methods

TnxStreamEventLog Methods
TnxStreamEventLog Class Legend Protected Methods Send Feedback

The methods of the TnxStreamEventLog class are listed here.

Class

TnxStreamEventLog Class

Protected Methods
Name | Description
clRawWrite | TnxStreamEventLog
DoFlush |
GetStream | This is GetStream, a member of class TnxStreamEventLog.
Links
TnxStreamEventLog Class, Legend, Protected Methods


TnxStreamEventLog.clRawWrite Method

TnxStreamEventLog.clRawWrite Method
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); override;
Description

TnxStreamEventLog

Group

TnxStreamEventLog Methods

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Methods


TnxStreamEventLog.DoFlush Method

TnxStreamEventLog.DoFlush Method
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Methods Send Feedback
Syntax
Delphi
procedure DoFlush; override;
Group

TnxStreamEventLog Methods

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Methods


TnxStreamEventLog.GetStream Method

TnxStreamEventLog.GetStream Method
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Methods Send Feedback
Syntax
Delphi
function GetStream: TStream; virtual; abstract;
Description

This is GetStream, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Methods

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Methods


TnxStreamEventLog Properties

TnxStreamEventLog Properties
TnxStreamEventLog Class Legend Protected Properties Published Properties Send Feedback

The properties of the TnxStreamEventLog class are listed here.

Class

TnxStreamEventLog Class

Protected Properties
Name | Description
NumRotations | This is NumRotations, a member of class TnxStreamEventLog.
RotationSize | This is RotationSize, a member of class TnxStreamEventLog.
Published Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxStreamEventLog.
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxStreamEventLog.
FormatString | This is FormatString, a member of class TnxStreamEventLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxStreamEventLog.
Links
TnxStreamEventLog Class, Legend, Protected Properties, Published Properties


TnxStreamEventLog.DateFormatString Property

TnxStreamEventLog.DateFormatString Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property DateFormatString: string;
Description

This is DateFormatString, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.Enabled Property

TnxStreamEventLog.Enabled Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.EventDispatcher Property

TnxStreamEventLog.EventDispatcher Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property EventDispatcher: TnxBaseEventLogDispatcher;
Description

This is EventDispatcher, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.FormatString Property

TnxStreamEventLog.FormatString Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property FormatString: string;
Description

This is FormatString, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.NumRotations Property

TnxStreamEventLog.NumRotations Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property NumRotations: integer;
Description

This is NumRotations, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.PrioritiesToLog Property

TnxStreamEventLog.PrioritiesToLog Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property PrioritiesToLog: TnxLogPriorities;
Description

This is PrioritiesToLog, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog.RotationSize Property

TnxStreamEventLog.RotationSize Property
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Properties Send Feedback
Syntax
Delphi
property RotationSize: Int64;
Description

This is RotationSize, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Properties

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Properties


TnxStreamEventLog Events

TnxStreamEventLog Events
TnxStreamEventLog Class Legend Published Events Send Feedback

The events of the TnxStreamEventLog class are listed here.

Class

TnxStreamEventLog Class

Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxStreamEventLog.
Links
TnxStreamEventLog Class, Legend, Published Events


TnxStreamEventLog.OnLogDataFilter Event

TnxStreamEventLog.OnLogDataFilter Event
TnxStreamEventLog Class TnxStreamEventLog Members nxlgEventLog Namespace TnxStreamEventLog Events Send Feedback
Syntax
Delphi
property OnLogDataFilter: TnxLogDataFilterEvent;
Description

This is OnLogDataFilter, a member of class TnxStreamEventLog.

Group

TnxStreamEventLog Events

Links
TnxStreamEventLog Class, TnxStreamEventLog Members, nxlgEventLog Namespace, TnxStreamEventLog Events


Types

Types
nxlgEventLog Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxlgEventLog Namespace

Types
Name | Description
TnxLogDataFilterEvent | This is type nxlgEventLog.TnxLogDataFilterEvent.
TnxLogDataFormatterClass | This is type nxlgEventLog.TnxLogDataFormatterClass.
TnxLogDataHandlerClass | This is type nxlgEventLog.TnxLogDataHandlerClass.
Links
nxlgEventLog Namespace, Types


nxlgEventLog.TnxLogDataFilterEvent Type

nxlgEventLog.TnxLogDataFilterEvent Type
nxlgEventLog Types Send Feedback
Syntax
Delphi
TnxLogDataFilterEvent = procedure (const aLogData: InxLogData; var aFiltered: Boolean) of object;
File

nxlgEventLog

Description

This is type nxlgEventLog.TnxLogDataFilterEvent.

Group

Types

Links
nxlgEventLog, Types


nxlgEventLog.TnxLogDataFormatterClass Type

nxlgEventLog.TnxLogDataFormatterClass Type
nxlgEventLog Types Send Feedback
Syntax
Delphi
TnxLogDataFormatterClass = class of TnxBaseLogDataFormatter;
File

nxlgEventLog

Description

This is type nxlgEventLog.TnxLogDataFormatterClass.

Group

Types

Links
nxlgEventLog, Types


nxlgEventLog.TnxLogDataHandlerClass Type

nxlgEventLog.TnxLogDataHandlerClass Type
nxlgEventLog Types Send Feedback
Syntax
Delphi
TnxLogDataHandlerClass = class of TnxBaseLogDataHandler;
File

nxlgEventLog

Description

This is type nxlgEventLog.TnxLogDataHandlerClass.

Group

Types

Links
nxlgEventLog, Types


nxlgEventLogDispatcher Namespace

nxlgEventLogDispatcher Namespace
Classes Legend Topics Send Feedback

This is namespace nxlgEventLogDispatcher.

Classes
Name | Description
TnxEventLogDispatcher | This is class nxlgEventLogDispatcher.TnxEventLogDispatcher.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxlgEventLogDispatcher Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxEventLogDispatcher | This is class nxlgEventLogDispatcher.TnxEventLogDispatcher.
Namespace

nxlgEventLogDispatcher Namespace

Links
Classes, nxlgEventLogDispatcher Namespace, Legend


TnxEventLogDispatcher Class

TnxEventLogDispatcher Class
TnxEventLogDispatcher Methods TnxEventLogDispatcher Properties TnxEventLogDispatcher Members nxlgEventLogDispatcher Classes Send Feedback
Class Hierarchy
nxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatchernxlgEventLogDispatcher_TnxEventLogDispatcher
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxEventLogDispatcher = class(TnxBaseEventLogDispatcher);
File

nxlgEventLogDispatcher

Description

This is class nxlgEventLogDispatcher.TnxEventLogDispatcher.

Group

Classes

Links
TnxEventLogDispatcher Methods, TnxEventLogDispatcher Properties, TnxEventLogDispatcher Members, nxlgEventLogDispatcher, Classes


TnxEventLogDispatcher Members

TnxEventLogDispatcher Members
TnxEventLogDispatcher Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxEventLogDispatcher.

Class

TnxEventLogDispatcher Class

Protected Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxCustomLog.
Protected Fields
Name | Description
beldLoggers | This is beldLoggers, a member of class TnxBaseEventLogDispatcher.
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | TnxEventLogDispatcher
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
EventDispatcher | This is EventDispatcher, a member of class TnxCustomLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxCustomLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
AddLogger | TnxBaseEventLogDispatcher
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Create | TnxCachedEventLog
Create |
Create | constructor
Destroy |
Destroy |
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
RemoveLogger |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxEventLogDispatcher Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Published Properties


TnxEventLogDispatcher Methods

TnxEventLogDispatcher Methods
TnxEventLogDispatcher Class Legend Protected Methods Send Feedback

The methods of the TnxEventLogDispatcher class are listed here.

Class

TnxEventLogDispatcher Class

Protected Methods
Name | Description
clRawWrite | TnxEventLogDispatcher
DoClear |
DoFlush |
PersistLogData |
Links
TnxEventLogDispatcher Class, Legend, Protected Methods


TnxEventLogDispatcher.clRawWrite Method

TnxEventLogDispatcher.clRawWrite Method
TnxEventLogDispatcher Class TnxEventLogDispatcher Members nxlgEventLogDispatcher Namespace TnxEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); override;
Description

TnxEventLogDispatcher

Group

TnxEventLogDispatcher Methods

Links
TnxEventLogDispatcher Class, TnxEventLogDispatcher Members, nxlgEventLogDispatcher Namespace, TnxEventLogDispatcher Methods


TnxEventLogDispatcher.DoClear Method

TnxEventLogDispatcher.DoClear Method
TnxEventLogDispatcher Class TnxEventLogDispatcher Members nxlgEventLogDispatcher Namespace TnxEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure DoClear; override;
Group

TnxEventLogDispatcher Methods

Links
TnxEventLogDispatcher Class, TnxEventLogDispatcher Members, nxlgEventLogDispatcher Namespace, TnxEventLogDispatcher Methods


TnxEventLogDispatcher.DoFlush Method

TnxEventLogDispatcher.DoFlush Method
TnxEventLogDispatcher Class TnxEventLogDispatcher Members nxlgEventLogDispatcher Namespace TnxEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure DoFlush; override;
Group

TnxEventLogDispatcher Methods

Links
TnxEventLogDispatcher Class, TnxEventLogDispatcher Members, nxlgEventLogDispatcher Namespace, TnxEventLogDispatcher Methods


TnxEventLogDispatcher.PersistLogData Method

TnxEventLogDispatcher.PersistLogData Method
TnxEventLogDispatcher Class TnxEventLogDispatcher Members nxlgEventLogDispatcher Namespace TnxEventLogDispatcher Methods Send Feedback
Syntax
Delphi
procedure PersistLogData(const LogData: InxLogData); override;
Group

TnxEventLogDispatcher Methods

Links
TnxEventLogDispatcher Class, TnxEventLogDispatcher Members, nxlgEventLogDispatcher Namespace, TnxEventLogDispatcher Methods


TnxEventLogDispatcher Properties

TnxEventLogDispatcher Properties
TnxEventLogDispatcher Class Legend Published Properties Send Feedback

The properties of the TnxEventLogDispatcher class are listed here.

Class

TnxEventLogDispatcher Class

Published Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Links
TnxEventLogDispatcher Class, Legend, Published Properties


TnxEventLogDispatcher.Enabled Property

TnxEventLogDispatcher.Enabled Property
TnxEventLogDispatcher Class TnxEventLogDispatcher Members nxlgEventLogDispatcher Namespace TnxEventLogDispatcher Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxEventLogDispatcher Properties

Links
TnxEventLogDispatcher Class, TnxEventLogDispatcher Members, nxlgEventLogDispatcher Namespace, TnxEventLogDispatcher Properties


nxlgWinEventLog Namespace

nxlgWinEventLog Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxlgWinEventLog.

Classes
Name | Description
TnxWinEventLog | This is class nxlgWinEventLog.TnxWinEventLog.
Constants
Name | Description
EVENTLOG_AUDIT_FAILURE | This is constant nxlgWinEventLog.EVENTLOG_AUDIT_FAILURE.
EVENTLOG_AUDIT_SUCCESS | This is constant nxlgWinEventLog.EVENTLOG_AUDIT_SUCCESS.
EVENTLOG_ERROR_TYPE | This is constant nxlgWinEventLog.EVENTLOG_ERROR_TYPE.
EVENTLOG_INFORMATION_TYPE | This is constant nxlgWinEventLog.EVENTLOG_INFORMATION_TYPE.
EVENTLOG_SUCCESS | This is constant nxlgWinEventLog.EVENTLOG_SUCCESS.
EVENTLOG_WARNING_TYPE | This is constant nxlgWinEventLog.EVENTLOG_WARNING_TYPE.
EventViewerLogNames | This is constant nxlgWinEventLog.EventViewerLogNames.
EventViewerMsgValues | This is constant nxlgWinEventLog.EventViewerMsgValues.
MESSAGE_RESOURCE_UNICODE | This is constant nxlgWinEventLog.MESSAGE_RESOURCE_UNICODE.
PriorityToMsgType | This is constant nxlgWinEventLog.PriorityToMsgType.
Functions
Name | Description
WriteWinLogEntry | This is function nxlgWinEventLog.WriteWinLogEntry.
Structs, Records, Enums
Name | Description
_MESSAGE_RESOURCE_BLOCK | This is record nxlgWinEventLog._MESSAGE_RESOURCE_BLOCK.
_MESSAGE_RESOURCE_DATA | This is record nxlgWinEventLog._MESSAGE_RESOURCE_DATA.
_MESSAGE_RESOURCE_ENTRY | This is record nxlgWinEventLog._MESSAGE_RESOURCE_ENTRY.
TnxWinEventLogType | This is record nxlgWinEventLog.TnxWinEventLogType.
TnxWinEventMsgType | This is record nxlgWinEventLog.TnxWinEventMsgType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
MESSAGE_RESOURCE_BLOCK | This is type nxlgWinEventLog.MESSAGE_RESOURCE_BLOCK.
MESSAGE_RESOURCE_DATA | This is type nxlgWinEventLog.MESSAGE_RESOURCE_DATA.
MESSAGE_RESOURCE_ENTRY | This is type nxlgWinEventLog.MESSAGE_RESOURCE_ENTRY.
PMESSAGE_RESOURCE_BLOCK | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_BLOCK.
PMESSAGE_RESOURCE_DATA | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_DATA.
PMESSAGE_RESOURCE_ENTRY | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_ENTRY.
PMessageResourceBlock | This is type nxlgWinEventLog.PMessageResourceBlock.
PMessageResourceData | This is type nxlgWinEventLog.PMessageResourceData.
PMessageResourceEntry | This is type nxlgWinEventLog.PMessageResourceEntry.
TMessageResourceBlock | This is type nxlgWinEventLog.TMessageResourceBlock.
TMessageResourceData | This is type nxlgWinEventLog.TMessageResourceData.
TMessageResourceEntry | This is type nxlgWinEventLog.TMessageResourceEntry.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxlgWinEventLog Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxWinEventLog | This is class nxlgWinEventLog.TnxWinEventLog.
Namespace

nxlgWinEventLog Namespace

Links
Classes, nxlgWinEventLog Namespace, Legend


TnxWinEventLog Class

TnxWinEventLog Class
TnxWinEventLog Fields TnxWinEventLog Methods TnxWinEventLog Properties TnxWinEventLog Events TnxWinEventLog Members nxlgWinEventLog Classes Send Feedback
Class Hierarchy
nxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLognxlgWinEventLog_TnxWinEventLog
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxWinEventLog = class(TnxCachedEventLog);
File

nxlgWinEventLog

Description

This is class nxlgWinEventLog.TnxWinEventLog.

Group

Classes

Links
TnxWinEventLog Fields, TnxWinEventLog Methods, TnxWinEventLog Properties, TnxWinEventLog Events, TnxWinEventLog Members, nxlgWinEventLog, Classes


TnxWinEventLog Members

TnxWinEventLog Members
TnxWinEventLog Class Legend Protected Fields Protected Methods Protected Properties Public Methods Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxWinEventLog.

Class

TnxWinEventLog Class

Protected Fields
Name | Description
blEnabled | private
celCache | private
celDiscardOnDestruction | This is celDiscardOnDestruction, a member of class TnxCachedEventLog.
clDateFormatString | This is clDateFormatString, a member of class TnxCustomLog.
clEventDispatcher | This is clEventDispatcher, a member of class TnxCustomLog.
clFormatString | This is clFormatString, a member of class TnxCustomLog.
clLogDataFormatter | This is clLogDataFormatter, a member of class TnxCustomLog.
clLogDataHandler | This is clLogDataHandler, a member of class TnxCustomLog.
clOnLogDataFilter | This is clOnLogDataFilter, a member of class TnxCustomLog.
clPrioritiesToLog | This is clPrioritiesToLog, a member of class TnxCustomLog.
clStorageLock | This is clStorageLock, a member of class TnxCustomLog.
clWriteBlockData | This is clWriteBlockData, a member of class TnxCustomLog.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
welCategories | This is welCategories, a member of class TnxWinEventLog.
welDefaultCategory | This is welDefaultCategory, a member of class TnxWinEventLog.
welDefaultCategoryNum | This is welDefaultCategoryNum, a member of class TnxWinEventLog.
welDefaultMsgPriority | This is welDefaultMsgPriority, a member of class TnxWinEventLog.
welEventViewer | This is welEventViewer, a member of class TnxWinEventLog.
welRegistryNeedsUpdate | This is welRegistryNeedsUpdate, a member of class TnxWinEventLog.
welResourceDllFileName | This is welResourceDllFileName, a member of class TnxWinEventLog.
welSourceName | This is welSourceName, a member of class TnxWinEventLog.
welUseMessageNumbers | This is welUseMessageNumbers, a member of class TnxWinEventLog.
welWinEventLogType | This is welWinEventLogType, a member of class TnxWinEventLog.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
BlockToStrings |
blSetEnabled |
blUnlockLog |
celSetCache |
clGetLogDataFormatter |
clGetLogDataHandler |
clGetLogDataHandler |
clLockStorage | TnxCustomLog
clRawWrite | TnxWinEventLog
clSetDateFormatString |
clSetEventDispatcher |
clSetFormatString |
clUnlockStorage |
DoClear |
DoFlush |
FilterLogData |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
LogEvent |
LookupCategoryNum |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
PersistLogData |
rcRegister |
rcUnregister |
ReadCategoriesFromResourceFile |
ResetDefaultCategoryNum |
SetDefaultCategory |
SetName |
SetResourceDllFileName |
SetWinEventLogType |
UpdateRegistryEventSource |
Protected Properties
Name | Description
DateFormatString | This is DateFormatString, a member of class TnxCustomLog.
DiscardOnDestruction | This is DiscardOnDestruction, a member of class TnxCachedEventLog.
FormatString | This is FormatString, a member of class TnxCustomLog.
WinEventLogType | This is WinEventLogType, a member of class TnxWinEventLog.
WriteBlockData | This is WriteBlockData, a member of class TnxCustomLog.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear |
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush |
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetCategories |
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDefaultResourceFile |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
RegisterEventViewerSource |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
UnRegisterEventViewerSource |
WriteBlock |
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData |
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteString | This is the overview for the WriteString method overload.
WriteStrings |
WriteStrings | Writes a string to the log.
Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxWinEventLog.
Published Properties
Name | Description
CacheEnabled | This is CacheEnabled, a member of class TnxCachedEventLog.
DefaultCategory | This is DefaultCategory, a member of class TnxWinEventLog.
DefaultMsgPriority | This is DefaultMsgPriority, a member of class TnxWinEventLog.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxWinEventLog.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxWinEventLog.
RegistryNeedsUpdate | This is RegistryNeedsUpdate, a member of class TnxWinEventLog.
ResourceDllFileName | This is ResourceDllFileName, a member of class TnxWinEventLog.
SourceName | This is SourceName, a member of class TnxWinEventLog.
UseMessageNumbers | This is UseMessageNumbers, a member of class TnxWinEventLog.
Version | Version of the component.
Links
TnxWinEventLog Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Published Events, Published Properties


TnxWinEventLog.Create Constructor

TnxWinEventLog.Create Constructor
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxWinEventLog Class

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Class


TnxWinEventLog.Destroy Destructor

TnxWinEventLog.Destroy Destructor
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxWinEventLog Class

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Class


TnxWinEventLog Fields

TnxWinEventLog Fields
TnxWinEventLog Class Legend Protected Fields Send Feedback

The fields of the TnxWinEventLog class are listed here.

Class

TnxWinEventLog Class

Protected Fields
Name | Description
welCategories | This is welCategories, a member of class TnxWinEventLog.
welDefaultCategory | This is welDefaultCategory, a member of class TnxWinEventLog.
welDefaultCategoryNum | This is welDefaultCategoryNum, a member of class TnxWinEventLog.
welDefaultMsgPriority | This is welDefaultMsgPriority, a member of class TnxWinEventLog.
welEventViewer | This is welEventViewer, a member of class TnxWinEventLog.
welRegistryNeedsUpdate | This is welRegistryNeedsUpdate, a member of class TnxWinEventLog.
welResourceDllFileName | This is welResourceDllFileName, a member of class TnxWinEventLog.
welSourceName | This is welSourceName, a member of class TnxWinEventLog.
welUseMessageNumbers | This is welUseMessageNumbers, a member of class TnxWinEventLog.
welWinEventLogType | This is welWinEventLogType, a member of class TnxWinEventLog.
Links
TnxWinEventLog Class, Legend, Protected Fields


TnxWinEventLog.welCategories Field

TnxWinEventLog.welCategories Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welCategories: TStringList;
Description

This is welCategories, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welDefaultCategory Field

TnxWinEventLog.welDefaultCategory Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welDefaultCategory: string;
Description

This is welDefaultCategory, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welDefaultCategoryNum Field

TnxWinEventLog.welDefaultCategoryNum Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welDefaultCategoryNum: integer;
Description

This is welDefaultCategoryNum, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welDefaultMsgPriority Field

TnxWinEventLog.welDefaultMsgPriority Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welDefaultMsgPriority: TnxLogPriority;
Description

This is welDefaultMsgPriority, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welEventViewer Field

TnxWinEventLog.welEventViewer Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welEventViewer: THandle;
Description

This is welEventViewer, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welRegistryNeedsUpdate Field

TnxWinEventLog.welRegistryNeedsUpdate Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welRegistryNeedsUpdate: Boolean;
Description

This is welRegistryNeedsUpdate, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welResourceDllFileName Field

TnxWinEventLog.welResourceDllFileName Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welResourceDllFileName: string;
Description

This is welResourceDllFileName, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welSourceName Field

TnxWinEventLog.welSourceName Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welSourceName: string;
Description

This is welSourceName, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welUseMessageNumbers Field

TnxWinEventLog.welUseMessageNumbers Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welUseMessageNumbers: boolean;
Description

This is welUseMessageNumbers, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog.welWinEventLogType Field

TnxWinEventLog.welWinEventLogType Field
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Fields Send Feedback
Syntax
Delphi
welWinEventLogType: TnxWinEventLogType;
Description

This is welWinEventLogType, a member of class TnxWinEventLog.

Group

TnxWinEventLog Fields

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Fields


TnxWinEventLog Methods

TnxWinEventLog Methods
TnxWinEventLog Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWinEventLog class are listed here.

Class

TnxWinEventLog Class

Protected Methods
Name | Description
blSetEnabled |
clRawWrite | TnxWinEventLog
LogEvent |
LookupCategoryNum |
PersistLogData |
ReadCategoriesFromResourceFile |
ResetDefaultCategoryNum |
SetDefaultCategory |
SetName |
SetResourceDllFileName |
SetWinEventLogType |
UpdateRegistryEventSource |
Public Methods
Name | Description
GetCategories |
GetDefaultResourceFile |
RegisterEventViewerSource |
UnRegisterEventViewerSource |
Links
TnxWinEventLog Class, Legend, Protected Methods, Public Methods


TnxWinEventLog.blSetEnabled Method

TnxWinEventLog.blSetEnabled Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure blSetEnabled(const Value: Boolean); override;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.clRawWrite Method

TnxWinEventLog.clRawWrite Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure clRawWrite(const LogStr: string); override;
Description

TnxWinEventLog

Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.GetCategories Method

TnxWinEventLog.GetCategories Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure GetCategories(Categories: TStrings);
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.GetDefaultResourceFile Method

TnxWinEventLog.GetDefaultResourceFile Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
class function GetDefaultResourceFile: string; virtual;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.LogEvent Method

TnxWinEventLog.LogEvent Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure LogEvent(const MsgType: TnxWinEventMsgType; const Category: Word; const EventId: Integer; const EventMsg: string); virtual;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.LookupCategoryNum Method

TnxWinEventLog.LookupCategoryNum Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
function LookupCategoryNum(const Category: string; const DefaultCategoryNum: Integer): Integer;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.PersistLogData Method

TnxWinEventLog.PersistLogData Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure PersistLogData(const LogData: InxLogData); override;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.ReadCategoriesFromResourceFile Method

TnxWinEventLog.ReadCategoriesFromResourceFile Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure ReadCategoriesFromResourceFile(const ResourceFile: string);
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.RegisterEventViewerSource Method

TnxWinEventLog.RegisterEventViewerSource Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
class function RegisterEventViewerSource(const LogType: TnxWinEventLogType; const LogName: string; const SourceName: string; const ResourceFile: string; const CategoryCount: integer): Boolean;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.ResetDefaultCategoryNum Method

TnxWinEventLog.ResetDefaultCategoryNum Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure ResetDefaultCategoryNum;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.SetDefaultCategory Method

TnxWinEventLog.SetDefaultCategory Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure SetDefaultCategory(const Value: string);
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.SetName Method

TnxWinEventLog.SetName Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure SetName(const NewName: TComponentName); override;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.SetResourceDllFileName Method

TnxWinEventLog.SetResourceDllFileName Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure SetResourceDllFileName(const Value: string);
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.SetWinEventLogType Method

TnxWinEventLog.SetWinEventLogType Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure SetWinEventLogType(const Value: TnxWinEventLogType);
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.UnRegisterEventViewerSource Method

TnxWinEventLog.UnRegisterEventViewerSource Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
class function UnRegisterEventViewerSource(const LogType: TnxWinEventLogType; const LogName: string; const SourceName: string): Boolean;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog.UpdateRegistryEventSource Method

TnxWinEventLog.UpdateRegistryEventSource Method
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Methods Send Feedback
Syntax
Delphi
procedure UpdateRegistryEventSource;
Group

TnxWinEventLog Methods

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Methods


TnxWinEventLog Properties

TnxWinEventLog Properties
TnxWinEventLog Class Legend Protected Properties Published Properties Send Feedback

The properties of the TnxWinEventLog class are listed here.

Class

TnxWinEventLog Class

Protected Properties
Name | Description
WinEventLogType | This is WinEventLogType, a member of class TnxWinEventLog.
Published Properties
Name | Description
DefaultCategory | This is DefaultCategory, a member of class TnxWinEventLog.
DefaultMsgPriority | This is DefaultMsgPriority, a member of class TnxWinEventLog.
Enabled | True if the log is currently enabled/active.
EventDispatcher | This is EventDispatcher, a member of class TnxWinEventLog.
PrioritiesToLog | This is PrioritiesToLog, a member of class TnxWinEventLog.
RegistryNeedsUpdate | This is RegistryNeedsUpdate, a member of class TnxWinEventLog.
ResourceDllFileName | This is ResourceDllFileName, a member of class TnxWinEventLog.
SourceName | This is SourceName, a member of class TnxWinEventLog.
UseMessageNumbers | This is UseMessageNumbers, a member of class TnxWinEventLog.
Links
TnxWinEventLog Class, Legend, Protected Properties, Published Properties


TnxWinEventLog.DefaultCategory Property

TnxWinEventLog.DefaultCategory Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property DefaultCategory: string;
Description

This is DefaultCategory, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.DefaultMsgPriority Property

TnxWinEventLog.DefaultMsgPriority Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property DefaultMsgPriority: TnxLogPriority;
Description

This is DefaultMsgPriority, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.Enabled Property

TnxWinEventLog.Enabled Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.EventDispatcher Property

TnxWinEventLog.EventDispatcher Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property EventDispatcher: TnxBaseEventLogDispatcher;
Description

This is EventDispatcher, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.PrioritiesToLog Property

TnxWinEventLog.PrioritiesToLog Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property PrioritiesToLog: TnxLogPriorities;
Description

This is PrioritiesToLog, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.RegistryNeedsUpdate Property

TnxWinEventLog.RegistryNeedsUpdate Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property RegistryNeedsUpdate: Boolean;
Description

This is RegistryNeedsUpdate, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.ResourceDllFileName Property

TnxWinEventLog.ResourceDllFileName Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property ResourceDllFileName: string;
Description

This is ResourceDllFileName, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.SourceName Property

TnxWinEventLog.SourceName Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property SourceName: string;
Description

This is SourceName, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.UseMessageNumbers Property

TnxWinEventLog.UseMessageNumbers Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property UseMessageNumbers: boolean;
Description

This is UseMessageNumbers, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog.WinEventLogType Property

TnxWinEventLog.WinEventLogType Property
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Properties Send Feedback
Syntax
Delphi
property WinEventLogType: TnxWinEventLogType;
Description

This is WinEventLogType, a member of class TnxWinEventLog.

Group

TnxWinEventLog Properties

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Properties


TnxWinEventLog Events

TnxWinEventLog Events
TnxWinEventLog Class Legend Published Events Send Feedback

The events of the TnxWinEventLog class are listed here.

Class

TnxWinEventLog Class

Published Events
Name | Description
OnLogDataFilter | This is OnLogDataFilter, a member of class TnxWinEventLog.
Links
TnxWinEventLog Class, Legend, Published Events


TnxWinEventLog.OnLogDataFilter Event

TnxWinEventLog.OnLogDataFilter Event
TnxWinEventLog Class TnxWinEventLog Members nxlgWinEventLog Namespace TnxWinEventLog Events Send Feedback
Syntax
Delphi
property OnLogDataFilter: TnxLogDataFilterEvent;
Description

This is OnLogDataFilter, a member of class TnxWinEventLog.

Group

TnxWinEventLog Events

Links
TnxWinEventLog Class, TnxWinEventLog Members, nxlgWinEventLog Namespace, TnxWinEventLog Events


Functions

Functions
Functions nxlgWinEventLog Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
WriteWinLogEntry | This is function nxlgWinEventLog.WriteWinLogEntry.
Namespace

nxlgWinEventLog Namespace

Links
Functions, nxlgWinEventLog Namespace, Legend


nxlgWinEventLog.WriteWinLogEntry Function

nxlgWinEventLog.WriteWinLogEntry Function
nxlgWinEventLog Functions Send Feedback
Syntax
Delphi
procedure WriteWinLogEntry(const aEventLogName: string; const aMsg: string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED);
File

nxlgWinEventLog

Description

This is function nxlgWinEventLog.WriteWinLogEntry.

Group

Functions

Links
nxlgWinEventLog, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxlgWinEventLog Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxWinEventLogType | This is record nxlgWinEventLog.TnxWinEventLogType.
TnxWinEventMsgType | This is record nxlgWinEventLog.TnxWinEventMsgType.
Namespace

nxlgWinEventLog Namespace

Records
Name | Description
_MESSAGE_RESOURCE_BLOCK | This is record nxlgWinEventLog._MESSAGE_RESOURCE_BLOCK.
_MESSAGE_RESOURCE_DATA | This is record nxlgWinEventLog._MESSAGE_RESOURCE_DATA.
_MESSAGE_RESOURCE_ENTRY | This is record nxlgWinEventLog._MESSAGE_RESOURCE_ENTRY.
Links
Enumerations, nxlgWinEventLog Namespace, Legend, Records


nxlgWinEventLog._MESSAGE_RESOURCE_BLOCK Record

nxlgWinEventLog._MESSAGE_RESOURCE_BLOCK Record
nxlgWinEventLog Structs, Records, Enums Send Feedback
Syntax
Delphi
_MESSAGE_RESOURCE_BLOCK = packed record
  LowId: DWORD;
  HighId: DWORD;
  OffsetToEntries: DWORD;
end;
File

nxlgWinEventLog

Description

This is record nxlgWinEventLog._MESSAGE_RESOURCE_BLOCK.

Group

Structs, Records, Enums

Links
nxlgWinEventLog, Structs, Records, Enums


nxlgWinEventLog._MESSAGE_RESOURCE_DATA Record

nxlgWinEventLog._MESSAGE_RESOURCE_DATA Record
nxlgWinEventLog Structs, Records, Enums Send Feedback
Syntax
Delphi
_MESSAGE_RESOURCE_DATA = packed record
  NumberOfBlocks: DWORD;
  Blocks: array [0..0] of MESSAGE_RESOURCE_BLOCK;
end;
File

nxlgWinEventLog

Description

This is record nxlgWinEventLog._MESSAGE_RESOURCE_DATA.

Group

Structs, Records, Enums

Links
nxlgWinEventLog, Structs, Records, Enums


nxlgWinEventLog._MESSAGE_RESOURCE_ENTRY Record

nxlgWinEventLog._MESSAGE_RESOURCE_ENTRY Record
nxlgWinEventLog Structs, Records, Enums Send Feedback
Syntax
Delphi
_MESSAGE_RESOURCE_ENTRY = packed record
  Length: Word;
  Flags: Word;
  Text: array [0..0] of Byte;
end;
File

nxlgWinEventLog

Description

This is record nxlgWinEventLog._MESSAGE_RESOURCE_ENTRY.

Group

Structs, Records, Enums

Links
nxlgWinEventLog, Structs, Records, Enums


nxlgWinEventLog.TnxWinEventLogType Enumeration

nxlgWinEventLog.TnxWinEventLogType Enumeration
nxlgWinEventLog Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWinEventLogType = ( elApplication, elSecurity, elSystem );
File

nxlgWinEventLog

Description

This is record nxlgWinEventLog.TnxWinEventLogType.

Group

Structs, Records, Enums

Links
nxlgWinEventLog, Structs, Records, Enums


nxlgWinEventLog.TnxWinEventMsgType Enumeration

nxlgWinEventLog.TnxWinEventMsgType Enumeration
nxlgWinEventLog Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWinEventMsgType = ( emSuccess, emError, emWarning, emInformation, emAuditSuccess, emAuditFailure );
File

nxlgWinEventLog

Description

This is record nxlgWinEventLog.TnxWinEventMsgType.

Group

Structs, Records, Enums

Links
nxlgWinEventLog, Structs, Records, Enums


Types

Types
nxlgWinEventLog Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxlgWinEventLog Namespace

Types
Name | Description
MESSAGE_RESOURCE_BLOCK | This is type nxlgWinEventLog.MESSAGE_RESOURCE_BLOCK.
MESSAGE_RESOURCE_DATA | This is type nxlgWinEventLog.MESSAGE_RESOURCE_DATA.
MESSAGE_RESOURCE_ENTRY | This is type nxlgWinEventLog.MESSAGE_RESOURCE_ENTRY.
PMESSAGE_RESOURCE_BLOCK | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_BLOCK.
PMESSAGE_RESOURCE_DATA | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_DATA.
PMESSAGE_RESOURCE_ENTRY | This is type nxlgWinEventLog.PMESSAGE_RESOURCE_ENTRY.
PMessageResourceBlock | This is type nxlgWinEventLog.PMessageResourceBlock.
PMessageResourceData | This is type nxlgWinEventLog.PMessageResourceData.
PMessageResourceEntry | This is type nxlgWinEventLog.PMessageResourceEntry.
TMessageResourceBlock | This is type nxlgWinEventLog.TMessageResourceBlock.
TMessageResourceData | This is type nxlgWinEventLog.TMessageResourceData.
TMessageResourceEntry | This is type nxlgWinEventLog.TMessageResourceEntry.
Links
nxlgWinEventLog Namespace, Types


nxlgWinEventLog.MESSAGE_RESOURCE_BLOCK Type

nxlgWinEventLog.MESSAGE_RESOURCE_BLOCK Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
MESSAGE_RESOURCE_BLOCK = _MESSAGE_RESOURCE_BLOCK;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.MESSAGE_RESOURCE_BLOCK.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.MESSAGE_RESOURCE_DATA Type

nxlgWinEventLog.MESSAGE_RESOURCE_DATA Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
MESSAGE_RESOURCE_DATA = _MESSAGE_RESOURCE_DATA;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.MESSAGE_RESOURCE_DATA.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.MESSAGE_RESOURCE_ENTRY Type

nxlgWinEventLog.MESSAGE_RESOURCE_ENTRY Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
MESSAGE_RESOURCE_ENTRY = _MESSAGE_RESOURCE_ENTRY;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.MESSAGE_RESOURCE_ENTRY.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMESSAGE_RESOURCE_BLOCK Type

nxlgWinEventLog.PMESSAGE_RESOURCE_BLOCK Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMESSAGE_RESOURCE_BLOCK = ^MESSAGE_RESOURCE_BLOCK;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMESSAGE_RESOURCE_BLOCK.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMESSAGE_RESOURCE_DATA Type

nxlgWinEventLog.PMESSAGE_RESOURCE_DATA Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMESSAGE_RESOURCE_DATA = ^MESSAGE_RESOURCE_DATA;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMESSAGE_RESOURCE_DATA.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMESSAGE_RESOURCE_ENTRY Type

nxlgWinEventLog.PMESSAGE_RESOURCE_ENTRY Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMESSAGE_RESOURCE_ENTRY = ^MESSAGE_RESOURCE_ENTRY;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMESSAGE_RESOURCE_ENTRY.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMessageResourceBlock Type

nxlgWinEventLog.PMessageResourceBlock Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMessageResourceBlock = PMESSAGE_RESOURCE_BLOCK;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMessageResourceBlock.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMessageResourceData Type

nxlgWinEventLog.PMessageResourceData Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMessageResourceData = PMESSAGE_RESOURCE_DATA;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMessageResourceData.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.PMessageResourceEntry Type

nxlgWinEventLog.PMessageResourceEntry Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
PMessageResourceEntry = PMESSAGE_RESOURCE_ENTRY;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.PMessageResourceEntry.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.TMessageResourceBlock Type

nxlgWinEventLog.TMessageResourceBlock Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
TMessageResourceBlock = MESSAGE_RESOURCE_BLOCK;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.TMessageResourceBlock.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.TMessageResourceData Type

nxlgWinEventLog.TMessageResourceData Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
TMessageResourceData = MESSAGE_RESOURCE_DATA;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.TMessageResourceData.

Group

Types

Links
nxlgWinEventLog, Types


nxlgWinEventLog.TMessageResourceEntry Type

nxlgWinEventLog.TMessageResourceEntry Type
nxlgWinEventLog Types Send Feedback
Syntax
Delphi
TMessageResourceEntry = MESSAGE_RESOURCE_ENTRY;
File

nxlgWinEventLog

Description

This is type nxlgWinEventLog.TMessageResourceEntry.

Group

Types

Links
nxlgWinEventLog, Types


Constants

Constants
Constants nxlgWinEventLog Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EVENTLOG_AUDIT_FAILURE | This is constant nxlgWinEventLog.EVENTLOG_AUDIT_FAILURE.
EVENTLOG_AUDIT_SUCCESS | This is constant nxlgWinEventLog.EVENTLOG_AUDIT_SUCCESS.
EVENTLOG_ERROR_TYPE | This is constant nxlgWinEventLog.EVENTLOG_ERROR_TYPE.
EVENTLOG_INFORMATION_TYPE | This is constant nxlgWinEventLog.EVENTLOG_INFORMATION_TYPE.
EVENTLOG_SUCCESS | This is constant nxlgWinEventLog.EVENTLOG_SUCCESS.
EVENTLOG_WARNING_TYPE | This is constant nxlgWinEventLog.EVENTLOG_WARNING_TYPE.
EventViewerLogNames | This is constant nxlgWinEventLog.EventViewerLogNames.
EventViewerMsgValues | This is constant nxlgWinEventLog.EventViewerMsgValues.
MESSAGE_RESOURCE_UNICODE | This is constant nxlgWinEventLog.MESSAGE_RESOURCE_UNICODE.
PriorityToMsgType | This is constant nxlgWinEventLog.PriorityToMsgType.
Namespace

nxlgWinEventLog Namespace

Links
Constants, nxlgWinEventLog Namespace


nxlgWinEventLog.EVENTLOG_AUDIT_FAILURE Constant

nxlgWinEventLog.EVENTLOG_AUDIT_FAILURE Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_AUDIT_FAILURE = $0010;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_AUDIT_FAILURE.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EVENTLOG_AUDIT_SUCCESS Constant

nxlgWinEventLog.EVENTLOG_AUDIT_SUCCESS Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_AUDIT_SUCCESS = $0008;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_AUDIT_SUCCESS.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EVENTLOG_ERROR_TYPE Constant

nxlgWinEventLog.EVENTLOG_ERROR_TYPE Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_ERROR_TYPE = $0001;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_ERROR_TYPE.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EVENTLOG_INFORMATION_TYPE Constant

nxlgWinEventLog.EVENTLOG_INFORMATION_TYPE Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_INFORMATION_TYPE = $0004;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_INFORMATION_TYPE.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EVENTLOG_SUCCESS Constant

nxlgWinEventLog.EVENTLOG_SUCCESS Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_SUCCESS = $0000;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_SUCCESS.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EVENTLOG_WARNING_TYPE Constant

nxlgWinEventLog.EVENTLOG_WARNING_TYPE Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EVENTLOG_WARNING_TYPE = $0002;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EVENTLOG_WARNING_TYPE.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EventViewerLogNames Constant

nxlgWinEventLog.EventViewerLogNames Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EventViewerLogNames: array[elApplication..elSystem] of string = ('Application', 'Security', 'System');
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EventViewerLogNames.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.EventViewerMsgValues Constant

nxlgWinEventLog.EventViewerMsgValues Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
EventViewerMsgValues: array[emSuccess..emAuditFailure] of Word = (EVENTLOG_SUCCESS, EVENTLOG_ERROR_TYPE, EVENTLOG_WARNING_TYPE, EVENTLOG_INFORMATION_TYPE, EVENTLOG_AUDIT_SUCCESS, EVENTLOG_AUDIT_FAILURE);
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.EventViewerMsgValues.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.MESSAGE_RESOURCE_UNICODE Constant

nxlgWinEventLog.MESSAGE_RESOURCE_UNICODE Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
MESSAGE_RESOURCE_UNICODE = $0001;
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.MESSAGE_RESOURCE_UNICODE.

Group

Constants

Links
nxlgWinEventLog, Constants


nxlgWinEventLog.PriorityToMsgType Constant

nxlgWinEventLog.PriorityToMsgType Constant
nxlgWinEventLog Constants Send Feedback
Syntax
Delphi
PriorityToMsgType: array[lpDebug..lpFatal] of TnxWinEventMsgType = (emInformation, emInformation, emWarning, emError, emError);
File

nxlgWinEventLog

Description

This is constant nxlgWinEventLog.PriorityToMsgType.

Group

Constants

Links
nxlgWinEventLog, Constants


nxllBackgroundThread Namespace

nxllBackgroundThread Namespace
Classes Legend Topics Send Feedback

This is namespace nxllBackgroundThread.

Classes
Name | Description
TnxBackgroundThread | This is class nxllBackgroundThread.TnxBackgroundThread.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxllBackgroundThread Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBackgroundThread | This is class nxllBackgroundThread.TnxBackgroundThread.
Namespace

nxllBackgroundThread Namespace

Links
Classes, nxllBackgroundThread Namespace, Legend


TnxBackgroundThread Class

TnxBackgroundThread Class
TnxBackgroundThread Fields TnxBackgroundThread Methods TnxBackgroundThread Members nxllBackgroundThread Classes Send Feedback
Class Hierarchy
nxllBackgroundThread_TnxBackgroundThreadnxllBackgroundThread_TnxBackgroundThread
Syntax
Delphi
TnxBackgroundThread = class(TnxObject);
File

nxllBackgroundThread

Description

This is class nxllBackgroundThread.TnxBackgroundThread.

Group

Classes

Links
TnxBackgroundThread Fields, TnxBackgroundThread Methods, TnxBackgroundThread Members, nxllBackgroundThread, Classes


TnxBackgroundThread Members

TnxBackgroundThread Members
TnxBackgroundThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBackgroundThread.

Class

TnxBackgroundThread Class

Protected Fields
Name | Description
btDieEvent | This is btDieEvent, a member of class TnxBackgroundThread.
btMutexHandle | This is btMutexHandle, a member of class TnxBackgroundThread.
btTerminated | This is btTerminated, a member of class TnxBackgroundThread.
btThreadDoneEvent | This is btThreadDoneEvent, a member of class TnxBackgroundThread.
btThreadHandle | This is btThreadHandle, a member of class TnxBackgroundThread.
btThreadID | private
Protected Methods
Name | Description
BeforeRun |
DoExecute | This is DoExecute, a member of class TnxBackgroundThread.
GetName |
Public Methods
Name | Description
Create |
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxBackgroundThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBackgroundThread.Create Constructor

TnxBackgroundThread.Create Constructor
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxBackgroundThread Class

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Class


TnxBackgroundThread.Destroy Destructor

TnxBackgroundThread.Destroy Destructor
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBackgroundThread Class

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Class


TnxBackgroundThread Fields

TnxBackgroundThread Fields
TnxBackgroundThread Class Legend Protected Fields Send Feedback

The fields of the TnxBackgroundThread class are listed here.

Class

TnxBackgroundThread Class

Protected Fields
Name | Description
btDieEvent | This is btDieEvent, a member of class TnxBackgroundThread.
btMutexHandle | This is btMutexHandle, a member of class TnxBackgroundThread.
btTerminated | This is btTerminated, a member of class TnxBackgroundThread.
btThreadDoneEvent | This is btThreadDoneEvent, a member of class TnxBackgroundThread.
btThreadHandle | This is btThreadHandle, a member of class TnxBackgroundThread.
btThreadID | private
Links
TnxBackgroundThread Class, Legend, Protected Fields


TnxBackgroundThread.btDieEvent Field

TnxBackgroundThread.btDieEvent Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btDieEvent: THandle;
Description

This is btDieEvent, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread.btMutexHandle Field

TnxBackgroundThread.btMutexHandle Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btMutexHandle: THandle;
Description

This is btMutexHandle, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread.btTerminated Field

TnxBackgroundThread.btTerminated Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btTerminated: Boolean;
Description

This is btTerminated, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread.btThreadDoneEvent Field

TnxBackgroundThread.btThreadDoneEvent Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btThreadDoneEvent: THandle;
Description

This is btThreadDoneEvent, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread.btThreadHandle Field

TnxBackgroundThread.btThreadHandle Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btThreadHandle: THandle;
Description

This is btThreadHandle, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread.btThreadID Field

TnxBackgroundThread.btThreadID Field
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Fields Send Feedback
Syntax
Delphi
btThreadID: Cardinal;
Description

private

Group

TnxBackgroundThread Fields

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Fields


TnxBackgroundThread Methods

TnxBackgroundThread Methods
TnxBackgroundThread Class Legend Protected Methods Send Feedback

The methods of the TnxBackgroundThread class are listed here.

Class

TnxBackgroundThread Class

Protected Methods
Name | Description
BeforeRun |
DoExecute | This is DoExecute, a member of class TnxBackgroundThread.
GetName |
Links
TnxBackgroundThread Class, Legend, Protected Methods


TnxBackgroundThread.BeforeRun Method

TnxBackgroundThread.BeforeRun Method
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Methods Send Feedback
Syntax
Delphi
procedure BeforeRun; virtual;
Group

TnxBackgroundThread Methods

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Methods


TnxBackgroundThread.DoExecute Method

TnxBackgroundThread.DoExecute Method
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; virtual; abstract;
Description

This is DoExecute, a member of class TnxBackgroundThread.

Group

TnxBackgroundThread Methods

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Methods


TnxBackgroundThread.GetName Method

TnxBackgroundThread.GetName Method
TnxBackgroundThread Class TnxBackgroundThread Members nxllBackgroundThread Namespace TnxBackgroundThread Methods Send Feedback
Syntax
Delphi
function GetName: AnsiString; virtual;
Group

TnxBackgroundThread Methods

Links
TnxBackgroundThread Class, TnxBackgroundThread Members, nxllBackgroundThread Namespace, TnxBackgroundThread Methods


nxllBase64 Namespace

nxllBase64 Namespace
Constants Functions Legend Topics Types Send Feedback

This is namespace nxllBase64.

Constants
Name | Description
Base64Code | This is constant nxllBase64.Base64Code.
Pad | This is constant nxllBase64.Pad.
Functions
Name | Description
Base64ToStr |
StrTobase64 | This is function nxllBase64.StrTobase64.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EBase64Error | This is type nxllBase64.EBase64Error.
Links
Constants, Functions, Legend, Topics, Types


Functions

Functions
Functions nxllBase64 Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
Base64ToStr |
StrTobase64 | This is function nxllBase64.StrTobase64.
Namespace

nxllBase64 Namespace

Links
Functions, nxllBase64 Namespace, Legend


nxllBase64.Base64ToStr Function

nxllBase64.Base64ToStr Function
nxllBase64 Functions Send Feedback
Syntax
Delphi
function Base64ToStr(B64: AnsiString): AnsiString;
File

nxllBase64

Group

Functions

Links
nxllBase64, Functions


nxllBase64.StrTobase64 Function

nxllBase64.StrTobase64 Function
nxllBase64 Functions Send Feedback
Syntax
Delphi
function StrTobase64(Buf: AnsiString): AnsiString;
File

nxllBase64

Description

This is function nxllBase64.StrTobase64.

Group

Functions

Links
nxllBase64, Functions


Types

Types
nxllBase64 Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllBase64 Namespace

Types
Name | Description
EBase64Error | This is type nxllBase64.EBase64Error.
Links
nxllBase64 Namespace, Types


nxllBase64.EBase64Error Type

nxllBase64.EBase64Error Type
nxllBase64 Types Send Feedback
Syntax
Delphi
EBase64Error = Exception;
File

nxllBase64

Description

This is type nxllBase64.EBase64Error.

Group

Types

Links
nxllBase64, Types


Constants

Constants
Constants nxllBase64 Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
Base64Code | This is constant nxllBase64.Base64Code.
Pad | This is constant nxllBase64.Pad.
Namespace

nxllBase64 Namespace

Links
Constants, nxllBase64 Namespace


nxllBase64.Base64Code Constant

nxllBase64.Base64Code Constant
nxllBase64 Constants Send Feedback
Syntax
Delphi
Base64Code: AnsiString = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' + 'abcdefghijklmnopqrstuvwxyz' + '0123456789+/';
File

nxllBase64

Description

This is constant nxllBase64.Base64Code.

Group

Constants

Links
nxllBase64, Constants


nxllBase64.Pad Constant

nxllBase64.Pad Constant
nxllBase64 Constants Send Feedback
Syntax
Delphi
Pad: AnsiChar = '=';
File

nxllBase64

Description

This is constant nxllBase64.Pad.

Group

Constants

Links
nxllBase64, Constants


nxllBaseCipher Namespace

nxllBaseCipher Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxllBaseCipher.

Classes
Name | Description
EnxBaseCipherException | This is class nxllBaseCipher.EnxBaseCipherException.
TnxBaseCipher | This is class nxllBaseCipher.TnxBaseCipher.
Constants
Name | Description
rsAltCipherLocked | This is constant nxllBaseCipher.rsAltCipherLocked.
rsNoAltCipherRegistered | This is constant nxllBaseCipher.rsNoAltCipherRegistered.
rsUnableToFindKeyWrapClass | This is constant nxllBaseCipher.rsUnableToFindKeyWrapClass.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBaseCipherClass | This is type nxllBaseCipher.TnxBaseCipherClass.
Variables
Name | Description
_AltClass | This is variable nxllBaseCipher._AltClass.
_AltClassList | This is variable nxllBaseCipher._AltClassList.
_AltClassNeedsCheck | This is variable nxllBaseCipher._AltClassNeedsCheck.
_AltClassPadlock | This is variable nxllBaseCipher._AltClassPadlock.
_AltLock | This is variable nxllBaseCipher._AltLock.
_KeyWrapList | This is variable nxllBaseCipher._KeyWrapList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxllBaseCipher Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseCipherException | This is class nxllBaseCipher.EnxBaseCipherException.
TnxBaseCipher | This is class nxllBaseCipher.TnxBaseCipher.
Namespace

nxllBaseCipher Namespace

Links
Classes, nxllBaseCipher Namespace, Legend


EnxBaseCipherException Class

EnxBaseCipherException Class
nxllBaseCipher Classes Send Feedback
Class Hierarchy
nxllBaseCipher_EnxBaseCipherExceptionnxllBaseCipher_EnxBaseCipherExceptionnxllBaseCipher_EnxBaseCipherExceptionnxllBaseCipher_EnxBaseCipherException
Syntax
Delphi
EnxBaseCipherException = class(EnxBaseException);
File

nxllBaseCipher

Description

This is class nxllBaseCipher.EnxBaseCipherException.

Group

Classes

Links
nxllBaseCipher, Classes


TnxBaseCipher Class

TnxBaseCipher Class
TnxBaseCipher Methods TnxBaseCipher Members nxllBaseCipher Classes Send Feedback
Class Hierarchy
nxllBaseCipher_TnxBaseCiphernxllBaseCipher_TnxBaseCipher
Syntax
Delphi
TnxBaseCipher = class(TnxObject);
File

nxllBaseCipher

Description

This is class nxllBaseCipher.TnxBaseCipher.

Group

Classes

Links
TnxBaseCipher Methods, TnxBaseCipher Members, nxllBaseCipher, Classes


TnxBaseCipher Members

TnxBaseCipher Members
TnxBaseCipher Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseCipher.

Class

TnxBaseCipher Class

Protected Methods
Name | Description
cbDecodeAlt |
cbEncodeAlt |
RegisterKeyWrap |
Unregister |
Public Methods
Name | Description
AltLock | TnxCipherBase
AltPriority |
AltRegister |
AltUnLock |
AltUnregister |
BlockLength | The length of a single block in bytes. Determines the expected size of the actual parameters of RandomIV, ResetIV, GetRandomBlock, Final.
Create |
Decode | Decrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
DecodeAlt | Decrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
DecodeKey |
DecodeStorage | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeStorage is intended to be used by an EncryptionEngine. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DecodeTransport | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeTransport is intended to be used by a SecuredTransport. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DeriveKey |
Encode | Encrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
EncodeAlt | Encrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
EncodeKey |
EncodeStorage | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeStorage is intended to be used by an EncryptionEngine. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
EncodeTransport | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeTransport is intended to be used by a SecuredTransport. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
Final | Call Final to get the Message Authentication Code corresponding to the aData previously passed to Encode or Decode. The size of the variable passed as aIV must be at least BlockLength.
FindKeyWrapClass |
FreeInstance |
GenerateRandom | GenerateRandom is the default method for generating keys for the cipher.
GetRandomBlock | Generate a fresh random block using the implementation specific default random bit generator and store it in aData. The size of the variable passed as aData must be at least BlockLength.
GetRegisteredKeyWrapClasses |
KeyWrapName |
KeyWrapPriority |
MustFindKeyWrapClass |
NewInstance | TnxObject
PreferredKeyWrapClass |
RandomIVBlock | Generate a fresh IV using the implementation specific default random bit generator and store it in aIV. RandomIV automatically calls ResetIV. RandomIV is typically called prior to a call to Encode. The size of the variable passed as aIV must be at least BlockLength.
ResetIVBlock | Reset the state of the cipher chaining mode with aIV. ResetIV is typically called prior to a call to Decode. The size of the variable passed as aIV must be at least BlockLength.
SelfTest |
SetKeys | Initialize the cipher with aKey as key.
TheCipher |
Links
TnxBaseCipher Class, Legend, Protected Methods, Public Methods


TnxBaseCipher.Create Constructor

TnxBaseCipher.Create Constructor
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Class Send Feedback
Syntax
Delphi
constructor Create(const aKey: RawByteString); virtual;
Class

TnxBaseCipher Class

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Class


TnxBaseCipher Methods

TnxBaseCipher Methods
TnxBaseCipher Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseCipher class are listed here.

Class

TnxBaseCipher Class

Protected Methods
Name | Description
cbDecodeAlt |
cbEncodeAlt |
RegisterKeyWrap |
Unregister |
Public Methods
Name | Description
AltLock | TnxCipherBase
AltPriority |
AltRegister |
AltUnLock |
AltUnregister |
BlockLength | The length of a single block in bytes. Determines the expected size of the actual parameters of RandomIV, ResetIV, GetRandomBlock, Final.
Decode | Decrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
DecodeAlt | Decrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
DecodeKey |
DecodeStorage | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeStorage is intended to be used by an EncryptionEngine. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DecodeTransport | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeTransport is intended to be used by a SecuredTransport. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DeriveKey |
Encode | Encrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
EncodeAlt | Encrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
EncodeKey |
EncodeStorage | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeStorage is intended to be used by an EncryptionEngine. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
EncodeTransport | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeTransport is intended to be used by a SecuredTransport. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
Final | Call Final to get the Message Authentication Code corresponding to the aData previously passed to Encode or Decode. The size of the variable passed as aIV must be at least BlockLength.
FindKeyWrapClass |
GenerateRandom | GenerateRandom is the default method for generating keys for the cipher.
GetRandomBlock | Generate a fresh random block using the implementation specific default random bit generator and store it in aData. The size of the variable passed as aData must be at least BlockLength.
GetRegisteredKeyWrapClasses |
KeyWrapName |
KeyWrapPriority |
MustFindKeyWrapClass |
PreferredKeyWrapClass |
RandomIVBlock | Generate a fresh IV using the implementation specific default random bit generator and store it in aIV. RandomIV automatically calls ResetIV. RandomIV is typically called prior to a call to Encode. The size of the variable passed as aIV must be at least BlockLength.
ResetIVBlock | Reset the state of the cipher chaining mode with aIV. ResetIV is typically called prior to a call to Decode. The size of the variable passed as aIV must be at least BlockLength.
SelfTest |
SetKeys | Initialize the cipher with aKey as key.
TheCipher |
Links
TnxBaseCipher Class, Legend, Protected Methods, Public Methods


TnxBaseCipher.AltLock Method

TnxBaseCipher.AltLock Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure AltLock;
Description

TnxCipherBase

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.AltPriority Method

TnxBaseCipher.AltPriority Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function AltPriority: TnxWord32; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.AltRegister Method

TnxBaseCipher.AltRegister Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure AltRegister;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.AltUnLock Method

TnxBaseCipher.AltUnLock Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure AltUnLock;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.AltUnregister Method

TnxBaseCipher.AltUnregister Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure AltUnregister;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.BlockLength Method

TnxBaseCipher.BlockLength Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function BlockLength: TnxWord32; virtual;
Description

The length of a single block in bytes. Determines the expected size of the actual parameters of RandomIV, ResetIV, GetRandomBlock, Final.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.cbDecodeAlt Method

TnxBaseCipher.cbDecodeAlt Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure cbDecodeAlt(var aData; aLen: TnxWord32); virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.cbEncodeAlt Method

TnxBaseCipher.cbEncodeAlt Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure cbEncodeAlt(var aData; aLen: TnxWord32); virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.Decode Method

TnxBaseCipher.Decode Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure Decode(var aData; aLen: TnxWord32); virtual; abstract;
Description

Decrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.DecodeAlt Method

TnxBaseCipher.DecodeAlt Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure DecodeAlt(var aData; aLen: TnxWord32);
Description

Decrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.DecodeKey Method

TnxBaseCipher.DecodeKey Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
function DecodeKey(const aIV; var aData; aLen: TnxWord32; const aMac): Boolean; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.DecodeStorage Method

TnxBaseCipher.DecodeStorage Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
function DecodeStorage(const aIV; aRandomizer: TnxWord32; out aCookie: TnxDynByteArray; var aData; aLen: TnxWord32; const aMac): Boolean; virtual;
Description

Decrypt aLen bytes of aData using the default mode of the implementation. DecodeStorage is intended to be used by an EncryptionEngine. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.DecodeTransport Method

TnxBaseCipher.DecodeTransport Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
function DecodeTransport(const aIV; var aData; aLen: TnxWord32; const aMac): Boolean; virtual;
Description

Decrypt aLen bytes of aData using the default mode of the implementation. DecodeTransport is intended to be used by a SecuredTransport. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.DeriveKey Method

TnxBaseCipher.DeriveKey Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function DeriveKey(const aPwd; aPwdLen: TnxWord32; const aSalt; aSaltLen: TnxWord32; const aLabel: RawByteString): TnxBaseCipher; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.Encode Method

TnxBaseCipher.Encode Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure Encode(var aData; aLen: TnxWord32); virtual; abstract;
Description

Encrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.EncodeAlt Method

TnxBaseCipher.EncodeAlt Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure EncodeAlt(var aData; aLen: TnxWord32);
Description

Encrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.EncodeKey Method

TnxBaseCipher.EncodeKey Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure EncodeKey(out aIV; var aData; aLen: TnxWord32; out aMac); virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.EncodeStorage Method

TnxBaseCipher.EncodeStorage Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure EncodeStorage(out aIV; aRandomizer: TnxWord32; var aCookie: TnxDynByteArray; const aDataIn; out aDataOut; aLen: TnxWord32; out aMac); virtual;
Description

Encrypt aLen bytes of aData using the default mode of the implementation. EncodeStorage is intended to be used by an EncryptionEngine. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.EncodeTransport Method

TnxBaseCipher.EncodeTransport Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure EncodeTransport(out aIV; var aData; aLen: TnxWord32; out aMac); virtual;
Description

Encrypt aLen bytes of aData using the default mode of the implementation. EncodeTransport is intended to be used by a SecuredTransport. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.Final Method

TnxBaseCipher.Final Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure Final(out aMac); virtual; abstract;
Description

Call Final to get the Message Authentication Code corresponding to the aData previously passed to Encode or Decode. The size of the variable passed as aIV must be at least BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.FindKeyWrapClass Method

TnxBaseCipher.FindKeyWrapClass Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function FindKeyWrapClass(const aName: string): TnxBaseCipherClass;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.GenerateRandom Method

TnxBaseCipher.GenerateRandom Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure GenerateRandom(var aData; aLength: TnxWord32); virtual;
Description

GenerateRandom is the default method for generating keys for the cipher.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.GetRandomBlock Method

TnxBaseCipher.GetRandomBlock Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure GetRandomBlock(var aData); virtual;
Description

Generate a fresh random block using the implementation specific default random bit generator and store it in aData. The size of the variable passed as aData must be at least BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.GetRegisteredKeyWrapClasses Method

TnxBaseCipher.GetRegisteredKeyWrapClasses Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure GetRegisteredKeyWrapClasses(aList: TStrings);
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.KeyWrapName Method

TnxBaseCipher.KeyWrapName Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function KeyWrapName: AnsiString; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.KeyWrapPriority Method

TnxBaseCipher.KeyWrapPriority Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function KeyWrapPriority: TnxWord32; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.MustFindKeyWrapClass Method

TnxBaseCipher.MustFindKeyWrapClass Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function MustFindKeyWrapClass(const aName: string): TnxBaseCipherClass;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.PreferredKeyWrapClass Method

TnxBaseCipher.PreferredKeyWrapClass Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function PreferredKeyWrapClass: TnxBaseCipherClass;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.RandomIVBlock Method

TnxBaseCipher.RandomIVBlock Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure RandomIVBlock(out aIV); virtual; abstract;
Description

Generate a fresh IV using the implementation specific default random bit generator and store it in aIV. RandomIV automatically calls ResetIV. RandomIV is typically called prior to a call to Encode. The size of the variable passed as aIV must be at least BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.RegisterKeyWrap Method

TnxBaseCipher.RegisterKeyWrap Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure RegisterKeyWrap;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.ResetIVBlock Method

TnxBaseCipher.ResetIVBlock Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure ResetIVBlock(const aIV); virtual; abstract;
Description

Reset the state of the cipher chaining mode with aIV. ResetIV is typically called prior to a call to Decode. The size of the variable passed as aIV must be at least BlockLength.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.SelfTest Method

TnxBaseCipher.SelfTest Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class function SelfTest: Boolean; virtual;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.SetKeys Method

TnxBaseCipher.SetKeys Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
procedure SetKeys(const aKey: RawByteString); virtual; abstract;
Description

Initialize the cipher with aKey as key.

Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.TheCipher Method

TnxBaseCipher.TheCipher Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
function TheCipher: TnxBaseCipher;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


TnxBaseCipher.Unregister Method

TnxBaseCipher.Unregister Method
TnxBaseCipher Class TnxBaseCipher Members nxllBaseCipher Namespace TnxBaseCipher Methods Send Feedback
Syntax
Delphi
class procedure Unregister;
Group

TnxBaseCipher Methods

Links
TnxBaseCipher Class, TnxBaseCipher Members, nxllBaseCipher Namespace, TnxBaseCipher Methods


Types

Types
nxllBaseCipher Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllBaseCipher Namespace

Types
Name | Description
TnxBaseCipherClass | This is type nxllBaseCipher.TnxBaseCipherClass.
Links
nxllBaseCipher Namespace, Types


nxllBaseCipher.TnxBaseCipherClass Type

nxllBaseCipher.TnxBaseCipherClass Type
nxllBaseCipher Types Send Feedback
Syntax
Delphi
TnxBaseCipherClass = class of TnxBaseCipher;
File

nxllBaseCipher

Description

This is type nxllBaseCipher.TnxBaseCipherClass.

Group

Types

Links
nxllBaseCipher, Types


Variables

Variables
nxllBaseCipher Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllBaseCipher Namespace

Variables
Name | Description
_AltClass | This is variable nxllBaseCipher._AltClass.
_AltClassList | This is variable nxllBaseCipher._AltClassList.
_AltClassNeedsCheck | This is variable nxllBaseCipher._AltClassNeedsCheck.
_AltClassPadlock | This is variable nxllBaseCipher._AltClassPadlock.
_AltLock | This is variable nxllBaseCipher._AltLock.
_KeyWrapList | This is variable nxllBaseCipher._KeyWrapList.
Links
nxllBaseCipher Namespace, Variables


nxllBaseCipher._AltClass Variable

nxllBaseCipher._AltClass Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_AltClass: TnxBaseCipherClass;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._AltClass.

Group

Variables

Links
nxllBaseCipher, Variables


nxllBaseCipher._AltClassList Variable

nxllBaseCipher._AltClassList Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_AltClassList: TnxSortedList;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._AltClassList.

Group

Variables

Links
nxllBaseCipher, Variables


nxllBaseCipher._AltClassNeedsCheck Variable

nxllBaseCipher._AltClassNeedsCheck Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_AltClassNeedsCheck: Boolean;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._AltClassNeedsCheck.

Group

Variables

Links
nxllBaseCipher, Variables


nxllBaseCipher._AltClassPadlock Variable

nxllBaseCipher._AltClassPadlock Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_AltClassPadlock: TnxPadlock;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._AltClassPadlock.

Group

Variables

Links
nxllBaseCipher, Variables


nxllBaseCipher._AltLock Variable

nxllBaseCipher._AltLock Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_AltLock: Integer;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._AltLock.

Group

Variables

Links
nxllBaseCipher, Variables


nxllBaseCipher._KeyWrapList Variable

nxllBaseCipher._KeyWrapList Variable
nxllBaseCipher Variables Send Feedback
Syntax
Delphi
_KeyWrapList: TnxFastStringListIC;
File

nxllBaseCipher

Description

This is variable nxllBaseCipher._KeyWrapList.

Group

Variables

Links
nxllBaseCipher, Variables


Constants

Constants
Constants nxllBaseCipher Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsAltCipherLocked | This is constant nxllBaseCipher.rsAltCipherLocked.
rsNoAltCipherRegistered | This is constant nxllBaseCipher.rsNoAltCipherRegistered.
rsUnableToFindKeyWrapClass | This is constant nxllBaseCipher.rsUnableToFindKeyWrapClass.
Namespace

nxllBaseCipher Namespace

Links
Constants, nxllBaseCipher Namespace


nxllBaseCipher.rsAltCipherLocked Constant

nxllBaseCipher.rsAltCipherLocked Constant
nxllBaseCipher Constants Send Feedback
Syntax
Delphi
rsAltCipherLocked = 'The alternative mode cipher about to the unregistered is currently locked as begin in use';
File

nxllBaseCipher

Description

This is constant nxllBaseCipher.rsAltCipherLocked.

Group

Constants

Links
nxllBaseCipher, Constants


nxllBaseCipher.rsNoAltCipherRegistered Constant

nxllBaseCipher.rsNoAltCipherRegistered Constant
nxllBaseCipher Constants Send Feedback
Syntax
Delphi
rsNoAltCipherRegistered = 'No alternative mode cipher class registered';
File

nxllBaseCipher

Description

This is constant nxllBaseCipher.rsNoAltCipherRegistered.

Group

Constants

Links
nxllBaseCipher, Constants


nxllBaseCipher.rsUnableToFindKeyWrapClass Constant

nxllBaseCipher.rsUnableToFindKeyWrapClass Constant
nxllBaseCipher Constants Send Feedback
Syntax
Delphi
rsUnableToFindKeyWrapClass = 'Unable to find key wrap class with algorithm name "%s"';
File

nxllBaseCipher

Description

This is constant nxllBaseCipher.rsUnableToFindKeyWrapClass.

Group

Constants

Links
nxllBaseCipher, Constants


nxllBaseCompressor Namespace

nxllBaseCompressor Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxllBaseCompressor.

Classes
Name | Description
EnxCompressorException | This is class nxllBaseCompressor.EnxCompressorException.
TnxBaseCompressor | This is class nxllBaseCompressor.TnxBaseCompressor.
Constants
Name | Description
rsCompressorAlreadyRegistered | This is constant nxllBaseCompressor.rsCompressorAlreadyRegistered.
rsUnknownCompressType | This is constant nxllBaseCompressor.rsUnknownCompressType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBaseCompressorClass | This is type nxllBaseCompressor.TnxBaseCompressorClass.
TnxCompressType | This is type nxllBaseCompressor.TnxCompressType.
Variables
Name | Description
_CompressorDescriptions | This is variable nxllBaseCompressor._CompressorDescriptions.
_Compressors | This is variable nxllBaseCompressor._Compressors.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxllBaseCompressor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxCompressorException | This is class nxllBaseCompressor.EnxCompressorException.
TnxBaseCompressor | This is class nxllBaseCompressor.TnxBaseCompressor.
Namespace

nxllBaseCompressor Namespace

Links
Classes, nxllBaseCompressor Namespace, Legend


EnxCompressorException Class

EnxCompressorException Class
nxllBaseCompressor Classes Send Feedback
Class Hierarchy
nxllBaseCompressor_EnxCompressorExceptionnxllBaseCompressor_EnxCompressorExceptionnxllBaseCompressor_EnxCompressorExceptionnxllBaseCompressor_EnxCompressorException
Syntax
Delphi
EnxCompressorException = class(EnxBaseException);
File

nxllBaseCompressor

Description

This is class nxllBaseCompressor.EnxCompressorException.

Group

Classes

Links
nxllBaseCompressor, Classes


TnxBaseCompressor Class

TnxBaseCompressor Class
TnxBaseCompressor Methods TnxBaseCompressor Members nxllBaseCompressor Classes Send Feedback
Class Hierarchy
nxllBaseCompressor_TnxBaseCompressornxllBaseCompressor_TnxBaseCompressor
Syntax
Delphi
TnxBaseCompressor = class(TnxObject);
File

nxllBaseCompressor

Description

This is class nxllBaseCompressor.TnxBaseCompressor.

Group

Classes

Links
TnxBaseCompressor Methods, TnxBaseCompressor Members, nxllBaseCompressor, Classes


TnxBaseCompressor Members

TnxBaseCompressor Members
TnxBaseCompressor Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseCompressor.

Class

TnxBaseCompressor Class

Protected Methods
Name | Description
Register |
UnRegister |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Links
TnxBaseCompressor Class, Legend, Protected Methods, Public Methods


TnxBaseCompressor Methods

TnxBaseCompressor Methods
TnxBaseCompressor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseCompressor class are listed here.

Class

TnxBaseCompressor Class

Protected Methods
Name | Description
Register |
UnRegister |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Uncompress | abstract;
Links
TnxBaseCompressor Class, Legend, Protected Methods, Public Methods


TnxBaseCompressor.Compress Method

TnxBaseCompressor.Compress Method
TnxBaseCompressor Class TnxBaseCompressor Members nxllBaseCompressor Namespace TnxBaseCompressor Methods Send Feedback
Syntax
Delphi
class function Compress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32): TnxWord32; virtual;
Description

abstract;

TnxBaseCompressor

Group

TnxBaseCompressor Methods

Links
TnxBaseCompressor Class, TnxBaseCompressor Members, nxllBaseCompressor Namespace, TnxBaseCompressor Methods


TnxBaseCompressor.Register Method

TnxBaseCompressor.Register Method
TnxBaseCompressor Class TnxBaseCompressor Members nxllBaseCompressor Namespace TnxBaseCompressor Methods Send Feedback
Syntax
Delphi
class procedure Register(aCompressType: TnxCompressType; const aDescription: string);
Group

TnxBaseCompressor Methods

Links
TnxBaseCompressor Class, TnxBaseCompressor Members, nxllBaseCompressor Namespace, TnxBaseCompressor Methods


TnxBaseCompressor.Uncompress Method

TnxBaseCompressor.Uncompress Method
TnxBaseCompressor Class TnxBaseCompressor Members nxllBaseCompressor Namespace TnxBaseCompressor Methods Send Feedback
Syntax
Delphi
class procedure Uncompress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32); virtual;
Description

abstract;

Group

TnxBaseCompressor Methods

Links
TnxBaseCompressor Class, TnxBaseCompressor Members, nxllBaseCompressor Namespace, TnxBaseCompressor Methods


TnxBaseCompressor.UnRegister Method

TnxBaseCompressor.UnRegister Method
TnxBaseCompressor Class TnxBaseCompressor Members nxllBaseCompressor Namespace TnxBaseCompressor Methods Send Feedback
Syntax
Delphi
class procedure UnRegister;
Group

TnxBaseCompressor Methods

Links
TnxBaseCompressor Class, TnxBaseCompressor Members, nxllBaseCompressor Namespace, TnxBaseCompressor Methods


Types

Types
nxllBaseCompressor Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllBaseCompressor Namespace

Types
Name | Description
TnxBaseCompressorClass | This is type nxllBaseCompressor.TnxBaseCompressorClass.
TnxCompressType | This is type nxllBaseCompressor.TnxCompressType.
Links
nxllBaseCompressor Namespace, Types


nxllBaseCompressor.TnxBaseCompressorClass Type

nxllBaseCompressor.TnxBaseCompressorClass Type
nxllBaseCompressor Types Send Feedback
Syntax
Delphi
TnxBaseCompressorClass = class of TnxBaseCompressor;
File

nxllBaseCompressor

Description

This is type nxllBaseCompressor.TnxBaseCompressorClass.

Group

Types

Links
nxllBaseCompressor, Types


nxllBaseCompressor.TnxCompressType Type

nxllBaseCompressor.TnxCompressType Type
nxllBaseCompressor Types Send Feedback
Syntax
Delphi
TnxCompressType = 1..255;
File

nxllBaseCompressor

Description

This is type nxllBaseCompressor.TnxCompressType.

Group

Types

Links
nxllBaseCompressor, Types


Variables

Variables
nxllBaseCompressor Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllBaseCompressor Namespace

Variables
Name | Description
_CompressorDescriptions | This is variable nxllBaseCompressor._CompressorDescriptions.
_Compressors | This is variable nxllBaseCompressor._Compressors.
Links
nxllBaseCompressor Namespace, Variables


nxllBaseCompressor._CompressorDescriptions Variable

nxllBaseCompressor._CompressorDescriptions Variable
nxllBaseCompressor Variables Send Feedback
Syntax
Delphi
_CompressorDescriptions: array[TnxCompressType] of string;
File

nxllBaseCompressor

Description

This is variable nxllBaseCompressor._CompressorDescriptions.

Group

Variables

Links
nxllBaseCompressor, Variables


nxllBaseCompressor._Compressors Variable

nxllBaseCompressor._Compressors Variable
nxllBaseCompressor Variables Send Feedback
Syntax
Delphi
_Compressors: array[TnxCompressType] of TnxBaseCompressorClass;
File

nxllBaseCompressor

Description

This is variable nxllBaseCompressor._Compressors.

Group

Variables

Links
nxllBaseCompressor, Variables


Constants

Constants
Constants nxllBaseCompressor Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsCompressorAlreadyRegistered | This is constant nxllBaseCompressor.rsCompressorAlreadyRegistered.
rsUnknownCompressType | This is constant nxllBaseCompressor.rsUnknownCompressType.
Namespace

nxllBaseCompressor Namespace

Links
Constants, nxllBaseCompressor Namespace


nxllBaseCompressor.rsCompressorAlreadyRegistered Constant

nxllBaseCompressor.rsCompressorAlreadyRegistered Constant
nxllBaseCompressor Constants Send Feedback
Syntax
Delphi
rsCompressorAlreadyRegistered = 'Compressor already registered';
File

nxllBaseCompressor

Description

This is constant nxllBaseCompressor.rsCompressorAlreadyRegistered.

Group

Constants

Links
nxllBaseCompressor, Constants


nxllBaseCompressor.rsUnknownCompressType Constant

nxllBaseCompressor.rsUnknownCompressType Constant
nxllBaseCompressor Constants Send Feedback
Syntax
Delphi
rsUnknownCompressType = 'Unknown CompressType "%d"';
File

nxllBaseCompressor

Description

This is constant nxllBaseCompressor.rsUnknownCompressType.

Group

Constants

Links
nxllBaseCompressor, Constants


nxllBde Namespace

nxllBde Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllBde.

Constants
Name
Description
DBICODE_BLOBERR
0x78 DBICODE_RESTARTQRY = 121; { 0x79 } DBICODE_UNKNOWNANSTYPE = 122; { 0x7a }
DBIERR_ACTIVETRAN
This is constant nxllBde.DBIERR_ACTIVETRAN.
DBIERR_BLOBERR
DBIERR_AMBJOASY = (ERRBASE_QUERY+DBICODE_AMBJOASY); DBIERR_AMBJOSYM = (ERRBASE_QUERY+DBICODE_AMBJOSYM); DBIERR_AMBOUTEX = (ERRBASE_QUERY+DBICODE_AMBOUTEX); DBIERR_AMBOUTPR = (ERRBASE_QUERY+DBICODE_AMBOUTPR); DBIERR_AMBSYMAS = (ERRBASE_QUERY+DBICODE_AMBSYMAS); DBIERR_ASETOPER = (ERRBASE_QUERY+DBICODE_ASETOPER); DBIERR_AVENUMDA = (ERRBASE_QUERY+DBICODE_AVENUMDA); DBIERR_BADEXPR1 = (ERRBASE_QUERY+DBICODE_BADEXPR1); DBIERR_BADFLDOR = (ERRBASE_QUERY+DBICODE_BADFLDOR); DBIERR_BADVNAME = (ERRBASE_QUERY+DBICODE_BADVNAME); DBIERR_BITMAPER = (ERRBASE_QUERY+DBICODE_BITMAPER); DBIERR_CALCBADR = (ERRBASE_QUERY+DBICODE_CALCBADR); DBIERR_CALCTYPE = (ERRBASE_QUERY+DBICODE_CALCTYPE); DBIERR_CHGTO1TI = (ERRBASE_QUERY+DBICODE_CHGTO1TI); DBIERR_CHGTOCHG = (ERRBASE_QUERY+DBICODE_CHGTOCHG); DBIERR_CHGTOEXP = (ERRBASE_QUERY+DBICODE_CHGTOEXP); DBIERR_CHGTOINS = (ERRBASE_QUERY+DBICODE_CHGTOINS); DBIERR_CHGTONEW = (ERRBASE_QUERY+DBICODE_CHGTONEW); DBIERR_CHGTOVAL = (ERRBASE_QUERY+DBICODE_CHGTOVAL); DBIERR_CHKMRKFI = (ERRBASE_QUERY+DBICODE_CHKMRKFI);... more
DBIERR_BLOBMODIFIED
DBIERR_FILEEXISTS = (ERRBASE_OTHER + ERRCODE_FILEEXISTS);
DBIERR_BOF
This is constant nxllBde.DBIERR_BOF.
DBIERR_CHECKCONSTRAINTFAILED
DBIERR_MASTEREXISTS = (ERRBASE_INTEGRITY + ERRCODE_MASTEREXISTS); DBIERR_MASTERTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPEN); DBIERR_DETAILTABLESEXIST = (ERRBASE_INTEGRITY + ERRCODE_DETAILTABLESEXIST); DBIERR_DETAILRECEXISTEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DETAILRECEXISTEMPTY); DBIERR_MASTERREFERENCEERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERREFERENCEERR); DBIERR_DETAILTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPEN); DBIERR_DEPENDENTSMUSTBEEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DEPENDENTSMUSTBEEMPTY); DBIERR_RINTREQINDEX = (ERRBASE_INTEGRITY + ERRCODE_RINTREQINDEX); DBIERR_LINKEDTBLPROTECTED = (ERRBASE_INTEGRITY + ERRCODE_LINKEDTBLPROTECTED); DBIERR_FIELDMULTILINKED = (ERRBASE_INTEGRITY + ERRCODE_FIELDMULTILINKED);
DBIERR_CLIENTSLIMIT
DBIERR_WSSESLIMIT = (ERRBASE_LIMIT + ERRCODE_WSSESLIMIT); DBIERR_SERNUMLIMIT = (ERRBASE_LIMIT + ERRCODE_SERNUMLIMIT); DBIERR_INTERNALLIMIT = (ERRBASE_LIMIT + ERRCODE_INTERNALLIMIT); DBIERR_OPENTBLLIMIT = (ERRBASE_LIMIT + ERRCODE_OPENTBLLIMIT); DBIERR_TBLCURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_TBLCURSORLIMIT); DBIERR_RECLOCKLIMIT = (ERRBASE_LIMIT + ERRCODE_RECLOCKLIMIT);
DBIERR_DEADLOCK
This is constant nxllBde.DBIERR_DEADLOCK.
DBIERR_DETAILRECORDSEXIST
This is constant nxllBde.DBIERR_DETAILRECORDSEXIST.
DBIERR_DIFFERENTTABLES
This is constant nxllBde.DBIERR_DIFFERENTTABLES.
DBIERR_DIRNOACCESS
This is constant nxllBde.DBIERR_DIRNOACCESS.
DBIERR_ENDOFBLOB
This is constant nxllBde.DBIERR_ENDOFBLOB.
DBIERR_EOF
This is constant nxllBde.DBIERR_EOF.
DBIERR_FIELDISBLANK
DBIERR_MASTERTBLLEVEL = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLLEVEL); DBIERR_LOOKUPTABLEERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTABLEERR); DBIERR_LOOKUPTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTBLOPENERR); DBIERR_DETAILTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPENERR); DBIERR_MASTERTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPENERR);
DBIERR_FILECORRUPT
This is constant nxllBde.DBIERR_FILECORRUPT.
DBIERR_FILELOCKED
DBIERR_UNLOCKFAILED = (ERRBASE_LOCKCONFLICT + ERRCODE_UNLOCKFAILED); DBIERR_FILEBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_FILEBUSY); DBIERR_DIRBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRBUSY);
DBIERR_FILENOACCESS
DBIERR_FILEDELETEFAIL = (ERRBASE_IO + ERRCODE_FILEDELETEFAIL);
DBIERR_FLDLIMIT
DBIERR_SESSIONSLIMIT = (ERRBASE_LIMIT + ERRCODE_SESSIONSLIMIT); DBIERR_DBLIMIT = (ERRBASE_LIMIT + ERRCODE_DBLIMIT); DBIERR_PASSWORDLIMIT = (ERRBASE_LIMIT + ERRCODE_PASSWORDLIMIT); DBIERR_DRIVERLIMIT = (ERRBASE_LIMIT + ERRCODE_DRIVERLIMIT);
DBIERR_FORIEGNKEYERR
This is constant nxllBde.DBIERR_FORIEGNKEYERR.
DBIERR_GROUPLOCKCONFLICT
This is constant nxllBde.DBIERR_GROUPLOCKCONFLICT.
DBIERR_HEADERCORRUPT
This is constant nxllBde.DBIERR_HEADERCORRUPT.
DBIERR_INDEXCORRUPT
DBIERR_MEMOCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_MEMOCORRUPT); DBIERR_BMPCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_BMPCORRUPT);
DBIERR_INDEXEXISTS
DBIERR_USECOUNT = (ERRBASE_INVALIDREQ + ERRCODE_USECOUNT); DBIERR_INVALIDKEY = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDKEY);
DBIERR_INDEXLIMIT
This is constant nxllBde.DBIERR_INDEXLIMIT.
DBIERR_INVALIDALIASNAME
DBIERR_INVALIDTABLECREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLECREATE); DBIERR_INVALIDTABLEDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLEDELETE); DBIERR_INVALIDINDEXCREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXCREATE); DBIERR_INVALIDINDEXDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXDELETE); DBIERR_INVALIDTABLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLE); DBIERR_MULTIRESULTS = (ERRBASE_INVALIDREQ + ERRCODE_MULTIRESULTS); DBIERR_INVALIDTIME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIME); DBIERR_INVALIDDATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDATE); DBIERR_INVALIDTIMESTAMP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIMESTAMP); DBIERR_DIFFERENTPATH = (ERRBASE_INVALIDREQ + ERRCODE_DIFFERENTPATH); DBIERR_MISMATCHARGS = (ERRBASE_INVALIDREQ + ERRCODE_MISMATCHARGS); DBIERR_FUNCTIONNOTFOUND = (ERRBASE_INVALIDREQ + ERRCODE_FUNCTIONNOTFOUND); DBIERR_MUSTUSEBASEORDER = (ERRBASE_INVALIDREQ + ERRCODE_MUSTUSEBASEORDER); DBIERR_INVALIDPROCEDURENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDPROCEDURENAME); DBIERR_INVALIDFLDMAP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDMAP);
DBIERR_INVALIDBLOBHANDLE
This is constant nxllBde.DBIERR_INVALIDBLOBHANDLE.
DBIERR_INVALIDBLOBLEN
DBIERR_INDEXOPEN = (ERRBASE_INVALIDREQ + ERRCODE_INDEXOPEN);
DBIERR_INVALIDBLOBOFFSET
This is constant nxllBde.DBIERR_INVALIDBLOBOFFSET.
DBIERR_INVALIDBOOKMARK
This is constant nxllBde.DBIERR_INVALIDBOOKMARK.
DBIERR_INVALIDDESC
This is constant nxllBde.DBIERR_INVALIDDESC.
DBIERR_INVALIDDESCNUM
This is constant nxllBde.DBIERR_INVALIDDESCNUM.
DBIERR_INVALIDDIR
DBIERR_NOCALLBACK = (ERRBASE_INVALIDREQ + ERRCODE_NOCALLBACK); DBIERR_INVALIDCALLBACKBUFLEN = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDCALLBACKBUFLEN );
DBIERR_INVALIDFIELDNAME
DBIERR_MULTILEVELCASCADE = (ERRBASE_INVALIDREQ + ERRCODE_MULTILEVELCASCADE);
DBIERR_INVALIDFILEEXTN
DBIERR_INVALIDLINKEXPR = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDLINKEXPR); DBIERR_NAMERESERVED = (ERRBASE_INVALIDREQ + ERRCODE_NAMERESERVED);
DBIERR_INVALIDFILTER
This is constant nxllBde.DBIERR_INVALIDFILTER.
DBIERR_INVALIDFLDDESC
This is constant nxllBde.DBIERR_INVALIDFLDDESC.
DBIERR_INVALIDFLDTYPE
This is constant nxllBde.DBIERR_INVALIDFLDTYPE.
DBIERR_INVALIDFLDXFORM
This is constant nxllBde.DBIERR_INVALIDFLDXFORM.
DBIERR_INVALIDHNDL
DBIERR_INVALIDFILENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFILENAME); DBIERR_NOSUCHFILE = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHFILE); DBIERR_INVALIDOPTION = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDOPTION);
DBIERR_INVALIDIDXDESC
This is constant nxllBde.DBIERR_INVALIDIDXDESC.
DBIERR_INVALIDINDEXNAME
This is constant nxllBde.DBIERR_INVALIDINDEXNAME.
DBIERR_INVALIDINDEXSTRUCT
This is constant nxllBde.DBIERR_INVALIDINDEXSTRUCT.
DBIERR_INVALIDLANGDRV
This is constant nxllBde.DBIERR_INVALIDLANGDRV.
DBIERR_INVALIDNAME
This is constant nxllBde.DBIERR_INVALIDNAME.
DBIERR_INVALIDPARAM
This is constant nxllBde.DBIERR_INVALIDPARAM.
DBIERR_INVALIDPASSWORD
This is constant nxllBde.DBIERR_INVALIDPASSWORD.
DBIERR_INVALIDRECSTRUCT
This is constant nxllBde.DBIERR_INVALIDRECSTRUCT.
DBIERR_INVALIDTABLENAME
This is constant nxllBde.DBIERR_INVALIDTABLENAME.
DBIERR_INVALIDUSRPASS
DBIERR_NEEDRESTRUCTURE = (ERRBASE_INVALIDREQ + ERRCODE_NEEDRESTRUCTURE); DBIERR_INVALIDMODE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODE); DBIERR_CANNOTCLOSE = (ERRBASE_INVALIDREQ + ERRCODE_CANNOTCLOSE); DBIERR_ACTIVEINDEX = (ERRBASE_INVALIDREQ + ERRCODE_ACTIVEINDEX);
DBIERR_INVALIDXLATION
This is constant nxllBde.DBIERR_INVALIDXLATION.
DBIERR_KEYORRECDELETED
This is constant nxllBde.DBIERR_KEYORRECDELETED.
DBIERR_KEYVIOL
This is constant nxllBde.DBIERR_KEYVIOL.
DBIERR_LOCKED
ERRCODE_LOCKEDRECS = 21; ERRCODE_NEEDWRITELOCK = 22;
DBIERR_LOCKTIMEOUT
DBIERR_DIRLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRLOCKED); DBIERR_ALREADYLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_ALREADYLOCKED); DBIERR_NOTLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_NOTLOCKED);
DBIERR_MAXVALERR
This is constant nxllBde.DBIERR_MAXVALERR.
DBIERR_MINVALERR
This is constant nxllBde.DBIERR_MINVALERR.
DBIERR_NA
DBIERR_BLOBOPENED = (ERRBASE_IC + ERRCODE_BLOBOPENED); DBIERR_BLOBNOTOPENED = (ERRBASE_IC + ERRCODE_BLOBNOTOPENED);
DBIERR_NAMENOTUNIQUE
DBIERR_INVALIDVCHKSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDVCHKSTRUCT); DBIERR_INVALIDRINTSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTSTRUCT); DBIERR_INVALIDRESTRTBLORDER = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTRTBLORDER);
DBIERR_NEEDEXCLACCESS
DBIERR_GROUPLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_GROUPLOCKED); DBIERR_LOSTTBLLOCK = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTTBLLOCK); DBIERR_LOSTEXCLACCESS = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTEXCLACCESS);
DBIERR_NOACTIVETRAN
This is constant nxllBde.DBIERR_NOACTIVETRAN.
DBIERR_NOASSOCINDEX
This is constant nxllBde.DBIERR_NOASSOCINDEX.
DBIERR_NOCURRREC
This is constant nxllBde.DBIERR_NOCURRREC.
DBIERR_NOMEMORY
This is constant nxllBde.DBIERR_NOMEMORY.
DBIERR_NONE
This is constant nxllBde.DBIERR_NONE.
DBIERR_NOSERVERSW
DBIERR_NOTEXACT = ( ERRBASE_OS + ERRCODE_NOTEXACT ); DBIERR_OSUNKNOWNSRVERR = ( ERRBASE_OS + ERRCODE_OSUNKNOWNSRVERR ); DBIERR_SERVERNOMEMORY = ( ERRBASE_OS + ERRCODE_SERVERNOMEMORY ); DBIERR_OSALREADYLOCKED = ( ERRBASE_OS + ERRCODE_OSALREADYLOCKED ); DBIERR_OSNOTLOCKED = ( ERRBASE_OS + ERRCODE_OSNOTLOCKED );
DBIERR_NOSUCHFILTER
DBIERR_ALIASNOTOPEN = (ERRBASE_INVALIDREQ + ERRCODE_ALIASNOTOPEN); DBIERR_INCOMPATRECSTRUCTS = (ERRBASE_INVALIDREQ + ERRCODE_INCOMPATRECSTRUCTS); DBIERR_RESERVEDOSNAME = (ERRBASE_INVALIDREQ + ERRCODE_RESERVEDDOSNAME); DBIERR_DESTMUSTBEINDEXED = (ERRBASE_INVALIDREQ + ERRCODE_DESTMUSTBEINDEXED); DBIERR_INVALIDINDEXTYPE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXTYPE); DBIERR_LANGDRVMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_LANGDRVMISMATCH);
DBIERR_NOSUCHINDEX
DBIERR_PRIMARYKEYREDEFINE = (ERRBASE_INVALIDREQ + ERRCODE_PRIMARYKEYREDEFINE); DBIERR_INVALIDRINTDESCNUM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTDESCNUM); DBIERR_KEYFLDTYPEMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_KEYFLDTYPEMISMATCH); DBIERR_INVALIDMODIFYREQUEST = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODIFYREQUEST);
DBIERR_NOSUCHTABLE
This is constant nxllBde.DBIERR_NOSUCHTABLE.
DBIERR_NOTABLOB
This is constant nxllBde.DBIERR_NOTABLOB.
DBIERR_NOTINDEXED
This is constant nxllBde.DBIERR_NOTINDEXED.
DBIERR_NOTSAMESESSION
DBIERR_NOTINITIALIZED = (ERRBASE_IC + ERRCODE_NOTINITIALIZED); DBIERR_MULTIPLEINIT = (ERRBASE_IC + ERRCODE_MULTIPLEINIT);
DBIERR_NOTSUFFTABLERIGHTS
DBIERR_NOTSUFFFIELDRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFIELDRIGHTS);
DBIERR_NOTSUPPORTED
This is constant nxllBde.DBIERR_NOTSUPPORTED.
DBIERR_NX_BADBLOCKNR
This is constant nxllBde.DBIERR_NX_BADBLOCKNR.
DBIERR_NX_BADDATABLOCK
This is constant nxllBde.DBIERR_NX_BADDATABLOCK.
DBIERR_NX_BADHEAPBLOCK
This is constant nxllBde.DBIERR_NX_BADHEAPBLOCK.
DBIERR_NX_BADINDEX
This is constant nxllBde.DBIERR_NX_BADINDEX.
DBIERR_NX_BADINXBLOCK
This is constant nxllBde.DBIERR_NX_BADINXBLOCK.
DBIERR_NX_BADREFNR
This is constant nxllBde.DBIERR_NX_BADREFNR.
DBIERR_NX_BADSTREAMBLOCK
This is constant nxllBde.DBIERR_NX_BADSTREAMBLOCK.
DBIERR_NX_BADSTRUCT
This is constant nxllBde.DBIERR_NX_BADSTRUCT.
DBIERR_NX_BLOBTOOBIG
This is constant nxllBde.DBIERR_NX_BLOBTOOBIG.
DBIERR_NX_CLOSEFAILED
This is constant nxllBde.DBIERR_NX_CLOSEFAILED.
DBIERR_NX_COPYFILE
This is constant nxllBde.DBIERR_NX_COPYFILE.
DBIERR_NX_CORRUPTTRANS
This is constant nxllBde.DBIERR_NX_CORRUPTTRANS.
DBIERR_NX_DELETEFILE
This is constant nxllBde.DBIERR_NX_DELETEFILE.
DBIERR_NX_DICT_DUPAUTOINC
This is constant nxllBde.DBIERR_NX_DICT_DUPAUTOINC.
DBIERR_NX_DICT_DUPRECREV
This is constant nxllBde.DBIERR_NX_DICT_DUPRECREV.
DBIERR_NX_DICT_OBJINUSE
This is constant nxllBde.DBIERR_NX_DICT_OBJINUSE.
DBIERR_NX_DICT_READONLY
This is constant nxllBde.DBIERR_NX_DICT_READONLY.
DBIERR_NX_FILEBLOBCLOSE
This is constant nxllBde.DBIERR_NX_FILEBLOBCLOSE.
DBIERR_NX_FILEBLOBOPEN
This is constant nxllBde.DBIERR_NX_FILEBLOBOPEN.
DBIERR_NX_FILEBLOBREAD
This is constant nxllBde.DBIERR_NX_FILEBLOBREAD.
DBIERR_NX_FILTERTIMEOUT
This is constant nxllBde.DBIERR_NX_FILTERTIMEOUT.
DBIERR_NX_GENERALTIMEOUT
This is constant nxllBde.DBIERR_NX_GENERALTIMEOUT.
DBIERR_NX_INCOMPATDICT
This is constant nxllBde.DBIERR_NX_INCOMPATDICT.
DBIERR_NX_INCOMPATHEADER
This is constant nxllBde.DBIERR_NX_INCOMPATHEADER.
DBIERR_NX_INCOMPATSTREAM
This is constant nxllBde.DBIERR_NX_INCOMPATSTREAM.
DBIERR_NX_INDEXNOTEMPTY
This is constant nxllBde.DBIERR_NX_INDEXNOTEMPTY.
DBIERR_NX_INVALIDSEGNR
This is constant nxllBde.DBIERR_NX_INVALIDSEGNR.
DBIERR_NX_KEYFILTERED
This is constant nxllBde.DBIERR_NX_KEYFILTERED.
DBIERR_NX_LICENSE_EXPIRED
This is constant nxllBde.DBIERR_NX_LICENSE_EXPIRED.
DBIERR_NX_LITE
This is constant nxllBde.DBIERR_NX_LITE.
DBIERR_NX_MAXKEYSIZE
This is constant nxllBde.DBIERR_NX_MAXKEYSIZE.
DBIERR_NX_MAXRECORDSIZE
This is constant nxllBde.DBIERR_NX_MAXRECORDSIZE.
DBIERR_NX_NOSESSIONSE
This is constant nxllBde.DBIERR_NX_NOSESSIONSE.
DBIERR_NX_RECOVERFAILED
This is constant nxllBde.DBIERR_NX_RECOVERFAILED.
DBIERR_NX_REGISTERFHAF
This is constant nxllBde.DBIERR_NX_REGISTERFHAF.
DBIERR_NX_RENAMEFILE
This is constant nxllBde.DBIERR_NX_RENAMEFILE.
DBIERR_NX_SAMEFOLDER
This is constant nxllBde.DBIERR_NX_SAMEFOLDER.
DBIERR_NX_SAMETABLE
This is constant nxllBde.DBIERR_NX_SAMETABLE.
DBIERR_NX_SEGMENTDELETED
This is constant nxllBde.DBIERR_NX_SEGMENTDELETED.
DBIERR_NX_SERVERNAMENOTSET
This is constant nxllBde.DBIERR_NX_SERVERNAMENOTSET.
DBIERR_NX_SQLSIGNAL
This is constant nxllBde.DBIERR_NX_SQLSIGNAL.
DBIERR_NX_TABLEVERSION
This is constant nxllBde.DBIERR_NX_TABLEVERSION.
DBIERR_NX_TRIAL
This is constant nxllBde.DBIERR_NX_TRIAL.
DBIERR_NX_TS_FULL
This is constant nxllBde.DBIERR_NX_TS_FULL.
DBIERR_NX_TS_INVALIDBLOCK
This is constant nxllBde.DBIERR_NX_TS_INVALIDBLOCK.
DBIERR_NX_UNKNOWN
This is constant nxllBde.DBIERR_NX_UNKNOWN.
DBIERR_NX_UNKNOWNEXCP
This is constant nxllBde.DBIERR_NX_UNKNOWNEXCP.
DBIERR_NX_UNKNOWNMSG
This is constant nxllBde.DBIERR_NX_UNKNOWNMSG.
DBIERR_NX_UNSUPDICTDESCR
This is constant nxllBde.DBIERR_NX_UNSUPDICTDESCR.
DBIERR_NX_UNSUPHEADER
This is constant nxllBde.DBIERR_NX_UNSUPHEADER.
DBIERR_NX_UNSUPSUBENGINE
This is constant nxllBde.DBIERR_NX_UNSUPSUBENGINE.
DBIERR_OBJNOTFOUND
This is constant nxllBde.DBIERR_OBJNOTFOUND.
DBIERR_OPTRECLOCKFAILED
This is constant nxllBde.DBIERR_OPTRECLOCKFAILED.
DBIERR_OPTRECLOCKRECDEL
This is constant nxllBde.DBIERR_OPTRECLOCKRECDEL.
DBIERR_OSUNKNOWN
DBIERR_OSEINVFNC = ( ERRBASE_OS + ERRCODE_OSEINVFNC ); DBIERR_OSENOENT = ( ERRBASE_OS + ERRCODE_OSENOENT ); DBIERR_OSENOPATH = ( ERRBASE_OS + ERRCODE_OSENOPATH ); DBIERR_OSEMFILE = ( ERRBASE_OS + ERRCODE_OSEMFILE ); DBIERR_OSEACCES = ( ERRBASE_OS + ERRCODE_OSEACCES ); DBIERR_OSEBADF = ( ERRBASE_OS + ERRCODE_OSEBADF ); DBIERR_OSECONTR = ( ERRBASE_OS + ERRCODE_OSECONTR ); DBIERR_OSENOMEM = ( ERRBASE_OS + ERRCODE_OSENOMEM ); DBIERR_OSEINVMEM = ( ERRBASE_OS + ERRCODE_OSEINVMEM ); DBIERR_OSEINVENV = ( ERRBASE_OS + ERRCODE_OSEINVENV ); DBIERR_OSEINVFMT = ( ERRBASE_OS + ERRCODE_OSEINVFMT ); DBIERR_OSEINVACC = ( ERRBASE_OS + ERRCODE_OSEINVACC ); DBIERR_OSEINVDAT = ( ERRBASE_OS + ERRCODE_OSEINVDAT ); DBIERR_OSENODEV = ( ERRBASE_OS + ERRCODE_OSENODEV ); DBIERR_OSECURDIR =... more
DBIERR_OUTOFRANGE
This is constant nxllBde.DBIERR_OUTOFRANGE.
DBIERR_READERR
This is constant nxllBde.DBIERR_READERR.
DBIERR_READONLYDB
DBIERR_NOTSUFFFAMILYRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFAMILYRIGHTS); DBIERR_READONLYDIR = (ERRBASE_SEC + ERRCODE_READONLYDIR);
DBIERR_READONLYFLD
This is constant nxllBde.DBIERR_READONLYFLD.
DBIERR_RECDELETED
DBIERR_RECMOVED = (ERRBASE_NOTFOUND + ERRCODE_RECMOVED);
DBIERR_RECGROUPCONFLICT
This is constant nxllBde.DBIERR_RECGROUPCONFLICT.
DBIERR_RECLOCKFAILED
This is constant nxllBde.DBIERR_RECLOCKFAILED.
DBIERR_RECNOTFOUND
This is constant nxllBde.DBIERR_RECNOTFOUND.
DBIERR_REENTERED
DBIERR_SYSFILEOPEN = (ERRBASE_SYSTEM + ERRCODE_SYSFILEOPEN); DBIERR_SYSFILEIO = (ERRBASE_SYSTEM + ERRCODE_SYSFILEIO); DBIERR_SYSCORRUPT = (ERRBASE_SYSTEM + ERRCODE_SYSCORRUPT); DBIERR_NOCONFIGFILE = (ERRBASE_SYSTEM + ERRCODE_NOCONFIGFILE); DBIERR_CFGCANNOTWRITE = (ERRBASE_SYSTEM + ERRCODE_CFGCANNOTWRITE); DBIERR_CFGMULTIFILE = (ERRBASE_SYSTEM + ERRCODE_CFGMULTIFILE);
DBIERR_REQDERR
This is constant nxllBde.DBIERR_REQDERR.
DBIERR_SERVERCOMMLOST
DBIERR_NETINITERR = (ERRBASE_NETWORK + ERRCODE_NETINITERR); DBIERR_NETUSERLIMIT = (ERRBASE_NETWORK + ERRCODE_NETUSERLIMIT); DBIERR_NETFILEVERSION = (ERRBASE_NETWORK + ERRCODE_NETFILEVERSION); DBIERR_NETFILELOCKED = (ERRBASE_NETWORK + ERRCODE_NETFILELOCKED); DBIERR_DIRNOTPRIVATE = (ERRBASE_NETWORK + ERRCODE_DIRNOTPRIVATE); DBIERR_NETMULTIPLE = (ERRBASE_NETWORK + ERRCODE_NETMULTIPLE); DBIERR_NETUNKNOWN = (ERRBASE_NETWORK + ERRCODE_NETUNKNOWN); DBIERR_SHAREDFILE = (ERRBASE_NETWORK + ERRCODE_SHAREDFILE); DBIERR_SHARENOTLOADED = (ERRBASE_NETWORK + ERRCODE_SHARENOTLOADED); DBIERR_NOTONANETWORK = (ERRBASE_NETWORK + ERRCODE_NOTONANETWORK); DBIERR_SQLCOMMLOST = (ERRBASE_NETWORK + ERRCODE_SQLCOMMLOST);
DBIERR_SERVERNOTFOUND
DBIERR_SQLSERVERNOTFOUND = (ERRBASE_NETWORK + ERRCODE_SQLSERVERNOTFOUND);
DBIERR_SERVERVERSION
DBIERR_INTERFACEVER = (ERRBASE_VERSION + ERRCODE_INTERFACEVER); DBIERR_INDEXOUTOFDATE = (ERRBASE_VERSION + ERRCODE_INDEXOUTOFDATE); DBIERR_OLDVERSION = (ERRBASE_VERSION + ERRCODE_OLDVERSION); DBIERR_VALFILEINVALID = (ERRBASE_VERSION + ERRCODE_VALFILEINVALID); DBIERR_BLOBVERSION = (ERRBASE_VERSION + ERRCODE_BLOBVERSION); DBIERR_ENGQRYMISMATCH = (ERRBASE_VERSION + ERRCODE_ENGQRYMISMATCH);
DBIERR_TABLEEXISTS
DBIERR_UNKNOWNSQL = (ERRBASE_OTHER + ERRCODE_UNKNOWNSQL);
DBIERR_TABLEFULL
DBIERR_NOFILEHANDLES = (ERRBASE_LIMIT + ERRCODE_NOFILEHANDLES); DBIERR_NODISKSPACE = (ERRBASE_LIMIT + ERRCODE_NODISKSPACE); DBIERR_NOTEMPTBLSPACE = (ERRBASE_LIMIT + ERRCODE_NOTEMPTBLSPACE); DBIERR_RECTOOBIG = (ERRBASE_LIMIT + ERRCODE_RECTOOBIG); DBIERR_CURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_CURSORLIMIT);
DBIERR_TABLELEVEL
This is constant nxllBde.DBIERR_TABLELEVEL.
DBIERR_TABLEOPEN
This is constant nxllBde.DBIERR_TABLEOPEN.
DBIERR_TABLEREADONLY
DBIERR_PDXDRIVERNOTACTIVE = (ERRBASE_IC + ERRCODE_PDXDRIVERNOTACTIVE); DBIERR_DRIVERNOTLOADED = (ERRBASE_IC + ERRCODE_DRIVERNOTLOADED);
DBIERR_TBLENCRYPTED
This is constant nxllBde.DBIERR_TBLENCRYPTED.
DBIERR_UNKNOWNDB
DBIERR_INDEXNAMEREQUIRED = (ERRBASE_INVALIDREQ + ERRCODE_INDEXNAMEREQUIRED); DBIERR_INVALIDSESHANDLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDSESHANDLE); DBIERR_INVALIDRESTROP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTROP); DBIERR_UNKNOWNDRIVER = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNDRIVER);
DBIERR_UNKNOWNFILE
DBIERR_UNKNOWNTBLTYPE = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNTBLTYPE);
DBIERR_UPDATEABORT
DBIERR_PDX10TABLE = (ERRBASE_OTHER + ERRCODE_PDX10TABLE);
DBIERR_WRITEERR
This is constant nxllBde.DBIERR_WRITEERR.
ERRBASE_CAPABILITY
Capability not supported
ERRBASE_COMPATIBILITY
Compatibility related
ERRBASE_CONFIG
System configuration error
ERRBASE_DATACORRUPT
Physical Data Corruption
ERRBASE_DRIVER
Driver related
ERRBASE_IC
Invalid context
ERRBASE_INTEGRITY
Integrity Violation
ERRBASE_INVALIDREQ
Invalid Request
ERRBASE_IO
I/O related error
ERRBASE_LIMIT
Resource or Limit error
ERRBASE_LOCKCONFLICT
Locking/Contention related
ERRBASE_NETWORK
Network related
ERRBASE_NEXUS
This is constant nxllBde.ERRBASE_NEXUS.
ERRBASE_NONE
No error
ERRBASE_NOTFOUND
Object of interest Not Found
ERRBASE_OPTPARAM
Optional Parameter related
ERRBASE_OS
Os Error not handled by Idapi
ERRBASE_OTHER
Miscellaneous
ERRBASE_QUERY
Query related
ERRBASE_RC
Internal
ERRBASE_REPOSITORY
Data Repository related
ERRBASE_SEC
Access Violation - Security related
ERRBASE_SYSTEM
System related (Fatal Error)
ERRBASE_VERSION
Version Mismatch Category
ERRBASE_WARNING
This is constant nxllBde.ERRBASE_WARNING.
ERRCAT_CAPABILITY
48 Capability not supported
ERRCAT_COMPATIBILITY
52 Compatibility related
ERRCAT_CONFIG
49 System configuration error
ERRCAT_DATACORRUPT
35 Physical Data Corruption
ERRCAT_DRIVER
62 Driver related
ERRCAT_INTEGRITY
38 Integrity Violation
ERRCAT_INVALIDCONTEXT
42 Invalid context
ERRCAT_INVALIDREQ
39 Invalid Request
ERRCAT_IO
36 I/O related error
ERRCAT_LIMIT
37 Resource or Limit error
ERRCAT_LOCKCONFLICT
40 Locking/Contention related
ERRCAT_NETWORK
44 Network related
ERRCAT_NEXUS
This is constant nxllBde.ERRCAT_NEXUS.
ERRCAT_NONE
0 No error
ERRCAT_NOTFOUND
34 Object of interest Not Found
ERRCAT_OPTPARAM
45 Optional parameter related
ERRCAT_OS
43 Os Error not handled by Idapi
ERRCAT_OTHER
51 Miscellaneous
ERRCAT_QUERY
46 Query related
ERRCAT_RC
63 Internal
ERRCAT_REPOSITORY
53 Data Repository related
ERRCAT_SECURITY
41 Access Violation - Security related
ERRCAT_SYSTEM
33 System related (Fatal Error)
ERRCAT_VERSION
47 Version Mismatch Category
ERRCAT_WARNING
50
ERRCODE_ACTIVETRAN
This is constant nxllBde.ERRCODE_ACTIVETRAN.
ERRCODE_BLOBMODIFIED
Another user modified Blob ERRCODE_UNKNOWNSQL = 3; { Unknown SQL error }
ERRCODE_BOF
Beginning of Virtual table
ERRCODE_CHECKCONSTRAINTFAILED
ERRCODE_DETAILTABLESEXIST = 15; { 0x0f Detail Tables exist ( cannot delete, rename ... ) ERRCODE_DETAILRECEXISTEMPTY = 16; { 0x10 Cannot empty because details exist ERRCODE_MASTERREFERENCEERR = 17; { 0x11 Cannot modify while adding self referencing Referential Integrity ERRCODE_DETAILTBLOPEN = 18; { 0x12 Detail Table is opened ERRCODE_DEPENDENTSMUSTBEEMPTY = 19; { 0x13 Cannot make a master a detail of another table if its details are not empty. ERRCODE_RINTREQINDEX = 20; { 0x14 Ref. integrity fields must be indexed ERRCODE_LINKEDTBLPROTECTED = 21; { 0x15 Master Table is protected ( requires password to open) ERRCODE_FIELDMULTILINKED = 22; { 0x16 Field has more than... more
ERRCODE_CLIENTSLIMIT
0x0e Too many clients
ERRCODE_DEADLOCK
This is constant nxllBde.ERRCODE_DEADLOCK.
ERRCODE_DETAILRECORDSEXIST
Cannot MODIFY or DELETE this Master record ERRCODE_MASTERTBLLEVEL = 7; { Master Table Level is incorrect } ERRCODE_LOOKUPTABLEERR = 8; { Field value out of lookup tbl range } ERRCODE_LOOKUPTBLOPENERR = 9; { Lookup Table Open failed } ERRCODE_DETAILTBLOPENERR = 10; { 0x0a Detail Table Open failed } ERRCODE_MASTERTBLOPENERR = 11; { 0x0b Master Table Open failed }
ERRCODE_DIFFERENTTABLES
0x24 Cannot Set Cursor of one Table to another
ERRCODE_DIRNOACCESS
No access to dir ERRCODE_FILEDELETEFAIL = 4; { File delete failed }
ERRCODE_ENDOFBLOB
End of Blob reached
ERRCODE_EOF
End of Virtual table ERRCODE_RECMOVED = 3; { Fly-away }
ERRCODE_FIELDISBLANK
0x0c Field is blank
ERRCODE_FILECORRUPT
File corrupt - other than header ERRCODE_MEMOCORRUPT = 3; { Memo file corrupted } ERRCODE_BMPCORRUPT = 4; { BitMap is corrupt (Internal error) }
ERRCODE_FILELOCKED
ERRCODE_UNLOCKFAILED = 2; ERRCODE_FILEBUSY = 3; ERRCODE_DIRBUSY = 4;
ERRCODE_FILENOACCESS
No access to file ERRCODE_ACCESSDISABLED = 6; { Access to table disabled (previous error) }
ERRCODE_FLDLIMIT
0x14 Too many Fields in Table Create ERRCODE_TBLLOCKLIMIT = 21; { 0x15 Too many table locks } ERRCODE_OPENBLOBLIMIT = 22; { 0x16 Too many open blobs } ERRCODE_LOCKFILELIMIT = 23; { 0x17 Lock file has grown too big } ERRCODE_OPENQRYLIMIT = 24; { 0x18 Too many open queries } ERRCODE_THREADLIMIT = 25; { 0x19 Too many threads for client } ERRCODE_BLOBLIMIT = 26; { 0x1a Too many blobs } ERRCODE_PDX50NAMELIMIT = 27; { 0x1b Pathname is too long for a Paradox 5.0 or less table } ERRCODE_ROWFETCHLIMIT = 28; { 0x1c Row fetch limit } ERRCODE_LONGNAMENOTALLOWED = 29; { 0x1d... more
ERRCODE_FORIEGNKEYERR
Master record missing
ERRCODE_HEADERCORRUPT
Corrupt Header
ERRCODE_INDEXCORRUPT
Index is corrupt ERRCODE_CORRUPTLOCKFILE = 6; { Corrupt lock file } ERRCODE_FAMFILEINVALID = 7; { Corrupt family file } ERRCODE_VALFILECORRUPT = 8; { Val file is missing or corrupt } ERRCODE_FOREIGNINDEX = 9; { Index is in a foreign format - import first }
ERRCODE_INDEXEXISTS
0x2b Index already exists ERRCODE_INDEXOPEN = 44; { 0x2c Index is open }
ERRCODE_INDEXLIMIT
0x0f Too many indexes (also in Table Create) ERRCODE_SESSIONSLIMIT = 16; { 0x10 Too many sessions } ERRCODE_DBLIMIT = 17; { 0x11 Too many databases } ERRCODE_PASSWORDLIMIT = 18; { 0x12 Too many passwords } ERRCODE_DRIVERLIMIT = 19; { 0x13 Too many active drivers }
ERRCODE_INVALIDALIASNAME
0x53 invalid alias name
ERRCODE_INVALIDBLOBHANDLE
0x2e Invalid Blob handle (in record buffer)
ERRCODE_INVALIDBLOBLEN
0x2d Invalid Blob Length
ERRCODE_INVALIDBLOBOFFSET
0x0e Invalid Offset into the Blob
ERRCODE_INVALIDBOOKMARK
0x25 Bookmarks does not match table, etc.
ERRCODE_INVALIDDESC
0x14 Generic: invalid descriptor
ERRCODE_INVALIDDESCNUM
0x0f Invalid descriptor number
ERRCODE_INVALIDDIR
0x22 Invalid directory
ERRCODE_INVALIDFIELDNAME
0x36 Invalid field name
ERRCODE_INVALIDFILEEXTN
0x3a Invalid file extention
ERRCODE_INVALIDFILTER
0x43 Invalid filter
ERRCODE_INVALIDFLDDESC
0x11 Invalid field descriptor
ERRCODE_INVALIDFLDTYPE
0x10 Invalid field type
ERRCODE_INVALIDFLDXFORM
0x12 Invalid field transform
ERRCODE_INVALIDHNDL
Invalid handle to the function ERRCODE_UNKNOWNTBLTYPE = 7; { Table type given not known }
ERRCODE_INVALIDIDXDESC
0x27 Invalid index descriptor
ERRCODE_INVALIDINDEXNAME
0x26 Index/Tag Name is invalid
ERRCODE_INVALIDINDEXSTRUCT
0x15 Invalid array of indexes descriptors ERRCODE_INVALIDVCHKSTRUCT = 22; { 0x16 Invalid array of val. check descriptors } ERRCODE_INVALIDRINTSTRUCT = 23; { 0x17 Invalid array of ref. integrity descriptors } ERRCODE_INVALIDRESTRTBLORDER = 24; { 0x18 Invalid ordering of tables during restructure }
ERRCODE_INVALIDLANGDRV
0x3b Invalid language driver ERRCODE_ALIASNOTOPEN = 60; { 0x3c Requested alias in not open } ERRCODE_INCOMPATRECSTRUCTS = 61; { 0x3d Incompatible record structures } ERRCODE_RESERVEDDOSNAME = 62; { 0x3e Reserved dos name } ERRCODE_DESTMUSTBEINDEXED = 63; { 0x3f Destination must be indexed } ERRCODE_INVALIDINDEXTYPE = 64; { 0x40 Invalid index type } ERRCODE_LANGDRVMISMATCH = 65; { 0x41 Language driver of table and index do not match }
ERRCODE_INVALIDNAME
0x54 invalid alias name
ERRCODE_INVALIDPARAM
Generic invalid parameter ERRCODE_INVALIDFILENAME = 3; { Invalid file name } ERRCODE_NOSUCHFILE = 4; { No such file } ERRCODE_INVALIDOPTION = 5; { Invalid option for a parameter }
ERRCODE_INVALIDPASSWORD
0x1f Invalid password given ERRCODE_NOCALLBACK = 32; { 0x20 No callback function } ERRCODE_INVALIDCALLBACKBUFLEN = 33; { 0x21 Invalid callback buffer length }
ERRCODE_INVALIDRECSTRUCT
0x13 Invalid record structure
ERRCODE_INVALIDTABLENAME
0x37 Invalid table name ERRCODE_INVALIDLINKEXPR = 56; { 0x38 Invalid linked cursor expression } ERRCODE_NAMERESERVED = 57; { 0x39 Name is reserved }
ERRCODE_INVALIDUSRPASS
0x34 Bad user name or password ERRCODE_MULTILEVELCASCADE = 53; { 0x35 Multi level Cascade not supported }
ERRCODE_INVALIDXLATION
0x23 Translate Error - Translate DID NOT happen
ERRCODE_KEYORRECDELETED
Record Deleted/Key Modified
ERRCODE_KEYVIOL
Key violation
ERRCODE_LOCKED
ERRCAT_LOCKCONFLICT
ERRCODE_LOCKTIMEOUT
ERRCODE_DIRLOCKED = 6; ERRCODE_ALREADYLOCKED = 7; ERRCODE_NOTLOCKED = 8;
ERRCODE_MAXVALERR
Max val check failed
ERRCODE_MINVALERR
Min val check failed
ERRCODE_NA
Operation not applicable
ERRCODE_NAMENOTUNIQUE
0x19 Name not unique in this context ERRCODE_INDEXNAMEREQUIRED = 26; { 0x1a Index name required } ERRCODE_INVALIDSESHANDLE = 27; { 0x1b Invalid ses handle } ERRCODE_INVALIDRESTROP = 28; { 0x1c Invalid restructure operation } ERRCODE_UNKNOWNDRIVER = 29; { 0x1d Driver not known to system }
ERRCODE_NEEDEXCLACCESS
0x0d
ERRCODE_NOACTIVETRAN
This is constant nxllBde.ERRCODE_NOACTIVETRAN.
ERRCODE_NOASSOCINDEX
0x0c No index associated with the cursor ERRCODE_HASOPENCURSORS = 13; { 0x0d Has open cursors } ERRCODE_NOTABLESUPPORT = 14; { 0x0e Op cannot be done on this table } ERRCODE_INDEXREADONLY = 15; { 0x0f Index is read only } ERRCODE_NOUNIQUERECS = 16; { 0x10 Records are not unique } ERRCODE_NOTCURSESSION = 17; { 0x11 Not the current/active session } ERRCODE_INVALIDKEYWORD = 18; { 0x12 Invalid use of keyword. } ERRCODE_CONNECTINUSE = 19; { 0x13 Connection in use } ERRCODE_CONNECTNOTSHARED = 20; { 0x14 Passthru SQL connection not share }
ERRCODE_NOCURRREC
No current record
ERRCODE_NOMEMORY
Not enough Memory for this op ERRCODE_NOFILEHANDLES = 2; { Not enough File handles } ERRCODE_NODISKSPACE = 3; { Not enough Disk space } ERRCODE_NOTEMPTBLSPACE = 4; { Temporary Table resource limit } ERRCODE_RECTOOBIG = 5; { Too big a record size for table } ERRCODE_CURSORLIMIT = 6; { Too many open cursors }
ERRCODE_NONE
ERRCAT_NONE (0)
ERRCODE_NOSERVERSW
0x6a Server software not running the workstation/server
ERRCODE_NOSUCHFILTER
0x42 Filter handle is invalid
ERRCODE_NOSUCHINDEX
0x0d Index does not exist
ERRCODE_NOSUCHTABLE
0x28 No such table ERRCODE_USECOUNT = 41; { 0x29 Table has too many users } ERRCODE_INVALIDKEY = 42; { 0x2a Key does not pass filter condition }
ERRCODE_NOTABLOB
Field is not a blob ERRCODE_BLOBOPENED = 2; { Blob already opened } ERRCODE_BLOBNOTOPENED = 3; { Blob not opened }
ERRCODE_NOTINDEXED
Table is not indexed ERRCODE_NOTINITIALIZED = 6; { Engine not initialized } ERRCODE_MULTIPLEINIT = 7; { Attempt to re-initialize engine }
ERRCODE_NOTSAMESESSION
Attempt to mix objs from diff ses ERRCODE_PDXDRIVERNOTACTIVE = 9; { Paradox driver not active } ERRCODE_DRIVERNOTLOADED = 10; { 0x0a Driver not loaded }
ERRCODE_NOTSUFFTABLERIGHTS
Not sufficient table rights for operation ERRCODE_NOTSUFFFAMILYRIGHTS = 3; { Not sufficient family rights for operation } ERRCODE_READONLYDIR = 4; { Is a read-only directory }
ERRCODE_NOTSUPPORTED
Capability not supported ERRCODE_NIY = 2; { Not Implemented Yet } ERRCODE_TABLESQL = 3; { Cannot access SQL replica } ERRCODE_SEARCHCOLREQD = 4; { Searchable (Non-blob column) required } ERRCODE_NOMULTCONNECT = 5; { Multiple connections not supported } ERRCODE_NODBASEEXPR = 6; { Full dBASE Expressions not supported }
ERRCODE_NX_BADBLOCKNR
This is constant nxllBde.ERRCODE_NX_BADBLOCKNR.
ERRCODE_NX_BADDATABLOCK
This is constant nxllBde.ERRCODE_NX_BADDATABLOCK.
ERRCODE_NX_BADHEAPBLOCK
This is constant nxllBde.ERRCODE_NX_BADHEAPBLOCK.
ERRCODE_NX_BADINDEX
This is constant nxllBde.ERRCODE_NX_BADINDEX.
ERRCODE_NX_BADINXBLOCK
This is constant nxllBde.ERRCODE_NX_BADINXBLOCK.
ERRCODE_NX_BADREFNR
This is constant nxllBde.ERRCODE_NX_BADREFNR.
ERRCODE_NX_BADSTREAMBLOCK
This is constant nxllBde.ERRCODE_NX_BADSTREAMBLOCK.
ERRCODE_NX_BADSTRUCT
DBIERR_REPOSITORYCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYCORRUPT); DBIERR_INFOBLOBCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_INFOBLOBCORRUPT); DBIERR_SCHEMACORRUPT = (ERRBASE_REPOSITORY + ERRCODE_SCHEMACORRUPT); DBIERR_ATTRTYPEEXISTS = (ERRBASE_REPOSITORY + ERRCODE_ATTRTYPEEXISTS); DBIERR_INVALIDOBJTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDOBJTYPE); DBIERR_INVALIDRELATIONTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRELATIONTYPE); DBIERR_VIEWEXISTS = (ERRBASE_REPOSITORY + ERRCODE_VIEWEXISTS); DBIERR_NOSUCHVIEW = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHVIEW); DBIERR_INVALIDRECCONSTRAINT = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRECCONSTRAINT); DBIERR_LDBCONNECTION = (ERRBASE_REPOSITORY + ERRCODE_LDBCONNECTION); DBIERR_REPOSITORYEXISTS = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYEXISTS); DBIERR_NOSUCHREPOSITORY = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHREPOSITORY); DBIERR_REPOSITORYDBMISSING = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYDBMISSING); DBIERR_REPOSITORYOUTOFDATE = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYOUTOFDATE); DBIERR_REPOSITORYVERSION = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYVERSION); DBIERR_REPOSITORYNAME = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYNAME); DBIERR_DEPENDENTOBJECTS = (ERRBASE_REPOSITORY... more
ERRCODE_NX_BLOBTOOBIG
This is constant nxllBde.ERRCODE_NX_BLOBTOOBIG.
ERRCODE_NX_CLOSEFAILED
This is constant nxllBde.ERRCODE_NX_CLOSEFAILED.
ERRCODE_NX_COPYFILE
This is constant nxllBde.ERRCODE_NX_COPYFILE.
ERRCODE_NX_CORRUPTTRANS
This is constant nxllBde.ERRCODE_NX_CORRUPTTRANS.
ERRCODE_NX_DELETEFILE
This is constant nxllBde.ERRCODE_NX_DELETEFILE.
ERRCODE_NX_DICT_DUPAUTOINC
This is constant nxllBde.ERRCODE_NX_DICT_DUPAUTOINC.
ERRCODE_NX_DICT_DUPRECREV
This is constant nxllBde.ERRCODE_NX_DICT_DUPRECREV.
ERRCODE_NX_DICT_OBJINUSE
This is constant nxllBde.ERRCODE_NX_DICT_OBJINUSE.
ERRCODE_NX_DICT_READONLY
This is constant nxllBde.ERRCODE_NX_DICT_READONLY.
ERRCODE_NX_FILEBLOBCLOSE
This is constant nxllBde.ERRCODE_NX_FILEBLOBCLOSE.
ERRCODE_NX_FILEBLOBOPEN
This is constant nxllBde.ERRCODE_NX_FILEBLOBOPEN.
ERRCODE_NX_FILEBLOBREAD
This is constant nxllBde.ERRCODE_NX_FILEBLOBREAD.
ERRCODE_NX_FILTERTIMEOUT
This is constant nxllBde.ERRCODE_NX_FILTERTIMEOUT.
ERRCODE_NX_GENERALTIMEOUT
This is constant nxllBde.ERRCODE_NX_GENERALTIMEOUT.
ERRCODE_NX_INCOMPATDICT
This is constant nxllBde.ERRCODE_NX_INCOMPATDICT.
ERRCODE_NX_INCOMPATHEADER
This is constant nxllBde.ERRCODE_NX_INCOMPATHEADER.
ERRCODE_NX_INCOMPATSTREAM
This is constant nxllBde.ERRCODE_NX_INCOMPATSTREAM.
ERRCODE_NX_INDEXNOTEMPTY
This is constant nxllBde.ERRCODE_NX_INDEXNOTEMPTY.
ERRCODE_NX_INVALIDSEGNR
This is constant nxllBde.ERRCODE_NX_INVALIDSEGNR.
ERRCODE_NX_KEYFILTERED_NONE
This is constant nxllBde.ERRCODE_NX_KEYFILTERED_NONE.
ERRCODE_NX_LICENSE_EXPIRED
This is constant nxllBde.ERRCODE_NX_LICENSE_EXPIRED.
ERRCODE_NX_LITE
This is constant nxllBde.ERRCODE_NX_LITE.
ERRCODE_NX_MAXKEYSIZE
This is constant nxllBde.ERRCODE_NX_MAXKEYSIZE.
ERRCODE_NX_MAXRECORDSIZE
This is constant nxllBde.ERRCODE_NX_MAXRECORDSIZE.
ERRCODE_NX_NOSESSIONSE
This is constant nxllBde.ERRCODE_NX_NOSESSIONSE.
ERRCODE_NX_RECOVERFAILED
This is constant nxllBde.ERRCODE_NX_RECOVERFAILED.
ERRCODE_NX_REGISTERFHAF
This is constant nxllBde.ERRCODE_NX_REGISTERFHAF.
ERRCODE_NX_RENAMEFILE
This is constant nxllBde.ERRCODE_NX_RENAMEFILE.
ERRCODE_NX_SAMEFOLDER
This is constant nxllBde.ERRCODE_NX_SAMEFOLDER.
ERRCODE_NX_SAMETABLE
This is constant nxllBde.ERRCODE_NX_SAMETABLE.
ERRCODE_NX_SEGMENTDELETED
This is constant nxllBde.ERRCODE_NX_SEGMENTDELETED.
ERRCODE_NX_SERVERNAMENOTSET
This is constant nxllBde.ERRCODE_NX_SERVERNAMENOTSET.
ERRCODE_NX_SQLSIGNAL
This is constant nxllBde.ERRCODE_NX_SQLSIGNAL.
ERRCODE_NX_TABLEVERSION
This is constant nxllBde.ERRCODE_NX_TABLEVERSION.
ERRCODE_NX_TRIAL
This is constant nxllBde.ERRCODE_NX_TRIAL.
ERRCODE_NX_TS_FULL
This is constant nxllBde.ERRCODE_NX_TS_FULL.
ERRCODE_NX_TS_INVALIDBLOCK
This is constant nxllBde.ERRCODE_NX_TS_INVALIDBLOCK.
ERRCODE_NX_UNKNOWN
This is constant nxllBde.ERRCODE_NX_UNKNOWN.
ERRCODE_NX_UNKNOWNEXCP
This is constant nxllBde.ERRCODE_NX_UNKNOWNEXCP.
ERRCODE_NX_UNKNOWNMSG
This is constant nxllBde.ERRCODE_NX_UNKNOWNMSG.
ERRCODE_NX_UNSUPDICTDESCR
This is constant nxllBde.ERRCODE_NX_UNSUPDICTDESCR.
ERRCODE_NX_UNSUPHEADER
This is constant nxllBde.ERRCODE_NX_UNSUPHEADER.
ERRCODE_NX_UNSUPSUBENGINE
This is constant nxllBde.ERRCODE_NX_UNSUPSUBENGINE.
ERRCODE_OBJNOTFOUND
Generic Not found ERRCODE_FMLMEMBERNOTFOUND = 9; { Family member not found } ERRCODE_BLOBFILEMISSING = 10; { 0x0a Blob file for table is missing } ERRCODE_LDNOTFOUND = 11; { 0x0b Language driver not found }
ERRCODE_OPTRECLOCKFAILED
This is constant nxllBde.ERRCODE_OPTRECLOCKFAILED.
ERRCODE_OPTRECLOCKRECDEL
This is constant nxllBde.ERRCODE_OPTRECLOCKRECDEL.
ERRCODE_OSUNKNOWN
0x27 Unkown | illegal error from rtl
ERRCODE_OUTOFRANGE
Number out of range (e.g field no)
ERRCODE_READERR
Read failure (not expected)
ERRCODE_READONLYDB
Database is read-only
ERRCODE_READONLYFLD
Trying to modify read-only field
ERRCODE_RECGROUPCONFLICT
0x0e
ERRCODE_RECLOCKFAILED
This is constant nxllBde.ERRCODE_RECLOCKFAILED.
ERRCODE_RECNOTFOUND
Record was not found
ERRCODE_REENTERED
System has been illegally re-entered ERRCODE_CANTFINDIDAPI = 8; { Cannot locate IDAPIxx.DLL } ERRCODE_CANTLOADIDAPI = 9; { Cannot load IDAPIxx.DLL } ERRCODE_CANTLOADLIBRARY = 10; { Cannot load a service DLL } ERRCODE_TEMPFILEERR = 11; { Cannot create or open temporary file } ERRCODE_MULTIPLEIDAPI = 12; { Trying to load multiple IDAPIxx.DLL }
ERRCODE_REQDERR
Field value required
ERRCODE_SERVERCOMMLOST
0x0c Lost Communication with IDAPI server ERRCODE_SQLSERVERNOTFOUND = 13; { 0x0d SQL Server not found }
ERRCODE_SERVERNOTFOUND
0x0e SQL Server not found
ERRCODE_SERVERVERSION
Server is incompatible version
ERRCODE_TABLEEXISTS
Table already exsits ERRCODE_PDX10TABLE = 5; { Paradox 1.0 tables not supported }
ERRCODE_TABLEFULL
Table is full ERRCODE_WSSESLIMIT = 8; { Too many sessions from this WS } ERRCODE_SERNUMLIMIT = 9; { Serial number limit (paradox) } ERRCODE_INTERNALLIMIT = 10; { 0x0a Some internal limit (see context) } ERRCODE_OPENTBLLIMIT = 11; { 0x0b Too many open tables } ERRCODE_TBLCURSORLIMIT = 12; { 0x0c Too many cursors per table } ERRCODE_RECLOCKLIMIT = 13; { 0x0d Too many record locks on table }
ERRCODE_TABLELEVEL
Higher table level required
ERRCODE_TABLEOPEN
0x2f Table is open ERRCODE_NEEDRESTRUCTURE = 48; { 0x30 Need to do (hard) restructure } ERRCODE_INVALIDMODE = 49; { 0x31 Invalid mode } ERRCODE_CANNOTCLOSE = 50; { 0x32 Cannot close index } ERRCODE_ACTIVEINDEX = 51; { 0x33 Index is being used to order tbl }
ERRCODE_TABLEREADONLY
0x0b Table is read only
ERRCODE_TBLENCRYPTED
Table is encrypted (dBASE only) ERRCODE_NOTSUFFSQLRIGHTS = 8; { Not sufficient sql rights for operation }
ERRCODE_UNKNOWNDB
0x1e Unknown db
ERRCODE_UNKNOWNFILE
Dont know how to open file ERRCODE_PRIMARYKEYREDEFINE = 9; { Cannot redefine primary key } ERRCODE_INVALIDRINTDESCNUM = 10; { 0x0a Cannot change this RINTDesc } ERRCODE_KEYFLDTYPEMISMATCH = 11; { 0x0b Foreign & Primary Key Mismatch } ERRCODE_INVALIDMODIFYREQUEST = 12; { 0x0c Invalid modify request }
ERRCODE_UPDATEABORT
Update operation aborted
ERRCODE_WRITEERR
Write failure (not expected)
fldADT
Abstract datatype (structure)
fldARRAY
Array field type
fldBCD
BCD
fldBLOB
Blob
fldBOOL
Boolean (16 bit)
fldBYTES
Fixed number of bytes
fldCURSOR
For Oracle Cursor type
fldDATE
Date (32 bit)
fldDATETIME
Datetime structure for DBExpress
fldDATETIMEOFFSET
DatetimeOffset structure for DBExpress
fldFLOAT
64 bit floating point
fldFLOATIEEE
80-bit IEEE float
fldFMTBCD
BCD Variant type: required by Midas, same as BCD for DBExpress
fldINT16
16 bit signed number
fldINT32
32 bit signed number
fldINT64
64 bit signed number
fldINT8
8 bit signed number as defined in alctypes.h
fldLOCKINFO
Look for LOCKINFO typedef
fldREF
Reference to ADT
fldSINGLE
32 bit floating point
fldstACCOLEOBJ
Access OLE object
fldstAUTOINC
fldINT32 subtype
fldstBFILE
BFILE
fldstBINARY
Binary data
fldstDBSOLEOBJ
dBASE OLE object
fldstFIXED
CHAR type
fldstFMTMEMO
Formatted Text
fldstGRAPHIC
Graphics object
fldstGUID
GUID
fldstHBINARY
BLOB
fldstHMEMO
CLOB
fldstMEMO
Text Memo
fldstMONEY
Money
fldstOLEOBJ
OLE object (Paradox)
fldstORAINTERVAL
ORACLE INTERVAL
fldstORATIMESTAMP
ORACLE TIMESTAMP
fldstPASSWORD
Password
fldstTYPEDBINARY
Typed Binary data
fldstWIDEMEMO
WideString Memo
fldTABLE
Nested table (reference)
fldTIME
Time (32 bit)
fldTIMESTAMP
Time-stamp (64 bit)
fldUINT16
Unsigned 16 bit integer
fldUINT32
Unsigned 32 bit integer
fldUINT64
Unsigned 64 bit integer
fldUINT8
Unsigned 8 bit integer (Byte) as defined in alctypes.h
fldUNICODE
Unicode
fldUNKNOWN
Field Types (Logical)
fldVARBYTES
Length prefixed var bytes
fldWIDESTRING
UCS2 null terminated string
fldZSTRING
Null terminated string
MAXLOGFLDTYPES
Number of logical fieldtypes
Functions
Name | Description
ErrCat | Error Categories
Structs, Records, Enums
Name | Description
CANBinary | Binary Node (*)
CANCompare | Extended compare Node (text fields) (*)
CANConst | Constant
CANContinue | Break Node (*)
CANExpr | Expression Tree
CANField | Field
CANFunc | Function
CANHdr | Header part common to all (*)
CANList | List of Constants
CANListElem | List Element
CANTuple | Tuple (record)
CANUnary | Unary Node (*)
NODEClass | This is record nxllBde.NODEClass.
TnxCANOp | This is record nxllBde.TnxCANOp.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
DBIDATE | This is type nxllBde.DBIDATE.
DBIMSG | This is type nxllBde.DBIMSG.
DBITIME | This is type nxllBde.DBITIME.
pCANBinary | This is type nxllBde.pCANBinary.
pCANCompare | This is type nxllBde.pCANCompare.
pCANConst | This is type nxllBde.pCANConst.
pCANContinue | This is type nxllBde.pCANContinue.
pCANExpr | This is type nxllBde.pCANExpr.
pCANField | This is type nxllBde.pCANField.
pCANFunc | This is type nxllBde.pCANFunc.
pCANHdr | NODE definitions including misc data structures
pCANList | This is type nxllBde.pCANList.
pCANListElem | This is type nxllBde.pCANListElem.
pCANTuple | This is type nxllBde.pCANTuple.
pCANUnary | This is type nxllBde.pCANUnary.
PnxCANOp | Filter description
ppCANExpr | Linear exression tree
TIMESTAMP | This is type nxllBde.TIMESTAMP.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Functions

Functions
Functions nxllBde Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ErrCat | Error Categories
Namespace

nxllBde Namespace

Links
Functions, nxllBde Namespace, Legend


nxllBde.ErrCat Function

nxllBde.ErrCat Function
nxllBde Functions Send Feedback
Syntax
Delphi
function ErrCat(rslt: Word): Word;
File

nxllBde

Description

Error Categories

Group

Functions

Links
nxllBde, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllBde Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
NODEClass | This is record nxllBde.NODEClass.
TnxCANOp | This is record nxllBde.TnxCANOp.
Namespace

nxllBde Namespace

Records
Name | Description
CANBinary | Binary Node (*)
CANCompare | Extended compare Node (text fields) (*)
CANConst | Constant
CANContinue | Break Node (*)
CANExpr | Expression Tree
CANField | Field
CANFunc | Function
CANHdr | Header part common to all (*)
CANList | List of Constants
CANListElem | List Element
CANTuple | Tuple (record)
CANUnary | Unary Node (*)
Links
Enumerations, nxllBde Namespace, Legend, Records


nxllBde.CANBinary Record

nxllBde.CANBinary Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANBinary = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iOperand1: Word;
  iOperand2: Word;
end;
File

nxllBde

Members
Members | Description
iOperand1: Word; | Byte offset of Op1
iOperand2: Word; | Byte offset of Op2
Description

Binary Node (*)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANCompare Record

nxllBde.CANCompare Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANCompare = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  bCaseInsensitive: WordBool;
  iPartialLen: Word;
  iOperand1: Word;
  iOperand2: Word;
end;
File

nxllBde

Members
Members | Description
canOp: TnxCANOp; | canLIKE, canEQ
bCaseInsensitive: WordBool; | 3 val: UNKNOWN = "fastest", "native
iPartialLen: Word; | Partial fieldlength (0 is full length)
iOperand1: Word; | Byte offset of Op1
iOperand2: Word; | Byte offset of Op2
Description

Extended compare Node (text fields) (*)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANConst Record

nxllBde.CANConst Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANConst = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iType: Word;
  iSize: Word;
  iOffset: Word;
end;
File

nxllBde

Members
Members | Description
iType: Word; | Constant type.
iSize: Word; | Constant size. (in bytes)
iOffset: Word; | Offset in the literal pool.
Description

Constant

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANContinue Record

nxllBde.CANContinue Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANContinue = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iContOperand: Word;
end;
File

nxllBde

Members
Members | Description
iContOperand: Word; | Continue if operand is true.
Description

Break Node (*)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANExpr Record

nxllBde.CANExpr Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANExpr = packed record
  iVer: Word;
  iTotalSize: Word;
  iNodes: Word;
  iNodeStart: Word;
  iLiteralStart: Word;
end;
File

nxllBde

Members
Members | Description
iVer: Word; | Version tag of expression.
iTotalSize: Word; | Size of this structure
iNodes: Word; | Number of nodes
iNodeStart: Word; | Starting offet of Nodes in this
iLiteralStart: Word; | Starting offset of Literals in this
Description

Expression Tree

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANField Record

nxllBde.CANField Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANField = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iFieldNum: Word;
  iNameOffset: Word;
end;
File

nxllBde

Members
Members | Description
iNameOffset: Word; | Name offset in Literal pool
Description

Field

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANFunc Record

nxllBde.CANFunc Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANFunc = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iNameOffset: Word;
  iElemOffset: Word;
end;
File

nxllBde

Members
Members | Description
iNameOffset: Word; | Name offset in Literal pool
iElemOffset: Word; | Offset of first List Element in Node pool
Description

Function

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANHdr Record

nxllBde.CANHdr Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANHdr = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
end;
File

nxllBde

Description

Header part common to all (*)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANList Record

nxllBde.CANList Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANList = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iType: Word;
  iTotalSize: Word;
  iElemSize: Word;
  iElems: Word;
  iOffset: Word;
end;
File

nxllBde

Members
Members | Description
iType: Word; | Constant type.
iTotalSize: Word; | Total list size;
iElemSize: Word; | Size of each elem for fix-width types
iElems: Word; | Number of elements in list
iOffset: Word; | Offset in the literal pool to first elem.
Description

List of Constants

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANListElem Record

nxllBde.CANListElem Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANListElem = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iOffset: Word;
  iNextOffset: Word;
end;
File

nxllBde

Members
Members | Description
iOffset: Word; | Arg offset in Node pool
iNextOffset: Word; | Offset in Node pool of next ListElem or 0 if end of list
Description

List Element

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANTuple Record

nxllBde.CANTuple Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANTuple = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iSize: Word;
end;
File

nxllBde

Members
Members | Description
iSize: Word; | Record size. (in bytes)
Description

Tuple (record)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.CANUnary Record

nxllBde.CANUnary Record
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
CANUnary = packed record
  nodeClass: NODEClass;
  canOp: TnxCANOp;
  iOperand1: Word;
end;
File

nxllBde

Members
Members | Description
iOperand1: Word; | Byte offset of Operand node
Description

Unary Node (*)

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.NODEClass Enumeration

nxllBde.NODEClass Enumeration
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
NODEClass = ( nodeNULL, nodeUNARY, nodeBINARY, nodeCOMPARE, nodeFIELD, nodeCONST, nodeTUPLE, nodeCONTINUE, nodeUDF, nodeLIST, nodeFUNC, nodeLISTELEM );
File

nxllBde

Members
Members | Description
nodeNULL | Null node (*)
nodeUNARY | Node is a unary (*)
nodeBINARY | Node is a binary (*)
nodeCOMPARE | Node is a compare (*)
nodeFIELD | Node is a field (*)
nodeCONST | Node is a constant (*)
nodeTUPLE | Node is a record
nodeCONTINUE | Node is a continue node (*)
nodeUDF | Node is a UDF node
nodeLIST | Node is a LIST node
nodeFUNC | Node is a Function node
nodeLISTELEM | Node is a List Element node
Description

This is record nxllBde.NODEClass.

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


nxllBde.TnxCANOp Enumeration

nxllBde.TnxCANOp Enumeration
nxllBde Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCANOp = ( canNOTDEFINED, canISBLANK, canNOTBLANK, canEQ, canNE, canGT, canLT, canGE, canLE, canNOT, canAND, canOR, canTUPLE2, canFIELD2, canCONST2, canMINUS, canADD, canSUB, canMUL, canDIV, canMOD, canREM, canSUM, canCOUNT, canMIN, canMAX, canAVG, canCONT, canUDF2, canCONTINUE2, canLIKE, canIN, canLIST2, canUPPER, canLOWER, canFUNC2, canLISTELEM2, canASSIGN );
File

nxllBde

Members
Members | Description
canNOTDEFINED | (*)
canISBLANK | CANUnary; is operand blank. (*)
canNOTBLANK | CANUnary; is operand not blank. (*)
canEQ | CANBinary, CANCompare; equal. (*)
canNE | CANBinary; NOT equal. (*)
canGT | CANBinary; greater than. (*)
canLT | CANBinary; less than. (*)
canGE | CANBinary; greater or equal. (*)
canLE | CANBinary; less or equal. (*)
canNOT | CANUnary; NOT (*)
canAND | CANBinary; AND (*)
canOR | CANBinary; OR (*)
canTUPLE2 | CANUnary; Entire record is operand.
canFIELD2 | CANUnary; operand is field (*)
canCONST2 | CANUnary; operand is constant (*)
canMINUS | CANUnary; minus.
canADD | CANBinary; addition.
canSUB | CANBinary; subtraction.
canMUL | CANBinary; multiplication.
canDIV | CANBinary; division.
canMOD | CANBinary; modulo division.
canREM | CANBinary; remainder of division.
canSUM | CANBinary, accumulate sum of.
canCOUNT | CANBinary, accumulate count of.
canMIN | CANBinary, find minimum of.
canMAX | CANBinary, find maximum of.
canAVG | CANBinary, find average of.
canCONT | CANBinary; provides a link between two
canUDF2 | CANBinary; invokes a User defined fn
canCONTINUE2 | CANUnary; Stops evaluating records
canLIKE | CANCompare, extended binary compare (*)
canIN | CANBinary field in list of values
canLIST2 | List of constant values of same type
canUPPER | CANUnary: upper case
canLOWER | CANUnary: lower case
canFUNC2 | CANFunc: Function
canLISTELEM2 | CANListElem: List Element
canASSIGN | CANBinary: Field assignment
Description

This is record nxllBde.TnxCANOp.

Group

Structs, Records, Enums

Links
nxllBde, Structs, Records, Enums


Types

Types
nxllBde Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllBde Namespace

Types
Name | Description
DBIDATE | This is type nxllBde.DBIDATE.
DBIMSG | This is type nxllBde.DBIMSG.
DBITIME | This is type nxllBde.DBITIME.
pCANBinary | This is type nxllBde.pCANBinary.
pCANCompare | This is type nxllBde.pCANCompare.
pCANConst | This is type nxllBde.pCANConst.
pCANContinue | This is type nxllBde.pCANContinue.
pCANExpr | This is type nxllBde.pCANExpr.
pCANField | This is type nxllBde.pCANField.
pCANFunc | This is type nxllBde.pCANFunc.
pCANHdr | NODE definitions including misc data structures
pCANList | This is type nxllBde.pCANList.
pCANListElem | This is type nxllBde.pCANListElem.
pCANTuple | This is type nxllBde.pCANTuple.
pCANUnary | This is type nxllBde.pCANUnary.
PnxCANOp | Filter description
ppCANExpr | Linear exression tree
TIMESTAMP | This is type nxllBde.TIMESTAMP.
Links
nxllBde Namespace, Types


nxllBde.DBIDATE Type

nxllBde.DBIDATE Type
nxllBde Types Send Feedback
Syntax
Delphi
DBIDATE = Integer;
File

nxllBde

Description

This is type nxllBde.DBIDATE.

Group

Types

Links
nxllBde, Types


nxllBde.DBIMSG Type

nxllBde.DBIMSG Type
nxllBde Types Send Feedback
Syntax
Delphi
DBIMSG = array [0..255] of AnsiChar;
File

nxllBde

Description

This is type nxllBde.DBIMSG.

Group

Types

Links
nxllBde, Types


nxllBde.DBITIME Type

nxllBde.DBITIME Type
nxllBde Types Send Feedback
Syntax
Delphi
DBITIME = Integer;
File

nxllBde

Description

This is type nxllBde.DBITIME.

Group

Types

Links
nxllBde, Types


nxllBde.pCANBinary Type

nxllBde.pCANBinary Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANBinary = ^CANBinary;
File

nxllBde

Description

This is type nxllBde.pCANBinary.

Group

Types

Links
nxllBde, Types


nxllBde.pCANCompare Type

nxllBde.pCANCompare Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANCompare = ^CANCompare;
File

nxllBde

Description

This is type nxllBde.pCANCompare.

Group

Types

Links
nxllBde, Types


nxllBde.pCANConst Type

nxllBde.pCANConst Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANConst = ^CANConst;
File

nxllBde

Description

This is type nxllBde.pCANConst.

Group

Types

Links
nxllBde, Types


nxllBde.pCANContinue Type

nxllBde.pCANContinue Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANContinue = ^CANContinue;
File

nxllBde

Description

This is type nxllBde.pCANContinue.

Group

Types

Links
nxllBde, Types


nxllBde.pCANExpr Type

nxllBde.pCANExpr Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANExpr = ^CANExpr;
File

nxllBde

Description

This is type nxllBde.pCANExpr.

Group

Types

Links
nxllBde, Types


nxllBde.pCANField Type

nxllBde.pCANField Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANField = ^CANField;
File

nxllBde

Description

This is type nxllBde.pCANField.

Group

Types

Links
nxllBde, Types


nxllBde.pCANFunc Type

nxllBde.pCANFunc Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANFunc = ^CANFunc;
File

nxllBde

Description

This is type nxllBde.pCANFunc.

Group

Types

Links
nxllBde, Types


nxllBde.pCANHdr Type

nxllBde.pCANHdr Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANHdr = ^CANHdr;
File

nxllBde

Description

NODE definitions including misc data structures

Group

Types

Links
nxllBde, Types


nxllBde.pCANList Type

nxllBde.pCANList Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANList = ^CANList;
File

nxllBde

Description

This is type nxllBde.pCANList.

Group

Types

Links
nxllBde, Types


nxllBde.pCANListElem Type

nxllBde.pCANListElem Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANListElem = ^CANListElem;
File

nxllBde

Description

This is type nxllBde.pCANListElem.

Group

Types

Links
nxllBde, Types


nxllBde.pCANTuple Type

nxllBde.pCANTuple Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANTuple = ^CANTuple;
File

nxllBde

Description

This is type nxllBde.pCANTuple.

Group

Types

Links
nxllBde, Types


nxllBde.pCANUnary Type

nxllBde.pCANUnary Type
nxllBde Types Send Feedback
Syntax
Delphi
pCANUnary = ^CANUnary;
File

nxllBde

Description

This is type nxllBde.pCANUnary.

Group

Types

Links
nxllBde, Types


nxllBde.PnxCANOp Type

nxllBde.PnxCANOp Type
nxllBde Types Send Feedback
Syntax
Delphi
PnxCANOp = ^TnxCANOp;
File

nxllBde

Description

Filter description

Group

Types

Links
nxllBde, Types


nxllBde.ppCANExpr Type

nxllBde.ppCANExpr Type
nxllBde Types Send Feedback
Syntax
Delphi
ppCANExpr = ^pCANExpr;
File

nxllBde

Description

Linear exression tree

Group

Types

Links
nxllBde, Types


nxllBde.TIMESTAMP Type

nxllBde.TIMESTAMP Type
nxllBde Types Send Feedback
Syntax
Delphi
TIMESTAMP = Double;
File

nxllBde

Description

This is type nxllBde.TIMESTAMP.

Group

Types

Links
nxllBde, Types


Constants

Constants
Constants nxllBde Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name
Description
DBICODE_BLOBERR
0x78 DBICODE_RESTARTQRY = 121; { 0x79 } DBICODE_UNKNOWNANSTYPE = 122; { 0x7a }
DBIERR_ACTIVETRAN
This is constant nxllBde.DBIERR_ACTIVETRAN.
DBIERR_BLOBERR
DBIERR_AMBJOASY = (ERRBASE_QUERY+DBICODE_AMBJOASY); DBIERR_AMBJOSYM = (ERRBASE_QUERY+DBICODE_AMBJOSYM); DBIERR_AMBOUTEX = (ERRBASE_QUERY+DBICODE_AMBOUTEX); DBIERR_AMBOUTPR = (ERRBASE_QUERY+DBICODE_AMBOUTPR); DBIERR_AMBSYMAS = (ERRBASE_QUERY+DBICODE_AMBSYMAS); DBIERR_ASETOPER = (ERRBASE_QUERY+DBICODE_ASETOPER); DBIERR_AVENUMDA = (ERRBASE_QUERY+DBICODE_AVENUMDA); DBIERR_BADEXPR1 = (ERRBASE_QUERY+DBICODE_BADEXPR1); DBIERR_BADFLDOR = (ERRBASE_QUERY+DBICODE_BADFLDOR); DBIERR_BADVNAME = (ERRBASE_QUERY+DBICODE_BADVNAME); DBIERR_BITMAPER = (ERRBASE_QUERY+DBICODE_BITMAPER); DBIERR_CALCBADR = (ERRBASE_QUERY+DBICODE_CALCBADR); DBIERR_CALCTYPE = (ERRBASE_QUERY+DBICODE_CALCTYPE); DBIERR_CHGTO1TI = (ERRBASE_QUERY+DBICODE_CHGTO1TI); DBIERR_CHGTOCHG = (ERRBASE_QUERY+DBICODE_CHGTOCHG); DBIERR_CHGTOEXP = (ERRBASE_QUERY+DBICODE_CHGTOEXP); DBIERR_CHGTOINS = (ERRBASE_QUERY+DBICODE_CHGTOINS); DBIERR_CHGTONEW = (ERRBASE_QUERY+DBICODE_CHGTONEW); DBIERR_CHGTOVAL = (ERRBASE_QUERY+DBICODE_CHGTOVAL); DBIERR_CHKMRKFI = (ERRBASE_QUERY+DBICODE_CHKMRKFI);... more
DBIERR_BLOBMODIFIED
DBIERR_FILEEXISTS = (ERRBASE_OTHER + ERRCODE_FILEEXISTS);
DBIERR_BOF
This is constant nxllBde.DBIERR_BOF.
DBIERR_CHECKCONSTRAINTFAILED
DBIERR_MASTEREXISTS = (ERRBASE_INTEGRITY + ERRCODE_MASTEREXISTS); DBIERR_MASTERTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPEN); DBIERR_DETAILTABLESEXIST = (ERRBASE_INTEGRITY + ERRCODE_DETAILTABLESEXIST); DBIERR_DETAILRECEXISTEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DETAILRECEXISTEMPTY); DBIERR_MASTERREFERENCEERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERREFERENCEERR); DBIERR_DETAILTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPEN); DBIERR_DEPENDENTSMUSTBEEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DEPENDENTSMUSTBEEMPTY); DBIERR_RINTREQINDEX = (ERRBASE_INTEGRITY + ERRCODE_RINTREQINDEX); DBIERR_LINKEDTBLPROTECTED = (ERRBASE_INTEGRITY + ERRCODE_LINKEDTBLPROTECTED); DBIERR_FIELDMULTILINKED = (ERRBASE_INTEGRITY + ERRCODE_FIELDMULTILINKED);
DBIERR_CLIENTSLIMIT
DBIERR_WSSESLIMIT = (ERRBASE_LIMIT + ERRCODE_WSSESLIMIT); DBIERR_SERNUMLIMIT = (ERRBASE_LIMIT + ERRCODE_SERNUMLIMIT); DBIERR_INTERNALLIMIT = (ERRBASE_LIMIT + ERRCODE_INTERNALLIMIT); DBIERR_OPENTBLLIMIT = (ERRBASE_LIMIT + ERRCODE_OPENTBLLIMIT); DBIERR_TBLCURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_TBLCURSORLIMIT); DBIERR_RECLOCKLIMIT = (ERRBASE_LIMIT + ERRCODE_RECLOCKLIMIT);
DBIERR_DEADLOCK
This is constant nxllBde.DBIERR_DEADLOCK.
DBIERR_DETAILRECORDSEXIST
This is constant nxllBde.DBIERR_DETAILRECORDSEXIST.
DBIERR_DIFFERENTTABLES
This is constant nxllBde.DBIERR_DIFFERENTTABLES.
DBIERR_DIRNOACCESS
This is constant nxllBde.DBIERR_DIRNOACCESS.
DBIERR_ENDOFBLOB
This is constant nxllBde.DBIERR_ENDOFBLOB.
DBIERR_EOF
This is constant nxllBde.DBIERR_EOF.
DBIERR_FIELDISBLANK
DBIERR_MASTERTBLLEVEL = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLLEVEL); DBIERR_LOOKUPTABLEERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTABLEERR); DBIERR_LOOKUPTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTBLOPENERR); DBIERR_DETAILTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPENERR); DBIERR_MASTERTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPENERR);
DBIERR_FILECORRUPT
This is constant nxllBde.DBIERR_FILECORRUPT.
DBIERR_FILELOCKED
DBIERR_UNLOCKFAILED = (ERRBASE_LOCKCONFLICT + ERRCODE_UNLOCKFAILED); DBIERR_FILEBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_FILEBUSY); DBIERR_DIRBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRBUSY);
DBIERR_FILENOACCESS
DBIERR_FILEDELETEFAIL = (ERRBASE_IO + ERRCODE_FILEDELETEFAIL);
DBIERR_FLDLIMIT
DBIERR_SESSIONSLIMIT = (ERRBASE_LIMIT + ERRCODE_SESSIONSLIMIT); DBIERR_DBLIMIT = (ERRBASE_LIMIT + ERRCODE_DBLIMIT); DBIERR_PASSWORDLIMIT = (ERRBASE_LIMIT + ERRCODE_PASSWORDLIMIT); DBIERR_DRIVERLIMIT = (ERRBASE_LIMIT + ERRCODE_DRIVERLIMIT);
DBIERR_FORIEGNKEYERR
This is constant nxllBde.DBIERR_FORIEGNKEYERR.
DBIERR_GROUPLOCKCONFLICT
This is constant nxllBde.DBIERR_GROUPLOCKCONFLICT.
DBIERR_HEADERCORRUPT
This is constant nxllBde.DBIERR_HEADERCORRUPT.
DBIERR_INDEXCORRUPT
DBIERR_MEMOCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_MEMOCORRUPT); DBIERR_BMPCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_BMPCORRUPT);
DBIERR_INDEXEXISTS
DBIERR_USECOUNT = (ERRBASE_INVALIDREQ + ERRCODE_USECOUNT); DBIERR_INVALIDKEY = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDKEY);
DBIERR_INDEXLIMIT
This is constant nxllBde.DBIERR_INDEXLIMIT.
DBIERR_INVALIDALIASNAME
DBIERR_INVALIDTABLECREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLECREATE); DBIERR_INVALIDTABLEDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLEDELETE); DBIERR_INVALIDINDEXCREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXCREATE); DBIERR_INVALIDINDEXDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXDELETE); DBIERR_INVALIDTABLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLE); DBIERR_MULTIRESULTS = (ERRBASE_INVALIDREQ + ERRCODE_MULTIRESULTS); DBIERR_INVALIDTIME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIME); DBIERR_INVALIDDATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDATE); DBIERR_INVALIDTIMESTAMP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIMESTAMP); DBIERR_DIFFERENTPATH = (ERRBASE_INVALIDREQ + ERRCODE_DIFFERENTPATH); DBIERR_MISMATCHARGS = (ERRBASE_INVALIDREQ + ERRCODE_MISMATCHARGS); DBIERR_FUNCTIONNOTFOUND = (ERRBASE_INVALIDREQ + ERRCODE_FUNCTIONNOTFOUND); DBIERR_MUSTUSEBASEORDER = (ERRBASE_INVALIDREQ + ERRCODE_MUSTUSEBASEORDER); DBIERR_INVALIDPROCEDURENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDPROCEDURENAME); DBIERR_INVALIDFLDMAP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDMAP);
DBIERR_INVALIDBLOBHANDLE
This is constant nxllBde.DBIERR_INVALIDBLOBHANDLE.
DBIERR_INVALIDBLOBLEN
DBIERR_INDEXOPEN = (ERRBASE_INVALIDREQ + ERRCODE_INDEXOPEN);
DBIERR_INVALIDBLOBOFFSET
This is constant nxllBde.DBIERR_INVALIDBLOBOFFSET.
DBIERR_INVALIDBOOKMARK
This is constant nxllBde.DBIERR_INVALIDBOOKMARK.
DBIERR_INVALIDDESC
This is constant nxllBde.DBIERR_INVALIDDESC.
DBIERR_INVALIDDESCNUM
This is constant nxllBde.DBIERR_INVALIDDESCNUM.
DBIERR_INVALIDDIR
DBIERR_NOCALLBACK = (ERRBASE_INVALIDREQ + ERRCODE_NOCALLBACK); DBIERR_INVALIDCALLBACKBUFLEN = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDCALLBACKBUFLEN );
DBIERR_INVALIDFIELDNAME
DBIERR_MULTILEVELCASCADE = (ERRBASE_INVALIDREQ + ERRCODE_MULTILEVELCASCADE);
DBIERR_INVALIDFILEEXTN
DBIERR_INVALIDLINKEXPR = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDLINKEXPR); DBIERR_NAMERESERVED = (ERRBASE_INVALIDREQ + ERRCODE_NAMERESERVED);
DBIERR_INVALIDFILTER
This is constant nxllBde.DBIERR_INVALIDFILTER.
DBIERR_INVALIDFLDDESC
This is constant nxllBde.DBIERR_INVALIDFLDDESC.
DBIERR_INVALIDFLDTYPE
This is constant nxllBde.DBIERR_INVALIDFLDTYPE.
DBIERR_INVALIDFLDXFORM
This is constant nxllBde.DBIERR_INVALIDFLDXFORM.
DBIERR_INVALIDHNDL
DBIERR_INVALIDFILENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFILENAME); DBIERR_NOSUCHFILE = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHFILE); DBIERR_INVALIDOPTION = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDOPTION);
DBIERR_INVALIDIDXDESC
This is constant nxllBde.DBIERR_INVALIDIDXDESC.
DBIERR_INVALIDINDEXNAME
This is constant nxllBde.DBIERR_INVALIDINDEXNAME.
DBIERR_INVALIDINDEXSTRUCT
This is constant nxllBde.DBIERR_INVALIDINDEXSTRUCT.
DBIERR_INVALIDLANGDRV
This is constant nxllBde.DBIERR_INVALIDLANGDRV.
DBIERR_INVALIDNAME
This is constant nxllBde.DBIERR_INVALIDNAME.
DBIERR_INVALIDPARAM
This is constant nxllBde.DBIERR_INVALIDPARAM.
DBIERR_INVALIDPASSWORD
This is constant nxllBde.DBIERR_INVALIDPASSWORD.
DBIERR_INVALIDRECSTRUCT
This is constant nxllBde.DBIERR_INVALIDRECSTRUCT.
DBIERR_INVALIDTABLENAME
This is constant nxllBde.DBIERR_INVALIDTABLENAME.
DBIERR_INVALIDUSRPASS
DBIERR_NEEDRESTRUCTURE = (ERRBASE_INVALIDREQ + ERRCODE_NEEDRESTRUCTURE); DBIERR_INVALIDMODE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODE); DBIERR_CANNOTCLOSE = (ERRBASE_INVALIDREQ + ERRCODE_CANNOTCLOSE); DBIERR_ACTIVEINDEX = (ERRBASE_INVALIDREQ + ERRCODE_ACTIVEINDEX);
DBIERR_INVALIDXLATION
This is constant nxllBde.DBIERR_INVALIDXLATION.
DBIERR_KEYORRECDELETED
This is constant nxllBde.DBIERR_KEYORRECDELETED.
DBIERR_KEYVIOL
This is constant nxllBde.DBIERR_KEYVIOL.
DBIERR_LOCKED
ERRCODE_LOCKEDRECS = 21; ERRCODE_NEEDWRITELOCK = 22;
DBIERR_LOCKTIMEOUT
DBIERR_DIRLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRLOCKED); DBIERR_ALREADYLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_ALREADYLOCKED); DBIERR_NOTLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_NOTLOCKED);
DBIERR_MAXVALERR
This is constant nxllBde.DBIERR_MAXVALERR.
DBIERR_MINVALERR
This is constant nxllBde.DBIERR_MINVALERR.
DBIERR_NA
DBIERR_BLOBOPENED = (ERRBASE_IC + ERRCODE_BLOBOPENED); DBIERR_BLOBNOTOPENED = (ERRBASE_IC + ERRCODE_BLOBNOTOPENED);
DBIERR_NAMENOTUNIQUE
DBIERR_INVALIDVCHKSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDVCHKSTRUCT); DBIERR_INVALIDRINTSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTSTRUCT); DBIERR_INVALIDRESTRTBLORDER = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTRTBLORDER);
DBIERR_NEEDEXCLACCESS
DBIERR_GROUPLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_GROUPLOCKED); DBIERR_LOSTTBLLOCK = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTTBLLOCK); DBIERR_LOSTEXCLACCESS = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTEXCLACCESS);
DBIERR_NOACTIVETRAN
This is constant nxllBde.DBIERR_NOACTIVETRAN.
DBIERR_NOASSOCINDEX
This is constant nxllBde.DBIERR_NOASSOCINDEX.
DBIERR_NOCURRREC
This is constant nxllBde.DBIERR_NOCURRREC.
DBIERR_NOMEMORY
This is constant nxllBde.DBIERR_NOMEMORY.
DBIERR_NONE
This is constant nxllBde.DBIERR_NONE.
DBIERR_NOSERVERSW
DBIERR_NOTEXACT = ( ERRBASE_OS + ERRCODE_NOTEXACT ); DBIERR_OSUNKNOWNSRVERR = ( ERRBASE_OS + ERRCODE_OSUNKNOWNSRVERR ); DBIERR_SERVERNOMEMORY = ( ERRBASE_OS + ERRCODE_SERVERNOMEMORY ); DBIERR_OSALREADYLOCKED = ( ERRBASE_OS + ERRCODE_OSALREADYLOCKED ); DBIERR_OSNOTLOCKED = ( ERRBASE_OS + ERRCODE_OSNOTLOCKED );
DBIERR_NOSUCHFILTER
DBIERR_ALIASNOTOPEN = (ERRBASE_INVALIDREQ + ERRCODE_ALIASNOTOPEN); DBIERR_INCOMPATRECSTRUCTS = (ERRBASE_INVALIDREQ + ERRCODE_INCOMPATRECSTRUCTS); DBIERR_RESERVEDOSNAME = (ERRBASE_INVALIDREQ + ERRCODE_RESERVEDDOSNAME); DBIERR_DESTMUSTBEINDEXED = (ERRBASE_INVALIDREQ + ERRCODE_DESTMUSTBEINDEXED); DBIERR_INVALIDINDEXTYPE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXTYPE); DBIERR_LANGDRVMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_LANGDRVMISMATCH);
DBIERR_NOSUCHINDEX
DBIERR_PRIMARYKEYREDEFINE = (ERRBASE_INVALIDREQ + ERRCODE_PRIMARYKEYREDEFINE); DBIERR_INVALIDRINTDESCNUM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTDESCNUM); DBIERR_KEYFLDTYPEMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_KEYFLDTYPEMISMATCH); DBIERR_INVALIDMODIFYREQUEST = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODIFYREQUEST);
DBIERR_NOSUCHTABLE
This is constant nxllBde.DBIERR_NOSUCHTABLE.
DBIERR_NOTABLOB
This is constant nxllBde.DBIERR_NOTABLOB.
DBIERR_NOTINDEXED
This is constant nxllBde.DBIERR_NOTINDEXED.
DBIERR_NOTSAMESESSION
DBIERR_NOTINITIALIZED = (ERRBASE_IC + ERRCODE_NOTINITIALIZED); DBIERR_MULTIPLEINIT = (ERRBASE_IC + ERRCODE_MULTIPLEINIT);
DBIERR_NOTSUFFTABLERIGHTS
DBIERR_NOTSUFFFIELDRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFIELDRIGHTS);
DBIERR_NOTSUPPORTED
This is constant nxllBde.DBIERR_NOTSUPPORTED.
DBIERR_NX_BADBLOCKNR
This is constant nxllBde.DBIERR_NX_BADBLOCKNR.
DBIERR_NX_BADDATABLOCK
This is constant nxllBde.DBIERR_NX_BADDATABLOCK.
DBIERR_NX_BADHEAPBLOCK
This is constant nxllBde.DBIERR_NX_BADHEAPBLOCK.
DBIERR_NX_BADINDEX
This is constant nxllBde.DBIERR_NX_BADINDEX.
DBIERR_NX_BADINXBLOCK
This is constant nxllBde.DBIERR_NX_BADINXBLOCK.
DBIERR_NX_BADREFNR
This is constant nxllBde.DBIERR_NX_BADREFNR.
DBIERR_NX_BADSTREAMBLOCK
This is constant nxllBde.DBIERR_NX_BADSTREAMBLOCK.
DBIERR_NX_BADSTRUCT
This is constant nxllBde.DBIERR_NX_BADSTRUCT.
DBIERR_NX_BLOBTOOBIG
This is constant nxllBde.DBIERR_NX_BLOBTOOBIG.
DBIERR_NX_CLOSEFAILED
This is constant nxllBde.DBIERR_NX_CLOSEFAILED.
DBIERR_NX_COPYFILE
This is constant nxllBde.DBIERR_NX_COPYFILE.
DBIERR_NX_CORRUPTTRANS
This is constant nxllBde.DBIERR_NX_CORRUPTTRANS.
DBIERR_NX_DELETEFILE
This is constant nxllBde.DBIERR_NX_DELETEFILE.
DBIERR_NX_DICT_DUPAUTOINC
This is constant nxllBde.DBIERR_NX_DICT_DUPAUTOINC.
DBIERR_NX_DICT_DUPRECREV
This is constant nxllBde.DBIERR_NX_DICT_DUPRECREV.
DBIERR_NX_DICT_OBJINUSE
This is constant nxllBde.DBIERR_NX_DICT_OBJINUSE.
DBIERR_NX_DICT_READONLY
This is constant nxllBde.DBIERR_NX_DICT_READONLY.
DBIERR_NX_FILEBLOBCLOSE
This is constant nxllBde.DBIERR_NX_FILEBLOBCLOSE.
DBIERR_NX_FILEBLOBOPEN
This is constant nxllBde.DBIERR_NX_FILEBLOBOPEN.
DBIERR_NX_FILEBLOBREAD
This is constant nxllBde.DBIERR_NX_FILEBLOBREAD.
DBIERR_NX_FILTERTIMEOUT
This is constant nxllBde.DBIERR_NX_FILTERTIMEOUT.
DBIERR_NX_GENERALTIMEOUT
This is constant nxllBde.DBIERR_NX_GENERALTIMEOUT.
DBIERR_NX_INCOMPATDICT
This is constant nxllBde.DBIERR_NX_INCOMPATDICT.
DBIERR_NX_INCOMPATHEADER
This is constant nxllBde.DBIERR_NX_INCOMPATHEADER.
DBIERR_NX_INCOMPATSTREAM
This is constant nxllBde.DBIERR_NX_INCOMPATSTREAM.
DBIERR_NX_INDEXNOTEMPTY
This is constant nxllBde.DBIERR_NX_INDEXNOTEMPTY.
DBIERR_NX_INVALIDSEGNR
This is constant nxllBde.DBIERR_NX_INVALIDSEGNR.
DBIERR_NX_KEYFILTERED
This is constant nxllBde.DBIERR_NX_KEYFILTERED.
DBIERR_NX_LICENSE_EXPIRED
This is constant nxllBde.DBIERR_NX_LICENSE_EXPIRED.
DBIERR_NX_LITE
This is constant nxllBde.DBIERR_NX_LITE.
DBIERR_NX_MAXKEYSIZE
This is constant nxllBde.DBIERR_NX_MAXKEYSIZE.
DBIERR_NX_MAXRECORDSIZE
This is constant nxllBde.DBIERR_NX_MAXRECORDSIZE.
DBIERR_NX_NOSESSIONSE
This is constant nxllBde.DBIERR_NX_NOSESSIONSE.
DBIERR_NX_RECOVERFAILED
This is constant nxllBde.DBIERR_NX_RECOVERFAILED.
DBIERR_NX_REGISTERFHAF
This is constant nxllBde.DBIERR_NX_REGISTERFHAF.
DBIERR_NX_RENAMEFILE
This is constant nxllBde.DBIERR_NX_RENAMEFILE.
DBIERR_NX_SAMEFOLDER
This is constant nxllBde.DBIERR_NX_SAMEFOLDER.
DBIERR_NX_SAMETABLE
This is constant nxllBde.DBIERR_NX_SAMETABLE.
DBIERR_NX_SEGMENTDELETED
This is constant nxllBde.DBIERR_NX_SEGMENTDELETED.
DBIERR_NX_SERVERNAMENOTSET
This is constant nxllBde.DBIERR_NX_SERVERNAMENOTSET.
DBIERR_NX_SQLSIGNAL
This is constant nxllBde.DBIERR_NX_SQLSIGNAL.
DBIERR_NX_TABLEVERSION
This is constant nxllBde.DBIERR_NX_TABLEVERSION.
DBIERR_NX_TRIAL
This is constant nxllBde.DBIERR_NX_TRIAL.
DBIERR_NX_TS_FULL
This is constant nxllBde.DBIERR_NX_TS_FULL.
DBIERR_NX_TS_INVALIDBLOCK
This is constant nxllBde.DBIERR_NX_TS_INVALIDBLOCK.
DBIERR_NX_UNKNOWN
This is constant nxllBde.DBIERR_NX_UNKNOWN.
DBIERR_NX_UNKNOWNEXCP
This is constant nxllBde.DBIERR_NX_UNKNOWNEXCP.
DBIERR_NX_UNKNOWNMSG
This is constant nxllBde.DBIERR_NX_UNKNOWNMSG.
DBIERR_NX_UNSUPDICTDESCR
This is constant nxllBde.DBIERR_NX_UNSUPDICTDESCR.
DBIERR_NX_UNSUPHEADER
This is constant nxllBde.DBIERR_NX_UNSUPHEADER.
DBIERR_NX_UNSUPSUBENGINE
This is constant nxllBde.DBIERR_NX_UNSUPSUBENGINE.
DBIERR_OBJNOTFOUND
This is constant nxllBde.DBIERR_OBJNOTFOUND.
DBIERR_OPTRECLOCKFAILED
This is constant nxllBde.DBIERR_OPTRECLOCKFAILED.
DBIERR_OPTRECLOCKRECDEL
This is constant nxllBde.DBIERR_OPTRECLOCKRECDEL.
DBIERR_OSUNKNOWN
DBIERR_OSEINVFNC = ( ERRBASE_OS + ERRCODE_OSEINVFNC ); DBIERR_OSENOENT = ( ERRBASE_OS + ERRCODE_OSENOENT ); DBIERR_OSENOPATH = ( ERRBASE_OS + ERRCODE_OSENOPATH ); DBIERR_OSEMFILE = ( ERRBASE_OS + ERRCODE_OSEMFILE ); DBIERR_OSEACCES = ( ERRBASE_OS + ERRCODE_OSEACCES ); DBIERR_OSEBADF = ( ERRBASE_OS + ERRCODE_OSEBADF ); DBIERR_OSECONTR = ( ERRBASE_OS + ERRCODE_OSECONTR ); DBIERR_OSENOMEM = ( ERRBASE_OS + ERRCODE_OSENOMEM ); DBIERR_OSEINVMEM = ( ERRBASE_OS + ERRCODE_OSEINVMEM ); DBIERR_OSEINVENV = ( ERRBASE_OS + ERRCODE_OSEINVENV ); DBIERR_OSEINVFMT = ( ERRBASE_OS + ERRCODE_OSEINVFMT ); DBIERR_OSEINVACC = ( ERRBASE_OS + ERRCODE_OSEINVACC ); DBIERR_OSEINVDAT = ( ERRBASE_OS + ERRCODE_OSEINVDAT ); DBIERR_OSENODEV = ( ERRBASE_OS + ERRCODE_OSENODEV ); DBIERR_OSECURDIR =... more
DBIERR_OUTOFRANGE
This is constant nxllBde.DBIERR_OUTOFRANGE.
DBIERR_READERR
This is constant nxllBde.DBIERR_READERR.
DBIERR_READONLYDB
DBIERR_NOTSUFFFAMILYRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFAMILYRIGHTS); DBIERR_READONLYDIR = (ERRBASE_SEC + ERRCODE_READONLYDIR);
DBIERR_READONLYFLD
This is constant nxllBde.DBIERR_READONLYFLD.
DBIERR_RECDELETED
DBIERR_RECMOVED = (ERRBASE_NOTFOUND + ERRCODE_RECMOVED);
DBIERR_RECGROUPCONFLICT
This is constant nxllBde.DBIERR_RECGROUPCONFLICT.
DBIERR_RECLOCKFAILED
This is constant nxllBde.DBIERR_RECLOCKFAILED.
DBIERR_RECNOTFOUND
This is constant nxllBde.DBIERR_RECNOTFOUND.
DBIERR_REENTERED
DBIERR_SYSFILEOPEN = (ERRBASE_SYSTEM + ERRCODE_SYSFILEOPEN); DBIERR_SYSFILEIO = (ERRBASE_SYSTEM + ERRCODE_SYSFILEIO); DBIERR_SYSCORRUPT = (ERRBASE_SYSTEM + ERRCODE_SYSCORRUPT); DBIERR_NOCONFIGFILE = (ERRBASE_SYSTEM + ERRCODE_NOCONFIGFILE); DBIERR_CFGCANNOTWRITE = (ERRBASE_SYSTEM + ERRCODE_CFGCANNOTWRITE); DBIERR_CFGMULTIFILE = (ERRBASE_SYSTEM + ERRCODE_CFGMULTIFILE);
DBIERR_REQDERR
This is constant nxllBde.DBIERR_REQDERR.
DBIERR_SERVERCOMMLOST
DBIERR_NETINITERR = (ERRBASE_NETWORK + ERRCODE_NETINITERR); DBIERR_NETUSERLIMIT = (ERRBASE_NETWORK + ERRCODE_NETUSERLIMIT); DBIERR_NETFILEVERSION = (ERRBASE_NETWORK + ERRCODE_NETFILEVERSION); DBIERR_NETFILELOCKED = (ERRBASE_NETWORK + ERRCODE_NETFILELOCKED); DBIERR_DIRNOTPRIVATE = (ERRBASE_NETWORK + ERRCODE_DIRNOTPRIVATE); DBIERR_NETMULTIPLE = (ERRBASE_NETWORK + ERRCODE_NETMULTIPLE); DBIERR_NETUNKNOWN = (ERRBASE_NETWORK + ERRCODE_NETUNKNOWN); DBIERR_SHAREDFILE = (ERRBASE_NETWORK + ERRCODE_SHAREDFILE); DBIERR_SHARENOTLOADED = (ERRBASE_NETWORK + ERRCODE_SHARENOTLOADED); DBIERR_NOTONANETWORK = (ERRBASE_NETWORK + ERRCODE_NOTONANETWORK); DBIERR_SQLCOMMLOST = (ERRBASE_NETWORK + ERRCODE_SQLCOMMLOST);
DBIERR_SERVERNOTFOUND
DBIERR_SQLSERVERNOTFOUND = (ERRBASE_NETWORK + ERRCODE_SQLSERVERNOTFOUND);
DBIERR_SERVERVERSION
DBIERR_INTERFACEVER = (ERRBASE_VERSION + ERRCODE_INTERFACEVER); DBIERR_INDEXOUTOFDATE = (ERRBASE_VERSION + ERRCODE_INDEXOUTOFDATE); DBIERR_OLDVERSION = (ERRBASE_VERSION + ERRCODE_OLDVERSION); DBIERR_VALFILEINVALID = (ERRBASE_VERSION + ERRCODE_VALFILEINVALID); DBIERR_BLOBVERSION = (ERRBASE_VERSION + ERRCODE_BLOBVERSION); DBIERR_ENGQRYMISMATCH = (ERRBASE_VERSION + ERRCODE_ENGQRYMISMATCH);
DBIERR_TABLEEXISTS
DBIERR_UNKNOWNSQL = (ERRBASE_OTHER + ERRCODE_UNKNOWNSQL);
DBIERR_TABLEFULL
DBIERR_NOFILEHANDLES = (ERRBASE_LIMIT + ERRCODE_NOFILEHANDLES); DBIERR_NODISKSPACE = (ERRBASE_LIMIT + ERRCODE_NODISKSPACE); DBIERR_NOTEMPTBLSPACE = (ERRBASE_LIMIT + ERRCODE_NOTEMPTBLSPACE); DBIERR_RECTOOBIG = (ERRBASE_LIMIT + ERRCODE_RECTOOBIG); DBIERR_CURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_CURSORLIMIT);
DBIERR_TABLELEVEL
This is constant nxllBde.DBIERR_TABLELEVEL.
DBIERR_TABLEOPEN
This is constant nxllBde.DBIERR_TABLEOPEN.
DBIERR_TABLEREADONLY
DBIERR_PDXDRIVERNOTACTIVE = (ERRBASE_IC + ERRCODE_PDXDRIVERNOTACTIVE); DBIERR_DRIVERNOTLOADED = (ERRBASE_IC + ERRCODE_DRIVERNOTLOADED);
DBIERR_TBLENCRYPTED
This is constant nxllBde.DBIERR_TBLENCRYPTED.
DBIERR_UNKNOWNDB
DBIERR_INDEXNAMEREQUIRED = (ERRBASE_INVALIDREQ + ERRCODE_INDEXNAMEREQUIRED); DBIERR_INVALIDSESHANDLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDSESHANDLE); DBIERR_INVALIDRESTROP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTROP); DBIERR_UNKNOWNDRIVER = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNDRIVER);
DBIERR_UNKNOWNFILE
DBIERR_UNKNOWNTBLTYPE = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNTBLTYPE);
DBIERR_UPDATEABORT
DBIERR_PDX10TABLE = (ERRBASE_OTHER + ERRCODE_PDX10TABLE);
DBIERR_WRITEERR
This is constant nxllBde.DBIERR_WRITEERR.
ERRBASE_CAPABILITY
Capability not supported
ERRBASE_COMPATIBILITY
Compatibility related
ERRBASE_CONFIG
System configuration error
ERRBASE_DATACORRUPT
Physical Data Corruption
ERRBASE_DRIVER
Driver related
ERRBASE_IC
Invalid context
ERRBASE_INTEGRITY
Integrity Violation
ERRBASE_INVALIDREQ
Invalid Request
ERRBASE_IO
I/O related error
ERRBASE_LIMIT
Resource or Limit error
ERRBASE_LOCKCONFLICT
Locking/Contention related
ERRBASE_NETWORK
Network related
ERRBASE_NEXUS
This is constant nxllBde.ERRBASE_NEXUS.
ERRBASE_NONE
No error
ERRBASE_NOTFOUND
Object of interest Not Found
ERRBASE_OPTPARAM
Optional Parameter related
ERRBASE_OS
Os Error not handled by Idapi
ERRBASE_OTHER
Miscellaneous
ERRBASE_QUERY
Query related
ERRBASE_RC
Internal
ERRBASE_REPOSITORY
Data Repository related
ERRBASE_SEC
Access Violation - Security related
ERRBASE_SYSTEM
System related (Fatal Error)
ERRBASE_VERSION
Version Mismatch Category
ERRBASE_WARNING
This is constant nxllBde.ERRBASE_WARNING.
ERRCAT_CAPABILITY
48 Capability not supported
ERRCAT_COMPATIBILITY
52 Compatibility related
ERRCAT_CONFIG
49 System configuration error
ERRCAT_DATACORRUPT
35 Physical Data Corruption
ERRCAT_DRIVER
62 Driver related
ERRCAT_INTEGRITY
38 Integrity Violation
ERRCAT_INVALIDCONTEXT
42 Invalid context
ERRCAT_INVALIDREQ
39 Invalid Request
ERRCAT_IO
36 I/O related error
ERRCAT_LIMIT
37 Resource or Limit error
ERRCAT_LOCKCONFLICT
40 Locking/Contention related
ERRCAT_NETWORK
44 Network related
ERRCAT_NEXUS
This is constant nxllBde.ERRCAT_NEXUS.
ERRCAT_NONE
0 No error
ERRCAT_NOTFOUND
34 Object of interest Not Found
ERRCAT_OPTPARAM
45 Optional parameter related
ERRCAT_OS
43 Os Error not handled by Idapi
ERRCAT_OTHER
51 Miscellaneous
ERRCAT_QUERY
46 Query related
ERRCAT_RC
63 Internal
ERRCAT_REPOSITORY
53 Data Repository related
ERRCAT_SECURITY
41 Access Violation - Security related
ERRCAT_SYSTEM
33 System related (Fatal Error)
ERRCAT_VERSION
47 Version Mismatch Category
ERRCAT_WARNING
50
ERRCODE_ACTIVETRAN
This is constant nxllBde.ERRCODE_ACTIVETRAN.
ERRCODE_BLOBMODIFIED
Another user modified Blob ERRCODE_UNKNOWNSQL = 3; { Unknown SQL error }
ERRCODE_BOF
Beginning of Virtual table
ERRCODE_CHECKCONSTRAINTFAILED
ERRCODE_DETAILTABLESEXIST = 15; { 0x0f Detail Tables exist ( cannot delete, rename ... ) ERRCODE_DETAILRECEXISTEMPTY = 16; { 0x10 Cannot empty because details exist ERRCODE_MASTERREFERENCEERR = 17; { 0x11 Cannot modify while adding self referencing Referential Integrity ERRCODE_DETAILTBLOPEN = 18; { 0x12 Detail Table is opened ERRCODE_DEPENDENTSMUSTBEEMPTY = 19; { 0x13 Cannot make a master a detail of another table if its details are not empty. ERRCODE_RINTREQINDEX = 20; { 0x14 Ref. integrity fields must be indexed ERRCODE_LINKEDTBLPROTECTED = 21; { 0x15 Master Table is protected ( requires password to open) ERRCODE_FIELDMULTILINKED = 22; { 0x16 Field has more than... more
ERRCODE_CLIENTSLIMIT
0x0e Too many clients
ERRCODE_DEADLOCK
This is constant nxllBde.ERRCODE_DEADLOCK.
ERRCODE_DETAILRECORDSEXIST
Cannot MODIFY or DELETE this Master record ERRCODE_MASTERTBLLEVEL = 7; { Master Table Level is incorrect } ERRCODE_LOOKUPTABLEERR = 8; { Field value out of lookup tbl range } ERRCODE_LOOKUPTBLOPENERR = 9; { Lookup Table Open failed } ERRCODE_DETAILTBLOPENERR = 10; { 0x0a Detail Table Open failed } ERRCODE_MASTERTBLOPENERR = 11; { 0x0b Master Table Open failed }
ERRCODE_DIFFERENTTABLES
0x24 Cannot Set Cursor of one Table to another
ERRCODE_DIRNOACCESS
No access to dir ERRCODE_FILEDELETEFAIL = 4; { File delete failed }
ERRCODE_ENDOFBLOB
End of Blob reached
ERRCODE_EOF
End of Virtual table ERRCODE_RECMOVED = 3; { Fly-away }
ERRCODE_FIELDISBLANK
0x0c Field is blank
ERRCODE_FILECORRUPT
File corrupt - other than header ERRCODE_MEMOCORRUPT = 3; { Memo file corrupted } ERRCODE_BMPCORRUPT = 4; { BitMap is corrupt (Internal error) }
ERRCODE_FILELOCKED
ERRCODE_UNLOCKFAILED = 2; ERRCODE_FILEBUSY = 3; ERRCODE_DIRBUSY = 4;
ERRCODE_FILENOACCESS
No access to file ERRCODE_ACCESSDISABLED = 6; { Access to table disabled (previous error) }
ERRCODE_FLDLIMIT
0x14 Too many Fields in Table Create ERRCODE_TBLLOCKLIMIT = 21; { 0x15 Too many table locks } ERRCODE_OPENBLOBLIMIT = 22; { 0x16 Too many open blobs } ERRCODE_LOCKFILELIMIT = 23; { 0x17 Lock file has grown too big } ERRCODE_OPENQRYLIMIT = 24; { 0x18 Too many open queries } ERRCODE_THREADLIMIT = 25; { 0x19 Too many threads for client } ERRCODE_BLOBLIMIT = 26; { 0x1a Too many blobs } ERRCODE_PDX50NAMELIMIT = 27; { 0x1b Pathname is too long for a Paradox 5.0 or less table } ERRCODE_ROWFETCHLIMIT = 28; { 0x1c Row fetch limit } ERRCODE_LONGNAMENOTALLOWED = 29; { 0x1d... more
ERRCODE_FORIEGNKEYERR
Master record missing
ERRCODE_HEADERCORRUPT
Corrupt Header
ERRCODE_INDEXCORRUPT
Index is corrupt ERRCODE_CORRUPTLOCKFILE = 6; { Corrupt lock file } ERRCODE_FAMFILEINVALID = 7; { Corrupt family file } ERRCODE_VALFILECORRUPT = 8; { Val file is missing or corrupt } ERRCODE_FOREIGNINDEX = 9; { Index is in a foreign format - import first }
ERRCODE_INDEXEXISTS
0x2b Index already exists ERRCODE_INDEXOPEN = 44; { 0x2c Index is open }
ERRCODE_INDEXLIMIT
0x0f Too many indexes (also in Table Create) ERRCODE_SESSIONSLIMIT = 16; { 0x10 Too many sessions } ERRCODE_DBLIMIT = 17; { 0x11 Too many databases } ERRCODE_PASSWORDLIMIT = 18; { 0x12 Too many passwords } ERRCODE_DRIVERLIMIT = 19; { 0x13 Too many active drivers }
ERRCODE_INVALIDALIASNAME
0x53 invalid alias name
ERRCODE_INVALIDBLOBHANDLE
0x2e Invalid Blob handle (in record buffer)
ERRCODE_INVALIDBLOBLEN
0x2d Invalid Blob Length
ERRCODE_INVALIDBLOBOFFSET
0x0e Invalid Offset into the Blob
ERRCODE_INVALIDBOOKMARK
0x25 Bookmarks does not match table, etc.
ERRCODE_INVALIDDESC
0x14 Generic: invalid descriptor
ERRCODE_INVALIDDESCNUM
0x0f Invalid descriptor number
ERRCODE_INVALIDDIR
0x22 Invalid directory
ERRCODE_INVALIDFIELDNAME
0x36 Invalid field name
ERRCODE_INVALIDFILEEXTN
0x3a Invalid file extention
ERRCODE_INVALIDFILTER
0x43 Invalid filter
ERRCODE_INVALIDFLDDESC
0x11 Invalid field descriptor
ERRCODE_INVALIDFLDTYPE
0x10 Invalid field type
ERRCODE_INVALIDFLDXFORM
0x12 Invalid field transform
ERRCODE_INVALIDHNDL
Invalid handle to the function ERRCODE_UNKNOWNTBLTYPE = 7; { Table type given not known }
ERRCODE_INVALIDIDXDESC
0x27 Invalid index descriptor
ERRCODE_INVALIDINDEXNAME
0x26 Index/Tag Name is invalid
ERRCODE_INVALIDINDEXSTRUCT
0x15 Invalid array of indexes descriptors ERRCODE_INVALIDVCHKSTRUCT = 22; { 0x16 Invalid array of val. check descriptors } ERRCODE_INVALIDRINTSTRUCT = 23; { 0x17 Invalid array of ref. integrity descriptors } ERRCODE_INVALIDRESTRTBLORDER = 24; { 0x18 Invalid ordering of tables during restructure }
ERRCODE_INVALIDLANGDRV
0x3b Invalid language driver ERRCODE_ALIASNOTOPEN = 60; { 0x3c Requested alias in not open } ERRCODE_INCOMPATRECSTRUCTS = 61; { 0x3d Incompatible record structures } ERRCODE_RESERVEDDOSNAME = 62; { 0x3e Reserved dos name } ERRCODE_DESTMUSTBEINDEXED = 63; { 0x3f Destination must be indexed } ERRCODE_INVALIDINDEXTYPE = 64; { 0x40 Invalid index type } ERRCODE_LANGDRVMISMATCH = 65; { 0x41 Language driver of table and index do not match }
ERRCODE_INVALIDNAME
0x54 invalid alias name
ERRCODE_INVALIDPARAM
Generic invalid parameter ERRCODE_INVALIDFILENAME = 3; { Invalid file name } ERRCODE_NOSUCHFILE = 4; { No such file } ERRCODE_INVALIDOPTION = 5; { Invalid option for a parameter }
ERRCODE_INVALIDPASSWORD
0x1f Invalid password given ERRCODE_NOCALLBACK = 32; { 0x20 No callback function } ERRCODE_INVALIDCALLBACKBUFLEN = 33; { 0x21 Invalid callback buffer length }
ERRCODE_INVALIDRECSTRUCT
0x13 Invalid record structure
ERRCODE_INVALIDTABLENAME
0x37 Invalid table name ERRCODE_INVALIDLINKEXPR = 56; { 0x38 Invalid linked cursor expression } ERRCODE_NAMERESERVED = 57; { 0x39 Name is reserved }
ERRCODE_INVALIDUSRPASS
0x34 Bad user name or password ERRCODE_MULTILEVELCASCADE = 53; { 0x35 Multi level Cascade not supported }
ERRCODE_INVALIDXLATION
0x23 Translate Error - Translate DID NOT happen
ERRCODE_KEYORRECDELETED
Record Deleted/Key Modified
ERRCODE_KEYVIOL
Key violation
ERRCODE_LOCKED
ERRCAT_LOCKCONFLICT
ERRCODE_LOCKTIMEOUT
ERRCODE_DIRLOCKED = 6; ERRCODE_ALREADYLOCKED = 7; ERRCODE_NOTLOCKED = 8;
ERRCODE_MAXVALERR
Max val check failed
ERRCODE_MINVALERR
Min val check failed
ERRCODE_NA
Operation not applicable
ERRCODE_NAMENOTUNIQUE
0x19 Name not unique in this context ERRCODE_INDEXNAMEREQUIRED = 26; { 0x1a Index name required } ERRCODE_INVALIDSESHANDLE = 27; { 0x1b Invalid ses handle } ERRCODE_INVALIDRESTROP = 28; { 0x1c Invalid restructure operation } ERRCODE_UNKNOWNDRIVER = 29; { 0x1d Driver not known to system }
ERRCODE_NEEDEXCLACCESS
0x0d
ERRCODE_NOACTIVETRAN
This is constant nxllBde.ERRCODE_NOACTIVETRAN.
ERRCODE_NOASSOCINDEX
0x0c No index associated with the cursor ERRCODE_HASOPENCURSORS = 13; { 0x0d Has open cursors } ERRCODE_NOTABLESUPPORT = 14; { 0x0e Op cannot be done on this table } ERRCODE_INDEXREADONLY = 15; { 0x0f Index is read only } ERRCODE_NOUNIQUERECS = 16; { 0x10 Records are not unique } ERRCODE_NOTCURSESSION = 17; { 0x11 Not the current/active session } ERRCODE_INVALIDKEYWORD = 18; { 0x12 Invalid use of keyword. } ERRCODE_CONNECTINUSE = 19; { 0x13 Connection in use } ERRCODE_CONNECTNOTSHARED = 20; { 0x14 Passthru SQL connection not share }
ERRCODE_NOCURRREC
No current record
ERRCODE_NOMEMORY
Not enough Memory for this op ERRCODE_NOFILEHANDLES = 2; { Not enough File handles } ERRCODE_NODISKSPACE = 3; { Not enough Disk space } ERRCODE_NOTEMPTBLSPACE = 4; { Temporary Table resource limit } ERRCODE_RECTOOBIG = 5; { Too big a record size for table } ERRCODE_CURSORLIMIT = 6; { Too many open cursors }
ERRCODE_NONE
ERRCAT_NONE (0)
ERRCODE_NOSERVERSW
0x6a Server software not running the workstation/server
ERRCODE_NOSUCHFILTER
0x42 Filter handle is invalid
ERRCODE_NOSUCHINDEX
0x0d Index does not exist
ERRCODE_NOSUCHTABLE
0x28 No such table ERRCODE_USECOUNT = 41; { 0x29 Table has too many users } ERRCODE_INVALIDKEY = 42; { 0x2a Key does not pass filter condition }
ERRCODE_NOTABLOB
Field is not a blob ERRCODE_BLOBOPENED = 2; { Blob already opened } ERRCODE_BLOBNOTOPENED = 3; { Blob not opened }
ERRCODE_NOTINDEXED
Table is not indexed ERRCODE_NOTINITIALIZED = 6; { Engine not initialized } ERRCODE_MULTIPLEINIT = 7; { Attempt to re-initialize engine }
ERRCODE_NOTSAMESESSION
Attempt to mix objs from diff ses ERRCODE_PDXDRIVERNOTACTIVE = 9; { Paradox driver not active } ERRCODE_DRIVERNOTLOADED = 10; { 0x0a Driver not loaded }
ERRCODE_NOTSUFFTABLERIGHTS
Not sufficient table rights for operation ERRCODE_NOTSUFFFAMILYRIGHTS = 3; { Not sufficient family rights for operation } ERRCODE_READONLYDIR = 4; { Is a read-only directory }
ERRCODE_NOTSUPPORTED
Capability not supported ERRCODE_NIY = 2; { Not Implemented Yet } ERRCODE_TABLESQL = 3; { Cannot access SQL replica } ERRCODE_SEARCHCOLREQD = 4; { Searchable (Non-blob column) required } ERRCODE_NOMULTCONNECT = 5; { Multiple connections not supported } ERRCODE_NODBASEEXPR = 6; { Full dBASE Expressions not supported }
ERRCODE_NX_BADBLOCKNR
This is constant nxllBde.ERRCODE_NX_BADBLOCKNR.
ERRCODE_NX_BADDATABLOCK
This is constant nxllBde.ERRCODE_NX_BADDATABLOCK.
ERRCODE_NX_BADHEAPBLOCK
This is constant nxllBde.ERRCODE_NX_BADHEAPBLOCK.
ERRCODE_NX_BADINDEX
This is constant nxllBde.ERRCODE_NX_BADINDEX.
ERRCODE_NX_BADINXBLOCK
This is constant nxllBde.ERRCODE_NX_BADINXBLOCK.
ERRCODE_NX_BADREFNR
This is constant nxllBde.ERRCODE_NX_BADREFNR.
ERRCODE_NX_BADSTREAMBLOCK
This is constant nxllBde.ERRCODE_NX_BADSTREAMBLOCK.
ERRCODE_NX_BADSTRUCT
DBIERR_REPOSITORYCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYCORRUPT); DBIERR_INFOBLOBCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_INFOBLOBCORRUPT); DBIERR_SCHEMACORRUPT = (ERRBASE_REPOSITORY + ERRCODE_SCHEMACORRUPT); DBIERR_ATTRTYPEEXISTS = (ERRBASE_REPOSITORY + ERRCODE_ATTRTYPEEXISTS); DBIERR_INVALIDOBJTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDOBJTYPE); DBIERR_INVALIDRELATIONTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRELATIONTYPE); DBIERR_VIEWEXISTS = (ERRBASE_REPOSITORY + ERRCODE_VIEWEXISTS); DBIERR_NOSUCHVIEW = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHVIEW); DBIERR_INVALIDRECCONSTRAINT = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRECCONSTRAINT); DBIERR_LDBCONNECTION = (ERRBASE_REPOSITORY + ERRCODE_LDBCONNECTION); DBIERR_REPOSITORYEXISTS = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYEXISTS); DBIERR_NOSUCHREPOSITORY = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHREPOSITORY); DBIERR_REPOSITORYDBMISSING = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYDBMISSING); DBIERR_REPOSITORYOUTOFDATE = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYOUTOFDATE); DBIERR_REPOSITORYVERSION = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYVERSION); DBIERR_REPOSITORYNAME = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYNAME); DBIERR_DEPENDENTOBJECTS = (ERRBASE_REPOSITORY... more
ERRCODE_NX_BLOBTOOBIG
This is constant nxllBde.ERRCODE_NX_BLOBTOOBIG.
ERRCODE_NX_CLOSEFAILED
This is constant nxllBde.ERRCODE_NX_CLOSEFAILED.
ERRCODE_NX_COPYFILE
This is constant nxllBde.ERRCODE_NX_COPYFILE.
ERRCODE_NX_CORRUPTTRANS
This is constant nxllBde.ERRCODE_NX_CORRUPTTRANS.
ERRCODE_NX_DELETEFILE
This is constant nxllBde.ERRCODE_NX_DELETEFILE.
ERRCODE_NX_DICT_DUPAUTOINC
This is constant nxllBde.ERRCODE_NX_DICT_DUPAUTOINC.
ERRCODE_NX_DICT_DUPRECREV
This is constant nxllBde.ERRCODE_NX_DICT_DUPRECREV.
ERRCODE_NX_DICT_OBJINUSE
This is constant nxllBde.ERRCODE_NX_DICT_OBJINUSE.
ERRCODE_NX_DICT_READONLY
This is constant nxllBde.ERRCODE_NX_DICT_READONLY.
ERRCODE_NX_FILEBLOBCLOSE
This is constant nxllBde.ERRCODE_NX_FILEBLOBCLOSE.
ERRCODE_NX_FILEBLOBOPEN
This is constant nxllBde.ERRCODE_NX_FILEBLOBOPEN.
ERRCODE_NX_FILEBLOBREAD
This is constant nxllBde.ERRCODE_NX_FILEBLOBREAD.
ERRCODE_NX_FILTERTIMEOUT
This is constant nxllBde.ERRCODE_NX_FILTERTIMEOUT.
ERRCODE_NX_GENERALTIMEOUT
This is constant nxllBde.ERRCODE_NX_GENERALTIMEOUT.
ERRCODE_NX_INCOMPATDICT
This is constant nxllBde.ERRCODE_NX_INCOMPATDICT.
ERRCODE_NX_INCOMPATHEADER
This is constant nxllBde.ERRCODE_NX_INCOMPATHEADER.
ERRCODE_NX_INCOMPATSTREAM
This is constant nxllBde.ERRCODE_NX_INCOMPATSTREAM.
ERRCODE_NX_INDEXNOTEMPTY
This is constant nxllBde.ERRCODE_NX_INDEXNOTEMPTY.
ERRCODE_NX_INVALIDSEGNR
This is constant nxllBde.ERRCODE_NX_INVALIDSEGNR.
ERRCODE_NX_KEYFILTERED_NONE
This is constant nxllBde.ERRCODE_NX_KEYFILTERED_NONE.
ERRCODE_NX_LICENSE_EXPIRED
This is constant nxllBde.ERRCODE_NX_LICENSE_EXPIRED.
ERRCODE_NX_LITE
This is constant nxllBde.ERRCODE_NX_LITE.
ERRCODE_NX_MAXKEYSIZE
This is constant nxllBde.ERRCODE_NX_MAXKEYSIZE.
ERRCODE_NX_MAXRECORDSIZE
This is constant nxllBde.ERRCODE_NX_MAXRECORDSIZE.
ERRCODE_NX_NOSESSIONSE
This is constant nxllBde.ERRCODE_NX_NOSESSIONSE.
ERRCODE_NX_RECOVERFAILED
This is constant nxllBde.ERRCODE_NX_RECOVERFAILED.
ERRCODE_NX_REGISTERFHAF
This is constant nxllBde.ERRCODE_NX_REGISTERFHAF.
ERRCODE_NX_RENAMEFILE
This is constant nxllBde.ERRCODE_NX_RENAMEFILE.
ERRCODE_NX_SAMEFOLDER
This is constant nxllBde.ERRCODE_NX_SAMEFOLDER.
ERRCODE_NX_SAMETABLE
This is constant nxllBde.ERRCODE_NX_SAMETABLE.
ERRCODE_NX_SEGMENTDELETED
This is constant nxllBde.ERRCODE_NX_SEGMENTDELETED.
ERRCODE_NX_SERVERNAMENOTSET
This is constant nxllBde.ERRCODE_NX_SERVERNAMENOTSET.
ERRCODE_NX_SQLSIGNAL
This is constant nxllBde.ERRCODE_NX_SQLSIGNAL.
ERRCODE_NX_TABLEVERSION
This is constant nxllBde.ERRCODE_NX_TABLEVERSION.
ERRCODE_NX_TRIAL
This is constant nxllBde.ERRCODE_NX_TRIAL.
ERRCODE_NX_TS_FULL
This is constant nxllBde.ERRCODE_NX_TS_FULL.
ERRCODE_NX_TS_INVALIDBLOCK
This is constant nxllBde.ERRCODE_NX_TS_INVALIDBLOCK.
ERRCODE_NX_UNKNOWN
This is constant nxllBde.ERRCODE_NX_UNKNOWN.
ERRCODE_NX_UNKNOWNEXCP
This is constant nxllBde.ERRCODE_NX_UNKNOWNEXCP.
ERRCODE_NX_UNKNOWNMSG
This is constant nxllBde.ERRCODE_NX_UNKNOWNMSG.
ERRCODE_NX_UNSUPDICTDESCR
This is constant nxllBde.ERRCODE_NX_UNSUPDICTDESCR.
ERRCODE_NX_UNSUPHEADER
This is constant nxllBde.ERRCODE_NX_UNSUPHEADER.
ERRCODE_NX_UNSUPSUBENGINE
This is constant nxllBde.ERRCODE_NX_UNSUPSUBENGINE.
ERRCODE_OBJNOTFOUND
Generic Not found ERRCODE_FMLMEMBERNOTFOUND = 9; { Family member not found } ERRCODE_BLOBFILEMISSING = 10; { 0x0a Blob file for table is missing } ERRCODE_LDNOTFOUND = 11; { 0x0b Language driver not found }
ERRCODE_OPTRECLOCKFAILED
This is constant nxllBde.ERRCODE_OPTRECLOCKFAILED.
ERRCODE_OPTRECLOCKRECDEL
This is constant nxllBde.ERRCODE_OPTRECLOCKRECDEL.
ERRCODE_OSUNKNOWN
0x27 Unkown | illegal error from rtl
ERRCODE_OUTOFRANGE
Number out of range (e.g field no)
ERRCODE_READERR
Read failure (not expected)
ERRCODE_READONLYDB
Database is read-only
ERRCODE_READONLYFLD
Trying to modify read-only field
ERRCODE_RECGROUPCONFLICT
0x0e
ERRCODE_RECLOCKFAILED
This is constant nxllBde.ERRCODE_RECLOCKFAILED.
ERRCODE_RECNOTFOUND
Record was not found
ERRCODE_REENTERED
System has been illegally re-entered ERRCODE_CANTFINDIDAPI = 8; { Cannot locate IDAPIxx.DLL } ERRCODE_CANTLOADIDAPI = 9; { Cannot load IDAPIxx.DLL } ERRCODE_CANTLOADLIBRARY = 10; { Cannot load a service DLL } ERRCODE_TEMPFILEERR = 11; { Cannot create or open temporary file } ERRCODE_MULTIPLEIDAPI = 12; { Trying to load multiple IDAPIxx.DLL }
ERRCODE_REQDERR
Field value required
ERRCODE_SERVERCOMMLOST
0x0c Lost Communication with IDAPI server ERRCODE_SQLSERVERNOTFOUND = 13; { 0x0d SQL Server not found }
ERRCODE_SERVERNOTFOUND
0x0e SQL Server not found
ERRCODE_SERVERVERSION
Server is incompatible version
ERRCODE_TABLEEXISTS
Table already exsits ERRCODE_PDX10TABLE = 5; { Paradox 1.0 tables not supported }
ERRCODE_TABLEFULL
Table is full ERRCODE_WSSESLIMIT = 8; { Too many sessions from this WS } ERRCODE_SERNUMLIMIT = 9; { Serial number limit (paradox) } ERRCODE_INTERNALLIMIT = 10; { 0x0a Some internal limit (see context) } ERRCODE_OPENTBLLIMIT = 11; { 0x0b Too many open tables } ERRCODE_TBLCURSORLIMIT = 12; { 0x0c Too many cursors per table } ERRCODE_RECLOCKLIMIT = 13; { 0x0d Too many record locks on table }
ERRCODE_TABLELEVEL
Higher table level required
ERRCODE_TABLEOPEN
0x2f Table is open ERRCODE_NEEDRESTRUCTURE = 48; { 0x30 Need to do (hard) restructure } ERRCODE_INVALIDMODE = 49; { 0x31 Invalid mode } ERRCODE_CANNOTCLOSE = 50; { 0x32 Cannot close index } ERRCODE_ACTIVEINDEX = 51; { 0x33 Index is being used to order tbl }
ERRCODE_TABLEREADONLY
0x0b Table is read only
ERRCODE_TBLENCRYPTED
Table is encrypted (dBASE only) ERRCODE_NOTSUFFSQLRIGHTS = 8; { Not sufficient sql rights for operation }
ERRCODE_UNKNOWNDB
0x1e Unknown db
ERRCODE_UNKNOWNFILE
Dont know how to open file ERRCODE_PRIMARYKEYREDEFINE = 9; { Cannot redefine primary key } ERRCODE_INVALIDRINTDESCNUM = 10; { 0x0a Cannot change this RINTDesc } ERRCODE_KEYFLDTYPEMISMATCH = 11; { 0x0b Foreign & Primary Key Mismatch } ERRCODE_INVALIDMODIFYREQUEST = 12; { 0x0c Invalid modify request }
ERRCODE_UPDATEABORT
Update operation aborted
ERRCODE_WRITEERR
Write failure (not expected)
fldADT
Abstract datatype (structure)
fldARRAY
Array field type
fldBCD
BCD
fldBLOB
Blob
fldBOOL
Boolean (16 bit)
fldBYTES
Fixed number of bytes
fldCURSOR
For Oracle Cursor type
fldDATE
Date (32 bit)
fldDATETIME
Datetime structure for DBExpress
fldDATETIMEOFFSET
DatetimeOffset structure for DBExpress
fldFLOAT
64 bit floating point
fldFLOATIEEE
80-bit IEEE float
fldFMTBCD
BCD Variant type: required by Midas, same as BCD for DBExpress
fldINT16
16 bit signed number
fldINT32
32 bit signed number
fldINT64
64 bit signed number
fldINT8
8 bit signed number as defined in alctypes.h
fldLOCKINFO
Look for LOCKINFO typedef
fldREF
Reference to ADT
fldSINGLE
32 bit floating point
fldstACCOLEOBJ
Access OLE object
fldstAUTOINC
fldINT32 subtype
fldstBFILE
BFILE
fldstBINARY
Binary data
fldstDBSOLEOBJ
dBASE OLE object
fldstFIXED
CHAR type
fldstFMTMEMO
Formatted Text
fldstGRAPHIC
Graphics object
fldstGUID
GUID
fldstHBINARY
BLOB
fldstHMEMO
CLOB
fldstMEMO
Text Memo
fldstMONEY
Money
fldstOLEOBJ
OLE object (Paradox)
fldstORAINTERVAL
ORACLE INTERVAL
fldstORATIMESTAMP
ORACLE TIMESTAMP
fldstPASSWORD
Password
fldstTYPEDBINARY
Typed Binary data
fldstWIDEMEMO
WideString Memo
fldTABLE
Nested table (reference)
fldTIME
Time (32 bit)
fldTIMESTAMP
Time-stamp (64 bit)
fldUINT16
Unsigned 16 bit integer
fldUINT32
Unsigned 32 bit integer
fldUINT64
Unsigned 64 bit integer
fldUINT8
Unsigned 8 bit integer (Byte) as defined in alctypes.h
fldUNICODE
Unicode
fldUNKNOWN
Field Types (Logical)
fldVARBYTES
Length prefixed var bytes
fldWIDESTRING
UCS2 null terminated string
fldZSTRING
Null terminated string
MAXLOGFLDTYPES
Number of logical fieldtypes
Namespace

nxllBde Namespace

Links
Constants, nxllBde Namespace


nxllBde.DBICODE_BLOBERR Constant

nxllBde.DBICODE_BLOBERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBICODE_BLOBERR = 120;
File

nxllBde

Description

0x78 DBICODE_RESTARTQRY = 121; { 0x79 } DBICODE_UNKNOWNANSTYPE = 122; { 0x7a }

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_ACTIVETRAN Constant

nxllBde.DBIERR_ACTIVETRAN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_ACTIVETRAN = (ERRBASE_LOCKCONFLICT + ERRCODE_ACTIVETRAN);
File

nxllBde

Description

This is constant nxllBde.DBIERR_ACTIVETRAN.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_BLOBERR Constant

nxllBde.DBIERR_BLOBERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_BLOBERR = (ERRBASE_QUERY+ DBICODE_BLOBERR);
File

nxllBde

Description

DBIERR_AMBJOASY = (ERRBASE_QUERY+DBICODE_AMBJOASY); DBIERR_AMBJOSYM = (ERRBASE_QUERY+DBICODE_AMBJOSYM); DBIERR_AMBOUTEX = (ERRBASE_QUERY+DBICODE_AMBOUTEX); DBIERR_AMBOUTPR = (ERRBASE_QUERY+DBICODE_AMBOUTPR); DBIERR_AMBSYMAS = (ERRBASE_QUERY+DBICODE_AMBSYMAS); DBIERR_ASETOPER = (ERRBASE_QUERY+DBICODE_ASETOPER); DBIERR_AVENUMDA = (ERRBASE_QUERY+DBICODE_AVENUMDA); DBIERR_BADEXPR1 = (ERRBASE_QUERY+DBICODE_BADEXPR1); DBIERR_BADFLDOR = (ERRBASE_QUERY+DBICODE_BADFLDOR); DBIERR_BADVNAME = (ERRBASE_QUERY+DBICODE_BADVNAME); DBIERR_BITMAPER = (ERRBASE_QUERY+DBICODE_BITMAPER); DBIERR_CALCBADR = (ERRBASE_QUERY+DBICODE_CALCBADR); DBIERR_CALCTYPE = (ERRBASE_QUERY+DBICODE_CALCTYPE); DBIERR_CHGTO1TI = (ERRBASE_QUERY+DBICODE_CHGTO1TI); DBIERR_CHGTOCHG = (ERRBASE_QUERY+DBICODE_CHGTOCHG); DBIERR_CHGTOEXP = (ERRBASE_QUERY+DBICODE_CHGTOEXP); DBIERR_CHGTOINS = (ERRBASE_QUERY+DBICODE_CHGTOINS); DBIERR_CHGTONEW = (ERRBASE_QUERY+DBICODE_CHGTONEW); DBIERR_CHGTOVAL = (ERRBASE_QUERY+DBICODE_CHGTOVAL); DBIERR_CHKMRKFI = (ERRBASE_QUERY+DBICODE_CHKMRKFI); DBIERR_CHNAMBIG = (ERRBASE_QUERY+DBICODE_CHNAMBIG); DBIERR_CHUNKERR = (ERRBASE_QUERY+DBICODE_CHUNKERR); DBIERR_COLUM255 = (ERRBASE_QUERY+DBICODE_COLUM255); DBIERR_CONAFTAS = (ERRBASE_QUERY+DBICODE_CONAFTAS); DBIERR_DEL1TIME = (ERRBASE_QUERY+DBICODE_DEL1TIME); DBIERR_DELAMBIG = (ERRBASE_QUERY+DBICODE_DELAMBIG); DBIERR_DELFRDEL = (ERRBASE_QUERY+DBICODE_DELFRDEL); DBIERR_EGFLDTYP = (ERRBASE_QUERY+DBICODE_EGFLDTYP); DBIERR_EXAMINOR = (ERRBASE_QUERY+DBICODE_EXAMINOR); DBIERR_EXPRTYPS = (ERRBASE_QUERY+DBICODE_EXPRTYPS); DBIERR_EXTRACOM = (ERRBASE_QUERY+DBICODE_EXTRACOM); DBIERR_EXTRAORO = (ERRBASE_QUERY+DBICODE_EXTRAORO); DBIERR_EXTRAQRO = (ERRBASE_QUERY+DBICODE_EXTRAQRO); DBIERR_FIND1ATT = (ERRBASE_QUERY+DBICODE_FIND1ATT); DBIERR_FINDANST = (ERRBASE_QUERY+DBICODE_FINDANST); DBIERR_GRPNOSET = (ERRBASE_QUERY+DBICODE_GRPNOSET); DBIERR_GRPSTROW = (ERRBASE_QUERY+DBICODE_GRPSTROW); DBIERR_IDFINLCO = (ERRBASE_QUERY+DBICODE_IDFINLCO); DBIERR_IDFPERLI = (ERRBASE_QUERY+DBICODE_IDFPERLI); DBIERR_INANEXPR = (ERRBASE_QUERY+DBICODE_INANEXPR); DBIERR_INS1TIME = (ERRBASE_QUERY+DBICODE_INS1TIME); DBIERR_INSAMBIG = (ERRBASE_QUERY+DBICODE_INSAMBIG); DBIERR_INSDELCH = (ERRBASE_QUERY+DBICODE_INSDELCH); DBIERR_INSEXPRR = (ERRBASE_QUERY+DBICODE_INSEXPRR); DBIERR_INSTOINS = (ERRBASE_QUERY+DBICODE_INSTOINS); DBIERR_ISARRAY = (ERRBASE_QUERY+DBICODE_ISARRAY); DBIERR_LABELERR = (ERRBASE_QUERY+DBICODE_LABELERR); DBIERR_LINKCALC = (ERRBASE_QUERY+DBICODE_LINKCALC); DBIERR_LNGVNAME = (ERRBASE_QUERY+DBICODE_LNGVNAME); DBIERR_LONGQURY = (ERRBASE_QUERY+DBICODE_LONGQURY); DBIERR_MEMVPROC = (ERRBASE_QUERY+DBICODE_MEMVPROC); DBIERR_MISNGCOM = (ERRBASE_QUERY+DBICODE_MISNGCOM); DBIERR_MISNGRPA = (ERRBASE_QUERY+DBICODE_MISNGRPA); DBIERR_MISSRTQU = (ERRBASE_QUERY+DBICODE_MISSRTQU); DBIERR_NAMTWICE = (ERRBASE_QUERY+DBICODE_NAMTWICE); DBIERR_NOCHKMAR = (ERRBASE_QUERY+DBICODE_NOCHKMAR); DBIERR_NODEFOCC = (ERRBASE_QUERY+DBICODE_NODEFOCC); DBIERR_NOGROUPS = (ERRBASE_QUERY+DBICODE_NOGROUPS); DBIERR_NONSENSE = (ERRBASE_QUERY+DBICODE_NONSENSE); DBIERR_NOPATTER = (ERRBASE_QUERY+DBICODE_NOPATTER); DBIERR_NOSUCHDA = (ERRBASE_QUERY+DBICODE_NOSUCHDA); DBIERR_NOVALUE = (ERRBASE_QUERY+DBICODE_NOVALUE); DBIERR_ONLYCONS = (ERRBASE_QUERY+DBICODE_ONLYCONS); DBIERR_ONLYSETR = (ERRBASE_QUERY+DBICODE_ONLYSETR); DBIERR_OUTSENS1 = (ERRBASE_QUERY+DBICODE_OUTSENS1); DBIERR_OUTTWIC1 = (ERRBASE_QUERY+DBICODE_OUTTWIC1); DBIERR_PAROWCNT = (ERRBASE_QUERY+DBICODE_PAROWCNT); DBIERR_PERSEPAR = (ERRBASE_QUERY+DBICODE_PERSEPAR); DBIERR_PROCPLSW = (ERRBASE_QUERY+DBICODE_PROCPLSW); DBIERR_PWINSRTS = (ERRBASE_QUERY+DBICODE_PWINSRTS); DBIERR_PWMODRTS = (ERRBASE_QUERY+DBICODE_PWMODRTS); DBIERR_QBEFLDFOUND = (ERRBASE_QUERY+DBICODE_QBEFLDFOUND); DBIERR_QBENOFENCE = (ERRBASE_QUERY+DBICODE_QBENOFENCE); DBIERR_QBENOFENCET = (ERRBASE_QUERY+DBICODE_QBENOFENCET); DBIERR_QBENOHEADERT = (ERRBASE_QUERY+DBICODE_QBENOHEADERT); DBIERR_QBENOTAB = (ERRBASE_QUERY+DBICODE_QBENOTAB); DBIERR_QBENUMCOLS = (ERRBASE_QUERY+DBICODE_QBENUMCOLS); DBIERR_QBEOPENTAB = (ERRBASE_QUERY+DBICODE_QBEOPENTAB); DBIERR_QBETWICE = (ERRBASE_QUERY+DBICODE_QBETWICE); DBIERR_QRYNOANSWER = (ERRBASE_QUERY+DBICODE_QRYNOANSWER); DBIERR_QRYNOTPREP = (ERRBASE_QUERY+DBICODE_QRYNOTPREP); DBIERR_QUAINDEL = (ERRBASE_QUERY+DBICODE_QUAINDEL); DBIERR_QUAININS = (ERRBASE_QUERY+DBICODE_QUAININS); DBIERR_RAGININS = (ERRBASE_QUERY+DBICODE_RAGININS); DBIERR_RAGINSET = (ERRBASE_QUERY+DBICODE_RAGINSET); DBIERR_ROWUSERR = (ERRBASE_QUERY+DBICODE_ROWUSERR); DBIERR_SETEXPEC = (ERRBASE_QUERY+DBICODE_SETEXPEC); DBIERR_SETVAMB1 = (ERRBASE_QUERY+DBICODE_SETVAMB1); DBIERR_SETVBAD1 = (ERRBASE_QUERY+DBICODE_SETVBAD1); DBIERR_SETVDEF1 = (ERRBASE_QUERY+DBICODE_SETVDEF1); DBIERR_SUMNUMBE = (ERRBASE_QUERY+DBICODE_SUMNUMBE); DBIERR_TBLISWP3 = (ERRBASE_QUERY+DBICODE_TBLISWP3); DBIERR_TOKENNOT = (ERRBASE_QUERY+DBICODE_TOKENNOT); DBIERR_TWOOUTR1 = (ERRBASE_QUERY+DBICODE_TWOOUTR1); DBIERR_TYPEMISM = (ERRBASE_QUERY+DBICODE_TYPEMISM); DBIERR_UNRELQ1 = (ERRBASE_QUERY+DBICODE_UNRELQ1); DBIERR_UNUSEDST = (ERRBASE_QUERY+DBICODE_UNUSEDST); DBIERR_USEINSDE = (ERRBASE_QUERY+DBICODE_USEINSDE); DBIERR_USEOFCHG = (ERRBASE_QUERY+DBICODE_USEOFCHG); DBIERR_VARMUSTF = (ERRBASE_QUERY+DBICODE_VARMUSTF); DBIERR_REGISTER = (ERRBASE_QUERY+DBICODE_REGISTER); DBIERR_LONGEXPR = (ERRBASE_QUERY+DBICODE_LONGEXPR); DBIERR_REFRESH = (ERRBASE_QUERY+DBICODE_REFRESH); DBIERR_CANCEXCEPT = (ERRBASE_QUERY+DBICODE_CANCEXCEPT); DBIERR_DBEXCEPT = (ERRBASE_QUERY+DBICODE_DBEXCEPT); DBIERR_MEMEXCEPT = (ERRBASE_QUERY+DBICODE_MEMEXCEPT); DBIERR_FATALEXCEPT = (ERRBASE_QUERY+DBICODE_FATALEXCEPT); DBIERR_QRYNIY = (ERRBASE_QUERY+ DBICODE_QRYNIY); DBIERR_BADFORMAT = (ERRBASE_QUERY+ DBICODE_BADFORMAT); DBIERR_QRYEMPTY = (ERRBASE_QUERY+ DBICODE_QRYEMPTY); DBIERR_NOQRYTOPREP = (ERRBASE_QUERY+ DBICODE_NOQRYTOPREP); DBIERR_BUFFTOOSMALL = (ERRBASE_QUERY+ DBICODE_BUFFTOOSMALL); DBIERR_QRYNOTPARSE = (ERRBASE_QUERY+ DBICODE_QRYNOTPARSE); DBIERR_NOTHANDLE = (ERRBASE_QUERY+ DBICODE_NOTHANDLE); DBIERR_QRYSYNTERR = (ERRBASE_QUERY+ DBICODE_QRYSYNTERR); DBIERR_QXFLDCOUNT = (ERRBASE_QUERY+ DBICODE_QXFLDCOUNT); DBIERR_QXFLDSYMNOTFOUND = (ERRBASE_QUERY+ DBICODE_QXFLDSYMNOTFOUND); DBIERR_QXTBLSYMNOTFOUND = (ERRBASE_QUERY+ DBICODE_QXTBLSYMNOTFOUND); DBIERR_BLOBTERM = (ERRBASE_QUERY+ DBICODE_BLOBTERM);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_BLOBMODIFIED Constant

nxllBde.DBIERR_BLOBMODIFIED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_BLOBMODIFIED = (ERRBASE_OTHER + ERRCODE_BLOBMODIFIED);
File

nxllBde

Description

DBIERR_FILEEXISTS = (ERRBASE_OTHER + ERRCODE_FILEEXISTS);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_BOF Constant

nxllBde.DBIERR_BOF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_BOF = (ERRBASE_NOTFOUND + ERRCODE_BOF);
File

nxllBde

Description

This is constant nxllBde.DBIERR_BOF.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_CHECKCONSTRAINTFAILED Constant

nxllBde.DBIERR_CHECKCONSTRAINTFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_CHECKCONSTRAINTFAILED = (ERRBASE_INTEGRITY + ERRCODE_CHECKCONSTRAINTFAILED);
File

nxllBde

Description

DBIERR_MASTEREXISTS = (ERRBASE_INTEGRITY + ERRCODE_MASTEREXISTS); DBIERR_MASTERTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPEN); DBIERR_DETAILTABLESEXIST = (ERRBASE_INTEGRITY + ERRCODE_DETAILTABLESEXIST); DBIERR_DETAILRECEXISTEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DETAILRECEXISTEMPTY); DBIERR_MASTERREFERENCEERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERREFERENCEERR); DBIERR_DETAILTBLOPEN = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPEN); DBIERR_DEPENDENTSMUSTBEEMPTY = (ERRBASE_INTEGRITY + ERRCODE_DEPENDENTSMUSTBEEMPTY); DBIERR_RINTREQINDEX = (ERRBASE_INTEGRITY + ERRCODE_RINTREQINDEX); DBIERR_LINKEDTBLPROTECTED = (ERRBASE_INTEGRITY + ERRCODE_LINKEDTBLPROTECTED); DBIERR_FIELDMULTILINKED = (ERRBASE_INTEGRITY + ERRCODE_FIELDMULTILINKED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_CLIENTSLIMIT Constant

nxllBde.DBIERR_CLIENTSLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_CLIENTSLIMIT = (ERRBASE_LIMIT + ERRCODE_CLIENTSLIMIT);
File

nxllBde

Description

DBIERR_WSSESLIMIT = (ERRBASE_LIMIT + ERRCODE_WSSESLIMIT); DBIERR_SERNUMLIMIT = (ERRBASE_LIMIT + ERRCODE_SERNUMLIMIT); DBIERR_INTERNALLIMIT = (ERRBASE_LIMIT + ERRCODE_INTERNALLIMIT); DBIERR_OPENTBLLIMIT = (ERRBASE_LIMIT + ERRCODE_OPENTBLLIMIT); DBIERR_TBLCURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_TBLCURSORLIMIT); DBIERR_RECLOCKLIMIT = (ERRBASE_LIMIT + ERRCODE_RECLOCKLIMIT);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_DEADLOCK Constant

nxllBde.DBIERR_DEADLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_DEADLOCK = (ERRBASE_LOCKCONFLICT + ERRCODE_DEADLOCK);
File

nxllBde

Description

This is constant nxllBde.DBIERR_DEADLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_DETAILRECORDSEXIST Constant

nxllBde.DBIERR_DETAILRECORDSEXIST Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_DETAILRECORDSEXIST = (ERRBASE_INTEGRITY + ERRCODE_DETAILRECORDSEXIST);
File

nxllBde

Description

This is constant nxllBde.DBIERR_DETAILRECORDSEXIST.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_DIFFERENTTABLES Constant

nxllBde.DBIERR_DIFFERENTTABLES Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_DIFFERENTTABLES = (ERRBASE_INVALIDREQ + ERRCODE_DIFFERENTTABLES);
File

nxllBde

Description

This is constant nxllBde.DBIERR_DIFFERENTTABLES.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_DIRNOACCESS Constant

nxllBde.DBIERR_DIRNOACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_DIRNOACCESS = (ERRBASE_IO + ERRCODE_DIRNOACCESS);
File

nxllBde

Description

This is constant nxllBde.DBIERR_DIRNOACCESS.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_ENDOFBLOB Constant

nxllBde.DBIERR_ENDOFBLOB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_ENDOFBLOB = (ERRBASE_NOTFOUND + ERRCODE_ENDOFBLOB);
File

nxllBde

Description

This is constant nxllBde.DBIERR_ENDOFBLOB.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_EOF Constant

nxllBde.DBIERR_EOF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_EOF = (ERRBASE_NOTFOUND + ERRCODE_EOF);
File

nxllBde

Description

This is constant nxllBde.DBIERR_EOF.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FIELDISBLANK Constant

nxllBde.DBIERR_FIELDISBLANK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FIELDISBLANK = (ERRBASE_INTEGRITY + ERRCODE_FIELDISBLANK);
File

nxllBde

Description

DBIERR_MASTERTBLLEVEL = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLLEVEL); DBIERR_LOOKUPTABLEERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTABLEERR); DBIERR_LOOKUPTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_LOOKUPTBLOPENERR); DBIERR_DETAILTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_DETAILTBLOPENERR); DBIERR_MASTERTBLOPENERR = (ERRBASE_INTEGRITY + ERRCODE_MASTERTBLOPENERR);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FILECORRUPT Constant

nxllBde.DBIERR_FILECORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FILECORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_FILECORRUPT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_FILECORRUPT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FILELOCKED Constant

nxllBde.DBIERR_FILELOCKED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FILELOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_FILELOCKED);
File

nxllBde

Description

DBIERR_UNLOCKFAILED = (ERRBASE_LOCKCONFLICT + ERRCODE_UNLOCKFAILED); DBIERR_FILEBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_FILEBUSY); DBIERR_DIRBUSY = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRBUSY);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FILENOACCESS Constant

nxllBde.DBIERR_FILENOACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FILENOACCESS = (ERRBASE_IO + ERRCODE_FILENOACCESS);
File

nxllBde

Description

DBIERR_FILEDELETEFAIL = (ERRBASE_IO + ERRCODE_FILEDELETEFAIL);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FLDLIMIT Constant

nxllBde.DBIERR_FLDLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FLDLIMIT = (ERRBASE_LIMIT + ERRCODE_FLDLIMIT);
File

nxllBde

Description

DBIERR_SESSIONSLIMIT = (ERRBASE_LIMIT + ERRCODE_SESSIONSLIMIT); DBIERR_DBLIMIT = (ERRBASE_LIMIT + ERRCODE_DBLIMIT); DBIERR_PASSWORDLIMIT = (ERRBASE_LIMIT + ERRCODE_PASSWORDLIMIT); DBIERR_DRIVERLIMIT = (ERRBASE_LIMIT + ERRCODE_DRIVERLIMIT);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_FORIEGNKEYERR Constant

nxllBde.DBIERR_FORIEGNKEYERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_FORIEGNKEYERR = (ERRBASE_INTEGRITY + ERRCODE_FORIEGNKEYERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_FORIEGNKEYERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_GROUPLOCKCONFLICT Constant

nxllBde.DBIERR_GROUPLOCKCONFLICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_GROUPLOCKCONFLICT = DBIERR_RECGROUPCONFLICT;
File

nxllBde

Description

This is constant nxllBde.DBIERR_GROUPLOCKCONFLICT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_HEADERCORRUPT Constant

nxllBde.DBIERR_HEADERCORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_HEADERCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_HEADERCORRUPT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_HEADERCORRUPT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INDEXCORRUPT Constant

nxllBde.DBIERR_INDEXCORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INDEXCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_INDEXCORRUPT);
File

nxllBde

Description

DBIERR_MEMOCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_MEMOCORRUPT); DBIERR_BMPCORRUPT = (ERRBASE_DATACORRUPT + ERRCODE_BMPCORRUPT);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INDEXEXISTS Constant

nxllBde.DBIERR_INDEXEXISTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INDEXEXISTS = (ERRBASE_INVALIDREQ + ERRCODE_INDEXEXISTS);
File

nxllBde

Description

DBIERR_USECOUNT = (ERRBASE_INVALIDREQ + ERRCODE_USECOUNT); DBIERR_INVALIDKEY = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDKEY);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INDEXLIMIT Constant

nxllBde.DBIERR_INDEXLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INDEXLIMIT = (ERRBASE_LIMIT + ERRCODE_INDEXLIMIT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INDEXLIMIT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDALIASNAME Constant

nxllBde.DBIERR_INVALIDALIASNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDALIASNAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDALIASNAME);
File

nxllBde

Description

DBIERR_INVALIDTABLECREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLECREATE); DBIERR_INVALIDTABLEDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLEDELETE); DBIERR_INVALIDINDEXCREATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXCREATE); DBIERR_INVALIDINDEXDELETE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXDELETE); DBIERR_INVALIDTABLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLE); DBIERR_MULTIRESULTS = (ERRBASE_INVALIDREQ + ERRCODE_MULTIRESULTS); DBIERR_INVALIDTIME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIME); DBIERR_INVALIDDATE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDATE); DBIERR_INVALIDTIMESTAMP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTIMESTAMP); DBIERR_DIFFERENTPATH = (ERRBASE_INVALIDREQ + ERRCODE_DIFFERENTPATH); DBIERR_MISMATCHARGS = (ERRBASE_INVALIDREQ + ERRCODE_MISMATCHARGS); DBIERR_FUNCTIONNOTFOUND = (ERRBASE_INVALIDREQ + ERRCODE_FUNCTIONNOTFOUND); DBIERR_MUSTUSEBASEORDER = (ERRBASE_INVALIDREQ + ERRCODE_MUSTUSEBASEORDER); DBIERR_INVALIDPROCEDURENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDPROCEDURENAME); DBIERR_INVALIDFLDMAP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDMAP);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDBLOBHANDLE Constant

nxllBde.DBIERR_INVALIDBLOBHANDLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDBLOBHANDLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDBLOBHANDLE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDBLOBHANDLE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDBLOBLEN Constant

nxllBde.DBIERR_INVALIDBLOBLEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDBLOBLEN = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDBLOBLEN);
File

nxllBde

Description

DBIERR_INDEXOPEN = (ERRBASE_INVALIDREQ + ERRCODE_INDEXOPEN);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDBLOBOFFSET Constant

nxllBde.DBIERR_INVALIDBLOBOFFSET Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDBLOBOFFSET = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDBLOBOFFSET);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDBLOBOFFSET.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDBOOKMARK Constant

nxllBde.DBIERR_INVALIDBOOKMARK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDBOOKMARK = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDBOOKMARK);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDBOOKMARK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDDESC Constant

nxllBde.DBIERR_INVALIDDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDDESC = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDESC);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDDESC.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDDESCNUM Constant

nxllBde.DBIERR_INVALIDDESCNUM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDDESCNUM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDESCNUM);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDDESCNUM.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDDIR Constant

nxllBde.DBIERR_INVALIDDIR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDDIR = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDDIR);
File

nxllBde

Description

DBIERR_NOCALLBACK = (ERRBASE_INVALIDREQ + ERRCODE_NOCALLBACK); DBIERR_INVALIDCALLBACKBUFLEN = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDCALLBACKBUFLEN );

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFIELDNAME Constant

nxllBde.DBIERR_INVALIDFIELDNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFIELDNAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFIELDNAME);
File

nxllBde

Description

DBIERR_MULTILEVELCASCADE = (ERRBASE_INVALIDREQ + ERRCODE_MULTILEVELCASCADE);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFILEEXTN Constant

nxllBde.DBIERR_INVALIDFILEEXTN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFILEEXTN = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFILEEXTN);
File

nxllBde

Description

DBIERR_INVALIDLINKEXPR = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDLINKEXPR); DBIERR_NAMERESERVED = (ERRBASE_INVALIDREQ + ERRCODE_NAMERESERVED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFILTER Constant

nxllBde.DBIERR_INVALIDFILTER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFILTER = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFILTER);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDFILTER.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFLDDESC Constant

nxllBde.DBIERR_INVALIDFLDDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFLDDESC = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDDESC);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDFLDDESC.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFLDTYPE Constant

nxllBde.DBIERR_INVALIDFLDTYPE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFLDTYPE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDTYPE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDFLDTYPE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDFLDXFORM Constant

nxllBde.DBIERR_INVALIDFLDXFORM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDFLDXFORM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFLDXFORM);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDFLDXFORM.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDHNDL Constant

nxllBde.DBIERR_INVALIDHNDL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDHNDL = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDHNDL);
File

nxllBde

Description

DBIERR_INVALIDFILENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDFILENAME); DBIERR_NOSUCHFILE = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHFILE); DBIERR_INVALIDOPTION = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDOPTION);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDIDXDESC Constant

nxllBde.DBIERR_INVALIDIDXDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDIDXDESC = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDIDXDESC);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDIDXDESC.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDINDEXNAME Constant

nxllBde.DBIERR_INVALIDINDEXNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDINDEXNAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXNAME);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDINDEXNAME.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDINDEXSTRUCT Constant

nxllBde.DBIERR_INVALIDINDEXSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDINDEXSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXSTRUCT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDINDEXSTRUCT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDLANGDRV Constant

nxllBde.DBIERR_INVALIDLANGDRV Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDLANGDRV = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDLANGDRV);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDLANGDRV.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDNAME Constant

nxllBde.DBIERR_INVALIDNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDNAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDNAME);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDNAME.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDPARAM Constant

nxllBde.DBIERR_INVALIDPARAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDPARAM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDPARAM);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDPARAM.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDPASSWORD Constant

nxllBde.DBIERR_INVALIDPASSWORD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDPASSWORD = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDPASSWORD);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDPASSWORD.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDRECSTRUCT Constant

nxllBde.DBIERR_INVALIDRECSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDRECSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRECSTRUCT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDRECSTRUCT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDTABLENAME Constant

nxllBde.DBIERR_INVALIDTABLENAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDTABLENAME = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDTABLENAME);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDTABLENAME.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDUSRPASS Constant

nxllBde.DBIERR_INVALIDUSRPASS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDUSRPASS = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDUSRPASS);
File

nxllBde

Description

DBIERR_NEEDRESTRUCTURE = (ERRBASE_INVALIDREQ + ERRCODE_NEEDRESTRUCTURE); DBIERR_INVALIDMODE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODE); DBIERR_CANNOTCLOSE = (ERRBASE_INVALIDREQ + ERRCODE_CANNOTCLOSE); DBIERR_ACTIVEINDEX = (ERRBASE_INVALIDREQ + ERRCODE_ACTIVEINDEX);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_INVALIDXLATION Constant

nxllBde.DBIERR_INVALIDXLATION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_INVALIDXLATION = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDXLATION);
File

nxllBde

Description

This is constant nxllBde.DBIERR_INVALIDXLATION.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_KEYORRECDELETED Constant

nxllBde.DBIERR_KEYORRECDELETED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_KEYORRECDELETED = (ERRBASE_NOTFOUND + ERRCODE_KEYORRECDELETED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_KEYORRECDELETED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_KEYVIOL Constant

nxllBde.DBIERR_KEYVIOL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_KEYVIOL = (ERRBASE_INTEGRITY + ERRCODE_KEYVIOL);
File

nxllBde

Description

This is constant nxllBde.DBIERR_KEYVIOL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_LOCKED Constant

nxllBde.DBIERR_LOCKED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_LOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_LOCKED);
File

nxllBde

Description

ERRCODE_LOCKEDRECS = 21; ERRCODE_NEEDWRITELOCK = 22;

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_LOCKTIMEOUT Constant

nxllBde.DBIERR_LOCKTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_LOCKTIMEOUT = (ERRBASE_LOCKCONFLICT + ERRCODE_LOCKTIMEOUT);
File

nxllBde

Description

DBIERR_DIRLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_DIRLOCKED); DBIERR_ALREADYLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_ALREADYLOCKED); DBIERR_NOTLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_NOTLOCKED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_MAXVALERR Constant

nxllBde.DBIERR_MAXVALERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_MAXVALERR = (ERRBASE_INTEGRITY + ERRCODE_MAXVALERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_MAXVALERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_MINVALERR Constant

nxllBde.DBIERR_MINVALERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_MINVALERR = (ERRBASE_INTEGRITY + ERRCODE_MINVALERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_MINVALERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NA Constant

nxllBde.DBIERR_NA Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NA = (ERRBASE_IC + ERRCODE_NA);
File

nxllBde

Description

DBIERR_BLOBOPENED = (ERRBASE_IC + ERRCODE_BLOBOPENED); DBIERR_BLOBNOTOPENED = (ERRBASE_IC + ERRCODE_BLOBNOTOPENED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NAMENOTUNIQUE Constant

nxllBde.DBIERR_NAMENOTUNIQUE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NAMENOTUNIQUE = (ERRBASE_INVALIDREQ + ERRCODE_NAMENOTUNIQUE);
File

nxllBde

Description

DBIERR_INVALIDVCHKSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDVCHKSTRUCT); DBIERR_INVALIDRINTSTRUCT = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTSTRUCT); DBIERR_INVALIDRESTRTBLORDER = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTRTBLORDER);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NEEDEXCLACCESS Constant

nxllBde.DBIERR_NEEDEXCLACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NEEDEXCLACCESS = (ERRBASE_LOCKCONFLICT + ERRCODE_NEEDEXCLACCESS);
File

nxllBde

Description

DBIERR_GROUPLOCKED = (ERRBASE_LOCKCONFLICT + ERRCODE_GROUPLOCKED); DBIERR_LOSTTBLLOCK = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTTBLLOCK); DBIERR_LOSTEXCLACCESS = (ERRBASE_LOCKCONFLICT + ERRCODE_LOSTEXCLACCESS);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOACTIVETRAN Constant

nxllBde.DBIERR_NOACTIVETRAN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOACTIVETRAN = (ERRBASE_LOCKCONFLICT + ERRCODE_NOACTIVETRAN);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOACTIVETRAN.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOASSOCINDEX Constant

nxllBde.DBIERR_NOASSOCINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOASSOCINDEX = (ERRBASE_IC + ERRCODE_NOASSOCINDEX);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOASSOCINDEX.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOCURRREC Constant

nxllBde.DBIERR_NOCURRREC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOCURRREC = (ERRBASE_NOTFOUND + ERRCODE_NOCURRREC);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOCURRREC.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOMEMORY Constant

nxllBde.DBIERR_NOMEMORY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOMEMORY = (ERRBASE_LIMIT + ERRCODE_NOMEMORY);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOMEMORY.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NONE Constant

nxllBde.DBIERR_NONE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NONE = (ERRBASE_NONE + ERRCODE_NONE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NONE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOSERVERSW Constant

nxllBde.DBIERR_NOSERVERSW Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOSERVERSW = ( ERRBASE_OS + ERRCODE_NOSERVERSW);
File

nxllBde

Description

DBIERR_NOTEXACT = ( ERRBASE_OS + ERRCODE_NOTEXACT ); DBIERR_OSUNKNOWNSRVERR = ( ERRBASE_OS + ERRCODE_OSUNKNOWNSRVERR ); DBIERR_SERVERNOMEMORY = ( ERRBASE_OS + ERRCODE_SERVERNOMEMORY ); DBIERR_OSALREADYLOCKED = ( ERRBASE_OS + ERRCODE_OSALREADYLOCKED ); DBIERR_OSNOTLOCKED = ( ERRBASE_OS + ERRCODE_OSNOTLOCKED );

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOSUCHFILTER Constant

nxllBde.DBIERR_NOSUCHFILTER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOSUCHFILTER = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHFILTER);
File

nxllBde

Description

DBIERR_ALIASNOTOPEN = (ERRBASE_INVALIDREQ + ERRCODE_ALIASNOTOPEN); DBIERR_INCOMPATRECSTRUCTS = (ERRBASE_INVALIDREQ + ERRCODE_INCOMPATRECSTRUCTS); DBIERR_RESERVEDOSNAME = (ERRBASE_INVALIDREQ + ERRCODE_RESERVEDDOSNAME); DBIERR_DESTMUSTBEINDEXED = (ERRBASE_INVALIDREQ + ERRCODE_DESTMUSTBEINDEXED); DBIERR_INVALIDINDEXTYPE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDINDEXTYPE); DBIERR_LANGDRVMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_LANGDRVMISMATCH);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOSUCHINDEX Constant

nxllBde.DBIERR_NOSUCHINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOSUCHINDEX = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHINDEX);
File

nxllBde

Description

DBIERR_PRIMARYKEYREDEFINE = (ERRBASE_INVALIDREQ + ERRCODE_PRIMARYKEYREDEFINE); DBIERR_INVALIDRINTDESCNUM = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRINTDESCNUM); DBIERR_KEYFLDTYPEMISMATCH = (ERRBASE_INVALIDREQ + ERRCODE_KEYFLDTYPEMISMATCH); DBIERR_INVALIDMODIFYREQUEST = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDMODIFYREQUEST);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOSUCHTABLE Constant

nxllBde.DBIERR_NOSUCHTABLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOSUCHTABLE = (ERRBASE_INVALIDREQ + ERRCODE_NOSUCHTABLE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOSUCHTABLE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOTABLOB Constant

nxllBde.DBIERR_NOTABLOB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOTABLOB = (ERRBASE_IC + ERRCODE_NOTABLOB);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOTABLOB.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOTINDEXED Constant

nxllBde.DBIERR_NOTINDEXED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOTINDEXED = (ERRBASE_IC + ERRCODE_NOTINDEXED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOTINDEXED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOTSAMESESSION Constant

nxllBde.DBIERR_NOTSAMESESSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOTSAMESESSION = (ERRBASE_IC + ERRCODE_NOTSAMESESSION);
File

nxllBde

Description

DBIERR_NOTINITIALIZED = (ERRBASE_IC + ERRCODE_NOTINITIALIZED); DBIERR_MULTIPLEINIT = (ERRBASE_IC + ERRCODE_MULTIPLEINIT);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOTSUFFTABLERIGHTS Constant

nxllBde.DBIERR_NOTSUFFTABLERIGHTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOTSUFFTABLERIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFTABLERIGHTS);
File

nxllBde

Description

DBIERR_NOTSUFFFIELDRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFIELDRIGHTS);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NOTSUPPORTED Constant

nxllBde.DBIERR_NOTSUPPORTED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NOTSUPPORTED = (ERRBASE_CAPABILITY + ERRCODE_NOTSUPPORTED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NOTSUPPORTED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADBLOCKNR Constant

nxllBde.DBIERR_NX_BADBLOCKNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADBLOCKNR = ERRBASE_NEXUS + ERRCODE_NX_BADBLOCKNR;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADBLOCKNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADDATABLOCK Constant

nxllBde.DBIERR_NX_BADDATABLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADDATABLOCK = ERRBASE_NEXUS + ERRCODE_NX_BADDATABLOCK;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADDATABLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADHEAPBLOCK Constant

nxllBde.DBIERR_NX_BADHEAPBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADHEAPBLOCK = ERRBASE_NEXUS + ERRCODE_NX_BADHEAPBLOCK;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADHEAPBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADINDEX Constant

nxllBde.DBIERR_NX_BADINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADINDEX = ERRBASE_NEXUS + ERRCODE_NX_BADINDEX;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADINDEX.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADINXBLOCK Constant

nxllBde.DBIERR_NX_BADINXBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADINXBLOCK = ERRBASE_NEXUS + ERRCODE_NX_BADINXBLOCK;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADINXBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADREFNR Constant

nxllBde.DBIERR_NX_BADREFNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADREFNR = ERRBASE_NEXUS + ERRCODE_NX_BADREFNR;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADREFNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADSTREAMBLOCK Constant

nxllBde.DBIERR_NX_BADSTREAMBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADSTREAMBLOCK = ERRBASE_NEXUS + ERRCODE_NX_BADSTREAMBLOCK;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADSTREAMBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BADSTRUCT Constant

nxllBde.DBIERR_NX_BADSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BADSTRUCT = ERRBASE_NEXUS + ERRCODE_NX_BADSTRUCT;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BADSTRUCT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_BLOBTOOBIG Constant

nxllBde.DBIERR_NX_BLOBTOOBIG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_BLOBTOOBIG = ERRBASE_NEXUS + ERRCODE_NX_BLOBTOOBIG;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_BLOBTOOBIG.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_CLOSEFAILED Constant

nxllBde.DBIERR_NX_CLOSEFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_CLOSEFAILED = ERRBASE_NEXUS + ERRCODE_NX_CLOSEFAILED;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_CLOSEFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_COPYFILE Constant

nxllBde.DBIERR_NX_COPYFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_COPYFILE = ERRBASE_NEXUS + ERRCODE_NX_COPYFILE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_COPYFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_CORRUPTTRANS Constant

nxllBde.DBIERR_NX_CORRUPTTRANS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_CORRUPTTRANS = ERRBASE_NEXUS + ERRCODE_NX_CORRUPTTRANS;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_CORRUPTTRANS.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_DELETEFILE Constant

nxllBde.DBIERR_NX_DELETEFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_DELETEFILE = ERRBASE_NEXUS + ERRCODE_NX_DELETEFILE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_DELETEFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_DICT_DUPAUTOINC Constant

nxllBde.DBIERR_NX_DICT_DUPAUTOINC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_DICT_DUPAUTOINC = ERRBASE_NEXUS + ERRCODE_NX_DICT_DUPAUTOINC;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_DICT_DUPAUTOINC.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_DICT_DUPRECREV Constant

nxllBde.DBIERR_NX_DICT_DUPRECREV Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_DICT_DUPRECREV = ERRBASE_NEXUS + ERRCODE_NX_DICT_DUPRECREV;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_DICT_DUPRECREV.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_DICT_OBJINUSE Constant

nxllBde.DBIERR_NX_DICT_OBJINUSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_DICT_OBJINUSE = ERRBASE_NEXUS + ERRCODE_NX_DICT_OBJINUSE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_DICT_OBJINUSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_DICT_READONLY Constant

nxllBde.DBIERR_NX_DICT_READONLY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_DICT_READONLY = ERRBASE_NEXUS + ERRCODE_NX_DICT_READONLY;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_DICT_READONLY.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_FILEBLOBCLOSE Constant

nxllBde.DBIERR_NX_FILEBLOBCLOSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_FILEBLOBCLOSE = ERRBASE_NEXUS + ERRCODE_NX_FILEBLOBCLOSE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_FILEBLOBCLOSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_FILEBLOBOPEN Constant

nxllBde.DBIERR_NX_FILEBLOBOPEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_FILEBLOBOPEN = ERRBASE_NEXUS + ERRCODE_NX_FILEBLOBOPEN;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_FILEBLOBOPEN.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_FILEBLOBREAD Constant

nxllBde.DBIERR_NX_FILEBLOBREAD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_FILEBLOBREAD = ERRBASE_NEXUS + ERRCODE_NX_FILEBLOBREAD;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_FILEBLOBREAD.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_FILTERTIMEOUT Constant

nxllBde.DBIERR_NX_FILTERTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_FILTERTIMEOUT = ERRBASE_NEXUS + ERRCODE_NX_FILTERTIMEOUT;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_FILTERTIMEOUT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_GENERALTIMEOUT Constant

nxllBde.DBIERR_NX_GENERALTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_GENERALTIMEOUT = ERRBASE_NEXUS + ERRCODE_NX_GENERALTIMEOUT;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_GENERALTIMEOUT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_INCOMPATDICT Constant

nxllBde.DBIERR_NX_INCOMPATDICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_INCOMPATDICT = ERRBASE_NEXUS + ERRCODE_NX_INCOMPATDICT;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_INCOMPATDICT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_INCOMPATHEADER Constant

nxllBde.DBIERR_NX_INCOMPATHEADER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_INCOMPATHEADER = ERRBASE_NEXUS + ERRCODE_NX_INCOMPATHEADER;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_INCOMPATHEADER.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_INCOMPATSTREAM Constant

nxllBde.DBIERR_NX_INCOMPATSTREAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_INCOMPATSTREAM = ERRBASE_NEXUS + ERRCODE_NX_INCOMPATSTREAM;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_INCOMPATSTREAM.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_INDEXNOTEMPTY Constant

nxllBde.DBIERR_NX_INDEXNOTEMPTY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_INDEXNOTEMPTY = ERRBASE_NEXUS + ERRCODE_NX_INDEXNOTEMPTY;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_INDEXNOTEMPTY.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_INVALIDSEGNR Constant

nxllBde.DBIERR_NX_INVALIDSEGNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_INVALIDSEGNR = ERRBASE_NEXUS + ERRCODE_NX_INVALIDSEGNR;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_INVALIDSEGNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_KEYFILTERED Constant

nxllBde.DBIERR_NX_KEYFILTERED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_KEYFILTERED = (ERRBASE_NONE + ERRCODE_NX_KEYFILTERED_NONE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_KEYFILTERED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_LICENSE_EXPIRED Constant

nxllBde.DBIERR_NX_LICENSE_EXPIRED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_LICENSE_EXPIRED = ERRBASE_NEXUS + ERRCODE_NX_LICENSE_EXPIRED;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_LICENSE_EXPIRED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_LITE Constant

nxllBde.DBIERR_NX_LITE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_LITE = ERRBASE_NEXUS + ERRCODE_NX_LITE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_LITE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_MAXKEYSIZE Constant

nxllBde.DBIERR_NX_MAXKEYSIZE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_MAXKEYSIZE = ERRBASE_NEXUS + ERRCODE_NX_MAXKEYSIZE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_MAXKEYSIZE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_MAXRECORDSIZE Constant

nxllBde.DBIERR_NX_MAXRECORDSIZE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_MAXRECORDSIZE = ERRBASE_NEXUS + ERRCODE_NX_MAXRECORDSIZE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_MAXRECORDSIZE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_NOSESSIONSE Constant

nxllBde.DBIERR_NX_NOSESSIONSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_NOSESSIONSE = ERRBASE_NEXUS + ERRCODE_NX_NOSESSIONSE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_NOSESSIONSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_RECOVERFAILED Constant

nxllBde.DBIERR_NX_RECOVERFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_RECOVERFAILED = ERRBASE_NEXUS + ERRCODE_NX_RECOVERFAILED;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_RECOVERFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_REGISTERFHAF Constant

nxllBde.DBIERR_NX_REGISTERFHAF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_REGISTERFHAF = ERRBASE_NEXUS + ERRCODE_NX_REGISTERFHAF;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_REGISTERFHAF.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_RENAMEFILE Constant

nxllBde.DBIERR_NX_RENAMEFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_RENAMEFILE = ERRBASE_NEXUS + ERRCODE_NX_RENAMEFILE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_RENAMEFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_SAMEFOLDER Constant

nxllBde.DBIERR_NX_SAMEFOLDER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_SAMEFOLDER = ERRBASE_NEXUS + ERRCODE_NX_SAMEFOLDER;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_SAMEFOLDER.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_SAMETABLE Constant

nxllBde.DBIERR_NX_SAMETABLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_SAMETABLE = ERRBASE_NEXUS + ERRCODE_NX_SAMETABLE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_SAMETABLE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_SEGMENTDELETED Constant

nxllBde.DBIERR_NX_SEGMENTDELETED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_SEGMENTDELETED = ERRBASE_NEXUS + ERRCODE_NX_SEGMENTDELETED;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_SEGMENTDELETED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_SERVERNAMENOTSET Constant

nxllBde.DBIERR_NX_SERVERNAMENOTSET Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_SERVERNAMENOTSET = ERRBASE_NEXUS + ERRCODE_NX_SERVERNAMENOTSET;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_SERVERNAMENOTSET.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_SQLSIGNAL Constant

nxllBde.DBIERR_NX_SQLSIGNAL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_SQLSIGNAL = ERRBASE_NEXUS + ERRCODE_NX_SQLSIGNAL;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_SQLSIGNAL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_TABLEVERSION Constant

nxllBde.DBIERR_NX_TABLEVERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_TABLEVERSION = ERRBASE_NEXUS + ERRCODE_NX_TABLEVERSION;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_TABLEVERSION.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_TRIAL Constant

nxllBde.DBIERR_NX_TRIAL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_TRIAL = ERRBASE_NEXUS + ERRCODE_NX_TRIAL;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_TRIAL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_TS_FULL Constant

nxllBde.DBIERR_NX_TS_FULL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_TS_FULL = ERRBASE_NEXUS + ERRCODE_NX_TS_FULL;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_TS_FULL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_TS_INVALIDBLOCK Constant

nxllBde.DBIERR_NX_TS_INVALIDBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_TS_INVALIDBLOCK = ERRBASE_NEXUS + ERRCODE_NX_TS_INVALIDBLOCK;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_TS_INVALIDBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNKNOWN Constant

nxllBde.DBIERR_NX_UNKNOWN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNKNOWN = ERRBASE_NEXUS + ERRCODE_NX_UNKNOWN;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNKNOWN.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNKNOWNEXCP Constant

nxllBde.DBIERR_NX_UNKNOWNEXCP Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNKNOWNEXCP = ERRBASE_NEXUS + ERRCODE_NX_UNKNOWNEXCP;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNKNOWNEXCP.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNKNOWNMSG Constant

nxllBde.DBIERR_NX_UNKNOWNMSG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNKNOWNMSG = ERRBASE_NEXUS + ERRCODE_NX_UNKNOWNMSG;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNKNOWNMSG.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNSUPDICTDESCR Constant

nxllBde.DBIERR_NX_UNSUPDICTDESCR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNSUPDICTDESCR = ERRBASE_NEXUS + ERRCODE_NX_UNSUPDICTDESCR;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNSUPDICTDESCR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNSUPHEADER Constant

nxllBde.DBIERR_NX_UNSUPHEADER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNSUPHEADER = ERRBASE_NEXUS + ERRCODE_NX_UNSUPHEADER;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNSUPHEADER.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_NX_UNSUPSUBENGINE Constant

nxllBde.DBIERR_NX_UNSUPSUBENGINE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_NX_UNSUPSUBENGINE = ERRBASE_NEXUS + ERRCODE_NX_UNSUPSUBENGINE;
File

nxllBde

Description

This is constant nxllBde.DBIERR_NX_UNSUPSUBENGINE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_OBJNOTFOUND Constant

nxllBde.DBIERR_OBJNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_OBJNOTFOUND = (ERRBASE_NOTFOUND + ERRCODE_OBJNOTFOUND);
File

nxllBde

Description

This is constant nxllBde.DBIERR_OBJNOTFOUND.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_OPTRECLOCKFAILED Constant

nxllBde.DBIERR_OPTRECLOCKFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_OPTRECLOCKFAILED = (ERRBASE_LOCKCONFLICT + ERRCODE_OPTRECLOCKFAILED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_OPTRECLOCKFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_OPTRECLOCKRECDEL Constant

nxllBde.DBIERR_OPTRECLOCKRECDEL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_OPTRECLOCKRECDEL = (ERRBASE_LOCKCONFLICT + ERRCODE_OPTRECLOCKRECDEL);
File

nxllBde

Description

This is constant nxllBde.DBIERR_OPTRECLOCKRECDEL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_OSUNKNOWN Constant

nxllBde.DBIERR_OSUNKNOWN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_OSUNKNOWN = ( ERRBASE_OS + ERRCODE_OSUNKNOWN );
File

nxllBde

Description

DBIERR_OSEINVFNC = ( ERRBASE_OS + ERRCODE_OSEINVFNC ); DBIERR_OSENOENT = ( ERRBASE_OS + ERRCODE_OSENOENT ); DBIERR_OSENOPATH = ( ERRBASE_OS + ERRCODE_OSENOPATH ); DBIERR_OSEMFILE = ( ERRBASE_OS + ERRCODE_OSEMFILE ); DBIERR_OSEACCES = ( ERRBASE_OS + ERRCODE_OSEACCES ); DBIERR_OSEBADF = ( ERRBASE_OS + ERRCODE_OSEBADF ); DBIERR_OSECONTR = ( ERRBASE_OS + ERRCODE_OSECONTR ); DBIERR_OSENOMEM = ( ERRBASE_OS + ERRCODE_OSENOMEM ); DBIERR_OSEINVMEM = ( ERRBASE_OS + ERRCODE_OSEINVMEM ); DBIERR_OSEINVENV = ( ERRBASE_OS + ERRCODE_OSEINVENV ); DBIERR_OSEINVFMT = ( ERRBASE_OS + ERRCODE_OSEINVFMT ); DBIERR_OSEINVACC = ( ERRBASE_OS + ERRCODE_OSEINVACC ); DBIERR_OSEINVDAT = ( ERRBASE_OS + ERRCODE_OSEINVDAT ); DBIERR_OSENODEV = ( ERRBASE_OS + ERRCODE_OSENODEV ); DBIERR_OSECURDIR = ( ERRBASE_OS + ERRCODE_OSECURDIR ); DBIERR_OSENOTSAM = ( ERRBASE_OS + ERRCODE_OSENOTSAM ); DBIERR_OSENMFILE = ( ERRBASE_OS + ERRCODE_OSENMFILE ); DBIERR_OSEINVAL = ( ERRBASE_OS + ERRCODE_OSEINVAL ); DBIERR_OSE2BIG = ( ERRBASE_OS + ERRCODE_OSE2BIG ); DBIERR_OSENOEXEC = ( ERRBASE_OS + ERRCODE_OSENOEXEC ); DBIERR_OSEXDEV = ( ERRBASE_OS + ERRCODE_OSEXDEV ); DBIERR_OSEDOM = ( ERRBASE_OS + ERRCODE_OSEDOM ); DBIERR_OSERANGE = ( ERRBASE_OS + ERRCODE_OSERANGE ); DBIERR_OSEEXIST = ( ERRBASE_OS + ERRCODE_OSEEXIST );

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_OUTOFRANGE Constant

nxllBde.DBIERR_OUTOFRANGE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_OUTOFRANGE = (ERRBASE_INVALIDREQ + ERRCODE_OUTOFRANGE);
File

nxllBde

Description

This is constant nxllBde.DBIERR_OUTOFRANGE.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_READERR Constant

nxllBde.DBIERR_READERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_READERR = (ERRBASE_IO + ERRCODE_READERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_READERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_READONLYDB Constant

nxllBde.DBIERR_READONLYDB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_READONLYDB = (ERRBASE_SEC + ERRCODE_READONLYDB);
File

nxllBde

Description

DBIERR_NOTSUFFFAMILYRIGHTS = (ERRBASE_SEC + ERRCODE_NOTSUFFFAMILYRIGHTS); DBIERR_READONLYDIR = (ERRBASE_SEC + ERRCODE_READONLYDIR);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_READONLYFLD Constant

nxllBde.DBIERR_READONLYFLD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_READONLYFLD = (ERRBASE_SEC + ERRCODE_READONLYFLD);
File

nxllBde

Description

This is constant nxllBde.DBIERR_READONLYFLD.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_RECDELETED Constant

nxllBde.DBIERR_RECDELETED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_RECDELETED = (ERRBASE_NOTFOUND + ERRCODE_KEYORRECDELETED);
File

nxllBde

Description

DBIERR_RECMOVED = (ERRBASE_NOTFOUND + ERRCODE_RECMOVED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_RECGROUPCONFLICT Constant

nxllBde.DBIERR_RECGROUPCONFLICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_RECGROUPCONFLICT = (ERRBASE_LOCKCONFLICT + ERRCODE_RECGROUPCONFLICT);
File

nxllBde

Description

This is constant nxllBde.DBIERR_RECGROUPCONFLICT.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_RECLOCKFAILED Constant

nxllBde.DBIERR_RECLOCKFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_RECLOCKFAILED = (ERRBASE_LOCKCONFLICT + ERRCODE_RECLOCKFAILED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_RECLOCKFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_RECNOTFOUND Constant

nxllBde.DBIERR_RECNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_RECNOTFOUND = (ERRBASE_NOTFOUND + ERRCODE_RECNOTFOUND);
File

nxllBde

Description

This is constant nxllBde.DBIERR_RECNOTFOUND.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_REENTERED Constant

nxllBde.DBIERR_REENTERED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_REENTERED = (ERRBASE_SYSTEM + ERRCODE_REENTERED);
File

nxllBde

Description

DBIERR_SYSFILEOPEN = (ERRBASE_SYSTEM + ERRCODE_SYSFILEOPEN); DBIERR_SYSFILEIO = (ERRBASE_SYSTEM + ERRCODE_SYSFILEIO); DBIERR_SYSCORRUPT = (ERRBASE_SYSTEM + ERRCODE_SYSCORRUPT); DBIERR_NOCONFIGFILE = (ERRBASE_SYSTEM + ERRCODE_NOCONFIGFILE); DBIERR_CFGCANNOTWRITE = (ERRBASE_SYSTEM + ERRCODE_CFGCANNOTWRITE); DBIERR_CFGMULTIFILE = (ERRBASE_SYSTEM + ERRCODE_CFGMULTIFILE);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_REQDERR Constant

nxllBde.DBIERR_REQDERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_REQDERR = (ERRBASE_INTEGRITY + ERRCODE_REQDERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_REQDERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_SERVERCOMMLOST Constant

nxllBde.DBIERR_SERVERCOMMLOST Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_SERVERCOMMLOST = (ERRBASE_NETWORK + ERRCODE_SERVERCOMMLOST);
File

nxllBde

Description

DBIERR_NETINITERR = (ERRBASE_NETWORK + ERRCODE_NETINITERR); DBIERR_NETUSERLIMIT = (ERRBASE_NETWORK + ERRCODE_NETUSERLIMIT); DBIERR_NETFILEVERSION = (ERRBASE_NETWORK + ERRCODE_NETFILEVERSION); DBIERR_NETFILELOCKED = (ERRBASE_NETWORK + ERRCODE_NETFILELOCKED); DBIERR_DIRNOTPRIVATE = (ERRBASE_NETWORK + ERRCODE_DIRNOTPRIVATE); DBIERR_NETMULTIPLE = (ERRBASE_NETWORK + ERRCODE_NETMULTIPLE); DBIERR_NETUNKNOWN = (ERRBASE_NETWORK + ERRCODE_NETUNKNOWN); DBIERR_SHAREDFILE = (ERRBASE_NETWORK + ERRCODE_SHAREDFILE); DBIERR_SHARENOTLOADED = (ERRBASE_NETWORK + ERRCODE_SHARENOTLOADED); DBIERR_NOTONANETWORK = (ERRBASE_NETWORK + ERRCODE_NOTONANETWORK); DBIERR_SQLCOMMLOST = (ERRBASE_NETWORK + ERRCODE_SQLCOMMLOST);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_SERVERNOTFOUND Constant

nxllBde.DBIERR_SERVERNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_SERVERNOTFOUND = (ERRBASE_NETWORK + ERRCODE_SERVERNOTFOUND);
File

nxllBde

Description

DBIERR_SQLSERVERNOTFOUND = (ERRBASE_NETWORK + ERRCODE_SQLSERVERNOTFOUND);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_SERVERVERSION Constant

nxllBde.DBIERR_SERVERVERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_SERVERVERSION = (ERRBASE_VERSION + ERRCODE_SERVERVERSION);
File

nxllBde

Description

DBIERR_INTERFACEVER = (ERRBASE_VERSION + ERRCODE_INTERFACEVER); DBIERR_INDEXOUTOFDATE = (ERRBASE_VERSION + ERRCODE_INDEXOUTOFDATE); DBIERR_OLDVERSION = (ERRBASE_VERSION + ERRCODE_OLDVERSION); DBIERR_VALFILEINVALID = (ERRBASE_VERSION + ERRCODE_VALFILEINVALID); DBIERR_BLOBVERSION = (ERRBASE_VERSION + ERRCODE_BLOBVERSION); DBIERR_ENGQRYMISMATCH = (ERRBASE_VERSION + ERRCODE_ENGQRYMISMATCH);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TABLEEXISTS Constant

nxllBde.DBIERR_TABLEEXISTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TABLEEXISTS = (ERRBASE_OTHER + ERRCODE_TABLEEXISTS);
File

nxllBde

Description

DBIERR_UNKNOWNSQL = (ERRBASE_OTHER + ERRCODE_UNKNOWNSQL);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TABLEFULL Constant

nxllBde.DBIERR_TABLEFULL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TABLEFULL = (ERRBASE_LIMIT + ERRCODE_TABLEFULL);
File

nxllBde

Description

DBIERR_NOFILEHANDLES = (ERRBASE_LIMIT + ERRCODE_NOFILEHANDLES); DBIERR_NODISKSPACE = (ERRBASE_LIMIT + ERRCODE_NODISKSPACE); DBIERR_NOTEMPTBLSPACE = (ERRBASE_LIMIT + ERRCODE_NOTEMPTBLSPACE); DBIERR_RECTOOBIG = (ERRBASE_LIMIT + ERRCODE_RECTOOBIG); DBIERR_CURSORLIMIT = (ERRBASE_LIMIT + ERRCODE_CURSORLIMIT);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TABLELEVEL Constant

nxllBde.DBIERR_TABLELEVEL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TABLELEVEL = (ERRBASE_VERSION + ERRCODE_TABLELEVEL);
File

nxllBde

Description

This is constant nxllBde.DBIERR_TABLELEVEL.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TABLEOPEN Constant

nxllBde.DBIERR_TABLEOPEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TABLEOPEN = (ERRBASE_INVALIDREQ + ERRCODE_TABLEOPEN);
File

nxllBde

Description

This is constant nxllBde.DBIERR_TABLEOPEN.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TABLEREADONLY Constant

nxllBde.DBIERR_TABLEREADONLY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TABLEREADONLY = (ERRBASE_IC + ERRCODE_TABLEREADONLY);
File

nxllBde

Description

DBIERR_PDXDRIVERNOTACTIVE = (ERRBASE_IC + ERRCODE_PDXDRIVERNOTACTIVE); DBIERR_DRIVERNOTLOADED = (ERRBASE_IC + ERRCODE_DRIVERNOTLOADED);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_TBLENCRYPTED Constant

nxllBde.DBIERR_TBLENCRYPTED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_TBLENCRYPTED = (ERRBASE_SEC + ERRCODE_TBLENCRYPTED);
File

nxllBde

Description

This is constant nxllBde.DBIERR_TBLENCRYPTED.

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_UNKNOWNDB Constant

nxllBde.DBIERR_UNKNOWNDB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_UNKNOWNDB = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNDB);
File

nxllBde

Description

DBIERR_INDEXNAMEREQUIRED = (ERRBASE_INVALIDREQ + ERRCODE_INDEXNAMEREQUIRED); DBIERR_INVALIDSESHANDLE = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDSESHANDLE); DBIERR_INVALIDRESTROP = (ERRBASE_INVALIDREQ + ERRCODE_INVALIDRESTROP); DBIERR_UNKNOWNDRIVER = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNDRIVER);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_UNKNOWNFILE Constant

nxllBde.DBIERR_UNKNOWNFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_UNKNOWNFILE = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNFILE);
File

nxllBde

Description

DBIERR_UNKNOWNTBLTYPE = (ERRBASE_INVALIDREQ + ERRCODE_UNKNOWNTBLTYPE);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_UPDATEABORT Constant

nxllBde.DBIERR_UPDATEABORT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_UPDATEABORT = (ERRBASE_OTHER + ERRCODE_UPDATEABORT);
File

nxllBde

Description

DBIERR_PDX10TABLE = (ERRBASE_OTHER + ERRCODE_PDX10TABLE);

Group

Constants

Links
nxllBde, Constants


nxllBde.DBIERR_WRITEERR Constant

nxllBde.DBIERR_WRITEERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
DBIERR_WRITEERR = (ERRBASE_IO + ERRCODE_WRITEERR);
File

nxllBde

Description

This is constant nxllBde.DBIERR_WRITEERR.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_CAPABILITY Constant

nxllBde.ERRBASE_CAPABILITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_CAPABILITY = $3000;
File

nxllBde

Description

Capability not supported

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_COMPATIBILITY Constant

nxllBde.ERRBASE_COMPATIBILITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_COMPATIBILITY = $3400;
File

nxllBde

Description

Compatibility related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_CONFIG Constant

nxllBde.ERRBASE_CONFIG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_CONFIG = $3100;
File

nxllBde

Description

System configuration error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_DATACORRUPT Constant

nxllBde.ERRBASE_DATACORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_DATACORRUPT = $2300;
File

nxllBde

Description

Physical Data Corruption

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_DRIVER Constant

nxllBde.ERRBASE_DRIVER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_DRIVER = $3E00;
File

nxllBde

Description

Driver related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_IC Constant

nxllBde.ERRBASE_IC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_IC = $2A00;
File

nxllBde

Description

Invalid context

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_INTEGRITY Constant

nxllBde.ERRBASE_INTEGRITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_INTEGRITY = $2600;
File

nxllBde

Description

Integrity Violation

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_INVALIDREQ Constant

nxllBde.ERRBASE_INVALIDREQ Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_INVALIDREQ = $2700;
File

nxllBde

Description

Invalid Request

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_IO Constant

nxllBde.ERRBASE_IO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_IO = $2400;
File

nxllBde

Description

I/O related error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_LIMIT Constant

nxllBde.ERRBASE_LIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_LIMIT = $2500;
File

nxllBde

Description

Resource or Limit error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_LOCKCONFLICT Constant

nxllBde.ERRBASE_LOCKCONFLICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_LOCKCONFLICT = $2800;
File

nxllBde

Description

Locking/Contention related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_NETWORK Constant

nxllBde.ERRBASE_NETWORK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_NETWORK = $2C00;
File

nxllBde

Description

Network related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_NEXUS Constant

nxllBde.ERRBASE_NEXUS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_NEXUS = $3C00;
File

nxllBde

Description

This is constant nxllBde.ERRBASE_NEXUS.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_NONE Constant

nxllBde.ERRBASE_NONE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_NONE = 0;
File

nxllBde

Description

No error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_NOTFOUND Constant

nxllBde.ERRBASE_NOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_NOTFOUND = $2200;
File

nxllBde

Description

Object of interest Not Found

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_OPTPARAM Constant

nxllBde.ERRBASE_OPTPARAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_OPTPARAM = $2D00;
File

nxllBde

Description

Optional Parameter related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_OS Constant

nxllBde.ERRBASE_OS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_OS = $2B00;
File

nxllBde

Description

Os Error not handled by Idapi

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_OTHER Constant

nxllBde.ERRBASE_OTHER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_OTHER = $3300;
File

nxllBde

Description

Miscellaneous

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_QUERY Constant

nxllBde.ERRBASE_QUERY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_QUERY = $2E00;
File

nxllBde

Description

Query related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_RC Constant

nxllBde.ERRBASE_RC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_RC = $3F00;
File

nxllBde

Description

Internal

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_REPOSITORY Constant

nxllBde.ERRBASE_REPOSITORY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_REPOSITORY = $3500;
File

nxllBde

Description

Data Repository related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_SEC Constant

nxllBde.ERRBASE_SEC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_SEC = $2900;
File

nxllBde

Description

Access Violation - Security related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_SYSTEM Constant

nxllBde.ERRBASE_SYSTEM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_SYSTEM = $2100;
File

nxllBde

Description

System related (Fatal Error)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_VERSION Constant

nxllBde.ERRBASE_VERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_VERSION = $2F00;
File

nxllBde

Description

Version Mismatch Category

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRBASE_WARNING Constant

nxllBde.ERRBASE_WARNING Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRBASE_WARNING = $3200;
File

nxllBde

Description

This is constant nxllBde.ERRBASE_WARNING.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_CAPABILITY Constant

nxllBde.ERRCAT_CAPABILITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_CAPABILITY = $30;
File

nxllBde

Description

48 Capability not supported

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_COMPATIBILITY Constant

nxllBde.ERRCAT_COMPATIBILITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_COMPATIBILITY = $34;
File

nxllBde

Description

52 Compatibility related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_CONFIG Constant

nxllBde.ERRCAT_CONFIG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_CONFIG = $31;
File

nxllBde

Description

49 System configuration error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_DATACORRUPT Constant

nxllBde.ERRCAT_DATACORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_DATACORRUPT = $23;
File

nxllBde

Description

35 Physical Data Corruption

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_DRIVER Constant

nxllBde.ERRCAT_DRIVER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_DRIVER = $3E;
File

nxllBde

Description

62 Driver related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_INTEGRITY Constant

nxllBde.ERRCAT_INTEGRITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_INTEGRITY = $26;
File

nxllBde

Description

38 Integrity Violation

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_INVALIDCONTEXT Constant

nxllBde.ERRCAT_INVALIDCONTEXT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_INVALIDCONTEXT = $2A;
File

nxllBde

Description

42 Invalid context

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_INVALIDREQ Constant

nxllBde.ERRCAT_INVALIDREQ Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_INVALIDREQ = $27;
File

nxllBde

Description

39 Invalid Request

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_IO Constant

nxllBde.ERRCAT_IO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_IO = $24;
File

nxllBde

Description

36 I/O related error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_LIMIT Constant

nxllBde.ERRCAT_LIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_LIMIT = $25;
File

nxllBde

Description

37 Resource or Limit error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_LOCKCONFLICT Constant

nxllBde.ERRCAT_LOCKCONFLICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_LOCKCONFLICT = $28;
File

nxllBde

Description

40 Locking/Contention related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_NETWORK Constant

nxllBde.ERRCAT_NETWORK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_NETWORK = $2C;
File

nxllBde

Description

44 Network related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_NEXUS Constant

nxllBde.ERRCAT_NEXUS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_NEXUS = $3C;
File

nxllBde

Description

This is constant nxllBde.ERRCAT_NEXUS.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_NONE Constant

nxllBde.ERRCAT_NONE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_NONE = 0;
File

nxllBde

Description

0 No error

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_NOTFOUND Constant

nxllBde.ERRCAT_NOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_NOTFOUND = $22;
File

nxllBde

Description

34 Object of interest Not Found

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_OPTPARAM Constant

nxllBde.ERRCAT_OPTPARAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_OPTPARAM = $2D;
File

nxllBde

Description

45 Optional parameter related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_OS Constant

nxllBde.ERRCAT_OS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_OS = $2B;
File

nxllBde

Description

43 Os Error not handled by Idapi

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_OTHER Constant

nxllBde.ERRCAT_OTHER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_OTHER = $33;
File

nxllBde

Description

51 Miscellaneous

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_QUERY Constant

nxllBde.ERRCAT_QUERY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_QUERY = $2E;
File

nxllBde

Description

46 Query related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_RC Constant

nxllBde.ERRCAT_RC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_RC = $3F;
File

nxllBde

Description

63 Internal

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_REPOSITORY Constant

nxllBde.ERRCAT_REPOSITORY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_REPOSITORY = $35;
File

nxllBde

Description

53 Data Repository related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_SECURITY Constant

nxllBde.ERRCAT_SECURITY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_SECURITY = $29;
File

nxllBde

Description

41 Access Violation - Security related

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_SYSTEM Constant

nxllBde.ERRCAT_SYSTEM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_SYSTEM = $21;
File

nxllBde

Description

33 System related (Fatal Error)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_VERSION Constant

nxllBde.ERRCAT_VERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_VERSION = $2F;
File

nxllBde

Description

47 Version Mismatch Category

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCAT_WARNING Constant

nxllBde.ERRCAT_WARNING Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCAT_WARNING = $32;
File

nxllBde

Description

50

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_ACTIVETRAN Constant

nxllBde.ERRCODE_ACTIVETRAN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_ACTIVETRAN = 16;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_ACTIVETRAN.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_BLOBMODIFIED Constant

nxllBde.ERRCODE_BLOBMODIFIED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_BLOBMODIFIED = 2;
File

nxllBde

Description

Another user modified Blob ERRCODE_UNKNOWNSQL = 3; { Unknown SQL error }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_BOF Constant

nxllBde.ERRCODE_BOF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_BOF = 1;
File

nxllBde

Description

Beginning of Virtual table

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_CHECKCONSTRAINTFAILED Constant

nxllBde.ERRCODE_CHECKCONSTRAINTFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_CHECKCONSTRAINTFAILED = 23;
File

nxllBde

Description

ERRCODE_DETAILTABLESEXIST = 15; { 0x0f Detail Tables exist ( cannot delete, rename ... ) ERRCODE_DETAILRECEXISTEMPTY = 16; { 0x10 Cannot empty because details exist ERRCODE_MASTERREFERENCEERR = 17; { 0x11 Cannot modify while adding self referencing Referential Integrity ERRCODE_DETAILTBLOPEN = 18; { 0x12 Detail Table is opened ERRCODE_DEPENDENTSMUSTBEEMPTY = 19; { 0x13 Cannot make a master a detail of another table if its details are not empty. ERRCODE_RINTREQINDEX = 20; { 0x14 Ref. integrity fields must be indexed ERRCODE_LINKEDTBLPROTECTED = 21; { 0x15 Master Table is protected ( requires password to open) ERRCODE_FIELDMULTILINKED = 22; { 0x16 Field has more than one master

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_CLIENTSLIMIT Constant

nxllBde.ERRCODE_CLIENTSLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_CLIENTSLIMIT = 14;
File

nxllBde

Description

0x0e Too many clients

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_DEADLOCK Constant

nxllBde.ERRCODE_DEADLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_DEADLOCK = 15;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_DEADLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_DETAILRECORDSEXIST Constant

nxllBde.ERRCODE_DETAILRECORDSEXIST Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_DETAILRECORDSEXIST = 6;
File

nxllBde

Description

Cannot MODIFY or DELETE this Master record ERRCODE_MASTERTBLLEVEL = 7; { Master Table Level is incorrect } ERRCODE_LOOKUPTABLEERR = 8; { Field value out of lookup tbl range } ERRCODE_LOOKUPTBLOPENERR = 9; { Lookup Table Open failed } ERRCODE_DETAILTBLOPENERR = 10; { 0x0a Detail Table Open failed } ERRCODE_MASTERTBLOPENERR = 11; { 0x0b Master Table Open failed }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_DIFFERENTTABLES Constant

nxllBde.ERRCODE_DIFFERENTTABLES Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_DIFFERENTTABLES = 36;
File

nxllBde

Description

0x24 Cannot Set Cursor of one Table to another

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_DIRNOACCESS Constant

nxllBde.ERRCODE_DIRNOACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_DIRNOACCESS = 3;
File

nxllBde

Description

No access to dir ERRCODE_FILEDELETEFAIL = 4; { File delete failed }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_ENDOFBLOB Constant

nxllBde.ERRCODE_ENDOFBLOB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_ENDOFBLOB = 7;
File

nxllBde

Description

End of Blob reached

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_EOF Constant

nxllBde.ERRCODE_EOF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_EOF = 2;
File

nxllBde

Description

End of Virtual table ERRCODE_RECMOVED = 3; { Fly-away }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FIELDISBLANK Constant

nxllBde.ERRCODE_FIELDISBLANK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FIELDISBLANK = 12;
File

nxllBde

Description

0x0c Field is blank

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FILECORRUPT Constant

nxllBde.ERRCODE_FILECORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FILECORRUPT = 2;
File

nxllBde

Description

File corrupt - other than header ERRCODE_MEMOCORRUPT = 3; { Memo file corrupted } ERRCODE_BMPCORRUPT = 4; { BitMap is corrupt (Internal error) }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FILELOCKED Constant

nxllBde.ERRCODE_FILELOCKED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FILELOCKED = 5;
File

nxllBde

Description

ERRCODE_UNLOCKFAILED = 2; ERRCODE_FILEBUSY = 3; ERRCODE_DIRBUSY = 4;

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FILENOACCESS Constant

nxllBde.ERRCODE_FILENOACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FILENOACCESS = 5;
File

nxllBde

Description

No access to file ERRCODE_ACCESSDISABLED = 6; { Access to table disabled (previous error) }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FLDLIMIT Constant

nxllBde.ERRCODE_FLDLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FLDLIMIT = 20;
File

nxllBde

Description

0x14 Too many Fields in Table Create ERRCODE_TBLLOCKLIMIT = 21; { 0x15 Too many table locks } ERRCODE_OPENBLOBLIMIT = 22; { 0x16 Too many open blobs } ERRCODE_LOCKFILELIMIT = 23; { 0x17 Lock file has grown too big } ERRCODE_OPENQRYLIMIT = 24; { 0x18 Too many open queries } ERRCODE_THREADLIMIT = 25; { 0x19 Too many threads for client } ERRCODE_BLOBLIMIT = 26; { 0x1a Too many blobs } ERRCODE_PDX50NAMELIMIT = 27; { 0x1b Pathname is too long for a Paradox 5.0 or less table } ERRCODE_ROWFETCHLIMIT = 28; { 0x1c Row fetch limit } ERRCODE_LONGNAMENOTALLOWED = 29; { 0x1d Long name is not allowed for this tableversion }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_FORIEGNKEYERR Constant

nxllBde.ERRCODE_FORIEGNKEYERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_FORIEGNKEYERR = 5;
File

nxllBde

Description

Master record missing

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_HEADERCORRUPT Constant

nxllBde.ERRCODE_HEADERCORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_HEADERCORRUPT = 1;
File

nxllBde

Description

Corrupt Header

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INDEXCORRUPT Constant

nxllBde.ERRCODE_INDEXCORRUPT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INDEXCORRUPT = 5;
File

nxllBde

Description

Index is corrupt ERRCODE_CORRUPTLOCKFILE = 6; { Corrupt lock file } ERRCODE_FAMFILEINVALID = 7; { Corrupt family file } ERRCODE_VALFILECORRUPT = 8; { Val file is missing or corrupt } ERRCODE_FOREIGNINDEX = 9; { Index is in a foreign format - import first }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INDEXEXISTS Constant

nxllBde.ERRCODE_INDEXEXISTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INDEXEXISTS = 43;
File

nxllBde

Description

0x2b Index already exists ERRCODE_INDEXOPEN = 44; { 0x2c Index is open }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INDEXLIMIT Constant

nxllBde.ERRCODE_INDEXLIMIT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INDEXLIMIT = 15;
File

nxllBde

Description

0x0f Too many indexes (also in Table Create) ERRCODE_SESSIONSLIMIT = 16; { 0x10 Too many sessions } ERRCODE_DBLIMIT = 17; { 0x11 Too many databases } ERRCODE_PASSWORDLIMIT = 18; { 0x12 Too many passwords } ERRCODE_DRIVERLIMIT = 19; { 0x13 Too many active drivers }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDALIASNAME Constant

nxllBde.ERRCODE_INVALIDALIASNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDALIASNAME = 83;
File

nxllBde

Description

0x53 invalid alias name

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDBLOBHANDLE Constant

nxllBde.ERRCODE_INVALIDBLOBHANDLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDBLOBHANDLE = 46;
File

nxllBde

Description

0x2e Invalid Blob handle (in record buffer)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDBLOBLEN Constant

nxllBde.ERRCODE_INVALIDBLOBLEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDBLOBLEN = 45;
File

nxllBde

Description

0x2d Invalid Blob Length

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDBLOBOFFSET Constant

nxllBde.ERRCODE_INVALIDBLOBOFFSET Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDBLOBOFFSET = 14;
File

nxllBde

Description

0x0e Invalid Offset into the Blob

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDBOOKMARK Constant

nxllBde.ERRCODE_INVALIDBOOKMARK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDBOOKMARK = 37;
File

nxllBde

Description

0x25 Bookmarks does not match table, etc.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDDESC Constant

nxllBde.ERRCODE_INVALIDDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDDESC = 20;
File

nxllBde

Description

0x14 Generic: invalid descriptor

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDDESCNUM Constant

nxllBde.ERRCODE_INVALIDDESCNUM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDDESCNUM = 15;
File

nxllBde

Description

0x0f Invalid descriptor number

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDDIR Constant

nxllBde.ERRCODE_INVALIDDIR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDDIR = 34;
File

nxllBde

Description

0x22 Invalid directory

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFIELDNAME Constant

nxllBde.ERRCODE_INVALIDFIELDNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFIELDNAME = 54;
File

nxllBde

Description

0x36 Invalid field name

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFILEEXTN Constant

nxllBde.ERRCODE_INVALIDFILEEXTN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFILEEXTN = 58;
File

nxllBde

Description

0x3a Invalid file extention

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFILTER Constant

nxllBde.ERRCODE_INVALIDFILTER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFILTER = 67;
File

nxllBde

Description

0x43 Invalid filter

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFLDDESC Constant

nxllBde.ERRCODE_INVALIDFLDDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFLDDESC = 17;
File

nxllBde

Description

0x11 Invalid field descriptor

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFLDTYPE Constant

nxllBde.ERRCODE_INVALIDFLDTYPE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFLDTYPE = 16;
File

nxllBde

Description

0x10 Invalid field type

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDFLDXFORM Constant

nxllBde.ERRCODE_INVALIDFLDXFORM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDFLDXFORM = 18;
File

nxllBde

Description

0x12 Invalid field transform

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDHNDL Constant

nxllBde.ERRCODE_INVALIDHNDL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDHNDL = 6;
File

nxllBde

Description

Invalid handle to the function ERRCODE_UNKNOWNTBLTYPE = 7; { Table type given not known }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDIDXDESC Constant

nxllBde.ERRCODE_INVALIDIDXDESC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDIDXDESC = 39;
File

nxllBde

Description

0x27 Invalid index descriptor

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDINDEXNAME Constant

nxllBde.ERRCODE_INVALIDINDEXNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDINDEXNAME = 38;
File

nxllBde

Description

0x26 Index/Tag Name is invalid

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDINDEXSTRUCT Constant

nxllBde.ERRCODE_INVALIDINDEXSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDINDEXSTRUCT = 21;
File

nxllBde

Description

0x15 Invalid array of indexes descriptors ERRCODE_INVALIDVCHKSTRUCT = 22; { 0x16 Invalid array of val. check descriptors } ERRCODE_INVALIDRINTSTRUCT = 23; { 0x17 Invalid array of ref. integrity descriptors } ERRCODE_INVALIDRESTRTBLORDER = 24; { 0x18 Invalid ordering of tables during restructure }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDLANGDRV Constant

nxllBde.ERRCODE_INVALIDLANGDRV Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDLANGDRV = 59;
File

nxllBde

Description

0x3b Invalid language driver ERRCODE_ALIASNOTOPEN = 60; { 0x3c Requested alias in not open } ERRCODE_INCOMPATRECSTRUCTS = 61; { 0x3d Incompatible record structures } ERRCODE_RESERVEDDOSNAME = 62; { 0x3e Reserved dos name } ERRCODE_DESTMUSTBEINDEXED = 63; { 0x3f Destination must be indexed } ERRCODE_INVALIDINDEXTYPE = 64; { 0x40 Invalid index type } ERRCODE_LANGDRVMISMATCH = 65; { 0x41 Language driver of table and index do not match }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDNAME Constant

nxllBde.ERRCODE_INVALIDNAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDNAME = 84;
File

nxllBde

Description

0x54 invalid alias name

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDPARAM Constant

nxllBde.ERRCODE_INVALIDPARAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDPARAM = 2;
File

nxllBde

Description

Generic invalid parameter ERRCODE_INVALIDFILENAME = 3; { Invalid file name } ERRCODE_NOSUCHFILE = 4; { No such file } ERRCODE_INVALIDOPTION = 5; { Invalid option for a parameter }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDPASSWORD Constant

nxllBde.ERRCODE_INVALIDPASSWORD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDPASSWORD = 31;
File

nxllBde

Description

0x1f Invalid password given ERRCODE_NOCALLBACK = 32; { 0x20 No callback function } ERRCODE_INVALIDCALLBACKBUFLEN = 33; { 0x21 Invalid callback buffer length }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDRECSTRUCT Constant

nxllBde.ERRCODE_INVALIDRECSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDRECSTRUCT = 19;
File

nxllBde

Description

0x13 Invalid record structure

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDTABLENAME Constant

nxllBde.ERRCODE_INVALIDTABLENAME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDTABLENAME = 55;
File

nxllBde

Description

0x37 Invalid table name ERRCODE_INVALIDLINKEXPR = 56; { 0x38 Invalid linked cursor expression } ERRCODE_NAMERESERVED = 57; { 0x39 Name is reserved }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDUSRPASS Constant

nxllBde.ERRCODE_INVALIDUSRPASS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDUSRPASS = 52;
File

nxllBde

Description

0x34 Bad user name or password ERRCODE_MULTILEVELCASCADE = 53; { 0x35 Multi level Cascade not supported }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_INVALIDXLATION Constant

nxllBde.ERRCODE_INVALIDXLATION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_INVALIDXLATION = 35;
File

nxllBde

Description

0x23 Translate Error - Translate DID NOT happen

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_KEYORRECDELETED Constant

nxllBde.ERRCODE_KEYORRECDELETED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_KEYORRECDELETED = 4;
File

nxllBde

Description

Record Deleted/Key Modified

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_KEYVIOL Constant

nxllBde.ERRCODE_KEYVIOL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_KEYVIOL = 1;
File

nxllBde

Description

Key violation

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_LOCKED Constant

nxllBde.ERRCODE_LOCKED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_LOCKED = 1;
File

nxllBde

Description

ERRCAT_LOCKCONFLICT

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_LOCKTIMEOUT Constant

nxllBde.ERRCODE_LOCKTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_LOCKTIMEOUT = 9;
File

nxllBde

Description

ERRCODE_DIRLOCKED = 6; ERRCODE_ALREADYLOCKED = 7; ERRCODE_NOTLOCKED = 8;

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_MAXVALERR Constant

nxllBde.ERRCODE_MAXVALERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_MAXVALERR = 3;
File

nxllBde

Description

Max val check failed

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_MINVALERR Constant

nxllBde.ERRCODE_MINVALERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_MINVALERR = 2;
File

nxllBde

Description

Min val check failed

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NA Constant

nxllBde.ERRCODE_NA Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NA = 4;
File

nxllBde

Description

Operation not applicable

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NAMENOTUNIQUE Constant

nxllBde.ERRCODE_NAMENOTUNIQUE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NAMENOTUNIQUE = 25;
File

nxllBde

Description

0x19 Name not unique in this context ERRCODE_INDEXNAMEREQUIRED = 26; { 0x1a Index name required } ERRCODE_INVALIDSESHANDLE = 27; { 0x1b Invalid ses handle } ERRCODE_INVALIDRESTROP = 28; { 0x1c Invalid restructure operation } ERRCODE_UNKNOWNDRIVER = 29; { 0x1d Driver not known to system }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NEEDEXCLACCESS Constant

nxllBde.ERRCODE_NEEDEXCLACCESS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NEEDEXCLACCESS = 13;
File

nxllBde

Description

0x0d

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOACTIVETRAN Constant

nxllBde.ERRCODE_NOACTIVETRAN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOACTIVETRAN = 17;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NOACTIVETRAN.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOASSOCINDEX Constant

nxllBde.ERRCODE_NOASSOCINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOASSOCINDEX = 12;
File

nxllBde

Description

0x0c No index associated with the cursor ERRCODE_HASOPENCURSORS = 13; { 0x0d Has open cursors } ERRCODE_NOTABLESUPPORT = 14; { 0x0e Op cannot be done on this table } ERRCODE_INDEXREADONLY = 15; { 0x0f Index is read only } ERRCODE_NOUNIQUERECS = 16; { 0x10 Records are not unique } ERRCODE_NOTCURSESSION = 17; { 0x11 Not the current/active session } ERRCODE_INVALIDKEYWORD = 18; { 0x12 Invalid use of keyword. } ERRCODE_CONNECTINUSE = 19; { 0x13 Connection in use } ERRCODE_CONNECTNOTSHARED = 20; { 0x14 Passthru SQL connection not share }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOCURRREC Constant

nxllBde.ERRCODE_NOCURRREC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOCURRREC = 5;
File

nxllBde

Description

No current record

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOMEMORY Constant

nxllBde.ERRCODE_NOMEMORY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOMEMORY = 1;
File

nxllBde

Description

Not enough Memory for this op ERRCODE_NOFILEHANDLES = 2; { Not enough File handles } ERRCODE_NODISKSPACE = 3; { Not enough Disk space } ERRCODE_NOTEMPTBLSPACE = 4; { Temporary Table resource limit } ERRCODE_RECTOOBIG = 5; { Too big a record size for table } ERRCODE_CURSORLIMIT = 6; { Too many open cursors }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NONE Constant

nxllBde.ERRCODE_NONE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NONE = 0;
File

nxllBde

Description

ERRCAT_NONE (0)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOSERVERSW Constant

nxllBde.ERRCODE_NOSERVERSW Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOSERVERSW = 106;
File

nxllBde

Description

0x6a Server software not running the workstation/server

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOSUCHFILTER Constant

nxllBde.ERRCODE_NOSUCHFILTER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOSUCHFILTER = 66;
File

nxllBde

Description

0x42 Filter handle is invalid

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOSUCHINDEX Constant

nxllBde.ERRCODE_NOSUCHINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOSUCHINDEX = 13;
File

nxllBde

Description

0x0d Index does not exist

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOSUCHTABLE Constant

nxllBde.ERRCODE_NOSUCHTABLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOSUCHTABLE = 40;
File

nxllBde

Description

0x28 No such table ERRCODE_USECOUNT = 41; { 0x29 Table has too many users } ERRCODE_INVALIDKEY = 42; { 0x2a Key does not pass filter condition }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOTABLOB Constant

nxllBde.ERRCODE_NOTABLOB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOTABLOB = 1;
File

nxllBde

Description

Field is not a blob ERRCODE_BLOBOPENED = 2; { Blob already opened } ERRCODE_BLOBNOTOPENED = 3; { Blob not opened }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOTINDEXED Constant

nxllBde.ERRCODE_NOTINDEXED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOTINDEXED = 5;
File

nxllBde

Description

Table is not indexed ERRCODE_NOTINITIALIZED = 6; { Engine not initialized } ERRCODE_MULTIPLEINIT = 7; { Attempt to re-initialize engine }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOTSAMESESSION Constant

nxllBde.ERRCODE_NOTSAMESESSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOTSAMESESSION = 8;
File

nxllBde

Description

Attempt to mix objs from diff ses ERRCODE_PDXDRIVERNOTACTIVE = 9; { Paradox driver not active } ERRCODE_DRIVERNOTLOADED = 10; { 0x0a Driver not loaded }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOTSUFFTABLERIGHTS Constant

nxllBde.ERRCODE_NOTSUFFTABLERIGHTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOTSUFFTABLERIGHTS = 2;
File

nxllBde

Description

Not sufficient table rights for operation ERRCODE_NOTSUFFFAMILYRIGHTS = 3; { Not sufficient family rights for operation } ERRCODE_READONLYDIR = 4; { Is a read-only directory }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NOTSUPPORTED Constant

nxllBde.ERRCODE_NOTSUPPORTED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NOTSUPPORTED = 1;
File

nxllBde

Description

Capability not supported ERRCODE_NIY = 2; { Not Implemented Yet } ERRCODE_TABLESQL = 3; { Cannot access SQL replica } ERRCODE_SEARCHCOLREQD = 4; { Searchable (Non-blob column) required } ERRCODE_NOMULTCONNECT = 5; { Multiple connections not supported } ERRCODE_NODBASEEXPR = 6; { Full dBASE Expressions not supported }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADBLOCKNR Constant

nxllBde.ERRCODE_NX_BADBLOCKNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADBLOCKNR = $31;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADBLOCKNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADDATABLOCK Constant

nxllBde.ERRCODE_NX_BADDATABLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADDATABLOCK = $35;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADDATABLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADHEAPBLOCK Constant

nxllBde.ERRCODE_NX_BADHEAPBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADHEAPBLOCK = $38;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADHEAPBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADINDEX Constant

nxllBde.ERRCODE_NX_BADINDEX Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADINDEX = $41;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADINDEX.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADINXBLOCK Constant

nxllBde.ERRCODE_NX_BADINXBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADINXBLOCK = $40;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADINXBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADREFNR Constant

nxllBde.ERRCODE_NX_BADREFNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADREFNR = $34;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADREFNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADSTREAMBLOCK Constant

nxllBde.ERRCODE_NX_BADSTREAMBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADSTREAMBLOCK = $3D;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BADSTREAMBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BADSTRUCT Constant

nxllBde.ERRCODE_NX_BADSTRUCT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BADSTRUCT = $00;
File

nxllBde

Description

DBIERR_REPOSITORYCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYCORRUPT); DBIERR_INFOBLOBCORRUPT = (ERRBASE_REPOSITORY + ERRCODE_INFOBLOBCORRUPT); DBIERR_SCHEMACORRUPT = (ERRBASE_REPOSITORY + ERRCODE_SCHEMACORRUPT); DBIERR_ATTRTYPEEXISTS = (ERRBASE_REPOSITORY + ERRCODE_ATTRTYPEEXISTS); DBIERR_INVALIDOBJTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDOBJTYPE); DBIERR_INVALIDRELATIONTYPE = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRELATIONTYPE); DBIERR_VIEWEXISTS = (ERRBASE_REPOSITORY + ERRCODE_VIEWEXISTS); DBIERR_NOSUCHVIEW = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHVIEW); DBIERR_INVALIDRECCONSTRAINT = (ERRBASE_REPOSITORY + ERRCODE_INVALIDRECCONSTRAINT); DBIERR_LDBCONNECTION = (ERRBASE_REPOSITORY + ERRCODE_LDBCONNECTION); DBIERR_REPOSITORYEXISTS = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYEXISTS); DBIERR_NOSUCHREPOSITORY = (ERRBASE_REPOSITORY + ERRCODE_NOSUCHREPOSITORY); DBIERR_REPOSITORYDBMISSING = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYDBMISSING); DBIERR_REPOSITORYOUTOFDATE = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYOUTOFDATE); DBIERR_REPOSITORYVERSION = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYVERSION); DBIERR_REPOSITORYNAME = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYNAME); DBIERR_DEPENDENTOBJECTS = (ERRBASE_REPOSITORY + ERRCODE_DEPENDENTOBJECTS); DBIERR_RELATIONLIMIT = (ERRBASE_REPOSITORY + ERRCODE_RELATIONLIMIT); DBIERR_RELATIONSHIPSEXIST = (ERRBASE_REPOSITORY + ERRCODE_RELATIONSHIPSEXIST); DBIERR_EXCHANGEFILECORRUPT = (ERRBASE_REPOSITORY + ERRCODE_EXCHANGEFILECORRUPT); DBIERR_EXCHANGEFILEVERSION = (ERRBASE_REPOSITORY + ERRCODE_EXCHANGEFILEVERSION); DBIERR_TYPEMISMATCH = (ERRBASE_REPOSITORY + ERRCODE_TYPEMISMATCH); DBIERR_OBJECTEXISTS = (ERRBASE_REPOSITORY + ERRCODE_OBJECTEXISTS); DBIERR_REPOSITORYACCESS = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYACCESS); DBIERR_REPOSITORYCREATE = (ERRBASE_REPOSITORY + ERRCODE_REPOSITORYCREATE); DBIERR_DATABASEOPENFAILED = (ERRBASE_REPOSITORY + ERRCODE_DATABASEOPENFAILED);

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_BLOBTOOBIG Constant

nxllBde.ERRCODE_NX_BLOBTOOBIG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_BLOBTOOBIG = $82;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_BLOBTOOBIG.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_CLOSEFAILED Constant

nxllBde.ERRCODE_NX_CLOSEFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_CLOSEFAILED = $03;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_CLOSEFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_COPYFILE Constant

nxllBde.ERRCODE_NX_COPYFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_COPYFILE = $20;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_COPYFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_CORRUPTTRANS Constant

nxllBde.ERRCODE_NX_CORRUPTTRANS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_CORRUPTTRANS = $53;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_CORRUPTTRANS.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_DELETEFILE Constant

nxllBde.ERRCODE_NX_DELETEFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_DELETEFILE = $21;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_DELETEFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_DICT_DUPAUTOINC Constant

nxllBde.ERRCODE_NX_DICT_DUPAUTOINC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_DICT_DUPAUTOINC = $8D;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_DICT_DUPAUTOINC.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_DICT_DUPRECREV Constant

nxllBde.ERRCODE_NX_DICT_DUPRECREV Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_DICT_DUPRECREV = $92;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_DICT_DUPRECREV.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_DICT_OBJINUSE Constant

nxllBde.ERRCODE_NX_DICT_OBJINUSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_DICT_OBJINUSE = $8E;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_DICT_OBJINUSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_DICT_READONLY Constant

nxllBde.ERRCODE_NX_DICT_READONLY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_DICT_READONLY = $8C;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_DICT_READONLY.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_FILEBLOBCLOSE Constant

nxllBde.ERRCODE_NX_FILEBLOBCLOSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_FILEBLOBCLOSE = $52;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_FILEBLOBCLOSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_FILEBLOBOPEN Constant

nxllBde.ERRCODE_NX_FILEBLOBOPEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_FILEBLOBOPEN = $50;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_FILEBLOBOPEN.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_FILEBLOBREAD Constant

nxllBde.ERRCODE_NX_FILEBLOBREAD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_FILEBLOBREAD = $51;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_FILEBLOBREAD.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_FILTERTIMEOUT Constant

nxllBde.ERRCODE_NX_FILTERTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_FILTERTIMEOUT = $54;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_FILTERTIMEOUT.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_GENERALTIMEOUT Constant

nxllBde.ERRCODE_NX_GENERALTIMEOUT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_GENERALTIMEOUT = $65;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_GENERALTIMEOUT.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_INCOMPATDICT Constant

nxllBde.ERRCODE_NX_INCOMPATDICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_INCOMPATDICT = $80;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_INCOMPATDICT.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_INCOMPATHEADER Constant

nxllBde.ERRCODE_NX_INCOMPATHEADER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_INCOMPATHEADER = $83;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_INCOMPATHEADER.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_INCOMPATSTREAM Constant

nxllBde.ERRCODE_NX_INCOMPATSTREAM Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_INCOMPATSTREAM = $8A;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_INCOMPATSTREAM.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_INDEXNOTEMPTY Constant

nxllBde.ERRCODE_NX_INDEXNOTEMPTY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_INDEXNOTEMPTY = $97;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_INDEXNOTEMPTY.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_INVALIDSEGNR Constant

nxllBde.ERRCODE_NX_INVALIDSEGNR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_INVALIDSEGNR = $84;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_INVALIDSEGNR.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_KEYFILTERED_NONE Constant

nxllBde.ERRCODE_NX_KEYFILTERED_NONE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_KEYFILTERED_NONE = 1;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_KEYFILTERED_NONE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_LICENSE_EXPIRED Constant

nxllBde.ERRCODE_NX_LICENSE_EXPIRED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_LICENSE_EXPIRED = $96;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_LICENSE_EXPIRED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_LITE Constant

nxllBde.ERRCODE_NX_LITE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_LITE = $FE;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_LITE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_MAXKEYSIZE Constant

nxllBde.ERRCODE_NX_MAXKEYSIZE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_MAXKEYSIZE = $86;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_MAXKEYSIZE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_MAXRECORDSIZE Constant

nxllBde.ERRCODE_NX_MAXRECORDSIZE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_MAXRECORDSIZE = $87;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_MAXRECORDSIZE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_NOSESSIONSE Constant

nxllBde.ERRCODE_NX_NOSESSIONSE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_NOSESSIONSE = $69;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_NOSESSIONSE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_RECOVERFAILED Constant

nxllBde.ERRCODE_NX_RECOVERFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_RECOVERFAILED = $95;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_RECOVERFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_REGISTERFHAF Constant

nxllBde.ERRCODE_NX_REGISTERFHAF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_REGISTERFHAF = $36;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_REGISTERFHAF.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_RENAMEFILE Constant

nxllBde.ERRCODE_NX_RENAMEFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_RENAMEFILE = $22;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_RENAMEFILE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_SAMEFOLDER Constant

nxllBde.ERRCODE_NX_SAMEFOLDER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_SAMEFOLDER = $94;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_SAMEFOLDER.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_SAMETABLE Constant

nxllBde.ERRCODE_NX_SAMETABLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_SAMETABLE = $81;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_SAMETABLE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_SEGMENTDELETED Constant

nxllBde.ERRCODE_NX_SEGMENTDELETED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_SEGMENTDELETED = $85;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_SEGMENTDELETED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_SERVERNAMENOTSET Constant

nxllBde.ERRCODE_NX_SERVERNAMENOTSET Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_SERVERNAMENOTSET = $91;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_SERVERNAMENOTSET.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_SQLSIGNAL Constant

nxllBde.ERRCODE_NX_SQLSIGNAL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_SQLSIGNAL = $93;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_SQLSIGNAL.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_TABLEVERSION Constant

nxllBde.ERRCODE_NX_TABLEVERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_TABLEVERSION = $37;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_TABLEVERSION.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_TRIAL Constant

nxllBde.ERRCODE_NX_TRIAL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_TRIAL = $FF;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_TRIAL.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_TS_FULL Constant

nxllBde.ERRCODE_NX_TS_FULL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_TS_FULL = $89;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_TS_FULL.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_TS_INVALIDBLOCK Constant

nxllBde.ERRCODE_NX_TS_INVALIDBLOCK Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_TS_INVALIDBLOCK = $88;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_TS_INVALIDBLOCK.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNKNOWN Constant

nxllBde.ERRCODE_NX_UNKNOWN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNKNOWN = $A0;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNKNOWN.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNKNOWNEXCP Constant

nxllBde.ERRCODE_NX_UNKNOWNEXCP Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNKNOWNEXCP = $A1;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNKNOWNEXCP.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNKNOWNMSG Constant

nxllBde.ERRCODE_NX_UNKNOWNMSG Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNKNOWNMSG = $A2;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNKNOWNMSG.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNSUPDICTDESCR Constant

nxllBde.ERRCODE_NX_UNSUPDICTDESCR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNSUPDICTDESCR = $8B;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNSUPDICTDESCR.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNSUPHEADER Constant

nxllBde.ERRCODE_NX_UNSUPHEADER Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNSUPHEADER = $90;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNSUPHEADER.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_NX_UNSUPSUBENGINE Constant

nxllBde.ERRCODE_NX_UNSUPSUBENGINE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_NX_UNSUPSUBENGINE = $8F;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_NX_UNSUPSUBENGINE.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_OBJNOTFOUND Constant

nxllBde.ERRCODE_OBJNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_OBJNOTFOUND = 8;
File

nxllBde

Description

Generic Not found ERRCODE_FMLMEMBERNOTFOUND = 9; { Family member not found } ERRCODE_BLOBFILEMISSING = 10; { 0x0a Blob file for table is missing } ERRCODE_LDNOTFOUND = 11; { 0x0b Language driver not found }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_OPTRECLOCKFAILED Constant

nxllBde.ERRCODE_OPTRECLOCKFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_OPTRECLOCKFAILED = 19;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_OPTRECLOCKFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_OPTRECLOCKRECDEL Constant

nxllBde.ERRCODE_OPTRECLOCKRECDEL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_OPTRECLOCKRECDEL = 20;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_OPTRECLOCKRECDEL.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_OSUNKNOWN Constant

nxllBde.ERRCODE_OSUNKNOWN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_OSUNKNOWN = 39;
File

nxllBde

Description

0x27 Unkown | illegal error from rtl

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_OUTOFRANGE Constant

nxllBde.ERRCODE_OUTOFRANGE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_OUTOFRANGE = 1;
File

nxllBde

Description

Number out of range (e.g field no)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_READERR Constant

nxllBde.ERRCODE_READERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_READERR = 1;
File

nxllBde

Description

Read failure (not expected)

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_READONLYDB Constant

nxllBde.ERRCODE_READONLYDB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_READONLYDB = 5;
File

nxllBde

Description

Database is read-only

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_READONLYFLD Constant

nxllBde.ERRCODE_READONLYFLD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_READONLYFLD = 6;
File

nxllBde

Description

Trying to modify read-only field

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_RECGROUPCONFLICT Constant

nxllBde.ERRCODE_RECGROUPCONFLICT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_RECGROUPCONFLICT = 14;
File

nxllBde

Description

0x0e

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_RECLOCKFAILED Constant

nxllBde.ERRCODE_RECLOCKFAILED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_RECLOCKFAILED = 18;
File

nxllBde

Description

This is constant nxllBde.ERRCODE_RECLOCKFAILED.

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_RECNOTFOUND Constant

nxllBde.ERRCODE_RECNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_RECNOTFOUND = 6;
File

nxllBde

Description

Record was not found

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_REENTERED Constant

nxllBde.ERRCODE_REENTERED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_REENTERED = 7;
File

nxllBde

Description

System has been illegally re-entered ERRCODE_CANTFINDIDAPI = 8; { Cannot locate IDAPIxx.DLL } ERRCODE_CANTLOADIDAPI = 9; { Cannot load IDAPIxx.DLL } ERRCODE_CANTLOADLIBRARY = 10; { Cannot load a service DLL } ERRCODE_TEMPFILEERR = 11; { Cannot create or open temporary file } ERRCODE_MULTIPLEIDAPI = 12; { Trying to load multiple IDAPIxx.DLL }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_REQDERR Constant

nxllBde.ERRCODE_REQDERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_REQDERR = 4;
File

nxllBde

Description

Field value required

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_SERVERCOMMLOST Constant

nxllBde.ERRCODE_SERVERCOMMLOST Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_SERVERCOMMLOST = 12;
File

nxllBde

Description

0x0c Lost Communication with IDAPI server ERRCODE_SQLSERVERNOTFOUND = 13; { 0x0d SQL Server not found }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_SERVERNOTFOUND Constant

nxllBde.ERRCODE_SERVERNOTFOUND Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_SERVERNOTFOUND = 14;
File

nxllBde

Description

0x0e SQL Server not found

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_SERVERVERSION Constant

nxllBde.ERRCODE_SERVERVERSION Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_SERVERVERSION = 7;
File

nxllBde

Description

Server is incompatible version

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TABLEEXISTS Constant

nxllBde.ERRCODE_TABLEEXISTS Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TABLEEXISTS = 4;
File

nxllBde

Description

Table already exsits ERRCODE_PDX10TABLE = 5; { Paradox 1.0 tables not supported }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TABLEFULL Constant

nxllBde.ERRCODE_TABLEFULL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TABLEFULL = 7;
File

nxllBde

Description

Table is full ERRCODE_WSSESLIMIT = 8; { Too many sessions from this WS } ERRCODE_SERNUMLIMIT = 9; { Serial number limit (paradox) } ERRCODE_INTERNALLIMIT = 10; { 0x0a Some internal limit (see context) } ERRCODE_OPENTBLLIMIT = 11; { 0x0b Too many open tables } ERRCODE_TBLCURSORLIMIT = 12; { 0x0c Too many cursors per table } ERRCODE_RECLOCKLIMIT = 13; { 0x0d Too many record locks on table }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TABLELEVEL Constant

nxllBde.ERRCODE_TABLELEVEL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TABLELEVEL = 8;
File

nxllBde

Description

Higher table level required

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TABLEOPEN Constant

nxllBde.ERRCODE_TABLEOPEN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TABLEOPEN = 47;
File

nxllBde

Description

0x2f Table is open ERRCODE_NEEDRESTRUCTURE = 48; { 0x30 Need to do (hard) restructure } ERRCODE_INVALIDMODE = 49; { 0x31 Invalid mode } ERRCODE_CANNOTCLOSE = 50; { 0x32 Cannot close index } ERRCODE_ACTIVEINDEX = 51; { 0x33 Index is being used to order tbl }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TABLEREADONLY Constant

nxllBde.ERRCODE_TABLEREADONLY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TABLEREADONLY = 11;
File

nxllBde

Description

0x0b Table is read only

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_TBLENCRYPTED Constant

nxllBde.ERRCODE_TBLENCRYPTED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_TBLENCRYPTED = 7;
File

nxllBde

Description

Table is encrypted (dBASE only) ERRCODE_NOTSUFFSQLRIGHTS = 8; { Not sufficient sql rights for operation }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_UNKNOWNDB Constant

nxllBde.ERRCODE_UNKNOWNDB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_UNKNOWNDB = 30;
File

nxllBde

Description

0x1e Unknown db

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_UNKNOWNFILE Constant

nxllBde.ERRCODE_UNKNOWNFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_UNKNOWNFILE = 8;
File

nxllBde

Description

Dont know how to open file ERRCODE_PRIMARYKEYREDEFINE = 9; { Cannot redefine primary key } ERRCODE_INVALIDRINTDESCNUM = 10; { 0x0a Cannot change this RINTDesc } ERRCODE_KEYFLDTYPEMISMATCH = 11; { 0x0b Foreign & Primary Key Mismatch } ERRCODE_INVALIDMODIFYREQUEST = 12; { 0x0c Invalid modify request }

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_UPDATEABORT Constant

nxllBde.ERRCODE_UPDATEABORT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_UPDATEABORT = 6;
File

nxllBde

Description

Update operation aborted

Group

Constants

Links
nxllBde, Constants


nxllBde.ERRCODE_WRITEERR Constant

nxllBde.ERRCODE_WRITEERR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
ERRCODE_WRITEERR = 2;
File

nxllBde

Description

Write failure (not expected)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldADT Constant

nxllBde.fldADT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldADT = 20;
File

nxllBde

Description

Abstract datatype (structure)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldARRAY Constant

nxllBde.fldARRAY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldARRAY = 21;
File

nxllBde

Description

Array field type

Group

Constants

Links
nxllBde, Constants


nxllBde.fldBCD Constant

nxllBde.fldBCD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldBCD = 8;
File

nxllBde

Description

BCD

Group

Constants

Links
nxllBde, Constants


nxllBde.fldBLOB Constant

nxllBde.fldBLOB Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldBLOB = 3;
File

nxllBde

Description

Blob

Group

Constants

Links
nxllBde, Constants


nxllBde.fldBOOL Constant

nxllBde.fldBOOL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldBOOL = 4;
File

nxllBde

Description

Boolean (16 bit)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldBYTES Constant

nxllBde.fldBYTES Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldBYTES = 9;
File

nxllBde

Description

Fixed number of bytes

Group

Constants

Links
nxllBde, Constants


nxllBde.fldCURSOR Constant

nxllBde.fldCURSOR Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldCURSOR = 17;
File

nxllBde

Description

For Oracle Cursor type

Group

Constants

Links
nxllBde, Constants


nxllBde.fldDATE Constant

nxllBde.fldDATE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldDATE = 2;
File

nxllBde

Description

Date (32 bit)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldDATETIME Constant

nxllBde.fldDATETIME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldDATETIME = 24;
File

nxllBde

Description

Datetime structure for DBExpress

Group

Constants

Links
nxllBde, Constants


nxllBde.fldDATETIMEOFFSET Constant

nxllBde.fldDATETIMEOFFSET Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldDATETIMEOFFSET = 36;
File

nxllBde

Description

DatetimeOffset structure for DBExpress

Group

Constants

Links
nxllBde, Constants


nxllBde.fldFLOAT Constant

nxllBde.fldFLOAT Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldFLOAT = 7;
File

nxllBde

Description

64 bit floating point

Group

Constants

Links
nxllBde, Constants


nxllBde.fldFLOATIEEE Constant

nxllBde.fldFLOATIEEE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldFLOATIEEE = 14;
File

nxllBde

Description

80-bit IEEE float

Group

Constants

Links
nxllBde, Constants


nxllBde.fldFMTBCD Constant

nxllBde.fldFMTBCD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldFMTBCD = 25;
File

nxllBde

Description

BCD Variant type: required by Midas, same as BCD for DBExpress

Group

Constants

Links
nxllBde, Constants


nxllBde.fldINT16 Constant

nxllBde.fldINT16 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldINT16 = 5;
File

nxllBde

Description

16 bit signed number

Group

Constants

Links
nxllBde, Constants


nxllBde.fldINT32 Constant

nxllBde.fldINT32 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldINT32 = 6;
File

nxllBde

Description

32 bit signed number

Group

Constants

Links
nxllBde, Constants


nxllBde.fldINT64 Constant

nxllBde.fldINT64 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldINT64 = 18;
File

nxllBde

Description

64 bit signed number

Group

Constants

Links
nxllBde, Constants


nxllBde.fldINT8 Constant

nxllBde.fldINT8 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldINT8 = 28;
File

nxllBde

Description

8 bit signed number as defined in alctypes.h

Group

Constants

Links
nxllBde, Constants


nxllBde.fldLOCKINFO Constant

nxllBde.fldLOCKINFO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldLOCKINFO = 16;
File

nxllBde

Description

Look for LOCKINFO typedef

Group

Constants

Links
nxllBde, Constants


nxllBde.fldREF Constant

nxllBde.fldREF Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldREF = 22;
File

nxllBde

Description

Reference to ADT

Group

Constants

Links
nxllBde, Constants


nxllBde.fldSINGLE Constant

nxllBde.fldSINGLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldSINGLE = 27;
File

nxllBde

Description

32 bit floating point

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstACCOLEOBJ Constant

nxllBde.fldstACCOLEOBJ Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstACCOLEOBJ = 30;
File

nxllBde

Description

Access OLE object

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstAUTOINC Constant

nxllBde.fldstAUTOINC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstAUTOINC = 29;
File

nxllBde

Description

fldINT32 subtype

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstBFILE Constant

nxllBde.fldstBFILE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstBFILE = 36;
File

nxllBde

Description

BFILE

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstBINARY Constant

nxllBde.fldstBINARY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstBINARY = 23;
File

nxllBde

Description

Binary data

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstDBSOLEOBJ Constant

nxllBde.fldstDBSOLEOBJ Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstDBSOLEOBJ = 27;
File

nxllBde

Description

dBASE OLE object

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstFIXED Constant

nxllBde.fldstFIXED Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstFIXED = 31;
File

nxllBde

Description

CHAR type

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstFMTMEMO Constant

nxllBde.fldstFMTMEMO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstFMTMEMO = 24;
File

nxllBde

Description

Formatted Text

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstGRAPHIC Constant

nxllBde.fldstGRAPHIC Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstGRAPHIC = 26;
File

nxllBde

Description

Graphics object

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstGUID Constant

nxllBde.fldstGUID Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstGUID = 38;
File

nxllBde

Description

GUID

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstHBINARY Constant

nxllBde.fldstHBINARY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstHBINARY = 34;
File

nxllBde

Description

BLOB

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstHMEMO Constant

nxllBde.fldstHMEMO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstHMEMO = 33;
File

nxllBde

Description

CLOB

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstMEMO Constant

nxllBde.fldstMEMO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstMEMO = 22;
File

nxllBde

Description

Text Memo

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstMONEY Constant

nxllBde.fldstMONEY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstMONEY = 21;
File

nxllBde

Description

Money

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstOLEOBJ Constant

nxllBde.fldstOLEOBJ Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstOLEOBJ = 25;
File

nxllBde

Description

OLE object (Paradox)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstORAINTERVAL Constant

nxllBde.fldstORAINTERVAL Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstORAINTERVAL = 40;
File

nxllBde

Description

ORACLE INTERVAL

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstORATIMESTAMP Constant

nxllBde.fldstORATIMESTAMP Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstORATIMESTAMP = 39;
File

nxllBde

Description

ORACLE TIMESTAMP

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstPASSWORD Constant

nxllBde.fldstPASSWORD Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstPASSWORD = 1;
File

nxllBde

Description

Password

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstTYPEDBINARY Constant

nxllBde.fldstTYPEDBINARY Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstTYPEDBINARY = 28;
File

nxllBde

Description

Typed Binary data

Group

Constants

Links
nxllBde, Constants


nxllBde.fldstWIDEMEMO Constant

nxllBde.fldstWIDEMEMO Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldstWIDEMEMO = 32;
File

nxllBde

Description

WideString Memo

Group

Constants

Links
nxllBde, Constants


nxllBde.fldTABLE Constant

nxllBde.fldTABLE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldTABLE = 23;
File

nxllBde

Description

Nested table (reference)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldTIME Constant

nxllBde.fldTIME Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldTIME = 10;
File

nxllBde

Description

Time (32 bit)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldTIMESTAMP Constant

nxllBde.fldTIMESTAMP Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldTIMESTAMP = 11;
File

nxllBde

Description

Time-stamp (64 bit)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUINT16 Constant

nxllBde.fldUINT16 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUINT16 = 12;
File

nxllBde

Description

Unsigned 16 bit integer

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUINT32 Constant

nxllBde.fldUINT32 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUINT32 = 13;
File

nxllBde

Description

Unsigned 32 bit integer

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUINT64 Constant

nxllBde.fldUINT64 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUINT64 = 19;
File

nxllBde

Description

Unsigned 64 bit integer

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUINT8 Constant

nxllBde.fldUINT8 Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUINT8 = 29;
File

nxllBde

Description

Unsigned 8 bit integer (Byte) as defined in alctypes.h

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUNICODE Constant

nxllBde.fldUNICODE Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUNICODE = $1007;
File

nxllBde

Description

Unicode

Group

Constants

Links
nxllBde, Constants


nxllBde.fldUNKNOWN Constant

nxllBde.fldUNKNOWN Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldUNKNOWN = 0;
File

nxllBde

Description

Field Types (Logical)

Group

Constants

Links
nxllBde, Constants


nxllBde.fldVARBYTES Constant

nxllBde.fldVARBYTES Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldVARBYTES = 15;
File

nxllBde

Description

Length prefixed var bytes

Group

Constants

Links
nxllBde, Constants


nxllBde.fldWIDESTRING Constant

nxllBde.fldWIDESTRING Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldWIDESTRING = 26;
File

nxllBde

Description

UCS2 null terminated string

Group

Constants

Links
nxllBde, Constants


nxllBde.fldZSTRING Constant

nxllBde.fldZSTRING Constant
nxllBde Constants Send Feedback
Syntax
Delphi
fldZSTRING = 1;
File

nxllBde

Description

Null terminated string

Group

Constants

Links
nxllBde, Constants


nxllBde.MAXLOGFLDTYPES Constant

nxllBde.MAXLOGFLDTYPES Constant
nxllBde Constants Send Feedback
Syntax
Delphi
MAXLOGFLDTYPES = 27;
File

nxllBde

Description

Number of logical fieldtypes

Group

Constants

Links
nxllBde, Constants


nxllBdeStrings Namespace

nxllBdeStrings Namespace
Constants Functions Legend Topics Send Feedback

This is namespace nxllBdeStrings.

Constants
Name | Description
rsDBIERR_ACTIVETRAN | This is constant nxllBdeStrings.rsDBIERR_ACTIVETRAN.
rsDBIERR_BLOBERR | rs11521 = 'Optional parameter is required.'; rs11522 = 'Invalid optional parameter.'; rs11777 = 'obsolete'; rs11778 = 'obsolete'; rs11779 = 'Ambiguous use of ! (inclusion operator).'; rs11780 = 'obsolete'; rs11781 = 'obsolete'; rs11782 = 'A SET operation cannot be included in its own grouping.'; rs11783 = 'Only numeric and date/time fields can be averaged.'; rs11784 = 'Invalid expression.'; rs11785 = 'Invalid OR expression.'; rs11786 = 'obsolete'; rs11787 = 'bitmap'; rs11788 = 'CALC expression cannot be used in INSERT, DELETE, CHANGETO and SET rows.'; rs11789 = 'Type error in CALC expression.'; rs11790 = 'CHANGETO can be used in only one query... more
rsDBIERR_BLOBMODIFIED | rs12290 = 'Not implemented yet.'; rs12291 = 'SQL replicas not supported.'; rs12292 = 'Non-blob column in table required to perform operation.'; rs12293 = 'Multiple connections not supported.'; rs12294 = 'Full dBASE expressions not supported.'; rs12545 = 'Invalid database alias specification.'; rs12546 = 'Unknown database type.'; rs12547 = 'Corrupt system configuration file.'; rs12548 = 'Network type unknown.'; rs12549 = 'Not on the network.'; rs12550 = 'Invalid configuration parameter.'; rs12801 = 'Object implicitly dropped.'; rs12802 = 'Object may be truncated.'; rs12803 = 'Object implicitly modified.'; rs12804 = 'Should field constraints be checked?'; rs12805 = 'Validity check field modified.'; rs12806 = 'Table level... more
rsDBIERR_BOF | rs8456 = 'Cannot locate IDAPI32 .DLL.'; rs8457 = 'Cannot load IDAPI32 .DLL.'; rs8458 = 'Cannot load an IDAPI service library.'; rs8459 = 'Cannot create or open temporary file.';
rsDBIERR_CHECKCONSTRAINTFAILED | rs9741 = 'Link to master table already defined.'; rs9742 = 'Master table is open.'; rs9743 = 'Detail table(s) exist.'; rs9744 = 'Master has detail records. Cannot empty it.'; rs9745 = 'Self referencing referential integrity must be entered one at a time with no other changes to the table'; rs9746 = 'Detail table is open.'; rs9747 = 'Cannot make this master a detail of another table if its details are not empty.'; rs9748 = 'Referential integrity fields must be indexed.'; rs9749 = 'A table linked by referential integrity requires password to open.'; rs9750 = 'Field(s) linked to more than one... more
rsDBIERR_CLIENTSLIMIT | rs9480 = 'Too many sessions from this workstation.'; rs9481 = 'Serial number limit (Paradox).'; rs9482 = 'Some internal limit (see context).'; rs9483 = 'Too many open tables.'; rs9484 = 'Too many cursors per table.'; rs9485 = 'Too many record locks on table.';
rsDBIERR_DEADLOCK | This is constant nxllBdeStrings.rsDBIERR_DEADLOCK.
rsDBIERR_DETAILRECORDSEXIST | This is constant nxllBdeStrings.rsDBIERR_DETAILRECORDSEXIST.
rsDBIERR_DIFFERENTTABLES | This is constant nxllBdeStrings.rsDBIERR_DIFFERENTTABLES.
rsDBIERR_DIRNOACCESS | This is constant nxllBdeStrings.rsDBIERR_DIRNOACCESS.
rsDBIERR_ENDOFBLOB | This is constant nxllBdeStrings.rsDBIERR_ENDOFBLOB.
rsDBIERR_EOF | This is constant nxllBdeStrings.rsDBIERR_EOF.
rsDBIERR_FIELDISBLANK | rs9735 = 'Master table level is incorrect.'; rs9736 = 'Field value out of lookup table range.'; rs9737 = 'Lookup Table Open operation failed.'; rs9738 = 'Detail Table Open operation failed.'; rs9739 = 'Master Table Open operation failed.';
rsDBIERR_FILECORRUPT | This is constant nxllBdeStrings.rsDBIERR_FILECORRUPT.
rsDBIERR_FILELOCKED | rs10242 = 'Unlock failed.'; rs10243 = 'Table is busy.'; rs10244 = 'Directory is busy.';
rsDBIERR_FILENOACCESS | rs9220 = 'File Delete operation failed.';
rsDBIERR_FLDLIMIT | rs9488 = 'Too many sessions.'; rs9489 = 'Too many open databases.'; rs9490 = 'Too many passwords.'; rs9491 = 'Too many active drivers.';
rsDBIERR_FORIEGNKEYERR | This is constant nxllBdeStrings.rsDBIERR_FORIEGNKEYERR.
rsDBIERR_HEADERCORRUPT | rs8713 = 'Could not find family member.'; rs8714 = 'BLOB file is missing.'; rs8715 = 'Could not find language driver.';
rsDBIERR_INDEXCORRUPT | rs8963 = 'Corrupt Memo/BLOB file.';
rsDBIERR_INDEXEXISTS | rs10025 = 'Table has too many users.'; rs10026 = 'Cannot evaluate Key or Key does not pass filter condition.';
rsDBIERR_INDEXLIMIT | This is constant nxllBdeStrings.rsDBIERR_INDEXLIMIT.
rsDBIERR_INVALIDALIASNAME | rs10052 = 'Invalid table create request'; rs10053 = 'Invalid table delete request'; rs10054 = 'Invalid index create request'; rs10055 = 'Invalid index delete request'; rs10056 = 'Invalid table specified'; rs10058 = 'Invalid Time.'; rs10059 = 'Invalid Date.'; rs10060 = 'Invalid Datetime'; rs10061 = 'Tables in different directories'; rs10062 = 'Mismatch in the number of arguments'; rs10063 = 'Function not found in service library.'; rs10064 = 'Must use baseorder for this operation.'; rs10065 = 'Invalid procedure name'; rs10066 = 'The field map is invalid.';
rsDBIERR_INVALIDBLOBHANDLE | This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBHANDLE.
rsDBIERR_INVALIDBLOBLEN | rs10028 = 'Index is open.';
rsDBIERR_INVALIDBLOBOFFSET | This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBOFFSET.
rsDBIERR_INVALIDBOOKMARK | This is constant nxllBdeStrings.rsDBIERR_INVALIDBOOKMARK.
rsDBIERR_INVALIDDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDDESC.
rsDBIERR_INVALIDDESCNUM | This is constant nxllBdeStrings.rsDBIERR_INVALIDDESCNUM.
rsDBIERR_INVALIDDIR | rs10016 = 'No callback function.'; rs10017 = 'Invalid callback buffer length.';
rsDBIERR_INVALIDFIELDNAME | rs10037 = 'Multi-level cascade is not supported.';
rsDBIERR_INVALIDFILEEXTN | rs10040 = 'Invalid linked cursor expression.'; rs10041 = 'Name is reserved.';
rsDBIERR_INVALIDFILTER | This is constant nxllBdeStrings.rsDBIERR_INVALIDFILTER.
rsDBIERR_INVALIDFLDDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDDESC.
rsDBIERR_INVALIDFLDTYPE | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDTYPE.
rsDBIERR_INVALIDFLDXFORM | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDXFORM.
rsDBIERR_INVALIDHNDL | rs9987 = 'Invalid file name.'; rs9988 = 'File does not exist.'; rs9989 = 'Invalid option.';
rsDBIERR_INVALIDIDXDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDIDXDESC.
rsDBIERR_INVALIDINDEXNAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXNAME.
rsDBIERR_INVALIDINDEXSTRUCT | This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXSTRUCT.
rsDBIERR_INVALIDLANGDRV | This is constant nxllBdeStrings.rsDBIERR_INVALIDLANGDRV.
rsDBIERR_INVALIDNAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDNAME.
rsDBIERR_INVALIDPARAM | This is constant nxllBdeStrings.rsDBIERR_INVALIDPARAM.
rsDBIERR_INVALIDPASSWORD | This is constant nxllBdeStrings.rsDBIERR_INVALIDPASSWORD.
rsDBIERR_INVALIDRECSTRUCT | This is constant nxllBdeStrings.rsDBIERR_INVALIDRECSTRUCT.
rsDBIERR_INVALIDTABLENAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDTABLENAME.
rsDBIERR_INVALIDUSRPASS | rs10032 = 'Need to do (hard) restructure.'; rs10033 = 'Invalid mode.'; rs10034 = 'Cannot close index.'; rs10035 = 'Index is being used to order table.';
rsDBIERR_INVALIDXLATION | This is constant nxllBdeStrings.rsDBIERR_INVALIDXLATION.
rsDBIERR_KEYVIOL | rs9493 = 'Too many table locks.'; rs9494 = 'Too many open BLOBs.'; rs9495 = 'Lock file has grown too large.'; rs9496 = 'Too many open queries.'; rs9498 = 'Too many BLOBs.'; rs9499 = 'File name is too long for a Paradox version 5.0 table.'; rs9500 = 'Row fetch limit exceeded.'; rs9501 = 'Long name not allowed for this tablelevel.';
rsDBIERR_LOCKED | This is constant nxllBdeStrings.rsDBIERR_LOCKED.
rsDBIERR_LOCKTIMEOUT | rs10246 = 'Directory is locked.'; rs10247 = 'Record already locked by this session.'; rs10248 = 'Object not locked.';
rsDBIERR_MAXVALERR | This is constant nxllBdeStrings.rsDBIERR_MAXVALERR.
rsDBIERR_MINVALERR | This is constant nxllBdeStrings.rsDBIERR_MINVALERR.
rsDBIERR_NA | rs10754 = 'BLOB already opened.'; rs10755 = 'BLOB not opened.';
rsDBIERR_NAMENOTUNIQUE | rs10006 = 'Invalid array of validity check descriptors.'; rs10007 = 'Invalid array of referential integrity descriptors.'; rs10008 = 'Invalid ordering of tables during restructure.';
rsDBIERR_NEEDEXCLACCESS | rs10250 = 'Key group is locked.'; rs10251 = 'Table lock was lost.'; rs10252 = 'Exclusive access was lost.';
rsDBIERR_NOACTIVETRAN | This is constant nxllBdeStrings.rsDBIERR_NOACTIVETRAN.
rsDBIERR_NOASSOCINDEX | This is constant nxllBdeStrings.rsDBIERR_NOASSOCINDEX.
rsDBIERR_NOCURRREC | This is constant nxllBdeStrings.rsDBIERR_NOCURRREC.
rsDBIERR_NOMEMORY | rs9222 = 'Access to table disabled because of previous error.';
rsDBIERR_NOSERVERSW | rs11058 = 'Share violation.'; rs11059 = 'Lock violation.'; rs11060 = 'Critical DOS Error.'; rs11061 = 'Drive not ready.'; rs11108 = 'Not exact read/write.'; rs11109 = 'Operating system network error.'; rs11110 = 'Error from NOVELL file server.'; rs11111 = 'NOVELL server out of memory.'; rs11112 = 'Record already locked by this workstation.'; rs11113 = 'Record not locked.';
rsDBIERR_NOSUCHFILTER | rs10044 = 'Alias is not currently opened.'; rs10045 = 'Incompatible record structures.'; rs10046 = 'Name is reserved by DOS.'; rs10047 = 'Destination must be indexed.'; rs10048 = 'Invalid index type'; rs10049 = 'Language Drivers of Table and Index do not match';
rsDBIERR_NOSUCHINDEX | rs9993 = 'Cannot redefine primary key.'; rs9994 = 'Cannot change this RINTDesc.'; rs9995 = 'Foreign and primary key do not match.'; rs9996 = 'Invalid modify request.';
rsDBIERR_NOSUCHTABLE | This is constant nxllBdeStrings.rsDBIERR_NOSUCHTABLE.
rsDBIERR_NOTABLOB | rs10504 = 'Insufficient SQL rights for operation.';
rsDBIERR_NOTINDEXED | This is constant nxllBdeStrings.rsDBIERR_NOTINDEXED.
rsDBIERR_NOTSAMESESSION | rs10758 = 'Engine not initialized.'; rs10759 = 'Attempt to re-initialize Engine.';
rsDBIERR_NOTSUFFTABLERIGHTS | rs10497 = 'Insufficient field rights for operation.';
rsDBIERR_NOTSUPPORTED | This is constant nxllBdeStrings.rsDBIERR_NOTSUPPORTED.
rsDBIERR_NX_BadBlockNr | This is constant nxllBdeStrings.rsDBIERR_NX_BadBlockNr.
rsDBIERR_NX_BadDataBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadDataBlock.
rsDBIERR_NX_BadHeapBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadHeapBlock.
rsDBIERR_NX_BadIndex | This is constant nxllBdeStrings.rsDBIERR_NX_BadIndex.
rsDBIERR_NX_BadInxBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadInxBlock.
rsDBIERR_NX_BadRefNr | This is constant nxllBdeStrings.rsDBIERR_NX_BadRefNr.
rsDBIERR_NX_BadStreamBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadStreamBlock.
rsDBIERR_NX_BadStruct | rs13313 = 'Different sort order.'; rs13314 = 'Directory in use by earlier version of Paradox.'; rs13315 = 'Needs Paradox 3.5-compatible language driver.'; rs13569 = 'Data Dictionary is corrupt'; rs13570 = 'Data Dictionary Info Blob corrupted'; rs13571 = 'Data Dictionary Schema is corrupt'; rs13572 = 'Attribute Type exists'; rs13573 = 'Invalid Object Type'; rs13574 = 'Invalid Relation Type'; rs13575 = 'View already exists'; rs13576 = 'No such View exists'; rs13577 = 'Invalid Record Constraint'; rs13578 = 'Object is in a Logical DB'; rs13579 = 'Dictionary already exists'; rs13580 = 'Dictionary does not exist'; rs13581 = 'Dictionary database does not... more
rsDBIERR_NX_BLOBTooBig | This is constant nxllBdeStrings.rsDBIERR_NX_BLOBTooBig.
rsDBIERR_NX_CloseFailed | This is constant nxllBdeStrings.rsDBIERR_NX_CloseFailed.
rsDBIERR_NX_CopyFile | This is constant nxllBdeStrings.rsDBIERR_NX_CopyFile.
rsDBIERR_NX_CorruptTrans | This is constant nxllBdeStrings.rsDBIERR_NX_CorruptTrans.
rsDBIERR_NX_DeleteFile | This is constant nxllBdeStrings.rsDBIERR_NX_DeleteFile.
rsDBIERR_NX_DICT_DUPAUTOINC | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPAUTOINC.
rsDBIERR_NX_DICT_DUPRECREV | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPRECREV.
rsDBIERR_NX_DICT_OBJINUSE | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_OBJINUSE.
rsDBIERR_NX_DICT_READONLY | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_READONLY.
rsDBIERR_NX_FileBLOBClose | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBClose.
rsDBIERR_NX_FileBLOBOpen | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBOpen.
rsDBIERR_NX_FileBLOBRead | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBRead.
rsDBIERR_NX_FilterTimeout | This is constant nxllBdeStrings.rsDBIERR_NX_FilterTimeout.
rsDBIERR_NX_GeneralTimeout | This is constant nxllBdeStrings.rsDBIERR_NX_GeneralTimeout.
rsDBIERR_NX_IncompatDict | This is constant nxllBdeStrings.rsDBIERR_NX_IncompatDict.
rsDBIERR_NX_INCOMPATHEADER | This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATHEADER.
rsDBIERR_NX_INCOMPATSTREAM | This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATSTREAM.
rsDBIERR_NX_INDEXNOTEMPTY | This is constant nxllBdeStrings.rsDBIERR_NX_INDEXNOTEMPTY.
rsDBIERR_NX_INVALIDSEGNR | This is constant nxllBdeStrings.rsDBIERR_NX_INVALIDSEGNR.
rsDBIERR_NX_LICENSE_EXPIRED | This is constant nxllBdeStrings.rsDBIERR_NX_LICENSE_EXPIRED.
rsDBIERR_NX_LITE | This is constant nxllBdeStrings.rsDBIERR_NX_LITE.
rsDBIERR_NX_MAXKEYSIZE | This is constant nxllBdeStrings.rsDBIERR_NX_MAXKEYSIZE.
rsDBIERR_NX_MAXRECORDSIZE | This is constant nxllBdeStrings.rsDBIERR_NX_MAXRECORDSIZE.
rsDBIERR_NX_MAXUSERS | This is constant nxllBdeStrings.rsDBIERR_NX_MAXUSERS.
rsDBIERR_NX_NoSessionSE | This is constant nxllBdeStrings.rsDBIERR_NX_NoSessionSE.
rsDBIERR_NX_RECOVERFAILED | This is constant nxllBdeStrings.rsDBIERR_NX_RECOVERFAILED.
rsDBIERR_NX_RegisterFHAF | This is constant nxllBdeStrings.rsDBIERR_NX_RegisterFHAF.
rsDBIERR_NX_RenameFile | This is constant nxllBdeStrings.rsDBIERR_NX_RenameFile.
rsDBIERR_NX_SameFolder | This is constant nxllBdeStrings.rsDBIERR_NX_SameFolder.
rsDBIERR_NX_SameTable | This is constant nxllBdeStrings.rsDBIERR_NX_SameTable.
rsDBIERR_NX_SEGMENTDELETED | This is constant nxllBdeStrings.rsDBIERR_NX_SEGMENTDELETED.
rsDBIERR_NX_SERVERNAMENOTSET | This is constant nxllBdeStrings.rsDBIERR_NX_SERVERNAMENOTSET.
rsDBIERR_NX_SQLSIGNAL | This is constant nxllBdeStrings.rsDBIERR_NX_SQLSIGNAL.
rsDBIERR_NX_TableVersion | This is constant nxllBdeStrings.rsDBIERR_NX_TableVersion.
rsDBIERR_NX_TempStorageFull | This is constant nxllBdeStrings.rsDBIERR_NX_TempStorageFull.
rsDBIERR_NX_TRIAL | This is constant nxllBdeStrings.rsDBIERR_NX_TRIAL.
rsDBIERR_NX_TS_FULL | This is constant nxllBdeStrings.rsDBIERR_NX_TS_FULL.
rsDBIERR_NX_TS_INVALIDBLOCK | This is constant nxllBdeStrings.rsDBIERR_NX_TS_INVALIDBLOCK.
rsDBIERR_NX_Unknown | This is constant nxllBdeStrings.rsDBIERR_NX_Unknown.
rsDBIERR_NX_UnknownExcp | This is constant nxllBdeStrings.rsDBIERR_NX_UnknownExcp.
rsDBIERR_NX_UnknownMsg | This is constant nxllBdeStrings.rsDBIERR_NX_UnknownMsg.
rsDBIERR_NX_UNSUPDICTDESCR | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPDICTDESCR.
rsDBIERR_NX_UNSUPHEADER | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPHEADER.
rsDBIERR_NX_UNSUPSUBENGINE | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPSUBENGINE.
rsDBIERR_OBJNOTFOUND | This is constant nxllBdeStrings.rsDBIERR_OBJNOTFOUND.
rsDBIERR_OPTRECLOCKFAILED | This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKFAILED.
rsDBIERR_OPTRECLOCKRECDEL | This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKRECDEL.
rsDBIERR_OSUNKNOWN | rs10765 = 'Table(s) open. Cannot perform this operation.'; rs10766 = 'Table does not support this operation.'; rs10767 = 'Index is read only.'; rs10768 = 'Table does not support this operation because it is not uniquely indexed.'; rs10769 = 'Operation must be performed on the current session.'; rs10770 = 'Invalid use of keyword.'; rs10771 = 'Connection is in use by another statement.'; rs10772 = 'Passthrough SQL connection must be shared'; rs11009 = 'Invalid function number.'; rs11010 = 'File or directory does not exist.'; rs11011 = 'Path not found.'; rs11012 = 'Too many open files. You may need to increase MAXFILEHANDLE limit... more
rsDBIERR_OUTOFRANGE | This is constant nxllBdeStrings.rsDBIERR_OUTOFRANGE.
rsDBIERR_READERR | rs8966 = 'Corrupt lock file.'; rs8967 = 'Corrupt family file.'; rs8968 = 'Corrupt or missing .VAL file.'; rs8969 = 'Foreign index file format.';
rsDBIERR_READONLYDB | rs10499 = 'Insufficient family rights for operation.'; rs10500 = 'This directory is read only.';
rsDBIERR_READONLYFLD | This is constant nxllBdeStrings.rsDBIERR_READONLYFLD.
rsDBIERR_RECDELETED | rsDBIERR_RECMOVED = 'Record moved because key value changed.';
rsDBIERR_RECGROUPCONFLICT | This is constant nxllBdeStrings.rsDBIERR_RECGROUPCONFLICT.
rsDBIERR_RECLOCKFAILED | This is constant nxllBdeStrings.rsDBIERR_RECLOCKFAILED.
rsDBIERR_RECNOTFOUND | This is constant nxllBdeStrings.rsDBIERR_RECNOTFOUND.
rsDBIERR_REENTERED | rs8449 = 'Cannot open a system file.'; rs8450 = 'I/O error on a system file.'; rs8451 = 'Data structure corruption.'; rs8452 = 'Cannot find Engine configuration file.'; rs8453 = 'Cannot write to Engine configuration file.'; rs8454 = 'Cannot initialize with different configuration file.';
rsDBIERR_REQDERR | This is constant nxllBdeStrings.rsDBIERR_REQDERR.
rsDBIERR_SERVERCOMMLOST | rs11265 = 'Network initialization failed.'; rs11266 = 'Network user limit exceeded.'; rs11267 = 'Wrong .NET file version.'; rs11268 = 'Cannot lock network file.'; rs11269 = 'Directory is not private.'; rs11270 = 'Directory is controlled by other .NET file.'; rs11271 = 'Unknown network error.'; rs11272 = 'Not initialized for accessing network files.'; rs11273 = 'SHARE not loaded. It is required to share local files.'; rs11274 = 'Not on a network. Not logged in or wrong network driver.'; rs11275 = 'Lost communication with SQL server.';
rsDBIERR_SERVERNOTFOUND | rs11277 = 'Cannot locate or connect to SQL server.';
rsDBIERR_SERVERVERSION | rs11897 = 'Query must be restarted.'; rs11898 = 'Unknown answer table type.'; rs11926 = 'Blob cannot be used as grouping field.'; rs11927 = 'Query properties have not been fetched.'; rs11928 = 'Answer table is of unsuitable type.'; rs11929 = 'Answer table is not yet supported under server alias.'; rs11930 = 'Non-null blob field required. Can''t insert records'; rs11931 = 'Unique index required to perform changeto'; rs11932 = 'Unique index required to delete records'; rs11933 = 'Update of table on the server failed.'; rs11934 = 'Can''t process this query remotely.'; rs11935 = 'Unexpected end of command.'; rs11936 = 'Parameter not set... more
rsDBIERR_TABLEEXISTS | rs13059 = 'General SQL error.';
rsDBIERR_TABLEFULL | rs9474 = 'Not enough file handles.'; rs9475 = 'Insufficient disk space.'; rs9477 = 'Record size is too big for table.'; rs9478 = 'Too many open cursors.';
rsDBIERR_TABLELEVEL | This is constant nxllBdeStrings.rsDBIERR_TABLELEVEL.
rsDBIERR_TABLEOPEN | This is constant nxllBdeStrings.rsDBIERR_TABLEOPEN.
rsDBIERR_TABLEREADONLY | rs10761 = 'Paradox driver not active.'; rs10762 = 'Driver not loaded.';
rsDBIERR_TBLENCRYPTED | This is constant nxllBdeStrings.rsDBIERR_TBLENCRYPTED.
rsDBIERR_UNKNOWNDB | rs10010 = 'Index name required.'; rs10011 = 'Invalid session handle.'; rs10012 = 'invalid restructure operation.'; rs10013 = 'Driver not known to system.';
rsDBIERR_UNKNOWNFILE | rs9991 = 'Unknown table type.';
rsDBIERR_UPDATEABORT | rs13061 = 'Paradox 1.0 tables are not supported.';
rsDBIERR_WRITEERR | This is constant nxllBdeStrings.rsDBIERR_WRITEERR.
Functions
Name | Description
nxGetErrorString | This is function nxllBdeStrings.nxGetErrorString.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Constants, Functions, Legend, Topics


Functions

Functions
Functions nxllBdeStrings Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxGetErrorString | This is function nxllBdeStrings.nxGetErrorString.
Namespace

nxllBdeStrings Namespace

Links
Functions, nxllBdeStrings Namespace, Legend


nxllBdeStrings.nxGetErrorString Function

nxllBdeStrings.nxGetErrorString Function
nxllBdeStrings Functions Send Feedback
Syntax
Delphi
function nxGetErrorString(aErrorCode: TnxResult): string;
File

nxllBdeStrings

Description

This is function nxllBdeStrings.nxGetErrorString.

Group

Functions

Links
nxllBdeStrings, Functions


Constants

Constants
Constants nxllBdeStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsDBIERR_ACTIVETRAN | This is constant nxllBdeStrings.rsDBIERR_ACTIVETRAN.
rsDBIERR_BLOBERR | rs11521 = 'Optional parameter is required.'; rs11522 = 'Invalid optional parameter.'; rs11777 = 'obsolete'; rs11778 = 'obsolete'; rs11779 = 'Ambiguous use of ! (inclusion operator).'; rs11780 = 'obsolete'; rs11781 = 'obsolete'; rs11782 = 'A SET operation cannot be included in its own grouping.'; rs11783 = 'Only numeric and date/time fields can be averaged.'; rs11784 = 'Invalid expression.'; rs11785 = 'Invalid OR expression.'; rs11786 = 'obsolete'; rs11787 = 'bitmap'; rs11788 = 'CALC expression cannot be used in INSERT, DELETE, CHANGETO and SET rows.'; rs11789 = 'Type error in CALC expression.'; rs11790 = 'CHANGETO can be used in only one query... more
rsDBIERR_BLOBMODIFIED | rs12290 = 'Not implemented yet.'; rs12291 = 'SQL replicas not supported.'; rs12292 = 'Non-blob column in table required to perform operation.'; rs12293 = 'Multiple connections not supported.'; rs12294 = 'Full dBASE expressions not supported.'; rs12545 = 'Invalid database alias specification.'; rs12546 = 'Unknown database type.'; rs12547 = 'Corrupt system configuration file.'; rs12548 = 'Network type unknown.'; rs12549 = 'Not on the network.'; rs12550 = 'Invalid configuration parameter.'; rs12801 = 'Object implicitly dropped.'; rs12802 = 'Object may be truncated.'; rs12803 = 'Object implicitly modified.'; rs12804 = 'Should field constraints be checked?'; rs12805 = 'Validity check field modified.'; rs12806 = 'Table level... more
rsDBIERR_BOF | rs8456 = 'Cannot locate IDAPI32 .DLL.'; rs8457 = 'Cannot load IDAPI32 .DLL.'; rs8458 = 'Cannot load an IDAPI service library.'; rs8459 = 'Cannot create or open temporary file.';
rsDBIERR_CHECKCONSTRAINTFAILED | rs9741 = 'Link to master table already defined.'; rs9742 = 'Master table is open.'; rs9743 = 'Detail table(s) exist.'; rs9744 = 'Master has detail records. Cannot empty it.'; rs9745 = 'Self referencing referential integrity must be entered one at a time with no other changes to the table'; rs9746 = 'Detail table is open.'; rs9747 = 'Cannot make this master a detail of another table if its details are not empty.'; rs9748 = 'Referential integrity fields must be indexed.'; rs9749 = 'A table linked by referential integrity requires password to open.'; rs9750 = 'Field(s) linked to more than one... more
rsDBIERR_CLIENTSLIMIT | rs9480 = 'Too many sessions from this workstation.'; rs9481 = 'Serial number limit (Paradox).'; rs9482 = 'Some internal limit (see context).'; rs9483 = 'Too many open tables.'; rs9484 = 'Too many cursors per table.'; rs9485 = 'Too many record locks on table.';
rsDBIERR_DEADLOCK | This is constant nxllBdeStrings.rsDBIERR_DEADLOCK.
rsDBIERR_DETAILRECORDSEXIST | This is constant nxllBdeStrings.rsDBIERR_DETAILRECORDSEXIST.
rsDBIERR_DIFFERENTTABLES | This is constant nxllBdeStrings.rsDBIERR_DIFFERENTTABLES.
rsDBIERR_DIRNOACCESS | This is constant nxllBdeStrings.rsDBIERR_DIRNOACCESS.
rsDBIERR_ENDOFBLOB | This is constant nxllBdeStrings.rsDBIERR_ENDOFBLOB.
rsDBIERR_EOF | This is constant nxllBdeStrings.rsDBIERR_EOF.
rsDBIERR_FIELDISBLANK | rs9735 = 'Master table level is incorrect.'; rs9736 = 'Field value out of lookup table range.'; rs9737 = 'Lookup Table Open operation failed.'; rs9738 = 'Detail Table Open operation failed.'; rs9739 = 'Master Table Open operation failed.';
rsDBIERR_FILECORRUPT | This is constant nxllBdeStrings.rsDBIERR_FILECORRUPT.
rsDBIERR_FILELOCKED | rs10242 = 'Unlock failed.'; rs10243 = 'Table is busy.'; rs10244 = 'Directory is busy.';
rsDBIERR_FILENOACCESS | rs9220 = 'File Delete operation failed.';
rsDBIERR_FLDLIMIT | rs9488 = 'Too many sessions.'; rs9489 = 'Too many open databases.'; rs9490 = 'Too many passwords.'; rs9491 = 'Too many active drivers.';
rsDBIERR_FORIEGNKEYERR | This is constant nxllBdeStrings.rsDBIERR_FORIEGNKEYERR.
rsDBIERR_HEADERCORRUPT | rs8713 = 'Could not find family member.'; rs8714 = 'BLOB file is missing.'; rs8715 = 'Could not find language driver.';
rsDBIERR_INDEXCORRUPT | rs8963 = 'Corrupt Memo/BLOB file.';
rsDBIERR_INDEXEXISTS | rs10025 = 'Table has too many users.'; rs10026 = 'Cannot evaluate Key or Key does not pass filter condition.';
rsDBIERR_INDEXLIMIT | This is constant nxllBdeStrings.rsDBIERR_INDEXLIMIT.
rsDBIERR_INVALIDALIASNAME | rs10052 = 'Invalid table create request'; rs10053 = 'Invalid table delete request'; rs10054 = 'Invalid index create request'; rs10055 = 'Invalid index delete request'; rs10056 = 'Invalid table specified'; rs10058 = 'Invalid Time.'; rs10059 = 'Invalid Date.'; rs10060 = 'Invalid Datetime'; rs10061 = 'Tables in different directories'; rs10062 = 'Mismatch in the number of arguments'; rs10063 = 'Function not found in service library.'; rs10064 = 'Must use baseorder for this operation.'; rs10065 = 'Invalid procedure name'; rs10066 = 'The field map is invalid.';
rsDBIERR_INVALIDBLOBHANDLE | This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBHANDLE.
rsDBIERR_INVALIDBLOBLEN | rs10028 = 'Index is open.';
rsDBIERR_INVALIDBLOBOFFSET | This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBOFFSET.
rsDBIERR_INVALIDBOOKMARK | This is constant nxllBdeStrings.rsDBIERR_INVALIDBOOKMARK.
rsDBIERR_INVALIDDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDDESC.
rsDBIERR_INVALIDDESCNUM | This is constant nxllBdeStrings.rsDBIERR_INVALIDDESCNUM.
rsDBIERR_INVALIDDIR | rs10016 = 'No callback function.'; rs10017 = 'Invalid callback buffer length.';
rsDBIERR_INVALIDFIELDNAME | rs10037 = 'Multi-level cascade is not supported.';
rsDBIERR_INVALIDFILEEXTN | rs10040 = 'Invalid linked cursor expression.'; rs10041 = 'Name is reserved.';
rsDBIERR_INVALIDFILTER | This is constant nxllBdeStrings.rsDBIERR_INVALIDFILTER.
rsDBIERR_INVALIDFLDDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDDESC.
rsDBIERR_INVALIDFLDTYPE | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDTYPE.
rsDBIERR_INVALIDFLDXFORM | This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDXFORM.
rsDBIERR_INVALIDHNDL | rs9987 = 'Invalid file name.'; rs9988 = 'File does not exist.'; rs9989 = 'Invalid option.';
rsDBIERR_INVALIDIDXDESC | This is constant nxllBdeStrings.rsDBIERR_INVALIDIDXDESC.
rsDBIERR_INVALIDINDEXNAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXNAME.
rsDBIERR_INVALIDINDEXSTRUCT | This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXSTRUCT.
rsDBIERR_INVALIDLANGDRV | This is constant nxllBdeStrings.rsDBIERR_INVALIDLANGDRV.
rsDBIERR_INVALIDNAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDNAME.
rsDBIERR_INVALIDPARAM | This is constant nxllBdeStrings.rsDBIERR_INVALIDPARAM.
rsDBIERR_INVALIDPASSWORD | This is constant nxllBdeStrings.rsDBIERR_INVALIDPASSWORD.
rsDBIERR_INVALIDRECSTRUCT | This is constant nxllBdeStrings.rsDBIERR_INVALIDRECSTRUCT.
rsDBIERR_INVALIDTABLENAME | This is constant nxllBdeStrings.rsDBIERR_INVALIDTABLENAME.
rsDBIERR_INVALIDUSRPASS | rs10032 = 'Need to do (hard) restructure.'; rs10033 = 'Invalid mode.'; rs10034 = 'Cannot close index.'; rs10035 = 'Index is being used to order table.';
rsDBIERR_INVALIDXLATION | This is constant nxllBdeStrings.rsDBIERR_INVALIDXLATION.
rsDBIERR_KEYVIOL | rs9493 = 'Too many table locks.'; rs9494 = 'Too many open BLOBs.'; rs9495 = 'Lock file has grown too large.'; rs9496 = 'Too many open queries.'; rs9498 = 'Too many BLOBs.'; rs9499 = 'File name is too long for a Paradox version 5.0 table.'; rs9500 = 'Row fetch limit exceeded.'; rs9501 = 'Long name not allowed for this tablelevel.';
rsDBIERR_LOCKED | This is constant nxllBdeStrings.rsDBIERR_LOCKED.
rsDBIERR_LOCKTIMEOUT | rs10246 = 'Directory is locked.'; rs10247 = 'Record already locked by this session.'; rs10248 = 'Object not locked.';
rsDBIERR_MAXVALERR | This is constant nxllBdeStrings.rsDBIERR_MAXVALERR.
rsDBIERR_MINVALERR | This is constant nxllBdeStrings.rsDBIERR_MINVALERR.
rsDBIERR_NA | rs10754 = 'BLOB already opened.'; rs10755 = 'BLOB not opened.';
rsDBIERR_NAMENOTUNIQUE | rs10006 = 'Invalid array of validity check descriptors.'; rs10007 = 'Invalid array of referential integrity descriptors.'; rs10008 = 'Invalid ordering of tables during restructure.';
rsDBIERR_NEEDEXCLACCESS | rs10250 = 'Key group is locked.'; rs10251 = 'Table lock was lost.'; rs10252 = 'Exclusive access was lost.';
rsDBIERR_NOACTIVETRAN | This is constant nxllBdeStrings.rsDBIERR_NOACTIVETRAN.
rsDBIERR_NOASSOCINDEX | This is constant nxllBdeStrings.rsDBIERR_NOASSOCINDEX.
rsDBIERR_NOCURRREC | This is constant nxllBdeStrings.rsDBIERR_NOCURRREC.
rsDBIERR_NOMEMORY | rs9222 = 'Access to table disabled because of previous error.';
rsDBIERR_NOSERVERSW | rs11058 = 'Share violation.'; rs11059 = 'Lock violation.'; rs11060 = 'Critical DOS Error.'; rs11061 = 'Drive not ready.'; rs11108 = 'Not exact read/write.'; rs11109 = 'Operating system network error.'; rs11110 = 'Error from NOVELL file server.'; rs11111 = 'NOVELL server out of memory.'; rs11112 = 'Record already locked by this workstation.'; rs11113 = 'Record not locked.';
rsDBIERR_NOSUCHFILTER | rs10044 = 'Alias is not currently opened.'; rs10045 = 'Incompatible record structures.'; rs10046 = 'Name is reserved by DOS.'; rs10047 = 'Destination must be indexed.'; rs10048 = 'Invalid index type'; rs10049 = 'Language Drivers of Table and Index do not match';
rsDBIERR_NOSUCHINDEX | rs9993 = 'Cannot redefine primary key.'; rs9994 = 'Cannot change this RINTDesc.'; rs9995 = 'Foreign and primary key do not match.'; rs9996 = 'Invalid modify request.';
rsDBIERR_NOSUCHTABLE | This is constant nxllBdeStrings.rsDBIERR_NOSUCHTABLE.
rsDBIERR_NOTABLOB | rs10504 = 'Insufficient SQL rights for operation.';
rsDBIERR_NOTINDEXED | This is constant nxllBdeStrings.rsDBIERR_NOTINDEXED.
rsDBIERR_NOTSAMESESSION | rs10758 = 'Engine not initialized.'; rs10759 = 'Attempt to re-initialize Engine.';
rsDBIERR_NOTSUFFTABLERIGHTS | rs10497 = 'Insufficient field rights for operation.';
rsDBIERR_NOTSUPPORTED | This is constant nxllBdeStrings.rsDBIERR_NOTSUPPORTED.
rsDBIERR_NX_BadBlockNr | This is constant nxllBdeStrings.rsDBIERR_NX_BadBlockNr.
rsDBIERR_NX_BadDataBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadDataBlock.
rsDBIERR_NX_BadHeapBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadHeapBlock.
rsDBIERR_NX_BadIndex | This is constant nxllBdeStrings.rsDBIERR_NX_BadIndex.
rsDBIERR_NX_BadInxBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadInxBlock.
rsDBIERR_NX_BadRefNr | This is constant nxllBdeStrings.rsDBIERR_NX_BadRefNr.
rsDBIERR_NX_BadStreamBlock | This is constant nxllBdeStrings.rsDBIERR_NX_BadStreamBlock.
rsDBIERR_NX_BadStruct | rs13313 = 'Different sort order.'; rs13314 = 'Directory in use by earlier version of Paradox.'; rs13315 = 'Needs Paradox 3.5-compatible language driver.'; rs13569 = 'Data Dictionary is corrupt'; rs13570 = 'Data Dictionary Info Blob corrupted'; rs13571 = 'Data Dictionary Schema is corrupt'; rs13572 = 'Attribute Type exists'; rs13573 = 'Invalid Object Type'; rs13574 = 'Invalid Relation Type'; rs13575 = 'View already exists'; rs13576 = 'No such View exists'; rs13577 = 'Invalid Record Constraint'; rs13578 = 'Object is in a Logical DB'; rs13579 = 'Dictionary already exists'; rs13580 = 'Dictionary does not exist'; rs13581 = 'Dictionary database does not... more
rsDBIERR_NX_BLOBTooBig | This is constant nxllBdeStrings.rsDBIERR_NX_BLOBTooBig.
rsDBIERR_NX_CloseFailed | This is constant nxllBdeStrings.rsDBIERR_NX_CloseFailed.
rsDBIERR_NX_CopyFile | This is constant nxllBdeStrings.rsDBIERR_NX_CopyFile.
rsDBIERR_NX_CorruptTrans | This is constant nxllBdeStrings.rsDBIERR_NX_CorruptTrans.
rsDBIERR_NX_DeleteFile | This is constant nxllBdeStrings.rsDBIERR_NX_DeleteFile.
rsDBIERR_NX_DICT_DUPAUTOINC | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPAUTOINC.
rsDBIERR_NX_DICT_DUPRECREV | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPRECREV.
rsDBIERR_NX_DICT_OBJINUSE | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_OBJINUSE.
rsDBIERR_NX_DICT_READONLY | This is constant nxllBdeStrings.rsDBIERR_NX_DICT_READONLY.
rsDBIERR_NX_FileBLOBClose | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBClose.
rsDBIERR_NX_FileBLOBOpen | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBOpen.
rsDBIERR_NX_FileBLOBRead | This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBRead.
rsDBIERR_NX_FilterTimeout | This is constant nxllBdeStrings.rsDBIERR_NX_FilterTimeout.
rsDBIERR_NX_GeneralTimeout | This is constant nxllBdeStrings.rsDBIERR_NX_GeneralTimeout.
rsDBIERR_NX_IncompatDict | This is constant nxllBdeStrings.rsDBIERR_NX_IncompatDict.
rsDBIERR_NX_INCOMPATHEADER | This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATHEADER.
rsDBIERR_NX_INCOMPATSTREAM | This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATSTREAM.
rsDBIERR_NX_INDEXNOTEMPTY | This is constant nxllBdeStrings.rsDBIERR_NX_INDEXNOTEMPTY.
rsDBIERR_NX_INVALIDSEGNR | This is constant nxllBdeStrings.rsDBIERR_NX_INVALIDSEGNR.
rsDBIERR_NX_LICENSE_EXPIRED | This is constant nxllBdeStrings.rsDBIERR_NX_LICENSE_EXPIRED.
rsDBIERR_NX_LITE | This is constant nxllBdeStrings.rsDBIERR_NX_LITE.
rsDBIERR_NX_MAXKEYSIZE | This is constant nxllBdeStrings.rsDBIERR_NX_MAXKEYSIZE.
rsDBIERR_NX_MAXRECORDSIZE | This is constant nxllBdeStrings.rsDBIERR_NX_MAXRECORDSIZE.
rsDBIERR_NX_MAXUSERS | This is constant nxllBdeStrings.rsDBIERR_NX_MAXUSERS.
rsDBIERR_NX_NoSessionSE | This is constant nxllBdeStrings.rsDBIERR_NX_NoSessionSE.
rsDBIERR_NX_RECOVERFAILED | This is constant nxllBdeStrings.rsDBIERR_NX_RECOVERFAILED.
rsDBIERR_NX_RegisterFHAF | This is constant nxllBdeStrings.rsDBIERR_NX_RegisterFHAF.
rsDBIERR_NX_RenameFile | This is constant nxllBdeStrings.rsDBIERR_NX_RenameFile.
rsDBIERR_NX_SameFolder | This is constant nxllBdeStrings.rsDBIERR_NX_SameFolder.
rsDBIERR_NX_SameTable | This is constant nxllBdeStrings.rsDBIERR_NX_SameTable.
rsDBIERR_NX_SEGMENTDELETED | This is constant nxllBdeStrings.rsDBIERR_NX_SEGMENTDELETED.
rsDBIERR_NX_SERVERNAMENOTSET | This is constant nxllBdeStrings.rsDBIERR_NX_SERVERNAMENOTSET.
rsDBIERR_NX_SQLSIGNAL | This is constant nxllBdeStrings.rsDBIERR_NX_SQLSIGNAL.
rsDBIERR_NX_TableVersion | This is constant nxllBdeStrings.rsDBIERR_NX_TableVersion.
rsDBIERR_NX_TempStorageFull | This is constant nxllBdeStrings.rsDBIERR_NX_TempStorageFull.
rsDBIERR_NX_TRIAL | This is constant nxllBdeStrings.rsDBIERR_NX_TRIAL.
rsDBIERR_NX_TS_FULL | This is constant nxllBdeStrings.rsDBIERR_NX_TS_FULL.
rsDBIERR_NX_TS_INVALIDBLOCK | This is constant nxllBdeStrings.rsDBIERR_NX_TS_INVALIDBLOCK.
rsDBIERR_NX_Unknown | This is constant nxllBdeStrings.rsDBIERR_NX_Unknown.
rsDBIERR_NX_UnknownExcp | This is constant nxllBdeStrings.rsDBIERR_NX_UnknownExcp.
rsDBIERR_NX_UnknownMsg | This is constant nxllBdeStrings.rsDBIERR_NX_UnknownMsg.
rsDBIERR_NX_UNSUPDICTDESCR | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPDICTDESCR.
rsDBIERR_NX_UNSUPHEADER | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPHEADER.
rsDBIERR_NX_UNSUPSUBENGINE | This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPSUBENGINE.
rsDBIERR_OBJNOTFOUND | This is constant nxllBdeStrings.rsDBIERR_OBJNOTFOUND.
rsDBIERR_OPTRECLOCKFAILED | This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKFAILED.
rsDBIERR_OPTRECLOCKRECDEL | This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKRECDEL.
rsDBIERR_OSUNKNOWN | rs10765 = 'Table(s) open. Cannot perform this operation.'; rs10766 = 'Table does not support this operation.'; rs10767 = 'Index is read only.'; rs10768 = 'Table does not support this operation because it is not uniquely indexed.'; rs10769 = 'Operation must be performed on the current session.'; rs10770 = 'Invalid use of keyword.'; rs10771 = 'Connection is in use by another statement.'; rs10772 = 'Passthrough SQL connection must be shared'; rs11009 = 'Invalid function number.'; rs11010 = 'File or directory does not exist.'; rs11011 = 'Path not found.'; rs11012 = 'Too many open files. You may need to increase MAXFILEHANDLE limit... more
rsDBIERR_OUTOFRANGE | This is constant nxllBdeStrings.rsDBIERR_OUTOFRANGE.
rsDBIERR_READERR | rs8966 = 'Corrupt lock file.'; rs8967 = 'Corrupt family file.'; rs8968 = 'Corrupt or missing .VAL file.'; rs8969 = 'Foreign index file format.';
rsDBIERR_READONLYDB | rs10499 = 'Insufficient family rights for operation.'; rs10500 = 'This directory is read only.';
rsDBIERR_READONLYFLD | This is constant nxllBdeStrings.rsDBIERR_READONLYFLD.
rsDBIERR_RECDELETED | rsDBIERR_RECMOVED = 'Record moved because key value changed.';
rsDBIERR_RECGROUPCONFLICT | This is constant nxllBdeStrings.rsDBIERR_RECGROUPCONFLICT.
rsDBIERR_RECLOCKFAILED | This is constant nxllBdeStrings.rsDBIERR_RECLOCKFAILED.
rsDBIERR_RECNOTFOUND | This is constant nxllBdeStrings.rsDBIERR_RECNOTFOUND.
rsDBIERR_REENTERED | rs8449 = 'Cannot open a system file.'; rs8450 = 'I/O error on a system file.'; rs8451 = 'Data structure corruption.'; rs8452 = 'Cannot find Engine configuration file.'; rs8453 = 'Cannot write to Engine configuration file.'; rs8454 = 'Cannot initialize with different configuration file.';
rsDBIERR_REQDERR | This is constant nxllBdeStrings.rsDBIERR_REQDERR.
rsDBIERR_SERVERCOMMLOST | rs11265 = 'Network initialization failed.'; rs11266 = 'Network user limit exceeded.'; rs11267 = 'Wrong .NET file version.'; rs11268 = 'Cannot lock network file.'; rs11269 = 'Directory is not private.'; rs11270 = 'Directory is controlled by other .NET file.'; rs11271 = 'Unknown network error.'; rs11272 = 'Not initialized for accessing network files.'; rs11273 = 'SHARE not loaded. It is required to share local files.'; rs11274 = 'Not on a network. Not logged in or wrong network driver.'; rs11275 = 'Lost communication with SQL server.';
rsDBIERR_SERVERNOTFOUND | rs11277 = 'Cannot locate or connect to SQL server.';
rsDBIERR_SERVERVERSION | rs11897 = 'Query must be restarted.'; rs11898 = 'Unknown answer table type.'; rs11926 = 'Blob cannot be used as grouping field.'; rs11927 = 'Query properties have not been fetched.'; rs11928 = 'Answer table is of unsuitable type.'; rs11929 = 'Answer table is not yet supported under server alias.'; rs11930 = 'Non-null blob field required. Can''t insert records'; rs11931 = 'Unique index required to perform changeto'; rs11932 = 'Unique index required to delete records'; rs11933 = 'Update of table on the server failed.'; rs11934 = 'Can''t process this query remotely.'; rs11935 = 'Unexpected end of command.'; rs11936 = 'Parameter not set... more
rsDBIERR_TABLEEXISTS | rs13059 = 'General SQL error.';
rsDBIERR_TABLEFULL | rs9474 = 'Not enough file handles.'; rs9475 = 'Insufficient disk space.'; rs9477 = 'Record size is too big for table.'; rs9478 = 'Too many open cursors.';
rsDBIERR_TABLELEVEL | This is constant nxllBdeStrings.rsDBIERR_TABLELEVEL.
rsDBIERR_TABLEOPEN | This is constant nxllBdeStrings.rsDBIERR_TABLEOPEN.
rsDBIERR_TABLEREADONLY | rs10761 = 'Paradox driver not active.'; rs10762 = 'Driver not loaded.';
rsDBIERR_TBLENCRYPTED | This is constant nxllBdeStrings.rsDBIERR_TBLENCRYPTED.
rsDBIERR_UNKNOWNDB | rs10010 = 'Index name required.'; rs10011 = 'Invalid session handle.'; rs10012 = 'invalid restructure operation.'; rs10013 = 'Driver not known to system.';
rsDBIERR_UNKNOWNFILE | rs9991 = 'Unknown table type.';
rsDBIERR_UPDATEABORT | rs13061 = 'Paradox 1.0 tables are not supported.';
rsDBIERR_WRITEERR | This is constant nxllBdeStrings.rsDBIERR_WRITEERR.
Namespace

nxllBdeStrings Namespace

Links
Constants, nxllBdeStrings Namespace


nxllBdeStrings.rsDBIERR_ACTIVETRAN Constant

nxllBdeStrings.rsDBIERR_ACTIVETRAN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_ACTIVETRAN = 'A user transaction is already in progress.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_ACTIVETRAN.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_BLOBERR Constant

nxllBdeStrings.rsDBIERR_BLOBERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_BLOBERR = 'General BLOB error.';
File

nxllBdeStrings

Description

rs11521 = 'Optional parameter is required.'; rs11522 = 'Invalid optional parameter.'; rs11777 = 'obsolete'; rs11778 = 'obsolete'; rs11779 = 'Ambiguous use of ! (inclusion operator).'; rs11780 = 'obsolete'; rs11781 = 'obsolete'; rs11782 = 'A SET operation cannot be included in its own grouping.'; rs11783 = 'Only numeric and date/time fields can be averaged.'; rs11784 = 'Invalid expression.'; rs11785 = 'Invalid OR expression.'; rs11786 = 'obsolete'; rs11787 = 'bitmap'; rs11788 = 'CALC expression cannot be used in INSERT, DELETE, CHANGETO and SET rows.'; rs11789 = 'Type error in CALC expression.'; rs11790 = 'CHANGETO can be used in only one query form at a time.'; rs11791 = 'Cannot modify CHANGED table.'; rs11792 = 'A field can contain only one CHANGETO expression.'; rs11793 = 'A field cannot contain more than one expression to be inserted.'; rs11794 = 'obsolete'; rs11795 = 'CHANGETO must be followed by the new value for the field.'; rs11796 = 'Checkmark or CALC expressions cannot be used in FIND queries.'; rs11797 = 'Cannot perform operation on CHANGED table together with a CHANGETO query.'; rs11798 = 'chunk'; rs11799 = 'More than 255 fields in ANSWER table.'; rs11800 = 'AS must be followed by the name for the field in the ANSWER table.'; rs11801 = 'DELETE can be used in only one query form at a time.'; rs11802 = 'Cannot perform operation on DELETED table together with a DELETE query.'; rs11803 = 'Cannot delete from the DELETED table.'; rs11804 = 'Example element is used in two fields with incompatible types or with a BLOB.'; rs11805 = 'Cannot use example elements in an OR expression.'; rs11806 = 'Expression in this field has the wrong type.'; rs11807 = 'Extra comma found.'; rs11808 = 'Extra OR found.'; rs11809 = 'One or more query rows do not contribute to the ANSWER.'; rs11810 = 'FIND can be used in only one query form at a time.'; rs11811 = 'FIND cannot be used with the ANSWER table.'; rs11812 = 'A row with GROUPBY must contain SET operations.'; rs11813 = 'GROUPBY can be used only in SET rows.'; rs11814 = 'Use only INSERT, DELETE, SET or FIND in leftmost column.'; rs11815 = 'Use only one INSERT, DELETE, SET or FIND per line.'; rs11816 = 'Syntax error in expression.'; rs11817 = 'INSERT can be used in only one query form at a time.'; rs11818 = 'Cannot perform operation on INSERTED table together with an INSERT query.'; rs11819 = 'INSERT, DELETE, CHANGETO and SET rows may not be checked.'; rs11820 = 'Field must contain an expression to insert (or be blank).'; rs11821 = 'Cannot insert into the INSERTED table.'; rs11822 = 'Variable is an array and cannot be accessed.'; rs11823 = 'Label'; rs11824 = 'Rows of example elements in CALC expression must be linked.'; rs11825 = 'Variable name is too long.'; rs11826 = 'Query may take a long time to process.'; rs11827 = 'Reserved word or one that can''t be used as a variable name.'; rs11828 = 'Missing comma.'; rs11829 = 'Missing ).'; rs11830 = 'Missing right quote.'; rs11831 = 'Cannot specify duplicate column names.'; rs11832 = 'Query has no checked fields.'; rs11833 = 'Example element has no defining occurrence.'; rs11834 = 'No grouping is defined for SET operation.'; rs11835 = 'Query makes no sense.'; rs11836 = 'Cannot use patterns in this context.'; rs11837 = 'Date does not exist.'; rs11838 = 'Variable has not been assigned a value.'; rs11839 = 'Invalid use of example element in summary expression.'; rs11840 = 'Incomplete query statement. Query only contains a SET definition.'; rs11841 = 'Example element with ! makes no sense in expression.'; rs11842 = 'Example element cannot be used more than twice with a ! query.'; rs11843 = 'Row cannot contain expression.'; rs11844 = 'obsolete'; rs11845 = 'obsolete'; rs11846 = 'No permission to insert or delete records.'; rs11847 = 'No permission to modify field.'; rs11848 = 'Field not found in table.'; rs11849 = 'Expecting a column separator in table header.'; rs11850 = 'Expecting a column separator in table.'; rs11851 = 'Expecting column name in table.'; rs11852 = 'Expecting table name.'; rs11853 = 'Expecting consistent number of columns in all rows of table.'; rs11854 = 'Cannot open table.'; rs11855 = 'Field appears more than once in table.'; rs11856 = 'This DELETE, CHANGE or INSERT query has no ANSWER.'; rs11857 = 'Query is not prepared. Properties unknown.'; rs11858 = 'DELETE rows cannot contain quantifier expression.'; rs11859 = 'Invalid expression in INSERT row.'; rs11860 = 'Invalid expression in INSERT row.'; rs11861 = 'Invalid expression in SET definition.'; rs11862 = 'row use'; rs11863 = 'SET keyword expected.'; rs11864 = 'Ambiguous use of example element.'; rs11865 = 'obsolete'; rs11866 = 'obsolete'; rs11867 = 'Only numeric fields can be summed.'; rs11868 = 'Table is write protected.'; rs11869 = 'Token not found.'; rs11870 = 'Cannot use example element with ! more than once in a single row.'; rs11871 = 'Type mismatch in expression.'; rs11872 = 'Query appears to ask two unrelated questions.'; rs11873 = 'Unused SET row.'; rs11874 = 'INSERT, DELETE, FIND, and SET can be used only in the leftmost column.'; rs11875 = 'CHANGETO cannot be used with INSERT, DELETE, SET or FIND.'; rs11876 = 'Expression must be followed by an example element defined in a SET.'; rs11877 = 'Lock failure.'; rs11878 = 'Expression is too long.'; rs11879 = 'Refresh exception during query.'; rs11880 = 'Query canceled.'; rs11881 = 'Unexpected Database Engine error.'; rs11882 = 'Not enough memory to finish operation.'; rs11883 = 'Unexpected exception.'; rs11884 = 'Feature not implemented yet in query.'; rs11885 = 'Query format is not supported.'; rs11886 = 'Query string is empty.'; rs11887 = 'Attempted to prepare an empty query.'; rs11888 = 'Buffer too small to contain query string.'; rs11889 = 'Query was not previously parsed or prepared.'; rs11890 = 'Function called with bad query handle.'; rs11891 = 'QBE syntax error.'; rs11892 = 'Query extended syntax field count error.'; rs11893 = 'Field name in sort or field clause not found.'; rs11894 = 'Table name in sort or field clause not found.'; rs11895 = 'Operation is not supported on BLOB fields.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_BLOBMODIFIED Constant

nxllBdeStrings.rsDBIERR_BLOBMODIFIED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_BLOBMODIFIED = 'BLOB has been modified.';
File

nxllBdeStrings

Description

rs12290 = 'Not implemented yet.'; rs12291 = 'SQL replicas not supported.'; rs12292 = 'Non-blob column in table required to perform operation.'; rs12293 = 'Multiple connections not supported.'; rs12294 = 'Full dBASE expressions not supported.'; rs12545 = 'Invalid database alias specification.'; rs12546 = 'Unknown database type.'; rs12547 = 'Corrupt system configuration file.'; rs12548 = 'Network type unknown.'; rs12549 = 'Not on the network.'; rs12550 = 'Invalid configuration parameter.'; rs12801 = 'Object implicitly dropped.'; rs12802 = 'Object may be truncated.'; rs12803 = 'Object implicitly modified.'; rs12804 = 'Should field constraints be checked?'; rs12805 = 'Validity check field modified.'; rs12806 = 'Table level changed.'; rs12807 = 'Copy linked tables?'; rs12809 = 'Object implicitly truncated.'; rs12810 = 'Validity check will not be enforced.'; rs12811 = 'Multiple records found, but only one was expected.'; rs12812 = 'Field will be trimmed, cannot put master records into PROBLEM table.'; rs13057 = 'File already exists.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_BOF Constant

nxllBdeStrings.rsDBIERR_BOF Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_BOF = 'At beginning of table.';
File

nxllBdeStrings

Description

rs8456 = 'Cannot locate IDAPI32 .DLL.'; rs8457 = 'Cannot load IDAPI32 .DLL.'; rs8458 = 'Cannot load an IDAPI service library.'; rs8459 = 'Cannot create or open temporary file.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_CHECKCONSTRAINTFAILED Constant

nxllBdeStrings.rsDBIERR_CHECKCONSTRAINTFAILED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_CHECKCONSTRAINTFAILED = 'Expression validity check failed.';
File

nxllBdeStrings

Description

rs9741 = 'Link to master table already defined.'; rs9742 = 'Master table is open.'; rs9743 = 'Detail table(s) exist.'; rs9744 = 'Master has detail records. Cannot empty it.'; rs9745 = 'Self referencing referential integrity must be entered one at a time with no other changes to the table'; rs9746 = 'Detail table is open.'; rs9747 = 'Cannot make this master a detail of another table if its details are not empty.'; rs9748 = 'Referential integrity fields must be indexed.'; rs9749 = 'A table linked by referential integrity requires password to open.'; rs9750 = 'Field(s) linked to more than one master.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_CLIENTSLIMIT Constant

nxllBdeStrings.rsDBIERR_CLIENTSLIMIT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_CLIENTSLIMIT = 'Too many clients.';
File

nxllBdeStrings

Description

rs9480 = 'Too many sessions from this workstation.'; rs9481 = 'Serial number limit (Paradox).'; rs9482 = 'Some internal limit (see context).'; rs9483 = 'Too many open tables.'; rs9484 = 'Too many cursors per table.'; rs9485 = 'Too many record locks on table.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_DEADLOCK Constant

nxllBdeStrings.rsDBIERR_DEADLOCK Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_DEADLOCK = 'A deadlock was detected. You need to rollback this transaction.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_DEADLOCK.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_DETAILRECORDSEXIST Constant

nxllBdeStrings.rsDBIERR_DETAILRECORDSEXIST Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_DETAILRECORDSEXIST = 'Master has detail records. Cannot delete or modify.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_DETAILRECORDSEXIST.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_DIFFERENTTABLES Constant

nxllBdeStrings.rsDBIERR_DIFFERENTTABLES Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_DIFFERENTTABLES = 'Cannot set cursor of one table to another.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_DIFFERENTTABLES.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_DIRNOACCESS Constant

nxllBdeStrings.rsDBIERR_DIRNOACCESS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_DIRNOACCESS = 'Cannot access directory.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_DIRNOACCESS.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_ENDOFBLOB Constant

nxllBdeStrings.rsDBIERR_ENDOFBLOB Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_ENDOFBLOB = 'End of BLOB.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_ENDOFBLOB.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_EOF Constant

nxllBdeStrings.rsDBIERR_EOF Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_EOF = 'At end of table.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_EOF.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FIELDISBLANK Constant

nxllBdeStrings.rsDBIERR_FIELDISBLANK Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FIELDISBLANK = 'Field is blank.';
File

nxllBdeStrings

Description

rs9735 = 'Master table level is incorrect.'; rs9736 = 'Field value out of lookup table range.'; rs9737 = 'Lookup Table Open operation failed.'; rs9738 = 'Detail Table Open operation failed.'; rs9739 = 'Master Table Open operation failed.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FILECORRUPT Constant

nxllBdeStrings.rsDBIERR_FILECORRUPT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FILECORRUPT = 'Corrupt file - other than header.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_FILECORRUPT.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FILELOCKED Constant

nxllBdeStrings.rsDBIERR_FILELOCKED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FILELOCKED = 'File is locked.';
File

nxllBdeStrings

Description

rs10242 = 'Unlock failed.'; rs10243 = 'Table is busy.'; rs10244 = 'Directory is busy.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FILENOACCESS Constant

nxllBdeStrings.rsDBIERR_FILENOACCESS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FILENOACCESS = 'Cannot access file. File may be in use by another process.';
File

nxllBdeStrings

Description

rs9220 = 'File Delete operation failed.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FLDLIMIT Constant

nxllBdeStrings.rsDBIERR_FLDLIMIT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FLDLIMIT = 'Too many fields.';
File

nxllBdeStrings

Description

rs9488 = 'Too many sessions.'; rs9489 = 'Too many open databases.'; rs9490 = 'Too many passwords.'; rs9491 = 'Too many active drivers.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_FORIEGNKEYERR Constant

nxllBdeStrings.rsDBIERR_FORIEGNKEYERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_FORIEGNKEYERR = 'Master record missing.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_FORIEGNKEYERR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_HEADERCORRUPT Constant

nxllBdeStrings.rsDBIERR_HEADERCORRUPT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_HEADERCORRUPT = 'Corrupt table/index header.';
File

nxllBdeStrings

Description

rs8713 = 'Could not find family member.'; rs8714 = 'BLOB file is missing.'; rs8715 = 'Could not find language driver.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INDEXCORRUPT Constant

nxllBdeStrings.rsDBIERR_INDEXCORRUPT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INDEXCORRUPT = 'Corrupt index.';
File

nxllBdeStrings

Description

rs8963 = 'Corrupt Memo/BLOB file.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INDEXEXISTS Constant

nxllBdeStrings.rsDBIERR_INDEXEXISTS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INDEXEXISTS = 'Index already exists.';
File

nxllBdeStrings

Description

rs10025 = 'Table has too many users.'; rs10026 = 'Cannot evaluate Key or Key does not pass filter condition.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INDEXLIMIT Constant

nxllBdeStrings.rsDBIERR_INDEXLIMIT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INDEXLIMIT = 'Too many indexes on table.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INDEXLIMIT.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDALIASNAME Constant

nxllBdeStrings.rsDBIERR_INVALIDALIASNAME Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDALIASNAME = 'Invalid alias name.';
File

nxllBdeStrings

Description

rs10052 = 'Invalid table create request'; rs10053 = 'Invalid table delete request'; rs10054 = 'Invalid index create request'; rs10055 = 'Invalid index delete request'; rs10056 = 'Invalid table specified'; rs10058 = 'Invalid Time.'; rs10059 = 'Invalid Date.'; rs10060 = 'Invalid Datetime'; rs10061 = 'Tables in different directories'; rs10062 = 'Mismatch in the number of arguments'; rs10063 = 'Function not found in service library.'; rs10064 = 'Must use baseorder for this operation.'; rs10065 = 'Invalid procedure name'; rs10066 = 'The field map is invalid.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDBLOBHANDLE Constant

nxllBdeStrings.rsDBIERR_INVALIDBLOBHANDLE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDBLOBHANDLE = 'Invalid BLOB handle in record buffer.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBHANDLE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDBLOBLEN Constant

nxllBdeStrings.rsDBIERR_INVALIDBLOBLEN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDBLOBLEN = 'Invalid BLOB length.';
File

nxllBdeStrings

Description

rs10028 = 'Index is open.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDBLOBOFFSET Constant

nxllBdeStrings.rsDBIERR_INVALIDBLOBOFFSET Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDBLOBOFFSET = 'Invalid offset into the BLOB.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDBLOBOFFSET.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDBOOKMARK Constant

nxllBdeStrings.rsDBIERR_INVALIDBOOKMARK Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDBOOKMARK = 'Bookmarks do not match table.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDBOOKMARK.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDDESC Constant

nxllBdeStrings.rsDBIERR_INVALIDDESC Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDDESC = 'Invalid descriptor.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDDESC.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDDESCNUM Constant

nxllBdeStrings.rsDBIERR_INVALIDDESCNUM Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDDESCNUM = 'Invalid descriptor number.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDDESCNUM.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDDIR Constant

nxllBdeStrings.rsDBIERR_INVALIDDIR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDDIR = 'The alias references a directory that does not exist.';
File

nxllBdeStrings

Description

rs10016 = 'No callback function.'; rs10017 = 'Invalid callback buffer length.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFIELDNAME Constant

nxllBdeStrings.rsDBIERR_INVALIDFIELDNAME Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFIELDNAME = 'Invalid field name.';
File

nxllBdeStrings

Description

rs10037 = 'Multi-level cascade is not supported.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFILEEXTN Constant

nxllBdeStrings.rsDBIERR_INVALIDFILEEXTN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFILEEXTN = 'Invalid file extension.';
File

nxllBdeStrings

Description

rs10040 = 'Invalid linked cursor expression.'; rs10041 = 'Name is reserved.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFILTER Constant

nxllBdeStrings.rsDBIERR_INVALIDFILTER Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFILTER = 'Invalid Filter';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDFILTER.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFLDDESC Constant

nxllBdeStrings.rsDBIERR_INVALIDFLDDESC Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFLDDESC = 'Invalid field descriptor.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDDESC.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFLDTYPE Constant

nxllBdeStrings.rsDBIERR_INVALIDFLDTYPE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFLDTYPE = 'Invalid field type.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDTYPE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDFLDXFORM Constant

nxllBdeStrings.rsDBIERR_INVALIDFLDXFORM Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDFLDXFORM = 'Invalid field transformation.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDFLDXFORM.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDHNDL Constant

nxllBdeStrings.rsDBIERR_INVALIDHNDL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDHNDL = 'Invalid handle to the function.';
File

nxllBdeStrings

Description

rs9987 = 'Invalid file name.'; rs9988 = 'File does not exist.'; rs9989 = 'Invalid option.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDIDXDESC Constant

nxllBdeStrings.rsDBIERR_INVALIDIDXDESC Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDIDXDESC = 'Invalid index descriptor.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDIDXDESC.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDINDEXNAME Constant

nxllBdeStrings.rsDBIERR_INVALIDINDEXNAME Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDINDEXNAME = 'Invalid index name.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXNAME.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDINDEXSTRUCT Constant

nxllBdeStrings.rsDBIERR_INVALIDINDEXSTRUCT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDINDEXSTRUCT = 'Invalid array of index descriptors.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDINDEXSTRUCT.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDLANGDRV Constant

nxllBdeStrings.rsDBIERR_INVALIDLANGDRV Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDLANGDRV = 'Invalid language Driver.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDLANGDRV.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDNAME Constant

nxllBdeStrings.rsDBIERR_INVALIDNAME Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDNAME = 'Invalid name.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDNAME.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDPARAM Constant

nxllBdeStrings.rsDBIERR_INVALIDPARAM Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDPARAM = 'Invalid parameter.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDPARAM.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDPASSWORD Constant

nxllBdeStrings.rsDBIERR_INVALIDPASSWORD Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDPASSWORD = 'Invalid password given.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDPASSWORD.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDRECSTRUCT Constant

nxllBdeStrings.rsDBIERR_INVALIDRECSTRUCT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDRECSTRUCT = 'Invalid record structure.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDRECSTRUCT.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDTABLENAME Constant

nxllBdeStrings.rsDBIERR_INVALIDTABLENAME Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDTABLENAME = 'Invalid table name.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDTABLENAME.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDUSRPASS Constant

nxllBdeStrings.rsDBIERR_INVALIDUSRPASS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDUSRPASS = 'Unknown user name or password.';
File

nxllBdeStrings

Description

rs10032 = 'Need to do (hard) restructure.'; rs10033 = 'Invalid mode.'; rs10034 = 'Cannot close index.'; rs10035 = 'Index is being used to order table.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_INVALIDXLATION Constant

nxllBdeStrings.rsDBIERR_INVALIDXLATION Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_INVALIDXLATION = 'Translate Error. Value out of bounds.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_INVALIDXLATION.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_KEYVIOL Constant

nxllBdeStrings.rsDBIERR_KEYVIOL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_KEYVIOL = 'Key violation.';
File

nxllBdeStrings

Description

rs9493 = 'Too many table locks.'; rs9494 = 'Too many open BLOBs.'; rs9495 = 'Lock file has grown too large.'; rs9496 = 'Too many open queries.'; rs9498 = 'Too many BLOBs.'; rs9499 = 'File name is too long for a Paradox version 5.0 table.'; rs9500 = 'Row fetch limit exceeded.'; rs9501 = 'Long name not allowed for this tablelevel.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_LOCKED Constant

nxllBdeStrings.rsDBIERR_LOCKED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_LOCKED = 'Record locked by another user.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_LOCKED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_LOCKTIMEOUT Constant

nxllBdeStrings.rsDBIERR_LOCKTIMEOUT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_LOCKTIMEOUT = 'Lock time out.';
File

nxllBdeStrings

Description

rs10246 = 'Directory is locked.'; rs10247 = 'Record already locked by this session.'; rs10248 = 'Object not locked.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_MAXVALERR Constant

nxllBdeStrings.rsDBIERR_MAXVALERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_MAXVALERR = 'Maximum validity check failed.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_MAXVALERR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_MINVALERR Constant

nxllBdeStrings.rsDBIERR_MINVALERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_MINVALERR = 'Minimum validity check failed.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_MINVALERR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NA Constant

nxllBdeStrings.rsDBIERR_NA Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NA = 'Operation not applicable.';
File

nxllBdeStrings

Description

rs10754 = 'BLOB already opened.'; rs10755 = 'BLOB not opened.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NAMENOTUNIQUE Constant

nxllBdeStrings.rsDBIERR_NAMENOTUNIQUE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NAMENOTUNIQUE = 'Name not unique in this context.';
File

nxllBdeStrings

Description

rs10006 = 'Invalid array of validity check descriptors.'; rs10007 = 'Invalid array of referential integrity descriptors.'; rs10008 = 'Invalid ordering of tables during restructure.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NEEDEXCLACCESS Constant

nxllBdeStrings.rsDBIERR_NEEDEXCLACCESS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NEEDEXCLACCESS = 'Object cannot be opened for exclusive use.';
File

nxllBdeStrings

Description

rs10250 = 'Key group is locked.'; rs10251 = 'Table lock was lost.'; rs10252 = 'Exclusive access was lost.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOACTIVETRAN Constant

nxllBdeStrings.rsDBIERR_NOACTIVETRAN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOACTIVETRAN = 'No user transaction is currently in progress.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOACTIVETRAN.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOASSOCINDEX Constant

nxllBdeStrings.rsDBIERR_NOASSOCINDEX Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOASSOCINDEX = 'No associated index.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOASSOCINDEX.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOCURRREC Constant

nxllBdeStrings.rsDBIERR_NOCURRREC Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOCURRREC = 'No current record.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOCURRREC.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOMEMORY Constant

nxllBdeStrings.rsDBIERR_NOMEMORY Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOMEMORY = 'Insufficient memory for this operation.';
File

nxllBdeStrings

Description

rs9222 = 'Access to table disabled because of previous error.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOSERVERSW Constant

nxllBdeStrings.rsDBIERR_NOSERVERSW Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOSERVERSW = 'No ServerEngine is connected to the CommandHandler.';
File

nxllBdeStrings

Description

rs11058 = 'Share violation.'; rs11059 = 'Lock violation.'; rs11060 = 'Critical DOS Error.'; rs11061 = 'Drive not ready.'; rs11108 = 'Not exact read/write.'; rs11109 = 'Operating system network error.'; rs11110 = 'Error from NOVELL file server.'; rs11111 = 'NOVELL server out of memory.'; rs11112 = 'Record already locked by this workstation.'; rs11113 = 'Record not locked.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOSUCHFILTER Constant

nxllBdeStrings.rsDBIERR_NOSUCHFILTER Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOSUCHFILTER = 'Filter handle is invalid';
File

nxllBdeStrings

Description

rs10044 = 'Alias is not currently opened.'; rs10045 = 'Incompatible record structures.'; rs10046 = 'Name is reserved by DOS.'; rs10047 = 'Destination must be indexed.'; rs10048 = 'Invalid index type'; rs10049 = 'Language Drivers of Table and Index do not match';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOSUCHINDEX Constant

nxllBdeStrings.rsDBIERR_NOSUCHINDEX Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOSUCHINDEX = 'Index does not exist.';
File

nxllBdeStrings

Description

rs9993 = 'Cannot redefine primary key.'; rs9994 = 'Cannot change this RINTDesc.'; rs9995 = 'Foreign and primary key do not match.'; rs9996 = 'Invalid modify request.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOSUCHTABLE Constant

nxllBdeStrings.rsDBIERR_NOSUCHTABLE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOSUCHTABLE = 'Table does not exist.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOSUCHTABLE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOTABLOB Constant

nxllBdeStrings.rsDBIERR_NOTABLOB Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOTABLOB = 'Field is not a BLOB.';
File

nxllBdeStrings

Description

rs10504 = 'Insufficient SQL rights for operation.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOTINDEXED Constant

nxllBdeStrings.rsDBIERR_NOTINDEXED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOTINDEXED = 'Table is not indexed.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOTINDEXED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOTSAMESESSION Constant

nxllBdeStrings.rsDBIERR_NOTSAMESESSION Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOTSAMESESSION = 'Objects are not owned by the same session.';
File

nxllBdeStrings

Description

rs10758 = 'Engine not initialized.'; rs10759 = 'Attempt to re-initialize Engine.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOTSUFFTABLERIGHTS Constant

nxllBdeStrings.rsDBIERR_NOTSUFFTABLERIGHTS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOTSUFFTABLERIGHTS = 'Insufficient table rights for operation.';
File

nxllBdeStrings

Description

rs10497 = 'Insufficient field rights for operation.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NOTSUPPORTED Constant

nxllBdeStrings.rsDBIERR_NOTSUPPORTED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NOTSUPPORTED = 'Capability not supported.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NOTSUPPORTED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadBlockNr Constant

nxllBdeStrings.rsDBIERR_NX_BadBlockNr Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadBlockNr = 'Block number is either < 0, or >= number of blocks in file';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadBlockNr.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadDataBlock Constant

nxllBdeStrings.rsDBIERR_NX_BadDataBlock Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadDataBlock = 'Block read from file is not a data block';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadDataBlock.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadHeapBlock Constant

nxllBdeStrings.rsDBIERR_NX_BadHeapBlock Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadHeapBlock = 'Block read from file is not a heap block';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadHeapBlock.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadIndex Constant

nxllBdeStrings.rsDBIERR_NX_BadIndex Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadIndex = 'Index number passed to routine is out of range';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadIndex.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadInxBlock Constant

nxllBdeStrings.rsDBIERR_NX_BadInxBlock Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadInxBlock = 'Block read from file is not an index block';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadInxBlock.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadRefNr Constant

nxllBdeStrings.rsDBIERR_NX_BadRefNr Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadRefNr = 'Record reference number is invalid';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadRefNr.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadStreamBlock Constant

nxllBdeStrings.rsDBIERR_NX_BadStreamBlock Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadStreamBlock = 'Block read from file is not a stream block';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BadStreamBlock.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BadStruct Constant

nxllBdeStrings.rsDBIERR_NX_BadStruct Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BadStruct = 'TnxBaseFile contains invalid data';
File

nxllBdeStrings

Description

rs13313 = 'Different sort order.'; rs13314 = 'Directory in use by earlier version of Paradox.'; rs13315 = 'Needs Paradox 3.5-compatible language driver.'; rs13569 = 'Data Dictionary is corrupt'; rs13570 = 'Data Dictionary Info Blob corrupted'; rs13571 = 'Data Dictionary Schema is corrupt'; rs13572 = 'Attribute Type exists'; rs13573 = 'Invalid Object Type'; rs13574 = 'Invalid Relation Type'; rs13575 = 'View already exists'; rs13576 = 'No such View exists'; rs13577 = 'Invalid Record Constraint'; rs13578 = 'Object is in a Logical DB'; rs13579 = 'Dictionary already exists'; rs13580 = 'Dictionary does not exist'; rs13581 = 'Dictionary database does not exist'; rs13582 = 'Dictionary info is out of date - needs Refresh'; rs13584 = 'Invalid Dictionary Name'; rs13585 = 'Dependent Objects exist'; rs13586 = 'Too many Relationships for this Object Type'; rs13587 = 'Relationships to the Object exist'; rs13588 = 'Dictionary Exchange File is corrupt'; rs13589 = 'Dictionary Exchange File Version mismatch'; rs13590 = 'Dictionary Object Type Mismatch'; rs13591 = 'Object exists in Target Dictionary'; rs13592 = 'Cannot access Data Dictionary'; rs13593 = 'Cannot create Data Dictionary'; rs13594 = 'Cannot open Database';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_BLOBTooBig Constant

nxllBdeStrings.rsDBIERR_NX_BLOBTooBig Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_BLOBTooBig = 'BLOB size exceeds maximum size.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_BLOBTooBig.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_CloseFailed Constant

nxllBdeStrings.rsDBIERR_NX_CloseFailed Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_CloseFailed = 'File could not be closed';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_CloseFailed.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_CopyFile Constant

nxllBdeStrings.rsDBIERR_NX_CopyFile Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_CopyFile = 'Error when copying a file';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_CopyFile.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_CorruptTrans Constant

nxllBdeStrings.rsDBIERR_NX_CorruptTrans Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_CorruptTrans = 'The transaction was corrupt due to an earlier failure. No commit took place. You need to rollback this transaction.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_CorruptTrans.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_DeleteFile Constant

nxllBdeStrings.rsDBIERR_NX_DeleteFile Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_DeleteFile = 'Error when deleting a file';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_DeleteFile.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_DICT_DUPAUTOINC Constant

nxllBdeStrings.rsDBIERR_NX_DICT_DUPAUTOINC Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_DICT_DUPAUTOINC = 'Duplicated autoinc field';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPAUTOINC.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_DICT_DUPRECREV Constant

nxllBdeStrings.rsDBIERR_NX_DICT_DUPRECREV Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_DICT_DUPRECREV = 'Duplicated RecRev field';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_DICT_DUPRECREV.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_DICT_OBJINUSE Constant

nxllBdeStrings.rsDBIERR_NX_DICT_OBJINUSE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_DICT_OBJINUSE = 'Object is currently in use';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_DICT_OBJINUSE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_DICT_READONLY Constant

nxllBdeStrings.rsDBIERR_NX_DICT_READONLY Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_DICT_READONLY = 'The data dictionary is read only';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_DICT_READONLY.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_FileBLOBClose Constant

nxllBdeStrings.rsDBIERR_NX_FileBLOBClose Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_FileBLOBClose = 'An error occurred when closing the external file for a file BLOB';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBClose.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_FileBLOBOpen Constant

nxllBdeStrings.rsDBIERR_NX_FileBLOBOpen Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_FileBLOBOpen = 'An error occurred when opening the external file for a file BLOB';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBOpen.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_FileBLOBRead Constant

nxllBdeStrings.rsDBIERR_NX_FileBLOBRead Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_FileBLOBRead = 'An error occurred when reading the external file for a file BLOB';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_FileBLOBRead.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_FilterTimeout Constant

nxllBdeStrings.rsDBIERR_NX_FilterTimeout Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_FilterTimeout = 'The filter timed out.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_FilterTimeout.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_GeneralTimeout Constant

nxllBdeStrings.rsDBIERR_NX_GeneralTimeout Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_GeneralTimeout = 'The operation could not be completed in the allotted time.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_GeneralTimeout.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_IncompatDict Constant

nxllBdeStrings.rsDBIERR_NX_IncompatDict Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_IncompatDict = 'The cursor dictionaries are incompatible. Verify the correct field types, lengths, units, and decimal places have been specified.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_IncompatDict.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_INCOMPATHEADER Constant

nxllBdeStrings.rsDBIERR_NX_INCOMPATHEADER Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_INCOMPATHEADER = 'Sub-Engine is incompatible with the selected file header structure.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATHEADER.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_INCOMPATSTREAM Constant

nxllBdeStrings.rsDBIERR_NX_INCOMPATSTREAM Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_INCOMPATSTREAM = 'Incompatible stream';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_INCOMPATSTREAM.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_INDEXNOTEMPTY Constant

nxllBdeStrings.rsDBIERR_NX_INDEXNOTEMPTY Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_INDEXNOTEMPTY = 'Index is not empty.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_INDEXNOTEMPTY.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_INVALIDSEGNR Constant

nxllBdeStrings.rsDBIERR_NX_INVALIDSEGNR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_INVALIDSEGNR = 'Invalid segment number';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_INVALIDSEGNR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_LICENSE_EXPIRED Constant

nxllBdeStrings.rsDBIERR_NX_LICENSE_EXPIRED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_LICENSE_EXPIRED = 'Server License Expired.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_LICENSE_EXPIRED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_LITE Constant

nxllBdeStrings.rsDBIERR_NX_LITE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_LITE = 'The application has reached the limit of the free NexusDB Lite database engine. Please contact the distributor of the application for an updated version with higher capacity.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_LITE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_MAXKEYSIZE Constant

nxllBdeStrings.rsDBIERR_NX_MAXKEYSIZE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_MAXKEYSIZE = 'Maximum key size has been exceeded';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_MAXKEYSIZE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_MAXRECORDSIZE Constant

nxllBdeStrings.rsDBIERR_NX_MAXRECORDSIZE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_MAXRECORDSIZE = 'Maximum record size has been exceeded';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_MAXRECORDSIZE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_MAXUSERS Constant

nxllBdeStrings.rsDBIERR_NX_MAXUSERS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_MAXUSERS = 'Maximum number of users already logged in. Can''t connect to this server.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_MAXUSERS.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_NoSessionSE Constant

nxllBdeStrings.rsDBIERR_NX_NoSessionSE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_NoSessionSE = 'The session is not connected to a server engine.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_NoSessionSE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_RECOVERFAILED Constant

nxllBdeStrings.rsDBIERR_NX_RECOVERFAILED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_RECOVERFAILED = 'Recovery failed.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_RECOVERFAILED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_RegisterFHAF Constant

nxllBdeStrings.rsDBIERR_NX_RegisterFHAF Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_RegisterFHAF = 'A TnxServerEngine without file header access factories has been detected. Please add "nxseAllEngines" to your program''s USES clause, and recompile.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_RegisterFHAF.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_RenameFile Constant

nxllBdeStrings.rsDBIERR_NX_RenameFile Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_RenameFile = 'Error when renaming a file';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_RenameFile.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_SameFolder Constant

nxllBdeStrings.rsDBIERR_NX_SameFolder Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_SameFolder = 'The databases may not reference the same folder for this operation.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_SameFolder.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_SameTable Constant

nxllBdeStrings.rsDBIERR_NX_SameTable Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_SameTable = 'The cursors may not reference the same table for this operation.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_SameTable.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_SEGMENTDELETED Constant

nxllBdeStrings.rsDBIERR_NX_SEGMENTDELETED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_SEGMENTDELETED = 'Segment has been deleted';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_SEGMENTDELETED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_SERVERNAMENOTSET Constant

nxllBdeStrings.rsDBIERR_NX_SERVERNAMENOTSET Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_SERVERNAMENOTSET = 'Servername of the transport is not set';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_SERVERNAMENOTSET.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_SQLSIGNAL Constant

nxllBdeStrings.rsDBIERR_NX_SQLSIGNAL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_SQLSIGNAL = 'A SIGNAL has been raised';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_SQLSIGNAL.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_TableVersion Constant

nxllBdeStrings.rsDBIERR_NX_TableVersion Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_TableVersion = 'The table cannot be opened because it was created with a newer version of NexusDB.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_TableVersion.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_TempStorageFull Constant

nxllBdeStrings.rsDBIERR_NX_TempStorageFull Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_TempStorageFull = 'Temporary storage is full. More space may need to be allocated.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_TempStorageFull.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_TRIAL Constant

nxllBdeStrings.rsDBIERR_NX_TRIAL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_TRIAL = 'The NexusDB Trial Version has timed out. Please close and restart your application, or in Delphi, close and reopen forms.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_TRIAL.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_TS_FULL Constant

nxllBdeStrings.rsDBIERR_NX_TS_FULL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_TS_FULL = 'Temporary Storage: Full';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_TS_FULL.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_TS_INVALIDBLOCK Constant

nxllBdeStrings.rsDBIERR_NX_TS_INVALIDBLOCK Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_TS_INVALIDBLOCK = 'Temporary Storage: Invalid block number';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_TS_INVALIDBLOCK.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_Unknown Constant

nxllBdeStrings.rsDBIERR_NX_Unknown Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_Unknown = 'Unknown (server exception object has unknown error code)';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_Unknown.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_UnknownExcp Constant

nxllBdeStrings.rsDBIERR_NX_UnknownExcp Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_UnknownExcp = 'Unknown (unexpected exception object raised)';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_UnknownExcp.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_UnknownMsg Constant

nxllBdeStrings.rsDBIERR_NX_UnknownMsg Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_UnknownMsg = 'Message is unrecognized.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_UnknownMsg.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_UNSUPDICTDESCR Constant

nxllBdeStrings.rsDBIERR_NX_UNSUPDICTDESCR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_UNSUPDICTDESCR = 'Unsupported dictionary descriptor';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPDICTDESCR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_UNSUPHEADER Constant

nxllBdeStrings.rsDBIERR_NX_UNSUPHEADER Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_UNSUPHEADER = 'Specified file header access is not supported';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPHEADER.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_NX_UNSUPSUBENGINE Constant

nxllBdeStrings.rsDBIERR_NX_UNSUPSUBENGINE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_NX_UNSUPSUBENGINE = 'Specified sub-engine is not supported';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_NX_UNSUPSUBENGINE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_OBJNOTFOUND Constant

nxllBdeStrings.rsDBIERR_OBJNOTFOUND Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_OBJNOTFOUND = 'Could not find object.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_OBJNOTFOUND.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_OPTRECLOCKFAILED Constant

nxllBdeStrings.rsDBIERR_OPTRECLOCKFAILED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_OPTRECLOCKFAILED = 'Couldn''t perform the edit because another user changed the record.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKFAILED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_OPTRECLOCKRECDEL Constant

nxllBdeStrings.rsDBIERR_OPTRECLOCKRECDEL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_OPTRECLOCKRECDEL = 'Couldn''t perform the edit because another user deleted or moved the record.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_OPTRECLOCKRECDEL.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_OSUNKNOWN Constant

nxllBdeStrings.rsDBIERR_OSUNKNOWN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_OSUNKNOWN = 'Unknown internal operating system error.';
File

nxllBdeStrings

Description

rs10765 = 'Table(s) open. Cannot perform this operation.'; rs10766 = 'Table does not support this operation.'; rs10767 = 'Index is read only.'; rs10768 = 'Table does not support this operation because it is not uniquely indexed.'; rs10769 = 'Operation must be performed on the current session.'; rs10770 = 'Invalid use of keyword.'; rs10771 = 'Connection is in use by another statement.'; rs10772 = 'Passthrough SQL connection must be shared'; rs11009 = 'Invalid function number.'; rs11010 = 'File or directory does not exist.'; rs11011 = 'Path not found.'; rs11012 = 'Too many open files. You may need to increase MAXFILEHANDLE limit in IDAPI configuration.'; rs11013 = 'Permission denied.'; rs11014 = 'Bad file number.'; rs11015 = 'Memory blocks destroyed.'; rs11016 = 'Not enough memory.'; rs11017 = 'Invalid memory block address.'; rs11018 = 'Invalid environment.'; rs11019 = 'Invalid format.'; rs11020 = 'Invalid access code.'; rs11021 = 'Invalid data.'; rs11023 = 'Device does not exist.'; rs11024 = 'Attempt to remove current directory.'; rs11025 = 'Not same device.'; rs11026 = 'No more files.'; rs11027 = 'Invalid argument.'; rs11028 = 'Argument list is too long.'; rs11029 = 'Execution format error.'; rs11030 = 'Cross-device link.'; rs11041 = 'Math argument.'; rs11042 = 'Result is too large.'; rs11043 = 'File already exists.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_OUTOFRANGE Constant

nxllBdeStrings.rsDBIERR_OUTOFRANGE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_OUTOFRANGE = 'Number is out of range.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_OUTOFRANGE.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_READERR Constant

nxllBdeStrings.rsDBIERR_READERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_READERR = 'Read failure.';
File

nxllBdeStrings

Description

rs8966 = 'Corrupt lock file.'; rs8967 = 'Corrupt family file.'; rs8968 = 'Corrupt or missing .VAL file.'; rs8969 = 'Foreign index file format.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_READONLYDB Constant

nxllBdeStrings.rsDBIERR_READONLYDB Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_READONLYDB = 'Database is read only.';
File

nxllBdeStrings

Description

rs10499 = 'Insufficient family rights for operation.'; rs10500 = 'This directory is read only.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_READONLYFLD Constant

nxllBdeStrings.rsDBIERR_READONLYFLD Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_READONLYFLD = 'Trying to modify read-only field.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_READONLYFLD.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_RECDELETED Constant

nxllBdeStrings.rsDBIERR_RECDELETED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_RECDELETED = 'Record/Key deleted.';
File

nxllBdeStrings

Description

rsDBIERR_RECMOVED = 'Record moved because key value changed.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_RECGROUPCONFLICT Constant

nxllBdeStrings.rsDBIERR_RECGROUPCONFLICT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_RECGROUPCONFLICT = 'Conflicting lock in this session.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_RECGROUPCONFLICT.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_RECLOCKFAILED Constant

nxllBdeStrings.rsDBIERR_RECLOCKFAILED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_RECLOCKFAILED = 'Record lock failed.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_RECLOCKFAILED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_RECNOTFOUND Constant

nxllBdeStrings.rsDBIERR_RECNOTFOUND Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_RECNOTFOUND = 'Could not find record.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_RECNOTFOUND.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_REENTERED Constant

nxllBdeStrings.rsDBIERR_REENTERED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_REENTERED = 'System has been illegally re-entered.';
File

nxllBdeStrings

Description

rs8449 = 'Cannot open a system file.'; rs8450 = 'I/O error on a system file.'; rs8451 = 'Data structure corruption.'; rs8452 = 'Cannot find Engine configuration file.'; rs8453 = 'Cannot write to Engine configuration file.'; rs8454 = 'Cannot initialize with different configuration file.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_REQDERR Constant

nxllBdeStrings.rsDBIERR_REQDERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_REQDERR = 'Field value required.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_REQDERR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_SERVERCOMMLOST Constant

nxllBdeStrings.rsDBIERR_SERVERCOMMLOST Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_SERVERCOMMLOST = 'Lost communication with network server.';
File

nxllBdeStrings

Description

rs11265 = 'Network initialization failed.'; rs11266 = 'Network user limit exceeded.'; rs11267 = 'Wrong .NET file version.'; rs11268 = 'Cannot lock network file.'; rs11269 = 'Directory is not private.'; rs11270 = 'Directory is controlled by other .NET file.'; rs11271 = 'Unknown network error.'; rs11272 = 'Not initialized for accessing network files.'; rs11273 = 'SHARE not loaded. It is required to share local files.'; rs11274 = 'Not on a network. Not logged in or wrong network driver.'; rs11275 = 'Lost communication with SQL server.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_SERVERNOTFOUND Constant

nxllBdeStrings.rsDBIERR_SERVERNOTFOUND Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_SERVERNOTFOUND = 'Cannot locate or connect to network server.';
File

nxllBdeStrings

Description

rs11277 = 'Cannot locate or connect to SQL server.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_SERVERVERSION Constant

nxllBdeStrings.rsDBIERR_SERVERVERSION Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_SERVERVERSION = 'Server is incompatible version.';
File

nxllBdeStrings

Description

rs11897 = 'Query must be restarted.'; rs11898 = 'Unknown answer table type.'; rs11926 = 'Blob cannot be used as grouping field.'; rs11927 = 'Query properties have not been fetched.'; rs11928 = 'Answer table is of unsuitable type.'; rs11929 = 'Answer table is not yet supported under server alias.'; rs11930 = 'Non-null blob field required. Can''t insert records'; rs11931 = 'Unique index required to perform changeto'; rs11932 = 'Unique index required to delete records'; rs11933 = 'Update of table on the server failed.'; rs11934 = 'Can''t process this query remotely.'; rs11935 = 'Unexpected end of command.'; rs11936 = 'Parameter not set in query string.'; rs11937 = 'Query string is too long.'; rs11946 = 'No such table or correlation name.'; rs11947 = 'Expression has ambiguous data type.'; rs11948 = 'Field in order by must be in result set.'; rs11949 = 'General parsing error.'; rs11950 = 'Record or field constraint failed.'; rs11951 = 'Field in group by must be in result set.'; rs11952 = 'User defined function is not defined.'; rs11953 = 'Unknown error from User defined function.'; rs11954 = 'Single row subquery produced more than one row.'; rs11955 = 'Expressions in group by are not supported.'; rs11956 = 'Queries on text or ascii tables is not supported.'; rs11957 = 'ANSI join keywords USING and NATURAL are not supported in this release.'; rs11958 = 'SELECT DISTINCT may not be used with UNION unless UNION ALL is used.'; rs11959 = 'GROUP BY is required when both aggregate and non-aggregate fields are used in result set.'; rs11960 = 'INSERT and UPDATE operations are not supported on autoincrement field type.'; rs11961 = 'UPDATE on Primary Key of a Master Table may modify more than one record.'; rs12033 = 'Interface mismatch. Engine version different.'; rs12034 = 'Index is out of date.'; rs12035 = 'Older version (see context).'; rs12036 = 'VAL file is out of date.'; rs12037 = 'BLOB file version is too old.'; rs12038 = 'Query and Engine DLLs are mismatched.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TABLEEXISTS Constant

nxllBdeStrings.rsDBIERR_TABLEEXISTS Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TABLEEXISTS = 'Table already exists.';
File

nxllBdeStrings

Description

rs13059 = 'General SQL error.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TABLEFULL Constant

nxllBdeStrings.rsDBIERR_TABLEFULL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TABLEFULL = 'Table is full.';
File

nxllBdeStrings

Description

rs9474 = 'Not enough file handles.'; rs9475 = 'Insufficient disk space.'; rs9477 = 'Record size is too big for table.'; rs9478 = 'Too many open cursors.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TABLELEVEL Constant

nxllBdeStrings.rsDBIERR_TABLELEVEL Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TABLELEVEL = 'Higher table level required';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_TABLELEVEL.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TABLEOPEN Constant

nxllBdeStrings.rsDBIERR_TABLEOPEN Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TABLEOPEN = 'Table is open.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_TABLEOPEN.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TABLEREADONLY Constant

nxllBdeStrings.rsDBIERR_TABLEREADONLY Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TABLEREADONLY = 'Table is read only.';
File

nxllBdeStrings

Description

rs10761 = 'Paradox driver not active.'; rs10762 = 'Driver not loaded.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_TBLENCRYPTED Constant

nxllBdeStrings.rsDBIERR_TBLENCRYPTED Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_TBLENCRYPTED = 'Encrypted tables not supported.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_TBLENCRYPTED.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_UNKNOWNDB Constant

nxllBdeStrings.rsDBIERR_UNKNOWNDB Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_UNKNOWNDB = 'Unknown database.';
File

nxllBdeStrings

Description

rs10010 = 'Index name required.'; rs10011 = 'Invalid session handle.'; rs10012 = 'invalid restructure operation.'; rs10013 = 'Driver not known to system.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_UNKNOWNFILE Constant

nxllBdeStrings.rsDBIERR_UNKNOWNFILE Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_UNKNOWNFILE = 'Cannot open file.';
File

nxllBdeStrings

Description

rs9991 = 'Unknown table type.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_UPDATEABORT Constant

nxllBdeStrings.rsDBIERR_UPDATEABORT Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_UPDATEABORT = 'Update aborted.';
File

nxllBdeStrings

Description

rs13061 = 'Paradox 1.0 tables are not supported.';

Group

Constants

Links
nxllBdeStrings, Constants


nxllBdeStrings.rsDBIERR_WRITEERR Constant

nxllBdeStrings.rsDBIERR_WRITEERR Constant
nxllBdeStrings Constants Send Feedback
Syntax
Delphi
rsDBIERR_WRITEERR = 'Write failure.';
File

nxllBdeStrings

Description

This is constant nxllBdeStrings.rsDBIERR_WRITEERR.

Group

Constants

Links
nxllBdeStrings, Constants


nxllBlowfishRC4 Namespace

nxllBlowfishRC4 Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllBlowfishRC4.

Classes
Name | Description
TnxBlowFishRC4 | This is class nxllBlowfishRC4.TnxBlowFishRC4.
TnxRC4 | This is class nxllBlowfishRC4.TnxRC4.
Constants
Name | Description
nxbfBlockSize | This is constant nxllBlowfishRC4.nxbfBlockSize.
nxBlowfishP | This is constant nxllBlowfishRC4.nxBlowfishP.
nxBlowfishS | This is constant nxllBlowfishRC4.nxBlowfishS.
Structs, Records, Enums
Name | Description
TnxBlowfishBlock | This is record nxllBlowfishRC4.TnxBlowfishBlock.
TnxRC4KeyData | This is record nxllBlowfishRC4.TnxRC4KeyData.
TnxWord32Rec | This is record nxllBlowfishRC4.TnxWord32Rec.
TnxWord64Rec | This is record nxllBlowfishRC4.TnxWord64Rec.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBlowfishBlock | This is type nxllBlowfishRC4.PnxBlowfishBlock.
PnxBlowfishP | This is type nxllBlowfishRC4.PnxBlowfishP.
PnxBlowfishS | This is type nxllBlowfishRC4.PnxBlowfishS.
PnxRC4K | This is type nxllBlowfishRC4.PnxRC4K.
PnxRC4KeyData | This is type nxllBlowfishRC4.PnxRC4KeyData.
PnxWord32Rec | This is type nxllBlowfishRC4.PnxWord32Rec.
TnxBlowfishP | This is type nxllBlowfishRC4.TnxBlowfishP.
TnxBlowfishS | This is type nxllBlowfishRC4.TnxBlowfishS.
TnxRC4K | This is type nxllBlowfishRC4.TnxRC4K.
Variables
Name | Description
gRandomKey | This is variable nxllBlowfishRC4.gRandomKey.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllBlowfishRC4 Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBlowFishRC4 | This is class nxllBlowfishRC4.TnxBlowFishRC4.
TnxRC4 | This is class nxllBlowfishRC4.TnxRC4.
Namespace

nxllBlowfishRC4 Namespace

Links
Classes, nxllBlowfishRC4 Namespace, Legend


TnxBlowFishRC4 Class

TnxBlowFishRC4 Class
TnxBlowFishRC4 Fields TnxBlowFishRC4 Methods TnxBlowFishRC4 Members nxllBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxllBlowfishRC4_TnxBlowFishRC4nxllBlowfishRC4_TnxBlowFishRC4nxllBlowfishRC4_TnxBlowFishRC4
Syntax
Delphi
TnxBlowFishRC4 = class(TnxBaseCipher);
File

nxllBlowfishRC4

Description

This is class nxllBlowfishRC4.TnxBlowFishRC4.

Group

Classes

Links
TnxBlowFishRC4 Fields, TnxBlowFishRC4 Methods, TnxBlowFishRC4 Members, nxllBlowfishRC4, Classes


TnxBlowFishRC4 Members

TnxBlowFishRC4 Members
TnxBlowFishRC4 Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBlowFishRC4.

Class

TnxBlowFishRC4 Class

Protected Fields
Name | Description
bfChk | This is bfChk, a member of class TnxBlowFishRC4.
bfIVl | This is bfIVl, a member of class TnxBlowFishRC4.
bfIVr | This is bfIVr, a member of class TnxBlowFishRC4.
bfKey | private
bfKSF | This is bfKSF, a member of class TnxBlowFishRC4.
bfMustReset | This is bfMustReset, a member of class TnxBlowFishRC4.
bfP | This is bfP, a member of class TnxBlowFishRC4.
bfRC4 | This is bfRC4, a member of class TnxBlowFishRC4.
bfS | This is bfS, a member of class TnxBlowFishRC4.
Protected Methods
Name | Description
bfCreateRandom | This is bfCreateRandom, a member of class TnxBlowFishRC4.
bfDecipher |
bfDecodeAlt |
bfEncipher |
bfEncodeAlt |
bfInitialize |
bfPrepare |
bfReset |
bfWrapDecode |
bfWrapEncode |
cbDecodeAlt |
cbEncodeAlt |
RegisterKeyWrap |
Unregister |
Public Methods
Name | Description
AltLock | TnxCipherBase
AltPriority |
AltRegister |
AltUnLock |
AltUnregister |
BlockLength |
Create |
Decode |
DecodeAlt | Decrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
DecodeKey |
DecodeStorage | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeStorage is intended to be used by an EncryptionEngine. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DecodeTransport | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeTransport is intended to be used by a SecuredTransport. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DeriveKey |
Destroy |
Encode |
EncodeAlt | Encrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
EncodeKey |
EncodeStorage | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeStorage is intended to be used by an EncryptionEngine. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
EncodeTransport | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeTransport is intended to be used by a SecuredTransport. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
Final |
FindKeyWrapClass |
FreeInstance |
GenerateRandom | GenerateRandom is the default method for generating keys for the cipher.
GetRandom64 |
GetRandomBlock |
GetRegisteredKeyWrapClasses |
KeyWrapName |
KeyWrapPriority |
MustFindKeyWrapClass |
NewInstance | TnxObject
PreferredKeyWrapClass |
RandomIV |
RandomIVBlock |
ResetIV |
ResetIVBlock |
SelfTest |
SetKeys |
TheCipher |
Links
TnxBlowFishRC4 Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBlowFishRC4.Destroy Destructor

TnxBlowFishRC4.Destroy Destructor
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBlowFishRC4 Class

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Class


TnxBlowFishRC4 Fields

TnxBlowFishRC4 Fields
TnxBlowFishRC4 Class Legend Protected Fields Send Feedback

The fields of the TnxBlowFishRC4 class are listed here.

Class

TnxBlowFishRC4 Class

Protected Fields
Name | Description
bfChk | This is bfChk, a member of class TnxBlowFishRC4.
bfIVl | This is bfIVl, a member of class TnxBlowFishRC4.
bfIVr | This is bfIVr, a member of class TnxBlowFishRC4.
bfKey | private
bfKSF | This is bfKSF, a member of class TnxBlowFishRC4.
bfMustReset | This is bfMustReset, a member of class TnxBlowFishRC4.
bfP | This is bfP, a member of class TnxBlowFishRC4.
bfRC4 | This is bfRC4, a member of class TnxBlowFishRC4.
bfS | This is bfS, a member of class TnxBlowFishRC4.
Links
TnxBlowFishRC4 Class, Legend, Protected Fields


TnxBlowFishRC4.bfChk Field

TnxBlowFishRC4.bfChk Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfChk: TnxBlowfishBlock;
Description

This is bfChk, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfIVl Field

TnxBlowFishRC4.bfIVl Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfIVl: TnxWord32Rec;
Description

This is bfIVl, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfIVr Field

TnxBlowFishRC4.bfIVr Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfIVr: TnxWord32Rec;
Description

This is bfIVr, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfKey Field

TnxBlowFishRC4.bfKey Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfKey: AnsiString;
Description

private

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfKSF Field

TnxBlowFishRC4.bfKSF Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfKSF: TnxBlowfishBlock;
Description

This is bfKSF, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfMustReset Field

TnxBlowFishRC4.bfMustReset Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfMustReset: Boolean;
Description

This is bfMustReset, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfP Field

TnxBlowFishRC4.bfP Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfP: TnxBlowfishP;
Description

This is bfP, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfRC4 Field

TnxBlowFishRC4.bfRC4 Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfRC4: TnxRC4;
Description

This is bfRC4, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4.bfS Field

TnxBlowFishRC4.bfS Field
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Fields Send Feedback
Syntax
Delphi
bfS: TnxBlowfishS;
Description

This is bfS, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Fields

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Fields


TnxBlowFishRC4 Methods

TnxBlowFishRC4 Methods
TnxBlowFishRC4 Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBlowFishRC4 class are listed here.

Class

TnxBlowFishRC4 Class

Protected Methods
Name | Description
bfCreateRandom | This is bfCreateRandom, a member of class TnxBlowFishRC4.
bfDecipher |
bfDecodeAlt |
bfEncipher |
bfEncodeAlt |
bfInitialize |
bfPrepare |
bfReset |
bfWrapDecode |
bfWrapEncode |
cbDecodeAlt |
cbEncodeAlt |
Public Methods
Name | Description
AltPriority |
BlockLength |
Decode |
DeriveKey |
Encode |
Final |
GetRandom64 |
GetRandomBlock |
KeyWrapName |
KeyWrapPriority |
RandomIV |
RandomIVBlock |
ResetIV |
ResetIVBlock |
SetKeys |
Links
TnxBlowFishRC4 Class, Legend, Protected Methods, Public Methods


TnxBlowFishRC4.AltPriority Method

TnxBlowFishRC4.AltPriority Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function AltPriority: TnxWord32; override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfCreateRandom Method

TnxBlowFishRC4.bfCreateRandom Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function bfCreateRandom: TnxBlowFishRC4;
Description

This is bfCreateRandom, a member of class TnxBlowFishRC4.

Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfDecipher Method

TnxBlowFishRC4.bfDecipher Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfDecipher(var Xl: TnxWord32Rec; var Xr: TnxWord32Rec);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfDecodeAlt Method

TnxBlowFishRC4.bfDecodeAlt Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfDecodeAlt(var aData; aLen: TnxWord32);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfEncipher Method

TnxBlowFishRC4.bfEncipher Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfEncipher(var Xl: TnxWord32Rec; var Xr: TnxWord32Rec);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfEncodeAlt Method

TnxBlowFishRC4.bfEncodeAlt Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfEncodeAlt(var aData; aLen: TnxWord32);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfInitialize Method

TnxBlowFishRC4.bfInitialize Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfInitialize;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfPrepare Method

TnxBlowFishRC4.bfPrepare Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfPrepare;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfReset Method

TnxBlowFishRC4.bfReset Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfReset(aXl: TnxWord32; aXr: TnxWord32);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfWrapDecode Method

TnxBlowFishRC4.bfWrapDecode Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfWrapDecode(var aKeyData: TnxRC4KeyData);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.bfWrapEncode Method

TnxBlowFishRC4.bfWrapEncode Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure bfWrapEncode(var aKeyData: TnxRC4KeyData);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.BlockLength Method

TnxBlowFishRC4.BlockLength Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function BlockLength: TnxWord32; override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.cbDecodeAlt Method

TnxBlowFishRC4.cbDecodeAlt Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class procedure cbDecodeAlt(var aData; aLen: TnxWord32); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.cbEncodeAlt Method

TnxBlowFishRC4.cbEncodeAlt Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class procedure cbEncodeAlt(var aData; aLen: TnxWord32); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.Decode Method

TnxBlowFishRC4.Decode Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure Decode(var aData; aLen: TnxWord32); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.DeriveKey Method

TnxBlowFishRC4.DeriveKey Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function DeriveKey(const aPwd; aPwdLen: TnxWord32; const aSalt; aSaltLen: TnxWord32; const aLabel: RawByteString): TnxBaseCipher; override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.Encode Method

TnxBlowFishRC4.Encode Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure Encode(var aData; aLen: TnxWord32); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.Final Method

TnxBlowFishRC4.Final Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure Final(out aMac); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.GetRandom64 Method

TnxBlowFishRC4.GetRandom64 Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class procedure GetRandom64(var aData);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.GetRandomBlock Method

TnxBlowFishRC4.GetRandomBlock Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class procedure GetRandomBlock(var aData); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.KeyWrapName Method

TnxBlowFishRC4.KeyWrapName Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function KeyWrapName: AnsiString; override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.KeyWrapPriority Method

TnxBlowFishRC4.KeyWrapPriority Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
class function KeyWrapPriority: TnxWord32; override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.RandomIV Method

TnxBlowFishRC4.RandomIV Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure RandomIV(out IVl: TnxWord32; out IVr: TnxWord32);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.RandomIVBlock Method

TnxBlowFishRC4.RandomIVBlock Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure RandomIVBlock(out aIV); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.ResetIV Method

TnxBlowFishRC4.ResetIV Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure ResetIV(const IVl: TnxWord32; const IVr: TnxWord32);
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.ResetIVBlock Method

TnxBlowFishRC4.ResetIVBlock Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure ResetIVBlock(const aIV); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxBlowFishRC4.SetKeys Method

TnxBlowFishRC4.SetKeys Method
TnxBlowFishRC4 Class TnxBlowFishRC4 Members nxllBlowfishRC4 Namespace TnxBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure SetKeys(const aKey: RawByteString); override;
Group

TnxBlowFishRC4 Methods

Links
TnxBlowFishRC4 Class, TnxBlowFishRC4 Members, nxllBlowfishRC4 Namespace, TnxBlowFishRC4 Methods


TnxRC4 Class

TnxRC4 Class
TnxRC4 Fields TnxRC4 Methods TnxRC4 Members nxllBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxllBlowfishRC4_TnxRC4nxllBlowfishRC4_TnxRC4
Syntax
Delphi
TnxRC4 = class(TnxObject);
File

nxllBlowfishRC4

Description

This is class nxllBlowfishRC4.TnxRC4.

Group

Classes

Links
TnxRC4 Fields, TnxRC4 Methods, TnxRC4 Members, nxllBlowfishRC4, Classes


TnxRC4 Members

TnxRC4 Members
TnxRC4 Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRC4.

Class

TnxRC4 Class

Protected Fields
Name | Description
rcI | This is rcI, a member of class TnxRC4.
rcJ | This is rcJ, a member of class TnxRC4.
rcK | private
rcOrgK | This is rcOrgK, a member of class TnxRC4.
Protected Methods
Name | Description
rcInitialize |
rcProcessKey |
Public Methods
Name | Description
Create |
Destroy |
FreeInstance |
KeyStream |
NewInstance | TnxObject
Reset |
SetKeys | This is the overview for the SetKeys method overload.
Links
TnxRC4 Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxRC4.Create Constructor

TnxRC4.Create Constructor
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Class Send Feedback
Syntax
Delphi
constructor Create(const aKey: RawByteString);
Class

TnxRC4 Class

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Class


TnxRC4.Destroy Destructor

TnxRC4.Destroy Destructor
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRC4 Class

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Class


TnxRC4 Fields

TnxRC4 Fields
TnxRC4 Class Legend Protected Fields Send Feedback

The fields of the TnxRC4 class are listed here.

Class

TnxRC4 Class

Protected Fields
Name | Description
rcI | This is rcI, a member of class TnxRC4.
rcJ | This is rcJ, a member of class TnxRC4.
rcK | private
rcOrgK | This is rcOrgK, a member of class TnxRC4.
Links
TnxRC4 Class, Legend, Protected Fields


TnxRC4.rcI Field

TnxRC4.rcI Field
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Fields Send Feedback
Syntax
Delphi
rcI: TnxByte8;
Description

This is rcI, a member of class TnxRC4.

Group

TnxRC4 Fields

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Fields


TnxRC4.rcJ Field

TnxRC4.rcJ Field
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Fields Send Feedback
Syntax
Delphi
rcJ: TnxByte8;
Description

This is rcJ, a member of class TnxRC4.

Group

TnxRC4 Fields

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Fields


TnxRC4.rcK Field

TnxRC4.rcK Field
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Fields Send Feedback
Syntax
Delphi
rcK: TnxRC4K;
Description

private

Group

TnxRC4 Fields

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Fields


TnxRC4.rcOrgK Field

TnxRC4.rcOrgK Field
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Fields Send Feedback
Syntax
Delphi
rcOrgK: TnxRC4K;
Description

This is rcOrgK, a member of class TnxRC4.

Group

TnxRC4 Fields

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Fields


TnxRC4 Methods

TnxRC4 Methods
TnxRC4 Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRC4 class are listed here.

Class

TnxRC4 Class

Protected Methods
Name | Description
rcInitialize |
rcProcessKey |
Public Methods
Name | Description
KeyStream |
Reset |
SetKeys | This is the overview for the SetKeys method overload.
Links
TnxRC4 Class, Legend, Protected Methods, Public Methods


TnxRC4.KeyStream Method

TnxRC4.KeyStream Method
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Methods Send Feedback
Syntax
Delphi
function KeyStream: TnxWord32;
Group

TnxRC4 Methods

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Methods


TnxRC4.rcInitialize Method

TnxRC4.rcInitialize Method
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Methods Send Feedback
Syntax
Delphi
procedure rcInitialize;
Group

TnxRC4 Methods

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Methods


TnxRC4.rcProcessKey Method

TnxRC4.rcProcessKey Method
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Methods Send Feedback
Syntax
Delphi
procedure rcProcessKey(const aInitCode: TnxRC4K; aLen: TnxWord32);
Group

TnxRC4 Methods

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Methods


TnxRC4.Reset Method

TnxRC4.Reset Method
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace TnxRC4 Methods Send Feedback
Syntax
Delphi
procedure Reset(const aInitCode: TnxRC4K);
Group

TnxRC4 Methods

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, TnxRC4 Methods


SetKeys Method

SetKeys Method
TnxRC4 Methods Send Feedback

This is the overview for the SetKeys method overload.

Overload List
Name | Description
TnxRC4.SetKeys (, TnxWord32) |
TnxRC4.SetKeys (RawByteString) |
Group

TnxRC4 Methods

Links
TnxRC4 Methods


TnxRC4.SetKeys Method (, TnxWord32)

TnxRC4.SetKeys Method (, TnxWord32)
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace SetKeys Method Send Feedback
Syntax
Delphi
procedure SetKeys(const aKey; aKeyLen: TnxWord32); overload;
Group

SetKeys Method

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, SetKeys Method


TnxRC4.SetKeys Method (RawByteString)

TnxRC4.SetKeys Method (RawByteString)
TnxRC4 Class TnxRC4 Members nxllBlowfishRC4 Namespace SetKeys Method Send Feedback
Syntax
Delphi
procedure SetKeys(const aKey: RawByteString); overload;
Group

SetKeys Method

Links
TnxRC4 Class, TnxRC4 Members, nxllBlowfishRC4 Namespace, SetKeys Method


Structs, Records, Enums

Structs, Records, Enums
nxllBlowfishRC4 Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllBlowfishRC4 Namespace

Records
Name | Description
TnxBlowfishBlock | This is record nxllBlowfishRC4.TnxBlowfishBlock.
TnxRC4KeyData | This is record nxllBlowfishRC4.TnxRC4KeyData.
TnxWord32Rec | This is record nxllBlowfishRC4.TnxWord32Rec.
TnxWord64Rec | This is record nxllBlowfishRC4.TnxWord64Rec.
Links
nxllBlowfishRC4 Namespace, Legend, Records


nxllBlowfishRC4.TnxBlowfishBlock Record

nxllBlowfishRC4.TnxBlowfishBlock Record
nxllBlowfishRC4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlowfishBlock = packed record
  Xl: TnxWord32Rec;
  Xr: TnxWord32Rec;
end;
File

nxllBlowfishRC4

Description

This is record nxllBlowfishRC4.TnxBlowfishBlock.

Group

Structs, Records, Enums

Links
nxllBlowfishRC4, Structs, Records, Enums


nxllBlowfishRC4.TnxRC4KeyData Record

nxllBlowfishRC4.TnxRC4KeyData Record
nxllBlowfishRC4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRC4KeyData = record
  case Integer of
    0: (RC4K: TnxRC4K;);
    1: (Word32: array[0..63] of TnxWord32););
end;
File

nxllBlowfishRC4

Description

This is record nxllBlowfishRC4.TnxRC4KeyData.

Group

Structs, Records, Enums

Links
nxllBlowfishRC4, Structs, Records, Enums


nxllBlowfishRC4.TnxWord32Rec Record

nxllBlowfishRC4.TnxWord32Rec Record
nxllBlowfishRC4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWord32Rec = packed record
  case Integer of
    0: (Word32: TnxWord32;);
    1: (Byte8: array[0..3] of TnxByte8););
end;
File

nxllBlowfishRC4

Description

This is record nxllBlowfishRC4.TnxWord32Rec.

Group

Structs, Records, Enums

Links
nxllBlowfishRC4, Structs, Records, Enums


nxllBlowfishRC4.TnxWord64Rec Record

nxllBlowfishRC4.TnxWord64Rec Record
nxllBlowfishRC4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWord64Rec = packed record
  case Integer of
    0: (Word32: array[0..1] of TnxWord32);
        Byte8: array[0..7] of TnxByte8););
end;
File

nxllBlowfishRC4

Description

This is record nxllBlowfishRC4.TnxWord64Rec.

Group

Structs, Records, Enums

Links
nxllBlowfishRC4, Structs, Records, Enums


Types

Types
nxllBlowfishRC4 Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllBlowfishRC4 Namespace

Types
Name | Description
PnxBlowfishBlock | This is type nxllBlowfishRC4.PnxBlowfishBlock.
PnxBlowfishP | This is type nxllBlowfishRC4.PnxBlowfishP.
PnxBlowfishS | This is type nxllBlowfishRC4.PnxBlowfishS.
PnxRC4K | This is type nxllBlowfishRC4.PnxRC4K.
PnxRC4KeyData | This is type nxllBlowfishRC4.PnxRC4KeyData.
PnxWord32Rec | This is type nxllBlowfishRC4.PnxWord32Rec.
TnxBlowfishP | This is type nxllBlowfishRC4.TnxBlowfishP.
TnxBlowfishS | This is type nxllBlowfishRC4.TnxBlowfishS.
TnxRC4K | This is type nxllBlowfishRC4.TnxRC4K.
Links
nxllBlowfishRC4 Namespace, Types


nxllBlowfishRC4.PnxBlowfishBlock Type

nxllBlowfishRC4.PnxBlowfishBlock Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxBlowfishBlock = ^TnxBlowfishBlock;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxBlowfishBlock.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.PnxBlowfishP Type

nxllBlowfishRC4.PnxBlowfishP Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxBlowfishP = ^TnxBlowfishP;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxBlowfishP.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.PnxBlowfishS Type

nxllBlowfishRC4.PnxBlowfishS Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxBlowfishS = ^TnxBlowfishS;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxBlowfishS.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.PnxRC4K Type

nxllBlowfishRC4.PnxRC4K Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxRC4K = ^TnxRC4K;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxRC4K.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.PnxRC4KeyData Type

nxllBlowfishRC4.PnxRC4KeyData Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxRC4KeyData = ^TnxRC4KeyData;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxRC4KeyData.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.PnxWord32Rec Type

nxllBlowfishRC4.PnxWord32Rec Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
PnxWord32Rec = ^TnxWord32Rec;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.PnxWord32Rec.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.TnxBlowfishP Type

nxllBlowfishRC4.TnxBlowfishP Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
TnxBlowfishP = array[0..17] of TnxWord32;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.TnxBlowfishP.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.TnxBlowfishS Type

nxllBlowfishRC4.TnxBlowfishS Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
TnxBlowfishS = array[0..3, 0..255] of TnxWord32;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.TnxBlowfishS.

Group

Types

Links
nxllBlowfishRC4, Types


nxllBlowfishRC4.TnxRC4K Type

nxllBlowfishRC4.TnxRC4K Type
nxllBlowfishRC4 Types Send Feedback
Syntax
Delphi
TnxRC4K = array[0..255] of TnxByte8;
File

nxllBlowfishRC4

Description

This is type nxllBlowfishRC4.TnxRC4K.

Group

Types

Links
nxllBlowfishRC4, Types


Variables

Variables
nxllBlowfishRC4 Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllBlowfishRC4 Namespace

Variables
Name | Description
gRandomKey | This is variable nxllBlowfishRC4.gRandomKey.
Links
nxllBlowfishRC4 Namespace, Variables


nxllBlowfishRC4.gRandomKey Variable

nxllBlowfishRC4.gRandomKey Variable
nxllBlowfishRC4 Variables Send Feedback
Syntax
Delphi
gRandomKey: TnxBlowFishRC4;
File

nxllBlowfishRC4

Description

This is variable nxllBlowfishRC4.gRandomKey.

Group

Variables

Links
nxllBlowfishRC4, Variables


Constants

Constants
Constants nxllBlowfishRC4 Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxbfBlockSize | This is constant nxllBlowfishRC4.nxbfBlockSize.
nxBlowfishP | This is constant nxllBlowfishRC4.nxBlowfishP.
nxBlowfishS | This is constant nxllBlowfishRC4.nxBlowfishS.
Namespace

nxllBlowfishRC4 Namespace

Links
Constants, nxllBlowfishRC4 Namespace


nxllBlowfishRC4.nxbfBlockSize Constant

nxllBlowfishRC4.nxbfBlockSize Constant
nxllBlowfishRC4 Constants Send Feedback
Syntax
Delphi
nxbfBlockSize = SizeOf(TnxBlowfishBlock);
File

nxllBlowfishRC4

Description

This is constant nxllBlowfishRC4.nxbfBlockSize.

Group

Constants

Links
nxllBlowfishRC4, Constants


nxllBlowfishRC4.nxBlowfishP Constant

nxllBlowfishRC4.nxBlowfishP Constant
nxllBlowfishRC4 Constants Send Feedback
Syntax
Delphi
nxBlowfishP: TnxBlowfishP = ( $243F6A88, $85A308D3, $13198A2E, $03707344, $A4093822, $299F31D0, $082EFA98, $EC4E6C89, $452821E6, $38D01377, $BE5466CF, $34E90C6C, $C0AC29B7, $C97C50DD, $3F84D5B5, $B5470917, $9216D5D9, $8979FB1B);
File

nxllBlowfishRC4

Description

This is constant nxllBlowfishRC4.nxBlowfishP.

Group

Constants

Links
nxllBlowfishRC4, Constants


nxllBlowfishRC4.nxBlowfishS Constant

nxllBlowfishRC4.nxBlowfishS Constant
nxllBlowfishRC4 Constants Send Feedback
Syntax
Delphi
nxBlowfishS: TnxBlowfishS = ( ($D1310BA6, $98DFB5AC, $2FFD72DB, $D01ADFB7, $B8E1AFED, $6A267E96, $BA7C9045, $F12C7F99, $24A19947, $B3916CF7, $0801F2E2, $858EFC16, $636920D8, $71574E69, $A458FEA3, $F4933D7E, $0D95748F, $728EB658, $718BCD58, $82154AEE, $7B54A41D, $C25A59B5, $9C30D539, $2AF26013, $C5D1B023, $286085F0, $CA417918, $B8DB38EF, $8E79DCB0, $603A180E, $6C9E0E8B, $B01E8A3E, $D71577C1, $BD314B27, $78AF2FDA, $55605C60, $E65525F3, $AA55AB94, $57489862, $63E81440, $55CA396A, $2AAB10B6, $B4CC5C34, $1141E8CE, $A15486AF, $7C72E993, $B3EE1411, $636FBC2A, $2BA9C55D, $741831F6, $CE5C3E16, $9B87931E, $AFD6BA33, $6C24CF5C, $7A325381, $28958677, $3B8F4898, $6B4BB9AF, $C4BFE81B, $66282193, $61D809CC, $FB21A991, $487CAC60, $5DEC8032, $EF845D5D, $E98575B1, $DC262302, $EB651B88, $23893E81, $D396ACC5, $0F6D6FF3, $83F44239, $2E0B4482, $A4842004, $69C8F04A, $9E1F9B5E, $21C66842, $F6E96C9A, $670C9C61, $ABD388F0, $6A51A0D2, $D8542F68, $960FA728, $AB5133A3, $6EEF0B6C, $137A3BE4, $BA3BF050, $7EFB2A98, $A1F1651D, $39AF0176, $66CA593E, $82430E88, $8CEE8619, $456F9FB4, $7D84A5C3, $3B8B5EBE, $E06F75D8, $85C12073, $401A449F, $56C16AA6, $4ED3AA62, $363F7706, $1BFEDF72, $429B023D, $37D0D724, $D00A1248, $DB0FEAD3, $49F1C09B, $075372C9, $80991B7B, $25D479D8, $F6E8DEF7, $E3FE501A, $B6794C3B, $976CE0BD, $04C006BA, $C1A94FB6, $409F60C4, $5E5C9EC2, $196A2463, $68FB6FAF, $3E6C53B5, $1339B2EB, $3B52EC6F, $6DFC511F, $9B30952C, $CC814544, $AF5EBD09, $BEE3D004, $DE334AFD, $660F2807, $192E4BB3, $C0CBA857, $45C8740F, $D20B5F39, $B9D3FBDB, $5579C0BD, $1A60320A, $D6A100C6, $402C7279, $679F25FE, $FB1FA3CC, $8EA5E9F8, $DB3222F8, $3C7516DF, $FD616B15, $2F501EC8, $AD0552AB, $323DB5FA, $FD238760, $53317B48, $3E00DF82, $9E5C57BB, $CA6F8CA0, $1A87562E, $DF1769DB, $D542A8F6, $287EFFC3, $AC6732C6, $8C4F5573, $695B27B0, $BBCA58C8, $E1FFA35D, $B8F011A0, $10FA3D98, $FD2183B8, $4AFCB56C, $2DD1D35B, $9A53E479, $B6F84565, $D28E49BC, $4BFB9790, $E1DDF2DA, $A4CB7E33, $62FB1341, $CEE4C6E8, $EF20CADA, $36774C01, $D07E9EFE, $2BF11FB4, $95DBDA4D, $AE909198, $EAAD8E71, $6B93D5A0, $D08ED1D0, $AFC725E0, $8E3C5B2F, $8E7594B7, $8FF6E2FB, $F2122B64, $8888B812, $900DF01C, $4FAD5EA0, $688FC31C, $D1CFF191, $B3A8C1AD, $2F2F2218, $BE0E1777, $EA752DFE, $8B021FA1, $E5A0CC0F, $B56F74E8, $18ACF3D6, $CE89E299, $B4A84FE0, $FD13E0B7, $7CC43B81, $D2ADA8D9, $165FA266, $80957705, $93CC7314, $211A1477, $E6AD2065, $77B5FA86, $C75442F5, $FB9D35CF, $EBCDAF0C, $7B3E89A0, $D6411BD3, $AE1E7E49, $00250E2D, $2071B35E, $226800BB, $57B8E0AF, $2464369B, $F009B91E, $5563911D, $59DFA6AA, $78C14389, $D95A537F, $207D5BA2, $02E5B9C5, $83260376, $6295CFA9, $11C81968, $4E734A41, $B3472DCA, $7B14A94A, $1B510052, $9A532915, $D60F573F, $BC9BC6E4, $2B60A476, $81E67400, $08BA6FB5, $571BE91F, $F296EC6B, $2A0DD915, $B6636521, $E7B9F9B6, $FF34052E, $C5855664, $53B02D5D, $A99F8FA1, $08BA4799, $6E85076A), ($4B7A70E9, $B5B32944, $DB75092E, $C4192623, $AD6EA6B0, $49A7DF7D, $9CEE60B8, $8FEDB266, $ECAA8C71, $699A17FF, $5664526C, $C2B19EE1, $193602A5, $75094C29, $A0591340, $E4183A3E, $3F54989A, $5B429D65, $6B8FE4D6, $99F73FD6, $A1D29C07, $EFE830F5, $4D2D38E6, $F0255DC1, $4CDD2086, $8470EB26, $6382E9C6, $021ECC5E, $09686B3F, $3EBAEFC9, $3C971814, $6B6A70A1, $687F3584, $52A0E286, $B79C5305, $AA500737, $3E07841C, $7FDEAE5C, $8E7D44EC, $5716F2B8, $B03ADA37, $F0500C0D, $F01C1F04, $0200B3FF, $AE0CF51A, $3CB574B2, $25837A58, $DC0921BD, $D19113F9, $7CA92FF6, $94324773, $22F54701, $3AE5E581, $37C2DADC, $C8B57634, $9AF3DDA7, $A9446146, $0FD0030E, $ECC8C73E, $A4751E41, $E238CD99, $3BEA0E2F, $3280BBA1, $183EB331, $4E548B38, $4F6DB908, $6F420D03, $F60A04BF, $2CB81290, $24977C79, $5679B072, $BCAF89AF, $DE9A771F, $D9930810, $B38BAE12, $DCCF3F2E, $5512721F, $2E6B7124, $501ADDE6, $9F84CD87, $7A584718, $7408DA17, $BC9F9ABC, $E94B7D8C, $EC7AEC3A, $DB851DFA, $63094366, $C464C3D2, $EF1C1847, $3215D908, $DD433B37, $24C2BA16, $12A14D43, $2A65C451, $50940002, $133AE4DD, $71DFF89E, $10314E55, $81AC77D6, $5F11199B, $043556F1, $D7A3C76B, $3C11183B, $5924A509, $F28FE6ED, $97F1FBFA, $9EBABF2C, $1E153C6E, $86E34570, $EAE96FB1, $860E5E0A, $5A3E2AB3, $771FE71C, $4E3D06FA, $2965DCB9, $99E71D0F, $803E89D6, $5266C825, $2E4CC978, $9C10B36A, $C6150EBA, $94E2EA78, $A5FC3C53, $1E0A2DF4, $F2F74EA7, $361D2B3D, $1939260F, $19C27960, $5223A708, $F71312B6, $EBADFE6E, $EAC31F66, $E3BC4595, $A67BC883, $B17F37D1, $018CFF28, $C332DDEF, $BE6C5AA5, $65582185, $68AB9802, $EECEA50F, $DB2F953B, $2AEF7DAD, $5B6E2F84, $1521B628, $29076170, $ECDD4775, $619F1510, $13CCA830, $EB61BD96, $0334FE1E, $AA0363CF, $B5735C90, $4C70A239, $D59E9E0B, $CBAADE14, $EECC86BC, $60622CA7, $9CAB5CAB, $B2F3846E, $648B1EAF, $19BDF0CA, $A02369B9, $655ABB50, $40685A32, $3C2AB4B3, $319EE9D5, $C021B8F7, $9B540B19, $875FA099, $95F7997E, $623D7DA8, $F837889A, $97E32D77, $11ED935F, $16681281, $0E358829, $C7E61FD6, $96DEDFA1, $7858BA99, $57F584A5, $1B227263, $9B83C3FF, $1AC24696, $CDB30AEB, $532E3054, $8FD948E4, $6DBC3128, $58EBF2EF, $34C6FFEA, $FE28ED61, $EE7C3C73, $5D4A14D9, $E864B7E3, $42105D14, $203E13E0, $45EEE2B6, $A3AAABEA, $DB6C4F15, $FACB4FD0, $C742F442, $EF6ABBB5, $654F3B1D, $41CD2105, $D81E799E, $86854DC7, $E44B476A, $3D816250, $CF62A1F2, $5B8D2646, $FC8883A0, $C1C7B6A3, $7F1524C3, $69CB7492, $47848A0B, $5692B285, $095BBF00, $AD19489D, $1462B174, $23820E00, $58428D2A, $0C55F5EA, $1DADF43E, $233F7061, $3372F092, $8D937E41, $D65FECF1, $6C223BDB, $7CDE3759, $CBEE7460, $4085F2A7, $CE77326E, $A6078084, $19F8509E, $E8EFD855, $61D99735, $A969A7AA, $C50C06C2, $5A04ABFC, $800BCADC, $9E447A2E, $C3453484, $FDD56705, $0E1E9EC9, $DB73DBD3, $105588CD, $675FDA79, $E3674340, $C5C43465, $713E38D8, $3D28F89E, $F16DFF20, $153E21E7, $8FB03D4A, $E6E39F2B, $DB83ADF7), ($E93D5A68, $948140F7, $F64C261C, $94692934, $411520F7, $7602D4F7, $BCF46B2E, $D4A20068, $D4082471, $3320F46A, $43B7D4B7, $500061AF, $1E39F62E, $97244546, $14214F74, $BF8B8840, $4D95FC1D, $96B591AF, $70F4DDD3, $66A02F45, $BFBC09EC, $03BD9785, $7FAC6DD0, $31CB8504, $96EB27B3, $55FD3941, $DA2547E6, $ABCA0A9A, $28507825, $530429F4, $0A2C86DA, $E9B66DFB, $68DC1462, $D7486900, $680EC0A4, $27A18DEE, $4F3FFEA2, $E887AD8C, $B58CE006, $7AF4D6B6, $AACE1E7C, $D3375FEC, $CE78A399, $406B2A42, $20FE9E35, $D9F385B9, $EE39D7AB, $3B124E8B, $1DC9FAF7, $4B6D1856, $26A36631, $EAE397B2, $3A6EFA74, $DD5B4332, $6841E7F7, $CA7820FB, $FB0AF54E, $D8FEB397, $454056AC, $BA489527, $55533A3A, $20838D87, $FE6BA9B7, $D096954B, $55A867BC, $A1159A58, $CCA92963, $99E1DB33, $A62A4A56, $3F3125F9, $5EF47E1C, $9029317C, $FDF8E802, $04272F70, $80BB155C, $05282CE3, $95C11548, $E4C66D22, $48C1133F, $C70F86DC, $07F9C9EE, $41041F0F, $404779A4, $5D886E17, $325F51EB, $D59BC0D1, $F2BCC18F, $41113564, $257B7834, $602A9C60, $DFF8E8A3, $1F636C1B, $0E12B4C2, $02E1329E, $AF664FD1, $CAD18115, $6B2395E0, $333E92E1, $3B240B62, $EEBEB922, $85B2A20E, $E6BA0D99, $DE720C8C, $2DA2F728, $D0127845, $95B794FD, $647D0862, $E7CCF5F0, $5449A36F, $877D48FA, $C39DFD27, $F33E8D1E, $0A476341, $992EFF74, $3A6F6EAB, $F4F8FD37, $A812DC60, $A1EBDDF8, $991BE14C, $DB6E6B0D, $C67B5510, $6D672C37, $2765D43B, $DCD0E804, $F1290DC7, $CC00FFA3, $B5390F92, $690FED0B, $667B9FFB, $CEDB7D9C, $A091CF0B, $D9155EA3, $BB132F88, $515BAD24, $7B9479BF, $763BD6EB, $37392EB3, $CC115979, $8026E297, $F42E312D, $6842ADA7, $C66A2B3B, $12754CCC, $782EF11C, $6A124237, $B79251E7, $06A1BBE6, $4BFB6350, $1A6B1018, $11CAEDFA, $3D25BDD8, $E2E1C3C9, $44421659, $0A121386, $D90CEC6E, $D5ABEA2A, $64AF674E, $DA86A85F, $BEBFE988, $64E4C3FE, $9DBC8057, $F0F7C086, $60787BF8, $6003604D, $D1FD8346, $F6381FB0, $7745AE04, $D736FCCC, $83426B33, $F01EAB71, $B0804187, $3C005E5F, $77A057BE, $BDE8AE24, $55464299, $BF582E61, $4E58F48F, $F2DDFDA2, $F474EF38, $8789BDC2, $5366F9C3, $C8B38E74, $B475F255, $46FCD9B9, $7AEB2661, $8B1DDF84, $846A0E79, $915F95E2, $466E598E, $20B45770, $8CD55591, $C902DE4C, $B90BACE1, $BB8205D0, $11A86248, $7574A99E, $B77F19B6, $E0A9DC09, $662D09A1, $C4324633, $E85A1F02, $09F0BE8C, $4A99A025, $1D6EFE10, $1AB93D1D, $0BA5A4DF, $A186F20F, $2868F169, $DCB7DA83, $573906FE, $A1E2CE9B, $4FCD7F52, $50115E01, $A70683FA, $A002B5C4, $0DE6D027, $9AF88C27, $773F8641, $C3604C06, $61A806B5, $F0177A28, $C0F586E0, $006058AA, $30DC7D62, $11E69ED7, $2338EA63, $53C2DD94, $C2C21634, $BBCBEE56, $90BCB6DE, $EBFC7DA1, $CE591D76, $6F05E409, $4B7C0188, $39720A3D, $7C927C24, $86E3725F, $724D9DB9, $1AC15BB4, $D39EB8FC, $ED545578, $08FCA5B5, $D83D7CD3, $4DAD0FC4, $1E50EF5E, $B161E6F8, $A28514D9, $6C51133C, $6FD5C7E7, $56E14EC4, $362ABFCE, $DDC6C837, $D79A3234, $92638212, $670EFA8E, $406000E0), ($3A39CE37, $D3FAF5CF, $ABC27737, $5AC52D1B, $5CB0679E, $4FA33742, $D3822740, $99BC9BBE, $D5118E9D, $BF0F7315, $D62D1C7E, $C700C47B, $B78C1B6B, $21A19045, $B26EB1BE, $6A366EB4, $5748AB2F, $BC946E79, $C6A376D2, $6549C2C8, $530FF8EE, $468DDE7D, $D5730A1D, $4CD04DC6, $2939BBDB, $A9BA4650, $AC9526E8, $BE5EE304, $A1FAD5F0, $6A2D519A, $63EF8CE2, $9A86EE22, $C089C2B8, $43242EF6, $A51E03AA, $9CF2D0A4, $83C061BA, $9BE96A4D, $8FE51550, $BA645BD6, $2826A2F9, $A73A3AE1, $4BA99586, $EF5562E9, $C72FEFD3, $F752F7DA, $3F046F69, $77FA0A59, $80E4A915, $87B08601, $9B09E6AD, $3B3EE593, $E990FD5A, $9E34D797, $2CF0B7D9, $022B8B51, $96D5AC3A, $017DA67D, $D1CF3ED6, $7C7D2D28, $1F9F25CF, $ADF2B89B, $5AD6B472, $5A88F54C, $E029AC71, $E019A5E6, $47B0ACFD, $ED93FA9B, $E8D3C48D, $283B57CC, $F8D56629, $79132E28, $785F0191, $ED756055, $F7960E44, $E3D35E8C, $15056DD4, $88F46DBA, $03A16125, $0564F0BD, $C3EB9E15, $3C9057A2, $97271AEC, $A93A072A, $1B3F6D9B, $1E6321F5, $F59C66FB, $26DCF319, $7533D928, $B155FDF5, $03563482, $8ABA3CBB, $28517711, $C20AD9F8, $ABCC5167, $CCAD925F, $4DE81751, $3830DC8E, $379D5862, $9320F991, $EA7A90C2, $FB3E7BCE, $5121CE64, $774FBE32, $A8B6E37E, $C3293D46, $48DE5369, $6413E680, $A2AE0810, $DD6DB224, $69852DFD, $09072166, $B39A460A, $6445C0DD, $586CDECF, $1C20C8AE, $5BBEF7DD, $1B588D40, $CCD2017F, $6BB4E3BB, $DDA26A7E, $3A59FF45, $3E350A44, $BCB4CDD5, $72EACEA8, $FA6484BB, $8D6612AE, $BF3C6F47, $D29BE463, $542F5D9E, $AEC2771B, $F64E6370, $740E0D8D, $E75B1357, $F8721671, $AF537D5D, $4040CB08, $4EB4E2CC, $34D2466A, $0115AF84, $E1B00428, $95983A1D, $06B89FB4, $CE6EA048, $6F3F3B82, $3520AB82, $011A1D4B, $277227F8, $611560B1, $E7933FDC, $BB3A792B, $344525BD, $A08839E1, $51CE794B, $2F32C9B7, $A01FBAC9, $E01CC87E, $BCC7D1F6, $CF0111C3, $A1E8AAC7, $1A908749, $D44FBD9A, $D0DADECB, $D50ADA38, $0339C32A, $C6913667, $8DF9317C, $E0B12B4F, $F79E59B7, $43F5BB3A, $F2D519FF, $27D9459C, $BF97222C, $15E6FC2A, $0F91FC71, $9B941525, $FAE59361, $CEB69CEB, $C2A86459, $12BAA8D1, $B6C1075E, $E3056A0C, $10D25065, $CB03A442, $E0EC6E0E, $1698DB3B, $4C98A0BE, $3278E964, $9F1F9532, $E0D392DF, $D3A0342B, $8971F21E, $1B0A7441, $4BA3348C, $C5BE7120, $C37632D8, $DF359F8D, $9B992F2E, $E60B6F47, $0FE3F11D, $E54CDA54, $1EDAD891, $CE6279CF, $CD3E7E6F, $1618B166, $FD2C1D05, $848FD2C5, $F6FB2299, $F523F357, $A6327623, $93A83531, $56CCCD02, $ACF08162, $5A75EBB5, $6E163697, $88D273CC, $DE966292, $81B949D0, $4C50901B, $71C65614, $E6C6C7BD, $327A140A, $45E1D006, $C3F27B9A, $C9AA53FD, $62A80F00, $BB25BFE2, $35BDD2F6, $71126905, $B2040222, $B6CBCF7C, $CD769C2B, $53113EC0, $1640E3D3, $38ABBD60, $2547ADF0, $BA38209C, $F746CE76, $77AFA1C5, $20756060, $85CBFE4E, $8AE88DD8, $7AAAF9B0, $4CF9AA7E, $1948C25C, $02FB8A8C, $01C36AE4, $D6EBE1F9, $90D4F869, $A65CDEA0, $3F09252D, $C208E69F, $B74E6132, $CE77E25B, $578FDFE3, $3AC372E6));
File

nxllBlowfishRC4

Description

This is constant nxllBlowfishRC4.nxBlowfishS.

Group

Constants

Links
nxllBlowfishRC4, Constants


nxllCipherUtils Namespace

nxllCipherUtils Namespace
Constants Functions Legend Topics Send Feedback

This is namespace nxllCipherUtils.

Constants
Name | Description
RandomKeyLength | This is constant nxllCipherUtils.RandomKeyLength.
SaltLength | This is constant nxllCipherUtils.SaltLength.
Functions
Name | Description
nxCipherDecodeData | nxCipherDecodeData
nxCipherDecodeData |
nxCipherDecodeData |
nxCipherDecodeData |
nxCipherDecodeString |
nxCipherEncodeData | nxCipherEncodeData
nxCipherEncodeData |
nxCipherEncodeData |
nxCipherEncodeRandomData | nxCipherEncodeData
nxCipherEncodeRandomData |
nxCipherEncodeRandomData |
nxCipherEncodeString |
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Constants, Functions, Legend, Topics


Functions

Functions
Functions nxllCipherUtils Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCipherDecodeData | nxCipherDecodeData
nxCipherDecodeData |
nxCipherDecodeData |
nxCipherDecodeData |
nxCipherDecodeString |
nxCipherEncodeData | nxCipherEncodeData
nxCipherEncodeData |
nxCipherEncodeData |
nxCipherEncodeRandomData | nxCipherEncodeData
nxCipherEncodeRandomData |
nxCipherEncodeRandomData |
nxCipherEncodeString |
Namespace

nxllCipherUtils Namespace

Links
Functions, nxllCipherUtils Namespace, Legend


nxllCipherUtils.nxCipherDecodeData Function

nxllCipherUtils.nxCipherDecodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherDecodeData(const aPassword; aPasswordLen: Integer; const aData; aDataLen: Integer; aCipherName: PAnsiString): TnxBytes; overload;
File

nxllCipherUtils

Description

nxCipherDecodeData

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherDecodeData Function

nxllCipherUtils.nxCipherDecodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherDecodeData(const aPassword; aPasswordLen: Integer; const aData: Variant; aCipherName: PAnsiString): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherDecodeData Function

nxllCipherUtils.nxCipherDecodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherDecodeData(const aPassword: TnxBytes; const aData: Variant; aCipherName: PAnsiString): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherDecodeData Function

nxllCipherUtils.nxCipherDecodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherDecodeData(const aPassword: UnicodeString; const aData: Variant; aCipherName: PAnsiString): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherDecodeString Function

nxllCipherUtils.nxCipherDecodeString Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherDecodeString(const aPassword: TnxBytes; const aData: Variant; aCipherName: PAnsiString): UnicodeString;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeData Function

nxllCipherUtils.nxCipherEncodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeData(aCipherClass: TnxBaseCipherClass; const aPassword; aPasswordLen: Integer; const aData; aDataLen: Integer): TnxBytes; overload;
File

nxllCipherUtils

Description

nxCipherEncodeData

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeData Function

nxllCipherUtils.nxCipherEncodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeData(aCipherClass: TnxBaseCipherClass; const aPassword: TnxBytes; const aData: TnxBytes): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeData Function

nxllCipherUtils.nxCipherEncodeData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeData(aCipherClass: TnxBaseCipherClass; const aPassword: UnicodeString; const aData: TnxBytes): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeRandomData Function

nxllCipherUtils.nxCipherEncodeRandomData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeRandomData(aCipherClass: TnxBaseCipherClass; const aPassword; aPasswordLen: Integer; aDataLen: Integer = RandomKeyLength): TnxBytes; overload;
File

nxllCipherUtils

Description

nxCipherEncodeData

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeRandomData Function

nxllCipherUtils.nxCipherEncodeRandomData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeRandomData(aCipherClass: TnxBaseCipherClass; const aPassword: TnxBytes; aDataLen: Integer = RandomKeyLength): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeRandomData Function

nxllCipherUtils.nxCipherEncodeRandomData Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeRandomData(aCipherClass: TnxBaseCipherClass; const aPassword: UnicodeString; aDataLen: Integer = RandomKeyLength): TnxBytes; overload;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


nxllCipherUtils.nxCipherEncodeString Function

nxllCipherUtils.nxCipherEncodeString Function
nxllCipherUtils Functions Send Feedback
Syntax
Delphi
function nxCipherEncodeString(aCipherClass: TnxBaseCipherClass; const aPassword: TnxBytes; const aString: UnicodeString): TnxBytes;
File

nxllCipherUtils

Group

Functions

Links
nxllCipherUtils, Functions


Constants

Constants
Constants nxllCipherUtils Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
RandomKeyLength | This is constant nxllCipherUtils.RandomKeyLength.
SaltLength | This is constant nxllCipherUtils.SaltLength.
Namespace

nxllCipherUtils Namespace

Links
Constants, nxllCipherUtils Namespace


nxllCipherUtils.RandomKeyLength Constant

nxllCipherUtils.RandomKeyLength Constant
nxllCipherUtils Constants Send Feedback
Syntax
Delphi
RandomKeyLength = 64;
File

nxllCipherUtils

Description

This is constant nxllCipherUtils.RandomKeyLength.

Group

Constants

Links
nxllCipherUtils, Constants


nxllCipherUtils.SaltLength Constant

nxllCipherUtils.SaltLength Constant
nxllCipherUtils Constants Send Feedback
Syntax
Delphi
SaltLength = 16;
File

nxllCipherUtils

Description

This is constant nxllCipherUtils.SaltLength.

Group

Constants

Links
nxllCipherUtils, Constants


nxllComponent Namespace

nxllComponent Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllComponent.

Classes
Name | Description
EnxAbortStateChange | Exception type used for critical state errors.
EnxBaseLogException | Special exception type for all logging classes.
EnxComponentException | A special Exception class that can have additional information about TnxComponent.
EnxLoggableComponentException | Special exception type for logable components.
EnxRegisterableComponentException | Special exception type for TnxRegisterableComponent.
EnxStateComponentException | Exception type used for State components.
TnxBaseComponentConfiguration | An abstract prototype for a Component configuration class. An actual implementation must implement all functions.
TnxBaseLog | Base logging class.
TnxBaseServerConfiguration | An abstract prototype for a Server configuration class. An actual implementation must override ALL functions.
TnxBaseSetting | The base class used for defining storeable component settings. Each setting can be fully defined by this class.
TnxBaseSettings | A collection of TBaseSetting instances. Each nxComponent that wants to save/load settings, must return this list.
TnxBroadcastData | This is class nxllComponent.TnxBroadcastData.
TnxComponent | The mother of most NexusDB components. Includes version info, UI settings, persisting options, error checking.
TnxComponent_BCB | HPPEMIT 'namespace Nxllcomponent' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxComponent_BCB;' HPPEMIT 'class PASCALIMPLEMENTATION TnxComponent_BCB : public Classes::TComponent' HPPEMIT '{' HPPEMIT ' typedef Classes::TComponent inherited;' HPPEMIT '' HPPEMIT '//public:' HPPEMIT ' //#pragma option push -w-inl' HPPEMIT ' ///* virtual class method */ virtual System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' //#pragma option pop' HPPEMIT '};' HPPEMIT '}'
TnxComponentIDContainer |
TnxComponentInfo | This is class nxllComponent.TnxComponentInfo.
TnxIterationData | This is class nxllComponent.TnxIterationData.
TnxIterationList | A special list class used by Iteration methods.
TnxLifetimeTrackedPersistent | This is class nxllComponent.TnxLifetimeTrackedPersistent.
TnxLoggableComponent | A component class that has integrated loggin support.
TnxLoggableComponentInfo | This is class nxllComponent.TnxLoggableComponentInfo.
TnxPersistent | Base class for all persistent NexusDB objects.
TnxRegisterableComponent | An component that can be registered to the system and thus created from class name.
TnxStateComponent | A state component has an integrated simple state engine for Initialiazing, Starting, Stopping and Deactivating the component.
TnxStateComponentInfo | This is class nxllComponent.TnxStateComponentInfo.
Constants
Name | Description
BIAS_UNSPECIFIED | DOM-IGNORE-END
CLSID_ComponentInfo | DOM-IGNORE-END
csDefault | This is constant nxllComponent.csDefault.
lpInfoOrWarning | This is constant nxllComponent.lpInfoOrWarning.
nxn_Broadcast | This is constant nxllComponent.nxn_Broadcast.
nxn_ConfigChanged | This is constant nxllComponent.nxn_ConfigChanged.
nxn_ConnectionLost | This is constant nxllComponent.nxn_ConnectionLost.
nxn_Destroy | This is constant nxllComponent.nxn_Destroy.
nxn_Iterate | This is constant nxllComponent.nxn_Iterate.
nxn_OwnerChanged | This is constant nxllComponent.nxn_OwnerChanged.
nxn_Release | This is constant nxllComponent.nxn_Release.
nxn_StateChanged | This is constant nxllComponent.nxn_StateChanged.
nxn_StateChanging | This is constant nxllComponent.nxn_StateChanging.
nxObjCastGUID | This is constant nxllComponent.nxObjCastGUID.
nxStateDiagram | Given the current state of the engine and the target state of the engine, this array identifies the state to which the engine should be moved. The first dimension (vertical) of the array is the engine's current state. The second dimension (horizontal) of the array is the engine's target state. To get the next state, index into the array as follows: nextState := nxEngineStateDiagram[, ];
nxStateTransitionDiagram | This is constant nxllComponent.nxStateTransitionDiagram.
nxStateTransitionUpward | This is constant nxllComponent.nxStateTransitionUpward.
Functions
Name | Description
nxIntfToObj |
nxIntToStr | This is function nxllComponent.nxIntToStr.
nxIntToStr | This is function nxllComponent.nxIntToStr.
nxMapStateToString | DOM-IGNORE-BEGIN nxMapStateToString
nxMapStateTransitionToString |
Interfaces
Name | Description
InxComponentInfo31000 | This is class nxllComponent.InxComponentInfo31000.
InxComponentInfoDisconnect | This is class nxllComponent.InxComponentInfoDisconnect.
InxLogData | Interface implemented by all components that provide Logging data
InxLoggableComponentInfo31000 | This is class nxllComponent.InxLoggableComponentInfo31000.
InxStateComponentInfo31000 | This is class nxllComponent.InxStateComponentInfo31000.
Structs, Records, Enums
Name | Description
TnxLogPriority | Priorties for InxLogData
TnxSettingType | Settings data type
TnxState | Possible states for TnxStateComponent
TnxStateChangeParam | This is record nxllComponent.TnxStateChangeParam.
TnxStateTransition | Possible state transitions for TnxStateComponent
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EnxComponentExceptionClass | Class definition for Component Exceptions
PInxLogData | BCB
PnxStateChangeParam | DOM-IGNORE-BEGIN
TnxComponentInfoClass | This is type nxllComponent.TnxComponentInfoClass.
TnxIterationListClass | Class definition for TnxIterationList
TnxLogPriorities | Set of TnxLogPriority
TnxNotifyOp | DOM-IGNORE-BEGIN
TnxPersistentClass | Class defintion for TnxPersistent.
TnxRegisterableComponentClass | Class definition for TnxRegisterableComponent.
Variables
Name | Description
___GetMem | This is variable nxllComponent.___GetMem.
_RegisterableComponentList | TnxRegisterableComponent
nxIncludeSelfPtrInExceptionData | This is variable nxllComponent.nxIncludeSelfPtrInExceptionData.
nxIncludeStatsInExceptionData | This is variable nxllComponent.nxIncludeStatsInExceptionData.
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllComponent Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxAbortStateChange | Exception type used for critical state errors.
EnxBaseLogException | Special exception type for all logging classes.
EnxComponentException | A special Exception class that can have additional information about TnxComponent.
EnxLoggableComponentException | Special exception type for logable components.
EnxRegisterableComponentException | Special exception type for TnxRegisterableComponent.
EnxStateComponentException | Exception type used for State components.
TnxBaseComponentConfiguration | An abstract prototype for a Component configuration class. An actual implementation must implement all functions.
TnxBaseLog | Base logging class.
TnxBaseServerConfiguration | An abstract prototype for a Server configuration class. An actual implementation must override ALL functions.
TnxBaseSetting | The base class used for defining storeable component settings. Each setting can be fully defined by this class.
TnxBaseSettings | A collection of TBaseSetting instances. Each nxComponent that wants to save/load settings, must return this list.
TnxBroadcastData | This is class nxllComponent.TnxBroadcastData.
TnxComponent | The mother of most NexusDB components. Includes version info, UI settings, persisting options, error checking.
TnxComponent_BCB | HPPEMIT 'namespace Nxllcomponent' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxComponent_BCB;' HPPEMIT 'class PASCALIMPLEMENTATION TnxComponent_BCB : public Classes::TComponent' HPPEMIT '{' HPPEMIT ' typedef Classes::TComponent inherited;' HPPEMIT '' HPPEMIT '//public:' HPPEMIT ' //#pragma option push -w-inl' HPPEMIT ' ///* virtual class method */ virtual System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' //#pragma option pop' HPPEMIT '};' HPPEMIT '}'
TnxComponentIDContainer |
TnxComponentInfo | This is class nxllComponent.TnxComponentInfo.
TnxIterationData | This is class nxllComponent.TnxIterationData.
TnxIterationList | A special list class used by Iteration methods.
TnxLifetimeTrackedPersistent | This is class nxllComponent.TnxLifetimeTrackedPersistent.
TnxLoggableComponent | A component class that has integrated loggin support.
TnxLoggableComponentInfo | This is class nxllComponent.TnxLoggableComponentInfo.
TnxPersistent | Base class for all persistent NexusDB objects.
TnxRegisterableComponent | An component that can be registered to the system and thus created from class name.
TnxStateComponent | A state component has an integrated simple state engine for Initialiazing, Starting, Stopping and Deactivating the component.
TnxStateComponentInfo | This is class nxllComponent.TnxStateComponentInfo.
Namespace

nxllComponent Namespace

Links
Classes, nxllComponent Namespace, Legend


EnxAbortStateChange Class

EnxAbortStateChange Class
nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxAbortStateChange
Syntax
Delphi
EnxAbortStateChange = class(EAbort);
File

nxllComponent

Description

Exception type used for critical state errors.

Group

Classes

Links
nxllComponent, Classes


EnxBaseLogException Class

EnxBaseLogException Class
nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxBaseLogExceptionnxllComponent_EnxBaseLogExceptionnxllComponent_EnxBaseLogExceptionnxllComponent_EnxBaseLogExceptionnxllComponent_EnxBaseLogExceptionnxllComponent_EnxBaseLogException
Syntax
Delphi
EnxBaseLogException = class(EnxRegisterableComponentException);
File

nxllComponent

Description

Special exception type for all logging classes.

Group

Classes

Links
nxllComponent, Classes


EnxComponentException Class

EnxComponentException Class
nxcCreate Constructor EnxComponentException Methods EnxComponentException Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxComponentExceptionnxllComponent_EnxComponentExceptionnxllComponent_EnxComponentExceptionnxllComponent_EnxComponentException
Syntax
Delphi
EnxComponentException = class(EnxBaseException);
File

nxllComponent

Description

A special Exception class that can have additional information about TnxComponent.

Group

Classes

Links
nxcCreate Constructor, EnxComponentException Methods, EnxComponentException Members, nxllComponent, Classes


EnxComponentException Members

EnxComponentException Members
EnxComponentException Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by EnxComponentException.

Class

EnxComponentException Class

Protected Fields
Name | Description
beCustomInfos | This is beCustomInfos, a member of class EnxBaseException.
beErrorCode | private
beErrorString | This is beErrorString, a member of class EnxBaseException.
beExceptionData | This is beExceptionData, a member of class EnxBaseException.
beExtendedMsg | This is beExtendedMsg, a member of class EnxBaseException.
beOSError | This is beOSError, a member of class EnxBaseException.
beProcessedErrorString | This is beProcessedErrorString, a member of class EnxBaseException.
Protected Methods
Name | Description
_AddRef | EnxBaseException
_Release |
beMsgForErrorCode |
beProcessTemplate |
beStripCustomInfos |
ceGetComponentName | EnxComponentException
GetCustomInfos |
GetErrorCode | InxException
GetErrorString |
GetExceptionData |
GetExtendedMsg |
GetOSError |
GetProcessedErrorString |
QueryInterface | InxInterface
Public Methods
Name | Description
Destroy |
GetCustomInfos | This is GetCustomInfos, a member of class InxException.
GetErrorCode | This is GetErrorCode, a member of class InxBaseException.
GetErrorString | This is GetErrorString, a member of class InxException.
GetExceptionData | This is GetExceptionData, a member of class InxException.
GetExtendedMsg | This is GetExtendedMsg, a member of class InxException.
GetLastConvertedException |
GetOSError | This is GetOSError, a member of class InxException.
GetProcessedErrorString | This is GetProcessedErrorString, a member of class InxException.
nxcCreate | This is the overview for the nxcCreate constructor overload.
nxCreate | This is the overview for the nxCreate method overload.
nxSetMessage | This is the overview for the nxSetMessage method overload.
SetLastConvertedException |
Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class EnxBaseException.
CustomInfos | This is CustomInfos, a member of class InxException.
ErrorCode | This is ErrorCode, a member of class EnxBaseException.
ErrorCode | This is ErrorCode, a member of class InxBaseException.
ErrorString | This is ErrorString, a member of class EnxBaseException.
ErrorString | This is ErrorString, a member of class InxException.
ExceptionData | This is ExceptionData, a member of class InxException.
ExtendedMsg | This is ExtendedMsg, a member of class EnxBaseException.
ExtendedMsg | This is ExtendedMsg, a member of class InxException.
OSError | This is OSError, a member of class EnxBaseException.
OSError | This is OSError, a member of class InxException.
ProcessedErrorString | This is ProcessedErrorString, a member of class EnxBaseException.
ProcessedErrorString | This is ProcessedErrorString, a member of class InxException.
Links
EnxComponentException Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


nxcCreate Constructor

nxcCreate Constructor
EnxComponentException Class Send Feedback

This is the overview for the nxcCreate constructor overload.

Overload List
Name | Description
EnxComponentException.nxcCreate (TComponent, PResStringRec) | constructor
EnxComponentException.nxcCreate (TComponent, PResStringRec, array of const) | constructor
EnxComponentException.nxcCreate (TComponent, string) | constructor
EnxComponentException.nxcCreate (TComponent, string, array of const) | constructor
EnxComponentException.nxcCreate (TComponent, TnxResult) | constructor
EnxComponentException.nxcCreate (TComponent, TnxResult, PResStringRec) | constructor
EnxComponentException.nxcCreate (TComponent, TnxResult, PResStringRec, array of const) | constructor
EnxComponentException.nxcCreate (TComponent, TnxResult, string) | constructor
EnxComponentException.nxcCreate (TComponent, TnxResult, string, array of const) | constructor
Class

EnxComponentException Class

Links
EnxComponentException Class


EnxComponentException.nxcCreate Constructor (TComponent, PResStringRec)

EnxComponentException.nxcCreate Constructor (TComponent, PResStringRec)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aMsgRes: PResStringRec); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, PResStringRec, array of const)

EnxComponentException.nxcCreate Constructor (TComponent, PResStringRec, array of const)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aMsgRes: PResStringRec; const aArgs: array of const); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, TnxResult)

EnxComponentException.nxcCreate Constructor (TComponent, TnxResult)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, PResStringRec)

EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, PResStringRec)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; aAltMsgRes: PResStringRec); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, PResStringRec, array of const)

EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, PResStringRec, array of const)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; aAltMsgRes: PResStringRec; const aArgs: array of const); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, string)

EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, string)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; const aAltMsg: string); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, string, array of const)

EnxComponentException.nxcCreate Constructor (TComponent, TnxResult, string, array of const)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, string)

EnxComponentException.nxcCreate Constructor (TComponent, string)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; const aMsg: string); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException.nxcCreate Constructor (TComponent, string, array of const)

EnxComponentException.nxcCreate Constructor (TComponent, string, array of const)
EnxComponentException Class EnxComponentException Members nxllComponent Namespace nxcCreate Constructor Send Feedback
Syntax
Delphi
constructor nxcCreate(aComponent: TComponent; const aMsg: string; const aArgs: array of const); overload;
Description

constructor

Group

nxcCreate Constructor

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, nxcCreate Constructor


EnxComponentException Methods

EnxComponentException Methods
EnxComponentException Class Legend Protected Methods Send Feedback

The methods of the EnxComponentException class are listed here.

Class

EnxComponentException Class

Protected Methods
Name | Description
ceGetComponentName | EnxComponentException
Links
EnxComponentException Class, Legend, Protected Methods


EnxComponentException.ceGetComponentName Method

EnxComponentException.ceGetComponentName Method
EnxComponentException Class EnxComponentException Members nxllComponent Namespace EnxComponentException Methods Send Feedback
Syntax
Delphi
class function ceGetComponentName(aComponent: TComponent): string; virtual;
Description

EnxComponentException

Group

EnxComponentException Methods

Links
EnxComponentException Class, EnxComponentException Members, nxllComponent Namespace, EnxComponentException Methods


EnxLoggableComponentException Class

EnxLoggableComponentException Class
nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxLoggableComponentExceptionnxllComponent_EnxLoggableComponentExceptionnxllComponent_EnxLoggableComponentExceptionnxllComponent_EnxLoggableComponentExceptionnxllComponent_EnxLoggableComponentExceptionnxllComponent_EnxLoggableComponentException
Syntax
Delphi
EnxLoggableComponentException = class(EnxRegisterableComponentException);
File

nxllComponent

Description

Special exception type for logable components.

Group

Classes

Links
nxllComponent, Classes


EnxRegisterableComponentException Class

EnxRegisterableComponentException Class
nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxRegisterableComponentExceptionnxllComponent_EnxRegisterableComponentExceptionnxllComponent_EnxRegisterableComponentExceptionnxllComponent_EnxRegisterableComponentExceptionnxllComponent_EnxRegisterableComponentException
Syntax
Delphi
EnxRegisterableComponentException = class(EnxComponentException);
File

nxllComponent

Description

Special exception type for TnxRegisterableComponent.

Group

Classes

Links
nxllComponent, Classes


EnxStateComponentException Class

EnxStateComponentException Class
nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentExceptionnxllComponent_EnxStateComponentException
Syntax
Delphi
EnxStateComponentException = class(EnxLoggableComponentException);
File

nxllComponent

Description

Exception type used for State components.

Group

Classes

Links
nxllComponent, Classes


TnxBaseComponentConfiguration Class

TnxBaseComponentConfiguration Class
TnxBaseComponentConfiguration Fields TnxBaseComponentConfiguration Methods TnxBaseComponentConfiguration Properties TnxBaseComponentConfiguration Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBaseComponentConfiguration
Syntax
Delphi
TnxBaseComponentConfiguration = class;
File

nxllComponent

Description

An abstract prototype for a Component configuration class. An actual implementation must implement all functions.

Group

Classes

Links
TnxBaseComponentConfiguration Fields, TnxBaseComponentConfiguration Methods, TnxBaseComponentConfiguration Properties, TnxBaseComponentConfiguration Members, nxllComponent, Classes


TnxBaseComponentConfiguration Members

TnxBaseComponentConfiguration Members
TnxBaseComponentConfiguration Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseComponentConfiguration.

Class

TnxBaseComponentConfiguration Class

Protected Fields
Name | Description
fConfig | This is fConfig, a member of class TnxBaseComponentConfiguration.
Public Methods
Name | Description
Create | TnxBaseComponentConfiguration
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Public Properties
Name | Description
Config | This is Config, a member of class TnxBaseComponentConfiguration.
Links
TnxBaseComponentConfiguration Class, Legend, Protected Fields, Public Methods, Public Properties


TnxBaseComponentConfiguration.Create Constructor

TnxBaseComponentConfiguration.Create Constructor
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Class Send Feedback
Syntax
Delphi
constructor Create(aConfig: TnxBaseServerConfiguration); virtual;
Description

TnxBaseComponentConfiguration

Class

TnxBaseComponentConfiguration Class

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Class


TnxBaseComponentConfiguration Fields

TnxBaseComponentConfiguration Fields
TnxBaseComponentConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxBaseComponentConfiguration class are listed here.

Class

TnxBaseComponentConfiguration Class

Protected Fields
Name | Description
fConfig | This is fConfig, a member of class TnxBaseComponentConfiguration.
Links
TnxBaseComponentConfiguration Class, Legend, Protected Fields


TnxBaseComponentConfiguration.fConfig Field

TnxBaseComponentConfiguration.fConfig Field
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Fields Send Feedback
Syntax
Delphi
fConfig: TnxBaseServerConfiguration;
Description

This is fConfig, a member of class TnxBaseComponentConfiguration.

Group

TnxBaseComponentConfiguration Fields

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Fields


TnxBaseComponentConfiguration Methods

TnxBaseComponentConfiguration Methods
TnxBaseComponentConfiguration Class Legend Public Methods Send Feedback

The methods of the TnxBaseComponentConfiguration class are listed here.

Class

TnxBaseComponentConfiguration Class

Public Methods
Name | Description
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Links
TnxBaseComponentConfiguration Class, Legend, Public Methods


TnxBaseComponentConfiguration.GetValue Method

TnxBaseComponentConfiguration.GetValue Method
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Methods Send Feedback
Syntax
Delphi
function GetValue(aName: String; aDefault: Variant): Variant; virtual;
Description

Get the value associated with aName as Variant.

Group

TnxBaseComponentConfiguration Methods

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Methods


TnxBaseComponentConfiguration.GetValueStream Method

TnxBaseComponentConfiguration.GetValueStream Method
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure GetValueStream(aName: String; aStream: TStream); virtual;
Description

Get the value associated with aName as stream.

Group

TnxBaseComponentConfiguration Methods

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Methods


TnxBaseComponentConfiguration.SetValue Method

TnxBaseComponentConfiguration.SetValue Method
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValue(aName: String; aValue: Variant); virtual;
Description

Set the value associated with aName as Variant.

Group

TnxBaseComponentConfiguration Methods

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Methods


TnxBaseComponentConfiguration.SetValueStream Method

TnxBaseComponentConfiguration.SetValueStream Method
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValueStream(aName: String; aStream: TStream); virtual;
Description

Set the value associated with aName as stream.

Group

TnxBaseComponentConfiguration Methods

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Methods


TnxBaseComponentConfiguration Properties

TnxBaseComponentConfiguration Properties
TnxBaseComponentConfiguration Class Legend Public Properties Send Feedback

The properties of the TnxBaseComponentConfiguration class are listed here.

Class

TnxBaseComponentConfiguration Class

Public Properties
Name | Description
Config | This is Config, a member of class TnxBaseComponentConfiguration.
Links
TnxBaseComponentConfiguration Class, Legend, Public Properties


TnxBaseComponentConfiguration.Config Property

TnxBaseComponentConfiguration.Config Property
TnxBaseComponentConfiguration Class TnxBaseComponentConfiguration Members nxllComponent Namespace TnxBaseComponentConfiguration Properties Send Feedback
Syntax
Delphi
property Config: TnxBaseServerConfiguration;
Description

This is Config, a member of class TnxBaseComponentConfiguration.

Group

TnxBaseComponentConfiguration Properties

Links
TnxBaseComponentConfiguration Class, TnxBaseComponentConfiguration Members, nxllComponent Namespace, TnxBaseComponentConfiguration Properties


TnxBaseLog Class

TnxBaseLog Class
TnxBaseLog Fields TnxBaseLog Methods TnxBaseLog Properties TnxBaseLog Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBaseLognxllComponent_TnxBaseLognxllComponent_TnxBaseLognxllComponent_TnxBaseLognxllComponent_TnxBaseLog
Syntax
Delphi
TnxBaseLog = class(TnxRegisterableComponent);
File

nxllComponent

Description

Base logging class.

Group

Classes

Links
TnxBaseLog Fields, TnxBaseLog Methods, TnxBaseLog Properties, TnxBaseLog Members, nxllComponent, Classes


TnxBaseLog Members

TnxBaseLog Members
TnxBaseLog Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseLog.

Class

TnxBaseLog Class

Protected Fields
Name | Description
blEnabled | private
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
blSetEnabled |
blUnlockLog |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear | Clear the log.
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
Flush | Flush the log.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteStrings | Writes a string to the log.
Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxBaseLog Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseLog Fields

TnxBaseLog Fields
TnxBaseLog Class Legend Protected Fields Send Feedback

The fields of the TnxBaseLog class are listed here.

Class

TnxBaseLog Class

Protected Fields
Name | Description
blEnabled | private
Links
TnxBaseLog Class, Legend, Protected Fields


TnxBaseLog.blEnabled Field

TnxBaseLog.blEnabled Field
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Fields Send Feedback
Syntax
Delphi
blEnabled: Boolean;
Description

private

Group

TnxBaseLog Fields

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Fields


TnxBaseLog Methods

TnxBaseLog Methods
TnxBaseLog Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseLog class are listed here.

Class

TnxBaseLog Class

Protected Methods
Name | Description
blGetEnabled | TnxBaseLog
blLockLog |
blSetEnabled |
blUnlockLog |
nxcExceptionClass |
Public Methods
Name | Description
Clear | Clear the log.
Flush | Flush the log.
WriteBlock | Writes a string and a block of memory to the log.
WriteLogData | Writes an object that implements InxLogData to the log.
WriteString | This is the overview for the WriteString method overload.
WriteStrings | Writes a string to the log.
Links
TnxBaseLog Class, Legend, Protected Methods, Public Methods


TnxBaseLog.blGetEnabled Method

TnxBaseLog.blGetEnabled Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
function blGetEnabled: Boolean;
Description

TnxBaseLog

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.blLockLog Method

TnxBaseLog.blLockLog Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure blLockLog;
Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.blSetEnabled Method

TnxBaseLog.blSetEnabled Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure blSetEnabled(const Value: Boolean); virtual;
Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.blUnlockLog Method

TnxBaseLog.blUnlockLog Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure blUnlockLog;
Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.Clear Method

TnxBaseLog.Clear Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure Clear; virtual;
Description

Clear the log.

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.Flush Method

TnxBaseLog.Flush Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure Flush; virtual;
Description

Flush the log.

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.nxcExceptionClass Method

TnxBaseLog.nxcExceptionClass Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.WriteBlock Method

TnxBaseLog.WriteBlock Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure WriteBlock(const S: string; Buf: Pointer; BufLen: TnxMemSize; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; abstract;
Description

Writes a string and a block of memory to the log.

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog.WriteLogData Method

TnxBaseLog.WriteLogData Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure WriteLogData(LogData: InxLogData); virtual; abstract;
Description

Writes an object that implements InxLogData to the log.

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


WriteString Method

WriteString Method
TnxBaseLog Methods Send Feedback

This is the overview for the WriteString method overload.

Overload List
Name | Description
TnxBaseLog.WriteString (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer) | Writes a string to the log.
TnxBaseLog.WriteString (string, Cardinal, TnxLogPriority, string, TDateTime, Integer) | Writes a string to the log.
Group

TnxBaseLog Methods

Links
TnxBaseLog Methods


TnxBaseLog.WriteString Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxBaseLog.WriteString Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace WriteString Method Send Feedback
Syntax
Delphi
procedure WriteString(const aMsg: string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; abstract; overload;
Description

Writes a string to the log.

Group

WriteString Method

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, WriteString Method


TnxBaseLog.WriteString Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxBaseLog.WriteString Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace WriteString Method Send Feedback
Syntax
Delphi
procedure WriteString(const aMsg: string; const aArgs: array of const; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; abstract; overload;
Description

Writes a string to the log.

Group

WriteString Method

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, WriteString Method


TnxBaseLog.WriteStrings Method

TnxBaseLog.WriteStrings Method
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Methods Send Feedback
Syntax
Delphi
procedure WriteStrings(const Msgs: array of string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; abstract;
Description

Writes a string to the log.

Group

TnxBaseLog Methods

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Methods


TnxBaseLog Properties

TnxBaseLog Properties
TnxBaseLog Class Legend Public Properties Send Feedback

The properties of the TnxBaseLog class are listed here.

Class

TnxBaseLog Class

Public Properties
Name | Description
Enabled | True if the log is currently enabled/active.
Links
TnxBaseLog Class, Legend, Public Properties


TnxBaseLog.Enabled Property

TnxBaseLog.Enabled Property
TnxBaseLog Class TnxBaseLog Members nxllComponent Namespace TnxBaseLog Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

True if the log is currently enabled/active.

Group

TnxBaseLog Properties

Links
TnxBaseLog Class, TnxBaseLog Members, nxllComponent Namespace, TnxBaseLog Properties


TnxBaseServerConfiguration Class

TnxBaseServerConfiguration Class
TnxBaseServerConfiguration Fields TnxBaseServerConfiguration Methods TnxBaseServerConfiguration Properties TnxBaseServerConfiguration Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBaseServerConfiguration
Syntax
Delphi
TnxBaseServerConfiguration = class;
File

nxllComponent

Description

An abstract prototype for a Server configuration class. An actual implementation must override ALL functions.

Group

Classes

Links
TnxBaseServerConfiguration Fields, TnxBaseServerConfiguration Methods, TnxBaseServerConfiguration Properties, TnxBaseServerConfiguration Members, nxllComponent, Classes


TnxBaseServerConfiguration Members

TnxBaseServerConfiguration Members
TnxBaseServerConfiguration Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseServerConfiguration.

Class

TnxBaseServerConfiguration Class

Protected Fields
Name | Description
fConfigErrors | This is fConfigErrors, a member of class TnxBaseServerConfiguration.
fFileName | This is fFileName, a member of class TnxBaseServerConfiguration.
Public Methods
Name | Description
Create | Constructor. TnxBaseServerConfiguration
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Save | This is Save, a member of class TnxBaseServerConfiguration.
Public Properties
Name | Description
Errors | This is Errors, a member of class TnxBaseServerConfiguration.
FileName | This is FileName, a member of class TnxBaseServerConfiguration.
ReportErrors | This is ReportErrors, a member of class TnxBaseServerConfiguration.
Links
TnxBaseServerConfiguration Class, Legend, Protected Fields, Public Methods, Public Properties


TnxBaseServerConfiguration.Create Constructor

TnxBaseServerConfiguration.Create Constructor
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Class Send Feedback
Syntax
Delphi
constructor Create(aFileName: String); virtual;
Description

Constructor.

TnxBaseServerConfiguration

Class

TnxBaseServerConfiguration Class

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Class


TnxBaseServerConfiguration Fields

TnxBaseServerConfiguration Fields
TnxBaseServerConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxBaseServerConfiguration class are listed here.

Class

TnxBaseServerConfiguration Class

Protected Fields
Name | Description
fConfigErrors | This is fConfigErrors, a member of class TnxBaseServerConfiguration.
fFileName | This is fFileName, a member of class TnxBaseServerConfiguration.
Links
TnxBaseServerConfiguration Class, Legend, Protected Fields


TnxBaseServerConfiguration.fConfigErrors Field

TnxBaseServerConfiguration.fConfigErrors Field
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Fields Send Feedback
Syntax
Delphi
fConfigErrors: String;
Description

This is fConfigErrors, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Fields

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Fields


TnxBaseServerConfiguration.fFileName Field

TnxBaseServerConfiguration.fFileName Field
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Fields Send Feedback
Syntax
Delphi
fFileName: string;
Description

This is fFileName, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Fields

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Fields


TnxBaseServerConfiguration Methods

TnxBaseServerConfiguration Methods
TnxBaseServerConfiguration Class Legend Public Methods Send Feedback

The methods of the TnxBaseServerConfiguration class are listed here.

Class

TnxBaseServerConfiguration Class

Public Methods
Name | Description
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Save | This is Save, a member of class TnxBaseServerConfiguration.
Links
TnxBaseServerConfiguration Class, Legend, Public Methods


TnxBaseServerConfiguration.EnsureComponentConfiguration Method

TnxBaseServerConfiguration.EnsureComponentConfiguration Method
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure EnsureComponentConfiguration(aComponent: string; aSettings: TnxBaseSettings); virtual; abstract;
Description

The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.

Group

TnxBaseServerConfiguration Methods

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Methods


TnxBaseServerConfiguration.GetComponentConfiguration Method

TnxBaseServerConfiguration.GetComponentConfiguration Method
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Methods Send Feedback
Syntax
Delphi
function GetComponentConfiguration(aComponent: string): TnxBaseComponentConfiguration; virtual; abstract;
Description

Has to return a TnBaseComponentConfiguration instance for the given Component.

Group

TnxBaseServerConfiguration Methods

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Methods


TnxBaseServerConfiguration.Save Method

TnxBaseServerConfiguration.Save Method
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Save; virtual; abstract;
Description

This is Save, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Methods

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Methods


TnxBaseServerConfiguration Properties

TnxBaseServerConfiguration Properties
TnxBaseServerConfiguration Class Legend Public Properties Send Feedback

The properties of the TnxBaseServerConfiguration class are listed here.

Class

TnxBaseServerConfiguration Class

Public Properties
Name | Description
Errors | This is Errors, a member of class TnxBaseServerConfiguration.
FileName | This is FileName, a member of class TnxBaseServerConfiguration.
ReportErrors | This is ReportErrors, a member of class TnxBaseServerConfiguration.
Links
TnxBaseServerConfiguration Class, Legend, Public Properties


TnxBaseServerConfiguration.Errors Property

TnxBaseServerConfiguration.Errors Property
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Properties Send Feedback
Syntax
Delphi
property Errors: String;
Description

This is Errors, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Properties

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Properties


TnxBaseServerConfiguration.FileName Property

TnxBaseServerConfiguration.FileName Property
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Properties Send Feedback
Syntax
Delphi
property FileName: String;
Description

This is FileName, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Properties

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Properties


TnxBaseServerConfiguration.ReportErrors Property

TnxBaseServerConfiguration.ReportErrors Property
TnxBaseServerConfiguration Class TnxBaseServerConfiguration Members nxllComponent Namespace TnxBaseServerConfiguration Properties Send Feedback
Syntax
Delphi
property ReportErrors: Boolean;
Description

This is ReportErrors, a member of class TnxBaseServerConfiguration.

Group

TnxBaseServerConfiguration Properties

Links
TnxBaseServerConfiguration Class, TnxBaseServerConfiguration Members, nxllComponent Namespace, TnxBaseServerConfiguration Properties


TnxBaseSetting Class

TnxBaseSetting Class
TnxBaseSetting Fields TnxBaseSetting Methods TnxBaseSetting Properties TnxBaseSetting Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBaseSetting
Syntax
Delphi
TnxBaseSetting = class;
File

nxllComponent

Description

The base class used for defining storeable component settings. Each setting can be fully defined by this class.

Group

Classes

Links
TnxBaseSetting Fields, TnxBaseSetting Methods, TnxBaseSetting Properties, TnxBaseSetting Members, nxllComponent, Classes


TnxBaseSetting Members

TnxBaseSetting Members
TnxBaseSetting Class Legend Protected Fields Protected Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSetting.

Class

TnxBaseSetting Class

Protected Fields
Name | Description
fDefaultValue | This is fDefaultValue, a member of class TnxBaseSetting.
fEnforceValues | This is fEnforceValues, a member of class TnxBaseSetting.
fHideFromGUI | This is fHideFromGUI, a member of class TnxBaseSetting.
fHint | This is fHint, a member of class TnxBaseSetting.
fLabel | This is fLabel, a member of class TnxBaseSetting.
fMax | This is fMax, a member of class TnxBaseSetting.
fMin | This is fMin, a member of class TnxBaseSetting.
fName | This is fName, a member of class TnxBaseSetting.
fNotQueryable | This is fNotQueryable, a member of class TnxBaseSetting.
fPropertyName | This is fPropertyName, a member of class TnxBaseSetting.
fSettingType | This is fSettingType, a member of class TnxBaseSetting.
fValueList | This is fValueList, a member of class TnxBaseSetting.
Protected Methods
Name | Description
GetLabel | TnxBaseSetting
Public Properties
Name | Description
_Label | Label.
DefaultValue | Default Value.
EnforceValues | If true then only values of Listvalues are possible.
HideFromGUI | Set to True to hide the setting from the UI; used for internal data.
Hint | A hint to be shown in a UI.
Max | Max value.
Min | Min value.
Name | Name of the Setting.
NotQueryable | Set to True to prevent the value from being queried from a client.
PropertyName | Name of the implementation Property
SettingType | Data type of the setting.
ValueList | List of possible values (usually Comma separated).
Links
TnxBaseSetting Class, Legend, Protected Fields, Protected Methods, Public Properties


TnxBaseSetting Fields

TnxBaseSetting Fields
TnxBaseSetting Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSetting class are listed here.

Class

TnxBaseSetting Class

Protected Fields
Name | Description
fDefaultValue | This is fDefaultValue, a member of class TnxBaseSetting.
fEnforceValues | This is fEnforceValues, a member of class TnxBaseSetting.
fHideFromGUI | This is fHideFromGUI, a member of class TnxBaseSetting.
fHint | This is fHint, a member of class TnxBaseSetting.
fLabel | This is fLabel, a member of class TnxBaseSetting.
fMax | This is fMax, a member of class TnxBaseSetting.
fMin | This is fMin, a member of class TnxBaseSetting.
fName | This is fName, a member of class TnxBaseSetting.
fNotQueryable | This is fNotQueryable, a member of class TnxBaseSetting.
fPropertyName | This is fPropertyName, a member of class TnxBaseSetting.
fSettingType | This is fSettingType, a member of class TnxBaseSetting.
fValueList | This is fValueList, a member of class TnxBaseSetting.
Links
TnxBaseSetting Class, Legend, Protected Fields


TnxBaseSetting.fDefaultValue Field

TnxBaseSetting.fDefaultValue Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fDefaultValue: Variant;
Description

This is fDefaultValue, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fEnforceValues Field

TnxBaseSetting.fEnforceValues Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fEnforceValues: Boolean;
Description

This is fEnforceValues, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fHideFromGUI Field

TnxBaseSetting.fHideFromGUI Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fHideFromGUI: Boolean;
Description

This is fHideFromGUI, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fHint Field

TnxBaseSetting.fHint Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fHint: string;
Description

This is fHint, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fLabel Field

TnxBaseSetting.fLabel Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fLabel: string;
Description

This is fLabel, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fMax Field

TnxBaseSetting.fMax Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fMax: Variant;
Description

This is fMax, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fMin Field

TnxBaseSetting.fMin Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fMin: Variant;
Description

This is fMin, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fName Field

TnxBaseSetting.fName Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fName: string;
Description

This is fName, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fNotQueryable Field

TnxBaseSetting.fNotQueryable Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fNotQueryable: Boolean;
Description

This is fNotQueryable, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fPropertyName Field

TnxBaseSetting.fPropertyName Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fPropertyName: string;
Description

This is fPropertyName, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fSettingType Field

TnxBaseSetting.fSettingType Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fSettingType: TnxSettingType;
Description

This is fSettingType, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting.fValueList Field

TnxBaseSetting.fValueList Field
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Fields Send Feedback
Syntax
Delphi
fValueList: string;
Description

This is fValueList, a member of class TnxBaseSetting.

Group

TnxBaseSetting Fields

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Fields


TnxBaseSetting Methods

TnxBaseSetting Methods
TnxBaseSetting Class Legend Protected Methods Send Feedback

The methods of the TnxBaseSetting class are listed here.

Class

TnxBaseSetting Class

Protected Methods
Name | Description
GetLabel | TnxBaseSetting
Links
TnxBaseSetting Class, Legend, Protected Methods


TnxBaseSetting.GetLabel Method

TnxBaseSetting.GetLabel Method
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Methods Send Feedback
Syntax
Delphi
function GetLabel: String;
Description

TnxBaseSetting

Group

TnxBaseSetting Methods

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Methods


TnxBaseSetting Properties

TnxBaseSetting Properties
TnxBaseSetting Class Legend Public Properties Send Feedback

The properties of the TnxBaseSetting class are listed here.

Class

TnxBaseSetting Class

Public Properties
Name | Description
_Label | Label.
DefaultValue | Default Value.
EnforceValues | If true then only values of Listvalues are possible.
HideFromGUI | Set to True to hide the setting from the UI; used for internal data.
Hint | A hint to be shown in a UI.
Max | Max value.
Min | Min value.
Name | Name of the Setting.
NotQueryable | Set to True to prevent the value from being queried from a client.
PropertyName | Name of the implementation Property
SettingType | Data type of the setting.
ValueList | List of possible values (usually Comma separated).
Links
TnxBaseSetting Class, Legend, Public Properties


TnxBaseSetting._Label Property

TnxBaseSetting._Label Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property _Label: string;
Description

Label.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.DefaultValue Property

TnxBaseSetting.DefaultValue Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property DefaultValue: Variant;
Description

Default Value.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.EnforceValues Property

TnxBaseSetting.EnforceValues Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property EnforceValues: Boolean;
Description

If true then only values of Listvalues are possible.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.HideFromGUI Property

TnxBaseSetting.HideFromGUI Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property HideFromGUI: Boolean;
Description

Set to True to hide the setting from the UI; used for internal data.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.Hint Property

TnxBaseSetting.Hint Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property Hint: string;
Description

A hint to be shown in a UI.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.Max Property

TnxBaseSetting.Max Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property Max: Variant;
Description

Max value.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.Min Property

TnxBaseSetting.Min Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property Min: Variant;
Description

Min value.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.Name Property

TnxBaseSetting.Name Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

Name of the Setting.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.NotQueryable Property

TnxBaseSetting.NotQueryable Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property NotQueryable: Boolean;
Description

Set to True to prevent the value from being queried from a client.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.PropertyName Property

TnxBaseSetting.PropertyName Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property PropertyName: string;
Description

Name of the implementation Property

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.SettingType Property

TnxBaseSetting.SettingType Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property SettingType: TnxSettingType;
Description

Data type of the setting.

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSetting.ValueList Property

TnxBaseSetting.ValueList Property
TnxBaseSetting Class TnxBaseSetting Members nxllComponent Namespace TnxBaseSetting Properties Send Feedback
Syntax
Delphi
property ValueList: string;
Description

List of possible values (usually Comma separated).

Group

TnxBaseSetting Properties

Links
TnxBaseSetting Class, TnxBaseSetting Members, nxllComponent Namespace, TnxBaseSetting Properties


TnxBaseSettings Class

TnxBaseSettings Class
TnxBaseSettings Methods TnxBaseSettings Properties TnxBaseSettings Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBaseSettings
Syntax
Delphi
TnxBaseSettings = class;
File

nxllComponent

Description

A collection of TBaseSetting instances. Each nxComponent that wants to save/load settings, must return this list.

Group

Classes

Links
TnxBaseSettings Methods, TnxBaseSettings Properties, TnxBaseSettings Members, nxllComponent, Classes


TnxBaseSettings Members

TnxBaseSettings Members
TnxBaseSettings Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSettings.

Class

TnxBaseSettings Class

Protected Methods
Name | Description
GetCount | This is GetCount, a member of class TnxBaseSettings.
GetSetting | This is GetSetting, a member of class TnxBaseSettings.
SetSetting | This is SetSetting, a member of class TnxBaseSettings.
Public Methods
Name | Description
AddSetting | Adds a setting to the collection.
RemoveSetting | Removes a setting from the collection.
Public Properties
Name | Description
Count | Returns the number of settings in the collection.
Setting | Returns the setting at position anIndex in the collection.
Links
TnxBaseSettings Class, Legend, Protected Methods, Public Methods, Public Properties


TnxBaseSettings Methods

TnxBaseSettings Methods
TnxBaseSettings Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSettings class are listed here.

Class

TnxBaseSettings Class

Protected Methods
Name | Description
GetCount | This is GetCount, a member of class TnxBaseSettings.
GetSetting | This is GetSetting, a member of class TnxBaseSettings.
SetSetting | This is SetSetting, a member of class TnxBaseSettings.
Public Methods
Name | Description
AddSetting | Adds a setting to the collection.
RemoveSetting | Removes a setting from the collection.
Links
TnxBaseSettings Class, Legend, Protected Methods, Public Methods


TnxBaseSettings.AddSetting Method

TnxBaseSettings.AddSetting Method
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Methods Send Feedback
Syntax
Delphi
function AddSetting(aSetting: TnxBaseSetting): TnxBaseSetting; virtual; abstract;
Description

Adds a setting to the collection.

Group

TnxBaseSettings Methods

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Methods


TnxBaseSettings.GetCount Method

TnxBaseSettings.GetCount Method
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Methods Send Feedback
Syntax
Delphi
function GetCount: integer; virtual; abstract;
Description

This is GetCount, a member of class TnxBaseSettings.

Group

TnxBaseSettings Methods

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Methods


TnxBaseSettings.GetSetting Method

TnxBaseSettings.GetSetting Method
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Methods Send Feedback
Syntax
Delphi
function GetSetting(anIndex: integer): TnxBaseSetting; virtual; abstract;
Description

This is GetSetting, a member of class TnxBaseSettings.

Group

TnxBaseSettings Methods

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Methods


TnxBaseSettings.RemoveSetting Method

TnxBaseSettings.RemoveSetting Method
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Methods Send Feedback
Syntax
Delphi
procedure RemoveSetting(Index: integer); virtual; abstract;
Description

Removes a setting from the collection.

Group

TnxBaseSettings Methods

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Methods


TnxBaseSettings.SetSetting Method

TnxBaseSettings.SetSetting Method
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Methods Send Feedback
Syntax
Delphi
procedure SetSetting(anIndex: integer; const Value: TnxBaseSetting); virtual; abstract;
Description

This is SetSetting, a member of class TnxBaseSettings.

Group

TnxBaseSettings Methods

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Methods


TnxBaseSettings Properties

TnxBaseSettings Properties
TnxBaseSettings Class Legend Public Properties Send Feedback

The properties of the TnxBaseSettings class are listed here.

Class

TnxBaseSettings Class

Public Properties
Name | Description
Count | Returns the number of settings in the collection.
Setting | Returns the setting at position anIndex in the collection.
Links
TnxBaseSettings Class, Legend, Public Properties


TnxBaseSettings.Count Property

TnxBaseSettings.Count Property
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Properties Send Feedback
Syntax
Delphi
property Count: integer;
Description

Returns the number of settings in the collection.

Group

TnxBaseSettings Properties

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Properties


TnxBaseSettings.Setting Property

TnxBaseSettings.Setting Property
TnxBaseSettings Class TnxBaseSettings Members nxllComponent Namespace TnxBaseSettings Properties Send Feedback
Syntax
Delphi
property Setting [anIndex: integer]: TnxBaseSetting;
Description

Returns the setting at position anIndex in the collection.

Group

TnxBaseSettings Properties

Links
TnxBaseSettings Class, TnxBaseSettings Members, nxllComponent Namespace, TnxBaseSettings Properties


TnxBroadcastData Class

TnxBroadcastData Class
TnxBroadcastData Fields TnxBroadcastData Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxBroadcastDatanxllComponent_TnxBroadcastData
Syntax
Delphi
TnxBroadcastData = class(TnxIterationData);
File

nxllComponent

Description

This is class nxllComponent.TnxBroadcastData.

Group

Classes

Links
TnxBroadcastData Fields, TnxBroadcastData Members, nxllComponent, Classes


TnxBroadcastData Members

TnxBroadcastData Members
TnxBroadcastData Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxBroadcastData.

Class

TnxBroadcastData Class

Public Fields
Name | Description
bdNotifyOp | This is bdNotifyOp, a member of class TnxBroadcastData.
bdParam | This is bdParam, a member of class TnxBroadcastData.
bdSender | This is bdSender, a member of class TnxBroadcastData.
IgnoreIterateClasses | This is IgnoreIterateClasses, a member of class TnxIterationData.
IteratonList | This is IteratonList, a member of class TnxIterationData.
Public Methods
Name | Description
Destroy | TnxIterationData
Links
TnxBroadcastData Class, Legend, Public Fields, Public Methods


TnxBroadcastData Fields

TnxBroadcastData Fields
TnxBroadcastData Class Legend Public Fields Send Feedback

The fields of the TnxBroadcastData class are listed here.

Class

TnxBroadcastData Class

Public Fields
Name | Description
bdNotifyOp | This is bdNotifyOp, a member of class TnxBroadcastData.
bdParam | This is bdParam, a member of class TnxBroadcastData.
bdSender | This is bdSender, a member of class TnxBroadcastData.
Links
TnxBroadcastData Class, Legend, Public Fields


TnxBroadcastData.bdNotifyOp Field

TnxBroadcastData.bdNotifyOp Field
TnxBroadcastData Class TnxBroadcastData Members nxllComponent Namespace TnxBroadcastData Fields Send Feedback
Syntax
Delphi
bdNotifyOp: TnxNotifyOp;
Description

This is bdNotifyOp, a member of class TnxBroadcastData.

Group

TnxBroadcastData Fields

Links
TnxBroadcastData Class, TnxBroadcastData Members, nxllComponent Namespace, TnxBroadcastData Fields


TnxBroadcastData.bdParam Field

TnxBroadcastData.bdParam Field
TnxBroadcastData Class TnxBroadcastData Members nxllComponent Namespace TnxBroadcastData Fields Send Feedback
Syntax
Delphi
bdParam: Pointer;
Description

This is bdParam, a member of class TnxBroadcastData.

Group

TnxBroadcastData Fields

Links
TnxBroadcastData Class, TnxBroadcastData Members, nxllComponent Namespace, TnxBroadcastData Fields


TnxBroadcastData.bdSender Field

TnxBroadcastData.bdSender Field
TnxBroadcastData Class TnxBroadcastData Members nxllComponent Namespace TnxBroadcastData Fields Send Feedback
Syntax
Delphi
bdSender: TnxComponent;
Description

This is bdSender, a member of class TnxBroadcastData.

Group

TnxBroadcastData Fields

Links
TnxBroadcastData Class, TnxBroadcastData Members, nxllComponent Namespace, TnxBroadcastData Fields


TnxComponent Class

TnxComponent Class
TnxComponent Fields TnxComponent Methods TnxComponent Properties TnxComponent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxComponentnxllComponent_TnxComponentnxllComponent_TnxComponent
Syntax
Delphi
TnxComponent = class(TnxComponent_BCB, InxExceptionData);
File

nxllComponent

Description

The mother of most NexusDB components. Includes version info, UI settings, persisting options, error checking.

Group

Classes

Links
TnxComponent Fields, TnxComponent Methods, TnxComponent Properties, TnxComponent Members, nxllComponent, Classes


TnxComponent Members

TnxComponent Members
TnxComponent Class Legend Protected Fields Protected Methods Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxComponent.

Class

TnxComponent Class

Protected Fields
Name | Description
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Properties


TnxComponent.Create Constructor

TnxComponent.Create Constructor
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor

Class

TnxComponent Class

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Class


TnxComponent.Destroy Destructor

TnxComponent.Destroy Destructor
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

denstructor

Class

TnxComponent Class

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Class


TnxComponent Fields

TnxComponent Fields
TnxComponent Class Legend Protected Fields Send Feedback

The fields of the TnxComponent class are listed here.

Class

TnxComponent Class

Protected Fields
Name | Description
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Links
TnxComponent Class, Legend, Protected Fields


TnxComponent.nxcDependentList Field

TnxComponent.nxcDependentList Field
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Fields Send Feedback
Syntax
Delphi
nxcDependentList: TnxListPadlock;
Description

This is nxcDependentList, a member of class TnxComponent.

Group

TnxComponent Fields

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Fields


TnxComponent.nxcDestroying Field

TnxComponent.nxcDestroying Field
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Fields Send Feedback
Syntax
Delphi
nxcDestroying: Boolean;
Description

This is nxcDestroying, a member of class TnxComponent.

Group

TnxComponent Fields

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Fields


TnxComponent.nxcDisplayCategory Field

TnxComponent.nxcDisplayCategory Field
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Fields Send Feedback
Syntax
Delphi
nxcDisplayCategory: String;
Description

This is nxcDisplayCategory, a member of class TnxComponent.

Group

TnxComponent Fields

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Fields


TnxComponent.nxcDisplayName Field

TnxComponent.nxcDisplayName Field
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Fields Send Feedback
Syntax
Delphi
nxcDisplayName: string;
Description

This is nxcDisplayName, a member of class TnxComponent.

Group

TnxComponent Fields

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Fields


TnxComponent.nxcOnSettingsLoaded Field

TnxComponent.nxcOnSettingsLoaded Field
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Fields Send Feedback
Syntax
Delphi
nxcOnSettingsLoaded: TNotifyEvent;
Description

This is nxcOnSettingsLoaded, a member of class TnxComponent.

Group

TnxComponent Fields

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Fields


TnxComponent Methods

TnxComponent Methods
TnxComponent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxComponent class are listed here.

Class

TnxComponent Class

Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Links
TnxComponent Class, Legend, Protected Methods, Public Methods


TnxComponent.BeforeDestruction Method

TnxComponent.BeforeDestruction Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TComponent.BeforeDestruction

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.ClearStats Method

TnxComponent.ClearStats Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure ClearStats; virtual;
Description

Resets all internal stats.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.DoLoadConfig Method

TnxComponent.DoLoadConfig Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure DoLoadConfig(aConfig: TnxBaseComponentConfiguration);
Description

Loads persisted settings.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.FindClassRecursive Method

TnxComponent.FindClassRecursive Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function FindClassRecursive(aSuffix: String): TClass; virtual;
Description

Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.FreeInstance Method

TnxComponent.FreeInstance Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Description

Overriden to take advantage of the NexusDB Memory Manager.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetComponentID Method

TnxComponent.GetComponentID Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function GetComponentID: TnxBaseID;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetConfigSettings Method

TnxComponent.GetConfigSettings Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); virtual;
Description

Returns the defintion of all persistable settings.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetDisplayOnlyValue Method

TnxComponent.GetDisplayOnlyValue Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function GetDisplayOnlyValue(aValueName: string): string; virtual;
Description

returns readonly/displayonly value; eg information values displayed in server config

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetExceptionData Method

TnxComponent.GetExceptionData Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); virtual;
Description

InxExceptionData

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetExceptionDataStats Method

TnxComponent.GetExceptionDataStats Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure GetExceptionDataStats(const aContainer: InxExceptionDataContainer);
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetLifetimeMontior Method

TnxComponent.GetLifetimeMontior Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function GetLifetimeMontior: InxLifetimeMonitorRef;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetStatsCaptions Method

TnxComponent.GetStatsCaptions Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); virtual;
Description

Returns the captions for the returned statistic values.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.GetStatsValues Method

TnxComponent.GetStatsValues Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); virtual;
Description

Returns statistic values.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.IterateDependents Method

TnxComponent.IterateDependents Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function IterateDependents(aIterationListClass: TnxIterationListClass = nil): TnxIterationList;
Description

Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.IterateDependentsEx Method

TnxComponent.IterateDependentsEx Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function IterateDependentsEx(const aIgnoreClasses: array of string; aIterationListClass: TnxIterationListClass = nil): TnxIterationList;
Description

Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.LoadConfig Method

TnxComponent.LoadConfig Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); virtual;
Description

Loads persisted settings.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.LoadSettingsFromStream Method

TnxComponent.LoadSettingsFromStream Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); virtual;
Description

Loads persisted settings. (legacy V1)

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.LookupByComponentID Method

TnxComponent.LookupByComponentID Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
class function LookupByComponentID(aID: TnxBaseID): TnxComponent;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcAddDependent Method

TnxComponent.nxcAddDependent Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcAddDependingOn Method

TnxComponent.nxcAddDependingOn Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependingOn(aComponent: TnxComponent);
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcCheck Method

TnxComponent.nxcCheck Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcCheck(const aErrorCode: TnxResult); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcCreateComponentInfo Method

TnxComponent.nxcCreateComponentInfo Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function nxcCreateComponentInfo: InxInterface; virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcCreateInstance Method

TnxComponent.nxcCreateInstance Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function nxcCreateInstance(const aSession: InxInterface; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


nxcError Method

nxcError Method
TnxComponent Methods Send Feedback

This is the overview for the nxcError method overload.

Overload List
Name | Description
TnxComponent.nxcError (PResStringRec) |
TnxComponent.nxcError (PResStringRec, array of const) |
TnxComponent.nxcError (string) |
TnxComponent.nxcError (string, array of const) |
TnxComponent.nxcError (TnxResult) |
TnxComponent.nxcError (TnxResult, PResStringRec) |
TnxComponent.nxcError (TnxResult, PResStringRec, array of const) |
Group

TnxComponent Methods

Links
TnxComponent Methods


TnxComponent.nxcError Method (PResStringRec)

TnxComponent.nxcError Method (PResStringRec)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(aMsgRes: PResStringRec); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (PResStringRec, array of const)

TnxComponent.nxcError Method (PResStringRec, array of const)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(aMsgRes: PResStringRec; const aArgs: array of const); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (TnxResult)

TnxComponent.nxcError Method (TnxResult)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (TnxResult, PResStringRec)

TnxComponent.nxcError Method (TnxResult, PResStringRec)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; aMsgRes: PResStringRec); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (TnxResult, PResStringRec, array of const)

TnxComponent.nxcError Method (TnxResult, PResStringRec, array of const)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aErrorCode: TnxResult; aMsgRes: PResStringRec; const aArgs: array of const); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (string)

TnxComponent.nxcError Method (string)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aMsg: string); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcError Method (string, array of const)

TnxComponent.nxcError Method (string, array of const)
TnxComponent Class TnxComponent Members nxllComponent Namespace nxcError Method Send Feedback
Syntax
Delphi
procedure nxcError(const aMsg: string; const aArgs: array of const); virtual; overload;
Group

nxcError Method

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, nxcError Method


TnxComponent.nxcExceptionClass Method

TnxComponent.nxcExceptionClass Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; virtual;
Description

TnxComponent

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcGetDisplayName Method

TnxComponent.nxcGetDisplayName Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function nxcGetDisplayName: string;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcIsDisplayNameStored Method

TnxComponent.nxcIsDisplayNameStored Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function nxcIsDisplayNameStored: Boolean;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcNotification Method

TnxComponent.nxcNotification Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcNotifyBroadcast Method

TnxComponent.nxcNotifyBroadcast Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotifyBroadcast(aOperation: TnxNotifyOp; aParam: Pointer; aIgnoreClasses: array of string); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcNotifyDependents Method

TnxComponent.nxcNotifyDependents Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotifyDependents(aOperation: TnxNotifyOp; aParam: Pointer = nil; aExcept: TnxComponent = nil); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcRemoveDependent Method

TnxComponent.nxcRemoveDependent Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); virtual;
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.nxcRemoveDependingOn Method

TnxComponent.nxcRemoveDependingOn Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependingOn(aComponent: TnxComponent);
Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.SaveConfig Method

TnxComponent.SaveConfig Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); virtual;
Description

Persists settings.

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.SaveSettingsToStream Method

TnxComponent.SaveSettingsToStream Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); virtual;
Description

Persists settings. (legacy V1)

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.Supported Method

TnxComponent.Supported Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function Supported: Boolean; virtual;
Description

This function returns true if the component is supported in the current environment (e.g. windows version)

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.UISettingsVisible Method

TnxComponent.UISettingsVisible Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function UISettingsVisible: Boolean; virtual;
Description

Are there UI settings visible for this component? (legacy V1)

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent.UIStatsVisible Method

TnxComponent.UIStatsVisible Method
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Methods Send Feedback
Syntax
Delphi
function UIStatsVisible: Boolean; virtual;
Description

Are there UI statistics visible for this component? (legacy V1)

Group

TnxComponent Methods

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Methods


TnxComponent Properties

TnxComponent Properties
TnxComponent Class Legend Published Properties Send Feedback

The properties of the TnxComponent class are listed here.

Class

TnxComponent Class

Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxComponent Class, Legend, Published Properties


TnxComponent.DisplayCategory Property

TnxComponent.DisplayCategory Property
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Properties Send Feedback
Syntax
Delphi
property DisplayCategory: String;
Description

Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)

Group

TnxComponent Properties

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Properties


TnxComponent.DisplayName Property

TnxComponent.DisplayName Property
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Properties Send Feedback
Syntax
Delphi
property DisplayName: string;
Description

Name of the component if used in a UI. (legacy V1)

Group

TnxComponent Properties

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Properties


TnxComponent.OnSettingsLoaded Property

TnxComponent.OnSettingsLoaded Property
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Properties Send Feedback
Syntax
Delphi
property OnSettingsLoaded: TNotifyEvent;
Description

This is OnSettingsLoaded, a member of class TnxComponent.

Group

TnxComponent Properties

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Properties


TnxComponent.Version Property

TnxComponent.Version Property
TnxComponent Class TnxComponent Members nxllComponent Namespace TnxComponent Properties Send Feedback
Syntax
Delphi
property Version: string;
Description

Version of the component.

Group

TnxComponent Properties

Links
TnxComponent Class, TnxComponent Members, nxllComponent Namespace, TnxComponent Properties


TnxComponent_BCB Class

TnxComponent_BCB Class
TnxComponent_BCB Methods TnxComponent_BCB Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxComponent_BCB
Syntax
Delphi
TnxComponent_BCB = class(TComponent);
File

nxllComponent

Description

HPPEMIT 'namespace Nxllcomponent' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxComponent_BCB;' HPPEMIT 'class PASCALIMPLEMENTATION TnxComponent_BCB : public Classes::TComponent' HPPEMIT '{' HPPEMIT ' typedef Classes::TComponent inherited;' HPPEMIT '' HPPEMIT '//public:' HPPEMIT ' //#pragma option push -w-inl' HPPEMIT ' ///* virtual class method */ virtual System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' //#pragma option pop' HPPEMIT '};' HPPEMIT '}'

Group

Classes

Links
TnxComponent_BCB Methods, TnxComponent_BCB Members, nxllComponent, Classes


TnxComponent_BCB Members

TnxComponent_BCB Members
TnxComponent_BCB Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxComponent_BCB.

Class

TnxComponent_BCB Class

Public Methods
Name | Description
NewInstance |
Links
TnxComponent_BCB Class, Legend, Public Methods


TnxComponent_BCB Methods

TnxComponent_BCB Methods
TnxComponent_BCB Class Legend Public Methods Send Feedback

The methods of the TnxComponent_BCB class are listed here.

Class

TnxComponent_BCB Class

Public Methods
Name | Description
NewInstance |
Links
TnxComponent_BCB Class, Legend, Public Methods


TnxComponent_BCB.NewInstance Method

TnxComponent_BCB.NewInstance Method
TnxComponent_BCB Class TnxComponent_BCB Members nxllComponent Namespace TnxComponent_BCB Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxComponent_BCB Methods

Links
TnxComponent_BCB Class, TnxComponent_BCB Members, nxllComponent Namespace, TnxComponent_BCB Methods


TnxComponentIDContainer Class

TnxComponentIDContainer Class
TnxComponentIDContainer Fields TnxComponentIDContainer Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxComponentIDContainernxllComponent_TnxComponentIDContainernxllComponent_TnxComponentIDContainer
Syntax
Delphi
TnxComponentIDContainer = class(TnxLowObject);
File

nxllComponent

Group

Classes

Links
TnxComponentIDContainer Fields, TnxComponentIDContainer Members, nxllComponent, Classes


TnxComponentIDContainer Members

TnxComponentIDContainer Members
TnxComponentIDContainer Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxComponentIDContainer.

Class

TnxComponentIDContainer Class

Public Fields
Name | Description
cicComponent | This is cicComponent, a member of class TnxComponentIDContainer.
Public Methods
Name | Description
Create |
FreeInstance |
NewInstance | TnxLowObject
NewInstance | TnxObject
Links
TnxComponentIDContainer Class, Legend, Public Fields, Public Methods


TnxComponentIDContainer.Create Constructor

TnxComponentIDContainer.Create Constructor
TnxComponentIDContainer Class TnxComponentIDContainer Members nxllComponent Namespace TnxComponentIDContainer Class Send Feedback
Syntax
Delphi
constructor Create(aComponent: TnxComponent);
Class

TnxComponentIDContainer Class

Links
TnxComponentIDContainer Class, TnxComponentIDContainer Members, nxllComponent Namespace, TnxComponentIDContainer Class


TnxComponentIDContainer Fields

TnxComponentIDContainer Fields
TnxComponentIDContainer Class Legend Public Fields Send Feedback

The fields of the TnxComponentIDContainer class are listed here.

Class

TnxComponentIDContainer Class

Public Fields
Name | Description
cicComponent | This is cicComponent, a member of class TnxComponentIDContainer.
Links
TnxComponentIDContainer Class, Legend, Public Fields


TnxComponentIDContainer.cicComponent Field

TnxComponentIDContainer.cicComponent Field
TnxComponentIDContainer Class TnxComponentIDContainer Members nxllComponent Namespace TnxComponentIDContainer Fields Send Feedback
Syntax
Delphi
cicComponent: TnxComponent;
Description

This is cicComponent, a member of class TnxComponentIDContainer.

Group

TnxComponentIDContainer Fields

Links
TnxComponentIDContainer Class, TnxComponentIDContainer Members, nxllComponent Namespace, TnxComponentIDContainer Fields


TnxComponentInfo Class

TnxComponentInfo Class
TnxComponentInfo Fields TnxComponentInfo Methods TnxComponentInfo Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxComponentInfonxllComponent_TnxComponentInfonxllComponent_TnxComponentInfonxllComponent_TnxComponentInfonxllComponent_TnxComponentInfo
Syntax
Delphi
TnxComponentInfo = class(TnxInterfacedObject, InxComponentInfo31000, InxComponentInfoDisconnect);
File

nxllComponent

Description

This is class nxllComponent.TnxComponentInfo.

Group

Classes

Links
TnxComponentInfo Fields, TnxComponentInfo Methods, TnxComponentInfo Members, nxllComponent, Classes


TnxComponentInfo Members

TnxComponentInfo Members
TnxComponentInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxComponentInfo.

Class

TnxComponentInfo Class

Protected Fields
Name | Description
ciComponent | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Create | TnxComponentInfo
Disconnect | InxComponentInfoDisconnect
GetClassName | InxComponentInfo31000
GetDisplayCategory |
GetDisplayName |
GetName |
GetStatsCaptions |
GetStatsValues |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
Name | This is Name, a member of class InxComponentInfo31000.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxComponentInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxComponentInfo.Create Constructor

TnxComponentInfo.Create Constructor
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Class Send Feedback
Syntax
Delphi
constructor Create(aComponent: TnxComponent);
Description

TnxComponentInfo

Class

TnxComponentInfo Class

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Class


TnxComponentInfo Fields

TnxComponentInfo Fields
TnxComponentInfo Class Legend Protected Fields Send Feedback

The fields of the TnxComponentInfo class are listed here.

Class

TnxComponentInfo Class

Protected Fields
Name | Description
ciComponent | private
Links
TnxComponentInfo Class, Legend, Protected Fields


TnxComponentInfo.ciComponent Field

TnxComponentInfo.ciComponent Field
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Fields Send Feedback
Syntax
Delphi
ciComponent: TnxComponent;
Description

private

Group

TnxComponentInfo Fields

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Fields


TnxComponentInfo Methods

TnxComponentInfo Methods
TnxComponentInfo Class Legend Protected Methods Send Feedback

The methods of the TnxComponentInfo class are listed here.

Class

TnxComponentInfo Class

Protected Methods
Name | Description
Disconnect | InxComponentInfoDisconnect
GetClassName | InxComponentInfo31000
GetDisplayCategory |
GetDisplayName |
GetName |
GetStatsCaptions |
GetStatsValues |
Links
TnxComponentInfo Class, Legend, Protected Methods


TnxComponentInfo.Disconnect Method

TnxComponentInfo.Disconnect Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

InxComponentInfoDisconnect

Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetClassName Method

TnxComponentInfo.GetClassName Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetClassName: string;
Description

InxComponentInfo31000

Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetDisplayCategory Method

TnxComponentInfo.GetDisplayCategory Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetDisplayCategory: string;
Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetDisplayName Method

TnxComponentInfo.GetDisplayName Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetDisplayName: string;
Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetName Method

TnxComponentInfo.GetName Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetName: string;
Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetStatsCaptions Method

TnxComponentInfo.GetStatsCaptions Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetStatsCaptions: TnxDynStringArray;
Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxComponentInfo.GetStatsValues Method

TnxComponentInfo.GetStatsValues Method
TnxComponentInfo Class TnxComponentInfo Members nxllComponent Namespace TnxComponentInfo Methods Send Feedback
Syntax
Delphi
function GetStatsValues: TnxDynStringArray;
Group

TnxComponentInfo Methods

Links
TnxComponentInfo Class, TnxComponentInfo Members, nxllComponent Namespace, TnxComponentInfo Methods


TnxIterationData Class

TnxIterationData Class
TnxIterationData Fields TnxIterationData Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxIterationData
Syntax
Delphi
TnxIterationData = class;
File

nxllComponent

Description

This is class nxllComponent.TnxIterationData.

Group

Classes

Links
TnxIterationData Fields, TnxIterationData Members, nxllComponent, Classes


TnxIterationData Members

TnxIterationData Members
TnxIterationData Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxIterationData.

Class

TnxIterationData Class

Public Fields
Name | Description
IgnoreIterateClasses | This is IgnoreIterateClasses, a member of class TnxIterationData.
IteratonList | This is IteratonList, a member of class TnxIterationData.
Public Methods
Name | Description
Destroy | TnxIterationData
Links
TnxIterationData Class, Legend, Public Fields, Public Methods


TnxIterationData.Destroy Destructor

TnxIterationData.Destroy Destructor
TnxIterationData Class TnxIterationData Members nxllComponent Namespace TnxIterationData Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

TnxIterationData

Class

TnxIterationData Class

Links
TnxIterationData Class, TnxIterationData Members, nxllComponent Namespace, TnxIterationData Class


TnxIterationData Fields

TnxIterationData Fields
TnxIterationData Class Legend Public Fields Send Feedback

The fields of the TnxIterationData class are listed here.

Class

TnxIterationData Class

Public Fields
Name | Description
IgnoreIterateClasses | This is IgnoreIterateClasses, a member of class TnxIterationData.
IteratonList | This is IteratonList, a member of class TnxIterationData.
Links
TnxIterationData Class, Legend, Public Fields


TnxIterationData.IgnoreIterateClasses Field

TnxIterationData.IgnoreIterateClasses Field
TnxIterationData Class TnxIterationData Members nxllComponent Namespace TnxIterationData Fields Send Feedback
Syntax
Delphi
IgnoreIterateClasses: TnxFastStringListIC;
Description

This is IgnoreIterateClasses, a member of class TnxIterationData.

Group

TnxIterationData Fields

Links
TnxIterationData Class, TnxIterationData Members, nxllComponent Namespace, TnxIterationData Fields


TnxIterationData.IteratonList Field

TnxIterationData.IteratonList Field
TnxIterationData Class TnxIterationData Members nxllComponent Namespace TnxIterationData Fields Send Feedback
Syntax
Delphi
IteratonList: TnxIterationList;
Description

This is IteratonList, a member of class TnxIterationData.

Group

TnxIterationData Fields

Links
TnxIterationData Class, TnxIterationData Members, nxllComponent Namespace, TnxIterationData Fields


TnxIterationList Class

TnxIterationList Class
TnxIterationList Methods TnxIterationList Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxIterationListnxllComponent_TnxIterationListnxllComponent_TnxIterationListnxllComponent_TnxIterationListnxllComponent_TnxIterationList
Syntax
Delphi
TnxIterationList = class(TnxSortedList);
File

nxllComponent

Description

A special list class used by Iteration methods.

Group

Classes

Links
TnxIterationList Methods, TnxIterationList Members, nxllComponent, Classes


TnxIterationList Members

TnxIterationList Members
TnxIterationList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxIterationList.

Class

TnxIterationList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
slModified | This is slModified, a member of class TnxSortedList.
slSuspendCount | This is slSuspendCount, a member of class TnxSortedList.
wlInitCapacity | private
Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
ilShouldAdd |
slCompare |
slSort |
wlGrow |
wlSetCapacity |
Public Methods
Name | Description
Add | Adds a new pointer to the list TnxIterationList
AddData |
AddData | This is AddData, a member of class TnxWriteableList.
AddList | TnxWriteableList
Clear |
Create |
Delete |
Destroy |
Find |
First |
FreeInstance |
IndexOf | This is IndexOf, a member of class TnxBaseList.
IndexOf |
Last |
LoadSetttingsFromStream | Loads items from a stream into the list
NewInstance | TnxObject
Release | This is the overview for the Release method overload.
Remove |
ResumeSorting |
SaveSettingsToStream | Saves the items in the list to a stream
SuspendSorting |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxBaseList.
Capacity | This is Capacity, a member of class TnxWriteableList.
Count | This is Count, a member of class TnxBaseList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxBaseList.
List | This is List, a member of class TnxBaseList.
Links
TnxIterationList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxIterationList Methods

TnxIterationList Methods
TnxIterationList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxIterationList class are listed here.

Class

TnxIterationList Class

Protected Methods
Name | Description
ilShouldAdd |
slCompare |
Public Methods
Name | Description
Add | Adds a new pointer to the list TnxIterationList
LoadSetttingsFromStream | Loads items from a stream into the list
SaveSettingsToStream | Saves the items in the list to a stream
Links
TnxIterationList Class, Legend, Protected Methods, Public Methods


TnxIterationList.Add Method

TnxIterationList.Add Method
TnxIterationList Class TnxIterationList Members nxllComponent Namespace TnxIterationList Methods Send Feedback
Syntax
Delphi
function Add(aItem: Pointer): Integer; override;
Description

Adds a new pointer to the list

TnxIterationList

Group

TnxIterationList Methods

Links
TnxIterationList Class, TnxIterationList Members, nxllComponent Namespace, TnxIterationList Methods


TnxIterationList.ilShouldAdd Method

TnxIterationList.ilShouldAdd Method
TnxIterationList Class TnxIterationList Members nxllComponent Namespace TnxIterationList Methods Send Feedback
Syntax
Delphi
function ilShouldAdd(aComponent: TnxComponent): Boolean; virtual;
Group

TnxIterationList Methods

Links
TnxIterationList Class, TnxIterationList Members, nxllComponent Namespace, TnxIterationList Methods


TnxIterationList.LoadSetttingsFromStream Method

TnxIterationList.LoadSetttingsFromStream Method
TnxIterationList Class TnxIterationList Members nxllComponent Namespace TnxIterationList Methods Send Feedback
Syntax
Delphi
procedure LoadSetttingsFromStream(aReader: TnxReader); virtual;
Description

Loads items from a stream into the list

Group

TnxIterationList Methods

Links
TnxIterationList Class, TnxIterationList Members, nxllComponent Namespace, TnxIterationList Methods


TnxIterationList.SaveSettingsToStream Method

TnxIterationList.SaveSettingsToStream Method
TnxIterationList Class TnxIterationList Members nxllComponent Namespace TnxIterationList Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); virtual;
Description

Saves the items in the list to a stream

Group

TnxIterationList Methods

Links
TnxIterationList Class, TnxIterationList Members, nxllComponent Namespace, TnxIterationList Methods


TnxIterationList.slCompare Method

TnxIterationList.slCompare Method
TnxIterationList Class TnxIterationList Members nxllComponent Namespace TnxIterationList Methods Send Feedback
Syntax
Delphi
function slCompare(a: Pointer; b: Pointer): TnxValueRelationship; override;
Group

TnxIterationList Methods

Links
TnxIterationList Class, TnxIterationList Members, nxllComponent Namespace, TnxIterationList Methods


TnxLifetimeTrackedPersistent Class

TnxLifetimeTrackedPersistent Class
TnxLifetimeTrackedPersistent Fields TnxLifetimeTrackedPersistent Methods TnxLifetimeTrackedPersistent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxLifetimeTrackedPersistentnxllComponent_TnxLifetimeTrackedPersistentnxllComponent_TnxLifetimeTrackedPersistent
Syntax
Delphi
TnxLifetimeTrackedPersistent = class(TnxPersistent);
File

nxllComponent

Description

This is class nxllComponent.TnxLifetimeTrackedPersistent.

Group

Classes

Links
TnxLifetimeTrackedPersistent Fields, TnxLifetimeTrackedPersistent Methods, TnxLifetimeTrackedPersistent Members, nxllComponent, Classes


TnxLifetimeTrackedPersistent Members

TnxLifetimeTrackedPersistent Members
TnxLifetimeTrackedPersistent Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxLifetimeTrackedPersistent.

Class

TnxLifetimeTrackedPersistent Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxLifetimeTrackedPersistent Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxLifetimeTrackedPersistent Fields

TnxLifetimeTrackedPersistent Fields
TnxLifetimeTrackedPersistent Class Legend Protected Fields Send Feedback

The fields of the TnxLifetimeTrackedPersistent class are listed here.

Class

TnxLifetimeTrackedPersistent Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
Links
TnxLifetimeTrackedPersistent Class, Legend, Protected Fields


TnxLifetimeTrackedPersistent.ltpLifetimeMonitor Field

TnxLifetimeTrackedPersistent.ltpLifetimeMonitor Field
TnxLifetimeTrackedPersistent Class TnxLifetimeTrackedPersistent Members nxllComponent Namespace TnxLifetimeTrackedPersistent Fields Send Feedback
Syntax
Delphi
ltpLifetimeMonitor: InxLifetimeMonitorObject;
Description

private

Group

TnxLifetimeTrackedPersistent Fields

Links
TnxLifetimeTrackedPersistent Class, TnxLifetimeTrackedPersistent Members, nxllComponent Namespace, TnxLifetimeTrackedPersistent Fields


TnxLifetimeTrackedPersistent Methods

TnxLifetimeTrackedPersistent Methods
TnxLifetimeTrackedPersistent Class Legend Public Methods Send Feedback

The methods of the TnxLifetimeTrackedPersistent class are listed here.

Class

TnxLifetimeTrackedPersistent Class

Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
GetLifetimeMontior |
Links
TnxLifetimeTrackedPersistent Class, Legend, Public Methods


TnxLifetimeTrackedPersistent.BeforeDestruction Method

TnxLifetimeTrackedPersistent.BeforeDestruction Method
TnxLifetimeTrackedPersistent Class TnxLifetimeTrackedPersistent Members nxllComponent Namespace TnxLifetimeTrackedPersistent Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

TnxLifetimeTrackedPersistent

Group

TnxLifetimeTrackedPersistent Methods

Links
TnxLifetimeTrackedPersistent Class, TnxLifetimeTrackedPersistent Members, nxllComponent Namespace, TnxLifetimeTrackedPersistent Methods


TnxLifetimeTrackedPersistent.GetLifetimeMontior Method

TnxLifetimeTrackedPersistent.GetLifetimeMontior Method
TnxLifetimeTrackedPersistent Class TnxLifetimeTrackedPersistent Members nxllComponent Namespace TnxLifetimeTrackedPersistent Methods Send Feedback
Syntax
Delphi
function GetLifetimeMontior: InxLifetimeMonitorRef;
Group

TnxLifetimeTrackedPersistent Methods

Links
TnxLifetimeTrackedPersistent Class, TnxLifetimeTrackedPersistent Members, nxllComponent Namespace, TnxLifetimeTrackedPersistent Methods


TnxLoggableComponent Class

TnxLoggableComponent Class
TnxLoggableComponent Fields TnxLoggableComponent Methods TnxLoggableComponent Properties TnxLoggableComponent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxLoggableComponentnxllComponent_TnxLoggableComponentnxllComponent_TnxLoggableComponentnxllComponent_TnxLoggableComponentnxllComponent_TnxLoggableComponent
Syntax
Delphi
TnxLoggableComponent = class(TnxRegisterableComponent);
File

nxllComponent

Description

A component class that has integrated loggin support.

Group

Classes

Links
TnxLoggableComponent Fields, TnxLoggableComponent Methods, TnxLoggableComponent Properties, TnxLoggableComponent Members, nxllComponent, Classes


TnxLoggableComponent Members

TnxLoggableComponent Members
TnxLoggableComponent Class Legend Protected Fields Protected Methods Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxLoggableComponent.

Class

TnxLoggableComponent Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxLoggableComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Properties


TnxLoggableComponent Fields

TnxLoggableComponent Fields
TnxLoggableComponent Class Legend Protected Fields Send Feedback

The fields of the TnxLoggableComponent class are listed here.

Class

TnxLoggableComponent Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
Links
TnxLoggableComponent Class, Legend, Protected Fields


TnxLoggableComponent.lcEventLog Field

TnxLoggableComponent.lcEventLog Field
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Fields Send Feedback
Syntax
Delphi
lcEventLog: TnxBaseLog;
Description

private

Group

TnxLoggableComponent Fields

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Fields


TnxLoggableComponent.lcLogEnabled Field

TnxLoggableComponent.lcLogEnabled Field
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Fields Send Feedback
Syntax
Delphi
lcLogEnabled: Boolean;
Description

This is lcLogEnabled, a member of class TnxLoggableComponent.

Group

TnxLoggableComponent Fields

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Fields


TnxLoggableComponent Methods

TnxLoggableComponent Methods
TnxLoggableComponent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxLoggableComponent class are listed here.

Class

TnxLoggableComponent Class

Protected Methods
Name | Description
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
nxcCreateComponentInfo |
nxcExceptionClass |
nxcNotification |
Public Methods
Name | Description
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
Links
TnxLoggableComponent Class, Legend, Protected Methods, Public Methods


TnxLoggableComponent.lcGetLogEnabled Method

TnxLoggableComponent.lcGetLogEnabled Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
function lcGetLogEnabled: Boolean; virtual;
Description

TnxLoggableComponent

Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


lcLog Method

lcLog Method
TnxLoggableComponent Methods Send Feedback

This is the overview for the lcLog method overload.

Overload List
Name | Description
TnxLoggableComponent.lcLog (string, , TnxMemSize, Cardinal, TnxLogPriority, string, TDateTime, Integer) | Log a string and Memory Block.
TnxLoggableComponent.lcLog (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer) | Log a string.
TnxLoggableComponent.lcLog (string, Cardinal, TnxLogPriority, string, TDateTime, Integer) | Log a string.
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Methods


TnxLoggableComponent.lcLog Method (string, , TnxMemSize, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxLoggableComponent.lcLog Method (string, , TnxMemSize, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace lcLog Method Send Feedback
Syntax
Delphi
procedure lcLog(const aMsg: string; const aData; aDataLen: TnxMemSize; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; overload;
Description

Log a string and Memory Block.

Group

lcLog Method

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, lcLog Method


TnxLoggableComponent.lcLog Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxLoggableComponent.lcLog Method (string, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace lcLog Method Send Feedback
Syntax
Delphi
procedure lcLog(const aMsg: string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; overload;
Description

Log a string.

Group

lcLog Method

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, lcLog Method


TnxLoggableComponent.lcLog Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)

TnxLoggableComponent.lcLog Method (string, array of const, Cardinal, TnxLogPriority, string, TDateTime, Integer)
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace lcLog Method Send Feedback
Syntax
Delphi
procedure lcLog(const aMsg: string; const aArgs: array of const; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; overload;
Description

Log a string.

Group

lcLog Method

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, lcLog Method


TnxLoggableComponent.lcLogs Method

TnxLoggableComponent.lcLogs Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
procedure lcLogs(const aMsgs: array of string; const aMsgNumber: Cardinal = 0; const aPriority: TnxLogPriority = lpError; const aCategory: string = csDefault; const aWhen: TDateTime = 0; const aWhenBias: Integer = BIAS_UNSPECIFIED); virtual; overload;
Description

Log a number of strings.

Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent.lcSetEventLog Method

TnxLoggableComponent.lcSetEventLog Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
procedure lcSetEventLog(anEventLog: TnxBaseLog); virtual;
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent.lcSetLogEnabled Method

TnxLoggableComponent.lcSetLogEnabled Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
procedure lcSetLogEnabled(const aEnabled: Boolean); virtual;
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent.nxcCreateComponentInfo Method

TnxLoggableComponent.nxcCreateComponentInfo Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
function nxcCreateComponentInfo: InxInterface; override;
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent.nxcExceptionClass Method

TnxLoggableComponent.nxcExceptionClass Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent.nxcNotification Method

TnxLoggableComponent.nxcNotification Method
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxLoggableComponent Methods

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Methods


TnxLoggableComponent Properties

TnxLoggableComponent Properties
TnxLoggableComponent Class Legend Published Properties Send Feedback

The properties of the TnxLoggableComponent class are listed here.

Class

TnxLoggableComponent Class

Published Properties
Name | Description
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
Links
TnxLoggableComponent Class, Legend, Published Properties


TnxLoggableComponent.EventLog Property

TnxLoggableComponent.EventLog Property
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Properties Send Feedback
Syntax
Delphi
property EventLog: TnxBaseLog;
Description

The Event log associated with this component. If none set the lcLog calls will do nothing.

Group

TnxLoggableComponent Properties

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Properties


TnxLoggableComponent.EventLogEnabled Property

TnxLoggableComponent.EventLogEnabled Property
TnxLoggableComponent Class TnxLoggableComponent Members nxllComponent Namespace TnxLoggableComponent Properties Send Feedback
Syntax
Delphi
property EventLogEnabled: Boolean;
Description

True if logging is enabled for this component.

Group

TnxLoggableComponent Properties

Links
TnxLoggableComponent Class, TnxLoggableComponent Members, nxllComponent Namespace, TnxLoggableComponent Properties


TnxLoggableComponentInfo Class

TnxLoggableComponentInfo Class
TnxLoggableComponentInfo Methods TnxLoggableComponentInfo Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfonxllComponent_TnxLoggableComponentInfo
Syntax
Delphi
TnxLoggableComponentInfo = class(TnxComponentInfo, InxLoggableComponentInfo31000);
File

nxllComponent

Description

This is class nxllComponent.TnxLoggableComponentInfo.

Group

Classes

Links
TnxLoggableComponentInfo Methods, TnxLoggableComponentInfo Members, nxllComponent, Classes


TnxLoggableComponentInfo Members

TnxLoggableComponentInfo Members
TnxLoggableComponentInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLoggableComponentInfo.

Class

TnxLoggableComponentInfo Class

Protected Fields
Name | Description
ciComponent | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Create | TnxLoggableComponentInfo
Disconnect | InxComponentInfoDisconnect
GetClassName | InxComponentInfo31000
GetDisplayCategory |
GetDisplayName |
GetEventLogInfo |
GetLogEnabled | InxLoggableComponentInfo31000
GetName |
GetStatsCaptions |
GetStatsValues |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Disconnect | This is Disconnect, a member of class InxComponentInfoDisconnect.
Free |
FreeInstance |
GetClassName | This is GetClassName, a member of class InxComponentInfo31000.
GetDisplayCategory | This is GetDisplayCategory, a member of class InxComponentInfo31000.
GetDisplayName | This is GetDisplayName, a member of class InxComponentInfo31000.
GetName | This is GetName, a member of class InxComponentInfo31000.
GetStatsCaptions | This is GetStatsCaptions, a member of class InxComponentInfo31000.
GetStatsValues | This is GetStatsValues, a member of class InxComponentInfo31000.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
EventLogInfo | This is EventLogInfo, a member of class InxLoggableComponentInfo31000.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
LogEnabled | This is LogEnabled, a member of class InxLoggableComponentInfo31000.
Name | This is Name, a member of class InxComponentInfo31000.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxLoggableComponentInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLoggableComponentInfo.Create Constructor

TnxLoggableComponentInfo.Create Constructor
TnxLoggableComponentInfo Class TnxLoggableComponentInfo Members nxllComponent Namespace TnxLoggableComponentInfo Class Send Feedback
Syntax
Delphi
constructor Create(aLoggableComponent: TnxLoggableComponent);
Description

TnxLoggableComponentInfo

Class

TnxLoggableComponentInfo Class

Links
TnxLoggableComponentInfo Class, TnxLoggableComponentInfo Members, nxllComponent Namespace, TnxLoggableComponentInfo Class


TnxLoggableComponentInfo Methods

TnxLoggableComponentInfo Methods
TnxLoggableComponentInfo Class Legend Protected Methods Send Feedback

The methods of the TnxLoggableComponentInfo class are listed here.

Class

TnxLoggableComponentInfo Class

Protected Methods
Name | Description
GetEventLogInfo |
GetLogEnabled | InxLoggableComponentInfo31000
Links
TnxLoggableComponentInfo Class, Legend, Protected Methods


TnxLoggableComponentInfo.GetEventLogInfo Method

TnxLoggableComponentInfo.GetEventLogInfo Method
TnxLoggableComponentInfo Class TnxLoggableComponentInfo Members nxllComponent Namespace TnxLoggableComponentInfo Methods Send Feedback
Syntax
Delphi
function GetEventLogInfo: InxComponentInfo31000;
Group

TnxLoggableComponentInfo Methods

Links
TnxLoggableComponentInfo Class, TnxLoggableComponentInfo Members, nxllComponent Namespace, TnxLoggableComponentInfo Methods


TnxLoggableComponentInfo.GetLogEnabled Method

TnxLoggableComponentInfo.GetLogEnabled Method
TnxLoggableComponentInfo Class TnxLoggableComponentInfo Members nxllComponent Namespace TnxLoggableComponentInfo Methods Send Feedback
Syntax
Delphi
function GetLogEnabled: Boolean;
Description

InxLoggableComponentInfo31000

Group

TnxLoggableComponentInfo Methods

Links
TnxLoggableComponentInfo Class, TnxLoggableComponentInfo Members, nxllComponent Namespace, TnxLoggableComponentInfo Methods


TnxPersistent Class

TnxPersistent Class
TnxPersistent Methods TnxPersistent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxPersistentnxllComponent_TnxPersistent
Syntax
Delphi
TnxPersistent = class(TPersistent, InxInterface, InxExceptionData);
File

nxllComponent

Description

Base class for all persistent NexusDB objects.

Group

Classes

Links
TnxPersistent Methods, TnxPersistent Members, nxllComponent, Classes


TnxPersistent Members

TnxPersistent Members
TnxPersistent Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPersistent.

Class

TnxPersistent Class

Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
QueryInterface | InxInterface
Public Methods
Name | Description
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxPersistent Class, Legend, Protected Methods, Public Methods


TnxPersistent Methods

TnxPersistent Methods
TnxPersistent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxPersistent class are listed here.

Class

TnxPersistent Class

Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
QueryInterface | InxInterface
Public Methods
Name | Description
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxPersistent Class, Legend, Protected Methods, Public Methods


TnxPersistent._AddRef Method

TnxPersistent._AddRef Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxPersistent._Release Method

TnxPersistent._Release Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxPersistent.FreeInstance Method

TnxPersistent.FreeInstance Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Description

Overidden to take advatange of the NexusDB Memory Manager.

Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxPersistent.GetExceptionData Method

TnxPersistent.GetExceptionData Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); virtual;
Description

InxExceptionData

TnxPersistent

Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxPersistent.NewInstance Method

TnxPersistent.NewInstance Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Description

Overidden to take advatange of the NexusDB Memory Manager.

Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxPersistent.QueryInterface Method

TnxPersistent.QueryInterface Method
TnxPersistent Class TnxPersistent Members nxllComponent Namespace TnxPersistent Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxPersistent Methods

Links
TnxPersistent Class, TnxPersistent Members, nxllComponent Namespace, TnxPersistent Methods


TnxRegisterableComponent Class

TnxRegisterableComponent Class
TnxRegisterableComponent Methods TnxRegisterableComponent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxRegisterableComponentnxllComponent_TnxRegisterableComponentnxllComponent_TnxRegisterableComponentnxllComponent_TnxRegisterableComponent
Syntax
Delphi
TnxRegisterableComponent = class(TnxComponent);
File

nxllComponent

Description

An component that can be registered to the system and thus created from class name.

Group

Classes

Links
TnxRegisterableComponent Methods, TnxRegisterableComponent Members, nxllComponent, Classes


TnxRegisterableComponent Members

TnxRegisterableComponent Members
TnxRegisterableComponent Class Legend Protected Fields Protected Methods Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxRegisterableComponent.

Class

TnxRegisterableComponent Class

Protected Fields
Name | Description
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxRegisterableComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Properties


TnxRegisterableComponent Methods

TnxRegisterableComponent Methods
TnxRegisterableComponent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRegisterableComponent class are listed here.

Class

TnxRegisterableComponent Class

Protected Methods
Name | Description
nxcExceptionClass |
rcRegister |
rcUnregister |
Public Methods
Name | Description
FindRegisteredClass | Returns it's class definition if the classname matches.
GetRegisteredClasses | Adds itself to the list of registered classes.
Links
TnxRegisterableComponent Class, Legend, Protected Methods, Public Methods


TnxRegisterableComponent.FindRegisteredClass Method

TnxRegisterableComponent.FindRegisteredClass Method
TnxRegisterableComponent Class TnxRegisterableComponent Members nxllComponent Namespace TnxRegisterableComponent Methods Send Feedback
Syntax
Delphi
class function FindRegisteredClass(const aClassName: string): TnxRegisterableComponentClass;
Description

Returns it's class definition if the classname matches.

Group

TnxRegisterableComponent Methods

Links
TnxRegisterableComponent Class, TnxRegisterableComponent Members, nxllComponent Namespace, TnxRegisterableComponent Methods


TnxRegisterableComponent.GetRegisteredClasses Method

TnxRegisterableComponent.GetRegisteredClasses Method
TnxRegisterableComponent Class TnxRegisterableComponent Members nxllComponent Namespace TnxRegisterableComponent Methods Send Feedback
Syntax
Delphi
class procedure GetRegisteredClasses(aList: TStrings);
Description

Adds itself to the list of registered classes.

Group

TnxRegisterableComponent Methods

Links
TnxRegisterableComponent Class, TnxRegisterableComponent Members, nxllComponent Namespace, TnxRegisterableComponent Methods


TnxRegisterableComponent.nxcExceptionClass Method

TnxRegisterableComponent.nxcExceptionClass Method
TnxRegisterableComponent Class TnxRegisterableComponent Members nxllComponent Namespace TnxRegisterableComponent Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxRegisterableComponent Methods

Links
TnxRegisterableComponent Class, TnxRegisterableComponent Members, nxllComponent Namespace, TnxRegisterableComponent Methods


TnxRegisterableComponent.rcRegister Method

TnxRegisterableComponent.rcRegister Method
TnxRegisterableComponent Class TnxRegisterableComponent Members nxllComponent Namespace TnxRegisterableComponent Methods Send Feedback
Syntax
Delphi
class procedure rcRegister; virtual;
Group

TnxRegisterableComponent Methods

Links
TnxRegisterableComponent Class, TnxRegisterableComponent Members, nxllComponent Namespace, TnxRegisterableComponent Methods


TnxRegisterableComponent.rcUnregister Method

TnxRegisterableComponent.rcUnregister Method
TnxRegisterableComponent Class TnxRegisterableComponent Members nxllComponent Namespace TnxRegisterableComponent Methods Send Feedback
Syntax
Delphi
class procedure rcUnregister; virtual;
Group

TnxRegisterableComponent Methods

Links
TnxRegisterableComponent Class, TnxRegisterableComponent Members, nxllComponent Namespace, TnxRegisterableComponent Methods


TnxStateComponent Class

TnxStateComponent Class
TnxStateComponent Fields TnxStateComponent Methods TnxStateComponent Properties TnxStateComponent Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxStateComponentnxllComponent_TnxStateComponentnxllComponent_TnxStateComponentnxllComponent_TnxStateComponentnxllComponent_TnxStateComponentnxllComponent_TnxStateComponent
Syntax
Delphi
TnxStateComponent = class(TnxLoggableComponent);
File

nxllComponent

Description

A state component has an integrated simple state engine for Initialiazing, Starting, Stopping and Deactivating the component.

Group

Classes

Links
TnxStateComponent Fields, TnxStateComponent Methods, TnxStateComponent Properties, TnxStateComponent Members, nxllComponent, Classes


TnxStateComponent Members

TnxStateComponent Members
TnxStateComponent Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxStateComponent.

Class

TnxStateComponent Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxStateComponent Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxStateComponent.Create Constructor

TnxStateComponent.Create Constructor
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor

Class

TnxStateComponent Class

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Class


TnxStateComponent.Destroy Destructor

TnxStateComponent.Destroy Destructor
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor

Class

TnxStateComponent Class

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Class


TnxStateComponent Fields

TnxStateComponent Fields
TnxStateComponent Class Legend Protected Fields Send Feedback

The fields of the TnxStateComponent class are listed here.

Class

TnxStateComponent Class

Protected Fields
Name | Description
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Links
TnxStateComponent Class, Legend, Protected Fields


TnxStateComponent.scActiveDesigntime Field

TnxStateComponent.scActiveDesigntime Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scActiveDesigntime: Boolean;
Description

This is scActiveDesigntime, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scActiveRuntime Field

TnxStateComponent.scActiveRuntime Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scActiveRuntime: Boolean;
Description

This is scActiveRuntime, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scEnabled Field

TnxStateComponent.scEnabled Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scEnabled: Boolean;
Description

This is scEnabled, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scLastStartError Field

TnxStateComponent.scLastStartError Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scLastStartError: string;
Description

This is scLastStartError, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scOnStateChanged Field

TnxStateComponent.scOnStateChanged Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scOnStateChanged: TNotifyEvent;
Description

This is scOnStateChanged, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scOnStateTransChanged Field

TnxStateComponent.scOnStateTransChanged Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scOnStateTransChanged: TNotifyEvent;
Description

This is scOnStateTransChanged, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scSavedActive Field

TnxStateComponent.scSavedActive Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scSavedActive: byte;
Description

(-1 false, 1 true, 0 not used);

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scStartTime Field

TnxStateComponent.scStartTime Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scStartTime: TDateTime;
Description

private

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scState Field

TnxStateComponent.scState Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scState: TnxState;
Description

This is scState, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent.scStateTransition Field

TnxStateComponent.scStateTransition Field
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Fields Send Feedback
Syntax
Delphi
scStateTransition: TnxStateTransition;
Description

This is scStateTransition, a member of class TnxStateComponent.

Group

TnxStateComponent Fields

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Fields


TnxStateComponent Methods

TnxStateComponent Methods
TnxStateComponent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStateComponent class are listed here.

Class

TnxStateComponent Class

Protected Methods
Name | Description
GetExceptionData | InxExceptionData
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcCreateComponentInfo |
nxcExceptionClass |
nxcNotification |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
GetConfigSettings |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues |
LoadConfig |
LoadSettingsFromStream |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
Links
TnxStateComponent Class, Legend, Protected Methods, Public Methods


TnxStateComponent.BeforeDestruction Method

TnxStateComponent.BeforeDestruction Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TComponent.BeforeDestruction

TnxStateComponent

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.Close Method

TnxStateComponent.Close Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure Close;
Description

Calling the close method is equivalent to setting Active to false.

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.Connect Method

TnxStateComponent.Connect Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure Connect;
Description

Calling the connect method is equivalent to setting Active to true.

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.GetConfigSettings Method

TnxStateComponent.GetConfigSettings Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.GetExceptionData Method

TnxStateComponent.GetExceptionData Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.GetStatsCaptions Method

TnxStateComponent.GetStatsCaptions Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); override;
Description

Returns the captions for the returned statistic values.

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.GetStatsValues Method

TnxStateComponent.GetStatsValues Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.LoadConfig Method

TnxStateComponent.LoadConfig Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.Loaded Method

TnxStateComponent.Loaded Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Description

This is Loaded, a member of class TnxStateComponent.

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.LoadSettingsFromStream Method

TnxStateComponent.LoadSettingsFromStream Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.nxcCreateComponentInfo Method

TnxStateComponent.nxcCreateComponentInfo Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function nxcCreateComponentInfo: InxInterface; override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.nxcExceptionClass Method

TnxStateComponent.nxcExceptionClass Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.nxcNotification Method

TnxStateComponent.nxcNotification Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.Open Method

TnxStateComponent.Open Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure Open;
Description

Calling the open method is equivalent to setting Active to true.

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.SaveConfig Method

TnxStateComponent.SaveConfig Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.SaveSettingsToStream Method

TnxStateComponent.SaveSettingsToStream Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); override;
Description

Persists settings. (legacy V1)

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scCheckInactive Method

TnxStateComponent.scCheckInactive Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scCheckInactive; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scCheckInactiveOrStopped Method

TnxStateComponent.scCheckInactiveOrStopped Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scCheckInactiveOrStopped; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scCheckStarted Method

TnxStateComponent.scCheckStarted Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scCheckStarted; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scDeactivating Method

TnxStateComponent.scDeactivating Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scDeactivating; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scDependentStateChange Method

TnxStateComponent.scDependentStateChange Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scDependentStateChange(aSender: TnxStateComponent; aBefore: Boolean; aOldState: TnxState; aNewState: TnxState); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scGetActive Method

TnxStateComponent.scGetActive Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scGetActive: Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scInitializing Method

TnxStateComponent.scInitializing Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scInitializing; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scIsStateParent Method

TnxStateComponent.scIsStateParent Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scSetActive Method

TnxStateComponent.scSetActive Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scSetActive(const aActive: Boolean); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scSetActiveDesigntime Method

TnxStateComponent.scSetActiveDesigntime Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scSetActiveDesigntime(const Value: Boolean); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scSetActiveRuntime Method

TnxStateComponent.scSetActiveRuntime Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scSetActiveRuntime(const Value: Boolean); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scSetEnabled Method

TnxStateComponent.scSetEnabled Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scSetEnabled(const aEnabled: Boolean); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scSetState Method

TnxStateComponent.scSetState Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scSetState(aState: TnxState); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scShouldFollowTransition Method

TnxStateComponent.scShouldFollowTransition Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scShouldFollowTransition(aSender: TnxStateComponent; aBefore: Boolean; aStateTransition: TnxStateTransition; aNewState: TnxState): Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scShowLastStartErrorInStats Method

TnxStateComponent.scShowLastStartErrorInStats Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scShowLastStartErrorInStats: Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scShowUpTime Method

TnxStateComponent.scShowUpTime Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scShowUpTime: Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStarted Method

TnxStateComponent.scStarted Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStarted; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStarting Method

TnxStateComponent.scStarting Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStarting; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStateChanged Method

TnxStateComponent.scStateChanged Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStateChanged(aOldState: TnxState; aNewState: TnxState); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStateChanging Method

TnxStateComponent.scStateChanging Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function scStateChanging(aOldState: TnxState; aNewState: TnxState): Boolean; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStateTransitionChanged Method

TnxStateComponent.scStateTransitionChanged Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStateTransitionChanged(aNewStateTrans: TnxStateTransition); virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStopped Method

TnxStateComponent.scStopped Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStopped; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.scStopping Method

TnxStateComponent.scStopping Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure scStopping; virtual;
Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.SwitchToSavedActive Method

TnxStateComponent.SwitchToSavedActive Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
procedure SwitchToSavedActive; virtual;
Description

A special command that can set the Active state to a before saved one. Also see: SavedActive

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent.UIStateVisible Method

TnxStateComponent.UIStateVisible Method
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Methods Send Feedback
Syntax
Delphi
function UIStateVisible: Boolean; virtual;
Description

Set this to true if the state of this component should be visible in UI (legacy V1)

Group

TnxStateComponent Methods

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Methods


TnxStateComponent Properties

TnxStateComponent Properties
TnxStateComponent Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxStateComponent class are listed here.

Class

TnxStateComponent Class

Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
Enabled | Enable/Disable this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Links
TnxStateComponent Class, Legend, Public Properties, Published Properties


TnxStateComponent.Active Property

TnxStateComponent.Active Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property Active: Boolean;
Description

(De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.ActiveDesigntime Property

TnxStateComponent.ActiveDesigntime Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property ActiveDesigntime: Boolean;
Description

Set this to true if you want the component to start automatically in design mode.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.ActiveRuntime Property

TnxStateComponent.ActiveRuntime Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property ActiveRuntime: Boolean;
Description

Set this to true if you want the component to start automatically on application startup.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.Connected Property

TnxStateComponent.Connected Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property Connected: Boolean;
Description

(De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.Enabled Property

TnxStateComponent.Enabled Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

Enable/Disable this component.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.LastStartError Property

TnxStateComponent.LastStartError Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property LastStartError: string;
Description

Error message (if any) the last time the component tried to set it's state to nxsStarted

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.OnStateChanged Property

TnxStateComponent.OnStateChanged Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property OnStateChanged: TNotifyEvent;
Description

This event is triggered every time the state of the component changed.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.OnStateTransChanged Property

TnxStateComponent.OnStateTransChanged Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property OnStateTransChanged: TNotifyEvent;
Description

This event is triggered every time the state transition of the component changed.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.SavedActive Property

TnxStateComponent.SavedActive Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property SavedActive: byte;
Description

Can be used to save a certain state.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.StartTime Property

TnxStateComponent.StartTime Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property StartTime: TDateTime;
Description

Time the componenet was last set to active.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.State Property

TnxStateComponent.State Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property State: TnxState;
Description

Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponent.StateTransition Property

TnxStateComponent.StateTransition Property
TnxStateComponent Class TnxStateComponent Members nxllComponent Namespace TnxStateComponent Properties Send Feedback
Syntax
Delphi
property StateTransition: TnxStateTransition;
Description

Returns the current StateTransition the component is in. If it is in a proper state this will return none.

Group

TnxStateComponent Properties

Links
TnxStateComponent Class, TnxStateComponent Members, nxllComponent Namespace, TnxStateComponent Properties


TnxStateComponentInfo Class

TnxStateComponentInfo Class
TnxStateComponentInfo Methods TnxStateComponentInfo Members nxllComponent Classes Send Feedback
Class Hierarchy
nxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfonxllComponent_TnxStateComponentInfo
Syntax
Delphi
TnxStateComponentInfo = class(TnxLoggableComponentInfo, InxStateComponentInfo31000);
File

nxllComponent

Description

This is class nxllComponent.TnxStateComponentInfo.

Group

Classes

Links
TnxStateComponentInfo Methods, TnxStateComponentInfo Members, nxllComponent, Classes


TnxStateComponentInfo Members

TnxStateComponentInfo Members
TnxStateComponentInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxStateComponentInfo.

Class

TnxStateComponentInfo Class

Protected Fields
Name | Description
ciComponent | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Create | TnxStateComponentInfo
Disconnect | InxComponentInfoDisconnect
GetClassName | InxComponentInfo31000
GetDisplayCategory |
GetDisplayName |
GetEventLogInfo |
GetLogEnabled | InxLoggableComponentInfo31000
GetName |
GetState | InxStateComponentInfo31000
GetStatsCaptions |
GetStatsValues |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Disconnect | This is Disconnect, a member of class InxComponentInfoDisconnect.
Free |
FreeInstance |
GetClassName | This is GetClassName, a member of class InxComponentInfo31000.
GetDisplayCategory | This is GetDisplayCategory, a member of class InxComponentInfo31000.
GetDisplayName | This is GetDisplayName, a member of class InxComponentInfo31000.
GetEventLogInfo | This is GetEventLogInfo, a member of class InxLoggableComponentInfo31000.
GetLogEnabled | This is GetLogEnabled, a member of class InxLoggableComponentInfo31000.
GetName | This is GetName, a member of class InxComponentInfo31000.
GetStatsCaptions | This is GetStatsCaptions, a member of class InxComponentInfo31000.
GetStatsValues | This is GetStatsValues, a member of class InxComponentInfo31000.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
EventLogInfo | This is EventLogInfo, a member of class InxLoggableComponentInfo31000.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
LogEnabled | This is LogEnabled, a member of class InxLoggableComponentInfo31000.
Name | This is Name, a member of class InxComponentInfo31000.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
State | This is State, a member of class InxStateComponentInfo31000.
Links
TnxStateComponentInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxStateComponentInfo.Create Constructor

TnxStateComponentInfo.Create Constructor
TnxStateComponentInfo Class TnxStateComponentInfo Members nxllComponent Namespace TnxStateComponentInfo Class Send Feedback
Syntax
Delphi
constructor Create(aStateComponent: TnxStateComponent);
Description

TnxStateComponentInfo

Class

TnxStateComponentInfo Class

Links
TnxStateComponentInfo Class, TnxStateComponentInfo Members, nxllComponent Namespace, TnxStateComponentInfo Class


TnxStateComponentInfo Methods

TnxStateComponentInfo Methods
TnxStateComponentInfo Class Legend Protected Methods Send Feedback

The methods of the TnxStateComponentInfo class are listed here.

Class

TnxStateComponentInfo Class

Protected Methods
Name | Description
GetState | InxStateComponentInfo31000
Links
TnxStateComponentInfo Class, Legend, Protected Methods


TnxStateComponentInfo.GetState Method

TnxStateComponentInfo.GetState Method
TnxStateComponentInfo Class TnxStateComponentInfo Members nxllComponent Namespace TnxStateComponentInfo Methods Send Feedback
Syntax
Delphi
function GetState: TnxState;
Description

InxStateComponentInfo31000

Group

TnxStateComponentInfo Methods

Links
TnxStateComponentInfo Class, TnxStateComponentInfo Members, nxllComponent Namespace, TnxStateComponentInfo Methods


Interfaces

Interfaces
nxllComponent Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllComponent Namespace

Interfaces
Name | Description
InxComponentInfo31000 | This is class nxllComponent.InxComponentInfo31000.
InxComponentInfoDisconnect | This is class nxllComponent.InxComponentInfoDisconnect.
InxLogData | Interface implemented by all components that provide Logging data
InxLoggableComponentInfo31000 | This is class nxllComponent.InxLoggableComponentInfo31000.
InxStateComponentInfo31000 | This is class nxllComponent.InxStateComponentInfo31000.
Links
nxllComponent Namespace, Interfaces, Legend


InxComponentInfo31000 Interface

InxComponentInfo31000 Interface
InxComponentInfo31000 Methods InxComponentInfo31000 Properties InxComponentInfo31000 Members nxllComponent Interfaces Send Feedback
Class Hierarchy
nxllComponent_InxComponentInfo31000
Syntax
Delphi
InxComponentInfo31000 = interface(InxInvokable);
File

nxllComponent

Description

This is class nxllComponent.InxComponentInfo31000.

Group

Interfaces

Links
InxComponentInfo31000 Methods, InxComponentInfo31000 Properties, InxComponentInfo31000 Members, nxllComponent, Interfaces


InxComponentInfo31000 Members

InxComponentInfo31000 Members
InxComponentInfo31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxComponentInfo31000.

Interface

InxComponentInfo31000 Interface

Public Methods
Name | Description
GetClassName | This is GetClassName, a member of class InxComponentInfo31000.
GetDisplayCategory | This is GetDisplayCategory, a member of class InxComponentInfo31000.
GetDisplayName | This is GetDisplayName, a member of class InxComponentInfo31000.
GetName | This is GetName, a member of class InxComponentInfo31000.
GetStatsCaptions | This is GetStatsCaptions, a member of class InxComponentInfo31000.
GetStatsValues | This is GetStatsValues, a member of class InxComponentInfo31000.
Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
Name | This is Name, a member of class InxComponentInfo31000.
Links
InxComponentInfo31000 Interface, Legend, Public Methods, Public Properties


InxComponentInfo31000 Methods

InxComponentInfo31000 Methods
InxComponentInfo31000 Interface Legend Public Methods Send Feedback

The methods of the InxComponentInfo31000 class are listed here.

Interface

InxComponentInfo31000 Interface

Public Methods
Name | Description
GetClassName | This is GetClassName, a member of class InxComponentInfo31000.
GetDisplayCategory | This is GetDisplayCategory, a member of class InxComponentInfo31000.
GetDisplayName | This is GetDisplayName, a member of class InxComponentInfo31000.
GetName | This is GetName, a member of class InxComponentInfo31000.
GetStatsCaptions | This is GetStatsCaptions, a member of class InxComponentInfo31000.
GetStatsValues | This is GetStatsValues, a member of class InxComponentInfo31000.
Links
InxComponentInfo31000 Interface, Legend, Public Methods


InxComponentInfo31000.GetClassName Method

InxComponentInfo31000.GetClassName Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetClassName: string;
Description

This is GetClassName, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000.GetDisplayCategory Method

InxComponentInfo31000.GetDisplayCategory Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetDisplayCategory: string;
Description

This is GetDisplayCategory, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000.GetDisplayName Method

InxComponentInfo31000.GetDisplayName Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetDisplayName: string;
Description

This is GetDisplayName, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000.GetName Method

InxComponentInfo31000.GetName Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetName: string;
Description

This is GetName, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000.GetStatsCaptions Method

InxComponentInfo31000.GetStatsCaptions Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetStatsCaptions: TnxDynStringArray;
Description

This is GetStatsCaptions, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000.GetStatsValues Method

InxComponentInfo31000.GetStatsValues Method
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetStatsValues: TnxDynStringArray;
Description

This is GetStatsValues, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Methods

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Methods


InxComponentInfo31000 Properties

InxComponentInfo31000 Properties
InxComponentInfo31000 Interface Legend Public Properties Send Feedback

The properties of the InxComponentInfo31000 class are listed here.

Interface

InxComponentInfo31000 Interface

Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
Name | This is Name, a member of class InxComponentInfo31000.
Links
InxComponentInfo31000 Interface, Legend, Public Properties


InxComponentInfo31000.ClassName Property

InxComponentInfo31000.ClassName Property
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property ClassName: string;
Description

This is ClassName, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Properties

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Properties


InxComponentInfo31000.DisplayCategory Property

InxComponentInfo31000.DisplayCategory Property
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property DisplayCategory: string;
Description

This is DisplayCategory, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Properties

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Properties


InxComponentInfo31000.DisplayName Property

InxComponentInfo31000.DisplayName Property
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property DisplayName: string;
Description

This is DisplayName, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Properties

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Properties


InxComponentInfo31000.Name Property

InxComponentInfo31000.Name Property
InxComponentInfo31000 Interface InxComponentInfo31000 Members nxllComponent Namespace InxComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is Name, a member of class InxComponentInfo31000.

Group

InxComponentInfo31000 Properties

Links
InxComponentInfo31000 Interface, InxComponentInfo31000 Members, nxllComponent Namespace, InxComponentInfo31000 Properties


InxComponentInfoDisconnect Interface

InxComponentInfoDisconnect Interface
InxComponentInfoDisconnect Methods InxComponentInfoDisconnect Members nxllComponent Interfaces Send Feedback
Class Hierarchy
nxllComponent_InxComponentInfoDisconnect
Syntax
Delphi
InxComponentInfoDisconnect = interface(InxInterface);
File

nxllComponent

Description

This is class nxllComponent.InxComponentInfoDisconnect.

Group

Interfaces

Links
InxComponentInfoDisconnect Methods, InxComponentInfoDisconnect Members, nxllComponent, Interfaces


InxComponentInfoDisconnect Members

InxComponentInfoDisconnect Members
InxComponentInfoDisconnect Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxComponentInfoDisconnect.

Interface

InxComponentInfoDisconnect Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxComponentInfoDisconnect.
Links
InxComponentInfoDisconnect Interface, Legend, Public Methods


InxComponentInfoDisconnect Methods

InxComponentInfoDisconnect Methods
InxComponentInfoDisconnect Interface Legend Public Methods Send Feedback

The methods of the InxComponentInfoDisconnect class are listed here.

Interface

InxComponentInfoDisconnect Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxComponentInfoDisconnect.
Links
InxComponentInfoDisconnect Interface, Legend, Public Methods


InxComponentInfoDisconnect.Disconnect Method

InxComponentInfoDisconnect.Disconnect Method
InxComponentInfoDisconnect Interface InxComponentInfoDisconnect Members nxllComponent Namespace InxComponentInfoDisconnect Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

This is Disconnect, a member of class InxComponentInfoDisconnect.

Group

InxComponentInfoDisconnect Methods

Links
InxComponentInfoDisconnect Interface, InxComponentInfoDisconnect Members, nxllComponent Namespace, InxComponentInfoDisconnect Methods


InxLogData Interface

InxLogData Interface
InxLogData Methods InxLogData Properties InxLogData Members nxllComponent Interfaces Send Feedback
Class Hierarchy
nxllComponent_InxLogData
Syntax
Delphi
InxLogData = interface(InxInterface);
File

nxllComponent

Description

Interface implemented by all components that provide Logging data

Group

Interfaces

Links
InxLogData Methods, InxLogData Properties, InxLogData Members, nxllComponent, Interfaces


InxLogData Members

InxLogData Members
InxLogData Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxLogData.

Interface

InxLogData Interface

Public Methods
Name | Description
GetCategory | A Category name (for display purposes)
GetMsg | Message to log, e.g. ErrorMessage
GetMsgNumber | Number of the message to log, e.g. ErrorCode
GetPriority | The Priority of the message
GetThreadID | Thread ID
GetUTCWhen | UTC date/time of the message to log
GetWhen | date/time for the message to log
GetWhenBias | Timezone offset of the When Date/Time
Public Properties
Name | Description
Category | A Category name (for display purposes)
Msg | Message to log, e.g. ErrorMessage
MsgNumber | Number of the message to log, e.g. ErrorCode
Priority | The Priority of the message
ThreadID | Thread ID
UTCWhen | UTC date/time of the message to log
When | date/time for the message to log
WhenBias | Timezone offset of the When Date/Time
Links
InxLogData Interface, Legend, Public Methods, Public Properties


InxLogData Methods

InxLogData Methods
InxLogData Interface Legend Public Methods Send Feedback

The methods of the InxLogData class are listed here.

Interface

InxLogData Interface

Public Methods
Name | Description
GetCategory | A Category name (for display purposes)
GetMsg | Message to log, e.g. ErrorMessage
GetMsgNumber | Number of the message to log, e.g. ErrorCode
GetPriority | The Priority of the message
GetThreadID | Thread ID
GetUTCWhen | UTC date/time of the message to log
GetWhen | date/time for the message to log
GetWhenBias | Timezone offset of the When Date/Time
Links
InxLogData Interface, Legend, Public Methods


InxLogData.GetCategory Method

InxLogData.GetCategory Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetCategory: string;
Description

A Category name (for display purposes)

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetMsg Method

InxLogData.GetMsg Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetMsg: string;
Description

Message to log, e.g. ErrorMessage

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetMsgNumber Method

InxLogData.GetMsgNumber Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetMsgNumber: Cardinal;
Description

Number of the message to log, e.g. ErrorCode

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetPriority Method

InxLogData.GetPriority Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetPriority: TnxLogPriority;
Description

The Priority of the message

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetThreadID Method

InxLogData.GetThreadID Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetThreadID: Cardinal;
Description

Thread ID

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetUTCWhen Method

InxLogData.GetUTCWhen Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetUTCWhen: TDateTime;
Description

UTC date/time of the message to log

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetWhen Method

InxLogData.GetWhen Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetWhen: TDateTime;
Description

date/time for the message to log

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData.GetWhenBias Method

InxLogData.GetWhenBias Method
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Methods Send Feedback
Syntax
Delphi
function GetWhenBias: Integer;
Description

Timezone offset of the When Date/Time

Group

InxLogData Methods

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Methods


InxLogData Properties

InxLogData Properties
InxLogData Interface Legend Public Properties Send Feedback

The properties of the InxLogData class are listed here.

Interface

InxLogData Interface

Public Properties
Name | Description
Category | A Category name (for display purposes)
Msg | Message to log, e.g. ErrorMessage
MsgNumber | Number of the message to log, e.g. ErrorCode
Priority | The Priority of the message
ThreadID | Thread ID
UTCWhen | UTC date/time of the message to log
When | date/time for the message to log
WhenBias | Timezone offset of the When Date/Time
Links
InxLogData Interface, Legend, Public Properties


InxLogData.Category Property

InxLogData.Category Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property Category: string;
Description

A Category name (for display purposes)

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.Msg Property

InxLogData.Msg Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property Msg: string;
Description

Message to log, e.g. ErrorMessage

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.MsgNumber Property

InxLogData.MsgNumber Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property MsgNumber: Cardinal;
Description

Number of the message to log, e.g. ErrorCode

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.Priority Property

InxLogData.Priority Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property Priority: TnxLogPriority;
Description

The Priority of the message

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.ThreadID Property

InxLogData.ThreadID Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property ThreadID: Cardinal;
Description

Thread ID

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.UTCWhen Property

InxLogData.UTCWhen Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property UTCWhen: TDateTime;
Description

UTC date/time of the message to log

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.When Property

InxLogData.When Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property When: TDateTime;
Description

date/time for the message to log

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLogData.WhenBias Property

InxLogData.WhenBias Property
InxLogData Interface InxLogData Members nxllComponent Namespace InxLogData Properties Send Feedback
Syntax
Delphi
property WhenBias: Integer;
Description

Timezone offset of the When Date/Time

Group

InxLogData Properties

Links
InxLogData Interface, InxLogData Members, nxllComponent Namespace, InxLogData Properties


InxLoggableComponentInfo31000 Interface

InxLoggableComponentInfo31000 Interface
InxLoggableComponentInfo31000 Methods InxLoggableComponentInfo31000 Properties InxLoggableComponentInfo31000 Members nxllComponent Interfaces Send Feedback
Class Hierarchy
nxllComponent_InxLoggableComponentInfo31000
Syntax
Delphi
InxLoggableComponentInfo31000 = interface(InxInvokable);
File

nxllComponent

Description

This is class nxllComponent.InxLoggableComponentInfo31000.

Group

Interfaces

Links
InxLoggableComponentInfo31000 Methods, InxLoggableComponentInfo31000 Properties, InxLoggableComponentInfo31000 Members, nxllComponent, Interfaces


InxLoggableComponentInfo31000 Members

InxLoggableComponentInfo31000 Members
InxLoggableComponentInfo31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxLoggableComponentInfo31000.

Interface

InxLoggableComponentInfo31000 Interface

Public Methods
Name | Description
GetEventLogInfo | This is GetEventLogInfo, a member of class InxLoggableComponentInfo31000.
GetLogEnabled | This is GetLogEnabled, a member of class InxLoggableComponentInfo31000.
Public Properties
Name | Description
EventLogInfo | This is EventLogInfo, a member of class InxLoggableComponentInfo31000.
LogEnabled | This is LogEnabled, a member of class InxLoggableComponentInfo31000.
Links
InxLoggableComponentInfo31000 Interface, Legend, Public Methods, Public Properties


InxLoggableComponentInfo31000 Methods

InxLoggableComponentInfo31000 Methods
InxLoggableComponentInfo31000 Interface Legend Public Methods Send Feedback

The methods of the InxLoggableComponentInfo31000 class are listed here.

Interface

InxLoggableComponentInfo31000 Interface

Public Methods
Name | Description
GetEventLogInfo | This is GetEventLogInfo, a member of class InxLoggableComponentInfo31000.
GetLogEnabled | This is GetLogEnabled, a member of class InxLoggableComponentInfo31000.
Links
InxLoggableComponentInfo31000 Interface, Legend, Public Methods


InxLoggableComponentInfo31000.GetEventLogInfo Method

InxLoggableComponentInfo31000.GetEventLogInfo Method
InxLoggableComponentInfo31000 Interface InxLoggableComponentInfo31000 Members nxllComponent Namespace InxLoggableComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetEventLogInfo: InxComponentInfo31000;
Description

This is GetEventLogInfo, a member of class InxLoggableComponentInfo31000.

Group

InxLoggableComponentInfo31000 Methods

Links
InxLoggableComponentInfo31000 Interface, InxLoggableComponentInfo31000 Members, nxllComponent Namespace, InxLoggableComponentInfo31000 Methods


InxLoggableComponentInfo31000.GetLogEnabled Method

InxLoggableComponentInfo31000.GetLogEnabled Method
InxLoggableComponentInfo31000 Interface InxLoggableComponentInfo31000 Members nxllComponent Namespace InxLoggableComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetLogEnabled: Boolean;
Description

This is GetLogEnabled, a member of class InxLoggableComponentInfo31000.

Group

InxLoggableComponentInfo31000 Methods

Links
InxLoggableComponentInfo31000 Interface, InxLoggableComponentInfo31000 Members, nxllComponent Namespace, InxLoggableComponentInfo31000 Methods


InxLoggableComponentInfo31000 Properties

InxLoggableComponentInfo31000 Properties
InxLoggableComponentInfo31000 Interface Legend Public Properties Send Feedback

The properties of the InxLoggableComponentInfo31000 class are listed here.

Interface

InxLoggableComponentInfo31000 Interface

Public Properties
Name | Description
EventLogInfo | This is EventLogInfo, a member of class InxLoggableComponentInfo31000.
LogEnabled | This is LogEnabled, a member of class InxLoggableComponentInfo31000.
Links
InxLoggableComponentInfo31000 Interface, Legend, Public Properties


InxLoggableComponentInfo31000.EventLogInfo Property

InxLoggableComponentInfo31000.EventLogInfo Property
InxLoggableComponentInfo31000 Interface InxLoggableComponentInfo31000 Members nxllComponent Namespace InxLoggableComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property EventLogInfo: InxComponentInfo31000;
Description

This is EventLogInfo, a member of class InxLoggableComponentInfo31000.

Group

InxLoggableComponentInfo31000 Properties

Links
InxLoggableComponentInfo31000 Interface, InxLoggableComponentInfo31000 Members, nxllComponent Namespace, InxLoggableComponentInfo31000 Properties


InxLoggableComponentInfo31000.LogEnabled Property

InxLoggableComponentInfo31000.LogEnabled Property
InxLoggableComponentInfo31000 Interface InxLoggableComponentInfo31000 Members nxllComponent Namespace InxLoggableComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property LogEnabled: Boolean;
Description

This is LogEnabled, a member of class InxLoggableComponentInfo31000.

Group

InxLoggableComponentInfo31000 Properties

Links
InxLoggableComponentInfo31000 Interface, InxLoggableComponentInfo31000 Members, nxllComponent Namespace, InxLoggableComponentInfo31000 Properties


InxStateComponentInfo31000 Interface

InxStateComponentInfo31000 Interface
InxStateComponentInfo31000 Methods InxStateComponentInfo31000 Properties InxStateComponentInfo31000 Members nxllComponent Interfaces Send Feedback
Class Hierarchy
nxllComponent_InxStateComponentInfo31000
Syntax
Delphi
InxStateComponentInfo31000 = interface(InxInvokable);
File

nxllComponent

Description

This is class nxllComponent.InxStateComponentInfo31000.

Group

Interfaces

Links
InxStateComponentInfo31000 Methods, InxStateComponentInfo31000 Properties, InxStateComponentInfo31000 Members, nxllComponent, Interfaces


InxStateComponentInfo31000 Members

InxStateComponentInfo31000 Members
InxStateComponentInfo31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxStateComponentInfo31000.

Interface

InxStateComponentInfo31000 Interface

Public Methods
Name | Description
GetState | This is GetState, a member of class InxStateComponentInfo31000.
Public Properties
Name | Description
State | This is State, a member of class InxStateComponentInfo31000.
Links
InxStateComponentInfo31000 Interface, Legend, Public Methods, Public Properties


InxStateComponentInfo31000 Methods

InxStateComponentInfo31000 Methods
InxStateComponentInfo31000 Interface Legend Public Methods Send Feedback

The methods of the InxStateComponentInfo31000 class are listed here.

Interface

InxStateComponentInfo31000 Interface

Public Methods
Name | Description
GetState | This is GetState, a member of class InxStateComponentInfo31000.
Links
InxStateComponentInfo31000 Interface, Legend, Public Methods


InxStateComponentInfo31000.GetState Method

InxStateComponentInfo31000.GetState Method
InxStateComponentInfo31000 Interface InxStateComponentInfo31000 Members nxllComponent Namespace InxStateComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function GetState: TnxState;
Description

This is GetState, a member of class InxStateComponentInfo31000.

Group

InxStateComponentInfo31000 Methods

Links
InxStateComponentInfo31000 Interface, InxStateComponentInfo31000 Members, nxllComponent Namespace, InxStateComponentInfo31000 Methods


InxStateComponentInfo31000 Properties

InxStateComponentInfo31000 Properties
InxStateComponentInfo31000 Interface Legend Public Properties Send Feedback

The properties of the InxStateComponentInfo31000 class are listed here.

Interface

InxStateComponentInfo31000 Interface

Public Properties
Name | Description
State | This is State, a member of class InxStateComponentInfo31000.
Links
InxStateComponentInfo31000 Interface, Legend, Public Properties


InxStateComponentInfo31000.State Property

InxStateComponentInfo31000.State Property
InxStateComponentInfo31000 Interface InxStateComponentInfo31000 Members nxllComponent Namespace InxStateComponentInfo31000 Properties Send Feedback
Syntax
Delphi
property State: TnxState;
Description

This is State, a member of class InxStateComponentInfo31000.

Group

InxStateComponentInfo31000 Properties

Links
InxStateComponentInfo31000 Interface, InxStateComponentInfo31000 Members, nxllComponent Namespace, InxStateComponentInfo31000 Properties


Functions

Functions
Functions nxllComponent Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxIntfToObj |
nxIntToStr | This is function nxllComponent.nxIntToStr.
nxIntToStr | This is function nxllComponent.nxIntToStr.
nxMapStateToString | DOM-IGNORE-BEGIN nxMapStateToString
nxMapStateTransitionToString |
Namespace

nxllComponent Namespace

Links
Functions, nxllComponent Namespace, Legend


nxllComponent.nxIntfToObj Function

nxllComponent.nxIntfToObj Function
nxllComponent Functions Send Feedback
Syntax
Delphi
function nxIntfToObj(const aIntf: InxInterface): TObject;
File

nxllComponent

Group

Functions

Links
nxllComponent, Functions


nxllComponent.nxIntToStr Function

nxllComponent.nxIntToStr Function
nxllComponent Functions Send Feedback
Syntax
Delphi
function nxIntToStr(anInt64: TnxInt64): string; overload;
File

nxllComponent

Description

This is function nxllComponent.nxIntToStr.

Group

Functions

Links
nxllComponent, Functions


nxllComponent.nxIntToStr Function

nxllComponent.nxIntToStr Function
nxllComponent Functions Send Feedback
Syntax
Delphi
function nxIntToStr(af: extended): string; overload;
File

nxllComponent

Description

This is function nxllComponent.nxIntToStr.

Group

Functions

Links
nxllComponent, Functions


nxllComponent.nxMapStateToString Function

nxllComponent.nxMapStateToString Function
nxllComponent Functions Send Feedback
Syntax
Delphi
function nxMapStateToString(const aState: TnxState): string;
File

nxllComponent

Description

DOM-IGNORE-BEGIN

nxMapStateToString

Group

Functions

Links
nxllComponent, Functions


nxllComponent.nxMapStateTransitionToString Function

nxllComponent.nxMapStateTransitionToString Function
nxllComponent Functions Send Feedback
Syntax
Delphi
function nxMapStateTransitionToString(const aStateTransition: TnxStateTransition): string;
File

nxllComponent

Group

Functions

Links
nxllComponent, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllComponent Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxLogPriority | Priorties for InxLogData
TnxSettingType | Settings data type
TnxState | Possible states for TnxStateComponent
TnxStateTransition | Possible state transitions for TnxStateComponent
Namespace

nxllComponent Namespace

Records
Name | Description
TnxStateChangeParam | This is record nxllComponent.TnxStateChangeParam.
Links
Enumerations, nxllComponent Namespace, Legend, Records


nxllComponent.TnxLogPriority Enumeration

nxllComponent.TnxLogPriority Enumeration
nxllComponent Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLogPriority = ( lpDebug, lpInfo, lpWarn, lpError, lpFatal );
File

nxllComponent

Members
Members | Description
lpDebug | debug only
lpInfo | information
lpWarn | Warning
lpError | Error
lpFatal | Fatal Error
Description

Priorties for InxLogData

Group

Structs, Records, Enums

Links
nxllComponent, Structs, Records, Enums


nxllComponent.TnxSettingType Enumeration

nxllComponent.TnxSettingType Enumeration
nxllComponent Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSettingType = ( nxstString, nxstInteger, nxstBoolean, nxstStream, nxstList, nxstThreadPriority, nxstSingleOption, nxstMultiOption, nxstAliases, nxstUsers, nxstExtended, nxstPasswordString, nxstCaption, nxstMemo, nxstPasswordMemo );
File

nxllComponent

Members
Members | Description
nxstString | string
nxstInteger | integer
nxstBoolean | Boolean
nxstStream | Stream
nxstList | Selection List
nxstThreadPriority | Thread Priority
nxstSingleOption | Radio Button
nxstMultiOption | Checkboxes
nxstAliases | Aliases
nxstUsers | Users
nxstExtended | Extended - needs to handle dynamically
nxstPasswordString | string accepting input and displaying
nxstCaption | display only string; not stored to component settings!
nxstMemo | multi-line string
nxstPasswordMemo | multi-line string accepting input and displaying
Description

Settings data type

Group

Structs, Records, Enums

Links
nxllComponent, Structs, Records, Enums


nxllComponent.TnxState Enumeration

nxllComponent.TnxState Enumeration
nxllComponent Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxState = ( nxsInactive, nxsUnsupported, nxsStopped, nxsStarted );
File

nxllComponent

Members
Members | Description
nxsInactive | Inactive
nxsUnsupported | Unsupported state - error
nxsStopped | Stopped
nxsStarted | Started
Description

Possible states for TnxStateComponent

Group

Structs, Records, Enums

Links
nxllComponent, Structs, Records, Enums


nxllComponent.TnxStateChangeParam Record

nxllComponent.TnxStateChangeParam Record
nxllComponent Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStateChangeParam = record
  OldState: TnxState;
  NewState: TnxState;
end;
File

nxllComponent

Description

This is record nxllComponent.TnxStateChangeParam.

Group

Structs, Records, Enums

Links
nxllComponent, Structs, Records, Enums


nxllComponent.TnxStateTransition Enumeration

nxllComponent.TnxStateTransition Enumeration
nxllComponent Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStateTransition = ( nxstNone, nxstInitializing, nxstDeactivating, nxstStarting, nxstStopping, nxstInvalid );
File

nxllComponent

Members
Members | Description
nxstNone | None
nxstInitializing | Component initializing
nxstDeactivating | Component deactivating
nxstStarting | Component starting
nxstStopping | Component stopping
nxstInvalid | Invalid state
Description

Possible state transitions for TnxStateComponent

Group

Structs, Records, Enums

Links
nxllComponent, Structs, Records, Enums


Types

Types
nxllComponent Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllComponent Namespace

Types
Name | Description
EnxComponentExceptionClass | Class definition for Component Exceptions
PInxLogData | BCB
PnxStateChangeParam | DOM-IGNORE-BEGIN
TnxComponentInfoClass | This is type nxllComponent.TnxComponentInfoClass.
TnxIterationListClass | Class definition for TnxIterationList
TnxLogPriorities | Set of TnxLogPriority
TnxNotifyOp | DOM-IGNORE-BEGIN
TnxPersistentClass | Class defintion for TnxPersistent.
TnxRegisterableComponentClass | Class definition for TnxRegisterableComponent.
Links
nxllComponent Namespace, Types


nxllComponent.EnxComponentExceptionClass Type

nxllComponent.EnxComponentExceptionClass Type
nxllComponent Types Send Feedback
Syntax
Delphi
EnxComponentExceptionClass = class of EnxComponentException;
File

nxllComponent

Description

Class definition for Component Exceptions

Group

Types

Links
nxllComponent, Types


nxllComponent.PInxLogData Type

nxllComponent.PInxLogData Type
nxllComponent Types Send Feedback
Syntax
Delphi
PInxLogData = ^InxLogData;
File

nxllComponent

Description

BCB

Group

Types

Links
nxllComponent, Types


nxllComponent.PnxStateChangeParam Type

nxllComponent.PnxStateChangeParam Type
nxllComponent Types Send Feedback
Syntax
Delphi
PnxStateChangeParam = ^TnxStateChangeParam;
File

nxllComponent

Description

DOM-IGNORE-BEGIN

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxComponentInfoClass Type

nxllComponent.TnxComponentInfoClass Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxComponentInfoClass = class of TnxComponentInfo;
File

nxllComponent

Description

This is type nxllComponent.TnxComponentInfoClass.

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxIterationListClass Type

nxllComponent.TnxIterationListClass Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxIterationListClass = class of TnxIterationList;
File

nxllComponent

Description

Class definition for TnxIterationList

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxLogPriorities Type

nxllComponent.TnxLogPriorities Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxLogPriorities = set of TnxLogPriority;
File

nxllComponent

Description

Set of TnxLogPriority

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxNotifyOp Type

nxllComponent.TnxNotifyOp Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxNotifyOp = type Byte;
File

nxllComponent

Description

DOM-IGNORE-BEGIN

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxPersistentClass Type

nxllComponent.TnxPersistentClass Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxPersistentClass = class of TnxPersistent;
File

nxllComponent

Description

Class defintion for TnxPersistent.

Group

Types

Links
nxllComponent, Types


nxllComponent.TnxRegisterableComponentClass Type

nxllComponent.TnxRegisterableComponentClass Type
nxllComponent Types Send Feedback
Syntax
Delphi
TnxRegisterableComponentClass = class of TnxRegisterableComponent;
File

nxllComponent

Description

Class definition for TnxRegisterableComponent.

Group

Types

Links
nxllComponent, Types


Variables

Variables
nxllComponent Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllComponent Namespace

Variables
Name | Description
___GetMem | This is variable nxllComponent.___GetMem.
_RegisterableComponentList | TnxRegisterableComponent
nxIncludeSelfPtrInExceptionData | This is variable nxllComponent.nxIncludeSelfPtrInExceptionData.
nxIncludeStatsInExceptionData | This is variable nxllComponent.nxIncludeStatsInExceptionData.
Links
nxllComponent Namespace, Variables


nxllComponent.___GetMem Variable

nxllComponent.___GetMem Variable
nxllComponent Variables Send Feedback
Syntax
Delphi
___GetMem: Pointer;
File

nxllComponent

Description

This is variable nxllComponent.___GetMem.

Group

Variables

Links
nxllComponent, Variables


nxllComponent._RegisterableComponentList Variable

nxllComponent._RegisterableComponentList Variable
nxllComponent Variables Send Feedback
Syntax
Delphi
_RegisterableComponentList: TStringList;
File

nxllComponent

Description

TnxRegisterableComponent

Group

Variables

Links
nxllComponent, Variables


nxllComponent.nxIncludeSelfPtrInExceptionData Variable

nxllComponent.nxIncludeSelfPtrInExceptionData Variable
nxllComponent Variables Send Feedback
Syntax
Delphi
nxIncludeSelfPtrInExceptionData: Boolean = True;
File

nxllComponent

Description

This is variable nxllComponent.nxIncludeSelfPtrInExceptionData.

Group

Variables

Links
nxllComponent, Variables


nxllComponent.nxIncludeStatsInExceptionData Variable

nxllComponent.nxIncludeStatsInExceptionData Variable
nxllComponent Variables Send Feedback
Syntax
Delphi
nxIncludeStatsInExceptionData: Boolean = True;
File

nxllComponent

Description

This is variable nxllComponent.nxIncludeStatsInExceptionData.

Group

Variables

Links
nxllComponent, Variables


Constants

Constants
Constants nxllComponent Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
BIAS_UNSPECIFIED | DOM-IGNORE-END
CLSID_ComponentInfo | DOM-IGNORE-END
csDefault | This is constant nxllComponent.csDefault.
lpInfoOrWarning | This is constant nxllComponent.lpInfoOrWarning.
nxn_Broadcast | This is constant nxllComponent.nxn_Broadcast.
nxn_ConfigChanged | This is constant nxllComponent.nxn_ConfigChanged.
nxn_ConnectionLost | This is constant nxllComponent.nxn_ConnectionLost.
nxn_Destroy | This is constant nxllComponent.nxn_Destroy.
nxn_Iterate | This is constant nxllComponent.nxn_Iterate.
nxn_OwnerChanged | This is constant nxllComponent.nxn_OwnerChanged.
nxn_Release | This is constant nxllComponent.nxn_Release.
nxn_StateChanged | This is constant nxllComponent.nxn_StateChanged.
nxn_StateChanging | This is constant nxllComponent.nxn_StateChanging.
nxObjCastGUID | This is constant nxllComponent.nxObjCastGUID.
nxStateDiagram | Given the current state of the engine and the target state of the engine, this array identifies the state to which the engine should be moved. The first dimension (vertical) of the array is the engine's current state. The second dimension (horizontal) of the array is the engine's target state. To get the next state, index into the array as follows: nextState := nxEngineStateDiagram[, ];
nxStateTransitionDiagram | This is constant nxllComponent.nxStateTransitionDiagram.
nxStateTransitionUpward | This is constant nxllComponent.nxStateTransitionUpward.
Namespace

nxllComponent Namespace

Links
Constants, nxllComponent Namespace


nxllComponent.BIAS_UNSPECIFIED Constant

nxllComponent.BIAS_UNSPECIFIED Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
BIAS_UNSPECIFIED = $0FFFFFFF;
File

nxllComponent

Description

DOM-IGNORE-END

Group

Constants

Links
nxllComponent, Constants


nxllComponent.CLSID_ComponentInfo Constant

nxllComponent.CLSID_ComponentInfo Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
CLSID_ComponentInfo: TnxGuid = '{9A00537F-49C8-456A-8770-E2143749D2FC}';
File

nxllComponent

Description

DOM-IGNORE-END

Group

Constants

Links
nxllComponent, Constants


nxllComponent.csDefault Constant

nxllComponent.csDefault Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
csDefault = 'default';
File

nxllComponent

Description

This is constant nxllComponent.csDefault.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.lpInfoOrWarning Constant

nxllComponent.lpInfoOrWarning Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
lpInfoOrWarning: array[Boolean] of TnxLogPriority = (lpInfo, lpWarn);
File

nxllComponent

Description

This is constant nxllComponent.lpInfoOrWarning.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_Broadcast Constant

nxllComponent.nxn_Broadcast Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_Broadcast = $09;
File

nxllComponent

Description

This is constant nxllComponent.nxn_Broadcast.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_ConfigChanged Constant

nxllComponent.nxn_ConfigChanged Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_ConfigChanged = $08;
File

nxllComponent

Description

This is constant nxllComponent.nxn_ConfigChanged.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_ConnectionLost Constant

nxllComponent.nxn_ConnectionLost Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_ConnectionLost = $02;
File

nxllComponent

Description

This is constant nxllComponent.nxn_ConnectionLost.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_Destroy Constant

nxllComponent.nxn_Destroy Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_Destroy = $01;
File

nxllComponent

Description

This is constant nxllComponent.nxn_Destroy.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_Iterate Constant

nxllComponent.nxn_Iterate Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_Iterate = $06;
File

nxllComponent

Description

This is constant nxllComponent.nxn_Iterate.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_OwnerChanged Constant

nxllComponent.nxn_OwnerChanged Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_OwnerChanged = $03;
File

nxllComponent

Description

This is constant nxllComponent.nxn_OwnerChanged.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_Release Constant

nxllComponent.nxn_Release Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_Release = $07;
File

nxllComponent

Description

This is constant nxllComponent.nxn_Release.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_StateChanged Constant

nxllComponent.nxn_StateChanged Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_StateChanged = $05;
File

nxllComponent

Description

This is constant nxllComponent.nxn_StateChanged.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxn_StateChanging Constant

nxllComponent.nxn_StateChanging Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxn_StateChanging = $04;
File

nxllComponent

Description

This is constant nxllComponent.nxn_StateChanging.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxObjCastGUID Constant

nxllComponent.nxObjCastGUID Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxObjCastGUID: TGUID = '{CEDF24DE-80A4-447D-8C75-EB871DC121FD}';
File

nxllComponent

Description

This is constant nxllComponent.nxObjCastGUID.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxStateDiagram Constant

nxllComponent.nxStateDiagram Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxStateDiagram: array [TnxState, TnxState] of TnxState = ( ( nxsInactive, nxsUnsupported, nxsStopped, nxsStopped ), ( nxsUnsupported, nxsUnsupported, nxsUnsupported, nxsUnsupported ), ( nxsInactive, nxsInactive, nxsStopped, nxsStarted ), ( nxsStopped, nxsStopped, nxsStopped, nxsStarted ) );
File

nxllComponent

Description

Given the current state of the engine and the target state of the engine, this array identifies the state to which the engine should be moved.

The first dimension (vertical) of the array is the engine's current state. The second dimension (horizontal) of the array is the engine's target state.

To get the next state, index into the array as follows:

nextState := nxEngineStateDiagram[, ];

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxStateTransitionDiagram Constant

nxllComponent.nxStateTransitionDiagram Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxStateTransitionDiagram: array [TnxState, TnxState] of TnxStateTransition = ( ( nxstNone, nxstNone, nxstInitializing, nxstInvalid ), ( nxstInvalid, nxstNone, nxstInvalid, nxstInvalid ), ( nxstDeactivating, nxstInvalid, nxstNone, nxstStarting ), ( nxstInvalid, nxstInvalid, nxstStopping, nxstNone ) );
File

nxllComponent

Description

This is constant nxllComponent.nxStateTransitionDiagram.

Group

Constants

Links
nxllComponent, Constants


nxllComponent.nxStateTransitionUpward Constant

nxllComponent.nxStateTransitionUpward Constant
nxllComponent Constants Send Feedback
Syntax
Delphi
nxStateTransitionUpward: array[TnxStateTransition] of Boolean = ( False, True, False, True, False, False );
File

nxllComponent

Description

This is constant nxllComponent.nxStateTransitionUpward.

Group

Constants

Links
nxllComponent, Constants


nxllComponentStrings Namespace

nxllComponentStrings Namespace
Constants Topics Send Feedback

This is namespace nxllComponentStrings.

Constants
Name | Description
rsComponentIsDisabled | This is constant nxllComponentStrings.rsComponentIsDisabled.
rsInstHasErrorCode | This is constant nxllComponentStrings.rsInstHasErrorCode.
rsInstNoCode | This is constant nxllComponentStrings.rsInstNoCode.
rsInvalidStateTransition | This is constant nxllComponentStrings.rsInvalidStateTransition.
rsMustBeInactive | This is constant nxllComponentStrings.rsMustBeInactive.
rsMustBeInactiveOrStopped | This is constant nxllComponentStrings.rsMustBeInactiveOrStopped.
rsMustBeStarted | This is constant nxllComponentStrings.rsMustBeStarted.
rsNilPointer | This is constant nxllComponentStrings.rsNilPointer.
rsStateFailed | This is constant nxllComponentStrings.rsStateFailed.
rsStateInactive | This is constant nxllComponentStrings.rsStateInactive.
rsStateStarted | This is constant nxllComponentStrings.rsStateStarted.
rsStateStopped | This is constant nxllComponentStrings.rsStateStopped.
rsStateTransitionDeactivating | This is constant nxllComponentStrings.rsStateTransitionDeactivating.
rsStateTransitionInitializing | This is constant nxllComponentStrings.rsStateTransitionInitializing.
rsStateTransitionInvalid | This is constant nxllComponentStrings.rsStateTransitionInvalid.
rsStateTransitionNone | This is constant nxllComponentStrings.rsStateTransitionNone.
rsStateTransitionStarting | This is constant nxllComponentStrings.rsStateTransitionStarting.
rsStateTransitionStopping | This is constant nxllComponentStrings.rsStateTransitionStopping.
rsStateUnsupported | This is constant nxllComponentStrings.rsStateUnsupported.
rsUnnamedInst | This is constant nxllComponentStrings.rsUnnamedInst.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxllComponentStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsComponentIsDisabled | This is constant nxllComponentStrings.rsComponentIsDisabled.
rsInstHasErrorCode | This is constant nxllComponentStrings.rsInstHasErrorCode.
rsInstNoCode | This is constant nxllComponentStrings.rsInstNoCode.
rsInvalidStateTransition | This is constant nxllComponentStrings.rsInvalidStateTransition.
rsMustBeInactive | This is constant nxllComponentStrings.rsMustBeInactive.
rsMustBeInactiveOrStopped | This is constant nxllComponentStrings.rsMustBeInactiveOrStopped.
rsMustBeStarted | This is constant nxllComponentStrings.rsMustBeStarted.
rsNilPointer | This is constant nxllComponentStrings.rsNilPointer.
rsStateFailed | This is constant nxllComponentStrings.rsStateFailed.
rsStateInactive | This is constant nxllComponentStrings.rsStateInactive.
rsStateStarted | This is constant nxllComponentStrings.rsStateStarted.
rsStateStopped | This is constant nxllComponentStrings.rsStateStopped.
rsStateTransitionDeactivating | This is constant nxllComponentStrings.rsStateTransitionDeactivating.
rsStateTransitionInitializing | This is constant nxllComponentStrings.rsStateTransitionInitializing.
rsStateTransitionInvalid | This is constant nxllComponentStrings.rsStateTransitionInvalid.
rsStateTransitionNone | This is constant nxllComponentStrings.rsStateTransitionNone.
rsStateTransitionStarting | This is constant nxllComponentStrings.rsStateTransitionStarting.
rsStateTransitionStopping | This is constant nxllComponentStrings.rsStateTransitionStopping.
rsStateUnsupported | This is constant nxllComponentStrings.rsStateUnsupported.
rsUnnamedInst | This is constant nxllComponentStrings.rsUnnamedInst.
Namespace

nxllComponentStrings Namespace

Links
Constants, nxllComponentStrings Namespace


nxllComponentStrings.rsComponentIsDisabled Constant

nxllComponentStrings.rsComponentIsDisabled Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsComponentIsDisabled = 'The Component is disabled.';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsComponentIsDisabled.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsInstHasErrorCode Constant

nxllComponentStrings.rsInstHasErrorCode Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsInstHasErrorCode = 'NexusDB: %s: %s [$%x/%d]';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsInstHasErrorCode.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsInstNoCode Constant

nxllComponentStrings.rsInstNoCode Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsInstNoCode = 'NexusDB: %s: %s [no error code]';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsInstNoCode.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsInvalidStateTransition Constant

nxllComponentStrings.rsInvalidStateTransition Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsInvalidStateTransition = 'Invalid state transition.';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsInvalidStateTransition.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsMustBeInactive Constant

nxllComponentStrings.rsMustBeInactive Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsMustBeInactive = 'This component must be inactive when performing this operation.';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsMustBeInactive.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsMustBeInactiveOrStopped Constant

nxllComponentStrings.rsMustBeInactiveOrStopped Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsMustBeInactiveOrStopped = 'This component must be inactive or stopped when performing this operation.';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsMustBeInactiveOrStopped.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsMustBeStarted Constant

nxllComponentStrings.rsMustBeStarted Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsMustBeStarted = 'This component must be started when performing this operation.';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsMustBeStarted.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsNilPointer Constant

nxllComponentStrings.rsNilPointer Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsNilPointer = '<nil pointer>';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsNilPointer.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateFailed Constant

nxllComponentStrings.rsStateFailed Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateFailed = 'Failed';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateFailed.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateInactive Constant

nxllComponentStrings.rsStateInactive Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateInactive = 'Inactive';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateInactive.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateStarted Constant

nxllComponentStrings.rsStateStarted Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateStarted = 'Started';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateStarted.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateStopped Constant

nxllComponentStrings.rsStateStopped Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateStopped = 'Stopped';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateStopped.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionDeactivating Constant

nxllComponentStrings.rsStateTransitionDeactivating Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionDeactivating = 'Deactivating';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionDeactivating.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionInitializing Constant

nxllComponentStrings.rsStateTransitionInitializing Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionInitializing = 'Initializing';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionInitializing.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionInvalid Constant

nxllComponentStrings.rsStateTransitionInvalid Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionInvalid = 'Invalid';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionInvalid.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionNone Constant

nxllComponentStrings.rsStateTransitionNone Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionNone = 'None';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionNone.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionStarting Constant

nxllComponentStrings.rsStateTransitionStarting Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionStarting = 'Starting';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionStarting.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateTransitionStopping Constant

nxllComponentStrings.rsStateTransitionStopping Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateTransitionStopping = 'Stopping';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateTransitionStopping.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsStateUnsupported Constant

nxllComponentStrings.rsStateUnsupported Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsStateUnsupported = 'Unsupported';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsStateUnsupported.

Group

Constants

Links
nxllComponentStrings, Constants


nxllComponentStrings.rsUnnamedInst Constant

nxllComponentStrings.rsUnnamedInst Constant
nxllComponentStrings Constants Send Feedback
Syntax
Delphi
rsUnnamedInst = '<unnamed %s instance>';
File

nxllComponentStrings

Description

This is constant nxllComponentStrings.rsUnnamedInst.

Group

Constants

Links
nxllComponentStrings, Constants


nxllConfigSettings Namespace

nxllConfigSettings Namespace
Classes Constants Legend Topics Send Feedback

Implements classes to persist settings to inifiles.

Classes
Name | Description
TnxINIComponentConfiguration | This is class nxllConfigSettings.TnxINIComponentConfiguration.
TnxINIServerConfiguration | This is class nxllConfigSettings.TnxINIServerConfiguration.
TnxSetting | A setting that can get it's attributes from another setting.
TnxSettings | Implementation of the TnxBaseSettings prototype.
Constants
Name | Description
EncryptionKey | TnxComponentConfiguration
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxllConfigSettings Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxINIComponentConfiguration | This is class nxllConfigSettings.TnxINIComponentConfiguration.
TnxINIServerConfiguration | This is class nxllConfigSettings.TnxINIServerConfiguration.
TnxSetting | A setting that can get it's attributes from another setting.
TnxSettings | Implementation of the TnxBaseSettings prototype.
Namespace

nxllConfigSettings Namespace

Links
Classes, nxllConfigSettings Namespace, Legend


TnxINIComponentConfiguration Class

TnxINIComponentConfiguration Class
TnxINIComponentConfiguration Fields TnxINIComponentConfiguration Methods TnxINIComponentConfiguration Members nxllConfigSettings Classes Send Feedback
Class Hierarchy
nxllConfigSettings_TnxINIComponentConfigurationnxllConfigSettings_TnxINIComponentConfiguration
Syntax
Delphi
TnxINIComponentConfiguration = class(TnxBaseComponentConfiguration);
File

nxllConfigSettings

Description

This is class nxllConfigSettings.TnxINIComponentConfiguration.

Group

Classes

Links
TnxINIComponentConfiguration Fields, TnxINIComponentConfiguration Methods, TnxINIComponentConfiguration Members, nxllConfigSettings, Classes


TnxINIComponentConfiguration Members

TnxINIComponentConfiguration Members
TnxINIComponentConfiguration Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxINIComponentConfiguration.

Class

TnxINIComponentConfiguration Class

Protected Fields
Name | Description
fBlowFish | This is fBlowFish, a member of class TnxINIComponentConfiguration.
fComponent | This is fComponent, a member of class TnxINIComponentConfiguration.
fConfig | This is fConfig, a member of class TnxBaseComponentConfiguration.
fServerConfiguration | This is fServerConfiguration, a member of class TnxINIComponentConfiguration.
Protected Methods
Name | Description
Decrypt | TnxINIComponentConfiguration
Encrypt | This is Encrypt, a member of class TnxINIComponentConfiguration.
Public Methods
Name | Description
Create | TnxBaseComponentConfiguration
CreateWithComponent | This is CreateWithComponent, a member of class TnxINIComponentConfiguration.
Destroy | This is Destroy, a member of class TnxINIComponentConfiguration.
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Public Properties
Name | Description
Config | This is Config, a member of class TnxBaseComponentConfiguration.
Links
TnxINIComponentConfiguration Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxINIComponentConfiguration.CreateWithComponent Constructor

TnxINIComponentConfiguration.CreateWithComponent Constructor
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Class Send Feedback
Syntax
Delphi
constructor CreateWithComponent(aServerConfiguration: TnxINIServerConfiguration; aComponent: String);
Description

This is CreateWithComponent, a member of class TnxINIComponentConfiguration.

Class

TnxINIComponentConfiguration Class

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Class


TnxINIComponentConfiguration.Destroy Destructor

TnxINIComponentConfiguration.Destroy Destructor
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxINIComponentConfiguration.

Class

TnxINIComponentConfiguration Class

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Class


TnxINIComponentConfiguration Fields

TnxINIComponentConfiguration Fields
TnxINIComponentConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxINIComponentConfiguration class are listed here.

Class

TnxINIComponentConfiguration Class

Protected Fields
Name | Description
fBlowFish | This is fBlowFish, a member of class TnxINIComponentConfiguration.
fComponent | This is fComponent, a member of class TnxINIComponentConfiguration.
fServerConfiguration | This is fServerConfiguration, a member of class TnxINIComponentConfiguration.
Links
TnxINIComponentConfiguration Class, Legend, Protected Fields


TnxINIComponentConfiguration.fBlowFish Field

TnxINIComponentConfiguration.fBlowFish Field
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Fields Send Feedback
Syntax
Delphi
fBlowFish: TnxBlowFishRC4;
Description

This is fBlowFish, a member of class TnxINIComponentConfiguration.

Group

TnxINIComponentConfiguration Fields

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Fields


TnxINIComponentConfiguration.fComponent Field

TnxINIComponentConfiguration.fComponent Field
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Fields Send Feedback
Syntax
Delphi
fComponent: string;
Description

This is fComponent, a member of class TnxINIComponentConfiguration.

Group

TnxINIComponentConfiguration Fields

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Fields


TnxINIComponentConfiguration.fServerConfiguration Field

TnxINIComponentConfiguration.fServerConfiguration Field
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Fields Send Feedback
Syntax
Delphi
fServerConfiguration: TnxINIServerConfiguration;
Description

This is fServerConfiguration, a member of class TnxINIComponentConfiguration.

Group

TnxINIComponentConfiguration Fields

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Fields


TnxINIComponentConfiguration Methods

TnxINIComponentConfiguration Methods
TnxINIComponentConfiguration Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxINIComponentConfiguration class are listed here.

Class

TnxINIComponentConfiguration Class

Protected Methods
Name | Description
Decrypt | TnxINIComponentConfiguration
Encrypt | This is Encrypt, a member of class TnxINIComponentConfiguration.
Public Methods
Name | Description
GetValue | Get the value associated with aName as Variant.
GetValueStream | Get the value associated with aName as stream.
SetValue | Set the value associated with aName as Variant.
SetValueStream | Set the value associated with aName as stream.
Links
TnxINIComponentConfiguration Class, Legend, Protected Methods, Public Methods


TnxINIComponentConfiguration.Decrypt Method

TnxINIComponentConfiguration.Decrypt Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure Decrypt(aBuffer: PAnsiChar; aSize: integer);
Description

TnxINIComponentConfiguration

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIComponentConfiguration.Encrypt Method

TnxINIComponentConfiguration.Encrypt Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure Encrypt(aBuffer: PAnsiChar; aSize: integer);
Description

This is Encrypt, a member of class TnxINIComponentConfiguration.

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIComponentConfiguration.GetValue Method

TnxINIComponentConfiguration.GetValue Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
function GetValue(aName: String; aDefault: Variant): Variant; override;
Description

Get the value associated with aName as Variant.

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIComponentConfiguration.GetValueStream Method

TnxINIComponentConfiguration.GetValueStream Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure GetValueStream(aName: String; aStream: TStream); override;
Description

Get the value associated with aName as stream.

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIComponentConfiguration.SetValue Method

TnxINIComponentConfiguration.SetValue Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValue(aName: String; aValue: Variant); override;
Description

Set the value associated with aName as Variant.

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIComponentConfiguration.SetValueStream Method

TnxINIComponentConfiguration.SetValueStream Method
TnxINIComponentConfiguration Class TnxINIComponentConfiguration Members nxllConfigSettings Namespace TnxINIComponentConfiguration Methods Send Feedback
Syntax
Delphi
procedure SetValueStream(aName: String; aStream: TStream); override;
Description

Set the value associated with aName as stream.

Group

TnxINIComponentConfiguration Methods

Links
TnxINIComponentConfiguration Class, TnxINIComponentConfiguration Members, nxllConfigSettings Namespace, TnxINIComponentConfiguration Methods


TnxINIServerConfiguration Class

TnxINIServerConfiguration Class
TnxINIServerConfiguration Fields TnxINIServerConfiguration Methods TnxINIServerConfiguration Members nxllConfigSettings Classes Send Feedback
Class Hierarchy
nxllConfigSettings_TnxINIServerConfigurationnxllConfigSettings_TnxINIServerConfiguration
Syntax
Delphi
TnxINIServerConfiguration = class(TnxBaseServerConfiguration);
File

nxllConfigSettings

Description

This is class nxllConfigSettings.TnxINIServerConfiguration.

Group

Classes

Links
TnxINIServerConfiguration Fields, TnxINIServerConfiguration Methods, TnxINIServerConfiguration Members, nxllConfigSettings, Classes


TnxINIServerConfiguration Members

TnxINIServerConfiguration Members
TnxINIServerConfiguration Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxINIServerConfiguration.

Class

TnxINIServerConfiguration Class

Protected Fields
Name | Description
fConfigErrors | This is fConfigErrors, a member of class TnxBaseServerConfiguration.
fFileName | This is fFileName, a member of class TnxBaseServerConfiguration.
fInifile | This is fInifile, a member of class TnxINIServerConfiguration.
Public Methods
Name | Description
Create | TnxINIServerConfiguration
Destroy | This is Destroy, a member of class TnxINIServerConfiguration.
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
Flush | This is Flush, a member of class TnxINIServerConfiguration.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Save | This is Save, a member of class TnxINIServerConfiguration.
Public Properties
Name | Description
Errors | This is Errors, a member of class TnxBaseServerConfiguration.
FileName | This is FileName, a member of class TnxBaseServerConfiguration.
ReportErrors | This is ReportErrors, a member of class TnxBaseServerConfiguration.
Links
TnxINIServerConfiguration Class, Legend, Protected Fields, Public Methods, Public Properties


TnxINIServerConfiguration.Create Constructor

TnxINIServerConfiguration.Create Constructor
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Class Send Feedback
Syntax
Delphi
constructor Create(aFileName: String); override;
Description

TnxINIServerConfiguration

Class

TnxINIServerConfiguration Class

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Class


TnxINIServerConfiguration.Destroy Destructor

TnxINIServerConfiguration.Destroy Destructor
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxINIServerConfiguration.

Class

TnxINIServerConfiguration Class

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Class


TnxINIServerConfiguration Fields

TnxINIServerConfiguration Fields
TnxINIServerConfiguration Class Legend Protected Fields Send Feedback

The fields of the TnxINIServerConfiguration class are listed here.

Class

TnxINIServerConfiguration Class

Protected Fields
Name | Description
fInifile | This is fInifile, a member of class TnxINIServerConfiguration.
Links
TnxINIServerConfiguration Class, Legend, Protected Fields


TnxINIServerConfiguration.fInifile Field

TnxINIServerConfiguration.fInifile Field
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Fields Send Feedback
Syntax
Delphi
fInifile: TMemIniFile;
Description

This is fInifile, a member of class TnxINIServerConfiguration.

Group

TnxINIServerConfiguration Fields

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Fields


TnxINIServerConfiguration Methods

TnxINIServerConfiguration Methods
TnxINIServerConfiguration Class Legend Public Methods Send Feedback

The methods of the TnxINIServerConfiguration class are listed here.

Class

TnxINIServerConfiguration Class

Public Methods
Name | Description
EnsureComponentConfiguration | The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.
Flush | This is Flush, a member of class TnxINIServerConfiguration.
GetComponentConfiguration | Has to return a TnBaseComponentConfiguration instance for the given Component.
Save | This is Save, a member of class TnxINIServerConfiguration.
Links
TnxINIServerConfiguration Class, Legend, Public Methods


TnxINIServerConfiguration.EnsureComponentConfiguration Method

TnxINIServerConfiguration.EnsureComponentConfiguration Method
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure EnsureComponentConfiguration(aComponent: string; aSettings: TnxBaseSettings); override;
Description

The implementation must make sure that all settings in the aSettings are available and of the right type; this method is NOT to write any values but the settings defintions only. A UI can then be built by reading that information.

Group

TnxINIServerConfiguration Methods

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Methods


TnxINIServerConfiguration.Flush Method

TnxINIServerConfiguration.Flush Method
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Flush;
Description

This is Flush, a member of class TnxINIServerConfiguration.

Group

TnxINIServerConfiguration Methods

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Methods


TnxINIServerConfiguration.GetComponentConfiguration Method

TnxINIServerConfiguration.GetComponentConfiguration Method
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Methods Send Feedback
Syntax
Delphi
function GetComponentConfiguration(aComponent: string): TnxBaseComponentConfiguration; override;
Description

Has to return a TnBaseComponentConfiguration instance for the given Component.

Group

TnxINIServerConfiguration Methods

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Methods


TnxINIServerConfiguration.Save Method

TnxINIServerConfiguration.Save Method
TnxINIServerConfiguration Class TnxINIServerConfiguration Members nxllConfigSettings Namespace TnxINIServerConfiguration Methods Send Feedback
Syntax
Delphi
procedure Save; override;
Description

This is Save, a member of class TnxINIServerConfiguration.

Group

TnxINIServerConfiguration Methods

Links
TnxINIServerConfiguration Class, TnxINIServerConfiguration Members, nxllConfigSettings Namespace, TnxINIServerConfiguration Methods


TnxSetting Class

TnxSetting Class
TnxSetting Methods TnxSetting Members nxllConfigSettings Classes Send Feedback
Class Hierarchy
nxllConfigSettings_TnxSettingnxllConfigSettings_TnxSetting
Syntax
Delphi
TnxSetting = class(TnxBaseSetting);
File

nxllConfigSettings

Description

A setting that can get it's attributes from another setting.

Group

Classes

Links
TnxSetting Methods, TnxSetting Members, nxllConfigSettings, Classes


TnxSetting Members

TnxSetting Members
TnxSetting Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSetting.

Class

TnxSetting Class

Protected Fields
Name | Description
fDefaultValue | This is fDefaultValue, a member of class TnxBaseSetting.
fEnforceValues | This is fEnforceValues, a member of class TnxBaseSetting.
fHideFromGUI | This is fHideFromGUI, a member of class TnxBaseSetting.
fHint | This is fHint, a member of class TnxBaseSetting.
fLabel | This is fLabel, a member of class TnxBaseSetting.
fMax | This is fMax, a member of class TnxBaseSetting.
fMin | This is fMin, a member of class TnxBaseSetting.
fName | This is fName, a member of class TnxBaseSetting.
fNotQueryable | This is fNotQueryable, a member of class TnxBaseSetting.
fPropertyName | This is fPropertyName, a member of class TnxBaseSetting.
fSettingType | This is fSettingType, a member of class TnxBaseSetting.
fValueList | This is fValueList, a member of class TnxBaseSetting.
Protected Methods
Name | Description
GetLabel | TnxBaseSetting
Public Methods
Name | Description
Assign | set the properties according to aSource TnxBaseSetting
Public Properties
Name | Description
_Label | Label.
DefaultValue | Default Value.
EnforceValues | If true then only values of Listvalues are possible.
HideFromGUI | Set to True to hide the setting from the UI; used for internal data.
Hint | A hint to be shown in a UI.
Max | Max value.
Min | Min value.
Name | Name of the Setting.
NotQueryable | Set to True to prevent the value from being queried from a client.
PropertyName | Name of the implementation Property
SettingType | Data type of the setting.
ValueList | List of possible values (usually Comma separated).
Links
TnxSetting Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSetting Methods

TnxSetting Methods
TnxSetting Class Legend Public Methods Send Feedback

The methods of the TnxSetting class are listed here.

Class

TnxSetting Class

Public Methods
Name | Description
Assign | set the properties according to aSource TnxBaseSetting
Links
TnxSetting Class, Legend, Public Methods


TnxSetting.Assign Method

TnxSetting.Assign Method
TnxSetting Class TnxSetting Members nxllConfigSettings Namespace TnxSetting Methods Send Feedback
Syntax
Delphi
procedure Assign(aSource: TnxBaseSetting); virtual;
Description

set the properties according to aSource

TnxBaseSetting

Group

TnxSetting Methods

Links
TnxSetting Class, TnxSetting Members, nxllConfigSettings Namespace, TnxSetting Methods


TnxSettings Class

TnxSettings Class
TnxSettings Fields TnxSettings Methods TnxSettings Members nxllConfigSettings Classes Send Feedback
Class Hierarchy
nxllConfigSettings_TnxSettingsnxllConfigSettings_TnxSettings
Syntax
Delphi
TnxSettings = class(TnxBaseSettings);
File

nxllConfigSettings

Description

Implementation of the TnxBaseSettings prototype.

Group

Classes

Links
TnxSettings Fields, TnxSettings Methods, TnxSettings Members, nxllConfigSettings, Classes


TnxSettings Members

TnxSettings Members
TnxSettings Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSettings.

Class

TnxSettings Class

Protected Fields
Name | Description
fList | This is fList, a member of class TnxSettings.
Protected Methods
Name | Description
GetCount | This is GetCount, a member of class TnxSettings.
GetSetting | This is GetSetting, a member of class TnxSettings.
SetSetting | This is SetSetting, a member of class TnxSettings.
Public Methods
Name | Description
AddSetting | Adds a setting to the collection.
Create | constructor TnxSettings
Destroy | destructor
RemoveSetting | Removes a setting from the collection.
Public Properties
Name | Description
Count | Returns the number of settings in the collection.
Setting | Returns the setting at position anIndex in the collection.
Links
TnxSettings Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSettings.Create Constructor

TnxSettings.Create Constructor
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Class Send Feedback
Syntax
Delphi
constructor Create;
Description

constructor

TnxSettings

Class

TnxSettings Class

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Class


TnxSettings.Destroy Destructor

TnxSettings.Destroy Destructor
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor

Class

TnxSettings Class

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Class


TnxSettings Fields

TnxSettings Fields
TnxSettings Class Legend Protected Fields Send Feedback

The fields of the TnxSettings class are listed here.

Class

TnxSettings Class

Protected Fields
Name | Description
fList | This is fList, a member of class TnxSettings.
Links
TnxSettings Class, Legend, Protected Fields


TnxSettings.fList Field

TnxSettings.fList Field
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Fields Send Feedback
Syntax
Delphi
fList: TList;
Description

This is fList, a member of class TnxSettings.

Group

TnxSettings Fields

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Fields


TnxSettings Methods

TnxSettings Methods
TnxSettings Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSettings class are listed here.

Class

TnxSettings Class

Protected Methods
Name | Description
GetCount | This is GetCount, a member of class TnxSettings.
GetSetting | This is GetSetting, a member of class TnxSettings.
SetSetting | This is SetSetting, a member of class TnxSettings.
Public Methods
Name | Description
AddSetting | Adds a setting to the collection.
RemoveSetting | Removes a setting from the collection.
Links
TnxSettings Class, Legend, Protected Methods, Public Methods


TnxSettings.AddSetting Method

TnxSettings.AddSetting Method
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Methods Send Feedback
Syntax
Delphi
function AddSetting(aSettting: TnxBaseSetting): TnxBaseSetting; override;
Description

Adds a setting to the collection.

Group

TnxSettings Methods

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Methods


TnxSettings.GetCount Method

TnxSettings.GetCount Method
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Methods Send Feedback
Syntax
Delphi
function GetCount: integer; override;
Description

This is GetCount, a member of class TnxSettings.

Group

TnxSettings Methods

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Methods


TnxSettings.GetSetting Method

TnxSettings.GetSetting Method
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Methods Send Feedback
Syntax
Delphi
function GetSetting(anIndex: integer): TnxBaseSetting; override;
Description

This is GetSetting, a member of class TnxSettings.

Group

TnxSettings Methods

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Methods


TnxSettings.RemoveSetting Method

TnxSettings.RemoveSetting Method
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Methods Send Feedback
Syntax
Delphi
procedure RemoveSetting(Index: integer); override;
Description

Removes a setting from the collection.

Group

TnxSettings Methods

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Methods


TnxSettings.SetSetting Method

TnxSettings.SetSetting Method
TnxSettings Class TnxSettings Members nxllConfigSettings Namespace TnxSettings Methods Send Feedback
Syntax
Delphi
procedure SetSetting(anIndex: integer; const Value: TnxBaseSetting); override;
Description

This is SetSetting, a member of class TnxSettings.

Group

TnxSettings Methods

Links
TnxSettings Class, TnxSettings Members, nxllConfigSettings Namespace, TnxSettings Methods


Constants

Constants
Constants nxllConfigSettings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EncryptionKey | TnxComponentConfiguration
Namespace

nxllConfigSettings Namespace

Links
Constants, nxllConfigSettings Namespace


nxllConfigSettings.EncryptionKey Constant

nxllConfigSettings.EncryptionKey Constant
nxllConfigSettings Constants Send Feedback
Syntax
Delphi
EncryptionKey: AnsiString = 'WERYKTJREW$^T#$%Y$THth2456NexusRox!wefrgsdhtg@#$^erghsdftj4w5tyfgvg';
File

nxllConfigSettings

Description

TnxComponentConfiguration

Group

Constants

Links
nxllConfigSettings, Constants


nxllConst Namespace

nxllConst Namespace
Constants Functions Legend Topics Variables Send Feedback

This is namespace nxllConst.

Constants
Name | Description
DoubleLinkedListCountStrings | This is constant nxllConst.DoubleLinkedListCountStrings.
IID_InxInterface | This is constant nxllConst.IID_InxInterface.
nxccREG_PRODUCT | This is constant nxllConst.nxccREG_PRODUCT.
nxcCRLF | This is constant nxllConst.nxcCRLF.
nxcl_1KB | One kilobyte.
nxcl_1MB | One megabyte.
nxcNexusMM3Hook | This is constant nxllConst.nxcNexusMM3Hook.
nxcNexusMM4Hook | This is constant nxllConst.nxcNexusMM4Hook.
nxcNexusMM5Hook | This is constant nxllConst.nxcNexusMM5Hook.
nxcNexusMM5Hook64 | This is constant nxllConst.nxcNexusMM5Hook64.
nxcValidIdentChars | This is constant nxllConst.nxcValidIdentChars.
nxDefaultTimeOut | 10 Seconds
nxDottedVersionString | This is constant nxllConst.nxDottedVersionString.
nxInt64Null | This is constant nxllConst.nxInt64Null.
nxNullGuid | This is constant nxllConst.nxNullGuid.
nxPackageVersion | This is constant nxllConst.nxPackageVersion.
nxSpecialString | This is constant nxllConst.nxSpecialString.
nxTableFormatVersionNumber | 3.00.00
nxVersion10000 | 1.00.00
nxVersion10100 | 1.01.00
nxVersion10200 | 1.02.00
nxVersion10300 | 1.03.00
nxVersion10301 | 1.03.01
nxVersion20000 | 2.00.00
nxVersion20100 | 2.01.00
nxVersion20200 | 2.02.00
nxVersion20300 | 2.03.00
nxVersion20400 | 2.04.00
nxVersion20500 | 2.05.00
nxVersion20600 | 2.06.00
nxVersion20601 | 2.06.01
nxVersion20700 | 2.07.00
nxVersion20701 | 2.07.01
nxVersion20702 | 2.07.02
nxVersion30000 | 3.00.00
nxVersion30001 | 3.00.01
nxVersion30002 | 3.00.02
nxVersion30100 | 3.01.00
nxVersion30101 | 3.01.01
nxVersion30200 | 3.02.00
nxVersion30201 | 3.02.01
nxVersion30300 | 3.03.00
nxVersion30400 | 3.04.00
nxVersion30401 | 3.04.01
nxVersion30500 | 3.05.00
nxVersion30501 | 3.05.01
nxVersion30600 | 3.06.00
nxVersion30601 | 3.06.01
nxVersion30700 | 3.07.00
nxVersion30800 | 3.08.00
nxVersion30900 | 3.09.00
nxVersion31000 | 3.10.00
nxVersion31001 | 3.10.01
nxVersion31002 | 3.10.02
nxVersion31003 | 3.10.03
nxVersion31004 | 3.10.04
nxVersion31100 | 3.11.00
nxVersion31110 | 3.11.10
nxVersion31120 | 3.11.20
nxVersion31122 | 3.11.22
nxVersion31200 | 3.12.00
nxVersion31201 | 3.12.01
nxVersion31202 | 3.12.02
nxVersion31203 | 3.12.03
nxVersion31204 | 3.12.04
nxVersion35000 | 3.50.00
nxVersion35100 | 3.51.00
nxVersion35110 | 3.51.10
nxVersion35120 | 3.51.20
nxVersion35130 | 3.51.30
nxVersion40000 | 4.00.00
nxVersion40001 | 4.00.01
nxVersion40002 | 4.00.02
nxVersion40003 | 4.00.03
nxVersion40004 | 4.00.04
nxVersion40005 | 4.00.05
nxVersion40006 | 4.00.06
nxVersion40007 | 4.00.07
nxVersion40008 | 4.00.08
nxVersion40009 | 4.00.09
nxVersion40010 | 4.00.10
nxVersion40011 | 4.00.11
nxVersion40012 | 4.00.12
nxVersion40013 | 4.00.13
nxVersion40014 | 4.00.14
nxVersion40015 | 4.00.15
nxVersion41000 | 4.10.00
nxVersion41100 | 4.11.00
nxVersion41200 | 4.12.00
nxVersion41201 | 4.12.01
nxVersion41300 | 4.13.00
nxVersion41301 | 4.13.01
nxVersion41302 | 4.13.02
nxVersion45000 | 4.50.00
nxVersion45003 | 4.50.03
nxVersion45004 | 4.50.04
nxVersion45005 | 4.50.05
nxVersion45006 | 4.50.06
nxVersion45008 | 4.50.08
nxVersion45009 | 4.50.09
nxVersion45011 | 4.50.11
nxVersion45012 | 4.50.12
nxVersion45013 | 4.50.13
nxVersion45014 | 4.50.14
nxVersion45015 | 4.50.15
nxVersion45016 | 4.50.16
nxVersion45017 | 4.50.17
nxVersion45018 | 4.50.18
nxVersion45019 | 4.50.19
nxVersion45020 | 4.50.20
nxVersion45021 | 4.50.21
nxVersion45022 | 4.50.22
nxVersion45023 | 4.50.23
nxVersion45024 | 4.50.24
nxVersion45025 | 4.50.25
nxVersion45026 | 4.50.26
nxVersion45027 | 4.50.27
nxVersionNumber | 4.50.27
nxVersionString | This is constant nxllConst.nxVersionString.
Functions
Name | Description
nxGetCurrentThreadNxMinVersion | This is function nxllConst.nxGetCurrentThreadNxMinVersion.
nxGetCurrentThreadNxVersion | This is function nxllConst.nxGetCurrentThreadNxVersion.
nxSetCurrentThreadNxVersion | This is function nxllConst.nxSetCurrentThreadNxVersion.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
nxDefaultAppData | This is variable nxllConst.nxDefaultAppData.
Links
Constants, Functions, Legend, Topics, Variables


Functions

Functions
Functions nxllConst Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxGetCurrentThreadNxMinVersion | This is function nxllConst.nxGetCurrentThreadNxMinVersion.
nxGetCurrentThreadNxVersion | This is function nxllConst.nxGetCurrentThreadNxVersion.
nxSetCurrentThreadNxVersion | This is function nxllConst.nxSetCurrentThreadNxVersion.
Namespace

nxllConst Namespace

Links
Functions, nxllConst Namespace, Legend


nxllConst.nxGetCurrentThreadNxMinVersion Function

nxllConst.nxGetCurrentThreadNxMinVersion Function
nxllConst Functions Send Feedback
Syntax
Delphi
function nxGetCurrentThreadNxMinVersion: Integer;
File

nxllConst

Description

This is function nxllConst.nxGetCurrentThreadNxMinVersion.

Group

Functions

Links
nxllConst, Functions


nxllConst.nxGetCurrentThreadNxVersion Function

nxllConst.nxGetCurrentThreadNxVersion Function
nxllConst Functions Send Feedback
Syntax
Delphi
function nxGetCurrentThreadNxVersion: Integer;
File

nxllConst

Description

This is function nxllConst.nxGetCurrentThreadNxVersion.

Group

Functions

Links
nxllConst, Functions


nxllConst.nxSetCurrentThreadNxVersion Function

nxllConst.nxSetCurrentThreadNxVersion Function
nxllConst Functions Send Feedback
Syntax
Delphi
procedure nxSetCurrentThreadNxVersion(aVersion: Integer);
File

nxllConst

Description

This is function nxllConst.nxSetCurrentThreadNxVersion.

Group

Functions

Links
nxllConst, Functions


Variables

Variables
nxllConst Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllConst Namespace

Variables
Name | Description
nxDefaultAppData | This is variable nxllConst.nxDefaultAppData.
Links
nxllConst Namespace, Variables


nxllConst.nxDefaultAppData Variable

nxllConst.nxDefaultAppData Variable
nxllConst Variables Send Feedback
Syntax
Delphi
nxDefaultAppData: string;
File

nxllConst

Description

This is variable nxllConst.nxDefaultAppData.

Group

Variables

Links
nxllConst, Variables


Constants

Constants
Constants nxllConst Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DoubleLinkedListCountStrings | This is constant nxllConst.DoubleLinkedListCountStrings.
IID_InxInterface | This is constant nxllConst.IID_InxInterface.
nxccREG_PRODUCT | This is constant nxllConst.nxccREG_PRODUCT.
nxcCRLF | This is constant nxllConst.nxcCRLF.
nxcl_1KB | One kilobyte.
nxcl_1MB | One megabyte.
nxcNexusMM3Hook | This is constant nxllConst.nxcNexusMM3Hook.
nxcNexusMM4Hook | This is constant nxllConst.nxcNexusMM4Hook.
nxcNexusMM5Hook | This is constant nxllConst.nxcNexusMM5Hook.
nxcNexusMM5Hook64 | This is constant nxllConst.nxcNexusMM5Hook64.
nxcValidIdentChars | This is constant nxllConst.nxcValidIdentChars.
nxDefaultTimeOut | 10 Seconds
nxDottedVersionString | This is constant nxllConst.nxDottedVersionString.
nxInt64Null | This is constant nxllConst.nxInt64Null.
nxNullGuid | This is constant nxllConst.nxNullGuid.
nxPackageVersion | This is constant nxllConst.nxPackageVersion.
nxSpecialString | This is constant nxllConst.nxSpecialString.
nxTableFormatVersionNumber | 3.00.00
nxVersion10000 | 1.00.00
nxVersion10100 | 1.01.00
nxVersion10200 | 1.02.00
nxVersion10300 | 1.03.00
nxVersion10301 | 1.03.01
nxVersion20000 | 2.00.00
nxVersion20100 | 2.01.00
nxVersion20200 | 2.02.00
nxVersion20300 | 2.03.00
nxVersion20400 | 2.04.00
nxVersion20500 | 2.05.00
nxVersion20600 | 2.06.00
nxVersion20601 | 2.06.01
nxVersion20700 | 2.07.00
nxVersion20701 | 2.07.01
nxVersion20702 | 2.07.02
nxVersion30000 | 3.00.00
nxVersion30001 | 3.00.01
nxVersion30002 | 3.00.02
nxVersion30100 | 3.01.00
nxVersion30101 | 3.01.01
nxVersion30200 | 3.02.00
nxVersion30201 | 3.02.01
nxVersion30300 | 3.03.00
nxVersion30400 | 3.04.00
nxVersion30401 | 3.04.01
nxVersion30500 | 3.05.00
nxVersion30501 | 3.05.01
nxVersion30600 | 3.06.00
nxVersion30601 | 3.06.01
nxVersion30700 | 3.07.00
nxVersion30800 | 3.08.00
nxVersion30900 | 3.09.00
nxVersion31000 | 3.10.00
nxVersion31001 | 3.10.01
nxVersion31002 | 3.10.02
nxVersion31003 | 3.10.03
nxVersion31004 | 3.10.04
nxVersion31100 | 3.11.00
nxVersion31110 | 3.11.10
nxVersion31120 | 3.11.20
nxVersion31122 | 3.11.22
nxVersion31200 | 3.12.00
nxVersion31201 | 3.12.01
nxVersion31202 | 3.12.02
nxVersion31203 | 3.12.03
nxVersion31204 | 3.12.04
nxVersion35000 | 3.50.00
nxVersion35100 | 3.51.00
nxVersion35110 | 3.51.10
nxVersion35120 | 3.51.20
nxVersion35130 | 3.51.30
nxVersion40000 | 4.00.00
nxVersion40001 | 4.00.01
nxVersion40002 | 4.00.02
nxVersion40003 | 4.00.03
nxVersion40004 | 4.00.04
nxVersion40005 | 4.00.05
nxVersion40006 | 4.00.06
nxVersion40007 | 4.00.07
nxVersion40008 | 4.00.08
nxVersion40009 | 4.00.09
nxVersion40010 | 4.00.10
nxVersion40011 | 4.00.11
nxVersion40012 | 4.00.12
nxVersion40013 | 4.00.13
nxVersion40014 | 4.00.14
nxVersion40015 | 4.00.15
nxVersion41000 | 4.10.00
nxVersion41100 | 4.11.00
nxVersion41200 | 4.12.00
nxVersion41201 | 4.12.01
nxVersion41300 | 4.13.00
nxVersion41301 | 4.13.01
nxVersion41302 | 4.13.02
nxVersion45000 | 4.50.00
nxVersion45003 | 4.50.03
nxVersion45004 | 4.50.04
nxVersion45005 | 4.50.05
nxVersion45006 | 4.50.06
nxVersion45008 | 4.50.08
nxVersion45009 | 4.50.09
nxVersion45011 | 4.50.11
nxVersion45012 | 4.50.12
nxVersion45013 | 4.50.13
nxVersion45014 | 4.50.14
nxVersion45015 | 4.50.15
nxVersion45016 | 4.50.16
nxVersion45017 | 4.50.17
nxVersion45018 | 4.50.18
nxVersion45019 | 4.50.19
nxVersion45020 | 4.50.20
nxVersion45021 | 4.50.21
nxVersion45022 | 4.50.22
nxVersion45023 | 4.50.23
nxVersion45024 | 4.50.24
nxVersion45025 | 4.50.25
nxVersion45026 | 4.50.26
nxVersion45027 | 4.50.27
nxVersionNumber | 4.50.27
nxVersionString | This is constant nxllConst.nxVersionString.
Namespace

nxllConst Namespace

Links
Constants, nxllConst Namespace


nxllConst.DoubleLinkedListCountStrings Constant

nxllConst.DoubleLinkedListCountStrings Constant
nxllConst Constants Send Feedback
Syntax
Delphi
DoubleLinkedListCountStrings: array[Boolean,Boolean] of string = ( ('None', 'None'), ('Multiple', 'One') );
File

nxllConst

Description

This is constant nxllConst.DoubleLinkedListCountStrings.

Group

Constants

Links
nxllConst, Constants


nxllConst.IID_InxInterface Constant

nxllConst.IID_InxInterface Constant
nxllConst Constants Send Feedback
Syntax
Delphi
IID_InxInterface: TGUID = '{00000000-0000-0000-C000-000000000046}';
File

nxllConst

Description

This is constant nxllConst.IID_InxInterface.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxccREG_PRODUCT Constant

nxllConst.nxccREG_PRODUCT Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxccREG_PRODUCT = '\Software\Nexus\NexusDB\4.0';
File

nxllConst

Description

This is constant nxllConst.nxccREG_PRODUCT.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcCRLF Constant

nxllConst.nxcCRLF Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcCRLF = #13#10;
File

nxllConst

Description

This is constant nxllConst.nxcCRLF.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcl_1KB Constant

nxllConst.nxcl_1KB Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcl_1KB = 1024;
File

nxllConst

Description

One kilobyte.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcl_1MB Constant

nxllConst.nxcl_1MB Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcl_1MB = 1024 * 1024;
File

nxllConst

Description

One megabyte.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcNexusMM3Hook Constant

nxllConst.nxcNexusMM3Hook Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcNexusMM3Hook = 'NexusMM3Hook';
File

nxllConst

Description

This is constant nxllConst.nxcNexusMM3Hook.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcNexusMM4Hook Constant

nxllConst.nxcNexusMM4Hook Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcNexusMM4Hook = 'NexusMM4Hook';
File

nxllConst

Description

This is constant nxllConst.nxcNexusMM4Hook.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcNexusMM5Hook Constant

nxllConst.nxcNexusMM5Hook Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcNexusMM5Hook = 'NexusMM5Hook';
File

nxllConst

Description

This is constant nxllConst.nxcNexusMM5Hook.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcNexusMM5Hook64 Constant

nxllConst.nxcNexusMM5Hook64 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcNexusMM5Hook64 = 'NexusMM5Hook_64';
File

nxllConst

Description

This is constant nxllConst.nxcNexusMM5Hook64.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxcValidIdentChars Constant

nxllConst.nxcValidIdentChars Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxcValidIdentChars: TnxCharSet = [ '.', #32 , #33 , #35 , #36 , #37 , #38 , #40 , #41 , #43 , #45 , #48 .. #57 , #64 , #65 .. #90 , #91 , #93 , #94 , #95 , #97 ..#122 , #123 , #125 , #126 , #39 , #42 , #44 , #47 , #59 , #124 , #128 , #163 , #176 , #192 ..#255 , #8364 ];
File

nxllConst

Description

This is constant nxllConst.nxcValidIdentChars.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxDefaultTimeOut Constant

nxllConst.nxDefaultTimeOut Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxDefaultTimeOut = 10 * 1000;
File

nxllConst

Description

10 Seconds

Group

Constants

Links
nxllConst, Constants


nxllConst.nxDottedVersionString Constant

nxllConst.nxDottedVersionString Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxDottedVersionString = '4.50';
File

nxllConst

Description

This is constant nxllConst.nxDottedVersionString.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxInt64Null Constant

nxllConst.nxInt64Null Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxInt64Null: TnxInt64 = 0;
File

nxllConst

Description

This is constant nxllConst.nxInt64Null.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxNullGuid Constant

nxllConst.nxNullGuid Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxNullGuid: TnxGuid = '{00000000-0000-0000-0000-000000000000}';
File

nxllConst

Description

This is constant nxllConst.nxNullGuid.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxPackageVersion Constant

nxllConst.nxPackageVersion Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxPackageVersion: string = '70' '90' '100' '110' '120' '140' '150' '160' '170' '180' '190' '200' '210' '220' '230' '240' '250' '260' '270' '280' '100' '110' '120' '140' '150' '160' '170' '180' '190' '200' '210' '220' '230' '240' '250' '260' '270' '280';
File

nxllConst

Description

This is constant nxllConst.nxPackageVersion.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxSpecialString Constant

nxllConst.nxSpecialString Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxSpecialString: string = 'Trial'{$DEFINE TYPESET} 'Lite'{$DEFINE TYPESET} 'Beta'{$DEFINE TYPESET} 'Release' + ' ' + '(D7)' '(D9)' '(D10)' '(D11)' '(D12)' '(D14)' '(D15)' '(D16)' '(D17)' '(D18)' '(D19)' '(D20)' '(D21)' '(D22)' '(D23)' '(D24)' '(D25)' '(D26)' '(D27)' '(D28)' '(C11)' '(C12)' '(C14)' '(C15)' '(C16)' '(C17)' '(C18)' '(C19)' '(C20)' '(C21)' '(C22)' '(C23)' '(C24)' '(C25)' '(C26)' '(C27)' '(C28)' {$DEFINE NX_STANDARD_EDITION} +' Embedded'{$UNDEF NX_STANDARD_EDITION} +' (Free)' +' Professional Edition'{$UNDEF NX_STANDARD_EDITION} +' Starter Edition'{$UNDEF NX_STANDARD_EDITION} +' BDE Replacement Edition'{$UNDEF NX_STANDARD_EDITION} +' Standard Edition' {$UNDEF NX_STANDARD_EDITION} +' 64bit' +' 32bit';
File

nxllConst

Description

This is constant nxllConst.nxSpecialString.

Group

Constants

Links
nxllConst, Constants


nxllConst.nxTableFormatVersionNumber Constant

nxllConst.nxTableFormatVersionNumber Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxTableFormatVersionNumber: Integer = 30000;
File

nxllConst

Description

3.00.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion10000 Constant

nxllConst.nxVersion10000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion10000: Integer = 10000;
File

nxllConst

Description

1.00.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion10100 Constant

nxllConst.nxVersion10100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion10100: Integer = 10100;
File

nxllConst

Description

1.01.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion10200 Constant

nxllConst.nxVersion10200 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion10200: Integer = 10200;
File

nxllConst

Description

1.02.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion10300 Constant

nxllConst.nxVersion10300 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion10300: Integer = 10300;
File

nxllConst

Description

1.03.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion10301 Constant

nxllConst.nxVersion10301 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion10301: Integer = 10301;
File

nxllConst

Description

1.03.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20000 Constant

nxllConst.nxVersion20000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20000: Integer = 20000;
File

nxllConst

Description

2.00.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20100 Constant

nxllConst.nxVersion20100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20100: Integer = 20100;
File

nxllConst

Description

2.01.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20200 Constant

nxllConst.nxVersion20200 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20200: Integer = 20200;
File

nxllConst

Description

2.02.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20300 Constant

nxllConst.nxVersion20300 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20300: Integer = 20300;
File

nxllConst

Description

2.03.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20400 Constant

nxllConst.nxVersion20400 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20400: Integer = 20400;
File

nxllConst

Description

2.04.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20500 Constant

nxllConst.nxVersion20500 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20500: Integer = 20500;
File

nxllConst

Description

2.05.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20600 Constant

nxllConst.nxVersion20600 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20600: Integer = 20600;
File

nxllConst

Description

2.06.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20601 Constant

nxllConst.nxVersion20601 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20601: Integer = 20601;
File

nxllConst

Description

2.06.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20700 Constant

nxllConst.nxVersion20700 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20700: Integer = 20700;
File

nxllConst

Description

2.07.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20701 Constant

nxllConst.nxVersion20701 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20701: Integer = 20701;
File

nxllConst

Description

2.07.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion20702 Constant

nxllConst.nxVersion20702 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion20702: Integer = 20702;
File

nxllConst

Description

2.07.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30000 Constant

nxllConst.nxVersion30000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30000: Integer = 30000;
File

nxllConst

Description

3.00.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30001 Constant

nxllConst.nxVersion30001 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30001: Integer = 30001;
File

nxllConst

Description

3.00.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30002 Constant

nxllConst.nxVersion30002 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30002: Integer = 30002;
File

nxllConst

Description

3.00.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30100 Constant

nxllConst.nxVersion30100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30100: Integer = 30100;
File

nxllConst

Description

3.01.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30101 Constant

nxllConst.nxVersion30101 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30101: Integer = 30101;
File

nxllConst

Description

3.01.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30200 Constant

nxllConst.nxVersion30200 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30200: Integer = 30200;
File

nxllConst

Description

3.02.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30201 Constant

nxllConst.nxVersion30201 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30201: Integer = 30201;
File

nxllConst

Description

3.02.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30300 Constant

nxllConst.nxVersion30300 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30300: Integer = 30300;
File

nxllConst

Description

3.03.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30400 Constant

nxllConst.nxVersion30400 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30400: Integer = 30400;
File

nxllConst

Description

3.04.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30401 Constant

nxllConst.nxVersion30401 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30401: Integer = 30401;
File

nxllConst

Description

3.04.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30500 Constant

nxllConst.nxVersion30500 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30500: Integer = 30500;
File

nxllConst

Description

3.05.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30501 Constant

nxllConst.nxVersion30501 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30501: Integer = 30501;
File

nxllConst

Description

3.05.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30600 Constant

nxllConst.nxVersion30600 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30600: Integer = 30600;
File

nxllConst

Description

3.06.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30601 Constant

nxllConst.nxVersion30601 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30601: Integer = 30601;
File

nxllConst

Description

3.06.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30700 Constant

nxllConst.nxVersion30700 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30700: Integer = 30700;
File

nxllConst

Description

3.07.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30800 Constant

nxllConst.nxVersion30800 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30800: Integer = 30800;
File

nxllConst

Description

3.08.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion30900 Constant

nxllConst.nxVersion30900 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion30900: Integer = 30900;
File

nxllConst

Description

3.09.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31000 Constant

nxllConst.nxVersion31000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31000: Integer = 31000;
File

nxllConst

Description

3.10.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31001 Constant

nxllConst.nxVersion31001 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31001: Integer = 31001;
File

nxllConst

Description

3.10.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31002 Constant

nxllConst.nxVersion31002 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31002: Integer = 31002;
File

nxllConst

Description

3.10.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31003 Constant

nxllConst.nxVersion31003 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31003: Integer = 31003;
File

nxllConst

Description

3.10.03

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31004 Constant

nxllConst.nxVersion31004 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31004: Integer = 31004;
File

nxllConst

Description

3.10.04

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31100 Constant

nxllConst.nxVersion31100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31100: Integer = 31100;
File

nxllConst

Description

3.11.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31110 Constant

nxllConst.nxVersion31110 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31110: Integer = 31110;
File

nxllConst

Description

3.11.10

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31120 Constant

nxllConst.nxVersion31120 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31120: Integer = 31120;
File

nxllConst

Description

3.11.20

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31122 Constant

nxllConst.nxVersion31122 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31122: Integer = 31122;
File

nxllConst

Description

3.11.22

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31200 Constant

nxllConst.nxVersion31200 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31200: Integer = 31200;
File

nxllConst

Description

3.12.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31201 Constant

nxllConst.nxVersion31201 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31201: Integer = 31201;
File

nxllConst

Description

3.12.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31202 Constant

nxllConst.nxVersion31202 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31202: Integer = 31202;
File

nxllConst

Description

3.12.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31203 Constant

nxllConst.nxVersion31203 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31203: Integer = 31203;
File

nxllConst

Description

3.12.03

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion31204 Constant

nxllConst.nxVersion31204 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion31204: Integer = 31204;
File

nxllConst

Description

3.12.04

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion35000 Constant

nxllConst.nxVersion35000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion35000: Integer = 35000;
File

nxllConst

Description

3.50.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion35100 Constant

nxllConst.nxVersion35100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion35100: Integer = 35100;
File

nxllConst

Description

3.51.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion35110 Constant

nxllConst.nxVersion35110 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion35110: Integer = 35110;
File

nxllConst

Description

3.51.10

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion35120 Constant

nxllConst.nxVersion35120 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion35120: Integer = 35120;
File

nxllConst

Description

3.51.20

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion35130 Constant

nxllConst.nxVersion35130 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion35130: Integer = 35130;
File

nxllConst

Description

3.51.30

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40000 Constant

nxllConst.nxVersion40000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40000: Integer = 40000;
File

nxllConst

Description

4.00.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40001 Constant

nxllConst.nxVersion40001 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40001: Integer = 40001;
File

nxllConst

Description

4.00.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40002 Constant

nxllConst.nxVersion40002 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40002: Integer = 40002;
File

nxllConst

Description

4.00.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40003 Constant

nxllConst.nxVersion40003 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40003: Integer = 40003;
File

nxllConst

Description

4.00.03

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40004 Constant

nxllConst.nxVersion40004 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40004: Integer = 40004;
File

nxllConst

Description

4.00.04

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40005 Constant

nxllConst.nxVersion40005 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40005: Integer = 40005;
File

nxllConst

Description

4.00.05

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40006 Constant

nxllConst.nxVersion40006 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40006: Integer = 40006;
File

nxllConst

Description

4.00.06

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40007 Constant

nxllConst.nxVersion40007 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40007: Integer = 40007;
File

nxllConst

Description

4.00.07

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40008 Constant

nxllConst.nxVersion40008 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40008: Integer = 40008;
File

nxllConst

Description

4.00.08

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40009 Constant

nxllConst.nxVersion40009 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40009: Integer = 40009;
File

nxllConst

Description

4.00.09

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40010 Constant

nxllConst.nxVersion40010 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40010: Integer = 40010;
File

nxllConst

Description

4.00.10

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40011 Constant

nxllConst.nxVersion40011 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40011: Integer = 40011;
File

nxllConst

Description

4.00.11

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40012 Constant

nxllConst.nxVersion40012 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40012: Integer = 40012;
File

nxllConst

Description

4.00.12

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40013 Constant

nxllConst.nxVersion40013 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40013: Integer = 40013;
File

nxllConst

Description

4.00.13

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40014 Constant

nxllConst.nxVersion40014 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40014: Integer = 40014;
File

nxllConst

Description

4.00.14

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion40015 Constant

nxllConst.nxVersion40015 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion40015: Integer = 40015;
File

nxllConst

Description

4.00.15

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41000 Constant

nxllConst.nxVersion41000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41000: Integer = 41000;
File

nxllConst

Description

4.10.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41100 Constant

nxllConst.nxVersion41100 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41100: Integer = 41100;
File

nxllConst

Description

4.11.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41200 Constant

nxllConst.nxVersion41200 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41200: Integer = 41200;
File

nxllConst

Description

4.12.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41201 Constant

nxllConst.nxVersion41201 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41201: Integer = 41201;
File

nxllConst

Description

4.12.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41300 Constant

nxllConst.nxVersion41300 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41300: Integer = 41300;
File

nxllConst

Description

4.13.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41301 Constant

nxllConst.nxVersion41301 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41301: Integer = 41301;
File

nxllConst

Description

4.13.01

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion41302 Constant

nxllConst.nxVersion41302 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion41302: Integer = 41302;
File

nxllConst

Description

4.13.02

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45000 Constant

nxllConst.nxVersion45000 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45000: Integer = 45000;
File

nxllConst

Description

4.50.00

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45003 Constant

nxllConst.nxVersion45003 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45003: Integer = 45003;
File

nxllConst

Description

4.50.03

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45004 Constant

nxllConst.nxVersion45004 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45004: Integer = 45004;
File

nxllConst

Description

4.50.04

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45005 Constant

nxllConst.nxVersion45005 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45005: Integer = 45005;
File

nxllConst

Description

4.50.05

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45006 Constant

nxllConst.nxVersion45006 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45006: Integer = 45006;
File

nxllConst

Description

4.50.06

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45008 Constant

nxllConst.nxVersion45008 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45008: Integer = 45008;
File

nxllConst

Description

4.50.08

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45009 Constant

nxllConst.nxVersion45009 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45009: Integer = 45009;
File

nxllConst

Description

4.50.09

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45011 Constant

nxllConst.nxVersion45011 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45011: Integer = 45011;
File

nxllConst

Description

4.50.11

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45012 Constant

nxllConst.nxVersion45012 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45012: Integer = 45012;
File

nxllConst

Description

4.50.12

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45013 Constant

nxllConst.nxVersion45013 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45013: Integer = 45013;
File

nxllConst

Description

4.50.13

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45014 Constant

nxllConst.nxVersion45014 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45014: Integer = 45014;
File

nxllConst

Description

4.50.14

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45015 Constant

nxllConst.nxVersion45015 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45015: Integer = 45015;
File

nxllConst

Description

4.50.15

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45016 Constant

nxllConst.nxVersion45016 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45016: Integer = 45016;
File

nxllConst

Description

4.50.16

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45017 Constant

nxllConst.nxVersion45017 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45017: Integer = 45017;
File

nxllConst

Description

4.50.17

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45018 Constant

nxllConst.nxVersion45018 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45018: Integer = 45018;
File

nxllConst

Description

4.50.18

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45019 Constant

nxllConst.nxVersion45019 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45019: Integer = 45019;
File

nxllConst

Description

4.50.19

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45020 Constant

nxllConst.nxVersion45020 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45020: Integer = 45020;
File

nxllConst

Description

4.50.20

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45021 Constant

nxllConst.nxVersion45021 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45021: Integer = 45021;
File

nxllConst

Description

4.50.21

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45022 Constant

nxllConst.nxVersion45022 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45022: Integer = 45022;
File

nxllConst

Description

4.50.22

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45023 Constant

nxllConst.nxVersion45023 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45023: Integer = 45023;
File

nxllConst

Description

4.50.23

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45024 Constant

nxllConst.nxVersion45024 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45024: Integer = 45024;
File

nxllConst

Description

4.50.24

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45025 Constant

nxllConst.nxVersion45025 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45025: Integer = 45025;
File

nxllConst

Description

4.50.25

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45026 Constant

nxllConst.nxVersion45026 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45026: Integer = 45026;
File

nxllConst

Description

4.50.26

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersion45027 Constant

nxllConst.nxVersion45027 Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersion45027: Integer = 45027;
File

nxllConst

Description

4.50.27

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersionNumber Constant

nxllConst.nxVersionNumber Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersionNumber: Integer = 45027;
File

nxllConst

Description

4.50.27

Group

Constants

Links
nxllConst, Constants


nxllConst.nxVersionString Constant

nxllConst.nxVersionString Constant
nxllConst Constants Send Feedback
Syntax
Delphi
nxVersionString = '450';
File

nxllConst

Description

This is constant nxllConst.nxVersionString.

Group

Constants

Links
nxllConst, Constants


nxllConvertException Namespace

nxllConvertException Namespace
Functions Legend Topics Types Variables Send Feedback

This is namespace nxllConvertException.

Functions
Name | Description
ConvertException |
RegisterConverter |
UnRegisterConverter |
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxConvertExceptionFunction | This is type nxllConvertException.TnxConvertExceptionFunction.
Variables
Name | Description
Converters | This is variable nxllConvertException.Converters.
Links
Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxllConvertException Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ConvertException |
RegisterConverter |
UnRegisterConverter |
Namespace

nxllConvertException Namespace

Links
Functions, nxllConvertException Namespace, Legend


nxllConvertException.ConvertException Function

nxllConvertException.ConvertException Function
nxllConvertException Functions Send Feedback
Syntax
Delphi
function ConvertException(E: Exception; aLog: TnxBaseLog; aSource: TObject; aVersion: Integer): TnxResult;
File

nxllConvertException

Group

Functions

Links
nxllConvertException, Functions


nxllConvertException.RegisterConverter Function

nxllConvertException.RegisterConverter Function
nxllConvertException Functions Send Feedback
Syntax
Delphi
procedure RegisterConverter(aFunction: TnxConvertExceptionFunction);
File

nxllConvertException

Group

Functions

Links
nxllConvertException, Functions


nxllConvertException.UnRegisterConverter Function

nxllConvertException.UnRegisterConverter Function
nxllConvertException Functions Send Feedback
Syntax
Delphi
procedure UnRegisterConverter(aFunction: TnxConvertExceptionFunction);
File

nxllConvertException

Group

Functions

Links
nxllConvertException, Functions


Types

Types
nxllConvertException Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllConvertException Namespace

Types
Name | Description
TnxConvertExceptionFunction | This is type nxllConvertException.TnxConvertExceptionFunction.
Links
nxllConvertException Namespace, Types


nxllConvertException.TnxConvertExceptionFunction Type

nxllConvertException.TnxConvertExceptionFunction Type
nxllConvertException Types Send Feedback
Syntax
Delphi
TnxConvertExceptionFunction = function (aException : Exception; out aErrorCode : TnxResult; out aMsg : string) : Boolean;
File

nxllConvertException

Description

This is type nxllConvertException.TnxConvertExceptionFunction.

Group

Types

Links
nxllConvertException, Types


Variables

Variables
nxllConvertException Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllConvertException Namespace

Variables
Name | Description
Converters | This is variable nxllConvertException.Converters.
Links
nxllConvertException Namespace, Variables


nxllConvertException.Converters Variable

nxllConvertException.Converters Variable
nxllConvertException Variables Send Feedback
Syntax
Delphi
Converters: array of Pointer;
File

nxllConvertException

Description

This is variable nxllConvertException.Converters.

Group

Variables

Links
nxllConvertException, Variables


nxllDataMessageQueue Namespace

nxllDataMessageQueue Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllDataMessageQueue.

Classes
Name | Description
TnxDataMessageQueue | This is class nxllDataMessageQueue.TnxDataMessageQueue.
Constants
Name | Description
nxc_SubMsgHeaderSize | This is constant nxllDataMessageQueue.nxc_SubMsgHeaderSize.
nxnmMultiPartMessage | This is constant nxllDataMessageQueue.nxnmMultiPartMessage.
Functions
Name | Description
nxCreateSubMessage | CreateSubMessage
Structs, Records, Enums
Name | Description
TnxDataMessageNode | This is record nxllDataMessageQueue.TnxDataMessageNode.
TnxsmHeader | Sub-message header
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxDataMessageNode | This is type nxllDataMessageQueue.PnxDataMessageNode.
PnxsmHeader | This is type nxllDataMessageQueue.PnxsmHeader.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllDataMessageQueue Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxDataMessageQueue | This is class nxllDataMessageQueue.TnxDataMessageQueue.
Namespace

nxllDataMessageQueue Namespace

Links
Classes, nxllDataMessageQueue Namespace, Legend


TnxDataMessageQueue Class

TnxDataMessageQueue Class
TnxDataMessageQueue Fields TnxDataMessageQueue Methods TnxDataMessageQueue Members nxllDataMessageQueue Classes Send Feedback
Class Hierarchy
nxllDataMessageQueue_TnxDataMessageQueuenxllDataMessageQueue_TnxDataMessageQueue
Syntax
Delphi
TnxDataMessageQueue = class(TnxObject);
File

nxllDataMessageQueue

Description

This is class nxllDataMessageQueue.TnxDataMessageQueue.

Group

Classes

Links
TnxDataMessageQueue Fields, TnxDataMessageQueue Methods, TnxDataMessageQueue Members, nxllDataMessageQueue, Classes


TnxDataMessageQueue Members

TnxDataMessageQueue Members
TnxDataMessageQueue Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDataMessageQueue.

Class

TnxDataMessageQueue Class

Protected Fields
Name | Description
dmqHead | private
dmqTail | This is dmqTail, a member of class TnxDataMessageQueue.
Protected Methods
Name | Description
dmqPop |
dmqSplitMultiPartMessage |
Public Methods
Name | Description
Create | TnxDataMessageQueue
Destroy |
FreeInstance |
NewInstance | TnxObject
Pop |
Push |
Links
TnxDataMessageQueue Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDataMessageQueue.Create Constructor

TnxDataMessageQueue.Create Constructor
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxDataMessageQueue

Class

TnxDataMessageQueue Class

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Class


TnxDataMessageQueue.Destroy Destructor

TnxDataMessageQueue.Destroy Destructor
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxDataMessageQueue Class

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Class


TnxDataMessageQueue Fields

TnxDataMessageQueue Fields
TnxDataMessageQueue Class Legend Protected Fields Send Feedback

The fields of the TnxDataMessageQueue class are listed here.

Class

TnxDataMessageQueue Class

Protected Fields
Name | Description
dmqHead | private
dmqTail | This is dmqTail, a member of class TnxDataMessageQueue.
Links
TnxDataMessageQueue Class, Legend, Protected Fields


TnxDataMessageQueue.dmqHead Field

TnxDataMessageQueue.dmqHead Field
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Fields Send Feedback
Syntax
Delphi
dmqHead: PnxDataMessageNode;
Description

private

Group

TnxDataMessageQueue Fields

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Fields


TnxDataMessageQueue.dmqTail Field

TnxDataMessageQueue.dmqTail Field
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Fields Send Feedback
Syntax
Delphi
dmqTail: PnxDataMessageNode;
Description

This is dmqTail, a member of class TnxDataMessageQueue.

Group

TnxDataMessageQueue Fields

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Fields


TnxDataMessageQueue Methods

TnxDataMessageQueue Methods
TnxDataMessageQueue Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDataMessageQueue class are listed here.

Class

TnxDataMessageQueue Class

Protected Methods
Name | Description
dmqPop |
dmqSplitMultiPartMessage |
Public Methods
Name | Description
Pop |
Push |
Links
TnxDataMessageQueue Class, Legend, Protected Methods, Public Methods


TnxDataMessageQueue.dmqPop Method

TnxDataMessageQueue.dmqPop Method
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Methods Send Feedback
Syntax
Delphi
procedure dmqPop;
Group

TnxDataMessageQueue Methods

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Methods


TnxDataMessageQueue.dmqSplitMultiPartMessage Method

TnxDataMessageQueue.dmqSplitMultiPartMessage Method
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Methods Send Feedback
Syntax
Delphi
procedure dmqSplitMultiPartMessage;
Group

TnxDataMessageQueue Methods

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Methods


TnxDataMessageQueue.Pop Method

TnxDataMessageQueue.Pop Method
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Methods Send Feedback
Syntax
Delphi
function Pop: PnxDataMessage;
Group

TnxDataMessageQueue Methods

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Methods


TnxDataMessageQueue.Push Method

TnxDataMessageQueue.Push Method
TnxDataMessageQueue Class TnxDataMessageQueue Members nxllDataMessageQueue Namespace TnxDataMessageQueue Methods Send Feedback
Syntax
Delphi
procedure Push(aSource: TObject; aMsg: TnxMsgID; aSessionID: TnxSessionID; aTimeOut: TnxWord32; aError: TnxResult; aData: Pointer; aDataLen: TnxMemSize);
Group

TnxDataMessageQueue Methods

Links
TnxDataMessageQueue Class, TnxDataMessageQueue Members, nxllDataMessageQueue Namespace, TnxDataMessageQueue Methods


Functions

Functions
Functions nxllDataMessageQueue Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCreateSubMessage | CreateSubMessage
Namespace

nxllDataMessageQueue Namespace

Links
Functions, nxllDataMessageQueue Namespace, Legend


nxllDataMessageQueue.nxCreateSubMessage Function

nxllDataMessageQueue.nxCreateSubMessage Function
nxllDataMessageQueue Functions Send Feedback
Syntax
Delphi
function nxCreateSubMessage(aSubMsg: PnxsmHeader; aMsgID: TnxMsgID; aError: TnxResult; aData: Pointer; aDataLen: TnxMemSize): PnxsmHeader;
File

nxllDataMessageQueue

Description

CreateSubMessage

Group

Functions

Links
nxllDataMessageQueue, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllDataMessageQueue Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllDataMessageQueue Namespace

Records
Name | Description
TnxDataMessageNode | This is record nxllDataMessageQueue.TnxDataMessageNode.
TnxsmHeader | Sub-message header
Links
nxllDataMessageQueue Namespace, Legend, Records


nxllDataMessageQueue.TnxDataMessageNode Record

nxllDataMessageQueue.TnxDataMessageNode Record
nxllDataMessageQueue Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDataMessageNode = record
  dmnMsg: PnxDataMessage;
  dmnNext: PnxDataMessageNode;
  dmnPrev: PnxDataMessageNode;
end;
File

nxllDataMessageQueue

Description

This is record nxllDataMessageQueue.TnxDataMessageNode.

Group

Structs, Records, Enums

Links
nxllDataMessageQueue, Structs, Records, Enums


nxllDataMessageQueue.TnxsmHeader Record

nxllDataMessageQueue.TnxsmHeader Record
nxllDataMessageQueue Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxsmHeader = packed record
  smhMsgID: TnxMsgID;
  smhReplyLen: TnxWord32;
  smhErrorCode: TnxResult;
  smhData: Byte;
end;
File

nxllDataMessageQueue

Members
Members | Description
smhMsgID: TnxMsgID; | ..message identifier
smhReplyLen: TnxWord32; | ..size of this reply (header + data)
smhErrorCode: TnxResult; | ..BDE error code, or 0 for success
smhData: Byte; | ..data marker
Description

Sub-message header

Group

Structs, Records, Enums

Links
nxllDataMessageQueue, Structs, Records, Enums


Types

Types
nxllDataMessageQueue Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllDataMessageQueue Namespace

Types
Name | Description
PnxDataMessageNode | This is type nxllDataMessageQueue.PnxDataMessageNode.
PnxsmHeader | This is type nxllDataMessageQueue.PnxsmHeader.
Links
nxllDataMessageQueue Namespace, Types


nxllDataMessageQueue.PnxDataMessageNode Type

nxllDataMessageQueue.PnxDataMessageNode Type
nxllDataMessageQueue Types Send Feedback
Syntax
Delphi
PnxDataMessageNode = ^TnxDataMessageNode;
File

nxllDataMessageQueue

Description

This is type nxllDataMessageQueue.PnxDataMessageNode.

Group

Types

Links
nxllDataMessageQueue, Types


nxllDataMessageQueue.PnxsmHeader Type

nxllDataMessageQueue.PnxsmHeader Type
nxllDataMessageQueue Types Send Feedback
Syntax
Delphi
PnxsmHeader = ^TnxsmHeader;
File

nxllDataMessageQueue

Description

This is type nxllDataMessageQueue.PnxsmHeader.

Group

Types

Links
nxllDataMessageQueue, Types


Constants

Constants
Constants nxllDataMessageQueue Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_SubMsgHeaderSize | This is constant nxllDataMessageQueue.nxc_SubMsgHeaderSize.
nxnmMultiPartMessage | This is constant nxllDataMessageQueue.nxnmMultiPartMessage.
Namespace

nxllDataMessageQueue Namespace

Links
Constants, nxllDataMessageQueue Namespace


nxllDataMessageQueue.nxc_SubMsgHeaderSize Constant

nxllDataMessageQueue.nxc_SubMsgHeaderSize Constant
nxllDataMessageQueue Constants Send Feedback
Syntax
Delphi
nxc_SubMsgHeaderSize = SizeOf(TnxsmHeader) - SizeOf(Byte);
File

nxllDataMessageQueue

Description

This is constant nxllDataMessageQueue.nxc_SubMsgHeaderSize.

Group

Constants

Links
nxllDataMessageQueue, Constants


nxllDataMessageQueue.nxnmMultiPartMessage Constant

nxllDataMessageQueue.nxnmMultiPartMessage Constant
nxllDataMessageQueue Constants Send Feedback
Syntax
Delphi
nxnmMultiPartMessage = $00FF;
File

nxllDataMessageQueue

Description

This is constant nxllDataMessageQueue.nxnmMultiPartMessage.

Group

Constants

Links
nxllDataMessageQueue, Constants


nxllException Namespace

nxllException Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllException.

Classes
Name | Description
EnxBaseException | This is class nxllException.EnxBaseException.
TnxExceptionDataBaseValue | This is class nxllException.TnxExceptionDataBaseValue.
TnxExceptionDataBooleanValue | This is class nxllException.TnxExceptionDataBooleanValue.
TnxExceptionDataContainer | This is class nxllException.TnxExceptionDataContainer.
TnxExceptionDataFloatValue | This is class nxllException.TnxExceptionDataFloatValue.
TnxExceptionDataIntegerValue | This is class nxllException.TnxExceptionDataIntegerValue.
TnxExceptionDataStringValue | This is class nxllException.TnxExceptionDataStringValue.
TnxExceptionDataVariantValue | This is class nxllException.TnxExceptionDataVariantValue.
Constants
Name | Description
nxcNewCustomInfoMarkerEnd | This is constant nxllException.nxcNewCustomInfoMarkerEnd.
nxcNewCustomInfoMarkerStart | This is constant nxllException.nxcNewCustomInfoMarkerStart.
nxcNewOrgMessageMarker | This is constant nxllException.nxcNewOrgMessageMarker.
nxcOldCustomInfoMarkerEnd | This is constant nxllException.nxcOldCustomInfoMarkerEnd.
nxcOldCustomInfoMarkerStart | This is constant nxllException.nxcOldCustomInfoMarkerStart.
nxcOldOrgMessageMarker | This is constant nxllException.nxcOldOrgMessageMarker.
rsAsContainerNotSupported | This is constant nxllException.rsAsContainerNotSupported.
rsAsVariantNotSupported | This is constant nxllException.rsAsVariantNotSupported.
rsFatalError | This is constant nxllException.rsFatalError.
Functions
Name | Description
nxCheck | nxCheck
nxCheck |
nxcOrgMessageMarker |
nxCreateExceptionDataContainer | This is function nxllException.nxCreateExceptionDataContainer.
nxCreateOSError |
nxCreateOSError | nxCreateOSError
nxCreateOSError | This has to be done this way because the Header translator doesn't understand that it doesn't have to generate the default constructors, resulting in multiple declarations for the "same" function. As this is generated in the User section of the Header, outside the Namespace, I'm also including it.
nxCreateOSError |
nxDecodeExceptionDataValue | This is function nxllException.nxDecodeExceptionDataValue.
nxeCustomInfo | nxeCustomInfo
nxGetExceptionHookInfo | This is function nxllException.nxGetExceptionHookInfo.
nxSetExceptionHookInfo | This is function nxllException.nxSetExceptionHookInfo.
Interfaces
Name | Description
InxException | This is class nxllException.InxException.
InxExceptionDataContainerInternal | This is class nxllException.InxExceptionDataContainerInternal.
InxExceptionDataValueInternal | This is class nxllException.InxExceptionDataValueInternal.
Structs, Records, Enums
Name | Description
_PRIVATE_TAG | This is record nxllException._PRIVATE_TAG.
TnxExceptionHookInfo | This is record nxllException.TnxExceptionHookInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EnxExceptionClass | This is type nxllException.EnxExceptionClass.
PnxExceptionHookInfo | This is type nxllException.PnxExceptionHookInfo.
TnxExceptionDataBaseValueClass | This is type nxllException.TnxExceptionDataBaseValueClass.
TStringsAddMethod |
Variables
Name | Description
_ExceptionHookModeName | This is variable nxllException._ExceptionHookModeName.
_FatalException | This is variable nxllException._FatalException.
_HasExceptionHook | This is variable nxllException._HasExceptionHook.
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllException Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseException | This is class nxllException.EnxBaseException.
TnxExceptionDataBaseValue | This is class nxllException.TnxExceptionDataBaseValue.
TnxExceptionDataBooleanValue | This is class nxllException.TnxExceptionDataBooleanValue.
TnxExceptionDataContainer | This is class nxllException.TnxExceptionDataContainer.
TnxExceptionDataFloatValue | This is class nxllException.TnxExceptionDataFloatValue.
TnxExceptionDataIntegerValue | This is class nxllException.TnxExceptionDataIntegerValue.
TnxExceptionDataStringValue | This is class nxllException.TnxExceptionDataStringValue.
TnxExceptionDataVariantValue | This is class nxllException.TnxExceptionDataVariantValue.
Namespace

nxllException Namespace

Links
Classes, nxllException Namespace, Legend


EnxBaseException Class

EnxBaseException Class
EnxBaseException Fields EnxBaseException Methods EnxBaseException Properties EnxBaseException Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_EnxBaseExceptionnxllException_EnxBaseExceptionnxllException_EnxBaseException
Syntax
Delphi
EnxBaseException = class(Exception, InxInterface, InxBaseException, InxException);
File

nxllException

Description

This is class nxllException.EnxBaseException.

Group

Classes

Links
EnxBaseException Fields, EnxBaseException Methods, EnxBaseException Properties, EnxBaseException Members, nxllException, Classes


EnxBaseException Members

EnxBaseException Members
EnxBaseException Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by EnxBaseException.

Class

EnxBaseException Class

Protected Fields
Name | Description
beCustomInfos | This is beCustomInfos, a member of class EnxBaseException.
beErrorCode | private
beErrorString | This is beErrorString, a member of class EnxBaseException.
beExceptionData | This is beExceptionData, a member of class EnxBaseException.
beExtendedMsg | This is beExtendedMsg, a member of class EnxBaseException.
beOSError | This is beOSError, a member of class EnxBaseException.
beProcessedErrorString | This is beProcessedErrorString, a member of class EnxBaseException.
Protected Methods
Name | Description
_AddRef | EnxBaseException
_Release |
beMsgForErrorCode |
beProcessTemplate |
beStripCustomInfos |
GetCustomInfos |
GetErrorCode | InxException
GetErrorString |
GetExceptionData |
GetExtendedMsg |
GetOSError |
GetProcessedErrorString |
QueryInterface | InxInterface
Public Methods
Name | Description
Destroy |
GetLastConvertedException |
nxCreate | This is the overview for the nxCreate method overload.
nxSetMessage | This is the overview for the nxSetMessage method overload.
SetLastConvertedException |
Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class EnxBaseException.
ErrorCode | This is ErrorCode, a member of class EnxBaseException.
ErrorString | This is ErrorString, a member of class EnxBaseException.
ExceptionData | This is ExceptionData, a member of class InxException.
ExtendedMsg | This is ExtendedMsg, a member of class EnxBaseException.
OSError | This is OSError, a member of class EnxBaseException.
ProcessedErrorString | This is ProcessedErrorString, a member of class EnxBaseException.
Links
EnxBaseException Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


EnxBaseException.Destroy Destructor

EnxBaseException.Destroy Destructor
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

EnxBaseException Class

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Class


EnxBaseException Fields

EnxBaseException Fields
EnxBaseException Class Legend Protected Fields Send Feedback

The fields of the EnxBaseException class are listed here.

Class

EnxBaseException Class

Protected Fields
Name | Description
beCustomInfos | This is beCustomInfos, a member of class EnxBaseException.
beErrorCode | private
beErrorString | This is beErrorString, a member of class EnxBaseException.
beExceptionData | This is beExceptionData, a member of class EnxBaseException.
beExtendedMsg | This is beExtendedMsg, a member of class EnxBaseException.
beOSError | This is beOSError, a member of class EnxBaseException.
beProcessedErrorString | This is beProcessedErrorString, a member of class EnxBaseException.
Links
EnxBaseException Class, Legend, Protected Fields


EnxBaseException.beCustomInfos Field

EnxBaseException.beCustomInfos Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beCustomInfos: TStrings;
Description

This is beCustomInfos, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beErrorCode Field

EnxBaseException.beErrorCode Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beErrorCode: TnxResult;
Description

private

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beErrorString Field

EnxBaseException.beErrorString Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beErrorString: string;
Description

This is beErrorString, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beExceptionData Field

EnxBaseException.beExceptionData Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beExceptionData: InxExceptionDataContainer;
Description

This is beExceptionData, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beExtendedMsg Field

EnxBaseException.beExtendedMsg Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beExtendedMsg: Boolean;
Description

This is beExtendedMsg, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beOSError Field

EnxBaseException.beOSError Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beOSError: Cardinal;
Description

This is beOSError, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException.beProcessedErrorString Field

EnxBaseException.beProcessedErrorString Field
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Fields Send Feedback
Syntax
Delphi
beProcessedErrorString: string;
Description

This is beProcessedErrorString, a member of class EnxBaseException.

Group

EnxBaseException Fields

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Fields


EnxBaseException Methods

EnxBaseException Methods
EnxBaseException Class Legend Protected Methods Public Methods Send Feedback

The methods of the EnxBaseException class are listed here.

Class

EnxBaseException Class

Protected Methods
Name | Description
_AddRef | EnxBaseException
_Release |
beMsgForErrorCode |
beProcessTemplate |
beStripCustomInfos |
GetCustomInfos |
GetErrorCode | InxException
GetErrorString |
GetExceptionData |
GetExtendedMsg |
GetOSError |
GetProcessedErrorString |
QueryInterface | InxInterface
Public Methods
Name | Description
GetLastConvertedException |
nxCreate | This is the overview for the nxCreate method overload.
nxSetMessage | This is the overview for the nxSetMessage method overload.
SetLastConvertedException |
Links
EnxBaseException Class, Legend, Protected Methods, Public Methods


EnxBaseException._AddRef Method

EnxBaseException._AddRef Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Description

EnxBaseException

Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException._Release Method

EnxBaseException._Release Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.beMsgForErrorCode Method

EnxBaseException.beMsgForErrorCode Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
class function beMsgForErrorCode(aErrorCode: TnxResult): string; virtual;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.beProcessTemplate Method

EnxBaseException.beProcessTemplate Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function beProcessTemplate(const aMsg: string): string;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.beStripCustomInfos Method

EnxBaseException.beStripCustomInfos Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function beStripCustomInfos(const aMsg: string): string;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetCustomInfos Method

EnxBaseException.GetCustomInfos Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetCustomInfos: TStrings;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetErrorCode Method

EnxBaseException.GetErrorCode Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetErrorCode: TnxResult;
Description

InxException

Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetErrorString Method

EnxBaseException.GetErrorString Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetErrorString: string;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetExceptionData Method

EnxBaseException.GetExceptionData Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetExceptionData: InxExceptionDataContainer;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetExtendedMsg Method

EnxBaseException.GetExtendedMsg Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetExtendedMsg: Boolean;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetLastConvertedException Method

EnxBaseException.GetLastConvertedException Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
class procedure GetLastConvertedException(out aErrorCode: TnxResult; out aCustomMessage: string);
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetOSError Method

EnxBaseException.GetOSError Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetOSError: Cardinal;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.GetProcessedErrorString Method

EnxBaseException.GetProcessedErrorString Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function GetProcessedErrorString: string;
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


nxCreate Method

nxCreate Method
EnxBaseException Methods Send Feedback

This is the overview for the nxCreate method overload.

Overload List
Name | Description
EnxBaseException.nxCreate (PResStringRec) |
EnxBaseException.nxCreate (PResStringRec, array of const) |
EnxBaseException.nxCreate (string) |
EnxBaseException.nxCreate (string, array of const) |
EnxBaseException.nxCreate (TnxInt64) |
EnxBaseException.nxCreate (TnxInt64, PResStringRec) |
EnxBaseException.nxCreate (TnxInt64, PResStringRec, array of const) |
EnxBaseException.nxCreate (TnxInt64, string) |
EnxBaseException.nxCreate (TnxInt64, string, array of const) |
Group

EnxBaseException Methods

Links
EnxBaseException Methods


EnxBaseException.nxCreate Method (PResStringRec)

EnxBaseException.nxCreate Method (PResStringRec)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aMsgRes: PResStringRec): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (PResStringRec, array of const)

EnxBaseException.nxCreate Method (PResStringRec, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aMsgRes: PResStringRec; const aArgs: array of const): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (TnxInt64)

EnxBaseException.nxCreate Method (TnxInt64)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aErrorCode: TnxInt64): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (TnxInt64, PResStringRec)

EnxBaseException.nxCreate Method (TnxInt64, PResStringRec)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aErrorCode: TnxInt64; aAltMsgRes: PResStringRec): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (TnxInt64, PResStringRec, array of const)

EnxBaseException.nxCreate Method (TnxInt64, PResStringRec, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aErrorCode: TnxInt64; aAltMsgRes: PResStringRec; const aArgs: array of const): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (TnxInt64, string)

EnxBaseException.nxCreate Method (TnxInt64, string)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aErrorCode: TnxInt64; const aAltMsg: string): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (TnxInt64, string, array of const)

EnxBaseException.nxCreate Method (TnxInt64, string, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(aErrorCode: TnxInt64; const aAltMsg: string; const aArgs: array of const): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (string)

EnxBaseException.nxCreate Method (string)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(const aMsg: string): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


EnxBaseException.nxCreate Method (string, array of const)

EnxBaseException.nxCreate Method (string, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxCreate Method Send Feedback
Syntax
Delphi
class function nxCreate(const aMsg: string; const aArgs: array of const): EnxBaseException; overload;
Group

nxCreate Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxCreate Method


nxSetMessage Method

nxSetMessage Method
EnxBaseException Methods Send Feedback

This is the overview for the nxSetMessage method overload.

Overload List
Name | Description
EnxBaseException.nxSetMessage (TnxResult, PResStringRec) |
EnxBaseException.nxSetMessage (TnxResult, PResStringRec, array of const) |
EnxBaseException.nxSetMessage (TnxResult, string) |
EnxBaseException.nxSetMessage (TnxResult, string, array of const) |
Group

EnxBaseException Methods

Links
EnxBaseException Methods


EnxBaseException.nxSetMessage Method (TnxResult, PResStringRec)

EnxBaseException.nxSetMessage Method (TnxResult, PResStringRec)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxSetMessage Method Send Feedback
Syntax
Delphi
class function nxSetMessage(aErrorCode: TnxResult; aAltMsgRes: PResStringRec): TnxResult; overload;
Group

nxSetMessage Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxSetMessage Method


EnxBaseException.nxSetMessage Method (TnxResult, PResStringRec, array of const)

EnxBaseException.nxSetMessage Method (TnxResult, PResStringRec, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxSetMessage Method Send Feedback
Syntax
Delphi
class function nxSetMessage(aErrorCode: TnxResult; aAltMsgRes: PResStringRec; const aArgs: array of const): TnxResult; overload;
Group

nxSetMessage Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxSetMessage Method


EnxBaseException.nxSetMessage Method (TnxResult, string)

EnxBaseException.nxSetMessage Method (TnxResult, string)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxSetMessage Method Send Feedback
Syntax
Delphi
class function nxSetMessage(aErrorCode: TnxResult; const aAltMsg: string): TnxResult; overload;
Group

nxSetMessage Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxSetMessage Method


EnxBaseException.nxSetMessage Method (TnxResult, string, array of const)

EnxBaseException.nxSetMessage Method (TnxResult, string, array of const)
EnxBaseException Class EnxBaseException Members nxllException Namespace nxSetMessage Method Send Feedback
Syntax
Delphi
class function nxSetMessage(aErrorCode: TnxResult; const aAltMsg: string; const aArgs: array of const): TnxResult; overload;
Group

nxSetMessage Method

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, nxSetMessage Method


EnxBaseException.QueryInterface Method

EnxBaseException.QueryInterface Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException.SetLastConvertedException Method

EnxBaseException.SetLastConvertedException Method
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Methods Send Feedback
Syntax
Delphi
class procedure SetLastConvertedException(aErrorCode: TnxResult; const aCustomMessage: string);
Group

EnxBaseException Methods

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Methods


EnxBaseException Properties

EnxBaseException Properties
EnxBaseException Class Legend Public Properties Send Feedback

The properties of the EnxBaseException class are listed here.

Class

EnxBaseException Class

Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class EnxBaseException.
ErrorCode | This is ErrorCode, a member of class EnxBaseException.
ErrorString | This is ErrorString, a member of class EnxBaseException.
ExtendedMsg | This is ExtendedMsg, a member of class EnxBaseException.
OSError | This is OSError, a member of class EnxBaseException.
ProcessedErrorString | This is ProcessedErrorString, a member of class EnxBaseException.
Links
EnxBaseException Class, Legend, Public Properties


EnxBaseException.CustomInfos Property

EnxBaseException.CustomInfos Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property CustomInfos: TStrings;
Description

This is CustomInfos, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


EnxBaseException.ErrorCode Property

EnxBaseException.ErrorCode Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property ErrorCode: TnxResult;
Description

This is ErrorCode, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


EnxBaseException.ErrorString Property

EnxBaseException.ErrorString Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property ErrorString: string;
Description

This is ErrorString, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


EnxBaseException.ExtendedMsg Property

EnxBaseException.ExtendedMsg Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property ExtendedMsg: Boolean;
Description

This is ExtendedMsg, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


EnxBaseException.OSError Property

EnxBaseException.OSError Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property OSError: Cardinal;
Description

This is OSError, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


EnxBaseException.ProcessedErrorString Property

EnxBaseException.ProcessedErrorString Property
EnxBaseException Class EnxBaseException Members nxllException Namespace EnxBaseException Properties Send Feedback
Syntax
Delphi
property ProcessedErrorString: string;
Description

This is ProcessedErrorString, a member of class EnxBaseException.

Group

EnxBaseException Properties

Links
EnxBaseException Class, EnxBaseException Members, nxllException Namespace, EnxBaseException Properties


TnxExceptionDataBaseValue Class

TnxExceptionDataBaseValue Class
TnxExceptionDataBaseValue Fields TnxExceptionDataBaseValue Methods TnxExceptionDataBaseValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataBaseValuenxllException_TnxExceptionDataBaseValuenxllException_TnxExceptionDataBaseValue
Syntax
Delphi
TnxExceptionDataBaseValue = class(TnxInterfacedObject, InxExceptionDataValue, InxExceptionDataValueInternal);
File

nxllException

Description

This is class nxllException.TnxExceptionDataBaseValue.

Group

Classes

Links
TnxExceptionDataBaseValue Fields, TnxExceptionDataBaseValue Methods, TnxExceptionDataBaseValue Members, nxllException, Classes


TnxExceptionDataBaseValue Members

TnxExceptionDataBaseValue Members
TnxExceptionDataBaseValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataBaseValue.

Class

TnxExceptionDataBaseValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
Protected Methods
Name | Description
AddToStrings | This is AddToStrings, a member of class TnxExceptionDataBaseValue.
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | This is GetValueType, a member of class TnxExceptionDataBaseValue.
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataBaseValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataBaseValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
Create | This is Create, a member of class TnxExceptionDataBaseValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataBaseValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataBaseValue.Create Constructor

TnxExceptionDataBaseValue.Create Constructor
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataBaseValue.

Class

TnxExceptionDataBaseValue Class

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Class


TnxExceptionDataBaseValue.InternalCreateFromReader Constructor

TnxExceptionDataBaseValue.InternalCreateFromReader Constructor
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); virtual;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataBaseValue.

Class

TnxExceptionDataBaseValue Class

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Class


TnxExceptionDataBaseValue Fields

TnxExceptionDataBaseValue Fields
TnxExceptionDataBaseValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataBaseValue class are listed here.

Class

TnxExceptionDataBaseValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
Links
TnxExceptionDataBaseValue Class, Legend, Protected Fields


TnxExceptionDataBaseValue.beName Field

TnxExceptionDataBaseValue.beName Field
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Fields Send Feedback
Syntax
Delphi
beName: string;
Description

private

Group

TnxExceptionDataBaseValue Fields

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Fields


TnxExceptionDataBaseValue.beParent Field

TnxExceptionDataBaseValue.beParent Field
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Fields Send Feedback
Syntax
Delphi
beParent: TnxExceptionDataContainer;
Description

This is beParent, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Fields

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Fields


TnxExceptionDataBaseValue Methods

TnxExceptionDataBaseValue Methods
TnxExceptionDataBaseValue Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxExceptionDataBaseValue class are listed here.

Class

TnxExceptionDataBaseValue Class

Protected Methods
Name | Description
AddToStrings | This is AddToStrings, a member of class TnxExceptionDataBaseValue.
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | This is GetValueType, a member of class TnxExceptionDataBaseValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataBaseValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Links
TnxExceptionDataBaseValue Class, Legend, Protected Methods, Public Methods


TnxExceptionDataBaseValue.AddToStrings Method

TnxExceptionDataBaseValue.AddToStrings Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); virtual; abstract;
Description

This is AddToStrings, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsBoolean Method

TnxExceptionDataBaseValue.AsBoolean Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsBoolean: Boolean; virtual;
Description

TnxExceptionDataBaseValue

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsContainer Method

TnxExceptionDataBaseValue.AsContainer Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsContainer: InxExceptionDataContainer; virtual;
Description

This is AsContainer, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsFloat Method

TnxExceptionDataBaseValue.AsFloat Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsFloat: Double; virtual;
Description

This is AsFloat, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsInteger Method

TnxExceptionDataBaseValue.AsInteger Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsInteger: Int64; virtual;
Description

This is AsInteger, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsString Method

TnxExceptionDataBaseValue.AsString Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsString: string; virtual;
Description

This is AsString, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.AsVariant Method

TnxExceptionDataBaseValue.AsVariant Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; virtual;
Description

This is AsVariant, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.CreateFromReader Method

TnxExceptionDataBaseValue.CreateFromReader Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
class function CreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer): TnxExceptionDataBaseValue;
Description

This is CreateFromReader, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.Encode Method

TnxExceptionDataBaseValue.Encode Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function Encode(aVersion: Integer): string;
Description

aVersion for Encode must be Min(ServerVersion,ClientVersion)

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.GetName Method

TnxExceptionDataBaseValue.GetName Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function GetName: string;
Description

InxExceptionDataValue

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.GetParent Method

TnxExceptionDataBaseValue.GetParent Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function GetParent: TnxExceptionDataContainer;
Description

This is GetParent, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.GetValueType Method

TnxExceptionDataBaseValue.GetValueType Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; virtual; abstract;
Description

This is GetValueType, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.SaveToWriter Method

TnxExceptionDataBaseValue.SaveToWriter Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); virtual;
Description

This is SaveToWriter, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBaseValue.ToString Method

TnxExceptionDataBaseValue.ToString Method
TnxExceptionDataBaseValue Class TnxExceptionDataBaseValue Members nxllException Namespace TnxExceptionDataBaseValue Methods Send Feedback
Syntax
Delphi
function ToString: string; override;
Description

This is ToString, a member of class TnxExceptionDataBaseValue.

Group

TnxExceptionDataBaseValue Methods

Links
TnxExceptionDataBaseValue Class, TnxExceptionDataBaseValue Members, nxllException Namespace, TnxExceptionDataBaseValue Methods


TnxExceptionDataBooleanValue Class

TnxExceptionDataBooleanValue Class
TnxExceptionDataBooleanValue Fields TnxExceptionDataBooleanValue Methods TnxExceptionDataBooleanValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataBooleanValuenxllException_TnxExceptionDataBooleanValuenxllException_TnxExceptionDataBooleanValuenxllException_TnxExceptionDataBooleanValue
Syntax
Delphi
TnxExceptionDataBooleanValue = class(TnxExceptionDataBaseValue);
File

nxllException

Description

This is class nxllException.TnxExceptionDataBooleanValue.

Group

Classes

Links
TnxExceptionDataBooleanValue Fields, TnxExceptionDataBooleanValue Methods, TnxExceptionDataBooleanValue Members, nxllException, Classes


TnxExceptionDataBooleanValue Members

TnxExceptionDataBooleanValue Members
TnxExceptionDataBooleanValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataBooleanValue.

Class

TnxExceptionDataBooleanValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
bvValue | private
Protected Methods
Name | Description
AddToStrings | TnxExceptionDataBooleanValue
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataBooleanValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataBooleanValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataBooleanValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataBooleanValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataBooleanValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataBooleanValue.Create Constructor

TnxExceptionDataBooleanValue.Create Constructor
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; const aValue: Boolean; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataBooleanValue.

Class

TnxExceptionDataBooleanValue Class

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Class


TnxExceptionDataBooleanValue.InternalCreateFromReader Constructor

TnxExceptionDataBooleanValue.InternalCreateFromReader Constructor
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataBooleanValue.

Class

TnxExceptionDataBooleanValue Class

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Class


TnxExceptionDataBooleanValue Fields

TnxExceptionDataBooleanValue Fields
TnxExceptionDataBooleanValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataBooleanValue class are listed here.

Class

TnxExceptionDataBooleanValue Class

Protected Fields
Name | Description
bvValue | private
Links
TnxExceptionDataBooleanValue Class, Legend, Protected Fields


TnxExceptionDataBooleanValue.bvValue Field

TnxExceptionDataBooleanValue.bvValue Field
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Fields Send Feedback
Syntax
Delphi
bvValue: Boolean;
Description

private

Group

TnxExceptionDataBooleanValue Fields

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Fields


TnxExceptionDataBooleanValue Methods

TnxExceptionDataBooleanValue Methods
TnxExceptionDataBooleanValue Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataBooleanValue class are listed here.

Class

TnxExceptionDataBooleanValue Class

Protected Methods
Name | Description
AddToStrings | TnxExceptionDataBooleanValue
AsBoolean | TnxExceptionDataBaseValue
AsVariant | This is AsVariant, a member of class TnxExceptionDataBooleanValue.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataBooleanValue.
Links
TnxExceptionDataBooleanValue Class, Legend, Protected Methods


TnxExceptionDataBooleanValue.AddToStrings Method

TnxExceptionDataBooleanValue.AddToStrings Method
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

TnxExceptionDataBooleanValue

Group

TnxExceptionDataBooleanValue Methods

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Methods


TnxExceptionDataBooleanValue.AsBoolean Method

TnxExceptionDataBooleanValue.AsBoolean Method
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Methods Send Feedback
Syntax
Delphi
function AsBoolean: Boolean; override;
Description

TnxExceptionDataBaseValue

Group

TnxExceptionDataBooleanValue Methods

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Methods


TnxExceptionDataBooleanValue.AsVariant Method

TnxExceptionDataBooleanValue.AsVariant Method
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; override;
Description

This is AsVariant, a member of class TnxExceptionDataBooleanValue.

Group

TnxExceptionDataBooleanValue Methods

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Methods


TnxExceptionDataBooleanValue.GetValueType Method

TnxExceptionDataBooleanValue.GetValueType Method
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataBooleanValue Methods

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Methods


TnxExceptionDataBooleanValue.SaveToWriter Method

TnxExceptionDataBooleanValue.SaveToWriter Method
TnxExceptionDataBooleanValue Class TnxExceptionDataBooleanValue Members nxllException Namespace TnxExceptionDataBooleanValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataBooleanValue.

Group

TnxExceptionDataBooleanValue Methods

Links
TnxExceptionDataBooleanValue Class, TnxExceptionDataBooleanValue Members, nxllException Namespace, TnxExceptionDataBooleanValue Methods


TnxExceptionDataContainer Class

TnxExceptionDataContainer Class
TnxExceptionDataContainer Fields TnxExceptionDataContainer Methods TnxExceptionDataContainer Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataContainernxllException_TnxExceptionDataContainernxllException_TnxExceptionDataContainernxllException_TnxExceptionDataContainernxllException_TnxExceptionDataContainernxllException_TnxExceptionDataContainer
Syntax
Delphi
TnxExceptionDataContainer = class(TnxExceptionDataBaseValue, InxExceptionDataContainer, InxExceptionDataContainerInternal);
File

nxllException

Description

This is class nxllException.TnxExceptionDataContainer.

Group

Classes

Links
TnxExceptionDataContainer Fields, TnxExceptionDataContainer Methods, TnxExceptionDataContainer Members, nxllException, Classes


TnxExceptionDataContainer Members

TnxExceptionDataContainer Members
TnxExceptionDataContainer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataContainer.

Class

TnxExceptionDataContainer Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
dcExcludedObjects | This is dcExcludedObjects, a member of class TnxExceptionDataContainer.
dcForObject | This is dcForObject, a member of class TnxExceptionDataContainer.
dcValues | private
Protected Methods
Name | Description
AddContainer | TnxExceptionDataContainer
AddToStrings | This is AddToStrings, a member of class TnxExceptionDataContainer.
AddValue | This is the overview for the AddValue method overload.
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataContainer.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetForObject | This is GetForObject, a member of class TnxExceptionDataContainer.
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValue | This is GetValue, a member of class TnxExceptionDataContainer.
GetValueCount | This is GetValueCount, a member of class TnxExceptionDataContainer.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataContainer.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataContainer.
SetForObject | This is SetForObject, a member of class TnxExceptionDataContainer.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AddValue | This is the overview for the AddValue method overload.
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataBaseValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
ForObject | This is ForObject, a member of class InxExceptionDataContainerInternal.
Name | This is Name, a member of class InxExceptionDataValue.
ValueCount | This is ValueCount, a member of class InxExceptionDataContainer.
Values | This is Values, a member of class InxExceptionDataContainer.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataContainer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataContainer.InternalCreateFromReader Constructor

TnxExceptionDataContainer.InternalCreateFromReader Constructor
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataContainer.

Class

TnxExceptionDataContainer Class

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Class


TnxExceptionDataContainer Fields

TnxExceptionDataContainer Fields
TnxExceptionDataContainer Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataContainer class are listed here.

Class

TnxExceptionDataContainer Class

Protected Fields
Name | Description
dcExcludedObjects | This is dcExcludedObjects, a member of class TnxExceptionDataContainer.
dcForObject | This is dcForObject, a member of class TnxExceptionDataContainer.
dcValues | private
Links
TnxExceptionDataContainer Class, Legend, Protected Fields


TnxExceptionDataContainer.dcExcludedObjects Field

TnxExceptionDataContainer.dcExcludedObjects Field
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Fields Send Feedback
Syntax
Delphi
dcExcludedObjects: TnxDynObjectArray;
Description

This is dcExcludedObjects, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Fields

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Fields


TnxExceptionDataContainer.dcForObject Field

TnxExceptionDataContainer.dcForObject Field
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Fields Send Feedback
Syntax
Delphi
dcForObject: TObject;
Description

This is dcForObject, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Fields

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Fields


TnxExceptionDataContainer.dcValues Field

TnxExceptionDataContainer.dcValues Field
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Fields Send Feedback
Syntax
Delphi
dcValues: array of InxExceptionDataValueInternal;
Description

private

Group

TnxExceptionDataContainer Fields

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Fields


TnxExceptionDataContainer Methods

TnxExceptionDataContainer Methods
TnxExceptionDataContainer Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataContainer class are listed here.

Class

TnxExceptionDataContainer Class

Protected Methods
Name | Description
AddContainer | TnxExceptionDataContainer
AddToStrings | This is AddToStrings, a member of class TnxExceptionDataContainer.
AddValue | This is the overview for the AddValue method overload.
AsContainer | This is AsContainer, a member of class TnxExceptionDataContainer.
GetForObject | This is GetForObject, a member of class TnxExceptionDataContainer.
GetValue | This is GetValue, a member of class TnxExceptionDataContainer.
GetValueCount | This is GetValueCount, a member of class TnxExceptionDataContainer.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataContainer.
SetForObject | This is SetForObject, a member of class TnxExceptionDataContainer.
Links
TnxExceptionDataContainer Class, Legend, Protected Methods


TnxExceptionDataContainer.AddContainer Method

TnxExceptionDataContainer.AddContainer Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function AddContainer(const aName: string): InxExceptionDataContainer; overload;
Description

TnxExceptionDataContainer

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.AddToStrings Method

TnxExceptionDataContainer.AddToStrings Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

This is AddToStrings, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


AddValue Method

AddValue Method
TnxExceptionDataContainer Methods Send Feedback

This is the overview for the AddValue method overload.

Overload List
Name | Description
TnxExceptionDataContainer.AddValue (InxExceptionDataValueInternal) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, Boolean) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, Double) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, Int64) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, Pointer) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, string) | InxExceptionDataContainer
TnxExceptionDataContainer.AddValue (string, TObject, Boolean) | This is AddValue, a member of class TnxExceptionDataContainer.
TnxExceptionDataContainer.AddValue (string, Variant) | This is AddValue, a member of class TnxExceptionDataContainer.
Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Methods


TnxExceptionDataContainer.AddValue Method (InxExceptionDataValueInternal)

TnxExceptionDataContainer.AddValue Method (InxExceptionDataValueInternal)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aValue: InxExceptionDataValueInternal); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, Boolean)

TnxExceptionDataContainer.AddValue Method (string, Boolean)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Boolean); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, Double)

TnxExceptionDataContainer.AddValue Method (string, Double)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Double); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, Int64)

TnxExceptionDataContainer.AddValue Method (string, Int64)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Int64); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, Pointer)

TnxExceptionDataContainer.AddValue Method (string, Pointer)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Pointer); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, TObject, Boolean)

TnxExceptionDataContainer.AddValue Method (string, TObject, Boolean)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: TObject; aIncludeChildren: Boolean = False); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, Variant)

TnxExceptionDataContainer.AddValue Method (string, Variant)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Variant); overload;
Description

This is AddValue, a member of class TnxExceptionDataContainer.

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AddValue Method (string, string)

TnxExceptionDataContainer.AddValue Method (string, string)
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: string); overload;
Description

InxExceptionDataContainer

Group

AddValue Method

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, AddValue Method


TnxExceptionDataContainer.AsContainer Method

TnxExceptionDataContainer.AsContainer Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function AsContainer: InxExceptionDataContainer; override;
Description

This is AsContainer, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.GetForObject Method

TnxExceptionDataContainer.GetForObject Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetForObject: TObject;
Description

This is GetForObject, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.GetValue Method

TnxExceptionDataContainer.GetValue Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetValue(i: Integer): InxExceptionDataValue;
Description

This is GetValue, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.GetValueCount Method

TnxExceptionDataContainer.GetValueCount Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetValueCount: Integer;
Description

This is GetValueCount, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.GetValueType Method

TnxExceptionDataContainer.GetValueType Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.SaveToWriter Method

TnxExceptionDataContainer.SaveToWriter Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataContainer.SetForObject Method

TnxExceptionDataContainer.SetForObject Method
TnxExceptionDataContainer Class TnxExceptionDataContainer Members nxllException Namespace TnxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
procedure SetForObject(const aObject: TObject);
Description

This is SetForObject, a member of class TnxExceptionDataContainer.

Group

TnxExceptionDataContainer Methods

Links
TnxExceptionDataContainer Class, TnxExceptionDataContainer Members, nxllException Namespace, TnxExceptionDataContainer Methods


TnxExceptionDataFloatValue Class

TnxExceptionDataFloatValue Class
TnxExceptionDataFloatValue Fields TnxExceptionDataFloatValue Methods TnxExceptionDataFloatValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataFloatValuenxllException_TnxExceptionDataFloatValuenxllException_TnxExceptionDataFloatValuenxllException_TnxExceptionDataFloatValue
Syntax
Delphi
TnxExceptionDataFloatValue = class(TnxExceptionDataBaseValue);
File

nxllException

Description

This is class nxllException.TnxExceptionDataFloatValue.

Group

Classes

Links
TnxExceptionDataFloatValue Fields, TnxExceptionDataFloatValue Methods, TnxExceptionDataFloatValue Members, nxllException, Classes


TnxExceptionDataFloatValue Members

TnxExceptionDataFloatValue Members
TnxExceptionDataFloatValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataFloatValue.

Class

TnxExceptionDataFloatValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
fvValue | private
Protected Methods
Name | Description
AddToStrings | TnxExceptionDataFloatValue
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataFloatValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataFloatValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataFloatValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataFloatValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataFloatValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataFloatValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataFloatValue.Create Constructor

TnxExceptionDataFloatValue.Create Constructor
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; const aValue: Double; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataFloatValue.

Class

TnxExceptionDataFloatValue Class

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Class


TnxExceptionDataFloatValue.InternalCreateFromReader Constructor

TnxExceptionDataFloatValue.InternalCreateFromReader Constructor
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataFloatValue.

Class

TnxExceptionDataFloatValue Class

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Class


TnxExceptionDataFloatValue Fields

TnxExceptionDataFloatValue Fields
TnxExceptionDataFloatValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataFloatValue class are listed here.

Class

TnxExceptionDataFloatValue Class

Protected Fields
Name | Description
fvValue | private
Links
TnxExceptionDataFloatValue Class, Legend, Protected Fields


TnxExceptionDataFloatValue.fvValue Field

TnxExceptionDataFloatValue.fvValue Field
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Fields Send Feedback
Syntax
Delphi
fvValue: Double;
Description

private

Group

TnxExceptionDataFloatValue Fields

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Fields


TnxExceptionDataFloatValue Methods

TnxExceptionDataFloatValue Methods
TnxExceptionDataFloatValue Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataFloatValue class are listed here.

Class

TnxExceptionDataFloatValue Class

Protected Methods
Name | Description
AddToStrings | TnxExceptionDataFloatValue
AsFloat | This is AsFloat, a member of class TnxExceptionDataFloatValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataFloatValue.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataFloatValue.
Links
TnxExceptionDataFloatValue Class, Legend, Protected Methods


TnxExceptionDataFloatValue.AddToStrings Method

TnxExceptionDataFloatValue.AddToStrings Method
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

TnxExceptionDataFloatValue

Group

TnxExceptionDataFloatValue Methods

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Methods


TnxExceptionDataFloatValue.AsFloat Method

TnxExceptionDataFloatValue.AsFloat Method
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Methods Send Feedback
Syntax
Delphi
function AsFloat: Double; override;
Description

This is AsFloat, a member of class TnxExceptionDataFloatValue.

Group

TnxExceptionDataFloatValue Methods

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Methods


TnxExceptionDataFloatValue.AsVariant Method

TnxExceptionDataFloatValue.AsVariant Method
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; override;
Description

This is AsVariant, a member of class TnxExceptionDataFloatValue.

Group

TnxExceptionDataFloatValue Methods

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Methods


TnxExceptionDataFloatValue.GetValueType Method

TnxExceptionDataFloatValue.GetValueType Method
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataFloatValue Methods

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Methods


TnxExceptionDataFloatValue.SaveToWriter Method

TnxExceptionDataFloatValue.SaveToWriter Method
TnxExceptionDataFloatValue Class TnxExceptionDataFloatValue Members nxllException Namespace TnxExceptionDataFloatValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataFloatValue.

Group

TnxExceptionDataFloatValue Methods

Links
TnxExceptionDataFloatValue Class, TnxExceptionDataFloatValue Members, nxllException Namespace, TnxExceptionDataFloatValue Methods


TnxExceptionDataIntegerValue Class

TnxExceptionDataIntegerValue Class
TnxExceptionDataIntegerValue Fields TnxExceptionDataIntegerValue Methods TnxExceptionDataIntegerValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataIntegerValuenxllException_TnxExceptionDataIntegerValuenxllException_TnxExceptionDataIntegerValuenxllException_TnxExceptionDataIntegerValue
Syntax
Delphi
TnxExceptionDataIntegerValue = class(TnxExceptionDataBaseValue);
File

nxllException

Description

This is class nxllException.TnxExceptionDataIntegerValue.

Group

Classes

Links
TnxExceptionDataIntegerValue Fields, TnxExceptionDataIntegerValue Methods, TnxExceptionDataIntegerValue Members, nxllException, Classes


TnxExceptionDataIntegerValue Members

TnxExceptionDataIntegerValue Members
TnxExceptionDataIntegerValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataIntegerValue.

Class

TnxExceptionDataIntegerValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
ivValue | private
Protected Methods
Name | Description
AddToStrings | TnxExceptionDataIntegerValue
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataIntegerValue.
AsString | This is AsString, a member of class TnxExceptionDataIntegerValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataIntegerValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataIntegerValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataIntegerValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataIntegerValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataIntegerValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataIntegerValue.Create Constructor

TnxExceptionDataIntegerValue.Create Constructor
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; const aValue: Int64; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataIntegerValue.

Class

TnxExceptionDataIntegerValue Class

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Class


TnxExceptionDataIntegerValue.InternalCreateFromReader Constructor

TnxExceptionDataIntegerValue.InternalCreateFromReader Constructor
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataIntegerValue.

Class

TnxExceptionDataIntegerValue Class

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Class


TnxExceptionDataIntegerValue Fields

TnxExceptionDataIntegerValue Fields
TnxExceptionDataIntegerValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataIntegerValue class are listed here.

Class

TnxExceptionDataIntegerValue Class

Protected Fields
Name | Description
ivValue | private
Links
TnxExceptionDataIntegerValue Class, Legend, Protected Fields


TnxExceptionDataIntegerValue.ivValue Field

TnxExceptionDataIntegerValue.ivValue Field
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Fields Send Feedback
Syntax
Delphi
ivValue: Int64;
Description

private

Group

TnxExceptionDataIntegerValue Fields

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Fields


TnxExceptionDataIntegerValue Methods

TnxExceptionDataIntegerValue Methods
TnxExceptionDataIntegerValue Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataIntegerValue class are listed here.

Class

TnxExceptionDataIntegerValue Class

Protected Methods
Name | Description
AddToStrings | TnxExceptionDataIntegerValue
AsInteger | This is AsInteger, a member of class TnxExceptionDataIntegerValue.
AsString | This is AsString, a member of class TnxExceptionDataIntegerValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataIntegerValue.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataIntegerValue.
Links
TnxExceptionDataIntegerValue Class, Legend, Protected Methods


TnxExceptionDataIntegerValue.AddToStrings Method

TnxExceptionDataIntegerValue.AddToStrings Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

TnxExceptionDataIntegerValue

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataIntegerValue.AsInteger Method

TnxExceptionDataIntegerValue.AsInteger Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
function AsInteger: Int64; override;
Description

This is AsInteger, a member of class TnxExceptionDataIntegerValue.

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataIntegerValue.AsString Method

TnxExceptionDataIntegerValue.AsString Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
function AsString: String; override;
Description

This is AsString, a member of class TnxExceptionDataIntegerValue.

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataIntegerValue.AsVariant Method

TnxExceptionDataIntegerValue.AsVariant Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; override;
Description

This is AsVariant, a member of class TnxExceptionDataIntegerValue.

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataIntegerValue.GetValueType Method

TnxExceptionDataIntegerValue.GetValueType Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataIntegerValue.SaveToWriter Method

TnxExceptionDataIntegerValue.SaveToWriter Method
TnxExceptionDataIntegerValue Class TnxExceptionDataIntegerValue Members nxllException Namespace TnxExceptionDataIntegerValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataIntegerValue.

Group

TnxExceptionDataIntegerValue Methods

Links
TnxExceptionDataIntegerValue Class, TnxExceptionDataIntegerValue Members, nxllException Namespace, TnxExceptionDataIntegerValue Methods


TnxExceptionDataStringValue Class

TnxExceptionDataStringValue Class
TnxExceptionDataStringValue Fields TnxExceptionDataStringValue Methods TnxExceptionDataStringValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataStringValuenxllException_TnxExceptionDataStringValuenxllException_TnxExceptionDataStringValuenxllException_TnxExceptionDataStringValue
Syntax
Delphi
TnxExceptionDataStringValue = class(TnxExceptionDataBaseValue);
File

nxllException

Description

This is class nxllException.TnxExceptionDataStringValue.

Group

Classes

Links
TnxExceptionDataStringValue Fields, TnxExceptionDataStringValue Methods, TnxExceptionDataStringValue Members, nxllException, Classes


TnxExceptionDataStringValue Members

TnxExceptionDataStringValue Members
TnxExceptionDataStringValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataStringValue.

Class

TnxExceptionDataStringValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
svValue | private
Protected Methods
Name | Description
AddToStrings | TnxExceptionDataStringValue
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataStringValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataStringValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataStringValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataStringValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataStringValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataStringValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataStringValue.Create Constructor

TnxExceptionDataStringValue.Create Constructor
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; const aValue: String; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataStringValue.

Class

TnxExceptionDataStringValue Class

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Class


TnxExceptionDataStringValue.InternalCreateFromReader Constructor

TnxExceptionDataStringValue.InternalCreateFromReader Constructor
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataStringValue.

Class

TnxExceptionDataStringValue Class

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Class


TnxExceptionDataStringValue Fields

TnxExceptionDataStringValue Fields
TnxExceptionDataStringValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataStringValue class are listed here.

Class

TnxExceptionDataStringValue Class

Protected Fields
Name | Description
svValue | private
Links
TnxExceptionDataStringValue Class, Legend, Protected Fields


TnxExceptionDataStringValue.svValue Field

TnxExceptionDataStringValue.svValue Field
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Fields Send Feedback
Syntax
Delphi
svValue: String;
Description

private

Group

TnxExceptionDataStringValue Fields

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Fields


TnxExceptionDataStringValue Methods

TnxExceptionDataStringValue Methods
TnxExceptionDataStringValue Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataStringValue class are listed here.

Class

TnxExceptionDataStringValue Class

Protected Methods
Name | Description
AddToStrings | TnxExceptionDataStringValue
AsString | This is AsString, a member of class TnxExceptionDataStringValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataStringValue.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataStringValue.
Links
TnxExceptionDataStringValue Class, Legend, Protected Methods


TnxExceptionDataStringValue.AddToStrings Method

TnxExceptionDataStringValue.AddToStrings Method
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

TnxExceptionDataStringValue

Group

TnxExceptionDataStringValue Methods

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Methods


TnxExceptionDataStringValue.AsString Method

TnxExceptionDataStringValue.AsString Method
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Methods Send Feedback
Syntax
Delphi
function AsString: String; override;
Description

This is AsString, a member of class TnxExceptionDataStringValue.

Group

TnxExceptionDataStringValue Methods

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Methods


TnxExceptionDataStringValue.AsVariant Method

TnxExceptionDataStringValue.AsVariant Method
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; override;
Description

This is AsVariant, a member of class TnxExceptionDataStringValue.

Group

TnxExceptionDataStringValue Methods

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Methods


TnxExceptionDataStringValue.GetValueType Method

TnxExceptionDataStringValue.GetValueType Method
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataStringValue Methods

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Methods


TnxExceptionDataStringValue.SaveToWriter Method

TnxExceptionDataStringValue.SaveToWriter Method
TnxExceptionDataStringValue Class TnxExceptionDataStringValue Members nxllException Namespace TnxExceptionDataStringValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataStringValue.

Group

TnxExceptionDataStringValue Methods

Links
TnxExceptionDataStringValue Class, TnxExceptionDataStringValue Members, nxllException Namespace, TnxExceptionDataStringValue Methods


TnxExceptionDataVariantValue Class

TnxExceptionDataVariantValue Class
TnxExceptionDataVariantValue Fields TnxExceptionDataVariantValue Methods TnxExceptionDataVariantValue Members nxllException Classes Send Feedback
Class Hierarchy
nxllException_TnxExceptionDataVariantValuenxllException_TnxExceptionDataVariantValuenxllException_TnxExceptionDataVariantValuenxllException_TnxExceptionDataVariantValue
Syntax
Delphi
TnxExceptionDataVariantValue = class(TnxExceptionDataBaseValue);
File

nxllException

Description

This is class nxllException.TnxExceptionDataVariantValue.

Group

Classes

Links
TnxExceptionDataVariantValue Fields, TnxExceptionDataVariantValue Methods, TnxExceptionDataVariantValue Members, nxllException, Classes


TnxExceptionDataVariantValue Members

TnxExceptionDataVariantValue Members
TnxExceptionDataVariantValue Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExceptionDataVariantValue.

Class

TnxExceptionDataVariantValue Class

Protected Fields
Name | Description
beName | private
beParent | This is beParent, a member of class TnxExceptionDataBaseValue.
vvValue | private
Protected Methods
Name | Description
AddToStrings | TnxExceptionDataVariantValue
AsBoolean | TnxExceptionDataBaseValue
AsContainer | This is AsContainer, a member of class TnxExceptionDataBaseValue.
AsFloat | This is AsFloat, a member of class TnxExceptionDataBaseValue.
AsInteger | This is AsInteger, a member of class TnxExceptionDataBaseValue.
AsString | This is AsString, a member of class TnxExceptionDataBaseValue.
AsVariant | This is AsVariant, a member of class TnxExceptionDataVariantValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | InxExceptionDataValue
GetParent | This is GetParent, a member of class TnxExceptionDataBaseValue.
GetValueType | InxExceptionDataValue
InternalCreateFromReader | This is InternalCreateFromReader, a member of class TnxExceptionDataVariantValue.
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataVariantValue.
ToString | This is ToString, a member of class TnxExceptionDataBaseValue.
Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
Create | This is Create, a member of class TnxExceptionDataVariantValue.
CreateFromReader | This is CreateFromReader, a member of class TnxExceptionDataBaseValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
TnxExceptionDataVariantValue Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExceptionDataVariantValue.Create Constructor

TnxExceptionDataVariantValue.Create Constructor
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Class Send Feedback
Syntax
Delphi
constructor Create(const aName: string; const aValue: Variant; aParent: TnxExceptionDataContainer);
Description

This is Create, a member of class TnxExceptionDataVariantValue.

Class

TnxExceptionDataVariantValue Class

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Class


TnxExceptionDataVariantValue.InternalCreateFromReader Constructor

TnxExceptionDataVariantValue.InternalCreateFromReader Constructor
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromReader(aReader: TnxReader; aVersion: Integer; aParent: TnxExceptionDataContainer); override;
Description

This is InternalCreateFromReader, a member of class TnxExceptionDataVariantValue.

Class

TnxExceptionDataVariantValue Class

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Class


TnxExceptionDataVariantValue Fields

TnxExceptionDataVariantValue Fields
TnxExceptionDataVariantValue Class Legend Protected Fields Send Feedback

The fields of the TnxExceptionDataVariantValue class are listed here.

Class

TnxExceptionDataVariantValue Class

Protected Fields
Name | Description
vvValue | private
Links
TnxExceptionDataVariantValue Class, Legend, Protected Fields


TnxExceptionDataVariantValue.vvValue Field

TnxExceptionDataVariantValue.vvValue Field
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Fields Send Feedback
Syntax
Delphi
vvValue: Variant;
Description

private

Group

TnxExceptionDataVariantValue Fields

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Fields


TnxExceptionDataVariantValue Methods

TnxExceptionDataVariantValue Methods
TnxExceptionDataVariantValue Class Legend Protected Methods Send Feedback

The methods of the TnxExceptionDataVariantValue class are listed here.

Class

TnxExceptionDataVariantValue Class

Protected Methods
Name | Description
AddToStrings | TnxExceptionDataVariantValue
AsVariant | This is AsVariant, a member of class TnxExceptionDataVariantValue.
GetValueType | InxExceptionDataValue
SaveToWriter | This is SaveToWriter, a member of class TnxExceptionDataVariantValue.
Links
TnxExceptionDataVariantValue Class, Legend, Protected Methods


TnxExceptionDataVariantValue.AddToStrings Method

TnxExceptionDataVariantValue.AddToStrings Method
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer); override;
Description

TnxExceptionDataVariantValue

Group

TnxExceptionDataVariantValue Methods

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Methods


TnxExceptionDataVariantValue.AsVariant Method

TnxExceptionDataVariantValue.AsVariant Method
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant; override;
Description

This is AsVariant, a member of class TnxExceptionDataVariantValue.

Group

TnxExceptionDataVariantValue Methods

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Methods


TnxExceptionDataVariantValue.GetValueType Method

TnxExceptionDataVariantValue.GetValueType Method
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType; override;
Description

InxExceptionDataValue

Group

TnxExceptionDataVariantValue Methods

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Methods


TnxExceptionDataVariantValue.SaveToWriter Method

TnxExceptionDataVariantValue.SaveToWriter Method
TnxExceptionDataVariantValue Class TnxExceptionDataVariantValue Members nxllException Namespace TnxExceptionDataVariantValue Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer); override;
Description

This is SaveToWriter, a member of class TnxExceptionDataVariantValue.

Group

TnxExceptionDataVariantValue Methods

Links
TnxExceptionDataVariantValue Class, TnxExceptionDataVariantValue Members, nxllException Namespace, TnxExceptionDataVariantValue Methods


Interfaces

Interfaces
nxllException Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllException Namespace

Interfaces
Name | Description
InxException | This is class nxllException.InxException.
InxExceptionDataContainerInternal | This is class nxllException.InxExceptionDataContainerInternal.
InxExceptionDataValueInternal | This is class nxllException.InxExceptionDataValueInternal.
Links
nxllException Namespace, Interfaces, Legend


InxException Interface

InxException Interface
InxException Methods InxException Properties InxException Members nxllException Interfaces Send Feedback
Class Hierarchy
nxllException_InxExceptionnxllException_InxException
Syntax
Delphi
InxException = interface(InxBaseException);
File

nxllException

Description

This is class nxllException.InxException.

Group

Interfaces

Links
InxException Methods, InxException Properties, InxException Members, nxllException, Interfaces


InxException Members

InxException Members
InxException Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxException.

Interface

InxException Interface

Public Methods
Name | Description
GetCustomInfos | This is GetCustomInfos, a member of class InxException.
GetErrorCode | This is GetErrorCode, a member of class InxBaseException.
GetErrorString | This is GetErrorString, a member of class InxException.
GetExceptionData | This is GetExceptionData, a member of class InxException.
GetExtendedMsg | This is GetExtendedMsg, a member of class InxException.
GetOSError | This is GetOSError, a member of class InxException.
GetProcessedErrorString | This is GetProcessedErrorString, a member of class InxException.
Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class InxException.
ErrorCode | This is ErrorCode, a member of class InxBaseException.
ErrorString | This is ErrorString, a member of class InxException.
ExceptionData | This is ExceptionData, a member of class InxException.
ExtendedMsg | This is ExtendedMsg, a member of class InxException.
OSError | This is OSError, a member of class InxException.
ProcessedErrorString | This is ProcessedErrorString, a member of class InxException.
Links
InxException Interface, Legend, Public Methods, Public Properties


InxException Methods

InxException Methods
InxException Interface Legend Public Methods Send Feedback

The methods of the InxException class are listed here.

Interface

InxException Interface

Public Methods
Name | Description
GetCustomInfos | This is GetCustomInfos, a member of class InxException.
GetErrorString | This is GetErrorString, a member of class InxException.
GetExceptionData | This is GetExceptionData, a member of class InxException.
GetExtendedMsg | This is GetExtendedMsg, a member of class InxException.
GetOSError | This is GetOSError, a member of class InxException.
GetProcessedErrorString | This is GetProcessedErrorString, a member of class InxException.
Links
InxException Interface, Legend, Public Methods


InxException.GetCustomInfos Method

InxException.GetCustomInfos Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetCustomInfos: TStrings;
Description

This is GetCustomInfos, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException.GetErrorString Method

InxException.GetErrorString Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetErrorString: string;
Description

This is GetErrorString, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException.GetExceptionData Method

InxException.GetExceptionData Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetExceptionData: InxExceptionDataContainer;
Description

This is GetExceptionData, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException.GetExtendedMsg Method

InxException.GetExtendedMsg Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetExtendedMsg: Boolean;
Description

This is GetExtendedMsg, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException.GetOSError Method

InxException.GetOSError Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetOSError: Cardinal;
Description

This is GetOSError, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException.GetProcessedErrorString Method

InxException.GetProcessedErrorString Method
InxException Interface InxException Members nxllException Namespace InxException Methods Send Feedback
Syntax
Delphi
function GetProcessedErrorString: string;
Description

This is GetProcessedErrorString, a member of class InxException.

Group

InxException Methods

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Methods


InxException Properties

InxException Properties
InxException Interface Legend Public Properties Send Feedback

The properties of the InxException class are listed here.

Interface

InxException Interface

Public Properties
Name | Description
CustomInfos | This is CustomInfos, a member of class InxException.
ErrorString | This is ErrorString, a member of class InxException.
ExceptionData | This is ExceptionData, a member of class InxException.
ExtendedMsg | This is ExtendedMsg, a member of class InxException.
OSError | This is OSError, a member of class InxException.
ProcessedErrorString | This is ProcessedErrorString, a member of class InxException.
Links
InxException Interface, Legend, Public Properties


InxException.CustomInfos Property

InxException.CustomInfos Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property CustomInfos: TStrings;
Description

This is CustomInfos, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxException.ErrorString Property

InxException.ErrorString Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property ErrorString: string;
Description

This is ErrorString, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxException.ExceptionData Property

InxException.ExceptionData Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property ExceptionData: InxExceptionDataContainer;
Description

This is ExceptionData, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxException.ExtendedMsg Property

InxException.ExtendedMsg Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property ExtendedMsg: Boolean;
Description

This is ExtendedMsg, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxException.OSError Property

InxException.OSError Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property OSError: Cardinal;
Description

This is OSError, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxException.ProcessedErrorString Property

InxException.ProcessedErrorString Property
InxException Interface InxException Members nxllException Namespace InxException Properties Send Feedback
Syntax
Delphi
property ProcessedErrorString: string;
Description

This is ProcessedErrorString, a member of class InxException.

Group

InxException Properties

Links
InxException Interface, InxException Members, nxllException Namespace, InxException Properties


InxExceptionDataContainerInternal Interface

InxExceptionDataContainerInternal Interface
InxExceptionDataContainerInternal Methods InxExceptionDataContainerInternal Properties InxExceptionDataContainerInternal Members nxllException Interfaces Send Feedback
Class Hierarchy
nxllException_InxExceptionDataContainerInternalnxllException_InxExceptionDataContainerInternalnxllException_InxExceptionDataContainerInternal
Syntax
Delphi
InxExceptionDataContainerInternal = interface(InxExceptionDataContainer);
File

nxllException

Description

This is class nxllException.InxExceptionDataContainerInternal.

Group

Interfaces

Links
InxExceptionDataContainerInternal Methods, InxExceptionDataContainerInternal Properties, InxExceptionDataContainerInternal Members, nxllException, Interfaces


InxExceptionDataContainerInternal Members

InxExceptionDataContainerInternal Members
InxExceptionDataContainerInternal Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxExceptionDataContainerInternal.

Interface

InxExceptionDataContainerInternal Interface

Public Methods
Name | Description
AddContainer | This is AddContainer, a member of class InxExceptionDataContainer.
AddValue | This is the overview for the AddValue method overload.
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetForObject | This is GetForObject, a member of class InxExceptionDataContainerInternal.
GetName | This is GetName, a member of class InxExceptionDataValue.
GetValue | This is GetValue, a member of class InxExceptionDataContainer.
GetValueCount | This is GetValueCount, a member of class InxExceptionDataContainer.
GetValueType | This is GetValueType, a member of class InxExceptionDataValue.
SetForObject | This is SetForObject, a member of class InxExceptionDataContainerInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
ForObject | This is ForObject, a member of class InxExceptionDataContainerInternal.
Name | This is Name, a member of class InxExceptionDataValue.
ValueCount | This is ValueCount, a member of class InxExceptionDataContainer.
Values | This is Values, a member of class InxExceptionDataContainer.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
InxExceptionDataContainerInternal Interface, Legend, Public Methods, Public Properties


InxExceptionDataContainerInternal Methods

InxExceptionDataContainerInternal Methods
InxExceptionDataContainerInternal Interface Legend Public Methods Send Feedback

The methods of the InxExceptionDataContainerInternal class are listed here.

Interface

InxExceptionDataContainerInternal Interface

Public Methods
Name | Description
GetForObject | This is GetForObject, a member of class InxExceptionDataContainerInternal.
SetForObject | This is SetForObject, a member of class InxExceptionDataContainerInternal.
Links
InxExceptionDataContainerInternal Interface, Legend, Public Methods


InxExceptionDataContainerInternal.GetForObject Method

InxExceptionDataContainerInternal.GetForObject Method
InxExceptionDataContainerInternal Interface InxExceptionDataContainerInternal Members nxllException Namespace InxExceptionDataContainerInternal Methods Send Feedback
Syntax
Delphi
function GetForObject: TObject;
Description

This is GetForObject, a member of class InxExceptionDataContainerInternal.

Group

InxExceptionDataContainerInternal Methods

Links
InxExceptionDataContainerInternal Interface, InxExceptionDataContainerInternal Members, nxllException Namespace, InxExceptionDataContainerInternal Methods


InxExceptionDataContainerInternal.SetForObject Method

InxExceptionDataContainerInternal.SetForObject Method
InxExceptionDataContainerInternal Interface InxExceptionDataContainerInternal Members nxllException Namespace InxExceptionDataContainerInternal Methods Send Feedback
Syntax
Delphi
procedure SetForObject(const aObject: TObject);
Description

This is SetForObject, a member of class InxExceptionDataContainerInternal.

Group

InxExceptionDataContainerInternal Methods

Links
InxExceptionDataContainerInternal Interface, InxExceptionDataContainerInternal Members, nxllException Namespace, InxExceptionDataContainerInternal Methods


InxExceptionDataContainerInternal Properties

InxExceptionDataContainerInternal Properties
InxExceptionDataContainerInternal Interface Legend Public Properties Send Feedback

The properties of the InxExceptionDataContainerInternal class are listed here.

Interface

InxExceptionDataContainerInternal Interface

Public Properties
Name | Description
ForObject | This is ForObject, a member of class InxExceptionDataContainerInternal.
Links
InxExceptionDataContainerInternal Interface, Legend, Public Properties


InxExceptionDataContainerInternal.ForObject Property

InxExceptionDataContainerInternal.ForObject Property
InxExceptionDataContainerInternal Interface InxExceptionDataContainerInternal Members nxllException Namespace InxExceptionDataContainerInternal Properties Send Feedback
Syntax
Delphi
property ForObject: TObject;
Description

This is ForObject, a member of class InxExceptionDataContainerInternal.

Group

InxExceptionDataContainerInternal Properties

Links
InxExceptionDataContainerInternal Interface, InxExceptionDataContainerInternal Members, nxllException Namespace, InxExceptionDataContainerInternal Properties


InxExceptionDataValueInternal Interface

InxExceptionDataValueInternal Interface
InxExceptionDataValueInternal Methods InxExceptionDataValueInternal Members nxllException Interfaces Send Feedback
Class Hierarchy
nxllException_InxExceptionDataValueInternalnxllException_InxExceptionDataValueInternal
Syntax
Delphi
InxExceptionDataValueInternal = interface(InxExceptionDataValue);
File

nxllException

Description

This is class nxllException.InxExceptionDataValueInternal.

Group

Interfaces

Links
InxExceptionDataValueInternal Methods, InxExceptionDataValueInternal Members, nxllException, Interfaces


InxExceptionDataValueInternal Members

InxExceptionDataValueInternal Members
InxExceptionDataValueInternal Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxExceptionDataValueInternal.

Interface

InxExceptionDataValueInternal Interface

Public Methods
Name | Description
AddToStrings | This is AddToStrings, a member of class InxExceptionDataValueInternal.
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
GetValueType | This is GetValueType, a member of class InxExceptionDataValue.
SaveToWriter | This is SaveToWriter, a member of class InxExceptionDataValueInternal.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
InxExceptionDataValueInternal Interface, Legend, Public Methods, Public Properties


InxExceptionDataValueInternal Methods

InxExceptionDataValueInternal Methods
InxExceptionDataValueInternal Interface Legend Public Methods Send Feedback

The methods of the InxExceptionDataValueInternal class are listed here.

Interface

InxExceptionDataValueInternal Interface

Public Methods
Name | Description
AddToStrings | This is AddToStrings, a member of class InxExceptionDataValueInternal.
GetParent | This is GetParent, a member of class InxExceptionDataValueInternal.
SaveToWriter | This is SaveToWriter, a member of class InxExceptionDataValueInternal.
Links
InxExceptionDataValueInternal Interface, Legend, Public Methods


InxExceptionDataValueInternal.AddToStrings Method

InxExceptionDataValueInternal.AddToStrings Method
InxExceptionDataValueInternal Interface InxExceptionDataValueInternal Members nxllException Namespace InxExceptionDataValueInternal Methods Send Feedback
Syntax
Delphi
procedure AddToStrings(aAdd: TStringsAddMethod; aIndent: Integer);
Description

This is AddToStrings, a member of class InxExceptionDataValueInternal.

Group

InxExceptionDataValueInternal Methods

Links
InxExceptionDataValueInternal Interface, InxExceptionDataValueInternal Members, nxllException Namespace, InxExceptionDataValueInternal Methods


InxExceptionDataValueInternal.GetParent Method

InxExceptionDataValueInternal.GetParent Method
InxExceptionDataValueInternal Interface InxExceptionDataValueInternal Members nxllException Namespace InxExceptionDataValueInternal Methods Send Feedback
Syntax
Delphi
function GetParent: TnxExceptionDataContainer;
Description

This is GetParent, a member of class InxExceptionDataValueInternal.

Group

InxExceptionDataValueInternal Methods

Links
InxExceptionDataValueInternal Interface, InxExceptionDataValueInternal Members, nxllException Namespace, InxExceptionDataValueInternal Methods


InxExceptionDataValueInternal.SaveToWriter Method

InxExceptionDataValueInternal.SaveToWriter Method
InxExceptionDataValueInternal Interface InxExceptionDataValueInternal Members nxllException Namespace InxExceptionDataValueInternal Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aVersion: Integer);
Description

This is SaveToWriter, a member of class InxExceptionDataValueInternal.

Group

InxExceptionDataValueInternal Methods

Links
InxExceptionDataValueInternal Interface, InxExceptionDataValueInternal Members, nxllException Namespace, InxExceptionDataValueInternal Methods


Functions

Functions
Functions nxllException Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCheck | nxCheck
nxCheck |
nxcOrgMessageMarker |
nxCreateExceptionDataContainer | This is function nxllException.nxCreateExceptionDataContainer.
nxCreateOSError |
nxCreateOSError | nxCreateOSError
nxCreateOSError | This has to be done this way because the Header translator doesn't understand that it doesn't have to generate the default constructors, resulting in multiple declarations for the "same" function. As this is generated in the User section of the Header, outside the Namespace, I'm also including it.
nxCreateOSError |
nxDecodeExceptionDataValue | This is function nxllException.nxDecodeExceptionDataValue.
nxeCustomInfo | nxeCustomInfo
nxGetExceptionHookInfo | This is function nxllException.nxGetExceptionHookInfo.
nxSetExceptionHookInfo | This is function nxllException.nxSetExceptionHookInfo.
Namespace

nxllException Namespace

Links
Functions, nxllException Namespace, Legend


nxllException.nxCheck Function

nxllException.nxCheck Function
nxllException Functions Send Feedback
Syntax
Delphi
procedure nxCheck(aError: TnxResult); overload;
File

nxllException

Description

nxCheck

Group

Functions

Links
nxllException, Functions


nxllException.nxCheck Function

nxllException.nxCheck Function
nxllException Functions Send Feedback
Syntax
Delphi
procedure nxCheck(aError: TnxResult; aErrorsToIgnore: array of TnxResult); overload;
File

nxllException

Group

Functions

Links
nxllException, Functions


nxllException.nxcOrgMessageMarker Function

nxllException.nxcOrgMessageMarker Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxcOrgMessageMarker: string;
File

nxllException

Group

Functions

Links
nxllException, Functions


nxllException.nxCreateExceptionDataContainer Function

nxllException.nxCreateExceptionDataContainer Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxCreateExceptionDataContainer(const aName: string; aForObject: TObject = nil; const aExcludedObjects: TnxDynObjectArray = nil): InxExceptionDataContainer;
File

nxllException

Description

This is function nxllException.nxCreateExceptionDataContainer.

Group

Functions

Links
nxllException, Functions


nxllException.nxCreateOSError Function

nxllException.nxCreateOSError Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxCreateOSError(aExceptionClass: EnxExceptionClass; aErrorCode: TnxResult; aActionRes: PResStringRec): EnxBaseException; overload;
File

nxllException

Group

Functions

Links
nxllException, Functions


nxllException.nxCreateOSError Function

nxllException.nxCreateOSError Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxCreateOSError(aExceptionClass: EnxExceptionClass; aErrorCode: TnxResult; aActionRes: PResStringRec; const aArgs: array of const): EnxBaseException; overload;
File

nxllException

Description

nxCreateOSError

Group

Functions

Links
nxllException, Functions


nxllException.nxCreateOSError Function

nxllException.nxCreateOSError Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxCreateOSError(aExceptionClass: EnxExceptionClass; aErrorCode: TnxResult; const aAction: string): EnxBaseException; overload;
File

nxllException

Description

This has to be done this way because the Header translator doesn't understand that it doesn't have to generate the default constructors, resulting in multiple declarations for the "same" function. As this is generated in the User section of the Header, outside the Namespace, I'm also including it.

Group

Functions

Links
nxllException, Functions


nxllException.nxCreateOSError Function

nxllException.nxCreateOSError Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxCreateOSError(aExceptionClass: EnxExceptionClass; aErrorCode: TnxResult; const aAction: string; const aArgs: array of const): EnxBaseException; overload;
File

nxllException

Group

Functions

Links
nxllException, Functions


nxllException.nxDecodeExceptionDataValue Function

nxllException.nxDecodeExceptionDataValue Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxDecodeExceptionDataValue(const s: string): InxExceptionDataValue;
File

nxllException

Description

This is function nxllException.nxDecodeExceptionDataValue.

Group

Functions

Links
nxllException, Functions


nxllException.nxeCustomInfo Function

nxllException.nxeCustomInfo Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxeCustomInfo(const aName: string; const aValue: string): string;
File

nxllException

Description

nxeCustomInfo

Group

Functions

Links
nxllException, Functions


nxllException.nxGetExceptionHookInfo Function

nxllException.nxGetExceptionHookInfo Function
nxllException Functions Send Feedback
Syntax
Delphi
function nxGetExceptionHookInfo: PnxExceptionHookInfo;
File

nxllException

Description

This is function nxllException.nxGetExceptionHookInfo.

Group

Functions

Links
nxllException, Functions


nxllException.nxSetExceptionHookInfo Function

nxllException.nxSetExceptionHookInfo Function
nxllException Functions Send Feedback
Syntax
Delphi
procedure nxSetExceptionHookInfo(aInfo: PnxExceptionHookInfo);
File

nxllException

Description

This is function nxllException.nxSetExceptionHookInfo.

Group

Functions

Links
nxllException, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllException Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
_PRIVATE_TAG | This is record nxllException._PRIVATE_TAG.
Namespace

nxllException Namespace

Records
Name | Description
TnxExceptionHookInfo | This is record nxllException.TnxExceptionHookInfo.
Links
Enumerations, nxllException Namespace, Legend, Records


nxllException._PRIVATE_TAG Enumeration

nxllException._PRIVATE_TAG Enumeration
nxllException Structs, Records, Enums Send Feedback
Syntax
Delphi
_PRIVATE_TAG = ( _PRIVATE_TAG_ENUM );
File

nxllException

Description

This is record nxllException._PRIVATE_TAG.

Group

Structs, Records, Enums

Links
nxllException, Structs, Records, Enums


nxllException.TnxExceptionHookInfo Record

nxllException.TnxExceptionHookInfo Record
nxllException Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxExceptionHookInfo = record
  ehiUserName: string;
  ehiConnectedFrom: string;
  ehiQuery: string;
  ehiSessionID: Int64;
  ehiClient: string;
end;
File

nxllException

Description

This is record nxllException.TnxExceptionHookInfo.

Group

Structs, Records, Enums

Links
nxllException, Structs, Records, Enums


Types

Types
nxllException Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllException Namespace

Types
Name | Description
EnxExceptionClass | This is type nxllException.EnxExceptionClass.
PnxExceptionHookInfo | This is type nxllException.PnxExceptionHookInfo.
TnxExceptionDataBaseValueClass | This is type nxllException.TnxExceptionDataBaseValueClass.
TStringsAddMethod |
Links
nxllException Namespace, Types


nxllException.EnxExceptionClass Type

nxllException.EnxExceptionClass Type
nxllException Types Send Feedback
Syntax
Delphi
EnxExceptionClass = class of EnxBaseException;
File

nxllException

Description

This is type nxllException.EnxExceptionClass.

Group

Types

Links
nxllException, Types


nxllException.PnxExceptionHookInfo Type

nxllException.PnxExceptionHookInfo Type
nxllException Types Send Feedback
Syntax
Delphi
PnxExceptionHookInfo = ^TnxExceptionHookInfo;
File

nxllException

Description

This is type nxllException.PnxExceptionHookInfo.

Group

Types

Links
nxllException, Types


nxllException.TnxExceptionDataBaseValueClass Type

nxllException.TnxExceptionDataBaseValueClass Type
nxllException Types Send Feedback
Syntax
Delphi
TnxExceptionDataBaseValueClass = class of TnxExceptionDataBaseValue;
File

nxllException

Description

This is type nxllException.TnxExceptionDataBaseValueClass.

Group

Types

Links
nxllException, Types


nxllException.TStringsAddMethod Type

nxllException.TStringsAddMethod Type
nxllException Types Send Feedback
Syntax
Delphi
TStringsAddMethod = function (const S: string): Integer of object;
File

nxllException

Group

Types

Links
nxllException, Types


Variables

Variables
nxllException Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllException Namespace

Variables
Name | Description
_ExceptionHookModeName | This is variable nxllException._ExceptionHookModeName.
_FatalException | This is variable nxllException._FatalException.
_HasExceptionHook | This is variable nxllException._HasExceptionHook.
Links
nxllException Namespace, Variables


nxllException._ExceptionHookModeName Variable

nxllException._ExceptionHookModeName Variable
nxllException Variables Send Feedback
Syntax
Delphi
_ExceptionHookModeName: string;
File

nxllException

Description

This is variable nxllException._ExceptionHookModeName.

Group

Variables

Links
nxllException, Variables


nxllException._FatalException Variable

nxllException._FatalException Variable
nxllException Variables Send Feedback
Syntax
Delphi
_FatalException: Boolean;
File

nxllException

Description

This is variable nxllException._FatalException.

Group

Variables

Links
nxllException, Variables


nxllException._HasExceptionHook Variable

nxllException._HasExceptionHook Variable
nxllException Variables Send Feedback
Syntax
Delphi
_HasExceptionHook: Boolean;
File

nxllException

Description

This is variable nxllException._HasExceptionHook.

Group

Variables

Links
nxllException, Variables


Constants

Constants
Constants nxllException Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxcNewCustomInfoMarkerEnd | This is constant nxllException.nxcNewCustomInfoMarkerEnd.
nxcNewCustomInfoMarkerStart | This is constant nxllException.nxcNewCustomInfoMarkerStart.
nxcNewOrgMessageMarker | This is constant nxllException.nxcNewOrgMessageMarker.
nxcOldCustomInfoMarkerEnd | This is constant nxllException.nxcOldCustomInfoMarkerEnd.
nxcOldCustomInfoMarkerStart | This is constant nxllException.nxcOldCustomInfoMarkerStart.
nxcOldOrgMessageMarker | This is constant nxllException.nxcOldOrgMessageMarker.
rsAsContainerNotSupported | This is constant nxllException.rsAsContainerNotSupported.
rsAsVariantNotSupported | This is constant nxllException.rsAsVariantNotSupported.
rsFatalError | This is constant nxllException.rsFatalError.
Namespace

nxllException Namespace

Links
Constants, nxllException Namespace


nxllException.nxcNewCustomInfoMarkerEnd Constant

nxllException.nxcNewCustomInfoMarkerEnd Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcNewCustomInfoMarkerEnd = '!--]>';
File

nxllException

Description

This is constant nxllException.nxcNewCustomInfoMarkerEnd.

Group

Constants

Links
nxllException, Constants


nxllException.nxcNewCustomInfoMarkerStart Constant

nxllException.nxcNewCustomInfoMarkerStart Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcNewCustomInfoMarkerStart = '<[--!';
File

nxllException

Description

This is constant nxllException.nxcNewCustomInfoMarkerStart.

Group

Constants

Links
nxllException, Constants


nxllException.nxcNewOrgMessageMarker Constant

nxllException.nxcNewOrgMessageMarker Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcNewOrgMessageMarker = '<[!Org!]>';
File

nxllException

Description

This is constant nxllException.nxcNewOrgMessageMarker.

Group

Constants

Links
nxllException, Constants


nxllException.nxcOldCustomInfoMarkerEnd Constant

nxllException.nxcOldCustomInfoMarkerEnd Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcOldCustomInfoMarkerEnd = #254'!--]>';
File

nxllException

Description

This is constant nxllException.nxcOldCustomInfoMarkerEnd.

Group

Constants

Links
nxllException, Constants


nxllException.nxcOldCustomInfoMarkerStart Constant

nxllException.nxcOldCustomInfoMarkerStart Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcOldCustomInfoMarkerStart = '<[--!'#254;
File

nxllException

Description

This is constant nxllException.nxcOldCustomInfoMarkerStart.

Group

Constants

Links
nxllException, Constants


nxllException.nxcOldOrgMessageMarker Constant

nxllException.nxcOldOrgMessageMarker Constant
nxllException Constants Send Feedback
Syntax
Delphi
nxcOldOrgMessageMarker = '<[!'#254'Org'#254'!>';
File

nxllException

Description

This is constant nxllException.nxcOldOrgMessageMarker.

Group

Constants

Links
nxllException, Constants


nxllException.rsAsContainerNotSupported Constant

nxllException.rsAsContainerNotSupported Constant
nxllException Constants Send Feedback
Syntax
Delphi
rsAsContainerNotSupported = 'AsContainer not supported for TnxExceptionDat' + 'aBaseValue';
File

nxllException

Description

This is constant nxllException.rsAsContainerNotSupported.

Group

Constants

Links
nxllException, Constants


nxllException.rsAsVariantNotSupported Constant

nxllException.rsAsVariantNotSupported Constant
nxllException Constants Send Feedback
Syntax
Delphi
rsAsVariantNotSupported = 'AsVariant not supported by TnxExceptionDataBase' + 'Value';
File

nxllException

Description

This is constant nxllException.rsAsVariantNotSupported.

Group

Constants

Links
nxllException, Constants


nxllException.rsFatalError Constant

nxllException.rsFatalError Constant
nxllException Constants Send Feedback
Syntax
Delphi
rsFatalError = 'A fatal error has occurred. Server operations are suspended until the server is restarted. Check exception log at server for further information';
File

nxllException

Description

This is constant nxllException.rsFatalError.

Group

Constants

Links
nxllException, Constants


nxllExceptionStrings Namespace

nxllExceptionStrings Namespace
Constants Topics Send Feedback

This is namespace nxllExceptionStrings.

Constants
Name | Description
csAction | This is constant nxllExceptionStrings.csAction.
csOSError | This is constant nxllExceptionStrings.csOSError.
rsHasErrorCode | This is constant nxllExceptionStrings.rsHasErrorCode.
rsNexusDB | This is constant nxllExceptionStrings.rsNexusDB.
rsNoErrorCode | This is constant nxllExceptionStrings.rsNoErrorCode.
rsOSError | This is constant nxllExceptionStrings.rsOSError.
rsOSErrorAction | This is constant nxllExceptionStrings.rsOSErrorAction.
rsOSErrorActionUnk | This is constant nxllExceptionStrings.rsOSErrorActionUnk.
rsOSErrorUnk | This is constant nxllExceptionStrings.rsOSErrorUnk.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxllExceptionStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csAction | This is constant nxllExceptionStrings.csAction.
csOSError | This is constant nxllExceptionStrings.csOSError.
rsHasErrorCode | This is constant nxllExceptionStrings.rsHasErrorCode.
rsNexusDB | This is constant nxllExceptionStrings.rsNexusDB.
rsNoErrorCode | This is constant nxllExceptionStrings.rsNoErrorCode.
rsOSError | This is constant nxllExceptionStrings.rsOSError.
rsOSErrorAction | This is constant nxllExceptionStrings.rsOSErrorAction.
rsOSErrorActionUnk | This is constant nxllExceptionStrings.rsOSErrorActionUnk.
rsOSErrorUnk | This is constant nxllExceptionStrings.rsOSErrorUnk.
Namespace

nxllExceptionStrings Namespace

Links
Constants, nxllExceptionStrings Namespace


nxllExceptionStrings.csAction Constant

nxllExceptionStrings.csAction Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
csAction = 'Action';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.csAction.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.csOSError Constant

nxllExceptionStrings.csOSError Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
csOSError = 'OSError';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.csOSError.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsHasErrorCode Constant

nxllExceptionStrings.rsHasErrorCode Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsHasErrorCode = '%s [$%x/%d]';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsHasErrorCode.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsNexusDB Constant

nxllExceptionStrings.rsNexusDB Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsNexusDB = 'NexusDB: ';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsNexusDB.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsNoErrorCode Constant

nxllExceptionStrings.rsNoErrorCode Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsNoErrorCode = '%s [no error code]';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsNoErrorCode.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsOSError Constant

nxllExceptionStrings.rsOSError Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsOSError = 'Operating system error: %s ($%x/%d)';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsOSError.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsOSErrorAction Constant

nxllExceptionStrings.rsOSErrorAction Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsOSErrorAction = 'Operating system error in %s: %s ($%x/%d)';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsOSErrorAction.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsOSErrorActionUnk Constant

nxllExceptionStrings.rsOSErrorActionUnk Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsOSErrorActionUnk = 'A call to an OS function failed in %s';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsOSErrorActionUnk.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllExceptionStrings.rsOSErrorUnk Constant

nxllExceptionStrings.rsOSErrorUnk Constant
nxllExceptionStrings Constants Send Feedback
Syntax
Delphi
rsOSErrorUnk = 'A call to an OS function failed.';
File

nxllExceptionStrings

Description

This is constant nxllExceptionStrings.rsOSErrorUnk.

Group

Constants

Links
nxllExceptionStrings, Constants


nxllFastCpuDetect Namespace

nxllFastCpuDetect Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllFastCpuDetect.

Constants
Name | Description
C3EzraEffModel | This is constant nxllFastCpuDetect.C3EzraEffModel.
C3Samuel2EffModel | This is constant nxllFastCpuDetect.C3Samuel2EffModel.
FastCodeTargetStr | This is constant nxllFastCpuDetect.FastCodeTargetStr.
InstructionSupportStr | This is constant nxllFastCpuDetect.InstructionSupportStr.
IntelLowestSEPSupportSignature | CPU signatures
K7DuronA0Signature | This is constant nxllFastCpuDetect.K7DuronA0Signature.
P3LowestEffModel | This is constant nxllFastCpuDetect.P3LowestEffModel.
PMBaniasEffModel | This is constant nxllFastCpuDetect.PMBaniasEffModel.
PMConroeEffModel | This is constant nxllFastCpuDetect.PMConroeEffModel.
PMDothanEffModel | This is constant nxllFastCpuDetect.PMDothanEffModel.
PMIvyBridgeEffModel | This is constant nxllFastCpuDetect.PMIvyBridgeEffModel.
PMNehalemEffModel | 1A $2E
PMPenrynEffModel | 1D
PMSandyBridgeEffModel | 2D
PMWestmereEffModel | 2C, $2F
PMYonahEffModel | This is constant nxllFastCpuDetect.PMYonahEffModel.
VendorIDString | This is constant nxllFastCpuDetect.VendorIDString.
VendorStr | This is constant nxllFastCpuDetect.VendorStr.
Functions
Name | Description
AddRef | This is function nxllFastCpuDetect.AddRef.
Release | This is function nxllFastCpuDetect.Release.
Structs, Records, Enums
Name | Description
TCheckOSVersionInfo | This is record nxllFastCpuDetect.TCheckOSVersionInfo.
TCPU | This is record nxllFastCpuDetect.TCPU.
TCpuExtendedFeatures | This is record nxllFastCpuDetect.TCpuExtendedFeatures.
TCpuFeatures | This is record nxllFastCpuDetect.TCpuFeatures.
TFastCodeTarget | Opteron/Athlon FX/Athlon 64 with SSE3 (future)
TInstructions | 3DNow! - AMD only
TRegisters | This is record nxllFastCpuDetect.TRegisters.
TVendor | This is record nxllFastCpuDetect.TVendor.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PCPU | This is type nxllFastCpuDetect.PCPU.
TCpuExtendedFeatureSet | This is type nxllFastCpuDetect.TCpuExtendedFeatureSet.
TCpuFeatureSet | This is type nxllFastCpuDetect.TCpuFeatureSet.
TCPUMask | This is type nxllFastCpuDetect.TCPUMask.
TCPUNumber | This is type nxllFastCpuDetect.TCPUNumber.
TInstructionSupport |
TVendorStr | This is type nxllFastCpuDetect.TVendorStr.
Variables
Name | Description
CPU | This is variable nxllFastCpuDetect.CPU.
CPUCount | This is variable nxllFastCpuDetect.CPUCount.
CPUMask | This is variable nxllFastCpuDetect.CPUMask.
CPUs | This is variable nxllFastCpuDetect.CPUs.
FastCodeTarget | This is variable nxllFastCpuDetect.FastCodeTarget.
ModernOS | This is variable nxllFastCpuDetect.ModernOS.
OSVersionInfo | This is variable nxllFastCpuDetect.OSVersionInfo.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxllFastCpuDetect Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllFastCpuDetect.AddRef.
Release | This is function nxllFastCpuDetect.Release.
Namespace

nxllFastCpuDetect Namespace

Links
Functions, nxllFastCpuDetect Namespace, Legend


nxllFastCpuDetect.AddRef Function

nxllFastCpuDetect.AddRef Function
nxllFastCpuDetect Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllFastCpuDetect

Description

This is function nxllFastCpuDetect.AddRef.

Group

Functions

Links
nxllFastCpuDetect, Functions


nxllFastCpuDetect.Release Function

nxllFastCpuDetect.Release Function
nxllFastCpuDetect Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllFastCpuDetect

Description

This is function nxllFastCpuDetect.Release.

Group

Functions

Links
nxllFastCpuDetect, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllFastCpuDetect Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TCpuExtendedFeatures | This is record nxllFastCpuDetect.TCpuExtendedFeatures.
TCpuFeatures | This is record nxllFastCpuDetect.TCpuFeatures.
TFastCodeTarget | Opteron/Athlon FX/Athlon 64 with SSE3 (future)
TInstructions | 3DNow! - AMD only
TVendor | This is record nxllFastCpuDetect.TVendor.
Namespace

nxllFastCpuDetect Namespace

Records
Name | Description
TCheckOSVersionInfo | This is record nxllFastCpuDetect.TCheckOSVersionInfo.
TCPU | This is record nxllFastCpuDetect.TCPU.
TRegisters | This is record nxllFastCpuDetect.TRegisters.
Links
Enumerations, nxllFastCpuDetect Namespace, Legend, Records


nxllFastCpuDetect.TCheckOSVersionInfo Record

nxllFastCpuDetect.TCheckOSVersionInfo Record
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TCheckOSVersionInfo = record
  dwOSVersionInfoSize: Cardinal;
  dwMajorVersion: Cardinal;
  dwMinorVersion: Cardinal;
  dwBuildNumber: Cardinal;
  dwPlatformId: Cardinal;
  szCSDVersion: array[0..127] of AnsiChar;
end;
File

nxllFastCpuDetect

Description

This is record nxllFastCpuDetect.TCheckOSVersionInfo.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TCPU Record

nxllFastCpuDetect.TCPU Record
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TCPU = record
  Vendor: TVendor;
  Signature: Cardinal;
  EffFamily: Byte;
  EffModel: Byte;
  EffModelBasic: Byte;
  CodeL1CacheSize: Word;
  DataL1CacheSize: Word;
  L2CacheSize: Word;
  L3CacheSize: Word;
  InstructionSupport: TInstructionSupport;
end;
File

nxllFastCpuDetect

Members
Members | Description
EffFamily: Byte; | ExtendedFamily + Family
EffModel: Byte; | (ExtendedModel shl 4) + Model
EffModelBasic: Byte; | Just Model (not ExtendedModel shl 4) + Model)
InstructionSupport: TInstructionSupport; | KB
Description

This is record nxllFastCpuDetect.TCPU.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TCpuExtendedFeatures Enumeration

nxllFastCpuDetect.TCpuExtendedFeatures Enumeration
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TCpuExtendedFeatures = ( cefLahv, cefCMP, cefSVM, cefEXT, cefALT, cefABM, cefSSE4A, cefMisAlign, cef3DPre, cefOSVW, cef_d10, cef_d11, cefSkinit, cefWDT, cef_d14, cef_d15, cef_d16, cef_d17, cef_d18, cef_d19, cef_d20, cef_d21, cef_d22, cef_d23, cef_d24, cef_d25, cef_d26, cef_d27, cef_d28, cef_d29, cef_d30, cef_d31, cefFPU, cefVME, cefDE, cefPSE, cefTSC, cefMSR, cefPAE, cefMCE, cefCX8, cefAPIC, cef_10, cefSEP, cefMTRR, cefPGE, cefMCA, cefCMOV, cefPAT, cefPSE36, cef_18, ceMPC, ceNX, cef_21, cefExMMX, cefMMX, cefFXSR, cef_25, cef_26, cef_27, cef_28, cefLM, cefEx3DNow, cef3DNow );
File

nxllFastCpuDetect

Members
Members | Description
cefLahv | in EDX
cefFPU | in ECX
Description

This is record nxllFastCpuDetect.TCpuExtendedFeatures.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TCpuFeatures Enumeration

nxllFastCpuDetect.TCpuFeatures Enumeration
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TCpuFeatures = ( cfFPU, cfVME, cfDE, cfPSE, cfTSC, cfMSR, cfPAE, cfMCE, cfCX8, cfAPIC, cf_d10, cfSEP, cfMTRR, cfPGE, cfMCA, cfCMOV, cfPAT, cfPSE36, cfPSN, cfCLFSH, cf_d20, cfDS, cfACPI, cfMMX, cfFXSR, cfSSE, cfSSE2, cfSS, cfHTT, cfTM, cfIA_64, cfPBE, cfSSE3, cf_c1, cf_c2, cfMON, cfDS_CPL, cf_c5, cf_c6, cfEIST, cfTM2, cfSSSE3, cfCID, cfSSE5, cf_c12, cfCX16, cfxTPR, cf_c15, cf_c16, cf_c17, cf_c18, cfSSE41, cfSSE42, cf_c21, cf_c22, cf_c23, cf_c24, cf_c25, cf_c26, cf_c27, cfAVX, cf_c29, cf_c30, cf_c31 );
File

nxllFastCpuDetect

Members
Members | Description
cfFPU | in EDX
cfSSE3 | in ECX
Description

This is record nxllFastCpuDetect.TCpuFeatures.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TFastCodeTarget Enumeration

nxllFastCpuDetect.TFastCodeTarget Enumeration
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TFastCodeTarget = ( fctRTLReplacement, fctBlended, fctP3, fctPM, fctP4, fctP4_SSE3, fctP4_64, fctK7, fctK7_SSE, fctK8, fctK8_SSE3 );
File

nxllFastCpuDetect

Members
Members | Description
fctRTLReplacement | not specific to any CPU
fctBlended | not specific to any CPU, requires FPU, MMX and CMOV
fctP3 | Pentium/Celeron 3
fctPM | Pentium/Celeron M (Banias and Dothan)
fctP4 | Pentium/Celeron/Xeon 4 without SSE3 (Willamette, Foster, Foster MP, Northwood, Prestonia, Gallatin)
fctP4_SSE3 | Pentium/Celeron 4 with SSE3 (Prescott)
fctP4_64 | Pentium/Xeon 4 with EM64T (some Prescott, and Nocona)
fctK7 | Athlon/Duron without SSE (Thunderbird and Spitfire)
fctK7_SSE | Athlon/Duron/Sempron with SSE (Palomino, Morgan, Thoroughbred, Applebred, Barton)
fctK8 | Opteron/Athlon FX/Athlon 64 (Clawhammer, Sledgehammer, Newcastle)
Description

Opteron/Athlon FX/Athlon 64 with SSE3 (future)

Notes

when changing TFastCodeTarget, also change FastCodeTargetStr array below

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TInstructions Enumeration

nxllFastCpuDetect.TInstructions Enumeration
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TInstructions = ( isFPU, isTSC, isCX8, isSEP, isCMOV, isMMX, isFXSR, isSSE, isSSE2, isSSE3, isSSSE3, isSSE4A, isSSE41, isSSE42, isSSE5, isAVX, isMONITOR, isCX16, isX64, isExMMX, isEx3DNow, is3DNow );
File

nxllFastCpuDetect

Members
Members | Description
isFPU | 80x87
isTSC | RDTSC
isCX8 | CMPXCHG8B
isSEP | SYSENTER/SYSEXIT
isCMOV | CMOVcc, and if isFPU, FCMOVcc/FCOMI
isMMX | MMX
isFXSR | FXSAVE/FXRSTOR
isSSE | SSE
isSSE2 | SSE2
isSSE3 | SSE3
isSSSE3 | SSSE3
isSSE4A | SSE4A
isSSE41 | SSE4.1
isSSE42 | SSE4.2
isSSE5 | SSE5
isAVX | AVX
isMONITOR | MONITOR/MWAIT
isCX16 | CMPXCHG16B
isX64 | AMD AMD64* or Intel EM64T
isExMMX | MMX+ - AMD only
isEx3DNow | 3DNow!+ - AMD only
Description

3DNow! - AMD only

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TRegisters Record

nxllFastCpuDetect.TRegisters Record
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TRegisters = record
  EAX: Cardinal;
  EBX: Cardinal;
  ECX: Cardinal;
  EDX: Cardinal;
end;
File

nxllFastCpuDetect

Description

This is record nxllFastCpuDetect.TRegisters.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


nxllFastCpuDetect.TVendor Enumeration

nxllFastCpuDetect.TVendor Enumeration
nxllFastCpuDetect Structs, Records, Enums Send Feedback
Syntax
Delphi
TVendor = ( cvUnknown, cvAMD, cvCentaur, cvCyrix, cvIntel, cvTransmeta, cvNexGen, cvRise, cvUMC, cvNSC, cvSiS );
File

nxllFastCpuDetect

Description

This is record nxllFastCpuDetect.TVendor.

Group

Structs, Records, Enums

Links
nxllFastCpuDetect, Structs, Records, Enums


Types

Types
nxllFastCpuDetect Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllFastCpuDetect Namespace

Types
Name | Description
PCPU | This is type nxllFastCpuDetect.PCPU.
TCpuExtendedFeatureSet | This is type nxllFastCpuDetect.TCpuExtendedFeatureSet.
TCpuFeatureSet | This is type nxllFastCpuDetect.TCpuFeatureSet.
TCPUMask | This is type nxllFastCpuDetect.TCPUMask.
TCPUNumber | This is type nxllFastCpuDetect.TCPUNumber.
TInstructionSupport |
TVendorStr | This is type nxllFastCpuDetect.TVendorStr.
Links
nxllFastCpuDetect Namespace, Types


nxllFastCpuDetect.PCPU Type

nxllFastCpuDetect.PCPU Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
PCPU = ^TCPU;
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.PCPU.

Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TCpuExtendedFeatureSet Type

nxllFastCpuDetect.TCpuExtendedFeatureSet Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TCpuExtendedFeatureSet = set of TCpuExtendedFeatures;
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.TCpuExtendedFeatureSet.

Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TCpuFeatureSet Type

nxllFastCpuDetect.TCpuFeatureSet Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TCpuFeatureSet = set of TCpuFeatures;
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.TCpuFeatureSet.

Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TCPUMask Type

nxllFastCpuDetect.TCPUMask Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TCPUMask = set of TCPUNumber;
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.TCPUMask.

Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TCPUNumber Type

nxllFastCpuDetect.TCPUNumber Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TCPUNumber = 0..31;
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.TCPUNumber.

Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TInstructionSupport Type

nxllFastCpuDetect.TInstructionSupport Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TInstructionSupport = set of TInstructions;
File

nxllFastCpuDetect

Notes

when changing TInstruction, also change InstructionSupportStr below

  • - instruction(s) not supported in Delphi 7 assembler
Group

Types

Links
nxllFastCpuDetect, Types


nxllFastCpuDetect.TVendorStr Type

nxllFastCpuDetect.TVendorStr Type
nxllFastCpuDetect Types Send Feedback
Syntax
Delphi
TVendorStr = string[12];
File

nxllFastCpuDetect

Description

This is type nxllFastCpuDetect.TVendorStr.

Group

Types

Links
nxllFastCpuDetect, Types


Variables

Variables
nxllFastCpuDetect Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllFastCpuDetect Namespace

Variables
Name | Description
CPU | This is variable nxllFastCpuDetect.CPU.
CPUCount | This is variable nxllFastCpuDetect.CPUCount.
CPUMask | This is variable nxllFastCpuDetect.CPUMask.
CPUs | This is variable nxllFastCpuDetect.CPUs.
FastCodeTarget | This is variable nxllFastCpuDetect.FastCodeTarget.
ModernOS | This is variable nxllFastCpuDetect.ModernOS.
OSVersionInfo | This is variable nxllFastCpuDetect.OSVersionInfo.
Links
nxllFastCpuDetect Namespace, Variables


nxllFastCpuDetect.CPU Variable

nxllFastCpuDetect.CPU Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
CPU: PCPU;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.CPU.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.CPUCount Variable

nxllFastCpuDetect.CPUCount Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
CPUCount: Integer;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.CPUCount.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.CPUMask Variable

nxllFastCpuDetect.CPUMask Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
CPUMask: TCPUMask;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.CPUMask.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.CPUs Variable

nxllFastCpuDetect.CPUs Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
CPUs: array[TCPUNumber] of TCPU;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.CPUs.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.FastCodeTarget Variable

nxllFastCpuDetect.FastCodeTarget Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
FastCodeTarget: TFastCodeTarget;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.FastCodeTarget.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.ModernOS Variable

nxllFastCpuDetect.ModernOS Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
ModernOS: Boolean;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.ModernOS.

Group

Variables

Links
nxllFastCpuDetect, Variables


nxllFastCpuDetect.OSVersionInfo Variable

nxllFastCpuDetect.OSVersionInfo Variable
nxllFastCpuDetect Variables Send Feedback
Syntax
Delphi
OSVersionInfo: TCheckOSVersionInfo;
File

nxllFastCpuDetect

Description

This is variable nxllFastCpuDetect.OSVersionInfo.

Group

Variables

Links
nxllFastCpuDetect, Variables


Constants

Constants
Constants nxllFastCpuDetect Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
C3EzraEffModel | This is constant nxllFastCpuDetect.C3EzraEffModel.
C3Samuel2EffModel | This is constant nxllFastCpuDetect.C3Samuel2EffModel.
FastCodeTargetStr | This is constant nxllFastCpuDetect.FastCodeTargetStr.
InstructionSupportStr | This is constant nxllFastCpuDetect.InstructionSupportStr.
IntelLowestSEPSupportSignature | CPU signatures
K7DuronA0Signature | This is constant nxllFastCpuDetect.K7DuronA0Signature.
P3LowestEffModel | This is constant nxllFastCpuDetect.P3LowestEffModel.
PMBaniasEffModel | This is constant nxllFastCpuDetect.PMBaniasEffModel.
PMConroeEffModel | This is constant nxllFastCpuDetect.PMConroeEffModel.
PMDothanEffModel | This is constant nxllFastCpuDetect.PMDothanEffModel.
PMIvyBridgeEffModel | This is constant nxllFastCpuDetect.PMIvyBridgeEffModel.
PMNehalemEffModel | 1A $2E
PMPenrynEffModel | 1D
PMSandyBridgeEffModel | 2D
PMWestmereEffModel | 2C, $2F
PMYonahEffModel | This is constant nxllFastCpuDetect.PMYonahEffModel.
VendorIDString | This is constant nxllFastCpuDetect.VendorIDString.
VendorStr | This is constant nxllFastCpuDetect.VendorStr.
Namespace

nxllFastCpuDetect Namespace

Links
Constants, nxllFastCpuDetect Namespace


nxllFastCpuDetect.C3EzraEffModel Constant

nxllFastCpuDetect.C3EzraEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
C3EzraEffModel = 8;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.C3EzraEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.C3Samuel2EffModel Constant

nxllFastCpuDetect.C3Samuel2EffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
C3Samuel2EffModel = 7;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.C3Samuel2EffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.FastCodeTargetStr Constant

nxllFastCpuDetect.FastCodeTargetStr Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
FastCodeTargetStr: array[Low(TFastCodeTarget)..High(TFastCodeTarget)] of ShortString = ('RTLReplacement', 'Blended', 'P3', 'PM', 'P4', 'P4_SSE3', 'P4_64', 'K7', 'K7_SSE', 'K8', 'K8_SSE3');
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.FastCodeTargetStr.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.InstructionSupportStr Constant

nxllFastCpuDetect.InstructionSupportStr Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
InstructionSupportStr: array [Low(TInstructions) .. High(TInstructions)] of ShortString = ('FPU', 'TSC', 'CX8', 'SEP', 'CMOV', 'MMX', 'FXSR', 'SSE', 'SSE2', 'SSE3', 'SSSE3', 'SSE4A', 'SSE41', 'SSE42', 'SSE5', 'AVX', 'MONITOR', 'CX16', 'X64', 'MMX+', '3DNow!+', '3DNow!');
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.InstructionSupportStr.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.IntelLowestSEPSupportSignature Constant

nxllFastCpuDetect.IntelLowestSEPSupportSignature Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
IntelLowestSEPSupportSignature = $633;
File

nxllFastCpuDetect

Description

CPU signatures

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.K7DuronA0Signature Constant

nxllFastCpuDetect.K7DuronA0Signature Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
K7DuronA0Signature = $630;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.K7DuronA0Signature.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.P3LowestEffModel Constant

nxllFastCpuDetect.P3LowestEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
P3LowestEffModel = 7;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.P3LowestEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMBaniasEffModel Constant

nxllFastCpuDetect.PMBaniasEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMBaniasEffModel = 9;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.PMBaniasEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMConroeEffModel Constant

nxllFastCpuDetect.PMConroeEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMConroeEffModel = $F;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.PMConroeEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMDothanEffModel Constant

nxllFastCpuDetect.PMDothanEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMDothanEffModel = $D;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.PMDothanEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMIvyBridgeEffModel Constant

nxllFastCpuDetect.PMIvyBridgeEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMIvyBridgeEffModel = $3A;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.PMIvyBridgeEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMNehalemEffModel Constant

nxllFastCpuDetect.PMNehalemEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMNehalemEffModel = $1E;
File

nxllFastCpuDetect

Description

1A $2E

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMPenrynEffModel Constant

nxllFastCpuDetect.PMPenrynEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMPenrynEffModel = $17;
File

nxllFastCpuDetect

Description

1D

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMSandyBridgeEffModel Constant

nxllFastCpuDetect.PMSandyBridgeEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMSandyBridgeEffModel = $2A;
File

nxllFastCpuDetect

Description

2D

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMWestmereEffModel Constant

nxllFastCpuDetect.PMWestmereEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMWestmereEffModel = $25;
File

nxllFastCpuDetect

Description

2C, $2F

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.PMYonahEffModel Constant

nxllFastCpuDetect.PMYonahEffModel Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
PMYonahEffModel = $E;
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.PMYonahEffModel.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.VendorIDString Constant

nxllFastCpuDetect.VendorIDString Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
VendorIDString: array [Low(TVendor) .. High(TVendor)] of TVendorStr = ('', 'AuthenticAMD', 'CentaurHauls', 'CyrixInstead', 'GenuineIntel', 'GenuineTMx86', 'NexGenDriven', 'RiseRiseRise', 'UMC UMC UMC ', 'Geode by NSC', 'SiS SiS SiS');
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.VendorIDString.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastCpuDetect.VendorStr Constant

nxllFastCpuDetect.VendorStr Constant
nxllFastCpuDetect Constants Send Feedback
Syntax
Delphi
VendorStr: array [Low(TVendor) .. High(TVendor)] of ShortString = ('Unknown', 'AMD', 'Centaur (VIA)', 'Cyrix', 'Intel', 'Transmeta', 'NexGen', 'Rise', 'UMC', 'National Semiconductor', 'SiS');
File

nxllFastCpuDetect

Description

This is constant nxllFastCpuDetect.VendorStr.

Group

Constants

Links
nxllFastCpuDetect, Constants


nxllFastFillChar Namespace

nxllFastFillChar Namespace
Functions Legend Topics Types Variables Send Feedback

This is namespace nxllFastFillChar.

Functions
Name | Description
AddRef | This is function nxllFastFillChar.AddRef.
Release | This is function nxllFastFillChar.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxFillChar | This is type nxllFastFillChar.TnxFillChar.
Variables
Name | Description
_RefCount | This is variable nxllFastFillChar._RefCount.
nxFillChar | This is variable nxllFastFillChar.nxFillChar.
Links
Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxllFastFillChar Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllFastFillChar.AddRef.
Release | This is function nxllFastFillChar.Release.
Namespace

nxllFastFillChar Namespace

Links
Functions, nxllFastFillChar Namespace, Legend


nxllFastFillChar.AddRef Function

nxllFastFillChar.AddRef Function
nxllFastFillChar Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllFastFillChar

Description

This is function nxllFastFillChar.AddRef.

Group

Functions

Links
nxllFastFillChar, Functions


nxllFastFillChar.Release Function

nxllFastFillChar.Release Function
nxllFastFillChar Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllFastFillChar

Description

This is function nxllFastFillChar.Release.

Group

Functions

Links
nxllFastFillChar, Functions


Types

Types
nxllFastFillChar Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllFastFillChar Namespace

Types
Name | Description
TnxFillChar | This is type nxllFastFillChar.TnxFillChar.
Links
nxllFastFillChar Namespace, Types


nxllFastFillChar.TnxFillChar Type

nxllFastFillChar.TnxFillChar Type
nxllFastFillChar Types Send Feedback
Syntax
Delphi
TnxFillChar = procedure (var Dest; Count: TnxNativeInt; Value: Byte);
File

nxllFastFillChar

Description

This is type nxllFastFillChar.TnxFillChar.

Group

Types

Links
nxllFastFillChar, Types


Variables

Variables
nxllFastFillChar Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllFastFillChar Namespace

Variables
Name | Description
_RefCount | This is variable nxllFastFillChar._RefCount.
nxFillChar | This is variable nxllFastFillChar.nxFillChar.
Links
nxllFastFillChar Namespace, Variables


nxllFastFillChar._RefCount Variable

nxllFastFillChar._RefCount Variable
nxllFastFillChar Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxllFastFillChar

Description

This is variable nxllFastFillChar._RefCount.

Group

Variables

Links
nxllFastFillChar, Variables


nxllFastFillChar.nxFillChar Variable

nxllFastFillChar.nxFillChar Variable
nxllFastFillChar Variables Send Feedback
Syntax
Delphi
nxFillChar: TnxFillChar;
File

nxllFastFillChar

Description

This is variable nxllFastFillChar.nxFillChar.

Group

Variables

Links
nxllFastFillChar, Variables


nxllFastMove Namespace

nxllFastMove Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllFastMove.

Constants
Name | Description
TINYSIZE | MoveJOH_PAS
Functions
Name | Description
AddRef | This is function nxllFastMove.AddRef.
GetVersionEx |
Release | This is function nxllFastMove.Release.
Structs, Records, Enums
Name | Description
TCheckOSVersionInfo | This is record nxllFastMove.TCheckOSVersionInfo.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxMove | This is type nxllFastMove.TnxMove.
Variables
Name | Description
CacheLimit | Used within SSE Moves
nxMove | This is variable nxllFastMove.nxMove.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxllFastMove Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllFastMove.AddRef.
GetVersionEx |
Release | This is function nxllFastMove.Release.
Namespace

nxllFastMove Namespace

Links
Functions, nxllFastMove Namespace, Legend


nxllFastMove.AddRef Function

nxllFastMove.AddRef Function
nxllFastMove Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllFastMove

Description

This is function nxllFastMove.AddRef.

Group

Functions

Links
nxllFastMove, Functions


nxllFastMove.GetVersionEx Function

nxllFastMove.GetVersionEx Function
nxllFastMove Functions Send Feedback
Syntax
Delphi
function GetVersionEx(var lpVersionInformation: TCheckOSVersionInfo): LongBool; stdcall;
File

nxllFastMove

Group

Functions

Links
nxllFastMove, Functions


nxllFastMove.Release Function

nxllFastMove.Release Function
nxllFastMove Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllFastMove

Description

This is function nxllFastMove.Release.

Group

Functions

Links
nxllFastMove, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllFastMove Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllFastMove Namespace

Records
Name | Description
TCheckOSVersionInfo | This is record nxllFastMove.TCheckOSVersionInfo.
Links
nxllFastMove Namespace, Legend, Records


nxllFastMove.TCheckOSVersionInfo Record

nxllFastMove.TCheckOSVersionInfo Record
nxllFastMove Structs, Records, Enums Send Feedback
Syntax
Delphi
TCheckOSVersionInfo = record
  dwOSVersionInfoSize: LongWord;
  dwMajorVersion: LongWord;
  dwMinorVersion: LongWord;
  dwBuildNumber: LongWord;
  dwPlatformId: LongWord;
  szCSDVersion: array[0..127] of AnsiChar;
end;
File

nxllFastMove

Description

This is record nxllFastMove.TCheckOSVersionInfo.

Group

Structs, Records, Enums

Links
nxllFastMove, Structs, Records, Enums


Types

Types
nxllFastMove Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllFastMove Namespace

Types
Name | Description
TnxMove | This is type nxllFastMove.TnxMove.
Links
nxllFastMove Namespace, Types


nxllFastMove.TnxMove Type

nxllFastMove.TnxMove Type
nxllFastMove Types Send Feedback
Syntax
Delphi
TnxMove = procedure (const Source; var Dest; Count : Integer);
File

nxllFastMove

Description

This is type nxllFastMove.TnxMove.

Group

Types

Links
nxllFastMove, Types


Variables

Variables
nxllFastMove Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllFastMove Namespace

Variables
Name | Description
CacheLimit | Used within SSE Moves
nxMove | This is variable nxllFastMove.nxMove.
Links
nxllFastMove Namespace, Variables


nxllFastMove.CacheLimit Variable

nxllFastMove.CacheLimit Variable
nxllFastMove Variables Send Feedback
Syntax
Delphi
CacheLimit: Integer;
File

nxllFastMove

Description

Used within SSE Moves

Group

Variables

Links
nxllFastMove, Variables


nxllFastMove.nxMove Variable

nxllFastMove.nxMove Variable
nxllFastMove Variables Send Feedback
Syntax
Delphi
nxMove: TnxMove = nil;
File

nxllFastMove

Description

This is variable nxllFastMove.nxMove.

Group

Variables

Links
nxllFastMove, Variables


Constants

Constants
Constants nxllFastMove Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
TINYSIZE | MoveJOH_PAS
Namespace

nxllFastMove Namespace

Links
Constants, nxllFastMove Namespace


nxllFastMove.TINYSIZE Constant

nxllFastMove.TINYSIZE Constant
nxllFastMove Constants Send Feedback
Syntax
Delphi
TINYSIZE = 36;
File

nxllFastMove

Description

MoveJOH_PAS

Group

Constants

Links
nxllFastMove, Constants


nxllFiFo Namespace

nxllFiFo Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllFiFo.

Classes
Name | Description
EnxFiFoException | This is class nxllFiFo.EnxFiFoException.
TnxBaseFiFoBuffer | This is class nxllFiFo.TnxBaseFiFoBuffer.
TnxBufferPage | This is class nxllFiFo.TnxBufferPage.
TnxFiFoBuffer | This is class nxllFiFo.TnxFiFoBuffer.
TnxFifoReadStream | This is class nxllFiFo.TnxFifoReadStream.
TnxFifoWriteStream | This is class nxllFiFo.TnxFifoWriteStream.
Constants
Name | Description
DefaultPageSize | This is constant nxllFiFo.DefaultPageSize.
NoPageCountLimit | This is constant nxllFiFo.NoPageCountLimit.
NoWaitLimit | This is constant nxllFiFo.NoWaitLimit.
Structs, Records, Enums
Name | Description
TnxBufferMarker | This is record nxllFiFo.TnxBufferMarker.
TnxBufferPageState | This is record nxllFiFo.TnxBufferPageState.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBufferPageClass | This is type nxllFiFo.TnxBufferPageClass.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllFiFo Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxFiFoException | This is class nxllFiFo.EnxFiFoException.
TnxBaseFiFoBuffer | This is class nxllFiFo.TnxBaseFiFoBuffer.
TnxBufferPage | This is class nxllFiFo.TnxBufferPage.
TnxFiFoBuffer | This is class nxllFiFo.TnxFiFoBuffer.
TnxFifoReadStream | This is class nxllFiFo.TnxFifoReadStream.
TnxFifoWriteStream | This is class nxllFiFo.TnxFifoWriteStream.
Namespace

nxllFiFo Namespace

Links
Classes, nxllFiFo Namespace, Legend


EnxFiFoException Class

EnxFiFoException Class
nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_EnxFiFoExceptionnxllFiFo_EnxFiFoExceptionnxllFiFo_EnxFiFoExceptionnxllFiFo_EnxFiFoException
Syntax
Delphi
EnxFiFoException = class(EnxBaseException);
File

nxllFiFo

Description

This is class nxllFiFo.EnxFiFoException.

Group

Classes

Links
nxllFiFo, Classes


TnxBaseFiFoBuffer Class

TnxBaseFiFoBuffer Class
TnxBaseFiFoBuffer Methods TnxBaseFiFoBuffer Members nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_TnxBaseFiFoBuffernxllFiFo_TnxBaseFiFoBuffer
Syntax
Delphi
TnxBaseFiFoBuffer = class(TnxObject);
File

nxllFiFo

Description

This is class nxllFiFo.TnxBaseFiFoBuffer.

Group

Classes

Links
TnxBaseFiFoBuffer Methods, TnxBaseFiFoBuffer Members, nxllFiFo, Classes


TnxBaseFiFoBuffer Members

TnxBaseFiFoBuffer Members
TnxBaseFiFoBuffer Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFiFoBuffer.

Class

TnxBaseFiFoBuffer Class

Protected Methods
Name | Description
GetPageClass | This is GetPageClass, a member of class TnxBaseFiFoBuffer.
Public Methods
Name | Description
Create | This is Create, a member of class TnxBaseFiFoBuffer.
FreeInstance |
GetReadPage | This is GetReadPage, a member of class TnxBaseFiFoBuffer.
GetWritePage | This is GetWritePage, a member of class TnxBaseFiFoBuffer.
NewInstance | TnxObject
Shutdown | This is Shutdown, a member of class TnxBaseFiFoBuffer.
Links
TnxBaseFiFoBuffer Class, Legend, Protected Methods, Public Methods


TnxBaseFiFoBuffer.Create Constructor

TnxBaseFiFoBuffer.Create Constructor
TnxBaseFiFoBuffer Class TnxBaseFiFoBuffer Members nxllFiFo Namespace TnxBaseFiFoBuffer Class Send Feedback
Syntax
Delphi
constructor Create(aPageSize: Cardinal; aMinKeepCount: Integer; aMaxPageCount: Integer = NoPageCountLimit; aMaxWriteTime: Integer = NoWaitLimit); virtual; abstract;
Description

This is Create, a member of class TnxBaseFiFoBuffer.

Class

TnxBaseFiFoBuffer Class

Links
TnxBaseFiFoBuffer Class, TnxBaseFiFoBuffer Members, nxllFiFo Namespace, TnxBaseFiFoBuffer Class


TnxBaseFiFoBuffer Methods

TnxBaseFiFoBuffer Methods
TnxBaseFiFoBuffer Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFiFoBuffer class are listed here.

Class

TnxBaseFiFoBuffer Class

Protected Methods
Name | Description
GetPageClass | This is GetPageClass, a member of class TnxBaseFiFoBuffer.
Public Methods
Name | Description
GetReadPage | This is GetReadPage, a member of class TnxBaseFiFoBuffer.
GetWritePage | This is GetWritePage, a member of class TnxBaseFiFoBuffer.
Shutdown | This is Shutdown, a member of class TnxBaseFiFoBuffer.
Links
TnxBaseFiFoBuffer Class, Legend, Protected Methods, Public Methods


TnxBaseFiFoBuffer.GetPageClass Method

TnxBaseFiFoBuffer.GetPageClass Method
TnxBaseFiFoBuffer Class TnxBaseFiFoBuffer Members nxllFiFo Namespace TnxBaseFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetPageClass: TnxBufferPageClass; virtual; abstract;
Description

This is GetPageClass, a member of class TnxBaseFiFoBuffer.

Group

TnxBaseFiFoBuffer Methods

Links
TnxBaseFiFoBuffer Class, TnxBaseFiFoBuffer Members, nxllFiFo Namespace, TnxBaseFiFoBuffer Methods


TnxBaseFiFoBuffer.GetReadPage Method

TnxBaseFiFoBuffer.GetReadPage Method
TnxBaseFiFoBuffer Class TnxBaseFiFoBuffer Members nxllFiFo Namespace TnxBaseFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetReadPage(aWaitForData: Boolean; aExceptOnShutdown: Boolean): TnxBufferPage; virtual; abstract;
Description

This is GetReadPage, a member of class TnxBaseFiFoBuffer.

Group

TnxBaseFiFoBuffer Methods

Links
TnxBaseFiFoBuffer Class, TnxBaseFiFoBuffer Members, nxllFiFo Namespace, TnxBaseFiFoBuffer Methods


TnxBaseFiFoBuffer.GetWritePage Method

TnxBaseFiFoBuffer.GetWritePage Method
TnxBaseFiFoBuffer Class TnxBaseFiFoBuffer Members nxllFiFo Namespace TnxBaseFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetWritePage(aSize: Cardinal = DefaultPageSize; aNoWait: Boolean = False): TnxBufferPage; virtual; abstract;
Description

This is GetWritePage, a member of class TnxBaseFiFoBuffer.

Group

TnxBaseFiFoBuffer Methods

Links
TnxBaseFiFoBuffer Class, TnxBaseFiFoBuffer Members, nxllFiFo Namespace, TnxBaseFiFoBuffer Methods


TnxBaseFiFoBuffer.Shutdown Method

TnxBaseFiFoBuffer.Shutdown Method
TnxBaseFiFoBuffer Class TnxBaseFiFoBuffer Members nxllFiFo Namespace TnxBaseFiFoBuffer Methods Send Feedback
Syntax
Delphi
procedure Shutdown; virtual; abstract;
Description

This is Shutdown, a member of class TnxBaseFiFoBuffer.

Group

TnxBaseFiFoBuffer Methods

Links
TnxBaseFiFoBuffer Class, TnxBaseFiFoBuffer Members, nxllFiFo Namespace, TnxBaseFiFoBuffer Methods


TnxBufferPage Class

TnxBufferPage Class
TnxBufferPage Methods TnxBufferPage Properties TnxBufferPage Members nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_TnxBufferPage
Syntax
Delphi
TnxBufferPage = class(TStream);
File

nxllFiFo

Description

This is class nxllFiFo.TnxBufferPage.

Group

Classes

Links
TnxBufferPage Methods, TnxBufferPage Properties, TnxBufferPage Members, nxllFiFo, Classes


TnxBufferPage Members

TnxBufferPage Members
TnxBufferPage Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBufferPage.

Class

TnxBufferPage Class

Protected Methods
Name | Description
Create |
SetSize |
Public Methods
Name | Description
Clear |
Destroy |
Finished |
Read |
Seek |
Write |
Public Properties
Name | Description
FiFo | This is FiFo, a member of class TnxBufferPage.
Marker | This is Marker, a member of class TnxBufferPage.
Memory | This is Memory, a member of class TnxBufferPage.
State | This is State, a member of class TnxBufferPage.
TimeRemaining | This is TimeRemaining, a member of class TnxBufferPage.
Links
TnxBufferPage Class, Legend, Protected Methods, Public Methods, Public Properties


TnxBufferPage.Create Constructor

TnxBufferPage.Create Constructor
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Class Send Feedback
Syntax
Delphi
constructor Create(aFiFo: TnxFiFoBuffer; aSize: Cardinal); virtual;
Class

TnxBufferPage Class

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Class


TnxBufferPage.Destroy Destructor

TnxBufferPage.Destroy Destructor
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBufferPage Class

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Class


TnxBufferPage Methods

TnxBufferPage Methods
TnxBufferPage Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBufferPage class are listed here.

Class

TnxBufferPage Class

Protected Methods
Name | Description
SetSize |
Public Methods
Name | Description
Clear |
Finished |
Read |
Seek |
Write |
Links
TnxBufferPage Class, Legend, Protected Methods, Public Methods


TnxBufferPage.Clear Method

TnxBufferPage.Clear Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage.Finished Method

TnxBufferPage.Finished Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
procedure Finished;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage.Read Method

TnxBufferPage.Read Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; override;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage.Seek Method

TnxBufferPage.Seek Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
function Seek(Offset: Integer; Origin: Word): Integer; override;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage.SetSize Method

TnxBufferPage.SetSize Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
procedure SetSize(NewSize: Integer); override;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage.Write Method

TnxBufferPage.Write Method
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Methods Send Feedback
Syntax
Delphi
function Write(const Buffer; Count: Integer): Integer; override;
Group

TnxBufferPage Methods

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Methods


TnxBufferPage Properties

TnxBufferPage Properties
TnxBufferPage Class Legend Public Properties Send Feedback

The properties of the TnxBufferPage class are listed here.

Class

TnxBufferPage Class

Public Properties
Name | Description
FiFo | This is FiFo, a member of class TnxBufferPage.
Marker | This is Marker, a member of class TnxBufferPage.
Memory | This is Memory, a member of class TnxBufferPage.
State | This is State, a member of class TnxBufferPage.
TimeRemaining | This is TimeRemaining, a member of class TnxBufferPage.
Links
TnxBufferPage Class, Legend, Public Properties


TnxBufferPage.FiFo Property

TnxBufferPage.FiFo Property
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Properties Send Feedback
Syntax
Delphi
property FiFo: TnxFiFoBuffer;
Description

This is FiFo, a member of class TnxBufferPage.

Group

TnxBufferPage Properties

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Properties


TnxBufferPage.Marker Property

TnxBufferPage.Marker Property
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Properties Send Feedback
Syntax
Delphi
property Marker: TnxBufferMarker;
Description

This is Marker, a member of class TnxBufferPage.

Group

TnxBufferPage Properties

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Properties


TnxBufferPage.Memory Property

TnxBufferPage.Memory Property
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Properties Send Feedback
Syntax
Delphi
property Memory: Pointer;
Description

This is Memory, a member of class TnxBufferPage.

Group

TnxBufferPage Properties

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Properties


TnxBufferPage.State Property

TnxBufferPage.State Property
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Properties Send Feedback
Syntax
Delphi
property State: TnxBufferPageState;
Description

This is State, a member of class TnxBufferPage.

Group

TnxBufferPage Properties

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Properties


TnxBufferPage.TimeRemaining Property

TnxBufferPage.TimeRemaining Property
TnxBufferPage Class TnxBufferPage Members nxllFiFo Namespace TnxBufferPage Properties Send Feedback
Syntax
Delphi
property TimeRemaining: Integer;
Description

This is TimeRemaining, a member of class TnxBufferPage.

Group

TnxBufferPage Properties

Links
TnxBufferPage Class, TnxBufferPage Members, nxllFiFo Namespace, TnxBufferPage Properties


TnxFiFoBuffer Class

TnxFiFoBuffer Class
TnxFiFoBuffer Fields TnxFiFoBuffer Methods TnxFiFoBuffer Properties TnxFiFoBuffer Members nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_TnxFiFoBuffernxllFiFo_TnxFiFoBuffernxllFiFo_TnxFiFoBuffer
Syntax
Delphi
TnxFiFoBuffer = class(TnxBaseFiFoBuffer);
File

nxllFiFo

Description

This is class nxllFiFo.TnxFiFoBuffer.

Group

Classes

Links
TnxFiFoBuffer Fields, TnxFiFoBuffer Methods, TnxFiFoBuffer Properties, TnxFiFoBuffer Members, nxllFiFo, Classes


TnxFiFoBuffer Members

TnxFiFoBuffer Members
TnxFiFoBuffer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFiFoBuffer.

Class

TnxFiFoBuffer Class

Protected Fields
Name | Description
ffbCanWrite | This is ffbCanWrite, a member of class TnxFiFoBuffer.
ffbCurrentWritePage | This is ffbCurrentWritePage, a member of class TnxFiFoBuffer.
ffbDataAvailable | This is ffbDataAvailable, a member of class TnxFiFoBuffer.
ffbLock | This is ffbLock, a member of class TnxFiFoBuffer.
ffbMaxPageCount | This is ffbMaxPageCount, a member of class TnxFiFoBuffer.
ffbMaxWriteTime | This is ffbMaxWriteTime, a member of class TnxFiFoBuffer.
ffbMinKeepCount | This is ffbMinKeepCount, a member of class TnxFiFoBuffer.
ffbPageCount | private
ffbPageSize | This is ffbPageSize, a member of class TnxFiFoBuffer.
ffbRecycleListHead | This is ffbRecycleListHead, a member of class TnxFiFoBuffer.
ffbShuttingDown | This is ffbShuttingDown, a member of class TnxFiFoBuffer.
ffbUsedListHead | This is ffbUsedListHead, a member of class TnxFiFoBuffer.
ffbUsedListTail | This is ffbUsedListTail, a member of class TnxFiFoBuffer.
Protected Methods
Name | Description
GetPageClass |
Public Methods
Name | Description
Create |
Destroy |
FreeInstance |
GetReadPage |
GetWritePage |
NewInstance | TnxObject
Shutdown |
Public Properties
Name | Description
PageSize | This is PageSize, a member of class TnxFiFoBuffer.
ShuttingDown | This is ShuttingDown, a member of class TnxFiFoBuffer.
Links
TnxFiFoBuffer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFiFoBuffer.Create Constructor

TnxFiFoBuffer.Create Constructor
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Class Send Feedback
Syntax
Delphi
constructor Create(aPageSize: Cardinal; aMinKeepCount: Integer; aMaxPageCount: Integer = NoPageCountLimit; aMaxWriteTime: Integer = NoWaitLimit); override;
Class

TnxFiFoBuffer Class

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Class


TnxFiFoBuffer.Destroy Destructor

TnxFiFoBuffer.Destroy Destructor
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFiFoBuffer Class

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Class


TnxFiFoBuffer Fields

TnxFiFoBuffer Fields
TnxFiFoBuffer Class Legend Protected Fields Send Feedback

The fields of the TnxFiFoBuffer class are listed here.

Class

TnxFiFoBuffer Class

Protected Fields
Name | Description
ffbCanWrite | This is ffbCanWrite, a member of class TnxFiFoBuffer.
ffbCurrentWritePage | This is ffbCurrentWritePage, a member of class TnxFiFoBuffer.
ffbDataAvailable | This is ffbDataAvailable, a member of class TnxFiFoBuffer.
ffbLock | This is ffbLock, a member of class TnxFiFoBuffer.
ffbMaxPageCount | This is ffbMaxPageCount, a member of class TnxFiFoBuffer.
ffbMaxWriteTime | This is ffbMaxWriteTime, a member of class TnxFiFoBuffer.
ffbMinKeepCount | This is ffbMinKeepCount, a member of class TnxFiFoBuffer.
ffbPageCount | private
ffbPageSize | This is ffbPageSize, a member of class TnxFiFoBuffer.
ffbRecycleListHead | This is ffbRecycleListHead, a member of class TnxFiFoBuffer.
ffbShuttingDown | This is ffbShuttingDown, a member of class TnxFiFoBuffer.
ffbUsedListHead | This is ffbUsedListHead, a member of class TnxFiFoBuffer.
ffbUsedListTail | This is ffbUsedListTail, a member of class TnxFiFoBuffer.
Links
TnxFiFoBuffer Class, Legend, Protected Fields


TnxFiFoBuffer.ffbCanWrite Field

TnxFiFoBuffer.ffbCanWrite Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbCanWrite: THandle;
Description

This is ffbCanWrite, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbCurrentWritePage Field

TnxFiFoBuffer.ffbCurrentWritePage Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbCurrentWritePage: TnxBufferPage;
Description

This is ffbCurrentWritePage, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbDataAvailable Field

TnxFiFoBuffer.ffbDataAvailable Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbDataAvailable: THandle;
Description

This is ffbDataAvailable, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbLock Field

TnxFiFoBuffer.ffbLock Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbLock: TnxPadlock;
Description

This is ffbLock, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbMaxPageCount Field

TnxFiFoBuffer.ffbMaxPageCount Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbMaxPageCount: Integer;
Description

This is ffbMaxPageCount, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbMaxWriteTime Field

TnxFiFoBuffer.ffbMaxWriteTime Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbMaxWriteTime: Integer;
Description

This is ffbMaxWriteTime, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbMinKeepCount Field

TnxFiFoBuffer.ffbMinKeepCount Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbMinKeepCount: Integer;
Description

This is ffbMinKeepCount, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbPageCount Field

TnxFiFoBuffer.ffbPageCount Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbPageCount: Integer;
Description

private

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbPageSize Field

TnxFiFoBuffer.ffbPageSize Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbPageSize: Integer;
Description

This is ffbPageSize, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbRecycleListHead Field

TnxFiFoBuffer.ffbRecycleListHead Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbRecycleListHead: TnxBufferPage;
Description

This is ffbRecycleListHead, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbShuttingDown Field

TnxFiFoBuffer.ffbShuttingDown Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbShuttingDown: Boolean;
Description

This is ffbShuttingDown, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbUsedListHead Field

TnxFiFoBuffer.ffbUsedListHead Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbUsedListHead: TnxBufferPage;
Description

This is ffbUsedListHead, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer.ffbUsedListTail Field

TnxFiFoBuffer.ffbUsedListTail Field
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Fields Send Feedback
Syntax
Delphi
ffbUsedListTail: TnxBufferPage;
Description

This is ffbUsedListTail, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Fields

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Fields


TnxFiFoBuffer Methods

TnxFiFoBuffer Methods
TnxFiFoBuffer Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFiFoBuffer class are listed here.

Class

TnxFiFoBuffer Class

Protected Methods
Name | Description
GetPageClass |
Public Methods
Name | Description
GetReadPage |
GetWritePage |
Shutdown |
Links
TnxFiFoBuffer Class, Legend, Protected Methods, Public Methods


TnxFiFoBuffer.GetPageClass Method

TnxFiFoBuffer.GetPageClass Method
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetPageClass: TnxBufferPageClass; override;
Group

TnxFiFoBuffer Methods

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Methods


TnxFiFoBuffer.GetReadPage Method

TnxFiFoBuffer.GetReadPage Method
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetReadPage(aWaitForData: Boolean; aExceptOnShutdown: Boolean): TnxBufferPage; override;
Group

TnxFiFoBuffer Methods

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Methods


TnxFiFoBuffer.GetWritePage Method

TnxFiFoBuffer.GetWritePage Method
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Methods Send Feedback
Syntax
Delphi
function GetWritePage(aSize: Cardinal = DefaultPageSize; aNoWait: Boolean = False): TnxBufferPage; override;
Group

TnxFiFoBuffer Methods

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Methods


TnxFiFoBuffer.Shutdown Method

TnxFiFoBuffer.Shutdown Method
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Methods Send Feedback
Syntax
Delphi
procedure Shutdown; override;
Group

TnxFiFoBuffer Methods

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Methods


TnxFiFoBuffer Properties

TnxFiFoBuffer Properties
TnxFiFoBuffer Class Legend Public Properties Send Feedback

The properties of the TnxFiFoBuffer class are listed here.

Class

TnxFiFoBuffer Class

Public Properties
Name | Description
PageSize | This is PageSize, a member of class TnxFiFoBuffer.
ShuttingDown | This is ShuttingDown, a member of class TnxFiFoBuffer.
Links
TnxFiFoBuffer Class, Legend, Public Properties


TnxFiFoBuffer.PageSize Property

TnxFiFoBuffer.PageSize Property
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Properties Send Feedback
Syntax
Delphi
property PageSize: Integer;
Description

This is PageSize, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Properties

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Properties


TnxFiFoBuffer.ShuttingDown Property

TnxFiFoBuffer.ShuttingDown Property
TnxFiFoBuffer Class TnxFiFoBuffer Members nxllFiFo Namespace TnxFiFoBuffer Properties Send Feedback
Syntax
Delphi
property ShuttingDown: Boolean;
Description

This is ShuttingDown, a member of class TnxFiFoBuffer.

Group

TnxFiFoBuffer Properties

Links
TnxFiFoBuffer Class, TnxFiFoBuffer Members, nxllFiFo Namespace, TnxFiFoBuffer Properties


TnxFifoReadStream Class

TnxFifoReadStream Class
TnxFifoReadStream Fields TnxFifoReadStream Methods TnxFifoReadStream Members nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_TnxFifoReadStream
Syntax
Delphi
TnxFifoReadStream = class(TStream);
File

nxllFiFo

Description

This is class nxllFiFo.TnxFifoReadStream.

Group

Classes

Links
TnxFifoReadStream Fields, TnxFifoReadStream Methods, TnxFifoReadStream Members, nxllFiFo, Classes


TnxFifoReadStream Members

TnxFifoReadStream Members
TnxFifoReadStream Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxFifoReadStream.

Class

TnxFifoReadStream Class

Protected Fields
Name | Description
frsCurrentPage | This is frsCurrentPage, a member of class TnxFifoReadStream.
frsEos | This is frsEos, a member of class TnxFifoReadStream.
frsFiFo | private
Public Methods
Name | Description
Create |
Destroy |
Read |
Seek |
Links
TnxFifoReadStream Class, Legend, Protected Fields, Public Methods


TnxFifoReadStream.Create Constructor

TnxFifoReadStream.Create Constructor
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Class Send Feedback
Syntax
Delphi
constructor Create(aFiFo: TnxBaseFiFoBuffer);
Class

TnxFifoReadStream Class

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Class


TnxFifoReadStream.Destroy Destructor

TnxFifoReadStream.Destroy Destructor
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFifoReadStream Class

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Class


TnxFifoReadStream Fields

TnxFifoReadStream Fields
TnxFifoReadStream Class Legend Protected Fields Send Feedback

The fields of the TnxFifoReadStream class are listed here.

Class

TnxFifoReadStream Class

Protected Fields
Name | Description
frsCurrentPage | This is frsCurrentPage, a member of class TnxFifoReadStream.
frsEos | This is frsEos, a member of class TnxFifoReadStream.
frsFiFo | private
Links
TnxFifoReadStream Class, Legend, Protected Fields


TnxFifoReadStream.frsCurrentPage Field

TnxFifoReadStream.frsCurrentPage Field
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Fields Send Feedback
Syntax
Delphi
frsCurrentPage: TnxBufferPage;
Description

This is frsCurrentPage, a member of class TnxFifoReadStream.

Group

TnxFifoReadStream Fields

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Fields


TnxFifoReadStream.frsEos Field

TnxFifoReadStream.frsEos Field
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Fields Send Feedback
Syntax
Delphi
frsEos: Boolean;
Description

This is frsEos, a member of class TnxFifoReadStream.

Group

TnxFifoReadStream Fields

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Fields


TnxFifoReadStream.frsFiFo Field

TnxFifoReadStream.frsFiFo Field
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Fields Send Feedback
Syntax
Delphi
frsFiFo: TnxBaseFiFoBuffer;
Description

private

Group

TnxFifoReadStream Fields

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Fields


TnxFifoReadStream Methods

TnxFifoReadStream Methods
TnxFifoReadStream Class Legend Public Methods Send Feedback

The methods of the TnxFifoReadStream class are listed here.

Class

TnxFifoReadStream Class

Public Methods
Name | Description
Read |
Seek |
Links
TnxFifoReadStream Class, Legend, Public Methods


TnxFifoReadStream.Read Method

TnxFifoReadStream.Read Method
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; override;
Group

TnxFifoReadStream Methods

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Methods


TnxFifoReadStream.Seek Method

TnxFifoReadStream.Seek Method
TnxFifoReadStream Class TnxFifoReadStream Members nxllFiFo Namespace TnxFifoReadStream Methods Send Feedback
Syntax
Delphi
function Seek(Offset: Integer; Origin: Word): Integer; override;
Group

TnxFifoReadStream Methods

Links
TnxFifoReadStream Class, TnxFifoReadStream Members, nxllFiFo Namespace, TnxFifoReadStream Methods


TnxFifoWriteStream Class

TnxFifoWriteStream Class
TnxFifoWriteStream Fields TnxFifoWriteStream Methods TnxFifoWriteStream Members nxllFiFo Classes Send Feedback
Class Hierarchy
nxllFiFo_TnxFifoWriteStream
Syntax
Delphi
TnxFifoWriteStream = class(TStream);
File

nxllFiFo

Description

This is class nxllFiFo.TnxFifoWriteStream.

Group

Classes

Links
TnxFifoWriteStream Fields, TnxFifoWriteStream Methods, TnxFifoWriteStream Members, nxllFiFo, Classes


TnxFifoWriteStream Members

TnxFifoWriteStream Members
TnxFifoWriteStream Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxFifoWriteStream.

Class

TnxFifoWriteStream Class

Protected Fields
Name | Description
frsCurrentPage | This is frsCurrentPage, a member of class TnxFifoWriteStream.
frsFiFo | private
Public Methods
Name | Description
Create |
Destroy |
Flush |
Seek |
Write |
Links
TnxFifoWriteStream Class, Legend, Protected Fields, Public Methods


TnxFifoWriteStream.Create Constructor

TnxFifoWriteStream.Create Constructor
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Class Send Feedback
Syntax
Delphi
constructor Create(aFiFo: TnxBaseFiFoBuffer);
Class

TnxFifoWriteStream Class

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Class


TnxFifoWriteStream.Destroy Destructor

TnxFifoWriteStream.Destroy Destructor
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFifoWriteStream Class

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Class


TnxFifoWriteStream Fields

TnxFifoWriteStream Fields
TnxFifoWriteStream Class Legend Protected Fields Send Feedback

The fields of the TnxFifoWriteStream class are listed here.

Class

TnxFifoWriteStream Class

Protected Fields
Name | Description
frsCurrentPage | This is frsCurrentPage, a member of class TnxFifoWriteStream.
frsFiFo | private
Links
TnxFifoWriteStream Class, Legend, Protected Fields


TnxFifoWriteStream.frsCurrentPage Field

TnxFifoWriteStream.frsCurrentPage Field
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Fields Send Feedback
Syntax
Delphi
frsCurrentPage: TnxBufferPage;
Description

This is frsCurrentPage, a member of class TnxFifoWriteStream.

Group

TnxFifoWriteStream Fields

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Fields


TnxFifoWriteStream.frsFiFo Field

TnxFifoWriteStream.frsFiFo Field
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Fields Send Feedback
Syntax
Delphi
frsFiFo: TnxBaseFiFoBuffer;
Description

private

Group

TnxFifoWriteStream Fields

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Fields


TnxFifoWriteStream Methods

TnxFifoWriteStream Methods
TnxFifoWriteStream Class Legend Public Methods Send Feedback

The methods of the TnxFifoWriteStream class are listed here.

Class

TnxFifoWriteStream Class

Public Methods
Name | Description
Flush |
Seek |
Write |
Links
TnxFifoWriteStream Class, Legend, Public Methods


TnxFifoWriteStream.Flush Method

TnxFifoWriteStream.Flush Method
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Methods Send Feedback
Syntax
Delphi
procedure Flush(aLastPage: Boolean);
Group

TnxFifoWriteStream Methods

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Methods


TnxFifoWriteStream.Seek Method

TnxFifoWriteStream.Seek Method
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Methods Send Feedback
Syntax
Delphi
function Seek(Offset: Integer; Origin: Word): Integer; override;
Group

TnxFifoWriteStream Methods

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Methods


TnxFifoWriteStream.Write Method

TnxFifoWriteStream.Write Method
TnxFifoWriteStream Class TnxFifoWriteStream Members nxllFiFo Namespace TnxFifoWriteStream Methods Send Feedback
Syntax
Delphi
function Write(const Buffer; Count: Integer): Integer; override;
Group

TnxFifoWriteStream Methods

Links
TnxFifoWriteStream Class, TnxFifoWriteStream Members, nxllFiFo Namespace, TnxFifoWriteStream Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllFiFo Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBufferMarker | This is record nxllFiFo.TnxBufferMarker.
TnxBufferPageState | This is record nxllFiFo.TnxBufferPageState.
Namespace

nxllFiFo Namespace

Links
Enumerations, nxllFiFo Namespace, Legend


nxllFiFo.TnxBufferMarker Enumeration

nxllFiFo.TnxBufferMarker Enumeration
nxllFiFo Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBufferMarker = ( bmNone, bmLastBuffer );
File

nxllFiFo

Description

This is record nxllFiFo.TnxBufferMarker.

Group

Structs, Records, Enums

Links
nxllFiFo, Structs, Records, Enums


nxllFiFo.TnxBufferPageState Enumeration

nxllFiFo.TnxBufferPageState Enumeration
nxllFiFo Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBufferPageState = ( bpsUnassigned, bpsCurrentWritePage, bpsQueued, bpsRecycled );
File

nxllFiFo

Description

This is record nxllFiFo.TnxBufferPageState.

Group

Structs, Records, Enums

Links
nxllFiFo, Structs, Records, Enums


Types

Types
nxllFiFo Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllFiFo Namespace

Types
Name | Description
TnxBufferPageClass | This is type nxllFiFo.TnxBufferPageClass.
Links
nxllFiFo Namespace, Types


nxllFiFo.TnxBufferPageClass Type

nxllFiFo.TnxBufferPageClass Type
nxllFiFo Types Send Feedback
Syntax
Delphi
TnxBufferPageClass = class of TnxBufferPage;
File

nxllFiFo

Description

This is type nxllFiFo.TnxBufferPageClass.

Group

Types

Links
nxllFiFo, Types


Constants

Constants
Constants nxllFiFo Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DefaultPageSize | This is constant nxllFiFo.DefaultPageSize.
NoPageCountLimit | This is constant nxllFiFo.NoPageCountLimit.
NoWaitLimit | This is constant nxllFiFo.NoWaitLimit.
Namespace

nxllFiFo Namespace

Links
Constants, nxllFiFo Namespace


nxllFiFo.DefaultPageSize Constant

nxllFiFo.DefaultPageSize Constant
nxllFiFo Constants Send Feedback
Syntax
Delphi
DefaultPageSize = 0;
File

nxllFiFo

Description

This is constant nxllFiFo.DefaultPageSize.

Group

Constants

Links
nxllFiFo, Constants


nxllFiFo.NoPageCountLimit Constant

nxllFiFo.NoPageCountLimit Constant
nxllFiFo Constants Send Feedback
Syntax
Delphi
NoPageCountLimit = 0;
File

nxllFiFo

Description

This is constant nxllFiFo.NoPageCountLimit.

Group

Constants

Links
nxllFiFo, Constants


nxllFiFo.NoWaitLimit Constant

nxllFiFo.NoWaitLimit Constant
nxllFiFo Constants Send Feedback
Syntax
Delphi
NoWaitLimit = 0;
File

nxllFiFo

Description

This is constant nxllFiFo.NoWaitLimit.

Group

Constants

Links
nxllFiFo, Constants


nxllFiler Namespace

nxllFiler Namespace
Classes Constants Interfaces Legend Structs, Records, Enums Topics Variables Send Feedback

This is namespace nxllFiler.

Classes
Name | Description
TFiler | This is class nxllFiler.TFiler.
TReader | TReader
TWriter | TWriter
Constants
Name | Description
SInvalidPropertyValue | This is constant nxllFiler.SInvalidPropertyValue.
SReadError | This is constant nxllFiler.SReadError.
SWriteError | This is constant nxllFiler.SWriteError.
Interfaces
Name | Description
IVarStreamable | This is class nxllFiler.IVarStreamable.
Structs, Records, Enums
Name | Description
TValueType | TFiler
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
ReadNo | This is variable nxllFiler.ReadNo.
Links
Classes, Constants, Interfaces, Legend, Structs, Records, Enums, Topics, Variables


Classes

Classes
Classes nxllFiler Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TFiler | This is class nxllFiler.TFiler.
TReader | TReader
TWriter | TWriter
Namespace

nxllFiler Namespace

Links
Classes, nxllFiler Namespace, Legend


TFiler Class

TFiler Class
TFiler Methods TFiler Members nxllFiler Classes Send Feedback
Class Hierarchy
nxllFiler_TFiler
Syntax
Delphi
TFiler = class(TObject);
File

nxllFiler

Description

This is class nxllFiler.TFiler.

Group

Classes

Links
TFiler Methods, TFiler Members, nxllFiler, Classes


TFiler Members

TFiler Members
TFiler Class Legend Public Methods Send Feedback

The following tables list the members exposed by TFiler.

Class

TFiler Class

Public Methods
Name | Description
Create | TFiler
Destroy | This is Destroy, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TFiler.
Links
TFiler Class, Legend, Public Methods


TFiler.Create Constructor

TFiler.Create Constructor
TFiler Class TFiler Members nxllFiler Namespace TFiler Class Send Feedback
Syntax
Delphi
constructor Create(Stream: TStream; BufSize: Integer);
Description

TFiler

Class

TFiler Class

Links
TFiler Class, TFiler Members, nxllFiler Namespace, TFiler Class


TFiler.Destroy Destructor

TFiler.Destroy Destructor
TFiler Class TFiler Members nxllFiler Namespace TFiler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TFiler.

Class

TFiler Class

Links
TFiler Class, TFiler Members, nxllFiler Namespace, TFiler Class


TFiler Methods

TFiler Methods
TFiler Class Legend Public Methods Send Feedback

The methods of the TFiler class are listed here.

Class

TFiler Class

Public Methods
Name | Description
FlushBuffer | This is FlushBuffer, a member of class TFiler.
Links
TFiler Class, Legend, Public Methods


TFiler.FlushBuffer Method

TFiler.FlushBuffer Method
TFiler Class TFiler Members nxllFiler Namespace TFiler Methods Send Feedback
Syntax
Delphi
procedure FlushBuffer; virtual; abstract;
Description

This is FlushBuffer, a member of class TFiler.

Group

TFiler Methods

Links
TFiler Class, TFiler Members, nxllFiler Namespace, TFiler Methods


TReader Class

TReader Class
TReader Methods TReader Properties TReader Members nxllFiler Classes Send Feedback
Class Hierarchy
nxllFiler_TReadernxllFiler_TReader
Syntax
Delphi
TReader = class(TFiler);
File

nxllFiler

Description

TReader

Group

Classes

Links
TReader Methods, TReader Properties, TReader Members, nxllFiler, Classes


TReader Members

TReader Members
TReader Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TReader.

Class

TReader Class

Protected Methods
Name | Description
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
Create | TFiler
Destroy | This is Destroy, a member of class TReader.
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadFloat | This is ReadFloat, a member of class TReader.
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideString | This is ReadWideString, a member of class TReader.
Public Properties
Name | Description
Position | This is Position, a member of class TReader.
Links
TReader Class, Legend, Protected Methods, Public Methods, Public Properties


TReader.Destroy Destructor

TReader.Destroy Destructor
TReader Class TReader Members nxllFiler Namespace TReader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TReader.

Class

TReader Class

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Class


TReader Methods

TReader Methods
TReader Class Legend Protected Methods Public Methods Send Feedback

The methods of the TReader class are listed here.

Class

TReader Class

Protected Methods
Name | Description
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadFloat | This is ReadFloat, a member of class TReader.
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideString | This is ReadWideString, a member of class TReader.
Links
TReader Class, Legend, Protected Methods, Public Methods


TReader.CheckValue Method

TReader.CheckValue Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure CheckValue(Value: TValueType);
Description

This is CheckValue, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.EndOfList Method

TReader.EndOfList Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function EndOfList: Boolean;
Description

This is EndOfList, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.FlushBuffer Method

TReader.FlushBuffer Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure FlushBuffer; override;
Description

This is FlushBuffer, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.NextValue Method

TReader.NextValue Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function NextValue: TValueType;
Description

This is NextValue, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.Read Method

TReader.Read Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure Read(var Buf; Count: Longint);
Description

This is Read, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadBoolean Method

TReader.ReadBoolean Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadBoolean: Boolean;
Description

This is ReadBoolean, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadChar Method

TReader.ReadChar Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadChar: Char;
Description

This is ReadChar, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadCurrency Method

TReader.ReadCurrency Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadCurrency: Currency;
Description

This is ReadCurrency, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadDate Method

TReader.ReadDate Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadDate: TDateTime;
Description

This is ReadDate, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadDouble Method

TReader.ReadDouble Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadDouble: Double;
Description

This is ReadDouble, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadFloat Method

TReader.ReadFloat Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadFloat: Extended;
Description

This is ReadFloat, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadIdent Method

TReader.ReadIdent Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadIdent: string;
Description

This is ReadIdent, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadInt64 Method

TReader.ReadInt64 Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadInt64: Int64;
Description

This is ReadInt64, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadInteger Method

TReader.ReadInteger Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadInteger: Longint;
Description

This is ReadInteger, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadInternal Method

TReader.ReadInternal Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure ReadInternal(var Buf; Count: Longint);
Description

This is ReadInternal, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadListBegin Method

TReader.ReadListBegin Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure ReadListBegin;
Description

This is ReadListBegin, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadListEnd Method

TReader.ReadListEnd Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure ReadListEnd;
Description

This is ReadListEnd, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadSingle Method

TReader.ReadSingle Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadSingle: Single;
Description

This is ReadSingle, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadStr Method

TReader.ReadStr Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadStr: string;
Description

This is ReadStr, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadString Method

TReader.ReadString Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadString: string;
Description

This is ReadString, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadValue Method

TReader.ReadValue Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadValue: TValueType;
Description

This is ReadValue, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadVariant Method

TReader.ReadVariant Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadVariant: Variant;
Description

This is ReadVariant, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadWideChar Method

TReader.ReadWideChar Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadWideChar: WideChar;
Description

This is ReadWideChar, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.ReadWideString Method

TReader.ReadWideString Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
function ReadWideString: UnicodeString;
Description

This is ReadWideString, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader.SetPosition Method

TReader.SetPosition Method
TReader Class TReader Members nxllFiler Namespace TReader Methods Send Feedback
Syntax
Delphi
procedure SetPosition(Value: Longint);
Description

This is SetPosition, a member of class TReader.

Group

TReader Methods

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Methods


TReader Properties

TReader Properties
TReader Class Legend Public Properties Send Feedback

The properties of the TReader class are listed here.

Class

TReader Class

Public Properties
Name | Description
Position | This is Position, a member of class TReader.
Links
TReader Class, Legend, Public Properties


TReader.Position Property

TReader.Position Property
TReader Class TReader Members nxllFiler Namespace TReader Properties Send Feedback
Syntax
Delphi
property Position: Longint;
Description

This is Position, a member of class TReader.

Group

TReader Properties

Links
TReader Class, TReader Members, nxllFiler Namespace, TReader Properties


TWriter Class

TWriter Class
TWriter Methods TWriter Properties TWriter Members nxllFiler Classes Send Feedback
Class Hierarchy
nxllFiler_TWriternxllFiler_TWriter
Syntax
Delphi
TWriter = class(TFiler);
File

nxllFiler

Description

TWriter

Group

Classes

Links
TWriter Methods, TWriter Properties, TWriter Members, nxllFiler, Classes


TWriter Members

TWriter Members
TWriter Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TWriter.

Class

TWriter Class

Protected Methods
Name | Description
WriteBinary | This is WriteBinary, a member of class TWriter.
WriteValue | This is WriteValue, a member of class TWriter.
Public Methods
Name | Description
Create | TFiler
Destroy | TWriter
FlushBuffer | This is FlushBuffer, a member of class TWriter.
Write | This is Write, a member of class TWriter.
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDouble | This is WriteDouble, a member of class TWriter.
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteWideChar | This is WriteWideChar, a member of class TWriter.
WriteWideString | This is WriteWideString, a member of class TWriter.
Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TWriter Class, Legend, Protected Methods, Public Methods, Public Properties


TWriter.Destroy Destructor

TWriter.Destroy Destructor
TWriter Class TWriter Members nxllFiler Namespace TWriter Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

TWriter

Class

TWriter Class

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Class


TWriter Methods

TWriter Methods
TWriter Class Legend Protected Methods Public Methods Send Feedback

The methods of the TWriter class are listed here.

Class

TWriter Class

Protected Methods
Name | Description
WriteBinary | This is WriteBinary, a member of class TWriter.
WriteValue | This is WriteValue, a member of class TWriter.
Public Methods
Name | Description
FlushBuffer | This is FlushBuffer, a member of class TWriter.
Write | This is Write, a member of class TWriter.
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDouble | This is WriteDouble, a member of class TWriter.
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteWideChar | This is WriteWideChar, a member of class TWriter.
WriteWideString | This is WriteWideString, a member of class TWriter.
Links
TWriter Class, Legend, Protected Methods, Public Methods


TWriter.FlushBuffer Method

TWriter.FlushBuffer Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure FlushBuffer; override;
Description

This is FlushBuffer, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.Write Method

TWriter.Write Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure Write(const Buf; Count: Longint);
Description

This is Write, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteBinary Method

TWriter.WriteBinary Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBinary(WriteData: TStreamProc);
Description

This is WriteBinary, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteBoolean Method

TWriter.WriteBoolean Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBoolean(Value: Boolean);
Description

This is WriteBoolean, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteChar Method

TWriter.WriteChar Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteChar(Value: Char);
Description

This is WriteChar, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteCurrency Method

TWriter.WriteCurrency Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteCurrency(const Value: Currency);
Description

This is WriteCurrency, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteDate Method

TWriter.WriteDate Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteDate(const Value: TDateTime);
Description

This is WriteDate, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteDouble Method

TWriter.WriteDouble Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteDouble(const Value: Double);
Description

This is WriteDouble, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteFloat Method

TWriter.WriteFloat Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteFloat(const Value: Extended);
Description

This is WriteFloat, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteIdent Method

TWriter.WriteIdent Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteIdent(const Ident: string);
Description

This is WriteIdent, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


WriteInteger Method

WriteInteger Method
TWriter Methods Send Feedback

This is the overview for the WriteInteger method overload.

Overload List
Name | Description
TWriter.WriteInteger (Int64) | This is WriteInteger, a member of class TWriter.
TWriter.WriteInteger (Longint) | This is WriteInteger, a member of class TWriter.
Group

TWriter Methods

Links
TWriter Methods


TWriter.WriteInteger Method (Int64)

TWriter.WriteInteger Method (Int64)
TWriter Class TWriter Members nxllFiler Namespace WriteInteger Method Send Feedback
Syntax
Delphi
procedure WriteInteger(Value: Int64); overload;
Description

This is WriteInteger, a member of class TWriter.

Group

WriteInteger Method

Links
TWriter Class, TWriter Members, nxllFiler Namespace, WriteInteger Method


TWriter.WriteInteger Method (Longint)

TWriter.WriteInteger Method (Longint)
TWriter Class TWriter Members nxllFiler Namespace WriteInteger Method Send Feedback
Syntax
Delphi
procedure WriteInteger(Value: Longint); overload;
Description

This is WriteInteger, a member of class TWriter.

Group

WriteInteger Method

Links
TWriter Class, TWriter Members, nxllFiler Namespace, WriteInteger Method


TWriter.WriteListBegin Method

TWriter.WriteListBegin Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteListBegin;
Description

This is WriteListBegin, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteListEnd Method

TWriter.WriteListEnd Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteListEnd;
Description

This is WriteListEnd, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteSingle Method

TWriter.WriteSingle Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteSingle(const Value: Single);
Description

This is WriteSingle, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteStr Method

TWriter.WriteStr Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteStr(const Value: string);
Description

This is WriteStr, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteString Method

TWriter.WriteString Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteString(const Value: string);
Description

This is WriteString, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteValue Method

TWriter.WriteValue Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteValue(Value: TValueType);
Description

This is WriteValue, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteVariant Method

TWriter.WriteVariant Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteVariant(const Value: Variant);
Description

This is WriteVariant, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteWideChar Method

TWriter.WriteWideChar Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideChar(Value: WideChar);
Description

This is WriteWideChar, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter.WriteWideString Method

TWriter.WriteWideString Method
TWriter Class TWriter Members nxllFiler Namespace TWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideString(const Value: UnicodeString);
Description

This is WriteWideString, a member of class TWriter.

Group

TWriter Methods

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Methods


TWriter Properties

TWriter Properties
TWriter Class Legend Public Properties Send Feedback

The properties of the TWriter class are listed here.

Class

TWriter Class

Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TWriter Class, Legend, Public Properties


TWriter.Position Property

TWriter.Position Property
TWriter Class TWriter Members nxllFiler Namespace TWriter Properties Send Feedback
Syntax
Delphi
property Position: Longint;
Description

This is Position, a member of class TWriter.

Group

TWriter Properties

Links
TWriter Class, TWriter Members, nxllFiler Namespace, TWriter Properties


Interfaces

Interfaces
nxllFiler Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllFiler Namespace

Interfaces
Name | Description
IVarStreamable | This is class nxllFiler.IVarStreamable.
Links
nxllFiler Namespace, Interfaces, Legend


IVarStreamable Interface

IVarStreamable Interface
IVarStreamable Methods IVarStreamable Members nxllFiler Interfaces Send Feedback
Class Hierarchy
nxllFiler_IVarStreamable
Syntax
Delphi
IVarStreamable = interface;
File

nxllFiler

Description

This is class nxllFiler.IVarStreamable.

Group

Interfaces

Links
IVarStreamable Methods, IVarStreamable Members, nxllFiler, Interfaces


IVarStreamable Members

IVarStreamable Members
IVarStreamable Interface Legend Public Methods Send Feedback

The following tables list the members exposed by IVarStreamable.

Interface

IVarStreamable Interface

Public Methods
Name | Description
StreamIn | This is StreamIn, a member of class IVarStreamable.
StreamOut | This is StreamOut, a member of class IVarStreamable.
Links
IVarStreamable Interface, Legend, Public Methods


IVarStreamable Methods

IVarStreamable Methods
IVarStreamable Interface Legend Public Methods Send Feedback

The methods of the IVarStreamable class are listed here.

Interface

IVarStreamable Interface

Public Methods
Name | Description
StreamIn | This is StreamIn, a member of class IVarStreamable.
StreamOut | This is StreamOut, a member of class IVarStreamable.
Links
IVarStreamable Interface, Legend, Public Methods


IVarStreamable.StreamIn Method

IVarStreamable.StreamIn Method
IVarStreamable Interface IVarStreamable Members nxllFiler Namespace IVarStreamable Methods Send Feedback
Syntax
Delphi
procedure StreamIn(var Dest: TVarData; const Stream: TStream);
Description

This is StreamIn, a member of class IVarStreamable.

Group

IVarStreamable Methods

Links
IVarStreamable Interface, IVarStreamable Members, nxllFiler Namespace, IVarStreamable Methods


IVarStreamable.StreamOut Method

IVarStreamable.StreamOut Method
IVarStreamable Interface IVarStreamable Members nxllFiler Namespace IVarStreamable Methods Send Feedback
Syntax
Delphi
procedure StreamOut(const Source: TVarData; const Stream: TStream);
Description

This is StreamOut, a member of class IVarStreamable.

Group

IVarStreamable Methods

Links
IVarStreamable Interface, IVarStreamable Members, nxllFiler Namespace, IVarStreamable Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllFiler Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TValueType | TFiler
Namespace

nxllFiler Namespace

Links
Enumerations, nxllFiler Namespace, Legend


nxllFiler.TValueType Enumeration

nxllFiler.TValueType Enumeration
nxllFiler Structs, Records, Enums Send Feedback
Syntax
Delphi
TValueType = ( vaNull, vaList, vaInt8, vaInt16, vaInt32, vaExtended, vaString, vaIdent, vaFalse, vaTrue, vaBinary, vaSet, vaLString, vaNil, vaCollection, vaSingle, vaCurrency, vaDate, vaWString, vaInt64, vaUTF8String, vaDouble );
File

nxllFiler

Description

TFiler

Group

Structs, Records, Enums

Links
nxllFiler, Structs, Records, Enums


Variables

Variables
nxllFiler Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllFiler Namespace

Variables
Name | Description
ReadNo | This is variable nxllFiler.ReadNo.
Links
nxllFiler Namespace, Variables


nxllFiler.ReadNo Variable

nxllFiler.ReadNo Variable
nxllFiler Variables Send Feedback
Syntax
Delphi
ReadNo: Integer;
File

nxllFiler

Description

This is variable nxllFiler.ReadNo.

Group

Variables

Links
nxllFiler, Variables


Constants

Constants
Constants nxllFiler Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
SInvalidPropertyValue | This is constant nxllFiler.SInvalidPropertyValue.
SReadError | This is constant nxllFiler.SReadError.
SWriteError | This is constant nxllFiler.SWriteError.
Namespace

nxllFiler Namespace

Links
Constants, nxllFiler Namespace


nxllFiler.SInvalidPropertyValue Constant

nxllFiler.SInvalidPropertyValue Constant
nxllFiler Constants Send Feedback
Syntax
Delphi
SInvalidPropertyValue = 'Invalid property value';
File

nxllFiler

Description

This is constant nxllFiler.SInvalidPropertyValue.

Group

Constants

Links
nxllFiler, Constants


nxllFiler.SReadError Constant

nxllFiler.SReadError Constant
nxllFiler Constants Send Feedback
Syntax
Delphi
SReadError = 'Stream read error';
File

nxllFiler

Description

This is constant nxllFiler.SReadError.

Group

Constants

Links
nxllFiler, Constants


nxllFiler.SWriteError Constant

nxllFiler.SWriteError Constant
nxllFiler Constants Send Feedback
Syntax
Delphi
SWriteError = 'Stream write error';
File

nxllFiler

Description

This is constant nxllFiler.SWriteError.

Group

Constants

Links
nxllFiler, Constants


nxllJwaIpExport Namespace

nxllJwaIpExport Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

Id: JwaIpExport.pas,v 1.11 2007/09/14 06:48:46 marquardt Exp

Constants
Name | Description
IOCTL_ARP_SEND_REQUEST | This is constant nxllJwaIpExport.IOCTL_ARP_SEND_REQUEST.
IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST | This is constant nxllJwaIpExport.IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST.
IOCTL_IP_GET_BEST_INTERFACE | This is constant nxllJwaIpExport.IOCTL_IP_GET_BEST_INTERFACE.
IOCTL_IP_INTERFACE_INFO | This is constant nxllJwaIpExport.IOCTL_IP_INTERFACE_INFO.
IOCTL_IP_RTCHANGE_NOTIFY_REQUEST | Ioctls code exposed by Memphis tcpip stack. For NT these ioctls are define in ntddip.h (privateinc)
IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS | This is constant nxllJwaIpExport.IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
IP_ADDR_ADDED | This is constant nxllJwaIpExport.IP_ADDR_ADDED.
IP_ADDR_DELETED | The next group are status codes passed up on status indications to transport layer protocols.
IP_BAD_DESTINATION | This is constant nxllJwaIpExport.IP_BAD_DESTINATION.
IP_BAD_HEADER | This is constant nxllJwaIpExport.IP_BAD_HEADER.
IP_BAD_OPTION | This is constant nxllJwaIpExport.IP_BAD_OPTION.
IP_BAD_REQ | This is constant nxllJwaIpExport.IP_BAD_REQ.
IP_BAD_ROUTE | This is constant nxllJwaIpExport.IP_BAD_ROUTE.
IP_BIND_ADAPTER | This is constant nxllJwaIpExport.IP_BIND_ADAPTER.
IP_BUF_TOO_SMALL | This is constant nxllJwaIpExport.IP_BUF_TOO_SMALL.
IP_DEST_ADDR_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_ADDR_UNREACHABLE.
IP_DEST_HOST_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_HOST_UNREACHABLE.
IP_DEST_NET_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_NET_UNREACHABLE.
IP_DEST_NO_ROUTE | Variants of the above using IPv6 terminology, where different
IP_DEST_PORT_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_PORT_UNREACHABLE.
IP_DEST_PROHIBITED | This is constant nxllJwaIpExport.IP_DEST_PROHIBITED.
IP_DEST_PROT_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_PROT_UNREACHABLE.
IP_DEST_SCOPE_MISMATCH | This is constant nxllJwaIpExport.IP_DEST_SCOPE_MISMATCH.
IP_DEST_UNREACHABLE | IPv6-only status codes
IP_DEVICE_DOES_NOT_EXIST | This is constant nxllJwaIpExport.IP_DEVICE_DOES_NOT_EXIST.
IP_DUPLICATE_ADDRESS | This is constant nxllJwaIpExport.IP_DUPLICATE_ADDRESS.
IP_DUPLICATE_IPADD | This is constant nxllJwaIpExport.IP_DUPLICATE_IPADD.
IP_FLAG_DF | Don't fragment this packet.
IP_GENERAL_FAILURE | This is constant nxllJwaIpExport.IP_GENERAL_FAILURE.
IP_HOP_LIMIT_EXCEEDED | IP_DEST_PORT_UNREACHABLE = IP_STATUS_BASE + 5; {$EXTERNALSYM IP_DEST_PORT_UNREACHABLE}
IP_HW_ERROR | This is constant nxllJwaIpExport.IP_HW_ERROR.
IP_ICMP_ERROR | This is constant nxllJwaIpExport.IP_ICMP_ERROR.
IP_INTERFACE_METRIC_CHANGE | This is constant nxllJwaIpExport.IP_INTERFACE_METRIC_CHANGE.
IP_INTERFACE_WOL_CAPABILITY_CHANGE | This is constant nxllJwaIpExport.IP_INTERFACE_WOL_CAPABILITY_CHANGE.
IP_MEDIA_CONNECT | This is constant nxllJwaIpExport.IP_MEDIA_CONNECT.
IP_MEDIA_DISCONNECT | This is constant nxllJwaIpExport.IP_MEDIA_DISCONNECT.
IP_MTU_CHANGE | This is constant nxllJwaIpExport.IP_MTU_CHANGE.
IP_NEGOTIATING_IPSEC | This is constant nxllJwaIpExport.IP_NEGOTIATING_IPSEC.
IP_NO_RESOURCES | This is constant nxllJwaIpExport.IP_NO_RESOURCES.
IP_OPT_EOL | End of list option
IP_OPT_LSRR | Loose source route
IP_OPT_NOP | No operation
IP_OPT_ROUTER_ALERT | Router Alert Option
IP_OPT_RR | Record route
IP_OPT_SECURITY | Security option
IP_OPT_SID | Stream ID (obsolete)
IP_OPT_SSRR | Strict source route
IP_OPT_TS | Timestamp
IP_OPTION_TOO_BIG | This is constant nxllJwaIpExport.IP_OPTION_TOO_BIG.
IP_PACKET_TOO_BIG | This is constant nxllJwaIpExport.IP_PACKET_TOO_BIG.
IP_PARAM_PROBLEM | This is constant nxllJwaIpExport.IP_PARAM_PROBLEM.
IP_PARAMETER_PROBLEM | This is constant nxllJwaIpExport.IP_PARAMETER_PROBLEM.
IP_PENDING | This is constant nxllJwaIpExport.IP_PENDING.
IP_REASSEMBLY_TIME_EXCEEDED | This is constant nxllJwaIpExport.IP_REASSEMBLY_TIME_EXCEEDED.
IP_RECONFIG_SECFLTR | This is constant nxllJwaIpExport.IP_RECONFIG_SECFLTR.
IP_REQ_TIMED_OUT | This is constant nxllJwaIpExport.IP_REQ_TIMED_OUT.
IP_SOURCE_QUENCH | This is constant nxllJwaIpExport.IP_SOURCE_QUENCH.
IP_SPEC_MTU_CHANGE | This is constant nxllJwaIpExport.IP_SPEC_MTU_CHANGE.
IP_STATUS_BASE | IP_STATUS codes returned from IP APIs
IP_SUCCESS | This is constant nxllJwaIpExport.IP_SUCCESS.
IP_TIME_EXCEEDED | This is constant nxllJwaIpExport.IP_TIME_EXCEEDED.
IP_TTL_EXPIRED_REASSEM | This is constant nxllJwaIpExport.IP_TTL_EXPIRED_REASSEM.
IP_TTL_EXPIRED_TRANSIT | This is constant nxllJwaIpExport.IP_TTL_EXPIRED_TRANSIT.
IP_UNBIND_ADAPTER | This is constant nxllJwaIpExport.IP_UNBIND_ADAPTER.
IP_UNLOAD | This is constant nxllJwaIpExport.IP_UNLOAD.
IP_UNRECOGNIZED_NEXT_HEADER | This is constant nxllJwaIpExport.IP_UNRECOGNIZED_NEXT_HEADER.
MAX_ADAPTER_NAME | This is constant nxllJwaIpExport.MAX_ADAPTER_NAME.
MAX_IP_STATUS | This is constant nxllJwaIpExport.MAX_IP_STATUS.
MAX_OPT_SIZE | Maximum length of IP options in bytes
Structs, Records, Enums
Name | Description
_IP_ADAPTER_INDEX_MAP | This is record nxllJwaIpExport._IP_ADAPTER_INDEX_MAP.
_IP_ADAPTER_ORDER_MAP | This is record nxllJwaIpExport._IP_ADAPTER_ORDER_MAP.
_IP_INTERFACE_INFO | This is record nxllJwaIpExport._IP_INTERFACE_INFO.
_IP_MCAST_COUNTER_INFO | This is record nxllJwaIpExport._IP_MCAST_COUNTER_INFO.
_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS | This is record nxllJwaIpExport._IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
ARP_SEND_REPLY | This is record nxllJwaIpExport.ARP_SEND_REPLY.
ICMP_ECHO_REPLY | The icmp_echo_reply structure describes the data returned in response to an echo request.
in_addr | ifndef s_addr
IP_OPTION_INFORMATION | The ip_option_information structure describes the options to be included in the header of an IP packet. The TTL, TOS, and Flags values are carried in specific fields in the header. The OptionsData bytes are carried in the options area following the standard IP header. With the exception of source route options, this data must be in the format to be transmitted on the wire as specified in RFC 791. A source route option should contain the full route - first hop thru final destination - in the route data. The first hop will be pulled out of the data and... more
TCP_RESERVE_PORT_RANGE | This is record nxllJwaIpExport.TCP_RESERVE_PORT_RANGE.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name
Description
IP_ADAPTER_INDEX_MAP
This is type nxllJwaIpExport.IP_ADAPTER_INDEX_MAP.
IP_ADAPTER_ORDER_MAP
This is type nxllJwaIpExport.IP_ADAPTER_ORDER_MAP.
IP_INTERFACE_INFO
This is type nxllJwaIpExport.IP_INTERFACE_INFO.
IP_MCAST_COUNTER_INFO
This is type nxllJwaIpExport.IP_MCAST_COUNTER_INFO.
IP_STATUS
Status code returned from IP APIs.
IP_UNIDIRECTIONAL_ADAPTER_ADDRESS
This is type nxllJwaIpExport.IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
IPAddr
An IP address.
IPMask
An IP subnet mask.
IPv6Addr
(rom) deactivated kernel mode is irrelevant for Delphi // // Duplicate these definitions here so that this file can be included by // kernel-mode components which cannot include ws2tcpip.h, as well as // by user-mode components which do. //
type IN6_ADDR = record case Integer of 0: (Byte: array [0..15] of UCHAR); 1: (Word: array [0..7] of USHORT); end; {$EXTERNALSYM IN6_ADDR} TIn6Addr = IN6_ADDR; PIn6Addr = ^IN6_ADDR;
in_addr6 = in6_addr; {$EXTERNALSYM in_addr6} TInAddr6 = in_addr6; PInAddr6 = ^in_addr6;
PARP_SEND_REPLY
This is type nxllJwaIpExport.PARP_SEND_REPLY.
PArpSendReply
This is type nxllJwaIpExport.PArpSendReply.
PICMP_ECHO_REPLY
This is type nxllJwaIpExport.PICMP_ECHO_REPLY.
PIcmpEchoReply
This is type nxllJwaIpExport.PIcmpEchoReply.
PIP_ADAPTER_INDEX_MAP
This is type nxllJwaIpExport.PIP_ADAPTER_INDEX_MAP.
PIP_ADAPTER_ORDER_MAP
This is type nxllJwaIpExport.PIP_ADAPTER_ORDER_MAP.
PIP_INTERFACE_INFO
This is type nxllJwaIpExport.PIP_INTERFACE_INFO.
PIP_MCAST_COUNTER_INFO
This is type nxllJwaIpExport.PIP_MCAST_COUNTER_INFO.
PIP_OPTION_INFORMATION
This is type nxllJwaIpExport.PIP_OPTION_INFORMATION.
PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS
This is type nxllJwaIpExport.PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
PIpAdapterIndexMap
This is type nxllJwaIpExport.PIpAdapterIndexMap.
PIpAdapterOrderMap
This is type nxllJwaIpExport.PIpAdapterOrderMap.
PIpInterfaceInfo
This is type nxllJwaIpExport.PIpInterfaceInfo.
PIpMCastCounterInfo
This is type nxllJwaIpExport.PIpMCastCounterInfo.
PIpOptionInformation
This is type nxllJwaIpExport.PIpOptionInformation.
PIpUnidirectionalAdapterAddress
This is type nxllJwaIpExport.PIpUnidirectionalAdapterAddress.
PIPv6Addr
This is type nxllJwaIpExport.PIPv6Addr.
PTCP_RESERVE_PORT_RANGE
This is type nxllJwaIpExport.PTCP_RESERVE_PORT_RANGE.
PTcpReservePortRange
This is type nxllJwaIpExport.PTcpReservePortRange.
TArpSendReply
This is type nxllJwaIpExport.TArpSendReply.
TIcmpEchoReply
This is type nxllJwaIpExport.TIcmpEchoReply.
TIpAdapterIndexMap
This is type nxllJwaIpExport.TIpAdapterIndexMap.
TIpAdapterOrderMap
This is type nxllJwaIpExport.TIpAdapterOrderMap.
TIpInterfaceInfo
This is type nxllJwaIpExport.TIpInterfaceInfo.
TIpMCastCounterInfo
This is type nxllJwaIpExport.TIpMCastCounterInfo.
TIpOptionInformation
This is type nxllJwaIpExport.TIpOptionInformation.
TIpUnidirectionalAdapterAddress
This is type nxllJwaIpExport.TIpUnidirectionalAdapterAddress.
TIPv6Addr
This is type nxllJwaIpExport.TIPv6Addr.
TTcpReservePortRange
This is type nxllJwaIpExport.TTcpReservePortRange.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
nxllJwaIpExport Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllJwaIpExport Namespace

Records
Name | Description
_IP_ADAPTER_INDEX_MAP | This is record nxllJwaIpExport._IP_ADAPTER_INDEX_MAP.
_IP_ADAPTER_ORDER_MAP | This is record nxllJwaIpExport._IP_ADAPTER_ORDER_MAP.
_IP_INTERFACE_INFO | This is record nxllJwaIpExport._IP_INTERFACE_INFO.
_IP_MCAST_COUNTER_INFO | This is record nxllJwaIpExport._IP_MCAST_COUNTER_INFO.
_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS | This is record nxllJwaIpExport._IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
ARP_SEND_REPLY | This is record nxllJwaIpExport.ARP_SEND_REPLY.
ICMP_ECHO_REPLY | The icmp_echo_reply structure describes the data returned in response to an echo request.
in_addr | ifndef s_addr
IP_OPTION_INFORMATION | The ip_option_information structure describes the options to be included in the header of an IP packet. The TTL, TOS, and Flags values are carried in specific fields in the header. The OptionsData bytes are carried in the options area following the standard IP header. With the exception of source route options, this data must be in the format to be transmitted on the wire as specified in RFC 791. A source route option should contain the full route - first hop thru final destination - in the route data. The first hop will be pulled out of the data and... more
TCP_RESERVE_PORT_RANGE | This is record nxllJwaIpExport.TCP_RESERVE_PORT_RANGE.
Links
nxllJwaIpExport Namespace, Legend, Records


nxllJwaIpExport._IP_ADAPTER_INDEX_MAP Record

nxllJwaIpExport._IP_ADAPTER_INDEX_MAP Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_INDEX_MAP = record
  Index: ULONG;
  Name: array [0..MAX_ADAPTER_NAME - 1] of WCHAR;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport._IP_ADAPTER_INDEX_MAP.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport._IP_ADAPTER_ORDER_MAP Record

nxllJwaIpExport._IP_ADAPTER_ORDER_MAP Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_ORDER_MAP = record
  NumAdapters: ULONG;
  AdapterOrder: array [0..0] of ULONG;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport._IP_ADAPTER_ORDER_MAP.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport._IP_INTERFACE_INFO Record

nxllJwaIpExport._IP_INTERFACE_INFO Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_INTERFACE_INFO = record
  NumAdapters: Longint;
  Adapter: array [0..0] of IP_ADAPTER_INDEX_MAP;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport._IP_INTERFACE_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport._IP_MCAST_COUNTER_INFO Record

nxllJwaIpExport._IP_MCAST_COUNTER_INFO Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_MCAST_COUNTER_INFO = record
  InMcastOctets: ULONG64;
  OutMcastOctets: ULONG64;
  InMcastPkts: ULONG64;
  OutMcastPkts: ULONG64;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport._IP_MCAST_COUNTER_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport._IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Record

nxllJwaIpExport._IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS = record
  NumAdapters: ULONG;
  Address: array [0..0] of IPAddr;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport._IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport.ARP_SEND_REPLY Record

nxllJwaIpExport.ARP_SEND_REPLY Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
ARP_SEND_REPLY = record
  DestAddress: IPAddr;
  SrcAddress: IPAddr;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport.ARP_SEND_REPLY.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport.ICMP_ECHO_REPLY Record

nxllJwaIpExport.ICMP_ECHO_REPLY Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
ICMP_ECHO_REPLY = record
  Address: IPAddr;
  Status: ULONG;
  RoundTripTime: ULONG;
  DataSize: USHORT;
  Reserved: USHORT;
  Data: LPVOID;
  Options: ip_option_information;
end;
File

nxllJwaIpExport

Members
Members | Description
Address: IPAddr; | Replying address
Status: ULONG; | Reply IP_STATUS
RoundTripTime: ULONG; | RTT in milliseconds
DataSize: USHORT; | Reply data size in bytes
Reserved: USHORT; | Reserved for system use
Data: LPVOID; | Pointer to the reply data
Options: ip_option_information; | Reply options
Description

The icmp_echo_reply structure describes the data returned in response to an echo request.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport.in_addr Record

nxllJwaIpExport.in_addr Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
in_addr = record
  case Integer of
    0: (s_b1: UCHAR;
        s_b2: UCHAR;
        s_b3: UCHAR;
        s_b4: UCHAR;);
    1: (s_w1: USHORT;
        s_w2: USHORT;);
    2: (S_addr: ULONG;);
end;
File

nxllJwaIpExport

Description

ifndef s_addr

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport.IP_OPTION_INFORMATION Record

nxllJwaIpExport.IP_OPTION_INFORMATION Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_OPTION_INFORMATION = record
  Ttl: UCHAR;
  Tos: UCHAR;
  Flags: UCHAR;
  OptionsSize: UCHAR;
  OptionsData: PUCHAR;
end;
File

nxllJwaIpExport

Members
Members | Description
Ttl: UCHAR; | Time To Live
Tos: UCHAR; | Type Of Service
Flags: UCHAR; | IP header flags
OptionsSize: UCHAR; | Size in bytes of options data
OptionsData: PUCHAR; | Pointer to options data
Description

The ip_option_information structure describes the options to be included in the header of an IP packet. The TTL, TOS, and Flags values are carried in specific fields in the header. The OptionsData bytes are carried in the options area following the standard IP header. With the exception of source route options, this data must be in the format to be transmitted on the wire as specified in RFC 791. A source route option should contain the full route - first hop thru final destination - in the route data. The first hop will be pulled out of the data and the option will be reformatted accordingly. Otherwise, the route option should be formatted as specified in RFC 791.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


nxllJwaIpExport.TCP_RESERVE_PORT_RANGE Record

nxllJwaIpExport.TCP_RESERVE_PORT_RANGE Record
nxllJwaIpExport Structs, Records, Enums Send Feedback
Syntax
Delphi
TCP_RESERVE_PORT_RANGE = record
  UpperRange: USHORT;
  LowerRange: USHORT;
end;
File

nxllJwaIpExport

Description

This is record nxllJwaIpExport.TCP_RESERVE_PORT_RANGE.

Group

Structs, Records, Enums

Links
nxllJwaIpExport, Structs, Records, Enums


Types

Types
nxllJwaIpExport Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaIpExport Namespace

Types
Name
Description
IP_ADAPTER_INDEX_MAP
This is type nxllJwaIpExport.IP_ADAPTER_INDEX_MAP.
IP_ADAPTER_ORDER_MAP
This is type nxllJwaIpExport.IP_ADAPTER_ORDER_MAP.
IP_INTERFACE_INFO
This is type nxllJwaIpExport.IP_INTERFACE_INFO.
IP_MCAST_COUNTER_INFO
This is type nxllJwaIpExport.IP_MCAST_COUNTER_INFO.
IP_STATUS
Status code returned from IP APIs.
IP_UNIDIRECTIONAL_ADAPTER_ADDRESS
This is type nxllJwaIpExport.IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
IPAddr
An IP address.
IPMask
An IP subnet mask.
IPv6Addr
(rom) deactivated kernel mode is irrelevant for Delphi // // Duplicate these definitions here so that this file can be included by // kernel-mode components which cannot include ws2tcpip.h, as well as // by user-mode components which do. //
type IN6_ADDR = record case Integer of 0: (Byte: array [0..15] of UCHAR); 1: (Word: array [0..7] of USHORT); end; {$EXTERNALSYM IN6_ADDR} TIn6Addr = IN6_ADDR; PIn6Addr = ^IN6_ADDR;
in_addr6 = in6_addr; {$EXTERNALSYM in_addr6} TInAddr6 = in_addr6; PInAddr6 = ^in_addr6;
PARP_SEND_REPLY
This is type nxllJwaIpExport.PARP_SEND_REPLY.
PArpSendReply
This is type nxllJwaIpExport.PArpSendReply.
PICMP_ECHO_REPLY
This is type nxllJwaIpExport.PICMP_ECHO_REPLY.
PIcmpEchoReply
This is type nxllJwaIpExport.PIcmpEchoReply.
PIP_ADAPTER_INDEX_MAP
This is type nxllJwaIpExport.PIP_ADAPTER_INDEX_MAP.
PIP_ADAPTER_ORDER_MAP
This is type nxllJwaIpExport.PIP_ADAPTER_ORDER_MAP.
PIP_INTERFACE_INFO
This is type nxllJwaIpExport.PIP_INTERFACE_INFO.
PIP_MCAST_COUNTER_INFO
This is type nxllJwaIpExport.PIP_MCAST_COUNTER_INFO.
PIP_OPTION_INFORMATION
This is type nxllJwaIpExport.PIP_OPTION_INFORMATION.
PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS
This is type nxllJwaIpExport.PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
PIpAdapterIndexMap
This is type nxllJwaIpExport.PIpAdapterIndexMap.
PIpAdapterOrderMap
This is type nxllJwaIpExport.PIpAdapterOrderMap.
PIpInterfaceInfo
This is type nxllJwaIpExport.PIpInterfaceInfo.
PIpMCastCounterInfo
This is type nxllJwaIpExport.PIpMCastCounterInfo.
PIpOptionInformation
This is type nxllJwaIpExport.PIpOptionInformation.
PIpUnidirectionalAdapterAddress
This is type nxllJwaIpExport.PIpUnidirectionalAdapterAddress.
PIPv6Addr
This is type nxllJwaIpExport.PIPv6Addr.
PTCP_RESERVE_PORT_RANGE
This is type nxllJwaIpExport.PTCP_RESERVE_PORT_RANGE.
PTcpReservePortRange
This is type nxllJwaIpExport.PTcpReservePortRange.
TArpSendReply
This is type nxllJwaIpExport.TArpSendReply.
TIcmpEchoReply
This is type nxllJwaIpExport.TIcmpEchoReply.
TIpAdapterIndexMap
This is type nxllJwaIpExport.TIpAdapterIndexMap.
TIpAdapterOrderMap
This is type nxllJwaIpExport.TIpAdapterOrderMap.
TIpInterfaceInfo
This is type nxllJwaIpExport.TIpInterfaceInfo.
TIpMCastCounterInfo
This is type nxllJwaIpExport.TIpMCastCounterInfo.
TIpOptionInformation
This is type nxllJwaIpExport.TIpOptionInformation.
TIpUnidirectionalAdapterAddress
This is type nxllJwaIpExport.TIpUnidirectionalAdapterAddress.
TIPv6Addr
This is type nxllJwaIpExport.TIPv6Addr.
TTcpReservePortRange
This is type nxllJwaIpExport.TTcpReservePortRange.
Links
nxllJwaIpExport Namespace, Types


nxllJwaIpExport.IP_ADAPTER_INDEX_MAP Type

nxllJwaIpExport.IP_ADAPTER_INDEX_MAP Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_ADAPTER_INDEX_MAP = _IP_ADAPTER_INDEX_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.IP_ADAPTER_INDEX_MAP.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IP_ADAPTER_ORDER_MAP Type

nxllJwaIpExport.IP_ADAPTER_ORDER_MAP Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_ADAPTER_ORDER_MAP = _IP_ADAPTER_ORDER_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.IP_ADAPTER_ORDER_MAP.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IP_INTERFACE_INFO Type

nxllJwaIpExport.IP_INTERFACE_INFO Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_INTERFACE_INFO = _IP_INTERFACE_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.IP_INTERFACE_INFO.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IP_MCAST_COUNTER_INFO Type

nxllJwaIpExport.IP_MCAST_COUNTER_INFO Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_MCAST_COUNTER_INFO = _IP_MCAST_COUNTER_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.IP_MCAST_COUNTER_INFO.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IP_STATUS Type

nxllJwaIpExport.IP_STATUS Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_STATUS = ULONG;
File

nxllJwaIpExport

Description

Status code returned from IP APIs.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Type

nxllJwaIpExport.IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IP_UNIDIRECTIONAL_ADAPTER_ADDRESS = _IP_UNIDIRECTIONAL_ADAPTER_ADDRESS;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IPAddr Type

nxllJwaIpExport.IPAddr Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IPAddr = ULONG;
File

nxllJwaIpExport

Description

An IP address.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IPMask Type

nxllJwaIpExport.IPMask Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IPMask = ULONG;
File

nxllJwaIpExport

Description

An IP subnet mask.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.IPv6Addr Type

nxllJwaIpExport.IPv6Addr Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
IPv6Addr = in6_addr;
File

nxllJwaIpExport

Description

(rom) deactivated kernel mode is irrelevant for Delphi // // Duplicate these definitions here so that this file can be included by // kernel-mode components which cannot include ws2tcpip.h, as well as // by user-mode components which do. //

type IN6_ADDR = record case Integer of 0: (Byte: array [0..15] of UCHAR); 1: (Word: array [0..7] of USHORT); end; {$EXTERNALSYM IN6_ADDR} TIn6Addr = IN6_ADDR; PIn6Addr = ^IN6_ADDR;

in_addr6 = in6_addr; {$EXTERNALSYM in_addr6} TInAddr6 = in_addr6; PInAddr6 = ^in_addr6;

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PARP_SEND_REPLY Type

nxllJwaIpExport.PARP_SEND_REPLY Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PARP_SEND_REPLY = ^ARP_SEND_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PARP_SEND_REPLY.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PArpSendReply Type

nxllJwaIpExport.PArpSendReply Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PArpSendReply = PARP_SEND_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PArpSendReply.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PICMP_ECHO_REPLY Type

nxllJwaIpExport.PICMP_ECHO_REPLY Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PICMP_ECHO_REPLY = ^ICMP_ECHO_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PICMP_ECHO_REPLY.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIcmpEchoReply Type

nxllJwaIpExport.PIcmpEchoReply Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIcmpEchoReply = PICMP_ECHO_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIcmpEchoReply.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_ADAPTER_INDEX_MAP Type

nxllJwaIpExport.PIP_ADAPTER_INDEX_MAP Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_INDEX_MAP = ^IP_ADAPTER_INDEX_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_ADAPTER_INDEX_MAP.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_ADAPTER_ORDER_MAP Type

nxllJwaIpExport.PIP_ADAPTER_ORDER_MAP Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_ORDER_MAP = ^IP_ADAPTER_ORDER_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_ADAPTER_ORDER_MAP.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_INTERFACE_INFO Type

nxllJwaIpExport.PIP_INTERFACE_INFO Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_INTERFACE_INFO = ^IP_INTERFACE_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_INTERFACE_INFO.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_MCAST_COUNTER_INFO Type

nxllJwaIpExport.PIP_MCAST_COUNTER_INFO Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_MCAST_COUNTER_INFO = ^IP_MCAST_COUNTER_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_MCAST_COUNTER_INFO.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_OPTION_INFORMATION Type

nxllJwaIpExport.PIP_OPTION_INFORMATION Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_OPTION_INFORMATION = ^IP_OPTION_INFORMATION;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_OPTION_INFORMATION.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS Type

nxllJwaIpExport.PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS = ^IP_UNIDIRECTIONAL_ADAPTER_ADDRESS;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpAdapterIndexMap Type

nxllJwaIpExport.PIpAdapterIndexMap Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpAdapterIndexMap = PIP_ADAPTER_INDEX_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpAdapterIndexMap.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpAdapterOrderMap Type

nxllJwaIpExport.PIpAdapterOrderMap Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpAdapterOrderMap = PIP_ADAPTER_ORDER_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpAdapterOrderMap.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpInterfaceInfo Type

nxllJwaIpExport.PIpInterfaceInfo Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpInterfaceInfo = PIP_INTERFACE_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpInterfaceInfo.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpMCastCounterInfo Type

nxllJwaIpExport.PIpMCastCounterInfo Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpMCastCounterInfo = PIP_MCAST_COUNTER_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpMCastCounterInfo.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpOptionInformation Type

nxllJwaIpExport.PIpOptionInformation Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpOptionInformation = PIP_OPTION_INFORMATION;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpOptionInformation.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIpUnidirectionalAdapterAddress Type

nxllJwaIpExport.PIpUnidirectionalAdapterAddress Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIpUnidirectionalAdapterAddress = PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIpUnidirectionalAdapterAddress.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PIPv6Addr Type

nxllJwaIpExport.PIPv6Addr Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PIPv6Addr = ^IPv6Addr;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PIPv6Addr.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PTCP_RESERVE_PORT_RANGE Type

nxllJwaIpExport.PTCP_RESERVE_PORT_RANGE Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PTCP_RESERVE_PORT_RANGE = ^TCP_RESERVE_PORT_RANGE;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PTCP_RESERVE_PORT_RANGE.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.PTcpReservePortRange Type

nxllJwaIpExport.PTcpReservePortRange Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
PTcpReservePortRange = PTCP_RESERVE_PORT_RANGE;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.PTcpReservePortRange.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TArpSendReply Type

nxllJwaIpExport.TArpSendReply Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TArpSendReply = ARP_SEND_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TArpSendReply.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIcmpEchoReply Type

nxllJwaIpExport.TIcmpEchoReply Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIcmpEchoReply = ICMP_ECHO_REPLY;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIcmpEchoReply.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpAdapterIndexMap Type

nxllJwaIpExport.TIpAdapterIndexMap Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpAdapterIndexMap = IP_ADAPTER_INDEX_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpAdapterIndexMap.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpAdapterOrderMap Type

nxllJwaIpExport.TIpAdapterOrderMap Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpAdapterOrderMap = IP_ADAPTER_ORDER_MAP;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpAdapterOrderMap.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpInterfaceInfo Type

nxllJwaIpExport.TIpInterfaceInfo Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpInterfaceInfo = IP_INTERFACE_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpInterfaceInfo.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpMCastCounterInfo Type

nxllJwaIpExport.TIpMCastCounterInfo Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpMCastCounterInfo = IP_MCAST_COUNTER_INFO;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpMCastCounterInfo.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpOptionInformation Type

nxllJwaIpExport.TIpOptionInformation Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpOptionInformation = IP_OPTION_INFORMATION;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpOptionInformation.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIpUnidirectionalAdapterAddress Type

nxllJwaIpExport.TIpUnidirectionalAdapterAddress Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIpUnidirectionalAdapterAddress = IP_UNIDIRECTIONAL_ADAPTER_ADDRESS;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIpUnidirectionalAdapterAddress.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TIPv6Addr Type

nxllJwaIpExport.TIPv6Addr Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TIPv6Addr = IPv6Addr;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TIPv6Addr.

Group

Types

Links
nxllJwaIpExport, Types


nxllJwaIpExport.TTcpReservePortRange Type

nxllJwaIpExport.TTcpReservePortRange Type
nxllJwaIpExport Types Send Feedback
Syntax
Delphi
TTcpReservePortRange = TCP_RESERVE_PORT_RANGE;
File

nxllJwaIpExport

Description

This is type nxllJwaIpExport.TTcpReservePortRange.

Group

Types

Links
nxllJwaIpExport, Types


Constants

Constants
Constants nxllJwaIpExport Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
IOCTL_ARP_SEND_REQUEST | This is constant nxllJwaIpExport.IOCTL_ARP_SEND_REQUEST.
IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST | This is constant nxllJwaIpExport.IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST.
IOCTL_IP_GET_BEST_INTERFACE | This is constant nxllJwaIpExport.IOCTL_IP_GET_BEST_INTERFACE.
IOCTL_IP_INTERFACE_INFO | This is constant nxllJwaIpExport.IOCTL_IP_INTERFACE_INFO.
IOCTL_IP_RTCHANGE_NOTIFY_REQUEST | Ioctls code exposed by Memphis tcpip stack. For NT these ioctls are define in ntddip.h (privateinc)
IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS | This is constant nxllJwaIpExport.IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.
IP_ADDR_ADDED | This is constant nxllJwaIpExport.IP_ADDR_ADDED.
IP_ADDR_DELETED | The next group are status codes passed up on status indications to transport layer protocols.
IP_BAD_DESTINATION | This is constant nxllJwaIpExport.IP_BAD_DESTINATION.
IP_BAD_HEADER | This is constant nxllJwaIpExport.IP_BAD_HEADER.
IP_BAD_OPTION | This is constant nxllJwaIpExport.IP_BAD_OPTION.
IP_BAD_REQ | This is constant nxllJwaIpExport.IP_BAD_REQ.
IP_BAD_ROUTE | This is constant nxllJwaIpExport.IP_BAD_ROUTE.
IP_BIND_ADAPTER | This is constant nxllJwaIpExport.IP_BIND_ADAPTER.
IP_BUF_TOO_SMALL | This is constant nxllJwaIpExport.IP_BUF_TOO_SMALL.
IP_DEST_ADDR_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_ADDR_UNREACHABLE.
IP_DEST_HOST_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_HOST_UNREACHABLE.
IP_DEST_NET_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_NET_UNREACHABLE.
IP_DEST_NO_ROUTE | Variants of the above using IPv6 terminology, where different
IP_DEST_PORT_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_PORT_UNREACHABLE.
IP_DEST_PROHIBITED | This is constant nxllJwaIpExport.IP_DEST_PROHIBITED.
IP_DEST_PROT_UNREACHABLE | This is constant nxllJwaIpExport.IP_DEST_PROT_UNREACHABLE.
IP_DEST_SCOPE_MISMATCH | This is constant nxllJwaIpExport.IP_DEST_SCOPE_MISMATCH.
IP_DEST_UNREACHABLE | IPv6-only status codes
IP_DEVICE_DOES_NOT_EXIST | This is constant nxllJwaIpExport.IP_DEVICE_DOES_NOT_EXIST.
IP_DUPLICATE_ADDRESS | This is constant nxllJwaIpExport.IP_DUPLICATE_ADDRESS.
IP_DUPLICATE_IPADD | This is constant nxllJwaIpExport.IP_DUPLICATE_IPADD.
IP_FLAG_DF | Don't fragment this packet.
IP_GENERAL_FAILURE | This is constant nxllJwaIpExport.IP_GENERAL_FAILURE.
IP_HOP_LIMIT_EXCEEDED | IP_DEST_PORT_UNREACHABLE = IP_STATUS_BASE + 5; {$EXTERNALSYM IP_DEST_PORT_UNREACHABLE}
IP_HW_ERROR | This is constant nxllJwaIpExport.IP_HW_ERROR.
IP_ICMP_ERROR | This is constant nxllJwaIpExport.IP_ICMP_ERROR.
IP_INTERFACE_METRIC_CHANGE | This is constant nxllJwaIpExport.IP_INTERFACE_METRIC_CHANGE.
IP_INTERFACE_WOL_CAPABILITY_CHANGE | This is constant nxllJwaIpExport.IP_INTERFACE_WOL_CAPABILITY_CHANGE.
IP_MEDIA_CONNECT | This is constant nxllJwaIpExport.IP_MEDIA_CONNECT.
IP_MEDIA_DISCONNECT | This is constant nxllJwaIpExport.IP_MEDIA_DISCONNECT.
IP_MTU_CHANGE | This is constant nxllJwaIpExport.IP_MTU_CHANGE.
IP_NEGOTIATING_IPSEC | This is constant nxllJwaIpExport.IP_NEGOTIATING_IPSEC.
IP_NO_RESOURCES | This is constant nxllJwaIpExport.IP_NO_RESOURCES.
IP_OPT_EOL | End of list option
IP_OPT_LSRR | Loose source route
IP_OPT_NOP | No operation
IP_OPT_ROUTER_ALERT | Router Alert Option
IP_OPT_RR | Record route
IP_OPT_SECURITY | Security option
IP_OPT_SID | Stream ID (obsolete)
IP_OPT_SSRR | Strict source route
IP_OPT_TS | Timestamp
IP_OPTION_TOO_BIG | This is constant nxllJwaIpExport.IP_OPTION_TOO_BIG.
IP_PACKET_TOO_BIG | This is constant nxllJwaIpExport.IP_PACKET_TOO_BIG.
IP_PARAM_PROBLEM | This is constant nxllJwaIpExport.IP_PARAM_PROBLEM.
IP_PARAMETER_PROBLEM | This is constant nxllJwaIpExport.IP_PARAMETER_PROBLEM.
IP_PENDING | This is constant nxllJwaIpExport.IP_PENDING.
IP_REASSEMBLY_TIME_EXCEEDED | This is constant nxllJwaIpExport.IP_REASSEMBLY_TIME_EXCEEDED.
IP_RECONFIG_SECFLTR | This is constant nxllJwaIpExport.IP_RECONFIG_SECFLTR.
IP_REQ_TIMED_OUT | This is constant nxllJwaIpExport.IP_REQ_TIMED_OUT.
IP_SOURCE_QUENCH | This is constant nxllJwaIpExport.IP_SOURCE_QUENCH.
IP_SPEC_MTU_CHANGE | This is constant nxllJwaIpExport.IP_SPEC_MTU_CHANGE.
IP_STATUS_BASE | IP_STATUS codes returned from IP APIs
IP_SUCCESS | This is constant nxllJwaIpExport.IP_SUCCESS.
IP_TIME_EXCEEDED | This is constant nxllJwaIpExport.IP_TIME_EXCEEDED.
IP_TTL_EXPIRED_REASSEM | This is constant nxllJwaIpExport.IP_TTL_EXPIRED_REASSEM.
IP_TTL_EXPIRED_TRANSIT | This is constant nxllJwaIpExport.IP_TTL_EXPIRED_TRANSIT.
IP_UNBIND_ADAPTER | This is constant nxllJwaIpExport.IP_UNBIND_ADAPTER.
IP_UNLOAD | This is constant nxllJwaIpExport.IP_UNLOAD.
IP_UNRECOGNIZED_NEXT_HEADER | This is constant nxllJwaIpExport.IP_UNRECOGNIZED_NEXT_HEADER.
MAX_ADAPTER_NAME | This is constant nxllJwaIpExport.MAX_ADAPTER_NAME.
MAX_IP_STATUS | This is constant nxllJwaIpExport.MAX_IP_STATUS.
MAX_OPT_SIZE | Maximum length of IP options in bytes
Namespace

nxllJwaIpExport Namespace

Links
Constants, nxllJwaIpExport Namespace


nxllJwaIpExport.IOCTL_ARP_SEND_REQUEST Constant

nxllJwaIpExport.IOCTL_ARP_SEND_REQUEST Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_ARP_SEND_REQUEST = 103;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IOCTL_ARP_SEND_REQUEST.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST Constant

nxllJwaIpExport.IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST = 102;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IOCTL_IP_ADDCHANGE_NOTIFY_REQUEST.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IOCTL_IP_GET_BEST_INTERFACE Constant

nxllJwaIpExport.IOCTL_IP_GET_BEST_INTERFACE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_IP_GET_BEST_INTERFACE = 105;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IOCTL_IP_GET_BEST_INTERFACE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IOCTL_IP_INTERFACE_INFO Constant

nxllJwaIpExport.IOCTL_IP_INTERFACE_INFO Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_IP_INTERFACE_INFO = 104;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IOCTL_IP_INTERFACE_INFO.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IOCTL_IP_RTCHANGE_NOTIFY_REQUEST Constant

nxllJwaIpExport.IOCTL_IP_RTCHANGE_NOTIFY_REQUEST Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_IP_RTCHANGE_NOTIFY_REQUEST = 101;
File

nxllJwaIpExport

Description

Ioctls code exposed by Memphis tcpip stack. For NT these ioctls are define in ntddip.h (privateinc)

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Constant

nxllJwaIpExport.IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS = 106;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IOCTL_IP_UNIDIRECTIONAL_ADAPTER_ADDRESS.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_ADDR_ADDED Constant

nxllJwaIpExport.IP_ADDR_ADDED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_ADDR_ADDED = IP_STATUS_BASE + 23;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_ADDR_ADDED.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_ADDR_DELETED Constant

nxllJwaIpExport.IP_ADDR_DELETED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_ADDR_DELETED = IP_STATUS_BASE + 19;
File

nxllJwaIpExport

Description

The next group are status codes passed up on status indications to transport layer protocols.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BAD_DESTINATION Constant

nxllJwaIpExport.IP_BAD_DESTINATION Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BAD_DESTINATION = IP_STATUS_BASE + 18;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BAD_DESTINATION.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BAD_HEADER Constant

nxllJwaIpExport.IP_BAD_HEADER Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BAD_HEADER = IP_STATUS_BASE + 42;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BAD_HEADER.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BAD_OPTION Constant

nxllJwaIpExport.IP_BAD_OPTION Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BAD_OPTION = IP_STATUS_BASE + 7;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BAD_OPTION.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BAD_REQ Constant

nxllJwaIpExport.IP_BAD_REQ Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BAD_REQ = IP_STATUS_BASE + 11;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BAD_REQ.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BAD_ROUTE Constant

nxllJwaIpExport.IP_BAD_ROUTE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BAD_ROUTE = IP_STATUS_BASE + 12;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BAD_ROUTE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BIND_ADAPTER Constant

nxllJwaIpExport.IP_BIND_ADAPTER Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BIND_ADAPTER = IP_STATUS_BASE + 26;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BIND_ADAPTER.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_BUF_TOO_SMALL Constant

nxllJwaIpExport.IP_BUF_TOO_SMALL Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_BUF_TOO_SMALL = IP_STATUS_BASE + 1;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_BUF_TOO_SMALL.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_ADDR_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_ADDR_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_ADDR_UNREACHABLE = IP_STATUS_BASE + 3;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_ADDR_UNREACHABLE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_HOST_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_HOST_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_HOST_UNREACHABLE = IP_STATUS_BASE + 3;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_HOST_UNREACHABLE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_NET_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_NET_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_NET_UNREACHABLE = IP_STATUS_BASE + 2;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_NET_UNREACHABLE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_NO_ROUTE Constant

nxllJwaIpExport.IP_DEST_NO_ROUTE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_NO_ROUTE = IP_STATUS_BASE + 2;
File

nxllJwaIpExport

Description

Variants of the above using IPv6 terminology, where different

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_PORT_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_PORT_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_PORT_UNREACHABLE = IP_STATUS_BASE + 5;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_PORT_UNREACHABLE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_PROHIBITED Constant

nxllJwaIpExport.IP_DEST_PROHIBITED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_PROHIBITED = IP_STATUS_BASE + 4;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_PROHIBITED.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_PROT_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_PROT_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_PROT_UNREACHABLE = IP_STATUS_BASE + 4;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_PROT_UNREACHABLE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_SCOPE_MISMATCH Constant

nxllJwaIpExport.IP_DEST_SCOPE_MISMATCH Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_SCOPE_MISMATCH = IP_STATUS_BASE + 45;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEST_SCOPE_MISMATCH.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEST_UNREACHABLE Constant

nxllJwaIpExport.IP_DEST_UNREACHABLE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEST_UNREACHABLE = IP_STATUS_BASE + 40;
File

nxllJwaIpExport

Description

IPv6-only status codes

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DEVICE_DOES_NOT_EXIST Constant

nxllJwaIpExport.IP_DEVICE_DOES_NOT_EXIST Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DEVICE_DOES_NOT_EXIST = IP_STATUS_BASE + 28;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DEVICE_DOES_NOT_EXIST.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DUPLICATE_ADDRESS Constant

nxllJwaIpExport.IP_DUPLICATE_ADDRESS Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DUPLICATE_ADDRESS = IP_STATUS_BASE + 29;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DUPLICATE_ADDRESS.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_DUPLICATE_IPADD Constant

nxllJwaIpExport.IP_DUPLICATE_IPADD Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_DUPLICATE_IPADD = IP_STATUS_BASE + 34;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_DUPLICATE_IPADD.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_FLAG_DF Constant

nxllJwaIpExport.IP_FLAG_DF Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_FLAG_DF = $2;
File

nxllJwaIpExport

Description

Don't fragment this packet.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_GENERAL_FAILURE Constant

nxllJwaIpExport.IP_GENERAL_FAILURE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_GENERAL_FAILURE = IP_STATUS_BASE + 50;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_GENERAL_FAILURE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_HOP_LIMIT_EXCEEDED Constant

nxllJwaIpExport.IP_HOP_LIMIT_EXCEEDED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_HOP_LIMIT_EXCEEDED = IP_STATUS_BASE + 13;
File

nxllJwaIpExport

Description

IP_DEST_PORT_UNREACHABLE = IP_STATUS_BASE + 5; {$EXTERNALSYM IP_DEST_PORT_UNREACHABLE}

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_HW_ERROR Constant

nxllJwaIpExport.IP_HW_ERROR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_HW_ERROR = IP_STATUS_BASE + 8;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_HW_ERROR.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_ICMP_ERROR Constant

nxllJwaIpExport.IP_ICMP_ERROR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_ICMP_ERROR = IP_STATUS_BASE + 44;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_ICMP_ERROR.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_INTERFACE_METRIC_CHANGE Constant

nxllJwaIpExport.IP_INTERFACE_METRIC_CHANGE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_INTERFACE_METRIC_CHANGE = IP_STATUS_BASE + 30;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_INTERFACE_METRIC_CHANGE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_INTERFACE_WOL_CAPABILITY_CHANGE Constant

nxllJwaIpExport.IP_INTERFACE_WOL_CAPABILITY_CHANGE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_INTERFACE_WOL_CAPABILITY_CHANGE = IP_STATUS_BASE + 33;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_INTERFACE_WOL_CAPABILITY_CHANGE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_MEDIA_CONNECT Constant

nxllJwaIpExport.IP_MEDIA_CONNECT Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_MEDIA_CONNECT = IP_STATUS_BASE + 24;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_MEDIA_CONNECT.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_MEDIA_DISCONNECT Constant

nxllJwaIpExport.IP_MEDIA_DISCONNECT Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_MEDIA_DISCONNECT = IP_STATUS_BASE + 25;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_MEDIA_DISCONNECT.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_MTU_CHANGE Constant

nxllJwaIpExport.IP_MTU_CHANGE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_MTU_CHANGE = IP_STATUS_BASE + 21;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_MTU_CHANGE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_NEGOTIATING_IPSEC Constant

nxllJwaIpExport.IP_NEGOTIATING_IPSEC Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_NEGOTIATING_IPSEC = IP_STATUS_BASE + 32;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_NEGOTIATING_IPSEC.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_NO_RESOURCES Constant

nxllJwaIpExport.IP_NO_RESOURCES Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_NO_RESOURCES = IP_STATUS_BASE + 6;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_NO_RESOURCES.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_EOL Constant

nxllJwaIpExport.IP_OPT_EOL Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_EOL = 0;
File

nxllJwaIpExport

Description

End of list option

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_LSRR Constant

nxllJwaIpExport.IP_OPT_LSRR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_LSRR = $83;
File

nxllJwaIpExport

Description

Loose source route

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_NOP Constant

nxllJwaIpExport.IP_OPT_NOP Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_NOP = 1;
File

nxllJwaIpExport

Description

No operation

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_ROUTER_ALERT Constant

nxllJwaIpExport.IP_OPT_ROUTER_ALERT Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_ROUTER_ALERT = $94;
File

nxllJwaIpExport

Description

Router Alert Option

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_RR Constant

nxllJwaIpExport.IP_OPT_RR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_RR = $7;
File

nxllJwaIpExport

Description

Record route

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_SECURITY Constant

nxllJwaIpExport.IP_OPT_SECURITY Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_SECURITY = $82;
File

nxllJwaIpExport

Description

Security option

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_SID Constant

nxllJwaIpExport.IP_OPT_SID Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_SID = $88;
File

nxllJwaIpExport

Description

Stream ID (obsolete)

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_SSRR Constant

nxllJwaIpExport.IP_OPT_SSRR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_SSRR = $89;
File

nxllJwaIpExport

Description

Strict source route

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPT_TS Constant

nxllJwaIpExport.IP_OPT_TS Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPT_TS = $44;
File

nxllJwaIpExport

Description

Timestamp

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_OPTION_TOO_BIG Constant

nxllJwaIpExport.IP_OPTION_TOO_BIG Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_OPTION_TOO_BIG = IP_STATUS_BASE + 17;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_OPTION_TOO_BIG.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_PACKET_TOO_BIG Constant

nxllJwaIpExport.IP_PACKET_TOO_BIG Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_PACKET_TOO_BIG = IP_STATUS_BASE + 9;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_PACKET_TOO_BIG.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_PARAM_PROBLEM Constant

nxllJwaIpExport.IP_PARAM_PROBLEM Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_PARAM_PROBLEM = IP_STATUS_BASE + 15;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_PARAM_PROBLEM.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_PARAMETER_PROBLEM Constant

nxllJwaIpExport.IP_PARAMETER_PROBLEM Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_PARAMETER_PROBLEM = IP_STATUS_BASE + 15;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_PARAMETER_PROBLEM.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_PENDING Constant

nxllJwaIpExport.IP_PENDING Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_PENDING = IP_STATUS_BASE + 255;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_PENDING.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_REASSEMBLY_TIME_EXCEEDED Constant

nxllJwaIpExport.IP_REASSEMBLY_TIME_EXCEEDED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_REASSEMBLY_TIME_EXCEEDED = IP_STATUS_BASE + 14;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_REASSEMBLY_TIME_EXCEEDED.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_RECONFIG_SECFLTR Constant

nxllJwaIpExport.IP_RECONFIG_SECFLTR Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_RECONFIG_SECFLTR = IP_STATUS_BASE + 31;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_RECONFIG_SECFLTR.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_REQ_TIMED_OUT Constant

nxllJwaIpExport.IP_REQ_TIMED_OUT Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_REQ_TIMED_OUT = IP_STATUS_BASE + 10;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_REQ_TIMED_OUT.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_SOURCE_QUENCH Constant

nxllJwaIpExport.IP_SOURCE_QUENCH Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_SOURCE_QUENCH = IP_STATUS_BASE + 16;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_SOURCE_QUENCH.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_SPEC_MTU_CHANGE Constant

nxllJwaIpExport.IP_SPEC_MTU_CHANGE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_SPEC_MTU_CHANGE = IP_STATUS_BASE + 20;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_SPEC_MTU_CHANGE.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_STATUS_BASE Constant

nxllJwaIpExport.IP_STATUS_BASE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_STATUS_BASE = 11000;
File

nxllJwaIpExport

Description

IP_STATUS codes returned from IP APIs

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_SUCCESS Constant

nxllJwaIpExport.IP_SUCCESS Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_SUCCESS = 0;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_SUCCESS.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_TIME_EXCEEDED Constant

nxllJwaIpExport.IP_TIME_EXCEEDED Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_TIME_EXCEEDED = IP_STATUS_BASE + 41;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_TIME_EXCEEDED.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_TTL_EXPIRED_REASSEM Constant

nxllJwaIpExport.IP_TTL_EXPIRED_REASSEM Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_TTL_EXPIRED_REASSEM = IP_STATUS_BASE + 14;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_TTL_EXPIRED_REASSEM.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_TTL_EXPIRED_TRANSIT Constant

nxllJwaIpExport.IP_TTL_EXPIRED_TRANSIT Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_TTL_EXPIRED_TRANSIT = IP_STATUS_BASE + 13;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_TTL_EXPIRED_TRANSIT.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_UNBIND_ADAPTER Constant

nxllJwaIpExport.IP_UNBIND_ADAPTER Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_UNBIND_ADAPTER = IP_STATUS_BASE + 27;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_UNBIND_ADAPTER.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_UNLOAD Constant

nxllJwaIpExport.IP_UNLOAD Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_UNLOAD = IP_STATUS_BASE + 22;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_UNLOAD.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.IP_UNRECOGNIZED_NEXT_HEADER Constant

nxllJwaIpExport.IP_UNRECOGNIZED_NEXT_HEADER Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
IP_UNRECOGNIZED_NEXT_HEADER = IP_STATUS_BASE + 43;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.IP_UNRECOGNIZED_NEXT_HEADER.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.MAX_ADAPTER_NAME Constant

nxllJwaIpExport.MAX_ADAPTER_NAME Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
MAX_ADAPTER_NAME = 128;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.MAX_ADAPTER_NAME.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.MAX_IP_STATUS Constant

nxllJwaIpExport.MAX_IP_STATUS Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
MAX_IP_STATUS = IP_GENERAL_FAILURE;
File

nxllJwaIpExport

Description

This is constant nxllJwaIpExport.MAX_IP_STATUS.

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpExport.MAX_OPT_SIZE Constant

nxllJwaIpExport.MAX_OPT_SIZE Constant
nxllJwaIpExport Constants Send Feedback
Syntax
Delphi
MAX_OPT_SIZE = 40;
File

nxllJwaIpExport

Description

Maximum length of IP options in bytes

Group

Constants

Links
nxllJwaIpExport, Constants


nxllJwaIpHlpApi Namespace

nxllJwaIpHlpApi Namespace
Constants Functions Legend Topics Variables Send Feedback

Id: JwaIpHlpApi.pas,v 1.11 2007/09/05 11:58:50 dezipaitor Exp

Constants
Name | Description
iphlpapilib | This is constant nxllJwaIpHlpApi.iphlpapilib.
Functions
Name | Description
AddIPAddress | This is function nxllJwaIpHlpApi.AddIPAddress.
CancelIPChangeNotify | This is function nxllJwaIpHlpApi.CancelIPChangeNotify.
CreateIpForwardEntry | Used to create, modify or delete a route. In all cases the dwForwardIfIndex, dwForwardDest, dwForwardMask, dwForwardNextHop and dwForwardPolicy MUST BE SPECIFIED. Currently dwForwardPolicy is unused and MUST BE 0. For a set, the complete MIB_IPFORWARDROW structure must be specified
CreateIpNetEntry | Used to create, modify or delete an ARP entry. In all cases the dwIndex dwAddr field MUST BE SPECIFIED. For a set, the complete MIB_IPNETROW structure must be specified
CreateProxyArpEntry | Used to create or delete a Proxy ARP entry. The dwIndex is the index of the interface on which to PARP for the dwAddress. If the interface is of a type that doesnt support ARP, e.g. PPP, then the call will fail
DeleteIPAddress | This is function nxllJwaIpHlpApi.DeleteIPAddress.
DeleteIpForwardEntry | This is function nxllJwaIpHlpApi.DeleteIpForwardEntry.
DeleteIpNetEntry | This is function nxllJwaIpHlpApi.DeleteIpNetEntry.
DeleteProxyArpEntry | This is function nxllJwaIpHlpApi.DeleteProxyArpEntry.
DisableMediaSense | This is function nxllJwaIpHlpApi.DisableMediaSense.
EnableRouter | This is function nxllJwaIpHlpApi.EnableRouter.
FlushIpNetTable | This is function nxllJwaIpHlpApi.FlushIpNetTable.
GetAdapterIndex | This is function nxllJwaIpHlpApi.GetAdapterIndex.
GetAdapterOrderMap | This is function nxllJwaIpHlpApi.GetAdapterOrderMap.
GetAdaptersAddresses | The following functions require Winsock2.
GetAdaptersInfo | This is function nxllJwaIpHlpApi.GetAdaptersInfo.
GetBestInterface | Gets the "best" outgoing interface for the specified destination address
GetBestInterfaceEx | This is function nxllJwaIpHlpApi.GetBestInterfaceEx.
GetBestRoute | Gets the best (longest matching prefix) route for the given destination If the source address is also specified (i.e. is not 0x00000000), and there are multiple "best" routes to the given destination, the returned route will be one that goes out over the interface which has an address that matches the source address
GetFriendlyIfIndex | This is function nxllJwaIpHlpApi.GetFriendlyIfIndex.
GetIcmpStatistics | This is function nxllJwaIpHlpApi.GetIcmpStatistics.
GetIcmpStatisticsEx | This is function nxllJwaIpHlpApi.GetIcmpStatisticsEx.
GetIfEntry | Gets the MIB-II ifEntry The dwIndex field of the MIB_IFROW should be set to the index of the interface being queried
GetIfTable | Gets the MIB-II IfTable
GetInterfaceInfo | This is function nxllJwaIpHlpApi.GetInterfaceInfo.
GetIpAddrTable | Gets the Interface to IP Address mapping
GetIpErrorString | This is function nxllJwaIpHlpApi.GetIpErrorString.
GetIpForwardTable | Gets the IP Routing Table (RFX XXXX)
GetIpNetTable | Gets the current IP Address to Physical Address (ARP) mapping
GetIpStatistics | Gets IP/ICMP/TCP/UDP Statistics
GetIpStatisticsEx | This is function nxllJwaIpHlpApi.GetIpStatisticsEx.
GetNetworkParams | This is function nxllJwaIpHlpApi.GetNetworkParams.
GetNumberOfInterfaces | Retrieves the number of interfaces in the system. These include LAN and WAN interfaces
GetPerAdapterInfo | This is function nxllJwaIpHlpApi.GetPerAdapterInfo.
GetRTTAndHopCount | This is function nxllJwaIpHlpApi.GetRTTAndHopCount.
GetTcpStatistics | This is function nxllJwaIpHlpApi.GetTcpStatistics.
GetTcpStatisticsEx | This is function nxllJwaIpHlpApi.GetTcpStatisticsEx.
GetTcpTable | Gets TCP Connection/UDP Listener Table
GetUdpStatistics | This is function nxllJwaIpHlpApi.GetUdpStatistics.
GetUdpStatisticsEx | This is function nxllJwaIpHlpApi.GetUdpStatisticsEx.
GetUdpTable | This is function nxllJwaIpHlpApi.GetUdpTable.
GetUniDirectionalAdapterInfo | This is function nxllJwaIpHlpApi.GetUniDirectionalAdapterInfo.
IpReleaseAddress | This is function nxllJwaIpHlpApi.IpReleaseAddress.
IpRenewAddress | This is function nxllJwaIpHlpApi.IpRenewAddress.
NhpAllocateAndGetInterfaceInfoFromStack | This is function nxllJwaIpHlpApi.NhpAllocateAndGetInterfaceInfoFromStack.
NotifyAddrChange | This is function nxllJwaIpHlpApi.NotifyAddrChange.
NotifyRouteChange | This is function nxllJwaIpHlpApi.NotifyRouteChange.
RestoreMediaSense | This is function nxllJwaIpHlpApi.RestoreMediaSense.
SendARP | This is function nxllJwaIpHlpApi.SendARP.
SetIfEntry | Used to set the ifAdminStatus on an interface. The only fields of the MIB_IFROW that are relevant are the dwIndex (index of the interface whose status needs to be set) and the dwAdminStatus which can be either MIB_IF_ADMIN_STATUS_UP or MIB_IF_ADMIN_STATUS_DOWN
SetIpForwardEntry | This is function nxllJwaIpHlpApi.SetIpForwardEntry.
SetIpNetEntry | This is function nxllJwaIpHlpApi.SetIpNetEntry.
SetIpStatistics | Used to set the ipForwarding to ON or OFF (currently only ON->OFF is allowed) and to set the defaultTTL. If only one of the fields needs to be modified and the other needs to be the same as before the other field needs to be set to MIB_USE_CURRENT_TTL or MIB_USE_CURRENT_FORWARDING as the case may be
SetIpTTL | Used to set the defaultTTL.
SetTcpEntry | Used to set the state of a TCP Connection. The only state that it can be set to is MIB_TCP_STATE_DELETE_TCB. The complete MIB_TCPROW structure MUST BE SPECIFIED
UnenableRouter | This is function nxllJwaIpHlpApi.UnenableRouter.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
_AddIPAddress | This is variable nxllJwaIpHlpApi._AddIPAddress.
_CancelIPChangeNotify | This is variable nxllJwaIpHlpApi._CancelIPChangeNotify.
_CreateIpForwardEntry | This is variable nxllJwaIpHlpApi._CreateIpForwardEntry.
_CreateIpNetEntry | This is variable nxllJwaIpHlpApi._CreateIpNetEntry.
_CreateProxyArpEntry | This is variable nxllJwaIpHlpApi._CreateProxyArpEntry.
_DeleteIPAddress | This is variable nxllJwaIpHlpApi._DeleteIPAddress.
_DeleteIpForwardEntry | This is variable nxllJwaIpHlpApi._DeleteIpForwardEntry.
_DeleteIpNetEntry | This is variable nxllJwaIpHlpApi._DeleteIpNetEntry.
_DeleteProxyArpEntry | This is variable nxllJwaIpHlpApi._DeleteProxyArpEntry.
_DisableMediaSense | This is variable nxllJwaIpHlpApi._DisableMediaSense.
_EnableRouter | This is variable nxllJwaIpHlpApi._EnableRouter.
_FlushIpNetTable | This is variable nxllJwaIpHlpApi._FlushIpNetTable.
_GetAdapterIndex | This is variable nxllJwaIpHlpApi._GetAdapterIndex.
_GetAdapterOrderMap | This is variable nxllJwaIpHlpApi._GetAdapterOrderMap.
_GetAdaptersAddresses | This is variable nxllJwaIpHlpApi._GetAdaptersAddresses.
_GetAdaptersInfo | This is variable nxllJwaIpHlpApi._GetAdaptersInfo.
_GetBestInterface | This is variable nxllJwaIpHlpApi._GetBestInterface.
_GetBestInterfaceEx | This is variable nxllJwaIpHlpApi._GetBestInterfaceEx.
_GetBestRoute | This is variable nxllJwaIpHlpApi._GetBestRoute.
_GetFriendlyIfIndex | This is variable nxllJwaIpHlpApi._GetFriendlyIfIndex.
_GetIcmpStatistics | This is variable nxllJwaIpHlpApi._GetIcmpStatistics.
_GetIcmpStatisticsEx | This is variable nxllJwaIpHlpApi._GetIcmpStatisticsEx.
_GetIfEntry | This is variable nxllJwaIpHlpApi._GetIfEntry.
_GetIfTable | This is variable nxllJwaIpHlpApi._GetIfTable.
_GetInterfaceInfo | This is variable nxllJwaIpHlpApi._GetInterfaceInfo.
_GetIpAddrTable | This is variable nxllJwaIpHlpApi._GetIpAddrTable.
_GetIpErrorString | This is variable nxllJwaIpHlpApi._GetIpErrorString.
_GetIpForwardTable | This is variable nxllJwaIpHlpApi._GetIpForwardTable.
_GetIpNetTable | This is variable nxllJwaIpHlpApi._GetIpNetTable.
_GetIpStatistics | This is variable nxllJwaIpHlpApi._GetIpStatistics.
_GetIpStatisticsEx | This is variable nxllJwaIpHlpApi._GetIpStatisticsEx.
_GetNetworkParams | This is variable nxllJwaIpHlpApi._GetNetworkParams.
_GetNumberOfInterfaces | This is variable nxllJwaIpHlpApi._GetNumberOfInterfaces.
_GetPerAdapterInfo | This is variable nxllJwaIpHlpApi._GetPerAdapterInfo.
_GetRTTAndHopCount | This is variable nxllJwaIpHlpApi._GetRTTAndHopCount.
_GetTcpStatistics | This is variable nxllJwaIpHlpApi._GetTcpStatistics.
_GetTcpStatisticsEx | This is variable nxllJwaIpHlpApi._GetTcpStatisticsEx.
_GetTcpTable | This is variable nxllJwaIpHlpApi._GetTcpTable.
_GetUdpStatistics | This is variable nxllJwaIpHlpApi._GetUdpStatistics.
_GetUdpStatisticsEx | This is variable nxllJwaIpHlpApi._GetUdpStatisticsEx.
_GetUdpTable | This is variable nxllJwaIpHlpApi._GetUdpTable.
_GetUniDirectionalAdapterInfo | This is variable nxllJwaIpHlpApi._GetUniDirectionalAdapterInfo.
_IpReleaseAddress | This is variable nxllJwaIpHlpApi._IpReleaseAddress.
_IpRenewAddress | This is variable nxllJwaIpHlpApi._IpRenewAddress.
_NhpAllocateAGIIFrStack | This is variable nxllJwaIpHlpApi._NhpAllocateAGIIFrStack.
_NhpAllocateAndGetInterfaceInfoFromStack | This is variable nxllJwaIpHlpApi._NhpAllocateAndGetInterfaceInfoFromStack.
_NotifyAddrChange | This is variable nxllJwaIpHlpApi._NotifyAddrChange.
_NotifyRouteChange | This is variable nxllJwaIpHlpApi._NotifyRouteChange.
_RestoreMediaSense | This is variable nxllJwaIpHlpApi._RestoreMediaSense.
_SendARP | This is variable nxllJwaIpHlpApi._SendARP.
_SetIfEntry | This is variable nxllJwaIpHlpApi._SetIfEntry.
_SetIpForwardEntry | This is variable nxllJwaIpHlpApi._SetIpForwardEntry.
_SetIpNetEntry | This is variable nxllJwaIpHlpApi._SetIpNetEntry.
_SetIpStatistics | This is variable nxllJwaIpHlpApi._SetIpStatistics.
_SetIpTTL | This is variable nxllJwaIpHlpApi._SetIpTTL.
_SetTcpEntry | This is variable nxllJwaIpHlpApi._SetTcpEntry.
_UnenableRouter | This is variable nxllJwaIpHlpApi._UnenableRouter.
Links
Constants, Functions, Legend, Topics, Variables


Functions

Functions
Functions nxllJwaIpHlpApi Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddIPAddress | This is function nxllJwaIpHlpApi.AddIPAddress.
CancelIPChangeNotify | This is function nxllJwaIpHlpApi.CancelIPChangeNotify.
CreateIpForwardEntry | Used to create, modify or delete a route. In all cases the dwForwardIfIndex, dwForwardDest, dwForwardMask, dwForwardNextHop and dwForwardPolicy MUST BE SPECIFIED. Currently dwForwardPolicy is unused and MUST BE 0. For a set, the complete MIB_IPFORWARDROW structure must be specified
CreateIpNetEntry | Used to create, modify or delete an ARP entry. In all cases the dwIndex dwAddr field MUST BE SPECIFIED. For a set, the complete MIB_IPNETROW structure must be specified
CreateProxyArpEntry | Used to create or delete a Proxy ARP entry. The dwIndex is the index of the interface on which to PARP for the dwAddress. If the interface is of a type that doesnt support ARP, e.g. PPP, then the call will fail
DeleteIPAddress | This is function nxllJwaIpHlpApi.DeleteIPAddress.
DeleteIpForwardEntry | This is function nxllJwaIpHlpApi.DeleteIpForwardEntry.
DeleteIpNetEntry | This is function nxllJwaIpHlpApi.DeleteIpNetEntry.
DeleteProxyArpEntry | This is function nxllJwaIpHlpApi.DeleteProxyArpEntry.
DisableMediaSense | This is function nxllJwaIpHlpApi.DisableMediaSense.
EnableRouter | This is function nxllJwaIpHlpApi.EnableRouter.
FlushIpNetTable | This is function nxllJwaIpHlpApi.FlushIpNetTable.
GetAdapterIndex | This is function nxllJwaIpHlpApi.GetAdapterIndex.
GetAdapterOrderMap | This is function nxllJwaIpHlpApi.GetAdapterOrderMap.
GetAdaptersAddresses | The following functions require Winsock2.
GetAdaptersInfo | This is function nxllJwaIpHlpApi.GetAdaptersInfo.
GetBestInterface | Gets the "best" outgoing interface for the specified destination address
GetBestInterfaceEx | This is function nxllJwaIpHlpApi.GetBestInterfaceEx.
GetBestRoute | Gets the best (longest matching prefix) route for the given destination If the source address is also specified (i.e. is not 0x00000000), and there are multiple "best" routes to the given destination, the returned route will be one that goes out over the interface which has an address that matches the source address
GetFriendlyIfIndex | This is function nxllJwaIpHlpApi.GetFriendlyIfIndex.
GetIcmpStatistics | This is function nxllJwaIpHlpApi.GetIcmpStatistics.
GetIcmpStatisticsEx | This is function nxllJwaIpHlpApi.GetIcmpStatisticsEx.
GetIfEntry | Gets the MIB-II ifEntry The dwIndex field of the MIB_IFROW should be set to the index of the interface being queried
GetIfTable | Gets the MIB-II IfTable
GetInterfaceInfo | This is function nxllJwaIpHlpApi.GetInterfaceInfo.
GetIpAddrTable | Gets the Interface to IP Address mapping
GetIpErrorString | This is function nxllJwaIpHlpApi.GetIpErrorString.
GetIpForwardTable | Gets the IP Routing Table (RFX XXXX)
GetIpNetTable | Gets the current IP Address to Physical Address (ARP) mapping
GetIpStatistics | Gets IP/ICMP/TCP/UDP Statistics
GetIpStatisticsEx | This is function nxllJwaIpHlpApi.GetIpStatisticsEx.
GetNetworkParams | This is function nxllJwaIpHlpApi.GetNetworkParams.
GetNumberOfInterfaces | Retrieves the number of interfaces in the system. These include LAN and WAN interfaces
GetPerAdapterInfo | This is function nxllJwaIpHlpApi.GetPerAdapterInfo.
GetRTTAndHopCount | This is function nxllJwaIpHlpApi.GetRTTAndHopCount.
GetTcpStatistics | This is function nxllJwaIpHlpApi.GetTcpStatistics.
GetTcpStatisticsEx | This is function nxllJwaIpHlpApi.GetTcpStatisticsEx.
GetTcpTable | Gets TCP Connection/UDP Listener Table
GetUdpStatistics | This is function nxllJwaIpHlpApi.GetUdpStatistics.
GetUdpStatisticsEx | This is function nxllJwaIpHlpApi.GetUdpStatisticsEx.
GetUdpTable | This is function nxllJwaIpHlpApi.GetUdpTable.
GetUniDirectionalAdapterInfo | This is function nxllJwaIpHlpApi.GetUniDirectionalAdapterInfo.
IpReleaseAddress | This is function nxllJwaIpHlpApi.IpReleaseAddress.
IpRenewAddress | This is function nxllJwaIpHlpApi.IpRenewAddress.
NhpAllocateAndGetInterfaceInfoFromStack | This is function nxllJwaIpHlpApi.NhpAllocateAndGetInterfaceInfoFromStack.
NotifyAddrChange | This is function nxllJwaIpHlpApi.NotifyAddrChange.
NotifyRouteChange | This is function nxllJwaIpHlpApi.NotifyRouteChange.
RestoreMediaSense | This is function nxllJwaIpHlpApi.RestoreMediaSense.
SendARP | This is function nxllJwaIpHlpApi.SendARP.
SetIfEntry | Used to set the ifAdminStatus on an interface. The only fields of the MIB_IFROW that are relevant are the dwIndex (index of the interface whose status needs to be set) and the dwAdminStatus which can be either MIB_IF_ADMIN_STATUS_UP or MIB_IF_ADMIN_STATUS_DOWN
SetIpForwardEntry | This is function nxllJwaIpHlpApi.SetIpForwardEntry.
SetIpNetEntry | This is function nxllJwaIpHlpApi.SetIpNetEntry.
SetIpStatistics | Used to set the ipForwarding to ON or OFF (currently only ON->OFF is allowed) and to set the defaultTTL. If only one of the fields needs to be modified and the other needs to be the same as before the other field needs to be set to MIB_USE_CURRENT_TTL or MIB_USE_CURRENT_FORWARDING as the case may be
SetIpTTL | Used to set the defaultTTL.
SetTcpEntry | Used to set the state of a TCP Connection. The only state that it can be set to is MIB_TCP_STATE_DELETE_TCB. The complete MIB_TCPROW structure MUST BE SPECIFIED
UnenableRouter | This is function nxllJwaIpHlpApi.UnenableRouter.
Namespace

nxllJwaIpHlpApi Namespace

Links
Functions, nxllJwaIpHlpApi Namespace, Legend


nxllJwaIpHlpApi.AddIPAddress Function

nxllJwaIpHlpApi.AddIPAddress Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function AddIPAddress(Address: IPAddr; IpMask: IPMask; IfIndex: DWORD; var NTEContext: ULONG; var NTEInstance: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.AddIPAddress.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.CancelIPChangeNotify Function

nxllJwaIpHlpApi.CancelIPChangeNotify Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function CancelIPChangeNotify(notifyOverlapped: POVERLAPPED): BOOL; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.CancelIPChangeNotify.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.CreateIpForwardEntry Function

nxllJwaIpHlpApi.CreateIpForwardEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function CreateIpForwardEntry(const pRoute: MIB_IPFORWARDROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to create, modify or delete a route. In all cases the dwForwardIfIndex, dwForwardDest, dwForwardMask, dwForwardNextHop and dwForwardPolicy MUST BE SPECIFIED. Currently dwForwardPolicy is unused and MUST BE 0. For a set, the complete MIB_IPFORWARDROW structure must be specified

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.CreateIpNetEntry Function

nxllJwaIpHlpApi.CreateIpNetEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function CreateIpNetEntry(const pArpEntry: MIB_IPNETROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to create, modify or delete an ARP entry. In all cases the dwIndex dwAddr field MUST BE SPECIFIED. For a set, the complete MIB_IPNETROW structure must be specified

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.CreateProxyArpEntry Function

nxllJwaIpHlpApi.CreateProxyArpEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function CreateProxyArpEntry(dwAddress: DWORD; dwMask: DWORD; dwIfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to create or delete a Proxy ARP entry. The dwIndex is the index of the interface on which to PARP for the dwAddress. If the interface is of a type that doesnt support ARP, e.g. PPP, then the call will fail

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.DeleteIPAddress Function

nxllJwaIpHlpApi.DeleteIPAddress Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function DeleteIPAddress(NTEContext: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.DeleteIPAddress.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.DeleteIpForwardEntry Function

nxllJwaIpHlpApi.DeleteIpForwardEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function DeleteIpForwardEntry(const pRoute: MIB_IPFORWARDROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.DeleteIpForwardEntry.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.DeleteIpNetEntry Function

nxllJwaIpHlpApi.DeleteIpNetEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function DeleteIpNetEntry(const pArpEntry: MIB_IPNETROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.DeleteIpNetEntry.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.DeleteProxyArpEntry Function

nxllJwaIpHlpApi.DeleteProxyArpEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function DeleteProxyArpEntry(dwAddress: DWORD; dwMask: DWORD; dwIfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.DeleteProxyArpEntry.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.DisableMediaSense Function

nxllJwaIpHlpApi.DisableMediaSense Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function DisableMediaSense(var pHandle: HANDLE; pOverLapped: POVERLAPPED): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.DisableMediaSense.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.EnableRouter Function

nxllJwaIpHlpApi.EnableRouter Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function EnableRouter(var pHandle: THandle; pOverlapped: POVERLAPPED): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.EnableRouter.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.FlushIpNetTable Function

nxllJwaIpHlpApi.FlushIpNetTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function FlushIpNetTable(dwIfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.FlushIpNetTable.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetAdapterIndex Function

nxllJwaIpHlpApi.GetAdapterIndex Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetAdapterIndex(AdapterName: LPWSTR; var IfIndex: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetAdapterIndex.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetAdapterOrderMap Function

nxllJwaIpHlpApi.GetAdapterOrderMap Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetAdapterOrderMap: PIP_ADAPTER_ORDER_MAP; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetAdapterOrderMap.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetAdaptersAddresses Function

nxllJwaIpHlpApi.GetAdaptersAddresses Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetAdaptersAddresses(Family: ULONG; Flags: DWORD; Reserved: PVOID; pAdapterAddresses: PIP_ADAPTER_ADDRESSES; pOutBufLen: PULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

The following functions require Winsock2.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetAdaptersInfo Function

nxllJwaIpHlpApi.GetAdaptersInfo Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetAdaptersInfo(pAdapterInfo: PIP_ADAPTER_INFO; var pOutBufLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetAdaptersInfo.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetBestInterface Function

nxllJwaIpHlpApi.GetBestInterface Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetBestInterface(dwDestAddr: IPAddr; var pdwBestIfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the "best" outgoing interface for the specified destination address

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetBestInterfaceEx Function

nxllJwaIpHlpApi.GetBestInterfaceEx Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetBestInterfaceEx(pDestAddr: PSockAddr; var pdwBestIfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetBestInterfaceEx.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetBestRoute Function

nxllJwaIpHlpApi.GetBestRoute Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetBestRoute(dwDestAddr: DWORD; dwSourceAddr: DWORD; pBestRoute: PMIB_IPFORWARDROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the best (longest matching prefix) route for the given destination If the source address is also specified (i.e. is not 0x00000000), and there are multiple "best" routes to the given destination, the returned route will be one that goes out over the interface which has an address that matches the source address

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetFriendlyIfIndex Function

nxllJwaIpHlpApi.GetFriendlyIfIndex Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetFriendlyIfIndex(IfIndex: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetFriendlyIfIndex.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIcmpStatistics Function

nxllJwaIpHlpApi.GetIcmpStatistics Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIcmpStatistics(var pStats: MIB_ICMP): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetIcmpStatistics.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIcmpStatisticsEx Function

nxllJwaIpHlpApi.GetIcmpStatisticsEx Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIcmpStatisticsEx(pStats: PMIB_ICMP_EX; dwFamily: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetIcmpStatisticsEx.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIfEntry Function

nxllJwaIpHlpApi.GetIfEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIfEntry(pIfRow: PMIB_IFROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the MIB-II ifEntry The dwIndex field of the MIB_IFROW should be set to the index of the interface being queried

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIfTable Function

nxllJwaIpHlpApi.GetIfTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIfTable(pIfTable: PMIB_IFTABLE; var pdwSize: ULONG; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the MIB-II IfTable

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetInterfaceInfo Function

nxllJwaIpHlpApi.GetInterfaceInfo Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetInterfaceInfo(pIfTable: PIP_INTERFACE_INFO; var dwOutBufLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetInterfaceInfo.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpAddrTable Function

nxllJwaIpHlpApi.GetIpAddrTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpAddrTable(pIpAddrTable: PMIB_IPADDRTABLE; var pdwSize: ULONG; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the Interface to IP Address mapping

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpErrorString Function

nxllJwaIpHlpApi.GetIpErrorString Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpErrorString(ErrorCode: IP_STATUS; Buffer: PWCHAR; var Size: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetIpErrorString.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpForwardTable Function

nxllJwaIpHlpApi.GetIpForwardTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpForwardTable(pIpForwardTable: PMIB_IPFORWARDTABLE; var pdwSize: ULONG; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the IP Routing Table (RFX XXXX)

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpNetTable Function

nxllJwaIpHlpApi.GetIpNetTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpNetTable(pIpNetTable: PMIB_IPNETTABLE; var pdwSize: ULONG; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets the current IP Address to Physical Address (ARP) mapping

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpStatistics Function

nxllJwaIpHlpApi.GetIpStatistics Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpStatistics(var pStats: MIB_IPSTATS): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets IP/ICMP/TCP/UDP Statistics

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetIpStatisticsEx Function

nxllJwaIpHlpApi.GetIpStatisticsEx Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetIpStatisticsEx(pStats: PMIB_IPSTATS; dwFamily: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetIpStatisticsEx.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetNetworkParams Function

nxllJwaIpHlpApi.GetNetworkParams Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetNetworkParams(pFixedInfo: PFIXED_INFO; var pOutBufLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetNetworkParams.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetNumberOfInterfaces Function

nxllJwaIpHlpApi.GetNumberOfInterfaces Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetNumberOfInterfaces(var pdwNumIf: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Retrieves the number of interfaces in the system. These include LAN and WAN interfaces

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetPerAdapterInfo Function

nxllJwaIpHlpApi.GetPerAdapterInfo Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetPerAdapterInfo(IfIndex: ULONG; pPerAdapterInfo: PIP_PER_ADAPTER_INFO; var pOutBufLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetPerAdapterInfo.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetRTTAndHopCount Function

nxllJwaIpHlpApi.GetRTTAndHopCount Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetRTTAndHopCount(DestIpAddress: IPAddr; var HopCount: ULONG; MaxHops: ULONG; var RTT: ULONG): BOOL; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetRTTAndHopCount.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetTcpStatistics Function

nxllJwaIpHlpApi.GetTcpStatistics Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetTcpStatistics(var pStats: MIB_TCPSTATS): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetTcpStatistics.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetTcpStatisticsEx Function

nxllJwaIpHlpApi.GetTcpStatisticsEx Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetTcpStatisticsEx(pStats: PMIB_TCPSTATS; dwFamily: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetTcpStatisticsEx.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetTcpTable Function

nxllJwaIpHlpApi.GetTcpTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetTcpTable(pTcpTable: PMIB_TCPTABLE; var pdwSize: DWORD; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Gets TCP Connection/UDP Listener Table

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetUdpStatistics Function

nxllJwaIpHlpApi.GetUdpStatistics Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetUdpStatistics(var pStats: MIB_UDPSTATS): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetUdpStatistics.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetUdpStatisticsEx Function

nxllJwaIpHlpApi.GetUdpStatisticsEx Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetUdpStatisticsEx(pStats: PMIB_UDPSTATS; dwFamily: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetUdpStatisticsEx.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetUdpTable Function

nxllJwaIpHlpApi.GetUdpTable Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetUdpTable(pUdpTable: PMIB_UDPTABLE; var pdwSize: DWORD; bOrder: BOOL): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetUdpTable.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.GetUniDirectionalAdapterInfo Function

nxllJwaIpHlpApi.GetUniDirectionalAdapterInfo Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function GetUniDirectionalAdapterInfo(pIPIfInfo: PIP_UNIDIRECTIONAL_ADAPTER_ADDRESS; var dwOutBufLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.GetUniDirectionalAdapterInfo.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.IpReleaseAddress Function

nxllJwaIpHlpApi.IpReleaseAddress Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function IpReleaseAddress(const AdapterInfo: IP_ADAPTER_INDEX_MAP): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.IpReleaseAddress.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.IpRenewAddress Function

nxllJwaIpHlpApi.IpRenewAddress Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function IpRenewAddress(const AdapterInfo: IP_ADAPTER_INDEX_MAP): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.IpRenewAddress.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.NhpAllocateAndGetInterfaceInfoFromStack Function

nxllJwaIpHlpApi.NhpAllocateAndGetInterfaceInfoFromStack Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function NhpAllocateAndGetInterfaceInfoFromStack(out ppTable: PIP_INTERFACE_NAME_INFO; pdwCount: PDWORD; bOrder: BOOL; hHeap: HANDLE; dwFlags: DWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.NhpAllocateAndGetInterfaceInfoFromStack.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.NotifyAddrChange Function

nxllJwaIpHlpApi.NotifyAddrChange Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function NotifyAddrChange(var Handle: THandle; overlapped: POVERLAPPED): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.NotifyAddrChange.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.NotifyRouteChange Function

nxllJwaIpHlpApi.NotifyRouteChange Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function NotifyRouteChange(var Handle: THandle; overlapped: POVERLAPPED): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.NotifyRouteChange.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.RestoreMediaSense Function

nxllJwaIpHlpApi.RestoreMediaSense Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function RestoreMediaSense(pOverlapped: POVERLAPPED; lpdwEnableCount: LPDWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.RestoreMediaSense.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SendARP Function

nxllJwaIpHlpApi.SendARP Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SendARP(const DestIP: IPAddr; const SrcIP: IPAddr; pMacAddr: PULONG; var PhyAddrLen: ULONG): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.SendARP.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetIfEntry Function

nxllJwaIpHlpApi.SetIfEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetIfEntry(const pIfRow: MIB_IFROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to set the ifAdminStatus on an interface. The only fields of the MIB_IFROW that are relevant are the dwIndex (index of the interface whose status needs to be set) and the dwAdminStatus which can be either MIB_IF_ADMIN_STATUS_UP or MIB_IF_ADMIN_STATUS_DOWN

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetIpForwardEntry Function

nxllJwaIpHlpApi.SetIpForwardEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetIpForwardEntry(const pRoute: MIB_IPFORWARDROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.SetIpForwardEntry.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetIpNetEntry Function

nxllJwaIpHlpApi.SetIpNetEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetIpNetEntry(const pArpEntry: MIB_IPNETROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.SetIpNetEntry.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetIpStatistics Function

nxllJwaIpHlpApi.SetIpStatistics Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetIpStatistics(const pIpStats: MIB_IPSTATS): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to set the ipForwarding to ON or OFF (currently only ON->OFF is allowed) and to set the defaultTTL. If only one of the fields needs to be modified and the other needs to be the same as before the other field needs to be set to MIB_USE_CURRENT_TTL or MIB_USE_CURRENT_FORWARDING as the case may be

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetIpTTL Function

nxllJwaIpHlpApi.SetIpTTL Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetIpTTL(nTTL: UINT): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to set the defaultTTL.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.SetTcpEntry Function

nxllJwaIpHlpApi.SetTcpEntry Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function SetTcpEntry(const pTcpRow: MIB_TCPROW): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

Used to set the state of a TCP Connection. The only state that it can be set to is MIB_TCP_STATE_DELETE_TCB. The complete MIB_TCPROW structure MUST BE SPECIFIED

Group

Functions

Links
nxllJwaIpHlpApi, Functions


nxllJwaIpHlpApi.UnenableRouter Function

nxllJwaIpHlpApi.UnenableRouter Function
nxllJwaIpHlpApi Functions Send Feedback
Syntax
Delphi
function UnenableRouter(pOverlapped: POVERLAPPED; lpdwEnableCount: LPDWORD): DWORD; stdcall;
File

nxllJwaIpHlpApi

Description

This is function nxllJwaIpHlpApi.UnenableRouter.

Group

Functions

Links
nxllJwaIpHlpApi, Functions


Variables

Variables
nxllJwaIpHlpApi Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllJwaIpHlpApi Namespace

Variables
Name | Description
_AddIPAddress | This is variable nxllJwaIpHlpApi._AddIPAddress.
_CancelIPChangeNotify | This is variable nxllJwaIpHlpApi._CancelIPChangeNotify.
_CreateIpForwardEntry | This is variable nxllJwaIpHlpApi._CreateIpForwardEntry.
_CreateIpNetEntry | This is variable nxllJwaIpHlpApi._CreateIpNetEntry.
_CreateProxyArpEntry | This is variable nxllJwaIpHlpApi._CreateProxyArpEntry.
_DeleteIPAddress | This is variable nxllJwaIpHlpApi._DeleteIPAddress.
_DeleteIpForwardEntry | This is variable nxllJwaIpHlpApi._DeleteIpForwardEntry.
_DeleteIpNetEntry | This is variable nxllJwaIpHlpApi._DeleteIpNetEntry.
_DeleteProxyArpEntry | This is variable nxllJwaIpHlpApi._DeleteProxyArpEntry.
_DisableMediaSense | This is variable nxllJwaIpHlpApi._DisableMediaSense.
_EnableRouter | This is variable nxllJwaIpHlpApi._EnableRouter.
_FlushIpNetTable | This is variable nxllJwaIpHlpApi._FlushIpNetTable.
_GetAdapterIndex | This is variable nxllJwaIpHlpApi._GetAdapterIndex.
_GetAdapterOrderMap | This is variable nxllJwaIpHlpApi._GetAdapterOrderMap.
_GetAdaptersAddresses | This is variable nxllJwaIpHlpApi._GetAdaptersAddresses.
_GetAdaptersInfo | This is variable nxllJwaIpHlpApi._GetAdaptersInfo.
_GetBestInterface | This is variable nxllJwaIpHlpApi._GetBestInterface.
_GetBestInterfaceEx | This is variable nxllJwaIpHlpApi._GetBestInterfaceEx.
_GetBestRoute | This is variable nxllJwaIpHlpApi._GetBestRoute.
_GetFriendlyIfIndex | This is variable nxllJwaIpHlpApi._GetFriendlyIfIndex.
_GetIcmpStatistics | This is variable nxllJwaIpHlpApi._GetIcmpStatistics.
_GetIcmpStatisticsEx | This is variable nxllJwaIpHlpApi._GetIcmpStatisticsEx.
_GetIfEntry | This is variable nxllJwaIpHlpApi._GetIfEntry.
_GetIfTable | This is variable nxllJwaIpHlpApi._GetIfTable.
_GetInterfaceInfo | This is variable nxllJwaIpHlpApi._GetInterfaceInfo.
_GetIpAddrTable | This is variable nxllJwaIpHlpApi._GetIpAddrTable.
_GetIpErrorString | This is variable nxllJwaIpHlpApi._GetIpErrorString.
_GetIpForwardTable | This is variable nxllJwaIpHlpApi._GetIpForwardTable.
_GetIpNetTable | This is variable nxllJwaIpHlpApi._GetIpNetTable.
_GetIpStatistics | This is variable nxllJwaIpHlpApi._GetIpStatistics.
_GetIpStatisticsEx | This is variable nxllJwaIpHlpApi._GetIpStatisticsEx.
_GetNetworkParams | This is variable nxllJwaIpHlpApi._GetNetworkParams.
_GetNumberOfInterfaces | This is variable nxllJwaIpHlpApi._GetNumberOfInterfaces.
_GetPerAdapterInfo | This is variable nxllJwaIpHlpApi._GetPerAdapterInfo.
_GetRTTAndHopCount | This is variable nxllJwaIpHlpApi._GetRTTAndHopCount.
_GetTcpStatistics | This is variable nxllJwaIpHlpApi._GetTcpStatistics.
_GetTcpStatisticsEx | This is variable nxllJwaIpHlpApi._GetTcpStatisticsEx.
_GetTcpTable | This is variable nxllJwaIpHlpApi._GetTcpTable.
_GetUdpStatistics | This is variable nxllJwaIpHlpApi._GetUdpStatistics.
_GetUdpStatisticsEx | This is variable nxllJwaIpHlpApi._GetUdpStatisticsEx.
_GetUdpTable | This is variable nxllJwaIpHlpApi._GetUdpTable.
_GetUniDirectionalAdapterInfo | This is variable nxllJwaIpHlpApi._GetUniDirectionalAdapterInfo.
_IpReleaseAddress | This is variable nxllJwaIpHlpApi._IpReleaseAddress.
_IpRenewAddress | This is variable nxllJwaIpHlpApi._IpRenewAddress.
_NhpAllocateAGIIFrStack | This is variable nxllJwaIpHlpApi._NhpAllocateAGIIFrStack.
_NhpAllocateAndGetInterfaceInfoFromStack | This is variable nxllJwaIpHlpApi._NhpAllocateAndGetInterfaceInfoFromStack.
_NotifyAddrChange | This is variable nxllJwaIpHlpApi._NotifyAddrChange.
_NotifyRouteChange | This is variable nxllJwaIpHlpApi._NotifyRouteChange.
_RestoreMediaSense | This is variable nxllJwaIpHlpApi._RestoreMediaSense.
_SendARP | This is variable nxllJwaIpHlpApi._SendARP.
_SetIfEntry | This is variable nxllJwaIpHlpApi._SetIfEntry.
_SetIpForwardEntry | This is variable nxllJwaIpHlpApi._SetIpForwardEntry.
_SetIpNetEntry | This is variable nxllJwaIpHlpApi._SetIpNetEntry.
_SetIpStatistics | This is variable nxllJwaIpHlpApi._SetIpStatistics.
_SetIpTTL | This is variable nxllJwaIpHlpApi._SetIpTTL.
_SetTcpEntry | This is variable nxllJwaIpHlpApi._SetTcpEntry.
_UnenableRouter | This is variable nxllJwaIpHlpApi._UnenableRouter.
Links
nxllJwaIpHlpApi Namespace, Variables


nxllJwaIpHlpApi._AddIPAddress Variable

nxllJwaIpHlpApi._AddIPAddress Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_AddIPAddress: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._AddIPAddress.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._CancelIPChangeNotify Variable

nxllJwaIpHlpApi._CancelIPChangeNotify Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_CancelIPChangeNotify: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._CancelIPChangeNotify.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._CreateIpForwardEntry Variable

nxllJwaIpHlpApi._CreateIpForwardEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_CreateIpForwardEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._CreateIpForwardEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._CreateIpNetEntry Variable

nxllJwaIpHlpApi._CreateIpNetEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_CreateIpNetEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._CreateIpNetEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._CreateProxyArpEntry Variable

nxllJwaIpHlpApi._CreateProxyArpEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_CreateProxyArpEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._CreateProxyArpEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._DeleteIPAddress Variable

nxllJwaIpHlpApi._DeleteIPAddress Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_DeleteIPAddress: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._DeleteIPAddress.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._DeleteIpForwardEntry Variable

nxllJwaIpHlpApi._DeleteIpForwardEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_DeleteIpForwardEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._DeleteIpForwardEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._DeleteIpNetEntry Variable

nxllJwaIpHlpApi._DeleteIpNetEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_DeleteIpNetEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._DeleteIpNetEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._DeleteProxyArpEntry Variable

nxllJwaIpHlpApi._DeleteProxyArpEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_DeleteProxyArpEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._DeleteProxyArpEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._DisableMediaSense Variable

nxllJwaIpHlpApi._DisableMediaSense Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_DisableMediaSense: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._DisableMediaSense.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._EnableRouter Variable

nxllJwaIpHlpApi._EnableRouter Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_EnableRouter: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._EnableRouter.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._FlushIpNetTable Variable

nxllJwaIpHlpApi._FlushIpNetTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_FlushIpNetTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._FlushIpNetTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetAdapterIndex Variable

nxllJwaIpHlpApi._GetAdapterIndex Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetAdapterIndex: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetAdapterIndex.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetAdapterOrderMap Variable

nxllJwaIpHlpApi._GetAdapterOrderMap Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetAdapterOrderMap: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetAdapterOrderMap.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetAdaptersAddresses Variable

nxllJwaIpHlpApi._GetAdaptersAddresses Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetAdaptersAddresses: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetAdaptersAddresses.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetAdaptersInfo Variable

nxllJwaIpHlpApi._GetAdaptersInfo Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetAdaptersInfo: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetAdaptersInfo.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetBestInterface Variable

nxllJwaIpHlpApi._GetBestInterface Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetBestInterface: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetBestInterface.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetBestInterfaceEx Variable

nxllJwaIpHlpApi._GetBestInterfaceEx Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetBestInterfaceEx: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetBestInterfaceEx.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetBestRoute Variable

nxllJwaIpHlpApi._GetBestRoute Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetBestRoute: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetBestRoute.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetFriendlyIfIndex Variable

nxllJwaIpHlpApi._GetFriendlyIfIndex Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetFriendlyIfIndex: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetFriendlyIfIndex.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIcmpStatistics Variable

nxllJwaIpHlpApi._GetIcmpStatistics Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIcmpStatistics: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIcmpStatistics.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIcmpStatisticsEx Variable

nxllJwaIpHlpApi._GetIcmpStatisticsEx Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIcmpStatisticsEx: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIcmpStatisticsEx.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIfEntry Variable

nxllJwaIpHlpApi._GetIfEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIfEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIfEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIfTable Variable

nxllJwaIpHlpApi._GetIfTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIfTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIfTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetInterfaceInfo Variable

nxllJwaIpHlpApi._GetInterfaceInfo Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetInterfaceInfo: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetInterfaceInfo.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpAddrTable Variable

nxllJwaIpHlpApi._GetIpAddrTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpAddrTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpAddrTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpErrorString Variable

nxllJwaIpHlpApi._GetIpErrorString Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpErrorString: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpErrorString.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpForwardTable Variable

nxllJwaIpHlpApi._GetIpForwardTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpForwardTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpForwardTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpNetTable Variable

nxllJwaIpHlpApi._GetIpNetTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpNetTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpNetTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpStatistics Variable

nxllJwaIpHlpApi._GetIpStatistics Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpStatistics: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpStatistics.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetIpStatisticsEx Variable

nxllJwaIpHlpApi._GetIpStatisticsEx Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetIpStatisticsEx: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetIpStatisticsEx.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetNetworkParams Variable

nxllJwaIpHlpApi._GetNetworkParams Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetNetworkParams: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetNetworkParams.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetNumberOfInterfaces Variable

nxllJwaIpHlpApi._GetNumberOfInterfaces Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetNumberOfInterfaces: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetNumberOfInterfaces.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetPerAdapterInfo Variable

nxllJwaIpHlpApi._GetPerAdapterInfo Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetPerAdapterInfo: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetPerAdapterInfo.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetRTTAndHopCount Variable

nxllJwaIpHlpApi._GetRTTAndHopCount Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetRTTAndHopCount: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetRTTAndHopCount.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetTcpStatistics Variable

nxllJwaIpHlpApi._GetTcpStatistics Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetTcpStatistics: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetTcpStatistics.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetTcpStatisticsEx Variable

nxllJwaIpHlpApi._GetTcpStatisticsEx Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetTcpStatisticsEx: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetTcpStatisticsEx.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetTcpTable Variable

nxllJwaIpHlpApi._GetTcpTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetTcpTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetTcpTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetUdpStatistics Variable

nxllJwaIpHlpApi._GetUdpStatistics Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetUdpStatistics: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetUdpStatistics.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetUdpStatisticsEx Variable

nxllJwaIpHlpApi._GetUdpStatisticsEx Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetUdpStatisticsEx: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetUdpStatisticsEx.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetUdpTable Variable

nxllJwaIpHlpApi._GetUdpTable Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetUdpTable: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetUdpTable.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._GetUniDirectionalAdapterInfo Variable

nxllJwaIpHlpApi._GetUniDirectionalAdapterInfo Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_GetUniDirectionalAdapterInfo: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._GetUniDirectionalAdapterInfo.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._IpReleaseAddress Variable

nxllJwaIpHlpApi._IpReleaseAddress Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_IpReleaseAddress: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._IpReleaseAddress.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._IpRenewAddress Variable

nxllJwaIpHlpApi._IpRenewAddress Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_IpRenewAddress: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._IpRenewAddress.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._NhpAllocateAGIIFrStack Variable

nxllJwaIpHlpApi._NhpAllocateAGIIFrStack Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_NhpAllocateAGIIFrStack: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._NhpAllocateAGIIFrStack.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._NhpAllocateAndGetInterfaceInfoFromStack Variable

nxllJwaIpHlpApi._NhpAllocateAndGetInterfaceInfoFromStack Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_NhpAllocateAndGetInterfaceInfoFromStack: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._NhpAllocateAndGetInterfaceInfoFromStack.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._NotifyAddrChange Variable

nxllJwaIpHlpApi._NotifyAddrChange Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_NotifyAddrChange: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._NotifyAddrChange.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._NotifyRouteChange Variable

nxllJwaIpHlpApi._NotifyRouteChange Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_NotifyRouteChange: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._NotifyRouteChange.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._RestoreMediaSense Variable

nxllJwaIpHlpApi._RestoreMediaSense Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_RestoreMediaSense: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._RestoreMediaSense.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SendARP Variable

nxllJwaIpHlpApi._SendARP Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SendARP: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SendARP.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetIfEntry Variable

nxllJwaIpHlpApi._SetIfEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetIfEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetIfEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetIpForwardEntry Variable

nxllJwaIpHlpApi._SetIpForwardEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetIpForwardEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetIpForwardEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetIpNetEntry Variable

nxllJwaIpHlpApi._SetIpNetEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetIpNetEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetIpNetEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetIpStatistics Variable

nxllJwaIpHlpApi._SetIpStatistics Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetIpStatistics: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetIpStatistics.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetIpTTL Variable

nxllJwaIpHlpApi._SetIpTTL Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetIpTTL: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetIpTTL.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._SetTcpEntry Variable

nxllJwaIpHlpApi._SetTcpEntry Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_SetTcpEntry: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._SetTcpEntry.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


nxllJwaIpHlpApi._UnenableRouter Variable

nxllJwaIpHlpApi._UnenableRouter Variable
nxllJwaIpHlpApi Variables Send Feedback
Syntax
Delphi
_UnenableRouter: Pointer;
File

nxllJwaIpHlpApi

Description

This is variable nxllJwaIpHlpApi._UnenableRouter.

Group

Variables

Links
nxllJwaIpHlpApi, Variables


Constants

Constants
Constants nxllJwaIpHlpApi Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
iphlpapilib | This is constant nxllJwaIpHlpApi.iphlpapilib.
Namespace

nxllJwaIpHlpApi Namespace

Links
Constants, nxllJwaIpHlpApi Namespace


nxllJwaIpHlpApi.iphlpapilib Constant

nxllJwaIpHlpApi.iphlpapilib Constant
nxllJwaIpHlpApi Constants Send Feedback
Syntax
Delphi
iphlpapilib = 'iphlpapi.dll';
File

nxllJwaIpHlpApi

Description

This is constant nxllJwaIpHlpApi.iphlpapilib.

Group

Constants

Links
nxllJwaIpHlpApi, Constants


nxllJwaIpIfCons Namespace

nxllJwaIpIfCons Namespace
Constants Topics Send Feedback

Id: JwaIpIfCons.pas,v 1.6 2007/09/05 11:58:50 dezipaitor Exp

Constants
Name | Description
IF_ACCESS_BROADCAST | This is constant nxllJwaIpIfCons.IF_ACCESS_BROADCAST.
IF_ACCESS_LOOPBACK | Access types
IF_ACCESS_POINTTOMULTIPOINT | This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOMULTIPOINT.
IF_ACCESS_POINTTOPOINT | This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOPOINT.
IF_ADMIN_STATUS_DOWN | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_DOWN.
IF_ADMIN_STATUS_TESTING | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_TESTING.
IF_ADMIN_STATUS_UP | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_UP.
IF_CHECK_MCAST | This is constant nxllJwaIpIfCons.IF_CHECK_MCAST.
IF_CHECK_NONE | Interface Capabilities (bit flags)
IF_CHECK_SEND | This is constant nxllJwaIpIfCons.IF_CHECK_SEND.
IF_CONNECTION_DEDICATED | Connection Types
IF_CONNECTION_DEMAND | This is constant nxllJwaIpIfCons.IF_CONNECTION_DEMAND.
IF_CONNECTION_PASSIVE | This is constant nxllJwaIpIfCons.IF_CONNECTION_PASSIVE.
IF_OPER_STATUS_CONNECTED | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTED.
IF_OPER_STATUS_CONNECTING | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTING.
IF_OPER_STATUS_DISCONNECTED | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_DISCONNECTED.
IF_OPER_STATUS_NON_OPERATIONAL | The following are the the operational states for WAN and LAN interfaces. The order of the states seems weird, but is done for a purpose. All states >= CONNECTED can transmit data right away. States >= DISCONNECTED can tx data but some set up might be needed. States < DISCONNECTED can not transmit data. A card is marked UNREACHABLE if DIM calls InterfaceUnreachable for reasons other than failure to connect. NON_OPERATIONAL -- Valid for LAN Interfaces. Means the card is not working or not plugged in or has no address. UNREACHABLE -- Valid for WAN Interfaces. Means the remote site... more
IF_OPER_STATUS_OPERATIONAL | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_OPERATIONAL.
IF_OPER_STATUS_UNREACHABLE | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_UNREACHABLE.
IF_TYPE_A12MPPSWITCH | Avalon Parallel Processor
IF_TYPE_AAL5 | AAL5 over ATM
IF_TYPE_ADSL | Asymmetric Digital Subscrbr Loop
IF_TYPE_AFLANE_8023 | ATM Emulated LAN for 802.3
IF_TYPE_AFLANE_8025 | ATM Emulated LAN for 802.5
IF_TYPE_ARAP | Appletalk Remote Access Protocol
IF_TYPE_ARCNET | This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET.
IF_TYPE_ARCNET_PLUS | This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET_PLUS.
IF_TYPE_ASYNC | Asynchronous Protocol
IF_TYPE_ATM | ATM cells
IF_TYPE_ATM_DXI | ATM DXI
IF_TYPE_ATM_FUNI | ATM FUNI
IF_TYPE_ATM_IMA | ATM IMA
IF_TYPE_ATM_LOGICAL | ATM Logical Port
IF_TYPE_ATM_SUBINTERFACE | ATM Sub Interface
IF_TYPE_BASIC_ISDN | This is constant nxllJwaIpIfCons.IF_TYPE_BASIC_ISDN.
IF_TYPE_BSC | Bisynchronous Protocol
IF_TYPE_CCTEMUL | ATM Emulated circuit
IF_TYPE_CES | Circuit Emulation Service
IF_TYPE_CHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_CHANNEL.
IF_TYPE_CNR | Combat Net Radio
IF_TYPE_COFFEE | Coffee pot
IF_TYPE_DCN | Data Communications Network
IF_TYPE_DDN_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_DDN_X25.
IF_TYPE_DIGITALPOWERLINE | IP over Power Lines
IF_TYPE_DLSW | Data Link Switching
IF_TYPE_DOCSCABLE_DOWNSTREAM | CATV Downstream interface
IF_TYPE_DOCSCABLE_MACLAYER | CATV Mac Layer
IF_TYPE_DOCSCABLE_UPSTREAM | CATV Upstream interface
IF_TYPE_DS0 | Digital Signal Level 0
IF_TYPE_DS0_BUNDLE | Group of ds0s on the same ds1
IF_TYPE_DS1 | DS1-MIB
IF_TYPE_DS3 | DS3-MIB
IF_TYPE_DTM | Dynamic syncronous Transfer Mode
IF_TYPE_E1 | Obsolete; see DS1-MIB
IF_TYPE_EON | CLNP over IP
IF_TYPE_EPLRS | Ext Pos Loc Report Sys
IF_TYPE_ESCON | IBM Enterprise Systems Connection
IF_TYPE_ETHERNET_3MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_3MBIT.
IF_TYPE_ETHERNET_CSMACD | This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_CSMACD.
IF_TYPE_FAST | Fast channel
IF_TYPE_FASTETHER | Fast Ethernet (100BaseT)
IF_TYPE_FASTETHER_FX | Fast Ethernet (100BaseFX)
IF_TYPE_FDDI | This is constant nxllJwaIpIfCons.IF_TYPE_FDDI.
IF_TYPE_FIBRECHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_FIBRECHANNEL.
IF_TYPE_FRAMERELAY | DTE only
IF_TYPE_FRAMERELAY_INTERCONNECT | Obsolete, use 32 or 44
IF_TYPE_FRAMERELAY_MPI | Multiproto Interconnect over FR
IF_TYPE_FRAMERELAY_SERVICE | FRNETSERV-MIB
IF_TYPE_G703_2MB | Obsolete; see DS1-MIB
IF_TYPE_G703_64K | CCITT G703 at 64Kbps
IF_TYPE_GIGABITETHERNET | This is constant nxllJwaIpIfCons.IF_TYPE_GIGABITETHERNET.
IF_TYPE_HDH_1822 | This is constant nxllJwaIpIfCons.IF_TYPE_HDH_1822.
IF_TYPE_HDLC | This is constant nxllJwaIpIfCons.IF_TYPE_HDLC.
IF_TYPE_HIPPI | This is constant nxllJwaIpIfCons.IF_TYPE_HIPPI.
IF_TYPE_HIPPIINTERFACE | This is constant nxllJwaIpIfCons.IF_TYPE_HIPPIINTERFACE.
IF_TYPE_HOSTPAD | CCITT-ITU X.29 PAD Protocol
IF_TYPE_HSSI | This is constant nxllJwaIpIfCons.IF_TYPE_HSSI.
IF_TYPE_HYPERCHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_HYPERCHANNEL.
IF_TYPE_IBM370PARCHAN | IBM System 360/370 OEMI Channel
IF_TYPE_IEEE1394 | IEEE1394 High Perf Serial Bus
IF_TYPE_IEEE80211 | Radio spread spectrum
IF_TYPE_IEEE80212 | 100BaseVG
IF_TYPE_INTERLEAVE | Interleave channel
IF_TYPE_IP | IP (for APPN HPR in IP networks)
IF_TYPE_IPFORWARD | IP Forwarding Interface
IF_TYPE_IPOVER_ATM | IBM ipOverAtm
IF_TYPE_IPOVER_CDLC | IBM ipOverCdlc
IF_TYPE_IPOVER_CLAW | IBM Common Link Access to Workstn
IF_TYPE_IPSWITCH | IP Switching Objects
IF_TYPE_IS088023_CSMACD | This is constant nxllJwaIpIfCons.IF_TYPE_IS088023_CSMACD.
IF_TYPE_ISDN | ISDN and X.25
IF_TYPE_ISDN_S | ISDN S/T interface
IF_TYPE_ISDN_U | ISDN U interface
IF_TYPE_ISO88022_LLC | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88022_LLC.
IF_TYPE_ISO88024_TOKENBUS | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88024_TOKENBUS.
IF_TYPE_ISO88025_CRFPRINT | ISO 802.5 CRFP
IF_TYPE_ISO88025_FIBER | ISO 802.5j Fiber Token Ring
IF_TYPE_ISO88025_TOKENRING | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88025_TOKENRING.
IF_TYPE_ISO88025R_DTR | ISO 802.5r DTR
IF_TYPE_ISO88026_MAN | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88026_MAN.
IF_TYPE_L2_VLAN | Layer 2 Virtual LAN using 802.1Q
IF_TYPE_L3_IPVLAN | Layer 3 Virtual LAN using IP
IF_TYPE_L3_IPXVLAN | Layer 3 Virtual LAN using IPX
IF_TYPE_LAP_B | This is constant nxllJwaIpIfCons.IF_TYPE_LAP_B.
IF_TYPE_LAP_D | Link Access Protocol D
IF_TYPE_LAP_F | This is constant nxllJwaIpIfCons.IF_TYPE_LAP_F.
IF_TYPE_LOCALTALK | This is constant nxllJwaIpIfCons.IF_TYPE_LOCALTALK.
IF_TYPE_MEDIAMAILOVERIP | Multimedia Mail over IP
IF_TYPE_MIO_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_MIO_X25.
IF_TYPE_MODEM | Generic Modem
IF_TYPE_MPC | IBM multi-proto channel support
IF_TYPE_MSDSL | Multi-rate Symmetric DSL
IF_TYPE_MYRINET | Myricom Myrinet
IF_TYPE_NSIP | XNS over IP
IF_TYPE_OTHER | None of the below
IF_TYPE_PARA | Parallel port
IF_TYPE_PPP | This is constant nxllJwaIpIfCons.IF_TYPE_PPP.
IF_TYPE_PPPMULTILINKBUNDLE | PPP Multilink Bundle
IF_TYPE_PRIMARY_ISDN | This is constant nxllJwaIpIfCons.IF_TYPE_PRIMARY_ISDN.
IF_TYPE_PROP_CNLS | Proprietary Connectionless Proto
IF_TYPE_PROP_MULTIPLEXOR | Proprietary multiplexing
IF_TYPE_PROP_POINT2POINT_SERIAL | proprietary serial
IF_TYPE_PROP_VIRTUAL | Proprietary virtual/internal
IF_TYPE_PROTEON_10MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_10MBIT.
IF_TYPE_PROTEON_80MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_80MBIT.
IF_TYPE_QLLC | SNA QLLC
IF_TYPE_RADSL | Rate-Adapt Digital Subscrbr Loop
IF_TYPE_RECEIVE_ONLY | TV adapter type
IF_TYPE_REGULAR_1822 | This is constant nxllJwaIpIfCons.IF_TYPE_REGULAR_1822.
IF_TYPE_RFC877_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_RFC877_X25.
IF_TYPE_RS232 | This is constant nxllJwaIpIfCons.IF_TYPE_RS232.
IF_TYPE_RSRB | Remote Source Route Bridging
IF_TYPE_SDLC | This is constant nxllJwaIpIfCons.IF_TYPE_SDLC.
IF_TYPE_SDSL | Symmetric Digital Subscriber Loop
IF_TYPE_SIP | SMDS, coffee
IF_TYPE_SLIP | Generic Slip
IF_TYPE_SMDS_DXI | This is constant nxllJwaIpIfCons.IF_TYPE_SMDS_DXI.
IF_TYPE_SMDS_ICIP | SMDS InterCarrier Interface
IF_TYPE_SOFTWARE_LOOPBACK | This is constant nxllJwaIpIfCons.IF_TYPE_SOFTWARE_LOOPBACK.
IF_TYPE_SONET | SONET or SDH
IF_TYPE_SONET_PATH | This is constant nxllJwaIpIfCons.IF_TYPE_SONET_PATH.
IF_TYPE_SONET_VT | This is constant nxllJwaIpIfCons.IF_TYPE_SONET_VT.
IF_TYPE_STACKTOSTACK | IBM stackToStack
IF_TYPE_STARLAN | This is constant nxllJwaIpIfCons.IF_TYPE_STARLAN.
IF_TYPE_TDLC | IBM twinaxial data link control
IF_TYPE_TERMPAD | CCITT-ITU X.3 PAD Facility
IF_TYPE_TRANSPHDLC | This is constant nxllJwaIpIfCons.IF_TYPE_TRANSPHDLC.
IF_TYPE_TUNNEL | Encapsulation interface
IF_TYPE_ULTRA | ULTRA Technologies
IF_TYPE_V11 | CCITT V.11/X.21
IF_TYPE_V35 | This is constant nxllJwaIpIfCons.IF_TYPE_V35.
IF_TYPE_V36 | CCITT V.36
IF_TYPE_V37 | This is constant nxllJwaIpIfCons.IF_TYPE_V37.
IF_TYPE_VDSL | Very H-Speed Digital Subscrb Loop
IF_TYPE_VIRTUALIPADDRESS | IBM VIPA
IF_TYPE_VOICE_EM | Voice recEive and transMit
IF_TYPE_VOICE_ENCAP | Voice encapsulation
IF_TYPE_VOICE_FXO | Voice Foreign Exchange Office
IF_TYPE_VOICE_FXS | Voice Foreign Exchange Station
IF_TYPE_VOICE_OVERIP | Voice over IP encapsulation
IF_TYPE_X213 | CCITT-ITU X213
IF_TYPE_X25_HUNTGROUP | X.25 Hunt Group
IF_TYPE_X25_MLP | Multi-Link Protocol
IF_TYPE_X25_PLE | This is constant nxllJwaIpIfCons.IF_TYPE_X25_PLE.
MAX_IF_TYPE | This is constant nxllJwaIpIfCons.MAX_IF_TYPE.
MIB_IF_ADMIN_STATUS_DOWN | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_DOWN.
MIB_IF_ADMIN_STATUS_TESTING | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_TESTING.
MIB_IF_ADMIN_STATUS_UP | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_UP.
MIB_IF_OPER_STATUS_CONNECTED | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTED.
MIB_IF_OPER_STATUS_CONNECTING | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTING.
MIB_IF_OPER_STATUS_DISCONNECTED | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_DISCONNECTED.
MIB_IF_OPER_STATUS_NON_OPERATIONAL | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_NON_OPERATIONAL.
MIB_IF_OPER_STATUS_OPERATIONAL | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_OPERATIONAL.
MIB_IF_OPER_STATUS_UNREACHABLE | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_UNREACHABLE.
MIB_IF_TYPE_ETHERNET | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_ETHERNET.
MIB_IF_TYPE_FDDI | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_FDDI.
MIB_IF_TYPE_LOOPBACK | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_LOOPBACK.
MIB_IF_TYPE_OTHER | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_OTHER.
MIB_IF_TYPE_PPP | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_PPP.
MIB_IF_TYPE_SLIP | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_SLIP.
MIB_IF_TYPE_TOKENRING | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_TOKENRING.
MIN_IF_TYPE | Media types
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxllJwaIpIfCons Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
IF_ACCESS_BROADCAST | This is constant nxllJwaIpIfCons.IF_ACCESS_BROADCAST.
IF_ACCESS_LOOPBACK | Access types
IF_ACCESS_POINTTOMULTIPOINT | This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOMULTIPOINT.
IF_ACCESS_POINTTOPOINT | This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOPOINT.
IF_ADMIN_STATUS_DOWN | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_DOWN.
IF_ADMIN_STATUS_TESTING | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_TESTING.
IF_ADMIN_STATUS_UP | This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_UP.
IF_CHECK_MCAST | This is constant nxllJwaIpIfCons.IF_CHECK_MCAST.
IF_CHECK_NONE | Interface Capabilities (bit flags)
IF_CHECK_SEND | This is constant nxllJwaIpIfCons.IF_CHECK_SEND.
IF_CONNECTION_DEDICATED | Connection Types
IF_CONNECTION_DEMAND | This is constant nxllJwaIpIfCons.IF_CONNECTION_DEMAND.
IF_CONNECTION_PASSIVE | This is constant nxllJwaIpIfCons.IF_CONNECTION_PASSIVE.
IF_OPER_STATUS_CONNECTED | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTED.
IF_OPER_STATUS_CONNECTING | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTING.
IF_OPER_STATUS_DISCONNECTED | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_DISCONNECTED.
IF_OPER_STATUS_NON_OPERATIONAL | The following are the the operational states for WAN and LAN interfaces. The order of the states seems weird, but is done for a purpose. All states >= CONNECTED can transmit data right away. States >= DISCONNECTED can tx data but some set up might be needed. States < DISCONNECTED can not transmit data. A card is marked UNREACHABLE if DIM calls InterfaceUnreachable for reasons other than failure to connect. NON_OPERATIONAL -- Valid for LAN Interfaces. Means the card is not working or not plugged in or has no address. UNREACHABLE -- Valid for WAN Interfaces. Means the remote site... more
IF_OPER_STATUS_OPERATIONAL | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_OPERATIONAL.
IF_OPER_STATUS_UNREACHABLE | This is constant nxllJwaIpIfCons.IF_OPER_STATUS_UNREACHABLE.
IF_TYPE_A12MPPSWITCH | Avalon Parallel Processor
IF_TYPE_AAL5 | AAL5 over ATM
IF_TYPE_ADSL | Asymmetric Digital Subscrbr Loop
IF_TYPE_AFLANE_8023 | ATM Emulated LAN for 802.3
IF_TYPE_AFLANE_8025 | ATM Emulated LAN for 802.5
IF_TYPE_ARAP | Appletalk Remote Access Protocol
IF_TYPE_ARCNET | This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET.
IF_TYPE_ARCNET_PLUS | This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET_PLUS.
IF_TYPE_ASYNC | Asynchronous Protocol
IF_TYPE_ATM | ATM cells
IF_TYPE_ATM_DXI | ATM DXI
IF_TYPE_ATM_FUNI | ATM FUNI
IF_TYPE_ATM_IMA | ATM IMA
IF_TYPE_ATM_LOGICAL | ATM Logical Port
IF_TYPE_ATM_SUBINTERFACE | ATM Sub Interface
IF_TYPE_BASIC_ISDN | This is constant nxllJwaIpIfCons.IF_TYPE_BASIC_ISDN.
IF_TYPE_BSC | Bisynchronous Protocol
IF_TYPE_CCTEMUL | ATM Emulated circuit
IF_TYPE_CES | Circuit Emulation Service
IF_TYPE_CHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_CHANNEL.
IF_TYPE_CNR | Combat Net Radio
IF_TYPE_COFFEE | Coffee pot
IF_TYPE_DCN | Data Communications Network
IF_TYPE_DDN_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_DDN_X25.
IF_TYPE_DIGITALPOWERLINE | IP over Power Lines
IF_TYPE_DLSW | Data Link Switching
IF_TYPE_DOCSCABLE_DOWNSTREAM | CATV Downstream interface
IF_TYPE_DOCSCABLE_MACLAYER | CATV Mac Layer
IF_TYPE_DOCSCABLE_UPSTREAM | CATV Upstream interface
IF_TYPE_DS0 | Digital Signal Level 0
IF_TYPE_DS0_BUNDLE | Group of ds0s on the same ds1
IF_TYPE_DS1 | DS1-MIB
IF_TYPE_DS3 | DS3-MIB
IF_TYPE_DTM | Dynamic syncronous Transfer Mode
IF_TYPE_E1 | Obsolete; see DS1-MIB
IF_TYPE_EON | CLNP over IP
IF_TYPE_EPLRS | Ext Pos Loc Report Sys
IF_TYPE_ESCON | IBM Enterprise Systems Connection
IF_TYPE_ETHERNET_3MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_3MBIT.
IF_TYPE_ETHERNET_CSMACD | This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_CSMACD.
IF_TYPE_FAST | Fast channel
IF_TYPE_FASTETHER | Fast Ethernet (100BaseT)
IF_TYPE_FASTETHER_FX | Fast Ethernet (100BaseFX)
IF_TYPE_FDDI | This is constant nxllJwaIpIfCons.IF_TYPE_FDDI.
IF_TYPE_FIBRECHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_FIBRECHANNEL.
IF_TYPE_FRAMERELAY | DTE only
IF_TYPE_FRAMERELAY_INTERCONNECT | Obsolete, use 32 or 44
IF_TYPE_FRAMERELAY_MPI | Multiproto Interconnect over FR
IF_TYPE_FRAMERELAY_SERVICE | FRNETSERV-MIB
IF_TYPE_G703_2MB | Obsolete; see DS1-MIB
IF_TYPE_G703_64K | CCITT G703 at 64Kbps
IF_TYPE_GIGABITETHERNET | This is constant nxllJwaIpIfCons.IF_TYPE_GIGABITETHERNET.
IF_TYPE_HDH_1822 | This is constant nxllJwaIpIfCons.IF_TYPE_HDH_1822.
IF_TYPE_HDLC | This is constant nxllJwaIpIfCons.IF_TYPE_HDLC.
IF_TYPE_HIPPI | This is constant nxllJwaIpIfCons.IF_TYPE_HIPPI.
IF_TYPE_HIPPIINTERFACE | This is constant nxllJwaIpIfCons.IF_TYPE_HIPPIINTERFACE.
IF_TYPE_HOSTPAD | CCITT-ITU X.29 PAD Protocol
IF_TYPE_HSSI | This is constant nxllJwaIpIfCons.IF_TYPE_HSSI.
IF_TYPE_HYPERCHANNEL | This is constant nxllJwaIpIfCons.IF_TYPE_HYPERCHANNEL.
IF_TYPE_IBM370PARCHAN | IBM System 360/370 OEMI Channel
IF_TYPE_IEEE1394 | IEEE1394 High Perf Serial Bus
IF_TYPE_IEEE80211 | Radio spread spectrum
IF_TYPE_IEEE80212 | 100BaseVG
IF_TYPE_INTERLEAVE | Interleave channel
IF_TYPE_IP | IP (for APPN HPR in IP networks)
IF_TYPE_IPFORWARD | IP Forwarding Interface
IF_TYPE_IPOVER_ATM | IBM ipOverAtm
IF_TYPE_IPOVER_CDLC | IBM ipOverCdlc
IF_TYPE_IPOVER_CLAW | IBM Common Link Access to Workstn
IF_TYPE_IPSWITCH | IP Switching Objects
IF_TYPE_IS088023_CSMACD | This is constant nxllJwaIpIfCons.IF_TYPE_IS088023_CSMACD.
IF_TYPE_ISDN | ISDN and X.25
IF_TYPE_ISDN_S | ISDN S/T interface
IF_TYPE_ISDN_U | ISDN U interface
IF_TYPE_ISO88022_LLC | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88022_LLC.
IF_TYPE_ISO88024_TOKENBUS | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88024_TOKENBUS.
IF_TYPE_ISO88025_CRFPRINT | ISO 802.5 CRFP
IF_TYPE_ISO88025_FIBER | ISO 802.5j Fiber Token Ring
IF_TYPE_ISO88025_TOKENRING | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88025_TOKENRING.
IF_TYPE_ISO88025R_DTR | ISO 802.5r DTR
IF_TYPE_ISO88026_MAN | This is constant nxllJwaIpIfCons.IF_TYPE_ISO88026_MAN.
IF_TYPE_L2_VLAN | Layer 2 Virtual LAN using 802.1Q
IF_TYPE_L3_IPVLAN | Layer 3 Virtual LAN using IP
IF_TYPE_L3_IPXVLAN | Layer 3 Virtual LAN using IPX
IF_TYPE_LAP_B | This is constant nxllJwaIpIfCons.IF_TYPE_LAP_B.
IF_TYPE_LAP_D | Link Access Protocol D
IF_TYPE_LAP_F | This is constant nxllJwaIpIfCons.IF_TYPE_LAP_F.
IF_TYPE_LOCALTALK | This is constant nxllJwaIpIfCons.IF_TYPE_LOCALTALK.
IF_TYPE_MEDIAMAILOVERIP | Multimedia Mail over IP
IF_TYPE_MIO_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_MIO_X25.
IF_TYPE_MODEM | Generic Modem
IF_TYPE_MPC | IBM multi-proto channel support
IF_TYPE_MSDSL | Multi-rate Symmetric DSL
IF_TYPE_MYRINET | Myricom Myrinet
IF_TYPE_NSIP | XNS over IP
IF_TYPE_OTHER | None of the below
IF_TYPE_PARA | Parallel port
IF_TYPE_PPP | This is constant nxllJwaIpIfCons.IF_TYPE_PPP.
IF_TYPE_PPPMULTILINKBUNDLE | PPP Multilink Bundle
IF_TYPE_PRIMARY_ISDN | This is constant nxllJwaIpIfCons.IF_TYPE_PRIMARY_ISDN.
IF_TYPE_PROP_CNLS | Proprietary Connectionless Proto
IF_TYPE_PROP_MULTIPLEXOR | Proprietary multiplexing
IF_TYPE_PROP_POINT2POINT_SERIAL | proprietary serial
IF_TYPE_PROP_VIRTUAL | Proprietary virtual/internal
IF_TYPE_PROTEON_10MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_10MBIT.
IF_TYPE_PROTEON_80MBIT | This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_80MBIT.
IF_TYPE_QLLC | SNA QLLC
IF_TYPE_RADSL | Rate-Adapt Digital Subscrbr Loop
IF_TYPE_RECEIVE_ONLY | TV adapter type
IF_TYPE_REGULAR_1822 | This is constant nxllJwaIpIfCons.IF_TYPE_REGULAR_1822.
IF_TYPE_RFC877_X25 | This is constant nxllJwaIpIfCons.IF_TYPE_RFC877_X25.
IF_TYPE_RS232 | This is constant nxllJwaIpIfCons.IF_TYPE_RS232.
IF_TYPE_RSRB | Remote Source Route Bridging
IF_TYPE_SDLC | This is constant nxllJwaIpIfCons.IF_TYPE_SDLC.
IF_TYPE_SDSL | Symmetric Digital Subscriber Loop
IF_TYPE_SIP | SMDS, coffee
IF_TYPE_SLIP | Generic Slip
IF_TYPE_SMDS_DXI | This is constant nxllJwaIpIfCons.IF_TYPE_SMDS_DXI.
IF_TYPE_SMDS_ICIP | SMDS InterCarrier Interface
IF_TYPE_SOFTWARE_LOOPBACK | This is constant nxllJwaIpIfCons.IF_TYPE_SOFTWARE_LOOPBACK.
IF_TYPE_SONET | SONET or SDH
IF_TYPE_SONET_PATH | This is constant nxllJwaIpIfCons.IF_TYPE_SONET_PATH.
IF_TYPE_SONET_VT | This is constant nxllJwaIpIfCons.IF_TYPE_SONET_VT.
IF_TYPE_STACKTOSTACK | IBM stackToStack
IF_TYPE_STARLAN | This is constant nxllJwaIpIfCons.IF_TYPE_STARLAN.
IF_TYPE_TDLC | IBM twinaxial data link control
IF_TYPE_TERMPAD | CCITT-ITU X.3 PAD Facility
IF_TYPE_TRANSPHDLC | This is constant nxllJwaIpIfCons.IF_TYPE_TRANSPHDLC.
IF_TYPE_TUNNEL | Encapsulation interface
IF_TYPE_ULTRA | ULTRA Technologies
IF_TYPE_V11 | CCITT V.11/X.21
IF_TYPE_V35 | This is constant nxllJwaIpIfCons.IF_TYPE_V35.
IF_TYPE_V36 | CCITT V.36
IF_TYPE_V37 | This is constant nxllJwaIpIfCons.IF_TYPE_V37.
IF_TYPE_VDSL | Very H-Speed Digital Subscrb Loop
IF_TYPE_VIRTUALIPADDRESS | IBM VIPA
IF_TYPE_VOICE_EM | Voice recEive and transMit
IF_TYPE_VOICE_ENCAP | Voice encapsulation
IF_TYPE_VOICE_FXO | Voice Foreign Exchange Office
IF_TYPE_VOICE_FXS | Voice Foreign Exchange Station
IF_TYPE_VOICE_OVERIP | Voice over IP encapsulation
IF_TYPE_X213 | CCITT-ITU X213
IF_TYPE_X25_HUNTGROUP | X.25 Hunt Group
IF_TYPE_X25_MLP | Multi-Link Protocol
IF_TYPE_X25_PLE | This is constant nxllJwaIpIfCons.IF_TYPE_X25_PLE.
MAX_IF_TYPE | This is constant nxllJwaIpIfCons.MAX_IF_TYPE.
MIB_IF_ADMIN_STATUS_DOWN | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_DOWN.
MIB_IF_ADMIN_STATUS_TESTING | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_TESTING.
MIB_IF_ADMIN_STATUS_UP | This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_UP.
MIB_IF_OPER_STATUS_CONNECTED | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTED.
MIB_IF_OPER_STATUS_CONNECTING | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTING.
MIB_IF_OPER_STATUS_DISCONNECTED | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_DISCONNECTED.
MIB_IF_OPER_STATUS_NON_OPERATIONAL | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_NON_OPERATIONAL.
MIB_IF_OPER_STATUS_OPERATIONAL | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_OPERATIONAL.
MIB_IF_OPER_STATUS_UNREACHABLE | This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_UNREACHABLE.
MIB_IF_TYPE_ETHERNET | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_ETHERNET.
MIB_IF_TYPE_FDDI | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_FDDI.
MIB_IF_TYPE_LOOPBACK | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_LOOPBACK.
MIB_IF_TYPE_OTHER | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_OTHER.
MIB_IF_TYPE_PPP | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_PPP.
MIB_IF_TYPE_SLIP | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_SLIP.
MIB_IF_TYPE_TOKENRING | This is constant nxllJwaIpIfCons.MIB_IF_TYPE_TOKENRING.
MIN_IF_TYPE | Media types
Namespace

nxllJwaIpIfCons Namespace

Links
Constants, nxllJwaIpIfCons Namespace


nxllJwaIpIfCons.IF_ACCESS_BROADCAST Constant

nxllJwaIpIfCons.IF_ACCESS_BROADCAST Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ACCESS_BROADCAST = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ACCESS_BROADCAST.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ACCESS_LOOPBACK Constant

nxllJwaIpIfCons.IF_ACCESS_LOOPBACK Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ACCESS_LOOPBACK = 1;
File

nxllJwaIpIfCons

Description

Access types

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ACCESS_POINTTOMULTIPOINT Constant

nxllJwaIpIfCons.IF_ACCESS_POINTTOMULTIPOINT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ACCESS_POINTTOMULTIPOINT = 4;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOMULTIPOINT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ACCESS_POINTTOPOINT Constant

nxllJwaIpIfCons.IF_ACCESS_POINTTOPOINT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ACCESS_POINTTOPOINT = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ACCESS_POINTTOPOINT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ADMIN_STATUS_DOWN Constant

nxllJwaIpIfCons.IF_ADMIN_STATUS_DOWN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ADMIN_STATUS_DOWN = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_DOWN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ADMIN_STATUS_TESTING Constant

nxllJwaIpIfCons.IF_ADMIN_STATUS_TESTING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ADMIN_STATUS_TESTING = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_TESTING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_ADMIN_STATUS_UP Constant

nxllJwaIpIfCons.IF_ADMIN_STATUS_UP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_ADMIN_STATUS_UP = 1;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_ADMIN_STATUS_UP.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CHECK_MCAST Constant

nxllJwaIpIfCons.IF_CHECK_MCAST Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CHECK_MCAST = $01;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_CHECK_MCAST.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CHECK_NONE Constant

nxllJwaIpIfCons.IF_CHECK_NONE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CHECK_NONE = $00;
File

nxllJwaIpIfCons

Description

Interface Capabilities (bit flags)

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CHECK_SEND Constant

nxllJwaIpIfCons.IF_CHECK_SEND Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CHECK_SEND = $02;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_CHECK_SEND.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CONNECTION_DEDICATED Constant

nxllJwaIpIfCons.IF_CONNECTION_DEDICATED Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CONNECTION_DEDICATED = 1;
File

nxllJwaIpIfCons

Description

Connection Types

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CONNECTION_DEMAND Constant

nxllJwaIpIfCons.IF_CONNECTION_DEMAND Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CONNECTION_DEMAND = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_CONNECTION_DEMAND.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_CONNECTION_PASSIVE Constant

nxllJwaIpIfCons.IF_CONNECTION_PASSIVE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_CONNECTION_PASSIVE = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_CONNECTION_PASSIVE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTED Constant

nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTED Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_CONNECTED = 4;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTED.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTING Constant

nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_CONNECTING = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_OPER_STATUS_CONNECTING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_DISCONNECTED Constant

nxllJwaIpIfCons.IF_OPER_STATUS_DISCONNECTED Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_DISCONNECTED = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_OPER_STATUS_DISCONNECTED.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_NON_OPERATIONAL Constant

nxllJwaIpIfCons.IF_OPER_STATUS_NON_OPERATIONAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_NON_OPERATIONAL = 0;
File

nxllJwaIpIfCons

Description

The following are the the operational states for WAN and LAN interfaces. The order of the states seems weird, but is done for a purpose. All states >= CONNECTED can transmit data right away. States >= DISCONNECTED can tx data but some set up might be needed. States < DISCONNECTED can not transmit data. A card is marked UNREACHABLE if DIM calls InterfaceUnreachable for reasons other than failure to connect.

NON_OPERATIONAL -- Valid for LAN Interfaces. Means the card is not working or not plugged in or has no address. UNREACHABLE -- Valid for WAN Interfaces. Means the remote site is not reachable at this time. DISCONNECTED -- Valid for WAN Interfaces. Means the remote site is not connected at this time. CONNECTING -- Valid for WAN Interfaces. Means a connection attempt has been initiated to the remote site. CONNECTED -- Valid for WAN Interfaces. Means the remote site is connected. OPERATIONAL -- Valid for LAN Interfaces. Means the card is plugged in and working.

It is the users duty to convert these values to MIB-II values if they are to be used by a subagent

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_OPERATIONAL Constant

nxllJwaIpIfCons.IF_OPER_STATUS_OPERATIONAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_OPERATIONAL = 5;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_OPER_STATUS_OPERATIONAL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_OPER_STATUS_UNREACHABLE Constant

nxllJwaIpIfCons.IF_OPER_STATUS_UNREACHABLE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_OPER_STATUS_UNREACHABLE = 1;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_OPER_STATUS_UNREACHABLE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_A12MPPSWITCH Constant

nxllJwaIpIfCons.IF_TYPE_A12MPPSWITCH Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_A12MPPSWITCH = 130;
File

nxllJwaIpIfCons

Description

Avalon Parallel Processor

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_AAL5 Constant

nxllJwaIpIfCons.IF_TYPE_AAL5 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_AAL5 = 49;
File

nxllJwaIpIfCons

Description

AAL5 over ATM

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ADSL Constant

nxllJwaIpIfCons.IF_TYPE_ADSL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ADSL = 94;
File

nxllJwaIpIfCons

Description

Asymmetric Digital Subscrbr Loop

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_AFLANE_8023 Constant

nxllJwaIpIfCons.IF_TYPE_AFLANE_8023 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_AFLANE_8023 = 59;
File

nxllJwaIpIfCons

Description

ATM Emulated LAN for 802.3

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_AFLANE_8025 Constant

nxllJwaIpIfCons.IF_TYPE_AFLANE_8025 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_AFLANE_8025 = 60;
File

nxllJwaIpIfCons

Description

ATM Emulated LAN for 802.5

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ARAP Constant

nxllJwaIpIfCons.IF_TYPE_ARAP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ARAP = 88;
File

nxllJwaIpIfCons

Description

Appletalk Remote Access Protocol

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ARCNET Constant

nxllJwaIpIfCons.IF_TYPE_ARCNET Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ARCNET = 35;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ARCNET_PLUS Constant

nxllJwaIpIfCons.IF_TYPE_ARCNET_PLUS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ARCNET_PLUS = 36;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ARCNET_PLUS.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ASYNC Constant

nxllJwaIpIfCons.IF_TYPE_ASYNC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ASYNC = 84;
File

nxllJwaIpIfCons

Description

Asynchronous Protocol

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM Constant

nxllJwaIpIfCons.IF_TYPE_ATM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM = 37;
File

nxllJwaIpIfCons

Description

ATM cells

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM_DXI Constant

nxllJwaIpIfCons.IF_TYPE_ATM_DXI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM_DXI = 105;
File

nxllJwaIpIfCons

Description

ATM DXI

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM_FUNI Constant

nxllJwaIpIfCons.IF_TYPE_ATM_FUNI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM_FUNI = 106;
File

nxllJwaIpIfCons

Description

ATM FUNI

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM_IMA Constant

nxllJwaIpIfCons.IF_TYPE_ATM_IMA Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM_IMA = 107;
File

nxllJwaIpIfCons

Description

ATM IMA

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM_LOGICAL Constant

nxllJwaIpIfCons.IF_TYPE_ATM_LOGICAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM_LOGICAL = 80;
File

nxllJwaIpIfCons

Description

ATM Logical Port

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ATM_SUBINTERFACE Constant

nxllJwaIpIfCons.IF_TYPE_ATM_SUBINTERFACE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ATM_SUBINTERFACE = 134;
File

nxllJwaIpIfCons

Description

ATM Sub Interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_BASIC_ISDN Constant

nxllJwaIpIfCons.IF_TYPE_BASIC_ISDN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_BASIC_ISDN = 20;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_BASIC_ISDN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_BSC Constant

nxllJwaIpIfCons.IF_TYPE_BSC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_BSC = 83;
File

nxllJwaIpIfCons

Description

Bisynchronous Protocol

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_CCTEMUL Constant

nxllJwaIpIfCons.IF_TYPE_CCTEMUL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_CCTEMUL = 61;
File

nxllJwaIpIfCons

Description

ATM Emulated circuit

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_CES Constant

nxllJwaIpIfCons.IF_TYPE_CES Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_CES = 133;
File

nxllJwaIpIfCons

Description

Circuit Emulation Service

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_CHANNEL Constant

nxllJwaIpIfCons.IF_TYPE_CHANNEL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_CHANNEL = 70;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_CHANNEL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_CNR Constant

nxllJwaIpIfCons.IF_TYPE_CNR Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_CNR = 85;
File

nxllJwaIpIfCons

Description

Combat Net Radio

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_COFFEE Constant

nxllJwaIpIfCons.IF_TYPE_COFFEE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_COFFEE = 132;
File

nxllJwaIpIfCons

Description

Coffee pot

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DCN Constant

nxllJwaIpIfCons.IF_TYPE_DCN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DCN = 141;
File

nxllJwaIpIfCons

Description

Data Communications Network

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DDN_X25 Constant

nxllJwaIpIfCons.IF_TYPE_DDN_X25 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DDN_X25 = 4;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_DDN_X25.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DIGITALPOWERLINE Constant

nxllJwaIpIfCons.IF_TYPE_DIGITALPOWERLINE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DIGITALPOWERLINE = 138;
File

nxllJwaIpIfCons

Description

IP over Power Lines

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DLSW Constant

nxllJwaIpIfCons.IF_TYPE_DLSW Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DLSW = 74;
File

nxllJwaIpIfCons

Description

Data Link Switching

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_DOWNSTREAM Constant

nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_DOWNSTREAM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DOCSCABLE_DOWNSTREAM = 128;
File

nxllJwaIpIfCons

Description

CATV Downstream interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_MACLAYER Constant

nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_MACLAYER Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DOCSCABLE_MACLAYER = 127;
File

nxllJwaIpIfCons

Description

CATV Mac Layer

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_UPSTREAM Constant

nxllJwaIpIfCons.IF_TYPE_DOCSCABLE_UPSTREAM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DOCSCABLE_UPSTREAM = 129;
File

nxllJwaIpIfCons

Description

CATV Upstream interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DS0 Constant

nxllJwaIpIfCons.IF_TYPE_DS0 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DS0 = 81;
File

nxllJwaIpIfCons

Description

Digital Signal Level 0

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DS0_BUNDLE Constant

nxllJwaIpIfCons.IF_TYPE_DS0_BUNDLE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DS0_BUNDLE = 82;
File

nxllJwaIpIfCons

Description

Group of ds0s on the same ds1

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DS1 Constant

nxllJwaIpIfCons.IF_TYPE_DS1 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DS1 = 18;
File

nxllJwaIpIfCons

Description

DS1-MIB

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DS3 Constant

nxllJwaIpIfCons.IF_TYPE_DS3 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DS3 = 30;
File

nxllJwaIpIfCons

Description

DS3-MIB

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_DTM Constant

nxllJwaIpIfCons.IF_TYPE_DTM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_DTM = 140;
File

nxllJwaIpIfCons

Description

Dynamic syncronous Transfer Mode

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_E1 Constant

nxllJwaIpIfCons.IF_TYPE_E1 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_E1 = 19;
File

nxllJwaIpIfCons

Description

Obsolete; see DS1-MIB

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_EON Constant

nxllJwaIpIfCons.IF_TYPE_EON Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_EON = 25;
File

nxllJwaIpIfCons

Description

CLNP over IP

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_EPLRS Constant

nxllJwaIpIfCons.IF_TYPE_EPLRS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_EPLRS = 87;
File

nxllJwaIpIfCons

Description

Ext Pos Loc Report Sys

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ESCON Constant

nxllJwaIpIfCons.IF_TYPE_ESCON Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ESCON = 73;
File

nxllJwaIpIfCons

Description

IBM Enterprise Systems Connection

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ETHERNET_3MBIT Constant

nxllJwaIpIfCons.IF_TYPE_ETHERNET_3MBIT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ETHERNET_3MBIT = 26;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_3MBIT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ETHERNET_CSMACD Constant

nxllJwaIpIfCons.IF_TYPE_ETHERNET_CSMACD Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ETHERNET_CSMACD = 6;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ETHERNET_CSMACD.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FAST Constant

nxllJwaIpIfCons.IF_TYPE_FAST Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FAST = 125;
File

nxllJwaIpIfCons

Description

Fast channel

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FASTETHER Constant

nxllJwaIpIfCons.IF_TYPE_FASTETHER Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FASTETHER = 62;
File

nxllJwaIpIfCons

Description

Fast Ethernet (100BaseT)

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FASTETHER_FX Constant

nxllJwaIpIfCons.IF_TYPE_FASTETHER_FX Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FASTETHER_FX = 69;
File

nxllJwaIpIfCons

Description

Fast Ethernet (100BaseFX)

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FDDI Constant

nxllJwaIpIfCons.IF_TYPE_FDDI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FDDI = 15;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_FDDI.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FIBRECHANNEL Constant

nxllJwaIpIfCons.IF_TYPE_FIBRECHANNEL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FIBRECHANNEL = 56;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_FIBRECHANNEL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FRAMERELAY Constant

nxllJwaIpIfCons.IF_TYPE_FRAMERELAY Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FRAMERELAY = 32;
File

nxllJwaIpIfCons

Description

DTE only

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_INTERCONNECT Constant

nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_INTERCONNECT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FRAMERELAY_INTERCONNECT = 58;
File

nxllJwaIpIfCons

Description

Obsolete, use 32 or 44

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_MPI Constant

nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_MPI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FRAMERELAY_MPI = 92;
File

nxllJwaIpIfCons

Description

Multiproto Interconnect over FR

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_SERVICE Constant

nxllJwaIpIfCons.IF_TYPE_FRAMERELAY_SERVICE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_FRAMERELAY_SERVICE = 44;
File

nxllJwaIpIfCons

Description

FRNETSERV-MIB

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_G703_2MB Constant

nxllJwaIpIfCons.IF_TYPE_G703_2MB Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_G703_2MB = 67;
File

nxllJwaIpIfCons

Description

Obsolete; see DS1-MIB

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_G703_64K Constant

nxllJwaIpIfCons.IF_TYPE_G703_64K Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_G703_64K = 66;
File

nxllJwaIpIfCons

Description

CCITT G703 at 64Kbps

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_GIGABITETHERNET Constant

nxllJwaIpIfCons.IF_TYPE_GIGABITETHERNET Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_GIGABITETHERNET = 117;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_GIGABITETHERNET.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HDH_1822 Constant

nxllJwaIpIfCons.IF_TYPE_HDH_1822 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HDH_1822 = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HDH_1822.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HDLC Constant

nxllJwaIpIfCons.IF_TYPE_HDLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HDLC = 118;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HDLC.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HIPPI Constant

nxllJwaIpIfCons.IF_TYPE_HIPPI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HIPPI = 47;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HIPPI.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HIPPIINTERFACE Constant

nxllJwaIpIfCons.IF_TYPE_HIPPIINTERFACE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HIPPIINTERFACE = 57;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HIPPIINTERFACE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HOSTPAD Constant

nxllJwaIpIfCons.IF_TYPE_HOSTPAD Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HOSTPAD = 90;
File

nxllJwaIpIfCons

Description

CCITT-ITU X.29 PAD Protocol

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HSSI Constant

nxllJwaIpIfCons.IF_TYPE_HSSI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HSSI = 46;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HSSI.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_HYPERCHANNEL Constant

nxllJwaIpIfCons.IF_TYPE_HYPERCHANNEL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_HYPERCHANNEL = 14;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_HYPERCHANNEL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IBM370PARCHAN Constant

nxllJwaIpIfCons.IF_TYPE_IBM370PARCHAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IBM370PARCHAN = 72;
File

nxllJwaIpIfCons

Description

IBM System 360/370 OEMI Channel

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IEEE1394 Constant

nxllJwaIpIfCons.IF_TYPE_IEEE1394 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IEEE1394 = 144;
File

nxllJwaIpIfCons

Description

IEEE1394 High Perf Serial Bus

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IEEE80211 Constant

nxllJwaIpIfCons.IF_TYPE_IEEE80211 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IEEE80211 = 71;
File

nxllJwaIpIfCons

Description

Radio spread spectrum

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IEEE80212 Constant

nxllJwaIpIfCons.IF_TYPE_IEEE80212 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IEEE80212 = 55;
File

nxllJwaIpIfCons

Description

100BaseVG

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_INTERLEAVE Constant

nxllJwaIpIfCons.IF_TYPE_INTERLEAVE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_INTERLEAVE = 124;
File

nxllJwaIpIfCons

Description

Interleave channel

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IP Constant

nxllJwaIpIfCons.IF_TYPE_IP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IP = 126;
File

nxllJwaIpIfCons

Description

IP (for APPN HPR in IP networks)

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IPFORWARD Constant

nxllJwaIpIfCons.IF_TYPE_IPFORWARD Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IPFORWARD = 142;
File

nxllJwaIpIfCons

Description

IP Forwarding Interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IPOVER_ATM Constant

nxllJwaIpIfCons.IF_TYPE_IPOVER_ATM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IPOVER_ATM = 114;
File

nxllJwaIpIfCons

Description

IBM ipOverAtm

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IPOVER_CDLC Constant

nxllJwaIpIfCons.IF_TYPE_IPOVER_CDLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IPOVER_CDLC = 109;
File

nxllJwaIpIfCons

Description

IBM ipOverCdlc

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IPOVER_CLAW Constant

nxllJwaIpIfCons.IF_TYPE_IPOVER_CLAW Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IPOVER_CLAW = 110;
File

nxllJwaIpIfCons

Description

IBM Common Link Access to Workstn

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IPSWITCH Constant

nxllJwaIpIfCons.IF_TYPE_IPSWITCH Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IPSWITCH = 78;
File

nxllJwaIpIfCons

Description

IP Switching Objects

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_IS088023_CSMACD Constant

nxllJwaIpIfCons.IF_TYPE_IS088023_CSMACD Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_IS088023_CSMACD = 7;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_IS088023_CSMACD.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISDN Constant

nxllJwaIpIfCons.IF_TYPE_ISDN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISDN = 63;
File

nxllJwaIpIfCons

Description

ISDN and X.25

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISDN_S Constant

nxllJwaIpIfCons.IF_TYPE_ISDN_S Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISDN_S = 75;
File

nxllJwaIpIfCons

Description

ISDN S/T interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISDN_U Constant

nxllJwaIpIfCons.IF_TYPE_ISDN_U Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISDN_U = 76;
File

nxllJwaIpIfCons

Description

ISDN U interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88022_LLC Constant

nxllJwaIpIfCons.IF_TYPE_ISO88022_LLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88022_LLC = 41;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ISO88022_LLC.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88024_TOKENBUS Constant

nxllJwaIpIfCons.IF_TYPE_ISO88024_TOKENBUS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88024_TOKENBUS = 8;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ISO88024_TOKENBUS.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88025_CRFPRINT Constant

nxllJwaIpIfCons.IF_TYPE_ISO88025_CRFPRINT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88025_CRFPRINT = 98;
File

nxllJwaIpIfCons

Description

ISO 802.5 CRFP

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88025_FIBER Constant

nxllJwaIpIfCons.IF_TYPE_ISO88025_FIBER Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88025_FIBER = 115;
File

nxllJwaIpIfCons

Description

ISO 802.5j Fiber Token Ring

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88025_TOKENRING Constant

nxllJwaIpIfCons.IF_TYPE_ISO88025_TOKENRING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88025_TOKENRING = 9;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ISO88025_TOKENRING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88025R_DTR Constant

nxllJwaIpIfCons.IF_TYPE_ISO88025R_DTR Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88025R_DTR = 86;
File

nxllJwaIpIfCons

Description

ISO 802.5r DTR

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ISO88026_MAN Constant

nxllJwaIpIfCons.IF_TYPE_ISO88026_MAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ISO88026_MAN = 10;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_ISO88026_MAN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_L2_VLAN Constant

nxllJwaIpIfCons.IF_TYPE_L2_VLAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_L2_VLAN = 135;
File

nxllJwaIpIfCons

Description

Layer 2 Virtual LAN using 802.1Q

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_L3_IPVLAN Constant

nxllJwaIpIfCons.IF_TYPE_L3_IPVLAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_L3_IPVLAN = 136;
File

nxllJwaIpIfCons

Description

Layer 3 Virtual LAN using IP

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_L3_IPXVLAN Constant

nxllJwaIpIfCons.IF_TYPE_L3_IPXVLAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_L3_IPXVLAN = 137;
File

nxllJwaIpIfCons

Description

Layer 3 Virtual LAN using IPX

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_LAP_B Constant

nxllJwaIpIfCons.IF_TYPE_LAP_B Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_LAP_B = 16;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_LAP_B.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_LAP_D Constant

nxllJwaIpIfCons.IF_TYPE_LAP_D Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_LAP_D = 77;
File

nxllJwaIpIfCons

Description

Link Access Protocol D

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_LAP_F Constant

nxllJwaIpIfCons.IF_TYPE_LAP_F Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_LAP_F = 119;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_LAP_F.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_LOCALTALK Constant

nxllJwaIpIfCons.IF_TYPE_LOCALTALK Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_LOCALTALK = 42;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_LOCALTALK.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MEDIAMAILOVERIP Constant

nxllJwaIpIfCons.IF_TYPE_MEDIAMAILOVERIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MEDIAMAILOVERIP = 139;
File

nxllJwaIpIfCons

Description

Multimedia Mail over IP

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MIO_X25 Constant

nxllJwaIpIfCons.IF_TYPE_MIO_X25 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MIO_X25 = 38;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_MIO_X25.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MODEM Constant

nxllJwaIpIfCons.IF_TYPE_MODEM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MODEM = 48;
File

nxllJwaIpIfCons

Description

Generic Modem

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MPC Constant

nxllJwaIpIfCons.IF_TYPE_MPC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MPC = 113;
File

nxllJwaIpIfCons

Description

IBM multi-proto channel support

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MSDSL Constant

nxllJwaIpIfCons.IF_TYPE_MSDSL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MSDSL = 143;
File

nxllJwaIpIfCons

Description

Multi-rate Symmetric DSL

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_MYRINET Constant

nxllJwaIpIfCons.IF_TYPE_MYRINET Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_MYRINET = 99;
File

nxllJwaIpIfCons

Description

Myricom Myrinet

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_NSIP Constant

nxllJwaIpIfCons.IF_TYPE_NSIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_NSIP = 27;
File

nxllJwaIpIfCons

Description

XNS over IP

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_OTHER Constant

nxllJwaIpIfCons.IF_TYPE_OTHER Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_OTHER = 1;
File

nxllJwaIpIfCons

Description

None of the below

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PARA Constant

nxllJwaIpIfCons.IF_TYPE_PARA Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PARA = 34;
File

nxllJwaIpIfCons

Description

Parallel port

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PPP Constant

nxllJwaIpIfCons.IF_TYPE_PPP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PPP = 23;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_PPP.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PPPMULTILINKBUNDLE Constant

nxllJwaIpIfCons.IF_TYPE_PPPMULTILINKBUNDLE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PPPMULTILINKBUNDLE = 108;
File

nxllJwaIpIfCons

Description

PPP Multilink Bundle

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PRIMARY_ISDN Constant

nxllJwaIpIfCons.IF_TYPE_PRIMARY_ISDN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PRIMARY_ISDN = 21;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_PRIMARY_ISDN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROP_CNLS Constant

nxllJwaIpIfCons.IF_TYPE_PROP_CNLS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROP_CNLS = 89;
File

nxllJwaIpIfCons

Description

Proprietary Connectionless Proto

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROP_MULTIPLEXOR Constant

nxllJwaIpIfCons.IF_TYPE_PROP_MULTIPLEXOR Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROP_MULTIPLEXOR = 54;
File

nxllJwaIpIfCons

Description

Proprietary multiplexing

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROP_POINT2POINT_SERIAL Constant

nxllJwaIpIfCons.IF_TYPE_PROP_POINT2POINT_SERIAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROP_POINT2POINT_SERIAL = 22;
File

nxllJwaIpIfCons

Description

proprietary serial

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROP_VIRTUAL Constant

nxllJwaIpIfCons.IF_TYPE_PROP_VIRTUAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROP_VIRTUAL = 53;
File

nxllJwaIpIfCons

Description

Proprietary virtual/internal

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROTEON_10MBIT Constant

nxllJwaIpIfCons.IF_TYPE_PROTEON_10MBIT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROTEON_10MBIT = 12;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_10MBIT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_PROTEON_80MBIT Constant

nxllJwaIpIfCons.IF_TYPE_PROTEON_80MBIT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_PROTEON_80MBIT = 13;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_PROTEON_80MBIT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_QLLC Constant

nxllJwaIpIfCons.IF_TYPE_QLLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_QLLC = 68;
File

nxllJwaIpIfCons

Description

SNA QLLC

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_RADSL Constant

nxllJwaIpIfCons.IF_TYPE_RADSL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_RADSL = 95;
File

nxllJwaIpIfCons

Description

Rate-Adapt Digital Subscrbr Loop

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_RECEIVE_ONLY Constant

nxllJwaIpIfCons.IF_TYPE_RECEIVE_ONLY Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_RECEIVE_ONLY = 145;
File

nxllJwaIpIfCons

Description

TV adapter type

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_REGULAR_1822 Constant

nxllJwaIpIfCons.IF_TYPE_REGULAR_1822 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_REGULAR_1822 = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_REGULAR_1822.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_RFC877_X25 Constant

nxllJwaIpIfCons.IF_TYPE_RFC877_X25 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_RFC877_X25 = 5;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_RFC877_X25.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_RS232 Constant

nxllJwaIpIfCons.IF_TYPE_RS232 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_RS232 = 33;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_RS232.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_RSRB Constant

nxllJwaIpIfCons.IF_TYPE_RSRB Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_RSRB = 79;
File

nxllJwaIpIfCons

Description

Remote Source Route Bridging

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SDLC Constant

nxllJwaIpIfCons.IF_TYPE_SDLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SDLC = 17;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_SDLC.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SDSL Constant

nxllJwaIpIfCons.IF_TYPE_SDSL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SDSL = 96;
File

nxllJwaIpIfCons

Description

Symmetric Digital Subscriber Loop

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SIP Constant

nxllJwaIpIfCons.IF_TYPE_SIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SIP = 31;
File

nxllJwaIpIfCons

Description

SMDS, coffee

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SLIP Constant

nxllJwaIpIfCons.IF_TYPE_SLIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SLIP = 28;
File

nxllJwaIpIfCons

Description

Generic Slip

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SMDS_DXI Constant

nxllJwaIpIfCons.IF_TYPE_SMDS_DXI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SMDS_DXI = 43;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_SMDS_DXI.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SMDS_ICIP Constant

nxllJwaIpIfCons.IF_TYPE_SMDS_ICIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SMDS_ICIP = 52;
File

nxllJwaIpIfCons

Description

SMDS InterCarrier Interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SOFTWARE_LOOPBACK Constant

nxllJwaIpIfCons.IF_TYPE_SOFTWARE_LOOPBACK Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SOFTWARE_LOOPBACK = 24;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_SOFTWARE_LOOPBACK.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SONET Constant

nxllJwaIpIfCons.IF_TYPE_SONET Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SONET = 39;
File

nxllJwaIpIfCons

Description

SONET or SDH

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SONET_PATH Constant

nxllJwaIpIfCons.IF_TYPE_SONET_PATH Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SONET_PATH = 50;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_SONET_PATH.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_SONET_VT Constant

nxllJwaIpIfCons.IF_TYPE_SONET_VT Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_SONET_VT = 51;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_SONET_VT.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_STACKTOSTACK Constant

nxllJwaIpIfCons.IF_TYPE_STACKTOSTACK Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_STACKTOSTACK = 111;
File

nxllJwaIpIfCons

Description

IBM stackToStack

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_STARLAN Constant

nxllJwaIpIfCons.IF_TYPE_STARLAN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_STARLAN = 11;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_STARLAN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_TDLC Constant

nxllJwaIpIfCons.IF_TYPE_TDLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_TDLC = 116;
File

nxllJwaIpIfCons

Description

IBM twinaxial data link control

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_TERMPAD Constant

nxllJwaIpIfCons.IF_TYPE_TERMPAD Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_TERMPAD = 91;
File

nxllJwaIpIfCons

Description

CCITT-ITU X.3 PAD Facility

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_TRANSPHDLC Constant

nxllJwaIpIfCons.IF_TYPE_TRANSPHDLC Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_TRANSPHDLC = 123;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_TRANSPHDLC.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_TUNNEL Constant

nxllJwaIpIfCons.IF_TYPE_TUNNEL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_TUNNEL = 131;
File

nxllJwaIpIfCons

Description

Encapsulation interface

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_ULTRA Constant

nxllJwaIpIfCons.IF_TYPE_ULTRA Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_ULTRA = 29;
File

nxllJwaIpIfCons

Description

ULTRA Technologies

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_V11 Constant

nxllJwaIpIfCons.IF_TYPE_V11 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_V11 = 64;
File

nxllJwaIpIfCons

Description

CCITT V.11/X.21

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_V35 Constant

nxllJwaIpIfCons.IF_TYPE_V35 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_V35 = 45;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_V35.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_V36 Constant

nxllJwaIpIfCons.IF_TYPE_V36 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_V36 = 65;
File

nxllJwaIpIfCons

Description

CCITT V.36

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_V37 Constant

nxllJwaIpIfCons.IF_TYPE_V37 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_V37 = 120;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_V37.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VDSL Constant

nxllJwaIpIfCons.IF_TYPE_VDSL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VDSL = 97;
File

nxllJwaIpIfCons

Description

Very H-Speed Digital Subscrb Loop

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VIRTUALIPADDRESS Constant

nxllJwaIpIfCons.IF_TYPE_VIRTUALIPADDRESS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VIRTUALIPADDRESS = 112;
File

nxllJwaIpIfCons

Description

IBM VIPA

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VOICE_EM Constant

nxllJwaIpIfCons.IF_TYPE_VOICE_EM Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VOICE_EM = 100;
File

nxllJwaIpIfCons

Description

Voice recEive and transMit

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VOICE_ENCAP Constant

nxllJwaIpIfCons.IF_TYPE_VOICE_ENCAP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VOICE_ENCAP = 103;
File

nxllJwaIpIfCons

Description

Voice encapsulation

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VOICE_FXO Constant

nxllJwaIpIfCons.IF_TYPE_VOICE_FXO Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VOICE_FXO = 101;
File

nxllJwaIpIfCons

Description

Voice Foreign Exchange Office

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VOICE_FXS Constant

nxllJwaIpIfCons.IF_TYPE_VOICE_FXS Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VOICE_FXS = 102;
File

nxllJwaIpIfCons

Description

Voice Foreign Exchange Station

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_VOICE_OVERIP Constant

nxllJwaIpIfCons.IF_TYPE_VOICE_OVERIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_VOICE_OVERIP = 104;
File

nxllJwaIpIfCons

Description

Voice over IP encapsulation

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_X213 Constant

nxllJwaIpIfCons.IF_TYPE_X213 Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_X213 = 93;
File

nxllJwaIpIfCons

Description

CCITT-ITU X213

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_X25_HUNTGROUP Constant

nxllJwaIpIfCons.IF_TYPE_X25_HUNTGROUP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_X25_HUNTGROUP = 122;
File

nxllJwaIpIfCons

Description

X.25 Hunt Group

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_X25_MLP Constant

nxllJwaIpIfCons.IF_TYPE_X25_MLP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_X25_MLP = 121;
File

nxllJwaIpIfCons

Description

Multi-Link Protocol

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.IF_TYPE_X25_PLE Constant

nxllJwaIpIfCons.IF_TYPE_X25_PLE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
IF_TYPE_X25_PLE = 40;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.IF_TYPE_X25_PLE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MAX_IF_TYPE Constant

nxllJwaIpIfCons.MAX_IF_TYPE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MAX_IF_TYPE = 145;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MAX_IF_TYPE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_DOWN Constant

nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_DOWN Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_ADMIN_STATUS_DOWN = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_DOWN.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_TESTING Constant

nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_TESTING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_ADMIN_STATUS_TESTING = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_TESTING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_UP Constant

nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_UP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_ADMIN_STATUS_UP = 1;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_ADMIN_STATUS_UP.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTED Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTED Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_CONNECTED = 4;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTED.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTING Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_CONNECTING = 3;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_CONNECTING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_DISCONNECTED Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_DISCONNECTED Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_DISCONNECTED = 2;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_DISCONNECTED.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_NON_OPERATIONAL Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_NON_OPERATIONAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_NON_OPERATIONAL = 0;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_NON_OPERATIONAL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_OPERATIONAL Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_OPERATIONAL Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_OPERATIONAL = 5;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_OPERATIONAL.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_OPER_STATUS_UNREACHABLE Constant

nxllJwaIpIfCons.MIB_IF_OPER_STATUS_UNREACHABLE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_OPER_STATUS_UNREACHABLE = 1;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_OPER_STATUS_UNREACHABLE.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_ETHERNET Constant

nxllJwaIpIfCons.MIB_IF_TYPE_ETHERNET Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_ETHERNET = 6;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_ETHERNET.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_FDDI Constant

nxllJwaIpIfCons.MIB_IF_TYPE_FDDI Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_FDDI = 15;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_FDDI.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_LOOPBACK Constant

nxllJwaIpIfCons.MIB_IF_TYPE_LOOPBACK Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_LOOPBACK = 24;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_LOOPBACK.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_OTHER Constant

nxllJwaIpIfCons.MIB_IF_TYPE_OTHER Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_OTHER = 1;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_OTHER.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_PPP Constant

nxllJwaIpIfCons.MIB_IF_TYPE_PPP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_PPP = 23;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_PPP.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_SLIP Constant

nxllJwaIpIfCons.MIB_IF_TYPE_SLIP Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_SLIP = 28;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_SLIP.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIB_IF_TYPE_TOKENRING Constant

nxllJwaIpIfCons.MIB_IF_TYPE_TOKENRING Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIB_IF_TYPE_TOKENRING = 9;
File

nxllJwaIpIfCons

Description

This is constant nxllJwaIpIfCons.MIB_IF_TYPE_TOKENRING.

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpIfCons.MIN_IF_TYPE Constant

nxllJwaIpIfCons.MIN_IF_TYPE Constant
nxllJwaIpIfCons Constants Send Feedback
Syntax
Delphi
MIN_IF_TYPE = 1;
File

nxllJwaIpIfCons

Description

Media types

Group

Constants

Links
nxllJwaIpIfCons, Constants


nxllJwaIpRtrMib Namespace

nxllJwaIpRtrMib Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

Id: JwaIpRtrMib.pas,v 1.8 2007/09/05 11:58:50 dezipaitor Exp

Constants
Name | Description
ANY_SIZE | This is constant nxllJwaIpRtrMib.ANY_SIZE.
BEST_IF | This is constant nxllJwaIpRtrMib.BEST_IF.
BEST_ROUTE | This is constant nxllJwaIpRtrMib.BEST_ROUTE.
DEST_LONGER | This is constant nxllJwaIpRtrMib.DEST_LONGER.
DEST_MATCHING | This is constant nxllJwaIpRtrMib.DEST_MATCHING.
DEST_SHORTER | This is constant nxllJwaIpRtrMib.DEST_SHORTER.
ICMP_STATS | This is constant nxllJwaIpRtrMib.ICMP_STATS.
ICMP4_DST_UNREACH | Destination Unreachable
ICMP4_ECHO_REPLY | Echo Reply
ICMP4_ECHO_REQUEST | Echo Request
ICMP4_MASK_REPLY | Address Mask Reply
ICMP4_MASK_REQUEST | Address Mask Request
ICMP4_PARAM_PROB | Parameter Problem
ICMP4_REDIRECT | Redirect
ICMP4_ROUTER_ADVERT | Router Advertisement
ICMP4_ROUTER_SOLICIT | Router Solicitation
ICMP4_SOURCE_QUENCH | Source Quench
ICMP4_TIME_EXCEEDED | Time Exceeded
ICMP4_TIMESTAMP_REPLY | Timestamp Reply
ICMP4_TIMESTAMP_REQUEST | Timestamp Request
ICMP6_DST_UNREACH | ICMPv6 Type Values from RFC 2292.
ICMP6_ECHO_REPLY | This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REPLY.
ICMP6_ECHO_REQUEST | This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REQUEST.
ICMP6_MEMBERSHIP_QUERY | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_QUERY.
ICMP6_MEMBERSHIP_REDUCTION | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REDUCTION.
ICMP6_MEMBERSHIP_REPORT | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REPORT.
ICMP6_PACKET_TOO_BIG | This is constant nxllJwaIpRtrMib.ICMP6_PACKET_TOO_BIG.
ICMP6_PARAM_PROB | This is constant nxllJwaIpRtrMib.ICMP6_PARAM_PROB.
ICMP6_TIME_EXCEEDED | This is constant nxllJwaIpRtrMib.ICMP6_TIME_EXCEEDED.
IF_NUMBER | The following #defines are the Ids of the MIB variables made accessible to the user via MprAdminMIBXXX Apis. It will be noticed that these are not the same as RFC 1213, since the MprAdminMIBXXX APIs work on rows and groups instead of scalar variables
IF_ROW | This is constant nxllJwaIpRtrMib.IF_ROW.
IF_STATUS | This is constant nxllJwaIpRtrMib.IF_STATUS.
IF_TABLE | This is constant nxllJwaIpRtrMib.IF_TABLE.
IP_ADDRROW | This is constant nxllJwaIpRtrMib.IP_ADDRROW.
IP_ADDRTABLE | This is constant nxllJwaIpRtrMib.IP_ADDRTABLE.
IP_FORWARDNUMBER | This is constant nxllJwaIpRtrMib.IP_FORWARDNUMBER.
IP_FORWARDROW | This is constant nxllJwaIpRtrMib.IP_FORWARDROW.
IP_FORWARDTABLE | This is constant nxllJwaIpRtrMib.IP_FORWARDTABLE.
IP_NETROW | This is constant nxllJwaIpRtrMib.IP_NETROW.
IP_NETTABLE | This is constant nxllJwaIpRtrMib.IP_NETTABLE.
IP_STATS | This is constant nxllJwaIpRtrMib.IP_STATS.
IP6_STATS | This is constant nxllJwaIpRtrMib.IP6_STATS.
IPRTRMGR_PID | This is constant nxllJwaIpRtrMib.IPRTRMGR_PID.
MAX_INTERFACE_NAME_LEN | MPRAPI.H
MAX_MIB_OFFSET | This is constant nxllJwaIpRtrMib.MAX_MIB_OFFSET.
MAX_SCOPE_NAME_LEN | This is constant nxllJwaIpRtrMib.MAX_SCOPE_NAME_LEN.
MAXLEN_IFDESCR | This is constant nxllJwaIpRtrMib.MAXLEN_IFDESCR.
MAXLEN_PHYSADDR | This is constant nxllJwaIpRtrMib.MAXLEN_PHYSADDR.
MCAST_BOUNDARY | This is constant nxllJwaIpRtrMib.MCAST_BOUNDARY.
MCAST_GLOBAL | This is constant nxllJwaIpRtrMib.MCAST_GLOBAL.
MCAST_IF_ENTRY | This is constant nxllJwaIpRtrMib.MCAST_IF_ENTRY.
MCAST_MFE | This is constant nxllJwaIpRtrMib.MCAST_MFE.
MCAST_MFE_STATS | This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS.
MCAST_MFE_STATS_EX | This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS_EX.
MCAST_SCOPE | This is constant nxllJwaIpRtrMib.MCAST_SCOPE.
MIB_IP_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_IP_FORWARDING.
MIB_IP_NOT_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_IP_NOT_FORWARDING.
MIB_IPADDR_DELETED | Address being deleted
MIB_IPADDR_DISCONNECTED | Address is on disconnected interface
MIB_IPADDR_DYNAMIC | Dynamic ipaddr
MIB_IPADDR_PRIMARY | Primary ipaddr
MIB_IPADDR_TRANSIENT | Transient address
MIB_IPNET_TYPE_DYNAMIC | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_DYNAMIC.
MIB_IPNET_TYPE_INVALID | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_INVALID.
MIB_IPNET_TYPE_OTHER | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_OTHER.
MIB_IPNET_TYPE_STATIC | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_STATIC.
MIB_IPPROTO_BBN | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BBN.
MIB_IPPROTO_BGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BGP.
MIB_IPPROTO_CISCO | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_CISCO.
MIB_IPPROTO_EGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_EGP.
MIB_IPPROTO_ES_IS | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ES_IS.
MIB_IPPROTO_GGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_GGP.
MIB_IPPROTO_HELLO | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_HELLO.
MIB_IPPROTO_ICMP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ICMP.
MIB_IPPROTO_IS_IS | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_IS_IS.
MIB_IPPROTO_LOCAL | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_LOCAL.
MIB_IPPROTO_NETMGMT | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NETMGMT.
MIB_IPPROTO_NT_AUTOSTATIC | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_AUTOSTATIC.
MIB_IPPROTO_NT_STATIC | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC.
MIB_IPPROTO_NT_STATIC_NON_DOD | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC_NON_DOD.
MIB_IPPROTO_OSPF | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_OSPF.
MIB_IPPROTO_OTHER | THESE MUST MATCH the ids in routprot.h
MIB_IPPROTO_RIP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_RIP.
MIB_IPROUTE_METRIC_UNUSED | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_METRIC_UNUSED.
MIB_IPROUTE_TYPE_DIRECT | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_DIRECT.
MIB_IPROUTE_TYPE_INDIRECT | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INDIRECT.
MIB_IPROUTE_TYPE_INVALID | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INVALID.
MIB_IPROUTE_TYPE_OTHER | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_OTHER.
MIB_TCP_MAXCONN_DYNAMIC | This is constant nxllJwaIpRtrMib.MIB_TCP_MAXCONN_DYNAMIC.
MIB_TCP_RTO_CONSTANT | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_CONSTANT.
MIB_TCP_RTO_OTHER | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_OTHER.
MIB_TCP_RTO_RSRE | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_RSRE.
MIB_TCP_RTO_VANJ | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_VANJ.
MIB_TCP_STATE_CLOSE_WAIT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSE_WAIT.
MIB_TCP_STATE_CLOSED | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSED.
MIB_TCP_STATE_CLOSING | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSING.
MIB_TCP_STATE_DELETE_TCB | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_DELETE_TCB.
MIB_TCP_STATE_ESTAB | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_ESTAB.
MIB_TCP_STATE_FIN_WAIT1 | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT1.
MIB_TCP_STATE_FIN_WAIT2 | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT2.
MIB_TCP_STATE_LAST_ACK | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LAST_ACK.
MIB_TCP_STATE_LISTEN | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LISTEN.
MIB_TCP_STATE_SYN_RCVD | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_RCVD.
MIB_TCP_STATE_SYN_SENT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_SENT.
MIB_TCP_STATE_TIME_WAIT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_TIME_WAIT.
MIB_USE_CURRENT_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_USE_CURRENT_FORWARDING.
MIB_USE_CURRENT_TTL | define SIZEOF_TCPTABLE(X) (FIELD_OFFSET(MIB_TCPTABLE,table[0]) + ((X) * sizeof(MIB_TCPROW)) + ALIGN_SIZE)
ND_NEIGHBOR_ADVERT | This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_ADVERT.
ND_NEIGHBOR_SOLICIT | This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_SOLICIT.
ND_REDIRECT | This is constant nxllJwaIpRtrMib.ND_REDIRECT.
ND_ROUTER_ADVERT | This is constant nxllJwaIpRtrMib.ND_ROUTER_ADVERT.
ND_ROUTER_SOLICIT | This is constant nxllJwaIpRtrMib.ND_ROUTER_SOLICIT.
NUMBER_OF_EXPORTED_VARIABLES | This is constant nxllJwaIpRtrMib.NUMBER_OF_EXPORTED_VARIABLES.
PROXY_ARP | This is constant nxllJwaIpRtrMib.PROXY_ARP.
ROUTE_LONGER | This is constant nxllJwaIpRtrMib.ROUTE_LONGER.
ROUTE_MATCHING | This is constant nxllJwaIpRtrMib.ROUTE_MATCHING.
ROUTE_SHORTER | This is constant nxllJwaIpRtrMib.ROUTE_SHORTER.
ROUTE_STATE | This is constant nxllJwaIpRtrMib.ROUTE_STATE.
TCP_ROW | This is constant nxllJwaIpRtrMib.TCP_ROW.
TCP_STATS | This is constant nxllJwaIpRtrMib.TCP_STATS.
TCP_TABLE | This is constant nxllJwaIpRtrMib.TCP_TABLE.
TCP6_STATS | This is constant nxllJwaIpRtrMib.TCP6_STATS.
UDP_ROW | This is constant nxllJwaIpRtrMib.UDP_ROW.
UDP_STATS | This is constant nxllJwaIpRtrMib.UDP_STATS.
UDP_TABLE | This is constant nxllJwaIpRtrMib.UDP_TABLE.
UDP6_STATS | This is constant nxllJwaIpRtrMib.UDP6_STATS.
Structs, Records, Enums
Name | Description
_MIB_BEST_IF | This is record nxllJwaIpRtrMib._MIB_BEST_IF.
_MIB_ICMP | This is record nxllJwaIpRtrMib._MIB_ICMP.
_MIB_ICMP_EX | This is record nxllJwaIpRtrMib._MIB_ICMP_EX.
_MIB_IFNUMBER | This is record nxllJwaIpRtrMib._MIB_IFNUMBER.
_MIB_IFROW | This is record nxllJwaIpRtrMib._MIB_IFROW.
_MIB_IFSTATUS | This is record nxllJwaIpRtrMib._MIB_IFSTATUS.
_MIB_IFTABLE | This is record nxllJwaIpRtrMib._MIB_IFTABLE.
_MIB_IPADDRROW | This is record nxllJwaIpRtrMib._MIB_IPADDRROW.
_MIB_IPADDRTABLE | This is record nxllJwaIpRtrMib._MIB_IPADDRTABLE.
_MIB_IPDESTROW | This is record nxllJwaIpRtrMib._MIB_IPDESTROW.
_MIB_IPDESTTABLE | This is record nxllJwaIpRtrMib._MIB_IPDESTTABLE.
_MIB_IPFORWARDNUMBER | This is record nxllJwaIpRtrMib._MIB_IPFORWARDNUMBER.
_MIB_IPFORWARDROW | This is record nxllJwaIpRtrMib._MIB_IPFORWARDROW.
_MIB_IPFORWARDTABLE | This is record nxllJwaIpRtrMib._MIB_IPFORWARDTABLE.
_MIB_IPMCAST_BOUNDARY | This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY.
_MIB_IPMCAST_BOUNDARY_TABLE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY_TABLE.
_MIB_IPMCAST_GLOBAL | This is record nxllJwaIpRtrMib._MIB_IPMCAST_GLOBAL.
_MIB_IPMCAST_IF_ENTRY | This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_ENTRY.
_MIB_IPMCAST_IF_TABLE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_TABLE.
_MIB_IPMCAST_MFE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE.
_MIB_IPMCAST_MFE_STATS | This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS.
_MIB_IPMCAST_MFE_STATS_EX | #define SIZEOF_MIB_MFE_STATS(X) (SIZEOF_BASIC_MIB_MFE_STATS + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))
_MIB_IPMCAST_OIF | This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF.
_MIB_IPMCAST_OIF_STATS | This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF_STATS.
_MIB_IPMCAST_SCOPE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_SCOPE.
_MIB_IPNETROW | This is record nxllJwaIpRtrMib._MIB_IPNETROW.
_MIB_IPNETTABLE | This is record nxllJwaIpRtrMib._MIB_IPNETTABLE.
_MIB_IPSTATS | This is record nxllJwaIpRtrMib._MIB_IPSTATS.
_MIB_MFE_STATS_TABLE | This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE.
_MIB_MFE_STATS_TABLE_EX | This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE_EX.
_MIB_MFE_TABLE | This is record nxllJwaIpRtrMib._MIB_MFE_TABLE.
_MIB_OPAQUE_INFO | This is record nxllJwaIpRtrMib._MIB_OPAQUE_INFO.
_MIB_OPAQUE_QUERY | This is record nxllJwaIpRtrMib._MIB_OPAQUE_QUERY.
_MIB_PROXYARP | This is record nxllJwaIpRtrMib._MIB_PROXYARP.
_MIB_ROUTESTATE | This is record nxllJwaIpRtrMib._MIB_ROUTESTATE.
_MIB_TCPROW | This is record nxllJwaIpRtrMib._MIB_TCPROW.
_MIB_TCPSTATS | This is record nxllJwaIpRtrMib._MIB_TCPSTATS.
_MIB_TCPTABLE | This is record nxllJwaIpRtrMib._MIB_TCPTABLE.
_MIB_UDPROW | This is record nxllJwaIpRtrMib._MIB_UDPROW.
_MIB_UDPSTATS | This is record nxllJwaIpRtrMib._MIB_UDPSTATS.
_MIB_UDPTABLE | This is record nxllJwaIpRtrMib._MIB_UDPTABLE.
_MIBICMPINFO | This is record nxllJwaIpRtrMib._MIBICMPINFO.
_MIBICMPSTATS | This is record nxllJwaIpRtrMib._MIBICMPSTATS.
_MIBICMPSTATS_EX | This is record nxllJwaIpRtrMib._MIBICMPSTATS_EX.
MIB_BOUNDARYROW | This is record nxllJwaIpRtrMib.MIB_BOUNDARYROW.
MIB_MCAST_LIMIT_ROW | This is record nxllJwaIpRtrMib.MIB_MCAST_LIMIT_ROW.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name
Description
ICMP4_TYPE
This is type nxllJwaIpRtrMib.ICMP4_TYPE.
ICMP6_TYPE
This is type nxllJwaIpRtrMib.ICMP6_TYPE.
MIB_BEST_IF
This is type nxllJwaIpRtrMib.MIB_BEST_IF.
MIB_ICMP
This is type nxllJwaIpRtrMib.MIB_ICMP.
MIB_ICMP_EX
This is type nxllJwaIpRtrMib.MIB_ICMP_EX.
MIB_IFNUMBER
This is type nxllJwaIpRtrMib.MIB_IFNUMBER.
MIB_IFROW
This is type nxllJwaIpRtrMib.MIB_IFROW.
MIB_IFSTATUS
This is type nxllJwaIpRtrMib.MIB_IFSTATUS.
MIB_IFTABLE
This is type nxllJwaIpRtrMib.MIB_IFTABLE.
MIB_IPADDRROW
This is type nxllJwaIpRtrMib.MIB_IPADDRROW.
MIB_IPADDRTABLE
This is type nxllJwaIpRtrMib.MIB_IPADDRTABLE.
MIB_IPDESTROW
This is type nxllJwaIpRtrMib.MIB_IPDESTROW.
MIB_IPDESTTABLE
This is type nxllJwaIpRtrMib.MIB_IPDESTTABLE.
MIB_IPFORWARDNUMBER
This is type nxllJwaIpRtrMib.MIB_IPFORWARDNUMBER.
MIB_IPFORWARDROW
This is type nxllJwaIpRtrMib.MIB_IPFORWARDROW.
MIB_IPFORWARDTABLE
This is type nxllJwaIpRtrMib.MIB_IPFORWARDTABLE.
MIB_IPMCAST_BOUNDARY
This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY.
MIB_IPMCAST_BOUNDARY_TABLE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY_TABLE.
MIB_IPMCAST_GLOBAL
This is type nxllJwaIpRtrMib.MIB_IPMCAST_GLOBAL.
MIB_IPMCAST_IF_ENTRY
This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_ENTRY.
MIB_IPMCAST_IF_TABLE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_TABLE.
MIB_IPMCAST_MFE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE.
MIB_IPMCAST_MFE_STATS
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS.
MIB_IPMCAST_MFE_STATS_EX
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS_EX.
MIB_IPMCAST_OIF
This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF.
MIB_IPMCAST_OIF_STATS
This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF_STATS.
MIB_IPMCAST_SCOPE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_SCOPE.
MIB_IPNETROW
This is type nxllJwaIpRtrMib.MIB_IPNETROW.
MIB_IPNETTABLE
This is type nxllJwaIpRtrMib.MIB_IPNETTABLE.
MIB_IPSTATS
This is type nxllJwaIpRtrMib.MIB_IPSTATS.
MIB_MFE_STATS_TABLE
This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE.
MIB_MFE_STATS_TABLE_EX
This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE_EX.
MIB_MFE_TABLE
This is type nxllJwaIpRtrMib.MIB_MFE_TABLE.
MIB_OPAQUE_INFO
This is type nxllJwaIpRtrMib.MIB_OPAQUE_INFO.
MIB_OPAQUE_QUERY
This is type nxllJwaIpRtrMib.MIB_OPAQUE_QUERY.
MIB_PROXYARP
This is type nxllJwaIpRtrMib.MIB_PROXYARP.
MIB_ROUTESTATE
This is type nxllJwaIpRtrMib.MIB_ROUTESTATE.
MIB_TCPROW
This is type nxllJwaIpRtrMib.MIB_TCPROW.
MIB_TCPSTATS
This is type nxllJwaIpRtrMib.MIB_TCPSTATS.
MIB_TCPTABLE
This is type nxllJwaIpRtrMib.MIB_TCPTABLE.
MIB_UDPROW
This is type nxllJwaIpRtrMib.MIB_UDPROW.
MIB_UDPSTATS
This is type nxllJwaIpRtrMib.MIB_UDPSTATS.
MIB_UDPTABLE
This is type nxllJwaIpRtrMib.MIB_UDPTABLE.
MIBICMPINFO
This is type nxllJwaIpRtrMib.MIBICMPINFO.
MIBICMPSTATS
This is type nxllJwaIpRtrMib.MIBICMPSTATS.
MIBICMPSTATS_EX
This is type nxllJwaIpRtrMib.MIBICMPSTATS_EX.
PICMP4_TYPE
This is type nxllJwaIpRtrMib.PICMP4_TYPE.
PIcmp4Type
This is type nxllJwaIpRtrMib.PIcmp4Type.
PICMP6_TYPE
This is type nxllJwaIpRtrMib.PICMP6_TYPE.
PIcmp6Type
This is type nxllJwaIpRtrMib.PIcmp6Type.
PMIB_BEST_IF
This is type nxllJwaIpRtrMib.PMIB_BEST_IF.
PMIB_BOUNDARYROW
define SIZEOF_BOUNDARY_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_BOUNDARY_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_BOUNDARY)) + ALIGN_SIZE)
PMIB_ICMP
This is type nxllJwaIpRtrMib.PMIB_ICMP.
PMIB_ICMP_EX
This is type nxllJwaIpRtrMib.PMIB_ICMP_EX.
PMIB_IFNUMBER
The following are the structures which are filled in and returned to the user when a query is made, OR are filled in BY THE USER when a set is done
PMIB_IFROW
This is type nxllJwaIpRtrMib.PMIB_IFROW.
PMIB_IFSTATUS
This is type nxllJwaIpRtrMib.PMIB_IFSTATUS.
PMIB_IFTABLE
This is type nxllJwaIpRtrMib.PMIB_IFTABLE.
PMIB_IPADDRROW
This is type nxllJwaIpRtrMib.PMIB_IPADDRROW.
PMIB_IPADDRTABLE
This is type nxllJwaIpRtrMib.PMIB_IPADDRTABLE.
PMIB_IPDESTROW
This is type nxllJwaIpRtrMib.PMIB_IPDESTROW.
PMIB_IPDESTTABLE
This is type nxllJwaIpRtrMib.PMIB_IPDESTTABLE.
PMIB_IPFORWARDNUMBER
define SIZEOF_IPADDRTABLE(X) (FIELD_OFFSET(MIB_IPADDRTABLE,table[0]) + ((X) * sizeof(MIB_IPADDRROW)) + ALIGN_SIZE)
PMIB_IPFORWARDROW
This is type nxllJwaIpRtrMib.PMIB_IPFORWARDROW.
PMIB_IPFORWARDTABLE
This is type nxllJwaIpRtrMib.PMIB_IPFORWARDTABLE.
PMIB_IPMCAST_BOUNDARY
define SIZEOF_MCAST_IF_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_IF_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_IF_ENTRY)) + ALIGN_SIZE)
PMIB_IPMCAST_BOUNDARY_TABLE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY_TABLE.
PMIB_IPMCAST_GLOBAL
#define SIZEOF_MIB_MFE_STATS_EX(X) (SIZEOF_BASIC_MIB_MFE_STATS_EX + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))
PMIB_IPMCAST_IF_ENTRY
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_ENTRY.
PMIB_IPMCAST_IF_TABLE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_TABLE.
PMIB_IPMCAST_MFE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE.
PMIB_IPMCAST_MFE_STATS
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS.
PMIB_IPMCAST_MFE_STATS_EX
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS_EX.
PMIB_IPMCAST_OIF
define SIZEOF_IPNETTABLE(X) (FIELD_OFFSET(MIB_IPNETTABLE, table[0]) + ((X) * sizeof(MIB_IPNETROW)) + ALIGN_SIZE)
PMIB_IPMCAST_OIF_STATS
#define SIZEOF_MIB_MFE(X) (SIZEOF_BASIC_MIB_MFE + ((X) * sizeof(MIB_IPMCAST_OIF)))
PMIB_IPMCAST_SCOPE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_SCOPE.
PMIB_IPNETROW
define SIZEOF_IPFORWARDTABLE(X) (FIELD_OFFSET(MIB_IPFORWARDTABLE,table[0]) + ((X) * sizeof(MIB_IPFORWARDROW)) + ALIGN_SIZE)
PMIB_IPNETTABLE
This is type nxllJwaIpRtrMib.PMIB_IPNETTABLE.
PMIB_IPSTATS
This is type nxllJwaIpRtrMib.PMIB_IPSTATS.
PMIB_MCAST_LIMIT_ROW
Structure matching what goes in the registry in a block of type IP_MCAST_LIMIT_INFO. This contains the fields of MIB_IPMCAST_IF_ENTRY which are configurable.
PMIB_MFE_STATS_TABLE
This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE.
PMIB_MFE_STATS_TABLE_EX
This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE_EX.
PMIB_MFE_TABLE
This is type nxllJwaIpRtrMib.PMIB_MFE_TABLE.
PMIB_OPAQUE_QUERY
MIB_OPAQUE_QUERY is the structure filled in by the user to identify a MIB variable
dwVarId ID of MIB Variable (One of the Ids #defined above) dwVarIndex Variable sized array containing the indices needed to identify a variable. NOTE: Unlike SNMP we dont require that a scalar variable be indexed by 0
PMIB_PROXYARP
This is type nxllJwaIpRtrMib.PMIB_PROXYARP.
PMIB_ROUTESTATE
This is type nxllJwaIpRtrMib.PMIB_ROUTESTATE.
PMIB_TCPROW
This is type nxllJwaIpRtrMib.PMIB_TCPROW.
PMIB_TCPSTATS
define SIZEOF_UDPTABLE(X) (FIELD_OFFSET(MIB_UDPTABLE, table[0]) + ((X) * sizeof(MIB_UDPROW)) + ALIGN_SIZE)
PMIB_TCPTABLE
This is type nxllJwaIpRtrMib.PMIB_TCPTABLE.
PMIB_UDPROW
This is type nxllJwaIpRtrMib.PMIB_UDPROW.
PMIB_UDPSTATS
This is type nxllJwaIpRtrMib.PMIB_UDPSTATS.
PMIB_UDPTABLE
This is type nxllJwaIpRtrMib.PMIB_UDPTABLE.
PMibBestIf
This is type nxllJwaIpRtrMib.PMibBestIf.
PMibBoundaryRow
This is type nxllJwaIpRtrMib.PMibBoundaryRow.
PMibIcmp
This is type nxllJwaIpRtrMib.PMibIcmp.
PMibIcmpEx
This is type nxllJwaIpRtrMib.PMibIcmpEx.
PMIBICMPINFO
This is type nxllJwaIpRtrMib.PMIBICMPINFO.
PMibIcmpStats
define SIZEOF_IFTABLE(X) (FIELD_OFFSET(MIB_IFTABLE,table[0]) + ((X) * sizeof(MIB_IFROW)) + ALIGN_SIZE)
PMIBICMPSTATS_EX
This is type nxllJwaIpRtrMib.PMIBICMPSTATS_EX.
PMibIcmpStatsEx
This is type nxllJwaIpRtrMib.PMibIcmpStatsEx.
PMibIfnumber
This is type nxllJwaIpRtrMib.PMibIfnumber.
PMibIfRow
This is type nxllJwaIpRtrMib.PMibIfRow.
PMibIfStatus
This is type nxllJwaIpRtrMib.PMibIfStatus.
PMibIftable
This is type nxllJwaIpRtrMib.PMibIftable.
PMibIpAddrRow
This is type nxllJwaIpRtrMib.PMibIpAddrRow.
PMibIpAddrTable
This is type nxllJwaIpRtrMib.PMibIpAddrTable.
PMibIpDestRow
This is type nxllJwaIpRtrMib.PMibIpDestRow.
PMibIpDestTable
This is type nxllJwaIpRtrMib.PMibIpDestTable.
PMibIpForwardNumber
This is type nxllJwaIpRtrMib.PMibIpForwardNumber.
PMibIpForwardRow
This is type nxllJwaIpRtrMib.PMibIpForwardRow.
PMibIpForwardTable
This is type nxllJwaIpRtrMib.PMibIpForwardTable.
PMibIpmCastBoundary
This is type nxllJwaIpRtrMib.PMibIpmCastBoundary.
PMibIpmCastBoundaryTable
This is type nxllJwaIpRtrMib.PMibIpmCastBoundaryTable.
PMibIpmCastGlobal
This is type nxllJwaIpRtrMib.PMibIpmCastGlobal.
PMibIpmCastIfEntry
This is type nxllJwaIpRtrMib.PMibIpmCastIfEntry.
PMibIpmCastIfTable
This is type nxllJwaIpRtrMib.PMibIpmCastIfTable.
PMibIpmCastMfe
This is type nxllJwaIpRtrMib.PMibIpmCastMfe.
PMibIpmCastMfeStats
This is type nxllJwaIpRtrMib.PMibIpmCastMfeStats.
PMibIpMCastMfeStatsEx
This is type nxllJwaIpRtrMib.PMibIpMCastMfeStatsEx.
PMibIpmCastOif
This is type nxllJwaIpRtrMib.PMibIpmCastOif.
PMibIpmCastOifStats
This is type nxllJwaIpRtrMib.PMibIpmCastOifStats.
PMibIpmCastScope
This is type nxllJwaIpRtrMib.PMibIpmCastScope.
PMibIpNetRow
This is type nxllJwaIpRtrMib.PMibIpNetRow.
PMibIpNetTable
This is type nxllJwaIpRtrMib.PMibIpNetTable.
PMibIpStats
This is type nxllJwaIpRtrMib.PMibIpStats.
PMibMcastLimitRow
This is type nxllJwaIpRtrMib.PMibMcastLimitRow.
PMibMfeStatsTable
This is type nxllJwaIpRtrMib.PMibMfeStatsTable.
PMibMfeStatsTableEx
This is type nxllJwaIpRtrMib.PMibMfeStatsTableEx.
PMibMfeTable
This is type nxllJwaIpRtrMib.PMibMfeTable.
PMibOpaqueInfo
All the info passed to (SET/CREATE) and from (GET/GETNEXT/GETFIRST) IP Router Manager is encapsulated in the following "discriminated" union. To pass, say MIB_IFROW, use the following code
PMIB_OPAQUE_INFO pInfo; PMIB_IFROW pIfRow; DWORD rgdwBuff[(MAX_MIB_OFFSET + sizeof(MIB_IFROW))/sizeof(DWORD) + 1];
pInfo = (PMIB_OPAQUE_INFO)rgdwBuffer; pIfRow = (MIB_IFROW *)(pInfo->rgbyData);
This can also be accomplished by using the following macro
DEFINE_MIB_BUFFER(pInfo,MIB_IFROW, pIfRow);
PMibOpaqueQuery
This is type nxllJwaIpRtrMib.PMibOpaqueQuery.
PMibProxyArp
This is type nxllJwaIpRtrMib.PMibProxyArp.
PMibRouteState
This is type nxllJwaIpRtrMib.PMibRouteState.
PMibTcpRow
This is type nxllJwaIpRtrMib.PMibTcpRow.
PMibTcpStats
This is type nxllJwaIpRtrMib.PMibTcpStats.
PMibTcpTable
This is type nxllJwaIpRtrMib.PMibTcpTable.
PMibUdpRow
This is type nxllJwaIpRtrMib.PMibUdpRow.
PMibUdpStats
This is type nxllJwaIpRtrMib.PMibUdpStats.
PMibUdpTable
This is type nxllJwaIpRtrMib.PMibUdpTable.
SCOPE_NAME
This is type nxllJwaIpRtrMib.SCOPE_NAME.
SCOPE_NAME_BUFFER
This is type nxllJwaIpRtrMib.SCOPE_NAME_BUFFER.
SN_CHAR
Scope names are unicode. SNMP and MZAP use UTF-8 encoding.
TIcmp4Type
This is type nxllJwaIpRtrMib.TIcmp4Type.
TIcmp6Type
This is type nxllJwaIpRtrMib.TIcmp6Type.
TMibBestIf
This is type nxllJwaIpRtrMib.TMibBestIf.
TMibBoundaryRow
This is type nxllJwaIpRtrMib.TMibBoundaryRow.
TMibIcmp
This is type nxllJwaIpRtrMib.TMibIcmp.
TMibIcmpEx
This is type nxllJwaIpRtrMib.TMibIcmpEx.
TMibIcmpInfo
This is type nxllJwaIpRtrMib.TMibIcmpInfo.
TMibIcmpStats
This is type nxllJwaIpRtrMib.TMibIcmpStats.
TMibIcmpStatsEx
This is type nxllJwaIpRtrMib.TMibIcmpStatsEx.
TMibIfnumber
This is type nxllJwaIpRtrMib.TMibIfnumber.
TMibIfRow
This is type nxllJwaIpRtrMib.TMibIfRow.
TMibIfStatus
This is type nxllJwaIpRtrMib.TMibIfStatus.
TMibIftable
This is type nxllJwaIpRtrMib.TMibIftable.
TMibIpAddrRow
This is type nxllJwaIpRtrMib.TMibIpAddrRow.
TMibIpAddrTable
This is type nxllJwaIpRtrMib.TMibIpAddrTable.
TMibIpDestRow
This is type nxllJwaIpRtrMib.TMibIpDestRow.
TMibIpDestTable
This is type nxllJwaIpRtrMib.TMibIpDestTable.
TMibIpForwardNumber
This is type nxllJwaIpRtrMib.TMibIpForwardNumber.
TMibIpForwardRow
This is type nxllJwaIpRtrMib.TMibIpForwardRow.
TMibIpForwardTable
This is type nxllJwaIpRtrMib.TMibIpForwardTable.
TMibIpmCastBoundary
This is type nxllJwaIpRtrMib.TMibIpmCastBoundary.
TMibIpmCastBoundaryTable
This is type nxllJwaIpRtrMib.TMibIpmCastBoundaryTable.
TMibIpmCastGlobal
This is type nxllJwaIpRtrMib.TMibIpmCastGlobal.
TMibIpmCastIfEntry
This is type nxllJwaIpRtrMib.TMibIpmCastIfEntry.
TMibIpmCastIfTable
This is type nxllJwaIpRtrMib.TMibIpmCastIfTable.
TMibIpmCastMfe
This is type nxllJwaIpRtrMib.TMibIpmCastMfe.
TMibIpmCastMfeStats
This is type nxllJwaIpRtrMib.TMibIpmCastMfeStats.
TMibIpMCastMfeStatsEx
This is type nxllJwaIpRtrMib.TMibIpMCastMfeStatsEx.
TMibIpmCastOif
This is type nxllJwaIpRtrMib.TMibIpmCastOif.
TMibIpmCastOifStats
This is type nxllJwaIpRtrMib.TMibIpmCastOifStats.
TMibIpmCastScope
This is type nxllJwaIpRtrMib.TMibIpmCastScope.
TMibIpNetRow
This is type nxllJwaIpRtrMib.TMibIpNetRow.
TMibIpNetTable
This is type nxllJwaIpRtrMib.TMibIpNetTable.
TMibIpStats
This is type nxllJwaIpRtrMib.TMibIpStats.
TMibMcastLimitRow
This is type nxllJwaIpRtrMib.TMibMcastLimitRow.
TMibMfeStatsTable
This is type nxllJwaIpRtrMib.TMibMfeStatsTable.
TMibMfeStatsTableEx
This is type nxllJwaIpRtrMib.TMibMfeStatsTableEx.
TMibMfeTable
This is type nxllJwaIpRtrMib.TMibMfeTable.
TMibOpaqueInfo
This is type nxllJwaIpRtrMib.TMibOpaqueInfo.
TMibOpaqueQuery
This is type nxllJwaIpRtrMib.TMibOpaqueQuery.
TMibProxyArp
This is type nxllJwaIpRtrMib.TMibProxyArp.
TMibRouteState
This is type nxllJwaIpRtrMib.TMibRouteState.
TMibTcpRow
This is type nxllJwaIpRtrMib.TMibTcpRow.
TMibTcpStats
This is type nxllJwaIpRtrMib.TMibTcpStats.
TMibTcpTable
This is type nxllJwaIpRtrMib.TMibTcpTable.
TMibUdpRow
This is type nxllJwaIpRtrMib.TMibUdpRow.
TMibUdpStats
This is type nxllJwaIpRtrMib.TMibUdpStats.
TMibUdpTable
This is type nxllJwaIpRtrMib.TMibUdpTable.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
nxllJwaIpRtrMib Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllJwaIpRtrMib Namespace

Records
Name | Description
_MIB_BEST_IF | This is record nxllJwaIpRtrMib._MIB_BEST_IF.
_MIB_ICMP | This is record nxllJwaIpRtrMib._MIB_ICMP.
_MIB_ICMP_EX | This is record nxllJwaIpRtrMib._MIB_ICMP_EX.
_MIB_IFNUMBER | This is record nxllJwaIpRtrMib._MIB_IFNUMBER.
_MIB_IFROW | This is record nxllJwaIpRtrMib._MIB_IFROW.
_MIB_IFSTATUS | This is record nxllJwaIpRtrMib._MIB_IFSTATUS.
_MIB_IFTABLE | This is record nxllJwaIpRtrMib._MIB_IFTABLE.
_MIB_IPADDRROW | This is record nxllJwaIpRtrMib._MIB_IPADDRROW.
_MIB_IPADDRTABLE | This is record nxllJwaIpRtrMib._MIB_IPADDRTABLE.
_MIB_IPDESTROW | This is record nxllJwaIpRtrMib._MIB_IPDESTROW.
_MIB_IPDESTTABLE | This is record nxllJwaIpRtrMib._MIB_IPDESTTABLE.
_MIB_IPFORWARDNUMBER | This is record nxllJwaIpRtrMib._MIB_IPFORWARDNUMBER.
_MIB_IPFORWARDROW | This is record nxllJwaIpRtrMib._MIB_IPFORWARDROW.
_MIB_IPFORWARDTABLE | This is record nxllJwaIpRtrMib._MIB_IPFORWARDTABLE.
_MIB_IPMCAST_BOUNDARY | This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY.
_MIB_IPMCAST_BOUNDARY_TABLE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY_TABLE.
_MIB_IPMCAST_GLOBAL | This is record nxllJwaIpRtrMib._MIB_IPMCAST_GLOBAL.
_MIB_IPMCAST_IF_ENTRY | This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_ENTRY.
_MIB_IPMCAST_IF_TABLE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_TABLE.
_MIB_IPMCAST_MFE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE.
_MIB_IPMCAST_MFE_STATS | This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS.
_MIB_IPMCAST_MFE_STATS_EX | #define SIZEOF_MIB_MFE_STATS(X) (SIZEOF_BASIC_MIB_MFE_STATS + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))
_MIB_IPMCAST_OIF | This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF.
_MIB_IPMCAST_OIF_STATS | This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF_STATS.
_MIB_IPMCAST_SCOPE | This is record nxllJwaIpRtrMib._MIB_IPMCAST_SCOPE.
_MIB_IPNETROW | This is record nxllJwaIpRtrMib._MIB_IPNETROW.
_MIB_IPNETTABLE | This is record nxllJwaIpRtrMib._MIB_IPNETTABLE.
_MIB_IPSTATS | This is record nxllJwaIpRtrMib._MIB_IPSTATS.
_MIB_MFE_STATS_TABLE | This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE.
_MIB_MFE_STATS_TABLE_EX | This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE_EX.
_MIB_MFE_TABLE | This is record nxllJwaIpRtrMib._MIB_MFE_TABLE.
_MIB_OPAQUE_INFO | This is record nxllJwaIpRtrMib._MIB_OPAQUE_INFO.
_MIB_OPAQUE_QUERY | This is record nxllJwaIpRtrMib._MIB_OPAQUE_QUERY.
_MIB_PROXYARP | This is record nxllJwaIpRtrMib._MIB_PROXYARP.
_MIB_ROUTESTATE | This is record nxllJwaIpRtrMib._MIB_ROUTESTATE.
_MIB_TCPROW | This is record nxllJwaIpRtrMib._MIB_TCPROW.
_MIB_TCPSTATS | This is record nxllJwaIpRtrMib._MIB_TCPSTATS.
_MIB_TCPTABLE | This is record nxllJwaIpRtrMib._MIB_TCPTABLE.
_MIB_UDPROW | This is record nxllJwaIpRtrMib._MIB_UDPROW.
_MIB_UDPSTATS | This is record nxllJwaIpRtrMib._MIB_UDPSTATS.
_MIB_UDPTABLE | This is record nxllJwaIpRtrMib._MIB_UDPTABLE.
_MIBICMPINFO | This is record nxllJwaIpRtrMib._MIBICMPINFO.
_MIBICMPSTATS | This is record nxllJwaIpRtrMib._MIBICMPSTATS.
_MIBICMPSTATS_EX | This is record nxllJwaIpRtrMib._MIBICMPSTATS_EX.
MIB_BOUNDARYROW | This is record nxllJwaIpRtrMib.MIB_BOUNDARYROW.
MIB_MCAST_LIMIT_ROW | This is record nxllJwaIpRtrMib.MIB_MCAST_LIMIT_ROW.
Links
nxllJwaIpRtrMib Namespace, Legend, Records


nxllJwaIpRtrMib._MIB_BEST_IF Record

nxllJwaIpRtrMib._MIB_BEST_IF Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_BEST_IF = record
  dwDestAddr: DWORD;
  dwIfIndex: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_BEST_IF.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_ICMP Record

nxllJwaIpRtrMib._MIB_ICMP Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_ICMP = record
  stats: MIBICMPINFO;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_ICMP.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_ICMP_EX Record

nxllJwaIpRtrMib._MIB_ICMP_EX Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_ICMP_EX = record
  icmpInStats: MIBICMPSTATS_EX;
  icmpOutStats: MIBICMPSTATS_EX;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_ICMP_EX.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IFNUMBER Record

nxllJwaIpRtrMib._MIB_IFNUMBER Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IFNUMBER = record
  dwValue: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IFNUMBER.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IFROW Record

nxllJwaIpRtrMib._MIB_IFROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IFROW = record
  wszName: array [0..MAX_INTERFACE_NAME_LEN - 1] of WCHAR;
  dwIndex: DWORD;
  dwType: DWORD;
  dwMtu: DWORD;
  dwSpeed: DWORD;
  dwPhysAddrLen: DWORD;
  bPhysAddr: array [0..MAXLEN_PHYSADDR - 1] of BYTE;
  dwAdminStatus: DWORD;
  dwOperStatus: DWORD;
  dwLastChange: DWORD;
  dwInOctets: DWORD;
  dwInUcastPkts: DWORD;
  dwInNUcastPkts: DWORD;
  dwInDiscards: DWORD;
  dwInErrors: DWORD;
  dwInUnknownProtos: DWORD;
  dwOutOctets: DWORD;
  dwOutUcastPkts: DWORD;
  dwOutNUcastPkts: DWORD;
  dwOutDiscards: DWORD;
  dwOutErrors: DWORD;
  dwOutQLen: DWORD;
  dwDescrLen: DWORD;
  bDescr: array[0..MAXLEN_IFDESCR - 1] of BYTE;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IFROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IFSTATUS Record

nxllJwaIpRtrMib._MIB_IFSTATUS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IFSTATUS = record
  dwIfIndex: DWORD;
  dwAdminStatus: DWORD;
  dwOperationalStatus: DWORD;
  bMHbeatActive: BOOL;
  bMHbeatAlive: BOOL;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IFSTATUS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IFTABLE Record

nxllJwaIpRtrMib._MIB_IFTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IFTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IFROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IFTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPADDRROW Record

nxllJwaIpRtrMib._MIB_IPADDRROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPADDRROW = record
  dwAddr: DWORD;
  dwIndex: DWORD;
  dwMask: DWORD;
  dwBCastAddr: DWORD;
  dwReasmSize: DWORD;
  unused1: Word;
  wType: Word;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPADDRROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPADDRTABLE Record

nxllJwaIpRtrMib._MIB_IPADDRTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPADDRTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPADDRROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPADDRTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPDESTROW Record

nxllJwaIpRtrMib._MIB_IPDESTROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPDESTROW = record
  ForwardRow: MIB_IPFORWARDROW;
  dwForwardPreference: DWORD;
  dwForwardViewSet: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPDESTROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPDESTTABLE Record

nxllJwaIpRtrMib._MIB_IPDESTTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPDESTTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPDESTROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPDESTTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPFORWARDNUMBER Record

nxllJwaIpRtrMib._MIB_IPFORWARDNUMBER Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPFORWARDNUMBER = record
  dwValue: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPFORWARDNUMBER.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPFORWARDROW Record

nxllJwaIpRtrMib._MIB_IPFORWARDROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPFORWARDROW = record
  dwForwardDest: DWORD;
  dwForwardMask: DWORD;
  dwForwardPolicy: DWORD;
  dwForwardNextHop: DWORD;
  dwForwardIfIndex: DWORD;
  dwForwardType: DWORD;
  dwForwardProto: DWORD;
  dwForwardAge: DWORD;
  dwForwardNextHopAS: DWORD;
  dwForwardMetric1: DWORD;
  dwForwardMetric2: DWORD;
  dwForwardMetric3: DWORD;
  dwForwardMetric4: DWORD;
  dwForwardMetric5: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPFORWARDROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPFORWARDTABLE Record

nxllJwaIpRtrMib._MIB_IPFORWARDTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPFORWARDTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPFORWARDROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPFORWARDTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY Record

nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_BOUNDARY = record
  dwIfIndex: DWORD;
  dwGroupAddress: DWORD;
  dwGroupMask: DWORD;
  dwStatus: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY_TABLE Record

nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY_TABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_BOUNDARY_TABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPMCAST_BOUNDARY;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_BOUNDARY_TABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_GLOBAL Record

nxllJwaIpRtrMib._MIB_IPMCAST_GLOBAL Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_GLOBAL = record
  dwEnable: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_GLOBAL.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_IF_ENTRY Record

nxllJwaIpRtrMib._MIB_IPMCAST_IF_ENTRY Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_IF_ENTRY = record
  dwIfIndex: DWORD;
  dwTtl: DWORD;
  dwProtocol: DWORD;
  dwRateLimit: DWORD;
  ulInMcastOctets: ULONG;
  ulOutMcastOctets: ULONG;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_ENTRY.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_IF_TABLE Record

nxllJwaIpRtrMib._MIB_IPMCAST_IF_TABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_IF_TABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPMCAST_IF_ENTRY;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_IF_TABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_MFE Record

nxllJwaIpRtrMib._MIB_IPMCAST_MFE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_MFE = record
  dwGroup: DWORD;
  dwSource: DWORD;
  dwSrcMask: DWORD;
  dwUpStrmNgbr: DWORD;
  dwInIfIndex: DWORD;
  dwInIfProtocol: DWORD;
  dwRouteProtocol: DWORD;
  dwRouteNetwork: DWORD;
  dwRouteMask: DWORD;
  ulUpTime: ULONG;
  ulExpiryTime: ULONG;
  ulTimeOut: ULONG;
  ulNumOutIf: ULONG;
  fFlags: DWORD;
  dwReserved: DWORD;
  rgmioOutInfo: array [0..ANY_SIZE - 1] of MIB_IPMCAST_OIF;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS Record

nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_MFE_STATS = record
  dwGroup: DWORD;
  dwSource: DWORD;
  dwSrcMask: DWORD;
  dwUpStrmNgbr: DWORD;
  dwInIfIndex: DWORD;
  dwInIfProtocol: DWORD;
  dwRouteProtocol: DWORD;
  dwRouteNetwork: DWORD;
  dwRouteMask: DWORD;
  ulUpTime: ULONG;
  ulExpiryTime: ULONG;
  ulNumOutIf: ULONG;
  ulInPkts: ULONG;
  ulInOctets: ULONG;
  ulPktsDifferentIf: ULONG;
  ulQueueOverflow: ULONG;
  rgmiosOutStats: array [0..ANY_SIZE - 1] of MIB_IPMCAST_OIF_STATS;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS_EX Record

nxllJwaIpRtrMib._MIB_IPMCAST_MFE_STATS_EX Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_MFE_STATS_EX = record
  dwGroup: DWORD;
  dwSource: DWORD;
  dwSrcMask: DWORD;
  dwUpStrmNgbr: DWORD;
  dwInIfIndex: DWORD;
  dwInIfProtocol: DWORD;
  dwRouteProtocol: DWORD;
  dwRouteNetwork: DWORD;
  dwRouteMask: DWORD;
  ulUpTime: ULONG;
  ulExpiryTime: ULONG;
  ulNumOutIf: ULONG;
  ulInPkts: ULONG;
  ulInOctets: ULONG;
  ulPktsDifferentIf: ULONG;
  ulQueueOverflow: ULONG;
  ulUninitMfe: ULONG;
  ulNegativeMfe: ULONG;
  ulInDiscards: ULONG;
  ulInHdrErrors: ULONG;
  ulTotalOutPackets: ULONG;
  rgmiosOutStats: array [0..ANY_SIZE - 1] of MIB_IPMCAST_OIF_STATS;
end;
File

nxllJwaIpRtrMib

Description

#define SIZEOF_MIB_MFE_STATS(X) (SIZEOF_BASIC_MIB_MFE_STATS + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_OIF Record

nxllJwaIpRtrMib._MIB_IPMCAST_OIF Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_OIF = record
  dwOutIfIndex: DWORD;
  dwNextHopAddr: DWORD;
  dwReserved: DWORD;
  dwReserved1: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_OIF_STATS Record

nxllJwaIpRtrMib._MIB_IPMCAST_OIF_STATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_OIF_STATS = record
  dwOutIfIndex: DWORD;
  dwNextHopAddr: DWORD;
  dwDialContext: DWORD;
  ulTtlTooLow: ULONG;
  ulFragNeeded: ULONG;
  ulOutPackets: ULONG;
  ulOutDiscards: ULONG;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_OIF_STATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPMCAST_SCOPE Record

nxllJwaIpRtrMib._MIB_IPMCAST_SCOPE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPMCAST_SCOPE = record
  dwGroupAddress: DWORD;
  dwGroupMask: DWORD;
  snNameBuffer: SCOPE_NAME_BUFFER;
  dwStatus: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPMCAST_SCOPE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPNETROW Record

nxllJwaIpRtrMib._MIB_IPNETROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPNETROW = record
  dwIndex: DWORD;
  dwPhysAddrLen: DWORD;
  bPhysAddr: array [0..MAXLEN_PHYSADDR - 1] of BYTE;
  dwAddr: DWORD;
  dwType: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPNETROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPNETTABLE Record

nxllJwaIpRtrMib._MIB_IPNETTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPNETTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPNETROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPNETTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_IPSTATS Record

nxllJwaIpRtrMib._MIB_IPSTATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_IPSTATS = record
  dwForwarding: DWORD;
  dwDefaultTTL: DWORD;
  dwInReceives: DWORD;
  dwInHdrErrors: DWORD;
  dwInAddrErrors: DWORD;
  dwForwDatagrams: DWORD;
  dwInUnknownProtos: DWORD;
  dwInDiscards: DWORD;
  dwInDelivers: DWORD;
  dwOutRequests: DWORD;
  dwRoutingDiscards: DWORD;
  dwOutDiscards: DWORD;
  dwOutNoRoutes: DWORD;
  dwReasmTimeout: DWORD;
  dwReasmReqds: DWORD;
  dwReasmOks: DWORD;
  dwReasmFails: DWORD;
  dwFragOks: DWORD;
  dwFragFails: DWORD;
  dwFragCreates: DWORD;
  dwNumIf: DWORD;
  dwNumAddr: DWORD;
  dwNumRoutes: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_IPSTATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE Record

nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_MFE_STATS_TABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPMCAST_MFE_STATS;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE_EX Record

nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE_EX Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_MFE_STATS_TABLE_EX = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPMCAST_MFE_STATS_EX;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_MFE_STATS_TABLE_EX.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_MFE_TABLE Record

nxllJwaIpRtrMib._MIB_MFE_TABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_MFE_TABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_IPMCAST_MFE;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_MFE_TABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_OPAQUE_INFO Record

nxllJwaIpRtrMib._MIB_OPAQUE_INFO Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_OPAQUE_INFO = record
  dwId: DWORD;
  case Integer of
    0: (ullAlign: Int64;);
    1: (rgbyData: array [0..0] of BYTE););
end;
File

nxllJwaIpRtrMib

Members
Members | Description
ullAlign: Int64; | ULONGLONG (unsigned!)
Description

This is record nxllJwaIpRtrMib._MIB_OPAQUE_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_OPAQUE_QUERY Record

nxllJwaIpRtrMib._MIB_OPAQUE_QUERY Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_OPAQUE_QUERY = record
  dwVarId: DWORD;
  rgdwVarIndex: array [0..ANY_SIZE - 1] of DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_OPAQUE_QUERY.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_PROXYARP Record

nxllJwaIpRtrMib._MIB_PROXYARP Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_PROXYARP = record
  dwAddress: DWORD;
  dwMask: DWORD;
  dwIfIndex: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_PROXYARP.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_ROUTESTATE Record

nxllJwaIpRtrMib._MIB_ROUTESTATE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_ROUTESTATE = record
  bRoutesSetToStack: BOOL;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_ROUTESTATE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_TCPROW Record

nxllJwaIpRtrMib._MIB_TCPROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_TCPROW = record
  dwState: DWORD;
  dwLocalAddr: DWORD;
  dwLocalPort: DWORD;
  dwRemoteAddr: DWORD;
  dwRemotePort: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_TCPROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_TCPSTATS Record

nxllJwaIpRtrMib._MIB_TCPSTATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_TCPSTATS = record
  dwRtoAlgorithm: DWORD;
  dwRtoMin: DWORD;
  dwRtoMax: DWORD;
  dwMaxConn: DWORD;
  dwActiveOpens: DWORD;
  dwPassiveOpens: DWORD;
  dwAttemptFails: DWORD;
  dwEstabResets: DWORD;
  dwCurrEstab: DWORD;
  dwInSegs: DWORD;
  dwOutSegs: DWORD;
  dwRetransSegs: DWORD;
  dwInErrs: DWORD;
  dwOutRsts: DWORD;
  dwNumConns: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_TCPSTATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_TCPTABLE Record

nxllJwaIpRtrMib._MIB_TCPTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_TCPTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_TCPROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_TCPTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_UDPROW Record

nxllJwaIpRtrMib._MIB_UDPROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_UDPROW = record
  dwLocalAddr: DWORD;
  dwLocalPort: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_UDPROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_UDPSTATS Record

nxllJwaIpRtrMib._MIB_UDPSTATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_UDPSTATS = record
  dwInDatagrams: DWORD;
  dwNoPorts: DWORD;
  dwInErrors: DWORD;
  dwOutDatagrams: DWORD;
  dwNumAddrs: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_UDPSTATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIB_UDPTABLE Record

nxllJwaIpRtrMib._MIB_UDPTABLE Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIB_UDPTABLE = record
  dwNumEntries: DWORD;
  table: array [0..ANY_SIZE - 1] of MIB_UDPROW;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIB_UDPTABLE.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIBICMPINFO Record

nxllJwaIpRtrMib._MIBICMPINFO Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIBICMPINFO = record
  icmpInStats: MIBICMPSTATS;
  icmpOutStats: MIBICMPSTATS;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIBICMPINFO.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIBICMPSTATS Record

nxllJwaIpRtrMib._MIBICMPSTATS Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIBICMPSTATS = record
  dwMsgs: DWORD;
  dwErrors: DWORD;
  dwDestUnreachs: DWORD;
  dwTimeExcds: DWORD;
  dwParmProbs: DWORD;
  dwSrcQuenchs: DWORD;
  dwRedirects: DWORD;
  dwEchos: DWORD;
  dwEchoReps: DWORD;
  dwTimestamps: DWORD;
  dwTimestampReps: DWORD;
  dwAddrMasks: DWORD;
  dwAddrMaskReps: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIBICMPSTATS.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib._MIBICMPSTATS_EX Record

nxllJwaIpRtrMib._MIBICMPSTATS_EX Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
_MIBICMPSTATS_EX = record
  dwMsgs: DWORD;
  dwErrors: DWORD;
  rgdwTypeCount: array [0..255] of DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib._MIBICMPSTATS_EX.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib.MIB_BOUNDARYROW Record

nxllJwaIpRtrMib.MIB_BOUNDARYROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
MIB_BOUNDARYROW = record
  dwGroupAddress: DWORD;
  dwGroupMask: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib.MIB_BOUNDARYROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


nxllJwaIpRtrMib.MIB_MCAST_LIMIT_ROW Record

nxllJwaIpRtrMib.MIB_MCAST_LIMIT_ROW Record
nxllJwaIpRtrMib Structs, Records, Enums Send Feedback
Syntax
Delphi
MIB_MCAST_LIMIT_ROW = record
  dwTtl: DWORD;
  dwRateLimit: DWORD;
end;
File

nxllJwaIpRtrMib

Description

This is record nxllJwaIpRtrMib.MIB_MCAST_LIMIT_ROW.

Group

Structs, Records, Enums

Links
nxllJwaIpRtrMib, Structs, Records, Enums


Types

Types
nxllJwaIpRtrMib Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaIpRtrMib Namespace

Types
Name
Description
ICMP4_TYPE
This is type nxllJwaIpRtrMib.ICMP4_TYPE.
ICMP6_TYPE
This is type nxllJwaIpRtrMib.ICMP6_TYPE.
MIB_BEST_IF
This is type nxllJwaIpRtrMib.MIB_BEST_IF.
MIB_ICMP
This is type nxllJwaIpRtrMib.MIB_ICMP.
MIB_ICMP_EX
This is type nxllJwaIpRtrMib.MIB_ICMP_EX.
MIB_IFNUMBER
This is type nxllJwaIpRtrMib.MIB_IFNUMBER.
MIB_IFROW
This is type nxllJwaIpRtrMib.MIB_IFROW.
MIB_IFSTATUS
This is type nxllJwaIpRtrMib.MIB_IFSTATUS.
MIB_IFTABLE
This is type nxllJwaIpRtrMib.MIB_IFTABLE.
MIB_IPADDRROW
This is type nxllJwaIpRtrMib.MIB_IPADDRROW.
MIB_IPADDRTABLE
This is type nxllJwaIpRtrMib.MIB_IPADDRTABLE.
MIB_IPDESTROW
This is type nxllJwaIpRtrMib.MIB_IPDESTROW.
MIB_IPDESTTABLE
This is type nxllJwaIpRtrMib.MIB_IPDESTTABLE.
MIB_IPFORWARDNUMBER
This is type nxllJwaIpRtrMib.MIB_IPFORWARDNUMBER.
MIB_IPFORWARDROW
This is type nxllJwaIpRtrMib.MIB_IPFORWARDROW.
MIB_IPFORWARDTABLE
This is type nxllJwaIpRtrMib.MIB_IPFORWARDTABLE.
MIB_IPMCAST_BOUNDARY
This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY.
MIB_IPMCAST_BOUNDARY_TABLE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY_TABLE.
MIB_IPMCAST_GLOBAL
This is type nxllJwaIpRtrMib.MIB_IPMCAST_GLOBAL.
MIB_IPMCAST_IF_ENTRY
This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_ENTRY.
MIB_IPMCAST_IF_TABLE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_TABLE.
MIB_IPMCAST_MFE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE.
MIB_IPMCAST_MFE_STATS
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS.
MIB_IPMCAST_MFE_STATS_EX
This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS_EX.
MIB_IPMCAST_OIF
This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF.
MIB_IPMCAST_OIF_STATS
This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF_STATS.
MIB_IPMCAST_SCOPE
This is type nxllJwaIpRtrMib.MIB_IPMCAST_SCOPE.
MIB_IPNETROW
This is type nxllJwaIpRtrMib.MIB_IPNETROW.
MIB_IPNETTABLE
This is type nxllJwaIpRtrMib.MIB_IPNETTABLE.
MIB_IPSTATS
This is type nxllJwaIpRtrMib.MIB_IPSTATS.
MIB_MFE_STATS_TABLE
This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE.
MIB_MFE_STATS_TABLE_EX
This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE_EX.
MIB_MFE_TABLE
This is type nxllJwaIpRtrMib.MIB_MFE_TABLE.
MIB_OPAQUE_INFO
This is type nxllJwaIpRtrMib.MIB_OPAQUE_INFO.
MIB_OPAQUE_QUERY
This is type nxllJwaIpRtrMib.MIB_OPAQUE_QUERY.
MIB_PROXYARP
This is type nxllJwaIpRtrMib.MIB_PROXYARP.
MIB_ROUTESTATE
This is type nxllJwaIpRtrMib.MIB_ROUTESTATE.
MIB_TCPROW
This is type nxllJwaIpRtrMib.MIB_TCPROW.
MIB_TCPSTATS
This is type nxllJwaIpRtrMib.MIB_TCPSTATS.
MIB_TCPTABLE
This is type nxllJwaIpRtrMib.MIB_TCPTABLE.
MIB_UDPROW
This is type nxllJwaIpRtrMib.MIB_UDPROW.
MIB_UDPSTATS
This is type nxllJwaIpRtrMib.MIB_UDPSTATS.
MIB_UDPTABLE
This is type nxllJwaIpRtrMib.MIB_UDPTABLE.
MIBICMPINFO
This is type nxllJwaIpRtrMib.MIBICMPINFO.
MIBICMPSTATS
This is type nxllJwaIpRtrMib.MIBICMPSTATS.
MIBICMPSTATS_EX
This is type nxllJwaIpRtrMib.MIBICMPSTATS_EX.
PICMP4_TYPE
This is type nxllJwaIpRtrMib.PICMP4_TYPE.
PIcmp4Type
This is type nxllJwaIpRtrMib.PIcmp4Type.
PICMP6_TYPE
This is type nxllJwaIpRtrMib.PICMP6_TYPE.
PIcmp6Type
This is type nxllJwaIpRtrMib.PIcmp6Type.
PMIB_BEST_IF
This is type nxllJwaIpRtrMib.PMIB_BEST_IF.
PMIB_BOUNDARYROW
define SIZEOF_BOUNDARY_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_BOUNDARY_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_BOUNDARY)) + ALIGN_SIZE)
PMIB_ICMP
This is type nxllJwaIpRtrMib.PMIB_ICMP.
PMIB_ICMP_EX
This is type nxllJwaIpRtrMib.PMIB_ICMP_EX.
PMIB_IFNUMBER
The following are the structures which are filled in and returned to the user when a query is made, OR are filled in BY THE USER when a set is done
PMIB_IFROW
This is type nxllJwaIpRtrMib.PMIB_IFROW.
PMIB_IFSTATUS
This is type nxllJwaIpRtrMib.PMIB_IFSTATUS.
PMIB_IFTABLE
This is type nxllJwaIpRtrMib.PMIB_IFTABLE.
PMIB_IPADDRROW
This is type nxllJwaIpRtrMib.PMIB_IPADDRROW.
PMIB_IPADDRTABLE
This is type nxllJwaIpRtrMib.PMIB_IPADDRTABLE.
PMIB_IPDESTROW
This is type nxllJwaIpRtrMib.PMIB_IPDESTROW.
PMIB_IPDESTTABLE
This is type nxllJwaIpRtrMib.PMIB_IPDESTTABLE.
PMIB_IPFORWARDNUMBER
define SIZEOF_IPADDRTABLE(X) (FIELD_OFFSET(MIB_IPADDRTABLE,table[0]) + ((X) * sizeof(MIB_IPADDRROW)) + ALIGN_SIZE)
PMIB_IPFORWARDROW
This is type nxllJwaIpRtrMib.PMIB_IPFORWARDROW.
PMIB_IPFORWARDTABLE
This is type nxllJwaIpRtrMib.PMIB_IPFORWARDTABLE.
PMIB_IPMCAST_BOUNDARY
define SIZEOF_MCAST_IF_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_IF_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_IF_ENTRY)) + ALIGN_SIZE)
PMIB_IPMCAST_BOUNDARY_TABLE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY_TABLE.
PMIB_IPMCAST_GLOBAL
#define SIZEOF_MIB_MFE_STATS_EX(X) (SIZEOF_BASIC_MIB_MFE_STATS_EX + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))
PMIB_IPMCAST_IF_ENTRY
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_ENTRY.
PMIB_IPMCAST_IF_TABLE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_TABLE.
PMIB_IPMCAST_MFE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE.
PMIB_IPMCAST_MFE_STATS
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS.
PMIB_IPMCAST_MFE_STATS_EX
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS_EX.
PMIB_IPMCAST_OIF
define SIZEOF_IPNETTABLE(X) (FIELD_OFFSET(MIB_IPNETTABLE, table[0]) + ((X) * sizeof(MIB_IPNETROW)) + ALIGN_SIZE)
PMIB_IPMCAST_OIF_STATS
#define SIZEOF_MIB_MFE(X) (SIZEOF_BASIC_MIB_MFE + ((X) * sizeof(MIB_IPMCAST_OIF)))
PMIB_IPMCAST_SCOPE
This is type nxllJwaIpRtrMib.PMIB_IPMCAST_SCOPE.
PMIB_IPNETROW
define SIZEOF_IPFORWARDTABLE(X) (FIELD_OFFSET(MIB_IPFORWARDTABLE,table[0]) + ((X) * sizeof(MIB_IPFORWARDROW)) + ALIGN_SIZE)
PMIB_IPNETTABLE
This is type nxllJwaIpRtrMib.PMIB_IPNETTABLE.
PMIB_IPSTATS
This is type nxllJwaIpRtrMib.PMIB_IPSTATS.
PMIB_MCAST_LIMIT_ROW
Structure matching what goes in the registry in a block of type IP_MCAST_LIMIT_INFO. This contains the fields of MIB_IPMCAST_IF_ENTRY which are configurable.
PMIB_MFE_STATS_TABLE
This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE.
PMIB_MFE_STATS_TABLE_EX
This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE_EX.
PMIB_MFE_TABLE
This is type nxllJwaIpRtrMib.PMIB_MFE_TABLE.
PMIB_OPAQUE_QUERY
MIB_OPAQUE_QUERY is the structure filled in by the user to identify a MIB variable
dwVarId ID of MIB Variable (One of the Ids #defined above) dwVarIndex Variable sized array containing the indices needed to identify a variable. NOTE: Unlike SNMP we dont require that a scalar variable be indexed by 0
PMIB_PROXYARP
This is type nxllJwaIpRtrMib.PMIB_PROXYARP.
PMIB_ROUTESTATE
This is type nxllJwaIpRtrMib.PMIB_ROUTESTATE.
PMIB_TCPROW
This is type nxllJwaIpRtrMib.PMIB_TCPROW.
PMIB_TCPSTATS
define SIZEOF_UDPTABLE(X) (FIELD_OFFSET(MIB_UDPTABLE, table[0]) + ((X) * sizeof(MIB_UDPROW)) + ALIGN_SIZE)
PMIB_TCPTABLE
This is type nxllJwaIpRtrMib.PMIB_TCPTABLE.
PMIB_UDPROW
This is type nxllJwaIpRtrMib.PMIB_UDPROW.
PMIB_UDPSTATS
This is type nxllJwaIpRtrMib.PMIB_UDPSTATS.
PMIB_UDPTABLE
This is type nxllJwaIpRtrMib.PMIB_UDPTABLE.
PMibBestIf
This is type nxllJwaIpRtrMib.PMibBestIf.
PMibBoundaryRow
This is type nxllJwaIpRtrMib.PMibBoundaryRow.
PMibIcmp
This is type nxllJwaIpRtrMib.PMibIcmp.
PMibIcmpEx
This is type nxllJwaIpRtrMib.PMibIcmpEx.
PMIBICMPINFO
This is type nxllJwaIpRtrMib.PMIBICMPINFO.
PMibIcmpStats
define SIZEOF_IFTABLE(X) (FIELD_OFFSET(MIB_IFTABLE,table[0]) + ((X) * sizeof(MIB_IFROW)) + ALIGN_SIZE)
PMIBICMPSTATS_EX
This is type nxllJwaIpRtrMib.PMIBICMPSTATS_EX.
PMibIcmpStatsEx
This is type nxllJwaIpRtrMib.PMibIcmpStatsEx.
PMibIfnumber
This is type nxllJwaIpRtrMib.PMibIfnumber.
PMibIfRow
This is type nxllJwaIpRtrMib.PMibIfRow.
PMibIfStatus
This is type nxllJwaIpRtrMib.PMibIfStatus.
PMibIftable
This is type nxllJwaIpRtrMib.PMibIftable.
PMibIpAddrRow
This is type nxllJwaIpRtrMib.PMibIpAddrRow.
PMibIpAddrTable
This is type nxllJwaIpRtrMib.PMibIpAddrTable.
PMibIpDestRow
This is type nxllJwaIpRtrMib.PMibIpDestRow.
PMibIpDestTable
This is type nxllJwaIpRtrMib.PMibIpDestTable.
PMibIpForwardNumber
This is type nxllJwaIpRtrMib.PMibIpForwardNumber.
PMibIpForwardRow
This is type nxllJwaIpRtrMib.PMibIpForwardRow.
PMibIpForwardTable
This is type nxllJwaIpRtrMib.PMibIpForwardTable.
PMibIpmCastBoundary
This is type nxllJwaIpRtrMib.PMibIpmCastBoundary.
PMibIpmCastBoundaryTable
This is type nxllJwaIpRtrMib.PMibIpmCastBoundaryTable.
PMibIpmCastGlobal
This is type nxllJwaIpRtrMib.PMibIpmCastGlobal.
PMibIpmCastIfEntry
This is type nxllJwaIpRtrMib.PMibIpmCastIfEntry.
PMibIpmCastIfTable
This is type nxllJwaIpRtrMib.PMibIpmCastIfTable.
PMibIpmCastMfe
This is type nxllJwaIpRtrMib.PMibIpmCastMfe.
PMibIpmCastMfeStats
This is type nxllJwaIpRtrMib.PMibIpmCastMfeStats.
PMibIpMCastMfeStatsEx
This is type nxllJwaIpRtrMib.PMibIpMCastMfeStatsEx.
PMibIpmCastOif
This is type nxllJwaIpRtrMib.PMibIpmCastOif.
PMibIpmCastOifStats
This is type nxllJwaIpRtrMib.PMibIpmCastOifStats.
PMibIpmCastScope
This is type nxllJwaIpRtrMib.PMibIpmCastScope.
PMibIpNetRow
This is type nxllJwaIpRtrMib.PMibIpNetRow.
PMibIpNetTable
This is type nxllJwaIpRtrMib.PMibIpNetTable.
PMibIpStats
This is type nxllJwaIpRtrMib.PMibIpStats.
PMibMcastLimitRow
This is type nxllJwaIpRtrMib.PMibMcastLimitRow.
PMibMfeStatsTable
This is type nxllJwaIpRtrMib.PMibMfeStatsTable.
PMibMfeStatsTableEx
This is type nxllJwaIpRtrMib.PMibMfeStatsTableEx.
PMibMfeTable
This is type nxllJwaIpRtrMib.PMibMfeTable.
PMibOpaqueInfo
All the info passed to (SET/CREATE) and from (GET/GETNEXT/GETFIRST) IP Router Manager is encapsulated in the following "discriminated" union. To pass, say MIB_IFROW, use the following code
PMIB_OPAQUE_INFO pInfo; PMIB_IFROW pIfRow; DWORD rgdwBuff[(MAX_MIB_OFFSET + sizeof(MIB_IFROW))/sizeof(DWORD) + 1];
pInfo = (PMIB_OPAQUE_INFO)rgdwBuffer; pIfRow = (MIB_IFROW *)(pInfo->rgbyData);
This can also be accomplished by using the following macro
DEFINE_MIB_BUFFER(pInfo,MIB_IFROW, pIfRow);
PMibOpaqueQuery
This is type nxllJwaIpRtrMib.PMibOpaqueQuery.
PMibProxyArp
This is type nxllJwaIpRtrMib.PMibProxyArp.
PMibRouteState
This is type nxllJwaIpRtrMib.PMibRouteState.
PMibTcpRow
This is type nxllJwaIpRtrMib.PMibTcpRow.
PMibTcpStats
This is type nxllJwaIpRtrMib.PMibTcpStats.
PMibTcpTable
This is type nxllJwaIpRtrMib.PMibTcpTable.
PMibUdpRow
This is type nxllJwaIpRtrMib.PMibUdpRow.
PMibUdpStats
This is type nxllJwaIpRtrMib.PMibUdpStats.
PMibUdpTable
This is type nxllJwaIpRtrMib.PMibUdpTable.
SCOPE_NAME
This is type nxllJwaIpRtrMib.SCOPE_NAME.
SCOPE_NAME_BUFFER
This is type nxllJwaIpRtrMib.SCOPE_NAME_BUFFER.
SN_CHAR
Scope names are unicode. SNMP and MZAP use UTF-8 encoding.
TIcmp4Type
This is type nxllJwaIpRtrMib.TIcmp4Type.
TIcmp6Type
This is type nxllJwaIpRtrMib.TIcmp6Type.
TMibBestIf
This is type nxllJwaIpRtrMib.TMibBestIf.
TMibBoundaryRow
This is type nxllJwaIpRtrMib.TMibBoundaryRow.
TMibIcmp
This is type nxllJwaIpRtrMib.TMibIcmp.
TMibIcmpEx
This is type nxllJwaIpRtrMib.TMibIcmpEx.
TMibIcmpInfo
This is type nxllJwaIpRtrMib.TMibIcmpInfo.
TMibIcmpStats
This is type nxllJwaIpRtrMib.TMibIcmpStats.
TMibIcmpStatsEx
This is type nxllJwaIpRtrMib.TMibIcmpStatsEx.
TMibIfnumber
This is type nxllJwaIpRtrMib.TMibIfnumber.
TMibIfRow
This is type nxllJwaIpRtrMib.TMibIfRow.
TMibIfStatus
This is type nxllJwaIpRtrMib.TMibIfStatus.
TMibIftable
This is type nxllJwaIpRtrMib.TMibIftable.
TMibIpAddrRow
This is type nxllJwaIpRtrMib.TMibIpAddrRow.
TMibIpAddrTable
This is type nxllJwaIpRtrMib.TMibIpAddrTable.
TMibIpDestRow
This is type nxllJwaIpRtrMib.TMibIpDestRow.
TMibIpDestTable
This is type nxllJwaIpRtrMib.TMibIpDestTable.
TMibIpForwardNumber
This is type nxllJwaIpRtrMib.TMibIpForwardNumber.
TMibIpForwardRow
This is type nxllJwaIpRtrMib.TMibIpForwardRow.
TMibIpForwardTable
This is type nxllJwaIpRtrMib.TMibIpForwardTable.
TMibIpmCastBoundary
This is type nxllJwaIpRtrMib.TMibIpmCastBoundary.
TMibIpmCastBoundaryTable
This is type nxllJwaIpRtrMib.TMibIpmCastBoundaryTable.
TMibIpmCastGlobal
This is type nxllJwaIpRtrMib.TMibIpmCastGlobal.
TMibIpmCastIfEntry
This is type nxllJwaIpRtrMib.TMibIpmCastIfEntry.
TMibIpmCastIfTable
This is type nxllJwaIpRtrMib.TMibIpmCastIfTable.
TMibIpmCastMfe
This is type nxllJwaIpRtrMib.TMibIpmCastMfe.
TMibIpmCastMfeStats
This is type nxllJwaIpRtrMib.TMibIpmCastMfeStats.
TMibIpMCastMfeStatsEx
This is type nxllJwaIpRtrMib.TMibIpMCastMfeStatsEx.
TMibIpmCastOif
This is type nxllJwaIpRtrMib.TMibIpmCastOif.
TMibIpmCastOifStats
This is type nxllJwaIpRtrMib.TMibIpmCastOifStats.
TMibIpmCastScope
This is type nxllJwaIpRtrMib.TMibIpmCastScope.
TMibIpNetRow
This is type nxllJwaIpRtrMib.TMibIpNetRow.
TMibIpNetTable
This is type nxllJwaIpRtrMib.TMibIpNetTable.
TMibIpStats
This is type nxllJwaIpRtrMib.TMibIpStats.
TMibMcastLimitRow
This is type nxllJwaIpRtrMib.TMibMcastLimitRow.
TMibMfeStatsTable
This is type nxllJwaIpRtrMib.TMibMfeStatsTable.
TMibMfeStatsTableEx
This is type nxllJwaIpRtrMib.TMibMfeStatsTableEx.
TMibMfeTable
This is type nxllJwaIpRtrMib.TMibMfeTable.
TMibOpaqueInfo
This is type nxllJwaIpRtrMib.TMibOpaqueInfo.
TMibOpaqueQuery
This is type nxllJwaIpRtrMib.TMibOpaqueQuery.
TMibProxyArp
This is type nxllJwaIpRtrMib.TMibProxyArp.
TMibRouteState
This is type nxllJwaIpRtrMib.TMibRouteState.
TMibTcpRow
This is type nxllJwaIpRtrMib.TMibTcpRow.
TMibTcpStats
This is type nxllJwaIpRtrMib.TMibTcpStats.
TMibTcpTable
This is type nxllJwaIpRtrMib.TMibTcpTable.
TMibUdpRow
This is type nxllJwaIpRtrMib.TMibUdpRow.
TMibUdpStats
This is type nxllJwaIpRtrMib.TMibUdpStats.
TMibUdpTable
This is type nxllJwaIpRtrMib.TMibUdpTable.
Links
nxllJwaIpRtrMib Namespace, Types


nxllJwaIpRtrMib.ICMP4_TYPE Type

nxllJwaIpRtrMib.ICMP4_TYPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
ICMP4_TYPE = DWORD;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.ICMP4_TYPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.ICMP6_TYPE Type

nxllJwaIpRtrMib.ICMP6_TYPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
ICMP6_TYPE = DWORD;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.ICMP6_TYPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_BEST_IF Type

nxllJwaIpRtrMib.MIB_BEST_IF Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_BEST_IF = _MIB_BEST_IF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_BEST_IF.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_ICMP Type

nxllJwaIpRtrMib.MIB_ICMP Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_ICMP = _MIB_ICMP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_ICMP.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_ICMP_EX Type

nxllJwaIpRtrMib.MIB_ICMP_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_ICMP_EX = _MIB_ICMP_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_ICMP_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IFNUMBER Type

nxllJwaIpRtrMib.MIB_IFNUMBER Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IFNUMBER = _MIB_IFNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IFNUMBER.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IFROW Type

nxllJwaIpRtrMib.MIB_IFROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IFROW = _MIB_IFROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IFROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IFSTATUS Type

nxllJwaIpRtrMib.MIB_IFSTATUS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IFSTATUS = _MIB_IFSTATUS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IFSTATUS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IFTABLE Type

nxllJwaIpRtrMib.MIB_IFTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IFTABLE = _MIB_IFTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IFTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPADDRROW Type

nxllJwaIpRtrMib.MIB_IPADDRROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPADDRROW = _MIB_IPADDRROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPADDRROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPADDRTABLE Type

nxllJwaIpRtrMib.MIB_IPADDRTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPADDRTABLE = _MIB_IPADDRTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPADDRTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPDESTROW Type

nxllJwaIpRtrMib.MIB_IPDESTROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPDESTROW = _MIB_IPDESTROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPDESTROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPDESTTABLE Type

nxllJwaIpRtrMib.MIB_IPDESTTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPDESTTABLE = _MIB_IPDESTTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPDESTTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPFORWARDNUMBER Type

nxllJwaIpRtrMib.MIB_IPFORWARDNUMBER Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPFORWARDNUMBER = _MIB_IPFORWARDNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPFORWARDNUMBER.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPFORWARDROW Type

nxllJwaIpRtrMib.MIB_IPFORWARDROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPFORWARDROW = _MIB_IPFORWARDROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPFORWARDROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPFORWARDTABLE Type

nxllJwaIpRtrMib.MIB_IPFORWARDTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPFORWARDTABLE = _MIB_IPFORWARDTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPFORWARDTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY Type

nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_BOUNDARY = _MIB_IPMCAST_BOUNDARY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY_TABLE Type

nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_BOUNDARY_TABLE = _MIB_IPMCAST_BOUNDARY_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_BOUNDARY_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_GLOBAL Type

nxllJwaIpRtrMib.MIB_IPMCAST_GLOBAL Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_GLOBAL = _MIB_IPMCAST_GLOBAL;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_GLOBAL.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_IF_ENTRY Type

nxllJwaIpRtrMib.MIB_IPMCAST_IF_ENTRY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_IF_ENTRY = _MIB_IPMCAST_IF_ENTRY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_ENTRY.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_IF_TABLE Type

nxllJwaIpRtrMib.MIB_IPMCAST_IF_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_IF_TABLE = _MIB_IPMCAST_IF_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_IF_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_MFE Type

nxllJwaIpRtrMib.MIB_IPMCAST_MFE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_MFE = _MIB_IPMCAST_MFE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS Type

nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_MFE_STATS = _MIB_IPMCAST_MFE_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS_EX Type

nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_MFE_STATS_EX = _MIB_IPMCAST_MFE_STATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_MFE_STATS_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_OIF Type

nxllJwaIpRtrMib.MIB_IPMCAST_OIF Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_OIF = _MIB_IPMCAST_OIF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_OIF_STATS Type

nxllJwaIpRtrMib.MIB_IPMCAST_OIF_STATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_OIF_STATS = _MIB_IPMCAST_OIF_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_OIF_STATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPMCAST_SCOPE Type

nxllJwaIpRtrMib.MIB_IPMCAST_SCOPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPMCAST_SCOPE = _MIB_IPMCAST_SCOPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPMCAST_SCOPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPNETROW Type

nxllJwaIpRtrMib.MIB_IPNETROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPNETROW = _MIB_IPNETROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPNETROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPNETTABLE Type

nxllJwaIpRtrMib.MIB_IPNETTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPNETTABLE = _MIB_IPNETTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPNETTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_IPSTATS Type

nxllJwaIpRtrMib.MIB_IPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_IPSTATS = _MIB_IPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_IPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE Type

nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_MFE_STATS_TABLE = _MIB_MFE_STATS_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE_EX Type

nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_MFE_STATS_TABLE_EX = _MIB_MFE_STATS_TABLE_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_MFE_STATS_TABLE_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_MFE_TABLE Type

nxllJwaIpRtrMib.MIB_MFE_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_MFE_TABLE = _MIB_MFE_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_MFE_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_OPAQUE_INFO Type

nxllJwaIpRtrMib.MIB_OPAQUE_INFO Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_OPAQUE_INFO = _MIB_OPAQUE_INFO;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_OPAQUE_INFO.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_OPAQUE_QUERY Type

nxllJwaIpRtrMib.MIB_OPAQUE_QUERY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_OPAQUE_QUERY = _MIB_OPAQUE_QUERY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_OPAQUE_QUERY.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_PROXYARP Type

nxllJwaIpRtrMib.MIB_PROXYARP Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_PROXYARP = _MIB_PROXYARP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_PROXYARP.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_ROUTESTATE Type

nxllJwaIpRtrMib.MIB_ROUTESTATE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_ROUTESTATE = _MIB_ROUTESTATE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_ROUTESTATE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_TCPROW Type

nxllJwaIpRtrMib.MIB_TCPROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_TCPROW = _MIB_TCPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_TCPROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_TCPSTATS Type

nxllJwaIpRtrMib.MIB_TCPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_TCPSTATS = _MIB_TCPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_TCPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_TCPTABLE Type

nxllJwaIpRtrMib.MIB_TCPTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_TCPTABLE = _MIB_TCPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_TCPTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_UDPROW Type

nxllJwaIpRtrMib.MIB_UDPROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_UDPROW = _MIB_UDPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_UDPROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_UDPSTATS Type

nxllJwaIpRtrMib.MIB_UDPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_UDPSTATS = _MIB_UDPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_UDPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIB_UDPTABLE Type

nxllJwaIpRtrMib.MIB_UDPTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIB_UDPTABLE = _MIB_UDPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIB_UDPTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIBICMPINFO Type

nxllJwaIpRtrMib.MIBICMPINFO Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIBICMPINFO = _MIBICMPINFO;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIBICMPINFO.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIBICMPSTATS Type

nxllJwaIpRtrMib.MIBICMPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIBICMPSTATS = _MIBICMPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIBICMPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.MIBICMPSTATS_EX Type

nxllJwaIpRtrMib.MIBICMPSTATS_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
MIBICMPSTATS_EX = _MIBICMPSTATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.MIBICMPSTATS_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PICMP4_TYPE Type

nxllJwaIpRtrMib.PICMP4_TYPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PICMP4_TYPE = ^ICMP4_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PICMP4_TYPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PIcmp4Type Type

nxllJwaIpRtrMib.PIcmp4Type Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PIcmp4Type = PICMP4_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PIcmp4Type.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PICMP6_TYPE Type

nxllJwaIpRtrMib.PICMP6_TYPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PICMP6_TYPE = ^ICMP6_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PICMP6_TYPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PIcmp6Type Type

nxllJwaIpRtrMib.PIcmp6Type Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PIcmp6Type = PICMP6_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PIcmp6Type.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_BEST_IF Type

nxllJwaIpRtrMib.PMIB_BEST_IF Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_BEST_IF = ^MIB_BEST_IF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_BEST_IF.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_BOUNDARYROW Type

nxllJwaIpRtrMib.PMIB_BOUNDARYROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_BOUNDARYROW = ^MIB_BOUNDARYROW;
File

nxllJwaIpRtrMib

Description

define SIZEOF_BOUNDARY_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_BOUNDARY_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_BOUNDARY)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_ICMP Type

nxllJwaIpRtrMib.PMIB_ICMP Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_ICMP = ^MIB_ICMP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_ICMP.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_ICMP_EX Type

nxllJwaIpRtrMib.PMIB_ICMP_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_ICMP_EX = ^MIB_ICMP_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_ICMP_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IFNUMBER Type

nxllJwaIpRtrMib.PMIB_IFNUMBER Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IFNUMBER = ^MIB_IFNUMBER;
File

nxllJwaIpRtrMib

Description

The following are the structures which are filled in and returned to the user when a query is made, OR are filled in BY THE USER when a set is done

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IFROW Type

nxllJwaIpRtrMib.PMIB_IFROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IFROW = ^MIB_IFROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IFROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IFSTATUS Type

nxllJwaIpRtrMib.PMIB_IFSTATUS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IFSTATUS = ^MIB_IFSTATUS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IFSTATUS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IFTABLE Type

nxllJwaIpRtrMib.PMIB_IFTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IFTABLE = ^MIB_IFTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IFTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPADDRROW Type

nxllJwaIpRtrMib.PMIB_IPADDRROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPADDRROW = ^MIB_IPADDRROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPADDRROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPADDRTABLE Type

nxllJwaIpRtrMib.PMIB_IPADDRTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPADDRTABLE = ^MIB_IPADDRTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPADDRTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPDESTROW Type

nxllJwaIpRtrMib.PMIB_IPDESTROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPDESTROW = ^MIB_IPDESTROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPDESTROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPDESTTABLE Type

nxllJwaIpRtrMib.PMIB_IPDESTTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPDESTTABLE = ^MIB_IPDESTTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPDESTTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPFORWARDNUMBER Type

nxllJwaIpRtrMib.PMIB_IPFORWARDNUMBER Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPFORWARDNUMBER = ^MIB_IPFORWARDNUMBER;
File

nxllJwaIpRtrMib

Description

define SIZEOF_IPADDRTABLE(X) (FIELD_OFFSET(MIB_IPADDRTABLE,table[0]) + ((X) * sizeof(MIB_IPADDRROW)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPFORWARDROW Type

nxllJwaIpRtrMib.PMIB_IPFORWARDROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPFORWARDROW = ^MIB_IPFORWARDROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPFORWARDROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPFORWARDTABLE Type

nxllJwaIpRtrMib.PMIB_IPFORWARDTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPFORWARDTABLE = ^MIB_IPFORWARDTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPFORWARDTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY Type

nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_BOUNDARY = ^MIB_IPMCAST_BOUNDARY;
File

nxllJwaIpRtrMib

Description

define SIZEOF_MCAST_IF_TABLE(X) (FIELD_OFFSET(MIB_IPMCAST_IF_TABLE,table[0]) + ((X) * sizeof(MIB_IPMCAST_IF_ENTRY)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY_TABLE Type

nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_BOUNDARY_TABLE = ^MIB_IPMCAST_BOUNDARY_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_BOUNDARY_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_GLOBAL Type

nxllJwaIpRtrMib.PMIB_IPMCAST_GLOBAL Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_GLOBAL = ^MIB_IPMCAST_GLOBAL;
File

nxllJwaIpRtrMib

Description

#define SIZEOF_MIB_MFE_STATS_EX(X) (SIZEOF_BASIC_MIB_MFE_STATS_EX + ((X) * sizeof(MIB_IPMCAST_OIF_STATS)))

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_IF_ENTRY Type

nxllJwaIpRtrMib.PMIB_IPMCAST_IF_ENTRY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_IF_ENTRY = ^MIB_IPMCAST_IF_ENTRY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_ENTRY.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_IF_TABLE Type

nxllJwaIpRtrMib.PMIB_IPMCAST_IF_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_IF_TABLE = ^MIB_IPMCAST_IF_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_IF_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_MFE Type

nxllJwaIpRtrMib.PMIB_IPMCAST_MFE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_MFE = ^MIB_IPMCAST_MFE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS Type

nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_MFE_STATS = ^MIB_IPMCAST_MFE_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS_EX Type

nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_MFE_STATS_EX = ^MIB_IPMCAST_MFE_STATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_MFE_STATS_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_OIF Type

nxllJwaIpRtrMib.PMIB_IPMCAST_OIF Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_OIF = ^MIB_IPMCAST_OIF;
File

nxllJwaIpRtrMib

Description

define SIZEOF_IPNETTABLE(X) (FIELD_OFFSET(MIB_IPNETTABLE, table[0]) + ((X) * sizeof(MIB_IPNETROW)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_OIF_STATS Type

nxllJwaIpRtrMib.PMIB_IPMCAST_OIF_STATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_OIF_STATS = ^MIB_IPMCAST_OIF_STATS;
File

nxllJwaIpRtrMib

Description

#define SIZEOF_MIB_MFE(X) (SIZEOF_BASIC_MIB_MFE + ((X) * sizeof(MIB_IPMCAST_OIF)))

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPMCAST_SCOPE Type

nxllJwaIpRtrMib.PMIB_IPMCAST_SCOPE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPMCAST_SCOPE = ^MIB_IPMCAST_SCOPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPMCAST_SCOPE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPNETROW Type

nxllJwaIpRtrMib.PMIB_IPNETROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPNETROW = ^MIB_IPNETROW;
File

nxllJwaIpRtrMib

Description

define SIZEOF_IPFORWARDTABLE(X) (FIELD_OFFSET(MIB_IPFORWARDTABLE,table[0]) + ((X) * sizeof(MIB_IPFORWARDROW)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPNETTABLE Type

nxllJwaIpRtrMib.PMIB_IPNETTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPNETTABLE = ^MIB_IPNETTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPNETTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_IPSTATS Type

nxllJwaIpRtrMib.PMIB_IPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_IPSTATS = ^MIB_IPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_IPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_MCAST_LIMIT_ROW Type

nxllJwaIpRtrMib.PMIB_MCAST_LIMIT_ROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_MCAST_LIMIT_ROW = ^MIB_MCAST_LIMIT_ROW;
File

nxllJwaIpRtrMib

Description

Structure matching what goes in the registry in a block of type IP_MCAST_LIMIT_INFO. This contains the fields of MIB_IPMCAST_IF_ENTRY which are configurable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE Type

nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_MFE_STATS_TABLE = ^MIB_MFE_STATS_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE_EX Type

nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_MFE_STATS_TABLE_EX = ^MIB_MFE_STATS_TABLE_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_MFE_STATS_TABLE_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_MFE_TABLE Type

nxllJwaIpRtrMib.PMIB_MFE_TABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_MFE_TABLE = ^MIB_MFE_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_MFE_TABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_OPAQUE_QUERY Type

nxllJwaIpRtrMib.PMIB_OPAQUE_QUERY Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_OPAQUE_QUERY = ^MIB_OPAQUE_QUERY;
File

nxllJwaIpRtrMib

Description

MIB_OPAQUE_QUERY is the structure filled in by the user to identify a MIB variable

dwVarId ID of MIB Variable (One of the Ids #defined above) dwVarIndex Variable sized array containing the indices needed to identify a variable. NOTE: Unlike SNMP we dont require that a scalar variable be indexed by 0

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_PROXYARP Type

nxllJwaIpRtrMib.PMIB_PROXYARP Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_PROXYARP = ^MIB_PROXYARP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_PROXYARP.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_ROUTESTATE Type

nxllJwaIpRtrMib.PMIB_ROUTESTATE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_ROUTESTATE = ^MIB_ROUTESTATE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_ROUTESTATE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_TCPROW Type

nxllJwaIpRtrMib.PMIB_TCPROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_TCPROW = ^MIB_TCPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_TCPROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_TCPSTATS Type

nxllJwaIpRtrMib.PMIB_TCPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_TCPSTATS = ^MIB_TCPSTATS;
File

nxllJwaIpRtrMib

Description

define SIZEOF_UDPTABLE(X) (FIELD_OFFSET(MIB_UDPTABLE, table[0]) + ((X) * sizeof(MIB_UDPROW)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_TCPTABLE Type

nxllJwaIpRtrMib.PMIB_TCPTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_TCPTABLE = ^MIB_TCPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_TCPTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_UDPROW Type

nxllJwaIpRtrMib.PMIB_UDPROW Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_UDPROW = ^MIB_UDPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_UDPROW.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_UDPSTATS Type

nxllJwaIpRtrMib.PMIB_UDPSTATS Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_UDPSTATS = ^MIB_UDPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_UDPSTATS.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIB_UDPTABLE Type

nxllJwaIpRtrMib.PMIB_UDPTABLE Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIB_UDPTABLE = ^MIB_UDPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIB_UDPTABLE.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibBestIf Type

nxllJwaIpRtrMib.PMibBestIf Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibBestIf = PMIB_BEST_IF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibBestIf.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibBoundaryRow Type

nxllJwaIpRtrMib.PMibBoundaryRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibBoundaryRow = PMIB_BOUNDARYROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibBoundaryRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIcmp Type

nxllJwaIpRtrMib.PMibIcmp Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIcmp = PMIB_ICMP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIcmp.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIcmpEx Type

nxllJwaIpRtrMib.PMibIcmpEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIcmpEx = PMIB_ICMP_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIcmpEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIBICMPINFO Type

nxllJwaIpRtrMib.PMIBICMPINFO Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIBICMPINFO = ^MIBICMPINFO;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIBICMPINFO.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIcmpStats Type

nxllJwaIpRtrMib.PMibIcmpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIcmpStats = ^TMibIcmpStats;
File

nxllJwaIpRtrMib

Description

define SIZEOF_IFTABLE(X) (FIELD_OFFSET(MIB_IFTABLE,table[0]) + ((X) * sizeof(MIB_IFROW)) + ALIGN_SIZE)

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMIBICMPSTATS_EX Type

nxllJwaIpRtrMib.PMIBICMPSTATS_EX Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMIBICMPSTATS_EX = ^MIBICMPSTATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMIBICMPSTATS_EX.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIcmpStatsEx Type

nxllJwaIpRtrMib.PMibIcmpStatsEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIcmpStatsEx = PMIBICMPSTATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIcmpStatsEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIfnumber Type

nxllJwaIpRtrMib.PMibIfnumber Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIfnumber = PMIB_IFNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIfnumber.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIfRow Type

nxllJwaIpRtrMib.PMibIfRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIfRow = PMIB_IFROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIfRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIfStatus Type

nxllJwaIpRtrMib.PMibIfStatus Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIfStatus = PMIB_IFSTATUS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIfStatus.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIftable Type

nxllJwaIpRtrMib.PMibIftable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIftable = PMIB_IFTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIftable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpAddrRow Type

nxllJwaIpRtrMib.PMibIpAddrRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpAddrRow = PMIB_IPADDRROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpAddrRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpAddrTable Type

nxllJwaIpRtrMib.PMibIpAddrTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpAddrTable = PMIB_IPADDRTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpAddrTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpDestRow Type

nxllJwaIpRtrMib.PMibIpDestRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpDestRow = PMIB_IPDESTROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpDestRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpDestTable Type

nxllJwaIpRtrMib.PMibIpDestTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpDestTable = PMIB_IPDESTTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpDestTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpForwardNumber Type

nxllJwaIpRtrMib.PMibIpForwardNumber Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpForwardNumber = PMIB_IPFORWARDNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpForwardNumber.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpForwardRow Type

nxllJwaIpRtrMib.PMibIpForwardRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpForwardRow = PMIB_IPFORWARDROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpForwardRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpForwardTable Type

nxllJwaIpRtrMib.PMibIpForwardTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpForwardTable = PMIB_IPFORWARDTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpForwardTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastBoundary Type

nxllJwaIpRtrMib.PMibIpmCastBoundary Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastBoundary = PMIB_IPMCAST_BOUNDARY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastBoundary.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastBoundaryTable Type

nxllJwaIpRtrMib.PMibIpmCastBoundaryTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastBoundaryTable = PMIB_IPMCAST_BOUNDARY_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastBoundaryTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastGlobal Type

nxllJwaIpRtrMib.PMibIpmCastGlobal Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastGlobal = PMIB_IPMCAST_GLOBAL;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastGlobal.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastIfEntry Type

nxllJwaIpRtrMib.PMibIpmCastIfEntry Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastIfEntry = PMIB_IPMCAST_IF_ENTRY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastIfEntry.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastIfTable Type

nxllJwaIpRtrMib.PMibIpmCastIfTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastIfTable = PMIB_IPMCAST_IF_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastIfTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastMfe Type

nxllJwaIpRtrMib.PMibIpmCastMfe Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastMfe = PMIB_IPMCAST_MFE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastMfe.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastMfeStats Type

nxllJwaIpRtrMib.PMibIpmCastMfeStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastMfeStats = PMIB_IPMCAST_MFE_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastMfeStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpMCastMfeStatsEx Type

nxllJwaIpRtrMib.PMibIpMCastMfeStatsEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpMCastMfeStatsEx = PMIB_IPMCAST_MFE_STATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpMCastMfeStatsEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastOif Type

nxllJwaIpRtrMib.PMibIpmCastOif Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastOif = PMIB_IPMCAST_OIF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastOif.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastOifStats Type

nxllJwaIpRtrMib.PMibIpmCastOifStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastOifStats = PMIB_IPMCAST_OIF_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastOifStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpmCastScope Type

nxllJwaIpRtrMib.PMibIpmCastScope Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpmCastScope = PMIB_IPMCAST_SCOPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpmCastScope.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpNetRow Type

nxllJwaIpRtrMib.PMibIpNetRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpNetRow = PMIB_IPNETROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpNetRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpNetTable Type

nxllJwaIpRtrMib.PMibIpNetTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpNetTable = PMIB_IPNETTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpNetTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibIpStats Type

nxllJwaIpRtrMib.PMibIpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibIpStats = PMIB_IPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibIpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibMcastLimitRow Type

nxllJwaIpRtrMib.PMibMcastLimitRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibMcastLimitRow = PMIB_MCAST_LIMIT_ROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibMcastLimitRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibMfeStatsTable Type

nxllJwaIpRtrMib.PMibMfeStatsTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibMfeStatsTable = PMIB_MFE_STATS_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibMfeStatsTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibMfeStatsTableEx Type

nxllJwaIpRtrMib.PMibMfeStatsTableEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibMfeStatsTableEx = PMIB_MFE_STATS_TABLE_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibMfeStatsTableEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibMfeTable Type

nxllJwaIpRtrMib.PMibMfeTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibMfeTable = PMIB_MFE_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibMfeTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibOpaqueInfo Type

nxllJwaIpRtrMib.PMibOpaqueInfo Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibOpaqueInfo = ^TMibOpaqueInfo;
File

nxllJwaIpRtrMib

Description

All the info passed to (SET/CREATE) and from (GET/GETNEXT/GETFIRST) IP Router Manager is encapsulated in the following "discriminated" union. To pass, say MIB_IFROW, use the following code

PMIB_OPAQUE_INFO pInfo; PMIB_IFROW pIfRow; DWORD rgdwBuff[(MAX_MIB_OFFSET + sizeof(MIB_IFROW))/sizeof(DWORD) + 1];

pInfo = (PMIB_OPAQUE_INFO)rgdwBuffer; pIfRow = (MIB_IFROW *)(pInfo->rgbyData);

This can also be accomplished by using the following macro

DEFINE_MIB_BUFFER(pInfo,MIB_IFROW, pIfRow);

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibOpaqueQuery Type

nxllJwaIpRtrMib.PMibOpaqueQuery Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibOpaqueQuery = PMIB_OPAQUE_QUERY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibOpaqueQuery.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibProxyArp Type

nxllJwaIpRtrMib.PMibProxyArp Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibProxyArp = PMIB_PROXYARP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibProxyArp.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibRouteState Type

nxllJwaIpRtrMib.PMibRouteState Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibRouteState = PMIB_ROUTESTATE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibRouteState.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibTcpRow Type

nxllJwaIpRtrMib.PMibTcpRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibTcpRow = PMIB_TCPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibTcpRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibTcpStats Type

nxllJwaIpRtrMib.PMibTcpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibTcpStats = PMIB_TCPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibTcpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibTcpTable Type

nxllJwaIpRtrMib.PMibTcpTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibTcpTable = PMIB_TCPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibTcpTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibUdpRow Type

nxllJwaIpRtrMib.PMibUdpRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibUdpRow = PMIB_UDPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibUdpRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibUdpStats Type

nxllJwaIpRtrMib.PMibUdpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibUdpStats = PMIB_UDPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibUdpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.PMibUdpTable Type

nxllJwaIpRtrMib.PMibUdpTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
PMibUdpTable = PMIB_UDPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.PMibUdpTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.SCOPE_NAME Type

nxllJwaIpRtrMib.SCOPE_NAME Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
SCOPE_NAME = ^SN_CHAR;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.SCOPE_NAME.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.SCOPE_NAME_BUFFER Type

nxllJwaIpRtrMib.SCOPE_NAME_BUFFER Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
SCOPE_NAME_BUFFER = array [0..MAX_SCOPE_NAME_LEN] of SN_CHAR;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.SCOPE_NAME_BUFFER.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.SN_CHAR Type

nxllJwaIpRtrMib.SN_CHAR Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
SN_CHAR = WCHAR;
File

nxllJwaIpRtrMib

Description

Scope names are unicode. SNMP and MZAP use UTF-8 encoding.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TIcmp4Type Type

nxllJwaIpRtrMib.TIcmp4Type Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TIcmp4Type = ICMP4_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TIcmp4Type.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TIcmp6Type Type

nxllJwaIpRtrMib.TIcmp6Type Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TIcmp6Type = ICMP6_TYPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TIcmp6Type.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibBestIf Type

nxllJwaIpRtrMib.TMibBestIf Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibBestIf = MIB_BEST_IF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibBestIf.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibBoundaryRow Type

nxllJwaIpRtrMib.TMibBoundaryRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibBoundaryRow = MIB_BOUNDARYROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibBoundaryRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIcmp Type

nxllJwaIpRtrMib.TMibIcmp Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIcmp = MIB_ICMP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIcmp.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIcmpEx Type

nxllJwaIpRtrMib.TMibIcmpEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIcmpEx = MIB_ICMP_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIcmpEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIcmpInfo Type

nxllJwaIpRtrMib.TMibIcmpInfo Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIcmpInfo = MIBICMPINFO;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIcmpInfo.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIcmpStats Type

nxllJwaIpRtrMib.TMibIcmpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIcmpStats = _MIBICMPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIcmpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIcmpStatsEx Type

nxllJwaIpRtrMib.TMibIcmpStatsEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIcmpStatsEx = MIBICMPSTATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIcmpStatsEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIfnumber Type

nxllJwaIpRtrMib.TMibIfnumber Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIfnumber = MIB_IFNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIfnumber.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIfRow Type

nxllJwaIpRtrMib.TMibIfRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIfRow = MIB_IFROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIfRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIfStatus Type

nxllJwaIpRtrMib.TMibIfStatus Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIfStatus = MIB_IFSTATUS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIfStatus.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIftable Type

nxllJwaIpRtrMib.TMibIftable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIftable = MIB_IFTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIftable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpAddrRow Type

nxllJwaIpRtrMib.TMibIpAddrRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpAddrRow = MIB_IPADDRROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpAddrRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpAddrTable Type

nxllJwaIpRtrMib.TMibIpAddrTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpAddrTable = _MIB_IPADDRTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpAddrTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpDestRow Type

nxllJwaIpRtrMib.TMibIpDestRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpDestRow = MIB_IPDESTROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpDestRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpDestTable Type

nxllJwaIpRtrMib.TMibIpDestTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpDestTable = MIB_IPDESTTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpDestTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpForwardNumber Type

nxllJwaIpRtrMib.TMibIpForwardNumber Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpForwardNumber = MIB_IPFORWARDNUMBER;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpForwardNumber.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpForwardRow Type

nxllJwaIpRtrMib.TMibIpForwardRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpForwardRow = MIB_IPFORWARDROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpForwardRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpForwardTable Type

nxllJwaIpRtrMib.TMibIpForwardTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpForwardTable = MIB_IPFORWARDTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpForwardTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastBoundary Type

nxllJwaIpRtrMib.TMibIpmCastBoundary Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastBoundary = MIB_IPMCAST_BOUNDARY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastBoundary.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastBoundaryTable Type

nxllJwaIpRtrMib.TMibIpmCastBoundaryTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastBoundaryTable = MIB_IPMCAST_BOUNDARY_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastBoundaryTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastGlobal Type

nxllJwaIpRtrMib.TMibIpmCastGlobal Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastGlobal = MIB_IPMCAST_GLOBAL;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastGlobal.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastIfEntry Type

nxllJwaIpRtrMib.TMibIpmCastIfEntry Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastIfEntry = MIB_IPMCAST_IF_ENTRY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastIfEntry.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastIfTable Type

nxllJwaIpRtrMib.TMibIpmCastIfTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastIfTable = MIB_IPMCAST_IF_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastIfTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastMfe Type

nxllJwaIpRtrMib.TMibIpmCastMfe Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastMfe = MIB_IPMCAST_MFE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastMfe.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastMfeStats Type

nxllJwaIpRtrMib.TMibIpmCastMfeStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastMfeStats = MIB_IPMCAST_MFE_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastMfeStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpMCastMfeStatsEx Type

nxllJwaIpRtrMib.TMibIpMCastMfeStatsEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpMCastMfeStatsEx = MIB_IPMCAST_MFE_STATS_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpMCastMfeStatsEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastOif Type

nxllJwaIpRtrMib.TMibIpmCastOif Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastOif = MIB_IPMCAST_OIF;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastOif.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastOifStats Type

nxllJwaIpRtrMib.TMibIpmCastOifStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastOifStats = MIB_IPMCAST_OIF_STATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastOifStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpmCastScope Type

nxllJwaIpRtrMib.TMibIpmCastScope Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpmCastScope = MIB_IPMCAST_SCOPE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpmCastScope.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpNetRow Type

nxllJwaIpRtrMib.TMibIpNetRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpNetRow = MIB_IPNETROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpNetRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpNetTable Type

nxllJwaIpRtrMib.TMibIpNetTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpNetTable = MIB_IPNETTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpNetTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibIpStats Type

nxllJwaIpRtrMib.TMibIpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibIpStats = MIB_IPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibIpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibMcastLimitRow Type

nxllJwaIpRtrMib.TMibMcastLimitRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibMcastLimitRow = MIB_MCAST_LIMIT_ROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibMcastLimitRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibMfeStatsTable Type

nxllJwaIpRtrMib.TMibMfeStatsTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibMfeStatsTable = MIB_MFE_STATS_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibMfeStatsTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibMfeStatsTableEx Type

nxllJwaIpRtrMib.TMibMfeStatsTableEx Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibMfeStatsTableEx = MIB_MFE_STATS_TABLE_EX;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibMfeStatsTableEx.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibMfeTable Type

nxllJwaIpRtrMib.TMibMfeTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibMfeTable = MIB_MFE_TABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibMfeTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibOpaqueInfo Type

nxllJwaIpRtrMib.TMibOpaqueInfo Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibOpaqueInfo = MIB_OPAQUE_INFO;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibOpaqueInfo.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibOpaqueQuery Type

nxllJwaIpRtrMib.TMibOpaqueQuery Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibOpaqueQuery = MIB_OPAQUE_QUERY;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibOpaqueQuery.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibProxyArp Type

nxllJwaIpRtrMib.TMibProxyArp Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibProxyArp = MIB_PROXYARP;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibProxyArp.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibRouteState Type

nxllJwaIpRtrMib.TMibRouteState Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibRouteState = MIB_ROUTESTATE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibRouteState.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibTcpRow Type

nxllJwaIpRtrMib.TMibTcpRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibTcpRow = MIB_TCPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibTcpRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibTcpStats Type

nxllJwaIpRtrMib.TMibTcpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibTcpStats = MIB_TCPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibTcpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibTcpTable Type

nxllJwaIpRtrMib.TMibTcpTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibTcpTable = MIB_TCPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibTcpTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibUdpRow Type

nxllJwaIpRtrMib.TMibUdpRow Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibUdpRow = MIB_UDPROW;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibUdpRow.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibUdpStats Type

nxllJwaIpRtrMib.TMibUdpStats Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibUdpStats = MIB_UDPSTATS;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibUdpStats.

Group

Types

Links
nxllJwaIpRtrMib, Types


nxllJwaIpRtrMib.TMibUdpTable Type

nxllJwaIpRtrMib.TMibUdpTable Type
nxllJwaIpRtrMib Types Send Feedback
Syntax
Delphi
TMibUdpTable = MIB_UDPTABLE;
File

nxllJwaIpRtrMib

Description

This is type nxllJwaIpRtrMib.TMibUdpTable.

Group

Types

Links
nxllJwaIpRtrMib, Types


Constants

Constants
Constants nxllJwaIpRtrMib Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
ANY_SIZE | This is constant nxllJwaIpRtrMib.ANY_SIZE.
BEST_IF | This is constant nxllJwaIpRtrMib.BEST_IF.
BEST_ROUTE | This is constant nxllJwaIpRtrMib.BEST_ROUTE.
DEST_LONGER | This is constant nxllJwaIpRtrMib.DEST_LONGER.
DEST_MATCHING | This is constant nxllJwaIpRtrMib.DEST_MATCHING.
DEST_SHORTER | This is constant nxllJwaIpRtrMib.DEST_SHORTER.
ICMP_STATS | This is constant nxllJwaIpRtrMib.ICMP_STATS.
ICMP4_DST_UNREACH | Destination Unreachable
ICMP4_ECHO_REPLY | Echo Reply
ICMP4_ECHO_REQUEST | Echo Request
ICMP4_MASK_REPLY | Address Mask Reply
ICMP4_MASK_REQUEST | Address Mask Request
ICMP4_PARAM_PROB | Parameter Problem
ICMP4_REDIRECT | Redirect
ICMP4_ROUTER_ADVERT | Router Advertisement
ICMP4_ROUTER_SOLICIT | Router Solicitation
ICMP4_SOURCE_QUENCH | Source Quench
ICMP4_TIME_EXCEEDED | Time Exceeded
ICMP4_TIMESTAMP_REPLY | Timestamp Reply
ICMP4_TIMESTAMP_REQUEST | Timestamp Request
ICMP6_DST_UNREACH | ICMPv6 Type Values from RFC 2292.
ICMP6_ECHO_REPLY | This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REPLY.
ICMP6_ECHO_REQUEST | This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REQUEST.
ICMP6_MEMBERSHIP_QUERY | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_QUERY.
ICMP6_MEMBERSHIP_REDUCTION | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REDUCTION.
ICMP6_MEMBERSHIP_REPORT | This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REPORT.
ICMP6_PACKET_TOO_BIG | This is constant nxllJwaIpRtrMib.ICMP6_PACKET_TOO_BIG.
ICMP6_PARAM_PROB | This is constant nxllJwaIpRtrMib.ICMP6_PARAM_PROB.
ICMP6_TIME_EXCEEDED | This is constant nxllJwaIpRtrMib.ICMP6_TIME_EXCEEDED.
IF_NUMBER | The following #defines are the Ids of the MIB variables made accessible to the user via MprAdminMIBXXX Apis. It will be noticed that these are not the same as RFC 1213, since the MprAdminMIBXXX APIs work on rows and groups instead of scalar variables
IF_ROW | This is constant nxllJwaIpRtrMib.IF_ROW.
IF_STATUS | This is constant nxllJwaIpRtrMib.IF_STATUS.
IF_TABLE | This is constant nxllJwaIpRtrMib.IF_TABLE.
IP_ADDRROW | This is constant nxllJwaIpRtrMib.IP_ADDRROW.
IP_ADDRTABLE | This is constant nxllJwaIpRtrMib.IP_ADDRTABLE.
IP_FORWARDNUMBER | This is constant nxllJwaIpRtrMib.IP_FORWARDNUMBER.
IP_FORWARDROW | This is constant nxllJwaIpRtrMib.IP_FORWARDROW.
IP_FORWARDTABLE | This is constant nxllJwaIpRtrMib.IP_FORWARDTABLE.
IP_NETROW | This is constant nxllJwaIpRtrMib.IP_NETROW.
IP_NETTABLE | This is constant nxllJwaIpRtrMib.IP_NETTABLE.
IP_STATS | This is constant nxllJwaIpRtrMib.IP_STATS.
IP6_STATS | This is constant nxllJwaIpRtrMib.IP6_STATS.
IPRTRMGR_PID | This is constant nxllJwaIpRtrMib.IPRTRMGR_PID.
MAX_INTERFACE_NAME_LEN | MPRAPI.H
MAX_MIB_OFFSET | This is constant nxllJwaIpRtrMib.MAX_MIB_OFFSET.
MAX_SCOPE_NAME_LEN | This is constant nxllJwaIpRtrMib.MAX_SCOPE_NAME_LEN.
MAXLEN_IFDESCR | This is constant nxllJwaIpRtrMib.MAXLEN_IFDESCR.
MAXLEN_PHYSADDR | This is constant nxllJwaIpRtrMib.MAXLEN_PHYSADDR.
MCAST_BOUNDARY | This is constant nxllJwaIpRtrMib.MCAST_BOUNDARY.
MCAST_GLOBAL | This is constant nxllJwaIpRtrMib.MCAST_GLOBAL.
MCAST_IF_ENTRY | This is constant nxllJwaIpRtrMib.MCAST_IF_ENTRY.
MCAST_MFE | This is constant nxllJwaIpRtrMib.MCAST_MFE.
MCAST_MFE_STATS | This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS.
MCAST_MFE_STATS_EX | This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS_EX.
MCAST_SCOPE | This is constant nxllJwaIpRtrMib.MCAST_SCOPE.
MIB_IP_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_IP_FORWARDING.
MIB_IP_NOT_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_IP_NOT_FORWARDING.
MIB_IPADDR_DELETED | Address being deleted
MIB_IPADDR_DISCONNECTED | Address is on disconnected interface
MIB_IPADDR_DYNAMIC | Dynamic ipaddr
MIB_IPADDR_PRIMARY | Primary ipaddr
MIB_IPADDR_TRANSIENT | Transient address
MIB_IPNET_TYPE_DYNAMIC | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_DYNAMIC.
MIB_IPNET_TYPE_INVALID | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_INVALID.
MIB_IPNET_TYPE_OTHER | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_OTHER.
MIB_IPNET_TYPE_STATIC | This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_STATIC.
MIB_IPPROTO_BBN | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BBN.
MIB_IPPROTO_BGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BGP.
MIB_IPPROTO_CISCO | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_CISCO.
MIB_IPPROTO_EGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_EGP.
MIB_IPPROTO_ES_IS | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ES_IS.
MIB_IPPROTO_GGP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_GGP.
MIB_IPPROTO_HELLO | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_HELLO.
MIB_IPPROTO_ICMP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ICMP.
MIB_IPPROTO_IS_IS | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_IS_IS.
MIB_IPPROTO_LOCAL | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_LOCAL.
MIB_IPPROTO_NETMGMT | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NETMGMT.
MIB_IPPROTO_NT_AUTOSTATIC | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_AUTOSTATIC.
MIB_IPPROTO_NT_STATIC | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC.
MIB_IPPROTO_NT_STATIC_NON_DOD | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC_NON_DOD.
MIB_IPPROTO_OSPF | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_OSPF.
MIB_IPPROTO_OTHER | THESE MUST MATCH the ids in routprot.h
MIB_IPPROTO_RIP | This is constant nxllJwaIpRtrMib.MIB_IPPROTO_RIP.
MIB_IPROUTE_METRIC_UNUSED | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_METRIC_UNUSED.
MIB_IPROUTE_TYPE_DIRECT | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_DIRECT.
MIB_IPROUTE_TYPE_INDIRECT | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INDIRECT.
MIB_IPROUTE_TYPE_INVALID | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INVALID.
MIB_IPROUTE_TYPE_OTHER | This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_OTHER.
MIB_TCP_MAXCONN_DYNAMIC | This is constant nxllJwaIpRtrMib.MIB_TCP_MAXCONN_DYNAMIC.
MIB_TCP_RTO_CONSTANT | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_CONSTANT.
MIB_TCP_RTO_OTHER | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_OTHER.
MIB_TCP_RTO_RSRE | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_RSRE.
MIB_TCP_RTO_VANJ | This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_VANJ.
MIB_TCP_STATE_CLOSE_WAIT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSE_WAIT.
MIB_TCP_STATE_CLOSED | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSED.
MIB_TCP_STATE_CLOSING | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSING.
MIB_TCP_STATE_DELETE_TCB | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_DELETE_TCB.
MIB_TCP_STATE_ESTAB | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_ESTAB.
MIB_TCP_STATE_FIN_WAIT1 | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT1.
MIB_TCP_STATE_FIN_WAIT2 | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT2.
MIB_TCP_STATE_LAST_ACK | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LAST_ACK.
MIB_TCP_STATE_LISTEN | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LISTEN.
MIB_TCP_STATE_SYN_RCVD | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_RCVD.
MIB_TCP_STATE_SYN_SENT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_SENT.
MIB_TCP_STATE_TIME_WAIT | This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_TIME_WAIT.
MIB_USE_CURRENT_FORWARDING | This is constant nxllJwaIpRtrMib.MIB_USE_CURRENT_FORWARDING.
MIB_USE_CURRENT_TTL | define SIZEOF_TCPTABLE(X) (FIELD_OFFSET(MIB_TCPTABLE,table[0]) + ((X) * sizeof(MIB_TCPROW)) + ALIGN_SIZE)
ND_NEIGHBOR_ADVERT | This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_ADVERT.
ND_NEIGHBOR_SOLICIT | This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_SOLICIT.
ND_REDIRECT | This is constant nxllJwaIpRtrMib.ND_REDIRECT.
ND_ROUTER_ADVERT | This is constant nxllJwaIpRtrMib.ND_ROUTER_ADVERT.
ND_ROUTER_SOLICIT | This is constant nxllJwaIpRtrMib.ND_ROUTER_SOLICIT.
NUMBER_OF_EXPORTED_VARIABLES | This is constant nxllJwaIpRtrMib.NUMBER_OF_EXPORTED_VARIABLES.
PROXY_ARP | This is constant nxllJwaIpRtrMib.PROXY_ARP.
ROUTE_LONGER | This is constant nxllJwaIpRtrMib.ROUTE_LONGER.
ROUTE_MATCHING | This is constant nxllJwaIpRtrMib.ROUTE_MATCHING.
ROUTE_SHORTER | This is constant nxllJwaIpRtrMib.ROUTE_SHORTER.
ROUTE_STATE | This is constant nxllJwaIpRtrMib.ROUTE_STATE.
TCP_ROW | This is constant nxllJwaIpRtrMib.TCP_ROW.
TCP_STATS | This is constant nxllJwaIpRtrMib.TCP_STATS.
TCP_TABLE | This is constant nxllJwaIpRtrMib.TCP_TABLE.
TCP6_STATS | This is constant nxllJwaIpRtrMib.TCP6_STATS.
UDP_ROW | This is constant nxllJwaIpRtrMib.UDP_ROW.
UDP_STATS | This is constant nxllJwaIpRtrMib.UDP_STATS.
UDP_TABLE | This is constant nxllJwaIpRtrMib.UDP_TABLE.
UDP6_STATS | This is constant nxllJwaIpRtrMib.UDP6_STATS.
Namespace

nxllJwaIpRtrMib Namespace

Links
Constants, nxllJwaIpRtrMib Namespace


nxllJwaIpRtrMib.ANY_SIZE Constant

nxllJwaIpRtrMib.ANY_SIZE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ANY_SIZE = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ANY_SIZE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.BEST_IF Constant

nxllJwaIpRtrMib.BEST_IF Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
BEST_IF = MCAST_MFE_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.BEST_IF.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.BEST_ROUTE Constant

nxllJwaIpRtrMib.BEST_ROUTE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
BEST_ROUTE = BEST_IF + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.BEST_ROUTE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.DEST_LONGER Constant

nxllJwaIpRtrMib.DEST_LONGER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
DEST_LONGER = DEST_MATCHING + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.DEST_LONGER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.DEST_MATCHING Constant

nxllJwaIpRtrMib.DEST_MATCHING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
DEST_MATCHING = MCAST_SCOPE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.DEST_MATCHING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.DEST_SHORTER Constant

nxllJwaIpRtrMib.DEST_SHORTER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
DEST_SHORTER = DEST_LONGER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.DEST_SHORTER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP_STATS Constant

nxllJwaIpRtrMib.ICMP_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP_STATS = IP_NETROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_DST_UNREACH Constant

nxllJwaIpRtrMib.ICMP4_DST_UNREACH Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_DST_UNREACH = 3;
File

nxllJwaIpRtrMib

Description

Destination Unreachable

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_ECHO_REPLY Constant

nxllJwaIpRtrMib.ICMP4_ECHO_REPLY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_ECHO_REPLY = 0;
File

nxllJwaIpRtrMib

Description

Echo Reply

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_ECHO_REQUEST Constant

nxllJwaIpRtrMib.ICMP4_ECHO_REQUEST Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_ECHO_REQUEST = 8;
File

nxllJwaIpRtrMib

Description

Echo Request

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_MASK_REPLY Constant

nxllJwaIpRtrMib.ICMP4_MASK_REPLY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_MASK_REPLY = 18;
File

nxllJwaIpRtrMib

Description

Address Mask Reply

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_MASK_REQUEST Constant

nxllJwaIpRtrMib.ICMP4_MASK_REQUEST Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_MASK_REQUEST = 17;
File

nxllJwaIpRtrMib

Description

Address Mask Request

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_PARAM_PROB Constant

nxllJwaIpRtrMib.ICMP4_PARAM_PROB Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_PARAM_PROB = 12;
File

nxllJwaIpRtrMib

Description

Parameter Problem

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_REDIRECT Constant

nxllJwaIpRtrMib.ICMP4_REDIRECT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_REDIRECT = 5;
File

nxllJwaIpRtrMib

Description

Redirect

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_ROUTER_ADVERT Constant

nxllJwaIpRtrMib.ICMP4_ROUTER_ADVERT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_ROUTER_ADVERT = 9;
File

nxllJwaIpRtrMib

Description

Router Advertisement

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_ROUTER_SOLICIT Constant

nxllJwaIpRtrMib.ICMP4_ROUTER_SOLICIT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_ROUTER_SOLICIT = 10;
File

nxllJwaIpRtrMib

Description

Router Solicitation

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_SOURCE_QUENCH Constant

nxllJwaIpRtrMib.ICMP4_SOURCE_QUENCH Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_SOURCE_QUENCH = 4;
File

nxllJwaIpRtrMib

Description

Source Quench

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_TIME_EXCEEDED Constant

nxllJwaIpRtrMib.ICMP4_TIME_EXCEEDED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_TIME_EXCEEDED = 11;
File

nxllJwaIpRtrMib

Description

Time Exceeded

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_TIMESTAMP_REPLY Constant

nxllJwaIpRtrMib.ICMP4_TIMESTAMP_REPLY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_TIMESTAMP_REPLY = 14;
File

nxllJwaIpRtrMib

Description

Timestamp Reply

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP4_TIMESTAMP_REQUEST Constant

nxllJwaIpRtrMib.ICMP4_TIMESTAMP_REQUEST Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP4_TIMESTAMP_REQUEST = 13;
File

nxllJwaIpRtrMib

Description

Timestamp Request

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_DST_UNREACH Constant

nxllJwaIpRtrMib.ICMP6_DST_UNREACH Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_DST_UNREACH = 1;
File

nxllJwaIpRtrMib

Description

ICMPv6 Type Values from RFC 2292.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_ECHO_REPLY Constant

nxllJwaIpRtrMib.ICMP6_ECHO_REPLY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_ECHO_REPLY = 129;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REPLY.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_ECHO_REQUEST Constant

nxllJwaIpRtrMib.ICMP6_ECHO_REQUEST Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_ECHO_REQUEST = 128;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_ECHO_REQUEST.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_QUERY Constant

nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_QUERY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_MEMBERSHIP_QUERY = 130;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_QUERY.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REDUCTION Constant

nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REDUCTION Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_MEMBERSHIP_REDUCTION = 132;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REDUCTION.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REPORT Constant

nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REPORT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_MEMBERSHIP_REPORT = 131;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_MEMBERSHIP_REPORT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_PACKET_TOO_BIG Constant

nxllJwaIpRtrMib.ICMP6_PACKET_TOO_BIG Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_PACKET_TOO_BIG = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_PACKET_TOO_BIG.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_PARAM_PROB Constant

nxllJwaIpRtrMib.ICMP6_PARAM_PROB Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_PARAM_PROB = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_PARAM_PROB.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ICMP6_TIME_EXCEEDED Constant

nxllJwaIpRtrMib.ICMP6_TIME_EXCEEDED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ICMP6_TIME_EXCEEDED = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ICMP6_TIME_EXCEEDED.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IF_NUMBER Constant

nxllJwaIpRtrMib.IF_NUMBER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IF_NUMBER = 0;
File

nxllJwaIpRtrMib

Description

The following #defines are the Ids of the MIB variables made accessible to the user via MprAdminMIBXXX Apis. It will be noticed that these are not the same as RFC 1213, since the MprAdminMIBXXX APIs work on rows and groups instead of scalar variables

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IF_ROW Constant

nxllJwaIpRtrMib.IF_ROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IF_ROW = IF_TABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IF_ROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IF_STATUS Constant

nxllJwaIpRtrMib.IF_STATUS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IF_STATUS = MCAST_GLOBAL + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IF_STATUS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IF_TABLE Constant

nxllJwaIpRtrMib.IF_TABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IF_TABLE = IF_NUMBER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IF_TABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_ADDRROW Constant

nxllJwaIpRtrMib.IP_ADDRROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_ADDRROW = IP_ADDRTABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_ADDRROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_ADDRTABLE Constant

nxllJwaIpRtrMib.IP_ADDRTABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_ADDRTABLE = IP_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_ADDRTABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_FORWARDNUMBER Constant

nxllJwaIpRtrMib.IP_FORWARDNUMBER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_FORWARDNUMBER = IP_ADDRROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_FORWARDNUMBER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_FORWARDROW Constant

nxllJwaIpRtrMib.IP_FORWARDROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_FORWARDROW = IP_FORWARDTABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_FORWARDROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_FORWARDTABLE Constant

nxllJwaIpRtrMib.IP_FORWARDTABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_FORWARDTABLE = IP_FORWARDNUMBER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_FORWARDTABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_NETROW Constant

nxllJwaIpRtrMib.IP_NETROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_NETROW = IP_NETTABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_NETROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_NETTABLE Constant

nxllJwaIpRtrMib.IP_NETTABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_NETTABLE = IP_FORWARDROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_NETTABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP_STATS Constant

nxllJwaIpRtrMib.IP_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP_STATS = IF_ROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IP6_STATS Constant

nxllJwaIpRtrMib.IP6_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IP6_STATS = MCAST_MFE_STATS_EX + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IP6_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.IPRTRMGR_PID Constant

nxllJwaIpRtrMib.IPRTRMGR_PID Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
IPRTRMGR_PID = 10000;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.IPRTRMGR_PID.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MAX_INTERFACE_NAME_LEN Constant

nxllJwaIpRtrMib.MAX_INTERFACE_NAME_LEN Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MAX_INTERFACE_NAME_LEN = 256;
File

nxllJwaIpRtrMib

Description

MPRAPI.H

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MAX_MIB_OFFSET Constant

nxllJwaIpRtrMib.MAX_MIB_OFFSET Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MAX_MIB_OFFSET = 8;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MAX_MIB_OFFSET.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MAX_SCOPE_NAME_LEN Constant

nxllJwaIpRtrMib.MAX_SCOPE_NAME_LEN Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MAX_SCOPE_NAME_LEN = 255;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MAX_SCOPE_NAME_LEN.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MAXLEN_IFDESCR Constant

nxllJwaIpRtrMib.MAXLEN_IFDESCR Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MAXLEN_IFDESCR = 256;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MAXLEN_IFDESCR.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MAXLEN_PHYSADDR Constant

nxllJwaIpRtrMib.MAXLEN_PHYSADDR Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MAXLEN_PHYSADDR = 8;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MAXLEN_PHYSADDR.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_BOUNDARY Constant

nxllJwaIpRtrMib.MCAST_BOUNDARY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_BOUNDARY = IF_STATUS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_BOUNDARY.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_GLOBAL Constant

nxllJwaIpRtrMib.MCAST_GLOBAL Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_GLOBAL = MCAST_IF_ENTRY + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_GLOBAL.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_IF_ENTRY Constant

nxllJwaIpRtrMib.MCAST_IF_ENTRY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_IF_ENTRY = PROXY_ARP + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_IF_ENTRY.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_MFE Constant

nxllJwaIpRtrMib.MCAST_MFE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_MFE = UDP_ROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_MFE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_MFE_STATS Constant

nxllJwaIpRtrMib.MCAST_MFE_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_MFE_STATS = MCAST_MFE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_MFE_STATS_EX Constant

nxllJwaIpRtrMib.MCAST_MFE_STATS_EX Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_MFE_STATS_EX = ROUTE_STATE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_MFE_STATS_EX.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MCAST_SCOPE Constant

nxllJwaIpRtrMib.MCAST_SCOPE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MCAST_SCOPE = MCAST_BOUNDARY + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MCAST_SCOPE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IP_FORWARDING Constant

nxllJwaIpRtrMib.MIB_IP_FORWARDING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IP_FORWARDING = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IP_FORWARDING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IP_NOT_FORWARDING Constant

nxllJwaIpRtrMib.MIB_IP_NOT_FORWARDING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IP_NOT_FORWARDING = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IP_NOT_FORWARDING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPADDR_DELETED Constant

nxllJwaIpRtrMib.MIB_IPADDR_DELETED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPADDR_DELETED = $0040;
File

nxllJwaIpRtrMib

Description

Address being deleted

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPADDR_DISCONNECTED Constant

nxllJwaIpRtrMib.MIB_IPADDR_DISCONNECTED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPADDR_DISCONNECTED = $0008;
File

nxllJwaIpRtrMib

Description

Address is on disconnected interface

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPADDR_DYNAMIC Constant

nxllJwaIpRtrMib.MIB_IPADDR_DYNAMIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPADDR_DYNAMIC = $0004;
File

nxllJwaIpRtrMib

Description

Dynamic ipaddr

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPADDR_PRIMARY Constant

nxllJwaIpRtrMib.MIB_IPADDR_PRIMARY Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPADDR_PRIMARY = $0001;
File

nxllJwaIpRtrMib

Description

Primary ipaddr

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPADDR_TRANSIENT Constant

nxllJwaIpRtrMib.MIB_IPADDR_TRANSIENT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPADDR_TRANSIENT = $0080;
File

nxllJwaIpRtrMib

Description

Transient address

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPNET_TYPE_DYNAMIC Constant

nxllJwaIpRtrMib.MIB_IPNET_TYPE_DYNAMIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPNET_TYPE_DYNAMIC = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_DYNAMIC.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPNET_TYPE_INVALID Constant

nxllJwaIpRtrMib.MIB_IPNET_TYPE_INVALID Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPNET_TYPE_INVALID = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_INVALID.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPNET_TYPE_OTHER Constant

nxllJwaIpRtrMib.MIB_IPNET_TYPE_OTHER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPNET_TYPE_OTHER = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_OTHER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPNET_TYPE_STATIC Constant

nxllJwaIpRtrMib.MIB_IPNET_TYPE_STATIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPNET_TYPE_STATIC = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPNET_TYPE_STATIC.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_BBN Constant

nxllJwaIpRtrMib.MIB_IPPROTO_BBN Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_BBN = 12;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BBN.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_BGP Constant

nxllJwaIpRtrMib.MIB_IPPROTO_BGP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_BGP = 14;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_BGP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_CISCO Constant

nxllJwaIpRtrMib.MIB_IPPROTO_CISCO Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_CISCO = 11;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_CISCO.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_EGP Constant

nxllJwaIpRtrMib.MIB_IPPROTO_EGP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_EGP = 5;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_EGP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_ES_IS Constant

nxllJwaIpRtrMib.MIB_IPPROTO_ES_IS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_ES_IS = 10;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ES_IS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_GGP Constant

nxllJwaIpRtrMib.MIB_IPPROTO_GGP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_GGP = 6;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_GGP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_HELLO Constant

nxllJwaIpRtrMib.MIB_IPPROTO_HELLO Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_HELLO = 7;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_HELLO.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_ICMP Constant

nxllJwaIpRtrMib.MIB_IPPROTO_ICMP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_ICMP = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_ICMP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_IS_IS Constant

nxllJwaIpRtrMib.MIB_IPPROTO_IS_IS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_IS_IS = 9;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_IS_IS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_LOCAL Constant

nxllJwaIpRtrMib.MIB_IPPROTO_LOCAL Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_LOCAL = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_LOCAL.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_NETMGMT Constant

nxllJwaIpRtrMib.MIB_IPPROTO_NETMGMT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_NETMGMT = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NETMGMT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_NT_AUTOSTATIC Constant

nxllJwaIpRtrMib.MIB_IPPROTO_NT_AUTOSTATIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_NT_AUTOSTATIC = 10002;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_AUTOSTATIC.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC Constant

nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_NT_STATIC = 10006;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC_NON_DOD Constant

nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC_NON_DOD Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_NT_STATIC_NON_DOD = 10007;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_NT_STATIC_NON_DOD.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_OSPF Constant

nxllJwaIpRtrMib.MIB_IPPROTO_OSPF Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_OSPF = 13;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_OSPF.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_OTHER Constant

nxllJwaIpRtrMib.MIB_IPPROTO_OTHER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_OTHER = 1;
File

nxllJwaIpRtrMib

Description

THESE MUST MATCH the ids in routprot.h

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPPROTO_RIP Constant

nxllJwaIpRtrMib.MIB_IPPROTO_RIP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPPROTO_RIP = 8;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPPROTO_RIP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPROUTE_METRIC_UNUSED Constant

nxllJwaIpRtrMib.MIB_IPROUTE_METRIC_UNUSED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPROUTE_METRIC_UNUSED = DWORD(-1);
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPROUTE_METRIC_UNUSED.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_DIRECT Constant

nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_DIRECT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPROUTE_TYPE_DIRECT = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_DIRECT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INDIRECT Constant

nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INDIRECT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPROUTE_TYPE_INDIRECT = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INDIRECT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INVALID Constant

nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INVALID Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPROUTE_TYPE_INVALID = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_INVALID.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_OTHER Constant

nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_OTHER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_IPROUTE_TYPE_OTHER = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_IPROUTE_TYPE_OTHER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_MAXCONN_DYNAMIC Constant

nxllJwaIpRtrMib.MIB_TCP_MAXCONN_DYNAMIC Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_MAXCONN_DYNAMIC = DWORD(-1);
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_MAXCONN_DYNAMIC.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_RTO_CONSTANT Constant

nxllJwaIpRtrMib.MIB_TCP_RTO_CONSTANT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_RTO_CONSTANT = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_CONSTANT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_RTO_OTHER Constant

nxllJwaIpRtrMib.MIB_TCP_RTO_OTHER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_RTO_OTHER = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_OTHER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_RTO_RSRE Constant

nxllJwaIpRtrMib.MIB_TCP_RTO_RSRE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_RTO_RSRE = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_RSRE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_RTO_VANJ Constant

nxllJwaIpRtrMib.MIB_TCP_RTO_VANJ Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_RTO_VANJ = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_RTO_VANJ.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSE_WAIT Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSE_WAIT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_CLOSE_WAIT = 8;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSE_WAIT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSED Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSED Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_CLOSED = 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSED.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSING Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_CLOSING = 9;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_CLOSING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_DELETE_TCB Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_DELETE_TCB Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_DELETE_TCB = 12;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_DELETE_TCB.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_ESTAB Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_ESTAB Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_ESTAB = 5;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_ESTAB.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT1 Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT1 Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_FIN_WAIT1 = 6;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT1.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT2 Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT2 Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_FIN_WAIT2 = 7;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_FIN_WAIT2.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_LAST_ACK Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_LAST_ACK Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_LAST_ACK = 10;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LAST_ACK.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_LISTEN Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_LISTEN Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_LISTEN = 2;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_LISTEN.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_RCVD Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_RCVD Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_SYN_RCVD = 4;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_RCVD.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_SENT Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_SENT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_SYN_SENT = 3;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_SYN_SENT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_TCP_STATE_TIME_WAIT Constant

nxllJwaIpRtrMib.MIB_TCP_STATE_TIME_WAIT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_TCP_STATE_TIME_WAIT = 11;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_TCP_STATE_TIME_WAIT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_USE_CURRENT_FORWARDING Constant

nxllJwaIpRtrMib.MIB_USE_CURRENT_FORWARDING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_USE_CURRENT_FORWARDING = DWORD(-1);
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.MIB_USE_CURRENT_FORWARDING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.MIB_USE_CURRENT_TTL Constant

nxllJwaIpRtrMib.MIB_USE_CURRENT_TTL Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
MIB_USE_CURRENT_TTL = DWORD(-1);
File

nxllJwaIpRtrMib

Description

define SIZEOF_TCPTABLE(X) (FIELD_OFFSET(MIB_TCPTABLE,table[0]) + ((X) * sizeof(MIB_TCPROW)) + ALIGN_SIZE)

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ND_NEIGHBOR_ADVERT Constant

nxllJwaIpRtrMib.ND_NEIGHBOR_ADVERT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ND_NEIGHBOR_ADVERT = 136;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_ADVERT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ND_NEIGHBOR_SOLICIT Constant

nxllJwaIpRtrMib.ND_NEIGHBOR_SOLICIT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ND_NEIGHBOR_SOLICIT = 135;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ND_NEIGHBOR_SOLICIT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ND_REDIRECT Constant

nxllJwaIpRtrMib.ND_REDIRECT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ND_REDIRECT = 137;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ND_REDIRECT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ND_ROUTER_ADVERT Constant

nxllJwaIpRtrMib.ND_ROUTER_ADVERT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ND_ROUTER_ADVERT = 134;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ND_ROUTER_ADVERT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ND_ROUTER_SOLICIT Constant

nxllJwaIpRtrMib.ND_ROUTER_SOLICIT Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ND_ROUTER_SOLICIT = 133;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ND_ROUTER_SOLICIT.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.NUMBER_OF_EXPORTED_VARIABLES Constant

nxllJwaIpRtrMib.NUMBER_OF_EXPORTED_VARIABLES Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
NUMBER_OF_EXPORTED_VARIABLES = TCP6_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.NUMBER_OF_EXPORTED_VARIABLES.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.PROXY_ARP Constant

nxllJwaIpRtrMib.PROXY_ARP Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
PROXY_ARP = BEST_ROUTE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.PROXY_ARP.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ROUTE_LONGER Constant

nxllJwaIpRtrMib.ROUTE_LONGER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ROUTE_LONGER = ROUTE_MATCHING + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ROUTE_LONGER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ROUTE_MATCHING Constant

nxllJwaIpRtrMib.ROUTE_MATCHING Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ROUTE_MATCHING = DEST_SHORTER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ROUTE_MATCHING.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ROUTE_SHORTER Constant

nxllJwaIpRtrMib.ROUTE_SHORTER Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ROUTE_SHORTER = ROUTE_LONGER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ROUTE_SHORTER.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.ROUTE_STATE Constant

nxllJwaIpRtrMib.ROUTE_STATE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
ROUTE_STATE = ROUTE_SHORTER + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.ROUTE_STATE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.TCP_ROW Constant

nxllJwaIpRtrMib.TCP_ROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
TCP_ROW = TCP_TABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.TCP_ROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.TCP_STATS Constant

nxllJwaIpRtrMib.TCP_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
TCP_STATS = ICMP_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.TCP_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.TCP_TABLE Constant

nxllJwaIpRtrMib.TCP_TABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
TCP_TABLE = TCP_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.TCP_TABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.TCP6_STATS Constant

nxllJwaIpRtrMib.TCP6_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
TCP6_STATS = UDP6_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.TCP6_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.UDP_ROW Constant

nxllJwaIpRtrMib.UDP_ROW Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
UDP_ROW = UDP_TABLE + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.UDP_ROW.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.UDP_STATS Constant

nxllJwaIpRtrMib.UDP_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
UDP_STATS = TCP_ROW + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.UDP_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.UDP_TABLE Constant

nxllJwaIpRtrMib.UDP_TABLE Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
UDP_TABLE = UDP_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.UDP_TABLE.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpRtrMib.UDP6_STATS Constant

nxllJwaIpRtrMib.UDP6_STATS Constant
nxllJwaIpRtrMib Constants Send Feedback
Syntax
Delphi
UDP6_STATS = IP6_STATS + 1;
File

nxllJwaIpRtrMib

Description

This is constant nxllJwaIpRtrMib.UDP6_STATS.

Group

Constants

Links
nxllJwaIpRtrMib, Constants


nxllJwaIpTypes Namespace

nxllJwaIpTypes Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

Id: JwaIpTypes.pas,v 1.8 2007/09/05 11:58:50 dezipaitor Exp

Constants
Name | Description
BROADCAST_NODETYPE | Node Type
DEFAULT_MINIMUM_ENTITIES | arb.
GAA_FLAG_INCLUDE_PREFIX | This is constant nxllJwaIpTypes.GAA_FLAG_INCLUDE_PREFIX.
GAA_FLAG_SKIP_ANYCAST | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_ANYCAST.
GAA_FLAG_SKIP_DNS_SERVER | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_DNS_SERVER.
GAA_FLAG_SKIP_FRIENDLY_NAME | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_FRIENDLY_NAME.
GAA_FLAG_SKIP_MULTICAST | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_MULTICAST.
GAA_FLAG_SKIP_UNICAST | Flags used as argument to GetAdaptersAddresses(). "SKIP" flags are added when the default is to include the information. "INCLUDE" flags are added when the default is to skip the information.
HYBRID_NODETYPE | This is constant nxllJwaIpTypes.HYBRID_NODETYPE.
IP_ADAPTER_ADDRESS_DNS_ELIGIBLE | Per-address Flags
IP_ADAPTER_ADDRESS_TRANSIENT | This is constant nxllJwaIpTypes.IP_ADAPTER_ADDRESS_TRANSIENT.
IP_ADAPTER_DDNS_ENABLED | Per-adapter Flags
IP_ADAPTER_DHCP_ENABLED | This is constant nxllJwaIpTypes.IP_ADAPTER_DHCP_ENABLED.
IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG | This is constant nxllJwaIpTypes.IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG.
IP_ADAPTER_NO_MULTICAST | This is constant nxllJwaIpTypes.IP_ADAPTER_NO_MULTICAST.
IP_ADAPTER_RECEIVE_ONLY | This is constant nxllJwaIpTypes.IP_ADAPTER_RECEIVE_ONLY.
IP_ADAPTER_REGISTER_ADAPTER_SUFFIX | This is constant nxllJwaIpTypes.IP_ADAPTER_REGISTER_ADAPTER_SUFFIX.
MAX_ADAPTER_ADDRESS_LENGTH | arb.
MAX_ADAPTER_DESCRIPTION_LENGTH | arb.
MAX_ADAPTER_NAME_LENGTH | arb.
MAX_DOMAIN_NAME_LEN | arb.
MAX_HOSTNAME_LEN | arb.
MAX_SCOPE_ID_LEN | arb.
MIXED_NODETYPE | This is constant nxllJwaIpTypes.MIXED_NODETYPE.
PEER_TO_PEER_NODETYPE | This is constant nxllJwaIpTypes.PEER_TO_PEER_NODETYPE.
ScopeLevelAdmin | This is constant nxllJwaIpTypes.ScopeLevelAdmin.
ScopeLevelGlobal | This is constant nxllJwaIpTypes.ScopeLevelGlobal.
ScopeLevelInterface | Scope levels from RFC 2373 used with ZoneIndices array.
ScopeLevelLink | This is constant nxllJwaIpTypes.ScopeLevelLink.
ScopeLevelOrganization | This is constant nxllJwaIpTypes.ScopeLevelOrganization.
ScopeLevelSite | This is constant nxllJwaIpTypes.ScopeLevelSite.
ScopeLevelSubnet | This is constant nxllJwaIpTypes.ScopeLevelSubnet.
Structs, Records, Enums
Name | Description
_IP_ADAPTER_ADDRESSES | This is record nxllJwaIpTypes._IP_ADAPTER_ADDRESSES.
_IP_ADAPTER_ANYCAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_ANYCAST_ADDRESS.
_IP_ADAPTER_DNS_SERVER_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_DNS_SERVER_ADDRESS.
_IP_ADAPTER_INFO | This is record nxllJwaIpTypes._IP_ADAPTER_INFO.
_IP_ADAPTER_MULTICAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_MULTICAST_ADDRESS.
_IP_ADAPTER_PREFIX | This is record nxllJwaIpTypes._IP_ADAPTER_PREFIX.
_IP_ADAPTER_UNICAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_UNICAST_ADDRESS.
_IP_ADDR_STRING | This is record nxllJwaIpTypes._IP_ADDR_STRING.
_IP_PER_ADAPTER_INFO | This is record nxllJwaIpTypes._IP_PER_ADAPTER_INFO.
FIXED_INFO | This is record nxllJwaIpTypes.FIXED_INFO.
IF_OPER_STATUS | OperStatus values from RFC 2863
IP_ADDRESS_STRING | This is record nxllJwaIpTypes.IP_ADDRESS_STRING.
IP_DAD_STATE | This is record nxllJwaIpTypes.IP_DAD_STATE.
IP_INTERFACE_NAME_INFO | This is record nxllJwaIpTypes.IP_INTERFACE_NAME_INFO.
IP_PREFIX_ORIGIN | The following types require Winsock2.
IP_SUFFIX_ORIGIN | This is record nxllJwaIpTypes.IP_SUFFIX_ORIGIN.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
IP_ADAPTER_ADDRESSES | This is type nxllJwaIpTypes.IP_ADAPTER_ADDRESSES.
IP_ADAPTER_ANYCAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_ANYCAST_ADDRESS.
IP_ADAPTER_DNS_SERVER_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_DNS_SERVER_ADDRESS.
IP_ADAPTER_INFO | This is type nxllJwaIpTypes.IP_ADAPTER_INFO.
IP_ADAPTER_MULTICAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_MULTICAST_ADDRESS.
IP_ADAPTER_PREFIX | This is type nxllJwaIpTypes.IP_ADAPTER_PREFIX.
IP_ADAPTER_UNICAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_UNICAST_ADDRESS.
IP_ADDR_STRING | This is type nxllJwaIpTypes.IP_ADDR_STRING.
IP_MASK_STRING | This is type nxllJwaIpTypes.IP_MASK_STRING.
IP_PER_ADAPTER_INFO | This is type nxllJwaIpTypes.IP_PER_ADAPTER_INFO.
PFIXED_INFO | FIXED_INFO - the set of IP-related information which does not depend on DHCP
PFixedInfo | This is type nxllJwaIpTypes.PFixedInfo.
PIP_ADAPTER_ADDRESSES | This is type nxllJwaIpTypes.PIP_ADAPTER_ADDRESSES.
PIP_ADAPTER_ANYCAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_ANYCAST_ADDRESS.
PIP_ADAPTER_DNS_SERVER_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_DNS_SERVER_ADDRESS.
PIP_ADAPTER_INFO | ADAPTER_INFO - per-adapter information. All IP addresses are stored as strings
PIP_ADAPTER_MULTICAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_MULTICAST_ADDRESS.
PIP_ADAPTER_PREFIX | This is type nxllJwaIpTypes.PIP_ADAPTER_PREFIX.
PIP_ADAPTER_UNICAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_UNICAST_ADDRESS.
PIP_ADDR_STRING | IP_ADDR_STRING - store an IP address with its corresponding subnet mask, both as dotted decimal strings
PIP_ADDRESS_STRING | This is type nxllJwaIpTypes.PIP_ADDRESS_STRING.
PIP_INTERFACE_NAME_INFO | This is type nxllJwaIpTypes.PIP_INTERFACE_NAME_INFO.
PIP_MASK_STRING | IP_ADDRESS_STRING - store an IP address as a dotted decimal string
PIP_PER_ADAPTER_INFO | IP_PER_ADAPTER_INFO - per-adapter IP information such as DNS server list.
PIpAdapterAddresses | This is type nxllJwaIpTypes.PIpAdapterAddresses.
PIpAdapterAnycaseAddress | This is type nxllJwaIpTypes.PIpAdapterAnycaseAddress.
PIpAdapterDnsServerAddress | This is type nxllJwaIpTypes.PIpAdapterDnsServerAddress.
PIpAdapterInfo | This is type nxllJwaIpTypes.PIpAdapterInfo.
PIpAdapterMulticastAddress | This is type nxllJwaIpTypes.PIpAdapterMulticastAddress.
PIpAdapterPrefix | This is type nxllJwaIpTypes.PIpAdapterPrefix.
PIpAdapterUnicastAddress | This is type nxllJwaIpTypes.PIpAdapterUnicastAddress.
PIpAddressString | This is type nxllJwaIpTypes.PIpAddressString.
PIpAddrString | This is type nxllJwaIpTypes.PIpAddrString.
PIpInterfaceNameInfo | This is type nxllJwaIpTypes.PIpInterfaceNameInfo.
PIpPerAdapterInfo | This is type nxllJwaIpTypes.PIpPerAdapterInfo.
SCOPE_LEVEL | This is type nxllJwaIpTypes.SCOPE_LEVEL.
TFixedInfo | This is type nxllJwaIpTypes.TFixedInfo.
TIfOperStatus | This is type nxllJwaIpTypes.TIfOperStatus.
time_t | include // TODO
TIpAdapterAddresses | This is type nxllJwaIpTypes.TIpAdapterAddresses.
TIpAdapterAnycaseAddress | This is type nxllJwaIpTypes.TIpAdapterAnycaseAddress.
TIpAdapterDnsServerAddress | This is type nxllJwaIpTypes.TIpAdapterDnsServerAddress.
TIpAdapterInfo | This is type nxllJwaIpTypes.TIpAdapterInfo.
TIpAdapterMulticastAddress | This is type nxllJwaIpTypes.TIpAdapterMulticastAddress.
TIpAdapterPrefix | This is type nxllJwaIpTypes.TIpAdapterPrefix.
TIpAdapterUnicastAddress | This is type nxllJwaIpTypes.TIpAdapterUnicastAddress.
TIpAddressString | This is type nxllJwaIpTypes.TIpAddressString.
TIpAddrString | This is type nxllJwaIpTypes.TIpAddrString.
TIpDadState | This is type nxllJwaIpTypes.TIpDadState.
TIpInterfaceNameInfo | This is type nxllJwaIpTypes.TIpInterfaceNameInfo.
TIpPerAdapterInfo | This is type nxllJwaIpTypes.TIpPerAdapterInfo.
TIpPrefixOrigin | This is type nxllJwaIpTypes.TIpPrefixOrigin.
TIpSuffixOrigin | This is type nxllJwaIpTypes.TIpSuffixOrigin.
TScopeLevel | This is type nxllJwaIpTypes.TScopeLevel.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllJwaIpTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
IF_OPER_STATUS | OperStatus values from RFC 2863
IP_DAD_STATE | This is record nxllJwaIpTypes.IP_DAD_STATE.
IP_PREFIX_ORIGIN | The following types require Winsock2.
IP_SUFFIX_ORIGIN | This is record nxllJwaIpTypes.IP_SUFFIX_ORIGIN.
Namespace

nxllJwaIpTypes Namespace

Records
Name | Description
_IP_ADAPTER_ADDRESSES | This is record nxllJwaIpTypes._IP_ADAPTER_ADDRESSES.
_IP_ADAPTER_ANYCAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_ANYCAST_ADDRESS.
_IP_ADAPTER_DNS_SERVER_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_DNS_SERVER_ADDRESS.
_IP_ADAPTER_INFO | This is record nxllJwaIpTypes._IP_ADAPTER_INFO.
_IP_ADAPTER_MULTICAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_MULTICAST_ADDRESS.
_IP_ADAPTER_PREFIX | This is record nxllJwaIpTypes._IP_ADAPTER_PREFIX.
_IP_ADAPTER_UNICAST_ADDRESS | This is record nxllJwaIpTypes._IP_ADAPTER_UNICAST_ADDRESS.
_IP_ADDR_STRING | This is record nxllJwaIpTypes._IP_ADDR_STRING.
_IP_PER_ADAPTER_INFO | This is record nxllJwaIpTypes._IP_PER_ADAPTER_INFO.
FIXED_INFO | This is record nxllJwaIpTypes.FIXED_INFO.
IP_ADDRESS_STRING | This is record nxllJwaIpTypes.IP_ADDRESS_STRING.
IP_INTERFACE_NAME_INFO | This is record nxllJwaIpTypes.IP_INTERFACE_NAME_INFO.
Links
Enumerations, nxllJwaIpTypes Namespace, Legend, Records


nxllJwaIpTypes._IP_ADAPTER_ADDRESSES Record

nxllJwaIpTypes._IP_ADAPTER_ADDRESSES Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_ADDRESSES = record
  Union: record;
  Next: PIP_ADAPTER_ADDRESSES;
  AdapterName: PAnsiChar;
  FirstUnicastAddress: PIP_ADAPTER_UNICAST_ADDRESS;
  FirstAnycastAddress: PIP_ADAPTER_ANYCAST_ADDRESS;
  FirstMulticastAddress: PIP_ADAPTER_MULTICAST_ADDRESS;
  FirstDnsServerAddress: PIP_ADAPTER_DNS_SERVER_ADDRESS;
  DnsSuffix: PWCHAR;
  Description: PWCHAR;
  FriendlyName: PWCHAR;
  PhysicalAddress: array [0..MAX_ADAPTER_ADDRESS_LENGTH - 1] of BYTE;
  PhysicalAddressLength: DWORD;
  Flags: DWORD;
  Mtu: DWORD;
  IfType: DWORD;
  OperStatus: IF_OPER_STATUS;
  Ipv6IfIndex: DWORD;
  ZoneIndices: array [0..15] of DWORD;
  FirstPrefix: PIP_ADAPTER_PREFIX;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_ADDRESSES.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_ANYCAST_ADDRESS Record

nxllJwaIpTypes._IP_ADAPTER_ANYCAST_ADDRESS Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_ANYCAST_ADDRESS = record
  Union: record;
  Next: PIP_ADAPTER_ANYCAST_ADDRESS;
  Address: SOCKET_ADDRESS;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_ANYCAST_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_DNS_SERVER_ADDRESS Record

nxllJwaIpTypes._IP_ADAPTER_DNS_SERVER_ADDRESS Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_DNS_SERVER_ADDRESS = record
  Union: record;
  Next: PIP_ADAPTER_DNS_SERVER_ADDRESS;
  Address: SOCKET_ADDRESS;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_DNS_SERVER_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_INFO Record

nxllJwaIpTypes._IP_ADAPTER_INFO Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_INFO = record
  Next: PIP_ADAPTER_INFO;
  ComboIndex: DWORD;
  AdapterName: array [0..MAX_ADAPTER_NAME_LENGTH + 3] of AnsiChar;
  Description: array [0..MAX_ADAPTER_DESCRIPTION_LENGTH + 3] of AnsiChar;
  AddressLength: UINT;
  Address: array [0..MAX_ADAPTER_ADDRESS_LENGTH - 1] of BYTE;
  Index: DWORD;
  Type_: UINT;
  DhcpEnabled: UINT;
  CurrentIpAddress: PIP_ADDR_STRING;
  IpAddressList: IP_ADDR_STRING;
  GatewayList: IP_ADDR_STRING;
  DhcpServer: IP_ADDR_STRING;
  HaveWins: BOOL;
  PrimaryWinsServer: IP_ADDR_STRING;
  SecondaryWinsServer: IP_ADDR_STRING;
  LeaseObtained: time_t;
  LeaseExpires: time_t;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_MULTICAST_ADDRESS Record

nxllJwaIpTypes._IP_ADAPTER_MULTICAST_ADDRESS Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_MULTICAST_ADDRESS = record
  Union: record;
  Next: PIP_ADAPTER_MULTICAST_ADDRESS;
  Address: SOCKET_ADDRESS;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_MULTICAST_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_PREFIX Record

nxllJwaIpTypes._IP_ADAPTER_PREFIX Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_PREFIX = record
  Union: record;
  Next: PIP_ADAPTER_PREFIX;
  Address: SOCKET_ADDRESS;
  PrefixLength: ULONG;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_PREFIX.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADAPTER_UNICAST_ADDRESS Record

nxllJwaIpTypes._IP_ADAPTER_UNICAST_ADDRESS Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADAPTER_UNICAST_ADDRESS = record
  Union: record;
  Next: PIP_ADAPTER_UNICAST_ADDRESS;
  Address: SOCKET_ADDRESS;
  PrefixOrigin: IP_PREFIX_ORIGIN;
  SuffixOrigin: IP_SUFFIX_ORIGIN;
  DadState: IP_DAD_STATE;
  ValidLifetime: ULONG;
  PreferredLifetime: ULONG;
  LeaseLifetime: ULONG;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADAPTER_UNICAST_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_ADDR_STRING Record

nxllJwaIpTypes._IP_ADDR_STRING Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_ADDR_STRING = record
  Next: PIP_ADDR_STRING;
  IpAddress: IP_ADDRESS_STRING;
  IpMask: IP_MASK_STRING;
  Context: DWORD;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_ADDR_STRING.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes._IP_PER_ADAPTER_INFO Record

nxllJwaIpTypes._IP_PER_ADAPTER_INFO Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
_IP_PER_ADAPTER_INFO = record
  AutoconfigEnabled: UINT;
  AutoconfigActive: UINT;
  CurrentDnsServer: PIP_ADDR_STRING;
  DnsServerList: IP_ADDR_STRING;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes._IP_PER_ADAPTER_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.FIXED_INFO Record

nxllJwaIpTypes.FIXED_INFO Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
FIXED_INFO = record
  HostName: array [0..MAX_HOSTNAME_LEN + 3] of AnsiChar;
  DomainName: array[0..MAX_DOMAIN_NAME_LEN + 3] of AnsiChar;
  CurrentDnsServer: PIP_ADDR_STRING;
  DnsServerList: IP_ADDR_STRING;
  NodeType: UINT;
  ScopeId: array [0..MAX_SCOPE_ID_LEN + 3] of AnsiChar;
  EnableRouting: UINT;
  EnableProxy: UINT;
  EnableDns: UINT;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes.FIXED_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IF_OPER_STATUS Enumeration

nxllJwaIpTypes.IF_OPER_STATUS Enumeration
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IF_OPER_STATUS = ( IfOperStatusUp, IfOperStatusDown, IfOperStatusTesting, IfOperStatusUnknown, IfOperStatusDormant, IfOperStatusNotPresent, IfOperStatusLowerLayerDown );
File

nxllJwaIpTypes

Description

OperStatus values from RFC 2863

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IP_ADDRESS_STRING Record

nxllJwaIpTypes.IP_ADDRESS_STRING Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_ADDRESS_STRING = record
  S: array [0..15] of AnsiChar;
end;
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes.IP_ADDRESS_STRING.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IP_DAD_STATE Enumeration

nxllJwaIpTypes.IP_DAD_STATE Enumeration
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_DAD_STATE = ( IpDadStateInvalid, IpDadStateTentative, IpDadStateDuplicate, IpDadStateDeprecated, IpDadStatePreferred );
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes.IP_DAD_STATE.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IP_INTERFACE_NAME_INFO Record

nxllJwaIpTypes.IP_INTERFACE_NAME_INFO Record
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_INTERFACE_NAME_INFO = record
  Index: ULONG;
  MediaType: ULONG;
  ConnectionType: UCHAR;
  AccessType: UCHAR;
  DeviceGuid: TGUID;
  InterfaceGuid: TGUID;
end;
File

nxllJwaIpTypes

Members
Members | Description
Index: ULONG; | Interface Index
MediaType: ULONG; | Interface Types - see ipifcons.h
DeviceGuid: TGUID; | Device GUID is the guid of the device that IP exposes
InterfaceGuid: TGUID; | Interface GUID, if not GUID_NULL is the GUID for the interface mapped to the device.
Description

This is record nxllJwaIpTypes.IP_INTERFACE_NAME_INFO.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IP_PREFIX_ORIGIN Enumeration

nxllJwaIpTypes.IP_PREFIX_ORIGIN Enumeration
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_PREFIX_ORIGIN = ( IpPrefixOriginOther, IpPrefixOriginManual, IpPrefixOriginWellKnown, IpPrefixOriginDhcp, IpPrefixOriginRouterAdvertisement );
File

nxllJwaIpTypes

Description

The following types require Winsock2.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


nxllJwaIpTypes.IP_SUFFIX_ORIGIN Enumeration

nxllJwaIpTypes.IP_SUFFIX_ORIGIN Enumeration
nxllJwaIpTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
IP_SUFFIX_ORIGIN = ( IpSuffixOriginOther, IpSuffixOriginManual, IpSuffixOriginWellKnown, IpSuffixOriginDhcp, IpSuffixOriginLinkLayerAddress, IpSuffixOriginRandom );
File

nxllJwaIpTypes

Description

This is record nxllJwaIpTypes.IP_SUFFIX_ORIGIN.

Group

Structs, Records, Enums

Links
nxllJwaIpTypes, Structs, Records, Enums


Types

Types
nxllJwaIpTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaIpTypes Namespace

Types
Name | Description
IP_ADAPTER_ADDRESSES | This is type nxllJwaIpTypes.IP_ADAPTER_ADDRESSES.
IP_ADAPTER_ANYCAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_ANYCAST_ADDRESS.
IP_ADAPTER_DNS_SERVER_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_DNS_SERVER_ADDRESS.
IP_ADAPTER_INFO | This is type nxllJwaIpTypes.IP_ADAPTER_INFO.
IP_ADAPTER_MULTICAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_MULTICAST_ADDRESS.
IP_ADAPTER_PREFIX | This is type nxllJwaIpTypes.IP_ADAPTER_PREFIX.
IP_ADAPTER_UNICAST_ADDRESS | This is type nxllJwaIpTypes.IP_ADAPTER_UNICAST_ADDRESS.
IP_ADDR_STRING | This is type nxllJwaIpTypes.IP_ADDR_STRING.
IP_MASK_STRING | This is type nxllJwaIpTypes.IP_MASK_STRING.
IP_PER_ADAPTER_INFO | This is type nxllJwaIpTypes.IP_PER_ADAPTER_INFO.
PFIXED_INFO | FIXED_INFO - the set of IP-related information which does not depend on DHCP
PFixedInfo | This is type nxllJwaIpTypes.PFixedInfo.
PIP_ADAPTER_ADDRESSES | This is type nxllJwaIpTypes.PIP_ADAPTER_ADDRESSES.
PIP_ADAPTER_ANYCAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_ANYCAST_ADDRESS.
PIP_ADAPTER_DNS_SERVER_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_DNS_SERVER_ADDRESS.
PIP_ADAPTER_INFO | ADAPTER_INFO - per-adapter information. All IP addresses are stored as strings
PIP_ADAPTER_MULTICAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_MULTICAST_ADDRESS.
PIP_ADAPTER_PREFIX | This is type nxllJwaIpTypes.PIP_ADAPTER_PREFIX.
PIP_ADAPTER_UNICAST_ADDRESS | This is type nxllJwaIpTypes.PIP_ADAPTER_UNICAST_ADDRESS.
PIP_ADDR_STRING | IP_ADDR_STRING - store an IP address with its corresponding subnet mask, both as dotted decimal strings
PIP_ADDRESS_STRING | This is type nxllJwaIpTypes.PIP_ADDRESS_STRING.
PIP_INTERFACE_NAME_INFO | This is type nxllJwaIpTypes.PIP_INTERFACE_NAME_INFO.
PIP_MASK_STRING | IP_ADDRESS_STRING - store an IP address as a dotted decimal string
PIP_PER_ADAPTER_INFO | IP_PER_ADAPTER_INFO - per-adapter IP information such as DNS server list.
PIpAdapterAddresses | This is type nxllJwaIpTypes.PIpAdapterAddresses.
PIpAdapterAnycaseAddress | This is type nxllJwaIpTypes.PIpAdapterAnycaseAddress.
PIpAdapterDnsServerAddress | This is type nxllJwaIpTypes.PIpAdapterDnsServerAddress.
PIpAdapterInfo | This is type nxllJwaIpTypes.PIpAdapterInfo.
PIpAdapterMulticastAddress | This is type nxllJwaIpTypes.PIpAdapterMulticastAddress.
PIpAdapterPrefix | This is type nxllJwaIpTypes.PIpAdapterPrefix.
PIpAdapterUnicastAddress | This is type nxllJwaIpTypes.PIpAdapterUnicastAddress.
PIpAddressString | This is type nxllJwaIpTypes.PIpAddressString.
PIpAddrString | This is type nxllJwaIpTypes.PIpAddrString.
PIpInterfaceNameInfo | This is type nxllJwaIpTypes.PIpInterfaceNameInfo.
PIpPerAdapterInfo | This is type nxllJwaIpTypes.PIpPerAdapterInfo.
SCOPE_LEVEL | This is type nxllJwaIpTypes.SCOPE_LEVEL.
TFixedInfo | This is type nxllJwaIpTypes.TFixedInfo.
TIfOperStatus | This is type nxllJwaIpTypes.TIfOperStatus.
time_t | include // TODO
TIpAdapterAddresses | This is type nxllJwaIpTypes.TIpAdapterAddresses.
TIpAdapterAnycaseAddress | This is type nxllJwaIpTypes.TIpAdapterAnycaseAddress.
TIpAdapterDnsServerAddress | This is type nxllJwaIpTypes.TIpAdapterDnsServerAddress.
TIpAdapterInfo | This is type nxllJwaIpTypes.TIpAdapterInfo.
TIpAdapterMulticastAddress | This is type nxllJwaIpTypes.TIpAdapterMulticastAddress.
TIpAdapterPrefix | This is type nxllJwaIpTypes.TIpAdapterPrefix.
TIpAdapterUnicastAddress | This is type nxllJwaIpTypes.TIpAdapterUnicastAddress.
TIpAddressString | This is type nxllJwaIpTypes.TIpAddressString.
TIpAddrString | This is type nxllJwaIpTypes.TIpAddrString.
TIpDadState | This is type nxllJwaIpTypes.TIpDadState.
TIpInterfaceNameInfo | This is type nxllJwaIpTypes.TIpInterfaceNameInfo.
TIpPerAdapterInfo | This is type nxllJwaIpTypes.TIpPerAdapterInfo.
TIpPrefixOrigin | This is type nxllJwaIpTypes.TIpPrefixOrigin.
TIpSuffixOrigin | This is type nxllJwaIpTypes.TIpSuffixOrigin.
TScopeLevel | This is type nxllJwaIpTypes.TScopeLevel.
Links
nxllJwaIpTypes Namespace, Types


nxllJwaIpTypes.IP_ADAPTER_ADDRESSES Type

nxllJwaIpTypes.IP_ADAPTER_ADDRESSES Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_ADDRESSES = _IP_ADAPTER_ADDRESSES;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_ADDRESSES.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_ANYCAST_ADDRESS Type

nxllJwaIpTypes.IP_ADAPTER_ANYCAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_ANYCAST_ADDRESS = _IP_ADAPTER_ANYCAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_ANYCAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_DNS_SERVER_ADDRESS Type

nxllJwaIpTypes.IP_ADAPTER_DNS_SERVER_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_DNS_SERVER_ADDRESS = _IP_ADAPTER_DNS_SERVER_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_DNS_SERVER_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_INFO Type

nxllJwaIpTypes.IP_ADAPTER_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_INFO = _IP_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_INFO.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_MULTICAST_ADDRESS Type

nxllJwaIpTypes.IP_ADAPTER_MULTICAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_MULTICAST_ADDRESS = _IP_ADAPTER_MULTICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_MULTICAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_PREFIX Type

nxllJwaIpTypes.IP_ADAPTER_PREFIX Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_PREFIX = _IP_ADAPTER_PREFIX;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_PREFIX.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADAPTER_UNICAST_ADDRESS Type

nxllJwaIpTypes.IP_ADAPTER_UNICAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADAPTER_UNICAST_ADDRESS = _IP_ADAPTER_UNICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADAPTER_UNICAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_ADDR_STRING Type

nxllJwaIpTypes.IP_ADDR_STRING Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_ADDR_STRING = _IP_ADDR_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_ADDR_STRING.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_MASK_STRING Type

nxllJwaIpTypes.IP_MASK_STRING Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_MASK_STRING = IP_ADDRESS_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_MASK_STRING.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.IP_PER_ADAPTER_INFO Type

nxllJwaIpTypes.IP_PER_ADAPTER_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
IP_PER_ADAPTER_INFO = _IP_PER_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.IP_PER_ADAPTER_INFO.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PFIXED_INFO Type

nxllJwaIpTypes.PFIXED_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PFIXED_INFO = ^FIXED_INFO;
File

nxllJwaIpTypes

Description

FIXED_INFO - the set of IP-related information which does not depend on DHCP

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PFixedInfo Type

nxllJwaIpTypes.PFixedInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PFixedInfo = PFIXED_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PFixedInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_ADDRESSES Type

nxllJwaIpTypes.PIP_ADAPTER_ADDRESSES Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_ADDRESSES = ^_IP_ADAPTER_ADDRESSES;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_ADDRESSES.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_ANYCAST_ADDRESS Type

nxllJwaIpTypes.PIP_ADAPTER_ANYCAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_ANYCAST_ADDRESS = ^_IP_ADAPTER_ANYCAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_ANYCAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_DNS_SERVER_ADDRESS Type

nxllJwaIpTypes.PIP_ADAPTER_DNS_SERVER_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_DNS_SERVER_ADDRESS = ^_IP_ADAPTER_DNS_SERVER_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_DNS_SERVER_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_INFO Type

nxllJwaIpTypes.PIP_ADAPTER_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_INFO = ^IP_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

ADAPTER_INFO - per-adapter information. All IP addresses are stored as strings

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_MULTICAST_ADDRESS Type

nxllJwaIpTypes.PIP_ADAPTER_MULTICAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_MULTICAST_ADDRESS = ^_IP_ADAPTER_MULTICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_MULTICAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_PREFIX Type

nxllJwaIpTypes.PIP_ADAPTER_PREFIX Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_PREFIX = ^IP_ADAPTER_PREFIX;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_PREFIX.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADAPTER_UNICAST_ADDRESS Type

nxllJwaIpTypes.PIP_ADAPTER_UNICAST_ADDRESS Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADAPTER_UNICAST_ADDRESS = ^_IP_ADAPTER_UNICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADAPTER_UNICAST_ADDRESS.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADDR_STRING Type

nxllJwaIpTypes.PIP_ADDR_STRING Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADDR_STRING = ^IP_ADDR_STRING;
File

nxllJwaIpTypes

Description

IP_ADDR_STRING - store an IP address with its corresponding subnet mask, both as dotted decimal strings

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_ADDRESS_STRING Type

nxllJwaIpTypes.PIP_ADDRESS_STRING Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_ADDRESS_STRING = ^IP_ADDRESS_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_ADDRESS_STRING.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_INTERFACE_NAME_INFO Type

nxllJwaIpTypes.PIP_INTERFACE_NAME_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_INTERFACE_NAME_INFO = ^IP_INTERFACE_NAME_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIP_INTERFACE_NAME_INFO.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_MASK_STRING Type

nxllJwaIpTypes.PIP_MASK_STRING Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_MASK_STRING = ^IP_MASK_STRING;
File

nxllJwaIpTypes

Description

IP_ADDRESS_STRING - store an IP address as a dotted decimal string

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIP_PER_ADAPTER_INFO Type

nxllJwaIpTypes.PIP_PER_ADAPTER_INFO Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIP_PER_ADAPTER_INFO = ^IP_PER_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

IP_PER_ADAPTER_INFO - per-adapter IP information such as DNS server list.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterAddresses Type

nxllJwaIpTypes.PIpAdapterAddresses Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterAddresses = PIP_ADAPTER_ADDRESSES;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterAddresses.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterAnycaseAddress Type

nxllJwaIpTypes.PIpAdapterAnycaseAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterAnycaseAddress = PIP_ADAPTER_ANYCAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterAnycaseAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterDnsServerAddress Type

nxllJwaIpTypes.PIpAdapterDnsServerAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterDnsServerAddress = PIP_ADAPTER_DNS_SERVER_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterDnsServerAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterInfo Type

nxllJwaIpTypes.PIpAdapterInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterInfo = PIP_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterMulticastAddress Type

nxllJwaIpTypes.PIpAdapterMulticastAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterMulticastAddress = PIP_ADAPTER_MULTICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterMulticastAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterPrefix Type

nxllJwaIpTypes.PIpAdapterPrefix Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterPrefix = PIP_ADAPTER_PREFIX;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterPrefix.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAdapterUnicastAddress Type

nxllJwaIpTypes.PIpAdapterUnicastAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAdapterUnicastAddress = PIP_ADAPTER_UNICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAdapterUnicastAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAddressString Type

nxllJwaIpTypes.PIpAddressString Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAddressString = PIP_MASK_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAddressString.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpAddrString Type

nxllJwaIpTypes.PIpAddrString Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpAddrString = PIP_ADDR_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpAddrString.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpInterfaceNameInfo Type

nxllJwaIpTypes.PIpInterfaceNameInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpInterfaceNameInfo = ^IP_INTERFACE_NAME_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpInterfaceNameInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.PIpPerAdapterInfo Type

nxllJwaIpTypes.PIpPerAdapterInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
PIpPerAdapterInfo = PIP_PER_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.PIpPerAdapterInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.SCOPE_LEVEL Type

nxllJwaIpTypes.SCOPE_LEVEL Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
SCOPE_LEVEL = DWORD;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.SCOPE_LEVEL.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TFixedInfo Type

nxllJwaIpTypes.TFixedInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TFixedInfo = FIXED_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TFixedInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIfOperStatus Type

nxllJwaIpTypes.TIfOperStatus Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIfOperStatus = IF_OPER_STATUS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIfOperStatus.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.time_t Type

nxllJwaIpTypes.time_t Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
time_t = Longint;
File

nxllJwaIpTypes

Description

include // TODO

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterAddresses Type

nxllJwaIpTypes.TIpAdapterAddresses Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterAddresses = IP_ADAPTER_ADDRESSES;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterAddresses.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterAnycaseAddress Type

nxllJwaIpTypes.TIpAdapterAnycaseAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterAnycaseAddress = IP_ADAPTER_ANYCAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterAnycaseAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterDnsServerAddress Type

nxllJwaIpTypes.TIpAdapterDnsServerAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterDnsServerAddress = IP_ADAPTER_DNS_SERVER_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterDnsServerAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterInfo Type

nxllJwaIpTypes.TIpAdapterInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterInfo = IP_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterMulticastAddress Type

nxllJwaIpTypes.TIpAdapterMulticastAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterMulticastAddress = IP_ADAPTER_MULTICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterMulticastAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterPrefix Type

nxllJwaIpTypes.TIpAdapterPrefix Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterPrefix = IP_ADAPTER_PREFIX;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterPrefix.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAdapterUnicastAddress Type

nxllJwaIpTypes.TIpAdapterUnicastAddress Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAdapterUnicastAddress = IP_ADAPTER_UNICAST_ADDRESS;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAdapterUnicastAddress.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAddressString Type

nxllJwaIpTypes.TIpAddressString Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAddressString = IP_ADDRESS_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAddressString.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpAddrString Type

nxllJwaIpTypes.TIpAddrString Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpAddrString = IP_ADDR_STRING;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpAddrString.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpDadState Type

nxllJwaIpTypes.TIpDadState Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpDadState = IP_DAD_STATE;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpDadState.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpInterfaceNameInfo Type

nxllJwaIpTypes.TIpInterfaceNameInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpInterfaceNameInfo = IP_INTERFACE_NAME_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpInterfaceNameInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpPerAdapterInfo Type

nxllJwaIpTypes.TIpPerAdapterInfo Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpPerAdapterInfo = IP_PER_ADAPTER_INFO;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpPerAdapterInfo.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpPrefixOrigin Type

nxllJwaIpTypes.TIpPrefixOrigin Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpPrefixOrigin = IP_PREFIX_ORIGIN;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpPrefixOrigin.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TIpSuffixOrigin Type

nxllJwaIpTypes.TIpSuffixOrigin Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TIpSuffixOrigin = IP_SUFFIX_ORIGIN;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TIpSuffixOrigin.

Group

Types

Links
nxllJwaIpTypes, Types


nxllJwaIpTypes.TScopeLevel Type

nxllJwaIpTypes.TScopeLevel Type
nxllJwaIpTypes Types Send Feedback
Syntax
Delphi
TScopeLevel = SCOPE_LEVEL;
File

nxllJwaIpTypes

Description

This is type nxllJwaIpTypes.TScopeLevel.

Group

Types

Links
nxllJwaIpTypes, Types


Constants

Constants
Constants nxllJwaIpTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
BROADCAST_NODETYPE | Node Type
DEFAULT_MINIMUM_ENTITIES | arb.
GAA_FLAG_INCLUDE_PREFIX | This is constant nxllJwaIpTypes.GAA_FLAG_INCLUDE_PREFIX.
GAA_FLAG_SKIP_ANYCAST | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_ANYCAST.
GAA_FLAG_SKIP_DNS_SERVER | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_DNS_SERVER.
GAA_FLAG_SKIP_FRIENDLY_NAME | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_FRIENDLY_NAME.
GAA_FLAG_SKIP_MULTICAST | This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_MULTICAST.
GAA_FLAG_SKIP_UNICAST | Flags used as argument to GetAdaptersAddresses(). "SKIP" flags are added when the default is to include the information. "INCLUDE" flags are added when the default is to skip the information.
HYBRID_NODETYPE | This is constant nxllJwaIpTypes.HYBRID_NODETYPE.
IP_ADAPTER_ADDRESS_DNS_ELIGIBLE | Per-address Flags
IP_ADAPTER_ADDRESS_TRANSIENT | This is constant nxllJwaIpTypes.IP_ADAPTER_ADDRESS_TRANSIENT.
IP_ADAPTER_DDNS_ENABLED | Per-adapter Flags
IP_ADAPTER_DHCP_ENABLED | This is constant nxllJwaIpTypes.IP_ADAPTER_DHCP_ENABLED.
IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG | This is constant nxllJwaIpTypes.IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG.
IP_ADAPTER_NO_MULTICAST | This is constant nxllJwaIpTypes.IP_ADAPTER_NO_MULTICAST.
IP_ADAPTER_RECEIVE_ONLY | This is constant nxllJwaIpTypes.IP_ADAPTER_RECEIVE_ONLY.
IP_ADAPTER_REGISTER_ADAPTER_SUFFIX | This is constant nxllJwaIpTypes.IP_ADAPTER_REGISTER_ADAPTER_SUFFIX.
MAX_ADAPTER_ADDRESS_LENGTH | arb.
MAX_ADAPTER_DESCRIPTION_LENGTH | arb.
MAX_ADAPTER_NAME_LENGTH | arb.
MAX_DOMAIN_NAME_LEN | arb.
MAX_HOSTNAME_LEN | arb.
MAX_SCOPE_ID_LEN | arb.
MIXED_NODETYPE | This is constant nxllJwaIpTypes.MIXED_NODETYPE.
PEER_TO_PEER_NODETYPE | This is constant nxllJwaIpTypes.PEER_TO_PEER_NODETYPE.
ScopeLevelAdmin | This is constant nxllJwaIpTypes.ScopeLevelAdmin.
ScopeLevelGlobal | This is constant nxllJwaIpTypes.ScopeLevelGlobal.
ScopeLevelInterface | Scope levels from RFC 2373 used with ZoneIndices array.
ScopeLevelLink | This is constant nxllJwaIpTypes.ScopeLevelLink.
ScopeLevelOrganization | This is constant nxllJwaIpTypes.ScopeLevelOrganization.
ScopeLevelSite | This is constant nxllJwaIpTypes.ScopeLevelSite.
ScopeLevelSubnet | This is constant nxllJwaIpTypes.ScopeLevelSubnet.
Namespace

nxllJwaIpTypes Namespace

Links
Constants, nxllJwaIpTypes Namespace


nxllJwaIpTypes.BROADCAST_NODETYPE Constant

nxllJwaIpTypes.BROADCAST_NODETYPE Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
BROADCAST_NODETYPE = 1;
File

nxllJwaIpTypes

Description

Node Type

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.DEFAULT_MINIMUM_ENTITIES Constant

nxllJwaIpTypes.DEFAULT_MINIMUM_ENTITIES Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
DEFAULT_MINIMUM_ENTITIES = 32;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_INCLUDE_PREFIX Constant

nxllJwaIpTypes.GAA_FLAG_INCLUDE_PREFIX Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_INCLUDE_PREFIX = $0010;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.GAA_FLAG_INCLUDE_PREFIX.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_SKIP_ANYCAST Constant

nxllJwaIpTypes.GAA_FLAG_SKIP_ANYCAST Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_SKIP_ANYCAST = $0002;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_ANYCAST.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_SKIP_DNS_SERVER Constant

nxllJwaIpTypes.GAA_FLAG_SKIP_DNS_SERVER Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_SKIP_DNS_SERVER = $0008;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_DNS_SERVER.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_SKIP_FRIENDLY_NAME Constant

nxllJwaIpTypes.GAA_FLAG_SKIP_FRIENDLY_NAME Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_SKIP_FRIENDLY_NAME = $0020;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_FRIENDLY_NAME.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_SKIP_MULTICAST Constant

nxllJwaIpTypes.GAA_FLAG_SKIP_MULTICAST Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_SKIP_MULTICAST = $0004;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.GAA_FLAG_SKIP_MULTICAST.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.GAA_FLAG_SKIP_UNICAST Constant

nxllJwaIpTypes.GAA_FLAG_SKIP_UNICAST Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
GAA_FLAG_SKIP_UNICAST = $0001;
File

nxllJwaIpTypes

Description

Flags used as argument to GetAdaptersAddresses(). "SKIP" flags are added when the default is to include the information. "INCLUDE" flags are added when the default is to skip the information.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.HYBRID_NODETYPE Constant

nxllJwaIpTypes.HYBRID_NODETYPE Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
HYBRID_NODETYPE = 8;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.HYBRID_NODETYPE.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_ADDRESS_DNS_ELIGIBLE Constant

nxllJwaIpTypes.IP_ADAPTER_ADDRESS_DNS_ELIGIBLE Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_ADDRESS_DNS_ELIGIBLE = $01;
File

nxllJwaIpTypes

Description

Per-address Flags

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_ADDRESS_TRANSIENT Constant

nxllJwaIpTypes.IP_ADAPTER_ADDRESS_TRANSIENT Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_ADDRESS_TRANSIENT = $02;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_ADDRESS_TRANSIENT.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_DDNS_ENABLED Constant

nxllJwaIpTypes.IP_ADAPTER_DDNS_ENABLED Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_DDNS_ENABLED = $01;
File

nxllJwaIpTypes

Description

Per-adapter Flags

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_DHCP_ENABLED Constant

nxllJwaIpTypes.IP_ADAPTER_DHCP_ENABLED Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_DHCP_ENABLED = $04;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_DHCP_ENABLED.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG Constant

nxllJwaIpTypes.IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG = $20;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_IPV6_OTHER_STATEFUL_CONFIG.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_NO_MULTICAST Constant

nxllJwaIpTypes.IP_ADAPTER_NO_MULTICAST Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_NO_MULTICAST = $10;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_NO_MULTICAST.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_RECEIVE_ONLY Constant

nxllJwaIpTypes.IP_ADAPTER_RECEIVE_ONLY Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_RECEIVE_ONLY = $08;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_RECEIVE_ONLY.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.IP_ADAPTER_REGISTER_ADAPTER_SUFFIX Constant

nxllJwaIpTypes.IP_ADAPTER_REGISTER_ADAPTER_SUFFIX Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
IP_ADAPTER_REGISTER_ADAPTER_SUFFIX = $02;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.IP_ADAPTER_REGISTER_ADAPTER_SUFFIX.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_ADAPTER_ADDRESS_LENGTH Constant

nxllJwaIpTypes.MAX_ADAPTER_ADDRESS_LENGTH Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_ADAPTER_ADDRESS_LENGTH = 8;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_ADAPTER_DESCRIPTION_LENGTH Constant

nxllJwaIpTypes.MAX_ADAPTER_DESCRIPTION_LENGTH Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_ADAPTER_DESCRIPTION_LENGTH = 128;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_ADAPTER_NAME_LENGTH Constant

nxllJwaIpTypes.MAX_ADAPTER_NAME_LENGTH Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_ADAPTER_NAME_LENGTH = 256;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_DOMAIN_NAME_LEN Constant

nxllJwaIpTypes.MAX_DOMAIN_NAME_LEN Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_DOMAIN_NAME_LEN = 128;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_HOSTNAME_LEN Constant

nxllJwaIpTypes.MAX_HOSTNAME_LEN Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_HOSTNAME_LEN = 128;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MAX_SCOPE_ID_LEN Constant

nxllJwaIpTypes.MAX_SCOPE_ID_LEN Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MAX_SCOPE_ID_LEN = 256;
File

nxllJwaIpTypes

Description

arb.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.MIXED_NODETYPE Constant

nxllJwaIpTypes.MIXED_NODETYPE Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
MIXED_NODETYPE = 4;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.MIXED_NODETYPE.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.PEER_TO_PEER_NODETYPE Constant

nxllJwaIpTypes.PEER_TO_PEER_NODETYPE Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
PEER_TO_PEER_NODETYPE = 2;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.PEER_TO_PEER_NODETYPE.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelAdmin Constant

nxllJwaIpTypes.ScopeLevelAdmin Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelAdmin = 4;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelAdmin.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelGlobal Constant

nxllJwaIpTypes.ScopeLevelGlobal Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelGlobal = 14;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelGlobal.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelInterface Constant

nxllJwaIpTypes.ScopeLevelInterface Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelInterface = 1;
File

nxllJwaIpTypes

Description

Scope levels from RFC 2373 used with ZoneIndices array.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelLink Constant

nxllJwaIpTypes.ScopeLevelLink Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelLink = 2;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelLink.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelOrganization Constant

nxllJwaIpTypes.ScopeLevelOrganization Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelOrganization = 8;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelOrganization.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelSite Constant

nxllJwaIpTypes.ScopeLevelSite Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelSite = 5;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelSite.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaIpTypes.ScopeLevelSubnet Constant

nxllJwaIpTypes.ScopeLevelSubnet Constant
nxllJwaIpTypes Constants Send Feedback
Syntax
Delphi
ScopeLevelSubnet = 3;
File

nxllJwaIpTypes

Description

This is constant nxllJwaIpTypes.ScopeLevelSubnet.

Group

Constants

Links
nxllJwaIpTypes, Constants


nxllJwaQos Namespace

nxllJwaQos Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllJwaQos.

Constants
Name | Description
POSITIVE_INFINITY_RATE | define a value that can be used for the PeakBandwidth, which will map into positive infinity when the FLOWSPEC is converted into IntServ floating point format. We can't use (-1) because that value was previously defined to mean "select the default".
QOS_GENERAL_ID_BASE | general QOS objects start at this offset from the base and have a range of 1000
QOS_NOT_SPECIFIED | this value can be used in the FLOWSPEC structure to instruct the Rsvp Service provider to derive the appropriate default value for the parameter. Note that not all values in the FLOWSPEC structure can be defaults. In the ReceivingFlowspec, all parameters can be defaulted except the ServiceType. In the SendingFlowspec, the MaxSduSize and MinimumPolicedSize can be defaulted. Other defaults may be possible. Refer to the appropriate documentation.
QOS_OBJECT_DESTADDR | QOS_DestAddr structure (defined in qossp.h)
QOS_OBJECT_END_OF_LIST | QOS_End_of_list structure passed
QOS_OBJECT_SD_MODE | QOS_ShapeDiscard structure passed
QOS_OBJECT_SHAPING_RATE | QOS_ShapingRate structure
SERVICE_BESTEFFORT | The usage of these is currently not supported.
SERVICE_CONTROLLEDLOAD | This is constant nxllJwaQos.SERVICE_CONTROLLEDLOAD.
SERVICE_GUARANTEED | This is constant nxllJwaQos.SERVICE_GUARANTEED.
SERVICE_NO_QOS_SIGNALING | this flag can be used to prevent any rsvp signaling messages from being sent. Local traffic control will be invoked, but no RSVP Path messages will be sent.This flag can also be used in conjunction with a receiving flowspec to suppress the automatic generation of a Reserve message. The application would receive notification that a Path message had arrived and would then need to alter the QOS by issuing WSAIoctl( SIO_SET_QOS ), to unset this flag and thereby causing Reserve messages to go out.
SERVICE_NO_TRAFFIC_CONTROL | to turn off traffic control, 'OR' ( | ) this flag with the ServiceType field in the FLOWSPEC
SERVICE_QUALITATIVE | This is constant nxllJwaQos.SERVICE_QUALITATIVE.
SERVICETYPE_BESTEFFORT | Best Effort
SERVICETYPE_CONTROLLEDLOAD | Controlled Load
SERVICETYPE_GENERAL_INFORMATION | corresponds to "General Parameters" defined by IntServ
SERVICETYPE_GUARANTEED | Guaranteed
SERVICETYPE_NETWORK_CONTROL | Network Control traffic
SERVICETYPE_NETWORK_UNAVAILABLE | Used to notify change to user
SERVICETYPE_NOCHANGE | used to indicate that the flow spec contains no change from any previous one
SERVICETYPE_NONCONFORMING | Non-Conforming Traffic
SERVICETYPE_NOTRAFFIC | No data in this direction
SERVICETYPE_QUALITATIVE | Qualitative applications
TC_NONCONF_BORROW | This is constant nxllJwaQos.TC_NONCONF_BORROW.
TC_NONCONF_BORROW_PLUS | not supported currently
TC_NONCONF_DISCARD | This is constant nxllJwaQos.TC_NONCONF_DISCARD.
TC_NONCONF_SHAPE | This is constant nxllJwaQos.TC_NONCONF_SHAPE.
Structs, Records, Enums
Name | Description
_flowspec | Flow Specifications for each direction of data flow.
_QOS_SD_MODE | This structure is used to define the behaviour that the traffic control packet shaper will apply to the flow. TC_NONCONF_BORROW - the flow will receive resources remaining after all higher priority flows have been serviced. If a TokenRate is specified, packets may be non-conforming and will be demoted to less than best-effort priority. TC_NONCONF_SHAPE - TokenRate must be specified. Non-conforming packets will be retianed in the packet shaper until they become conforming. TC_NONCONF_DISCARD - TokenRate must be specified. Non-conforming packets will be discarded.
_QOS_SHAPING_RATE | This structure allows an app to specify a prorated "average token rate" using by the traffic shaper under SHAPE modehaper queue. It is expressed in bytes per sec. ShapingRate (bytes per sec.)
QOS_OBJECT_HDR | the provider specific structure can have a number of objects in it. Each next structure in the ProviderSpecific will be the QOS_OBJECT_HDR struct that prefaces the actual data with a type and length for that object. This QOS_OBJECT struct can repeat several times if there are several objects. This list of objects terminates either when the buffer length has been reached ( WSABUF ) or an object of type QOS_END_OF_LIST is encountered.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
FLOWSPEC | This is type nxllJwaQos.FLOWSPEC.
LPFLOWSPEC | This is type nxllJwaQos.LPFLOWSPEC.
LPQOS_OBJECT_HDR | This is type nxllJwaQos.LPQOS_OBJECT_HDR.
LPQOS_SD_MODE | This is type nxllJwaQos.LPQOS_SD_MODE.
LPQOS_SHAPING_RATE | This is type nxllJwaQos.LPQOS_SHAPING_RATE.
PFLOWSPEC | This is type nxllJwaQos.PFLOWSPEC.
PQOSObjectHdr | This is type nxllJwaQos.PQOSObjectHdr.
PQOSSDMode | This is type nxllJwaQos.PQOSSDMode.
PQOSShapingRate | This is type nxllJwaQos.PQOSShapingRate.
PServiceType | This is type nxllJwaQos.PServiceType.
QOS_SD_MODE | This is type nxllJwaQos.QOS_SD_MODE.
QOS_SHAPING_RATE | This is type nxllJwaQos.QOS_SHAPING_RATE.
SERVICETYPE | Definitions for valued-based Service Type for each direction of data flow.
TFlowSpec | This is type nxllJwaQos.TFlowSpec.
TQOSObjectHdr | This is type nxllJwaQos.TQOSObjectHdr.
TQOSSDMode | This is type nxllJwaQos.TQOSSDMode.
TQOSShapingRate | This is type nxllJwaQos.TQOSShapingRate.
TServiceType | This is type nxllJwaQos.TServiceType.
ULONG | This is type nxllJwaQos.ULONG.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
nxllJwaQos Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllJwaQos Namespace

Records
Name | Description
_flowspec | Flow Specifications for each direction of data flow.
_QOS_SD_MODE | This structure is used to define the behaviour that the traffic control packet shaper will apply to the flow. TC_NONCONF_BORROW - the flow will receive resources remaining after all higher priority flows have been serviced. If a TokenRate is specified, packets may be non-conforming and will be demoted to less than best-effort priority. TC_NONCONF_SHAPE - TokenRate must be specified. Non-conforming packets will be retianed in the packet shaper until they become conforming. TC_NONCONF_DISCARD - TokenRate must be specified. Non-conforming packets will be discarded.
_QOS_SHAPING_RATE | This structure allows an app to specify a prorated "average token rate" using by the traffic shaper under SHAPE modehaper queue. It is expressed in bytes per sec. ShapingRate (bytes per sec.)
QOS_OBJECT_HDR | the provider specific structure can have a number of objects in it. Each next structure in the ProviderSpecific will be the QOS_OBJECT_HDR struct that prefaces the actual data with a type and length for that object. This QOS_OBJECT struct can repeat several times if there are several objects. This list of objects terminates either when the buffer length has been reached ( WSABUF ) or an object of type QOS_END_OF_LIST is encountered.
Links
nxllJwaQos Namespace, Legend, Records


nxllJwaQos._flowspec Record

nxllJwaQos._flowspec Record
nxllJwaQos Structs, Records, Enums Send Feedback
Syntax
Delphi
_flowspec = record
  TokenRate: ULONG;
  TokenBucketSize: ULONG;
  PeakBandwidth: ULONG;
  Latency: ULONG;
  DelayVariation: ULONG;
  ServiceType: SERVICETYPE;
  MaxSduSize: ULONG;
  MinimumPolicedSize: ULONG;
end;
File

nxllJwaQos

Members
Members | Description
TokenRate: ULONG; | In Bytes/sec
TokenBucketSize: ULONG; | In Bytes
PeakBandwidth: ULONG; | In Bytes/sec
Latency: ULONG; | In microseconds
DelayVariation: ULONG; | In microseconds
MaxSduSize: ULONG; | In Bytes
MinimumPolicedSize: ULONG; | In Bytes
Description

Flow Specifications for each direction of data flow.

Group

Structs, Records, Enums

Links
nxllJwaQos, Structs, Records, Enums


nxllJwaQos._QOS_SD_MODE Record

nxllJwaQos._QOS_SD_MODE Record
nxllJwaQos Structs, Records, Enums Send Feedback
Syntax
Delphi
_QOS_SD_MODE = record
  ObjectHdr: QOS_OBJECT_HDR;
  ShapeDiscardMode: ULONG;
end;
File

nxllJwaQos

Description

This structure is used to define the behaviour that the traffic control packet shaper will apply to the flow.

TC_NONCONF_BORROW - the flow will receive resources remaining after all higher priority flows have been serviced. If a TokenRate is specified, packets may be non-conforming and will be demoted to less than best-effort priority.

TC_NONCONF_SHAPE - TokenRate must be specified. Non-conforming packets will be retianed in the packet shaper until they become conforming.

TC_NONCONF_DISCARD - TokenRate must be specified. Non-conforming packets will be discarded.

Group

Structs, Records, Enums

Links
nxllJwaQos, Structs, Records, Enums


nxllJwaQos._QOS_SHAPING_RATE Record

nxllJwaQos._QOS_SHAPING_RATE Record
nxllJwaQos Structs, Records, Enums Send Feedback
Syntax
Delphi
_QOS_SHAPING_RATE = record
  ObjectHdr: QOS_OBJECT_HDR;
  ShapingRate: ULONG;
end;
File

nxllJwaQos

Description

This structure allows an app to specify a prorated "average token rate" using by the traffic shaper under SHAPE modehaper queue. It is expressed in bytes per sec.

ShapingRate (bytes per sec.)

Group

Structs, Records, Enums

Links
nxllJwaQos, Structs, Records, Enums


nxllJwaQos.QOS_OBJECT_HDR Record

nxllJwaQos.QOS_OBJECT_HDR Record
nxllJwaQos Structs, Records, Enums Send Feedback
Syntax
Delphi
QOS_OBJECT_HDR = record
  ObjectType: ULONG;
  ObjectLength: ULONG;
end;
File

nxllJwaQos

Members
Members | Description
ObjectLength: ULONG; | the length of object buffer INCLUDING this header
Description

the provider specific structure can have a number of objects in it. Each next structure in the ProviderSpecific will be the QOS_OBJECT_HDR struct that prefaces the actual data with a type and length for that object. This QOS_OBJECT struct can repeat several times if there are several objects. This list of objects terminates either when the buffer length has been reached ( WSABUF ) or an object of type QOS_END_OF_LIST is encountered.

Group

Structs, Records, Enums

Links
nxllJwaQos, Structs, Records, Enums


Types

Types
nxllJwaQos Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaQos Namespace

Types
Name | Description
FLOWSPEC | This is type nxllJwaQos.FLOWSPEC.
LPFLOWSPEC | This is type nxllJwaQos.LPFLOWSPEC.
LPQOS_OBJECT_HDR | This is type nxllJwaQos.LPQOS_OBJECT_HDR.
LPQOS_SD_MODE | This is type nxllJwaQos.LPQOS_SD_MODE.
LPQOS_SHAPING_RATE | This is type nxllJwaQos.LPQOS_SHAPING_RATE.
PFLOWSPEC | This is type nxllJwaQos.PFLOWSPEC.
PQOSObjectHdr | This is type nxllJwaQos.PQOSObjectHdr.
PQOSSDMode | This is type nxllJwaQos.PQOSSDMode.
PQOSShapingRate | This is type nxllJwaQos.PQOSShapingRate.
PServiceType | This is type nxllJwaQos.PServiceType.
QOS_SD_MODE | This is type nxllJwaQos.QOS_SD_MODE.
QOS_SHAPING_RATE | This is type nxllJwaQos.QOS_SHAPING_RATE.
SERVICETYPE | Definitions for valued-based Service Type for each direction of data flow.
TFlowSpec | This is type nxllJwaQos.TFlowSpec.
TQOSObjectHdr | This is type nxllJwaQos.TQOSObjectHdr.
TQOSSDMode | This is type nxllJwaQos.TQOSSDMode.
TQOSShapingRate | This is type nxllJwaQos.TQOSShapingRate.
TServiceType | This is type nxllJwaQos.TServiceType.
ULONG | This is type nxllJwaQos.ULONG.
Links
nxllJwaQos Namespace, Types


nxllJwaQos.FLOWSPEC Type

nxllJwaQos.FLOWSPEC Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
FLOWSPEC = _flowspec;
File

nxllJwaQos

Description

This is type nxllJwaQos.FLOWSPEC.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.LPFLOWSPEC Type

nxllJwaQos.LPFLOWSPEC Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
LPFLOWSPEC = ^FLOWSPEC;
File

nxllJwaQos

Description

This is type nxllJwaQos.LPFLOWSPEC.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.LPQOS_OBJECT_HDR Type

nxllJwaQos.LPQOS_OBJECT_HDR Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
LPQOS_OBJECT_HDR = ^QOS_OBJECT_HDR;
File

nxllJwaQos

Description

This is type nxllJwaQos.LPQOS_OBJECT_HDR.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.LPQOS_SD_MODE Type

nxllJwaQos.LPQOS_SD_MODE Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
LPQOS_SD_MODE = ^QOS_SD_MODE;
File

nxllJwaQos

Description

This is type nxllJwaQos.LPQOS_SD_MODE.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.LPQOS_SHAPING_RATE Type

nxllJwaQos.LPQOS_SHAPING_RATE Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
LPQOS_SHAPING_RATE = ^QOS_SHAPING_RATE;
File

nxllJwaQos

Description

This is type nxllJwaQos.LPQOS_SHAPING_RATE.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.PFLOWSPEC Type

nxllJwaQos.PFLOWSPEC Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
PFLOWSPEC = ^FLOWSPEC;
File

nxllJwaQos

Description

This is type nxllJwaQos.PFLOWSPEC.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.PQOSObjectHdr Type

nxllJwaQos.PQOSObjectHdr Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
PQOSObjectHdr = LPQOS_OBJECT_HDR;
File

nxllJwaQos

Description

This is type nxllJwaQos.PQOSObjectHdr.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.PQOSSDMode Type

nxllJwaQos.PQOSSDMode Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
PQOSSDMode = LPQOS_SD_MODE;
File

nxllJwaQos

Description

This is type nxllJwaQos.PQOSSDMode.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.PQOSShapingRate Type

nxllJwaQos.PQOSShapingRate Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
PQOSShapingRate = LPQOS_SHAPING_RATE;
File

nxllJwaQos

Description

This is type nxllJwaQos.PQOSShapingRate.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.PServiceType Type

nxllJwaQos.PServiceType Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
PServiceType = ^TServiceType;
File

nxllJwaQos

Description

This is type nxllJwaQos.PServiceType.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.QOS_SD_MODE Type

nxllJwaQos.QOS_SD_MODE Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
QOS_SD_MODE = _QOS_SD_MODE;
File

nxllJwaQos

Description

This is type nxllJwaQos.QOS_SD_MODE.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.QOS_SHAPING_RATE Type

nxllJwaQos.QOS_SHAPING_RATE Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
QOS_SHAPING_RATE = _QOS_SHAPING_RATE;
File

nxllJwaQos

Description

This is type nxllJwaQos.QOS_SHAPING_RATE.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.SERVICETYPE Type

nxllJwaQos.SERVICETYPE Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
SERVICETYPE = ULONG;
File

nxllJwaQos

Description

Definitions for valued-based Service Type for each direction of data flow.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.TFlowSpec Type

nxllJwaQos.TFlowSpec Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
TFlowSpec = FLOWSPEC;
File

nxllJwaQos

Description

This is type nxllJwaQos.TFlowSpec.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.TQOSObjectHdr Type

nxllJwaQos.TQOSObjectHdr Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
TQOSObjectHdr = QOS_OBJECT_HDR;
File

nxllJwaQos

Description

This is type nxllJwaQos.TQOSObjectHdr.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.TQOSSDMode Type

nxllJwaQos.TQOSSDMode Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
TQOSSDMode = QOS_SD_MODE;
File

nxllJwaQos

Description

This is type nxllJwaQos.TQOSSDMode.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.TQOSShapingRate Type

nxllJwaQos.TQOSShapingRate Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
TQOSShapingRate = QOS_SHAPING_RATE;
File

nxllJwaQos

Description

This is type nxllJwaQos.TQOSShapingRate.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.TServiceType Type

nxllJwaQos.TServiceType Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
TServiceType = SERVICETYPE;
File

nxllJwaQos

Description

This is type nxllJwaQos.TServiceType.

Group

Types

Links
nxllJwaQos, Types


nxllJwaQos.ULONG Type

nxllJwaQos.ULONG Type
nxllJwaQos Types Send Feedback
Syntax
Delphi
ULONG = Cardinal;
File

nxllJwaQos

Description

This is type nxllJwaQos.ULONG.

Group

Types

Links
nxllJwaQos, Types


Constants

Constants
Constants nxllJwaQos Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
POSITIVE_INFINITY_RATE | define a value that can be used for the PeakBandwidth, which will map into positive infinity when the FLOWSPEC is converted into IntServ floating point format. We can't use (-1) because that value was previously defined to mean "select the default".
QOS_GENERAL_ID_BASE | general QOS objects start at this offset from the base and have a range of 1000
QOS_NOT_SPECIFIED | this value can be used in the FLOWSPEC structure to instruct the Rsvp Service provider to derive the appropriate default value for the parameter. Note that not all values in the FLOWSPEC structure can be defaults. In the ReceivingFlowspec, all parameters can be defaulted except the ServiceType. In the SendingFlowspec, the MaxSduSize and MinimumPolicedSize can be defaulted. Other defaults may be possible. Refer to the appropriate documentation.
QOS_OBJECT_DESTADDR | QOS_DestAddr structure (defined in qossp.h)
QOS_OBJECT_END_OF_LIST | QOS_End_of_list structure passed
QOS_OBJECT_SD_MODE | QOS_ShapeDiscard structure passed
QOS_OBJECT_SHAPING_RATE | QOS_ShapingRate structure
SERVICE_BESTEFFORT | The usage of these is currently not supported.
SERVICE_CONTROLLEDLOAD | This is constant nxllJwaQos.SERVICE_CONTROLLEDLOAD.
SERVICE_GUARANTEED | This is constant nxllJwaQos.SERVICE_GUARANTEED.
SERVICE_NO_QOS_SIGNALING | this flag can be used to prevent any rsvp signaling messages from being sent. Local traffic control will be invoked, but no RSVP Path messages will be sent.This flag can also be used in conjunction with a receiving flowspec to suppress the automatic generation of a Reserve message. The application would receive notification that a Path message had arrived and would then need to alter the QOS by issuing WSAIoctl( SIO_SET_QOS ), to unset this flag and thereby causing Reserve messages to go out.
SERVICE_NO_TRAFFIC_CONTROL | to turn off traffic control, 'OR' ( | ) this flag with the ServiceType field in the FLOWSPEC
SERVICE_QUALITATIVE | This is constant nxllJwaQos.SERVICE_QUALITATIVE.
SERVICETYPE_BESTEFFORT | Best Effort
SERVICETYPE_CONTROLLEDLOAD | Controlled Load
SERVICETYPE_GENERAL_INFORMATION | corresponds to "General Parameters" defined by IntServ
SERVICETYPE_GUARANTEED | Guaranteed
SERVICETYPE_NETWORK_CONTROL | Network Control traffic
SERVICETYPE_NETWORK_UNAVAILABLE | Used to notify change to user
SERVICETYPE_NOCHANGE | used to indicate that the flow spec contains no change from any previous one
SERVICETYPE_NONCONFORMING | Non-Conforming Traffic
SERVICETYPE_NOTRAFFIC | No data in this direction
SERVICETYPE_QUALITATIVE | Qualitative applications
TC_NONCONF_BORROW | This is constant nxllJwaQos.TC_NONCONF_BORROW.
TC_NONCONF_BORROW_PLUS | not supported currently
TC_NONCONF_DISCARD | This is constant nxllJwaQos.TC_NONCONF_DISCARD.
TC_NONCONF_SHAPE | This is constant nxllJwaQos.TC_NONCONF_SHAPE.
Namespace

nxllJwaQos Namespace

Links
Constants, nxllJwaQos Namespace


nxllJwaQos.POSITIVE_INFINITY_RATE Constant

nxllJwaQos.POSITIVE_INFINITY_RATE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
POSITIVE_INFINITY_RATE = DWORD($FFFFFFFE);
File

nxllJwaQos

Description

define a value that can be used for the PeakBandwidth, which will map into positive infinity when the FLOWSPEC is converted into IntServ floating point format. We can't use (-1) because that value was previously defined to mean "select the default".

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_GENERAL_ID_BASE Constant

nxllJwaQos.QOS_GENERAL_ID_BASE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_GENERAL_ID_BASE = 2000;
File

nxllJwaQos

Description

general QOS objects start at this offset from the base and have a range of 1000

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_NOT_SPECIFIED Constant

nxllJwaQos.QOS_NOT_SPECIFIED Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_NOT_SPECIFIED = DWORD($FFFFFFFF);
File

nxllJwaQos

Description

this value can be used in the FLOWSPEC structure to instruct the Rsvp Service provider to derive the appropriate default value for the parameter. Note that not all values in the FLOWSPEC structure can be defaults. In the ReceivingFlowspec, all parameters can be defaulted except the ServiceType. In the SendingFlowspec, the MaxSduSize and MinimumPolicedSize can be defaulted. Other defaults may be possible. Refer to the appropriate documentation.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_OBJECT_DESTADDR Constant

nxllJwaQos.QOS_OBJECT_DESTADDR Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_OBJECT_DESTADDR = ($00000004 + QOS_GENERAL_ID_BASE);
File

nxllJwaQos

Description

QOS_DestAddr structure (defined in qossp.h)

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_OBJECT_END_OF_LIST Constant

nxllJwaQos.QOS_OBJECT_END_OF_LIST Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_OBJECT_END_OF_LIST = ($00000001 + QOS_GENERAL_ID_BASE);
File

nxllJwaQos

Description

QOS_End_of_list structure passed

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_OBJECT_SD_MODE Constant

nxllJwaQos.QOS_OBJECT_SD_MODE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_OBJECT_SD_MODE = ($00000002 + QOS_GENERAL_ID_BASE);
File

nxllJwaQos

Description

QOS_ShapeDiscard structure passed

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.QOS_OBJECT_SHAPING_RATE Constant

nxllJwaQos.QOS_OBJECT_SHAPING_RATE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
QOS_OBJECT_SHAPING_RATE = ($00000003 + QOS_GENERAL_ID_BASE);
File

nxllJwaQos

Description

QOS_ShapingRate structure

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_BESTEFFORT Constant

nxllJwaQos.SERVICE_BESTEFFORT Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_BESTEFFORT = DWORD($80010000);
File

nxllJwaQos

Description

The usage of these is currently not supported.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_CONTROLLEDLOAD Constant

nxllJwaQos.SERVICE_CONTROLLEDLOAD Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_CONTROLLEDLOAD = DWORD($80020000);
File

nxllJwaQos

Description

This is constant nxllJwaQos.SERVICE_CONTROLLEDLOAD.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_GUARANTEED Constant

nxllJwaQos.SERVICE_GUARANTEED Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_GUARANTEED = DWORD($80040000);
File

nxllJwaQos

Description

This is constant nxllJwaQos.SERVICE_GUARANTEED.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_NO_QOS_SIGNALING Constant

nxllJwaQos.SERVICE_NO_QOS_SIGNALING Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_NO_QOS_SIGNALING = $40000000;
File

nxllJwaQos

Description

this flag can be used to prevent any rsvp signaling messages from being sent. Local traffic control will be invoked, but no RSVP Path messages will be sent.This flag can also be used in conjunction with a receiving flowspec to suppress the automatic generation of a Reserve message. The application would receive notification that a Path message had arrived and would then need to alter the QOS by issuing WSAIoctl( SIO_SET_QOS ), to unset this flag and thereby causing Reserve messages to go out.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_NO_TRAFFIC_CONTROL Constant

nxllJwaQos.SERVICE_NO_TRAFFIC_CONTROL Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_NO_TRAFFIC_CONTROL = DWORD($81000000);
File

nxllJwaQos

Description

to turn off traffic control, 'OR' ( | ) this flag with the ServiceType field in the FLOWSPEC

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICE_QUALITATIVE Constant

nxllJwaQos.SERVICE_QUALITATIVE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICE_QUALITATIVE = DWORD($80200000);
File

nxllJwaQos

Description

This is constant nxllJwaQos.SERVICE_QUALITATIVE.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_BESTEFFORT Constant

nxllJwaQos.SERVICETYPE_BESTEFFORT Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_BESTEFFORT = $00000001;
File

nxllJwaQos

Description

Best Effort

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_CONTROLLEDLOAD Constant

nxllJwaQos.SERVICETYPE_CONTROLLEDLOAD Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_CONTROLLEDLOAD = $00000002;
File

nxllJwaQos

Description

Controlled Load

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_GENERAL_INFORMATION Constant

nxllJwaQos.SERVICETYPE_GENERAL_INFORMATION Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_GENERAL_INFORMATION = $00000005;
File

nxllJwaQos

Description

corresponds to "General Parameters" defined by IntServ

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_GUARANTEED Constant

nxllJwaQos.SERVICETYPE_GUARANTEED Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_GUARANTEED = $00000003;
File

nxllJwaQos

Description

Guaranteed

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_NETWORK_CONTROL Constant

nxllJwaQos.SERVICETYPE_NETWORK_CONTROL Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_NETWORK_CONTROL = $0000000A;
File

nxllJwaQos

Description

Network Control traffic

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_NETWORK_UNAVAILABLE Constant

nxllJwaQos.SERVICETYPE_NETWORK_UNAVAILABLE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_NETWORK_UNAVAILABLE = $00000004;
File

nxllJwaQos

Description

Used to notify change to user

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_NOCHANGE Constant

nxllJwaQos.SERVICETYPE_NOCHANGE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_NOCHANGE = $00000006;
File

nxllJwaQos

Description

used to indicate that the flow spec contains no change from any previous one

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_NONCONFORMING Constant

nxllJwaQos.SERVICETYPE_NONCONFORMING Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_NONCONFORMING = $00000009;
File

nxllJwaQos

Description

Non-Conforming Traffic

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_NOTRAFFIC Constant

nxllJwaQos.SERVICETYPE_NOTRAFFIC Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_NOTRAFFIC = $00000000;
File

nxllJwaQos

Description

No data in this direction

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.SERVICETYPE_QUALITATIVE Constant

nxllJwaQos.SERVICETYPE_QUALITATIVE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
SERVICETYPE_QUALITATIVE = $0000000D;
File

nxllJwaQos

Description

Qualitative applications

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.TC_NONCONF_BORROW Constant

nxllJwaQos.TC_NONCONF_BORROW Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
TC_NONCONF_BORROW = 0;
File

nxllJwaQos

Description

This is constant nxllJwaQos.TC_NONCONF_BORROW.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.TC_NONCONF_BORROW_PLUS Constant

nxllJwaQos.TC_NONCONF_BORROW_PLUS Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
TC_NONCONF_BORROW_PLUS = 3;
File

nxllJwaQos

Description

not supported currently

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.TC_NONCONF_DISCARD Constant

nxllJwaQos.TC_NONCONF_DISCARD Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
TC_NONCONF_DISCARD = 2;
File

nxllJwaQos

Description

This is constant nxllJwaQos.TC_NONCONF_DISCARD.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaQos.TC_NONCONF_SHAPE Constant

nxllJwaQos.TC_NONCONF_SHAPE Constant
nxllJwaQos Constants Send Feedback
Syntax
Delphi
TC_NONCONF_SHAPE = 1;
File

nxllJwaQos

Description

This is constant nxllJwaQos.TC_NONCONF_SHAPE.

Group

Constants

Links
nxllJwaQos, Constants


nxllJwaWinsock2 Namespace

nxllJwaWinsock2 Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllJwaWinsock2.

Constants
Name | Description
_SS_ALIGNSIZE | Desired alignment.
_SS_MAXSIZE | Maximum size.
_SS_PAD1SIZE | Definitions used for sockaddr_storage structure paddings design.
_SS_PAD2SIZE | This is constant nxllJwaWinsock2._SS_PAD2SIZE.
ADDR_ANY | This is constant nxllJwaWinsock2.ADDR_ANY.
AF_12844 | IEEE 1284.4 WG AF
AF_APPLETALK | AppleTalk
AF_ATM | Native ATM Services
AF_BAN | Banyan
AF_CCITT | CCITT protocols, X.25 etc
AF_CHAOS | mit CHAOS protocols
AF_CLUSTER | Microsoft Wolfpack
AF_DATAKIT | datakit protocols
AF_DECnet | DECnet
AF_DLI | Direct data link interface
AF_ECMA | european computer manufacturers
AF_FIREFOX | Protocols from Firefox
AF_HYLINK | NSC Hyperchannel
AF_ICLFXBM | This is constant nxllJwaWinsock2.AF_ICLFXBM.
AF_IMPLINK | arpanet imp addresses
AF_INET | internetwork: UDP, TCP, etc.
AF_INET6 | Internetwork Version 6
AF_IPX | IPX protocols: IPX, SPX, etc.
AF_IRDA | IrDA
AF_ISO | ISO protocols
AF_LAT | LAT
AF_MAX | This is constant nxllJwaWinsock2.AF_MAX.
AF_NETBIOS | NetBios-style addresses
AF_NETDES | Network Designers OSI & gateway enabled protocols
AF_NS | XEROX NS protocols
AF_OSI | OSI is ISO
AF_PUP | pup protocols: e.g. BSP
AF_SNA | IBM SNA
AF_TCNMESSAGE | This is constant nxllJwaWinsock2.AF_TCNMESSAGE.
AF_TCNPROCESS | This is constant nxllJwaWinsock2.AF_TCNPROCESS.
AF_UNIX | local to host (pipes, portals
AF_UNKNOWN1 | Somebody is using this!
AF_UNSPEC | unspecified
AF_VOICEVIEW | VoiceView
BASE_PROTOCOL | This is constant nxllJwaWinsock2.BASE_PROTOCOL.
BIGENDIAN | This is constant nxllJwaWinsock2.BIGENDIAN.
CF_ACCEPT | WinSock 2 extension -- manifest constants for return values of the condition function
CF_DEFER | This is constant nxllJwaWinsock2.CF_DEFER.
CF_REJECT | This is constant nxllJwaWinsock2.CF_REJECT.
EADDRINUSE | This is constant nxllJwaWinsock2.EADDRINUSE.
EADDRNOTAVAIL | This is constant nxllJwaWinsock2.EADDRNOTAVAIL.
EAFNOSUPPORT | This is constant nxllJwaWinsock2.EAFNOSUPPORT.
EALREADY | This is constant nxllJwaWinsock2.EALREADY.
ECONNABORTED | This is constant nxllJwaWinsock2.ECONNABORTED.
ECONNREFUSED | This is constant nxllJwaWinsock2.ECONNREFUSED.
ECONNRESET | This is constant nxllJwaWinsock2.ECONNRESET.
EDESTADDRREQ | This is constant nxllJwaWinsock2.EDESTADDRREQ.
EDQUOT | This is constant nxllJwaWinsock2.EDQUOT.
EHOSTDOWN | This is constant nxllJwaWinsock2.EHOSTDOWN.
EHOSTUNREACH | This is constant nxllJwaWinsock2.EHOSTUNREACH.
EINPROGRESS | This is constant nxllJwaWinsock2.EINPROGRESS.
EISCONN | This is constant nxllJwaWinsock2.EISCONN.
ELOOP | This is constant nxllJwaWinsock2.ELOOP.
EMSGSIZE | This is constant nxllJwaWinsock2.EMSGSIZE.
ENAMETOOLONG | This is constant nxllJwaWinsock2.ENAMETOOLONG.
ENETDOWN | This is constant nxllJwaWinsock2.ENETDOWN.
ENETRESET | This is constant nxllJwaWinsock2.ENETRESET.
ENETUNREACH | This is constant nxllJwaWinsock2.ENETUNREACH.
ENOBUFS | This is constant nxllJwaWinsock2.ENOBUFS.
ENOPROTOOPT | This is constant nxllJwaWinsock2.ENOPROTOOPT.
ENOTCONN | This is constant nxllJwaWinsock2.ENOTCONN.
ENOTEMPTY | This is constant nxllJwaWinsock2.ENOTEMPTY.
ENOTSOCK | This is constant nxllJwaWinsock2.ENOTSOCK.
EOPNOTSUPP | This is constant nxllJwaWinsock2.EOPNOTSUPP.
EPFNOSUPPORT | This is constant nxllJwaWinsock2.EPFNOSUPPORT.
EPROCLIM | This is constant nxllJwaWinsock2.EPROCLIM.
EPROTONOSUPPORT | This is constant nxllJwaWinsock2.EPROTONOSUPPORT.
EPROTOTYPE | This is constant nxllJwaWinsock2.EPROTOTYPE.
EREMOTE | This is constant nxllJwaWinsock2.EREMOTE.
ESHUTDOWN | This is constant nxllJwaWinsock2.ESHUTDOWN.
ESOCKTNOSUPPORT | This is constant nxllJwaWinsock2.ESOCKTNOSUPPORT.
ESTALE | This is constant nxllJwaWinsock2.ESTALE.
ETIMEDOUT | This is constant nxllJwaWinsock2.ETIMEDOUT.
ETOOMANYREFS | This is constant nxllJwaWinsock2.ETOOMANYREFS.
EUSERS | This is constant nxllJwaWinsock2.EUSERS.
EWOULDBLOCK | Windows Sockets errors redefined as regular Berkeley error constants. These are commented out in Windows NT to avoid conflicts with errno.h. Use the WSA constants instead.
FD_ACCEPT | This is constant nxllJwaWinsock2.FD_ACCEPT.
FD_ACCEPT_BIT | This is constant nxllJwaWinsock2.FD_ACCEPT_BIT.
FD_ADDRESS_LIST_CHANGE | This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE.
FD_ADDRESS_LIST_CHANGE_BIT | This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE_BIT.
FD_ALL_EVENTS | This is constant nxllJwaWinsock2.FD_ALL_EVENTS.
FD_CLOSE | This is constant nxllJwaWinsock2.FD_CLOSE.
FD_CLOSE_BIT | This is constant nxllJwaWinsock2.FD_CLOSE_BIT.
FD_CONNECT | This is constant nxllJwaWinsock2.FD_CONNECT.
FD_CONNECT_BIT | This is constant nxllJwaWinsock2.FD_CONNECT_BIT.
FD_GROUP_QOS | This is constant nxllJwaWinsock2.FD_GROUP_QOS.
FD_GROUP_QOS_BIT | This is constant nxllJwaWinsock2.FD_GROUP_QOS_BIT.
FD_MAX_EVENTS | This is constant nxllJwaWinsock2.FD_MAX_EVENTS.
FD_OOB | This is constant nxllJwaWinsock2.FD_OOB.
FD_OOB_BIT | This is constant nxllJwaWinsock2.FD_OOB_BIT.
FD_QOS | This is constant nxllJwaWinsock2.FD_QOS.
FD_QOS_BIT | This is constant nxllJwaWinsock2.FD_QOS_BIT.
FD_READ | This is constant nxllJwaWinsock2.FD_READ.
FD_READ_BIT | WinSock 2 extension -- bit values and indices for FD_XXX network events
FD_ROUTING_INTERFACE_CHANGE | This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE.
FD_ROUTING_INTERFACE_CHANGE_BIT | This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE_BIT.
FD_SETSIZE | Select uses arrays of SOCKETs. These macros manipulate such arrays. FD_SETSIZE may be defined by the user before including this file, but the default here should be >= 64. CAVEAT IMPLEMENTOR and USER: THESE MACROS AND TYPES MUST BE INCLUDED IN WINSOCK2.H EXACTLY AS SHOWN HERE.
FD_WRITE | This is constant nxllJwaWinsock2.FD_WRITE.
FD_WRITE_BIT | This is constant nxllJwaWinsock2.FD_WRITE_BIT.
FIOASYNC | set/clear async i/o
FIONBIO | set/clear non-blocking i/o
FIONREAD | get # bytes to read
FROM_PROTOCOL_INFO | The following may be used in place of the address family, socket type, or protocol in a call to WSASocket to indicate that the corresponding value should be taken from the supplied WSAPROTOCOL_INFO structure instead of the parameter itself.
HOST_NOT_FOUND | This is constant nxllJwaWinsock2.HOST_NOT_FOUND.
IMPLINK_HIGHEXPER | This is constant nxllJwaWinsock2.IMPLINK_HIGHEXPER.
IMPLINK_IP | Link numbers
IMPLINK_LOWEXPER | This is constant nxllJwaWinsock2.IMPLINK_LOWEXPER.
IN_CLASSA_HOST | This is constant nxllJwaWinsock2.IN_CLASSA_HOST.
IN_CLASSA_MAX | This is constant nxllJwaWinsock2.IN_CLASSA_MAX.
IN_CLASSA_NET | This is constant nxllJwaWinsock2.IN_CLASSA_NET.
IN_CLASSA_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSA_NSHIFT.
IN_CLASSB_HOST | This is constant nxllJwaWinsock2.IN_CLASSB_HOST.
IN_CLASSB_MAX | This is constant nxllJwaWinsock2.IN_CLASSB_MAX.
IN_CLASSB_NET | This is constant nxllJwaWinsock2.IN_CLASSB_NET.
IN_CLASSB_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSB_NSHIFT.
IN_CLASSC_HOST | This is constant nxllJwaWinsock2.IN_CLASSC_HOST.
IN_CLASSC_NET | This is constant nxllJwaWinsock2.IN_CLASSC_NET.
IN_CLASSC_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSC_NSHIFT.
IN_CLASSD_HOST | routing needn't know.
IN_CLASSD_NET | These ones aren't really
IN_CLASSD_NSHIFT | net and host fields, but
INADDR_ANY | This is constant nxllJwaWinsock2.INADDR_ANY.
INADDR_BROADCAST | This is constant nxllJwaWinsock2.INADDR_BROADCAST.
INADDR_LOOPBACK | This is constant nxllJwaWinsock2.INADDR_LOOPBACK.
INADDR_NONE | This is constant nxllJwaWinsock2.INADDR_NONE.
INCL_WINSOCK_API_PROTOTYPES | Default: include function prototypes, don't include function typedefs.
INCL_WINSOCK_API_TYPEDEFS | This is constant nxllJwaWinsock2.INCL_WINSOCK_API_TYPEDEFS.
INVALID_SOCKET | This is used instead of -1, since the SOCKET type is unsigned.
IOC_IN | copy in parameters
IOC_INOUT | This is constant nxllJwaWinsock2.IOC_INOUT.
IOC_OUT | copy out parameters
IOC_PROTOCOL | This is constant nxllJwaWinsock2.IOC_PROTOCOL.
IOC_UNIX | WinSock 2 extension -- manifest constants for WSAIoctl()
IOC_VENDOR | This is constant nxllJwaWinsock2.IOC_VENDOR.
IOC_VOID | no parameters
IOC_WS2 | This is constant nxllJwaWinsock2.IOC_WS2.
IOCPARM_MASK | parameters must be < 128 bytes
IPPORT_BIFFUDP | UNIX UDP sockets
IPPORT_CMDSERVER | This is constant nxllJwaWinsock2.IPPORT_CMDSERVER.
IPPORT_DAYTIME | This is constant nxllJwaWinsock2.IPPORT_DAYTIME.
IPPORT_DISCARD | This is constant nxllJwaWinsock2.IPPORT_DISCARD.
IPPORT_ECHO | Port/socket numbers: network standard functions
IPPORT_EFSSERVER | This is constant nxllJwaWinsock2.IPPORT_EFSSERVER.
IPPORT_EXECSERVER | UNIX TCP sockets
IPPORT_FINGER | This is constant nxllJwaWinsock2.IPPORT_FINGER.
IPPORT_FTP | This is constant nxllJwaWinsock2.IPPORT_FTP.
IPPORT_LOGINSERVER | This is constant nxllJwaWinsock2.IPPORT_LOGINSERVER.
IPPORT_MTP | This is constant nxllJwaWinsock2.IPPORT_MTP.
IPPORT_NAMESERVER | This is constant nxllJwaWinsock2.IPPORT_NAMESERVER.
IPPORT_NETSTAT | This is constant nxllJwaWinsock2.IPPORT_NETSTAT.
IPPORT_RESERVED | Ports < IPPORT_RESERVED are reserved for privileged processes (e.g. root).
IPPORT_RJE | This is constant nxllJwaWinsock2.IPPORT_RJE.
IPPORT_ROUTESERVER | This is constant nxllJwaWinsock2.IPPORT_ROUTESERVER.
IPPORT_SMTP | This is constant nxllJwaWinsock2.IPPORT_SMTP.
IPPORT_SUPDUP | This is constant nxllJwaWinsock2.IPPORT_SUPDUP.
IPPORT_SYSTAT | This is constant nxllJwaWinsock2.IPPORT_SYSTAT.
IPPORT_TELNET | This is constant nxllJwaWinsock2.IPPORT_TELNET.
IPPORT_TFTP | Port/socket numbers: host specific functions
IPPORT_TIMESERVER | This is constant nxllJwaWinsock2.IPPORT_TIMESERVER.
IPPORT_TTYLINK | This is constant nxllJwaWinsock2.IPPORT_TTYLINK.
IPPORT_WHOIS | This is constant nxllJwaWinsock2.IPPORT_WHOIS.
IPPORT_WHOSERVER | This is constant nxllJwaWinsock2.IPPORT_WHOSERVER.
IPPROTO_AH | IPsec AH
IPPROTO_DSTOPTS | IPv6 destination options
IPPROTO_ESP | IPsec ESP header
IPPROTO_FRAGMENT | IPv6 fragmentation header
IPPROTO_GGP | gateway^2 (deprecated)
IPPROTO_HOPOPTS | IPv6 hop-by-hop options
IPPROTO_ICLFXBM | This is constant nxllJwaWinsock2.IPPROTO_ICLFXBM.
IPPROTO_ICMP | control message protocol
IPPROTO_ICMPV6 | ICMPv6
IPPROTO_IDP | xns idp
IPPROTO_IGMP | internet group management protocol
IPPROTO_IP | dummy for IP
IPPROTO_IPV4 | IPv4
IPPROTO_IPV6 | IPv6
IPPROTO_MAX | This is constant nxllJwaWinsock2.IPPROTO_MAX.
IPPROTO_ND | UNOFFICIAL net disk proto
IPPROTO_NONE | IPv6 no next header
IPPROTO_PUP | pup
IPPROTO_RAW | raw IP packet
IPPROTO_ROUTING | IPv6 routing header
IPPROTO_TCP | tcp
IPPROTO_UDP | user datagram protocol
JL_BOTH | This is constant nxllJwaWinsock2.JL_BOTH.
JL_RECEIVER_ONLY | This is constant nxllJwaWinsock2.JL_RECEIVER_ONLY.
JL_SENDER_ONLY | WinSock 2 extension -- manifest constants for WSAJoinLeaf()
LAYERED_PROTOCOL | This is constant nxllJwaWinsock2.LAYERED_PROTOCOL.
LITTLEENDIAN | This is constant nxllJwaWinsock2.LITTLEENDIAN.
LUP_CONTAINERS | This is constant nxllJwaWinsock2.LUP_CONTAINERS.
LUP_DEEP | This is constant nxllJwaWinsock2.LUP_DEEP.
LUP_FLUSHCACHE | This is constant nxllJwaWinsock2.LUP_FLUSHCACHE.
LUP_FLUSHPREVIOUS | This is constant nxllJwaWinsock2.LUP_FLUSHPREVIOUS.
LUP_NEAREST | This is constant nxllJwaWinsock2.LUP_NEAREST.
LUP_NOCONTAINERS | This is constant nxllJwaWinsock2.LUP_NOCONTAINERS.
LUP_RES_SERVICE | This is constant nxllJwaWinsock2.LUP_RES_SERVICE.
LUP_RETURN_ADDR | This is constant nxllJwaWinsock2.LUP_RETURN_ADDR.
LUP_RETURN_ALIASES | This is constant nxllJwaWinsock2.LUP_RETURN_ALIASES.
LUP_RETURN_ALL | This is constant nxllJwaWinsock2.LUP_RETURN_ALL.
LUP_RETURN_BLOB | This is constant nxllJwaWinsock2.LUP_RETURN_BLOB.
LUP_RETURN_COMMENT | This is constant nxllJwaWinsock2.LUP_RETURN_COMMENT.
LUP_RETURN_NAME | This is constant nxllJwaWinsock2.LUP_RETURN_NAME.
LUP_RETURN_QUERY_STRING | This is constant nxllJwaWinsock2.LUP_RETURN_QUERY_STRING.
LUP_RETURN_TYPE | This is constant nxllJwaWinsock2.LUP_RETURN_TYPE.
LUP_RETURN_VERSION | This is constant nxllJwaWinsock2.LUP_RETURN_VERSION.
MAX_PROTOCOL_CHAIN | WinSock 2 extension -- WSAPROTOCOL_INFO structure and associated manifest constants
MAXGETHOSTSTRUCT | Define constant based on rfc883, used by gethostbyxxxx() calls.
MSG_DONTROUTE | send without using routing tables
MSG_INTERRUPT | send/recv in the interrupt context
MSG_MAXIOVLEN | This is constant nxllJwaWinsock2.MSG_MAXIOVLEN.
MSG_OOB | process out-of-band data
MSG_PARTIAL | partial send or recv for message xport
MSG_PEEK | peek at incoming message
NO_ADDRESS | This is constant nxllJwaWinsock2.NO_ADDRESS.
NO_DATA | This is constant nxllJwaWinsock2.NO_DATA.
NO_RECOVERY | This is constant nxllJwaWinsock2.NO_RECOVERY.
NS_ALL | Name Spaces
NS_DHCP | This is constant nxllJwaWinsock2.NS_DHCP.
NS_DNS | This is constant nxllJwaWinsock2.NS_DNS.
NS_MS | This is constant nxllJwaWinsock2.NS_MS.
NS_NBP | This is constant nxllJwaWinsock2.NS_NBP.
NS_NDS | This is constant nxllJwaWinsock2.NS_NDS.
NS_NETBT | This is constant nxllJwaWinsock2.NS_NETBT.
NS_NETDES | Network Designers Limited
NS_NIS | This is constant nxllJwaWinsock2.NS_NIS.
NS_NISPLUS | This is constant nxllJwaWinsock2.NS_NISPLUS.
NS_NLA | Network Location Awareness
NS_NTDS | This is constant nxllJwaWinsock2.NS_NTDS.
NS_PEER_BROWSE | This is constant nxllJwaWinsock2.NS_PEER_BROWSE.
NS_SAP | This is constant nxllJwaWinsock2.NS_SAP.
NS_SLP | This is constant nxllJwaWinsock2.NS_SLP.
NS_STDA | This is constant nxllJwaWinsock2.NS_STDA.
NS_TCPIP_HOSTS | This is constant nxllJwaWinsock2.NS_TCPIP_HOSTS.
NS_TCPIP_LOCAL | This is constant nxllJwaWinsock2.NS_TCPIP_LOCAL.
NS_WINS | This is constant nxllJwaWinsock2.NS_WINS.
NS_WRQ | This is constant nxllJwaWinsock2.NS_WRQ.
NS_X500 | This is constant nxllJwaWinsock2.NS_X500.
PF_APPLETALK | This is constant nxllJwaWinsock2.PF_APPLETALK.
PF_ATM | This is constant nxllJwaWinsock2.PF_ATM.
PF_BAN | This is constant nxllJwaWinsock2.PF_BAN.
PF_CCITT | This is constant nxllJwaWinsock2.PF_CCITT.
PF_CHAOS | This is constant nxllJwaWinsock2.PF_CHAOS.
PF_DATAKIT | This is constant nxllJwaWinsock2.PF_DATAKIT.
PF_DECnet | This is constant nxllJwaWinsock2.PF_DECnet.
PF_DLI | This is constant nxllJwaWinsock2.PF_DLI.
PF_ECMA | This is constant nxllJwaWinsock2.PF_ECMA.
PF_FIREFOX | This is constant nxllJwaWinsock2.PF_FIREFOX.
PF_HYLINK | This is constant nxllJwaWinsock2.PF_HYLINK.
PF_IMPLINK | This is constant nxllJwaWinsock2.PF_IMPLINK.
PF_INET | This is constant nxllJwaWinsock2.PF_INET.
PF_INET6 | This is constant nxllJwaWinsock2.PF_INET6.
PF_IPX | This is constant nxllJwaWinsock2.PF_IPX.
PF_ISO | This is constant nxllJwaWinsock2.PF_ISO.
PF_LAT | This is constant nxllJwaWinsock2.PF_LAT.
PF_MAX | This is constant nxllJwaWinsock2.PF_MAX.
PF_NS | This is constant nxllJwaWinsock2.PF_NS.
PF_OSI | This is constant nxllJwaWinsock2.PF_OSI.
PF_PUP | This is constant nxllJwaWinsock2.PF_PUP.
PF_SNA | This is constant nxllJwaWinsock2.PF_SNA.
PF_UNIX | This is constant nxllJwaWinsock2.PF_UNIX.
PF_UNKNOWN1 | This is constant nxllJwaWinsock2.PF_UNKNOWN1.
PF_UNSPEC | Protocol families, same as address families for now.
PF_VOICEVIEW | This is constant nxllJwaWinsock2.PF_VOICEVIEW.
PFL_HIDDEN | This is constant nxllJwaWinsock2.PFL_HIDDEN.
PFL_MATCHES_PROTOCOL_ZERO | This is constant nxllJwaWinsock2.PFL_MATCHES_PROTOCOL_ZERO.
PFL_MULTIPLE_PROTO_ENTRIES | Flag bit definitions for dwProviderFlags
PFL_RECOMMENDED_PROTO_ENTRY | This is constant nxllJwaWinsock2.PFL_RECOMMENDED_PROTO_ENTRY.
PVD_CONFIG | configuration info for service provider
RES_FLUSH_CACHE | This is constant nxllJwaWinsock2.RES_FLUSH_CACHE.
RES_SERVICE | This is constant nxllJwaWinsock2.RES_SERVICE.
RES_UNUSED_1 | Resolution flags for WSAGetAddressByName(). Note these are also used by the 1.1 API GetAddressByName, so leave them around.
RESULT_IS_ADDED | This is constant nxllJwaWinsock2.RESULT_IS_ADDED.
RESULT_IS_ALIAS | Return flags
RESULT_IS_CHANGED | This is constant nxllJwaWinsock2.RESULT_IS_CHANGED.
RESULT_IS_DELETED | This is constant nxllJwaWinsock2.RESULT_IS_DELETED.
SD_BOTH | This is constant nxllJwaWinsock2.SD_BOTH.
SD_RECEIVE | WinSock 2 extension -- manifest constants for shutdown()
SD_SEND | This is constant nxllJwaWinsock2.SD_SEND.
SECURITY_PROTOCOL_NONE | This is constant nxllJwaWinsock2.SECURITY_PROTOCOL_NONE.
SERVICE_MULTIPLE | Service Install Flags
SERVICE_TYPE_VALUE_IPXPORTA | Well known value names for Service Types
SERVICE_TYPE_VALUE_IPXPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTW.
SERVICE_TYPE_VALUE_OBJECTID | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTID.
SERVICE_TYPE_VALUE_OBJECTIDA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDA.
SERVICE_TYPE_VALUE_OBJECTIDW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDW.
SERVICE_TYPE_VALUE_SAPID | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPID.
SERVICE_TYPE_VALUE_SAPIDA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDA.
SERVICE_TYPE_VALUE_SAPIDW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDW.
SERVICE_TYPE_VALUE_TCPPORT | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORT.
SERVICE_TYPE_VALUE_TCPPORTA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTA.
SERVICE_TYPE_VALUE_TCPPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTW.
SERVICE_TYPE_VALUE_UDPPORT | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORT.
SERVICE_TYPE_VALUE_UDPPORTA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTA.
SERVICE_TYPE_VALUE_UDPPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTW.
SG_CONSTRAINED_GROUP | This is constant nxllJwaWinsock2.SG_CONSTRAINED_GROUP.
SG_UNCONSTRAINED_GROUP | This is constant nxllJwaWinsock2.SG_UNCONSTRAINED_GROUP.
SIO_ADDRESS_LIST_CHANGE | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_CHANGE.
SIO_ADDRESS_LIST_QUERY | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_QUERY.
SIO_ADDRESS_LIST_SORT | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_SORT.
SIO_ASSOCIATE_HANDLE | This is constant nxllJwaWinsock2.SIO_ASSOCIATE_HANDLE.
SIO_ENABLE_CIRCULAR_QUEUEING | This is constant nxllJwaWinsock2.SIO_ENABLE_CIRCULAR_QUEUEING.
SIO_FIND_ROUTE | This is constant nxllJwaWinsock2.SIO_FIND_ROUTE.
SIO_FLUSH | This is constant nxllJwaWinsock2.SIO_FLUSH.
SIO_GET_BROADCAST_ADDRESS | This is constant nxllJwaWinsock2.SIO_GET_BROADCAST_ADDRESS.
SIO_GET_EXTENSION_FUNCTION_POINTER | This is constant nxllJwaWinsock2.SIO_GET_EXTENSION_FUNCTION_POINTER.
SIO_GET_GROUP_QOS | This is constant nxllJwaWinsock2.SIO_GET_GROUP_QOS.
SIO_GET_QOS | This is constant nxllJwaWinsock2.SIO_GET_QOS.
SIO_MULTICAST_SCOPE | This is constant nxllJwaWinsock2.SIO_MULTICAST_SCOPE.
SIO_MULTIPOINT_LOOPBACK | This is constant nxllJwaWinsock2.SIO_MULTIPOINT_LOOPBACK.
SIO_NSP_NOTIFY_CHANGE | WinSock 2 extension -- manifest constants and associated structures for WSANSPIoctl()
SIO_QUERY_TARGET_PNP_HANDLE | This is constant nxllJwaWinsock2.SIO_QUERY_TARGET_PNP_HANDLE.
SIO_ROUTING_INTERFACE_CHANGE | This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_CHANGE.
SIO_ROUTING_INTERFACE_QUERY | This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_QUERY.
SIO_SET_GROUP_QOS | This is constant nxllJwaWinsock2.SIO_SET_GROUP_QOS.
SIO_SET_QOS | This is constant nxllJwaWinsock2.SIO_SET_QOS.
SIO_TRANSLATE_HANDLE | This is constant nxllJwaWinsock2.SIO_TRANSLATE_HANDLE.
SIOCATMARK | at oob mark?
SIOCGHIWAT | get high watermark
SIOCGLOWAT | get low watermark
SIOCSHIWAT | set high watermark
SIOCSLOWAT | set low watermark
SO_ACCEPTCONN | socket has had listen()
SO_BROADCAST | permit sending of broadcast msgs
SO_CONDITIONAL_ACCEPT | enable true conditional accept: connection is not ack-ed to the other side until conditional function returns CF_ACCEPT
SO_DEBUG | turn on debugging info recording
SO_DONTLINGER | This is constant nxllJwaWinsock2.SO_DONTLINGER.
SO_DONTROUTE | just use interface addresses
SO_ERROR | get error status and clear
SO_EXCLUSIVEADDRUSE | disallow local address reuse
SO_GROUP_ID | ID of a socket group
SO_GROUP_PRIORITY | the relative priority within a group
SO_KEEPALIVE | keep connections alive
SO_LINGER | linger on close if data present
SO_MAX_MSG_SIZE | maximum message size
SO_OOBINLINE | leave received OOB data in line
SO_OPENTYPE | This is constant nxllJwaWinsock2.SO_OPENTYPE.
SO_PROTOCOL_INFO | This is constant nxllJwaWinsock2.SO_PROTOCOL_INFO.
SO_PROTOCOL_INFOA | WSAPROTOCOL_INFOA structure
SO_PROTOCOL_INFOW | WSAPROTOCOL_INFOW structure
SO_RCVBUF | receive buffer size
SO_RCVLOWAT | receive low-water mark
SO_RCVTIMEO | receive timeout
SO_REUSEADDR | allow local address reuse
SO_SNDBUF | send buffer size
SO_SNDLOWAT | send low-water mark
SO_SNDTIMEO | send timeout
SO_SYNCHRONOUS_ALERT | This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_ALERT.
SO_SYNCHRONOUS_NONALERT | This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_NONALERT.
SO_TYPE | get socket type
SO_USELOOPBACK | bypass hardware when possible
SOCK_DGRAM | datagram socket
SOCK_RAW | raw-protocol interface
SOCK_RDM | reliably-delivered message
SOCK_SEQPACKET | sequenced packet stream
SOCK_STREAM | stream socket
SOCKET_ERROR | This is constant nxllJwaWinsock2.SOCKET_ERROR.
SOL_SOCKET | options for socket level
SOMAXCONN | Maximum queue length specifiable by listen.
TCP_NODELAY | TCP options.
TH_NETDEV | WinSock 2 extension -- manifest constants for SIO_TRANSLATE_HANDLE ioctl
TH_TAPI | This is constant nxllJwaWinsock2.TH_TAPI.
TRY_AGAIN | This is constant nxllJwaWinsock2.TRY_AGAIN.
WINSOCK_VERSION | This is constant nxllJwaWinsock2.WINSOCK_VERSION.
ws2_32 | This is constant nxllJwaWinsock2.ws2_32.
WSA_E_CANCELLED | This is constant nxllJwaWinsock2.WSA_E_CANCELLED.
WSA_E_NO_MORE | This is constant nxllJwaWinsock2.WSA_E_NO_MORE.
WSA_FLAG_MULTIPOINT_C_LEAF | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_LEAF.
WSA_FLAG_MULTIPOINT_C_ROOT | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_ROOT.
WSA_FLAG_MULTIPOINT_D_LEAF | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_LEAF.
WSA_FLAG_MULTIPOINT_D_ROOT | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_ROOT.
WSA_FLAG_OVERLAPPED | WinSock 2 extension -- manifest constants for WSASocket()
WSA_INFINITE | This is constant nxllJwaWinsock2.WSA_INFINITE.
WSA_INVALID_EVENT | This is constant nxllJwaWinsock2.WSA_INVALID_EVENT.
WSA_INVALID_HANDLE | This is constant nxllJwaWinsock2.WSA_INVALID_HANDLE.
WSA_INVALID_PARAMETER | This is constant nxllJwaWinsock2.WSA_INVALID_PARAMETER.
WSA_IO_INCOMPLETE | This is constant nxllJwaWinsock2.WSA_IO_INCOMPLETE.
WSA_IO_PENDING | This is constant nxllJwaWinsock2.WSA_IO_PENDING.
WSA_MAXIMUM_WAIT_EVENTS | This is constant nxllJwaWinsock2.WSA_MAXIMUM_WAIT_EVENTS.
WSA_NOT_ENOUGH_MEMORY | This is constant nxllJwaWinsock2.WSA_NOT_ENOUGH_MEMORY.
WSA_OPERATION_ABORTED | This is constant nxllJwaWinsock2.WSA_OPERATION_ABORTED.
WSA_QOS_ADMISSION_FAILURE | error due to lack of resources
WSA_QOS_BAD_OBJECT | problem with some part of the filterspec or providerspecific buffer in general
WSA_QOS_BAD_STYLE | unknown or conflicting style
WSA_QOS_EFILTERCOUNT | incorrect number of filters
WSA_QOS_EFILTERSTYLE | invalid filter style
WSA_QOS_EFILTERTYPE | invalid filter type
WSA_QOS_EFLOWCOUNT | incorrect number of flows
WSA_QOS_EFLOWDESC | invalid flow descriptor in the list
WSA_QOS_EFLOWSPEC | invalid flowspec
WSA_QOS_EOBJLENGTH | invalid object length
WSA_QOS_EPOLICYOBJ | invalid policy object in provider specific buffer
WSA_QOS_EPROVSPECBUF | invalid provider specific buffer
WSA_QOS_EPSFILTERSPEC | invalid filter spec in provider specific buffer
WSA_QOS_EPSFLOWSPEC | inconsistent flow spec in provider specific buffer
WSA_QOS_ESDMODEOBJ | invalid shape discard mode object in provider specific buffer
WSA_QOS_ESERVICETYPE | invalid service type in flowspec
WSA_QOS_ESHAPERATEOBJ | invalid shaping rate object in provider specific buffer
WSA_QOS_EUNKOWNPSOBJ | unknown object in provider specific buffer
WSA_QOS_GENERIC_ERROR | general error
WSA_QOS_NO_RECEIVERS | there are no receivers
WSA_QOS_NO_SENDERS | there are no senders
WSA_QOS_POLICY_FAILURE | rejected for administrative reasons - bad credentials
WSA_QOS_RECEIVERS | at least one Reserve has arrived
WSA_QOS_REQUEST_CONFIRMED | Reserve has been confirmed
WSA_QOS_RESERVED_PETYPE | reserved policy element in provider specific buffer
WSA_QOS_SENDERS | at least one Path has arrived
WSA_QOS_TRAFFIC_CTRL_ERROR | problem with some part of the flowspec
WSA_WAIT_EVENT_0 | This is constant nxllJwaWinsock2.WSA_WAIT_EVENT_0.
WSA_WAIT_FAILED | This is constant nxllJwaWinsock2.WSA_WAIT_FAILED.
WSA_WAIT_IO_COMPLETION | This is constant nxllJwaWinsock2.WSA_WAIT_IO_COMPLETION.
WSA_WAIT_TIMEOUT | This is constant nxllJwaWinsock2.WSA_WAIT_TIMEOUT.
WSABASEERR | All Windows Sockets error constants are biased by WSABASEERR from the "normal"
WSADESCRIPTION_LEN | This is constant nxllJwaWinsock2.WSADESCRIPTION_LEN.
WSAEACCES | This is constant nxllJwaWinsock2.WSAEACCES.
WSAEADDRINUSE | This is constant nxllJwaWinsock2.WSAEADDRINUSE.
WSAEADDRNOTAVAIL | This is constant nxllJwaWinsock2.WSAEADDRNOTAVAIL.
WSAEAFNOSUPPORT | This is constant nxllJwaWinsock2.WSAEAFNOSUPPORT.
WSAEALREADY | This is constant nxllJwaWinsock2.WSAEALREADY.
WSAEBADF | This is constant nxllJwaWinsock2.WSAEBADF.
WSAECANCELLED | This is constant nxllJwaWinsock2.WSAECANCELLED.
WSAECONNABORTED | This is constant nxllJwaWinsock2.WSAECONNABORTED.
WSAECONNREFUSED | This is constant nxllJwaWinsock2.WSAECONNREFUSED.
WSAECONNRESET | This is constant nxllJwaWinsock2.WSAECONNRESET.
WSAEDESTADDRREQ | This is constant nxllJwaWinsock2.WSAEDESTADDRREQ.
WSAEDISCON | This is constant nxllJwaWinsock2.WSAEDISCON.
WSAEDQUOT | This is constant nxllJwaWinsock2.WSAEDQUOT.
WSAEFAULT | This is constant nxllJwaWinsock2.WSAEFAULT.
WSAEHOSTDOWN | This is constant nxllJwaWinsock2.WSAEHOSTDOWN.
WSAEHOSTUNREACH | This is constant nxllJwaWinsock2.WSAEHOSTUNREACH.
WSAEINPROGRESS | This is constant nxllJwaWinsock2.WSAEINPROGRESS.
WSAEINTR | Windows Sockets definitions of regular Microsoft C error constants
WSAEINVAL | This is constant nxllJwaWinsock2.WSAEINVAL.
WSAEINVALIDPROCTABLE | This is constant nxllJwaWinsock2.WSAEINVALIDPROCTABLE.
WSAEINVALIDPROVIDER | This is constant nxllJwaWinsock2.WSAEINVALIDPROVIDER.
WSAEISCONN | This is constant nxllJwaWinsock2.WSAEISCONN.
WSAELOOP | This is constant nxllJwaWinsock2.WSAELOOP.
WSAEMFILE | This is constant nxllJwaWinsock2.WSAEMFILE.
WSAEMSGSIZE | This is constant nxllJwaWinsock2.WSAEMSGSIZE.
WSAENAMETOOLONG | This is constant nxllJwaWinsock2.WSAENAMETOOLONG.
WSAENETDOWN | This is constant nxllJwaWinsock2.WSAENETDOWN.
WSAENETRESET | This is constant nxllJwaWinsock2.WSAENETRESET.
WSAENETUNREACH | This is constant nxllJwaWinsock2.WSAENETUNREACH.
WSAENOBUFS | This is constant nxllJwaWinsock2.WSAENOBUFS.
WSAENOMORE | This is constant nxllJwaWinsock2.WSAENOMORE.
WSAENOPROTOOPT | This is constant nxllJwaWinsock2.WSAENOPROTOOPT.
WSAENOTCONN | This is constant nxllJwaWinsock2.WSAENOTCONN.
WSAENOTEMPTY | This is constant nxllJwaWinsock2.WSAENOTEMPTY.
WSAENOTSOCK | This is constant nxllJwaWinsock2.WSAENOTSOCK.
WSAEOPNOTSUPP | This is constant nxllJwaWinsock2.WSAEOPNOTSUPP.
WSAEPFNOSUPPORT | This is constant nxllJwaWinsock2.WSAEPFNOSUPPORT.
WSAEPROCLIM | This is constant nxllJwaWinsock2.WSAEPROCLIM.
WSAEPROTONOSUPPORT | This is constant nxllJwaWinsock2.WSAEPROTONOSUPPORT.
WSAEPROTOTYPE | This is constant nxllJwaWinsock2.WSAEPROTOTYPE.
WSAEPROVIDERFAILEDINIT | This is constant nxllJwaWinsock2.WSAEPROVIDERFAILEDINIT.
WSAEREFUSED | This is constant nxllJwaWinsock2.WSAEREFUSED.
WSAEREMOTE | This is constant nxllJwaWinsock2.WSAEREMOTE.
WSAESHUTDOWN | This is constant nxllJwaWinsock2.WSAESHUTDOWN.
WSAESOCKTNOSUPPORT | This is constant nxllJwaWinsock2.WSAESOCKTNOSUPPORT.
WSAESTALE | This is constant nxllJwaWinsock2.WSAESTALE.
WSAETIMEDOUT | This is constant nxllJwaWinsock2.WSAETIMEDOUT.
WSAETOOMANYREFS | This is constant nxllJwaWinsock2.WSAETOOMANYREFS.
WSAEUSERS | This is constant nxllJwaWinsock2.WSAEUSERS.
WSAEWOULDBLOCK | Windows Sockets definitions of regular Berkeley error constants
WSAHOST_NOT_FOUND | Authoritative Answer: Host not found
WSANO_ADDRESS | no address, look for MX record
WSANO_DATA | Valid name, no data record of requested type
WSANO_RECOVERY | Non-recoverable errors, FORMERR, REFUSED, NOTIMP
WSANOTINITIALISED | This is constant nxllJwaWinsock2.WSANOTINITIALISED.
WSAPROTOCOL_LEN | This is constant nxllJwaWinsock2.WSAPROTOCOL_LEN.
WSASERVICE_NOT_FOUND | This is constant nxllJwaWinsock2.WSASERVICE_NOT_FOUND.
WSASYS_STATUS_LEN | This is constant nxllJwaWinsock2.WSASYS_STATUS_LEN.
WSASYSCALLFAILURE | This is constant nxllJwaWinsock2.WSASYSCALLFAILURE.
WSASYSNOTREADY | Extended Windows Sockets error constant definitions
WSATRY_AGAIN | Non-Authoritative: Host not found, or SERVERFAIL
WSATYPE_NOT_FOUND | This is constant nxllJwaWinsock2.WSATYPE_NOT_FOUND.
WSAVERNOTSUPPORTED | This is constant nxllJwaWinsock2.WSAVERNOTSUPPORTED.
XP1_CONNECT_DATA | This is constant nxllJwaWinsock2.XP1_CONNECT_DATA.
XP1_CONNECTIONLESS | Flag bit definitions for dwServiceFlags1
XP1_DISCONNECT_DATA | This is constant nxllJwaWinsock2.XP1_DISCONNECT_DATA.
XP1_EXPEDITED_DATA | This is constant nxllJwaWinsock2.XP1_EXPEDITED_DATA.
XP1_GRACEFUL_CLOSE | This is constant nxllJwaWinsock2.XP1_GRACEFUL_CLOSE.
XP1_GUARANTEED_DELIVERY | This is constant nxllJwaWinsock2.XP1_GUARANTEED_DELIVERY.
XP1_GUARANTEED_ORDER | This is constant nxllJwaWinsock2.XP1_GUARANTEED_ORDER.
XP1_IFS_HANDLES | This is constant nxllJwaWinsock2.XP1_IFS_HANDLES.
XP1_INTERRUPT | This is constant nxllJwaWinsock2.XP1_INTERRUPT.
XP1_MESSAGE_ORIENTED | This is constant nxllJwaWinsock2.XP1_MESSAGE_ORIENTED.
XP1_MULTIPOINT_CONTROL_PLANE | This is constant nxllJwaWinsock2.XP1_MULTIPOINT_CONTROL_PLANE.
XP1_MULTIPOINT_DATA_PLANE | This is constant nxllJwaWinsock2.XP1_MULTIPOINT_DATA_PLANE.
XP1_PARTIAL_MESSAGE | This is constant nxllJwaWinsock2.XP1_PARTIAL_MESSAGE.
XP1_PSEUDO_STREAM | This is constant nxllJwaWinsock2.XP1_PSEUDO_STREAM.
XP1_QOS_SUPPORTED | This is constant nxllJwaWinsock2.XP1_QOS_SUPPORTED.
XP1_SUPPORT_BROADCAST | This is constant nxllJwaWinsock2.XP1_SUPPORT_BROADCAST.
XP1_SUPPORT_MULTIPOINT | This is constant nxllJwaWinsock2.XP1_SUPPORT_MULTIPOINT.
XP1_UNI_RECV | This is constant nxllJwaWinsock2.XP1_UNI_RECV.
XP1_UNI_SEND | This is constant nxllJwaWinsock2.XP1_UNI_SEND.
Functions
Name | Description
__WSAFDIsSet | This is function nxllJwaWinsock2.__WSAFDIsSet.
_FD_SET | This is function nxllJwaWinsock2._FD_SET.
_IO | 0x20000000 distinguishes new & old ioctl's
_IOR | This is function nxllJwaWinsock2._IOR.
_IOW | This is function nxllJwaWinsock2._IOW.
_WSAIO | This is function nxllJwaWinsock2._WSAIO.
_WSAIOR | This is function nxllJwaWinsock2._WSAIOR.
_WSAIORW | This is function nxllJwaWinsock2._WSAIORW.
_WSAIOW | This is function nxllJwaWinsock2._WSAIOW.
accept | Socket function prototypes
bind | This is function nxllJwaWinsock2.bind.
closesocket | This is function nxllJwaWinsock2.closesocket.
connect | This is function nxllJwaWinsock2.connect.
FD_CLR | This is function nxllJwaWinsock2.FD_CLR.
FD_ISSET | This is function nxllJwaWinsock2.FD_ISSET.
FD_ZERO | EXTERNALSYM FD_SET
gethostbyaddr | Database function prototypes
gethostbyname | This is function nxllJwaWinsock2.gethostbyname.
gethostname | This is function nxllJwaWinsock2.gethostname.
getpeername | This is function nxllJwaWinsock2.getpeername.
getprotobyname | This is function nxllJwaWinsock2.getprotobyname.
getprotobynumber | This is function nxllJwaWinsock2.getprotobynumber.
getservbyname | This is function nxllJwaWinsock2.getservbyname.
getservbyport | This is function nxllJwaWinsock2.getservbyport.
getsockname | This is function nxllJwaWinsock2.getsockname.
getsockopt | This is function nxllJwaWinsock2.getsockopt.
h_errno | Compatibility macros.
htonl | This is function nxllJwaWinsock2.htonl.
htons | This is function nxllJwaWinsock2.htons.
IN_CLASSA | Definitions of bits in internet address integers. On subnets, the decomposition of addresses to host and net parts is done according to subnet mask, not the masks here.
IN_CLASSB | This is function nxllJwaWinsock2.IN_CLASSB.
IN_CLASSC | This is function nxllJwaWinsock2.IN_CLASSC.
IN_CLASSD | This is function nxllJwaWinsock2.IN_CLASSD.
IN_MULTICAST | This is function nxllJwaWinsock2.IN_MULTICAST.
inet_addr | This is function nxllJwaWinsock2.inet_addr.
inet_ntoa | This is function nxllJwaWinsock2.inet_ntoa.
ioctlsocket | This is function nxllJwaWinsock2.ioctlsocket.
listen | This is function nxllJwaWinsock2.listen.
ntohl | This is function nxllJwaWinsock2.ntohl.
ntohs | This is function nxllJwaWinsock2.ntohs.
recv | This is function nxllJwaWinsock2.recv.
recvfrom | This is function nxllJwaWinsock2.recvfrom.
select | This is function nxllJwaWinsock2.select.
send | This is function nxllJwaWinsock2.send.
sendto | This is function nxllJwaWinsock2.sendto.
setsockopt | This is function nxllJwaWinsock2.setsockopt.
shutdown | This is function nxllJwaWinsock2.shutdown.
socket | This is function nxllJwaWinsock2.socket.
timerclear | function timercmp(const tvp, uvp: TTimeVal; cmp): Boolean; {$EXTERNALSYM timercmp}
timerisset | Operations on timevals. NB: timercmp does not work for >= or <=.
WSAAccept | WinSock 2 API new function prototypes
WSAAddressToString | This is function nxllJwaWinsock2.WSAAddressToString.
WSAAddressToString | This is function nxllJwaWinsock2.WSAAddressToString.
WSAAddressToStringA | This is function nxllJwaWinsock2.WSAAddressToStringA.
WSAAddressToStringW | This is function nxllJwaWinsock2.WSAAddressToStringW.
WSAAsyncGetHostByAddr | This is function nxllJwaWinsock2.WSAAsyncGetHostByAddr.
WSAAsyncGetHostByName | This is function nxllJwaWinsock2.WSAAsyncGetHostByName.
WSAAsyncGetProtoByName | This is function nxllJwaWinsock2.WSAAsyncGetProtoByName.
WSAAsyncGetProtoByNumber | This is function nxllJwaWinsock2.WSAAsyncGetProtoByNumber.
WSAAsyncGetServByName | This is function nxllJwaWinsock2.WSAAsyncGetServByName.
WSAAsyncGetServByPort | This is function nxllJwaWinsock2.WSAAsyncGetServByPort.
WSAAsyncSelect | This is function nxllJwaWinsock2.WSAAsyncSelect.
WSACancelAsyncRequest | This is function nxllJwaWinsock2.WSACancelAsyncRequest.
WSACancelBlockingCall | This is function nxllJwaWinsock2.WSACancelBlockingCall.
WSACleanup | This is function nxllJwaWinsock2.WSACleanup.
WSACloseEvent | This is function nxllJwaWinsock2.WSACloseEvent.
WSAConnect | This is function nxllJwaWinsock2.WSAConnect.
WSACreateEvent | This is function nxllJwaWinsock2.WSACreateEvent.
WSADuplicateSocket | This is function nxllJwaWinsock2.WSADuplicateSocket.
WSADuplicateSocket | This is function nxllJwaWinsock2.WSADuplicateSocket.
WSADuplicateSocketA | This is function nxllJwaWinsock2.WSADuplicateSocketA.
WSADuplicateSocketW | This is function nxllJwaWinsock2.WSADuplicateSocketW.
WSAEnumNameSpaceProviders | This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.
WSAEnumNameSpaceProviders | This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.
WSAEnumNameSpaceProvidersA | This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersA.
WSAEnumNameSpaceProvidersW | This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersW.
WSAEnumNetworkEvents | This is function nxllJwaWinsock2.WSAEnumNetworkEvents.
WSAEnumProtocols | This is function nxllJwaWinsock2.WSAEnumProtocols.
WSAEnumProtocols | This is function nxllJwaWinsock2.WSAEnumProtocols.
WSAEnumProtocolsA | This is function nxllJwaWinsock2.WSAEnumProtocolsA.
WSAEnumProtocolsW | This is function nxllJwaWinsock2.WSAEnumProtocolsW.
WSAEventSelect | This is function nxllJwaWinsock2.WSAEventSelect.
WSAGETASYNCBUFLEN | WSAGETASYNCBUFLEN is intended for use by the Windows Sockets application to extract the buffer length from the lParam in the response to a WSAAsyncGetXByY().
WSAGETASYNCERROR | WSAGETASYNCERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAGetXByY().
WSAGetLastError | This is function nxllJwaWinsock2.WSAGetLastError.
WSAGetOverlappedResult | Thanks Kai Henningsen for var on lpdwFlags
WSAGetQOSByName | This is function nxllJwaWinsock2.WSAGetQOSByName.
WSAGETSELECTERROR | WSAGETSELECTERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAAsyncSelect().
WSAGETSELECTEVENT | WSAGETSELECTEVENT is intended for use by the Windows Sockets application to extract the event code from the lParam in the response to a WSAAsyncSelect().
WSAGetServiceClassInfo | This is function nxllJwaWinsock2.WSAGetServiceClassInfo.
WSAGetServiceClassInfo | This is function nxllJwaWinsock2.WSAGetServiceClassInfo.
WSAGetServiceClassInfoA | This is function nxllJwaWinsock2.WSAGetServiceClassInfoA.
WSAGetServiceClassInfoW | This is function nxllJwaWinsock2.WSAGetServiceClassInfoW.
WSAGetServiceClassNameByClassId | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.
WSAGetServiceClassNameByClassId | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.
WSAGetServiceClassNameByClassIdA | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdA.
WSAGetServiceClassNameByClassIdW | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdW.
WSAHtonl | This is function nxllJwaWinsock2.WSAHtonl.
WSAHtons | This is function nxllJwaWinsock2.WSAHtons.
WSAInstallServiceClass | This is function nxllJwaWinsock2.WSAInstallServiceClass.
WSAInstallServiceClass | This is function nxllJwaWinsock2.WSAInstallServiceClass.
WSAInstallServiceClassA | This is function nxllJwaWinsock2.WSAInstallServiceClassA.
WSAInstallServiceClassW | This is function nxllJwaWinsock2.WSAInstallServiceClassW.
WSAIoctl | This is function nxllJwaWinsock2.WSAIoctl.
WSAIsBlocking | This is function nxllJwaWinsock2.WSAIsBlocking.
WSAJoinLeaf | This is function nxllJwaWinsock2.WSAJoinLeaf.
WSALookupServiceBegin | This is function nxllJwaWinsock2.WSALookupServiceBegin.
WSALookupServiceBegin | This is function nxllJwaWinsock2.WSALookupServiceBegin.
WSALookupServiceBeginA | Registration and Name Resolution API functions
WSALookupServiceBeginW | This is function nxllJwaWinsock2.WSALookupServiceBeginW.
WSALookupServiceEnd | This is function nxllJwaWinsock2.WSALookupServiceEnd.
WSALookupServiceNext | This is function nxllJwaWinsock2.WSALookupServiceNext.
WSALookupServiceNext | This is function nxllJwaWinsock2.WSALookupServiceNext.
WSALookupServiceNextA | This is function nxllJwaWinsock2.WSALookupServiceNextA.
WSALookupServiceNextW | This is function nxllJwaWinsock2.WSALookupServiceNextW.
WSAMAKEASYNCREPLY | Windows message parameter composition and decomposition macros. WSAMAKEASYNCREPLY is intended for use by the Windows Sockets implementation when constructing the response to a WSAAsyncGetXByY() routine.
WSAMAKESELECTREPLY | WSAMAKESELECTREPLY is intended for use by the Windows Sockets implementation when constructing the response to WSAAsyncSelect().
WSANSPIoctl | This is function nxllJwaWinsock2.WSANSPIoctl.
WSANtohl | This is function nxllJwaWinsock2.WSANtohl.
WSANtohs | This is function nxllJwaWinsock2.WSANtohs.
WSAProviderConfigChange | This is function nxllJwaWinsock2.WSAProviderConfigChange.
WSARecv | This is function nxllJwaWinsock2.WSARecv.
WSARecvDisconnect | This is function nxllJwaWinsock2.WSARecvDisconnect.
WSARecvFrom | This is function nxllJwaWinsock2.WSARecvFrom.
WSARemoveServiceClass | This is function nxllJwaWinsock2.WSARemoveServiceClass.
WSAResetEvent | This is function nxllJwaWinsock2.WSAResetEvent.
WSASend | This is function nxllJwaWinsock2.WSASend.
WSASendDisconnect | This is function nxllJwaWinsock2.WSASendDisconnect.
WSASendTo | This is function nxllJwaWinsock2.WSASendTo.
WSASetBlockingHook | This is function nxllJwaWinsock2.WSASetBlockingHook.
WSASetEvent | This is function nxllJwaWinsock2.WSASetEvent.
WSASetLastError | This is function nxllJwaWinsock2.WSASetLastError.
WSASetService | This is function nxllJwaWinsock2.WSASetService.
WSASetService | This is function nxllJwaWinsock2.WSASetService.
WSASetServiceA | This is function nxllJwaWinsock2.WSASetServiceA.
WSASetServiceW | This is function nxllJwaWinsock2.WSASetServiceW.
WSASocket | This is function nxllJwaWinsock2.WSASocket.
WSASocket | This is function nxllJwaWinsock2.WSASocket.
WSASocketA | This is function nxllJwaWinsock2.WSASocketA.
WSASocketW | This is function nxllJwaWinsock2.WSASocketW.
WSAStartup | Microsoft Windows Extension function prototypes
WSAStringToAddress | This is function nxllJwaWinsock2.WSAStringToAddress.
WSAStringToAddress | This is function nxllJwaWinsock2.WSAStringToAddress.
WSAStringToAddressA | This is function nxllJwaWinsock2.WSAStringToAddressA.
WSAStringToAddressW | This is function nxllJwaWinsock2.WSAStringToAddressW.
WSAUnhookBlockingHook | This is function nxllJwaWinsock2.WSAUnhookBlockingHook.
WSAWaitForMultipleEvents | This is function nxllJwaWinsock2.WSAWaitForMultipleEvents.
Structs, Records, Enums
Name | Description
_AFPROTOCOLS | This is record nxllJwaWinsock2._AFPROTOCOLS.
_BLOB | Manifest constants and type definitions related to name resolution and registration (RNR) API
_CSADDR_INFO | This is record nxllJwaWinsock2._CSADDR_INFO.
_QualityOfService | This is record nxllJwaWinsock2._QualityOfService.
_SOCKET_ADDRESS | This is record nxllJwaWinsock2._SOCKET_ADDRESS.
_SOCKET_ADDRESS_LIST | This is record nxllJwaWinsock2._SOCKET_ADDRESS_LIST.
_WSABUF | WinSock 2 extension -- WSABUF and QOS struct, include qos.h to pull in FLOWSPEC and related definitions
_WSACOMPLETION | This is record nxllJwaWinsock2._WSACOMPLETION.
_WSACOMPLETIONTYPE | This is record nxllJwaWinsock2._WSACOMPLETIONTYPE.
_WSAEcomparator | The comparators
_WSAESETSERVICEOP | Service Address Registration and Deregistration Data Types.
_WSANAMESPACE_INFOA | This is record nxllJwaWinsock2._WSANAMESPACE_INFOA.
_WSANAMESPACE_INFOW | This is record nxllJwaWinsock2._WSANAMESPACE_INFOW.
_WSANETWORKEVENTS | WinSock 2 extension -- data type for WSAEnumNetworkEvents()
_WSANSClassInfoA | Service Installation/Removal Data Types.
_WSANSClassInfoW | This is record nxllJwaWinsock2._WSANSClassInfoW.
_WSAPROTOCOL_INFOA | This is record nxllJwaWinsock2._WSAPROTOCOL_INFOA.
_WSAPROTOCOL_INFOW | This is record nxllJwaWinsock2._WSAPROTOCOL_INFOW.
_WSAPROTOCOLCHAIN | This is record nxllJwaWinsock2._WSAPROTOCOLCHAIN.
_WSAQuerySetA | This is record nxllJwaWinsock2._WSAQuerySetA.
_WSAQuerySetW | This is record nxllJwaWinsock2._WSAQuerySetW.
_WSAServiceClassInfoA | This is record nxllJwaWinsock2._WSAServiceClassInfoA.
_WSAServiceClassInfoW | This is record nxllJwaWinsock2._WSAServiceClassInfoW.
_WSAVersion | This is record nxllJwaWinsock2._WSAVersion.
fd_set | This is record nxllJwaWinsock2.fd_set.
hostent | Structures returned by network data base library, taken from the BSD file netdb.h. All addresses are supplied in host order, and returned in network order (suitable for use in system calls).
in_addr | This is record nxllJwaWinsock2.in_addr.
linger | Structure used for manipulating linger option.
netent | It is assumed here that a network number fits in 32 bits.
protoent | This is record nxllJwaWinsock2.protoent.
servent | This is record nxllJwaWinsock2.servent.
sockaddr | Structure used by kernel to store most addresses.
sockaddr_in | Socket address, internet style.
sockaddr_storage | This is record nxllJwaWinsock2.sockaddr_storage.
sockproto | Structure used by kernel to pass protocol information in raw sockets.
SunB | Internet address (old style... should be updated)
SunC | This is record nxllJwaWinsock2.SunC.
SunW | This is record nxllJwaWinsock2.SunW.
timeval | Structure used in select() call, taken from the BSD file sys/time.h.
WSAData | This is record nxllJwaWinsock2.WSAData.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
AFPROTOCOLS | This is type nxllJwaWinsock2.AFPROTOCOLS.
BLOB | This is type nxllJwaWinsock2.BLOB.
CSADDR_INFO | This is type nxllJwaWinsock2.CSADDR_INFO.
DWORD_PTR | This is type nxllJwaWinsock2.DWORD_PTR.
GROUP | WinSock 2 extension -- data type and manifest constants for socket groups
HANDLE | This is type nxllJwaWinsock2.HANDLE.
LPAFPROTOCOLS | Address Family/Protocol Tuples
LPBLOB | This is type nxllJwaWinsock2.LPBLOB.
LPBYTE | This is type nxllJwaWinsock2.LPBYTE.
LPCONDITIONPROC | WinSock 2 extensions -- data types for the condition function in WSAAccept() and overlapped I/O completion routine.
LPCSADDR_INFO | CSAddr Information
LPFD_SET | This is type nxllJwaWinsock2.LPFD_SET.
LPHANDLE | This is type nxllJwaWinsock2.LPHANDLE.
LPHOSTENT | This is type nxllJwaWinsock2.LPHOSTENT.
LPIN_ADDR | This is type nxllJwaWinsock2.LPIN_ADDR.
LPLINGER | This is type nxllJwaWinsock2.LPLINGER.
LPPROTOENT | This is type nxllJwaWinsock2.LPPROTOENT.
LPQOS | This is type nxllJwaWinsock2.LPQOS.
LPSERVENT | This is type nxllJwaWinsock2.LPSERVENT.
LPSOCKADDR | Microsoft Windows Extended data types required for the functions to convert back and forth between binary and string forms of addresses.
LPSOCKADDR_IN | This is type nxllJwaWinsock2.LPSOCKADDR_IN.
LPSOCKADDR_STORAGE | This is type nxllJwaWinsock2.LPSOCKADDR_STORAGE.
LPSOCKET_ADDRESS | SockAddr Information
LPSOCKET_ADDRESS_LIST | Address list returned via SIO_ADDRESS_LIST_QUERY
LPTIMEVAL | This is type nxllJwaWinsock2.LPTIMEVAL.
LPVOID | This is type nxllJwaWinsock2.LPVOID.
LPWSABUF | This is type nxllJwaWinsock2.LPWSABUF.
LPWSACOMPLETION | This is type nxllJwaWinsock2.LPWSACOMPLETION.
LPWSACOMPLETIONTYPE | This is type nxllJwaWinsock2.LPWSACOMPLETIONTYPE.
LPWSADATA | This is type nxllJwaWinsock2.LPWSADATA.
LPWSAECOMPARATOR | This is type nxllJwaWinsock2.LPWSAECOMPARATOR.
LPWSAESETSERVICEOP | This is type nxllJwaWinsock2.LPWSAESETSERVICEOP.
LPWSAEVENT | This is type nxllJwaWinsock2.LPWSAEVENT.
LPWSANAMESPACE_INFO | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFO.
LPWSANAMESPACE_INFOA | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOA.
LPWSANAMESPACE_INFOW | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOW.
LPWSANETWORKEVENTS | This is type nxllJwaWinsock2.LPWSANETWORKEVENTS.
LPWSANSCLASSINFO | This is type nxllJwaWinsock2.LPWSANSCLASSINFO.
LPWSANSCLASSINFOA | This is type nxllJwaWinsock2.LPWSANSCLASSINFOA.
LPWSANSCLASSINFOW | This is type nxllJwaWinsock2.LPWSANSCLASSINFOW.
LPWSAOVERLAPPED | This is type nxllJwaWinsock2.LPWSAOVERLAPPED.
LPWSAOVERLAPPED_COMPLETION_ROUTINE | This is type nxllJwaWinsock2.LPWSAOVERLAPPED_COMPLETION_ROUTINE.
LPWSAPROTOCOL_INFO | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFO.
LPWSAPROTOCOL_INFOA | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOA.
LPWSAPROTOCOL_INFOW | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOW.
LPWSAPROTOCOLCHAIN | This is type nxllJwaWinsock2.LPWSAPROTOCOLCHAIN.
LPWSAQUERYSET | This is type nxllJwaWinsock2.LPWSAQUERYSET.
LPWSAQUERYSETA | This is type nxllJwaWinsock2.LPWSAQUERYSETA.
LPWSAQUERYSETW | This is type nxllJwaWinsock2.LPWSAQUERYSETW.
LPWSASERVICECLASSINFO | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFO.
LPWSASERVICECLASSINFOA | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOA.
LPWSASERVICECLASSINFOW | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOW.
LPWSAVERSION | This is type nxllJwaWinsock2.LPWSAVERSION.
PAFPROTOCOLS | This is type nxllJwaWinsock2.PAFPROTOCOLS.
PBlob | This is type nxllJwaWinsock2.PBlob.
PCSADDR_INFO | This is type nxllJwaWinsock2.PCSADDR_INFO.
PCsAddrInfo | This is type nxllJwaWinsock2.PCsAddrInfo.
PFD_SET | This is type nxllJwaWinsock2.PFD_SET.
PFdSet | This is type nxllJwaWinsock2.PFdSet.
PGroup | This is type nxllJwaWinsock2.PGroup.
PHostEnt | This is type nxllJwaWinsock2.PHostEnt.
PIN_ADDR | This is type nxllJwaWinsock2.PIN_ADDR.
PInAddr | This is type nxllJwaWinsock2.PInAddr.
PLinger | This is type nxllJwaWinsock2.PLinger.
PNetEnt | This is type nxllJwaWinsock2.PNetEnt.
PPAnsiChar | This is type nxllJwaWinsock2.PPAnsiChar.
PProtoEnt | This is type nxllJwaWinsock2.PProtoEnt.
PQOS | This is type nxllJwaWinsock2.PQOS.
PServEnt | This is type nxllJwaWinsock2.PServEnt.
PSockAddr | This is type nxllJwaWinsock2.PSockAddr.
PSOCKADDR_IN | Microsoft Windows Extended data types
PSOCKADDR_STORAGE | This is type nxllJwaWinsock2.PSOCKADDR_STORAGE.
PSockAddrIn | This is type nxllJwaWinsock2.PSockAddrIn.
PSockAddrStorage | This is type nxllJwaWinsock2.PSockAddrStorage.
PSOCKET_ADDRESS | This is type nxllJwaWinsock2.PSOCKET_ADDRESS.
PSocketAddress | This is type nxllJwaWinsock2.PSocketAddress.
PSocketAddressList | This is type nxllJwaWinsock2.PSocketAddressList.
PSockProto | This is type nxllJwaWinsock2.PSockProto.
PTimeVal | This is type nxllJwaWinsock2.PTimeVal.
PWsaBuf | This is type nxllJwaWinsock2.PWsaBuf.
PWSACOMPLETION | This is type nxllJwaWinsock2.PWSACOMPLETION.
PWSACOMPLETIONTYPE | This is type nxllJwaWinsock2.PWSACOMPLETIONTYPE.
PWsaData | This is type nxllJwaWinsock2.PWsaData.
PWSAECOMPARATOR | This is type nxllJwaWinsock2.PWSAECOMPARATOR.
PWSAESETSERVICEOP | This is type nxllJwaWinsock2.PWSAESETSERVICEOP.
PWsaEvent | This is type nxllJwaWinsock2.PWsaEvent.
PWSANAMESPACE_INFO | This is type nxllJwaWinsock2.PWSANAMESPACE_INFO.
PWSANAMESPACE_INFOA | This is type nxllJwaWinsock2.PWSANAMESPACE_INFOA.
PWSANAMESPACE_INFOW | This is type nxllJwaWinsock2.PWSANAMESPACE_INFOW.
PWsaNameSpaceInfo | This is type nxllJwaWinsock2.PWsaNameSpaceInfo.
PWsaNameSpaceInfoA | This is type nxllJwaWinsock2.PWsaNameSpaceInfoA.
PWsaNameSpaceInfoW | This is type nxllJwaWinsock2.PWsaNameSpaceInfoW.
PWsaNetworkEvents | This is type nxllJwaWinsock2.PWsaNetworkEvents.
PWSANSCLASSINFO | This is type nxllJwaWinsock2.PWSANSCLASSINFO.
PWSANSCLASSINFOA | This is type nxllJwaWinsock2.PWSANSCLASSINFOA.
PWSANSCLASSINFOW | This is type nxllJwaWinsock2.PWSANSCLASSINFOW.
PWsaOverlapped | This is type nxllJwaWinsock2.PWsaOverlapped.
PWsaProtocolChain | This is type nxllJwaWinsock2.PWsaProtocolChain.
PWsaProtocolInfo | This is type nxllJwaWinsock2.PWsaProtocolInfo.
PWsaProtocolInfoA | This is type nxllJwaWinsock2.PWsaProtocolInfoA.
PWsaProtocolInfoW | This is type nxllJwaWinsock2.PWsaProtocolInfoW.
PWSAQUERYSET | This is type nxllJwaWinsock2.PWSAQUERYSET.
PWSAQUERYSETA | This is type nxllJwaWinsock2.PWSAQUERYSETA.
PWSAQUERYSETW | This is type nxllJwaWinsock2.PWSAQUERYSETW.
PWSASERVICECLASSINFO | This is type nxllJwaWinsock2.PWSASERVICECLASSINFO.
PWSASERVICECLASSINFOA | This is type nxllJwaWinsock2.PWSASERVICECLASSINFOA.
PWSASERVICECLASSINFOW | This is type nxllJwaWinsock2.PWSASERVICECLASSINFOW.
PWSAVERSION | This is type nxllJwaWinsock2.PWSAVERSION.
QOS | This is type nxllJwaWinsock2.QOS.
SOCKET_ADDRESS | This is type nxllJwaWinsock2.SOCKET_ADDRESS.
SOCKET_ADDRESS_LIST | This is type nxllJwaWinsock2.SOCKET_ADDRESS_LIST.
TAfProtocols | This is type nxllJwaWinsock2.TAfProtocols.
TBlob | This is type nxllJwaWinsock2.TBlob.
TCsAddrInfo | This is type nxllJwaWinsock2.TCsAddrInfo.
TFdSet | This is type nxllJwaWinsock2.TFdSet.
TGroup | This is type nxllJwaWinsock2.TGroup.
THostEnt | This is type nxllJwaWinsock2.THostEnt.
TInAddr | This is type nxllJwaWinsock2.TInAddr.
TLinger | This is type nxllJwaWinsock2.TLinger.
TNetEnt | This is type nxllJwaWinsock2.TNetEnt.
TProtoEnt | This is type nxllJwaWinsock2.TProtoEnt.
TQOS | This is type nxllJwaWinsock2.TQOS.
TServEnt | This is type nxllJwaWinsock2.TServEnt.
TSockAddr | This is type nxllJwaWinsock2.TSockAddr.
TSockAddrIn | This is type nxllJwaWinsock2.TSockAddrIn.
TSockAddrStorage | This is type nxllJwaWinsock2.TSockAddrStorage.
TSocket | The new type to be used in all instances which refer to sockets.
TSocketAddress | This is type nxllJwaWinsock2.TSocketAddress.
TSocketAddressList | This is type nxllJwaWinsock2.TSocketAddressList.
TSockProto | This is type nxllJwaWinsock2.TSockProto.
TTimeVal | This is type nxllJwaWinsock2.TTimeVal.
TWsaBuf | This is type nxllJwaWinsock2.TWsaBuf.
TWsaCompletion | This is type nxllJwaWinsock2.TWsaCompletion.
TWsaCompletionType | This is type nxllJwaWinsock2.TWsaCompletionType.
TWsaData | This is type nxllJwaWinsock2.TWsaData.
TWsaEvent | This is type nxllJwaWinsock2.TWsaEvent.
TWsaNameSpaceInfo | This is type nxllJwaWinsock2.TWsaNameSpaceInfo.
TWsaNameSpaceInfoA | This is type nxllJwaWinsock2.TWsaNameSpaceInfoA.
TWsaNameSpaceInfoW | This is type nxllJwaWinsock2.TWsaNameSpaceInfoW.
TWsaNetworkEvents | This is type nxllJwaWinsock2.TWsaNetworkEvents.
TWsaNsClassInfo | This is type nxllJwaWinsock2.TWsaNsClassInfo.
TWsaNsClassInfoA | This is type nxllJwaWinsock2.TWsaNsClassInfoA.
TWsaNsClassInfoW | This is type nxllJwaWinsock2.TWsaNsClassInfoW.
TWsaOverlapped | This is type nxllJwaWinsock2.TWsaOverlapped.
TWsaProtocolChain | This is type nxllJwaWinsock2.TWsaProtocolChain.
TWsaProtocolInfo | This is type nxllJwaWinsock2.TWsaProtocolInfo.
TWsaProtocolInfoA | This is type nxllJwaWinsock2.TWsaProtocolInfoA.
TWsaProtocolInfoW | This is type nxllJwaWinsock2.TWsaProtocolInfoW.
TWsaQuerySet | This is type nxllJwaWinsock2.TWsaQuerySet.
TWsaQuerySetA | This is type nxllJwaWinsock2.TWsaQuerySetA.
TWsaQuerySetW | This is type nxllJwaWinsock2.TWsaQuerySetW.
TWsaServiceClassInfo | This is type nxllJwaWinsock2.TWsaServiceClassInfo.
TWsaServiceClassInfoA | This is type nxllJwaWinsock2.TWsaServiceClassInfoA.
TWsaServiceClassInfoW | This is type nxllJwaWinsock2.TWsaServiceClassInfoW.
TWsaVersion | This is type nxllJwaWinsock2.TWsaVersion.
u_char | Basic system type definitions, taken from the BSD file sys/types.h.
u_int | This is type nxllJwaWinsock2.u_int.
u_int64 | unsigned __int64 !! TODO For Delphi 7 ??
u_long | This is type nxllJwaWinsock2.u_long.
u_short | This is type nxllJwaWinsock2.u_short.
UCHAR | This is type nxllJwaWinsock2.UCHAR.
ULONG | This is type nxllJwaWinsock2.ULONG.
ULONG_PTR | TODO
USHORT | This is type nxllJwaWinsock2.USHORT.
WSABUF | This is type nxllJwaWinsock2.WSABUF.
WSACOMPLETION | This is type nxllJwaWinsock2.WSACOMPLETION.
WSACOMPLETIONTYPE | This is type nxllJwaWinsock2.WSACOMPLETIONTYPE.
WSAECOMPARATOR | This is type nxllJwaWinsock2.WSAECOMPARATOR.
WSAESETSERVICEOP | This is type nxllJwaWinsock2.WSAESETSERVICEOP.
WSAEVENT | WinSock 2 extension -- new error codes and type definition
WSANAMESPACE_INFO | This is type nxllJwaWinsock2.WSANAMESPACE_INFO.
WSANAMESPACE_INFOA | This is type nxllJwaWinsock2.WSANAMESPACE_INFOA.
WSANAMESPACE_INFOW | This is type nxllJwaWinsock2.WSANAMESPACE_INFOW.
WSANETWORKEVENTS | This is type nxllJwaWinsock2.WSANETWORKEVENTS.
WSANSCLASSINFO | This is type nxllJwaWinsock2.WSANSCLASSINFO.
WSANSCLASSINFOA | This is type nxllJwaWinsock2.WSANSCLASSINFOA.
WSANSCLASSINFOW | This is type nxllJwaWinsock2.WSANSCLASSINFOW.
WSAOVERLAPPED | This is type nxllJwaWinsock2.WSAOVERLAPPED.
WSAPROTOCOL_INFO | This is type nxllJwaWinsock2.WSAPROTOCOL_INFO.
WSAPROTOCOL_INFOA | This is type nxllJwaWinsock2.WSAPROTOCOL_INFOA.
WSAPROTOCOL_INFOW | This is type nxllJwaWinsock2.WSAPROTOCOL_INFOW.
WSAPROTOCOLCHAIN | This is type nxllJwaWinsock2.WSAPROTOCOLCHAIN.
WSAQUERYSET | This is type nxllJwaWinsock2.WSAQUERYSET.
WSAQUERYSETA | This is type nxllJwaWinsock2.WSAQUERYSETA.
WSAQUERYSETW | This is type nxllJwaWinsock2.WSAQUERYSETW.
WSASERVICECLASSINFO | This is type nxllJwaWinsock2.WSASERVICECLASSINFO.
WSASERVICECLASSINFOA | This is type nxllJwaWinsock2.WSASERVICECLASSINFOA.
WSASERVICECLASSINFOW | This is type nxllJwaWinsock2.WSASERVICECLASSINFOW.
WSAVERSION | This is type nxllJwaWinsock2.WSAVERSION.
Variables
Name | Description
___WSAFDIsSet | This is variable nxllJwaWinsock2.___WSAFDIsSet.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxllJwaWinsock2 Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
__WSAFDIsSet | This is function nxllJwaWinsock2.__WSAFDIsSet.
_FD_SET | This is function nxllJwaWinsock2._FD_SET.
_IO | 0x20000000 distinguishes new & old ioctl's
_IOR | This is function nxllJwaWinsock2._IOR.
_IOW | This is function nxllJwaWinsock2._IOW.
_WSAIO | This is function nxllJwaWinsock2._WSAIO.
_WSAIOR | This is function nxllJwaWinsock2._WSAIOR.
_WSAIORW | This is function nxllJwaWinsock2._WSAIORW.
_WSAIOW | This is function nxllJwaWinsock2._WSAIOW.
accept | Socket function prototypes
bind | This is function nxllJwaWinsock2.bind.
closesocket | This is function nxllJwaWinsock2.closesocket.
connect | This is function nxllJwaWinsock2.connect.
FD_CLR | This is function nxllJwaWinsock2.FD_CLR.
FD_ISSET | This is function nxllJwaWinsock2.FD_ISSET.
FD_ZERO | EXTERNALSYM FD_SET
gethostbyaddr | Database function prototypes
gethostbyname | This is function nxllJwaWinsock2.gethostbyname.
gethostname | This is function nxllJwaWinsock2.gethostname.
getpeername | This is function nxllJwaWinsock2.getpeername.
getprotobyname | This is function nxllJwaWinsock2.getprotobyname.
getprotobynumber | This is function nxllJwaWinsock2.getprotobynumber.
getservbyname | This is function nxllJwaWinsock2.getservbyname.
getservbyport | This is function nxllJwaWinsock2.getservbyport.
getsockname | This is function nxllJwaWinsock2.getsockname.
getsockopt | This is function nxllJwaWinsock2.getsockopt.
h_errno | Compatibility macros.
htonl | This is function nxllJwaWinsock2.htonl.
htons | This is function nxllJwaWinsock2.htons.
IN_CLASSA | Definitions of bits in internet address integers. On subnets, the decomposition of addresses to host and net parts is done according to subnet mask, not the masks here.
IN_CLASSB | This is function nxllJwaWinsock2.IN_CLASSB.
IN_CLASSC | This is function nxllJwaWinsock2.IN_CLASSC.
IN_CLASSD | This is function nxllJwaWinsock2.IN_CLASSD.
IN_MULTICAST | This is function nxllJwaWinsock2.IN_MULTICAST.
inet_addr | This is function nxllJwaWinsock2.inet_addr.
inet_ntoa | This is function nxllJwaWinsock2.inet_ntoa.
ioctlsocket | This is function nxllJwaWinsock2.ioctlsocket.
listen | This is function nxllJwaWinsock2.listen.
ntohl | This is function nxllJwaWinsock2.ntohl.
ntohs | This is function nxllJwaWinsock2.ntohs.
recv | This is function nxllJwaWinsock2.recv.
recvfrom | This is function nxllJwaWinsock2.recvfrom.
select | This is function nxllJwaWinsock2.select.
send | This is function nxllJwaWinsock2.send.
sendto | This is function nxllJwaWinsock2.sendto.
setsockopt | This is function nxllJwaWinsock2.setsockopt.
shutdown | This is function nxllJwaWinsock2.shutdown.
socket | This is function nxllJwaWinsock2.socket.
timerclear | function timercmp(const tvp, uvp: TTimeVal; cmp): Boolean; {$EXTERNALSYM timercmp}
timerisset | Operations on timevals. NB: timercmp does not work for >= or <=.
WSAAccept | WinSock 2 API new function prototypes
WSAAddressToString | This is function nxllJwaWinsock2.WSAAddressToString.
WSAAddressToString | This is function nxllJwaWinsock2.WSAAddressToString.
WSAAddressToStringA | This is function nxllJwaWinsock2.WSAAddressToStringA.
WSAAddressToStringW | This is function nxllJwaWinsock2.WSAAddressToStringW.
WSAAsyncGetHostByAddr | This is function nxllJwaWinsock2.WSAAsyncGetHostByAddr.
WSAAsyncGetHostByName | This is function nxllJwaWinsock2.WSAAsyncGetHostByName.
WSAAsyncGetProtoByName | This is function nxllJwaWinsock2.WSAAsyncGetProtoByName.
WSAAsyncGetProtoByNumber | This is function nxllJwaWinsock2.WSAAsyncGetProtoByNumber.
WSAAsyncGetServByName | This is function nxllJwaWinsock2.WSAAsyncGetServByName.
WSAAsyncGetServByPort | This is function nxllJwaWinsock2.WSAAsyncGetServByPort.
WSAAsyncSelect | This is function nxllJwaWinsock2.WSAAsyncSelect.
WSACancelAsyncRequest | This is function nxllJwaWinsock2.WSACancelAsyncRequest.
WSACancelBlockingCall | This is function nxllJwaWinsock2.WSACancelBlockingCall.
WSACleanup | This is function nxllJwaWinsock2.WSACleanup.
WSACloseEvent | This is function nxllJwaWinsock2.WSACloseEvent.
WSAConnect | This is function nxllJwaWinsock2.WSAConnect.
WSACreateEvent | This is function nxllJwaWinsock2.WSACreateEvent.
WSADuplicateSocket | This is function nxllJwaWinsock2.WSADuplicateSocket.
WSADuplicateSocket | This is function nxllJwaWinsock2.WSADuplicateSocket.
WSADuplicateSocketA | This is function nxllJwaWinsock2.WSADuplicateSocketA.
WSADuplicateSocketW | This is function nxllJwaWinsock2.WSADuplicateSocketW.
WSAEnumNameSpaceProviders | This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.
WSAEnumNameSpaceProviders | This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.
WSAEnumNameSpaceProvidersA | This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersA.
WSAEnumNameSpaceProvidersW | This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersW.
WSAEnumNetworkEvents | This is function nxllJwaWinsock2.WSAEnumNetworkEvents.
WSAEnumProtocols | This is function nxllJwaWinsock2.WSAEnumProtocols.
WSAEnumProtocols | This is function nxllJwaWinsock2.WSAEnumProtocols.
WSAEnumProtocolsA | This is function nxllJwaWinsock2.WSAEnumProtocolsA.
WSAEnumProtocolsW | This is function nxllJwaWinsock2.WSAEnumProtocolsW.
WSAEventSelect | This is function nxllJwaWinsock2.WSAEventSelect.
WSAGETASYNCBUFLEN | WSAGETASYNCBUFLEN is intended for use by the Windows Sockets application to extract the buffer length from the lParam in the response to a WSAAsyncGetXByY().
WSAGETASYNCERROR | WSAGETASYNCERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAGetXByY().
WSAGetLastError | This is function nxllJwaWinsock2.WSAGetLastError.
WSAGetOverlappedResult | Thanks Kai Henningsen for var on lpdwFlags
WSAGetQOSByName | This is function nxllJwaWinsock2.WSAGetQOSByName.
WSAGETSELECTERROR | WSAGETSELECTERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAAsyncSelect().
WSAGETSELECTEVENT | WSAGETSELECTEVENT is intended for use by the Windows Sockets application to extract the event code from the lParam in the response to a WSAAsyncSelect().
WSAGetServiceClassInfo | This is function nxllJwaWinsock2.WSAGetServiceClassInfo.
WSAGetServiceClassInfo | This is function nxllJwaWinsock2.WSAGetServiceClassInfo.
WSAGetServiceClassInfoA | This is function nxllJwaWinsock2.WSAGetServiceClassInfoA.
WSAGetServiceClassInfoW | This is function nxllJwaWinsock2.WSAGetServiceClassInfoW.
WSAGetServiceClassNameByClassId | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.
WSAGetServiceClassNameByClassId | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.
WSAGetServiceClassNameByClassIdA | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdA.
WSAGetServiceClassNameByClassIdW | This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdW.
WSAHtonl | This is function nxllJwaWinsock2.WSAHtonl.
WSAHtons | This is function nxllJwaWinsock2.WSAHtons.
WSAInstallServiceClass | This is function nxllJwaWinsock2.WSAInstallServiceClass.
WSAInstallServiceClass | This is function nxllJwaWinsock2.WSAInstallServiceClass.
WSAInstallServiceClassA | This is function nxllJwaWinsock2.WSAInstallServiceClassA.
WSAInstallServiceClassW | This is function nxllJwaWinsock2.WSAInstallServiceClassW.
WSAIoctl | This is function nxllJwaWinsock2.WSAIoctl.
WSAIsBlocking | This is function nxllJwaWinsock2.WSAIsBlocking.
WSAJoinLeaf | This is function nxllJwaWinsock2.WSAJoinLeaf.
WSALookupServiceBegin | This is function nxllJwaWinsock2.WSALookupServiceBegin.
WSALookupServiceBegin | This is function nxllJwaWinsock2.WSALookupServiceBegin.
WSALookupServiceBeginA | Registration and Name Resolution API functions
WSALookupServiceBeginW | This is function nxllJwaWinsock2.WSALookupServiceBeginW.
WSALookupServiceEnd | This is function nxllJwaWinsock2.WSALookupServiceEnd.
WSALookupServiceNext | This is function nxllJwaWinsock2.WSALookupServiceNext.
WSALookupServiceNext | This is function nxllJwaWinsock2.WSALookupServiceNext.
WSALookupServiceNextA | This is function nxllJwaWinsock2.WSALookupServiceNextA.
WSALookupServiceNextW | This is function nxllJwaWinsock2.WSALookupServiceNextW.
WSAMAKEASYNCREPLY | Windows message parameter composition and decomposition macros. WSAMAKEASYNCREPLY is intended for use by the Windows Sockets implementation when constructing the response to a WSAAsyncGetXByY() routine.
WSAMAKESELECTREPLY | WSAMAKESELECTREPLY is intended for use by the Windows Sockets implementation when constructing the response to WSAAsyncSelect().
WSANSPIoctl | This is function nxllJwaWinsock2.WSANSPIoctl.
WSANtohl | This is function nxllJwaWinsock2.WSANtohl.
WSANtohs | This is function nxllJwaWinsock2.WSANtohs.
WSAProviderConfigChange | This is function nxllJwaWinsock2.WSAProviderConfigChange.
WSARecv | This is function nxllJwaWinsock2.WSARecv.
WSARecvDisconnect | This is function nxllJwaWinsock2.WSARecvDisconnect.
WSARecvFrom | This is function nxllJwaWinsock2.WSARecvFrom.
WSARemoveServiceClass | This is function nxllJwaWinsock2.WSARemoveServiceClass.
WSAResetEvent | This is function nxllJwaWinsock2.WSAResetEvent.
WSASend | This is function nxllJwaWinsock2.WSASend.
WSASendDisconnect | This is function nxllJwaWinsock2.WSASendDisconnect.
WSASendTo | This is function nxllJwaWinsock2.WSASendTo.
WSASetBlockingHook | This is function nxllJwaWinsock2.WSASetBlockingHook.
WSASetEvent | This is function nxllJwaWinsock2.WSASetEvent.
WSASetLastError | This is function nxllJwaWinsock2.WSASetLastError.
WSASetService | This is function nxllJwaWinsock2.WSASetService.
WSASetService | This is function nxllJwaWinsock2.WSASetService.
WSASetServiceA | This is function nxllJwaWinsock2.WSASetServiceA.
WSASetServiceW | This is function nxllJwaWinsock2.WSASetServiceW.
WSASocket | This is function nxllJwaWinsock2.WSASocket.
WSASocket | This is function nxllJwaWinsock2.WSASocket.
WSASocketA | This is function nxllJwaWinsock2.WSASocketA.
WSASocketW | This is function nxllJwaWinsock2.WSASocketW.
WSAStartup | Microsoft Windows Extension function prototypes
WSAStringToAddress | This is function nxllJwaWinsock2.WSAStringToAddress.
WSAStringToAddress | This is function nxllJwaWinsock2.WSAStringToAddress.
WSAStringToAddressA | This is function nxllJwaWinsock2.WSAStringToAddressA.
WSAStringToAddressW | This is function nxllJwaWinsock2.WSAStringToAddressW.
WSAUnhookBlockingHook | This is function nxllJwaWinsock2.WSAUnhookBlockingHook.
WSAWaitForMultipleEvents | This is function nxllJwaWinsock2.WSAWaitForMultipleEvents.
Namespace

nxllJwaWinsock2 Namespace

Links
Functions, nxllJwaWinsock2 Namespace, Legend


nxllJwaWinsock2.__WSAFDIsSet Function

nxllJwaWinsock2.__WSAFDIsSet Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function __WSAFDIsSet(s: TSocket; var FDSet: TFDSet): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.__WSAFDIsSet.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._FD_SET Function

nxllJwaWinsock2._FD_SET Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
procedure _FD_SET(fd: TSocket; var fdset: TFDSet);
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._FD_SET.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._IO Function

nxllJwaWinsock2._IO Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _IO(x: DWORD; y: DWORD): DWORD;
File

nxllJwaWinsock2

Description

0x20000000 distinguishes new & old ioctl's

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._IOR Function

nxllJwaWinsock2._IOR Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _IOR(x: DWORD; y: DWORD; t: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._IOR.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._IOW Function

nxllJwaWinsock2._IOW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _IOW(x: DWORD; y: DWORD; t: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._IOW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._WSAIO Function

nxllJwaWinsock2._WSAIO Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _WSAIO(x: DWORD; y: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._WSAIO.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._WSAIOR Function

nxllJwaWinsock2._WSAIOR Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _WSAIOR(x: DWORD; y: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._WSAIOR.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._WSAIORW Function

nxllJwaWinsock2._WSAIORW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _WSAIORW(x: DWORD; y: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._WSAIORW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2._WSAIOW Function

nxllJwaWinsock2._WSAIOW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function _WSAIOW(x: DWORD; y: DWORD): DWORD;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2._WSAIOW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.accept Function

nxllJwaWinsock2.accept Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function accept(s: TSocket; addr: PSockAddr; addrlen: PINT): TSocket; stdcall;
File

nxllJwaWinsock2

Description

Socket function prototypes

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.bind Function

nxllJwaWinsock2.bind Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function bind(s: TSocket; name: PSockAddr; namelen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.bind.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.closesocket Function

nxllJwaWinsock2.closesocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function closesocket(s: TSocket): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.closesocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.connect Function

nxllJwaWinsock2.connect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function connect(s: TSocket; name: PSockAddr; namelen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.connect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.FD_CLR Function

nxllJwaWinsock2.FD_CLR Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
procedure FD_CLR(fd: TSocket; var fdset: TFdSet);
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.FD_CLR.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.FD_ISSET Function

nxllJwaWinsock2.FD_ISSET Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function FD_ISSET(fd: TSocket; var fdset: TFdSet): Boolean;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.FD_ISSET.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.FD_ZERO Function

nxllJwaWinsock2.FD_ZERO Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
procedure FD_ZERO(var fdset: TFdSet);
File

nxllJwaWinsock2

Description

EXTERNALSYM FD_SET

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.gethostbyaddr Function

nxllJwaWinsock2.gethostbyaddr Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function gethostbyaddr(addr: PAnsiChar; len: Integer; type_: Integer): PHostEnt; stdcall;
File

nxllJwaWinsock2

Description

Database function prototypes

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.gethostbyname Function

nxllJwaWinsock2.gethostbyname Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function gethostbyname(name: PAnsiChar): PHostEnt; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.gethostbyname.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.gethostname Function

nxllJwaWinsock2.gethostname Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function gethostname(name: PAnsiChar; namelen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.gethostname.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getpeername Function

nxllJwaWinsock2.getpeername Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getpeername(s: TSocket; name: PSockAddr; var namelen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getpeername.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getprotobyname Function

nxllJwaWinsock2.getprotobyname Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getprotobyname(name: PAnsiChar): PProtoEnt; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getprotobyname.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getprotobynumber Function

nxllJwaWinsock2.getprotobynumber Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getprotobynumber(number: Integer): PProtoEnt; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getprotobynumber.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getservbyname Function

nxllJwaWinsock2.getservbyname Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getservbyname(name: PAnsiChar; proto: PAnsiChar): PServEnt; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getservbyname.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getservbyport Function

nxllJwaWinsock2.getservbyport Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getservbyport(port: Integer; proto: PAnsiChar): PServEnt; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getservbyport.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getsockname Function

nxllJwaWinsock2.getsockname Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getsockname(s: TSocket; name: PSockAddr; var namelen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getsockname.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.getsockopt Function

nxllJwaWinsock2.getsockopt Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function getsockopt(s: TSocket; level: Integer; optname: Integer; optval: PAnsiChar; var optlen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.getsockopt.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.h_errno Function

nxllJwaWinsock2.h_errno Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function h_errno: Integer;
File

nxllJwaWinsock2

Description

Compatibility macros.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.htonl Function

nxllJwaWinsock2.htonl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function htonl(hostlong: u_long): u_long; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.htonl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.htons Function

nxllJwaWinsock2.htons Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function htons(hostshort: u_short): u_short; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.htons.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.IN_CLASSA Function

nxllJwaWinsock2.IN_CLASSA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function IN_CLASSA(i: DWORD): Boolean;
File

nxllJwaWinsock2

Description

Definitions of bits in internet address integers. On subnets, the decomposition of addresses to host and net parts is done according to subnet mask, not the masks here.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.IN_CLASSB Function

nxllJwaWinsock2.IN_CLASSB Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function IN_CLASSB(i: DWORD): Boolean;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.IN_CLASSB.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.IN_CLASSC Function

nxllJwaWinsock2.IN_CLASSC Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function IN_CLASSC(i: DWORD): Boolean;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.IN_CLASSC.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.IN_CLASSD Function

nxllJwaWinsock2.IN_CLASSD Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function IN_CLASSD(i: DWORD): Boolean;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.IN_CLASSD.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.IN_MULTICAST Function

nxllJwaWinsock2.IN_MULTICAST Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function IN_MULTICAST(i: DWORD): Boolean;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.IN_MULTICAST.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.inet_addr Function

nxllJwaWinsock2.inet_addr Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function inet_addr(cp: PAnsiChar): u_long; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.inet_addr.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.inet_ntoa Function

nxllJwaWinsock2.inet_ntoa Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function inet_ntoa(inaddr: in_addr): PAnsiChar; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.inet_ntoa.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.ioctlsocket Function

nxllJwaWinsock2.ioctlsocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function ioctlsocket(s: TSocket; cmd: Longint; var argp: u_long): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.ioctlsocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.listen Function

nxllJwaWinsock2.listen Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function listen(s: TSocket; backlog: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.listen.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.ntohl Function

nxllJwaWinsock2.ntohl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function ntohl(netlong: u_long): u_long; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.ntohl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.ntohs Function

nxllJwaWinsock2.ntohs Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function ntohs(netshort: u_short): u_short; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.ntohs.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.recv Function

nxllJwaWinsock2.recv Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function recv(s: TSocket; var buf; len: Integer; flags: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.recv.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.recvfrom Function

nxllJwaWinsock2.recvfrom Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function recvfrom(s: TSocket; var buf; len: Integer; flags: Integer; from: PSockAddr; var fromlen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.recvfrom.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.select Function

nxllJwaWinsock2.select Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function select(nfds: Integer; readfds: PFdSet; writefds: PFdSet; exceptfds: PFdSet; timeout: PTimeVal): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.select.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.send Function

nxllJwaWinsock2.send Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function send(s: TSocket; var buf; len: Integer; flags: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.send.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.sendto Function

nxllJwaWinsock2.sendto Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function sendto(s: TSocket; var buf; len: Integer; flags: Integer; toaddr: PSockAddr; tolen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.sendto.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.setsockopt Function

nxllJwaWinsock2.setsockopt Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function setsockopt(s: TSocket; level: Integer; optname: Integer; optval: PAnsiChar; optlen: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.setsockopt.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.shutdown Function

nxllJwaWinsock2.shutdown Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function shutdown(s: TSocket; how: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.shutdown.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.socket Function

nxllJwaWinsock2.socket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function socket(af: Integer; type_: Integer; protocol: Integer): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.socket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.timerclear Function

nxllJwaWinsock2.timerclear Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
procedure timerclear(var tvp: TTimeVal);
File

nxllJwaWinsock2

Description

function timercmp(const tvp, uvp: TTimeVal; cmp): Boolean; {$EXTERNALSYM timercmp}

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.timerisset Function

nxllJwaWinsock2.timerisset Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function timerisset(const tvp: TTimeVal): Boolean;
File

nxllJwaWinsock2

Description

Operations on timevals.

NB: timercmp does not work for >= or <=.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAccept Function

nxllJwaWinsock2.WSAAccept Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAccept(s: TSocket; addr: PSockAddr; addrlen: PINT; lpfnCondition: LPCONDITIONPROC; dwCallbackData: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

WinSock 2 API new function prototypes

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAddressToString Function

nxllJwaWinsock2.WSAAddressToString Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAddressToString(lpsaAddress: LPSOCKADDR; dwAddressLength: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOA; lpszAddressString: LPSTR; var lpdwAddressStringLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAddressToString.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAddressToString Function

nxllJwaWinsock2.WSAAddressToString Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAddressToString(lpsaAddress: LPSOCKADDR; dwAddressLength: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOW; lpszAddressString: LPWSTR; var lpdwAddressStringLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAddressToString.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAddressToStringA Function

nxllJwaWinsock2.WSAAddressToStringA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAddressToStringA(lpsaAddress: LPSOCKADDR; dwAddressLength: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOA; lpszAddressString: LPSTR; var lpdwAddressStringLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAddressToStringA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAddressToStringW Function

nxllJwaWinsock2.WSAAddressToStringW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAddressToStringW(lpsaAddress: LPSOCKADDR; dwAddressLength: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOW; lpszAddressString: LPWSTR; var lpdwAddressStringLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAddressToStringW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetHostByAddr Function

nxllJwaWinsock2.WSAAsyncGetHostByAddr Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetHostByAddr(hWnd: HWND; wMsg: u_int; addr: PAnsiChar; len: Integer; type_: Integer; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetHostByAddr.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetHostByName Function

nxllJwaWinsock2.WSAAsyncGetHostByName Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetHostByName(hWnd: HWND; wMsg: u_int; name: PAnsiChar; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetHostByName.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetProtoByName Function

nxllJwaWinsock2.WSAAsyncGetProtoByName Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetProtoByName(hWnd: HWND; wMsg: u_int; name: PAnsiChar; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetProtoByName.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetProtoByNumber Function

nxllJwaWinsock2.WSAAsyncGetProtoByNumber Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetProtoByNumber(hWnd: HWND; wMsg: u_int; number: Integer; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetProtoByNumber.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetServByName Function

nxllJwaWinsock2.WSAAsyncGetServByName Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetServByName(hWnd: HWND; wMsg: u_int; name: PAnsiChar; proto: PAnsiChar; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetServByName.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncGetServByPort Function

nxllJwaWinsock2.WSAAsyncGetServByPort Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncGetServByPort(hWnd: HWND; wMsg: u_int; port: Integer; proto: PAnsiChar; buf: PAnsiChar; buflen: Integer): HANDLE; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncGetServByPort.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAAsyncSelect Function

nxllJwaWinsock2.WSAAsyncSelect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAAsyncSelect(s: TSocket; hWnd: HWND; wMsg: u_int; lEvent: Longint): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAAsyncSelect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSACancelAsyncRequest Function

nxllJwaWinsock2.WSACancelAsyncRequest Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSACancelAsyncRequest(hAsyncTaskHandle: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSACancelAsyncRequest.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSACancelBlockingCall Function

nxllJwaWinsock2.WSACancelBlockingCall Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSACancelBlockingCall: Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSACancelBlockingCall.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSACleanup Function

nxllJwaWinsock2.WSACleanup Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSACleanup: Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSACleanup.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSACloseEvent Function

nxllJwaWinsock2.WSACloseEvent Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSACloseEvent(hEvent: WSAEVENT): BOOL; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSACloseEvent.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAConnect Function

nxllJwaWinsock2.WSAConnect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAConnect(s: TSocket; name: PSockAddr; namelen: Integer; lpCallerData: LPWSABUF; lpCalleeData: LPWSABUF; lpSQOS: LPQOS; lpGQOS: LPQOS): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAConnect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSACreateEvent Function

nxllJwaWinsock2.WSACreateEvent Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSACreateEvent: WSAEVENT; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSACreateEvent.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSADuplicateSocket Function

nxllJwaWinsock2.WSADuplicateSocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSADuplicateSocket(s: TSocket; dwProcessId: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSADuplicateSocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSADuplicateSocket Function

nxllJwaWinsock2.WSADuplicateSocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSADuplicateSocket(s: TSocket; dwProcessId: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSADuplicateSocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSADuplicateSocketA Function

nxllJwaWinsock2.WSADuplicateSocketA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSADuplicateSocketA(s: TSocket; dwProcessId: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSADuplicateSocketA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSADuplicateSocketW Function

nxllJwaWinsock2.WSADuplicateSocketW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSADuplicateSocketW(s: TSocket; dwProcessId: DWORD; lpProtocolInfo: LPWSAPROTOCOL_INFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSADuplicateSocketW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumNameSpaceProviders Function

nxllJwaWinsock2.WSAEnumNameSpaceProviders Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumNameSpaceProviders(var lpdwBufferLength: DWORD; lpnspBuffer: LPWSANAMESPACE_INFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumNameSpaceProviders Function

nxllJwaWinsock2.WSAEnumNameSpaceProviders Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumNameSpaceProviders(var lpdwBufferLength: DWORD; lpnspBuffer: LPWSANAMESPACE_INFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumNameSpaceProviders.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumNameSpaceProvidersA Function

nxllJwaWinsock2.WSAEnumNameSpaceProvidersA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumNameSpaceProvidersA(var lpdwBufferLength: DWORD; lpnspBuffer: LPWSANAMESPACE_INFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumNameSpaceProvidersW Function

nxllJwaWinsock2.WSAEnumNameSpaceProvidersW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumNameSpaceProvidersW(var lpdwBufferLength: DWORD; lpnspBuffer: LPWSANAMESPACE_INFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumNameSpaceProvidersW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumNetworkEvents Function

nxllJwaWinsock2.WSAEnumNetworkEvents Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumNetworkEvents(s: TSocket; hEventObject: WSAEVENT; lpNetworkEvents: LPWSANETWORKEVENTS): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumNetworkEvents.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumProtocols Function

nxllJwaWinsock2.WSAEnumProtocols Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumProtocols(lpiProtocols: PINT; lpProtocolBuffer: LPWSAPROTOCOL_INFOA; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumProtocols.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumProtocols Function

nxllJwaWinsock2.WSAEnumProtocols Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumProtocols(lpiProtocols: PINT; lpProtocolBuffer: LPWSAPROTOCOL_INFOW; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumProtocols.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumProtocolsA Function

nxllJwaWinsock2.WSAEnumProtocolsA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumProtocolsA(lpiProtocols: PINT; lpProtocolBuffer: LPWSAPROTOCOL_INFOA; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumProtocolsA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEnumProtocolsW Function

nxllJwaWinsock2.WSAEnumProtocolsW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEnumProtocolsW(lpiProtocols: PINT; lpProtocolBuffer: LPWSAPROTOCOL_INFOW; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEnumProtocolsW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAEventSelect Function

nxllJwaWinsock2.WSAEventSelect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAEventSelect(s: TSocket; hEventObject: WSAEVENT; lNetworkEvents: Longint): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAEventSelect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGETASYNCBUFLEN Function

nxllJwaWinsock2.WSAGETASYNCBUFLEN Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGETASYNCBUFLEN(lParam: DWORD): WORD;
File

nxllJwaWinsock2

Description

WSAGETASYNCBUFLEN is intended for use by the Windows Sockets application to extract the buffer length from the lParam in the response to a WSAAsyncGetXByY().

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGETASYNCERROR Function

nxllJwaWinsock2.WSAGETASYNCERROR Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGETASYNCERROR(lParam: DWORD): WORD;
File

nxllJwaWinsock2

Description

WSAGETASYNCERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAGetXByY().

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetLastError Function

nxllJwaWinsock2.WSAGetLastError Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetLastError: Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetLastError.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetOverlappedResult Function

nxllJwaWinsock2.WSAGetOverlappedResult Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetOverlappedResult(s: TSocket; lpOverlapped: LPWSAOVERLAPPED; var lpcbTransfer: DWORD; fWait: BOOL; var lpdwFlags: DWORD): BOOL; stdcall;
File

nxllJwaWinsock2

Description

Thanks Kai Henningsen for var on lpdwFlags

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetQOSByName Function

nxllJwaWinsock2.WSAGetQOSByName Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetQOSByName(s: TSocket; var lpQOSName: WSABUF; lpQOS: LPQOS): BOOL; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetQOSByName.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGETSELECTERROR Function

nxllJwaWinsock2.WSAGETSELECTERROR Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGETSELECTERROR(lParam: DWORD): WORD;
File

nxllJwaWinsock2

Description

WSAGETSELECTERROR is intended for use by the Windows Sockets application to extract the error code from the lParam in the response to a WSAAsyncSelect().

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGETSELECTEVENT Function

nxllJwaWinsock2.WSAGETSELECTEVENT Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGETSELECTEVENT(lParam: DWORD): WORD;
File

nxllJwaWinsock2

Description

WSAGETSELECTEVENT is intended for use by the Windows Sockets application to extract the event code from the lParam in the response to a WSAAsyncSelect().

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassInfo Function

nxllJwaWinsock2.WSAGetServiceClassInfo Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassInfo(const lpProviderId: TGUID; const lpServiceClassId: TGUID; var lpdwBufSize: DWORD; lpServiceClassInfo: LPWSASERVICECLASSINFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassInfo.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassInfo Function

nxllJwaWinsock2.WSAGetServiceClassInfo Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassInfo(const lpProviderId: TGUID; const lpServiceClassId: TGUID; var lpdwBufSize: DWORD; lpServiceClassInfo: LPWSASERVICECLASSINFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassInfo.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassInfoA Function

nxllJwaWinsock2.WSAGetServiceClassInfoA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassInfoA(const lpProviderId: TGUID; const lpServiceClassId: TGUID; var lpdwBufSize: DWORD; lpServiceClassInfo: LPWSASERVICECLASSINFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassInfoA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassInfoW Function

nxllJwaWinsock2.WSAGetServiceClassInfoW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassInfoW(const lpProviderId: TGUID; const lpServiceClassId: TGUID; var lpdwBufSize: DWORD; lpServiceClassInfo: LPWSASERVICECLASSINFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassInfoW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassNameByClassId Function

nxllJwaWinsock2.WSAGetServiceClassNameByClassId Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassNameByClassId(const lpServiceClassId: TGUID; lpszServiceClassName: LPSTR; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassNameByClassId Function

nxllJwaWinsock2.WSAGetServiceClassNameByClassId Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassNameByClassId(const lpServiceClassId: TGUID; lpszServiceClassName: LPWSTR; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassId.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassNameByClassIdA Function

nxllJwaWinsock2.WSAGetServiceClassNameByClassIdA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassNameByClassIdA(const lpServiceClassId: TGUID; lpszServiceClassName: LPSTR; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAGetServiceClassNameByClassIdW Function

nxllJwaWinsock2.WSAGetServiceClassNameByClassIdW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAGetServiceClassNameByClassIdW(const lpServiceClassId: TGUID; lpszServiceClassName: LPWSTR; var lpdwBufferLength: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAGetServiceClassNameByClassIdW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAHtonl Function

nxllJwaWinsock2.WSAHtonl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAHtonl(s: TSocket; hostlong: u_long; var lpnetlong: u_long): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAHtonl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAHtons Function

nxllJwaWinsock2.WSAHtons Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAHtons(s: TSocket; hostshort: u_short; var lpnetshort: u_short): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAHtons.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAInstallServiceClass Function

nxllJwaWinsock2.WSAInstallServiceClass Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAInstallServiceClass(lpServiceClassInfo: LPWSASERVICECLASSINFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAInstallServiceClass.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAInstallServiceClass Function

nxllJwaWinsock2.WSAInstallServiceClass Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAInstallServiceClass(lpServiceClassInfo: LPWSASERVICECLASSINFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAInstallServiceClass.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAInstallServiceClassA Function

nxllJwaWinsock2.WSAInstallServiceClassA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAInstallServiceClassA(lpServiceClassInfo: LPWSASERVICECLASSINFOA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAInstallServiceClassA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAInstallServiceClassW Function

nxllJwaWinsock2.WSAInstallServiceClassW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAInstallServiceClassW(lpServiceClassInfo: LPWSASERVICECLASSINFOW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAInstallServiceClassW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAIoctl Function

nxllJwaWinsock2.WSAIoctl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAIoctl(s: TSocket; dwIoControlCode: DWORD; lpvInBuffer: LPVOID; cbInBuffer: DWORD; lpvOutBuffer: LPVOID; cbOutBuffer: DWORD; var lpcbBytesReturned: DWORD; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAIoctl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAIsBlocking Function

nxllJwaWinsock2.WSAIsBlocking Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAIsBlocking: BOOL; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAIsBlocking.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAJoinLeaf Function

nxllJwaWinsock2.WSAJoinLeaf Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAJoinLeaf(s: TSocket; name: PSockAddr; namelen: Integer; lpCallerData: LPWSABUF; lpCalleeData: LPWSABUF; lpSQOS: LPQOS; lpGQOS: LPQOS; dwFlags: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAJoinLeaf.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceBegin Function

nxllJwaWinsock2.WSALookupServiceBegin Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceBegin(lpqsRestrictions: LPWSAQUERYSETA; dwControlFlags: DWORD; var lphLookup: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceBegin.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceBegin Function

nxllJwaWinsock2.WSALookupServiceBegin Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceBegin(lpqsRestrictions: LPWSAQUERYSETW; dwControlFlags: DWORD; var lphLookup: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceBegin.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceBeginA Function

nxllJwaWinsock2.WSALookupServiceBeginA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceBeginA(lpqsRestrictions: LPWSAQUERYSETA; dwControlFlags: DWORD; var lphLookup: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

Registration and Name Resolution API functions

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceBeginW Function

nxllJwaWinsock2.WSALookupServiceBeginW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceBeginW(lpqsRestrictions: LPWSAQUERYSETW; dwControlFlags: DWORD; var lphLookup: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceBeginW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceEnd Function

nxllJwaWinsock2.WSALookupServiceEnd Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceEnd(hLookup: HANDLE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceEnd.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceNext Function

nxllJwaWinsock2.WSALookupServiceNext Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceNext(hLookup: HANDLE; dwControlFlags: DWORD; var lpdwBufferLength: DWORD; lpqsResults: LPWSAQUERYSETA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceNext.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceNext Function

nxllJwaWinsock2.WSALookupServiceNext Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceNext(hLookup: HANDLE; dwControlFlags: DWORD; var lpdwBufferLength: DWORD; lpqsResults: LPWSAQUERYSETW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceNext.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceNextA Function

nxllJwaWinsock2.WSALookupServiceNextA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceNextA(hLookup: HANDLE; dwControlFlags: DWORD; var lpdwBufferLength: DWORD; lpqsResults: LPWSAQUERYSETA): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceNextA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSALookupServiceNextW Function

nxllJwaWinsock2.WSALookupServiceNextW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSALookupServiceNextW(hLookup: HANDLE; dwControlFlags: DWORD; var lpdwBufferLength: DWORD; lpqsResults: LPWSAQUERYSETW): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSALookupServiceNextW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAMAKEASYNCREPLY Function

nxllJwaWinsock2.WSAMAKEASYNCREPLY Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAMAKEASYNCREPLY(buflen: WORD; error: WORD): DWORD;
File

nxllJwaWinsock2

Description

Windows message parameter composition and decomposition macros.

WSAMAKEASYNCREPLY is intended for use by the Windows Sockets implementation when constructing the response to a WSAAsyncGetXByY() routine.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAMAKESELECTREPLY Function

nxllJwaWinsock2.WSAMAKESELECTREPLY Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAMAKESELECTREPLY(event: WORD; error: WORD): DWORD;
File

nxllJwaWinsock2

Description

WSAMAKESELECTREPLY is intended for use by the Windows Sockets implementation when constructing the response to WSAAsyncSelect().

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSANSPIoctl Function

nxllJwaWinsock2.WSANSPIoctl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSANSPIoctl(hLookup: HANDLE; dwControlCode: DWORD; lpvInBuffer: LPVOID; cbInBuffer: DWORD; lpvOutBuffer: LPVOID; cbOutBuffer: DWORD; lpcbBytesReturned: LPDWORD; lpCompletion: LPWSACOMPLETION): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSANSPIoctl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSANtohl Function

nxllJwaWinsock2.WSANtohl Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSANtohl(s: TSocket; netlong: u_long; var lphostlong: u_long): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSANtohl.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSANtohs Function

nxllJwaWinsock2.WSANtohs Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSANtohs(s: TSocket; netshort: u_short; var lphostshort: u_short): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSANtohs.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAProviderConfigChange Function

nxllJwaWinsock2.WSAProviderConfigChange Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAProviderConfigChange(var lpNotificationHandle: HANDLE; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAProviderConfigChange.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSARecv Function

nxllJwaWinsock2.WSARecv Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSARecv(s: TSocket; lpBuffers: LPWSABUF; dwBufferCount: DWORD; var lpNumberOfBytesRecvd: DWORD; var lpFlags: DWORD; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSARecv.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSARecvDisconnect Function

nxllJwaWinsock2.WSARecvDisconnect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSARecvDisconnect(s: TSocket; lpInboundDisconnectData: LPWSABUF): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSARecvDisconnect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSARecvFrom Function

nxllJwaWinsock2.WSARecvFrom Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSARecvFrom(s: TSocket; lpBuffers: LPWSABUF; dwBufferCount: DWORD; var lpNumberOfBytesRecvd: DWORD; var lpFlags: DWORD; lpFrom: PSockAddr; lpFromlen: PINT; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSARecvFrom.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSARemoveServiceClass Function

nxllJwaWinsock2.WSARemoveServiceClass Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSARemoveServiceClass(const lpServiceClassId: TGUID): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSARemoveServiceClass.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAResetEvent Function

nxllJwaWinsock2.WSAResetEvent Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAResetEvent(hEvent: WSAEVENT): BOOL; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAResetEvent.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASend Function

nxllJwaWinsock2.WSASend Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASend(s: TSocket; lpBuffers: LPWSABUF; dwBufferCount: DWORD; var lpNumberOfBytesSent: DWORD; dwFlags: DWORD; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASend.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASendDisconnect Function

nxllJwaWinsock2.WSASendDisconnect Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASendDisconnect(s: TSocket; lpOutboundDisconnectData: LPWSABUF): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASendDisconnect.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASendTo Function

nxllJwaWinsock2.WSASendTo Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASendTo(s: TSocket; lpBuffers: LPWSABUF; dwBufferCount: DWORD; var lpNumberOfBytesSent: DWORD; dwFlags: DWORD; lpTo: PSockAddr; iTolen: Integer; lpOverlapped: LPWSAOVERLAPPED; lpCompletionRoutine: LPWSAOVERLAPPED_COMPLETION_ROUTINE): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASendTo.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetBlockingHook Function

nxllJwaWinsock2.WSASetBlockingHook Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetBlockingHook(lpBlockFunc: FARPROC): FARPROC; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetBlockingHook.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetEvent Function

nxllJwaWinsock2.WSASetEvent Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetEvent(hEvent: WSAEVENT): BOOL; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetEvent.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetLastError Function

nxllJwaWinsock2.WSASetLastError Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
procedure WSASetLastError(iError: Integer); stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetLastError.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetService Function

nxllJwaWinsock2.WSASetService Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetService(lpqsRegInfo: LPWSAQUERYSETA; essoperation: WSAESETSERVICEOP; dwControlFlags: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetService.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetService Function

nxllJwaWinsock2.WSASetService Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetService(lpqsRegInfo: LPWSAQUERYSETW; essoperation: WSAESETSERVICEOP; dwControlFlags: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetService.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetServiceA Function

nxllJwaWinsock2.WSASetServiceA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetServiceA(lpqsRegInfo: LPWSAQUERYSETA; essoperation: WSAESETSERVICEOP; dwControlFlags: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetServiceA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASetServiceW Function

nxllJwaWinsock2.WSASetServiceW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASetServiceW(lpqsRegInfo: LPWSAQUERYSETW; essoperation: WSAESETSERVICEOP; dwControlFlags: DWORD): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASetServiceW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASocket Function

nxllJwaWinsock2.WSASocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASocket(af: Integer; type_: Integer; protocol: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOA; g: GROUP; dwFlags: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASocket Function

nxllJwaWinsock2.WSASocket Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASocket(af: Integer; type_: Integer; protocol: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOW; g: GROUP; dwFlags: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASocket.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASocketA Function

nxllJwaWinsock2.WSASocketA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASocketA(af: Integer; type_: Integer; protocol: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOA; g: GROUP; dwFlags: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASocketA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSASocketW Function

nxllJwaWinsock2.WSASocketW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSASocketW(af: Integer; type_: Integer; protocol: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOW; g: GROUP; dwFlags: DWORD): TSocket; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSASocketW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAStartup Function

nxllJwaWinsock2.WSAStartup Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAStartup(wVersionRequired: WORD; var lpWSAData: TWSAData): Integer; stdcall;
File

nxllJwaWinsock2

Description

Microsoft Windows Extension function prototypes

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAStringToAddress Function

nxllJwaWinsock2.WSAStringToAddress Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAStringToAddress(AddressString: LPSTR; AddressFamily: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOA; lpAddress: LPSOCKADDR; var lpAddressLength: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAStringToAddress.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAStringToAddress Function

nxllJwaWinsock2.WSAStringToAddress Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAStringToAddress(AddressString: LPWSTR; AddressFamily: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOW; lpAddress: LPSOCKADDR; var lpAddressLength: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAStringToAddress.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAStringToAddressA Function

nxllJwaWinsock2.WSAStringToAddressA Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAStringToAddressA(AddressString: LPSTR; AddressFamily: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOA; lpAddress: LPSOCKADDR; var lpAddressLength: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAStringToAddressA.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAStringToAddressW Function

nxllJwaWinsock2.WSAStringToAddressW Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAStringToAddressW(AddressString: LPWSTR; AddressFamily: Integer; lpProtocolInfo: LPWSAPROTOCOL_INFOW; lpAddress: LPSOCKADDR; var lpAddressLength: Integer): Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAStringToAddressW.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAUnhookBlockingHook Function

nxllJwaWinsock2.WSAUnhookBlockingHook Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAUnhookBlockingHook: Integer; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAUnhookBlockingHook.

Group

Functions

Links
nxllJwaWinsock2, Functions


nxllJwaWinsock2.WSAWaitForMultipleEvents Function

nxllJwaWinsock2.WSAWaitForMultipleEvents Function
nxllJwaWinsock2 Functions Send Feedback
Syntax
Delphi
function WSAWaitForMultipleEvents(cEvents: DWORD; lphEvents: PWSAEVENT; fWaitAll: BOOL; dwTimeout: DWORD; fAlertable: BOOL): DWORD; stdcall;
File

nxllJwaWinsock2

Description

This is function nxllJwaWinsock2.WSAWaitForMultipleEvents.

Group

Functions

Links
nxllJwaWinsock2, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllJwaWinsock2 Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
_WSACOMPLETIONTYPE | This is record nxllJwaWinsock2._WSACOMPLETIONTYPE.
_WSAEcomparator | The comparators
_WSAESETSERVICEOP | Service Address Registration and Deregistration Data Types.
Namespace

nxllJwaWinsock2 Namespace

Records
Name | Description
_AFPROTOCOLS | This is record nxllJwaWinsock2._AFPROTOCOLS.
_BLOB | Manifest constants and type definitions related to name resolution and registration (RNR) API
_CSADDR_INFO | This is record nxllJwaWinsock2._CSADDR_INFO.
_QualityOfService | This is record nxllJwaWinsock2._QualityOfService.
_SOCKET_ADDRESS | This is record nxllJwaWinsock2._SOCKET_ADDRESS.
_SOCKET_ADDRESS_LIST | This is record nxllJwaWinsock2._SOCKET_ADDRESS_LIST.
_WSABUF | WinSock 2 extension -- WSABUF and QOS struct, include qos.h to pull in FLOWSPEC and related definitions
_WSACOMPLETION | This is record nxllJwaWinsock2._WSACOMPLETION.
_WSANAMESPACE_INFOA | This is record nxllJwaWinsock2._WSANAMESPACE_INFOA.
_WSANAMESPACE_INFOW | This is record nxllJwaWinsock2._WSANAMESPACE_INFOW.
_WSANETWORKEVENTS | WinSock 2 extension -- data type for WSAEnumNetworkEvents()
_WSANSClassInfoA | Service Installation/Removal Data Types.
_WSANSClassInfoW | This is record nxllJwaWinsock2._WSANSClassInfoW.
_WSAPROTOCOL_INFOA | This is record nxllJwaWinsock2._WSAPROTOCOL_INFOA.
_WSAPROTOCOL_INFOW | This is record nxllJwaWinsock2._WSAPROTOCOL_INFOW.
_WSAPROTOCOLCHAIN | This is record nxllJwaWinsock2._WSAPROTOCOLCHAIN.
_WSAQuerySetA | This is record nxllJwaWinsock2._WSAQuerySetA.
_WSAQuerySetW | This is record nxllJwaWinsock2._WSAQuerySetW.
_WSAServiceClassInfoA | This is record nxllJwaWinsock2._WSAServiceClassInfoA.
_WSAServiceClassInfoW | This is record nxllJwaWinsock2._WSAServiceClassInfoW.
_WSAVersion | This is record nxllJwaWinsock2._WSAVersion.
fd_set | This is record nxllJwaWinsock2.fd_set.
hostent | Structures returned by network data base library, taken from the BSD file netdb.h. All addresses are supplied in host order, and returned in network order (suitable for use in system calls).
in_addr | This is record nxllJwaWinsock2.in_addr.
linger | Structure used for manipulating linger option.
netent | It is assumed here that a network number fits in 32 bits.
protoent | This is record nxllJwaWinsock2.protoent.
servent | This is record nxllJwaWinsock2.servent.
sockaddr | Structure used by kernel to store most addresses.
sockaddr_in | Socket address, internet style.
sockaddr_storage | This is record nxllJwaWinsock2.sockaddr_storage.
sockproto | Structure used by kernel to pass protocol information in raw sockets.
SunB | Internet address (old style... should be updated)
SunC | This is record nxllJwaWinsock2.SunC.
SunW | This is record nxllJwaWinsock2.SunW.
timeval | Structure used in select() call, taken from the BSD file sys/time.h.
WSAData | This is record nxllJwaWinsock2.WSAData.
Links
Enumerations, nxllJwaWinsock2 Namespace, Legend, Records


nxllJwaWinsock2._AFPROTOCOLS Record

nxllJwaWinsock2._AFPROTOCOLS Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_AFPROTOCOLS = record
  iAddressFamily: Integer;
  iProtocol: Integer;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._AFPROTOCOLS.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._BLOB Record

nxllJwaWinsock2._BLOB Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_BLOB = record
  cbSize: ULONG;
  pBlobData: LPBYTE;
end;
File

nxllJwaWinsock2

Description

Manifest constants and type definitions related to name resolution and registration (RNR) API

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._CSADDR_INFO Record

nxllJwaWinsock2._CSADDR_INFO Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_CSADDR_INFO = record
  LocalAddr: SOCKET_ADDRESS;
  RemoteAddr: SOCKET_ADDRESS;
  iSocketType: Integer;
  iProtocol: Integer;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._CSADDR_INFO.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._QualityOfService Record

nxllJwaWinsock2._QualityOfService Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_QualityOfService = record
  SendingFlowspec: FLOWSPEC;
  ReceivingFlowspec: FLOWSPEC;
  ProviderSpecific: WSABUF;
end;
File

nxllJwaWinsock2

Members
Members | Description
SendingFlowspec: FLOWSPEC; | the flow spec for data sending
ReceivingFlowspec: FLOWSPEC; | the flow spec for data receiving
ProviderSpecific: WSABUF; | additional provider specific stuff
Description

This is record nxllJwaWinsock2._QualityOfService.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._SOCKET_ADDRESS Record

nxllJwaWinsock2._SOCKET_ADDRESS Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_SOCKET_ADDRESS = record
  lpSockaddr: LPSOCKADDR;
  iSockaddrLength: Integer;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._SOCKET_ADDRESS.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._SOCKET_ADDRESS_LIST Record

nxllJwaWinsock2._SOCKET_ADDRESS_LIST Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_SOCKET_ADDRESS_LIST = record
  iAddressCount: Integer;
  Address: array [0..0] of SOCKET_ADDRESS;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._SOCKET_ADDRESS_LIST.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSABUF Record

nxllJwaWinsock2._WSABUF Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSABUF = record
  len: u_long;
  buf: PAnsiChar;
end;
File

nxllJwaWinsock2

Members
Members | Description
len: u_long; | the length of the buffer
buf: PAnsiChar; | the pointer to the buffer
Description

WinSock 2 extension -- WSABUF and QOS struct, include qos.h to pull in FLOWSPEC and related definitions

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSACOMPLETION Record

nxllJwaWinsock2._WSACOMPLETION Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSACOMPLETION = record
  Type_: WSACOMPLETIONTYPE;
  case Integer of
    0: (hWnd: HWND;
        uMsg: UINT;
        context: WPARAM;);
    3: (lpOverlapped: LPWSAOVERLAPPED;
        hPort: HANDLE;
        Key: ULONG_PTR;);
end;
File

nxllJwaWinsock2

Members
Members | Description
hWnd: HWND; | WindowMessage
lpOverlapped: LPWSAOVERLAPPED; | Port
Description

This is record nxllJwaWinsock2._WSACOMPLETION.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSACOMPLETIONTYPE Enumeration

nxllJwaWinsock2._WSACOMPLETIONTYPE Enumeration
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSACOMPLETIONTYPE = ( NSP_NOTIFY_IMMEDIATELY, NSP_NOTIFY_HWND, NSP_NOTIFY_EVENT, NSP_NOTIFY_PORT, NSP_NOTIFY_APC );
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSACOMPLETIONTYPE.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAEcomparator Enumeration

nxllJwaWinsock2._WSAEcomparator Enumeration
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAEcomparator = ( COMP_EQUAL, COMP_NOTLESS );
File

nxllJwaWinsock2

Description

The comparators

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAESETSERVICEOP Enumeration

nxllJwaWinsock2._WSAESETSERVICEOP Enumeration
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAESETSERVICEOP = ( RNRSERVICE_REGISTER, RNRSERVICE_DEREGISTER, RNRSERVICE_DELETE );
File

nxllJwaWinsock2

Description

Service Address Registration and Deregistration Data Types.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSANAMESPACE_INFOA Record

nxllJwaWinsock2._WSANAMESPACE_INFOA Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSANAMESPACE_INFOA = record
  NSProviderId: TGUID;
  dwNameSpace: DWORD;
  fActive: BOOL;
  dwVersion: DWORD;
  lpszIdentifier: LPSTR;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSANAMESPACE_INFOA.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSANAMESPACE_INFOW Record

nxllJwaWinsock2._WSANAMESPACE_INFOW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSANAMESPACE_INFOW = record
  NSProviderId: TGUID;
  dwNameSpace: DWORD;
  fActive: BOOL;
  dwVersion: DWORD;
  lpszIdentifier: LPWSTR;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSANAMESPACE_INFOW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSANETWORKEVENTS Record

nxllJwaWinsock2._WSANETWORKEVENTS Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSANETWORKEVENTS = record
  lNetworkEvents: Longint;
  iErrorCode: array [0..FD_MAX_EVENTS - 1] of Integer;
end;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- data type for WSAEnumNetworkEvents()

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSANSClassInfoA Record

nxllJwaWinsock2._WSANSClassInfoA Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSANSClassInfoA = record
  lpszName: LPSTR;
  dwNameSpace: DWORD;
  dwValueType: DWORD;
  dwValueSize: DWORD;
  lpValue: LPVOID;
end;
File

nxllJwaWinsock2

Description

Service Installation/Removal Data Types.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSANSClassInfoW Record

nxllJwaWinsock2._WSANSClassInfoW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSANSClassInfoW = record
  lpszName: LPWSTR;
  dwNameSpace: DWORD;
  dwValueType: DWORD;
  dwValueSize: DWORD;
  lpValue: LPVOID;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSANSClassInfoW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAPROTOCOL_INFOA Record

nxllJwaWinsock2._WSAPROTOCOL_INFOA Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAPROTOCOL_INFOA = record
  dwServiceFlags1: DWORD;
  dwServiceFlags2: DWORD;
  dwServiceFlags3: DWORD;
  dwServiceFlags4: DWORD;
  dwProviderFlags: DWORD;
  ProviderId: TGUID;
  dwCatalogEntryId: DWORD;
  ProtocolChain: WSAPROTOCOLCHAIN;
  iVersion: Integer;
  iAddressFamily: Integer;
  iMaxSockAddr: Integer;
  iMinSockAddr: Integer;
  iSocketType: Integer;
  iProtocol: Integer;
  iProtocolMaxOffset: Integer;
  iNetworkByteOrder: Integer;
  iSecurityScheme: Integer;
  dwMessageSize: DWORD;
  dwProviderReserved: DWORD;
  szProtocol: array [0..WSAPROTOCOL_LEN] of AnsiChar;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAPROTOCOL_INFOA.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAPROTOCOL_INFOW Record

nxllJwaWinsock2._WSAPROTOCOL_INFOW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAPROTOCOL_INFOW = record
  dwServiceFlags1: DWORD;
  dwServiceFlags2: DWORD;
  dwServiceFlags3: DWORD;
  dwServiceFlags4: DWORD;
  dwProviderFlags: DWORD;
  ProviderId: TGUID;
  dwCatalogEntryId: DWORD;
  ProtocolChain: WSAPROTOCOLCHAIN;
  iVersion: Integer;
  iAddressFamily: Integer;
  iMaxSockAddr: Integer;
  iMinSockAddr: Integer;
  iSocketType: Integer;
  iProtocol: Integer;
  iProtocolMaxOffset: Integer;
  iNetworkByteOrder: Integer;
  iSecurityScheme: Integer;
  dwMessageSize: DWORD;
  dwProviderReserved: DWORD;
  szProtocol: array [0..WSAPROTOCOL_LEN] of WideChar;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAPROTOCOL_INFOW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAPROTOCOLCHAIN Record

nxllJwaWinsock2._WSAPROTOCOLCHAIN Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAPROTOCOLCHAIN = record
  ChainLen: Integer;
  ChainEntries: array [0..MAX_PROTOCOL_CHAIN - 1] of DWORD;
end;
File

nxllJwaWinsock2

Members
Members | Description
ChainLen: Integer; | the length of the chain, length = 0 means layered protocol, length = 1 means base protocol, length > 1 means protocol chain
ChainEntries: array [0..MAX_PROTOCOL_CHAIN - 1] of DWORD; | a list of dwCatalogEntryIds
Description

This is record nxllJwaWinsock2._WSAPROTOCOLCHAIN.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAQuerySetA Record

nxllJwaWinsock2._WSAQuerySetA Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAQuerySetA = record
  dwSize: DWORD;
  lpszServiceInstanceName: LPSTR;
  lpServiceClassId: PGUID;
  lpVersion: LPWSAVERSION;
  lpszComment: LPSTR;
  dwNameSpace: DWORD;
  lpNSProviderId: PGUID;
  lpszContext: LPSTR;
  dwNumberOfProtocols: DWORD;
  lpafpProtocols: LPAFPROTOCOLS;
  lpszQueryString: LPSTR;
  dwNumberOfCsAddrs: DWORD;
  lpcsaBuffer: LPCSADDR_INFO;
  dwOutputFlags: DWORD;
  lpBlob: LPBLOB;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAQuerySetA.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAQuerySetW Record

nxllJwaWinsock2._WSAQuerySetW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAQuerySetW = record
  dwSize: DWORD;
  lpszServiceInstanceName: LPWSTR;
  lpServiceClassId: PGUID;
  lpVersion: LPWSAVERSION;
  lpszComment: LPWSTR;
  dwNameSpace: DWORD;
  lpNSProviderId: PGUID;
  lpszContext: LPWSTR;
  dwNumberOfProtocols: DWORD;
  lpafpProtocols: LPAFPROTOCOLS;
  lpszQueryString: LPWSTR;
  dwNumberOfCsAddrs: DWORD;
  lpcsaBuffer: LPCSADDR_INFO;
  dwOutputFlags: DWORD;
  lpBlob: LPBLOB;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAQuerySetW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAServiceClassInfoA Record

nxllJwaWinsock2._WSAServiceClassInfoA Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAServiceClassInfoA = record
  lpServiceClassId: PGUID;
  lpszServiceClassName: LPSTR;
  dwCount: DWORD;
  lpClassInfos: LPWSANSCLASSINFOA;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAServiceClassInfoA.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAServiceClassInfoW Record

nxllJwaWinsock2._WSAServiceClassInfoW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAServiceClassInfoW = record
  lpServiceClassId: PGUID;
  lpszServiceClassName: LPWSTR;
  dwCount: DWORD;
  lpClassInfos: LPWSANSCLASSINFOW;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAServiceClassInfoW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2._WSAVersion Record

nxllJwaWinsock2._WSAVersion Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
_WSAVersion = record
  dwVersion: DWORD;
  ecHow: WSAECOMPARATOR;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2._WSAVersion.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.fd_set Record

nxllJwaWinsock2.fd_set Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
fd_set = record
  fd_count: u_int;
  fd_array: array [0..FD_SETSIZE - 1] of TSocket;
end;
File

nxllJwaWinsock2

Members
Members | Description
fd_count: u_int; | how many are SET?
fd_array: array [0..FD_SETSIZE - 1] of TSocket; | an array of SOCKETs
Description

This is record nxllJwaWinsock2.fd_set.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.hostent Record

nxllJwaWinsock2.hostent Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
hostent = record
  h_name: PAnsiChar;
  h_aliases: PPAnsiChar;
  h_addrtype: Smallint;
  h_length: Smallint;
  case Integer of
    0: (h_addr_list: PPAnsiChar;);
    1: (h_addr: PPAnsiChar;);
end;
File

nxllJwaWinsock2

Members
Members | Description
h_name: PAnsiChar; | official name of host
h_aliases: PPAnsiChar; | alias list
h_addrtype: Smallint; | host address type
h_length: Smallint; | length of address
h_addr_list: PPAnsiChar; | list of addresses
h_addr: PPAnsiChar; | address, for backward compat
Description

Structures returned by network data base library, taken from the BSD file netdb.h. All addresses are supplied in host order, and returned in network order (suitable for use in system calls).

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.in_addr Record

nxllJwaWinsock2.in_addr Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
in_addr = record
  case Integer of
    0: (S_un_b: SunB;);
    1: (S_un_c: SunC;);
    2: (S_un_w: SunW;);
    3: (S_addr: u_long;);
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2.in_addr.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.linger Record

nxllJwaWinsock2.linger Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
linger = record
  l_onoff: u_short;
  l_linger: u_short;
end;
File

nxllJwaWinsock2

Members
Members | Description
l_onoff: u_short; | option on/off
l_linger: u_short; | linger time
Description

Structure used for manipulating linger option.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.netent Record

nxllJwaWinsock2.netent Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
netent = record
  n_name: PAnsiChar;
  n_aliases: PPAnsiChar;
  n_addrtype: Smallint;
  n_net: u_long;
end;
File

nxllJwaWinsock2

Members
Members | Description
n_name: PAnsiChar; | official name of net
n_aliases: PPAnsiChar; | alias list
n_addrtype: Smallint; | net address type
n_net: u_long; | network
Description

It is assumed here that a network number fits in 32 bits.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.protoent Record

nxllJwaWinsock2.protoent Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
protoent = record
  p_name: PAnsiChar;
  p_aliases: PPAnsiChar;
  p_proto: Smallint;
end;
File

nxllJwaWinsock2

Members
Members | Description
p_name: PAnsiChar; | official protocol name
p_aliases: PPAnsiChar; | alias list
p_proto: Smallint; | protocol
Description

This is record nxllJwaWinsock2.protoent.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.servent Record

nxllJwaWinsock2.servent Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
servent = record
  s_name: PAnsiChar;
  s_aliases: PPAnsiChar;
  s_port: Smallint;
  s_proto: PAnsiChar;
end;
File

nxllJwaWinsock2

Members
Members | Description
s_name: PAnsiChar; | official service name
s_aliases: PPAnsiChar; | alias list
s_port: Smallint; | port
s_proto: PAnsiChar; | protocol to use
Description

This is record nxllJwaWinsock2.servent.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.sockaddr Record

nxllJwaWinsock2.sockaddr Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
sockaddr = record
  sa_family: u_short;
  sa_data: array [0..13] of AnsiChar;
end;
File

nxllJwaWinsock2

Members
Members | Description
sa_family: u_short; | address family
sa_data: array [0..13] of AnsiChar; | up to 14 bytes of direct address
Description

Structure used by kernel to store most addresses.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.sockaddr_in Record

nxllJwaWinsock2.sockaddr_in Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
sockaddr_in = record
  sin_family: Smallint;
  sin_port: u_short;
  sin_addr: in_addr;
  sin_zero: array [0..7] of AnsiChar;
end;
File

nxllJwaWinsock2

Description

Socket address, internet style.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.sockaddr_storage Record

nxllJwaWinsock2.sockaddr_storage Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
sockaddr_storage = record
  ss_family: short;
  __ss_pad1: array [0.._SS_PAD1SIZE - 1] of AnsiChar;
  __ss_align: Int64;
  __ss_pad2: array [0.._SS_PAD2SIZE - 1] of AnsiChar;
end;
File

nxllJwaWinsock2

Members
Members | Description
ss_family: short; | Address family.
__ss_pad1: array [0.._SS_PAD1SIZE - 1] of AnsiChar; | 6 byte pad, this is to make implementation specific pad up to alignment field that follows explicit in the data structure.
__ss_align: Int64; | Field to force desired structure.
__ss_pad2: array [0.._SS_PAD2SIZE - 1] of AnsiChar; | 112 byte pad to achieve desired size; _SS_MAXSIZE value minus size of ss_family, __ss_pad1, and __ss_align fields is 112.
Description

This is record nxllJwaWinsock2.sockaddr_storage.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.sockproto Record

nxllJwaWinsock2.sockproto Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
sockproto = record
  sp_family: u_short;
  sp_protocol: u_short;
end;
File

nxllJwaWinsock2

Members
Members | Description
sp_family: u_short; | address family
sp_protocol: u_short; | protocol
Description

Structure used by kernel to pass protocol information in raw sockets.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.SunB Record

nxllJwaWinsock2.SunB Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
SunB = packed record
  s_b1: u_char;
  s_b2: u_char;
  s_b3: u_char;
  s_b4: u_char;
end;
File

nxllJwaWinsock2

Description

Internet address (old style... should be updated)

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.SunC Record

nxllJwaWinsock2.SunC Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
SunC = packed record
  s_c1: AnsiChar;
  s_c2: AnsiChar;
  s_c3: AnsiChar;
  s_c4: AnsiChar;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2.SunC.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.SunW Record

nxllJwaWinsock2.SunW Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
SunW = packed record
  s_w1: u_short;
  s_w2: u_short;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2.SunW.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.timeval Record

nxllJwaWinsock2.timeval Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
timeval = record
  tv_sec: Longint;
  tv_usec: Longint;
end;
File

nxllJwaWinsock2

Members
Members | Description
tv_sec: Longint; | seconds
tv_usec: Longint; | and microseconds
Description

Structure used in select() call, taken from the BSD file sys/time.h.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


nxllJwaWinsock2.WSAData Record

nxllJwaWinsock2.WSAData Record
nxllJwaWinsock2 Structs, Records, Enums Send Feedback
Syntax
Delphi
WSAData = record
  wVersion: WORD;
  wHighVersion: WORD;
  szDescription: array [0..WSADESCRIPTION_LEN] of AnsiChar;
  szSystemStatus: array [0..WSASYS_STATUS_LEN] of AnsiChar;
  iMaxSockets: Word;
  iMaxUdpDg: Word;
  lpVendorInfo: PAnsiChar;
end;
File

nxllJwaWinsock2

Description

This is record nxllJwaWinsock2.WSAData.

Group

Structs, Records, Enums

Links
nxllJwaWinsock2, Structs, Records, Enums


Types

Types
nxllJwaWinsock2 Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaWinsock2 Namespace

Types
Name | Description
AFPROTOCOLS | This is type nxllJwaWinsock2.AFPROTOCOLS.
BLOB | This is type nxllJwaWinsock2.BLOB.
CSADDR_INFO | This is type nxllJwaWinsock2.CSADDR_INFO.
DWORD_PTR | This is type nxllJwaWinsock2.DWORD_PTR.
GROUP | WinSock 2 extension -- data type and manifest constants for socket groups
HANDLE | This is type nxllJwaWinsock2.HANDLE.
LPAFPROTOCOLS | Address Family/Protocol Tuples
LPBLOB | This is type nxllJwaWinsock2.LPBLOB.
LPBYTE | This is type nxllJwaWinsock2.LPBYTE.
LPCONDITIONPROC | WinSock 2 extensions -- data types for the condition function in WSAAccept() and overlapped I/O completion routine.
LPCSADDR_INFO | CSAddr Information
LPFD_SET | This is type nxllJwaWinsock2.LPFD_SET.
LPHANDLE | This is type nxllJwaWinsock2.LPHANDLE.
LPHOSTENT | This is type nxllJwaWinsock2.LPHOSTENT.
LPIN_ADDR | This is type nxllJwaWinsock2.LPIN_ADDR.
LPLINGER | This is type nxllJwaWinsock2.LPLINGER.
LPPROTOENT | This is type nxllJwaWinsock2.LPPROTOENT.
LPQOS | This is type nxllJwaWinsock2.LPQOS.
LPSERVENT | This is type nxllJwaWinsock2.LPSERVENT.
LPSOCKADDR | Microsoft Windows Extended data types required for the functions to convert back and forth between binary and string forms of addresses.
LPSOCKADDR_IN | This is type nxllJwaWinsock2.LPSOCKADDR_IN.
LPSOCKADDR_STORAGE | This is type nxllJwaWinsock2.LPSOCKADDR_STORAGE.
LPSOCKET_ADDRESS | SockAddr Information
LPSOCKET_ADDRESS_LIST | Address list returned via SIO_ADDRESS_LIST_QUERY
LPTIMEVAL | This is type nxllJwaWinsock2.LPTIMEVAL.
LPVOID | This is type nxllJwaWinsock2.LPVOID.
LPWSABUF | This is type nxllJwaWinsock2.LPWSABUF.
LPWSACOMPLETION | This is type nxllJwaWinsock2.LPWSACOMPLETION.
LPWSACOMPLETIONTYPE | This is type nxllJwaWinsock2.LPWSACOMPLETIONTYPE.
LPWSADATA | This is type nxllJwaWinsock2.LPWSADATA.
LPWSAECOMPARATOR | This is type nxllJwaWinsock2.LPWSAECOMPARATOR.
LPWSAESETSERVICEOP | This is type nxllJwaWinsock2.LPWSAESETSERVICEOP.
LPWSAEVENT | This is type nxllJwaWinsock2.LPWSAEVENT.
LPWSANAMESPACE_INFO | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFO.
LPWSANAMESPACE_INFOA | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOA.
LPWSANAMESPACE_INFOW | This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOW.
LPWSANETWORKEVENTS | This is type nxllJwaWinsock2.LPWSANETWORKEVENTS.
LPWSANSCLASSINFO | This is type nxllJwaWinsock2.LPWSANSCLASSINFO.
LPWSANSCLASSINFOA | This is type nxllJwaWinsock2.LPWSANSCLASSINFOA.
LPWSANSCLASSINFOW | This is type nxllJwaWinsock2.LPWSANSCLASSINFOW.
LPWSAOVERLAPPED | This is type nxllJwaWinsock2.LPWSAOVERLAPPED.
LPWSAOVERLAPPED_COMPLETION_ROUTINE | This is type nxllJwaWinsock2.LPWSAOVERLAPPED_COMPLETION_ROUTINE.
LPWSAPROTOCOL_INFO | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFO.
LPWSAPROTOCOL_INFOA | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOA.
LPWSAPROTOCOL_INFOW | This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOW.
LPWSAPROTOCOLCHAIN | This is type nxllJwaWinsock2.LPWSAPROTOCOLCHAIN.
LPWSAQUERYSET | This is type nxllJwaWinsock2.LPWSAQUERYSET.
LPWSAQUERYSETA | This is type nxllJwaWinsock2.LPWSAQUERYSETA.
LPWSAQUERYSETW | This is type nxllJwaWinsock2.LPWSAQUERYSETW.
LPWSASERVICECLASSINFO | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFO.
LPWSASERVICECLASSINFOA | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOA.
LPWSASERVICECLASSINFOW | This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOW.
LPWSAVERSION | This is type nxllJwaWinsock2.LPWSAVERSION.
PAFPROTOCOLS | This is type nxllJwaWinsock2.PAFPROTOCOLS.
PBlob | This is type nxllJwaWinsock2.PBlob.
PCSADDR_INFO | This is type nxllJwaWinsock2.PCSADDR_INFO.
PCsAddrInfo | This is type nxllJwaWinsock2.PCsAddrInfo.
PFD_SET | This is type nxllJwaWinsock2.PFD_SET.
PFdSet | This is type nxllJwaWinsock2.PFdSet.
PGroup | This is type nxllJwaWinsock2.PGroup.
PHostEnt | This is type nxllJwaWinsock2.PHostEnt.
PIN_ADDR | This is type nxllJwaWinsock2.PIN_ADDR.
PInAddr | This is type nxllJwaWinsock2.PInAddr.
PLinger | This is type nxllJwaWinsock2.PLinger.
PNetEnt | This is type nxllJwaWinsock2.PNetEnt.
PPAnsiChar | This is type nxllJwaWinsock2.PPAnsiChar.
PProtoEnt | This is type nxllJwaWinsock2.PProtoEnt.
PQOS | This is type nxllJwaWinsock2.PQOS.
PServEnt | This is type nxllJwaWinsock2.PServEnt.
PSockAddr | This is type nxllJwaWinsock2.PSockAddr.
PSOCKADDR_IN | Microsoft Windows Extended data types
PSOCKADDR_STORAGE | This is type nxllJwaWinsock2.PSOCKADDR_STORAGE.
PSockAddrIn | This is type nxllJwaWinsock2.PSockAddrIn.
PSockAddrStorage | This is type nxllJwaWinsock2.PSockAddrStorage.
PSOCKET_ADDRESS | This is type nxllJwaWinsock2.PSOCKET_ADDRESS.
PSocketAddress | This is type nxllJwaWinsock2.PSocketAddress.
PSocketAddressList | This is type nxllJwaWinsock2.PSocketAddressList.
PSockProto | This is type nxllJwaWinsock2.PSockProto.
PTimeVal | This is type nxllJwaWinsock2.PTimeVal.
PWsaBuf | This is type nxllJwaWinsock2.PWsaBuf.
PWSACOMPLETION | This is type nxllJwaWinsock2.PWSACOMPLETION.
PWSACOMPLETIONTYPE | This is type nxllJwaWinsock2.PWSACOMPLETIONTYPE.
PWsaData | This is type nxllJwaWinsock2.PWsaData.
PWSAECOMPARATOR | This is type nxllJwaWinsock2.PWSAECOMPARATOR.
PWSAESETSERVICEOP | This is type nxllJwaWinsock2.PWSAESETSERVICEOP.
PWsaEvent | This is type nxllJwaWinsock2.PWsaEvent.
PWSANAMESPACE_INFO | This is type nxllJwaWinsock2.PWSANAMESPACE_INFO.
PWSANAMESPACE_INFOA | This is type nxllJwaWinsock2.PWSANAMESPACE_INFOA.
PWSANAMESPACE_INFOW | This is type nxllJwaWinsock2.PWSANAMESPACE_INFOW.
PWsaNameSpaceInfo | This is type nxllJwaWinsock2.PWsaNameSpaceInfo.
PWsaNameSpaceInfoA | This is type nxllJwaWinsock2.PWsaNameSpaceInfoA.
PWsaNameSpaceInfoW | This is type nxllJwaWinsock2.PWsaNameSpaceInfoW.
PWsaNetworkEvents | This is type nxllJwaWinsock2.PWsaNetworkEvents.
PWSANSCLASSINFO | This is type nxllJwaWinsock2.PWSANSCLASSINFO.
PWSANSCLASSINFOA | This is type nxllJwaWinsock2.PWSANSCLASSINFOA.
PWSANSCLASSINFOW | This is type nxllJwaWinsock2.PWSANSCLASSINFOW.
PWsaOverlapped | This is type nxllJwaWinsock2.PWsaOverlapped.
PWsaProtocolChain | This is type nxllJwaWinsock2.PWsaProtocolChain.
PWsaProtocolInfo | This is type nxllJwaWinsock2.PWsaProtocolInfo.
PWsaProtocolInfoA | This is type nxllJwaWinsock2.PWsaProtocolInfoA.
PWsaProtocolInfoW | This is type nxllJwaWinsock2.PWsaProtocolInfoW.
PWSAQUERYSET | This is type nxllJwaWinsock2.PWSAQUERYSET.
PWSAQUERYSETA | This is type nxllJwaWinsock2.PWSAQUERYSETA.
PWSAQUERYSETW | This is type nxllJwaWinsock2.PWSAQUERYSETW.
PWSASERVICECLASSINFO | This is type nxllJwaWinsock2.PWSASERVICECLASSINFO.
PWSASERVICECLASSINFOA | This is type nxllJwaWinsock2.PWSASERVICECLASSINFOA.
PWSASERVICECLASSINFOW | This is type nxllJwaWinsock2.PWSASERVICECLASSINFOW.
PWSAVERSION | This is type nxllJwaWinsock2.PWSAVERSION.
QOS | This is type nxllJwaWinsock2.QOS.
SOCKET_ADDRESS | This is type nxllJwaWinsock2.SOCKET_ADDRESS.
SOCKET_ADDRESS_LIST | This is type nxllJwaWinsock2.SOCKET_ADDRESS_LIST.
TAfProtocols | This is type nxllJwaWinsock2.TAfProtocols.
TBlob | This is type nxllJwaWinsock2.TBlob.
TCsAddrInfo | This is type nxllJwaWinsock2.TCsAddrInfo.
TFdSet | This is type nxllJwaWinsock2.TFdSet.
TGroup | This is type nxllJwaWinsock2.TGroup.
THostEnt | This is type nxllJwaWinsock2.THostEnt.
TInAddr | This is type nxllJwaWinsock2.TInAddr.
TLinger | This is type nxllJwaWinsock2.TLinger.
TNetEnt | This is type nxllJwaWinsock2.TNetEnt.
TProtoEnt | This is type nxllJwaWinsock2.TProtoEnt.
TQOS | This is type nxllJwaWinsock2.TQOS.
TServEnt | This is type nxllJwaWinsock2.TServEnt.
TSockAddr | This is type nxllJwaWinsock2.TSockAddr.
TSockAddrIn | This is type nxllJwaWinsock2.TSockAddrIn.
TSockAddrStorage | This is type nxllJwaWinsock2.TSockAddrStorage.
TSocket | The new type to be used in all instances which refer to sockets.
TSocketAddress | This is type nxllJwaWinsock2.TSocketAddress.
TSocketAddressList | This is type nxllJwaWinsock2.TSocketAddressList.
TSockProto | This is type nxllJwaWinsock2.TSockProto.
TTimeVal | This is type nxllJwaWinsock2.TTimeVal.
TWsaBuf | This is type nxllJwaWinsock2.TWsaBuf.
TWsaCompletion | This is type nxllJwaWinsock2.TWsaCompletion.
TWsaCompletionType | This is type nxllJwaWinsock2.TWsaCompletionType.
TWsaData | This is type nxllJwaWinsock2.TWsaData.
TWsaEvent | This is type nxllJwaWinsock2.TWsaEvent.
TWsaNameSpaceInfo | This is type nxllJwaWinsock2.TWsaNameSpaceInfo.
TWsaNameSpaceInfoA | This is type nxllJwaWinsock2.TWsaNameSpaceInfoA.
TWsaNameSpaceInfoW | This is type nxllJwaWinsock2.TWsaNameSpaceInfoW.
TWsaNetworkEvents | This is type nxllJwaWinsock2.TWsaNetworkEvents.
TWsaNsClassInfo | This is type nxllJwaWinsock2.TWsaNsClassInfo.
TWsaNsClassInfoA | This is type nxllJwaWinsock2.TWsaNsClassInfoA.
TWsaNsClassInfoW | This is type nxllJwaWinsock2.TWsaNsClassInfoW.
TWsaOverlapped | This is type nxllJwaWinsock2.TWsaOverlapped.
TWsaProtocolChain | This is type nxllJwaWinsock2.TWsaProtocolChain.
TWsaProtocolInfo | This is type nxllJwaWinsock2.TWsaProtocolInfo.
TWsaProtocolInfoA | This is type nxllJwaWinsock2.TWsaProtocolInfoA.
TWsaProtocolInfoW | This is type nxllJwaWinsock2.TWsaProtocolInfoW.
TWsaQuerySet | This is type nxllJwaWinsock2.TWsaQuerySet.
TWsaQuerySetA | This is type nxllJwaWinsock2.TWsaQuerySetA.
TWsaQuerySetW | This is type nxllJwaWinsock2.TWsaQuerySetW.
TWsaServiceClassInfo | This is type nxllJwaWinsock2.TWsaServiceClassInfo.
TWsaServiceClassInfoA | This is type nxllJwaWinsock2.TWsaServiceClassInfoA.
TWsaServiceClassInfoW | This is type nxllJwaWinsock2.TWsaServiceClassInfoW.
TWsaVersion | This is type nxllJwaWinsock2.TWsaVersion.
u_char | Basic system type definitions, taken from the BSD file sys/types.h.
u_int | This is type nxllJwaWinsock2.u_int.
u_int64 | unsigned __int64 !! TODO For Delphi 7 ??
u_long | This is type nxllJwaWinsock2.u_long.
u_short | This is type nxllJwaWinsock2.u_short.
UCHAR | This is type nxllJwaWinsock2.UCHAR.
ULONG | This is type nxllJwaWinsock2.ULONG.
ULONG_PTR | TODO
USHORT | This is type nxllJwaWinsock2.USHORT.
WSABUF | This is type nxllJwaWinsock2.WSABUF.
WSACOMPLETION | This is type nxllJwaWinsock2.WSACOMPLETION.
WSACOMPLETIONTYPE | This is type nxllJwaWinsock2.WSACOMPLETIONTYPE.
WSAECOMPARATOR | This is type nxllJwaWinsock2.WSAECOMPARATOR.
WSAESETSERVICEOP | This is type nxllJwaWinsock2.WSAESETSERVICEOP.
WSAEVENT | WinSock 2 extension -- new error codes and type definition
WSANAMESPACE_INFO | This is type nxllJwaWinsock2.WSANAMESPACE_INFO.
WSANAMESPACE_INFOA | This is type nxllJwaWinsock2.WSANAMESPACE_INFOA.
WSANAMESPACE_INFOW | This is type nxllJwaWinsock2.WSANAMESPACE_INFOW.
WSANETWORKEVENTS | This is type nxllJwaWinsock2.WSANETWORKEVENTS.
WSANSCLASSINFO | This is type nxllJwaWinsock2.WSANSCLASSINFO.
WSANSCLASSINFOA | This is type nxllJwaWinsock2.WSANSCLASSINFOA.
WSANSCLASSINFOW | This is type nxllJwaWinsock2.WSANSCLASSINFOW.
WSAOVERLAPPED | This is type nxllJwaWinsock2.WSAOVERLAPPED.
WSAPROTOCOL_INFO | This is type nxllJwaWinsock2.WSAPROTOCOL_INFO.
WSAPROTOCOL_INFOA | This is type nxllJwaWinsock2.WSAPROTOCOL_INFOA.
WSAPROTOCOL_INFOW | This is type nxllJwaWinsock2.WSAPROTOCOL_INFOW.
WSAPROTOCOLCHAIN | This is type nxllJwaWinsock2.WSAPROTOCOLCHAIN.
WSAQUERYSET | This is type nxllJwaWinsock2.WSAQUERYSET.
WSAQUERYSETA | This is type nxllJwaWinsock2.WSAQUERYSETA.
WSAQUERYSETW | This is type nxllJwaWinsock2.WSAQUERYSETW.
WSASERVICECLASSINFO | This is type nxllJwaWinsock2.WSASERVICECLASSINFO.
WSASERVICECLASSINFOA | This is type nxllJwaWinsock2.WSASERVICECLASSINFOA.
WSASERVICECLASSINFOW | This is type nxllJwaWinsock2.WSASERVICECLASSINFOW.
WSAVERSION | This is type nxllJwaWinsock2.WSAVERSION.
Links
nxllJwaWinsock2 Namespace, Types


nxllJwaWinsock2.AFPROTOCOLS Type

nxllJwaWinsock2.AFPROTOCOLS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
AFPROTOCOLS = _AFPROTOCOLS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.AFPROTOCOLS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.BLOB Type

nxllJwaWinsock2.BLOB Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
BLOB = _BLOB;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.BLOB.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.CSADDR_INFO Type

nxllJwaWinsock2.CSADDR_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
CSADDR_INFO = _CSADDR_INFO;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.CSADDR_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.DWORD_PTR Type

nxllJwaWinsock2.DWORD_PTR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
DWORD_PTR = DWORD;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.DWORD_PTR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.GROUP Type

nxllJwaWinsock2.GROUP Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
GROUP = Cardinal;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- data type and manifest constants for socket groups

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.HANDLE Type

nxllJwaWinsock2.HANDLE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
HANDLE = THandle;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.HANDLE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPAFPROTOCOLS Type

nxllJwaWinsock2.LPAFPROTOCOLS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPAFPROTOCOLS = ^AFPROTOCOLS;
File

nxllJwaWinsock2

Description

Address Family/Protocol Tuples

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPBLOB Type

nxllJwaWinsock2.LPBLOB Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPBLOB = ^BLOB;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPBLOB.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPBYTE Type

nxllJwaWinsock2.LPBYTE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPBYTE = ^BYTE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPBYTE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPCONDITIONPROC Type

nxllJwaWinsock2.LPCONDITIONPROC Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPCONDITIONPROC = function (lpCallerId, lpCallerData: LPWSABUF; lpSQOS, lpGQOS: LPQOS; lpCalleeId, lpCalleeData: LPWSABUF; g: PGROUP; dwCallbackData: DWORD_PTR): Integer;
File

nxllJwaWinsock2

Description

WinSock 2 extensions -- data types for the condition function in WSAAccept() and overlapped I/O completion routine.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPCSADDR_INFO Type

nxllJwaWinsock2.LPCSADDR_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPCSADDR_INFO = ^CSADDR_INFO;
File

nxllJwaWinsock2

Description

CSAddr Information

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPFD_SET Type

nxllJwaWinsock2.LPFD_SET Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPFD_SET = ^fd_set;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPFD_SET.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPHANDLE Type

nxllJwaWinsock2.LPHANDLE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPHANDLE = ^THandle;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPHANDLE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPHOSTENT Type

nxllJwaWinsock2.LPHOSTENT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPHOSTENT = PHOSTENT;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPHOSTENT.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPIN_ADDR Type

nxllJwaWinsock2.LPIN_ADDR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPIN_ADDR = ^in_addr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPIN_ADDR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPLINGER Type

nxllJwaWinsock2.LPLINGER Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPLINGER = PLINGER;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPLINGER.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPPROTOENT Type

nxllJwaWinsock2.LPPROTOENT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPPROTOENT = PPROTOENT;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPPROTOENT.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPQOS Type

nxllJwaWinsock2.LPQOS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPQOS = ^_QualityOfService;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPQOS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSERVENT Type

nxllJwaWinsock2.LPSERVENT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSERVENT = PSERVENT;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPSERVENT.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSOCKADDR Type

nxllJwaWinsock2.LPSOCKADDR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSOCKADDR = ^sockaddr;
File

nxllJwaWinsock2

Description

Microsoft Windows Extended data types required for the functions to convert back and forth between binary and string forms of addresses.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSOCKADDR_IN Type

nxllJwaWinsock2.LPSOCKADDR_IN Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSOCKADDR_IN = ^sockaddr_in;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPSOCKADDR_IN.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSOCKADDR_STORAGE Type

nxllJwaWinsock2.LPSOCKADDR_STORAGE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSOCKADDR_STORAGE = ^sockaddr_storage;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPSOCKADDR_STORAGE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSOCKET_ADDRESS Type

nxllJwaWinsock2.LPSOCKET_ADDRESS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSOCKET_ADDRESS = ^SOCKET_ADDRESS;
File

nxllJwaWinsock2

Description

SockAddr Information

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPSOCKET_ADDRESS_LIST Type

nxllJwaWinsock2.LPSOCKET_ADDRESS_LIST Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPSOCKET_ADDRESS_LIST = ^SOCKET_ADDRESS_LIST;
File

nxllJwaWinsock2

Description

Address list returned via SIO_ADDRESS_LIST_QUERY

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPTIMEVAL Type

nxllJwaWinsock2.LPTIMEVAL Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPTIMEVAL = PTIMEVAL;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPTIMEVAL.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPVOID Type

nxllJwaWinsock2.LPVOID Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPVOID = Pointer;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPVOID.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSABUF Type

nxllJwaWinsock2.LPWSABUF Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSABUF = ^_WSABUF;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSABUF.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSACOMPLETION Type

nxllJwaWinsock2.LPWSACOMPLETION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSACOMPLETION = ^WSACOMPLETION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSACOMPLETION.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSACOMPLETIONTYPE Type

nxllJwaWinsock2.LPWSACOMPLETIONTYPE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSACOMPLETIONTYPE = ^WSACOMPLETIONTYPE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSACOMPLETIONTYPE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSADATA Type

nxllJwaWinsock2.LPWSADATA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSADATA = ^WSAData;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSADATA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAECOMPARATOR Type

nxllJwaWinsock2.LPWSAECOMPARATOR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAECOMPARATOR = ^WSAECOMPARATOR;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAECOMPARATOR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAESETSERVICEOP Type

nxllJwaWinsock2.LPWSAESETSERVICEOP Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAESETSERVICEOP = ^WSAESETSERVICEOP;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAESETSERVICEOP.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAEVENT Type

nxllJwaWinsock2.LPWSAEVENT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAEVENT = LPHANDLE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAEVENT.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANAMESPACE_INFO Type

nxllJwaWinsock2.LPWSANAMESPACE_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANAMESPACE_INFO = LPWSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANAMESPACE_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANAMESPACE_INFOA Type

nxllJwaWinsock2.LPWSANAMESPACE_INFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANAMESPACE_INFOA = ^WSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANAMESPACE_INFOW Type

nxllJwaWinsock2.LPWSANAMESPACE_INFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANAMESPACE_INFOW = ^WSANAMESPACE_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANAMESPACE_INFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANETWORKEVENTS Type

nxllJwaWinsock2.LPWSANETWORKEVENTS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANETWORKEVENTS = ^WSANETWORKEVENTS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANETWORKEVENTS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANSCLASSINFO Type

nxllJwaWinsock2.LPWSANSCLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANSCLASSINFO = LPWSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANSCLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANSCLASSINFOA Type

nxllJwaWinsock2.LPWSANSCLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANSCLASSINFOA = ^WSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANSCLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSANSCLASSINFOW Type

nxllJwaWinsock2.LPWSANSCLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSANSCLASSINFOW = ^WSANSCLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSANSCLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAOVERLAPPED Type

nxllJwaWinsock2.LPWSAOVERLAPPED Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAOVERLAPPED = ^OVERLAPPED;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAOVERLAPPED.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAOVERLAPPED_COMPLETION_ROUTINE Type

nxllJwaWinsock2.LPWSAOVERLAPPED_COMPLETION_ROUTINE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAOVERLAPPED_COMPLETION_ROUTINE = procedure (dwError, cbTransferred: DWORD; lpOverlapped: LPWSAOVERLAPPED; dwFlags: DWORD);
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAOVERLAPPED_COMPLETION_ROUTINE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAPROTOCOL_INFO Type

nxllJwaWinsock2.LPWSAPROTOCOL_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAPROTOCOL_INFO = LPWSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAPROTOCOL_INFOA Type

nxllJwaWinsock2.LPWSAPROTOCOL_INFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAPROTOCOL_INFOA = ^WSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAPROTOCOL_INFOW Type

nxllJwaWinsock2.LPWSAPROTOCOL_INFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAPROTOCOL_INFOW = ^WSAPROTOCOL_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAPROTOCOL_INFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAPROTOCOLCHAIN Type

nxllJwaWinsock2.LPWSAPROTOCOLCHAIN Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAPROTOCOLCHAIN = ^WSAPROTOCOLCHAIN;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAPROTOCOLCHAIN.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAQUERYSET Type

nxllJwaWinsock2.LPWSAQUERYSET Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAQUERYSET = LPWSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAQUERYSET.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAQUERYSETA Type

nxllJwaWinsock2.LPWSAQUERYSETA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAQUERYSETA = ^WSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAQUERYSETA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAQUERYSETW Type

nxllJwaWinsock2.LPWSAQUERYSETW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAQUERYSETW = ^WSAQUERYSETW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAQUERYSETW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSASERVICECLASSINFO Type

nxllJwaWinsock2.LPWSASERVICECLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSASERVICECLASSINFO = LPWSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSASERVICECLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSASERVICECLASSINFOA Type

nxllJwaWinsock2.LPWSASERVICECLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSASERVICECLASSINFOA = ^WSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSASERVICECLASSINFOW Type

nxllJwaWinsock2.LPWSASERVICECLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSASERVICECLASSINFOW = ^WSASERVICECLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSASERVICECLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.LPWSAVERSION Type

nxllJwaWinsock2.LPWSAVERSION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
LPWSAVERSION = ^WSAVERSION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.LPWSAVERSION.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PAFPROTOCOLS Type

nxllJwaWinsock2.PAFPROTOCOLS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PAFPROTOCOLS = ^AFPROTOCOLS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PAFPROTOCOLS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PBlob Type

nxllJwaWinsock2.PBlob Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PBlob = LPBLOB;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PBlob.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PCSADDR_INFO Type

nxllJwaWinsock2.PCSADDR_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PCSADDR_INFO = ^CSADDR_INFO;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PCSADDR_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PCsAddrInfo Type

nxllJwaWinsock2.PCsAddrInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PCsAddrInfo = PCSADDR_INFO;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PCsAddrInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PFD_SET Type

nxllJwaWinsock2.PFD_SET Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PFD_SET = ^fd_set;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PFD_SET.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PFdSet Type

nxllJwaWinsock2.PFdSet Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PFdSet = ^fd_set;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PFdSet.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PGroup Type

nxllJwaWinsock2.PGroup Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PGroup = ^GROUP;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PGroup.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PHostEnt Type

nxllJwaWinsock2.PHostEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PHostEnt = ^hostent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PHostEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PIN_ADDR Type

nxllJwaWinsock2.PIN_ADDR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PIN_ADDR = ^in_addr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PIN_ADDR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PInAddr Type

nxllJwaWinsock2.PInAddr Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PInAddr = ^in_addr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PInAddr.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PLinger Type

nxllJwaWinsock2.PLinger Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PLinger = ^linger;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PLinger.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PNetEnt Type

nxllJwaWinsock2.PNetEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PNetEnt = ^netent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PNetEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PPAnsiChar Type

nxllJwaWinsock2.PPAnsiChar Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PPAnsiChar = ^PAnsiChar;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PPAnsiChar.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PProtoEnt Type

nxllJwaWinsock2.PProtoEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PProtoEnt = ^protoent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PProtoEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PQOS Type

nxllJwaWinsock2.PQOS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PQOS = LPQOS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PQOS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PServEnt Type

nxllJwaWinsock2.PServEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PServEnt = ^servent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PServEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSockAddr Type

nxllJwaWinsock2.PSockAddr Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSockAddr = ^sockaddr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSockAddr.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSOCKADDR_IN Type

nxllJwaWinsock2.PSOCKADDR_IN Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSOCKADDR_IN = ^sockaddr_in;
File

nxllJwaWinsock2

Description

Microsoft Windows Extended data types

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSOCKADDR_STORAGE Type

nxllJwaWinsock2.PSOCKADDR_STORAGE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSOCKADDR_STORAGE = ^sockaddr_storage;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSOCKADDR_STORAGE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSockAddrIn Type

nxllJwaWinsock2.PSockAddrIn Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSockAddrIn = ^sockaddr_in;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSockAddrIn.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSockAddrStorage Type

nxllJwaWinsock2.PSockAddrStorage Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSockAddrStorage = ^sockaddr_storage;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSockAddrStorage.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSOCKET_ADDRESS Type

nxllJwaWinsock2.PSOCKET_ADDRESS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSOCKET_ADDRESS = ^SOCKET_ADDRESS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSOCKET_ADDRESS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSocketAddress Type

nxllJwaWinsock2.PSocketAddress Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSocketAddress = PSOCKET_ADDRESS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSocketAddress.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSocketAddressList Type

nxllJwaWinsock2.PSocketAddressList Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSocketAddressList = LPSOCKET_ADDRESS_LIST;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSocketAddressList.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PSockProto Type

nxllJwaWinsock2.PSockProto Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PSockProto = ^sockproto;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PSockProto.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PTimeVal Type

nxllJwaWinsock2.PTimeVal Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PTimeVal = ^timeval;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PTimeVal.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaBuf Type

nxllJwaWinsock2.PWsaBuf Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaBuf = LPWSABUF;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaBuf.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSACOMPLETION Type

nxllJwaWinsock2.PWSACOMPLETION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSACOMPLETION = ^WSACOMPLETION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSACOMPLETION.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSACOMPLETIONTYPE Type

nxllJwaWinsock2.PWSACOMPLETIONTYPE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSACOMPLETIONTYPE = ^WSACOMPLETIONTYPE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSACOMPLETIONTYPE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaData Type

nxllJwaWinsock2.PWsaData Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaData = LPWSADATA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaData.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAECOMPARATOR Type

nxllJwaWinsock2.PWSAECOMPARATOR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAECOMPARATOR = ^WSAECOMPARATOR;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAECOMPARATOR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAESETSERVICEOP Type

nxllJwaWinsock2.PWSAESETSERVICEOP Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAESETSERVICEOP = ^WSAESETSERVICEOP;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAESETSERVICEOP.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaEvent Type

nxllJwaWinsock2.PWsaEvent Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaEvent = LPWSAEVENT;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaEvent.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANAMESPACE_INFO Type

nxllJwaWinsock2.PWSANAMESPACE_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANAMESPACE_INFO = PWSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANAMESPACE_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANAMESPACE_INFOA Type

nxllJwaWinsock2.PWSANAMESPACE_INFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANAMESPACE_INFOA = ^WSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANAMESPACE_INFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANAMESPACE_INFOW Type

nxllJwaWinsock2.PWSANAMESPACE_INFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANAMESPACE_INFOW = ^WSANAMESPACE_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANAMESPACE_INFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaNameSpaceInfo Type

nxllJwaWinsock2.PWsaNameSpaceInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaNameSpaceInfo = PWsaNameSpaceInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaNameSpaceInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaNameSpaceInfoA Type

nxllJwaWinsock2.PWsaNameSpaceInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaNameSpaceInfoA = LPWSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaNameSpaceInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaNameSpaceInfoW Type

nxllJwaWinsock2.PWsaNameSpaceInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaNameSpaceInfoW = PWSANAMESPACE_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaNameSpaceInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaNetworkEvents Type

nxllJwaWinsock2.PWsaNetworkEvents Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaNetworkEvents = LPWSANETWORKEVENTS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaNetworkEvents.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANSCLASSINFO Type

nxllJwaWinsock2.PWSANSCLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANSCLASSINFO = PWSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANSCLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANSCLASSINFOA Type

nxllJwaWinsock2.PWSANSCLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANSCLASSINFOA = ^WSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANSCLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSANSCLASSINFOW Type

nxllJwaWinsock2.PWSANSCLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSANSCLASSINFOW = ^WSANSCLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSANSCLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaOverlapped Type

nxllJwaWinsock2.PWsaOverlapped Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaOverlapped = LPWSAOVERLAPPED;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaOverlapped.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaProtocolChain Type

nxllJwaWinsock2.PWsaProtocolChain Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaProtocolChain = LPWSAPROTOCOLCHAIN;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaProtocolChain.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaProtocolInfo Type

nxllJwaWinsock2.PWsaProtocolInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaProtocolInfo = PWsaProtocolInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaProtocolInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaProtocolInfoA Type

nxllJwaWinsock2.PWsaProtocolInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaProtocolInfoA = LPWSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaProtocolInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWsaProtocolInfoW Type

nxllJwaWinsock2.PWsaProtocolInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWsaProtocolInfoW = LPWSAPROTOCOL_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWsaProtocolInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAQUERYSET Type

nxllJwaWinsock2.PWSAQUERYSET Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAQUERYSET = PWSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAQUERYSET.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAQUERYSETA Type

nxllJwaWinsock2.PWSAQUERYSETA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAQUERYSETA = ^WSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAQUERYSETA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAQUERYSETW Type

nxllJwaWinsock2.PWSAQUERYSETW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAQUERYSETW = ^WSAQUERYSETW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAQUERYSETW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSASERVICECLASSINFO Type

nxllJwaWinsock2.PWSASERVICECLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSASERVICECLASSINFO = PWSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSASERVICECLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSASERVICECLASSINFOA Type

nxllJwaWinsock2.PWSASERVICECLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSASERVICECLASSINFOA = ^WSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSASERVICECLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSASERVICECLASSINFOW Type

nxllJwaWinsock2.PWSASERVICECLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSASERVICECLASSINFOW = ^WSASERVICECLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSASERVICECLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.PWSAVERSION Type

nxllJwaWinsock2.PWSAVERSION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
PWSAVERSION = ^WSAVERSION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.PWSAVERSION.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.QOS Type

nxllJwaWinsock2.QOS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
QOS = _QualityOfService;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.QOS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.SOCKET_ADDRESS Type

nxllJwaWinsock2.SOCKET_ADDRESS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
SOCKET_ADDRESS = _SOCKET_ADDRESS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.SOCKET_ADDRESS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.SOCKET_ADDRESS_LIST Type

nxllJwaWinsock2.SOCKET_ADDRESS_LIST Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
SOCKET_ADDRESS_LIST = _SOCKET_ADDRESS_LIST;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.SOCKET_ADDRESS_LIST.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TAfProtocols Type

nxllJwaWinsock2.TAfProtocols Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TAfProtocols = AFPROTOCOLS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TAfProtocols.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TBlob Type

nxllJwaWinsock2.TBlob Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TBlob = BLOB;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TBlob.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TCsAddrInfo Type

nxllJwaWinsock2.TCsAddrInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TCsAddrInfo = CSADDR_INFO;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TCsAddrInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TFdSet Type

nxllJwaWinsock2.TFdSet Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TFdSet = fd_set;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TFdSet.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TGroup Type

nxllJwaWinsock2.TGroup Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TGroup = GROUP;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TGroup.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.THostEnt Type

nxllJwaWinsock2.THostEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
THostEnt = hostent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.THostEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TInAddr Type

nxllJwaWinsock2.TInAddr Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TInAddr = in_addr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TInAddr.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TLinger Type

nxllJwaWinsock2.TLinger Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TLinger = linger;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TLinger.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TNetEnt Type

nxllJwaWinsock2.TNetEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TNetEnt = netent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TNetEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TProtoEnt Type

nxllJwaWinsock2.TProtoEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TProtoEnt = protoent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TProtoEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TQOS Type

nxllJwaWinsock2.TQOS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TQOS = QOS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TQOS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TServEnt Type

nxllJwaWinsock2.TServEnt Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TServEnt = servent;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TServEnt.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSockAddr Type

nxllJwaWinsock2.TSockAddr Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSockAddr = sockaddr;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSockAddr.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSockAddrIn Type

nxllJwaWinsock2.TSockAddrIn Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSockAddrIn = sockaddr_in;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSockAddrIn.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSockAddrStorage Type

nxllJwaWinsock2.TSockAddrStorage Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSockAddrStorage = sockaddr_storage;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSockAddrStorage.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSocket Type

nxllJwaWinsock2.TSocket Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSocket = HANDLE;
File

nxllJwaWinsock2

Description

The new type to be used in all instances which refer to sockets.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSocketAddress Type

nxllJwaWinsock2.TSocketAddress Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSocketAddress = SOCKET_ADDRESS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSocketAddress.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSocketAddressList Type

nxllJwaWinsock2.TSocketAddressList Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSocketAddressList = SOCKET_ADDRESS_LIST;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSocketAddressList.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TSockProto Type

nxllJwaWinsock2.TSockProto Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TSockProto = sockproto;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TSockProto.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TTimeVal Type

nxllJwaWinsock2.TTimeVal Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TTimeVal = timeval;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TTimeVal.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaBuf Type

nxllJwaWinsock2.TWsaBuf Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaBuf = WSABUF;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaBuf.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaCompletion Type

nxllJwaWinsock2.TWsaCompletion Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaCompletion = WSACOMPLETION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaCompletion.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaCompletionType Type

nxllJwaWinsock2.TWsaCompletionType Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaCompletionType = WSACOMPLETIONTYPE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaCompletionType.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaData Type

nxllJwaWinsock2.TWsaData Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaData = WSAData;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaData.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaEvent Type

nxllJwaWinsock2.TWsaEvent Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaEvent = WSAEVENT;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaEvent.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNameSpaceInfo Type

nxllJwaWinsock2.TWsaNameSpaceInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNameSpaceInfo = TWsaNameSpaceInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNameSpaceInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNameSpaceInfoA Type

nxllJwaWinsock2.TWsaNameSpaceInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNameSpaceInfoA = WSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNameSpaceInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNameSpaceInfoW Type

nxllJwaWinsock2.TWsaNameSpaceInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNameSpaceInfoW = WSANAMESPACE_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNameSpaceInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNetworkEvents Type

nxllJwaWinsock2.TWsaNetworkEvents Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNetworkEvents = WSANETWORKEVENTS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNetworkEvents.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNsClassInfo Type

nxllJwaWinsock2.TWsaNsClassInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNsClassInfo = TWsaNsClassInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNsClassInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNsClassInfoA Type

nxllJwaWinsock2.TWsaNsClassInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNsClassInfoA = WSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNsClassInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaNsClassInfoW Type

nxllJwaWinsock2.TWsaNsClassInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaNsClassInfoW = WSANSCLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaNsClassInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaOverlapped Type

nxllJwaWinsock2.TWsaOverlapped Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaOverlapped = WSAOVERLAPPED;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaOverlapped.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaProtocolChain Type

nxllJwaWinsock2.TWsaProtocolChain Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaProtocolChain = WSAPROTOCOLCHAIN;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaProtocolChain.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaProtocolInfo Type

nxllJwaWinsock2.TWsaProtocolInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaProtocolInfo = TWsaProtocolInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaProtocolInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaProtocolInfoA Type

nxllJwaWinsock2.TWsaProtocolInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaProtocolInfoA = WSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaProtocolInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaProtocolInfoW Type

nxllJwaWinsock2.TWsaProtocolInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaProtocolInfoW = WSAPROTOCOL_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaProtocolInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaQuerySet Type

nxllJwaWinsock2.TWsaQuerySet Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaQuerySet = TWsaQuerySetA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaQuerySet.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaQuerySetA Type

nxllJwaWinsock2.TWsaQuerySetA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaQuerySetA = WSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaQuerySetA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaQuerySetW Type

nxllJwaWinsock2.TWsaQuerySetW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaQuerySetW = WSAQUERYSETW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaQuerySetW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaServiceClassInfo Type

nxllJwaWinsock2.TWsaServiceClassInfo Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaServiceClassInfo = TWsaServiceClassInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaServiceClassInfo.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaServiceClassInfoA Type

nxllJwaWinsock2.TWsaServiceClassInfoA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaServiceClassInfoA = WSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaServiceClassInfoA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaServiceClassInfoW Type

nxllJwaWinsock2.TWsaServiceClassInfoW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaServiceClassInfoW = WSASERVICECLASSINFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaServiceClassInfoW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.TWsaVersion Type

nxllJwaWinsock2.TWsaVersion Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
TWsaVersion = WSAVERSION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.TWsaVersion.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.u_char Type

nxllJwaWinsock2.u_char Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
u_char = Byte;
File

nxllJwaWinsock2

Description

Basic system type definitions, taken from the BSD file sys/types.h.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.u_int Type

nxllJwaWinsock2.u_int Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
u_int = Cardinal;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.u_int.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.u_int64 Type

nxllJwaWinsock2.u_int64 Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
u_int64 = Int64;
File

nxllJwaWinsock2

Description

unsigned __int64 !! TODO For Delphi 7 ??

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.u_long Type

nxllJwaWinsock2.u_long Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
u_long = Cardinal;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.u_long.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.u_short Type

nxllJwaWinsock2.u_short Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
u_short = Word;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.u_short.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.UCHAR Type

nxllJwaWinsock2.UCHAR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
UCHAR = Byte;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.UCHAR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.ULONG Type

nxllJwaWinsock2.ULONG Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
ULONG = Cardinal;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.ULONG.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.ULONG_PTR Type

nxllJwaWinsock2.ULONG_PTR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
ULONG_PTR = ULONG;
File

nxllJwaWinsock2

Description

TODO

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.USHORT Type

nxllJwaWinsock2.USHORT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
USHORT = Word;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.USHORT.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSABUF Type

nxllJwaWinsock2.WSABUF Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSABUF = _WSABUF;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSABUF.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSACOMPLETION Type

nxllJwaWinsock2.WSACOMPLETION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSACOMPLETION = _WSACOMPLETION;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSACOMPLETION.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSACOMPLETIONTYPE Type

nxllJwaWinsock2.WSACOMPLETIONTYPE Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSACOMPLETIONTYPE = _WSACOMPLETIONTYPE;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSACOMPLETIONTYPE.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAECOMPARATOR Type

nxllJwaWinsock2.WSAECOMPARATOR Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAECOMPARATOR = _WSAEcomparator;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAECOMPARATOR.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAESETSERVICEOP Type

nxllJwaWinsock2.WSAESETSERVICEOP Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAESETSERVICEOP = _WSAESETSERVICEOP;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAESETSERVICEOP.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAEVENT Type

nxllJwaWinsock2.WSAEVENT Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAEVENT = HANDLE;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- new error codes and type definition

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANAMESPACE_INFO Type

nxllJwaWinsock2.WSANAMESPACE_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANAMESPACE_INFO = WSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANAMESPACE_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANAMESPACE_INFOA Type

nxllJwaWinsock2.WSANAMESPACE_INFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANAMESPACE_INFOA = _WSANAMESPACE_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANAMESPACE_INFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANAMESPACE_INFOW Type

nxllJwaWinsock2.WSANAMESPACE_INFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANAMESPACE_INFOW = _WSANAMESPACE_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANAMESPACE_INFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANETWORKEVENTS Type

nxllJwaWinsock2.WSANETWORKEVENTS Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANETWORKEVENTS = _WSANETWORKEVENTS;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANETWORKEVENTS.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANSCLASSINFO Type

nxllJwaWinsock2.WSANSCLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANSCLASSINFO = WSANSCLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANSCLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANSCLASSINFOA Type

nxllJwaWinsock2.WSANSCLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANSCLASSINFOA = _WSANSClassInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANSCLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSANSCLASSINFOW Type

nxllJwaWinsock2.WSANSCLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSANSCLASSINFOW = _WSANSClassInfoW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSANSCLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAOVERLAPPED Type

nxllJwaWinsock2.WSAOVERLAPPED Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAOVERLAPPED = OVERLAPPED;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAOVERLAPPED.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAPROTOCOL_INFO Type

nxllJwaWinsock2.WSAPROTOCOL_INFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAPROTOCOL_INFO = WSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAPROTOCOL_INFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAPROTOCOL_INFOA Type

nxllJwaWinsock2.WSAPROTOCOL_INFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAPROTOCOL_INFOA = _WSAPROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAPROTOCOL_INFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAPROTOCOL_INFOW Type

nxllJwaWinsock2.WSAPROTOCOL_INFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAPROTOCOL_INFOW = _WSAPROTOCOL_INFOW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAPROTOCOL_INFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAPROTOCOLCHAIN Type

nxllJwaWinsock2.WSAPROTOCOLCHAIN Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAPROTOCOLCHAIN = _WSAPROTOCOLCHAIN;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAPROTOCOLCHAIN.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAQUERYSET Type

nxllJwaWinsock2.WSAQUERYSET Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAQUERYSET = WSAQUERYSETA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAQUERYSET.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAQUERYSETA Type

nxllJwaWinsock2.WSAQUERYSETA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAQUERYSETA = _WSAQuerySetA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAQUERYSETA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAQUERYSETW Type

nxllJwaWinsock2.WSAQUERYSETW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAQUERYSETW = _WSAQuerySetW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAQUERYSETW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSASERVICECLASSINFO Type

nxllJwaWinsock2.WSASERVICECLASSINFO Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSASERVICECLASSINFO = WSASERVICECLASSINFOA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSASERVICECLASSINFO.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSASERVICECLASSINFOA Type

nxllJwaWinsock2.WSASERVICECLASSINFOA Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSASERVICECLASSINFOA = _WSAServiceClassInfoA;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSASERVICECLASSINFOA.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSASERVICECLASSINFOW Type

nxllJwaWinsock2.WSASERVICECLASSINFOW Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSASERVICECLASSINFOW = _WSAServiceClassInfoW;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSASERVICECLASSINFOW.

Group

Types

Links
nxllJwaWinsock2, Types


nxllJwaWinsock2.WSAVERSION Type

nxllJwaWinsock2.WSAVERSION Type
nxllJwaWinsock2 Types Send Feedback
Syntax
Delphi
WSAVERSION = _WSAVersion;
File

nxllJwaWinsock2

Description

This is type nxllJwaWinsock2.WSAVERSION.

Group

Types

Links
nxllJwaWinsock2, Types


Variables

Variables
nxllJwaWinsock2 Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllJwaWinsock2 Namespace

Variables
Name | Description
___WSAFDIsSet | This is variable nxllJwaWinsock2.___WSAFDIsSet.
Links
nxllJwaWinsock2 Namespace, Variables


nxllJwaWinsock2.___WSAFDIsSet Variable

nxllJwaWinsock2.___WSAFDIsSet Variable
nxllJwaWinsock2 Variables Send Feedback
Syntax
Delphi
___WSAFDIsSet: Pointer;
File

nxllJwaWinsock2

Description

This is variable nxllJwaWinsock2.___WSAFDIsSet.

Group

Variables

Links
nxllJwaWinsock2, Variables


Constants

Constants
Constants nxllJwaWinsock2 Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_SS_ALIGNSIZE | Desired alignment.
_SS_MAXSIZE | Maximum size.
_SS_PAD1SIZE | Definitions used for sockaddr_storage structure paddings design.
_SS_PAD2SIZE | This is constant nxllJwaWinsock2._SS_PAD2SIZE.
ADDR_ANY | This is constant nxllJwaWinsock2.ADDR_ANY.
AF_12844 | IEEE 1284.4 WG AF
AF_APPLETALK | AppleTalk
AF_ATM | Native ATM Services
AF_BAN | Banyan
AF_CCITT | CCITT protocols, X.25 etc
AF_CHAOS | mit CHAOS protocols
AF_CLUSTER | Microsoft Wolfpack
AF_DATAKIT | datakit protocols
AF_DECnet | DECnet
AF_DLI | Direct data link interface
AF_ECMA | european computer manufacturers
AF_FIREFOX | Protocols from Firefox
AF_HYLINK | NSC Hyperchannel
AF_ICLFXBM | This is constant nxllJwaWinsock2.AF_ICLFXBM.
AF_IMPLINK | arpanet imp addresses
AF_INET | internetwork: UDP, TCP, etc.
AF_INET6 | Internetwork Version 6
AF_IPX | IPX protocols: IPX, SPX, etc.
AF_IRDA | IrDA
AF_ISO | ISO protocols
AF_LAT | LAT
AF_MAX | This is constant nxllJwaWinsock2.AF_MAX.
AF_NETBIOS | NetBios-style addresses
AF_NETDES | Network Designers OSI & gateway enabled protocols
AF_NS | XEROX NS protocols
AF_OSI | OSI is ISO
AF_PUP | pup protocols: e.g. BSP
AF_SNA | IBM SNA
AF_TCNMESSAGE | This is constant nxllJwaWinsock2.AF_TCNMESSAGE.
AF_TCNPROCESS | This is constant nxllJwaWinsock2.AF_TCNPROCESS.
AF_UNIX | local to host (pipes, portals
AF_UNKNOWN1 | Somebody is using this!
AF_UNSPEC | unspecified
AF_VOICEVIEW | VoiceView
BASE_PROTOCOL | This is constant nxllJwaWinsock2.BASE_PROTOCOL.
BIGENDIAN | This is constant nxllJwaWinsock2.BIGENDIAN.
CF_ACCEPT | WinSock 2 extension -- manifest constants for return values of the condition function
CF_DEFER | This is constant nxllJwaWinsock2.CF_DEFER.
CF_REJECT | This is constant nxllJwaWinsock2.CF_REJECT.
EADDRINUSE | This is constant nxllJwaWinsock2.EADDRINUSE.
EADDRNOTAVAIL | This is constant nxllJwaWinsock2.EADDRNOTAVAIL.
EAFNOSUPPORT | This is constant nxllJwaWinsock2.EAFNOSUPPORT.
EALREADY | This is constant nxllJwaWinsock2.EALREADY.
ECONNABORTED | This is constant nxllJwaWinsock2.ECONNABORTED.
ECONNREFUSED | This is constant nxllJwaWinsock2.ECONNREFUSED.
ECONNRESET | This is constant nxllJwaWinsock2.ECONNRESET.
EDESTADDRREQ | This is constant nxllJwaWinsock2.EDESTADDRREQ.
EDQUOT | This is constant nxllJwaWinsock2.EDQUOT.
EHOSTDOWN | This is constant nxllJwaWinsock2.EHOSTDOWN.
EHOSTUNREACH | This is constant nxllJwaWinsock2.EHOSTUNREACH.
EINPROGRESS | This is constant nxllJwaWinsock2.EINPROGRESS.
EISCONN | This is constant nxllJwaWinsock2.EISCONN.
ELOOP | This is constant nxllJwaWinsock2.ELOOP.
EMSGSIZE | This is constant nxllJwaWinsock2.EMSGSIZE.
ENAMETOOLONG | This is constant nxllJwaWinsock2.ENAMETOOLONG.
ENETDOWN | This is constant nxllJwaWinsock2.ENETDOWN.
ENETRESET | This is constant nxllJwaWinsock2.ENETRESET.
ENETUNREACH | This is constant nxllJwaWinsock2.ENETUNREACH.
ENOBUFS | This is constant nxllJwaWinsock2.ENOBUFS.
ENOPROTOOPT | This is constant nxllJwaWinsock2.ENOPROTOOPT.
ENOTCONN | This is constant nxllJwaWinsock2.ENOTCONN.
ENOTEMPTY | This is constant nxllJwaWinsock2.ENOTEMPTY.
ENOTSOCK | This is constant nxllJwaWinsock2.ENOTSOCK.
EOPNOTSUPP | This is constant nxllJwaWinsock2.EOPNOTSUPP.
EPFNOSUPPORT | This is constant nxllJwaWinsock2.EPFNOSUPPORT.
EPROCLIM | This is constant nxllJwaWinsock2.EPROCLIM.
EPROTONOSUPPORT | This is constant nxllJwaWinsock2.EPROTONOSUPPORT.
EPROTOTYPE | This is constant nxllJwaWinsock2.EPROTOTYPE.
EREMOTE | This is constant nxllJwaWinsock2.EREMOTE.
ESHUTDOWN | This is constant nxllJwaWinsock2.ESHUTDOWN.
ESOCKTNOSUPPORT | This is constant nxllJwaWinsock2.ESOCKTNOSUPPORT.
ESTALE | This is constant nxllJwaWinsock2.ESTALE.
ETIMEDOUT | This is constant nxllJwaWinsock2.ETIMEDOUT.
ETOOMANYREFS | This is constant nxllJwaWinsock2.ETOOMANYREFS.
EUSERS | This is constant nxllJwaWinsock2.EUSERS.
EWOULDBLOCK | Windows Sockets errors redefined as regular Berkeley error constants. These are commented out in Windows NT to avoid conflicts with errno.h. Use the WSA constants instead.
FD_ACCEPT | This is constant nxllJwaWinsock2.FD_ACCEPT.
FD_ACCEPT_BIT | This is constant nxllJwaWinsock2.FD_ACCEPT_BIT.
FD_ADDRESS_LIST_CHANGE | This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE.
FD_ADDRESS_LIST_CHANGE_BIT | This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE_BIT.
FD_ALL_EVENTS | This is constant nxllJwaWinsock2.FD_ALL_EVENTS.
FD_CLOSE | This is constant nxllJwaWinsock2.FD_CLOSE.
FD_CLOSE_BIT | This is constant nxllJwaWinsock2.FD_CLOSE_BIT.
FD_CONNECT | This is constant nxllJwaWinsock2.FD_CONNECT.
FD_CONNECT_BIT | This is constant nxllJwaWinsock2.FD_CONNECT_BIT.
FD_GROUP_QOS | This is constant nxllJwaWinsock2.FD_GROUP_QOS.
FD_GROUP_QOS_BIT | This is constant nxllJwaWinsock2.FD_GROUP_QOS_BIT.
FD_MAX_EVENTS | This is constant nxllJwaWinsock2.FD_MAX_EVENTS.
FD_OOB | This is constant nxllJwaWinsock2.FD_OOB.
FD_OOB_BIT | This is constant nxllJwaWinsock2.FD_OOB_BIT.
FD_QOS | This is constant nxllJwaWinsock2.FD_QOS.
FD_QOS_BIT | This is constant nxllJwaWinsock2.FD_QOS_BIT.
FD_READ | This is constant nxllJwaWinsock2.FD_READ.
FD_READ_BIT | WinSock 2 extension -- bit values and indices for FD_XXX network events
FD_ROUTING_INTERFACE_CHANGE | This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE.
FD_ROUTING_INTERFACE_CHANGE_BIT | This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE_BIT.
FD_SETSIZE | Select uses arrays of SOCKETs. These macros manipulate such arrays. FD_SETSIZE may be defined by the user before including this file, but the default here should be >= 64. CAVEAT IMPLEMENTOR and USER: THESE MACROS AND TYPES MUST BE INCLUDED IN WINSOCK2.H EXACTLY AS SHOWN HERE.
FD_WRITE | This is constant nxllJwaWinsock2.FD_WRITE.
FD_WRITE_BIT | This is constant nxllJwaWinsock2.FD_WRITE_BIT.
FIOASYNC | set/clear async i/o
FIONBIO | set/clear non-blocking i/o
FIONREAD | get # bytes to read
FROM_PROTOCOL_INFO | The following may be used in place of the address family, socket type, or protocol in a call to WSASocket to indicate that the corresponding value should be taken from the supplied WSAPROTOCOL_INFO structure instead of the parameter itself.
HOST_NOT_FOUND | This is constant nxllJwaWinsock2.HOST_NOT_FOUND.
IMPLINK_HIGHEXPER | This is constant nxllJwaWinsock2.IMPLINK_HIGHEXPER.
IMPLINK_IP | Link numbers
IMPLINK_LOWEXPER | This is constant nxllJwaWinsock2.IMPLINK_LOWEXPER.
IN_CLASSA_HOST | This is constant nxllJwaWinsock2.IN_CLASSA_HOST.
IN_CLASSA_MAX | This is constant nxllJwaWinsock2.IN_CLASSA_MAX.
IN_CLASSA_NET | This is constant nxllJwaWinsock2.IN_CLASSA_NET.
IN_CLASSA_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSA_NSHIFT.
IN_CLASSB_HOST | This is constant nxllJwaWinsock2.IN_CLASSB_HOST.
IN_CLASSB_MAX | This is constant nxllJwaWinsock2.IN_CLASSB_MAX.
IN_CLASSB_NET | This is constant nxllJwaWinsock2.IN_CLASSB_NET.
IN_CLASSB_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSB_NSHIFT.
IN_CLASSC_HOST | This is constant nxllJwaWinsock2.IN_CLASSC_HOST.
IN_CLASSC_NET | This is constant nxllJwaWinsock2.IN_CLASSC_NET.
IN_CLASSC_NSHIFT | This is constant nxllJwaWinsock2.IN_CLASSC_NSHIFT.
IN_CLASSD_HOST | routing needn't know.
IN_CLASSD_NET | These ones aren't really
IN_CLASSD_NSHIFT | net and host fields, but
INADDR_ANY | This is constant nxllJwaWinsock2.INADDR_ANY.
INADDR_BROADCAST | This is constant nxllJwaWinsock2.INADDR_BROADCAST.
INADDR_LOOPBACK | This is constant nxllJwaWinsock2.INADDR_LOOPBACK.
INADDR_NONE | This is constant nxllJwaWinsock2.INADDR_NONE.
INCL_WINSOCK_API_PROTOTYPES | Default: include function prototypes, don't include function typedefs.
INCL_WINSOCK_API_TYPEDEFS | This is constant nxllJwaWinsock2.INCL_WINSOCK_API_TYPEDEFS.
INVALID_SOCKET | This is used instead of -1, since the SOCKET type is unsigned.
IOC_IN | copy in parameters
IOC_INOUT | This is constant nxllJwaWinsock2.IOC_INOUT.
IOC_OUT | copy out parameters
IOC_PROTOCOL | This is constant nxllJwaWinsock2.IOC_PROTOCOL.
IOC_UNIX | WinSock 2 extension -- manifest constants for WSAIoctl()
IOC_VENDOR | This is constant nxllJwaWinsock2.IOC_VENDOR.
IOC_VOID | no parameters
IOC_WS2 | This is constant nxllJwaWinsock2.IOC_WS2.
IOCPARM_MASK | parameters must be < 128 bytes
IPPORT_BIFFUDP | UNIX UDP sockets
IPPORT_CMDSERVER | This is constant nxllJwaWinsock2.IPPORT_CMDSERVER.
IPPORT_DAYTIME | This is constant nxllJwaWinsock2.IPPORT_DAYTIME.
IPPORT_DISCARD | This is constant nxllJwaWinsock2.IPPORT_DISCARD.
IPPORT_ECHO | Port/socket numbers: network standard functions
IPPORT_EFSSERVER | This is constant nxllJwaWinsock2.IPPORT_EFSSERVER.
IPPORT_EXECSERVER | UNIX TCP sockets
IPPORT_FINGER | This is constant nxllJwaWinsock2.IPPORT_FINGER.
IPPORT_FTP | This is constant nxllJwaWinsock2.IPPORT_FTP.
IPPORT_LOGINSERVER | This is constant nxllJwaWinsock2.IPPORT_LOGINSERVER.
IPPORT_MTP | This is constant nxllJwaWinsock2.IPPORT_MTP.
IPPORT_NAMESERVER | This is constant nxllJwaWinsock2.IPPORT_NAMESERVER.
IPPORT_NETSTAT | This is constant nxllJwaWinsock2.IPPORT_NETSTAT.
IPPORT_RESERVED | Ports < IPPORT_RESERVED are reserved for privileged processes (e.g. root).
IPPORT_RJE | This is constant nxllJwaWinsock2.IPPORT_RJE.
IPPORT_ROUTESERVER | This is constant nxllJwaWinsock2.IPPORT_ROUTESERVER.
IPPORT_SMTP | This is constant nxllJwaWinsock2.IPPORT_SMTP.
IPPORT_SUPDUP | This is constant nxllJwaWinsock2.IPPORT_SUPDUP.
IPPORT_SYSTAT | This is constant nxllJwaWinsock2.IPPORT_SYSTAT.
IPPORT_TELNET | This is constant nxllJwaWinsock2.IPPORT_TELNET.
IPPORT_TFTP | Port/socket numbers: host specific functions
IPPORT_TIMESERVER | This is constant nxllJwaWinsock2.IPPORT_TIMESERVER.
IPPORT_TTYLINK | This is constant nxllJwaWinsock2.IPPORT_TTYLINK.
IPPORT_WHOIS | This is constant nxllJwaWinsock2.IPPORT_WHOIS.
IPPORT_WHOSERVER | This is constant nxllJwaWinsock2.IPPORT_WHOSERVER.
IPPROTO_AH | IPsec AH
IPPROTO_DSTOPTS | IPv6 destination options
IPPROTO_ESP | IPsec ESP header
IPPROTO_FRAGMENT | IPv6 fragmentation header
IPPROTO_GGP | gateway^2 (deprecated)
IPPROTO_HOPOPTS | IPv6 hop-by-hop options
IPPROTO_ICLFXBM | This is constant nxllJwaWinsock2.IPPROTO_ICLFXBM.
IPPROTO_ICMP | control message protocol
IPPROTO_ICMPV6 | ICMPv6
IPPROTO_IDP | xns idp
IPPROTO_IGMP | internet group management protocol
IPPROTO_IP | dummy for IP
IPPROTO_IPV4 | IPv4
IPPROTO_IPV6 | IPv6
IPPROTO_MAX | This is constant nxllJwaWinsock2.IPPROTO_MAX.
IPPROTO_ND | UNOFFICIAL net disk proto
IPPROTO_NONE | IPv6 no next header
IPPROTO_PUP | pup
IPPROTO_RAW | raw IP packet
IPPROTO_ROUTING | IPv6 routing header
IPPROTO_TCP | tcp
IPPROTO_UDP | user datagram protocol
JL_BOTH | This is constant nxllJwaWinsock2.JL_BOTH.
JL_RECEIVER_ONLY | This is constant nxllJwaWinsock2.JL_RECEIVER_ONLY.
JL_SENDER_ONLY | WinSock 2 extension -- manifest constants for WSAJoinLeaf()
LAYERED_PROTOCOL | This is constant nxllJwaWinsock2.LAYERED_PROTOCOL.
LITTLEENDIAN | This is constant nxllJwaWinsock2.LITTLEENDIAN.
LUP_CONTAINERS | This is constant nxllJwaWinsock2.LUP_CONTAINERS.
LUP_DEEP | This is constant nxllJwaWinsock2.LUP_DEEP.
LUP_FLUSHCACHE | This is constant nxllJwaWinsock2.LUP_FLUSHCACHE.
LUP_FLUSHPREVIOUS | This is constant nxllJwaWinsock2.LUP_FLUSHPREVIOUS.
LUP_NEAREST | This is constant nxllJwaWinsock2.LUP_NEAREST.
LUP_NOCONTAINERS | This is constant nxllJwaWinsock2.LUP_NOCONTAINERS.
LUP_RES_SERVICE | This is constant nxllJwaWinsock2.LUP_RES_SERVICE.
LUP_RETURN_ADDR | This is constant nxllJwaWinsock2.LUP_RETURN_ADDR.
LUP_RETURN_ALIASES | This is constant nxllJwaWinsock2.LUP_RETURN_ALIASES.
LUP_RETURN_ALL | This is constant nxllJwaWinsock2.LUP_RETURN_ALL.
LUP_RETURN_BLOB | This is constant nxllJwaWinsock2.LUP_RETURN_BLOB.
LUP_RETURN_COMMENT | This is constant nxllJwaWinsock2.LUP_RETURN_COMMENT.
LUP_RETURN_NAME | This is constant nxllJwaWinsock2.LUP_RETURN_NAME.
LUP_RETURN_QUERY_STRING | This is constant nxllJwaWinsock2.LUP_RETURN_QUERY_STRING.
LUP_RETURN_TYPE | This is constant nxllJwaWinsock2.LUP_RETURN_TYPE.
LUP_RETURN_VERSION | This is constant nxllJwaWinsock2.LUP_RETURN_VERSION.
MAX_PROTOCOL_CHAIN | WinSock 2 extension -- WSAPROTOCOL_INFO structure and associated manifest constants
MAXGETHOSTSTRUCT | Define constant based on rfc883, used by gethostbyxxxx() calls.
MSG_DONTROUTE | send without using routing tables
MSG_INTERRUPT | send/recv in the interrupt context
MSG_MAXIOVLEN | This is constant nxllJwaWinsock2.MSG_MAXIOVLEN.
MSG_OOB | process out-of-band data
MSG_PARTIAL | partial send or recv for message xport
MSG_PEEK | peek at incoming message
NO_ADDRESS | This is constant nxllJwaWinsock2.NO_ADDRESS.
NO_DATA | This is constant nxllJwaWinsock2.NO_DATA.
NO_RECOVERY | This is constant nxllJwaWinsock2.NO_RECOVERY.
NS_ALL | Name Spaces
NS_DHCP | This is constant nxllJwaWinsock2.NS_DHCP.
NS_DNS | This is constant nxllJwaWinsock2.NS_DNS.
NS_MS | This is constant nxllJwaWinsock2.NS_MS.
NS_NBP | This is constant nxllJwaWinsock2.NS_NBP.
NS_NDS | This is constant nxllJwaWinsock2.NS_NDS.
NS_NETBT | This is constant nxllJwaWinsock2.NS_NETBT.
NS_NETDES | Network Designers Limited
NS_NIS | This is constant nxllJwaWinsock2.NS_NIS.
NS_NISPLUS | This is constant nxllJwaWinsock2.NS_NISPLUS.
NS_NLA | Network Location Awareness
NS_NTDS | This is constant nxllJwaWinsock2.NS_NTDS.
NS_PEER_BROWSE | This is constant nxllJwaWinsock2.NS_PEER_BROWSE.
NS_SAP | This is constant nxllJwaWinsock2.NS_SAP.
NS_SLP | This is constant nxllJwaWinsock2.NS_SLP.
NS_STDA | This is constant nxllJwaWinsock2.NS_STDA.
NS_TCPIP_HOSTS | This is constant nxllJwaWinsock2.NS_TCPIP_HOSTS.
NS_TCPIP_LOCAL | This is constant nxllJwaWinsock2.NS_TCPIP_LOCAL.
NS_WINS | This is constant nxllJwaWinsock2.NS_WINS.
NS_WRQ | This is constant nxllJwaWinsock2.NS_WRQ.
NS_X500 | This is constant nxllJwaWinsock2.NS_X500.
PF_APPLETALK | This is constant nxllJwaWinsock2.PF_APPLETALK.
PF_ATM | This is constant nxllJwaWinsock2.PF_ATM.
PF_BAN | This is constant nxllJwaWinsock2.PF_BAN.
PF_CCITT | This is constant nxllJwaWinsock2.PF_CCITT.
PF_CHAOS | This is constant nxllJwaWinsock2.PF_CHAOS.
PF_DATAKIT | This is constant nxllJwaWinsock2.PF_DATAKIT.
PF_DECnet | This is constant nxllJwaWinsock2.PF_DECnet.
PF_DLI | This is constant nxllJwaWinsock2.PF_DLI.
PF_ECMA | This is constant nxllJwaWinsock2.PF_ECMA.
PF_FIREFOX | This is constant nxllJwaWinsock2.PF_FIREFOX.
PF_HYLINK | This is constant nxllJwaWinsock2.PF_HYLINK.
PF_IMPLINK | This is constant nxllJwaWinsock2.PF_IMPLINK.
PF_INET | This is constant nxllJwaWinsock2.PF_INET.
PF_INET6 | This is constant nxllJwaWinsock2.PF_INET6.
PF_IPX | This is constant nxllJwaWinsock2.PF_IPX.
PF_ISO | This is constant nxllJwaWinsock2.PF_ISO.
PF_LAT | This is constant nxllJwaWinsock2.PF_LAT.
PF_MAX | This is constant nxllJwaWinsock2.PF_MAX.
PF_NS | This is constant nxllJwaWinsock2.PF_NS.
PF_OSI | This is constant nxllJwaWinsock2.PF_OSI.
PF_PUP | This is constant nxllJwaWinsock2.PF_PUP.
PF_SNA | This is constant nxllJwaWinsock2.PF_SNA.
PF_UNIX | This is constant nxllJwaWinsock2.PF_UNIX.
PF_UNKNOWN1 | This is constant nxllJwaWinsock2.PF_UNKNOWN1.
PF_UNSPEC | Protocol families, same as address families for now.
PF_VOICEVIEW | This is constant nxllJwaWinsock2.PF_VOICEVIEW.
PFL_HIDDEN | This is constant nxllJwaWinsock2.PFL_HIDDEN.
PFL_MATCHES_PROTOCOL_ZERO | This is constant nxllJwaWinsock2.PFL_MATCHES_PROTOCOL_ZERO.
PFL_MULTIPLE_PROTO_ENTRIES | Flag bit definitions for dwProviderFlags
PFL_RECOMMENDED_PROTO_ENTRY | This is constant nxllJwaWinsock2.PFL_RECOMMENDED_PROTO_ENTRY.
PVD_CONFIG | configuration info for service provider
RES_FLUSH_CACHE | This is constant nxllJwaWinsock2.RES_FLUSH_CACHE.
RES_SERVICE | This is constant nxllJwaWinsock2.RES_SERVICE.
RES_UNUSED_1 | Resolution flags for WSAGetAddressByName(). Note these are also used by the 1.1 API GetAddressByName, so leave them around.
RESULT_IS_ADDED | This is constant nxllJwaWinsock2.RESULT_IS_ADDED.
RESULT_IS_ALIAS | Return flags
RESULT_IS_CHANGED | This is constant nxllJwaWinsock2.RESULT_IS_CHANGED.
RESULT_IS_DELETED | This is constant nxllJwaWinsock2.RESULT_IS_DELETED.
SD_BOTH | This is constant nxllJwaWinsock2.SD_BOTH.
SD_RECEIVE | WinSock 2 extension -- manifest constants for shutdown()
SD_SEND | This is constant nxllJwaWinsock2.SD_SEND.
SECURITY_PROTOCOL_NONE | This is constant nxllJwaWinsock2.SECURITY_PROTOCOL_NONE.
SERVICE_MULTIPLE | Service Install Flags
SERVICE_TYPE_VALUE_IPXPORTA | Well known value names for Service Types
SERVICE_TYPE_VALUE_IPXPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTW.
SERVICE_TYPE_VALUE_OBJECTID | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTID.
SERVICE_TYPE_VALUE_OBJECTIDA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDA.
SERVICE_TYPE_VALUE_OBJECTIDW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDW.
SERVICE_TYPE_VALUE_SAPID | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPID.
SERVICE_TYPE_VALUE_SAPIDA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDA.
SERVICE_TYPE_VALUE_SAPIDW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDW.
SERVICE_TYPE_VALUE_TCPPORT | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORT.
SERVICE_TYPE_VALUE_TCPPORTA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTA.
SERVICE_TYPE_VALUE_TCPPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTW.
SERVICE_TYPE_VALUE_UDPPORT | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORT.
SERVICE_TYPE_VALUE_UDPPORTA | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTA.
SERVICE_TYPE_VALUE_UDPPORTW | This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTW.
SG_CONSTRAINED_GROUP | This is constant nxllJwaWinsock2.SG_CONSTRAINED_GROUP.
SG_UNCONSTRAINED_GROUP | This is constant nxllJwaWinsock2.SG_UNCONSTRAINED_GROUP.
SIO_ADDRESS_LIST_CHANGE | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_CHANGE.
SIO_ADDRESS_LIST_QUERY | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_QUERY.
SIO_ADDRESS_LIST_SORT | This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_SORT.
SIO_ASSOCIATE_HANDLE | This is constant nxllJwaWinsock2.SIO_ASSOCIATE_HANDLE.
SIO_ENABLE_CIRCULAR_QUEUEING | This is constant nxllJwaWinsock2.SIO_ENABLE_CIRCULAR_QUEUEING.
SIO_FIND_ROUTE | This is constant nxllJwaWinsock2.SIO_FIND_ROUTE.
SIO_FLUSH | This is constant nxllJwaWinsock2.SIO_FLUSH.
SIO_GET_BROADCAST_ADDRESS | This is constant nxllJwaWinsock2.SIO_GET_BROADCAST_ADDRESS.
SIO_GET_EXTENSION_FUNCTION_POINTER | This is constant nxllJwaWinsock2.SIO_GET_EXTENSION_FUNCTION_POINTER.
SIO_GET_GROUP_QOS | This is constant nxllJwaWinsock2.SIO_GET_GROUP_QOS.
SIO_GET_QOS | This is constant nxllJwaWinsock2.SIO_GET_QOS.
SIO_MULTICAST_SCOPE | This is constant nxllJwaWinsock2.SIO_MULTICAST_SCOPE.
SIO_MULTIPOINT_LOOPBACK | This is constant nxllJwaWinsock2.SIO_MULTIPOINT_LOOPBACK.
SIO_NSP_NOTIFY_CHANGE | WinSock 2 extension -- manifest constants and associated structures for WSANSPIoctl()
SIO_QUERY_TARGET_PNP_HANDLE | This is constant nxllJwaWinsock2.SIO_QUERY_TARGET_PNP_HANDLE.
SIO_ROUTING_INTERFACE_CHANGE | This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_CHANGE.
SIO_ROUTING_INTERFACE_QUERY | This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_QUERY.
SIO_SET_GROUP_QOS | This is constant nxllJwaWinsock2.SIO_SET_GROUP_QOS.
SIO_SET_QOS | This is constant nxllJwaWinsock2.SIO_SET_QOS.
SIO_TRANSLATE_HANDLE | This is constant nxllJwaWinsock2.SIO_TRANSLATE_HANDLE.
SIOCATMARK | at oob mark?
SIOCGHIWAT | get high watermark
SIOCGLOWAT | get low watermark
SIOCSHIWAT | set high watermark
SIOCSLOWAT | set low watermark
SO_ACCEPTCONN | socket has had listen()
SO_BROADCAST | permit sending of broadcast msgs
SO_CONDITIONAL_ACCEPT | enable true conditional accept: connection is not ack-ed to the other side until conditional function returns CF_ACCEPT
SO_DEBUG | turn on debugging info recording
SO_DONTLINGER | This is constant nxllJwaWinsock2.SO_DONTLINGER.
SO_DONTROUTE | just use interface addresses
SO_ERROR | get error status and clear
SO_EXCLUSIVEADDRUSE | disallow local address reuse
SO_GROUP_ID | ID of a socket group
SO_GROUP_PRIORITY | the relative priority within a group
SO_KEEPALIVE | keep connections alive
SO_LINGER | linger on close if data present
SO_MAX_MSG_SIZE | maximum message size
SO_OOBINLINE | leave received OOB data in line
SO_OPENTYPE | This is constant nxllJwaWinsock2.SO_OPENTYPE.
SO_PROTOCOL_INFO | This is constant nxllJwaWinsock2.SO_PROTOCOL_INFO.
SO_PROTOCOL_INFOA | WSAPROTOCOL_INFOA structure
SO_PROTOCOL_INFOW | WSAPROTOCOL_INFOW structure
SO_RCVBUF | receive buffer size
SO_RCVLOWAT | receive low-water mark
SO_RCVTIMEO | receive timeout
SO_REUSEADDR | allow local address reuse
SO_SNDBUF | send buffer size
SO_SNDLOWAT | send low-water mark
SO_SNDTIMEO | send timeout
SO_SYNCHRONOUS_ALERT | This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_ALERT.
SO_SYNCHRONOUS_NONALERT | This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_NONALERT.
SO_TYPE | get socket type
SO_USELOOPBACK | bypass hardware when possible
SOCK_DGRAM | datagram socket
SOCK_RAW | raw-protocol interface
SOCK_RDM | reliably-delivered message
SOCK_SEQPACKET | sequenced packet stream
SOCK_STREAM | stream socket
SOCKET_ERROR | This is constant nxllJwaWinsock2.SOCKET_ERROR.
SOL_SOCKET | options for socket level
SOMAXCONN | Maximum queue length specifiable by listen.
TCP_NODELAY | TCP options.
TH_NETDEV | WinSock 2 extension -- manifest constants for SIO_TRANSLATE_HANDLE ioctl
TH_TAPI | This is constant nxllJwaWinsock2.TH_TAPI.
TRY_AGAIN | This is constant nxllJwaWinsock2.TRY_AGAIN.
WINSOCK_VERSION | This is constant nxllJwaWinsock2.WINSOCK_VERSION.
ws2_32 | This is constant nxllJwaWinsock2.ws2_32.
WSA_E_CANCELLED | This is constant nxllJwaWinsock2.WSA_E_CANCELLED.
WSA_E_NO_MORE | This is constant nxllJwaWinsock2.WSA_E_NO_MORE.
WSA_FLAG_MULTIPOINT_C_LEAF | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_LEAF.
WSA_FLAG_MULTIPOINT_C_ROOT | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_ROOT.
WSA_FLAG_MULTIPOINT_D_LEAF | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_LEAF.
WSA_FLAG_MULTIPOINT_D_ROOT | This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_ROOT.
WSA_FLAG_OVERLAPPED | WinSock 2 extension -- manifest constants for WSASocket()
WSA_INFINITE | This is constant nxllJwaWinsock2.WSA_INFINITE.
WSA_INVALID_EVENT | This is constant nxllJwaWinsock2.WSA_INVALID_EVENT.
WSA_INVALID_HANDLE | This is constant nxllJwaWinsock2.WSA_INVALID_HANDLE.
WSA_INVALID_PARAMETER | This is constant nxllJwaWinsock2.WSA_INVALID_PARAMETER.
WSA_IO_INCOMPLETE | This is constant nxllJwaWinsock2.WSA_IO_INCOMPLETE.
WSA_IO_PENDING | This is constant nxllJwaWinsock2.WSA_IO_PENDING.
WSA_MAXIMUM_WAIT_EVENTS | This is constant nxllJwaWinsock2.WSA_MAXIMUM_WAIT_EVENTS.
WSA_NOT_ENOUGH_MEMORY | This is constant nxllJwaWinsock2.WSA_NOT_ENOUGH_MEMORY.
WSA_OPERATION_ABORTED | This is constant nxllJwaWinsock2.WSA_OPERATION_ABORTED.
WSA_QOS_ADMISSION_FAILURE | error due to lack of resources
WSA_QOS_BAD_OBJECT | problem with some part of the filterspec or providerspecific buffer in general
WSA_QOS_BAD_STYLE | unknown or conflicting style
WSA_QOS_EFILTERCOUNT | incorrect number of filters
WSA_QOS_EFILTERSTYLE | invalid filter style
WSA_QOS_EFILTERTYPE | invalid filter type
WSA_QOS_EFLOWCOUNT | incorrect number of flows
WSA_QOS_EFLOWDESC | invalid flow descriptor in the list
WSA_QOS_EFLOWSPEC | invalid flowspec
WSA_QOS_EOBJLENGTH | invalid object length
WSA_QOS_EPOLICYOBJ | invalid policy object in provider specific buffer
WSA_QOS_EPROVSPECBUF | invalid provider specific buffer
WSA_QOS_EPSFILTERSPEC | invalid filter spec in provider specific buffer
WSA_QOS_EPSFLOWSPEC | inconsistent flow spec in provider specific buffer
WSA_QOS_ESDMODEOBJ | invalid shape discard mode object in provider specific buffer
WSA_QOS_ESERVICETYPE | invalid service type in flowspec
WSA_QOS_ESHAPERATEOBJ | invalid shaping rate object in provider specific buffer
WSA_QOS_EUNKOWNPSOBJ | unknown object in provider specific buffer
WSA_QOS_GENERIC_ERROR | general error
WSA_QOS_NO_RECEIVERS | there are no receivers
WSA_QOS_NO_SENDERS | there are no senders
WSA_QOS_POLICY_FAILURE | rejected for administrative reasons - bad credentials
WSA_QOS_RECEIVERS | at least one Reserve has arrived
WSA_QOS_REQUEST_CONFIRMED | Reserve has been confirmed
WSA_QOS_RESERVED_PETYPE | reserved policy element in provider specific buffer
WSA_QOS_SENDERS | at least one Path has arrived
WSA_QOS_TRAFFIC_CTRL_ERROR | problem with some part of the flowspec
WSA_WAIT_EVENT_0 | This is constant nxllJwaWinsock2.WSA_WAIT_EVENT_0.
WSA_WAIT_FAILED | This is constant nxllJwaWinsock2.WSA_WAIT_FAILED.
WSA_WAIT_IO_COMPLETION | This is constant nxllJwaWinsock2.WSA_WAIT_IO_COMPLETION.
WSA_WAIT_TIMEOUT | This is constant nxllJwaWinsock2.WSA_WAIT_TIMEOUT.
WSABASEERR | All Windows Sockets error constants are biased by WSABASEERR from the "normal"
WSADESCRIPTION_LEN | This is constant nxllJwaWinsock2.WSADESCRIPTION_LEN.
WSAEACCES | This is constant nxllJwaWinsock2.WSAEACCES.
WSAEADDRINUSE | This is constant nxllJwaWinsock2.WSAEADDRINUSE.
WSAEADDRNOTAVAIL | This is constant nxllJwaWinsock2.WSAEADDRNOTAVAIL.
WSAEAFNOSUPPORT | This is constant nxllJwaWinsock2.WSAEAFNOSUPPORT.
WSAEALREADY | This is constant nxllJwaWinsock2.WSAEALREADY.
WSAEBADF | This is constant nxllJwaWinsock2.WSAEBADF.
WSAECANCELLED | This is constant nxllJwaWinsock2.WSAECANCELLED.
WSAECONNABORTED | This is constant nxllJwaWinsock2.WSAECONNABORTED.
WSAECONNREFUSED | This is constant nxllJwaWinsock2.WSAECONNREFUSED.
WSAECONNRESET | This is constant nxllJwaWinsock2.WSAECONNRESET.
WSAEDESTADDRREQ | This is constant nxllJwaWinsock2.WSAEDESTADDRREQ.
WSAEDISCON | This is constant nxllJwaWinsock2.WSAEDISCON.
WSAEDQUOT | This is constant nxllJwaWinsock2.WSAEDQUOT.
WSAEFAULT | This is constant nxllJwaWinsock2.WSAEFAULT.
WSAEHOSTDOWN | This is constant nxllJwaWinsock2.WSAEHOSTDOWN.
WSAEHOSTUNREACH | This is constant nxllJwaWinsock2.WSAEHOSTUNREACH.
WSAEINPROGRESS | This is constant nxllJwaWinsock2.WSAEINPROGRESS.
WSAEINTR | Windows Sockets definitions of regular Microsoft C error constants
WSAEINVAL | This is constant nxllJwaWinsock2.WSAEINVAL.
WSAEINVALIDPROCTABLE | This is constant nxllJwaWinsock2.WSAEINVALIDPROCTABLE.
WSAEINVALIDPROVIDER | This is constant nxllJwaWinsock2.WSAEINVALIDPROVIDER.
WSAEISCONN | This is constant nxllJwaWinsock2.WSAEISCONN.
WSAELOOP | This is constant nxllJwaWinsock2.WSAELOOP.
WSAEMFILE | This is constant nxllJwaWinsock2.WSAEMFILE.
WSAEMSGSIZE | This is constant nxllJwaWinsock2.WSAEMSGSIZE.
WSAENAMETOOLONG | This is constant nxllJwaWinsock2.WSAENAMETOOLONG.
WSAENETDOWN | This is constant nxllJwaWinsock2.WSAENETDOWN.
WSAENETRESET | This is constant nxllJwaWinsock2.WSAENETRESET.
WSAENETUNREACH | This is constant nxllJwaWinsock2.WSAENETUNREACH.
WSAENOBUFS | This is constant nxllJwaWinsock2.WSAENOBUFS.
WSAENOMORE | This is constant nxllJwaWinsock2.WSAENOMORE.
WSAENOPROTOOPT | This is constant nxllJwaWinsock2.WSAENOPROTOOPT.
WSAENOTCONN | This is constant nxllJwaWinsock2.WSAENOTCONN.
WSAENOTEMPTY | This is constant nxllJwaWinsock2.WSAENOTEMPTY.
WSAENOTSOCK | This is constant nxllJwaWinsock2.WSAENOTSOCK.
WSAEOPNOTSUPP | This is constant nxllJwaWinsock2.WSAEOPNOTSUPP.
WSAEPFNOSUPPORT | This is constant nxllJwaWinsock2.WSAEPFNOSUPPORT.
WSAEPROCLIM | This is constant nxllJwaWinsock2.WSAEPROCLIM.
WSAEPROTONOSUPPORT | This is constant nxllJwaWinsock2.WSAEPROTONOSUPPORT.
WSAEPROTOTYPE | This is constant nxllJwaWinsock2.WSAEPROTOTYPE.
WSAEPROVIDERFAILEDINIT | This is constant nxllJwaWinsock2.WSAEPROVIDERFAILEDINIT.
WSAEREFUSED | This is constant nxllJwaWinsock2.WSAEREFUSED.
WSAEREMOTE | This is constant nxllJwaWinsock2.WSAEREMOTE.
WSAESHUTDOWN | This is constant nxllJwaWinsock2.WSAESHUTDOWN.
WSAESOCKTNOSUPPORT | This is constant nxllJwaWinsock2.WSAESOCKTNOSUPPORT.
WSAESTALE | This is constant nxllJwaWinsock2.WSAESTALE.
WSAETIMEDOUT | This is constant nxllJwaWinsock2.WSAETIMEDOUT.
WSAETOOMANYREFS | This is constant nxllJwaWinsock2.WSAETOOMANYREFS.
WSAEUSERS | This is constant nxllJwaWinsock2.WSAEUSERS.
WSAEWOULDBLOCK | Windows Sockets definitions of regular Berkeley error constants
WSAHOST_NOT_FOUND | Authoritative Answer: Host not found
WSANO_ADDRESS | no address, look for MX record
WSANO_DATA | Valid name, no data record of requested type
WSANO_RECOVERY | Non-recoverable errors, FORMERR, REFUSED, NOTIMP
WSANOTINITIALISED | This is constant nxllJwaWinsock2.WSANOTINITIALISED.
WSAPROTOCOL_LEN | This is constant nxllJwaWinsock2.WSAPROTOCOL_LEN.
WSASERVICE_NOT_FOUND | This is constant nxllJwaWinsock2.WSASERVICE_NOT_FOUND.
WSASYS_STATUS_LEN | This is constant nxllJwaWinsock2.WSASYS_STATUS_LEN.
WSASYSCALLFAILURE | This is constant nxllJwaWinsock2.WSASYSCALLFAILURE.
WSASYSNOTREADY | Extended Windows Sockets error constant definitions
WSATRY_AGAIN | Non-Authoritative: Host not found, or SERVERFAIL
WSATYPE_NOT_FOUND | This is constant nxllJwaWinsock2.WSATYPE_NOT_FOUND.
WSAVERNOTSUPPORTED | This is constant nxllJwaWinsock2.WSAVERNOTSUPPORTED.
XP1_CONNECT_DATA | This is constant nxllJwaWinsock2.XP1_CONNECT_DATA.
XP1_CONNECTIONLESS | Flag bit definitions for dwServiceFlags1
XP1_DISCONNECT_DATA | This is constant nxllJwaWinsock2.XP1_DISCONNECT_DATA.
XP1_EXPEDITED_DATA | This is constant nxllJwaWinsock2.XP1_EXPEDITED_DATA.
XP1_GRACEFUL_CLOSE | This is constant nxllJwaWinsock2.XP1_GRACEFUL_CLOSE.
XP1_GUARANTEED_DELIVERY | This is constant nxllJwaWinsock2.XP1_GUARANTEED_DELIVERY.
XP1_GUARANTEED_ORDER | This is constant nxllJwaWinsock2.XP1_GUARANTEED_ORDER.
XP1_IFS_HANDLES | This is constant nxllJwaWinsock2.XP1_IFS_HANDLES.
XP1_INTERRUPT | This is constant nxllJwaWinsock2.XP1_INTERRUPT.
XP1_MESSAGE_ORIENTED | This is constant nxllJwaWinsock2.XP1_MESSAGE_ORIENTED.
XP1_MULTIPOINT_CONTROL_PLANE | This is constant nxllJwaWinsock2.XP1_MULTIPOINT_CONTROL_PLANE.
XP1_MULTIPOINT_DATA_PLANE | This is constant nxllJwaWinsock2.XP1_MULTIPOINT_DATA_PLANE.
XP1_PARTIAL_MESSAGE | This is constant nxllJwaWinsock2.XP1_PARTIAL_MESSAGE.
XP1_PSEUDO_STREAM | This is constant nxllJwaWinsock2.XP1_PSEUDO_STREAM.
XP1_QOS_SUPPORTED | This is constant nxllJwaWinsock2.XP1_QOS_SUPPORTED.
XP1_SUPPORT_BROADCAST | This is constant nxllJwaWinsock2.XP1_SUPPORT_BROADCAST.
XP1_SUPPORT_MULTIPOINT | This is constant nxllJwaWinsock2.XP1_SUPPORT_MULTIPOINT.
XP1_UNI_RECV | This is constant nxllJwaWinsock2.XP1_UNI_RECV.
XP1_UNI_SEND | This is constant nxllJwaWinsock2.XP1_UNI_SEND.
Namespace

nxllJwaWinsock2 Namespace

Links
Constants, nxllJwaWinsock2 Namespace


nxllJwaWinsock2._SS_ALIGNSIZE Constant

nxllJwaWinsock2._SS_ALIGNSIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
_SS_ALIGNSIZE = SizeOf(Int64);
File

nxllJwaWinsock2

Description

Desired alignment.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2._SS_MAXSIZE Constant

nxllJwaWinsock2._SS_MAXSIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
_SS_MAXSIZE = 128;
File

nxllJwaWinsock2

Description

Maximum size.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2._SS_PAD1SIZE Constant

nxllJwaWinsock2._SS_PAD1SIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
_SS_PAD1SIZE = _SS_ALIGNSIZE - SizeOf(short);
File

nxllJwaWinsock2

Description

Definitions used for sockaddr_storage structure paddings design.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2._SS_PAD2SIZE Constant

nxllJwaWinsock2._SS_PAD2SIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
_SS_PAD2SIZE = _SS_MAXSIZE - (SizeOf(short) + _SS_PAD1SIZE + _SS_ALIGNSIZE);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2._SS_PAD2SIZE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ADDR_ANY Constant

nxllJwaWinsock2.ADDR_ANY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ADDR_ANY = INADDR_ANY;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ADDR_ANY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_12844 Constant

nxllJwaWinsock2.AF_12844 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_12844 = 25;
File

nxllJwaWinsock2

Description

IEEE 1284.4 WG AF

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_APPLETALK Constant

nxllJwaWinsock2.AF_APPLETALK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_APPLETALK = 16;
File

nxllJwaWinsock2

Description

AppleTalk

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_ATM Constant

nxllJwaWinsock2.AF_ATM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_ATM = 22;
File

nxllJwaWinsock2

Description

Native ATM Services

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_BAN Constant

nxllJwaWinsock2.AF_BAN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_BAN = 21;
File

nxllJwaWinsock2

Description

Banyan

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_CCITT Constant

nxllJwaWinsock2.AF_CCITT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_CCITT = 10;
File

nxllJwaWinsock2

Description

CCITT protocols, X.25 etc

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_CHAOS Constant

nxllJwaWinsock2.AF_CHAOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_CHAOS = 5;
File

nxllJwaWinsock2

Description

mit CHAOS protocols

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_CLUSTER Constant

nxllJwaWinsock2.AF_CLUSTER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_CLUSTER = 24;
File

nxllJwaWinsock2

Description

Microsoft Wolfpack

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_DATAKIT Constant

nxllJwaWinsock2.AF_DATAKIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_DATAKIT = 9;
File

nxllJwaWinsock2

Description

datakit protocols

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_DECnet Constant

nxllJwaWinsock2.AF_DECnet Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_DECnet = 12;
File

nxllJwaWinsock2

Description

DECnet

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_DLI Constant

nxllJwaWinsock2.AF_DLI Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_DLI = 13;
File

nxllJwaWinsock2

Description

Direct data link interface

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_ECMA Constant

nxllJwaWinsock2.AF_ECMA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_ECMA = 8;
File

nxllJwaWinsock2

Description

european computer manufacturers

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_FIREFOX Constant

nxllJwaWinsock2.AF_FIREFOX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_FIREFOX = 19;
File

nxllJwaWinsock2

Description

Protocols from Firefox

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_HYLINK Constant

nxllJwaWinsock2.AF_HYLINK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_HYLINK = 15;
File

nxllJwaWinsock2

Description

NSC Hyperchannel

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_ICLFXBM Constant

nxllJwaWinsock2.AF_ICLFXBM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_ICLFXBM = 31;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.AF_ICLFXBM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_IMPLINK Constant

nxllJwaWinsock2.AF_IMPLINK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_IMPLINK = 3;
File

nxllJwaWinsock2

Description

arpanet imp addresses

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_INET Constant

nxllJwaWinsock2.AF_INET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_INET = 2;
File

nxllJwaWinsock2

Description

internetwork: UDP, TCP, etc.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_INET6 Constant

nxllJwaWinsock2.AF_INET6 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_INET6 = 23;
File

nxllJwaWinsock2

Description

Internetwork Version 6

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_IPX Constant

nxllJwaWinsock2.AF_IPX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_IPX = AF_NS;
File

nxllJwaWinsock2

Description

IPX protocols: IPX, SPX, etc.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_IRDA Constant

nxllJwaWinsock2.AF_IRDA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_IRDA = 26;
File

nxllJwaWinsock2

Description

IrDA

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_ISO Constant

nxllJwaWinsock2.AF_ISO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_ISO = 7;
File

nxllJwaWinsock2

Description

ISO protocols

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_LAT Constant

nxllJwaWinsock2.AF_LAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_LAT = 14;
File

nxllJwaWinsock2

Description

LAT

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_MAX Constant

nxllJwaWinsock2.AF_MAX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_MAX = 32;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.AF_MAX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_NETBIOS Constant

nxllJwaWinsock2.AF_NETBIOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_NETBIOS = 17;
File

nxllJwaWinsock2

Description

NetBios-style addresses

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_NETDES Constant

nxllJwaWinsock2.AF_NETDES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_NETDES = 28;
File

nxllJwaWinsock2

Description

Network Designers OSI & gateway enabled protocols

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_NS Constant

nxllJwaWinsock2.AF_NS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_NS = 6;
File

nxllJwaWinsock2

Description

XEROX NS protocols

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_OSI Constant

nxllJwaWinsock2.AF_OSI Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_OSI = AF_ISO;
File

nxllJwaWinsock2

Description

OSI is ISO

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_PUP Constant

nxllJwaWinsock2.AF_PUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_PUP = 4;
File

nxllJwaWinsock2

Description

pup protocols: e.g. BSP

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_SNA Constant

nxllJwaWinsock2.AF_SNA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_SNA = 11;
File

nxllJwaWinsock2

Description

IBM SNA

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_TCNMESSAGE Constant

nxllJwaWinsock2.AF_TCNMESSAGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_TCNMESSAGE = 30;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.AF_TCNMESSAGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_TCNPROCESS Constant

nxllJwaWinsock2.AF_TCNPROCESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_TCNPROCESS = 29;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.AF_TCNPROCESS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_UNIX Constant

nxllJwaWinsock2.AF_UNIX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_UNIX = 1;
File

nxllJwaWinsock2

Description

local to host (pipes, portals

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_UNKNOWN1 Constant

nxllJwaWinsock2.AF_UNKNOWN1 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_UNKNOWN1 = 20;
File

nxllJwaWinsock2

Description

Somebody is using this!

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_UNSPEC Constant

nxllJwaWinsock2.AF_UNSPEC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_UNSPEC = 0;
File

nxllJwaWinsock2

Description

unspecified

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.AF_VOICEVIEW Constant

nxllJwaWinsock2.AF_VOICEVIEW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
AF_VOICEVIEW = 18;
File

nxllJwaWinsock2

Description

VoiceView

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.BASE_PROTOCOL Constant

nxllJwaWinsock2.BASE_PROTOCOL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
BASE_PROTOCOL = 1;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.BASE_PROTOCOL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.BIGENDIAN Constant

nxllJwaWinsock2.BIGENDIAN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
BIGENDIAN = $0000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.BIGENDIAN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.CF_ACCEPT Constant

nxllJwaWinsock2.CF_ACCEPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
CF_ACCEPT = $0000;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for return values of the condition function

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.CF_DEFER Constant

nxllJwaWinsock2.CF_DEFER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
CF_DEFER = $0002;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.CF_DEFER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.CF_REJECT Constant

nxllJwaWinsock2.CF_REJECT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
CF_REJECT = $0001;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.CF_REJECT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EADDRINUSE Constant

nxllJwaWinsock2.EADDRINUSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EADDRINUSE = WSAEADDRINUSE;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EADDRINUSE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EADDRNOTAVAIL Constant

nxllJwaWinsock2.EADDRNOTAVAIL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EADDRNOTAVAIL = WSAEADDRNOTAVAIL;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EADDRNOTAVAIL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EAFNOSUPPORT Constant

nxllJwaWinsock2.EAFNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EAFNOSUPPORT = WSAEAFNOSUPPORT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EAFNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EALREADY Constant

nxllJwaWinsock2.EALREADY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EALREADY = WSAEALREADY;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EALREADY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ECONNABORTED Constant

nxllJwaWinsock2.ECONNABORTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ECONNABORTED = WSAECONNABORTED;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ECONNABORTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ECONNREFUSED Constant

nxllJwaWinsock2.ECONNREFUSED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ECONNREFUSED = WSAECONNREFUSED;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ECONNREFUSED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ECONNRESET Constant

nxllJwaWinsock2.ECONNRESET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ECONNRESET = WSAECONNRESET;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ECONNRESET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EDESTADDRREQ Constant

nxllJwaWinsock2.EDESTADDRREQ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EDESTADDRREQ = WSAEDESTADDRREQ;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EDESTADDRREQ.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EDQUOT Constant

nxllJwaWinsock2.EDQUOT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EDQUOT = WSAEDQUOT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EDQUOT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EHOSTDOWN Constant

nxllJwaWinsock2.EHOSTDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EHOSTDOWN = WSAEHOSTDOWN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EHOSTDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EHOSTUNREACH Constant

nxllJwaWinsock2.EHOSTUNREACH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EHOSTUNREACH = WSAEHOSTUNREACH;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EHOSTUNREACH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EINPROGRESS Constant

nxllJwaWinsock2.EINPROGRESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EINPROGRESS = WSAEINPROGRESS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EINPROGRESS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EISCONN Constant

nxllJwaWinsock2.EISCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EISCONN = WSAEISCONN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EISCONN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ELOOP Constant

nxllJwaWinsock2.ELOOP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ELOOP = WSAELOOP;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ELOOP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EMSGSIZE Constant

nxllJwaWinsock2.EMSGSIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EMSGSIZE = WSAEMSGSIZE;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EMSGSIZE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENAMETOOLONG Constant

nxllJwaWinsock2.ENAMETOOLONG Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENAMETOOLONG = WSAENAMETOOLONG;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENAMETOOLONG.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENETDOWN Constant

nxllJwaWinsock2.ENETDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENETDOWN = WSAENETDOWN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENETDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENETRESET Constant

nxllJwaWinsock2.ENETRESET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENETRESET = WSAENETRESET;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENETRESET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENETUNREACH Constant

nxllJwaWinsock2.ENETUNREACH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENETUNREACH = WSAENETUNREACH;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENETUNREACH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENOBUFS Constant

nxllJwaWinsock2.ENOBUFS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENOBUFS = WSAENOBUFS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENOBUFS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENOPROTOOPT Constant

nxllJwaWinsock2.ENOPROTOOPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENOPROTOOPT = WSAENOPROTOOPT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENOPROTOOPT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENOTCONN Constant

nxllJwaWinsock2.ENOTCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENOTCONN = WSAENOTCONN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENOTCONN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENOTEMPTY Constant

nxllJwaWinsock2.ENOTEMPTY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENOTEMPTY = WSAENOTEMPTY;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENOTEMPTY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ENOTSOCK Constant

nxllJwaWinsock2.ENOTSOCK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ENOTSOCK = WSAENOTSOCK;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ENOTSOCK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EOPNOTSUPP Constant

nxllJwaWinsock2.EOPNOTSUPP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EOPNOTSUPP = WSAEOPNOTSUPP;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EOPNOTSUPP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EPFNOSUPPORT Constant

nxllJwaWinsock2.EPFNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EPFNOSUPPORT = WSAEPFNOSUPPORT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EPFNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EPROCLIM Constant

nxllJwaWinsock2.EPROCLIM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EPROCLIM = WSAEPROCLIM;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EPROCLIM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EPROTONOSUPPORT Constant

nxllJwaWinsock2.EPROTONOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EPROTONOSUPPORT = WSAEPROTONOSUPPORT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EPROTONOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EPROTOTYPE Constant

nxllJwaWinsock2.EPROTOTYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EPROTOTYPE = WSAEPROTOTYPE;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EPROTOTYPE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EREMOTE Constant

nxllJwaWinsock2.EREMOTE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EREMOTE = WSAEREMOTE;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EREMOTE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ESHUTDOWN Constant

nxllJwaWinsock2.ESHUTDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ESHUTDOWN = WSAESHUTDOWN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ESHUTDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ESOCKTNOSUPPORT Constant

nxllJwaWinsock2.ESOCKTNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ESOCKTNOSUPPORT = WSAESOCKTNOSUPPORT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ESOCKTNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ESTALE Constant

nxllJwaWinsock2.ESTALE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ESTALE = WSAESTALE;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ESTALE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ETIMEDOUT Constant

nxllJwaWinsock2.ETIMEDOUT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ETIMEDOUT = WSAETIMEDOUT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ETIMEDOUT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ETOOMANYREFS Constant

nxllJwaWinsock2.ETOOMANYREFS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ETOOMANYREFS = WSAETOOMANYREFS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ETOOMANYREFS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EUSERS Constant

nxllJwaWinsock2.EUSERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EUSERS = WSAEUSERS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.EUSERS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.EWOULDBLOCK Constant

nxllJwaWinsock2.EWOULDBLOCK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
EWOULDBLOCK = WSAEWOULDBLOCK;
File

nxllJwaWinsock2

Description

Windows Sockets errors redefined as regular Berkeley error constants. These are commented out in Windows NT to avoid conflicts with errno.h. Use the WSA constants instead.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ACCEPT Constant

nxllJwaWinsock2.FD_ACCEPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ACCEPT = (1 shl FD_ACCEPT_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ACCEPT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ACCEPT_BIT Constant

nxllJwaWinsock2.FD_ACCEPT_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ACCEPT_BIT = 3;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ACCEPT_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE Constant

nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ADDRESS_LIST_CHANGE = (1 shl FD_ADDRESS_LIST_CHANGE_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE_BIT Constant

nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ADDRESS_LIST_CHANGE_BIT = 9;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ADDRESS_LIST_CHANGE_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ALL_EVENTS Constant

nxllJwaWinsock2.FD_ALL_EVENTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ALL_EVENTS = ((1 shl FD_MAX_EVENTS) - 1);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ALL_EVENTS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_CLOSE Constant

nxllJwaWinsock2.FD_CLOSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_CLOSE = (1 shl FD_CLOSE_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_CLOSE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_CLOSE_BIT Constant

nxllJwaWinsock2.FD_CLOSE_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_CLOSE_BIT = 5;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_CLOSE_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_CONNECT Constant

nxllJwaWinsock2.FD_CONNECT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_CONNECT = (1 shl FD_CONNECT_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_CONNECT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_CONNECT_BIT Constant

nxllJwaWinsock2.FD_CONNECT_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_CONNECT_BIT = 4;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_CONNECT_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_GROUP_QOS Constant

nxllJwaWinsock2.FD_GROUP_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_GROUP_QOS = (1 shl FD_GROUP_QOS_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_GROUP_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_GROUP_QOS_BIT Constant

nxllJwaWinsock2.FD_GROUP_QOS_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_GROUP_QOS_BIT = 7;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_GROUP_QOS_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_MAX_EVENTS Constant

nxllJwaWinsock2.FD_MAX_EVENTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_MAX_EVENTS = 10;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_MAX_EVENTS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_OOB Constant

nxllJwaWinsock2.FD_OOB Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_OOB = (1 shl FD_OOB_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_OOB.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_OOB_BIT Constant

nxllJwaWinsock2.FD_OOB_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_OOB_BIT = 2;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_OOB_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_QOS Constant

nxllJwaWinsock2.FD_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_QOS = (1 shl FD_QOS_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_QOS_BIT Constant

nxllJwaWinsock2.FD_QOS_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_QOS_BIT = 6;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_QOS_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_READ Constant

nxllJwaWinsock2.FD_READ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_READ = (1 shl FD_READ_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_READ.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_READ_BIT Constant

nxllJwaWinsock2.FD_READ_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_READ_BIT = 0;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- bit values and indices for FD_XXX network events

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE Constant

nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ROUTING_INTERFACE_CHANGE = (1 shl FD_ROUTING_INTERFACE_CHANGE_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE_BIT Constant

nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_ROUTING_INTERFACE_CHANGE_BIT = 8;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_ROUTING_INTERFACE_CHANGE_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_SETSIZE Constant

nxllJwaWinsock2.FD_SETSIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_SETSIZE = 64;
File

nxllJwaWinsock2

Description

Select uses arrays of SOCKETs. These macros manipulate such arrays. FD_SETSIZE may be defined by the user before including this file, but the default here should be >= 64.

CAVEAT IMPLEMENTOR and USER: THESE MACROS AND TYPES MUST BE INCLUDED IN WINSOCK2.H EXACTLY AS SHOWN HERE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_WRITE Constant

nxllJwaWinsock2.FD_WRITE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_WRITE = (1 shl FD_WRITE_BIT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_WRITE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FD_WRITE_BIT Constant

nxllJwaWinsock2.FD_WRITE_BIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FD_WRITE_BIT = 1;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.FD_WRITE_BIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FIOASYNC Constant

nxllJwaWinsock2.FIOASYNC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FIOASYNC = IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('f') shl 8) or 125;
File

nxllJwaWinsock2

Description

set/clear async i/o

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FIONBIO Constant

nxllJwaWinsock2.FIONBIO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FIONBIO = IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('f') shl 8) or 126;
File

nxllJwaWinsock2

Description

set/clear non-blocking i/o

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FIONREAD Constant

nxllJwaWinsock2.FIONREAD Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FIONREAD = IOC_OUT or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('f') shl 8) or 127;
File

nxllJwaWinsock2

Description

get # bytes to read

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.FROM_PROTOCOL_INFO Constant

nxllJwaWinsock2.FROM_PROTOCOL_INFO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
FROM_PROTOCOL_INFO = -1;
File

nxllJwaWinsock2

Description

The following may be used in place of the address family, socket type, or protocol in a call to WSASocket to indicate that the corresponding value should be taken from the supplied WSAPROTOCOL_INFO structure instead of the parameter itself.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.HOST_NOT_FOUND Constant

nxllJwaWinsock2.HOST_NOT_FOUND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
HOST_NOT_FOUND = WSAHOST_NOT_FOUND;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.HOST_NOT_FOUND.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IMPLINK_HIGHEXPER Constant

nxllJwaWinsock2.IMPLINK_HIGHEXPER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IMPLINK_HIGHEXPER = 158;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IMPLINK_HIGHEXPER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IMPLINK_IP Constant

nxllJwaWinsock2.IMPLINK_IP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IMPLINK_IP = 155;
File

nxllJwaWinsock2

Description

Link numbers

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IMPLINK_LOWEXPER Constant

nxllJwaWinsock2.IMPLINK_LOWEXPER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IMPLINK_LOWEXPER = 156;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IMPLINK_LOWEXPER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSA_HOST Constant

nxllJwaWinsock2.IN_CLASSA_HOST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSA_HOST = $00ffffff;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSA_HOST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSA_MAX Constant

nxllJwaWinsock2.IN_CLASSA_MAX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSA_MAX = 128;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSA_MAX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSA_NET Constant

nxllJwaWinsock2.IN_CLASSA_NET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSA_NET = DWORD($ff000000);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSA_NET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSA_NSHIFT Constant

nxllJwaWinsock2.IN_CLASSA_NSHIFT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSA_NSHIFT = 24;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSA_NSHIFT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSB_HOST Constant

nxllJwaWinsock2.IN_CLASSB_HOST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSB_HOST = $0000ffff;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSB_HOST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSB_MAX Constant

nxllJwaWinsock2.IN_CLASSB_MAX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSB_MAX = 65536;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSB_MAX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSB_NET Constant

nxllJwaWinsock2.IN_CLASSB_NET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSB_NET = DWORD($ffff0000);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSB_NET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSB_NSHIFT Constant

nxllJwaWinsock2.IN_CLASSB_NSHIFT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSB_NSHIFT = 16;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSB_NSHIFT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSC_HOST Constant

nxllJwaWinsock2.IN_CLASSC_HOST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSC_HOST = $000000ff;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSC_HOST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSC_NET Constant

nxllJwaWinsock2.IN_CLASSC_NET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSC_NET = DWORD($ffffff00);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSC_NET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSC_NSHIFT Constant

nxllJwaWinsock2.IN_CLASSC_NSHIFT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSC_NSHIFT = 8;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IN_CLASSC_NSHIFT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSD_HOST Constant

nxllJwaWinsock2.IN_CLASSD_HOST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSD_HOST = $0fffffff;
File

nxllJwaWinsock2

Description

routing needn't know.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSD_NET Constant

nxllJwaWinsock2.IN_CLASSD_NET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSD_NET = DWORD($f0000000);
File

nxllJwaWinsock2

Description

These ones aren't really

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IN_CLASSD_NSHIFT Constant

nxllJwaWinsock2.IN_CLASSD_NSHIFT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IN_CLASSD_NSHIFT = 28;
File

nxllJwaWinsock2

Description

net and host fields, but

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INADDR_ANY Constant

nxllJwaWinsock2.INADDR_ANY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INADDR_ANY = u_long($00000000);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.INADDR_ANY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INADDR_BROADCAST Constant

nxllJwaWinsock2.INADDR_BROADCAST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INADDR_BROADCAST = u_long($ffffffff);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.INADDR_BROADCAST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INADDR_LOOPBACK Constant

nxllJwaWinsock2.INADDR_LOOPBACK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INADDR_LOOPBACK = $7f000001;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.INADDR_LOOPBACK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INADDR_NONE Constant

nxllJwaWinsock2.INADDR_NONE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INADDR_NONE = DWORD($ffffffff);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.INADDR_NONE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INCL_WINSOCK_API_PROTOTYPES Constant

nxllJwaWinsock2.INCL_WINSOCK_API_PROTOTYPES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INCL_WINSOCK_API_PROTOTYPES = 1;
File

nxllJwaWinsock2

Description

Default: include function prototypes, don't include function typedefs.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INCL_WINSOCK_API_TYPEDEFS Constant

nxllJwaWinsock2.INCL_WINSOCK_API_TYPEDEFS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INCL_WINSOCK_API_TYPEDEFS = 0;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.INCL_WINSOCK_API_TYPEDEFS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.INVALID_SOCKET Constant

nxllJwaWinsock2.INVALID_SOCKET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
INVALID_SOCKET = TSocket(not 0);
File

nxllJwaWinsock2

Description

This is used instead of -1, since the SOCKET type is unsigned.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_IN Constant

nxllJwaWinsock2.IOC_IN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_IN = DWORD($80000000);
File

nxllJwaWinsock2

Description

copy in parameters

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_INOUT Constant

nxllJwaWinsock2.IOC_INOUT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_INOUT = DWORD(IOC_IN or IOC_OUT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IOC_INOUT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_OUT Constant

nxllJwaWinsock2.IOC_OUT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_OUT = $40000000;
File

nxllJwaWinsock2

Description

copy out parameters

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_PROTOCOL Constant

nxllJwaWinsock2.IOC_PROTOCOL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_PROTOCOL = $10000000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IOC_PROTOCOL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_UNIX Constant

nxllJwaWinsock2.IOC_UNIX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_UNIX = $00000000;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for WSAIoctl()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_VENDOR Constant

nxllJwaWinsock2.IOC_VENDOR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_VENDOR = $18000000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IOC_VENDOR.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_VOID Constant

nxllJwaWinsock2.IOC_VOID Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_VOID = $20000000;
File

nxllJwaWinsock2

Description

no parameters

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOC_WS2 Constant

nxllJwaWinsock2.IOC_WS2 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOC_WS2 = $08000000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IOC_WS2.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IOCPARM_MASK Constant

nxllJwaWinsock2.IOCPARM_MASK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IOCPARM_MASK = $7f;
File

nxllJwaWinsock2

Description

parameters must be < 128 bytes

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_BIFFUDP Constant

nxllJwaWinsock2.IPPORT_BIFFUDP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_BIFFUDP = 512;
File

nxllJwaWinsock2

Description

UNIX UDP sockets

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_CMDSERVER Constant

nxllJwaWinsock2.IPPORT_CMDSERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_CMDSERVER = 514;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_CMDSERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_DAYTIME Constant

nxllJwaWinsock2.IPPORT_DAYTIME Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_DAYTIME = 13;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_DAYTIME.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_DISCARD Constant

nxllJwaWinsock2.IPPORT_DISCARD Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_DISCARD = 9;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_DISCARD.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_ECHO Constant

nxllJwaWinsock2.IPPORT_ECHO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_ECHO = 7;
File

nxllJwaWinsock2

Description

Port/socket numbers: network standard functions

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_EFSSERVER Constant

nxllJwaWinsock2.IPPORT_EFSSERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_EFSSERVER = 520;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_EFSSERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_EXECSERVER Constant

nxllJwaWinsock2.IPPORT_EXECSERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_EXECSERVER = 512;
File

nxllJwaWinsock2

Description

UNIX TCP sockets

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_FINGER Constant

nxllJwaWinsock2.IPPORT_FINGER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_FINGER = 79;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_FINGER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_FTP Constant

nxllJwaWinsock2.IPPORT_FTP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_FTP = 21;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_FTP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_LOGINSERVER Constant

nxllJwaWinsock2.IPPORT_LOGINSERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_LOGINSERVER = 513;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_LOGINSERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_MTP Constant

nxllJwaWinsock2.IPPORT_MTP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_MTP = 57;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_MTP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_NAMESERVER Constant

nxllJwaWinsock2.IPPORT_NAMESERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_NAMESERVER = 42;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_NAMESERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_NETSTAT Constant

nxllJwaWinsock2.IPPORT_NETSTAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_NETSTAT = 15;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_NETSTAT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_RESERVED Constant

nxllJwaWinsock2.IPPORT_RESERVED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_RESERVED = 1024;
File

nxllJwaWinsock2

Description

Ports < IPPORT_RESERVED are reserved for privileged processes (e.g. root).

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_RJE Constant

nxllJwaWinsock2.IPPORT_RJE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_RJE = 77;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_RJE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_ROUTESERVER Constant

nxllJwaWinsock2.IPPORT_ROUTESERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_ROUTESERVER = 520;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_ROUTESERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_SMTP Constant

nxllJwaWinsock2.IPPORT_SMTP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_SMTP = 25;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_SMTP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_SUPDUP Constant

nxllJwaWinsock2.IPPORT_SUPDUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_SUPDUP = 95;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_SUPDUP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_SYSTAT Constant

nxllJwaWinsock2.IPPORT_SYSTAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_SYSTAT = 11;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_SYSTAT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_TELNET Constant

nxllJwaWinsock2.IPPORT_TELNET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_TELNET = 23;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_TELNET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_TFTP Constant

nxllJwaWinsock2.IPPORT_TFTP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_TFTP = 69;
File

nxllJwaWinsock2

Description

Port/socket numbers: host specific functions

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_TIMESERVER Constant

nxllJwaWinsock2.IPPORT_TIMESERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_TIMESERVER = 37;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_TIMESERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_TTYLINK Constant

nxllJwaWinsock2.IPPORT_TTYLINK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_TTYLINK = 87;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_TTYLINK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_WHOIS Constant

nxllJwaWinsock2.IPPORT_WHOIS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_WHOIS = 43;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_WHOIS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPORT_WHOSERVER Constant

nxllJwaWinsock2.IPPORT_WHOSERVER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPORT_WHOSERVER = 513;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPORT_WHOSERVER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_AH Constant

nxllJwaWinsock2.IPPROTO_AH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_AH = 51;
File

nxllJwaWinsock2

Description

IPsec AH

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_DSTOPTS Constant

nxllJwaWinsock2.IPPROTO_DSTOPTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_DSTOPTS = 60;
File

nxllJwaWinsock2

Description

IPv6 destination options

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ESP Constant

nxllJwaWinsock2.IPPROTO_ESP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ESP = 50;
File

nxllJwaWinsock2

Description

IPsec ESP header

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_FRAGMENT Constant

nxllJwaWinsock2.IPPROTO_FRAGMENT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_FRAGMENT = 44;
File

nxllJwaWinsock2

Description

IPv6 fragmentation header

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_GGP Constant

nxllJwaWinsock2.IPPROTO_GGP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_GGP = 3;
File

nxllJwaWinsock2

Description

gateway^2 (deprecated)

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_HOPOPTS Constant

nxllJwaWinsock2.IPPROTO_HOPOPTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_HOPOPTS = 0;
File

nxllJwaWinsock2

Description

IPv6 hop-by-hop options

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ICLFXBM Constant

nxllJwaWinsock2.IPPROTO_ICLFXBM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ICLFXBM = 78;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPROTO_ICLFXBM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ICMP Constant

nxllJwaWinsock2.IPPROTO_ICMP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ICMP = 1;
File

nxllJwaWinsock2

Description

control message protocol

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ICMPV6 Constant

nxllJwaWinsock2.IPPROTO_ICMPV6 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ICMPV6 = 58;
File

nxllJwaWinsock2

Description

ICMPv6

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_IDP Constant

nxllJwaWinsock2.IPPROTO_IDP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_IDP = 22;
File

nxllJwaWinsock2

Description

xns idp

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_IGMP Constant

nxllJwaWinsock2.IPPROTO_IGMP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_IGMP = 2;
File

nxllJwaWinsock2

Description

internet group management protocol

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_IP Constant

nxllJwaWinsock2.IPPROTO_IP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_IP = 0;
File

nxllJwaWinsock2

Description

dummy for IP

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_IPV4 Constant

nxllJwaWinsock2.IPPROTO_IPV4 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_IPV4 = 4;
File

nxllJwaWinsock2

Description

IPv4

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_IPV6 Constant

nxllJwaWinsock2.IPPROTO_IPV6 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_IPV6 = 41;
File

nxllJwaWinsock2

Description

IPv6

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_MAX Constant

nxllJwaWinsock2.IPPROTO_MAX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_MAX = 256;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.IPPROTO_MAX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ND Constant

nxllJwaWinsock2.IPPROTO_ND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ND = 77;
File

nxllJwaWinsock2

Description

UNOFFICIAL net disk proto

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_NONE Constant

nxllJwaWinsock2.IPPROTO_NONE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_NONE = 59;
File

nxllJwaWinsock2

Description

IPv6 no next header

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_PUP Constant

nxllJwaWinsock2.IPPROTO_PUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_PUP = 12;
File

nxllJwaWinsock2

Description

pup

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_RAW Constant

nxllJwaWinsock2.IPPROTO_RAW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_RAW = 255;
File

nxllJwaWinsock2

Description

raw IP packet

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_ROUTING Constant

nxllJwaWinsock2.IPPROTO_ROUTING Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_ROUTING = 43;
File

nxllJwaWinsock2

Description

IPv6 routing header

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_TCP Constant

nxllJwaWinsock2.IPPROTO_TCP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_TCP = 6;
File

nxllJwaWinsock2

Description

tcp

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.IPPROTO_UDP Constant

nxllJwaWinsock2.IPPROTO_UDP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
IPPROTO_UDP = 17;
File

nxllJwaWinsock2

Description

user datagram protocol

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.JL_BOTH Constant

nxllJwaWinsock2.JL_BOTH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
JL_BOTH = $04;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.JL_BOTH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.JL_RECEIVER_ONLY Constant

nxllJwaWinsock2.JL_RECEIVER_ONLY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
JL_RECEIVER_ONLY = $02;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.JL_RECEIVER_ONLY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.JL_SENDER_ONLY Constant

nxllJwaWinsock2.JL_SENDER_ONLY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
JL_SENDER_ONLY = $01;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for WSAJoinLeaf()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LAYERED_PROTOCOL Constant

nxllJwaWinsock2.LAYERED_PROTOCOL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LAYERED_PROTOCOL = 0;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LAYERED_PROTOCOL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LITTLEENDIAN Constant

nxllJwaWinsock2.LITTLEENDIAN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LITTLEENDIAN = $0001;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LITTLEENDIAN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_CONTAINERS Constant

nxllJwaWinsock2.LUP_CONTAINERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_CONTAINERS = $0002;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_CONTAINERS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_DEEP Constant

nxllJwaWinsock2.LUP_DEEP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_DEEP = $0001;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_DEEP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_FLUSHCACHE Constant

nxllJwaWinsock2.LUP_FLUSHCACHE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_FLUSHCACHE = $1000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_FLUSHCACHE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_FLUSHPREVIOUS Constant

nxllJwaWinsock2.LUP_FLUSHPREVIOUS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_FLUSHPREVIOUS = $2000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_FLUSHPREVIOUS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_NEAREST Constant

nxllJwaWinsock2.LUP_NEAREST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_NEAREST = $0008;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_NEAREST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_NOCONTAINERS Constant

nxllJwaWinsock2.LUP_NOCONTAINERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_NOCONTAINERS = $0004;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_NOCONTAINERS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RES_SERVICE Constant

nxllJwaWinsock2.LUP_RES_SERVICE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RES_SERVICE = $8000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RES_SERVICE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_ADDR Constant

nxllJwaWinsock2.LUP_RETURN_ADDR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_ADDR = $0100;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_ADDR.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_ALIASES Constant

nxllJwaWinsock2.LUP_RETURN_ALIASES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_ALIASES = $0400;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_ALIASES.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_ALL Constant

nxllJwaWinsock2.LUP_RETURN_ALL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_ALL = $0FF0;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_ALL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_BLOB Constant

nxllJwaWinsock2.LUP_RETURN_BLOB Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_BLOB = $0200;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_BLOB.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_COMMENT Constant

nxllJwaWinsock2.LUP_RETURN_COMMENT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_COMMENT = $0080;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_COMMENT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_NAME Constant

nxllJwaWinsock2.LUP_RETURN_NAME Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_NAME = $0010;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_NAME.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_QUERY_STRING Constant

nxllJwaWinsock2.LUP_RETURN_QUERY_STRING Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_QUERY_STRING = $0800;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_QUERY_STRING.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_TYPE Constant

nxllJwaWinsock2.LUP_RETURN_TYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_TYPE = $0020;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_TYPE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.LUP_RETURN_VERSION Constant

nxllJwaWinsock2.LUP_RETURN_VERSION Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
LUP_RETURN_VERSION = $0040;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.LUP_RETURN_VERSION.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MAX_PROTOCOL_CHAIN Constant

nxllJwaWinsock2.MAX_PROTOCOL_CHAIN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MAX_PROTOCOL_CHAIN = 7;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- WSAPROTOCOL_INFO structure and associated manifest constants

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MAXGETHOSTSTRUCT Constant

nxllJwaWinsock2.MAXGETHOSTSTRUCT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MAXGETHOSTSTRUCT = 1024;
File

nxllJwaWinsock2

Description

Define constant based on rfc883, used by gethostbyxxxx() calls.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_DONTROUTE Constant

nxllJwaWinsock2.MSG_DONTROUTE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_DONTROUTE = $4;
File

nxllJwaWinsock2

Description

send without using routing tables

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_INTERRUPT Constant

nxllJwaWinsock2.MSG_INTERRUPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_INTERRUPT = $10;
File

nxllJwaWinsock2

Description

send/recv in the interrupt context

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_MAXIOVLEN Constant

nxllJwaWinsock2.MSG_MAXIOVLEN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_MAXIOVLEN = 16;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.MSG_MAXIOVLEN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_OOB Constant

nxllJwaWinsock2.MSG_OOB Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_OOB = $1;
File

nxllJwaWinsock2

Description

process out-of-band data

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_PARTIAL Constant

nxllJwaWinsock2.MSG_PARTIAL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_PARTIAL = $8000;
File

nxllJwaWinsock2

Description

partial send or recv for message xport

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.MSG_PEEK Constant

nxllJwaWinsock2.MSG_PEEK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
MSG_PEEK = $2;
File

nxllJwaWinsock2

Description

peek at incoming message

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NO_ADDRESS Constant

nxllJwaWinsock2.NO_ADDRESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NO_ADDRESS = WSANO_ADDRESS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NO_ADDRESS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NO_DATA Constant

nxllJwaWinsock2.NO_DATA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NO_DATA = WSANO_DATA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NO_DATA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NO_RECOVERY Constant

nxllJwaWinsock2.NO_RECOVERY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NO_RECOVERY = WSANO_RECOVERY;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NO_RECOVERY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_ALL Constant

nxllJwaWinsock2.NS_ALL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_ALL = (0);
File

nxllJwaWinsock2

Description

Name Spaces

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_DHCP Constant

nxllJwaWinsock2.NS_DHCP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_DHCP = (6);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_DHCP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_DNS Constant

nxllJwaWinsock2.NS_DNS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_DNS = (12);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_DNS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_MS Constant

nxllJwaWinsock2.NS_MS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_MS = (30);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_MS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NBP Constant

nxllJwaWinsock2.NS_NBP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NBP = (20);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NBP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NDS Constant

nxllJwaWinsock2.NS_NDS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NDS = (2);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NDS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NETBT Constant

nxllJwaWinsock2.NS_NETBT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NETBT = (13);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NETBT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NETDES Constant

nxllJwaWinsock2.NS_NETDES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NETDES = (60);
File

nxllJwaWinsock2

Description

Network Designers Limited

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NIS Constant

nxllJwaWinsock2.NS_NIS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NIS = (41);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NIS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NISPLUS Constant

nxllJwaWinsock2.NS_NISPLUS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NISPLUS = (42);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NISPLUS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NLA Constant

nxllJwaWinsock2.NS_NLA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NLA = (15);
File

nxllJwaWinsock2

Description

Network Location Awareness

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_NTDS Constant

nxllJwaWinsock2.NS_NTDS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_NTDS = (32);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_NTDS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_PEER_BROWSE Constant

nxllJwaWinsock2.NS_PEER_BROWSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_PEER_BROWSE = (3);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_PEER_BROWSE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_SAP Constant

nxllJwaWinsock2.NS_SAP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_SAP = (1);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_SAP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_SLP Constant

nxllJwaWinsock2.NS_SLP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_SLP = (5);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_SLP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_STDA Constant

nxllJwaWinsock2.NS_STDA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_STDA = (31);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_STDA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_TCPIP_HOSTS Constant

nxllJwaWinsock2.NS_TCPIP_HOSTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_TCPIP_HOSTS = (11);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_TCPIP_HOSTS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_TCPIP_LOCAL Constant

nxllJwaWinsock2.NS_TCPIP_LOCAL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_TCPIP_LOCAL = (10);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_TCPIP_LOCAL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_WINS Constant

nxllJwaWinsock2.NS_WINS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_WINS = (14);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_WINS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_WRQ Constant

nxllJwaWinsock2.NS_WRQ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_WRQ = (50);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_WRQ.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.NS_X500 Constant

nxllJwaWinsock2.NS_X500 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
NS_X500 = (40);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.NS_X500.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_APPLETALK Constant

nxllJwaWinsock2.PF_APPLETALK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_APPLETALK = AF_APPLETALK;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_APPLETALK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_ATM Constant

nxllJwaWinsock2.PF_ATM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_ATM = AF_ATM;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_ATM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_BAN Constant

nxllJwaWinsock2.PF_BAN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_BAN = AF_BAN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_BAN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_CCITT Constant

nxllJwaWinsock2.PF_CCITT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_CCITT = AF_CCITT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_CCITT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_CHAOS Constant

nxllJwaWinsock2.PF_CHAOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_CHAOS = AF_CHAOS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_CHAOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_DATAKIT Constant

nxllJwaWinsock2.PF_DATAKIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_DATAKIT = AF_DATAKIT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_DATAKIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_DECnet Constant

nxllJwaWinsock2.PF_DECnet Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_DECnet = AF_DECnet;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_DECnet.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_DLI Constant

nxllJwaWinsock2.PF_DLI Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_DLI = AF_DLI;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_DLI.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_ECMA Constant

nxllJwaWinsock2.PF_ECMA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_ECMA = AF_ECMA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_ECMA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_FIREFOX Constant

nxllJwaWinsock2.PF_FIREFOX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_FIREFOX = AF_FIREFOX;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_FIREFOX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_HYLINK Constant

nxllJwaWinsock2.PF_HYLINK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_HYLINK = AF_HYLINK;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_HYLINK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_IMPLINK Constant

nxllJwaWinsock2.PF_IMPLINK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_IMPLINK = AF_IMPLINK;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_IMPLINK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_INET Constant

nxllJwaWinsock2.PF_INET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_INET = AF_INET;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_INET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_INET6 Constant

nxllJwaWinsock2.PF_INET6 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_INET6 = AF_INET6;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_INET6.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_IPX Constant

nxllJwaWinsock2.PF_IPX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_IPX = AF_IPX;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_IPX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_ISO Constant

nxllJwaWinsock2.PF_ISO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_ISO = AF_ISO;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_ISO.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_LAT Constant

nxllJwaWinsock2.PF_LAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_LAT = AF_LAT;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_LAT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_MAX Constant

nxllJwaWinsock2.PF_MAX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_MAX = AF_MAX;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_MAX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_NS Constant

nxllJwaWinsock2.PF_NS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_NS = AF_NS;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_NS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_OSI Constant

nxllJwaWinsock2.PF_OSI Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_OSI = AF_OSI;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_OSI.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_PUP Constant

nxllJwaWinsock2.PF_PUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_PUP = AF_PUP;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_PUP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_SNA Constant

nxllJwaWinsock2.PF_SNA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_SNA = AF_SNA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_SNA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_UNIX Constant

nxllJwaWinsock2.PF_UNIX Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_UNIX = AF_UNIX;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_UNIX.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_UNKNOWN1 Constant

nxllJwaWinsock2.PF_UNKNOWN1 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_UNKNOWN1 = AF_UNKNOWN1;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_UNKNOWN1.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_UNSPEC Constant

nxllJwaWinsock2.PF_UNSPEC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_UNSPEC = AF_UNSPEC;
File

nxllJwaWinsock2

Description

Protocol families, same as address families for now.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PF_VOICEVIEW Constant

nxllJwaWinsock2.PF_VOICEVIEW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PF_VOICEVIEW = AF_VOICEVIEW;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PF_VOICEVIEW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PFL_HIDDEN Constant

nxllJwaWinsock2.PFL_HIDDEN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PFL_HIDDEN = $00000004;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PFL_HIDDEN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PFL_MATCHES_PROTOCOL_ZERO Constant

nxllJwaWinsock2.PFL_MATCHES_PROTOCOL_ZERO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PFL_MATCHES_PROTOCOL_ZERO = $00000008;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PFL_MATCHES_PROTOCOL_ZERO.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PFL_MULTIPLE_PROTO_ENTRIES Constant

nxllJwaWinsock2.PFL_MULTIPLE_PROTO_ENTRIES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PFL_MULTIPLE_PROTO_ENTRIES = $00000001;
File

nxllJwaWinsock2

Description

Flag bit definitions for dwProviderFlags

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PFL_RECOMMENDED_PROTO_ENTRY Constant

nxllJwaWinsock2.PFL_RECOMMENDED_PROTO_ENTRY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PFL_RECOMMENDED_PROTO_ENTRY = $00000002;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.PFL_RECOMMENDED_PROTO_ENTRY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.PVD_CONFIG Constant

nxllJwaWinsock2.PVD_CONFIG Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
PVD_CONFIG = $3001;
File

nxllJwaWinsock2

Description

configuration info for service provider

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RES_FLUSH_CACHE Constant

nxllJwaWinsock2.RES_FLUSH_CACHE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RES_FLUSH_CACHE = ($00000002);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.RES_FLUSH_CACHE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RES_SERVICE Constant

nxllJwaWinsock2.RES_SERVICE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RES_SERVICE = ($00000004);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.RES_SERVICE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RES_UNUSED_1 Constant

nxllJwaWinsock2.RES_UNUSED_1 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RES_UNUSED_1 = ($00000001);
File

nxllJwaWinsock2

Description

Resolution flags for WSAGetAddressByName(). Note these are also used by the 1.1 API GetAddressByName, so leave them around.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RESULT_IS_ADDED Constant

nxllJwaWinsock2.RESULT_IS_ADDED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RESULT_IS_ADDED = $0010;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.RESULT_IS_ADDED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RESULT_IS_ALIAS Constant

nxllJwaWinsock2.RESULT_IS_ALIAS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RESULT_IS_ALIAS = $0001;
File

nxllJwaWinsock2

Description

Return flags

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RESULT_IS_CHANGED Constant

nxllJwaWinsock2.RESULT_IS_CHANGED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RESULT_IS_CHANGED = $0020;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.RESULT_IS_CHANGED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.RESULT_IS_DELETED Constant

nxllJwaWinsock2.RESULT_IS_DELETED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
RESULT_IS_DELETED = $0040;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.RESULT_IS_DELETED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SD_BOTH Constant

nxllJwaWinsock2.SD_BOTH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SD_BOTH = $02;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SD_BOTH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SD_RECEIVE Constant

nxllJwaWinsock2.SD_RECEIVE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SD_RECEIVE = $00;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for shutdown()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SD_SEND Constant

nxllJwaWinsock2.SD_SEND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SD_SEND = $01;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SD_SEND.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SECURITY_PROTOCOL_NONE Constant

nxllJwaWinsock2.SECURITY_PROTOCOL_NONE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SECURITY_PROTOCOL_NONE = $0000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SECURITY_PROTOCOL_NONE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_MULTIPLE Constant

nxllJwaWinsock2.SERVICE_MULTIPLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_MULTIPLE = ($00000001);
File

nxllJwaWinsock2

Description

Service Install Flags

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTA Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_IPXPORTA = 'IpxSocket';
File

nxllJwaWinsock2

Description

Well known value names for Service Types

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTW Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_IPXPORTW = WideString('IpxSocket');
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_IPXPORTW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTID Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTID Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_OBJECTID = SERVICE_TYPE_VALUE_OBJECTIDA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTID.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDA Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_OBJECTIDA = 'ObjectId';
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDW Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_OBJECTIDW = WideString('ObjectId');
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_OBJECTIDW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPID Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPID Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_SAPID = SERVICE_TYPE_VALUE_SAPIDA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPID.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDA Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_SAPIDA = 'SapId';
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDW Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_SAPIDW = WideString('SapId');
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_SAPIDW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORT Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_TCPPORT = SERVICE_TYPE_VALUE_TCPPORTA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTA Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_TCPPORTA = 'TcpPort';
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTW Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_TCPPORTW = WideString('TcpPort');
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_TCPPORTW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORT Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_UDPPORT = SERVICE_TYPE_VALUE_UDPPORTA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTA Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_UDPPORTA = 'UdpPort';
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTW Constant

nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SERVICE_TYPE_VALUE_UDPPORTW = WideString('UdpPort');
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SERVICE_TYPE_VALUE_UDPPORTW.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SG_CONSTRAINED_GROUP Constant

nxllJwaWinsock2.SG_CONSTRAINED_GROUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SG_CONSTRAINED_GROUP = $02;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SG_CONSTRAINED_GROUP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SG_UNCONSTRAINED_GROUP Constant

nxllJwaWinsock2.SG_UNCONSTRAINED_GROUP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SG_UNCONSTRAINED_GROUP = $01;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SG_UNCONSTRAINED_GROUP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ADDRESS_LIST_CHANGE Constant

nxllJwaWinsock2.SIO_ADDRESS_LIST_CHANGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ADDRESS_LIST_CHANGE = IOC_VOID or IOC_WS2 or 23;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_CHANGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ADDRESS_LIST_QUERY Constant

nxllJwaWinsock2.SIO_ADDRESS_LIST_QUERY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ADDRESS_LIST_QUERY = IOC_OUT or IOC_WS2 or 22;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_QUERY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ADDRESS_LIST_SORT Constant

nxllJwaWinsock2.SIO_ADDRESS_LIST_SORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ADDRESS_LIST_SORT = IOC_INOUT or IOC_WS2 or 25;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ADDRESS_LIST_SORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ASSOCIATE_HANDLE Constant

nxllJwaWinsock2.SIO_ASSOCIATE_HANDLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ASSOCIATE_HANDLE = IOC_INOUT or IOC_WS2 or 1;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ASSOCIATE_HANDLE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ENABLE_CIRCULAR_QUEUEING Constant

nxllJwaWinsock2.SIO_ENABLE_CIRCULAR_QUEUEING Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ENABLE_CIRCULAR_QUEUEING = IOC_VOID or IOC_WS2 or 2;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ENABLE_CIRCULAR_QUEUEING.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_FIND_ROUTE Constant

nxllJwaWinsock2.SIO_FIND_ROUTE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_FIND_ROUTE = IOC_OUT or IOC_WS2 or 3;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_FIND_ROUTE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_FLUSH Constant

nxllJwaWinsock2.SIO_FLUSH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_FLUSH = IOC_VOID or IOC_WS2 or 4;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_FLUSH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_GET_BROADCAST_ADDRESS Constant

nxllJwaWinsock2.SIO_GET_BROADCAST_ADDRESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_GET_BROADCAST_ADDRESS = IOC_OUT or IOC_WS2 or 5;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_GET_BROADCAST_ADDRESS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_GET_EXTENSION_FUNCTION_POINTER Constant

nxllJwaWinsock2.SIO_GET_EXTENSION_FUNCTION_POINTER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_GET_EXTENSION_FUNCTION_POINTER = IOC_INOUT or IOC_WS2 or 6;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_GET_EXTENSION_FUNCTION_POINTER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_GET_GROUP_QOS Constant

nxllJwaWinsock2.SIO_GET_GROUP_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_GET_GROUP_QOS = IOC_INOUT or IOC_WS2 or 8;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_GET_GROUP_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_GET_QOS Constant

nxllJwaWinsock2.SIO_GET_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_GET_QOS = IOC_INOUT or IOC_WS2 or 7;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_GET_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_MULTICAST_SCOPE Constant

nxllJwaWinsock2.SIO_MULTICAST_SCOPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_MULTICAST_SCOPE = IOC_INOUT or IOC_WS2 or 10;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_MULTICAST_SCOPE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_MULTIPOINT_LOOPBACK Constant

nxllJwaWinsock2.SIO_MULTIPOINT_LOOPBACK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_MULTIPOINT_LOOPBACK = IOC_INOUT or IOC_WS2 or 9;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_MULTIPOINT_LOOPBACK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_NSP_NOTIFY_CHANGE Constant

nxllJwaWinsock2.SIO_NSP_NOTIFY_CHANGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_NSP_NOTIFY_CHANGE = IOC_IN or IOC_WS2 or 25;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants and associated structures for WSANSPIoctl()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_QUERY_TARGET_PNP_HANDLE Constant

nxllJwaWinsock2.SIO_QUERY_TARGET_PNP_HANDLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_QUERY_TARGET_PNP_HANDLE = IOC_OUT or IOC_WS2 or 24;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_QUERY_TARGET_PNP_HANDLE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ROUTING_INTERFACE_CHANGE Constant

nxllJwaWinsock2.SIO_ROUTING_INTERFACE_CHANGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ROUTING_INTERFACE_CHANGE = IOC_INOUT or IOC_WS2 or 21;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_CHANGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_ROUTING_INTERFACE_QUERY Constant

nxllJwaWinsock2.SIO_ROUTING_INTERFACE_QUERY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_ROUTING_INTERFACE_QUERY = IOC_INOUT or IOC_WS2 or 20;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_ROUTING_INTERFACE_QUERY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_SET_GROUP_QOS Constant

nxllJwaWinsock2.SIO_SET_GROUP_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_SET_GROUP_QOS = IOC_INOUT or IOC_WS2 or 12;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_SET_GROUP_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_SET_QOS Constant

nxllJwaWinsock2.SIO_SET_QOS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_SET_QOS = IOC_INOUT or IOC_WS2 or 11;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_SET_QOS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIO_TRANSLATE_HANDLE Constant

nxllJwaWinsock2.SIO_TRANSLATE_HANDLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIO_TRANSLATE_HANDLE = IOC_INOUT or IOC_WS2 or 13;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SIO_TRANSLATE_HANDLE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIOCATMARK Constant

nxllJwaWinsock2.SIOCATMARK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIOCATMARK = IOC_OUT or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('s') shl 8) or 7;
File

nxllJwaWinsock2

Description

at oob mark?

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIOCGHIWAT Constant

nxllJwaWinsock2.SIOCGHIWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIOCGHIWAT = IOC_OUT or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('s') shl 8) or 1;
File

nxllJwaWinsock2

Description

get high watermark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIOCGLOWAT Constant

nxllJwaWinsock2.SIOCGLOWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIOCGLOWAT = IOC_OUT or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('s') shl 8) or 3;
File

nxllJwaWinsock2

Description

get low watermark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIOCSHIWAT Constant

nxllJwaWinsock2.SIOCSHIWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIOCSHIWAT = DWORD(IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('s') shl 8) or 0);
File

nxllJwaWinsock2

Description

set high watermark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SIOCSLOWAT Constant

nxllJwaWinsock2.SIOCSLOWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SIOCSLOWAT = DWORD(IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('s') shl 8) or 2);
File

nxllJwaWinsock2

Description

set low watermark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_ACCEPTCONN Constant

nxllJwaWinsock2.SO_ACCEPTCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_ACCEPTCONN = $0002;
File

nxllJwaWinsock2

Description

socket has had listen()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_BROADCAST Constant

nxllJwaWinsock2.SO_BROADCAST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_BROADCAST = $0020;
File

nxllJwaWinsock2

Description

permit sending of broadcast msgs

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_CONDITIONAL_ACCEPT Constant

nxllJwaWinsock2.SO_CONDITIONAL_ACCEPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_CONDITIONAL_ACCEPT = $3002;
File

nxllJwaWinsock2

Description

enable true conditional accept: connection is not ack-ed to the other side until conditional function returns CF_ACCEPT

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_DEBUG Constant

nxllJwaWinsock2.SO_DEBUG Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_DEBUG = $0001;
File

nxllJwaWinsock2

Description

turn on debugging info recording

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_DONTLINGER Constant

nxllJwaWinsock2.SO_DONTLINGER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_DONTLINGER = DWORD(not SO_LINGER);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SO_DONTLINGER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_DONTROUTE Constant

nxllJwaWinsock2.SO_DONTROUTE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_DONTROUTE = $0010;
File

nxllJwaWinsock2

Description

just use interface addresses

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_ERROR Constant

nxllJwaWinsock2.SO_ERROR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_ERROR = $1007;
File

nxllJwaWinsock2

Description

get error status and clear

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_EXCLUSIVEADDRUSE Constant

nxllJwaWinsock2.SO_EXCLUSIVEADDRUSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_EXCLUSIVEADDRUSE = DWORD(not SO_REUSEADDR);
File

nxllJwaWinsock2

Description

disallow local address reuse

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_GROUP_ID Constant

nxllJwaWinsock2.SO_GROUP_ID Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_GROUP_ID = $2001;
File

nxllJwaWinsock2

Description

ID of a socket group

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_GROUP_PRIORITY Constant

nxllJwaWinsock2.SO_GROUP_PRIORITY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_GROUP_PRIORITY = $2002;
File

nxllJwaWinsock2

Description

the relative priority within a group

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_KEEPALIVE Constant

nxllJwaWinsock2.SO_KEEPALIVE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_KEEPALIVE = $0008;
File

nxllJwaWinsock2

Description

keep connections alive

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_LINGER Constant

nxllJwaWinsock2.SO_LINGER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_LINGER = $0080;
File

nxllJwaWinsock2

Description

linger on close if data present

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_MAX_MSG_SIZE Constant

nxllJwaWinsock2.SO_MAX_MSG_SIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_MAX_MSG_SIZE = $2003;
File

nxllJwaWinsock2

Description

maximum message size

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_OOBINLINE Constant

nxllJwaWinsock2.SO_OOBINLINE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_OOBINLINE = $0100;
File

nxllJwaWinsock2

Description

leave received OOB data in line

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_OPENTYPE Constant

nxllJwaWinsock2.SO_OPENTYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_OPENTYPE = $7008;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SO_OPENTYPE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_PROTOCOL_INFO Constant

nxllJwaWinsock2.SO_PROTOCOL_INFO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_PROTOCOL_INFO = SO_PROTOCOL_INFOA;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SO_PROTOCOL_INFO.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_PROTOCOL_INFOA Constant

nxllJwaWinsock2.SO_PROTOCOL_INFOA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_PROTOCOL_INFOA = $2004;
File

nxllJwaWinsock2

Description

WSAPROTOCOL_INFOA structure

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_PROTOCOL_INFOW Constant

nxllJwaWinsock2.SO_PROTOCOL_INFOW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_PROTOCOL_INFOW = $2005;
File

nxllJwaWinsock2

Description

WSAPROTOCOL_INFOW structure

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_RCVBUF Constant

nxllJwaWinsock2.SO_RCVBUF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_RCVBUF = $1002;
File

nxllJwaWinsock2

Description

receive buffer size

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_RCVLOWAT Constant

nxllJwaWinsock2.SO_RCVLOWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_RCVLOWAT = $1004;
File

nxllJwaWinsock2

Description

receive low-water mark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_RCVTIMEO Constant

nxllJwaWinsock2.SO_RCVTIMEO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_RCVTIMEO = $1006;
File

nxllJwaWinsock2

Description

receive timeout

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_REUSEADDR Constant

nxllJwaWinsock2.SO_REUSEADDR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_REUSEADDR = $0004;
File

nxllJwaWinsock2

Description

allow local address reuse

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_SNDBUF Constant

nxllJwaWinsock2.SO_SNDBUF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_SNDBUF = $1001;
File

nxllJwaWinsock2

Description

send buffer size

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_SNDLOWAT Constant

nxllJwaWinsock2.SO_SNDLOWAT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_SNDLOWAT = $1003;
File

nxllJwaWinsock2

Description

send low-water mark

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_SNDTIMEO Constant

nxllJwaWinsock2.SO_SNDTIMEO Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_SNDTIMEO = $1005;
File

nxllJwaWinsock2

Description

send timeout

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_SYNCHRONOUS_ALERT Constant

nxllJwaWinsock2.SO_SYNCHRONOUS_ALERT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_SYNCHRONOUS_ALERT = $10;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_ALERT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_SYNCHRONOUS_NONALERT Constant

nxllJwaWinsock2.SO_SYNCHRONOUS_NONALERT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_SYNCHRONOUS_NONALERT = $20;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SO_SYNCHRONOUS_NONALERT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_TYPE Constant

nxllJwaWinsock2.SO_TYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_TYPE = $1008;
File

nxllJwaWinsock2

Description

get socket type

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SO_USELOOPBACK Constant

nxllJwaWinsock2.SO_USELOOPBACK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SO_USELOOPBACK = $0040;
File

nxllJwaWinsock2

Description

bypass hardware when possible

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCK_DGRAM Constant

nxllJwaWinsock2.SOCK_DGRAM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCK_DGRAM = 2;
File

nxllJwaWinsock2

Description

datagram socket

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCK_RAW Constant

nxllJwaWinsock2.SOCK_RAW Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCK_RAW = 3;
File

nxllJwaWinsock2

Description

raw-protocol interface

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCK_RDM Constant

nxllJwaWinsock2.SOCK_RDM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCK_RDM = 4;
File

nxllJwaWinsock2

Description

reliably-delivered message

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCK_SEQPACKET Constant

nxllJwaWinsock2.SOCK_SEQPACKET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCK_SEQPACKET = 5;
File

nxllJwaWinsock2

Description

sequenced packet stream

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCK_STREAM Constant

nxllJwaWinsock2.SOCK_STREAM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCK_STREAM = 1;
File

nxllJwaWinsock2

Description

stream socket

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOCKET_ERROR Constant

nxllJwaWinsock2.SOCKET_ERROR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOCKET_ERROR = -1;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.SOCKET_ERROR.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOL_SOCKET Constant

nxllJwaWinsock2.SOL_SOCKET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOL_SOCKET = $ffff;
File

nxllJwaWinsock2

Description

options for socket level

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.SOMAXCONN Constant

nxllJwaWinsock2.SOMAXCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
SOMAXCONN = $7fffffff;
File

nxllJwaWinsock2

Description

Maximum queue length specifiable by listen.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.TCP_NODELAY Constant

nxllJwaWinsock2.TCP_NODELAY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
TCP_NODELAY = $0001;
File

nxllJwaWinsock2

Description

TCP options.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.TH_NETDEV Constant

nxllJwaWinsock2.TH_NETDEV Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
TH_NETDEV = $00000001;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for SIO_TRANSLATE_HANDLE ioctl

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.TH_TAPI Constant

nxllJwaWinsock2.TH_TAPI Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
TH_TAPI = $00000002;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.TH_TAPI.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.TRY_AGAIN Constant

nxllJwaWinsock2.TRY_AGAIN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
TRY_AGAIN = WSATRY_AGAIN;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.TRY_AGAIN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WINSOCK_VERSION Constant

nxllJwaWinsock2.WINSOCK_VERSION Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WINSOCK_VERSION = $0202;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WINSOCK_VERSION.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.ws2_32 Constant

nxllJwaWinsock2.ws2_32 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
ws2_32 = 'ws2_32.dll';
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.ws2_32.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_E_CANCELLED Constant

nxllJwaWinsock2.WSA_E_CANCELLED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_E_CANCELLED = (WSABASEERR+111);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_E_CANCELLED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_E_NO_MORE Constant

nxllJwaWinsock2.WSA_E_NO_MORE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_E_NO_MORE = (WSABASEERR+110);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_E_NO_MORE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_LEAF Constant

nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_LEAF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_FLAG_MULTIPOINT_C_LEAF = $04;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_LEAF.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_ROOT Constant

nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_ROOT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_FLAG_MULTIPOINT_C_ROOT = $02;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_C_ROOT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_LEAF Constant

nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_LEAF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_FLAG_MULTIPOINT_D_LEAF = $10;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_LEAF.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_ROOT Constant

nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_ROOT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_FLAG_MULTIPOINT_D_ROOT = $08;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_FLAG_MULTIPOINT_D_ROOT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_FLAG_OVERLAPPED Constant

nxllJwaWinsock2.WSA_FLAG_OVERLAPPED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_FLAG_OVERLAPPED = $01;
File

nxllJwaWinsock2

Description

WinSock 2 extension -- manifest constants for WSASocket()

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_INFINITE Constant

nxllJwaWinsock2.WSA_INFINITE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_INFINITE = (INFINITE);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_INFINITE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_INVALID_EVENT Constant

nxllJwaWinsock2.WSA_INVALID_EVENT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_INVALID_EVENT = WSAEVENT(nil);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_INVALID_EVENT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_INVALID_HANDLE Constant

nxllJwaWinsock2.WSA_INVALID_HANDLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_INVALID_HANDLE = (ERROR_INVALID_HANDLE);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_INVALID_HANDLE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_INVALID_PARAMETER Constant

nxllJwaWinsock2.WSA_INVALID_PARAMETER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_INVALID_PARAMETER = (ERROR_INVALID_PARAMETER);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_INVALID_PARAMETER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_IO_INCOMPLETE Constant

nxllJwaWinsock2.WSA_IO_INCOMPLETE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_IO_INCOMPLETE = (ERROR_IO_INCOMPLETE);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_IO_INCOMPLETE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_IO_PENDING Constant

nxllJwaWinsock2.WSA_IO_PENDING Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_IO_PENDING = (ERROR_IO_PENDING);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_IO_PENDING.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_MAXIMUM_WAIT_EVENTS Constant

nxllJwaWinsock2.WSA_MAXIMUM_WAIT_EVENTS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_MAXIMUM_WAIT_EVENTS = (MAXIMUM_WAIT_OBJECTS);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_MAXIMUM_WAIT_EVENTS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_NOT_ENOUGH_MEMORY Constant

nxllJwaWinsock2.WSA_NOT_ENOUGH_MEMORY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_NOT_ENOUGH_MEMORY = (ERROR_NOT_ENOUGH_MEMORY);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_NOT_ENOUGH_MEMORY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_OPERATION_ABORTED Constant

nxllJwaWinsock2.WSA_OPERATION_ABORTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_OPERATION_ABORTED = (ERROR_OPERATION_ABORTED);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_OPERATION_ABORTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_ADMISSION_FAILURE Constant

nxllJwaWinsock2.WSA_QOS_ADMISSION_FAILURE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_ADMISSION_FAILURE = (WSABASEERR + 1010);
File

nxllJwaWinsock2

Description

error due to lack of resources

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_BAD_OBJECT Constant

nxllJwaWinsock2.WSA_QOS_BAD_OBJECT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_BAD_OBJECT = (WSABASEERR + 1013);
File

nxllJwaWinsock2

Description

problem with some part of the filterspec or providerspecific buffer in general

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_BAD_STYLE Constant

nxllJwaWinsock2.WSA_QOS_BAD_STYLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_BAD_STYLE = (WSABASEERR + 1012);
File

nxllJwaWinsock2

Description

unknown or conflicting style

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFILTERCOUNT Constant

nxllJwaWinsock2.WSA_QOS_EFILTERCOUNT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFILTERCOUNT = (WSABASEERR + 1021);
File

nxllJwaWinsock2

Description

incorrect number of filters

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFILTERSTYLE Constant

nxllJwaWinsock2.WSA_QOS_EFILTERSTYLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFILTERSTYLE = (WSABASEERR + 1019);
File

nxllJwaWinsock2

Description

invalid filter style

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFILTERTYPE Constant

nxllJwaWinsock2.WSA_QOS_EFILTERTYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFILTERTYPE = (WSABASEERR + 1020);
File

nxllJwaWinsock2

Description

invalid filter type

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFLOWCOUNT Constant

nxllJwaWinsock2.WSA_QOS_EFLOWCOUNT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFLOWCOUNT = (WSABASEERR + 1023);
File

nxllJwaWinsock2

Description

incorrect number of flows

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFLOWDESC Constant

nxllJwaWinsock2.WSA_QOS_EFLOWDESC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFLOWDESC = (WSABASEERR + 1026);
File

nxllJwaWinsock2

Description

invalid flow descriptor in the list

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EFLOWSPEC Constant

nxllJwaWinsock2.WSA_QOS_EFLOWSPEC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EFLOWSPEC = (WSABASEERR + 1017);
File

nxllJwaWinsock2

Description

invalid flowspec

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EOBJLENGTH Constant

nxllJwaWinsock2.WSA_QOS_EOBJLENGTH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EOBJLENGTH = (WSABASEERR + 1022);
File

nxllJwaWinsock2

Description

invalid object length

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EPOLICYOBJ Constant

nxllJwaWinsock2.WSA_QOS_EPOLICYOBJ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EPOLICYOBJ = (WSABASEERR + 1025);
File

nxllJwaWinsock2

Description

invalid policy object in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EPROVSPECBUF Constant

nxllJwaWinsock2.WSA_QOS_EPROVSPECBUF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EPROVSPECBUF = (WSABASEERR + 1018);
File

nxllJwaWinsock2

Description

invalid provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EPSFILTERSPEC Constant

nxllJwaWinsock2.WSA_QOS_EPSFILTERSPEC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EPSFILTERSPEC = (WSABASEERR + 1028);
File

nxllJwaWinsock2

Description

invalid filter spec in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EPSFLOWSPEC Constant

nxllJwaWinsock2.WSA_QOS_EPSFLOWSPEC Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EPSFLOWSPEC = (WSABASEERR + 1027);
File

nxllJwaWinsock2

Description

inconsistent flow spec in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_ESDMODEOBJ Constant

nxllJwaWinsock2.WSA_QOS_ESDMODEOBJ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_ESDMODEOBJ = (WSABASEERR + 1029);
File

nxllJwaWinsock2

Description

invalid shape discard mode object in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_ESERVICETYPE Constant

nxllJwaWinsock2.WSA_QOS_ESERVICETYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_ESERVICETYPE = (WSABASEERR + 1016);
File

nxllJwaWinsock2

Description

invalid service type in flowspec

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_ESHAPERATEOBJ Constant

nxllJwaWinsock2.WSA_QOS_ESHAPERATEOBJ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_ESHAPERATEOBJ = (WSABASEERR + 1030);
File

nxllJwaWinsock2

Description

invalid shaping rate object in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_EUNKOWNPSOBJ Constant

nxllJwaWinsock2.WSA_QOS_EUNKOWNPSOBJ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_EUNKOWNPSOBJ = (WSABASEERR + 1024);
File

nxllJwaWinsock2

Description

unknown object in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_GENERIC_ERROR Constant

nxllJwaWinsock2.WSA_QOS_GENERIC_ERROR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_GENERIC_ERROR = (WSABASEERR + 1015);
File

nxllJwaWinsock2

Description

general error

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_NO_RECEIVERS Constant

nxllJwaWinsock2.WSA_QOS_NO_RECEIVERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_NO_RECEIVERS = (WSABASEERR + 1008);
File

nxllJwaWinsock2

Description

there are no receivers

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_NO_SENDERS Constant

nxllJwaWinsock2.WSA_QOS_NO_SENDERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_NO_SENDERS = (WSABASEERR + 1007);
File

nxllJwaWinsock2

Description

there are no senders

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_POLICY_FAILURE Constant

nxllJwaWinsock2.WSA_QOS_POLICY_FAILURE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_POLICY_FAILURE = (WSABASEERR + 1011);
File

nxllJwaWinsock2

Description

rejected for administrative reasons - bad credentials

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_RECEIVERS Constant

nxllJwaWinsock2.WSA_QOS_RECEIVERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_RECEIVERS = (WSABASEERR + 1005);
File

nxllJwaWinsock2

Description

at least one Reserve has arrived

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_REQUEST_CONFIRMED Constant

nxllJwaWinsock2.WSA_QOS_REQUEST_CONFIRMED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_REQUEST_CONFIRMED = (WSABASEERR + 1009);
File

nxllJwaWinsock2

Description

Reserve has been confirmed

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_RESERVED_PETYPE Constant

nxllJwaWinsock2.WSA_QOS_RESERVED_PETYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_RESERVED_PETYPE = (WSABASEERR + 1031);
File

nxllJwaWinsock2

Description

reserved policy element in provider specific buffer

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_SENDERS Constant

nxllJwaWinsock2.WSA_QOS_SENDERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_SENDERS = (WSABASEERR + 1006);
File

nxllJwaWinsock2

Description

at least one Path has arrived

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_QOS_TRAFFIC_CTRL_ERROR Constant

nxllJwaWinsock2.WSA_QOS_TRAFFIC_CTRL_ERROR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_QOS_TRAFFIC_CTRL_ERROR = (WSABASEERR + 1014);
File

nxllJwaWinsock2

Description

problem with some part of the flowspec

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_WAIT_EVENT_0 Constant

nxllJwaWinsock2.WSA_WAIT_EVENT_0 Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_WAIT_EVENT_0 = (WAIT_OBJECT_0);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_WAIT_EVENT_0.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_WAIT_FAILED Constant

nxllJwaWinsock2.WSA_WAIT_FAILED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_WAIT_FAILED = (WAIT_FAILED);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_WAIT_FAILED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_WAIT_IO_COMPLETION Constant

nxllJwaWinsock2.WSA_WAIT_IO_COMPLETION Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_WAIT_IO_COMPLETION = (WAIT_IO_COMPLETION);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_WAIT_IO_COMPLETION.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSA_WAIT_TIMEOUT Constant

nxllJwaWinsock2.WSA_WAIT_TIMEOUT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSA_WAIT_TIMEOUT = (WAIT_TIMEOUT);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSA_WAIT_TIMEOUT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSABASEERR Constant

nxllJwaWinsock2.WSABASEERR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSABASEERR = 10000;
File

nxllJwaWinsock2

Description

All Windows Sockets error constants are biased by WSABASEERR from the "normal"

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSADESCRIPTION_LEN Constant

nxllJwaWinsock2.WSADESCRIPTION_LEN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSADESCRIPTION_LEN = 256;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSADESCRIPTION_LEN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEACCES Constant

nxllJwaWinsock2.WSAEACCES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEACCES = (WSABASEERR+13);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEACCES.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEADDRINUSE Constant

nxllJwaWinsock2.WSAEADDRINUSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEADDRINUSE = (WSABASEERR+48);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEADDRINUSE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEADDRNOTAVAIL Constant

nxllJwaWinsock2.WSAEADDRNOTAVAIL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEADDRNOTAVAIL = (WSABASEERR+49);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEADDRNOTAVAIL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEAFNOSUPPORT Constant

nxllJwaWinsock2.WSAEAFNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEAFNOSUPPORT = (WSABASEERR+47);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEAFNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEALREADY Constant

nxllJwaWinsock2.WSAEALREADY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEALREADY = (WSABASEERR+37);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEALREADY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEBADF Constant

nxllJwaWinsock2.WSAEBADF Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEBADF = (WSABASEERR+9);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEBADF.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAECANCELLED Constant

nxllJwaWinsock2.WSAECANCELLED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAECANCELLED = (WSABASEERR+103);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAECANCELLED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAECONNABORTED Constant

nxllJwaWinsock2.WSAECONNABORTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAECONNABORTED = (WSABASEERR+53);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAECONNABORTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAECONNREFUSED Constant

nxllJwaWinsock2.WSAECONNREFUSED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAECONNREFUSED = (WSABASEERR+61);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAECONNREFUSED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAECONNRESET Constant

nxllJwaWinsock2.WSAECONNRESET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAECONNRESET = (WSABASEERR+54);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAECONNRESET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEDESTADDRREQ Constant

nxllJwaWinsock2.WSAEDESTADDRREQ Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEDESTADDRREQ = (WSABASEERR+39);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEDESTADDRREQ.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEDISCON Constant

nxllJwaWinsock2.WSAEDISCON Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEDISCON = (WSABASEERR+101);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEDISCON.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEDQUOT Constant

nxllJwaWinsock2.WSAEDQUOT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEDQUOT = (WSABASEERR+69);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEDQUOT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEFAULT Constant

nxllJwaWinsock2.WSAEFAULT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEFAULT = (WSABASEERR+14);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEFAULT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEHOSTDOWN Constant

nxllJwaWinsock2.WSAEHOSTDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEHOSTDOWN = (WSABASEERR+64);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEHOSTDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEHOSTUNREACH Constant

nxllJwaWinsock2.WSAEHOSTUNREACH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEHOSTUNREACH = (WSABASEERR+65);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEHOSTUNREACH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEINPROGRESS Constant

nxllJwaWinsock2.WSAEINPROGRESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEINPROGRESS = (WSABASEERR+36);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEINPROGRESS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEINTR Constant

nxllJwaWinsock2.WSAEINTR Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEINTR = (WSABASEERR+4);
File

nxllJwaWinsock2

Description

Windows Sockets definitions of regular Microsoft C error constants

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEINVAL Constant

nxllJwaWinsock2.WSAEINVAL Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEINVAL = (WSABASEERR+22);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEINVAL.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEINVALIDPROCTABLE Constant

nxllJwaWinsock2.WSAEINVALIDPROCTABLE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEINVALIDPROCTABLE = (WSABASEERR+104);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEINVALIDPROCTABLE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEINVALIDPROVIDER Constant

nxllJwaWinsock2.WSAEINVALIDPROVIDER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEINVALIDPROVIDER = (WSABASEERR+105);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEINVALIDPROVIDER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEISCONN Constant

nxllJwaWinsock2.WSAEISCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEISCONN = (WSABASEERR+56);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEISCONN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAELOOP Constant

nxllJwaWinsock2.WSAELOOP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAELOOP = (WSABASEERR+62);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAELOOP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEMFILE Constant

nxllJwaWinsock2.WSAEMFILE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEMFILE = (WSABASEERR+24);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEMFILE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEMSGSIZE Constant

nxllJwaWinsock2.WSAEMSGSIZE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEMSGSIZE = (WSABASEERR+40);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEMSGSIZE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENAMETOOLONG Constant

nxllJwaWinsock2.WSAENAMETOOLONG Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENAMETOOLONG = (WSABASEERR+63);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENAMETOOLONG.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENETDOWN Constant

nxllJwaWinsock2.WSAENETDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENETDOWN = (WSABASEERR+50);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENETDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENETRESET Constant

nxllJwaWinsock2.WSAENETRESET Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENETRESET = (WSABASEERR+52);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENETRESET.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENETUNREACH Constant

nxllJwaWinsock2.WSAENETUNREACH Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENETUNREACH = (WSABASEERR+51);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENETUNREACH.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOBUFS Constant

nxllJwaWinsock2.WSAENOBUFS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOBUFS = (WSABASEERR+55);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOBUFS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOMORE Constant

nxllJwaWinsock2.WSAENOMORE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOMORE = (WSABASEERR+102);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOMORE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOPROTOOPT Constant

nxllJwaWinsock2.WSAENOPROTOOPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOPROTOOPT = (WSABASEERR+42);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOPROTOOPT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOTCONN Constant

nxllJwaWinsock2.WSAENOTCONN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOTCONN = (WSABASEERR+57);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOTCONN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOTEMPTY Constant

nxllJwaWinsock2.WSAENOTEMPTY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOTEMPTY = (WSABASEERR+66);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOTEMPTY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAENOTSOCK Constant

nxllJwaWinsock2.WSAENOTSOCK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAENOTSOCK = (WSABASEERR+38);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAENOTSOCK.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEOPNOTSUPP Constant

nxllJwaWinsock2.WSAEOPNOTSUPP Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEOPNOTSUPP = (WSABASEERR+45);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEOPNOTSUPP.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEPFNOSUPPORT Constant

nxllJwaWinsock2.WSAEPFNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEPFNOSUPPORT = (WSABASEERR+46);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEPFNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEPROCLIM Constant

nxllJwaWinsock2.WSAEPROCLIM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEPROCLIM = (WSABASEERR+67);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEPROCLIM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEPROTONOSUPPORT Constant

nxllJwaWinsock2.WSAEPROTONOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEPROTONOSUPPORT = (WSABASEERR+43);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEPROTONOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEPROTOTYPE Constant

nxllJwaWinsock2.WSAEPROTOTYPE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEPROTOTYPE = (WSABASEERR+41);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEPROTOTYPE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEPROVIDERFAILEDINIT Constant

nxllJwaWinsock2.WSAEPROVIDERFAILEDINIT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEPROVIDERFAILEDINIT = (WSABASEERR+106);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEPROVIDERFAILEDINIT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEREFUSED Constant

nxllJwaWinsock2.WSAEREFUSED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEREFUSED = (WSABASEERR+112);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEREFUSED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEREMOTE Constant

nxllJwaWinsock2.WSAEREMOTE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEREMOTE = (WSABASEERR+71);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEREMOTE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAESHUTDOWN Constant

nxllJwaWinsock2.WSAESHUTDOWN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAESHUTDOWN = (WSABASEERR+58);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAESHUTDOWN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAESOCKTNOSUPPORT Constant

nxllJwaWinsock2.WSAESOCKTNOSUPPORT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAESOCKTNOSUPPORT = (WSABASEERR+44);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAESOCKTNOSUPPORT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAESTALE Constant

nxllJwaWinsock2.WSAESTALE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAESTALE = (WSABASEERR+70);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAESTALE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAETIMEDOUT Constant

nxllJwaWinsock2.WSAETIMEDOUT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAETIMEDOUT = (WSABASEERR+60);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAETIMEDOUT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAETOOMANYREFS Constant

nxllJwaWinsock2.WSAETOOMANYREFS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAETOOMANYREFS = (WSABASEERR+59);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAETOOMANYREFS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEUSERS Constant

nxllJwaWinsock2.WSAEUSERS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEUSERS = (WSABASEERR+68);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAEUSERS.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAEWOULDBLOCK Constant

nxllJwaWinsock2.WSAEWOULDBLOCK Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAEWOULDBLOCK = (WSABASEERR+35);
File

nxllJwaWinsock2

Description

Windows Sockets definitions of regular Berkeley error constants

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAHOST_NOT_FOUND Constant

nxllJwaWinsock2.WSAHOST_NOT_FOUND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAHOST_NOT_FOUND = (WSABASEERR+1001);
File

nxllJwaWinsock2

Description

Authoritative Answer: Host not found

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSANO_ADDRESS Constant

nxllJwaWinsock2.WSANO_ADDRESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSANO_ADDRESS = WSANO_DATA;
File

nxllJwaWinsock2

Description

no address, look for MX record

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSANO_DATA Constant

nxllJwaWinsock2.WSANO_DATA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSANO_DATA = (WSABASEERR+1004);
File

nxllJwaWinsock2

Description

Valid name, no data record of requested type

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSANO_RECOVERY Constant

nxllJwaWinsock2.WSANO_RECOVERY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSANO_RECOVERY = (WSABASEERR+1003);
File

nxllJwaWinsock2

Description

Non-recoverable errors, FORMERR, REFUSED, NOTIMP

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSANOTINITIALISED Constant

nxllJwaWinsock2.WSANOTINITIALISED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSANOTINITIALISED = (WSABASEERR+93);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSANOTINITIALISED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAPROTOCOL_LEN Constant

nxllJwaWinsock2.WSAPROTOCOL_LEN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAPROTOCOL_LEN = 255;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAPROTOCOL_LEN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSASERVICE_NOT_FOUND Constant

nxllJwaWinsock2.WSASERVICE_NOT_FOUND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSASERVICE_NOT_FOUND = (WSABASEERR+108);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSASERVICE_NOT_FOUND.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSASYS_STATUS_LEN Constant

nxllJwaWinsock2.WSASYS_STATUS_LEN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSASYS_STATUS_LEN = 128;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSASYS_STATUS_LEN.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSASYSCALLFAILURE Constant

nxllJwaWinsock2.WSASYSCALLFAILURE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSASYSCALLFAILURE = (WSABASEERR+107);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSASYSCALLFAILURE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSASYSNOTREADY Constant

nxllJwaWinsock2.WSASYSNOTREADY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSASYSNOTREADY = (WSABASEERR+91);
File

nxllJwaWinsock2

Description

Extended Windows Sockets error constant definitions

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSATRY_AGAIN Constant

nxllJwaWinsock2.WSATRY_AGAIN Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSATRY_AGAIN = (WSABASEERR+1002);
File

nxllJwaWinsock2

Description

Non-Authoritative: Host not found, or SERVERFAIL

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSATYPE_NOT_FOUND Constant

nxllJwaWinsock2.WSATYPE_NOT_FOUND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSATYPE_NOT_FOUND = (WSABASEERR+109);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSATYPE_NOT_FOUND.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.WSAVERNOTSUPPORTED Constant

nxllJwaWinsock2.WSAVERNOTSUPPORTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
WSAVERNOTSUPPORTED = (WSABASEERR+92);
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.WSAVERNOTSUPPORTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_CONNECT_DATA Constant

nxllJwaWinsock2.XP1_CONNECT_DATA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_CONNECT_DATA = $00000080;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_CONNECT_DATA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_CONNECTIONLESS Constant

nxllJwaWinsock2.XP1_CONNECTIONLESS Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_CONNECTIONLESS = $00000001;
File

nxllJwaWinsock2

Description

Flag bit definitions for dwServiceFlags1

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_DISCONNECT_DATA Constant

nxllJwaWinsock2.XP1_DISCONNECT_DATA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_DISCONNECT_DATA = $00000100;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_DISCONNECT_DATA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_EXPEDITED_DATA Constant

nxllJwaWinsock2.XP1_EXPEDITED_DATA Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_EXPEDITED_DATA = $00000040;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_EXPEDITED_DATA.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_GRACEFUL_CLOSE Constant

nxllJwaWinsock2.XP1_GRACEFUL_CLOSE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_GRACEFUL_CLOSE = $00000020;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_GRACEFUL_CLOSE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_GUARANTEED_DELIVERY Constant

nxllJwaWinsock2.XP1_GUARANTEED_DELIVERY Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_GUARANTEED_DELIVERY = $00000002;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_GUARANTEED_DELIVERY.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_GUARANTEED_ORDER Constant

nxllJwaWinsock2.XP1_GUARANTEED_ORDER Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_GUARANTEED_ORDER = $00000004;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_GUARANTEED_ORDER.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_IFS_HANDLES Constant

nxllJwaWinsock2.XP1_IFS_HANDLES Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_IFS_HANDLES = $00020000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_IFS_HANDLES.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_INTERRUPT Constant

nxllJwaWinsock2.XP1_INTERRUPT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_INTERRUPT = $00004000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_INTERRUPT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_MESSAGE_ORIENTED Constant

nxllJwaWinsock2.XP1_MESSAGE_ORIENTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_MESSAGE_ORIENTED = $00000008;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_MESSAGE_ORIENTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_MULTIPOINT_CONTROL_PLANE Constant

nxllJwaWinsock2.XP1_MULTIPOINT_CONTROL_PLANE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_MULTIPOINT_CONTROL_PLANE = $00000800;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_MULTIPOINT_CONTROL_PLANE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_MULTIPOINT_DATA_PLANE Constant

nxllJwaWinsock2.XP1_MULTIPOINT_DATA_PLANE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_MULTIPOINT_DATA_PLANE = $00001000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_MULTIPOINT_DATA_PLANE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_PARTIAL_MESSAGE Constant

nxllJwaWinsock2.XP1_PARTIAL_MESSAGE Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_PARTIAL_MESSAGE = $00040000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_PARTIAL_MESSAGE.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_PSEUDO_STREAM Constant

nxllJwaWinsock2.XP1_PSEUDO_STREAM Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_PSEUDO_STREAM = $00000010;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_PSEUDO_STREAM.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_QOS_SUPPORTED Constant

nxllJwaWinsock2.XP1_QOS_SUPPORTED Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_QOS_SUPPORTED = $00002000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_QOS_SUPPORTED.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_SUPPORT_BROADCAST Constant

nxllJwaWinsock2.XP1_SUPPORT_BROADCAST Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_SUPPORT_BROADCAST = $00000200;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_SUPPORT_BROADCAST.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_SUPPORT_MULTIPOINT Constant

nxllJwaWinsock2.XP1_SUPPORT_MULTIPOINT Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_SUPPORT_MULTIPOINT = $00000400;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_SUPPORT_MULTIPOINT.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_UNI_RECV Constant

nxllJwaWinsock2.XP1_UNI_RECV Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_UNI_RECV = $00010000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_UNI_RECV.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWinsock2.XP1_UNI_SEND Constant

nxllJwaWinsock2.XP1_UNI_SEND Constant
nxllJwaWinsock2 Constants Send Feedback
Syntax
Delphi
XP1_UNI_SEND = $00008000;
File

nxllJwaWinsock2

Description

This is constant nxllJwaWinsock2.XP1_UNI_SEND.

Group

Constants

Links
nxllJwaWinsock2, Constants


nxllJwaWS2tcpip Namespace

nxllJwaWS2tcpip Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllJwaWS2tcpip.

Constants
Name | Description
AI_CANONNAME | Return canonical name in first ai_canonname
AI_NUMERICHOST | Nodename must be a numeric address string
AI_PASSIVE | Socket address will be used in bind() call
EAI_AGAIN | Error codes from getaddrinfo()
EAI_BADFLAGS | This is constant nxllJwaWS2tcpip.EAI_BADFLAGS.
EAI_FAIL | This is constant nxllJwaWS2tcpip.EAI_FAIL.
EAI_FAMILY | This is constant nxllJwaWS2tcpip.EAI_FAMILY.
EAI_MEMORY | This is constant nxllJwaWS2tcpip.EAI_MEMORY.
EAI_NODATA | DCR_FIX: EAI_NODATA remove or fix EAI_NODATA was removed from rfc2553bis need to find out from the authors why and determine the error for "no records of this type" temporarily, we'll keep #define to avoid changing code that could change back; use NONAME
EAI_NONAME | define EAI_NODATA WSANO_DATA
EAI_SERVICE | This is constant nxllJwaWS2tcpip.EAI_SERVICE.
EAI_SOCKTYPE | This is constant nxllJwaWS2tcpip.EAI_SOCKTYPE.
GAI_STRERROR_BUFFER_SIZE | WARNING: The gai_strerror inline functions below use static buffers, and hence are not thread-safe. We'll use buffers long enough to hold 1k characters. Any system error messages longer than this will be returned as empty strings. However 1k should work for the error codes used by getaddrinfo().
IFF_BROADCAST | Broadcast is supported
IFF_LOOPBACK | this is loopback interface
IFF_MULTICAST | multicast is supported
IFF_POINTTOPOINT | this is point-to-point interface
IFF_UP | Interface is up
in6addr_any | This is constant nxllJwaWS2tcpip.in6addr_any.
IN6ADDR_ANY_INIT | This is constant nxllJwaWS2tcpip.IN6ADDR_ANY_INIT.
in6addr_loopback | This is constant nxllJwaWS2tcpip.in6addr_loopback.
IN6ADDR_LOOPBACK_INIT | This is constant nxllJwaWS2tcpip.IN6ADDR_LOOPBACK_INIT.
INET_ADDRSTRLEN | Max size of numeric form of IPv4 address
INET6_ADDRSTRLEN | Max size of numeric form of IPv6 address
IP_ADD_MEMBERSHIP | add an IP group membership
IP_ADD_SOURCE_MEMBERSHIP | join IP group/source
IP_BLOCK_SOURCE | block IP group/source
IP_DONTFRAGMENT | don't fragment IP datagrams
IP_DROP_MEMBERSHIP | drop an IP group membership
IP_DROP_SOURCE_MEMBERSHIP | leave IP group/source
IP_HDRINCL | header is included with data
IP_MULTICAST_IF | set/get IP multicast i/f
IP_MULTICAST_LOOP | set/get IP multicast loopback
IP_MULTICAST_TTL | set/get IP multicast ttl
IP_OPTIONS | set/get IP options
IP_PKTINFO | receive packet information for ipv4
IP_TOS | IP type of service and preced
IP_TTL | IP time to live
IP_UNBLOCK_SOURCE | unblock IP group/source
IPV6_ADD_MEMBERSHIP | Add an IP group membership
IPV6_DROP_MEMBERSHIP | Drop an IP group membership
IPV6_HDRINCL | Header is included with data
IPV6_JOIN_GROUP | This is constant nxllJwaWS2tcpip.IPV6_JOIN_GROUP.
IPV6_LEAVE_GROUP | This is constant nxllJwaWS2tcpip.IPV6_LEAVE_GROUP.
IPV6_MULTICAST_HOPS | Set/get IP multicast ttl
IPV6_MULTICAST_IF | Set/get IP multicast interface
IPV6_MULTICAST_LOOP | Set/get IP multicast loopback
IPV6_PKTINFO | Receive packet information for ipv6
IPV6_UNICAST_HOPS | Set/get IP unicast hop limit
MCAST_EXCLUDE | This is constant nxllJwaWS2tcpip.MCAST_EXCLUDE.
MCAST_INCLUDE | This is constant nxllJwaWS2tcpip.MCAST_INCLUDE.
NI_DGRAM | Service is a datagram service
NI_MAXHOST | Max size of a fully-qualified domain name
NI_MAXSERV | Max size of a service name
NI_NAMEREQD | Error if the host's name not in DNS
NI_NOFQDN | Only return nodename portion for local hosts
NI_NUMERICHOST | Return numeric form of the host's address
NI_NUMERICSERV | Return numeric form of the service (port #)
SIO_GET_INTERFACE_LIST | TCP/IP specific Ioctl codes
SIO_GET_INTERFACE_LIST_EX | New IOCTL with address size independent address array
SIO_GET_MULTICAST_FILTER | This is constant nxllJwaWS2tcpip.SIO_GET_MULTICAST_FILTER.
SIO_SET_MULTICAST_FILTER | This is constant nxllJwaWS2tcpip.SIO_SET_MULTICAST_FILTER.
TCP_EXPEDITED_1122 | Option to use with [gs]etsockopt at the IPPROTO_TCP level
UDP_CHECKSUM_COVERAGE | Set/get UDP-Lite checksum coverage
UDP_NOCHECKSUM | Option to use with [gs]etsockopt at the IPPROTO_UDP level
ws2tcpip | This is constant nxllJwaWS2tcpip.ws2tcpip.
Functions
Name | Description
freeaddrinfo | This is function nxllJwaWS2tcpip.freeaddrinfo.
gai_strerror | This is function nxllJwaWS2tcpip.gai_strerror.
gai_strerrorA | This is function nxllJwaWS2tcpip.gai_strerrorA.
gai_strerrorW | This is function nxllJwaWS2tcpip.gai_strerrorW.
getaddrinfo | This is function nxllJwaWS2tcpip.getaddrinfo.
getnameinfo | This is function nxllJwaWS2tcpip.getnameinfo.
IN6_ADDR_EQUAL | This is function nxllJwaWS2tcpip.IN6_ADDR_EQUAL.
IN6_IS_ADDR_LINKLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LINKLOCAL.
IN6_IS_ADDR_LOOPBACK | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LOOPBACK.
IN6_IS_ADDR_MC_GLOBAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_GLOBAL.
IN6_IS_ADDR_MC_LINKLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_LINKLOCAL.
IN6_IS_ADDR_MC_NODELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_NODELOCAL.
IN6_IS_ADDR_MC_ORGLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_ORGLOCAL.
IN6_IS_ADDR_MC_SITELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_SITELOCAL.
IN6_IS_ADDR_MULTICAST | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MULTICAST.
IN6_IS_ADDR_SITELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_SITELOCAL.
IN6_IS_ADDR_UNSPECIFIED | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_UNSPECIFIED.
IN6_IS_ADDR_V4COMPAT | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4COMPAT.
IN6_IS_ADDR_V4MAPPED | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4MAPPED.
IN6ADDR_ISANY | This is function nxllJwaWS2tcpip.IN6ADDR_ISANY.
IN6ADDR_ISLOOPBACK | This is function nxllJwaWS2tcpip.IN6ADDR_ISLOOPBACK.
IN6ADDR_SETANY | This is function nxllJwaWS2tcpip.IN6ADDR_SETANY.
IN6ADDR_SETLOOPBACK | This is function nxllJwaWS2tcpip.IN6ADDR_SETLOOPBACK.
IP_MSFILTER_SIZE | This is function nxllJwaWS2tcpip.IP_MSFILTER_SIZE.
SS_PORT | Macro that works for both IPv4 and IPv6
Structs, Records, Enums
Name | Description
_INTERFACE_INFO | Structure to keep interface specific information
_INTERFACE_INFO_EX | New structure that does not have dependency on the address size
addrinfo | This is record nxllJwaWS2tcpip.addrinfo.
in_addr6 | This is record nxllJwaWS2tcpip.in_addr6.
in_pktinfo | structure for IP_PKTINFO option
in6_addr | IPv6 definitions
in6_pktinfo | structure for IPV6_PKTINFO option
ip_mreq | Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP
ip_mreq_source | Argument structure for IP_ADD_SOURCE_MEMBERSHIP, IP_DROP_SOURCE_MEMBERSHIP, IP_BLOCK_SOURCE, and IP_UNBLOCK_SOURCE
ip_msfilter | Argument structure for SIO_{GET,SET}_MULTICAST_FILTER
ipv6_mreq | Argument structure for IPV6_JOIN_GROUP and IPV6_LEAVE_GROUP
sockaddr_gen | This is record nxllJwaWS2tcpip.sockaddr_gen.
SOCKADDR_IN6 | IPv6 socket address structure, RFC 2553
sockaddr_in6_old | Old IPv6 socket address structure (retained for sockaddr_gen definition below)
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
INTERFACE_INFO | This is type nxllJwaWS2tcpip.INTERFACE_INFO.
INTERFACE_INFO_EX | This is type nxllJwaWS2tcpip.INTERFACE_INFO_EX.
LPADDRINFO | Structure used in getaddrinfo() call
LPINTERFACE_INFO | This is type nxllJwaWS2tcpip.LPINTERFACE_INFO.
LPINTERFACE_INFO_EX | This is type nxllJwaWS2tcpip.LPINTERFACE_INFO_EX.
LPSOCKADDR_IN6 | This is type nxllJwaWS2tcpip.LPSOCKADDR_IN6.
PAddrInfo | This is type nxllJwaWS2tcpip.PAddrInfo.
PIn6Addr | This is type nxllJwaWS2tcpip.PIn6Addr.
PIn6PktInfo | This is type nxllJwaWS2tcpip.PIn6PktInfo.
PInAddr6 | This is type nxllJwaWS2tcpip.PInAddr6.
PInPktInfo | This is type nxllJwaWS2tcpip.PInPktInfo.
PInterfaceInfo | This is type nxllJwaWS2tcpip.PInterfaceInfo.
PInterfaceInfoEx | This is type nxllJwaWS2tcpip.PInterfaceInfoEx.
PIPMReq | This is type nxllJwaWS2tcpip.PIPMReq.
PIpMreqSource | This is type nxllJwaWS2tcpip.PIpMreqSource.
PIpMsFilter | This is type nxllJwaWS2tcpip.PIpMsFilter.
PIpV6MReq | This is type nxllJwaWS2tcpip.PIpV6MReq.
PSOCKADDR_IN6 | This is type nxllJwaWS2tcpip.PSOCKADDR_IN6.
PSockAddrGen | This is type nxllJwaWS2tcpip.PSockAddrGen.
PSockAddrIn6 | This is type nxllJwaWS2tcpip.PSockAddrIn6.
PSockAddrIn6Old | This is type nxllJwaWS2tcpip.PSockAddrIn6Old.
socklen_t | This is type nxllJwaWS2tcpip.socklen_t.
TAddrInfo | This is type nxllJwaWS2tcpip.TAddrInfo.
TIn6Addr | This is type nxllJwaWS2tcpip.TIn6Addr.
TIn6PktInfo | This is type nxllJwaWS2tcpip.TIn6PktInfo.
TInAddr6 | This is type nxllJwaWS2tcpip.TInAddr6.
TInPktInfo | This is type nxllJwaWS2tcpip.TInPktInfo.
TInterfaceInfo | This is type nxllJwaWS2tcpip.TInterfaceInfo.
TInterfaceInfoEx | This is type nxllJwaWS2tcpip.TInterfaceInfoEx.
TIPMReq | This is type nxllJwaWS2tcpip.TIPMReq.
TIpMreqSource | This is type nxllJwaWS2tcpip.TIpMreqSource.
TIpMsFilter | This is type nxllJwaWS2tcpip.TIpMsFilter.
TIpV6MReq | This is type nxllJwaWS2tcpip.TIpV6MReq.
TSockAddrGen | This is type nxllJwaWS2tcpip.TSockAddrGen.
TSockAddrIn6 | This is type nxllJwaWS2tcpip.TSockAddrIn6.
TSockAddrIn6Old | This is type nxllJwaWS2tcpip.TSockAddrIn6Old.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Functions

Functions
Functions nxllJwaWS2tcpip Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
freeaddrinfo | This is function nxllJwaWS2tcpip.freeaddrinfo.
gai_strerror | This is function nxllJwaWS2tcpip.gai_strerror.
gai_strerrorA | This is function nxllJwaWS2tcpip.gai_strerrorA.
gai_strerrorW | This is function nxllJwaWS2tcpip.gai_strerrorW.
getaddrinfo | This is function nxllJwaWS2tcpip.getaddrinfo.
getnameinfo | This is function nxllJwaWS2tcpip.getnameinfo.
IN6_ADDR_EQUAL | This is function nxllJwaWS2tcpip.IN6_ADDR_EQUAL.
IN6_IS_ADDR_LINKLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LINKLOCAL.
IN6_IS_ADDR_LOOPBACK | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LOOPBACK.
IN6_IS_ADDR_MC_GLOBAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_GLOBAL.
IN6_IS_ADDR_MC_LINKLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_LINKLOCAL.
IN6_IS_ADDR_MC_NODELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_NODELOCAL.
IN6_IS_ADDR_MC_ORGLOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_ORGLOCAL.
IN6_IS_ADDR_MC_SITELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_SITELOCAL.
IN6_IS_ADDR_MULTICAST | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MULTICAST.
IN6_IS_ADDR_SITELOCAL | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_SITELOCAL.
IN6_IS_ADDR_UNSPECIFIED | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_UNSPECIFIED.
IN6_IS_ADDR_V4COMPAT | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4COMPAT.
IN6_IS_ADDR_V4MAPPED | This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4MAPPED.
IN6ADDR_ISANY | This is function nxllJwaWS2tcpip.IN6ADDR_ISANY.
IN6ADDR_ISLOOPBACK | This is function nxllJwaWS2tcpip.IN6ADDR_ISLOOPBACK.
IN6ADDR_SETANY | This is function nxllJwaWS2tcpip.IN6ADDR_SETANY.
IN6ADDR_SETLOOPBACK | This is function nxllJwaWS2tcpip.IN6ADDR_SETLOOPBACK.
IP_MSFILTER_SIZE | This is function nxllJwaWS2tcpip.IP_MSFILTER_SIZE.
SS_PORT | Macro that works for both IPv4 and IPv6
Namespace

nxllJwaWS2tcpip Namespace

Links
Functions, nxllJwaWS2tcpip Namespace, Legend


nxllJwaWS2tcpip.freeaddrinfo Function

nxllJwaWS2tcpip.freeaddrinfo Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
procedure freeaddrinfo(ai: PAddrInfo); stdcall;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.freeaddrinfo.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.gai_strerror Function

nxllJwaWS2tcpip.gai_strerror Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function gai_strerror(ecode: Integer): PAnsiChar;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.gai_strerror.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.gai_strerrorA Function

nxllJwaWS2tcpip.gai_strerrorA Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function gai_strerrorA(ecode: Integer): PAnsiChar;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.gai_strerrorA.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.gai_strerrorW Function

nxllJwaWS2tcpip.gai_strerrorW Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function gai_strerrorW(ecode: Integer): PWideChar;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.gai_strerrorW.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.getaddrinfo Function

nxllJwaWS2tcpip.getaddrinfo Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function getaddrinfo(nodename: PAnsiChar; servname: PAnsiChar; hints: PAddrInfo; var res: PAddrInfo): Integer; stdcall;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.getaddrinfo.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.getnameinfo Function

nxllJwaWS2tcpip.getnameinfo Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function getnameinfo(sa: PSockAddr; salen: socklen_t; host: PAnsiChar; hostlen: DWORD; serv: PAnsiChar; servlen: DWORD; flags: Integer): Integer; stdcall;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.getnameinfo.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_ADDR_EQUAL Function

nxllJwaWS2tcpip.IN6_ADDR_EQUAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_ADDR_EQUAL(const a: in6_addr; const b: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_ADDR_EQUAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_LINKLOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_LINKLOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_LINKLOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LINKLOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_LOOPBACK Function

nxllJwaWS2tcpip.IN6_IS_ADDR_LOOPBACK Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_LOOPBACK(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_LOOPBACK.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MC_GLOBAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MC_GLOBAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MC_GLOBAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_GLOBAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MC_LINKLOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MC_LINKLOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MC_LINKLOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_LINKLOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MC_NODELOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MC_NODELOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MC_NODELOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_NODELOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MC_ORGLOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MC_ORGLOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MC_ORGLOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_ORGLOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MC_SITELOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MC_SITELOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MC_SITELOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MC_SITELOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_MULTICAST Function

nxllJwaWS2tcpip.IN6_IS_ADDR_MULTICAST Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_MULTICAST(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_MULTICAST.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_SITELOCAL Function

nxllJwaWS2tcpip.IN6_IS_ADDR_SITELOCAL Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_SITELOCAL(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_SITELOCAL.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_UNSPECIFIED Function

nxllJwaWS2tcpip.IN6_IS_ADDR_UNSPECIFIED Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_UNSPECIFIED(const a: in6_addr): boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_UNSPECIFIED.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_V4COMPAT Function

nxllJwaWS2tcpip.IN6_IS_ADDR_V4COMPAT Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_V4COMPAT(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4COMPAT.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6_IS_ADDR_V4MAPPED Function

nxllJwaWS2tcpip.IN6_IS_ADDR_V4MAPPED Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6_IS_ADDR_V4MAPPED(const a: in6_addr): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6_IS_ADDR_V4MAPPED.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6ADDR_ISANY Function

nxllJwaWS2tcpip.IN6ADDR_ISANY Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6ADDR_ISANY(const x: TSockAddrIn6): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6ADDR_ISANY.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6ADDR_ISLOOPBACK Function

nxllJwaWS2tcpip.IN6ADDR_ISLOOPBACK Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IN6ADDR_ISLOOPBACK(const x: TSockAddrIn6): Boolean;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6ADDR_ISLOOPBACK.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6ADDR_SETANY Function

nxllJwaWS2tcpip.IN6ADDR_SETANY Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
procedure IN6ADDR_SETANY(var x: TSockAddrIn6);
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6ADDR_SETANY.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IN6ADDR_SETLOOPBACK Function

nxllJwaWS2tcpip.IN6ADDR_SETLOOPBACK Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
procedure IN6ADDR_SETLOOPBACK(var x: TSockAddrIn6);
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IN6ADDR_SETLOOPBACK.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.IP_MSFILTER_SIZE Function

nxllJwaWS2tcpip.IP_MSFILTER_SIZE Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function IP_MSFILTER_SIZE(numsrc: Integer): Integer;
File

nxllJwaWS2tcpip

Description

This is function nxllJwaWS2tcpip.IP_MSFILTER_SIZE.

Group

Functions

Links
nxllJwaWS2tcpip, Functions


nxllJwaWS2tcpip.SS_PORT Function

nxllJwaWS2tcpip.SS_PORT Function
nxllJwaWS2tcpip Functions Send Feedback
Syntax
Delphi
function SS_PORT(ssp: Pointer): u_short;
File

nxllJwaWS2tcpip

Description

Macro that works for both IPv4 and IPv6

Group

Functions

Links
nxllJwaWS2tcpip, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllJwaWS2tcpip Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllJwaWS2tcpip Namespace

Records
Name | Description
_INTERFACE_INFO | Structure to keep interface specific information
_INTERFACE_INFO_EX | New structure that does not have dependency on the address size
addrinfo | This is record nxllJwaWS2tcpip.addrinfo.
in_addr6 | This is record nxllJwaWS2tcpip.in_addr6.
in_pktinfo | structure for IP_PKTINFO option
in6_addr | IPv6 definitions
in6_pktinfo | structure for IPV6_PKTINFO option
ip_mreq | Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP
ip_mreq_source | Argument structure for IP_ADD_SOURCE_MEMBERSHIP, IP_DROP_SOURCE_MEMBERSHIP, IP_BLOCK_SOURCE, and IP_UNBLOCK_SOURCE
ip_msfilter | Argument structure for SIO_{GET,SET}_MULTICAST_FILTER
ipv6_mreq | Argument structure for IPV6_JOIN_GROUP and IPV6_LEAVE_GROUP
sockaddr_gen | This is record nxllJwaWS2tcpip.sockaddr_gen.
SOCKADDR_IN6 | IPv6 socket address structure, RFC 2553
sockaddr_in6_old | Old IPv6 socket address structure (retained for sockaddr_gen definition below)
Links
nxllJwaWS2tcpip Namespace, Legend, Records


nxllJwaWS2tcpip._INTERFACE_INFO Record

nxllJwaWS2tcpip._INTERFACE_INFO Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
_INTERFACE_INFO = record
  iiFlags: u_long;
  iiAddress: sockaddr_gen;
  iiBroadcastAddress: sockaddr_gen;
  iiNetmask: sockaddr_gen;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
iiFlags: u_long; | Interface flags
iiAddress: sockaddr_gen; | Interface address
iiBroadcastAddress: sockaddr_gen; | Broadcast address
iiNetmask: sockaddr_gen; | Network mask
Description

Structure to keep interface specific information

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip._INTERFACE_INFO_EX Record

nxllJwaWS2tcpip._INTERFACE_INFO_EX Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
_INTERFACE_INFO_EX = record
  iiFlags: u_long;
  iiAddress: SOCKET_ADDRESS;
  iiBroadcastAddress: SOCKET_ADDRESS;
  iiNetmask: SOCKET_ADDRESS;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
iiFlags: u_long; | Interface flags
iiAddress: SOCKET_ADDRESS; | Interface address
iiBroadcastAddress: SOCKET_ADDRESS; | Broadcast address
iiNetmask: SOCKET_ADDRESS; | Network mask
Description

New structure that does not have dependency on the address size

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.addrinfo Record

nxllJwaWS2tcpip.addrinfo Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
addrinfo = record
  ai_flags: Integer;
  ai_family: Integer;
  ai_socktype: Integer;
  ai_protocol: Integer;
  ai_addrlen: Cardinal;
  ai_canonname: PAnsiChar;
  ai_addr: PSockAddr;
  ai_next: LPADDRINFO;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
ai_flags: Integer; | AI_PASSIVE, AI_CANONNAME, AI_NUMERICHOST
ai_family: Integer; | PF_xxx
ai_socktype: Integer; | SOCK_xxx
ai_protocol: Integer; | 0 or IPPROTO_xxx for IPv4 and IPv6
ai_addrlen: Cardinal; | Length of ai_addr
ai_canonname: PAnsiChar; | Canonical name for nodename
ai_addr: PSockAddr; | Binary address
ai_next: LPADDRINFO; | Next structure in linked list
Description

This is record nxllJwaWS2tcpip.addrinfo.

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.in_addr6 Record

nxllJwaWS2tcpip.in_addr6 Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
in_addr6 = record
  s6_addr: array [0..15] of u_char;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
s6_addr: array [0..15] of u_char; | IPv6 address
Description

This is record nxllJwaWS2tcpip.in_addr6.

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.in_pktinfo Record

nxllJwaWS2tcpip.in_pktinfo Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
in_pktinfo = record
  ipi_addr: IN_ADDR;
  ipi_ifindex: UINT;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
ipi_addr: IN_ADDR; | destination IPv4 address
ipi_ifindex: UINT; | received interface index
Description

structure for IP_PKTINFO option

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.in6_addr Record

nxllJwaWS2tcpip.in6_addr Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
in6_addr = record
  case Integer of
    0: (Byte: array [0..15] of u_char);
        Word: array[0..7] of u_short);
        s6_bytes: array [0..15] of u_char);
        s6_addr: array [0..15] of u_char);
        s6_words: array[0..7] of u_short););
end;
File

nxllJwaWS2tcpip

Description

IPv6 definitions

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.in6_pktinfo Record

nxllJwaWS2tcpip.in6_pktinfo Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
in6_pktinfo = record
  ipi6_addr: IN6_ADDR;
  ipi6_ifindex: UINT;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
ipi6_addr: IN6_ADDR; | destination IPv6 address
ipi6_ifindex: UINT; | received interface index
Description

structure for IPV6_PKTINFO option

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.ip_mreq Record

nxllJwaWS2tcpip.ip_mreq Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
ip_mreq = record
  imr_multiaddr: in_addr;
  imr_interface: in_addr;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
imr_multiaddr: in_addr; | IP multicast address of group
imr_interface: in_addr; | local IP address of interface
Description

Argument structure for IP_ADD_MEMBERSHIP and IP_DROP_MEMBERSHIP

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.ip_mreq_source Record

nxllJwaWS2tcpip.ip_mreq_source Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
ip_mreq_source = record
  imr_multiaddr: in_addr;
  imr_sourceaddr: in_addr;
  imr_interface: in_addr;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
imr_multiaddr: in_addr; | IP multicast address of group
imr_sourceaddr: in_addr; | IP address of source
imr_interface: in_addr; | local IP address of interface
Description

Argument structure for IP_ADD_SOURCE_MEMBERSHIP, IP_DROP_SOURCE_MEMBERSHIP, IP_BLOCK_SOURCE, and IP_UNBLOCK_SOURCE

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.ip_msfilter Record

nxllJwaWS2tcpip.ip_msfilter Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
ip_msfilter = record
  imsf_multiaddr: in_addr;
  imsf_interface: in_addr;
  imsf_fmode: u_long;
  imsf_numsrc: u_long;
  imsf_slist: array [0..0] of in_addr;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
imsf_multiaddr: in_addr; | IP multicast address of group
imsf_interface: in_addr; | local IP address of interface
imsf_fmode: u_long; | filter mode - INCLUDE or EXCLUDE
imsf_numsrc: u_long; | number of sources in src_list
Description

Argument structure for SIO_{GET,SET}_MULTICAST_FILTER

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.ipv6_mreq Record

nxllJwaWS2tcpip.ipv6_mreq Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
ipv6_mreq = record
  ipv6mr_multiaddr: in6_addr;
  ipv6mr_interface: Cardinal;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
ipv6mr_multiaddr: in6_addr; | IPv6 multicast address
ipv6mr_interface: Cardinal; | Interface index
Description

Argument structure for IPV6_JOIN_GROUP and IPV6_LEAVE_GROUP

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.sockaddr_gen Record

nxllJwaWS2tcpip.sockaddr_gen Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
sockaddr_gen = record
  case Integer of
    0: (Address: sockaddr;);
    1: (AddressIn: sockaddr_in;);
    2: (AddressIn6: sockaddr_in6_old;);
end;
File

nxllJwaWS2tcpip

Description

This is record nxllJwaWS2tcpip.sockaddr_gen.

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.SOCKADDR_IN6 Record

nxllJwaWS2tcpip.SOCKADDR_IN6 Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
SOCKADDR_IN6 = record
  sin6_family: short;
  sin6_port: u_short;
  sin6_flowinfo: u_long;
  sin6_addr: in6_addr;
  sin6_scope_id: u_long;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
sin6_family: short; | AF_INET6
sin6_port: u_short; | Transport level port number
sin6_flowinfo: u_long; | IPv6 flow information
sin6_addr: in6_addr; | IPv6 address
sin6_scope_id: u_long; | set of interfaces for a scope
Description

IPv6 socket address structure, RFC 2553

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


nxllJwaWS2tcpip.sockaddr_in6_old Record

nxllJwaWS2tcpip.sockaddr_in6_old Record
nxllJwaWS2tcpip Structs, Records, Enums Send Feedback
Syntax
Delphi
sockaddr_in6_old = record
  sin6_family: short;
  sin6_port: u_short;
  sin6_flowinfo: u_long;
  sin6_addr: in6_addr;
end;
File

nxllJwaWS2tcpip

Members
Members | Description
sin6_family: short; | AF_INET6
sin6_port: u_short; | Transport level port number
sin6_flowinfo: u_long; | IPv6 flow information
sin6_addr: in6_addr; | IPv6 address
Description

Old IPv6 socket address structure (retained for sockaddr_gen definition below)

Group

Structs, Records, Enums

Links
nxllJwaWS2tcpip, Structs, Records, Enums


Types

Types
nxllJwaWS2tcpip Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaWS2tcpip Namespace

Types
Name | Description
INTERFACE_INFO | This is type nxllJwaWS2tcpip.INTERFACE_INFO.
INTERFACE_INFO_EX | This is type nxllJwaWS2tcpip.INTERFACE_INFO_EX.
LPADDRINFO | Structure used in getaddrinfo() call
LPINTERFACE_INFO | This is type nxllJwaWS2tcpip.LPINTERFACE_INFO.
LPINTERFACE_INFO_EX | This is type nxllJwaWS2tcpip.LPINTERFACE_INFO_EX.
LPSOCKADDR_IN6 | This is type nxllJwaWS2tcpip.LPSOCKADDR_IN6.
PAddrInfo | This is type nxllJwaWS2tcpip.PAddrInfo.
PIn6Addr | This is type nxllJwaWS2tcpip.PIn6Addr.
PIn6PktInfo | This is type nxllJwaWS2tcpip.PIn6PktInfo.
PInAddr6 | This is type nxllJwaWS2tcpip.PInAddr6.
PInPktInfo | This is type nxllJwaWS2tcpip.PInPktInfo.
PInterfaceInfo | This is type nxllJwaWS2tcpip.PInterfaceInfo.
PInterfaceInfoEx | This is type nxllJwaWS2tcpip.PInterfaceInfoEx.
PIPMReq | This is type nxllJwaWS2tcpip.PIPMReq.
PIpMreqSource | This is type nxllJwaWS2tcpip.PIpMreqSource.
PIpMsFilter | This is type nxllJwaWS2tcpip.PIpMsFilter.
PIpV6MReq | This is type nxllJwaWS2tcpip.PIpV6MReq.
PSOCKADDR_IN6 | This is type nxllJwaWS2tcpip.PSOCKADDR_IN6.
PSockAddrGen | This is type nxllJwaWS2tcpip.PSockAddrGen.
PSockAddrIn6 | This is type nxllJwaWS2tcpip.PSockAddrIn6.
PSockAddrIn6Old | This is type nxllJwaWS2tcpip.PSockAddrIn6Old.
socklen_t | This is type nxllJwaWS2tcpip.socklen_t.
TAddrInfo | This is type nxllJwaWS2tcpip.TAddrInfo.
TIn6Addr | This is type nxllJwaWS2tcpip.TIn6Addr.
TIn6PktInfo | This is type nxllJwaWS2tcpip.TIn6PktInfo.
TInAddr6 | This is type nxllJwaWS2tcpip.TInAddr6.
TInPktInfo | This is type nxllJwaWS2tcpip.TInPktInfo.
TInterfaceInfo | This is type nxllJwaWS2tcpip.TInterfaceInfo.
TInterfaceInfoEx | This is type nxllJwaWS2tcpip.TInterfaceInfoEx.
TIPMReq | This is type nxllJwaWS2tcpip.TIPMReq.
TIpMreqSource | This is type nxllJwaWS2tcpip.TIpMreqSource.
TIpMsFilter | This is type nxllJwaWS2tcpip.TIpMsFilter.
TIpV6MReq | This is type nxllJwaWS2tcpip.TIpV6MReq.
TSockAddrGen | This is type nxllJwaWS2tcpip.TSockAddrGen.
TSockAddrIn6 | This is type nxllJwaWS2tcpip.TSockAddrIn6.
TSockAddrIn6Old | This is type nxllJwaWS2tcpip.TSockAddrIn6Old.
Links
nxllJwaWS2tcpip Namespace, Types


nxllJwaWS2tcpip.INTERFACE_INFO Type

nxllJwaWS2tcpip.INTERFACE_INFO Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
INTERFACE_INFO = _INTERFACE_INFO;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.INTERFACE_INFO.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.INTERFACE_INFO_EX Type

nxllJwaWS2tcpip.INTERFACE_INFO_EX Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
INTERFACE_INFO_EX = _INTERFACE_INFO_EX;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.INTERFACE_INFO_EX.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.LPADDRINFO Type

nxllJwaWS2tcpip.LPADDRINFO Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
LPADDRINFO = ^addrinfo;
File

nxllJwaWS2tcpip

Description

Structure used in getaddrinfo() call

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.LPINTERFACE_INFO Type

nxllJwaWS2tcpip.LPINTERFACE_INFO Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
LPINTERFACE_INFO = ^INTERFACE_INFO;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.LPINTERFACE_INFO.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.LPINTERFACE_INFO_EX Type

nxllJwaWS2tcpip.LPINTERFACE_INFO_EX Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
LPINTERFACE_INFO_EX = ^INTERFACE_INFO_EX;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.LPINTERFACE_INFO_EX.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.LPSOCKADDR_IN6 Type

nxllJwaWS2tcpip.LPSOCKADDR_IN6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
LPSOCKADDR_IN6 = ^SOCKADDR_IN6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.LPSOCKADDR_IN6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PAddrInfo Type

nxllJwaWS2tcpip.PAddrInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PAddrInfo = LPADDRINFO;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PAddrInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIn6Addr Type

nxllJwaWS2tcpip.PIn6Addr Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIn6Addr = ^in6_addr;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIn6Addr.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIn6PktInfo Type

nxllJwaWS2tcpip.PIn6PktInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIn6PktInfo = ^in6_pktinfo;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIn6PktInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PInAddr6 Type

nxllJwaWS2tcpip.PInAddr6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PInAddr6 = ^in_addr6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PInAddr6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PInPktInfo Type

nxllJwaWS2tcpip.PInPktInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PInPktInfo = ^in_pktinfo;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PInPktInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PInterfaceInfo Type

nxllJwaWS2tcpip.PInterfaceInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PInterfaceInfo = LPINTERFACE_INFO;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PInterfaceInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PInterfaceInfoEx Type

nxllJwaWS2tcpip.PInterfaceInfoEx Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PInterfaceInfoEx = LPINTERFACE_INFO_EX;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PInterfaceInfoEx.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIPMReq Type

nxllJwaWS2tcpip.PIPMReq Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIPMReq = ^ip_mreq;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIPMReq.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIpMreqSource Type

nxllJwaWS2tcpip.PIpMreqSource Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIpMreqSource = ^ip_mreq_source;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIpMreqSource.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIpMsFilter Type

nxllJwaWS2tcpip.PIpMsFilter Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIpMsFilter = ^ip_msfilter;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIpMsFilter.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PIpV6MReq Type

nxllJwaWS2tcpip.PIpV6MReq Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PIpV6MReq = ^ipv6_mreq;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PIpV6MReq.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PSOCKADDR_IN6 Type

nxllJwaWS2tcpip.PSOCKADDR_IN6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PSOCKADDR_IN6 = ^SOCKADDR_IN6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PSOCKADDR_IN6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PSockAddrGen Type

nxllJwaWS2tcpip.PSockAddrGen Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PSockAddrGen = ^sockaddr_gen;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PSockAddrGen.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PSockAddrIn6 Type

nxllJwaWS2tcpip.PSockAddrIn6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PSockAddrIn6 = LPSOCKADDR_IN6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PSockAddrIn6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.PSockAddrIn6Old Type

nxllJwaWS2tcpip.PSockAddrIn6Old Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
PSockAddrIn6Old = ^sockaddr_in6_old;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.PSockAddrIn6Old.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.socklen_t Type

nxllJwaWS2tcpip.socklen_t Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
socklen_t = Integer;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.socklen_t.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TAddrInfo Type

nxllJwaWS2tcpip.TAddrInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TAddrInfo = addrinfo;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TAddrInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIn6Addr Type

nxllJwaWS2tcpip.TIn6Addr Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIn6Addr = in6_addr;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIn6Addr.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIn6PktInfo Type

nxllJwaWS2tcpip.TIn6PktInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIn6PktInfo = in6_pktinfo;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIn6PktInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TInAddr6 Type

nxllJwaWS2tcpip.TInAddr6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TInAddr6 = in_addr6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TInAddr6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TInPktInfo Type

nxllJwaWS2tcpip.TInPktInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TInPktInfo = in_pktinfo;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TInPktInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TInterfaceInfo Type

nxllJwaWS2tcpip.TInterfaceInfo Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TInterfaceInfo = INTERFACE_INFO;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TInterfaceInfo.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TInterfaceInfoEx Type

nxllJwaWS2tcpip.TInterfaceInfoEx Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TInterfaceInfoEx = INTERFACE_INFO_EX;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TInterfaceInfoEx.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIPMReq Type

nxllJwaWS2tcpip.TIPMReq Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIPMReq = ip_mreq;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIPMReq.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIpMreqSource Type

nxllJwaWS2tcpip.TIpMreqSource Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIpMreqSource = ip_mreq_source;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIpMreqSource.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIpMsFilter Type

nxllJwaWS2tcpip.TIpMsFilter Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIpMsFilter = ip_msfilter;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIpMsFilter.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TIpV6MReq Type

nxllJwaWS2tcpip.TIpV6MReq Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TIpV6MReq = ipv6_mreq;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TIpV6MReq.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TSockAddrGen Type

nxllJwaWS2tcpip.TSockAddrGen Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TSockAddrGen = sockaddr_gen;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TSockAddrGen.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TSockAddrIn6 Type

nxllJwaWS2tcpip.TSockAddrIn6 Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TSockAddrIn6 = SOCKADDR_IN6;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TSockAddrIn6.

Group

Types

Links
nxllJwaWS2tcpip, Types


nxllJwaWS2tcpip.TSockAddrIn6Old Type

nxllJwaWS2tcpip.TSockAddrIn6Old Type
nxllJwaWS2tcpip Types Send Feedback
Syntax
Delphi
TSockAddrIn6Old = sockaddr_in6_old;
File

nxllJwaWS2tcpip

Description

This is type nxllJwaWS2tcpip.TSockAddrIn6Old.

Group

Types

Links
nxllJwaWS2tcpip, Types


Constants

Constants
Constants nxllJwaWS2tcpip Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
AI_CANONNAME | Return canonical name in first ai_canonname
AI_NUMERICHOST | Nodename must be a numeric address string
AI_PASSIVE | Socket address will be used in bind() call
EAI_AGAIN | Error codes from getaddrinfo()
EAI_BADFLAGS | This is constant nxllJwaWS2tcpip.EAI_BADFLAGS.
EAI_FAIL | This is constant nxllJwaWS2tcpip.EAI_FAIL.
EAI_FAMILY | This is constant nxllJwaWS2tcpip.EAI_FAMILY.
EAI_MEMORY | This is constant nxllJwaWS2tcpip.EAI_MEMORY.
EAI_NODATA | DCR_FIX: EAI_NODATA remove or fix EAI_NODATA was removed from rfc2553bis need to find out from the authors why and determine the error for "no records of this type" temporarily, we'll keep #define to avoid changing code that could change back; use NONAME
EAI_NONAME | define EAI_NODATA WSANO_DATA
EAI_SERVICE | This is constant nxllJwaWS2tcpip.EAI_SERVICE.
EAI_SOCKTYPE | This is constant nxllJwaWS2tcpip.EAI_SOCKTYPE.
GAI_STRERROR_BUFFER_SIZE | WARNING: The gai_strerror inline functions below use static buffers, and hence are not thread-safe. We'll use buffers long enough to hold 1k characters. Any system error messages longer than this will be returned as empty strings. However 1k should work for the error codes used by getaddrinfo().
IFF_BROADCAST | Broadcast is supported
IFF_LOOPBACK | this is loopback interface
IFF_MULTICAST | multicast is supported
IFF_POINTTOPOINT | this is point-to-point interface
IFF_UP | Interface is up
in6addr_any | This is constant nxllJwaWS2tcpip.in6addr_any.
IN6ADDR_ANY_INIT | This is constant nxllJwaWS2tcpip.IN6ADDR_ANY_INIT.
in6addr_loopback | This is constant nxllJwaWS2tcpip.in6addr_loopback.
IN6ADDR_LOOPBACK_INIT | This is constant nxllJwaWS2tcpip.IN6ADDR_LOOPBACK_INIT.
INET_ADDRSTRLEN | Max size of numeric form of IPv4 address
INET6_ADDRSTRLEN | Max size of numeric form of IPv6 address
IP_ADD_MEMBERSHIP | add an IP group membership
IP_ADD_SOURCE_MEMBERSHIP | join IP group/source
IP_BLOCK_SOURCE | block IP group/source
IP_DONTFRAGMENT | don't fragment IP datagrams
IP_DROP_MEMBERSHIP | drop an IP group membership
IP_DROP_SOURCE_MEMBERSHIP | leave IP group/source
IP_HDRINCL | header is included with data
IP_MULTICAST_IF | set/get IP multicast i/f
IP_MULTICAST_LOOP | set/get IP multicast loopback
IP_MULTICAST_TTL | set/get IP multicast ttl
IP_OPTIONS | set/get IP options
IP_PKTINFO | receive packet information for ipv4
IP_TOS | IP type of service and preced
IP_TTL | IP time to live
IP_UNBLOCK_SOURCE | unblock IP group/source
IPV6_ADD_MEMBERSHIP | Add an IP group membership
IPV6_DROP_MEMBERSHIP | Drop an IP group membership
IPV6_HDRINCL | Header is included with data
IPV6_JOIN_GROUP | This is constant nxllJwaWS2tcpip.IPV6_JOIN_GROUP.
IPV6_LEAVE_GROUP | This is constant nxllJwaWS2tcpip.IPV6_LEAVE_GROUP.
IPV6_MULTICAST_HOPS | Set/get IP multicast ttl
IPV6_MULTICAST_IF | Set/get IP multicast interface
IPV6_MULTICAST_LOOP | Set/get IP multicast loopback
IPV6_PKTINFO | Receive packet information for ipv6
IPV6_UNICAST_HOPS | Set/get IP unicast hop limit
MCAST_EXCLUDE | This is constant nxllJwaWS2tcpip.MCAST_EXCLUDE.
MCAST_INCLUDE | This is constant nxllJwaWS2tcpip.MCAST_INCLUDE.
NI_DGRAM | Service is a datagram service
NI_MAXHOST | Max size of a fully-qualified domain name
NI_MAXSERV | Max size of a service name
NI_NAMEREQD | Error if the host's name not in DNS
NI_NOFQDN | Only return nodename portion for local hosts
NI_NUMERICHOST | Return numeric form of the host's address
NI_NUMERICSERV | Return numeric form of the service (port #)
SIO_GET_INTERFACE_LIST | TCP/IP specific Ioctl codes
SIO_GET_INTERFACE_LIST_EX | New IOCTL with address size independent address array
SIO_GET_MULTICAST_FILTER | This is constant nxllJwaWS2tcpip.SIO_GET_MULTICAST_FILTER.
SIO_SET_MULTICAST_FILTER | This is constant nxllJwaWS2tcpip.SIO_SET_MULTICAST_FILTER.
TCP_EXPEDITED_1122 | Option to use with [gs]etsockopt at the IPPROTO_TCP level
UDP_CHECKSUM_COVERAGE | Set/get UDP-Lite checksum coverage
UDP_NOCHECKSUM | Option to use with [gs]etsockopt at the IPPROTO_UDP level
ws2tcpip | This is constant nxllJwaWS2tcpip.ws2tcpip.
Namespace

nxllJwaWS2tcpip Namespace

Links
Constants, nxllJwaWS2tcpip Namespace


nxllJwaWS2tcpip.AI_CANONNAME Constant

nxllJwaWS2tcpip.AI_CANONNAME Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
AI_CANONNAME = $2;
File

nxllJwaWS2tcpip

Description

Return canonical name in first ai_canonname

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.AI_NUMERICHOST Constant

nxllJwaWS2tcpip.AI_NUMERICHOST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
AI_NUMERICHOST = $4;
File

nxllJwaWS2tcpip

Description

Nodename must be a numeric address string

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.AI_PASSIVE Constant

nxllJwaWS2tcpip.AI_PASSIVE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
AI_PASSIVE = $1;
File

nxllJwaWS2tcpip

Description

Socket address will be used in bind() call

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_AGAIN Constant

nxllJwaWS2tcpip.EAI_AGAIN Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_AGAIN = WSATRY_AGAIN;
File

nxllJwaWS2tcpip

Description

Error codes from getaddrinfo()

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_BADFLAGS Constant

nxllJwaWS2tcpip.EAI_BADFLAGS Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_BADFLAGS = WSAEINVAL;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_BADFLAGS.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_FAIL Constant

nxllJwaWS2tcpip.EAI_FAIL Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_FAIL = WSANO_RECOVERY;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_FAIL.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_FAMILY Constant

nxllJwaWS2tcpip.EAI_FAMILY Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_FAMILY = WSAEAFNOSUPPORT;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_FAMILY.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_MEMORY Constant

nxllJwaWS2tcpip.EAI_MEMORY Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_MEMORY = WSA_NOT_ENOUGH_MEMORY;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_MEMORY.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_NODATA Constant

nxllJwaWS2tcpip.EAI_NODATA Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_NODATA = EAI_NONAME;
File

nxllJwaWS2tcpip

Description

DCR_FIX: EAI_NODATA remove or fix

EAI_NODATA was removed from rfc2553bis need to find out from the authors why and determine the error for "no records of this type" temporarily, we'll keep #define to avoid changing code that could change back; use NONAME

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_NONAME Constant

nxllJwaWS2tcpip.EAI_NONAME Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_NONAME = WSAHOST_NOT_FOUND;
File

nxllJwaWS2tcpip

Description

define EAI_NODATA WSANO_DATA

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_SERVICE Constant

nxllJwaWS2tcpip.EAI_SERVICE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_SERVICE = WSATYPE_NOT_FOUND;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_SERVICE.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.EAI_SOCKTYPE Constant

nxllJwaWS2tcpip.EAI_SOCKTYPE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
EAI_SOCKTYPE = WSAESOCKTNOSUPPORT;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.EAI_SOCKTYPE.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.GAI_STRERROR_BUFFER_SIZE Constant

nxllJwaWS2tcpip.GAI_STRERROR_BUFFER_SIZE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
GAI_STRERROR_BUFFER_SIZE = 1024;
File

nxllJwaWS2tcpip

Description

WARNING: The gai_strerror inline functions below use static buffers, and hence are not thread-safe. We'll use buffers long enough to hold 1k characters. Any system error messages longer than this will be returned as empty strings. However 1k should work for the error codes used by getaddrinfo().

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IFF_BROADCAST Constant

nxllJwaWS2tcpip.IFF_BROADCAST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IFF_BROADCAST = $00000002;
File

nxllJwaWS2tcpip

Description

Broadcast is supported

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IFF_LOOPBACK Constant

nxllJwaWS2tcpip.IFF_LOOPBACK Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IFF_LOOPBACK = $00000004;
File

nxllJwaWS2tcpip

Description

this is loopback interface

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IFF_MULTICAST Constant

nxllJwaWS2tcpip.IFF_MULTICAST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IFF_MULTICAST = $00000010;
File

nxllJwaWS2tcpip

Description

multicast is supported

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IFF_POINTTOPOINT Constant

nxllJwaWS2tcpip.IFF_POINTTOPOINT Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IFF_POINTTOPOINT = $00000008;
File

nxllJwaWS2tcpip

Description

this is point-to-point interface

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IFF_UP Constant

nxllJwaWS2tcpip.IFF_UP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IFF_UP = $00000001;
File

nxllJwaWS2tcpip

Description

Interface is up

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.in6addr_any Constant

nxllJwaWS2tcpip.in6addr_any Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
in6addr_any: in6_addr = (Word: (0, 0, 0, 0, 0, 0, 0, 0));
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.in6addr_any.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IN6ADDR_ANY_INIT Constant

nxllJwaWS2tcpip.IN6ADDR_ANY_INIT Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IN6ADDR_ANY_INIT: in6_addr = (Word: (0, 0, 0, 0, 0, 0, 0, 0));
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.IN6ADDR_ANY_INIT.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.in6addr_loopback Constant

nxllJwaWS2tcpip.in6addr_loopback Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
in6addr_loopback: in6_addr = (Byte: (0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1));
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.in6addr_loopback.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IN6ADDR_LOOPBACK_INIT Constant

nxllJwaWS2tcpip.IN6ADDR_LOOPBACK_INIT Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IN6ADDR_LOOPBACK_INIT: in6_addr = (Byte: (0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1));
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.IN6ADDR_LOOPBACK_INIT.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.INET_ADDRSTRLEN Constant

nxllJwaWS2tcpip.INET_ADDRSTRLEN Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
INET_ADDRSTRLEN = 16;
File

nxllJwaWS2tcpip

Description

Max size of numeric form of IPv4 address

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.INET6_ADDRSTRLEN Constant

nxllJwaWS2tcpip.INET6_ADDRSTRLEN Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
INET6_ADDRSTRLEN = 46;
File

nxllJwaWS2tcpip

Description

Max size of numeric form of IPv6 address

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_ADD_MEMBERSHIP Constant

nxllJwaWS2tcpip.IP_ADD_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_ADD_MEMBERSHIP = 12;
File

nxllJwaWS2tcpip

Description

add an IP group membership

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_ADD_SOURCE_MEMBERSHIP Constant

nxllJwaWS2tcpip.IP_ADD_SOURCE_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_ADD_SOURCE_MEMBERSHIP = 15;
File

nxllJwaWS2tcpip

Description

join IP group/source

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_BLOCK_SOURCE Constant

nxllJwaWS2tcpip.IP_BLOCK_SOURCE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_BLOCK_SOURCE = 17;
File

nxllJwaWS2tcpip

Description

block IP group/source

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_DONTFRAGMENT Constant

nxllJwaWS2tcpip.IP_DONTFRAGMENT Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_DONTFRAGMENT = 14;
File

nxllJwaWS2tcpip

Description

don't fragment IP datagrams

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_DROP_MEMBERSHIP Constant

nxllJwaWS2tcpip.IP_DROP_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_DROP_MEMBERSHIP = 13;
File

nxllJwaWS2tcpip

Description

drop an IP group membership

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_DROP_SOURCE_MEMBERSHIP Constant

nxllJwaWS2tcpip.IP_DROP_SOURCE_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_DROP_SOURCE_MEMBERSHIP = 16;
File

nxllJwaWS2tcpip

Description

leave IP group/source

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_HDRINCL Constant

nxllJwaWS2tcpip.IP_HDRINCL Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_HDRINCL = 2;
File

nxllJwaWS2tcpip

Description

header is included with data

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_MULTICAST_IF Constant

nxllJwaWS2tcpip.IP_MULTICAST_IF Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_MULTICAST_IF = 9;
File

nxllJwaWS2tcpip

Description

set/get IP multicast i/f

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_MULTICAST_LOOP Constant

nxllJwaWS2tcpip.IP_MULTICAST_LOOP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_MULTICAST_LOOP = 11;
File

nxllJwaWS2tcpip

Description

set/get IP multicast loopback

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_MULTICAST_TTL Constant

nxllJwaWS2tcpip.IP_MULTICAST_TTL Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_MULTICAST_TTL = 10;
File

nxllJwaWS2tcpip

Description

set/get IP multicast ttl

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_OPTIONS Constant

nxllJwaWS2tcpip.IP_OPTIONS Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_OPTIONS = 1;
File

nxllJwaWS2tcpip

Description

set/get IP options

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_PKTINFO Constant

nxllJwaWS2tcpip.IP_PKTINFO Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_PKTINFO = 19;
File

nxllJwaWS2tcpip

Description

receive packet information for ipv4

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_TOS Constant

nxllJwaWS2tcpip.IP_TOS Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_TOS = 3;
File

nxllJwaWS2tcpip

Description

IP type of service and preced

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_TTL Constant

nxllJwaWS2tcpip.IP_TTL Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_TTL = 4;
File

nxllJwaWS2tcpip

Description

IP time to live

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IP_UNBLOCK_SOURCE Constant

nxllJwaWS2tcpip.IP_UNBLOCK_SOURCE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IP_UNBLOCK_SOURCE = 18;
File

nxllJwaWS2tcpip

Description

unblock IP group/source

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_ADD_MEMBERSHIP Constant

nxllJwaWS2tcpip.IPV6_ADD_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_ADD_MEMBERSHIP = 12;
File

nxllJwaWS2tcpip

Description

Add an IP group membership

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_DROP_MEMBERSHIP Constant

nxllJwaWS2tcpip.IPV6_DROP_MEMBERSHIP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_DROP_MEMBERSHIP = 13;
File

nxllJwaWS2tcpip

Description

Drop an IP group membership

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_HDRINCL Constant

nxllJwaWS2tcpip.IPV6_HDRINCL Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_HDRINCL = 2;
File

nxllJwaWS2tcpip

Description

Header is included with data

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_JOIN_GROUP Constant

nxllJwaWS2tcpip.IPV6_JOIN_GROUP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_JOIN_GROUP = IPV6_ADD_MEMBERSHIP;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.IPV6_JOIN_GROUP.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_LEAVE_GROUP Constant

nxllJwaWS2tcpip.IPV6_LEAVE_GROUP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_LEAVE_GROUP = IPV6_DROP_MEMBERSHIP;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.IPV6_LEAVE_GROUP.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_MULTICAST_HOPS Constant

nxllJwaWS2tcpip.IPV6_MULTICAST_HOPS Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_MULTICAST_HOPS = 10;
File

nxllJwaWS2tcpip

Description

Set/get IP multicast ttl

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_MULTICAST_IF Constant

nxllJwaWS2tcpip.IPV6_MULTICAST_IF Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_MULTICAST_IF = 9;
File

nxllJwaWS2tcpip

Description

Set/get IP multicast interface

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_MULTICAST_LOOP Constant

nxllJwaWS2tcpip.IPV6_MULTICAST_LOOP Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_MULTICAST_LOOP = 11;
File

nxllJwaWS2tcpip

Description

Set/get IP multicast loopback

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_PKTINFO Constant

nxllJwaWS2tcpip.IPV6_PKTINFO Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_PKTINFO = 19;
File

nxllJwaWS2tcpip

Description

Receive packet information for ipv6

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.IPV6_UNICAST_HOPS Constant

nxllJwaWS2tcpip.IPV6_UNICAST_HOPS Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
IPV6_UNICAST_HOPS = 4;
File

nxllJwaWS2tcpip

Description

Set/get IP unicast hop limit

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.MCAST_EXCLUDE Constant

nxllJwaWS2tcpip.MCAST_EXCLUDE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
MCAST_EXCLUDE = 1;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.MCAST_EXCLUDE.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.MCAST_INCLUDE Constant

nxllJwaWS2tcpip.MCAST_INCLUDE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
MCAST_INCLUDE = 0;
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.MCAST_INCLUDE.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_DGRAM Constant

nxllJwaWS2tcpip.NI_DGRAM Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_DGRAM = $10;
File

nxllJwaWS2tcpip

Description

Service is a datagram service

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_MAXHOST Constant

nxllJwaWS2tcpip.NI_MAXHOST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_MAXHOST = 1025;
File

nxllJwaWS2tcpip

Description

Max size of a fully-qualified domain name

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_MAXSERV Constant

nxllJwaWS2tcpip.NI_MAXSERV Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_MAXSERV = 32;
File

nxllJwaWS2tcpip

Description

Max size of a service name

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_NAMEREQD Constant

nxllJwaWS2tcpip.NI_NAMEREQD Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_NAMEREQD = $04;
File

nxllJwaWS2tcpip

Description

Error if the host's name not in DNS

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_NOFQDN Constant

nxllJwaWS2tcpip.NI_NOFQDN Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_NOFQDN = $01;
File

nxllJwaWS2tcpip

Description

Only return nodename portion for local hosts

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_NUMERICHOST Constant

nxllJwaWS2tcpip.NI_NUMERICHOST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_NUMERICHOST = $02;
File

nxllJwaWS2tcpip

Description

Return numeric form of the host's address

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.NI_NUMERICSERV Constant

nxllJwaWS2tcpip.NI_NUMERICSERV Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
NI_NUMERICSERV = $08;
File

nxllJwaWS2tcpip

Description

Return numeric form of the service (port #)

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.SIO_GET_INTERFACE_LIST Constant

nxllJwaWS2tcpip.SIO_GET_INTERFACE_LIST Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
SIO_GET_INTERFACE_LIST = IOC_OUT or ((4 and IOCPARM_MASK) shl 16) or ((Ord('t')) shl 8) or (127);
File

nxllJwaWS2tcpip

Description

TCP/IP specific Ioctl codes

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.SIO_GET_INTERFACE_LIST_EX Constant

nxllJwaWS2tcpip.SIO_GET_INTERFACE_LIST_EX Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
SIO_GET_INTERFACE_LIST_EX = IOC_OUT or ((4 and IOCPARM_MASK) shl 16) or ((Ord('t')) shl 8) or (126);
File

nxllJwaWS2tcpip

Description

New IOCTL with address size independent address array

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.SIO_GET_MULTICAST_FILTER Constant

nxllJwaWS2tcpip.SIO_GET_MULTICAST_FILTER Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
SIO_GET_MULTICAST_FILTER = DWORD(IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('t') shl 8) or 124 or IOC_IN);
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.SIO_GET_MULTICAST_FILTER.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.SIO_SET_MULTICAST_FILTER Constant

nxllJwaWS2tcpip.SIO_SET_MULTICAST_FILTER Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
SIO_SET_MULTICAST_FILTER = DWORD(IOC_IN or ((SizeOf(u_long) and IOCPARM_MASK) shl 16) or (Ord('t') shl 8) or 125);
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.SIO_SET_MULTICAST_FILTER.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.TCP_EXPEDITED_1122 Constant

nxllJwaWS2tcpip.TCP_EXPEDITED_1122 Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
TCP_EXPEDITED_1122 = $0002;
File

nxllJwaWS2tcpip

Description

Option to use with [gs]etsockopt at the IPPROTO_TCP level

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.UDP_CHECKSUM_COVERAGE Constant

nxllJwaWS2tcpip.UDP_CHECKSUM_COVERAGE Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
UDP_CHECKSUM_COVERAGE = 20;
File

nxllJwaWS2tcpip

Description

Set/get UDP-Lite checksum coverage

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.UDP_NOCHECKSUM Constant

nxllJwaWS2tcpip.UDP_NOCHECKSUM Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
UDP_NOCHECKSUM = 1;
File

nxllJwaWS2tcpip

Description

Option to use with [gs]etsockopt at the IPPROTO_UDP level

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWS2tcpip.ws2tcpip Constant

nxllJwaWS2tcpip.ws2tcpip Constant
nxllJwaWS2tcpip Constants Send Feedback
Syntax
Delphi
ws2tcpip = 'ws2_32.dll';
File

nxllJwaWS2tcpip

Description

This is constant nxllJwaWS2tcpip.ws2tcpip.

Group

Constants

Links
nxllJwaWS2tcpip, Constants


nxllJwaWSipx Namespace

nxllJwaWSipx Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllJwaWSipx.

Constants
Name | Description
NSPROTO_IPX | Protocol families used in the "protocol" parameter of the socket() API.
NSPROTO_SPX | This is constant nxllJwaWSipx.NSPROTO_SPX.
NSPROTO_SPXII | This is constant nxllJwaWSipx.NSPROTO_SPXII.
Structs, Records, Enums
Name | Description
SOCKADDR_IPX | This is the structure of the SOCKADDR structure for IPX and SPX.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
LPSOCKADDR_IPX | This is type nxllJwaWSipx.LPSOCKADDR_IPX.
PSOCKADDR_IPX | This is type nxllJwaWSipx.PSOCKADDR_IPX.
PSockAddrIPX | This is type nxllJwaWSipx.PSockAddrIPX.
TSockAddrIPX | This is type nxllJwaWSipx.TSockAddrIPX.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
nxllJwaWSipx Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllJwaWSipx Namespace

Records
Name | Description
SOCKADDR_IPX | This is the structure of the SOCKADDR structure for IPX and SPX.
Links
nxllJwaWSipx Namespace, Legend, Records


nxllJwaWSipx.SOCKADDR_IPX Record

nxllJwaWSipx.SOCKADDR_IPX Record
nxllJwaWSipx Structs, Records, Enums Send Feedback
Syntax
Delphi
SOCKADDR_IPX = record
  sa_family: Smallint;
  sa_netnum: array [0..3] of Char;
  sa_nodenum: array [0..5] of Char;
  sa_socket: Word;
end;
File

nxllJwaWSipx

Description

This is the structure of the SOCKADDR structure for IPX and SPX.

Group

Structs, Records, Enums

Links
nxllJwaWSipx, Structs, Records, Enums


Types

Types
nxllJwaWSipx Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllJwaWSipx Namespace

Types
Name | Description
LPSOCKADDR_IPX | This is type nxllJwaWSipx.LPSOCKADDR_IPX.
PSOCKADDR_IPX | This is type nxllJwaWSipx.PSOCKADDR_IPX.
PSockAddrIPX | This is type nxllJwaWSipx.PSockAddrIPX.
TSockAddrIPX | This is type nxllJwaWSipx.TSockAddrIPX.
Links
nxllJwaWSipx Namespace, Types


nxllJwaWSipx.LPSOCKADDR_IPX Type

nxllJwaWSipx.LPSOCKADDR_IPX Type
nxllJwaWSipx Types Send Feedback
Syntax
Delphi
LPSOCKADDR_IPX = ^SOCKADDR_IPX;
File

nxllJwaWSipx

Description

This is type nxllJwaWSipx.LPSOCKADDR_IPX.

Group

Types

Links
nxllJwaWSipx, Types


nxllJwaWSipx.PSOCKADDR_IPX Type

nxllJwaWSipx.PSOCKADDR_IPX Type
nxllJwaWSipx Types Send Feedback
Syntax
Delphi
PSOCKADDR_IPX = ^SOCKADDR_IPX;
File

nxllJwaWSipx

Description

This is type nxllJwaWSipx.PSOCKADDR_IPX.

Group

Types

Links
nxllJwaWSipx, Types


nxllJwaWSipx.PSockAddrIPX Type

nxllJwaWSipx.PSockAddrIPX Type
nxllJwaWSipx Types Send Feedback
Syntax
Delphi
PSockAddrIPX = LPSOCKADDR_IPX;
File

nxllJwaWSipx

Description

This is type nxllJwaWSipx.PSockAddrIPX.

Group

Types

Links
nxllJwaWSipx, Types


nxllJwaWSipx.TSockAddrIPX Type

nxllJwaWSipx.TSockAddrIPX Type
nxllJwaWSipx Types Send Feedback
Syntax
Delphi
TSockAddrIPX = SOCKADDR_IPX;
File

nxllJwaWSipx

Description

This is type nxllJwaWSipx.TSockAddrIPX.

Group

Types

Links
nxllJwaWSipx, Types


Constants

Constants
Constants nxllJwaWSipx Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
NSPROTO_IPX | Protocol families used in the "protocol" parameter of the socket() API.
NSPROTO_SPX | This is constant nxllJwaWSipx.NSPROTO_SPX.
NSPROTO_SPXII | This is constant nxllJwaWSipx.NSPROTO_SPXII.
Namespace

nxllJwaWSipx Namespace

Links
Constants, nxllJwaWSipx Namespace


nxllJwaWSipx.NSPROTO_IPX Constant

nxllJwaWSipx.NSPROTO_IPX Constant
nxllJwaWSipx Constants Send Feedback
Syntax
Delphi
NSPROTO_IPX = 1000;
File

nxllJwaWSipx

Description

Protocol families used in the "protocol" parameter of the socket() API.

Group

Constants

Links
nxllJwaWSipx, Constants


nxllJwaWSipx.NSPROTO_SPX Constant

nxllJwaWSipx.NSPROTO_SPX Constant
nxllJwaWSipx Constants Send Feedback
Syntax
Delphi
NSPROTO_SPX = 1256;
File

nxllJwaWSipx

Description

This is constant nxllJwaWSipx.NSPROTO_SPX.

Group

Constants

Links
nxllJwaWSipx, Constants


nxllJwaWSipx.NSPROTO_SPXII Constant

nxllJwaWSipx.NSPROTO_SPXII Constant
nxllJwaWSipx Constants Send Feedback
Syntax
Delphi
NSPROTO_SPXII = 1257;
File

nxllJwaWSipx

Description

This is constant nxllJwaWSipx.NSPROTO_SPXII.

Group

Constants

Links
nxllJwaWSipx, Constants


nxllKeepAliveService Namespace

nxllKeepAliveService Namespace
Classes Functions Legend Topics Variables Send Feedback

This is namespace nxllKeepAliveService.

Classes
Name | Description
TnxKeepAliveItem | This is class nxllKeepAliveService.TnxKeepAliveItem.
TnxKeepAliveQueue | This is class nxllKeepAliveService.TnxKeepAliveQueue.
TnxKeepAliveThread | This is class nxllKeepAliveService.TnxKeepAliveThread.
Functions
Name | Description
nxAddKeepAlive | This is function nxllKeepAliveService.nxAddKeepAlive.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_Queue | This is variable nxllKeepAliveService._Queue.
Links
Classes, Functions, Legend, Topics, Variables


Classes

Classes
Classes nxllKeepAliveService Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxKeepAliveItem | This is class nxllKeepAliveService.TnxKeepAliveItem.
TnxKeepAliveQueue | This is class nxllKeepAliveService.TnxKeepAliveQueue.
TnxKeepAliveThread | This is class nxllKeepAliveService.TnxKeepAliveThread.
Namespace

nxllKeepAliveService Namespace

Links
Classes, nxllKeepAliveService Namespace, Legend


TnxKeepAliveItem Class

TnxKeepAliveItem Class
TnxKeepAliveItem Fields TnxKeepAliveItem Methods TnxKeepAliveItem Members nxllKeepAliveService Classes Send Feedback
Class Hierarchy
nxllKeepAliveService_TnxKeepAliveItem
Syntax
Delphi
TnxKeepAliveItem = class(TnxThreadSafeQueueItem);
File

nxllKeepAliveService

Description

This is class nxllKeepAliveService.TnxKeepAliveItem.

Group

Classes

Links
TnxKeepAliveItem Fields, TnxKeepAliveItem Methods, TnxKeepAliveItem Members, nxllKeepAliveService, Classes


TnxKeepAliveItem Members

TnxKeepAliveItem Members
TnxKeepAliveItem Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxKeepAliveItem.

Class

TnxKeepAliveItem Class

Protected Fields
Name | Description
kaiKeepAlive | This is kaiKeepAlive, a member of class TnxKeepAliveItem.
kaiKeepAliveSince | This is kaiKeepAliveSince, a member of class TnxKeepAliveItem.
kaiKeepAliveUntil | This is kaiKeepAliveUntil, a member of class TnxKeepAliveItem.
kaiQueue | private
Public Methods
Name | Description
Create | TnxKeepAliveItem
WaitFor | This is WaitFor, a member of class TnxKeepAliveItem.
Links
TnxKeepAliveItem Class, Legend, Protected Fields, Public Methods


TnxKeepAliveItem.Create Constructor

TnxKeepAliveItem.Create Constructor
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Class Send Feedback
Syntax
Delphi
constructor Create(aQueue: TnxKeepAliveQueue; const aInterface: InxInterface);
Description

TnxKeepAliveItem

Class

TnxKeepAliveItem Class

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Class


TnxKeepAliveItem Fields

TnxKeepAliveItem Fields
TnxKeepAliveItem Class Legend Protected Fields Send Feedback

The fields of the TnxKeepAliveItem class are listed here.

Class

TnxKeepAliveItem Class

Protected Fields
Name | Description
kaiKeepAlive | This is kaiKeepAlive, a member of class TnxKeepAliveItem.
kaiKeepAliveSince | This is kaiKeepAliveSince, a member of class TnxKeepAliveItem.
kaiKeepAliveUntil | This is kaiKeepAliveUntil, a member of class TnxKeepAliveItem.
kaiQueue | private
Links
TnxKeepAliveItem Class, Legend, Protected Fields


TnxKeepAliveItem.kaiKeepAlive Field

TnxKeepAliveItem.kaiKeepAlive Field
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Fields Send Feedback
Syntax
Delphi
kaiKeepAlive: InxInterface;
Description

This is kaiKeepAlive, a member of class TnxKeepAliveItem.

Group

TnxKeepAliveItem Fields

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Fields


TnxKeepAliveItem.kaiKeepAliveSince Field

TnxKeepAliveItem.kaiKeepAliveSince Field
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Fields Send Feedback
Syntax
Delphi
kaiKeepAliveSince: Cardinal;
Description

This is kaiKeepAliveSince, a member of class TnxKeepAliveItem.

Group

TnxKeepAliveItem Fields

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Fields


TnxKeepAliveItem.kaiKeepAliveUntil Field

TnxKeepAliveItem.kaiKeepAliveUntil Field
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Fields Send Feedback
Syntax
Delphi
kaiKeepAliveUntil: Cardinal;
Description

This is kaiKeepAliveUntil, a member of class TnxKeepAliveItem.

Group

TnxKeepAliveItem Fields

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Fields


TnxKeepAliveItem.kaiQueue Field

TnxKeepAliveItem.kaiQueue Field
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Fields Send Feedback
Syntax
Delphi
kaiQueue: TnxKeepAliveQueue;
Description

private

Group

TnxKeepAliveItem Fields

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Fields


TnxKeepAliveItem Methods

TnxKeepAliveItem Methods
TnxKeepAliveItem Class Legend Public Methods Send Feedback

The methods of the TnxKeepAliveItem class are listed here.

Class

TnxKeepAliveItem Class

Public Methods
Name | Description
WaitFor | This is WaitFor, a member of class TnxKeepAliveItem.
Links
TnxKeepAliveItem Class, Legend, Public Methods


TnxKeepAliveItem.WaitFor Method

TnxKeepAliveItem.WaitFor Method
TnxKeepAliveItem Class TnxKeepAliveItem Members nxllKeepAliveService Namespace TnxKeepAliveItem Methods Send Feedback
Syntax
Delphi
procedure WaitFor;
Description

This is WaitFor, a member of class TnxKeepAliveItem.

Group

TnxKeepAliveItem Methods

Links
TnxKeepAliveItem Class, TnxKeepAliveItem Members, nxllKeepAliveService Namespace, TnxKeepAliveItem Methods


TnxKeepAliveQueue Class

TnxKeepAliveQueue Class
TnxKeepAliveQueue Fields TnxKeepAliveQueue Methods TnxKeepAliveQueue Members nxllKeepAliveService Classes Send Feedback
Class Hierarchy
nxllKeepAliveService_TnxKeepAliveQueue
Syntax
Delphi
TnxKeepAliveQueue = class(TnxThreadSafeQueue);
File

nxllKeepAliveService

Description

This is class nxllKeepAliveService.TnxKeepAliveQueue.

Group

Classes

Links
TnxKeepAliveQueue Fields, TnxKeepAliveQueue Methods, TnxKeepAliveQueue Members, nxllKeepAliveService, Classes


TnxKeepAliveQueue Members

TnxKeepAliveQueue Members
TnxKeepAliveQueue Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxKeepAliveQueue.

Class

TnxKeepAliveQueue Class

Protected Fields
Name | Description
kaqKeepAliveTime | This is kaqKeepAliveTime, a member of class TnxKeepAliveQueue.
kaqThread | This is kaqThread, a member of class TnxKeepAliveQueue.
Public Methods
Name | Description
Create | TnxKeepAliveQueue
Destroy | This is Destroy, a member of class TnxKeepAliveQueue.
Terminate | This is Terminate, a member of class TnxKeepAliveQueue.
Links
TnxKeepAliveQueue Class, Legend, Protected Fields, Public Methods


TnxKeepAliveQueue.Create Constructor

TnxKeepAliveQueue.Create Constructor
TnxKeepAliveQueue Class TnxKeepAliveQueue Members nxllKeepAliveService Namespace TnxKeepAliveQueue Class Send Feedback
Syntax
Delphi
constructor Create(aKeepAliveTime: Cardinal);
Description

TnxKeepAliveQueue

Class

TnxKeepAliveQueue Class

Links
TnxKeepAliveQueue Class, TnxKeepAliveQueue Members, nxllKeepAliveService Namespace, TnxKeepAliveQueue Class


TnxKeepAliveQueue.Destroy Destructor

TnxKeepAliveQueue.Destroy Destructor
TnxKeepAliveQueue Class TnxKeepAliveQueue Members nxllKeepAliveService Namespace TnxKeepAliveQueue Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxKeepAliveQueue.

Class

TnxKeepAliveQueue Class

Links
TnxKeepAliveQueue Class, TnxKeepAliveQueue Members, nxllKeepAliveService Namespace, TnxKeepAliveQueue Class


TnxKeepAliveQueue Fields

TnxKeepAliveQueue Fields
TnxKeepAliveQueue Class Legend Protected Fields Send Feedback

The fields of the TnxKeepAliveQueue class are listed here.

Class

TnxKeepAliveQueue Class

Protected Fields
Name | Description
kaqKeepAliveTime | This is kaqKeepAliveTime, a member of class TnxKeepAliveQueue.
kaqThread | This is kaqThread, a member of class TnxKeepAliveQueue.
Links
TnxKeepAliveQueue Class, Legend, Protected Fields


TnxKeepAliveQueue.kaqKeepAliveTime Field

TnxKeepAliveQueue.kaqKeepAliveTime Field
TnxKeepAliveQueue Class TnxKeepAliveQueue Members nxllKeepAliveService Namespace TnxKeepAliveQueue Fields Send Feedback
Syntax
Delphi
kaqKeepAliveTime: Cardinal;
Description

This is kaqKeepAliveTime, a member of class TnxKeepAliveQueue.

Group

TnxKeepAliveQueue Fields

Links
TnxKeepAliveQueue Class, TnxKeepAliveQueue Members, nxllKeepAliveService Namespace, TnxKeepAliveQueue Fields


TnxKeepAliveQueue.kaqThread Field

TnxKeepAliveQueue.kaqThread Field
TnxKeepAliveQueue Class TnxKeepAliveQueue Members nxllKeepAliveService Namespace TnxKeepAliveQueue Fields Send Feedback
Syntax
Delphi
kaqThread: TnxKeepAliveThread;
Description

This is kaqThread, a member of class TnxKeepAliveQueue.

Group

TnxKeepAliveQueue Fields

Links
TnxKeepAliveQueue Class, TnxKeepAliveQueue Members, nxllKeepAliveService Namespace, TnxKeepAliveQueue Fields


TnxKeepAliveQueue Methods

TnxKeepAliveQueue Methods
TnxKeepAliveQueue Class Legend Public Methods Send Feedback

The methods of the TnxKeepAliveQueue class are listed here.

Class

TnxKeepAliveQueue Class

Public Methods
Name | Description
Terminate | This is Terminate, a member of class TnxKeepAliveQueue.
Links
TnxKeepAliveQueue Class, Legend, Public Methods


TnxKeepAliveQueue.Terminate Method

TnxKeepAliveQueue.Terminate Method
TnxKeepAliveQueue Class TnxKeepAliveQueue Members nxllKeepAliveService Namespace TnxKeepAliveQueue Methods Send Feedback
Syntax
Delphi
procedure Terminate; override;
Description

This is Terminate, a member of class TnxKeepAliveQueue.

Group

TnxKeepAliveQueue Methods

Links
TnxKeepAliveQueue Class, TnxKeepAliveQueue Members, nxllKeepAliveService Namespace, TnxKeepAliveQueue Methods


TnxKeepAliveThread Class

TnxKeepAliveThread Class
TnxKeepAliveThread Fields TnxKeepAliveThread Methods TnxKeepAliveThread Members nxllKeepAliveService Classes Send Feedback
Class Hierarchy
nxllKeepAliveService_TnxKeepAliveThread
Syntax
Delphi
TnxKeepAliveThread = class(TnxThread);
File

nxllKeepAliveService

Description

This is class nxllKeepAliveService.TnxKeepAliveThread.

Group

Classes

Links
TnxKeepAliveThread Fields, TnxKeepAliveThread Methods, TnxKeepAliveThread Members, nxllKeepAliveService, Classes


TnxKeepAliveThread Members

TnxKeepAliveThread Members
TnxKeepAliveThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxKeepAliveThread.

Class

TnxKeepAliveThread Class

Protected Fields
Name | Description
katQueue | This is katQueue, a member of class TnxKeepAliveThread.
Protected Methods
Name | Description
DoExecute | This is DoExecute, a member of class TnxKeepAliveThread.
Public Methods
Name | Description
Create | TnxKeepAliveThread
Links
TnxKeepAliveThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxKeepAliveThread.Create Constructor

TnxKeepAliveThread.Create Constructor
TnxKeepAliveThread Class TnxKeepAliveThread Members nxllKeepAliveService Namespace TnxKeepAliveThread Class Send Feedback
Syntax
Delphi
constructor Create(aQueue: TnxKeepAliveQueue);
Description

TnxKeepAliveThread

Class

TnxKeepAliveThread Class

Links
TnxKeepAliveThread Class, TnxKeepAliveThread Members, nxllKeepAliveService Namespace, TnxKeepAliveThread Class


TnxKeepAliveThread Fields

TnxKeepAliveThread Fields
TnxKeepAliveThread Class Legend Protected Fields Send Feedback

The fields of the TnxKeepAliveThread class are listed here.

Class

TnxKeepAliveThread Class

Protected Fields
Name | Description
katQueue | This is katQueue, a member of class TnxKeepAliveThread.
Links
TnxKeepAliveThread Class, Legend, Protected Fields


TnxKeepAliveThread.katQueue Field

TnxKeepAliveThread.katQueue Field
TnxKeepAliveThread Class TnxKeepAliveThread Members nxllKeepAliveService Namespace TnxKeepAliveThread Fields Send Feedback
Syntax
Delphi
katQueue: TnxKeepAliveQueue;
Description

This is katQueue, a member of class TnxKeepAliveThread.

Group

TnxKeepAliveThread Fields

Links
TnxKeepAliveThread Class, TnxKeepAliveThread Members, nxllKeepAliveService Namespace, TnxKeepAliveThread Fields


TnxKeepAliveThread Methods

TnxKeepAliveThread Methods
TnxKeepAliveThread Class Legend Protected Methods Send Feedback

The methods of the TnxKeepAliveThread class are listed here.

Class

TnxKeepAliveThread Class

Protected Methods
Name | Description
DoExecute | This is DoExecute, a member of class TnxKeepAliveThread.
Links
TnxKeepAliveThread Class, Legend, Protected Methods


TnxKeepAliveThread.DoExecute Method

TnxKeepAliveThread.DoExecute Method
TnxKeepAliveThread Class TnxKeepAliveThread Members nxllKeepAliveService Namespace TnxKeepAliveThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Description

This is DoExecute, a member of class TnxKeepAliveThread.

Group

TnxKeepAliveThread Methods

Links
TnxKeepAliveThread Class, TnxKeepAliveThread Members, nxllKeepAliveService Namespace, TnxKeepAliveThread Methods


Functions

Functions
Functions nxllKeepAliveService Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxAddKeepAlive | This is function nxllKeepAliveService.nxAddKeepAlive.
Namespace

nxllKeepAliveService Namespace

Links
Functions, nxllKeepAliveService Namespace, Legend


nxllKeepAliveService.nxAddKeepAlive Function

nxllKeepAliveService.nxAddKeepAlive Function
nxllKeepAliveService Functions Send Feedback
Syntax
Delphi
procedure nxAddKeepAlive(const aInterface: InxInterface);
File

nxllKeepAliveService

Description

This is function nxllKeepAliveService.nxAddKeepAlive.

Group

Functions

Links
nxllKeepAliveService, Functions


Variables

Variables
nxllKeepAliveService Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllKeepAliveService Namespace

Variables
Name | Description
_Queue | This is variable nxllKeepAliveService._Queue.
Links
nxllKeepAliveService Namespace, Variables


nxllKeepAliveService._Queue Variable

nxllKeepAliveService._Queue Variable
nxllKeepAliveService Variables Send Feedback
Syntax
Delphi
_Queue: TnxKeepAliveQueue;
File

nxllKeepAliveService

Description

This is variable nxllKeepAliveService._Queue.

Group

Variables

Links
nxllKeepAliveService, Variables


nxllList Namespace

nxllList Namespace
Classes Constants Functions Legend Topics Types Send Feedback

This is namespace nxllList.

Classes
Name | Description
EnxBaseListException | This is class nxllList.EnxBaseListException.
EnxSortedListException | This is class nxllList.EnxSortedListException.
EnxWriteableListException | This is class nxllList.EnxWriteableListException.
TnxBaseList | This is class nxllList.TnxBaseList.
TnxFastStringList | This is class nxllList.TnxFastStringList.
TnxFastStringListCS | This is class nxllList.TnxFastStringListCS.
TnxFastStringListIC | This is class nxllList.TnxFastStringListIC.
TnxList | This is class nxllList.TnxList.
TnxListPadlock | This is class nxllList.TnxListPadlock.
TnxListPortal | This is class nxllList.TnxListPortal.
TnxListSyncAccess | This is class nxllList.TnxListSyncAccess.
TnxSortedList | This is class nxllList.TnxSortedList.
TnxWriteableList | This is class nxllList.TnxWriteableList.
Constants
Name | Description
rsFindNotSupportedWhileSortingSuspended | This is constant nxllList.rsFindNotSupportedWhileSortingSuspended.
Functions
Name | Description
QuickSort | QuickSort
QuickSort |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxListSortCompare | This is type nxllList.TnxListSortCompare.
TnxWriteableListClass | This is type nxllList.TnxWriteableListClass.
Links
Classes, Constants, Functions, Legend, Topics, Types


Classes

Classes
Classes nxllList Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseListException | This is class nxllList.EnxBaseListException.
EnxSortedListException | This is class nxllList.EnxSortedListException.
EnxWriteableListException | This is class nxllList.EnxWriteableListException.
TnxBaseList | This is class nxllList.TnxBaseList.
TnxFastStringList | This is class nxllList.TnxFastStringList.
TnxFastStringListCS | This is class nxllList.TnxFastStringListCS.
TnxFastStringListIC | This is class nxllList.TnxFastStringListIC.
TnxList | This is class nxllList.TnxList.
TnxListPadlock | This is class nxllList.TnxListPadlock.
TnxListPortal | This is class nxllList.TnxListPortal.
TnxListSyncAccess | This is class nxllList.TnxListSyncAccess.
TnxSortedList | This is class nxllList.TnxSortedList.
TnxWriteableList | This is class nxllList.TnxWriteableList.
Namespace

nxllList Namespace

Links
Classes, nxllList Namespace, Legend


EnxBaseListException Class

EnxBaseListException Class
nxllList Classes Send Feedback
Class Hierarchy
nxllList_EnxBaseListExceptionnxllList_EnxBaseListExceptionnxllList_EnxBaseListExceptionnxllList_EnxBaseListException
Syntax
Delphi
EnxBaseListException = class(EnxBaseException);
File

nxllList

Description

This is class nxllList.EnxBaseListException.

Group

Classes

Links
nxllList, Classes


EnxSortedListException Class

EnxSortedListException Class
nxllList Classes Send Feedback
Class Hierarchy
nxllList_EnxSortedListExceptionnxllList_EnxSortedListExceptionnxllList_EnxSortedListExceptionnxllList_EnxSortedListExceptionnxllList_EnxSortedListExceptionnxllList_EnxSortedListException
Syntax
Delphi
EnxSortedListException = class(EnxWriteableListException);
File

nxllList

Description

This is class nxllList.EnxSortedListException.

Group

Classes

Links
nxllList, Classes


EnxWriteableListException Class

EnxWriteableListException Class
nxllList Classes Send Feedback
Class Hierarchy
nxllList_EnxWriteableListExceptionnxllList_EnxWriteableListExceptionnxllList_EnxWriteableListExceptionnxllList_EnxWriteableListExceptionnxllList_EnxWriteableListException
Syntax
Delphi
EnxWriteableListException = class(EnxBaseListException);
File

nxllList

Description

This is class nxllList.EnxWriteableListException.

Group

Classes

Links
nxllList, Classes


TnxBaseList Class

TnxBaseList Class
TnxBaseList Fields TnxBaseList Methods TnxBaseList Properties TnxBaseList Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxBaseListnxllList_TnxBaseList
Syntax
Delphi
TnxBaseList = class(TnxObject);
File

nxllList

Description

This is class nxllList.TnxBaseList.

Group

Classes

Links
TnxBaseList Fields, TnxBaseList Methods, TnxBaseList Properties, TnxBaseList Members, nxllList, Classes


TnxBaseList Members

TnxBaseList Members
TnxBaseList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseList.

Class

TnxBaseList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
Public Methods
Name | Description
First |
FreeInstance |
IndexOf | This is IndexOf, a member of class TnxBaseList.
Last |
NewInstance | TnxObject
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxBaseList.
Count | This is Count, a member of class TnxBaseList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxBaseList.
List | This is List, a member of class TnxBaseList.
Links
TnxBaseList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseList Fields

TnxBaseList Fields
TnxBaseList Class Legend Protected Fields Send Feedback

The fields of the TnxBaseList class are listed here.

Class

TnxBaseList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
Links
TnxBaseList Class, Legend, Protected Fields


TnxBaseList.blCapacity Field

TnxBaseList.blCapacity Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blCapacity: Integer;
Description

This is blCapacity, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blCount Field

TnxBaseList.blCount Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blCount: Integer;
Description

This is blCount, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blData Field

TnxBaseList.blData Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blData: PnxPointerArray;
Description

This is blData, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blFreeDataObjects Field

TnxBaseList.blFreeDataObjects Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blFreeDataObjects: Boolean;
Description

This is blFreeDataObjects, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blGeneration Field

TnxBaseList.blGeneration Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blGeneration: Cardinal;
Description

This is blGeneration, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blList Field

TnxBaseList.blList Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blList: PnxPointerArray;
Description

private

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList.blUseData Field

TnxBaseList.blUseData Field
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Fields Send Feedback
Syntax
Delphi
blUseData: Boolean;
Description

This is blUseData, a member of class TnxBaseList.

Group

TnxBaseList Fields

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Fields


TnxBaseList Methods

TnxBaseList Methods
TnxBaseList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseList class are listed here.

Class

TnxBaseList Class

Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
Public Methods
Name | Description
First |
IndexOf | This is IndexOf, a member of class TnxBaseList.
Last |
Links
TnxBaseList Class, Legend, Protected Methods, Public Methods


TnxBaseList.blGet Method

TnxBaseList.blGet Method
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Methods Send Feedback
Syntax
Delphi
function blGet(aIndex: Integer): Pointer;
Description

TnxBaseList

Group

TnxBaseList Methods

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Methods


Error Method

Error Method
TnxBaseList Methods Send Feedback

This is the overview for the Error method overload.

Overload List
Name | Description
TnxBaseList.Error (PResStringRec, Integer) |
TnxBaseList.Error (string, Integer) |
Group

TnxBaseList Methods

Links
TnxBaseList Methods


TnxBaseList.Error Method (PResStringRec, Integer)

TnxBaseList.Error Method (PResStringRec, Integer)
TnxBaseList Class TnxBaseList Members nxllList Namespace Error Method Send Feedback
Syntax
Delphi
class procedure Error(Msg: PResStringRec; Data: Integer); overload;
Group

Error Method

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, Error Method


TnxBaseList.Error Method (string, Integer)

TnxBaseList.Error Method (string, Integer)
TnxBaseList Class TnxBaseList Members nxllList Namespace Error Method Send Feedback
Syntax
Delphi
class procedure Error(const Msg: string; Data: Integer); virtual; overload;
Group

Error Method

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, Error Method


TnxBaseList.First Method

TnxBaseList.First Method
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Methods Send Feedback
Syntax
Delphi
function First: Pointer;
Group

TnxBaseList Methods

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Methods


TnxBaseList.IndexOf Method

TnxBaseList.IndexOf Method
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Methods Send Feedback
Syntax
Delphi
function IndexOf(aItem: Pointer): Integer; virtual; abstract;
Description

This is IndexOf, a member of class TnxBaseList.

Group

TnxBaseList Methods

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Methods


TnxBaseList.Last Method

TnxBaseList.Last Method
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Methods Send Feedback
Syntax
Delphi
function Last: Pointer;
Group

TnxBaseList Methods

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Methods


TnxBaseList Properties

TnxBaseList Properties
TnxBaseList Class Legend Public Properties Send Feedback

The properties of the TnxBaseList class are listed here.

Class

TnxBaseList Class

Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxBaseList.
Count | This is Count, a member of class TnxBaseList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxBaseList.
List | This is List, a member of class TnxBaseList.
Links
TnxBaseList Class, Legend, Public Properties


TnxBaseList.Capacity Property

TnxBaseList.Capacity Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property Capacity: Integer;
Description

This is Capacity, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxBaseList.Count Property

TnxBaseList.Count Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property Count: Integer;
Description

This is Count, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxBaseList.Data Property

TnxBaseList.Data Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property Data: PnxPointerArray;
Description

This is Data, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxBaseList.Generation Property

TnxBaseList.Generation Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property Generation: Cardinal;
Description

This is Generation, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxBaseList.Items Property

TnxBaseList.Items Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property Items [aIndex: Integer]: Pointer;
Description

This is Items, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxBaseList.List Property

TnxBaseList.List Property
TnxBaseList Class TnxBaseList Members nxllList Namespace TnxBaseList Properties Send Feedback
Syntax
Delphi
property List: PnxPointerArray;
Description

This is List, a member of class TnxBaseList.

Group

TnxBaseList Properties

Links
TnxBaseList Class, TnxBaseList Members, nxllList Namespace, TnxBaseList Properties


TnxFastStringList Class

TnxFastStringList Class
TnxFastStringList Methods TnxFastStringList Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxFastStringList
Syntax
Delphi
TnxFastStringList = class(TStringList);
File

nxllList

Description

This is class nxllList.TnxFastStringList.

Group

Classes

Links
TnxFastStringList Methods, TnxFastStringList Members, nxllList, Classes


TnxFastStringList Members

TnxFastStringList Members
TnxFastStringList Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFastStringList.

Class

TnxFastStringList Class

Protected Methods
Name | Description
CompareStrings | This is CompareStrings, a member of class TnxFastStringList.
Public Methods
Name | Description
Clear | TnxFastStringList
CreateSorted | This is CreateSorted, a member of class TnxFastStringList.
Links
TnxFastStringList Class, Legend, Protected Methods, Public Methods


TnxFastStringList.CreateSorted Constructor

TnxFastStringList.CreateSorted Constructor
TnxFastStringList Class TnxFastStringList Members nxllList Namespace TnxFastStringList Class Send Feedback
Syntax
Delphi
constructor CreateSorted(aDups: TDuplicates = dupError);
Description

This is CreateSorted, a member of class TnxFastStringList.

Class

TnxFastStringList Class

Links
TnxFastStringList Class, TnxFastStringList Members, nxllList Namespace, TnxFastStringList Class


TnxFastStringList Methods

TnxFastStringList Methods
TnxFastStringList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFastStringList class are listed here.

Class

TnxFastStringList Class

Protected Methods
Name | Description
CompareStrings | This is CompareStrings, a member of class TnxFastStringList.
Public Methods
Name | Description
Clear | TnxFastStringList
Links
TnxFastStringList Class, Legend, Protected Methods, Public Methods


TnxFastStringList.Clear Method

TnxFastStringList.Clear Method
TnxFastStringList Class TnxFastStringList Members nxllList Namespace TnxFastStringList Methods Send Feedback
Syntax
Delphi
procedure Clear(aFreeObjects: Boolean = False); virtual; reintroduce;
Description

TnxFastStringList

Group

TnxFastStringList Methods

Links
TnxFastStringList Class, TnxFastStringList Members, nxllList Namespace, TnxFastStringList Methods


TnxFastStringList.CompareStrings Method

TnxFastStringList.CompareStrings Method
TnxFastStringList Class TnxFastStringList Members nxllList Namespace TnxFastStringList Methods Send Feedback
Syntax
Delphi
function CompareStrings(const S1: string; const S2: string): Integer; override;
Description

This is CompareStrings, a member of class TnxFastStringList.

Group

TnxFastStringList Methods

Links
TnxFastStringList Class, TnxFastStringList Members, nxllList Namespace, TnxFastStringList Methods


TnxFastStringListCS Class

TnxFastStringListCS Class
TnxFastStringListCS Methods TnxFastStringListCS Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxFastStringListCSnxllList_TnxFastStringListCS
Syntax
Delphi
TnxFastStringListCS = class(TnxFastStringList);
File

nxllList

Description

This is class nxllList.TnxFastStringListCS.

Group

Classes

Links
TnxFastStringListCS Methods, TnxFastStringListCS Members, nxllList, Classes


TnxFastStringListCS Members

TnxFastStringListCS Members
TnxFastStringListCS Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFastStringListCS.

Class

TnxFastStringListCS Class

Protected Methods
Name | Description
CompareStrings | This is CompareStrings, a member of class TnxFastStringListCS.
Public Methods
Name | Description
AfterConstruction | TnxFastStringListCS
Clear | TnxFastStringList
CreateSorted | This is CreateSorted, a member of class TnxFastStringList.
Links
TnxFastStringListCS Class, Legend, Protected Methods, Public Methods


TnxFastStringListCS Methods

TnxFastStringListCS Methods
TnxFastStringListCS Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFastStringListCS class are listed here.

Class

TnxFastStringListCS Class

Protected Methods
Name | Description
CompareStrings | This is CompareStrings, a member of class TnxFastStringListCS.
Public Methods
Name | Description
AfterConstruction | TnxFastStringListCS
Links
TnxFastStringListCS Class, Legend, Protected Methods, Public Methods


TnxFastStringListCS.AfterConstruction Method

TnxFastStringListCS.AfterConstruction Method
TnxFastStringListCS Class TnxFastStringListCS Members nxllList Namespace TnxFastStringListCS Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxFastStringListCS

Group

TnxFastStringListCS Methods

Links
TnxFastStringListCS Class, TnxFastStringListCS Members, nxllList Namespace, TnxFastStringListCS Methods


TnxFastStringListCS.CompareStrings Method

TnxFastStringListCS.CompareStrings Method
TnxFastStringListCS Class TnxFastStringListCS Members nxllList Namespace TnxFastStringListCS Methods Send Feedback
Syntax
Delphi
function CompareStrings(const S1: string; const S2: string): Integer; override;
Description

This is CompareStrings, a member of class TnxFastStringListCS.

Group

TnxFastStringListCS Methods

Links
TnxFastStringListCS Class, TnxFastStringListCS Members, nxllList Namespace, TnxFastStringListCS Methods


TnxFastStringListIC Class

TnxFastStringListIC Class
TnxFastStringListIC Methods TnxFastStringListIC Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxFastStringListICnxllList_TnxFastStringListIC
Syntax
Delphi
TnxFastStringListIC = class(TnxFastStringList);
File

nxllList

Description

This is class nxllList.TnxFastStringListIC.

Group

Classes

Links
TnxFastStringListIC Methods, TnxFastStringListIC Members, nxllList, Classes


TnxFastStringListIC Members

TnxFastStringListIC Members
TnxFastStringListIC Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFastStringListIC.

Class

TnxFastStringListIC Class

Protected Methods
Name | Description
CompareStrings | TnxFastStringListIC
Public Methods
Name | Description
Clear | TnxFastStringList
CreateSorted | This is CreateSorted, a member of class TnxFastStringList.
Links
TnxFastStringListIC Class, Legend, Protected Methods, Public Methods


TnxFastStringListIC Methods

TnxFastStringListIC Methods
TnxFastStringListIC Class Legend Protected Methods Send Feedback

The methods of the TnxFastStringListIC class are listed here.

Class

TnxFastStringListIC Class

Protected Methods
Name | Description
CompareStrings | TnxFastStringListIC
Links
TnxFastStringListIC Class, Legend, Protected Methods


TnxFastStringListIC.CompareStrings Method

TnxFastStringListIC.CompareStrings Method
TnxFastStringListIC Class TnxFastStringListIC Members nxllList Namespace TnxFastStringListIC Methods Send Feedback
Syntax
Delphi
function CompareStrings(const S1: string; const S2: string): Integer; override;
Description

TnxFastStringListIC

Group

TnxFastStringListIC Methods

Links
TnxFastStringListIC Class, TnxFastStringListIC Members, nxllList Namespace, TnxFastStringListIC Methods


TnxList Class

TnxList Class
TnxList Methods TnxList Properties TnxList Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxListnxllList_TnxListnxllList_TnxListnxllList_TnxList
Syntax
Delphi
TnxList = class(TnxWriteableList);
File

nxllList

Description

This is class nxllList.TnxList.

Group

Classes

Links
TnxList Methods, TnxList Properties, TnxList Members, nxllList, Classes


TnxList Members

TnxList Members
TnxList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxList.

Class

TnxList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
wlInitCapacity | private
Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
liPut |
liSetCount |
wlGrow |
wlSetCapacity |
Public Methods
Name | Description
Add | TnxList
AddData |
AddList | TnxWriteableList
Clear |
Create |
Delete |
Destroy |
Exchange |
First |
FreeInstance |
IndexOf |
IndexOfData |
Insert |
InsertData |
Last |
Move |
NewInstance | TnxObject
Pack |
Release | This is the overview for the Release method overload.
Remove |
Sort |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxBaseList.
Capacity | This is Capacity, a member of class TnxWriteableList.
Count | This is Count, a member of class TnxList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxList.
List | This is List, a member of class TnxBaseList.
Links
TnxList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxList Methods

TnxList Methods
TnxList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxList class are listed here.

Class

TnxList Class

Protected Methods
Name | Description
liPut |
liSetCount |
Public Methods
Name | Description
Add | TnxList
AddData |
Exchange |
IndexOf |
IndexOfData |
Insert |
InsertData |
Move |
Pack |
Sort |
Links
TnxList Class, Legend, Protected Methods, Public Methods


TnxList.Add Method

TnxList.Add Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
function Add(aItem: Pointer): Integer; override;
Description

TnxList

Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.AddData Method

TnxList.AddData Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
function AddData(aItem: Pointer; aData: Pointer): Integer; override;
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.Exchange Method

TnxList.Exchange Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
function Exchange(aIndex1: Integer; aIndex2: Integer): Boolean;
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.IndexOf Method

TnxList.IndexOf Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
function IndexOf(aItem: Pointer): Integer; override;
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.IndexOfData Method

TnxList.IndexOfData Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
function IndexOfData(aData: Pointer): Integer;
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.Insert Method

TnxList.Insert Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure Insert(aIndex: Integer; Item: Pointer);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.InsertData Method

TnxList.InsertData Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure InsertData(aIndex: Integer; Item: Pointer; Data: Pointer);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.liPut Method

TnxList.liPut Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure liPut(aIndex: Integer; Item: Pointer);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.liSetCount Method

TnxList.liSetCount Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure liSetCount(aNewCount: Integer);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.Move Method

TnxList.Move Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure Move(aCurIndex: Integer; aNewIndex: Integer);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.Pack Method

TnxList.Pack Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure Pack;
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList.Sort Method

TnxList.Sort Method
TnxList Class TnxList Members nxllList Namespace TnxList Methods Send Feedback
Syntax
Delphi
procedure Sort(Compare: TListSortCompare);
Group

TnxList Methods

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Methods


TnxList Properties

TnxList Properties
TnxList Class Legend Public Properties Send Feedback

The properties of the TnxList class are listed here.

Class

TnxList Class

Public Properties
Name | Description
Count | This is Count, a member of class TnxList.
Items | This is Items, a member of class TnxList.
Links
TnxList Class, Legend, Public Properties


TnxList.Count Property

TnxList.Count Property
TnxList Class TnxList Members nxllList Namespace TnxList Properties Send Feedback
Syntax
Delphi
property Count: Integer;
Description

This is Count, a member of class TnxList.

Group

TnxList Properties

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Properties


TnxList.Items Property

TnxList.Items Property
TnxList Class TnxList Members nxllList Namespace TnxList Properties Send Feedback
Syntax
Delphi
property Items [aIndex: Integer]: Pointer;
Description

This is Items, a member of class TnxList.

Group

TnxList Properties

Links
TnxList Class, TnxList Members, nxllList Namespace, TnxList Properties


TnxListPadlock Class

TnxListPadlock Class
TnxListPadlock Fields TnxListPadlock Methods TnxListPadlock Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxListPadlocknxllList_TnxListPadlocknxllList_TnxListPadlock
Syntax
Delphi
TnxListPadlock = class(TnxListSyncAccess);
File

nxllList

Description

This is class nxllList.TnxListPadlock.

Group

Classes

Links
TnxListPadlock Fields, TnxListPadlock Methods, TnxListPadlock Members, nxllList, Classes


TnxListPadlock Members

TnxListPadlock Members
TnxListPadlock Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxListPadlock.

Class

TnxListPadlock Class

Protected Fields
Name | Description
lplPadlock | This is lplPadlock, a member of class TnxListPadlock.
lsaList | private
Protected Methods
Name | Description
lsaGetCount |
Public Methods
Name | Description
Add | TnxListSyncAccess
AddData |
AddList | This is the overview for the AddList method overload.
BeginRead |
BeginWrite | TnxListPadlock
Clear |
Create |
Destroy |
EndRead |
EndWrite |
FreeInstance |
NewInstance | TnxObject
Release |
Remove |
Public Properties
Name | Description
Count | This is Count, a member of class TnxListSyncAccess.
Links
TnxListPadlock Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxListPadlock.Create Constructor

TnxListPadlock.Create Constructor
TnxListPadlock Class TnxListPadlock Members nxllList Namespace TnxListPadlock Class Send Feedback
Syntax
Delphi
constructor Create(aList: TnxWriteableList); override;
Class

TnxListPadlock Class

Links
TnxListPadlock Class, TnxListPadlock Members, nxllList Namespace, TnxListPadlock Class


TnxListPadlock.Destroy Destructor

TnxListPadlock.Destroy Destructor
TnxListPadlock Class TnxListPadlock Members nxllList Namespace TnxListPadlock Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxListPadlock Class

Links
TnxListPadlock Class, TnxListPadlock Members, nxllList Namespace, TnxListPadlock Class


TnxListPadlock Fields

TnxListPadlock Fields
TnxListPadlock Class Legend Protected Fields Send Feedback

The fields of the TnxListPadlock class are listed here.

Class

TnxListPadlock Class

Protected Fields
Name | Description
lplPadlock | This is lplPadlock, a member of class TnxListPadlock.
Links
TnxListPadlock Class, Legend, Protected Fields


TnxListPadlock.lplPadlock Field

TnxListPadlock.lplPadlock Field
TnxListPadlock Class TnxListPadlock Members nxllList Namespace TnxListPadlock Fields Send Feedback
Syntax
Delphi
lplPadlock: TnxPadlock;
Description

This is lplPadlock, a member of class TnxListPadlock.

Group

TnxListPadlock Fields

Links
TnxListPadlock Class, TnxListPadlock Members, nxllList Namespace, TnxListPadlock Fields


TnxListPadlock Methods

TnxListPadlock Methods
TnxListPadlock Class Legend Public Methods Send Feedback

The methods of the TnxListPadlock class are listed here.

Class

TnxListPadlock Class

Public Methods
Name | Description
BeginWrite | TnxListPadlock
EndWrite |
Links
TnxListPadlock Class, Legend, Public Methods


TnxListPadlock.BeginWrite Method

TnxListPadlock.BeginWrite Method
TnxListPadlock Class TnxListPadlock Members nxllList Namespace TnxListPadlock Methods Send Feedback
Syntax
Delphi
function BeginWrite: TnxWriteableList; override;
Description

TnxListPadlock

Group

TnxListPadlock Methods

Links
TnxListPadlock Class, TnxListPadlock Members, nxllList Namespace, TnxListPadlock Methods


TnxListPadlock.EndWrite Method

TnxListPadlock.EndWrite Method
TnxListPadlock Class TnxListPadlock Members nxllList Namespace TnxListPadlock Methods Send Feedback
Syntax
Delphi
procedure EndWrite; override;
Group

TnxListPadlock Methods

Links
TnxListPadlock Class, TnxListPadlock Members, nxllList Namespace, TnxListPadlock Methods


TnxListPortal Class

TnxListPortal Class
TnxListPortal Fields TnxListPortal Methods TnxListPortal Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxListPortalnxllList_TnxListPortalnxllList_TnxListPortal
Syntax
Delphi
TnxListPortal = class(TnxListSyncAccess);
File

nxllList

Description

This is class nxllList.TnxListPortal.

Group

Classes

Links
TnxListPortal Fields, TnxListPortal Methods, TnxListPortal Members, nxllList, Classes


TnxListPortal Members

TnxListPortal Members
TnxListPortal Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxListPortal.

Class

TnxListPortal Class

Protected Fields
Name | Description
lptPortal | This is lptPortal, a member of class TnxListPortal.
lsaList | private
Protected Methods
Name | Description
lsaGetCount |
Public Methods
Name | Description
Add | TnxListSyncAccess
AddData |
AddList | This is the overview for the AddList method overload.
BeginRead |
BeginWrite |
Clear |
Create |
Destroy |
EndRead |
EndWrite |
FreeInstance |
NewInstance | TnxObject
Release |
Remove |
Public Properties
Name | Description
Count | This is Count, a member of class TnxListSyncAccess.
Links
TnxListPortal Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxListPortal.Create Constructor

TnxListPortal.Create Constructor
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Class Send Feedback
Syntax
Delphi
constructor Create(aList: TnxWriteableList); override;
Class

TnxListPortal Class

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Class


TnxListPortal.Destroy Destructor

TnxListPortal.Destroy Destructor
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxListPortal Class

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Class


TnxListPortal Fields

TnxListPortal Fields
TnxListPortal Class Legend Protected Fields Send Feedback

The fields of the TnxListPortal class are listed here.

Class

TnxListPortal Class

Protected Fields
Name | Description
lptPortal | This is lptPortal, a member of class TnxListPortal.
Links
TnxListPortal Class, Legend, Protected Fields


TnxListPortal.lptPortal Field

TnxListPortal.lptPortal Field
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Fields Send Feedback
Syntax
Delphi
lptPortal: TnxReadWritePortal;
Description

This is lptPortal, a member of class TnxListPortal.

Group

TnxListPortal Fields

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Fields


TnxListPortal Methods

TnxListPortal Methods
TnxListPortal Class Legend Public Methods Send Feedback

The methods of the TnxListPortal class are listed here.

Class

TnxListPortal Class

Public Methods
Name | Description
BeginRead |
BeginWrite |
EndRead |
EndWrite |
Links
TnxListPortal Class, Legend, Public Methods


TnxListPortal.BeginRead Method

TnxListPortal.BeginRead Method
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Methods Send Feedback
Syntax
Delphi
function BeginRead: TnxBaseList; override;
Group

TnxListPortal Methods

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Methods


TnxListPortal.BeginWrite Method

TnxListPortal.BeginWrite Method
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Methods Send Feedback
Syntax
Delphi
function BeginWrite: TnxWriteableList; override;
Group

TnxListPortal Methods

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Methods


TnxListPortal.EndRead Method

TnxListPortal.EndRead Method
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Methods Send Feedback
Syntax
Delphi
procedure EndRead; override;
Group

TnxListPortal Methods

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Methods


TnxListPortal.EndWrite Method

TnxListPortal.EndWrite Method
TnxListPortal Class TnxListPortal Members nxllList Namespace TnxListPortal Methods Send Feedback
Syntax
Delphi
procedure EndWrite; override;
Group

TnxListPortal Methods

Links
TnxListPortal Class, TnxListPortal Members, nxllList Namespace, TnxListPortal Methods


TnxListSyncAccess Class

TnxListSyncAccess Class
TnxListSyncAccess Fields TnxListSyncAccess Methods TnxListSyncAccess Properties TnxListSyncAccess Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxListSyncAccessnxllList_TnxListSyncAccess
Syntax
Delphi
TnxListSyncAccess = class(TnxObject);
File

nxllList

Description

This is class nxllList.TnxListSyncAccess.

Group

Classes

Links
TnxListSyncAccess Fields, TnxListSyncAccess Methods, TnxListSyncAccess Properties, TnxListSyncAccess Members, nxllList, Classes


TnxListSyncAccess Members

TnxListSyncAccess Members
TnxListSyncAccess Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxListSyncAccess.

Class

TnxListSyncAccess Class

Protected Fields
Name | Description
lsaList | private
Protected Methods
Name | Description
lsaGetCount |
Public Methods
Name | Description
Add | TnxListSyncAccess
AddData |
AddList | This is the overview for the AddList method overload.
BeginRead |
BeginWrite | This is BeginWrite, a member of class TnxListSyncAccess.
Clear |
Create |
Destroy |
EndRead |
EndWrite | This is EndWrite, a member of class TnxListSyncAccess.
FreeInstance |
NewInstance | TnxObject
Release |
Remove |
Public Properties
Name | Description
Count | This is Count, a member of class TnxListSyncAccess.
Links
TnxListSyncAccess Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxListSyncAccess.Create Constructor

TnxListSyncAccess.Create Constructor
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Class Send Feedback
Syntax
Delphi
constructor Create(aList: TnxWriteableList); virtual;
Class

TnxListSyncAccess Class

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Class


TnxListSyncAccess.Destroy Destructor

TnxListSyncAccess.Destroy Destructor
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxListSyncAccess Class

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Class


TnxListSyncAccess Fields

TnxListSyncAccess Fields
TnxListSyncAccess Class Legend Protected Fields Send Feedback

The fields of the TnxListSyncAccess class are listed here.

Class

TnxListSyncAccess Class

Protected Fields
Name | Description
lsaList | private
Links
TnxListSyncAccess Class, Legend, Protected Fields


TnxListSyncAccess.lsaList Field

TnxListSyncAccess.lsaList Field
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Fields Send Feedback
Syntax
Delphi
lsaList: TnxWriteableList;
Description

private

Group

TnxListSyncAccess Fields

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Fields


TnxListSyncAccess Methods

TnxListSyncAccess Methods
TnxListSyncAccess Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxListSyncAccess class are listed here.

Class

TnxListSyncAccess Class

Protected Methods
Name | Description
lsaGetCount |
Public Methods
Name | Description
Add | TnxListSyncAccess
AddData |
AddList | This is the overview for the AddList method overload.
BeginRead |
BeginWrite | This is BeginWrite, a member of class TnxListSyncAccess.
Clear |
EndRead |
EndWrite | This is EndWrite, a member of class TnxListSyncAccess.
Release |
Remove |
Links
TnxListSyncAccess Class, Legend, Protected Methods, Public Methods


TnxListSyncAccess.Add Method

TnxListSyncAccess.Add Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
procedure Add(aItem: Pointer);
Description

TnxListSyncAccess

Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.AddData Method

TnxListSyncAccess.AddData Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
procedure AddData(aItem: Pointer; aData: Pointer);
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


AddList Method

AddList Method
TnxListSyncAccess Methods Send Feedback

This is the overview for the AddList method overload.

Overload List
Name | Description
TnxListSyncAccess.AddList (TnxBaseList) |
TnxListSyncAccess.AddList (TnxListSyncAccess) |
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Methods


TnxListSyncAccess.AddList Method (TnxBaseList)

TnxListSyncAccess.AddList Method (TnxBaseList)
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace AddList Method Send Feedback
Syntax
Delphi
procedure AddList(aList: TnxBaseList); overload;
Group

AddList Method

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, AddList Method


TnxListSyncAccess.AddList Method (TnxListSyncAccess)

TnxListSyncAccess.AddList Method (TnxListSyncAccess)
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace AddList Method Send Feedback
Syntax
Delphi
procedure AddList(aList: TnxListSyncAccess); overload;
Group

AddList Method

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, AddList Method


TnxListSyncAccess.BeginRead Method

TnxListSyncAccess.BeginRead Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
function BeginRead: TnxBaseList; virtual;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.BeginWrite Method

TnxListSyncAccess.BeginWrite Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
function BeginWrite: TnxWriteableList; virtual; abstract;
Description

This is BeginWrite, a member of class TnxListSyncAccess.

Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.Clear Method

TnxListSyncAccess.Clear Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.EndRead Method

TnxListSyncAccess.EndRead Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
procedure EndRead; virtual;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.EndWrite Method

TnxListSyncAccess.EndWrite Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
procedure EndWrite; virtual; abstract;
Description

This is EndWrite, a member of class TnxListSyncAccess.

Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.lsaGetCount Method

TnxListSyncAccess.lsaGetCount Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
function lsaGetCount: Integer;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.Release Method

TnxListSyncAccess.Release Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
function Release(aItem: Pointer): Pointer;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess.Remove Method

TnxListSyncAccess.Remove Method
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Methods Send Feedback
Syntax
Delphi
function Remove(aItem: Pointer): Boolean;
Group

TnxListSyncAccess Methods

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Methods


TnxListSyncAccess Properties

TnxListSyncAccess Properties
TnxListSyncAccess Class Legend Public Properties Send Feedback

The properties of the TnxListSyncAccess class are listed here.

Class

TnxListSyncAccess Class

Public Properties
Name | Description
Count | This is Count, a member of class TnxListSyncAccess.
Links
TnxListSyncAccess Class, Legend, Public Properties


TnxListSyncAccess.Count Property

TnxListSyncAccess.Count Property
TnxListSyncAccess Class TnxListSyncAccess Members nxllList Namespace TnxListSyncAccess Properties Send Feedback
Syntax
Delphi
property Count: Integer;
Description

This is Count, a member of class TnxListSyncAccess.

Group

TnxListSyncAccess Properties

Links
TnxListSyncAccess Class, TnxListSyncAccess Members, nxllList Namespace, TnxListSyncAccess Properties


TnxSortedList Class

TnxSortedList Class
TnxSortedList Fields TnxSortedList Methods TnxSortedList Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxSortedListnxllList_TnxSortedListnxllList_TnxSortedListnxllList_TnxSortedList
Syntax
Delphi
TnxSortedList = class(TnxWriteableList);
File

nxllList

Description

This is class nxllList.TnxSortedList.

Group

Classes

Links
TnxSortedList Fields, TnxSortedList Methods, TnxSortedList Members, nxllList, Classes


TnxSortedList Members

TnxSortedList Members
TnxSortedList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSortedList.

Class

TnxSortedList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
slModified | This is slModified, a member of class TnxSortedList.
slSuspendCount | This is slSuspendCount, a member of class TnxSortedList.
wlInitCapacity | private
Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
slCompare |
slSort |
wlGrow |
wlSetCapacity |
Public Methods
Name | Description
Add |
AddData |
AddList | TnxWriteableList
Clear |
Create |
Delete |
Destroy |
Find |
First |
FreeInstance |
IndexOf |
Last |
NewInstance | TnxObject
Release | This is the overview for the Release method overload.
Remove |
ResumeSorting |
SuspendSorting |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxBaseList.
Capacity | This is Capacity, a member of class TnxWriteableList.
Count | This is Count, a member of class TnxBaseList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxBaseList.
List | This is List, a member of class TnxBaseList.
Links
TnxSortedList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSortedList Fields

TnxSortedList Fields
TnxSortedList Class Legend Protected Fields Send Feedback

The fields of the TnxSortedList class are listed here.

Class

TnxSortedList Class

Protected Fields
Name | Description
slModified | This is slModified, a member of class TnxSortedList.
slSuspendCount | This is slSuspendCount, a member of class TnxSortedList.
Links
TnxSortedList Class, Legend, Protected Fields


TnxSortedList.slModified Field

TnxSortedList.slModified Field
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Fields Send Feedback
Syntax
Delphi
slModified: Boolean;
Description

This is slModified, a member of class TnxSortedList.

Group

TnxSortedList Fields

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Fields


TnxSortedList.slSuspendCount Field

TnxSortedList.slSuspendCount Field
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Fields Send Feedback
Syntax
Delphi
slSuspendCount: Integer;
Description

This is slSuspendCount, a member of class TnxSortedList.

Group

TnxSortedList Fields

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Fields


TnxSortedList Methods

TnxSortedList Methods
TnxSortedList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSortedList class are listed here.

Class

TnxSortedList Class

Protected Methods
Name | Description
slCompare |
slSort |
Public Methods
Name | Description
Add |
AddData |
Find |
IndexOf |
ResumeSorting |
SuspendSorting |
Links
TnxSortedList Class, Legend, Protected Methods, Public Methods


TnxSortedList.Add Method

TnxSortedList.Add Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
function Add(aItem: Pointer): Integer; override;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.AddData Method

TnxSortedList.AddData Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
function AddData(aItem: Pointer; aData: Pointer): Integer; override;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.Find Method

TnxSortedList.Find Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
function Find(aItem: Pointer; out aIndex: Integer): Boolean;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.IndexOf Method

TnxSortedList.IndexOf Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
function IndexOf(aItem: Pointer): Integer; override;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.ResumeSorting Method

TnxSortedList.ResumeSorting Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
procedure ResumeSorting;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.slCompare Method

TnxSortedList.slCompare Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
function slCompare(a: Pointer; b: Pointer): TnxValueRelationship; virtual;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.slSort Method

TnxSortedList.slSort Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
procedure slSort;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxSortedList.SuspendSorting Method

TnxSortedList.SuspendSorting Method
TnxSortedList Class TnxSortedList Members nxllList Namespace TnxSortedList Methods Send Feedback
Syntax
Delphi
procedure SuspendSorting;
Group

TnxSortedList Methods

Links
TnxSortedList Class, TnxSortedList Members, nxllList Namespace, TnxSortedList Methods


TnxWriteableList Class

TnxWriteableList Class
TnxWriteableList Fields TnxWriteableList Methods TnxWriteableList Properties TnxWriteableList Members nxllList Classes Send Feedback
Class Hierarchy
nxllList_TnxWriteableListnxllList_TnxWriteableListnxllList_TnxWriteableList
Syntax
Delphi
TnxWriteableList = class(TnxBaseList);
File

nxllList

Description

This is class nxllList.TnxWriteableList.

Group

Classes

Links
TnxWriteableList Fields, TnxWriteableList Methods, TnxWriteableList Properties, TnxWriteableList Members, nxllList, Classes


TnxWriteableList Members

TnxWriteableList Members
TnxWriteableList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWriteableList.

Class

TnxWriteableList Class

Protected Fields
Name | Description
blCapacity | This is blCapacity, a member of class TnxBaseList.
blCount | This is blCount, a member of class TnxBaseList.
blData | This is blData, a member of class TnxBaseList.
blFreeDataObjects | This is blFreeDataObjects, a member of class TnxBaseList.
blGeneration | This is blGeneration, a member of class TnxBaseList.
blList | private
blUseData | This is blUseData, a member of class TnxBaseList.
wlInitCapacity | private
Protected Methods
Name | Description
blGet | TnxBaseList
Error | This is the overview for the Error method overload.
wlGrow |
wlSetCapacity |
Public Methods
Name | Description
Add | This is Add, a member of class TnxWriteableList.
AddData | This is AddData, a member of class TnxWriteableList.
AddList | TnxWriteableList
Clear |
Create |
Delete |
Destroy |
First |
FreeInstance |
IndexOf | This is IndexOf, a member of class TnxBaseList.
Last |
NewInstance | TnxObject
Release | This is the overview for the Release method overload.
Remove |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxWriteableList.
Count | This is Count, a member of class TnxBaseList.
Data | This is Data, a member of class TnxBaseList.
Generation | This is Generation, a member of class TnxBaseList.
Items | This is Items, a member of class TnxBaseList.
List | This is List, a member of class TnxBaseList.
Links
TnxWriteableList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWriteableList.Create Constructor

TnxWriteableList.Create Constructor
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Class Send Feedback
Syntax
Delphi
constructor Create(aInitCapacity: Integer = 0; aUseData: Boolean = False; aFreeDataObjects: Boolean = False);
Class

TnxWriteableList Class

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Class


TnxWriteableList.Destroy Destructor

TnxWriteableList.Destroy Destructor
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxWriteableList Class

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Class


TnxWriteableList Fields

TnxWriteableList Fields
TnxWriteableList Class Legend Protected Fields Send Feedback

The fields of the TnxWriteableList class are listed here.

Class

TnxWriteableList Class

Protected Fields
Name | Description
wlInitCapacity | private
Links
TnxWriteableList Class, Legend, Protected Fields


TnxWriteableList.wlInitCapacity Field

TnxWriteableList.wlInitCapacity Field
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Fields Send Feedback
Syntax
Delphi
wlInitCapacity: Integer;
Description

private

Group

TnxWriteableList Fields

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Fields


TnxWriteableList Methods

TnxWriteableList Methods
TnxWriteableList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWriteableList class are listed here.

Class

TnxWriteableList Class

Protected Methods
Name | Description
wlGrow |
wlSetCapacity |
Public Methods
Name | Description
Add | This is Add, a member of class TnxWriteableList.
AddData | This is AddData, a member of class TnxWriteableList.
AddList | TnxWriteableList
Clear |
Delete |
Release | This is the overview for the Release method overload.
Remove |
Links
TnxWriteableList Class, Legend, Protected Methods, Public Methods


TnxWriteableList.Add Method

TnxWriteableList.Add Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
function Add(aItem: Pointer): Integer; virtual; abstract;
Description

This is Add, a member of class TnxWriteableList.

Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.AddData Method

TnxWriteableList.AddData Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
function AddData(aItem: Pointer; aData: Pointer): Integer; virtual; abstract;
Description

This is AddData, a member of class TnxWriteableList.

Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.AddList Method

TnxWriteableList.AddList Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
procedure AddList(aList: TnxBaseList);
Description

TnxWriteableList

Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.Clear Method

TnxWriteableList.Clear Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.Delete Method

TnxWriteableList.Delete Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
procedure Delete(aIndex: Integer);
Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


Release Method

Release Method
TnxWriteableList Methods Send Feedback

This is the overview for the Release method overload.

Overload List
Name | Description
TnxWriteableList.Release (Integer) |
TnxWriteableList.Release (Pointer) |
Group

TnxWriteableList Methods

Links
TnxWriteableList Methods


TnxWriteableList.Release Method (Integer)

TnxWriteableList.Release Method (Integer)
TnxWriteableList Class TnxWriteableList Members nxllList Namespace Release Method Send Feedback
Syntax
Delphi
function Release(aIndex: Integer): Pointer; overload;
Group

Release Method

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, Release Method


TnxWriteableList.Release Method (Pointer)

TnxWriteableList.Release Method (Pointer)
TnxWriteableList Class TnxWriteableList Members nxllList Namespace Release Method Send Feedback
Syntax
Delphi
function Release(aItem: Pointer): Pointer; overload;
Group

Release Method

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, Release Method


TnxWriteableList.Remove Method

TnxWriteableList.Remove Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
function Remove(aItem: Pointer): Integer;
Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.wlGrow Method

TnxWriteableList.wlGrow Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
procedure wlGrow;
Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList.wlSetCapacity Method

TnxWriteableList.wlSetCapacity Method
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Methods Send Feedback
Syntax
Delphi
procedure wlSetCapacity(aNewCapacity: Integer);
Group

TnxWriteableList Methods

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Methods


TnxWriteableList Properties

TnxWriteableList Properties
TnxWriteableList Class Legend Public Properties Send Feedback

The properties of the TnxWriteableList class are listed here.

Class

TnxWriteableList Class

Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxWriteableList.
Links
TnxWriteableList Class, Legend, Public Properties


TnxWriteableList.Capacity Property

TnxWriteableList.Capacity Property
TnxWriteableList Class TnxWriteableList Members nxllList Namespace TnxWriteableList Properties Send Feedback
Syntax
Delphi
property Capacity: Integer;
Description

This is Capacity, a member of class TnxWriteableList.

Group

TnxWriteableList Properties

Links
TnxWriteableList Class, TnxWriteableList Members, nxllList Namespace, TnxWriteableList Properties


Functions

Functions
Functions nxllList Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
QuickSort | QuickSort
QuickSort |
Namespace

nxllList Namespace

Links
Functions, nxllList Namespace, Legend


nxllList.QuickSort Function

nxllList.QuickSort Function
nxllList Functions Send Feedback
Syntax
Delphi
function QuickSort(SortList: PnxPointerArray; DataList: PnxPointerArray; L: Integer; R: Integer; SCompare: TListSortCompare): Boolean; overload;
File

nxllList

Description

QuickSort

Group

Functions

Links
nxllList, Functions


nxllList.QuickSort Function

nxllList.QuickSort Function
nxllList Functions Send Feedback
Syntax
Delphi
function QuickSort(SortList: PnxPointerArray; DataList: PnxPointerArray; L: Integer; R: Integer; SCompare: TnxListSortCompare): Boolean; overload;
File

nxllList

Group

Functions

Links
nxllList, Functions


Types

Types
nxllList Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllList Namespace

Types
Name | Description
TnxListSortCompare | This is type nxllList.TnxListSortCompare.
TnxWriteableListClass | This is type nxllList.TnxWriteableListClass.
Links
nxllList Namespace, Types


nxllList.TnxListSortCompare Type

nxllList.TnxListSortCompare Type
nxllList Types Send Feedback
Syntax
Delphi
TnxListSortCompare = function (a, b : Pointer) : TnxValueRelationship of object;
File

nxllList

Description

This is type nxllList.TnxListSortCompare.

Group

Types

Links
nxllList, Types


nxllList.TnxWriteableListClass Type

nxllList.TnxWriteableListClass Type
nxllList Types Send Feedback
Syntax
Delphi
TnxWriteableListClass = class of TnxWriteableList;
File

nxllList

Description

This is type nxllList.TnxWriteableListClass.

Group

Types

Links
nxllList, Types


Constants

Constants
Constants nxllList Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsFindNotSupportedWhileSortingSuspended | This is constant nxllList.rsFindNotSupportedWhileSortingSuspended.
Namespace

nxllList Namespace

Links
Constants, nxllList Namespace


nxllList.rsFindNotSupportedWhileSortingSuspended Constant

nxllList.rsFindNotSupportedWhileSortingSuspended Constant
nxllList Constants Send Feedback
Syntax
Delphi
rsFindNotSupportedWhileSortingSuspended = 'Find is not supported while sorting is suspended.';
File

nxllList

Description

This is constant nxllList.rsFindNotSupportedWhileSortingSuspended.

Group

Constants

Links
nxllList, Constants


nxllLockedFuncs Namespace

nxllLockedFuncs Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

do not remove, code is not compatible with overflow checking!

Classes
Name | Description
TnxTwoPointerRec | This is class nxllLockedFuncs.TnxTwoPointerRec.
Constants
Name | Description
InitialSpinSleep | This is constant nxllLockedFuncs.InitialSpinSleep.
NextSpinSleep | This is constant nxllLockedFuncs.NextSpinSleep.
Functions
Name | Description
AddRef | This is function nxllLockedFuncs.AddRef.
BitTest |
CountedSListCount |
InitCountedSListHead | Locked Single-linked Lists
InitSListHead | Locked Single-linked Lists
LockedAdd | Locked Cardinal manipulation Locked Cardinal manipulation
LockedAdd | Locked Int64 manipulation Locked Int64 manipulation
LockedAdd | Locked Integer manipulation Locked Integer manipulation
LockedAdd |
LockedAdd |
LockedAdd | Locked Pointer manipulation Locked Pointer manipulation
LockedAdd |
LockedAdd | Locked TnxNativeInt manipulation Locked TnxNativeInt manipulation
LockedAdd | Locked TnxNativeUInt manipulation Locked TnxNativeUInt manipulation
LockedAdd | Locked UInt64 manipulation Locked UInt64 manipulation
LockedBitComplement |
LockedBitReset |
LockedBitSet | Locked bit manipulation Locked Bit manipulation
LockedCompareExchange | Locked TObject manipulation Locked TObject manipulation
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange | If Target = Comp, returns true and replaces Target with Exch, otherwise returns false and returns Target in Comp
LockedCompareExchange |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedFlushCountedSList |
LockedFlushSList |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedPopEntryCountedSList |
LockedPopEntrySList |
LockedPushEntriesSList |
LockedPushEntryCountedSList |
LockedPushEntrySList |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
Release | This is function nxllLockedFuncs.Release.
Structs, Records, Enums
Name | Description
TnxCountedListHead | This is record nxllLockedFuncs.TnxCountedListHead.
TnxListEntry | This is record nxllLockedFuncs.TnxListEntry.
TnxListHead | This is record nxllLockedFuncs.TnxListHead.
TnxStackEntry | This is record nxllLockedFuncs.TnxStackEntry.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxCountedListHead | This is type nxllLockedFuncs.PnxCountedListHead.
PnxListEntry | Locked Single-linked Lists
PnxListHead | This is type nxllLockedFuncs.PnxListHead.
PnxStackEntry | This is type nxllLockedFuncs.PnxStackEntry.
PnxTwoPointerRec | This is type nxllLockedFuncs.PnxTwoPointerRec.
Variables
Name | Description
_RefCount | This is variable nxllLockedFuncs._RefCount.
ItemIndex | This is variable nxllLockedFuncs.ItemIndex.
Mask | This is variable nxllLockedFuncs.Mask.
New | This is variable nxllLockedFuncs.New.
Old | This is variable nxllLockedFuncs.Old.
Res | This is variable nxllLockedFuncs.Res.
Segment | This is variable nxllLockedFuncs.Segment.
SegmentIndex | This is variable nxllLockedFuncs.SegmentIndex.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
nxllLockedFuncs Namespace Legend Records Send Feedback

The following table lists classes in this documentation.

Namespace

nxllLockedFuncs Namespace

Records
Name | Description
TnxTwoPointerRec | This is class nxllLockedFuncs.TnxTwoPointerRec.
Links
nxllLockedFuncs Namespace, Legend, Records


TnxTwoPointerRec Record

TnxTwoPointerRec Record
TnxTwoPointerRec Fields TnxTwoPointerRec Members nxllLockedFuncs Classes Send Feedback
Syntax
Delphi
TnxTwoPointerRec = record
  Hi: Pointer;
  Lo: Pointer;
end;
File

nxllLockedFuncs

Description

This is class nxllLockedFuncs.TnxTwoPointerRec.

Group

Classes

Links
TnxTwoPointerRec Fields, TnxTwoPointerRec Members, nxllLockedFuncs, Classes


TnxTwoPointerRec Members

TnxTwoPointerRec Members
TnxTwoPointerRec Record Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxTwoPointerRec.

Record

TnxTwoPointerRec Record

Public Fields
Name | Description
Hi | This is Hi, a member of class TnxTwoPointerRec.
Lo | This is Lo, a member of class TnxTwoPointerRec.
Public Methods
Name | Description
Create | LockedCompareExchange 16 byte
Links
TnxTwoPointerRec Record, Legend, Public Fields, Public Methods


TnxTwoPointerRec.Create Constructor

TnxTwoPointerRec.Create Constructor
TnxTwoPointerRec Record TnxTwoPointerRec Members nxllLockedFuncs Namespace TnxTwoPointerRec Record Send Feedback
Syntax
Delphi
constructor Create(aHi: Pointer; aLo: Pointer);
Description

LockedCompareExchange 16 byte

Record

TnxTwoPointerRec Record

Links
TnxTwoPointerRec Record, TnxTwoPointerRec Members, nxllLockedFuncs Namespace, TnxTwoPointerRec Record


TnxTwoPointerRec Fields

TnxTwoPointerRec Fields
TnxTwoPointerRec Record Legend Public Fields Send Feedback

The fields of the TnxTwoPointerRec class are listed here.

Record

TnxTwoPointerRec Record

Public Fields
Name | Description
Hi | This is Hi, a member of class TnxTwoPointerRec.
Lo | This is Lo, a member of class TnxTwoPointerRec.
Links
TnxTwoPointerRec Record, Legend, Public Fields


TnxTwoPointerRec.Hi Field

TnxTwoPointerRec.Hi Field
TnxTwoPointerRec Record TnxTwoPointerRec Members nxllLockedFuncs Namespace TnxTwoPointerRec Fields Send Feedback
Syntax
Delphi
Hi: Pointer;
Description

This is Hi, a member of class TnxTwoPointerRec.

Group

TnxTwoPointerRec Fields

Links
TnxTwoPointerRec Record, TnxTwoPointerRec Members, nxllLockedFuncs Namespace, TnxTwoPointerRec Fields


TnxTwoPointerRec.Lo Field

TnxTwoPointerRec.Lo Field
TnxTwoPointerRec Record TnxTwoPointerRec Members nxllLockedFuncs Namespace TnxTwoPointerRec Fields Send Feedback
Syntax
Delphi
Lo: Pointer;
Description

This is Lo, a member of class TnxTwoPointerRec.

Group

TnxTwoPointerRec Fields

Links
TnxTwoPointerRec Record, TnxTwoPointerRec Members, nxllLockedFuncs Namespace, TnxTwoPointerRec Fields


Functions

Functions
Functions nxllLockedFuncs Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllLockedFuncs.AddRef.
BitTest |
CountedSListCount |
InitCountedSListHead | Locked Single-linked Lists
InitSListHead | Locked Single-linked Lists
LockedAdd | Locked Cardinal manipulation Locked Cardinal manipulation
LockedAdd | Locked Int64 manipulation Locked Int64 manipulation
LockedAdd | Locked Integer manipulation Locked Integer manipulation
LockedAdd |
LockedAdd |
LockedAdd | Locked Pointer manipulation Locked Pointer manipulation
LockedAdd |
LockedAdd | Locked TnxNativeInt manipulation Locked TnxNativeInt manipulation
LockedAdd | Locked TnxNativeUInt manipulation Locked TnxNativeUInt manipulation
LockedAdd | Locked UInt64 manipulation Locked UInt64 manipulation
LockedBitComplement |
LockedBitReset |
LockedBitSet | Locked bit manipulation Locked Bit manipulation
LockedCompareExchange | Locked TObject manipulation Locked TObject manipulation
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange |
LockedCompareExchange | If Target = Comp, returns true and replaces Target with Exch, otherwise returns false and returns Target in Comp
LockedCompareExchange |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedDec |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchange |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeAdd |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeDec |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeInc |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedExchangeSub |
LockedFlushCountedSList |
LockedFlushSList |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedInc |
LockedPopEntryCountedSList |
LockedPopEntrySList |
LockedPushEntriesSList |
LockedPushEntryCountedSList |
LockedPushEntrySList |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
LockedSub |
Release | This is function nxllLockedFuncs.Release.
Namespace

nxllLockedFuncs Namespace

Links
Functions, nxllLockedFuncs Namespace, Legend


nxllLockedFuncs.AddRef Function

nxllLockedFuncs.AddRef Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllLockedFuncs

Description

This is function nxllLockedFuncs.AddRef.

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.BitTest Function

nxllLockedFuncs.BitTest Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function BitTest(var Bits; Bit: TnxNativeUInt): Boolean;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.CountedSListCount Function

nxllLockedFuncs.CountedSListCount Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function CountedSListCount(aCountedListHead: PnxCountedListHead): TnxNativeHalfUInt; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.InitCountedSListHead Function

nxllLockedFuncs.InitCountedSListHead Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure InitCountedSListHead(aCountedListHead: PnxCountedListHead); register;
File

nxllLockedFuncs

Description

Locked Single-linked Lists

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.InitSListHead Function

nxllLockedFuncs.InitSListHead Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure InitSListHead(aListHead: PnxListHead); register;
File

nxllLockedFuncs

Description

Locked Single-linked Lists

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Cardinal; Value: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Description

Locked Cardinal manipulation

Locked Cardinal manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Int64; Value: Int64): Int64; register; overload;
File

nxllLockedFuncs

Description

Locked Int64 manipulation

Locked Int64 manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Integer; Value: Integer): Integer; register; overload;
File

nxllLockedFuncs

Description

Locked Integer manipulation

Locked Integer manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Pointer; Value: Cardinal): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Pointer; Value: Int64): Pointer; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Pointer; Value: Integer): Pointer; register; overload;
File

nxllLockedFuncs

Description

Locked Pointer manipulation

Locked Pointer manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: Pointer; Value: UInt64): Pointer; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: TnxNativeInt; Value: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Description

Locked TnxNativeInt manipulation

Locked TnxNativeInt manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: TnxNativeUInt; Value: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Description

Locked TnxNativeUInt manipulation

Locked TnxNativeUInt manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedAdd Function

nxllLockedFuncs.LockedAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedAdd(var Target: UInt64; Value: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Description

Locked UInt64 manipulation

Locked UInt64 manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedBitComplement Function

nxllLockedFuncs.LockedBitComplement Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedBitComplement(var Bits; Bit: TnxNativeUInt): Boolean;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedBitReset Function

nxllLockedFuncs.LockedBitReset Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedBitReset(var Bits; Bit: TnxNativeUInt): Boolean;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedBitSet Function

nxllLockedFuncs.LockedBitSet Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedBitSet(var Bits; Bit: TnxNativeUInt): Boolean;
File

nxllLockedFuncs

Description

Locked bit manipulation

Locked Bit manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target; Exch: TObject; Comp: TObject): TObject; register; overload;
File

nxllLockedFuncs

Description

Locked TObject manipulation

Locked TObject manipulation

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: Cardinal; Exch: Cardinal; Comp: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: Int64; Exch: Int64; Comp: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: Integer; Exch: Integer; Comp: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: Pointer; Exch: Pointer; Comp: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: TnxNativeInt; Exch: TnxNativeInt; Comp: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: TnxNativeUInt; Exch: TnxNativeUInt; Comp: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: TnxTwoPointerRec; const Exch: TnxTwoPointerRec; var Comp: TnxTwoPointerRec): Boolean; overload;
File

nxllLockedFuncs

Description

If Target = Comp, returns true and replaces Target with Exch, otherwise returns false and returns Target in Comp

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedCompareExchange Function

nxllLockedFuncs.LockedCompareExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedCompareExchange(var Target: UInt64; Exch: UInt64; Comp: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedDec Function

nxllLockedFuncs.LockedDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedDec(var Target: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: Cardinal; Value: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: Int64; Value: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: Integer; Value: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: Pointer; Value: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: TnxNativeInt; Value: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: TnxNativeUInt; Value: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchange Function

nxllLockedFuncs.LockedExchange Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchange(var Target: UInt64; Value: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: Cardinal; Value: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: Int64; Value: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: Integer; Value: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: Pointer; Value: Cardinal): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: Pointer; Value: Integer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: TnxNativeInt; Value: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: TnxNativeUInt; Value: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeAdd Function

nxllLockedFuncs.LockedExchangeAdd Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeAdd(var Target: UInt64; Value: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeDec Function

nxllLockedFuncs.LockedExchangeDec Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeDec(var Target: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeInc Function

nxllLockedFuncs.LockedExchangeInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeInc(var Target: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: Cardinal; Value: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: Int64; Value: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: Integer; Value: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: Pointer; Value: Cardinal): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: Pointer; Value: Integer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: TnxNativeInt; Value: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: TnxNativeUInt; Value: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedExchangeSub Function

nxllLockedFuncs.LockedExchangeSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedExchangeSub(var Target: UInt64; Value: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedFlushCountedSList Function

nxllLockedFuncs.LockedFlushCountedSList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedFlushCountedSList(aCountedListHead: PnxCountedListHead): PnxListEntry; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedFlushSList Function

nxllLockedFuncs.LockedFlushSList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedFlushSList(aListHead: PnxListHead): PnxListEntry; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: Pointer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedInc Function

nxllLockedFuncs.LockedInc Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedInc(var Target: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedPopEntryCountedSList Function

nxllLockedFuncs.LockedPopEntryCountedSList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedPopEntryCountedSList(aCountedListHead: PnxCountedListHead; aMinCount: TnxNativeHalfUInt = 0): PnxListEntry; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedPopEntrySList Function

nxllLockedFuncs.LockedPopEntrySList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedPopEntrySList(aListHead: PnxListHead): PnxListEntry; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedPushEntriesSList Function

nxllLockedFuncs.LockedPushEntriesSList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure LockedPushEntriesSList(aListHead: PnxListHead; aFirstListEntry: PnxListEntry; aLastListEntry: PnxListEntry); register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedPushEntryCountedSList Function

nxllLockedFuncs.LockedPushEntryCountedSList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedPushEntryCountedSList(aCountedListHead: PnxCountedListHead; aListEntry: PnxListEntry; aMaxCount: TnxNativeHalfUInt = Pred(High(TnxNativeHalfUInt))): TnxNativeHalfUInt; register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedPushEntrySList Function

nxllLockedFuncs.LockedPushEntrySList Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure LockedPushEntrySList(aListHead: PnxListHead; aListEntry: PnxListEntry); register;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: Cardinal; Value: Cardinal): Cardinal; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: Int64; Value: Int64): Int64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: Integer; Value: Integer): Integer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: Pointer; Value: Cardinal): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: Pointer; Value: Integer): Pointer; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: TnxNativeInt; Value: TnxNativeInt): TnxNativeInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: TnxNativeUInt; Value: TnxNativeUInt): TnxNativeUInt; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.LockedSub Function

nxllLockedFuncs.LockedSub Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
function LockedSub(var Target: UInt64; Value: UInt64): UInt64; register; overload;
File

nxllLockedFuncs

Group

Functions

Links
nxllLockedFuncs, Functions


nxllLockedFuncs.Release Function

nxllLockedFuncs.Release Function
nxllLockedFuncs Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllLockedFuncs

Description

This is function nxllLockedFuncs.Release.

Group

Functions

Links
nxllLockedFuncs, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllLockedFuncs Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllLockedFuncs Namespace

Records
Name | Description
TnxCountedListHead | This is record nxllLockedFuncs.TnxCountedListHead.
TnxListEntry | This is record nxllLockedFuncs.TnxListEntry.
TnxListHead | This is record nxllLockedFuncs.TnxListHead.
TnxStackEntry | This is record nxllLockedFuncs.TnxStackEntry.
Links
nxllLockedFuncs Namespace, Legend, Records


nxllLockedFuncs.TnxCountedListHead Record

nxllLockedFuncs.TnxCountedListHead Record
nxllLockedFuncs Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCountedListHead = record
  clhFirst: PnxListEntry;
  clhSequence: TnxNativeHalfUInt;
  clhCount: TnxNativeHalfUInt;
end;
File

nxllLockedFuncs

Description

This is record nxllLockedFuncs.TnxCountedListHead.

Group

Structs, Records, Enums

Links
nxllLockedFuncs, Structs, Records, Enums


nxllLockedFuncs.TnxListEntry Record

nxllLockedFuncs.TnxListEntry Record
nxllLockedFuncs Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxListEntry = packed record
  leNext: PnxListEntry;
end;
File

nxllLockedFuncs

Description

This is record nxllLockedFuncs.TnxListEntry.

Group

Structs, Records, Enums

Links
nxllLockedFuncs, Structs, Records, Enums


nxllLockedFuncs.TnxListHead Record

nxllLockedFuncs.TnxListHead Record
nxllLockedFuncs Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxListHead = record
  lhFirst: PnxListEntry;
  lhSequence: TnxNativeUInt;
end;
File

nxllLockedFuncs

Description

This is record nxllLockedFuncs.TnxListHead.

Group

Structs, Records, Enums

Links
nxllLockedFuncs, Structs, Records, Enums


nxllLockedFuncs.TnxStackEntry Record

nxllLockedFuncs.TnxStackEntry Record
nxllLockedFuncs Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStackEntry = record
  seListEntry: TnxListEntry;
  seData: Pointer;
end;
File

nxllLockedFuncs

Description

This is record nxllLockedFuncs.TnxStackEntry.

Group

Structs, Records, Enums

Links
nxllLockedFuncs, Structs, Records, Enums


Types

Types
nxllLockedFuncs Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllLockedFuncs Namespace

Types
Name | Description
PnxCountedListHead | This is type nxllLockedFuncs.PnxCountedListHead.
PnxListEntry | Locked Single-linked Lists
PnxListHead | This is type nxllLockedFuncs.PnxListHead.
PnxStackEntry | This is type nxllLockedFuncs.PnxStackEntry.
PnxTwoPointerRec | This is type nxllLockedFuncs.PnxTwoPointerRec.
Links
nxllLockedFuncs Namespace, Types


nxllLockedFuncs.PnxCountedListHead Type

nxllLockedFuncs.PnxCountedListHead Type
nxllLockedFuncs Types Send Feedback
Syntax
Delphi
PnxCountedListHead = ^TnxCountedListHead;
File

nxllLockedFuncs

Description

This is type nxllLockedFuncs.PnxCountedListHead.

Group

Types

Links
nxllLockedFuncs, Types


nxllLockedFuncs.PnxListEntry Type

nxllLockedFuncs.PnxListEntry Type
nxllLockedFuncs Types Send Feedback
Syntax
Delphi
PnxListEntry = ^TnxListEntry;
File

nxllLockedFuncs

Description

Locked Single-linked Lists

Group

Types

Links
nxllLockedFuncs, Types


nxllLockedFuncs.PnxListHead Type

nxllLockedFuncs.PnxListHead Type
nxllLockedFuncs Types Send Feedback
Syntax
Delphi
PnxListHead = ^TnxListHead;
File

nxllLockedFuncs

Description

This is type nxllLockedFuncs.PnxListHead.

Group

Types

Links
nxllLockedFuncs, Types


nxllLockedFuncs.PnxStackEntry Type

nxllLockedFuncs.PnxStackEntry Type
nxllLockedFuncs Types Send Feedback
Syntax
Delphi
PnxStackEntry = ^TnxStackEntry;
File

nxllLockedFuncs

Description

This is type nxllLockedFuncs.PnxStackEntry.

Group

Types

Links
nxllLockedFuncs, Types


nxllLockedFuncs.PnxTwoPointerRec Type

nxllLockedFuncs.PnxTwoPointerRec Type
nxllLockedFuncs Types Send Feedback
Syntax
Delphi
PnxTwoPointerRec = ^TnxTwoPointerRec;
File

nxllLockedFuncs

Description

This is type nxllLockedFuncs.PnxTwoPointerRec.

Group

Types

Links
nxllLockedFuncs, Types


Variables

Variables
nxllLockedFuncs Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllLockedFuncs Namespace

Variables
Name | Description
_RefCount | This is variable nxllLockedFuncs._RefCount.
ItemIndex | This is variable nxllLockedFuncs.ItemIndex.
Mask | This is variable nxllLockedFuncs.Mask.
New | This is variable nxllLockedFuncs.New.
Old | This is variable nxllLockedFuncs.Old.
Res | This is variable nxllLockedFuncs.Res.
Segment | This is variable nxllLockedFuncs.Segment.
SegmentIndex | This is variable nxllLockedFuncs.SegmentIndex.
Links
nxllLockedFuncs Namespace, Variables


nxllLockedFuncs._RefCount Variable

nxllLockedFuncs._RefCount Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs._RefCount.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.ItemIndex Variable

nxllLockedFuncs.ItemIndex Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
ItemIndex: TnxNativeUInt;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.ItemIndex.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.Mask Variable

nxllLockedFuncs.Mask Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
Mask: Cardinal;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.Mask.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.New Variable

nxllLockedFuncs.New Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
New: Cardinal;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.New.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.Old Variable

nxllLockedFuncs.Old Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
Old: Cardinal;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.Old.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.Res Variable

nxllLockedFuncs.Res Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
Res: Cardinal;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.Res.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.Segment Variable

nxllLockedFuncs.Segment Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
Segment: PCardinal;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.Segment.

Group

Variables

Links
nxllLockedFuncs, Variables


nxllLockedFuncs.SegmentIndex Variable

nxllLockedFuncs.SegmentIndex Variable
nxllLockedFuncs Variables Send Feedback
Syntax
Delphi
SegmentIndex: TnxNativeUInt;
File

nxllLockedFuncs

Description

This is variable nxllLockedFuncs.SegmentIndex.

Group

Variables

Links
nxllLockedFuncs, Variables


Constants

Constants
Constants nxllLockedFuncs Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
InitialSpinSleep | This is constant nxllLockedFuncs.InitialSpinSleep.
NextSpinSleep | This is constant nxllLockedFuncs.NextSpinSleep.
Namespace

nxllLockedFuncs Namespace

Links
Constants, nxllLockedFuncs Namespace


nxllLockedFuncs.InitialSpinSleep Constant

nxllLockedFuncs.InitialSpinSleep Constant
nxllLockedFuncs Constants Send Feedback
Syntax
Delphi
InitialSpinSleep = 0;
File

nxllLockedFuncs

Description

This is constant nxllLockedFuncs.InitialSpinSleep.

Group

Constants

Links
nxllLockedFuncs, Constants


nxllLockedFuncs.NextSpinSleep Constant

nxllLockedFuncs.NextSpinSleep Constant
nxllLockedFuncs Constants Send Feedback
Syntax
Delphi
NextSpinSleep = 1;
File

nxllLockedFuncs

Description

This is constant nxllLockedFuncs.NextSpinSleep.

Group

Constants

Links
nxllLockedFuncs, Constants


nxllMemoryManager Namespace

nxllMemoryManager Namespace
Classes Constants Functions Interfaces Legend Topics Types Variables Send Feedback

This is namespace nxllMemoryManager.

Classes
Name | Description
TnxAggregatableObject | This is class nxllMemoryManager.TnxAggregatableObject.
TnxAggregateableMultiIQ | This is class nxllMemoryManager.TnxAggregateableMultiIQ.
TnxAggregationHost | This is class nxllMemoryManager.TnxAggregationHost.
TnxBlockPoolCommitted | This is class nxllMemoryManager.TnxBlockPoolCommitted.
TnxBlockPoolPhysical | This is class nxllMemoryManager.TnxBlockPoolPhysical.
TnxInterfacedObject | This is class nxllMemoryManager.TnxInterfacedObject.
TnxLifetimeMonitor | TnxLifetimeMonitor
TnxLifetimeTrackedObject | This is class nxllMemoryManager.TnxLifetimeTrackedObject.
TnxLowInterfacedObject | This is class nxllMemoryManager.TnxLowInterfacedObject.
TnxLowObject | This is class nxllMemoryManager.TnxLowObject.
TnxMemoryPool | This is class nxllMemoryManager.TnxMemoryPool.
TnxObject | HPPEMIT 'namespace Nxllmemorymanager' HPPEMIT '{' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxObject;' HPPEMIT 'class PASCALIMPLEMENTATION TnxObject : public System::TObject' HPPEMIT '{' HPPEMIT ' typedef System::TObject inherited;' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' virtual __classmethod System::TObject* __fastcall NewInstance();' HPPEMIT ' #pragma option pop' HPPEMIT ' ///* class method */ static System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' virtual void __fastcall FreeInstance(void);' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* TObject.Create */ inline __fastcall TnxObject(void) : System::TObject() { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT '... more
Constants
Name | Description
_BlockSizes | This is constant nxllMemoryManager._BlockSizes.
_PagesPerBlock | This is constant nxllMemoryManager._PagesPerBlock.
Functions
Name | Description
AddRef | This is function nxllMemoryManager.AddRef.
nxBeginSecureFreeMem |
nxChunkEmergency |
nxCreateLifetimeMonitor |
nxEndSecureFreeMem |
nxForceCleanup |
nxFreeAndNil |
nxFreeMem |
nxFreeMemDirect |
nxGetAllocSize |
nxGetHeapStatus |
nxGetLicenseKeyStatus |
nxGetMem |
nxGetMem |
nxGetMemLow |
nxGetPool |
nxGetZeroMem |
nxGetZeroMem |
nxHeapAddRef |
nxHeapRelease |
nxIntfNil |
nxIsAWEAvailable |
nxIsAWESupported |
nxLicenseHasFeature |
nxMapableBlockAllocate | Allocates a new block of the requested size. raises exception on error
nxMapableBlockDispose | Disposes a block, raises exception on error
nxMapableBlockLock | Maps a block into the virtual address space, raises exception on error
nxMapableBlocksAllocate | HPPEMIT 'class DELPHICLASS TnxMapableBlockHandle; //Forward declaration HPPEMIT 'class DELPHICLASS TnxMapableBlockHandles; //Forward declaration HPPEMIT 'extern PACKAGE TnxMapableBlockHandles* __fastcall nxMapableBlocksAllocate(Nxlltypes::TnxBlockSizeAll aBlockSize); //incorrect return type?
nxMapableBlocksLock | Maps an array of blocks into the virtual address space, raises exception on error
nxMapableBlocksUnlock | Unmaps an array of blocks, raises exception on error
nxMapableBlockUnlock | Unmaps a block, raises exception on error
nxPhysicalEmergency |
nxReallocMem |
Release | This is function nxllMemoryManager.Release.
Interfaces
Name | Description
InxLifetimeMonitorObject | This is class nxllMemoryManager.InxLifetimeMonitorObject.
InxLifetimeMonitorRef | This is class nxllMemoryManager.InxLifetimeMonitorRef.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxLicenseHasFeature |
TnxMapableBlockHandle | This is type nxllMemoryManager.TnxMapableBlockHandle.
TnxMapableBlockHandles | This is type nxllMemoryManager.TnxMapableBlockHandles.
Variables
Name | Description
_ChunkEmergencyCommitted | don't use directly! use nxChunkEmergency
_ChunkEmergencyPhysical | don't use directly! use nxChunkEmergency
_CountObjectInstance | This is variable nxllMemoryManager._CountObjectInstance.
_ForceCleanup |
_HeapAddRef |
_HeapRelease | This is variable nxllMemoryManager._HeapRelease.
_LicenseHasFeature | This is variable nxllMemoryManager._LicenseHasFeature.
_LicenseKeyStatus |
_nxFillChar | This is variable nxllMemoryManager._nxFillChar.
_nxGetAllocSize | This is variable nxllMemoryManager._nxGetAllocSize.
_nxGetHeapStatus | This is variable nxllMemoryManager._nxGetHeapStatus.
_nxGetMemLow |
_nxGetPool |
_nxMapableBlockAllocate |
_nxMapableBlockDispose | This is variable nxllMemoryManager._nxMapableBlockDispose.
_nxMapableBlockLock | This is variable nxllMemoryManager._nxMapableBlockLock.
_nxMapableBlocksLock | This is variable nxllMemoryManager._nxMapableBlocksLock.
_nxMapableBlocksUnlock | This is variable nxllMemoryManager._nxMapableBlocksUnlock.
_nxMapableBlockUnlock | This is variable nxllMemoryManager._nxMapableBlockUnlock.
_nxMemoryManager | This is variable nxllMemoryManager._nxMemoryManager.
_nxSecureFreeMem |
_PhysicalEmergency | This is variable nxllMemoryManager._PhysicalEmergency.
_RefCount |
_TnxBlockPoolCommitted_Alloc | TnxBlockPoolCommitted
_TnxBlockPoolCommitted_Dispose | This is variable nxllMemoryManager._TnxBlockPoolCommitted_Dispose.
_TnxBlockPoolPhysical_Alloc | TnxBlockPoolPhysical
_TnxBlockPoolPhysical_Dispose | This is variable nxllMemoryManager._TnxBlockPoolPhysical_Dispose.
_TnxMemoryPool_Alloc | TnxMemoryPool
_TnxMemoryPool_Dispose | This is variable nxllMemoryManager._TnxMemoryPool_Dispose.
BlockPools | This is variable nxllMemoryManager.BlockPools.
BlockPoolsPhysical | This is variable nxllMemoryManager.BlockPoolsPhysical.
EmptyBlock | empty 64kB block, read-only
FileMappingHandle |
nxAWEAvailable | This is variable nxllMemoryManager.nxAWEAvailable.
nxAWESupported | This is variable nxllMemoryManager.nxAWESupported.
q | This is variable nxllMemoryManager.q.
Links
Classes, Constants, Functions, Interfaces, Legend, Topics, Types, Variables


Classes

Classes
Classes nxllMemoryManager Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAggregatableObject | This is class nxllMemoryManager.TnxAggregatableObject.
TnxAggregateableMultiIQ | This is class nxllMemoryManager.TnxAggregateableMultiIQ.
TnxAggregationHost | This is class nxllMemoryManager.TnxAggregationHost.
TnxBlockPoolCommitted | This is class nxllMemoryManager.TnxBlockPoolCommitted.
TnxBlockPoolPhysical | This is class nxllMemoryManager.TnxBlockPoolPhysical.
TnxInterfacedObject | This is class nxllMemoryManager.TnxInterfacedObject.
TnxLifetimeMonitor | TnxLifetimeMonitor
TnxLifetimeTrackedObject | This is class nxllMemoryManager.TnxLifetimeTrackedObject.
TnxLowInterfacedObject | This is class nxllMemoryManager.TnxLowInterfacedObject.
TnxLowObject | This is class nxllMemoryManager.TnxLowObject.
TnxMemoryPool | This is class nxllMemoryManager.TnxMemoryPool.
TnxObject | HPPEMIT 'namespace Nxllmemorymanager' HPPEMIT '{' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxObject;' HPPEMIT 'class PASCALIMPLEMENTATION TnxObject : public System::TObject' HPPEMIT '{' HPPEMIT ' typedef System::TObject inherited;' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' virtual __classmethod System::TObject* __fastcall NewInstance();' HPPEMIT ' #pragma option pop' HPPEMIT ' ///* class method */ static System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' virtual void __fastcall FreeInstance(void);' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* TObject.Create */ inline __fastcall TnxObject(void) : System::TObject() { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT '... more
Namespace

nxllMemoryManager Namespace

Links
Classes, nxllMemoryManager Namespace, Legend


TnxAggregatableObject Class

TnxAggregatableObject Class
TnxAggregatableObject Fields TnxAggregatableObject Methods TnxAggregatableObject Properties TnxAggregatableObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxAggregatableObjectnxllMemoryManager_TnxAggregatableObjectnxllMemoryManager_TnxAggregatableObject
Syntax
Delphi
TnxAggregatableObject = class(TnxInterfacedObject, InxInterface);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxAggregatableObject.

Group

Classes

Links
TnxAggregatableObject Fields, TnxAggregatableObject Methods, TnxAggregatableObject Properties, TnxAggregatableObject Members, nxllMemoryManager, Classes


TnxAggregatableObject Members

TnxAggregatableObject Members
TnxAggregatableObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAggregatableObject.

Class

TnxAggregatableObject Class

Protected Fields
Name | Description
aoHost | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef |
_Release |
aoGetHost | TnxAggregatableObject
InternalAddRef |
InternalQueryInterface |
InternalRelease |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxAggregatableObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAggregatableObject.Create Constructor

TnxAggregatableObject.Create Constructor
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Class Send Feedback
Syntax
Delphi
constructor Create(const aHost: InxInterface; aKeepAlive: Boolean = False);
Class

TnxAggregatableObject Class

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Class


TnxAggregatableObject Fields

TnxAggregatableObject Fields
TnxAggregatableObject Class Legend Protected Fields Send Feedback

The fields of the TnxAggregatableObject class are listed here.

Class

TnxAggregatableObject Class

Protected Fields
Name | Description
aoHost | private
Links
TnxAggregatableObject Class, Legend, Protected Fields


TnxAggregatableObject.aoHost Field

TnxAggregatableObject.aoHost Field
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Fields Send Feedback
Syntax
Delphi
aoHost: Pointer;
Description

private

Group

TnxAggregatableObject Fields

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Fields


TnxAggregatableObject Methods

TnxAggregatableObject Methods
TnxAggregatableObject Class Legend Protected Methods Send Feedback

The methods of the TnxAggregatableObject class are listed here.

Class

TnxAggregatableObject Class

Protected Methods
Name | Description
_AddRef |
_Release |
aoGetHost | TnxAggregatableObject
InternalAddRef |
InternalQueryInterface |
InternalRelease |
QueryInterface |
Links
TnxAggregatableObject Class, Legend, Protected Methods


TnxAggregatableObject._AddRef Method

TnxAggregatableObject._AddRef Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; virtual; stdcall;
Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject._Release Method

TnxAggregatableObject._Release Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function _Release: Integer; virtual; stdcall;
Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject.aoGetHost Method

TnxAggregatableObject.aoGetHost Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function aoGetHost: InxInterface;
Description

TnxAggregatableObject

Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject.InternalAddRef Method

TnxAggregatableObject.InternalAddRef Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function InternalAddRef: Integer; virtual; stdcall;
Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject.InternalQueryInterface Method

TnxAggregatableObject.InternalQueryInterface Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function InternalQueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall;
Description
-- InxInterface methods ONLY for InxInterface --

Override this InternalQueryInterface method to add additional interfaces

Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject.InternalRelease Method

TnxAggregatableObject.InternalRelease Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function InternalRelease: Integer; virtual; stdcall;
Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject.QueryInterface Method

TnxAggregatableObject.QueryInterface Method
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall;
Description
-- InxInterface methods for all interfaces EXCEPT InxInterface --

Do NOT override this QueryInterface to add additional interfaces, it will mess with aggregated objects support.

Group

TnxAggregatableObject Methods

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Methods


TnxAggregatableObject Properties

TnxAggregatableObject Properties
TnxAggregatableObject Class Legend Public Properties Send Feedback

The properties of the TnxAggregatableObject class are listed here.

Class

TnxAggregatableObject Class

Public Properties
Name | Description
Host | This is Host, a member of class TnxAggregatableObject.
Links
TnxAggregatableObject Class, Legend, Public Properties


TnxAggregatableObject.Host Property

TnxAggregatableObject.Host Property
TnxAggregatableObject Class TnxAggregatableObject Members nxllMemoryManager Namespace TnxAggregatableObject Properties Send Feedback
Syntax
Delphi
property Host: InxInterface;
Description

This is Host, a member of class TnxAggregatableObject.

Group

TnxAggregatableObject Properties

Links
TnxAggregatableObject Class, TnxAggregatableObject Members, nxllMemoryManager Namespace, TnxAggregatableObject Properties


TnxAggregateableMultiIQ Class

TnxAggregateableMultiIQ Class
TnxAggregateableMultiIQ Methods TnxAggregateableMultiIQ Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxAggregateableMultiIQnxllMemoryManager_TnxAggregateableMultiIQnxllMemoryManager_TnxAggregateableMultiIQnxllMemoryManager_TnxAggregateableMultiIQnxllMemoryManager_TnxAggregateableMultiIQ
Syntax
Delphi
TnxAggregateableMultiIQ = class(TnxAggregatableObject, IMultiQI);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxAggregateableMultiIQ.

Group

Classes

Links
TnxAggregateableMultiIQ Methods, TnxAggregateableMultiIQ Members, nxllMemoryManager, Classes


TnxAggregateableMultiIQ Members

TnxAggregateableMultiIQ Members
TnxAggregateableMultiIQ Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAggregateableMultiIQ.

Class

TnxAggregateableMultiIQ Class

Protected Fields
Name | Description
aoHost | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
InternalAddRef |
InternalQueryInterface |
InternalRelease |
ioDeactivate |
QueryInterface |
QueryInterface |
QueryMultipleInterfaces | IMultiQI TnxAggregateableMultiIQ
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxAggregateableMultiIQ Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAggregateableMultiIQ Methods

TnxAggregateableMultiIQ Methods
TnxAggregateableMultiIQ Class Legend Protected Methods Send Feedback

The methods of the TnxAggregateableMultiIQ class are listed here.

Class

TnxAggregateableMultiIQ Class

Protected Methods
Name | Description
QueryMultipleInterfaces | IMultiQI TnxAggregateableMultiIQ
Links
TnxAggregateableMultiIQ Class, Legend, Protected Methods


TnxAggregateableMultiIQ.QueryMultipleInterfaces Method

TnxAggregateableMultiIQ.QueryMultipleInterfaces Method
TnxAggregateableMultiIQ Class TnxAggregateableMultiIQ Members nxllMemoryManager Namespace TnxAggregateableMultiIQ Methods Send Feedback
Syntax
Delphi
function QueryMultipleInterfaces(cMQIs: Cardinal; pMQIs: PMULTI_QI): HRESULT; stdcall;
Description

IMultiQI

TnxAggregateableMultiIQ

Group

TnxAggregateableMultiIQ Methods

Links
TnxAggregateableMultiIQ Class, TnxAggregateableMultiIQ Members, nxllMemoryManager Namespace, TnxAggregateableMultiIQ Methods


TnxAggregationHost Class

TnxAggregationHost Class
TnxAggregationHost Fields TnxAggregationHost Methods TnxAggregationHost Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxAggregationHostnxllMemoryManager_TnxAggregationHostnxllMemoryManager_TnxAggregationHost
Syntax
Delphi
TnxAggregationHost = class(TnxInterfacedObject, InxInterface);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxAggregationHost.

Group

Classes

Links
TnxAggregationHost Fields, TnxAggregationHost Methods, TnxAggregationHost Members, nxllMemoryManager, Classes


TnxAggregationHost Members

TnxAggregationHost Members
TnxAggregationHost Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAggregationHost.

Class

TnxAggregationHost Class

Protected Fields
Name | Description
ahAggregatedInterfaces | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ahAddAggregatedInterface | TnxAggregationHost
ioDeactivate |
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxAggregationHost Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAggregationHost Fields

TnxAggregationHost Fields
TnxAggregationHost Class Legend Protected Fields Send Feedback

The fields of the TnxAggregationHost class are listed here.

Class

TnxAggregationHost Class

Protected Fields
Name | Description
ahAggregatedInterfaces | private
Links
TnxAggregationHost Class, Legend, Protected Fields


TnxAggregationHost.ahAggregatedInterfaces Field

TnxAggregationHost.ahAggregatedInterfaces Field
TnxAggregationHost Class TnxAggregationHost Members nxllMemoryManager Namespace TnxAggregationHost Fields Send Feedback
Syntax
Delphi
ahAggregatedInterfaces: array of InxInterface;
Description

private

Group

TnxAggregationHost Fields

Links
TnxAggregationHost Class, TnxAggregationHost Members, nxllMemoryManager Namespace, TnxAggregationHost Fields


TnxAggregationHost Methods

TnxAggregationHost Methods
TnxAggregationHost Class Legend Protected Methods Send Feedback

The methods of the TnxAggregationHost class are listed here.

Class

TnxAggregationHost Class

Protected Methods
Name | Description
ahAddAggregatedInterface | TnxAggregationHost
QueryInterface | InxInterface
Links
TnxAggregationHost Class, Legend, Protected Methods


TnxAggregationHost.ahAddAggregatedInterface Method

TnxAggregationHost.ahAddAggregatedInterface Method
TnxAggregationHost Class TnxAggregationHost Members nxllMemoryManager Namespace TnxAggregationHost Methods Send Feedback
Syntax
Delphi
procedure ahAddAggregatedInterface(const aInterface: InxInterface);
Description

TnxAggregationHost

Group

TnxAggregationHost Methods

Links
TnxAggregationHost Class, TnxAggregationHost Members, nxllMemoryManager Namespace, TnxAggregationHost Methods


TnxAggregationHost.QueryInterface Method

TnxAggregationHost.QueryInterface Method
TnxAggregationHost Class TnxAggregationHost Members nxllMemoryManager Namespace TnxAggregationHost Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxAggregationHost Methods

Links
TnxAggregationHost Class, TnxAggregationHost Members, nxllMemoryManager Namespace, TnxAggregationHost Methods


TnxBlockPoolCommitted Class

TnxBlockPoolCommitted Class
TnxBlockPoolCommitted Methods TnxBlockPoolCommitted Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxBlockPoolCommitted
Syntax
Delphi
TnxBlockPoolCommitted = class(TObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxBlockPoolCommitted.

Group

Classes

Links
TnxBlockPoolCommitted Methods, TnxBlockPoolCommitted Members, nxllMemoryManager, Classes


TnxBlockPoolCommitted Members

TnxBlockPoolCommitted Members
TnxBlockPoolCommitted Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxBlockPoolCommitted.

Class

TnxBlockPoolCommitted Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxBlockPoolCommitted Class, Legend, Public Methods


TnxBlockPoolCommitted Methods

TnxBlockPoolCommitted Methods
TnxBlockPoolCommitted Class Legend Public Methods Send Feedback

The methods of the TnxBlockPoolCommitted class are listed here.

Class

TnxBlockPoolCommitted Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxBlockPoolCommitted Class, Legend, Public Methods


TnxBlockPoolCommitted.Alloc Method

TnxBlockPoolCommitted.Alloc Method
TnxBlockPoolCommitted Class TnxBlockPoolCommitted Members nxllMemoryManager Namespace TnxBlockPoolCommitted Methods Send Feedback
Syntax
Delphi
function Alloc(aLow: Boolean = False): Pointer; register;
Group

TnxBlockPoolCommitted Methods

Links
TnxBlockPoolCommitted Class, TnxBlockPoolCommitted Members, nxllMemoryManager Namespace, TnxBlockPoolCommitted Methods


TnxBlockPoolCommitted.Dispose Method

TnxBlockPoolCommitted.Dispose Method
TnxBlockPoolCommitted Class TnxBlockPoolCommitted Members nxllMemoryManager Namespace TnxBlockPoolCommitted Methods Send Feedback
Syntax
Delphi
procedure Dispose(var P); register;
Parameters
Parameters | Description
var P | : Pointer : Pointer
Group

TnxBlockPoolCommitted Methods

Links
TnxBlockPoolCommitted Class, TnxBlockPoolCommitted Members, nxllMemoryManager Namespace, TnxBlockPoolCommitted Methods


TnxBlockPoolCommitted.DisposeDirect Method

TnxBlockPoolCommitted.DisposeDirect Method
TnxBlockPoolCommitted Class TnxBlockPoolCommitted Members nxllMemoryManager Namespace TnxBlockPoolCommitted Methods Send Feedback
Syntax
Delphi
procedure DisposeDirect(P: Pointer); register;
Group

TnxBlockPoolCommitted Methods

Links
TnxBlockPoolCommitted Class, TnxBlockPoolCommitted Members, nxllMemoryManager Namespace, TnxBlockPoolCommitted Methods


TnxBlockPoolPhysical Class

TnxBlockPoolPhysical Class
TnxBlockPoolPhysical Methods TnxBlockPoolPhysical Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxBlockPoolPhysical
Syntax
Delphi
TnxBlockPoolPhysical = class(TObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxBlockPoolPhysical.

Group

Classes

Links
TnxBlockPoolPhysical Methods, TnxBlockPoolPhysical Members, nxllMemoryManager, Classes


TnxBlockPoolPhysical Members

TnxBlockPoolPhysical Members
TnxBlockPoolPhysical Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxBlockPoolPhysical.

Class

TnxBlockPoolPhysical Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxBlockPoolPhysical Class, Legend, Public Methods


TnxBlockPoolPhysical Methods

TnxBlockPoolPhysical Methods
TnxBlockPoolPhysical Class Legend Public Methods Send Feedback

The methods of the TnxBlockPoolPhysical class are listed here.

Class

TnxBlockPoolPhysical Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxBlockPoolPhysical Class, Legend, Public Methods


TnxBlockPoolPhysical.Alloc Method

TnxBlockPoolPhysical.Alloc Method
TnxBlockPoolPhysical Class TnxBlockPoolPhysical Members nxllMemoryManager Namespace TnxBlockPoolPhysical Methods Send Feedback
Syntax
Delphi
function Alloc(aLow: Boolean = False): Pointer; register;
Group

TnxBlockPoolPhysical Methods

Links
TnxBlockPoolPhysical Class, TnxBlockPoolPhysical Members, nxllMemoryManager Namespace, TnxBlockPoolPhysical Methods


TnxBlockPoolPhysical.Dispose Method

TnxBlockPoolPhysical.Dispose Method
TnxBlockPoolPhysical Class TnxBlockPoolPhysical Members nxllMemoryManager Namespace TnxBlockPoolPhysical Methods Send Feedback
Syntax
Delphi
procedure Dispose(var P); register;
Parameters
Parameters | Description
var P | : Pointer : Pointer
Group

TnxBlockPoolPhysical Methods

Links
TnxBlockPoolPhysical Class, TnxBlockPoolPhysical Members, nxllMemoryManager Namespace, TnxBlockPoolPhysical Methods


TnxBlockPoolPhysical.DisposeDirect Method

TnxBlockPoolPhysical.DisposeDirect Method
TnxBlockPoolPhysical Class TnxBlockPoolPhysical Members nxllMemoryManager Namespace TnxBlockPoolPhysical Methods Send Feedback
Syntax
Delphi
procedure DisposeDirect(P: Pointer); register;
Group

TnxBlockPoolPhysical Methods

Links
TnxBlockPoolPhysical Class, TnxBlockPoolPhysical Members, nxllMemoryManager Namespace, TnxBlockPoolPhysical Methods


TnxInterfacedObject Class

TnxInterfacedObject Class
TnxInterfacedObject Fields TnxInterfacedObject Methods TnxInterfacedObject Properties TnxInterfacedObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxInterfacedObjectnxllMemoryManager_TnxInterfacedObject
Syntax
Delphi
TnxInterfacedObject = class(TnxObject, InxInterface);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxInterfacedObject.

Group

Classes

Links
TnxInterfacedObject Fields, TnxInterfacedObject Methods, TnxInterfacedObject Properties, TnxInterfacedObject Members, nxllMemoryManager, Classes


TnxInterfacedObject Members

TnxInterfacedObject Members
TnxInterfacedObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfacedObject.

Class

TnxInterfacedObject Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfacedObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfacedObject.Create Constructor

TnxInterfacedObject.Create Constructor
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Class Send Feedback
Syntax
Delphi
constructor Create(aKeepAlive: Boolean = False);
Class

TnxInterfacedObject Class

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Class


TnxInterfacedObject Fields

TnxInterfacedObject Fields
TnxInterfacedObject Class Legend Protected Fields Send Feedback

The fields of the TnxInterfacedObject class are listed here.

Class

TnxInterfacedObject Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Links
TnxInterfacedObject Class, Legend, Protected Fields


TnxInterfacedObject.ioKeepAlive Field

TnxInterfacedObject.ioKeepAlive Field
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Fields Send Feedback
Syntax
Delphi
ioKeepAlive: Boolean;
Description

This is ioKeepAlive, a member of class TnxInterfacedObject.

Group

TnxInterfacedObject Fields

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Fields


TnxInterfacedObject.ioRefCount Field

TnxInterfacedObject.ioRefCount Field
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Fields Send Feedback
Syntax
Delphi
ioRefCount: Integer;
Description

This is ioRefCount, a member of class TnxInterfacedObject.

Group

TnxInterfacedObject Fields

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Fields


TnxInterfacedObject.ioReleased Field

TnxInterfacedObject.ioReleased Field
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Fields Send Feedback
Syntax
Delphi
ioReleased: Integer;
Description

This is ioReleased, a member of class TnxInterfacedObject.

Group

TnxInterfacedObject Fields

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Fields


TnxInterfacedObject Methods

TnxInterfacedObject Methods
TnxInterfacedObject Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInterfacedObject class are listed here.

Class

TnxInterfacedObject Class

Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Free |
NewInstance |
Links
TnxInterfacedObject Class, Legend, Protected Methods, Public Methods


TnxInterfacedObject._AddRef Method

TnxInterfacedObject._AddRef Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Description

TnxInterfacedObject

Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject._Release Method

TnxInterfacedObject._Release Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.AfterConstruction Method

TnxInterfacedObject.AfterConstruction Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.BeforeDestruction Method

TnxInterfacedObject.BeforeDestruction Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.Free Method

TnxInterfacedObject.Free Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
procedure Free;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.ioDeactivate Method

TnxInterfacedObject.ioDeactivate Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
procedure ioDeactivate; virtual;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.NewInstance Method

TnxInterfacedObject.NewInstance Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject.QueryInterface Method

TnxInterfacedObject.QueryInterface Method
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Group

TnxInterfacedObject Methods

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Methods


TnxInterfacedObject Properties

TnxInterfacedObject Properties
TnxInterfacedObject Class Legend Public Properties Send Feedback

The properties of the TnxInterfacedObject class are listed here.

Class

TnxInterfacedObject Class

Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfacedObject Class, Legend, Public Properties


TnxInterfacedObject.KeptAlive Property

TnxInterfacedObject.KeptAlive Property
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Properties Send Feedback
Syntax
Delphi
property KeptAlive: Boolean;
Description

This is KeptAlive, a member of class TnxInterfacedObject.

Group

TnxInterfacedObject Properties

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Properties


TnxInterfacedObject.RefCount Property

TnxInterfacedObject.RefCount Property
TnxInterfacedObject Class TnxInterfacedObject Members nxllMemoryManager Namespace TnxInterfacedObject Properties Send Feedback
Syntax
Delphi
property RefCount: Integer;
Description

This is RefCount, a member of class TnxInterfacedObject.

Group

TnxInterfacedObject Properties

Links
TnxInterfacedObject Class, TnxInterfacedObject Members, nxllMemoryManager Namespace, TnxInterfacedObject Properties


TnxLifetimeMonitor Class

TnxLifetimeMonitor Class
TnxLifetimeMonitor Fields TnxLifetimeMonitor Methods TnxLifetimeMonitor Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxLifetimeMonitornxllMemoryManager_TnxLifetimeMonitornxllMemoryManager_TnxLifetimeMonitornxllMemoryManager_TnxLifetimeMonitornxllMemoryManager_TnxLifetimeMonitor
Syntax
Delphi
TnxLifetimeMonitor = class(TnxInterfacedObject, InxLifetimeMonitorObject, InxLifetimeMonitorRef);
File

nxllMemoryManager

Description

TnxLifetimeMonitor

Group

Classes

Links
TnxLifetimeMonitor Fields, TnxLifetimeMonitor Methods, TnxLifetimeMonitor Members, nxllMemoryManager, Classes


TnxLifetimeMonitor Members

TnxLifetimeMonitor Members
TnxLifetimeMonitor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLifetimeMonitor.

Class

TnxLifetimeMonitor Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
ltmIsDead | This is ltmIsDead, a member of class TnxLifetimeMonitor.
ltmObjectRefCount | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Dead | InxLifetimeMonitorObject
ioDeactivate |
IsAlive | InxLifetimeMonitorRef
ObjectAddRef |
ObjectRelease |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxLifetimeMonitor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLifetimeMonitor Fields

TnxLifetimeMonitor Fields
TnxLifetimeMonitor Class Legend Protected Fields Send Feedback

The fields of the TnxLifetimeMonitor class are listed here.

Class

TnxLifetimeMonitor Class

Protected Fields
Name | Description
ltmIsDead | This is ltmIsDead, a member of class TnxLifetimeMonitor.
ltmObjectRefCount | private
Links
TnxLifetimeMonitor Class, Legend, Protected Fields


TnxLifetimeMonitor.ltmIsDead Field

TnxLifetimeMonitor.ltmIsDead Field
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Fields Send Feedback
Syntax
Delphi
ltmIsDead: Boolean;
Description

This is ltmIsDead, a member of class TnxLifetimeMonitor.

Group

TnxLifetimeMonitor Fields

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Fields


TnxLifetimeMonitor.ltmObjectRefCount Field

TnxLifetimeMonitor.ltmObjectRefCount Field
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Fields Send Feedback
Syntax
Delphi
ltmObjectRefCount: Integer;
Description

private

Group

TnxLifetimeMonitor Fields

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Fields


TnxLifetimeMonitor Methods

TnxLifetimeMonitor Methods
TnxLifetimeMonitor Class Legend Protected Methods Send Feedback

The methods of the TnxLifetimeMonitor class are listed here.

Class

TnxLifetimeMonitor Class

Protected Methods
Name | Description
Dead | InxLifetimeMonitorObject
IsAlive | InxLifetimeMonitorRef
ObjectAddRef |
ObjectRelease |
Links
TnxLifetimeMonitor Class, Legend, Protected Methods


TnxLifetimeMonitor.Dead Method

TnxLifetimeMonitor.Dead Method
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Methods Send Feedback
Syntax
Delphi
procedure Dead;
Description

InxLifetimeMonitorObject

Group

TnxLifetimeMonitor Methods

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Methods


TnxLifetimeMonitor.IsAlive Method

TnxLifetimeMonitor.IsAlive Method
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Methods Send Feedback
Syntax
Delphi
function IsAlive: Boolean;
Description

InxLifetimeMonitorRef

Group

TnxLifetimeMonitor Methods

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Methods


TnxLifetimeMonitor.ObjectAddRef Method

TnxLifetimeMonitor.ObjectAddRef Method
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Methods Send Feedback
Syntax
Delphi
function ObjectAddRef: Integer; stdcall;
Group

TnxLifetimeMonitor Methods

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Methods


TnxLifetimeMonitor.ObjectRelease Method

TnxLifetimeMonitor.ObjectRelease Method
TnxLifetimeMonitor Class TnxLifetimeMonitor Members nxllMemoryManager Namespace TnxLifetimeMonitor Methods Send Feedback
Syntax
Delphi
function ObjectRelease: Integer; stdcall;
Group

TnxLifetimeMonitor Methods

Links
TnxLifetimeMonitor Class, TnxLifetimeMonitor Members, nxllMemoryManager Namespace, TnxLifetimeMonitor Methods


TnxLifetimeTrackedObject Class

TnxLifetimeTrackedObject Class
TnxLifetimeTrackedObject Fields TnxLifetimeTrackedObject Methods TnxLifetimeTrackedObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxLifetimeTrackedObjectnxllMemoryManager_TnxLifetimeTrackedObject
Syntax
Delphi
TnxLifetimeTrackedObject = class(TnxObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxLifetimeTrackedObject.

Group

Classes

Links
TnxLifetimeTrackedObject Fields, TnxLifetimeTrackedObject Methods, TnxLifetimeTrackedObject Members, nxllMemoryManager, Classes


TnxLifetimeTrackedObject Members

TnxLifetimeTrackedObject Members
TnxLifetimeTrackedObject Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxLifetimeTrackedObject.

Class

TnxLifetimeTrackedObject Class

Protected Fields
Name | Description
ltoLifetimeMonitor | private
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedObject
FreeInstance |
GetLifetimeMontior |
NewInstance | TnxObject
Links
TnxLifetimeTrackedObject Class, Legend, Protected Fields, Public Methods


TnxLifetimeTrackedObject Fields

TnxLifetimeTrackedObject Fields
TnxLifetimeTrackedObject Class Legend Protected Fields Send Feedback

The fields of the TnxLifetimeTrackedObject class are listed here.

Class

TnxLifetimeTrackedObject Class

Protected Fields
Name | Description
ltoLifetimeMonitor | private
Links
TnxLifetimeTrackedObject Class, Legend, Protected Fields


TnxLifetimeTrackedObject.ltoLifetimeMonitor Field

TnxLifetimeTrackedObject.ltoLifetimeMonitor Field
TnxLifetimeTrackedObject Class TnxLifetimeTrackedObject Members nxllMemoryManager Namespace TnxLifetimeTrackedObject Fields Send Feedback
Syntax
Delphi
ltoLifetimeMonitor: InxLifetimeMonitorObject;
Description

private

Group

TnxLifetimeTrackedObject Fields

Links
TnxLifetimeTrackedObject Class, TnxLifetimeTrackedObject Members, nxllMemoryManager Namespace, TnxLifetimeTrackedObject Fields


TnxLifetimeTrackedObject Methods

TnxLifetimeTrackedObject Methods
TnxLifetimeTrackedObject Class Legend Public Methods Send Feedback

The methods of the TnxLifetimeTrackedObject class are listed here.

Class

TnxLifetimeTrackedObject Class

Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedObject
GetLifetimeMontior |
Links
TnxLifetimeTrackedObject Class, Legend, Public Methods


TnxLifetimeTrackedObject.BeforeDestruction Method

TnxLifetimeTrackedObject.BeforeDestruction Method
TnxLifetimeTrackedObject Class TnxLifetimeTrackedObject Members nxllMemoryManager Namespace TnxLifetimeTrackedObject Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

TnxLifetimeTrackedObject

Group

TnxLifetimeTrackedObject Methods

Links
TnxLifetimeTrackedObject Class, TnxLifetimeTrackedObject Members, nxllMemoryManager Namespace, TnxLifetimeTrackedObject Methods


TnxLifetimeTrackedObject.GetLifetimeMontior Method

TnxLifetimeTrackedObject.GetLifetimeMontior Method
TnxLifetimeTrackedObject Class TnxLifetimeTrackedObject Members nxllMemoryManager Namespace TnxLifetimeTrackedObject Methods Send Feedback
Syntax
Delphi
function GetLifetimeMontior: InxLifetimeMonitorRef;
Group

TnxLifetimeTrackedObject Methods

Links
TnxLifetimeTrackedObject Class, TnxLifetimeTrackedObject Members, nxllMemoryManager Namespace, TnxLifetimeTrackedObject Methods


TnxLowInterfacedObject Class

TnxLowInterfacedObject Class
TnxLowInterfacedObject Methods TnxLowInterfacedObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxLowInterfacedObjectnxllMemoryManager_TnxLowInterfacedObjectnxllMemoryManager_TnxLowInterfacedObject
Syntax
Delphi
TnxLowInterfacedObject = class(TnxInterfacedObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxLowInterfacedObject.

Group

Classes

Links
TnxLowInterfacedObject Methods, TnxLowInterfacedObject Members, nxllMemoryManager, Classes


TnxLowInterfacedObject Members

TnxLowInterfacedObject Members
TnxLowInterfacedObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLowInterfacedObject.

Class

TnxLowInterfacedObject Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance | TnxLowInterfacedObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxLowInterfacedObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLowInterfacedObject Methods

TnxLowInterfacedObject Methods
TnxLowInterfacedObject Class Legend Public Methods Send Feedback

The methods of the TnxLowInterfacedObject class are listed here.

Class

TnxLowInterfacedObject Class

Public Methods
Name | Description
NewInstance | TnxLowInterfacedObject
Links
TnxLowInterfacedObject Class, Legend, Public Methods


TnxLowInterfacedObject.NewInstance Method

TnxLowInterfacedObject.NewInstance Method
TnxLowInterfacedObject Class TnxLowInterfacedObject Members nxllMemoryManager Namespace TnxLowInterfacedObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Description

TnxLowInterfacedObject

Group

TnxLowInterfacedObject Methods

Links
TnxLowInterfacedObject Class, TnxLowInterfacedObject Members, nxllMemoryManager Namespace, TnxLowInterfacedObject Methods


TnxLowObject Class

TnxLowObject Class
TnxLowObject Methods TnxLowObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxLowObjectnxllMemoryManager_TnxLowObject
Syntax
Delphi
TnxLowObject = class(TnxObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxLowObject.

Group

Classes

Links
TnxLowObject Methods, TnxLowObject Members, nxllMemoryManager, Classes


TnxLowObject Members

TnxLowObject Members
TnxLowObject Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxLowObject.

Class

TnxLowObject Class

Public Methods
Name | Description
FreeInstance |
NewInstance | TnxLowObject
Links
TnxLowObject Class, Legend, Public Methods


TnxLowObject Methods

TnxLowObject Methods
TnxLowObject Class Legend Public Methods Send Feedback

The methods of the TnxLowObject class are listed here.

Class

TnxLowObject Class

Public Methods
Name | Description
NewInstance | TnxLowObject
Links
TnxLowObject Class, Legend, Public Methods


TnxLowObject.NewInstance Method

TnxLowObject.NewInstance Method
TnxLowObject Class TnxLowObject Members nxllMemoryManager Namespace TnxLowObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Description

TnxLowObject

Group

TnxLowObject Methods

Links
TnxLowObject Class, TnxLowObject Members, nxllMemoryManager Namespace, TnxLowObject Methods


TnxMemoryPool Class

TnxMemoryPool Class
TnxMemoryPool Methods TnxMemoryPool Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxMemoryPool
Syntax
Delphi
TnxMemoryPool = class(TObject);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.TnxMemoryPool.

Group

Classes

Links
TnxMemoryPool Methods, TnxMemoryPool Members, nxllMemoryManager, Classes


TnxMemoryPool Members

TnxMemoryPool Members
TnxMemoryPool Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxMemoryPool.

Class

TnxMemoryPool Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxMemoryPool Class, Legend, Public Methods


TnxMemoryPool Methods

TnxMemoryPool Methods
TnxMemoryPool Class Legend Public Methods Send Feedback

The methods of the TnxMemoryPool class are listed here.

Class

TnxMemoryPool Class

Public Methods
Name | Description
Alloc |
Dispose |
DisposeDirect |
Links
TnxMemoryPool Class, Legend, Public Methods


TnxMemoryPool.Alloc Method

TnxMemoryPool.Alloc Method
TnxMemoryPool Class TnxMemoryPool Members nxllMemoryManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function Alloc: Pointer; register;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxllMemoryManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.Dispose Method

TnxMemoryPool.Dispose Method
TnxMemoryPool Class TnxMemoryPool Members nxllMemoryManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
procedure Dispose(var P); register;
Parameters
Parameters | Description
var P | : Pointer : Pointer
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxllMemoryManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.DisposeDirect Method

TnxMemoryPool.DisposeDirect Method
TnxMemoryPool Class TnxMemoryPool Members nxllMemoryManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
procedure DisposeDirect(P: Pointer); register;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxllMemoryManager Namespace, TnxMemoryPool Methods


TnxObject Class

TnxObject Class
TnxObject Methods TnxObject Members nxllMemoryManager Classes Send Feedback
Class Hierarchy
nxllMemoryManager_TnxObject
Syntax
Delphi
TnxObject = class(TObject);
File

nxllMemoryManager

Description

HPPEMIT 'namespace Nxllmemorymanager' HPPEMIT '{' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxObject;' HPPEMIT 'class PASCALIMPLEMENTATION TnxObject : public System::TObject' HPPEMIT '{' HPPEMIT ' typedef System::TObject inherited;' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' virtual __classmethod System::TObject* __fastcall NewInstance();' HPPEMIT ' #pragma option pop' HPPEMIT ' ///* class method */ static System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' virtual void __fastcall FreeInstance(void);' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* TObject.Create */ inline __fastcall TnxObject(void) : System::TObject() { }' HPPEMIT ' #pragma option pop' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* TObject.Destroy */ inline __fastcall virtual ~TnxObject(void) { }' HPPEMIT ' #pragma option pop' HPPEMIT '' HPPEMIT '};' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxInterfacedObject;' HPPEMIT 'class PASCALIMPLEMENTATION TnxInterfacedObject : public TnxObject' HPPEMIT '{' HPPEMIT ' typedef TnxObject inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' int ioRefCount;' HPPEMIT ' bool ioKeepAlive;' HPPEMIT ' HRESULT __stdcall QueryInterface(const GUID &IID, /* out */ void *Obj);' HPPEMIT ' int __stdcall _AddRef(void);' HPPEMIT ' int __stdcall _Release(void);' HPPEMIT ' virtual void __fastcall ioDeactivate(void);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' __fastcall TnxInterfacedObject(bool aKeepAlive);' HPPEMIT ' virtual void __fastcall AfterConstruction(void);' HPPEMIT ' virtual void __fastcall BeforeDestruction(void);' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' virtual System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' #pragma option pop' HPPEMIT ' ///* class method */ static System::TObject* __fastcall NewInstance(TMetaClass* vmt);' HPPEMIT ' HIDESBASE void __fastcall Free(void);' HPPEMIT ' __property int RefCount = {read=ioRefCount, nodefault};' HPPEMIT 'public:' HPPEMIT ' #pragma option push -w-inl' HPPEMIT ' /* TObject.Destroy */ inline __fastcall virtual ~TnxInterfacedObject(void) { }' HPPEMIT ' #pragma option pop' HPPEMIT '' HPPEMIT 'private:' HPPEMIT ' void *__IInterface; /* System::IInterface */' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' operator IInterface*(void) { return (IInterface* )&__IInterface; }' HPPEMIT '' HPPEMIT '};' HPPEMIT '' HPPEMIT '}' HPPEMIT '#define IMultiQI Nxlltypes::IMultiQI //Prevent ambiguity'

Group

Classes

Links
TnxObject Methods, TnxObject Members, nxllMemoryManager, Classes


TnxObject Members

TnxObject Members
TnxObject Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxObject.

Class

TnxObject Class

Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxObject Class, Legend, Public Methods


TnxObject Methods

TnxObject Methods
TnxObject Class Legend Public Methods Send Feedback

The methods of the TnxObject class are listed here.

Class

TnxObject Class

Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxObject Class, Legend, Public Methods


TnxObject.FreeInstance Method

TnxObject.FreeInstance Method
TnxObject Class TnxObject Members nxllMemoryManager Namespace TnxObject Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxObject Methods

Links
TnxObject Class, TnxObject Members, nxllMemoryManager Namespace, TnxObject Methods


TnxObject.NewInstance Method

TnxObject.NewInstance Method
TnxObject Class TnxObject Members nxllMemoryManager Namespace TnxObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Description

TnxObject

Group

TnxObject Methods

Links
TnxObject Class, TnxObject Members, nxllMemoryManager Namespace, TnxObject Methods


Interfaces

Interfaces
nxllMemoryManager Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllMemoryManager Namespace

Interfaces
Name | Description
InxLifetimeMonitorObject | This is class nxllMemoryManager.InxLifetimeMonitorObject.
InxLifetimeMonitorRef | This is class nxllMemoryManager.InxLifetimeMonitorRef.
Links
nxllMemoryManager Namespace, Interfaces, Legend


InxLifetimeMonitorObject Interface

InxLifetimeMonitorObject Interface
InxLifetimeMonitorObject Methods InxLifetimeMonitorObject Members nxllMemoryManager Interfaces Send Feedback
Class Hierarchy
nxllMemoryManager_InxLifetimeMonitorObject
Syntax
Delphi
InxLifetimeMonitorObject = interface(InxInterface);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.InxLifetimeMonitorObject.

Group

Interfaces

Links
InxLifetimeMonitorObject Methods, InxLifetimeMonitorObject Members, nxllMemoryManager, Interfaces


InxLifetimeMonitorObject Members

InxLifetimeMonitorObject Members
InxLifetimeMonitorObject Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxLifetimeMonitorObject.

Interface

InxLifetimeMonitorObject Interface

Public Methods
Name | Description
Dead | This is Dead, a member of class InxLifetimeMonitorObject.
Links
InxLifetimeMonitorObject Interface, Legend, Public Methods


InxLifetimeMonitorObject Methods

InxLifetimeMonitorObject Methods
InxLifetimeMonitorObject Interface Legend Public Methods Send Feedback

The methods of the InxLifetimeMonitorObject class are listed here.

Interface

InxLifetimeMonitorObject Interface

Public Methods
Name | Description
Dead | This is Dead, a member of class InxLifetimeMonitorObject.
Links
InxLifetimeMonitorObject Interface, Legend, Public Methods


InxLifetimeMonitorObject.Dead Method

InxLifetimeMonitorObject.Dead Method
InxLifetimeMonitorObject Interface InxLifetimeMonitorObject Members nxllMemoryManager Namespace InxLifetimeMonitorObject Methods Send Feedback
Syntax
Delphi
procedure Dead;
Description

This is Dead, a member of class InxLifetimeMonitorObject.

Group

InxLifetimeMonitorObject Methods

Links
InxLifetimeMonitorObject Interface, InxLifetimeMonitorObject Members, nxllMemoryManager Namespace, InxLifetimeMonitorObject Methods


InxLifetimeMonitorRef Interface

InxLifetimeMonitorRef Interface
InxLifetimeMonitorRef Methods InxLifetimeMonitorRef Members nxllMemoryManager Interfaces Send Feedback
Class Hierarchy
nxllMemoryManager_InxLifetimeMonitorRef
Syntax
Delphi
InxLifetimeMonitorRef = interface(InxInterface);
File

nxllMemoryManager

Description

This is class nxllMemoryManager.InxLifetimeMonitorRef.

Group

Interfaces

Links
InxLifetimeMonitorRef Methods, InxLifetimeMonitorRef Members, nxllMemoryManager, Interfaces


InxLifetimeMonitorRef Members

InxLifetimeMonitorRef Members
InxLifetimeMonitorRef Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxLifetimeMonitorRef.

Interface

InxLifetimeMonitorRef Interface

Public Methods
Name | Description
IsAlive | This is IsAlive, a member of class InxLifetimeMonitorRef.
Links
InxLifetimeMonitorRef Interface, Legend, Public Methods


InxLifetimeMonitorRef Methods

InxLifetimeMonitorRef Methods
InxLifetimeMonitorRef Interface Legend Public Methods Send Feedback

The methods of the InxLifetimeMonitorRef class are listed here.

Interface

InxLifetimeMonitorRef Interface

Public Methods
Name | Description
IsAlive | This is IsAlive, a member of class InxLifetimeMonitorRef.
Links
InxLifetimeMonitorRef Interface, Legend, Public Methods


InxLifetimeMonitorRef.IsAlive Method

InxLifetimeMonitorRef.IsAlive Method
InxLifetimeMonitorRef Interface InxLifetimeMonitorRef Members nxllMemoryManager Namespace InxLifetimeMonitorRef Methods Send Feedback
Syntax
Delphi
function IsAlive: Boolean;
Description

This is IsAlive, a member of class InxLifetimeMonitorRef.

Group

InxLifetimeMonitorRef Methods

Links
InxLifetimeMonitorRef Interface, InxLifetimeMonitorRef Members, nxllMemoryManager Namespace, InxLifetimeMonitorRef Methods


Functions

Functions
Functions nxllMemoryManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllMemoryManager.AddRef.
nxBeginSecureFreeMem |
nxChunkEmergency |
nxCreateLifetimeMonitor |
nxEndSecureFreeMem |
nxForceCleanup |
nxFreeAndNil |
nxFreeMem |
nxFreeMemDirect |
nxGetAllocSize |
nxGetHeapStatus |
nxGetLicenseKeyStatus |
nxGetMem |
nxGetMem |
nxGetMemLow |
nxGetPool |
nxGetZeroMem |
nxGetZeroMem |
nxHeapAddRef |
nxHeapRelease |
nxIntfNil |
nxIsAWEAvailable |
nxIsAWESupported |
nxLicenseHasFeature |
nxMapableBlockAllocate | Allocates a new block of the requested size. raises exception on error
nxMapableBlockDispose | Disposes a block, raises exception on error
nxMapableBlockLock | Maps a block into the virtual address space, raises exception on error
nxMapableBlocksAllocate | HPPEMIT 'class DELPHICLASS TnxMapableBlockHandle; //Forward declaration HPPEMIT 'class DELPHICLASS TnxMapableBlockHandles; //Forward declaration HPPEMIT 'extern PACKAGE TnxMapableBlockHandles* __fastcall nxMapableBlocksAllocate(Nxlltypes::TnxBlockSizeAll aBlockSize); //incorrect return type?
nxMapableBlocksLock | Maps an array of blocks into the virtual address space, raises exception on error
nxMapableBlocksUnlock | Unmaps an array of blocks, raises exception on error
nxMapableBlockUnlock | Unmaps a block, raises exception on error
nxPhysicalEmergency |
nxReallocMem |
Release | This is function nxllMemoryManager.Release.
Namespace

nxllMemoryManager Namespace

Links
Functions, nxllMemoryManager Namespace, Legend


nxllMemoryManager.AddRef Function

nxllMemoryManager.AddRef Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllMemoryManager

Description

This is function nxllMemoryManager.AddRef.

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxBeginSecureFreeMem Function

nxllMemoryManager.nxBeginSecureFreeMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxBeginSecureFreeMem: Integer; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxChunkEmergency Function

nxllMemoryManager.nxChunkEmergency Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxChunkEmergency: Boolean; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxCreateLifetimeMonitor Function

nxllMemoryManager.nxCreateLifetimeMonitor Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxCreateLifetimeMonitor: InxLifetimeMonitorObject;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxEndSecureFreeMem Function

nxllMemoryManager.nxEndSecureFreeMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxEndSecureFreeMem: Integer; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxForceCleanup Function

nxllMemoryManager.nxForceCleanup Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxForceCleanup; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxFreeAndNil Function

nxllMemoryManager.nxFreeAndNil Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxFreeAndNil(var Obj);
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxFreeMem Function

nxllMemoryManager.nxFreeMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxFreeMem(var P); register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxFreeMemDirect Function

nxllMemoryManager.nxFreeMemDirect Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxFreeMemDirect(P: Pointer); register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetAllocSize Function

nxllMemoryManager.nxGetAllocSize Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetAllocSize(P: Pointer): Integer; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetHeapStatus Function

nxllMemoryManager.nxGetHeapStatus Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetHeapStatus: THeapStatus; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetLicenseKeyStatus Function

nxllMemoryManager.nxGetLicenseKeyStatus Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetLicenseKeyStatus: string;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetMem Function

nxllMemoryManager.nxGetMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxGetMem(var P; Size: TnxMemSize); register; overload;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetMem Function

nxllMemoryManager.nxGetMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetMem(Size: TnxMemSize): Pointer; register; overload;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetMemLow Function

nxllMemoryManager.nxGetMemLow Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetMemLow(Size: TnxMemSize): Pointer; register; overload;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetPool Function

nxllMemoryManager.nxGetPool Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetPool(Size: TnxMemSize): TnxMemoryPool; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetZeroMem Function

nxllMemoryManager.nxGetZeroMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxGetZeroMem(var P; Size: TnxMemSize); register; overload;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxGetZeroMem Function

nxllMemoryManager.nxGetZeroMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxGetZeroMem(Size: TnxMemSize): Pointer; register; overload;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxHeapAddRef Function

nxllMemoryManager.nxHeapAddRef Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxHeapAddRef; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxHeapRelease Function

nxllMemoryManager.nxHeapRelease Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxHeapRelease; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxIntfNil Function

nxllMemoryManager.nxIntfNil Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxIntfNil(var Intf);
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxIsAWEAvailable Function

nxllMemoryManager.nxIsAWEAvailable Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxIsAWEAvailable: Boolean; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxIsAWESupported Function

nxllMemoryManager.nxIsAWESupported Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxIsAWESupported: Boolean; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxLicenseHasFeature Function

nxllMemoryManager.nxLicenseHasFeature Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxLicenseHasFeature(const aFeature: UnicodeString): Boolean;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlockAllocate Function

nxllMemoryManager.nxMapableBlockAllocate Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockAllocate(aBlockSize: TnxBlockSizeAll; aLow: Boolean = False): TnxMapableBlockHandle; register;
File

nxllMemoryManager

Description

Allocates a new block of the requested size. raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlockDispose Function

nxllMemoryManager.nxMapableBlockDispose Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxMapableBlockDispose(aHandle: TnxMapableBlockHandle); register;
File

nxllMemoryManager

Description

Disposes a block, raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlockLock Function

nxllMemoryManager.nxMapableBlockLock Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockLock(aHandle: TnxMapableBlockHandle): Pointer; register;
File

nxllMemoryManager

Description

Maps a block into the virtual address space, raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlocksAllocate Function

nxllMemoryManager.nxMapableBlocksAllocate Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlocksAllocate(aBlockSize: TnxBlockSizeAll): TnxMapableBlockHandles; register;
File

nxllMemoryManager

Description

HPPEMIT 'class DELPHICLASS TnxMapableBlockHandle; //Forward declaration HPPEMIT 'class DELPHICLASS TnxMapableBlockHandles; //Forward declaration HPPEMIT 'extern PACKAGE TnxMapableBlockHandles* __fastcall nxMapableBlocksAllocate(Nxlltypes::TnxBlockSizeAll aBlockSize); //incorrect return type?

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlocksLock Function

nxllMemoryManager.nxMapableBlocksLock Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlocksLock(aHandles: TnxMapableBlockHandles): Pointer; register;
File

nxllMemoryManager

Description

Maps an array of blocks into the virtual address space, raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlocksUnlock Function

nxllMemoryManager.nxMapableBlocksUnlock Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxMapableBlocksUnlock(aHandles: TnxMapableBlockHandles; aBlocks: Pointer); register;
File

nxllMemoryManager

Description

Unmaps an array of blocks, raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxMapableBlockUnlock Function

nxllMemoryManager.nxMapableBlockUnlock Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxMapableBlockUnlock(aHandle: TnxMapableBlockHandle; aBlock: Pointer); register;
File

nxllMemoryManager

Description

Unmaps a block, raises exception on error

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxPhysicalEmergency Function

nxllMemoryManager.nxPhysicalEmergency Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
function nxPhysicalEmergency: Boolean; register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.nxReallocMem Function

nxllMemoryManager.nxReallocMem Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxReallocMem(var P; NewSize: TnxMemSize); register;
File

nxllMemoryManager

Group

Functions

Links
nxllMemoryManager, Functions


nxllMemoryManager.Release Function

nxllMemoryManager.Release Function
nxllMemoryManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllMemoryManager

Description

This is function nxllMemoryManager.Release.

Group

Functions

Links
nxllMemoryManager, Functions


Types

Types
nxllMemoryManager Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllMemoryManager Namespace

Types
Name | Description
TnxLicenseHasFeature |
TnxMapableBlockHandle | This is type nxllMemoryManager.TnxMapableBlockHandle.
TnxMapableBlockHandles | This is type nxllMemoryManager.TnxMapableBlockHandles.
Links
nxllMemoryManager Namespace, Types


nxllMemoryManager.TnxLicenseHasFeature Type

nxllMemoryManager.TnxLicenseHasFeature Type
nxllMemoryManager Types Send Feedback
Syntax
Delphi
TnxLicenseHasFeature = function (const aFeature: PWideChar): LongBool;
File

nxllMemoryManager

Group

Types

Links
nxllMemoryManager, Types


nxllMemoryManager.TnxMapableBlockHandle Type

nxllMemoryManager.TnxMapableBlockHandle Type
nxllMemoryManager Types Send Feedback
Syntax
Delphi
TnxMapableBlockHandle = type TnxNativeUInt;
File

nxllMemoryManager

Description

This is type nxllMemoryManager.TnxMapableBlockHandle.

Group

Types

Links
nxllMemoryManager, Types


nxllMemoryManager.TnxMapableBlockHandles Type

nxllMemoryManager.TnxMapableBlockHandles Type
nxllMemoryManager Types Send Feedback
Syntax
Delphi
TnxMapableBlockHandles = array[Byte] of TnxMapableBlockHandle;
File

nxllMemoryManager

Description

This is type nxllMemoryManager.TnxMapableBlockHandles.

Group

Types

Links
nxllMemoryManager, Types


Variables

Variables
nxllMemoryManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllMemoryManager Namespace

Variables
Name | Description
_ChunkEmergencyCommitted | don't use directly! use nxChunkEmergency
_ChunkEmergencyPhysical | don't use directly! use nxChunkEmergency
_CountObjectInstance | This is variable nxllMemoryManager._CountObjectInstance.
_ForceCleanup |
_HeapAddRef |
_HeapRelease | This is variable nxllMemoryManager._HeapRelease.
_LicenseHasFeature | This is variable nxllMemoryManager._LicenseHasFeature.
_LicenseKeyStatus |
_nxFillChar | This is variable nxllMemoryManager._nxFillChar.
_nxGetAllocSize | This is variable nxllMemoryManager._nxGetAllocSize.
_nxGetHeapStatus | This is variable nxllMemoryManager._nxGetHeapStatus.
_nxGetMemLow |
_nxGetPool |
_nxMapableBlockAllocate |
_nxMapableBlockDispose | This is variable nxllMemoryManager._nxMapableBlockDispose.
_nxMapableBlockLock | This is variable nxllMemoryManager._nxMapableBlockLock.
_nxMapableBlocksLock | This is variable nxllMemoryManager._nxMapableBlocksLock.
_nxMapableBlocksUnlock | This is variable nxllMemoryManager._nxMapableBlocksUnlock.
_nxMapableBlockUnlock | This is variable nxllMemoryManager._nxMapableBlockUnlock.
_nxMemoryManager | This is variable nxllMemoryManager._nxMemoryManager.
_nxSecureFreeMem |
_PhysicalEmergency | This is variable nxllMemoryManager._PhysicalEmergency.
_RefCount |
_TnxBlockPoolCommitted_Alloc | TnxBlockPoolCommitted
_TnxBlockPoolCommitted_Dispose | This is variable nxllMemoryManager._TnxBlockPoolCommitted_Dispose.
_TnxBlockPoolPhysical_Alloc | TnxBlockPoolPhysical
_TnxBlockPoolPhysical_Dispose | This is variable nxllMemoryManager._TnxBlockPoolPhysical_Dispose.
_TnxMemoryPool_Alloc | TnxMemoryPool
_TnxMemoryPool_Dispose | This is variable nxllMemoryManager._TnxMemoryPool_Dispose.
BlockPools | This is variable nxllMemoryManager.BlockPools.
BlockPoolsPhysical | This is variable nxllMemoryManager.BlockPoolsPhysical.
EmptyBlock | empty 64kB block, read-only
FileMappingHandle |
nxAWEAvailable | This is variable nxllMemoryManager.nxAWEAvailable.
nxAWESupported | This is variable nxllMemoryManager.nxAWESupported.
q | This is variable nxllMemoryManager.q.
Links
nxllMemoryManager Namespace, Variables


nxllMemoryManager._ChunkEmergencyCommitted Variable

nxllMemoryManager._ChunkEmergencyCommitted Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_ChunkEmergencyCommitted: ^LongBool;
File

nxllMemoryManager

Description

don't use directly! use nxChunkEmergency

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._ChunkEmergencyPhysical Variable

nxllMemoryManager._ChunkEmergencyPhysical Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_ChunkEmergencyPhysical: ^LongBool;
File

nxllMemoryManager

Description

don't use directly! use nxChunkEmergency

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._CountObjectInstance Variable

nxllMemoryManager._CountObjectInstance Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_CountObjectInstance: procedure(aInstance: TObject; aNew: Boolean);
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._CountObjectInstance.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._ForceCleanup Variable

nxllMemoryManager._ForceCleanup Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_ForceCleanup: procedure;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._HeapAddRef Variable

nxllMemoryManager._HeapAddRef Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_HeapAddRef: procedure;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._HeapRelease Variable

nxllMemoryManager._HeapRelease Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_HeapRelease: procedure;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._HeapRelease.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._LicenseHasFeature Variable

nxllMemoryManager._LicenseHasFeature Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_LicenseHasFeature: TnxLicenseHasFeature;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._LicenseHasFeature.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._LicenseKeyStatus Variable

nxllMemoryManager._LicenseKeyStatus Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_LicenseKeyStatus: PAnsiChar;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxFillChar Variable

nxllMemoryManager._nxFillChar Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxFillChar: TnxFillChar;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxFillChar.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxGetAllocSize Variable

nxllMemoryManager._nxGetAllocSize Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxGetAllocSize: Pointer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxGetAllocSize.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxGetHeapStatus Variable

nxllMemoryManager._nxGetHeapStatus Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxGetHeapStatus: Pointer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxGetHeapStatus.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxGetMemLow Variable

nxllMemoryManager._nxGetMemLow Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxGetMemLow: function(Size: TnxMemSize): Pointer;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxGetPool Variable

nxllMemoryManager._nxGetPool Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxGetPool: Pointer;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlockAllocate Variable

nxllMemoryManager._nxMapableBlockAllocate Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlockAllocate: function(aBlockSize : TnxBlockSizeAll ; aLow: Boolean ): TnxMapableBlockHandle;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlockDispose Variable

nxllMemoryManager._nxMapableBlockDispose Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlockDispose: function(aHandle: TnxMapableBlockHandle): Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMapableBlockDispose.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlockLock Variable

nxllMemoryManager._nxMapableBlockLock Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlockLock: function(aHandle: TnxMapableBlockHandle): Pointer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMapableBlockLock.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlocksLock Variable

nxllMemoryManager._nxMapableBlocksLock Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlocksLock: function(aHandles: TnxMapableBlockHandles): Pointer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMapableBlocksLock.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlocksUnlock Variable

nxllMemoryManager._nxMapableBlocksUnlock Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlocksUnlock: function(aHandles: TnxMapableBlockHandles; aBlocks: Pointer): Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMapableBlocksUnlock.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMapableBlockUnlock Variable

nxllMemoryManager._nxMapableBlockUnlock Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMapableBlockUnlock: function(aHandle: TnxMapableBlockHandle; aBlock: Pointer): Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMapableBlockUnlock.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxMemoryManager Variable

nxllMemoryManager._nxMemoryManager Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxMemoryManager: TMemoryManager;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._nxMemoryManager.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._nxSecureFreeMem Variable

nxllMemoryManager._nxSecureFreeMem Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_nxSecureFreeMem: PInteger;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._PhysicalEmergency Variable

nxllMemoryManager._PhysicalEmergency Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_PhysicalEmergency: function: Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._PhysicalEmergency.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._RefCount Variable

nxllMemoryManager._RefCount Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxBlockPoolCommitted_Alloc Variable

nxllMemoryManager._TnxBlockPoolCommitted_Alloc Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxBlockPoolCommitted_Alloc: function(aBlockType : Pointer ; aLow: Boolean ): Pointer;
File

nxllMemoryManager

Description

TnxBlockPoolCommitted

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxBlockPoolCommitted_Dispose Variable

nxllMemoryManager._TnxBlockPoolCommitted_Dispose Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxBlockPoolCommitted_Dispose: function(aBlockType : Pointer; aBlock: Pointer): Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._TnxBlockPoolCommitted_Dispose.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxBlockPoolPhysical_Alloc Variable

nxllMemoryManager._TnxBlockPoolPhysical_Alloc Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxBlockPoolPhysical_Alloc: function(aBlockType : Pointer ; aLow: Boolean ): Pointer;
File

nxllMemoryManager

Description

TnxBlockPoolPhysical

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxBlockPoolPhysical_Dispose Variable

nxllMemoryManager._TnxBlockPoolPhysical_Dispose Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxBlockPoolPhysical_Dispose: function(aBlockType : Pointer; aBlock: Pointer): Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._TnxBlockPoolPhysical_Dispose.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxMemoryPool_Alloc Variable

nxllMemoryManager._TnxMemoryPool_Alloc Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxMemoryPool_Alloc: function(Self: Pointer): Pointer;
File

nxllMemoryManager

Description

TnxMemoryPool

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager._TnxMemoryPool_Dispose Variable

nxllMemoryManager._TnxMemoryPool_Dispose Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
_TnxMemoryPool_Dispose: function(Self: Pointer; P: Pointer): Integer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager._TnxMemoryPool_Dispose.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.BlockPools Variable

nxllMemoryManager.BlockPools Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
BlockPools: array[TnxBlockSizeAll] of TnxBlockPoolCommitted;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager.BlockPools.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.BlockPoolsPhysical Variable

nxllMemoryManager.BlockPoolsPhysical Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
BlockPoolsPhysical: array[TnxBlockSizeAll] of TnxBlockPoolPhysical;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager.BlockPoolsPhysical.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.EmptyBlock Variable

nxllMemoryManager.EmptyBlock Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
EmptyBlock: Pointer;
File

nxllMemoryManager

Description

empty 64kB block, read-only

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.FileMappingHandle Variable

nxllMemoryManager.FileMappingHandle Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
FileMappingHandle: THandle;
File

nxllMemoryManager

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.nxAWEAvailable Variable

nxllMemoryManager.nxAWEAvailable Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
nxAWEAvailable: Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager.nxAWEAvailable.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.nxAWESupported Variable

nxllMemoryManager.nxAWESupported Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
nxAWESupported: Boolean;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager.nxAWESupported.

Group

Variables

Links
nxllMemoryManager, Variables


nxllMemoryManager.q Variable

nxllMemoryManager.q Variable
nxllMemoryManager Variables Send Feedback
Syntax
Delphi
q: Pointer;
File

nxllMemoryManager

Description

This is variable nxllMemoryManager.q.

Group

Variables

Links
nxllMemoryManager, Variables


Constants

Constants
Constants nxllMemoryManager Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_BlockSizes | This is constant nxllMemoryManager._BlockSizes.
_PagesPerBlock | This is constant nxllMemoryManager._PagesPerBlock.
Namespace

nxllMemoryManager Namespace

Links
Constants, nxllMemoryManager Namespace


nxllMemoryManager._BlockSizes Constant

nxllMemoryManager._BlockSizes Constant
nxllMemoryManager Constants Send Feedback
Syntax
Delphi
_BlockSizes: array[TnxBlockSizeAll] of TnxWord32 = ( 4 * 1024, 8 * 1024, 16 * 1024, 32 * 1024, 64 * 1024, 4 * 1024 * 1024);
File

nxllMemoryManager

Description

This is constant nxllMemoryManager._BlockSizes.

Group

Constants

Links
nxllMemoryManager, Constants


nxllMemoryManager._PagesPerBlock Constant

nxllMemoryManager._PagesPerBlock Constant
nxllMemoryManager Constants Send Feedback
Syntax
Delphi
_PagesPerBlock: array[TnxBlockSizeAll] of TnxWord32 = ( 1, 2, 4, 8, 16, 1024);
File

nxllMemoryManager

Description

This is constant nxllMemoryManager._PagesPerBlock.

Group

Constants

Links
nxllMemoryManager, Constants


nxllMemoryManagerImpl Namespace

nxllMemoryManagerImpl Namespace
Constants Functions Legend Topics Variables Send Feedback

This is namespace nxllMemoryManagerImpl.

Constants
Name | Description
_HookedMemoryManager | This is constant nxllMemoryManagerImpl._HookedMemoryManager.
_MemoryManager |
NoNXMMDLL | nxcl_SmallDownsizeShiftFactor = 5;
nxcl_1KB | This is constant nxllMemoryManagerImpl.nxcl_1KB.
nxcl_1MB | This is constant nxllMemoryManagerImpl.nxcl_1MB.
nxcl_AllocGranularity | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularity.
nxcl_AllocGranularityUnfreeable | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnfreeable.
nxcl_AllocGranularityUnpaged | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnpaged.
nxcl_CleanupInterval | .5 sec
Functions
Name | Description
AddRef | This is function nxllMemoryManagerImpl.AddRef.
InitMemoryManager |
Release | This is function nxllMemoryManagerImpl.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
_AfterBlockPoolCommittedAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedAlloc.
_AfterBlockPoolCommittedLargeAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedLargeAlloc.
_AfterBlockPoolPhysicalAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolPhysicalAlloc.
_AfterGetAllocSize | This is variable nxllMemoryManagerImpl._AfterGetAllocSize.
_AfterGetMem | This is variable nxllMemoryManagerImpl._AfterGetMem.
_AfterGetMemLow | This is variable nxllMemoryManagerImpl._AfterGetMemLow.
_AfterMemoryPoolAlloc | This is variable nxllMemoryManagerImpl._AfterMemoryPoolAlloc.
_AfterReallocMem | This is variable nxllMemoryManagerImpl._AfterReallocMem.
_BeforeBlockPoolCommittedDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedDispose.
_BeforeBlockPoolCommittedLargeDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedLargeDispose.
_BeforeBlockPoolPhysicalDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolPhysicalDispose.
_BeforeFreeMem | This is variable nxllMemoryManagerImpl._BeforeFreeMem.
_BeforeGetAllocSize | This is variable nxllMemoryManagerImpl._BeforeGetAllocSize.
_BeforeGetMem | This is variable nxllMemoryManagerImpl._BeforeGetMem.
_BeforeGetMemLow | This is variable nxllMemoryManagerImpl._BeforeGetMemLow.
_BeforeGetPool | This is variable nxllMemoryManagerImpl._BeforeGetPool.
_BeforeMemoryPoolDispose | This is variable nxllMemoryManagerImpl._BeforeMemoryPoolDispose.
_BeforeReallocMem | This is variable nxllMemoryManagerImpl._BeforeReallocMem.
_CleanupThread8087CW | This is variable nxllMemoryManagerImpl._CleanupThread8087CW.
_CleanupThreadDieEvent | This is variable nxllMemoryManagerImpl._CleanupThreadDieEvent.
_CleanupThreadHandle | This is variable nxllMemoryManagerImpl._CleanupThreadHandle.
_CleanupThreadHasRunEvent | This is variable nxllMemoryManagerImpl._CleanupThreadHasRunEvent.
_CleanupThreadMutex | This is variable nxllMemoryManagerImpl._CleanupThreadMutex.
_CleanupThreadRunEvent | This is variable nxllMemoryManagerImpl._CleanupThreadRunEvent.
_CleanupThreadTerminatedEvent | This is variable nxllMemoryManagerImpl._CleanupThreadTerminatedEvent.
_MemoryManagerImpl | Init/Done
_MemoryManagerInitialized | This is variable nxllMemoryManagerImpl._MemoryManagerInitialized.
_nxMove | This is variable nxllMemoryManagerImpl._nxMove.
Links
Constants, Functions, Legend, Topics, Variables


Functions

Functions
Functions nxllMemoryManagerImpl Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxllMemoryManagerImpl.AddRef.
InitMemoryManager |
Release | This is function nxllMemoryManagerImpl.Release.
Namespace

nxllMemoryManagerImpl Namespace

Links
Functions, nxllMemoryManagerImpl Namespace, Legend


nxllMemoryManagerImpl.AddRef Function

nxllMemoryManagerImpl.AddRef Function
nxllMemoryManagerImpl Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxllMemoryManagerImpl

Description

This is function nxllMemoryManagerImpl.AddRef.

Group

Functions

Links
nxllMemoryManagerImpl, Functions


nxllMemoryManagerImpl.InitMemoryManager Function

nxllMemoryManagerImpl.InitMemoryManager Function
nxllMemoryManagerImpl Functions Send Feedback
Syntax
Delphi
function InitMemoryManager: PnxMemoryManagerImpl;
File

nxllMemoryManagerImpl

Group

Functions

Links
nxllMemoryManagerImpl, Functions


nxllMemoryManagerImpl.Release Function

nxllMemoryManagerImpl.Release Function
nxllMemoryManagerImpl Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxllMemoryManagerImpl

Description

This is function nxllMemoryManagerImpl.Release.

Group

Functions

Links
nxllMemoryManagerImpl, Functions


Variables

Variables
nxllMemoryManagerImpl Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllMemoryManagerImpl Namespace

Variables
Name | Description
_AfterBlockPoolCommittedAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedAlloc.
_AfterBlockPoolCommittedLargeAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedLargeAlloc.
_AfterBlockPoolPhysicalAlloc | This is variable nxllMemoryManagerImpl._AfterBlockPoolPhysicalAlloc.
_AfterGetAllocSize | This is variable nxllMemoryManagerImpl._AfterGetAllocSize.
_AfterGetMem | This is variable nxllMemoryManagerImpl._AfterGetMem.
_AfterGetMemLow | This is variable nxllMemoryManagerImpl._AfterGetMemLow.
_AfterMemoryPoolAlloc | This is variable nxllMemoryManagerImpl._AfterMemoryPoolAlloc.
_AfterReallocMem | This is variable nxllMemoryManagerImpl._AfterReallocMem.
_BeforeBlockPoolCommittedDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedDispose.
_BeforeBlockPoolCommittedLargeDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedLargeDispose.
_BeforeBlockPoolPhysicalDispose | This is variable nxllMemoryManagerImpl._BeforeBlockPoolPhysicalDispose.
_BeforeFreeMem | This is variable nxllMemoryManagerImpl._BeforeFreeMem.
_BeforeGetAllocSize | This is variable nxllMemoryManagerImpl._BeforeGetAllocSize.
_BeforeGetMem | This is variable nxllMemoryManagerImpl._BeforeGetMem.
_BeforeGetMemLow | This is variable nxllMemoryManagerImpl._BeforeGetMemLow.
_BeforeGetPool | This is variable nxllMemoryManagerImpl._BeforeGetPool.
_BeforeMemoryPoolDispose | This is variable nxllMemoryManagerImpl._BeforeMemoryPoolDispose.
_BeforeReallocMem | This is variable nxllMemoryManagerImpl._BeforeReallocMem.
_CleanupThread8087CW | This is variable nxllMemoryManagerImpl._CleanupThread8087CW.
_CleanupThreadDieEvent | This is variable nxllMemoryManagerImpl._CleanupThreadDieEvent.
_CleanupThreadHandle | This is variable nxllMemoryManagerImpl._CleanupThreadHandle.
_CleanupThreadHasRunEvent | This is variable nxllMemoryManagerImpl._CleanupThreadHasRunEvent.
_CleanupThreadMutex | This is variable nxllMemoryManagerImpl._CleanupThreadMutex.
_CleanupThreadRunEvent | This is variable nxllMemoryManagerImpl._CleanupThreadRunEvent.
_CleanupThreadTerminatedEvent | This is variable nxllMemoryManagerImpl._CleanupThreadTerminatedEvent.
_MemoryManagerImpl | Init/Done
_MemoryManagerInitialized | This is variable nxllMemoryManagerImpl._MemoryManagerInitialized.
_nxMove | This is variable nxllMemoryManagerImpl._nxMove.
Links
nxllMemoryManagerImpl Namespace, Variables


nxllMemoryManagerImpl._AfterBlockPoolCommittedAlloc Variable

nxllMemoryManagerImpl._AfterBlockPoolCommittedAlloc Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterBlockPoolCommittedAlloc: TAfterBlockPoolAlloc;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedAlloc.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterBlockPoolCommittedLargeAlloc Variable

nxllMemoryManagerImpl._AfterBlockPoolCommittedLargeAlloc Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterBlockPoolCommittedLargeAlloc: TAfterBlockPoolAlloc;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterBlockPoolCommittedLargeAlloc.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterBlockPoolPhysicalAlloc Variable

nxllMemoryManagerImpl._AfterBlockPoolPhysicalAlloc Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterBlockPoolPhysicalAlloc: TAfterBlockPoolAlloc;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterBlockPoolPhysicalAlloc.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterGetAllocSize Variable

nxllMemoryManagerImpl._AfterGetAllocSize Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterGetAllocSize: TAfterGetAllocSize;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterGetAllocSize.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterGetMem Variable

nxllMemoryManagerImpl._AfterGetMem Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterGetMem: TAfterGetMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterGetMem.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterGetMemLow Variable

nxllMemoryManagerImpl._AfterGetMemLow Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterGetMemLow: TAfterGetMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterGetMemLow.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterMemoryPoolAlloc Variable

nxllMemoryManagerImpl._AfterMemoryPoolAlloc Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterMemoryPoolAlloc: TAfterMemoryPoolAlloc;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterMemoryPoolAlloc.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._AfterReallocMem Variable

nxllMemoryManagerImpl._AfterReallocMem Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_AfterReallocMem: TAfterReallocMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._AfterReallocMem.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeBlockPoolCommittedDispose Variable

nxllMemoryManagerImpl._BeforeBlockPoolCommittedDispose Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeBlockPoolCommittedDispose: TBeforeBlockPoolDispose;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedDispose.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeBlockPoolCommittedLargeDispose Variable

nxllMemoryManagerImpl._BeforeBlockPoolCommittedLargeDispose Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeBlockPoolCommittedLargeDispose: TBeforeBlockPoolDispose;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeBlockPoolCommittedLargeDispose.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeBlockPoolPhysicalDispose Variable

nxllMemoryManagerImpl._BeforeBlockPoolPhysicalDispose Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeBlockPoolPhysicalDispose: TBeforeBlockPoolDispose;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeBlockPoolPhysicalDispose.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeFreeMem Variable

nxllMemoryManagerImpl._BeforeFreeMem Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeFreeMem: TBeforeFreeMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeFreeMem.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeGetAllocSize Variable

nxllMemoryManagerImpl._BeforeGetAllocSize Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeGetAllocSize: TBeforeGetAllocSize;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeGetAllocSize.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeGetMem Variable

nxllMemoryManagerImpl._BeforeGetMem Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeGetMem: TBeforeGetMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeGetMem.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeGetMemLow Variable

nxllMemoryManagerImpl._BeforeGetMemLow Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeGetMemLow: TBeforeGetMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeGetMemLow.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeGetPool Variable

nxllMemoryManagerImpl._BeforeGetPool Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeGetPool: TBeforeGetPool;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeGetPool.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeMemoryPoolDispose Variable

nxllMemoryManagerImpl._BeforeMemoryPoolDispose Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeMemoryPoolDispose: TBeforeMemoryPoolDispose;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeMemoryPoolDispose.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._BeforeReallocMem Variable

nxllMemoryManagerImpl._BeforeReallocMem Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_BeforeReallocMem: TBeforeReallocMem;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._BeforeReallocMem.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThread8087CW Variable

nxllMemoryManagerImpl._CleanupThread8087CW Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThread8087CW: Word;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThread8087CW.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadDieEvent Variable

nxllMemoryManagerImpl._CleanupThreadDieEvent Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadDieEvent: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadDieEvent.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadHandle Variable

nxllMemoryManagerImpl._CleanupThreadHandle Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadHandle: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadHandle.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadHasRunEvent Variable

nxllMemoryManagerImpl._CleanupThreadHasRunEvent Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadHasRunEvent: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadHasRunEvent.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadMutex Variable

nxllMemoryManagerImpl._CleanupThreadMutex Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadMutex: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadMutex.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadRunEvent Variable

nxllMemoryManagerImpl._CleanupThreadRunEvent Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadRunEvent: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadRunEvent.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._CleanupThreadTerminatedEvent Variable

nxllMemoryManagerImpl._CleanupThreadTerminatedEvent Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_CleanupThreadTerminatedEvent: THandle;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._CleanupThreadTerminatedEvent.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._MemoryManagerImpl Variable

nxllMemoryManagerImpl._MemoryManagerImpl Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_MemoryManagerImpl: TnxMemoryManagerImpl;
File

nxllMemoryManagerImpl

Description

Init/Done

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._MemoryManagerInitialized Variable

nxllMemoryManagerImpl._MemoryManagerInitialized Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_MemoryManagerInitialized: Boolean = False;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._MemoryManagerInitialized.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


nxllMemoryManagerImpl._nxMove Variable

nxllMemoryManagerImpl._nxMove Variable
nxllMemoryManagerImpl Variables Send Feedback
Syntax
Delphi
_nxMove: TnxMove;
File

nxllMemoryManagerImpl

Description

This is variable nxllMemoryManagerImpl._nxMove.

Group

Variables

Links
nxllMemoryManagerImpl, Variables


Constants

Constants
Constants nxllMemoryManagerImpl Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_HookedMemoryManager | This is constant nxllMemoryManagerImpl._HookedMemoryManager.
_MemoryManager |
NoNXMMDLL | nxcl_SmallDownsizeShiftFactor = 5;
nxcl_1KB | This is constant nxllMemoryManagerImpl.nxcl_1KB.
nxcl_1MB | This is constant nxllMemoryManagerImpl.nxcl_1MB.
nxcl_AllocGranularity | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularity.
nxcl_AllocGranularityUnfreeable | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnfreeable.
nxcl_AllocGranularityUnpaged | This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnpaged.
nxcl_CleanupInterval | .5 sec
Namespace

nxllMemoryManagerImpl Namespace

Links
Constants, nxllMemoryManagerImpl Namespace


nxllMemoryManagerImpl._HookedMemoryManager Constant

nxllMemoryManagerImpl._HookedMemoryManager Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
_HookedMemoryManager: TMemoryManager = ( GetMem: _HookedGetMem; FreeMem: _HookedFreeMem; ReallocMem: _HookedReallocMem; );
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl._HookedMemoryManager.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl._MemoryManager Constant

nxllMemoryManagerImpl._MemoryManager Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
_MemoryManager: TMemoryManager = ( GetMem: nxmmItemManager. _GetMemMM _GetMem ; FreeMem: nxmmItemManager._FreeMem; ReallocMem: nxmmItemManager._ReallocMem; );
File

nxllMemoryManagerImpl

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.NoNXMMDLL Constant

nxllMemoryManagerImpl.NoNXMMDLL Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
NoNXMMDLL: AnsiString = 'Standard Server (non AWE)';
File

nxllMemoryManagerImpl

Description

nxcl_SmallDownsizeShiftFactor = 5;

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_1KB Constant

nxllMemoryManagerImpl.nxcl_1KB Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_1KB = 1024;
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl.nxcl_1KB.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_1MB Constant

nxllMemoryManagerImpl.nxcl_1MB Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_1MB = 1024 * nxcl_1KB;
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl.nxcl_1MB.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_AllocGranularity Constant

nxllMemoryManagerImpl.nxcl_AllocGranularity Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_AllocGranularity = 8;
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl.nxcl_AllocGranularity.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_AllocGranularityUnfreeable Constant

nxllMemoryManagerImpl.nxcl_AllocGranularityUnfreeable Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_AllocGranularityUnfreeable = 32;
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnfreeable.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_AllocGranularityUnpaged Constant

nxllMemoryManagerImpl.nxcl_AllocGranularityUnpaged Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_AllocGranularityUnpaged = 32;
File

nxllMemoryManagerImpl

Description

This is constant nxllMemoryManagerImpl.nxcl_AllocGranularityUnpaged.

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllMemoryManagerImpl.nxcl_CleanupInterval Constant

nxllMemoryManagerImpl.nxcl_CleanupInterval Constant
nxllMemoryManagerImpl Constants Send Feedback
Syntax
Delphi
nxcl_CleanupInterval = 500;
File

nxllMemoryManagerImpl

Description

.5 sec

Group

Constants

Links
nxllMemoryManagerImpl, Constants


nxllModuleLoader Namespace

nxllModuleLoader Namespace
Classes Constants Functions Interfaces Legend Topics Send Feedback

This is namespace nxllModuleLoader.

Classes
Name | Description
TnxModule | This is class nxllModuleLoader.TnxModule.
TnxModuleHandler | This is class nxllModuleLoader.TnxModuleHandler.
TnxModuleLoader | This is class nxllModuleLoader.TnxModuleLoader.
TnxModuleLoaderEnvironment | This is class nxllModuleLoader.TnxModuleLoaderEnvironment.
TnxPackage | This is class nxllModuleLoader.TnxPackage.
Constants
Name | Description
nxcModuleHandler | This is constant nxllModuleLoader.nxcModuleHandler.
Functions
Name | Description
nxFindAllClasses | nxFindAllClasses
nxFindAllClasses |
nxRegisterClasses | nxRegisterClasses
Interfaces
Name | Description
InxModuleLoader | This is class nxllModuleLoader.InxModuleLoader.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Functions, Interfaces, Legend, Topics


Classes

Classes
Classes nxllModuleLoader Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxModule | This is class nxllModuleLoader.TnxModule.
TnxModuleHandler | This is class nxllModuleLoader.TnxModuleHandler.
TnxModuleLoader | This is class nxllModuleLoader.TnxModuleLoader.
TnxModuleLoaderEnvironment | This is class nxllModuleLoader.TnxModuleLoaderEnvironment.
TnxPackage | This is class nxllModuleLoader.TnxPackage.
Namespace

nxllModuleLoader Namespace

Links
Classes, nxllModuleLoader Namespace, Legend


TnxModule Class

TnxModule Class
TnxModule Fields TnxModule Methods TnxModule Members nxllModuleLoader Classes Send Feedback
Class Hierarchy
nxllModuleLoader_TnxModulenxllModuleLoader_TnxModule
Syntax
Delphi
TnxModule = class(TnxObject);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.TnxModule.

Group

Classes

Links
TnxModule Fields, TnxModule Methods, TnxModule Members, nxllModuleLoader, Classes


TnxModule Members

TnxModule Members
TnxModule Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxModule.

Class

TnxModule Class

Protected Fields
Name | Description
modFileName | This is modFileName, a member of class TnxModule.
modLoader | private
modModule | This is modModule, a member of class TnxModule.
modPackages | This is modPackages, a member of class TnxModule.
modStartDfm | This is modStartDfm, a member of class TnxModule.
modText | This is modText, a member of class TnxModule.
modUses | This is modUses, a member of class TnxModule.
Protected Methods
Name | Description
Create | TnxModule
modAddPackage |
modAddUses |
modLoad |
modProcessText |
Public Methods
Name | Description
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxModule Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxModule.Create Constructor

TnxModule.Create Constructor
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Class Send Feedback
Syntax
Delphi
constructor Create(aLoader: TnxModuleLoader; const aModule: string);
Description

TnxModule

Class

TnxModule Class

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Class


TnxModule.Destroy Destructor

TnxModule.Destroy Destructor
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxModule Class

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Class


TnxModule Fields

TnxModule Fields
TnxModule Class Legend Protected Fields Send Feedback

The fields of the TnxModule class are listed here.

Class

TnxModule Class

Protected Fields
Name | Description
modFileName | This is modFileName, a member of class TnxModule.
modLoader | private
modModule | This is modModule, a member of class TnxModule.
modPackages | This is modPackages, a member of class TnxModule.
modStartDfm | This is modStartDfm, a member of class TnxModule.
modText | This is modText, a member of class TnxModule.
modUses | This is modUses, a member of class TnxModule.
Links
TnxModule Class, Legend, Protected Fields


TnxModule.modFileName Field

TnxModule.modFileName Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modFileName: string;
Description

This is modFileName, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modLoader Field

TnxModule.modLoader Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modLoader: TnxModuleLoader;
Description

private

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modModule Field

TnxModule.modModule Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modModule: string;
Description

This is modModule, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modPackages Field

TnxModule.modPackages Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modPackages: TStringList;
Description

This is modPackages, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modStartDfm Field

TnxModule.modStartDfm Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modStartDfm: Integer;
Description

This is modStartDfm, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modText Field

TnxModule.modText Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modText: TStringList;
Description

This is modText, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule.modUses Field

TnxModule.modUses Field
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Fields Send Feedback
Syntax
Delphi
modUses: TStringList;
Description

This is modUses, a member of class TnxModule.

Group

TnxModule Fields

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Fields


TnxModule Methods

TnxModule Methods
TnxModule Class Legend Protected Methods Send Feedback

The methods of the TnxModule class are listed here.

Class

TnxModule Class

Protected Methods
Name | Description
modAddPackage |
modAddUses |
modLoad |
modProcessText |
Links
TnxModule Class, Legend, Protected Methods


TnxModule.modAddPackage Method

TnxModule.modAddPackage Method
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Methods Send Feedback
Syntax
Delphi
procedure modAddPackage(const s: string);
Group

TnxModule Methods

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Methods


TnxModule.modAddUses Method

TnxModule.modAddUses Method
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Methods Send Feedback
Syntax
Delphi
procedure modAddUses(const s: string);
Group

TnxModule Methods

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Methods


TnxModule.modLoad Method

TnxModule.modLoad Method
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Methods Send Feedback
Syntax
Delphi
procedure modLoad(aHandler: TnxModuleHandler; aContext: TStringList);
Group

TnxModule Methods

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Methods


TnxModule.modProcessText Method

TnxModule.modProcessText Method
TnxModule Class TnxModule Members nxllModuleLoader Namespace TnxModule Methods Send Feedback
Syntax
Delphi
procedure modProcessText;
Group

TnxModule Methods

Links
TnxModule Class, TnxModule Members, nxllModuleLoader Namespace, TnxModule Methods


TnxModuleHandler Class

TnxModuleHandler Class
TnxModuleHandler Fields TnxModuleHandler Methods TnxModuleHandler Members nxllModuleLoader Classes Send Feedback
Class Hierarchy
nxllModuleLoader_TnxModuleHandlernxllModuleLoader_TnxModuleHandlernxllModuleLoader_TnxModuleHandlernxllModuleLoader_TnxModuleHandler
Syntax
Delphi
TnxModuleHandler = class(TnxComponent);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.TnxModuleHandler.

Group

Classes

Links
TnxModuleHandler Fields, TnxModuleHandler Methods, TnxModuleHandler Members, nxllModuleLoader, Classes


TnxModuleHandler Members

TnxModuleHandler Members
TnxModuleHandler Class Legend Protected Fields Protected Methods Public Methods Published Properties Send Feedback

The following tables list the members exposed by TnxModuleHandler.

Class

TnxModuleHandler Class

Protected Fields
Name | Description
mhEnvironment | private
mhLoadedModules | This is mhLoadedModules, a member of class TnxModuleHandler.
mhLoaders | This is mhLoaders, a member of class TnxModuleHandler.
mhModuleText | This is mhModuleText, a member of class TnxModuleHandler.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
mhLoadModule |
mhModuleLoaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Methods
Name | Description
AddLoader | TnxModuleHandler
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxModuleHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Published Properties


TnxModuleHandler.Create Constructor

TnxModuleHandler.Create Constructor
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Class

TnxModuleHandler Class

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Class


TnxModuleHandler.Destroy Destructor

TnxModuleHandler.Destroy Destructor
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxModuleHandler Class

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Class


TnxModuleHandler Fields

TnxModuleHandler Fields
TnxModuleHandler Class Legend Protected Fields Send Feedback

The fields of the TnxModuleHandler class are listed here.

Class

TnxModuleHandler Class

Protected Fields
Name | Description
mhEnvironment | private
mhLoadedModules | This is mhLoadedModules, a member of class TnxModuleHandler.
mhLoaders | This is mhLoaders, a member of class TnxModuleHandler.
mhModuleText | This is mhModuleText, a member of class TnxModuleHandler.
Links
TnxModuleHandler Class, Legend, Protected Fields


TnxModuleHandler.mhEnvironment Field

TnxModuleHandler.mhEnvironment Field
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Fields Send Feedback
Syntax
Delphi
mhEnvironment: TnxModuleLoaderEnvironment;
Description

private

Group

TnxModuleHandler Fields

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Fields


TnxModuleHandler.mhLoadedModules Field

TnxModuleHandler.mhLoadedModules Field
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Fields Send Feedback
Syntax
Delphi
mhLoadedModules: TStringList;
Description

This is mhLoadedModules, a member of class TnxModuleHandler.

Group

TnxModuleHandler Fields

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Fields


TnxModuleHandler.mhLoaders Field

TnxModuleHandler.mhLoaders Field
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Fields Send Feedback
Syntax
Delphi
mhLoaders: IInterfaceList;
Description

This is mhLoaders, a member of class TnxModuleHandler.

Group

TnxModuleHandler Fields

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Fields


TnxModuleHandler.mhModuleText Field

TnxModuleHandler.mhModuleText Field
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Fields Send Feedback
Syntax
Delphi
mhModuleText: TStringList;
Description

This is mhModuleText, a member of class TnxModuleHandler.

Group

TnxModuleHandler Fields

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Fields


TnxModuleHandler Methods

TnxModuleHandler Methods
TnxModuleHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxModuleHandler class are listed here.

Class

TnxModuleHandler Class

Protected Methods
Name | Description
mhLoadModule |
mhModuleLoaded |
Public Methods
Name | Description
AddLoader | TnxModuleHandler
Links
TnxModuleHandler Class, Legend, Protected Methods, Public Methods


TnxModuleHandler.AddLoader Method

TnxModuleHandler.AddLoader Method
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Methods Send Feedback
Syntax
Delphi
procedure AddLoader(aLoader: TnxModuleLoader);
Description

TnxModuleHandler

Group

TnxModuleHandler Methods

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Methods


TnxModuleHandler.mhLoadModule Method

TnxModuleHandler.mhLoadModule Method
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Methods Send Feedback
Syntax
Delphi
procedure mhLoadModule(aModule: TnxModule);
Group

TnxModuleHandler Methods

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Methods


TnxModuleHandler.mhModuleLoaded Method

TnxModuleHandler.mhModuleLoaded Method
TnxModuleHandler Class TnxModuleHandler Members nxllModuleLoader Namespace TnxModuleHandler Methods Send Feedback
Syntax
Delphi
function mhModuleLoaded(const aModule: string): Boolean;
Group

TnxModuleHandler Methods

Links
TnxModuleHandler Class, TnxModuleHandler Members, nxllModuleLoader Namespace, TnxModuleHandler Methods


TnxModuleLoader Class

TnxModuleLoader Class
TnxModuleLoader Fields TnxModuleLoader Methods TnxModuleLoader Members nxllModuleLoader Classes Send Feedback
Class Hierarchy
nxllModuleLoader_TnxModuleLoadernxllModuleLoader_TnxModuleLoadernxllModuleLoader_TnxModuleLoadernxllModuleLoader_TnxModuleLoader
Syntax
Delphi
TnxModuleLoader = class(TnxInterfacedObject, InxInterface, InxModuleLoader);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.TnxModuleLoader.

Group

Classes

Links
TnxModuleLoader Fields, TnxModuleLoader Methods, TnxModuleLoader Members, nxllModuleLoader, Classes


TnxModuleLoader Members

TnxModuleLoader Members
TnxModuleLoader Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxModuleLoader.

Class

TnxModuleLoader Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
mlEnvironment | private
mlEnvRef | This is mlEnvRef, a member of class TnxModuleLoader.
mlLocked | This is mlLocked, a member of class TnxModuleLoader.
mlModules | This is mlModules, a member of class TnxModuleLoader.
mlPackages | This is mlPackages, a member of class TnxModuleLoader.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
AddModule | InxModuleLoader TnxModuleLoader
ApplyToComponent |
Create |
ioDeactivate |
mlAddModule |
mlAddPackage |
mlLoadModules |
mlNotifyAddModule |
mlNotifyAddPackage |
mlNotifyRemoveModule |
mlNotifyRemovePackage |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxModuleLoader Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxModuleLoader.Create Constructor

TnxModuleLoader.Create Constructor
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Class Send Feedback
Syntax
Delphi
constructor Create(aEnvironment: TnxModuleLoaderEnvironment);
Class

TnxModuleLoader Class

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Class


TnxModuleLoader.Destroy Destructor

TnxModuleLoader.Destroy Destructor
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxModuleLoader Class

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Class


TnxModuleLoader Fields

TnxModuleLoader Fields
TnxModuleLoader Class Legend Protected Fields Send Feedback

The fields of the TnxModuleLoader class are listed here.

Class

TnxModuleLoader Class

Protected Fields
Name | Description
mlEnvironment | private
mlEnvRef | This is mlEnvRef, a member of class TnxModuleLoader.
mlLocked | This is mlLocked, a member of class TnxModuleLoader.
mlModules | This is mlModules, a member of class TnxModuleLoader.
mlPackages | This is mlPackages, a member of class TnxModuleLoader.
Links
TnxModuleLoader Class, Legend, Protected Fields


TnxModuleLoader.mlEnvironment Field

TnxModuleLoader.mlEnvironment Field
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Fields Send Feedback
Syntax
Delphi
mlEnvironment: TnxModuleLoaderEnvironment;
Description

private

Group

TnxModuleLoader Fields

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Fields


TnxModuleLoader.mlEnvRef Field

TnxModuleLoader.mlEnvRef Field
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Fields Send Feedback
Syntax
Delphi
mlEnvRef: InxInterface;
Description

This is mlEnvRef, a member of class TnxModuleLoader.

Group

TnxModuleLoader Fields

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Fields


TnxModuleLoader.mlLocked Field

TnxModuleLoader.mlLocked Field
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Fields Send Feedback
Syntax
Delphi
mlLocked: Boolean;
Description

This is mlLocked, a member of class TnxModuleLoader.

Group

TnxModuleLoader Fields

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Fields


TnxModuleLoader.mlModules Field

TnxModuleLoader.mlModules Field
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Fields Send Feedback
Syntax
Delphi
mlModules: TStringList;
Description

This is mlModules, a member of class TnxModuleLoader.

Group

TnxModuleLoader Fields

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Fields


TnxModuleLoader.mlPackages Field

TnxModuleLoader.mlPackages Field
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Fields Send Feedback
Syntax
Delphi
mlPackages: TStringList;
Description

This is mlPackages, a member of class TnxModuleLoader.

Group

TnxModuleLoader Fields

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Fields


TnxModuleLoader Methods

TnxModuleLoader Methods
TnxModuleLoader Class Legend Protected Methods Send Feedback

The methods of the TnxModuleLoader class are listed here.

Class

TnxModuleLoader Class

Protected Methods
Name | Description
AddModule | InxModuleLoader TnxModuleLoader
ApplyToComponent |
mlAddModule |
mlAddPackage |
mlLoadModules |
mlNotifyAddModule |
mlNotifyAddPackage |
mlNotifyRemoveModule |
mlNotifyRemovePackage |
Links
TnxModuleLoader Class, Legend, Protected Methods


TnxModuleLoader.AddModule Method

TnxModuleLoader.AddModule Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure AddModule(s: string);
Description

InxModuleLoader

TnxModuleLoader

Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.ApplyToComponent Method

TnxModuleLoader.ApplyToComponent Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure ApplyToComponent(aComponent: TComponent);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlAddModule Method

TnxModuleLoader.mlAddModule Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
function mlAddModule(S: string): TnxModule;
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlAddPackage Method

TnxModuleLoader.mlAddPackage Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
function mlAddPackage(S: string): TnxPackage;
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlLoadModules Method

TnxModuleLoader.mlLoadModules Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure mlLoadModules(aHandler: TnxModuleHandler);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlNotifyAddModule Method

TnxModuleLoader.mlNotifyAddModule Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure mlNotifyAddModule(aModule: TnxModule);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlNotifyAddPackage Method

TnxModuleLoader.mlNotifyAddPackage Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure mlNotifyAddPackage(aPackage: TnxPackage);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlNotifyRemoveModule Method

TnxModuleLoader.mlNotifyRemoveModule Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure mlNotifyRemoveModule(aModule: TnxModule);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoader.mlNotifyRemovePackage Method

TnxModuleLoader.mlNotifyRemovePackage Method
TnxModuleLoader Class TnxModuleLoader Members nxllModuleLoader Namespace TnxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure mlNotifyRemovePackage(aPackage: TnxPackage);
Group

TnxModuleLoader Methods

Links
TnxModuleLoader Class, TnxModuleLoader Members, nxllModuleLoader Namespace, TnxModuleLoader Methods


TnxModuleLoaderEnvironment Class

TnxModuleLoaderEnvironment Class
TnxModuleLoaderEnvironment Fields TnxModuleLoaderEnvironment Methods TnxModuleLoaderEnvironment Properties TnxModuleLoaderEnvironment Members nxllModuleLoader Classes Send Feedback
Class Hierarchy
nxllModuleLoader_TnxModuleLoaderEnvironmentnxllModuleLoader_TnxModuleLoaderEnvironmentnxllModuleLoader_TnxModuleLoaderEnvironment
Syntax
Delphi
TnxModuleLoaderEnvironment = class(TnxInterfacedObject, InxInterface);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.TnxModuleLoaderEnvironment.

Group

Classes

Links
TnxModuleLoaderEnvironment Fields, TnxModuleLoaderEnvironment Methods, TnxModuleLoaderEnvironment Properties, TnxModuleLoaderEnvironment Members, nxllModuleLoader, Classes


TnxModuleLoaderEnvironment Members

TnxModuleLoaderEnvironment Members
TnxModuleLoaderEnvironment Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxModuleLoaderEnvironment.

Class

TnxModuleLoaderEnvironment Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
mleModuleExtension | This is mleModuleExtension, a member of class TnxModuleLoaderEnvironment.
mleModuleSearchPath | private
mlePackageSearchPath | This is mlePackageSearchPath, a member of class TnxModuleLoaderEnvironment.
mleVersionString | This is mleVersionString, a member of class TnxModuleLoaderEnvironment.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
mleBuildPackageName |
mleFindInSearchPath |
mleFindModule |
mleFindPackage |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxModuleLoaderEnvironment
CreateModuleLoader |
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
ModuleExtension | This is ModuleExtension, a member of class TnxModuleLoaderEnvironment.
ModuleSearchPath | This is ModuleSearchPath, a member of class TnxModuleLoaderEnvironment.
PackageSearchPath | This is PackageSearchPath, a member of class TnxModuleLoaderEnvironment.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
VersionString | This is VersionString, a member of class TnxModuleLoaderEnvironment.
Links
TnxModuleLoaderEnvironment Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxModuleLoaderEnvironment.Create Constructor

TnxModuleLoaderEnvironment.Create Constructor
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxModuleLoaderEnvironment

Class

TnxModuleLoaderEnvironment Class

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Class


TnxModuleLoaderEnvironment.Destroy Destructor

TnxModuleLoaderEnvironment.Destroy Destructor
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxModuleLoaderEnvironment Class

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Class


TnxModuleLoaderEnvironment Fields

TnxModuleLoaderEnvironment Fields
TnxModuleLoaderEnvironment Class Legend Protected Fields Send Feedback

The fields of the TnxModuleLoaderEnvironment class are listed here.

Class

TnxModuleLoaderEnvironment Class

Protected Fields
Name | Description
mleModuleExtension | This is mleModuleExtension, a member of class TnxModuleLoaderEnvironment.
mleModuleSearchPath | private
mlePackageSearchPath | This is mlePackageSearchPath, a member of class TnxModuleLoaderEnvironment.
mleVersionString | This is mleVersionString, a member of class TnxModuleLoaderEnvironment.
Links
TnxModuleLoaderEnvironment Class, Legend, Protected Fields


TnxModuleLoaderEnvironment.mleModuleExtension Field

TnxModuleLoaderEnvironment.mleModuleExtension Field
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Fields Send Feedback
Syntax
Delphi
mleModuleExtension: string;
Description

This is mleModuleExtension, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Fields

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Fields


TnxModuleLoaderEnvironment.mleModuleSearchPath Field

TnxModuleLoaderEnvironment.mleModuleSearchPath Field
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Fields Send Feedback
Syntax
Delphi
mleModuleSearchPath: TStringList;
Description

private

Group

TnxModuleLoaderEnvironment Fields

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Fields


TnxModuleLoaderEnvironment.mlePackageSearchPath Field

TnxModuleLoaderEnvironment.mlePackageSearchPath Field
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Fields Send Feedback
Syntax
Delphi
mlePackageSearchPath: TStringList;
Description

This is mlePackageSearchPath, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Fields

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Fields


TnxModuleLoaderEnvironment.mleVersionString Field

TnxModuleLoaderEnvironment.mleVersionString Field
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Fields Send Feedback
Syntax
Delphi
mleVersionString: string;
Description

This is mleVersionString, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Fields

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Fields


TnxModuleLoaderEnvironment Methods

TnxModuleLoaderEnvironment Methods
TnxModuleLoaderEnvironment Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxModuleLoaderEnvironment class are listed here.

Class

TnxModuleLoaderEnvironment Class

Protected Methods
Name | Description
mleBuildPackageName |
mleFindInSearchPath |
mleFindModule |
mleFindPackage |
Public Methods
Name | Description
CreateModuleLoader |
Links
TnxModuleLoaderEnvironment Class, Legend, Protected Methods, Public Methods


TnxModuleLoaderEnvironment.CreateModuleLoader Method

TnxModuleLoaderEnvironment.CreateModuleLoader Method
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Methods Send Feedback
Syntax
Delphi
function CreateModuleLoader: InxModuleLoader;
Group

TnxModuleLoaderEnvironment Methods

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Methods


TnxModuleLoaderEnvironment.mleBuildPackageName Method

TnxModuleLoaderEnvironment.mleBuildPackageName Method
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Methods Send Feedback
Syntax
Delphi
function mleBuildPackageName(const s: string): string;
Group

TnxModuleLoaderEnvironment Methods

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Methods


TnxModuleLoaderEnvironment.mleFindInSearchPath Method

TnxModuleLoaderEnvironment.mleFindInSearchPath Method
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Methods Send Feedback
Syntax
Delphi
function mleFindInSearchPath(aSearchPath: TStringList; const aFileName: string): string;
Group

TnxModuleLoaderEnvironment Methods

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Methods


TnxModuleLoaderEnvironment.mleFindModule Method

TnxModuleLoaderEnvironment.mleFindModule Method
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Methods Send Feedback
Syntax
Delphi
function mleFindModule(S: string): string;
Group

TnxModuleLoaderEnvironment Methods

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Methods


TnxModuleLoaderEnvironment.mleFindPackage Method

TnxModuleLoaderEnvironment.mleFindPackage Method
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Methods Send Feedback
Syntax
Delphi
function mleFindPackage(S: string): string;
Group

TnxModuleLoaderEnvironment Methods

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Methods


TnxModuleLoaderEnvironment Properties

TnxModuleLoaderEnvironment Properties
TnxModuleLoaderEnvironment Class Legend Public Properties Send Feedback

The properties of the TnxModuleLoaderEnvironment class are listed here.

Class

TnxModuleLoaderEnvironment Class

Public Properties
Name | Description
ModuleExtension | This is ModuleExtension, a member of class TnxModuleLoaderEnvironment.
ModuleSearchPath | This is ModuleSearchPath, a member of class TnxModuleLoaderEnvironment.
PackageSearchPath | This is PackageSearchPath, a member of class TnxModuleLoaderEnvironment.
VersionString | This is VersionString, a member of class TnxModuleLoaderEnvironment.
Links
TnxModuleLoaderEnvironment Class, Legend, Public Properties


TnxModuleLoaderEnvironment.ModuleExtension Property

TnxModuleLoaderEnvironment.ModuleExtension Property
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Properties Send Feedback
Syntax
Delphi
property ModuleExtension: string;
Description

This is ModuleExtension, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Properties

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Properties


TnxModuleLoaderEnvironment.ModuleSearchPath Property

TnxModuleLoaderEnvironment.ModuleSearchPath Property
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Properties Send Feedback
Syntax
Delphi
property ModuleSearchPath: TStringList;
Description

This is ModuleSearchPath, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Properties

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Properties


TnxModuleLoaderEnvironment.PackageSearchPath Property

TnxModuleLoaderEnvironment.PackageSearchPath Property
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Properties Send Feedback
Syntax
Delphi
property PackageSearchPath: TStringList;
Description

This is PackageSearchPath, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Properties

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Properties


TnxModuleLoaderEnvironment.VersionString Property

TnxModuleLoaderEnvironment.VersionString Property
TnxModuleLoaderEnvironment Class TnxModuleLoaderEnvironment Members nxllModuleLoader Namespace TnxModuleLoaderEnvironment Properties Send Feedback
Syntax
Delphi
property VersionString: string;
Description

This is VersionString, a member of class TnxModuleLoaderEnvironment.

Group

TnxModuleLoaderEnvironment Properties

Links
TnxModuleLoaderEnvironment Class, TnxModuleLoaderEnvironment Members, nxllModuleLoader Namespace, TnxModuleLoaderEnvironment Properties


TnxPackage Class

TnxPackage Class
TnxPackage Fields TnxPackage Methods TnxPackage Members nxllModuleLoader Classes Send Feedback
Class Hierarchy
nxllModuleLoader_TnxPackagenxllModuleLoader_TnxPackage
Syntax
Delphi
TnxPackage = class(TnxObject);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.TnxPackage.

Group

Classes

Links
TnxPackage Fields, TnxPackage Methods, TnxPackage Members, nxllModuleLoader, Classes


TnxPackage Members

TnxPackage Members
TnxPackage Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPackage.

Class

TnxPackage Class

Protected Fields
Name | Description
pkgClasses | This is pkgClasses, a member of class TnxPackage.
pkgFileName | This is pkgFileName, a member of class TnxPackage.
pkgHandle | This is pkgHandle, a member of class TnxPackage.
pkgLoader | private
pkgPackage | This is pkgPackage, a member of class TnxPackage.
Protected Methods
Name | Description
Create | TnxPackage
pkgLoad |
Public Methods
Name | Description
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxPackage Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxPackage.Create Constructor

TnxPackage.Create Constructor
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Class Send Feedback
Syntax
Delphi
constructor Create(aLoader: TnxModuleLoader; const aPackage: string);
Description

TnxPackage

Class

TnxPackage Class

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Class


TnxPackage.Destroy Destructor

TnxPackage.Destroy Destructor
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxPackage Class

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Class


TnxPackage Fields

TnxPackage Fields
TnxPackage Class Legend Protected Fields Send Feedback

The fields of the TnxPackage class are listed here.

Class

TnxPackage Class

Protected Fields
Name | Description
pkgClasses | This is pkgClasses, a member of class TnxPackage.
pkgFileName | This is pkgFileName, a member of class TnxPackage.
pkgHandle | This is pkgHandle, a member of class TnxPackage.
pkgLoader | private
pkgPackage | This is pkgPackage, a member of class TnxPackage.
Links
TnxPackage Class, Legend, Protected Fields


TnxPackage.pkgClasses Field

TnxPackage.pkgClasses Field
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Fields Send Feedback
Syntax
Delphi
pkgClasses: TStringList;
Description

This is pkgClasses, a member of class TnxPackage.

Group

TnxPackage Fields

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Fields


TnxPackage.pkgFileName Field

TnxPackage.pkgFileName Field
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Fields Send Feedback
Syntax
Delphi
pkgFileName: string;
Description

This is pkgFileName, a member of class TnxPackage.

Group

TnxPackage Fields

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Fields


TnxPackage.pkgHandle Field

TnxPackage.pkgHandle Field
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Fields Send Feedback
Syntax
Delphi
pkgHandle: HMODULE;
Description

This is pkgHandle, a member of class TnxPackage.

Group

TnxPackage Fields

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Fields


TnxPackage.pkgLoader Field

TnxPackage.pkgLoader Field
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Fields Send Feedback
Syntax
Delphi
pkgLoader: TnxModuleLoader;
Description

private

Group

TnxPackage Fields

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Fields


TnxPackage.pkgPackage Field

TnxPackage.pkgPackage Field
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Fields Send Feedback
Syntax
Delphi
pkgPackage: string;
Description

This is pkgPackage, a member of class TnxPackage.

Group

TnxPackage Fields

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Fields


TnxPackage Methods

TnxPackage Methods
TnxPackage Class Legend Protected Methods Send Feedback

The methods of the TnxPackage class are listed here.

Class

TnxPackage Class

Protected Methods
Name | Description
pkgLoad |
Links
TnxPackage Class, Legend, Protected Methods


TnxPackage.pkgLoad Method

TnxPackage.pkgLoad Method
TnxPackage Class TnxPackage Members nxllModuleLoader Namespace TnxPackage Methods Send Feedback
Syntax
Delphi
procedure pkgLoad;
Group

TnxPackage Methods

Links
TnxPackage Class, TnxPackage Members, nxllModuleLoader Namespace, TnxPackage Methods


Interfaces

Interfaces
nxllModuleLoader Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllModuleLoader Namespace

Interfaces
Name | Description
InxModuleLoader | This is class nxllModuleLoader.InxModuleLoader.
Links
nxllModuleLoader Namespace, Interfaces, Legend


InxModuleLoader Interface

InxModuleLoader Interface
InxModuleLoader Methods InxModuleLoader Members nxllModuleLoader Interfaces Send Feedback
Class Hierarchy
nxllModuleLoader_InxModuleLoader
Syntax
Delphi
InxModuleLoader = interface(InxInterface);
File

nxllModuleLoader

Description

This is class nxllModuleLoader.InxModuleLoader.

Group

Interfaces

Links
InxModuleLoader Methods, InxModuleLoader Members, nxllModuleLoader, Interfaces


InxModuleLoader Members

InxModuleLoader Members
InxModuleLoader Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxModuleLoader.

Interface

InxModuleLoader Interface

Public Methods
Name | Description
AddModule | This is AddModule, a member of class InxModuleLoader.
ApplyToComponent | This is ApplyToComponent, a member of class InxModuleLoader.
Links
InxModuleLoader Interface, Legend, Public Methods


InxModuleLoader Methods

InxModuleLoader Methods
InxModuleLoader Interface Legend Public Methods Send Feedback

The methods of the InxModuleLoader class are listed here.

Interface

InxModuleLoader Interface

Public Methods
Name | Description
AddModule | This is AddModule, a member of class InxModuleLoader.
ApplyToComponent | This is ApplyToComponent, a member of class InxModuleLoader.
Links
InxModuleLoader Interface, Legend, Public Methods


InxModuleLoader.AddModule Method

InxModuleLoader.AddModule Method
InxModuleLoader Interface InxModuleLoader Members nxllModuleLoader Namespace InxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure AddModule(s: string);
Description

This is AddModule, a member of class InxModuleLoader.

Group

InxModuleLoader Methods

Links
InxModuleLoader Interface, InxModuleLoader Members, nxllModuleLoader Namespace, InxModuleLoader Methods


InxModuleLoader.ApplyToComponent Method

InxModuleLoader.ApplyToComponent Method
InxModuleLoader Interface InxModuleLoader Members nxllModuleLoader Namespace InxModuleLoader Methods Send Feedback
Syntax
Delphi
procedure ApplyToComponent(aComponent: TComponent);
Description

This is ApplyToComponent, a member of class InxModuleLoader.

Group

InxModuleLoader Methods

Links
InxModuleLoader Interface, InxModuleLoader Members, nxllModuleLoader Namespace, InxModuleLoader Methods


Functions

Functions
Functions nxllModuleLoader Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxFindAllClasses | nxFindAllClasses
nxFindAllClasses |
nxRegisterClasses | nxRegisterClasses
Namespace

nxllModuleLoader Namespace

Links
Functions, nxllModuleLoader Namespace, Legend


nxllModuleLoader.nxFindAllClasses Function

nxllModuleLoader.nxFindAllClasses Function
nxllModuleLoader Functions Send Feedback
Syntax
Delphi
function nxFindAllClasses(aModule: HMODULE): TStringList; overload;
File

nxllModuleLoader

Description

nxFindAllClasses

Group

Functions

Links
nxllModuleLoader, Functions


nxllModuleLoader.nxFindAllClasses Function

nxllModuleLoader.nxFindAllClasses Function
nxllModuleLoader Functions Send Feedback
Syntax
Delphi
function nxFindAllClasses(aBaseAddres: Pointer; aSize: Cardinal): TStringList; overload;
File

nxllModuleLoader

Group

Functions

Links
nxllModuleLoader, Functions


nxllModuleLoader.nxRegisterClasses Function

nxllModuleLoader.nxRegisterClasses Function
nxllModuleLoader Functions Send Feedback
Syntax
Delphi
procedure nxRegisterClasses(aClasses: TStringList);
File

nxllModuleLoader

Description

nxRegisterClasses

Group

Functions

Links
nxllModuleLoader, Functions


Constants

Constants
Constants nxllModuleLoader Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxcModuleHandler | This is constant nxllModuleLoader.nxcModuleHandler.
Namespace

nxllModuleLoader Namespace

Links
Constants, nxllModuleLoader Namespace


nxllModuleLoader.nxcModuleHandler Constant

nxllModuleLoader.nxcModuleHandler Constant
nxllModuleLoader Constants Send Feedback
Syntax
Delphi
nxcModuleHandler = '___nxModuleHandler___';
File

nxllModuleLoader

Description

This is constant nxllModuleLoader.nxcModuleHandler.

Group

Constants

Links
nxllModuleLoader, Constants


nxllPlatformInterface Namespace

nxllPlatformInterface Namespace
Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllPlatformInterface.

Constants
Name | Description
rsPlatformImplementationRequired | This is constant nxllPlatformInterface.rsPlatformImplementationRequired.
Functions
Name | Description
nxGetIsUIThread | This is function nxllPlatformInterface.nxGetIsUIThread.
nxSetIsUIThread | This is function nxllPlatformInterface.nxSetIsUIThread.
Interfaces
Name | Description
InxTimer | This is class nxllPlatformInterface.InxTimer.
Structs, Records, Enums
Name | Description
TnxJournalState | This is record nxllPlatformInterface.TnxJournalState.
TnxMsgDlgBtn | This is record nxllPlatformInterface.TnxMsgDlgBtn.
TnxMsgDlgType | This is record nxllPlatformInterface.TnxMsgDlgType.
Topics
Name | Description
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxAllocateHWnd | This is type nxllPlatformInterface.TnxAllocateHWnd.
TnxCreateTimerFunc | This is type nxllPlatformInterface.TnxCreateTimerFunc.
TnxDeallocateHWnd | This is type nxllPlatformInterface.TnxDeallocateHWnd.
TnxDefWindowProc | This is type nxllPlatformInterface.TnxDefWindowProc.
TnxMessageDlgFunc | This is type nxllPlatformInterface.TnxMessageDlgFunc.
TnxMsgDlgButtons | This is type nxllPlatformInterface.TnxMsgDlgButtons.
TnxShowExceptionFrmFunc | This is type nxllPlatformInterface.TnxShowExceptionFrmFunc.
TnxShowJournalFrmFunc | This is type nxllPlatformInterface.TnxShowJournalFrmFunc.
TnxShowLoginFrmFunc | This is type nxllPlatformInterface.TnxShowLoginFrmFunc.
TnxShowPickServerFrmFunc | This is type nxllPlatformInterface.TnxShowPickServerFrmFunc.
TnxSimpleEvent | This is type nxllPlatformInterface.TnxSimpleEvent.
Variables
Name | Description
nxAllocateHWnd | This is variable nxllPlatformInterface.nxAllocateHWnd.
nxCreateTimer | This is variable nxllPlatformInterface.nxCreateTimer.
nxDeallocateHWnd | This is variable nxllPlatformInterface.nxDeallocateHWnd.
nxDefWindowProc | This is variable nxllPlatformInterface.nxDefWindowProc.
nxHandleException | This is variable nxllPlatformInterface.nxHandleException.
nxMessageDlg | This is variable nxllPlatformInterface.nxMessageDlg.
nxProcessMessages | This is variable nxllPlatformInterface.nxProcessMessages.
nxShowExceptionFrm | TODO create form!!!
nxShowJournalFrm | This is variable nxllPlatformInterface.nxShowJournalFrm.
nxShowLoginFrm | This is variable nxllPlatformInterface.nxShowLoginFrm.
nxShowPickServerFrm | This is variable nxllPlatformInterface.nxShowPickServerFrm.
nxTerminate | This is variable nxllPlatformInterface.nxTerminate.
Links
Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Interfaces

Interfaces
nxllPlatformInterface Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllPlatformInterface Namespace

Interfaces
Name | Description
InxTimer | This is class nxllPlatformInterface.InxTimer.
Links
nxllPlatformInterface Namespace, Interfaces, Legend


InxTimer Interface

InxTimer Interface
InxTimer Methods InxTimer Properties InxTimer Members nxllPlatformInterface Interfaces Send Feedback
Class Hierarchy
nxllPlatformInterface_InxTimer
Syntax
Delphi
InxTimer = interface;
File

nxllPlatformInterface

Description

This is class nxllPlatformInterface.InxTimer.

Group

Interfaces

Links
InxTimer Methods, InxTimer Properties, InxTimer Members, nxllPlatformInterface, Interfaces


InxTimer Members

InxTimer Members
InxTimer Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxTimer.

Interface

InxTimer Interface

Public Methods
Name | Description
ftGetEnabled | This is ftGetEnabled, a member of class InxTimer.
ftGetInterval | This is ftGetInterval, a member of class InxTimer.
ftGetOnTimer | This is ftGetOnTimer, a member of class InxTimer.
ftSetEnabled | This is ftSetEnabled, a member of class InxTimer.
ftSetInterval | This is ftSetInterval, a member of class InxTimer.
ftSetOnTimer | This is ftSetOnTimer, a member of class InxTimer.
Public Properties
Name | Description
Enabled | This is Enabled, a member of class InxTimer.
Interval | This is Interval, a member of class InxTimer.
OnTimer | This is OnTimer, a member of class InxTimer.
Links
InxTimer Interface, Legend, Public Methods, Public Properties


InxTimer Methods

InxTimer Methods
InxTimer Interface Legend Public Methods Send Feedback

The methods of the InxTimer class are listed here.

Interface

InxTimer Interface

Public Methods
Name | Description
ftGetEnabled | This is ftGetEnabled, a member of class InxTimer.
ftGetInterval | This is ftGetInterval, a member of class InxTimer.
ftGetOnTimer | This is ftGetOnTimer, a member of class InxTimer.
ftSetEnabled | This is ftSetEnabled, a member of class InxTimer.
ftSetInterval | This is ftSetInterval, a member of class InxTimer.
ftSetOnTimer | This is ftSetOnTimer, a member of class InxTimer.
Links
InxTimer Interface, Legend, Public Methods


InxTimer.ftGetEnabled Method

InxTimer.ftGetEnabled Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
function ftGetEnabled: Boolean;
Description

This is ftGetEnabled, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer.ftGetInterval Method

InxTimer.ftGetInterval Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
function ftGetInterval: Cardinal;
Description

This is ftGetInterval, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer.ftGetOnTimer Method

InxTimer.ftGetOnTimer Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
function ftGetOnTimer: TNotifyEvent;
Description

This is ftGetOnTimer, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer.ftSetEnabled Method

InxTimer.ftSetEnabled Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetEnabled(aEnabled: Boolean);
Description

This is ftSetEnabled, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer.ftSetInterval Method

InxTimer.ftSetInterval Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetInterval(aInterval: Cardinal);
Description

This is ftSetInterval, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer.ftSetOnTimer Method

InxTimer.ftSetOnTimer Method
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetOnTimer(aOnTimer: TNotifyEvent);
Description

This is ftSetOnTimer, a member of class InxTimer.

Group

InxTimer Methods

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Methods


InxTimer Properties

InxTimer Properties
InxTimer Interface Legend Public Properties Send Feedback

The properties of the InxTimer class are listed here.

Interface

InxTimer Interface

Public Properties
Name | Description
Enabled | This is Enabled, a member of class InxTimer.
Interval | This is Interval, a member of class InxTimer.
OnTimer | This is OnTimer, a member of class InxTimer.
Links
InxTimer Interface, Legend, Public Properties


InxTimer.Enabled Property

InxTimer.Enabled Property
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Properties Send Feedback
Syntax
Delphi
property Enabled: Boolean;
Description

This is Enabled, a member of class InxTimer.

Group

InxTimer Properties

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Properties


InxTimer.Interval Property

InxTimer.Interval Property
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Properties Send Feedback
Syntax
Delphi
property Interval: Cardinal;
Description

This is Interval, a member of class InxTimer.

Group

InxTimer Properties

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Properties


InxTimer.OnTimer Property

InxTimer.OnTimer Property
InxTimer Interface InxTimer Members nxllPlatformInterface Namespace InxTimer Properties Send Feedback
Syntax
Delphi
property OnTimer: TNotifyEvent;
Description

This is OnTimer, a member of class InxTimer.

Group

InxTimer Properties

Links
InxTimer Interface, InxTimer Members, nxllPlatformInterface Namespace, InxTimer Properties


Functions

Functions
Functions nxllPlatformInterface Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxGetIsUIThread | This is function nxllPlatformInterface.nxGetIsUIThread.
nxSetIsUIThread | This is function nxllPlatformInterface.nxSetIsUIThread.
Namespace

nxllPlatformInterface Namespace

Links
Functions, nxllPlatformInterface Namespace, Legend


nxllPlatformInterface.nxGetIsUIThread Function

nxllPlatformInterface.nxGetIsUIThread Function
nxllPlatformInterface Functions Send Feedback
Syntax
Delphi
function nxGetIsUIThread: Boolean;
File

nxllPlatformInterface

Description

This is function nxllPlatformInterface.nxGetIsUIThread.

Group

Functions

Links
nxllPlatformInterface, Functions


nxllPlatformInterface.nxSetIsUIThread Function

nxllPlatformInterface.nxSetIsUIThread Function
nxllPlatformInterface Functions Send Feedback
Syntax
Delphi
procedure nxSetIsUIThread(const aValue: Boolean);
File

nxllPlatformInterface

Description

This is function nxllPlatformInterface.nxSetIsUIThread.

Group

Functions

Links
nxllPlatformInterface, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllPlatformInterface Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxJournalState | This is record nxllPlatformInterface.TnxJournalState.
TnxMsgDlgBtn | This is record nxllPlatformInterface.TnxMsgDlgBtn.
TnxMsgDlgType | This is record nxllPlatformInterface.TnxMsgDlgType.
Namespace

nxllPlatformInterface Namespace

Links
Enumerations, nxllPlatformInterface Namespace, Legend


nxllPlatformInterface.TnxJournalState Enumeration

nxllPlatformInterface.TnxJournalState Enumeration
nxllPlatformInterface Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxJournalState = ( jsComplete, jsIncomplete, jsTrash, jsSkipping );
File

nxllPlatformInterface

Description

This is record nxllPlatformInterface.TnxJournalState.

Group

Structs, Records, Enums

Links
nxllPlatformInterface, Structs, Records, Enums


nxllPlatformInterface.TnxMsgDlgBtn Enumeration

nxllPlatformInterface.TnxMsgDlgBtn Enumeration
nxllPlatformInterface Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMsgDlgBtn = ( nxmbYes, nxmbNo, nxmbOK, nxmbCancel, nxmbAbort, nxmbRetry, nxmbIgnore, nxmbAll, nxmbNoToAll, nxmbYesToAll, nxmbHelp );
File

nxllPlatformInterface

Description

This is record nxllPlatformInterface.TnxMsgDlgBtn.

Group

Structs, Records, Enums

Links
nxllPlatformInterface, Structs, Records, Enums


nxllPlatformInterface.TnxMsgDlgType Enumeration

nxllPlatformInterface.TnxMsgDlgType Enumeration
nxllPlatformInterface Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMsgDlgType = ( nxmtWarning, nxmtError, nxmtInformation, nxmtConfirmation, nxmtCustom );
File

nxllPlatformInterface

Description

This is record nxllPlatformInterface.TnxMsgDlgType.

Group

Structs, Records, Enums

Links
nxllPlatformInterface, Structs, Records, Enums


Types

Types
nxllPlatformInterface Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllPlatformInterface Namespace

Types
Name | Description
TnxAllocateHWnd | This is type nxllPlatformInterface.TnxAllocateHWnd.
TnxCreateTimerFunc | This is type nxllPlatformInterface.TnxCreateTimerFunc.
TnxDeallocateHWnd | This is type nxllPlatformInterface.TnxDeallocateHWnd.
TnxDefWindowProc | This is type nxllPlatformInterface.TnxDefWindowProc.
TnxMessageDlgFunc | This is type nxllPlatformInterface.TnxMessageDlgFunc.
TnxMsgDlgButtons | This is type nxllPlatformInterface.TnxMsgDlgButtons.
TnxShowExceptionFrmFunc | This is type nxllPlatformInterface.TnxShowExceptionFrmFunc.
TnxShowJournalFrmFunc | This is type nxllPlatformInterface.TnxShowJournalFrmFunc.
TnxShowLoginFrmFunc | This is type nxllPlatformInterface.TnxShowLoginFrmFunc.
TnxShowPickServerFrmFunc | This is type nxllPlatformInterface.TnxShowPickServerFrmFunc.
TnxSimpleEvent | This is type nxllPlatformInterface.TnxSimpleEvent.
Links
nxllPlatformInterface Namespace, Types


nxllPlatformInterface.TnxAllocateHWnd Type

nxllPlatformInterface.TnxAllocateHWnd Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxAllocateHWnd = function (aMethod : TWndMethod): HWND;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxAllocateHWnd.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxCreateTimerFunc Type

nxllPlatformInterface.TnxCreateTimerFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxCreateTimerFunc = function : InxTimer;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxCreateTimerFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxDeallocateHWnd Type

nxllPlatformInterface.TnxDeallocateHWnd Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxDeallocateHWnd = procedure (aWnd : HWND);
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxDeallocateHWnd.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxDefWindowProc Type

nxllPlatformInterface.TnxDefWindowProc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxDefWindowProc = function (hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): LRESULT;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxDefWindowProc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxMessageDlgFunc Type

nxllPlatformInterface.TnxMessageDlgFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxMessageDlgFunc = function (const aMsg : string; aDlgType : TnxMsgDlgType; aButtons : TnxMsgDlgButtons; aHelpCtx : Integer) : TnxMsgDlgBtn;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxMessageDlgFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxMsgDlgButtons Type

nxllPlatformInterface.TnxMsgDlgButtons Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxMsgDlgButtons = set of TnxMsgDlgBtn;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxMsgDlgButtons.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxShowExceptionFrmFunc Type

nxllPlatformInterface.TnxShowExceptionFrmFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxShowExceptionFrmFunc = function (aCaption, aExceptionText, aExceptionDetails : string) : Boolean;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxShowExceptionFrmFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxShowJournalFrmFunc Type

nxllPlatformInterface.TnxShowJournalFrmFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxShowJournalFrmFunc = function (aJournalState : TnxJournalState; aAlias : string; aPath : string; aFilename : string; aExceptionString : string) : Boolean;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxShowJournalFrmFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxShowLoginFrmFunc Type

nxllPlatformInterface.TnxShowLoginFrmFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxShowLoginFrmFunc = function (var aUserName : UnicodeString; var aPassword : UnicodeString) : Boolean;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxShowLoginFrmFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxShowPickServerFrmFunc Type

nxllPlatformInterface.TnxShowPickServerFrmFunc Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxShowPickServerFrmFunc = function (aNames : TStrings; out aServerName : string) : Boolean;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxShowPickServerFrmFunc.

Group

Types

Links
nxllPlatformInterface, Types


nxllPlatformInterface.TnxSimpleEvent Type

nxllPlatformInterface.TnxSimpleEvent Type
nxllPlatformInterface Types Send Feedback
Syntax
Delphi
TnxSimpleEvent = procedure of object;
File

nxllPlatformInterface

Description

This is type nxllPlatformInterface.TnxSimpleEvent.

Group

Types

Links
nxllPlatformInterface, Types


Variables

Variables
nxllPlatformInterface Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllPlatformInterface Namespace

Variables
Name | Description
nxAllocateHWnd | This is variable nxllPlatformInterface.nxAllocateHWnd.
nxCreateTimer | This is variable nxllPlatformInterface.nxCreateTimer.
nxDeallocateHWnd | This is variable nxllPlatformInterface.nxDeallocateHWnd.
nxDefWindowProc | This is variable nxllPlatformInterface.nxDefWindowProc.
nxHandleException | This is variable nxllPlatformInterface.nxHandleException.
nxMessageDlg | This is variable nxllPlatformInterface.nxMessageDlg.
nxProcessMessages | This is variable nxllPlatformInterface.nxProcessMessages.
nxShowExceptionFrm | TODO create form!!!
nxShowJournalFrm | This is variable nxllPlatformInterface.nxShowJournalFrm.
nxShowLoginFrm | This is variable nxllPlatformInterface.nxShowLoginFrm.
nxShowPickServerFrm | This is variable nxllPlatformInterface.nxShowPickServerFrm.
nxTerminate | This is variable nxllPlatformInterface.nxTerminate.
Links
nxllPlatformInterface Namespace, Variables


nxllPlatformInterface.nxAllocateHWnd Variable

nxllPlatformInterface.nxAllocateHWnd Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxAllocateHWnd: TnxAllocateHWnd;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxAllocateHWnd.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxCreateTimer Variable

nxllPlatformInterface.nxCreateTimer Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxCreateTimer: TnxCreateTimerFunc = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxCreateTimer.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxDeallocateHWnd Variable

nxllPlatformInterface.nxDeallocateHWnd Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxDeallocateHWnd: TnxDeallocateHWnd;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxDeallocateHWnd.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxDefWindowProc Variable

nxllPlatformInterface.nxDefWindowProc Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxDefWindowProc: TnxDefWindowProc;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxDefWindowProc.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxHandleException Variable

nxllPlatformInterface.nxHandleException Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxHandleException: TNotifyEvent = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxHandleException.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxMessageDlg Variable

nxllPlatformInterface.nxMessageDlg Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxMessageDlg: TnxMessageDlgFunc = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxMessageDlg.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxProcessMessages Variable

nxllPlatformInterface.nxProcessMessages Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxProcessMessages: TnxSimpleEvent = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxProcessMessages.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxShowExceptionFrm Variable

nxllPlatformInterface.nxShowExceptionFrm Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxShowExceptionFrm: TnxShowExceptionFrmFunc = nil;
File

nxllPlatformInterface

Description

TODO create form!!!

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxShowJournalFrm Variable

nxllPlatformInterface.nxShowJournalFrm Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxShowJournalFrm: TnxShowJournalFrmFunc = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxShowJournalFrm.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxShowLoginFrm Variable

nxllPlatformInterface.nxShowLoginFrm Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxShowLoginFrm: TnxShowLoginFrmFunc = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxShowLoginFrm.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxShowPickServerFrm Variable

nxllPlatformInterface.nxShowPickServerFrm Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxShowPickServerFrm: TnxShowPickServerFrmFunc = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxShowPickServerFrm.

Group

Variables

Links
nxllPlatformInterface, Variables


nxllPlatformInterface.nxTerminate Variable

nxllPlatformInterface.nxTerminate Variable
nxllPlatformInterface Variables Send Feedback
Syntax
Delphi
nxTerminate: TnxSimpleEvent = nil;
File

nxllPlatformInterface

Description

This is variable nxllPlatformInterface.nxTerminate.

Group

Variables

Links
nxllPlatformInterface, Variables


Constants

Constants
Constants nxllPlatformInterface Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsPlatformImplementationRequired | This is constant nxllPlatformInterface.rsPlatformImplementationRequired.
Namespace

nxllPlatformInterface Namespace

Links
Constants, nxllPlatformInterface Namespace


nxllPlatformInterface.rsPlatformImplementationRequired Constant

nxllPlatformInterface.rsPlatformImplementationRequired Constant
nxllPlatformInterface Constants Send Feedback
Syntax
Delphi
rsPlatformImplementationRequired = 'A platform implementation unit (e.g. nxpvPlatformImplementation or Fmx.nxpvPlatformImplementation) must be added to the USES clause.';
File

nxllPlatformInterface

Description

This is constant nxllPlatformInterface.rsPlatformImplementationRequired.

Group

Constants

Links
nxllPlatformInterface, Constants


nxllPluginBase Namespace

nxllPluginBase Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxllPluginBase.

Classes
Name | Description
EnxPluginEngineException | The base Exception type used for plugins.
EnxPluginException | The base Exception type used for plugins.
TnxBasePlugin | The base for all plugins.
TnxBasePluginEngine | The base for all plugin engines.
Constants
Name | Description
rsNoSessionAssigend | This is constant nxllPluginBase.rsNoSessionAssigend.
rsPlugins | This is constant nxllPluginBase.rsPlugins.
rsTheSessionMustSupportInxSessionRequests | This is constant nxllPluginBase.rsTheSessionMustSupportInxSessionRequests.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxllPluginBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxPluginEngineException | The base Exception type used for plugins.
EnxPluginException | The base Exception type used for plugins.
TnxBasePlugin | The base for all plugins.
TnxBasePluginEngine | The base for all plugin engines.
Namespace

nxllPluginBase Namespace

Links
Classes, nxllPluginBase Namespace, Legend


EnxPluginEngineException Class

EnxPluginEngineException Class
nxllPluginBase Classes Send Feedback
Class Hierarchy
nxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineExceptionnxllPluginBase_EnxPluginEngineException
Syntax
Delphi
EnxPluginEngineException = class(EnxPluginException);
File

nxllPluginBase

Description

The base Exception type used for plugins.

Group

Classes

Links
nxllPluginBase, Classes


EnxPluginException Class

EnxPluginException Class
nxllPluginBase Classes Send Feedback
Class Hierarchy
nxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginExceptionnxllPluginBase_EnxPluginException
Syntax
Delphi
EnxPluginException = class(EnxStateComponentException);
File

nxllPluginBase

Description

The base Exception type used for plugins.

Group

Classes

Links
nxllPluginBase, Classes


TnxBasePlugin Class

TnxBasePlugin Class
nxllPluginBase Classes Send Feedback
Class Hierarchy
nxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePluginnxllPluginBase_TnxBasePlugin
Syntax
Delphi
TnxBasePlugin = class(TnxStateComponent);
File

nxllPluginBase

Description

The base for all plugins.

Group

Classes

Links
nxllPluginBase, Classes


TnxBasePluginEngine Class

TnxBasePluginEngine Class
TnxBasePluginEngine Fields TnxBasePluginEngine Methods TnxBasePluginEngine Properties TnxBasePluginEngine Members nxllPluginBase Classes Send Feedback
Class Hierarchy
nxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEnginenxllPluginBase_TnxBasePluginEngine
Syntax
Delphi
TnxBasePluginEngine = class(TnxBasePlugin);
File

nxllPluginBase

Description

The base for all plugin engines.

Group

Classes

Links
TnxBasePluginEngine Fields, TnxBasePluginEngine Methods, TnxBasePluginEngine Properties, TnxBasePluginEngine Members, nxllPluginBase, Classes


TnxBasePluginEngine Members

TnxBasePluginEngine Members
TnxBasePluginEngine Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBasePluginEngine.

Class

TnxBasePluginEngine Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxBasePluginEngine
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBasePluginEngine Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxBasePluginEngine.Create Constructor

TnxBasePluginEngine.Create Constructor
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

Class

TnxBasePluginEngine Class

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Class


TnxBasePluginEngine Fields

TnxBasePluginEngine Fields
TnxBasePluginEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBasePluginEngine class are listed here.

Class

TnxBasePluginEngine Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
Links
TnxBasePluginEngine Class, Legend, Protected Fields


TnxBasePluginEngine.bpeSession Field

TnxBasePluginEngine.bpeSession Field
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Fields Send Feedback
Syntax
Delphi
bpeSession: TnxStateComponent;
Description

private.

Group

TnxBasePluginEngine Fields

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Fields


TnxBasePluginEngine.bpeTimeout Field

TnxBasePluginEngine.bpeTimeout Field
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Fields Send Feedback
Syntax
Delphi
bpeTimeout: TnxWord32;
Description

This is bpeTimeout, a member of class TnxBasePluginEngine.

Group

TnxBasePluginEngine Fields

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Fields


TnxBasePluginEngine Methods

TnxBasePluginEngine Methods
TnxBasePluginEngine Class Legend Protected Methods Send Feedback

The methods of the TnxBasePluginEngine class are listed here.

Class

TnxBasePluginEngine Class

Protected Methods
Name | Description
bpeIsRemote | TnxBasePluginEngine
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
nxcExceptionClass |
nxcNotification |
RequestNoData |
RequestNoDataNoReply |
scInitializing |
scIsStateParent |
Links
TnxBasePluginEngine Class, Legend, Protected Methods


TnxBasePluginEngine.bpeIsRemote Method

TnxBasePluginEngine.bpeIsRemote Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
class function bpeIsRemote: Boolean; virtual;
Description

TnxBasePluginEngine

Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.bpeProcessPost Method

TnxBasePluginEngine.bpeProcessPost Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
procedure bpeProcessPost(aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aThreadPriority: TnxThreadPriority = 0);
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.bpeProcessRequest Method

TnxBasePluginEngine.bpeProcessRequest Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function bpeProcessRequest(aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType; aThreadPriority: TnxThreadPriority = 0): TnxResult;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.bpeProcessStreamedRequest Method

TnxBasePluginEngine.bpeProcessStreamedRequest Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function bpeProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.bpeSetSession Method

TnxBasePluginEngine.bpeSetSession Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
procedure bpeSetSession(aSession: TnxStateComponent);
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.CreateRequest Method

TnxBasePluginEngine.CreateRequest Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.nxcExceptionClass Method

TnxBasePluginEngine.nxcExceptionClass Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.nxcNotification Method

TnxBasePluginEngine.nxcNotification Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.RequestNoData Method

TnxBasePluginEngine.RequestNoData Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.RequestNoDataNoReply Method

TnxBasePluginEngine.RequestNoDataNoReply Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.scInitializing Method

TnxBasePluginEngine.scInitializing Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine.scIsStateParent Method

TnxBasePluginEngine.scIsStateParent Method
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBasePluginEngine Methods

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Methods


TnxBasePluginEngine Properties

TnxBasePluginEngine Properties
TnxBasePluginEngine Class Legend Protected Properties Send Feedback

The properties of the TnxBasePluginEngine class are listed here.

Class

TnxBasePluginEngine Class

Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Links
TnxBasePluginEngine Class, Legend, Protected Properties


TnxBasePluginEngine.Session Property

TnxBasePluginEngine.Session Property
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Properties Send Feedback
Syntax
Delphi
property Session: TnxStateComponent;
Description

This is Session, a member of class TnxBasePluginEngine.

Group

TnxBasePluginEngine Properties

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Properties


TnxBasePluginEngine.Timeout Property

TnxBasePluginEngine.Timeout Property
TnxBasePluginEngine Class TnxBasePluginEngine Members nxllPluginBase Namespace TnxBasePluginEngine Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

This is Timeout, a member of class TnxBasePluginEngine.

Group

TnxBasePluginEngine Properties

Links
TnxBasePluginEngine Class, TnxBasePluginEngine Members, nxllPluginBase Namespace, TnxBasePluginEngine Properties


Constants

Constants
Constants nxllPluginBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsNoSessionAssigend | This is constant nxllPluginBase.rsNoSessionAssigend.
rsPlugins | This is constant nxllPluginBase.rsPlugins.
rsTheSessionMustSupportInxSessionRequests | This is constant nxllPluginBase.rsTheSessionMustSupportInxSessionRequests.
Namespace

nxllPluginBase Namespace

Links
Constants, nxllPluginBase Namespace


nxllPluginBase.rsNoSessionAssigend Constant

nxllPluginBase.rsNoSessionAssigend Constant
nxllPluginBase Constants Send Feedback
Syntax
Delphi
rsNoSessionAssigend = 'No Session assigend';
File

nxllPluginBase

Description

This is constant nxllPluginBase.rsNoSessionAssigend.

Group

Constants

Links
nxllPluginBase, Constants


nxllPluginBase.rsPlugins Constant

nxllPluginBase.rsPlugins Constant
nxllPluginBase Constants Send Feedback
Syntax
Delphi
rsPlugins = 'Plugins';
File

nxllPluginBase

Description

This is constant nxllPluginBase.rsPlugins.

Group

Constants

Links
nxllPluginBase, Constants


nxllPluginBase.rsTheSessionMustSupportInxSessionRequests Constant

nxllPluginBase.rsTheSessionMustSupportInxSessionRequests Constant
nxllPluginBase Constants Send Feedback
Syntax
Delphi
rsTheSessionMustSupportInxSessionRequests = 'The Session must support InxSessionRequests';
File

nxllPluginBase

Description

This is constant nxllPluginBase.rsTheSessionMustSupportInxSessionRequests.

Group

Constants

Links
nxllPluginBase, Constants


nxllQueue Namespace

nxllQueue Namespace
Classes Legend Topics Send Feedback

This is namespace nxllQueue.

Classes
Name | Description
TnxQueue | This is class nxllQueue.TnxQueue.
TnxQueueItem | This is class nxllQueue.TnxQueueItem.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxllQueue Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxQueue | This is class nxllQueue.TnxQueue.
TnxQueueItem | This is class nxllQueue.TnxQueueItem.
Namespace

nxllQueue Namespace

Links
Classes, nxllQueue Namespace, Legend


TnxQueue Class

TnxQueue Class
TnxQueue Fields TnxQueue Methods TnxQueue Members nxllQueue Classes Send Feedback
Class Hierarchy
nxllQueue_TnxQueuenxllQueue_TnxQueue
Syntax
Delphi
TnxQueue = class(TnxObject);
File

nxllQueue

Description

This is class nxllQueue.TnxQueue.

Group

Classes

Links
TnxQueue Fields, TnxQueue Methods, TnxQueue Members, nxllQueue, Classes


TnxQueue Members

TnxQueue Members
TnxQueue Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxQueue.

Class

TnxQueue Class

Protected Fields
Name | Description
tsqItemsHead | private
tsqItemsTail | This is tsqItemsTail, a member of class TnxQueue.
Public Methods
Name | Description
Dequeue | TnxQueue
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxQueue Class, Legend, Protected Fields, Public Methods


TnxQueue.Destroy Destructor

TnxQueue.Destroy Destructor
TnxQueue Class TnxQueue Members nxllQueue Namespace TnxQueue Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxQueue Class

Links
TnxQueue Class, TnxQueue Members, nxllQueue Namespace, TnxQueue Class


TnxQueue Fields

TnxQueue Fields
TnxQueue Class Legend Protected Fields Send Feedback

The fields of the TnxQueue class are listed here.

Class

TnxQueue Class

Protected Fields
Name | Description
tsqItemsHead | private
tsqItemsTail | This is tsqItemsTail, a member of class TnxQueue.
Links
TnxQueue Class, Legend, Protected Fields


TnxQueue.tsqItemsHead Field

TnxQueue.tsqItemsHead Field
TnxQueue Class TnxQueue Members nxllQueue Namespace TnxQueue Fields Send Feedback
Syntax
Delphi
tsqItemsHead: TnxQueueItem;
Description

private

Group

TnxQueue Fields

Links
TnxQueue Class, TnxQueue Members, nxllQueue Namespace, TnxQueue Fields


TnxQueue.tsqItemsTail Field

TnxQueue.tsqItemsTail Field
TnxQueue Class TnxQueue Members nxllQueue Namespace TnxQueue Fields Send Feedback
Syntax
Delphi
tsqItemsTail: TnxQueueItem;
Description

This is tsqItemsTail, a member of class TnxQueue.

Group

TnxQueue Fields

Links
TnxQueue Class, TnxQueue Members, nxllQueue Namespace, TnxQueue Fields


TnxQueue Methods

TnxQueue Methods
TnxQueue Class Legend Public Methods Send Feedback

The methods of the TnxQueue class are listed here.

Class

TnxQueue Class

Public Methods
Name | Description
Dequeue | TnxQueue
Links
TnxQueue Class, Legend, Public Methods


TnxQueue.Dequeue Method

TnxQueue.Dequeue Method
TnxQueue Class TnxQueue Members nxllQueue Namespace TnxQueue Methods Send Feedback
Syntax
Delphi
function Dequeue: TnxQueueItem;
Description

TnxQueue

Group

TnxQueue Methods

Links
TnxQueue Class, TnxQueue Members, nxllQueue Namespace, TnxQueue Methods


TnxQueueItem Class

TnxQueueItem Class
TnxQueueItem Fields TnxQueueItem Methods TnxQueueItem Members nxllQueue Classes Send Feedback
Class Hierarchy
nxllQueue_TnxQueueItem
Syntax
Delphi
TnxQueueItem = class(TObject);
File

nxllQueue

Description

This is class nxllQueue.TnxQueueItem.

Group

Classes

Links
TnxQueueItem Fields, TnxQueueItem Methods, TnxQueueItem Members, nxllQueue, Classes


TnxQueueItem Members

TnxQueueItem Members
TnxQueueItem Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxQueueItem.

Class

TnxQueueItem Class

Protected Fields
Name | Description
qiQueue | private
qiQueueNext | This is qiQueueNext, a member of class TnxQueueItem.
qiQueuePrev | This is qiQueuePrev, a member of class TnxQueueItem.
Protected Methods
Name | Description
qiAddToQueue |
qiRemoveFromQueue |
Public Methods
Name | Description
Create | TnxQueueItem
Destroy |
Links
TnxQueueItem Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxQueueItem.Create Constructor

TnxQueueItem.Create Constructor
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Class Send Feedback
Syntax
Delphi
constructor Create(aQueue: TnxQueue);
Description

TnxQueueItem

Class

TnxQueueItem Class

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Class


TnxQueueItem.Destroy Destructor

TnxQueueItem.Destroy Destructor
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxQueueItem Class

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Class


TnxQueueItem Fields

TnxQueueItem Fields
TnxQueueItem Class Legend Protected Fields Send Feedback

The fields of the TnxQueueItem class are listed here.

Class

TnxQueueItem Class

Protected Fields
Name | Description
qiQueue | private
qiQueueNext | This is qiQueueNext, a member of class TnxQueueItem.
qiQueuePrev | This is qiQueuePrev, a member of class TnxQueueItem.
Links
TnxQueueItem Class, Legend, Protected Fields


TnxQueueItem.qiQueue Field

TnxQueueItem.qiQueue Field
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Fields Send Feedback
Syntax
Delphi
qiQueue: TnxQueue;
Description

private

Group

TnxQueueItem Fields

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Fields


TnxQueueItem.qiQueueNext Field

TnxQueueItem.qiQueueNext Field
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Fields Send Feedback
Syntax
Delphi
qiQueueNext: TnxQueueItem;
Description

This is qiQueueNext, a member of class TnxQueueItem.

Group

TnxQueueItem Fields

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Fields


TnxQueueItem.qiQueuePrev Field

TnxQueueItem.qiQueuePrev Field
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Fields Send Feedback
Syntax
Delphi
qiQueuePrev: TnxQueueItem;
Description

This is qiQueuePrev, a member of class TnxQueueItem.

Group

TnxQueueItem Fields

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Fields


TnxQueueItem Methods

TnxQueueItem Methods
TnxQueueItem Class Legend Protected Methods Send Feedback

The methods of the TnxQueueItem class are listed here.

Class

TnxQueueItem Class

Protected Methods
Name | Description
qiAddToQueue |
qiRemoveFromQueue |
Links
TnxQueueItem Class, Legend, Protected Methods


TnxQueueItem.qiAddToQueue Method

TnxQueueItem.qiAddToQueue Method
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Methods Send Feedback
Syntax
Delphi
procedure qiAddToQueue;
Group

TnxQueueItem Methods

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Methods


TnxQueueItem.qiRemoveFromQueue Method

TnxQueueItem.qiRemoveFromQueue Method
TnxQueueItem Class TnxQueueItem Members nxllQueue Namespace TnxQueueItem Methods Send Feedback
Syntax
Delphi
procedure qiRemoveFromQueue;
Group

TnxQueueItem Methods

Links
TnxQueueItem Class, TnxQueueItem Members, nxllQueue Namespace, TnxQueueItem Methods


nxllRegisterableEngine Namespace

nxllRegisterableEngine Namespace
Classes Constants Legend Topics Types Send Feedback

This is namespace nxllRegisterableEngine.

Classes
Name | Description
EnxBaseRegisterableDescriptorException | This is class nxllRegisterableEngine.EnxBaseRegisterableDescriptorException.
EnxBaseRegisterableEngineException | This is class nxllRegisterableEngine.EnxBaseRegisterableEngineException.
TnxBaseRegisterableDescriptor | This is class nxllRegisterableEngine.TnxBaseRegisterableDescriptor.
TnxBaseRegisterableEngine | This is class nxllRegisterableEngine.TnxBaseRegisterableEngine.
Constants
Name | Description
csDescriptor | This is constant nxllRegisterableEngine.csDescriptor.
csEngine | This is constant nxllRegisterableEngine.csEngine.
rsUnknownEngine | This is constant nxllRegisterableEngine.rsUnknownEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PStringList | Pointer to TStringlist. Internally needed.
TnxBaseRegisterableDescriptorClass | This is type nxllRegisterableEngine.TnxBaseRegisterableDescriptorClass.
TnxBaseRegisterableEngineClass | This is type nxllRegisterableEngine.TnxBaseRegisterableEngineClass.
Links
Classes, Constants, Legend, Topics, Types


Classes

Classes
Classes nxllRegisterableEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseRegisterableDescriptorException | This is class nxllRegisterableEngine.EnxBaseRegisterableDescriptorException.
EnxBaseRegisterableEngineException | This is class nxllRegisterableEngine.EnxBaseRegisterableEngineException.
TnxBaseRegisterableDescriptor | This is class nxllRegisterableEngine.TnxBaseRegisterableDescriptor.
TnxBaseRegisterableEngine | This is class nxllRegisterableEngine.TnxBaseRegisterableEngine.
Namespace

nxllRegisterableEngine Namespace

Links
Classes, nxllRegisterableEngine Namespace, Legend


EnxBaseRegisterableDescriptorException Class

EnxBaseRegisterableDescriptorException Class
nxllRegisterableEngine Classes Send Feedback
Class Hierarchy
nxllRegisterableEngine_EnxBaseRegisterableDescriptorExceptionnxllRegisterableEngine_EnxBaseRegisterableDescriptorExceptionnxllRegisterableEngine_EnxBaseRegisterableDescriptorExceptionnxllRegisterableEngine_EnxBaseRegisterableDescriptorException
Syntax
Delphi
EnxBaseRegisterableDescriptorException = class(EnxBaseException);
File

nxllRegisterableEngine

Description

This is class nxllRegisterableEngine.EnxBaseRegisterableDescriptorException.

Group

Classes

Links
nxllRegisterableEngine, Classes


EnxBaseRegisterableEngineException Class

EnxBaseRegisterableEngineException Class
nxllRegisterableEngine Classes Send Feedback
Class Hierarchy
nxllRegisterableEngine_EnxBaseRegisterableEngineExceptionnxllRegisterableEngine_EnxBaseRegisterableEngineExceptionnxllRegisterableEngine_EnxBaseRegisterableEngineExceptionnxllRegisterableEngine_EnxBaseRegisterableEngineException
Syntax
Delphi
EnxBaseRegisterableEngineException = class(EnxBaseException);
File

nxllRegisterableEngine

Description

This is class nxllRegisterableEngine.EnxBaseRegisterableEngineException.

Group

Classes

Links
nxllRegisterableEngine, Classes


TnxBaseRegisterableDescriptor Class

TnxBaseRegisterableDescriptor Class
TnxBaseRegisterableDescriptor Methods TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Classes Send Feedback
Class Hierarchy
nxllRegisterableEngine_TnxBaseRegisterableDescriptornxllRegisterableEngine_TnxBaseRegisterableDescriptornxllRegisterableEngine_TnxBaseRegisterableDescriptornxllRegisterableEngine_TnxBaseRegisterableDescriptor
Syntax
Delphi
TnxBaseRegisterableDescriptor = class(TnxLifetimeTrackedPersistent);
File

nxllRegisterableEngine

Description

This is class nxllRegisterableEngine.TnxBaseRegisterableDescriptor.

Group

Classes

Links
TnxBaseRegisterableDescriptor Methods, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine, Classes


TnxBaseRegisterableDescriptor Members

TnxBaseRegisterableDescriptor Members
TnxBaseRegisterableDescriptor Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseRegisterableDescriptor.

Class

TnxBaseRegisterableDescriptor Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxBaseRegisterableDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseRegisterableDescriptor Methods

TnxBaseRegisterableDescriptor Methods
TnxBaseRegisterableDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRegisterableDescriptor class are listed here.

Class

TnxBaseRegisterableDescriptor Class

Protected Methods
Name | Description
GetList |
Register |
Unregister |
Public Methods
Name | Description
FindDescriptorClass | TnxBaseRegisterableDescriptor
GetRegisteredDescriptors |
Links
TnxBaseRegisterableDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseRegisterableDescriptor.FindDescriptorClass Method

TnxBaseRegisterableDescriptor.FindDescriptorClass Method
TnxBaseRegisterableDescriptor Class TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Namespace TnxBaseRegisterableDescriptor Methods Send Feedback
Syntax
Delphi
class function FindDescriptorClass(const aName: string): TnxBaseRegisterableDescriptorClass;
Description

TnxBaseRegisterableDescriptor

Group

TnxBaseRegisterableDescriptor Methods

Links
TnxBaseRegisterableDescriptor Class, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableDescriptor Methods


TnxBaseRegisterableDescriptor.GetList Method

TnxBaseRegisterableDescriptor.GetList Method
TnxBaseRegisterableDescriptor Class TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Namespace TnxBaseRegisterableDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; virtual;
Group

TnxBaseRegisterableDescriptor Methods

Links
TnxBaseRegisterableDescriptor Class, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableDescriptor Methods


TnxBaseRegisterableDescriptor.GetRegisteredDescriptors Method

TnxBaseRegisterableDescriptor.GetRegisteredDescriptors Method
TnxBaseRegisterableDescriptor Class TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Namespace TnxBaseRegisterableDescriptor Methods Send Feedback
Syntax
Delphi
class procedure GetRegisteredDescriptors(aList: TStrings; aIncludeAliases: Boolean = False);
Group

TnxBaseRegisterableDescriptor Methods

Links
TnxBaseRegisterableDescriptor Class, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableDescriptor Methods


TnxBaseRegisterableDescriptor.Register Method

TnxBaseRegisterableDescriptor.Register Method
TnxBaseRegisterableDescriptor Class TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Namespace TnxBaseRegisterableDescriptor Methods Send Feedback
Syntax
Delphi
class procedure Register(aAlias: string = '');
Group

TnxBaseRegisterableDescriptor Methods

Links
TnxBaseRegisterableDescriptor Class, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableDescriptor Methods


TnxBaseRegisterableDescriptor.Unregister Method

TnxBaseRegisterableDescriptor.Unregister Method
TnxBaseRegisterableDescriptor Class TnxBaseRegisterableDescriptor Members nxllRegisterableEngine Namespace TnxBaseRegisterableDescriptor Methods Send Feedback
Syntax
Delphi
class procedure Unregister;
Group

TnxBaseRegisterableDescriptor Methods

Links
TnxBaseRegisterableDescriptor Class, TnxBaseRegisterableDescriptor Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableDescriptor Methods


TnxBaseRegisterableEngine Class

TnxBaseRegisterableEngine Class
TnxBaseRegisterableEngine Methods TnxBaseRegisterableEngine Members nxllRegisterableEngine Classes Send Feedback
Class Hierarchy
nxllRegisterableEngine_TnxBaseRegisterableEnginenxllRegisterableEngine_TnxBaseRegisterableEnginenxllRegisterableEngine_TnxBaseRegisterableEngine
Syntax
Delphi
TnxBaseRegisterableEngine = class(TnxPersistent);
File

nxllRegisterableEngine

Description

This is class nxllRegisterableEngine.TnxBaseRegisterableEngine.

Group

Classes

Links
TnxBaseRegisterableEngine Methods, TnxBaseRegisterableEngine Members, nxllRegisterableEngine, Classes


TnxBaseRegisterableEngine Members

TnxBaseRegisterableEngine Members
TnxBaseRegisterableEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseRegisterableEngine.

Class

TnxBaseRegisterableEngine Class

Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxBaseRegisterableEngine Class, Legend, Protected Methods, Public Methods


TnxBaseRegisterableEngine Methods

TnxBaseRegisterableEngine Methods
TnxBaseRegisterableEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRegisterableEngine class are listed here.

Class

TnxBaseRegisterableEngine Class

Protected Methods
Name | Description
GetList |
Register |
Unregister |
Public Methods
Name | Description
FindEngineClass | TnxBaseRegisterableEngine
GetRegisteredEngines |
Links
TnxBaseRegisterableEngine Class, Legend, Protected Methods, Public Methods


TnxBaseRegisterableEngine.FindEngineClass Method

TnxBaseRegisterableEngine.FindEngineClass Method
TnxBaseRegisterableEngine Class TnxBaseRegisterableEngine Members nxllRegisterableEngine Namespace TnxBaseRegisterableEngine Methods Send Feedback
Syntax
Delphi
class function FindEngineClass(const aName: string): TnxBaseRegisterableEngineClass;
Description

TnxBaseRegisterableEngine

Group

TnxBaseRegisterableEngine Methods

Links
TnxBaseRegisterableEngine Class, TnxBaseRegisterableEngine Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableEngine Methods


TnxBaseRegisterableEngine.GetList Method

TnxBaseRegisterableEngine.GetList Method
TnxBaseRegisterableEngine Class TnxBaseRegisterableEngine Members nxllRegisterableEngine Namespace TnxBaseRegisterableEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; virtual;
Group

TnxBaseRegisterableEngine Methods

Links
TnxBaseRegisterableEngine Class, TnxBaseRegisterableEngine Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableEngine Methods


TnxBaseRegisterableEngine.GetRegisteredEngines Method

TnxBaseRegisterableEngine.GetRegisteredEngines Method
TnxBaseRegisterableEngine Class TnxBaseRegisterableEngine Members nxllRegisterableEngine Namespace TnxBaseRegisterableEngine Methods Send Feedback
Syntax
Delphi
class procedure GetRegisteredEngines(aList: TStrings; aIncludeAliases: Boolean = False);
Group

TnxBaseRegisterableEngine Methods

Links
TnxBaseRegisterableEngine Class, TnxBaseRegisterableEngine Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableEngine Methods


TnxBaseRegisterableEngine.Register Method

TnxBaseRegisterableEngine.Register Method
TnxBaseRegisterableEngine Class TnxBaseRegisterableEngine Members nxllRegisterableEngine Namespace TnxBaseRegisterableEngine Methods Send Feedback
Syntax
Delphi
class procedure Register(aAlias: string = '');
Group

TnxBaseRegisterableEngine Methods

Links
TnxBaseRegisterableEngine Class, TnxBaseRegisterableEngine Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableEngine Methods


TnxBaseRegisterableEngine.Unregister Method

TnxBaseRegisterableEngine.Unregister Method
TnxBaseRegisterableEngine Class TnxBaseRegisterableEngine Members nxllRegisterableEngine Namespace TnxBaseRegisterableEngine Methods Send Feedback
Syntax
Delphi
class procedure Unregister;
Group

TnxBaseRegisterableEngine Methods

Links
TnxBaseRegisterableEngine Class, TnxBaseRegisterableEngine Members, nxllRegisterableEngine Namespace, TnxBaseRegisterableEngine Methods


Types

Types
nxllRegisterableEngine Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllRegisterableEngine Namespace

Types
Name | Description
PStringList | Pointer to TStringlist. Internally needed.
TnxBaseRegisterableDescriptorClass | This is type nxllRegisterableEngine.TnxBaseRegisterableDescriptorClass.
TnxBaseRegisterableEngineClass | This is type nxllRegisterableEngine.TnxBaseRegisterableEngineClass.
Links
nxllRegisterableEngine Namespace, Types


nxllRegisterableEngine.PStringList Type

nxllRegisterableEngine.PStringList Type
nxllRegisterableEngine Types Send Feedback
Syntax
Delphi
PStringList = ^TStringList;
File

nxllRegisterableEngine

Description

Pointer to TStringlist. Internally needed.

Group

Types

Links
nxllRegisterableEngine, Types


nxllRegisterableEngine.TnxBaseRegisterableDescriptorClass Type

nxllRegisterableEngine.TnxBaseRegisterableDescriptorClass Type
nxllRegisterableEngine Types Send Feedback
Syntax
Delphi
TnxBaseRegisterableDescriptorClass = class of TnxBaseRegisterableDescriptor;
File

nxllRegisterableEngine

Description

This is type nxllRegisterableEngine.TnxBaseRegisterableDescriptorClass.

Group

Types

Links
nxllRegisterableEngine, Types


nxllRegisterableEngine.TnxBaseRegisterableEngineClass Type

nxllRegisterableEngine.TnxBaseRegisterableEngineClass Type
nxllRegisterableEngine Types Send Feedback
Syntax
Delphi
TnxBaseRegisterableEngineClass = class of TnxBaseRegisterableEngine;
File

nxllRegisterableEngine

Description

This is type nxllRegisterableEngine.TnxBaseRegisterableEngineClass.

Group

Types

Links
nxllRegisterableEngine, Types


Constants

Constants
Constants nxllRegisterableEngine Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csDescriptor | This is constant nxllRegisterableEngine.csDescriptor.
csEngine | This is constant nxllRegisterableEngine.csEngine.
rsUnknownEngine | This is constant nxllRegisterableEngine.rsUnknownEngine.
Namespace

nxllRegisterableEngine Namespace

Links
Constants, nxllRegisterableEngine Namespace


nxllRegisterableEngine.csDescriptor Constant

nxllRegisterableEngine.csDescriptor Constant
nxllRegisterableEngine Constants Send Feedback
Syntax
Delphi
csDescriptor = 'Descriptor';
File

nxllRegisterableEngine

Description

This is constant nxllRegisterableEngine.csDescriptor.

Group

Constants

Links
nxllRegisterableEngine, Constants


nxllRegisterableEngine.csEngine Constant

nxllRegisterableEngine.csEngine Constant
nxllRegisterableEngine Constants Send Feedback
Syntax
Delphi
csEngine = 'Engine';
File

nxllRegisterableEngine

Description

This is constant nxllRegisterableEngine.csEngine.

Group

Constants

Links
nxllRegisterableEngine, Constants


nxllRegisterableEngine.rsUnknownEngine Constant

nxllRegisterableEngine.rsUnknownEngine Constant
nxllRegisterableEngine Constants Send Feedback
Syntax
Delphi
rsUnknownEngine = 'Unknown %s engine: "%s"';
File

nxllRegisterableEngine

Description

This is constant nxllRegisterableEngine.rsUnknownEngine.

Group

Constants

Links
nxllRegisterableEngine, Constants


nxllRleCompressor Namespace

nxllRleCompressor Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxllRleCompressor.

Classes
Name | Description
TnxRleCompressor | This is class nxllRleCompressor.TnxRleCompressor.
Constants
Name | Description
_EncodeFlag | This is constant nxllRleCompressor._EncodeFlag.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxllRleCompressor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRleCompressor | This is class nxllRleCompressor.TnxRleCompressor.
Namespace

nxllRleCompressor Namespace

Links
Classes, nxllRleCompressor Namespace, Legend


TnxRleCompressor Class

TnxRleCompressor Class
TnxRleCompressor Methods TnxRleCompressor Members nxllRleCompressor Classes Send Feedback
Class Hierarchy
nxllRleCompressor_TnxRleCompressornxllRleCompressor_TnxRleCompressornxllRleCompressor_TnxRleCompressor
Syntax
Delphi
TnxRleCompressor = class(TnxBaseCompressor);
File

nxllRleCompressor

Description

This is class nxllRleCompressor.TnxRleCompressor.

Group

Classes

Links
TnxRleCompressor Methods, TnxRleCompressor Members, nxllRleCompressor, Classes


TnxRleCompressor Members

TnxRleCompressor Members
TnxRleCompressor Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRleCompressor.

Class

TnxRleCompressor Class

Protected Methods
Name | Description
Register |
UnRegister |
Public Methods
Name | Description
Compress | TnxRleCompressor
FreeInstance |
NewInstance | TnxObject
Uncompress |
Links
TnxRleCompressor Class, Legend, Protected Methods, Public Methods


TnxRleCompressor Methods

TnxRleCompressor Methods
TnxRleCompressor Class Legend Public Methods Send Feedback

The methods of the TnxRleCompressor class are listed here.

Class

TnxRleCompressor Class

Public Methods
Name | Description
Compress | TnxRleCompressor
Uncompress |
Links
TnxRleCompressor Class, Legend, Public Methods


TnxRleCompressor.Compress Method

TnxRleCompressor.Compress Method
TnxRleCompressor Class TnxRleCompressor Members nxllRleCompressor Namespace TnxRleCompressor Methods Send Feedback
Syntax
Delphi
class function Compress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32): TnxWord32; override;
Description

TnxRleCompressor

Group

TnxRleCompressor Methods

Links
TnxRleCompressor Class, TnxRleCompressor Members, nxllRleCompressor Namespace, TnxRleCompressor Methods


TnxRleCompressor.Uncompress Method

TnxRleCompressor.Uncompress Method
TnxRleCompressor Class TnxRleCompressor Members nxllRleCompressor Namespace TnxRleCompressor Methods Send Feedback
Syntax
Delphi
class procedure Uncompress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32); override;
Group

TnxRleCompressor Methods

Links
TnxRleCompressor Class, TnxRleCompressor Members, nxllRleCompressor Namespace, TnxRleCompressor Methods


Constants

Constants
Constants nxllRleCompressor Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_EncodeFlag | This is constant nxllRleCompressor._EncodeFlag.
Namespace

nxllRleCompressor Namespace

Links
Constants, nxllRleCompressor Namespace


nxllRleCompressor._EncodeFlag Constant

nxllRleCompressor._EncodeFlag Constant
nxllRleCompressor Constants Send Feedback
Syntax
Delphi
_EncodeFlag: AnsiChar = #131;
File

nxllRleCompressor

Description

This is constant nxllRleCompressor._EncodeFlag.

Group

Constants

Links
nxllRleCompressor, Constants


nxllSessionNotifications Namespace

nxllSessionNotifications Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllSessionNotifications.

Classes
Name | Description
TnxSessionNotifications | This is class nxllSessionNotifications.TnxSessionNotifications.
TnxSessionNotifierItem | This is class nxllSessionNotifications.TnxSessionNotifierItem.
Structs, Records, Enums
Name | Description
TnxInternalNotifierID | This is record nxllSessionNotifications.TnxInternalNotifierID.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
PnxInternalNotifierID | This is type nxllSessionNotifications.PnxInternalNotifierID.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllSessionNotifications Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxSessionNotifications | This is class nxllSessionNotifications.TnxSessionNotifications.
TnxSessionNotifierItem | This is class nxllSessionNotifications.TnxSessionNotifierItem.
Namespace

nxllSessionNotifications Namespace

Links
Classes, nxllSessionNotifications Namespace, Legend


TnxSessionNotifications Class

TnxSessionNotifications Class
TnxSessionNotifications Fields TnxSessionNotifications Methods TnxSessionNotifications Members nxllSessionNotifications Classes Send Feedback
Class Hierarchy
nxllSessionNotifications_TnxSessionNotificationsnxllSessionNotifications_TnxSessionNotifications
Syntax
Delphi
TnxSessionNotifications = class(TAggregatedObject, InxSessionNotifications);
File

nxllSessionNotifications

Description

This is class nxllSessionNotifications.TnxSessionNotifications.

Group

Classes

Links
TnxSessionNotifications Fields, TnxSessionNotifications Methods, TnxSessionNotifications Members, nxllSessionNotifications, Classes


TnxSessionNotifications Members

TnxSessionNotifications Members
TnxSessionNotifications Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSessionNotifications.

Class

TnxSessionNotifications Class

Protected Fields
Name | Description
snHead | This is snHead, a member of class TnxSessionNotifications.
snPadlock | private
snTail | This is snTail, a member of class TnxSessionNotifications.
Protected Methods
Name | Description
AddNotifier | InxSessionNotifications TnxSessionNotifications
RemoveNotifier | This is RemoveNotifier, a member of class TnxSessionNotifications.
Public Methods
Name | Description
Destroy | This is Destroy, a member of class TnxSessionNotifications.
Disconnected | This is Disconnected, a member of class TnxSessionNotifications.
Links
TnxSessionNotifications Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSessionNotifications.Destroy Destructor

TnxSessionNotifications.Destroy Destructor
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxSessionNotifications.

Class

TnxSessionNotifications Class

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Class


TnxSessionNotifications Fields

TnxSessionNotifications Fields
TnxSessionNotifications Class Legend Protected Fields Send Feedback

The fields of the TnxSessionNotifications class are listed here.

Class

TnxSessionNotifications Class

Protected Fields
Name | Description
snHead | This is snHead, a member of class TnxSessionNotifications.
snPadlock | private
snTail | This is snTail, a member of class TnxSessionNotifications.
Links
TnxSessionNotifications Class, Legend, Protected Fields


TnxSessionNotifications.snHead Field

TnxSessionNotifications.snHead Field
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Fields Send Feedback
Syntax
Delphi
snHead: TnxSessionNotifierItem;
Description

This is snHead, a member of class TnxSessionNotifications.

Group

TnxSessionNotifications Fields

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Fields


TnxSessionNotifications.snPadlock Field

TnxSessionNotifications.snPadlock Field
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Fields Send Feedback
Syntax
Delphi
snPadlock: TnxPadlock;
Description

private

Group

TnxSessionNotifications Fields

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Fields


TnxSessionNotifications.snTail Field

TnxSessionNotifications.snTail Field
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Fields Send Feedback
Syntax
Delphi
snTail: TnxSessionNotifierItem;
Description

This is snTail, a member of class TnxSessionNotifications.

Group

TnxSessionNotifications Fields

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Fields


TnxSessionNotifications Methods

TnxSessionNotifications Methods
TnxSessionNotifications Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSessionNotifications class are listed here.

Class

TnxSessionNotifications Class

Protected Methods
Name | Description
AddNotifier | InxSessionNotifications TnxSessionNotifications
RemoveNotifier | This is RemoveNotifier, a member of class TnxSessionNotifications.
Public Methods
Name | Description
Disconnected | This is Disconnected, a member of class TnxSessionNotifications.
Links
TnxSessionNotifications Class, Legend, Protected Methods, Public Methods


TnxSessionNotifications.AddNotifier Method

TnxSessionNotifications.AddNotifier Method
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Methods Send Feedback
Syntax
Delphi
function AddNotifier(const aNotifier: InxSessionNotifier): TnxNotifierID;
Description

InxSessionNotifications

TnxSessionNotifications

Group

TnxSessionNotifications Methods

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Methods


TnxSessionNotifications.Disconnected Method

TnxSessionNotifications.Disconnected Method
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

This is Disconnected, a member of class TnxSessionNotifications.

Group

TnxSessionNotifications Methods

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Methods


TnxSessionNotifications.RemoveNotifier Method

TnxSessionNotifications.RemoveNotifier Method
TnxSessionNotifications Class TnxSessionNotifications Members nxllSessionNotifications Namespace TnxSessionNotifications Methods Send Feedback
Syntax
Delphi
procedure RemoveNotifier(aID: TnxNotifierID);
Description

This is RemoveNotifier, a member of class TnxSessionNotifications.

Group

TnxSessionNotifications Methods

Links
TnxSessionNotifications Class, TnxSessionNotifications Members, nxllSessionNotifications Namespace, TnxSessionNotifications Methods


TnxSessionNotifierItem Class

TnxSessionNotifierItem Class
TnxSessionNotifierItem Fields TnxSessionNotifierItem Methods TnxSessionNotifierItem Members nxllSessionNotifications Classes Send Feedback
Class Hierarchy
nxllSessionNotifications_TnxSessionNotifierItem
Syntax
Delphi
TnxSessionNotifierItem = class;
File

nxllSessionNotifications

Description

This is class nxllSessionNotifications.TnxSessionNotifierItem.

Group

Classes

Links
TnxSessionNotifierItem Fields, TnxSessionNotifierItem Methods, TnxSessionNotifierItem Members, nxllSessionNotifications, Classes


TnxSessionNotifierItem Members

TnxSessionNotifierItem Members
TnxSessionNotifierItem Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSessionNotifierItem.

Class

TnxSessionNotifierItem Class

Protected Fields
Name | Description
sniNext | This is sniNext, a member of class TnxSessionNotifierItem.
sniNotifier | This is sniNotifier, a member of class TnxSessionNotifierItem.
sniParent | This is sniParent, a member of class TnxSessionNotifierItem.
sniPrev | This is sniPrev, a member of class TnxSessionNotifierItem.
sniTickCount | private
Protected Methods
Name | Description
Create | TnxSessionNotifierItem
Disconnected | This is Disconnected, a member of class TnxSessionNotifierItem.
sniAddToParent | This is sniAddToParent, a member of class TnxSessionNotifierItem.
sniRemoveFromParent | This is sniRemoveFromParent, a member of class TnxSessionNotifierItem.
Public Methods
Name | Description
Destroy | This is Destroy, a member of class TnxSessionNotifierItem.
Links
TnxSessionNotifierItem Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSessionNotifierItem.Create Constructor

TnxSessionNotifierItem.Create Constructor
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxSessionNotifications; const aNotifier: InxSessionNotifier);
Description

TnxSessionNotifierItem

Class

TnxSessionNotifierItem Class

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Class


TnxSessionNotifierItem.Destroy Destructor

TnxSessionNotifierItem.Destroy Destructor
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxSessionNotifierItem.

Class

TnxSessionNotifierItem Class

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Class


TnxSessionNotifierItem Fields

TnxSessionNotifierItem Fields
TnxSessionNotifierItem Class Legend Protected Fields Send Feedback

The fields of the TnxSessionNotifierItem class are listed here.

Class

TnxSessionNotifierItem Class

Protected Fields
Name | Description
sniNext | This is sniNext, a member of class TnxSessionNotifierItem.
sniNotifier | This is sniNotifier, a member of class TnxSessionNotifierItem.
sniParent | This is sniParent, a member of class TnxSessionNotifierItem.
sniPrev | This is sniPrev, a member of class TnxSessionNotifierItem.
sniTickCount | private
Links
TnxSessionNotifierItem Class, Legend, Protected Fields


TnxSessionNotifierItem.sniNext Field

TnxSessionNotifierItem.sniNext Field
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Fields Send Feedback
Syntax
Delphi
sniNext: TnxSessionNotifierItem;
Description

This is sniNext, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Fields

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Fields


TnxSessionNotifierItem.sniNotifier Field

TnxSessionNotifierItem.sniNotifier Field
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Fields Send Feedback
Syntax
Delphi
sniNotifier: InxSessionNotifier;
Description

This is sniNotifier, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Fields

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Fields


TnxSessionNotifierItem.sniParent Field

TnxSessionNotifierItem.sniParent Field
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Fields Send Feedback
Syntax
Delphi
sniParent: TnxSessionNotifications;
Description

This is sniParent, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Fields

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Fields


TnxSessionNotifierItem.sniPrev Field

TnxSessionNotifierItem.sniPrev Field
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Fields Send Feedback
Syntax
Delphi
sniPrev: TnxSessionNotifierItem;
Description

This is sniPrev, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Fields

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Fields


TnxSessionNotifierItem.sniTickCount Field

TnxSessionNotifierItem.sniTickCount Field
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Fields Send Feedback
Syntax
Delphi
sniTickCount: Cardinal;
Description

private

Group

TnxSessionNotifierItem Fields

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Fields


TnxSessionNotifierItem Methods

TnxSessionNotifierItem Methods
TnxSessionNotifierItem Class Legend Protected Methods Send Feedback

The methods of the TnxSessionNotifierItem class are listed here.

Class

TnxSessionNotifierItem Class

Protected Methods
Name | Description
Disconnected | This is Disconnected, a member of class TnxSessionNotifierItem.
sniAddToParent | This is sniAddToParent, a member of class TnxSessionNotifierItem.
sniRemoveFromParent | This is sniRemoveFromParent, a member of class TnxSessionNotifierItem.
Links
TnxSessionNotifierItem Class, Legend, Protected Methods


TnxSessionNotifierItem.Disconnected Method

TnxSessionNotifierItem.Disconnected Method
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

This is Disconnected, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Methods

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Methods


TnxSessionNotifierItem.sniAddToParent Method

TnxSessionNotifierItem.sniAddToParent Method
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Methods Send Feedback
Syntax
Delphi
procedure sniAddToParent;
Description

This is sniAddToParent, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Methods

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Methods


TnxSessionNotifierItem.sniRemoveFromParent Method

TnxSessionNotifierItem.sniRemoveFromParent Method
TnxSessionNotifierItem Class TnxSessionNotifierItem Members nxllSessionNotifications Namespace TnxSessionNotifierItem Methods Send Feedback
Syntax
Delphi
procedure sniRemoveFromParent;
Description

This is sniRemoveFromParent, a member of class TnxSessionNotifierItem.

Group

TnxSessionNotifierItem Methods

Links
TnxSessionNotifierItem Class, TnxSessionNotifierItem Members, nxllSessionNotifications Namespace, TnxSessionNotifierItem Methods


Structs, Records, Enums

Structs, Records, Enums
nxllSessionNotifications Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllSessionNotifications Namespace

Records
Name | Description
TnxInternalNotifierID | This is record nxllSessionNotifications.TnxInternalNotifierID.
Links
nxllSessionNotifications Namespace, Legend, Records


nxllSessionNotifications.TnxInternalNotifierID Record

nxllSessionNotifications.TnxInternalNotifierID Record
nxllSessionNotifications Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInternalNotifierID = packed record
  iniParent: TnxSessionNotifications;
  iniItem: TnxSessionNotifierItem;
  iniTickCount: Cardinal;
  iniCheckSum: Cardinal;
end;
File

nxllSessionNotifications

Description

This is record nxllSessionNotifications.TnxInternalNotifierID.

Group

Structs, Records, Enums

Links
nxllSessionNotifications, Structs, Records, Enums


Types

Types
nxllSessionNotifications Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSessionNotifications Namespace

Types
Name | Description
PnxInternalNotifierID | This is type nxllSessionNotifications.PnxInternalNotifierID.
Links
nxllSessionNotifications Namespace, Types


nxllSessionNotifications.PnxInternalNotifierID Type

nxllSessionNotifications.PnxInternalNotifierID Type
nxllSessionNotifications Types Send Feedback
Syntax
Delphi
PnxInternalNotifierID = ^TnxInternalNotifierID;
File

nxllSessionNotifications

Description

This is type nxllSessionNotifications.PnxInternalNotifierID.

Group

Types

Links
nxllSessionNotifications, Types


nxllSessionNotifierIsolator Namespace

nxllSessionNotifierIsolator Namespace
Classes Interfaces Legend Topics Send Feedback

This is namespace nxllSessionNotifierIsolator.

Classes
Name | Description
TnxSessionNotifierIsolator | This is class nxllSessionNotifierIsolator.TnxSessionNotifierIsolator.
Interfaces
Name | Description
InxSessionNotifierIsolator | This is class nxllSessionNotifierIsolator.InxSessionNotifierIsolator.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Links
Classes, Interfaces, Legend, Topics


Classes

Classes
Classes nxllSessionNotifierIsolator Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxSessionNotifierIsolator | This is class nxllSessionNotifierIsolator.TnxSessionNotifierIsolator.
Namespace

nxllSessionNotifierIsolator Namespace

Links
Classes, nxllSessionNotifierIsolator Namespace, Legend


TnxSessionNotifierIsolator Class

TnxSessionNotifierIsolator Class
TnxSessionNotifierIsolator Fields TnxSessionNotifierIsolator Methods TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Classes Send Feedback
Class Hierarchy
nxllSessionNotifierIsolator_TnxSessionNotifierIsolatornxllSessionNotifierIsolator_TnxSessionNotifierIsolatornxllSessionNotifierIsolator_TnxSessionNotifierIsolatornxllSessionNotifierIsolator_TnxSessionNotifierIsolatornxllSessionNotifierIsolator_TnxSessionNotifierIsolator
Syntax
Delphi
TnxSessionNotifierIsolator = class(TnxInterfacedObject, InxSessionNotifier, InxSessionNotifierIsolator);
File

nxllSessionNotifierIsolator

Description

This is class nxllSessionNotifierIsolator.TnxSessionNotifierIsolator.

Group

Classes

Links
TnxSessionNotifierIsolator Fields, TnxSessionNotifierIsolator Methods, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator, Classes


TnxSessionNotifierIsolator Members

TnxSessionNotifierIsolator Members
TnxSessionNotifierIsolator Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSessionNotifierIsolator.

Class

TnxSessionNotifierIsolator Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
sniNotifierID | This is sniNotifierID, a member of class TnxSessionNotifierIsolator.
sniOwner | private
sniPadlock | This is sniPadlock, a member of class TnxSessionNotifierIsolator.
sniSessionNotifications | This is sniSessionNotifications, a member of class TnxSessionNotifierIsolator.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Disconnected | InxSessionNotifier
DisconnectFromOwner | InxSessionNotifierIsolator
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxSessionNotifierIsolator
Destroy | This is Destroy, a member of class TnxSessionNotifierIsolator.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxSessionNotifierIsolator Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSessionNotifierIsolator.Create Constructor

TnxSessionNotifierIsolator.Create Constructor
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Class Send Feedback
Syntax
Delphi
constructor Create(const aOwner: InxSessionNotifier; const aSessionNotifications: InxSessionNotifications);
Description

TnxSessionNotifierIsolator

Class

TnxSessionNotifierIsolator Class

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Class


TnxSessionNotifierIsolator.Destroy Destructor

TnxSessionNotifierIsolator.Destroy Destructor
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxSessionNotifierIsolator.

Class

TnxSessionNotifierIsolator Class

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Class


TnxSessionNotifierIsolator Fields

TnxSessionNotifierIsolator Fields
TnxSessionNotifierIsolator Class Legend Protected Fields Send Feedback

The fields of the TnxSessionNotifierIsolator class are listed here.

Class

TnxSessionNotifierIsolator Class

Protected Fields
Name | Description
sniNotifierID | This is sniNotifierID, a member of class TnxSessionNotifierIsolator.
sniOwner | private
sniPadlock | This is sniPadlock, a member of class TnxSessionNotifierIsolator.
sniSessionNotifications | This is sniSessionNotifications, a member of class TnxSessionNotifierIsolator.
Links
TnxSessionNotifierIsolator Class, Legend, Protected Fields


TnxSessionNotifierIsolator.sniNotifierID Field

TnxSessionNotifierIsolator.sniNotifierID Field
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Fields Send Feedback
Syntax
Delphi
sniNotifierID: TnxNotifierID;
Description

This is sniNotifierID, a member of class TnxSessionNotifierIsolator.

Group

TnxSessionNotifierIsolator Fields

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Fields


TnxSessionNotifierIsolator.sniOwner Field

TnxSessionNotifierIsolator.sniOwner Field
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Fields Send Feedback
Syntax
Delphi
sniOwner: Pointer;
Description

private

Group

TnxSessionNotifierIsolator Fields

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Fields


TnxSessionNotifierIsolator.sniPadlock Field

TnxSessionNotifierIsolator.sniPadlock Field
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Fields Send Feedback
Syntax
Delphi
sniPadlock: TnxPadlock;
Description

This is sniPadlock, a member of class TnxSessionNotifierIsolator.

Group

TnxSessionNotifierIsolator Fields

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Fields


TnxSessionNotifierIsolator.sniSessionNotifications Field

TnxSessionNotifierIsolator.sniSessionNotifications Field
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Fields Send Feedback
Syntax
Delphi
sniSessionNotifications: InxSessionNotifications;
Description

This is sniSessionNotifications, a member of class TnxSessionNotifierIsolator.

Group

TnxSessionNotifierIsolator Fields

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Fields


TnxSessionNotifierIsolator Methods

TnxSessionNotifierIsolator Methods
TnxSessionNotifierIsolator Class Legend Protected Methods Send Feedback

The methods of the TnxSessionNotifierIsolator class are listed here.

Class

TnxSessionNotifierIsolator Class

Protected Methods
Name | Description
Disconnected | InxSessionNotifier
DisconnectFromOwner | InxSessionNotifierIsolator
Links
TnxSessionNotifierIsolator Class, Legend, Protected Methods


TnxSessionNotifierIsolator.Disconnected Method

TnxSessionNotifierIsolator.Disconnected Method
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

InxSessionNotifier

Group

TnxSessionNotifierIsolator Methods

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Methods


TnxSessionNotifierIsolator.DisconnectFromOwner Method

TnxSessionNotifierIsolator.DisconnectFromOwner Method
TnxSessionNotifierIsolator Class TnxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace TnxSessionNotifierIsolator Methods Send Feedback
Syntax
Delphi
procedure DisconnectFromOwner;
Description

InxSessionNotifierIsolator

Group

TnxSessionNotifierIsolator Methods

Links
TnxSessionNotifierIsolator Class, TnxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, TnxSessionNotifierIsolator Methods


Interfaces

Interfaces
nxllSessionNotifierIsolator Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllSessionNotifierIsolator Namespace

Interfaces
Name | Description
InxSessionNotifierIsolator | This is class nxllSessionNotifierIsolator.InxSessionNotifierIsolator.
Links
nxllSessionNotifierIsolator Namespace, Interfaces, Legend


InxSessionNotifierIsolator Interface

InxSessionNotifierIsolator Interface
InxSessionNotifierIsolator Methods InxSessionNotifierIsolator Members nxllSessionNotifierIsolator Interfaces Send Feedback
Class Hierarchy
nxllSessionNotifierIsolator_InxSessionNotifierIsolatornxllSessionNotifierIsolator_InxSessionNotifierIsolator
Syntax
Delphi
InxSessionNotifierIsolator = interface(InxSessionNotifier);
File

nxllSessionNotifierIsolator

Description

This is class nxllSessionNotifierIsolator.InxSessionNotifierIsolator.

Group

Interfaces

Links
InxSessionNotifierIsolator Methods, InxSessionNotifierIsolator Members, nxllSessionNotifierIsolator, Interfaces


InxSessionNotifierIsolator Members

InxSessionNotifierIsolator Members
InxSessionNotifierIsolator Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionNotifierIsolator.

Interface

InxSessionNotifierIsolator Interface

Public Methods
Name | Description
Disconnected | Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.
DisconnectFromOwner | This is DisconnectFromOwner, a member of class InxSessionNotifierIsolator.
Links
InxSessionNotifierIsolator Interface, Legend, Public Methods


InxSessionNotifierIsolator Methods

InxSessionNotifierIsolator Methods
InxSessionNotifierIsolator Interface Legend Public Methods Send Feedback

The methods of the InxSessionNotifierIsolator class are listed here.

Interface

InxSessionNotifierIsolator Interface

Public Methods
Name | Description
DisconnectFromOwner | This is DisconnectFromOwner, a member of class InxSessionNotifierIsolator.
Links
InxSessionNotifierIsolator Interface, Legend, Public Methods


InxSessionNotifierIsolator.DisconnectFromOwner Method

InxSessionNotifierIsolator.DisconnectFromOwner Method
InxSessionNotifierIsolator Interface InxSessionNotifierIsolator Members nxllSessionNotifierIsolator Namespace InxSessionNotifierIsolator Methods Send Feedback
Syntax
Delphi
procedure DisconnectFromOwner;
Description

This is DisconnectFromOwner, a member of class InxSessionNotifierIsolator.

Group

InxSessionNotifierIsolator Methods

Links
InxSessionNotifierIsolator Interface, InxSessionNotifierIsolator Members, nxllSessionNotifierIsolator Namespace, InxSessionNotifierIsolator Methods


nxllSimpleCommandHandler Namespace

nxllSimpleCommandHandler Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxllSimpleCommandHandler.

Classes
Name | Description
TnxSimpleCommandHandler | The SimpleCommandHandler component decodes messages and hands them off to be processed. Typical use would be to add message-based communication to a database system. To use, set a transport component's CommandHandler property to point to an instance of this component, and set a TnxServerCommandHandler's CommandHandler property to point to the TnxSimpleCommandHandler.
TnxSimpleSessionState | This is class nxllSimpleCommandHandler.TnxSimpleSessionState.
Constants
Name | Description
nxc_MagicNumber_SimpleSession | NSES
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxllSimpleCommandHandler Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxSimpleCommandHandler | The SimpleCommandHandler component decodes messages and hands them off to be processed. Typical use would be to add message-based communication to a database system. To use, set a transport component's CommandHandler property to point to an instance of this component, and set a TnxServerCommandHandler's CommandHandler property to point to the TnxSimpleCommandHandler.
TnxSimpleSessionState | This is class nxllSimpleCommandHandler.TnxSimpleSessionState.
Namespace

nxllSimpleCommandHandler Namespace

Links
Classes, nxllSimpleCommandHandler Namespace, Legend


TnxSimpleCommandHandler Class

TnxSimpleCommandHandler Class
TnxSimpleCommandHandler Fields TnxSimpleCommandHandler Methods TnxSimpleCommandHandler Members nxllSimpleCommandHandler Classes Send Feedback
Class Hierarchy
nxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandlernxllSimpleCommandHandler_TnxSimpleCommandHandler
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSimpleCommandHandler = class(TnxBaseCommandHandler);
File

nxllSimpleCommandHandler

Description

The SimpleCommandHandler component decodes messages and hands them off to be processed. Typical use would be to add message-based communication to a database system.

To use, set a transport component's CommandHandler property to point to an instance of this component, and set a TnxServerCommandHandler's CommandHandler property to point to the TnxSimpleCommandHandler.

Group

Classes

Links
TnxSimpleCommandHandler Fields, TnxSimpleCommandHandler Methods, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler, Classes


TnxSimpleCommandHandler Members

TnxSimpleCommandHandler Members
TnxSimpleCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSimpleCommandHandler.

Class

TnxSimpleCommandHandler Class

Protected Fields
Name | Description
bchPlugins | This is bchPlugins, a member of class TnxBaseCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
schGuid | private
schSessionsHead | This is schSessionsHead, a member of class TnxSimpleCommandHandler.
schSessionsPadlock | This is schSessionsPadlock, a member of class TnxSimpleCommandHandler.
schSessionsTail | This is schSessionsTail, a member of class TnxSimpleCommandHandler.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bchAddSession | TnxSimpleCommandHandler
bchGetServerGuid |
bchGetServerName |
bchNotifyPluginsAddSession |
bchNotifyPluginsRemoveSession |
bchNotifyPluginsSessionFailed |
bchProcess |
bchRemoveSession |
bchSessionFailed |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
schAcceptClient |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UISettingsVisible | Result is always set to false, cause the command handler settings are never visible in the UI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxSimpleCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxSimpleCommandHandler.Create Constructor

TnxSimpleCommandHandler.Create Constructor
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxSimpleCommandHandler Class

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Class


TnxSimpleCommandHandler.Destroy Destructor

TnxSimpleCommandHandler.Destroy Destructor
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSimpleCommandHandler Class

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Class


TnxSimpleCommandHandler Fields

TnxSimpleCommandHandler Fields
TnxSimpleCommandHandler Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleCommandHandler class are listed here.

Class

TnxSimpleCommandHandler Class

Protected Fields
Name | Description
schGuid | private
schSessionsHead | This is schSessionsHead, a member of class TnxSimpleCommandHandler.
schSessionsPadlock | This is schSessionsPadlock, a member of class TnxSimpleCommandHandler.
schSessionsTail | This is schSessionsTail, a member of class TnxSimpleCommandHandler.
Links
TnxSimpleCommandHandler Class, Legend, Protected Fields


TnxSimpleCommandHandler.schGuid Field

TnxSimpleCommandHandler.schGuid Field
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Fields Send Feedback
Syntax
Delphi
schGuid: TnxGuid;
Description

private

Group

TnxSimpleCommandHandler Fields

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Fields


TnxSimpleCommandHandler.schSessionsHead Field

TnxSimpleCommandHandler.schSessionsHead Field
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Fields Send Feedback
Syntax
Delphi
schSessionsHead: TnxSimpleSessionState;
Description

This is schSessionsHead, a member of class TnxSimpleCommandHandler.

Group

TnxSimpleCommandHandler Fields

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Fields


TnxSimpleCommandHandler.schSessionsPadlock Field

TnxSimpleCommandHandler.schSessionsPadlock Field
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Fields Send Feedback
Syntax
Delphi
schSessionsPadlock: TnxPadlock;
Description

This is schSessionsPadlock, a member of class TnxSimpleCommandHandler.

Group

TnxSimpleCommandHandler Fields

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Fields


TnxSimpleCommandHandler.schSessionsTail Field

TnxSimpleCommandHandler.schSessionsTail Field
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Fields Send Feedback
Syntax
Delphi
schSessionsTail: TnxSimpleSessionState;
Description

This is schSessionsTail, a member of class TnxSimpleCommandHandler.

Group

TnxSimpleCommandHandler Fields

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Fields


TnxSimpleCommandHandler Methods

TnxSimpleCommandHandler Methods
TnxSimpleCommandHandler Class Legend Protected Methods Send Feedback

The methods of the TnxSimpleCommandHandler class are listed here.

Class

TnxSimpleCommandHandler Class

Protected Methods
Name | Description
bchAddSession | TnxSimpleCommandHandler
bchGetServerGuid |
bchRemoveSession |
schAcceptClient |
Links
TnxSimpleCommandHandler Class, Legend, Protected Methods


TnxSimpleCommandHandler.bchAddSession Method

TnxSimpleCommandHandler.bchAddSession Method
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Methods Send Feedback
Syntax
Delphi
function bchAddSession(aTransport: TnxBaseTransport; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: Integer; aClientVersion: Integer; out aSessionID: TnxSessionID; out aServerVersion: Integer): TnxResult; override;
Description

TnxSimpleCommandHandler

Group

TnxSimpleCommandHandler Methods

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Methods


TnxSimpleCommandHandler.bchGetServerGuid Method

TnxSimpleCommandHandler.bchGetServerGuid Method
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Methods Send Feedback
Syntax
Delphi
function bchGetServerGuid: TnxGuid; override;
Group

TnxSimpleCommandHandler Methods

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Methods


TnxSimpleCommandHandler.bchRemoveSession Method

TnxSimpleCommandHandler.bchRemoveSession Method
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Methods Send Feedback
Syntax
Delphi
function bchRemoveSession(aTransport: TnxBaseTransport; aSessionID: TnxSessionID): TnxResult; override;
Group

TnxSimpleCommandHandler Methods

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Methods


TnxSimpleCommandHandler.schAcceptClient Method

TnxSimpleCommandHandler.schAcceptClient Method
TnxSimpleCommandHandler Class TnxSimpleCommandHandler Members nxllSimpleCommandHandler Namespace TnxSimpleCommandHandler Methods Send Feedback
Syntax
Delphi
function schAcceptClient(const aUserName: UnicodeString; const aPassword: UnicodeString; aClientVersion: Integer): TnxResult;
Group

TnxSimpleCommandHandler Methods

Links
TnxSimpleCommandHandler Class, TnxSimpleCommandHandler Members, nxllSimpleCommandHandler Namespace, TnxSimpleCommandHandler Methods


TnxSimpleSessionState Class

TnxSimpleSessionState Class
TnxSimpleSessionState Fields TnxSimpleSessionState Methods TnxSimpleSessionState Members nxllSimpleCommandHandler Classes Send Feedback
Class Hierarchy
nxllSimpleCommandHandler_TnxSimpleSessionStatenxllSimpleCommandHandler_TnxSimpleSessionStatenxllSimpleCommandHandler_TnxSimpleSessionState
Syntax
Delphi
TnxSimpleSessionState = class(TnxLowObject);
File

nxllSimpleCommandHandler

Description

This is class nxllSimpleCommandHandler.TnxSimpleSessionState.

Group

Classes

Links
TnxSimpleSessionState Fields, TnxSimpleSessionState Methods, TnxSimpleSessionState Members, nxllSimpleCommandHandler, Classes


TnxSimpleSessionState Members

TnxSimpleSessionState Members
TnxSimpleSessionState Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSimpleSessionState.

Class

TnxSimpleSessionState Class

Protected Fields
Name | Description
sssClientVersion | This is sssClientVersion, a member of class TnxSimpleSessionState.
sssCommandHandler | This is sssCommandHandler, a member of class TnxSimpleSessionState.
sssCommandHandlerNext | This is sssCommandHandlerNext, a member of class TnxSimpleSessionState.
sssCommandHandlerPrev | This is sssCommandHandlerPrev, a member of class TnxSimpleSessionState.
sssConnectedFrom | This is sssConnectedFrom, a member of class TnxSimpleSessionState.
sssMagicNumber | private
sssPassword | This is sssPassword, a member of class TnxSimpleSessionState.
sssTimeout | This is sssTimeout, a member of class TnxSimpleSessionState.
sssUserName | This is sssUserName, a member of class TnxSimpleSessionState.
Protected Methods
Name | Description
sssAddToCommandHandler |
sssRemoveFromCommandHandler |
Public Methods
Name | Description
AfterConstruction | TnxSimpleSessionState
BeforeDestruction |
Create |
Destroy |
FreeInstance |
LookupByID |
NewInstance | TnxLowObject
NewInstance | TnxObject
Links
TnxSimpleSessionState Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSimpleSessionState.Create Constructor

TnxSimpleSessionState.Create Constructor
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Class Send Feedback
Syntax
Delphi
constructor Create(aCommandHandler: TnxSimpleCommandHandler; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: Integer; aClientVersion: Integer);
Class

TnxSimpleSessionState Class

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Class


TnxSimpleSessionState.Destroy Destructor

TnxSimpleSessionState.Destroy Destructor
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSimpleSessionState Class

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Class


TnxSimpleSessionState Fields

TnxSimpleSessionState Fields
TnxSimpleSessionState Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleSessionState class are listed here.

Class

TnxSimpleSessionState Class

Protected Fields
Name | Description
sssClientVersion | This is sssClientVersion, a member of class TnxSimpleSessionState.
sssCommandHandler | This is sssCommandHandler, a member of class TnxSimpleSessionState.
sssCommandHandlerNext | This is sssCommandHandlerNext, a member of class TnxSimpleSessionState.
sssCommandHandlerPrev | This is sssCommandHandlerPrev, a member of class TnxSimpleSessionState.
sssConnectedFrom | This is sssConnectedFrom, a member of class TnxSimpleSessionState.
sssMagicNumber | private
sssPassword | This is sssPassword, a member of class TnxSimpleSessionState.
sssTimeout | This is sssTimeout, a member of class TnxSimpleSessionState.
sssUserName | This is sssUserName, a member of class TnxSimpleSessionState.
Links
TnxSimpleSessionState Class, Legend, Protected Fields


TnxSimpleSessionState.sssClientVersion Field

TnxSimpleSessionState.sssClientVersion Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssClientVersion: Integer;
Description

This is sssClientVersion, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssCommandHandler Field

TnxSimpleSessionState.sssCommandHandler Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssCommandHandler: TnxSimpleCommandHandler;
Description

This is sssCommandHandler, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssCommandHandlerNext Field

TnxSimpleSessionState.sssCommandHandlerNext Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssCommandHandlerNext: TnxSimpleSessionState;
Description

This is sssCommandHandlerNext, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssCommandHandlerPrev Field

TnxSimpleSessionState.sssCommandHandlerPrev Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssCommandHandlerPrev: TnxSimpleSessionState;
Description

This is sssCommandHandlerPrev, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssConnectedFrom Field

TnxSimpleSessionState.sssConnectedFrom Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssConnectedFrom: string;
Description

This is sssConnectedFrom, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssMagicNumber Field

TnxSimpleSessionState.sssMagicNumber Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssMagicNumber: TnxWord32;
Description

private

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssPassword Field

TnxSimpleSessionState.sssPassword Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssPassword: Unicodestring;
Description

This is sssPassword, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssTimeout Field

TnxSimpleSessionState.sssTimeout Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssTimeout: Integer;
Description

This is sssTimeout, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState.sssUserName Field

TnxSimpleSessionState.sssUserName Field
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Fields Send Feedback
Syntax
Delphi
sssUserName: UnicodeString;
Description

This is sssUserName, a member of class TnxSimpleSessionState.

Group

TnxSimpleSessionState Fields

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Fields


TnxSimpleSessionState Methods

TnxSimpleSessionState Methods
TnxSimpleSessionState Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSimpleSessionState class are listed here.

Class

TnxSimpleSessionState Class

Protected Methods
Name | Description
sssAddToCommandHandler |
sssRemoveFromCommandHandler |
Public Methods
Name | Description
AfterConstruction | TnxSimpleSessionState
BeforeDestruction |
LookupByID |
Links
TnxSimpleSessionState Class, Legend, Protected Methods, Public Methods


TnxSimpleSessionState.AfterConstruction Method

TnxSimpleSessionState.AfterConstruction Method
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxSimpleSessionState

Group

TnxSimpleSessionState Methods

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Methods


TnxSimpleSessionState.BeforeDestruction Method

TnxSimpleSessionState.BeforeDestruction Method
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxSimpleSessionState Methods

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Methods


TnxSimpleSessionState.LookupByID Method

TnxSimpleSessionState.LookupByID Method
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Methods Send Feedback
Syntax
Delphi
class function LookupByID(aSessionID: TnxSessionID; out aSession: TnxSimpleSessionState): TnxResult;
Group

TnxSimpleSessionState Methods

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Methods


TnxSimpleSessionState.sssAddToCommandHandler Method

TnxSimpleSessionState.sssAddToCommandHandler Method
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Methods Send Feedback
Syntax
Delphi
procedure sssAddToCommandHandler;
Group

TnxSimpleSessionState Methods

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Methods


TnxSimpleSessionState.sssRemoveFromCommandHandler Method

TnxSimpleSessionState.sssRemoveFromCommandHandler Method
TnxSimpleSessionState Class TnxSimpleSessionState Members nxllSimpleCommandHandler Namespace TnxSimpleSessionState Methods Send Feedback
Syntax
Delphi
procedure sssRemoveFromCommandHandler;
Group

TnxSimpleSessionState Methods

Links
TnxSimpleSessionState Class, TnxSimpleSessionState Members, nxllSimpleCommandHandler Namespace, TnxSimpleSessionState Methods


Constants

Constants
Constants nxllSimpleCommandHandler Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_MagicNumber_SimpleSession | NSES
Namespace

nxllSimpleCommandHandler Namespace

Links
Constants, nxllSimpleCommandHandler Namespace


nxllSimpleCommandHandler.nxc_MagicNumber_SimpleSession Constant

nxllSimpleCommandHandler.nxc_MagicNumber_SimpleSession Constant
nxllSimpleCommandHandler Constants Send Feedback
Syntax
Delphi
nxc_MagicNumber_SimpleSession: TnxWord32 = $FFD242FF;
File

nxllSimpleCommandHandler

Description

NSES

Group

Constants

Links
nxllSimpleCommandHandler, Constants


nxllSimpleOutputCache Namespace

nxllSimpleOutputCache Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxllSimpleOutputCache.

Classes
Name | Description
TnxSimpleOutputCache | This is class nxllSimpleOutputCache.TnxSimpleOutputCache.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxSimpleOutputCacheEvent | This is type nxllSimpleOutputCache.TnxSimpleOutputCacheEvent.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxllSimpleOutputCache Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxSimpleOutputCache | This is class nxllSimpleOutputCache.TnxSimpleOutputCache.
Namespace

nxllSimpleOutputCache Namespace

Links
Classes, nxllSimpleOutputCache Namespace, Legend


TnxSimpleOutputCache Class

TnxSimpleOutputCache Class
TnxSimpleOutputCache Fields TnxSimpleOutputCache Methods TnxSimpleOutputCache Properties TnxSimpleOutputCache Events TnxSimpleOutputCache Members nxllSimpleOutputCache Classes Send Feedback
Class Hierarchy
nxllSimpleOutputCache_TnxSimpleOutputCachenxllSimpleOutputCache_TnxSimpleOutputCachenxllSimpleOutputCache_TnxSimpleOutputCachenxllSimpleOutputCache_TnxSimpleOutputCache
Syntax
Delphi
TnxSimpleOutputCache = class(TnxComponent);
File

nxllSimpleOutputCache

Description

This is class nxllSimpleOutputCache.TnxSimpleOutputCache.

Group

Classes

Links
TnxSimpleOutputCache Fields, TnxSimpleOutputCache Methods, TnxSimpleOutputCache Properties, TnxSimpleOutputCache Events, TnxSimpleOutputCache Members, nxllSimpleOutputCache, Classes


TnxSimpleOutputCache Members

TnxSimpleOutputCache Members
TnxSimpleOutputCache Class Legend Protected Fields Protected Methods Public Events Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxSimpleOutputCache.

Class

TnxSimpleOutputCache Class

Protected Fields
Name | Description
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
socOnWrite | This is socOnWrite, a member of class TnxSimpleOutputCache.
socText | This is socText, a member of class TnxSimpleOutputCache.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionDataStats |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
Public Events
Name | Description
OnFlush | This is OnFlush, a member of class TnxSimpleOutputCache.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
Clear | TnxSimpleOutputCache
ClearStats | Resets all internal stats.
Create | constructor
Destroy | denstructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
Flush |
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
SaveToFile |
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Write |
WriteLn |
Public Properties
Name | Description
Text | This is Text, a member of class TnxSimpleOutputCache.
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxSimpleOutputCache Class, Legend, Protected Fields, Protected Methods, Public Events, Public Methods, Public Properties, Published Properties


TnxSimpleOutputCache Fields

TnxSimpleOutputCache Fields
TnxSimpleOutputCache Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleOutputCache class are listed here.

Class

TnxSimpleOutputCache Class

Protected Fields
Name | Description
socOnWrite | This is socOnWrite, a member of class TnxSimpleOutputCache.
socText | This is socText, a member of class TnxSimpleOutputCache.
Links
TnxSimpleOutputCache Class, Legend, Protected Fields


TnxSimpleOutputCache.socOnWrite Field

TnxSimpleOutputCache.socOnWrite Field
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Fields Send Feedback
Syntax
Delphi
socOnWrite: TnxSimpleOutputCacheEvent;
Description

This is socOnWrite, a member of class TnxSimpleOutputCache.

Group

TnxSimpleOutputCache Fields

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Fields


TnxSimpleOutputCache.socText Field

TnxSimpleOutputCache.socText Field
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Fields Send Feedback
Syntax
Delphi
socText: string;
Description

This is socText, a member of class TnxSimpleOutputCache.

Group

TnxSimpleOutputCache Fields

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Fields


TnxSimpleOutputCache Methods

TnxSimpleOutputCache Methods
TnxSimpleOutputCache Class Legend Public Methods Send Feedback

The methods of the TnxSimpleOutputCache class are listed here.

Class

TnxSimpleOutputCache Class

Public Methods
Name | Description
Clear | TnxSimpleOutputCache
Flush |
SaveToFile |
Write |
WriteLn |
Links
TnxSimpleOutputCache Class, Legend, Public Methods


TnxSimpleOutputCache.Clear Method

TnxSimpleOutputCache.Clear Method
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

TnxSimpleOutputCache

Group

TnxSimpleOutputCache Methods

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Methods


TnxSimpleOutputCache.Flush Method

TnxSimpleOutputCache.Flush Method
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Methods Send Feedback
Syntax
Delphi
procedure Flush;
Group

TnxSimpleOutputCache Methods

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Methods


TnxSimpleOutputCache.SaveToFile Method

TnxSimpleOutputCache.SaveToFile Method
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Methods Send Feedback
Syntax
Delphi
procedure SaveToFile(FileName: string);
Group

TnxSimpleOutputCache Methods

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Methods


TnxSimpleOutputCache.Write Method

TnxSimpleOutputCache.Write Method
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Methods Send Feedback
Syntax
Delphi
procedure Write(const aText: Variant);
Group

TnxSimpleOutputCache Methods

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Methods


TnxSimpleOutputCache.WriteLn Method

TnxSimpleOutputCache.WriteLn Method
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Methods Send Feedback
Syntax
Delphi
procedure WriteLn(const aText: Variant);
Group

TnxSimpleOutputCache Methods

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Methods


TnxSimpleOutputCache Properties

TnxSimpleOutputCache Properties
TnxSimpleOutputCache Class Legend Public Properties Send Feedback

The properties of the TnxSimpleOutputCache class are listed here.

Class

TnxSimpleOutputCache Class

Public Properties
Name | Description
Text | This is Text, a member of class TnxSimpleOutputCache.
Links
TnxSimpleOutputCache Class, Legend, Public Properties


TnxSimpleOutputCache.Text Property

TnxSimpleOutputCache.Text Property
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Properties Send Feedback
Syntax
Delphi
property Text: string;
Description

This is Text, a member of class TnxSimpleOutputCache.

Group

TnxSimpleOutputCache Properties

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Properties


TnxSimpleOutputCache Events

TnxSimpleOutputCache Events
TnxSimpleOutputCache Class Legend Public Events Send Feedback

The events of the TnxSimpleOutputCache class are listed here.

Class

TnxSimpleOutputCache Class

Public Events
Name | Description
OnFlush | This is OnFlush, a member of class TnxSimpleOutputCache.
Links
TnxSimpleOutputCache Class, Legend, Public Events


TnxSimpleOutputCache.OnFlush Event

TnxSimpleOutputCache.OnFlush Event
TnxSimpleOutputCache Class TnxSimpleOutputCache Members nxllSimpleOutputCache Namespace TnxSimpleOutputCache Events Send Feedback
Syntax
Delphi
property OnFlush: TnxSimpleOutputCacheEvent;
Description

This is OnFlush, a member of class TnxSimpleOutputCache.

Group

TnxSimpleOutputCache Events

Links
TnxSimpleOutputCache Class, TnxSimpleOutputCache Members, nxllSimpleOutputCache Namespace, TnxSimpleOutputCache Events


Types

Types
nxllSimpleOutputCache Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSimpleOutputCache Namespace

Types
Name | Description
TnxSimpleOutputCacheEvent | This is type nxllSimpleOutputCache.TnxSimpleOutputCacheEvent.
Links
nxllSimpleOutputCache Namespace, Types


nxllSimpleOutputCache.TnxSimpleOutputCacheEvent Type

nxllSimpleOutputCache.TnxSimpleOutputCacheEvent Type
nxllSimpleOutputCache Types Send Feedback
Syntax
Delphi
TnxSimpleOutputCacheEvent = procedure (aSender: TObject; const aText: string) of object;
File

nxllSimpleOutputCache

Description

This is type nxllSimpleOutputCache.TnxSimpleOutputCacheEvent.

Group

Types

Links
nxllSimpleOutputCache, Types


nxllSimpleSession Namespace

nxllSimpleSession Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllSimpleSession.

Classes
Name | Description
TnxSimpleSession | This component is a minimalistic Session component. Set its Transport Property to point to the transport component you wish to connnect with. Its main use is to create a message-based communication system where no database capability is needed.
Constants
Name | Description
rsTransportRequired | This is constant nxllSimpleSession.rsTransportRequired.
Structs, Records, Enums
Name | Description
TnxCallbackInfo | This is record nxllSimpleSession.TnxCallbackInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxCallbackInfo | This is type nxllSimpleSession.PnxCallbackInfo.
TnxLoginEvent | Event used when usename and password is required.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllSimpleSession Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxSimpleSession | This component is a minimalistic Session component. Set its Transport Property to point to the transport component you wish to connnect with. Its main use is to create a message-based communication system where no database capability is needed.
Namespace

nxllSimpleSession Namespace

Links
Classes, nxllSimpleSession Namespace, Legend


TnxSimpleSession Class

TnxSimpleSession Class
TnxSimpleSession Fields TnxSimpleSession Methods TnxSimpleSession Properties TnxSimpleSession Events TnxSimpleSession Members nxllSimpleSession Classes Send Feedback
Class Hierarchy
nxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSessionnxllSimpleSession_TnxSimpleSession
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSimpleSession = class(TnxStateComponent, IUnknown, InxSessionRequests, InxSessionNotifications);
File

nxllSimpleSession

Description

This component is a minimalistic Session component. Set its Transport Property to point to the transport component you wish to connnect with. Its main use is to create a message-based communication system where no database capability is needed.

Group

Classes

Links
TnxSimpleSession Fields, TnxSimpleSession Methods, TnxSimpleSession Properties, TnxSimpleSession Events, TnxSimpleSession Members, nxllSimpleSession, Classes


TnxSimpleSession Members

TnxSimpleSession Members
TnxSimpleSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxSimpleSession.

Class

TnxSimpleSession Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
ssBeepOnLoginError | This is ssBeepOnLoginError, a member of class TnxSimpleSession.
ssMsgQueue | This is ssMsgQueue, a member of class TnxSimpleSession.
ssOnLogin | This is ssOnLogin, a member of class TnxSimpleSession.
ssPassword | This is ssPassword, a member of class TnxSimpleSession.
ssPasswordRetries | This is ssPasswordRetries, a member of class TnxSimpleSession.
ssServerVersion | This is ssServerVersion, a member of class TnxSimpleSession.
ssSessionID | This is ssSessionID, a member of class TnxSimpleSession.
ssSessionNotifications | This is ssSessionNotifications, a member of class TnxSimpleSession.
ssTimeout | This is ssTimeout, a member of class TnxSimpleSession.
ssTransport | private
ssTransportID | This is ssTransportID, a member of class TnxSimpleSession.
ssUserName | This is ssUserName, a member of class TnxSimpleSession.
Protected Methods
Name | Description
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect | This is ProcessRequestDirect, a member of class TnxSimpleSession.
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
ssCheckTransport |
ssDoLogin |
ssGetSessionNotifications |
ssSetPassword |
ssSetTimeout |
ssSetTransport |
ssSetTransportID |
ssSetUserName |
Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | TnxSimpleSession
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IsConnected | True if a connection is established.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
ServerVersion | This is ServerVersion, a member of class TnxSimpleSession.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TransportID | This is TransportID, a member of class TnxSimpleSession.
Published Events
Name | Description
OnLogin | Event that is called if username and password is required. If it is not defined, the default action is to show a password dialog.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
BeepOnLoginError | Set to true if a beep on login error is desired.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Password | Store password in this property if appropriate for your app.
PasswordRetries | The number of login attempts allowed before failing the login attempt.
SessionNotifications | This is SessionNotifications, a member of class TnxSimpleSession.
Timeout | Timeout value in ms.
Transport | The transport which is used for network communication.
UserName | Store username in this property if appropriate for your app.
Version | Version of the component.
Links
TnxSimpleSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxSimpleSession.Create Constructor

TnxSimpleSession.Create Constructor
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

TnxSimpleSession

Class

TnxSimpleSession Class

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Class


TnxSimpleSession.Destroy Destructor

TnxSimpleSession.Destroy Destructor
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSimpleSession Class

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Class


TnxSimpleSession Fields

TnxSimpleSession Fields
TnxSimpleSession Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleSession class are listed here.

Class

TnxSimpleSession Class

Protected Fields
Name | Description
ssBeepOnLoginError | This is ssBeepOnLoginError, a member of class TnxSimpleSession.
ssMsgQueue | This is ssMsgQueue, a member of class TnxSimpleSession.
ssOnLogin | This is ssOnLogin, a member of class TnxSimpleSession.
ssPassword | This is ssPassword, a member of class TnxSimpleSession.
ssPasswordRetries | This is ssPasswordRetries, a member of class TnxSimpleSession.
ssServerVersion | This is ssServerVersion, a member of class TnxSimpleSession.
ssSessionID | This is ssSessionID, a member of class TnxSimpleSession.
ssSessionNotifications | This is ssSessionNotifications, a member of class TnxSimpleSession.
ssTimeout | This is ssTimeout, a member of class TnxSimpleSession.
ssTransport | private
ssTransportID | This is ssTransportID, a member of class TnxSimpleSession.
ssUserName | This is ssUserName, a member of class TnxSimpleSession.
Links
TnxSimpleSession Class, Legend, Protected Fields


TnxSimpleSession.ssBeepOnLoginError Field

TnxSimpleSession.ssBeepOnLoginError Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssBeepOnLoginError: Boolean;
Description

This is ssBeepOnLoginError, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssMsgQueue Field

TnxSimpleSession.ssMsgQueue Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssMsgQueue: TnxDataMessageQueue;
Description

This is ssMsgQueue, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssOnLogin Field

TnxSimpleSession.ssOnLogin Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssOnLogin: TnxLoginEvent;
Description

This is ssOnLogin, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssPassword Field

TnxSimpleSession.ssPassword Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssPassword: UnicodeString;
Description

This is ssPassword, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssPasswordRetries Field

TnxSimpleSession.ssPasswordRetries Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssPasswordRetries: Integer;
Description

This is ssPasswordRetries, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssServerVersion Field

TnxSimpleSession.ssServerVersion Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssServerVersion: Integer;
Description

This is ssServerVersion, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssSessionID Field

TnxSimpleSession.ssSessionID Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssSessionID: TnxSessionID;
Description

This is ssSessionID, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssSessionNotifications Field

TnxSimpleSession.ssSessionNotifications Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssSessionNotifications: TnxSessionNotifications;
Description

This is ssSessionNotifications, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssTimeout Field

TnxSimpleSession.ssTimeout Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssTimeout: TnxWord32;
Description

This is ssTimeout, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssTransport Field

TnxSimpleSession.ssTransport Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssTransport: TnxBaseTransport;
Description

private

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssTransportID Field

TnxSimpleSession.ssTransportID Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssTransportID: TnxTransportID;
Description

This is ssTransportID, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession.ssUserName Field

TnxSimpleSession.ssUserName Field
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Fields Send Feedback
Syntax
Delphi
ssUserName: UnicodeString;
Description

This is ssUserName, a member of class TnxSimpleSession.

Group

TnxSimpleSession Fields

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Fields


TnxSimpleSession Methods

TnxSimpleSession Methods
TnxSimpleSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSimpleSession class are listed here.

Class

TnxSimpleSession Class

Protected Methods
Name | Description
nxcNotification |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect | This is ProcessRequestDirect, a member of class TnxSimpleSession.
scInitializing |
scIsStateParent |
scStarting |
scStopping |
ssCheckTransport |
ssDoLogin |
ssGetSessionNotifications |
ssSetPassword |
ssSetTimeout |
ssSetTransport |
ssSetTransportID |
ssSetUserName |
Public Methods
Name | Description
IsConnected | True if a connection is established.
Links
TnxSimpleSession Class, Legend, Protected Methods, Public Methods


TnxSimpleSession.IsConnected Method

TnxSimpleSession.IsConnected Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function IsConnected: Boolean;
Description

True if a connection is established.

Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.nxcNotification Method

TnxSimpleSession.nxcNotification Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ProcessPost Method

TnxSimpleSession.ProcessPost Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ProcessRequest Method

TnxSimpleSession.ProcessRequest Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

InxSessionRequests

Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ProcessRequestDirect Method

TnxSimpleSession.ProcessRequestDirect Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

This is ProcessRequestDirect, a member of class TnxSimpleSession.

Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.scInitializing Method

TnxSimpleSession.scInitializing Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.scIsStateParent Method

TnxSimpleSession.scIsStateParent Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.scStarting Method

TnxSimpleSession.scStarting Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.scStopping Method

TnxSimpleSession.scStopping Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssCheckTransport Method

TnxSimpleSession.ssCheckTransport Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssCheckTransport; virtual;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssDoLogin Method

TnxSimpleSession.ssDoLogin Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function ssDoLogin(var aUserName: UnicodeString; var aPassword: UnicodeString): Boolean;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssGetSessionNotifications Method

TnxSimpleSession.ssGetSessionNotifications Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
function ssGetSessionNotifications: TnxSessionNotifications;
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssSetPassword Method

TnxSimpleSession.ssSetPassword Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssSetPassword(const aValue: UnicodeString);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssSetTimeout Method

TnxSimpleSession.ssSetTimeout Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssSetTimeout(aTimeout: TnxWord32);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssSetTransport Method

TnxSimpleSession.ssSetTransport Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssSetTransport(const aValue: TnxBaseTransport);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssSetTransportID Method

TnxSimpleSession.ssSetTransportID Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssSetTransportID(const aValue: TnxTransportID);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession.ssSetUserName Method

TnxSimpleSession.ssSetUserName Method
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Methods Send Feedback
Syntax
Delphi
procedure ssSetUserName(const aValue: UnicodeString);
Group

TnxSimpleSession Methods

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Methods


TnxSimpleSession Properties

TnxSimpleSession Properties
TnxSimpleSession Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxSimpleSession class are listed here.

Class

TnxSimpleSession Class

Public Properties
Name | Description
ServerVersion | This is ServerVersion, a member of class TnxSimpleSession.
TransportID | This is TransportID, a member of class TnxSimpleSession.
Published Properties
Name | Description
BeepOnLoginError | Set to true if a beep on login error is desired.
Password | Store password in this property if appropriate for your app.
PasswordRetries | The number of login attempts allowed before failing the login attempt.
SessionNotifications | This is SessionNotifications, a member of class TnxSimpleSession.
Timeout | Timeout value in ms.
Transport | The transport which is used for network communication.
UserName | Store username in this property if appropriate for your app.
Links
TnxSimpleSession Class, Legend, Public Properties, Published Properties


TnxSimpleSession.BeepOnLoginError Property

TnxSimpleSession.BeepOnLoginError Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property BeepOnLoginError: Boolean;
Description

Set to true if a beep on login error is desired.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.Password Property

TnxSimpleSession.Password Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

Store password in this property if appropriate for your app.

Notes

stored as clear text and can be viewed with a hexviewer.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.PasswordRetries Property

TnxSimpleSession.PasswordRetries Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property PasswordRetries: Integer;
Description

The number of login attempts allowed before failing the login attempt.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.ServerVersion Property

TnxSimpleSession.ServerVersion Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property ServerVersion: Integer;
Description

This is ServerVersion, a member of class TnxSimpleSession.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.SessionNotifications Property

TnxSimpleSession.SessionNotifications Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property SessionNotifications: TnxSessionNotifications;
Description

This is SessionNotifications, a member of class TnxSimpleSession.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.Timeout Property

TnxSimpleSession.Timeout Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

Timeout value in ms.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.Transport Property

TnxSimpleSession.Transport Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property Transport: TnxBaseTransport;
Description

The transport which is used for network communication.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.TransportID Property

TnxSimpleSession.TransportID Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property TransportID: TnxTransportID;
Description

This is TransportID, a member of class TnxSimpleSession.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession.UserName Property

TnxSimpleSession.UserName Property
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

Store username in this property if appropriate for your app.

Notes

stored as clear text and can be viewed with a hexviewer.

Group

TnxSimpleSession Properties

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Properties


TnxSimpleSession Events

TnxSimpleSession Events
TnxSimpleSession Class Legend Published Events Send Feedback

The events of the TnxSimpleSession class are listed here.

Class

TnxSimpleSession Class

Published Events
Name | Description
OnLogin | Event that is called if username and password is required. If it is not defined, the default action is to show a password dialog.
Links
TnxSimpleSession Class, Legend, Published Events


TnxSimpleSession.OnLogin Event

TnxSimpleSession.OnLogin Event
TnxSimpleSession Class TnxSimpleSession Members nxllSimpleSession Namespace TnxSimpleSession Events Send Feedback
Syntax
Delphi
property OnLogin: TnxLoginEvent;
Description

Event that is called if username and password is required. If it is not defined, the default action is to show a password dialog.

Group

TnxSimpleSession Events

Links
TnxSimpleSession Class, TnxSimpleSession Members, nxllSimpleSession Namespace, TnxSimpleSession Events


Structs, Records, Enums

Structs, Records, Enums
nxllSimpleSession Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllSimpleSession Namespace

Records
Name | Description
TnxCallbackInfo | This is record nxllSimpleSession.TnxCallbackInfo.
Links
nxllSimpleSession Namespace, Legend, Records


nxllSimpleSession.TnxCallbackInfo Record

nxllSimpleSession.TnxCallbackInfo Record
nxllSimpleSession Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCallbackInfo = record
  ciSession: TnxSimpleSession;
  ciSource: TObject;
end;
File

nxllSimpleSession

Description

This is record nxllSimpleSession.TnxCallbackInfo.

Group

Structs, Records, Enums

Links
nxllSimpleSession, Structs, Records, Enums


Types

Types
nxllSimpleSession Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSimpleSession Namespace

Types
Name | Description
PnxCallbackInfo | This is type nxllSimpleSession.PnxCallbackInfo.
TnxLoginEvent | Event used when usename and password is required.
Links
nxllSimpleSession Namespace, Types


nxllSimpleSession.PnxCallbackInfo Type

nxllSimpleSession.PnxCallbackInfo Type
nxllSimpleSession Types Send Feedback
Syntax
Delphi
PnxCallbackInfo = ^TnxCallbackInfo;
File

nxllSimpleSession

Description

This is type nxllSimpleSession.PnxCallbackInfo.

Group

Types

Links
nxllSimpleSession, Types


nxllSimpleSession.TnxLoginEvent Type

nxllSimpleSession.TnxLoginEvent Type
nxllSimpleSession Types See Also Send Feedback
Syntax
Delphi
TnxLoginEvent = procedure (aSender : TnxSimpleSession; var aUserName : UnicodeString; var aPassword : UnicodeString; var aResult : Boolean) of object;
File

nxllSimpleSession

Description

Event used when usename and password is required.

See Also

TnxSession, TnxSimpleSession

Group

Types

Links
nxllSimpleSession, Types, See Also


Constants

Constants
Constants nxllSimpleSession Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsTransportRequired | This is constant nxllSimpleSession.rsTransportRequired.
Namespace

nxllSimpleSession Namespace

Links
Constants, nxllSimpleSession Namespace


nxllSimpleSession.rsTransportRequired Constant

nxllSimpleSession.rsTransportRequired Constant
nxllSimpleSession Constants Send Feedback
Syntax
Delphi
rsTransportRequired = 'Transport required';
File

nxllSimpleSession

Description

This is constant nxllSimpleSession.rsTransportRequired.

Group

Constants

Links
nxllSimpleSession, Constants


nxllSocket Namespace

nxllSocket Namespace
Classes Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllSocket.

Classes
Name | Description
EnxSocketError | This is class nxllSocket.EnxSocketError.
TnxAbstractSocket | This is class nxllSocket.TnxAbstractSocket.
TnxClientSocket | This is class nxllSocket.TnxClientSocket.
TnxClientWinSocket | This is class nxllSocket.TnxClientWinSocket.
TnxCustomServerSocket | This is class nxllSocket.TnxCustomServerSocket.
TnxCustomSocket | This is class nxllSocket.TnxCustomSocket.
TnxCustomWinSocket | This is class nxllSocket.TnxCustomWinSocket.
TnxServerAcceptThread | This is class nxllSocket.TnxServerAcceptThread.
TnxServerClientThread | This is class nxllSocket.TnxServerClientThread.
TnxServerClientWinSocket | This is class nxllSocket.TnxServerClientWinSocket.
TnxServerSocket | This is class nxllSocket.TnxServerSocket.
TnxServerWinSocket | This is class nxllSocket.TnxServerWinSocket.
TnxWinSocketStream | This is class nxllSocket.TnxWinSocketStream.
Functions
Name | Description
SetErrorProc |
Structs, Records, Enums
Name | Description
TnxErrorEvent | This is record nxllSocket.TnxErrorEvent.
TnxSocketEvent | This is record nxllSocket.TnxSocketEvent.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxGetSocketEvent | This is type nxllSocket.TnxGetSocketEvent.
TnxGetThreadEvent | This is type nxllSocket.TnxGetThreadEvent.
TnxSocketErrorEvent | This is type nxllSocket.TnxSocketErrorEvent.
TnxSocketErrorProc | This is type nxllSocket.TnxSocketErrorProc.
TnxSocketEventEvent | This is type nxllSocket.TnxSocketEventEvent.
TnxSocketNotifyEvent | This is type nxllSocket.TnxSocketNotifyEvent.
TnxThreadNotifyEvent | This is type nxllSocket.TnxThreadNotifyEvent.
Links
Classes, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllSocket Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxSocketError | This is class nxllSocket.EnxSocketError.
TnxAbstractSocket | This is class nxllSocket.TnxAbstractSocket.
TnxClientSocket | This is class nxllSocket.TnxClientSocket.
TnxClientWinSocket | This is class nxllSocket.TnxClientWinSocket.
TnxCustomServerSocket | This is class nxllSocket.TnxCustomServerSocket.
TnxCustomSocket | This is class nxllSocket.TnxCustomSocket.
TnxCustomWinSocket | This is class nxllSocket.TnxCustomWinSocket.
TnxServerAcceptThread | This is class nxllSocket.TnxServerAcceptThread.
TnxServerClientThread | This is class nxllSocket.TnxServerClientThread.
TnxServerClientWinSocket | This is class nxllSocket.TnxServerClientWinSocket.
TnxServerSocket | This is class nxllSocket.TnxServerSocket.
TnxServerWinSocket | This is class nxllSocket.TnxServerWinSocket.
TnxWinSocketStream | This is class nxllSocket.TnxWinSocketStream.
Namespace

nxllSocket Namespace

Links
Classes, nxllSocket Namespace, Legend


EnxSocketError Class

EnxSocketError Class
nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_EnxSocketErrornxllSocket_EnxSocketErrornxllSocket_EnxSocketErrornxllSocket_EnxSocketError
Syntax
Delphi
EnxSocketError = class(EnxBaseException);
File

nxllSocket

Description

This is class nxllSocket.EnxSocketError.

Group

Classes

Links
nxllSocket, Classes


TnxAbstractSocket Class

TnxAbstractSocket Class
TnxAbstractSocket Methods TnxAbstractSocket Properties TnxAbstractSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxAbstractSocket
Syntax
Delphi
TnxAbstractSocket = class(TObject);
File

nxllSocket

Description

This is class nxllSocket.TnxAbstractSocket.

Group

Classes

Links
TnxAbstractSocket Methods, TnxAbstractSocket Properties, TnxAbstractSocket Members, nxllSocket, Classes


TnxAbstractSocket Members

TnxAbstractSocket Members
TnxAbstractSocket Class Legend Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxAbstractSocket.

Class

TnxAbstractSocket Class

Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class TnxAbstractSocket.
Error | This is Error, a member of class TnxAbstractSocket.
Event | This is Event, a member of class TnxAbstractSocket.
InitSocket |
Protected Properties
Name | Description
Active | This is Active, a member of class TnxAbstractSocket.
Address | This is Address, a member of class TnxAbstractSocket.
Host | This is Host, a member of class TnxAbstractSocket.
Port | This is Port, a member of class TnxAbstractSocket.
Service | This is Service, a member of class TnxAbstractSocket.
Public Methods
Name | Description
Close |
Open |
Links
TnxAbstractSocket Class, Legend, Protected Methods, Protected Properties, Public Methods


TnxAbstractSocket Methods

TnxAbstractSocket Methods
TnxAbstractSocket Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractSocket class are listed here.

Class

TnxAbstractSocket Class

Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class TnxAbstractSocket.
Error | This is Error, a member of class TnxAbstractSocket.
Event | This is Event, a member of class TnxAbstractSocket.
InitSocket |
Public Methods
Name | Description
Close |
Open |
Links
TnxAbstractSocket Class, Legend, Protected Methods, Public Methods


TnxAbstractSocket.Close Method

TnxAbstractSocket.Close Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure Close;
Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket.DoActivate Method

TnxAbstractSocket.DoActivate Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure DoActivate(Value: Boolean); virtual; abstract;
Description

This is DoActivate, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket.Error Method

TnxAbstractSocket.Error Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure Error(Socket: TnxCustomWinSocket; ErrorEvent: TnxErrorEvent; var ErrorCode: Integer); virtual; abstract;
Description

This is Error, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket.Event Method

TnxAbstractSocket.Event Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure Event(Socket: TnxCustomWinSocket; SocketEvent: TnxSocketEvent); virtual; abstract;
Description

This is Event, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket.InitSocket Method

TnxAbstractSocket.InitSocket Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure InitSocket(Socket: TnxCustomWinSocket);
Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket.Open Method

TnxAbstractSocket.Open Method
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Methods Send Feedback
Syntax
Delphi
procedure Open;
Group

TnxAbstractSocket Methods

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Methods


TnxAbstractSocket Properties

TnxAbstractSocket Properties
TnxAbstractSocket Class Legend Protected Properties Send Feedback

The properties of the TnxAbstractSocket class are listed here.

Class

TnxAbstractSocket Class

Protected Properties
Name | Description
Active | This is Active, a member of class TnxAbstractSocket.
Address | This is Address, a member of class TnxAbstractSocket.
Host | This is Host, a member of class TnxAbstractSocket.
Port | This is Port, a member of class TnxAbstractSocket.
Service | This is Service, a member of class TnxAbstractSocket.
Links
TnxAbstractSocket Class, Legend, Protected Properties


TnxAbstractSocket.Active Property

TnxAbstractSocket.Active Property
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Properties Send Feedback
Syntax
Delphi
property Active: Boolean;
Description

This is Active, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Properties

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Properties


TnxAbstractSocket.Address Property

TnxAbstractSocket.Address Property
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Properties Send Feedback
Syntax
Delphi
property Address: string;
Description

This is Address, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Properties

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Properties


TnxAbstractSocket.Host Property

TnxAbstractSocket.Host Property
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Properties Send Feedback
Syntax
Delphi
property Host: string;
Description

This is Host, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Properties

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Properties


TnxAbstractSocket.Port Property

TnxAbstractSocket.Port Property
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Properties Send Feedback
Syntax
Delphi
property Port: Integer;
Description

This is Port, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Properties

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Properties


TnxAbstractSocket.Service Property

TnxAbstractSocket.Service Property
TnxAbstractSocket Class TnxAbstractSocket Members nxllSocket Namespace TnxAbstractSocket Properties Send Feedback
Syntax
Delphi
property Service: string;
Description

This is Service, a member of class TnxAbstractSocket.

Group

TnxAbstractSocket Properties

Links
TnxAbstractSocket Class, TnxAbstractSocket Members, nxllSocket Namespace, TnxAbstractSocket Properties


TnxClientSocket Class

TnxClientSocket Class
TnxClientSocket Methods TnxClientSocket Properties TnxClientSocket Events TnxClientSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxClientSocketnxllSocket_TnxClientSocketnxllSocket_TnxClientSocket
Syntax
Delphi
TnxClientSocket = class(TnxCustomSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxClientSocket.

Group

Classes

Links
TnxClientSocket Methods, TnxClientSocket Properties, TnxClientSocket Events, TnxClientSocket Members, nxllSocket, Classes


TnxClientSocket Members

TnxClientSocket Members
TnxClientSocket Class Legend Protected Events Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClientSocket.

Class

TnxClientSocket Class

Protected Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxCustomSocket.
OnListen | This is OnListen, a member of class TnxCustomSocket.
Protected Methods
Name | Description
DoActivate |
Error | This is Error, a member of class TnxAbstractSocket.
Error |
Event | This is Event, a member of class TnxAbstractSocket.
Event | TnxCustomSocket
InitSocket |
Public Events
Name | Description
OnConnect | This is OnConnect, a member of class TnxClientSocket.
OnConnecting | This is OnConnecting, a member of class TnxClientSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxClientSocket.
OnError | This is OnError, a member of class TnxClientSocket.
OnLookup | This is OnLookup, a member of class TnxClientSocket.
OnRead | This is OnRead, a member of class TnxClientSocket.
OnWrite | This is OnWrite, a member of class TnxClientSocket.
Public Methods
Name | Description
Close |
Create | TnxClientSocket
Destroy |
Open |
Public Properties
Name | Description
Active | This is Active, a member of class TnxClientSocket.
Address | This is Address, a member of class TnxClientSocket.
Host | This is Host, a member of class TnxClientSocket.
Port | This is Port, a member of class TnxClientSocket.
Service | This is Service, a member of class TnxClientSocket.
Socket | This is Socket, a member of class TnxClientSocket.
Links
TnxClientSocket Class, Legend, Protected Events, Protected Methods, Public Events, Public Methods, Public Properties


TnxClientSocket.Create Constructor

TnxClientSocket.Create Constructor
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxClientSocket

Class

TnxClientSocket Class

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Class


TnxClientSocket.Destroy Destructor

TnxClientSocket.Destroy Destructor
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClientSocket Class

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Class


TnxClientSocket Methods

TnxClientSocket Methods
TnxClientSocket Class Legend Protected Methods Send Feedback

The methods of the TnxClientSocket class are listed here.

Class

TnxClientSocket Class

Protected Methods
Name | Description
DoActivate |
Links
TnxClientSocket Class, Legend, Protected Methods


TnxClientSocket.DoActivate Method

TnxClientSocket.DoActivate Method
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Methods Send Feedback
Syntax
Delphi
procedure DoActivate(Value: Boolean); override;
Group

TnxClientSocket Methods

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Methods


TnxClientSocket Properties

TnxClientSocket Properties
TnxClientSocket Class Legend Public Properties Send Feedback

The properties of the TnxClientSocket class are listed here.

Class

TnxClientSocket Class

Public Properties
Name | Description
Active | This is Active, a member of class TnxClientSocket.
Address | This is Address, a member of class TnxClientSocket.
Host | This is Host, a member of class TnxClientSocket.
Port | This is Port, a member of class TnxClientSocket.
Service | This is Service, a member of class TnxClientSocket.
Socket | This is Socket, a member of class TnxClientSocket.
Links
TnxClientSocket Class, Legend, Public Properties


TnxClientSocket.Active Property

TnxClientSocket.Active Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Active: Boolean;
Description

This is Active, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket.Address Property

TnxClientSocket.Address Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Address: string;
Description

This is Address, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket.Host Property

TnxClientSocket.Host Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Host: string;
Description

This is Host, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket.Port Property

TnxClientSocket.Port Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Port: Integer;
Description

This is Port, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket.Service Property

TnxClientSocket.Service Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Service: string;
Description

This is Service, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket.Socket Property

TnxClientSocket.Socket Property
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Properties Send Feedback
Syntax
Delphi
property Socket: TnxClientWinSocket;
Description

This is Socket, a member of class TnxClientSocket.

Group

TnxClientSocket Properties

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Properties


TnxClientSocket Events

TnxClientSocket Events
TnxClientSocket Class Legend Public Events Send Feedback

The events of the TnxClientSocket class are listed here.

Class

TnxClientSocket Class

Public Events
Name | Description
OnConnect | This is OnConnect, a member of class TnxClientSocket.
OnConnecting | This is OnConnecting, a member of class TnxClientSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxClientSocket.
OnError | This is OnError, a member of class TnxClientSocket.
OnLookup | This is OnLookup, a member of class TnxClientSocket.
OnRead | This is OnRead, a member of class TnxClientSocket.
OnWrite | This is OnWrite, a member of class TnxClientSocket.
Links
TnxClientSocket Class, Legend, Public Events


TnxClientSocket.OnConnect Event

TnxClientSocket.OnConnect Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnConnect: TnxSocketNotifyEvent;
Description

This is OnConnect, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnConnecting Event

TnxClientSocket.OnConnecting Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnConnecting: TnxSocketNotifyEvent;
Description

This is OnConnecting, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnDisconnect Event

TnxClientSocket.OnDisconnect Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnDisconnect: TnxSocketNotifyEvent;
Description

This is OnDisconnect, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnError Event

TnxClientSocket.OnError Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnError: TnxSocketErrorEvent;
Description

This is OnError, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnLookup Event

TnxClientSocket.OnLookup Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnLookup: TnxSocketNotifyEvent;
Description

This is OnLookup, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnRead Event

TnxClientSocket.OnRead Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnRead: TnxSocketNotifyEvent;
Description

This is OnRead, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientSocket.OnWrite Event

TnxClientSocket.OnWrite Event
TnxClientSocket Class TnxClientSocket Members nxllSocket Namespace TnxClientSocket Events Send Feedback
Syntax
Delphi
property OnWrite: TnxSocketNotifyEvent;
Description

This is OnWrite, a member of class TnxClientSocket.

Group

TnxClientSocket Events

Links
TnxClientSocket Class, TnxClientSocket Members, nxllSocket Namespace, TnxClientSocket Events


TnxClientWinSocket Class

TnxClientWinSocket Class
TnxClientWinSocket Methods TnxClientWinSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxClientWinSocketnxllSocket_TnxClientWinSocket
Syntax
Delphi
TnxClientWinSocket = class(TnxCustomWinSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxClientWinSocket.

Group

Classes

Links
TnxClientWinSocket Methods, TnxClientWinSocket Members, nxllSocket, Classes


TnxClientWinSocket Members

TnxClientWinSocket Members
TnxClientWinSocket Class Legend Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClientWinSocket.

Class

TnxClientWinSocket Class

Protected Methods
Name | Description
DoListen |
DoOpen |
Error |
Event |
InitSocket |
Public Events
Name | Description
OnErrorEvent | This is OnErrorEvent, a member of class TnxCustomWinSocket.
OnSocketEvent | This is OnSocketEvent, a member of class TnxCustomWinSocket.
Public Methods
Name | Description
Accept |
Close |
Connect | TnxClientWinSocket
Create |
Destroy |
Disconnect |
Listen |
Lock |
LookupName |
LookupService |
Open |
Read |
ReceiveAnsiText |
ReceiveBuf |
ReceiveLength |
ReceiveUnicodeText |
SendAnsiText |
SendBuf |
SendStream |
SendStreamThenDrop |
SendUnicodeText |
Unlock |
Write |
Public Properties
Name | Description
Addr | This is Addr, a member of class TnxCustomWinSocket.
Connected | This is Connected, a member of class TnxCustomWinSocket.
Data | This is Data, a member of class TnxCustomWinSocket.
LocalAddress | This is LocalAddress, a member of class TnxCustomWinSocket.
LocalHost | This is LocalHost, a member of class TnxCustomWinSocket.
LocalPort | This is LocalPort, a member of class TnxCustomWinSocket.
RemoteAddr | This is RemoteAddr, a member of class TnxCustomWinSocket.
RemoteAddress | This is RemoteAddress, a member of class TnxCustomWinSocket.
RemoteHost | This is RemoteHost, a member of class TnxCustomWinSocket.
RemotePort | This is RemotePort, a member of class TnxCustomWinSocket.
ReportExceptions | This is ReportExceptions, a member of class TnxCustomWinSocket.
SocketHandle | This is SocketHandle, a member of class TnxCustomWinSocket.
SynchronizeEvents | This is SynchronizeEvents, a member of class TnxCustomWinSocket.
Links
TnxClientWinSocket Class, Legend, Protected Methods, Public Events, Public Methods, Public Properties


TnxClientWinSocket Methods

TnxClientWinSocket Methods
TnxClientWinSocket Class Legend Public Methods Send Feedback

The methods of the TnxClientWinSocket class are listed here.

Class

TnxClientWinSocket Class

Public Methods
Name | Description
Connect | TnxClientWinSocket
Links
TnxClientWinSocket Class, Legend, Public Methods


TnxClientWinSocket.Connect Method

TnxClientWinSocket.Connect Method
TnxClientWinSocket Class TnxClientWinSocket Members nxllSocket Namespace TnxClientWinSocket Methods Send Feedback
Syntax
Delphi
procedure Connect(Socket: TSocket); override;
Description

TnxClientWinSocket

Group

TnxClientWinSocket Methods

Links
TnxClientWinSocket Class, TnxClientWinSocket Members, nxllSocket Namespace, TnxClientWinSocket Methods


TnxCustomServerSocket Class

TnxCustomServerSocket Class
TnxCustomServerSocket Fields TnxCustomServerSocket Methods TnxCustomServerSocket Properties TnxCustomServerSocket Events TnxCustomServerSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxCustomServerSocketnxllSocket_TnxCustomServerSocketnxllSocket_TnxCustomServerSocket
Syntax
Delphi
TnxCustomServerSocket = class(TnxCustomSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxCustomServerSocket.

Group

Classes

Links
TnxCustomServerSocket Fields, TnxCustomServerSocket Methods, TnxCustomServerSocket Properties, TnxCustomServerSocket Events, TnxCustomServerSocket Members, nxllSocket, Classes


TnxCustomServerSocket Members

TnxCustomServerSocket Members
TnxCustomServerSocket Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxCustomServerSocket.

Class

TnxCustomServerSocket Class

Protected Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxCustomSocket.
OnClientConnect | This is OnClientConnect, a member of class TnxCustomServerSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxCustomServerSocket.
OnClientError | This is OnClientError, a member of class TnxCustomServerSocket.
OnClientRead | This is OnClientRead, a member of class TnxCustomServerSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxCustomServerSocket.
OnConnect | This is OnConnect, a member of class TnxCustomSocket.
OnConnecting | This is OnConnecting, a member of class TnxCustomSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxCustomSocket.
OnError | This is OnError, a member of class TnxCustomSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxCustomServerSocket.
OnGetThread | This is OnGetThread, a member of class TnxCustomServerSocket.
OnListen | This is OnListen, a member of class TnxCustomSocket.
OnLookup | This is OnLookup, a member of class TnxCustomSocket.
OnRead | This is OnRead, a member of class TnxCustomSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxCustomServerSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxCustomServerSocket.
OnWrite | This is OnWrite, a member of class TnxCustomSocket.
Protected Fields
Name | Description
cssServerSocket | This is cssServerSocket, a member of class TnxCustomServerSocket.
Protected Methods
Name | Description
DoActivate |
Error | This is Error, a member of class TnxAbstractSocket.
Error |
Event | This is Event, a member of class TnxAbstractSocket.
Event | TnxCustomSocket
GetGetSocketEvent |
GetGetThreadEvent |
GetOnClientError |
GetOnClientEvent |
GetOnThreadEnd |
GetOnThreadStart |
GetThreadCacheSize |
InitSocket |
SetGetSocketEvent |
SetGetThreadEvent |
SetOnClientError |
SetOnClientEvent |
SetOnThreadEnd |
SetOnThreadStart |
SetThreadCacheSize |
Protected Properties
Name | Description
Active | This is Active, a member of class TnxAbstractSocket.
Address | This is Address, a member of class TnxAbstractSocket.
Host | This is Host, a member of class TnxAbstractSocket.
Port | This is Port, a member of class TnxAbstractSocket.
Service | This is Service, a member of class TnxAbstractSocket.
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxCustomServerSocket.
Public Methods
Name | Description
Close |
Destroy | TnxCustomServerSocket
Open |
Links
TnxCustomServerSocket Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxCustomServerSocket.Destroy Destructor

TnxCustomServerSocket.Destroy Destructor
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

TnxCustomServerSocket

Class

TnxCustomServerSocket Class

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Class


TnxCustomServerSocket Fields

TnxCustomServerSocket Fields
TnxCustomServerSocket Class Legend Protected Fields Send Feedback

The fields of the TnxCustomServerSocket class are listed here.

Class

TnxCustomServerSocket Class

Protected Fields
Name | Description
cssServerSocket | This is cssServerSocket, a member of class TnxCustomServerSocket.
Links
TnxCustomServerSocket Class, Legend, Protected Fields


TnxCustomServerSocket.cssServerSocket Field

TnxCustomServerSocket.cssServerSocket Field
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Fields Send Feedback
Syntax
Delphi
cssServerSocket: TnxServerWinSocket;
Description

This is cssServerSocket, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Fields

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Fields


TnxCustomServerSocket Methods

TnxCustomServerSocket Methods
TnxCustomServerSocket Class Legend Protected Methods Send Feedback

The methods of the TnxCustomServerSocket class are listed here.

Class

TnxCustomServerSocket Class

Protected Methods
Name | Description
DoActivate |
GetGetSocketEvent |
GetGetThreadEvent |
GetOnClientError |
GetOnClientEvent |
GetOnThreadEnd |
GetOnThreadStart |
GetThreadCacheSize |
SetGetSocketEvent |
SetGetThreadEvent |
SetOnClientError |
SetOnClientEvent |
SetOnThreadEnd |
SetOnThreadStart |
SetThreadCacheSize |
Links
TnxCustomServerSocket Class, Legend, Protected Methods


TnxCustomServerSocket.DoActivate Method

TnxCustomServerSocket.DoActivate Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure DoActivate(Value: Boolean); override;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetGetSocketEvent Method

TnxCustomServerSocket.GetGetSocketEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetGetSocketEvent: TnxGetSocketEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetGetThreadEvent Method

TnxCustomServerSocket.GetGetThreadEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetGetThreadEvent: TnxGetThreadEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetOnClientError Method

TnxCustomServerSocket.GetOnClientError Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetOnClientError: TnxSocketErrorEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetOnClientEvent Method

TnxCustomServerSocket.GetOnClientEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetOnClientEvent(Index: Integer): TnxSocketNotifyEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetOnThreadEnd Method

TnxCustomServerSocket.GetOnThreadEnd Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetOnThreadEnd: TnxThreadNotifyEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetOnThreadStart Method

TnxCustomServerSocket.GetOnThreadStart Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetOnThreadStart: TnxThreadNotifyEvent;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.GetThreadCacheSize Method

TnxCustomServerSocket.GetThreadCacheSize Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
function GetThreadCacheSize: Integer;
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetGetSocketEvent Method

TnxCustomServerSocket.SetGetSocketEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetGetSocketEvent(Value: TnxGetSocketEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetGetThreadEvent Method

TnxCustomServerSocket.SetGetThreadEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetGetThreadEvent(Value: TnxGetThreadEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetOnClientError Method

TnxCustomServerSocket.SetOnClientError Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetOnClientError(Value: TnxSocketErrorEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetOnClientEvent Method

TnxCustomServerSocket.SetOnClientEvent Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetOnClientEvent(Index: Integer; Value: TnxSocketNotifyEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetOnThreadEnd Method

TnxCustomServerSocket.SetOnThreadEnd Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetOnThreadEnd(Value: TnxThreadNotifyEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetOnThreadStart Method

TnxCustomServerSocket.SetOnThreadStart Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetOnThreadStart(Value: TnxThreadNotifyEvent);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket.SetThreadCacheSize Method

TnxCustomServerSocket.SetThreadCacheSize Method
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Methods Send Feedback
Syntax
Delphi
procedure SetThreadCacheSize(Value: Integer);
Group

TnxCustomServerSocket Methods

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Methods


TnxCustomServerSocket Properties

TnxCustomServerSocket Properties
TnxCustomServerSocket Class Legend Protected Properties Send Feedback

The properties of the TnxCustomServerSocket class are listed here.

Class

TnxCustomServerSocket Class

Protected Properties
Name | Description
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxCustomServerSocket.
Links
TnxCustomServerSocket Class, Legend, Protected Properties


TnxCustomServerSocket.ThreadCacheSize Property

TnxCustomServerSocket.ThreadCacheSize Property
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Properties Send Feedback
Syntax
Delphi
property ThreadCacheSize: Integer;
Description

This is ThreadCacheSize, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Properties

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Properties


TnxCustomServerSocket Events

TnxCustomServerSocket Events
TnxCustomServerSocket Class Legend Protected Events Send Feedback

The events of the TnxCustomServerSocket class are listed here.

Class

TnxCustomServerSocket Class

Protected Events
Name | Description
OnClientConnect | This is OnClientConnect, a member of class TnxCustomServerSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxCustomServerSocket.
OnClientError | This is OnClientError, a member of class TnxCustomServerSocket.
OnClientRead | This is OnClientRead, a member of class TnxCustomServerSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxCustomServerSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxCustomServerSocket.
OnGetThread | This is OnGetThread, a member of class TnxCustomServerSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxCustomServerSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxCustomServerSocket.
Links
TnxCustomServerSocket Class, Legend, Protected Events


TnxCustomServerSocket.OnClientConnect Event

TnxCustomServerSocket.OnClientConnect Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnClientConnect: TnxSocketNotifyEvent;
Description

This is OnClientConnect, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnClientDisconnect Event

TnxCustomServerSocket.OnClientDisconnect Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnClientDisconnect: TnxSocketNotifyEvent;
Description

This is OnClientDisconnect, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnClientError Event

TnxCustomServerSocket.OnClientError Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnClientError: TnxSocketErrorEvent;
Description

This is OnClientError, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnClientRead Event

TnxCustomServerSocket.OnClientRead Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnClientRead: TnxSocketNotifyEvent;
Description

This is OnClientRead, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnClientWrite Event

TnxCustomServerSocket.OnClientWrite Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnClientWrite: TnxSocketNotifyEvent;
Description

This is OnClientWrite, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnGetSocket Event

TnxCustomServerSocket.OnGetSocket Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnGetSocket: TnxGetSocketEvent;
Description

This is OnGetSocket, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnGetThread Event

TnxCustomServerSocket.OnGetThread Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnGetThread: TnxGetThreadEvent;
Description

This is OnGetThread, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnThreadEnd Event

TnxCustomServerSocket.OnThreadEnd Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnThreadEnd: TnxThreadNotifyEvent;
Description

This is OnThreadEnd, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomServerSocket.OnThreadStart Event

TnxCustomServerSocket.OnThreadStart Event
TnxCustomServerSocket Class TnxCustomServerSocket Members nxllSocket Namespace TnxCustomServerSocket Events Send Feedback
Syntax
Delphi
property OnThreadStart: TnxThreadNotifyEvent;
Description

This is OnThreadStart, a member of class TnxCustomServerSocket.

Group

TnxCustomServerSocket Events

Links
TnxCustomServerSocket Class, TnxCustomServerSocket Members, nxllSocket Namespace, TnxCustomServerSocket Events


TnxCustomSocket Class

TnxCustomSocket Class
TnxCustomSocket Methods TnxCustomSocket Events TnxCustomSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxCustomSocketnxllSocket_TnxCustomSocket
Syntax
Delphi
TnxCustomSocket = class(TnxAbstractSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxCustomSocket.

Group

Classes

Links
TnxCustomSocket Methods, TnxCustomSocket Events, TnxCustomSocket Members, nxllSocket, Classes


TnxCustomSocket Members

TnxCustomSocket Members
TnxCustomSocket Class Legend Protected Events Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxCustomSocket.

Class

TnxCustomSocket Class

Protected Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxCustomSocket.
OnConnect | This is OnConnect, a member of class TnxCustomSocket.
OnConnecting | This is OnConnecting, a member of class TnxCustomSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxCustomSocket.
OnError | This is OnError, a member of class TnxCustomSocket.
OnListen | This is OnListen, a member of class TnxCustomSocket.
OnLookup | This is OnLookup, a member of class TnxCustomSocket.
OnRead | This is OnRead, a member of class TnxCustomSocket.
OnWrite | This is OnWrite, a member of class TnxCustomSocket.
Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class TnxAbstractSocket.
Error |
Event | TnxCustomSocket
InitSocket |
Protected Properties
Name | Description
Active | This is Active, a member of class TnxAbstractSocket.
Address | This is Address, a member of class TnxAbstractSocket.
Host | This is Host, a member of class TnxAbstractSocket.
Port | This is Port, a member of class TnxAbstractSocket.
Service | This is Service, a member of class TnxAbstractSocket.
Public Methods
Name | Description
Close |
Open |
Links
TnxCustomSocket Class, Legend, Protected Events, Protected Methods, Protected Properties, Public Methods


TnxCustomSocket Methods

TnxCustomSocket Methods
TnxCustomSocket Class Legend Protected Methods Send Feedback

The methods of the TnxCustomSocket class are listed here.

Class

TnxCustomSocket Class

Protected Methods
Name | Description
Error |
Event | TnxCustomSocket
Links
TnxCustomSocket Class, Legend, Protected Methods


TnxCustomSocket.Error Method

TnxCustomSocket.Error Method
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Methods Send Feedback
Syntax
Delphi
procedure Error(Socket: TnxCustomWinSocket; ErrorEvent: TnxErrorEvent; var ErrorCode: Integer); override;
Group

TnxCustomSocket Methods

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Methods


TnxCustomSocket.Event Method

TnxCustomSocket.Event Method
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Methods Send Feedback
Syntax
Delphi
procedure Event(Socket: TnxCustomWinSocket; SocketEvent: TnxSocketEvent); override;
Description

TnxCustomSocket

Group

TnxCustomSocket Methods

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Methods


TnxCustomSocket Events

TnxCustomSocket Events
TnxCustomSocket Class Legend Protected Events Send Feedback

The events of the TnxCustomSocket class are listed here.

Class

TnxCustomSocket Class

Protected Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxCustomSocket.
OnConnect | This is OnConnect, a member of class TnxCustomSocket.
OnConnecting | This is OnConnecting, a member of class TnxCustomSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxCustomSocket.
OnError | This is OnError, a member of class TnxCustomSocket.
OnListen | This is OnListen, a member of class TnxCustomSocket.
OnLookup | This is OnLookup, a member of class TnxCustomSocket.
OnRead | This is OnRead, a member of class TnxCustomSocket.
OnWrite | This is OnWrite, a member of class TnxCustomSocket.
Links
TnxCustomSocket Class, Legend, Protected Events


TnxCustomSocket.OnAccept Event

TnxCustomSocket.OnAccept Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnAccept: TnxSocketNotifyEvent;
Description

This is OnAccept, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnConnect Event

TnxCustomSocket.OnConnect Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnConnect: TnxSocketNotifyEvent;
Description

This is OnConnect, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnConnecting Event

TnxCustomSocket.OnConnecting Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnConnecting: TnxSocketNotifyEvent;
Description

This is OnConnecting, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnDisconnect Event

TnxCustomSocket.OnDisconnect Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnDisconnect: TnxSocketNotifyEvent;
Description

This is OnDisconnect, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnError Event

TnxCustomSocket.OnError Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnError: TnxSocketErrorEvent;
Description

This is OnError, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnListen Event

TnxCustomSocket.OnListen Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnListen: TnxSocketNotifyEvent;
Description

This is OnListen, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnLookup Event

TnxCustomSocket.OnLookup Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnLookup: TnxSocketNotifyEvent;
Description

This is OnLookup, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnRead Event

TnxCustomSocket.OnRead Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnRead: TnxSocketNotifyEvent;
Description

This is OnRead, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomSocket.OnWrite Event

TnxCustomSocket.OnWrite Event
TnxCustomSocket Class TnxCustomSocket Members nxllSocket Namespace TnxCustomSocket Events Send Feedback
Syntax
Delphi
property OnWrite: TnxSocketNotifyEvent;
Description

This is OnWrite, a member of class TnxCustomSocket.

Group

TnxCustomSocket Events

Links
TnxCustomSocket Class, TnxCustomSocket Members, nxllSocket Namespace, TnxCustomSocket Events


TnxCustomWinSocket Class

TnxCustomWinSocket Class
TnxCustomWinSocket Methods TnxCustomWinSocket Properties TnxCustomWinSocket Events TnxCustomWinSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxCustomWinSocket
Syntax
Delphi
TnxCustomWinSocket = class;
File

nxllSocket

Description

This is class nxllSocket.TnxCustomWinSocket.

Group

Classes

Links
TnxCustomWinSocket Methods, TnxCustomWinSocket Properties, TnxCustomWinSocket Events, TnxCustomWinSocket Members, nxllSocket, Classes


TnxCustomWinSocket Members

TnxCustomWinSocket Members
TnxCustomWinSocket Class Legend Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCustomWinSocket.

Class

TnxCustomWinSocket Class

Protected Methods
Name | Description
DoListen |
DoOpen |
Error |
Event |
InitSocket |
Public Events
Name | Description
OnErrorEvent | This is OnErrorEvent, a member of class TnxCustomWinSocket.
OnSocketEvent | This is OnSocketEvent, a member of class TnxCustomWinSocket.
Public Methods
Name | Description
Accept |
Close |
Connect |
Create |
Destroy |
Disconnect |
Listen |
Lock |
LookupName |
LookupService |
Open |
Read |
ReceiveAnsiText |
ReceiveBuf |
ReceiveLength |
ReceiveUnicodeText |
SendAnsiText |
SendBuf |
SendStream |
SendStreamThenDrop |
SendUnicodeText |
Unlock |
Write |
Public Properties
Name | Description
Addr | This is Addr, a member of class TnxCustomWinSocket.
Connected | This is Connected, a member of class TnxCustomWinSocket.
Data | This is Data, a member of class TnxCustomWinSocket.
LocalAddress | This is LocalAddress, a member of class TnxCustomWinSocket.
LocalHost | This is LocalHost, a member of class TnxCustomWinSocket.
LocalPort | This is LocalPort, a member of class TnxCustomWinSocket.
RemoteAddr | This is RemoteAddr, a member of class TnxCustomWinSocket.
RemoteAddress | This is RemoteAddress, a member of class TnxCustomWinSocket.
RemoteHost | This is RemoteHost, a member of class TnxCustomWinSocket.
RemotePort | This is RemotePort, a member of class TnxCustomWinSocket.
ReportExceptions | This is ReportExceptions, a member of class TnxCustomWinSocket.
SocketHandle | This is SocketHandle, a member of class TnxCustomWinSocket.
SynchronizeEvents | This is SynchronizeEvents, a member of class TnxCustomWinSocket.
Links
TnxCustomWinSocket Class, Legend, Protected Methods, Public Events, Public Methods, Public Properties


TnxCustomWinSocket.Create Constructor

TnxCustomWinSocket.Create Constructor
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Class Send Feedback
Syntax
Delphi
constructor Create(aSocket: TSocket);
Class

TnxCustomWinSocket Class

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Class


TnxCustomWinSocket.Destroy Destructor

TnxCustomWinSocket.Destroy Destructor
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxCustomWinSocket Class

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Class


TnxCustomWinSocket Methods

TnxCustomWinSocket Methods
TnxCustomWinSocket Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomWinSocket class are listed here.

Class

TnxCustomWinSocket Class

Protected Methods
Name | Description
DoListen |
DoOpen |
Error |
Event |
InitSocket |
Public Methods
Name | Description
Accept |
Close |
Connect |
Disconnect |
Listen |
Lock |
LookupName |
LookupService |
Open |
Read |
ReceiveAnsiText |
ReceiveBuf |
ReceiveLength |
ReceiveUnicodeText |
SendAnsiText |
SendBuf |
SendStream |
SendStreamThenDrop |
SendUnicodeText |
Unlock |
Write |
Links
TnxCustomWinSocket Class, Legend, Protected Methods, Public Methods


TnxCustomWinSocket.Accept Method

TnxCustomWinSocket.Accept Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Accept(Socket: TSocket); virtual;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Close Method

TnxCustomWinSocket.Close Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Close;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Connect Method

TnxCustomWinSocket.Connect Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Connect(Socket: TSocket); virtual;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Disconnect Method

TnxCustomWinSocket.Disconnect Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Disconnect(Socket: TSocket); virtual;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.DoListen Method

TnxCustomWinSocket.DoListen Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure DoListen(QueueSize: Integer);
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.DoOpen Method

TnxCustomWinSocket.DoOpen Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure DoOpen;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Error Method

TnxCustomWinSocket.Error Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Error(Socket: TnxCustomWinSocket; ErrorEvent: TnxErrorEvent; var ErrorCode: Integer); dynamic;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Event Method

TnxCustomWinSocket.Event Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Event(Socket: TnxCustomWinSocket; SocketEvent: TnxSocketEvent); dynamic;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.InitSocket Method

TnxCustomWinSocket.InitSocket Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function InitSocket(const Name: string; const Address: string; const Service: string; Port: Word; Client: Boolean): TSockAddrIn;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Listen Method

TnxCustomWinSocket.Listen Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Listen(const Name: string; const Address: string; const Service: string; Port: Word; QueueSize: Integer);
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Lock Method

TnxCustomWinSocket.Lock Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Lock;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.LookupName Method

TnxCustomWinSocket.LookupName Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function LookupName(const name: string): TInAddr;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.LookupService Method

TnxCustomWinSocket.LookupService Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function LookupService(const service: string): Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Open Method

TnxCustomWinSocket.Open Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Open(const Name: string; const Address: string; const Service: string; Port: Word);
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Read Method

TnxCustomWinSocket.Read Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Read(Socket: TSocket); virtual;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.ReceiveAnsiText Method

TnxCustomWinSocket.ReceiveAnsiText Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function ReceiveAnsiText(Peek: Boolean = False): AnsiString;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.ReceiveBuf Method

TnxCustomWinSocket.ReceiveBuf Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function ReceiveBuf(var Buf; Count: Integer; Peek: Boolean = False): Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.ReceiveLength Method

TnxCustomWinSocket.ReceiveLength Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function ReceiveLength: Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.ReceiveUnicodeText Method

TnxCustomWinSocket.ReceiveUnicodeText Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function ReceiveUnicodeText(Peek: Boolean = False): UnicodeString;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.SendAnsiText Method

TnxCustomWinSocket.SendAnsiText Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function SendAnsiText(const S: AnsiString): Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.SendBuf Method

TnxCustomWinSocket.SendBuf Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function SendBuf(var Buf; Count: Integer): Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.SendStream Method

TnxCustomWinSocket.SendStream Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function SendStream(aStream: TStream): Boolean;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.SendStreamThenDrop Method

TnxCustomWinSocket.SendStreamThenDrop Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function SendStreamThenDrop(aStream: TStream): Boolean;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.SendUnicodeText Method

TnxCustomWinSocket.SendUnicodeText Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
function SendUnicodeText(const S: UnicodeString): Integer;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Unlock Method

TnxCustomWinSocket.Unlock Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Unlock;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket.Write Method

TnxCustomWinSocket.Write Method
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Methods Send Feedback
Syntax
Delphi
procedure Write(Socket: TSocket); virtual;
Group

TnxCustomWinSocket Methods

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Methods


TnxCustomWinSocket Properties

TnxCustomWinSocket Properties
TnxCustomWinSocket Class Legend Public Properties Send Feedback

The properties of the TnxCustomWinSocket class are listed here.

Class

TnxCustomWinSocket Class

Public Properties
Name | Description
Addr | This is Addr, a member of class TnxCustomWinSocket.
Connected | This is Connected, a member of class TnxCustomWinSocket.
Data | This is Data, a member of class TnxCustomWinSocket.
LocalAddress | This is LocalAddress, a member of class TnxCustomWinSocket.
LocalHost | This is LocalHost, a member of class TnxCustomWinSocket.
LocalPort | This is LocalPort, a member of class TnxCustomWinSocket.
RemoteAddr | This is RemoteAddr, a member of class TnxCustomWinSocket.
RemoteAddress | This is RemoteAddress, a member of class TnxCustomWinSocket.
RemoteHost | This is RemoteHost, a member of class TnxCustomWinSocket.
RemotePort | This is RemotePort, a member of class TnxCustomWinSocket.
ReportExceptions | This is ReportExceptions, a member of class TnxCustomWinSocket.
SocketHandle | This is SocketHandle, a member of class TnxCustomWinSocket.
SynchronizeEvents | This is SynchronizeEvents, a member of class TnxCustomWinSocket.
Links
TnxCustomWinSocket Class, Legend, Public Properties


TnxCustomWinSocket.Addr Property

TnxCustomWinSocket.Addr Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property Addr: TSockAddrIn;
Description

This is Addr, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.Connected Property

TnxCustomWinSocket.Connected Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property Connected: Boolean;
Description

This is Connected, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.Data Property

TnxCustomWinSocket.Data Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property Data: Pointer;
Description

This is Data, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.LocalAddress Property

TnxCustomWinSocket.LocalAddress Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property LocalAddress: string;
Description

This is LocalAddress, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.LocalHost Property

TnxCustomWinSocket.LocalHost Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property LocalHost: string;
Description

This is LocalHost, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.LocalPort Property

TnxCustomWinSocket.LocalPort Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property LocalPort: Integer;
Description

This is LocalPort, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.RemoteAddr Property

TnxCustomWinSocket.RemoteAddr Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property RemoteAddr: TSockAddrIn;
Description

This is RemoteAddr, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.RemoteAddress Property

TnxCustomWinSocket.RemoteAddress Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property RemoteAddress: string;
Description

This is RemoteAddress, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.RemoteHost Property

TnxCustomWinSocket.RemoteHost Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property RemoteHost: string;
Description

This is RemoteHost, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.RemotePort Property

TnxCustomWinSocket.RemotePort Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property RemotePort: Integer;
Description

This is RemotePort, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.ReportExceptions Property

TnxCustomWinSocket.ReportExceptions Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property ReportExceptions: Boolean;
Description

This is ReportExceptions, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.SocketHandle Property

TnxCustomWinSocket.SocketHandle Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property SocketHandle: TSocket;
Description

This is SocketHandle, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket.SynchronizeEvents Property

TnxCustomWinSocket.SynchronizeEvents Property
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Properties Send Feedback
Syntax
Delphi
property SynchronizeEvents: Boolean;
Description

This is SynchronizeEvents, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Properties

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Properties


TnxCustomWinSocket Events

TnxCustomWinSocket Events
TnxCustomWinSocket Class Legend Public Events Send Feedback

The events of the TnxCustomWinSocket class are listed here.

Class

TnxCustomWinSocket Class

Public Events
Name | Description
OnErrorEvent | This is OnErrorEvent, a member of class TnxCustomWinSocket.
OnSocketEvent | This is OnSocketEvent, a member of class TnxCustomWinSocket.
Links
TnxCustomWinSocket Class, Legend, Public Events


TnxCustomWinSocket.OnErrorEvent Event

TnxCustomWinSocket.OnErrorEvent Event
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Events Send Feedback
Syntax
Delphi
property OnErrorEvent: TnxSocketErrorEvent;
Description

This is OnErrorEvent, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Events

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Events


TnxCustomWinSocket.OnSocketEvent Event

TnxCustomWinSocket.OnSocketEvent Event
TnxCustomWinSocket Class TnxCustomWinSocket Members nxllSocket Namespace TnxCustomWinSocket Events Send Feedback
Syntax
Delphi
property OnSocketEvent: TnxSocketEventEvent;
Description

This is OnSocketEvent, a member of class TnxCustomWinSocket.

Group

TnxCustomWinSocket Events

Links
TnxCustomWinSocket Class, TnxCustomWinSocket Members, nxllSocket Namespace, TnxCustomWinSocket Events


TnxServerAcceptThread Class

TnxServerAcceptThread Class
TnxServerAcceptThread Methods TnxServerAcceptThread Properties TnxServerAcceptThread Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxServerAcceptThreadnxllSocket_TnxServerAcceptThread
Syntax
Delphi
TnxServerAcceptThread = class(TnxThread);
File

nxllSocket

Description

This is class nxllSocket.TnxServerAcceptThread.

Group

Classes

Links
TnxServerAcceptThread Methods, TnxServerAcceptThread Properties, TnxServerAcceptThread Members, nxllSocket, Classes


TnxServerAcceptThread Members

TnxServerAcceptThread Members
TnxServerAcceptThread Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerAcceptThread.

Class

TnxServerAcceptThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
DoHandleException |
DoTerminate |
Execute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxServerAcceptThread
Destroy |
DoExecute |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
ServerSocket | This is ServerSocket, a member of class TnxServerAcceptThread.
Links
TnxServerAcceptThread Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxServerAcceptThread.Create Constructor

TnxServerAcceptThread.Create Constructor
TnxServerAcceptThread Class TnxServerAcceptThread Members nxllSocket Namespace TnxServerAcceptThread Class Send Feedback
Syntax
Delphi
constructor Create(CreateSuspended: Boolean; aSocket: TnxServerWinSocket);
Description

TnxServerAcceptThread

Class

TnxServerAcceptThread Class

Links
TnxServerAcceptThread Class, TnxServerAcceptThread Members, nxllSocket Namespace, TnxServerAcceptThread Class


TnxServerAcceptThread Methods

TnxServerAcceptThread Methods
TnxServerAcceptThread Class Legend Public Methods Send Feedback

The methods of the TnxServerAcceptThread class are listed here.

Class

TnxServerAcceptThread Class

Public Methods
Name | Description
DoExecute |
Links
TnxServerAcceptThread Class, Legend, Public Methods


TnxServerAcceptThread.DoExecute Method

TnxServerAcceptThread.DoExecute Method
TnxServerAcceptThread Class TnxServerAcceptThread Members nxllSocket Namespace TnxServerAcceptThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Group

TnxServerAcceptThread Methods

Links
TnxServerAcceptThread Class, TnxServerAcceptThread Members, nxllSocket Namespace, TnxServerAcceptThread Methods


TnxServerAcceptThread Properties

TnxServerAcceptThread Properties
TnxServerAcceptThread Class Legend Public Properties Send Feedback

The properties of the TnxServerAcceptThread class are listed here.

Class

TnxServerAcceptThread Class

Public Properties
Name | Description
ServerSocket | This is ServerSocket, a member of class TnxServerAcceptThread.
Links
TnxServerAcceptThread Class, Legend, Public Properties


TnxServerAcceptThread.ServerSocket Property

TnxServerAcceptThread.ServerSocket Property
TnxServerAcceptThread Class TnxServerAcceptThread Members nxllSocket Namespace TnxServerAcceptThread Properties Send Feedback
Syntax
Delphi
property ServerSocket: TnxServerWinSocket;
Description

This is ServerSocket, a member of class TnxServerAcceptThread.

Group

TnxServerAcceptThread Properties

Links
TnxServerAcceptThread Class, TnxServerAcceptThread Members, nxllSocket Namespace, TnxServerAcceptThread Properties


TnxServerClientThread Class

TnxServerClientThread Class
TnxServerClientThread Methods TnxServerClientThread Properties TnxServerClientThread Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxServerClientThreadnxllSocket_TnxServerClientThread
Syntax
Delphi
TnxServerClientThread = class(TnxThread);
File

nxllSocket

Description

This is class nxllSocket.TnxServerClientThread.

Group

Classes

Links
TnxServerClientThread Methods, TnxServerClientThread Properties, TnxServerClientThread Members, nxllSocket, Classes


TnxServerClientThread Members

TnxServerClientThread Members
TnxServerClientThread Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerClientThread.

Class

TnxServerClientThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
ClientExecute |
DoExecute |
DoHandleException |
DoTerminate |
EndConnect |
Error |
Event |
Execute |
HandleException |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
ReActivate |
SetName |
StartConnect |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxServerClientThread
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
ClientSocket | This is ClientSocket, a member of class TnxServerClientThread.
Data | This is Data, a member of class TnxServerClientThread.
KeepInCache | This is KeepInCache, a member of class TnxServerClientThread.
ServerSocket | This is ServerSocket, a member of class TnxServerClientThread.
Links
TnxServerClientThread Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxServerClientThread.Create Constructor

TnxServerClientThread.Create Constructor
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Class Send Feedback
Syntax
Delphi
constructor Create(CreateSuspended: Boolean; aSocket: TnxServerClientWinSocket);
Description

TnxServerClientThread

Class

TnxServerClientThread Class

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Class


TnxServerClientThread.Destroy Destructor

TnxServerClientThread.Destroy Destructor
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxServerClientThread Class

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Class


TnxServerClientThread Methods

TnxServerClientThread Methods
TnxServerClientThread Class Legend Protected Methods Send Feedback

The methods of the TnxServerClientThread class are listed here.

Class

TnxServerClientThread Class

Protected Methods
Name | Description
ClientExecute |
DoExecute |
DoTerminate |
EndConnect |
Error |
Event |
HandleException |
ReActivate |
StartConnect |
Links
TnxServerClientThread Class, Legend, Protected Methods


TnxServerClientThread.ClientExecute Method

TnxServerClientThread.ClientExecute Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure ClientExecute; virtual;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.DoExecute Method

TnxServerClientThread.DoExecute Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.DoTerminate Method

TnxServerClientThread.DoTerminate Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure DoTerminate; override;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.EndConnect Method

TnxServerClientThread.EndConnect Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
function EndConnect: Boolean;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.Error Method

TnxServerClientThread.Error Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure Error(ErrorEvent: TnxErrorEvent; var ErrorCode: Integer); virtual;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.Event Method

TnxServerClientThread.Event Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure Event(SocketEvent: TnxSocketEvent); virtual;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.HandleException Method

TnxServerClientThread.HandleException Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure HandleException; virtual;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.ReActivate Method

TnxServerClientThread.ReActivate Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
procedure ReActivate(aSocket: TnxServerClientWinSocket);
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread.StartConnect Method

TnxServerClientThread.StartConnect Method
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Methods Send Feedback
Syntax
Delphi
function StartConnect: Boolean;
Group

TnxServerClientThread Methods

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Methods


TnxServerClientThread Properties

TnxServerClientThread Properties
TnxServerClientThread Class Legend Public Properties Send Feedback

The properties of the TnxServerClientThread class are listed here.

Class

TnxServerClientThread Class

Public Properties
Name | Description
ClientSocket | This is ClientSocket, a member of class TnxServerClientThread.
Data | This is Data, a member of class TnxServerClientThread.
KeepInCache | This is KeepInCache, a member of class TnxServerClientThread.
ServerSocket | This is ServerSocket, a member of class TnxServerClientThread.
Links
TnxServerClientThread Class, Legend, Public Properties


TnxServerClientThread.ClientSocket Property

TnxServerClientThread.ClientSocket Property
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Properties Send Feedback
Syntax
Delphi
property ClientSocket: TnxServerClientWinSocket;
Description

This is ClientSocket, a member of class TnxServerClientThread.

Group

TnxServerClientThread Properties

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Properties


TnxServerClientThread.Data Property

TnxServerClientThread.Data Property
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Properties Send Feedback
Syntax
Delphi
property Data: Pointer;
Description

This is Data, a member of class TnxServerClientThread.

Group

TnxServerClientThread Properties

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Properties


TnxServerClientThread.KeepInCache Property

TnxServerClientThread.KeepInCache Property
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Properties Send Feedback
Syntax
Delphi
property KeepInCache: Boolean;
Description

This is KeepInCache, a member of class TnxServerClientThread.

Group

TnxServerClientThread Properties

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Properties


TnxServerClientThread.ServerSocket Property

TnxServerClientThread.ServerSocket Property
TnxServerClientThread Class TnxServerClientThread Members nxllSocket Namespace TnxServerClientThread Properties Send Feedback
Syntax
Delphi
property ServerSocket: TnxServerWinSocket;
Description

This is ServerSocket, a member of class TnxServerClientThread.

Group

TnxServerClientThread Properties

Links
TnxServerClientThread Class, TnxServerClientThread Members, nxllSocket Namespace, TnxServerClientThread Properties


TnxServerClientWinSocket Class

TnxServerClientWinSocket Class
TnxServerClientWinSocket Properties TnxServerClientWinSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxServerClientWinSocketnxllSocket_TnxServerClientWinSocket
Syntax
Delphi
TnxServerClientWinSocket = class(TnxCustomWinSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxServerClientWinSocket.

Group

Classes

Links
TnxServerClientWinSocket Properties, TnxServerClientWinSocket Members, nxllSocket, Classes


TnxServerClientWinSocket Members

TnxServerClientWinSocket Members
TnxServerClientWinSocket Class Legend Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerClientWinSocket.

Class

TnxServerClientWinSocket Class

Protected Methods
Name | Description
DoListen |
DoOpen |
Error |
Event |
InitSocket |
Public Events
Name | Description
OnErrorEvent | This is OnErrorEvent, a member of class TnxCustomWinSocket.
OnSocketEvent | This is OnSocketEvent, a member of class TnxCustomWinSocket.
Public Methods
Name | Description
Accept |
Close |
Connect |
Create | TnxServerClientWinSocket
Destroy |
Disconnect |
Listen |
Lock |
LookupName |
LookupService |
Open |
Read |
ReceiveAnsiText |
ReceiveBuf |
ReceiveLength |
ReceiveUnicodeText |
SendAnsiText |
SendBuf |
SendStream |
SendStreamThenDrop |
SendUnicodeText |
Unlock |
Write |
Public Properties
Name | Description
Addr | This is Addr, a member of class TnxCustomWinSocket.
Connected | This is Connected, a member of class TnxCustomWinSocket.
Data | This is Data, a member of class TnxCustomWinSocket.
LocalAddress | This is LocalAddress, a member of class TnxCustomWinSocket.
LocalHost | This is LocalHost, a member of class TnxCustomWinSocket.
LocalPort | This is LocalPort, a member of class TnxCustomWinSocket.
RemoteAddr | This is RemoteAddr, a member of class TnxCustomWinSocket.
RemoteAddress | This is RemoteAddress, a member of class TnxCustomWinSocket.
RemoteHost | This is RemoteHost, a member of class TnxCustomWinSocket.
RemotePort | This is RemotePort, a member of class TnxCustomWinSocket.
ReportExceptions | This is ReportExceptions, a member of class TnxCustomWinSocket.
ServerWinSocket | This is ServerWinSocket, a member of class TnxServerClientWinSocket.
SocketHandle | This is SocketHandle, a member of class TnxCustomWinSocket.
SynchronizeEvents | This is SynchronizeEvents, a member of class TnxCustomWinSocket.
Links
TnxServerClientWinSocket Class, Legend, Protected Methods, Public Events, Public Methods, Public Properties


TnxServerClientWinSocket.Create Constructor

TnxServerClientWinSocket.Create Constructor
TnxServerClientWinSocket Class TnxServerClientWinSocket Members nxllSocket Namespace TnxServerClientWinSocket Class Send Feedback
Syntax
Delphi
constructor Create(Socket: TSocket; ServerWinSocket: TnxServerWinSocket);
Description

TnxServerClientWinSocket

Class

TnxServerClientWinSocket Class

Links
TnxServerClientWinSocket Class, TnxServerClientWinSocket Members, nxllSocket Namespace, TnxServerClientWinSocket Class


TnxServerClientWinSocket.Destroy Destructor

TnxServerClientWinSocket.Destroy Destructor
TnxServerClientWinSocket Class TnxServerClientWinSocket Members nxllSocket Namespace TnxServerClientWinSocket Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxServerClientWinSocket Class

Links
TnxServerClientWinSocket Class, TnxServerClientWinSocket Members, nxllSocket Namespace, TnxServerClientWinSocket Class


TnxServerClientWinSocket Properties

TnxServerClientWinSocket Properties
TnxServerClientWinSocket Class Legend Public Properties Send Feedback

The properties of the TnxServerClientWinSocket class are listed here.

Class

TnxServerClientWinSocket Class

Public Properties
Name | Description
ServerWinSocket | This is ServerWinSocket, a member of class TnxServerClientWinSocket.
Links
TnxServerClientWinSocket Class, Legend, Public Properties


TnxServerClientWinSocket.ServerWinSocket Property

TnxServerClientWinSocket.ServerWinSocket Property
TnxServerClientWinSocket Class TnxServerClientWinSocket Members nxllSocket Namespace TnxServerClientWinSocket Properties Send Feedback
Syntax
Delphi
property ServerWinSocket: TnxServerWinSocket;
Description

This is ServerWinSocket, a member of class TnxServerClientWinSocket.

Group

TnxServerClientWinSocket Properties

Links
TnxServerClientWinSocket Class, TnxServerClientWinSocket Members, nxllSocket Namespace, TnxServerClientWinSocket Properties


TnxServerSocket Class

TnxServerSocket Class
TnxServerSocket Properties TnxServerSocket Events TnxServerSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxServerSocketnxllSocket_TnxServerSocketnxllSocket_TnxServerSocketnxllSocket_TnxServerSocket
Syntax
Delphi
TnxServerSocket = class(TnxCustomServerSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxServerSocket.

Group

Classes

Links
TnxServerSocket Properties, TnxServerSocket Events, TnxServerSocket Members, nxllSocket, Classes


TnxServerSocket Members

TnxServerSocket Members
TnxServerSocket Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerSocket.

Class

TnxServerSocket Class

Protected Events
Name | Description
OnConnect | This is OnConnect, a member of class TnxCustomSocket.
OnConnecting | This is OnConnecting, a member of class TnxCustomSocket.
OnDisconnect | This is OnDisconnect, a member of class TnxCustomSocket.
OnError | This is OnError, a member of class TnxCustomSocket.
OnLookup | This is OnLookup, a member of class TnxCustomSocket.
OnRead | This is OnRead, a member of class TnxCustomSocket.
OnWrite | This is OnWrite, a member of class TnxCustomSocket.
Protected Fields
Name | Description
cssServerSocket | This is cssServerSocket, a member of class TnxCustomServerSocket.
Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class TnxAbstractSocket.
DoActivate |
Error | This is Error, a member of class TnxAbstractSocket.
Error |
Event | This is Event, a member of class TnxAbstractSocket.
Event | TnxCustomSocket
GetGetSocketEvent |
GetGetThreadEvent |
GetOnClientError |
GetOnClientEvent |
GetOnThreadEnd |
GetOnThreadStart |
GetThreadCacheSize |
InitSocket |
SetGetSocketEvent |
SetGetThreadEvent |
SetOnClientError |
SetOnClientEvent |
SetOnThreadEnd |
SetOnThreadStart |
SetThreadCacheSize |
Protected Properties
Name | Description
Address | This is Address, a member of class TnxAbstractSocket.
Host | This is Host, a member of class TnxAbstractSocket.
Public Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxServerSocket.
OnClientConnect | This is OnClientConnect, a member of class TnxServerSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxServerSocket.
OnClientError | This is OnClientError, a member of class TnxServerSocket.
OnClientRead | This is OnClientRead, a member of class TnxServerSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxServerSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxServerSocket.
OnGetThread | This is OnGetThread, a member of class TnxServerSocket.
OnListen | This is OnListen, a member of class TnxServerSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxServerSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxServerSocket.
Public Methods
Name | Description
Close |
Create | TnxServerSocket
Destroy | TnxCustomServerSocket
Open |
Public Properties
Name | Description
Active | This is Active, a member of class TnxServerSocket.
Port | This is Port, a member of class TnxServerSocket.
Service | This is Service, a member of class TnxServerSocket.
Socket | This is Socket, a member of class TnxServerSocket.
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxServerSocket.
Links
TnxServerSocket Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Events, Public Methods, Public Properties


TnxServerSocket.Create Constructor

TnxServerSocket.Create Constructor
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxServerSocket

Class

TnxServerSocket Class

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Class


TnxServerSocket Properties

TnxServerSocket Properties
TnxServerSocket Class Legend Public Properties Send Feedback

The properties of the TnxServerSocket class are listed here.

Class

TnxServerSocket Class

Public Properties
Name | Description
Active | This is Active, a member of class TnxServerSocket.
Port | This is Port, a member of class TnxServerSocket.
Service | This is Service, a member of class TnxServerSocket.
Socket | This is Socket, a member of class TnxServerSocket.
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxServerSocket.
Links
TnxServerSocket Class, Legend, Public Properties


TnxServerSocket.Active Property

TnxServerSocket.Active Property
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Properties Send Feedback
Syntax
Delphi
property Active: Boolean;
Description

This is Active, a member of class TnxServerSocket.

Group

TnxServerSocket Properties

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Properties


TnxServerSocket.Port Property

TnxServerSocket.Port Property
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Properties Send Feedback
Syntax
Delphi
property Port: Integer;
Description

This is Port, a member of class TnxServerSocket.

Group

TnxServerSocket Properties

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Properties


TnxServerSocket.Service Property

TnxServerSocket.Service Property
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Properties Send Feedback
Syntax
Delphi
property Service: string;
Description

This is Service, a member of class TnxServerSocket.

Group

TnxServerSocket Properties

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Properties


TnxServerSocket.Socket Property

TnxServerSocket.Socket Property
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Properties Send Feedback
Syntax
Delphi
property Socket: TnxServerWinSocket;
Description

This is Socket, a member of class TnxServerSocket.

Group

TnxServerSocket Properties

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Properties


TnxServerSocket.ThreadCacheSize Property

TnxServerSocket.ThreadCacheSize Property
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Properties Send Feedback
Syntax
Delphi
property ThreadCacheSize: Integer;
Description

This is ThreadCacheSize, a member of class TnxServerSocket.

Group

TnxServerSocket Properties

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Properties


TnxServerSocket Events

TnxServerSocket Events
TnxServerSocket Class Legend Public Events Send Feedback

The events of the TnxServerSocket class are listed here.

Class

TnxServerSocket Class

Public Events
Name | Description
OnAccept | This is OnAccept, a member of class TnxServerSocket.
OnClientConnect | This is OnClientConnect, a member of class TnxServerSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxServerSocket.
OnClientError | This is OnClientError, a member of class TnxServerSocket.
OnClientRead | This is OnClientRead, a member of class TnxServerSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxServerSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxServerSocket.
OnGetThread | This is OnGetThread, a member of class TnxServerSocket.
OnListen | This is OnListen, a member of class TnxServerSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxServerSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxServerSocket.
Links
TnxServerSocket Class, Legend, Public Events


TnxServerSocket.OnAccept Event

TnxServerSocket.OnAccept Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnAccept: TnxSocketNotifyEvent;
Description

This is OnAccept, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnClientConnect Event

TnxServerSocket.OnClientConnect Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnClientConnect: TnxSocketNotifyEvent;
Description

This is OnClientConnect, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnClientDisconnect Event

TnxServerSocket.OnClientDisconnect Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnClientDisconnect: TnxSocketNotifyEvent;
Description

This is OnClientDisconnect, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnClientError Event

TnxServerSocket.OnClientError Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnClientError: TnxSocketErrorEvent;
Description

This is OnClientError, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnClientRead Event

TnxServerSocket.OnClientRead Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnClientRead: TnxSocketNotifyEvent;
Description

This is OnClientRead, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnClientWrite Event

TnxServerSocket.OnClientWrite Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnClientWrite: TnxSocketNotifyEvent;
Description

This is OnClientWrite, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnGetSocket Event

TnxServerSocket.OnGetSocket Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnGetSocket: TnxGetSocketEvent;
Description

This is OnGetSocket, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnGetThread Event

TnxServerSocket.OnGetThread Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnGetThread: TnxGetThreadEvent;
Description

This is OnGetThread, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnListen Event

TnxServerSocket.OnListen Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnListen: TnxSocketNotifyEvent;
Description

This is OnListen, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnThreadEnd Event

TnxServerSocket.OnThreadEnd Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnThreadEnd: TnxThreadNotifyEvent;
Description

This is OnThreadEnd, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerSocket.OnThreadStart Event

TnxServerSocket.OnThreadStart Event
TnxServerSocket Class TnxServerSocket Members nxllSocket Namespace TnxServerSocket Events Send Feedback
Syntax
Delphi
property OnThreadStart: TnxThreadNotifyEvent;
Description

This is OnThreadStart, a member of class TnxServerSocket.

Group

TnxServerSocket Events

Links
TnxServerSocket Class, TnxServerSocket Members, nxllSocket Namespace, TnxServerSocket Events


TnxServerWinSocket Class

TnxServerWinSocket Class
TnxServerWinSocket Methods TnxServerWinSocket Properties TnxServerWinSocket Events TnxServerWinSocket Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxServerWinSocketnxllSocket_TnxServerWinSocket
Syntax
Delphi
TnxServerWinSocket = class(TnxCustomWinSocket);
File

nxllSocket

Description

This is class nxllSocket.TnxServerWinSocket.

Group

Classes

Links
TnxServerWinSocket Methods, TnxServerWinSocket Properties, TnxServerWinSocket Events, TnxServerWinSocket Members, nxllSocket, Classes


TnxServerWinSocket Members

TnxServerWinSocket Members
TnxServerWinSocket Class Legend Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerWinSocket.

Class

TnxServerWinSocket Class

Protected Methods
Name | Description
ClientConnect |
ClientDisconnect |
ClientErrorEvent |
ClientRead |
ClientWrite |
DoCreateThread |
DoListen |
DoOpen |
Error |
Event |
GetClientSocket |
GetServerThread |
InitSocket |
Listen |
SetThreadCacheSize |
ThreadEnd |
ThreadStart |
Public Events
Name | Description
OnClientConnect | This is OnClientConnect, a member of class TnxServerWinSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxServerWinSocket.
OnClientError | This is OnClientError, a member of class TnxServerWinSocket.
OnClientRead | This is OnClientRead, a member of class TnxServerWinSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxServerWinSocket.
OnErrorEvent | This is OnErrorEvent, a member of class TnxCustomWinSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxServerWinSocket.
OnGetThread | This is OnGetThread, a member of class TnxServerWinSocket.
OnSocketEvent | This is OnSocketEvent, a member of class TnxCustomWinSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxServerWinSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxServerWinSocket.
Public Methods
Name | Description
Accept |
Close |
Connect |
Create | TnxServerWinSocket
Destroy |
Disconnect |
GetClientThread |
Lock |
LookupName |
LookupService |
Open |
Read |
ReceiveAnsiText |
ReceiveBuf |
ReceiveLength |
ReceiveUnicodeText |
SendAnsiText |
SendBuf |
SendStream |
SendStreamThenDrop |
SendUnicodeText |
Unlock |
Write |
Public Properties
Name | Description
AcceptPriority | This is AcceptPriority, a member of class TnxServerWinSocket.
ActiveConnections | This is ActiveConnections, a member of class TnxServerWinSocket.
ActiveThreads | This is ActiveThreads, a member of class TnxServerWinSocket.
Addr | This is Addr, a member of class TnxCustomWinSocket.
Connected | This is Connected, a member of class TnxCustomWinSocket.
Connections | This is Connections, a member of class TnxServerWinSocket.
Data | This is Data, a member of class TnxCustomWinSocket.
IdleThreads | This is IdleThreads, a member of class TnxServerWinSocket.
LocalAddress | This is LocalAddress, a member of class TnxCustomWinSocket.
LocalHost | This is LocalHost, a member of class TnxCustomWinSocket.
LocalPort | This is LocalPort, a member of class TnxCustomWinSocket.
RemoteAddr | This is RemoteAddr, a member of class TnxCustomWinSocket.
RemoteAddress | This is RemoteAddress, a member of class TnxCustomWinSocket.
RemoteHost | This is RemoteHost, a member of class TnxCustomWinSocket.
RemotePort | This is RemotePort, a member of class TnxCustomWinSocket.
ReportExceptions | This is ReportExceptions, a member of class TnxCustomWinSocket.
SocketHandle | This is SocketHandle, a member of class TnxCustomWinSocket.
SynchronizeEvents | This is SynchronizeEvents, a member of class TnxCustomWinSocket.
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxServerWinSocket.
Links
TnxServerWinSocket Class, Legend, Protected Methods, Public Events, Public Methods, Public Properties


TnxServerWinSocket.Create Constructor

TnxServerWinSocket.Create Constructor
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Class Send Feedback
Syntax
Delphi
constructor Create(aSocket: TSocket);
Description

TnxServerWinSocket

Class

TnxServerWinSocket Class

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Class


TnxServerWinSocket.Destroy Destructor

TnxServerWinSocket.Destroy Destructor
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxServerWinSocket Class

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Class


TnxServerWinSocket Methods

TnxServerWinSocket Methods
TnxServerWinSocket Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxServerWinSocket class are listed here.

Class

TnxServerWinSocket Class

Protected Methods
Name | Description
ClientConnect |
ClientDisconnect |
ClientErrorEvent |
ClientRead |
ClientWrite |
DoCreateThread |
GetClientSocket |
GetServerThread |
Listen |
SetThreadCacheSize |
ThreadEnd |
ThreadStart |
Public Methods
Name | Description
Accept |
Disconnect |
GetClientThread |
Links
TnxServerWinSocket Class, Legend, Protected Methods, Public Methods


TnxServerWinSocket.Accept Method

TnxServerWinSocket.Accept Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure Accept(Socket: TSocket); override;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ClientConnect Method

TnxServerWinSocket.ClientConnect Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ClientConnect(Socket: TnxCustomWinSocket); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ClientDisconnect Method

TnxServerWinSocket.ClientDisconnect Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ClientDisconnect(Socket: TnxCustomWinSocket); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ClientErrorEvent Method

TnxServerWinSocket.ClientErrorEvent Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ClientErrorEvent(Socket: TnxCustomWinSocket; ErrorEvent: TnxErrorEvent; var ErrorCode: Integer); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ClientRead Method

TnxServerWinSocket.ClientRead Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ClientRead(Socket: TnxCustomWinSocket); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ClientWrite Method

TnxServerWinSocket.ClientWrite Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ClientWrite(Socket: TnxCustomWinSocket); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.Disconnect Method

TnxServerWinSocket.Disconnect Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure Disconnect(Socket: TSocket); override;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.DoCreateThread Method

TnxServerWinSocket.DoCreateThread Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
function DoCreateThread(ClientSocket: TnxServerClientWinSocket): TnxServerClientThread; virtual;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.GetClientSocket Method

TnxServerWinSocket.GetClientSocket Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
function GetClientSocket(Socket: TSocket): TnxServerClientWinSocket; dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.GetClientThread Method

TnxServerWinSocket.GetClientThread Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
function GetClientThread(ClientSocket: TnxServerClientWinSocket): TnxServerClientThread;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.GetServerThread Method

TnxServerWinSocket.GetServerThread Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
function GetServerThread(ClientSocket: TnxServerClientWinSocket): TnxServerClientThread; dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.Listen Method

TnxServerWinSocket.Listen Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure Listen(var Name: string; var Address: string; var Service: string; Port: Word; QueueSize: Integer);
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.SetThreadCacheSize Method

TnxServerWinSocket.SetThreadCacheSize Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure SetThreadCacheSize(Value: Integer);
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ThreadEnd Method

TnxServerWinSocket.ThreadEnd Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ThreadEnd(aThread: TnxServerClientThread); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket.ThreadStart Method

TnxServerWinSocket.ThreadStart Method
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Methods Send Feedback
Syntax
Delphi
procedure ThreadStart(aThread: TnxServerClientThread); dynamic;
Group

TnxServerWinSocket Methods

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Methods


TnxServerWinSocket Properties

TnxServerWinSocket Properties
TnxServerWinSocket Class Legend Public Properties Send Feedback

The properties of the TnxServerWinSocket class are listed here.

Class

TnxServerWinSocket Class

Public Properties
Name | Description
AcceptPriority | This is AcceptPriority, a member of class TnxServerWinSocket.
ActiveConnections | This is ActiveConnections, a member of class TnxServerWinSocket.
ActiveThreads | This is ActiveThreads, a member of class TnxServerWinSocket.
Connections | This is Connections, a member of class TnxServerWinSocket.
IdleThreads | This is IdleThreads, a member of class TnxServerWinSocket.
ThreadCacheSize | This is ThreadCacheSize, a member of class TnxServerWinSocket.
Links
TnxServerWinSocket Class, Legend, Public Properties


TnxServerWinSocket.AcceptPriority Property

TnxServerWinSocket.AcceptPriority Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property AcceptPriority: TThreadPriority;
Description

This is AcceptPriority, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket.ActiveConnections Property

TnxServerWinSocket.ActiveConnections Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property ActiveConnections: Integer;
Description

This is ActiveConnections, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket.ActiveThreads Property

TnxServerWinSocket.ActiveThreads Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property ActiveThreads: Integer;
Description

This is ActiveThreads, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket.Connections Property

TnxServerWinSocket.Connections Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property Connections [Index: Integer]: TnxCustomWinSocket;
Description

This is Connections, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket.IdleThreads Property

TnxServerWinSocket.IdleThreads Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property IdleThreads: Integer;
Description

This is IdleThreads, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket.ThreadCacheSize Property

TnxServerWinSocket.ThreadCacheSize Property
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Properties Send Feedback
Syntax
Delphi
property ThreadCacheSize: Integer;
Description

This is ThreadCacheSize, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Properties

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Properties


TnxServerWinSocket Events

TnxServerWinSocket Events
TnxServerWinSocket Class Legend Public Events Send Feedback

The events of the TnxServerWinSocket class are listed here.

Class

TnxServerWinSocket Class

Public Events
Name | Description
OnClientConnect | This is OnClientConnect, a member of class TnxServerWinSocket.
OnClientDisconnect | This is OnClientDisconnect, a member of class TnxServerWinSocket.
OnClientError | This is OnClientError, a member of class TnxServerWinSocket.
OnClientRead | This is OnClientRead, a member of class TnxServerWinSocket.
OnClientWrite | This is OnClientWrite, a member of class TnxServerWinSocket.
OnGetSocket | This is OnGetSocket, a member of class TnxServerWinSocket.
OnGetThread | This is OnGetThread, a member of class TnxServerWinSocket.
OnThreadEnd | This is OnThreadEnd, a member of class TnxServerWinSocket.
OnThreadStart | This is OnThreadStart, a member of class TnxServerWinSocket.
Links
TnxServerWinSocket Class, Legend, Public Events


TnxServerWinSocket.OnClientConnect Event

TnxServerWinSocket.OnClientConnect Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnClientConnect: TnxSocketNotifyEvent;
Description

This is OnClientConnect, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnClientDisconnect Event

TnxServerWinSocket.OnClientDisconnect Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnClientDisconnect: TnxSocketNotifyEvent;
Description

This is OnClientDisconnect, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnClientError Event

TnxServerWinSocket.OnClientError Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnClientError: TnxSocketErrorEvent;
Description

This is OnClientError, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnClientRead Event

TnxServerWinSocket.OnClientRead Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnClientRead: TnxSocketNotifyEvent;
Description

This is OnClientRead, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnClientWrite Event

TnxServerWinSocket.OnClientWrite Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnClientWrite: TnxSocketNotifyEvent;
Description

This is OnClientWrite, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnGetSocket Event

TnxServerWinSocket.OnGetSocket Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnGetSocket: TnxGetSocketEvent;
Description

This is OnGetSocket, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnGetThread Event

TnxServerWinSocket.OnGetThread Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnGetThread: TnxGetThreadEvent;
Description

This is OnGetThread, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnThreadEnd Event

TnxServerWinSocket.OnThreadEnd Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnThreadEnd: TnxThreadNotifyEvent;
Description

This is OnThreadEnd, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxServerWinSocket.OnThreadStart Event

TnxServerWinSocket.OnThreadStart Event
TnxServerWinSocket Class TnxServerWinSocket Members nxllSocket Namespace TnxServerWinSocket Events Send Feedback
Syntax
Delphi
property OnThreadStart: TnxThreadNotifyEvent;
Description

This is OnThreadStart, a member of class TnxServerWinSocket.

Group

TnxServerWinSocket Events

Links
TnxServerWinSocket Class, TnxServerWinSocket Members, nxllSocket Namespace, TnxServerWinSocket Events


TnxWinSocketStream Class

TnxWinSocketStream Class
TnxWinSocketStream Methods TnxWinSocketStream Properties TnxWinSocketStream Members nxllSocket Classes Send Feedback
Class Hierarchy
nxllSocket_TnxWinSocketStream
Syntax
Delphi
TnxWinSocketStream = class(TStream);
File

nxllSocket

Description

This is class nxllSocket.TnxWinSocketStream.

Group

Classes

Links
TnxWinSocketStream Methods, TnxWinSocketStream Properties, TnxWinSocketStream Members, nxllSocket, Classes


TnxWinSocketStream Members

TnxWinSocketStream Members
TnxWinSocketStream Class Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWinSocketStream.

Class

TnxWinSocketStream Class

Public Methods
Name | Description
Create | TnxWinSocketStream
Destroy |
Read |
ReadAnsiString |
ReadUnicodeString |
Seek |
WaitForData |
Write |
WriteAnsiString |
WriteUnicodeString |
Public Properties
Name | Description
TimeOut | This is TimeOut, a member of class TnxWinSocketStream.
Links
TnxWinSocketStream Class, Legend, Public Methods, Public Properties


TnxWinSocketStream.Create Constructor

TnxWinSocketStream.Create Constructor
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Class Send Feedback
Syntax
Delphi
constructor Create(aSocket: TnxCustomWinSocket; TimeOut: Longint);
Description

TnxWinSocketStream

Class

TnxWinSocketStream Class

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Class


TnxWinSocketStream.Destroy Destructor

TnxWinSocketStream.Destroy Destructor
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxWinSocketStream Class

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Class


TnxWinSocketStream Methods

TnxWinSocketStream Methods
TnxWinSocketStream Class Legend Public Methods Send Feedback

The methods of the TnxWinSocketStream class are listed here.

Class

TnxWinSocketStream Class

Public Methods
Name | Description
Read |
ReadAnsiString |
ReadUnicodeString |
Seek |
WaitForData |
Write |
WriteAnsiString |
WriteUnicodeString |
Links
TnxWinSocketStream Class, Legend, Public Methods


TnxWinSocketStream.Read Method

TnxWinSocketStream.Read Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Longint): Longint; override;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.ReadAnsiString Method

TnxWinSocketStream.ReadAnsiString Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function ReadAnsiString: AnsiString;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.ReadUnicodeString Method

TnxWinSocketStream.ReadUnicodeString Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function ReadUnicodeString: UnicodeString;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.Seek Method

TnxWinSocketStream.Seek Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function Seek(Offset: Longint; Origin: Word): Longint; override;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.WaitForData Method

TnxWinSocketStream.WaitForData Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function WaitForData(Timeout: Longint): Boolean;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.Write Method

TnxWinSocketStream.Write Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
function Write(const Buffer; Count: Longint): Longint; override;
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.WriteAnsiString Method

TnxWinSocketStream.WriteAnsiString Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
procedure WriteAnsiString(const aString: AnsiString);
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream.WriteUnicodeString Method

TnxWinSocketStream.WriteUnicodeString Method
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Methods Send Feedback
Syntax
Delphi
procedure WriteUnicodeString(const aString: UnicodeString);
Group

TnxWinSocketStream Methods

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Methods


TnxWinSocketStream Properties

TnxWinSocketStream Properties
TnxWinSocketStream Class Legend Public Properties Send Feedback

The properties of the TnxWinSocketStream class are listed here.

Class

TnxWinSocketStream Class

Public Properties
Name | Description
TimeOut | This is TimeOut, a member of class TnxWinSocketStream.
Links
TnxWinSocketStream Class, Legend, Public Properties


TnxWinSocketStream.TimeOut Property

TnxWinSocketStream.TimeOut Property
TnxWinSocketStream Class TnxWinSocketStream Members nxllSocket Namespace TnxWinSocketStream Properties Send Feedback
Syntax
Delphi
property TimeOut: Longint;
Description

This is TimeOut, a member of class TnxWinSocketStream.

Group

TnxWinSocketStream Properties

Links
TnxWinSocketStream Class, TnxWinSocketStream Members, nxllSocket Namespace, TnxWinSocketStream Properties


Functions

Functions
Functions nxllSocket Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
SetErrorProc |
Namespace

nxllSocket Namespace

Links
Functions, nxllSocket Namespace, Legend


nxllSocket.SetErrorProc Function

nxllSocket.SetErrorProc Function
nxllSocket Functions Send Feedback
Syntax
Delphi
function SetErrorProc(ErrorProc: TnxSocketErrorProc): TnxSocketErrorProc;
File

nxllSocket

Group

Functions

Links
nxllSocket, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllSocket Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxErrorEvent | This is record nxllSocket.TnxErrorEvent.
TnxSocketEvent | This is record nxllSocket.TnxSocketEvent.
Namespace

nxllSocket Namespace

Links
Enumerations, nxllSocket Namespace, Legend


nxllSocket.TnxErrorEvent Enumeration

nxllSocket.TnxErrorEvent Enumeration
nxllSocket Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxErrorEvent = ( eeGeneral, eeSend, eeReceive, eeConnect, eeDisconnect, eeAccept );
File

nxllSocket

Description

This is record nxllSocket.TnxErrorEvent.

Group

Structs, Records, Enums

Links
nxllSocket, Structs, Records, Enums


nxllSocket.TnxSocketEvent Enumeration

nxllSocket.TnxSocketEvent Enumeration
nxllSocket Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSocketEvent = ( seLookup, seConnecting, seConnect, seDisconnect, seListen, seAccept, seWrite, seRead );
File

nxllSocket

Description

This is record nxllSocket.TnxSocketEvent.

Group

Structs, Records, Enums

Links
nxllSocket, Structs, Records, Enums


Types

Types
nxllSocket Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSocket Namespace

Types
Name | Description
TnxGetSocketEvent | This is type nxllSocket.TnxGetSocketEvent.
TnxGetThreadEvent | This is type nxllSocket.TnxGetThreadEvent.
TnxSocketErrorEvent | This is type nxllSocket.TnxSocketErrorEvent.
TnxSocketErrorProc | This is type nxllSocket.TnxSocketErrorProc.
TnxSocketEventEvent | This is type nxllSocket.TnxSocketEventEvent.
TnxSocketNotifyEvent | This is type nxllSocket.TnxSocketNotifyEvent.
TnxThreadNotifyEvent | This is type nxllSocket.TnxThreadNotifyEvent.
Links
nxllSocket Namespace, Types


nxllSocket.TnxGetSocketEvent Type

nxllSocket.TnxGetSocketEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxGetSocketEvent = procedure (Sender : TObject; Socket : TSocket; var ClientSocket : TnxServerClientWinSocket) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxGetSocketEvent.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxGetThreadEvent Type

nxllSocket.TnxGetThreadEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxGetThreadEvent = procedure (Sender : TObject; ClientSocket : TnxServerClientWinSocket; var SocketThread : TnxServerClientThread) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxGetThreadEvent.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxSocketErrorEvent Type

nxllSocket.TnxSocketErrorEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxSocketErrorEvent = procedure (Sender : TObject; Socket : TnxCustomWinSocket; ErrorEvent : TnxErrorEvent; var ErrorCode : Integer) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxSocketErrorEvent.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxSocketErrorProc Type

nxllSocket.TnxSocketErrorProc Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxSocketErrorProc = procedure (ErrorCode: Integer);
File

nxllSocket

Description

This is type nxllSocket.TnxSocketErrorProc.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxSocketEventEvent Type

nxllSocket.TnxSocketEventEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxSocketEventEvent = procedure (Sender : TObject; Socket : TnxCustomWinSocket; SocketEvent : TnxSocketEvent) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxSocketEventEvent.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxSocketNotifyEvent Type

nxllSocket.TnxSocketNotifyEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxSocketNotifyEvent = procedure (Sender : TObject; Socket : TnxCustomWinSocket) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxSocketNotifyEvent.

Group

Types

Links
nxllSocket, Types


nxllSocket.TnxThreadNotifyEvent Type

nxllSocket.TnxThreadNotifyEvent Type
nxllSocket Types Send Feedback
Syntax
Delphi
TnxThreadNotifyEvent = procedure (Sender: TObject; Thread: TnxServerClientThread) of object;
File

nxllSocket

Description

This is type nxllSocket.TnxThreadNotifyEvent.

Group

Types

Links
nxllSocket, Types


nxllStreams Namespace

nxllStreams Namespace
Classes Constants Functions Legend Topics Types Send Feedback

This is namespace nxllStreams.

Classes
Name | Description
TnxAnsiStringStream | This is class nxllStreams.TnxAnsiStringStream.
TnxBaseStreamHubElement | This is class nxllStreams.TnxBaseStreamHubElement.
TnxBytesStream | This is class nxllStreams.TnxBytesStream.
TnxCustomMemoryStream | This is class nxllStreams.TnxCustomMemoryStream.
TnxMemoryStream | TnxMemoryStream
TnxPointerStreamHubElement | This is class nxllStreams.TnxPointerStreamHubElement.
TnxReader | This is class nxllStreams.TnxReader.
TnxReplyReader | This is class nxllStreams.TnxReplyReader.
TnxRequestWriter | This is class nxllStreams.TnxRequestWriter.
TnxStaticMemoryStream | This is class nxllStreams.TnxStaticMemoryStream.
TnxStreamHub | This is class nxllStreams.TnxStreamHub.
TnxStreamStreamHubElement | This is class nxllStreams.TnxStreamStreamHubElement.
TnxWriter | This is class nxllStreams.TnxWriter.
Constants
Name | Description
nxcl_1KB | This is constant nxllStreams.nxcl_1KB.
nxcl_SystemAllocationSize | This is constant nxllStreams.nxcl_SystemAllocationSize.
nxcl_SystemPageSize | This is constant nxllStreams.nxcl_SystemPageSize.
Functions
Name | Description
nxAnsiStringWriter | nxAnsiStringWriter
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PStream | This is type nxllStreams.PStream.
TnxProcessStreamedRequest | This is type nxllStreams.TnxProcessStreamedRequest.
Links
Classes, Constants, Functions, Legend, Topics, Types


Classes

Classes
Classes nxllStreams Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAnsiStringStream | This is class nxllStreams.TnxAnsiStringStream.
TnxBaseStreamHubElement | This is class nxllStreams.TnxBaseStreamHubElement.
TnxBytesStream | This is class nxllStreams.TnxBytesStream.
TnxCustomMemoryStream | This is class nxllStreams.TnxCustomMemoryStream.
TnxMemoryStream | TnxMemoryStream
TnxPointerStreamHubElement | This is class nxllStreams.TnxPointerStreamHubElement.
TnxReader | This is class nxllStreams.TnxReader.
TnxReplyReader | This is class nxllStreams.TnxReplyReader.
TnxRequestWriter | This is class nxllStreams.TnxRequestWriter.
TnxStaticMemoryStream | This is class nxllStreams.TnxStaticMemoryStream.
TnxStreamHub | This is class nxllStreams.TnxStreamHub.
TnxStreamStreamHubElement | This is class nxllStreams.TnxStreamStreamHubElement.
TnxWriter | This is class nxllStreams.TnxWriter.
Namespace

nxllStreams Namespace

Links
Classes, nxllStreams Namespace, Legend


TnxAnsiStringStream Class

TnxAnsiStringStream Class
TnxAnsiStringStream Fields TnxAnsiStringStream Methods TnxAnsiStringStream Properties TnxAnsiStringStream Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxAnsiStringStream
Syntax
Delphi
TnxAnsiStringStream = class(TStream);
File

nxllStreams

Description

This is class nxllStreams.TnxAnsiStringStream.

Group

Classes

Links
TnxAnsiStringStream Fields, TnxAnsiStringStream Methods, TnxAnsiStringStream Properties, TnxAnsiStringStream Members, nxllStreams, Classes


TnxAnsiStringStream Members

TnxAnsiStringStream Members
TnxAnsiStringStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAnsiStringStream.

Class

TnxAnsiStringStream Class

Protected Fields
Name | Description
assDataString | private
assPosition | This is assPosition, a member of class TnxAnsiStringStream.
Protected Methods
Name | Description
SetSize |
Public Methods
Name | Description
Create | TnxAnsiStringStream
Read |
ReadString |
Seek |
Write |
WriteString |
Public Properties
Name | Description
DataString | This is DataString, a member of class TnxAnsiStringStream.
Links
TnxAnsiStringStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAnsiStringStream.Create Constructor

TnxAnsiStringStream.Create Constructor
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Class Send Feedback
Syntax
Delphi
constructor Create(const aString: AnsiString);
Description

TnxAnsiStringStream

Class

TnxAnsiStringStream Class

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Class


TnxAnsiStringStream Fields

TnxAnsiStringStream Fields
TnxAnsiStringStream Class Legend Protected Fields Send Feedback

The fields of the TnxAnsiStringStream class are listed here.

Class

TnxAnsiStringStream Class

Protected Fields
Name | Description
assDataString | private
assPosition | This is assPosition, a member of class TnxAnsiStringStream.
Links
TnxAnsiStringStream Class, Legend, Protected Fields


TnxAnsiStringStream.assDataString Field

TnxAnsiStringStream.assDataString Field
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Fields Send Feedback
Syntax
Delphi
assDataString: AnsiString;
Description

private

Group

TnxAnsiStringStream Fields

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Fields


TnxAnsiStringStream.assPosition Field

TnxAnsiStringStream.assPosition Field
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Fields Send Feedback
Syntax
Delphi
assPosition: Integer;
Description

This is assPosition, a member of class TnxAnsiStringStream.

Group

TnxAnsiStringStream Fields

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Fields


TnxAnsiStringStream Methods

TnxAnsiStringStream Methods
TnxAnsiStringStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAnsiStringStream class are listed here.

Class

TnxAnsiStringStream Class

Protected Methods
Name | Description
SetSize |
Public Methods
Name | Description
Read |
ReadString |
Seek |
Write |
WriteString |
Links
TnxAnsiStringStream Class, Legend, Protected Methods, Public Methods


TnxAnsiStringStream.Read Method

TnxAnsiStringStream.Read Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Longint): Longint; override;
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream.ReadString Method

TnxAnsiStringStream.ReadString Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
function ReadString(aCount: Longint): AnsiString;
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream.Seek Method

TnxAnsiStringStream.Seek Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Longint; aOrigin: Word): Longint; override;
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream.SetSize Method

TnxAnsiStringStream.SetSize Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
procedure SetSize(aNewSize: Longint); override;
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream.Write Method

TnxAnsiStringStream.Write Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Longint): Longint; override;
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream.WriteString Method

TnxAnsiStringStream.WriteString Method
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Methods Send Feedback
Syntax
Delphi
procedure WriteString(const aString: AnsiString);
Group

TnxAnsiStringStream Methods

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Methods


TnxAnsiStringStream Properties

TnxAnsiStringStream Properties
TnxAnsiStringStream Class Legend Public Properties Send Feedback

The properties of the TnxAnsiStringStream class are listed here.

Class

TnxAnsiStringStream Class

Public Properties
Name | Description
DataString | This is DataString, a member of class TnxAnsiStringStream.
Links
TnxAnsiStringStream Class, Legend, Public Properties


TnxAnsiStringStream.DataString Property

TnxAnsiStringStream.DataString Property
TnxAnsiStringStream Class TnxAnsiStringStream Members nxllStreams Namespace TnxAnsiStringStream Properties Send Feedback
Syntax
Delphi
property DataString: AnsiString;
Description

This is DataString, a member of class TnxAnsiStringStream.

Group

TnxAnsiStringStream Properties

Links
TnxAnsiStringStream Class, TnxAnsiStringStream Members, nxllStreams Namespace, TnxAnsiStringStream Properties


TnxBaseStreamHubElement Class

TnxBaseStreamHubElement Class
TnxBaseStreamHubElement Fields TnxBaseStreamHubElement Methods TnxBaseStreamHubElement Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxBaseStreamHubElementnxllStreams_TnxBaseStreamHubElement
Syntax
Delphi
TnxBaseStreamHubElement = class(TnxObject);
File

nxllStreams

Description

This is class nxllStreams.TnxBaseStreamHubElement.

Group

Classes

Links
TnxBaseStreamHubElement Fields, TnxBaseStreamHubElement Methods, TnxBaseStreamHubElement Members, nxllStreams, Classes


TnxBaseStreamHubElement Members

TnxBaseStreamHubElement Members
TnxBaseStreamHubElement Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseStreamHubElement.

Class

TnxBaseStreamHubElement Class

Protected Fields
Name | Description
bsheHub | private
bsheNext | This is bsheNext, a member of class TnxBaseStreamHubElement.
Protected Methods
Name | Description
Create | TnxBaseStreamHubElement
Read | This is Read, a member of class TnxBaseStreamHubElement.
Public Methods
Name | Description
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxBaseStreamHubElement Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseStreamHubElement.Create Constructor

TnxBaseStreamHubElement.Create Constructor
TnxBaseStreamHubElement Class TnxBaseStreamHubElement Members nxllStreams Namespace TnxBaseStreamHubElement Class Send Feedback
Syntax
Delphi
constructor Create(aHub: TnxStreamHub);
Description

TnxBaseStreamHubElement

Class

TnxBaseStreamHubElement Class

Links
TnxBaseStreamHubElement Class, TnxBaseStreamHubElement Members, nxllStreams Namespace, TnxBaseStreamHubElement Class


TnxBaseStreamHubElement.Destroy Destructor

TnxBaseStreamHubElement.Destroy Destructor
TnxBaseStreamHubElement Class TnxBaseStreamHubElement Members nxllStreams Namespace TnxBaseStreamHubElement Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseStreamHubElement Class

Links
TnxBaseStreamHubElement Class, TnxBaseStreamHubElement Members, nxllStreams Namespace, TnxBaseStreamHubElement Class


TnxBaseStreamHubElement Fields

TnxBaseStreamHubElement Fields
TnxBaseStreamHubElement Class Legend Protected Fields Send Feedback

The fields of the TnxBaseStreamHubElement class are listed here.

Class

TnxBaseStreamHubElement Class

Protected Fields
Name | Description
bsheHub | private
bsheNext | This is bsheNext, a member of class TnxBaseStreamHubElement.
Links
TnxBaseStreamHubElement Class, Legend, Protected Fields


TnxBaseStreamHubElement.bsheHub Field

TnxBaseStreamHubElement.bsheHub Field
TnxBaseStreamHubElement Class TnxBaseStreamHubElement Members nxllStreams Namespace TnxBaseStreamHubElement Fields Send Feedback
Syntax
Delphi
bsheHub: TnxStreamHub;
Description

private

Group

TnxBaseStreamHubElement Fields

Links
TnxBaseStreamHubElement Class, TnxBaseStreamHubElement Members, nxllStreams Namespace, TnxBaseStreamHubElement Fields


TnxBaseStreamHubElement.bsheNext Field

TnxBaseStreamHubElement.bsheNext Field
TnxBaseStreamHubElement Class TnxBaseStreamHubElement Members nxllStreams Namespace TnxBaseStreamHubElement Fields Send Feedback
Syntax
Delphi
bsheNext: TnxBaseStreamHubElement;
Description

This is bsheNext, a member of class TnxBaseStreamHubElement.

Group

TnxBaseStreamHubElement Fields

Links
TnxBaseStreamHubElement Class, TnxBaseStreamHubElement Members, nxllStreams Namespace, TnxBaseStreamHubElement Fields


TnxBaseStreamHubElement Methods

TnxBaseStreamHubElement Methods
TnxBaseStreamHubElement Class Legend Protected Methods Send Feedback

The methods of the TnxBaseStreamHubElement class are listed here.

Class

TnxBaseStreamHubElement Class

Protected Methods
Name | Description
Read | This is Read, a member of class TnxBaseStreamHubElement.
Links
TnxBaseStreamHubElement Class, Legend, Protected Methods


TnxBaseStreamHubElement.Read Method

TnxBaseStreamHubElement.Read Method
TnxBaseStreamHubElement Class TnxBaseStreamHubElement Members nxllStreams Namespace TnxBaseStreamHubElement Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; virtual; abstract;
Description

This is Read, a member of class TnxBaseStreamHubElement.

Group

TnxBaseStreamHubElement Methods

Links
TnxBaseStreamHubElement Class, TnxBaseStreamHubElement Members, nxllStreams Namespace, TnxBaseStreamHubElement Methods


TnxBytesStream Class

TnxBytesStream Class
Create Constructor TnxBytesStream Fields TnxBytesStream Methods TnxBytesStream Properties TnxBytesStream Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxBytesStream
Syntax
Delphi
TnxBytesStream = class(TStream);
File

nxllStreams

Description

This is class nxllStreams.TnxBytesStream.

Group

Classes

Links
Create Constructor, TnxBytesStream Fields, TnxBytesStream Methods, TnxBytesStream Properties, TnxBytesStream Members, nxllStreams, Classes


TnxBytesStream Members

TnxBytesStream Members
TnxBytesStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBytesStream.

Class

TnxBytesStream Class

Protected Fields
Name | Description
bsBytes | private
bsPosition | This is bsPosition, a member of class TnxBytesStream.
Protected Methods
Name | Description
SetSize |
Public Methods
Name | Description
Create | This is the overview for the Create constructor overload.
Read |
ReadBytes |
Seek |
Write |
WriteBytes |
Public Properties
Name | Description
Bytes | This is Bytes, a member of class TnxBytesStream.
Links
TnxBytesStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBytesStream Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBytesStream.Create () |
TnxBytesStream.Create (, Integer) |
TnxBytesStream.Create (TnxBytes) | TnxBytesStream
Class

TnxBytesStream Class

Links
TnxBytesStream Class


TnxBytesStream.Create Constructor ()

TnxBytesStream.Create Constructor ()
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create; overload;
Group

Create Constructor

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, Create Constructor


TnxBytesStream.Create Constructor (, Integer)

TnxBytesStream.Create Constructor (, Integer)
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(const aData; aDataLen: Integer); overload;
Group

Create Constructor

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, Create Constructor


TnxBytesStream.Create Constructor (TnxBytes)

TnxBytesStream.Create Constructor (TnxBytes)
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(const aBytes: TnxBytes); overload;
Description

TnxBytesStream

Group

Create Constructor

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, Create Constructor


TnxBytesStream Fields

TnxBytesStream Fields
TnxBytesStream Class Legend Protected Fields Send Feedback

The fields of the TnxBytesStream class are listed here.

Class

TnxBytesStream Class

Protected Fields
Name | Description
bsBytes | private
bsPosition | This is bsPosition, a member of class TnxBytesStream.
Links
TnxBytesStream Class, Legend, Protected Fields


TnxBytesStream.bsBytes Field

TnxBytesStream.bsBytes Field
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Fields Send Feedback
Syntax
Delphi
bsBytes: TnxBytes;
Description

private

Group

TnxBytesStream Fields

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Fields


TnxBytesStream.bsPosition Field

TnxBytesStream.bsPosition Field
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Fields Send Feedback
Syntax
Delphi
bsPosition: Integer;
Description

This is bsPosition, a member of class TnxBytesStream.

Group

TnxBytesStream Fields

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Fields


TnxBytesStream Methods

TnxBytesStream Methods
TnxBytesStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBytesStream class are listed here.

Class

TnxBytesStream Class

Protected Methods
Name | Description
SetSize |
Public Methods
Name | Description
Read |
ReadBytes |
Seek |
Write |
WriteBytes |
Links
TnxBytesStream Class, Legend, Protected Methods, Public Methods


TnxBytesStream.Read Method

TnxBytesStream.Read Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Longint): Longint; override;
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream.ReadBytes Method

TnxBytesStream.ReadBytes Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
function ReadBytes(aCount: Longint): TnxBytes;
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream.Seek Method

TnxBytesStream.Seek Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Longint; aOrigin: Word): Longint; override;
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream.SetSize Method

TnxBytesStream.SetSize Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
procedure SetSize(aNewSize: Longint); override;
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream.Write Method

TnxBytesStream.Write Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Longint): Longint; override;
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream.WriteBytes Method

TnxBytesStream.WriteBytes Method
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Methods Send Feedback
Syntax
Delphi
procedure WriteBytes(const aBytes: TnxBytes);
Group

TnxBytesStream Methods

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Methods


TnxBytesStream Properties

TnxBytesStream Properties
TnxBytesStream Class Legend Public Properties Send Feedback

The properties of the TnxBytesStream class are listed here.

Class

TnxBytesStream Class

Public Properties
Name | Description
Bytes | This is Bytes, a member of class TnxBytesStream.
Links
TnxBytesStream Class, Legend, Public Properties


TnxBytesStream.Bytes Property

TnxBytesStream.Bytes Property
TnxBytesStream Class TnxBytesStream Members nxllStreams Namespace TnxBytesStream Properties Send Feedback
Syntax
Delphi
property Bytes: TnxBytes;
Description

This is Bytes, a member of class TnxBytesStream.

Group

TnxBytesStream Properties

Links
TnxBytesStream Class, TnxBytesStream Members, nxllStreams Namespace, TnxBytesStream Properties


TnxCustomMemoryStream Class

TnxCustomMemoryStream Class
TnxCustomMemoryStream Fields TnxCustomMemoryStream Methods TnxCustomMemoryStream Properties TnxCustomMemoryStream Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxCustomMemoryStream
Syntax
Delphi
TnxCustomMemoryStream = class(TStream);
File

nxllStreams

Description

This is class nxllStreams.TnxCustomMemoryStream.

Group

Classes

Links
TnxCustomMemoryStream Fields, TnxCustomMemoryStream Methods, TnxCustomMemoryStream Properties, TnxCustomMemoryStream Members, nxllStreams, Classes


TnxCustomMemoryStream Members

TnxCustomMemoryStream Members
TnxCustomMemoryStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCustomMemoryStream.

Class

TnxCustomMemoryStream Class

Protected Fields
Name | Description
cmsMemory | private
cmsPosition | This is cmsPosition, a member of class TnxCustomMemoryStream.
cmsSize | This is cmsSize, a member of class TnxCustomMemoryStream.
Protected Methods
Name | Description
SetPointer |
Public Methods
Name | Description
Read | TnxCustomMemoryStream
SaveToFile |
SaveToStream |
Seek |
TheStream |
Public Properties
Name | Description
Memory | This is Memory, a member of class TnxCustomMemoryStream.
Links
TnxCustomMemoryStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCustomMemoryStream Fields

TnxCustomMemoryStream Fields
TnxCustomMemoryStream Class Legend Protected Fields Send Feedback

The fields of the TnxCustomMemoryStream class are listed here.

Class

TnxCustomMemoryStream Class

Protected Fields
Name | Description
cmsMemory | private
cmsPosition | This is cmsPosition, a member of class TnxCustomMemoryStream.
cmsSize | This is cmsSize, a member of class TnxCustomMemoryStream.
Links
TnxCustomMemoryStream Class, Legend, Protected Fields


TnxCustomMemoryStream.cmsMemory Field

TnxCustomMemoryStream.cmsMemory Field
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Fields Send Feedback
Syntax
Delphi
cmsMemory: Pointer;
Description

private

Group

TnxCustomMemoryStream Fields

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Fields


TnxCustomMemoryStream.cmsPosition Field

TnxCustomMemoryStream.cmsPosition Field
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Fields Send Feedback
Syntax
Delphi
cmsPosition: Integer;
Description

This is cmsPosition, a member of class TnxCustomMemoryStream.

Group

TnxCustomMemoryStream Fields

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Fields


TnxCustomMemoryStream.cmsSize Field

TnxCustomMemoryStream.cmsSize Field
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Fields Send Feedback
Syntax
Delphi
cmsSize: Integer;
Description

This is cmsSize, a member of class TnxCustomMemoryStream.

Group

TnxCustomMemoryStream Fields

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Fields


TnxCustomMemoryStream Methods

TnxCustomMemoryStream Methods
TnxCustomMemoryStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomMemoryStream class are listed here.

Class

TnxCustomMemoryStream Class

Protected Methods
Name | Description
SetPointer |
Public Methods
Name | Description
Read | TnxCustomMemoryStream
SaveToFile |
SaveToStream |
Seek |
TheStream |
Links
TnxCustomMemoryStream Class, Legend, Protected Methods, Public Methods


TnxCustomMemoryStream.Read Method

TnxCustomMemoryStream.Read Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
function Read(var aBuffer; aCount: Integer): Integer; override;
Description

TnxCustomMemoryStream

Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream.SaveToFile Method

TnxCustomMemoryStream.SaveToFile Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
procedure SaveToFile(const aFileName: string);
Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream.SaveToStream Method

TnxCustomMemoryStream.SaveToStream Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
procedure SaveToStream(aStream: TStream);
Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream.Seek Method

TnxCustomMemoryStream.Seek Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
function Seek(aOffset: Integer; aOrigin: Word): Integer; override;
Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream.SetPointer Method

TnxCustomMemoryStream.SetPointer Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
procedure SetPointer(aPointer: Pointer; aSize: Integer);
Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream.TheStream Method

TnxCustomMemoryStream.TheStream Method
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Methods Send Feedback
Syntax
Delphi
function TheStream: TnxCustomMemoryStream;
Group

TnxCustomMemoryStream Methods

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Methods


TnxCustomMemoryStream Properties

TnxCustomMemoryStream Properties
TnxCustomMemoryStream Class Legend Public Properties Send Feedback

The properties of the TnxCustomMemoryStream class are listed here.

Class

TnxCustomMemoryStream Class

Public Properties
Name | Description
Memory | This is Memory, a member of class TnxCustomMemoryStream.
Links
TnxCustomMemoryStream Class, Legend, Public Properties


TnxCustomMemoryStream.Memory Property

TnxCustomMemoryStream.Memory Property
TnxCustomMemoryStream Class TnxCustomMemoryStream Members nxllStreams Namespace TnxCustomMemoryStream Properties Send Feedback
Syntax
Delphi
property Memory: Pointer;
Description

This is Memory, a member of class TnxCustomMemoryStream.

Group

TnxCustomMemoryStream Properties

Links
TnxCustomMemoryStream Class, TnxCustomMemoryStream Members, nxllStreams Namespace, TnxCustomMemoryStream Properties


TnxMemoryStream Class

TnxMemoryStream Class
TnxMemoryStream Fields TnxMemoryStream Methods TnxMemoryStream Properties TnxMemoryStream Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxMemoryStreamnxllStreams_TnxMemoryStream
Syntax
Delphi
TnxMemoryStream = class(TnxCustomMemoryStream);
File

nxllStreams

Description

TnxMemoryStream

Group

Classes

Links
TnxMemoryStream Fields, TnxMemoryStream Methods, TnxMemoryStream Properties, TnxMemoryStream Members, nxllStreams, Classes


TnxMemoryStream Members

TnxMemoryStream Members
TnxMemoryStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMemoryStream.

Class

TnxMemoryStream Class

Protected Fields
Name | Description
cmsMemory | private
cmsPosition | This is cmsPosition, a member of class TnxCustomMemoryStream.
cmsSize | This is cmsSize, a member of class TnxCustomMemoryStream.
msCommited | This is msCommited, a member of class TnxMemoryStream.
msReserved | This is msReserved, a member of class TnxMemoryStream.
msReservedBases | This is msReservedBases, a member of class TnxMemoryStream.
msReserveInitial | private
Protected Methods
Name | Description
msRealloc |
msSetCapacity |
SetPointer |
Public Methods
Name | Description
Clear | TnxMemoryStream
Create |
Destroy |
LoadFromFile |
LoadFromStream |
Read | TnxCustomMemoryStream
SaveToFile |
SaveToStream |
Seek |
SetSize |
TheStream |
Write |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxMemoryStream.
Memory | This is Memory, a member of class TnxCustomMemoryStream.
Links
TnxMemoryStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMemoryStream.Create Constructor

TnxMemoryStream.Create Constructor
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Class Send Feedback
Syntax
Delphi
constructor Create(aInitial: Integer = 0);
Class

TnxMemoryStream Class

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Class


TnxMemoryStream.Destroy Destructor

TnxMemoryStream.Destroy Destructor
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMemoryStream Class

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Class


TnxMemoryStream Fields

TnxMemoryStream Fields
TnxMemoryStream Class Legend Protected Fields Send Feedback

The fields of the TnxMemoryStream class are listed here.

Class

TnxMemoryStream Class

Protected Fields
Name | Description
msCommited | This is msCommited, a member of class TnxMemoryStream.
msReserved | This is msReserved, a member of class TnxMemoryStream.
msReservedBases | This is msReservedBases, a member of class TnxMemoryStream.
msReserveInitial | private
Links
TnxMemoryStream Class, Legend, Protected Fields


TnxMemoryStream.msCommited Field

TnxMemoryStream.msCommited Field
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Fields Send Feedback
Syntax
Delphi
msCommited: Integer;
Description

This is msCommited, a member of class TnxMemoryStream.

Group

TnxMemoryStream Fields

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Fields


TnxMemoryStream.msReserved Field

TnxMemoryStream.msReserved Field
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Fields Send Feedback
Syntax
Delphi
msReserved: Integer;
Description

This is msReserved, a member of class TnxMemoryStream.

Group

TnxMemoryStream Fields

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Fields


TnxMemoryStream.msReservedBases Field

TnxMemoryStream.msReservedBases Field
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Fields Send Feedback
Syntax
Delphi
msReservedBases: TnxList;
Description

This is msReservedBases, a member of class TnxMemoryStream.

Group

TnxMemoryStream Fields

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Fields


TnxMemoryStream.msReserveInitial Field

TnxMemoryStream.msReserveInitial Field
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Fields Send Feedback
Syntax
Delphi
msReserveInitial: Integer;
Description

private

Group

TnxMemoryStream Fields

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Fields


TnxMemoryStream Methods

TnxMemoryStream Methods
TnxMemoryStream Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMemoryStream class are listed here.

Class

TnxMemoryStream Class

Protected Methods
Name | Description
msRealloc |
msSetCapacity |
Public Methods
Name | Description
Clear | TnxMemoryStream
LoadFromFile |
LoadFromStream |
SetSize |
Write |
Links
TnxMemoryStream Class, Legend, Protected Methods, Public Methods


TnxMemoryStream.Clear Method

TnxMemoryStream.Clear Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

TnxMemoryStream

Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.LoadFromFile Method

TnxMemoryStream.LoadFromFile Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
procedure LoadFromFile(const aFileName: string);
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.LoadFromStream Method

TnxMemoryStream.LoadFromStream Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
procedure LoadFromStream(aStream: TStream);
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.msRealloc Method

TnxMemoryStream.msRealloc Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
function msRealloc(var aNewCapacity: Integer): Pointer; virtual;
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.msSetCapacity Method

TnxMemoryStream.msSetCapacity Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
procedure msSetCapacity(aNewCapacity: Integer);
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.SetSize Method

TnxMemoryStream.SetSize Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
procedure SetSize(aNewSize: Integer); override;
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream.Write Method

TnxMemoryStream.Write Method
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Group

TnxMemoryStream Methods

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Methods


TnxMemoryStream Properties

TnxMemoryStream Properties
TnxMemoryStream Class Legend Public Properties Send Feedback

The properties of the TnxMemoryStream class are listed here.

Class

TnxMemoryStream Class

Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxMemoryStream.
Links
TnxMemoryStream Class, Legend, Public Properties


TnxMemoryStream.Capacity Property

TnxMemoryStream.Capacity Property
TnxMemoryStream Class TnxMemoryStream Members nxllStreams Namespace TnxMemoryStream Properties Send Feedback
Syntax
Delphi
property Capacity: Integer;
Description

This is Capacity, a member of class TnxMemoryStream.

Group

TnxMemoryStream Properties

Links
TnxMemoryStream Class, TnxMemoryStream Members, nxllStreams Namespace, TnxMemoryStream Properties


TnxPointerStreamHubElement Class

TnxPointerStreamHubElement Class
TnxPointerStreamHubElement Fields TnxPointerStreamHubElement Methods TnxPointerStreamHubElement Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxPointerStreamHubElementnxllStreams_TnxPointerStreamHubElementnxllStreams_TnxPointerStreamHubElement
Syntax
Delphi
TnxPointerStreamHubElement = class(TnxBaseStreamHubElement);
File

nxllStreams

Description

This is class nxllStreams.TnxPointerStreamHubElement.

Group

Classes

Links
TnxPointerStreamHubElement Fields, TnxPointerStreamHubElement Methods, TnxPointerStreamHubElement Members, nxllStreams, Classes


TnxPointerStreamHubElement Members

TnxPointerStreamHubElement Members
TnxPointerStreamHubElement Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxPointerStreamHubElement.

Class

TnxPointerStreamHubElement Class

Protected Fields
Name | Description
bsheHub | private
bsheNext | This is bsheNext, a member of class TnxBaseStreamHubElement.
pshePointer | private
psheSize | This is psheSize, a member of class TnxPointerStreamHubElement.
Protected Methods
Name | Description
Create | TnxPointerStreamHubElement
Read |
Public Methods
Name | Description
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxPointerStreamHubElement Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxPointerStreamHubElement.Create Constructor

TnxPointerStreamHubElement.Create Constructor
TnxPointerStreamHubElement Class TnxPointerStreamHubElement Members nxllStreams Namespace TnxPointerStreamHubElement Class Send Feedback
Syntax
Delphi
constructor Create(aHub: TnxStreamHub; aPointer: Pointer; aSize: Integer);
Description

TnxPointerStreamHubElement

Class

TnxPointerStreamHubElement Class

Links
TnxPointerStreamHubElement Class, TnxPointerStreamHubElement Members, nxllStreams Namespace, TnxPointerStreamHubElement Class


TnxPointerStreamHubElement Fields

TnxPointerStreamHubElement Fields
TnxPointerStreamHubElement Class Legend Protected Fields Send Feedback

The fields of the TnxPointerStreamHubElement class are listed here.

Class

TnxPointerStreamHubElement Class

Protected Fields
Name | Description
pshePointer | private
psheSize | This is psheSize, a member of class TnxPointerStreamHubElement.
Links
TnxPointerStreamHubElement Class, Legend, Protected Fields


TnxPointerStreamHubElement.pshePointer Field

TnxPointerStreamHubElement.pshePointer Field
TnxPointerStreamHubElement Class TnxPointerStreamHubElement Members nxllStreams Namespace TnxPointerStreamHubElement Fields Send Feedback
Syntax
Delphi
pshePointer: Pointer;
Description

private

Group

TnxPointerStreamHubElement Fields

Links
TnxPointerStreamHubElement Class, TnxPointerStreamHubElement Members, nxllStreams Namespace, TnxPointerStreamHubElement Fields


TnxPointerStreamHubElement.psheSize Field

TnxPointerStreamHubElement.psheSize Field
TnxPointerStreamHubElement Class TnxPointerStreamHubElement Members nxllStreams Namespace TnxPointerStreamHubElement Fields Send Feedback
Syntax
Delphi
psheSize: Integer;
Description

This is psheSize, a member of class TnxPointerStreamHubElement.

Group

TnxPointerStreamHubElement Fields

Links
TnxPointerStreamHubElement Class, TnxPointerStreamHubElement Members, nxllStreams Namespace, TnxPointerStreamHubElement Fields


TnxPointerStreamHubElement Methods

TnxPointerStreamHubElement Methods
TnxPointerStreamHubElement Class Legend Protected Methods Send Feedback

The methods of the TnxPointerStreamHubElement class are listed here.

Class

TnxPointerStreamHubElement Class

Protected Methods
Name | Description
Read |
Links
TnxPointerStreamHubElement Class, Legend, Protected Methods


TnxPointerStreamHubElement.Read Method

TnxPointerStreamHubElement.Read Method
TnxPointerStreamHubElement Class TnxPointerStreamHubElement Members nxllStreams Namespace TnxPointerStreamHubElement Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; override;
Group

TnxPointerStreamHubElement Methods

Links
TnxPointerStreamHubElement Class, TnxPointerStreamHubElement Members, nxllStreams Namespace, TnxPointerStreamHubElement Methods


TnxReader Class

TnxReader Class
TnxReader Methods TnxReader Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxReadernxllStreams_TnxReadernxllStreams_TnxReader
Syntax
Delphi
TnxReader = class(TReader);
File

nxllStreams

Description

This is class nxllStreams.TnxReader.

Group

Classes

Links
TnxReader Methods, TnxReader Members, nxllStreams, Classes


TnxReader Members

TnxReader Members
TnxReader Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxReader.

Class

TnxReader Class

Protected Methods
Name | Description
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
Create | TnxReader
Destroy | This is Destroy, a member of class TFiler.
Destroy | This is Destroy, a member of class TReader.
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadAnsiChar |
ReadBinary |
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadBytes |
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble |
ReadFloat | This is ReadFloat, a member of class TReader.
ReadGuid |
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadStrings |
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar |
ReadWideString | This is ReadWideString, a member of class TReader.
ReadWideString_ |
TheReader |
Public Properties
Name | Description
Position | This is Position, a member of class TReader.
Links
TnxReader Class, Legend, Protected Methods, Public Methods, Public Properties


TnxReader.Create Constructor

TnxReader.Create Constructor
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Class Send Feedback
Syntax
Delphi
constructor Create(aStream: TStream);
Description

TnxReader

Class

TnxReader Class

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Class


TnxReader Methods

TnxReader Methods
TnxReader Class Legend Public Methods Send Feedback

The methods of the TnxReader class are listed here.

Class

TnxReader Class

Public Methods
Name | Description
ReadAnsiChar |
ReadBinary |
ReadBytes |
ReadDouble |
ReadGuid |
ReadStrings |
ReadWideChar |
ReadWideString_ |
TheReader |
Links
TnxReader Class, Legend, Public Methods


TnxReader.ReadAnsiChar Method

TnxReader.ReadAnsiChar Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadAnsiChar: AnsiChar;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadBinary Method

TnxReader.ReadBinary Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
procedure ReadBinary(out Value; Size: Integer);
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadBytes Method

TnxReader.ReadBytes Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadBytes: TnxBytes;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadDouble Method

TnxReader.ReadDouble Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadDouble: Double;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadGuid Method

TnxReader.ReadGuid Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadGuid: TnxGuid;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadStrings Method

TnxReader.ReadStrings Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
procedure ReadStrings(aStrings: TStrings);
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadWideChar Method

TnxReader.ReadWideChar Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadWideChar: WideChar;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.ReadWideString_ Method

TnxReader.ReadWideString_ Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function ReadWideString_: UnicodeString;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReader.TheReader Method

TnxReader.TheReader Method
TnxReader Class TnxReader Members nxllStreams Namespace TnxReader Methods Send Feedback
Syntax
Delphi
function TheReader: TnxReader;
Group

TnxReader Methods

Links
TnxReader Class, TnxReader Members, nxllStreams Namespace, TnxReader Methods


TnxReplyReader Class

TnxReplyReader Class
TnxReplyReader Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxReplyReadernxllStreams_TnxReplyReadernxllStreams_TnxReplyReadernxllStreams_TnxReplyReader
Syntax
Delphi
TnxReplyReader = class(TnxReader);
File

nxllStreams

Description

This is class nxllStreams.TnxReplyReader.

Group

Classes

Links
TnxReplyReader Members, nxllStreams, Classes


TnxReplyReader Members

TnxReplyReader Members
TnxReplyReader Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxReplyReader.

Class

TnxReplyReader Class

Protected Methods
Name | Description
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
Create | TnxReplyReader
Destroy |
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadAnsiChar |
ReadBinary |
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadBytes |
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadDouble |
ReadFloat | This is ReadFloat, a member of class TReader.
ReadGuid |
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadStrings |
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideChar |
ReadWideString | This is ReadWideString, a member of class TReader.
ReadWideString_ |
TheReader |
Public Properties
Name | Description
Position | This is Position, a member of class TReader.
Links
TnxReplyReader Class, Legend, Protected Methods, Public Methods, Public Properties


TnxReplyReader.Create Constructor

TnxReplyReader.Create Constructor
TnxReplyReader Class TnxReplyReader Members nxllStreams Namespace TnxReplyReader Class Send Feedback
Syntax
Delphi
constructor Create(aStream: TStream);
Description

TnxReplyReader

Class

TnxReplyReader Class

Links
TnxReplyReader Class, TnxReplyReader Members, nxllStreams Namespace, TnxReplyReader Class


TnxReplyReader.Destroy Destructor

TnxReplyReader.Destroy Destructor
TnxReplyReader Class TnxReplyReader Members nxllStreams Namespace TnxReplyReader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxReplyReader Class

Links
TnxReplyReader Class, TnxReplyReader Members, nxllStreams Namespace, TnxReplyReader Class


TnxRequestWriter Class

TnxRequestWriter Class
TnxRequestWriter Fields TnxRequestWriter Methods TnxRequestWriter Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxRequestWriternxllStreams_TnxRequestWriternxllStreams_TnxRequestWriternxllStreams_TnxRequestWriter
Syntax
Delphi
TnxRequestWriter = class(TnxWriter);
File

nxllStreams

Description

This is class nxllStreams.TnxRequestWriter.

Group

Classes

Links
TnxRequestWriter Fields, TnxRequestWriter Methods, TnxRequestWriter Members, nxllStreams, Classes


TnxRequestWriter Members

TnxRequestWriter Members
TnxRequestWriter Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRequestWriter.

Class

TnxRequestWriter Class

Protected Fields
Name | Description
rwProcessStreamedRequest | private
rwReplyReader | This is rwReplyReader, a member of class TnxRequestWriter.
rwReplyStream | This is rwReplyStream, a member of class TnxRequestWriter.
rwRequestStream | This is rwRequestStream, a member of class TnxRequestWriter.
Protected Methods
Name | Description
WriteBinary | This is WriteBinary, a member of class TWriter.
WriteValue | This is WriteValue, a member of class TWriter.
Public Methods
Name | Description
Create | TnxRequestWriter
Destroy |
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TWriter.
ReleaseReply |
Request |
RequestIntoStream |
RequestNoReply |
TheWriter |
Write | This is Write, a member of class TWriter.
WriteAnsiChar |
WriteAnsiString |
WriteAnsiStrings |
WriteBinary |
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteBytes |
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDouble | This is WriteDouble, a member of class TWriter.
WriteDouble |
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteGuid |
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteStrings |
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteWideChar | This is WriteWideChar, a member of class TWriter.
WriteWideChar |
WriteWideString | This is WriteWideString, a member of class TWriter.
WriteWideString_ |
WriteWideStrings |
Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TnxRequestWriter Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRequestWriter.Create Constructor

TnxRequestWriter.Create Constructor
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Class Send Feedback
Syntax
Delphi
constructor Create(aProcessStreamedRequest: TnxProcessStreamedRequest);
Description

TnxRequestWriter

Class

TnxRequestWriter Class

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Class


TnxRequestWriter.Destroy Destructor

TnxRequestWriter.Destroy Destructor
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRequestWriter Class

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Class


TnxRequestWriter Fields

TnxRequestWriter Fields
TnxRequestWriter Class Legend Protected Fields Send Feedback

The fields of the TnxRequestWriter class are listed here.

Class

TnxRequestWriter Class

Protected Fields
Name | Description
rwProcessStreamedRequest | private
rwReplyReader | This is rwReplyReader, a member of class TnxRequestWriter.
rwReplyStream | This is rwReplyStream, a member of class TnxRequestWriter.
rwRequestStream | This is rwRequestStream, a member of class TnxRequestWriter.
Links
TnxRequestWriter Class, Legend, Protected Fields


TnxRequestWriter.rwProcessStreamedRequest Field

TnxRequestWriter.rwProcessStreamedRequest Field
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Fields Send Feedback
Syntax
Delphi
rwProcessStreamedRequest: TnxProcessStreamedRequest;
Description

private

Group

TnxRequestWriter Fields

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Fields


TnxRequestWriter.rwReplyReader Field

TnxRequestWriter.rwReplyReader Field
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Fields Send Feedback
Syntax
Delphi
rwReplyReader: TnxReplyReader;
Description

This is rwReplyReader, a member of class TnxRequestWriter.

Group

TnxRequestWriter Fields

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Fields


TnxRequestWriter.rwReplyStream Field

TnxRequestWriter.rwReplyStream Field
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Fields Send Feedback
Syntax
Delphi
rwReplyStream: TnxMemoryStream;
Description

This is rwReplyStream, a member of class TnxRequestWriter.

Group

TnxRequestWriter Fields

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Fields


TnxRequestWriter.rwRequestStream Field

TnxRequestWriter.rwRequestStream Field
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Fields Send Feedback
Syntax
Delphi
rwRequestStream: TnxMemoryStream;
Description

This is rwRequestStream, a member of class TnxRequestWriter.

Group

TnxRequestWriter Fields

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Fields


TnxRequestWriter Methods

TnxRequestWriter Methods
TnxRequestWriter Class Legend Public Methods Send Feedback

The methods of the TnxRequestWriter class are listed here.

Class

TnxRequestWriter Class

Public Methods
Name | Description
ReleaseReply |
Request |
RequestIntoStream |
RequestNoReply |
Links
TnxRequestWriter Class, Legend, Public Methods


TnxRequestWriter.ReleaseReply Method

TnxRequestWriter.ReleaseReply Method
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Methods Send Feedback
Syntax
Delphi
function ReleaseReply: TnxReplyReader;
Group

TnxRequestWriter Methods

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Methods


TnxRequestWriter.Request Method

TnxRequestWriter.Request Method
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Methods Send Feedback
Syntax
Delphi
function Request(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRequestWriter Methods

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Methods


TnxRequestWriter.RequestIntoStream Method

TnxRequestWriter.RequestIntoStream Method
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Methods Send Feedback
Syntax
Delphi
function RequestIntoStream(aMsgID: TnxMsgID; aStream: TStream): TnxResult;
Group

TnxRequestWriter Methods

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Methods


TnxRequestWriter.RequestNoReply Method

TnxRequestWriter.RequestNoReply Method
TnxRequestWriter Class TnxRequestWriter Members nxllStreams Namespace TnxRequestWriter Methods Send Feedback
Syntax
Delphi
function RequestNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRequestWriter Methods

Links
TnxRequestWriter Class, TnxRequestWriter Members, nxllStreams Namespace, TnxRequestWriter Methods


TnxStaticMemoryStream Class

TnxStaticMemoryStream Class
TnxStaticMemoryStream Methods TnxStaticMemoryStream Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxStaticMemoryStreamnxllStreams_TnxStaticMemoryStream
Syntax
Delphi
TnxStaticMemoryStream = class(TnxCustomMemoryStream);
File

nxllStreams

Description

This is class nxllStreams.TnxStaticMemoryStream.

Group

Classes

Links
TnxStaticMemoryStream Methods, TnxStaticMemoryStream Members, nxllStreams, Classes


TnxStaticMemoryStream Members

TnxStaticMemoryStream Members
TnxStaticMemoryStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxStaticMemoryStream.

Class

TnxStaticMemoryStream Class

Protected Fields
Name | Description
cmsMemory | private
cmsPosition | This is cmsPosition, a member of class TnxCustomMemoryStream.
cmsSize | This is cmsSize, a member of class TnxCustomMemoryStream.
Protected Methods
Name | Description
SetPointer |
Public Methods
Name | Description
Create | TnxStaticMemoryStream
Read | TnxCustomMemoryStream
SaveToFile |
SaveToStream |
Seek |
TheStream |
Write |
Public Properties
Name | Description
Memory | This is Memory, a member of class TnxCustomMemoryStream.
Links
TnxStaticMemoryStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxStaticMemoryStream.Create Constructor

TnxStaticMemoryStream.Create Constructor
TnxStaticMemoryStream Class TnxStaticMemoryStream Members nxllStreams Namespace TnxStaticMemoryStream Class Send Feedback
Syntax
Delphi
constructor Create(aMemory: Pointer; aSize: Integer);
Description

TnxStaticMemoryStream

Class

TnxStaticMemoryStream Class

Links
TnxStaticMemoryStream Class, TnxStaticMemoryStream Members, nxllStreams Namespace, TnxStaticMemoryStream Class


TnxStaticMemoryStream Methods

TnxStaticMemoryStream Methods
TnxStaticMemoryStream Class Legend Public Methods Send Feedback

The methods of the TnxStaticMemoryStream class are listed here.

Class

TnxStaticMemoryStream Class

Public Methods
Name | Description
Write |
Links
TnxStaticMemoryStream Class, Legend, Public Methods


TnxStaticMemoryStream.Write Method

TnxStaticMemoryStream.Write Method
TnxStaticMemoryStream Class TnxStaticMemoryStream Members nxllStreams Namespace TnxStaticMemoryStream Methods Send Feedback
Syntax
Delphi
function Write(const aBuffer; aCount: Integer): Integer; override;
Group

TnxStaticMemoryStream Methods

Links
TnxStaticMemoryStream Class, TnxStaticMemoryStream Members, nxllStreams Namespace, TnxStaticMemoryStream Methods


TnxStreamHub Class

TnxStreamHub Class
TnxStreamHub Fields TnxStreamHub Methods TnxStreamHub Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxStreamHub
Syntax
Delphi
TnxStreamHub = class(TStream);
File

nxllStreams

Description

This is class nxllStreams.TnxStreamHub.

Group

Classes

Links
TnxStreamHub Fields, TnxStreamHub Methods, TnxStreamHub Members, nxllStreams, Classes


TnxStreamHub Members

TnxStreamHub Members
TnxStreamHub Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxStreamHub.

Class

TnxStreamHub Class

Protected Fields
Name | Description
shHead | private
shTail | This is shTail, a member of class TnxStreamHub.
Protected Methods
Name | Description
GetSize |
Public Methods
Name | Description
AddPointer | TnxStreamHub
AddStream |
Read |
Seek |
Links
TnxStreamHub Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxStreamHub Fields

TnxStreamHub Fields
TnxStreamHub Class Legend Protected Fields Send Feedback

The fields of the TnxStreamHub class are listed here.

Class

TnxStreamHub Class

Protected Fields
Name | Description
shHead | private
shTail | This is shTail, a member of class TnxStreamHub.
Links
TnxStreamHub Class, Legend, Protected Fields


TnxStreamHub.shHead Field

TnxStreamHub.shHead Field
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Fields Send Feedback
Syntax
Delphi
shHead: TnxBaseStreamHubElement;
Description

private

Group

TnxStreamHub Fields

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Fields


TnxStreamHub.shTail Field

TnxStreamHub.shTail Field
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Fields Send Feedback
Syntax
Delphi
shTail: TnxBaseStreamHubElement;
Description

This is shTail, a member of class TnxStreamHub.

Group

TnxStreamHub Fields

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Fields


TnxStreamHub Methods

TnxStreamHub Methods
TnxStreamHub Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStreamHub class are listed here.

Class

TnxStreamHub Class

Protected Methods
Name | Description
GetSize |
Public Methods
Name | Description
AddPointer | TnxStreamHub
AddStream |
Read |
Seek |
Links
TnxStreamHub Class, Legend, Protected Methods, Public Methods


TnxStreamHub.AddPointer Method

TnxStreamHub.AddPointer Method
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Methods Send Feedback
Syntax
Delphi
procedure AddPointer(aPointer: Pointer; aSize: Integer);
Description

TnxStreamHub

Group

TnxStreamHub Methods

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Methods


TnxStreamHub.AddStream Method

TnxStreamHub.AddStream Method
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Methods Send Feedback
Syntax
Delphi
procedure AddStream(aStream: TStream; aSize: TnxInt64 = -1);
Group

TnxStreamHub Methods

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Methods


TnxStreamHub.GetSize Method

TnxStreamHub.GetSize Method
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Methods Send Feedback
Syntax
Delphi
function GetSize: Int64; override;
Group

TnxStreamHub Methods

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Methods


TnxStreamHub.Read Method

TnxStreamHub.Read Method
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; override;
Group

TnxStreamHub Methods

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Methods


TnxStreamHub.Seek Method

TnxStreamHub.Seek Method
TnxStreamHub Class TnxStreamHub Members nxllStreams Namespace TnxStreamHub Methods Send Feedback
Syntax
Delphi
function Seek(const Offset: Int64; Origin: TSeekOrigin): Int64; override;
Group

TnxStreamHub Methods

Links
TnxStreamHub Class, TnxStreamHub Members, nxllStreams Namespace, TnxStreamHub Methods


TnxStreamStreamHubElement Class

TnxStreamStreamHubElement Class
TnxStreamStreamHubElement Fields TnxStreamStreamHubElement Methods TnxStreamStreamHubElement Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxStreamStreamHubElementnxllStreams_TnxStreamStreamHubElementnxllStreams_TnxStreamStreamHubElement
Syntax
Delphi
TnxStreamStreamHubElement = class(TnxBaseStreamHubElement);
File

nxllStreams

Description

This is class nxllStreams.TnxStreamStreamHubElement.

Group

Classes

Links
TnxStreamStreamHubElement Fields, TnxStreamStreamHubElement Methods, TnxStreamStreamHubElement Members, nxllStreams, Classes


TnxStreamStreamHubElement Members

TnxStreamStreamHubElement Members
TnxStreamStreamHubElement Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxStreamStreamHubElement.

Class

TnxStreamStreamHubElement Class

Protected Fields
Name | Description
bsheHub | private
bsheNext | This is bsheNext, a member of class TnxBaseStreamHubElement.
ssheSize | This is ssheSize, a member of class TnxStreamStreamHubElement.
ssheStream | private
Protected Methods
Name | Description
Create | TnxStreamStreamHubElement
Read |
Public Methods
Name | Description
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxStreamStreamHubElement Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxStreamStreamHubElement.Create Constructor

TnxStreamStreamHubElement.Create Constructor
TnxStreamStreamHubElement Class TnxStreamStreamHubElement Members nxllStreams Namespace TnxStreamStreamHubElement Class Send Feedback
Syntax
Delphi
constructor Create(aHub: TnxStreamHub; aStream: TStream; aSize: TnxInt64 = -1);
Description

TnxStreamStreamHubElement

Class

TnxStreamStreamHubElement Class

Links
TnxStreamStreamHubElement Class, TnxStreamStreamHubElement Members, nxllStreams Namespace, TnxStreamStreamHubElement Class


TnxStreamStreamHubElement Fields

TnxStreamStreamHubElement Fields
TnxStreamStreamHubElement Class Legend Protected Fields Send Feedback

The fields of the TnxStreamStreamHubElement class are listed here.

Class

TnxStreamStreamHubElement Class

Protected Fields
Name | Description
ssheSize | This is ssheSize, a member of class TnxStreamStreamHubElement.
ssheStream | private
Links
TnxStreamStreamHubElement Class, Legend, Protected Fields


TnxStreamStreamHubElement.ssheSize Field

TnxStreamStreamHubElement.ssheSize Field
TnxStreamStreamHubElement Class TnxStreamStreamHubElement Members nxllStreams Namespace TnxStreamStreamHubElement Fields Send Feedback
Syntax
Delphi
ssheSize: TnxInt64;
Description

This is ssheSize, a member of class TnxStreamStreamHubElement.

Group

TnxStreamStreamHubElement Fields

Links
TnxStreamStreamHubElement Class, TnxStreamStreamHubElement Members, nxllStreams Namespace, TnxStreamStreamHubElement Fields


TnxStreamStreamHubElement.ssheStream Field

TnxStreamStreamHubElement.ssheStream Field
TnxStreamStreamHubElement Class TnxStreamStreamHubElement Members nxllStreams Namespace TnxStreamStreamHubElement Fields Send Feedback
Syntax
Delphi
ssheStream: TStream;
Description

private

Group

TnxStreamStreamHubElement Fields

Links
TnxStreamStreamHubElement Class, TnxStreamStreamHubElement Members, nxllStreams Namespace, TnxStreamStreamHubElement Fields


TnxStreamStreamHubElement Methods

TnxStreamStreamHubElement Methods
TnxStreamStreamHubElement Class Legend Protected Methods Send Feedback

The methods of the TnxStreamStreamHubElement class are listed here.

Class

TnxStreamStreamHubElement Class

Protected Methods
Name | Description
Read |
Links
TnxStreamStreamHubElement Class, Legend, Protected Methods


TnxStreamStreamHubElement.Read Method

TnxStreamStreamHubElement.Read Method
TnxStreamStreamHubElement Class TnxStreamStreamHubElement Members nxllStreams Namespace TnxStreamStreamHubElement Methods Send Feedback
Syntax
Delphi
function Read(var Buffer; Count: Integer): Integer; override;
Group

TnxStreamStreamHubElement Methods

Links
TnxStreamStreamHubElement Class, TnxStreamStreamHubElement Members, nxllStreams Namespace, TnxStreamStreamHubElement Methods


TnxWriter Class

TnxWriter Class
TnxWriter Methods TnxWriter Members nxllStreams Classes Send Feedback
Class Hierarchy
nxllStreams_TnxWriternxllStreams_TnxWriternxllStreams_TnxWriter
Syntax
Delphi
TnxWriter = class(TWriter);
File

nxllStreams

Description

This is class nxllStreams.TnxWriter.

Group

Classes

Links
TnxWriter Methods, TnxWriter Members, nxllStreams, Classes


TnxWriter Members

TnxWriter Members
TnxWriter Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWriter.

Class

TnxWriter Class

Protected Methods
Name | Description
WriteValue | This is WriteValue, a member of class TWriter.
Public Methods
Name | Description
Create | TnxWriter
Destroy | This is Destroy, a member of class TFiler.
Destroy | TWriter
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TWriter.
TheWriter |
Write | This is Write, a member of class TWriter.
WriteAnsiChar |
WriteAnsiString |
WriteAnsiStrings |
WriteBinary |
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteBytes |
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDouble |
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteGuid |
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteStrings |
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteWideChar |
WriteWideString | This is WriteWideString, a member of class TWriter.
WriteWideString_ |
WriteWideStrings |
Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TnxWriter Class, Legend, Protected Methods, Public Methods, Public Properties


TnxWriter.Create Constructor

TnxWriter.Create Constructor
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Class Send Feedback
Syntax
Delphi
constructor Create(aStream: TStream);
Description

TnxWriter

Class

TnxWriter Class

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Class


TnxWriter Methods

TnxWriter Methods
TnxWriter Class Legend Public Methods Send Feedback

The methods of the TnxWriter class are listed here.

Class

TnxWriter Class

Public Methods
Name | Description
TheWriter |
WriteAnsiChar |
WriteAnsiString |
WriteAnsiStrings |
WriteBinary |
WriteBytes |
WriteDouble |
WriteGuid |
WriteStrings |
WriteWideChar |
WriteWideString_ |
WriteWideStrings |
Links
TnxWriter Class, Legend, Public Methods


TnxWriter.TheWriter Method

TnxWriter.TheWriter Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
function TheWriter: TnxWriter;
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteAnsiChar Method

TnxWriter.WriteAnsiChar Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteAnsiChar(aChar: AnsiChar);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteAnsiString Method

TnxWriter.WriteAnsiString Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteAnsiString(const aString: AnsiString);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteAnsiStrings Method

TnxWriter.WriteAnsiStrings Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteAnsiStrings(aString: TStrings);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteBinary Method

TnxWriter.WriteBinary Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBinary(const Value; Size: Integer);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteBytes Method

TnxWriter.WriteBytes Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBytes(const aBytes: TnxBytes);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteDouble Method

TnxWriter.WriteDouble Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteDouble(const Value: Double);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteGuid Method

TnxWriter.WriteGuid Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteGuid(const Value: TnxGuid);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteStrings Method

TnxWriter.WriteStrings Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteStrings(aString: TStrings);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteWideChar Method

TnxWriter.WriteWideChar Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideChar(Value: WideChar);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteWideString_ Method

TnxWriter.WriteWideString_ Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideString_(const aString: UnicodeString);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


TnxWriter.WriteWideStrings Method

TnxWriter.WriteWideStrings Method
TnxWriter Class TnxWriter Members nxllStreams Namespace TnxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideStrings(aString: TStrings);
Group

TnxWriter Methods

Links
TnxWriter Class, TnxWriter Members, nxllStreams Namespace, TnxWriter Methods


Functions

Functions
Functions nxllStreams Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxAnsiStringWriter | nxAnsiStringWriter
Namespace

nxllStreams Namespace

Links
Functions, nxllStreams Namespace, Legend


nxllStreams.nxAnsiStringWriter Function

nxllStreams.nxAnsiStringWriter Function
nxllStreams Functions Send Feedback
Syntax
Delphi
procedure nxAnsiStringWriter(const aString: AnsiString; aWriter: TWriter);
File

nxllStreams

Description

nxAnsiStringWriter

Group

Functions

Links
nxllStreams, Functions


Types

Types
nxllStreams Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllStreams Namespace

Types
Name | Description
PStream | This is type nxllStreams.PStream.
TnxProcessStreamedRequest | This is type nxllStreams.TnxProcessStreamedRequest.
Links
nxllStreams Namespace, Types


nxllStreams.PStream Type

nxllStreams.PStream Type
nxllStreams Types Send Feedback
Syntax
Delphi
PStream = ^TStream;
File

nxllStreams

Description

This is type nxllStreams.PStream.

Group

Types

Links
nxllStreams, Types


nxllStreams.TnxProcessStreamedRequest Type

nxllStreams.TnxProcessStreamedRequest Type
nxllStreams Types Send Feedback
Syntax
Delphi
TnxProcessStreamedRequest = function (aMsgID : TnxMsgID; aRequestStream : TnxMemoryStream; aReplyStream : PStream) : TnxResult of object;
File

nxllStreams

Description

This is type nxllStreams.TnxProcessStreamedRequest.

Group

Types

Links
nxllStreams, Types


Constants

Constants
Constants nxllStreams Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxcl_1KB | This is constant nxllStreams.nxcl_1KB.
nxcl_SystemAllocationSize | This is constant nxllStreams.nxcl_SystemAllocationSize.
nxcl_SystemPageSize | This is constant nxllStreams.nxcl_SystemPageSize.
Namespace

nxllStreams Namespace

Links
Constants, nxllStreams Namespace


nxllStreams.nxcl_1KB Constant

nxllStreams.nxcl_1KB Constant
nxllStreams Constants Send Feedback
Syntax
Delphi
nxcl_1KB = 1024;
File

nxllStreams

Description

This is constant nxllStreams.nxcl_1KB.

Group

Constants

Links
nxllStreams, Constants


nxllStreams.nxcl_SystemAllocationSize Constant

nxllStreams.nxcl_SystemAllocationSize Constant
nxllStreams Constants Send Feedback
Syntax
Delphi
nxcl_SystemAllocationSize = 64 * nxcl_1KB;
File

nxllStreams

Description

This is constant nxllStreams.nxcl_SystemAllocationSize.

Group

Constants

Links
nxllStreams, Constants


nxllStreams.nxcl_SystemPageSize Constant

nxllStreams.nxcl_SystemPageSize Constant
nxllStreams Constants Send Feedback
Syntax
Delphi
nxcl_SystemPageSize = 4 * nxcl_1KB;
File

nxllStreams

Description

This is constant nxllStreams.nxcl_SystemPageSize.

Group

Constants

Links
nxllStreams, Constants


nxllSync Namespace

nxllSync Namespace
Classes Constants Functions Interfaces Legend Topics Types Variables Send Feedback

This is namespace nxllSync.

Classes
Name | Description
EnxSyncException | This is class nxllSync.EnxSyncException.
TnxEvent | This is class nxllSync.TnxEvent.
TnxEventPool | This is class nxllSync.TnxEventPool.
TnxManualEvent |
TnxPadlock | This is class nxllSync.TnxPadlock.
TnxReadWritePortal | This is class nxllSync.TnxReadWritePortal.
TnxThreadSafeStack | This is class nxllSync.TnxThreadSafeStack.
Constants
Name | Description
_ManuelEventCacheSize | This is constant nxllSync._ManuelEventCacheSize.
nxcl_INFINITE | This is constant nxllSync.nxcl_INFINITE.
nxcl_InitialEventCount | Initial # of events in event pool.
nxcl_RetainEventCount | of events to retain when flush event pool.
rsCallingWaitForSingleObject | This is constant nxllSync.rsCallingWaitForSingleObject.
Functions
Name | Description
GetManualEvent |
nxBeginBreathCallback |
nxBreath |
nxEndBreathCallback |
Interfaces
Name | Description
InxManualEvent | This is class nxllSync.InxManualEvent.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EnxSyncExceptionClass | This is type nxllSync.EnxSyncExceptionClass.
TInitializeCriticalSectionAndSpinCount | This is type nxllSync.TInitializeCriticalSectionAndSpinCount.
TnxBreathCallback | This is type nxllSync.TnxBreathCallback.
Variables
Name | Description
_InitializeCriticalSectionAndSpinCount | This is variable nxllSync._InitializeCriticalSectionAndSpinCount.
_ManualEventCache |
_ManualEventEntryOffset | This is variable nxllSync._ManualEventEntryOffset.
_PadlockList | TnxPadlock
nxEventPool | This is variable nxllSync.nxEventPool.
StackEntry | This is variable nxllSync.StackEntry.
Links
Classes, Constants, Functions, Interfaces, Legend, Topics, Types, Variables


Classes

Classes
Classes nxllSync Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxSyncException | This is class nxllSync.EnxSyncException.
TnxEvent | This is class nxllSync.TnxEvent.
TnxEventPool | This is class nxllSync.TnxEventPool.
TnxManualEvent |
TnxPadlock | This is class nxllSync.TnxPadlock.
TnxReadWritePortal | This is class nxllSync.TnxReadWritePortal.
TnxThreadSafeStack | This is class nxllSync.TnxThreadSafeStack.
Namespace

nxllSync Namespace

Links
Classes, nxllSync Namespace, Legend


EnxSyncException Class

EnxSyncException Class
nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_EnxSyncExceptionnxllSync_EnxSyncExceptionnxllSync_EnxSyncExceptionnxllSync_EnxSyncException
Syntax
Delphi
EnxSyncException = class(EnxBaseException);
File

nxllSync

Description

This is class nxllSync.EnxSyncException.

Group

Classes

Links
nxllSync, Classes


TnxEvent Class

TnxEvent Class
TnxEvent Methods TnxEvent Properties TnxEvent Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxEventnxllSync_TnxEvent
Syntax
Delphi
TnxEvent = class(TnxObject);
File

nxllSync

Description

This is class nxllSync.TnxEvent.

Group

Classes

Links
TnxEvent Methods, TnxEvent Properties, TnxEvent Members, nxllSync, Classes


TnxEvent Members

TnxEvent Members
TnxEvent Class Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxEvent.

Class

TnxEvent Class

Public Methods
Name | Description
Create | TnxEvent
Destroy |
FreeInstance |
NewInstance | TnxObject
SignalEvent |
WaitFor |
WaitForQuietly |
Public Properties
Name | Description
Handle | This is Handle, a member of class TnxEvent.
Links
TnxEvent Class, Legend, Public Methods, Public Properties


TnxEvent.Create Constructor

TnxEvent.Create Constructor
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxEvent

Class

TnxEvent Class

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Class


TnxEvent.Destroy Destructor

TnxEvent.Destroy Destructor
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxEvent Class

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Class


TnxEvent Methods

TnxEvent Methods
TnxEvent Class Legend Public Methods Send Feedback

The methods of the TnxEvent class are listed here.

Class

TnxEvent Class

Public Methods
Name | Description
SignalEvent |
WaitFor |
WaitForQuietly |
Links
TnxEvent Class, Legend, Public Methods


TnxEvent.SignalEvent Method

TnxEvent.SignalEvent Method
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Methods Send Feedback
Syntax
Delphi
procedure SignalEvent;
Group

TnxEvent Methods

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Methods


TnxEvent.WaitFor Method

TnxEvent.WaitFor Method
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Methods Send Feedback
Syntax
Delphi
procedure WaitFor(aTimeOut: TnxWord32);
Group

TnxEvent Methods

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Methods


TnxEvent.WaitForQuietly Method

TnxEvent.WaitForQuietly Method
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Methods Send Feedback
Syntax
Delphi
function WaitForQuietly(aTimeOut: TnxWord32): TnxWord32;
Group

TnxEvent Methods

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Methods


TnxEvent Properties

TnxEvent Properties
TnxEvent Class Legend Public Properties Send Feedback

The properties of the TnxEvent class are listed here.

Class

TnxEvent Class

Public Properties
Name | Description
Handle | This is Handle, a member of class TnxEvent.
Links
TnxEvent Class, Legend, Public Properties


TnxEvent.Handle Property

TnxEvent.Handle Property
TnxEvent Class TnxEvent Members nxllSync Namespace TnxEvent Properties Send Feedback
Syntax
Delphi
property Handle: THandle;
Description

This is Handle, a member of class TnxEvent.

Group

TnxEvent Properties

Links
TnxEvent Class, TnxEvent Members, nxllSync Namespace, TnxEvent Properties


TnxEventPool Class

TnxEventPool Class
TnxEventPool Fields TnxEventPool Methods TnxEventPool Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxEventPoolnxllSync_TnxEventPool
Syntax
Delphi
TnxEventPool = class(TnxObject);
File

nxllSync

Description

This is class nxllSync.TnxEventPool.

Group

Classes

Links
TnxEventPool Fields, TnxEventPool Methods, TnxEventPool Members, nxllSync, Classes


TnxEventPool Members

TnxEventPool Members
TnxEventPool Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxEventPool.

Class

TnxEventPool Class

Protected Fields
Name | Description
epList | This is epList, a member of class TnxEventPool.
epRetainCount | This is epRetainCount, a member of class TnxEventPool.
Public Methods
Name | Description
Create | TnxEventPool
Destroy |
Flush |
FreeInstance |
Get |
NewInstance | TnxObject
Put |
Links
TnxEventPool Class, Legend, Protected Fields, Public Methods


TnxEventPool.Create Constructor

TnxEventPool.Create Constructor
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Class Send Feedback
Syntax
Delphi
constructor Create(const InitialCount: Integer; const RetainCount: Integer);
Description

TnxEventPool

Class

TnxEventPool Class

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Class


TnxEventPool.Destroy Destructor

TnxEventPool.Destroy Destructor
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxEventPool Class

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Class


TnxEventPool Fields

TnxEventPool Fields
TnxEventPool Class Legend Protected Fields Send Feedback

The fields of the TnxEventPool class are listed here.

Class

TnxEventPool Class

Protected Fields
Name | Description
epList | This is epList, a member of class TnxEventPool.
epRetainCount | This is epRetainCount, a member of class TnxEventPool.
Links
TnxEventPool Class, Legend, Protected Fields


TnxEventPool.epList Field

TnxEventPool.epList Field
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Fields Send Feedback
Syntax
Delphi
epList: TnxThreadSafeStack;
Description

This is epList, a member of class TnxEventPool.

Group

TnxEventPool Fields

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Fields


TnxEventPool.epRetainCount Field

TnxEventPool.epRetainCount Field
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Fields Send Feedback
Syntax
Delphi
epRetainCount: Integer;
Description

This is epRetainCount, a member of class TnxEventPool.

Group

TnxEventPool Fields

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Fields


TnxEventPool Methods

TnxEventPool Methods
TnxEventPool Class Legend Public Methods Send Feedback

The methods of the TnxEventPool class are listed here.

Class

TnxEventPool Class

Public Methods
Name | Description
Flush |
Get |
Put |
Links
TnxEventPool Class, Legend, Public Methods


TnxEventPool.Flush Method

TnxEventPool.Flush Method
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Methods Send Feedback
Syntax
Delphi
procedure Flush;
Group

TnxEventPool Methods

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Methods


TnxEventPool.Get Method

TnxEventPool.Get Method
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Methods Send Feedback
Syntax
Delphi
function Get: THandle;
Group

TnxEventPool Methods

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Methods


TnxEventPool.Put Method

TnxEventPool.Put Method
TnxEventPool Class TnxEventPool Members nxllSync Namespace TnxEventPool Methods Send Feedback
Syntax
Delphi
procedure Put(const aHandle: THandle);
Group

TnxEventPool Methods

Links
TnxEventPool Class, TnxEventPool Members, nxllSync Namespace, TnxEventPool Methods


TnxManualEvent Class

TnxManualEvent Class
TnxManualEvent Fields TnxManualEvent Methods TnxManualEvent Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxManualEventnxllSync_TnxManualEventnxllSync_TnxManualEvent
Syntax
Delphi
TnxManualEvent = class(TnxObject, InxInterface, InxManualEvent);
File

nxllSync

Group

Classes

Links
TnxManualEvent Fields, TnxManualEvent Methods, TnxManualEvent Members, nxllSync, Classes


TnxManualEvent Members

TnxManualEvent Members
TnxManualEvent Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxManualEvent.

Class

TnxManualEvent Class

Protected Fields
Name | Description
meCached | This is meCached, a member of class TnxManualEvent.
meEvent | This is meEvent, a member of class TnxManualEvent.
meNext | private
meRefCount | This is meRefCount, a member of class TnxManualEvent.
Protected Methods
Name | Description
_AddRef |
_Release |
EventHandle |
meCache |
QueryInterface | InxInterface
SetEvent | InxManualEvent
Wait |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Destroy |
FreeInstance |
NewInstance |
Links
TnxManualEvent Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxManualEvent.Create Constructor

TnxManualEvent.Create Constructor
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxManualEvent Class

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Class


TnxManualEvent.Destroy Destructor

TnxManualEvent.Destroy Destructor
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxManualEvent Class

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Class


TnxManualEvent Fields

TnxManualEvent Fields
TnxManualEvent Class Legend Protected Fields Send Feedback

The fields of the TnxManualEvent class are listed here.

Class

TnxManualEvent Class

Protected Fields
Name | Description
meCached | This is meCached, a member of class TnxManualEvent.
meEvent | This is meEvent, a member of class TnxManualEvent.
meNext | private
meRefCount | This is meRefCount, a member of class TnxManualEvent.
Links
TnxManualEvent Class, Legend, Protected Fields


TnxManualEvent.meCached Field

TnxManualEvent.meCached Field
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Fields Send Feedback
Syntax
Delphi
meCached: Integer;
Description

This is meCached, a member of class TnxManualEvent.

Group

TnxManualEvent Fields

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Fields


TnxManualEvent.meEvent Field

TnxManualEvent.meEvent Field
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Fields Send Feedback
Syntax
Delphi
meEvent: THandle;
Description

This is meEvent, a member of class TnxManualEvent.

Group

TnxManualEvent Fields

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Fields


TnxManualEvent.meNext Field

TnxManualEvent.meNext Field
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Fields Send Feedback
Syntax
Delphi
meNext: TnxListEntry;
Description

private

Group

TnxManualEvent Fields

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Fields


TnxManualEvent.meRefCount Field

TnxManualEvent.meRefCount Field
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Fields Send Feedback
Syntax
Delphi
meRefCount: Integer;
Description

This is meRefCount, a member of class TnxManualEvent.

Group

TnxManualEvent Fields

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Fields


TnxManualEvent Methods

TnxManualEvent Methods
TnxManualEvent Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxManualEvent class are listed here.

Class

TnxManualEvent Class

Protected Methods
Name | Description
_AddRef |
_Release |
EventHandle |
meCache |
QueryInterface | InxInterface
SetEvent | InxManualEvent
Wait |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
NewInstance |
Links
TnxManualEvent Class, Legend, Protected Methods, Public Methods


TnxManualEvent._AddRef Method

TnxManualEvent._AddRef Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent._Release Method

TnxManualEvent._Release Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.AfterConstruction Method

TnxManualEvent.AfterConstruction Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.BeforeDestruction Method

TnxManualEvent.BeforeDestruction Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.EventHandle Method

TnxManualEvent.EventHandle Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
function EventHandle: THandle;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.meCache Method

TnxManualEvent.meCache Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
procedure meCache;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.NewInstance Method

TnxManualEvent.NewInstance Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.QueryInterface Method

TnxManualEvent.QueryInterface Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.SetEvent Method

TnxManualEvent.SetEvent Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
procedure SetEvent;
Description

InxManualEvent

Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxManualEvent.Wait Method

TnxManualEvent.Wait Method
TnxManualEvent Class TnxManualEvent Members nxllSync Namespace TnxManualEvent Methods Send Feedback
Syntax
Delphi
procedure Wait;
Group

TnxManualEvent Methods

Links
TnxManualEvent Class, TnxManualEvent Members, nxllSync Namespace, TnxManualEvent Methods


TnxPadlock Class

TnxPadlock Class
TnxPadlock Fields TnxPadlock Methods TnxPadlock Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxPadlocknxllSync_TnxPadlock
Syntax
Delphi
TnxPadlock = class(TnxObject);
File

nxllSync

Description

This is class nxllSync.TnxPadlock.

Group

Classes

Links
TnxPadlock Fields, TnxPadlock Methods, TnxPadlock Members, nxllSync, Classes


TnxPadlock Members

TnxPadlock Members
TnxPadlock Class Legend Protected Fields Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxPadlock.

Class

TnxPadlock Class

Protected Fields
Name | Description
plCritSect | This is plCritSect, a member of class TnxPadlock.
Public Fields
Name | Description
plLockCount | This is plLockCount, a member of class TnxPadlock.
Public Methods
Name | Description
Check |
Create |
CreateAndLock |
Destroy |
FreeInstance |
Lock |
NewInstance | TnxObject
TryLock |
Unlock |
Links
TnxPadlock Class, Legend, Protected Fields, Public Fields, Public Methods


TnxPadlock.Create Constructor

TnxPadlock.Create Constructor
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Class Send Feedback
Syntax
Delphi
constructor Create(aFastLock: Boolean = False);
Class

TnxPadlock Class

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Class


TnxPadlock.Destroy Destructor

TnxPadlock.Destroy Destructor
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxPadlock Class

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Class


TnxPadlock Fields

TnxPadlock Fields
TnxPadlock Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxPadlock class are listed here.

Class

TnxPadlock Class

Protected Fields
Name | Description
plCritSect | This is plCritSect, a member of class TnxPadlock.
Public Fields
Name | Description
plLockCount | This is plLockCount, a member of class TnxPadlock.
Links
TnxPadlock Class, Legend, Protected Fields, Public Fields


TnxPadlock.plCritSect Field

TnxPadlock.plCritSect Field
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Fields Send Feedback
Syntax
Delphi
plCritSect: TRTLCriticalSection;
Description

This is plCritSect, a member of class TnxPadlock.

Group

TnxPadlock Fields

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Fields


TnxPadlock.plLockCount Field

TnxPadlock.plLockCount Field
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Fields Send Feedback
Syntax
Delphi
plLockCount: Integer;
Description

This is plLockCount, a member of class TnxPadlock.

Group

TnxPadlock Fields

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Fields


TnxPadlock Methods

TnxPadlock Methods
TnxPadlock Class Legend Public Methods Send Feedback

The methods of the TnxPadlock class are listed here.

Class

TnxPadlock Class

Public Methods
Name | Description
Check |
CreateAndLock |
Lock |
TryLock |
Unlock |
Links
TnxPadlock Class, Legend, Public Methods


TnxPadlock.Check Method

TnxPadlock.Check Method
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Methods Send Feedback
Syntax
Delphi
class function Check: Boolean;
Group

TnxPadlock Methods

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Methods


TnxPadlock.CreateAndLock Method

TnxPadlock.CreateAndLock Method
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Methods Send Feedback
Syntax
Delphi
class procedure CreateAndLock(var aPadlock: TnxPadlock; aFastLock: Boolean = False);
Group

TnxPadlock Methods

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Methods


TnxPadlock.Lock Method

TnxPadlock.Lock Method
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Methods Send Feedback
Syntax
Delphi
procedure Lock;
Group

TnxPadlock Methods

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Methods


TnxPadlock.TryLock Method

TnxPadlock.TryLock Method
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Methods Send Feedback
Syntax
Delphi
function TryLock: Boolean;
Group

TnxPadlock Methods

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Methods


TnxPadlock.Unlock Method

TnxPadlock.Unlock Method
TnxPadlock Class TnxPadlock Members nxllSync Namespace TnxPadlock Methods Send Feedback
Syntax
Delphi
procedure Unlock;
Group

TnxPadlock Methods

Links
TnxPadlock Class, TnxPadlock Members, nxllSync Namespace, TnxPadlock Methods


TnxReadWritePortal Class

TnxReadWritePortal Class
TnxReadWritePortal Methods TnxReadWritePortal Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxReadWritePortalnxllSync_TnxReadWritePortalnxllSync_TnxReadWritePortal
Syntax
Delphi
TnxReadWritePortal = class(TnxPadlock);
File

nxllSync

Description

This is class nxllSync.TnxReadWritePortal.

Group

Classes

Links
TnxReadWritePortal Methods, TnxReadWritePortal Members, nxllSync, Classes


TnxReadWritePortal Members

TnxReadWritePortal Members
TnxReadWritePortal Class Legend Protected Fields Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxReadWritePortal.

Class

TnxReadWritePortal Class

Protected Fields
Name | Description
plCritSect | This is plCritSect, a member of class TnxPadlock.
Public Fields
Name | Description
plLockCount | This is plLockCount, a member of class TnxPadlock.
Public Methods
Name | Description
BeginWrite |
Check |
Create |
CreateAndLock |
Destroy |
EndRead |
EndWrite |
FreeInstance |
Lock |
NewInstance | TnxObject
TryLock |
Unlock |
Links
TnxReadWritePortal Class, Legend, Protected Fields, Public Fields, Public Methods


TnxReadWritePortal Methods

TnxReadWritePortal Methods
TnxReadWritePortal Class Legend Public Methods Send Feedback

The methods of the TnxReadWritePortal class are listed here.

Class

TnxReadWritePortal Class

Public Methods
Name | Description
BeginWrite |
EndRead |
EndWrite |
Links
TnxReadWritePortal Class, Legend, Public Methods


TnxReadWritePortal.BeginWrite Method

TnxReadWritePortal.BeginWrite Method
TnxReadWritePortal Class TnxReadWritePortal Members nxllSync Namespace TnxReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure BeginWrite;
Group

TnxReadWritePortal Methods

Links
TnxReadWritePortal Class, TnxReadWritePortal Members, nxllSync Namespace, TnxReadWritePortal Methods


TnxReadWritePortal.EndRead Method

TnxReadWritePortal.EndRead Method
TnxReadWritePortal Class TnxReadWritePortal Members nxllSync Namespace TnxReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure EndRead;
Group

TnxReadWritePortal Methods

Links
TnxReadWritePortal Class, TnxReadWritePortal Members, nxllSync Namespace, TnxReadWritePortal Methods


TnxReadWritePortal.EndWrite Method

TnxReadWritePortal.EndWrite Method
TnxReadWritePortal Class TnxReadWritePortal Members nxllSync Namespace TnxReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure EndWrite;
Group

TnxReadWritePortal Methods

Links
TnxReadWritePortal Class, TnxReadWritePortal Members, nxllSync Namespace, TnxReadWritePortal Methods


TnxThreadSafeStack Class

TnxThreadSafeStack Class
TnxThreadSafeStack Methods TnxThreadSafeStack Properties TnxThreadSafeStack Members nxllSync Classes Send Feedback
Class Hierarchy
nxllSync_TnxThreadSafeStacknxllSync_TnxThreadSafeStack
Syntax
Delphi
TnxThreadSafeStack = class(TnxObject);
File

nxllSync

Description

This is class nxllSync.TnxThreadSafeStack.

Group

Classes

Links
TnxThreadSafeStack Methods, TnxThreadSafeStack Properties, TnxThreadSafeStack Members, nxllSync, Classes


TnxThreadSafeStack Members

TnxThreadSafeStack Members
TnxThreadSafeStack Class Legend Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxThreadSafeStack.

Class

TnxThreadSafeStack Class

Protected Methods
Name | Description
tssAllocBlock |
Public Methods
Name | Description
Create | TnxThreadSafeStack
Destroy |
FreeInstance |
NewInstance | TnxObject
Pop |
Push |
Public Properties
Name | Description
Count | This is Count, a member of class TnxThreadSafeStack.
Links
TnxThreadSafeStack Class, Legend, Protected Methods, Public Methods, Public Properties


TnxThreadSafeStack.Create Constructor

TnxThreadSafeStack.Create Constructor
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxThreadSafeStack

Class

TnxThreadSafeStack Class

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Class


TnxThreadSafeStack.Destroy Destructor

TnxThreadSafeStack.Destroy Destructor
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxThreadSafeStack Class

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Class


TnxThreadSafeStack Methods

TnxThreadSafeStack Methods
TnxThreadSafeStack Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxThreadSafeStack class are listed here.

Class

TnxThreadSafeStack Class

Protected Methods
Name | Description
tssAllocBlock |
Public Methods
Name | Description
Pop |
Push |
Links
TnxThreadSafeStack Class, Legend, Protected Methods, Public Methods


TnxThreadSafeStack.Pop Method

TnxThreadSafeStack.Pop Method
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Methods Send Feedback
Syntax
Delphi
function Pop: Pointer;
Group

TnxThreadSafeStack Methods

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Methods


TnxThreadSafeStack.Push Method

TnxThreadSafeStack.Push Method
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Methods Send Feedback
Syntax
Delphi
procedure Push(p: Pointer);
Group

TnxThreadSafeStack Methods

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Methods


TnxThreadSafeStack.tssAllocBlock Method

TnxThreadSafeStack.tssAllocBlock Method
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Methods Send Feedback
Syntax
Delphi
procedure tssAllocBlock;
Group

TnxThreadSafeStack Methods

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Methods


TnxThreadSafeStack Properties

TnxThreadSafeStack Properties
TnxThreadSafeStack Class Legend Public Properties Send Feedback

The properties of the TnxThreadSafeStack class are listed here.

Class

TnxThreadSafeStack Class

Public Properties
Name | Description
Count | This is Count, a member of class TnxThreadSafeStack.
Links
TnxThreadSafeStack Class, Legend, Public Properties


TnxThreadSafeStack.Count Property

TnxThreadSafeStack.Count Property
TnxThreadSafeStack Class TnxThreadSafeStack Members nxllSync Namespace TnxThreadSafeStack Properties Send Feedback
Syntax
Delphi
property Count: Integer;
Description

This is Count, a member of class TnxThreadSafeStack.

Group

TnxThreadSafeStack Properties

Links
TnxThreadSafeStack Class, TnxThreadSafeStack Members, nxllSync Namespace, TnxThreadSafeStack Properties


Interfaces

Interfaces
nxllSync Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllSync Namespace

Interfaces
Name | Description
InxManualEvent | This is class nxllSync.InxManualEvent.
Links
nxllSync Namespace, Interfaces, Legend


InxManualEvent Interface

InxManualEvent Interface
InxManualEvent Methods InxManualEvent Members nxllSync Interfaces Send Feedback
Class Hierarchy
nxllSync_InxManualEvent
Syntax
Delphi
InxManualEvent = interface(InxInterface);
File

nxllSync

Description

This is class nxllSync.InxManualEvent.

Group

Interfaces

Links
InxManualEvent Methods, InxManualEvent Members, nxllSync, Interfaces


InxManualEvent Members

InxManualEvent Members
InxManualEvent Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxManualEvent.

Interface

InxManualEvent Interface

Public Methods
Name | Description
EventHandle | This is EventHandle, a member of class InxManualEvent.
SetEvent | This is SetEvent, a member of class InxManualEvent.
Wait | This is Wait, a member of class InxManualEvent.
Links
InxManualEvent Interface, Legend, Public Methods


InxManualEvent Methods

InxManualEvent Methods
InxManualEvent Interface Legend Public Methods Send Feedback

The methods of the InxManualEvent class are listed here.

Interface

InxManualEvent Interface

Public Methods
Name | Description
EventHandle | This is EventHandle, a member of class InxManualEvent.
SetEvent | This is SetEvent, a member of class InxManualEvent.
Wait | This is Wait, a member of class InxManualEvent.
Links
InxManualEvent Interface, Legend, Public Methods


InxManualEvent.EventHandle Method

InxManualEvent.EventHandle Method
InxManualEvent Interface InxManualEvent Members nxllSync Namespace InxManualEvent Methods Send Feedback
Syntax
Delphi
function EventHandle: THandle;
Description

This is EventHandle, a member of class InxManualEvent.

Group

InxManualEvent Methods

Links
InxManualEvent Interface, InxManualEvent Members, nxllSync Namespace, InxManualEvent Methods


InxManualEvent.SetEvent Method

InxManualEvent.SetEvent Method
InxManualEvent Interface InxManualEvent Members nxllSync Namespace InxManualEvent Methods Send Feedback
Syntax
Delphi
procedure SetEvent;
Description

This is SetEvent, a member of class InxManualEvent.

Group

InxManualEvent Methods

Links
InxManualEvent Interface, InxManualEvent Members, nxllSync Namespace, InxManualEvent Methods


InxManualEvent.Wait Method

InxManualEvent.Wait Method
InxManualEvent Interface InxManualEvent Members nxllSync Namespace InxManualEvent Methods Send Feedback
Syntax
Delphi
procedure Wait;
Description

This is Wait, a member of class InxManualEvent.

Group

InxManualEvent Methods

Links
InxManualEvent Interface, InxManualEvent Members, nxllSync Namespace, InxManualEvent Methods


Functions

Functions
Functions nxllSync Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
GetManualEvent |
nxBeginBreathCallback |
nxBreath |
nxEndBreathCallback |
Namespace

nxllSync Namespace

Links
Functions, nxllSync Namespace, Legend


nxllSync.GetManualEvent Function

nxllSync.GetManualEvent Function
nxllSync Functions Send Feedback
Syntax
Delphi
function GetManualEvent: InxManualEvent;
File

nxllSync

Group

Functions

Links
nxllSync, Functions


nxllSync.nxBeginBreathCallback Function

nxllSync.nxBeginBreathCallback Function
nxllSync Functions Send Feedback
Syntax
Delphi
procedure nxBeginBreathCallback(aCallback: TnxBreathCallback);
File

nxllSync

Group

Functions

Links
nxllSync, Functions


nxllSync.nxBreath Function

nxllSync.nxBreath Function
nxllSync Functions Send Feedback
Syntax
Delphi
procedure nxBreath;
File

nxllSync

Group

Functions

Links
nxllSync, Functions


nxllSync.nxEndBreathCallback Function

nxllSync.nxEndBreathCallback Function
nxllSync Functions Send Feedback
Syntax
Delphi
procedure nxEndBreathCallback;
File

nxllSync

Group

Functions

Links
nxllSync, Functions


Types

Types
nxllSync Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSync Namespace

Types
Name | Description
EnxSyncExceptionClass | This is type nxllSync.EnxSyncExceptionClass.
TInitializeCriticalSectionAndSpinCount | This is type nxllSync.TInitializeCriticalSectionAndSpinCount.
TnxBreathCallback | This is type nxllSync.TnxBreathCallback.
Links
nxllSync Namespace, Types


nxllSync.EnxSyncExceptionClass Type

nxllSync.EnxSyncExceptionClass Type
nxllSync Types Send Feedback
Syntax
Delphi
EnxSyncExceptionClass = class of EnxSyncException;
File

nxllSync

Description

This is type nxllSync.EnxSyncExceptionClass.

Group

Types

Links
nxllSync, Types


nxllSync.TInitializeCriticalSectionAndSpinCount Type

nxllSync.TInitializeCriticalSectionAndSpinCount Type
nxllSync Types Send Feedback
Syntax
Delphi
TInitializeCriticalSectionAndSpinCount = function (var lpCriticalSection: TRTLCriticalSection; dwSpinCount: DWORD): BOOL;
File

nxllSync

Description

This is type nxllSync.TInitializeCriticalSectionAndSpinCount.

Group

Types

Links
nxllSync, Types


nxllSync.TnxBreathCallback Type

nxllSync.TnxBreathCallback Type
nxllSync Types Send Feedback
Syntax
Delphi
TnxBreathCallback = procedure of object;
File

nxllSync

Description

This is type nxllSync.TnxBreathCallback.

Group

Types

Links
nxllSync, Types


Variables

Variables
nxllSync Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllSync Namespace

Variables
Name | Description
_InitializeCriticalSectionAndSpinCount | This is variable nxllSync._InitializeCriticalSectionAndSpinCount.
_ManualEventCache |
_ManualEventEntryOffset | This is variable nxllSync._ManualEventEntryOffset.
_PadlockList | TnxPadlock
nxEventPool | This is variable nxllSync.nxEventPool.
StackEntry | This is variable nxllSync.StackEntry.
Links
nxllSync Namespace, Variables


nxllSync._InitializeCriticalSectionAndSpinCount Variable

nxllSync._InitializeCriticalSectionAndSpinCount Variable
nxllSync Variables Send Feedback
Syntax
Delphi
_InitializeCriticalSectionAndSpinCount: TInitializeCriticalSectionAndSpinCount;
File

nxllSync

Description

This is variable nxllSync._InitializeCriticalSectionAndSpinCount.

Group

Variables

Links
nxllSync, Variables


nxllSync._ManualEventCache Variable

nxllSync._ManualEventCache Variable
nxllSync Variables Send Feedback
Syntax
Delphi
_ManualEventCache: PnxCountedListHead;
File

nxllSync

Group

Variables

Links
nxllSync, Variables


nxllSync._ManualEventEntryOffset Variable

nxllSync._ManualEventEntryOffset Variable
nxllSync Variables Send Feedback
Syntax
Delphi
_ManualEventEntryOffset: TnxNativeUInt;
File

nxllSync

Description

This is variable nxllSync._ManualEventEntryOffset.

Group

Variables

Links
nxllSync, Variables


nxllSync._PadlockList Variable

nxllSync._PadlockList Variable
nxllSync Variables Send Feedback
Syntax
Delphi
_PadlockList: TThreadList;
File

nxllSync

Description

TnxPadlock

Group

Variables

Links
nxllSync, Variables


nxllSync.nxEventPool Variable

nxllSync.nxEventPool Variable
nxllSync Variables Send Feedback
Syntax
Delphi
nxEventPool: TnxEventPool;
File

nxllSync

Description

This is variable nxllSync.nxEventPool.

Group

Variables

Links
nxllSync, Variables


nxllSync.StackEntry Variable

nxllSync.StackEntry Variable
nxllSync Variables Send Feedback
Syntax
Delphi
StackEntry: PnxStackEntry;
File

nxllSync

Description

This is variable nxllSync.StackEntry.

Group

Variables

Links
nxllSync, Variables


Constants

Constants
Constants nxllSync Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_ManuelEventCacheSize | This is constant nxllSync._ManuelEventCacheSize.
nxcl_INFINITE | This is constant nxllSync.nxcl_INFINITE.
nxcl_InitialEventCount | Initial # of events in event pool.
nxcl_RetainEventCount | of events to retain when flush event pool.
rsCallingWaitForSingleObject | This is constant nxllSync.rsCallingWaitForSingleObject.
Namespace

nxllSync Namespace

Links
Constants, nxllSync Namespace


nxllSync._ManuelEventCacheSize Constant

nxllSync._ManuelEventCacheSize Constant
nxllSync Constants Send Feedback
Syntax
Delphi
_ManuelEventCacheSize = 128;
File

nxllSync

Description

This is constant nxllSync._ManuelEventCacheSize.

Group

Constants

Links
nxllSync, Constants


nxllSync.nxcl_INFINITE Constant

nxllSync.nxcl_INFINITE Constant
nxllSync Constants Send Feedback
Syntax
Delphi
nxcl_INFINITE = High(Cardinal);
File

nxllSync

Description

This is constant nxllSync.nxcl_INFINITE.

Group

Constants

Links
nxllSync, Constants


nxllSync.nxcl_InitialEventCount Constant

nxllSync.nxcl_InitialEventCount Constant
nxllSync Constants Send Feedback
Syntax
Delphi
nxcl_InitialEventCount = 250;
File

nxllSync

Description

Initial # of events in event pool.

Group

Constants

Links
nxllSync, Constants


nxllSync.nxcl_RetainEventCount Constant

nxllSync.nxcl_RetainEventCount Constant
nxllSync Constants Send Feedback
Syntax
Delphi
nxcl_RetainEventCount = 2500;
File

nxllSync

Description

of events to retain when flush event pool.

Group

Constants

Links
nxllSync, Constants


nxllSync.rsCallingWaitForSingleObject Constant

nxllSync.rsCallingWaitForSingleObject Constant
nxllSync Constants Send Feedback
Syntax
Delphi
rsCallingWaitForSingleObject = 'calling WaitForSingleObject';
File

nxllSync

Description

This is constant nxllSync.rsCallingWaitForSingleObject.

Group

Constants

Links
nxllSync, Constants


nxllSyncPortal Namespace

nxllSyncPortal Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllSyncPortal.

Classes
Name | Description
TnxInternalReadWritePortal | This is class nxllSyncPortal.TnxInternalReadWritePortal.
TnxThreadStates | This is class nxllSyncPortal.TnxThreadStates.
Constants
Name | Description
nxc_RequestingWrite |
nxc_ThreadHashCount | This is constant nxllSyncPortal.nxc_ThreadHashCount.
Yes | This is constant nxllSyncPortal.Yes.
Structs, Records, Enums
Name | Description
TnxThreadState | This is record nxllSyncPortal.TnxThreadState.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxThreadState | This is type nxllSyncPortal.PnxThreadState.
TnxThreadHashIndex | This is type nxllSyncPortal.TnxThreadHashIndex.
TnxThreadStateTable | This is type nxllSyncPortal.TnxThreadStateTable.
Variables
Name | Description
_ThreadStatePool | This is variable nxllSyncPortal._ThreadStatePool.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllSyncPortal Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInternalReadWritePortal | This is class nxllSyncPortal.TnxInternalReadWritePortal.
TnxThreadStates | This is class nxllSyncPortal.TnxThreadStates.
Namespace

nxllSyncPortal Namespace

Links
Classes, nxllSyncPortal Namespace, Legend


TnxInternalReadWritePortal Class

TnxInternalReadWritePortal Class
TnxInternalReadWritePortal Fields TnxInternalReadWritePortal Methods TnxInternalReadWritePortal Members nxllSyncPortal Classes Send Feedback
Class Hierarchy
nxllSyncPortal_TnxInternalReadWritePortalnxllSyncPortal_TnxInternalReadWritePortal
Syntax
Delphi
TnxInternalReadWritePortal = class(TnxObject);
File

nxllSyncPortal

Description

This is class nxllSyncPortal.TnxInternalReadWritePortal.

Group

Classes

Links
TnxInternalReadWritePortal Fields, TnxInternalReadWritePortal Methods, TnxInternalReadWritePortal Members, nxllSyncPortal, Classes


TnxInternalReadWritePortal Members

TnxInternalReadWritePortal Members
TnxInternalReadWritePortal Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxInternalReadWritePortal.

Class

TnxInternalReadWritePortal Class

Protected Fields
Name | Description
rwpGeneration | This is rwpGeneration, a member of class TnxInternalReadWritePortal.
rwpPortal | private
rwpReadEvent | This is rwpReadEvent, a member of class TnxInternalReadWritePortal.
rwpThreadStates | This is rwpThreadStates, a member of class TnxInternalReadWritePortal.
rwpWriteEvent | This is rwpWriteEvent, a member of class TnxInternalReadWritePortal.
rwpWriterCount | This is rwpWriterCount, a member of class TnxInternalReadWritePortal.
rwpWriterID | This is rwpWriterID, a member of class TnxInternalReadWritePortal.
Public Methods
Name | Description
BeginRead | TnxInternalReadWritePortal
BeginWrite |
Create |
CreateAndRead |
CreateAndWrite |
Destroy |
EndRead |
EndWrite |
FreeInstance |
NewInstance | TnxObject
Links
TnxInternalReadWritePortal Class, Legend, Protected Fields, Public Methods


TnxInternalReadWritePortal.Create Constructor

TnxInternalReadWritePortal.Create Constructor
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxInternalReadWritePortal Class

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Class


TnxInternalReadWritePortal.Destroy Destructor

TnxInternalReadWritePortal.Destroy Destructor
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInternalReadWritePortal Class

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Class


TnxInternalReadWritePortal Fields

TnxInternalReadWritePortal Fields
TnxInternalReadWritePortal Class Legend Protected Fields Send Feedback

The fields of the TnxInternalReadWritePortal class are listed here.

Class

TnxInternalReadWritePortal Class

Protected Fields
Name | Description
rwpGeneration | This is rwpGeneration, a member of class TnxInternalReadWritePortal.
rwpPortal | private
rwpReadEvent | This is rwpReadEvent, a member of class TnxInternalReadWritePortal.
rwpThreadStates | This is rwpThreadStates, a member of class TnxInternalReadWritePortal.
rwpWriteEvent | This is rwpWriteEvent, a member of class TnxInternalReadWritePortal.
rwpWriterCount | This is rwpWriterCount, a member of class TnxInternalReadWritePortal.
rwpWriterID | This is rwpWriterID, a member of class TnxInternalReadWritePortal.
Links
TnxInternalReadWritePortal Class, Legend, Protected Fields


TnxInternalReadWritePortal.rwpGeneration Field

TnxInternalReadWritePortal.rwpGeneration Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpGeneration: TnxWord32;
Description

This is rwpGeneration, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpPortal Field

TnxInternalReadWritePortal.rwpPortal Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpPortal: TnxInt32;
Description

private

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpReadEvent Field

TnxInternalReadWritePortal.rwpReadEvent Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpReadEvent: THandle;
Description

This is rwpReadEvent, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpThreadStates Field

TnxInternalReadWritePortal.rwpThreadStates Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpThreadStates: TnxThreadStates;
Description

This is rwpThreadStates, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpWriteEvent Field

TnxInternalReadWritePortal.rwpWriteEvent Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpWriteEvent: THandle;
Description

This is rwpWriteEvent, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpWriterCount Field

TnxInternalReadWritePortal.rwpWriterCount Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpWriterCount: TnxWord32;
Description

This is rwpWriterCount, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal.rwpWriterID Field

TnxInternalReadWritePortal.rwpWriterID Field
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Fields Send Feedback
Syntax
Delphi
rwpWriterID: TnxWord32;
Description

This is rwpWriterID, a member of class TnxInternalReadWritePortal.

Group

TnxInternalReadWritePortal Fields

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Fields


TnxInternalReadWritePortal Methods

TnxInternalReadWritePortal Methods
TnxInternalReadWritePortal Class Legend Public Methods Send Feedback

The methods of the TnxInternalReadWritePortal class are listed here.

Class

TnxInternalReadWritePortal Class

Public Methods
Name | Description
BeginRead | TnxInternalReadWritePortal
BeginWrite |
CreateAndRead |
CreateAndWrite |
EndRead |
EndWrite |
Links
TnxInternalReadWritePortal Class, Legend, Public Methods


TnxInternalReadWritePortal.BeginRead Method

TnxInternalReadWritePortal.BeginRead Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure BeginRead;
Description

TnxInternalReadWritePortal

Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxInternalReadWritePortal.BeginWrite Method

TnxInternalReadWritePortal.BeginWrite Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
function BeginWrite: Boolean;
Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxInternalReadWritePortal.CreateAndRead Method

TnxInternalReadWritePortal.CreateAndRead Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
class procedure CreateAndRead(var aPortal: TnxInternalReadWritePortal);
Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxInternalReadWritePortal.CreateAndWrite Method

TnxInternalReadWritePortal.CreateAndWrite Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
class procedure CreateAndWrite(var aPortal: TnxInternalReadWritePortal);
Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxInternalReadWritePortal.EndRead Method

TnxInternalReadWritePortal.EndRead Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure EndRead;
Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxInternalReadWritePortal.EndWrite Method

TnxInternalReadWritePortal.EndWrite Method
TnxInternalReadWritePortal Class TnxInternalReadWritePortal Members nxllSyncPortal Namespace TnxInternalReadWritePortal Methods Send Feedback
Syntax
Delphi
procedure EndWrite;
Group

TnxInternalReadWritePortal Methods

Links
TnxInternalReadWritePortal Class, TnxInternalReadWritePortal Members, nxllSyncPortal Namespace, TnxInternalReadWritePortal Methods


TnxThreadStates Class

TnxThreadStates Class
TnxThreadStates Fields TnxThreadStates Methods TnxThreadStates Members nxllSyncPortal Classes Send Feedback
Class Hierarchy
nxllSyncPortal_TnxThreadStatesnxllSyncPortal_TnxThreadStates
Syntax
Delphi
TnxThreadStates = class(TnxObject);
File

nxllSyncPortal

Description

This is class nxllSyncPortal.TnxThreadStates.

Group

Classes

Links
TnxThreadStates Fields, TnxThreadStates Methods, TnxThreadStates Members, nxllSyncPortal, Classes


TnxThreadStates Members

TnxThreadStates Members
TnxThreadStates Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxThreadStates.

Class

TnxThreadStates Class

Protected Fields
Name | Description
tlcHashTable | private
Protected Methods
Name | Description
tlcHashIndex |
Public Methods
Name | Description
Acquire | TnxThreadStates
Destroy |
FreeInstance |
NewInstance | TnxObject
Release |
Links
TnxThreadStates Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxThreadStates.Destroy Destructor

TnxThreadStates.Destroy Destructor
TnxThreadStates Class TnxThreadStates Members nxllSyncPortal Namespace TnxThreadStates Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxThreadStates Class

Links
TnxThreadStates Class, TnxThreadStates Members, nxllSyncPortal Namespace, TnxThreadStates Class


TnxThreadStates Fields

TnxThreadStates Fields
TnxThreadStates Class Legend Protected Fields Send Feedback

The fields of the TnxThreadStates class are listed here.

Class

TnxThreadStates Class

Protected Fields
Name | Description
tlcHashTable | private
Links
TnxThreadStates Class, Legend, Protected Fields


TnxThreadStates.tlcHashTable Field

TnxThreadStates.tlcHashTable Field
TnxThreadStates Class TnxThreadStates Members nxllSyncPortal Namespace TnxThreadStates Fields Send Feedback
Syntax
Delphi
tlcHashTable: TnxThreadStateTable;
Description

private

Group

TnxThreadStates Fields

Links
TnxThreadStates Class, TnxThreadStates Members, nxllSyncPortal Namespace, TnxThreadStates Fields


TnxThreadStates Methods

TnxThreadStates Methods
TnxThreadStates Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxThreadStates class are listed here.

Class

TnxThreadStates Class

Protected Methods
Name | Description
tlcHashIndex |
Public Methods
Name | Description
Acquire | TnxThreadStates
Release |
Links
TnxThreadStates Class, Legend, Protected Methods, Public Methods


TnxThreadStates.Acquire Method

TnxThreadStates.Acquire Method
TnxThreadStates Class TnxThreadStates Members nxllSyncPortal Namespace TnxThreadStates Methods Send Feedback
Syntax
Delphi
procedure Acquire(aThreadID: TnxWord32; out aThreadState: PnxThreadState);
Description

TnxThreadStates

Group

TnxThreadStates Methods

Links
TnxThreadStates Class, TnxThreadStates Members, nxllSyncPortal Namespace, TnxThreadStates Methods


TnxThreadStates.Release Method

TnxThreadStates.Release Method
TnxThreadStates Class TnxThreadStates Members nxllSyncPortal Namespace TnxThreadStates Methods Send Feedback
Syntax
Delphi
procedure Release(aThreadState: PnxThreadState);
Group

TnxThreadStates Methods

Links
TnxThreadStates Class, TnxThreadStates Members, nxllSyncPortal Namespace, TnxThreadStates Methods


TnxThreadStates.tlcHashIndex Method

TnxThreadStates.tlcHashIndex Method
TnxThreadStates Class TnxThreadStates Members nxllSyncPortal Namespace TnxThreadStates Methods Send Feedback
Syntax
Delphi
function tlcHashIndex(aThreadID: TnxWord32): TnxThreadHashIndex;
Group

TnxThreadStates Methods

Links
TnxThreadStates Class, TnxThreadStates Members, nxllSyncPortal Namespace, TnxThreadStates Methods


Structs, Records, Enums

Structs, Records, Enums
nxllSyncPortal Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllSyncPortal Namespace

Records
Name | Description
TnxThreadState | This is record nxllSyncPortal.TnxThreadState.
Links
nxllSyncPortal Namespace, Legend, Records


nxllSyncPortal.TnxThreadState Record

nxllSyncPortal.TnxThreadState Record
nxllSyncPortal Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxThreadState = record
  tsNext: PnxThreadState;
  tsInUse: TnxInt32;
  tsCount: TnxWord32;
  tsID: TnxWord32;
end;
File

nxllSyncPortal

Description

This is record nxllSyncPortal.TnxThreadState.

Group

Structs, Records, Enums

Links
nxllSyncPortal, Structs, Records, Enums


Types

Types
nxllSyncPortal Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllSyncPortal Namespace

Types
Name | Description
PnxThreadState | This is type nxllSyncPortal.PnxThreadState.
TnxThreadHashIndex | This is type nxllSyncPortal.TnxThreadHashIndex.
TnxThreadStateTable | This is type nxllSyncPortal.TnxThreadStateTable.
Links
nxllSyncPortal Namespace, Types


nxllSyncPortal.PnxThreadState Type

nxllSyncPortal.PnxThreadState Type
nxllSyncPortal Types Send Feedback
Syntax
Delphi
PnxThreadState = ^TnxThreadState;
File

nxllSyncPortal

Description

This is type nxllSyncPortal.PnxThreadState.

Group

Types

Links
nxllSyncPortal, Types


nxllSyncPortal.TnxThreadHashIndex Type

nxllSyncPortal.TnxThreadHashIndex Type
nxllSyncPortal Types Send Feedback
Syntax
Delphi
TnxThreadHashIndex = 0..nxc_ThreadHashCount;
File

nxllSyncPortal

Description

This is type nxllSyncPortal.TnxThreadHashIndex.

Group

Types

Links
nxllSyncPortal, Types


nxllSyncPortal.TnxThreadStateTable Type

nxllSyncPortal.TnxThreadStateTable Type
nxllSyncPortal Types Send Feedback
Syntax
Delphi
TnxThreadStateTable = array[TnxThreadHashIndex] of PnxThreadState;
File

nxllSyncPortal

Description

This is type nxllSyncPortal.TnxThreadStateTable.

Group

Types

Links
nxllSyncPortal, Types


Variables

Variables
nxllSyncPortal Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllSyncPortal Namespace

Variables
Name | Description
_ThreadStatePool | This is variable nxllSyncPortal._ThreadStatePool.
Links
nxllSyncPortal Namespace, Variables


nxllSyncPortal._ThreadStatePool Variable

nxllSyncPortal._ThreadStatePool Variable
nxllSyncPortal Variables Send Feedback
Syntax
Delphi
_ThreadStatePool: TnxMemoryPool;
File

nxllSyncPortal

Description

This is variable nxllSyncPortal._ThreadStatePool.

Group

Variables

Links
nxllSyncPortal, Variables


Constants

Constants
Constants nxllSyncPortal Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_RequestingWrite |
nxc_ThreadHashCount | This is constant nxllSyncPortal.nxc_ThreadHashCount.
Yes | This is constant nxllSyncPortal.Yes.
Namespace

nxllSyncPortal Namespace

Links
Constants, nxllSyncPortal Namespace


nxllSyncPortal.nxc_RequestingWrite Constant

nxllSyncPortal.nxc_RequestingWrite Constant
nxllSyncPortal Constants Send Feedback
Syntax
Delphi
nxc_RequestingWrite = $FFFF;
File

nxllSyncPortal

Group

Constants

Links
nxllSyncPortal, Constants


nxllSyncPortal.nxc_ThreadHashCount Constant

nxllSyncPortal.nxc_ThreadHashCount Constant
nxllSyncPortal Constants Send Feedback
Syntax
Delphi
nxc_ThreadHashCount = 15;
File

nxllSyncPortal

Description

This is constant nxllSyncPortal.nxc_ThreadHashCount.

Group

Constants

Links
nxllSyncPortal, Constants


nxllSyncPortal.Yes Constant

nxllSyncPortal.Yes Constant
nxllSyncPortal Constants Send Feedback
Syntax
Delphi
Yes: TnxInt32 = -1;
File

nxllSyncPortal

Description

This is constant nxllSyncPortal.Yes.

Group

Constants

Links
nxllSyncPortal, Constants


nxllThread Namespace

nxllThread Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllThread.

Classes
Name | Description
EnxInitThread | This is class nxllThread.EnxInitThread.
EnxInternalInitThread | This is class nxllThread.EnxInternalInitThread.
EnxInternalWaitThread | This is class nxllThread.EnxInternalWaitThread.
EnxMessageThread | This is class nxllThread.EnxMessageThread.
EnxThread | This is class nxllThread.EnxThread.
EnxWaitThread | This is class nxllThread.EnxWaitThread.
EnxWorkerThread | TnxWorkerThread
TnxInitThread | This is class nxllThread.TnxInitThread.
TnxInternalInitThread | This is class nxllThread.TnxInternalInitThread.
TnxInternalWaitThread | This is class nxllThread.TnxInternalWaitThread.
TnxMessageThread | This is class nxllThread.TnxMessageThread.
TnxSimpleTimerThread | This is class nxllThread.TnxSimpleTimerThread.
TnxThread | This is class nxllThread.TnxThread.
TnxTimerThread | This is class nxllThread.TnxTimerThread.
TnxWaitThread | This is class nxllThread.TnxWaitThread.
TnxWorkerThread | This is class nxllThread.TnxWorkerThread.
Constants
Name | Description
kernel32 | This is constant nxllThread.kernel32.
rsTnxInternalInitThreadCreateCreateSemaphore | This is constant nxllThread.rsTnxInternalInitThreadCreateCreateSemaphore.
ThreadIsIoPending | This is constant nxllThread.ThreadIsIoPending.
ThreadPriorities | TnxThreadPriority
WT_EXECUTEDEFAULT | This is constant nxllThread.WT_EXECUTEDEFAULT.
WT_EXECUTEINIOTHREAD | This is constant nxllThread.WT_EXECUTEINIOTHREAD.
WT_EXECUTEINPERSISTENTIOTHREAD | This is constant nxllThread.WT_EXECUTEINPERSISTENTIOTHREAD.
WT_EXECUTEINPERSISTENTTHREAD | This is constant nxllThread.WT_EXECUTEINPERSISTENTTHREAD.
WT_EXECUTEINTIMERTHREAD | This is constant nxllThread.WT_EXECUTEINTIMERTHREAD.
WT_EXECUTEINUITHREAD | This is constant nxllThread.WT_EXECUTEINUITHREAD.
WT_EXECUTEINWAITTHREAD | This is constant nxllThread.WT_EXECUTEINWAITTHREAD.
WT_EXECUTELONGFUNCTION | This is constant nxllThread.WT_EXECUTELONGFUNCTION.
WT_EXECUTEONLYONCE | This is constant nxllThread.WT_EXECUTEONLYONCE.
WT_TRANSFER_IMPERSONATION | This is constant nxllThread.WT_TRANSFER_IMPERSONATION.
Functions
Name | Description
GetThreadPriorities |
IdentToThreadPriority |
nxProcessThreaded | nxProcessThreaded
nxSynchronize | nxSynchronize
nxThreadSetName | nxThreadSetName
PostQueuedCompletionStatus | This is function nxllThread.PostQueuedCompletionStatus.
ThreadPriorityToIdent |
ThreadPriorityToString |
Structs, Records, Enums
Name | Description
TRaiseFrame | This is record nxllThread.TRaiseFrame.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EnxThreadClass | This is type nxllThread.EnxThreadClass.
PRaiseFrame | copied from system.pas
TBindIoCompletionCallback | This is type nxllThread.TBindIoCompletionCallback.
TCancelTimerQueueTimer | This is type nxllThread.TCancelTimerQueueTimer.
TChangeTimerQueueTimer | This is type nxllThread.TChangeTimerQueueTimer.
TCreateTimerQueue | This is type nxllThread.TCreateTimerQueue.
TCreateTimerQueueTimer | This is type nxllThread.TCreateTimerQueueTimer.
TDeleteTimerQueue | This is type nxllThread.TDeleteTimerQueue.
TDeleteTimerQueueEx | This is type nxllThread.TDeleteTimerQueueEx.
TDeleteTimerQueueTimer | This is type nxllThread.TDeleteTimerQueueTimer.
TGetThreadIOPendingFlag | This is type nxllThread.TGetThreadIOPendingFlag.
TNtQueryInformationThread | This is type nxllThread.TNtQueryInformationThread.
TnxThreadProcessEvent | This is type nxllThread.TnxThreadProcessEvent.
TOverlappedCompletionRoutine | This is type nxllThread.TOverlappedCompletionRoutine.
TQueueUserWorkItem | This is type nxllThread.TQueueUserWorkItem.
TSetTimerQueueTimer | This is type nxllThread.TSetTimerQueueTimer.
TThreadStartRoutine | This is type nxllThread.TThreadStartRoutine.
TWaitOrTimerCallback | This is type nxllThread.TWaitOrTimerCallback.
Variables
Name | Description
_BindIoCompletionCallback | This is variable nxllThread._BindIoCompletionCallback.
_CancelTimerQueueTimer | This is variable nxllThread._CancelTimerQueueTimer.
_ChangeTimerQueueTimer | This is variable nxllThread._ChangeTimerQueueTimer.
_CreateTimerQueue | This is variable nxllThread._CreateTimerQueue.
_CreateTimerQueueTimer | This is variable nxllThread._CreateTimerQueueTimer.
_DeleteTimerQueue | This is variable nxllThread._DeleteTimerQueue.
_DeleteTimerQueueEx | This is variable nxllThread._DeleteTimerQueueEx.
_DeleteTimerQueueTimer | This is variable nxllThread._DeleteTimerQueueTimer.
_GetThreadIOPendingFlag | This is variable nxllThread._GetThreadIOPendingFlag.
_NtQueryInformationThread | This is variable nxllThread._NtQueryInformationThread.
_QueueUserWorkItem | This is variable nxllThread._QueueUserWorkItem.
_SetTimerQueueTimer | This is variable nxllThread._SetTimerQueueTimer.
nxPatchPPLPresent | This is variable nxllThread.nxPatchPPLPresent.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllThread Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxInitThread | This is class nxllThread.EnxInitThread.
EnxInternalInitThread | This is class nxllThread.EnxInternalInitThread.
EnxInternalWaitThread | This is class nxllThread.EnxInternalWaitThread.
EnxMessageThread | This is class nxllThread.EnxMessageThread.
EnxThread | This is class nxllThread.EnxThread.
EnxWaitThread | This is class nxllThread.EnxWaitThread.
EnxWorkerThread | TnxWorkerThread
TnxInitThread | This is class nxllThread.TnxInitThread.
TnxInternalInitThread | This is class nxllThread.TnxInternalInitThread.
TnxInternalWaitThread | This is class nxllThread.TnxInternalWaitThread.
TnxMessageThread | This is class nxllThread.TnxMessageThread.
TnxSimpleTimerThread | This is class nxllThread.TnxSimpleTimerThread.
TnxThread | This is class nxllThread.TnxThread.
TnxTimerThread | This is class nxllThread.TnxTimerThread.
TnxWaitThread | This is class nxllThread.TnxWaitThread.
TnxWorkerThread | This is class nxllThread.TnxWorkerThread.
Namespace

nxllThread Namespace

Links
Classes, nxllThread Namespace, Legend


EnxInitThread Class

EnxInitThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxInitThreadnxllThread_EnxInitThreadnxllThread_EnxInitThreadnxllThread_EnxInitThreadnxllThread_EnxInitThreadnxllThread_EnxInitThreadnxllThread_EnxInitThread
Syntax
Delphi
EnxInitThread = class(EnxInternalWaitThread);
File

nxllThread

Description

This is class nxllThread.EnxInitThread.

Group

Classes

Links
nxllThread, Classes


EnxInternalInitThread Class

EnxInternalInitThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxInternalInitThreadnxllThread_EnxInternalInitThreadnxllThread_EnxInternalInitThreadnxllThread_EnxInternalInitThreadnxllThread_EnxInternalInitThread
Syntax
Delphi
EnxInternalInitThread = class(EnxThread);
File

nxllThread

Description

This is class nxllThread.EnxInternalInitThread.

Group

Classes

Links
nxllThread, Classes


EnxInternalWaitThread Class

EnxInternalWaitThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxInternalWaitThreadnxllThread_EnxInternalWaitThreadnxllThread_EnxInternalWaitThreadnxllThread_EnxInternalWaitThreadnxllThread_EnxInternalWaitThreadnxllThread_EnxInternalWaitThread
Syntax
Delphi
EnxInternalWaitThread = class(EnxInternalInitThread);
File

nxllThread

Description

This is class nxllThread.EnxInternalWaitThread.

Group

Classes

Links
nxllThread, Classes


EnxMessageThread Class

EnxMessageThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThreadnxllThread_EnxMessageThread
Syntax
Delphi
EnxMessageThread = class(EnxInitThread);
File

nxllThread

Description

This is class nxllThread.EnxMessageThread.

Group

Classes

Links
nxllThread, Classes


EnxThread Class

EnxThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxThreadnxllThread_EnxThreadnxllThread_EnxThreadnxllThread_EnxThread
Syntax
Delphi
EnxThread = class(EnxBaseException);
File

nxllThread

Description

This is class nxllThread.EnxThread.

Group

Classes

Links
nxllThread, Classes


EnxWaitThread Class

EnxWaitThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxWaitThreadnxllThread_EnxWaitThreadnxllThread_EnxWaitThreadnxllThread_EnxWaitThreadnxllThread_EnxWaitThreadnxllThread_EnxWaitThreadnxllThread_EnxWaitThread
Syntax
Delphi
EnxWaitThread = class(EnxInternalWaitThread);
File

nxllThread

Description

This is class nxllThread.EnxWaitThread.

Group

Classes

Links
nxllThread, Classes


EnxWorkerThread Class

EnxWorkerThread Class
nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_EnxWorkerThreadnxllThread_EnxWorkerThreadnxllThread_EnxWorkerThreadnxllThread_EnxWorkerThreadnxllThread_EnxWorkerThread
Syntax
Delphi
EnxWorkerThread = class(EnxThread);
File

nxllThread

Description

TnxWorkerThread

Group

Classes

Links
nxllThread, Classes


TnxInitThread Class

TnxInitThread Class
TnxInitThread Methods TnxInitThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxInitThreadnxllThread_TnxInitThreadnxllThread_TnxInitThreadnxllThread_TnxInitThread
Syntax
Delphi
TnxInitThread = class(TnxInternalWaitThread);
File

nxllThread

Description

This is class nxllThread.TnxInitThread.

Group

Classes

Links
TnxInitThread Methods, TnxInitThread Members, nxllThread, Classes


TnxInitThread Members

TnxInitThread Members
TnxInitThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxInitThread.

Class

TnxInitThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
Create |
Create |
Create | This is Create, a member of class TnxThread.
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxInitThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxInitThread Methods

TnxInitThread Methods
TnxInitThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInitThread class are listed here.

Class

TnxInitThread Class

Protected Methods
Name | Description
nxtExceptionClass |
Public Methods
Name | Description
AfterConstruction | TnxInitThread
Links
TnxInitThread Class, Legend, Protected Methods, Public Methods


TnxInitThread.AfterConstruction Method

TnxInitThread.AfterConstruction Method
TnxInitThread Class TnxInitThread Members nxllThread Namespace TnxInitThread Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxInitThread

Group

TnxInitThread Methods

Links
TnxInitThread Class, TnxInitThread Members, nxllThread Namespace, TnxInitThread Methods


TnxInitThread.nxtExceptionClass Method

TnxInitThread.nxtExceptionClass Method
TnxInitThread Class TnxInitThread Members nxllThread Namespace TnxInitThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxInitThread Methods

Links
TnxInitThread Class, TnxInitThread Members, nxllThread Namespace, TnxInitThread Methods


TnxInternalInitThread Class

TnxInternalInitThread Class
TnxInternalInitThread Fields TnxInternalInitThread Methods TnxInternalInitThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxInternalInitThreadnxllThread_TnxInternalInitThread
Syntax
Delphi
TnxInternalInitThread = class(TnxThread);
File

nxllThread

Description

This is class nxllThread.TnxInternalInitThread.

Group

Classes

Links
TnxInternalInitThread Fields, TnxInternalInitThread Methods, TnxInternalInitThread Members, nxllThread, Classes


TnxInternalInitThread Members

TnxInternalInitThread Members
TnxInternalInitThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInternalInitThread.

Class

TnxInternalInitThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
WaitForInit |
Public Methods
Name | Description
AfterConstruction | TnxInternalInitThread0
Create |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxInternalInitThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInternalInitThread.Create Constructor

TnxInternalInitThread.Create Constructor
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority);
Class

TnxInternalInitThread Class

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Class


TnxInternalInitThread Fields

TnxInternalInitThread Fields
TnxInternalInitThread Class Legend Protected Fields Send Feedback

The fields of the TnxInternalInitThread class are listed here.

Class

TnxInternalInitThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
Links
TnxInternalInitThread Class, Legend, Protected Fields


TnxInternalInitThread.itInitException Field

TnxInternalInitThread.itInitException Field
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Fields Send Feedback
Syntax
Delphi
itInitException: TObject;
Description

This is itInitException, a member of class TnxInternalInitThread.

Group

TnxInternalInitThread Fields

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Fields


TnxInternalInitThread.itInitSemaphore Field

TnxInternalInitThread.itInitSemaphore Field
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Fields Send Feedback
Syntax
Delphi
itInitSemaphore: THandle;
Description

private

Group

TnxInternalInitThread Fields

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Fields


TnxInternalInitThread Methods

TnxInternalInitThread Methods
TnxInternalInitThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInternalInitThread class are listed here.

Class

TnxInternalInitThread Class

Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
DoExecute |
InnerExecute |
nxtExceptionClass |
WaitForInit |
Public Methods
Name | Description
AfterConstruction | TnxInternalInitThread0
Links
TnxInternalInitThread Class, Legend, Protected Methods, Public Methods


TnxInternalInitThread.AfterConstruction Method

TnxInternalInitThread.AfterConstruction Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxInternalInitThread0

Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.DoAfterExecute Method

TnxInternalInitThread.DoAfterExecute Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; virtual;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.DoBeforeExecute Method

TnxInternalInitThread.DoBeforeExecute Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; virtual;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.DoExecute Method

TnxInternalInitThread.DoExecute Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.InnerExecute Method

TnxInternalInitThread.InnerExecute Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; virtual;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.nxtExceptionClass Method

TnxInternalInitThread.nxtExceptionClass Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalInitThread.WaitForInit Method

TnxInternalInitThread.WaitForInit Method
TnxInternalInitThread Class TnxInternalInitThread Members nxllThread Namespace TnxInternalInitThread Methods Send Feedback
Syntax
Delphi
procedure WaitForInit;
Group

TnxInternalInitThread Methods

Links
TnxInternalInitThread Class, TnxInternalInitThread Members, nxllThread Namespace, TnxInternalInitThread Methods


TnxInternalWaitThread Class

TnxInternalWaitThread Class
TnxInternalWaitThread Fields TnxInternalWaitThread Methods TnxInternalWaitThread Properties TnxInternalWaitThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxInternalWaitThreadnxllThread_TnxInternalWaitThreadnxllThread_TnxInternalWaitThread
Syntax
Delphi
TnxInternalWaitThread = class(TnxInternalInitThread);
File

nxllThread

Description

This is class nxllThread.TnxInternalWaitThread.

Group

Classes

Links
TnxInternalWaitThread Fields, TnxInternalWaitThread Methods, TnxInternalWaitThread Properties, TnxInternalWaitThread Members, nxllThread, Classes


TnxInternalWaitThread Members

TnxInternalWaitThread Members
TnxInternalWaitThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxInternalWaitThread.

Class

TnxInternalWaitThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxInternalWaitThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxInternalWaitThread.Create Constructor

TnxInternalWaitThread.Create Constructor
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority);
Class

TnxInternalWaitThread Class

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Class


TnxInternalWaitThread.Destroy Destructor

TnxInternalWaitThread.Destroy Destructor
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInternalWaitThread Class

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Class


TnxInternalWaitThread Fields

TnxInternalWaitThread Fields
TnxInternalWaitThread Class Legend Protected Fields Send Feedback

The fields of the TnxInternalWaitThread class are listed here.

Class

TnxInternalWaitThread Class

Protected Fields
Name | Description
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Links
TnxInternalWaitThread Class, Legend, Protected Fields


TnxInternalWaitThread.wtWaiting Field

TnxInternalWaitThread.wtWaiting Field
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Fields Send Feedback
Syntax
Delphi
wtWaiting: Boolean;
Description

private

Group

TnxInternalWaitThread Fields

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Fields


TnxInternalWaitThread.wtWaitSemaphore Field

TnxInternalWaitThread.wtWaitSemaphore Field
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Fields Send Feedback
Syntax
Delphi
wtWaitSemaphore: THandle;
Description

This is wtWaitSemaphore, a member of class TnxInternalWaitThread.

Group

TnxInternalWaitThread Fields

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Fields


TnxInternalWaitThread Methods

TnxInternalWaitThread Methods
TnxInternalWaitThread Class Legend Protected Methods Send Feedback

The methods of the TnxInternalWaitThread class are listed here.

Class

TnxInternalWaitThread Class

Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
nxtExceptionClass |
WaitForExit |
Links
TnxInternalWaitThread Class, Legend, Protected Methods


TnxInternalWaitThread.AllowExit Method

TnxInternalWaitThread.AllowExit Method
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Methods Send Feedback
Syntax
Delphi
procedure AllowExit;
Description

TnxInternalWaitThread

Group

TnxInternalWaitThread Methods

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Methods


TnxInternalWaitThread.DoAfterExecute Method

TnxInternalWaitThread.DoAfterExecute Method
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; override;
Group

TnxInternalWaitThread Methods

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Methods


TnxInternalWaitThread.nxtExceptionClass Method

TnxInternalWaitThread.nxtExceptionClass Method
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxInternalWaitThread Methods

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Methods


TnxInternalWaitThread.WaitForExit Method

TnxInternalWaitThread.WaitForExit Method
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Methods Send Feedback
Syntax
Delphi
procedure WaitForExit;
Group

TnxInternalWaitThread Methods

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Methods


TnxInternalWaitThread Properties

TnxInternalWaitThread Properties
TnxInternalWaitThread Class Legend Protected Properties Send Feedback

The properties of the TnxInternalWaitThread class are listed here.

Class

TnxInternalWaitThread Class

Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Links
TnxInternalWaitThread Class, Legend, Protected Properties


TnxInternalWaitThread.Waiting Property

TnxInternalWaitThread.Waiting Property
TnxInternalWaitThread Class TnxInternalWaitThread Members nxllThread Namespace TnxInternalWaitThread Properties Send Feedback
Syntax
Delphi
property Waiting: Boolean;
Description

This is Waiting, a member of class TnxInternalWaitThread.

Group

TnxInternalWaitThread Properties

Links
TnxInternalWaitThread Class, TnxInternalWaitThread Members, nxllThread Namespace, TnxInternalWaitThread Properties


TnxMessageThread Class

TnxMessageThread Class
TnxMessageThread Fields TnxMessageThread Methods TnxMessageThread Properties TnxMessageThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxMessageThreadnxllThread_TnxMessageThreadnxllThread_TnxMessageThreadnxllThread_TnxMessageThreadnxllThread_TnxMessageThread
Syntax
Delphi
TnxMessageThread = class(TnxInitThread);
File

nxllThread

Description

This is class nxllThread.TnxMessageThread.

Group

Classes

Links
TnxMessageThread Fields, TnxMessageThread Methods, TnxMessageThread Properties, TnxMessageThread Members, nxllThread, Classes


TnxMessageThread Members

TnxMessageThread Members
TnxMessageThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMessageThread.

Class

TnxMessageThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
mtHandle | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoAfterMessage |
DoBeforeExecute |
DoBeforeMessage |
DoExecute |
DoHandleException |
DoIdle |
DoTerminate |
Execute |
HandleMessage |
Idle |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
ProcessMessage |
SetName |
WaitForExit |
WaitForInit |
WndProc |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create |
DefaultHandler | TnxMessageThread
Destroy |
FreeInstance |
NewInstance |
PerformPost |
PerformSend |
PostQuitMessage |
PostThreadMessage |
WaitForEx |
WaitForQuit |
Public Properties
Name | Description
Handle | This is Handle, a member of class TnxMessageThread.
Links
TnxMessageThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties


TnxMessageThread.Create Constructor

TnxMessageThread.Create Constructor
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Class Send Feedback
Syntax
Delphi
constructor Create(aThreadPriority: TThreadPriority);
Class

TnxMessageThread Class

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Class


TnxMessageThread.Destroy Destructor

TnxMessageThread.Destroy Destructor
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMessageThread Class

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Class


TnxMessageThread Fields

TnxMessageThread Fields
TnxMessageThread Class Legend Protected Fields Send Feedback

The fields of the TnxMessageThread class are listed here.

Class

TnxMessageThread Class

Protected Fields
Name | Description
mtHandle | private
Links
TnxMessageThread Class, Legend, Protected Fields


TnxMessageThread.mtHandle Field

TnxMessageThread.mtHandle Field
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Fields Send Feedback
Syntax
Delphi
mtHandle: THandle;
Description

private

Group

TnxMessageThread Fields

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Fields


TnxMessageThread Methods

TnxMessageThread Methods
TnxMessageThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMessageThread class are listed here.

Class

TnxMessageThread Class

Protected Methods
Name | Description
DoAfterMessage |
DoBeforeExecute |
DoBeforeMessage |
DoExecute |
DoIdle |
HandleMessage |
Idle |
InnerExecute |
nxtExceptionClass |
ProcessMessage |
WndProc |
Public Methods
Name | Description
DefaultHandler | TnxMessageThread
PerformPost |
PerformSend |
PostQuitMessage |
PostThreadMessage |
WaitForQuit |
Links
TnxMessageThread Class, Legend, Protected Methods, Public Methods


TnxMessageThread.DefaultHandler Method

TnxMessageThread.DefaultHandler Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DefaultHandler(var Message); override;
Description

TnxMessageThread

Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.DoAfterMessage Method

TnxMessageThread.DoAfterMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DoAfterMessage(const Msg: TMsg; const RetValue: Integer); virtual;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.DoBeforeExecute Method

TnxMessageThread.DoBeforeExecute Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.DoBeforeMessage Method

TnxMessageThread.DoBeforeMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DoBeforeMessage(var Msg: TMsg; var Handled: Boolean); virtual;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.DoExecute Method

TnxMessageThread.DoExecute Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.DoIdle Method

TnxMessageThread.DoIdle Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure DoIdle(const Msg: TMsg; var Done: Boolean); virtual;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.HandleMessage Method

TnxMessageThread.HandleMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure HandleMessage;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.Idle Method

TnxMessageThread.Idle Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure Idle(const Msg: TMsg);
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.InnerExecute Method

TnxMessageThread.InnerExecute Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.nxtExceptionClass Method

TnxMessageThread.nxtExceptionClass Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.PerformPost Method

TnxMessageThread.PerformPost Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure PerformPost(Msg: Cardinal; wParam: WPARAM; lParam: LPARAM);
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.PerformSend Method

TnxMessageThread.PerformSend Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
function PerformSend(Msg: Cardinal; wParam: WPARAM; lParam: LPARAM): LRESULT;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.PostQuitMessage Method

TnxMessageThread.PostQuitMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure PostQuitMessage;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.PostThreadMessage Method

TnxMessageThread.PostThreadMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure PostThreadMessage(Msg: UINT; wParam: WPARAM; lParam: LPARAM);
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.ProcessMessage Method

TnxMessageThread.ProcessMessage Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
function ProcessMessage(var Msg: TMsg): Boolean;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.WaitForQuit Method

TnxMessageThread.WaitForQuit Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure WaitForQuit;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread.WndProc Method

TnxMessageThread.WndProc Method
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Methods Send Feedback
Syntax
Delphi
procedure WndProc(var Message: TMessage); virtual;
Group

TnxMessageThread Methods

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Methods


TnxMessageThread Properties

TnxMessageThread Properties
TnxMessageThread Class Legend Public Properties Send Feedback

The properties of the TnxMessageThread class are listed here.

Class

TnxMessageThread Class

Public Properties
Name | Description
Handle | This is Handle, a member of class TnxMessageThread.
Links
TnxMessageThread Class, Legend, Public Properties


TnxMessageThread.Handle Property

TnxMessageThread.Handle Property
TnxMessageThread Class TnxMessageThread Members nxllThread Namespace TnxMessageThread Properties Send Feedback
Syntax
Delphi
property Handle: THandle;
Description

This is Handle, a member of class TnxMessageThread.

Group

TnxMessageThread Properties

Links
TnxMessageThread Class, TnxMessageThread Members, nxllThread Namespace, TnxMessageThread Properties


TnxSimpleTimerThread Class

TnxSimpleTimerThread Class
TnxSimpleTimerThread Fields TnxSimpleTimerThread Methods TnxSimpleTimerThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxSimpleTimerThreadnxllThread_TnxSimpleTimerThreadnxllThread_TnxSimpleTimerThreadnxllThread_TnxSimpleTimerThreadnxllThread_TnxSimpleTimerThreadnxllThread_TnxSimpleTimerThread
Syntax
Delphi
TnxSimpleTimerThread = class(TnxTimerThread);
File

nxllThread

Description

This is class nxllThread.TnxSimpleTimerThread.

Group

Classes

Links
TnxSimpleTimerThread Fields, TnxSimpleTimerThread Methods, TnxSimpleTimerThread Members, nxllThread, Classes


TnxSimpleTimerThread Members

TnxSimpleTimerThread Members
TnxSimpleTimerThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxSimpleTimerThread.

Class

TnxSimpleTimerThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
sttCallback | This is sttCallback, a member of class TnxSimpleTimerThread.
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
DoTimer |
Execute |
InnerExecute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxSimpleTimerThread
Destroy |
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxSimpleTimerThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxSimpleTimerThread.Create Constructor

TnxSimpleTimerThread.Create Constructor
TnxSimpleTimerThread Class TnxSimpleTimerThread Members nxllThread Namespace TnxSimpleTimerThread Class Send Feedback
Syntax
Delphi
constructor Create(const aInterval: Integer; const aThreadPriority: TThreadPriority; aCallback: TNotifyEvent);
Description

TnxSimpleTimerThread

Class

TnxSimpleTimerThread Class

Links
TnxSimpleTimerThread Class, TnxSimpleTimerThread Members, nxllThread Namespace, TnxSimpleTimerThread Class


TnxSimpleTimerThread Fields

TnxSimpleTimerThread Fields
TnxSimpleTimerThread Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleTimerThread class are listed here.

Class

TnxSimpleTimerThread Class

Protected Fields
Name | Description
sttCallback | This is sttCallback, a member of class TnxSimpleTimerThread.
Links
TnxSimpleTimerThread Class, Legend, Protected Fields


TnxSimpleTimerThread.sttCallback Field

TnxSimpleTimerThread.sttCallback Field
TnxSimpleTimerThread Class TnxSimpleTimerThread Members nxllThread Namespace TnxSimpleTimerThread Fields Send Feedback
Syntax
Delphi
sttCallback: TNotifyEvent;
Description

This is sttCallback, a member of class TnxSimpleTimerThread.

Group

TnxSimpleTimerThread Fields

Links
TnxSimpleTimerThread Class, TnxSimpleTimerThread Members, nxllThread Namespace, TnxSimpleTimerThread Fields


TnxSimpleTimerThread Methods

TnxSimpleTimerThread Methods
TnxSimpleTimerThread Class Legend Protected Methods Send Feedback

The methods of the TnxSimpleTimerThread class are listed here.

Class

TnxSimpleTimerThread Class

Protected Methods
Name | Description
DoTimer |
Links
TnxSimpleTimerThread Class, Legend, Protected Methods


TnxSimpleTimerThread.DoTimer Method

TnxSimpleTimerThread.DoTimer Method
TnxSimpleTimerThread Class TnxSimpleTimerThread Members nxllThread Namespace TnxSimpleTimerThread Methods Send Feedback
Syntax
Delphi
procedure DoTimer; override;
Group

TnxSimpleTimerThread Methods

Links
TnxSimpleTimerThread Class, TnxSimpleTimerThread Members, nxllThread Namespace, TnxSimpleTimerThread Methods


TnxThread Class

TnxThread Class
TnxThread Fields TnxThread Methods TnxThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxThread
Syntax
Delphi
TnxThread = class(TThread);
File

nxllThread

Description

This is class nxllThread.TnxThread.

Group

Classes

Links
TnxThread Fields, TnxThread Methods, TnxThread Members, nxllThread, Classes


TnxThread Members

TnxThread Members
TnxThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxThread.

Class

TnxThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
DoExecute |
DoHandleException |
DoTerminate |
Execute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | This is Create, a member of class TnxThread.
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxThread.Create Constructor

TnxThread.Create Constructor
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Class Send Feedback
Syntax
Delphi
constructor Create(aCreateSuspended: Boolean; aThreadPriority: TThreadPriority);
Description

This is Create, a member of class TnxThread.

Class

TnxThread Class

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Class


TnxThread.Destroy Destructor

TnxThread.Destroy Destructor
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxThread Class

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Class


TnxThread Fields

TnxThread Fields
TnxThread Class Legend Protected Fields Send Feedback

The fields of the TnxThread class are listed here.

Class

TnxThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Links
TnxThread Class, Legend, Protected Fields


TnxThread.nxtName Field

TnxThread.nxtName Field
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Fields Send Feedback
Syntax
Delphi
nxtName: string;
Description

private

Group

TnxThread Fields

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Fields


TnxThread.nxtStartTime Field

TnxThread.nxtStartTime Field
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Fields Send Feedback
Syntax
Delphi
nxtStartTime: TDateTime;
Description

This is nxtStartTime, a member of class TnxThread.

Group

TnxThread Fields

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Fields


TnxThread Methods

TnxThread Methods
TnxThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxThread class are listed here.

Class

TnxThread Class

Protected Methods
Name | Description
DoExecute |
DoHandleException |
DoTerminate |
Execute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxThread Class, Legend, Protected Methods, Public Methods


TnxThread.AfterConstruction Method

TnxThread.AfterConstruction Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

This is AfterConstruction, a member of class TnxThread.

Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.DoExecute Method

TnxThread.DoExecute Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; virtual;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.DoHandleException Method

TnxThread.DoHandleException Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure DoHandleException(E: Exception); virtual;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.DoTerminate Method

TnxThread.DoTerminate Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure DoTerminate; override;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.Execute Method

TnxThread.Execute Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure Execute; override;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.FreeInstance Method

TnxThread.FreeInstance Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.NewInstance Method

TnxThread.NewInstance Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.nxtCheck Method

TnxThread.nxtCheck Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure nxtCheck(const aErrorCode: TnxResult);
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


nxtError Method

nxtError Method
TnxThread Methods Send Feedback

This is the overview for the nxtError method overload.

Overload List
Name | Description
TnxThread.nxtError (PResStringRec) |
TnxThread.nxtError (PResStringRec, array of const) |
TnxThread.nxtError (string) |
TnxThread.nxtError (string, array of const) |
TnxThread.nxtError (TnxResult) |
Group

TnxThread Methods

Links
TnxThread Methods


TnxThread.nxtError Method (PResStringRec)

TnxThread.nxtError Method (PResStringRec)
TnxThread Class TnxThread Members nxllThread Namespace nxtError Method Send Feedback
Syntax
Delphi
procedure nxtError(aMsgRes: PResStringRec); overload;
Group

nxtError Method

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, nxtError Method


TnxThread.nxtError Method (PResStringRec, array of const)

TnxThread.nxtError Method (PResStringRec, array of const)
TnxThread Class TnxThread Members nxllThread Namespace nxtError Method Send Feedback
Syntax
Delphi
procedure nxtError(aMsgRes: PResStringRec; const aArgs: array of const); overload;
Group

nxtError Method

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, nxtError Method


TnxThread.nxtError Method (TnxResult)

TnxThread.nxtError Method (TnxResult)
TnxThread Class TnxThread Members nxllThread Namespace nxtError Method Send Feedback
Syntax
Delphi
procedure nxtError(const aErrorCode: TnxResult); overload;
Group

nxtError Method

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, nxtError Method


TnxThread.nxtError Method (string)

TnxThread.nxtError Method (string)
TnxThread Class TnxThread Members nxllThread Namespace nxtError Method Send Feedback
Syntax
Delphi
procedure nxtError(const aMsg: string); overload;
Group

nxtError Method

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, nxtError Method


TnxThread.nxtError Method (string, array of const)

TnxThread.nxtError Method (string, array of const)
TnxThread Class TnxThread Members nxllThread Namespace nxtError Method Send Feedback
Syntax
Delphi
procedure nxtError(const aMsg: string; const aArgs: array of const); overload;
Group

nxtError Method

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, nxtError Method


TnxThread.nxtExceptionClass Method

TnxThread.nxtExceptionClass Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; virtual;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.SetName Method

TnxThread.SetName Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure SetName;
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxThread.WaitForEx Method

TnxThread.WaitForEx Method
TnxThread Class TnxThread Members nxllThread Namespace TnxThread Methods Send Feedback
Syntax
Delphi
procedure WaitForEx(aTimeout: Integer);
Group

TnxThread Methods

Links
TnxThread Class, TnxThread Members, nxllThread Namespace, TnxThread Methods


TnxTimerThread Class

TnxTimerThread Class
TnxTimerThread Fields TnxTimerThread Methods TnxTimerThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxTimerThreadnxllThread_TnxTimerThreadnxllThread_TnxTimerThreadnxllThread_TnxTimerThreadnxllThread_TnxTimerThread
Syntax
Delphi
TnxTimerThread = class(TnxInitThread);
File

nxllThread

Description

This is class nxllThread.TnxTimerThread.

Group

Classes

Links
TnxTimerThread Fields, TnxTimerThread Methods, TnxTimerThread Members, nxllThread, Classes


TnxTimerThread Members

TnxTimerThread Members
TnxTimerThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxTimerThread.

Class

TnxTimerThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
DoTimer | This is DoTimer, a member of class TnxTimerThread.
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxTimerThread
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxTimerThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxTimerThread.Create Constructor

TnxTimerThread.Create Constructor
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Class Send Feedback
Syntax
Delphi
constructor Create(const aInterval: Integer; const aThreadPriority: TThreadPriority);
Description

TnxTimerThread

Class

TnxTimerThread Class

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Class


TnxTimerThread.Destroy Destructor

TnxTimerThread.Destroy Destructor
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTimerThread Class

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Class


TnxTimerThread Fields

TnxTimerThread Fields
TnxTimerThread Class Legend Protected Fields Send Feedback

The fields of the TnxTimerThread class are listed here.

Class

TnxTimerThread Class

Protected Fields
Name | Description
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
Links
TnxTimerThread Class, Legend, Protected Fields


TnxTimerThread.ttTimerEvent Field

TnxTimerThread.ttTimerEvent Field
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Fields Send Feedback
Syntax
Delphi
ttTimerEvent: TnxEvent;
Description

This is ttTimerEvent, a member of class TnxTimerThread.

Group

TnxTimerThread Fields

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Fields


TnxTimerThread.ttTimerInterval Field

TnxTimerThread.ttTimerInterval Field
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Fields Send Feedback
Syntax
Delphi
ttTimerInterval: integer;
Description

This is ttTimerInterval, a member of class TnxTimerThread.

Group

TnxTimerThread Fields

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Fields


TnxTimerThread Methods

TnxTimerThread Methods
TnxTimerThread Class Legend Protected Methods Send Feedback

The methods of the TnxTimerThread class are listed here.

Class

TnxTimerThread Class

Protected Methods
Name | Description
DoTimer | This is DoTimer, a member of class TnxTimerThread.
InnerExecute |
Links
TnxTimerThread Class, Legend, Protected Methods


TnxTimerThread.DoTimer Method

TnxTimerThread.DoTimer Method
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Methods Send Feedback
Syntax
Delphi
procedure DoTimer; virtual; abstract;
Description

This is DoTimer, a member of class TnxTimerThread.

Group

TnxTimerThread Methods

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Methods


TnxTimerThread.InnerExecute Method

TnxTimerThread.InnerExecute Method
TnxTimerThread Class TnxTimerThread Members nxllThread Namespace TnxTimerThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxTimerThread Methods

Links
TnxTimerThread Class, TnxTimerThread Members, nxllThread Namespace, TnxTimerThread Methods


TnxWaitThread Class

TnxWaitThread Class
TnxWaitThread Methods TnxWaitThread Properties TnxWaitThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxWaitThreadnxllThread_TnxWaitThreadnxllThread_TnxWaitThreadnxllThread_TnxWaitThread
Syntax
Delphi
TnxWaitThread = class(TnxInternalWaitThread);
File

nxllThread

Description

This is class nxllThread.TnxWaitThread.

Group

Classes

Links
TnxWaitThread Methods, TnxWaitThread Properties, TnxWaitThread Members, nxllThread, Classes


TnxWaitThread Members

TnxWaitThread Members
TnxWaitThread Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWaitThread.

Class

TnxWaitThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Public Methods
Name | Description
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
AllowExit | TnxWaitThread
Create |
Create |
Create | This is Create, a member of class TnxThread.
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Public Properties
Name | Description
Waiting | This is Waiting, a member of class TnxWaitThread.
Links
TnxWaitThread Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWaitThread Methods

TnxWaitThread Methods
TnxWaitThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWaitThread class are listed here.

Class

TnxWaitThread Class

Protected Methods
Name | Description
nxtExceptionClass |
Public Methods
Name | Description
AllowExit | TnxWaitThread
Links
TnxWaitThread Class, Legend, Protected Methods, Public Methods


TnxWaitThread.AllowExit Method

TnxWaitThread.AllowExit Method
TnxWaitThread Class TnxWaitThread Members nxllThread Namespace TnxWaitThread Methods Send Feedback
Syntax
Delphi
procedure AllowExit;
Description

TnxWaitThread

Group

TnxWaitThread Methods

Links
TnxWaitThread Class, TnxWaitThread Members, nxllThread Namespace, TnxWaitThread Methods


TnxWaitThread.nxtExceptionClass Method

TnxWaitThread.nxtExceptionClass Method
TnxWaitThread Class TnxWaitThread Members nxllThread Namespace TnxWaitThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxWaitThread Methods

Links
TnxWaitThread Class, TnxWaitThread Members, nxllThread Namespace, TnxWaitThread Methods


TnxWaitThread Properties

TnxWaitThread Properties
TnxWaitThread Class Legend Public Properties Send Feedback

The properties of the TnxWaitThread class are listed here.

Class

TnxWaitThread Class

Public Properties
Name | Description
Waiting | This is Waiting, a member of class TnxWaitThread.
Links
TnxWaitThread Class, Legend, Public Properties


TnxWaitThread.Waiting Property

TnxWaitThread.Waiting Property
TnxWaitThread Class TnxWaitThread Members nxllThread Namespace TnxWaitThread Properties Send Feedback
Syntax
Delphi
property Waiting: Boolean;
Description

This is Waiting, a member of class TnxWaitThread.

Group

TnxWaitThread Properties

Links
TnxWaitThread Class, TnxWaitThread Members, nxllThread Namespace, TnxWaitThread Properties


TnxWorkerThread Class

TnxWorkerThread Class
TnxWorkerThread Methods TnxWorkerThread Members nxllThread Classes Send Feedback
Class Hierarchy
nxllThread_TnxWorkerThreadnxllThread_TnxWorkerThread
Syntax
Delphi
TnxWorkerThread = class(TnxThread);
File

nxllThread

Description

This is class nxllThread.TnxWorkerThread.

Group

Classes

Links
TnxWorkerThread Methods, TnxWorkerThread Members, nxllThread, Classes


TnxWorkerThread Members

TnxWorkerThread Members
TnxWorkerThread Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWorkerThread.

Class

TnxWorkerThread Class

Protected Fields
Name | Description
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
Protected Methods
Name | Description
DoExecute |
DoHandleException |
DoTerminate |
Execute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
SetName |
Public Methods
Name | Description
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxWorkerThread Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWorkerThread.Create Constructor

TnxWorkerThread.Create Constructor
TnxWorkerThread Class TnxWorkerThread Members nxllThread Namespace TnxWorkerThread Class Send Feedback
Syntax
Delphi
constructor Create(aSender: TObject; aEvent: TNotifyEvent; aThreadPriority: TThreadPriority);
Class

TnxWorkerThread Class

Links
TnxWorkerThread Class, TnxWorkerThread Members, nxllThread Namespace, TnxWorkerThread Class


TnxWorkerThread Methods

TnxWorkerThread Methods
TnxWorkerThread Class Legend Protected Methods Send Feedback

The methods of the TnxWorkerThread class are listed here.

Class

TnxWorkerThread Class

Protected Methods
Name | Description
DoExecute |
nxtExceptionClass |
Links
TnxWorkerThread Class, Legend, Protected Methods


TnxWorkerThread.DoExecute Method

TnxWorkerThread.DoExecute Method
TnxWorkerThread Class TnxWorkerThread Members nxllThread Namespace TnxWorkerThread Methods Send Feedback
Syntax
Delphi
procedure DoExecute; override;
Group

TnxWorkerThread Methods

Links
TnxWorkerThread Class, TnxWorkerThread Members, nxllThread Namespace, TnxWorkerThread Methods


TnxWorkerThread.nxtExceptionClass Method

TnxWorkerThread.nxtExceptionClass Method
TnxWorkerThread Class TnxWorkerThread Members nxllThread Namespace TnxWorkerThread Methods Send Feedback
Syntax
Delphi
class function nxtExceptionClass: EnxThreadClass; override;
Group

TnxWorkerThread Methods

Links
TnxWorkerThread Class, TnxWorkerThread Members, nxllThread Namespace, TnxWorkerThread Methods


Functions

Functions
Functions nxllThread Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
GetThreadPriorities |
IdentToThreadPriority |
nxProcessThreaded | nxProcessThreaded
nxSynchronize | nxSynchronize
nxThreadSetName | nxThreadSetName
PostQueuedCompletionStatus | This is function nxllThread.PostQueuedCompletionStatus.
ThreadPriorityToIdent |
ThreadPriorityToString |
Namespace

nxllThread Namespace

Links
Functions, nxllThread Namespace, Legend


nxllThread.GetThreadPriorities Function

nxllThread.GetThreadPriorities Function
nxllThread Functions Send Feedback
Syntax
Delphi
procedure GetThreadPriorities(Proc: TGetStrProc);
File

nxllThread

Group

Functions

Links
nxllThread, Functions


nxllThread.IdentToThreadPriority Function

nxllThread.IdentToThreadPriority Function
nxllThread Functions Send Feedback
Syntax
Delphi
function IdentToThreadPriority(const Ident: string; var ThreadPriority: Longint): Boolean;
File

nxllThread

Group

Functions

Links
nxllThread, Functions


nxllThread.nxProcessThreaded Function

nxllThread.nxProcessThreaded Function
nxllThread Functions Send Feedback
Syntax
Delphi
procedure nxProcessThreaded(aSender: TObject; aEvent: TNotifyEvent; aThreadPriority: TThreadPriority);
File

nxllThread

Description

nxProcessThreaded

Group

Functions

Links
nxllThread, Functions


nxllThread.nxSynchronize Function

nxllThread.nxSynchronize Function
nxllThread Functions Send Feedback
Syntax
Delphi
procedure nxSynchronize(aMethod: TThreadMethod);
File

nxllThread

Description

nxSynchronize

Group

Functions

Links
nxllThread, Functions


nxllThread.nxThreadSetName Function

nxllThread.nxThreadSetName Function
nxllThread Functions Send Feedback
Syntax
Delphi
procedure nxThreadSetName(const aName: AnsiString);
File

nxllThread

Description

nxThreadSetName

Group

Functions

Links
nxllThread, Functions


nxllThread.PostQueuedCompletionStatus Function

nxllThread.PostQueuedCompletionStatus Function
nxllThread Functions Send Feedback
Syntax
Delphi
function PostQueuedCompletionStatus(CompletionPort: THandle; dwNumberOfBytesTransferred: DWORD; dwCompletionKey: DWORD; lpOverlapped: POverlapped): BOOL; stdcall;
File

nxllThread

Description

This is function nxllThread.PostQueuedCompletionStatus.

Group

Functions

Links
nxllThread, Functions


nxllThread.ThreadPriorityToIdent Function

nxllThread.ThreadPriorityToIdent Function
nxllThread Functions Send Feedback
Syntax
Delphi
function ThreadPriorityToIdent(ThreadPriority: Longint; var Ident: string): Boolean;
File

nxllThread

Group

Functions

Links
nxllThread, Functions


nxllThread.ThreadPriorityToString Function

nxllThread.ThreadPriorityToString Function
nxllThread Functions Send Feedback
Syntax
Delphi
function ThreadPriorityToString(ThreadPriority: TnxThreadPriority): string;
File

nxllThread

Group

Functions

Links
nxllThread, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllThread Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllThread Namespace

Records
Name | Description
TRaiseFrame | This is record nxllThread.TRaiseFrame.
Links
nxllThread Namespace, Legend, Records


nxllThread.TRaiseFrame Record

nxllThread.TRaiseFrame Record
nxllThread Structs, Records, Enums Send Feedback
Syntax
Delphi
TRaiseFrame = record
  NextRaise: PRaiseFrame;
  ExceptAddr: Pointer;
  ExceptObject: TObject;
  ExceptionRecord: PExceptionRecord;
end;
File

nxllThread

Description

This is record nxllThread.TRaiseFrame.

Group

Structs, Records, Enums

Links
nxllThread, Structs, Records, Enums


Types

Types
nxllThread Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllThread Namespace

Types
Name | Description
EnxThreadClass | This is type nxllThread.EnxThreadClass.
PRaiseFrame | copied from system.pas
TBindIoCompletionCallback | This is type nxllThread.TBindIoCompletionCallback.
TCancelTimerQueueTimer | This is type nxllThread.TCancelTimerQueueTimer.
TChangeTimerQueueTimer | This is type nxllThread.TChangeTimerQueueTimer.
TCreateTimerQueue | This is type nxllThread.TCreateTimerQueue.
TCreateTimerQueueTimer | This is type nxllThread.TCreateTimerQueueTimer.
TDeleteTimerQueue | This is type nxllThread.TDeleteTimerQueue.
TDeleteTimerQueueEx | This is type nxllThread.TDeleteTimerQueueEx.
TDeleteTimerQueueTimer | This is type nxllThread.TDeleteTimerQueueTimer.
TGetThreadIOPendingFlag | This is type nxllThread.TGetThreadIOPendingFlag.
TNtQueryInformationThread | This is type nxllThread.TNtQueryInformationThread.
TnxThreadProcessEvent | This is type nxllThread.TnxThreadProcessEvent.
TOverlappedCompletionRoutine | This is type nxllThread.TOverlappedCompletionRoutine.
TQueueUserWorkItem | This is type nxllThread.TQueueUserWorkItem.
TSetTimerQueueTimer | This is type nxllThread.TSetTimerQueueTimer.
TThreadStartRoutine | This is type nxllThread.TThreadStartRoutine.
TWaitOrTimerCallback | This is type nxllThread.TWaitOrTimerCallback.
Links
nxllThread Namespace, Types


nxllThread.EnxThreadClass Type

nxllThread.EnxThreadClass Type
nxllThread Types Send Feedback
Syntax
Delphi
EnxThreadClass = class of EnxThread;
File

nxllThread

Description

This is type nxllThread.EnxThreadClass.

Group

Types

Links
nxllThread, Types


nxllThread.PRaiseFrame Type

nxllThread.PRaiseFrame Type
nxllThread Types Send Feedback
Syntax
Delphi
PRaiseFrame = ^TRaiseFrame;
File

nxllThread

Description

copied from system.pas

Group

Types

Links
nxllThread, Types


nxllThread.TBindIoCompletionCallback Type

nxllThread.TBindIoCompletionCallback Type
nxllThread Types Send Feedback
Syntax
Delphi
TBindIoCompletionCallback = function (FileHandle : THandle; Function_ : TOverlappedCompletionRoutine; Flags : Cardinal) : BOOL;
File

nxllThread

Description

This is type nxllThread.TBindIoCompletionCallback.

Group

Types

Links
nxllThread, Types


nxllThread.TCancelTimerQueueTimer Type

nxllThread.TCancelTimerQueueTimer Type
nxllThread Types Send Feedback
Syntax
Delphi
TCancelTimerQueueTimer = function (TimerQueue : THandle; Timer : THandle) : BOOL;
File

nxllThread

Description

This is type nxllThread.TCancelTimerQueueTimer.

Group

Types

Links
nxllThread, Types


nxllThread.TChangeTimerQueueTimer Type

nxllThread.TChangeTimerQueueTimer Type
nxllThread Types Send Feedback
Syntax
Delphi
TChangeTimerQueueTimer = function (TimerQueue : THandle; Timer : THandle; DueTime : Cardinal; Period : Cardinal) : BOOL;
File

nxllThread

Description

This is type nxllThread.TChangeTimerQueueTimer.

Group

Types

Links
nxllThread, Types


nxllThread.TCreateTimerQueue Type

nxllThread.TCreateTimerQueue Type
nxllThread Types Send Feedback
Syntax
Delphi
TCreateTimerQueue = function : THandle;
File

nxllThread

Description

This is type nxllThread.TCreateTimerQueue.

Group

Types

Links
nxllThread, Types


nxllThread.TCreateTimerQueueTimer Type

nxllThread.TCreateTimerQueueTimer Type
nxllThread Types Send Feedback
Syntax
Delphi
TCreateTimerQueueTimer = function (var phNewTimer : THandle; TimerQueue : THandle; Callback : TWaitOrTimerCallback; Parameter : Pointer; DueTime : Cardinal; Period : Cardinal; Flags : Cardinal) : BOOL;
File

nxllThread

Description

This is type nxllThread.TCreateTimerQueueTimer.

Group

Types

Links
nxllThread, Types


nxllThread.TDeleteTimerQueue Type

nxllThread.TDeleteTimerQueue Type
nxllThread Types Send Feedback
Syntax
Delphi
TDeleteTimerQueue = function (TimerQueue : THandle) : BOOL;
File

nxllThread

Description

This is type nxllThread.TDeleteTimerQueue.

Group

Types

Links
nxllThread, Types


nxllThread.TDeleteTimerQueueEx Type

nxllThread.TDeleteTimerQueueEx Type
nxllThread Types Send Feedback
Syntax
Delphi
TDeleteTimerQueueEx = function (TimerQueue : THandle; CompletionEvent : THandle) : BOOL;
File

nxllThread

Description

This is type nxllThread.TDeleteTimerQueueEx.

Group

Types

Links
nxllThread, Types


nxllThread.TDeleteTimerQueueTimer Type

nxllThread.TDeleteTimerQueueTimer Type
nxllThread Types Send Feedback
Syntax
Delphi
TDeleteTimerQueueTimer = function (TimerQueue : THandle; Timer : THandle; CompletionEvent : THandle) : BOOL;
File

nxllThread

Description

This is type nxllThread.TDeleteTimerQueueTimer.

Group

Types

Links
nxllThread, Types


nxllThread.TGetThreadIOPendingFlag Type

nxllThread.TGetThreadIOPendingFlag Type
nxllThread Types Send Feedback
Syntax
Delphi
TGetThreadIOPendingFlag = function (hThread : THandle; out lpIOIsPending : BOOL) : BOOL;
File

nxllThread

Description

This is type nxllThread.TGetThreadIOPendingFlag.

Group

Types

Links
nxllThread, Types


nxllThread.TNtQueryInformationThread Type

nxllThread.TNtQueryInformationThread Type
nxllThread Types Send Feedback
Syntax
Delphi
TNtQueryInformationThread = function (ThreadHandle : THandle; ThreadInformationClass : Cardinal; ThreadInformation : Pointer; ThreadInformationLength : Cardinal; var ReturnLength : Cardinal) : Integer;
File

nxllThread

Description

This is type nxllThread.TNtQueryInformationThread.

Group

Types

Links
nxllThread, Types


nxllThread.TnxThreadProcessEvent Type

nxllThread.TnxThreadProcessEvent Type
nxllThread Types Send Feedback
Syntax
Delphi
TnxThreadProcessEvent = procedure (const aProcessCookie: Pointer) of object;
File

nxllThread

Description

This is type nxllThread.TnxThreadProcessEvent.

Group

Types

Links
nxllThread, Types


nxllThread.TOverlappedCompletionRoutine Type

nxllThread.TOverlappedCompletionRoutine Type
nxllThread Types Send Feedback
Syntax
Delphi
TOverlappedCompletionRoutine = procedure (dwErrorCode: Cardinal; dwNumberOfBytesTransfered: Cardinal; lpOverlapped: POverlapped);
File

nxllThread

Description

This is type nxllThread.TOverlappedCompletionRoutine.

Group

Types

Links
nxllThread, Types


nxllThread.TQueueUserWorkItem Type

nxllThread.TQueueUserWorkItem Type
nxllThread Types Send Feedback
Syntax
Delphi
TQueueUserWorkItem = function (Function_ : TThreadStartRoutine; Context : Pointer; Flags : Cardinal) : BOOL;
File

nxllThread

Description

This is type nxllThread.TQueueUserWorkItem.

Group

Types

Links
nxllThread, Types


nxllThread.TSetTimerQueueTimer Type

nxllThread.TSetTimerQueueTimer Type
nxllThread Types Send Feedback
Syntax
Delphi
TSetTimerQueueTimer = function (TimerQueue : THandle; Callback : TWaitOrTimerCallback; Parameter : Pointer; DueTime : Cardinal; Period : Cardinal; PreferIo : BOOL) : THandle;
File

nxllThread

Description

This is type nxllThread.TSetTimerQueueTimer.

Group

Types

Links
nxllThread, Types


nxllThread.TThreadStartRoutine Type

nxllThread.TThreadStartRoutine Type
nxllThread Types Send Feedback
Syntax
Delphi
TThreadStartRoutine = function (lpThreadParameter: Pointer): Cardinal;
File

nxllThread

Description

This is type nxllThread.TThreadStartRoutine.

Group

Types

Links
nxllThread, Types


nxllThread.TWaitOrTimerCallback Type

nxllThread.TWaitOrTimerCallback Type
nxllThread Types Send Feedback
Syntax
Delphi
TWaitOrTimerCallback = procedure (lpParameter : Pointer; TimerOrWaitFired : BOOL);
File

nxllThread

Description

This is type nxllThread.TWaitOrTimerCallback.

Group

Types

Links
nxllThread, Types


Variables

Variables
nxllThread Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllThread Namespace

Variables
Name | Description
_BindIoCompletionCallback | This is variable nxllThread._BindIoCompletionCallback.
_CancelTimerQueueTimer | This is variable nxllThread._CancelTimerQueueTimer.
_ChangeTimerQueueTimer | This is variable nxllThread._ChangeTimerQueueTimer.
_CreateTimerQueue | This is variable nxllThread._CreateTimerQueue.
_CreateTimerQueueTimer | This is variable nxllThread._CreateTimerQueueTimer.
_DeleteTimerQueue | This is variable nxllThread._DeleteTimerQueue.
_DeleteTimerQueueEx | This is variable nxllThread._DeleteTimerQueueEx.
_DeleteTimerQueueTimer | This is variable nxllThread._DeleteTimerQueueTimer.
_GetThreadIOPendingFlag | This is variable nxllThread._GetThreadIOPendingFlag.
_NtQueryInformationThread | This is variable nxllThread._NtQueryInformationThread.
_QueueUserWorkItem | This is variable nxllThread._QueueUserWorkItem.
_SetTimerQueueTimer | This is variable nxllThread._SetTimerQueueTimer.
nxPatchPPLPresent | This is variable nxllThread.nxPatchPPLPresent.
Links
nxllThread Namespace, Variables


nxllThread._BindIoCompletionCallback Variable

nxllThread._BindIoCompletionCallback Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_BindIoCompletionCallback: TBindIoCompletionCallback;
File

nxllThread

Description

This is variable nxllThread._BindIoCompletionCallback.

Group

Variables

Links
nxllThread, Variables


nxllThread._CancelTimerQueueTimer Variable

nxllThread._CancelTimerQueueTimer Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_CancelTimerQueueTimer: TCancelTimerQueueTimer;
File

nxllThread

Description

This is variable nxllThread._CancelTimerQueueTimer.

Group

Variables

Links
nxllThread, Variables


nxllThread._ChangeTimerQueueTimer Variable

nxllThread._ChangeTimerQueueTimer Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_ChangeTimerQueueTimer: TChangeTimerQueueTimer;
File

nxllThread

Description

This is variable nxllThread._ChangeTimerQueueTimer.

Group

Variables

Links
nxllThread, Variables


nxllThread._CreateTimerQueue Variable

nxllThread._CreateTimerQueue Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_CreateTimerQueue: TCreateTimerQueue;
File

nxllThread

Description

This is variable nxllThread._CreateTimerQueue.

Group

Variables

Links
nxllThread, Variables


nxllThread._CreateTimerQueueTimer Variable

nxllThread._CreateTimerQueueTimer Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_CreateTimerQueueTimer: TCreateTimerQueueTimer;
File

nxllThread

Description

This is variable nxllThread._CreateTimerQueueTimer.

Group

Variables

Links
nxllThread, Variables


nxllThread._DeleteTimerQueue Variable

nxllThread._DeleteTimerQueue Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_DeleteTimerQueue: TDeleteTimerQueue;
File

nxllThread

Description

This is variable nxllThread._DeleteTimerQueue.

Group

Variables

Links
nxllThread, Variables


nxllThread._DeleteTimerQueueEx Variable

nxllThread._DeleteTimerQueueEx Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_DeleteTimerQueueEx: TDeleteTimerQueueEx;
File

nxllThread

Description

This is variable nxllThread._DeleteTimerQueueEx.

Group

Variables

Links
nxllThread, Variables


nxllThread._DeleteTimerQueueTimer Variable

nxllThread._DeleteTimerQueueTimer Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_DeleteTimerQueueTimer: TDeleteTimerQueueTimer;
File

nxllThread

Description

This is variable nxllThread._DeleteTimerQueueTimer.

Group

Variables

Links
nxllThread, Variables


nxllThread._GetThreadIOPendingFlag Variable

nxllThread._GetThreadIOPendingFlag Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_GetThreadIOPendingFlag: TGetThreadIOPendingFlag;
File

nxllThread

Description

This is variable nxllThread._GetThreadIOPendingFlag.

Group

Variables

Links
nxllThread, Variables


nxllThread._NtQueryInformationThread Variable

nxllThread._NtQueryInformationThread Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_NtQueryInformationThread: TNtQueryInformationThread;
File

nxllThread

Description

This is variable nxllThread._NtQueryInformationThread.

Group

Variables

Links
nxllThread, Variables


nxllThread._QueueUserWorkItem Variable

nxllThread._QueueUserWorkItem Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_QueueUserWorkItem: TQueueUserWorkItem;
File

nxllThread

Description

This is variable nxllThread._QueueUserWorkItem.

Group

Variables

Links
nxllThread, Variables


nxllThread._SetTimerQueueTimer Variable

nxllThread._SetTimerQueueTimer Variable
nxllThread Variables Send Feedback
Syntax
Delphi
_SetTimerQueueTimer: TSetTimerQueueTimer;
File

nxllThread

Description

This is variable nxllThread._SetTimerQueueTimer.

Group

Variables

Links
nxllThread, Variables


nxllThread.nxPatchPPLPresent Variable

nxllThread.nxPatchPPLPresent Variable
nxllThread Variables Send Feedback
Syntax
Delphi
nxPatchPPLPresent: Boolean = False;
File

nxllThread

Description

This is variable nxllThread.nxPatchPPLPresent.

Group

Variables

Links
nxllThread, Variables


Constants

Constants
Constants nxllThread Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
kernel32 | This is constant nxllThread.kernel32.
rsTnxInternalInitThreadCreateCreateSemaphore | This is constant nxllThread.rsTnxInternalInitThreadCreateCreateSemaphore.
ThreadIsIoPending | This is constant nxllThread.ThreadIsIoPending.
ThreadPriorities | TnxThreadPriority
WT_EXECUTEDEFAULT | This is constant nxllThread.WT_EXECUTEDEFAULT.
WT_EXECUTEINIOTHREAD | This is constant nxllThread.WT_EXECUTEINIOTHREAD.
WT_EXECUTEINPERSISTENTIOTHREAD | This is constant nxllThread.WT_EXECUTEINPERSISTENTIOTHREAD.
WT_EXECUTEINPERSISTENTTHREAD | This is constant nxllThread.WT_EXECUTEINPERSISTENTTHREAD.
WT_EXECUTEINTIMERTHREAD | This is constant nxllThread.WT_EXECUTEINTIMERTHREAD.
WT_EXECUTEINUITHREAD | This is constant nxllThread.WT_EXECUTEINUITHREAD.
WT_EXECUTEINWAITTHREAD | This is constant nxllThread.WT_EXECUTEINWAITTHREAD.
WT_EXECUTELONGFUNCTION | This is constant nxllThread.WT_EXECUTELONGFUNCTION.
WT_EXECUTEONLYONCE | This is constant nxllThread.WT_EXECUTEONLYONCE.
WT_TRANSFER_IMPERSONATION | This is constant nxllThread.WT_TRANSFER_IMPERSONATION.
Namespace

nxllThread Namespace

Links
Constants, nxllThread Namespace


nxllThread.kernel32 Constant

nxllThread.kernel32 Constant
nxllThread Constants Send Feedback
Syntax
Delphi
kernel32 = 'kernel32.dll';
File

nxllThread

Description

This is constant nxllThread.kernel32.

Group

Constants

Links
nxllThread, Constants


nxllThread.rsTnxInternalInitThreadCreateCreateSemaphore Constant

nxllThread.rsTnxInternalInitThreadCreateCreateSemaphore Constant
nxllThread Constants Send Feedback
Syntax
Delphi
rsTnxInternalInitThreadCreateCreateSemaphore = 'TnxInternalInitThread.Create/CreateSemaphore';
File

nxllThread

Description

This is constant nxllThread.rsTnxInternalInitThreadCreateCreateSemaphore.

Group

Constants

Links
nxllThread, Constants


nxllThread.ThreadIsIoPending Constant

nxllThread.ThreadIsIoPending Constant
nxllThread Constants Send Feedback
Syntax
Delphi
ThreadIsIoPending = 16;
File

nxllThread

Description

This is constant nxllThread.ThreadIsIoPending.

Group

Constants

Links
nxllThread, Constants


nxllThread.ThreadPriorities Constant

nxllThread.ThreadPriorities Constant
nxllThread Constants Send Feedback
Syntax
Delphi
ThreadPriorities: array[0..6] of TIdentMapEntry = ( (Value: THREAD_PRIORITY_IDLE; Name: 'IDLE'), (Value: THREAD_PRIORITY_LOWEST; Name: 'LOWEST'), (Value: THREAD_PRIORITY_BELOW_NORMAL; Name: 'BELOW_NORMAL'), (Value: THREAD_PRIORITY_NORMAL; Name: 'NORMAL'), (Value: THREAD_PRIORITY_ABOVE_NORMAL; Name: 'ABOVE_NORMAL'), (Value: THREAD_PRIORITY_HIGHEST; Name: 'HIGHEST'), (Value: THREAD_PRIORITY_TIME_CRITICAL; Name: 'TIME_CRITICAL'));
File

nxllThread

Description

TnxThreadPriority

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEDEFAULT Constant

nxllThread.WT_EXECUTEDEFAULT Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEDEFAULT = DWORD($00000000);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEDEFAULT.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINIOTHREAD Constant

nxllThread.WT_EXECUTEINIOTHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINIOTHREAD = DWORD($00000001);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINIOTHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINPERSISTENTIOTHREAD Constant

nxllThread.WT_EXECUTEINPERSISTENTIOTHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINPERSISTENTIOTHREAD = DWORD($00000040);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINPERSISTENTIOTHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINPERSISTENTTHREAD Constant

nxllThread.WT_EXECUTEINPERSISTENTTHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINPERSISTENTTHREAD = DWORD($00000080);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINPERSISTENTTHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINTIMERTHREAD Constant

nxllThread.WT_EXECUTEINTIMERTHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINTIMERTHREAD = DWORD($00000020);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINTIMERTHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINUITHREAD Constant

nxllThread.WT_EXECUTEINUITHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINUITHREAD = DWORD($00000002);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINUITHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEINWAITTHREAD Constant

nxllThread.WT_EXECUTEINWAITTHREAD Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEINWAITTHREAD = DWORD($00000004);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEINWAITTHREAD.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTELONGFUNCTION Constant

nxllThread.WT_EXECUTELONGFUNCTION Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTELONGFUNCTION = DWORD($00000010);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTELONGFUNCTION.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_EXECUTEONLYONCE Constant

nxllThread.WT_EXECUTEONLYONCE Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_EXECUTEONLYONCE = DWORD($00000008);
File

nxllThread

Description

This is constant nxllThread.WT_EXECUTEONLYONCE.

Group

Constants

Links
nxllThread, Constants


nxllThread.WT_TRANSFER_IMPERSONATION Constant

nxllThread.WT_TRANSFER_IMPERSONATION Constant
nxllThread Constants Send Feedback
Syntax
Delphi
WT_TRANSFER_IMPERSONATION = DWORD($00000100);
File

nxllThread

Description

This is constant nxllThread.WT_TRANSFER_IMPERSONATION.

Group

Constants

Links
nxllThread, Constants


nxllThreadSafeQueue Namespace

nxllThreadSafeQueue Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxllThreadSafeQueue.

Classes
Name | Description
TnxQueueItemList | This is class nxllThreadSafeQueue.TnxQueueItemList.
TnxThreadSafeQueue | This is class nxllThreadSafeQueue.TnxThreadSafeQueue.
TnxThreadSafeQueueItem | This is class nxllThreadSafeQueue.TnxThreadSafeQueueItem.
Constants
Name | Description
rsTnxThreadSafeQueueCreateCreateEvent | Usage of resourcestrings with @ prevents compiler from creating implicit try/finally blocks.
rsTnxThreadSafeQueueDequeueResetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueResetEvent.
rsTnxThreadSafeQueueDequeueSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueSetEvent.
rsTnxThreadSafeQueueDequeueWaitForMultipleObjects | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueWaitForMultipleObjects.
rsTnxThreadSafeQueueEnqueueSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueEnqueueSetEvent.
rsTnxThreadSafeQueueTerminateSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueTerminateSetEvent.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxllThreadSafeQueue Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxQueueItemList | This is class nxllThreadSafeQueue.TnxQueueItemList.
TnxThreadSafeQueue | This is class nxllThreadSafeQueue.TnxThreadSafeQueue.
TnxThreadSafeQueueItem | This is class nxllThreadSafeQueue.TnxThreadSafeQueueItem.
Namespace

nxllThreadSafeQueue Namespace

Links
Classes, nxllThreadSafeQueue Namespace, Legend


TnxQueueItemList Class

TnxQueueItemList Class
TnxQueueItemList Fields TnxQueueItemList Methods TnxQueueItemList Members nxllThreadSafeQueue Classes Send Feedback
Class Hierarchy
nxllThreadSafeQueue_TnxQueueItemListnxllThreadSafeQueue_TnxQueueItemList
Syntax
Delphi
TnxQueueItemList = class(TnxObject);
File

nxllThreadSafeQueue

Description

This is class nxllThreadSafeQueue.TnxQueueItemList.

Group

Classes

Links
TnxQueueItemList Fields, TnxQueueItemList Methods, TnxQueueItemList Members, nxllThreadSafeQueue, Classes


TnxQueueItemList Members

TnxQueueItemList Members
TnxQueueItemList Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxQueueItemList.

Class

TnxQueueItemList Class

Protected Fields
Name | Description
qilHead | private ClassType: TClass 4/8 bytes
qilTail | This is qilTail, a member of class TnxQueueItemList.
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
Destroy |
FreeInstance |
NewInstance | TnxObject
Links
TnxQueueItemList Class, Legend, Protected Fields, Public Methods


TnxQueueItemList.Destroy Destructor

TnxQueueItemList.Destroy Destructor
TnxQueueItemList Class TnxQueueItemList Members nxllThreadSafeQueue Namespace TnxQueueItemList Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxQueueItemList Class

Links
TnxQueueItemList Class, TnxQueueItemList Members, nxllThreadSafeQueue Namespace, TnxQueueItemList Class


TnxQueueItemList Fields

TnxQueueItemList Fields
TnxQueueItemList Class Legend Protected Fields Send Feedback

The fields of the TnxQueueItemList class are listed here.

Class

TnxQueueItemList Class

Protected Fields
Name | Description
qilHead | private ClassType: TClass 4/8 bytes
qilTail | This is qilTail, a member of class TnxQueueItemList.
Links
TnxQueueItemList Class, Legend, Protected Fields


TnxQueueItemList.qilHead Field

TnxQueueItemList.qilHead Field
TnxQueueItemList Class TnxQueueItemList Members nxllThreadSafeQueue Namespace TnxQueueItemList Fields Send Feedback
Syntax
Delphi
qilHead: PnxListEntry;
Description

private ClassType: TClass 4/8 bytes

Group

TnxQueueItemList Fields

Links
TnxQueueItemList Class, TnxQueueItemList Members, nxllThreadSafeQueue Namespace, TnxQueueItemList Fields


TnxQueueItemList.qilTail Field

TnxQueueItemList.qilTail Field
TnxQueueItemList Class TnxQueueItemList Members nxllThreadSafeQueue Namespace TnxQueueItemList Fields Send Feedback
Syntax
Delphi
qilTail: PnxListEntry;
Description

This is qilTail, a member of class TnxQueueItemList.

Group

TnxQueueItemList Fields

Links
TnxQueueItemList Class, TnxQueueItemList Members, nxllThreadSafeQueue Namespace, TnxQueueItemList Fields


TnxQueueItemList Methods

TnxQueueItemList Methods
TnxQueueItemList Class Legend Public Methods Send Feedback

The methods of the TnxQueueItemList class are listed here.

Class

TnxQueueItemList Class

Public Methods
Name | Description
Add | This is the overview for the Add method overload.
Links
TnxQueueItemList Class, Legend, Public Methods


Add Method

Add Method
TnxQueueItemList Methods Send Feedback

This is the overview for the Add method overload.

Overload List
Name | Description
TnxQueueItemList.Add (TnxQueueItemList) |
TnxQueueItemList.Add (TnxThreadSafeQueueItem) | Add takes ownership of the passed in object. TnxQueueItemList
Group

TnxQueueItemList Methods

Links
TnxQueueItemList Methods


TnxQueueItemList.Add Method (TnxQueueItemList)

TnxQueueItemList.Add Method (TnxQueueItemList)
TnxQueueItemList Class TnxQueueItemList Members nxllThreadSafeQueue Namespace Add Method Send Feedback
Syntax
Delphi
procedure Add(aList: TnxQueueItemList); overload;
Group

Add Method

Links
TnxQueueItemList Class, TnxQueueItemList Members, nxllThreadSafeQueue Namespace, Add Method


TnxQueueItemList.Add Method (TnxThreadSafeQueueItem)

TnxQueueItemList.Add Method (TnxThreadSafeQueueItem)
TnxQueueItemList Class TnxQueueItemList Members nxllThreadSafeQueue Namespace Add Method Send Feedback
Syntax
Delphi
procedure Add(aItem: TnxThreadSafeQueueItem); overload;
Description

Add takes ownership of the passed in object.

TnxQueueItemList

Group

Add Method

Links
TnxQueueItemList Class, TnxQueueItemList Members, nxllThreadSafeQueue Namespace, Add Method


TnxThreadSafeQueue Class

TnxThreadSafeQueue Class
TnxThreadSafeQueue Fields TnxThreadSafeQueue Methods TnxThreadSafeQueue Members nxllThreadSafeQueue Classes Send Feedback
Class Hierarchy
nxllThreadSafeQueue_TnxThreadSafeQueuenxllThreadSafeQueue_TnxThreadSafeQueue
Syntax
Delphi
TnxThreadSafeQueue = class(TnxObject);
File

nxllThreadSafeQueue

Description

This is class nxllThreadSafeQueue.TnxThreadSafeQueue.

Group

Classes

Links
TnxThreadSafeQueue Fields, TnxThreadSafeQueue Methods, TnxThreadSafeQueue Members, nxllThreadSafeQueue, Classes


TnxThreadSafeQueue Members

TnxThreadSafeQueue Members
TnxThreadSafeQueue Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxThreadSafeQueue.

Class

TnxThreadSafeQueue Class

Protected Fields
Name | Description
tsqDieEvent | Event handles must remain together, used as an array for WaitForMultipleObjects in Dequeue
tsqHead | must be 8/8 byte aligned for optimal performance
tsqItemsAvailableEvent | This is tsqItemsAvailableEvent, a member of class TnxThreadSafeQueue.
tsqList | This is tsqList, a member of class TnxThreadSafeQueue.
tsqListPadlock | This is tsqListPadlock, a member of class TnxThreadSafeQueue.
tsqPadding | 4 bytes
tsqTerminated | 4 bytes
Public Methods
Name | Description
Create | TnxThreadSafeQueue
Dequeue | Dequeue waits for aTimeout msecs for available items. May return nil if timeout expires or terminated.
Destroy | Caller is responsible to make sure that no threads are still operating inside the object.
Enqueue | This is the overview for the Enqueue method overload.
FreeInstance |
NewInstance | TnxObject
Terminate | Instantly terminates all waiting dequeue operations
Links
TnxThreadSafeQueue Class, Legend, Protected Fields, Public Methods


TnxThreadSafeQueue.Create Constructor

TnxThreadSafeQueue.Create Constructor
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxThreadSafeQueue

Class

TnxThreadSafeQueue Class

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Class


TnxThreadSafeQueue.Destroy Destructor

TnxThreadSafeQueue.Destroy Destructor
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

Caller is responsible to make sure that no threads are still operating inside the object.

Class

TnxThreadSafeQueue Class

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Class


TnxThreadSafeQueue Fields

TnxThreadSafeQueue Fields
TnxThreadSafeQueue Class Legend Protected Fields Send Feedback

The fields of the TnxThreadSafeQueue class are listed here.

Class

TnxThreadSafeQueue Class

Protected Fields
Name | Description
tsqDieEvent | Event handles must remain together, used as an array for WaitForMultipleObjects in Dequeue
tsqHead | must be 8/8 byte aligned for optimal performance
tsqItemsAvailableEvent | This is tsqItemsAvailableEvent, a member of class TnxThreadSafeQueue.
tsqList | This is tsqList, a member of class TnxThreadSafeQueue.
tsqListPadlock | This is tsqListPadlock, a member of class TnxThreadSafeQueue.
tsqPadding | 4 bytes
tsqTerminated | 4 bytes
Links
TnxThreadSafeQueue Class, Legend, Protected Fields


TnxThreadSafeQueue.tsqDieEvent Field

TnxThreadSafeQueue.tsqDieEvent Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqDieEvent: THandle;
Description

Event handles must remain together, used as an array for WaitForMultipleObjects in Dequeue

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqHead Field

TnxThreadSafeQueue.tsqHead Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqHead: TnxListHead;
Description

must be 8/8 byte aligned for optimal performance

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqItemsAvailableEvent Field

TnxThreadSafeQueue.tsqItemsAvailableEvent Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqItemsAvailableEvent: THandle;
Description

This is tsqItemsAvailableEvent, a member of class TnxThreadSafeQueue.

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqList Field

TnxThreadSafeQueue.tsqList Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqList: TnxQueueItemList;
Description

This is tsqList, a member of class TnxThreadSafeQueue.

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqListPadlock Field

TnxThreadSafeQueue.tsqListPadlock Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqListPadlock: TnxPadlock;
Description

This is tsqListPadlock, a member of class TnxThreadSafeQueue.

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqPadding Field

TnxThreadSafeQueue.tsqPadding Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqPadding: Integer;
Description

4 bytes

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue.tsqTerminated Field

TnxThreadSafeQueue.tsqTerminated Field
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Fields Send Feedback
Syntax
Delphi
tsqTerminated: LongBool;
Description

4 bytes

Group

TnxThreadSafeQueue Fields

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Fields


TnxThreadSafeQueue Methods

TnxThreadSafeQueue Methods
TnxThreadSafeQueue Class Legend Public Methods Send Feedback

The methods of the TnxThreadSafeQueue class are listed here.

Class

TnxThreadSafeQueue Class

Public Methods
Name | Description
Dequeue | Dequeue waits for aTimeout msecs for available items. May return nil if timeout expires or terminated.
Enqueue | This is the overview for the Enqueue method overload.
Terminate | Instantly terminates all waiting dequeue operations
Links
TnxThreadSafeQueue Class, Legend, Public Methods


TnxThreadSafeQueue.Dequeue Method

TnxThreadSafeQueue.Dequeue Method
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Methods Send Feedback
Syntax
Delphi
function Dequeue(aTimeout: Cardinal): TnxThreadSafeQueueItem;
Description

Dequeue waits for aTimeout msecs for available items. May return nil if timeout expires or terminated.

Group

TnxThreadSafeQueue Methods

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Methods


Enqueue Method

Enqueue Method
TnxThreadSafeQueue Methods Send Feedback

This is the overview for the Enqueue method overload.

Overload List
Name | Description
TnxThreadSafeQueue.Enqueue (TnxQueueItemList) |
TnxThreadSafeQueue.Enqueue (TnxThreadSafeQueueItem) | Enqueue takes ownership of the passed in object.
Group

TnxThreadSafeQueue Methods

Links
TnxThreadSafeQueue Methods


TnxThreadSafeQueue.Enqueue Method (TnxQueueItemList)

TnxThreadSafeQueue.Enqueue Method (TnxQueueItemList)
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace Enqueue Method Send Feedback
Syntax
Delphi
procedure Enqueue(aList: TnxQueueItemList); overload;
Group

Enqueue Method

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, Enqueue Method


TnxThreadSafeQueue.Enqueue Method (TnxThreadSafeQueueItem)

TnxThreadSafeQueue.Enqueue Method (TnxThreadSafeQueueItem)
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace Enqueue Method Send Feedback
Syntax
Delphi
procedure Enqueue(aItem: TnxThreadSafeQueueItem); overload;
Description

Enqueue takes ownership of the passed in object.

Group

Enqueue Method

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, Enqueue Method


TnxThreadSafeQueue.Terminate Method

TnxThreadSafeQueue.Terminate Method
TnxThreadSafeQueue Class TnxThreadSafeQueue Members nxllThreadSafeQueue Namespace TnxThreadSafeQueue Methods Send Feedback
Syntax
Delphi
procedure Terminate; virtual;
Description

Instantly terminates all waiting dequeue operations

Group

TnxThreadSafeQueue Methods

Links
TnxThreadSafeQueue Class, TnxThreadSafeQueue Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueue Methods


TnxThreadSafeQueueItem Class

TnxThreadSafeQueueItem Class
TnxThreadSafeQueueItem Fields TnxThreadSafeQueueItem Methods TnxThreadSafeQueueItem Members nxllThreadSafeQueue Classes Send Feedback
Class Hierarchy
nxllThreadSafeQueue_TnxThreadSafeQueueItemnxllThreadSafeQueue_TnxThreadSafeQueueItem
Syntax
Delphi
TnxThreadSafeQueueItem = class(TnxObject);
File

nxllThreadSafeQueue

Description

This is class nxllThreadSafeQueue.TnxThreadSafeQueueItem.

Group

Classes

Links
TnxThreadSafeQueueItem Fields, TnxThreadSafeQueueItem Methods, TnxThreadSafeQueueItem Members, nxllThreadSafeQueue, Classes


TnxThreadSafeQueueItem Members

TnxThreadSafeQueueItem Members
TnxThreadSafeQueueItem Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxThreadSafeQueueItem.

Class

TnxThreadSafeQueueItem Class

Protected Fields
Name | Description
tqiListEntry | private ClassType: TClass 4/8 bytes
Protected Methods
Name | Description
tqiItemFromEntry | TnxThreadSafeQueueItem
Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxThreadSafeQueueItem Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxThreadSafeQueueItem Fields

TnxThreadSafeQueueItem Fields
TnxThreadSafeQueueItem Class Legend Protected Fields Send Feedback

The fields of the TnxThreadSafeQueueItem class are listed here.

Class

TnxThreadSafeQueueItem Class

Protected Fields
Name | Description
tqiListEntry | private ClassType: TClass 4/8 bytes
Links
TnxThreadSafeQueueItem Class, Legend, Protected Fields


TnxThreadSafeQueueItem.tqiListEntry Field

TnxThreadSafeQueueItem.tqiListEntry Field
TnxThreadSafeQueueItem Class TnxThreadSafeQueueItem Members nxllThreadSafeQueue Namespace TnxThreadSafeQueueItem Fields Send Feedback
Syntax
Delphi
tqiListEntry: TnxListEntry;
Description

private ClassType: TClass 4/8 bytes

Group

TnxThreadSafeQueueItem Fields

Links
TnxThreadSafeQueueItem Class, TnxThreadSafeQueueItem Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueueItem Fields


TnxThreadSafeQueueItem Methods

TnxThreadSafeQueueItem Methods
TnxThreadSafeQueueItem Class Legend Protected Methods Send Feedback

The methods of the TnxThreadSafeQueueItem class are listed here.

Class

TnxThreadSafeQueueItem Class

Protected Methods
Name | Description
tqiItemFromEntry | TnxThreadSafeQueueItem
Links
TnxThreadSafeQueueItem Class, Legend, Protected Methods


TnxThreadSafeQueueItem.tqiItemFromEntry Method

TnxThreadSafeQueueItem.tqiItemFromEntry Method
TnxThreadSafeQueueItem Class TnxThreadSafeQueueItem Members nxllThreadSafeQueue Namespace TnxThreadSafeQueueItem Methods Send Feedback
Syntax
Delphi
class function tqiItemFromEntry(aListEntry: PnxListEntry): TnxThreadSafeQueueItem;
Description

TnxThreadSafeQueueItem

Group

TnxThreadSafeQueueItem Methods

Links
TnxThreadSafeQueueItem Class, TnxThreadSafeQueueItem Members, nxllThreadSafeQueue Namespace, TnxThreadSafeQueueItem Methods


Constants

Constants
Constants nxllThreadSafeQueue Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsTnxThreadSafeQueueCreateCreateEvent | Usage of resourcestrings with @ prevents compiler from creating implicit try/finally blocks.
rsTnxThreadSafeQueueDequeueResetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueResetEvent.
rsTnxThreadSafeQueueDequeueSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueSetEvent.
rsTnxThreadSafeQueueDequeueWaitForMultipleObjects | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueWaitForMultipleObjects.
rsTnxThreadSafeQueueEnqueueSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueEnqueueSetEvent.
rsTnxThreadSafeQueueTerminateSetEvent | This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueTerminateSetEvent.
Namespace

nxllThreadSafeQueue Namespace

Links
Constants, nxllThreadSafeQueue Namespace


nxllThreadSafeQueue.rsTnxThreadSafeQueueCreateCreateEvent Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueCreateCreateEvent Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueCreateCreateEvent = 'TnxThreadSafeQueue.Create/CreateEvent';
File

nxllThreadSafeQueue

Description

Usage of resourcestrings with @ prevents compiler from creating implicit try/finally blocks.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueResetEvent Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueResetEvent Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueDequeueResetEvent = 'TnxThreadSafeQueue.Dequeue/ResetEvent';
File

nxllThreadSafeQueue

Description

This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueResetEvent.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueSetEvent Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueSetEvent Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueDequeueSetEvent = 'TnxThreadSafeQueue.Dequeue/SetEvent';
File

nxllThreadSafeQueue

Description

This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueSetEvent.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueWaitForMultipleObjects Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueWaitForMultipleObjects Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueDequeueWaitForMultipleObjects = 'TnxThreadSafeQueue.Dequeue/WaitForMultipleObjects';
File

nxllThreadSafeQueue

Description

This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueDequeueWaitForMultipleObjects.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllThreadSafeQueue.rsTnxThreadSafeQueueEnqueueSetEvent Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueEnqueueSetEvent Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueEnqueueSetEvent = 'TnxThreadSafeQueue.Enqueue/SetEvent';
File

nxllThreadSafeQueue

Description

This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueEnqueueSetEvent.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllThreadSafeQueue.rsTnxThreadSafeQueueTerminateSetEvent Constant

nxllThreadSafeQueue.rsTnxThreadSafeQueueTerminateSetEvent Constant
nxllThreadSafeQueue Constants Send Feedback
Syntax
Delphi
rsTnxThreadSafeQueueTerminateSetEvent = 'TnxThreadSafeQueue.Terminate/SetEvent';
File

nxllThreadSafeQueue

Description

This is constant nxllThreadSafeQueue.rsTnxThreadSafeQueueTerminateSetEvent.

Group

Constants

Links
nxllThreadSafeQueue, Constants


nxllTransport Namespace

nxllTransport Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllTransport.

Classes
Name | Description
EnxCommandHandlerException | The base exception type used by the command handler.
EnxPluginCommandHandlerException | The base Exception class for Plug in Command handlers.
EnxTransportException | This is the exception type for transport based exceptions.
TnxBaseCommandHandler | The base for all command handlers. The command handler is responsible for translating received message into actual functionality by decoding the messages and calling the appropriate methods.
TnxBaseDirectTransport | This is the base class for all *real* transports.
TnxBasePluginCommandHandler | The base for Plugin Command handlers. A plugin command handler is responsible for decoding and executing the appropriate methods for plugins.
TnxBaseTransport | The base class for all transports.
TnxBaseTransportWrapper | This is the base class for all wrapper transports. A wrapper transports wraps another transport, e.g. for security extensions.
TnxBroadcastReply | DOM-IGNORE-BEGIN
TnxDataMessageReader | A TReader descendant for easily reading the data of a message.
TnxDataMessageStream | A stream for reading/writing message data.
TnxGetServerNamesHandler | DOM-IGNORE-BEGIN
TnxNullActiveBroadcast | This is class nxllTransport.TnxNullActiveBroadcast.
TnxReplyWriter | This is class nxllTransport.TnxReplyWriter.
TnxRequestReader | This is class nxllTransport.TnxRequestReader.
Constants
Name | Description
_nxnmRemotingChannelRequest | This is constant nxllTransport._nxnmRemotingChannelRequest.
nxcDefaultServerSearchTimeout | The default timeout for searching servers via broadcast.
rsBchAddSessionNotSupported | This is constant nxllTransport.rsBchAddSessionNotSupported.
rsBtAddSessionRequires | This is constant nxllTransport.rsBtAddSessionRequires.
rsBtRemoveSessionRequires | This is constant nxllTransport.rsBtRemoveSessionRequires.
Functions
Name | Description
nxSplitAddress | This function separates the server name in form name@address.
TransportRequestDirectCallback | TransportRequestDirectCallback
Interfaces
Name | Description
InxActiveBroadcast | This interface is returned by TnxBaseTransport.BeginBroadcast.
InxBroadcastReply | This interface is passed into InxBroadcastReplyHandler.ReplyReceived.
InxBroadcastReplyHandler | This interface has to be passed into TnxBaseTransport.BeginBroadcast.
InxSessionCallback | Interface for session callbacks.
InxSessionDataStore | This interface is (optionall) implemented by the same object as InxSessionCallback. It allows storage of additional data that remains associated with the session.
InxSessionInfo | This is class nxllTransport.InxSessionInfo.
Structs, Records, Enums
Name | Description
TnxBaseHeader | The base header for a communication messages.
TnxDataMessage | the structure for storing one data message part.
TnxDirectCallbackInfo | DOM-IGNORE-BEGIN
TnxMessageHeaderFlag | the flags that are sent with every message
TnxTransportLogOption | Log options for the transport.
TnxTransportMode | The mode of the transport.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBaseHeader | The base header for a communication messages.
PnxDataMessage | the structure for storing one data message part.
PnxDirectCallbackInfo | This is type nxllTransport.PnxDirectCallbackInfo.
TnxAddSessionEvent | Definition for the OnAddSession event.
TnxBaseTransportClass | Class definition for trnasports.
TnxChooseServerEvent | The definition for the OnChooseServer event
TnxConnectionLostEvent | The definition for the OnConnectionLost event.
TnxFindServersEvent | The definition for the OnFindServers event
TnxMessageHeaderFlags | set of Message flags
TnxRemoveSessionEvent | The definition for the OnRemoveSession event
TnxReplyCallback | Definition for the callback functions used by the transports.
TnxTransportLogOptions | Log options for the transport.
Variables
Name | Description
_nxTransportChannelExitProcess | This is variable nxllTransport._nxTransportChannelExitProcess.
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllTransport Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxCommandHandlerException | The base exception type used by the command handler.
EnxPluginCommandHandlerException | The base Exception class for Plug in Command handlers.
EnxTransportException | This is the exception type for transport based exceptions.
TnxBaseCommandHandler | The base for all command handlers. The command handler is responsible for translating received message into actual functionality by decoding the messages and calling the appropriate methods.
TnxBaseDirectTransport | This is the base class for all *real* transports.
TnxBasePluginCommandHandler | The base for Plugin Command handlers. A plugin command handler is responsible for decoding and executing the appropriate methods for plugins.
TnxBaseTransport | The base class for all transports.
TnxBaseTransportWrapper | This is the base class for all wrapper transports. A wrapper transports wraps another transport, e.g. for security extensions.
TnxBroadcastReply | DOM-IGNORE-BEGIN
TnxDataMessageReader | A TReader descendant for easily reading the data of a message.
TnxDataMessageStream | A stream for reading/writing message data.
TnxGetServerNamesHandler | DOM-IGNORE-BEGIN
TnxNullActiveBroadcast | This is class nxllTransport.TnxNullActiveBroadcast.
TnxReplyWriter | This is class nxllTransport.TnxReplyWriter.
TnxRequestReader | This is class nxllTransport.TnxRequestReader.
Namespace

nxllTransport Namespace

Links
Classes, nxllTransport Namespace, Legend


EnxCommandHandlerException Class

EnxCommandHandlerException Class
nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerExceptionnxllTransport_EnxCommandHandlerException
Syntax
Delphi
EnxCommandHandlerException = class(EnxStateComponentException);
File

nxllTransport

Description

The base exception type used by the command handler.

Group

Classes

Links
nxllTransport, Classes


EnxPluginCommandHandlerException Class

EnxPluginCommandHandlerException Class
nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerExceptionnxllTransport_EnxPluginCommandHandlerException
Syntax
Delphi
EnxPluginCommandHandlerException = class(EnxPluginException);
File

nxllTransport

Description

The base Exception class for Plug in Command handlers.

Group

Classes

Links
nxllTransport, Classes


EnxTransportException Class

EnxTransportException Class
nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportExceptionnxllTransport_EnxTransportException
Syntax
Delphi
EnxTransportException = class(EnxStateComponentException);
File

nxllTransport

Description

This is the exception type for transport based exceptions.

Group

Classes

Links
nxllTransport, Classes


TnxBaseCommandHandler Class

TnxBaseCommandHandler Class
TnxBaseCommandHandler Fields TnxBaseCommandHandler Methods TnxBaseCommandHandler Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandlernxllTransport_TnxBaseCommandHandler
Syntax
Delphi
TnxBaseCommandHandler = class(TnxStateComponent);
File

nxllTransport

Description

The base for all command handlers. The command handler is responsible for translating received message into actual functionality by decoding the messages and calling the appropriate methods.

Group

Classes

Links
TnxBaseCommandHandler Fields, TnxBaseCommandHandler Methods, TnxBaseCommandHandler Members, nxllTransport, Classes


TnxBaseCommandHandler Members

TnxBaseCommandHandler Members
TnxBaseCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseCommandHandler.

Class

TnxBaseCommandHandler Class

Protected Fields
Name | Description
bchPlugins | This is bchPlugins, a member of class TnxBaseCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bchAddSession | TnxBaseCommandHandler
bchGetServerGuid | This is bchGetServerGuid, a member of class TnxBaseCommandHandler.
bchGetServerName |
bchNotifyPluginsAddSession |
bchNotifyPluginsRemoveSession |
bchNotifyPluginsSessionFailed |
bchProcess |
bchRemoveSession |
bchSessionFailed |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Result is always set to false, cause the command handler settings are never visible in the UI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBaseCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseCommandHandler.Create Constructor

TnxBaseCommandHandler.Create Constructor
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

Class

TnxBaseCommandHandler Class

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Class


TnxBaseCommandHandler.Destroy Destructor

TnxBaseCommandHandler.Destroy Destructor
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseCommandHandler Class

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Class


TnxBaseCommandHandler Fields

TnxBaseCommandHandler Fields
TnxBaseCommandHandler Class Legend Protected Fields Send Feedback

The fields of the TnxBaseCommandHandler class are listed here.

Class

TnxBaseCommandHandler Class

Protected Fields
Name | Description
bchPlugins | This is bchPlugins, a member of class TnxBaseCommandHandler.
Links
TnxBaseCommandHandler Class, Legend, Protected Fields


TnxBaseCommandHandler.bchPlugins Field

TnxBaseCommandHandler.bchPlugins Field
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Fields Send Feedback
Syntax
Delphi
bchPlugins: TnxListSyncAccess;
Description

This is bchPlugins, a member of class TnxBaseCommandHandler.

Group

TnxBaseCommandHandler Fields

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Fields


TnxBaseCommandHandler Methods

TnxBaseCommandHandler Methods
TnxBaseCommandHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseCommandHandler class are listed here.

Class

TnxBaseCommandHandler Class

Protected Methods
Name | Description
bchAddSession | TnxBaseCommandHandler
bchGetServerGuid | This is bchGetServerGuid, a member of class TnxBaseCommandHandler.
bchGetServerName |
bchNotifyPluginsAddSession |
bchNotifyPluginsRemoveSession |
bchNotifyPluginsSessionFailed |
bchProcess |
bchRemoveSession |
bchSessionFailed |
nxcAddDependent |
nxcExceptionClass |
nxcRemoveDependent |
Public Methods
Name | Description
UISettingsVisible | Result is always set to false, cause the command handler settings are never visible in the UI.
Links
TnxBaseCommandHandler Class, Legend, Protected Methods, Public Methods


TnxBaseCommandHandler.bchAddSession Method

TnxBaseCommandHandler.bchAddSession Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
function bchAddSession(aTransport: TnxBaseTransport; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: Integer; aClientVersion: Integer; out aSessionID: TnxSessionID; out aServerVersion: Integer): TnxResult; virtual;
Description

TnxBaseCommandHandler

Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchGetServerGuid Method

TnxBaseCommandHandler.bchGetServerGuid Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
function bchGetServerGuid: TnxGuid; virtual; abstract;
Description

This is bchGetServerGuid, a member of class TnxBaseCommandHandler.

Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchGetServerName Method

TnxBaseCommandHandler.bchGetServerName Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
function bchGetServerName: string; virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchNotifyPluginsAddSession Method

TnxBaseCommandHandler.bchNotifyPluginsAddSession Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchNotifyPluginsAddSession(aTransport: TnxBaseTransport; const aUserName: UnicodeString; aSessionID: TnxSessionID; aMinVersion: Integer); virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchNotifyPluginsRemoveSession Method

TnxBaseCommandHandler.bchNotifyPluginsRemoveSession Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchNotifyPluginsRemoveSession(aTransport: TnxBaseTransport; aSessionID: TnxSessionID; aMinVersion: Integer); virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchNotifyPluginsSessionFailed Method

TnxBaseCommandHandler.bchNotifyPluginsSessionFailed Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchNotifyPluginsSessionFailed(aTransport: TnxBaseTransport; aSessionID: TnxSessionID; aMinVersion: Integer); virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchProcess Method

TnxBaseCommandHandler.bchProcess Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchProcess(aMsg: PnxDataMessage); virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchRemoveSession Method

TnxBaseCommandHandler.bchRemoveSession Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
function bchRemoveSession(aTransport: TnxBaseTransport; aSessionID: TnxSessionID): TnxResult; virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.bchSessionFailed Method

TnxBaseCommandHandler.bchSessionFailed Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bchSessionFailed(aTransport: TnxBaseTransport; aSessionID: TnxSessionID); virtual;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.nxcAddDependent Method

TnxBaseCommandHandler.nxcAddDependent Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.nxcExceptionClass Method

TnxBaseCommandHandler.nxcExceptionClass Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.nxcRemoveDependent Method

TnxBaseCommandHandler.nxcRemoveDependent Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseCommandHandler.UISettingsVisible Method

TnxBaseCommandHandler.UISettingsVisible Method
TnxBaseCommandHandler Class TnxBaseCommandHandler Members nxllTransport Namespace TnxBaseCommandHandler Methods Send Feedback
Syntax
Delphi
function UISettingsVisible: Boolean; override;
Description

Result is always set to false, cause the command handler settings are never visible in the UI.

Group

TnxBaseCommandHandler Methods

Links
TnxBaseCommandHandler Class, TnxBaseCommandHandler Members, nxllTransport Namespace, TnxBaseCommandHandler Methods


TnxBaseDirectTransport Class

TnxBaseDirectTransport Class
nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransportnxllTransport_TnxBaseDirectTransport
Syntax
Delphi
TnxBaseDirectTransport = class(TnxBaseTransport);
File

nxllTransport

Description

This is the base class for all *real* transports.

Group

Classes

Links
nxllTransport, Classes


TnxBasePluginCommandHandler Class

TnxBasePluginCommandHandler Class
TnxBasePluginCommandHandler Fields TnxBasePluginCommandHandler Methods TnxBasePluginCommandHandler Properties TnxBasePluginCommandHandler Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandlernxllTransport_TnxBasePluginCommandHandler
Syntax
Delphi
TnxBasePluginCommandHandler = class(TnxBasePlugin);
File

nxllTransport

Description

The base for Plugin Command handlers. A plugin command handler is responsible for decoding and executing the appropriate methods for plugins.

Group

Classes

Links
TnxBasePluginCommandHandler Fields, TnxBasePluginCommandHandler Methods, TnxBasePluginCommandHandler Properties, TnxBasePluginCommandHandler Members, nxllTransport, Classes


TnxBasePluginCommandHandler Members

TnxBasePluginCommandHandler Members
TnxBasePluginCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBasePluginCommandHandler.

Class

TnxBasePluginCommandHandler Class

Protected Fields
Name | Description
bpchCmdHandler | private.
bpchPluginEngine | This is bpchPluginEngine, a member of class TnxBasePluginCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpchAddSession | TnxBasePluginCommandHandler
bpchProcess | This is bpchProcess, a member of class TnxBasePluginCommandHandler.
bpchRemoveSession |
bpchSessionFailed |
bpchSetCmdHandler |
bpchSetPluginEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | This function always returns false, cause the settings should never be visible in the GUI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CommandHandler | This is the main command handler the plugin command handler is attached to.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBasePluginCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBasePluginCommandHandler Fields

TnxBasePluginCommandHandler Fields
TnxBasePluginCommandHandler Class Legend Protected Fields Send Feedback

The fields of the TnxBasePluginCommandHandler class are listed here.

Class

TnxBasePluginCommandHandler Class

Protected Fields
Name | Description
bpchCmdHandler | private.
bpchPluginEngine | This is bpchPluginEngine, a member of class TnxBasePluginCommandHandler.
Links
TnxBasePluginCommandHandler Class, Legend, Protected Fields


TnxBasePluginCommandHandler.bpchCmdHandler Field

TnxBasePluginCommandHandler.bpchCmdHandler Field
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Fields Send Feedback
Syntax
Delphi
bpchCmdHandler: TnxBaseCommandHandler;
Description

private.

Group

TnxBasePluginCommandHandler Fields

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Fields


TnxBasePluginCommandHandler.bpchPluginEngine Field

TnxBasePluginCommandHandler.bpchPluginEngine Field
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Fields Send Feedback
Syntax
Delphi
bpchPluginEngine: TnxBasePluginEngine;
Description

This is bpchPluginEngine, a member of class TnxBasePluginCommandHandler.

Group

TnxBasePluginCommandHandler Fields

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Fields


TnxBasePluginCommandHandler Methods

TnxBasePluginCommandHandler Methods
TnxBasePluginCommandHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBasePluginCommandHandler class are listed here.

Class

TnxBasePluginCommandHandler Class

Protected Methods
Name | Description
bpchAddSession | TnxBasePluginCommandHandler
bpchProcess | This is bpchProcess, a member of class TnxBasePluginCommandHandler.
bpchRemoveSession |
bpchSessionFailed |
bpchSetCmdHandler |
bpchSetPluginEngine |
nxcExceptionClass |
nxcNotification |
scIsStateParent |
scShouldFollowTransition |
Public Methods
Name | Description
UISettingsVisible | This function always returns false, cause the settings should never be visible in the GUI.
Links
TnxBasePluginCommandHandler Class, Legend, Protected Methods, Public Methods


TnxBasePluginCommandHandler.bpchAddSession Method

TnxBasePluginCommandHandler.bpchAddSession Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchAddSession(aTransport: TnxBaseTransport; const aUserName: UnicodeString; aSessionID: TnxSessionID); virtual;
Description

TnxBasePluginCommandHandler

Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.bpchProcess Method

TnxBasePluginCommandHandler.bpchProcess Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchProcess(aMsg: PnxDataMessage; var aHandled: Boolean); virtual; abstract;
Description

This is bpchProcess, a member of class TnxBasePluginCommandHandler.

Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.bpchRemoveSession Method

TnxBasePluginCommandHandler.bpchRemoveSession Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchRemoveSession(aTransport: TnxBaseTransport; aSessionID: TnxSessionID); virtual;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.bpchSessionFailed Method

TnxBasePluginCommandHandler.bpchSessionFailed Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchSessionFailed(aTransport: TnxBaseTransport; aSessionID: TnxSessionID); virtual;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.bpchSetCmdHandler Method

TnxBasePluginCommandHandler.bpchSetCmdHandler Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchSetCmdHandler(aCmdHandler: TnxBaseCommandHandler); virtual;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.bpchSetPluginEngine Method

TnxBasePluginCommandHandler.bpchSetPluginEngine Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchSetPluginEngine(anEngine: TnxBasePluginEngine); virtual;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.nxcExceptionClass Method

TnxBasePluginCommandHandler.nxcExceptionClass Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.nxcNotification Method

TnxBasePluginCommandHandler.nxcNotification Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.scIsStateParent Method

TnxBasePluginCommandHandler.scIsStateParent Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.scShouldFollowTransition Method

TnxBasePluginCommandHandler.scShouldFollowTransition Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
function scShouldFollowTransition(aSender: TnxStateComponent; aBefore: Boolean; aStateTransition: TnxStateTransition; aNewState: TnxState): Boolean; override;
Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler.UISettingsVisible Method

TnxBasePluginCommandHandler.UISettingsVisible Method
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Methods Send Feedback
Syntax
Delphi
function UISettingsVisible: Boolean; override;
Description

This function always returns false, cause the settings should never be visible in the GUI.

Group

TnxBasePluginCommandHandler Methods

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Methods


TnxBasePluginCommandHandler Properties

TnxBasePluginCommandHandler Properties
TnxBasePluginCommandHandler Class Legend Published Properties Send Feedback

The properties of the TnxBasePluginCommandHandler class are listed here.

Class

TnxBasePluginCommandHandler Class

Published Properties
Name | Description
CommandHandler | This is the main command handler the plugin command handler is attached to.
Links
TnxBasePluginCommandHandler Class, Legend, Published Properties


TnxBasePluginCommandHandler.CommandHandler Property

TnxBasePluginCommandHandler.CommandHandler Property
TnxBasePluginCommandHandler Class TnxBasePluginCommandHandler Members nxllTransport Namespace TnxBasePluginCommandHandler Properties Send Feedback
Syntax
Delphi
property CommandHandler: TnxBaseCommandHandler;
Description

This is the main command handler the plugin command handler is attached to.

Group

TnxBasePluginCommandHandler Properties

Links
TnxBasePluginCommandHandler Class, TnxBasePluginCommandHandler Members, nxllTransport Namespace, TnxBasePluginCommandHandler Properties


TnxBaseTransport Class

TnxBaseTransport Class
TnxBaseTransport Fields TnxBaseTransport Methods TnxBaseTransport Properties TnxBaseTransport Events TnxBaseTransport Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransportnxllTransport_TnxBaseTransport
Syntax
Delphi
TnxBaseTransport = class(TnxStateComponent);
File

nxllTransport

Description

The base class for all transports.

Group

Classes

Links
TnxBaseTransport Fields, TnxBaseTransport Methods, TnxBaseTransport Properties, TnxBaseTransport Events, TnxBaseTransport Members, nxllTransport, Classes


TnxBaseTransport Members

TnxBaseTransport Members
TnxBaseTransport Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBaseTransport.

Class

TnxBaseTransport Class

Protected Fields
Name | Description
btActualBytesReceived | This is btActualBytesReceived, a member of class TnxBaseTransport.
btActualBytesSent | This is btActualBytesSent, a member of class TnxBaseTransport.
btCmdHandler | This is btCmdHandler, a member of class TnxBaseTransport.
btCompressTime | This is btCompressTime, a member of class TnxBaseTransport.
btKeepStats | This is btKeepStats, a member of class TnxBaseTransport.
btLastReceived | This is btLastReceived, a member of class TnxBaseTransport.
btLastSent | This is btLastSent, a member of class TnxBaseTransport.
btLogOptions | This is btLogOptions, a member of class TnxBaseTransport.
btMaxBytesPerSecond | This is btMaxBytesPerSecond, a member of class TnxBaseTransport.
btMessagesReceived | This is btMessagesReceived, a member of class TnxBaseTransport.
btMessagesSent | This is btMessagesSent, a member of class TnxBaseTransport.
btMode | This is btMode, a member of class TnxBaseTransport.
btMsgCount | This is btMsgCount, a member of class TnxBaseTransport.
btOnAddSession | This is btOnAddSession, a member of class TnxBaseTransport.
btOnChooseServer | This is btOnChooseServer, a member of class TnxBaseTransport.
btOnConnectionLost | This is btOnConnectionLost, a member of class TnxBaseTransport.
btOnFindServers | This is btOnFindServers, a member of class TnxBaseTransport.
btOnRemoveSession | This is btOnRemoveSession, a member of class TnxBaseTransport.
btPingTime | This is btPingTime, a member of class TnxBaseTransport.
btReceivedThisSecond | This is btReceivedThisSecond, a member of class TnxBaseTransport.
btRespondToBroadcasts | This is btRespondToBroadcasts, a member of class TnxBaseTransport.
btSentThisSecond | private.
btServerNameDesigntime | This is btServerNameDesigntime, a member of class TnxBaseTransport.
btServerNameRuntime | This is btServerNameRuntime, a member of class TnxBaseTransport.
btStatsPadLock | This is btStatsPadLock, a member of class TnxBaseTransport.
btThreadPriorityMax | This is btThreadPriorityMax, a member of class TnxBaseTransport.
btThreadPriorityMin | This is btThreadPriorityMin, a member of class TnxBaseTransport.
btTimeout | This is btTimeout, a member of class TnxBaseTransport.
btUncompressedBytesReceived | This is btUncompressedBytesReceived, a member of class TnxBaseTransport.
btUncompressedBytesSent | This is btUncompressedBytesSent, a member of class TnxBaseTransport.
btUnCompressTime | This is btUnCompressTime, a member of class TnxBaseTransport.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
btAddSession | TnxBaseTransport
btCheckListener |
btCheckSender |
btCheckServerName |
btCheckupServerName |
btChooseServer |
btConnectionLost |
btDetectServer |
btDoReadThrottle |
btDoWriteThrottle |
btFindServerName |
btFindServers |
btGetActualBytesReceived |
btGetActualBytesSent |
btGetCompressTime |
btGetMaxBytesPerSecond |
btGetMessagesReceived |
btGetMessagesSent |
btGetPingTime |
btGetServerGUID |
btGetServername |
btGetUncompressedBytesReceived |
btGetUncompressedBytesSent |
btGetUncompressTime |
btIncStats |
btInternalGetSessionCallback |
btInternalReply |
btLimitThreadPriority |
btProcess |
btRemoveSession |
btSessionFailed |
btSetCmdHandler |
btSetMaxBytesPerSecond |
btSetMode |
btSetPingTime |
btSetRespondToBroadcasts |
btSetServername |
btSetServerNameDesigntime |
btSetServerNameRuntime |
btStoreSelfInThreadvar |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
BeginBroadcast | This function returns an InxActiveBroadcast and will start sending out server discovery broadcast every aInterval seconds. The broadcasting can be suspended or stopped using the returned InxActiveBroadcast interface. To get an event triggered for each reply received from a server, pass in an InxBroadcastReplyHandler. The ReplyReceived method of the passed in aHandler will be called.
Broadcast | This function initiates a broadcast for servers.
btDoCallBack | This function executes a callback function with the given parameters.
ClearStats | This function resets all statistics for the transport.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
ConnectionCount | This function returns the number of physical connections.
Create | constructor.
CurrentTransport | This function returns the currently active transport.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
EstablishConnection | This function establishes a connection and returns the session id. This function sends a request to the server and then waits for the reply.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetBoundAddresses | This function returns a list of addresses for the transport.
GetComponentID |
GetConfigSettings | Returns the Configuration settings for the UI
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetName | This function returns the name of the transport.
GetRegisteredClasses | Adds itself to the list of registered classes.
GetServerNames | This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.
GetSessionCallback | This function returns an interface that can be used to send callbacks to the session that initiated the currently active call. May return nil.
GetStatsCaptions | This function returns the captions for the statistics items.
GetStatsValues | This function returns the values for the statistics items.
IsConnected | IsConnected returns true if the current transport has an open connection.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig | Loads the transport settings.
LoadSettingsFromStream | This function loads the Transport settings from a stream using aReader.
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
Post | This functions posts a request and does NOT wait for the answer.
ProtocolName | This function returns the name of the transport.
Reply | This function is called to reply to a request
Request | This functions sends a request and waits for the answer.
ResetMsgCount | This function sets the MsgCount stats to 0.
SaveConfig | Saves the transport settings.
SaveSettingsToStream | This function saves the Transport settings to a stream using aWriter.
Sleep | This function forces the transport to sleep for aTimeOut msec.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TerminateConnection | This function closes a connection.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Write | This functions transfers the given information to the other connection point by wrapping it into a TnxDataMessage and sending it over an open connection.
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
ActualBytesReceived | The number of bytes received since the last clearing.
ActualBytesSent | The number of bytes sent since the last clearing.
CompressTime | The total time used for compressing data.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
MessagesReceived | The number of Messages received since the last clearing.
MessagesSent | The number of Messages sent since the last clearing.
MsgCount | The total number of messages transferred.
SavedActive | Can be used to save a certain state.
ServerGUID | This is ServerGUID, a member of class TnxBaseTransport.
ServerName | The Server Name. If in listening mode it's the name of the clients have to connect to. In sending mode it's the name the transport gets connected to.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
UncompressedBytesReceived | The number of bytes received after uncompression since the last clearing.
UncompressedBytesSent | The number of bytes sent after uncompression since the last clearing.
UncompressTime | The total time used for uncompressing data.
Published Events
Name | Description
OnAddSession | OnAddSession is called every time a session connects to the transport if it is in listening mode.
OnChooseServer | OnChooseServer is called in sending mode, if more than one server was found for broadcast
OnConnectionLost | OnConnectionLost is called if the transport detects a drop of a connection.
OnFindServers | OnFindServers is called before and after broadcasting for servers.
OnRemoveSession | OnAddSession is called every time a session disconnects from a transport if it is in listening mode.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CommandHandler | This property points to the connected Command Handler.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
EventLogOptions | The log options for the event.
KeepStats | Should the stats be updated or not. On high volume servers on the edge of capacity switch this off
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
MaxBytesPerSecond | This is a maximum bytes per second setting for the transport. It is experimental and helps to test the transport for slow connections.
Mode | The mode of the transport.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
PingTime | This is a minimum turnaround time setting in msec for the transport. It is experimental and helps to test the transport for slow connections.
RespondToBroadcasts | If the server is in listening it responds to broadcast requests if this property is set to true.
ServerNameDesigntime | This is the Server Name property at design time.
ServerNameRuntime | This is the Server Name property at runtime.
ThreadPriorityMax | Maximum possible Threadpriority
ThreadPriorityMin | Minimal possible Threadpriority
Timeout | The timeout of the transport in msec.
Version | Version of the component.
Links
TnxBaseTransport Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxBaseTransport.Create Constructor

TnxBaseTransport.Create Constructor
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

Class

TnxBaseTransport Class

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Class


TnxBaseTransport.Destroy Destructor

TnxBaseTransport.Destroy Destructor
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseTransport Class

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Class


TnxBaseTransport Fields

TnxBaseTransport Fields
TnxBaseTransport Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTransport class are listed here.

Class

TnxBaseTransport Class

Protected Fields
Name | Description
btActualBytesReceived | This is btActualBytesReceived, a member of class TnxBaseTransport.
btActualBytesSent | This is btActualBytesSent, a member of class TnxBaseTransport.
btCmdHandler | This is btCmdHandler, a member of class TnxBaseTransport.
btCompressTime | This is btCompressTime, a member of class TnxBaseTransport.
btKeepStats | This is btKeepStats, a member of class TnxBaseTransport.
btLastReceived | This is btLastReceived, a member of class TnxBaseTransport.
btLastSent | This is btLastSent, a member of class TnxBaseTransport.
btLogOptions | This is btLogOptions, a member of class TnxBaseTransport.
btMaxBytesPerSecond | This is btMaxBytesPerSecond, a member of class TnxBaseTransport.
btMessagesReceived | This is btMessagesReceived, a member of class TnxBaseTransport.
btMessagesSent | This is btMessagesSent, a member of class TnxBaseTransport.
btMode | This is btMode, a member of class TnxBaseTransport.
btMsgCount | This is btMsgCount, a member of class TnxBaseTransport.
btOnAddSession | This is btOnAddSession, a member of class TnxBaseTransport.
btOnChooseServer | This is btOnChooseServer, a member of class TnxBaseTransport.
btOnConnectionLost | This is btOnConnectionLost, a member of class TnxBaseTransport.
btOnFindServers | This is btOnFindServers, a member of class TnxBaseTransport.
btOnRemoveSession | This is btOnRemoveSession, a member of class TnxBaseTransport.
btPingTime | This is btPingTime, a member of class TnxBaseTransport.
btReceivedThisSecond | This is btReceivedThisSecond, a member of class TnxBaseTransport.
btRespondToBroadcasts | This is btRespondToBroadcasts, a member of class TnxBaseTransport.
btSentThisSecond | private.
btServerNameDesigntime | This is btServerNameDesigntime, a member of class TnxBaseTransport.
btServerNameRuntime | This is btServerNameRuntime, a member of class TnxBaseTransport.
btStatsPadLock | This is btStatsPadLock, a member of class TnxBaseTransport.
btThreadPriorityMax | This is btThreadPriorityMax, a member of class TnxBaseTransport.
btThreadPriorityMin | This is btThreadPriorityMin, a member of class TnxBaseTransport.
btTimeout | This is btTimeout, a member of class TnxBaseTransport.
btUncompressedBytesReceived | This is btUncompressedBytesReceived, a member of class TnxBaseTransport.
btUncompressedBytesSent | This is btUncompressedBytesSent, a member of class TnxBaseTransport.
btUnCompressTime | This is btUnCompressTime, a member of class TnxBaseTransport.
Links
TnxBaseTransport Class, Legend, Protected Fields


TnxBaseTransport.btActualBytesReceived Field

TnxBaseTransport.btActualBytesReceived Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btActualBytesReceived: TnxInt64;
Description

This is btActualBytesReceived, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btActualBytesSent Field

TnxBaseTransport.btActualBytesSent Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btActualBytesSent: TnxInt64;
Description

This is btActualBytesSent, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btCmdHandler Field

TnxBaseTransport.btCmdHandler Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btCmdHandler: TnxBaseCommandHandler;
Description

This is btCmdHandler, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btCompressTime Field

TnxBaseTransport.btCompressTime Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btCompressTime: TnxInt64;
Description

This is btCompressTime, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btKeepStats Field

TnxBaseTransport.btKeepStats Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btKeepStats: Boolean;
Description

This is btKeepStats, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btLastReceived Field

TnxBaseTransport.btLastReceived Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btLastReceived: tnxWord32;
Description

This is btLastReceived, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btLastSent Field

TnxBaseTransport.btLastSent Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btLastSent: TnxWord32;
Description

This is btLastSent, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btLogOptions Field

TnxBaseTransport.btLogOptions Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btLogOptions: TnxTransportLogOptions;
Description

This is btLogOptions, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btMaxBytesPerSecond Field

TnxBaseTransport.btMaxBytesPerSecond Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btMaxBytesPerSecond: tnxWord32;
Description

This is btMaxBytesPerSecond, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btMessagesReceived Field

TnxBaseTransport.btMessagesReceived Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btMessagesReceived: TnxInt64;
Description

This is btMessagesReceived, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btMessagesSent Field

TnxBaseTransport.btMessagesSent Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btMessagesSent: TnxInt64;
Description

This is btMessagesSent, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btMode Field

TnxBaseTransport.btMode Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btMode: TnxTransportMode;
Description

This is btMode, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btMsgCount Field

TnxBaseTransport.btMsgCount Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btMsgCount: Integer;
Description

This is btMsgCount, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btOnAddSession Field

TnxBaseTransport.btOnAddSession Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btOnAddSession: TnxAddSessionEvent;
Description

This is btOnAddSession, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btOnChooseServer Field

TnxBaseTransport.btOnChooseServer Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btOnChooseServer: TnxChooseServerEvent;
Description

This is btOnChooseServer, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btOnConnectionLost Field

TnxBaseTransport.btOnConnectionLost Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btOnConnectionLost: TnxConnectionLostEvent;
Description

This is btOnConnectionLost, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btOnFindServers Field

TnxBaseTransport.btOnFindServers Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btOnFindServers: TnxFindServersEvent;
Description

This is btOnFindServers, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btOnRemoveSession Field

TnxBaseTransport.btOnRemoveSession Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btOnRemoveSession: TnxRemoveSessionEvent;
Description

This is btOnRemoveSession, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btPingTime Field

TnxBaseTransport.btPingTime Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btPingTime: TnxWord32;
Description

This is btPingTime, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btReceivedThisSecond Field

TnxBaseTransport.btReceivedThisSecond Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btReceivedThisSecond: TnxWord32;
Description

This is btReceivedThisSecond, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btRespondToBroadcasts Field

TnxBaseTransport.btRespondToBroadcasts Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btRespondToBroadcasts: Boolean;
Description

This is btRespondToBroadcasts, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btSentThisSecond Field

TnxBaseTransport.btSentThisSecond Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btSentThisSecond: TnxWord32;
Description

private.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btServerNameDesigntime Field

TnxBaseTransport.btServerNameDesigntime Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btServerNameDesigntime: string;
Description

This is btServerNameDesigntime, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btServerNameRuntime Field

TnxBaseTransport.btServerNameRuntime Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btServerNameRuntime: string;
Description

This is btServerNameRuntime, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btStatsPadLock Field

TnxBaseTransport.btStatsPadLock Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btStatsPadLock: TnxPadlock;
Description

This is btStatsPadLock, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btThreadPriorityMax Field

TnxBaseTransport.btThreadPriorityMax Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btThreadPriorityMax: TnxThreadPriority;
Description

This is btThreadPriorityMax, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btThreadPriorityMin Field

TnxBaseTransport.btThreadPriorityMin Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btThreadPriorityMin: TnxThreadPriority;
Description

This is btThreadPriorityMin, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btTimeout Field

TnxBaseTransport.btTimeout Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btTimeout: TnxWord32;
Description

This is btTimeout, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btUncompressedBytesReceived Field

TnxBaseTransport.btUncompressedBytesReceived Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btUncompressedBytesReceived: TnxInt64;
Description

This is btUncompressedBytesReceived, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btUncompressedBytesSent Field

TnxBaseTransport.btUncompressedBytesSent Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btUncompressedBytesSent: TnxInt64;
Description

This is btUncompressedBytesSent, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport.btUnCompressTime Field

TnxBaseTransport.btUnCompressTime Field
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Fields Send Feedback
Syntax
Delphi
btUnCompressTime: TnxInt64;
Description

This is btUnCompressTime, a member of class TnxBaseTransport.

Group

TnxBaseTransport Fields

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Fields


TnxBaseTransport Methods

TnxBaseTransport Methods
TnxBaseTransport Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTransport class are listed here.

Class

TnxBaseTransport Class

Protected Methods
Name | Description
btAddSession | TnxBaseTransport
btCheckListener |
btCheckSender |
btCheckServerName |
btCheckupServerName |
btChooseServer |
btConnectionLost |
btDetectServer |
btDoReadThrottle |
btDoWriteThrottle |
btFindServerName |
btFindServers |
btGetActualBytesReceived |
btGetActualBytesSent |
btGetCompressTime |
btGetMaxBytesPerSecond |
btGetMessagesReceived |
btGetMessagesSent |
btGetPingTime |
btGetServerGUID |
btGetServername |
btGetUncompressedBytesReceived |
btGetUncompressedBytesSent |
btGetUncompressTime |
btIncStats |
btInternalGetSessionCallback |
btInternalReply |
btLimitThreadPriority |
btProcess |
btRemoveSession |
btSessionFailed |
btSetCmdHandler |
btSetMaxBytesPerSecond |
btSetMode |
btSetPingTime |
btSetRespondToBroadcasts |
btSetServername |
btSetServerNameDesigntime |
btSetServerNameRuntime |
btStoreSelfInThreadvar |
Loaded |
nxcExceptionClass |
nxcNotification |
scInitializing |
scIsStateParent |
scShowLastStartErrorInStats |
scShowUpTime |
Public Methods
Name | Description
BeginBroadcast | This function returns an InxActiveBroadcast and will start sending out server discovery broadcast every aInterval seconds. The broadcasting can be suspended or stopped using the returned InxActiveBroadcast interface. To get an event triggered for each reply received from a server, pass in an InxBroadcastReplyHandler. The ReplyReceived method of the passed in aHandler will be called.
Broadcast | This function initiates a broadcast for servers.
btDoCallBack | This function executes a callback function with the given parameters.
ClearStats | This function resets all statistics for the transport.
ConnectionCount | This function returns the number of physical connections.
CurrentTransport | This function returns the currently active transport.
EstablishConnection | This function establishes a connection and returns the session id. This function sends a request to the server and then waits for the reply.
GetBoundAddresses | This function returns a list of addresses for the transport.
GetConfigSettings | Returns the Configuration settings for the UI
GetName | This function returns the name of the transport.
GetServerNames | This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.
GetSessionCallback | This function returns an interface that can be used to send callbacks to the session that initiated the currently active call. May return nil.
GetStatsCaptions | This function returns the captions for the statistics items.
GetStatsValues | This function returns the values for the statistics items.
IsConnected | IsConnected returns true if the current transport has an open connection.
LoadConfig | Loads the transport settings.
LoadSettingsFromStream | This function loads the Transport settings from a stream using aReader.
Post | This functions posts a request and does NOT wait for the answer.
ProtocolName | This function returns the name of the transport.
Reply | This function is called to reply to a request
Request | This functions sends a request and waits for the answer.
ResetMsgCount | This function sets the MsgCount stats to 0.
SaveConfig | Saves the transport settings.
SaveSettingsToStream | This function saves the Transport settings to a stream using aWriter.
Sleep | This function forces the transport to sleep for aTimeOut msec.
TerminateConnection | This function closes a connection.
Write | This functions transfers the given information to the other connection point by wrapping it into a TnxDataMessage and sending it over an open connection.
Links
TnxBaseTransport Class, Legend, Protected Methods, Public Methods


TnxBaseTransport.BeginBroadcast Method

TnxBaseTransport.BeginBroadcast Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function BeginBroadcast(aHandler: InxBroadcastReplyHandler; aInterval: Integer): InxActiveBroadcast; virtual; abstract;
Description

This function returns an InxActiveBroadcast and will start sending out server discovery broadcast every aInterval seconds. The broadcasting can be suspended or stopped using the returned InxActiveBroadcast interface. To get an event triggered for each reply received from a server, pass in an InxBroadcastReplyHandler. The ReplyReceived method of the passed in aHandler will be called.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Broadcast Method

TnxBaseTransport.Broadcast Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure Broadcast(aMsgID: TnxMsgID; aThreadPriority: TnxThreadPriority; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer); virtual; abstract;
Parameters
Parameters | Description
aMsgID: TnxMsgID | the id of the message
aRequestData: Pointer | the data of the broadcast request
aRequestDataLen: TnxWord32 | the length of aRequestData
aTimeOut: Integer | timeout in msec
Description

This function initiates a broadcast for servers.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btAddSession Method

TnxBaseTransport.btAddSession Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btAddSession(const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: Integer; aClientVersion: Integer; out aSessionID: TnxSessionID; out aServerVersion: Integer): TnxResult; virtual;
Description

TnxBaseTransport

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btCheckListener Method

TnxBaseTransport.btCheckListener Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btCheckListener;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btCheckSender Method

TnxBaseTransport.btCheckSender Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btCheckSender;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btCheckServerName Method

TnxBaseTransport.btCheckServerName Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btCheckServerName;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btCheckupServerName Method

TnxBaseTransport.btCheckupServerName Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btCheckupServerName(const aServerName: string): string; virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btChooseServer Method

TnxBaseTransport.btChooseServer Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btChooseServer(out aServerName: string);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btConnectionLost Method

TnxBaseTransport.btConnectionLost Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btConnectionLost(aSessionID: TnxSessionID);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btDetectServer Method

TnxBaseTransport.btDetectServer Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btDetectServer;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btDoCallBack Method

TnxBaseTransport.btDoCallBack Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btDoCallBack(aReplyCallback: TnxReplyCallback; aMsgID: TnxMsgID; aErrorCode: TnxResult; aReplyData: Pointer; aReplyDataLen: Integer; aReplyCookie: Pointer; aReplyCompressedSize: integer = 0);
Parameters
Parameters | Description
aReplyCallback: TnxReplyCallback | the pointer to the callback function that should be called
aMsgID: TnxMsgID | the message id
aErrorCode: TnxResult | the error code to be transferred
aReplyData: Pointer | the data returned for the request
aReplyDataLen: Integer | the length of aReplyData
aReplyCookie: Pointer | additional info to be returned
aReplyCompressedSize: integer = 0 | the compressed data size
Description

This function executes a callback function with the given parameters.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btDoReadThrottle Method

TnxBaseTransport.btDoReadThrottle Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btDoReadThrottle(bytesread: TnxWord32);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btDoWriteThrottle Method

TnxBaseTransport.btDoWriteThrottle Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btDoWriteThrottle(bytesread: TnxWord32);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btFindServerName Method

TnxBaseTransport.btFindServerName Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btFindServerName;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btFindServers Method

TnxBaseTransport.btFindServers Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btFindServers(aStarting: Boolean);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetActualBytesReceived Method

TnxBaseTransport.btGetActualBytesReceived Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetActualBytesReceived: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetActualBytesSent Method

TnxBaseTransport.btGetActualBytesSent Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetActualBytesSent: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetCompressTime Method

TnxBaseTransport.btGetCompressTime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetCompressTime: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetMaxBytesPerSecond Method

TnxBaseTransport.btGetMaxBytesPerSecond Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetMaxBytesPerSecond: TnxWord32;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetMessagesReceived Method

TnxBaseTransport.btGetMessagesReceived Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetMessagesReceived: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetMessagesSent Method

TnxBaseTransport.btGetMessagesSent Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetMessagesSent: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetPingTime Method

TnxBaseTransport.btGetPingTime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetPingTime: TnxWord32;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetServerGUID Method

TnxBaseTransport.btGetServerGUID Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetServerGUID: TnxGuid;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetServername Method

TnxBaseTransport.btGetServername Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetServername: string;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetUncompressedBytesReceived Method

TnxBaseTransport.btGetUncompressedBytesReceived Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetUncompressedBytesReceived: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetUncompressedBytesSent Method

TnxBaseTransport.btGetUncompressedBytesSent Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetUncompressedBytesSent: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btGetUncompressTime Method

TnxBaseTransport.btGetUncompressTime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btGetUncompressTime: TnxInt64;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btIncStats Method

TnxBaseTransport.btIncStats Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btIncStats(aMessageSent: TnxWord32; aUncompressedSizeSent: TnxWord32; aActualSent: TnxWord32; aMessageReceived: TnxWord32; aUncompressedSizeReceived: TnxWord32; aActualReceived: TnxWord32; aCompressTime: TnxWord32 = 0; aunCompressTime: TnxWord32 = 0);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btInternalGetSessionCallback Method

TnxBaseTransport.btInternalGetSessionCallback Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btInternalGetSessionCallback: InxSessionCallback; virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btInternalReply Method

TnxBaseTransport.btInternalReply Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btInternalReply(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReplyData: Pointer; aReplyDataLen: TnxWord32); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btLimitThreadPriority Method

TnxBaseTransport.btLimitThreadPriority Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btLimitThreadPriority(aThreadPriority: TnxThreadPriority): TnxThreadPriority;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btProcess Method

TnxBaseTransport.btProcess Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btProcess(aMsg: PnxDataMessage); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btRemoveSession Method

TnxBaseTransport.btRemoveSession Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function btRemoveSession(aSessionID: TnxSessionID): TnxResult; virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSessionFailed Method

TnxBaseTransport.btSessionFailed Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSessionFailed(aSessionID: TnxSessionID); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetCmdHandler Method

TnxBaseTransport.btSetCmdHandler Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetCmdHandler(aCmdHandler: TnxBaseCommandHandler); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetMaxBytesPerSecond Method

TnxBaseTransport.btSetMaxBytesPerSecond Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetMaxBytesPerSecond(const Value: TnxWord32);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetMode Method

TnxBaseTransport.btSetMode Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetMode(const aMode: TnxTransportMode); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetPingTime Method

TnxBaseTransport.btSetPingTime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetPingTime(const Value: TnxWord32);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetRespondToBroadcasts Method

TnxBaseTransport.btSetRespondToBroadcasts Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetRespondToBroadcasts(const aRespond: Boolean); virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetServername Method

TnxBaseTransport.btSetServername Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetServername(const Value: string);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetServerNameDesigntime Method

TnxBaseTransport.btSetServerNameDesigntime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetServerNameDesigntime(Value: string);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btSetServerNameRuntime Method

TnxBaseTransport.btSetServerNameRuntime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btSetServerNameRuntime(Value: string);
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.btStoreSelfInThreadvar Method

TnxBaseTransport.btStoreSelfInThreadvar Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure btStoreSelfInThreadvar; virtual;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.ClearStats Method

TnxBaseTransport.ClearStats Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure ClearStats; override;
Description

This function resets all statistics for the transport.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.ConnectionCount Method

TnxBaseTransport.ConnectionCount Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function ConnectionCount: Integer; virtual; abstract;
Description

This function returns the number of physical connections.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.CurrentTransport Method

TnxBaseTransport.CurrentTransport Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
class function CurrentTransport: TnxBaseTransport;
Description

This function returns the currently active transport.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.EstablishConnection Method

TnxBaseTransport.EstablishConnection Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function EstablishConnection(aTransportID: TnxTransportID; const aUserName: UnicodeString; const aPassword: UnicodeString; aTimeOut: Integer; aClientVersion: Integer; out aServerVersion: Integer; out aSessionID: TnxSessionID): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aTransportID: TnxTransportID | the id of the transport
const aUserName: UnicodeString | the user name used to connect
const aPassword: UnicodeString | the password used to connect
aTimeOut: Integer | timeout in msec
out aSessionID: TnxSessionID | the session id for the connection
Description

This function establishes a connection and returns the session id. This function sends a request to the server and then waits for the reply.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetBoundAddresses Method

TnxBaseTransport.GetBoundAddresses Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure GetBoundAddresses(aList: TStrings); virtual;
Description

This function returns a list of addresses for the transport.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetConfigSettings Method

TnxBaseTransport.GetConfigSettings Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Description

Returns the Configuration settings for the UI

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetName Method

TnxBaseTransport.GetName Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function GetName: string; virtual; abstract;
Description

This function returns the name of the transport.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetServerNames Method

TnxBaseTransport.GetServerNames Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure GetServerNames(aList: TStrings; aTimeOut: TnxWord32); virtual;
Description

This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetSessionCallback Method

TnxBaseTransport.GetSessionCallback Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
class function GetSessionCallback: InxSessionCallback;
Description

This function returns an interface that can be used to send callbacks to the session that initiated the currently active call. May return nil.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetStatsCaptions Method

TnxBaseTransport.GetStatsCaptions Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); override;
Description

This function returns the captions for the statistics items.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.GetStatsValues Method

TnxBaseTransport.GetStatsValues Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); override;
Description

This function returns the values for the statistics items.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.IsConnected Method

TnxBaseTransport.IsConnected Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function IsConnected: Boolean; virtual; abstract;
Description

IsConnected returns true if the current transport has an open connection.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.LoadConfig Method

TnxBaseTransport.LoadConfig Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Description

Loads the transport settings.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Loaded Method

TnxBaseTransport.Loaded Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure Loaded; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.LoadSettingsFromStream Method

TnxBaseTransport.LoadSettingsFromStream Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); override;
Description

This function loads the Transport settings from a stream using aReader.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.nxcExceptionClass Method

TnxBaseTransport.nxcExceptionClass Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.nxcNotification Method

TnxBaseTransport.nxcNotification Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Post Method

TnxBaseTransport.Post Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure Post(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer); virtual; abstract;
Parameters
Parameters | Description
aTransportID: TnxTransportID | generally the current transport id
aSessionID: TnxSessionID | the session id
aMsgID: TnxMsgID | the message id
aRequestData: Pointer | the data of the broadcast request
aRequestDataLen: TnxWord32 | the length of aRequestData
aTimeOut: Integer | timeout in msec
Description

This functions posts a request and does NOT wait for the answer.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.ProtocolName Method

TnxBaseTransport.ProtocolName Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
class function ProtocolName: string; virtual;
Description

This function returns the name of the transport.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Reply Method

TnxBaseTransport.Reply Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
class procedure Reply(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReplyData: Pointer; aReplyDataLen: TnxWord32);
Parameters
Parameters | Description
aMsgID: TnxMsgID | the message id to reply to
aErrorCode: TnxResult | the error code to be returned
aReplyData: Pointer | the data to be returned
aReplyDataLen: TnxWord32 | the length of aReplyData
Description

This function is called to reply to a request

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Request Method

TnxBaseTransport.Request Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure Request(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeOut: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer); virtual; abstract;
Parameters
Parameters | Description
aTransportID: TnxTransportID | generally the current transport id
aSessionID: TnxSessionID | the session id
aMsgID: TnxMsgID | the message id
aTimeOut: Integer | timeout in msec
aRequestData: Pointer | the data of the broadcast request
aRequestDataLen: TnxWord32 | the length of aRequestData
aReplyCallback: TnxReplyCallback | the callback function to be called once the reply arrived.
aReplyCookie: Pointer | additional information received.
Description

This functions sends a request and waits for the answer.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.ResetMsgCount Method

TnxBaseTransport.ResetMsgCount Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure ResetMsgCount; virtual;
Description

This function sets the MsgCount stats to 0.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.SaveConfig Method

TnxBaseTransport.SaveConfig Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Description

Saves the transport settings.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.SaveSettingsToStream Method

TnxBaseTransport.SaveSettingsToStream Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); override;
Description

This function saves the Transport settings to a stream using aWriter.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.scInitializing Method

TnxBaseTransport.scInitializing Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.scIsStateParent Method

TnxBaseTransport.scIsStateParent Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.scShowLastStartErrorInStats Method

TnxBaseTransport.scShowLastStartErrorInStats Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function scShowLastStartErrorInStats: Boolean; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.scShowUpTime Method

TnxBaseTransport.scShowUpTime Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function scShowUpTime: Boolean; override;
Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Sleep Method

TnxBaseTransport.Sleep Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
function Sleep(const aTimeOut: Integer): Boolean; virtual;
Description

This function forces the transport to sleep for aTimeOut msec.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.TerminateConnection Method

TnxBaseTransport.TerminateConnection Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure TerminateConnection(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aTimeOut: Integer); virtual; abstract;
Parameters
Parameters | Description
aTransportID: TnxTransportID | the transport
aSessionID: TnxSessionID | the session to be disconnected
aTimeOut: Integer | timeout in msec
Description

This function closes a connection.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport.Write Method

TnxBaseTransport.Write Method
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Methods Send Feedback
Syntax
Delphi
procedure Write(aConnection: Pointer; aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aMsgType: Byte; aErrorCode: TnxResult; aCompressType: Byte; aUncompressedSize: TnxWord32; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Parameters
Parameters | Description
aConnection: Pointer | the connection to be used
aTransportID: TnxTransportID | generally the current transport id
aMsgID: TnxMsgID | the message id
aMsgType: Byte | the type of the message
aErrorCode: TnxResult | the error code to be transferred
aCompressType: Byte | the type of compression used for the data
aUncompressedSize: TnxWord32 | the uncompressed size of the message
aBuffer: Pointer | the data
aBufferSize: TnxWord32 | the length of aBuffer in bytes
aRequestID | the request id
Description

This functions transfers the given information to the other connection point by wrapping it into a TnxDataMessage and sending it over an open connection.

Group

TnxBaseTransport Methods

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Methods


TnxBaseTransport Properties

TnxBaseTransport Properties
TnxBaseTransport Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBaseTransport class are listed here.

Class

TnxBaseTransport Class

Public Properties
Name | Description
ActualBytesReceived | The number of bytes received since the last clearing.
ActualBytesSent | The number of bytes sent since the last clearing.
CompressTime | The total time used for compressing data.
MessagesReceived | The number of Messages received since the last clearing.
MessagesSent | The number of Messages sent since the last clearing.
MsgCount | The total number of messages transferred.
ServerGUID | This is ServerGUID, a member of class TnxBaseTransport.
ServerName | The Server Name. If in listening mode it's the name of the clients have to connect to. In sending mode it's the name the transport gets connected to.
UncompressedBytesReceived | The number of bytes received after uncompression since the last clearing.
UncompressedBytesSent | The number of bytes sent after uncompression since the last clearing.
UncompressTime | The total time used for uncompressing data.
Published Properties
Name | Description
CommandHandler | This property points to the connected Command Handler.
EventLogOptions | The log options for the event.
KeepStats | Should the stats be updated or not. On high volume servers on the edge of capacity switch this off
MaxBytesPerSecond | This is a maximum bytes per second setting for the transport. It is experimental and helps to test the transport for slow connections.
Mode | The mode of the transport.
PingTime | This is a minimum turnaround time setting in msec for the transport. It is experimental and helps to test the transport for slow connections.
RespondToBroadcasts | If the server is in listening it responds to broadcast requests if this property is set to true.
ServerNameDesigntime | This is the Server Name property at design time.
ServerNameRuntime | This is the Server Name property at runtime.
ThreadPriorityMax | Maximum possible Threadpriority
ThreadPriorityMin | Minimal possible Threadpriority
Timeout | The timeout of the transport in msec.
Links
TnxBaseTransport Class, Legend, Public Properties, Published Properties


TnxBaseTransport.ActualBytesReceived Property

TnxBaseTransport.ActualBytesReceived Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ActualBytesReceived: TnxInt64;
Description

The number of bytes received since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ActualBytesSent Property

TnxBaseTransport.ActualBytesSent Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ActualBytesSent: TnxInt64;
Description

The number of bytes sent since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.CommandHandler Property

TnxBaseTransport.CommandHandler Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property CommandHandler: TnxBaseCommandHandler;
Description

This property points to the connected Command Handler.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.CompressTime Property

TnxBaseTransport.CompressTime Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property CompressTime: TnxInt64;
Description

The total time used for compressing data.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.EventLogOptions Property

TnxBaseTransport.EventLogOptions Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property EventLogOptions: TnxTransportLogOptions;
Description

The log options for the event.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.KeepStats Property

TnxBaseTransport.KeepStats Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property KeepStats: Boolean;
Description

Should the stats be updated or not. On high volume servers on the edge of capacity switch this off

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.MaxBytesPerSecond Property

TnxBaseTransport.MaxBytesPerSecond Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property MaxBytesPerSecond: TnxWord32;
Description

This is a maximum bytes per second setting for the transport. It is experimental and helps to test the transport for slow connections.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.MessagesReceived Property

TnxBaseTransport.MessagesReceived Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property MessagesReceived: TnxInt64;
Description

The number of Messages received since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.MessagesSent Property

TnxBaseTransport.MessagesSent Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property MessagesSent: TnxInt64;
Description

The number of Messages sent since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.Mode Property

TnxBaseTransport.Mode Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property Mode: TnxTransportMode;
Description

The mode of the transport.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.MsgCount Property

TnxBaseTransport.MsgCount Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property MsgCount: Integer;
Description

The total number of messages transferred.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.PingTime Property

TnxBaseTransport.PingTime Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property PingTime: TnxWord32;
Description

This is a minimum turnaround time setting in msec for the transport. It is experimental and helps to test the transport for slow connections.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.RespondToBroadcasts Property

TnxBaseTransport.RespondToBroadcasts Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property RespondToBroadcasts: Boolean;
Description

If the server is in listening it responds to broadcast requests if this property is set to true.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ServerGUID Property

TnxBaseTransport.ServerGUID Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ServerGUID: TnxGuid;
Description

This is ServerGUID, a member of class TnxBaseTransport.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ServerName Property

TnxBaseTransport.ServerName Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ServerName: string;
Description

The Server Name. If in listening mode it's the name of the clients have to connect to. In sending mode it's the name the transport gets connected to.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ServerNameDesigntime Property

TnxBaseTransport.ServerNameDesigntime Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ServerNameDesigntime: string;
Description

This is the Server Name property at design time.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ServerNameRuntime Property

TnxBaseTransport.ServerNameRuntime Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ServerNameRuntime: string;
Description

This is the Server Name property at runtime.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ThreadPriorityMax Property

TnxBaseTransport.ThreadPriorityMax Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ThreadPriorityMax: TnxThreadPriority;
Description

Maximum possible Threadpriority

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.ThreadPriorityMin Property

TnxBaseTransport.ThreadPriorityMin Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property ThreadPriorityMin: TnxThreadPriority;
Description

Minimal possible Threadpriority

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.Timeout Property

TnxBaseTransport.Timeout Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

The timeout of the transport in msec.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.UncompressedBytesReceived Property

TnxBaseTransport.UncompressedBytesReceived Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property UncompressedBytesReceived: TnxInt64;
Description

The number of bytes received after uncompression since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.UncompressedBytesSent Property

TnxBaseTransport.UncompressedBytesSent Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property UncompressedBytesSent: TnxInt64;
Description

The number of bytes sent after uncompression since the last clearing.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport.UncompressTime Property

TnxBaseTransport.UncompressTime Property
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Properties Send Feedback
Syntax
Delphi
property UncompressTime: TnxInt64;
Description

The total time used for uncompressing data.

Group

TnxBaseTransport Properties

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Properties


TnxBaseTransport Events

TnxBaseTransport Events
TnxBaseTransport Class Legend Published Events Send Feedback

The events of the TnxBaseTransport class are listed here.

Class

TnxBaseTransport Class

Published Events
Name | Description
OnAddSession | OnAddSession is called every time a session connects to the transport if it is in listening mode.
OnChooseServer | OnChooseServer is called in sending mode, if more than one server was found for broadcast
OnConnectionLost | OnConnectionLost is called if the transport detects a drop of a connection.
OnFindServers | OnFindServers is called before and after broadcasting for servers.
OnRemoveSession | OnAddSession is called every time a session disconnects from a transport if it is in listening mode.
Links
TnxBaseTransport Class, Legend, Published Events


TnxBaseTransport.OnAddSession Event

TnxBaseTransport.OnAddSession Event
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Events Send Feedback
Syntax
Delphi
property OnAddSession: TnxAddSessionEvent;
Description

OnAddSession is called every time a session connects to the transport if it is in listening mode.

Group

TnxBaseTransport Events

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Events


TnxBaseTransport.OnChooseServer Event

TnxBaseTransport.OnChooseServer Event
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Events Send Feedback
Syntax
Delphi
property OnChooseServer: TnxChooseServerEvent;
Description

OnChooseServer is called in sending mode, if more than one server was found for broadcast

Group

TnxBaseTransport Events

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Events


TnxBaseTransport.OnConnectionLost Event

TnxBaseTransport.OnConnectionLost Event
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Events Send Feedback
Syntax
Delphi
property OnConnectionLost: TnxConnectionLostEvent;
Description

OnConnectionLost is called if the transport detects a drop of a connection.

Group

TnxBaseTransport Events

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Events


TnxBaseTransport.OnFindServers Event

TnxBaseTransport.OnFindServers Event
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Events Send Feedback
Syntax
Delphi
property OnFindServers: TnxFindServersEvent;
Description

OnFindServers is called before and after broadcasting for servers.

Group

TnxBaseTransport Events

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Events


TnxBaseTransport.OnRemoveSession Event

TnxBaseTransport.OnRemoveSession Event
TnxBaseTransport Class TnxBaseTransport Members nxllTransport Namespace TnxBaseTransport Events Send Feedback
Syntax
Delphi
property OnRemoveSession: TnxRemoveSessionEvent;
Description

OnAddSession is called every time a session disconnects from a transport if it is in listening mode.

Group

TnxBaseTransport Events

Links
TnxBaseTransport Class, TnxBaseTransport Members, nxllTransport Namespace, TnxBaseTransport Events


TnxBaseTransportWrapper Class

TnxBaseTransportWrapper Class
nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrappernxllTransport_TnxBaseTransportWrapper
Syntax
Delphi
TnxBaseTransportWrapper = class(TnxBaseTransport);
File

nxllTransport

Description

This is the base class for all wrapper transports. A wrapper transports wraps another transport, e.g. for security extensions.

Group

Classes

Links
nxllTransport, Classes


TnxBroadcastReply Class

TnxBroadcastReply Class
Create Constructor TnxBroadcastReply Fields TnxBroadcastReply Methods TnxBroadcastReply Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxBroadcastReplynxllTransport_TnxBroadcastReplynxllTransport_TnxBroadcastReplynxllTransport_TnxBroadcastReply
Syntax
Delphi
TnxBroadcastReply = class(TnxInterfacedObject, InxBroadcastReply);
File

nxllTransport

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
Create Constructor, TnxBroadcastReply Fields, TnxBroadcastReply Methods, TnxBroadcastReply Members, nxllTransport, Classes


TnxBroadcastReply Members

TnxBroadcastReply Members
TnxBroadcastReply Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBroadcastReply.

Class

TnxBroadcastReply Class

Protected Fields
Name | Description
brServerID | This is brServerID, a member of class TnxBroadcastReply.
brServerName | private
brServerVersion | This is brServerVersion, a member of class TnxBroadcastReply.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
GetServerID |
GetServerName | InxBroadcastReply
GetServerVersion |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | This is the overview for the Create constructor overload.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxBroadcastReply Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBroadcastReply Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBroadcastReply.Create (string, string, string) |
TnxBroadcastReply.Create (string, TnxGuid, Integer) | TnxBroadcastReply
Class

TnxBroadcastReply Class

Links
TnxBroadcastReply Class


TnxBroadcastReply.Create Constructor (string, TnxGuid, Integer)

TnxBroadcastReply.Create Constructor (string, TnxGuid, Integer)
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(const aServerName: string; const aServerID: TnxGuid; const aServerVersion: Integer); overload;
Description

TnxBroadcastReply

Group

Create Constructor

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, Create Constructor


TnxBroadcastReply.Create Constructor (string, string, string)

TnxBroadcastReply.Create Constructor (string, string, string)
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(const aServerName: string; const aServerID: string; const aServerVersion: string); overload;
Group

Create Constructor

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, Create Constructor


TnxBroadcastReply Fields

TnxBroadcastReply Fields
TnxBroadcastReply Class Legend Protected Fields Send Feedback

The fields of the TnxBroadcastReply class are listed here.

Class

TnxBroadcastReply Class

Protected Fields
Name | Description
brServerID | This is brServerID, a member of class TnxBroadcastReply.
brServerName | private
brServerVersion | This is brServerVersion, a member of class TnxBroadcastReply.
Links
TnxBroadcastReply Class, Legend, Protected Fields


TnxBroadcastReply.brServerID Field

TnxBroadcastReply.brServerID Field
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Fields Send Feedback
Syntax
Delphi
brServerID: TnxGuid;
Description

This is brServerID, a member of class TnxBroadcastReply.

Group

TnxBroadcastReply Fields

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Fields


TnxBroadcastReply.brServerName Field

TnxBroadcastReply.brServerName Field
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Fields Send Feedback
Syntax
Delphi
brServerName: string;
Description

private

Group

TnxBroadcastReply Fields

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Fields


TnxBroadcastReply.brServerVersion Field

TnxBroadcastReply.brServerVersion Field
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Fields Send Feedback
Syntax
Delphi
brServerVersion: Integer;
Description

This is brServerVersion, a member of class TnxBroadcastReply.

Group

TnxBroadcastReply Fields

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Fields


TnxBroadcastReply Methods

TnxBroadcastReply Methods
TnxBroadcastReply Class Legend Protected Methods Send Feedback

The methods of the TnxBroadcastReply class are listed here.

Class

TnxBroadcastReply Class

Protected Methods
Name | Description
GetServerID |
GetServerName | InxBroadcastReply
GetServerVersion |
Links
TnxBroadcastReply Class, Legend, Protected Methods


TnxBroadcastReply.GetServerID Method

TnxBroadcastReply.GetServerID Method
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerID: TnxGuid;
Group

TnxBroadcastReply Methods

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Methods


TnxBroadcastReply.GetServerName Method

TnxBroadcastReply.GetServerName Method
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerName: string;
Description

InxBroadcastReply

Group

TnxBroadcastReply Methods

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Methods


TnxBroadcastReply.GetServerVersion Method

TnxBroadcastReply.GetServerVersion Method
TnxBroadcastReply Class TnxBroadcastReply Members nxllTransport Namespace TnxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerVersion: Integer;
Group

TnxBroadcastReply Methods

Links
TnxBroadcastReply Class, TnxBroadcastReply Members, nxllTransport Namespace, TnxBroadcastReply Methods


TnxDataMessageReader Class

TnxDataMessageReader Class
TnxDataMessageReader Fields TnxDataMessageReader Properties TnxDataMessageReader Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxDataMessageReadernxllTransport_TnxDataMessageReadernxllTransport_TnxDataMessageReadernxllTransport_TnxDataMessageReader
Syntax
Delphi
TnxDataMessageReader = class(TnxReader);
File

nxllTransport

Description

A TReader descendant for easily reading the data of a message.

Group

Classes

Links
TnxDataMessageReader Fields, TnxDataMessageReader Properties, TnxDataMessageReader Members, nxllTransport, Classes


TnxDataMessageReader Members

TnxDataMessageReader Members
TnxDataMessageReader Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDataMessageReader.

Class

TnxDataMessageReader Class

Protected Fields
Name | Description
dmrStream | private.
Protected Methods
Name | Description
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
Create | constructor.
Destroy | destructor.
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadAnsiChar |
ReadBinary |
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadBytes |
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadDouble |
ReadFloat | This is ReadFloat, a member of class TReader.
ReadGuid |
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadStrings |
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideChar |
ReadWideString | This is ReadWideString, a member of class TReader.
ReadWideString_ |
TheReader |
Public Properties
Name | Description
DataMessageStream | A stream for reading/writing message data.
Position | This is Position, a member of class TReader.
Links
TnxDataMessageReader Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDataMessageReader.Create Constructor

TnxDataMessageReader.Create Constructor
TnxDataMessageReader Class TnxDataMessageReader Members nxllTransport Namespace TnxDataMessageReader Class Send Feedback
Syntax
Delphi
constructor Create(const aDataMessage: TnxDataMessage);
Parameters
Parameters | Description
const aDataMessage: TnxDataMessage | the Message used. TnxDataMessageReader
Description

constructor.

Class

TnxDataMessageReader Class

Links
TnxDataMessageReader Class, TnxDataMessageReader Members, nxllTransport Namespace, TnxDataMessageReader Class


TnxDataMessageReader.Destroy Destructor

TnxDataMessageReader.Destroy Destructor
TnxDataMessageReader Class TnxDataMessageReader Members nxllTransport Namespace TnxDataMessageReader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxDataMessageReader Class

Links
TnxDataMessageReader Class, TnxDataMessageReader Members, nxllTransport Namespace, TnxDataMessageReader Class


TnxDataMessageReader Fields

TnxDataMessageReader Fields
TnxDataMessageReader Class Legend Protected Fields Send Feedback

The fields of the TnxDataMessageReader class are listed here.

Class

TnxDataMessageReader Class

Protected Fields
Name | Description
dmrStream | private.
Links
TnxDataMessageReader Class, Legend, Protected Fields


TnxDataMessageReader.dmrStream Field

TnxDataMessageReader.dmrStream Field
TnxDataMessageReader Class TnxDataMessageReader Members nxllTransport Namespace TnxDataMessageReader Fields Send Feedback
Syntax
Delphi
dmrStream: TStream;
Description

private.

Group

TnxDataMessageReader Fields

Links
TnxDataMessageReader Class, TnxDataMessageReader Members, nxllTransport Namespace, TnxDataMessageReader Fields


TnxDataMessageReader Properties

TnxDataMessageReader Properties
TnxDataMessageReader Class Legend Public Properties Send Feedback

The properties of the TnxDataMessageReader class are listed here.

Class

TnxDataMessageReader Class

Public Properties
Name | Description
DataMessageStream | A stream for reading/writing message data.
Links
TnxDataMessageReader Class, Legend, Public Properties


TnxDataMessageReader.DataMessageStream Property

TnxDataMessageReader.DataMessageStream Property
TnxDataMessageReader Class TnxDataMessageReader Members nxllTransport Namespace TnxDataMessageReader Properties Send Feedback
Syntax
Delphi
property DataMessageStream: TStream;
Description

A stream for reading/writing message data.

Group

TnxDataMessageReader Properties

Links
TnxDataMessageReader Class, TnxDataMessageReader Members, nxllTransport Namespace, TnxDataMessageReader Properties


TnxDataMessageStream Class

TnxDataMessageStream Class
TnxDataMessageStream Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxDataMessageStreamnxllTransport_TnxDataMessageStreamnxllTransport_TnxDataMessageStream
Syntax
Delphi
TnxDataMessageStream = class(TnxStaticMemoryStream);
File

nxllTransport

Description

A stream for reading/writing message data.

Group

Classes

Links
TnxDataMessageStream Members, nxllTransport, Classes


TnxDataMessageStream Members

TnxDataMessageStream Members
TnxDataMessageStream Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDataMessageStream.

Class

TnxDataMessageStream Class

Protected Fields
Name | Description
cmsMemory | private
cmsPosition | This is cmsPosition, a member of class TnxCustomMemoryStream.
cmsSize | This is cmsSize, a member of class TnxCustomMemoryStream.
Protected Methods
Name | Description
SetPointer |
Public Methods
Name | Description
Create | constuctor.
Read | TnxCustomMemoryStream
SaveToFile |
SaveToStream |
Seek |
TheStream |
Write |
Public Properties
Name | Description
Memory | This is Memory, a member of class TnxCustomMemoryStream.
Links
TnxDataMessageStream Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDataMessageStream.Create Constructor

TnxDataMessageStream.Create Constructor
TnxDataMessageStream Class TnxDataMessageStream Members nxllTransport Namespace TnxDataMessageStream Class Send Feedback
Syntax
Delphi
constructor Create(const aDataMessage: TnxDataMessage);
Parameters
Parameters | Description
const aDataMessage: TnxDataMessage | the Message used. TnxDataMessageStream
Description

constuctor.

Class

TnxDataMessageStream Class

Links
TnxDataMessageStream Class, TnxDataMessageStream Members, nxllTransport Namespace, TnxDataMessageStream Class


TnxGetServerNamesHandler Class

TnxGetServerNamesHandler Class
TnxGetServerNamesHandler Fields TnxGetServerNamesHandler Methods TnxGetServerNamesHandler Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxGetServerNamesHandlernxllTransport_TnxGetServerNamesHandlernxllTransport_TnxGetServerNamesHandlernxllTransport_TnxGetServerNamesHandler
Syntax
Delphi
TnxGetServerNamesHandler = class(TnxInterfacedObject, InxBroadcastReplyHandler);
File

nxllTransport

Description

DOM-IGNORE-BEGIN

Group

Classes

Links
TnxGetServerNamesHandler Fields, TnxGetServerNamesHandler Methods, TnxGetServerNamesHandler Members, nxllTransport, Classes


TnxGetServerNamesHandler Members

TnxGetServerNamesHandler Members
TnxGetServerNamesHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxGetServerNamesHandler.

Class

TnxGetServerNamesHandler Class

Protected Fields
Name | Description
gsnhList | This is gsnhList, a member of class TnxGetServerNamesHandler.
gsnhLock | private
gsnhTransport | This is gsnhTransport, a member of class TnxGetServerNamesHandler.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
ReplyReceived | InxBroadcastReplyHandler
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxGetServerNamesHandler
Destroy |
Free |
FreeInstance |
GetServerNames |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxGetServerNamesHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxGetServerNamesHandler.Create Constructor

TnxGetServerNamesHandler.Create Constructor
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBaseTransport);
Description

TnxGetServerNamesHandler

Class

TnxGetServerNamesHandler Class

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Class


TnxGetServerNamesHandler.Destroy Destructor

TnxGetServerNamesHandler.Destroy Destructor
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxGetServerNamesHandler Class

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Class


TnxGetServerNamesHandler Fields

TnxGetServerNamesHandler Fields
TnxGetServerNamesHandler Class Legend Protected Fields Send Feedback

The fields of the TnxGetServerNamesHandler class are listed here.

Class

TnxGetServerNamesHandler Class

Protected Fields
Name | Description
gsnhList | This is gsnhList, a member of class TnxGetServerNamesHandler.
gsnhLock | private
gsnhTransport | This is gsnhTransport, a member of class TnxGetServerNamesHandler.
Links
TnxGetServerNamesHandler Class, Legend, Protected Fields


TnxGetServerNamesHandler.gsnhList Field

TnxGetServerNamesHandler.gsnhList Field
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Fields Send Feedback
Syntax
Delphi
gsnhList: TStringList;
Description

This is gsnhList, a member of class TnxGetServerNamesHandler.

Group

TnxGetServerNamesHandler Fields

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Fields


TnxGetServerNamesHandler.gsnhLock Field

TnxGetServerNamesHandler.gsnhLock Field
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Fields Send Feedback
Syntax
Delphi
gsnhLock: TnxPadlock;
Description

private

Group

TnxGetServerNamesHandler Fields

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Fields


TnxGetServerNamesHandler.gsnhTransport Field

TnxGetServerNamesHandler.gsnhTransport Field
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Fields Send Feedback
Syntax
Delphi
gsnhTransport: TnxBaseTransport;
Description

This is gsnhTransport, a member of class TnxGetServerNamesHandler.

Group

TnxGetServerNamesHandler Fields

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Fields


TnxGetServerNamesHandler Methods

TnxGetServerNamesHandler Methods
TnxGetServerNamesHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxGetServerNamesHandler class are listed here.

Class

TnxGetServerNamesHandler Class

Protected Methods
Name | Description
ReplyReceived | InxBroadcastReplyHandler
Public Methods
Name | Description
GetServerNames |
Links
TnxGetServerNamesHandler Class, Legend, Protected Methods, Public Methods


TnxGetServerNamesHandler.GetServerNames Method

TnxGetServerNamesHandler.GetServerNames Method
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Methods Send Feedback
Syntax
Delphi
procedure GetServerNames(aList: TStrings; aTimeOut: TnxWord32);
Group

TnxGetServerNamesHandler Methods

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Methods


TnxGetServerNamesHandler.ReplyReceived Method

TnxGetServerNamesHandler.ReplyReceived Method
TnxGetServerNamesHandler Class TnxGetServerNamesHandler Members nxllTransport Namespace TnxGetServerNamesHandler Methods Send Feedback
Syntax
Delphi
procedure ReplyReceived(aReply: InxBroadcastReply);
Description

InxBroadcastReplyHandler

Group

TnxGetServerNamesHandler Methods

Links
TnxGetServerNamesHandler Class, TnxGetServerNamesHandler Members, nxllTransport Namespace, TnxGetServerNamesHandler Methods


TnxNullActiveBroadcast Class

TnxNullActiveBroadcast Class
TnxNullActiveBroadcast Methods TnxNullActiveBroadcast Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxNullActiveBroadcastnxllTransport_TnxNullActiveBroadcastnxllTransport_TnxNullActiveBroadcastnxllTransport_TnxNullActiveBroadcast
Syntax
Delphi
TnxNullActiveBroadcast = class(TnxInterfacedObject, InxActiveBroadcast);
File

nxllTransport

Description

This is class nxllTransport.TnxNullActiveBroadcast.

Group

Classes

Links
TnxNullActiveBroadcast Methods, TnxNullActiveBroadcast Members, nxllTransport, Classes


TnxNullActiveBroadcast Members

TnxNullActiveBroadcast Members
TnxNullActiveBroadcast Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNullActiveBroadcast.

Class

TnxNullActiveBroadcast Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Resume | TnxNullActiveBroadcast
Stop |
Suspend | InxActiveBroadcast
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxNullActiveBroadcast Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxNullActiveBroadcast Methods

TnxNullActiveBroadcast Methods
TnxNullActiveBroadcast Class Legend Protected Methods Send Feedback

The methods of the TnxNullActiveBroadcast class are listed here.

Class

TnxNullActiveBroadcast Class

Protected Methods
Name | Description
Resume | TnxNullActiveBroadcast
Stop |
Suspend | InxActiveBroadcast
Links
TnxNullActiveBroadcast Class, Legend, Protected Methods


TnxNullActiveBroadcast.Resume Method

TnxNullActiveBroadcast.Resume Method
TnxNullActiveBroadcast Class TnxNullActiveBroadcast Members nxllTransport Namespace TnxNullActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Resume;
Description

TnxNullActiveBroadcast

Group

TnxNullActiveBroadcast Methods

Links
TnxNullActiveBroadcast Class, TnxNullActiveBroadcast Members, nxllTransport Namespace, TnxNullActiveBroadcast Methods


TnxNullActiveBroadcast.Stop Method

TnxNullActiveBroadcast.Stop Method
TnxNullActiveBroadcast Class TnxNullActiveBroadcast Members nxllTransport Namespace TnxNullActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Stop;
Group

TnxNullActiveBroadcast Methods

Links
TnxNullActiveBroadcast Class, TnxNullActiveBroadcast Members, nxllTransport Namespace, TnxNullActiveBroadcast Methods


TnxNullActiveBroadcast.Suspend Method

TnxNullActiveBroadcast.Suspend Method
TnxNullActiveBroadcast Class TnxNullActiveBroadcast Members nxllTransport Namespace TnxNullActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Suspend;
Description

InxActiveBroadcast

Group

TnxNullActiveBroadcast Methods

Links
TnxNullActiveBroadcast Class, TnxNullActiveBroadcast Members, nxllTransport Namespace, TnxNullActiveBroadcast Methods


TnxReplyWriter Class

TnxReplyWriter Class
TnxReplyWriter Fields TnxReplyWriter Methods TnxReplyWriter Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxReplyWriternxllTransport_TnxReplyWriternxllTransport_TnxReplyWriternxllTransport_TnxReplyWriter
Syntax
Delphi
TnxReplyWriter = class(TnxWriter);
File

nxllTransport

Description

This is class nxllTransport.TnxReplyWriter.

Group

Classes

Links
TnxReplyWriter Fields, TnxReplyWriter Methods, TnxReplyWriter Members, nxllTransport, Classes


TnxReplyWriter Members

TnxReplyWriter Members
TnxReplyWriter Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxReplyWriter.

Class

TnxReplyWriter Class

Protected Fields
Name | Description
rwMsgID | private
rwStream | This is rwStream, a member of class TnxReplyWriter.
Protected Methods
Name | Description
WriteBinary | This is WriteBinary, a member of class TWriter.
WriteValue | This is WriteValue, a member of class TWriter.
Public Fields
Name | Description
Error | This is Error, a member of class TnxReplyWriter.
Public Methods
Name | Description
Create | TnxReplyWriter
Destroy |
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TWriter.
Send |
TheWriter |
Write | This is Write, a member of class TWriter.
WriteAnsiChar |
WriteAnsiString |
WriteAnsiStrings |
WriteBinary |
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteBytes |
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDouble | This is WriteDouble, a member of class TWriter.
WriteDouble |
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteGuid |
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteStrings |
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteWideChar | This is WriteWideChar, a member of class TWriter.
WriteWideChar |
WriteWideString | This is WriteWideString, a member of class TWriter.
WriteWideString_ |
WriteWideStrings |
Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TnxReplyWriter Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxReplyWriter.Create Constructor

TnxReplyWriter.Create Constructor
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Class Send Feedback
Syntax
Delphi
constructor Create(aMsgID: TnxMsgID);
Description

TnxReplyWriter

Class

TnxReplyWriter Class

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Class


TnxReplyWriter.Destroy Destructor

TnxReplyWriter.Destroy Destructor
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxReplyWriter Class

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Class


TnxReplyWriter Fields

TnxReplyWriter Fields
TnxReplyWriter Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxReplyWriter class are listed here.

Class

TnxReplyWriter Class

Protected Fields
Name | Description
rwMsgID | private
rwStream | This is rwStream, a member of class TnxReplyWriter.
Public Fields
Name | Description
Error | This is Error, a member of class TnxReplyWriter.
Links
TnxReplyWriter Class, Legend, Protected Fields, Public Fields


TnxReplyWriter.Error Field

TnxReplyWriter.Error Field
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Fields Send Feedback
Syntax
Delphi
Error: TnxResult;
Description

This is Error, a member of class TnxReplyWriter.

Group

TnxReplyWriter Fields

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Fields


TnxReplyWriter.rwMsgID Field

TnxReplyWriter.rwMsgID Field
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Fields Send Feedback
Syntax
Delphi
rwMsgID: TnxMsgID;
Description

private

Group

TnxReplyWriter Fields

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Fields


TnxReplyWriter.rwStream Field

TnxReplyWriter.rwStream Field
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Fields Send Feedback
Syntax
Delphi
rwStream: TnxMemoryStream;
Description

This is rwStream, a member of class TnxReplyWriter.

Group

TnxReplyWriter Fields

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Fields


TnxReplyWriter Methods

TnxReplyWriter Methods
TnxReplyWriter Class Legend Public Methods Send Feedback

The methods of the TnxReplyWriter class are listed here.

Class

TnxReplyWriter Class

Public Methods
Name | Description
Send |
Links
TnxReplyWriter Class, Legend, Public Methods


TnxReplyWriter.Send Method

TnxReplyWriter.Send Method
TnxReplyWriter Class TnxReplyWriter Members nxllTransport Namespace TnxReplyWriter Methods Send Feedback
Syntax
Delphi
procedure Send;
Group

TnxReplyWriter Methods

Links
TnxReplyWriter Class, TnxReplyWriter Members, nxllTransport Namespace, TnxReplyWriter Methods


TnxRequestReader Class

TnxRequestReader Class
TnxRequestReader Fields TnxRequestReader Methods TnxRequestReader Properties TnxRequestReader Members nxllTransport Classes Send Feedback
Class Hierarchy
nxllTransport_TnxRequestReadernxllTransport_TnxRequestReadernxllTransport_TnxRequestReadernxllTransport_TnxRequestReadernxllTransport_TnxRequestReader
Syntax
Delphi
TnxRequestReader = class(TnxDataMessageReader);
File

nxllTransport

Description

This is class nxllTransport.TnxRequestReader.

Group

Classes

Links
TnxRequestReader Fields, TnxRequestReader Methods, TnxRequestReader Properties, TnxRequestReader Members, nxllTransport, Classes


TnxRequestReader Members

TnxRequestReader Members
TnxRequestReader Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRequestReader.

Class

TnxRequestReader Class

Protected Fields
Name | Description
dmrStream | private.
rrWriter | private
Protected Methods
Name | Description
CreateWriter |
SetPosition | This is SetPosition, a member of class TReader.
Public Methods
Name | Description
CheckValue | This is CheckValue, a member of class TReader.
Create | TnxRequestReader
Destroy |
EndOfList | This is EndOfList, a member of class TReader.
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TReader.
NextValue | This is NextValue, a member of class TReader.
Read | This is Read, a member of class TReader.
ReadAnsiChar |
ReadBinary |
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadBytes |
ReadChar | This is ReadChar, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadDouble |
ReadFloat | This is ReadFloat, a member of class TReader.
ReadGuid |
ReadIdent | This is ReadIdent, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadStrings |
ReadValue | This is ReadValue, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideChar |
ReadWideString | This is ReadWideString, a member of class TReader.
ReadWideString_ |
TheReader |
Public Properties
Name | Description
DataMessageStream | A stream for reading/writing message data.
Position | This is Position, a member of class TReader.
Reply | This is Reply, a member of class TnxRequestReader.
Links
TnxRequestReader Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRequestReader.Create Constructor

TnxRequestReader.Create Constructor
TnxRequestReader Class TnxRequestReader Members nxllTransport Namespace TnxRequestReader Class Send Feedback
Syntax
Delphi
constructor Create(const aDataMessage: TnxDataMessage);
Description

TnxRequestReader

Class

TnxRequestReader Class

Links
TnxRequestReader Class, TnxRequestReader Members, nxllTransport Namespace, TnxRequestReader Class


TnxRequestReader.Destroy Destructor

TnxRequestReader.Destroy Destructor
TnxRequestReader Class TnxRequestReader Members nxllTransport Namespace TnxRequestReader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRequestReader Class

Links
TnxRequestReader Class, TnxRequestReader Members, nxllTransport Namespace, TnxRequestReader Class


TnxRequestReader Fields

TnxRequestReader Fields
TnxRequestReader Class Legend Protected Fields Send Feedback

The fields of the TnxRequestReader class are listed here.

Class

TnxRequestReader Class

Protected Fields
Name | Description
rrWriter | private
Links
TnxRequestReader Class, Legend, Protected Fields


TnxRequestReader.rrWriter Field

TnxRequestReader.rrWriter Field
TnxRequestReader Class TnxRequestReader Members nxllTransport Namespace TnxRequestReader Fields Send Feedback
Syntax
Delphi
rrWriter: TnxReplyWriter;
Description

private

Group

TnxRequestReader Fields

Links
TnxRequestReader Class, TnxRequestReader Members, nxllTransport Namespace, TnxRequestReader Fields


TnxRequestReader Methods

TnxRequestReader Methods
TnxRequestReader Class Legend Protected Methods Send Feedback

The methods of the TnxRequestReader class are listed here.

Class

TnxRequestReader Class

Protected Methods
Name | Description
CreateWriter |
Links
TnxRequestReader Class, Legend, Protected Methods


TnxRequestReader.CreateWriter Method

TnxRequestReader.CreateWriter Method
TnxRequestReader Class TnxRequestReader Members nxllTransport Namespace TnxRequestReader Methods Send Feedback
Syntax
Delphi
function CreateWriter(const aDataMessage: TnxDataMessage): TnxReplyWriter; virtual;
Group

TnxRequestReader Methods

Links
TnxRequestReader Class, TnxRequestReader Members, nxllTransport Namespace, TnxRequestReader Methods


TnxRequestReader Properties

TnxRequestReader Properties
TnxRequestReader Class Legend Public Properties Send Feedback

The properties of the TnxRequestReader class are listed here.

Class

TnxRequestReader Class

Public Properties
Name | Description
Reply | This is Reply, a member of class TnxRequestReader.
Links
TnxRequestReader Class, Legend, Public Properties


TnxRequestReader.Reply Property

TnxRequestReader.Reply Property
TnxRequestReader Class TnxRequestReader Members nxllTransport Namespace TnxRequestReader Properties Send Feedback
Syntax
Delphi
property Reply: TnxReplyWriter;
Description

This is Reply, a member of class TnxRequestReader.

Group

TnxRequestReader Properties

Links
TnxRequestReader Class, TnxRequestReader Members, nxllTransport Namespace, TnxRequestReader Properties


Interfaces

Interfaces
nxllTransport Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllTransport Namespace

Interfaces
Name | Description
InxActiveBroadcast | This interface is returned by TnxBaseTransport.BeginBroadcast.
InxBroadcastReply | This interface is passed into InxBroadcastReplyHandler.ReplyReceived.
InxBroadcastReplyHandler | This interface has to be passed into TnxBaseTransport.BeginBroadcast.
InxSessionCallback | Interface for session callbacks.
InxSessionDataStore | This interface is (optionall) implemented by the same object as InxSessionCallback. It allows storage of additional data that remains associated with the session.
InxSessionInfo | This is class nxllTransport.InxSessionInfo.
Links
nxllTransport Namespace, Interfaces, Legend


InxActiveBroadcast Interface

InxActiveBroadcast Interface
InxActiveBroadcast Methods InxActiveBroadcast Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxActiveBroadcast
Syntax
Delphi
InxActiveBroadcast = interface;
File

nxllTransport

Description

This interface is returned by TnxBaseTransport.BeginBroadcast.

Group

Interfaces

Links
InxActiveBroadcast Methods, InxActiveBroadcast Members, nxllTransport, Interfaces


InxActiveBroadcast Members

InxActiveBroadcast Members
InxActiveBroadcast Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxActiveBroadcast.

Interface

InxActiveBroadcast Interface

Public Methods
Name | Description
Resume | Resumes broadcasts.
Stop | Stops all broadcasts and stops listening for replies.
Suspend | Suspends further broadcasts but continues to list for replies,
Links
InxActiveBroadcast Interface, Legend, Public Methods


InxActiveBroadcast Methods

InxActiveBroadcast Methods
InxActiveBroadcast Interface Legend Public Methods Send Feedback

The methods of the InxActiveBroadcast class are listed here.

Interface

InxActiveBroadcast Interface

Public Methods
Name | Description
Resume | Resumes broadcasts.
Stop | Stops all broadcasts and stops listening for replies.
Suspend | Suspends further broadcasts but continues to list for replies,
Links
InxActiveBroadcast Interface, Legend, Public Methods


InxActiveBroadcast.Resume Method

InxActiveBroadcast.Resume Method
InxActiveBroadcast Interface InxActiveBroadcast Members nxllTransport Namespace InxActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Resume;
Description

Resumes broadcasts.

Group

InxActiveBroadcast Methods

Links
InxActiveBroadcast Interface, InxActiveBroadcast Members, nxllTransport Namespace, InxActiveBroadcast Methods


InxActiveBroadcast.Stop Method

InxActiveBroadcast.Stop Method
InxActiveBroadcast Interface InxActiveBroadcast Members nxllTransport Namespace InxActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Stop;
Description

Stops all broadcasts and stops listening for replies.

Group

InxActiveBroadcast Methods

Links
InxActiveBroadcast Interface, InxActiveBroadcast Members, nxllTransport Namespace, InxActiveBroadcast Methods


InxActiveBroadcast.Suspend Method

InxActiveBroadcast.Suspend Method
InxActiveBroadcast Interface InxActiveBroadcast Members nxllTransport Namespace InxActiveBroadcast Methods Send Feedback
Syntax
Delphi
procedure Suspend;
Description

Suspends further broadcasts but continues to list for replies,

Group

InxActiveBroadcast Methods

Links
InxActiveBroadcast Interface, InxActiveBroadcast Members, nxllTransport Namespace, InxActiveBroadcast Methods


InxBroadcastReply Interface

InxBroadcastReply Interface
InxBroadcastReply Methods InxBroadcastReply Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxBroadcastReply
Syntax
Delphi
InxBroadcastReply = interface;
File

nxllTransport

Description

This interface is passed into InxBroadcastReplyHandler.ReplyReceived.

Group

Interfaces

Links
InxBroadcastReply Methods, InxBroadcastReply Members, nxllTransport, Interfaces


InxBroadcastReply Members

InxBroadcastReply Members
InxBroadcastReply Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxBroadcastReply.

Interface

InxBroadcastReply Interface

Public Methods
Name | Description
GetServerID | GUID of the server. Can be 0 (for < 2.0 servers). The GUID will be identical for replies on different transports from the same server.
GetServerName | Transport dependant name of the server.
GetServerVersion | Can be 0 (for < 2.0 server). Otherwise it specifies the Version of the server.
Links
InxBroadcastReply Interface, Legend, Public Methods


InxBroadcastReply Methods

InxBroadcastReply Methods
InxBroadcastReply Interface Legend Public Methods Send Feedback

The methods of the InxBroadcastReply class are listed here.

Interface

InxBroadcastReply Interface

Public Methods
Name | Description
GetServerID | GUID of the server. Can be 0 (for < 2.0 servers). The GUID will be identical for replies on different transports from the same server.
GetServerName | Transport dependant name of the server.
GetServerVersion | Can be 0 (for < 2.0 server). Otherwise it specifies the Version of the server.
Links
InxBroadcastReply Interface, Legend, Public Methods


InxBroadcastReply.GetServerID Method

InxBroadcastReply.GetServerID Method
InxBroadcastReply Interface InxBroadcastReply Members nxllTransport Namespace InxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerID: TnxGuid;
Description

GUID of the server. Can be 0 (for < 2.0 servers). The GUID will be identical for replies on different transports from the same server.

Group

InxBroadcastReply Methods

Links
InxBroadcastReply Interface, InxBroadcastReply Members, nxllTransport Namespace, InxBroadcastReply Methods


InxBroadcastReply.GetServerName Method

InxBroadcastReply.GetServerName Method
InxBroadcastReply Interface InxBroadcastReply Members nxllTransport Namespace InxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerName: string;
Description

Transport dependant name of the server.

Group

InxBroadcastReply Methods

Links
InxBroadcastReply Interface, InxBroadcastReply Members, nxllTransport Namespace, InxBroadcastReply Methods


InxBroadcastReply.GetServerVersion Method

InxBroadcastReply.GetServerVersion Method
InxBroadcastReply Interface InxBroadcastReply Members nxllTransport Namespace InxBroadcastReply Methods Send Feedback
Syntax
Delphi
function GetServerVersion: Integer;
Description

Can be 0 (for < 2.0 server). Otherwise it specifies the Version of the server.

Group

InxBroadcastReply Methods

Links
InxBroadcastReply Interface, InxBroadcastReply Members, nxllTransport Namespace, InxBroadcastReply Methods


InxBroadcastReplyHandler Interface

InxBroadcastReplyHandler Interface
InxBroadcastReplyHandler Methods InxBroadcastReplyHandler Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxBroadcastReplyHandler
Syntax
Delphi
InxBroadcastReplyHandler = interface;
File

nxllTransport

Description

This interface has to be passed into TnxBaseTransport.BeginBroadcast.

Group

Interfaces

Links
InxBroadcastReplyHandler Methods, InxBroadcastReplyHandler Members, nxllTransport, Interfaces


InxBroadcastReplyHandler Members

InxBroadcastReplyHandler Members
InxBroadcastReplyHandler Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxBroadcastReplyHandler.

Interface

InxBroadcastReplyHandler Interface

Public Methods
Name | Description
ReplyReceived | Called each time the Transport receives a reply to the broadcast. May be called multiple times for the same server.
Links
InxBroadcastReplyHandler Interface, Legend, Public Methods


InxBroadcastReplyHandler Methods

InxBroadcastReplyHandler Methods
InxBroadcastReplyHandler Interface Legend Public Methods Send Feedback

The methods of the InxBroadcastReplyHandler class are listed here.

Interface

InxBroadcastReplyHandler Interface

Public Methods
Name | Description
ReplyReceived | Called each time the Transport receives a reply to the broadcast. May be called multiple times for the same server.
Links
InxBroadcastReplyHandler Interface, Legend, Public Methods


InxBroadcastReplyHandler.ReplyReceived Method

InxBroadcastReplyHandler.ReplyReceived Method
InxBroadcastReplyHandler Interface InxBroadcastReplyHandler Members nxllTransport Namespace InxBroadcastReplyHandler Methods Send Feedback
Syntax
Delphi
procedure ReplyReceived(aReply: InxBroadcastReply);
Description

Called each time the Transport receives a reply to the broadcast. May be called multiple times for the same server.

Group

InxBroadcastReplyHandler Methods

Links
InxBroadcastReplyHandler Interface, InxBroadcastReplyHandler Members, nxllTransport Namespace, InxBroadcastReplyHandler Methods


InxSessionCallback Interface

InxSessionCallback Interface
InxSessionCallback Methods InxSessionCallback Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxSessionCallback
Syntax
Delphi
InxSessionCallback = interface(InxInterface);
File

nxllTransport

Description

Interface for session callbacks.

Group

Interfaces

Links
InxSessionCallback Methods, InxSessionCallback Members, nxllTransport, Interfaces


InxSessionCallback Members

InxSessionCallback Members
InxSessionCallback Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionCallback.

Interface

InxSessionCallback Interface

Public Methods
Name | Description
Post | This functions posts a request and does NOT wait for the answer.
Request | This functions sends a request and waits for the answer.
Links
InxSessionCallback Interface, Legend, Public Methods


InxSessionCallback Methods

InxSessionCallback Methods
InxSessionCallback Interface Legend Public Methods Send Feedback

The methods of the InxSessionCallback class are listed here.

Interface

InxSessionCallback Interface

Public Methods
Name | Description
Post | This functions posts a request and does NOT wait for the answer.
Request | This functions sends a request and waits for the answer.
Links
InxSessionCallback Interface, Legend, Public Methods


InxSessionCallback.Post Method

InxSessionCallback.Post Method
InxSessionCallback Interface InxSessionCallback Members nxllTransport Namespace InxSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Post(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer);
Parameters
Parameters | Description
aMsgID: TnxMsgID | the message id
aRequestData: Pointer | the data of the broadcast request
aRequestDataLen: TnxWord32 | the length of aRequestData
aTimeOut: Integer | timeout in msec
Description

This functions posts a request and does NOT wait for the answer.

Group

InxSessionCallback Methods

Links
InxSessionCallback Interface, InxSessionCallback Members, nxllTransport Namespace, InxSessionCallback Methods


InxSessionCallback.Request Method

InxSessionCallback.Request Method
InxSessionCallback Interface InxSessionCallback Members nxllTransport Namespace InxSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Request(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeOut: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer);
Parameters
Parameters | Description
aMsgID: TnxMsgID | the message id
aTimeOut: Integer | timeout in msec
aRequestData: Pointer | the data of the broadcast request
aRequestDataLen: TnxWord32 | the length of aRequestData
aReplyCallback: TnxReplyCallback | the callback function to be called once the reply arrived.
aReplyCookie: Pointer | additional information received.
Description

This functions sends a request and waits for the answer.

Group

InxSessionCallback Methods

Links
InxSessionCallback Interface, InxSessionCallback Members, nxllTransport Namespace, InxSessionCallback Methods


InxSessionDataStore Interface

InxSessionDataStore Interface
InxSessionDataStore Methods InxSessionDataStore Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxSessionDataStore
Syntax
Delphi
InxSessionDataStore = interface(InxInterface);
File

nxllTransport

Description

This interface is (optionall) implemented by the same object as InxSessionCallback. It allows storage of additional data that remains associated with the session.

Group

Interfaces

Links
InxSessionDataStore Methods, InxSessionDataStore Members, nxllTransport, Interfaces


InxSessionDataStore Members

InxSessionDataStore Members
InxSessionDataStore Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionDataStore.

Interface

InxSessionDataStore Interface

Public Methods
Name | Description
AddData | Adds a named data item. If the item already exist the operation is ignored. Returns the current value.
GetData | Returns the data item currently registered under this name or nil.
RemoveData | Removes a named data item and returns it. If no data item is registered under this name the result is nil.
Links
InxSessionDataStore Interface, Legend, Public Methods


InxSessionDataStore Methods

InxSessionDataStore Methods
InxSessionDataStore Interface Legend Public Methods Send Feedback

The methods of the InxSessionDataStore class are listed here.

Interface

InxSessionDataStore Interface

Public Methods
Name | Description
AddData | Adds a named data item. If the item already exist the operation is ignored. Returns the current value.
GetData | Returns the data item currently registered under this name or nil.
RemoveData | Removes a named data item and returns it. If no data item is registered under this name the result is nil.
Links
InxSessionDataStore Interface, Legend, Public Methods


InxSessionDataStore.AddData Method

InxSessionDataStore.AddData Method
InxSessionDataStore Interface InxSessionDataStore Members nxllTransport Namespace InxSessionDataStore Methods Send Feedback
Syntax
Delphi
function AddData(aName: string; aData: InxInterface): InxInterface;
Description

Adds a named data item. If the item already exist the operation is ignored. Returns the current value.

Group

InxSessionDataStore Methods

Links
InxSessionDataStore Interface, InxSessionDataStore Members, nxllTransport Namespace, InxSessionDataStore Methods


InxSessionDataStore.GetData Method

InxSessionDataStore.GetData Method
InxSessionDataStore Interface InxSessionDataStore Members nxllTransport Namespace InxSessionDataStore Methods Send Feedback
Syntax
Delphi
function GetData(aName: string): InxInterface;
Description

Returns the data item currently registered under this name or nil.

Group

InxSessionDataStore Methods

Links
InxSessionDataStore Interface, InxSessionDataStore Members, nxllTransport Namespace, InxSessionDataStore Methods


InxSessionDataStore.RemoveData Method

InxSessionDataStore.RemoveData Method
InxSessionDataStore Interface InxSessionDataStore Members nxllTransport Namespace InxSessionDataStore Methods Send Feedback
Syntax
Delphi
function RemoveData(aName: string): InxInterface;
Description

Removes a named data item and returns it. If no data item is registered under this name the result is nil.

Group

InxSessionDataStore Methods

Links
InxSessionDataStore Interface, InxSessionDataStore Members, nxllTransport Namespace, InxSessionDataStore Methods


InxSessionInfo Interface

InxSessionInfo Interface
InxSessionInfo Methods InxSessionInfo Members nxllTransport Interfaces Send Feedback
Class Hierarchy
nxllTransport_InxSessionInfo
Syntax
Delphi
InxSessionInfo = interface(InxInterface);
File

nxllTransport

Description

This is class nxllTransport.InxSessionInfo.

Group

Interfaces

Links
InxSessionInfo Methods, InxSessionInfo Members, nxllTransport, Interfaces


InxSessionInfo Members

InxSessionInfo Members
InxSessionInfo Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionInfo.

Interface

InxSessionInfo Interface

Public Methods
Name | Description
GetSessionID | This is GetSessionID, a member of class InxSessionInfo.
Links
InxSessionInfo Interface, Legend, Public Methods


InxSessionInfo Methods

InxSessionInfo Methods
InxSessionInfo Interface Legend Public Methods Send Feedback

The methods of the InxSessionInfo class are listed here.

Interface

InxSessionInfo Interface

Public Methods
Name | Description
GetSessionID | This is GetSessionID, a member of class InxSessionInfo.
Links
InxSessionInfo Interface, Legend, Public Methods


InxSessionInfo.GetSessionID Method

InxSessionInfo.GetSessionID Method
InxSessionInfo Interface InxSessionInfo Members nxllTransport Namespace InxSessionInfo Methods Send Feedback
Syntax
Delphi
function GetSessionID: TnxSessionID;
Description

This is GetSessionID, a member of class InxSessionInfo.

Group

InxSessionInfo Methods

Links
InxSessionInfo Interface, InxSessionInfo Members, nxllTransport Namespace, InxSessionInfo Methods


Functions

Functions
Functions nxllTransport Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxSplitAddress | This function separates the server name in form name@address.
TransportRequestDirectCallback | TransportRequestDirectCallback
Namespace

nxllTransport Namespace

Links
Functions, nxllTransport Namespace, Legend


nxllTransport.nxSplitAddress Function

nxllTransport.nxSplitAddress Function
nxllTransport Functions Send Feedback
Syntax
Delphi
procedure nxSplitAddress(aOriginal: string; var aName: string; var aAddress: string);
File

nxllTransport

Description

This function separates the server name in form name@address.

Group

Functions

Links
nxllTransport, Functions


nxllTransport.TransportRequestDirectCallback Function

nxllTransport.TransportRequestDirectCallback Function
nxllTransport Functions Send Feedback
Syntax
Delphi
procedure TransportRequestDirectCallback(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReply: Pointer; aReplyLen: Integer; aReplyCookie: Pointer);
File

nxllTransport

Description

TransportRequestDirectCallback

Group

Functions

Links
nxllTransport, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllTransport Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxMessageHeaderFlag | the flags that are sent with every message
TnxTransportLogOption | Log options for the transport.
TnxTransportMode | The mode of the transport.
Namespace

nxllTransport Namespace

Records
Name | Description
TnxBaseHeader | The base header for a communication messages.
TnxDataMessage | the structure for storing one data message part.
TnxDirectCallbackInfo | DOM-IGNORE-BEGIN
Links
Enumerations, nxllTransport Namespace, Legend, Records


nxllTransport.TnxBaseHeader Record

nxllTransport.TnxBaseHeader Record
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBaseHeader = packed record
  bhTransportID: TnxTransportID;
  bhSessionID: TnxSessionID;
  bhVersion: TnxByte8;
  bhThreadPriority: TnxThreadPriority;
  bhFlags: TnxMessageHeaderFlags;
  bhReserved3: Byte;
  bhMsgID: TnxMsgID;
  bhLength: TnxWord32;
  bhParts: TnxWord32;
  bhErrorCode: TnxWord16;
  bhMsgType: Byte;
  bhCompressType: Byte;
  bhUncompressedSize: TnxWord32;
end;
File

nxllTransport

Members
Members | Description
bhTransportID: TnxTransportID; | .. the id of the transport the message came from.
bhSessionID: TnxSessionID; | .. the session id.
bhVersion: TnxByte8; | .. the reuqest id.
bhThreadPriority: TnxThreadPriority; | remote thread priority to use, if a the message request is executed in a separate thread
bhFlags: TnxMessageHeaderFlags; | flags sent with the message
bhReserved3: Byte; | reserved for future use
bhMsgID: TnxMsgID; | .. the message id.
bhLength: TnxWord32; | .. the length of the message including the headers.
bhParts: TnxWord32; | .. the number of message parts for the message consists of.
bhErrorCode: TnxWord16; | .. the error code.
bhMsgType: Byte; | .. the message type.
bhCompressType: Byte; | .. the compression type for the message data
bhUncompressedSize: TnxWord32; | .. the size of the uncompressed full message.
Description

The base header for a communication messages.

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


nxllTransport.TnxDataMessage Record

nxllTransport.TnxDataMessage Record
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDataMessage = record
  dmMsg: TnxMsgID;
  dmSource: TObject;
  dmSessionID: TnxSessionID;
  dmErrorCode: TnxResult;
  dmData: Pointer;
  dmDataLen: TnxMemSize;
end;
File

nxllTransport

Members
Members | Description
dmMsg: TnxMsgID; | .. the message id which mus be unique in the transport context.
dmSource: TObject; | .. the source of the message.
dmSessionID: TnxSessionID; | .. the session id.
dmErrorCode: TnxResult; | .. the request ID the message belongs to.
dmData: Pointer; | the data of the message.
dmDataLen: TnxMemSize; | the length of the data.
Description

the structure for storing one data message part.

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


nxllTransport.TnxDirectCallbackInfo Record

nxllTransport.TnxDirectCallbackInfo Record
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDirectCallbackInfo = record
  dciMsgID: TnxMsgID;
  dciError: TnxResult;
  dciReply: PPointer;
  dciReplyLen: PnxWord32;
  dciReplyType: TnxNetMsgDataType;
end;
File

nxllTransport

Description

DOM-IGNORE-BEGIN

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


nxllTransport.TnxMessageHeaderFlag Enumeration

nxllTransport.TnxMessageHeaderFlag Enumeration
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMessageHeaderFlag = ( mhfErrorMessage, mhfErrorMessageIsUnicode, mhfReserved2, mhfReserved3, mhfReserved4, mhfReserved5, mhfReserved6, mhfReserved7 );
File

nxllTransport

Members
Members | Description
mhfErrorMessage | the message header is followed by a string
mhfErrorMessageIsUnicode | reserver for future use
mhfReserved2 | reserver for future use
mhfReserved3 | reserver for future use
mhfReserved4 | reserver for future use
mhfReserved5 | reserver for future use
mhfReserved6 | reserver for future use
mhfReserved7 | reserver for future use
Description

the flags that are sent with every message

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


nxllTransport.TnxTransportLogOption Enumeration

nxllTransport.TnxTransportLogOption Enumeration
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTransportLogOption = ( nxtpLogErrors, nxtpLogRequests, nxtpLogReplies );
File

nxllTransport

Members
Members | Description
nxtpLogErrors | Log errors only.
nxtpLogRequests | Log all requests. Note that this has a major impact on performance.
nxtpLogReplies | Log all replies Note that this has a major impact on performance.
Description

Log options for the transport.

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


nxllTransport.TnxTransportMode Enumeration

nxllTransport.TnxTransportMode Enumeration
nxllTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTransportMode = ( nxtmSend, nxtmListen );
File

nxllTransport

Members
Members | Description
nxtmSend | .. the transport is set up for sending.
nxtmListen | .. the transport is set up for receiving.
Description

The mode of the transport.

Group

Structs, Records, Enums

Links
nxllTransport, Structs, Records, Enums


Types

Types
nxllTransport Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllTransport Namespace

Types
Name | Description
PnxBaseHeader | The base header for a communication messages.
PnxDataMessage | the structure for storing one data message part.
PnxDirectCallbackInfo | This is type nxllTransport.PnxDirectCallbackInfo.
TnxAddSessionEvent | Definition for the OnAddSession event.
TnxBaseTransportClass | Class definition for trnasports.
TnxChooseServerEvent | The definition for the OnChooseServer event
TnxConnectionLostEvent | The definition for the OnConnectionLost event.
TnxFindServersEvent | The definition for the OnFindServers event
TnxMessageHeaderFlags | set of Message flags
TnxRemoveSessionEvent | The definition for the OnRemoveSession event
TnxReplyCallback | Definition for the callback functions used by the transports.
TnxTransportLogOptions | Log options for the transport.
Links
nxllTransport Namespace, Types


nxllTransport.PnxBaseHeader Type

nxllTransport.PnxBaseHeader Type
nxllTransport Types Send Feedback
Syntax
Delphi
PnxBaseHeader = ^TnxBaseHeader;
File

nxllTransport

Description

The base header for a communication messages.

Group

Types

Links
nxllTransport, Types


nxllTransport.PnxDataMessage Type

nxllTransport.PnxDataMessage Type
nxllTransport Types Send Feedback
Syntax
Delphi
PnxDataMessage = ^TnxDataMessage;
File

nxllTransport

Description

the structure for storing one data message part.

Group

Types

Links
nxllTransport, Types


nxllTransport.PnxDirectCallbackInfo Type

nxllTransport.PnxDirectCallbackInfo Type
nxllTransport Types Send Feedback
Syntax
Delphi
PnxDirectCallbackInfo = ^TnxDirectCallbackInfo;
File

nxllTransport

Description

This is type nxllTransport.PnxDirectCallbackInfo.

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxAddSessionEvent Type

nxllTransport.TnxAddSessionEvent Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxAddSessionEvent = function (aSender : TnxBaseTransport; const aUserName : UnicodeString; const aPassword : UnicodeString; aTimeOut : Integer; aClientVersion : Integer; out aSessionID : TnxSessionID; out aServerVersion : Integer) : TnxResult of object;
File

nxllTransport

Parameters
Parameters | Description
aSender | the transport that received the event
aUserName | the user name that should be used for authentication
aPassword | the password that should be used for authentication
aTimeOut | the timeout in msec
aClientVersion | the version of the client who wants to connect
aSessionID | the returned SessionID
aServerVersion | the returned Server version
Description

Definition for the OnAddSession event.

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxBaseTransportClass Type

nxllTransport.TnxBaseTransportClass Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxBaseTransportClass = class of TnxBaseTransport;
File

nxllTransport

Description

Class definition for trnasports.

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxChooseServerEvent Type

nxllTransport.TnxChooseServerEvent Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxChooseServerEvent = procedure (aSender : TnxBaseTransport; aServerNames : TStrings; var aServerName : string; var aResult : Boolean) of object;
File

nxllTransport

Parameters
Parameters | Description
aSender | the transport that received the event
aServerNames | the names of available servers
aServerName | the name of the (pre)selected server
aResult | set to true to force connect to aServerName
Description

The definition for the OnChooseServer event

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxConnectionLostEvent Type

nxllTransport.TnxConnectionLostEvent Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxConnectionLostEvent = procedure (aSender : TnxBaseTransport; aSessionID : TnxSessionID) of object;
File

nxllTransport

Parameters
Parameters | Description
aSender | the transport that received the event
aSessionID | the session id
Description

The definition for the OnConnectionLost event.

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxFindServersEvent Type

nxllTransport.TnxFindServersEvent Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxFindServersEvent = procedure (aSender : TnxBaseTransport; aStarting : Boolean) of object;
File

nxllTransport

Parameters
Parameters | Description
aSender | the transport that received the event
aStarting | set to true if the event was called before starting to search otherwise its false
Description

The definition for the OnFindServers event

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxMessageHeaderFlags Type

nxllTransport.TnxMessageHeaderFlags Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxMessageHeaderFlags = set of TnxMessageHeaderFlag;
File

nxllTransport

Description

set of Message flags

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxRemoveSessionEvent Type

nxllTransport.TnxRemoveSessionEvent Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxRemoveSessionEvent = function (aSender : TnxBaseTransport; aSessionID : TnxSessionID) : TnxResult of object;
File

nxllTransport

Parameters
Parameters | Description
aSender | the transport that received the event
aSessionID | the session id
Description

The definition for the OnRemoveSession event

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxReplyCallback Type

nxllTransport.TnxReplyCallback Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxReplyCallback = procedure (aMsgID : TnxMsgID; aErrorCode : TnxResult; aReplyData : Pointer; aReplyDataLen : Integer; aReplyCookie : Pointer);
File

nxllTransport

Parameters
Parameters | Description
aMsgId | the Message ID that triggered the callback
aErrorCode | the error code for the message
aReplyData | the data returned to the request
aReplyDataLen | the length of aReplyData
aReplyCookie | additional information transferred
Description

Definition for the callback functions used by the transports.

Group

Types

Links
nxllTransport, Types


nxllTransport.TnxTransportLogOptions Type

nxllTransport.TnxTransportLogOptions Type
nxllTransport Types Send Feedback
Syntax
Delphi
TnxTransportLogOptions = set of TnxTransportLogOption;
File

nxllTransport

Description

Log options for the transport.

Group

Types

Links
nxllTransport, Types


Variables

Variables
nxllTransport Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllTransport Namespace

Variables
Name | Description
_nxTransportChannelExitProcess | This is variable nxllTransport._nxTransportChannelExitProcess.
Links
nxllTransport Namespace, Variables


nxllTransport._nxTransportChannelExitProcess Variable

nxllTransport._nxTransportChannelExitProcess Variable
nxllTransport Variables Send Feedback
Syntax
Delphi
_nxTransportChannelExitProcess: procedure (const aMsg : TnxDataMessage) = nil;
File

nxllTransport

Description

This is variable nxllTransport._nxTransportChannelExitProcess.

Group

Variables

Links
nxllTransport, Variables


Constants

Constants
Constants nxllTransport Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_nxnmRemotingChannelRequest | This is constant nxllTransport._nxnmRemotingChannelRequest.
nxcDefaultServerSearchTimeout | The default timeout for searching servers via broadcast.
rsBchAddSessionNotSupported | This is constant nxllTransport.rsBchAddSessionNotSupported.
rsBtAddSessionRequires | This is constant nxllTransport.rsBtAddSessionRequires.
rsBtRemoveSessionRequires | This is constant nxllTransport.rsBtRemoveSessionRequires.
Namespace

nxllTransport Namespace

Links
Constants, nxllTransport Namespace


nxllTransport._nxnmRemotingChannelRequest Constant

nxllTransport._nxnmRemotingChannelRequest Constant
nxllTransport Constants Send Feedback
Syntax
Delphi
_nxnmRemotingChannelRequest = $1201;
File

nxllTransport

Description

This is constant nxllTransport._nxnmRemotingChannelRequest.

Group

Constants

Links
nxllTransport, Constants


nxllTransport.nxcDefaultServerSearchTimeout Constant

nxllTransport.nxcDefaultServerSearchTimeout Constant
nxllTransport Constants Send Feedback
Syntax
Delphi
nxcDefaultServerSearchTimeout = 3000;
File

nxllTransport

Description

The default timeout for searching servers via broadcast.

Group

Constants

Links
nxllTransport, Constants


nxllTransport.rsBchAddSessionNotSupported Constant

nxllTransport.rsBchAddSessionNotSupported Constant
nxllTransport Constants Send Feedback
Syntax
Delphi
rsBchAddSessionNotSupported = 'bchAddSession not supported by TnxBaseComma' + 'ndHandler';
File

nxllTransport

Description

This is constant nxllTransport.rsBchAddSessionNotSupported.

Group

Constants

Links
nxllTransport, Constants


nxllTransport.rsBtAddSessionRequires Constant

nxllTransport.rsBtAddSessionRequires Constant
nxllTransport Constants Send Feedback
Syntax
Delphi
rsBtAddSessionRequires = 'btAddSession requires an OnAddSession handler or' + ' an attached CommandHandler';
File

nxllTransport

Description

This is constant nxllTransport.rsBtAddSessionRequires.

Group

Constants

Links
nxllTransport, Constants


nxllTransport.rsBtRemoveSessionRequires Constant

nxllTransport.rsBtRemoveSessionRequires Constant
nxllTransport Constants Send Feedback
Syntax
Delphi
rsBtRemoveSessionRequires = 'btRemoveSession requires an OnRemoveSession handler or' + ' an attached CommandHandler';
File

nxllTransport

Description

This is constant nxllTransport.rsBtRemoveSessionRequires.

Group

Constants

Links
nxllTransport, Constants


nxllTransportStrings Namespace

nxllTransportStrings Namespace
Constants Topics Send Feedback

This is namespace nxllTransportStrings.

Constants
Name | Description
rsMustBeListener | This is constant nxllTransportStrings.rsMustBeListener.
rsMustBeSender | This is constant nxllTransportStrings.rsMustBeSender.
rsMustHaveServerName | This is constant nxllTransportStrings.rsMustHaveServerName.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxllTransportStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsMustBeListener | This is constant nxllTransportStrings.rsMustBeListener.
rsMustBeSender | This is constant nxllTransportStrings.rsMustBeSender.
rsMustHaveServerName | This is constant nxllTransportStrings.rsMustHaveServerName.
Namespace

nxllTransportStrings Namespace

Links
Constants, nxllTransportStrings Namespace


nxllTransportStrings.rsMustBeListener Constant

nxllTransportStrings.rsMustBeListener Constant
nxllTransportStrings Constants Send Feedback
Syntax
Delphi
rsMustBeListener = 'The transport must be in listening mode when performing this operation';
File

nxllTransportStrings

Description

This is constant nxllTransportStrings.rsMustBeListener.

Group

Constants

Links
nxllTransportStrings, Constants


nxllTransportStrings.rsMustBeSender Constant

nxllTransportStrings.rsMustBeSender Constant
nxllTransportStrings Constants Send Feedback
Syntax
Delphi
rsMustBeSender = 'The transport must be in sending mode when performing this operation';
File

nxllTransportStrings

Description

This is constant nxllTransportStrings.rsMustBeSender.

Group

Constants

Links
nxllTransportStrings, Constants


nxllTransportStrings.rsMustHaveServerName Constant

nxllTransportStrings.rsMustHaveServerName Constant
nxllTransportStrings Constants Send Feedback
Syntax
Delphi
rsMustHaveServerName = 'A server name must be specified for the transport';
File

nxllTransportStrings

Description

This is constant nxllTransportStrings.rsMustHaveServerName.

Group

Constants

Links
nxllTransportStrings, Constants


nxllTypes Namespace

nxllTypes Namespace
Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllTypes.

Constants
Name | Description
__aspect__Depth | This is constant nxllTypes.__aspect__Depth.
__aspect__Enabled | This is constant nxllTypes.__aspect__Enabled.
__aspect__Indent | This is constant nxllTypes.__aspect__Indent.
MEM_RESET | This is constant nxllTypes.MEM_RESET.
nxEqual | This is constant nxllTypes.nxEqual.
nxGreaterThan | This is constant nxllTypes.nxGreaterThan.
nxSmallerThan | This is constant nxllTypes.nxSmallerThan.
varUInt64 | vt_ui8 21
varUString | Unicode string 258 not OLE compatible
Functions
Name | Description
Noop | This is function nxllTypes.Noop.
Interfaces
Name | Description
IMultiQI | This is class nxllTypes.IMultiQI.
InxBaseException | This is class nxllTypes.InxBaseException.
InxClassActivator | This is class nxllTypes.InxClassActivator.
InxExceptionData | This is class nxllTypes.InxExceptionData.
InxExceptionDataContainer | This is class nxllTypes.InxExceptionDataContainer.
InxExceptionDataValue | This is class nxllTypes.InxExceptionDataValue.
InxSessionNotifications | This is class nxllTypes.InxSessionNotifications.
InxSessionNotifier | This is class nxllTypes.InxSessionNotifier.
InxSessionRequests | This is class nxllTypes.InxSessionRequests.
Structs, Records, Enums
Name | Description
TMemoryManager | This is record nxllTypes.TMemoryManager.
TMULTI_QI | This is record nxllTypes.TMULTI_QI.
TnxBlockSizeAll | This is record nxllTypes.TnxBlockSizeAll.
TnxDataValueType | Do not modify order or remove entries, stored as integer in over the wire streams
TnxFmtBcd | This is record nxllTypes.TnxFmtBcd.
TnxInt64Rec | This is record nxllTypes.TnxInt64Rec.
TnxMemoryManagerImpl | This is record nxllTypes.TnxMemoryManagerImpl.
TnxNetMsgDataType | ..it's a stream (TStream descendant), the stream will be left at the end
TnxWord64Rec | This is record nxllTypes.TnxWord64Rec.
Topics
Name | Description
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
InxInterface | This is type nxllTypes.InxInterface.
InxInvokable | HPPEMIT 'namespace Nxlltypes {' HPPEMIT ' typedef IInvokable InxInvokable;' HPPEMIT '}'
PComp | This is type nxllTypes.PComp.
PLongBool | missing from system.pas in older versions
PMemoryManager | This is type nxllTypes.PMemoryManager.
PMULTI_QI | This is type nxllTypes.PMULTI_QI.
PnxAnsiChar | Pointer to a 8-bit AnsiChar
PnxAnsiCharArray | For debugging purposes.
PnxBcd | This is type nxllTypes.PnxBcd.
PnxBoolean | Pointer to a 8-bit Boolean
PnxByte8 | Pointer to a 8-bit unsigned Integer
PnxByteArray | General array of bytes
PnxCardinalArray | General array of long Cardinals
PnxCurrency | This is type nxllTypes.PnxCurrency.
PnxDate | Pointer to a 4 byte date value
PnxDateTime | Pointer to a 8 byte date/time value
PnxDouble | This is type nxllTypes.PnxDouble.
PnxDynByteArray | This is type nxllTypes.PnxDynByteArray.
PnxExtended | This is type nxllTypes.PnxExtended.
PnxFmtBcd | This is type nxllTypes.PnxFmtBcd.
PnxGuid | This is type nxllTypes.PnxGuid.
PnxInt16 | Pointer to a 16-bit signed Integer
PnxInt32 | Pointer to a 32-bit signed Integer
PnxInt64 | Pointer to a 64-bit signed Integer
PnxInt64Rec | This is type nxllTypes.PnxInt64Rec.
PnxInt8 | Pointer to a 8-bit signed Integer
PnxIntegerArray | General array of long integers
PnxInterface | This is type nxllTypes.PnxInterface.
PnxMemoryManagerImpl | This is type nxllTypes.PnxMemoryManagerImpl.
PnxMsgID | This is type nxllTypes.PnxMsgID.
PnxNativeInt | This is type nxllTypes.PnxNativeInt.
PnxNativeUInt | This is type nxllTypes.PnxNativeUInt.
PnxPointerArray | General array of pointer
PnxPPointerArray | General array of pointer to pointers
PnxResult | This is type nxllTypes.PnxResult.
PnxShStr | Pointer to a length-byte string
PnxSingle | This is type nxllTypes.PnxSingle.
PnxTime | Pointer to a 4 byte time value
PnxUnicodeStrings | This is type nxllTypes.PnxUnicodeStrings.
PnxWideChar | Pointer to a 16-bit WideChar
PnxWideCharArray | For debugging purposes.
PnxWord16 | Pointer to a 16-bit unsigned Integer
PnxWord32 | Pointer to a 32-bit unsigned Integer
PnxWord64Rec | This is type nxllTypes.PnxWord64Rec.
PPnxByteArray | This is type nxllTypes.PPnxByteArray.
PUnicodeString | This is type nxllTypes.PUnicodeString.
RawByteString | This is type nxllTypes.RawByteString.
TAfterBlockPoolAlloc | This is type nxllTypes.TAfterBlockPoolAlloc.
TAfterGetAllocSize | This is type nxllTypes.TAfterGetAllocSize.
TAfterGetMem | This is type nxllTypes.TAfterGetMem.
TAfterMemoryPoolAlloc | This is type nxllTypes.TAfterMemoryPoolAlloc.
TAfterReallocMem | This is type nxllTypes.TAfterReallocMem.
TBeforeBlockPoolDispose | This is type nxllTypes.TBeforeBlockPoolDispose.
TBeforeFreeMem | This is type nxllTypes.TBeforeFreeMem.
TBeforeGetAllocSize | This is type nxllTypes.TBeforeGetAllocSize.
TBeforeGetMem | This is type nxllTypes.TBeforeGetMem.
TBeforeGetPool | This is type nxllTypes.TBeforeGetPool.
TBeforeMemoryPoolDispose | This is type nxllTypes.TBeforeMemoryPoolDispose.
TBeforeReallocMem | This is type nxllTypes.TBeforeReallocMem.
TnxAnsiChar | 8-bit AnsiChar
TnxAnsiCharArray | This is type nxllTypes.TnxAnsiCharArray.
TnxBaseID | This is type nxllTypes.TnxBaseID.
TnxBcd | This is type nxllTypes.TnxBcd.
TnxBlockSize | This is type nxllTypes.TnxBlockSize.
TnxBlockSizes | This is type nxllTypes.TnxBlockSizes.
TnxBoolean | 8-bit Boolean
TnxByte8 | 8-bit unsigned Integer
TnxByteArray | This is type nxllTypes.TnxByteArray.
TnxBytes | This is type nxllTypes.TnxBytes.
TnxCardinalArray | This is type nxllTypes.TnxCardinalArray.
TnxCharSet | This is type nxllTypes.TnxCharSet.
TnxCurrency | This is type nxllTypes.TnxCurrency.
TnxDate | 4 byte date value; One plus number of days since 1/1/0001
TnxDateTime | 8 byte date/time value; Number of milliseconds since midnight on one plus number of days since 1/1/0001
TnxDouble | This is type nxllTypes.TnxDouble.
TnxDynByteArray | This is type nxllTypes.TnxDynByteArray.
TnxDynCardinalArray | This is type nxllTypes.TnxDynCardinalArray.
TnxDynDoubleArray | This is type nxllTypes.TnxDynDoubleArray.
TnxDynIntegerArray | This is type nxllTypes.TnxDynIntegerArray.
TnxDynObjectArray | This is type nxllTypes.TnxDynObjectArray.
TnxDynPointerArray | This is type nxllTypes.TnxDynPointerArray.
TnxDynStringArray | This is type nxllTypes.TnxDynStringArray.
TnxDynVariantArray | This is type nxllTypes.TnxDynVariantArray.
TnxDynWord16Array | This is type nxllTypes.TnxDynWord16Array.
TnxExtended | This is type nxllTypes.TnxExtended.
TnxGuid | This is type nxllTypes.TnxGuid.
TnxInt16 | 16-bit signed Integer
TnxInt32 | 32-bit signed Integer
TnxInt64 | 64-bit signed Integer
TnxInt8 | 8-bit signed Integer
TnxIntegerArray | This is type nxllTypes.TnxIntegerArray.
TnxMemSize | type for size of memory to alloc/free
TnxMsgID | This is type nxllTypes.TnxMsgID.
TnxNativeHalfUInt | This is type nxllTypes.TnxNativeHalfUInt.
TnxNativeInt | This is type nxllTypes.TnxNativeInt.
TnxNativeUInt | This is type nxllTypes.TnxNativeUInt.
TnxNotifierID | This is type nxllTypes.TnxNotifierID.
TnxPointerArray | This is type nxllTypes.TnxPointerArray.
TnxPPointerArray | This is type nxllTypes.TnxPPointerArray.
TnxResult | This is type nxllTypes.TnxResult.
TnxSessionID | This is type nxllTypes.TnxSessionID.
TnxShStr | a length-byte string
TnxSingle | This is type nxllTypes.TnxSingle.
TnxStringZ | For converting ShortStrings to StringZs
TnxThreadPriority | This is type nxllTypes.TnxThreadPriority.
TnxTime | 4 byte time value; Number of milliseconds since midnight
TnxTransportID | TnxRequestID = type TnxBaseID;
TnxUnicodeStrings | This is type nxllTypes.TnxUnicodeStrings.
TnxValueRelationship | This is type nxllTypes.TnxValueRelationship.
TnxWideChar | 16-bit WideChar
TnxWideCharArray | This is type nxllTypes.TnxWideCharArray.
TnxWideString | This is type nxllTypes.TnxWideString.
TnxWord16 | 16-bit unsigned Integer
TnxWord32 | 32-bit unsigned Integer
UnicodeString | This is type nxllTypes.UnicodeString.
Variables
Name | Description
nxForceCleanup | This is variable nxllTypes.nxForceCleanup.
nxRegistryClassActivator | This is variable nxllTypes.nxRegistryClassActivator.
Links
Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Interfaces

Interfaces
nxllTypes Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllTypes Namespace

Interfaces
Name | Description
IMultiQI | This is class nxllTypes.IMultiQI.
InxBaseException | This is class nxllTypes.InxBaseException.
InxClassActivator | This is class nxllTypes.InxClassActivator.
InxExceptionData | This is class nxllTypes.InxExceptionData.
InxExceptionDataContainer | This is class nxllTypes.InxExceptionDataContainer.
InxExceptionDataValue | This is class nxllTypes.InxExceptionDataValue.
InxSessionNotifications | This is class nxllTypes.InxSessionNotifications.
InxSessionNotifier | This is class nxllTypes.InxSessionNotifier.
InxSessionRequests | This is class nxllTypes.InxSessionRequests.
Links
nxllTypes Namespace, Interfaces, Legend


IMultiQI Interface

IMultiQI Interface
IMultiQI Methods IMultiQI Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_IMultiQI
Syntax
Delphi
IMultiQI = interface(IInterface);
File

nxllTypes

Description

This is class nxllTypes.IMultiQI.

Group

Interfaces

Links
IMultiQI Methods, IMultiQI Members, nxllTypes, Interfaces


IMultiQI Members

IMultiQI Members
IMultiQI Interface Legend Public Methods Send Feedback

The following tables list the members exposed by IMultiQI.

Interface

IMultiQI Interface

Public Methods
Name | Description
QueryMultipleInterfaces | This is QueryMultipleInterfaces, a member of class IMultiQI.
Links
IMultiQI Interface, Legend, Public Methods


IMultiQI Methods

IMultiQI Methods
IMultiQI Interface Legend Public Methods Send Feedback

The methods of the IMultiQI class are listed here.

Interface

IMultiQI Interface

Public Methods
Name | Description
QueryMultipleInterfaces | This is QueryMultipleInterfaces, a member of class IMultiQI.
Links
IMultiQI Interface, Legend, Public Methods


IMultiQI.QueryMultipleInterfaces Method

IMultiQI.QueryMultipleInterfaces Method
IMultiQI Interface IMultiQI Members nxllTypes Namespace IMultiQI Methods Send Feedback
Syntax
Delphi
function QueryMultipleInterfaces(cMQIs: Cardinal; pMQIs: PMULTI_QI): HRESULT; stdcall;
Description

This is QueryMultipleInterfaces, a member of class IMultiQI.

Group

IMultiQI Methods

Links
IMultiQI Interface, IMultiQI Members, nxllTypes Namespace, IMultiQI Methods


InxBaseException Interface

InxBaseException Interface
InxBaseException Methods InxBaseException Properties InxBaseException Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxBaseException
Syntax
Delphi
InxBaseException = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxBaseException.

Group

Interfaces

Links
InxBaseException Methods, InxBaseException Properties, InxBaseException Members, nxllTypes, Interfaces


InxBaseException Members

InxBaseException Members
InxBaseException Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxBaseException.

Interface

InxBaseException Interface

Public Methods
Name | Description
GetErrorCode | This is GetErrorCode, a member of class InxBaseException.
Public Properties
Name | Description
ErrorCode | This is ErrorCode, a member of class InxBaseException.
Links
InxBaseException Interface, Legend, Public Methods, Public Properties


InxBaseException Methods

InxBaseException Methods
InxBaseException Interface Legend Public Methods Send Feedback

The methods of the InxBaseException class are listed here.

Interface

InxBaseException Interface

Public Methods
Name | Description
GetErrorCode | This is GetErrorCode, a member of class InxBaseException.
Links
InxBaseException Interface, Legend, Public Methods


InxBaseException.GetErrorCode Method

InxBaseException.GetErrorCode Method
InxBaseException Interface InxBaseException Members nxllTypes Namespace InxBaseException Methods Send Feedback
Syntax
Delphi
function GetErrorCode: TnxResult;
Description

This is GetErrorCode, a member of class InxBaseException.

Group

InxBaseException Methods

Links
InxBaseException Interface, InxBaseException Members, nxllTypes Namespace, InxBaseException Methods


InxBaseException Properties

InxBaseException Properties
InxBaseException Interface Legend Public Properties Send Feedback

The properties of the InxBaseException class are listed here.

Interface

InxBaseException Interface

Public Properties
Name | Description
ErrorCode | This is ErrorCode, a member of class InxBaseException.
Links
InxBaseException Interface, Legend, Public Properties


InxBaseException.ErrorCode Property

InxBaseException.ErrorCode Property
InxBaseException Interface InxBaseException Members nxllTypes Namespace InxBaseException Properties Send Feedback
Syntax
Delphi
property ErrorCode: TnxResult;
Description

This is ErrorCode, a member of class InxBaseException.

Group

InxBaseException Properties

Links
InxBaseException Interface, InxBaseException Members, nxllTypes Namespace, InxBaseException Properties


InxClassActivator Interface

InxClassActivator Interface
InxClassActivator Methods InxClassActivator Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxClassActivator
Syntax
Delphi
InxClassActivator = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxClassActivator.

Group

Interfaces

Links
InxClassActivator Methods, InxClassActivator Members, nxllTypes, Interfaces


InxClassActivator Members

InxClassActivator Members
InxClassActivator Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassActivator.

Interface

InxClassActivator Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassActivator.
Links
InxClassActivator Interface, Legend, Public Methods


InxClassActivator Methods

InxClassActivator Methods
InxClassActivator Interface Legend Public Methods Send Feedback

The methods of the InxClassActivator class are listed here.

Interface

InxClassActivator Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassActivator.
Links
InxClassActivator Interface, Legend, Public Methods


InxClassActivator.CreateInstance Method

InxClassActivator.CreateInstance Method
InxClassActivator Interface InxClassActivator Members nxllTypes Namespace InxClassActivator Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT;
Description

This is CreateInstance, a member of class InxClassActivator.

Group

InxClassActivator Methods

Links
InxClassActivator Interface, InxClassActivator Members, nxllTypes Namespace, InxClassActivator Methods


InxExceptionData Interface

InxExceptionData Interface
InxExceptionData Methods InxExceptionData Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxExceptionData
Syntax
Delphi
InxExceptionData = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxExceptionData.

Group

Interfaces

Links
InxExceptionData Methods, InxExceptionData Members, nxllTypes, Interfaces


InxExceptionData Members

InxExceptionData Members
InxExceptionData Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxExceptionData.

Interface

InxExceptionData Interface

Public Methods
Name | Description
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
Links
InxExceptionData Interface, Legend, Public Methods


InxExceptionData Methods

InxExceptionData Methods
InxExceptionData Interface Legend Public Methods Send Feedback

The methods of the InxExceptionData class are listed here.

Interface

InxExceptionData Interface

Public Methods
Name | Description
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
Links
InxExceptionData Interface, Legend, Public Methods


InxExceptionData.GetExceptionData Method

InxExceptionData.GetExceptionData Method
InxExceptionData Interface InxExceptionData Members nxllTypes Namespace InxExceptionData Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False);
Description

This is GetExceptionData, a member of class InxExceptionData.

Group

InxExceptionData Methods

Links
InxExceptionData Interface, InxExceptionData Members, nxllTypes Namespace, InxExceptionData Methods


InxExceptionDataContainer Interface

InxExceptionDataContainer Interface
InxExceptionDataContainer Methods InxExceptionDataContainer Properties InxExceptionDataContainer Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxExceptionDataContainernxllTypes_InxExceptionDataContainer
Syntax
Delphi
InxExceptionDataContainer = interface(InxExceptionDataValue);
File

nxllTypes

Description

This is class nxllTypes.InxExceptionDataContainer.

Group

Interfaces

Links
InxExceptionDataContainer Methods, InxExceptionDataContainer Properties, InxExceptionDataContainer Members, nxllTypes, Interfaces


InxExceptionDataContainer Members

InxExceptionDataContainer Members
InxExceptionDataContainer Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxExceptionDataContainer.

Interface

InxExceptionDataContainer Interface

Public Methods
Name | Description
AddContainer | This is AddContainer, a member of class InxExceptionDataContainer.
AddValue | This is the overview for the AddValue method overload.
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetValue | This is GetValue, a member of class InxExceptionDataContainer.
GetValueCount | This is GetValueCount, a member of class InxExceptionDataContainer.
GetValueType | This is GetValueType, a member of class InxExceptionDataValue.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueCount | This is ValueCount, a member of class InxExceptionDataContainer.
Values | This is Values, a member of class InxExceptionDataContainer.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
InxExceptionDataContainer Interface, Legend, Public Methods, Public Properties


InxExceptionDataContainer Methods

InxExceptionDataContainer Methods
InxExceptionDataContainer Interface Legend Public Methods Send Feedback

The methods of the InxExceptionDataContainer class are listed here.

Interface

InxExceptionDataContainer Interface

Public Methods
Name | Description
AddContainer | This is AddContainer, a member of class InxExceptionDataContainer.
AddValue | This is the overview for the AddValue method overload.
GetValue | This is GetValue, a member of class InxExceptionDataContainer.
GetValueCount | This is GetValueCount, a member of class InxExceptionDataContainer.
Links
InxExceptionDataContainer Interface, Legend, Public Methods


InxExceptionDataContainer.AddContainer Method

InxExceptionDataContainer.AddContainer Method
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace InxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function AddContainer(const aName: string): InxExceptionDataContainer; overload;
Description

This is AddContainer, a member of class InxExceptionDataContainer.

Group

InxExceptionDataContainer Methods

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, InxExceptionDataContainer Methods


AddValue Method

AddValue Method
InxExceptionDataContainer Methods Send Feedback

This is the overview for the AddValue method overload.

Overload List
Name | Description
InxExceptionDataContainer.AddValue (string, Boolean) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, Double) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, Int64) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, Pointer) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, string) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, TObject, Boolean) | This is AddValue, a member of class InxExceptionDataContainer.
InxExceptionDataContainer.AddValue (string, Variant) | This is AddValue, a member of class InxExceptionDataContainer.
Group

InxExceptionDataContainer Methods

Links
InxExceptionDataContainer Methods


InxExceptionDataContainer.AddValue Method (string, Boolean)

InxExceptionDataContainer.AddValue Method (string, Boolean)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Boolean); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, Double)

InxExceptionDataContainer.AddValue Method (string, Double)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Double); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, Int64)

InxExceptionDataContainer.AddValue Method (string, Int64)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Int64); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, Pointer)

InxExceptionDataContainer.AddValue Method (string, Pointer)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Pointer); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, TObject, Boolean)

InxExceptionDataContainer.AddValue Method (string, TObject, Boolean)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: TObject; aIncludeChildren: Boolean = False); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, Variant)

InxExceptionDataContainer.AddValue Method (string, Variant)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: Variant); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.AddValue Method (string, string)

InxExceptionDataContainer.AddValue Method (string, string)
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace AddValue Method Send Feedback
Syntax
Delphi
procedure AddValue(const aName: string; const aValue: string); overload;
Description

This is AddValue, a member of class InxExceptionDataContainer.

Group

AddValue Method

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, AddValue Method


InxExceptionDataContainer.GetValue Method

InxExceptionDataContainer.GetValue Method
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace InxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetValue(i: Integer): InxExceptionDataValue;
Description

This is GetValue, a member of class InxExceptionDataContainer.

Group

InxExceptionDataContainer Methods

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, InxExceptionDataContainer Methods


InxExceptionDataContainer.GetValueCount Method

InxExceptionDataContainer.GetValueCount Method
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace InxExceptionDataContainer Methods Send Feedback
Syntax
Delphi
function GetValueCount: Integer;
Description

This is GetValueCount, a member of class InxExceptionDataContainer.

Group

InxExceptionDataContainer Methods

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, InxExceptionDataContainer Methods


InxExceptionDataContainer Properties

InxExceptionDataContainer Properties
InxExceptionDataContainer Interface Legend Public Properties Send Feedback

The properties of the InxExceptionDataContainer class are listed here.

Interface

InxExceptionDataContainer Interface

Public Properties
Name | Description
ValueCount | This is ValueCount, a member of class InxExceptionDataContainer.
Values | This is Values, a member of class InxExceptionDataContainer.
Links
InxExceptionDataContainer Interface, Legend, Public Properties


InxExceptionDataContainer.ValueCount Property

InxExceptionDataContainer.ValueCount Property
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace InxExceptionDataContainer Properties Send Feedback
Syntax
Delphi
property ValueCount: Integer;
Description

This is ValueCount, a member of class InxExceptionDataContainer.

Group

InxExceptionDataContainer Properties

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, InxExceptionDataContainer Properties


InxExceptionDataContainer.Values Property

InxExceptionDataContainer.Values Property
InxExceptionDataContainer Interface InxExceptionDataContainer Members nxllTypes Namespace InxExceptionDataContainer Properties Send Feedback
Syntax
Delphi
property Values [i: Integer]: InxExceptionDataValue;
Description

This is Values, a member of class InxExceptionDataContainer.

Group

InxExceptionDataContainer Properties

Links
InxExceptionDataContainer Interface, InxExceptionDataContainer Members, nxllTypes Namespace, InxExceptionDataContainer Properties


InxExceptionDataValue Interface

InxExceptionDataValue Interface
InxExceptionDataValue Methods InxExceptionDataValue Properties InxExceptionDataValue Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxExceptionDataValue
Syntax
Delphi
InxExceptionDataValue = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxExceptionDataValue.

Group

Interfaces

Links
InxExceptionDataValue Methods, InxExceptionDataValue Properties, InxExceptionDataValue Members, nxllTypes, Interfaces


InxExceptionDataValue Members

InxExceptionDataValue Members
InxExceptionDataValue Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxExceptionDataValue.

Interface

InxExceptionDataValue Interface

Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetValueType | This is GetValueType, a member of class InxExceptionDataValue.
ToString | This is ToString, a member of class InxExceptionDataValue.
Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
InxExceptionDataValue Interface, Legend, Public Methods, Public Properties


InxExceptionDataValue Methods

InxExceptionDataValue Methods
InxExceptionDataValue Interface Legend Public Methods Send Feedback

The methods of the InxExceptionDataValue class are listed here.

Interface

InxExceptionDataValue Interface

Public Methods
Name | Description
AsBoolean | This is AsBoolean, a member of class InxExceptionDataValue.
AsContainer | This is AsContainer, a member of class InxExceptionDataValue.
AsFloat | This is AsFloat, a member of class InxExceptionDataValue.
AsInteger | This is AsInteger, a member of class InxExceptionDataValue.
AsString | This is AsString, a member of class InxExceptionDataValue.
AsVariant | This is AsVariant, a member of class InxExceptionDataValue.
Encode | aVersion for Encode must be Min(ServerVersion,ClientVersion)
GetName | This is GetName, a member of class InxExceptionDataValue.
GetValueType | This is GetValueType, a member of class InxExceptionDataValue.
ToString | This is ToString, a member of class InxExceptionDataValue.
Links
InxExceptionDataValue Interface, Legend, Public Methods


InxExceptionDataValue.AsBoolean Method

InxExceptionDataValue.AsBoolean Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsBoolean: Boolean;
Description

This is AsBoolean, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.AsContainer Method

InxExceptionDataValue.AsContainer Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsContainer: InxExceptionDataContainer;
Description

This is AsContainer, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.AsFloat Method

InxExceptionDataValue.AsFloat Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsFloat: Double;
Description

This is AsFloat, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.AsInteger Method

InxExceptionDataValue.AsInteger Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsInteger: Int64;
Description

This is AsInteger, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.AsString Method

InxExceptionDataValue.AsString Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsString: string;
Description

This is AsString, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.AsVariant Method

InxExceptionDataValue.AsVariant Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function AsVariant: Variant;
Description

This is AsVariant, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.Encode Method

InxExceptionDataValue.Encode Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function Encode(aVersion: Integer): string;
Description

aVersion for Encode must be Min(ServerVersion,ClientVersion)

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.GetName Method

InxExceptionDataValue.GetName Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function GetName: string;
Description

This is GetName, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.GetValueType Method

InxExceptionDataValue.GetValueType Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function GetValueType: TnxDataValueType;
Description

This is GetValueType, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue.ToString Method

InxExceptionDataValue.ToString Method
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Methods Send Feedback
Syntax
Delphi
function ToString: string;
Description

This is ToString, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Methods

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Methods


InxExceptionDataValue Properties

InxExceptionDataValue Properties
InxExceptionDataValue Interface Legend Public Properties Send Feedback

The properties of the InxExceptionDataValue class are listed here.

Interface

InxExceptionDataValue Interface

Public Properties
Name | Description
Name | This is Name, a member of class InxExceptionDataValue.
ValueType | This is ValueType, a member of class InxExceptionDataValue.
Links
InxExceptionDataValue Interface, Legend, Public Properties


InxExceptionDataValue.Name Property

InxExceptionDataValue.Name Property
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is Name, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Properties

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Properties


InxExceptionDataValue.ValueType Property

InxExceptionDataValue.ValueType Property
InxExceptionDataValue Interface InxExceptionDataValue Members nxllTypes Namespace InxExceptionDataValue Properties Send Feedback
Syntax
Delphi
property ValueType: TnxDataValueType;
Description

This is ValueType, a member of class InxExceptionDataValue.

Group

InxExceptionDataValue Properties

Links
InxExceptionDataValue Interface, InxExceptionDataValue Members, nxllTypes Namespace, InxExceptionDataValue Properties


InxSessionNotifications Interface

InxSessionNotifications Interface
InxSessionNotifications Methods InxSessionNotifications Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxSessionNotifications
Syntax
Delphi
InxSessionNotifications = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxSessionNotifications.

Group

Interfaces

Links
InxSessionNotifications Methods, InxSessionNotifications Members, nxllTypes, Interfaces


InxSessionNotifications Members

InxSessionNotifications Members
InxSessionNotifications Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionNotifications.

Interface

InxSessionNotifications Interface

Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
Links
InxSessionNotifications Interface, Legend, Public Methods


InxSessionNotifications Methods

InxSessionNotifications Methods
InxSessionNotifications Interface Legend Public Methods Send Feedback

The methods of the InxSessionNotifications class are listed here.

Interface

InxSessionNotifications Interface

Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
Links
InxSessionNotifications Interface, Legend, Public Methods


InxSessionNotifications.AddNotifier Method

InxSessionNotifications.AddNotifier Method
InxSessionNotifications Interface InxSessionNotifications Members nxllTypes Namespace InxSessionNotifications Methods Send Feedback
Syntax
Delphi
function AddNotifier(const aNotifier: InxSessionNotifier): TnxNotifierID;
Description

This is AddNotifier, a member of class InxSessionNotifications.

Group

InxSessionNotifications Methods

Links
InxSessionNotifications Interface, InxSessionNotifications Members, nxllTypes Namespace, InxSessionNotifications Methods


InxSessionNotifications.RemoveNotifier Method

InxSessionNotifications.RemoveNotifier Method
InxSessionNotifications Interface InxSessionNotifications Members nxllTypes Namespace InxSessionNotifications Methods Send Feedback
Syntax
Delphi
procedure RemoveNotifier(aID: TnxNotifierID);
Description

This is RemoveNotifier, a member of class InxSessionNotifications.

Group

InxSessionNotifications Methods

Links
InxSessionNotifications Interface, InxSessionNotifications Members, nxllTypes Namespace, InxSessionNotifications Methods


InxSessionNotifier Interface

InxSessionNotifier Interface
InxSessionNotifier Methods InxSessionNotifier Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxSessionNotifier
Syntax
Delphi
InxSessionNotifier = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxSessionNotifier.

Group

Interfaces

Links
InxSessionNotifier Methods, InxSessionNotifier Members, nxllTypes, Interfaces


InxSessionNotifier Members

InxSessionNotifier Members
InxSessionNotifier Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionNotifier.

Interface

InxSessionNotifier Interface

Public Methods
Name | Description
Disconnected | Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.
Links
InxSessionNotifier Interface, Legend, Public Methods


InxSessionNotifier Methods

InxSessionNotifier Methods
InxSessionNotifier Interface Legend Public Methods Send Feedback

The methods of the InxSessionNotifier class are listed here.

Interface

InxSessionNotifier Interface

Public Methods
Name | Description
Disconnected | Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.
Links
InxSessionNotifier Interface, Legend, Public Methods


InxSessionNotifier.Disconnected Method

InxSessionNotifier.Disconnected Method
InxSessionNotifier Interface InxSessionNotifier Members nxllTypes Namespace InxSessionNotifier Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

Called if the session has been disconnected. Release all references still held to that session after receiving this notification. It's not required to call RemoveNotifier. The reference to this interface will be removed after the Disconnected call returns.

Group

InxSessionNotifier Methods

Links
InxSessionNotifier Interface, InxSessionNotifier Members, nxllTypes Namespace, InxSessionNotifier Methods


InxSessionRequests Interface

InxSessionRequests Interface
InxSessionRequests Methods InxSessionRequests Members nxllTypes Interfaces Send Feedback
Class Hierarchy
nxllTypes_InxSessionRequests
Syntax
Delphi
InxSessionRequests = interface(InxInterface);
File

nxllTypes

Description

This is class nxllTypes.InxSessionRequests.

Group

Interfaces

Links
InxSessionRequests Methods, InxSessionRequests Members, nxllTypes, Interfaces


InxSessionRequests Members

InxSessionRequests Members
InxSessionRequests Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSessionRequests.

Interface

InxSessionRequests Interface

Public Methods
Name | Description
ProcessPost | This is ProcessPost, a member of class InxSessionRequests.
ProcessRequest | This is ProcessRequest, a member of class InxSessionRequests.
ProcessRequestDirect | This is ProcessRequestDirect, a member of class InxSessionRequests.
Links
InxSessionRequests Interface, Legend, Public Methods


InxSessionRequests Methods

InxSessionRequests Methods
InxSessionRequests Interface Legend Public Methods Send Feedback

The methods of the InxSessionRequests class are listed here.

Interface

InxSessionRequests Interface

Public Methods
Name | Description
ProcessPost | This is ProcessPost, a member of class InxSessionRequests.
ProcessRequest | This is ProcessRequest, a member of class InxSessionRequests.
ProcessRequestDirect | This is ProcessRequestDirect, a member of class InxSessionRequests.
Links
InxSessionRequests Interface, Legend, Public Methods


InxSessionRequests.ProcessPost Method

InxSessionRequests.ProcessPost Method
InxSessionRequests Interface InxSessionRequests Members nxllTypes Namespace InxSessionRequests Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Description

This is ProcessPost, a member of class InxSessionRequests.

Group

InxSessionRequests Methods

Links
InxSessionRequests Interface, InxSessionRequests Members, nxllTypes Namespace, InxSessionRequests Methods


InxSessionRequests.ProcessRequest Method

InxSessionRequests.ProcessRequest Method
InxSessionRequests Interface InxSessionRequests Members nxllTypes Namespace InxSessionRequests Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

This is ProcessRequest, a member of class InxSessionRequests.

Group

InxSessionRequests Methods

Links
InxSessionRequests Interface, InxSessionRequests Members, nxllTypes Namespace, InxSessionRequests Methods


InxSessionRequests.ProcessRequestDirect Method

InxSessionRequests.ProcessRequestDirect Method
InxSessionRequests Interface InxSessionRequests Members nxllTypes Namespace InxSessionRequests Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

This is ProcessRequestDirect, a member of class InxSessionRequests.

Group

InxSessionRequests Methods

Links
InxSessionRequests Interface, InxSessionRequests Members, nxllTypes Namespace, InxSessionRequests Methods


Functions

Functions
Functions nxllTypes Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
Noop | This is function nxllTypes.Noop.
Namespace

nxllTypes Namespace

Links
Functions, nxllTypes Namespace, Legend


nxllTypes.Noop Function

nxllTypes.Noop Function
nxllTypes Functions Send Feedback
Syntax
Delphi
procedure Noop; register;
File

nxllTypes

Description

This is function nxllTypes.Noop.

Group

Functions

Links
nxllTypes, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBlockSizeAll | This is record nxllTypes.TnxBlockSizeAll.
TnxDataValueType | Do not modify order or remove entries, stored as integer in over the wire streams
TnxNetMsgDataType | ..it's a stream (TStream descendant), the stream will be left at the end
Namespace

nxllTypes Namespace

Records
Name | Description
TMemoryManager | This is record nxllTypes.TMemoryManager.
TMULTI_QI | This is record nxllTypes.TMULTI_QI.
TnxFmtBcd | This is record nxllTypes.TnxFmtBcd.
TnxInt64Rec | This is record nxllTypes.TnxInt64Rec.
TnxMemoryManagerImpl | This is record nxllTypes.TnxMemoryManagerImpl.
TnxWord64Rec | This is record nxllTypes.TnxWord64Rec.
Links
Enumerations, nxllTypes Namespace, Legend, Records


nxllTypes.TMemoryManager Record

nxllTypes.TMemoryManager Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TMemoryManager = record
  GetMem: function(Size: Integer): Pointer;
  FreeMem: function(P: Pointer): Integer;
  ReallocMem: function(P: Pointer; Size: Integer): Pointer;
end;
File

nxllTypes

Description

This is record nxllTypes.TMemoryManager.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TMULTI_QI Record

nxllTypes.TMULTI_QI Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TMULTI_QI = record
  IID: PGUID;
  pItf: IInterface;
  hr: HRESULT;
end;
File

nxllTypes

Description

This is record nxllTypes.TMULTI_QI.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxBlockSizeAll Enumeration

nxllTypes.TnxBlockSizeAll Enumeration
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlockSizeAll = ( nxbs4k, nxbs8k, nxbs16k, nxbs32k, nxbs64k, nxbs4M );
File

nxllTypes

Description

This is record nxllTypes.TnxBlockSizeAll.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxDataValueType Enumeration

nxllTypes.TnxDataValueType Enumeration
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDataValueType = ( dvtString, dvtInt64, dvtBoolean, dvtFloat, dvtVariant, dvtContainer );
File

nxllTypes

Description

Do not modify order or remove entries, stored as integer in over the wire streams

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxFmtBcd Record

nxllTypes.TnxFmtBcd Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxFmtBcd = packed record
  Precision: Byte;
  SignSpecialPlaces: Byte;
  Fraction: packed array [0..31] of Byte;
end;
File

nxllTypes

Members
Members | Description
Precision: Byte; | 1..64
SignSpecialPlaces: Byte; | Sign:1, Special:1, Places:6
Fraction: packed array [0..31] of Byte; | BCD Nibbles, 00..99 per Byte, high Nibble 1st
Description

This is record nxllTypes.TnxFmtBcd.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxInt64Rec Record

nxllTypes.TnxInt64Rec Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInt64Rec = record
  case Integer of
    0: (Value: TnxInt64;);
    1: (iLow: TnxWord32;
        iHigh: TnxInt32;);
end;
File

nxllTypes

Description

This is record nxllTypes.TnxInt64Rec.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxMemoryManagerImpl Record

nxllTypes.TnxMemoryManagerImpl Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMemoryManagerImpl = record
  __MemoryManager: TMemoryManager;
  __GetPool: Pointer;
  __GetAllocSize: Pointer;
  __GetHeapStatus: Pointer;
  __BlockPoolsCommitted: array[TnxBlockSizeAll] of Pointer;
  __EmptyBlock: Pointer;
  __BlockPoolsPhysical: array[TnxBlockSizeAll] of Pointer;
  __TnxBlockPoolCommitted_Alloc: Pointer;
  __TnxBlockPoolCommitted_Dispose: Pointer;
  __TnxBlockPoolPhysical_Alloc: Pointer;
  __TnxBlockPoolPhysical_Dispose: Pointer;
  __TnxMemoryPool_Alloc: Pointer;
  __TnxMemoryPool_Dispose: Pointer;
  __nxAWEAvailable: LongBool;
  __nxAWESupported: LongBool;
  __nxMapableBlockAllocate: Pointer;
  __nxMapableBlockDispose: Pointer;
  __nxMapableBlockLock: Pointer;
  __nxMapableBlockUnlock: Pointer;
  __nxMapableChunkAllocate: Pointer;
  __nxMapableChunkDispose: Pointer;
  __nxMapableChunkLock: Pointer;
  __nxMapableChunkUnlock: Pointer;
  __AddRef: Pointer;
  __Release: Pointer;
  __nxMapableBlocksLock: Pointer;
  __nxMapableBlocksUnlock: Pointer;
  __ForceCleanup: Pointer;
  __ChunkEmergencyCommitted: Pointer;
  __ChunkEmergencyPhysical: Pointer;
  __PhysicalEmergency: Pointer;
  __nxSecureFreeMem: Pointer;
  __LicenseKeyStatus: PAnsiChar;
  __nxGetMemLow: Pointer;
  __LicenseHasFeature: Pointer;
end;
File

nxllTypes

Description

This is record nxllTypes.TnxMemoryManagerImpl.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxNetMsgDataType Enumeration

nxllTypes.TnxNetMsgDataType Enumeration
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxNetMsgDataType = ( nmdByteArray, nmdStream, nmdStreamLeavePosition );
File

nxllTypes

Members
Members | Description
nmdByteArray | ..it's an array of bytes
nmdStream | ..it's a stream (TStream descendant)
Description

..it's a stream (TStream descendant), the stream will be left at the end

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


nxllTypes.TnxWord64Rec Record

nxllTypes.TnxWord64Rec Record
nxllTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWord64Rec = record
  case Integer of
    0: (Value: TnxInt64;);
    1: (iLow: TnxWord32;
        iHigh: TnxWord32;);
end;
File

nxllTypes

Description

This is record nxllTypes.TnxWord64Rec.

Group

Structs, Records, Enums

Links
nxllTypes, Structs, Records, Enums


Types

Types
nxllTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllTypes Namespace

Types
Name | Description
InxInterface | This is type nxllTypes.InxInterface.
InxInvokable | HPPEMIT 'namespace Nxlltypes {' HPPEMIT ' typedef IInvokable InxInvokable;' HPPEMIT '}'
PComp | This is type nxllTypes.PComp.
PLongBool | missing from system.pas in older versions
PMemoryManager | This is type nxllTypes.PMemoryManager.
PMULTI_QI | This is type nxllTypes.PMULTI_QI.
PnxAnsiChar | Pointer to a 8-bit AnsiChar
PnxAnsiCharArray | For debugging purposes.
PnxBcd | This is type nxllTypes.PnxBcd.
PnxBoolean | Pointer to a 8-bit Boolean
PnxByte8 | Pointer to a 8-bit unsigned Integer
PnxByteArray | General array of bytes
PnxCardinalArray | General array of long Cardinals
PnxCurrency | This is type nxllTypes.PnxCurrency.
PnxDate | Pointer to a 4 byte date value
PnxDateTime | Pointer to a 8 byte date/time value
PnxDouble | This is type nxllTypes.PnxDouble.
PnxDynByteArray | This is type nxllTypes.PnxDynByteArray.
PnxExtended | This is type nxllTypes.PnxExtended.
PnxFmtBcd | This is type nxllTypes.PnxFmtBcd.
PnxGuid | This is type nxllTypes.PnxGuid.
PnxInt16 | Pointer to a 16-bit signed Integer
PnxInt32 | Pointer to a 32-bit signed Integer
PnxInt64 | Pointer to a 64-bit signed Integer
PnxInt64Rec | This is type nxllTypes.PnxInt64Rec.
PnxInt8 | Pointer to a 8-bit signed Integer
PnxIntegerArray | General array of long integers
PnxInterface | This is type nxllTypes.PnxInterface.
PnxMemoryManagerImpl | This is type nxllTypes.PnxMemoryManagerImpl.
PnxMsgID | This is type nxllTypes.PnxMsgID.
PnxNativeInt | This is type nxllTypes.PnxNativeInt.
PnxNativeUInt | This is type nxllTypes.PnxNativeUInt.
PnxPointerArray | General array of pointer
PnxPPointerArray | General array of pointer to pointers
PnxResult | This is type nxllTypes.PnxResult.
PnxShStr | Pointer to a length-byte string
PnxSingle | This is type nxllTypes.PnxSingle.
PnxTime | Pointer to a 4 byte time value
PnxUnicodeStrings | This is type nxllTypes.PnxUnicodeStrings.
PnxWideChar | Pointer to a 16-bit WideChar
PnxWideCharArray | For debugging purposes.
PnxWord16 | Pointer to a 16-bit unsigned Integer
PnxWord32 | Pointer to a 32-bit unsigned Integer
PnxWord64Rec | This is type nxllTypes.PnxWord64Rec.
PPnxByteArray | This is type nxllTypes.PPnxByteArray.
PUnicodeString | This is type nxllTypes.PUnicodeString.
RawByteString | This is type nxllTypes.RawByteString.
TAfterBlockPoolAlloc | This is type nxllTypes.TAfterBlockPoolAlloc.
TAfterGetAllocSize | This is type nxllTypes.TAfterGetAllocSize.
TAfterGetMem | This is type nxllTypes.TAfterGetMem.
TAfterMemoryPoolAlloc | This is type nxllTypes.TAfterMemoryPoolAlloc.
TAfterReallocMem | This is type nxllTypes.TAfterReallocMem.
TBeforeBlockPoolDispose | This is type nxllTypes.TBeforeBlockPoolDispose.
TBeforeFreeMem | This is type nxllTypes.TBeforeFreeMem.
TBeforeGetAllocSize | This is type nxllTypes.TBeforeGetAllocSize.
TBeforeGetMem | This is type nxllTypes.TBeforeGetMem.
TBeforeGetPool | This is type nxllTypes.TBeforeGetPool.
TBeforeMemoryPoolDispose | This is type nxllTypes.TBeforeMemoryPoolDispose.
TBeforeReallocMem | This is type nxllTypes.TBeforeReallocMem.
TnxAnsiChar | 8-bit AnsiChar
TnxAnsiCharArray | This is type nxllTypes.TnxAnsiCharArray.
TnxBaseID | This is type nxllTypes.TnxBaseID.
TnxBcd | This is type nxllTypes.TnxBcd.
TnxBlockSize | This is type nxllTypes.TnxBlockSize.
TnxBlockSizes | This is type nxllTypes.TnxBlockSizes.
TnxBoolean | 8-bit Boolean
TnxByte8 | 8-bit unsigned Integer
TnxByteArray | This is type nxllTypes.TnxByteArray.
TnxBytes | This is type nxllTypes.TnxBytes.
TnxCardinalArray | This is type nxllTypes.TnxCardinalArray.
TnxCharSet | This is type nxllTypes.TnxCharSet.
TnxCurrency | This is type nxllTypes.TnxCurrency.
TnxDate | 4 byte date value; One plus number of days since 1/1/0001
TnxDateTime | 8 byte date/time value; Number of milliseconds since midnight on one plus number of days since 1/1/0001
TnxDouble | This is type nxllTypes.TnxDouble.
TnxDynByteArray | This is type nxllTypes.TnxDynByteArray.
TnxDynCardinalArray | This is type nxllTypes.TnxDynCardinalArray.
TnxDynDoubleArray | This is type nxllTypes.TnxDynDoubleArray.
TnxDynIntegerArray | This is type nxllTypes.TnxDynIntegerArray.
TnxDynObjectArray | This is type nxllTypes.TnxDynObjectArray.
TnxDynPointerArray | This is type nxllTypes.TnxDynPointerArray.
TnxDynStringArray | This is type nxllTypes.TnxDynStringArray.
TnxDynVariantArray | This is type nxllTypes.TnxDynVariantArray.
TnxDynWord16Array | This is type nxllTypes.TnxDynWord16Array.
TnxExtended | This is type nxllTypes.TnxExtended.
TnxGuid | This is type nxllTypes.TnxGuid.
TnxInt16 | 16-bit signed Integer
TnxInt32 | 32-bit signed Integer
TnxInt64 | 64-bit signed Integer
TnxInt8 | 8-bit signed Integer
TnxIntegerArray | This is type nxllTypes.TnxIntegerArray.
TnxMemSize | type for size of memory to alloc/free
TnxMsgID | This is type nxllTypes.TnxMsgID.
TnxNativeHalfUInt | This is type nxllTypes.TnxNativeHalfUInt.
TnxNativeInt | This is type nxllTypes.TnxNativeInt.
TnxNativeUInt | This is type nxllTypes.TnxNativeUInt.
TnxNotifierID | This is type nxllTypes.TnxNotifierID.
TnxPointerArray | This is type nxllTypes.TnxPointerArray.
TnxPPointerArray | This is type nxllTypes.TnxPPointerArray.
TnxResult | This is type nxllTypes.TnxResult.
TnxSessionID | This is type nxllTypes.TnxSessionID.
TnxShStr | a length-byte string
TnxSingle | This is type nxllTypes.TnxSingle.
TnxStringZ | For converting ShortStrings to StringZs
TnxThreadPriority | This is type nxllTypes.TnxThreadPriority.
TnxTime | 4 byte time value; Number of milliseconds since midnight
TnxTransportID | TnxRequestID = type TnxBaseID;
TnxUnicodeStrings | This is type nxllTypes.TnxUnicodeStrings.
TnxValueRelationship | This is type nxllTypes.TnxValueRelationship.
TnxWideChar | 16-bit WideChar
TnxWideCharArray | This is type nxllTypes.TnxWideCharArray.
TnxWideString | This is type nxllTypes.TnxWideString.
TnxWord16 | 16-bit unsigned Integer
TnxWord32 | 32-bit unsigned Integer
UnicodeString | This is type nxllTypes.UnicodeString.
Links
nxllTypes Namespace, Types


nxllTypes.InxInterface Type

nxllTypes.InxInterface Type
nxllTypes Types Send Feedback
Syntax
Delphi
InxInterface = IInterface;
File

nxllTypes

Description

This is type nxllTypes.InxInterface.

Group

Types

Links
nxllTypes, Types


nxllTypes.InxInvokable Type

nxllTypes.InxInvokable Type
nxllTypes Types Send Feedback
Syntax
Delphi
InxInvokable = IInvokable;
File

nxllTypes

Description

HPPEMIT 'namespace Nxlltypes {' HPPEMIT ' typedef IInvokable InxInvokable;' HPPEMIT '}'

Group

Types

Links
nxllTypes, Types


nxllTypes.PComp Type

nxllTypes.PComp Type
nxllTypes Types Send Feedback
Syntax
Delphi
PComp = ^Comp;
File

nxllTypes

Description

This is type nxllTypes.PComp.

Group

Types

Links
nxllTypes, Types


nxllTypes.PLongBool Type

nxllTypes.PLongBool Type
nxllTypes Types Send Feedback
Syntax
Delphi
PLongBool = ^LongBool;
File

nxllTypes

Description

missing from system.pas in older versions

Group

Types

Links
nxllTypes, Types


nxllTypes.PMemoryManager Type

nxllTypes.PMemoryManager Type
nxllTypes Types Send Feedback
Syntax
Delphi
PMemoryManager = ^TMemoryManager;
File

nxllTypes

Description

This is type nxllTypes.PMemoryManager.

Group

Types

Links
nxllTypes, Types


nxllTypes.PMULTI_QI Type

nxllTypes.PMULTI_QI Type
nxllTypes Types Send Feedback
Syntax
Delphi
PMULTI_QI = ^TMULTI_QI;
File

nxllTypes

Description

This is type nxllTypes.PMULTI_QI.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxAnsiChar Type

nxllTypes.PnxAnsiChar Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxAnsiChar = ^TnxAnsiChar;
File

nxllTypes

Description

Pointer to a 8-bit AnsiChar

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxAnsiCharArray Type

nxllTypes.PnxAnsiCharArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxAnsiCharArray = ^TnxAnsiCharArray;
File

nxllTypes

Description

For debugging purposes.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxBcd Type

nxllTypes.PnxBcd Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxBcd = ^TnxBcd;
File

nxllTypes

Description

This is type nxllTypes.PnxBcd.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxBoolean Type

nxllTypes.PnxBoolean Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxBoolean = ^TnxBoolean;
File

nxllTypes

Description

Pointer to a 8-bit Boolean

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxByte8 Type

nxllTypes.PnxByte8 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxByte8 = ^TnxByte8;
File

nxllTypes

Description

Pointer to a 8-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxByteArray Type

nxllTypes.PnxByteArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxByteArray = ^TnxByteArray;
File

nxllTypes

Description

General array of bytes

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxCardinalArray Type

nxllTypes.PnxCardinalArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxCardinalArray = ^TnxCardinalArray;
File

nxllTypes

Description

General array of long Cardinals

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxCurrency Type

nxllTypes.PnxCurrency Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxCurrency = ^TnxCurrency;
File

nxllTypes

Description

This is type nxllTypes.PnxCurrency.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxDate Type

nxllTypes.PnxDate Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxDate = ^TnxDate;
File

nxllTypes

Description

Pointer to a 4 byte date value

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxDateTime Type

nxllTypes.PnxDateTime Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxDateTime = ^TnxDateTime;
File

nxllTypes

Description

Pointer to a 8 byte date/time value

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxDouble Type

nxllTypes.PnxDouble Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxDouble = ^TnxDouble;
File

nxllTypes

Description

This is type nxllTypes.PnxDouble.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxDynByteArray Type

nxllTypes.PnxDynByteArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxDynByteArray = ^TnxDynByteArray;
File

nxllTypes

Description

This is type nxllTypes.PnxDynByteArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxExtended Type

nxllTypes.PnxExtended Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxExtended = ^TnxExtended;
File

nxllTypes

Description

This is type nxllTypes.PnxExtended.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxFmtBcd Type

nxllTypes.PnxFmtBcd Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxFmtBcd = ^TnxFmtBcd;
File

nxllTypes

Description

This is type nxllTypes.PnxFmtBcd.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxGuid Type

nxllTypes.PnxGuid Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxGuid = ^TnxGuid;
File

nxllTypes

Description

This is type nxllTypes.PnxGuid.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInt16 Type

nxllTypes.PnxInt16 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInt16 = ^TnxInt16;
File

nxllTypes

Description

Pointer to a 16-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInt32 Type

nxllTypes.PnxInt32 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInt32 = ^TnxInt32;
File

nxllTypes

Description

Pointer to a 32-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInt64 Type

nxllTypes.PnxInt64 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInt64 = ^TnxInt64;
File

nxllTypes

Description

Pointer to a 64-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInt64Rec Type

nxllTypes.PnxInt64Rec Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInt64Rec = ^TnxInt64Rec;
File

nxllTypes

Description

This is type nxllTypes.PnxInt64Rec.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInt8 Type

nxllTypes.PnxInt8 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInt8 = ^TnxInt8;
File

nxllTypes

Description

Pointer to a 8-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxIntegerArray Type

nxllTypes.PnxIntegerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxIntegerArray = ^TnxIntegerArray;
File

nxllTypes

Description

General array of long integers

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxInterface Type

nxllTypes.PnxInterface Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxInterface = ^InxInterface;
File

nxllTypes

Description

This is type nxllTypes.PnxInterface.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxMemoryManagerImpl Type

nxllTypes.PnxMemoryManagerImpl Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxMemoryManagerImpl = ^TnxMemoryManagerImpl;
File

nxllTypes

Description

This is type nxllTypes.PnxMemoryManagerImpl.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxMsgID Type

nxllTypes.PnxMsgID Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxMsgID = ^TnxMsgID;
File

nxllTypes

Description

This is type nxllTypes.PnxMsgID.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxNativeInt Type

nxllTypes.PnxNativeInt Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxNativeInt = ^TnxNativeInt;
File

nxllTypes

Description

This is type nxllTypes.PnxNativeInt.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxNativeUInt Type

nxllTypes.PnxNativeUInt Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxNativeUInt = ^TnxNativeUInt;
File

nxllTypes

Description

This is type nxllTypes.PnxNativeUInt.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxPointerArray Type

nxllTypes.PnxPointerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxPointerArray = ^TnxPointerArray;
File

nxllTypes

Description

General array of pointer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxPPointerArray Type

nxllTypes.PnxPPointerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxPPointerArray = ^TnxPPointerArray;
File

nxllTypes

Description

General array of pointer to pointers

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxResult Type

nxllTypes.PnxResult Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxResult = ^TnxResult;
File

nxllTypes

Description

This is type nxllTypes.PnxResult.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxShStr Type

nxllTypes.PnxShStr Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxShStr = ^TnxShStr;
File

nxllTypes

Description

Pointer to a length-byte string

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxSingle Type

nxllTypes.PnxSingle Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxSingle = ^TnxSingle;
File

nxllTypes

Description

This is type nxllTypes.PnxSingle.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxTime Type

nxllTypes.PnxTime Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxTime = ^TnxTime;
File

nxllTypes

Description

Pointer to a 4 byte time value

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxUnicodeStrings Type

nxllTypes.PnxUnicodeStrings Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxUnicodeStrings = ^TnxUnicodeStrings;
File

nxllTypes

Description

This is type nxllTypes.PnxUnicodeStrings.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxWideChar Type

nxllTypes.PnxWideChar Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxWideChar = ^TnxWideChar;
File

nxllTypes

Description

Pointer to a 16-bit WideChar

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxWideCharArray Type

nxllTypes.PnxWideCharArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxWideCharArray = ^TnxWideCharArray;
File

nxllTypes

Description

For debugging purposes.

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxWord16 Type

nxllTypes.PnxWord16 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxWord16 = ^TnxWord16;
File

nxllTypes

Description

Pointer to a 16-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxWord32 Type

nxllTypes.PnxWord32 Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxWord32 = ^TnxWord32;
File

nxllTypes

Description

Pointer to a 32-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.PnxWord64Rec Type

nxllTypes.PnxWord64Rec Type
nxllTypes Types Send Feedback
Syntax
Delphi
PnxWord64Rec = ^TnxWord64Rec;
File

nxllTypes

Description

This is type nxllTypes.PnxWord64Rec.

Group

Types

Links
nxllTypes, Types


nxllTypes.PPnxByteArray Type

nxllTypes.PPnxByteArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
PPnxByteArray = ^PnxByteArray;
File

nxllTypes

Description

This is type nxllTypes.PPnxByteArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.PUnicodeString Type

nxllTypes.PUnicodeString Type
nxllTypes Types Send Feedback
Syntax
Delphi
PUnicodeString = ^UnicodeString;
File

nxllTypes

Description

This is type nxllTypes.PUnicodeString.

Group

Types

Links
nxllTypes, Types


nxllTypes.RawByteString Type

nxllTypes.RawByteString Type
nxllTypes Types Send Feedback
Syntax
Delphi
RawByteString = AnsiString;
File

nxllTypes

Description

This is type nxllTypes.RawByteString.

Group

Types

Links
nxllTypes, Types


nxllTypes.TAfterBlockPoolAlloc Type

nxllTypes.TAfterBlockPoolAlloc Type
nxllTypes Types Send Feedback
Syntax
Delphi
TAfterBlockPoolAlloc = procedure (p: Pointer ; aLow: Boolean );
File

nxllTypes

Description

This is type nxllTypes.TAfterBlockPoolAlloc.

Group

Types

Links
nxllTypes, Types


nxllTypes.TAfterGetAllocSize Type

nxllTypes.TAfterGetAllocSize Type
nxllTypes Types Send Feedback
Syntax
Delphi
TAfterGetAllocSize = procedure (p: Pointer; var aSize: TnxMemSize);
File

nxllTypes

Description

This is type nxllTypes.TAfterGetAllocSize.

Group

Types

Links
nxllTypes, Types


nxllTypes.TAfterGetMem Type

nxllTypes.TAfterGetMem Type
nxllTypes Types Send Feedback
Syntax
Delphi
TAfterGetMem = procedure (aSize: TnxMemSize; var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TAfterGetMem.

Group

Types

Links
nxllTypes, Types


nxllTypes.TAfterMemoryPoolAlloc Type

nxllTypes.TAfterMemoryPoolAlloc Type
nxllTypes Types Send Feedback
Syntax
Delphi
TAfterMemoryPoolAlloc = procedure (aSize: TnxMemSize; var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TAfterMemoryPoolAlloc.

Group

Types

Links
nxllTypes, Types


nxllTypes.TAfterReallocMem Type

nxllTypes.TAfterReallocMem Type
nxllTypes Types Send Feedback
Syntax
Delphi
TAfterReallocMem = procedure (aSize: TnxMemSize; var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TAfterReallocMem.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeBlockPoolDispose Type

nxllTypes.TBeforeBlockPoolDispose Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeBlockPoolDispose = procedure (p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TBeforeBlockPoolDispose.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeFreeMem Type

nxllTypes.TBeforeFreeMem Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeFreeMem = procedure (var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TBeforeFreeMem.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeGetAllocSize Type

nxllTypes.TBeforeGetAllocSize Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeGetAllocSize = procedure (var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TBeforeGetAllocSize.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeGetMem Type

nxllTypes.TBeforeGetMem Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeGetMem = procedure (var aSize: TnxMemSize);
File

nxllTypes

Description

This is type nxllTypes.TBeforeGetMem.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeGetPool Type

nxllTypes.TBeforeGetPool Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeGetPool = procedure (var aSize: TnxMemSize);
File

nxllTypes

Description

This is type nxllTypes.TBeforeGetPool.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeMemoryPoolDispose Type

nxllTypes.TBeforeMemoryPoolDispose Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeMemoryPoolDispose = procedure (var p: Pointer);
File

nxllTypes

Description

This is type nxllTypes.TBeforeMemoryPoolDispose.

Group

Types

Links
nxllTypes, Types


nxllTypes.TBeforeReallocMem Type

nxllTypes.TBeforeReallocMem Type
nxllTypes Types Send Feedback
Syntax
Delphi
TBeforeReallocMem = procedure (var p: Pointer; var aSize: TnxMemSize);
File

nxllTypes

Description

This is type nxllTypes.TBeforeReallocMem.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxAnsiChar Type

nxllTypes.TnxAnsiChar Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxAnsiChar = AnsiChar;
File

nxllTypes

Description

8-bit AnsiChar

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxAnsiCharArray Type

nxllTypes.TnxAnsiCharArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxAnsiCharArray = array[0..Pred(High(Integer))] of TnxAnsiChar;
File

nxllTypes

Description

This is type nxllTypes.TnxAnsiCharArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBaseID Type

nxllTypes.TnxBaseID Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBaseID = type TnxWord32;
File

nxllTypes

Description

This is type nxllTypes.TnxBaseID.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBcd Type

nxllTypes.TnxBcd Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBcd = Currency;
File

nxllTypes

Description

This is type nxllTypes.TnxBcd.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBlockSize Type

nxllTypes.TnxBlockSize Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBlockSize = nxbs4k..nxbs64k;
File

nxllTypes

Description

This is type nxllTypes.TnxBlockSize.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBlockSizes Type

nxllTypes.TnxBlockSizes Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBlockSizes = set of TnxBlockSize;
File

nxllTypes

Description

This is type nxllTypes.TnxBlockSizes.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBoolean Type

nxllTypes.TnxBoolean Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBoolean = ByteBool;
File

nxllTypes

Description

8-bit Boolean

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxByte8 Type

nxllTypes.TnxByte8 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxByte8 = Byte;
File

nxllTypes

Description

8-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxByteArray Type

nxllTypes.TnxByteArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxByteArray = array[0..Pred(High(Integer))] of Byte;
File

nxllTypes

Description

This is type nxllTypes.TnxByteArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxBytes Type

nxllTypes.TnxBytes Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxBytes = TByteDynArray;
File

nxllTypes

Description

This is type nxllTypes.TnxBytes.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxCardinalArray Type

nxllTypes.TnxCardinalArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxCardinalArray = array [0..Pred(High(Integer) div SizeOf(Cardinal))] of Cardinal;
File

nxllTypes

Description

This is type nxllTypes.TnxCardinalArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxCharSet Type

nxllTypes.TnxCharSet Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxCharSet = set of AnsiChar;
File

nxllTypes

Description

This is type nxllTypes.TnxCharSet.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxCurrency Type

nxllTypes.TnxCurrency Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxCurrency = Currency;
File

nxllTypes

Description

This is type nxllTypes.TnxCurrency.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDate Type

nxllTypes.TnxDate Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDate = type Integer;
File

nxllTypes

Description

4 byte date value; One plus number of days since 1/1/0001

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDateTime Type

nxllTypes.TnxDateTime Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDateTime = Double;
File

nxllTypes

Description

8 byte date/time value; Number of milliseconds since midnight on one plus number of days since 1/1/0001

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDouble Type

nxllTypes.TnxDouble Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDouble = Double;
File

nxllTypes

Description

This is type nxllTypes.TnxDouble.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynByteArray Type

nxllTypes.TnxDynByteArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynByteArray = TnxBytes;
File

nxllTypes

Description

This is type nxllTypes.TnxDynByteArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynCardinalArray Type

nxllTypes.TnxDynCardinalArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynCardinalArray = array of Cardinal;
File

nxllTypes

Description

This is type nxllTypes.TnxDynCardinalArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynDoubleArray Type

nxllTypes.TnxDynDoubleArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynDoubleArray = array of TnxDouble;
File

nxllTypes

Description

This is type nxllTypes.TnxDynDoubleArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynIntegerArray Type

nxllTypes.TnxDynIntegerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynIntegerArray = array of Integer;
File

nxllTypes

Description

This is type nxllTypes.TnxDynIntegerArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynObjectArray Type

nxllTypes.TnxDynObjectArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynObjectArray = array of TObject;
File

nxllTypes

Description

This is type nxllTypes.TnxDynObjectArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynPointerArray Type

nxllTypes.TnxDynPointerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynPointerArray = array of Pointer;
File

nxllTypes

Description

This is type nxllTypes.TnxDynPointerArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynStringArray Type

nxllTypes.TnxDynStringArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynStringArray = TStringDynArray;
File

nxllTypes

Description

This is type nxllTypes.TnxDynStringArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynVariantArray Type

nxllTypes.TnxDynVariantArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynVariantArray = array of Variant;
File

nxllTypes

Description

This is type nxllTypes.TnxDynVariantArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxDynWord16Array Type

nxllTypes.TnxDynWord16Array Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxDynWord16Array = array of TnxWord16;
File

nxllTypes

Description

This is type nxllTypes.TnxDynWord16Array.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxExtended Type

nxllTypes.TnxExtended Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxExtended = Extended;
File

nxllTypes

Description

This is type nxllTypes.TnxExtended.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxGuid Type

nxllTypes.TnxGuid Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxGuid = TGuid;
File

nxllTypes

Description

This is type nxllTypes.TnxGuid.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxInt16 Type

nxllTypes.TnxInt16 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxInt16 = Smallint;
File

nxllTypes

Description

16-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxInt32 Type

nxllTypes.TnxInt32 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxInt32 = Integer;
File

nxllTypes

Description

32-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxInt64 Type

nxllTypes.TnxInt64 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxInt64 = Int64;
File

nxllTypes

Description

64-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxInt8 Type

nxllTypes.TnxInt8 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxInt8 = Shortint;
File

nxllTypes

Description

8-bit signed Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxIntegerArray Type

nxllTypes.TnxIntegerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxIntegerArray = array [0..Pred(High(Integer) div SizeOf(Integer))] of Integer;
File

nxllTypes

Description

This is type nxllTypes.TnxIntegerArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxMemSize Type

nxllTypes.TnxMemSize Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxMemSize = TnxNativeInt;
File

nxllTypes

Description

type for size of memory to alloc/free

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxMsgID Type

nxllTypes.TnxMsgID Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxMsgID = type TnxBaseID;
File

nxllTypes

Description

This is type nxllTypes.TnxMsgID.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxNativeHalfUInt Type

nxllTypes.TnxNativeHalfUInt Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxNativeHalfUInt = Word;
File

nxllTypes

Description

This is type nxllTypes.TnxNativeHalfUInt.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxNativeInt Type

nxllTypes.TnxNativeInt Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxNativeInt = Integer;
File

nxllTypes

Description

This is type nxllTypes.TnxNativeInt.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxNativeUInt Type

nxllTypes.TnxNativeUInt Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxNativeUInt = Cardinal;
File

nxllTypes

Description

This is type nxllTypes.TnxNativeUInt.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxNotifierID Type

nxllTypes.TnxNotifierID Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxNotifierID = type TnxGuid;
File

nxllTypes

Description

This is type nxllTypes.TnxNotifierID.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxPointerArray Type

nxllTypes.TnxPointerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxPointerArray = array [0..Pred(High(Integer) div SizeOf(Pointer))] of Pointer;
File

nxllTypes

Description

This is type nxllTypes.TnxPointerArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxPPointerArray Type

nxllTypes.TnxPPointerArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxPPointerArray = array [0..Pred(High(Integer) div SizeOf(PPointer))] of PPointer;
File

nxllTypes

Description

This is type nxllTypes.TnxPPointerArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxResult Type

nxllTypes.TnxResult Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxResult = TnxWord32;
File

nxllTypes

Description

This is type nxllTypes.TnxResult.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxSessionID Type

nxllTypes.TnxSessionID Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxSessionID = type TnxBaseID;
File

nxllTypes

Description

This is type nxllTypes.TnxSessionID.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxShStr Type

nxllTypes.TnxShStr Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxShStr = ShortString;
File

nxllTypes

Description

a length-byte string

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxSingle Type

nxllTypes.TnxSingle Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxSingle = Single;
File

nxllTypes

Description

This is type nxllTypes.TnxSingle.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxStringZ Type

nxllTypes.TnxStringZ Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxStringZ = array [0..255] of AnsiChar;
File

nxllTypes

Description

For converting ShortStrings to StringZs

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxThreadPriority Type

nxllTypes.TnxThreadPriority Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxThreadPriority = -15..15;
File

nxllTypes

Description

This is type nxllTypes.TnxThreadPriority.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxTime Type

nxllTypes.TnxTime Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxTime = type Integer;
File

nxllTypes

Description

4 byte time value; Number of milliseconds since midnight

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxTransportID Type

nxllTypes.TnxTransportID Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxTransportID = type TnxBaseID;
File

nxllTypes

Description

TnxRequestID = type TnxBaseID;

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxUnicodeStrings Type

nxllTypes.TnxUnicodeStrings Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxUnicodeStrings = array of UnicodeString;
File

nxllTypes

Description

This is type nxllTypes.TnxUnicodeStrings.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxValueRelationship Type

nxllTypes.TnxValueRelationship Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxValueRelationship = -1..1;
File

nxllTypes

Description

This is type nxllTypes.TnxValueRelationship.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxWideChar Type

nxllTypes.TnxWideChar Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxWideChar = WideChar;
File

nxllTypes

Description

16-bit WideChar

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxWideCharArray Type

nxllTypes.TnxWideCharArray Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxWideCharArray = array[0..Pred(High(Integer) div SizeOf(TnxWideChar))] of TnxWideChar;
File

nxllTypes

Description

This is type nxllTypes.TnxWideCharArray.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxWideString Type

nxllTypes.TnxWideString Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxWideString = array of TnxWideChar;
File

nxllTypes

Description

This is type nxllTypes.TnxWideString.

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxWord16 Type

nxllTypes.TnxWord16 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxWord16 = Word;
File

nxllTypes

Description

16-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.TnxWord32 Type

nxllTypes.TnxWord32 Type
nxllTypes Types Send Feedback
Syntax
Delphi
TnxWord32 = Cardinal;
File

nxllTypes

Description

32-bit unsigned Integer

Group

Types

Links
nxllTypes, Types


nxllTypes.UnicodeString Type

nxllTypes.UnicodeString Type
nxllTypes Types Send Feedback
Syntax
Delphi
UnicodeString = WideString;
File

nxllTypes

Description

This is type nxllTypes.UnicodeString.

Group

Types

Links
nxllTypes, Types


Variables

Variables
nxllTypes Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllTypes Namespace

Variables
Name | Description
nxForceCleanup | This is variable nxllTypes.nxForceCleanup.
nxRegistryClassActivator | This is variable nxllTypes.nxRegistryClassActivator.
Links
nxllTypes Namespace, Variables


nxllTypes.nxForceCleanup Variable

nxllTypes.nxForceCleanup Variable
nxllTypes Variables Send Feedback
Syntax
Delphi
nxForceCleanup: procedure;
File

nxllTypes

Description

This is variable nxllTypes.nxForceCleanup.

Group

Variables

Links
nxllTypes, Variables


nxllTypes.nxRegistryClassActivator Variable

nxllTypes.nxRegistryClassActivator Variable
nxllTypes Variables Send Feedback
Syntax
Delphi
nxRegistryClassActivator: function: InxClassActivator;
File

nxllTypes

Description

This is variable nxllTypes.nxRegistryClassActivator.

Group

Variables

Links
nxllTypes, Variables


Constants

Constants
Constants nxllTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
__aspect__Depth | This is constant nxllTypes.__aspect__Depth.
__aspect__Enabled | This is constant nxllTypes.__aspect__Enabled.
__aspect__Indent | This is constant nxllTypes.__aspect__Indent.
MEM_RESET | This is constant nxllTypes.MEM_RESET.
nxEqual | This is constant nxllTypes.nxEqual.
nxGreaterThan | This is constant nxllTypes.nxGreaterThan.
nxSmallerThan | This is constant nxllTypes.nxSmallerThan.
varUInt64 | vt_ui8 21
varUString | Unicode string 258 not OLE compatible
Namespace

nxllTypes Namespace

Links
Constants, nxllTypes Namespace


nxllTypes.__aspect__Depth Constant

nxllTypes.__aspect__Depth Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
__aspect__Depth: Integer = ;
File

nxllTypes

Description

This is constant nxllTypes.__aspect__Depth.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.__aspect__Enabled Constant

nxllTypes.__aspect__Enabled Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
__aspect__Enabled: Boolean = ;
File

nxllTypes

Description

This is constant nxllTypes.__aspect__Enabled.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.__aspect__Indent Constant

nxllTypes.__aspect__Indent Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
__aspect__Indent = 1;
File

nxllTypes

Description

This is constant nxllTypes.__aspect__Indent.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.MEM_RESET Constant

nxllTypes.MEM_RESET Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
MEM_RESET = $80000;
File

nxllTypes

Description

This is constant nxllTypes.MEM_RESET.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.nxEqual Constant

nxllTypes.nxEqual Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
nxEqual = 0;
File

nxllTypes

Description

This is constant nxllTypes.nxEqual.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.nxGreaterThan Constant

nxllTypes.nxGreaterThan Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
nxGreaterThan = High(TnxValueRelationship);
File

nxllTypes

Description

This is constant nxllTypes.nxGreaterThan.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.nxSmallerThan Constant

nxllTypes.nxSmallerThan Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
nxSmallerThan = Low(TnxValueRelationship);
File

nxllTypes

Description

This is constant nxllTypes.nxSmallerThan.

Group

Constants

Links
nxllTypes, Constants


nxllTypes.varUInt64 Constant

nxllTypes.varUInt64 Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
varUInt64 = $0015;
File

nxllTypes

Description

vt_ui8 21

Group

Constants

Links
nxllTypes, Constants


nxllTypes.varUString Constant

nxllTypes.varUString Constant
nxllTypes Constants Send Feedback
Syntax
Delphi
varUString = $0102;
File

nxllTypes

Description

Unicode string 258 not OLE compatible

Group

Constants

Links
nxllTypes, Constants


nxllUserManagement Namespace

nxllUserManagement Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

the sets access control are expected to be 4 byte, not 1!

Constants
Name | Description
NERR_BadPassword | This is constant nxllUserManagement.NERR_BadPassword.
NERR_BASE | This is constant nxllUserManagement.NERR_BASE.
NERR_GroupExists | This is constant nxllUserManagement.NERR_GroupExists.
NERR_GroupNotFound | The group name could not be found.
NERR_InvalidComputer | This is constant nxllUserManagement.NERR_InvalidComputer.
NERR_NotPrimary | This is constant nxllUserManagement.NERR_NotPrimary.
NERR_PasswordTooShort | This is constant nxllUserManagement.NERR_PasswordTooShort.
NERR_SpeGroupOp | The operation is not allowed on specified special groups, which are user groups, admin groups, local groups, or guest groups.
NERR_UserExists | This is constant nxllUserManagement.NERR_UserExists.
NERR_UserNotFound | The user name could not be found.
NERR_UserNotInGroup | The user does not belong to this group.
POLICY_ALL_ACCESS | This is constant nxllUserManagement.POLICY_ALL_ACCESS.
POLICY_CREATE_ACCOUNT | This is constant nxllUserManagement.POLICY_CREATE_ACCOUNT.
POLICY_CREATE_PRIVILEGE | This is constant nxllUserManagement.POLICY_CREATE_PRIVILEGE.
POLICY_LOOKUP_NAMES | This is constant nxllUserManagement.POLICY_LOOKUP_NAMES.
STANDARD_RIGHTS_REQUIRED | low level
SUB_CONTAINERS_AND_OBJECTS_INHERIT | This is constant nxllUserManagement.SUB_CONTAINERS_AND_OBJECTS_INHERIT.
UF_ACCOUNTDISABLE | This is constant nxllUserManagement.UF_ACCOUNTDISABLE.
UF_DONT_EXPIRE_PASSWD | This is constant nxllUserManagement.UF_DONT_EXPIRE_PASSWD.
UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED | This is constant nxllUserManagement.UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED.
UF_HOMEDIR_REQUIRED | This is constant nxllUserManagement.UF_HOMEDIR_REQUIRED.
UF_LOCKOUT | This is constant nxllUserManagement.UF_LOCKOUT.
UF_NORMAL_ACCOUNT | This is constant nxllUserManagement.UF_NORMAL_ACCOUNT.
UF_PASSWD_CANT_CHANGE | This is constant nxllUserManagement.UF_PASSWD_CANT_CHANGE.
UF_PASSWD_NOTREQD | This is constant nxllUserManagement.UF_PASSWD_NOTREQD.
UF_SCRIPT | This is constant nxllUserManagement.UF_SCRIPT.
USER_PRIV_ADMIN | This is constant nxllUserManagement.USER_PRIV_ADMIN.
USER_PRIV_GUEST | This is constant nxllUserManagement.USER_PRIV_GUEST.
USER_PRIV_MASK | This is constant nxllUserManagement.USER_PRIV_MASK.
USER_PRIV_USER | This is constant nxllUserManagement.USER_PRIV_USER.
Functions
Name | Description
AddPrivilege | This is function nxllUserManagement.AddPrivilege.
AddToLocalGroup | This is function nxllUserManagement.AddToLocalGroup.
AddUserAccount | This is function nxllUserManagement.AddUserAccount.
BuildExplicitAccessWithName | This is function nxllUserManagement.BuildExplicitAccessWithName.
ClosePolicy | This is function nxllUserManagement.ClosePolicy.
DeleteUserAccount | This is function nxllUserManagement.DeleteUserAccount.
GetAccountSidString | This is function nxllUserManagement.GetAccountSidString.
GetNamedSecurityInfo | This is function nxllUserManagement.GetNamedSecurityInfo.
LsaAddAccountRights | This is function nxllUserManagement.LsaAddAccountRights.
LsaNtStatusToWinError | This is function nxllUserManagement.LsaNtStatusToWinError.
LsaOpenPolicy | This is function nxllUserManagement.LsaOpenPolicy.
LsaRemoveAccountRights | This is function nxllUserManagement.LsaRemoveAccountRights.
NetLocalGroupAddMembers | This is function nxllUserManagement.NetLocalGroupAddMembers.
NetLocalGroupDelMembers | This is function nxllUserManagement.NetLocalGroupDelMembers.
NetUserAdd | This is function nxllUserManagement.NetUserAdd.
NetUserDel | This is function nxllUserManagement.NetUserDel.
RemoveFromLocalGroup | This is function nxllUserManagement.RemoveFromLocalGroup.
RemovePrivilege | This is function nxllUserManagement.RemovePrivilege.
SetAccessRights | This is function nxllUserManagement.SetAccessRights.
SetEntriesInAcl | This is function nxllUserManagement.SetEntriesInAcl.
SetNamedSecurityInfo | This is function nxllUserManagement.SetNamedSecurityInfo.
Structs, Records, Enums
Name | Description
_LSA_UNICODE_STRING | This is record nxllUserManagement._LSA_UNICODE_STRING.
_TRUSTEE_W | This is record nxllUserManagement._TRUSTEE_W.
ACCESS_MODE | This is record nxllUserManagement.ACCESS_MODE.
EXPLICIT_ACCESS_W | This is record nxllUserManagement.EXPLICIT_ACCESS_W.
LOCALGROUP_MEMBERS_INFO_3 | This is record nxllUserManagement.LOCALGROUP_MEMBERS_INFO_3.
LSA_OBJECT_ATTRIBUTES | This is record nxllUserManagement.LSA_OBJECT_ATTRIBUTES.
MULTIPLE_TRUSTEE_OPERATION | Definition: MULTIPLE_TRUSTEE_OPERATION If the trustee is a multiple trustee, this enumerated type specifies the type. TRUSTEE_IS_IMPERSONATE The trustee is an impersonate trustee and the multiple trustee field in the trustee points to another trustee that is a trustee for the server that will be doing the impersonation.
TRUSTEE_FORM | Definition: TRUSTEE_FORM This enumerated type specifies the form the trustee identifier is in for a particular trustee. TRUSTEE_IS_SID The trustee is identified with a SID rather than with a name. TRUSTEE_IS_NAME The trustee is identified with a name.
TRUSTEE_TYPE | This is record nxllUserManagement.TRUSTEE_TYPE.
TRUSTEE_W | D2009 has a buggy definition
USER_INFO_2 | This is record nxllUserManagement.USER_INFO_2.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
LSA_HANDLE | LSA RPC Context Handle (Opaque form). Note that a Context Handle is always a pointer type unlike regular handles.
LSA_UNICODE_STRING | This is type nxllUserManagement.LSA_UNICODE_STRING.
NTSTATUS | This is type nxllUserManagement.NTSTATUS.
P_TRUSTEE_W | This is type nxllUserManagement.P_TRUSTEE_W.
PEXPLICIT_ACCESS_W | This is type nxllUserManagement.PEXPLICIT_ACCESS_W.
PLOCALGROUP_MEMBERS_INFO_3 | This is type nxllUserManagement.PLOCALGROUP_MEMBERS_INFO_3.
PLSA_HANDLE | This is type nxllUserManagement.PLSA_HANDLE.
PLSA_UNICODE_STRING | This is type nxllUserManagement.PLSA_UNICODE_STRING.
PLsaUnicodeString | This is type nxllUserManagement.PLsaUnicodeString.
PNtStatus | This is type nxllUserManagement.PNtStatus.
PPSECURITY_DESCRIPTOR | This is type nxllUserManagement.PPSECURITY_DESCRIPTOR.
PPSID | This is type nxllUserManagement.PPSID.
TBytes | This is type nxllUserManagement.TBytes.
TLsaHandle | This is type nxllUserManagement.TLsaHandle.
TLsaUnicodeString | This is type nxllUserManagement.TLsaUnicodeString.
TNtStatus | This is type nxllUserManagement.TNtStatus.
TRUSTEEW | This is type nxllUserManagement.TRUSTEEW.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Functions

Functions
Functions nxllUserManagement Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddPrivilege | This is function nxllUserManagement.AddPrivilege.
AddToLocalGroup | This is function nxllUserManagement.AddToLocalGroup.
AddUserAccount | This is function nxllUserManagement.AddUserAccount.
BuildExplicitAccessWithName | This is function nxllUserManagement.BuildExplicitAccessWithName.
ClosePolicy | This is function nxllUserManagement.ClosePolicy.
DeleteUserAccount | This is function nxllUserManagement.DeleteUserAccount.
GetAccountSidString | This is function nxllUserManagement.GetAccountSidString.
GetNamedSecurityInfo | This is function nxllUserManagement.GetNamedSecurityInfo.
LsaAddAccountRights | This is function nxllUserManagement.LsaAddAccountRights.
LsaNtStatusToWinError | This is function nxllUserManagement.LsaNtStatusToWinError.
LsaOpenPolicy | This is function nxllUserManagement.LsaOpenPolicy.
LsaRemoveAccountRights | This is function nxllUserManagement.LsaRemoveAccountRights.
NetLocalGroupAddMembers | This is function nxllUserManagement.NetLocalGroupAddMembers.
NetLocalGroupDelMembers | This is function nxllUserManagement.NetLocalGroupDelMembers.
NetUserAdd | This is function nxllUserManagement.NetUserAdd.
NetUserDel | This is function nxllUserManagement.NetUserDel.
RemoveFromLocalGroup | This is function nxllUserManagement.RemoveFromLocalGroup.
RemovePrivilege | This is function nxllUserManagement.RemovePrivilege.
SetAccessRights | This is function nxllUserManagement.SetAccessRights.
SetEntriesInAcl | This is function nxllUserManagement.SetEntriesInAcl.
SetNamedSecurityInfo | This is function nxllUserManagement.SetNamedSecurityInfo.
Namespace

nxllUserManagement Namespace

Links
Functions, nxllUserManagement Namespace, Legend


nxllUserManagement.AddPrivilege Function

nxllUserManagement.AddPrivilege Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function AddPrivilege(aUserName: UnicodeString; aPrivilege: UnicodeString): Integer; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.AddPrivilege.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.AddToLocalGroup Function

nxllUserManagement.AddToLocalGroup Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function AddToLocalGroup(UserName: UnicodeString; GroupName: UnicodeString; ServerName: UnicodeString): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.AddToLocalGroup.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.AddUserAccount Function

nxllUserManagement.AddUserAccount Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function AddUserAccount(UserName: UnicodeString; Password: UnicodeString; ServerName: UnicodeString): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.AddUserAccount.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.BuildExplicitAccessWithName Function

nxllUserManagement.BuildExplicitAccessWithName Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
procedure BuildExplicitAccessWithName(pExplicitAccess: PEXPLICIT_ACCESS_W; pTrusteeName: PWideChar; AccessPermissions: DWORD; AccessMode: ACCESS_MODE; Ineritance: DWORD); stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.BuildExplicitAccessWithName.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.ClosePolicy Function

nxllUserManagement.ClosePolicy Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
procedure ClosePolicy(PolicyHandle: LSA_HANDLE); stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.ClosePolicy.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.DeleteUserAccount Function

nxllUserManagement.DeleteUserAccount Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function DeleteUserAccount(UserName: UnicodeString; ServerName: UnicodeString): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.DeleteUserAccount.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.GetAccountSidString Function

nxllUserManagement.GetAccountSidString Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function GetAccountSidString(const AccountName: UnicodeString): UnicodeString;
File

nxllUserManagement

Description

This is function nxllUserManagement.GetAccountSidString.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.GetNamedSecurityInfo Function

nxllUserManagement.GetNamedSecurityInfo Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function GetNamedSecurityInfo(pObjectName: PWideChar; ObjectType: SE_OBJECT_TYPE; SecurityInfo: SECURITY_INFORMATION; ppsidOwner: PPSID; ppsidGroup: PPSID; ppDacl: PACL; ppSacl: PACL; var ppSecurityDescriptor: PSECURITY_DESCRIPTOR): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.GetNamedSecurityInfo.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.LsaAddAccountRights Function

nxllUserManagement.LsaAddAccountRights Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function LsaAddAccountRights(const PolicyHandle: LSA_HANDLE; const AccountSid: PSID; ptrUserRights: pointer; const CountOfRights: Integer): NTSTATUS; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.LsaAddAccountRights.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.LsaNtStatusToWinError Function

nxllUserManagement.LsaNtStatusToWinError Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function LsaNtStatusToWinError(Status: NTSTATUS): ULONG; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.LsaNtStatusToWinError.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.LsaOpenPolicy Function

nxllUserManagement.LsaOpenPolicy Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function LsaOpenPolicy(SystemName: pointer; ObjectAttributes: pointer; DesiredAccess: DWORD; ptrPolicyHandle: LSA_HANDLE): NTSTATUS; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.LsaOpenPolicy.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.LsaRemoveAccountRights Function

nxllUserManagement.LsaRemoveAccountRights Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function LsaRemoveAccountRights(const PolicyHandle: LSA_HANDLE; const AccountSid: PSID; const AllRights: BOOL; ptrUserRights: pointer; const CountOfRights: Integer): NTSTATUS; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.LsaRemoveAccountRights.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.NetLocalGroupAddMembers Function

nxllUserManagement.NetLocalGroupAddMembers Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function NetLocalGroupAddMembers(ServerName: PWideChar; LocalGroupName: PWideChar; level: DWORD; buf: pointer; membercount: DWORD): LongInt; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.NetLocalGroupAddMembers.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.NetLocalGroupDelMembers Function

nxllUserManagement.NetLocalGroupDelMembers Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function NetLocalGroupDelMembers(ServerName: PWideChar; LocalGroupName: PWideChar; level: DWORD; buf: pointer; membercount: DWORD): LongInt; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.NetLocalGroupDelMembers.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.NetUserAdd Function

nxllUserManagement.NetUserAdd Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function NetUserAdd(servername: LPCWSTR; level: DWORD; buf: PBYTE; parm_err: LPDWORD): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.NetUserAdd.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.NetUserDel Function

nxllUserManagement.NetUserDel Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function NetUserDel(ServerName: PWideChar; UserName: PWideChar): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.NetUserDel.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.RemoveFromLocalGroup Function

nxllUserManagement.RemoveFromLocalGroup Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function RemoveFromLocalGroup(UserName: UnicodeString; GroupName: UnicodeString; ServerName: UnicodeString): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.RemoveFromLocalGroup.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.RemovePrivilege Function

nxllUserManagement.RemovePrivilege Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function RemovePrivilege(aUserName: UnicodeString; aPrivilege: UnicodeString): Integer; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.RemovePrivilege.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.SetAccessRights Function

nxllUserManagement.SetAccessRights Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function SetAccessRights(FileOrFolder: UnicodeString; Trustee: UnicodeString; Rights: DWORD): DWORD;
File

nxllUserManagement

Description

This is function nxllUserManagement.SetAccessRights.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.SetEntriesInAcl Function

nxllUserManagement.SetEntriesInAcl Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function SetEntriesInAcl(cCountOfExplicitEntries: ULONG; pListOfExplicitEntries: PEXPLICIT_ACCESS_W; OldAcl: PACL; var NewAcl: PACL): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.SetEntriesInAcl.

Group

Functions

Links
nxllUserManagement, Functions


nxllUserManagement.SetNamedSecurityInfo Function

nxllUserManagement.SetNamedSecurityInfo Function
nxllUserManagement Functions Send Feedback
Syntax
Delphi
function SetNamedSecurityInfo(pObjectName: PWideChar; ObjectType: SE_OBJECT_TYPE; SecurityInfo: SECURITY_INFORMATION; ppsidOwner: PPSID; ppsidGroup: PPSID; ppDacl: PACL; ppSacl: PACL): DWORD; stdcall;
File

nxllUserManagement

Description

This is function nxllUserManagement.SetNamedSecurityInfo.

Group

Functions

Links
nxllUserManagement, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllUserManagement Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
ACCESS_MODE | This is record nxllUserManagement.ACCESS_MODE.
MULTIPLE_TRUSTEE_OPERATION | Definition: MULTIPLE_TRUSTEE_OPERATION If the trustee is a multiple trustee, this enumerated type specifies the type. TRUSTEE_IS_IMPERSONATE The trustee is an impersonate trustee and the multiple trustee field in the trustee points to another trustee that is a trustee for the server that will be doing the impersonation.
TRUSTEE_FORM | Definition: TRUSTEE_FORM This enumerated type specifies the form the trustee identifier is in for a particular trustee. TRUSTEE_IS_SID The trustee is identified with a SID rather than with a name. TRUSTEE_IS_NAME The trustee is identified with a name.
TRUSTEE_TYPE | This is record nxllUserManagement.TRUSTEE_TYPE.
Namespace

nxllUserManagement Namespace

Records
Name | Description
_LSA_UNICODE_STRING | This is record nxllUserManagement._LSA_UNICODE_STRING.
_TRUSTEE_W | This is record nxllUserManagement._TRUSTEE_W.
EXPLICIT_ACCESS_W | This is record nxllUserManagement.EXPLICIT_ACCESS_W.
LOCALGROUP_MEMBERS_INFO_3 | This is record nxllUserManagement.LOCALGROUP_MEMBERS_INFO_3.
LSA_OBJECT_ATTRIBUTES | This is record nxllUserManagement.LSA_OBJECT_ATTRIBUTES.
TRUSTEE_W | D2009 has a buggy definition
USER_INFO_2 | This is record nxllUserManagement.USER_INFO_2.
Links
Enumerations, nxllUserManagement Namespace, Legend, Records


nxllUserManagement._LSA_UNICODE_STRING Record

nxllUserManagement._LSA_UNICODE_STRING Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
_LSA_UNICODE_STRING = record
  Length: word;
  MaximumLength: word;
  Buffer: pointer;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement._LSA_UNICODE_STRING.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement._TRUSTEE_W Record

nxllUserManagement._TRUSTEE_W Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
_TRUSTEE_W = record
  pMultipleTrustee: P_TRUSTEE_W;
  MultipleTrusteeOperation: MULTIPLE_TRUSTEE_OPERATION;
  TrusteeForm: TRUSTEE_FORM;
  TrusteeType: TRUSTEE_TYPE;
  ptstrName: PWideChar;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement._TRUSTEE_W.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.ACCESS_MODE Enumeration

nxllUserManagement.ACCESS_MODE Enumeration
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
ACCESS_MODE = ( NOT_USED_ACCESS, GRANT_ACCESS, SET_ACCESS, DENY_ACCESS, REVOKE_ACCESS, SET_AUDIT_SUCCESS, SET_AUDIT_FAILURE );
File

nxllUserManagement

Description

This is record nxllUserManagement.ACCESS_MODE.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.EXPLICIT_ACCESS_W Record

nxllUserManagement.EXPLICIT_ACCESS_W Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
EXPLICIT_ACCESS_W = packed record
  grfAccessPermissions: DWORD;
  grfAccessMode: ACCESS_MODE;
  grfInheritance: DWORD;
  Trustee: TRUSTEE_W;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement.EXPLICIT_ACCESS_W.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.LOCALGROUP_MEMBERS_INFO_3 Record

nxllUserManagement.LOCALGROUP_MEMBERS_INFO_3 Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
LOCALGROUP_MEMBERS_INFO_3 = packed record
  lgrmi3_domainandname: LPWSTR;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement.LOCALGROUP_MEMBERS_INFO_3.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.LSA_OBJECT_ATTRIBUTES Record

nxllUserManagement.LSA_OBJECT_ATTRIBUTES Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
LSA_OBJECT_ATTRIBUTES = record
  Length: DWord;
  RootDirectory: THandle;
  ObjectName: PLSA_UNICODE_STRING;
  Attributes: DWord;
  SecurityDescriptor: pointer;
  SecurityQualityOfService: pointer;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement.LSA_OBJECT_ATTRIBUTES.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.MULTIPLE_TRUSTEE_OPERATION Enumeration

nxllUserManagement.MULTIPLE_TRUSTEE_OPERATION Enumeration
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
MULTIPLE_TRUSTEE_OPERATION = ( NO_MULTIPLE_TRUSTEE, TRUSTEE_IS_IMPERSONATE );
File

nxllUserManagement

Description

Definition: MULTIPLE_TRUSTEE_OPERATION If the trustee is a multiple trustee, this enumerated type specifies the type. TRUSTEE_IS_IMPERSONATE The trustee is an impersonate trustee and the multiple trustee field in the trustee points to another trustee that is a trustee for the server that will be doing the impersonation.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.TRUSTEE_FORM Enumeration

nxllUserManagement.TRUSTEE_FORM Enumeration
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
TRUSTEE_FORM = ( TRUSTEE_IS_SID, TRUSTEE_IS_NAME, TRUSTEE_BAD_FORM );
File

nxllUserManagement

Description

Definition: TRUSTEE_FORM This enumerated type specifies the form the trustee identifier is in for a particular trustee. TRUSTEE_IS_SID The trustee is identified with a SID rather than with a name. TRUSTEE_IS_NAME The trustee is identified with a name.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.TRUSTEE_TYPE Enumeration

nxllUserManagement.TRUSTEE_TYPE Enumeration
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
TRUSTEE_TYPE = ( TRUSTEE_IS_UNKNOWN, TRUSTEE_IS_USER, TRUSTEE_IS_GROUP, TRUSTEE_IS_DOMAIN, TRUSTEE_IS_ALIAS, TRUSTEE_IS_WELL_KNOWN_GROUP, TRUSTEE_IS_DELETED, TRUSTEE_IS_INVALID );
File

nxllUserManagement

Description

This is record nxllUserManagement.TRUSTEE_TYPE.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.TRUSTEE_W Record

nxllUserManagement.TRUSTEE_W Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
TRUSTEE_W = packed record
  pMultipleTrustee: P_TRUSTEE_W;
  MultipleTrusteeOperation: MULTIPLE_TRUSTEE_OPERATION;
  TrusteeForm: TRUSTEE_FORM;
  TrusteeType: TRUSTEE_TYPE;
  ptstrName: PWideChar;
end;
File

nxllUserManagement

Description

D2009 has a buggy definition

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


nxllUserManagement.USER_INFO_2 Record

nxllUserManagement.USER_INFO_2 Record
nxllUserManagement Structs, Records, Enums Send Feedback
Syntax
Delphi
USER_INFO_2 = record
  usri2_name: LPWSTR;
  usri2_password: LPWSTR;
  usri2_password_age: DWORD;
  usri2_priv: DWORD;
  usri2_home_dir: LPWSTR;
  usri2_comment: LPWSTR;
  usri2_flags: DWORD;
  usri2_script_path: LPWSTR;
  usri2_auth_flags: DWORD;
  usri2_full_name: LPWSTR;
  usri2_usr_comment: LPWSTR;
  usri2_parms: LPWSTR;
  usri2_workstations: LPWSTR;
  usri2_last_logon: DWORD;
  usri2_last_logoff: DWORD;
  usri2_acct_expires: DWORD;
  usri2_max_storage: DWORD;
  usri2_units_per_week: DWORD;
  usri2_logon_hours: PBYTE;
  usri2_bad_pw_count: DWORD;
  usri2_num_logons: DWORD;
  usri2_logon_server: LPWSTR;
  usri2_country_code: DWORD;
  usri2_code_page: DWORD;
end;
File

nxllUserManagement

Description

This is record nxllUserManagement.USER_INFO_2.

Group

Structs, Records, Enums

Links
nxllUserManagement, Structs, Records, Enums


Types

Types
nxllUserManagement Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllUserManagement Namespace

Types
Name | Description
LSA_HANDLE | LSA RPC Context Handle (Opaque form). Note that a Context Handle is always a pointer type unlike regular handles.
LSA_UNICODE_STRING | This is type nxllUserManagement.LSA_UNICODE_STRING.
NTSTATUS | This is type nxllUserManagement.NTSTATUS.
P_TRUSTEE_W | This is type nxllUserManagement.P_TRUSTEE_W.
PEXPLICIT_ACCESS_W | This is type nxllUserManagement.PEXPLICIT_ACCESS_W.
PLOCALGROUP_MEMBERS_INFO_3 | This is type nxllUserManagement.PLOCALGROUP_MEMBERS_INFO_3.
PLSA_HANDLE | This is type nxllUserManagement.PLSA_HANDLE.
PLSA_UNICODE_STRING | This is type nxllUserManagement.PLSA_UNICODE_STRING.
PLsaUnicodeString | This is type nxllUserManagement.PLsaUnicodeString.
PNtStatus | This is type nxllUserManagement.PNtStatus.
PPSECURITY_DESCRIPTOR | This is type nxllUserManagement.PPSECURITY_DESCRIPTOR.
PPSID | This is type nxllUserManagement.PPSID.
TBytes | This is type nxllUserManagement.TBytes.
TLsaHandle | This is type nxllUserManagement.TLsaHandle.
TLsaUnicodeString | This is type nxllUserManagement.TLsaUnicodeString.
TNtStatus | This is type nxllUserManagement.TNtStatus.
TRUSTEEW | This is type nxllUserManagement.TRUSTEEW.
Links
nxllUserManagement Namespace, Types


nxllUserManagement.LSA_HANDLE Type

nxllUserManagement.LSA_HANDLE Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
LSA_HANDLE = Pointer;
File

nxllUserManagement

Description

LSA RPC Context Handle (Opaque form). Note that a Context Handle is always a pointer type unlike regular handles.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.LSA_UNICODE_STRING Type

nxllUserManagement.LSA_UNICODE_STRING Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
LSA_UNICODE_STRING = _LSA_UNICODE_STRING;
File

nxllUserManagement

Description

This is type nxllUserManagement.LSA_UNICODE_STRING.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.NTSTATUS Type

nxllUserManagement.NTSTATUS Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
NTSTATUS = LongInt;
File

nxllUserManagement

Description

This is type nxllUserManagement.NTSTATUS.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.P_TRUSTEE_W Type

nxllUserManagement.P_TRUSTEE_W Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
P_TRUSTEE_W = ^_TRUSTEE_W;
File

nxllUserManagement

Description

This is type nxllUserManagement.P_TRUSTEE_W.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PEXPLICIT_ACCESS_W Type

nxllUserManagement.PEXPLICIT_ACCESS_W Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PEXPLICIT_ACCESS_W = ^EXPLICIT_ACCESS_W;
File

nxllUserManagement

Description

This is type nxllUserManagement.PEXPLICIT_ACCESS_W.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PLOCALGROUP_MEMBERS_INFO_3 Type

nxllUserManagement.PLOCALGROUP_MEMBERS_INFO_3 Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PLOCALGROUP_MEMBERS_INFO_3 = ^LOCALGROUP_MEMBERS_INFO_3;
File

nxllUserManagement

Description

This is type nxllUserManagement.PLOCALGROUP_MEMBERS_INFO_3.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PLSA_HANDLE Type

nxllUserManagement.PLSA_HANDLE Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PLSA_HANDLE = ^LSA_HANDLE;
File

nxllUserManagement

Description

This is type nxllUserManagement.PLSA_HANDLE.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PLSA_UNICODE_STRING Type

nxllUserManagement.PLSA_UNICODE_STRING Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PLSA_UNICODE_STRING = ^LSA_UNICODE_STRING;
File

nxllUserManagement

Description

This is type nxllUserManagement.PLSA_UNICODE_STRING.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PLsaUnicodeString Type

nxllUserManagement.PLsaUnicodeString Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PLsaUnicodeString = PLSA_UNICODE_STRING;
File

nxllUserManagement

Description

This is type nxllUserManagement.PLsaUnicodeString.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PNtStatus Type

nxllUserManagement.PNtStatus Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PNtStatus = ^TNtStatus;
File

nxllUserManagement

Description

This is type nxllUserManagement.PNtStatus.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PPSECURITY_DESCRIPTOR Type

nxllUserManagement.PPSECURITY_DESCRIPTOR Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PPSECURITY_DESCRIPTOR = ^PSECURITY_DESCRIPTOR;
File

nxllUserManagement

Description

This is type nxllUserManagement.PPSECURITY_DESCRIPTOR.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.PPSID Type

nxllUserManagement.PPSID Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
PPSID = ^PSID;
File

nxllUserManagement

Description

This is type nxllUserManagement.PPSID.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.TBytes Type

nxllUserManagement.TBytes Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
TBytes = array of Byte;
File

nxllUserManagement

Description

This is type nxllUserManagement.TBytes.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.TLsaHandle Type

nxllUserManagement.TLsaHandle Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
TLsaHandle = LSA_HANDLE;
File

nxllUserManagement

Description

This is type nxllUserManagement.TLsaHandle.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.TLsaUnicodeString Type

nxllUserManagement.TLsaUnicodeString Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
TLsaUnicodeString = LSA_UNICODE_STRING;
File

nxllUserManagement

Description

This is type nxllUserManagement.TLsaUnicodeString.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.TNtStatus Type

nxllUserManagement.TNtStatus Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
TNtStatus = NTSTATUS;
File

nxllUserManagement

Description

This is type nxllUserManagement.TNtStatus.

Group

Types

Links
nxllUserManagement, Types


nxllUserManagement.TRUSTEEW Type

nxllUserManagement.TRUSTEEW Type
nxllUserManagement Types Send Feedback
Syntax
Delphi
TRUSTEEW = _TRUSTEE_W;
File

nxllUserManagement

Description

This is type nxllUserManagement.TRUSTEEW.

Group

Types

Links
nxllUserManagement, Types


Constants

Constants
Constants nxllUserManagement Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
NERR_BadPassword | This is constant nxllUserManagement.NERR_BadPassword.
NERR_BASE | This is constant nxllUserManagement.NERR_BASE.
NERR_GroupExists | This is constant nxllUserManagement.NERR_GroupExists.
NERR_GroupNotFound | The group name could not be found.
NERR_InvalidComputer | This is constant nxllUserManagement.NERR_InvalidComputer.
NERR_NotPrimary | This is constant nxllUserManagement.NERR_NotPrimary.
NERR_PasswordTooShort | This is constant nxllUserManagement.NERR_PasswordTooShort.
NERR_SpeGroupOp | The operation is not allowed on specified special groups, which are user groups, admin groups, local groups, or guest groups.
NERR_UserExists | This is constant nxllUserManagement.NERR_UserExists.
NERR_UserNotFound | The user name could not be found.
NERR_UserNotInGroup | The user does not belong to this group.
POLICY_ALL_ACCESS | This is constant nxllUserManagement.POLICY_ALL_ACCESS.
POLICY_CREATE_ACCOUNT | This is constant nxllUserManagement.POLICY_CREATE_ACCOUNT.
POLICY_CREATE_PRIVILEGE | This is constant nxllUserManagement.POLICY_CREATE_PRIVILEGE.
POLICY_LOOKUP_NAMES | This is constant nxllUserManagement.POLICY_LOOKUP_NAMES.
STANDARD_RIGHTS_REQUIRED | low level
SUB_CONTAINERS_AND_OBJECTS_INHERIT | This is constant nxllUserManagement.SUB_CONTAINERS_AND_OBJECTS_INHERIT.
UF_ACCOUNTDISABLE | This is constant nxllUserManagement.UF_ACCOUNTDISABLE.
UF_DONT_EXPIRE_PASSWD | This is constant nxllUserManagement.UF_DONT_EXPIRE_PASSWD.
UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED | This is constant nxllUserManagement.UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED.
UF_HOMEDIR_REQUIRED | This is constant nxllUserManagement.UF_HOMEDIR_REQUIRED.
UF_LOCKOUT | This is constant nxllUserManagement.UF_LOCKOUT.
UF_NORMAL_ACCOUNT | This is constant nxllUserManagement.UF_NORMAL_ACCOUNT.
UF_PASSWD_CANT_CHANGE | This is constant nxllUserManagement.UF_PASSWD_CANT_CHANGE.
UF_PASSWD_NOTREQD | This is constant nxllUserManagement.UF_PASSWD_NOTREQD.
UF_SCRIPT | This is constant nxllUserManagement.UF_SCRIPT.
USER_PRIV_ADMIN | This is constant nxllUserManagement.USER_PRIV_ADMIN.
USER_PRIV_GUEST | This is constant nxllUserManagement.USER_PRIV_GUEST.
USER_PRIV_MASK | This is constant nxllUserManagement.USER_PRIV_MASK.
USER_PRIV_USER | This is constant nxllUserManagement.USER_PRIV_USER.
Namespace

nxllUserManagement Namespace

Links
Constants, nxllUserManagement Namespace


nxllUserManagement.NERR_BadPassword Constant

nxllUserManagement.NERR_BadPassword Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_BadPassword = NERR_BASE + 103;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_BadPassword.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_BASE Constant

nxllUserManagement.NERR_BASE Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_BASE = 2100;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_BASE.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_GroupExists Constant

nxllUserManagement.NERR_GroupExists Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_GroupExists = NERR_BASE + 123;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_GroupExists.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_GroupNotFound Constant

nxllUserManagement.NERR_GroupNotFound Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_GroupNotFound = NERR_BASE + 120;
File

nxllUserManagement

Description

The group name could not be found.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_InvalidComputer Constant

nxllUserManagement.NERR_InvalidComputer Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_InvalidComputer = NERR_BASE + 251;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_InvalidComputer.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_NotPrimary Constant

nxllUserManagement.NERR_NotPrimary Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_NotPrimary = NERR_BASE + 126;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_NotPrimary.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_PasswordTooShort Constant

nxllUserManagement.NERR_PasswordTooShort Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_PasswordTooShort = NERR_BASE + 145;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_PasswordTooShort.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_SpeGroupOp Constant

nxllUserManagement.NERR_SpeGroupOp Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_SpeGroupOp = NERR_BASE + 134;
File

nxllUserManagement

Description

The operation is not allowed on specified special groups, which are user groups, admin groups, local groups, or guest groups.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_UserExists Constant

nxllUserManagement.NERR_UserExists Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_UserExists = NERR_BASE + 124;
File

nxllUserManagement

Description

This is constant nxllUserManagement.NERR_UserExists.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_UserNotFound Constant

nxllUserManagement.NERR_UserNotFound Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_UserNotFound = NERR_BASE + 121;
File

nxllUserManagement

Description

The user name could not be found.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.NERR_UserNotInGroup Constant

nxllUserManagement.NERR_UserNotInGroup Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
NERR_UserNotInGroup = NERR_BASE + 137;
File

nxllUserManagement

Description

The user does not belong to this group.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.POLICY_ALL_ACCESS Constant

nxllUserManagement.POLICY_ALL_ACCESS Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
POLICY_ALL_ACCESS = STANDARD_RIGHTS_REQUIRED OR POLICY_LOOKUP_NAMES OR POLICY_CREATE_PRIVILEGE OR POLICY_CREATE_ACCOUNT;
File

nxllUserManagement

Description

This is constant nxllUserManagement.POLICY_ALL_ACCESS.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.POLICY_CREATE_ACCOUNT Constant

nxllUserManagement.POLICY_CREATE_ACCOUNT Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
POLICY_CREATE_ACCOUNT = $10;
File

nxllUserManagement

Description

This is constant nxllUserManagement.POLICY_CREATE_ACCOUNT.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.POLICY_CREATE_PRIVILEGE Constant

nxllUserManagement.POLICY_CREATE_PRIVILEGE Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
POLICY_CREATE_PRIVILEGE = $40;
File

nxllUserManagement

Description

This is constant nxllUserManagement.POLICY_CREATE_PRIVILEGE.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.POLICY_LOOKUP_NAMES Constant

nxllUserManagement.POLICY_LOOKUP_NAMES Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
POLICY_LOOKUP_NAMES = $800;
File

nxllUserManagement

Description

This is constant nxllUserManagement.POLICY_LOOKUP_NAMES.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.STANDARD_RIGHTS_REQUIRED Constant

nxllUserManagement.STANDARD_RIGHTS_REQUIRED Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
STANDARD_RIGHTS_REQUIRED = $F0000;
File

nxllUserManagement

Description

low level

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.SUB_CONTAINERS_AND_OBJECTS_INHERIT Constant

nxllUserManagement.SUB_CONTAINERS_AND_OBJECTS_INHERIT Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
SUB_CONTAINERS_AND_OBJECTS_INHERIT = $3;
File

nxllUserManagement

Description

This is constant nxllUserManagement.SUB_CONTAINERS_AND_OBJECTS_INHERIT.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_ACCOUNTDISABLE Constant

nxllUserManagement.UF_ACCOUNTDISABLE Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_ACCOUNTDISABLE = $0002;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_ACCOUNTDISABLE.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_DONT_EXPIRE_PASSWD Constant

nxllUserManagement.UF_DONT_EXPIRE_PASSWD Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_DONT_EXPIRE_PASSWD = $10000;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_DONT_EXPIRE_PASSWD.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED Constant

nxllUserManagement.UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED = $0080;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_ENCRYPTED_TEXT_PASSWORD_ALLOWED.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_HOMEDIR_REQUIRED Constant

nxllUserManagement.UF_HOMEDIR_REQUIRED Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_HOMEDIR_REQUIRED = $0008;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_HOMEDIR_REQUIRED.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_LOCKOUT Constant

nxllUserManagement.UF_LOCKOUT Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_LOCKOUT = $0010;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_LOCKOUT.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_NORMAL_ACCOUNT Constant

nxllUserManagement.UF_NORMAL_ACCOUNT Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_NORMAL_ACCOUNT = 512;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_NORMAL_ACCOUNT.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_PASSWD_CANT_CHANGE Constant

nxllUserManagement.UF_PASSWD_CANT_CHANGE Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_PASSWD_CANT_CHANGE = $0040;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_PASSWD_CANT_CHANGE.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_PASSWD_NOTREQD Constant

nxllUserManagement.UF_PASSWD_NOTREQD Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_PASSWD_NOTREQD = $0020;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_PASSWD_NOTREQD.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.UF_SCRIPT Constant

nxllUserManagement.UF_SCRIPT Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
UF_SCRIPT = $0001;
File

nxllUserManagement

Description

This is constant nxllUserManagement.UF_SCRIPT.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.USER_PRIV_ADMIN Constant

nxllUserManagement.USER_PRIV_ADMIN Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
USER_PRIV_ADMIN = 2;
File

nxllUserManagement

Description

This is constant nxllUserManagement.USER_PRIV_ADMIN.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.USER_PRIV_GUEST Constant

nxllUserManagement.USER_PRIV_GUEST Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
USER_PRIV_GUEST = 0;
File

nxllUserManagement

Description

This is constant nxllUserManagement.USER_PRIV_GUEST.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.USER_PRIV_MASK Constant

nxllUserManagement.USER_PRIV_MASK Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
USER_PRIV_MASK = 3;
File

nxllUserManagement

Description

This is constant nxllUserManagement.USER_PRIV_MASK.

Group

Constants

Links
nxllUserManagement, Constants


nxllUserManagement.USER_PRIV_USER Constant

nxllUserManagement.USER_PRIV_USER Constant
nxllUserManagement Constants Send Feedback
Syntax
Delphi
USER_PRIV_USER = 1;
File

nxllUserManagement

Description

This is constant nxllUserManagement.USER_PRIV_USER.

Group

Constants

Links
nxllUserManagement, Constants


nxllUtils Namespace

nxllUtils Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllUtils.

Classes
Name | Description
_FormatSetting | This is class nxllUtils._FormatSetting.
Constants
Name | Description
LOCALE_INVARIANT | This is constant nxllUtils.LOCALE_INVARIANT.
nxFullAccessSD | D:(A;;GA;;;WD)' DACL:(SDDL_ACCESS_ALLOWED;;SDDL_FILE_ALL;;;SDDL_EVERYONE)
nxLocaleNameMappings | This is constant nxllUtils.nxLocaleNameMappings.
rsInvalidHexChar | This is constant nxllUtils.rsInvalidHexChar.
rsOSError | This is constant nxllUtils.rsOSError.
rsOSErrorSourceUnknown | This is constant nxllUtils.rsOSErrorSourceUnknown.
rsUnkOSError | This is constant nxllUtils.rsUnkOSError.
SDDL_REVISION | This is constant nxllUtils.SDDL_REVISION.
SDDL_REVISION_1 | This is constant nxllUtils.SDDL_REVISION_1.
Functions
Name
Description
EmulateGlobalMemoryStatusEx
EmulateGlobalMemoryStatusEx
GetNLSVersionCompareString
This is function nxllUtils.GetNLSVersionCompareString.
HexStringToByteArray
ByteArray functions
ByteArray functions
nxAddLineBreakForMultiLine
This is function nxllUtils.nxAddLineBreakForMultiLine.
nxAddToArray
This is function nxllUtils.nxAddToArray.
nxAnsiStrIComp
String functions
String functions
nxAnsiStrLIComp
nxAnsiStrPos
nxAnsiStrToIntDef
nxAppHomeDirectory
on OS before Windos Vista, returns the exe directory. on Vista, returns directory under All usersApplication Data
nxBitsOr
procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register;
procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register; asm push ebx push ebp
add ecx, 7 and ecx, $FFFFFFF8 shr ecx, 3
mov ebp, ecx shr ecx, 2
@@LoopDWord: jcxz @@DoneDWord dec ecx mov ebx, [edx + ecx * 4] and [eax + ecx * 4], ebx jmp @@LoopDWord
@@DoneDWord: mov ecx, ebp and ecx, $03 jcxz @@DoneAll
shr ebp, 2 lea eax, [eax + ebp * 4] lea edx, [edx + ebp * 4]
@@LoopByte: dec ecx mov bl, [edx + ecx] and [eax + ecx], bl... more
nxCalcELFHash
Hash functions
nxCalcShStrELFHash
nxCalcStrELFHash
nxCalcStrELFHash
nxCharacterSetNameFromCodepage
This is function nxllUtils.nxCharacterSetNameFromCodepage.
nxCharIsInSet
nxCharToWideChar
Wide-String functions
Wide-String functions
nxCheckValidIdent
nxClassFromPtr
nxClearAllBits
BitSet functions
BitSet functions
nxClearBit
nxCloseEventAndSetAndNull
nxCloseHandleAndInvalidate
nxCloseHandleAndNull
nxCmpB8
comparison functions
comparison functions
nxCmpBytes
nxCmpDouble
nxCmpDynBytes
nxCmpExtended
nxCmpI16
nxCmpI32
nxCmpI64
nxCmpI64Ptr
nxCmpI8
nxCmpObj
nxCmpPtr
nxCmpShStr
nxCmpShStrUC
nxCmpSingle
nxCmpStr
nxCmpStrUC
nxCmpW16
nxCmpW32
nxCodepageFromCharacterSet
This is function nxllUtils.nxCodepageFromCharacterSet.
nxCodePageList
This is function nxllUtils.nxCodePageList.
nxCollationList
This is function nxllUtils.nxCollationList.
nxCollationNameFromLocale
This is function nxllUtils.nxCollationNameFromLocale.
nxCommaizeChL
nxDateTimeToAnsiStr
nxDateTimeToWideStr
nxDateToAnsiStr
nxDateToWideStr
nxDelphiStringsToUnicodeStrings
This is function nxllUtils.nxDelphiStringsToUnicodeStrings.
nxDisconnectObject
This is function nxllUtils.nxDisconnectObject.
nxExpandAnsiToWide
nxFindCmdLineParam
nxFindCmdLineParam
nxFindCmdLineSwitch
command line functions
nxFirstClearBit
function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register;
function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register; asm push ebx
xor ecx, ecx @@Loop: bsf ebx, [eax] jz @@AllZero add ecx, ebx cmp edx,ecx jnle @@FoundIt jmp @@NotFound @@AllZero: add ecx,$20 add eax,$04 cmp edx,ecx jnle @@Loop
@@NotFound: mov ecx, -1 @@FoundIt: mov eax, ecx
pop ebx end;
nxFloatToAnsiStr
nxFloatToWideStr
nxFormatSettingFromLocaleID
This is function nxllUtils.nxFormatSettingFromLocaleID.
nxGetCSIDLShellFolder
nxGetThreadCodePage
nxGUIDToAnsiString
nxGUIDToWideString
nxIntToAnsiStr
nxIntToAnsiStr
other functions
nxIntToWideStr
nxIntToWideStr
nxIsBitSet
nxIsClassInstance
nxIsClassInstanceOfType
nxIsSystemTable
nxIsValidCodepage
This is function nxllUtils.nxIsValidCodepage.
nxIsValidLocale
nxLocaleFromCollation
This is function nxllUtils.nxLocaleFromCollation.
nxMakeTimeStamp
date/time functions
date/time functions
nxMakeValidIdent
nxMakeValidIdent
nxMaxI32
nxMaxI64
nxMaxW16
nxMaxW32
nxMinI32
nxMinI64
nxMinW16
nxMinW32
nxMinWC
minimum/maximum functions
minimum/maximum functions
nxNewArray
This is function nxllUtils.nxNewArray.
nxNullStrLToWideStr
nxOSCheck
nxOSCheck
nxOSCheck
nxOSIsWindowsVistaOrBetter
nxPathEncode
This is function nxllUtils.nxPathEncode.
nxPtrIsClassOfType
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRemoveFromArray
This is function nxllUtils.nxRemoveFromArray.
nxSameDynBytes
nxSameDynBytes
nxSameGuid
nxSameGuid
nxSetAllBits
nxSetBit
nxSetPrivilege
nxSetPrivilege
nxShStrLToWideStr
nxStartsWith
nxStrCompW
This is function nxllUtils.nxStrCompW.
nxStrICompW
This is function nxllUtils.nxStrICompW.
nxStringsToArray
This is function nxllUtils.nxStringsToArray.
nxStringToWideChar
nxStrLCompW
This is function nxllUtils.nxStrLCompW.
nxStrLICompW
This is function nxllUtils.nxStrLICompW.
nxStrSplit
nxSupportsMulti
This is function nxllUtils.nxSupportsMulti.
nxSwapByteOrder
nxTimeToAnsiStr
nxTimeToWideStr
nxUnicodeStringsToDelphiStrings
This is function nxllUtils.nxUnicodeStringsToDelphiStrings.
nxUnmapViewOfFileAndNil
nxVarArrayLength
This is function nxllUtils.nxVarArrayLength.
nxVarRecAsAnsiString
This is function nxllUtils.nxVarRecAsAnsiString.
nxVarRecAsString
This is function nxllUtils.nxVarRecAsString.
nxVarRecAsUnicodeString
This is function nxllUtils.nxVarRecAsUnicodeString.
nxVerifyExtension
file handlings functions
nxVerifyFileName
nxWideCharToChar
nxWideStrLower
nxWideStrLToNullStr
nxWideStrLToShStr
nxWideStrLToWideStr
nxWideStrPos
nxWideStrToIntDef
ServiceStillBusy
This is function nxllUtils.ServiceStillBusy.
Succeeded
This is function nxllUtils.Succeeded.
UTF8EncodeToShortString
This is function nxllUtils.UTF8EncodeToShortString.
UTF8EncodeToShortString
This is function nxllUtils.UTF8EncodeToShortString.
UTF8ToUnicodeString
This is function nxllUtils.UTF8ToUnicodeString.
UTF8ToUnicodeString
This is function nxllUtils.UTF8ToUnicodeString.
Structs, Records, Enums
Name | Description
TCpInfoEx | This is record nxllUtils.TCpInfoEx.
TMemoryStatusEx | This is record nxllUtils.TMemoryStatusEx.
TNLSVersionInfo | This is record nxllUtils.TNLSVersionInfo.
TNLSVersionInfoEx | This is record nxllUtils.TNLSVersionInfoEx.
TnxLocaleNameMapping | This is record nxllUtils.TnxLocaleNameMapping.
TnxSupportsMultiResult | This is record nxllUtils.TnxSupportsMultiResult.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PFormatSettings | This is type nxllUtils.PFormatSettings.
PNLSVersionInfo | This is type nxllUtils.PNLSVersionInfo.
PNLSVersionInfoEx | This is type nxllUtils.PNLSVersionInfoEx.
TConvertSecurityDescriptorToStringSecurityDescriptor | This is type nxllUtils.TConvertSecurityDescriptorToStringSecurityDescriptor.
TConvertStringSecurityDescriptorToSecurityDescriptor | This is type nxllUtils.TConvertStringSecurityDescriptorToSecurityDescriptor.
TGetCPInfoEx | This is type nxllUtils.TGetCPInfoEx.
TGetNLSVersion | This is type nxllUtils.TGetNLSVersion.
TGlobalMemoryStatusEx | This is type nxllUtils.TGlobalMemoryStatusEx.
Variables
Name | Description
_CodePageList | This is variable nxllUtils._CodePageList.
_CodePageListPadlock | This is variable nxllUtils._CodePageListPadlock.
_CodePageListTemp | This is variable nxllUtils._CodePageListTemp.
_CollationList | This is variable nxllUtils._CollationList.
_CollationListPadlock | This is variable nxllUtils._CollationListPadlock.
_CollationListTemp | This is variable nxllUtils._CollationListTemp.
_ConvertSecurityDescriptorToStringSecurityDescriptor | This is variable nxllUtils._ConvertSecurityDescriptorToStringSecurityDescriptor.
_ConvertStringSecurityDescriptorToSecurityDescriptor | This is variable nxllUtils._ConvertStringSecurityDescriptorToSecurityDescriptor.
_FormatSettingList | This is variable nxllUtils._FormatSettingList.
_FormatSettingListPadlock | This is variable nxllUtils._FormatSettingListPadlock.
_GetNLSVersion | This is variable nxllUtils._GetNLSVersion.
_GlobalMemoryStatusEx | This is variable nxllUtils._GlobalMemoryStatusEx.
_nxDisconnectObject | This is variable nxllUtils._nxDisconnectObject.
_nxFillChar | This is variable nxllUtils._nxFillChar.
_ServiceStillBusy | This is variable nxllUtils._ServiceStillBusy.
CharA | This is variable nxllUtils.CharA.
CharB | This is variable nxllUtils.CharB.
GetCPInfoEx | This is variable nxllUtils.GetCPInfoEx.
i | This is variable nxllUtils.i.
LenA | This is variable nxllUtils.LenA.
LenB | This is variable nxllUtils.LenB.
LStr1 | This is variable nxllUtils.LStr1.
LStr2 | This is variable nxllUtils.LStr2.
MatchStart | This is variable nxllUtils.MatchStart.
nxDefaultUserCodePage | This is variable nxllUtils.nxDefaultUserCodePage.
nxInvariantFormatSettings | This is variable nxllUtils.nxInvariantFormatSettings.
nxRaiseLastOSErrorSimple | This is variable nxllUtils.nxRaiseLastOSErrorSimple.
q | This is variable nxllUtils.q.
sGlobalNamePrefix | This is variable nxllUtils.sGlobalNamePrefix.
sLocalNamePrefix | This is variable nxllUtils.sLocalNamePrefix.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxllUtils Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
_FormatSetting | This is class nxllUtils._FormatSetting.
Namespace

nxllUtils Namespace

Links
Classes, nxllUtils Namespace, Legend


_FormatSetting Class

_FormatSetting Class
_FormatSetting Fields _FormatSetting Members nxllUtils Classes Send Feedback
Class Hierarchy
nxllUtils__FormatSetting
Syntax
Delphi
_FormatSetting = class;
File

nxllUtils

Description

This is class nxllUtils._FormatSetting.

Group

Classes

Links
_FormatSetting Fields, _FormatSetting Members, nxllUtils, Classes


_FormatSetting Members

_FormatSetting Members
_FormatSetting Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by _FormatSetting.

Class

_FormatSetting Class

Public Fields
Name | Description
FormatSetting | This is FormatSetting, a member of class _FormatSetting.
Public Methods
Name | Description
Create | FormatSetting
Links
_FormatSetting Class, Legend, Public Fields, Public Methods


_FormatSetting.Create Constructor

_FormatSetting.Create Constructor
_FormatSetting Class _FormatSetting Members nxllUtils Namespace _FormatSetting Class Send Feedback
Syntax
Delphi
constructor Create(aLocaleID: DWord);
Description

FormatSetting

Class

_FormatSetting Class

Links
_FormatSetting Class, _FormatSetting Members, nxllUtils Namespace, _FormatSetting Class


_FormatSetting Fields

_FormatSetting Fields
_FormatSetting Class Legend Public Fields Send Feedback

The fields of the _FormatSetting class are listed here.

Class

_FormatSetting Class

Public Fields
Name | Description
FormatSetting | This is FormatSetting, a member of class _FormatSetting.
Links
_FormatSetting Class, Legend, Public Fields


_FormatSetting.FormatSetting Field

_FormatSetting.FormatSetting Field
_FormatSetting Class _FormatSetting Members nxllUtils Namespace _FormatSetting Fields Send Feedback
Syntax
Delphi
FormatSetting: TFormatSettings;
Description

This is FormatSetting, a member of class _FormatSetting.

Group

_FormatSetting Fields

Links
_FormatSetting Class, _FormatSetting Members, nxllUtils Namespace, _FormatSetting Fields


Functions

Functions
Functions nxllUtils Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name
Description
EmulateGlobalMemoryStatusEx
EmulateGlobalMemoryStatusEx
GetNLSVersionCompareString
This is function nxllUtils.GetNLSVersionCompareString.
HexStringToByteArray
ByteArray functions
ByteArray functions
nxAddLineBreakForMultiLine
This is function nxllUtils.nxAddLineBreakForMultiLine.
nxAddToArray
This is function nxllUtils.nxAddToArray.
nxAnsiStrIComp
String functions
String functions
nxAnsiStrLIComp
nxAnsiStrPos
nxAnsiStrToIntDef
nxAppHomeDirectory
on OS before Windos Vista, returns the exe directory. on Vista, returns directory under All usersApplication Data
nxBitsOr
procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register;
procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register; asm push ebx push ebp
add ecx, 7 and ecx, $FFFFFFF8 shr ecx, 3
mov ebp, ecx shr ecx, 2
@@LoopDWord: jcxz @@DoneDWord dec ecx mov ebx, [edx + ecx * 4] and [eax + ecx * 4], ebx jmp @@LoopDWord
@@DoneDWord: mov ecx, ebp and ecx, $03 jcxz @@DoneAll
shr ebp, 2 lea eax, [eax + ebp * 4] lea edx, [edx + ebp * 4]
@@LoopByte: dec ecx mov bl, [edx + ecx] and [eax + ecx], bl... more
nxCalcELFHash
Hash functions
nxCalcShStrELFHash
nxCalcStrELFHash
nxCalcStrELFHash
nxCharacterSetNameFromCodepage
This is function nxllUtils.nxCharacterSetNameFromCodepage.
nxCharIsInSet
nxCharToWideChar
Wide-String functions
Wide-String functions
nxCheckValidIdent
nxClassFromPtr
nxClearAllBits
BitSet functions
BitSet functions
nxClearBit
nxCloseEventAndSetAndNull
nxCloseHandleAndInvalidate
nxCloseHandleAndNull
nxCmpB8
comparison functions
comparison functions
nxCmpBytes
nxCmpDouble
nxCmpDynBytes
nxCmpExtended
nxCmpI16
nxCmpI32
nxCmpI64
nxCmpI64Ptr
nxCmpI8
nxCmpObj
nxCmpPtr
nxCmpShStr
nxCmpShStrUC
nxCmpSingle
nxCmpStr
nxCmpStrUC
nxCmpW16
nxCmpW32
nxCodepageFromCharacterSet
This is function nxllUtils.nxCodepageFromCharacterSet.
nxCodePageList
This is function nxllUtils.nxCodePageList.
nxCollationList
This is function nxllUtils.nxCollationList.
nxCollationNameFromLocale
This is function nxllUtils.nxCollationNameFromLocale.
nxCommaizeChL
nxDateTimeToAnsiStr
nxDateTimeToWideStr
nxDateToAnsiStr
nxDateToWideStr
nxDelphiStringsToUnicodeStrings
This is function nxllUtils.nxDelphiStringsToUnicodeStrings.
nxDisconnectObject
This is function nxllUtils.nxDisconnectObject.
nxExpandAnsiToWide
nxFindCmdLineParam
nxFindCmdLineParam
nxFindCmdLineSwitch
command line functions
nxFirstClearBit
function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register;
function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register; asm push ebx
xor ecx, ecx @@Loop: bsf ebx, [eax] jz @@AllZero add ecx, ebx cmp edx,ecx jnle @@FoundIt jmp @@NotFound @@AllZero: add ecx,$20 add eax,$04 cmp edx,ecx jnle @@Loop
@@NotFound: mov ecx, -1 @@FoundIt: mov eax, ecx
pop ebx end;
nxFloatToAnsiStr
nxFloatToWideStr
nxFormatSettingFromLocaleID
This is function nxllUtils.nxFormatSettingFromLocaleID.
nxGetCSIDLShellFolder
nxGetThreadCodePage
nxGUIDToAnsiString
nxGUIDToWideString
nxIntToAnsiStr
nxIntToAnsiStr
other functions
nxIntToWideStr
nxIntToWideStr
nxIsBitSet
nxIsClassInstance
nxIsClassInstanceOfType
nxIsSystemTable
nxIsValidCodepage
This is function nxllUtils.nxIsValidCodepage.
nxIsValidLocale
nxLocaleFromCollation
This is function nxllUtils.nxLocaleFromCollation.
nxMakeTimeStamp
date/time functions
date/time functions
nxMakeValidIdent
nxMakeValidIdent
nxMaxI32
nxMaxI64
nxMaxW16
nxMaxW32
nxMinI32
nxMinI64
nxMinW16
nxMinW32
nxMinWC
minimum/maximum functions
minimum/maximum functions
nxNewArray
This is function nxllUtils.nxNewArray.
nxNullStrLToWideStr
nxOSCheck
nxOSCheck
nxOSCheck
nxOSIsWindowsVistaOrBetter
nxPathEncode
This is function nxllUtils.nxPathEncode.
nxPtrIsClassOfType
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRaiseLastOSError
nxRemoveFromArray
This is function nxllUtils.nxRemoveFromArray.
nxSameDynBytes
nxSameDynBytes
nxSameGuid
nxSameGuid
nxSetAllBits
nxSetBit
nxSetPrivilege
nxSetPrivilege
nxShStrLToWideStr
nxStartsWith
nxStrCompW
This is function nxllUtils.nxStrCompW.
nxStrICompW
This is function nxllUtils.nxStrICompW.
nxStringsToArray
This is function nxllUtils.nxStringsToArray.
nxStringToWideChar
nxStrLCompW
This is function nxllUtils.nxStrLCompW.
nxStrLICompW
This is function nxllUtils.nxStrLICompW.
nxStrSplit
nxSupportsMulti
This is function nxllUtils.nxSupportsMulti.
nxSwapByteOrder
nxTimeToAnsiStr
nxTimeToWideStr
nxUnicodeStringsToDelphiStrings
This is function nxllUtils.nxUnicodeStringsToDelphiStrings.
nxUnmapViewOfFileAndNil
nxVarArrayLength
This is function nxllUtils.nxVarArrayLength.
nxVarRecAsAnsiString
This is function nxllUtils.nxVarRecAsAnsiString.
nxVarRecAsString
This is function nxllUtils.nxVarRecAsString.
nxVarRecAsUnicodeString
This is function nxllUtils.nxVarRecAsUnicodeString.
nxVerifyExtension
file handlings functions
nxVerifyFileName
nxWideCharToChar
nxWideStrLower
nxWideStrLToNullStr
nxWideStrLToShStr
nxWideStrLToWideStr
nxWideStrPos
nxWideStrToIntDef
ServiceStillBusy
This is function nxllUtils.ServiceStillBusy.
Succeeded
This is function nxllUtils.Succeeded.
UTF8EncodeToShortString
This is function nxllUtils.UTF8EncodeToShortString.
UTF8EncodeToShortString
This is function nxllUtils.UTF8EncodeToShortString.
UTF8ToUnicodeString
This is function nxllUtils.UTF8ToUnicodeString.
UTF8ToUnicodeString
This is function nxllUtils.UTF8ToUnicodeString.
Namespace

nxllUtils Namespace

Links
Functions, nxllUtils Namespace, Legend


nxllUtils.EmulateGlobalMemoryStatusEx Function

nxllUtils.EmulateGlobalMemoryStatusEx Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function EmulateGlobalMemoryStatusEx(var lpBuffer: TMemoryStatusEx): LongBool; stdcall;
File

nxllUtils

Description

EmulateGlobalMemoryStatusEx

Group

Functions

Links
nxllUtils, Functions


nxllUtils.GetNLSVersionCompareString Function

nxllUtils.GetNLSVersionCompareString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure GetNLSVersionCompareString(aLocale: LCID; out aVersionInfo: TNLSVersionInfoEx);
File

nxllUtils

Description

This is function nxllUtils.GetNLSVersionCompareString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.HexStringToByteArray Function

nxllUtils.HexStringToByteArray Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure HexStringToByteArray(S: string; ArrayLength: Integer; ByteArray: Pointer);
File

nxllUtils

Description

ByteArray functions

ByteArray functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAddLineBreakForMultiLine Function

nxllUtils.nxAddLineBreakForMultiLine Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAddLineBreakForMultiLine(const s: string): string;
File

nxllUtils

Description

This is function nxllUtils.nxAddLineBreakForMultiLine.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAddToArray Function

nxllUtils.nxAddToArray Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxAddToArray(var aArray: TnxUnicodeStrings; const aElement: UnicodeString); overload;
File

nxllUtils

Description

This is function nxllUtils.nxAddToArray.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAnsiStrIComp Function

nxllUtils.nxAnsiStrIComp Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAnsiStrIComp(S1: PAnsiChar; S2: PAnsiChar): Integer;
File

nxllUtils

Description

String functions

String functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAnsiStrLIComp Function

nxllUtils.nxAnsiStrLIComp Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAnsiStrLIComp(S1: PAnsiChar; S2: PAnsiChar; MaxLen: Cardinal): Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAnsiStrPos Function

nxllUtils.nxAnsiStrPos Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAnsiStrPos(S1: PAnsiChar; S2: PAnsiChar): Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAnsiStrToIntDef Function

nxllUtils.nxAnsiStrToIntDef Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAnsiStrToIntDef(const S: AnsiString; Default: Integer): Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxAppHomeDirectory Function

nxllUtils.nxAppHomeDirectory Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxAppHomeDirectory(aCommonAppdataSubDir: String): String;
File

nxllUtils

Description

on OS before Windos Vista, returns the exe directory. on Vista, returns directory under All usersApplication Data

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxBitsOr Function

nxllUtils.nxBitsOr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxBitsOr(Target: PnxByteArray; Source: PnxByteArray; BitCount: Integer); register;
File

nxllUtils

Description

procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register;

procedure nxBitsAnd(Target, Source : PnxByteArray; BitCount : Integer); register; asm push ebx push ebp

add ecx, 7 and ecx, $FFFFFFF8 shr ecx, 3

mov ebp, ecx shr ecx, 2

@@LoopDWord: jcxz @@DoneDWord dec ecx mov ebx, [edx + ecx * 4] and [eax + ecx * 4], ebx jmp @@LoopDWord

@@DoneDWord: mov ecx, ebp and ecx, $03 jcxz @@DoneAll

shr ebp, 2 lea eax, [eax + ebp * 4] lea edx, [edx + ebp * 4]

@@LoopByte: dec ecx mov bl, [edx + ecx] and [eax + ecx], bl jcxz @@DoneAll jmp @@LoopByte

@@DoneAll: pop ebp pop ebx end;

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCalcELFHash Function

nxllUtils.nxCalcELFHash Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCalcELFHash(const Buffer; BufSize: Integer): TnxWord32;
File

nxllUtils

Description

Hash functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCalcShStrELFHash Function

nxllUtils.nxCalcShStrELFHash Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCalcShStrELFHash(const S: TnxShStr): TnxWord32;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCalcStrELFHash Function

nxllUtils.nxCalcStrELFHash Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCalcStrELFHash(const S: AnsiString): TnxWord32; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCalcStrELFHash Function

nxllUtils.nxCalcStrELFHash Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCalcStrELFHash(const S: UnicodeString): TnxWord32; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCharacterSetNameFromCodepage Function

nxllUtils.nxCharacterSetNameFromCodepage Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCharacterSetNameFromCodepage(CodepageID: DWord): WideString;
File

nxllUtils

Description

This is function nxllUtils.nxCharacterSetNameFromCodepage.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCharIsInSet Function

nxllUtils.nxCharIsInSet Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCharIsInSet(AString: string; const ACharPos: Integer; ASet: TSysCharSet): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCharToWideChar Function

nxllUtils.nxCharToWideChar Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCharToWideChar(Ch: AnsiChar): WideChar;
File

nxllUtils

Description

Wide-String functions

Wide-String functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCheckValidIdent Function

nxllUtils.nxCheckValidIdent Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCheckValidIdent(const aIdent: string; aErrorCode: TnxResult; aAllowEmpty: Boolean; aAllowSystem: Boolean = True): TnxResult;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxClassFromPtr Function

nxllUtils.nxClassFromPtr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxClassFromPtr(aPtr: Pointer): TClass;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxClearAllBits Function

nxllUtils.nxClearAllBits Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxClearAllBits(BitSet: PnxByteArray; BitCount: Integer); register;
File

nxllUtils

Description

BitSet functions

BitSet functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxClearBit Function

nxllUtils.nxClearBit Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxClearBit(BitSet: PnxByteArray; Bit: Integer); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCloseEventAndSetAndNull Function

nxllUtils.nxCloseEventAndSetAndNull Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxCloseEventAndSetAndNull(var aHandle: THandle); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCloseHandleAndInvalidate Function

nxllUtils.nxCloseHandleAndInvalidate Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxCloseHandleAndInvalidate(var aHandle: THandle); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCloseHandleAndNull Function

nxllUtils.nxCloseHandleAndNull Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxCloseHandleAndNull(var aHandle: THandle); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpB8 Function

nxllUtils.nxCmpB8 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpB8(a: TnxByte8; b: TnxByte8): TnxValueRelationship;
File

nxllUtils

Description

comparison functions

comparison functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpBytes Function

nxllUtils.nxCmpBytes Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpBytes(a: PnxByteArray; b: PnxByteArray; MaxLen: TnxWord32): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpDouble Function

nxllUtils.nxCmpDouble Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpDouble(const a: TnxDouble; const b: TnxDouble): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpDynBytes Function

nxllUtils.nxCmpDynBytes Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpDynBytes(a: TnxDynByteArray; b: TnxDynByteArray): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpExtended Function

nxllUtils.nxCmpExtended Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpExtended(const a: TnxExtended; const b: TnxExtended): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpI16 Function

nxllUtils.nxCmpI16 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpI16(a: TnxInt16; b: TnxInt16): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpI32 Function

nxllUtils.nxCmpI32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpI32(a: TnxInt32; b: TnxInt32): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpI64 Function

nxllUtils.nxCmpI64 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpI64(const a: TnxInt64; const b: TnxInt64): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpI64Ptr Function

nxllUtils.nxCmpI64Ptr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpI64Ptr(a: PnxInt64; b: PnxInt64): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpI8 Function

nxllUtils.nxCmpI8 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpI8(a: TnxInt8; b: TnxInt8): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpObj Function

nxllUtils.nxCmpObj Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpObj(a: TObject; b: TObject): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpPtr Function

nxllUtils.nxCmpPtr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpPtr(a: Pointer; b: Pointer): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpShStr Function

nxllUtils.nxCmpShStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpShStr(const a: TnxShStr; const b: TnxShStr; MaxLen: TnxByte8 = 255): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpShStrUC Function

nxllUtils.nxCmpShStrUC Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpShStrUC(const a: TnxShStr; const b: TnxShStr; MaxLen: TnxByte8 = 255): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpSingle Function

nxllUtils.nxCmpSingle Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpSingle(const a: TnxSingle; const b: TnxSingle): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpStr Function

nxllUtils.nxCmpStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpStr(const a: string; const b: string): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpStrUC Function

nxllUtils.nxCmpStrUC Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpStrUC(const a: string; const b: string): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpW16 Function

nxllUtils.nxCmpW16 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpW16(a: TnxWord16; b: TnxWord16): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCmpW32 Function

nxllUtils.nxCmpW32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCmpW32(a: TnxWord32; b: TnxWord32): TnxValueRelationship;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCodepageFromCharacterSet Function

nxllUtils.nxCodepageFromCharacterSet Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCodepageFromCharacterSet(const CharacterSetName: string): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxCodepageFromCharacterSet.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCodePageList Function

nxllUtils.nxCodePageList Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCodePageList: TStringList;
File

nxllUtils

Description

This is function nxllUtils.nxCodePageList.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCollationList Function

nxllUtils.nxCollationList Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCollationList: TStringList;
File

nxllUtils

Description

This is function nxllUtils.nxCollationList.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCollationNameFromLocale Function

nxllUtils.nxCollationNameFromLocale Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCollationNameFromLocale(LocaleID: DWord): WideString;
File

nxllUtils

Description

This is function nxllUtils.nxCollationNameFromLocale.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxCommaizeChL Function

nxllUtils.nxCommaizeChL Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxCommaizeChL(L: Integer; Ch: Char): string;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDateTimeToAnsiStr Function

nxllUtils.nxDateTimeToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDateTimeToAnsiStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): AnsiString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDateTimeToWideStr Function

nxllUtils.nxDateTimeToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDateTimeToWideStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): UnicodeString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDateToAnsiStr Function

nxllUtils.nxDateToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDateToAnsiStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): AnsiString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDateToWideStr Function

nxllUtils.nxDateToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDateToWideStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): UnicodeString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDelphiStringsToUnicodeStrings Function

nxllUtils.nxDelphiStringsToUnicodeStrings Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDelphiStringsToUnicodeStrings(aStrings: TStrings): TnxUnicodeStrings;
File

nxllUtils

Description

This is function nxllUtils.nxDelphiStringsToUnicodeStrings.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxDisconnectObject Function

nxllUtils.nxDisconnectObject Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxDisconnectObject(const aInstance: InxInterface): HRESULT;
File

nxllUtils

Description

This is function nxllUtils.nxDisconnectObject.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxExpandAnsiToWide Function

nxllUtils.nxExpandAnsiToWide Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxExpandAnsiToWide(aSource: PAnsiChar; aTarget: PWideChar; aCount: Cardinal);
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFindCmdLineParam Function

nxllUtils.nxFindCmdLineParam Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFindCmdLineParam(const aSwitch: string; const aChars: TSysCharSet; aIgnoreCase: Boolean; out aValue: string): Boolean; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFindCmdLineParam Function

nxllUtils.nxFindCmdLineParam Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFindCmdLineParam(const aSwitch: string; out aValue: string): Boolean; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFindCmdLineSwitch Function

nxllUtils.nxFindCmdLineSwitch Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFindCmdLineSwitch(const aSwitch: string): Boolean;
File

nxllUtils

Description

command line functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFirstClearBit Function

nxllUtils.nxFirstClearBit Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFirstClearBit(BitSet: PnxByteArray; BitCount: Integer): Integer; register;
File

nxllUtils

Description

function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register;

function nxFirstSetBit(BitSet : PnxByteArray; BitCount : Integer): Integer; register; asm push ebx

xor ecx, ecx @@Loop: bsf ebx, [eax] jz @@AllZero add ecx, ebx cmp edx,ecx jnle @@FoundIt jmp @@NotFound @@AllZero: add ecx,$20 add eax,$04 cmp edx,ecx jnle @@Loop

@@NotFound: mov ecx, -1 @@FoundIt: mov eax, ecx

pop ebx end;

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFloatToAnsiStr Function

nxllUtils.nxFloatToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFloatToAnsiStr(const Value: Extended; const FormatSettings: TFormatSettings): AnsiString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFloatToWideStr Function

nxllUtils.nxFloatToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFloatToWideStr(const Value: Extended; const FormatSettings: TFormatSettings): UnicodeString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxFormatSettingFromLocaleID Function

nxllUtils.nxFormatSettingFromLocaleID Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxFormatSettingFromLocaleID(LocaleID: DWord): PFormatSettings;
File

nxllUtils

Description

This is function nxllUtils.nxFormatSettingFromLocaleID.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxGetCSIDLShellFolder Function

nxllUtils.nxGetCSIDLShellFolder Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxGetCSIDLShellFolder(CSIDLFolder: integer): string;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxGetThreadCodePage Function

nxllUtils.nxGetThreadCodePage Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxGetThreadCodePage: Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxGUIDToAnsiString Function

nxllUtils.nxGUIDToAnsiString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxGUIDToAnsiString(const aGUID: TGUID): AnsiString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxGUIDToWideString Function

nxllUtils.nxGUIDToWideString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxGUIDToWideString(const aGUID: TGUID): UnicodeString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIntToAnsiStr Function

nxllUtils.nxIntToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIntToAnsiStr(aInt: Int64): AnsiString; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIntToAnsiStr Function

nxllUtils.nxIntToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIntToAnsiStr(aInt: Integer): AnsiString; overload;
File

nxllUtils

Description

other functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIntToWideStr Function

nxllUtils.nxIntToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIntToWideStr(aInt: Int64): UnicodeString; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIntToWideStr Function

nxllUtils.nxIntToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIntToWideStr(aInt: Integer): UnicodeString; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsBitSet Function

nxllUtils.nxIsBitSet Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsBitSet(BitSet: PnxByteArray; Bit: Integer): Boolean; register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsClassInstance Function

nxllUtils.nxIsClassInstance Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsClassInstance(aPtr: Pointer; out aClass: TClass): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsClassInstanceOfType Function

nxllUtils.nxIsClassInstanceOfType Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsClassInstanceOfType(aPtr: Pointer; aClass: TClass): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsSystemTable Function

nxllUtils.nxIsSystemTable Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsSystemTable(const aTableName: string): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsValidCodepage Function

nxllUtils.nxIsValidCodepage Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsValidCodepage(CodepageID: DWord): Boolean;
File

nxllUtils

Description

This is function nxllUtils.nxIsValidCodepage.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxIsValidLocale Function

nxllUtils.nxIsValidLocale Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxIsValidLocale(LocaleID: DWord): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxLocaleFromCollation Function

nxllUtils.nxLocaleFromCollation Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxLocaleFromCollation(const CollationName: string): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxLocaleFromCollation.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMakeTimeStamp Function

nxllUtils.nxMakeTimeStamp Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMakeTimeStamp(const aDate: TnxDate; const aTime: TnxTime): TTimeStamp;
File

nxllUtils

Description

date/time functions

date/time functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMakeValidIdent Function

nxllUtils.nxMakeValidIdent Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMakeValidIdent(const aIdent: string): string; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMakeValidIdent Function

nxllUtils.nxMakeValidIdent Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMakeValidIdent(const aIdent: string; aValidIdentChars: TnxCharSet): string; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMaxI32 Function

nxllUtils.nxMaxI32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMaxI32(a: TnxInt32; b: TnxInt32): TnxInt32;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMaxI64 Function

nxllUtils.nxMaxI64 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMaxI64(const a: TnxInt64; const b: TnxInt64): TnxInt64;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMaxW16 Function

nxllUtils.nxMaxW16 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMaxW16(a: TnxWord16; b: TnxWord16): TnxWord16;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMaxW32 Function

nxllUtils.nxMaxW32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMaxW32(a: TnxWord32; b: TnxWord32): TnxWord32;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMinI32 Function

nxllUtils.nxMinI32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMinI32(a: TnxInt32; b: TnxInt32): TnxInt32;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMinI64 Function

nxllUtils.nxMinI64 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMinI64(const a: TnxInt64; const b: TnxInt64): TnxInt64;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMinW16 Function

nxllUtils.nxMinW16 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMinW16(a: TnxWord16; b: TnxWord16): TnxWord16;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMinW32 Function

nxllUtils.nxMinW32 Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMinW32(a: TnxWord32; b: TnxWord32): TnxWord32;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxMinWC Function

nxllUtils.nxMinWC Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxMinWC(a: TnxWideChar; b: TnxWideChar): TnxWideChar;
File

nxllUtils

Description

minimum/maximum functions

minimum/maximum functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxNewArray Function

nxllUtils.nxNewArray Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxNewArray(const aFirstElement: UnicodeString): TnxUnicodeStrings; overload;
File

nxllUtils

Description

This is function nxllUtils.nxNewArray.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxNullStrLToWideStr Function

nxllUtils.nxNullStrLToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxNullStrLToWideStr(ZStr: PAnsiChar; WS: PWideChar; MaxLen: Integer): PWideChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxOSCheck Function

nxllUtils.nxOSCheck Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxOSCheck(RetVal: Boolean): Boolean; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxOSCheck Function

nxllUtils.nxOSCheck Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxOSCheck(RetVal: Boolean; const aSource: PResStringRec): Boolean; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxOSCheck Function

nxllUtils.nxOSCheck Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxOSCheck(RetVal: Boolean; const aSource: String): Boolean; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxOSIsWindowsVistaOrBetter Function

nxllUtils.nxOSIsWindowsVistaOrBetter Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxOSIsWindowsVistaOrBetter: Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxPathEncode Function

nxllUtils.nxPathEncode Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxPathEncode(const ASrc: string): string;
File

nxllUtils

Description

This is function nxllUtils.nxPathEncode.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxPtrIsClassOfType Function

nxllUtils.nxPtrIsClassOfType Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxPtrIsClassOfType(aPtr: Pointer; aClass: TClass): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRaiseLastOSError Function

nxllUtils.nxRaiseLastOSError Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxRaiseLastOSError(aSilentException: Boolean; const aSource: String; aErrorCode: TnxResult = 0); overload; procedure nxRaiseLastOSError; register; overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRaiseLastOSError Function

nxllUtils.nxRaiseLastOSError Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxRaiseLastOSError(aSilentException: Boolean; aSource: PResStringRec; aErrorCode: TnxResult = 0); overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRaiseLastOSError Function

nxllUtils.nxRaiseLastOSError Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxRaiseLastOSError(aSilentException: Boolean; aErrorCode: TnxResult = 0); overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRaiseLastOSError Function

nxllUtils.nxRaiseLastOSError Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxRaiseLastOSError(aSource: PResStringRec; aErrorCode: TnxResult = 0); overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRaiseLastOSError Function

nxllUtils.nxRaiseLastOSError Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxRaiseLastOSError(const aSource: String; aErrorCode: TnxResult = 0); overload;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxRemoveFromArray Function

nxllUtils.nxRemoveFromArray Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxRemoveFromArray(var aArray: TnxUnicodeStrings; aIndex: Integer): UnicodeString; overload;
File

nxllUtils

Description

This is function nxllUtils.nxRemoveFromArray.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSameDynBytes Function

nxllUtils.nxSameDynBytes Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxSameDynBytes(a: TnxDynByteArray; b: TnxDynByteArray): Boolean;
File

nxllUtils

Description

nxSameDynBytes

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSameGuid Function

nxllUtils.nxSameGuid Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxSameGuid(a: TnxGuid; b: TnxGuid): Boolean;
File

nxllUtils

Description

nxSameGuid

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSetAllBits Function

nxllUtils.nxSetAllBits Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxSetAllBits(BitSet: PnxByteArray; BitCount: Integer); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSetBit Function

nxllUtils.nxSetBit Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxSetBit(BitSet: PnxByteArray; Bit: Integer); register;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSetPrivilege Function

nxllUtils.nxSetPrivilege Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxSetPrivilege(aPrivilegeName: string; aEnable: Boolean): Boolean;
File

nxllUtils

Description

nxSetPrivilege

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxShStrLToWideStr Function

nxllUtils.nxShStrLToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxShStrLToWideStr(const S: TnxShStr; WS: PWideChar; MaxLen: Integer): PWideChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStartsWith Function

nxllUtils.nxStartsWith Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStartsWith(const s: string; const t: string): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStrCompW Function

nxllUtils.nxStrCompW Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStrCompW(const Str1: PWideChar; const Str2: PWideChar): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxStrCompW.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStrICompW Function

nxllUtils.nxStrICompW Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStrICompW(const Str1: PWideChar; const Str2: PWideChar): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxStrICompW.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStringsToArray Function

nxllUtils.nxStringsToArray Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStringsToArray(aStrings: TStrings): TnxDynStringArray;
File

nxllUtils

Description

This is function nxllUtils.nxStringsToArray.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStringToWideChar Function

nxllUtils.nxStringToWideChar Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxStringToWideChar(const Source: UnicodeString; Dest: PWideChar; DestSize: Integer);
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStrLCompW Function

nxllUtils.nxStrLCompW Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStrLCompW(const Str1: PWideChar; const Str2: PWideChar; MaxLen: Cardinal): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxStrLCompW.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStrLICompW Function

nxllUtils.nxStrLICompW Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxStrLICompW(const Str1: PWideChar; const Str2: PWideChar; MaxLen: Cardinal): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxStrLICompW.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxStrSplit Function

nxllUtils.nxStrSplit Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxStrSplit(S: string; const SplitChars: TnxCharSet; var Left: string; var Right: string);
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSupportsMulti Function

nxllUtils.nxSupportsMulti Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxSupportsMulti(const Instance: IInterface; const IIDs: array of TGUID; const Intfs: array of PnxInterface): TnxSupportsMultiResult;
File

nxllUtils

Description

This is function nxllUtils.nxSupportsMulti.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxSwapByteOrder Function

nxllUtils.nxSwapByteOrder Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxSwapByteOrder(aWideString: PWideChar; aCount: Cardinal);
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxTimeToAnsiStr Function

nxllUtils.nxTimeToAnsiStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxTimeToAnsiStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): AnsiString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxTimeToWideStr Function

nxllUtils.nxTimeToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxTimeToWideStr(const aDateTime: TDateTime; const aFormatSettings: TFormatSettings): UnicodeString;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxUnicodeStringsToDelphiStrings Function

nxllUtils.nxUnicodeStringsToDelphiStrings Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxUnicodeStringsToDelphiStrings(const aUnicodeStrings: TnxUnicodeStrings; aStrings: TStrings);
File

nxllUtils

Description

This is function nxllUtils.nxUnicodeStringsToDelphiStrings.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxUnmapViewOfFileAndNil Function

nxllUtils.nxUnmapViewOfFileAndNil Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure nxUnmapViewOfFileAndNil(var p); register;
File

nxllUtils

Parameters
Parameters | Description
var p | : Pointer : Pointer
Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVarArrayLength Function

nxllUtils.nxVarArrayLength Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVarArrayLength(const V: Variant; Dim: Integer): Integer;
File

nxllUtils

Description

This is function nxllUtils.nxVarArrayLength.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVarRecAsAnsiString Function

nxllUtils.nxVarRecAsAnsiString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVarRecAsAnsiString(const aVarRec: TVarRec): AnsiString;
File

nxllUtils

Description

This is function nxllUtils.nxVarRecAsAnsiString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVarRecAsString Function

nxllUtils.nxVarRecAsString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVarRecAsString(const aVarRec: TVarRec): string;
File

nxllUtils

Description

This is function nxllUtils.nxVarRecAsString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVarRecAsUnicodeString Function

nxllUtils.nxVarRecAsUnicodeString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVarRecAsUnicodeString(const aVarRec: TVarRec): UnicodeString;
File

nxllUtils

Description

This is function nxllUtils.nxVarRecAsUnicodeString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVerifyExtension Function

nxllUtils.nxVerifyExtension Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVerifyExtension(const Ext: string): Boolean;
File

nxllUtils

Description

file handlings functions

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxVerifyFileName Function

nxllUtils.nxVerifyFileName Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxVerifyFileName(const FileName: string): Boolean;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideCharToChar Function

nxllUtils.nxWideCharToChar Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideCharToChar(WC: WideChar): AnsiChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrLower Function

nxllUtils.nxWideStrLower Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrLower(Str: PWideChar): PWideChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrLToNullStr Function

nxllUtils.nxWideStrLToNullStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrLToNullStr(WS: PWideChar; ZStr: PAnsiChar; MaxLen: Integer): PAnsiChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrLToShStr Function

nxllUtils.nxWideStrLToShStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrLToShStr(WS: PWideChar; MaxLen: Integer): TnxShStr;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrLToWideStr Function

nxllUtils.nxWideStrLToWideStr Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrLToWideStr(aSourceValue: PWideChar; aTargetValue: PWideChar; MaxLength: Integer): PWideChar;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrPos Function

nxllUtils.nxWideStrPos Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrPos(S1: PWideChar; S2: PWideChar): Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.nxWideStrToIntDef Function

nxllUtils.nxWideStrToIntDef Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function nxWideStrToIntDef(const S: WideString; Default: Integer): Integer;
File

nxllUtils

Group

Functions

Links
nxllUtils, Functions


nxllUtils.ServiceStillBusy Function

nxllUtils.ServiceStillBusy Function
nxllUtils Functions Send Feedback
Syntax
Delphi
procedure ServiceStillBusy;
File

nxllUtils

Description

This is function nxllUtils.ServiceStillBusy.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.Succeeded Function

nxllUtils.Succeeded Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function Succeeded(Res: HResult): Boolean;
File

nxllUtils

Description

This is function nxllUtils.Succeeded.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.UTF8EncodeToShortString Function

nxllUtils.UTF8EncodeToShortString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function UTF8EncodeToShortString(const aAnsi: RawByteString): ShortString; overload;
File

nxllUtils

Description

This is function nxllUtils.UTF8EncodeToShortString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.UTF8EncodeToShortString Function

nxllUtils.UTF8EncodeToShortString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function UTF8EncodeToShortString(const aWide: WideString): ShortString; overload;
File

nxllUtils

Description

This is function nxllUtils.UTF8EncodeToShortString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.UTF8ToUnicodeString Function

nxllUtils.UTF8ToUnicodeString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function UTF8ToUnicodeString(const aAnsi: RawByteString): UnicodeString; overload;
File

nxllUtils

Description

This is function nxllUtils.UTF8ToUnicodeString.

Group

Functions

Links
nxllUtils, Functions


nxllUtils.UTF8ToUnicodeString Function

nxllUtils.UTF8ToUnicodeString Function
nxllUtils Functions Send Feedback
Syntax
Delphi
function UTF8ToUnicodeString(const aShort: ShortString): UnicodeString; overload;
File

nxllUtils

Description

This is function nxllUtils.UTF8ToUnicodeString.

Group

Functions

Links
nxllUtils, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllUtils Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxSupportsMultiResult | This is record nxllUtils.TnxSupportsMultiResult.
Namespace

nxllUtils Namespace

Records
Name | Description
TCpInfoEx | This is record nxllUtils.TCpInfoEx.
TMemoryStatusEx | This is record nxllUtils.TMemoryStatusEx.
TNLSVersionInfo | This is record nxllUtils.TNLSVersionInfo.
TNLSVersionInfoEx | This is record nxllUtils.TNLSVersionInfoEx.
TnxLocaleNameMapping | This is record nxllUtils.TnxLocaleNameMapping.
Links
Enumerations, nxllUtils Namespace, Legend, Records


nxllUtils.TCpInfoEx Record

nxllUtils.TCpInfoEx Record
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TCpInfoEx = packed record
  MaxCharSize: DWord;
  DefaultChar: array[0..MAX_DEFAULTCHAR-1] of AnsiChar;
  LeadByte: array[0..MAX_LEADBYTES-1] of byte;
  UnicodeDefaultChar: WideChar;
  CodePage: DWord;
  CodePageName: array[0..MAX_PATH-1] of char;
end;
File

nxllUtils

Description

This is record nxllUtils.TCpInfoEx.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


nxllUtils.TMemoryStatusEx Record

nxllUtils.TMemoryStatusEx Record
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TMemoryStatusEx = record
  dwLength: Cardinal;
  dwMemoryLoad: Cardinal;
  ullTotalPhys: Int64;
  ullAvailPhys: Int64;
  ullTotalPageFile: Int64;
  ullAvailPageFile: Int64;
  ullTotalVirtual: Int64;
  ullAvailVirtual: Int64;
  ullAvailExtendedVirtual: Int64;
end;
File

nxllUtils

Description

This is record nxllUtils.TMemoryStatusEx.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


nxllUtils.TNLSVersionInfo Record

nxllUtils.TNLSVersionInfo Record
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TNLSVersionInfo = record
  dwNLSVersionInfoSize: DWORD;
  dwNLSVersion: DWORD;
  dwDefinedVersion: DWORD;
end;
File

nxllUtils

Description

This is record nxllUtils.TNLSVersionInfo.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


nxllUtils.TNLSVersionInfoEx Record

nxllUtils.TNLSVersionInfoEx Record
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TNLSVersionInfoEx = record
  dwNLSVersionInfoSize: DWORD;
  dwNLSVersion: DWORD;
  dwDefinedVersion: DWORD;
  dwEffectiveId: DWORD;
  guidCustomVersion: TGUID;
end;
File

nxllUtils

Description

This is record nxllUtils.TNLSVersionInfoEx.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


nxllUtils.TnxLocaleNameMapping Record

nxllUtils.TnxLocaleNameMapping Record
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLocaleNameMapping = record
  lnmID: LCID;
  lnmName: string;
end;
File

nxllUtils

Description

This is record nxllUtils.TnxLocaleNameMapping.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


nxllUtils.TnxSupportsMultiResult Enumeration

nxllUtils.TnxSupportsMultiResult Enumeration
nxllUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSupportsMultiResult = ( smrNone, smrSome, smrAll );
File

nxllUtils

Description

This is record nxllUtils.TnxSupportsMultiResult.

Group

Structs, Records, Enums

Links
nxllUtils, Structs, Records, Enums


Types

Types
nxllUtils Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllUtils Namespace

Types
Name | Description
PFormatSettings | This is type nxllUtils.PFormatSettings.
PNLSVersionInfo | This is type nxllUtils.PNLSVersionInfo.
PNLSVersionInfoEx | This is type nxllUtils.PNLSVersionInfoEx.
TConvertSecurityDescriptorToStringSecurityDescriptor | This is type nxllUtils.TConvertSecurityDescriptorToStringSecurityDescriptor.
TConvertStringSecurityDescriptorToSecurityDescriptor | This is type nxllUtils.TConvertStringSecurityDescriptorToSecurityDescriptor.
TGetCPInfoEx | This is type nxllUtils.TGetCPInfoEx.
TGetNLSVersion | This is type nxllUtils.TGetNLSVersion.
TGlobalMemoryStatusEx | This is type nxllUtils.TGlobalMemoryStatusEx.
Links
nxllUtils Namespace, Types


nxllUtils.PFormatSettings Type

nxllUtils.PFormatSettings Type
nxllUtils Types Send Feedback
Syntax
Delphi
PFormatSettings = ^TFormatSettings;
File

nxllUtils

Description

This is type nxllUtils.PFormatSettings.

Group

Types

Links
nxllUtils, Types


nxllUtils.PNLSVersionInfo Type

nxllUtils.PNLSVersionInfo Type
nxllUtils Types Send Feedback
Syntax
Delphi
PNLSVersionInfo = ^TNLSVersionInfo;
File

nxllUtils

Description

This is type nxllUtils.PNLSVersionInfo.

Group

Types

Links
nxllUtils, Types


nxllUtils.PNLSVersionInfoEx Type

nxllUtils.PNLSVersionInfoEx Type
nxllUtils Types Send Feedback
Syntax
Delphi
PNLSVersionInfoEx = ^TNLSVersionInfoEx;
File

nxllUtils

Description

This is type nxllUtils.PNLSVersionInfoEx.

Group

Types

Links
nxllUtils, Types


nxllUtils.TConvertSecurityDescriptorToStringSecurityDescriptor Type

nxllUtils.TConvertSecurityDescriptorToStringSecurityDescriptor Type
nxllUtils Types Send Feedback
Syntax
Delphi
TConvertSecurityDescriptorToStringSecurityDescriptor = function (SecurityDescriptor : PSECURITY_DESCRIPTOR; RequestedStringSDRevision : DWORD; SecurityInformation : SECURITY_INFORMATION; var StringSecurityDescriptor : LPTSTR; StringSecurityDescriptorLen : PULONG) : BOOL;
File

nxllUtils

Description

This is type nxllUtils.TConvertSecurityDescriptorToStringSecurityDescriptor.

Group

Types

Links
nxllUtils, Types


nxllUtils.TConvertStringSecurityDescriptorToSecurityDescriptor Type

nxllUtils.TConvertStringSecurityDescriptorToSecurityDescriptor Type
nxllUtils Types Send Feedback
Syntax
Delphi
TConvertStringSecurityDescriptorToSecurityDescriptor = function (StringSecurityDescriptor : LPCTSTR; StringSDRevision : DWORD; var SecurityDescriptor : PSECURITY_DESCRIPTOR; SecurityDescriptorSize : PULONG) : BOOL;
File

nxllUtils

Description

This is type nxllUtils.TConvertStringSecurityDescriptorToSecurityDescriptor.

Group

Types

Links
nxllUtils, Types


nxllUtils.TGetCPInfoEx Type

nxllUtils.TGetCPInfoEx Type
nxllUtils Types Send Feedback
Syntax
Delphi
TGetCPInfoEx = function (CodePage: UINT; Flags: UINT; var lpCPInfo: TCPInfoEx): BOOL;
File

nxllUtils

Description

This is type nxllUtils.TGetCPInfoEx.

Group

Types

Links
nxllUtils, Types


nxllUtils.TGetNLSVersion Type

nxllUtils.TGetNLSVersion Type
nxllUtils Types Send Feedback
Syntax
Delphi
TGetNLSVersion = function (Function_: DWORD; Locale: LCID; lpVersionInformation: PNLSVersionInfo): BOOL;
File

nxllUtils

Description

This is type nxllUtils.TGetNLSVersion.

Group

Types

Links
nxllUtils, Types


nxllUtils.TGlobalMemoryStatusEx Type

nxllUtils.TGlobalMemoryStatusEx Type
nxllUtils Types Send Feedback
Syntax
Delphi
TGlobalMemoryStatusEx = function (var lpBuffer: TMemoryStatusEx): LongBool;
File

nxllUtils

Description

This is type nxllUtils.TGlobalMemoryStatusEx.

Group

Types

Links
nxllUtils, Types


Variables

Variables
nxllUtils Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllUtils Namespace

Variables
Name | Description
_CodePageList | This is variable nxllUtils._CodePageList.
_CodePageListPadlock | This is variable nxllUtils._CodePageListPadlock.
_CodePageListTemp | This is variable nxllUtils._CodePageListTemp.
_CollationList | This is variable nxllUtils._CollationList.
_CollationListPadlock | This is variable nxllUtils._CollationListPadlock.
_CollationListTemp | This is variable nxllUtils._CollationListTemp.
_ConvertSecurityDescriptorToStringSecurityDescriptor | This is variable nxllUtils._ConvertSecurityDescriptorToStringSecurityDescriptor.
_ConvertStringSecurityDescriptorToSecurityDescriptor | This is variable nxllUtils._ConvertStringSecurityDescriptorToSecurityDescriptor.
_FormatSettingList | This is variable nxllUtils._FormatSettingList.
_FormatSettingListPadlock | This is variable nxllUtils._FormatSettingListPadlock.
_GetNLSVersion | This is variable nxllUtils._GetNLSVersion.
_GlobalMemoryStatusEx | This is variable nxllUtils._GlobalMemoryStatusEx.
_nxDisconnectObject | This is variable nxllUtils._nxDisconnectObject.
_nxFillChar | This is variable nxllUtils._nxFillChar.
_ServiceStillBusy | This is variable nxllUtils._ServiceStillBusy.
CharA | This is variable nxllUtils.CharA.
CharB | This is variable nxllUtils.CharB.
GetCPInfoEx | This is variable nxllUtils.GetCPInfoEx.
i | This is variable nxllUtils.i.
LenA | This is variable nxllUtils.LenA.
LenB | This is variable nxllUtils.LenB.
LStr1 | This is variable nxllUtils.LStr1.
LStr2 | This is variable nxllUtils.LStr2.
MatchStart | This is variable nxllUtils.MatchStart.
nxDefaultUserCodePage | This is variable nxllUtils.nxDefaultUserCodePage.
nxInvariantFormatSettings | This is variable nxllUtils.nxInvariantFormatSettings.
nxRaiseLastOSErrorSimple | This is variable nxllUtils.nxRaiseLastOSErrorSimple.
q | This is variable nxllUtils.q.
sGlobalNamePrefix | This is variable nxllUtils.sGlobalNamePrefix.
sLocalNamePrefix | This is variable nxllUtils.sLocalNamePrefix.
Links
nxllUtils Namespace, Variables


nxllUtils._CodePageList Variable

nxllUtils._CodePageList Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CodePageList: TStringList;
File

nxllUtils

Description

This is variable nxllUtils._CodePageList.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._CodePageListPadlock Variable

nxllUtils._CodePageListPadlock Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CodePageListPadlock: TnxPadlock;
File

nxllUtils

Description

This is variable nxllUtils._CodePageListPadlock.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._CodePageListTemp Variable

nxllUtils._CodePageListTemp Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CodePageListTemp: TStringList;
File

nxllUtils

Description

This is variable nxllUtils._CodePageListTemp.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._CollationList Variable

nxllUtils._CollationList Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CollationList: TStringList;
File

nxllUtils

Description

This is variable nxllUtils._CollationList.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._CollationListPadlock Variable

nxllUtils._CollationListPadlock Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CollationListPadlock: TnxPadlock;
File

nxllUtils

Description

This is variable nxllUtils._CollationListPadlock.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._CollationListTemp Variable

nxllUtils._CollationListTemp Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_CollationListTemp: TStringList;
File

nxllUtils

Description

This is variable nxllUtils._CollationListTemp.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._ConvertSecurityDescriptorToStringSecurityDescriptor Variable

nxllUtils._ConvertSecurityDescriptorToStringSecurityDescriptor Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_ConvertSecurityDescriptorToStringSecurityDescriptor: TConvertSecurityDescriptorToStringSecurityDescriptor;
File

nxllUtils

Description

This is variable nxllUtils._ConvertSecurityDescriptorToStringSecurityDescriptor.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._ConvertStringSecurityDescriptorToSecurityDescriptor Variable

nxllUtils._ConvertStringSecurityDescriptorToSecurityDescriptor Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_ConvertStringSecurityDescriptorToSecurityDescriptor: TConvertStringSecurityDescriptorToSecurityDescriptor;
File

nxllUtils

Description

This is variable nxllUtils._ConvertStringSecurityDescriptorToSecurityDescriptor.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._FormatSettingList Variable

nxllUtils._FormatSettingList Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_FormatSettingList: TnxFastStringListCS;
File

nxllUtils

Description

This is variable nxllUtils._FormatSettingList.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._FormatSettingListPadlock Variable

nxllUtils._FormatSettingListPadlock Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_FormatSettingListPadlock: TnxPadlock;
File

nxllUtils

Description

This is variable nxllUtils._FormatSettingListPadlock.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._GetNLSVersion Variable

nxllUtils._GetNLSVersion Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_GetNLSVersion: TGetNLSVersion;
File

nxllUtils

Description

This is variable nxllUtils._GetNLSVersion.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._GlobalMemoryStatusEx Variable

nxllUtils._GlobalMemoryStatusEx Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_GlobalMemoryStatusEx: TGlobalMemoryStatusEx;
File

nxllUtils

Description

This is variable nxllUtils._GlobalMemoryStatusEx.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._nxDisconnectObject Variable

nxllUtils._nxDisconnectObject Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_nxDisconnectObject: function(const aInstance: InxInterface): HRESULT = nil;
File

nxllUtils

Description

This is variable nxllUtils._nxDisconnectObject.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._nxFillChar Variable

nxllUtils._nxFillChar Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_nxFillChar: TnxFillChar;
File

nxllUtils

Description

This is variable nxllUtils._nxFillChar.

Group

Variables

Links
nxllUtils, Variables


nxllUtils._ServiceStillBusy Variable

nxllUtils._ServiceStillBusy Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
_ServiceStillBusy: procedure of object;
File

nxllUtils

Description

This is variable nxllUtils._ServiceStillBusy.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.CharA Variable

nxllUtils.CharA Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
CharA: AnsiChar;
File

nxllUtils

Description

This is variable nxllUtils.CharA.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.CharB Variable

nxllUtils.CharB Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
CharB: AnsiChar;
File

nxllUtils

Description

This is variable nxllUtils.CharB.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.GetCPInfoEx Variable

nxllUtils.GetCPInfoEx Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
GetCPInfoEx: TGetCPInfoEx;
File

nxllUtils

Description

This is variable nxllUtils.GetCPInfoEx.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.i Variable

nxllUtils.i Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
i: Integer;
File

nxllUtils

Description

This is variable nxllUtils.i.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.LenA Variable

nxllUtils.LenA Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
LenA: Integer;
File

nxllUtils

Description

This is variable nxllUtils.LenA.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.LenB Variable

nxllUtils.LenB Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
LenB: Integer;
File

nxllUtils

Description

This is variable nxllUtils.LenB.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.LStr1 Variable

nxllUtils.LStr1 Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
LStr1: PWideChar;
File

nxllUtils

Description

This is variable nxllUtils.LStr1.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.LStr2 Variable

nxllUtils.LStr2 Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
LStr2: PWideChar;
File

nxllUtils

Description

This is variable nxllUtils.LStr2.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.MatchStart Variable

nxllUtils.MatchStart Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
MatchStart: PWideChar;
File

nxllUtils

Description

This is variable nxllUtils.MatchStart.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.nxDefaultUserCodePage Variable

nxllUtils.nxDefaultUserCodePage Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
nxDefaultUserCodePage: Integer;
File

nxllUtils

Description

This is variable nxllUtils.nxDefaultUserCodePage.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.nxInvariantFormatSettings Variable

nxllUtils.nxInvariantFormatSettings Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
nxInvariantFormatSettings: TFormatSettings;
File

nxllUtils

Description

This is variable nxllUtils.nxInvariantFormatSettings.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.nxRaiseLastOSErrorSimple Variable

nxllUtils.nxRaiseLastOSErrorSimple Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
nxRaiseLastOSErrorSimple: procedure = nxRaiseLastOSError;
File

nxllUtils

Description

This is variable nxllUtils.nxRaiseLastOSErrorSimple.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.q Variable

nxllUtils.q Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
q: THandle;
File

nxllUtils

Description

This is variable nxllUtils.q.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.sGlobalNamePrefix Variable

nxllUtils.sGlobalNamePrefix Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
sGlobalNamePrefix: string;
File

nxllUtils

Description

This is variable nxllUtils.sGlobalNamePrefix.

Group

Variables

Links
nxllUtils, Variables


nxllUtils.sLocalNamePrefix Variable

nxllUtils.sLocalNamePrefix Variable
nxllUtils Variables Send Feedback
Syntax
Delphi
sLocalNamePrefix: string;
File

nxllUtils

Description

This is variable nxllUtils.sLocalNamePrefix.

Group

Variables

Links
nxllUtils, Variables


Constants

Constants
Constants nxllUtils Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
LOCALE_INVARIANT | This is constant nxllUtils.LOCALE_INVARIANT.
nxFullAccessSD | D:(A;;GA;;;WD)' DACL:(SDDL_ACCESS_ALLOWED;;SDDL_FILE_ALL;;;SDDL_EVERYONE)
nxLocaleNameMappings | This is constant nxllUtils.nxLocaleNameMappings.
rsInvalidHexChar | This is constant nxllUtils.rsInvalidHexChar.
rsOSError | This is constant nxllUtils.rsOSError.
rsOSErrorSourceUnknown | This is constant nxllUtils.rsOSErrorSourceUnknown.
rsUnkOSError | This is constant nxllUtils.rsUnkOSError.
SDDL_REVISION | This is constant nxllUtils.SDDL_REVISION.
SDDL_REVISION_1 | This is constant nxllUtils.SDDL_REVISION_1.
Namespace

nxllUtils Namespace

Links
Constants, nxllUtils Namespace


nxllUtils.LOCALE_INVARIANT Constant

nxllUtils.LOCALE_INVARIANT Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
LOCALE_INVARIANT = $7f;
File

nxllUtils

Description

This is constant nxllUtils.LOCALE_INVARIANT.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.nxFullAccessSD Constant

nxllUtils.nxFullAccessSD Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
nxFullAccessSD: array[0..47] of Byte = (1, 0, 4, 128, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 20, 0, 0, 0, 2, 0, 28, 0, 1, 0, 0, 0, 0, 0, 20, 0, 0, 0, 0, 16, 1, 1, 0, 0, 0, 0, 0, 1, 0, 0, 0, 0);
File

nxllUtils

Description

D:(A;;GA;;;WD)' DACL:(SDDL_ACCESS_ALLOWED;;SDDL_FILE_ALL;;;SDDL_EVERYONE)

Group

Constants

Links
nxllUtils, Constants


nxllUtils.nxLocaleNameMappings Constant

nxllUtils.nxLocaleNameMappings Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
nxLocaleNameMappings: array [0..141] of TnxLocaleNameMapping = ( (lnmID: 1078; lnmName: 'Afrikaans'), (lnmID: 1052; lnmName: 'Albanian'), (lnmID: 5121; lnmName: 'Arabic (Algeria)'), (lnmID: 15361; lnmName: 'Arabic (Bahrain)'), (lnmID: 3073; lnmName: 'Arabic (Egypt)'), (lnmID: 2049; lnmName: 'Arabic (Iraq)'), (lnmID: 11265; lnmName: 'Arabic (Jordan)'), (lnmID: 13313; lnmName: 'Arabic (Kuwait)'), (lnmID: 12289; lnmName: 'Arabic (Lebanon)'), (lnmID: 4097; lnmName: 'Arabic (Libya)'), (lnmID: 6145; lnmName: 'Arabic (Morocco)'), (lnmID: 8193; lnmName: 'Arabic (Oman)'), (lnmID: 16385; lnmName: 'Arabic (Qatar)'), (lnmID: 1025; lnmName: 'Arabic (Saudi Arabia)'), (lnmID: 10241; lnmName: 'Arabic (Syria)'), (lnmID: 7169; lnmName: 'Arabic (Tunisia)'), (lnmID: 14337; lnmName: 'Arabic (U.A.E.)'), (lnmID: 9217; lnmName: 'Arabic (Yemen)'), (lnmID: 1067; lnmName: 'Armenian'), (lnmID: 2092; lnmName: 'Azeri (Cyrillic)'), (lnmID: 1068; lnmName: 'Azeri (Latin)'), (lnmID: 1069; lnmName: 'Basque'), (lnmID: 1059; lnmName: 'Belarusian'), (lnmID: 1026; lnmName: 'Bulgarian'), (lnmID: 1027; lnmName: 'Catalan'), (lnmID: 3076; lnmName: 'Chinese (Hong Kong S.A.R.) Stroke Count'), (lnmID: 5124; lnmName: 'Chinese (Macau S.A.R.) Pronunciation'), (lnmID: 136196; lnmName: 'Chinese (Macau S.A.R.) Stroke Count'), (lnmID: 2052; lnmName: 'Chinese (PRC) Pronunciation'), (lnmID: 133124; lnmName: 'Chinese (PRC) Stroke Count'), (lnmID: 4100; lnmName: 'Chinese (Singapore) Pronunciation'), (lnmID: 135172; lnmName: 'Chinese (Singapore) Stroke Count'), (lnmID: 197636; lnmName: 'Chinese (Taiwan) Bopomofo'), (lnmID: 1028; lnmName: 'Chinese (Taiwan) Stroke Count'), (lnmID: 1050; lnmName: 'Croatian'), (lnmID: 1029; lnmName: 'Czech'), (lnmID: 1030; lnmName: 'Danish'), (lnmID: 1125; lnmName: 'Divehi'), (lnmID: 2067; lnmName: 'Dutch (Belgium)'), (lnmID: 1043; lnmName: 'Dutch (Netherlands)'), (lnmID: 3081; lnmName: 'English (Australia)'), (lnmID: 10249; lnmName: 'English (Belize)'), (lnmID: 4105; lnmName: 'English (Canada)'), (lnmID: 9225; lnmName: 'English (Caribbean)'), (lnmID: 6153; lnmName: 'English (Ireland)'), (lnmID: 8201; lnmName: 'English (Jamaica)'), (lnmID: 5129; lnmName: 'English (New Zealand)'), (lnmID: 13321; lnmName: 'English (Philippines)'), (lnmID: 7177; lnmName: 'English (South Africa)'), (lnmID: 11273; lnmName: 'English (Trinidad)'), (lnmID: 2057; lnmName: 'English (United Kingdom)'), (lnmID: 1033; lnmName: 'English (United States)'), (lnmID: 12297; lnmName: 'English (Zimbabwe)'), (lnmID: 1061; lnmName: 'Estonian'), (lnmID: 1080; lnmName: 'Faroese'), (lnmID: 1065; lnmName: 'Farsi'), (lnmID: 1035; lnmName: 'Finnish'), (lnmID: 2060; lnmName: 'French (Belgium)'), (lnmID: 3084; lnmName: 'French (Canada)'), (lnmID: 1036; lnmName: 'French (France)'), (lnmID: 5132; lnmName: 'French (Luxembourg)'), (lnmID: 6156; lnmName: 'French (Monaco)'), (lnmID: 4108; lnmName: 'French (Switzerland)'), (lnmID: 1071; lnmName: 'FYRO Macedonian'), (lnmID: 1110; lnmName: 'Galician'), (lnmID: 66615; lnmName: 'Georgian Modern'), (lnmID: 1079; lnmName: 'Georgian Traditional'), (lnmID: 3079; lnmName: 'German (Austria)'), (lnmID: 1031; lnmName: 'German (Germany) Dictionary'), (lnmID: 66567; lnmName: 'German (Germany) Phone Book (DIN)'), (lnmID: 5127; lnmName: 'German (Liechtenstein)'), (lnmID: 4103; lnmName: 'German (Luxembourg)'), (lnmID: 2055; lnmName: 'German (Switzerland)'), (lnmID: 1032; lnmName: 'Greek'), (lnmID: 1095; lnmName: 'Gujarati'), (lnmID: 1037; lnmName: 'Hebrew'), (lnmID: 1081; lnmName: 'Hindi'), (lnmID: 1038; lnmName: 'Hungarian'), (lnmID: 66574; lnmName: 'Hungarian Technical'), (lnmID: 1039; lnmName: 'Icelandic'), (lnmID: 1057; lnmName: 'Indonesian'), (lnmID: 1040; lnmName: 'Italian (Italy)'), (lnmID: 2064; lnmName: 'Italian (Switzerland)'), (lnmID: 1041; lnmName: 'Japanese XJIS'), (lnmID: 1099; lnmName: 'Kannada'), (lnmID: 1087; lnmName: 'Kazakh'), (lnmID: 1111; lnmName: 'Konkani'), (lnmID: 1042; lnmName: 'Korean Dictionary'), (lnmID: 1088; lnmName: 'Kyrgyz (Cyrillic)'), (lnmID: 1062; lnmName: 'Latvian'), (lnmID: 1063; lnmName: 'Lithuanian'), (lnmID: 2110; lnmName: 'Malay (Brunei Darussalam)'), (lnmID: 1086; lnmName: 'Malay (Malaysia)'), (lnmID: 1102; lnmName: 'Marathi'), (lnmID: 1104; lnmName: 'Mongolian (Cyrillic)'), (lnmID: 1044; lnmName: 'Norwegian (Bokmal)'), (lnmID: 2068; lnmName: 'Norwegian (Nynorsk)'), (lnmID: 1045; lnmName: 'Polish'), (lnmID: 1046; lnmName: 'Portuguese (Brazil)'), (lnmID: 2070; lnmName: 'Portuguese (Portugal)'), (lnmID: 1094; lnmName: 'Punjabi'), (lnmID: 1048; lnmName: 'Romanian'), (lnmID: 1049; lnmName: 'Russian'), (lnmID: 1103; lnmName: 'Sanskrit'), (lnmID: 3098; lnmName: 'Serbian (Cyrillic)'), (lnmID: 2074; lnmName: 'Serbian (Latin)'), (lnmID: 1051; lnmName: 'Slovak'), (lnmID: 1060; lnmName: 'Slovenian'), (lnmID: 11274; lnmName: 'Spanish (Argentina)'), (lnmID: 16394; lnmName: 'Spanish (Bolivia)'), (lnmID: 13322; lnmName: 'Spanish (Chile)'), (lnmID: 9226; lnmName: 'Spanish (Colombia)'), (lnmID: 5130; lnmName: 'Spanish (Costa Rica)'), (lnmID: 7178; lnmName: 'Spanish (Dominican Republic)'), (lnmID: 12298; lnmName: 'Spanish (Ecuador)'), (lnmID: 17418; lnmName: 'Spanish (El Salvador)'), (lnmID: 4106; lnmName: 'Spanish (Guatemala)'), (lnmID: 18442; lnmName: 'Spanish (Honduras)'), (lnmID: 3082; lnmName: 'Spanish (International Sort) International'), (lnmID: 2058; lnmName: 'Spanish (Mexico)'), (lnmID: 19466; lnmName: 'Spanish (Nicaragua)'), (lnmID: 6154; lnmName: 'Spanish (Panama)'), (lnmID: 15370; lnmName: 'Spanish (Paraguay)'), (lnmID: 10250; lnmName: 'Spanish (Peru)'), (lnmID: 20490; lnmName: 'Spanish (Puerto Rico)'), (lnmID: 1034; lnmName: 'Spanish (Traditional Sort) Traditional'), (lnmID: 14346; lnmName: 'Spanish (Uruguay)'), (lnmID: 8202; lnmName: 'Spanish (Venezuela)'), (lnmID: 1089; lnmName: 'Swahili'), (lnmID: 1053; lnmName: 'Swedish'), (lnmID: 2077; lnmName: 'Swedish (Finland)'), (lnmID: 1114; lnmName: 'Syriac'), (lnmID: 1097; lnmName: 'Tamil'), (lnmID: 1092; lnmName: 'Tatar'), (lnmID: 1098; lnmName: 'Telugu'), (lnmID: 1054; lnmName: 'Thai'), (lnmID: 1055; lnmName: 'Turkish'), (lnmID: 1058; lnmName: 'Ukrainian'), (lnmID: 1056; lnmName: 'Urdu'), (lnmID: 2115; lnmName: 'Uzbek (Cyrillic)'), (lnmID: 1091; lnmName: 'Uzbek (Latin)'), (lnmID: 1066; lnmName: 'Vietnamese') );
File

nxllUtils

Description

This is constant nxllUtils.nxLocaleNameMappings.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.rsInvalidHexChar Constant

nxllUtils.rsInvalidHexChar Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
rsInvalidHexChar = 'Invalid character encountered - use only hexadecimal digits 0..9, A..F!';
File

nxllUtils

Description

This is constant nxllUtils.rsInvalidHexChar.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.rsOSError Constant

nxllUtils.rsOSError Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
rsOSError = 'Win32 Error in %s. Code: %d.'#10'%s';
File

nxllUtils

Description

This is constant nxllUtils.rsOSError.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.rsOSErrorSourceUnknown Constant

nxllUtils.rsOSErrorSourceUnknown Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
rsOSErrorSourceUnknown = '[unknown]';
File

nxllUtils

Description

This is constant nxllUtils.rsOSErrorSourceUnknown.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.rsUnkOSError Constant

nxllUtils.rsUnkOSError Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
rsUnkOSError = 'A Win32 API function failed in %s.';
File

nxllUtils

Description

This is constant nxllUtils.rsUnkOSError.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.SDDL_REVISION Constant

nxllUtils.SDDL_REVISION Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
SDDL_REVISION = SDDL_REVISION_1;
File

nxllUtils

Description

This is constant nxllUtils.SDDL_REVISION.

Group

Constants

Links
nxllUtils, Constants


nxllUtils.SDDL_REVISION_1 Constant

nxllUtils.SDDL_REVISION_1 Constant
nxllUtils Constants Send Feedback
Syntax
Delphi
SDDL_REVISION_1 = 1;
File

nxllUtils

Description

This is constant nxllUtils.SDDL_REVISION_1.

Group

Constants

Links
nxllUtils, Constants


nxllWideString Namespace

nxllWideString Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllWideString.

Constants
Name | Description
BOM_LSB_FIRST | byte order marks for Unicode files Unicode text files (in UTF-16 format) should contain $FFFE as first character to identify such a file clearly. Depending on the system where the file was created on this appears either in big endian or little endian style.
BOM_MSB_FIRST | This is constant nxllWideString.BOM_MSB_FIRST.
nxcClassAll | used to negate a set of categories
nxcClassEuropeanNumber | This is constant nxllWideString.nxcClassEuropeanNumber.
nxcClassLetter | some predefined sets to shorten parameter lists below and ease repeative usage
nxcClassMark | This is constant nxllWideString.nxcClassMark.
nxcClassNumber | This is constant nxllWideString.nxcClassNumber.
nxcClassPunctuation | This is constant nxllWideString.nxcClassPunctuation.
nxcClassSpace | This is constant nxllWideString.nxcClassSpace.
nxcClassSymbol | This is constant nxllWideString.nxcClassSymbol.
SurrogateHighEnd | This is constant nxllWideString.SurrogateHighEnd.
SurrogateHighStart | This is constant nxllWideString.SurrogateHighStart.
SurrogateLowEnd | This is constant nxllWideString.SurrogateLowEnd.
SurrogateLowStart | This is constant nxllWideString.SurrogateLowStart.
WideCarriageReturn | This is constant nxllWideString.WideCarriageReturn.
WideCR | This is constant nxllWideString.WideCR.
WideFormFeed | This is constant nxllWideString.WideFormFeed.
WideLF | This is constant nxllWideString.WideLF.
WideLineFeed | This is constant nxllWideString.WideLineFeed.
WideLineSeparator | This is constant nxllWideString.WideLineSeparator.
WideNull | This is constant nxllWideString.WideNull.
WideParagraphSeparator | This is constant nxllWideString.WideParagraphSeparator.
WideSpace | This is constant nxllWideString.WideSpace.
WideTabulator | This is constant nxllWideString.WideTabulator.
WideVerticalTab | This is constant nxllWideString.WideVerticalTab.
Functions
Name | Description
nxBytesToWideString | nxBytesToWideString
nxCodePageFromLocale | nxCodePageFromLocale
nxDelphiUnicodeStringToWideString | nxDelphiUnicodeStringToWideString
nxDelphiWideStringToBytes | nxDelphiWideStringToBytes
nxDelphiWideStringToString | nxDelphiWideStringToString
nxDelphiWideStringToWideString | nxDelphiWideStringToWideString
nxStringToDelphiWideString | nxStringToDelphiWideString
nxStringToWideString | nxStringToWideString
nxUnicodeStringToWideString | nxUnicodeStringToWideString
nxWideCat |
nxWideCat | nxWideCat
nxWideCat |
nxWideCat |
nxWideQuotedStr | nxWideQuotedStr
nxWideStringBufferToBytes | nxWideStringBufferToBytes
nxWideStringBufferToString | nxWideStringBufferToString
nxWideStringToBytes | nxWideStringToBytes
nxWideStringToDelphiUnicodeString | nxWideStringToDelphiUnicodeString
nxWideStringToDelphiWideString | nxWideStringToDelphiWideString
nxWideStringToString | nxWideStringToString
nxWStrEnd | nxWStrEnd
nxWStrScan | nxWStrScan
Structs, Records, Enums
Name | Description
TnxCharacterCategory | various predefined or otherwise useful character property categories
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxCharacterCategories | This is type nxllWideString.TnxCharacterCategories.
Variables
Name | Description
nxDelphiWideLCMapString | This is variable nxllWideString.nxDelphiWideLCMapString.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxllWideString Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxBytesToWideString | nxBytesToWideString
nxCodePageFromLocale | nxCodePageFromLocale
nxDelphiUnicodeStringToWideString | nxDelphiUnicodeStringToWideString
nxDelphiWideStringToBytes | nxDelphiWideStringToBytes
nxDelphiWideStringToString | nxDelphiWideStringToString
nxDelphiWideStringToWideString | nxDelphiWideStringToWideString
nxStringToDelphiWideString | nxStringToDelphiWideString
nxStringToWideString | nxStringToWideString
nxUnicodeStringToWideString | nxUnicodeStringToWideString
nxWideCat |
nxWideCat | nxWideCat
nxWideCat |
nxWideCat |
nxWideQuotedStr | nxWideQuotedStr
nxWideStringBufferToBytes | nxWideStringBufferToBytes
nxWideStringBufferToString | nxWideStringBufferToString
nxWideStringToBytes | nxWideStringToBytes
nxWideStringToDelphiUnicodeString | nxWideStringToDelphiUnicodeString
nxWideStringToDelphiWideString | nxWideStringToDelphiWideString
nxWideStringToString | nxWideStringToString
nxWStrEnd | nxWStrEnd
nxWStrScan | nxWStrScan
Namespace

nxllWideString Namespace

Links
Functions, nxllWideString Namespace, Legend


nxllWideString.nxBytesToWideString Function

nxllWideString.nxBytesToWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxBytesToWideString(const aBytes; aLength: Integer; aCodePage: Word): TnxWideString;
File

nxllWideString

Description

nxBytesToWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxCodePageFromLocale Function

nxllWideString.nxCodePageFromLocale Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxCodePageFromLocale(aLanguage: LCID): Integer;
File

nxllWideString

Description

nxCodePageFromLocale

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxDelphiUnicodeStringToWideString Function

nxllWideString.nxDelphiUnicodeStringToWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxDelphiUnicodeStringToWideString(const S: UnicodeString): TnxWideString;
File

nxllWideString

Description

nxDelphiUnicodeStringToWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxDelphiWideStringToBytes Function

nxllWideString.nxDelphiWideStringToBytes Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxDelphiWideStringToBytes(const aWideString: WideString; aCodePage: Word): TnxBytes;
File

nxllWideString

Description

nxDelphiWideStringToBytes

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxDelphiWideStringToString Function

nxllWideString.nxDelphiWideStringToString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxDelphiWideStringToString(const aWideString: WideString; aCodePage: Word): AnsiString;
File

nxllWideString

Description

nxDelphiWideStringToString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxDelphiWideStringToWideString Function

nxllWideString.nxDelphiWideStringToWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxDelphiWideStringToWideString(const S: WideString): TnxWideString;
File

nxllWideString

Description

nxDelphiWideStringToWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxStringToDelphiWideString Function

nxllWideString.nxStringToDelphiWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxStringToDelphiWideString(const aString: AnsiString; aCodePage: Word): WideString;
File

nxllWideString

Description

nxStringToDelphiWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxStringToWideString Function

nxllWideString.nxStringToWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxStringToWideString(const aString: AnsiString; aCodePage: Word): TnxWideString;
File

nxllWideString

Description

nxStringToWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxUnicodeStringToWideString Function

nxllWideString.nxUnicodeStringToWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxUnicodeStringToWideString(const aString: UnicodeString): TnxWideString;
File

nxllWideString

Description

nxUnicodeStringToWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideCat Function

nxllWideString.nxWideCat Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideCat(const Dest: TnxWideString; Source: AnsiChar): TnxWideString; overload;
File

nxllWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideCat Function

nxllWideString.nxWideCat Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideCat(const Dest: TnxWideString; const Source: TnxWideString): TnxWideString; overload;
File

nxllWideString

Description

nxWideCat

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideCat Function

nxllWideString.nxWideCat Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideCat(const Dest: TnxWideString; Source: WideChar): TnxWideString; overload;
File

nxllWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideCat Function

nxllWideString.nxWideCat Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideCat(Dest: WideChar; const Source: TnxWideString): TnxWideString; overload;
File

nxllWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideQuotedStr Function

nxllWideString.nxWideQuotedStr Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideQuotedStr(const S: WideString; Quote: WideChar): WideString;
File

nxllWideString

Description

nxWideQuotedStr

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringBufferToBytes Function

nxllWideString.nxWideStringBufferToBytes Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringBufferToBytes(const aWideString; aLength: Integer; aCodePage: Word): TnxDynByteArray;
File

nxllWideString

Description

nxWideStringBufferToBytes

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringBufferToString Function

nxllWideString.nxWideStringBufferToString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringBufferToString(const aWideString; aLength: Integer; aCodePage: Word): AnsiString;
File

nxllWideString

Description

nxWideStringBufferToString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringToBytes Function

nxllWideString.nxWideStringToBytes Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringToBytes(const aWideString: TnxWideString; aCodePage: Word): TnxDynByteArray;
File

nxllWideString

Description

nxWideStringToBytes

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringToDelphiUnicodeString Function

nxllWideString.nxWideStringToDelphiUnicodeString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringToDelphiUnicodeString(const S: TnxWideString): UnicodeString;
File

nxllWideString

Description

nxWideStringToDelphiUnicodeString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringToDelphiWideString Function

nxllWideString.nxWideStringToDelphiWideString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringToDelphiWideString(const S: TnxWideString): WideString;
File

nxllWideString

Description

nxWideStringToDelphiWideString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWideStringToString Function

nxllWideString.nxWideStringToString Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWideStringToString(const aWideString: TnxWideString; aCodePage: Word): AnsiString;
File

nxllWideString

Description

nxWideStringToString

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWStrEnd Function

nxllWideString.nxWStrEnd Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWStrEnd(const Str: PWideChar): PWideChar;
File

nxllWideString

Description

nxWStrEnd

Group

Functions

Links
nxllWideString, Functions


nxllWideString.nxWStrScan Function

nxllWideString.nxWStrScan Function
nxllWideString Functions Send Feedback
Syntax
Delphi
function nxWStrScan(Str: PWideChar; Chr: WideChar): PWideChar;
File

nxllWideString

Description

nxWStrScan

Group

Functions

Links
nxllWideString, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxllWideString Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxCharacterCategory | various predefined or otherwise useful character property categories
Namespace

nxllWideString Namespace

Links
Enumerations, nxllWideString Namespace, Legend


nxllWideString.TnxCharacterCategory Enumeration

nxllWideString.TnxCharacterCategory Enumeration
nxllWideString Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCharacterCategory = ( ccLetterUppercase, ccLetterLowercase, ccLetterTitlecase, ccMarkNonSpacing, ccMarkSpacingCombining, ccMarkEnclosing, ccNumberDecimalDigit, ccNumberLetter, ccNumberOther, ccSeparatorSpace, ccSeparatorLine, ccSeparatorParagraph, ccOtherControl, ccOtherFormat, ccOtherSurrogate, ccOtherPrivate, ccOtherUnassigned, ccLetterModifier, ccLetterOther, ccPunctuationConnector, ccPunctuationDash, ccPunctuationOpen, ccPunctuationClose, ccPunctuationInitialQuote, ccPunctuationFinalQuote, ccPunctuationOther, ccSymbolMath, ccSymbolCurrency, ccSymbolModifier, ccSymbolOther, ccLeftToRight, ccLeftToRightEmbedding, ccLeftToRightOverride, ccRightToLeft, ccRightToLeftArabic, ccRightToLeftEmbedding, ccRightToLeftoverride, ccPopDirectionalFormat, ccEuropeanNumber, ccEuropeanNumberSeparator, ccEuropeanNumberTerminator, ccArabicNumber, ccCommonNumberSeparator, ccBoundaryNeutral, ccSegmentSeparator, ccWhiteSpace, ccOtherNeutrals, ccComposed, ccNonBreaking, ccSymmetric, ccHexDigit, ccQuotationMark, ccMirroring, ccSpaceOther, ccAssigned );
File

nxllWideString

Members
Members | Description
ccLetterUppercase | normative categories
ccLetterModifier | informative categories
ccLeftToRight | bidirectional categories
ccSegmentSeparator | this includes tab and vertical tab
ccComposed | can be decomposed
ccSymmetric | has left and right forms
ccAssigned | means there is a definition in the Unicode standard
Description

various predefined or otherwise useful character property categories

Group

Structs, Records, Enums

Links
nxllWideString, Structs, Records, Enums


Types

Types
nxllWideString Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllWideString Namespace

Types
Name | Description
TnxCharacterCategories | This is type nxllWideString.TnxCharacterCategories.
Links
nxllWideString Namespace, Types


nxllWideString.TnxCharacterCategories Type

nxllWideString.TnxCharacterCategories Type
nxllWideString Types Send Feedback
Syntax
Delphi
TnxCharacterCategories = set of TnxCharacterCategory;
File

nxllWideString

Description

This is type nxllWideString.TnxCharacterCategories.

Group

Types

Links
nxllWideString, Types


Variables

Variables
nxllWideString Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllWideString Namespace

Variables
Name | Description
nxDelphiWideLCMapString | This is variable nxllWideString.nxDelphiWideLCMapString.
Links
nxllWideString Namespace, Variables


nxllWideString.nxDelphiWideLCMapString Variable

nxllWideString.nxDelphiWideLCMapString Variable
nxllWideString Variables Send Feedback
Syntax
Delphi
nxDelphiWideLCMapString: function(const aSource: WideString; aLocale: LCID; aFlags: Cardinal): WideString;
File

nxllWideString

Description

This is variable nxllWideString.nxDelphiWideLCMapString.

Group

Variables

Links
nxllWideString, Variables


Constants

Constants
Constants nxllWideString Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
BOM_LSB_FIRST | byte order marks for Unicode files Unicode text files (in UTF-16 format) should contain $FFFE as first character to identify such a file clearly. Depending on the system where the file was created on this appears either in big endian or little endian style.
BOM_MSB_FIRST | This is constant nxllWideString.BOM_MSB_FIRST.
nxcClassAll | used to negate a set of categories
nxcClassEuropeanNumber | This is constant nxllWideString.nxcClassEuropeanNumber.
nxcClassLetter | some predefined sets to shorten parameter lists below and ease repeative usage
nxcClassMark | This is constant nxllWideString.nxcClassMark.
nxcClassNumber | This is constant nxllWideString.nxcClassNumber.
nxcClassPunctuation | This is constant nxllWideString.nxcClassPunctuation.
nxcClassSpace | This is constant nxllWideString.nxcClassSpace.
nxcClassSymbol | This is constant nxllWideString.nxcClassSymbol.
SurrogateHighEnd | This is constant nxllWideString.SurrogateHighEnd.
SurrogateHighStart | This is constant nxllWideString.SurrogateHighStart.
SurrogateLowEnd | This is constant nxllWideString.SurrogateLowEnd.
SurrogateLowStart | This is constant nxllWideString.SurrogateLowStart.
WideCarriageReturn | This is constant nxllWideString.WideCarriageReturn.
WideCR | This is constant nxllWideString.WideCR.
WideFormFeed | This is constant nxllWideString.WideFormFeed.
WideLF | This is constant nxllWideString.WideLF.
WideLineFeed | This is constant nxllWideString.WideLineFeed.
WideLineSeparator | This is constant nxllWideString.WideLineSeparator.
WideNull | This is constant nxllWideString.WideNull.
WideParagraphSeparator | This is constant nxllWideString.WideParagraphSeparator.
WideSpace | This is constant nxllWideString.WideSpace.
WideTabulator | This is constant nxllWideString.WideTabulator.
WideVerticalTab | This is constant nxllWideString.WideVerticalTab.
Namespace

nxllWideString Namespace

Links
Constants, nxllWideString Namespace


nxllWideString.BOM_LSB_FIRST Constant

nxllWideString.BOM_LSB_FIRST Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
BOM_LSB_FIRST: WideChar = WideChar($FEFF);
File

nxllWideString

Description

byte order marks for Unicode files Unicode text files (in UTF-16 format) should contain $FFFE as first character to identify such a file clearly. Depending on the system where the file was created on this appears either in big endian or little endian style.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.BOM_MSB_FIRST Constant

nxllWideString.BOM_MSB_FIRST Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
BOM_MSB_FIRST: WideChar = WideChar($FFFE);
File

nxllWideString

Description

This is constant nxllWideString.BOM_MSB_FIRST.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassAll Constant

nxllWideString.nxcClassAll Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassAll = [Low(TnxCharacterCategory)..High(TnxCharacterCategory)];
File

nxllWideString

Description

used to negate a set of categories

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassEuropeanNumber Constant

nxllWideString.nxcClassEuropeanNumber Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassEuropeanNumber = [ ccEuropeanNumber, ccEuropeanNumberSeparator, ccEuropeanNumberTerminator ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassEuropeanNumber.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassLetter Constant

nxllWideString.nxcClassLetter Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassLetter = [ ccLetterUppercase, ccLetterLowercase, ccLetterTitlecase, ccLetterModifier, ccLetterOther ];
File

nxllWideString

Description

some predefined sets to shorten parameter lists below and ease repeative usage

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassMark Constant

nxllWideString.nxcClassMark Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassMark = [ ccMarkNonSpacing, ccMarkSpacingCombining, ccMarkEnclosing ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassMark.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassNumber Constant

nxllWideString.nxcClassNumber Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassNumber = [ ccNumberDecimalDigit, ccNumberLetter, ccNumberOther ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassNumber.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassPunctuation Constant

nxllWideString.nxcClassPunctuation Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassPunctuation = [ ccPunctuationConnector, ccPunctuationDash, ccPunctuationOpen, ccPunctuationClose, ccPunctuationOther, ccPunctuationInitialQuote, ccPunctuationFinalQuote ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassPunctuation.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassSpace Constant

nxllWideString.nxcClassSpace Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassSpace = [ ccSeparatorSpace, ccSpaceOther ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassSpace.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.nxcClassSymbol Constant

nxllWideString.nxcClassSymbol Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
nxcClassSymbol = [ ccSymbolMath, ccSymbolCurrency, ccSymbolModifier, ccSymbolOther ];
File

nxllWideString

Description

This is constant nxllWideString.nxcClassSymbol.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.SurrogateHighEnd Constant

nxllWideString.SurrogateHighEnd Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
SurrogateHighEnd = WideChar($DBFF);
File

nxllWideString

Description

This is constant nxllWideString.SurrogateHighEnd.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.SurrogateHighStart Constant

nxllWideString.SurrogateHighStart Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
SurrogateHighStart = WideChar($D800);
File

nxllWideString

Description

This is constant nxllWideString.SurrogateHighStart.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.SurrogateLowEnd Constant

nxllWideString.SurrogateLowEnd Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
SurrogateLowEnd = WideChar($DFFF);
File

nxllWideString

Description

This is constant nxllWideString.SurrogateLowEnd.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.SurrogateLowStart Constant

nxllWideString.SurrogateLowStart Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
SurrogateLowStart = WideChar($DC00);
File

nxllWideString

Description

This is constant nxllWideString.SurrogateLowStart.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideCarriageReturn Constant

nxllWideString.WideCarriageReturn Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideCarriageReturn = WideChar(#13);
File

nxllWideString

Description

This is constant nxllWideString.WideCarriageReturn.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideCR Constant

nxllWideString.WideCR Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideCR = WideChar(#13);
File

nxllWideString

Description

This is constant nxllWideString.WideCR.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideFormFeed Constant

nxllWideString.WideFormFeed Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideFormFeed = WideChar(#12);
File

nxllWideString

Description

This is constant nxllWideString.WideFormFeed.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideLF Constant

nxllWideString.WideLF Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideLF = WideChar(#10);
File

nxllWideString

Description

This is constant nxllWideString.WideLF.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideLineFeed Constant

nxllWideString.WideLineFeed Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideLineFeed = WideChar(#10);
File

nxllWideString

Description

This is constant nxllWideString.WideLineFeed.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideLineSeparator Constant

nxllWideString.WideLineSeparator Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideLineSeparator = WideChar($2028);
File

nxllWideString

Description

This is constant nxllWideString.WideLineSeparator.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideNull Constant

nxllWideString.WideNull Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideNull = WideChar(#0);
File

nxllWideString

Description

This is constant nxllWideString.WideNull.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideParagraphSeparator Constant

nxllWideString.WideParagraphSeparator Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideParagraphSeparator = WideChar($2029);
File

nxllWideString

Description

This is constant nxllWideString.WideParagraphSeparator.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideSpace Constant

nxllWideString.WideSpace Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideSpace = WideChar(#32);
File

nxllWideString

Description

This is constant nxllWideString.WideSpace.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideTabulator Constant

nxllWideString.WideTabulator Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideTabulator = WideChar(#9);
File

nxllWideString

Description

This is constant nxllWideString.WideTabulator.

Group

Constants

Links
nxllWideString, Constants


nxllWideString.WideVerticalTab Constant

nxllWideString.WideVerticalTab Constant
nxllWideString Constants Send Feedback
Syntax
Delphi
WideVerticalTab = WideChar(#11);
File

nxllWideString

Description

This is constant nxllWideString.WideVerticalTab.

Group

Constants

Links
nxllWideString, Constants


nxllWideStringCategories Namespace

nxllWideStringCategories Namespace
Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxllWideStringCategories.

Functions
Name | Description
_LoadCharacterCategories |
nxCategoryLookup |
nxCategoryLookup |
nxWideCharIsAlpha | Character test routines
nxWideCharIsAlphaNum |
nxWideCharIsBlank |
nxWideCharIsCased |
nxWideCharIsClosePunctuation |
nxWideCharIsComposed |
nxWideCharIsConnectionPunctuation |
nxWideCharIsControl |
nxWideCharIsCurrency |
nxWideCharIsDash |
nxWideCharIsDefined |
nxWideCharIsDigit |
nxWideCharIsEnclosing |
nxWideCharIsFinalPunctuation |
nxWideCharIsFormatControl |
nxWideCharIsGraph |
nxWideCharIsHan |
nxWideCharIsHangul |
nxWideCharIsHexDigit |
nxWideCharIsIdentifierPart |
nxWideCharIsIdentifierStart |
nxWideCharIsInitialPunctuation |
nxWideCharIsIsoControl |
nxWideCharIsLeftToRight |
nxWideCharIsLetterNumber |
nxWideCharIsLineSeparator |
nxWideCharIsLower |
nxWideCharIsMark | Other character test functions
nxWideCharIsMath |
nxWideCharIsMirroring |
nxWideCharIsModifier |
nxWideCharIsModifierSymbol |
nxWideCharIsNeutral |
nxWideCharIsNonBreaking |
nxWideCharIsNonSpacing |
nxWideCharIsNonSpacingMark |
nxWideCharIsNumber |
nxWideCharIsOpenPunctuation |
nxWideCharIsParagraphSeparator |
nxWideCharIsPrintable |
nxWideCharIsPrivate |
nxWideCharIsPunctuation |
nxWideCharIsQuotationMark |
nxWideCharIsRightToLeft | Directionality functions
nxWideCharIsSeparator |
nxWideCharIsSpace |
nxWideCharIsSpacingMark |
nxWideCharIsStrong |
nxWideCharIsSurrogate |
nxWideCharIsSymbol |
nxWideCharIsSymmetric |
nxWideCharIsTitle |
nxWideCharIsUndefined |
nxWideCharIsUpper |
nxWideCharIsWeak |
nxWideCharIsWhiteSpace |
Structs, Records, Enums
Name | Description
TnxRange | This is record nxllWideStringCategories.TnxRange.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxCategoriesArray | This is type nxllWideStringCategories.TnxCategoriesArray.
TnxRangeArray | This is type nxllWideStringCategories.TnxRangeArray.
Variables
Name | Description
_Categories | This is variable nxllWideStringCategories._Categories.
_Loaded | This is variable nxllWideStringCategories._Loaded.
_Loading | This is variable nxllWideStringCategories._Loading.
_Ranges | This is variable nxllWideStringCategories._Ranges.
Links
Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxllWideStringCategories Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
_LoadCharacterCategories |
nxCategoryLookup |
nxCategoryLookup |
nxWideCharIsAlpha | Character test routines
nxWideCharIsAlphaNum |
nxWideCharIsBlank |
nxWideCharIsCased |
nxWideCharIsClosePunctuation |
nxWideCharIsComposed |
nxWideCharIsConnectionPunctuation |
nxWideCharIsControl |
nxWideCharIsCurrency |
nxWideCharIsDash |
nxWideCharIsDefined |
nxWideCharIsDigit |
nxWideCharIsEnclosing |
nxWideCharIsFinalPunctuation |
nxWideCharIsFormatControl |
nxWideCharIsGraph |
nxWideCharIsHan |
nxWideCharIsHangul |
nxWideCharIsHexDigit |
nxWideCharIsIdentifierPart |
nxWideCharIsIdentifierStart |
nxWideCharIsInitialPunctuation |
nxWideCharIsIsoControl |
nxWideCharIsLeftToRight |
nxWideCharIsLetterNumber |
nxWideCharIsLineSeparator |
nxWideCharIsLower |
nxWideCharIsMark | Other character test functions
nxWideCharIsMath |
nxWideCharIsMirroring |
nxWideCharIsModifier |
nxWideCharIsModifierSymbol |
nxWideCharIsNeutral |
nxWideCharIsNonBreaking |
nxWideCharIsNonSpacing |
nxWideCharIsNonSpacingMark |
nxWideCharIsNumber |
nxWideCharIsOpenPunctuation |
nxWideCharIsParagraphSeparator |
nxWideCharIsPrintable |
nxWideCharIsPrivate |
nxWideCharIsPunctuation |
nxWideCharIsQuotationMark |
nxWideCharIsRightToLeft | Directionality functions
nxWideCharIsSeparator |
nxWideCharIsSpace |
nxWideCharIsSpacingMark |
nxWideCharIsStrong |
nxWideCharIsSurrogate |
nxWideCharIsSymbol |
nxWideCharIsSymmetric |
nxWideCharIsTitle |
nxWideCharIsUndefined |
nxWideCharIsUpper |
nxWideCharIsWeak |
nxWideCharIsWhiteSpace |
Namespace

nxllWideStringCategories Namespace

Links
Functions, nxllWideStringCategories Namespace, Legend


nxllWideStringCategories._LoadCharacterCategories Function

nxllWideStringCategories._LoadCharacterCategories Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
procedure _LoadCharacterCategories;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxCategoryLookup Function

nxllWideStringCategories.nxCategoryLookup Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxCategoryLookup(aWideChar: TnxWideChar; const aCats: TnxCharacterCategories): Boolean; overload;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxCategoryLookup Function

nxllWideStringCategories.nxCategoryLookup Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxCategoryLookup(aWideChar: TnxWideChar; aCat: TnxCharacterCategory): Boolean; overload;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsAlpha Function

nxllWideStringCategories.nxWideCharIsAlpha Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsAlpha(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Description

Character test routines

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsAlphaNum Function

nxllWideStringCategories.nxWideCharIsAlphaNum Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsAlphaNum(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsBlank Function

nxllWideStringCategories.nxWideCharIsBlank Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsBlank(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsCased Function

nxllWideStringCategories.nxWideCharIsCased Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsCased(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsClosePunctuation Function

nxllWideStringCategories.nxWideCharIsClosePunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsClosePunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsComposed Function

nxllWideStringCategories.nxWideCharIsComposed Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsComposed(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsConnectionPunctuation Function

nxllWideStringCategories.nxWideCharIsConnectionPunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsConnectionPunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsControl Function

nxllWideStringCategories.nxWideCharIsControl Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsControl(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsCurrency Function

nxllWideStringCategories.nxWideCharIsCurrency Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsCurrency(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsDash Function

nxllWideStringCategories.nxWideCharIsDash Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsDash(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsDefined Function

nxllWideStringCategories.nxWideCharIsDefined Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsDefined(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsDigit Function

nxllWideStringCategories.nxWideCharIsDigit Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsDigit(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsEnclosing Function

nxllWideStringCategories.nxWideCharIsEnclosing Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsEnclosing(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsFinalPunctuation Function

nxllWideStringCategories.nxWideCharIsFinalPunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsFinalPunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsFormatControl Function

nxllWideStringCategories.nxWideCharIsFormatControl Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsFormatControl(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsGraph Function

nxllWideStringCategories.nxWideCharIsGraph Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsGraph(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsHan Function

nxllWideStringCategories.nxWideCharIsHan Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsHan(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsHangul Function

nxllWideStringCategories.nxWideCharIsHangul Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsHangul(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsHexDigit Function

nxllWideStringCategories.nxWideCharIsHexDigit Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsHexDigit(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsIdentifierPart Function

nxllWideStringCategories.nxWideCharIsIdentifierPart Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsIdentifierPart(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsIdentifierStart Function

nxllWideStringCategories.nxWideCharIsIdentifierStart Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsIdentifierStart(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsInitialPunctuation Function

nxllWideStringCategories.nxWideCharIsInitialPunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsInitialPunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsIsoControl Function

nxllWideStringCategories.nxWideCharIsIsoControl Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsIsoControl(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsLeftToRight Function

nxllWideStringCategories.nxWideCharIsLeftToRight Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsLeftToRight(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsLetterNumber Function

nxllWideStringCategories.nxWideCharIsLetterNumber Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsLetterNumber(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsLineSeparator Function

nxllWideStringCategories.nxWideCharIsLineSeparator Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsLineSeparator(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsLower Function

nxllWideStringCategories.nxWideCharIsLower Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsLower(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsMark Function

nxllWideStringCategories.nxWideCharIsMark Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsMark(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Description

Other character test functions

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsMath Function

nxllWideStringCategories.nxWideCharIsMath Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsMath(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsMirroring Function

nxllWideStringCategories.nxWideCharIsMirroring Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsMirroring(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsModifier Function

nxllWideStringCategories.nxWideCharIsModifier Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsModifier(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsModifierSymbol Function

nxllWideStringCategories.nxWideCharIsModifierSymbol Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsModifierSymbol(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsNeutral Function

nxllWideStringCategories.nxWideCharIsNeutral Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsNeutral(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsNonBreaking Function

nxllWideStringCategories.nxWideCharIsNonBreaking Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsNonBreaking(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsNonSpacing Function

nxllWideStringCategories.nxWideCharIsNonSpacing Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsNonSpacing(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsNonSpacingMark Function

nxllWideStringCategories.nxWideCharIsNonSpacingMark Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsNonSpacingMark(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsNumber Function

nxllWideStringCategories.nxWideCharIsNumber Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsNumber(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsOpenPunctuation Function

nxllWideStringCategories.nxWideCharIsOpenPunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsOpenPunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsParagraphSeparator Function

nxllWideStringCategories.nxWideCharIsParagraphSeparator Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsParagraphSeparator(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsPrintable Function

nxllWideStringCategories.nxWideCharIsPrintable Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsPrintable(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsPrivate Function

nxllWideStringCategories.nxWideCharIsPrivate Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsPrivate(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsPunctuation Function

nxllWideStringCategories.nxWideCharIsPunctuation Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsPunctuation(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsQuotationMark Function

nxllWideStringCategories.nxWideCharIsQuotationMark Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsQuotationMark(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsRightToLeft Function

nxllWideStringCategories.nxWideCharIsRightToLeft Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsRightToLeft(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Description

Directionality functions

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSeparator Function

nxllWideStringCategories.nxWideCharIsSeparator Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSeparator(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSpace Function

nxllWideStringCategories.nxWideCharIsSpace Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSpace(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSpacingMark Function

nxllWideStringCategories.nxWideCharIsSpacingMark Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSpacingMark(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsStrong Function

nxllWideStringCategories.nxWideCharIsStrong Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsStrong(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSurrogate Function

nxllWideStringCategories.nxWideCharIsSurrogate Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSurrogate(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSymbol Function

nxllWideStringCategories.nxWideCharIsSymbol Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSymbol(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsSymmetric Function

nxllWideStringCategories.nxWideCharIsSymmetric Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsSymmetric(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsTitle Function

nxllWideStringCategories.nxWideCharIsTitle Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsTitle(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsUndefined Function

nxllWideStringCategories.nxWideCharIsUndefined Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsUndefined(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsUpper Function

nxllWideStringCategories.nxWideCharIsUpper Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsUpper(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsWeak Function

nxllWideStringCategories.nxWideCharIsWeak Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsWeak(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


nxllWideStringCategories.nxWideCharIsWhiteSpace Function

nxllWideStringCategories.nxWideCharIsWhiteSpace Function
nxllWideStringCategories Functions Send Feedback
Syntax
Delphi
function nxWideCharIsWhiteSpace(aWideChar: TnxWideChar): Boolean;
File

nxllWideStringCategories

Group

Functions

Links
nxllWideStringCategories, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllWideStringCategories Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllWideStringCategories Namespace

Records
Name | Description
TnxRange | This is record nxllWideStringCategories.TnxRange.
Links
nxllWideStringCategories Namespace, Legend, Records


nxllWideStringCategories.TnxRange Record

nxllWideStringCategories.TnxRange Record
nxllWideStringCategories Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRange = record
  rngStart: Cardinal;
  rngStop: Cardinal;
end;
File

nxllWideStringCategories

Description

This is record nxllWideStringCategories.TnxRange.

Group

Structs, Records, Enums

Links
nxllWideStringCategories, Structs, Records, Enums


Types

Types
nxllWideStringCategories Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllWideStringCategories Namespace

Types
Name | Description
TnxCategoriesArray | This is type nxllWideStringCategories.TnxCategoriesArray.
TnxRangeArray | This is type nxllWideStringCategories.TnxRangeArray.
Links
nxllWideStringCategories Namespace, Types


nxllWideStringCategories.TnxCategoriesArray Type

nxllWideStringCategories.TnxCategoriesArray Type
nxllWideStringCategories Types Send Feedback
Syntax
Delphi
TnxCategoriesArray = array of TnxCharacterCategories;
File

nxllWideStringCategories

Description

This is type nxllWideStringCategories.TnxCategoriesArray.

Group

Types

Links
nxllWideStringCategories, Types


nxllWideStringCategories.TnxRangeArray Type

nxllWideStringCategories.TnxRangeArray Type
nxllWideStringCategories Types Send Feedback
Syntax
Delphi
TnxRangeArray = array of TnxRange;
File

nxllWideStringCategories

Description

This is type nxllWideStringCategories.TnxRangeArray.

Group

Types

Links
nxllWideStringCategories, Types


Variables

Variables
nxllWideStringCategories Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxllWideStringCategories Namespace

Variables
Name | Description
_Categories | This is variable nxllWideStringCategories._Categories.
_Loaded | This is variable nxllWideStringCategories._Loaded.
_Loading | This is variable nxllWideStringCategories._Loading.
_Ranges | This is variable nxllWideStringCategories._Ranges.
Links
nxllWideStringCategories Namespace, Variables


nxllWideStringCategories._Categories Variable

nxllWideStringCategories._Categories Variable
nxllWideStringCategories Variables Send Feedback
Syntax
Delphi
_Categories: array[Byte] of TnxCategoriesArray;
File

nxllWideStringCategories

Description

This is variable nxllWideStringCategories._Categories.

Group

Variables

Links
nxllWideStringCategories, Variables


nxllWideStringCategories._Loaded Variable

nxllWideStringCategories._Loaded Variable
nxllWideStringCategories Variables Send Feedback
Syntax
Delphi
_Loaded: Boolean;
File

nxllWideStringCategories

Description

This is variable nxllWideStringCategories._Loaded.

Group

Variables

Links
nxllWideStringCategories, Variables


nxllWideStringCategories._Loading Variable

nxllWideStringCategories._Loading Variable
nxllWideStringCategories Variables Send Feedback
Syntax
Delphi
_Loading: TnxPadlock;
File

nxllWideStringCategories

Description

This is variable nxllWideStringCategories._Loading.

Group

Variables

Links
nxllWideStringCategories, Variables


nxllWideStringCategories._Ranges Variable

nxllWideStringCategories._Ranges Variable
nxllWideStringCategories Variables Send Feedback
Syntax
Delphi
_Ranges: array[TnxCharacterCategory] of TnxRangeArray;
File

nxllWideStringCategories

Description

This is variable nxllWideStringCategories._Ranges.

Group

Variables

Links
nxllWideStringCategories, Variables


nxllWideStringList Namespace

nxllWideStringList Namespace
Classes Constants Interfaces Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxllWideStringList.

Classes
Name | Description
EnxWideStringLocaleMappingTransformerException | This is class nxllWideStringList.EnxWideStringLocaleMappingTransformerException.
TnxBaseWideStringCompareStringComparer | This is class nxllWideStringList.TnxBaseWideStringCompareStringComparer.
TnxWideStringAnsiRoundtripTransformer | This is class nxllWideStringList.TnxWideStringAnsiRoundtripTransformer.
TnxWideStringByteComparer | This is class nxllWideStringList.TnxWideStringByteComparer.
TnxWideStringCompareStringAComparer | This is class nxllWideStringList.TnxWideStringCompareStringAComparer.
TnxWideStringCompareStringWComparer | This is class nxllWideStringList.TnxWideStringCompareStringWComparer.
TnxWideStringDecomposeTransformer | This is class nxllWideStringList.TnxWideStringDecomposeTransformer.
TnxWideStringFoldStringTransformer | This is class nxllWideStringList.TnxWideStringFoldStringTransformer.
TnxWideStringList | This is class nxllWideStringList.TnxWideStringList.
TnxWideStringLocaleMappingTransformer | This is class nxllWideStringList.TnxWideStringLocaleMappingTransformer.
TnxWideStringLowerCaseTransformer | This is class nxllWideStringList.TnxWideStringLowerCaseTransformer.
TnxWideStringNullTransformer | This is class nxllWideStringList.TnxWideStringNullTransformer.
TnxWideStringPreComposeTransformer | This is class nxllWideStringList.TnxWideStringPreComposeTransformer.
TnxWideStrings | This is class nxllWideStringList.TnxWideStrings.
TnxWideStringTransformerHub | This is class nxllWideStringList.TnxWideStringTransformerHub.
TnxWideStringTruncateTransformer | This is class nxllWideStringList.TnxWideStringTruncateTransformer.
TnxWideStringUpperCaseTransformer | This is class nxllWideStringList.TnxWideStringUpperCaseTransformer.
Constants
Name | Description
rsLCMAPSORTKEYIsNotSupported | This is constant nxllWideStringList.rsLCMAPSORTKEYIsNotSupported.
Interfaces
Name | Description
InxWideStringComparer | This is class nxllWideStringList.InxWideStringComparer.
InxWideStringTransformer | This is class nxllWideStringList.InxWideStringTransformer.
Structs, Records, Enums
Name | Description
TnxWideStringItem | This is record nxllWideStringList.TnxWideStringItem.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxWideStringItemList | This is type nxllWideStringList.TnxWideStringItemList.
TnxWideStringTransformers | This is type nxllWideStringList.TnxWideStringTransformers.
Links
Classes, Constants, Interfaces, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxllWideStringList Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxWideStringLocaleMappingTransformerException | This is class nxllWideStringList.EnxWideStringLocaleMappingTransformerException.
TnxBaseWideStringCompareStringComparer | This is class nxllWideStringList.TnxBaseWideStringCompareStringComparer.
TnxWideStringAnsiRoundtripTransformer | This is class nxllWideStringList.TnxWideStringAnsiRoundtripTransformer.
TnxWideStringByteComparer | This is class nxllWideStringList.TnxWideStringByteComparer.
TnxWideStringCompareStringAComparer | This is class nxllWideStringList.TnxWideStringCompareStringAComparer.
TnxWideStringCompareStringWComparer | This is class nxllWideStringList.TnxWideStringCompareStringWComparer.
TnxWideStringDecomposeTransformer | This is class nxllWideStringList.TnxWideStringDecomposeTransformer.
TnxWideStringFoldStringTransformer | This is class nxllWideStringList.TnxWideStringFoldStringTransformer.
TnxWideStringList | This is class nxllWideStringList.TnxWideStringList.
TnxWideStringLocaleMappingTransformer | This is class nxllWideStringList.TnxWideStringLocaleMappingTransformer.
TnxWideStringLowerCaseTransformer | This is class nxllWideStringList.TnxWideStringLowerCaseTransformer.
TnxWideStringNullTransformer | This is class nxllWideStringList.TnxWideStringNullTransformer.
TnxWideStringPreComposeTransformer | This is class nxllWideStringList.TnxWideStringPreComposeTransformer.
TnxWideStrings | This is class nxllWideStringList.TnxWideStrings.
TnxWideStringTransformerHub | This is class nxllWideStringList.TnxWideStringTransformerHub.
TnxWideStringTruncateTransformer | This is class nxllWideStringList.TnxWideStringTruncateTransformer.
TnxWideStringUpperCaseTransformer | This is class nxllWideStringList.TnxWideStringUpperCaseTransformer.
Namespace

nxllWideStringList Namespace

Links
Classes, nxllWideStringList Namespace, Legend


EnxWideStringLocaleMappingTransformerException Class

EnxWideStringLocaleMappingTransformerException Class
nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_EnxWideStringLocaleMappingTransformerExceptionnxllWideStringList_EnxWideStringLocaleMappingTransformerExceptionnxllWideStringList_EnxWideStringLocaleMappingTransformerExceptionnxllWideStringList_EnxWideStringLocaleMappingTransformerException
Syntax
Delphi
EnxWideStringLocaleMappingTransformerException = class(EnxBaseException);
File

nxllWideStringList

Description

This is class nxllWideStringList.EnxWideStringLocaleMappingTransformerException.

Group

Classes

Links
nxllWideStringList, Classes


TnxBaseWideStringCompareStringComparer Class

TnxBaseWideStringCompareStringComparer Class
TnxBaseWideStringCompareStringComparer Fields TnxBaseWideStringCompareStringComparer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxBaseWideStringCompareStringComparernxllWideStringList_TnxBaseWideStringCompareStringComparernxllWideStringList_TnxBaseWideStringCompareStringComparer
Syntax
Delphi
TnxBaseWideStringCompareStringComparer = class(TnxInterfacedObject);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxBaseWideStringCompareStringComparer.

Group

Classes

Links
TnxBaseWideStringCompareStringComparer Fields, TnxBaseWideStringCompareStringComparer Members, nxllWideStringList, Classes


TnxBaseWideStringCompareStringComparer Members

TnxBaseWideStringCompareStringComparer Members
TnxBaseWideStringCompareStringComparer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseWideStringCompareStringComparer.

Class

TnxBaseWideStringCompareStringComparer Class

Protected Fields
Name | Description
bwscscFlags | This is bwscscFlags, a member of class TnxBaseWideStringCompareStringComparer.
bwscscLocale | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxBaseWideStringCompareStringComparer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxBaseWideStringCompareStringComparer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseWideStringCompareStringComparer.Create Constructor

TnxBaseWideStringCompareStringComparer.Create Constructor
TnxBaseWideStringCompareStringComparer Class TnxBaseWideStringCompareStringComparer Members nxllWideStringList Namespace TnxBaseWideStringCompareStringComparer Class Send Feedback
Syntax
Delphi
constructor Create(aLocale: Cardinal; aFlags: Cardinal); virtual;
Description

TnxBaseWideStringCompareStringComparer

Class

TnxBaseWideStringCompareStringComparer Class

Links
TnxBaseWideStringCompareStringComparer Class, TnxBaseWideStringCompareStringComparer Members, nxllWideStringList Namespace, TnxBaseWideStringCompareStringComparer Class


TnxBaseWideStringCompareStringComparer Fields

TnxBaseWideStringCompareStringComparer Fields
TnxBaseWideStringCompareStringComparer Class Legend Protected Fields Send Feedback

The fields of the TnxBaseWideStringCompareStringComparer class are listed here.

Class

TnxBaseWideStringCompareStringComparer Class

Protected Fields
Name | Description
bwscscFlags | This is bwscscFlags, a member of class TnxBaseWideStringCompareStringComparer.
bwscscLocale | private
Links
TnxBaseWideStringCompareStringComparer Class, Legend, Protected Fields


TnxBaseWideStringCompareStringComparer.bwscscFlags Field

TnxBaseWideStringCompareStringComparer.bwscscFlags Field
TnxBaseWideStringCompareStringComparer Class TnxBaseWideStringCompareStringComparer Members nxllWideStringList Namespace TnxBaseWideStringCompareStringComparer Fields Send Feedback
Syntax
Delphi
bwscscFlags: Cardinal;
Description

This is bwscscFlags, a member of class TnxBaseWideStringCompareStringComparer.

Group

TnxBaseWideStringCompareStringComparer Fields

Links
TnxBaseWideStringCompareStringComparer Class, TnxBaseWideStringCompareStringComparer Members, nxllWideStringList Namespace, TnxBaseWideStringCompareStringComparer Fields


TnxBaseWideStringCompareStringComparer.bwscscLocale Field

TnxBaseWideStringCompareStringComparer.bwscscLocale Field
TnxBaseWideStringCompareStringComparer Class TnxBaseWideStringCompareStringComparer Members nxllWideStringList Namespace TnxBaseWideStringCompareStringComparer Fields Send Feedback
Syntax
Delphi
bwscscLocale: Cardinal;
Description

private

Group

TnxBaseWideStringCompareStringComparer Fields

Links
TnxBaseWideStringCompareStringComparer Class, TnxBaseWideStringCompareStringComparer Members, nxllWideStringList Namespace, TnxBaseWideStringCompareStringComparer Fields


TnxWideStringAnsiRoundtripTransformer Class

TnxWideStringAnsiRoundtripTransformer Class
TnxWideStringAnsiRoundtripTransformer Fields TnxWideStringAnsiRoundtripTransformer Methods TnxWideStringAnsiRoundtripTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringAnsiRoundtripTransformernxllWideStringList_TnxWideStringAnsiRoundtripTransformernxllWideStringList_TnxWideStringAnsiRoundtripTransformernxllWideStringList_TnxWideStringAnsiRoundtripTransformer
Syntax
Delphi
TnxWideStringAnsiRoundtripTransformer = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringAnsiRoundtripTransformer.

Group

Classes

Links
TnxWideStringAnsiRoundtripTransformer Fields, TnxWideStringAnsiRoundtripTransformer Methods, TnxWideStringAnsiRoundtripTransformer Members, nxllWideStringList, Classes


TnxWideStringAnsiRoundtripTransformer Members

TnxWideStringAnsiRoundtripTransformer Members
TnxWideStringAnsiRoundtripTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringAnsiRoundtripTransformer.

Class

TnxWideStringAnsiRoundtripTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsartCodepage | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringAnsiRoundtripTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringAnsiRoundtripTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringAnsiRoundtripTransformer.Create Constructor

TnxWideStringAnsiRoundtripTransformer.Create Constructor
TnxWideStringAnsiRoundtripTransformer Class TnxWideStringAnsiRoundtripTransformer Members nxllWideStringList Namespace TnxWideStringAnsiRoundtripTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aCodepage: Word = High(Word));
Description

TnxWideStringAnsiRoundtripTransformer

Class

TnxWideStringAnsiRoundtripTransformer Class

Links
TnxWideStringAnsiRoundtripTransformer Class, TnxWideStringAnsiRoundtripTransformer Members, nxllWideStringList Namespace, TnxWideStringAnsiRoundtripTransformer Class


TnxWideStringAnsiRoundtripTransformer Fields

TnxWideStringAnsiRoundtripTransformer Fields
TnxWideStringAnsiRoundtripTransformer Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringAnsiRoundtripTransformer class are listed here.

Class

TnxWideStringAnsiRoundtripTransformer Class

Protected Fields
Name | Description
wsartCodepage | private
Links
TnxWideStringAnsiRoundtripTransformer Class, Legend, Protected Fields


TnxWideStringAnsiRoundtripTransformer.wsartCodepage Field

TnxWideStringAnsiRoundtripTransformer.wsartCodepage Field
TnxWideStringAnsiRoundtripTransformer Class TnxWideStringAnsiRoundtripTransformer Members nxllWideStringList Namespace TnxWideStringAnsiRoundtripTransformer Fields Send Feedback
Syntax
Delphi
wsartCodepage: Cardinal;
Description

private

Group

TnxWideStringAnsiRoundtripTransformer Fields

Links
TnxWideStringAnsiRoundtripTransformer Class, TnxWideStringAnsiRoundtripTransformer Members, nxllWideStringList Namespace, TnxWideStringAnsiRoundtripTransformer Fields


TnxWideStringAnsiRoundtripTransformer Methods

TnxWideStringAnsiRoundtripTransformer Methods
TnxWideStringAnsiRoundtripTransformer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringAnsiRoundtripTransformer class are listed here.

Class

TnxWideStringAnsiRoundtripTransformer Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer
Links
TnxWideStringAnsiRoundtripTransformer Class, Legend, Protected Methods


TnxWideStringAnsiRoundtripTransformer.Transform Method

TnxWideStringAnsiRoundtripTransformer.Transform Method
TnxWideStringAnsiRoundtripTransformer Class TnxWideStringAnsiRoundtripTransformer Members nxllWideStringList Namespace TnxWideStringAnsiRoundtripTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

Group

TnxWideStringAnsiRoundtripTransformer Methods

Links
TnxWideStringAnsiRoundtripTransformer Class, TnxWideStringAnsiRoundtripTransformer Members, nxllWideStringList Namespace, TnxWideStringAnsiRoundtripTransformer Methods


TnxWideStringByteComparer Class

TnxWideStringByteComparer Class
TnxWideStringByteComparer Methods TnxWideStringByteComparer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringByteComparernxllWideStringList_TnxWideStringByteComparernxllWideStringList_TnxWideStringByteComparernxllWideStringList_TnxWideStringByteComparer
Syntax
Delphi
TnxWideStringByteComparer = class(TnxInterfacedObject, InxWideStringComparer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringByteComparer.

Group

Classes

Links
TnxWideStringByteComparer Methods, TnxWideStringByteComparer Members, nxllWideStringList, Classes


TnxWideStringByteComparer Members

TnxWideStringByteComparer Members
TnxWideStringByteComparer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringByteComparer.

Class

TnxWideStringByteComparer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Compare | InxWideStringComparer TnxWideStringByteComparer
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringByteComparer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringByteComparer Methods

TnxWideStringByteComparer Methods
TnxWideStringByteComparer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringByteComparer class are listed here.

Class

TnxWideStringByteComparer Class

Protected Methods
Name | Description
Compare | InxWideStringComparer TnxWideStringByteComparer
Links
TnxWideStringByteComparer Class, Legend, Protected Methods


TnxWideStringByteComparer.Compare Method

TnxWideStringByteComparer.Compare Method
TnxWideStringByteComparer Class TnxWideStringByteComparer Members nxllWideStringList Namespace TnxWideStringByteComparer Methods Send Feedback
Syntax
Delphi
function Compare(const a: TnxWideString; const b: TnxWideString): TnxValueRelationship;
Description

InxWideStringComparer

TnxWideStringByteComparer

Group

TnxWideStringByteComparer Methods

Links
TnxWideStringByteComparer Class, TnxWideStringByteComparer Members, nxllWideStringList Namespace, TnxWideStringByteComparer Methods


TnxWideStringCompareStringAComparer Class

TnxWideStringCompareStringAComparer Class
TnxWideStringCompareStringAComparer Fields TnxWideStringCompareStringAComparer Methods TnxWideStringCompareStringAComparer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringCompareStringAComparernxllWideStringList_TnxWideStringCompareStringAComparernxllWideStringList_TnxWideStringCompareStringAComparernxllWideStringList_TnxWideStringCompareStringAComparernxllWideStringList_TnxWideStringCompareStringAComparer
Syntax
Delphi
TnxWideStringCompareStringAComparer = class(TnxBaseWideStringCompareStringComparer, InxWideStringComparer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringCompareStringAComparer.

Group

Classes

Links
TnxWideStringCompareStringAComparer Fields, TnxWideStringCompareStringAComparer Methods, TnxWideStringCompareStringAComparer Members, nxllWideStringList, Classes


TnxWideStringCompareStringAComparer Members

TnxWideStringCompareStringAComparer Members
TnxWideStringCompareStringAComparer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringCompareStringAComparer.

Class

TnxWideStringCompareStringAComparer Class

Protected Fields
Name | Description
bwscscFlags | This is bwscscFlags, a member of class TnxBaseWideStringCompareStringComparer.
bwscscLocale | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wscsacCodepage | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Compare | InxWideStringComparer TnxWideStringCompareStringAComparer
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringCompareStringAComparer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringCompareStringAComparer.Create Constructor

TnxWideStringCompareStringAComparer.Create Constructor
TnxWideStringCompareStringAComparer Class TnxWideStringCompareStringAComparer Members nxllWideStringList Namespace TnxWideStringCompareStringAComparer Class Send Feedback
Syntax
Delphi
constructor Create(aLocale: Cardinal; aFlags: Cardinal); override;
Class

TnxWideStringCompareStringAComparer Class

Links
TnxWideStringCompareStringAComparer Class, TnxWideStringCompareStringAComparer Members, nxllWideStringList Namespace, TnxWideStringCompareStringAComparer Class


TnxWideStringCompareStringAComparer Fields

TnxWideStringCompareStringAComparer Fields
TnxWideStringCompareStringAComparer Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringCompareStringAComparer class are listed here.

Class

TnxWideStringCompareStringAComparer Class

Protected Fields
Name | Description
wscsacCodepage | private
Links
TnxWideStringCompareStringAComparer Class, Legend, Protected Fields


TnxWideStringCompareStringAComparer.wscsacCodepage Field

TnxWideStringCompareStringAComparer.wscsacCodepage Field
TnxWideStringCompareStringAComparer Class TnxWideStringCompareStringAComparer Members nxllWideStringList Namespace TnxWideStringCompareStringAComparer Fields Send Feedback
Syntax
Delphi
wscsacCodepage: Word;
Description

private

Group

TnxWideStringCompareStringAComparer Fields

Links
TnxWideStringCompareStringAComparer Class, TnxWideStringCompareStringAComparer Members, nxllWideStringList Namespace, TnxWideStringCompareStringAComparer Fields


TnxWideStringCompareStringAComparer Methods

TnxWideStringCompareStringAComparer Methods
TnxWideStringCompareStringAComparer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringCompareStringAComparer class are listed here.

Class

TnxWideStringCompareStringAComparer Class

Protected Methods
Name | Description
Compare | InxWideStringComparer TnxWideStringCompareStringAComparer
Links
TnxWideStringCompareStringAComparer Class, Legend, Protected Methods


TnxWideStringCompareStringAComparer.Compare Method

TnxWideStringCompareStringAComparer.Compare Method
TnxWideStringCompareStringAComparer Class TnxWideStringCompareStringAComparer Members nxllWideStringList Namespace TnxWideStringCompareStringAComparer Methods Send Feedback
Syntax
Delphi
function Compare(const a: TnxWideString; const b: TnxWideString): TnxValueRelationship;
Description

InxWideStringComparer

TnxWideStringCompareStringAComparer

Group

TnxWideStringCompareStringAComparer Methods

Links
TnxWideStringCompareStringAComparer Class, TnxWideStringCompareStringAComparer Members, nxllWideStringList Namespace, TnxWideStringCompareStringAComparer Methods


TnxWideStringCompareStringWComparer Class

TnxWideStringCompareStringWComparer Class
TnxWideStringCompareStringWComparer Methods TnxWideStringCompareStringWComparer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringCompareStringWComparernxllWideStringList_TnxWideStringCompareStringWComparernxllWideStringList_TnxWideStringCompareStringWComparernxllWideStringList_TnxWideStringCompareStringWComparernxllWideStringList_TnxWideStringCompareStringWComparer
Syntax
Delphi
TnxWideStringCompareStringWComparer = class(TnxBaseWideStringCompareStringComparer, InxWideStringComparer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringCompareStringWComparer.

Group

Classes

Links
TnxWideStringCompareStringWComparer Methods, TnxWideStringCompareStringWComparer Members, nxllWideStringList, Classes


TnxWideStringCompareStringWComparer Members

TnxWideStringCompareStringWComparer Members
TnxWideStringCompareStringWComparer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringCompareStringWComparer.

Class

TnxWideStringCompareStringWComparer Class

Protected Fields
Name | Description
bwscscFlags | This is bwscscFlags, a member of class TnxBaseWideStringCompareStringComparer.
bwscscLocale | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Compare | InxWideStringComparer TnxWideStringCompareStringWComparer
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create | TnxBaseWideStringCompareStringComparer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringCompareStringWComparer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringCompareStringWComparer Methods

TnxWideStringCompareStringWComparer Methods
TnxWideStringCompareStringWComparer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringCompareStringWComparer class are listed here.

Class

TnxWideStringCompareStringWComparer Class

Protected Methods
Name | Description
Compare | InxWideStringComparer TnxWideStringCompareStringWComparer
Links
TnxWideStringCompareStringWComparer Class, Legend, Protected Methods


TnxWideStringCompareStringWComparer.Compare Method

TnxWideStringCompareStringWComparer.Compare Method
TnxWideStringCompareStringWComparer Class TnxWideStringCompareStringWComparer Members nxllWideStringList Namespace TnxWideStringCompareStringWComparer Methods Send Feedback
Syntax
Delphi
function Compare(const a: TnxWideString; const b: TnxWideString): TnxValueRelationship;
Description

InxWideStringComparer

TnxWideStringCompareStringWComparer

Group

TnxWideStringCompareStringWComparer Methods

Links
TnxWideStringCompareStringWComparer Class, TnxWideStringCompareStringWComparer Members, nxllWideStringList Namespace, TnxWideStringCompareStringWComparer Methods


TnxWideStringDecomposeTransformer Class

TnxWideStringDecomposeTransformer Class
TnxWideStringDecomposeTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringDecomposeTransformernxllWideStringList_TnxWideStringDecomposeTransformernxllWideStringList_TnxWideStringDecomposeTransformernxllWideStringList_TnxWideStringDecomposeTransformernxllWideStringList_TnxWideStringDecomposeTransformer
Syntax
Delphi
TnxWideStringDecomposeTransformer = class(TnxWideStringFoldStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringDecomposeTransformer.

Group

Classes

Links
TnxWideStringDecomposeTransformer Members, nxllWideStringList, Classes


TnxWideStringDecomposeTransformer Members

TnxWideStringDecomposeTransformer Members
TnxWideStringDecomposeTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringDecomposeTransformer.

Class

TnxWideStringDecomposeTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsfstFlags | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringDecomposeTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Transform | This is Transform, a member of class InxWideStringTransformer.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringDecomposeTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringDecomposeTransformer.Create Constructor

TnxWideStringDecomposeTransformer.Create Constructor
TnxWideStringDecomposeTransformer Class TnxWideStringDecomposeTransformer Members nxllWideStringList Namespace TnxWideStringDecomposeTransformer Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxWideStringDecomposeTransformer

Class

TnxWideStringDecomposeTransformer Class

Links
TnxWideStringDecomposeTransformer Class, TnxWideStringDecomposeTransformer Members, nxllWideStringList Namespace, TnxWideStringDecomposeTransformer Class


TnxWideStringFoldStringTransformer Class

TnxWideStringFoldStringTransformer Class
TnxWideStringFoldStringTransformer Fields TnxWideStringFoldStringTransformer Methods TnxWideStringFoldStringTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringFoldStringTransformernxllWideStringList_TnxWideStringFoldStringTransformernxllWideStringList_TnxWideStringFoldStringTransformernxllWideStringList_TnxWideStringFoldStringTransformer
Syntax
Delphi
TnxWideStringFoldStringTransformer = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringFoldStringTransformer.

Group

Classes

Links
TnxWideStringFoldStringTransformer Fields, TnxWideStringFoldStringTransformer Methods, TnxWideStringFoldStringTransformer Members, nxllWideStringList, Classes


TnxWideStringFoldStringTransformer Members

TnxWideStringFoldStringTransformer Members
TnxWideStringFoldStringTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringFoldStringTransformer.

Class

TnxWideStringFoldStringTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsfstFlags | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringFoldStringTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringFoldStringTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringFoldStringTransformer.Create Constructor

TnxWideStringFoldStringTransformer.Create Constructor
TnxWideStringFoldStringTransformer Class TnxWideStringFoldStringTransformer Members nxllWideStringList Namespace TnxWideStringFoldStringTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aFlags: Cardinal);
Description

TnxWideStringFoldStringTransformer

Class

TnxWideStringFoldStringTransformer Class

Links
TnxWideStringFoldStringTransformer Class, TnxWideStringFoldStringTransformer Members, nxllWideStringList Namespace, TnxWideStringFoldStringTransformer Class


TnxWideStringFoldStringTransformer Fields

TnxWideStringFoldStringTransformer Fields
TnxWideStringFoldStringTransformer Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringFoldStringTransformer class are listed here.

Class

TnxWideStringFoldStringTransformer Class

Protected Fields
Name | Description
wsfstFlags | private
Links
TnxWideStringFoldStringTransformer Class, Legend, Protected Fields


TnxWideStringFoldStringTransformer.wsfstFlags Field

TnxWideStringFoldStringTransformer.wsfstFlags Field
TnxWideStringFoldStringTransformer Class TnxWideStringFoldStringTransformer Members nxllWideStringList Namespace TnxWideStringFoldStringTransformer Fields Send Feedback
Syntax
Delphi
wsfstFlags: Cardinal;
Description

private

Group

TnxWideStringFoldStringTransformer Fields

Links
TnxWideStringFoldStringTransformer Class, TnxWideStringFoldStringTransformer Members, nxllWideStringList Namespace, TnxWideStringFoldStringTransformer Fields


TnxWideStringFoldStringTransformer Methods

TnxWideStringFoldStringTransformer Methods
TnxWideStringFoldStringTransformer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringFoldStringTransformer class are listed here.

Class

TnxWideStringFoldStringTransformer Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer
Links
TnxWideStringFoldStringTransformer Class, Legend, Protected Methods


TnxWideStringFoldStringTransformer.Transform Method

TnxWideStringFoldStringTransformer.Transform Method
TnxWideStringFoldStringTransformer Class TnxWideStringFoldStringTransformer Members nxllWideStringList Namespace TnxWideStringFoldStringTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

Group

TnxWideStringFoldStringTransformer Methods

Links
TnxWideStringFoldStringTransformer Class, TnxWideStringFoldStringTransformer Members, nxllWideStringList Namespace, TnxWideStringFoldStringTransformer Methods


TnxWideStringList Class

TnxWideStringList Class
TnxWideStringList Fields TnxWideStringList Methods TnxWideStringList Properties TnxWideStringList Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringListnxllWideStringList_TnxWideStringListnxllWideStringList_TnxWideStringListnxllWideStringList_TnxWideStringList
Syntax
Delphi
TnxWideStringList = class(TnxWideStrings);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringList.

Group

Classes

Links
TnxWideStringList Fields, TnxWideStringList Methods, TnxWideStringList Properties, TnxWideStringList Members, nxllWideStringList, Classes


TnxWideStringList Members

TnxWideStringList Members
TnxWideStringList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringList.

Class

TnxWideStringList Class

Protected Fields
Name | Description
wsComparer | This is wsComparer, a member of class TnxWideStrings.
wslCount | This is wslCount, a member of class TnxWideStringList.
wslDuplicates | This is wslDuplicates, a member of class TnxWideStringList.
wslList | private
wslOnChange | This is wslOnChange, a member of class TnxWideStringList.
wslOnChanging | This is wslOnChanging, a member of class TnxWideStringList.
wslSorted | This is wslSorted, a member of class TnxWideStringList.
wsTransformer | This is wsTransformer, a member of class TnxWideStrings.
wsUpdateCount | private
Protected Methods
Name | Description
_AddRef |
_Release |
DefineProperties |
GetExceptionData | InxExceptionData TnxPersistent
QueryInterface | InxInterface
ReadData |
WriteData |
wsCompare |
wsError |
wsGetCapacity |
wsGetCount |
wsGetName |
wsGetObject |
wsGetString |
wsGetText |
wsGetValue |
wslChanged |
wslChanging |
wslExchangeItems |
wslGrow |
wslInsertItem |
wslQuickSort |
wslSetSorted |
wsPutObject |
wsPutString |
wsSetCapacity |
wsSetText |
wsSetUpdateState |
wsSetValue |
wsTransform |
Public Methods
Name | Description
Add |
Add | This is the overview for the Add method overload.
AddObject | This is the overview for the AddObject method overload.
AddStrings | This is the overview for the AddStrings method overload.
Append | This is the overview for the Append method overload.
Assign |
AssignTo |
BeginUpdate |
Clear |
Create |
Delete |
Destroy |
EndUpdate |
Equals |
Exchange |
Find |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetSeparatedText | This is the overview for the GetSeparatedText method overload.
IndexOf |
IndexOfName |
IndexOfObject |
Insert |
Insert | This is the overview for the Insert method overload.
InsertObject | This is the overview for the InsertObject method overload.
LoadFromFile |
LoadFromStream |
Move |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SaveToFile |
SaveToStream |
Sort |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxWideStrings.
Count | This is Count, a member of class TnxWideStrings.
Duplicates | This is Duplicates, a member of class TnxWideStringList.
Names | This is Names, a member of class TnxWideStrings.
Objects | This is Objects, a member of class TnxWideStrings.
OnChange | This is OnChange, a member of class TnxWideStringList.
OnChanging | This is OnChanging, a member of class TnxWideStringList.
Sorted | This is Sorted, a member of class TnxWideStringList.
Strings | This is Strings, a member of class TnxWideStrings.
Text | This is Text, a member of class TnxWideStrings.
Values | This is Values, a member of class TnxWideStrings.
Links
TnxWideStringList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringList.Destroy Destructor

TnxWideStringList.Destroy Destructor
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxWideStringList Class

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Class


TnxWideStringList Fields

TnxWideStringList Fields
TnxWideStringList Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringList class are listed here.

Class

TnxWideStringList Class

Protected Fields
Name | Description
wslCount | This is wslCount, a member of class TnxWideStringList.
wslDuplicates | This is wslDuplicates, a member of class TnxWideStringList.
wslList | private
wslOnChange | This is wslOnChange, a member of class TnxWideStringList.
wslOnChanging | This is wslOnChanging, a member of class TnxWideStringList.
wslSorted | This is wslSorted, a member of class TnxWideStringList.
Links
TnxWideStringList Class, Legend, Protected Fields


TnxWideStringList.wslCount Field

TnxWideStringList.wslCount Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslCount: Integer;
Description

This is wslCount, a member of class TnxWideStringList.

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList.wslDuplicates Field

TnxWideStringList.wslDuplicates Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslDuplicates: TDuplicates;
Description

This is wslDuplicates, a member of class TnxWideStringList.

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList.wslList Field

TnxWideStringList.wslList Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslList: TnxWideStringItemList;
Description

private

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList.wslOnChange Field

TnxWideStringList.wslOnChange Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslOnChange: TNotifyEvent;
Description

This is wslOnChange, a member of class TnxWideStringList.

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList.wslOnChanging Field

TnxWideStringList.wslOnChanging Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslOnChanging: TNotifyEvent;
Description

This is wslOnChanging, a member of class TnxWideStringList.

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList.wslSorted Field

TnxWideStringList.wslSorted Field
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Fields Send Feedback
Syntax
Delphi
wslSorted: Boolean;
Description

This is wslSorted, a member of class TnxWideStringList.

Group

TnxWideStringList Fields

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Fields


TnxWideStringList Methods

TnxWideStringList Methods
TnxWideStringList Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWideStringList class are listed here.

Class

TnxWideStringList Class

Protected Methods
Name | Description
wsGetCapacity |
wsGetCount |
wsGetObject |
wsGetString |
wslChanged |
wslChanging |
wslExchangeItems |
wslGrow |
wslInsertItem |
wslQuickSort |
wslSetSorted |
wsPutObject |
wsPutString |
wsSetCapacity |
wsSetUpdateState |
Public Methods
Name | Description
Add |
Clear |
Delete |
Exchange |
Find |
IndexOf |
Insert |
Sort |
Links
TnxWideStringList Class, Legend, Protected Methods, Public Methods


TnxWideStringList.Add Method

TnxWideStringList.Add Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function Add(const s: TnxWideString): Integer; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Clear Method

TnxWideStringList.Clear Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure Clear; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Delete Method

TnxWideStringList.Delete Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure Delete(aIndex: Integer); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Exchange Method

TnxWideStringList.Exchange Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure Exchange(aIndex1: Integer; aIndex2: Integer); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Find Method

TnxWideStringList.Find Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function Find(const s: TnxWideString; var aIndex: Integer): Boolean; virtual;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.IndexOf Method

TnxWideStringList.IndexOf Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function IndexOf(const s: TnxWideString): Integer; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Insert Method

TnxWideStringList.Insert Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure Insert(aIndex: Integer; const s: TnxWideString); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.Sort Method

TnxWideStringList.Sort Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure Sort; virtual;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsGetCapacity Method

TnxWideStringList.wsGetCapacity Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function wsGetCapacity: Integer; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsGetCount Method

TnxWideStringList.wsGetCount Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function wsGetCount: Integer; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsGetObject Method

TnxWideStringList.wsGetObject Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function wsGetObject(aIndex: Integer): TObject; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsGetString Method

TnxWideStringList.wsGetString Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
function wsGetString(aIndex: Integer): TnxWideString; override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslChanged Method

TnxWideStringList.wslChanged Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslChanged; virtual;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslChanging Method

TnxWideStringList.wslChanging Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslChanging; virtual;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslExchangeItems Method

TnxWideStringList.wslExchangeItems Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslExchangeItems(aIndex1: Integer; aIndex2: Integer);
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslGrow Method

TnxWideStringList.wslGrow Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslGrow;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslInsertItem Method

TnxWideStringList.wslInsertItem Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslInsertItem(aIndex: Integer; const s: TnxWideString);
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslQuickSort Method

TnxWideStringList.wslQuickSort Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslQuickSort(l: Integer; r: Integer);
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wslSetSorted Method

TnxWideStringList.wslSetSorted Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wslSetSorted(aValue: Boolean);
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsPutObject Method

TnxWideStringList.wsPutObject Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wsPutObject(aIndex: Integer; aObject: TObject); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsPutString Method

TnxWideStringList.wsPutString Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wsPutString(aIndex: Integer; const s: TnxWideString); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsSetCapacity Method

TnxWideStringList.wsSetCapacity Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wsSetCapacity(aNewCapacity: Integer); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList.wsSetUpdateState Method

TnxWideStringList.wsSetUpdateState Method
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Methods Send Feedback
Syntax
Delphi
procedure wsSetUpdateState(aUpdating: Boolean); override;
Group

TnxWideStringList Methods

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Methods


TnxWideStringList Properties

TnxWideStringList Properties
TnxWideStringList Class Legend Public Properties Send Feedback

The properties of the TnxWideStringList class are listed here.

Class

TnxWideStringList Class

Public Properties
Name | Description
Duplicates | This is Duplicates, a member of class TnxWideStringList.
OnChange | This is OnChange, a member of class TnxWideStringList.
OnChanging | This is OnChanging, a member of class TnxWideStringList.
Sorted | This is Sorted, a member of class TnxWideStringList.
Links
TnxWideStringList Class, Legend, Public Properties


TnxWideStringList.Duplicates Property

TnxWideStringList.Duplicates Property
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Properties Send Feedback
Syntax
Delphi
property Duplicates: TDuplicates;
Description

This is Duplicates, a member of class TnxWideStringList.

Group

TnxWideStringList Properties

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Properties


TnxWideStringList.OnChange Property

TnxWideStringList.OnChange Property
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Properties Send Feedback
Syntax
Delphi
property OnChange: TNotifyEvent;
Description

This is OnChange, a member of class TnxWideStringList.

Group

TnxWideStringList Properties

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Properties


TnxWideStringList.OnChanging Property

TnxWideStringList.OnChanging Property
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Properties Send Feedback
Syntax
Delphi
property OnChanging: TNotifyEvent;
Description

This is OnChanging, a member of class TnxWideStringList.

Group

TnxWideStringList Properties

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Properties


TnxWideStringList.Sorted Property

TnxWideStringList.Sorted Property
TnxWideStringList Class TnxWideStringList Members nxllWideStringList Namespace TnxWideStringList Properties Send Feedback
Syntax
Delphi
property Sorted: Boolean;
Description

This is Sorted, a member of class TnxWideStringList.

Group

TnxWideStringList Properties

Links
TnxWideStringList Class, TnxWideStringList Members, nxllWideStringList Namespace, TnxWideStringList Properties


TnxWideStringLocaleMappingTransformer Class

TnxWideStringLocaleMappingTransformer Class
TnxWideStringLocaleMappingTransformer Fields TnxWideStringLocaleMappingTransformer Methods TnxWideStringLocaleMappingTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringLocaleMappingTransformernxllWideStringList_TnxWideStringLocaleMappingTransformernxllWideStringList_TnxWideStringLocaleMappingTransformernxllWideStringList_TnxWideStringLocaleMappingTransformer
Syntax
Delphi
TnxWideStringLocaleMappingTransformer = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringLocaleMappingTransformer.

Group

Classes

Links
TnxWideStringLocaleMappingTransformer Fields, TnxWideStringLocaleMappingTransformer Methods, TnxWideStringLocaleMappingTransformer Members, nxllWideStringList, Classes


TnxWideStringLocaleMappingTransformer Members

TnxWideStringLocaleMappingTransformer Members
TnxWideStringLocaleMappingTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringLocaleMappingTransformer.

Class

TnxWideStringLocaleMappingTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wslmtFlags | This is wslmtFlags, a member of class TnxWideStringLocaleMappingTransformer.
wslmtLocale | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringLocaleMappingTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringLocaleMappingTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringLocaleMappingTransformer.Create Constructor

TnxWideStringLocaleMappingTransformer.Create Constructor
TnxWideStringLocaleMappingTransformer Class TnxWideStringLocaleMappingTransformer Members nxllWideStringList Namespace TnxWideStringLocaleMappingTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aLocale: LCID; aFlags: Cardinal);
Description

TnxWideStringLocaleMappingTransformer

Class

TnxWideStringLocaleMappingTransformer Class

Links
TnxWideStringLocaleMappingTransformer Class, TnxWideStringLocaleMappingTransformer Members, nxllWideStringList Namespace, TnxWideStringLocaleMappingTransformer Class


TnxWideStringLocaleMappingTransformer Fields

TnxWideStringLocaleMappingTransformer Fields
TnxWideStringLocaleMappingTransformer Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringLocaleMappingTransformer class are listed here.

Class

TnxWideStringLocaleMappingTransformer Class

Protected Fields
Name | Description
wslmtFlags | This is wslmtFlags, a member of class TnxWideStringLocaleMappingTransformer.
wslmtLocale | private
Links
TnxWideStringLocaleMappingTransformer Class, Legend, Protected Fields


TnxWideStringLocaleMappingTransformer.wslmtFlags Field

TnxWideStringLocaleMappingTransformer.wslmtFlags Field
TnxWideStringLocaleMappingTransformer Class TnxWideStringLocaleMappingTransformer Members nxllWideStringList Namespace TnxWideStringLocaleMappingTransformer Fields Send Feedback
Syntax
Delphi
wslmtFlags: Cardinal;
Description

This is wslmtFlags, a member of class TnxWideStringLocaleMappingTransformer.

Group

TnxWideStringLocaleMappingTransformer Fields

Links
TnxWideStringLocaleMappingTransformer Class, TnxWideStringLocaleMappingTransformer Members, nxllWideStringList Namespace, TnxWideStringLocaleMappingTransformer Fields


TnxWideStringLocaleMappingTransformer.wslmtLocale Field

TnxWideStringLocaleMappingTransformer.wslmtLocale Field
TnxWideStringLocaleMappingTransformer Class TnxWideStringLocaleMappingTransformer Members nxllWideStringList Namespace TnxWideStringLocaleMappingTransformer Fields Send Feedback
Syntax
Delphi
wslmtLocale: LCID;
Description

private

Group

TnxWideStringLocaleMappingTransformer Fields

Links
TnxWideStringLocaleMappingTransformer Class, TnxWideStringLocaleMappingTransformer Members, nxllWideStringList Namespace, TnxWideStringLocaleMappingTransformer Fields


TnxWideStringLocaleMappingTransformer Methods

TnxWideStringLocaleMappingTransformer Methods
TnxWideStringLocaleMappingTransformer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringLocaleMappingTransformer class are listed here.

Class

TnxWideStringLocaleMappingTransformer Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer
Links
TnxWideStringLocaleMappingTransformer Class, Legend, Protected Methods


TnxWideStringLocaleMappingTransformer.Transform Method

TnxWideStringLocaleMappingTransformer.Transform Method
TnxWideStringLocaleMappingTransformer Class TnxWideStringLocaleMappingTransformer Members nxllWideStringList Namespace TnxWideStringLocaleMappingTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

Group

TnxWideStringLocaleMappingTransformer Methods

Links
TnxWideStringLocaleMappingTransformer Class, TnxWideStringLocaleMappingTransformer Members, nxllWideStringList Namespace, TnxWideStringLocaleMappingTransformer Methods


TnxWideStringLowerCaseTransformer Class

TnxWideStringLowerCaseTransformer Class
TnxWideStringLowerCaseTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringLowerCaseTransformernxllWideStringList_TnxWideStringLowerCaseTransformernxllWideStringList_TnxWideStringLowerCaseTransformernxllWideStringList_TnxWideStringLowerCaseTransformernxllWideStringList_TnxWideStringLowerCaseTransformer
Syntax
Delphi
TnxWideStringLowerCaseTransformer = class(TnxWideStringLocaleMappingTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringLowerCaseTransformer.

Group

Classes

Links
TnxWideStringLowerCaseTransformer Members, nxllWideStringList, Classes


TnxWideStringLowerCaseTransformer Members

TnxWideStringLowerCaseTransformer Members
TnxWideStringLowerCaseTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringLowerCaseTransformer.

Class

TnxWideStringLowerCaseTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wslmtFlags | This is wslmtFlags, a member of class TnxWideStringLocaleMappingTransformer.
wslmtLocale | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringLowerCaseTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Transform | This is Transform, a member of class InxWideStringTransformer.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringLowerCaseTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringLowerCaseTransformer.Create Constructor

TnxWideStringLowerCaseTransformer.Create Constructor
TnxWideStringLowerCaseTransformer Class TnxWideStringLowerCaseTransformer Members nxllWideStringList Namespace TnxWideStringLowerCaseTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aLocale: LCID);
Description

TnxWideStringLowerCaseTransformer

Class

TnxWideStringLowerCaseTransformer Class

Links
TnxWideStringLowerCaseTransformer Class, TnxWideStringLowerCaseTransformer Members, nxllWideStringList Namespace, TnxWideStringLowerCaseTransformer Class


TnxWideStringNullTransformer Class

TnxWideStringNullTransformer Class
TnxWideStringNullTransformer Methods TnxWideStringNullTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringNullTransformernxllWideStringList_TnxWideStringNullTransformernxllWideStringList_TnxWideStringNullTransformernxllWideStringList_TnxWideStringNullTransformer
Syntax
Delphi
TnxWideStringNullTransformer = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringNullTransformer.

Group

Classes

Links
TnxWideStringNullTransformer Methods, TnxWideStringNullTransformer Members, nxllWideStringList, Classes


TnxWideStringNullTransformer Members

TnxWideStringNullTransformer Members
TnxWideStringNullTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringNullTransformer.

Class

TnxWideStringNullTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer TnxWideStringNullTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringNullTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringNullTransformer Methods

TnxWideStringNullTransformer Methods
TnxWideStringNullTransformer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringNullTransformer class are listed here.

Class

TnxWideStringNullTransformer Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer TnxWideStringNullTransformer
Links
TnxWideStringNullTransformer Class, Legend, Protected Methods


TnxWideStringNullTransformer.Transform Method

TnxWideStringNullTransformer.Transform Method
TnxWideStringNullTransformer Class TnxWideStringNullTransformer Members nxllWideStringList Namespace TnxWideStringNullTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

TnxWideStringNullTransformer

Group

TnxWideStringNullTransformer Methods

Links
TnxWideStringNullTransformer Class, TnxWideStringNullTransformer Members, nxllWideStringList Namespace, TnxWideStringNullTransformer Methods


TnxWideStringPreComposeTransformer Class

TnxWideStringPreComposeTransformer Class
TnxWideStringPreComposeTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringPreComposeTransformernxllWideStringList_TnxWideStringPreComposeTransformernxllWideStringList_TnxWideStringPreComposeTransformernxllWideStringList_TnxWideStringPreComposeTransformernxllWideStringList_TnxWideStringPreComposeTransformer
Syntax
Delphi
TnxWideStringPreComposeTransformer = class(TnxWideStringFoldStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringPreComposeTransformer.

Group

Classes

Links
TnxWideStringPreComposeTransformer Members, nxllWideStringList, Classes


TnxWideStringPreComposeTransformer Members

TnxWideStringPreComposeTransformer Members
TnxWideStringPreComposeTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringPreComposeTransformer.

Class

TnxWideStringPreComposeTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsfstFlags | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringPreComposeTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Transform | This is Transform, a member of class InxWideStringTransformer.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringPreComposeTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringPreComposeTransformer.Create Constructor

TnxWideStringPreComposeTransformer.Create Constructor
TnxWideStringPreComposeTransformer Class TnxWideStringPreComposeTransformer Members nxllWideStringList Namespace TnxWideStringPreComposeTransformer Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxWideStringPreComposeTransformer

Class

TnxWideStringPreComposeTransformer Class

Links
TnxWideStringPreComposeTransformer Class, TnxWideStringPreComposeTransformer Members, nxllWideStringList Namespace, TnxWideStringPreComposeTransformer Class


TnxWideStrings Class

TnxWideStrings Class
TnxWideStrings Fields TnxWideStrings Methods TnxWideStrings Properties TnxWideStrings Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringsnxllWideStringList_TnxWideStringsnxllWideStringList_TnxWideStrings
Syntax
Delphi
TnxWideStrings = class(TnxPersistent);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStrings.

Group

Classes

Links
TnxWideStrings Fields, TnxWideStrings Methods, TnxWideStrings Properties, TnxWideStrings Members, nxllWideStringList, Classes


TnxWideStrings Members

TnxWideStrings Members
TnxWideStrings Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStrings.

Class

TnxWideStrings Class

Protected Fields
Name | Description
wsComparer | This is wsComparer, a member of class TnxWideStrings.
wsTransformer | This is wsTransformer, a member of class TnxWideStrings.
wsUpdateCount | private
Protected Methods
Name | Description
_AddRef |
_Release |
DefineProperties |
GetExceptionData | InxExceptionData TnxPersistent
QueryInterface | InxInterface
ReadData |
WriteData |
wsCompare |
wsError |
wsGetCapacity |
wsGetCount | This is wsGetCount, a member of class TnxWideStrings.
wsGetName |
wsGetObject |
wsGetString | This is wsGetString, a member of class TnxWideStrings.
wsGetText |
wsGetValue |
wsPutObject | This is wsPutObject, a member of class TnxWideStrings.
wsPutString | This is wsPutString, a member of class TnxWideStrings.
wsSetCapacity |
wsSetText |
wsSetUpdateState |
wsSetValue |
wsTransform |
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddObject | This is the overview for the AddObject method overload.
AddStrings | This is the overview for the AddStrings method overload.
Append | This is the overview for the Append method overload.
Assign |
AssignTo |
BeginUpdate |
Clear | This is Clear, a member of class TnxWideStrings.
Create |
Delete | This is Delete, a member of class TnxWideStrings.
EndUpdate |
Equals |
Exchange |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetSeparatedText | This is the overview for the GetSeparatedText method overload.
IndexOf |
IndexOfName |
IndexOfObject |
Insert | This is the overview for the Insert method overload.
InsertObject | This is the overview for the InsertObject method overload.
LoadFromFile |
LoadFromStream |
Move |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SaveToFile |
SaveToStream |
Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxWideStrings.
Count | This is Count, a member of class TnxWideStrings.
Names | This is Names, a member of class TnxWideStrings.
Objects | This is Objects, a member of class TnxWideStrings.
Strings | This is Strings, a member of class TnxWideStrings.
Text | This is Text, a member of class TnxWideStrings.
Values | This is Values, a member of class TnxWideStrings.
Links
TnxWideStrings Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStrings.Create Constructor

TnxWideStrings.Create Constructor
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Class Send Feedback
Syntax
Delphi
constructor Create(aComparer: InxWideStringComparer = nil; aTransformer: InxWideStringTransformer = nil);
Class

TnxWideStrings Class

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Class


TnxWideStrings Fields

TnxWideStrings Fields
TnxWideStrings Class Legend Protected Fields Send Feedback

The fields of the TnxWideStrings class are listed here.

Class

TnxWideStrings Class

Protected Fields
Name | Description
wsComparer | This is wsComparer, a member of class TnxWideStrings.
wsTransformer | This is wsTransformer, a member of class TnxWideStrings.
wsUpdateCount | private
Links
TnxWideStrings Class, Legend, Protected Fields


TnxWideStrings.wsComparer Field

TnxWideStrings.wsComparer Field
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Fields Send Feedback
Syntax
Delphi
wsComparer: InxWideStringComparer;
Description

This is wsComparer, a member of class TnxWideStrings.

Group

TnxWideStrings Fields

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Fields


TnxWideStrings.wsTransformer Field

TnxWideStrings.wsTransformer Field
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Fields Send Feedback
Syntax
Delphi
wsTransformer: InxWideStringTransformer;
Description

This is wsTransformer, a member of class TnxWideStrings.

Group

TnxWideStrings Fields

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Fields


TnxWideStrings.wsUpdateCount Field

TnxWideStrings.wsUpdateCount Field
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Fields Send Feedback
Syntax
Delphi
wsUpdateCount: Integer;
Description

private

Group

TnxWideStrings Fields

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Fields


TnxWideStrings Methods

TnxWideStrings Methods
TnxWideStrings Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWideStrings class are listed here.

Class

TnxWideStrings Class

Protected Methods
Name | Description
DefineProperties |
ReadData |
WriteData |
wsCompare |
wsError |
wsGetCapacity |
wsGetCount | This is wsGetCount, a member of class TnxWideStrings.
wsGetName |
wsGetObject |
wsGetString | This is wsGetString, a member of class TnxWideStrings.
wsGetText |
wsGetValue |
wsPutObject | This is wsPutObject, a member of class TnxWideStrings.
wsPutString | This is wsPutString, a member of class TnxWideStrings.
wsSetCapacity |
wsSetText |
wsSetUpdateState |
wsSetValue |
wsTransform |
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddObject | This is the overview for the AddObject method overload.
AddStrings | This is the overview for the AddStrings method overload.
Append | This is the overview for the Append method overload.
Assign |
AssignTo |
BeginUpdate |
Clear | This is Clear, a member of class TnxWideStrings.
Delete | This is Delete, a member of class TnxWideStrings.
EndUpdate |
Equals |
Exchange |
GetSeparatedText | This is the overview for the GetSeparatedText method overload.
IndexOf |
IndexOfName |
IndexOfObject |
Insert | This is the overview for the Insert method overload.
InsertObject | This is the overview for the InsertObject method overload.
LoadFromFile |
LoadFromStream |
Move |
SaveToFile |
SaveToStream |
Links
TnxWideStrings Class, Legend, Protected Methods, Public Methods


Add Method

Add Method
TnxWideStrings Methods Send Feedback

This is the overview for the Add method overload.

Overload List
Name | Description
TnxWideStrings.Add (AnsiString, Word) |
TnxWideStrings.Add (TnxWideString) |
TnxWideStrings.Add (WideString) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.Add Method (AnsiString, Word)

TnxWideStrings.Add Method (AnsiString, Word)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Add Method Send Feedback
Syntax
Delphi
function Add(const s: AnsiString; aCodePage: Word = High(Word)): Integer; overload;
Group

Add Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Add Method


TnxWideStrings.Add Method (TnxWideString)

TnxWideStrings.Add Method (TnxWideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Add Method Send Feedback
Syntax
Delphi
function Add(const s: TnxWideString): Integer; virtual; overload;
Group

Add Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Add Method


TnxWideStrings.Add Method (WideString)

TnxWideStrings.Add Method (WideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Add Method Send Feedback
Syntax
Delphi
function Add(const s: WideString): Integer; overload;
Group

Add Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Add Method


AddObject Method

AddObject Method
TnxWideStrings Methods Send Feedback

This is the overview for the AddObject method overload.

Overload List
Name | Description
TnxWideStrings.AddObject (AnsiString, TObject, Word) |
TnxWideStrings.AddObject (TnxWideString, TObject) |
TnxWideStrings.AddObject (WideString, TObject) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.AddObject Method (AnsiString, TObject, Word)

TnxWideStrings.AddObject Method (AnsiString, TObject, Word)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace AddObject Method Send Feedback
Syntax
Delphi
function AddObject(const s: AnsiString; aObject: TObject; aCodePage: Word = High(Word)): Integer; overload;
Group

AddObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, AddObject Method


TnxWideStrings.AddObject Method (TnxWideString, TObject)

TnxWideStrings.AddObject Method (TnxWideString, TObject)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace AddObject Method Send Feedback
Syntax
Delphi
function AddObject(const s: TnxWideString; aObject: TObject): Integer; virtual; overload;
Group

AddObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, AddObject Method


TnxWideStrings.AddObject Method (WideString, TObject)

TnxWideStrings.AddObject Method (WideString, TObject)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace AddObject Method Send Feedback
Syntax
Delphi
function AddObject(const s: WideString; aObject: TObject): Integer; overload;
Group

AddObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, AddObject Method


AddStrings Method

AddStrings Method
TnxWideStrings Methods Send Feedback

This is the overview for the AddStrings method overload.

Overload List
Name | Description
TnxWideStrings.AddStrings (TnxWideStrings) |
TnxWideStrings.AddStrings (TStrings, TnxWord16) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.AddStrings Method (TStrings, TnxWord16)

TnxWideStrings.AddStrings Method (TStrings, TnxWord16)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace AddStrings Method Send Feedback
Syntax
Delphi
procedure AddStrings(aStrings: TStrings; aCodePage: TnxWord16 = High(TnxWord16)); virtual; overload;
Group

AddStrings Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, AddStrings Method


TnxWideStrings.AddStrings Method (TnxWideStrings)

TnxWideStrings.AddStrings Method (TnxWideStrings)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace AddStrings Method Send Feedback
Syntax
Delphi
procedure AddStrings(Strings: TnxWideStrings); virtual; overload;
Group

AddStrings Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, AddStrings Method


Append Method

Append Method
TnxWideStrings Methods Send Feedback

This is the overview for the Append method overload.

Overload List
Name | Description
TnxWideStrings.Append (AnsiString, Word) |
TnxWideStrings.Append (TnxWideString) |
TnxWideStrings.Append (WideString) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.Append Method (AnsiString, Word)

TnxWideStrings.Append Method (AnsiString, Word)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Append Method Send Feedback
Syntax
Delphi
procedure Append(const s: AnsiString; aCodePage: Word = High(Word)); overload;
Group

Append Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Append Method


TnxWideStrings.Append Method (TnxWideString)

TnxWideStrings.Append Method (TnxWideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Append Method Send Feedback
Syntax
Delphi
procedure Append(const s: TnxWideString); overload;
Group

Append Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Append Method


TnxWideStrings.Append Method (WideString)

TnxWideStrings.Append Method (WideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Append Method Send Feedback
Syntax
Delphi
procedure Append(const s: WideString); overload;
Group

Append Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Append Method


TnxWideStrings.Assign Method

TnxWideStrings.Assign Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure Assign(Source: TPersistent); override;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.AssignTo Method

TnxWideStrings.AssignTo Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure AssignTo(Dest: TPersistent); override;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.BeginUpdate Method

TnxWideStrings.BeginUpdate Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure BeginUpdate;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.Clear Method

TnxWideStrings.Clear Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure Clear; virtual; abstract;
Description

This is Clear, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.DefineProperties Method

TnxWideStrings.DefineProperties Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure DefineProperties(aFiler: TFiler); override;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.Delete Method

TnxWideStrings.Delete Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure Delete(aIndex: Integer); virtual; abstract;
Description

This is Delete, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.EndUpdate Method

TnxWideStrings.EndUpdate Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure EndUpdate;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.Equals Method

TnxWideStrings.Equals Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function Equals(Strings: TnxWideStrings): Boolean; reintroduce;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.Exchange Method

TnxWideStrings.Exchange Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure Exchange(aIndex1: Integer; aIndex2: Integer); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


GetSeparatedText Method

GetSeparatedText Method
TnxWideStrings Methods Send Feedback

This is the overview for the GetSeparatedText method overload.

Overload List
Name | Description
TnxWideStrings.GetSeparatedText (TnxWideString) |
TnxWideStrings.GetSeparatedText (WideChar) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.GetSeparatedText Method (TnxWideString)

TnxWideStrings.GetSeparatedText Method (TnxWideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace GetSeparatedText Method Send Feedback
Syntax
Delphi
function GetSeparatedText(Separators: TnxWideString): TnxWideString; virtual; overload;
Group

GetSeparatedText Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, GetSeparatedText Method


TnxWideStrings.GetSeparatedText Method (WideChar)

TnxWideStrings.GetSeparatedText Method (WideChar)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace GetSeparatedText Method Send Feedback
Syntax
Delphi
function GetSeparatedText(Separator: WideChar): TnxWideString; overload;
Group

GetSeparatedText Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, GetSeparatedText Method


TnxWideStrings.IndexOf Method

TnxWideStrings.IndexOf Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function IndexOf(const s: TnxWideString): Integer; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.IndexOfName Method

TnxWideStrings.IndexOfName Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function IndexOfName(const aName: TnxWideString): Integer;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.IndexOfObject Method

TnxWideStrings.IndexOfObject Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function IndexOfObject(aObject: TObject): Integer;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


Insert Method

Insert Method
TnxWideStrings Methods Send Feedback

This is the overview for the Insert method overload.

Overload List
Name | Description
TnxWideStrings.Insert (Integer, AnsiString, Word) |
TnxWideStrings.Insert (Integer, TnxWideString) | This is Insert, a member of class TnxWideStrings.
TnxWideStrings.Insert (Integer, WideString) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.Insert Method (Integer, AnsiString, Word)

TnxWideStrings.Insert Method (Integer, AnsiString, Word)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Insert Method Send Feedback
Syntax
Delphi
procedure Insert(aIndex: Integer; const s: AnsiString; aCodePage: Word = High(Word)); overload;
Group

Insert Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Insert Method


TnxWideStrings.Insert Method (Integer, TnxWideString)

TnxWideStrings.Insert Method (Integer, TnxWideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Insert Method Send Feedback
Syntax
Delphi
procedure Insert(aIndex: Integer; const s: TnxWideString); virtual; abstract; overload;
Description

This is Insert, a member of class TnxWideStrings.

Group

Insert Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Insert Method


TnxWideStrings.Insert Method (Integer, WideString)

TnxWideStrings.Insert Method (Integer, WideString)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace Insert Method Send Feedback
Syntax
Delphi
procedure Insert(aIndex: Integer; const s: WideString); overload;
Group

Insert Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, Insert Method


InsertObject Method

InsertObject Method
TnxWideStrings Methods Send Feedback

This is the overview for the InsertObject method overload.

Overload List
Name | Description
TnxWideStrings.InsertObject (Integer, AnsiString, TObject, Word) |
TnxWideStrings.InsertObject (Integer, TnxWideString, TObject) |
TnxWideStrings.InsertObject (Integer, WideString, TObject) |
Group

TnxWideStrings Methods

Links
TnxWideStrings Methods


TnxWideStrings.InsertObject Method (Integer, AnsiString, TObject, Word)

TnxWideStrings.InsertObject Method (Integer, AnsiString, TObject, Word)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace InsertObject Method Send Feedback
Syntax
Delphi
procedure InsertObject(aIndex: Integer; const s: AnsiString; aObject: TObject; aCodePage: Word = High(Word)); overload;
Group

InsertObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, InsertObject Method


TnxWideStrings.InsertObject Method (Integer, TnxWideString, TObject)

TnxWideStrings.InsertObject Method (Integer, TnxWideString, TObject)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace InsertObject Method Send Feedback
Syntax
Delphi
procedure InsertObject(aIndex: Integer; const s: TnxWideString; aObject: TObject); overload;
Group

InsertObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, InsertObject Method


TnxWideStrings.InsertObject Method (Integer, WideString, TObject)

TnxWideStrings.InsertObject Method (Integer, WideString, TObject)
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace InsertObject Method Send Feedback
Syntax
Delphi
procedure InsertObject(aIndex: Integer; const s: WideString; aObject: TObject); overload;
Group

InsertObject Method

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, InsertObject Method


TnxWideStrings.LoadFromFile Method

TnxWideStrings.LoadFromFile Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure LoadFromFile(const aFileName: string; aForceUnicode: Boolean = False; aCodePage: TnxWord16 = High(TnxWord16)); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.LoadFromStream Method

TnxWideStrings.LoadFromStream Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure LoadFromStream(aStream: TStream; aForceUnicode: Boolean = False; aCodePage: TnxWord16 = High(TnxWord16)); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.Move Method

TnxWideStrings.Move Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure Move(aCurIndex: Integer; aNewIndex: Integer); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.ReadData Method

TnxWideStrings.ReadData Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure ReadData(aReader: TReader);
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.SaveToFile Method

TnxWideStrings.SaveToFile Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure SaveToFile(const aFileName: string; aUnicode: Boolean = True; aWithBOM: Boolean = True; aCodePage: TnxWord16 = High(TnxWord16)); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.SaveToStream Method

TnxWideStrings.SaveToStream Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure SaveToStream(aStream: TStream; aUnicode: Boolean = True; aWithBOM: Boolean = True; aCodePage: TnxWord16 = High(TnxWord16)); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.WriteData Method

TnxWideStrings.WriteData Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure WriteData(aWriter: TWriter);
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsCompare Method

TnxWideStrings.wsCompare Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsCompare(const a: TnxWideString; const b: TnxWideString): TnxValueRelationship; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsError Method

TnxWideStrings.wsError Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsError(const Msg: string; Data: Integer);
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetCapacity Method

TnxWideStrings.wsGetCapacity Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetCapacity: Integer; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetCount Method

TnxWideStrings.wsGetCount Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetCount: Integer; virtual; abstract;
Description

This is wsGetCount, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetName Method

TnxWideStrings.wsGetName Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetName(aIndex: Integer): TnxWideString;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetObject Method

TnxWideStrings.wsGetObject Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetObject(aIndex: Integer): TObject; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetString Method

TnxWideStrings.wsGetString Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetString(aIndex: Integer): TnxWideString; virtual; abstract;
Description

This is wsGetString, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetText Method

TnxWideStrings.wsGetText Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetText: TnxWideString; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsGetValue Method

TnxWideStrings.wsGetValue Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsGetValue(const aName: TnxWideString): TnxWideString;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsPutObject Method

TnxWideStrings.wsPutObject Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsPutObject(aIndex: Integer; aObject: TObject); virtual; abstract;
Description

This is wsPutObject, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsPutString Method

TnxWideStrings.wsPutString Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsPutString(aIndex: Integer; const s: TnxWideString); virtual; abstract;
Description

This is wsPutString, a member of class TnxWideStrings.

Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsSetCapacity Method

TnxWideStrings.wsSetCapacity Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsSetCapacity(aNewCapacity: Integer); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsSetText Method

TnxWideStrings.wsSetText Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsSetText(const aValue: TnxWideString); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsSetUpdateState Method

TnxWideStrings.wsSetUpdateState Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsSetUpdateState(aUpdating: Boolean); virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsSetValue Method

TnxWideStrings.wsSetValue Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
procedure wsSetValue(const aName: TnxWideString; const aValue: TnxWideString);
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings.wsTransform Method

TnxWideStrings.wsTransform Method
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Methods Send Feedback
Syntax
Delphi
function wsTransform(const s: TnxWideString): TnxWideString; virtual;
Group

TnxWideStrings Methods

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Methods


TnxWideStrings Properties

TnxWideStrings Properties
TnxWideStrings Class Legend Public Properties Send Feedback

The properties of the TnxWideStrings class are listed here.

Class

TnxWideStrings Class

Public Properties
Name | Description
Capacity | This is Capacity, a member of class TnxWideStrings.
Count | This is Count, a member of class TnxWideStrings.
Names | This is Names, a member of class TnxWideStrings.
Objects | This is Objects, a member of class TnxWideStrings.
Strings | This is Strings, a member of class TnxWideStrings.
Text | This is Text, a member of class TnxWideStrings.
Values | This is Values, a member of class TnxWideStrings.
Links
TnxWideStrings Class, Legend, Public Properties


TnxWideStrings.Capacity Property

TnxWideStrings.Capacity Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Capacity: Integer;
Description

This is Capacity, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Count Property

TnxWideStrings.Count Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Count: Integer;
Description

This is Count, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Names Property

TnxWideStrings.Names Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Names [aIndex: Integer]: TnxWideString;
Description

This is Names, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Objects Property

TnxWideStrings.Objects Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Objects [aIndex: Integer]: TObject;
Description

This is Objects, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Strings Property

TnxWideStrings.Strings Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Strings [aIndex: Integer]: TnxWideString;
Description

This is Strings, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Text Property

TnxWideStrings.Text Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Text: TnxWideString;
Description

This is Text, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStrings.Values Property

TnxWideStrings.Values Property
TnxWideStrings Class TnxWideStrings Members nxllWideStringList Namespace TnxWideStrings Properties Send Feedback
Syntax
Delphi
property Values [const aName: TnxWideString]: TnxWideString;
Description

This is Values, a member of class TnxWideStrings.

Group

TnxWideStrings Properties

Links
TnxWideStrings Class, TnxWideStrings Members, nxllWideStringList Namespace, TnxWideStrings Properties


TnxWideStringTransformerHub Class

TnxWideStringTransformerHub Class
TnxWideStringTransformerHub Fields TnxWideStringTransformerHub Methods TnxWideStringTransformerHub Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringTransformerHubnxllWideStringList_TnxWideStringTransformerHubnxllWideStringList_TnxWideStringTransformerHubnxllWideStringList_TnxWideStringTransformerHub
Syntax
Delphi
TnxWideStringTransformerHub = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringTransformerHub.

Group

Classes

Links
TnxWideStringTransformerHub Fields, TnxWideStringTransformerHub Methods, TnxWideStringTransformerHub Members, nxllWideStringList, Classes


TnxWideStringTransformerHub Members

TnxWideStringTransformerHub Members
TnxWideStringTransformerHub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringTransformerHub.

Class

TnxWideStringTransformerHub Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsthTransformers | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringTransformerHub
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringTransformerHub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringTransformerHub.Create Constructor

TnxWideStringTransformerHub.Create Constructor
TnxWideStringTransformerHub Class TnxWideStringTransformerHub Members nxllWideStringList Namespace TnxWideStringTransformerHub Class Send Feedback
Syntax
Delphi
constructor Create(const aTransformers: array of InxWideStringTransformer);
Description

TnxWideStringTransformerHub

Class

TnxWideStringTransformerHub Class

Links
TnxWideStringTransformerHub Class, TnxWideStringTransformerHub Members, nxllWideStringList Namespace, TnxWideStringTransformerHub Class


TnxWideStringTransformerHub Fields

TnxWideStringTransformerHub Fields
TnxWideStringTransformerHub Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringTransformerHub class are listed here.

Class

TnxWideStringTransformerHub Class

Protected Fields
Name | Description
wsthTransformers | private
Links
TnxWideStringTransformerHub Class, Legend, Protected Fields


TnxWideStringTransformerHub.wsthTransformers Field

TnxWideStringTransformerHub.wsthTransformers Field
TnxWideStringTransformerHub Class TnxWideStringTransformerHub Members nxllWideStringList Namespace TnxWideStringTransformerHub Fields Send Feedback
Syntax
Delphi
wsthTransformers: TnxWideStringTransformers;
Description

private

Group

TnxWideStringTransformerHub Fields

Links
TnxWideStringTransformerHub Class, TnxWideStringTransformerHub Members, nxllWideStringList Namespace, TnxWideStringTransformerHub Fields


TnxWideStringTransformerHub Methods

TnxWideStringTransformerHub Methods
TnxWideStringTransformerHub Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringTransformerHub class are listed here.

Class

TnxWideStringTransformerHub Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer
Links
TnxWideStringTransformerHub Class, Legend, Protected Methods


TnxWideStringTransformerHub.Transform Method

TnxWideStringTransformerHub.Transform Method
TnxWideStringTransformerHub Class TnxWideStringTransformerHub Members nxllWideStringList Namespace TnxWideStringTransformerHub Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

Group

TnxWideStringTransformerHub Methods

Links
TnxWideStringTransformerHub Class, TnxWideStringTransformerHub Members, nxllWideStringList Namespace, TnxWideStringTransformerHub Methods


TnxWideStringTruncateTransformer Class

TnxWideStringTruncateTransformer Class
TnxWideStringTruncateTransformer Fields TnxWideStringTruncateTransformer Methods TnxWideStringTruncateTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringTruncateTransformernxllWideStringList_TnxWideStringTruncateTransformernxllWideStringList_TnxWideStringTruncateTransformernxllWideStringList_TnxWideStringTruncateTransformer
Syntax
Delphi
TnxWideStringTruncateTransformer = class(TnxInterfacedObject, InxWideStringTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringTruncateTransformer.

Group

Classes

Links
TnxWideStringTruncateTransformer Fields, TnxWideStringTruncateTransformer Methods, TnxWideStringTruncateTransformer Members, nxllWideStringList, Classes


TnxWideStringTruncateTransformer Members

TnxWideStringTruncateTransformer Members
TnxWideStringTruncateTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringTruncateTransformer.

Class

TnxWideStringTruncateTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wsttMaxLength | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringTruncateTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringTruncateTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringTruncateTransformer.Create Constructor

TnxWideStringTruncateTransformer.Create Constructor
TnxWideStringTruncateTransformer Class TnxWideStringTruncateTransformer Members nxllWideStringList Namespace TnxWideStringTruncateTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aMaxLength: Integer);
Description

TnxWideStringTruncateTransformer

Class

TnxWideStringTruncateTransformer Class

Links
TnxWideStringTruncateTransformer Class, TnxWideStringTruncateTransformer Members, nxllWideStringList Namespace, TnxWideStringTruncateTransformer Class


TnxWideStringTruncateTransformer Fields

TnxWideStringTruncateTransformer Fields
TnxWideStringTruncateTransformer Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringTruncateTransformer class are listed here.

Class

TnxWideStringTruncateTransformer Class

Protected Fields
Name | Description
wsttMaxLength | private
Links
TnxWideStringTruncateTransformer Class, Legend, Protected Fields


TnxWideStringTruncateTransformer.wsttMaxLength Field

TnxWideStringTruncateTransformer.wsttMaxLength Field
TnxWideStringTruncateTransformer Class TnxWideStringTruncateTransformer Members nxllWideStringList Namespace TnxWideStringTruncateTransformer Fields Send Feedback
Syntax
Delphi
wsttMaxLength: Integer;
Description

private

Group

TnxWideStringTruncateTransformer Fields

Links
TnxWideStringTruncateTransformer Class, TnxWideStringTruncateTransformer Members, nxllWideStringList Namespace, TnxWideStringTruncateTransformer Fields


TnxWideStringTruncateTransformer Methods

TnxWideStringTruncateTransformer Methods
TnxWideStringTruncateTransformer Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringTruncateTransformer class are listed here.

Class

TnxWideStringTruncateTransformer Class

Protected Methods
Name | Description
Transform | InxWideStringTransformer
Links
TnxWideStringTruncateTransformer Class, Legend, Protected Methods


TnxWideStringTruncateTransformer.Transform Method

TnxWideStringTruncateTransformer.Transform Method
TnxWideStringTruncateTransformer Class TnxWideStringTruncateTransformer Members nxllWideStringList Namespace TnxWideStringTruncateTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

InxWideStringTransformer

Group

TnxWideStringTruncateTransformer Methods

Links
TnxWideStringTruncateTransformer Class, TnxWideStringTruncateTransformer Members, nxllWideStringList Namespace, TnxWideStringTruncateTransformer Methods


TnxWideStringUpperCaseTransformer Class

TnxWideStringUpperCaseTransformer Class
TnxWideStringUpperCaseTransformer Members nxllWideStringList Classes Send Feedback
Class Hierarchy
nxllWideStringList_TnxWideStringUpperCaseTransformernxllWideStringList_TnxWideStringUpperCaseTransformernxllWideStringList_TnxWideStringUpperCaseTransformernxllWideStringList_TnxWideStringUpperCaseTransformernxllWideStringList_TnxWideStringUpperCaseTransformer
Syntax
Delphi
TnxWideStringUpperCaseTransformer = class(TnxWideStringLocaleMappingTransformer);
File

nxllWideStringList

Description

This is class nxllWideStringList.TnxWideStringUpperCaseTransformer.

Group

Classes

Links
TnxWideStringUpperCaseTransformer Members, nxllWideStringList, Classes


TnxWideStringUpperCaseTransformer Members

TnxWideStringUpperCaseTransformer Members
TnxWideStringUpperCaseTransformer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideStringUpperCaseTransformer.

Class

TnxWideStringUpperCaseTransformer Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
wslmtFlags | This is wslmtFlags, a member of class TnxWideStringLocaleMappingTransformer.
wslmtLocale | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Transform | InxWideStringTransformer
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxWideStringUpperCaseTransformer
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Transform | This is Transform, a member of class InxWideStringTransformer.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxWideStringUpperCaseTransformer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideStringUpperCaseTransformer.Create Constructor

TnxWideStringUpperCaseTransformer.Create Constructor
TnxWideStringUpperCaseTransformer Class TnxWideStringUpperCaseTransformer Members nxllWideStringList Namespace TnxWideStringUpperCaseTransformer Class Send Feedback
Syntax
Delphi
constructor Create(aLocale: LCID);
Description

TnxWideStringUpperCaseTransformer

Class

TnxWideStringUpperCaseTransformer Class

Links
TnxWideStringUpperCaseTransformer Class, TnxWideStringUpperCaseTransformer Members, nxllWideStringList Namespace, TnxWideStringUpperCaseTransformer Class


Interfaces

Interfaces
nxllWideStringList Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxllWideStringList Namespace

Interfaces
Name | Description
InxWideStringComparer | This is class nxllWideStringList.InxWideStringComparer.
InxWideStringTransformer | This is class nxllWideStringList.InxWideStringTransformer.
Links
nxllWideStringList Namespace, Interfaces, Legend


InxWideStringComparer Interface

InxWideStringComparer Interface
InxWideStringComparer Methods InxWideStringComparer Members nxllWideStringList Interfaces Send Feedback
Class Hierarchy
nxllWideStringList_InxWideStringComparer
Syntax
Delphi
InxWideStringComparer = interface(InxInterface);
File

nxllWideStringList

Description

This is class nxllWideStringList.InxWideStringComparer.

Group

Interfaces

Links
InxWideStringComparer Methods, InxWideStringComparer Members, nxllWideStringList, Interfaces


InxWideStringComparer Members

InxWideStringComparer Members
InxWideStringComparer Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxWideStringComparer.

Interface

InxWideStringComparer Interface

Public Methods
Name | Description
Compare | This is Compare, a member of class InxWideStringComparer.
Links
InxWideStringComparer Interface, Legend, Public Methods


InxWideStringComparer Methods

InxWideStringComparer Methods
InxWideStringComparer Interface Legend Public Methods Send Feedback

The methods of the InxWideStringComparer class are listed here.

Interface

InxWideStringComparer Interface

Public Methods
Name | Description
Compare | This is Compare, a member of class InxWideStringComparer.
Links
InxWideStringComparer Interface, Legend, Public Methods


InxWideStringComparer.Compare Method

InxWideStringComparer.Compare Method
InxWideStringComparer Interface InxWideStringComparer Members nxllWideStringList Namespace InxWideStringComparer Methods Send Feedback
Syntax
Delphi
function Compare(const a: TnxWideString; const b: TnxWideString): TnxValueRelationship;
Description

This is Compare, a member of class InxWideStringComparer.

Group

InxWideStringComparer Methods

Links
InxWideStringComparer Interface, InxWideStringComparer Members, nxllWideStringList Namespace, InxWideStringComparer Methods


InxWideStringTransformer Interface

InxWideStringTransformer Interface
InxWideStringTransformer Methods InxWideStringTransformer Members nxllWideStringList Interfaces Send Feedback
Class Hierarchy
nxllWideStringList_InxWideStringTransformer
Syntax
Delphi
InxWideStringTransformer = interface(InxInterface);
File

nxllWideStringList

Description

This is class nxllWideStringList.InxWideStringTransformer.

Group

Interfaces

Links
InxWideStringTransformer Methods, InxWideStringTransformer Members, nxllWideStringList, Interfaces


InxWideStringTransformer Members

InxWideStringTransformer Members
InxWideStringTransformer Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxWideStringTransformer.

Interface

InxWideStringTransformer Interface

Public Methods
Name | Description
Transform | This is Transform, a member of class InxWideStringTransformer.
Links
InxWideStringTransformer Interface, Legend, Public Methods


InxWideStringTransformer Methods

InxWideStringTransformer Methods
InxWideStringTransformer Interface Legend Public Methods Send Feedback

The methods of the InxWideStringTransformer class are listed here.

Interface

InxWideStringTransformer Interface

Public Methods
Name | Description
Transform | This is Transform, a member of class InxWideStringTransformer.
Links
InxWideStringTransformer Interface, Legend, Public Methods


InxWideStringTransformer.Transform Method

InxWideStringTransformer.Transform Method
InxWideStringTransformer Interface InxWideStringTransformer Members nxllWideStringList Namespace InxWideStringTransformer Methods Send Feedback
Syntax
Delphi
function Transform(const s: TnxWideString): TnxWideString;
Description

This is Transform, a member of class InxWideStringTransformer.

Group

InxWideStringTransformer Methods

Links
InxWideStringTransformer Interface, InxWideStringTransformer Members, nxllWideStringList Namespace, InxWideStringTransformer Methods


Structs, Records, Enums

Structs, Records, Enums
nxllWideStringList Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllWideStringList Namespace

Records
Name | Description
TnxWideStringItem | This is record nxllWideStringList.TnxWideStringItem.
Links
nxllWideStringList Namespace, Legend, Records


nxllWideStringList.TnxWideStringItem Record

nxllWideStringList.TnxWideStringItem Record
nxllWideStringList Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxWideStringItem = record
  wsiString: TnxWideString;
  wsiObject: TObject;
end;
File

nxllWideStringList

Description

This is record nxllWideStringList.TnxWideStringItem.

Group

Structs, Records, Enums

Links
nxllWideStringList, Structs, Records, Enums


Types

Types
nxllWideStringList Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllWideStringList Namespace

Types
Name | Description
TnxWideStringItemList | This is type nxllWideStringList.TnxWideStringItemList.
TnxWideStringTransformers | This is type nxllWideStringList.TnxWideStringTransformers.
Links
nxllWideStringList Namespace, Types


nxllWideStringList.TnxWideStringItemList Type

nxllWideStringList.TnxWideStringItemList Type
nxllWideStringList Types Send Feedback
Syntax
Delphi
TnxWideStringItemList = array of TnxWideStringItem;
File

nxllWideStringList

Description

This is type nxllWideStringList.TnxWideStringItemList.

Group

Types

Links
nxllWideStringList, Types


nxllWideStringList.TnxWideStringTransformers Type

nxllWideStringList.TnxWideStringTransformers Type
nxllWideStringList Types Send Feedback
Syntax
Delphi
TnxWideStringTransformers = array of InxWideStringTransformer;
File

nxllWideStringList

Description

This is type nxllWideStringList.TnxWideStringTransformers.

Group

Types

Links
nxllWideStringList, Types


Constants

Constants
Constants nxllWideStringList Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsLCMAPSORTKEYIsNotSupported | This is constant nxllWideStringList.rsLCMAPSORTKEYIsNotSupported.
Namespace

nxllWideStringList Namespace

Links
Constants, nxllWideStringList Namespace


nxllWideStringList.rsLCMAPSORTKEYIsNotSupported Constant

nxllWideStringList.rsLCMAPSORTKEYIsNotSupported Constant
nxllWideStringList Constants Send Feedback
Syntax
Delphi
rsLCMAPSORTKEYIsNotSupported = 'LCMAP_SORTKEY is not supported by TnxWideS' + 'tringLocaleMappingTransformer';
File

nxllWideStringList

Description

This is constant nxllWideStringList.rsLCMAPSORTKEYIsNotSupported.

Group

Constants

Links
nxllWideStringList, Constants


nxllZipCompressor Namespace

nxllZipCompressor Namespace
Classes Legend Topics Send Feedback

This is namespace nxllZipCompressor.

Classes
Name | Description
EzCompressionError | This is class nxllZipCompressor.EzCompressionError.
EzDecompressionError | This is class nxllZipCompressor.EzDecompressionError.
EzLibError |
TnxZipCompressor | This is class nxllZipCompressor.TnxZipCompressor.
TnxZipCompressor1 | This is class nxllZipCompressor.TnxZipCompressor1.
TnxZipCompressor2 | This is class nxllZipCompressor.TnxZipCompressor2.
TnxZipCompressor3 | This is class nxllZipCompressor.TnxZipCompressor3.
TnxZipCompressor4 | This is class nxllZipCompressor.TnxZipCompressor4.
TnxZipCompressor5 | This is class nxllZipCompressor.TnxZipCompressor5.
TnxZipCompressor6 | This is class nxllZipCompressor.TnxZipCompressor6.
TnxZipCompressor7 | This is class nxllZipCompressor.TnxZipCompressor7.
TnxZipCompressor8 | This is class nxllZipCompressor.TnxZipCompressor8.
TnxZipCompressor9 | This is class nxllZipCompressor.TnxZipCompressor9.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxllZipCompressor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EzCompressionError | This is class nxllZipCompressor.EzCompressionError.
EzDecompressionError | This is class nxllZipCompressor.EzDecompressionError.
EzLibError |
TnxZipCompressor | This is class nxllZipCompressor.TnxZipCompressor.
TnxZipCompressor1 | This is class nxllZipCompressor.TnxZipCompressor1.
TnxZipCompressor2 | This is class nxllZipCompressor.TnxZipCompressor2.
TnxZipCompressor3 | This is class nxllZipCompressor.TnxZipCompressor3.
TnxZipCompressor4 | This is class nxllZipCompressor.TnxZipCompressor4.
TnxZipCompressor5 | This is class nxllZipCompressor.TnxZipCompressor5.
TnxZipCompressor6 | This is class nxllZipCompressor.TnxZipCompressor6.
TnxZipCompressor7 | This is class nxllZipCompressor.TnxZipCompressor7.
TnxZipCompressor8 | This is class nxllZipCompressor.TnxZipCompressor8.
TnxZipCompressor9 | This is class nxllZipCompressor.TnxZipCompressor9.
Namespace

nxllZipCompressor Namespace

Links
Classes, nxllZipCompressor Namespace, Legend


EzCompressionError Class

EzCompressionError Class
nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_EzCompressionErrornxllZipCompressor_EzCompressionError
Syntax
Delphi
EzCompressionError = class(EzLibError);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.EzCompressionError.

Group

Classes

Links
nxllZipCompressor, Classes


EzDecompressionError Class

EzDecompressionError Class
nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_EzDecompressionErrornxllZipCompressor_EzDecompressionError
Syntax
Delphi
EzDecompressionError = class(EzLibError);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.EzDecompressionError.

Group

Classes

Links
nxllZipCompressor, Classes


EzLibError Class

EzLibError Class
nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_EzLibError
Syntax
Delphi
EzLibError = class(Exception);
File

nxllZipCompressor

Group

Classes

Links
nxllZipCompressor, Classes


TnxZipCompressor Class

TnxZipCompressor Class
TnxZipCompressor Methods TnxZipCompressor Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressornxllZipCompressor_TnxZipCompressornxllZipCompressor_TnxZipCompressor
Syntax
Delphi
TnxZipCompressor = class(TnxBaseCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor.

Group

Classes

Links
TnxZipCompressor Methods, TnxZipCompressor Members, nxllZipCompressor, Classes


TnxZipCompressor Members

TnxZipCompressor Members
TnxZipCompressor Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor.

Class

TnxZipCompressor Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress |
Links
TnxZipCompressor Class, Legend, Protected Methods, Public Methods


TnxZipCompressor Methods

TnxZipCompressor Methods
TnxZipCompressor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxZipCompressor class are listed here.

Class

TnxZipCompressor Class

Protected Methods
Name | Description
zcCompressionLevel |
Public Methods
Name | Description
Compress |
Uncompress |
Links
TnxZipCompressor Class, Legend, Protected Methods, Public Methods


TnxZipCompressor.Compress Method

TnxZipCompressor.Compress Method
TnxZipCompressor Class TnxZipCompressor Members nxllZipCompressor Namespace TnxZipCompressor Methods Send Feedback
Syntax
Delphi
class function Compress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32): TnxWord32; override;
Group

TnxZipCompressor Methods

Links
TnxZipCompressor Class, TnxZipCompressor Members, nxllZipCompressor Namespace, TnxZipCompressor Methods


TnxZipCompressor.Uncompress Method

TnxZipCompressor.Uncompress Method
TnxZipCompressor Class TnxZipCompressor Members nxllZipCompressor Namespace TnxZipCompressor Methods Send Feedback
Syntax
Delphi
class procedure Uncompress(aSource: Pointer; aTarget: Pointer; aSourceSize: TnxWord32; aTargetSize: TnxWord32); override;
Group

TnxZipCompressor Methods

Links
TnxZipCompressor Class, TnxZipCompressor Members, nxllZipCompressor Namespace, TnxZipCompressor Methods


TnxZipCompressor.zcCompressionLevel Method

TnxZipCompressor.zcCompressionLevel Method
TnxZipCompressor Class TnxZipCompressor Members nxllZipCompressor Namespace TnxZipCompressor Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; virtual;
Group

TnxZipCompressor Methods

Links
TnxZipCompressor Class, TnxZipCompressor Members, nxllZipCompressor Namespace, TnxZipCompressor Methods


TnxZipCompressor1 Class

TnxZipCompressor1 Class
TnxZipCompressor1 Methods TnxZipCompressor1 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor1nxllZipCompressor_TnxZipCompressor1nxllZipCompressor_TnxZipCompressor1nxllZipCompressor_TnxZipCompressor1
Syntax
Delphi
TnxZipCompressor1 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor1.

Group

Classes

Links
TnxZipCompressor1 Methods, TnxZipCompressor1 Members, nxllZipCompressor, Classes


TnxZipCompressor1 Members

TnxZipCompressor1 Members
TnxZipCompressor1 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor1.

Class

TnxZipCompressor1 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel | TnxZipCompressorX
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor1 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor1 Methods

TnxZipCompressor1 Methods
TnxZipCompressor1 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor1 class are listed here.

Class

TnxZipCompressor1 Class

Protected Methods
Name | Description
zcCompressionLevel | TnxZipCompressorX
Links
TnxZipCompressor1 Class, Legend, Protected Methods


TnxZipCompressor1.zcCompressionLevel Method

TnxZipCompressor1.zcCompressionLevel Method
TnxZipCompressor1 Class TnxZipCompressor1 Members nxllZipCompressor Namespace TnxZipCompressor1 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Description

TnxZipCompressorX

Group

TnxZipCompressor1 Methods

Links
TnxZipCompressor1 Class, TnxZipCompressor1 Members, nxllZipCompressor Namespace, TnxZipCompressor1 Methods


TnxZipCompressor2 Class

TnxZipCompressor2 Class
TnxZipCompressor2 Methods TnxZipCompressor2 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor2nxllZipCompressor_TnxZipCompressor2nxllZipCompressor_TnxZipCompressor2nxllZipCompressor_TnxZipCompressor2
Syntax
Delphi
TnxZipCompressor2 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor2.

Group

Classes

Links
TnxZipCompressor2 Methods, TnxZipCompressor2 Members, nxllZipCompressor, Classes


TnxZipCompressor2 Members

TnxZipCompressor2 Members
TnxZipCompressor2 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor2.

Class

TnxZipCompressor2 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor2 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor2 Methods

TnxZipCompressor2 Methods
TnxZipCompressor2 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor2 class are listed here.

Class

TnxZipCompressor2 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor2 Class, Legend, Protected Methods


TnxZipCompressor2.zcCompressionLevel Method

TnxZipCompressor2.zcCompressionLevel Method
TnxZipCompressor2 Class TnxZipCompressor2 Members nxllZipCompressor Namespace TnxZipCompressor2 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor2 Methods

Links
TnxZipCompressor2 Class, TnxZipCompressor2 Members, nxllZipCompressor Namespace, TnxZipCompressor2 Methods


TnxZipCompressor3 Class

TnxZipCompressor3 Class
TnxZipCompressor3 Methods TnxZipCompressor3 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor3nxllZipCompressor_TnxZipCompressor3nxllZipCompressor_TnxZipCompressor3nxllZipCompressor_TnxZipCompressor3
Syntax
Delphi
TnxZipCompressor3 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor3.

Group

Classes

Links
TnxZipCompressor3 Methods, TnxZipCompressor3 Members, nxllZipCompressor, Classes


TnxZipCompressor3 Members

TnxZipCompressor3 Members
TnxZipCompressor3 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor3.

Class

TnxZipCompressor3 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor3 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor3 Methods

TnxZipCompressor3 Methods
TnxZipCompressor3 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor3 class are listed here.

Class

TnxZipCompressor3 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor3 Class, Legend, Protected Methods


TnxZipCompressor3.zcCompressionLevel Method

TnxZipCompressor3.zcCompressionLevel Method
TnxZipCompressor3 Class TnxZipCompressor3 Members nxllZipCompressor Namespace TnxZipCompressor3 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor3 Methods

Links
TnxZipCompressor3 Class, TnxZipCompressor3 Members, nxllZipCompressor Namespace, TnxZipCompressor3 Methods


TnxZipCompressor4 Class

TnxZipCompressor4 Class
TnxZipCompressor4 Methods TnxZipCompressor4 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor4nxllZipCompressor_TnxZipCompressor4nxllZipCompressor_TnxZipCompressor4nxllZipCompressor_TnxZipCompressor4
Syntax
Delphi
TnxZipCompressor4 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor4.

Group

Classes

Links
TnxZipCompressor4 Methods, TnxZipCompressor4 Members, nxllZipCompressor, Classes


TnxZipCompressor4 Members

TnxZipCompressor4 Members
TnxZipCompressor4 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor4.

Class

TnxZipCompressor4 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor4 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor4 Methods

TnxZipCompressor4 Methods
TnxZipCompressor4 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor4 class are listed here.

Class

TnxZipCompressor4 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor4 Class, Legend, Protected Methods


TnxZipCompressor4.zcCompressionLevel Method

TnxZipCompressor4.zcCompressionLevel Method
TnxZipCompressor4 Class TnxZipCompressor4 Members nxllZipCompressor Namespace TnxZipCompressor4 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor4 Methods

Links
TnxZipCompressor4 Class, TnxZipCompressor4 Members, nxllZipCompressor Namespace, TnxZipCompressor4 Methods


TnxZipCompressor5 Class

TnxZipCompressor5 Class
TnxZipCompressor5 Methods TnxZipCompressor5 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor5nxllZipCompressor_TnxZipCompressor5nxllZipCompressor_TnxZipCompressor5nxllZipCompressor_TnxZipCompressor5
Syntax
Delphi
TnxZipCompressor5 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor5.

Group

Classes

Links
TnxZipCompressor5 Methods, TnxZipCompressor5 Members, nxllZipCompressor, Classes


TnxZipCompressor5 Members

TnxZipCompressor5 Members
TnxZipCompressor5 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor5.

Class

TnxZipCompressor5 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor5 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor5 Methods

TnxZipCompressor5 Methods
TnxZipCompressor5 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor5 class are listed here.

Class

TnxZipCompressor5 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor5 Class, Legend, Protected Methods


TnxZipCompressor5.zcCompressionLevel Method

TnxZipCompressor5.zcCompressionLevel Method
TnxZipCompressor5 Class TnxZipCompressor5 Members nxllZipCompressor Namespace TnxZipCompressor5 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor5 Methods

Links
TnxZipCompressor5 Class, TnxZipCompressor5 Members, nxllZipCompressor Namespace, TnxZipCompressor5 Methods


TnxZipCompressor6 Class

TnxZipCompressor6 Class
TnxZipCompressor6 Methods TnxZipCompressor6 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor6nxllZipCompressor_TnxZipCompressor6nxllZipCompressor_TnxZipCompressor6nxllZipCompressor_TnxZipCompressor6
Syntax
Delphi
TnxZipCompressor6 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor6.

Group

Classes

Links
TnxZipCompressor6 Methods, TnxZipCompressor6 Members, nxllZipCompressor, Classes


TnxZipCompressor6 Members

TnxZipCompressor6 Members
TnxZipCompressor6 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor6.

Class

TnxZipCompressor6 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor6 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor6 Methods

TnxZipCompressor6 Methods
TnxZipCompressor6 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor6 class are listed here.

Class

TnxZipCompressor6 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor6 Class, Legend, Protected Methods


TnxZipCompressor6.zcCompressionLevel Method

TnxZipCompressor6.zcCompressionLevel Method
TnxZipCompressor6 Class TnxZipCompressor6 Members nxllZipCompressor Namespace TnxZipCompressor6 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor6 Methods

Links
TnxZipCompressor6 Class, TnxZipCompressor6 Members, nxllZipCompressor Namespace, TnxZipCompressor6 Methods


TnxZipCompressor7 Class

TnxZipCompressor7 Class
TnxZipCompressor7 Methods TnxZipCompressor7 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor7nxllZipCompressor_TnxZipCompressor7nxllZipCompressor_TnxZipCompressor7nxllZipCompressor_TnxZipCompressor7
Syntax
Delphi
TnxZipCompressor7 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor7.

Group

Classes

Links
TnxZipCompressor7 Methods, TnxZipCompressor7 Members, nxllZipCompressor, Classes


TnxZipCompressor7 Members

TnxZipCompressor7 Members
TnxZipCompressor7 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor7.

Class

TnxZipCompressor7 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor7 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor7 Methods

TnxZipCompressor7 Methods
TnxZipCompressor7 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor7 class are listed here.

Class

TnxZipCompressor7 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor7 Class, Legend, Protected Methods


TnxZipCompressor7.zcCompressionLevel Method

TnxZipCompressor7.zcCompressionLevel Method
TnxZipCompressor7 Class TnxZipCompressor7 Members nxllZipCompressor Namespace TnxZipCompressor7 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor7 Methods

Links
TnxZipCompressor7 Class, TnxZipCompressor7 Members, nxllZipCompressor Namespace, TnxZipCompressor7 Methods


TnxZipCompressor8 Class

TnxZipCompressor8 Class
TnxZipCompressor8 Methods TnxZipCompressor8 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor8nxllZipCompressor_TnxZipCompressor8nxllZipCompressor_TnxZipCompressor8nxllZipCompressor_TnxZipCompressor8
Syntax
Delphi
TnxZipCompressor8 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor8.

Group

Classes

Links
TnxZipCompressor8 Methods, TnxZipCompressor8 Members, nxllZipCompressor, Classes


TnxZipCompressor8 Members

TnxZipCompressor8 Members
TnxZipCompressor8 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor8.

Class

TnxZipCompressor8 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor8 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor8 Methods

TnxZipCompressor8 Methods
TnxZipCompressor8 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor8 class are listed here.

Class

TnxZipCompressor8 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor8 Class, Legend, Protected Methods


TnxZipCompressor8.zcCompressionLevel Method

TnxZipCompressor8.zcCompressionLevel Method
TnxZipCompressor8 Class TnxZipCompressor8 Members nxllZipCompressor Namespace TnxZipCompressor8 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor8 Methods

Links
TnxZipCompressor8 Class, TnxZipCompressor8 Members, nxllZipCompressor Namespace, TnxZipCompressor8 Methods


TnxZipCompressor9 Class

TnxZipCompressor9 Class
TnxZipCompressor9 Methods TnxZipCompressor9 Members nxllZipCompressor Classes Send Feedback
Class Hierarchy
nxllZipCompressor_TnxZipCompressor9nxllZipCompressor_TnxZipCompressor9nxllZipCompressor_TnxZipCompressor9nxllZipCompressor_TnxZipCompressor9
Syntax
Delphi
TnxZipCompressor9 = class(TnxZipCompressor);
File

nxllZipCompressor

Description

This is class nxllZipCompressor.TnxZipCompressor9.

Group

Classes

Links
TnxZipCompressor9 Methods, TnxZipCompressor9 Members, nxllZipCompressor, Classes


TnxZipCompressor9 Members

TnxZipCompressor9 Members
TnxZipCompressor9 Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxZipCompressor9.

Class

TnxZipCompressor9 Class

Protected Methods
Name | Description
Register |
UnRegister |
zcCompressionLevel |
Public Methods
Name | Description
Compress | abstract; TnxBaseCompressor
Compress |
FreeInstance |
NewInstance | TnxObject
Uncompress | abstract;
Uncompress |
Links
TnxZipCompressor9 Class, Legend, Protected Methods, Public Methods


TnxZipCompressor9 Methods

TnxZipCompressor9 Methods
TnxZipCompressor9 Class Legend Protected Methods Send Feedback

The methods of the TnxZipCompressor9 class are listed here.

Class

TnxZipCompressor9 Class

Protected Methods
Name | Description
zcCompressionLevel |
Links
TnxZipCompressor9 Class, Legend, Protected Methods


TnxZipCompressor9.zcCompressionLevel Method

TnxZipCompressor9.zcCompressionLevel Method
TnxZipCompressor9 Class TnxZipCompressor9 Members nxllZipCompressor Namespace TnxZipCompressor9 Methods Send Feedback
Syntax
Delphi
class function zcCompressionLevel: Integer; override;
Group

TnxZipCompressor9 Methods

Links
TnxZipCompressor9 Class, TnxZipCompressor9 Members, nxllZipCompressor Namespace, TnxZipCompressor9 Methods


nxllZLib Namespace

nxllZLib Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

ZLibExApi.pas

copyright (c) 2000-2010 base2 technologies copyright (c) 1995-2002 Borland Software Corporation

revision history 2010.04.20 updated to zlib version 1.2.5 2010.04.15 updated to zlib version 1.2.4 2005.07.25 updated to zlib version 1.2.3 2005.01.11 updated to zlib version 1.2.2 2004.01.06 updated to zlib version 1.2.1 2002.03.15 updated to zlib version 1.1.4

acknowledgments burak kalayci 2002.03.15 informing me about the zlib 1.1.4 update 2004.01.06 informing me about the zlib 1.2.1 update

vicente sanchez-alarcos 2005.01.11 informing me about the zlib 1.2.2 update

mathijs van veluw 2005.07.25 informing me about the zlib 1.2.3 update

Constants
Name | Description
_z_errmsg | return code messages
Z_ASCII | This is constant nxllZLib.Z_ASCII.
Z_BEST_COMPRESSION | This is constant nxllZLib.Z_BEST_COMPRESSION.
Z_BEST_SPEED | This is constant nxllZLib.Z_BEST_SPEED.
Z_BINARY | data types
Z_BLOCK | This is constant nxllZLib.Z_BLOCK.
Z_BUF_ERROR | This is constant nxllZLib.Z_BUF_ERROR.
Z_DATA_ERROR | This is constant nxllZLib.Z_DATA_ERROR.
Z_DEFAULT_COMPRESSION | This is constant nxllZLib.Z_DEFAULT_COMPRESSION.
Z_DEFAULT_STRATEGY | This is constant nxllZLib.Z_DEFAULT_STRATEGY.
Z_DEFLATED | compression methods
Z_ERRNO | This is constant nxllZLib.Z_ERRNO.
Z_FILTERED | compression strategies
Z_FINISH | This is constant nxllZLib.Z_FINISH.
Z_FIXED | This is constant nxllZLib.Z_FIXED.
Z_FULL_FLUSH | This is constant nxllZLib.Z_FULL_FLUSH.
Z_HUFFMAN_ONLY | This is constant nxllZLib.Z_HUFFMAN_ONLY.
Z_INFO_DEFAULT | This is constant nxllZLib.Z_INFO_DEFAULT.
Z_INFO_FLAG_ADLER | This is constant nxllZLib.Z_INFO_FLAG_ADLER.
Z_INFO_FLAG_CRC | This is constant nxllZLib.Z_INFO_FLAG_CRC.
Z_INFO_FLAG_SIZE | information flags
Z_INFO_NONE | This is constant nxllZLib.Z_INFO_NONE.
Z_MEM_ERROR | This is constant nxllZLib.Z_MEM_ERROR.
Z_NEED_DICT | This is constant nxllZLib.Z_NEED_DICT.
Z_NO_COMPRESSION | compression levels
Z_NO_FLUSH | flush constants
Z_OK | return codes
Z_PARTIAL_FLUSH | This is constant nxllZLib.Z_PARTIAL_FLUSH.
Z_RLE | This is constant nxllZLib.Z_RLE.
Z_STREAM_END | This is constant nxllZLib.Z_STREAM_END.
Z_STREAM_ERROR | This is constant nxllZLib.Z_STREAM_ERROR.
Z_SYNC_FLUSH | This is constant nxllZLib.Z_SYNC_FLUSH.
Z_TEXT | This is constant nxllZLib.Z_TEXT.
Z_TREES | This is constant nxllZLib.Z_TREES.
Z_UNKNOWN | This is constant nxllZLib.Z_UNKNOWN.
Z_VERSION_ERROR | This is constant nxllZLib.Z_VERSION_ERROR.
ZLIB_VER_MAJOR | This is constant nxllZLib.ZLIB_VER_MAJOR.
ZLIB_VER_MINOR | This is constant nxllZLib.ZLIB_VER_MINOR.
ZLIB_VER_REVISION | This is constant nxllZLib.ZLIB_VER_REVISION.
ZLIB_VER_SUBREVISION | This is constant nxllZLib.ZLIB_VER_SUBREVISION.
ZLIB_VERNUM | This is constant nxllZLib.ZLIB_VERNUM.
ZLIB_VERSION | version ids
Functions
Name | Description
adler32 | This is function nxllZLib.adler32.
crc32 | This is function nxllZLib.crc32.
deflate | This is function nxllZLib.deflate.
deflateEnd | This is function nxllZLib.deflateEnd.
deflateInit | macros macros
deflateInit_ | external routines external routines
deflateInit2 | This is function nxllZLib.deflateInit2.
deflateInit2_ | This is function nxllZLib.deflateInit2_.
deflateReset | This is function nxllZLib.deflateReset.
inflate | This is function nxllZLib.inflate.
inflateEnd | This is function nxllZLib.inflateEnd.
inflateInit | This is function nxllZLib.inflateInit.
inflateInit_ | This is function nxllZLib.inflateInit_.
inflateInit2 | This is function nxllZLib.inflateInit2.
inflateInit2_ | This is function nxllZLib.inflateInit2_.
inflateReset | This is function nxllZLib.inflateReset.
Structs, Records, Enums
Name | Description
TZStreamRec | TZStreamRec
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TZAlloc | This is type nxllZLib.TZAlloc.
TZFree | This is type nxllZLib.TZFree.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Functions

Functions
Functions nxllZLib Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
adler32 | This is function nxllZLib.adler32.
crc32 | This is function nxllZLib.crc32.
deflate | This is function nxllZLib.deflate.
deflateEnd | This is function nxllZLib.deflateEnd.
deflateInit | macros macros
deflateInit_ | external routines external routines
deflateInit2 | This is function nxllZLib.deflateInit2.
deflateInit2_ | This is function nxllZLib.deflateInit2_.
deflateReset | This is function nxllZLib.deflateReset.
inflate | This is function nxllZLib.inflate.
inflateEnd | This is function nxllZLib.inflateEnd.
inflateInit | This is function nxllZLib.inflateInit.
inflateInit_ | This is function nxllZLib.inflateInit_.
inflateInit2 | This is function nxllZLib.inflateInit2.
inflateInit2_ | This is function nxllZLib.inflateInit2_.
inflateReset | This is function nxllZLib.inflateReset.
Namespace

nxllZLib Namespace

Links
Functions, nxllZLib Namespace, Legend


nxllZLib.adler32 Function

nxllZLib.adler32 Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function adler32(adler: Longint; const buf; len: Integer): Longint;
File

nxllZLib

Description

This is function nxllZLib.adler32.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.crc32 Function

nxllZLib.crc32 Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function crc32(crc: Longint; const buf; len: Integer): Longint;
File

nxllZLib

Description

This is function nxllZLib.crc32.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflate Function

nxllZLib.deflate Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflate(var strm: TZStreamRec; flush: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.deflate.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateEnd Function

nxllZLib.deflateEnd Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateEnd(var strm: TZStreamRec): Integer;
File

nxllZLib

Description

This is function nxllZLib.deflateEnd.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateInit Function

nxllZLib.deflateInit Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateInit(var strm: TZStreamRec; level: Integer): Integer;
File

nxllZLib

Description

macros

macros

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateInit_ Function

nxllZLib.deflateInit_ Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateInit_(var strm: TZStreamRec; level: Integer; version: PAnsiChar; recsize: Integer): Integer;
File

nxllZLib

Description

external routines

external routines

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateInit2 Function

nxllZLib.deflateInit2 Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateInit2(var strm: TZStreamRec; level: Integer; method: Integer; windowBits: Integer; memLevel: Integer; strategy: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.deflateInit2.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateInit2_ Function

nxllZLib.deflateInit2_ Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateInit2_(var strm: TZStreamRec; level: Integer; method: Integer; windowBits: Integer; memLevel: Integer; strategy: Integer; version: PAnsiChar; recsize: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.deflateInit2_.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.deflateReset Function

nxllZLib.deflateReset Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function deflateReset(var strm: TZStreamRec): Integer;
File

nxllZLib

Description

This is function nxllZLib.deflateReset.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflate Function

nxllZLib.inflate Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflate(var strm: TZStreamRec; flush: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflate.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateEnd Function

nxllZLib.inflateEnd Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateEnd(var strm: TZStreamRec): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateEnd.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateInit Function

nxllZLib.inflateInit Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateInit(var strm: TZStreamRec): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateInit.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateInit_ Function

nxllZLib.inflateInit_ Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateInit_(var strm: TZStreamRec; version: PAnsiChar; recsize: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateInit_.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateInit2 Function

nxllZLib.inflateInit2 Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateInit2(var strm: TZStreamRec; windowBits: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateInit2.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateInit2_ Function

nxllZLib.inflateInit2_ Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateInit2_(var strm: TZStreamRec; windowBits: Integer; version: PAnsiChar; recsize: Integer): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateInit2_.

Group

Functions

Links
nxllZLib, Functions


nxllZLib.inflateReset Function

nxllZLib.inflateReset Function
nxllZLib Functions Send Feedback
Syntax
Delphi
function inflateReset(var strm: TZStreamRec): Integer;
File

nxllZLib

Description

This is function nxllZLib.inflateReset.

Group

Functions

Links
nxllZLib, Functions


Structs, Records, Enums

Structs, Records, Enums
nxllZLib Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxllZLib Namespace

Records
Name | Description
TZStreamRec | TZStreamRec
Links
nxllZLib Namespace, Legend, Records


nxllZLib.TZStreamRec Record

nxllZLib.TZStreamRec Record
nxllZLib Structs, Records, Enums Send Feedback
Syntax
Delphi
TZStreamRec = packed record
  next_in: Pointer;
  avail_in: Longint;
  total_in: Longint;
  next_out: Pointer;
  avail_out: Longint;
  total_out: Longint;
  msg: Pointer;
  state: Pointer;
  zalloc: TZAlloc;
  zfree: TZFree;
  opaque: Pointer;
  data_type: Integer;
  adler: Longint;
  reserved: Longint;
end;
File

nxllZLib

Members
Members | Description
next_in: Pointer; | next input byte
avail_in: Longint; | number of bytes available at next_in
total_in: Longint; | total nb of input bytes read so far
next_out: Pointer; | next output byte should be put here
avail_out: Longint; | remaining free space at next_out
total_out: Longint; | total nb of bytes output so far
msg: Pointer; | last error message, NULL if no error
state: Pointer; | not visible by applications
zalloc: TZAlloc; | used to allocate the internal state
zfree: TZFree; | used to free the internal state
opaque: Pointer; | private data object passed to zalloc and zfree
data_type: Integer; | best guess about the data type: ascii or binary
adler: Longint; | adler32 value of the uncompressed data
reserved: Longint; | reserved for future use
Description

TZStreamRec

Group

Structs, Records, Enums

Links
nxllZLib, Structs, Records, Enums


Types

Types
nxllZLib Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxllZLib Namespace

Types
Name | Description
TZAlloc | This is type nxllZLib.TZAlloc.
TZFree | This is type nxllZLib.TZFree.
Links
nxllZLib Namespace, Types


nxllZLib.TZAlloc Type

nxllZLib.TZAlloc Type
nxllZLib Types Send Feedback
Syntax
Delphi
TZAlloc = function (opaque: Pointer; items, size: Integer): Pointer;
File

nxllZLib

Description

This is type nxllZLib.TZAlloc.

Group

Types

Links
nxllZLib, Types


nxllZLib.TZFree Type

nxllZLib.TZFree Type
nxllZLib Types Send Feedback
Syntax
Delphi
TZFree = procedure (opaque, block: Pointer);
File

nxllZLib

Description

This is type nxllZLib.TZFree.

Group

Types

Links
nxllZLib, Types


Constants

Constants
Constants nxllZLib Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_z_errmsg | return code messages
Z_ASCII | This is constant nxllZLib.Z_ASCII.
Z_BEST_COMPRESSION | This is constant nxllZLib.Z_BEST_COMPRESSION.
Z_BEST_SPEED | This is constant nxllZLib.Z_BEST_SPEED.
Z_BINARY | data types
Z_BLOCK | This is constant nxllZLib.Z_BLOCK.
Z_BUF_ERROR | This is constant nxllZLib.Z_BUF_ERROR.
Z_DATA_ERROR | This is constant nxllZLib.Z_DATA_ERROR.
Z_DEFAULT_COMPRESSION | This is constant nxllZLib.Z_DEFAULT_COMPRESSION.
Z_DEFAULT_STRATEGY | This is constant nxllZLib.Z_DEFAULT_STRATEGY.
Z_DEFLATED | compression methods
Z_ERRNO | This is constant nxllZLib.Z_ERRNO.
Z_FILTERED | compression strategies
Z_FINISH | This is constant nxllZLib.Z_FINISH.
Z_FIXED | This is constant nxllZLib.Z_FIXED.
Z_FULL_FLUSH | This is constant nxllZLib.Z_FULL_FLUSH.
Z_HUFFMAN_ONLY | This is constant nxllZLib.Z_HUFFMAN_ONLY.
Z_INFO_DEFAULT | This is constant nxllZLib.Z_INFO_DEFAULT.
Z_INFO_FLAG_ADLER | This is constant nxllZLib.Z_INFO_FLAG_ADLER.
Z_INFO_FLAG_CRC | This is constant nxllZLib.Z_INFO_FLAG_CRC.
Z_INFO_FLAG_SIZE | information flags
Z_INFO_NONE | This is constant nxllZLib.Z_INFO_NONE.
Z_MEM_ERROR | This is constant nxllZLib.Z_MEM_ERROR.
Z_NEED_DICT | This is constant nxllZLib.Z_NEED_DICT.
Z_NO_COMPRESSION | compression levels
Z_NO_FLUSH | flush constants
Z_OK | return codes
Z_PARTIAL_FLUSH | This is constant nxllZLib.Z_PARTIAL_FLUSH.
Z_RLE | This is constant nxllZLib.Z_RLE.
Z_STREAM_END | This is constant nxllZLib.Z_STREAM_END.
Z_STREAM_ERROR | This is constant nxllZLib.Z_STREAM_ERROR.
Z_SYNC_FLUSH | This is constant nxllZLib.Z_SYNC_FLUSH.
Z_TEXT | This is constant nxllZLib.Z_TEXT.
Z_TREES | This is constant nxllZLib.Z_TREES.
Z_UNKNOWN | This is constant nxllZLib.Z_UNKNOWN.
Z_VERSION_ERROR | This is constant nxllZLib.Z_VERSION_ERROR.
ZLIB_VER_MAJOR | This is constant nxllZLib.ZLIB_VER_MAJOR.
ZLIB_VER_MINOR | This is constant nxllZLib.ZLIB_VER_MINOR.
ZLIB_VER_REVISION | This is constant nxllZLib.ZLIB_VER_REVISION.
ZLIB_VER_SUBREVISION | This is constant nxllZLib.ZLIB_VER_SUBREVISION.
ZLIB_VERNUM | This is constant nxllZLib.ZLIB_VERNUM.
ZLIB_VERSION | version ids
Namespace

nxllZLib Namespace

Links
Constants, nxllZLib Namespace


nxllZLib._z_errmsg Constant

nxllZLib._z_errmsg Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
_z_errmsg: array[-2..7] of string = ( 'need dictionary', 'stream end', '', 'file error', 'stream error', 'data error', 'insufficient memory', 'buffer error', 'incompatible version', '' );
File

nxllZLib

Description

return code messages

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_ASCII Constant

nxllZLib.Z_ASCII Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_ASCII = 1;
File

nxllZLib

Description

This is constant nxllZLib.Z_ASCII.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_BEST_COMPRESSION Constant

nxllZLib.Z_BEST_COMPRESSION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_BEST_COMPRESSION = 9;
File

nxllZLib

Description

This is constant nxllZLib.Z_BEST_COMPRESSION.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_BEST_SPEED Constant

nxllZLib.Z_BEST_SPEED Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_BEST_SPEED = 1;
File

nxllZLib

Description

This is constant nxllZLib.Z_BEST_SPEED.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_BINARY Constant

nxllZLib.Z_BINARY Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_BINARY = 0;
File

nxllZLib

Description

data types

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_BLOCK Constant

nxllZLib.Z_BLOCK Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_BLOCK = 5;
File

nxllZLib

Description

This is constant nxllZLib.Z_BLOCK.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_BUF_ERROR Constant

nxllZLib.Z_BUF_ERROR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_BUF_ERROR = (-5);
File

nxllZLib

Description

This is constant nxllZLib.Z_BUF_ERROR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_DATA_ERROR Constant

nxllZLib.Z_DATA_ERROR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_DATA_ERROR = (-3);
File

nxllZLib

Description

This is constant nxllZLib.Z_DATA_ERROR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_DEFAULT_COMPRESSION Constant

nxllZLib.Z_DEFAULT_COMPRESSION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_DEFAULT_COMPRESSION = (-1);
File

nxllZLib

Description

This is constant nxllZLib.Z_DEFAULT_COMPRESSION.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_DEFAULT_STRATEGY Constant

nxllZLib.Z_DEFAULT_STRATEGY Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_DEFAULT_STRATEGY = 0;
File

nxllZLib

Description

This is constant nxllZLib.Z_DEFAULT_STRATEGY.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_DEFLATED Constant

nxllZLib.Z_DEFLATED Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_DEFLATED = 8;
File

nxllZLib

Description

compression methods

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_ERRNO Constant

nxllZLib.Z_ERRNO Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_ERRNO = (-1);
File

nxllZLib

Description

This is constant nxllZLib.Z_ERRNO.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_FILTERED Constant

nxllZLib.Z_FILTERED Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_FILTERED = 1;
File

nxllZLib

Description

compression strategies

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_FINISH Constant

nxllZLib.Z_FINISH Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_FINISH = 4;
File

nxllZLib

Description

This is constant nxllZLib.Z_FINISH.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_FIXED Constant

nxllZLib.Z_FIXED Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_FIXED = 4;
File

nxllZLib

Description

This is constant nxllZLib.Z_FIXED.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_FULL_FLUSH Constant

nxllZLib.Z_FULL_FLUSH Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_FULL_FLUSH = 3;
File

nxllZLib

Description

This is constant nxllZLib.Z_FULL_FLUSH.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_HUFFMAN_ONLY Constant

nxllZLib.Z_HUFFMAN_ONLY Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_HUFFMAN_ONLY = 2;
File

nxllZLib

Description

This is constant nxllZLib.Z_HUFFMAN_ONLY.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_INFO_DEFAULT Constant

nxllZLib.Z_INFO_DEFAULT Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_INFO_DEFAULT = Z_INFO_FLAG_SIZE or Z_INFO_FLAG_CRC;
File

nxllZLib

Description

This is constant nxllZLib.Z_INFO_DEFAULT.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_INFO_FLAG_ADLER Constant

nxllZLib.Z_INFO_FLAG_ADLER Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_INFO_FLAG_ADLER = $4;
File

nxllZLib

Description

This is constant nxllZLib.Z_INFO_FLAG_ADLER.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_INFO_FLAG_CRC Constant

nxllZLib.Z_INFO_FLAG_CRC Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_INFO_FLAG_CRC = $2;
File

nxllZLib

Description

This is constant nxllZLib.Z_INFO_FLAG_CRC.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_INFO_FLAG_SIZE Constant

nxllZLib.Z_INFO_FLAG_SIZE Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_INFO_FLAG_SIZE = $1;
File

nxllZLib

Description

information flags

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_INFO_NONE Constant

nxllZLib.Z_INFO_NONE Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_INFO_NONE = 0;
File

nxllZLib

Description

This is constant nxllZLib.Z_INFO_NONE.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_MEM_ERROR Constant

nxllZLib.Z_MEM_ERROR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_MEM_ERROR = (-4);
File

nxllZLib

Description

This is constant nxllZLib.Z_MEM_ERROR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_NEED_DICT Constant

nxllZLib.Z_NEED_DICT Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_NEED_DICT = 2;
File

nxllZLib

Description

This is constant nxllZLib.Z_NEED_DICT.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_NO_COMPRESSION Constant

nxllZLib.Z_NO_COMPRESSION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_NO_COMPRESSION = 0;
File

nxllZLib

Description

compression levels

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_NO_FLUSH Constant

nxllZLib.Z_NO_FLUSH Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_NO_FLUSH = 0;
File

nxllZLib

Description

flush constants

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_OK Constant

nxllZLib.Z_OK Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_OK = 0;
File

nxllZLib

Description

return codes

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_PARTIAL_FLUSH Constant

nxllZLib.Z_PARTIAL_FLUSH Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_PARTIAL_FLUSH = 1;
File

nxllZLib

Description

This is constant nxllZLib.Z_PARTIAL_FLUSH.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_RLE Constant

nxllZLib.Z_RLE Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_RLE = 3;
File

nxllZLib

Description

This is constant nxllZLib.Z_RLE.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_STREAM_END Constant

nxllZLib.Z_STREAM_END Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_STREAM_END = 1;
File

nxllZLib

Description

This is constant nxllZLib.Z_STREAM_END.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_STREAM_ERROR Constant

nxllZLib.Z_STREAM_ERROR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_STREAM_ERROR = (-2);
File

nxllZLib

Description

This is constant nxllZLib.Z_STREAM_ERROR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_SYNC_FLUSH Constant

nxllZLib.Z_SYNC_FLUSH Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_SYNC_FLUSH = 2;
File

nxllZLib

Description

This is constant nxllZLib.Z_SYNC_FLUSH.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_TEXT Constant

nxllZLib.Z_TEXT Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_TEXT = Z_ASCII;
File

nxllZLib

Description

This is constant nxllZLib.Z_TEXT.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_TREES Constant

nxllZLib.Z_TREES Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_TREES = 6;
File

nxllZLib

Description

This is constant nxllZLib.Z_TREES.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_UNKNOWN Constant

nxllZLib.Z_UNKNOWN Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_UNKNOWN = 2;
File

nxllZLib

Description

This is constant nxllZLib.Z_UNKNOWN.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.Z_VERSION_ERROR Constant

nxllZLib.Z_VERSION_ERROR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
Z_VERSION_ERROR = (-6);
File

nxllZLib

Description

This is constant nxllZLib.Z_VERSION_ERROR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VER_MAJOR Constant

nxllZLib.ZLIB_VER_MAJOR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VER_MAJOR = 1;
File

nxllZLib

Description

This is constant nxllZLib.ZLIB_VER_MAJOR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VER_MINOR Constant

nxllZLib.ZLIB_VER_MINOR Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VER_MINOR = 2;
File

nxllZLib

Description

This is constant nxllZLib.ZLIB_VER_MINOR.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VER_REVISION Constant

nxllZLib.ZLIB_VER_REVISION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VER_REVISION = 5;
File

nxllZLib

Description

This is constant nxllZLib.ZLIB_VER_REVISION.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VER_SUBREVISION Constant

nxllZLib.ZLIB_VER_SUBREVISION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VER_SUBREVISION = 0;
File

nxllZLib

Description

This is constant nxllZLib.ZLIB_VER_SUBREVISION.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VERNUM Constant

nxllZLib.ZLIB_VERNUM Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VERNUM = $1250;
File

nxllZLib

Description

This is constant nxllZLib.ZLIB_VERNUM.

Group

Constants

Links
nxllZLib, Constants


nxllZLib.ZLIB_VERSION Constant

nxllZLib.ZLIB_VERSION Constant
nxllZLib Constants Send Feedback
Syntax
Delphi
ZLIB_VERSION = '1.2.5';
File

nxllZLib

Description

version ids

Group

Constants

Links
nxllZLib, Constants


nxmmBitmapUtils Namespace

nxmmBitmapUtils Namespace
Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmmBitmapUtils.

Functions
Name | Description
AddRef | This is function nxmmBitmapUtils.AddRef.
nxBitmapClear | Resets all bits
nxBitmapComplement | Threadsafe complements the specified bit and returns the old value of the bit.
nxBitmapComplementCascade | This is function nxmmBitmapUtils.nxBitmapComplementCascade.
nxBitmapFindLSB | Threadsafe returns the LSB set. Returns -1 if non found.
nxBitmapFindMSB | Threadsafe returns the MSB set. Returns -1 if non found.
nxBitmapIsBitSet | This is function nxmmBitmapUtils.nxBitmapIsBitSet.
nxBitmapMoveOr | Threadsafe moves all set bits from Source to Target
nxBitmapRebuildLevel1 | Rebuilds Level1 based on Level2
nxBitmapReset | Threadsafe resets the specified bit and returns true if the operation was successful (= bit was set)
nxBitmapResetLSB | Threadsafe returns the LSB set and resets it. Returns -1 if non found.
nxBitmapResetMSB | Threadsafe returns the MSB set and resets it. Returns -1 if non found.
nxBitmapResetMSBCascade | This is function nxmmBitmapUtils.nxBitmapResetMSBCascade.
nxBitmapSet | Threadsafe sets the specified bit and returns true if the operation was successful (= bit was not set)
nxBitmapSetCascade | This is function nxmmBitmapUtils.nxBitmapSetCascade.
Release | This is function nxmmBitmapUtils.Release.
Structs, Records, Enums
Name | Description
TnxBitmap | This is record nxmmBitmapUtils.TnxBitmap.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxBitmap | This is type nxmmBitmapUtils.PnxBitmap.
TnxBitmapArray | 1024 bits
Variables
Name | Description
_RefCount | This is variable nxmmBitmapUtils._RefCount.
Links
Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxmmBitmapUtils Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmBitmapUtils.AddRef.
nxBitmapClear | Resets all bits
nxBitmapComplement | Threadsafe complements the specified bit and returns the old value of the bit.
nxBitmapComplementCascade | This is function nxmmBitmapUtils.nxBitmapComplementCascade.
nxBitmapFindLSB | Threadsafe returns the LSB set. Returns -1 if non found.
nxBitmapFindMSB | Threadsafe returns the MSB set. Returns -1 if non found.
nxBitmapIsBitSet | This is function nxmmBitmapUtils.nxBitmapIsBitSet.
nxBitmapMoveOr | Threadsafe moves all set bits from Source to Target
nxBitmapRebuildLevel1 | Rebuilds Level1 based on Level2
nxBitmapReset | Threadsafe resets the specified bit and returns true if the operation was successful (= bit was set)
nxBitmapResetLSB | Threadsafe returns the LSB set and resets it. Returns -1 if non found.
nxBitmapResetMSB | Threadsafe returns the MSB set and resets it. Returns -1 if non found.
nxBitmapResetMSBCascade | This is function nxmmBitmapUtils.nxBitmapResetMSBCascade.
nxBitmapSet | Threadsafe sets the specified bit and returns true if the operation was successful (= bit was not set)
nxBitmapSetCascade | This is function nxmmBitmapUtils.nxBitmapSetCascade.
Release | This is function nxmmBitmapUtils.Release.
Namespace

nxmmBitmapUtils Namespace

Links
Functions, nxmmBitmapUtils Namespace, Legend


nxmmBitmapUtils.AddRef Function

nxmmBitmapUtils.AddRef Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.AddRef.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapClear Function

nxmmBitmapUtils.nxBitmapClear Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
procedure nxBitmapClear(var aBitmap: TnxBitmap);
File

nxmmBitmapUtils

Description

Resets all bits

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapComplement Function

nxmmBitmapUtils.nxBitmapComplement Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapComplement(var aBitmap: TnxBitmap; aIndex: Integer): Boolean;
File

nxmmBitmapUtils

Description

Threadsafe complements the specified bit and returns the old value of the bit.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapComplementCascade Function

nxmmBitmapUtils.nxBitmapComplementCascade Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapComplementCascade(var aBitmap: TnxBitmap; aIndex: Integer; var Cascade: Boolean): Boolean;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.nxBitmapComplementCascade.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapFindLSB Function

nxmmBitmapUtils.nxBitmapFindLSB Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapFindLSB(var aBitmap: TnxBitmap): Integer;
File

nxmmBitmapUtils

Description

Threadsafe returns the LSB set. Returns -1 if non found.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapFindMSB Function

nxmmBitmapUtils.nxBitmapFindMSB Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapFindMSB(var aBitmap: TnxBitmap): Integer;
File

nxmmBitmapUtils

Description

Threadsafe returns the MSB set. Returns -1 if non found.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapIsBitSet Function

nxmmBitmapUtils.nxBitmapIsBitSet Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapIsBitSet(const aBitmap: TnxBitmap; Bit: Integer): Boolean;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.nxBitmapIsBitSet.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapMoveOr Function

nxmmBitmapUtils.nxBitmapMoveOr Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
procedure nxBitmapMoveOr(var aSource: TnxBitmap; var aTarget: TnxBitmap);
File

nxmmBitmapUtils

Description

Threadsafe moves all set bits from Source to Target

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapRebuildLevel1 Function

nxmmBitmapUtils.nxBitmapRebuildLevel1 Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
procedure nxBitmapRebuildLevel1(var aBitmap: TnxBitmap);
File

nxmmBitmapUtils

Description

Rebuilds Level1 based on Level2

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapReset Function

nxmmBitmapUtils.nxBitmapReset Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapReset(var aBitmap: TnxBitmap; aIndex: Integer): Boolean;
File

nxmmBitmapUtils

Description

Threadsafe resets the specified bit and returns true if the operation was successful (= bit was set)

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapResetLSB Function

nxmmBitmapUtils.nxBitmapResetLSB Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapResetLSB(var aBitmap: TnxBitmap): Integer;
File

nxmmBitmapUtils

Description

Threadsafe returns the LSB set and resets it. Returns -1 if non found.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapResetMSB Function

nxmmBitmapUtils.nxBitmapResetMSB Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapResetMSB(var aBitmap: TnxBitmap): Integer;
File

nxmmBitmapUtils

Description

Threadsafe returns the MSB set and resets it. Returns -1 if non found.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapResetMSBCascade Function

nxmmBitmapUtils.nxBitmapResetMSBCascade Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapResetMSBCascade(var aBitmap: TnxBitmap; var Cascade: Boolean): Integer;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.nxBitmapResetMSBCascade.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapSet Function

nxmmBitmapUtils.nxBitmapSet Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapSet(var aBitmap: TnxBitmap; aIndex: Integer): Boolean;
File

nxmmBitmapUtils

Description

Threadsafe sets the specified bit and returns true if the operation was successful (= bit was not set)

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.nxBitmapSetCascade Function

nxmmBitmapUtils.nxBitmapSetCascade Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
function nxBitmapSetCascade(var aBitmap: TnxBitmap; aIndex: Integer; var Cascade: Boolean): Boolean;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.nxBitmapSetCascade.

Group

Functions

Links
nxmmBitmapUtils, Functions


nxmmBitmapUtils.Release Function

nxmmBitmapUtils.Release Function
nxmmBitmapUtils Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmBitmapUtils

Description

This is function nxmmBitmapUtils.Release.

Group

Functions

Links
nxmmBitmapUtils, Functions


Structs, Records, Enums

Structs, Records, Enums
nxmmBitmapUtils Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxmmBitmapUtils Namespace

Records
Name | Description
TnxBitmap | This is record nxmmBitmapUtils.TnxBitmap.
Links
nxmmBitmapUtils Namespace, Legend, Records


nxmmBitmapUtils.TnxBitmap Record

nxmmBitmapUtils.TnxBitmap Record
nxmmBitmapUtils Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBitmap = record
  bmLevel1One: Cardinal;
  bmLevel1All: Cardinal;
  bmLevel2: TnxBitmapArray;
end;
File

nxmmBitmapUtils

Description

This is record nxmmBitmapUtils.TnxBitmap.

Group

Structs, Records, Enums

Links
nxmmBitmapUtils, Structs, Records, Enums


Types

Types
nxmmBitmapUtils Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmBitmapUtils Namespace

Types
Name | Description
PnxBitmap | This is type nxmmBitmapUtils.PnxBitmap.
TnxBitmapArray | 1024 bits
Links
nxmmBitmapUtils Namespace, Types


nxmmBitmapUtils.PnxBitmap Type

nxmmBitmapUtils.PnxBitmap Type
nxmmBitmapUtils Types Send Feedback
Syntax
Delphi
PnxBitmap = ^TnxBitmap;
File

nxmmBitmapUtils

Description

This is type nxmmBitmapUtils.PnxBitmap.

Group

Types

Links
nxmmBitmapUtils, Types


nxmmBitmapUtils.TnxBitmapArray Type

nxmmBitmapUtils.TnxBitmapArray Type
nxmmBitmapUtils Types Send Feedback
Syntax
Delphi
TnxBitmapArray = array[0..31] of Cardinal;
File

nxmmBitmapUtils

Description

1024 bits

Group

Types

Links
nxmmBitmapUtils, Types


Variables

Variables
nxmmBitmapUtils Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmBitmapUtils Namespace

Variables
Name | Description
_RefCount | This is variable nxmmBitmapUtils._RefCount.
Links
nxmmBitmapUtils Namespace, Variables


nxmmBitmapUtils._RefCount Variable

nxmmBitmapUtils._RefCount Variable
nxmmBitmapUtils Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmBitmapUtils

Description

This is variable nxmmBitmapUtils._RefCount.

Group

Variables

Links
nxmmBitmapUtils, Variables


nxmmBlockManagerBase Namespace

nxmmBlockManagerBase Namespace
Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmmBlockManagerBase.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerBase.AddRef.
Release | This is function nxmmBlockManagerBase.Release.
Structs, Records, Enums
Name | Description
TnxBlockHeader | This is record nxmmBlockManagerBase.TnxBlockHeader.
TnxBlockType | This is record nxmmBlockManagerBase.TnxBlockType.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxBitmaps | This is type nxmmBlockManagerBase.PnxBitmaps.
PnxBlockHeader | This is type nxmmBlockManagerBase.PnxBlockHeader.
PnxBlockHeaders | This is type nxmmBlockManagerBase.PnxBlockHeaders.
PnxBlockType | This is type nxmmBlockManagerBase.PnxBlockType.
PnxRegionBlockHeaders | This is type nxmmBlockManagerBase.PnxRegionBlockHeaders.
TnxBitmaps | This is type nxmmBlockManagerBase.TnxBitmaps.
TnxBlockHeaders | This is type nxmmBlockManagerBase.TnxBlockHeaders.
TnxRegionBlockHeaders | This is type nxmmBlockManagerBase.TnxRegionBlockHeaders.
Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerBase._nxBlockHeaders.
_nxBlockNeedReset | This is variable nxmmBlockManagerBase._nxBlockNeedReset.
_RefCount | This is variable nxmmBlockManagerBase._RefCount.
Links
Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxmmBlockManagerBase Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerBase.AddRef.
Release | This is function nxmmBlockManagerBase.Release.
Namespace

nxmmBlockManagerBase Namespace

Links
Functions, nxmmBlockManagerBase Namespace, Legend


nxmmBlockManagerBase.AddRef Function

nxmmBlockManagerBase.AddRef Function
nxmmBlockManagerBase Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmBlockManagerBase

Description

This is function nxmmBlockManagerBase.AddRef.

Group

Functions

Links
nxmmBlockManagerBase, Functions


nxmmBlockManagerBase.Release Function

nxmmBlockManagerBase.Release Function
nxmmBlockManagerBase Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmBlockManagerBase

Description

This is function nxmmBlockManagerBase.Release.

Group

Functions

Links
nxmmBlockManagerBase, Functions


Structs, Records, Enums

Structs, Records, Enums
nxmmBlockManagerBase Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxmmBlockManagerBase Namespace

Records
Name | Description
TnxBlockHeader | This is record nxmmBlockManagerBase.TnxBlockHeader.
TnxBlockType | This is record nxmmBlockManagerBase.TnxBlockType.
Links
nxmmBlockManagerBase Namespace, Legend, Records


nxmmBlockManagerBase.TnxBlockHeader Record

nxmmBlockManagerBase.TnxBlockHeader Record
nxmmBlockManagerBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlockHeader = record
  bhType: Pointer;
  bhChunkIndex: Cardinal;
  bhIndex: Cardinal;
  bhAvailable: TnxBitmap;
  bhRegionIndex: Cardinal;
  bhPadding: array[140..143] of Byte;
end;
File

nxmmBlockManagerBase

Description

This is record nxmmBlockManagerBase.TnxBlockHeader.

Group

Structs, Records, Enums

Links
nxmmBlockManagerBase, Structs, Records, Enums


nxmmBlockManagerBase.TnxBlockType Record

nxmmBlockManagerBase.TnxBlockType Record
nxmmBlockManagerBase Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlockType = record
  btShiftFactor: TnxNativeUInt;
  btSize: TnxNativeUInt;
  btAddrMask: TnxNativeUInt;
  btAddrMaskInv: TnxNativeUInt;
  btUsedBitmap: Cardinal;
  btLevel1Mask: Cardinal;
  btAvailableRegions: TnxBitmap;
  btAvailableChunks: TnxBitmaps;
  btAvailable: TnxBitmap;
end;
File

nxmmBlockManagerBase

Description

This is record nxmmBlockManagerBase.TnxBlockType.

Group

Structs, Records, Enums

Links
nxmmBlockManagerBase, Structs, Records, Enums


Types

Types
nxmmBlockManagerBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmBlockManagerBase Namespace

Types
Name | Description
PnxBitmaps | This is type nxmmBlockManagerBase.PnxBitmaps.
PnxBlockHeader | This is type nxmmBlockManagerBase.PnxBlockHeader.
PnxBlockHeaders | This is type nxmmBlockManagerBase.PnxBlockHeaders.
PnxBlockType | This is type nxmmBlockManagerBase.PnxBlockType.
PnxRegionBlockHeaders | This is type nxmmBlockManagerBase.PnxRegionBlockHeaders.
TnxBitmaps | This is type nxmmBlockManagerBase.TnxBitmaps.
TnxBlockHeaders | This is type nxmmBlockManagerBase.TnxBlockHeaders.
TnxRegionBlockHeaders | This is type nxmmBlockManagerBase.TnxRegionBlockHeaders.
Links
nxmmBlockManagerBase Namespace, Types


nxmmBlockManagerBase.PnxBitmaps Type

nxmmBlockManagerBase.PnxBitmaps Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
PnxBitmaps = ^TnxBitmaps;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.PnxBitmaps.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.PnxBlockHeader Type

nxmmBlockManagerBase.PnxBlockHeader Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
PnxBlockHeader = ^TnxBlockHeader;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.PnxBlockHeader.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.PnxBlockHeaders Type

nxmmBlockManagerBase.PnxBlockHeaders Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
PnxBlockHeaders = ^TnxBlockHeaders;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.PnxBlockHeaders.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.PnxBlockType Type

nxmmBlockManagerBase.PnxBlockType Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
PnxBlockType = ^TnxBlockType;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.PnxBlockType.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.PnxRegionBlockHeaders Type

nxmmBlockManagerBase.PnxRegionBlockHeaders Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
PnxRegionBlockHeaders = ^TnxRegionBlockHeaders;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.PnxRegionBlockHeaders.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.TnxBitmaps Type

nxmmBlockManagerBase.TnxBitmaps Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
TnxBitmaps = array [0..1023] of TnxBitmap;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.TnxBitmaps.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.TnxBlockHeaders Type

nxmmBlockManagerBase.TnxBlockHeaders Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
TnxBlockHeaders = array [0..1023] of TnxBlockHeader;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.TnxBlockHeaders.

Group

Types

Links
nxmmBlockManagerBase, Types


nxmmBlockManagerBase.TnxRegionBlockHeaders Type

nxmmBlockManagerBase.TnxRegionBlockHeaders Type
nxmmBlockManagerBase Types Send Feedback
Syntax
Delphi
TnxRegionBlockHeaders = array [0..1023] of TnxBlockHeader;
File

nxmmBlockManagerBase

Description

This is type nxmmBlockManagerBase.TnxRegionBlockHeaders.

Group

Types

Links
nxmmBlockManagerBase, Types


Variables

Variables
nxmmBlockManagerBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmBlockManagerBase Namespace

Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerBase._nxBlockHeaders.
_nxBlockNeedReset | This is variable nxmmBlockManagerBase._nxBlockNeedReset.
_RefCount | This is variable nxmmBlockManagerBase._RefCount.
Links
nxmmBlockManagerBase Namespace, Variables


nxmmBlockManagerBase._nxBlockHeaders Variable

nxmmBlockManagerBase._nxBlockHeaders Variable
nxmmBlockManagerBase Variables Send Feedback
Syntax
Delphi
_nxBlockHeaders: PnxBlockHeaders;
File

nxmmBlockManagerBase

Description

This is variable nxmmBlockManagerBase._nxBlockHeaders.

Group

Variables

Links
nxmmBlockManagerBase, Variables


nxmmBlockManagerBase._nxBlockNeedReset Variable

nxmmBlockManagerBase._nxBlockNeedReset Variable
nxmmBlockManagerBase Variables Send Feedback
Syntax
Delphi
_nxBlockNeedReset: PnxBitmaps;
File

nxmmBlockManagerBase

Description

This is variable nxmmBlockManagerBase._nxBlockNeedReset.

Group

Variables

Links
nxmmBlockManagerBase, Variables


nxmmBlockManagerBase._RefCount Variable

nxmmBlockManagerBase._RefCount Variable
nxmmBlockManagerBase Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmBlockManagerBase

Description

This is variable nxmmBlockManagerBase._RefCount.

Group

Variables

Links
nxmmBlockManagerBase, Variables


nxmmBlockManagerCommitted Namespace

nxmmBlockManagerCommitted Namespace
Functions Legend Topics Types Variables Send Feedback

This is namespace nxmmBlockManagerCommitted.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerCommitted.AddRef.
nxCommittedBlockAllocateBySize | Allocates a new block of the requested size. May return nil if out of memory
nxCommittedBlockAllocateByType | This is function nxmmBlockManagerCommitted.nxCommittedBlockAllocateByType.
nxCommittedBlockCleanup | This is function nxmmBlockManagerCommitted.nxCommittedBlockCleanup.
nxCommittedBlockDispose | Disposes a block, returns true if successful
nxCommittedBlockDisposeBySize | This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeBySize.
nxCommittedBlockDisposeByType | This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeByType.
Release | This is function nxmmBlockManagerCommitted.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxCommittedBlock | This is type nxmmBlockManagerCommitted.PnxCommittedBlock.
PnxCommittedBlockType | This is type nxmmBlockManagerCommitted.PnxCommittedBlockType.
TnxCommittedBlock | This is type nxmmBlockManagerCommitted.TnxCommittedBlock.
Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerCommitted._nxBlockHeaders.
_RefCount | This is variable nxmmBlockManagerCommitted._RefCount.
nxCommittedBlockTypes | This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypes.
nxCommittedBlockTypesPtr | This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypesPtr.
Links
Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxmmBlockManagerCommitted Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerCommitted.AddRef.
nxCommittedBlockAllocateBySize | Allocates a new block of the requested size. May return nil if out of memory
nxCommittedBlockAllocateByType | This is function nxmmBlockManagerCommitted.nxCommittedBlockAllocateByType.
nxCommittedBlockCleanup | This is function nxmmBlockManagerCommitted.nxCommittedBlockCleanup.
nxCommittedBlockDispose | Disposes a block, returns true if successful
nxCommittedBlockDisposeBySize | This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeBySize.
nxCommittedBlockDisposeByType | This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeByType.
Release | This is function nxmmBlockManagerCommitted.Release.
Namespace

nxmmBlockManagerCommitted Namespace

Links
Functions, nxmmBlockManagerCommitted Namespace, Legend


nxmmBlockManagerCommitted.AddRef Function

nxmmBlockManagerCommitted.AddRef Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.AddRef.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockAllocateBySize Function

nxmmBlockManagerCommitted.nxCommittedBlockAllocateBySize Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
function nxCommittedBlockAllocateBySize(aBlockSize: TnxBlockSizeAll; aLow: Boolean): PnxCommittedBlock; register;
File

nxmmBlockManagerCommitted

Description

Allocates a new block of the requested size. May return nil if out of memory

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockAllocateByType Function

nxmmBlockManagerCommitted.nxCommittedBlockAllocateByType Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
function nxCommittedBlockAllocateByType(aBlockType: PnxCommittedBlockType; aLow: Boolean): PnxCommittedBlock; register;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.nxCommittedBlockAllocateByType.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockCleanup Function

nxmmBlockManagerCommitted.nxCommittedBlockCleanup Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
procedure nxCommittedBlockCleanup;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.nxCommittedBlockCleanup.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockDispose Function

nxmmBlockManagerCommitted.nxCommittedBlockDispose Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
function nxCommittedBlockDispose(aBlock: PnxCommittedBlock): Boolean; register;
File

nxmmBlockManagerCommitted

Description

Disposes a block, returns true if successful

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockDisposeBySize Function

nxmmBlockManagerCommitted.nxCommittedBlockDisposeBySize Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
function nxCommittedBlockDisposeBySize(aBlockSize: TnxBlockSizeAll; aBlock: PnxCommittedBlock): Boolean; register;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeBySize.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.nxCommittedBlockDisposeByType Function

nxmmBlockManagerCommitted.nxCommittedBlockDisposeByType Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
function nxCommittedBlockDisposeByType(aBlockType: PnxCommittedBlockType; aBlock: PnxCommittedBlock): Boolean; register;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.nxCommittedBlockDisposeByType.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


nxmmBlockManagerCommitted.Release Function

nxmmBlockManagerCommitted.Release Function
nxmmBlockManagerCommitted Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmBlockManagerCommitted

Description

This is function nxmmBlockManagerCommitted.Release.

Group

Functions

Links
nxmmBlockManagerCommitted, Functions


Types

Types
nxmmBlockManagerCommitted Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmBlockManagerCommitted Namespace

Types
Name | Description
PnxCommittedBlock | This is type nxmmBlockManagerCommitted.PnxCommittedBlock.
PnxCommittedBlockType | This is type nxmmBlockManagerCommitted.PnxCommittedBlockType.
TnxCommittedBlock | This is type nxmmBlockManagerCommitted.TnxCommittedBlock.
Links
nxmmBlockManagerCommitted Namespace, Types


nxmmBlockManagerCommitted.PnxCommittedBlock Type

nxmmBlockManagerCommitted.PnxCommittedBlock Type
nxmmBlockManagerCommitted Types Send Feedback
Syntax
Delphi
PnxCommittedBlock = ^TnxCommittedBlock;
File

nxmmBlockManagerCommitted

Description

This is type nxmmBlockManagerCommitted.PnxCommittedBlock.

Group

Types

Links
nxmmBlockManagerCommitted, Types


nxmmBlockManagerCommitted.PnxCommittedBlockType Type

nxmmBlockManagerCommitted.PnxCommittedBlockType Type
nxmmBlockManagerCommitted Types Send Feedback
Syntax
Delphi
PnxCommittedBlockType = type PnxBlockType;
File

nxmmBlockManagerCommitted

Description

This is type nxmmBlockManagerCommitted.PnxCommittedBlockType.

Group

Types

Links
nxmmBlockManagerCommitted, Types


nxmmBlockManagerCommitted.TnxCommittedBlock Type

nxmmBlockManagerCommitted.TnxCommittedBlock Type
nxmmBlockManagerCommitted Types Send Feedback
Syntax
Delphi
TnxCommittedBlock = array[TnxWord16] of TnxByte8;
File

nxmmBlockManagerCommitted

Description

This is type nxmmBlockManagerCommitted.TnxCommittedBlock.

Group

Types

Links
nxmmBlockManagerCommitted, Types


Variables

Variables
nxmmBlockManagerCommitted Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmBlockManagerCommitted Namespace

Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerCommitted._nxBlockHeaders.
_RefCount | This is variable nxmmBlockManagerCommitted._RefCount.
nxCommittedBlockTypes | This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypes.
nxCommittedBlockTypesPtr | This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypesPtr.
Links
nxmmBlockManagerCommitted Namespace, Variables


nxmmBlockManagerCommitted._nxBlockHeaders Variable

nxmmBlockManagerCommitted._nxBlockHeaders Variable
nxmmBlockManagerCommitted Variables Send Feedback
Syntax
Delphi
_nxBlockHeaders: PnxBlockHeaders;
File

nxmmBlockManagerCommitted

Description

This is variable nxmmBlockManagerCommitted._nxBlockHeaders.

Group

Variables

Links
nxmmBlockManagerCommitted, Variables


nxmmBlockManagerCommitted._RefCount Variable

nxmmBlockManagerCommitted._RefCount Variable
nxmmBlockManagerCommitted Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmBlockManagerCommitted

Description

This is variable nxmmBlockManagerCommitted._RefCount.

Group

Variables

Links
nxmmBlockManagerCommitted, Variables


nxmmBlockManagerCommitted.nxCommittedBlockTypes Variable

nxmmBlockManagerCommitted.nxCommittedBlockTypes Variable
nxmmBlockManagerCommitted Variables Send Feedback
Syntax
Delphi
nxCommittedBlockTypes: array[TnxBlockSizeAll] of TnxBlockType = ( (btShiftFactor: 12), (btShiftFactor: 13), (btShiftFactor: 14), (btShiftFactor: 15), (btShiftFactor: 16), (btShiftFactor: 22) );
File

nxmmBlockManagerCommitted

Description

This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypes.

Group

Variables

Links
nxmmBlockManagerCommitted, Variables


nxmmBlockManagerCommitted.nxCommittedBlockTypesPtr Variable

nxmmBlockManagerCommitted.nxCommittedBlockTypesPtr Variable
nxmmBlockManagerCommitted Variables Send Feedback
Syntax
Delphi
nxCommittedBlockTypesPtr: array[TnxBlockSizeAll] of PnxCommittedBlockType;
File

nxmmBlockManagerCommitted

Description

This is variable nxmmBlockManagerCommitted.nxCommittedBlockTypesPtr.

Group

Variables

Links
nxmmBlockManagerCommitted, Variables


nxmmBlockManagerPhysical Namespace

nxmmBlockManagerPhysical Namespace
Functions Legend Topics Types Variables Send Feedback

This is namespace nxmmBlockManagerPhysical.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerPhysical.AddRef.
nxPhysicalBlockAllocateBySize | Allocates a new block of the requested size. May return nil if out of memory
nxPhysicalBlockAllocateByType | This is function nxmmBlockManagerPhysical.nxPhysicalBlockAllocateByType.
nxPhysicalBlockCleanup | This is function nxmmBlockManagerPhysical.nxPhysicalBlockCleanup.
nxPhysicalBlockDispose | Disposes a block, returns true if successful
nxPhysicalBlockDisposeBySize | This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeBySize.
nxPhysicalBlockDisposeByType | This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeByType.
Release | This is function nxmmBlockManagerPhysical.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxPhysicalBlock | This is type nxmmBlockManagerPhysical.PnxPhysicalBlock.
PnxPhysicalBlockType | This is type nxmmBlockManagerPhysical.PnxPhysicalBlockType.
TnxPhysicalBlock | This is type nxmmBlockManagerPhysical.TnxPhysicalBlock.
Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerPhysical._nxBlockHeaders.
_RefCount | This is variable nxmmBlockManagerPhysical._RefCount.
nxPhysicalBlockTypes | This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypes.
nxPhysicalBlockTypesPtr | This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypesPtr.
Links
Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxmmBlockManagerPhysical Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmBlockManagerPhysical.AddRef.
nxPhysicalBlockAllocateBySize | Allocates a new block of the requested size. May return nil if out of memory
nxPhysicalBlockAllocateByType | This is function nxmmBlockManagerPhysical.nxPhysicalBlockAllocateByType.
nxPhysicalBlockCleanup | This is function nxmmBlockManagerPhysical.nxPhysicalBlockCleanup.
nxPhysicalBlockDispose | Disposes a block, returns true if successful
nxPhysicalBlockDisposeBySize | This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeBySize.
nxPhysicalBlockDisposeByType | This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeByType.
Release | This is function nxmmBlockManagerPhysical.Release.
Namespace

nxmmBlockManagerPhysical Namespace

Links
Functions, nxmmBlockManagerPhysical Namespace, Legend


nxmmBlockManagerPhysical.AddRef Function

nxmmBlockManagerPhysical.AddRef Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.AddRef.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockAllocateBySize Function

nxmmBlockManagerPhysical.nxPhysicalBlockAllocateBySize Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
function nxPhysicalBlockAllocateBySize(aBlockSize: TnxBlockSizeAll; aLow: Boolean): PnxPhysicalBlock; register;
File

nxmmBlockManagerPhysical

Description

Allocates a new block of the requested size. May return nil if out of memory

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockAllocateByType Function

nxmmBlockManagerPhysical.nxPhysicalBlockAllocateByType Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
function nxPhysicalBlockAllocateByType(aBlockType: PnxPhysicalBlockType; aLow: Boolean): PnxPhysicalBlock; register;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.nxPhysicalBlockAllocateByType.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockCleanup Function

nxmmBlockManagerPhysical.nxPhysicalBlockCleanup Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
procedure nxPhysicalBlockCleanup;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.nxPhysicalBlockCleanup.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockDispose Function

nxmmBlockManagerPhysical.nxPhysicalBlockDispose Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
function nxPhysicalBlockDispose(aBlock: PnxPhysicalBlock): Boolean; register;
File

nxmmBlockManagerPhysical

Description

Disposes a block, returns true if successful

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockDisposeBySize Function

nxmmBlockManagerPhysical.nxPhysicalBlockDisposeBySize Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
function nxPhysicalBlockDisposeBySize(aBlockSize: TnxBlockSizeAll; aBlock: PnxPhysicalBlock): Boolean; register;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeBySize.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.nxPhysicalBlockDisposeByType Function

nxmmBlockManagerPhysical.nxPhysicalBlockDisposeByType Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
function nxPhysicalBlockDisposeByType(aBlockType: PnxPhysicalBlockType; aBlock: PnxPhysicalBlock): Boolean; register;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.nxPhysicalBlockDisposeByType.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


nxmmBlockManagerPhysical.Release Function

nxmmBlockManagerPhysical.Release Function
nxmmBlockManagerPhysical Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmBlockManagerPhysical

Description

This is function nxmmBlockManagerPhysical.Release.

Group

Functions

Links
nxmmBlockManagerPhysical, Functions


Types

Types
nxmmBlockManagerPhysical Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmBlockManagerPhysical Namespace

Types
Name | Description
PnxPhysicalBlock | This is type nxmmBlockManagerPhysical.PnxPhysicalBlock.
PnxPhysicalBlockType | This is type nxmmBlockManagerPhysical.PnxPhysicalBlockType.
TnxPhysicalBlock | This is type nxmmBlockManagerPhysical.TnxPhysicalBlock.
Links
nxmmBlockManagerPhysical Namespace, Types


nxmmBlockManagerPhysical.PnxPhysicalBlock Type

nxmmBlockManagerPhysical.PnxPhysicalBlock Type
nxmmBlockManagerPhysical Types Send Feedback
Syntax
Delphi
PnxPhysicalBlock = ^TnxPhysicalBlock;
File

nxmmBlockManagerPhysical

Description

This is type nxmmBlockManagerPhysical.PnxPhysicalBlock.

Group

Types

Links
nxmmBlockManagerPhysical, Types


nxmmBlockManagerPhysical.PnxPhysicalBlockType Type

nxmmBlockManagerPhysical.PnxPhysicalBlockType Type
nxmmBlockManagerPhysical Types Send Feedback
Syntax
Delphi
PnxPhysicalBlockType = type PnxBlockType;
File

nxmmBlockManagerPhysical

Description

This is type nxmmBlockManagerPhysical.PnxPhysicalBlockType.

Group

Types

Links
nxmmBlockManagerPhysical, Types


nxmmBlockManagerPhysical.TnxPhysicalBlock Type

nxmmBlockManagerPhysical.TnxPhysicalBlock Type
nxmmBlockManagerPhysical Types Send Feedback
Syntax
Delphi
TnxPhysicalBlock = array[TnxWord16] of TnxByte8;
File

nxmmBlockManagerPhysical

Description

This is type nxmmBlockManagerPhysical.TnxPhysicalBlock.

Group

Types

Links
nxmmBlockManagerPhysical, Types


Variables

Variables
nxmmBlockManagerPhysical Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmBlockManagerPhysical Namespace

Variables
Name | Description
_nxBlockHeaders | This is variable nxmmBlockManagerPhysical._nxBlockHeaders.
_RefCount | This is variable nxmmBlockManagerPhysical._RefCount.
nxPhysicalBlockTypes | This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypes.
nxPhysicalBlockTypesPtr | This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypesPtr.
Links
nxmmBlockManagerPhysical Namespace, Variables


nxmmBlockManagerPhysical._nxBlockHeaders Variable

nxmmBlockManagerPhysical._nxBlockHeaders Variable
nxmmBlockManagerPhysical Variables Send Feedback
Syntax
Delphi
_nxBlockHeaders: PnxBlockHeaders;
File

nxmmBlockManagerPhysical

Description

This is variable nxmmBlockManagerPhysical._nxBlockHeaders.

Group

Variables

Links
nxmmBlockManagerPhysical, Variables


nxmmBlockManagerPhysical._RefCount Variable

nxmmBlockManagerPhysical._RefCount Variable
nxmmBlockManagerPhysical Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmBlockManagerPhysical

Description

This is variable nxmmBlockManagerPhysical._RefCount.

Group

Variables

Links
nxmmBlockManagerPhysical, Variables


nxmmBlockManagerPhysical.nxPhysicalBlockTypes Variable

nxmmBlockManagerPhysical.nxPhysicalBlockTypes Variable
nxmmBlockManagerPhysical Variables Send Feedback
Syntax
Delphi
nxPhysicalBlockTypes: array[TnxBlockSizeAll] of TnxBlockType = ( (btShiftFactor: 12), (btShiftFactor: 13), (btShiftFactor: 14), (btShiftFactor: 15), (btShiftFactor: 16), (btShiftFactor: 22) );
File

nxmmBlockManagerPhysical

Description

This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypes.

Group

Variables

Links
nxmmBlockManagerPhysical, Variables


nxmmBlockManagerPhysical.nxPhysicalBlockTypesPtr Variable

nxmmBlockManagerPhysical.nxPhysicalBlockTypesPtr Variable
nxmmBlockManagerPhysical Variables Send Feedback
Syntax
Delphi
nxPhysicalBlockTypesPtr: array[TnxBlockSizeAll] of PnxPhysicalBlockType;
File

nxmmBlockManagerPhysical

Description

This is variable nxmmBlockManagerPhysical.nxPhysicalBlockTypesPtr.

Group

Variables

Links
nxmmBlockManagerPhysical, Variables


nxmmChunkManager Namespace

nxmmChunkManager Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmmChunkManager.

Constants
Name | Description
EmergencyPoolCount | This is constant nxmmChunkManager.EmergencyPoolCount.
MEM_4MB_PAGES | This is constant nxmmChunkManager.MEM_4MB_PAGES.
MEM_LARGE_PAGES | This is constant nxmmChunkManager.MEM_LARGE_PAGES.
MEM_PHYSICAL | This is constant nxmmChunkManager.MEM_PHYSICAL.
nxcChunkAddrMask | This is constant nxmmChunkManager.nxcChunkAddrMask.
nxcChunkAddrMaskInv | This is constant nxmmChunkManager.nxcChunkAddrMaskInv.
nxcChunkSize | This is constant nxmmChunkManager.nxcChunkSize.
nxcChunkSizeShiftFactor | This is constant nxmmChunkManager.nxcChunkSizeShiftFactor.
Functions
Name | Description
AddRef | This is function nxmmChunkManager.AddRef.
nxChunkAllocateCommitted | This is function nxmmChunkManager.nxChunkAllocateCommitted.
nxChunkAllocateCommitted | Returns the base address of a 4MB region of committed address space. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.
nxChunkAllocateCommittedEmpty | This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.
nxChunkAllocateCommittedEmpty | This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.
nxChunkAllocatePhysical | This is function nxmmChunkManager.nxChunkAllocatePhysical.
nxChunkAllocatePhysical | Returns the base address of a 4MB region of reserved address space for use with Physical. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.
nxChunkCleanUp | Releases all cached Chunks back to the OS
nxChunkCleanUpCommitted | This is function nxmmChunkManager.nxChunkCleanUpCommitted.
nxChunkCleanUpPhysical | This is function nxmmChunkManager.nxChunkCleanUpPhysical.
nxChunkDisposeCommitted | Disposes a 4MB chunk of address space, the pointer will be cached for some time to speed up nxChunkAllocateCommitted requests, returns True on success
nxChunkDisposeCommittedDirect | This is function nxmmChunkManager.nxChunkDisposeCommittedDirect.
nxChunkDisposePhysical | Disposes a 4MB chunk of address space that was allocated for use with Physical, the pointer will be cached for some time to speed up nxChunkAllocatePhysical requests, returns True on success
Release | This is function nxmmChunkManager.Release.
Structs, Records, Enums
Name | Description
TnxChunkBitmap | This is record nxmmChunkManager.TnxChunkBitmap.
TnxEmergencyPool | This is record nxmmChunkManager.TnxEmergencyPool.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxChunk | This is type nxmmChunkManager.PnxChunk.
PnxChunkBitmap | This is type nxmmChunkManager.PnxChunkBitmap.
PnxChunkBitmaps | This is type nxmmChunkManager.PnxChunkBitmaps.
PnxEmergencyPool | This is type nxmmChunkManager.PnxEmergencyPool.
TnxChunk | This is type nxmmChunkManager.TnxChunk.
TnxChunkBitmaps | This is type nxmmChunkManager.TnxChunkBitmaps.
Variables
Name | Description
_AvailableRegionsCommitted | This is variable nxmmChunkManager._AvailableRegionsCommitted.
_AvailableRegionsPhysical | This is variable nxmmChunkManager._AvailableRegionsPhysical.
_CachedChunksCommitted | chunks that have been reserved and returned to the manager again
_CachedChunksPhysical | chunks that have been reserved and returned to the manager again
_CachedRegionsCommitted | This is variable nxmmChunkManager._CachedRegionsCommitted.
_CachedRegionsPhysical | This is variable nxmmChunkManager._CachedRegionsPhysical.
_ChunkBitmaps | This is variable nxmmChunkManager._ChunkBitmaps.
_ChunkEmergencyCommited | This is variable nxmmChunkManager._ChunkEmergencyCommited.
_ChunkEmergencyPhysical | This is variable nxmmChunkManager._ChunkEmergencyPhysical.
_EmergencyPool | This is variable nxmmChunkManager._EmergencyPool.
_EmergencyPoolEmptyCommitted | This is variable nxmmChunkManager._EmergencyPoolEmptyCommitted.
_EmergencyPoolEmptyPhysical | This is variable nxmmChunkManager._EmergencyPoolEmptyPhysical.
_FailedChunks | chunks that couldn't be reserved last time
_RefCount | This is variable nxmmChunkManager._RefCount.
_ReservedRegions | This is variable nxmmChunkManager._ReservedRegions.
_UnusedChunks | chunks potentially available to be reserved
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxmmChunkManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmChunkManager.AddRef.
nxChunkAllocateCommitted | This is function nxmmChunkManager.nxChunkAllocateCommitted.
nxChunkAllocateCommitted | Returns the base address of a 4MB region of committed address space. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.
nxChunkAllocateCommittedEmpty | This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.
nxChunkAllocateCommittedEmpty | This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.
nxChunkAllocatePhysical | This is function nxmmChunkManager.nxChunkAllocatePhysical.
nxChunkAllocatePhysical | Returns the base address of a 4MB region of reserved address space for use with Physical. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.
nxChunkCleanUp | Releases all cached Chunks back to the OS
nxChunkCleanUpCommitted | This is function nxmmChunkManager.nxChunkCleanUpCommitted.
nxChunkCleanUpPhysical | This is function nxmmChunkManager.nxChunkCleanUpPhysical.
nxChunkDisposeCommitted | Disposes a 4MB chunk of address space, the pointer will be cached for some time to speed up nxChunkAllocateCommitted requests, returns True on success
nxChunkDisposeCommittedDirect | This is function nxmmChunkManager.nxChunkDisposeCommittedDirect.
nxChunkDisposePhysical | Disposes a 4MB chunk of address space that was allocated for use with Physical, the pointer will be cached for some time to speed up nxChunkAllocatePhysical requests, returns True on success
Release | This is function nxmmChunkManager.Release.
Namespace

nxmmChunkManager Namespace

Links
Functions, nxmmChunkManager Namespace, Legend


nxmmChunkManager.AddRef Function

nxmmChunkManager.AddRef Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.AddRef.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocateCommitted Function

nxmmChunkManager.nxChunkAllocateCommitted Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocateCommitted: PnxChunk; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkAllocateCommitted.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocateCommitted Function

nxmmChunkManager.nxChunkAllocateCommitted Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocateCommitted(aLow: Boolean): PnxChunk; register;
File

nxmmChunkManager

Description

Returns the base address of a 4MB region of committed address space. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocateCommittedEmpty Function

nxmmChunkManager.nxChunkAllocateCommittedEmpty Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocateCommittedEmpty: PnxChunk; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocateCommittedEmpty Function

nxmmChunkManager.nxChunkAllocateCommittedEmpty Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocateCommittedEmpty(aLow: Boolean): PnxChunk; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkAllocateCommittedEmpty.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocatePhysical Function

nxmmChunkManager.nxChunkAllocatePhysical Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocatePhysical: PnxChunk; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkAllocatePhysical.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkAllocatePhysical Function

nxmmChunkManager.nxChunkAllocatePhysical Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkAllocatePhysical(aLow: Boolean): PnxChunk; register;
File

nxmmChunkManager

Description

Returns the base address of a 4MB region of reserved address space for use with Physical. The returned pointer is guaranteed to be 4MB aligned. Allocation takes place top to bottom.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkCleanUp Function

nxmmChunkManager.nxChunkCleanUp Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
procedure nxChunkCleanUp; register;
File

nxmmChunkManager

Description

Releases all cached Chunks back to the OS

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkCleanUpCommitted Function

nxmmChunkManager.nxChunkCleanUpCommitted Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
procedure nxChunkCleanUpCommitted; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkCleanUpCommitted.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkCleanUpPhysical Function

nxmmChunkManager.nxChunkCleanUpPhysical Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
procedure nxChunkCleanUpPhysical; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkCleanUpPhysical.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkDisposeCommitted Function

nxmmChunkManager.nxChunkDisposeCommitted Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkDisposeCommitted(p: PnxChunk): System; register;
File

nxmmChunkManager

Description

Disposes a 4MB chunk of address space, the pointer will be cached for some time to speed up nxChunkAllocateCommitted requests, returns True on success

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkDisposeCommittedDirect Function

nxmmChunkManager.nxChunkDisposeCommittedDirect Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkDisposeCommittedDirect(p: PnxChunk): System; register;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.nxChunkDisposeCommittedDirect.

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.nxChunkDisposePhysical Function

nxmmChunkManager.nxChunkDisposePhysical Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
function nxChunkDisposePhysical(p: PnxChunk): System; register;
File

nxmmChunkManager

Description

Disposes a 4MB chunk of address space that was allocated for use with Physical, the pointer will be cached for some time to speed up nxChunkAllocatePhysical requests, returns True on success

Group

Functions

Links
nxmmChunkManager, Functions


nxmmChunkManager.Release Function

nxmmChunkManager.Release Function
nxmmChunkManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmChunkManager

Description

This is function nxmmChunkManager.Release.

Group

Functions

Links
nxmmChunkManager, Functions


Structs, Records, Enums

Structs, Records, Enums
nxmmChunkManager Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxmmChunkManager Namespace

Records
Name | Description
TnxChunkBitmap | This is record nxmmChunkManager.TnxChunkBitmap.
TnxEmergencyPool | This is record nxmmChunkManager.TnxEmergencyPool.
Links
nxmmChunkManager Namespace, Legend, Records


nxmmChunkManager.TnxChunkBitmap Record

nxmmChunkManager.TnxChunkBitmap Record
nxmmChunkManager Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxChunkBitmap = record
  UnusedChunks: TnxBitmap;
  FailedChunks: TnxBitmap;
  CachedChunksCommitted: TnxBitmap;
  CachedChunksPhysical: TnxBitmap;
end;
File

nxmmChunkManager

Members
Members | Description
UnusedChunks: TnxBitmap; | chunks potentially available to be reserved
FailedChunks: TnxBitmap; | chunks that couldn't be reserved last time
CachedChunksCommitted: TnxBitmap; | chunks that have been reserved and returned to the manager again
CachedChunksPhysical: TnxBitmap; | chunks that have been reserved and returned to the manager again
Description

This is record nxmmChunkManager.TnxChunkBitmap.

Group

Structs, Records, Enums

Links
nxmmChunkManager, Structs, Records, Enums


nxmmChunkManager.TnxEmergencyPool Record

nxmmChunkManager.TnxEmergencyPool Record
nxmmChunkManager Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxEmergencyPool = record
  EmptyCommitted: TnxListHead;
  EmptyPhysical: TnxListHead;
  AvailableCommitted: TnxListHead;
  AvailablePhysical: TnxListHead;
  EntriesCommitted: array[0..Pred(EmergencyPoolCount)] of TnxStackEntry;
  EntriesPhysical: array[0..Pred(EmergencyPoolCount)] of TnxStackEntry;
end;
File

nxmmChunkManager

Description

This is record nxmmChunkManager.TnxEmergencyPool.

Group

Structs, Records, Enums

Links
nxmmChunkManager, Structs, Records, Enums


Types

Types
nxmmChunkManager Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmChunkManager Namespace

Types
Name | Description
PnxChunk | This is type nxmmChunkManager.PnxChunk.
PnxChunkBitmap | This is type nxmmChunkManager.PnxChunkBitmap.
PnxChunkBitmaps | This is type nxmmChunkManager.PnxChunkBitmaps.
PnxEmergencyPool | This is type nxmmChunkManager.PnxEmergencyPool.
TnxChunk | This is type nxmmChunkManager.TnxChunk.
TnxChunkBitmaps | This is type nxmmChunkManager.TnxChunkBitmaps.
Links
nxmmChunkManager Namespace, Types


nxmmChunkManager.PnxChunk Type

nxmmChunkManager.PnxChunk Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
PnxChunk = ^TnxChunk;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.PnxChunk.

Group

Types

Links
nxmmChunkManager, Types


nxmmChunkManager.PnxChunkBitmap Type

nxmmChunkManager.PnxChunkBitmap Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
PnxChunkBitmap = ^TnxChunkBitmap;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.PnxChunkBitmap.

Group

Types

Links
nxmmChunkManager, Types


nxmmChunkManager.PnxChunkBitmaps Type

nxmmChunkManager.PnxChunkBitmaps Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
PnxChunkBitmaps = ^TnxChunkBitmaps;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.PnxChunkBitmaps.

Group

Types

Links
nxmmChunkManager, Types


nxmmChunkManager.PnxEmergencyPool Type

nxmmChunkManager.PnxEmergencyPool Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
PnxEmergencyPool = ^TnxEmergencyPool;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.PnxEmergencyPool.

Group

Types

Links
nxmmChunkManager, Types


nxmmChunkManager.TnxChunk Type

nxmmChunkManager.TnxChunk Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
TnxChunk = array[0..Pred(nxcChunkSize)] of Byte;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.TnxChunk.

Group

Types

Links
nxmmChunkManager, Types


nxmmChunkManager.TnxChunkBitmaps Type

nxmmChunkManager.TnxChunkBitmaps Type
nxmmChunkManager Types Send Feedback
Syntax
Delphi
TnxChunkBitmaps = array[0..1023] of TnxChunkBitmap;
File

nxmmChunkManager

Description

This is type nxmmChunkManager.TnxChunkBitmaps.

Group

Types

Links
nxmmChunkManager, Types


Variables

Variables
nxmmChunkManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmChunkManager Namespace

Variables
Name | Description
_AvailableRegionsCommitted | This is variable nxmmChunkManager._AvailableRegionsCommitted.
_AvailableRegionsPhysical | This is variable nxmmChunkManager._AvailableRegionsPhysical.
_CachedChunksCommitted | chunks that have been reserved and returned to the manager again
_CachedChunksPhysical | chunks that have been reserved and returned to the manager again
_CachedRegionsCommitted | This is variable nxmmChunkManager._CachedRegionsCommitted.
_CachedRegionsPhysical | This is variable nxmmChunkManager._CachedRegionsPhysical.
_ChunkBitmaps | This is variable nxmmChunkManager._ChunkBitmaps.
_ChunkEmergencyCommited | This is variable nxmmChunkManager._ChunkEmergencyCommited.
_ChunkEmergencyPhysical | This is variable nxmmChunkManager._ChunkEmergencyPhysical.
_EmergencyPool | This is variable nxmmChunkManager._EmergencyPool.
_EmergencyPoolEmptyCommitted | This is variable nxmmChunkManager._EmergencyPoolEmptyCommitted.
_EmergencyPoolEmptyPhysical | This is variable nxmmChunkManager._EmergencyPoolEmptyPhysical.
_FailedChunks | chunks that couldn't be reserved last time
_RefCount | This is variable nxmmChunkManager._RefCount.
_ReservedRegions | This is variable nxmmChunkManager._ReservedRegions.
_UnusedChunks | chunks potentially available to be reserved
Links
nxmmChunkManager Namespace, Variables


nxmmChunkManager._AvailableRegionsCommitted Variable

nxmmChunkManager._AvailableRegionsCommitted Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_AvailableRegionsCommitted: TnxBitmap;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._AvailableRegionsCommitted.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._AvailableRegionsPhysical Variable

nxmmChunkManager._AvailableRegionsPhysical Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_AvailableRegionsPhysical: TnxBitmap;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._AvailableRegionsPhysical.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._CachedChunksCommitted Variable

nxmmChunkManager._CachedChunksCommitted Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_CachedChunksCommitted: TnxBitmap;
File

nxmmChunkManager

Description

chunks that have been reserved and returned to the manager again

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._CachedChunksPhysical Variable

nxmmChunkManager._CachedChunksPhysical Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_CachedChunksPhysical: TnxBitmap;
File

nxmmChunkManager

Description

chunks that have been reserved and returned to the manager again

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._CachedRegionsCommitted Variable

nxmmChunkManager._CachedRegionsCommitted Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_CachedRegionsCommitted: TnxBitmap;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._CachedRegionsCommitted.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._CachedRegionsPhysical Variable

nxmmChunkManager._CachedRegionsPhysical Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_CachedRegionsPhysical: TnxBitmap;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._CachedRegionsPhysical.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._ChunkBitmaps Variable

nxmmChunkManager._ChunkBitmaps Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_ChunkBitmaps: PnxChunkBitmaps;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._ChunkBitmaps.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._ChunkEmergencyCommited Variable

nxmmChunkManager._ChunkEmergencyCommited Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_ChunkEmergencyCommited: ^LongBool;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._ChunkEmergencyCommited.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._ChunkEmergencyPhysical Variable

nxmmChunkManager._ChunkEmergencyPhysical Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_ChunkEmergencyPhysical: ^LongBool;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._ChunkEmergencyPhysical.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._EmergencyPool Variable

nxmmChunkManager._EmergencyPool Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_EmergencyPool: PnxEmergencyPool;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._EmergencyPool.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._EmergencyPoolEmptyCommitted Variable

nxmmChunkManager._EmergencyPoolEmptyCommitted Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_EmergencyPoolEmptyCommitted: Pointer;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._EmergencyPoolEmptyCommitted.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._EmergencyPoolEmptyPhysical Variable

nxmmChunkManager._EmergencyPoolEmptyPhysical Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_EmergencyPoolEmptyPhysical: Pointer;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._EmergencyPoolEmptyPhysical.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._FailedChunks Variable

nxmmChunkManager._FailedChunks Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_FailedChunks: TnxBitmap;
File

nxmmChunkManager

Description

chunks that couldn't be reserved last time

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._RefCount Variable

nxmmChunkManager._RefCount Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._RefCount.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._ReservedRegions Variable

nxmmChunkManager._ReservedRegions Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_ReservedRegions: TnxBitmap;
File

nxmmChunkManager

Description

This is variable nxmmChunkManager._ReservedRegions.

Group

Variables

Links
nxmmChunkManager, Variables


nxmmChunkManager._UnusedChunks Variable

nxmmChunkManager._UnusedChunks Variable
nxmmChunkManager Variables Send Feedback
Syntax
Delphi
_UnusedChunks: TnxBitmap;
File

nxmmChunkManager

Description

chunks potentially available to be reserved

Group

Variables

Links
nxmmChunkManager, Variables


Constants

Constants
Constants nxmmChunkManager Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EmergencyPoolCount | This is constant nxmmChunkManager.EmergencyPoolCount.
MEM_4MB_PAGES | This is constant nxmmChunkManager.MEM_4MB_PAGES.
MEM_LARGE_PAGES | This is constant nxmmChunkManager.MEM_LARGE_PAGES.
MEM_PHYSICAL | This is constant nxmmChunkManager.MEM_PHYSICAL.
nxcChunkAddrMask | This is constant nxmmChunkManager.nxcChunkAddrMask.
nxcChunkAddrMaskInv | This is constant nxmmChunkManager.nxcChunkAddrMaskInv.
nxcChunkSize | This is constant nxmmChunkManager.nxcChunkSize.
nxcChunkSizeShiftFactor | This is constant nxmmChunkManager.nxcChunkSizeShiftFactor.
Namespace

nxmmChunkManager Namespace

Links
Constants, nxmmChunkManager Namespace


nxmmChunkManager.EmergencyPoolCount Constant

nxmmChunkManager.EmergencyPoolCount Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
EmergencyPoolCount = 5;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.EmergencyPoolCount.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.MEM_4MB_PAGES Constant

nxmmChunkManager.MEM_4MB_PAGES Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
MEM_4MB_PAGES = DWORD($80000000);
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.MEM_4MB_PAGES.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.MEM_LARGE_PAGES Constant

nxmmChunkManager.MEM_LARGE_PAGES Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
MEM_LARGE_PAGES = $20000000;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.MEM_LARGE_PAGES.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.MEM_PHYSICAL Constant

nxmmChunkManager.MEM_PHYSICAL Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
MEM_PHYSICAL = $400000;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.MEM_PHYSICAL.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.nxcChunkAddrMask Constant

nxmmChunkManager.nxcChunkAddrMask Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
nxcChunkAddrMask = Pred(nxcChunkSize);
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.nxcChunkAddrMask.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.nxcChunkAddrMaskInv Constant

nxmmChunkManager.nxcChunkAddrMaskInv Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
nxcChunkAddrMaskInv = not nxcChunkAddrMask;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.nxcChunkAddrMaskInv.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.nxcChunkSize Constant

nxmmChunkManager.nxcChunkSize Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
nxcChunkSize = 4 * 1024 * 1024;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.nxcChunkSize.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmChunkManager.nxcChunkSizeShiftFactor Constant

nxmmChunkManager.nxcChunkSizeShiftFactor Constant
nxmmChunkManager Constants Send Feedback
Syntax
Delphi
nxcChunkSizeShiftFactor = 22;
File

nxmmChunkManager

Description

This is constant nxmmChunkManager.nxcChunkSizeShiftFactor.

Group

Constants

Links
nxmmChunkManager, Constants


nxmmFastMM4 Namespace

nxmmFastMM4 Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

Fast Memory Manager 4.94

A fast replacement memory manager for CodeGear Delphi Win32 applications that scales well under multi-threaded usage, is not prone to memory fragmentation, and supports shared memory without the use of external .DLL files.

Homepage: http://fastmm.sourceforge.net

Advantages:

  • Fast
  • Low overhead. FastMM is designed for an average of 5% and maximum of 10% overhead per block.
  • Supports up to 3GB of user mode address space under Windows 32-bit and 4GB under Windows 64-bit. Add the "$SetPEFlags $20" option (in curly braces) to your .dpr to enable this.
  • Highly aligned memory blocks. Can be configured for either 8-byte or 16-byte alignment.
  • Good scaling under multi-threaded applications
  • Intelligent reallocations. Avoids slow memory move operations through not performing unneccesary downsizes and by having a minimum percentage block size growth factor when an in-place block upsize is not possible.
  • Resistant to address space fragmentation
  • No external DLL required when sharing memory between the application and external libraries (provided both use this memory manager)
  • Optionally reports memory leaks on program shutdown. (This check can be set to be performed only if Delphi is currently running on the machine, so end users won't be bothered by the error message.)
  • Supports Delphi 4 (or later), C++ Builder 4 (or later), Kylix 3.

Usage: Delphi: Place this unit as the very first unit under the "uses" section in your project's .dpr file. When sharing memory between an application and a DLL (e.g. when passing a long string or dynamic array to a DLL function), both the main application and the DLL must be compiled using this memory manager (with the required conditional defines set). There are some conditional defines (inside FastMM4Options.inc) that may be used to tweak the memory manager. To enable support for a user mode address space greater than 2GB you will have to use the EditBin* tool to set the LARGE_ADDRESS_AWARE flag in the EXE header. This informs Windows x64 or Windows 32-bit (with the /3GB option set) that the application supports an address space larger than 2GB (up to 4GB). In Delphi 6 and later you can also specify this flag through the compiler directive {$SetPEFlags $20} *The EditBin tool ships with the MS Visual C compiler. C++ Builder 6: Refer to the instructions inside FastMM4BCB.cpp.

License: This work is copyright Professional Software Development / Pierre le Riche. It is released under a dual license, and you may choose to use it under either the Mozilla Public License 1.1 (MPL 1.1, available from http://www.mozilla.org/MPL/MPL-1.1.html) or the GNU Lesser General Public License 2.1 (LGPL 2.1, available from http://www.opensource.org/licenses/lgpl-license.php). If you find FastMM useful or you would like to support further development, a donation would be much appreciated. My banking details are: Country: South Africa Bank: ABSA Bank Ltd Branch: Somerset West Branch Code: 334-712 Account Name: PSD (Distribution) Account No.: 4041827693 Swift Code: ABSAZAJJ My PayPal account is: bof@psd.co.za

Contact Details: My contact details are shown below if you would like to get in touch with me. If you use this memory manager I would like to hear from you: please e-mail me your comments - good and bad. Snailmail: PO Box 2514 Somerset West 7129 South Africa E-mail: plr@psd.co.za

Support: If you have trouble using FastMM, you are welcome to drop me an e-mail at the address above, or you may post your questions in the BASM newsgroup on the CodeGear news server (which is where I hang out quite frequently).

Disclaimer: FastMM has been tested extensively with both single and multithreaded applications on various hardware platforms, but unfortunately I am not in a position to make any guarantees. Use it at your own risk.

Acknowledgements (for version 4):

  • Eric Grange for his RecyclerMM on which the earlier versions of FastMM were based. RecyclerMM was what inspired me to try and write my own memory manager back in early 2004.
  • Primoz Gabrijelcic for helping to track down various bugs.
  • Dennis Christensen for his tireless efforts with the Fastcode project: helping to develop, optimize and debug the growing Fastcode library.
  • JiYuan Xie for implementing the leak reporting code for C++ Builder.
  • Pierre Y. for his suggestions regarding the extension of the memory leak checking options.
  • Hanspeter Widmer for his suggestion to have an option to display install and uninstall debug messages and moving options to a separate file, as well as the new usage tracker.
  • Anders Isaksson and Greg for finding and identifying the "DelphiIsRunning" bug under Delphi 5.
  • Francois Malan for various suggestions and bug reports.
  • Craig Peterson for helping me identify the cache associativity issues that could arise due to medium blocks always being an exact multiple of 256 bytes. Also for various other bug reports and enhancement suggestions.
  • Jarek Karciarz, Vladimir Ulchenko (Vavan) and Bob Gonder for their help in implementing the BCB support.
  • Ben Taylor for his suggestion to display the object class of all memory leaks.
  • Jean Marc Eber and Vincent Mahon (the Memcheck guys) for the call stack trace code and also the method used to catch virtual method calls on freed objects.
  • Nahan Hyn for the suggestion to be able to enable or disable memory leak reporting through a global variable (the "ManualLeakReportingControl" option.)
  • Leonel Togniolli for various suggestions with regard to enhancing the bug tracking features of FastMM and other helpful advice.
  • Joe Bain and Leonel Togniolli for the workaround to QC#10922 affecting compilation under Delphi 2005.
  • Robert Marquardt for the suggestion to make localisation of FastMM easier by having all string constants together.
  • Simon Kissel and Fikret Hasovic for their help in implementing Kylix support.
  • Matthias Thoma, Petr Vones, Robert Rossmair and the rest of the JCL team for their debug info library used in the debug info support DLL and also the code used to check for a valid call site in the "raw" stack trace code.
  • Andreas Hausladen for the suggestion to use an external DLL to enable the reporting of debug information.
  • Alexander Tabakov for various good suggestions regarding the debugging facilities of FastMM.
  • M. Skloff for some useful suggestions and bringing to my attention some compiler warnings.
  • Martin Aignesberger for the code to use madExcept instead of the JCL library inside the debug info support DLL.
  • Diederik and Dennis Passmore for the suggestion to be able to register expected leaks.
  • Dario Tiraboschi and Mark Gebauer for pointing out the problems that occur when range checking and complete boolean evaluation is turned on.
  • Arthur Hoornweg for notifying me of the image base being incorrect for borlndmm.dll.
  • Theo Carr-Brion and Hanspeter Widmer for finding the false alarm error message "Block Header Has Been Corrupted" bug in FullDebugMode.
  • Danny Heijl for reporting the compiler error in "release" mode.
  • Omar Zelaya for reporting the BCB support regression bug.
  • Dan Miser for various good suggestions, e.g. not logging expected leaks to file, enhancements the stack trace and messagebox functionality, etc.
  • Arjen de Ruijter for fixing the bug in GetMemoryLeakType that caused it to not properly detect expected leaks registered by class when in "FullDebugMode".
  • Aleksander Oven for reporting the installation problem when trying to use FastMM in an application together with libraries that all use runtime packages.
  • Kristofer Skaug for reporting the bug that sometimes causes the leak report to be shown, even when all the leaks have been registered as expected leaks. Also for some useful enhancement suggestions.
  • Günther Schoch for the "RequireDebuggerPresenceForLeakReporting" option.
  • Jan Schlüter for the "ForceMMX" option.
  • Hallvard Vassbotn for various good enhancement suggestions.
  • Mark Edington for some good suggestions and bug reports.
  • Paul Ishenin for reporting the compilation error when the NoMessageBoxes option is set and also the missing call stack entries issue when "raw" stack traces are enabled, as well as for the Russian translation.
  • Cristian Nicola for reporting the compilation bug when the CatchUseOfFreedInterfaces option was enabled (4.40).
  • Mathias Rauen (madshi) for improving the support for madExcept in the debug info support DLL.
  • Roddy Pratt for the BCB5 support code.
  • Rene Mihula for the Czech translation and the suggestion to have dynamic loading of the FullDebugMode DLL as an option.
  • Artur Redzko for the Polish translation.
  • Bart van der Werf for helping me solve the DLL unload order problem when using the debug mode borlndmm.dll library, as well as various other suggestions.
  • JRG ("The Delphi Guy") for the Spanish translation.
  • Justus Janssen for Delphi 4 support.
  • Vadim Lopushansky and Charles Vinal for reporting the Delphi 5 compiler error in version 4.50.
  • Johni Jeferson Capeletto for the Brazilian Portuguese translation.
  • Kurt Fitzner for reporting the BCb6 compiler error in 4.52.
  • Michal Niklas for reporting the Kylix compiler error in 4.54.
  • Thomas Speck and Uwe Queisser for German translations.
  • Zaenal Mutaqin for the Indonesian translation.
  • Carlos Macao for the Portuguese translation.
  • Michael Winter for catching the performance issue when reallocating certain block sizes.
  • dzmitry[li] for the Belarussian translation.
  • Marcelo Montenegro for the updated Spanish translation.
  • Jud Cole for finding and reporting the bug which may trigger a read access violation when upsizing certain small block sizes together with the "UseCustomVariableSizeMoveRoutines" option.
  • Zdenek Vasku for reporting and fixing the memory manager sharing bug affecting Windows 95/98/Me.
  • RB Winston for suggesting the improvement to GExperts "backup" support.
  • Thomas Schulz for reporting the bug affecting large address space support under FullDebugMode, as well as the recursive call bug when attempting to report memory leaks when EnableMemoryLeakReporting is disabled.
  • Luigi Sandon for the Italian translation.
  • Werner Bochtler for various suggestions and bug reports.
  • Markus Beth for suggesting the "NeverSleepOnThreadContention" option.
  • JiYuan Xie for the Simplified Chinese translation.
  • Andrey Shtukaturov for the updated Russian translation, as well as the Ukrainian translation.
  • Dimitry Timokhov for finding two elusive bugs in the memory leak class detection code.
  • Paulo Moreno for fixing the AllocMem bug in FullDebugMode that prevented large blocks from being cleared.
  • Vladimir Bochkarev for the suggestion to remove some unnecessary code if the MM sharing mechanism is disabled.
  • Loris Luise for the version constant suggestion.
  • J.W. de Bokx for the MessageBox bugfix.
  • Igor Lindunen for reporting the bug that caused the Align16Bytes option to not work in FullDebugMode.
  • Ionut Muntean for the Romanian translation.
  • Florent Ouchet for the French translation.
  • Marcus Mönnig for the ScanMemoryPoolForCorruptions suggestion and the suggestion to have the option to scan the memory pool before every operation when in FullDebugMode.
  • Francois Piette for bringing under my attention that ScanMemoryPoolForCorruption was not thread safe.
  • Michael Rabatscher for reporting some compiler warnings.
  • QianYuan Wang for the Simplified Chinese translation of FastMM4Options.inc.
  • Maurizio Lotauro and Christian-W. Budde for reporting some Delphi 5 compiler errors.
  • Patrick van Logchem for the DisableLoggingOfMemoryDumps option.
  • Norbert Spiegel for the BCB4 support code.
  • Uwe Schuster for the improved string leak detection code.
  • Everyone who have made donations. Thanks!
  • Any other Fastcoders or supporters that I have forgotten, and also everyone that helped with the older versions.

Change log: Version 1.00 (28 June 2004):

  • First version (called PSDMemoryManager). Based on RecyclerMM (free block stack approach) by Eric Grange.

Version 2.00 (3 November 2004):

  • Complete redesign and rewrite from scratch. Name changed to FastMM to reflect this fact. Uses a linked-list approach. Is faster, has less memory overhead, and will now catch most bad pointers on FreeMem calls.

Version 3.00 (1 March 2005):

  • Another rewrite. Reduced the memory overhead by: (a) not having a separate memory area for the linked list of free blocks (uses space inside free blocks themselves) (b) batch managers are allocated as part of chunks (c) block size lookup table size reduced. This should make FastMM more CPU cache friendly.

Version 4.00 (7 June 2005):

  • Yet another rewrite. FastMM4 is in fact three memory managers in one: Small blocks (up to a few KB) are managed through the binning model in the same way as previous versions, medium blocks (from a few KB up to approximately 256K) are allocated in a linked-list fashion, and large blocks are grabbed directly from the system through VirtualAlloc. This 3-layered design allows very fast operation with the most frequently used block sizes (small blocks), while also minimizing fragmentation and imparting significant overhead savings with blocks larger than a few KB.

Version 4.01 (8 June 2005):

  • Added the options "RequireDebugInfoForLeakReporting" and "RequireIDEPresenceForLeakReporting" as suggested by Pierre Y.
  • Fixed the "DelphiIsRunning" function not working under Delphi 5, and consequently no leak checking. (Reported by Anders Isaksson and Greg.)

Version 4.02 (8 June 2005):

  • Fixed the compilation error when both the "AssumeMultiThreaded" and "CheckHeapForCorruption options were set. (Reported by Francois Malan.)

Version 4.03 (9 June 2005):

  • Added descriptive error messages when FastMM4 cannot be installed because another MM has already been installed or memory has already been allocated.

Version 4.04 (13 June 2005):

  • Added a small fixed offset to the size of medium blocks (previously always exact multiples of 256 bytes). This makes performance problems due to CPU cache associativity limitations much less likely. (Reported by Craig Peterson.)

Version 4.05 (17 June 2005):

  • Added the Align16Bytes option. Disable this option to drop the 16 byte alignment restriction and reduce alignment to 8 bytes for the smallest block sizes. Disabling Align16Bytes should lower memory consumption at the cost of complicating the use of aligned SSE move instructions. (Suggested by Craig Peterson.)
  • Added a support unit for C++ Builder 6 - Add FastMM4BCB.cpp and FastMM4.pas to your BCB project to use FastMM instead of the RTL MM. Memory leak checking is not supported because (unfortunately) once an MM is installed under BCB you cannot uninstall it... at least not without modifying the RTL code in exit.c or patching the RTL code runtime. (Thanks to Jarek Karciarz, Vladimir Ulchenko and Bob Gonder.)

Version 4.06 (22 June 2005):

  • Displays the class of all leaked objects on the memory leak report and also tries to identify leaked long strings. Previously it only displayed the sizes of all leaked blocks. (Suggested by Ben Taylor.)
  • Added support for displaying the sizes of medium and large block memory leaks. Previously it only displayed details for small block leaks.

Version 4.07 (22 June 2005):

  • Fixed the detection of the class of leaked objects not working under Windows 98/Me.

Version 4.08 (27 June 2005):

  • Added a BorlndMM.dpr project to allow you to build a borlndmm.dll that uses FastMM4 instead of the default memory manager. You may replace the old DLL in the Delphi Bin directory to make the IDE use this memory manager instead.

Version 4.09 (30 June 2005):

  • Included a patch fix for the bug affecting replacement borlndmm.dll files with Delphi 2005 (QC#14007). Compile the patch, close Delphi, and run it once to patch your vclide90.bpl. You will now be able to use the replacement borlndmm.dll to speed up the Delphi 2005 IDE as well.

Version 4.10 (7 July 2005):

  • Due to QC#14070 ("Delphi IDE attempts to free memory after the shutdown code of borlndmm.dll has been called"), FastMM cannot be uninstalled safely when used inside a replacement borlndmm.dll for the IDE. Added a conditional define "NeverUninstall" for this purpose.
  • Added the "FullDebugMode" option to pad all blocks with a header and footer to help you catch memory overwrite bugs in your applications. All blocks returned to freemem are also zeroed out to help catch bugs involving the use of previously freed blocks. Also catches attempts at calling virtual methods of freed objects provided the block in question has not been reused since the object was freed. Displays stack traces on error to aid debugging.
  • Added the "LogErrorsToFile" option to log all errors to a text file in the same folder as the application.
  • Added the "ManualLeakReportingControl" option (suggested by Nahan Hyn) to enable control over whether the memory leak report should be done or not via a global variable.

Version 4.11 (7 July 2005):

  • Fixed a compilation error under Delphi 2005 due to QC#10922. (Thanks to Joe Bain and Leonel Togniolli.)
  • Fixed leaked object classes not displaying in the leak report in "FullDebugMode".

Version 4.12 (8 July 2005):

  • Moved all the string constants to one place to make it easier to do translations into other languages. (Thanks to Robert Marquardt.)
  • Added support for Kylix. Some functionality is currently missing: No support for detecting the object class on leaks and also no MM sharing. (Thanks to Simon Kissel and Fikret Hasovic).

Version 4.13 (11 July 2005):

  • Added the FastMM_DebugInfo.dll support library to display debug info for stack traces.
  • Stack traces for the memory leak report is now logged to the log file in "FullDebugMode".

Version 4.14 (14 July 2005):

  • Fixed string leaks not being detected as such in "FullDebugMode". (Thanks to Leonel Togniolli.)
  • Fixed the compilation error in "FullDebugMode" when "LogErrorsToFile" is not set. (Thanks to Leonel Togniolli.)
  • Added a "Release" option to allow the grouping of various options and to make it easier to make debug and release builds. (Thanks to Alexander Tabakov.)
  • Added a "HideMemoryLeakHintMessage" option to not display the hint below the memory leak message. (Thanks to Alexander Tabakov.)
  • Changed the fill character for "FullDebugMode" from zero to $80 to be able to differentiate between invalid memory accesses using nil pointers to invalid memory accesses using fields of freed objects. FastMM tries to reserve the 64K block starting at $80800000 at startup to ensure that an A/V will occur when this block is accessed. (Thanks to Alexander Tabakov.)
  • Fixed some compiler warnings. (Thanks to M. Skloff)
  • Fixed some display bugs in the memory leak report. (Thanks to Leonel Togniolli.)
  • Added a "LogMemoryLeakDetailToFile" option. Some applications leak a lot of memory and can make the log file grow very large very quickly.
  • Added the option to use madExcept instead of the JCL Debug library in the debug info support DLL. (Thanks to Martin Aignesberger.)
  • Added procedures "GetMemoryManagerState" and "GetMemoryMap" to retrieve statistics about the current state of the memory manager and memory pool. (A usage tracker form together with a demo is also available.)

Version 4.15 (14 July 2005):

  • Fixed a false 4GB(!) memory leak reported in some instances.

Version 4.16 (15 July 2005):

  • Added the "CatchUseOfFreedInterfaces" option to catch the use of interfaces of freed objects. This option is not compatible with checking that a freed block has not been modified, so enable this option only when hunting an invalid interface reference. (Only relevant if "FullDebugMode" is set.)
  • During shutdown FastMM now checks that all free blocks have not been modified since being freed. (Only when "FullDebugMode" is set and "CatchUseOfFreedInterfaces" is disabled.)

Version 4.17 (15 July 2005):

  • Added the AddExpectedMemoryLeaks and RemoveExpectedMemoryLeaks procedures to register/unregister expected leaks, thus preventing the leak report from displaying if only expected leaks occurred. (Thanks to Diederik and Dennis Passmore for the suggestion.) (Note: these functions were renamed in later versions.)
  • Fixed the "LogMemoryLeakDetailToFile" not logging memory leak detail to file as it is supposed to. (Thanks to Leonel Togniolli.)

Version 4.18 (18 July 2005):

  • Fixed some issues when range checking or complete boolean evaluation is switched on. (Thanks to Dario Tiraboschi and Mark Gebauer.)
  • Added the "OutputInstallUninstallDebugString" option to display a message when FastMM is installed or uninstalled. (Thanks to Hanspeter Widmer.)
  • Moved the options to a separate include file. (Thanks to Hanspeter Widmer.)
  • Moved message strings to a separate file for easy translation.

Version 4.19 (19 July 2005):

  • Fixed Kylix support that was broken in 4.14.

Version 4.20 (20 July 2005):

  • Fixed a false memory overwrite report at shutdown in "FullDebugMode". If you consistently got a "Block Header Has Been Corrupted" error message during shutdown at address $xxxx0070 then it was probably a false alarm. (Thanks to Theo Carr-Brion and Hanspeter Widmer.}

Version 4.21 (27 July 2005):

  • Minor change to the block header flags to make it possible to immediately tell whether a medium block is being used as a small block pool or not. (Simplifies the leak checking and status reporting code.)
  • Expanded the functionality around the management of expected memory leaks.
  • Added the "ClearLogFileOnStartup" option. Deletes the log file during initialization. (Thanks to M. Skloff.)
  • Changed "OutputInstallUninstallDebugString" to use OutputDebugString instead of MessageBox. (Thanks to Hanspeter Widmer.)

Version 4.22 (1 August 2005):

  • Added a FastAllocMem function that avoids an unnecessary FillChar call with large blocks.
  • Changed large block resizing behavior to be a bit more conservative. Large blocks will be downsized if the new size is less than half of the old size (the threshold was a quarter previously).

Version 4.23 (6 August 2005):

  • Fixed BCB6 support (Thanks to Omar Zelaya).
  • Renamed "OutputInstallUninstallDebugString" to "UseOutputDebugString", and added debug string output on memory leak or error detection.

Version 4.24 (11 August 2005):

  • Added the "NoMessageBoxes" option to suppress the display of message boxes, which is useful for services that should not be interrupted. (Thanks to Dan Miser).
  • Changed the stack trace code to return the line number of the caller and not the line number of the return address. (Thanks to Dan Miser).

Version 4.25 (15 August 2005):

  • Fixed GetMemoryLeakType not detecting expected leaks registered by class when in "FullDebugMode". (Thanks to Arjen de Ruijter).

Version 4.26 (18 August 2005):

  • Added a "UseRuntimePackages" option that allows FastMM to be used in a main application together with DLLs that all use runtime packages. (Thanks to Aleksander Oven.)

Version 4.27 (24 August 2005):

  • Fixed a bug that sometimes caused the leak report to be shown even though all leaks were registered as expected leaks. (Thanks to Kristofer Skaug.)

Version 4.29 (30 September 2005):

  • Added the "RequireDebuggerPresenceForLeakReporting" option to only display the leak report if the application is run inside the IDE. (Thanks to Günther Schoch.)
  • Added the "ForceMMX" option, which when disabled will check the CPU for MMX compatibility before using MMX. (Thanks to Jan Schlüter.)
  • Added the module name to the title of error dialogs to more easily identify which application caused the error. (Thanks to Kristofer Skaug.)
  • Added an ASCII dump to the "FullDebugMode" memory dumps. (Thanks to Hallvard Vassbotn.)
  • Added the option "HideExpectedLeaksRegisteredByPointer" to suppress the display and logging of expected memory leaks that were registered by pointer. (Thanks to Dan Miser.) Leaks registered by size or class are often ambiguous, so these expected leaks are always logged to file (in FullDebugMode) and are never hidden from the leak display (only displayed if there is at least one unexpected leak).
  • Added a procedure "GetRegisteredMemoryLeaks" to return a list of all registered memory leaks. (Thanks to Dan Miser.)
  • Added the "RawStackTraces" option to perform "raw" stack traces, negating the need for stack frames. This will usually result in more complete stack traces in FullDebugMode error reports, but it is significantly slower. (Thanks to Hallvard Vassbotn, Dan Miser and the JCL team.)

Version 4.31 (2 October 2005):

  • Fixed the crash bug when both "RawStackTraces" and "FullDebugMode" were enabled. (Thanks to Dan Miser and Mark Edington.)

Version 4.33 (6 October 2005):

  • Added a header corruption check to all memory blocks that are identified as leaks in FullDebugMode. This allows better differentiation between memory pool corruption bugs and actual memory leaks.
  • Fixed the stack overflow bug when using "RawStackTraces".

Version 4.35 (6 October 2005):

  • Fixed a compilation error when the "NoMessageBoxes" option is set. (Thanks to Paul Ishenin.)
  • Before performing a "raw" stack trace, FastMM now checks whether exception handling is in place. If exception handling is not in place FastMM falls back to stack frame tracing. (Exception handling is required to handle the possible A/Vs when reading invalid call addresses. Exception handling is usually always available except when SysUtils hasn't been initialized yet or after SysUtils has been finalized.)

Version 4.37 (8 October 2005):

  • Fixed the missing call stack trace entry issue when dynamically loading DLLs. (Thanks to Paul Ishenin.)

Version 4.39 (12 October 2005):

  • Restored the performance with "RawStackTraces" enabled back to the level it was in 4.35.
  • Fixed the stack overflow error when using "RawStackTraces" that I thought I had fixed in 4.31, but unfortunately didn't. (Thanks to Craig Peterson.)

Version 4.40 (13 October 2005):

  • Improved "RawStackTraces" to have less incorrect extra entries. (Thanks to Craig Peterson.)
  • Added the Russian (by Paul Ishenin) and Afrikaans translations of FastMM4Messages.pas.

Version 4.42 (13 October 2005):

  • Fixed the compilation error when "CatchUseOfFreedInterfaces" is enabled. (Thanks to Cristian Nicola.)

Version 4.44 (25 October 2005):

  • Implemented a FastGetHeapStatus function in analogy with GetHeapStatus. (Suggested by Cristian Nicola.)
  • Shifted more of the stack trace code over to the support dll to allow third party vendors to make available their own stack tracing and stack trace logging facilities.
  • Mathias Rauen (madshi) improved the support for madExcept in the debug info support DLL. Thanks!
  • Added support for BCB5. (Thanks to Roddy Pratt.)
  • Added the Czech translation by Rene Mihula.
  • Added the "DetectMMOperationsAfterUninstall" option. This will catch attempts to use the MM after FastMM has been uninstalled, and is useful for debugging.

Version 4.46 (26 October 2005):

  • Renamed FastMM_DebugInfo.dll to FastMM_FullDebugMode.dll and made the dependency on this library a static one. This solves a DLL unload order problem when using FullDebugMode together with the replacement borlndmm.dll. (Thanks to Bart van der Werf.)
  • Added the Polish translation by Artur Redzko.

Version 4.48 (10 November 2005):

  • Fixed class detection for objects leaked in dynamically loaded DLLs that were relocated.
  • Fabio Dell'Aria implemented support for EurekaLog in the FullDebugMode support DLL. Thanks!
  • Added the Spanish translation by JRG ("The Delphi Guy").

Version 4.49 (10 November 2005):

  • Implemented support for installing replacement AllocMem and leak registration mechanisms for Delphi/BCB versions that support it.
  • Added support for Delphi 4. (Thanks to Justus Janssen.)

Version 4.50 (5 December 2005):

  • Renamed the ReportMemoryLeaks global variable to ReportMemoryLeaksOnShutdown to be more consistent with the Delphi 2006 memory manager.
  • Improved the handling of large blocks. Large blocks can now consist of several consecutive segments allocated through VirtualAlloc. This significantly improves speed when frequently resizing large blocks, since these blocks can now often be upsized in-place.

Version 4.52 (7 December 2005):

  • Fixed the compilation error with Delphi 5. (Thanks to Vadim Lopushansky and Charles Vinal for reporting the error.)

Version 4.54 (15 December 2005):

  • Added the Brazilian Portuguese translation by Johni Jeferson Capeletto.
  • Fixed the compilation error with BCB6. (Thanks to Kurt Fitzner.)

Version 4.56 (20 December 2005):

  • Fixed the Kylix compilation problem. (Thanks to Michal Niklas.)

Version 4.58 (1 February 2006):

  • Added the German translations by Thomas Speck and Uwe Queisser.
  • Added the Indonesian translation by Zaenal Mutaqin.
  • Added the Portuguese translation by Carlos Macao.

Version 4.60 (21 February 2006):

  • Fixed a performance issue due to an unnecessary block move operation when allocating a block in the range 1261-1372 bytes and then reallocating it in the range 1373-1429 bytes twice. (Thanks to Michael Winter.)
  • Added the Belarussian translation by dzmitry[li].
  • Added the updated Spanish translation by Marcelo Montenegro.
  • Added a new option "EnableSharingWithDefaultMM". This option allows FastMM to be shared with the default MM of Delphi 2006. It is on by default, but MM sharing has to be enabled otherwise it has no effect (refer to the documentation for the "ShareMM" and "AttemptToUseSharedMM" options).

Version 4.62 (22 February 2006):

  • Fixed a possible read access violation in the MoveX16L4 routine when the UseCustomVariableSizeMoveRoutines option is enabled. (Thanks to Jud Cole for some great detective work in finding this bug.)
  • Improved the downsizing behaviour of medium blocks to better correlate with the reallocation behaviour of small blocks. This change reduces the number of transitions between small and medium block types when reallocating blocks in the 0.7K to 2.6K range. It cuts down on the number of memory move operations and improves performance.

Version 4.64 (31 March 2006):

  • Added the following functions for use with FullDebugMode (and added the exports to the replacement BorlndMM.dll): SetMMLogFileName, GetCurrentAllocationGroup, PushAllocationGroup, PopAllocationGroup and LogAllocatedBlocksToFile. The purpose of these functions are to allow you to identify and log related memory leaks while your application is still running.
  • Fixed a bug in the memory manager sharing mechanism affecting Windows 95/98/ME. (Thanks to Zdenek Vasku.)

Version 4.66 (9 May 2006):

  • Added a hint comment in this file so that FastMM4Messages.pas will also be backed up by GExperts. (Thanks to RB Winston.)
  • Fixed a bug affecting large address space (> 2GB) support under FullDebugMode. (Thanks to Thomas Schulz.)

Version 4.68 (3 July 2006):

  • Added the Italian translation by Luigi Sandon.
  • If FastMM is used inside a DLL it will now use the name of the DLL as base for the log file name. (Previously it always used the name of the main application executable file.)
  • Fixed a rare A/V when both the FullDebugMode and RawStackTraces options were enabled. (Thanks to Primoz Gabrijelcic.)
  • Added the "NeverSleepOnThreadContention" option. This option may improve performance if the ratio of the the number of active threads to the number of CPU cores is low (typically < 2). This option is only useful for 4+ CPU systems, it almost always hurts performance on single and dual CPU systems. (Thanks to Werner Bochtler and Markus Beth.)

Version 4.70 (4 August 2006):

  • Added the Simplified Chinese translation by JiYuan Xie.
  • Added the updated Russian as well as the Ukrainian translation by Andrey Shtukaturov.
  • Fixed two bugs in the leak class detection code that would sometimes fail to detect the class of leaked objects and strings, and report them as 'unknown'. (Thanks to Dimitry Timokhov)

Version 4.72 (24 September 2006):

  • Fixed a bug that caused AllocMem to not clear blocks > 256K in FullDebugMode. (Thanks to Paulo Moreno.)

Version 4.74 (9 November 2006):

  • Fixed a bug in the segmented large block functionality that could lead to an application freeze when upsizing blocks greater than 256K in a multithreaded application (one of those "what the heck was I thinking?" type bugs).

Version 4.76 (12 January 2007):

  • Changed the RawStackTraces code in the FullDebugMode DLL to prevent it from modifying the Windows "GetLastError" error code. (Thanks to Primoz Gabrijelcic.)
  • Fixed a threading issue when the "CheckHeapForCorruption" option was enabled, but the "FullDebugMode" option was disabled. (Thanks to Primoz Gabrijelcic.)
  • Removed some unnecessary startup code when the MM sharing mechanism is disabled. (Thanks to Vladimir Bochkarev.)
  • In FullDebugMode leaked blocks would sometimes be reported as belonging to the class "TFreedObject" if they were allocated but never used. Such blocks will now be reported as "unknown". (Thanks to Francois Malan.)
  • In recent versions the replacement borlndmm.dll created a log file (when enabled) that used the "borlndmm" prefix instead of the application name. It is now fixed to use the application name, however if FastMM is used inside other DLLs the name of those DLLs will be used. (Thanks to Bart van der Werf.)
  • Added a "FastMMVersion" constant. (Suggested by Loris Luise.)
  • Fixed an issue with error message boxes not displaying under certain configurations. (Thanks to J.W. de Bokx.)
  • FastMM will now display only one error message at a time. If many errors occur in quick succession, only the first error will be shown (but all will be logged). This avoids a stack overflow with badly misbehaved programs. (Thanks to Bart van der Werf.)
  • Added a LoadDebugDLLDynamically option to be used in conjunction with FullDebugMode. In this mode FastMM_FullDebugMode.dll is loaded dynamically. If the DLL cannot be found, stack traces will not be available. (Thanks to Rene Mihula.)

Version 4.78 (1 March 2007):

  • The MB_DEFAULT_DESKTOP_ONLY constant that is used when displaying messages boxes since 4.76 is not defined under Kylix, and the source would thus not compile. That constant is now defined. (Thanks to Werner Bochtler.)
  • Moved the medium block locking code that was duplicated in several places to a subroutine to reduce code size. (Thanks to Hallvard Vassbotn.)
  • Fixed a bug in the leak registration code that sometimes caused registered leaks to be reported erroneously. (Thanks to Primoz Gabrijelcic.)
  • Added the NoDebugInfo option (on by default) that suppresses the generation of debug info for the FastMM4.pas unit. This will prevent the integrated debugger from stepping into the memory manager. (Thanks to Primoz Gabrijelcic.)
  • Increased the default stack trace depth in FullDebugMode from 9 to 10 to ensure that the Align16Bytes setting works in FullDebugMode. (Thanks to Igor Lindunen.)
  • Updated the Czech translation. (Thanks to Rene Mihula.)

Version 4.84 (7 July 2008):

  • Added the Romanian translation. (Thanks to Ionut Muntean.)
  • Optimized the GetMemoryMap procedure to improve speed.
  • Added the GetMemoryManagerUsageSummary function that returns a summary of the GetMemoryManagerState call. (Thanks to Hallvard Vassbotn.)
  • Added the French translation. (Thanks to Florent Ouchet.)
  • Added the "AlwaysAllocateTopDown" FullDebugMode option to help with catching bad pointer arithmetic code in an address space > 2GB. This option is enabled by default.
  • Added the "InstallOnlyIfRunningInIDE" option. Enable this option to only install FastMM as the memory manager when the application is run inside the Delphi IDE. This is useful when you want to deploy the same EXE that you use for testing, but only want the debugging features active on development machines. When this option is enabled and the application is not being run inside the IDE, then the default Delphi memory manager will be used (which, since Delphi 2006, is FastMM without FullDebugMode.) This option is off by default.
  • Added the "FullDebugModeInIDE" option. This is a convenient shorthand for enabling FullDebugMode, InstallOnlyIfRunningInIDE and LoadDebugDLLDynamically. This causes FastMM to be used in FullDebugMode when the application is being debugged on development machines, and the default memory manager when the same executable is deployed. This allows the debugging and deployment of an application without having to compile separate executables. This option is off by default.
  • Added a ScanMemoryPoolForCorruptions procedure that checks the entire memory pool for corruptions and raises an exception if one is found. It can be called at any time, but is only available in FullDebugMode. (Thanks to Marcus Mönnig.)
  • Added a global variable "FullDebugModeScanMemoryPoolBeforeEveryOperation". When this variable is set to true and FullDebugMode is enabled, then the entire memory pool is checked for consistency before every GetMem, FreeMem and ReallocMem operation. An "Out of Memory" error is raised if a corruption is found (and this variable is set to false to prevent recursive errors). This obviously incurs a massive performance hit, so enable it only when hunting for elusive memory corruption bugs. (Thanks to Marcus Mönnig.)
  • Fixed a bug in AllocMem that caused the FPU stack to be shifted by one position.
  • Changed the default for option "EnableMMX" to false, since using MMX may cause unexpected behaviour in code that passes parameters on the FPU stack (like some "compiler magic" routines, e.g. VarFromReal).
  • Removed the "EnableSharingWithDefaultMM" option. This is now the default behaviour and cannot be disabled. (FastMM will always try to share memory managers between itself and the default memory manager when memory manager sharing is enabled.)
  • Introduced a new memory manager sharing mechanism based on memory mapped files. This solves compatibility issues with console and service applications. This sharing mechanism currently runs in parallel with the old mechanism, but the old mechanism can be disabled by undefining "EnableBackwardCompatibleMMSharing" in FastMM4Options.inc.
  • Fixed the recursive call error when the EnableMemoryLeakReporting option is disabled and an attempt is made to register a memory leak under Delphi 2006 or later. (Thanks to Thomas Schulz.)
  • Added a global variable "SuppressMessageBoxes" to enable or disable messageboxes at runtime. (Thanks to Craig Peterson.)
  • Added the leak reporting code for C++ Builder, as well as various other C++ Builder bits written by JiYuan Xie. (Thank you!)
  • Added the new Usage Tracker written by Hanspeter Widmer. (Thank you!)

Version 4.86 (31 July 2008):

  • Tweaked the string detection algorithm somewhat to be less strict, and allow non-class leaks to be more often categorized as strings.
  • Fixed a compilation error under Delphi 5.
  • Made LogAllocatedBlocksToFile and ScanMemoryPoolForCorruptions thread safe. (Thanks to Francois Piette.)

Version 4.88 (13 August 2008):

  • Fixed compiler warnings in NoOpRegisterExpectedMemoryLeak and NoOpUnRegisterExpectedMemoryLeak. (Thanks to Michael Rabatscher.)
  • Added the Simplified Chinese translation of FastMM4Options.inc by QianYuan Wang. (Thank you!)
  • Included the updated C++ Builder files with support for BCB6 without update 4 applied. (Submitted by JiYuan Xie. Thanks!)
  • Fixed a compilation error under Delphi 5.
  • Made LogAllocatedBlocksToFile and ScanMemoryPoolForCorruptions thread safe - for real this time. (Thanks to Francois Piette.)

Version 4.90 (9 September 2008):

  • Added logging of the thread ID when capturing and displaying stack traces. (Suggested by Allen Bauer and Mark Edington.)
  • Fixed a Delphi 5 compiler error under FullDebugMode. (Thanks to Maurizio Lotauro and Christian-W. Budde.)
  • Changed a default setting in FastMM4Options.inc: RawStackTraces is now off by default due to the high number of support requests I receive with regards to the false postives it may cause. I recommend compiling debug builds of applications with the "Stack Frames" option enabled.
  • Fixed a compilation error under Kylix. (Thanks to Werner Bochtler.)
  • Official support for Delphi 2009.

Version 4.92 (25 November 2008):

  • Added the DisableLoggingOfMemoryDumps option under FullDebugMode. When this option is set, memory dumps will not be logged for memory leaks or errors. (Thanks to Patrick van Logchem.)
  • Exposed the class and string type detection code in the interface section for use in application code (if required). (Requested by Patrick van Logchem.)
  • Fixed a bug in SetMMLogFileName that could cause the log file name to be set incorrectly.
  • Added BCB4 support. (Thanks to Norbert Spiegel.)
  • Included the updated Czech translation by Rene Mihula.
  • When FastMM raises an error due to a freed block being modified, it now logs detail about which bytes in the block were modified.

Version 4.94 (28 August 2009):

  • Added the DoNotInstallIfDLLMissing option that prevents FastMM from installing itself if the FastMM_FullDebugMode.dll library is not available. (Only applicable when FullDebugMode and LoadDebugDLLDynamically are both enabled.) This is useful when the same executable will be used for both debugging and deployment - when the debug support DLL is available FastMM will be installed in FullDebugMode, and otherwise the default memory manager will be used.
  • Added the FullDebugModeWhenDLLAvailable option that combines the FullDebugMode, LoadDebugDLLDynamically and DoNotInstallIfDLLMissing options.
  • Re-enabled RawStackTraces by default. The frame based stack traces (even when compiling with stack frames enabled) are generally too incomplete.
  • Improved the speed of large block operations under FullDebugMode: Since large blocks are never reused, there is no point in clearing them before and after use (so it does not do that anymore).
  • If an error occurs in FullDebugMode and FastMM is unable to append to the log file, it will attempt to write to a log file of the same name in the "My Documents" folder. This feature is helpful when the executable resides in a read-only location and the default log file, which is derived from the executable name, would thus not be writeable.
  • Added support for controlling the error log file location through an environment variable. If the 'FastMMLogFilePath' environment variable is set then any generated error logs will be written to the specified folder instead of the default location (which is the same folder as the application).
  • Improved the call instruction detection code in the FastMM_FullDebugMode library. (Thanks to the JCL team.)
  • Improved the string leak detection and reporting code. (Thanks to Uwe Schuster.)
  • New FullDebugMode feature: Whenever FreeMem or ReallocMem is called, FastMM will check that the block was actually allocated through the same FastMM instance. This is useful for tracking down memory manager sharing issues.
  • Compatible with Delphi 2010.
Classes
Name | Description
TFreedObject | The class used to catch attempts to execute a virtual method of a freed object
Constants
Name | Description
AdditionalSleepTime | Used when the resource is still in use after the first sleep
AllocationGroupStackSize | The number of entries in the allocation group stack
BlockHeaderSize | The size of the block header in front of small and medium blocks
Copyright | Copyright message - not used anywhere in the code
DebugFillByte | The pattern used to fill unused memory
DebugFillDWord | This is constant nxmmFastMM4.DebugFillDWord.
DebugReservedAddress | The address that is reserved so that accesses to the address of the fill pattern will result in an A/V
DropMediumAndLargeFlagsMask | The flags masks for medium and large blocks
DropSmallFlagsMask | The flags masks for small blocks
ExpectedMemoryLeaksListSize | Memory leak reporting constants
ExtractMediumAndLargeFlagsMask | This is constant nxmmFastMM4.ExtractMediumAndLargeFlagsMask.
ExtractSmallFlagsMask | This is constant nxmmFastMM4.ExtractSmallFlagsMask.
FastMMVersion | The current version of FastMM
FullDebugBlockOverhead | We need space for the header. 4 bytes for the trailer and 4 bytes for the trailing block size when the block is free
HexTable | Hexadecimal characters
InitialSleepTime | Sleep time when a resource (small/medium/large block manager) is in use
IsFreeBlockFlag |
IsLargeBlockFlag | Set if it is a large block. Only valid if IsMediumBlockFlag is not set.
IsMediumBlockFlag | Set if this is a medium block
IsSmallBlockPoolInUseFlag | Set if it is a medium block being used as a small block pool. Only valid if IsMediumBlockFlag is set.
LargeBlockGranularity | The granularity of large blocks
LargeBlockHeaderSize | The size of the header in front of Large blocks
LargeBlockIsSegmented | Is this large block segmented? I.e. is it actually built up from more than one chunk allocated through VirtualAlloc? (Only used by large blocks.)
MaxFakeVMTEntries | The number of fake VMT entries - used to track virtual method calls on freed objects. Do not change this value without also updating TFreedObject.GetVirtualMethodIndex
MaximumMediumBlockSize | The maximum size allocatable through medium blocks. Blocks larger than this fall through to VirtualAlloc ( = large blocks).
MaximumSmallBlockPoolSize | The maximum small block pool size. If a free block is this size or larger then it will be split.
MaximumSmallBlockSize | The maximum size of a small block. Blocks Larger than this are either medium or large blocks.
MB_DEFAULT_DESKTOP_ONLY | This is constant nxmmFastMM4.MB_DEFAULT_DESKTOP_ONLY.
MB_ICONERROR | This is constant nxmmFastMM4.MB_ICONERROR.
MB_OK | Messagebox constants
MB_TASKMODAL | This is constant nxmmFastMM4.MB_TASKMODAL.
MediumBlockBinCount | This is constant nxmmFastMM4.MediumBlockBinCount.
MediumBlockBinGroupCount | This is constant nxmmFastMM4.MediumBlockBinGroupCount.
MediumBlockBinsPerGroup | The number of bins reserved for medium blocks
MediumBlockGranularity | The granularity of medium blocks. Newly allocated medium blocks are a multiple of this size plus MediumBlockSizeOffset, to avoid cache line conflicts
MediumBlockPoolHeaderSize | The size of a medium block pool header
MediumBlockPoolSize | The size of a medium block pool. This is allocated through VirtualAlloc and is used to serve medium blocks. The size must be a multiple of 16 and at least 4 bytes less than a multiple of 4K (the page size) to prevent a possible read access violation when reading past the end of a memory block in the optimized move routine (MoveX16L4). In Full Debug mode we leave a trailing 256 bytes to be able to safely do a memory dump. >>>
MediumBlockSizeOffset | This is constant nxmmFastMM4.MediumBlockSizeOffset.
MediumInPlaceDownsizeLimit | When a medium block is reallocated to a size smaller than this, then it must be reallocated to a small block and the data moved. If not, then it is shrunk in place down to MinimumMediumBlockSize. Currently the limit is set at a quarter of the minimum medium block size.
MEM_COMMIT | Virtual memory constants
MEM_RELEASE | This is constant nxmmFastMM4.MEM_RELEASE.
MEM_TOP_DOWN | This is constant nxmmFastMM4.MEM_TOP_DOWN.
MinimumMediumBlockSize | The smallest medium block size. (Medium blocks are rounded up to the nearest multiple of MediumBlockGranularity plus MediumBlockSizeOffset)
MinimumSmallBlocksPerPool | The minimum number of small blocks per pool. Any available medium block must have space for roughly this many small blocks (or more) to be useable as a small block pool.
NumSmallBlockTypes | The number of small block types
OptimalSmallBlockPoolSizeLowerLimit | The lower and upper limits for the optimal small block pool size
OptimalSmallBlockPoolSizeUpperLimit | This is constant nxmmFastMM4.OptimalSmallBlockPoolSizeUpperLimit.
PAGE_READWRITE | This is constant nxmmFastMM4.PAGE_READWRITE.
PreviousMediumBlockIsFreeFlag | Is the medium block preceding this block available? (Only used by medium blocks)
reInvalidPtr | This is constant nxmmFastMM4.reInvalidPtr.
reOutOfMemory | Private constants
SmallBlockDownsizeCheckAdder | Block resizing constants
SmallBlockGranularity | <<< The granularity of small blocks
SmallBlockPoolHeaderSize | The size of a small block pool header
SmallBlockUpsizeAdder | This is constant nxmmFastMM4.SmallBlockUpsizeAdder.
StackTraceDepth | The stack trace depth. (Must be an *uneven* number to ensure that the Align16Bytes option works in FullDebugMode.)
StandardVirtualMethodNames | Virtual Method Called On Freed Object Errors
TargetSmallBlocksPerPool | The target number of small blocks per pool. The actual number of blocks per pool may be much greater for very small sizes and less for larger sizes. The cost of allocating the small block pool is amortized across all the small blocks in the pool, however the blocks may not all end up being used so they may be lying idle.
Functions
Name | Description
AddRef | >>>
CheckCanInstallMemoryManager | This is function nxmmFastMM4.CheckCanInstallMemoryManager.
DebugAllocMem | This is function nxmmFastMM4.DebugAllocMem.
DebugFreeMem | This is function nxmmFastMM4.DebugFreeMem.
DebugGetMem | The FullDebugMode memory manager functions
DebugReallocMem | This is function nxmmFastMM4.DebugReallocMem.
DeleteEventLog | HPPEMIT ' #define ClearLogFileOnStartup
DetectClassInstance | Returns the class for a memory block. Returns nil if it is not a valid class. Used by the leak detection code.
DetectStringData | Detects the probable string data type for a memory block. Used by the leak classification code when a block cannot be identified as a known class instance.
FastAllocMem | This is function nxmmFastMM4.FastAllocMem.
FastFreeMem | This is function nxmmFastMM4.FastFreeMem.
FastGetHeapStatus | Returns summarised information about the state of the memory manager. (For backward compatibility.)
FastGetMem | The standard memory manager functions
FastReallocMem | This is function nxmmFastMM4.FastReallocMem.
FinalizeMemoryManager | Called in FastMM4BCB.cpp, should contain codes of original "finalization" section
FreeAllMemory | Releases all allocated memory (use with extreme care)
GetCurrentAllocationGroup | Returns the current "allocation group". Whenever a GetMem request is serviced in FullDebugMode, the current "allocation group" is stored in the block header. This may help with debugging. Note that if a block is subsequently reallocated that it keeps its original "allocation group" and "allocation number" (all allocations are also numbered sequentially).
GetMemoryManagerState | Returns statistics about the current state of the memory manager
GetMemoryManagerUsageSummary | Returns a summary of the information returned by GetMemoryManagerState
GetMemoryMap | Gets the state of every 64K block in the 4GB address space
GetRegisteredMemoryLeaks | Returns a list of all expected memory leaks
InitializeMemoryManager |
InstallMemoryManager | This is function nxmmFastMM4.InstallMemoryManager.
InvalidAllocMem | This is function nxmmFastMM4.InvalidAllocMem.
InvalidFreeMem | Invalid handlers to catch MM operations after uninstall
InvalidGetMem | This is function nxmmFastMM4.InvalidGetMem.
InvalidReallocMem | This is function nxmmFastMM4.InvalidReallocMem.
InvalidRegisterAndUnRegisterMemoryLeak | This is function nxmmFastMM4.InvalidRegisterAndUnRegisterMemoryLeak.
LogAllocatedBlocksToFile | Logs detail about currently allocated memory blocks for the specified range of allocation groups. if ALastAllocationGroupToLog is less than AFirstAllocationGroupToLog or it is zero, then all allocation groups are logged. This routine also checks the memory pool for consistency at the same time, raising an "Out of Memory" error if the check fails.
Move12 | Fixed size move procedures Fixed size move operations ignore the size parameter. All moves are assumed to be non-overlapping.
Move20 | This is function nxmmFastMM4.Move20.
Move28 | This is function nxmmFastMM4.Move28.
Move36 | This is function nxmmFastMM4.Move36.
Move44 | This is function nxmmFastMM4.Move44.
Move52 | This is function nxmmFastMM4.Move52.
Move60 | This is function nxmmFastMM4.Move60.
Move68 | This is function nxmmFastMM4.Move68.
PopAllocationGroup | This is function nxmmFastMM4.PopAllocationGroup.
PushAllocationGroup | Allocation groups work in a stack like fashion. Group numbers are pushed onto and popped off the stack. Note that the stack size is limited, so every push should have a matching pop.
RegisterExpectedMemoryLeak | This is function nxmmFastMM4.RegisterExpectedMemoryLeak.
RegisterExpectedMemoryLeak | Registers expected memory leaks. Returns true on success. The list of leaked blocks is limited, so failure is possible if the list is full.
RegisterExpectedMemoryLeak | Registers expected memory leaks by virtual object's typeId pointer. Usage: RegisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);
RegisterExpectedMemoryLeak | This is function nxmmFastMM4.RegisterExpectedMemoryLeak.
Release | This is function nxmmFastMM4.Release.
ScanMemoryPoolForCorruptions | Scans the memory pool for any corruptions. If a corruption is encountered an "Out of Memory" exception is raised.
SetMMLogFileName | Specify the full path and name for the filename to be used for logging memory errors, etc. If ALogFileName is nil or points to an empty string it will revert to the default log file name.
UnregisterExpectedMemoryLeak | This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.
UnregisterExpectedMemoryLeak | Removes expected memory leaks. Returns true on success.
UnregisterExpectedMemoryLeak | Usage: UnregisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);
UnregisterExpectedMemoryLeak | This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.
Structs, Records, Enums
Name | Description
StrRec | This is record nxmmFastMM4.StrRec.
TBlockOperation | This is record nxmmFastMM4.TBlockOperation.
TChunkStatus | Memory map
TExpectedMemoryLeak | This is record nxmmFastMM4.TExpectedMemoryLeak.
TExpectedMemoryLeaks | This is record nxmmFastMM4.TExpectedMemoryLeaks.
TFullDebugBlockHeader | This is record nxmmFastMM4.TFullDebugBlockHeader.
TLargeBlockHeader | This is record nxmmFastMM4.TLargeBlockHeader.
TMediumBlockPoolHeader | This is record nxmmFastMM4.TMediumBlockPoolHeader.
TMediumFreeBlock | This is record nxmmFastMM4.TMediumFreeBlock.
TMemoryLeakType | Different kinds of memory leaks
TMemoryManagerState | This is record nxmmFastMM4.TMemoryManagerState.
TMemoryManagerUsageSummary | This is record nxmmFastMM4.TMemoryManagerUsageSummary.
TRegisteredMemoryLeak | List of registered leaks
TRegisters | Registers structure (for GetCPUID)
TSmallBlockPoolHeader | Small block pool (Size = 32 bytes)
TSmallBlockType | This is record nxmmFastMM4.TSmallBlockType.
TSmallBlockTypeState | Public types
TStringDataType | Used by the DetectStringData routine to detect whether a leaked block contains string data.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PCardinal | Delphi 5 Compatibility
PExpectedMemoryLeak | The layout of an expected leak. All fields may not be specified, in which case it may be harder to determine which leaks are expected and which are not.
PExpectedMemoryLeaks | This is type nxmmFastMM4.PExpectedMemoryLeaks.
PFullDebugBlockHeader | The header placed in front blocks in FullDebugMode (just after the standard header). Must be a multiple of 16 bytes in size otherwise the Align16Bytes option will not work. Current size = 128 bytes.
PInteger | Define some additional types for BCB4
PLargeBlockHeader | Large block header record (size = 16)
PMediumBlockPoolHeader | The medium block pool from which medium blocks are drawn
PMediumFreeBlock | Medium block layout: Offset: -8 = Previous Block Size (only if the previous block is free) Offset: -4 = This block size and flags Offset: 0 = User data / Previous Free Block (if this block is free) Offset: 4 = Next Free Block (if this block is free) Offset: BlockSize - 8 = Size of this block (if this block is free) Offset: BlockSize - 4 = Size of the next block and flags {A medium block that is unused
PPExpectedMemoryLeak | This is type nxmmFastMM4.PPExpectedMemoryLeak.
PPointer | This is type nxmmFastMM4.PPointer.
PSmallBlockPoolHeader | Pointer to the header of a small block pool
PSmallBlockType | Small block type (Size = 32)
PStackTrace | Full Debug Mode Structures
PStrRec | The layout of a string allocation. Used to detect string leaks.
TGetCppVirtObjSizeByTypeIdPtrFunc | HPPEMIT ''#13#10 HPPEMIT '#define CheckCppObjectTypeEnabled'
TGetCppVirtObjTypeIdPtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeIdPtrFunc.
TGetCppVirtObjTypeNameByTypeIdPtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameByTypeIdPtrFunc.
TGetCppVirtObjTypeNameByVTablePtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameByVTablePtrFunc.
TGetCppVirtObjTypeNameFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameFunc.
TMemoryMap | This is type nxmmFastMM4.TMemoryMap.
TMoveProc | Move procedure type
TRegisteredMemoryLeaks | This is type nxmmFastMM4.TRegisteredMemoryLeaks.
TSmallBlockTypeStates | This is type nxmmFastMM4.TSmallBlockTypeStates.
TStackTrace | This is type nxmmFastMM4.TStackTrace.
Variables
Name | Description
_Seq | make sure thread IDs are never reused
AllocationGroupStack | The allocation group stack
AllocationGroupStackTop | The allocation group stack top (it is an index into AllocationGroupStack)
AllocSize2SmallBlockTypeIndX4 | Size to small block type translation table
CurrentAllocationNumber | The last allocation number used
ExpectedMemoryLeaks | The expected memory leaks
ExpectedMemoryLeaksListLocked | This is variable nxmmFastMM4.ExpectedMemoryLeaksListLocked.
FastMMIsInstalled | Has FastMM been installed?
FreedObjectVMT | The fake VMT used to catch virtual method calls on freed objects.
FullDebugModeScanMemoryPoolBeforeEveryOperation | If this variable is set to true and FullDebugMode is enabled, then the entire memory pool is checked for consistency before every memory operation. Note that this incurs a massive performance hit on top of the already significant FullDebugMode overhead, so enable this option only when absolutely necessary.
GetCppVirtObjSizeByTypeIdPtrFunc | Return virtual object's size from typeId pointer
GetCppVirtObjTypeIdPtrFunc | Retrieve virtual object's typeId pointer
GetCppVirtObjTypeNameByTypeIdPtrFunc | Return virtual object's type name from typeId pointer
GetCppVirtObjTypeNameByVTablePtrFunc | Retrieve virtual object's typeId pointer from it's virtual table pointer
GetCppVirtObjTypeNameFunc | Retrieve virtual object's type name
InvalidMemoryManager | Invalid handlers to catch MM operations after uninstall
IsMemoryManagerOwner | Is the MM in place a shared memory manager?
LargeBlocksCircularList | A dummy large block header: Maintains a list of all allocated large blocks to enable memory leak detection on program shutdown.
LargeBlocksLocked |
LastSequentiallyFedMediumBlock | The sequential feed medium block pool.
MappingObjectHandle | The handle of the memory mapped file
MappingObjectName | A string uniquely identifying the current process (for sharing the memory manager between DLLs and the main application)
MediumBlockBinBitmaps | The medium block bins: total of 32 * 32 = 1024 bins of a certain minimum size.
MediumBlockBinGroupBitmap | The medium block bins are divided into groups of 32 bins. If a bit is set in this group bitmap, then at least one bin in the group has free blocks.
MediumBlockBins | The medium block bins. There are 1024 LIFO circular linked lists each holding blocks of a specified minimum size. The sizes vary in size from MinimumMediumBlockSize to MaximumMediumBlockSize. The bins are treated as type TMediumFreeBlock to avoid pointer checks.
MediumBlockPoolsCircularList |
MediumBlocksLocked | Are medium blocks locked?
MediumSequentialFeedBytesLeft | This is variable nxmmFastMM4.MediumSequentialFeedBytesLeft.
MMLogFileName | The current log file name
MMWindow | The handle of the MM window
MMWindowBE | The handle of the MM window (for default MM of Delphi 2006 compatibility)
NewMemoryManager | The replacement memory manager
OldMemoryManager |
pCppDebugHook | PInteger not defined in BCB5
ReportMemoryLeaksOnShutdown | Variable is declared in system.pas in newer Delphi versions.
ReservedBlock | The 64K block of reserved memory used to trap invalid memory accesses using fields in a freed object.
ShowingMessageBox | Is a MessageBox currently showing? If so, do not show another one.
SmallBlockTypes |
SuppressMessageBoxes | If set to true, disables the display of all messageboxes
ThreadsInFullDebugModeRoutine | This is a count of the number of threads currently inside any of the FullDebugMode GetMem, Freemem or ReallocMem handlers. If this value is negative then a block scan is in progress and no thread may allocate, free or reallocate any block or modify any FullDebugMode block header or footer.
UniqueProcessIDString | This is variable nxmmFastMM4.UniqueProcessIDString.
UniqueProcessIDStringBE | This is variable nxmmFastMM4.UniqueProcessIDStringBE.
UseMMX | Must MMX be used for move operations?
VMIndex | The virtual method index count - used to get the virtual method index for a virtual method call on a freed object.
VMTBadInterface | This is variable nxmmFastMM4.VMTBadInterface.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxmmFastMM4 Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TFreedObject | The class used to catch attempts to execute a virtual method of a freed object
Namespace

nxmmFastMM4 Namespace

Links
Classes, nxmmFastMM4 Namespace, Legend


TFreedObject Class

TFreedObject Class
TFreedObject Methods TFreedObject Members nxmmFastMM4 Classes Send Feedback
Class Hierarchy
nxmmFastMM4_TFreedObject
Syntax
Delphi
TFreedObject = class;
File

nxmmFastMM4

Description

The class used to catch attempts to execute a virtual method of a freed object

Group

Classes

Links
TFreedObject Methods, TFreedObject Members, nxmmFastMM4, Classes


TFreedObject Members

TFreedObject Members
TFreedObject Class Legend Public Methods Send Feedback

The following tables list the members exposed by TFreedObject.

Class

TFreedObject Class

Public Methods
Name | Description
GetVirtualMethodIndex | This is GetVirtualMethodIndex, a member of class TFreedObject.
InterfaceError | This is InterfaceError, a member of class TFreedObject.
VirtualMethodError | This is VirtualMethodError, a member of class TFreedObject.
Links
TFreedObject Class, Legend, Public Methods


TFreedObject Methods

TFreedObject Methods
TFreedObject Class Legend Public Methods Send Feedback

The methods of the TFreedObject class are listed here.

Class

TFreedObject Class

Public Methods
Name | Description
GetVirtualMethodIndex | This is GetVirtualMethodIndex, a member of class TFreedObject.
InterfaceError | This is InterfaceError, a member of class TFreedObject.
VirtualMethodError | This is VirtualMethodError, a member of class TFreedObject.
Links
TFreedObject Class, Legend, Public Methods


TFreedObject.GetVirtualMethodIndex Method

TFreedObject.GetVirtualMethodIndex Method
TFreedObject Class TFreedObject Members nxmmFastMM4 Namespace TFreedObject Methods Send Feedback
Syntax
Delphi
procedure GetVirtualMethodIndex;
Description

This is GetVirtualMethodIndex, a member of class TFreedObject.

Group

TFreedObject Methods

Links
TFreedObject Class, TFreedObject Members, nxmmFastMM4 Namespace, TFreedObject Methods


TFreedObject.InterfaceError Method

TFreedObject.InterfaceError Method
TFreedObject Class TFreedObject Members nxmmFastMM4 Namespace TFreedObject Methods Send Feedback
Syntax
Delphi
procedure InterfaceError;
Description

This is InterfaceError, a member of class TFreedObject.

Group

TFreedObject Methods

Links
TFreedObject Class, TFreedObject Members, nxmmFastMM4 Namespace, TFreedObject Methods


TFreedObject.VirtualMethodError Method

TFreedObject.VirtualMethodError Method
TFreedObject Class TFreedObject Members nxmmFastMM4 Namespace TFreedObject Methods Send Feedback
Syntax
Delphi
procedure VirtualMethodError;
Description

This is VirtualMethodError, a member of class TFreedObject.

Group

TFreedObject Methods

Links
TFreedObject Class, TFreedObject Members, nxmmFastMM4 Namespace, TFreedObject Methods


Functions

Functions
Functions nxmmFastMM4 Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | >>>
CheckCanInstallMemoryManager | This is function nxmmFastMM4.CheckCanInstallMemoryManager.
DebugAllocMem | This is function nxmmFastMM4.DebugAllocMem.
DebugFreeMem | This is function nxmmFastMM4.DebugFreeMem.
DebugGetMem | The FullDebugMode memory manager functions
DebugReallocMem | This is function nxmmFastMM4.DebugReallocMem.
DeleteEventLog | HPPEMIT ' #define ClearLogFileOnStartup
DetectClassInstance | Returns the class for a memory block. Returns nil if it is not a valid class. Used by the leak detection code.
DetectStringData | Detects the probable string data type for a memory block. Used by the leak classification code when a block cannot be identified as a known class instance.
FastAllocMem | This is function nxmmFastMM4.FastAllocMem.
FastFreeMem | This is function nxmmFastMM4.FastFreeMem.
FastGetHeapStatus | Returns summarised information about the state of the memory manager. (For backward compatibility.)
FastGetMem | The standard memory manager functions
FastReallocMem | This is function nxmmFastMM4.FastReallocMem.
FinalizeMemoryManager | Called in FastMM4BCB.cpp, should contain codes of original "finalization" section
FreeAllMemory | Releases all allocated memory (use with extreme care)
GetCurrentAllocationGroup | Returns the current "allocation group". Whenever a GetMem request is serviced in FullDebugMode, the current "allocation group" is stored in the block header. This may help with debugging. Note that if a block is subsequently reallocated that it keeps its original "allocation group" and "allocation number" (all allocations are also numbered sequentially).
GetMemoryManagerState | Returns statistics about the current state of the memory manager
GetMemoryManagerUsageSummary | Returns a summary of the information returned by GetMemoryManagerState
GetMemoryMap | Gets the state of every 64K block in the 4GB address space
GetRegisteredMemoryLeaks | Returns a list of all expected memory leaks
InitializeMemoryManager |
InstallMemoryManager | This is function nxmmFastMM4.InstallMemoryManager.
InvalidAllocMem | This is function nxmmFastMM4.InvalidAllocMem.
InvalidFreeMem | Invalid handlers to catch MM operations after uninstall
InvalidGetMem | This is function nxmmFastMM4.InvalidGetMem.
InvalidReallocMem | This is function nxmmFastMM4.InvalidReallocMem.
InvalidRegisterAndUnRegisterMemoryLeak | This is function nxmmFastMM4.InvalidRegisterAndUnRegisterMemoryLeak.
LogAllocatedBlocksToFile | Logs detail about currently allocated memory blocks for the specified range of allocation groups. if ALastAllocationGroupToLog is less than AFirstAllocationGroupToLog or it is zero, then all allocation groups are logged. This routine also checks the memory pool for consistency at the same time, raising an "Out of Memory" error if the check fails.
Move12 | Fixed size move procedures Fixed size move operations ignore the size parameter. All moves are assumed to be non-overlapping.
Move20 | This is function nxmmFastMM4.Move20.
Move28 | This is function nxmmFastMM4.Move28.
Move36 | This is function nxmmFastMM4.Move36.
Move44 | This is function nxmmFastMM4.Move44.
Move52 | This is function nxmmFastMM4.Move52.
Move60 | This is function nxmmFastMM4.Move60.
Move68 | This is function nxmmFastMM4.Move68.
PopAllocationGroup | This is function nxmmFastMM4.PopAllocationGroup.
PushAllocationGroup | Allocation groups work in a stack like fashion. Group numbers are pushed onto and popped off the stack. Note that the stack size is limited, so every push should have a matching pop.
RegisterExpectedMemoryLeak | This is function nxmmFastMM4.RegisterExpectedMemoryLeak.
RegisterExpectedMemoryLeak | Registers expected memory leaks. Returns true on success. The list of leaked blocks is limited, so failure is possible if the list is full.
RegisterExpectedMemoryLeak | Registers expected memory leaks by virtual object's typeId pointer. Usage: RegisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);
RegisterExpectedMemoryLeak | This is function nxmmFastMM4.RegisterExpectedMemoryLeak.
Release | This is function nxmmFastMM4.Release.
ScanMemoryPoolForCorruptions | Scans the memory pool for any corruptions. If a corruption is encountered an "Out of Memory" exception is raised.
SetMMLogFileName | Specify the full path and name for the filename to be used for logging memory errors, etc. If ALogFileName is nil or points to an empty string it will revert to the default log file name.
UnregisterExpectedMemoryLeak | This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.
UnregisterExpectedMemoryLeak | Removes expected memory leaks. Returns true on success.
UnregisterExpectedMemoryLeak | Usage: UnregisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);
UnregisterExpectedMemoryLeak | This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.
Namespace

nxmmFastMM4 Namespace

Links
Functions, nxmmFastMM4 Namespace, Legend


nxmmFastMM4.AddRef Function

nxmmFastMM4.AddRef Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmFastMM4

Description

>>>

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.CheckCanInstallMemoryManager Function

nxmmFastMM4.CheckCanInstallMemoryManager Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function CheckCanInstallMemoryManager: Boolean;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.CheckCanInstallMemoryManager.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DebugAllocMem Function

nxmmFastMM4.DebugAllocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DebugAllocMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.DebugAllocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DebugFreeMem Function

nxmmFastMM4.DebugFreeMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DebugFreeMem(APointer: Pointer): Integer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.DebugFreeMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DebugGetMem Function

nxmmFastMM4.DebugGetMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DebugGetMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

The FullDebugMode memory manager functions

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DebugReallocMem Function

nxmmFastMM4.DebugReallocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DebugReallocMem(APointer: Pointer; ANewSize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.DebugReallocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DeleteEventLog Function

nxmmFastMM4.DeleteEventLog Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure DeleteEventLog;
File

nxmmFastMM4

Description

HPPEMIT ' #define ClearLogFileOnStartup

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DetectClassInstance Function

nxmmFastMM4.DetectClassInstance Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DetectClassInstance(APointer: Pointer): TClass;
File

nxmmFastMM4

Description

Returns the class for a memory block. Returns nil if it is not a valid class. Used by the leak detection code.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.DetectStringData Function

nxmmFastMM4.DetectStringData Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function DetectStringData(APMemoryBlock: Pointer; AAvailableSpaceInBlock: Integer): TStringDataType;
File

nxmmFastMM4

Description

Detects the probable string data type for a memory block. Used by the leak classification code when a block cannot be identified as a known class instance.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FastAllocMem Function

nxmmFastMM4.FastAllocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function FastAllocMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.FastAllocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FastFreeMem Function

nxmmFastMM4.FastFreeMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function FastFreeMem(APointer: Pointer): Integer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.FastFreeMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FastGetHeapStatus Function

nxmmFastMM4.FastGetHeapStatus Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function FastGetHeapStatus: THeapStatus;
File

nxmmFastMM4

Description

Returns summarised information about the state of the memory manager. (For backward compatibility.)

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FastGetMem Function

nxmmFastMM4.FastGetMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function FastGetMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

The standard memory manager functions

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FastReallocMem Function

nxmmFastMM4.FastReallocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function FastReallocMem(APointer: Pointer; ANewSize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.FastReallocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FinalizeMemoryManager Function

nxmmFastMM4.FinalizeMemoryManager Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure FinalizeMemoryManager;
File

nxmmFastMM4

Description

Called in FastMM4BCB.cpp, should contain codes of original "finalization" section

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.FreeAllMemory Function

nxmmFastMM4.FreeAllMemory Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure FreeAllMemory;
File

nxmmFastMM4

Description

Releases all allocated memory (use with extreme care)

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.GetCurrentAllocationGroup Function

nxmmFastMM4.GetCurrentAllocationGroup Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function GetCurrentAllocationGroup: Cardinal;
File

nxmmFastMM4

Description

Returns the current "allocation group". Whenever a GetMem request is serviced in FullDebugMode, the current "allocation group" is stored in the block header. This may help with debugging. Note that if a block is subsequently reallocated that it keeps its original "allocation group" and "allocation number" (all allocations are also numbered sequentially).

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.GetMemoryManagerState Function

nxmmFastMM4.GetMemoryManagerState Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure GetMemoryManagerState(var AMemoryManagerState: TMemoryManagerState);
File

nxmmFastMM4

Description

Returns statistics about the current state of the memory manager

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.GetMemoryManagerUsageSummary Function

nxmmFastMM4.GetMemoryManagerUsageSummary Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure GetMemoryManagerUsageSummary(var AMemoryManagerUsageSummary: TMemoryManagerUsageSummary);
File

nxmmFastMM4

Description

Returns a summary of the information returned by GetMemoryManagerState

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.GetMemoryMap Function

nxmmFastMM4.GetMemoryMap Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure GetMemoryMap(var AMemoryMap: TMemoryMap);
File

nxmmFastMM4

Description

Gets the state of every 64K block in the 4GB address space

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.GetRegisteredMemoryLeaks Function

nxmmFastMM4.GetRegisteredMemoryLeaks Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function GetRegisteredMemoryLeaks: TRegisteredMemoryLeaks;
File

nxmmFastMM4

Description

Returns a list of all expected memory leaks

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InitializeMemoryManager Function

nxmmFastMM4.InitializeMemoryManager Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure InitializeMemoryManager;
File

nxmmFastMM4

Description
------------------------Public procedures---------------------------

Installation procedures must be exposed for the BCB helper unit FastMM4BCB.cpp

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InstallMemoryManager Function

nxmmFastMM4.InstallMemoryManager Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure InstallMemoryManager;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.InstallMemoryManager.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InvalidAllocMem Function

nxmmFastMM4.InvalidAllocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function InvalidAllocMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.InvalidAllocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InvalidFreeMem Function

nxmmFastMM4.InvalidFreeMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function InvalidFreeMem(APointer: Pointer): Integer;
File

nxmmFastMM4

Description

Invalid handlers to catch MM operations after uninstall

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InvalidGetMem Function

nxmmFastMM4.InvalidGetMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function InvalidGetMem(ASize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.InvalidGetMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InvalidReallocMem Function

nxmmFastMM4.InvalidReallocMem Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function InvalidReallocMem(APointer: Pointer; ANewSize: TnxMemSize): Pointer;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.InvalidReallocMem.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.InvalidRegisterAndUnRegisterMemoryLeak Function

nxmmFastMM4.InvalidRegisterAndUnRegisterMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function InvalidRegisterAndUnRegisterMemoryLeak(APointer: Pointer): Boolean;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.InvalidRegisterAndUnRegisterMemoryLeak.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.LogAllocatedBlocksToFile Function

nxmmFastMM4.LogAllocatedBlocksToFile Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure LogAllocatedBlocksToFile(AFirstAllocationGroupToLog: Cardinal; ALastAllocationGroupToLog: Cardinal);
File

nxmmFastMM4

Description

Logs detail about currently allocated memory blocks for the specified range of allocation groups. if ALastAllocationGroupToLog is less than AFirstAllocationGroupToLog or it is zero, then all allocation groups are logged. This routine also checks the memory pool for consistency at the same time, raising an "Out of Memory" error if the check fails.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move12 Function

nxmmFastMM4.Move12 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move12(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

Fixed size move procedures

Fixed size move operations ignore the size parameter. All moves are assumed to be non-overlapping.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move20 Function

nxmmFastMM4.Move20 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move20(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move20.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move28 Function

nxmmFastMM4.Move28 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move28(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move28.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move36 Function

nxmmFastMM4.Move36 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move36(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move36.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move44 Function

nxmmFastMM4.Move44 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move44(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move44.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move52 Function

nxmmFastMM4.Move52 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move52(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move52.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move60 Function

nxmmFastMM4.Move60 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move60(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move60.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Move68 Function

nxmmFastMM4.Move68 Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Move68(const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Move68.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.PopAllocationGroup Function

nxmmFastMM4.PopAllocationGroup Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure PopAllocationGroup;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.PopAllocationGroup.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.PushAllocationGroup Function

nxmmFastMM4.PushAllocationGroup Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure PushAllocationGroup(ANewCurrentAllocationGroup: Cardinal);
File

nxmmFastMM4

Description

Allocation groups work in a stack like fashion. Group numbers are pushed onto and popped off the stack. Note that the stack size is limited, so every push should have a matching pop.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.RegisterExpectedMemoryLeak Function

nxmmFastMM4.RegisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function RegisterExpectedMemoryLeak(ALeakedBlockSize: Integer; ACount: Integer = 1): Boolean; overload;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.RegisterExpectedMemoryLeak.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.RegisterExpectedMemoryLeak Function

nxmmFastMM4.RegisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function RegisterExpectedMemoryLeak(ALeakedPointer: Pointer): Boolean; overload;
File

nxmmFastMM4

Description

Registers expected memory leaks. Returns true on success. The list of leaked blocks is limited, so failure is possible if the list is full.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.RegisterExpectedMemoryLeak Function

nxmmFastMM4.RegisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function RegisterExpectedMemoryLeak(ALeakedCppVirtObjTypeIdPtr: Pointer; ACount: Integer = 1): boolean; overload;
File

nxmmFastMM4

Description

Registers expected memory leaks by virtual object's typeId pointer. Usage: RegisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.RegisterExpectedMemoryLeak Function

nxmmFastMM4.RegisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function RegisterExpectedMemoryLeak(ALeakedObjectClass: TClass; ACount: Integer = 1): Boolean; overload;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.RegisterExpectedMemoryLeak.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.Release Function

nxmmFastMM4.Release Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.Release.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.ScanMemoryPoolForCorruptions Function

nxmmFastMM4.ScanMemoryPoolForCorruptions Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure ScanMemoryPoolForCorruptions;
File

nxmmFastMM4

Description

Scans the memory pool for any corruptions. If a corruption is encountered an "Out of Memory" exception is raised.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.SetMMLogFileName Function

nxmmFastMM4.SetMMLogFileName Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
procedure SetMMLogFileName(ALogFileName: PAnsiChar = nil);
File

nxmmFastMM4

Description

Specify the full path and name for the filename to be used for logging memory errors, etc. If ALogFileName is nil or points to an empty string it will revert to the default log file name.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.UnregisterExpectedMemoryLeak Function

nxmmFastMM4.UnregisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function UnregisterExpectedMemoryLeak(ALeakedBlockSize: Integer; ACount: Integer = 1): Boolean; overload;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.UnregisterExpectedMemoryLeak Function

nxmmFastMM4.UnregisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function UnregisterExpectedMemoryLeak(ALeakedPointer: Pointer): Boolean; overload;
File

nxmmFastMM4

Description

Removes expected memory leaks. Returns true on success.

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.UnregisterExpectedMemoryLeak Function

nxmmFastMM4.UnregisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function UnregisterExpectedMemoryLeak(ALeakedCppVirtObjTypeIdPtr: Pointer; ACount: Integer = 1): boolean; overload;
File

nxmmFastMM4

Description

Usage: UnregisterExpectedMemoryLeak(typeid(ACppObject).tpp, Count);

Group

Functions

Links
nxmmFastMM4, Functions


nxmmFastMM4.UnregisterExpectedMemoryLeak Function

nxmmFastMM4.UnregisterExpectedMemoryLeak Function
nxmmFastMM4 Functions Send Feedback
Syntax
Delphi
function UnregisterExpectedMemoryLeak(ALeakedObjectClass: TClass; ACount: Integer = 1): Boolean; overload;
File

nxmmFastMM4

Description

This is function nxmmFastMM4.UnregisterExpectedMemoryLeak.

Group

Functions

Links
nxmmFastMM4, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxmmFastMM4 Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TBlockOperation | This is record nxmmFastMM4.TBlockOperation.
TChunkStatus | Memory map
TMemoryLeakType | Different kinds of memory leaks
TStringDataType | Used by the DetectStringData routine to detect whether a leaked block contains string data.
Namespace

nxmmFastMM4 Namespace

Records
Name | Description
StrRec | This is record nxmmFastMM4.StrRec.
TExpectedMemoryLeak | This is record nxmmFastMM4.TExpectedMemoryLeak.
TExpectedMemoryLeaks | This is record nxmmFastMM4.TExpectedMemoryLeaks.
TFullDebugBlockHeader | This is record nxmmFastMM4.TFullDebugBlockHeader.
TLargeBlockHeader | This is record nxmmFastMM4.TLargeBlockHeader.
TMediumBlockPoolHeader | This is record nxmmFastMM4.TMediumBlockPoolHeader.
TMediumFreeBlock | This is record nxmmFastMM4.TMediumFreeBlock.
TMemoryManagerState | This is record nxmmFastMM4.TMemoryManagerState.
TMemoryManagerUsageSummary | This is record nxmmFastMM4.TMemoryManagerUsageSummary.
TRegisteredMemoryLeak | List of registered leaks
TRegisters | Registers structure (for GetCPUID)
TSmallBlockPoolHeader | Small block pool (Size = 32 bytes)
TSmallBlockType | This is record nxmmFastMM4.TSmallBlockType.
TSmallBlockTypeState | Public types
Links
Enumerations, nxmmFastMM4 Namespace, Legend, Records


nxmmFastMM4.StrRec Record

nxmmFastMM4.StrRec Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
StrRec = packed record
  codePage: Word;
  elemSize: Word;
  refCnt: Longint;
  length: Longint;
end;
File

nxmmFastMM4

Description

This is record nxmmFastMM4.StrRec.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TBlockOperation Enumeration

nxmmFastMM4.TBlockOperation Enumeration
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TBlockOperation = ( boBlockCheck, boGetMem, boFreeMem, boReallocMem );
File

nxmmFastMM4

Description

This is record nxmmFastMM4.TBlockOperation.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TChunkStatus Enumeration

nxmmFastMM4.TChunkStatus Enumeration
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TChunkStatus = ( csUnallocated, csAllocated, csReserved, csSysAllocated, csSysReserved );
File

nxmmFastMM4

Description

Memory map

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TExpectedMemoryLeak Record

nxmmFastMM4.TExpectedMemoryLeak Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TExpectedMemoryLeak = packed record
  NextLeak: PExpectedMemoryLeak;
  PreviousLeak: PExpectedMemoryLeak;
  LeakAddress: Pointer;
  LeakedClass: TClass;
  LeakedCppTypeIdPtr: Pointer;
  LeakSize: Integer;
  LeakCount: Integer;
end;
File

nxmmFastMM4

Members
Members | Description
NextLeak: PExpectedMemoryLeak; | Linked list pointers
PreviousLeak: PExpectedMemoryLeak; | Linked list pointers
LeakAddress: Pointer; | Information about the expected leak
Description

This is record nxmmFastMM4.TExpectedMemoryLeak.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TExpectedMemoryLeaks Record

nxmmFastMM4.TExpectedMemoryLeaks Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TExpectedMemoryLeaks = packed record
  EntriesUsed: Integer;
  FirstFreeSlot: PExpectedMemoryLeak;
  FirstEntryByAddress: PExpectedMemoryLeak;
  FirstEntryByClass: PExpectedMemoryLeak;
  FirstEntryBySizeOnly: PExpectedMemoryLeak;
  ExpectedLeaks: packed array[0..(ExpectedMemoryLeaksListSize - 20) div SizeOf(TExpectedMemoryLeak) - 1] of TExpectedMemoryLeak;
end;
File

nxmmFastMM4

Members
Members | Description
EntriesUsed: Integer; | The number of entries used in the expected leaks buffer
FirstFreeSlot: PExpectedMemoryLeak; | Freed entries
FirstEntryByAddress: PExpectedMemoryLeak; | Entries with the address specified
FirstEntryByClass: PExpectedMemoryLeak; | Entries with no address specified, but with the class specified
FirstEntryBySizeOnly: PExpectedMemoryLeak; | Entries with only size specified
ExpectedLeaks: packed array[0..(ExpectedMemoryLeaksListSize - 20) div SizeOf(TExpectedMemoryLeak) - 1] of TExpectedMemoryLeak; | The expected leaks buffer
Description

This is record nxmmFastMM4.TExpectedMemoryLeaks.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TFullDebugBlockHeader Record

nxmmFastMM4.TFullDebugBlockHeader Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TFullDebugBlockHeader = packed record
  Reserved1: Cardinal;
  Reserved2: Cardinal;
  AllocatedByRoutine: Pointer;
  AllocationGroup: Cardinal;
  AllocationNumber: Cardinal;
  AllocationStackTrace: TStackTrace;
  AllocatedByThread: Cardinal;
  FreeStackTrace: TStackTrace;
  FreedByThread: Cardinal;
  UserSize: Cardinal;
  PreviouslyUsedByClass: Cardinal;
  HeaderCheckSum: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
Reserved1: Cardinal; | Space used by the medium block manager for previous/next block management. If a medium block is binned then these two dwords will be modified.
AllocatedByRoutine: Pointer; | Is the block currently allocated? If it is allocated this will be the address of the getmem routine through which it was allocated, otherwise it will be nil.
AllocationGroup: Cardinal; | The allocation group: Can be used in the debugging process to group related memory leaks together
AllocationNumber: Cardinal; | The allocation number: All new allocations are numbered sequentially. This number may be useful in memory leak analysis. If it reaches 4G it wraps back to 0.
AllocationStackTrace: TStackTrace; | The call stack when the block was allocated
AllocatedByThread: Cardinal; | The thread that allocated the block
FreeStackTrace: TStackTrace; | The call stack when the block was freed
FreedByThread: Cardinal; | The thread that freed the block
UserSize: Cardinal; | The user requested size for the block. 0 if this is the first time the block is used.
PreviouslyUsedByClass: Cardinal; | The object class this block was used for the previous time it was allocated. When a block is freed, the dword that would normally be in the space of the class pointer is copied here, so if it is detected that the block was used after being freed we have an idea what class it is.
HeaderCheckSum: Cardinal; | The sum of all the dwords excluding reserved dwords.
Description

This is record nxmmFastMM4.TFullDebugBlockHeader.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TLargeBlockHeader Record

nxmmFastMM4.TLargeBlockHeader Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TLargeBlockHeader = packed record
  MappedBlocks: Integer;
  ReservedBlocks: Integer;
  FileMapping: THandle;
  MappedBase: Pointer;
  CommitedPagesMapped: Integer;
  CommitedPagesTotal: Integer;
  ReallocGrowCount: Cardinal;
  Reserved: array[0..4] of Cardinal;
  PreviousLargeBlockHeader: PLargeBlockHeader;
  NextLargeBlockHeader: PLargeBlockHeader;
  UserAllocatedSize: Cardinal;
  BlockSizeAndFlags: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
MappedBlocks: Integer; | >>>
PreviousLargeBlockHeader: PLargeBlockHeader; | <<< Points to the previous and next large blocks. This circular linked list is used to track memory leaks on program shutdown.
UserAllocatedSize: Cardinal; | The user allocated size of the Large block
BlockSizeAndFlags: Cardinal; | The size of this block plus the flags
Description

This is record nxmmFastMM4.TLargeBlockHeader.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TMediumBlockPoolHeader Record

nxmmFastMM4.TMediumBlockPoolHeader Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TMediumBlockPoolHeader = packed record
  PreviousMediumBlockPoolHeader: PMediumBlockPoolHeader;
  NextMediumBlockPoolHeader: PMediumBlockPoolHeader;
  Reserved: Cardinal;
  FirstMediumBlockSizeAndFlags: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
PreviousMediumBlockPoolHeader: PMediumBlockPoolHeader; | Points to the previous and next medium block pools. This circular linked list is used to track memory leaks on program shutdown.
Reserved: Cardinal; | Unused dword
FirstMediumBlockSizeAndFlags: Cardinal; | The block size and flags of the first medium block in the block pool
Description

This is record nxmmFastMM4.TMediumBlockPoolHeader.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TMediumFreeBlock Record

nxmmFastMM4.TMediumFreeBlock Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TMediumFreeBlock = packed record
  PreviousFreeBlock: PMediumFreeBlock;
  NextFreeBlock: PMediumFreeBlock;
end;
File

nxmmFastMM4

Description

This is record nxmmFastMM4.TMediumFreeBlock.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TMemoryLeakType Enumeration

nxmmFastMM4.TMemoryLeakType Enumeration
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TMemoryLeakType = ( mltUnexpectedLeak, mltExpectedLeakRegisteredByPointer, mltExpectedLeakRegisteredByClass, mltExpectedLeakRegisteredBySize );
File

nxmmFastMM4

Description

Different kinds of memory leaks

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TMemoryManagerState Record

nxmmFastMM4.TMemoryManagerState Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TMemoryManagerState = packed record
  SmallBlockTypeStates: TSmallBlockTypeStates;
  AllocatedMediumBlockCount: Cardinal;
  TotalAllocatedMediumBlockSize: Cardinal;
  ReservedMediumBlockAddressSpace: Cardinal;
  AllocatedLargeBlockCount: Cardinal;
  TotalAllocatedLargeBlockSize: Cardinal;
  ReservedLargeBlockAddressSpace: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
SmallBlockTypeStates: TSmallBlockTypeStates; | Small block type states
AllocatedMediumBlockCount: Cardinal; | Medium block stats
AllocatedLargeBlockCount: Cardinal; | Large block stats
Description

This is record nxmmFastMM4.TMemoryManagerState.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TMemoryManagerUsageSummary Record

nxmmFastMM4.TMemoryManagerUsageSummary Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TMemoryManagerUsageSummary = packed record
  AllocatedBytes: Cardinal;
  OverheadBytes: Cardinal;
  EfficiencyPercentage: Double;
end;
File

nxmmFastMM4

Members
Members | Description
AllocatedBytes: Cardinal; | The total number of bytes allocated by the application.
OverheadBytes: Cardinal; | The total number of address space bytes used by control structures, or lost due to fragmentation and other overhead.
EfficiencyPercentage: Double; | The efficiency of the memory manager expressed as a percentage. This is 100 * AllocatedBytes / (AllocatedBytes + OverheadBytes).
Description

This is record nxmmFastMM4.TMemoryManagerUsageSummary.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TRegisteredMemoryLeak Record

nxmmFastMM4.TRegisteredMemoryLeak Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TRegisteredMemoryLeak = packed record
  LeakAddress: Pointer;
  LeakedClass: TClass;
  LeakedCppTypeIdPtr: Pointer;
  LeakSize: Integer;
  LeakCount: Integer;
end;
File

nxmmFastMM4

Description

List of registered leaks

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TRegisters Record

nxmmFastMM4.TRegisters Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TRegisters = record
  RegEAX: Integer;
  RegEBX: Integer;
  RegECX: Integer;
  RegEDX: Integer;
end;
File

nxmmFastMM4

Description

Registers structure (for GetCPUID)

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TSmallBlockPoolHeader Record

nxmmFastMM4.TSmallBlockPoolHeader Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TSmallBlockPoolHeader = packed record
  BlockType: PSmallBlockType;
  NextPartiallyFreePool: PSmallBlockPoolHeader;
  FirstFreeBlock: Pointer;
  BlocksInUse: Cardinal;
  Reserved1: Cardinal;
  PreviousPartiallyFreePool: PSmallBlockPoolHeader;
  Reserved2: Cardinal;
  FirstBlockPoolPointerAndFlags: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
BlockType: PSmallBlockType; | BlockType
NextPartiallyFreePool: PSmallBlockPoolHeader; | The next pool that has free blocks of this size. Must be at offset +4 to be typecast compatible with TSmallBlockType
FirstFreeBlock: Pointer; | Pointer to the first free block inside this pool. Must be at offset + 8 to be at the same offset as "NextSequentialFeedBlockAddress" of TSmallBlockType
BlocksInUse: Cardinal; | The number of blocks allocated in this pool. Must be at offset + 12 to be at the same offset as "MaxSequentialFeedBlockAddress" of TSmallBlockType
Reserved1: Cardinal; | Reserved
PreviousPartiallyFreePool: PSmallBlockPoolHeader; | The previous pool that has free blocks of this size. Must be at offset +20 to be compatible with TSmallBlockType
Reserved2: Cardinal; | Reserved
FirstBlockPoolPointerAndFlags: Cardinal; | The pool pointer and flags of the first block
Description

Small block pool (Size = 32 bytes)

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TSmallBlockType Record

nxmmFastMM4.TSmallBlockType Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TSmallBlockType = packed record
  BlockTypeLocked: Boolean;
  AllowedGroupsForBlockPoolBitmap: byte;
  BlockSize: Word;
  NextPartiallyFreePool: PSmallBlockPoolHeader;
  NextSequentialFeedBlockAddress: Pointer;
  MaxSequentialFeedBlockAddress: Pointer;
  CurrentSequentialFeedPool: PSmallBlockPoolHeader;
  PreviousPartiallyFreePool: PSmallBlockPoolHeader;
  MinimumBlockPoolSize: Word;
  OptimalBlockPoolSize: Word;
  UpsizeMoveProcedure: TMoveProc;
  Reserved1: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
BlockTypeLocked: Boolean; | True = Block type is locked
AllowedGroupsForBlockPoolBitmap: byte; | Bitmap indicating which of the first 8 medium block groups contain blocks of a suitable size for a block pool.
BlockSize: Word; | The block size for this block type
NextPartiallyFreePool: PSmallBlockPoolHeader; | The first partially free pool for the given small block type (offset = +4 for typecast compatibility with TSmallBlockPoolHeader). This is a circular buffer.
NextSequentialFeedBlockAddress: Pointer; | The offset of the last block that was served sequentially (0ffset = +8 to to be at the same offset as the "FirstFreeBlock" of TSmallBlockPoolHeader
MaxSequentialFeedBlockAddress: Pointer; | The last block that can be served sequentially. Offset is at +12 to be at the same address as the "BlocksInUse" field of TSmallBlockPoolHeader
CurrentSequentialFeedPool: PSmallBlockPoolHeader; | The pool that is current being used to serve blocks in sequential order
PreviousPartiallyFreePool: PSmallBlockPoolHeader; | The previous partially free pool for the small block type (offset = +20 for typecast compatibility with TSmallBlockPoolHeader)
MinimumBlockPoolSize: Word; | The minimum and optimal size of a small block pool for this block type
UpsizeMoveProcedure: TMoveProc; | The fixed size move procedure used to move data for this block size when it is upsized. When a block is downsized (which usually does not occur that often) the variable size move routine is used.
Description

This is record nxmmFastMM4.TSmallBlockType.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TSmallBlockTypeState Record

nxmmFastMM4.TSmallBlockTypeState Record
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TSmallBlockTypeState = packed record
  InternalBlockSize: Cardinal;
  UseableBlockSize: Cardinal;
  AllocatedBlockCount: Cardinal;
  ReservedAddressSpace: Cardinal;
end;
File

nxmmFastMM4

Members
Members | Description
InternalBlockSize: Cardinal; | The internal size of the block type
UseableBlockSize: Cardinal; | Useable block size: The number of non-reserved bytes inside the block.
AllocatedBlockCount: Cardinal; | The number of allocated blocks
ReservedAddressSpace: Cardinal; | The total address space reserved for this block type (both allocated and free blocks)
Description

Public types

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


nxmmFastMM4.TStringDataType Enumeration

nxmmFastMM4.TStringDataType Enumeration
nxmmFastMM4 Structs, Records, Enums Send Feedback
Syntax
Delphi
TStringDataType = ( stUnknown, stAnsiString, stUnicodeString );
File

nxmmFastMM4

Description

Used by the DetectStringData routine to detect whether a leaked block contains string data.

Group

Structs, Records, Enums

Links
nxmmFastMM4, Structs, Records, Enums


Types

Types
nxmmFastMM4 Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmFastMM4 Namespace

Types
Name | Description
PCardinal | Delphi 5 Compatibility
PExpectedMemoryLeak | The layout of an expected leak. All fields may not be specified, in which case it may be harder to determine which leaks are expected and which are not.
PExpectedMemoryLeaks | This is type nxmmFastMM4.PExpectedMemoryLeaks.
PFullDebugBlockHeader | The header placed in front blocks in FullDebugMode (just after the standard header). Must be a multiple of 16 bytes in size otherwise the Align16Bytes option will not work. Current size = 128 bytes.
PInteger | Define some additional types for BCB4
PLargeBlockHeader | Large block header record (size = 16)
PMediumBlockPoolHeader | The medium block pool from which medium blocks are drawn
PMediumFreeBlock | Medium block layout: Offset: -8 = Previous Block Size (only if the previous block is free) Offset: -4 = This block size and flags Offset: 0 = User data / Previous Free Block (if this block is free) Offset: 4 = Next Free Block (if this block is free) Offset: BlockSize - 8 = Size of this block (if this block is free) Offset: BlockSize - 4 = Size of the next block and flags {A medium block that is unused
PPExpectedMemoryLeak | This is type nxmmFastMM4.PPExpectedMemoryLeak.
PPointer | This is type nxmmFastMM4.PPointer.
PSmallBlockPoolHeader | Pointer to the header of a small block pool
PSmallBlockType | Small block type (Size = 32)
PStackTrace | Full Debug Mode Structures
PStrRec | The layout of a string allocation. Used to detect string leaks.
TGetCppVirtObjSizeByTypeIdPtrFunc | HPPEMIT ''#13#10 HPPEMIT '#define CheckCppObjectTypeEnabled'
TGetCppVirtObjTypeIdPtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeIdPtrFunc.
TGetCppVirtObjTypeNameByTypeIdPtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameByTypeIdPtrFunc.
TGetCppVirtObjTypeNameByVTablePtrFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameByVTablePtrFunc.
TGetCppVirtObjTypeNameFunc | This is type nxmmFastMM4.TGetCppVirtObjTypeNameFunc.
TMemoryMap | This is type nxmmFastMM4.TMemoryMap.
TMoveProc | Move procedure type
TRegisteredMemoryLeaks | This is type nxmmFastMM4.TRegisteredMemoryLeaks.
TSmallBlockTypeStates | This is type nxmmFastMM4.TSmallBlockTypeStates.
TStackTrace | This is type nxmmFastMM4.TStackTrace.
Links
nxmmFastMM4 Namespace, Types


nxmmFastMM4.PCardinal Type

nxmmFastMM4.PCardinal Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PCardinal = ^Cardinal;
File

nxmmFastMM4

Description

Delphi 5 Compatibility

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PExpectedMemoryLeak Type

nxmmFastMM4.PExpectedMemoryLeak Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PExpectedMemoryLeak = ^TExpectedMemoryLeak;
File

nxmmFastMM4

Description

The layout of an expected leak. All fields may not be specified, in which case it may be harder to determine which leaks are expected and which are not.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PExpectedMemoryLeaks Type

nxmmFastMM4.PExpectedMemoryLeaks Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PExpectedMemoryLeaks = ^TExpectedMemoryLeaks;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.PExpectedMemoryLeaks.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PFullDebugBlockHeader Type

nxmmFastMM4.PFullDebugBlockHeader Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PFullDebugBlockHeader = ^TFullDebugBlockHeader;
File

nxmmFastMM4

Description

The header placed in front blocks in FullDebugMode (just after the standard header). Must be a multiple of 16 bytes in size otherwise the Align16Bytes option will not work. Current size = 128 bytes.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PInteger Type

nxmmFastMM4.PInteger Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PInteger = ^Integer;
File

nxmmFastMM4

Description

Define some additional types for BCB4

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PLargeBlockHeader Type

nxmmFastMM4.PLargeBlockHeader Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PLargeBlockHeader = ^TLargeBlockHeader;
File

nxmmFastMM4

Description

Large block header record (size = 16)

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PMediumBlockPoolHeader Type

nxmmFastMM4.PMediumBlockPoolHeader Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PMediumBlockPoolHeader = ^TMediumBlockPoolHeader;
File

nxmmFastMM4

Description

The medium block pool from which medium blocks are drawn

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PMediumFreeBlock Type

nxmmFastMM4.PMediumFreeBlock Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PMediumFreeBlock = ^TMediumFreeBlock;
File

nxmmFastMM4

Description

Medium block layout: Offset: -8 = Previous Block Size (only if the previous block is free) Offset: -4 = This block size and flags Offset: 0 = User data / Previous Free Block (if this block is free) Offset: 4 = Next Free Block (if this block is free) Offset: BlockSize - 8 = Size of this block (if this block is free) Offset: BlockSize - 4 = Size of the next block and flags

{A medium block that is unused

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PPExpectedMemoryLeak Type

nxmmFastMM4.PPExpectedMemoryLeak Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PPExpectedMemoryLeak = ^PExpectedMemoryLeak;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.PPExpectedMemoryLeak.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PPointer Type

nxmmFastMM4.PPointer Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PPointer = ^Pointer;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.PPointer.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PSmallBlockPoolHeader Type

nxmmFastMM4.PSmallBlockPoolHeader Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PSmallBlockPoolHeader = ^TSmallBlockPoolHeader;
File

nxmmFastMM4

Description

Pointer to the header of a small block pool

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PSmallBlockType Type

nxmmFastMM4.PSmallBlockType Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PSmallBlockType = ^TSmallBlockType;
File

nxmmFastMM4

Description

Small block type (Size = 32)

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PStackTrace Type

nxmmFastMM4.PStackTrace Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PStackTrace = ^TStackTrace;
File

nxmmFastMM4

Description

Full Debug Mode Structures

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.PStrRec Type

nxmmFastMM4.PStrRec Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
PStrRec = ^StrRec;
File

nxmmFastMM4

Description

The layout of a string allocation. Used to detect string leaks.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TGetCppVirtObjSizeByTypeIdPtrFunc Type

nxmmFastMM4.TGetCppVirtObjSizeByTypeIdPtrFunc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TGetCppVirtObjSizeByTypeIdPtrFunc = function (APointer: Pointer): Cardinal;
File

nxmmFastMM4

Description

HPPEMIT ''#13#10 HPPEMIT '#define CheckCppObjectTypeEnabled'

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TGetCppVirtObjTypeIdPtrFunc Type

nxmmFastMM4.TGetCppVirtObjTypeIdPtrFunc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TGetCppVirtObjTypeIdPtrFunc = function (APointer: Pointer; ASize: Cardinal): Pointer;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TGetCppVirtObjTypeIdPtrFunc.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TGetCppVirtObjTypeNameByTypeIdPtrFunc Type

nxmmFastMM4.TGetCppVirtObjTypeNameByTypeIdPtrFunc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TGetCppVirtObjTypeNameByTypeIdPtrFunc = function (APointer: Pointer): PAnsiChar;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TGetCppVirtObjTypeNameByTypeIdPtrFunc.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TGetCppVirtObjTypeNameByVTablePtrFunc Type

nxmmFastMM4.TGetCppVirtObjTypeNameByVTablePtrFunc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TGetCppVirtObjTypeNameByVTablePtrFunc = function (AVTablePtr: Pointer; AVTablePtrOffset: Cardinal): PAnsiChar;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TGetCppVirtObjTypeNameByVTablePtrFunc.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TGetCppVirtObjTypeNameFunc Type

nxmmFastMM4.TGetCppVirtObjTypeNameFunc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TGetCppVirtObjTypeNameFunc = function (APointer: Pointer; ASize: Cardinal): PAnsiChar;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TGetCppVirtObjTypeNameFunc.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TMemoryMap Type

nxmmFastMM4.TMemoryMap Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TMemoryMap = array[0..65535] of TChunkStatus;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TMemoryMap.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TMoveProc Type

nxmmFastMM4.TMoveProc Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TMoveProc = procedure (const ASource; var ADest; ACount: Integer);
File

nxmmFastMM4

Description

Move procedure type

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TRegisteredMemoryLeaks Type

nxmmFastMM4.TRegisteredMemoryLeaks Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TRegisteredMemoryLeaks = array of TRegisteredMemoryLeak;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TRegisteredMemoryLeaks.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TSmallBlockTypeStates Type

nxmmFastMM4.TSmallBlockTypeStates Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TSmallBlockTypeStates = array[0..NumSmallBlockTypes - 1] of TSmallBlockTypeState;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TSmallBlockTypeStates.

Group

Types

Links
nxmmFastMM4, Types


nxmmFastMM4.TStackTrace Type

nxmmFastMM4.TStackTrace Type
nxmmFastMM4 Types Send Feedback
Syntax
Delphi
TStackTrace = array[0..StackTraceDepth - 1] of Cardinal;
File

nxmmFastMM4

Description

This is type nxmmFastMM4.TStackTrace.

Group

Types

Links
nxmmFastMM4, Types


Variables

Variables
nxmmFastMM4 Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmFastMM4 Namespace

Variables
Name | Description
_Seq | make sure thread IDs are never reused
AllocationGroupStack | The allocation group stack
AllocationGroupStackTop | The allocation group stack top (it is an index into AllocationGroupStack)
AllocSize2SmallBlockTypeIndX4 | Size to small block type translation table
CurrentAllocationNumber | The last allocation number used
ExpectedMemoryLeaks | The expected memory leaks
ExpectedMemoryLeaksListLocked | This is variable nxmmFastMM4.ExpectedMemoryLeaksListLocked.
FastMMIsInstalled | Has FastMM been installed?
FreedObjectVMT | The fake VMT used to catch virtual method calls on freed objects.
FullDebugModeScanMemoryPoolBeforeEveryOperation | If this variable is set to true and FullDebugMode is enabled, then the entire memory pool is checked for consistency before every memory operation. Note that this incurs a massive performance hit on top of the already significant FullDebugMode overhead, so enable this option only when absolutely necessary.
GetCppVirtObjSizeByTypeIdPtrFunc | Return virtual object's size from typeId pointer
GetCppVirtObjTypeIdPtrFunc | Retrieve virtual object's typeId pointer
GetCppVirtObjTypeNameByTypeIdPtrFunc | Return virtual object's type name from typeId pointer
GetCppVirtObjTypeNameByVTablePtrFunc | Retrieve virtual object's typeId pointer from it's virtual table pointer
GetCppVirtObjTypeNameFunc | Retrieve virtual object's type name
InvalidMemoryManager | Invalid handlers to catch MM operations after uninstall
IsMemoryManagerOwner | Is the MM in place a shared memory manager?
LargeBlocksCircularList | A dummy large block header: Maintains a list of all allocated large blocks to enable memory leak detection on program shutdown.
LargeBlocksLocked |
LastSequentiallyFedMediumBlock | The sequential feed medium block pool.
MappingObjectHandle | The handle of the memory mapped file
MappingObjectName | A string uniquely identifying the current process (for sharing the memory manager between DLLs and the main application)
MediumBlockBinBitmaps | The medium block bins: total of 32 * 32 = 1024 bins of a certain minimum size.
MediumBlockBinGroupBitmap | The medium block bins are divided into groups of 32 bins. If a bit is set in this group bitmap, then at least one bin in the group has free blocks.
MediumBlockBins | The medium block bins. There are 1024 LIFO circular linked lists each holding blocks of a specified minimum size. The sizes vary in size from MinimumMediumBlockSize to MaximumMediumBlockSize. The bins are treated as type TMediumFreeBlock to avoid pointer checks.
MediumBlockPoolsCircularList |
MediumBlocksLocked | Are medium blocks locked?
MediumSequentialFeedBytesLeft | This is variable nxmmFastMM4.MediumSequentialFeedBytesLeft.
MMLogFileName | The current log file name
MMWindow | The handle of the MM window
MMWindowBE | The handle of the MM window (for default MM of Delphi 2006 compatibility)
NewMemoryManager | The replacement memory manager
OldMemoryManager |
pCppDebugHook | PInteger not defined in BCB5
ReportMemoryLeaksOnShutdown | Variable is declared in system.pas in newer Delphi versions.
ReservedBlock | The 64K block of reserved memory used to trap invalid memory accesses using fields in a freed object.
ShowingMessageBox | Is a MessageBox currently showing? If so, do not show another one.
SmallBlockTypes |
SuppressMessageBoxes | If set to true, disables the display of all messageboxes
ThreadsInFullDebugModeRoutine | This is a count of the number of threads currently inside any of the FullDebugMode GetMem, Freemem or ReallocMem handlers. If this value is negative then a block scan is in progress and no thread may allocate, free or reallocate any block or modify any FullDebugMode block header or footer.
UniqueProcessIDString | This is variable nxmmFastMM4.UniqueProcessIDString.
UniqueProcessIDStringBE | This is variable nxmmFastMM4.UniqueProcessIDStringBE.
UseMMX | Must MMX be used for move operations?
VMIndex | The virtual method index count - used to get the virtual method index for a virtual method call on a freed object.
VMTBadInterface | This is variable nxmmFastMM4.VMTBadInterface.
Links
nxmmFastMM4 Namespace, Variables


nxmmFastMM4._Seq Variable

nxmmFastMM4._Seq Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
_Seq: Cardinal;
File

nxmmFastMM4

Description

make sure thread IDs are never reused

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.AllocationGroupStack Variable

nxmmFastMM4.AllocationGroupStack Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
AllocationGroupStack: array[0..AllocationGroupStackSize - 1] of Cardinal;
File

nxmmFastMM4

Description

The allocation group stack

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.AllocationGroupStackTop Variable

nxmmFastMM4.AllocationGroupStackTop Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
AllocationGroupStackTop: Cardinal;
File

nxmmFastMM4

Description

The allocation group stack top (it is an index into AllocationGroupStack)

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.AllocSize2SmallBlockTypeIndX4 Variable

nxmmFastMM4.AllocSize2SmallBlockTypeIndX4 Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
AllocSize2SmallBlockTypeIndX4: packed array[0..(MaximumSmallBlockSize - 1) div SmallBlockGranularity] of Byte;
File

nxmmFastMM4

Description

Size to small block type translation table

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.CurrentAllocationNumber Variable

nxmmFastMM4.CurrentAllocationNumber Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
CurrentAllocationNumber: Cardinal;
File

nxmmFastMM4

Description

The last allocation number used

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ExpectedMemoryLeaks Variable

nxmmFastMM4.ExpectedMemoryLeaks Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ExpectedMemoryLeaks: PExpectedMemoryLeaks;
File

nxmmFastMM4

Description

The expected memory leaks

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ExpectedMemoryLeaksListLocked Variable

nxmmFastMM4.ExpectedMemoryLeaksListLocked Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ExpectedMemoryLeaksListLocked: Boolean;
File

nxmmFastMM4

Description

This is variable nxmmFastMM4.ExpectedMemoryLeaksListLocked.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.FastMMIsInstalled Variable

nxmmFastMM4.FastMMIsInstalled Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
FastMMIsInstalled: Boolean;
File

nxmmFastMM4

Description

Has FastMM been installed?

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.FreedObjectVMT Variable

nxmmFastMM4.FreedObjectVMT Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
FreedObjectVMT: packed record VMTData: array[vmtSelfPtr .. vmtParent + 3] of byte; VMTMethods: array[4 + vmtParent .. MaxFakeVMTEntries * 4 + vmtParent + 3] of Byte; end;
File

nxmmFastMM4

Description

The fake VMT used to catch virtual method calls on freed objects.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.FullDebugModeScanMemoryPoolBeforeEveryOperation Variable

nxmmFastMM4.FullDebugModeScanMemoryPoolBeforeEveryOperation Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
FullDebugModeScanMemoryPoolBeforeEveryOperation: Boolean = False;
File

nxmmFastMM4

Description

If this variable is set to true and FullDebugMode is enabled, then the entire memory pool is checked for consistency before every memory operation. Note that this incurs a massive performance hit on top of the already significant FullDebugMode overhead, so enable this option only when absolutely necessary.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.GetCppVirtObjSizeByTypeIdPtrFunc Variable

nxmmFastMM4.GetCppVirtObjSizeByTypeIdPtrFunc Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
GetCppVirtObjSizeByTypeIdPtrFunc: TGetCppVirtObjSizeByTypeIdPtrFunc = nil;
File

nxmmFastMM4

Description

Return virtual object's size from typeId pointer

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.GetCppVirtObjTypeIdPtrFunc Variable

nxmmFastMM4.GetCppVirtObjTypeIdPtrFunc Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
GetCppVirtObjTypeIdPtrFunc: TGetCppVirtObjTypeIdPtrFunc = nil;
File

nxmmFastMM4

Description

Retrieve virtual object's typeId pointer

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.GetCppVirtObjTypeNameByTypeIdPtrFunc Variable

nxmmFastMM4.GetCppVirtObjTypeNameByTypeIdPtrFunc Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
GetCppVirtObjTypeNameByTypeIdPtrFunc: TGetCppVirtObjTypeNameByTypeIdPtrFunc = nil;
File

nxmmFastMM4

Description

Return virtual object's type name from typeId pointer

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.GetCppVirtObjTypeNameByVTablePtrFunc Variable

nxmmFastMM4.GetCppVirtObjTypeNameByVTablePtrFunc Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
GetCppVirtObjTypeNameByVTablePtrFunc: TGetCppVirtObjTypeNameByVTablePtrFunc = nil;
File

nxmmFastMM4

Description

Retrieve virtual object's typeId pointer from it's virtual table pointer

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.GetCppVirtObjTypeNameFunc Variable

nxmmFastMM4.GetCppVirtObjTypeNameFunc Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
GetCppVirtObjTypeNameFunc: TGetCppVirtObjTypeNameFunc = nil;
File

nxmmFastMM4

Description

Retrieve virtual object's type name

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.InvalidMemoryManager Variable

nxmmFastMM4.InvalidMemoryManager Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
InvalidMemoryManager: TMemoryManager TMemoryManagerEx = ( GetMem: InvalidGetMem; FreeMem: InvalidFreeMem; ReallocMem: InvalidReallocMem ; AllocMem: InvalidAllocMem; RegisterExpectedMemoryLeak: InvalidRegisterAndUnRegisterMemoryLeak; UnRegisterExpectedMemoryLeak: InvalidRegisterAndUnRegisterMemoryLeak; );
File

nxmmFastMM4

Description

Invalid handlers to catch MM operations after uninstall

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.IsMemoryManagerOwner Variable

nxmmFastMM4.IsMemoryManagerOwner Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
IsMemoryManagerOwner: Boolean;
File

nxmmFastMM4

Description

Is the MM in place a shared memory manager?

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.LargeBlocksCircularList Variable

nxmmFastMM4.LargeBlocksCircularList Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
LargeBlocksCircularList: TLargeBlockHeader;
File

nxmmFastMM4

Description

A dummy large block header: Maintains a list of all allocated large blocks to enable memory leak detection on program shutdown.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.LargeBlocksLocked Variable

nxmmFastMM4.LargeBlocksLocked Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
LargeBlocksLocked: Boolean;
File

nxmmFastMM4

Description
----------------Large block management-----------------

Are large blocks locked?

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.LastSequentiallyFedMediumBlock Variable

nxmmFastMM4.LastSequentiallyFedMediumBlock Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
LastSequentiallyFedMediumBlock: Pointer;
File

nxmmFastMM4

Description

The sequential feed medium block pool.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MappingObjectHandle Variable

nxmmFastMM4.MappingObjectHandle Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MappingObjectHandle: Cardinal;
File

nxmmFastMM4

Description

The handle of the memory mapped file

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MappingObjectName Variable

nxmmFastMM4.MappingObjectName Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MappingObjectName: array[0..25] of AnsiChar = ('L', 'o', 'c', 'a', 'l', '\', 'F', 'a', 's', 't', 'M', 'M', '_', 'P', 'I', 'D', '_', '?', '?', '?', '?', '?', '?', '?', '?', #0);
File

nxmmFastMM4

Description

A string uniquely identifying the current process (for sharing the memory manager between DLLs and the main application)

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumBlockBinBitmaps Variable

nxmmFastMM4.MediumBlockBinBitmaps Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumBlockBinBitmaps: packed array[0..MediumBlockBinGroupCount - 1] of Cardinal;
File

nxmmFastMM4

Description

The medium block bins: total of 32 * 32 = 1024 bins of a certain minimum size.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumBlockBinGroupBitmap Variable

nxmmFastMM4.MediumBlockBinGroupBitmap Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumBlockBinGroupBitmap: Cardinal;
File

nxmmFastMM4

Description

The medium block bins are divided into groups of 32 bins. If a bit is set in this group bitmap, then at least one bin in the group has free blocks.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumBlockBins Variable

nxmmFastMM4.MediumBlockBins Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumBlockBins: packed array[0..MediumBlockBinCount - 1] of TMediumFreeBlock;
File

nxmmFastMM4

Description

The medium block bins. There are 1024 LIFO circular linked lists each holding blocks of a specified minimum size. The sizes vary in size from MinimumMediumBlockSize to MaximumMediumBlockSize. The bins are treated as type TMediumFreeBlock to avoid pointer checks.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumBlockPoolsCircularList Variable

nxmmFastMM4.MediumBlockPoolsCircularList Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumBlockPoolsCircularList: TMediumBlockPoolHeader;
File

nxmmFastMM4

Description
----------------Medium block management-----------------

A dummy medium block pool header: Maintains a circular list of all medium block pools to enable memory leak detection on program shutdown.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumBlocksLocked Variable

nxmmFastMM4.MediumBlocksLocked Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumBlocksLocked: Boolean;
File

nxmmFastMM4

Description

Are medium blocks locked?

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MediumSequentialFeedBytesLeft Variable

nxmmFastMM4.MediumSequentialFeedBytesLeft Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MediumSequentialFeedBytesLeft: Cardinal;
File

nxmmFastMM4

Description

This is variable nxmmFastMM4.MediumSequentialFeedBytesLeft.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MMLogFileName Variable

nxmmFastMM4.MMLogFileName Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MMLogFileName: array[0..1023] of AnsiChar;
File

nxmmFastMM4

Description

The current log file name

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MMWindow Variable

nxmmFastMM4.MMWindow Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MMWindow: HWND;
File

nxmmFastMM4

Description

The handle of the MM window

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.MMWindowBE Variable

nxmmFastMM4.MMWindowBE Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
MMWindowBE: HWND;
File

nxmmFastMM4

Description

The handle of the MM window (for default MM of Delphi 2006 compatibility)

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.NewMemoryManager Variable

nxmmFastMM4.NewMemoryManager Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
NewMemoryManager: TMemoryManager TMemoryManagerEx;
File

nxmmFastMM4

Description

The replacement memory manager

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.OldMemoryManager Variable

nxmmFastMM4.OldMemoryManager Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
OldMemoryManager: TMemoryManager TMemoryManagerEx;
File

nxmmFastMM4

Description
-------------Other info-------------

The memory manager that was replaced

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.pCppDebugHook Variable

nxmmFastMM4.pCppDebugHook Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
pCppDebugHook: ^Integer = nil;
File

nxmmFastMM4

Description

PInteger not defined in BCB5

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ReportMemoryLeaksOnShutdown Variable

nxmmFastMM4.ReportMemoryLeaksOnShutdown Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ReportMemoryLeaksOnShutdown: Boolean;
File

nxmmFastMM4

Description

Variable is declared in system.pas in newer Delphi versions.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ReservedBlock Variable

nxmmFastMM4.ReservedBlock Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ReservedBlock: Pointer;
File

nxmmFastMM4

Description

The 64K block of reserved memory used to trap invalid memory accesses using fields in a freed object.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ShowingMessageBox Variable

nxmmFastMM4.ShowingMessageBox Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ShowingMessageBox: Boolean;
File

nxmmFastMM4

Description

Is a MessageBox currently showing? If so, do not show another one.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.SmallBlockTypes Variable

nxmmFastMM4.SmallBlockTypes Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
SmallBlockTypes: packed array[0..NumSmallBlockTypes - 1] of TSmallBlockType = ( (BlockSize: 16 ; UpsizeMoveProcedure: Move12 ), (BlockSize: 24 ; UpsizeMoveProcedure: Move20 ), (BlockSize: 32 ; UpsizeMoveProcedure: Move28 ), (BlockSize: 40 ; UpsizeMoveProcedure: Move36 ), (BlockSize: 48 ; UpsizeMoveProcedure: Move44 ), (BlockSize: 56 ; UpsizeMoveProcedure: Move52 ), (BlockSize: 64 ; UpsizeMoveProcedure: Move60 ), (BlockSize: 72 ; UpsizeMoveProcedure: Move68 ), (BlockSize: 80), (BlockSize: 88), (BlockSize: 96), (BlockSize: 104), (BlockSize: 112), (BlockSize: 120), (BlockSize: 128), (BlockSize: 136), (BlockSize: 144), (BlockSize: 152), (BlockSize: 160), (BlockSize: 176), (BlockSize: 192), (BlockSize: 208), (BlockSize: 224), (BlockSize: 240), (BlockSize: 256), (BlockSize: 272), (BlockSize: 288), (BlockSize: 304), (BlockSize: 320), (BlockSize: 352), (BlockSize: 384), (BlockSize: 416), (BlockSize: 448), (BlockSize: 480), (BlockSize: 528), (BlockSize: 576), (BlockSize: 624), (BlockSize: 672), (BlockSize: 736), (BlockSize: 800), (BlockSize: 880), (BlockSize: 960), (BlockSize: 1056), (BlockSize: 1152), (BlockSize: 1264), (BlockSize: 1376), (BlockSize: 1504), (BlockSize: 1648), (BlockSize: 1808), (BlockSize: 1984), (BlockSize: 2176), (BlockSize: 2384), (BlockSize: MaximumSmallBlockSize), (BlockSize: MaximumSmallBlockSize), (BlockSize: MaximumSmallBlockSize));
File

nxmmFastMM4

Description
----------------Small block management-----------------

The small block types. Sizes include the leading 4-byte header. Sizes are picked to limit maximum wastage to about 10% or 256 bytes (whichever is less) where possible.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.SuppressMessageBoxes Variable

nxmmFastMM4.SuppressMessageBoxes Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
SuppressMessageBoxes: Boolean;
File

nxmmFastMM4

Description

If set to true, disables the display of all messageboxes

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.ThreadsInFullDebugModeRoutine Variable

nxmmFastMM4.ThreadsInFullDebugModeRoutine Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
ThreadsInFullDebugModeRoutine: Integer;
File

nxmmFastMM4

Description

This is a count of the number of threads currently inside any of the FullDebugMode GetMem, Freemem or ReallocMem handlers. If this value is negative then a block scan is in progress and no thread may allocate, free or reallocate any block or modify any FullDebugMode block header or footer.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.UniqueProcessIDString Variable

nxmmFastMM4.UniqueProcessIDString Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
UniqueProcessIDString: array[1..20] of AnsiChar = ('?', '?', '?', '?', '?', '?', '?', '?', '_', 'P', 'I', 'D', '_', 'F', 'a', 's', 't', 'M', 'M', #0);
File

nxmmFastMM4

Description

This is variable nxmmFastMM4.UniqueProcessIDString.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.UniqueProcessIDStringBE Variable

nxmmFastMM4.UniqueProcessIDStringBE Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
UniqueProcessIDStringBE: array[1..23] of AnsiChar = ('?', '?', '?', '?', '?', '?', '?', '?', '_', 'P', 'I', 'D', '_', 'F', 'a', 's', 't', 'M', 'M', '_', 'B', 'E', #0);
File

nxmmFastMM4

Description

This is variable nxmmFastMM4.UniqueProcessIDStringBE.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.UseMMX Variable

nxmmFastMM4.UseMMX Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
UseMMX: Boolean;
File

nxmmFastMM4

Description

Must MMX be used for move operations?

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.VMIndex Variable

nxmmFastMM4.VMIndex Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
VMIndex: Integer;
File

nxmmFastMM4

Description

The virtual method index count - used to get the virtual method index for a virtual method call on a freed object.

Group

Variables

Links
nxmmFastMM4, Variables


nxmmFastMM4.VMTBadInterface Variable

nxmmFastMM4.VMTBadInterface Variable
nxmmFastMM4 Variables Send Feedback
Syntax
Delphi
VMTBadInterface: array[0..MaxFakeVMTEntries - 1] of Pointer;
File

nxmmFastMM4

Description

This is variable nxmmFastMM4.VMTBadInterface.

Group

Variables

Links
nxmmFastMM4, Variables


Constants

Constants
Constants nxmmFastMM4 Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
AdditionalSleepTime | Used when the resource is still in use after the first sleep
AllocationGroupStackSize | The number of entries in the allocation group stack
BlockHeaderSize | The size of the block header in front of small and medium blocks
Copyright | Copyright message - not used anywhere in the code
DebugFillByte | The pattern used to fill unused memory
DebugFillDWord | This is constant nxmmFastMM4.DebugFillDWord.
DebugReservedAddress | The address that is reserved so that accesses to the address of the fill pattern will result in an A/V
DropMediumAndLargeFlagsMask | The flags masks for medium and large blocks
DropSmallFlagsMask | The flags masks for small blocks
ExpectedMemoryLeaksListSize | Memory leak reporting constants
ExtractMediumAndLargeFlagsMask | This is constant nxmmFastMM4.ExtractMediumAndLargeFlagsMask.
ExtractSmallFlagsMask | This is constant nxmmFastMM4.ExtractSmallFlagsMask.
FastMMVersion | The current version of FastMM
FullDebugBlockOverhead | We need space for the header. 4 bytes for the trailer and 4 bytes for the trailing block size when the block is free
HexTable | Hexadecimal characters
InitialSleepTime | Sleep time when a resource (small/medium/large block manager) is in use
IsFreeBlockFlag |
IsLargeBlockFlag | Set if it is a large block. Only valid if IsMediumBlockFlag is not set.
IsMediumBlockFlag | Set if this is a medium block
IsSmallBlockPoolInUseFlag | Set if it is a medium block being used as a small block pool. Only valid if IsMediumBlockFlag is set.
LargeBlockGranularity | The granularity of large blocks
LargeBlockHeaderSize | The size of the header in front of Large blocks
LargeBlockIsSegmented | Is this large block segmented? I.e. is it actually built up from more than one chunk allocated through VirtualAlloc? (Only used by large blocks.)
MaxFakeVMTEntries | The number of fake VMT entries - used to track virtual method calls on freed objects. Do not change this value without also updating TFreedObject.GetVirtualMethodIndex
MaximumMediumBlockSize | The maximum size allocatable through medium blocks. Blocks larger than this fall through to VirtualAlloc ( = large blocks).
MaximumSmallBlockPoolSize | The maximum small block pool size. If a free block is this size or larger then it will be split.
MaximumSmallBlockSize | The maximum size of a small block. Blocks Larger than this are either medium or large blocks.
MB_DEFAULT_DESKTOP_ONLY | This is constant nxmmFastMM4.MB_DEFAULT_DESKTOP_ONLY.
MB_ICONERROR | This is constant nxmmFastMM4.MB_ICONERROR.
MB_OK | Messagebox constants
MB_TASKMODAL | This is constant nxmmFastMM4.MB_TASKMODAL.
MediumBlockBinCount | This is constant nxmmFastMM4.MediumBlockBinCount.
MediumBlockBinGroupCount | This is constant nxmmFastMM4.MediumBlockBinGroupCount.
MediumBlockBinsPerGroup | The number of bins reserved for medium blocks
MediumBlockGranularity | The granularity of medium blocks. Newly allocated medium blocks are a multiple of this size plus MediumBlockSizeOffset, to avoid cache line conflicts
MediumBlockPoolHeaderSize | The size of a medium block pool header
MediumBlockPoolSize | The size of a medium block pool. This is allocated through VirtualAlloc and is used to serve medium blocks. The size must be a multiple of 16 and at least 4 bytes less than a multiple of 4K (the page size) to prevent a possible read access violation when reading past the end of a memory block in the optimized move routine (MoveX16L4). In Full Debug mode we leave a trailing 256 bytes to be able to safely do a memory dump. >>>
MediumBlockSizeOffset | This is constant nxmmFastMM4.MediumBlockSizeOffset.
MediumInPlaceDownsizeLimit | When a medium block is reallocated to a size smaller than this, then it must be reallocated to a small block and the data moved. If not, then it is shrunk in place down to MinimumMediumBlockSize. Currently the limit is set at a quarter of the minimum medium block size.
MEM_COMMIT | Virtual memory constants
MEM_RELEASE | This is constant nxmmFastMM4.MEM_RELEASE.
MEM_TOP_DOWN | This is constant nxmmFastMM4.MEM_TOP_DOWN.
MinimumMediumBlockSize | The smallest medium block size. (Medium blocks are rounded up to the nearest multiple of MediumBlockGranularity plus MediumBlockSizeOffset)
MinimumSmallBlocksPerPool | The minimum number of small blocks per pool. Any available medium block must have space for roughly this many small blocks (or more) to be useable as a small block pool.
NumSmallBlockTypes | The number of small block types
OptimalSmallBlockPoolSizeLowerLimit | The lower and upper limits for the optimal small block pool size
OptimalSmallBlockPoolSizeUpperLimit | This is constant nxmmFastMM4.OptimalSmallBlockPoolSizeUpperLimit.
PAGE_READWRITE | This is constant nxmmFastMM4.PAGE_READWRITE.
PreviousMediumBlockIsFreeFlag | Is the medium block preceding this block available? (Only used by medium blocks)
reInvalidPtr | This is constant nxmmFastMM4.reInvalidPtr.
reOutOfMemory | Private constants
SmallBlockDownsizeCheckAdder | Block resizing constants
SmallBlockGranularity | <<< The granularity of small blocks
SmallBlockPoolHeaderSize | The size of a small block pool header
SmallBlockUpsizeAdder | This is constant nxmmFastMM4.SmallBlockUpsizeAdder.
StackTraceDepth | The stack trace depth. (Must be an *uneven* number to ensure that the Align16Bytes option works in FullDebugMode.)
StandardVirtualMethodNames | Virtual Method Called On Freed Object Errors
TargetSmallBlocksPerPool | The target number of small blocks per pool. The actual number of blocks per pool may be much greater for very small sizes and less for larger sizes. The cost of allocating the small block pool is amortized across all the small blocks in the pool, however the blocks may not all end up being used so they may be lying idle.
Namespace

nxmmFastMM4 Namespace

Links
Constants, nxmmFastMM4 Namespace


nxmmFastMM4.AdditionalSleepTime Constant

nxmmFastMM4.AdditionalSleepTime Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
AdditionalSleepTime = 10;
File

nxmmFastMM4

Description

Used when the resource is still in use after the first sleep

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.AllocationGroupStackSize Constant

nxmmFastMM4.AllocationGroupStackSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
AllocationGroupStackSize = 1000;
File

nxmmFastMM4

Description

The number of entries in the allocation group stack

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.BlockHeaderSize Constant

nxmmFastMM4.BlockHeaderSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
BlockHeaderSize = 4;
File

nxmmFastMM4

Description

The size of the block header in front of small and medium blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.Copyright Constant

nxmmFastMM4.Copyright Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
Copyright: AnsiString = 'FastMM4 (c) 2004 - 2008 Pierre le Riche / Professional Software Development';
File

nxmmFastMM4

Description

Copyright message - not used anywhere in the code

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.DebugFillByte Constant

nxmmFastMM4.DebugFillByte Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
DebugFillByte = $80;
File

nxmmFastMM4

Description

The pattern used to fill unused memory

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.DebugFillDWord Constant

nxmmFastMM4.DebugFillDWord Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
DebugFillDWord = $01010101 * Cardinal(DebugFillByte);
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.DebugFillDWord.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.DebugReservedAddress Constant

nxmmFastMM4.DebugReservedAddress Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
DebugReservedAddress = $01010000 * Cardinal(DebugFillByte);
File

nxmmFastMM4

Description

The address that is reserved so that accesses to the address of the fill pattern will result in an A/V

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.DropMediumAndLargeFlagsMask Constant

nxmmFastMM4.DropMediumAndLargeFlagsMask Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
DropMediumAndLargeFlagsMask = -16;
File

nxmmFastMM4

Description

The flags masks for medium and large blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.DropSmallFlagsMask Constant

nxmmFastMM4.DropSmallFlagsMask Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
DropSmallFlagsMask = -8;
File

nxmmFastMM4

Description

The flags masks for small blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.ExpectedMemoryLeaksListSize Constant

nxmmFastMM4.ExpectedMemoryLeaksListSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
ExpectedMemoryLeaksListSize = 64 * 1024;
File

nxmmFastMM4

Description

Memory leak reporting constants

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.ExtractMediumAndLargeFlagsMask Constant

nxmmFastMM4.ExtractMediumAndLargeFlagsMask Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
ExtractMediumAndLargeFlagsMask = 15;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.ExtractMediumAndLargeFlagsMask.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.ExtractSmallFlagsMask Constant

nxmmFastMM4.ExtractSmallFlagsMask Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
ExtractSmallFlagsMask = 7;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.ExtractSmallFlagsMask.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.FastMMVersion Constant

nxmmFastMM4.FastMMVersion Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
FastMMVersion = '4.94';
File

nxmmFastMM4

Description

The current version of FastMM

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.FullDebugBlockOverhead Constant

nxmmFastMM4.FullDebugBlockOverhead Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
FullDebugBlockOverhead = SizeOf(TFullDebugBlockHeader) + 2 * SizeOf(Pointer);
File

nxmmFastMM4

Description

We need space for the header. 4 bytes for the trailer and 4 bytes for the trailing block size when the block is free

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.HexTable Constant

nxmmFastMM4.HexTable Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
HexTable: array[0..15] of AnsiChar = ('0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C', 'D', 'E', 'F');
File

nxmmFastMM4

Description

Hexadecimal characters

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.InitialSleepTime Constant

nxmmFastMM4.InitialSleepTime Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
InitialSleepTime = 0;
File

nxmmFastMM4

Description

Sleep time when a resource (small/medium/large block manager) is in use

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.IsFreeBlockFlag Constant

nxmmFastMM4.IsFreeBlockFlag Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
IsFreeBlockFlag = 1;
File

nxmmFastMM4

Description
------------Block type flags-------------

The lower 3 bits in the dword header of small blocks (4 bits in medium and large blocks) are used as flags to indicate the state of the block Set if the block is not in use

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.IsLargeBlockFlag Constant

nxmmFastMM4.IsLargeBlockFlag Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
IsLargeBlockFlag = 4;
File

nxmmFastMM4

Description

Set if it is a large block. Only valid if IsMediumBlockFlag is not set.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.IsMediumBlockFlag Constant

nxmmFastMM4.IsMediumBlockFlag Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
IsMediumBlockFlag = 2;
File

nxmmFastMM4

Description

Set if this is a medium block

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.IsSmallBlockPoolInUseFlag Constant

nxmmFastMM4.IsSmallBlockPoolInUseFlag Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
IsSmallBlockPoolInUseFlag = 4;
File

nxmmFastMM4

Description

Set if it is a medium block being used as a small block pool. Only valid if IsMediumBlockFlag is set.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.LargeBlockGranularity Constant

nxmmFastMM4.LargeBlockGranularity Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
LargeBlockGranularity = 65536;
File

nxmmFastMM4

Description

The granularity of large blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.LargeBlockHeaderSize Constant

nxmmFastMM4.LargeBlockHeaderSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
LargeBlockHeaderSize = SizeOf(TLargeBlockHeader);
File

nxmmFastMM4

Description

The size of the header in front of Large blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.LargeBlockIsSegmented Constant

nxmmFastMM4.LargeBlockIsSegmented Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
LargeBlockIsSegmented = 8;
File

nxmmFastMM4

Description

Is this large block segmented? I.e. is it actually built up from more than one chunk allocated through VirtualAlloc? (Only used by large blocks.)

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MaxFakeVMTEntries Constant

nxmmFastMM4.MaxFakeVMTEntries Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MaxFakeVMTEntries = 200;
File

nxmmFastMM4

Description

The number of fake VMT entries - used to track virtual method calls on freed objects. Do not change this value without also updating TFreedObject.GetVirtualMethodIndex

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MaximumMediumBlockSize Constant

nxmmFastMM4.MaximumMediumBlockSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MaximumMediumBlockSize = MinimumMediumBlockSize + (MediumBlockBinCount - 1) * MediumBlockGranularity;
File

nxmmFastMM4

Description

The maximum size allocatable through medium blocks. Blocks larger than this fall through to VirtualAlloc ( = large blocks).

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MaximumSmallBlockPoolSize Constant

nxmmFastMM4.MaximumSmallBlockPoolSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MaximumSmallBlockPoolSize = OptimalSmallBlockPoolSizeUpperLimit + MinimumMediumBlockSize;
File

nxmmFastMM4

Description

The maximum small block pool size. If a free block is this size or larger then it will be split.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MaximumSmallBlockSize Constant

nxmmFastMM4.MaximumSmallBlockSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MaximumSmallBlockSize = 2608;
File

nxmmFastMM4

Description

The maximum size of a small block. Blocks Larger than this are either medium or large blocks.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MB_DEFAULT_DESKTOP_ONLY Constant

nxmmFastMM4.MB_DEFAULT_DESKTOP_ONLY Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MB_DEFAULT_DESKTOP_ONLY = $20000;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MB_DEFAULT_DESKTOP_ONLY.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MB_ICONERROR Constant

nxmmFastMM4.MB_ICONERROR Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MB_ICONERROR = $10;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MB_ICONERROR.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MB_OK Constant

nxmmFastMM4.MB_OK Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MB_OK = 0;
File

nxmmFastMM4

Description

Messagebox constants

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MB_TASKMODAL Constant

nxmmFastMM4.MB_TASKMODAL Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MB_TASKMODAL = $2000;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MB_TASKMODAL.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockBinCount Constant

nxmmFastMM4.MediumBlockBinCount Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockBinCount = MediumBlockBinGroupCount * MediumBlockBinsPerGroup;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MediumBlockBinCount.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockBinGroupCount Constant

nxmmFastMM4.MediumBlockBinGroupCount Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockBinGroupCount = 32;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MediumBlockBinGroupCount.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockBinsPerGroup Constant

nxmmFastMM4.MediumBlockBinsPerGroup Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockBinsPerGroup = 32;
File

nxmmFastMM4

Description

The number of bins reserved for medium blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockGranularity Constant

nxmmFastMM4.MediumBlockGranularity Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockGranularity = 256;
File

nxmmFastMM4

Description

The granularity of medium blocks. Newly allocated medium blocks are a multiple of this size plus MediumBlockSizeOffset, to avoid cache line conflicts

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockPoolHeaderSize Constant

nxmmFastMM4.MediumBlockPoolHeaderSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockPoolHeaderSize = SizeOf(TMediumBlockPoolHeader);
File

nxmmFastMM4

Description

The size of a medium block pool header

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockPoolSize Constant

nxmmFastMM4.MediumBlockPoolSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockPoolSize = 4 * 1024 * 1024 - 256;
File

nxmmFastMM4

Description

The size of a medium block pool. This is allocated through VirtualAlloc and is used to serve medium blocks. The size must be a multiple of 16 and at least 4 bytes less than a multiple of 4K (the page size) to prevent a possible read access violation when reading past the end of a memory block in the optimized move routine (MoveX16L4). In Full Debug mode we leave a trailing 256 bytes to be able to safely do a memory dump. >>>

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumBlockSizeOffset Constant

nxmmFastMM4.MediumBlockSizeOffset Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumBlockSizeOffset = 48;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MediumBlockSizeOffset.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MediumInPlaceDownsizeLimit Constant

nxmmFastMM4.MediumInPlaceDownsizeLimit Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MediumInPlaceDownsizeLimit = MinimumMediumBlockSize div 4;
File

nxmmFastMM4

Description

When a medium block is reallocated to a size smaller than this, then it must be reallocated to a small block and the data moved. If not, then it is shrunk in place down to MinimumMediumBlockSize. Currently the limit is set at a quarter of the minimum medium block size.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MEM_COMMIT Constant

nxmmFastMM4.MEM_COMMIT Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MEM_COMMIT = $1000;
File

nxmmFastMM4

Description

Virtual memory constants

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MEM_RELEASE Constant

nxmmFastMM4.MEM_RELEASE Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MEM_RELEASE = $8000;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MEM_RELEASE.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MEM_TOP_DOWN Constant

nxmmFastMM4.MEM_TOP_DOWN Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MEM_TOP_DOWN = $100000;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.MEM_TOP_DOWN.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MinimumMediumBlockSize Constant

nxmmFastMM4.MinimumMediumBlockSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MinimumMediumBlockSize = 11 * 256 + MediumBlockSizeOffset;
File

nxmmFastMM4

Description

The smallest medium block size. (Medium blocks are rounded up to the nearest multiple of MediumBlockGranularity plus MediumBlockSizeOffset)

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.MinimumSmallBlocksPerPool Constant

nxmmFastMM4.MinimumSmallBlocksPerPool Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
MinimumSmallBlocksPerPool = 12;
File

nxmmFastMM4

Description

The minimum number of small blocks per pool. Any available medium block must have space for roughly this many small blocks (or more) to be useable as a small block pool.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.NumSmallBlockTypes Constant

nxmmFastMM4.NumSmallBlockTypes Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
NumSmallBlockTypes = 55;
File

nxmmFastMM4

Description

The number of small block types

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.OptimalSmallBlockPoolSizeLowerLimit Constant

nxmmFastMM4.OptimalSmallBlockPoolSizeLowerLimit Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
OptimalSmallBlockPoolSizeLowerLimit = 29 * 1024 - MediumBlockGranularity + MediumBlockSizeOffset;
File

nxmmFastMM4

Description

The lower and upper limits for the optimal small block pool size

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.OptimalSmallBlockPoolSizeUpperLimit Constant

nxmmFastMM4.OptimalSmallBlockPoolSizeUpperLimit Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
OptimalSmallBlockPoolSizeUpperLimit = 64 * 1024 - MediumBlockGranularity + MediumBlockSizeOffset;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.OptimalSmallBlockPoolSizeUpperLimit.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.PAGE_READWRITE Constant

nxmmFastMM4.PAGE_READWRITE Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
PAGE_READWRITE = 4;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.PAGE_READWRITE.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.PreviousMediumBlockIsFreeFlag Constant

nxmmFastMM4.PreviousMediumBlockIsFreeFlag Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
PreviousMediumBlockIsFreeFlag = 8;
File

nxmmFastMM4

Description

Is the medium block preceding this block available? (Only used by medium blocks)

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.reInvalidPtr Constant

nxmmFastMM4.reInvalidPtr Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
reInvalidPtr = 2;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.reInvalidPtr.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.reOutOfMemory Constant

nxmmFastMM4.reOutOfMemory Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
reOutOfMemory = 1;
File

nxmmFastMM4

Description

Private constants

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.SmallBlockDownsizeCheckAdder Constant

nxmmFastMM4.SmallBlockDownsizeCheckAdder Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
SmallBlockDownsizeCheckAdder = 64;
File

nxmmFastMM4

Description

Block resizing constants

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.SmallBlockGranularity Constant

nxmmFastMM4.SmallBlockGranularity Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
SmallBlockGranularity = 8;
File

nxmmFastMM4

Description

<<< The granularity of small blocks

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.SmallBlockPoolHeaderSize Constant

nxmmFastMM4.SmallBlockPoolHeaderSize Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
SmallBlockPoolHeaderSize = SizeOf(TSmallBlockPoolHeader);
File

nxmmFastMM4

Description

The size of a small block pool header

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.SmallBlockUpsizeAdder Constant

nxmmFastMM4.SmallBlockUpsizeAdder Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
SmallBlockUpsizeAdder = 32;
File

nxmmFastMM4

Description

This is constant nxmmFastMM4.SmallBlockUpsizeAdder.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.StackTraceDepth Constant

nxmmFastMM4.StackTraceDepth Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
StackTraceDepth = 11;
File

nxmmFastMM4

Description

The stack trace depth. (Must be an *uneven* number to ensure that the Align16Bytes option works in FullDebugMode.)

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.StandardVirtualMethodNames Constant

nxmmFastMM4.StandardVirtualMethodNames Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
StandardVirtualMethodNames: array[1 + vmtParent div 4 .. -1] of PAnsiChar = ( 'Equals', 'GetHashCode', 'ToString', 'SafeCallException', 'AfterConstruction', 'BeforeDestruction', 'Dispatch', 'DefaultHandler', 'NewInstance', 'FreeInstance', 'Destroy');
File

nxmmFastMM4

Description

Virtual Method Called On Freed Object Errors

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4.TargetSmallBlocksPerPool Constant

nxmmFastMM4.TargetSmallBlocksPerPool Constant
nxmmFastMM4 Constants Send Feedback
Syntax
Delphi
TargetSmallBlocksPerPool = 48;
File

nxmmFastMM4

Description

The target number of small blocks per pool. The actual number of blocks per pool may be much greater for very small sizes and less for larger sizes. The cost of allocating the small block pool is amortized across all the small blocks in the pool, however the blocks may not all end up being used so they may be lying idle.

Group

Constants

Links
nxmmFastMM4, Constants


nxmmFastMM4Messages Namespace

nxmmFastMM4Messages Namespace
Constants Topics Send Feedback

This is namespace nxmmFastMM4Messages.

Constants
Name | Description
AlreadyInstalledMsg | Installation Messages
AlreadyInstalledTitle | This is constant nxmmFastMM4Messages.AlreadyInstalledTitle.
AnsiStringBlockMessage | This is constant nxmmFastMM4Messages.AnsiStringBlockMessage.
BlockCheckMsg | This is constant nxmmFastMM4Messages.BlockCheckMsg.
BlockErrorMsgTitle | This is constant nxmmFastMM4Messages.BlockErrorMsgTitle.
BlockFooterCorruptedMsg | This is constant nxmmFastMM4Messages.BlockFooterCorruptedMsg.
BlockHeaderCorruptedMsg | This is constant nxmmFastMM4Messages.BlockHeaderCorruptedMsg.
BlockHeaderCorruptedNoHistoryMsg | This is constant nxmmFastMM4Messages.BlockHeaderCorruptedNoHistoryMsg.
BlockScanLogHeader | Block Error Messages
BytesMessage | This is constant nxmmFastMM4Messages.BytesMessage.
CRLF | This is constant nxmmFastMM4Messages.CRLF.
CurrentAllocationGroupMsg | This is constant nxmmFastMM4Messages.CurrentAllocationGroupMsg.
CurrentAllocationNumberMsg | This is constant nxmmFastMM4Messages.CurrentAllocationNumberMsg.
CurrentBlockSizeMsg | This is constant nxmmFastMM4Messages.CurrentBlockSizeMsg.
CurrentObjectClassMsg | This is constant nxmmFastMM4Messages.CurrentObjectClassMsg.
CurrentStackTraceMsg | This is constant nxmmFastMM4Messages.CurrentStackTraceMsg.
CurrentThreadIDMsg | Stack trace messages
DoubleFreeErrorMsg | This is constant nxmmFastMM4Messages.DoubleFreeErrorMsg.
ErrorMsgHeader | This is constant nxmmFastMM4Messages.ErrorMsgHeader.
EventSeparator | This is constant nxmmFastMM4Messages.EventSeparator.
FastMMInstallMsg | This is constant nxmmFastMM4Messages.FastMMInstallMsg.
FastMMInstallSharedMsg | This is constant nxmmFastMM4Messages.FastMMInstallSharedMsg.
FastMMUninstallMsg | This is constant nxmmFastMM4Messages.FastMMUninstallMsg.
FastMMUninstallSharedMsg | This is constant nxmmFastMM4Messages.FastMMUninstallSharedMsg.
FreedObjectClassMsg | This is constant nxmmFastMM4Messages.FreedObjectClassMsg.
FreeMemMsg | This is constant nxmmFastMM4Messages.FreeMemMsg.
FreeModifiedDetailMsg | This is constant nxmmFastMM4Messages.FreeModifiedDetailMsg.
FreeModifiedErrorMsg | This is constant nxmmFastMM4Messages.FreeModifiedErrorMsg.
FullDebugModeLibraryName | The name of the debug info support DLL
GetMemMsg | This is constant nxmmFastMM4Messages.GetMemMsg.
InterfaceErrorHeader | This is constant nxmmFastMM4Messages.InterfaceErrorHeader.
InvalidAllocMemMsg | This is constant nxmmFastMM4Messages.InvalidAllocMemMsg.
InvalidFreeMemMsg | This is constant nxmmFastMM4Messages.InvalidFreeMemMsg.
InvalidGetMemMsg | This is constant nxmmFastMM4Messages.InvalidGetMemMsg.
InvalidOperationTitle | This is constant nxmmFastMM4Messages.InvalidOperationTitle.
InvalidReallocMemMsg | This is constant nxmmFastMM4Messages.InvalidReallocMemMsg.
LargeLeakDetail | This is constant nxmmFastMM4Messages.LargeLeakDetail.
LeakLogHeader | Leak checking messages
LeakMessageFooter | This is constant nxmmFastMM4Messages.LeakMessageFooter.
LeakMessageHeader | This is constant nxmmFastMM4Messages.LeakMessageHeader.
LeakMessageTitle | This is constant nxmmFastMM4Messages.LeakMessageTitle.
LogFileExtension | Event log strings
MemoryAllocatedMsg | This is constant nxmmFastMM4Messages.MemoryAllocatedMsg.
MemoryAllocatedTitle | This is constant nxmmFastMM4Messages.MemoryAllocatedTitle.
MemoryDumpMsg | Memory dump message
OperationMsg | This is constant nxmmFastMM4Messages.OperationMsg.
OtherMMInstalledMsg | This is constant nxmmFastMM4Messages.OtherMMInstalledMsg.
OtherMMInstalledTitle | This is constant nxmmFastMM4Messages.OtherMMInstalledTitle.
PreviousAllocationGroupMsg | This is constant nxmmFastMM4Messages.PreviousAllocationGroupMsg.
PreviousAllocationNumberMsg | This is constant nxmmFastMM4Messages.PreviousAllocationNumberMsg.
PreviousBlockSizeMsg | This is constant nxmmFastMM4Messages.PreviousBlockSizeMsg.
PreviousObjectClassMsg | This is constant nxmmFastMM4Messages.PreviousObjectClassMsg.
ReallocMemMsg | This is constant nxmmFastMM4Messages.ReallocMemMsg.
SmallLeakDetail | This is constant nxmmFastMM4Messages.SmallLeakDetail.
StackTraceMsg | This is constant nxmmFastMM4Messages.StackTraceMsg.
ThreadIDAtAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDAtAllocMsg.
ThreadIDAtFreeMsg | This is constant nxmmFastMM4Messages.ThreadIDAtFreeMsg.
ThreadIDAtObjectAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDAtObjectAllocMsg.
ThreadIDAtObjectFreeMsg | This is constant nxmmFastMM4Messages.ThreadIDAtObjectFreeMsg.
ThreadIDPrevAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDPrevAllocMsg.
UnicodeStringBlockMessage | This is constant nxmmFastMM4Messages.UnicodeStringBlockMessage.
UnknownClassNameMsg | Class name messages
VirtualMethodAddress | This is constant nxmmFastMM4Messages.VirtualMethodAddress.
VirtualMethodErrorHeader | This is constant nxmmFastMM4Messages.VirtualMethodErrorHeader.
VirtualMethodName | This is constant nxmmFastMM4Messages.VirtualMethodName.
VirtualMethodOffset | This is constant nxmmFastMM4Messages.VirtualMethodOffset.
WrongMMFreeErrorMsg | This is constant nxmmFastMM4Messages.WrongMMFreeErrorMsg.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxmmFastMM4Messages Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
AlreadyInstalledMsg | Installation Messages
AlreadyInstalledTitle | This is constant nxmmFastMM4Messages.AlreadyInstalledTitle.
AnsiStringBlockMessage | This is constant nxmmFastMM4Messages.AnsiStringBlockMessage.
BlockCheckMsg | This is constant nxmmFastMM4Messages.BlockCheckMsg.
BlockErrorMsgTitle | This is constant nxmmFastMM4Messages.BlockErrorMsgTitle.
BlockFooterCorruptedMsg | This is constant nxmmFastMM4Messages.BlockFooterCorruptedMsg.
BlockHeaderCorruptedMsg | This is constant nxmmFastMM4Messages.BlockHeaderCorruptedMsg.
BlockHeaderCorruptedNoHistoryMsg | This is constant nxmmFastMM4Messages.BlockHeaderCorruptedNoHistoryMsg.
BlockScanLogHeader | Block Error Messages
BytesMessage | This is constant nxmmFastMM4Messages.BytesMessage.
CRLF | This is constant nxmmFastMM4Messages.CRLF.
CurrentAllocationGroupMsg | This is constant nxmmFastMM4Messages.CurrentAllocationGroupMsg.
CurrentAllocationNumberMsg | This is constant nxmmFastMM4Messages.CurrentAllocationNumberMsg.
CurrentBlockSizeMsg | This is constant nxmmFastMM4Messages.CurrentBlockSizeMsg.
CurrentObjectClassMsg | This is constant nxmmFastMM4Messages.CurrentObjectClassMsg.
CurrentStackTraceMsg | This is constant nxmmFastMM4Messages.CurrentStackTraceMsg.
CurrentThreadIDMsg | Stack trace messages
DoubleFreeErrorMsg | This is constant nxmmFastMM4Messages.DoubleFreeErrorMsg.
ErrorMsgHeader | This is constant nxmmFastMM4Messages.ErrorMsgHeader.
EventSeparator | This is constant nxmmFastMM4Messages.EventSeparator.
FastMMInstallMsg | This is constant nxmmFastMM4Messages.FastMMInstallMsg.
FastMMInstallSharedMsg | This is constant nxmmFastMM4Messages.FastMMInstallSharedMsg.
FastMMUninstallMsg | This is constant nxmmFastMM4Messages.FastMMUninstallMsg.
FastMMUninstallSharedMsg | This is constant nxmmFastMM4Messages.FastMMUninstallSharedMsg.
FreedObjectClassMsg | This is constant nxmmFastMM4Messages.FreedObjectClassMsg.
FreeMemMsg | This is constant nxmmFastMM4Messages.FreeMemMsg.
FreeModifiedDetailMsg | This is constant nxmmFastMM4Messages.FreeModifiedDetailMsg.
FreeModifiedErrorMsg | This is constant nxmmFastMM4Messages.FreeModifiedErrorMsg.
FullDebugModeLibraryName | The name of the debug info support DLL
GetMemMsg | This is constant nxmmFastMM4Messages.GetMemMsg.
InterfaceErrorHeader | This is constant nxmmFastMM4Messages.InterfaceErrorHeader.
InvalidAllocMemMsg | This is constant nxmmFastMM4Messages.InvalidAllocMemMsg.
InvalidFreeMemMsg | This is constant nxmmFastMM4Messages.InvalidFreeMemMsg.
InvalidGetMemMsg | This is constant nxmmFastMM4Messages.InvalidGetMemMsg.
InvalidOperationTitle | This is constant nxmmFastMM4Messages.InvalidOperationTitle.
InvalidReallocMemMsg | This is constant nxmmFastMM4Messages.InvalidReallocMemMsg.
LargeLeakDetail | This is constant nxmmFastMM4Messages.LargeLeakDetail.
LeakLogHeader | Leak checking messages
LeakMessageFooter | This is constant nxmmFastMM4Messages.LeakMessageFooter.
LeakMessageHeader | This is constant nxmmFastMM4Messages.LeakMessageHeader.
LeakMessageTitle | This is constant nxmmFastMM4Messages.LeakMessageTitle.
LogFileExtension | Event log strings
MemoryAllocatedMsg | This is constant nxmmFastMM4Messages.MemoryAllocatedMsg.
MemoryAllocatedTitle | This is constant nxmmFastMM4Messages.MemoryAllocatedTitle.
MemoryDumpMsg | Memory dump message
OperationMsg | This is constant nxmmFastMM4Messages.OperationMsg.
OtherMMInstalledMsg | This is constant nxmmFastMM4Messages.OtherMMInstalledMsg.
OtherMMInstalledTitle | This is constant nxmmFastMM4Messages.OtherMMInstalledTitle.
PreviousAllocationGroupMsg | This is constant nxmmFastMM4Messages.PreviousAllocationGroupMsg.
PreviousAllocationNumberMsg | This is constant nxmmFastMM4Messages.PreviousAllocationNumberMsg.
PreviousBlockSizeMsg | This is constant nxmmFastMM4Messages.PreviousBlockSizeMsg.
PreviousObjectClassMsg | This is constant nxmmFastMM4Messages.PreviousObjectClassMsg.
ReallocMemMsg | This is constant nxmmFastMM4Messages.ReallocMemMsg.
SmallLeakDetail | This is constant nxmmFastMM4Messages.SmallLeakDetail.
StackTraceMsg | This is constant nxmmFastMM4Messages.StackTraceMsg.
ThreadIDAtAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDAtAllocMsg.
ThreadIDAtFreeMsg | This is constant nxmmFastMM4Messages.ThreadIDAtFreeMsg.
ThreadIDAtObjectAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDAtObjectAllocMsg.
ThreadIDAtObjectFreeMsg | This is constant nxmmFastMM4Messages.ThreadIDAtObjectFreeMsg.
ThreadIDPrevAllocMsg | This is constant nxmmFastMM4Messages.ThreadIDPrevAllocMsg.
UnicodeStringBlockMessage | This is constant nxmmFastMM4Messages.UnicodeStringBlockMessage.
UnknownClassNameMsg | Class name messages
VirtualMethodAddress | This is constant nxmmFastMM4Messages.VirtualMethodAddress.
VirtualMethodErrorHeader | This is constant nxmmFastMM4Messages.VirtualMethodErrorHeader.
VirtualMethodName | This is constant nxmmFastMM4Messages.VirtualMethodName.
VirtualMethodOffset | This is constant nxmmFastMM4Messages.VirtualMethodOffset.
WrongMMFreeErrorMsg | This is constant nxmmFastMM4Messages.WrongMMFreeErrorMsg.
Namespace

nxmmFastMM4Messages Namespace

Links
Constants, nxmmFastMM4Messages Namespace


nxmmFastMM4Messages.AlreadyInstalledMsg Constant

nxmmFastMM4Messages.AlreadyInstalledMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
AlreadyInstalledMsg = 'FastMM4 is already installed.';
File

nxmmFastMM4Messages

Description

Installation Messages

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.AlreadyInstalledTitle Constant

nxmmFastMM4Messages.AlreadyInstalledTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
AlreadyInstalledTitle = 'Already installed.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.AlreadyInstalledTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.AnsiStringBlockMessage Constant

nxmmFastMM4Messages.AnsiStringBlockMessage Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
AnsiStringBlockMessage = 'AnsiString';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.AnsiStringBlockMessage.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockCheckMsg Constant

nxmmFastMM4Messages.BlockCheckMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockCheckMsg = 'free block scan';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BlockCheckMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockErrorMsgTitle Constant

nxmmFastMM4Messages.BlockErrorMsgTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockErrorMsgTitle = 'Memory Error Detected';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BlockErrorMsgTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockFooterCorruptedMsg Constant

nxmmFastMM4Messages.BlockFooterCorruptedMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockFooterCorruptedMsg = 'The block footer has been corrupted. ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BlockFooterCorruptedMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockHeaderCorruptedMsg Constant

nxmmFastMM4Messages.BlockHeaderCorruptedMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockHeaderCorruptedMsg = 'The block header has been corrupted. ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BlockHeaderCorruptedMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockHeaderCorruptedNoHistoryMsg Constant

nxmmFastMM4Messages.BlockHeaderCorruptedNoHistoryMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockHeaderCorruptedNoHistoryMsg = ' Unfortunately the block header has been corrupted so no history is available.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BlockHeaderCorruptedNoHistoryMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BlockScanLogHeader Constant

nxmmFastMM4Messages.BlockScanLogHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BlockScanLogHeader = 'Allocated block logged by LogAllocatedBlocksToFile. The size is: ';
File

nxmmFastMM4Messages

Description

Block Error Messages

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.BytesMessage Constant

nxmmFastMM4Messages.BytesMessage Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
BytesMessage = ' bytes: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.BytesMessage.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CRLF Constant

nxmmFastMM4Messages.CRLF Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CRLF = #13#10;
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CRLF.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentAllocationGroupMsg Constant

nxmmFastMM4Messages.CurrentAllocationGroupMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentAllocationGroupMsg = #13#10#13#10'The allocation group is: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CurrentAllocationGroupMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentAllocationNumberMsg Constant

nxmmFastMM4Messages.CurrentAllocationNumberMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentAllocationNumberMsg = #13#10#13#10'The allocation number is: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CurrentAllocationNumberMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentBlockSizeMsg Constant

nxmmFastMM4Messages.CurrentBlockSizeMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentBlockSizeMsg = #13#10#13#10'The block size is: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CurrentBlockSizeMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentObjectClassMsg Constant

nxmmFastMM4Messages.CurrentObjectClassMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentObjectClassMsg = #13#10#13#10'The block is currently used for an object of class: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CurrentObjectClassMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentStackTraceMsg Constant

nxmmFastMM4Messages.CurrentStackTraceMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentStackTraceMsg = ', and the stack trace (return addresses) leading to this error is:';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.CurrentStackTraceMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.CurrentThreadIDMsg Constant

nxmmFastMM4Messages.CurrentThreadIDMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
CurrentThreadIDMsg = #13#10#13#10'The current thread ID is 0x';
File

nxmmFastMM4Messages

Description

Stack trace messages

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.DoubleFreeErrorMsg Constant

nxmmFastMM4Messages.DoubleFreeErrorMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
DoubleFreeErrorMsg = 'An attempt has been made to free/reallocate an unallocated block.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.DoubleFreeErrorMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ErrorMsgHeader Constant

nxmmFastMM4Messages.ErrorMsgHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ErrorMsgHeader = 'FastMM has detected an error during a ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ErrorMsgHeader.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.EventSeparator Constant

nxmmFastMM4Messages.EventSeparator Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
EventSeparator = '--------------------------------';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.EventSeparator.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FastMMInstallMsg Constant

nxmmFastMM4Messages.FastMMInstallMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FastMMInstallMsg = 'FastMM has been installed.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FastMMInstallMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FastMMInstallSharedMsg Constant

nxmmFastMM4Messages.FastMMInstallSharedMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FastMMInstallSharedMsg = 'Sharing an existing instance of FastMM.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FastMMInstallSharedMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FastMMUninstallMsg Constant

nxmmFastMM4Messages.FastMMUninstallMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FastMMUninstallMsg = 'FastMM has been uninstalled.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FastMMUninstallMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FastMMUninstallSharedMsg Constant

nxmmFastMM4Messages.FastMMUninstallSharedMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FastMMUninstallSharedMsg = 'Stopped sharing an existing instance of FastMM.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FastMMUninstallSharedMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FreedObjectClassMsg Constant

nxmmFastMM4Messages.FreedObjectClassMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FreedObjectClassMsg = #13#10#13#10'Freed object class: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FreedObjectClassMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FreeMemMsg Constant

nxmmFastMM4Messages.FreeMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FreeMemMsg = 'FreeMem';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FreeMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FreeModifiedDetailMsg Constant

nxmmFastMM4Messages.FreeModifiedDetailMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FreeModifiedDetailMsg = #13#10#13#10'Modified byte offsets (and lengths): ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FreeModifiedDetailMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FreeModifiedErrorMsg Constant

nxmmFastMM4Messages.FreeModifiedErrorMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FreeModifiedErrorMsg = 'FastMM detected that a block has been modified after being freed. ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.FreeModifiedErrorMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.FullDebugModeLibraryName Constant

nxmmFastMM4Messages.FullDebugModeLibraryName Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
FullDebugModeLibraryName = 'FastMM_FullDebugMode.dll';
File

nxmmFastMM4Messages

Description

The name of the debug info support DLL

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.GetMemMsg Constant

nxmmFastMM4Messages.GetMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
GetMemMsg = 'GetMem';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.GetMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InterfaceErrorHeader Constant

nxmmFastMM4Messages.InterfaceErrorHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InterfaceErrorHeader = 'FastMM has detected an attempt to use an interface of a freed object. An access violation will now be raised in order to abort the current operation.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InterfaceErrorHeader.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InvalidAllocMemMsg Constant

nxmmFastMM4Messages.InvalidAllocMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InvalidAllocMemMsg = 'FastMM has detected an AllocMem call after FastMM was uninstalled.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InvalidAllocMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InvalidFreeMemMsg Constant

nxmmFastMM4Messages.InvalidFreeMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InvalidFreeMemMsg = 'FastMM has detected a FreeMem call after FastMM was uninstalled.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InvalidFreeMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InvalidGetMemMsg Constant

nxmmFastMM4Messages.InvalidGetMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InvalidGetMemMsg = 'FastMM has detected a GetMem call after FastMM was uninstalled.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InvalidGetMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InvalidOperationTitle Constant

nxmmFastMM4Messages.InvalidOperationTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InvalidOperationTitle = 'MM Operation after uninstall.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InvalidOperationTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.InvalidReallocMemMsg Constant

nxmmFastMM4Messages.InvalidReallocMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
InvalidReallocMemMsg = 'FastMM has detected a ReallocMem call after FastMM was uninstalled.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.InvalidReallocMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LargeLeakDetail Constant

nxmmFastMM4Messages.LargeLeakDetail Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LargeLeakDetail = 'The sizes of leaked medium and large blocks are' + ' (excluding expected leaks registered by pointer)' + ': ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.LargeLeakDetail.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LeakLogHeader Constant

nxmmFastMM4Messages.LeakLogHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LeakLogHeader = 'A memory block has been leaked. The size is: ';
File

nxmmFastMM4Messages

Description

Leak checking messages

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LeakMessageFooter Constant

nxmmFastMM4Messages.LeakMessageFooter Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LeakMessageFooter = #13#10 + #13#10'Note: ' + 'This memory leak check is only performed if Delphi is currently running on the same computer. ' + 'Memory leak detail is logged to a text file in the same folder as this application. ' + 'Enable the "LogMemoryLeakDetailToFile" to obtain a log file containing detail on memory leaks. ' + 'To obtain a log file containing detail on memory leaks, enable the "FullDebugMode" and "LogMemoryLeakDetailToFile" conditional defines. ' + 'To disable this memory leak check, undefine "EnableMemoryLeakReporting".'#13#10 + #0;
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.LeakMessageFooter.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LeakMessageHeader Constant

nxmmFastMM4Messages.LeakMessageHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LeakMessageHeader = 'This application has leaked memory. ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.LeakMessageHeader.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LeakMessageTitle Constant

nxmmFastMM4Messages.LeakMessageTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LeakMessageTitle = 'Memory Leak Detected';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.LeakMessageTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.LogFileExtension Constant

nxmmFastMM4Messages.LogFileExtension Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
LogFileExtension = '_MemoryManager_EventLog.txt'#0;
File

nxmmFastMM4Messages

Description

Event log strings

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.MemoryAllocatedMsg Constant

nxmmFastMM4Messages.MemoryAllocatedMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
MemoryAllocatedMsg = 'FastMM4 cannot install since memory has already been ' + 'allocated through the default memory manager.'#13#10'FastMM4.pas MUST ' + 'be the first unit in your project''s .dpr file, otherwise memory may ' + 'be allocated'#13#10'through the default memory manager before FastMM4 ' + 'gains control. '#13#10#13#10'If you are using an exception trapper ' + 'like MadExcept (or any tool that modifies the unit initialization ' + 'order),'#13#10'go into its configuration page and ensure that the ' + 'FastMM4.pas unit is initialized before any other unit.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.MemoryAllocatedMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.MemoryAllocatedTitle Constant

nxmmFastMM4Messages.MemoryAllocatedTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
MemoryAllocatedTitle = 'Cannot install FastMM4 - Memory has already been allocated';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.MemoryAllocatedTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.MemoryDumpMsg Constant

nxmmFastMM4Messages.MemoryDumpMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
MemoryDumpMsg = #13#10#13#10'Current memory dump of 256 bytes starting at pointer address ';
File

nxmmFastMM4Messages

Description

Memory dump message

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.OperationMsg Constant

nxmmFastMM4Messages.OperationMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
OperationMsg = ' operation. ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.OperationMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.OtherMMInstalledMsg Constant

nxmmFastMM4Messages.OtherMMInstalledMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
OtherMMInstalledMsg = 'FastMM4 cannot be installed since another third party memory ' + 'manager has already installed itself.'#13#10'If you want to use FastMM4, ' + 'please make sure that FastMM4.pas is the very first unit in the "uses"' + #13#10'section of your project''s .dpr file.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.OtherMMInstalledMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.OtherMMInstalledTitle Constant

nxmmFastMM4Messages.OtherMMInstalledTitle Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
OtherMMInstalledTitle = 'Cannot install FastMM4 - Another memory manager is already installed';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.OtherMMInstalledTitle.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.PreviousAllocationGroupMsg Constant

nxmmFastMM4Messages.PreviousAllocationGroupMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
PreviousAllocationGroupMsg = #13#10#13#10'The allocation group was: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.PreviousAllocationGroupMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.PreviousAllocationNumberMsg Constant

nxmmFastMM4Messages.PreviousAllocationNumberMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
PreviousAllocationNumberMsg = #13#10#13#10'The allocation number was: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.PreviousAllocationNumberMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.PreviousBlockSizeMsg Constant

nxmmFastMM4Messages.PreviousBlockSizeMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
PreviousBlockSizeMsg = #13#10#13#10'The previous block size was: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.PreviousBlockSizeMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.PreviousObjectClassMsg Constant

nxmmFastMM4Messages.PreviousObjectClassMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
PreviousObjectClassMsg = #13#10#13#10'The block was previously used for an object of class: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.PreviousObjectClassMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ReallocMemMsg Constant

nxmmFastMM4Messages.ReallocMemMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ReallocMemMsg = 'ReallocMem';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ReallocMemMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.SmallLeakDetail Constant

nxmmFastMM4Messages.SmallLeakDetail Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
SmallLeakDetail = 'The small block leaks are' + ' (excluding expected leaks registered by pointer)' + ':'#13#10;
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.SmallLeakDetail.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.StackTraceMsg Constant

nxmmFastMM4Messages.StackTraceMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
StackTraceMsg = ', and the stack trace (return addresses) at the time was:';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.StackTraceMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ThreadIDAtAllocMsg Constant

nxmmFastMM4Messages.ThreadIDAtAllocMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ThreadIDAtAllocMsg = #13#10#13#10'This block was allocated by thread 0x';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ThreadIDAtAllocMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ThreadIDAtFreeMsg Constant

nxmmFastMM4Messages.ThreadIDAtFreeMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ThreadIDAtFreeMsg = #13#10#13#10'The block was previously freed by thread 0x';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ThreadIDAtFreeMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ThreadIDAtObjectAllocMsg Constant

nxmmFastMM4Messages.ThreadIDAtObjectAllocMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ThreadIDAtObjectAllocMsg = #13#10#13#10'The object was allocated by thread 0x';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ThreadIDAtObjectAllocMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ThreadIDAtObjectFreeMsg Constant

nxmmFastMM4Messages.ThreadIDAtObjectFreeMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ThreadIDAtObjectFreeMsg = #13#10#13#10'The object was subsequently freed by thread 0x';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ThreadIDAtObjectFreeMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.ThreadIDPrevAllocMsg Constant

nxmmFastMM4Messages.ThreadIDPrevAllocMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
ThreadIDPrevAllocMsg = #13#10#13#10'This block was previously allocated by thread 0x';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.ThreadIDPrevAllocMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.UnicodeStringBlockMessage Constant

nxmmFastMM4Messages.UnicodeStringBlockMessage Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
UnicodeStringBlockMessage = 'UnicodeString';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.UnicodeStringBlockMessage.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.UnknownClassNameMsg Constant

nxmmFastMM4Messages.UnknownClassNameMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
UnknownClassNameMsg = 'Unknown';
File

nxmmFastMM4Messages

Description

Class name messages

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.VirtualMethodAddress Constant

nxmmFastMM4Messages.VirtualMethodAddress Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
VirtualMethodAddress = #13#10#13#10'Virtual method address: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.VirtualMethodAddress.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.VirtualMethodErrorHeader Constant

nxmmFastMM4Messages.VirtualMethodErrorHeader Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
VirtualMethodErrorHeader = 'FastMM has detected an attempt to call a virtual method on a freed object. An access violation will now be raised in order to abort the current operation.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.VirtualMethodErrorHeader.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.VirtualMethodName Constant

nxmmFastMM4Messages.VirtualMethodName Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
VirtualMethodName = #13#10#13#10'Virtual method: ';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.VirtualMethodName.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.VirtualMethodOffset Constant

nxmmFastMM4Messages.VirtualMethodOffset Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
VirtualMethodOffset = 'Offset +';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.VirtualMethodOffset.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmFastMM4Messages.WrongMMFreeErrorMsg Constant

nxmmFastMM4Messages.WrongMMFreeErrorMsg Constant
nxmmFastMM4Messages Constants Send Feedback
Syntax
Delphi
WrongMMFreeErrorMsg = 'An attempt has been made to free/reallocate a block that was allocated through a different FastMM instance. Check your memory manager sharing settings.';
File

nxmmFastMM4Messages

Description

This is constant nxmmFastMM4Messages.WrongMMFreeErrorMsg.

Group

Constants

Links
nxmmFastMM4Messages, Constants


nxmmHeapStatus Namespace

nxmmHeapStatus Namespace
Topics Variables Send Feedback

This is namespace nxmmHeapStatus.

Topics
Name | Description
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_AllocatedBytes | This is variable nxmmHeapStatus._AllocatedBytes.
_CommitedMemory | This is variable nxmmHeapStatus._CommitedMemory.
_CommitedOverhead | This is variable nxmmHeapStatus._CommitedOverhead.
_ReservedAddressSpace | This is variable nxmmHeapStatus._ReservedAddressSpace.
Links
Topics, Variables


Variables

Variables
nxmmHeapStatus Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmHeapStatus Namespace

Variables
Name | Description
_AllocatedBytes | This is variable nxmmHeapStatus._AllocatedBytes.
_CommitedMemory | This is variable nxmmHeapStatus._CommitedMemory.
_CommitedOverhead | This is variable nxmmHeapStatus._CommitedOverhead.
_ReservedAddressSpace | This is variable nxmmHeapStatus._ReservedAddressSpace.
Links
nxmmHeapStatus Namespace, Variables


nxmmHeapStatus._AllocatedBytes Variable

nxmmHeapStatus._AllocatedBytes Variable
nxmmHeapStatus Variables Send Feedback
Syntax
Delphi
_AllocatedBytes: UInt64 Cardinal;
File

nxmmHeapStatus

Description

This is variable nxmmHeapStatus._AllocatedBytes.

Group

Variables

Links
nxmmHeapStatus, Variables


nxmmHeapStatus._CommitedMemory Variable

nxmmHeapStatus._CommitedMemory Variable
nxmmHeapStatus Variables Send Feedback
Syntax
Delphi
_CommitedMemory: UInt64 Cardinal;
File

nxmmHeapStatus

Description

This is variable nxmmHeapStatus._CommitedMemory.

Group

Variables

Links
nxmmHeapStatus, Variables


nxmmHeapStatus._CommitedOverhead Variable

nxmmHeapStatus._CommitedOverhead Variable
nxmmHeapStatus Variables Send Feedback
Syntax
Delphi
_CommitedOverhead: UInt64 Cardinal;
File

nxmmHeapStatus

Description

This is variable nxmmHeapStatus._CommitedOverhead.

Group

Variables

Links
nxmmHeapStatus, Variables


nxmmHeapStatus._ReservedAddressSpace Variable

nxmmHeapStatus._ReservedAddressSpace Variable
nxmmHeapStatus Variables Send Feedback
Syntax
Delphi
_ReservedAddressSpace: UInt64 Cardinal;
File

nxmmHeapStatus

Description

This is variable nxmmHeapStatus._ReservedAddressSpace.

Group

Variables

Links
nxmmHeapStatus, Variables


nxmmItemManager Namespace

nxmmItemManager Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmmItemManager.

Classes
Name | Description
TnxMemoryPool | This is class nxmmItemManager.TnxMemoryPool.
TnxUnpagedObject | TnxUnpagedObject
Constants
Name | Description
_MemPoolsVarSizes | This is constant nxmmItemManager._MemPoolsVarSizes.
_MemPoolsVarSizesHigh | This is constant nxmmItemManager._MemPoolsVarSizesHigh.
nxcl_1KB | This is constant nxmmItemManager.nxcl_1KB.
nxcl_1MB | This is constant nxmmItemManager.nxcl_1MB.
nxcl_AllocGranularity | This is constant nxmmItemManager.nxcl_AllocGranularity.
nxcl_LargeDownsizeFactorShift | This is constant nxmmItemManager.nxcl_LargeDownsizeFactorShift.
nxcl_LargeReserveFactorShift | This is constant nxmmItemManager.nxcl_LargeReserveFactorShift.
nxcl_MemoryPoolBlockHeaderSize |
nxcl_SmallDownsizeShiftFactor | This is constant nxmmItemManager.nxcl_SmallDownsizeShiftFactor.
nxcl_SystemAllocationSize | This is constant nxmmItemManager.nxcl_SystemAllocationSize.
nxcl_SystemAllocationSizeShift | This is constant nxmmItemManager.nxcl_SystemAllocationSizeShift.
nxcl_SystemPageSize | This is constant nxmmItemManager.nxcl_SystemPageSize.
nxcl_SystemPageSizeShift | This is constant nxmmItemManager.nxcl_SystemPageSizeShift.
Functions
Name | Description
_FreeMem |
_FreeMemLarge |
_GetMem |
_GetMemLarge |
_GetMemLow |
_GetMemMM |
_GetPool | System MemoryManager Replacement
_MemoryPoolCleanup |
_ReallocMem |
_ReallocMemLarge |
AddRef |
Release |
Structs, Records, Enums
Name | Description
TnxLargeMemoryBlockInfo | This is record nxmmItemManager.TnxLargeMemoryBlockInfo.
TnxMemoryPoolBlockHeader | This is record nxmmItemManager.TnxMemoryPoolBlockHeader.
TnxMemPools |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxLargeMemoryBlockInfo |
PnxLargeMemoryBlockInfoMap | This is type nxmmItemManager.PnxLargeMemoryBlockInfoMap.
PnxMemoryPoolBlockHeader | This is type nxmmItemManager.PnxMemoryPoolBlockHeader.
TnxLargeMemoryBlockInfoMap | This is type nxmmItemManager.TnxLargeMemoryBlockInfoMap.
Variables
Name | Description
_AllocatedBytesAddr | This is variable nxmmItemManager._AllocatedBytesAddr.
_ErrorProc | This is variable nxmmItemManager._ErrorProc.
_GetMemTable |
_GetMemTableLow | This is variable nxmmItemManager._GetMemTableLow.
_GetMemTableLowPtr | This is variable nxmmItemManager._GetMemTableLowPtr.
_GetMemTableLowSmall | This is variable nxmmItemManager._GetMemTableLowSmall.
_GetMemTableLowSmallPtr | This is variable nxmmItemManager._GetMemTableLowSmallPtr.
_GetMemTablePtr | This is variable nxmmItemManager._GetMemTablePtr.
_GetMemTableSmall | This is variable nxmmItemManager._GetMemTableSmall.
_GetMemTableSmallPtr | This is variable nxmmItemManager._GetMemTableSmallPtr.
_MemPools | This is variable nxmmItemManager._MemPools.
_nxMove | This is variable nxmmItemManager._nxMove.
_nxSecureFreeMem | This is variable nxmmItemManager._nxSecureFreeMem.
_RefCount |
_UnpagedBase | This is variable nxmmItemManager._UnpagedBase.
_UnpagedCurrent | This is variable nxmmItemManager._UnpagedCurrent.
AllocSize | This is variable nxmmItemManager.AllocSize.
BlockHeader | This is variable nxmmItemManager.BlockHeader.
Info | This is variable nxmmItemManager.Info.
LargeMemoryBlockInfoMap |
LargeMemoryBlockInfoMapLevels | This is variable nxmmItemManager.LargeMemoryBlockInfoMapLevels.
LargeMemoryBlockInfoMapPool | This is variable nxmmItemManager.LargeMemoryBlockInfoMapPool.
Low | This is variable nxmmItemManager.Low.
MemInfo | This is variable nxmmItemManager.MemInfo.
Offset | This is variable nxmmItemManager.Offset.
Pool | This is variable nxmmItemManager.Pool.
Size | This is variable nxmmItemManager.Size.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxmmItemManager Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMemoryPool | This is class nxmmItemManager.TnxMemoryPool.
TnxUnpagedObject | TnxUnpagedObject
Namespace

nxmmItemManager Namespace

Links
Classes, nxmmItemManager Namespace, Legend


TnxMemoryPool Class

TnxMemoryPool Class
TnxMemoryPool Fields TnxMemoryPool Methods TnxMemoryPool Members nxmmItemManager Classes Send Feedback
Class Hierarchy
nxmmItemManager_TnxMemoryPoolnxmmItemManager_TnxMemoryPool
Syntax
Delphi
TnxMemoryPool = class(TnxUnpagedObject);
File

nxmmItemManager

Description

This is class nxmmItemManager.TnxMemoryPool.

Group

Classes

Links
TnxMemoryPool Fields, TnxMemoryPool Methods, TnxMemoryPool Members, nxmmItemManager, Classes


TnxMemoryPool Members

TnxMemoryPool Members
TnxMemoryPool Class Legend Protected Methods Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxMemoryPool.

Class

TnxMemoryPool Class

Protected Methods
Name | Description
mpAllocBlock |
mpDisposeBlock |
mpInternalCleanup |
Public Fields
Name | Description
mpBlockHeaderSize | This is mpBlockHeaderSize, a member of class TnxMemoryPool.
mpFreeBlockHead | make sure this is 8/16 byte aligned!
mpItemSize | This is mpItemSize, a member of class TnxMemoryPool.
mpItemsPerBlock | This is mpItemsPerBlock, a member of class TnxMemoryPool.
mpLow | This is mpLow, a member of class TnxMemoryPool.
mpNeedCleanup | This is mpNeedCleanup, a member of class TnxMemoryPool.
mpPartialFreeBlockBool | private implict pointer to class, 4/8 byte
mpPartialFreeBlockHead1 | make sure this is 8/16 byte aligned!
mpPartialFreeBlockHead2 | make sure this is 8/16 byte aligned!
Public Methods
Name | Description
Alloc |
Cleanup |
Create |
Destroy |
Dispose |
DisposeDirect |
Finalize |
FreeInstance |
NewInstance |
Prepare |
Links
TnxMemoryPool Class, Legend, Protected Methods, Public Fields, Public Methods


TnxMemoryPool.Create Constructor

TnxMemoryPool.Create Constructor
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Class Send Feedback
Syntax
Delphi
constructor Create(aItemSize: Cardinal; aLow: Boolean);
Class

TnxMemoryPool Class

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Class


TnxMemoryPool.Destroy Destructor

TnxMemoryPool.Destroy Destructor
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMemoryPool Class

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Class


TnxMemoryPool Fields

TnxMemoryPool Fields
TnxMemoryPool Class Legend Public Fields Send Feedback

The fields of the TnxMemoryPool class are listed here.

Class

TnxMemoryPool Class

Public Fields
Name | Description
mpBlockHeaderSize | This is mpBlockHeaderSize, a member of class TnxMemoryPool.
mpFreeBlockHead | make sure this is 8/16 byte aligned!
mpItemSize | This is mpItemSize, a member of class TnxMemoryPool.
mpItemsPerBlock | This is mpItemsPerBlock, a member of class TnxMemoryPool.
mpLow | This is mpLow, a member of class TnxMemoryPool.
mpNeedCleanup | This is mpNeedCleanup, a member of class TnxMemoryPool.
mpPartialFreeBlockBool | private implict pointer to class, 4/8 byte
mpPartialFreeBlockHead1 | make sure this is 8/16 byte aligned!
mpPartialFreeBlockHead2 | make sure this is 8/16 byte aligned!
Links
TnxMemoryPool Class, Legend, Public Fields


TnxMemoryPool.mpBlockHeaderSize Field

TnxMemoryPool.mpBlockHeaderSize Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpBlockHeaderSize: Cardinal;
Description

This is mpBlockHeaderSize, a member of class TnxMemoryPool.

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpFreeBlockHead Field

TnxMemoryPool.mpFreeBlockHead Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpFreeBlockHead: TnxListHead;
Description

make sure this is 8/16 byte aligned!

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpItemSize Field

TnxMemoryPool.mpItemSize Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpItemSize: Cardinal;
Description

This is mpItemSize, a member of class TnxMemoryPool.

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpItemsPerBlock Field

TnxMemoryPool.mpItemsPerBlock Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpItemsPerBlock: Cardinal;
Description

This is mpItemsPerBlock, a member of class TnxMemoryPool.

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpLow Field

TnxMemoryPool.mpLow Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpLow: Boolean;
Description

This is mpLow, a member of class TnxMemoryPool.

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpNeedCleanup Field

TnxMemoryPool.mpNeedCleanup Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpNeedCleanup: Cardinal;
Description

This is mpNeedCleanup, a member of class TnxMemoryPool.

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpPartialFreeBlockBool Field

TnxMemoryPool.mpPartialFreeBlockBool Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpPartialFreeBlockBool: TnxNativeUInt;
Description

private implict pointer to class, 4/8 byte

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpPartialFreeBlockHead1 Field

TnxMemoryPool.mpPartialFreeBlockHead1 Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpPartialFreeBlockHead1: TnxListHead;
Description

make sure this is 8/16 byte aligned!

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool.mpPartialFreeBlockHead2 Field

TnxMemoryPool.mpPartialFreeBlockHead2 Field
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Fields Send Feedback
Syntax
Delphi
mpPartialFreeBlockHead2: TnxListHead;
Description

make sure this is 8/16 byte aligned!

Group

TnxMemoryPool Fields

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Fields


TnxMemoryPool Methods

TnxMemoryPool Methods
TnxMemoryPool Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMemoryPool class are listed here.

Class

TnxMemoryPool Class

Protected Methods
Name | Description
mpAllocBlock |
mpDisposeBlock |
mpInternalCleanup |
Public Methods
Name | Description
Alloc |
Cleanup |
Dispose |
DisposeDirect |
Finalize |
Prepare |
Links
TnxMemoryPool Class, Legend, Protected Methods, Public Methods


TnxMemoryPool.Alloc Method

TnxMemoryPool.Alloc Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function Alloc: Pointer; register;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.Cleanup Method

TnxMemoryPool.Cleanup Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
class procedure Cleanup;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.Dispose Method

TnxMemoryPool.Dispose Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function Dispose(var P: Pointer): Boolean; register;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.DisposeDirect Method

TnxMemoryPool.DisposeDirect Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function DisposeDirect(P: Pointer): Boolean; register;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.Finalize Method

TnxMemoryPool.Finalize Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
class procedure Finalize;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.mpAllocBlock Method

TnxMemoryPool.mpAllocBlock Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function mpAllocBlock: PnxMemoryPoolBlockHeader;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.mpDisposeBlock Method

TnxMemoryPool.mpDisposeBlock Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
function mpDisposeBlock(aBlock: PnxMemoryPoolBlockHeader): Boolean;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.mpInternalCleanup Method

TnxMemoryPool.mpInternalCleanup Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
procedure mpInternalCleanup;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxMemoryPool.Prepare Method

TnxMemoryPool.Prepare Method
TnxMemoryPool Class TnxMemoryPool Members nxmmItemManager Namespace TnxMemoryPool Methods Send Feedback
Syntax
Delphi
class procedure Prepare;
Group

TnxMemoryPool Methods

Links
TnxMemoryPool Class, TnxMemoryPool Members, nxmmItemManager Namespace, TnxMemoryPool Methods


TnxUnpagedObject Class

TnxUnpagedObject Class
TnxUnpagedObject Methods TnxUnpagedObject Members nxmmItemManager Classes Send Feedback
Class Hierarchy
nxmmItemManager_TnxUnpagedObject
Syntax
Delphi
TnxUnpagedObject = class(TObject);
File

nxmmItemManager

Description

TnxUnpagedObject

Group

Classes

Links
TnxUnpagedObject Methods, TnxUnpagedObject Members, nxmmItemManager, Classes


TnxUnpagedObject Members

TnxUnpagedObject Members
TnxUnpagedObject Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxUnpagedObject.

Class

TnxUnpagedObject Class

Public Methods
Name | Description
FreeInstance |
NewInstance |
Links
TnxUnpagedObject Class, Legend, Public Methods


TnxUnpagedObject Methods

TnxUnpagedObject Methods
TnxUnpagedObject Class Legend Public Methods Send Feedback

The methods of the TnxUnpagedObject class are listed here.

Class

TnxUnpagedObject Class

Public Methods
Name | Description
FreeInstance |
NewInstance |
Links
TnxUnpagedObject Class, Legend, Public Methods


TnxUnpagedObject.FreeInstance Method

TnxUnpagedObject.FreeInstance Method
TnxUnpagedObject Class TnxUnpagedObject Members nxmmItemManager Namespace TnxUnpagedObject Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxUnpagedObject Methods

Links
TnxUnpagedObject Class, TnxUnpagedObject Members, nxmmItemManager Namespace, TnxUnpagedObject Methods


TnxUnpagedObject.NewInstance Method

TnxUnpagedObject.NewInstance Method
TnxUnpagedObject Class TnxUnpagedObject Members nxmmItemManager Namespace TnxUnpagedObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxUnpagedObject Methods

Links
TnxUnpagedObject Class, TnxUnpagedObject Members, nxmmItemManager Namespace, TnxUnpagedObject Methods


Functions

Functions
Functions nxmmItemManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
_FreeMem |
_FreeMemLarge |
_GetMem |
_GetMemLarge |
_GetMemLow |
_GetMemMM |
_GetPool | System MemoryManager Replacement
_MemoryPoolCleanup |
_ReallocMem |
_ReallocMemLarge |
AddRef |
Release |
Namespace

nxmmItemManager Namespace

Links
Functions, nxmmItemManager Namespace, Legend


nxmmItemManager._FreeMem Function

nxmmItemManager._FreeMem Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _FreeMem(aPointer: Pointer): Integer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._FreeMemLarge Function

nxmmItemManager._FreeMemLarge Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _FreeMemLarge(P: Pointer): Integer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._GetMem Function

nxmmItemManager._GetMem Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _GetMem(aSize: TnxMemSize; aLow: Boolean): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._GetMemLarge Function

nxmmItemManager._GetMemLarge Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _GetMemLarge(Size: TnxMemSize; aGrowCount: Cardinal): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._GetMemLow Function

nxmmItemManager._GetMemLow Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _GetMemLow(aSize: TnxMemSize): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._GetMemMM Function

nxmmItemManager._GetMemMM Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _GetMemMM(aSize: TnxMemSize): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._GetPool Function

nxmmItemManager._GetPool Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _GetPool(Size: TnxMemSize; aLow: Boolean): Pointer;
File

nxmmItemManager

Description

System MemoryManager Replacement

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._MemoryPoolCleanup Function

nxmmItemManager._MemoryPoolCleanup Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
procedure _MemoryPoolCleanup;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._ReallocMem Function

nxmmItemManager._ReallocMem Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _ReallocMem(aPointer: Pointer; aNewSize: TnxMemSize): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager._ReallocMemLarge Function

nxmmItemManager._ReallocMemLarge Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
function _ReallocMemLarge(P: Pointer; Size: TnxMemSize): Pointer;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager.AddRef Function

nxmmItemManager.AddRef Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


nxmmItemManager.Release Function

nxmmItemManager.Release Function
nxmmItemManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmItemManager

Group

Functions

Links
nxmmItemManager, Functions


Structs, Records, Enums

Structs, Records, Enums
nxmmItemManager Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxmmItemManager Namespace

Records
Name | Description
TnxLargeMemoryBlockInfo | This is record nxmmItemManager.TnxLargeMemoryBlockInfo.
TnxMemoryPoolBlockHeader | This is record nxmmItemManager.TnxMemoryPoolBlockHeader.
TnxMemPools |
Links
nxmmItemManager Namespace, Legend, Records


nxmmItemManager.TnxLargeMemoryBlockInfo Record

nxmmItemManager.TnxLargeMemoryBlockInfo Record
nxmmItemManager Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLargeMemoryBlockInfo = record
  Size: TnxMemSize;
  FileMapping: THandle;
  MappedBase: Pointer;
  MappedBlocks: TnxNativeInt;
  ReservedBlocks: TnxNativeInt;
  CommitedPagesMapped: TnxNativeInt;
  CommitedPagesTotal: TnxNativeInt;
  ReallocGrowCount: Cardinal;
end;
File

nxmmItemManager

Description

This is record nxmmItemManager.TnxLargeMemoryBlockInfo.

Group

Structs, Records, Enums

Links
nxmmItemManager, Structs, Records, Enums


nxmmItemManager.TnxMemoryPoolBlockHeader Record

nxmmItemManager.TnxMemoryPoolBlockHeader Record
nxmmItemManager Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMemoryPoolBlockHeader = packed record
  mpbhFreeListEntry: TnxListEntry;
  mpbhMemoryPool: TnxMemoryPool;
  mpbhFreeListHead: TnxListHead;
  mpbhUsedCount: Cardinal;
  mpbhFull: Integer;
  mpbhPadding1: Cardinal;
  mpbhPadding2: Cardinal;
end;
File

nxmmItemManager

Members
Members | Description
mpbhFreeListEntry: TnxListEntry; | 4/ 8
mpbhMemoryPool: TnxMemoryPool; | the memory pool that owns this block
mpbhFreeListHead: TnxListHead; | pointer to the first free item in this block 4/ 4
mpbhFull: Integer; | 0 = contained in free list
Description

This is record nxmmItemManager.TnxMemoryPoolBlockHeader.

Group

Structs, Records, Enums

Links
nxmmItemManager, Structs, Records, Enums


nxmmItemManager.TnxMemPools Record

nxmmItemManager.TnxMemPools Record
nxmmItemManager Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMemPools = record
  Pool4: TnxMemoryPool;
  Pool8: TnxMemoryPool;
  Pools16: array[0..03] of TnxMemoryPool;
  Pools32: array[0..29] of TnxMemoryPool;
  Pools256: array[0..10] of TnxMemoryPool;
  PoolsVar: array[0..14] of TnxMemoryPool;
end;
File

nxmmItemManager

Members
Members | Description
Pool4: TnxMemoryPool; | 4 byte
Pool8: TnxMemoryPool; | 8 byte
Pools16: array[0..03] of TnxMemoryPool; | 16 .. 64 in 16 byte steps
Pools32: array[0..29] of TnxMemoryPool; | 96 .. 1024 in 32 byte steps
Pools256: array[0..10] of TnxMemoryPool; | 1280 .. 3840 in 256 byte steps
PoolsVar: array[0..14] of TnxMemoryPool; | 15 pools from (64k-32)/16 to (64k-32)/2
Group

Structs, Records, Enums

Links
nxmmItemManager, Structs, Records, Enums


Types

Types
nxmmItemManager Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmItemManager Namespace

Types
Name | Description
PnxLargeMemoryBlockInfo |
PnxLargeMemoryBlockInfoMap | This is type nxmmItemManager.PnxLargeMemoryBlockInfoMap.
PnxMemoryPoolBlockHeader | This is type nxmmItemManager.PnxMemoryPoolBlockHeader.
TnxLargeMemoryBlockInfoMap | This is type nxmmItemManager.TnxLargeMemoryBlockInfoMap.
Links
nxmmItemManager Namespace, Types


nxmmItemManager.PnxLargeMemoryBlockInfo Type

nxmmItemManager.PnxLargeMemoryBlockInfo Type
nxmmItemManager Types Send Feedback
Syntax
Delphi
PnxLargeMemoryBlockInfo = ^TnxLargeMemoryBlockInfo;
File

nxmmItemManager

Group

Types

Links
nxmmItemManager, Types


nxmmItemManager.PnxLargeMemoryBlockInfoMap Type

nxmmItemManager.PnxLargeMemoryBlockInfoMap Type
nxmmItemManager Types Send Feedback
Syntax
Delphi
PnxLargeMemoryBlockInfoMap = ^TnxLargeMemoryBlockInfoMap;
File

nxmmItemManager

Description

This is type nxmmItemManager.PnxLargeMemoryBlockInfoMap.

Group

Types

Links
nxmmItemManager, Types


nxmmItemManager.PnxMemoryPoolBlockHeader Type

nxmmItemManager.PnxMemoryPoolBlockHeader Type
nxmmItemManager Types Send Feedback
Syntax
Delphi
PnxMemoryPoolBlockHeader = ^TnxMemoryPoolBlockHeader;
File

nxmmItemManager

Description

This is type nxmmItemManager.PnxMemoryPoolBlockHeader.

Group

Types

Links
nxmmItemManager, Types


nxmmItemManager.TnxLargeMemoryBlockInfoMap Type

nxmmItemManager.TnxLargeMemoryBlockInfoMap Type
nxmmItemManager Types Send Feedback
Syntax
Delphi
TnxLargeMemoryBlockInfoMap = array[Byte] of Pointer;
File

nxmmItemManager

Description

This is type nxmmItemManager.TnxLargeMemoryBlockInfoMap.

Group

Types

Links
nxmmItemManager, Types


Variables

Variables
nxmmItemManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmItemManager Namespace

Variables
Name | Description
_AllocatedBytesAddr | This is variable nxmmItemManager._AllocatedBytesAddr.
_ErrorProc | This is variable nxmmItemManager._ErrorProc.
_GetMemTable |
_GetMemTableLow | This is variable nxmmItemManager._GetMemTableLow.
_GetMemTableLowPtr | This is variable nxmmItemManager._GetMemTableLowPtr.
_GetMemTableLowSmall | This is variable nxmmItemManager._GetMemTableLowSmall.
_GetMemTableLowSmallPtr | This is variable nxmmItemManager._GetMemTableLowSmallPtr.
_GetMemTablePtr | This is variable nxmmItemManager._GetMemTablePtr.
_GetMemTableSmall | This is variable nxmmItemManager._GetMemTableSmall.
_GetMemTableSmallPtr | This is variable nxmmItemManager._GetMemTableSmallPtr.
_MemPools | This is variable nxmmItemManager._MemPools.
_nxMove | This is variable nxmmItemManager._nxMove.
_nxSecureFreeMem | This is variable nxmmItemManager._nxSecureFreeMem.
_RefCount |
_UnpagedBase | This is variable nxmmItemManager._UnpagedBase.
_UnpagedCurrent | This is variable nxmmItemManager._UnpagedCurrent.
AllocSize | This is variable nxmmItemManager.AllocSize.
BlockHeader | This is variable nxmmItemManager.BlockHeader.
Info | This is variable nxmmItemManager.Info.
LargeMemoryBlockInfoMap |
LargeMemoryBlockInfoMapLevels | This is variable nxmmItemManager.LargeMemoryBlockInfoMapLevels.
LargeMemoryBlockInfoMapPool | This is variable nxmmItemManager.LargeMemoryBlockInfoMapPool.
Low | This is variable nxmmItemManager.Low.
MemInfo | This is variable nxmmItemManager.MemInfo.
Offset | This is variable nxmmItemManager.Offset.
Pool | This is variable nxmmItemManager.Pool.
Size | This is variable nxmmItemManager.Size.
Links
nxmmItemManager Namespace, Variables


nxmmItemManager._AllocatedBytesAddr Variable

nxmmItemManager._AllocatedBytesAddr Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_AllocatedBytesAddr: PnxNativeUInt;
File

nxmmItemManager

Description

This is variable nxmmItemManager._AllocatedBytesAddr.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._ErrorProc Variable

nxmmItemManager._ErrorProc Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_ErrorProc: procedure(errorCode: TRuntimeError);
File

nxmmItemManager

Description

This is variable nxmmItemManager._ErrorProc.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTable Variable

nxmmItemManager._GetMemTable Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTable: array[0.._MemPoolsVarSizesHigh div 32] of TnxMemoryPool;
File

nxmmItemManager

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableLow Variable

nxmmItemManager._GetMemTableLow Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableLow: array[0.._MemPoolsVarSizesHigh div 32] of TnxMemoryPool;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableLow.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableLowPtr Variable

nxmmItemManager._GetMemTableLowPtr Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableLowPtr: Pointer = @_GetMemTableLow;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableLowPtr.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableLowSmall Variable

nxmmItemManager._GetMemTableLowSmall Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableLowSmall: array[0..64 div SizeOf(Pointer)] of TnxMemoryPool;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableLowSmall.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableLowSmallPtr Variable

nxmmItemManager._GetMemTableLowSmallPtr Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableLowSmallPtr: Pointer = @_GetMemTableLowSmall;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableLowSmallPtr.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTablePtr Variable

nxmmItemManager._GetMemTablePtr Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTablePtr: Pointer = @_GetMemTable;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTablePtr.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableSmall Variable

nxmmItemManager._GetMemTableSmall Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableSmall: array[0..64 div SizeOf(Pointer)] of TnxMemoryPool;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableSmall.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._GetMemTableSmallPtr Variable

nxmmItemManager._GetMemTableSmallPtr Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_GetMemTableSmallPtr: Pointer = @_GetMemTableSmall;
File

nxmmItemManager

Description

This is variable nxmmItemManager._GetMemTableSmallPtr.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._MemPools Variable

nxmmItemManager._MemPools Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_MemPools: array[Boolean] of TnxMemPools;
File

nxmmItemManager

Description

This is variable nxmmItemManager._MemPools.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._nxMove Variable

nxmmItemManager._nxMove Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_nxMove: TnxMove;
File

nxmmItemManager

Description

This is variable nxmmItemManager._nxMove.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._nxSecureFreeMem Variable

nxmmItemManager._nxSecureFreeMem Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_nxSecureFreeMem: Integer;
File

nxmmItemManager

Description

This is variable nxmmItemManager._nxSecureFreeMem.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._RefCount Variable

nxmmItemManager._RefCount Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmItemManager

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._UnpagedBase Variable

nxmmItemManager._UnpagedBase Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_UnpagedBase: Pointer;
File

nxmmItemManager

Description

This is variable nxmmItemManager._UnpagedBase.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager._UnpagedCurrent Variable

nxmmItemManager._UnpagedCurrent Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
_UnpagedCurrent: Pointer;
File

nxmmItemManager

Description

This is variable nxmmItemManager._UnpagedCurrent.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.AllocSize Variable

nxmmItemManager.AllocSize Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
AllocSize: TnxNativeUInt;
File

nxmmItemManager

Description

This is variable nxmmItemManager.AllocSize.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.BlockHeader Variable

nxmmItemManager.BlockHeader Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
BlockHeader: PnxMemoryPoolBlockHeader;
File

nxmmItemManager

Description

This is variable nxmmItemManager.BlockHeader.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.Info Variable

nxmmItemManager.Info Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
Info: TMemoryBasicInformation;
File

nxmmItemManager

Description

This is variable nxmmItemManager.Info.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.LargeMemoryBlockInfoMap Variable

nxmmItemManager.LargeMemoryBlockInfoMap Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
LargeMemoryBlockInfoMap: PnxLargeMemoryBlockInfoMap;
File

nxmmItemManager

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.LargeMemoryBlockInfoMapLevels Variable

nxmmItemManager.LargeMemoryBlockInfoMapLevels Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
LargeMemoryBlockInfoMapLevels: Integer;
File

nxmmItemManager

Description

This is variable nxmmItemManager.LargeMemoryBlockInfoMapLevels.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.LargeMemoryBlockInfoMapPool Variable

nxmmItemManager.LargeMemoryBlockInfoMapPool Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
LargeMemoryBlockInfoMapPool: TnxMemoryPool;
File

nxmmItemManager

Description

This is variable nxmmItemManager.LargeMemoryBlockInfoMapPool.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.Low Variable

nxmmItemManager.Low Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
Low: Boolean;
File

nxmmItemManager

Description

This is variable nxmmItemManager.Low.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.MemInfo Variable

nxmmItemManager.MemInfo Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
MemInfo: TMemoryBasicInformation;
File

nxmmItemManager

Description

This is variable nxmmItemManager.MemInfo.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.Offset Variable

nxmmItemManager.Offset Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
Offset: TnxNativeUInt;
File

nxmmItemManager

Description

This is variable nxmmItemManager.Offset.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.Pool Variable

nxmmItemManager.Pool Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
Pool: TnxMemoryPool;
File

nxmmItemManager

Description

This is variable nxmmItemManager.Pool.

Group

Variables

Links
nxmmItemManager, Variables


nxmmItemManager.Size Variable

nxmmItemManager.Size Variable
nxmmItemManager Variables Send Feedback
Syntax
Delphi
Size: TnxMemSize;
File

nxmmItemManager

Description

This is variable nxmmItemManager.Size.

Group

Variables

Links
nxmmItemManager, Variables


Constants

Constants
Constants nxmmItemManager Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_MemPoolsVarSizes | This is constant nxmmItemManager._MemPoolsVarSizes.
_MemPoolsVarSizesHigh | This is constant nxmmItemManager._MemPoolsVarSizesHigh.
nxcl_1KB | This is constant nxmmItemManager.nxcl_1KB.
nxcl_1MB | This is constant nxmmItemManager.nxcl_1MB.
nxcl_AllocGranularity | This is constant nxmmItemManager.nxcl_AllocGranularity.
nxcl_LargeDownsizeFactorShift | This is constant nxmmItemManager.nxcl_LargeDownsizeFactorShift.
nxcl_LargeReserveFactorShift | This is constant nxmmItemManager.nxcl_LargeReserveFactorShift.
nxcl_MemoryPoolBlockHeaderSize |
nxcl_SmallDownsizeShiftFactor | This is constant nxmmItemManager.nxcl_SmallDownsizeShiftFactor.
nxcl_SystemAllocationSize | This is constant nxmmItemManager.nxcl_SystemAllocationSize.
nxcl_SystemAllocationSizeShift | This is constant nxmmItemManager.nxcl_SystemAllocationSizeShift.
nxcl_SystemPageSize | This is constant nxmmItemManager.nxcl_SystemPageSize.
nxcl_SystemPageSizeShift | This is constant nxmmItemManager.nxcl_SystemPageSizeShift.
Namespace

nxmmItemManager Namespace

Links
Constants, nxmmItemManager Namespace


nxmmItemManager._MemPoolsVarSizes Constant

nxmmItemManager._MemPoolsVarSizes Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
_MemPoolsVarSizes: array[0..14] of Integer = ( 4064, 4352, 4672, 5024, 5440, 5952, 6528, 7264, 8160, 9344, 10912, 13088, 16352, 21824, 32736);
File

nxmmItemManager

Description

This is constant nxmmItemManager._MemPoolsVarSizes.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager._MemPoolsVarSizesHigh Constant

nxmmItemManager._MemPoolsVarSizesHigh Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
_MemPoolsVarSizesHigh = 32735;
File

nxmmItemManager

Description

This is constant nxmmItemManager._MemPoolsVarSizesHigh.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_1KB Constant

nxmmItemManager.nxcl_1KB Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_1KB = 1024;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_1KB.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_1MB Constant

nxmmItemManager.nxcl_1MB Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_1MB = 1024 * nxcl_1KB;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_1MB.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_AllocGranularity Constant

nxmmItemManager.nxcl_AllocGranularity Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_AllocGranularity = 2 * SizeOf(Pointer);
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_AllocGranularity.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_LargeDownsizeFactorShift Constant

nxmmItemManager.nxcl_LargeDownsizeFactorShift Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_LargeDownsizeFactorShift = 3;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_LargeDownsizeFactorShift.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_LargeReserveFactorShift Constant

nxmmItemManager.nxcl_LargeReserveFactorShift Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_LargeReserveFactorShift = 3;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_LargeReserveFactorShift.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_MemoryPoolBlockHeaderSize Constant

nxmmItemManager.nxcl_MemoryPoolBlockHeaderSize Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_MemoryPoolBlockHeaderSize = (SizeOf(TnxMemoryPoolBlockHeader) + Pred(2* SizeOf(Pointer))) and not Pred(2* SizeOf(Pointer));
File

nxmmItemManager

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_SmallDownsizeShiftFactor Constant

nxmmItemManager.nxcl_SmallDownsizeShiftFactor Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_SmallDownsizeShiftFactor = 5;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_SmallDownsizeShiftFactor.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_SystemAllocationSize Constant

nxmmItemManager.nxcl_SystemAllocationSize Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_SystemAllocationSize = 64 * nxcl_1KB;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_SystemAllocationSize.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_SystemAllocationSizeShift Constant

nxmmItemManager.nxcl_SystemAllocationSizeShift Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_SystemAllocationSizeShift = 16;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_SystemAllocationSizeShift.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_SystemPageSize Constant

nxmmItemManager.nxcl_SystemPageSize Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_SystemPageSize = 4 * nxcl_1KB;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_SystemPageSize.

Group

Constants

Links
nxmmItemManager, Constants


nxmmItemManager.nxcl_SystemPageSizeShift Constant

nxmmItemManager.nxcl_SystemPageSizeShift Constant
nxmmItemManager Constants Send Feedback
Syntax
Delphi
nxcl_SystemPageSizeShift = 12;
File

nxmmItemManager

Description

This is constant nxmmItemManager.nxcl_SystemPageSizeShift.

Group

Constants

Links
nxmmItemManager, Constants


nxmmMappingManager Namespace

nxmmMappingManager Namespace
Functions Legend Topics Types Send Feedback

This is namespace nxmmMappingManager.

Functions
Name | Description
AddRef | This is function nxmmMappingManager.AddRef.
nxMapableBlockAllocate | Allocates a new block of the requested size. May return nil if out of memory
nxMapableBlockDispose | Disposes a block, returns true if successful
nxMapableBlockLock | Maps a block into the virtual address space, May return nil if out of memory or already mapped.
nxMapableBlocksLock | Maps a block into the virtual address space, May return nil if out of memory or already mapped.
nxMapableBlocksUnlock | Unmaps a block, returns true if successful
nxMapableBlockUnlock | Unmaps a block, returns true if successful
Release | This is function nxmmMappingManager.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxMapableBlockHandle | This is type nxmmMappingManager.TnxMapableBlockHandle.
TnxMapableBlockHandles | This is type nxmmMappingManager.TnxMapableBlockHandles.
Links
Functions, Legend, Topics, Types


Functions

Functions
Functions nxmmMappingManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmMappingManager.AddRef.
nxMapableBlockAllocate | Allocates a new block of the requested size. May return nil if out of memory
nxMapableBlockDispose | Disposes a block, returns true if successful
nxMapableBlockLock | Maps a block into the virtual address space, May return nil if out of memory or already mapped.
nxMapableBlocksLock | Maps a block into the virtual address space, May return nil if out of memory or already mapped.
nxMapableBlocksUnlock | Unmaps a block, returns true if successful
nxMapableBlockUnlock | Unmaps a block, returns true if successful
Release | This is function nxmmMappingManager.Release.
Namespace

nxmmMappingManager Namespace

Links
Functions, nxmmMappingManager Namespace, Legend


nxmmMappingManager.AddRef Function

nxmmMappingManager.AddRef Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmMappingManager

Description

This is function nxmmMappingManager.AddRef.

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlockAllocate Function

nxmmMappingManager.nxMapableBlockAllocate Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockAllocate(aBlockSize: TnxBlockSizeAll; aLow: Boolean): TnxMapableBlockHandle; register;
File

nxmmMappingManager

Description

Allocates a new block of the requested size. May return nil if out of memory

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlockDispose Function

nxmmMappingManager.nxMapableBlockDispose Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockDispose(aHandle: TnxMapableBlockHandle): Boolean; register;
File

nxmmMappingManager

Description

Disposes a block, returns true if successful

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlockLock Function

nxmmMappingManager.nxMapableBlockLock Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockLock(aHandle: TnxMapableBlockHandle): Pointer; register;
File

nxmmMappingManager

Description

Maps a block into the virtual address space, May return nil if out of memory or already mapped.

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlocksLock Function

nxmmMappingManager.nxMapableBlocksLock Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlocksLock(aHandles: TnxMapableBlockHandles): Pointer; register;
File

nxmmMappingManager

Description

Maps a block into the virtual address space, May return nil if out of memory or already mapped.

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlocksUnlock Function

nxmmMappingManager.nxMapableBlocksUnlock Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlocksUnlock(aHandles: TnxMapableBlockHandles; aBlocks: Pointer): Boolean; register;
File

nxmmMappingManager

Description

Unmaps a block, returns true if successful

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.nxMapableBlockUnlock Function

nxmmMappingManager.nxMapableBlockUnlock Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
function nxMapableBlockUnlock(aHandle: TnxMapableBlockHandle; aBlock: Pointer): Boolean; register;
File

nxmmMappingManager

Description

Unmaps a block, returns true if successful

Group

Functions

Links
nxmmMappingManager, Functions


nxmmMappingManager.Release Function

nxmmMappingManager.Release Function
nxmmMappingManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmMappingManager

Description

This is function nxmmMappingManager.Release.

Group

Functions

Links
nxmmMappingManager, Functions


Types

Types
nxmmMappingManager Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmMappingManager Namespace

Types
Name | Description
TnxMapableBlockHandle | This is type nxmmMappingManager.TnxMapableBlockHandle.
TnxMapableBlockHandles | This is type nxmmMappingManager.TnxMapableBlockHandles.
Links
nxmmMappingManager Namespace, Types


nxmmMappingManager.TnxMapableBlockHandle Type

nxmmMappingManager.TnxMapableBlockHandle Type
nxmmMappingManager Types Send Feedback
Syntax
Delphi
TnxMapableBlockHandle = TnxNativeUInt;
File

nxmmMappingManager

Description

This is type nxmmMappingManager.TnxMapableBlockHandle.

Group

Types

Links
nxmmMappingManager, Types


nxmmMappingManager.TnxMapableBlockHandles Type

nxmmMappingManager.TnxMapableBlockHandles Type
nxmmMappingManager Types Send Feedback
Syntax
Delphi
TnxMapableBlockHandles = array[Byte] of TnxNativeUInt;
File

nxmmMappingManager

Description

This is type nxmmMappingManager.TnxMapableBlockHandles.

Group

Types

Links
nxmmMappingManager, Types


nxmmPhysicalFrameManager Namespace

nxmmPhysicalFrameManager Namespace
Functions Legend Topics Send Feedback

This is namespace nxmmPhysicalFrameManager.

Functions
Name | Description
AddRef | This is function nxmmPhysicalFrameManager.AddRef.
nxPhysicalCleanup | This is function nxmmPhysicalFrameManager.nxPhysicalCleanup.
nxPhysicalEmergency | This is function nxmmPhysicalFrameManager.nxPhysicalEmergency.
nxPhysicalFramesAllocate | This is function nxmmPhysicalFrameManager.nxPhysicalFramesAllocate.
nxPhysicalFramesDispose | This is function nxmmPhysicalFrameManager.nxPhysicalFramesDispose.
Release | This is function nxmmPhysicalFrameManager.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Links
Functions, Legend, Topics


Functions

Functions
Functions nxmmPhysicalFrameManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmPhysicalFrameManager.AddRef.
nxPhysicalCleanup | This is function nxmmPhysicalFrameManager.nxPhysicalCleanup.
nxPhysicalEmergency | This is function nxmmPhysicalFrameManager.nxPhysicalEmergency.
nxPhysicalFramesAllocate | This is function nxmmPhysicalFrameManager.nxPhysicalFramesAllocate.
nxPhysicalFramesDispose | This is function nxmmPhysicalFrameManager.nxPhysicalFramesDispose.
Release | This is function nxmmPhysicalFrameManager.Release.
Namespace

nxmmPhysicalFrameManager Namespace

Links
Functions, nxmmPhysicalFrameManager Namespace, Legend


nxmmPhysicalFrameManager.AddRef Function

nxmmPhysicalFrameManager.AddRef Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.AddRef.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmPhysicalFrameManager.nxPhysicalCleanup Function

nxmmPhysicalFrameManager.nxPhysicalCleanup Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
procedure nxPhysicalCleanup(aEverything: Boolean);
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.nxPhysicalCleanup.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmPhysicalFrameManager.nxPhysicalEmergency Function

nxmmPhysicalFrameManager.nxPhysicalEmergency Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
function nxPhysicalEmergency: Boolean; register;
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.nxPhysicalEmergency.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmPhysicalFrameManager.nxPhysicalFramesAllocate Function

nxmmPhysicalFrameManager.nxPhysicalFramesAllocate Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
function nxPhysicalFramesAllocate(aCount: TnxNativeUInt; out Frames): Boolean;
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.nxPhysicalFramesAllocate.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmPhysicalFrameManager.nxPhysicalFramesDispose Function

nxmmPhysicalFrameManager.nxPhysicalFramesDispose Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
function nxPhysicalFramesDispose(aCount: TnxNativeUInt; const Frames): Boolean;
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.nxPhysicalFramesDispose.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmPhysicalFrameManager.Release Function

nxmmPhysicalFrameManager.Release Function
nxmmPhysicalFrameManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmPhysicalFrameManager

Description

This is function nxmmPhysicalFrameManager.Release.

Group

Functions

Links
nxmmPhysicalFrameManager, Functions


nxmmRegionManager Namespace

nxmmRegionManager Namespace
Constants Functions Legend Topics Types Variables Send Feedback

This is namespace nxmmRegionManager.

Constants
Name | Description
MEM_PHYSICAL | This is constant nxmmRegionManager.MEM_PHYSICAL.
nxcRegionAddrMask | This is constant nxmmRegionManager.nxcRegionAddrMask.
nxcRegionAddrMaskInv | This is constant nxmmRegionManager.nxcRegionAddrMaskInv.
nxcRegionSize | This is constant nxmmRegionManager.nxcRegionSize.
nxcRegionSizeShiftFactor | This is constant nxmmRegionManager.nxcRegionSizeShiftFactor.
Functions
Name | Description
AddRef | This is function nxmmRegionManager.AddRef.
nxRegionCleanUp | Releases all cached Regions back to the OS
nxRegionCleanUpReserved | This is function nxmmRegionManager.nxRegionCleanUpReserved.
nxRegionDispose | Disposes a 4GB Region of address space, the pointer will be cached for some time to speed up nxRegionReserve requests, returns True on success
nxRegionDisposeDirect | This is function nxmmRegionManager.nxRegionDisposeDirect.
nxRegionIsPhysical | This is function nxmmRegionManager.nxRegionIsPhysical.
nxRegionReserve | Returns the base address of a 4GB region of Reserved address space. The returned pointer is guaranteed to be 4GB aligned. Allocation takes place top to bottom.
nxRegionReserveEmpty | This is function nxmmRegionManager.nxRegionReserveEmpty.
Release | This is function nxmmRegionManager.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxRegion | This is type nxmmRegionManager.PnxRegion.
TnxRegion | This is type nxmmRegionManager.TnxRegion.
Variables
Name | Description
_CachedRegionsReserved | Regions that have been reserved and returned to the manager again
_FailedRegions | Regions that couldn't be reserved last time
_PhysicalRegions | Regions that have been reserved as physical
_RefCount | This is variable nxmmRegionManager._RefCount.
_UnusedRegions | Regions potentially available to be reserved
Links
Constants, Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxmmRegionManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmRegionManager.AddRef.
nxRegionCleanUp | Releases all cached Regions back to the OS
nxRegionCleanUpReserved | This is function nxmmRegionManager.nxRegionCleanUpReserved.
nxRegionDispose | Disposes a 4GB Region of address space, the pointer will be cached for some time to speed up nxRegionReserve requests, returns True on success
nxRegionDisposeDirect | This is function nxmmRegionManager.nxRegionDisposeDirect.
nxRegionIsPhysical | This is function nxmmRegionManager.nxRegionIsPhysical.
nxRegionReserve | Returns the base address of a 4GB region of Reserved address space. The returned pointer is guaranteed to be 4GB aligned. Allocation takes place top to bottom.
nxRegionReserveEmpty | This is function nxmmRegionManager.nxRegionReserveEmpty.
Release | This is function nxmmRegionManager.Release.
Namespace

nxmmRegionManager Namespace

Links
Functions, nxmmRegionManager Namespace, Legend


nxmmRegionManager.AddRef Function

nxmmRegionManager.AddRef Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.AddRef.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionCleanUp Function

nxmmRegionManager.nxRegionCleanUp Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
procedure nxRegionCleanUp; register;
File

nxmmRegionManager

Description

Releases all cached Regions back to the OS

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionCleanUpReserved Function

nxmmRegionManager.nxRegionCleanUpReserved Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
procedure nxRegionCleanUpReserved; register;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.nxRegionCleanUpReserved.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionDispose Function

nxmmRegionManager.nxRegionDispose Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
function nxRegionDispose(p: PnxRegion): Boolean; register;
File

nxmmRegionManager

Description

Disposes a 4GB Region of address space, the pointer will be cached for some time to speed up nxRegionReserve requests, returns True on success

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionDisposeDirect Function

nxmmRegionManager.nxRegionDisposeDirect Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
function nxRegionDisposeDirect(p: PnxRegion): Boolean; register;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.nxRegionDisposeDirect.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionIsPhysical Function

nxmmRegionManager.nxRegionIsPhysical Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
function nxRegionIsPhysical(aRegion: Integer): Boolean;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.nxRegionIsPhysical.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionReserve Function

nxmmRegionManager.nxRegionReserve Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
function nxRegionReserve(aPhysical: Boolean): PnxRegion; register;
File

nxmmRegionManager

Description

Returns the base address of a 4GB region of Reserved address space. The returned pointer is guaranteed to be 4GB aligned. Allocation takes place top to bottom.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.nxRegionReserveEmpty Function

nxmmRegionManager.nxRegionReserveEmpty Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
function nxRegionReserveEmpty(aPhysical: Boolean): PnxRegion; register;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.nxRegionReserveEmpty.

Group

Functions

Links
nxmmRegionManager, Functions


nxmmRegionManager.Release Function

nxmmRegionManager.Release Function
nxmmRegionManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmRegionManager

Description

This is function nxmmRegionManager.Release.

Group

Functions

Links
nxmmRegionManager, Functions


Types

Types
nxmmRegionManager Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmRegionManager Namespace

Types
Name | Description
PnxRegion | This is type nxmmRegionManager.PnxRegion.
TnxRegion | This is type nxmmRegionManager.TnxRegion.
Links
nxmmRegionManager Namespace, Types


nxmmRegionManager.PnxRegion Type

nxmmRegionManager.PnxRegion Type
nxmmRegionManager Types Send Feedback
Syntax
Delphi
PnxRegion = ^TnxRegion;
File

nxmmRegionManager

Description

This is type nxmmRegionManager.PnxRegion.

Group

Types

Links
nxmmRegionManager, Types


nxmmRegionManager.TnxRegion Type

nxmmRegionManager.TnxRegion Type
nxmmRegionManager Types Send Feedback
Syntax
Delphi
TnxRegion = type Pointer;
File

nxmmRegionManager

Description

This is type nxmmRegionManager.TnxRegion.

Group

Types

Links
nxmmRegionManager, Types


Variables

Variables
nxmmRegionManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmRegionManager Namespace

Variables
Name | Description
_CachedRegionsReserved | Regions that have been reserved and returned to the manager again
_FailedRegions | Regions that couldn't be reserved last time
_PhysicalRegions | Regions that have been reserved as physical
_RefCount | This is variable nxmmRegionManager._RefCount.
_UnusedRegions | Regions potentially available to be reserved
Links
nxmmRegionManager Namespace, Variables


nxmmRegionManager._CachedRegionsReserved Variable

nxmmRegionManager._CachedRegionsReserved Variable
nxmmRegionManager Variables Send Feedback
Syntax
Delphi
_CachedRegionsReserved: TnxBitmap;
File

nxmmRegionManager

Description

Regions that have been reserved and returned to the manager again

Group

Variables

Links
nxmmRegionManager, Variables


nxmmRegionManager._FailedRegions Variable

nxmmRegionManager._FailedRegions Variable
nxmmRegionManager Variables Send Feedback
Syntax
Delphi
_FailedRegions: TnxBitmap;
File

nxmmRegionManager

Description

Regions that couldn't be reserved last time

Group

Variables

Links
nxmmRegionManager, Variables


nxmmRegionManager._PhysicalRegions Variable

nxmmRegionManager._PhysicalRegions Variable
nxmmRegionManager Variables Send Feedback
Syntax
Delphi
_PhysicalRegions: TnxBitmap;
File

nxmmRegionManager

Description

Regions that have been reserved as physical

Group

Variables

Links
nxmmRegionManager, Variables


nxmmRegionManager._RefCount Variable

nxmmRegionManager._RefCount Variable
nxmmRegionManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmRegionManager

Description

This is variable nxmmRegionManager._RefCount.

Group

Variables

Links
nxmmRegionManager, Variables


nxmmRegionManager._UnusedRegions Variable

nxmmRegionManager._UnusedRegions Variable
nxmmRegionManager Variables Send Feedback
Syntax
Delphi
_UnusedRegions: TnxBitmap;
File

nxmmRegionManager

Description

Regions potentially available to be reserved

Group

Variables

Links
nxmmRegionManager, Variables


Constants

Constants
Constants nxmmRegionManager Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
MEM_PHYSICAL | This is constant nxmmRegionManager.MEM_PHYSICAL.
nxcRegionAddrMask | This is constant nxmmRegionManager.nxcRegionAddrMask.
nxcRegionAddrMaskInv | This is constant nxmmRegionManager.nxcRegionAddrMaskInv.
nxcRegionSize | This is constant nxmmRegionManager.nxcRegionSize.
nxcRegionSizeShiftFactor | This is constant nxmmRegionManager.nxcRegionSizeShiftFactor.
Namespace

nxmmRegionManager Namespace

Links
Constants, nxmmRegionManager Namespace


nxmmRegionManager.MEM_PHYSICAL Constant

nxmmRegionManager.MEM_PHYSICAL Constant
nxmmRegionManager Constants Send Feedback
Syntax
Delphi
MEM_PHYSICAL = $400000;
File

nxmmRegionManager

Description

This is constant nxmmRegionManager.MEM_PHYSICAL.

Group

Constants

Links
nxmmRegionManager, Constants


nxmmRegionManager.nxcRegionAddrMask Constant

nxmmRegionManager.nxcRegionAddrMask Constant
nxmmRegionManager Constants Send Feedback
Syntax
Delphi
nxcRegionAddrMask = Pred(nxcRegionSize);
File

nxmmRegionManager

Description

This is constant nxmmRegionManager.nxcRegionAddrMask.

Group

Constants

Links
nxmmRegionManager, Constants


nxmmRegionManager.nxcRegionAddrMaskInv Constant

nxmmRegionManager.nxcRegionAddrMaskInv Constant
nxmmRegionManager Constants Send Feedback
Syntax
Delphi
nxcRegionAddrMaskInv = not nxcRegionAddrMask;
File

nxmmRegionManager

Description

This is constant nxmmRegionManager.nxcRegionAddrMaskInv.

Group

Constants

Links
nxmmRegionManager, Constants


nxmmRegionManager.nxcRegionSize Constant

nxmmRegionManager.nxcRegionSize Constant
nxmmRegionManager Constants Send Feedback
Syntax
Delphi
nxcRegionSize = 4 * 1024 * 1024 * Int64(1024);
File

nxmmRegionManager

Description

This is constant nxmmRegionManager.nxcRegionSize.

Group

Constants

Links
nxmmRegionManager, Constants


nxmmRegionManager.nxcRegionSizeShiftFactor Constant

nxmmRegionManager.nxcRegionSizeShiftFactor Constant
nxmmRegionManager Constants Send Feedback
Syntax
Delphi
nxcRegionSizeShiftFactor = 32;
File

nxmmRegionManager

Description

This is constant nxmmRegionManager.nxcRegionSizeShiftFactor.

Group

Constants

Links
nxmmRegionManager, Constants


nxmmSafeMM Namespace

nxmmSafeMM Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmmSafeMM.

Classes
Name | Description
TBlockInfo | This is class nxmmSafeMM.TBlockInfo.
TPoolInfo | This is class nxmmSafeMM.TPoolInfo.
Constants
Name | Description
cMagic | This is constant nxmmSafeMM.cMagic.
cMaxAvail | This is constant nxmmSafeMM.cMaxAvail.
cPage | should read page size from system?
cProtect | This is constant nxmmSafeMM.cProtect.
cSubCount | how many 4k blocks in a 64k pool
SafeMemoryManager | This is constant nxmmSafeMM.SafeMemoryManager.
SafeMemoryManagerEx | This is constant nxmmSafeMM.SafeMemoryManagerEx.
TopDownFlag | This is constant nxmmSafeMM.TopDownFlag.
Functions
Name | Description
SafeAllocMem | This is function nxmmSafeMM.SafeAllocMem.
SafeFreeMem | This is function nxmmSafeMM.SafeFreeMem.
SafeGetMem | This is function nxmmSafeMM.SafeGetMem.
SafeGetMemLow | This is function nxmmSafeMM.SafeGetMemLow.
SafeMMMark | This is function nxmmSafeMM.SafeMMMark.
SafeMMProtect | caller can specifically set protection on a block of memory
SafeReallocMem | This is function nxmmSafeMM.SafeReallocMem.
Structs, Records, Enums
Name | Description
TSafeGuardMode | This is record nxmmSafeMM.TSafeGuardMode.
TSafeProtect | This is record nxmmSafeMM.TSafeProtect.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PBlockInfo | This is type nxmmSafeMM.PBlockInfo.
PCardinalArray | This is type nxmmSafeMM.PCardinalArray.
PPoolInfo | This is type nxmmSafeMM.PPoolInfo.
TCardinalArray | This is type nxmmSafeMM.TCardinalArray.
Variables
Name | Description
FCritical | This is variable nxmmSafeMM.FCritical.
FHeap | This is variable nxmmSafeMM.FHeap.
FPool | This is variable nxmmSafeMM.FPool.
LastMode | This is variable nxmmSafeMM.LastMode.
SafeMMAlign | This is variable nxmmSafeMM.SafeMMAlign.
SafeMMMode | This is variable nxmmSafeMM.SafeMMMode.
SafeMMNeverRelease | This is variable nxmmSafeMM.SafeMMNeverRelease.
SafeMMNeverReleaseLow | This is variable nxmmSafeMM.SafeMMNeverReleaseLow.
SafeMMPageProtect | This is variable nxmmSafeMM.SafeMMPageProtect.
SafeMMTrashOnAlloc | This is variable nxmmSafeMM.SafeMMTrashOnAlloc.
SafeMMTrashOnFree | This is variable nxmmSafeMM.SafeMMTrashOnFree.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
nxmmSafeMM Namespace Legend Records Send Feedback

The following table lists classes in this documentation.

Namespace

nxmmSafeMM Namespace

Records
Name | Description
TBlockInfo | This is class nxmmSafeMM.TBlockInfo.
TPoolInfo | This is class nxmmSafeMM.TPoolInfo.
Links
nxmmSafeMM Namespace, Legend, Records


TBlockInfo Record

TBlockInfo Record
TBlockInfo Fields TBlockInfo Methods TBlockInfo Members nxmmSafeMM Classes Send Feedback
Syntax
Delphi
TBlockInfo = record
  biMagic: Cardinal;
  biPool: PPoolInfo;
  biPoolIndex: Integer;
  biIssued: Boolean;
  biMarked: Integer;
  biRequestSize: TnxMemSize;
  biStart: Pointer;
end;
File

nxmmSafeMM

Description

This is class nxmmSafeMM.TBlockInfo.

Group

Classes

Links
TBlockInfo Fields, TBlockInfo Methods, TBlockInfo Members, nxmmSafeMM, Classes


TBlockInfo Members

TBlockInfo Members
TBlockInfo Record Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TBlockInfo.

Record

TBlockInfo Record

Public Fields
Name | Description
biIssued |
biMagic | indicate valid info
biMarked | This is biMarked, a member of class TBlockInfo.
biPool | pool. nil=it was alloc seperately
biPoolIndex | This is biPoolIndex, a member of class TBlockInfo.
biRequestSize | requested size
biStart | pointer to returned memory
Public Methods
Name | Description
CheckValid | This is CheckValid, a member of class TBlockInfo.
Init | use a fixed size list of pointers for a stack Stack:Pointer;
lock | This is lock, a member of class TBlockInfo.
unlock | This is unlock, a member of class TBlockInfo.
Links
TBlockInfo Record, Legend, Public Fields, Public Methods


TBlockInfo Fields

TBlockInfo Fields
TBlockInfo Record Legend Public Fields Send Feedback

The fields of the TBlockInfo class are listed here.

Record

TBlockInfo Record

Public Fields
Name | Description
biIssued |
biMagic | indicate valid info
biMarked | This is biMarked, a member of class TBlockInfo.
biPool | pool. nil=it was alloc seperately
biPoolIndex | This is biPoolIndex, a member of class TBlockInfo.
biRequestSize | requested size
biStart | pointer to returned memory
Links
TBlockInfo Record, Legend, Public Fields


TBlockInfo.biIssued Field

TBlockInfo.biIssued Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biIssued: Boolean;
Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biMagic Field

TBlockInfo.biMagic Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biMagic: Cardinal;
Description

indicate valid info

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biMarked Field

TBlockInfo.biMarked Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biMarked: Integer;
Description

This is biMarked, a member of class TBlockInfo.

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biPool Field

TBlockInfo.biPool Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biPool: PPoolInfo;
Description

pool. nil=it was alloc seperately

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biPoolIndex Field

TBlockInfo.biPoolIndex Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biPoolIndex: Integer;
Description

This is biPoolIndex, a member of class TBlockInfo.

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biRequestSize Field

TBlockInfo.biRequestSize Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biRequestSize: TnxMemSize;
Description

requested size

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo.biStart Field

TBlockInfo.biStart Field
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Fields Send Feedback
Syntax
Delphi
biStart: Pointer;
Description

pointer to returned memory

Group

TBlockInfo Fields

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Fields


TBlockInfo Methods

TBlockInfo Methods
TBlockInfo Record Legend Public Methods Send Feedback

The methods of the TBlockInfo class are listed here.

Record

TBlockInfo Record

Public Methods
Name | Description
CheckValid | This is CheckValid, a member of class TBlockInfo.
Init | use a fixed size list of pointers for a stack Stack:Pointer;
lock | This is lock, a member of class TBlockInfo.
unlock | This is unlock, a member of class TBlockInfo.
Links
TBlockInfo Record, Legend, Public Methods


TBlockInfo.CheckValid Method

TBlockInfo.CheckValid Method
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Methods Send Feedback
Syntax
Delphi
procedure CheckValid;
Description

This is CheckValid, a member of class TBlockInfo.

Group

TBlockInfo Methods

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Methods


TBlockInfo.Init Method

TBlockInfo.Init Method
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Methods Send Feedback
Syntax
Delphi
procedure Init;
Description

use a fixed size list of pointers for a stack Stack:Pointer;

Group

TBlockInfo Methods

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Methods


TBlockInfo.lock Method

TBlockInfo.lock Method
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Methods Send Feedback
Syntax
Delphi
procedure lock;
Description

This is lock, a member of class TBlockInfo.

Group

TBlockInfo Methods

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Methods


TBlockInfo.unlock Method

TBlockInfo.unlock Method
TBlockInfo Record TBlockInfo Members nxmmSafeMM Namespace TBlockInfo Methods Send Feedback
Syntax
Delphi
procedure unlock;
Description

This is unlock, a member of class TBlockInfo.

Group

TBlockInfo Methods

Links
TBlockInfo Record, TBlockInfo Members, nxmmSafeMM Namespace, TBlockInfo Methods


TPoolInfo Record

TPoolInfo Record
TPoolInfo Fields TPoolInfo Methods TPoolInfo Members nxmmSafeMM Classes Send Feedback
Syntax
Delphi
TPoolInfo = record
  piPool: Pointer;
  piAvailable: array [0 .. cSubCount - 1] of Boolean;
  piLow: Boolean;
end;
File

nxmmSafeMM

Description

This is class nxmmSafeMM.TPoolInfo.

Group

Classes

Links
TPoolInfo Fields, TPoolInfo Methods, TPoolInfo Members, nxmmSafeMM, Classes


TPoolInfo Members

TPoolInfo Members
TPoolInfo Record Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TPoolInfo.

Record

TPoolInfo Record

Public Fields
Name | Description
piAvailable | is each subblock available? could be better to use 7 bits and bitwise ops? eg 01111111. then full=127,empty=0, inuse>0
piLow | This is piLow, a member of class TPoolInfo.
piPool | This is piPool, a member of class TPoolInfo.
Public Methods
Name | Description
InUse | This is InUse, a member of class TPoolInfo.
IsEmpty | This is IsEmpty, a member of class TPoolInfo.
IsFull | This is IsFull, a member of class TPoolInfo.
Links
TPoolInfo Record, Legend, Public Fields, Public Methods


TPoolInfo Fields

TPoolInfo Fields
TPoolInfo Record Legend Public Fields Send Feedback

The fields of the TPoolInfo class are listed here.

Record

TPoolInfo Record

Public Fields
Name | Description
piAvailable | is each subblock available? could be better to use 7 bits and bitwise ops? eg 01111111. then full=127,empty=0, inuse>0
piLow | This is piLow, a member of class TPoolInfo.
piPool | This is piPool, a member of class TPoolInfo.
Links
TPoolInfo Record, Legend, Public Fields


TPoolInfo.piAvailable Field

TPoolInfo.piAvailable Field
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Fields Send Feedback
Syntax
Delphi
piAvailable: array [0 .. cSubCount - 1] of Boolean;
Description

is each subblock available? could be better to use 7 bits and bitwise ops? eg 01111111. then full=127,empty=0, inuse>0

Group

TPoolInfo Fields

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Fields


TPoolInfo.piLow Field

TPoolInfo.piLow Field
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Fields Send Feedback
Syntax
Delphi
piLow: Boolean;
Description

This is piLow, a member of class TPoolInfo.

Group

TPoolInfo Fields

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Fields


TPoolInfo.piPool Field

TPoolInfo.piPool Field
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Fields Send Feedback
Syntax
Delphi
piPool: Pointer;
Description

This is piPool, a member of class TPoolInfo.

Group

TPoolInfo Fields

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Fields


TPoolInfo Methods

TPoolInfo Methods
TPoolInfo Record Legend Public Methods Send Feedback

The methods of the TPoolInfo class are listed here.

Record

TPoolInfo Record

Public Methods
Name | Description
InUse | This is InUse, a member of class TPoolInfo.
IsEmpty | This is IsEmpty, a member of class TPoolInfo.
IsFull | This is IsFull, a member of class TPoolInfo.
Links
TPoolInfo Record, Legend, Public Methods


TPoolInfo.InUse Method

TPoolInfo.InUse Method
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Methods Send Feedback
Syntax
Delphi
function InUse: Boolean;
Description

This is InUse, a member of class TPoolInfo.

Group

TPoolInfo Methods

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Methods


TPoolInfo.IsEmpty Method

TPoolInfo.IsEmpty Method
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Methods Send Feedback
Syntax
Delphi
function IsEmpty: Boolean;
Description

This is IsEmpty, a member of class TPoolInfo.

Group

TPoolInfo Methods

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Methods


TPoolInfo.IsFull Method

TPoolInfo.IsFull Method
TPoolInfo Record TPoolInfo Members nxmmSafeMM Namespace TPoolInfo Methods Send Feedback
Syntax
Delphi
function IsFull: Boolean;
Description

This is IsFull, a member of class TPoolInfo.

Group

TPoolInfo Methods

Links
TPoolInfo Record, TPoolInfo Members, nxmmSafeMM Namespace, TPoolInfo Methods


Functions

Functions
Functions nxmmSafeMM Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
SafeAllocMem | This is function nxmmSafeMM.SafeAllocMem.
SafeFreeMem | This is function nxmmSafeMM.SafeFreeMem.
SafeGetMem | This is function nxmmSafeMM.SafeGetMem.
SafeGetMemLow | This is function nxmmSafeMM.SafeGetMemLow.
SafeMMMark | This is function nxmmSafeMM.SafeMMMark.
SafeMMProtect | caller can specifically set protection on a block of memory
SafeReallocMem | This is function nxmmSafeMM.SafeReallocMem.
Namespace

nxmmSafeMM Namespace

Links
Functions, nxmmSafeMM Namespace, Legend


nxmmSafeMM.SafeAllocMem Function

nxmmSafeMM.SafeAllocMem Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
function SafeAllocMem(ASize: TnxMemSize): Pointer;
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeAllocMem.

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeFreeMem Function

nxmmSafeMM.SafeFreeMem Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
function SafeFreeMem(P: Pointer): Integer;
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeFreeMem.

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeGetMem Function

nxmmSafeMM.SafeGetMem Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
function SafeGetMem(Size: TnxMemSize): Pointer;
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeGetMem.

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeGetMemLow Function

nxmmSafeMM.SafeGetMemLow Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
function SafeGetMemLow(Size: TnxMemSize): Pointer;
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeGetMemLow.

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeMMMark Function

nxmmSafeMM.SafeMMMark Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
procedure SafeMMMark(const P: Pointer; aMark: Boolean);
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeMMMark.

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeMMProtect Function

nxmmSafeMM.SafeMMProtect Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
procedure SafeMMProtect(const P: Pointer; const aProtect: TSafeProtect);
File

nxmmSafeMM

Description

caller can specifically set protection on a block of memory

Group

Functions

Links
nxmmSafeMM, Functions


nxmmSafeMM.SafeReallocMem Function

nxmmSafeMM.SafeReallocMem Function
nxmmSafeMM Functions Send Feedback
Syntax
Delphi
function SafeReallocMem(P: Pointer; Size: TnxMemSize): Pointer;
File

nxmmSafeMM

Description

This is function nxmmSafeMM.SafeReallocMem.

Group

Functions

Links
nxmmSafeMM, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxmmSafeMM Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TSafeGuardMode | This is record nxmmSafeMM.TSafeGuardMode.
TSafeProtect | This is record nxmmSafeMM.TSafeProtect.
Namespace

nxmmSafeMM Namespace

Links
Enumerations, nxmmSafeMM Namespace, Legend


nxmmSafeMM.TSafeGuardMode Enumeration

nxmmSafeMM.TSafeGuardMode Enumeration
nxmmSafeMM Structs, Records, Enums Send Feedback
Syntax
Delphi
TSafeGuardMode = ( gmHeader, gmFooter, gmToggle );
File

nxmmSafeMM

Members
Members | Description
gmHeader | mostly protect against access before block
gmFooter | mostly protect against access after block
gmToggle | switches between Header and Footer for each allocation
Description

This is record nxmmSafeMM.TSafeGuardMode.

Group

Structs, Records, Enums

Links
nxmmSafeMM, Structs, Records, Enums


nxmmSafeMM.TSafeProtect Enumeration

nxmmSafeMM.TSafeProtect Enumeration
nxmmSafeMM Structs, Records, Enums Send Feedback
Syntax
Delphi
TSafeProtect = ( spReadWrite, spReadOnly, spProtected );
File

nxmmSafeMM

Description

This is record nxmmSafeMM.TSafeProtect.

Group

Structs, Records, Enums

Links
nxmmSafeMM, Structs, Records, Enums


Types

Types
nxmmSafeMM Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmSafeMM Namespace

Types
Name | Description
PBlockInfo | This is type nxmmSafeMM.PBlockInfo.
PCardinalArray | This is type nxmmSafeMM.PCardinalArray.
PPoolInfo | This is type nxmmSafeMM.PPoolInfo.
TCardinalArray | This is type nxmmSafeMM.TCardinalArray.
Links
nxmmSafeMM Namespace, Types


nxmmSafeMM.PBlockInfo Type

nxmmSafeMM.PBlockInfo Type
nxmmSafeMM Types Send Feedback
Syntax
Delphi
PBlockInfo = ^TBlockInfo;
File

nxmmSafeMM

Description

This is type nxmmSafeMM.PBlockInfo.

Group

Types

Links
nxmmSafeMM, Types


nxmmSafeMM.PCardinalArray Type

nxmmSafeMM.PCardinalArray Type
nxmmSafeMM Types Send Feedback
Syntax
Delphi
PCardinalArray = ^TCardinalArray;
File

nxmmSafeMM

Description

This is type nxmmSafeMM.PCardinalArray.

Group

Types

Links
nxmmSafeMM, Types


nxmmSafeMM.PPoolInfo Type

nxmmSafeMM.PPoolInfo Type
nxmmSafeMM Types Send Feedback
Syntax
Delphi
PPoolInfo = ^TPoolInfo;
File

nxmmSafeMM

Description

This is type nxmmSafeMM.PPoolInfo.

Group

Types

Links
nxmmSafeMM, Types


nxmmSafeMM.TCardinalArray Type

nxmmSafeMM.TCardinalArray Type
nxmmSafeMM Types Send Feedback
Syntax
Delphi
TCardinalArray = array [0 .. Pred(High(Integer) div SizeOf(Cardinal))] of Cardinal;
File

nxmmSafeMM

Description

This is type nxmmSafeMM.TCardinalArray.

Group

Types

Links
nxmmSafeMM, Types


Variables

Variables
nxmmSafeMM Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmSafeMM Namespace

Variables
Name | Description
FCritical | This is variable nxmmSafeMM.FCritical.
FHeap | This is variable nxmmSafeMM.FHeap.
FPool | This is variable nxmmSafeMM.FPool.
LastMode | This is variable nxmmSafeMM.LastMode.
SafeMMAlign | This is variable nxmmSafeMM.SafeMMAlign.
SafeMMMode | This is variable nxmmSafeMM.SafeMMMode.
SafeMMNeverRelease | This is variable nxmmSafeMM.SafeMMNeverRelease.
SafeMMNeverReleaseLow | This is variable nxmmSafeMM.SafeMMNeverReleaseLow.
SafeMMPageProtect | This is variable nxmmSafeMM.SafeMMPageProtect.
SafeMMTrashOnAlloc | This is variable nxmmSafeMM.SafeMMTrashOnAlloc.
SafeMMTrashOnFree | This is variable nxmmSafeMM.SafeMMTrashOnFree.
Links
nxmmSafeMM Namespace, Variables


nxmmSafeMM.FCritical Variable

nxmmSafeMM.FCritical Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
FCritical: TRTLCriticalSection;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.FCritical.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.FHeap Variable

nxmmSafeMM.FHeap Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
FHeap: Cardinal;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.FHeap.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.FPool Variable

nxmmSafeMM.FPool Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
FPool: array[Boolean] of record FAvailCount: Cardinal; FAvailList: array [0 .. cMaxAvail] of PPoolInfo; FHoldStart: Cardinal; FHoldEnd: Cardinal; end;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.FPool.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.LastMode Variable

nxmmSafeMM.LastMode Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
LastMode: TSafeGuardMode;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.LastMode.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMAlign Variable

nxmmSafeMM.SafeMMAlign Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMAlign: Cardinal = SizeOf(Pointer) * 2;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMAlign.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMMode Variable

nxmmSafeMM.SafeMMMode Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMMode: TSafeGuardMode = gmFooter;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMMode.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMNeverRelease Variable

nxmmSafeMM.SafeMMNeverRelease Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMNeverRelease: Boolean = True False;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMNeverRelease.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMNeverReleaseLow Variable

nxmmSafeMM.SafeMMNeverReleaseLow Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMNeverReleaseLow: Boolean = False;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMNeverReleaseLow.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMPageProtect Variable

nxmmSafeMM.SafeMMPageProtect Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMPageProtect: TSafeProtect = spProtected;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMPageProtect.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMTrashOnAlloc Variable

nxmmSafeMM.SafeMMTrashOnAlloc Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMTrashOnAlloc: Boolean = True;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMTrashOnAlloc.

Group

Variables

Links
nxmmSafeMM, Variables


nxmmSafeMM.SafeMMTrashOnFree Variable

nxmmSafeMM.SafeMMTrashOnFree Variable
nxmmSafeMM Variables Send Feedback
Syntax
Delphi
SafeMMTrashOnFree: Boolean = True;
File

nxmmSafeMM

Description

This is variable nxmmSafeMM.SafeMMTrashOnFree.

Group

Variables

Links
nxmmSafeMM, Variables


Constants

Constants
Constants nxmmSafeMM Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cMagic | This is constant nxmmSafeMM.cMagic.
cMaxAvail | This is constant nxmmSafeMM.cMaxAvail.
cPage | should read page size from system?
cProtect | This is constant nxmmSafeMM.cProtect.
cSubCount | how many 4k blocks in a 64k pool
SafeMemoryManager | This is constant nxmmSafeMM.SafeMemoryManager.
SafeMemoryManagerEx | This is constant nxmmSafeMM.SafeMemoryManagerEx.
TopDownFlag | This is constant nxmmSafeMM.TopDownFlag.
Namespace

nxmmSafeMM Namespace

Links
Constants, nxmmSafeMM Namespace


nxmmSafeMM.cMagic Constant

nxmmSafeMM.cMagic Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
cMagic = $C001BABE;
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.cMagic.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.cMaxAvail Constant

nxmmSafeMM.cMaxAvail Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
cMaxAvail = 16 * 65536;
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.cMaxAvail.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.cPage Constant

nxmmSafeMM.cPage Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
cPage = 4 * 1024;
File

nxmmSafeMM

Description

should read page size from system?

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.cProtect Constant

nxmmSafeMM.cProtect Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
cProtect: array [TSafeProtect] of Cardinal = (PAGE_READWRITE, PAGE_READONLY, PAGE_NOACCESS);
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.cProtect.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.cSubCount Constant

nxmmSafeMM.cSubCount Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
cSubCount = 7;
File

nxmmSafeMM

Description

how many 4k blocks in a 64k pool

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.SafeMemoryManager Constant

nxmmSafeMM.SafeMemoryManager Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
SafeMemoryManager: TMemoryManager = (GetMem: SafeGetMem; FreeMem: SafeFreeMem; ReallocMem: SafeReallocMem;);
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.SafeMemoryManager.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.SafeMemoryManagerEx Constant

nxmmSafeMM.SafeMemoryManagerEx Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
SafeMemoryManagerEx: TMemoryManagerEx = (GetMem: SafeGetMem; FreeMem: SafeFreeMem; ReallocMem: SafeReallocMem; AllocMem: SafeAllocMem; RegisterExpectedMemoryLeak: nil; UnregisterExpectedMemoryLeak: nil;);
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.SafeMemoryManagerEx.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmSafeMM.TopDownFlag Constant

nxmmSafeMM.TopDownFlag Constant
nxmmSafeMM Constants Send Feedback
Syntax
Delphi
TopDownFlag: array[Boolean] of Cardinal = (0, MEM_TOP_DOWN);
File

nxmmSafeMM

Description

This is constant nxmmSafeMM.TopDownFlag.

Group

Constants

Links
nxmmSafeMM, Constants


nxmmUnfreeableManager Namespace

nxmmUnfreeableManager Namespace
Functions Legend Topics Variables Send Feedback

This is namespace nxmmUnfreeableManager.

Functions
Name | Description
AddRef | This is function nxmmUnfreeableManager.AddRef.
nxAllocateUnfreeable | This is function nxmmUnfreeableManager.nxAllocateUnfreeable.
Release | This is function nxmmUnfreeableManager.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_RefCount | This is variable nxmmUnfreeableManager._RefCount.
Links
Functions, Legend, Topics, Variables


Functions

Functions
Functions nxmmUnfreeableManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxmmUnfreeableManager.AddRef.
nxAllocateUnfreeable | This is function nxmmUnfreeableManager.nxAllocateUnfreeable.
Release | This is function nxmmUnfreeableManager.Release.
Namespace

nxmmUnfreeableManager Namespace

Links
Functions, nxmmUnfreeableManager Namespace, Legend


nxmmUnfreeableManager.AddRef Function

nxmmUnfreeableManager.AddRef Function
nxmmUnfreeableManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmUnfreeableManager

Description

This is function nxmmUnfreeableManager.AddRef.

Group

Functions

Links
nxmmUnfreeableManager, Functions


nxmmUnfreeableManager.nxAllocateUnfreeable Function

nxmmUnfreeableManager.nxAllocateUnfreeable Function
nxmmUnfreeableManager Functions Send Feedback
Syntax
Delphi
function nxAllocateUnfreeable(aSize: Integer): Pointer;
File

nxmmUnfreeableManager

Description

This is function nxmmUnfreeableManager.nxAllocateUnfreeable.

Group

Functions

Links
nxmmUnfreeableManager, Functions


nxmmUnfreeableManager.Release Function

nxmmUnfreeableManager.Release Function
nxmmUnfreeableManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmUnfreeableManager

Description

This is function nxmmUnfreeableManager.Release.

Group

Functions

Links
nxmmUnfreeableManager, Functions


Variables

Variables
nxmmUnfreeableManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmUnfreeableManager Namespace

Variables
Name | Description
_RefCount | This is variable nxmmUnfreeableManager._RefCount.
Links
nxmmUnfreeableManager Namespace, Variables


nxmmUnfreeableManager._RefCount Variable

nxmmUnfreeableManager._RefCount Variable
nxmmUnfreeableManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmUnfreeableManager

Description

This is variable nxmmUnfreeableManager._RefCount.

Group

Variables

Links
nxmmUnfreeableManager, Variables


nxmmUtils Namespace

nxmmUtils Namespace
Functions Legend Topics Types Variables Send Feedback

This is namespace nxmmUtils.

Functions
Name | Description
AddRef |
nxSetPrivilege | nxSetPrivilege
Release |
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TAllocateUserPhysicalPages | This is type nxmmUtils.TAllocateUserPhysicalPages.
TFreeUserPhysicalPages | This is type nxmmUtils.TFreeUserPhysicalPages.
TMapUserPhysicalPages | This is type nxmmUtils.TMapUserPhysicalPages.
TMapUserPhysicalPagesScatter | This is type nxmmUtils.TMapUserPhysicalPagesScatter.
Variables
Name | Description
_RefCount |
AllocateUserPhysicalPages | This is variable nxmmUtils.AllocateUserPhysicalPages.
FreeUserPhysicalPages | This is variable nxmmUtils.FreeUserPhysicalPages.
MapUserPhysicalPages | This is variable nxmmUtils.MapUserPhysicalPages.
MapUserPhysicalPagesScatter | This is variable nxmmUtils.MapUserPhysicalPagesScatter.
nxCurrentProcess | This is variable nxmmUtils.nxCurrentProcess.
nxmmAWEAvailable | This is variable nxmmUtils.nxmmAWEAvailable.
nxmmAWESupported | This is variable nxmmUtils.nxmmAWESupported.
nxWin32BuildNumber | This is variable nxmmUtils.nxWin32BuildNumber.
nxWin32MajorVersion | This is variable nxmmUtils.nxWin32MajorVersion.
nxWin32MinorVersion | This is variable nxmmUtils.nxWin32MinorVersion.
nxWin32PlatformId | This is variable nxmmUtils.nxWin32PlatformId.
Links
Functions, Legend, Topics, Types, Variables


Functions

Functions
Functions nxmmUtils Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef |
nxSetPrivilege | nxSetPrivilege
Release |
Namespace

nxmmUtils Namespace

Links
Functions, nxmmUtils Namespace, Legend


nxmmUtils.AddRef Function

nxmmUtils.AddRef Function
nxmmUtils Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxmmUtils

Group

Functions

Links
nxmmUtils, Functions


nxmmUtils.nxSetPrivilege Function

nxmmUtils.nxSetPrivilege Function
nxmmUtils Functions Send Feedback
Syntax
Delphi
function nxSetPrivilege(aPrivilegeName: PChar; aEnable: Boolean): Boolean;
File

nxmmUtils

Description

nxSetPrivilege

Group

Functions

Links
nxmmUtils, Functions


nxmmUtils.Release Function

nxmmUtils.Release Function
nxmmUtils Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxmmUtils

Group

Functions

Links
nxmmUtils, Functions


Types

Types
nxmmUtils Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmmUtils Namespace

Types
Name | Description
TAllocateUserPhysicalPages | This is type nxmmUtils.TAllocateUserPhysicalPages.
TFreeUserPhysicalPages | This is type nxmmUtils.TFreeUserPhysicalPages.
TMapUserPhysicalPages | This is type nxmmUtils.TMapUserPhysicalPages.
TMapUserPhysicalPagesScatter | This is type nxmmUtils.TMapUserPhysicalPagesScatter.
Links
nxmmUtils Namespace, Types


nxmmUtils.TAllocateUserPhysicalPages Type

nxmmUtils.TAllocateUserPhysicalPages Type
nxmmUtils Types Send Feedback
Syntax
Delphi
TAllocateUserPhysicalPages = function (hProcess : THandle; var NumberOfPages : TnxNativeUInt; PageArray : Pointer) : LongBool;
File

nxmmUtils

Description

This is type nxmmUtils.TAllocateUserPhysicalPages.

Group

Types

Links
nxmmUtils, Types


nxmmUtils.TFreeUserPhysicalPages Type

nxmmUtils.TFreeUserPhysicalPages Type
nxmmUtils Types Send Feedback
Syntax
Delphi
TFreeUserPhysicalPages = function (hProcess : THandle; var NumberOfPages : TnxNativeUInt; PageArray : Pointer) : LongBool;
File

nxmmUtils

Description

This is type nxmmUtils.TFreeUserPhysicalPages.

Group

Types

Links
nxmmUtils, Types


nxmmUtils.TMapUserPhysicalPages Type

nxmmUtils.TMapUserPhysicalPages Type
nxmmUtils Types Send Feedback
Syntax
Delphi
TMapUserPhysicalPages = function (VirtualAddress : Pointer; NumberOfPages : TnxNativeUInt; PageArray : Pointer) : LongBool;
File

nxmmUtils

Description

This is type nxmmUtils.TMapUserPhysicalPages.

Group

Types

Links
nxmmUtils, Types


nxmmUtils.TMapUserPhysicalPagesScatter Type

nxmmUtils.TMapUserPhysicalPagesScatter Type
nxmmUtils Types Send Feedback
Syntax
Delphi
TMapUserPhysicalPagesScatter = function (VirtualAddresses : Pointer; NumberOfPages : TnxNativeUInt; PageArray : Pointer) : LongBool;
File

nxmmUtils

Description

This is type nxmmUtils.TMapUserPhysicalPagesScatter.

Group

Types

Links
nxmmUtils, Types


Variables

Variables
nxmmUtils Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmmUtils Namespace

Variables
Name | Description
_RefCount |
AllocateUserPhysicalPages | This is variable nxmmUtils.AllocateUserPhysicalPages.
FreeUserPhysicalPages | This is variable nxmmUtils.FreeUserPhysicalPages.
MapUserPhysicalPages | This is variable nxmmUtils.MapUserPhysicalPages.
MapUserPhysicalPagesScatter | This is variable nxmmUtils.MapUserPhysicalPagesScatter.
nxCurrentProcess | This is variable nxmmUtils.nxCurrentProcess.
nxmmAWEAvailable | This is variable nxmmUtils.nxmmAWEAvailable.
nxmmAWESupported | This is variable nxmmUtils.nxmmAWESupported.
nxWin32BuildNumber | This is variable nxmmUtils.nxWin32BuildNumber.
nxWin32MajorVersion | This is variable nxmmUtils.nxWin32MajorVersion.
nxWin32MinorVersion | This is variable nxmmUtils.nxWin32MinorVersion.
nxWin32PlatformId | This is variable nxmmUtils.nxWin32PlatformId.
Links
nxmmUtils Namespace, Variables


nxmmUtils._RefCount Variable

nxmmUtils._RefCount Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxmmUtils

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.AllocateUserPhysicalPages Variable

nxmmUtils.AllocateUserPhysicalPages Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
AllocateUserPhysicalPages: TAllocateUserPhysicalPages;
File

nxmmUtils

Description

This is variable nxmmUtils.AllocateUserPhysicalPages.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.FreeUserPhysicalPages Variable

nxmmUtils.FreeUserPhysicalPages Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
FreeUserPhysicalPages: TFreeUserPhysicalPages;
File

nxmmUtils

Description

This is variable nxmmUtils.FreeUserPhysicalPages.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.MapUserPhysicalPages Variable

nxmmUtils.MapUserPhysicalPages Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
MapUserPhysicalPages: TMapUserPhysicalPages;
File

nxmmUtils

Description

This is variable nxmmUtils.MapUserPhysicalPages.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.MapUserPhysicalPagesScatter Variable

nxmmUtils.MapUserPhysicalPagesScatter Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
MapUserPhysicalPagesScatter: TMapUserPhysicalPagesScatter;
File

nxmmUtils

Description

This is variable nxmmUtils.MapUserPhysicalPagesScatter.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxCurrentProcess Variable

nxmmUtils.nxCurrentProcess Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxCurrentProcess: THandle;
File

nxmmUtils

Description

This is variable nxmmUtils.nxCurrentProcess.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxmmAWEAvailable Variable

nxmmUtils.nxmmAWEAvailable Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxmmAWEAvailable: Boolean;
File

nxmmUtils

Description

This is variable nxmmUtils.nxmmAWEAvailable.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxmmAWESupported Variable

nxmmUtils.nxmmAWESupported Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxmmAWESupported: Boolean;
File

nxmmUtils

Description

This is variable nxmmUtils.nxmmAWESupported.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxWin32BuildNumber Variable

nxmmUtils.nxWin32BuildNumber Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxWin32BuildNumber: Cardinal;
File

nxmmUtils

Description

This is variable nxmmUtils.nxWin32BuildNumber.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxWin32MajorVersion Variable

nxmmUtils.nxWin32MajorVersion Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxWin32MajorVersion: Cardinal;
File

nxmmUtils

Description

This is variable nxmmUtils.nxWin32MajorVersion.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxWin32MinorVersion Variable

nxmmUtils.nxWin32MinorVersion Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxWin32MinorVersion: Cardinal;
File

nxmmUtils

Description

This is variable nxmmUtils.nxWin32MinorVersion.

Group

Variables

Links
nxmmUtils, Variables


nxmmUtils.nxWin32PlatformId Variable

nxmmUtils.nxWin32PlatformId Variable
nxmmUtils Variables Send Feedback
Syntax
Delphi
nxWin32PlatformId: Cardinal;
File

nxmmUtils

Description

This is variable nxmmUtils.nxWin32PlatformId.

Group

Variables

Links
nxmmUtils, Variables


nxmrClient Namespace

nxmrClient Namespace
Classes Constants Legend Topics Types Send Feedback

This is namespace nxmrClient.

Classes
Name | Description
TnxMessageRelayClient | HPPEMIT 'class PASCALIMPLEMENTATION TnxMessageRelayClient : public Nxllpluginbase::TnxBasePluginEngine' HPPEMIT '{' HPPEMIT ' typedef Nxllpluginbase::TnxBasePluginEngine inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' System::UnicodeString mrcDescription;' HPPEMIT ' bool mrcPromiscuous;' HPPEMIT ' TnxOnMessageReceived mrcOnMessageReceived;' HPPEMIT ' Nxmrtypes::_di_InxMessageRelayRegisteredClient mrcRegisteredClient;' HPPEMIT ' Nxllsync::TnxPadlock* mrcMessagesPadlock;' HPPEMIT ' TnxReceivedMessage* mrcMessagesHead;' HPPEMIT ' TnxReceivedMessage* mrcMessagesTail;' HPPEMIT ' NativeUInt mrcHandle;' HPPEMIT ' void __fastcall mrcSetDescription(const System::UnicodeString Value);' HPPEMIT ' void __fastcall mrcSetPromiscuous(const bool Value);' HPPEMIT ' __classmethod virtual bool __fastcall bpeIsRemote();' HPPEMIT ' virtual void __fastcall scInitializing(void);' HPPEMIT '... more
TnxReceivedMessage | This is class nxmrClient.TnxReceivedMessage.
Constants
Name | Description
NX_NEWMESSAGE | This is constant nxmrClient.NX_NEWMESSAGE.
rsTheSessionMustSupportInxClassActivator | This is constant nxmrClient.rsTheSessionMustSupportInxClassActivator.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxOnMessageReceived | This is type nxmrClient.TnxOnMessageReceived.
Links
Classes, Constants, Legend, Topics, Types


Classes

Classes
Classes nxmrClient Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMessageRelayClient | HPPEMIT 'class PASCALIMPLEMENTATION TnxMessageRelayClient : public Nxllpluginbase::TnxBasePluginEngine' HPPEMIT '{' HPPEMIT ' typedef Nxllpluginbase::TnxBasePluginEngine inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' System::UnicodeString mrcDescription;' HPPEMIT ' bool mrcPromiscuous;' HPPEMIT ' TnxOnMessageReceived mrcOnMessageReceived;' HPPEMIT ' Nxmrtypes::_di_InxMessageRelayRegisteredClient mrcRegisteredClient;' HPPEMIT ' Nxllsync::TnxPadlock* mrcMessagesPadlock;' HPPEMIT ' TnxReceivedMessage* mrcMessagesHead;' HPPEMIT ' TnxReceivedMessage* mrcMessagesTail;' HPPEMIT ' NativeUInt mrcHandle;' HPPEMIT ' void __fastcall mrcSetDescription(const System::UnicodeString Value);' HPPEMIT ' void __fastcall mrcSetPromiscuous(const bool Value);' HPPEMIT ' __classmethod virtual bool __fastcall bpeIsRemote();' HPPEMIT ' virtual void __fastcall scInitializing(void);' HPPEMIT '... more
TnxReceivedMessage | This is class nxmrClient.TnxReceivedMessage.
Namespace

nxmrClient Namespace

Links
Classes, nxmrClient Namespace, Legend


TnxMessageRelayClient Class

TnxMessageRelayClient Class
TnxMessageRelayClient Fields TnxMessageRelayClient Methods TnxMessageRelayClient Properties TnxMessageRelayClient Events TnxMessageRelayClient Members nxmrClient Classes Send Feedback
Class Hierarchy
nxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClientnxmrClient_TnxMessageRelayClient
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxMessageRelayClient = class(TnxBasePluginEngine, InxMessageRelayClient);
File

nxmrClient

Description

HPPEMIT 'class PASCALIMPLEMENTATION TnxMessageRelayClient : public Nxllpluginbase::TnxBasePluginEngine' HPPEMIT '{' HPPEMIT ' typedef Nxllpluginbase::TnxBasePluginEngine inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' System::UnicodeString mrcDescription;' HPPEMIT ' bool mrcPromiscuous;' HPPEMIT ' TnxOnMessageReceived mrcOnMessageReceived;' HPPEMIT ' Nxmrtypes::_di_InxMessageRelayRegisteredClient mrcRegisteredClient;' HPPEMIT ' Nxllsync::TnxPadlock* mrcMessagesPadlock;' HPPEMIT ' TnxReceivedMessage* mrcMessagesHead;' HPPEMIT ' TnxReceivedMessage* mrcMessagesTail;' HPPEMIT ' NativeUInt mrcHandle;' HPPEMIT ' void __fastcall mrcSetDescription(const System::UnicodeString Value);' HPPEMIT ' void __fastcall mrcSetPromiscuous(const bool Value);' HPPEMIT ' __classmethod virtual bool __fastcall bpeIsRemote();' HPPEMIT ' virtual void __fastcall scInitializing(void);' HPPEMIT ' virtual void __fastcall scStarting(void);' HPPEMIT ' virtual void __fastcall scStopping(void);' HPPEMIT ' void __fastcall mrcProcessMessages(void);' HPPEMIT ' void __fastcall mrcProcessMessage(TnxReceivedMessage* aMessage);' HPPEMIT ' void __fastcall mrcWndMethod(Winapi::Messages::TMessage &Message);' HPPEMIT ' MESSAGE void __fastcall nxNewMessage(Winapi::Messages::TMessage &Message);' HPPEMIT '' HPPEMIT 'private:' HPPEMIT ' Nxmrtypes::_di_InxMessageRelayClientList __fastcall mrcGetClients(void);' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' void __fastcall ReceivedMessage(const GUID &aFrom, const GUID &aTo, const GUID &aMsgID, const System::UnicodeString aMsg, const System::TByteDynArray aData, const System::_di_IInterface aIntf);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' virtual void __fastcall DefaultHandler(void *Message);' HPPEMIT '#undef SendMessage' HPPEMIT 'void __fastcall SendMessage(const GUID &aTo, const GUID &aMsgID, const System::UnicodeString aMsg, const System::TByteDynArray aData, const System::_di_IInterface aIntf);' HPPEMIT '#define SendMessage SendMessageW' HPPEMIT ' void __fastcall BroadcastMessage(const GUID &aMsgID, const System::UnicodeString aMsg, const System::TByteDynArray aData, const System::_di_IInterface aIntf);' HPPEMIT ' __property Nxmrtypes::_di_InxMessageRelayClientList Clients = {read=mrcGetClients};' HPPEMIT '' HPPEMIT '__published:' HPPEMIT ' __property Session;' HPPEMIT ' __property System::UnicodeString Description = {read=mrcDescription, write=mrcSetDescription};' HPPEMIT ' __property bool Promiscuous = {read=mrcPromiscuous, write=mrcSetPromiscuous, nodefault};' HPPEMIT ' __property TnxOnMessageReceived OnMessageReceived = {read=mrcOnMessageReceived, write=mrcOnMessageReceived};' HPPEMIT 'public:' HPPEMIT ' /* TnxBasePluginEngine.Create */ inline __fastcall virtual TnxMessageRelayClient(System::Classes::TComponent* aOwner) : Nxllpluginbase::TnxBasePluginEngine(aOwner) { }' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' /* TnxStateComponent.Destroy */ inline __fastcall virtual ~TnxMessageRelayClient(void) { }' HPPEMIT '' HPPEMIT 'private:' HPPEMIT ' void *__InxMessageRelayClient; // Nxmrtypes::InxMessageRelayClient' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' #if defined(MANAGED_INTERFACE_OPERATORS)' HPPEMIT ' // {A6CFDD43-B0A6-4786-8CBB-F1D266A3769B}' HPPEMIT ' operator Nxmrtypes::_di_InxMessageRelayClient()' HPPEMIT ' {' HPPEMIT ' Nxmrtypes::_di_InxMessageRelayClient intf;' HPPEMIT ' GetInterface(intf);' HPPEMIT ' return intf;' HPPEMIT ' }' HPPEMIT ' #else' HPPEMIT ' operator Nxmrtypes::InxMessageRelayClient*(void) { return (Nxmrtypes::InxMessageRelayClient* )&__InxMessageRelayClient; }' HPPEMIT ' #endif' HPPEMIT '' HPPEMIT '};'

Group

Classes

Links
TnxMessageRelayClient Fields, TnxMessageRelayClient Methods, TnxMessageRelayClient Properties, TnxMessageRelayClient Events, TnxMessageRelayClient Members, nxmrClient, Classes


TnxMessageRelayClient Members

TnxMessageRelayClient Members
TnxMessageRelayClient Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxMessageRelayClient.

Class

TnxMessageRelayClient Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
mrcDescription | private
mrcHandle | This is mrcHandle, a member of class TnxMessageRelayClient.
mrcMessagesHead | This is mrcMessagesHead, a member of class TnxMessageRelayClient.
mrcMessagesPadlock | This is mrcMessagesPadlock, a member of class TnxMessageRelayClient.
mrcMessagesTail | This is mrcMessagesTail, a member of class TnxMessageRelayClient.
mrcOnMessageReceived | This is mrcOnMessageReceived, a member of class TnxMessageRelayClient.
mrcPromiscuous | This is mrcPromiscuous, a member of class TnxMessageRelayClient.
mrcRegisteredClient | This is mrcRegisteredClient, a member of class TnxMessageRelayClient.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxMessageRelayClient
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
mrcProcessMessage | This is mrcProcessMessage, a member of class TnxMessageRelayClient.
mrcProcessMessages | This is mrcProcessMessages, a member of class TnxMessageRelayClient.
mrcSetDescription | This is mrcSetDescription, a member of class TnxMessageRelayClient.
mrcSetPromiscuous | This is mrcSetPromiscuous, a member of class TnxMessageRelayClient.
mrcWndMethod | This is mrcWndMethod, a member of class TnxMessageRelayClient.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
nxNewMessage | This is nxNewMessage, a member of class TnxMessageRelayClient.
rcRegister |
rcUnregister |
ReceivedMessage | InxMessageRelayClient
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Protected Properties
Name | Description
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
BroadcastMessage | This is BroadcastMessage, a member of class TnxMessageRelayClient.
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
DefaultHandler | This is DefaultHandler, a member of class TnxMessageRelayClient.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
SendMessage | This is SendMessage, a member of class TnxMessageRelayClient.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Clients | This is Clients, a member of class TnxMessageRelayClient.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Events
Name | Description
OnMessageReceived | This is OnMessageReceived, a member of class TnxMessageRelayClient.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
Description | This is Description, a member of class TnxMessageRelayClient.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Promiscuous | This is Promiscuous, a member of class TnxMessageRelayClient.
Session | This is Session, a member of class TnxMessageRelayClient.
Version | Version of the component.
Links
TnxMessageRelayClient Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Events, Published Properties


TnxMessageRelayClient Fields

TnxMessageRelayClient Fields
TnxMessageRelayClient Class Legend Protected Fields Send Feedback

The fields of the TnxMessageRelayClient class are listed here.

Class

TnxMessageRelayClient Class

Protected Fields
Name | Description
mrcDescription | private
mrcHandle | This is mrcHandle, a member of class TnxMessageRelayClient.
mrcMessagesHead | This is mrcMessagesHead, a member of class TnxMessageRelayClient.
mrcMessagesPadlock | This is mrcMessagesPadlock, a member of class TnxMessageRelayClient.
mrcMessagesTail | This is mrcMessagesTail, a member of class TnxMessageRelayClient.
mrcOnMessageReceived | This is mrcOnMessageReceived, a member of class TnxMessageRelayClient.
mrcPromiscuous | This is mrcPromiscuous, a member of class TnxMessageRelayClient.
mrcRegisteredClient | This is mrcRegisteredClient, a member of class TnxMessageRelayClient.
Links
TnxMessageRelayClient Class, Legend, Protected Fields


TnxMessageRelayClient.mrcDescription Field

TnxMessageRelayClient.mrcDescription Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcDescription: string;
Description

private

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcHandle Field

TnxMessageRelayClient.mrcHandle Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcHandle: THandle;
Description

This is mrcHandle, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcMessagesHead Field

TnxMessageRelayClient.mrcMessagesHead Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcMessagesHead: TnxReceivedMessage;
Description

This is mrcMessagesHead, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcMessagesPadlock Field

TnxMessageRelayClient.mrcMessagesPadlock Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcMessagesPadlock: TnxPadlock;
Description

This is mrcMessagesPadlock, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcMessagesTail Field

TnxMessageRelayClient.mrcMessagesTail Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcMessagesTail: TnxReceivedMessage;
Description

This is mrcMessagesTail, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcOnMessageReceived Field

TnxMessageRelayClient.mrcOnMessageReceived Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcOnMessageReceived: TnxOnMessageReceived;
Description

This is mrcOnMessageReceived, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcPromiscuous Field

TnxMessageRelayClient.mrcPromiscuous Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcPromiscuous: Boolean;
Description

This is mrcPromiscuous, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient.mrcRegisteredClient Field

TnxMessageRelayClient.mrcRegisteredClient Field
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Fields Send Feedback
Syntax
Delphi
mrcRegisteredClient: InxMessageRelayRegisteredClient;
Description

This is mrcRegisteredClient, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Fields

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Fields


TnxMessageRelayClient Methods

TnxMessageRelayClient Methods
TnxMessageRelayClient Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMessageRelayClient class are listed here.

Class

TnxMessageRelayClient Class

Protected Methods
Name | Description
bpeIsRemote | TnxMessageRelayClient
mrcProcessMessage | This is mrcProcessMessage, a member of class TnxMessageRelayClient.
mrcProcessMessages | This is mrcProcessMessages, a member of class TnxMessageRelayClient.
mrcSetDescription | This is mrcSetDescription, a member of class TnxMessageRelayClient.
mrcSetPromiscuous | This is mrcSetPromiscuous, a member of class TnxMessageRelayClient.
mrcWndMethod | This is mrcWndMethod, a member of class TnxMessageRelayClient.
nxNewMessage | This is nxNewMessage, a member of class TnxMessageRelayClient.
ReceivedMessage | InxMessageRelayClient
scInitializing |
scStarting |
scStopping |
Public Methods
Name | Description
BroadcastMessage | This is BroadcastMessage, a member of class TnxMessageRelayClient.
DefaultHandler | This is DefaultHandler, a member of class TnxMessageRelayClient.
SendMessage | This is SendMessage, a member of class TnxMessageRelayClient.
Links
TnxMessageRelayClient Class, Legend, Protected Methods, Public Methods


TnxMessageRelayClient.bpeIsRemote Method

TnxMessageRelayClient.bpeIsRemote Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
class function bpeIsRemote: Boolean; override;
Description

TnxMessageRelayClient

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.BroadcastMessage Method

TnxMessageRelayClient.BroadcastMessage Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure BroadcastMessage(const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Description

This is BroadcastMessage, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.DefaultHandler Method

TnxMessageRelayClient.DefaultHandler Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure DefaultHandler(var Message); override;
Description

This is DefaultHandler, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.mrcProcessMessage Method

TnxMessageRelayClient.mrcProcessMessage Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure mrcProcessMessage(aMessage: TnxReceivedMessage);
Description

This is mrcProcessMessage, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.mrcProcessMessages Method

TnxMessageRelayClient.mrcProcessMessages Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure mrcProcessMessages;
Description

This is mrcProcessMessages, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.mrcSetDescription Method

TnxMessageRelayClient.mrcSetDescription Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure mrcSetDescription(const Value: string);
Description

This is mrcSetDescription, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.mrcSetPromiscuous Method

TnxMessageRelayClient.mrcSetPromiscuous Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure mrcSetPromiscuous(const Value: Boolean);
Description

This is mrcSetPromiscuous, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.mrcWndMethod Method

TnxMessageRelayClient.mrcWndMethod Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure mrcWndMethod(var Message: TMessage);
Description

This is mrcWndMethod, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.nxNewMessage Method

TnxMessageRelayClient.nxNewMessage Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure nxNewMessage(var Message: TMessage); message NX_NEWMESSAGE;
Description

This is nxNewMessage, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.ReceivedMessage Method

TnxMessageRelayClient.ReceivedMessage Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure ReceivedMessage(const aFrom: TnxGuid; const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Description

InxMessageRelayClient

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.scInitializing Method

TnxMessageRelayClient.scInitializing Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.scStarting Method

TnxMessageRelayClient.scStarting Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.scStopping Method

TnxMessageRelayClient.scStopping Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient.SendMessage Method

TnxMessageRelayClient.SendMessage Method
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure SendMessage(const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Description

This is SendMessage, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Methods

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Methods


TnxMessageRelayClient Properties

TnxMessageRelayClient Properties
TnxMessageRelayClient Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxMessageRelayClient class are listed here.

Class

TnxMessageRelayClient Class

Public Properties
Name | Description
Clients | This is Clients, a member of class TnxMessageRelayClient.
Published Properties
Name | Description
Description | This is Description, a member of class TnxMessageRelayClient.
Promiscuous | This is Promiscuous, a member of class TnxMessageRelayClient.
Session | This is Session, a member of class TnxMessageRelayClient.
Links
TnxMessageRelayClient Class, Legend, Public Properties, Published Properties


TnxMessageRelayClient.Clients Property

TnxMessageRelayClient.Clients Property
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Properties Send Feedback
Syntax
Delphi
property Clients: InxMessageRelayClientList;
Description

This is Clients, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Properties

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Properties


TnxMessageRelayClient.Description Property

TnxMessageRelayClient.Description Property
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Properties Send Feedback
Syntax
Delphi
property Description: string;
Description

This is Description, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Properties

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Properties


TnxMessageRelayClient.Promiscuous Property

TnxMessageRelayClient.Promiscuous Property
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Properties Send Feedback
Syntax
Delphi
property Promiscuous: Boolean;
Description

This is Promiscuous, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Properties

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Properties


TnxMessageRelayClient.Session Property

TnxMessageRelayClient.Session Property
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Properties Send Feedback
Syntax
Delphi
property Session: TnxStateComponent;
Description

This is Session, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Properties

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Properties


TnxMessageRelayClient Events

TnxMessageRelayClient Events
TnxMessageRelayClient Class Legend Published Events Send Feedback

The events of the TnxMessageRelayClient class are listed here.

Class

TnxMessageRelayClient Class

Published Events
Name | Description
OnMessageReceived | This is OnMessageReceived, a member of class TnxMessageRelayClient.
Links
TnxMessageRelayClient Class, Legend, Published Events


TnxMessageRelayClient.OnMessageReceived Event

TnxMessageRelayClient.OnMessageReceived Event
TnxMessageRelayClient Class TnxMessageRelayClient Members nxmrClient Namespace TnxMessageRelayClient Events Send Feedback
Syntax
Delphi
property OnMessageReceived: TnxOnMessageReceived;
Description

This is OnMessageReceived, a member of class TnxMessageRelayClient.

Group

TnxMessageRelayClient Events

Links
TnxMessageRelayClient Class, TnxMessageRelayClient Members, nxmrClient Namespace, TnxMessageRelayClient Events


TnxReceivedMessage Class

TnxReceivedMessage Class
TnxReceivedMessage Fields TnxReceivedMessage Members nxmrClient Classes Send Feedback
Class Hierarchy
nxmrClient_TnxReceivedMessagenxmrClient_TnxReceivedMessage
Syntax
Delphi
TnxReceivedMessage = class(TnxObject);
File

nxmrClient

Description

This is class nxmrClient.TnxReceivedMessage.

Group

Classes

Links
TnxReceivedMessage Fields, TnxReceivedMessage Members, nxmrClient, Classes


TnxReceivedMessage Members

TnxReceivedMessage Members
TnxReceivedMessage Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxReceivedMessage.

Class

TnxReceivedMessage Class

Public Fields
Name | Description
rmData | This is rmData, a member of class TnxReceivedMessage.
rmFrom | This is rmFrom, a member of class TnxReceivedMessage.
rmIntf | This is rmIntf, a member of class TnxReceivedMessage.
rmMsg | This is rmMsg, a member of class TnxReceivedMessage.
rmMsgID | This is rmMsgID, a member of class TnxReceivedMessage.
rmNext | This is rmNext, a member of class TnxReceivedMessage.
rmTo | This is rmTo, a member of class TnxReceivedMessage.
Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxReceivedMessage Class, Legend, Public Fields, Public Methods


TnxReceivedMessage Fields

TnxReceivedMessage Fields
TnxReceivedMessage Class Legend Public Fields Send Feedback

The fields of the TnxReceivedMessage class are listed here.

Class

TnxReceivedMessage Class

Public Fields
Name | Description
rmData | This is rmData, a member of class TnxReceivedMessage.
rmFrom | This is rmFrom, a member of class TnxReceivedMessage.
rmIntf | This is rmIntf, a member of class TnxReceivedMessage.
rmMsg | This is rmMsg, a member of class TnxReceivedMessage.
rmMsgID | This is rmMsgID, a member of class TnxReceivedMessage.
rmNext | This is rmNext, a member of class TnxReceivedMessage.
rmTo | This is rmTo, a member of class TnxReceivedMessage.
Links
TnxReceivedMessage Class, Legend, Public Fields


TnxReceivedMessage.rmData Field

TnxReceivedMessage.rmData Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmData: TnxBytes;
Description

This is rmData, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmFrom Field

TnxReceivedMessage.rmFrom Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmFrom: TnxGuid;
Description

This is rmFrom, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmIntf Field

TnxReceivedMessage.rmIntf Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmIntf: InxInterface;
Description

This is rmIntf, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmMsg Field

TnxReceivedMessage.rmMsg Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmMsg: string;
Description

This is rmMsg, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmMsgID Field

TnxReceivedMessage.rmMsgID Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmMsgID: TnxGuid;
Description

This is rmMsgID, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmNext Field

TnxReceivedMessage.rmNext Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmNext: TnxReceivedMessage;
Description

This is rmNext, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


TnxReceivedMessage.rmTo Field

TnxReceivedMessage.rmTo Field
TnxReceivedMessage Class TnxReceivedMessage Members nxmrClient Namespace TnxReceivedMessage Fields Send Feedback
Syntax
Delphi
rmTo: TnxGuid;
Description

This is rmTo, a member of class TnxReceivedMessage.

Group

TnxReceivedMessage Fields

Links
TnxReceivedMessage Class, TnxReceivedMessage Members, nxmrClient Namespace, TnxReceivedMessage Fields


Types

Types
nxmrClient Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmrClient Namespace

Types
Name | Description
TnxOnMessageReceived | This is type nxmrClient.TnxOnMessageReceived.
Links
nxmrClient Namespace, Types


nxmrClient.TnxOnMessageReceived Type

nxmrClient.TnxOnMessageReceived Type
nxmrClient Types Send Feedback
Syntax
Delphi
TnxOnMessageReceived = procedure (aSender : TnxMessageRelayClient; aMessage : TnxReceivedMessage) of object;
File

nxmrClient

Description

This is type nxmrClient.TnxOnMessageReceived.

Group

Types

Links
nxmrClient, Types


Constants

Constants
Constants nxmrClient Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
NX_NEWMESSAGE | This is constant nxmrClient.NX_NEWMESSAGE.
rsTheSessionMustSupportInxClassActivator | This is constant nxmrClient.rsTheSessionMustSupportInxClassActivator.
Namespace

nxmrClient Namespace

Links
Constants, nxmrClient Namespace


nxmrClient.NX_NEWMESSAGE Constant

nxmrClient.NX_NEWMESSAGE Constant
nxmrClient Constants Send Feedback
Syntax
Delphi
NX_NEWMESSAGE = WM_USER + 1;
File

nxmrClient

Description

This is constant nxmrClient.NX_NEWMESSAGE.

Group

Constants

Links
nxmrClient, Constants


nxmrClient.rsTheSessionMustSupportInxClassActivator Constant

nxmrClient.rsTheSessionMustSupportInxClassActivator Constant
nxmrClient Constants Send Feedback
Syntax
Delphi
rsTheSessionMustSupportInxClassActivator = 'The Session must support InxClassActivator';
File

nxmrClient

Description

This is constant nxmrClient.rsTheSessionMustSupportInxClassActivator.

Group

Constants

Links
nxmrClient, Constants


nxmrServer Namespace

nxmrServer Namespace
Classes Legend Topics Variables Send Feedback

This is namespace nxmrServer.

Classes
Name | Description
TnxMessageRelayRegisteredClient | This is class nxmrServer.TnxMessageRelayRegisteredClient.
TnxMessageRelayServer | This is class nxmrServer.TnxMessageRelayServer.
TnxServerMessageRelayClientList | This is class nxmrServer.TnxServerMessageRelayClientList.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_MessageRelayServerControl | Init/Done
Links
Classes, Legend, Topics, Variables


Classes

Classes
Classes nxmrServer Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMessageRelayRegisteredClient | This is class nxmrServer.TnxMessageRelayRegisteredClient.
TnxMessageRelayServer | This is class nxmrServer.TnxMessageRelayServer.
TnxServerMessageRelayClientList | This is class nxmrServer.TnxServerMessageRelayClientList.
Namespace

nxmrServer Namespace

Links
Classes, nxmrServer Namespace, Legend


TnxMessageRelayRegisteredClient Class

TnxMessageRelayRegisteredClient Class
TnxMessageRelayRegisteredClient Fields TnxMessageRelayRegisteredClient Methods TnxMessageRelayRegisteredClient Members nxmrServer Classes Send Feedback
Class Hierarchy
nxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClientnxmrServer_TnxMessageRelayRegisteredClient
Syntax
Delphi
TnxMessageRelayRegisteredClient = class(TnxClass, InxMessageRelayRegisteredClient);
File

nxmrServer

Description

This is class nxmrServer.TnxMessageRelayRegisteredClient.

Group

Classes

Links
TnxMessageRelayRegisteredClient Fields, TnxMessageRelayRegisteredClient Methods, TnxMessageRelayRegisteredClient Members, nxmrServer, Classes


TnxMessageRelayRegisteredClient Members

TnxMessageRelayRegisteredClient Members
TnxMessageRelayRegisteredClient Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMessageRelayRegisteredClient.

Class

TnxMessageRelayRegisteredClient Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
rmrcClient | This is rmrcClient, a member of class TnxMessageRelayRegisteredClient.
rmrcDescription | This is rmrcDescription, a member of class TnxMessageRelayRegisteredClient.
rmrcID | private
rmrcPromiscuous | This is rmrcPromiscuous, a member of class TnxMessageRelayRegisteredClient.
rmrcServer | This is rmrcServer, a member of class TnxMessageRelayRegisteredClient.
rmrcServerIntf | This is rmrcServerIntf, a member of class TnxMessageRelayRegisteredClient.
rmrcServerNext | This is rmrcServerNext, a member of class TnxMessageRelayRegisteredClient.
rmrcServerPrev | This is rmrcServerPrev, a member of class TnxMessageRelayRegisteredClient.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
CreateInstance |
GetClassID | InxClass
GetClientList |
InternalAddRef |
InternalQueryInterface |
InternalRelease |
InternalRelease | InxInterface methods ONLY for InxInterface
ioDeactivate |
OwnID | InxMessageRelayRegisteredClient
QueryInterface |
QueryInterface |
rmrcAddToServer |
rmrcRemoveFromServer |
SendMessage |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxMessageRelayRegisteredClient
Destroy |
Free |
FreeInstance |
GetClassID | This is GetClassID, a member of class InxClass.
Initialize |
NewInstance |
NewInstance | TnxObject
SafeCallException |
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxMessageRelayRegisteredClient Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMessageRelayRegisteredClient.Create Constructor

TnxMessageRelayRegisteredClient.Create Constructor
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Class Send Feedback
Syntax
Delphi
constructor Create(aServer: TnxMessageRelayServer; const aClient: InxMessageRelayClient; const aDescription: string; aPromiscuous: Boolean); reintroduce;
Description

TnxMessageRelayRegisteredClient

Class

TnxMessageRelayRegisteredClient Class

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Class


TnxMessageRelayRegisteredClient.Destroy Destructor

TnxMessageRelayRegisteredClient.Destroy Destructor
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMessageRelayRegisteredClient Class

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Class


TnxMessageRelayRegisteredClient Fields

TnxMessageRelayRegisteredClient Fields
TnxMessageRelayRegisteredClient Class Legend Protected Fields Send Feedback

The fields of the TnxMessageRelayRegisteredClient class are listed here.

Class

TnxMessageRelayRegisteredClient Class

Protected Fields
Name | Description
rmrcClient | This is rmrcClient, a member of class TnxMessageRelayRegisteredClient.
rmrcDescription | This is rmrcDescription, a member of class TnxMessageRelayRegisteredClient.
rmrcID | private
rmrcPromiscuous | This is rmrcPromiscuous, a member of class TnxMessageRelayRegisteredClient.
rmrcServer | This is rmrcServer, a member of class TnxMessageRelayRegisteredClient.
rmrcServerIntf | This is rmrcServerIntf, a member of class TnxMessageRelayRegisteredClient.
rmrcServerNext | This is rmrcServerNext, a member of class TnxMessageRelayRegisteredClient.
rmrcServerPrev | This is rmrcServerPrev, a member of class TnxMessageRelayRegisteredClient.
Links
TnxMessageRelayRegisteredClient Class, Legend, Protected Fields


TnxMessageRelayRegisteredClient.rmrcClient Field

TnxMessageRelayRegisteredClient.rmrcClient Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcClient: InxMessageRelayClient;
Description

This is rmrcClient, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcDescription Field

TnxMessageRelayRegisteredClient.rmrcDescription Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcDescription: string;
Description

This is rmrcDescription, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcID Field

TnxMessageRelayRegisteredClient.rmrcID Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcID: TnxGuid;
Description

private

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcPromiscuous Field

TnxMessageRelayRegisteredClient.rmrcPromiscuous Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcPromiscuous: Boolean;
Description

This is rmrcPromiscuous, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcServer Field

TnxMessageRelayRegisteredClient.rmrcServer Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcServer: TnxMessageRelayServer;
Description

This is rmrcServer, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcServerIntf Field

TnxMessageRelayRegisteredClient.rmrcServerIntf Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcServerIntf: InxMessageRelayServer;
Description

This is rmrcServerIntf, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcServerNext Field

TnxMessageRelayRegisteredClient.rmrcServerNext Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcServerNext: TnxMessageRelayRegisteredClient;
Description

This is rmrcServerNext, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient.rmrcServerPrev Field

TnxMessageRelayRegisteredClient.rmrcServerPrev Field
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Fields Send Feedback
Syntax
Delphi
rmrcServerPrev: TnxMessageRelayRegisteredClient;
Description

This is rmrcServerPrev, a member of class TnxMessageRelayRegisteredClient.

Group

TnxMessageRelayRegisteredClient Fields

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Fields


TnxMessageRelayRegisteredClient Methods

TnxMessageRelayRegisteredClient Methods
TnxMessageRelayRegisteredClient Class Legend Protected Methods Send Feedback

The methods of the TnxMessageRelayRegisteredClient class are listed here.

Class

TnxMessageRelayRegisteredClient Class

Protected Methods
Name | Description
GetClientList |
OwnID | InxMessageRelayRegisteredClient
rmrcAddToServer |
rmrcRemoveFromServer |
SendMessage |
Links
TnxMessageRelayRegisteredClient Class, Legend, Protected Methods


TnxMessageRelayRegisteredClient.GetClientList Method

TnxMessageRelayRegisteredClient.GetClientList Method
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
function GetClientList: InxMessageRelayClientList;
Group

TnxMessageRelayRegisteredClient Methods

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Methods


TnxMessageRelayRegisteredClient.OwnID Method

TnxMessageRelayRegisteredClient.OwnID Method
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
function OwnID: TnxGuid;
Description

InxMessageRelayRegisteredClient

Group

TnxMessageRelayRegisteredClient Methods

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Methods


TnxMessageRelayRegisteredClient.rmrcAddToServer Method

TnxMessageRelayRegisteredClient.rmrcAddToServer Method
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
procedure rmrcAddToServer;
Group

TnxMessageRelayRegisteredClient Methods

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Methods


TnxMessageRelayRegisteredClient.rmrcRemoveFromServer Method

TnxMessageRelayRegisteredClient.rmrcRemoveFromServer Method
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
procedure rmrcRemoveFromServer;
Group

TnxMessageRelayRegisteredClient Methods

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Methods


TnxMessageRelayRegisteredClient.SendMessage Method

TnxMessageRelayRegisteredClient.SendMessage Method
TnxMessageRelayRegisteredClient Class TnxMessageRelayRegisteredClient Members nxmrServer Namespace TnxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
procedure SendMessage(const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Group

TnxMessageRelayRegisteredClient Methods

Links
TnxMessageRelayRegisteredClient Class, TnxMessageRelayRegisteredClient Members, nxmrServer Namespace, TnxMessageRelayRegisteredClient Methods


TnxMessageRelayServer Class

TnxMessageRelayServer Class
TnxMessageRelayServer Fields TnxMessageRelayServer Methods TnxMessageRelayServer Members nxmrServer Classes Send Feedback
Class Hierarchy
nxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServernxmrServer_TnxMessageRelayServer
Syntax
Delphi
TnxMessageRelayServer = class(TnxClass, InxMessageRelayServer);
File

nxmrServer

Description

This is class nxmrServer.TnxMessageRelayServer.

Group

Classes

Links
TnxMessageRelayServer Fields, TnxMessageRelayServer Methods, TnxMessageRelayServer Members, nxmrServer, Classes


TnxMessageRelayServer Members

TnxMessageRelayServer Members
TnxMessageRelayServer Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMessageRelayServer.

Class

TnxMessageRelayServer Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
mrsClientsHead | This is mrsClientsHead, a member of class TnxMessageRelayServer.
mrsClientsPortal | private
mrsClientsTail | This is mrsClientsTail, a member of class TnxMessageRelayServer.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
CreateInstance |
GetClassID | InxClass
GetClientList |
InternalAddRef |
InternalQueryInterface |
InternalRelease |
InternalRelease | InxInterface methods ONLY for InxInterface
ioDeactivate |
QueryInterface |
QueryInterface |
RegisterClient | InxMessageRelayServer
SendMessage |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create |
Create | TnxClass
Destroy | TnxMessageRelayServer
Free |
FreeInstance |
GetClassID | This is GetClassID, a member of class InxClass.
Initialize |
NewInstance |
NewInstance | TnxObject
SafeCallException |
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxMessageRelayServer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMessageRelayServer.Destroy Destructor

TnxMessageRelayServer.Destroy Destructor
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

TnxMessageRelayServer

Class

TnxMessageRelayServer Class

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Class


TnxMessageRelayServer Fields

TnxMessageRelayServer Fields
TnxMessageRelayServer Class Legend Protected Fields Send Feedback

The fields of the TnxMessageRelayServer class are listed here.

Class

TnxMessageRelayServer Class

Protected Fields
Name | Description
mrsClientsHead | This is mrsClientsHead, a member of class TnxMessageRelayServer.
mrsClientsPortal | private
mrsClientsTail | This is mrsClientsTail, a member of class TnxMessageRelayServer.
Links
TnxMessageRelayServer Class, Legend, Protected Fields


TnxMessageRelayServer.mrsClientsHead Field

TnxMessageRelayServer.mrsClientsHead Field
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Fields Send Feedback
Syntax
Delphi
mrsClientsHead: TnxMessageRelayRegisteredClient;
Description

This is mrsClientsHead, a member of class TnxMessageRelayServer.

Group

TnxMessageRelayServer Fields

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Fields


TnxMessageRelayServer.mrsClientsPortal Field

TnxMessageRelayServer.mrsClientsPortal Field
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Fields Send Feedback
Syntax
Delphi
mrsClientsPortal: TnxReadWritePortal;
Description

private

Group

TnxMessageRelayServer Fields

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Fields


TnxMessageRelayServer.mrsClientsTail Field

TnxMessageRelayServer.mrsClientsTail Field
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Fields Send Feedback
Syntax
Delphi
mrsClientsTail: TnxMessageRelayRegisteredClient;
Description

This is mrsClientsTail, a member of class TnxMessageRelayServer.

Group

TnxMessageRelayServer Fields

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Fields


TnxMessageRelayServer Methods

TnxMessageRelayServer Methods
TnxMessageRelayServer Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMessageRelayServer class are listed here.

Class

TnxMessageRelayServer Class

Protected Methods
Name | Description
GetClientList |
RegisterClient | InxMessageRelayServer
SendMessage |
Public Methods
Name | Description
Initialize |
Links
TnxMessageRelayServer Class, Legend, Protected Methods, Public Methods


TnxMessageRelayServer.GetClientList Method

TnxMessageRelayServer.GetClientList Method
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Methods Send Feedback
Syntax
Delphi
function GetClientList(aExclude: TnxMessageRelayRegisteredClient): InxMessageRelayClientList;
Group

TnxMessageRelayServer Methods

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Methods


TnxMessageRelayServer.Initialize Method

TnxMessageRelayServer.Initialize Method
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Methods Send Feedback
Syntax
Delphi
procedure Initialize; override;
Group

TnxMessageRelayServer Methods

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Methods


TnxMessageRelayServer.RegisterClient Method

TnxMessageRelayServer.RegisterClient Method
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Methods Send Feedback
Syntax
Delphi
function RegisterClient(aClient: InxMessageRelayClient; const aDescription: string; aPromiscuous: Boolean): InxMessageRelayRegisteredClient;
Description

InxMessageRelayServer

Group

TnxMessageRelayServer Methods

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Methods


TnxMessageRelayServer.SendMessage Method

TnxMessageRelayServer.SendMessage Method
TnxMessageRelayServer Class TnxMessageRelayServer Members nxmrServer Namespace TnxMessageRelayServer Methods Send Feedback
Syntax
Delphi
procedure SendMessage(const aFrom: TnxGuid; const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Group

TnxMessageRelayServer Methods

Links
TnxMessageRelayServer Class, TnxMessageRelayServer Members, nxmrServer Namespace, TnxMessageRelayServer Methods


TnxServerMessageRelayClientList Class

TnxServerMessageRelayClientList Class
TnxServerMessageRelayClientList Methods TnxServerMessageRelayClientList Members nxmrServer Classes Send Feedback
Class Hierarchy
nxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientListnxmrServer_TnxServerMessageRelayClientList
Syntax
Delphi
TnxServerMessageRelayClientList = class(TnxMessageRelayClientList);
File

nxmrServer

Description

This is class nxmrServer.TnxServerMessageRelayClientList.

Group

Classes

Links
TnxServerMessageRelayClientList Methods, TnxServerMessageRelayClientList Members, nxmrServer, Classes


TnxServerMessageRelayClientList Members

TnxServerMessageRelayClientList Members
TnxServerMessageRelayClientList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerMessageRelayClientList.

Class

TnxServerMessageRelayClientList Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
mrclInfos | private
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
CreateInstance |
GetClassID | InxClass
GetClientCount | InxMessageRelayClientList TnxMessageRelayClientList
GetClientDescription |
GetClientID |
GetClientPromiscuous |
InitFrom |
InternalAddRef |
InternalQueryInterface |
InternalRelease |
InternalRelease | InxInterface methods ONLY for InxInterface
ioDeactivate |
LoadFromReader |
QueryInterface |
QueryInterface |
SaveToWriter | InxRemotableClass
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Destroy |
Free |
FreeInstance |
GetClassID | This is GetClassID, a member of class InxClass.
GetClientCount | This is GetClientCount, a member of class InxMessageRelayClientList.
GetClientDescription | This is GetClientDescription, a member of class InxMessageRelayClientList.
GetClientID | This is GetClientID, a member of class InxMessageRelayClientList.
GetClientPromiscuous | This is GetClientPromiscuous, a member of class InxMessageRelayClientList.
Initialize |
LoadFromReader | This is LoadFromReader, a member of class InxRemoteableClass.
NewInstance |
NewInstance | TnxObject
SafeCallException |
SaveToWriter | This is SaveToWriter, a member of class InxRemoteableClass.
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
ClientCount | This is ClientCount, a member of class InxMessageRelayClientList.
ClientDescription | This is ClientDescription, a member of class InxMessageRelayClientList.
ClientID | This is ClientID, a member of class InxMessageRelayClientList.
ClientPromiscuous | This is ClientPromiscuous, a member of class InxMessageRelayClientList.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxServerMessageRelayClientList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxServerMessageRelayClientList.Create Constructor

TnxServerMessageRelayClientList.Create Constructor
TnxServerMessageRelayClientList Class TnxServerMessageRelayClientList Members nxmrServer Namespace TnxServerMessageRelayClientList Class Send Feedback
Syntax
Delphi
constructor Create(aServer: TnxMessageRelayServer; aExclude: TnxMessageRelayRegisteredClient); reintroduce;
Class

TnxServerMessageRelayClientList Class

Links
TnxServerMessageRelayClientList Class, TnxServerMessageRelayClientList Members, nxmrServer Namespace, TnxServerMessageRelayClientList Class


TnxServerMessageRelayClientList Methods

TnxServerMessageRelayClientList Methods
TnxServerMessageRelayClientList Class Legend Protected Methods Send Feedback

The methods of the TnxServerMessageRelayClientList class are listed here.

Class

TnxServerMessageRelayClientList Class

Protected Methods
Name | Description
InitFrom |
Links
TnxServerMessageRelayClientList Class, Legend, Protected Methods


TnxServerMessageRelayClientList.InitFrom Method

TnxServerMessageRelayClientList.InitFrom Method
TnxServerMessageRelayClientList Class TnxServerMessageRelayClientList Members nxmrServer Namespace TnxServerMessageRelayClientList Methods Send Feedback
Syntax
Delphi
procedure InitFrom(aServer: TnxMessageRelayServer; aExclude: TnxMessageRelayRegisteredClient);
Group

TnxServerMessageRelayClientList Methods

Links
TnxServerMessageRelayClientList Class, TnxServerMessageRelayClientList Members, nxmrServer Namespace, TnxServerMessageRelayClientList Methods


Variables

Variables
nxmrServer Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmrServer Namespace

Variables
Name | Description
_MessageRelayServerControl | Init/Done
Links
nxmrServer Namespace, Variables


nxmrServer._MessageRelayServerControl Variable

nxmrServer._MessageRelayServerControl Variable
nxmrServer Variables Send Feedback
Syntax
Delphi
_MessageRelayServerControl: InxClassFactoryControl;
File

nxmrServer

Description

Init/Done

Group

Variables

Links
nxmrServer, Variables


nxmrTypes Namespace

nxmrTypes Namespace
Classes Constants Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxmrTypes.

Classes
Name | Description
TnxMessageRelayClientList | This is class nxmrTypes.TnxMessageRelayClientList.
Constants
Name | Description
CLASS_MessageRelayClientList | This is constant nxmrTypes.CLASS_MessageRelayClientList.
CLASS_MessageRelayRegisteredClient | This is constant nxmrTypes.CLASS_MessageRelayRegisteredClient.
CLASS_MessageRelayServer | This is constant nxmrTypes.CLASS_MessageRelayServer.
nxMsgIDNone | This is constant nxmrTypes.nxMsgIDNone.
nxMsgTargetAll | This is constant nxmrTypes.nxMsgTargetAll.
Interfaces
Name | Description
InxMessageRelayClient | This is class nxmrTypes.InxMessageRelayClient.
InxMessageRelayClientList | This is class nxmrTypes.InxMessageRelayClientList.
InxMessageRelayRegisteredClient | This is class nxmrTypes.InxMessageRelayRegisteredClient.
InxMessageRelayServer | This is class nxmrTypes.InxMessageRelayServer.
Structs, Records, Enums
Name | Description
TnxMessageRelayClientInfo | This is record nxmrTypes.TnxMessageRelayClientInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxMessageRelayClientInfos | This is type nxmrTypes.TnxMessageRelayClientInfos.
Variables
Name | Description
_MessageRelayClientListControl | Init/Done
Links
Classes, Constants, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxmrTypes Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMessageRelayClientList | This is class nxmrTypes.TnxMessageRelayClientList.
Namespace

nxmrTypes Namespace

Links
Classes, nxmrTypes Namespace, Legend


TnxMessageRelayClientList Class

TnxMessageRelayClientList Class
TnxMessageRelayClientList Fields TnxMessageRelayClientList Methods TnxMessageRelayClientList Members nxmrTypes Classes Send Feedback
Class Hierarchy
nxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientListnxmrTypes_TnxMessageRelayClientList
Syntax
Delphi
TnxMessageRelayClientList = class(TnxClass, InxRemoteableClass, InxMessageRelayClientList);
File

nxmrTypes

Description

This is class nxmrTypes.TnxMessageRelayClientList.

Group

Classes

Links
TnxMessageRelayClientList Fields, TnxMessageRelayClientList Methods, TnxMessageRelayClientList Members, nxmrTypes, Classes


TnxMessageRelayClientList Members

TnxMessageRelayClientList Members
TnxMessageRelayClientList Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMessageRelayClientList.

Class

TnxMessageRelayClientList Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
mrclInfos | private
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
CreateInstance |
GetClassID | InxClass
GetClientCount | InxMessageRelayClientList TnxMessageRelayClientList
GetClientDescription |
GetClientID |
GetClientPromiscuous |
InternalAddRef |
InternalQueryInterface |
InternalRelease |
InternalRelease | InxInterface methods ONLY for InxInterface
ioDeactivate |
LoadFromReader |
QueryInterface |
QueryInterface |
SaveToWriter | InxRemotableClass
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create |
Create | TnxClass
Destroy |
Free |
FreeInstance |
GetClassID | This is GetClassID, a member of class InxClass.
Initialize |
NewInstance |
NewInstance | TnxObject
SafeCallException |
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
ClientCount | This is ClientCount, a member of class InxMessageRelayClientList.
ClientDescription | This is ClientDescription, a member of class InxMessageRelayClientList.
ClientID | This is ClientID, a member of class InxMessageRelayClientList.
ClientPromiscuous | This is ClientPromiscuous, a member of class InxMessageRelayClientList.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxMessageRelayClientList Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMessageRelayClientList Fields

TnxMessageRelayClientList Fields
TnxMessageRelayClientList Class Legend Protected Fields Send Feedback

The fields of the TnxMessageRelayClientList class are listed here.

Class

TnxMessageRelayClientList Class

Protected Fields
Name | Description
mrclInfos | private
Links
TnxMessageRelayClientList Class, Legend, Protected Fields


TnxMessageRelayClientList.mrclInfos Field

TnxMessageRelayClientList.mrclInfos Field
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Fields Send Feedback
Syntax
Delphi
mrclInfos: TnxMessageRelayClientInfos;
Description

private

Group

TnxMessageRelayClientList Fields

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Fields


TnxMessageRelayClientList Methods

TnxMessageRelayClientList Methods
TnxMessageRelayClientList Class Legend Protected Methods Send Feedback

The methods of the TnxMessageRelayClientList class are listed here.

Class

TnxMessageRelayClientList Class

Protected Methods
Name | Description
GetClientCount | InxMessageRelayClientList TnxMessageRelayClientList
GetClientDescription |
GetClientID |
GetClientPromiscuous |
LoadFromReader |
SaveToWriter | InxRemotableClass
Links
TnxMessageRelayClientList Class, Legend, Protected Methods


TnxMessageRelayClientList.GetClientCount Method

TnxMessageRelayClientList.GetClientCount Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientCount: Integer;
Description

InxMessageRelayClientList

TnxMessageRelayClientList

Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


TnxMessageRelayClientList.GetClientDescription Method

TnxMessageRelayClientList.GetClientDescription Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientDescription(aIndex: Integer): string;
Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


TnxMessageRelayClientList.GetClientID Method

TnxMessageRelayClientList.GetClientID Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientID(aIndex: Integer): TnxGuid;
Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


TnxMessageRelayClientList.GetClientPromiscuous Method

TnxMessageRelayClientList.GetClientPromiscuous Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientPromiscuous(aIndex: Integer): Boolean;
Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


TnxMessageRelayClientList.LoadFromReader Method

TnxMessageRelayClientList.LoadFromReader Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function LoadFromReader(aReader: InxReader): HRESULT;
Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


TnxMessageRelayClientList.SaveToWriter Method

TnxMessageRelayClientList.SaveToWriter Method
TnxMessageRelayClientList Class TnxMessageRelayClientList Members nxmrTypes Namespace TnxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function SaveToWriter(aWriter: InxWriter): HRESULT;
Description

InxRemotableClass

Group

TnxMessageRelayClientList Methods

Links
TnxMessageRelayClientList Class, TnxMessageRelayClientList Members, nxmrTypes Namespace, TnxMessageRelayClientList Methods


Interfaces

Interfaces
nxmrTypes Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxmrTypes Namespace

Interfaces
Name | Description
InxMessageRelayClient | This is class nxmrTypes.InxMessageRelayClient.
InxMessageRelayClientList | This is class nxmrTypes.InxMessageRelayClientList.
InxMessageRelayRegisteredClient | This is class nxmrTypes.InxMessageRelayRegisteredClient.
InxMessageRelayServer | This is class nxmrTypes.InxMessageRelayServer.
Links
nxmrTypes Namespace, Interfaces, Legend


InxMessageRelayClient Interface

InxMessageRelayClient Interface
InxMessageRelayClient Methods InxMessageRelayClient Members nxmrTypes Interfaces Send Feedback
Class Hierarchy
nxmrTypes_InxMessageRelayClient
Syntax
Delphi
InxMessageRelayClient = interface(InxInvokable);
File

nxmrTypes

Description

This is class nxmrTypes.InxMessageRelayClient.

Group

Interfaces

Links
InxMessageRelayClient Methods, InxMessageRelayClient Members, nxmrTypes, Interfaces


InxMessageRelayClient Members

InxMessageRelayClient Members
InxMessageRelayClient Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxMessageRelayClient.

Interface

InxMessageRelayClient Interface

Public Methods
Name | Description
ReceivedMessage | This is ReceivedMessage, a member of class InxMessageRelayClient.
Links
InxMessageRelayClient Interface, Legend, Public Methods


InxMessageRelayClient Methods

InxMessageRelayClient Methods
InxMessageRelayClient Interface Legend Public Methods Send Feedback

The methods of the InxMessageRelayClient class are listed here.

Interface

InxMessageRelayClient Interface

Public Methods
Name | Description
ReceivedMessage | This is ReceivedMessage, a member of class InxMessageRelayClient.
Links
InxMessageRelayClient Interface, Legend, Public Methods


InxMessageRelayClient.ReceivedMessage Method

InxMessageRelayClient.ReceivedMessage Method
InxMessageRelayClient Interface InxMessageRelayClient Members nxmrTypes Namespace InxMessageRelayClient Methods Send Feedback
Syntax
Delphi
procedure ReceivedMessage(const aFrom: TnxGuid; const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Description

This is ReceivedMessage, a member of class InxMessageRelayClient.

Group

InxMessageRelayClient Methods

Links
InxMessageRelayClient Interface, InxMessageRelayClient Members, nxmrTypes Namespace, InxMessageRelayClient Methods


InxMessageRelayClientList Interface

InxMessageRelayClientList Interface
InxMessageRelayClientList Methods InxMessageRelayClientList Properties InxMessageRelayClientList Members nxmrTypes Interfaces Send Feedback
Class Hierarchy
nxmrTypes_InxMessageRelayClientList
Syntax
Delphi
InxMessageRelayClientList = interface(InxInvokable);
File

nxmrTypes

Description

This is class nxmrTypes.InxMessageRelayClientList.

Group

Interfaces

Links
InxMessageRelayClientList Methods, InxMessageRelayClientList Properties, InxMessageRelayClientList Members, nxmrTypes, Interfaces


InxMessageRelayClientList Members

InxMessageRelayClientList Members
InxMessageRelayClientList Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxMessageRelayClientList.

Interface

InxMessageRelayClientList Interface

Public Methods
Name | Description
GetClientCount | This is GetClientCount, a member of class InxMessageRelayClientList.
GetClientDescription | This is GetClientDescription, a member of class InxMessageRelayClientList.
GetClientID | This is GetClientID, a member of class InxMessageRelayClientList.
GetClientPromiscuous | This is GetClientPromiscuous, a member of class InxMessageRelayClientList.
Public Properties
Name | Description
ClientCount | This is ClientCount, a member of class InxMessageRelayClientList.
ClientDescription | This is ClientDescription, a member of class InxMessageRelayClientList.
ClientID | This is ClientID, a member of class InxMessageRelayClientList.
ClientPromiscuous | This is ClientPromiscuous, a member of class InxMessageRelayClientList.
Links
InxMessageRelayClientList Interface, Legend, Public Methods, Public Properties


InxMessageRelayClientList Methods

InxMessageRelayClientList Methods
InxMessageRelayClientList Interface Legend Public Methods Send Feedback

The methods of the InxMessageRelayClientList class are listed here.

Interface

InxMessageRelayClientList Interface

Public Methods
Name | Description
GetClientCount | This is GetClientCount, a member of class InxMessageRelayClientList.
GetClientDescription | This is GetClientDescription, a member of class InxMessageRelayClientList.
GetClientID | This is GetClientID, a member of class InxMessageRelayClientList.
GetClientPromiscuous | This is GetClientPromiscuous, a member of class InxMessageRelayClientList.
Links
InxMessageRelayClientList Interface, Legend, Public Methods


InxMessageRelayClientList.GetClientCount Method

InxMessageRelayClientList.GetClientCount Method
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientCount: Integer;
Description

This is GetClientCount, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Methods

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Methods


InxMessageRelayClientList.GetClientDescription Method

InxMessageRelayClientList.GetClientDescription Method
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientDescription(aIndex: Integer): string;
Description

This is GetClientDescription, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Methods

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Methods


InxMessageRelayClientList.GetClientID Method

InxMessageRelayClientList.GetClientID Method
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientID(aIndex: Integer): TnxGuid;
Description

This is GetClientID, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Methods

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Methods


InxMessageRelayClientList.GetClientPromiscuous Method

InxMessageRelayClientList.GetClientPromiscuous Method
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Methods Send Feedback
Syntax
Delphi
function GetClientPromiscuous(aIndex: Integer): Boolean;
Description

This is GetClientPromiscuous, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Methods

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Methods


InxMessageRelayClientList Properties

InxMessageRelayClientList Properties
InxMessageRelayClientList Interface Legend Public Properties Send Feedback

The properties of the InxMessageRelayClientList class are listed here.

Interface

InxMessageRelayClientList Interface

Public Properties
Name | Description
ClientCount | This is ClientCount, a member of class InxMessageRelayClientList.
ClientDescription | This is ClientDescription, a member of class InxMessageRelayClientList.
ClientID | This is ClientID, a member of class InxMessageRelayClientList.
ClientPromiscuous | This is ClientPromiscuous, a member of class InxMessageRelayClientList.
Links
InxMessageRelayClientList Interface, Legend, Public Properties


InxMessageRelayClientList.ClientCount Property

InxMessageRelayClientList.ClientCount Property
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Properties Send Feedback
Syntax
Delphi
property ClientCount: Integer;
Description

This is ClientCount, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Properties

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Properties


InxMessageRelayClientList.ClientDescription Property

InxMessageRelayClientList.ClientDescription Property
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Properties Send Feedback
Syntax
Delphi
property ClientDescription [aIndex: Integer]: string;
Description

This is ClientDescription, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Properties

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Properties


InxMessageRelayClientList.ClientID Property

InxMessageRelayClientList.ClientID Property
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Properties Send Feedback
Syntax
Delphi
property ClientID [aIndex: Integer]: TnxGuid;
Description

This is ClientID, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Properties

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Properties


InxMessageRelayClientList.ClientPromiscuous Property

InxMessageRelayClientList.ClientPromiscuous Property
InxMessageRelayClientList Interface InxMessageRelayClientList Members nxmrTypes Namespace InxMessageRelayClientList Properties Send Feedback
Syntax
Delphi
property ClientPromiscuous [aIndex: Integer]: Boolean;
Description

This is ClientPromiscuous, a member of class InxMessageRelayClientList.

Group

InxMessageRelayClientList Properties

Links
InxMessageRelayClientList Interface, InxMessageRelayClientList Members, nxmrTypes Namespace, InxMessageRelayClientList Properties


InxMessageRelayRegisteredClient Interface

InxMessageRelayRegisteredClient Interface
InxMessageRelayRegisteredClient Methods InxMessageRelayRegisteredClient Members nxmrTypes Interfaces Send Feedback
Class Hierarchy
nxmrTypes_InxMessageRelayRegisteredClient
Syntax
Delphi
InxMessageRelayRegisteredClient = interface(InxInvokable);
File

nxmrTypes

Description

This is class nxmrTypes.InxMessageRelayRegisteredClient.

Group

Interfaces

Links
InxMessageRelayRegisteredClient Methods, InxMessageRelayRegisteredClient Members, nxmrTypes, Interfaces


InxMessageRelayRegisteredClient Members

InxMessageRelayRegisteredClient Members
InxMessageRelayRegisteredClient Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxMessageRelayRegisteredClient.

Interface

InxMessageRelayRegisteredClient Interface

Public Methods
Name | Description
GetClientList | This is GetClientList, a member of class InxMessageRelayRegisteredClient.
OwnID | This is OwnID, a member of class InxMessageRelayRegisteredClient.
SendMessage | This is SendMessage, a member of class InxMessageRelayRegisteredClient.
Links
InxMessageRelayRegisteredClient Interface, Legend, Public Methods


InxMessageRelayRegisteredClient Methods

InxMessageRelayRegisteredClient Methods
InxMessageRelayRegisteredClient Interface Legend Public Methods Send Feedback

The methods of the InxMessageRelayRegisteredClient class are listed here.

Interface

InxMessageRelayRegisteredClient Interface

Public Methods
Name | Description
GetClientList | This is GetClientList, a member of class InxMessageRelayRegisteredClient.
OwnID | This is OwnID, a member of class InxMessageRelayRegisteredClient.
SendMessage | This is SendMessage, a member of class InxMessageRelayRegisteredClient.
Links
InxMessageRelayRegisteredClient Interface, Legend, Public Methods


InxMessageRelayRegisteredClient.GetClientList Method

InxMessageRelayRegisteredClient.GetClientList Method
InxMessageRelayRegisteredClient Interface InxMessageRelayRegisteredClient Members nxmrTypes Namespace InxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
function GetClientList: InxMessageRelayClientList;
Description

This is GetClientList, a member of class InxMessageRelayRegisteredClient.

Group

InxMessageRelayRegisteredClient Methods

Links
InxMessageRelayRegisteredClient Interface, InxMessageRelayRegisteredClient Members, nxmrTypes Namespace, InxMessageRelayRegisteredClient Methods


InxMessageRelayRegisteredClient.OwnID Method

InxMessageRelayRegisteredClient.OwnID Method
InxMessageRelayRegisteredClient Interface InxMessageRelayRegisteredClient Members nxmrTypes Namespace InxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
function OwnID: TnxGuid;
Description

This is OwnID, a member of class InxMessageRelayRegisteredClient.

Group

InxMessageRelayRegisteredClient Methods

Links
InxMessageRelayRegisteredClient Interface, InxMessageRelayRegisteredClient Members, nxmrTypes Namespace, InxMessageRelayRegisteredClient Methods


InxMessageRelayRegisteredClient.SendMessage Method

InxMessageRelayRegisteredClient.SendMessage Method
InxMessageRelayRegisteredClient Interface InxMessageRelayRegisteredClient Members nxmrTypes Namespace InxMessageRelayRegisteredClient Methods Send Feedback
Syntax
Delphi
procedure SendMessage(const aTo: TnxGuid; const aMsgID: TnxGuid; const aMsg: string; const aData: TnxBytes; const aIntf: InxInterface);
Description

This is SendMessage, a member of class InxMessageRelayRegisteredClient.

Group

InxMessageRelayRegisteredClient Methods

Links
InxMessageRelayRegisteredClient Interface, InxMessageRelayRegisteredClient Members, nxmrTypes Namespace, InxMessageRelayRegisteredClient Methods


InxMessageRelayServer Interface

InxMessageRelayServer Interface
InxMessageRelayServer Methods InxMessageRelayServer Members nxmrTypes Interfaces Send Feedback
Class Hierarchy
nxmrTypes_InxMessageRelayServer
Syntax
Delphi
InxMessageRelayServer = interface(InxInvokable);
File

nxmrTypes

Description

This is class nxmrTypes.InxMessageRelayServer.

Group

Interfaces

Links
InxMessageRelayServer Methods, InxMessageRelayServer Members, nxmrTypes, Interfaces


InxMessageRelayServer Members

InxMessageRelayServer Members
InxMessageRelayServer Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxMessageRelayServer.

Interface

InxMessageRelayServer Interface

Public Methods
Name | Description
RegisterClient | This is RegisterClient, a member of class InxMessageRelayServer.
Links
InxMessageRelayServer Interface, Legend, Public Methods


InxMessageRelayServer Methods

InxMessageRelayServer Methods
InxMessageRelayServer Interface Legend Public Methods Send Feedback

The methods of the InxMessageRelayServer class are listed here.

Interface

InxMessageRelayServer Interface

Public Methods
Name | Description
RegisterClient | This is RegisterClient, a member of class InxMessageRelayServer.
Links
InxMessageRelayServer Interface, Legend, Public Methods


InxMessageRelayServer.RegisterClient Method

InxMessageRelayServer.RegisterClient Method
InxMessageRelayServer Interface InxMessageRelayServer Members nxmrTypes Namespace InxMessageRelayServer Methods Send Feedback
Syntax
Delphi
function RegisterClient(aClient: InxMessageRelayClient; const aDescription: string; aPromiscuous: Boolean): InxMessageRelayRegisteredClient;
Description

This is RegisterClient, a member of class InxMessageRelayServer.

Group

InxMessageRelayServer Methods

Links
InxMessageRelayServer Interface, InxMessageRelayServer Members, nxmrTypes Namespace, InxMessageRelayServer Methods


Structs, Records, Enums

Structs, Records, Enums
nxmrTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxmrTypes Namespace

Records
Name | Description
TnxMessageRelayClientInfo | This is record nxmrTypes.TnxMessageRelayClientInfo.
Links
nxmrTypes Namespace, Legend, Records


nxmrTypes.TnxMessageRelayClientInfo Record

nxmrTypes.TnxMessageRelayClientInfo Record
nxmrTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxMessageRelayClientInfo = record
  mrciID: TnxGuid;
  mrciDescription: string;
  mrciPromiscuous: Boolean;
end;
File

nxmrTypes

Description

This is record nxmrTypes.TnxMessageRelayClientInfo.

Group

Structs, Records, Enums

Links
nxmrTypes, Structs, Records, Enums


Types

Types
nxmrTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxmrTypes Namespace

Types
Name | Description
TnxMessageRelayClientInfos | This is type nxmrTypes.TnxMessageRelayClientInfos.
Links
nxmrTypes Namespace, Types


nxmrTypes.TnxMessageRelayClientInfos Type

nxmrTypes.TnxMessageRelayClientInfos Type
nxmrTypes Types Send Feedback
Syntax
Delphi
TnxMessageRelayClientInfos = array of TnxMessageRelayClientInfo;
File

nxmrTypes

Description

This is type nxmrTypes.TnxMessageRelayClientInfos.

Group

Types

Links
nxmrTypes, Types


Variables

Variables
nxmrTypes Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxmrTypes Namespace

Variables
Name | Description
_MessageRelayClientListControl | Init/Done
Links
nxmrTypes Namespace, Variables


nxmrTypes._MessageRelayClientListControl Variable

nxmrTypes._MessageRelayClientListControl Variable
nxmrTypes Variables Send Feedback
Syntax
Delphi
_MessageRelayClientListControl: InxClassFactoryControl;
File

nxmrTypes

Description

Init/Done

Group

Variables

Links
nxmrTypes, Variables


Constants

Constants
Constants nxmrTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
CLASS_MessageRelayClientList | This is constant nxmrTypes.CLASS_MessageRelayClientList.
CLASS_MessageRelayRegisteredClient | This is constant nxmrTypes.CLASS_MessageRelayRegisteredClient.
CLASS_MessageRelayServer | This is constant nxmrTypes.CLASS_MessageRelayServer.
nxMsgIDNone | This is constant nxmrTypes.nxMsgIDNone.
nxMsgTargetAll | This is constant nxmrTypes.nxMsgTargetAll.
Namespace

nxmrTypes Namespace

Links
Constants, nxmrTypes Namespace


nxmrTypes.CLASS_MessageRelayClientList Constant

nxmrTypes.CLASS_MessageRelayClientList Constant
nxmrTypes Constants Send Feedback
Syntax
Delphi
CLASS_MessageRelayClientList: TnxGuid = '{5907D7E5-BA1F-47F0-8FC0-B346BEAA8979}';
File

nxmrTypes

Description

This is constant nxmrTypes.CLASS_MessageRelayClientList.

Group

Constants

Links
nxmrTypes, Constants


nxmrTypes.CLASS_MessageRelayRegisteredClient Constant

nxmrTypes.CLASS_MessageRelayRegisteredClient Constant
nxmrTypes Constants Send Feedback
Syntax
Delphi
CLASS_MessageRelayRegisteredClient: TnxGuid = '{0561734D-D096-4A95-A6F0-C629F2476F31}';
File

nxmrTypes

Description

This is constant nxmrTypes.CLASS_MessageRelayRegisteredClient.

Group

Constants

Links
nxmrTypes, Constants


nxmrTypes.CLASS_MessageRelayServer Constant

nxmrTypes.CLASS_MessageRelayServer Constant
nxmrTypes Constants Send Feedback
Syntax
Delphi
CLASS_MessageRelayServer: TnxGuid = '{DA7B0DE5-FB26-4EFE-869D-A84980C976BF}';
File

nxmrTypes

Description

This is constant nxmrTypes.CLASS_MessageRelayServer.

Group

Constants

Links
nxmrTypes, Constants


nxmrTypes.nxMsgIDNone Constant

nxmrTypes.nxMsgIDNone Constant
nxmrTypes Constants Send Feedback
Syntax
Delphi
nxMsgIDNone: TnxGuid = '{00000000-0000-0000-0000-000000000000}';
File

nxmrTypes

Description

This is constant nxmrTypes.nxMsgIDNone.

Group

Constants

Links
nxmrTypes, Constants


nxmrTypes.nxMsgTargetAll Constant

nxmrTypes.nxMsgTargetAll Constant
nxmrTypes Constants Send Feedback
Syntax
Delphi
nxMsgTargetAll: TnxGuid = '{FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF}';
File

nxmrTypes

Description

This is constant nxmrTypes.nxMsgTargetAll.

Group

Constants

Links
nxmrTypes, Constants


nxNetHost Namespace

nxNetHost Namespace
Constants Functions Legend Topics Variables Send Feedback

This is namespace nxNetHost.

Constants
Name | Description
msCoree | This is constant nxNetHost.msCoree.
STARTUP_CONCURRENT_GC | This is constant nxNetHost.STARTUP_CONCURRENT_GC.
STARTUP_LOADER_OPTIMIZATION_MASK | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MASK.
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN.
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST.
STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN.
STARTUP_LOADER_SAFEMODE | This is constant nxNetHost.STARTUP_LOADER_SAFEMODE.
STARTUP_LOADER_SETPREFERENCE | This is constant nxNetHost.STARTUP_LOADER_SETPREFERENCE.
Functions
Name | Description
CreateDomain | This is function nxNetHost.CreateDomain.
CreateInterface | This is function nxNetHost.CreateInterface.
CreateOleClass | This is function nxNetHost.CreateOleClass.
LoadAssembly | This is function nxNetHost.LoadAssembly.
NxDomain | defaultdomain
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
_CoreeLib | This is variable nxNetHost._CoreeLib.
_Domain | This is variable nxNetHost._Domain.
_Host | This is variable nxNetHost._Host.
_Lock | This is variable nxNetHost._Lock.
_RefCount | This is variable nxNetHost._RefCount.
CorBindToRuntimeEx | This is variable nxNetHost.CorBindToRuntimeEx.
CorExitProcess | This is variable nxNetHost.CorExitProcess.
Links
Constants, Functions, Legend, Topics, Variables


Functions

Functions
Functions nxNetHost Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
CreateDomain | This is function nxNetHost.CreateDomain.
CreateInterface | This is function nxNetHost.CreateInterface.
CreateOleClass | This is function nxNetHost.CreateOleClass.
LoadAssembly | This is function nxNetHost.LoadAssembly.
NxDomain | defaultdomain
Namespace

nxNetHost Namespace

Links
Functions, nxNetHost Namespace, Legend


nxNetHost.CreateDomain Function

nxNetHost.CreateDomain Function
nxNetHost Functions Send Feedback
Syntax
Delphi
function CreateDomain(AppName: WideString; BaseDir: WideString; AppPath: WideString): _AppDomain;
File

nxNetHost

Description

This is function nxNetHost.CreateDomain.

Group

Functions

Links
nxNetHost, Functions


nxNetHost.CreateInterface Function

nxNetHost.CreateInterface Function
nxNetHost Functions Send Feedback
Syntax
Delphi
function CreateInterface(const anAssembly: IUnknown; const aClassName: String; const aInterface: TIID): IUnknown;
File

nxNetHost

Description

This is function nxNetHost.CreateInterface.

Group

Functions

Links
nxNetHost, Functions


nxNetHost.CreateOleClass Function

nxNetHost.CreateOleClass Function
nxNetHost Functions Send Feedback
Syntax
Delphi
function CreateOleClass(const anAssembly: IUnknown; const aClassName: String): OleVariant;
File

nxNetHost

Description

This is function nxNetHost.CreateOleClass.

Group

Functions

Links
nxNetHost, Functions


nxNetHost.LoadAssembly Function

nxNetHost.LoadAssembly Function
nxNetHost Functions Send Feedback
Syntax
Delphi
function LoadAssembly(const aDomain: _AppDomain; const aDllName: String; const aDirectory: String): _Assembly;
File

nxNetHost

Description

This is function nxNetHost.LoadAssembly.

Group

Functions

Links
nxNetHost, Functions


nxNetHost.NxDomain Function

nxNetHost.NxDomain Function
nxNetHost Functions Send Feedback
Syntax
Delphi
function NxDomain: _AppDomain;
File

nxNetHost

Description

defaultdomain

Group

Functions

Links
nxNetHost, Functions


Variables

Variables
nxNetHost Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxNetHost Namespace

Variables
Name | Description
_CoreeLib | This is variable nxNetHost._CoreeLib.
_Domain | This is variable nxNetHost._Domain.
_Host | This is variable nxNetHost._Host.
_Lock | This is variable nxNetHost._Lock.
_RefCount | This is variable nxNetHost._RefCount.
CorBindToRuntimeEx | This is variable nxNetHost.CorBindToRuntimeEx.
CorExitProcess | This is variable nxNetHost.CorExitProcess.
Links
nxNetHost Namespace, Variables


nxNetHost._CoreeLib Variable

nxNetHost._CoreeLib Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
_CoreeLib: THandle = 0;
File

nxNetHost

Description

This is variable nxNetHost._CoreeLib.

Group

Variables

Links
nxNetHost, Variables


nxNetHost._Domain Variable

nxNetHost._Domain Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
_Domain: _AppDomain = nil;
File

nxNetHost

Description

This is variable nxNetHost._Domain.

Group

Variables

Links
nxNetHost, Variables


nxNetHost._Host Variable

nxNetHost._Host Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
_Host: ICorRuntimeHost = nil;
File

nxNetHost

Description

This is variable nxNetHost._Host.

Group

Variables

Links
nxNetHost, Variables


nxNetHost._Lock Variable

nxNetHost._Lock Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
_Lock: TCriticalSection = nil;
File

nxNetHost

Description

This is variable nxNetHost._Lock.

Group

Variables

Links
nxNetHost, Variables


nxNetHost._RefCount Variable

nxNetHost._RefCount Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
_RefCount: Integer = 0;
File

nxNetHost

Description

This is variable nxNetHost._RefCount.

Group

Variables

Links
nxNetHost, Variables


nxNetHost.CorBindToRuntimeEx Variable

nxNetHost.CorBindToRuntimeEx Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
CorBindToRuntimeEx: function ( pwszVersion : PWideChar; pwszBuildFlavor: PWideChar; flags: Cardinal; const rclsid: TGUID; const riid: TGUID; out ppv) : HRESULT;
File

nxNetHost

Description

This is variable nxNetHost.CorBindToRuntimeEx.

Group

Variables

Links
nxNetHost, Variables


nxNetHost.CorExitProcess Variable

nxNetHost.CorExitProcess Variable
nxNetHost Variables Send Feedback
Syntax
Delphi
CorExitProcess: procedure (exitCode: Integer);
File

nxNetHost

Description

This is variable nxNetHost.CorExitProcess.

Group

Variables

Links
nxNetHost, Variables


Constants

Constants
Constants nxNetHost Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
msCoree | This is constant nxNetHost.msCoree.
STARTUP_CONCURRENT_GC | This is constant nxNetHost.STARTUP_CONCURRENT_GC.
STARTUP_LOADER_OPTIMIZATION_MASK | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MASK.
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN.
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST.
STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN | This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN.
STARTUP_LOADER_SAFEMODE | This is constant nxNetHost.STARTUP_LOADER_SAFEMODE.
STARTUP_LOADER_SETPREFERENCE | This is constant nxNetHost.STARTUP_LOADER_SETPREFERENCE.
Namespace

nxNetHost Namespace

Links
Constants, nxNetHost Namespace


nxNetHost.msCoree Constant

nxNetHost.msCoree Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
msCoree = 'mscoree.dll';
File

nxNetHost

Description

This is constant nxNetHost.msCoree.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_CONCURRENT_GC Constant

nxNetHost.STARTUP_CONCURRENT_GC Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_CONCURRENT_GC = $0001;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_CONCURRENT_GC.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_OPTIMIZATION_MASK Constant

nxNetHost.STARTUP_LOADER_OPTIMIZATION_MASK Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_OPTIMIZATION_MASK = $0006;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MASK.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN Constant

nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN = $0004;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST Constant

nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST = $0006;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_MULTI_DOMAIN_HOST.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN Constant

nxNetHost.STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN = $0002;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_OPTIMIZATION_SINGLE_DOMAIN.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_SAFEMODE Constant

nxNetHost.STARTUP_LOADER_SAFEMODE Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_SAFEMODE = $0010;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_SAFEMODE.

Group

Constants

Links
nxNetHost, Constants


nxNetHost.STARTUP_LOADER_SETPREFERENCE Constant

nxNetHost.STARTUP_LOADER_SETPREFERENCE Constant
nxNetHost Constants Send Feedback
Syntax
Delphi
STARTUP_LOADER_SETPREFERENCE = $0100;
File

nxNetHost

Description

This is constant nxNetHost.STARTUP_LOADER_SETPREFERENCE.

Group

Constants

Links
nxNetHost, Constants


nxpsdDispatch Namespace

nxpsdDispatch Namespace
Classes Constants Legend Topics Variables Send Feedback

This is namespace nxpsdDispatch.

Classes
Name | Description
TnxDispatchInterfaceProxy | This is class nxpsdDispatch.TnxDispatchInterfaceProxy.
TnxDispatchInterfaceStub | This is class nxpsdDispatch.TnxDispatchInterfaceStub.
Constants
Name | Description
DefaultDispatchInterfaceProxyID | RegisterFactories
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
DispatchInterfaceProxyControl |
DispatchInterfaceStubControl | This is variable nxpsdDispatch.DispatchInterfaceStubControl.
Links
Classes, Constants, Legend, Topics, Variables


Classes

Classes
Classes nxpsdDispatch Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxDispatchInterfaceProxy | This is class nxpsdDispatch.TnxDispatchInterfaceProxy.
TnxDispatchInterfaceStub | This is class nxpsdDispatch.TnxDispatchInterfaceStub.
Namespace

nxpsdDispatch Namespace

Links
Classes, nxpsdDispatch Namespace, Legend


TnxDispatchInterfaceProxy Class

TnxDispatchInterfaceProxy Class
TnxDispatchInterfaceProxy Methods TnxDispatchInterfaceProxy Members nxpsdDispatch Classes Send Feedback
Class Hierarchy
nxpsdDispatch_TnxDispatchInterfaceProxynxpsdDispatch_TnxDispatchInterfaceProxynxpsdDispatch_TnxDispatchInterfaceProxynxpsdDispatch_TnxDispatchInterfaceProxynxpsdDispatch_TnxDispatchInterfaceProxy
Syntax
Delphi
TnxDispatchInterfaceProxy = class(TnxInterfaceProxy, IDispatch);
File

nxpsdDispatch

Description

This is class nxpsdDispatch.TnxDispatchInterfaceProxy.

Group

Classes

Links
TnxDispatchInterfaceProxy Methods, TnxDispatchInterfaceProxy Members, nxpsdDispatch, Classes


TnxDispatchInterfaceProxy Members

TnxDispatchInterfaceProxy Members
TnxDispatchInterfaceProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDispatchInterfaceProxy.

Class

TnxDispatchInterfaceProxy Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
pxClassID | private
pxClassProxy | This is pxClassProxy, a member of class TnxInterfaceProxy.
pxInterfaceID | This is pxInterfaceID, a member of class TnxInterfaceProxy.
pxStubID | This is pxStubID, a member of class TnxInterfaceProxy.
pxStubVersion | This is pxStubVersion, a member of class TnxInterfaceProxy.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_AddRef |
_ProxyAddRef |
_ProxyRelease |
_Release |
_Release |
CreateInterfaceProxy |
GetIDsOfNames | TnxDispatchInterfaceProxy
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
GetSharedVersion |
GetTypeInfo |
GetTypeInfoCount | IDispatch
GetWriter |
Invoke |
ioDeactivate |
Process |
ProxyQueryInterface | InxInterfaceProxy
pxQueryInterface |
QueryInterface |
QueryInterface | InxInterface
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create | TnxInterfaceProxy
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxDispatchInterfaceProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDispatchInterfaceProxy Methods

TnxDispatchInterfaceProxy Methods
TnxDispatchInterfaceProxy Class Legend Protected Methods Send Feedback

The methods of the TnxDispatchInterfaceProxy class are listed here.

Class

TnxDispatchInterfaceProxy Class

Protected Methods
Name | Description
GetIDsOfNames | TnxDispatchInterfaceProxy
GetTypeInfo |
GetTypeInfoCount | IDispatch
Invoke |
Links
TnxDispatchInterfaceProxy Class, Legend, Protected Methods


TnxDispatchInterfaceProxy.GetIDsOfNames Method

TnxDispatchInterfaceProxy.GetIDsOfNames Method
TnxDispatchInterfaceProxy Class TnxDispatchInterfaceProxy Members nxpsdDispatch Namespace TnxDispatchInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetIDsOfNames(const IID: TGUID; Names: Pointer; NameCount: Integer; LocaleID: Integer; DispIDs: Pointer): HResult; stdcall;
Description

TnxDispatchInterfaceProxy

Group

TnxDispatchInterfaceProxy Methods

Links
TnxDispatchInterfaceProxy Class, TnxDispatchInterfaceProxy Members, nxpsdDispatch Namespace, TnxDispatchInterfaceProxy Methods


TnxDispatchInterfaceProxy.GetTypeInfo Method

TnxDispatchInterfaceProxy.GetTypeInfo Method
TnxDispatchInterfaceProxy Class TnxDispatchInterfaceProxy Members nxpsdDispatch Namespace TnxDispatchInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetTypeInfo(Index: Integer; LocaleID: Integer; out TypeInfo): HResult; stdcall;
Group

TnxDispatchInterfaceProxy Methods

Links
TnxDispatchInterfaceProxy Class, TnxDispatchInterfaceProxy Members, nxpsdDispatch Namespace, TnxDispatchInterfaceProxy Methods


TnxDispatchInterfaceProxy.GetTypeInfoCount Method

TnxDispatchInterfaceProxy.GetTypeInfoCount Method
TnxDispatchInterfaceProxy Class TnxDispatchInterfaceProxy Members nxpsdDispatch Namespace TnxDispatchInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetTypeInfoCount(out Count: Integer): HResult; stdcall;
Description

IDispatch

Group

TnxDispatchInterfaceProxy Methods

Links
TnxDispatchInterfaceProxy Class, TnxDispatchInterfaceProxy Members, nxpsdDispatch Namespace, TnxDispatchInterfaceProxy Methods


TnxDispatchInterfaceProxy.Invoke Method

TnxDispatchInterfaceProxy.Invoke Method
TnxDispatchInterfaceProxy Class TnxDispatchInterfaceProxy Members nxpsdDispatch Namespace TnxDispatchInterfaceProxy Methods Send Feedback
Syntax
Delphi
function Invoke(DispID: Integer; const IID: TGUID; LocaleID: Integer; Flags: Word; var Params; VarResult: Pointer; ExcepInfo: Pointer; ArgErr: Pointer): HResult; stdcall;
Group

TnxDispatchInterfaceProxy Methods

Links
TnxDispatchInterfaceProxy Class, TnxDispatchInterfaceProxy Members, nxpsdDispatch Namespace, TnxDispatchInterfaceProxy Methods


TnxDispatchInterfaceStub Class

TnxDispatchInterfaceStub Class
TnxDispatchInterfaceStub Methods TnxDispatchInterfaceStub Members nxpsdDispatch Classes Send Feedback
Class Hierarchy
nxpsdDispatch_TnxDispatchInterfaceStubnxpsdDispatch_TnxDispatchInterfaceStubnxpsdDispatch_TnxDispatchInterfaceStubnxpsdDispatch_TnxDispatchInterfaceStubnxpsdDispatch_TnxDispatchInterfaceStub
Syntax
Delphi
TnxDispatchInterfaceStub = class(TnxInterfaceStub);
File

nxpsdDispatch

Description

This is class nxpsdDispatch.TnxDispatchInterfaceStub.

Group

Classes

Links
TnxDispatchInterfaceStub Methods, TnxDispatchInterfaceStub Members, nxpsdDispatch, Classes


TnxDispatchInterfaceStub Members

TnxDispatchInterfaceStub Members
TnxDispatchInterfaceStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDispatchInterfaceStub.

Class

TnxDispatchInterfaceStub Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
stClassID | private
stInterface | This is stInterface, a member of class TnxInterfaceStub.
stInterfaceID | This is stInterfaceID, a member of class TnxInterfaceStub.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ChannelAttached | TnxInterfaceStub
CreateInterfaceStub |
GetMinVersion |
GetStubVersion | TnxInterfaceStub
ioDeactivate |
Process | InxInterfaceStub
ProcessCallMethod | TnxInterfaceStub TnxDispatchInterfaceStub
ProcessGetIDsOfNames | TnxDispatchInterfaceStub
ProcessInvoke |
QueryInterface |
Supports | InxInterfaceStubFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
ChannelAttached | This is ChannelAttached, a member of class InxInterfaceStub.
Create |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Process | This is Process, a member of class InxInterfaceStub.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxDispatchInterfaceStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDispatchInterfaceStub Methods

TnxDispatchInterfaceStub Methods
TnxDispatchInterfaceStub Class Legend Protected Methods Send Feedback

The methods of the TnxDispatchInterfaceStub class are listed here.

Class

TnxDispatchInterfaceStub Class

Protected Methods
Name | Description
ProcessCallMethod | TnxInterfaceStub TnxDispatchInterfaceStub
ProcessGetIDsOfNames | TnxDispatchInterfaceStub
ProcessInvoke |
Links
TnxDispatchInterfaceStub Class, Legend, Protected Methods


TnxDispatchInterfaceStub.ProcessCallMethod Method

TnxDispatchInterfaceStub.ProcessCallMethod Method
TnxDispatchInterfaceStub Class TnxDispatchInterfaceStub Members nxpsdDispatch Namespace TnxDispatchInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessCallMethod(const aChannel: InxChannelExit; const aClassStub: InxClassStub; aMessageVersion: Integer; aMethod: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT; override;
Description

TnxInterfaceStub

TnxDispatchInterfaceStub

Group

TnxDispatchInterfaceStub Methods

Links
TnxDispatchInterfaceStub Class, TnxDispatchInterfaceStub Members, nxpsdDispatch Namespace, TnxDispatchInterfaceStub Methods


TnxDispatchInterfaceStub.ProcessGetIDsOfNames Method

TnxDispatchInterfaceStub.ProcessGetIDsOfNames Method
TnxDispatchInterfaceStub Class TnxDispatchInterfaceStub Members nxpsdDispatch Namespace TnxDispatchInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessGetIDsOfNames(aMessageVersion: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

TnxDispatchInterfaceStub

Group

TnxDispatchInterfaceStub Methods

Links
TnxDispatchInterfaceStub Class, TnxDispatchInterfaceStub Members, nxpsdDispatch Namespace, TnxDispatchInterfaceStub Methods


TnxDispatchInterfaceStub.ProcessInvoke Method

TnxDispatchInterfaceStub.ProcessInvoke Method
TnxDispatchInterfaceStub Class TnxDispatchInterfaceStub Members nxpsdDispatch Namespace TnxDispatchInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessInvoke(aMessageVersion: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Group

TnxDispatchInterfaceStub Methods

Links
TnxDispatchInterfaceStub Class, TnxDispatchInterfaceStub Members, nxpsdDispatch Namespace, TnxDispatchInterfaceStub Methods


Variables

Variables
nxpsdDispatch Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxpsdDispatch Namespace

Variables
Name | Description
DispatchInterfaceProxyControl |
DispatchInterfaceStubControl | This is variable nxpsdDispatch.DispatchInterfaceStubControl.
Links
nxpsdDispatch Namespace, Variables


nxpsdDispatch.DispatchInterfaceProxyControl Variable

nxpsdDispatch.DispatchInterfaceProxyControl Variable
nxpsdDispatch Variables Send Feedback
Syntax
Delphi
DispatchInterfaceProxyControl: InxInterfaceProxyFactoryControl;
File

nxpsdDispatch

Group

Variables

Links
nxpsdDispatch, Variables


nxpsdDispatch.DispatchInterfaceStubControl Variable

nxpsdDispatch.DispatchInterfaceStubControl Variable
nxpsdDispatch Variables Send Feedback
Syntax
Delphi
DispatchInterfaceStubControl: InxInterfaceStubFactoryControl;
File

nxpsdDispatch

Description

This is variable nxpsdDispatch.DispatchInterfaceStubControl.

Group

Variables

Links
nxpsdDispatch, Variables


Constants

Constants
Constants nxpsdDispatch Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DefaultDispatchInterfaceProxyID | RegisterFactories
Namespace

nxpsdDispatch Namespace

Links
Constants, nxpsdDispatch Namespace


nxpsdDispatch.DefaultDispatchInterfaceProxyID Constant

nxpsdDispatch.DefaultDispatchInterfaceProxyID Constant
nxpsdDispatch Constants Send Feedback
Syntax
Delphi
DefaultDispatchInterfaceProxyID: TnxGuid = '{2B569DD5-8F81-478E-BF08-ECACCBE4DDA3}';
File

nxpsdDispatch

Description

RegisterFactories

Group

Constants

Links
nxpsdDispatch, Constants


nxpsiInvokable Namespace

nxpsiInvokable Namespace
Classes Constants Legend Topics Variables Send Feedback

This is namespace nxpsiInvokable.

Classes
Name | Description
TnxInvokableInterfaceProxy | This is class nxpsiInvokable.TnxInvokableInterfaceProxy.
TnxInvokableInterfaceStub | This is class nxpsiInvokable.TnxInvokableInterfaceStub.
Constants
Name | Description
DefaultInvokableInterfaceProxyID |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
InvokableInterfaceProxyControl |
InvokableInterfaceStubControl | This is variable nxpsiInvokable.InvokableInterfaceStubControl.
Links
Classes, Constants, Legend, Topics, Variables


Classes

Classes
Classes nxpsiInvokable Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInvokableInterfaceProxy | This is class nxpsiInvokable.TnxInvokableInterfaceProxy.
TnxInvokableInterfaceStub | This is class nxpsiInvokable.TnxInvokableInterfaceStub.
Namespace

nxpsiInvokable Namespace

Links
Classes, nxpsiInvokable Namespace, Legend


TnxInvokableInterfaceProxy Class

TnxInvokableInterfaceProxy Class
TnxInvokableInterfaceProxy Fields TnxInvokableInterfaceProxy Methods TnxInvokableInterfaceProxy Members nxpsiInvokable Classes Send Feedback
Class Hierarchy
nxpsiInvokable_TnxInvokableInterfaceProxynxpsiInvokable_TnxInvokableInterfaceProxynxpsiInvokable_TnxInvokableInterfaceProxynxpsiInvokable_TnxInvokableInterfaceProxynxpsiInvokable_TnxInvokableInterfaceProxynxpsiInvokable_TnxInvokableInterfaceProxy
Syntax
Delphi
TnxInvokableInterfaceProxy = class(TnxInterfaceProxy, InxInvokeDispatcher);
File

nxpsiInvokable

Description

This is class nxpsiInvokable.TnxInvokableInterfaceProxy.

Group

Classes

Links
TnxInvokableInterfaceProxy Fields, TnxInvokableInterfaceProxy Methods, TnxInvokableInterfaceProxy Members, nxpsiInvokable, Classes


TnxInvokableInterfaceProxy Members

TnxInvokableInterfaceProxy Members
TnxInvokableInterfaceProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInvokableInterfaceProxy.

Class

TnxInvokableInterfaceProxy Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
ipInvokeStub | This is ipInvokeStub, a member of class TnxInvokableInterfaceProxy.
pxClassID | private
pxClassProxy | This is pxClassProxy, a member of class TnxInterfaceProxy.
pxInterfaceID | This is pxInterfaceID, a member of class TnxInterfaceProxy.
pxStubID | This is pxStubID, a member of class TnxInterfaceProxy.
pxStubVersion | This is pxStubVersion, a member of class TnxInterfaceProxy.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_AddRef |
_ProxyAddRef |
_ProxyRelease |
_Release |
_Release |
CreateInterfaceProxy |
DispatchInvoke | InxInvokeDispatcher
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
GetSharedVersion |
GetWriter |
ioDeactivate |
Process |
ProxyQueryInterface | InxInterfaceProxy
pxQueryInterface |
QueryInterface |
QueryInterface | InxInterface
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceProxy
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInvokableInterfaceProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInvokableInterfaceProxy.Create Constructor

TnxInvokableInterfaceProxy.Create Constructor
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterfaceStubID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aResult: HRESULT); override;
Description

TnxInterfaceProxy

Class

TnxInvokableInterfaceProxy Class

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Class


TnxInvokableInterfaceProxy Fields

TnxInvokableInterfaceProxy Fields
TnxInvokableInterfaceProxy Class Legend Protected Fields Send Feedback

The fields of the TnxInvokableInterfaceProxy class are listed here.

Class

TnxInvokableInterfaceProxy Class

Protected Fields
Name | Description
ipInvokeStub | This is ipInvokeStub, a member of class TnxInvokableInterfaceProxy.
Links
TnxInvokableInterfaceProxy Class, Legend, Protected Fields


TnxInvokableInterfaceProxy.ipInvokeStub Field

TnxInvokableInterfaceProxy.ipInvokeStub Field
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Fields Send Feedback
Syntax
Delphi
ipInvokeStub: InxInvokeStub;
Description

This is ipInvokeStub, a member of class TnxInvokableInterfaceProxy.

Group

TnxInvokableInterfaceProxy Fields

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Fields


TnxInvokableInterfaceProxy Methods

TnxInvokableInterfaceProxy Methods
TnxInvokableInterfaceProxy Class Legend Protected Methods Send Feedback

The methods of the TnxInvokableInterfaceProxy class are listed here.

Class

TnxInvokableInterfaceProxy Class

Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
pxQueryInterface |
Supports | InxInterfaceProxyFactory
Links
TnxInvokableInterfaceProxy Class, Legend, Protected Methods


TnxInvokableInterfaceProxy.DispatchInvoke Method

TnxInvokableInterfaceProxy.DispatchInvoke Method
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

InxInvokeDispatcher

Group

TnxInvokableInterfaceProxy Methods

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Methods


TnxInvokableInterfaceProxy.GetMinVersion Method

TnxInvokableInterfaceProxy.GetMinVersion Method
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetMinVersion: Integer; override;
Group

TnxInvokableInterfaceProxy Methods

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Methods


TnxInvokableInterfaceProxy.GetProxyVersion Method

TnxInvokableInterfaceProxy.GetProxyVersion Method
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetProxyVersion: Integer; override;
Description

TnxInterfaceProxy

Group

TnxInvokableInterfaceProxy Methods

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Methods


TnxInvokableInterfaceProxy.pxQueryInterface Method

TnxInvokableInterfaceProxy.pxQueryInterface Method
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Methods Send Feedback
Syntax
Delphi
function pxQueryInterface(constref const IID: TGUID; out Obj): HResult; override; stdcall;
Group

TnxInvokableInterfaceProxy Methods

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Methods


TnxInvokableInterfaceProxy.Supports Method

TnxInvokableInterfaceProxy.Supports Method
TnxInvokableInterfaceProxy Class TnxInvokableInterfaceProxy Members nxpsiInvokable Namespace TnxInvokableInterfaceProxy Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT; override;
Description

InxInterfaceProxyFactory

Group

TnxInvokableInterfaceProxy Methods

Links
TnxInvokableInterfaceProxy Class, TnxInvokableInterfaceProxy Members, nxpsiInvokable Namespace, TnxInvokableInterfaceProxy Methods


TnxInvokableInterfaceStub Class

TnxInvokableInterfaceStub Class
TnxInvokableInterfaceStub Fields TnxInvokableInterfaceStub Methods TnxInvokableInterfaceStub Members nxpsiInvokable Classes Send Feedback
Class Hierarchy
nxpsiInvokable_TnxInvokableInterfaceStubnxpsiInvokable_TnxInvokableInterfaceStubnxpsiInvokable_TnxInvokableInterfaceStubnxpsiInvokable_TnxInvokableInterfaceStubnxpsiInvokable_TnxInvokableInterfaceStub
Syntax
Delphi
TnxInvokableInterfaceStub = class(TnxInterfaceStub);
File

nxpsiInvokable

Description

This is class nxpsiInvokable.TnxInvokableInterfaceStub.

Group

Classes

Links
TnxInvokableInterfaceStub Fields, TnxInvokableInterfaceStub Methods, TnxInvokableInterfaceStub Members, nxpsiInvokable, Classes


TnxInvokableInterfaceStub Members

TnxInvokableInterfaceStub Members
TnxInvokableInterfaceStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInvokableInterfaceStub.

Class

TnxInvokableInterfaceStub Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
isInvokeProxy | private
stClassID | private
stInterface | This is stInterface, a member of class TnxInterfaceStub.
stInterfaceID | This is stInterfaceID, a member of class TnxInterfaceStub.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ChannelAttached | TnxInterfaceStub
CreateInterfaceStub |
GetMinVersion |
GetStubVersion | TnxInterfaceStub
ioDeactivate |
Process | InxInterfaceStub
ProcessCallMethod |
QueryInterface |
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
ChannelAttached | This is ChannelAttached, a member of class InxInterfaceStub.
Create | TnxInvokableInterfaceStub
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Process | This is Process, a member of class InxInterfaceStub.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInvokableInterfaceStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInvokableInterfaceStub.Create Constructor

TnxInvokableInterfaceStub.Create Constructor
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; var aResult: HRESULT); override;
Description

TnxInvokableInterfaceStub

Class

TnxInvokableInterfaceStub Class

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Class


TnxInvokableInterfaceStub Fields

TnxInvokableInterfaceStub Fields
TnxInvokableInterfaceStub Class Legend Protected Fields Send Feedback

The fields of the TnxInvokableInterfaceStub class are listed here.

Class

TnxInvokableInterfaceStub Class

Protected Fields
Name | Description
isInvokeProxy | private
Links
TnxInvokableInterfaceStub Class, Legend, Protected Fields


TnxInvokableInterfaceStub.isInvokeProxy Field

TnxInvokableInterfaceStub.isInvokeProxy Field
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Fields Send Feedback
Syntax
Delphi
isInvokeProxy: InxInvokeProxy;
Description

private

Group

TnxInvokableInterfaceStub Fields

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Fields


TnxInvokableInterfaceStub Methods

TnxInvokableInterfaceStub Methods
TnxInvokableInterfaceStub Class Legend Protected Methods Send Feedback

The methods of the TnxInvokableInterfaceStub class are listed here.

Class

TnxInvokableInterfaceStub Class

Protected Methods
Name | Description
GetMinVersion |
GetStubVersion | TnxInterfaceStub
ProcessCallMethod |
Supports | InxInterfaceProxyFactory
Links
TnxInvokableInterfaceStub Class, Legend, Protected Methods


TnxInvokableInterfaceStub.GetMinVersion Method

TnxInvokableInterfaceStub.GetMinVersion Method
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Methods Send Feedback
Syntax
Delphi
function GetMinVersion: Integer; override;
Group

TnxInvokableInterfaceStub Methods

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Methods


TnxInvokableInterfaceStub.GetStubVersion Method

TnxInvokableInterfaceStub.GetStubVersion Method
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Methods Send Feedback
Syntax
Delphi
function GetStubVersion: Integer; override;
Description

TnxInterfaceStub

Group

TnxInvokableInterfaceStub Methods

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Methods


TnxInvokableInterfaceStub.ProcessCallMethod Method

TnxInvokableInterfaceStub.ProcessCallMethod Method
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessCallMethod(const aChannel: InxChannelExit; const aClassStub: InxClassStub; aMessageVersion: Integer; aMethod: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT; override;
Group

TnxInvokableInterfaceStub Methods

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Methods


TnxInvokableInterfaceStub.Supports Method

TnxInvokableInterfaceStub.Supports Method
TnxInvokableInterfaceStub Class TnxInvokableInterfaceStub Members nxpsiInvokable Namespace TnxInvokableInterfaceStub Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT; override;
Description

InxInterfaceProxyFactory

Group

TnxInvokableInterfaceStub Methods

Links
TnxInvokableInterfaceStub Class, TnxInvokableInterfaceStub Members, nxpsiInvokable Namespace, TnxInvokableInterfaceStub Methods


Variables

Variables
nxpsiInvokable Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxpsiInvokable Namespace

Variables
Name | Description
InvokableInterfaceProxyControl |
InvokableInterfaceStubControl | This is variable nxpsiInvokable.InvokableInterfaceStubControl.
Links
nxpsiInvokable Namespace, Variables


nxpsiInvokable.InvokableInterfaceProxyControl Variable

nxpsiInvokable.InvokableInterfaceProxyControl Variable
nxpsiInvokable Variables Send Feedback
Syntax
Delphi
InvokableInterfaceProxyControl: InxInterfaceProxyFactoryControl;
File

nxpsiInvokable

Group

Variables

Links
nxpsiInvokable, Variables


nxpsiInvokable.InvokableInterfaceStubControl Variable

nxpsiInvokable.InvokableInterfaceStubControl Variable
nxpsiInvokable Variables Send Feedback
Syntax
Delphi
InvokableInterfaceStubControl: InxInterfaceStubFactoryControl;
File

nxpsiInvokable

Description

This is variable nxpsiInvokable.InvokableInterfaceStubControl.

Group

Variables

Links
nxpsiInvokable, Variables


Constants

Constants
Constants nxpsiInvokable Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DefaultInvokableInterfaceProxyID |
Namespace

nxpsiInvokable Namespace

Links
Constants, nxpsiInvokable Namespace


nxpsiInvokable.DefaultInvokableInterfaceProxyID Constant

nxpsiInvokable.DefaultInvokableInterfaceProxyID Constant
nxpsiInvokable Constants Send Feedback
Syntax
Delphi
DefaultInvokableInterfaceProxyID: TnxGuid = '{03D2E708-2A4C-477D-8EAD-214F46C7178F}';
File

nxpsiInvokable

Group

Constants

Links
nxpsiInvokable, Constants


nxpsiInvokeBroadcaster Namespace

nxpsiInvokeBroadcaster Namespace
Classes Functions Interfaces Legend Topics Send Feedback

This is namespace nxpsiInvokeBroadcaster.

Classes
Name | Description
TnxInvokeBroadcaster | This is class nxpsiInvokeBroadcaster.TnxInvokeBroadcaster.
TnxInvokeSink | This is class nxpsiInvokeBroadcaster.TnxInvokeSink.
Functions
Name | Description
nxCreateInvokeBroadcaster |
Interfaces
Name | Description
InxInvokeConnectionPoint | This is class nxpsiInvokeBroadcaster.InxInvokeConnectionPoint.
InxInvokeSinkControl | This is class nxpsiInvokeBroadcaster.InxInvokeSinkControl.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Links
Classes, Functions, Interfaces, Legend, Topics


Classes

Classes
Classes nxpsiInvokeBroadcaster Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInvokeBroadcaster | This is class nxpsiInvokeBroadcaster.TnxInvokeBroadcaster.
TnxInvokeSink | This is class nxpsiInvokeBroadcaster.TnxInvokeSink.
Namespace

nxpsiInvokeBroadcaster Namespace

Links
Classes, nxpsiInvokeBroadcaster Namespace, Legend


TnxInvokeBroadcaster Class

TnxInvokeBroadcaster Class
TnxInvokeBroadcaster Fields TnxInvokeBroadcaster Methods TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Classes Send Feedback
Class Hierarchy
nxpsiInvokeBroadcaster_TnxInvokeBroadcasternxpsiInvokeBroadcaster_TnxInvokeBroadcasternxpsiInvokeBroadcaster_TnxInvokeBroadcaster
Syntax
Delphi
TnxInvokeBroadcaster = class(TnxInterfacedObject, InxInvokeConnectionPoint, InxInvokeDispatcher);
File

nxpsiInvokeBroadcaster

Description

This is class nxpsiInvokeBroadcaster.TnxInvokeBroadcaster.

Group

Classes

Links
TnxInvokeBroadcaster Fields, TnxInvokeBroadcaster Methods, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster, Classes


TnxInvokeBroadcaster Members

TnxInvokeBroadcaster Members
TnxInvokeBroadcaster Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInvokeBroadcaster.

Class

TnxInvokeBroadcaster Class

Protected Fields
Name | Description
ibcHead | This is ibcHead, a member of class TnxInvokeBroadcaster.
ibcInterfaceID | privat
ibcPortal | This is ibcPortal, a member of class TnxInvokeBroadcaster.
ibcStub | required to keep the stub alive
Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
RegisterSink | InxInvokeConnectionPoint
Public Methods
Name | Description
Create | TnxInvokeBroadcaster
Destroy | This is Destroy, a member of class TnxInvokeBroadcaster.
Links
TnxInvokeBroadcaster Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInvokeBroadcaster.Create Constructor

TnxInvokeBroadcaster.Create Constructor
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Class Send Feedback
Syntax
Delphi
constructor Create(const aInterfaceID: TnxGuid);
Description

TnxInvokeBroadcaster

Class

TnxInvokeBroadcaster Class

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Class


TnxInvokeBroadcaster.Destroy Destructor

TnxInvokeBroadcaster.Destroy Destructor
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxInvokeBroadcaster.

Class

TnxInvokeBroadcaster Class

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Class


TnxInvokeBroadcaster Fields

TnxInvokeBroadcaster Fields
TnxInvokeBroadcaster Class Legend Protected Fields Send Feedback

The fields of the TnxInvokeBroadcaster class are listed here.

Class

TnxInvokeBroadcaster Class

Protected Fields
Name | Description
ibcHead | This is ibcHead, a member of class TnxInvokeBroadcaster.
ibcInterfaceID | privat
ibcPortal | This is ibcPortal, a member of class TnxInvokeBroadcaster.
ibcStub | required to keep the stub alive
Links
TnxInvokeBroadcaster Class, Legend, Protected Fields


TnxInvokeBroadcaster.ibcHead Field

TnxInvokeBroadcaster.ibcHead Field
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Fields Send Feedback
Syntax
Delphi
ibcHead: TnxInvokeSink;
Description

This is ibcHead, a member of class TnxInvokeBroadcaster.

Group

TnxInvokeBroadcaster Fields

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Fields


TnxInvokeBroadcaster.ibcInterfaceID Field

TnxInvokeBroadcaster.ibcInterfaceID Field
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Fields Send Feedback
Syntax
Delphi
ibcInterfaceID: TnxGuid;
Description

privat

Group

TnxInvokeBroadcaster Fields

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Fields


TnxInvokeBroadcaster.ibcPortal Field

TnxInvokeBroadcaster.ibcPortal Field
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Fields Send Feedback
Syntax
Delphi
ibcPortal: TnxReadWritePortal;
Description

This is ibcPortal, a member of class TnxInvokeBroadcaster.

Group

TnxInvokeBroadcaster Fields

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Fields


TnxInvokeBroadcaster.ibcStub Field

TnxInvokeBroadcaster.ibcStub Field
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Fields Send Feedback
Syntax
Delphi
ibcStub: InxInvokeStub;
Description

required to keep the stub alive

Group

TnxInvokeBroadcaster Fields

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Fields


TnxInvokeBroadcaster Methods

TnxInvokeBroadcaster Methods
TnxInvokeBroadcaster Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeBroadcaster class are listed here.

Class

TnxInvokeBroadcaster Class

Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
RegisterSink | InxInvokeConnectionPoint
Links
TnxInvokeBroadcaster Class, Legend, Protected Methods


TnxInvokeBroadcaster.DispatchInvoke Method

TnxInvokeBroadcaster.DispatchInvoke Method
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

InxInvokeDispatcher

Group

TnxInvokeBroadcaster Methods

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Methods


TnxInvokeBroadcaster.RegisterSink Method

TnxInvokeBroadcaster.RegisterSink Method
TnxInvokeBroadcaster Class TnxInvokeBroadcaster Members nxpsiInvokeBroadcaster Namespace TnxInvokeBroadcaster Methods Send Feedback
Syntax
Delphi
function RegisterSink(const aSink: InxInterface; out aControl: InxInvokeSinkControl): HRESULT;
Description

InxInvokeConnectionPoint

Group

TnxInvokeBroadcaster Methods

Links
TnxInvokeBroadcaster Class, TnxInvokeBroadcaster Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeBroadcaster Methods


TnxInvokeSink Class

TnxInvokeSink Class
TnxInvokeSink Fields TnxInvokeSink Methods TnxInvokeSink Members nxpsiInvokeBroadcaster Classes Send Feedback
Class Hierarchy
nxpsiInvokeBroadcaster_TnxInvokeSinknxpsiInvokeBroadcaster_TnxInvokeSinknxpsiInvokeBroadcaster_TnxInvokeSink
Syntax
Delphi
TnxInvokeSink = class(TnxInterfacedObject, InxInvokeSinkControl, InxInvokeDispatcher);
File

nxpsiInvokeBroadcaster

Description

This is class nxpsiInvokeBroadcaster.TnxInvokeSink.

Group

Classes

Links
TnxInvokeSink Fields, TnxInvokeSink Methods, TnxInvokeSink Members, nxpsiInvokeBroadcaster, Classes


TnxInvokeSink Members

TnxInvokeSink Members
TnxInvokeSink Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInvokeSink.

Class

TnxInvokeSink Class

Protected Fields
Name | Description
isBroadcaster | privat
isControlRefCount | This is isControlRefCount, a member of class TnxInvokeSink.
isInvokeProxy | This is isInvokeProxy, a member of class TnxInvokeSink.
isNext | This is isNext, a member of class TnxInvokeSink.
isPadlock | This is isPadlock, a member of class TnxInvokeSink.
isPrev | This is isPrev, a member of class TnxInvokeSink.
isRegistered | This is isRegistered, a member of class TnxInvokeSink.
Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
InvokeSinkControlAddRef | This is InvokeSinkControlAddRef, a member of class TnxInvokeSink.
InvokeSinkControlQueryInterface | InxInvokeSinkControl
InvokeSinkControlRelease | This is InvokeSinkControlRelease, a member of class TnxInvokeSink.
isAddToBroadcaster | This is isAddToBroadcaster, a member of class TnxInvokeSink.
isRemoveFromBroadcaster | This is isRemoveFromBroadcaster, a member of class TnxInvokeSink.
Unregister | This is Unregister, a member of class TnxInvokeSink.
Public Methods
Name | Description
Create | TnxInvokeSink
Destroy | This is Destroy, a member of class TnxInvokeSink.
Links
TnxInvokeSink Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInvokeSink.Create Constructor

TnxInvokeSink.Create Constructor
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Class Send Feedback
Syntax
Delphi
constructor Create(aBroadcaster: TnxInvokeBroadcaster; const aInvokeProxy: InxInvokeProxy);
Description

TnxInvokeSink

Class

TnxInvokeSink Class

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Class


TnxInvokeSink.Destroy Destructor

TnxInvokeSink.Destroy Destructor
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxInvokeSink.

Class

TnxInvokeSink Class

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Class


TnxInvokeSink Fields

TnxInvokeSink Fields
TnxInvokeSink Class Legend Protected Fields Send Feedback

The fields of the TnxInvokeSink class are listed here.

Class

TnxInvokeSink Class

Protected Fields
Name | Description
isBroadcaster | privat
isControlRefCount | This is isControlRefCount, a member of class TnxInvokeSink.
isInvokeProxy | This is isInvokeProxy, a member of class TnxInvokeSink.
isNext | This is isNext, a member of class TnxInvokeSink.
isPadlock | This is isPadlock, a member of class TnxInvokeSink.
isPrev | This is isPrev, a member of class TnxInvokeSink.
isRegistered | This is isRegistered, a member of class TnxInvokeSink.
Links
TnxInvokeSink Class, Legend, Protected Fields


TnxInvokeSink.isBroadcaster Field

TnxInvokeSink.isBroadcaster Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isBroadcaster: TnxInvokeBroadcaster;
Description

privat

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isControlRefCount Field

TnxInvokeSink.isControlRefCount Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isControlRefCount: Integer;
Description

This is isControlRefCount, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isInvokeProxy Field

TnxInvokeSink.isInvokeProxy Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isInvokeProxy: InxInvokeProxy;
Description

This is isInvokeProxy, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isNext Field

TnxInvokeSink.isNext Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isNext: TnxInvokeSink;
Description

This is isNext, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isPadlock Field

TnxInvokeSink.isPadlock Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isPadlock: TnxPadlock;
Description

This is isPadlock, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isPrev Field

TnxInvokeSink.isPrev Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isPrev: TnxInvokeSink;
Description

This is isPrev, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink.isRegistered Field

TnxInvokeSink.isRegistered Field
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Fields Send Feedback
Syntax
Delphi
isRegistered: InxInterface;
Description

This is isRegistered, a member of class TnxInvokeSink.

Group

TnxInvokeSink Fields

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Fields


TnxInvokeSink Methods

TnxInvokeSink Methods
TnxInvokeSink Class Legend Protected Methods Send Feedback

The methods of the TnxInvokeSink class are listed here.

Class

TnxInvokeSink Class

Protected Methods
Name | Description
DispatchInvoke | InxInvokeDispatcher
InvokeSinkControlAddRef | This is InvokeSinkControlAddRef, a member of class TnxInvokeSink.
InvokeSinkControlQueryInterface | InxInvokeSinkControl
InvokeSinkControlRelease | This is InvokeSinkControlRelease, a member of class TnxInvokeSink.
isAddToBroadcaster | This is isAddToBroadcaster, a member of class TnxInvokeSink.
isRemoveFromBroadcaster | This is isRemoveFromBroadcaster, a member of class TnxInvokeSink.
Unregister | This is Unregister, a member of class TnxInvokeSink.
Links
TnxInvokeSink Class, Legend, Protected Methods


TnxInvokeSink.DispatchInvoke Method

TnxInvokeSink.DispatchInvoke Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
procedure DispatchInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray);
Description

InxInvokeDispatcher

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.InvokeSinkControlAddRef Method

TnxInvokeSink.InvokeSinkControlAddRef Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
function InvokeSinkControlAddRef: Integer; stdcall;
Description

This is InvokeSinkControlAddRef, a member of class TnxInvokeSink.

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.InvokeSinkControlQueryInterface Method

TnxInvokeSink.InvokeSinkControlQueryInterface Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
function InvokeSinkControlQueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInvokeSinkControl

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.InvokeSinkControlRelease Method

TnxInvokeSink.InvokeSinkControlRelease Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
function InvokeSinkControlRelease: Integer; stdcall;
Description

This is InvokeSinkControlRelease, a member of class TnxInvokeSink.

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.isAddToBroadcaster Method

TnxInvokeSink.isAddToBroadcaster Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
procedure isAddToBroadcaster;
Description

This is isAddToBroadcaster, a member of class TnxInvokeSink.

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.isRemoveFromBroadcaster Method

TnxInvokeSink.isRemoveFromBroadcaster Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
procedure isRemoveFromBroadcaster;
Description

This is isRemoveFromBroadcaster, a member of class TnxInvokeSink.

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


TnxInvokeSink.Unregister Method

TnxInvokeSink.Unregister Method
TnxInvokeSink Class TnxInvokeSink Members nxpsiInvokeBroadcaster Namespace TnxInvokeSink Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

This is Unregister, a member of class TnxInvokeSink.

Group

TnxInvokeSink Methods

Links
TnxInvokeSink Class, TnxInvokeSink Members, nxpsiInvokeBroadcaster Namespace, TnxInvokeSink Methods


Interfaces

Interfaces
nxpsiInvokeBroadcaster Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxpsiInvokeBroadcaster Namespace

Interfaces
Name | Description
InxInvokeConnectionPoint | This is class nxpsiInvokeBroadcaster.InxInvokeConnectionPoint.
InxInvokeSinkControl | This is class nxpsiInvokeBroadcaster.InxInvokeSinkControl.
Links
nxpsiInvokeBroadcaster Namespace, Interfaces, Legend


InxInvokeConnectionPoint Interface

InxInvokeConnectionPoint Interface
InxInvokeConnectionPoint Methods InxInvokeConnectionPoint Members nxpsiInvokeBroadcaster Interfaces Send Feedback
Class Hierarchy
nxpsiInvokeBroadcaster_InxInvokeConnectionPoint
Syntax
Delphi
InxInvokeConnectionPoint = interface(InxInvokable);
File

nxpsiInvokeBroadcaster

Description

This is class nxpsiInvokeBroadcaster.InxInvokeConnectionPoint.

Group

Interfaces

Links
InxInvokeConnectionPoint Methods, InxInvokeConnectionPoint Members, nxpsiInvokeBroadcaster, Interfaces


InxInvokeConnectionPoint Members

InxInvokeConnectionPoint Members
InxInvokeConnectionPoint Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeConnectionPoint.

Interface

InxInvokeConnectionPoint Interface

Public Methods
Name | Description
RegisterSink | This is RegisterSink, a member of class InxInvokeConnectionPoint.
Links
InxInvokeConnectionPoint Interface, Legend, Public Methods


InxInvokeConnectionPoint Methods

InxInvokeConnectionPoint Methods
InxInvokeConnectionPoint Interface Legend Public Methods Send Feedback

The methods of the InxInvokeConnectionPoint class are listed here.

Interface

InxInvokeConnectionPoint Interface

Public Methods
Name | Description
RegisterSink | This is RegisterSink, a member of class InxInvokeConnectionPoint.
Links
InxInvokeConnectionPoint Interface, Legend, Public Methods


InxInvokeConnectionPoint.RegisterSink Method

InxInvokeConnectionPoint.RegisterSink Method
InxInvokeConnectionPoint Interface InxInvokeConnectionPoint Members nxpsiInvokeBroadcaster Namespace InxInvokeConnectionPoint Methods Send Feedback
Syntax
Delphi
function RegisterSink(const aSink: InxInterface; out aControl: InxInvokeSinkControl): HRESULT;
Description

This is RegisterSink, a member of class InxInvokeConnectionPoint.

Group

InxInvokeConnectionPoint Methods

Links
InxInvokeConnectionPoint Interface, InxInvokeConnectionPoint Members, nxpsiInvokeBroadcaster Namespace, InxInvokeConnectionPoint Methods


InxInvokeSinkControl Interface

InxInvokeSinkControl Interface
InxInvokeSinkControl Methods InxInvokeSinkControl Members nxpsiInvokeBroadcaster Interfaces Send Feedback
Class Hierarchy
nxpsiInvokeBroadcaster_InxInvokeSinkControl
Syntax
Delphi
InxInvokeSinkControl = interface(InxInvokable);
File

nxpsiInvokeBroadcaster

Description

This is class nxpsiInvokeBroadcaster.InxInvokeSinkControl.

Group

Interfaces

Links
InxInvokeSinkControl Methods, InxInvokeSinkControl Members, nxpsiInvokeBroadcaster, Interfaces


InxInvokeSinkControl Members

InxInvokeSinkControl Members
InxInvokeSinkControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInvokeSinkControl.

Interface

InxInvokeSinkControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxInvokeSinkControl.
Links
InxInvokeSinkControl Interface, Legend, Public Methods


InxInvokeSinkControl Methods

InxInvokeSinkControl Methods
InxInvokeSinkControl Interface Legend Public Methods Send Feedback

The methods of the InxInvokeSinkControl class are listed here.

Interface

InxInvokeSinkControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxInvokeSinkControl.
Links
InxInvokeSinkControl Interface, Legend, Public Methods


InxInvokeSinkControl.Unregister Method

InxInvokeSinkControl.Unregister Method
InxInvokeSinkControl Interface InxInvokeSinkControl Members nxpsiInvokeBroadcaster Namespace InxInvokeSinkControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

This is Unregister, a member of class InxInvokeSinkControl.

Group

InxInvokeSinkControl Methods

Links
InxInvokeSinkControl Interface, InxInvokeSinkControl Members, nxpsiInvokeBroadcaster Namespace, InxInvokeSinkControl Methods


Functions

Functions
Functions nxpsiInvokeBroadcaster Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCreateInvokeBroadcaster |
Namespace

nxpsiInvokeBroadcaster Namespace

Links
Functions, nxpsiInvokeBroadcaster Namespace, Legend


nxpsiInvokeBroadcaster.nxCreateInvokeBroadcaster Function

nxpsiInvokeBroadcaster.nxCreateInvokeBroadcaster Function
nxpsiInvokeBroadcaster Functions Send Feedback
Syntax
Delphi
function nxCreateInvokeBroadcaster(const aInterfaceID: TnxGuid; out aConnectionPoint: InxInvokeConnectionPoint; out aInterface): HRESULT;
File

nxpsiInvokeBroadcaster

Parameters
Parameters | Description
out aInterface | : type depends on aInterfaceID : type depends on aInterfaceID
Group

Functions

Links
nxpsiInvokeBroadcaster, Functions


nxpsiMessagePumpInterceptor Namespace

nxpsiMessagePumpInterceptor Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxpsiMessagePumpInterceptor.

Classes
Name | Description
TnxMessagePumpInterceptor | This is class nxpsiMessagePumpInterceptor.TnxMessagePumpInterceptor.
Constants
Name | Description
NX_MAKECALL | This is constant nxpsiMessagePumpInterceptor.NX_MAKECALL.
Functions
Name | Description
nxCreateMessagePumpInterceptor | This is function nxpsiMessagePumpInterceptor.nxCreateMessagePumpInterceptor.
nxWrapMessagePump | This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.
nxWrapMessagePump | This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.
Structs, Records, Enums
Name | Description
TnxCallData | This is record nxpsiMessagePumpInterceptor.TnxCallData.
TNXMakeCall | This is record nxpsiMessagePumpInterceptor.TNXMakeCall.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxCallData | This is type nxpsiMessagePumpInterceptor.PnxCallData.
PnxMessagePumpInterceptor | This is type nxpsiMessagePumpInterceptor.PnxMessagePumpInterceptor.
Variables
Name | Description
_MessagePump | This is variable nxpsiMessagePumpInterceptor._MessagePump.
_ReleasePadlock | This is variable nxpsiMessagePumpInterceptor._ReleasePadlock.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxpsiMessagePumpInterceptor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMessagePumpInterceptor | This is class nxpsiMessagePumpInterceptor.TnxMessagePumpInterceptor.
Namespace

nxpsiMessagePumpInterceptor Namespace

Links
Classes, nxpsiMessagePumpInterceptor Namespace, Legend


TnxMessagePumpInterceptor Class

TnxMessagePumpInterceptor Class
TnxMessagePumpInterceptor Fields TnxMessagePumpInterceptor Methods TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Classes Send Feedback
Class Hierarchy
nxpsiMessagePumpInterceptor_TnxMessagePumpInterceptornxpsiMessagePumpInterceptor_TnxMessagePumpInterceptor
Syntax
Delphi
TnxMessagePumpInterceptor = class(TnxInterfacedObject, InxInterface, InxInvokeInterceptor);
File

nxpsiMessagePumpInterceptor

Description

This is class nxpsiMessagePumpInterceptor.TnxMessagePumpInterceptor.

Group

Classes

Links
TnxMessagePumpInterceptor Fields, TnxMessagePumpInterceptor Methods, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor, Classes


TnxMessagePumpInterceptor Members

TnxMessagePumpInterceptor Members
TnxMessagePumpInterceptor Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMessagePumpInterceptor.

Class

TnxMessagePumpInterceptor Class

Protected Fields
Name | Description
mpiHandle | This is mpiHandle, a member of class TnxMessagePumpInterceptor.
mpiThreadID | This is mpiThreadID, a member of class TnxMessagePumpInterceptor.
mpiThreadVar | private
Protected Methods
Name | Description
_Release | InxInterface
InterceptInvoke | InxInvokeInterceptor
mpiClearThreadVar | This is mpiClearThreadVar, a member of class TnxMessagePumpInterceptor.
mpiWndMethod | TnxMessagePumpInterceptor
NXMakeCall | This is NXMakeCall, a member of class TnxMessagePumpInterceptor.
Public Methods
Name | Description
Create | TnxMessagePumpInterceptor
DefaultHandler | This is DefaultHandler, a member of class TnxMessagePumpInterceptor.
Destroy | This is Destroy, a member of class TnxMessagePumpInterceptor.
Links
TnxMessagePumpInterceptor Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxMessagePumpInterceptor.Create Constructor

TnxMessagePumpInterceptor.Create Constructor
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxMessagePumpInterceptor

Class

TnxMessagePumpInterceptor Class

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Class


TnxMessagePumpInterceptor.Destroy Destructor

TnxMessagePumpInterceptor.Destroy Destructor
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxMessagePumpInterceptor.

Class

TnxMessagePumpInterceptor Class

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Class


TnxMessagePumpInterceptor Fields

TnxMessagePumpInterceptor Fields
TnxMessagePumpInterceptor Class Legend Protected Fields Send Feedback

The fields of the TnxMessagePumpInterceptor class are listed here.

Class

TnxMessagePumpInterceptor Class

Protected Fields
Name | Description
mpiHandle | This is mpiHandle, a member of class TnxMessagePumpInterceptor.
mpiThreadID | This is mpiThreadID, a member of class TnxMessagePumpInterceptor.
mpiThreadVar | private
Links
TnxMessagePumpInterceptor Class, Legend, Protected Fields


TnxMessagePumpInterceptor.mpiHandle Field

TnxMessagePumpInterceptor.mpiHandle Field
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Fields Send Feedback
Syntax
Delphi
mpiHandle: THandle;
Description

This is mpiHandle, a member of class TnxMessagePumpInterceptor.

Group

TnxMessagePumpInterceptor Fields

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Fields


TnxMessagePumpInterceptor.mpiThreadID Field

TnxMessagePumpInterceptor.mpiThreadID Field
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Fields Send Feedback
Syntax
Delphi
mpiThreadID: Cardinal;
Description

This is mpiThreadID, a member of class TnxMessagePumpInterceptor.

Group

TnxMessagePumpInterceptor Fields

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Fields


TnxMessagePumpInterceptor.mpiThreadVar Field

TnxMessagePumpInterceptor.mpiThreadVar Field
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Fields Send Feedback
Syntax
Delphi
mpiThreadVar: PnxMessagePumpInterceptor;
Description

private

Group

TnxMessagePumpInterceptor Fields

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Fields


TnxMessagePumpInterceptor Methods

TnxMessagePumpInterceptor Methods
TnxMessagePumpInterceptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMessagePumpInterceptor class are listed here.

Class

TnxMessagePumpInterceptor Class

Protected Methods
Name | Description
_Release | InxInterface
InterceptInvoke | InxInvokeInterceptor
mpiClearThreadVar | This is mpiClearThreadVar, a member of class TnxMessagePumpInterceptor.
mpiWndMethod | TnxMessagePumpInterceptor
NXMakeCall | This is NXMakeCall, a member of class TnxMessagePumpInterceptor.
Public Methods
Name | Description
DefaultHandler | This is DefaultHandler, a member of class TnxMessagePumpInterceptor.
Links
TnxMessagePumpInterceptor Class, Legend, Protected Methods, Public Methods


TnxMessagePumpInterceptor._Release Method

TnxMessagePumpInterceptor._Release Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Description

InxInterface

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


TnxMessagePumpInterceptor.DefaultHandler Method

TnxMessagePumpInterceptor.DefaultHandler Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
procedure DefaultHandler(var Message); override;
Description

This is DefaultHandler, a member of class TnxMessagePumpInterceptor.

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


TnxMessagePumpInterceptor.InterceptInvoke Method

TnxMessagePumpInterceptor.InterceptInvoke Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
function InterceptInvoke(aMethod: PnxIntfMethEntry; aParams: PnxPointerArray; const aCallFrame: InxCallFrame): HRESULT;
Description

InxInvokeInterceptor

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


TnxMessagePumpInterceptor.mpiClearThreadVar Method

TnxMessagePumpInterceptor.mpiClearThreadVar Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
procedure mpiClearThreadVar;
Description

This is mpiClearThreadVar, a member of class TnxMessagePumpInterceptor.

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


TnxMessagePumpInterceptor.mpiWndMethod Method

TnxMessagePumpInterceptor.mpiWndMethod Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
procedure mpiWndMethod(var Message: TMessage);
Description

TnxMessagePumpInterceptor

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


TnxMessagePumpInterceptor.NXMakeCall Method

TnxMessagePumpInterceptor.NXMakeCall Method
TnxMessagePumpInterceptor Class TnxMessagePumpInterceptor Members nxpsiMessagePumpInterceptor Namespace TnxMessagePumpInterceptor Methods Send Feedback
Syntax
Delphi
procedure NXMakeCall(var Message: TNXMakeCall); message NX_MAKECALL;
Description

This is NXMakeCall, a member of class TnxMessagePumpInterceptor.

Group

TnxMessagePumpInterceptor Methods

Links
TnxMessagePumpInterceptor Class, TnxMessagePumpInterceptor Members, nxpsiMessagePumpInterceptor Namespace, TnxMessagePumpInterceptor Methods


Functions

Functions
Functions nxpsiMessagePumpInterceptor Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCreateMessagePumpInterceptor | This is function nxpsiMessagePumpInterceptor.nxCreateMessagePumpInterceptor.
nxWrapMessagePump | This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.
nxWrapMessagePump | This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.
Namespace

nxpsiMessagePumpInterceptor Namespace

Links
Functions, nxpsiMessagePumpInterceptor Namespace, Legend


nxpsiMessagePumpInterceptor.nxCreateMessagePumpInterceptor Function

nxpsiMessagePumpInterceptor.nxCreateMessagePumpInterceptor Function
nxpsiMessagePumpInterceptor Functions Send Feedback
Syntax
Delphi
function nxCreateMessagePumpInterceptor: InxInvokeInterceptor;
File

nxpsiMessagePumpInterceptor

Description

This is function nxpsiMessagePumpInterceptor.nxCreateMessagePumpInterceptor.

Group

Functions

Links
nxpsiMessagePumpInterceptor, Functions


nxpsiMessagePumpInterceptor.nxWrapMessagePump Function

nxpsiMessagePumpInterceptor.nxWrapMessagePump Function
nxpsiMessagePumpInterceptor Functions Send Feedback
Syntax
Delphi
function nxWrapMessagePump(const aInterface: InxInterface): InxInterface; overload;
File

nxpsiMessagePumpInterceptor

Description

This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.

Group

Functions

Links
nxpsiMessagePumpInterceptor, Functions


nxpsiMessagePumpInterceptor.nxWrapMessagePump Function

nxpsiMessagePumpInterceptor.nxWrapMessagePump Function
nxpsiMessagePumpInterceptor Functions Send Feedback
Syntax
Delphi
function nxWrapMessagePump(const aInterface: InxInterface; out aWrappedIntf: InxInterface): HRESULT; overload;
File

nxpsiMessagePumpInterceptor

Description

This is function nxpsiMessagePumpInterceptor.nxWrapMessagePump.

Group

Functions

Links
nxpsiMessagePumpInterceptor, Functions


Structs, Records, Enums

Structs, Records, Enums
nxpsiMessagePumpInterceptor Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxpsiMessagePumpInterceptor Namespace

Records
Name | Description
TnxCallData | This is record nxpsiMessagePumpInterceptor.TnxCallData.
TNXMakeCall | This is record nxpsiMessagePumpInterceptor.TNXMakeCall.
Links
nxpsiMessagePumpInterceptor Namespace, Legend, Records


nxpsiMessagePumpInterceptor.TnxCallData Record

nxpsiMessagePumpInterceptor.TnxCallData Record
nxpsiMessagePumpInterceptor Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCallData = record
  cdContext: InxCallContext;
  cdCallFrame: InxCallFrame;
  cdErrorInfo: IErrorInfo;
end;
File

nxpsiMessagePumpInterceptor

Description

This is record nxpsiMessagePumpInterceptor.TnxCallData.

Group

Structs, Records, Enums

Links
nxpsiMessagePumpInterceptor, Structs, Records, Enums


nxpsiMessagePumpInterceptor.TNXMakeCall Record

nxpsiMessagePumpInterceptor.TNXMakeCall Record
nxpsiMessagePumpInterceptor Structs, Records, Enums Send Feedback
Syntax
Delphi
TNXMakeCall = packed record
  mcMsg: Cardinal;
  mcData: PnxCallData;
  mcUnused: Integer;
  mcResult: HRESULT;
end;
File

nxpsiMessagePumpInterceptor

Description

This is record nxpsiMessagePumpInterceptor.TNXMakeCall.

Group

Structs, Records, Enums

Links
nxpsiMessagePumpInterceptor, Structs, Records, Enums


Types

Types
nxpsiMessagePumpInterceptor Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxpsiMessagePumpInterceptor Namespace

Types
Name | Description
PnxCallData | This is type nxpsiMessagePumpInterceptor.PnxCallData.
PnxMessagePumpInterceptor | This is type nxpsiMessagePumpInterceptor.PnxMessagePumpInterceptor.
Links
nxpsiMessagePumpInterceptor Namespace, Types


nxpsiMessagePumpInterceptor.PnxCallData Type

nxpsiMessagePumpInterceptor.PnxCallData Type
nxpsiMessagePumpInterceptor Types Send Feedback
Syntax
Delphi
PnxCallData = ^TnxCallData;
File

nxpsiMessagePumpInterceptor

Description

This is type nxpsiMessagePumpInterceptor.PnxCallData.

Group

Types

Links
nxpsiMessagePumpInterceptor, Types


nxpsiMessagePumpInterceptor.PnxMessagePumpInterceptor Type

nxpsiMessagePumpInterceptor.PnxMessagePumpInterceptor Type
nxpsiMessagePumpInterceptor Types Send Feedback
Syntax
Delphi
PnxMessagePumpInterceptor = ^TnxMessagePumpInterceptor;
File

nxpsiMessagePumpInterceptor

Description

This is type nxpsiMessagePumpInterceptor.PnxMessagePumpInterceptor.

Group

Types

Links
nxpsiMessagePumpInterceptor, Types


Variables

Variables
nxpsiMessagePumpInterceptor Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxpsiMessagePumpInterceptor Namespace

Variables
Name | Description
_MessagePump | This is variable nxpsiMessagePumpInterceptor._MessagePump.
_ReleasePadlock | This is variable nxpsiMessagePumpInterceptor._ReleasePadlock.
Links
nxpsiMessagePumpInterceptor Namespace, Variables


nxpsiMessagePumpInterceptor._MessagePump Variable

nxpsiMessagePumpInterceptor._MessagePump Variable
nxpsiMessagePumpInterceptor Variables Send Feedback
Syntax
Delphi
_MessagePump: TnxMessagePumpInterceptor;
File

nxpsiMessagePumpInterceptor

Description

This is variable nxpsiMessagePumpInterceptor._MessagePump.

Group

Variables

Links
nxpsiMessagePumpInterceptor, Variables


nxpsiMessagePumpInterceptor._ReleasePadlock Variable

nxpsiMessagePumpInterceptor._ReleasePadlock Variable
nxpsiMessagePumpInterceptor Variables Send Feedback
Syntax
Delphi
_ReleasePadlock: TnxPadlock;
File

nxpsiMessagePumpInterceptor

Description

This is variable nxpsiMessagePumpInterceptor._ReleasePadlock.

Group

Variables

Links
nxpsiMessagePumpInterceptor, Variables


Constants

Constants
Constants nxpsiMessagePumpInterceptor Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
NX_MAKECALL | This is constant nxpsiMessagePumpInterceptor.NX_MAKECALL.
Namespace

nxpsiMessagePumpInterceptor Namespace

Links
Constants, nxpsiMessagePumpInterceptor Namespace


nxpsiMessagePumpInterceptor.NX_MAKECALL Constant

nxpsiMessagePumpInterceptor.NX_MAKECALL Constant
nxpsiMessagePumpInterceptor Constants Send Feedback
Syntax
Delphi
NX_MAKECALL = WM_USER + $2000;
File

nxpsiMessagePumpInterceptor

Description

This is constant nxpsiMessagePumpInterceptor.NX_MAKECALL.

Group

Constants

Links
nxpsiMessagePumpInterceptor, Constants


nxptBasePooledTransport Namespace

nxptBasePooledTransport Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxptBasePooledTransport.

Classes
Name | Description
EnxPooledTransportException | This is class nxptBasePooledTransport.EnxPooledTransportException.
TnxBaseCallbackThread | This is class nxptBasePooledTransport.TnxBaseCallbackThread.
TnxBaseClientConnection | This is class nxptBasePooledTransport.TnxBaseClientConnection.
TnxBaseConnection | This is class nxptBasePooledTransport.TnxBaseConnection.
TnxBasePooledTransport | The base class for all transports that support connection pooling.
TnxBaseRemoteSession | This is class nxptBasePooledTransport.TnxBaseRemoteSession.
TnxBaseRemoteTransport | This is class nxptBasePooledTransport.TnxBaseRemoteTransport.
TnxBaseServerConnection | This is class nxptBasePooledTransport.TnxBaseServerConnection.
TnxBaseServerThread | This is class nxptBasePooledTransport.TnxBaseServerThread.
TnxFreedConnectionCleanupThread | This is class nxptBasePooledTransport.TnxFreedConnectionCleanupThread.
TnxHeartbeatThread | This is class nxptBasePooledTransport.TnxHeartbeatThread.
TnxLocalSessionCallback | This is class nxptBasePooledTransport.TnxLocalSessionCallback.
TnxRemoteSessionCallback | This is class nxptBasePooledTransport.TnxRemoteSessionCallback.
TnxWatchdogThread | This is class nxptBasePooledTransport.TnxWatchdogThread.
Constants
Name | Description
cConnectionKey | This is constant nxptBasePooledTransport.cConnectionKey.
nxc_AliveMarker | ALIV
nxc_MagicNumber_Session | RSES
nxc_MagicNumber_Transport | TRAN
nxDefaultHeartbeatInterval | This is constant nxptBasePooledTransport.nxDefaultHeartbeatInterval.
nxDefaultLostConnectionTimeout | This is constant nxptBasePooledTransport.nxDefaultLostConnectionTimeout.
nxDefaultWatchdogInterval | This is constant nxptBasePooledTransport.nxDefaultWatchdogInterval.
nxmtAttachTransport | This is constant nxptBasePooledTransport.nxmtAttachTransport.
nxmtError | This is constant nxptBasePooledTransport.nxmtError.
nxmtEstablishConnectionReq | This is constant nxptBasePooledTransport.nxmtEstablishConnectionReq.
nxmtEstablishConnectionRpy | This is constant nxptBasePooledTransport.nxmtEstablishConnectionRpy.
nxmtHeartbeat | This is constant nxptBasePooledTransport.nxmtHeartbeat.
nxmtPost | This is constant nxptBasePooledTransport.nxmtPost.
nxmtReply | This is constant nxptBasePooledTransport.nxmtReply.
nxmtReplyTransport | This is constant nxptBasePooledTransport.nxmtReplyTransport.
nxmtRequest | This is constant nxptBasePooledTransport.nxmtRequest.
nxmtRequestTransport | This is constant nxptBasePooledTransport.nxmtRequestTransport.
nxmtSetAsCallbackReq | This is constant nxptBasePooledTransport.nxmtSetAsCallbackReq.
nxmtSetAsCallbackRpy | This is constant nxptBasePooledTransport.nxmtSetAsCallbackRpy.
nxmtTerminateConnection | This is constant nxptBasePooledTransport.nxmtTerminateConnection.
nxmvCurrentVersion | This is constant nxptBasePooledTransport.nxmvCurrentVersion.
nxnmAttachServer | This is constant nxptBasePooledTransport.nxnmAttachServer.
rsCallbacksAreNotSupported | This is constant nxptBasePooledTransport.rsCallbacksAreNotSupported.
rsExplicitThreadNotSupported | This is constant nxptBasePooledTransport.rsExplicitThreadNotSupported.
rsRemoteTransportIsClosing | DOM-IGNORE-BEGIN
Functions
Name | Description
nxFreedConnectionCleanupAddRef |
nxFreedConnectionCleanupRelease |
nxPooledTransportCheckWaitingConnections | OS Thread Pool support
nxPooledTransportHeartBeat |
nxPooledTransportIoCompletionCallback | This is function nxptBasePooledTransport.nxPooledTransportIoCompletionCallback.
nxPooledTransportSetEvent |
nxPooledTransportStartConnection |
nxPooledTransportWatchdog |
Interfaces
Name | Description
InxInternalSessionCallback | This is class nxptBasePooledTransport.InxInternalSessionCallback.
Structs, Records, Enums
Name | Description
TnxIoCompletionQueueItem | This is record nxptBasePooledTransport.TnxIoCompletionQueueItem.
TnxnmAttachServerReq | This is record nxptBasePooledTransport.TnxnmAttachServerReq.
TnxnmAttachServerRpy | This is record nxptBasePooledTransport.TnxnmAttachServerRpy.
TnxReplyInfos | This is record nxptBasePooledTransport.TnxReplyInfos.
TnxServerConnectionOverlapped | This is record nxptBasePooledTransport.TnxServerConnectionOverlapped.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxIoCompletionQueueItem | This is type nxptBasePooledTransport.PnxIoCompletionQueueItem.
PnxnmAttachServerReq | This is type nxptBasePooledTransport.PnxnmAttachServerReq.
PnxnmAttachServerRpy | This is type nxptBasePooledTransport.PnxnmAttachServerRpy.
PnxReplyInfos | DOM-IGNORE-BEGIN
PnxServerConnectionOverlapped | This is type nxptBasePooledTransport.PnxServerConnectionOverlapped.
TnxBaseClientConnectionClass | This is type nxptBasePooledTransport.TnxBaseClientConnectionClass.
TnxBasePooledTransportClass | Class of TnxBasePooledTransport
TnxMessageReceived | This is type nxptBasePooledTransport.TnxMessageReceived.
TnxNetIdleEvent | Event type for Idle Event
Variables
Name | Description
_FreedConnectionCleanup | This is variable nxptBasePooledTransport._FreedConnectionCleanup.
_FreedConnectionCleanupRefCount | This is variable nxptBasePooledTransport._FreedConnectionCleanupRefCount.
_FreedConnectionHeads | This is variable nxptBasePooledTransport._FreedConnectionHeads.
_FreedConnectionPadlock | This is variable nxptBasePooledTransport._FreedConnectionPadlock.
_Interval | This is variable nxptBasePooledTransport._Interval.
_Mask | This is variable nxptBasePooledTransport._Mask.
_NetIdle | This is variable nxptBasePooledTransport._NetIdle.
_RemoteSessionPortal | This is variable nxptBasePooledTransport._RemoteSessionPortal.
_RemoteTransportPortal | This is variable nxptBasePooledTransport._RemoteTransportPortal.
csConnectionKey | initialized from cConnectionKey to make sure system locale doesn't mix things up, see InitConnectionKey
nxitvReplyInfos | This is variable nxptBasePooledTransport.nxitvReplyInfos.
UseIOCP | This is variable nxptBasePooledTransport.UseIOCP.
UseThreadPool | This is variable nxptBasePooledTransport.UseThreadPool.
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxptBasePooledTransport Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxPooledTransportException | This is class nxptBasePooledTransport.EnxPooledTransportException.
TnxBaseCallbackThread | This is class nxptBasePooledTransport.TnxBaseCallbackThread.
TnxBaseClientConnection | This is class nxptBasePooledTransport.TnxBaseClientConnection.
TnxBaseConnection | This is class nxptBasePooledTransport.TnxBaseConnection.
TnxBasePooledTransport | The base class for all transports that support connection pooling.
TnxBaseRemoteSession | This is class nxptBasePooledTransport.TnxBaseRemoteSession.
TnxBaseRemoteTransport | This is class nxptBasePooledTransport.TnxBaseRemoteTransport.
TnxBaseServerConnection | This is class nxptBasePooledTransport.TnxBaseServerConnection.
TnxBaseServerThread | This is class nxptBasePooledTransport.TnxBaseServerThread.
TnxFreedConnectionCleanupThread | This is class nxptBasePooledTransport.TnxFreedConnectionCleanupThread.
TnxHeartbeatThread | This is class nxptBasePooledTransport.TnxHeartbeatThread.
TnxLocalSessionCallback | This is class nxptBasePooledTransport.TnxLocalSessionCallback.
TnxRemoteSessionCallback | This is class nxptBasePooledTransport.TnxRemoteSessionCallback.
TnxWatchdogThread | This is class nxptBasePooledTransport.TnxWatchdogThread.
Namespace

nxptBasePooledTransport Namespace

Links
Classes, nxptBasePooledTransport Namespace, Legend


EnxPooledTransportException Class

EnxPooledTransportException Class
nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportExceptionnxptBasePooledTransport_EnxPooledTransportException
Syntax
Delphi
EnxPooledTransportException = class(EnxTransportException);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.EnxPooledTransportException.

Group

Classes

Links
nxptBasePooledTransport, Classes


TnxBaseCallbackThread Class

TnxBaseCallbackThread Class
TnxBaseCallbackThread Fields TnxBaseCallbackThread Methods TnxBaseCallbackThread Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseCallbackThreadnxptBasePooledTransport_TnxBaseCallbackThreadnxptBasePooledTransport_TnxBaseCallbackThreadnxptBasePooledTransport_TnxBaseCallbackThreadnxptBasePooledTransport_TnxBaseCallbackThread
Syntax
Delphi
TnxBaseCallbackThread = class(TnxInitThread);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseCallbackThread.

Group

Classes

Links
TnxBaseCallbackThread Fields, TnxBaseCallbackThread Methods, TnxBaseCallbackThread Members, nxptBasePooledTransport, Classes


TnxBaseCallbackThread Members

TnxBaseCallbackThread Members
TnxBaseCallbackThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxBaseCallbackThread.

Class

TnxBaseCallbackThread Class

Protected Fields
Name | Description
bctConnection | This is bctConnection, a member of class TnxBaseCallbackThread.
bctTransport | privat
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxBaseCallbackThread
Destroy |
Destroy |
Execute |
FreeInstance |
NewInstance |
Shutdown |
WaitForEx |
Links
TnxBaseCallbackThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxBaseCallbackThread.Create Constructor

TnxBaseCallbackThread.Create Constructor
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport);
Description

TnxBaseCallbackThread

Class

TnxBaseCallbackThread Class

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Class


TnxBaseCallbackThread Fields

TnxBaseCallbackThread Fields
TnxBaseCallbackThread Class Legend Protected Fields Send Feedback

The fields of the TnxBaseCallbackThread class are listed here.

Class

TnxBaseCallbackThread Class

Protected Fields
Name | Description
bctConnection | This is bctConnection, a member of class TnxBaseCallbackThread.
bctTransport | privat
Links
TnxBaseCallbackThread Class, Legend, Protected Fields


TnxBaseCallbackThread.bctConnection Field

TnxBaseCallbackThread.bctConnection Field
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Fields Send Feedback
Syntax
Delphi
bctConnection: TnxBaseClientConnection;
Description

This is bctConnection, a member of class TnxBaseCallbackThread.

Group

TnxBaseCallbackThread Fields

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Fields


TnxBaseCallbackThread.bctTransport Field

TnxBaseCallbackThread.bctTransport Field
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Fields Send Feedback
Syntax
Delphi
bctTransport: TnxBasePooledTransport;
Description

privat

Group

TnxBaseCallbackThread Fields

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Fields


TnxBaseCallbackThread Methods

TnxBaseCallbackThread Methods
TnxBaseCallbackThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseCallbackThread class are listed here.

Class

TnxBaseCallbackThread Class

Protected Methods
Name | Description
DoAfterExecute |
DoBeforeExecute |
InnerExecute |
Public Methods
Name | Description
Execute |
Shutdown |
Links
TnxBaseCallbackThread Class, Legend, Protected Methods, Public Methods


TnxBaseCallbackThread.DoAfterExecute Method

TnxBaseCallbackThread.DoAfterExecute Method
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Methods Send Feedback
Syntax
Delphi
procedure DoAfterExecute; override;
Group

TnxBaseCallbackThread Methods

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Methods


TnxBaseCallbackThread.DoBeforeExecute Method

TnxBaseCallbackThread.DoBeforeExecute Method
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxBaseCallbackThread Methods

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Methods


TnxBaseCallbackThread.Execute Method

TnxBaseCallbackThread.Execute Method
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Methods Send Feedback
Syntax
Delphi
procedure Execute; override;
Group

TnxBaseCallbackThread Methods

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Methods


TnxBaseCallbackThread.InnerExecute Method

TnxBaseCallbackThread.InnerExecute Method
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxBaseCallbackThread Methods

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Methods


TnxBaseCallbackThread.Shutdown Method

TnxBaseCallbackThread.Shutdown Method
TnxBaseCallbackThread Class TnxBaseCallbackThread Members nxptBasePooledTransport Namespace TnxBaseCallbackThread Methods Send Feedback
Syntax
Delphi
procedure Shutdown; virtual;
Group

TnxBaseCallbackThread Methods

Links
TnxBaseCallbackThread Class, TnxBaseCallbackThread Members, nxptBasePooledTransport Namespace, TnxBaseCallbackThread Methods


TnxBaseClientConnection Class

TnxBaseClientConnection Class
TnxBaseClientConnection Methods TnxBaseClientConnection Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseClientConnectionnxptBasePooledTransport_TnxBaseClientConnectionnxptBasePooledTransport_TnxBaseClientConnection
Syntax
Delphi
TnxBaseClientConnection = class(TnxBaseConnection);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseClientConnection.

Group

Classes

Links
TnxBaseClientConnection Methods, TnxBaseClientConnection Members, nxptBasePooledTransport, Classes


TnxBaseClientConnection Members

TnxBaseClientConnection Members
TnxBaseClientConnection Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseClientConnection.

Class

TnxBaseClientConnection Class

Protected Fields
Name | Description
bcActive | This is bcActive, a member of class TnxBaseConnection.
bcAlive | privat
bcDestroying | This is bcDestroying, a member of class TnxBaseConnection.
bcForcedDisconnect | This is bcForcedDisconnect, a member of class TnxBaseConnection.
bcNextFree | This is bcNextFree, a member of class TnxBaseConnection.
bcTransport | This is bcTransport, a member of class TnxBaseConnection.
Protected Methods
Name | Description
bcGetRemoteAddress | TnxBaseConnection
bcMessageReceived |
Public Methods
Name | Description
BeforeDestruction |
Create | TnxBaseClientConnection
Deactivate |
Destroy |
DoWrite | This is DoWrite, a member of class TnxBaseConnection.
ForceDisconnect | This is ForceDisconnect, a member of class TnxBaseConnection.
Free |
FreeInstance |
FreeInstance |
Initialize |
NewInstance | TnxObject
NewInstance |
Read | This is Read, a member of class TnxBaseClientConnection.
Read | This is the overview for the Read method overload.
Transact |
Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseConnection.
Transport | This is Transport, a member of class TnxBaseConnection.
Links
TnxBaseClientConnection Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseClientConnection.Create Constructor

TnxBaseClientConnection.Create Constructor
TnxBaseClientConnection Class TnxBaseClientConnection Members nxptBasePooledTransport Namespace TnxBaseClientConnection Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport); override;
Description

TnxBaseClientConnection

Class

TnxBaseClientConnection Class

Links
TnxBaseClientConnection Class, TnxBaseClientConnection Members, nxptBasePooledTransport Namespace, TnxBaseClientConnection Class


TnxBaseClientConnection.Destroy Destructor

TnxBaseClientConnection.Destroy Destructor
TnxBaseClientConnection Class TnxBaseClientConnection Members nxptBasePooledTransport Namespace TnxBaseClientConnection Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseClientConnection Class

Links
TnxBaseClientConnection Class, TnxBaseClientConnection Members, nxptBasePooledTransport Namespace, TnxBaseClientConnection Class


TnxBaseClientConnection Methods

TnxBaseClientConnection Methods
TnxBaseClientConnection Class Legend Public Methods Send Feedback

The methods of the TnxBaseClientConnection class are listed here.

Class

TnxBaseClientConnection Class

Public Methods
Name | Description
Deactivate |
Initialize |
Read | This is Read, a member of class TnxBaseClientConnection.
Links
TnxBaseClientConnection Class, Legend, Public Methods


TnxBaseClientConnection.Deactivate Method

TnxBaseClientConnection.Deactivate Method
TnxBaseClientConnection Class TnxBaseClientConnection Members nxptBasePooledTransport Namespace TnxBaseClientConnection Methods Send Feedback
Syntax
Delphi
procedure Deactivate; override;
Group

TnxBaseClientConnection Methods

Links
TnxBaseClientConnection Class, TnxBaseClientConnection Members, nxptBasePooledTransport Namespace, TnxBaseClientConnection Methods


TnxBaseClientConnection.Initialize Method

TnxBaseClientConnection.Initialize Method
TnxBaseClientConnection Class TnxBaseClientConnection Members nxptBasePooledTransport Namespace TnxBaseClientConnection Methods Send Feedback
Syntax
Delphi
procedure Initialize; virtual;
Group

TnxBaseClientConnection Methods

Links
TnxBaseClientConnection Class, TnxBaseClientConnection Members, nxptBasePooledTransport Namespace, TnxBaseClientConnection Methods


TnxBaseClientConnection.Read Method

TnxBaseClientConnection.Read Method
TnxBaseClientConnection Class TnxBaseClientConnection Members nxptBasePooledTransport Namespace TnxBaseClientConnection Methods Send Feedback
Syntax
Delphi
procedure Read(aMessageReceived: TnxMessageReceived); virtual; abstract; overload;
Description

This is Read, a member of class TnxBaseClientConnection.

Group

TnxBaseClientConnection Methods

Links
TnxBaseClientConnection Class, TnxBaseClientConnection Members, nxptBasePooledTransport Namespace, TnxBaseClientConnection Methods


TnxBaseConnection Class

TnxBaseConnection Class
TnxBaseConnection Fields TnxBaseConnection Methods TnxBaseConnection Properties TnxBaseConnection Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseConnectionnxptBasePooledTransport_TnxBaseConnection
Syntax
Delphi
TnxBaseConnection = class(TnxObject);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseConnection.

Group

Classes

Links
TnxBaseConnection Fields, TnxBaseConnection Methods, TnxBaseConnection Properties, TnxBaseConnection Members, nxptBasePooledTransport, Classes


TnxBaseConnection Members

TnxBaseConnection Members
TnxBaseConnection Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseConnection.

Class

TnxBaseConnection Class

Protected Fields
Name | Description
bcActive | This is bcActive, a member of class TnxBaseConnection.
bcAlive | privat
bcDestroying | This is bcDestroying, a member of class TnxBaseConnection.
bcForcedDisconnect | This is bcForcedDisconnect, a member of class TnxBaseConnection.
bcNextFree | This is bcNextFree, a member of class TnxBaseConnection.
bcTransport | This is bcTransport, a member of class TnxBaseConnection.
Protected Methods
Name | Description
bcGetRemoteAddress | TnxBaseConnection
bcMessageReceived |
Public Methods
Name | Description
BeforeDestruction |
Create |
Deactivate | This is Deactivate, a member of class TnxBaseConnection.
DoWrite | This is DoWrite, a member of class TnxBaseConnection.
ForceDisconnect | This is ForceDisconnect, a member of class TnxBaseConnection.
Free |
FreeInstance |
NewInstance |
Read | This is the overview for the Read method overload.
Transact |
Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseConnection.
Transport | This is Transport, a member of class TnxBaseConnection.
Links
TnxBaseConnection Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseConnection.Create Constructor

TnxBaseConnection.Create Constructor
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport); virtual;
Class

TnxBaseConnection Class

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Class


TnxBaseConnection Fields

TnxBaseConnection Fields
TnxBaseConnection Class Legend Protected Fields Send Feedback

The fields of the TnxBaseConnection class are listed here.

Class

TnxBaseConnection Class

Protected Fields
Name | Description
bcActive | This is bcActive, a member of class TnxBaseConnection.
bcAlive | privat
bcDestroying | This is bcDestroying, a member of class TnxBaseConnection.
bcForcedDisconnect | This is bcForcedDisconnect, a member of class TnxBaseConnection.
bcNextFree | This is bcNextFree, a member of class TnxBaseConnection.
bcTransport | This is bcTransport, a member of class TnxBaseConnection.
Links
TnxBaseConnection Class, Legend, Protected Fields


TnxBaseConnection.bcActive Field

TnxBaseConnection.bcActive Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcActive: Integer;
Description

This is bcActive, a member of class TnxBaseConnection.

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection.bcAlive Field

TnxBaseConnection.bcAlive Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcAlive: Integer;
Description

privat

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection.bcDestroying Field

TnxBaseConnection.bcDestroying Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcDestroying: Integer;
Description

This is bcDestroying, a member of class TnxBaseConnection.

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection.bcForcedDisconnect Field

TnxBaseConnection.bcForcedDisconnect Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcForcedDisconnect: Boolean;
Description

This is bcForcedDisconnect, a member of class TnxBaseConnection.

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection.bcNextFree Field

TnxBaseConnection.bcNextFree Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcNextFree: TnxBaseConnection;
Description

This is bcNextFree, a member of class TnxBaseConnection.

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection.bcTransport Field

TnxBaseConnection.bcTransport Field
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Fields Send Feedback
Syntax
Delphi
bcTransport: TnxBasePooledTransport;
Description

This is bcTransport, a member of class TnxBaseConnection.

Group

TnxBaseConnection Fields

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Fields


TnxBaseConnection Methods

TnxBaseConnection Methods
TnxBaseConnection Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseConnection class are listed here.

Class

TnxBaseConnection Class

Protected Methods
Name | Description
bcGetRemoteAddress | TnxBaseConnection
bcMessageReceived |
Public Methods
Name | Description
BeforeDestruction |
Deactivate | This is Deactivate, a member of class TnxBaseConnection.
DoWrite | This is DoWrite, a member of class TnxBaseConnection.
ForceDisconnect | This is ForceDisconnect, a member of class TnxBaseConnection.
Free |
FreeInstance |
NewInstance |
Read | This is the overview for the Read method overload.
Transact |
Links
TnxBaseConnection Class, Legend, Protected Methods, Public Methods


TnxBaseConnection.bcGetRemoteAddress Method

TnxBaseConnection.bcGetRemoteAddress Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
function bcGetRemoteAddress: string; virtual;
Description

TnxBaseConnection

Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.bcMessageReceived Method

TnxBaseConnection.bcMessageReceived Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure bcMessageReceived; virtual;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.BeforeDestruction Method

TnxBaseConnection.BeforeDestruction Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.Deactivate Method

TnxBaseConnection.Deactivate Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure Deactivate; virtual; abstract;
Description

This is Deactivate, a member of class TnxBaseConnection.

Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.DoWrite Method

TnxBaseConnection.DoWrite Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure DoWrite(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aMsgType: Byte; aErrorCode: TnxResult; aCompressType: Byte; aUncompressedSize: TnxWord32; aBuffer: Pointer; aBufferSize: TnxWord32); virtual; abstract;
Description

This is DoWrite, a member of class TnxBaseConnection.

Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.ForceDisconnect Method

TnxBaseConnection.ForceDisconnect Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure ForceDisconnect; virtual; abstract;
Description

This is ForceDisconnect, a member of class TnxBaseConnection.

Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.Free Method

TnxBaseConnection.Free Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure Free;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.FreeInstance Method

TnxBaseConnection.FreeInstance Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection.NewInstance Method

TnxBaseConnection.NewInstance Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


Read Method

Read Method
TnxBaseConnection Methods Send Feedback

This is the overview for the Read method overload.

Overload List
Name | Description
TnxBaseConnection.Read (TnxBaseHeader, Pointer, TnxWord32) | This is Read, a member of class TnxBaseConnection.
TnxBaseConnection.Read (TnxReplyCallback, Pointer) | This is Read, a member of class TnxBaseConnection.
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Methods


TnxBaseConnection.Read Method (TnxBaseHeader, Pointer, TnxWord32)

TnxBaseConnection.Read Method (TnxBaseHeader, Pointer, TnxWord32)
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace Read Method Send Feedback
Syntax
Delphi
function Read(var aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32): TnxWord32; virtual; abstract; overload;
Description

This is Read, a member of class TnxBaseConnection.

Group

Read Method

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, Read Method


TnxBaseConnection.Read Method (TnxReplyCallback, Pointer)

TnxBaseConnection.Read Method (TnxReplyCallback, Pointer)
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace Read Method Send Feedback
Syntax
Delphi
procedure Read(aCallback: TnxReplyCallback; aReplyCookie: Pointer); virtual; abstract; overload;
Description

This is Read, a member of class TnxBaseConnection.

Group

Read Method

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, Read Method


TnxBaseConnection.Transact Method

TnxBaseConnection.Transact Method
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Methods Send Feedback
Syntax
Delphi
procedure Transact(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aMsgType: Byte; aErrorCode: TnxResult; aCompressType: Byte; aUncompressedSize: TnxWord32; aBuffer: Pointer; aBufferSize: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer); virtual;
Group

TnxBaseConnection Methods

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Methods


TnxBaseConnection Properties

TnxBaseConnection Properties
TnxBaseConnection Class Legend Public Properties Send Feedback

The properties of the TnxBaseConnection class are listed here.

Class

TnxBaseConnection Class

Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseConnection.
Transport | This is Transport, a member of class TnxBaseConnection.
Links
TnxBaseConnection Class, Legend, Public Properties


TnxBaseConnection.RemoteAddress Property

TnxBaseConnection.RemoteAddress Property
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Properties Send Feedback
Syntax
Delphi
property RemoteAddress: string;
Description

This is RemoteAddress, a member of class TnxBaseConnection.

Group

TnxBaseConnection Properties

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Properties


TnxBaseConnection.Transport Property

TnxBaseConnection.Transport Property
TnxBaseConnection Class TnxBaseConnection Members nxptBasePooledTransport Namespace TnxBaseConnection Properties Send Feedback
Syntax
Delphi
property Transport: TnxBasePooledTransport;
Description

This is Transport, a member of class TnxBaseConnection.

Group

TnxBaseConnection Properties

Links
TnxBaseConnection Class, TnxBaseConnection Members, nxptBasePooledTransport Namespace, TnxBaseConnection Properties


TnxBasePooledTransport Class

TnxBasePooledTransport Class
TnxBasePooledTransport Fields TnxBasePooledTransport Methods TnxBasePooledTransport Properties TnxBasePooledTransport Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransportnxptBasePooledTransport_TnxBasePooledTransport
Syntax
Delphi
TnxBasePooledTransport = class(TnxBaseDirectTransport);
File

nxptBasePooledTransport

Description

The base class for all transports that support connection pooling.

Group

Classes

Links
TnxBasePooledTransport Fields, TnxBasePooledTransport Methods, TnxBasePooledTransport Properties, TnxBasePooledTransport Members, nxptBasePooledTransport, Classes


TnxBasePooledTransport Members

TnxBasePooledTransport Members
TnxBasePooledTransport Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxBasePooledTransport.

Class

TnxBasePooledTransport Class

Protected Fields
Name | Description
btActualBytesReceived | This is btActualBytesReceived, a member of class TnxBaseTransport.
btActualBytesSent | This is btActualBytesSent, a member of class TnxBaseTransport.
btAvailableConnections | This is btAvailableConnections, a member of class TnxBasePooledTransport.
btBlowFish | This is btBlowFish, a member of class TnxBasePooledTransport.
btBlowFishPadlock | This is btBlowFishPadlock, a member of class TnxBasePooledTransport.
btCallbackThreadCount | This is btCallbackThreadCount, a member of class TnxBasePooledTransport.
btCallbackThreadPriority | This is btCallbackThreadPriority, a member of class TnxBasePooledTransport.
btCallbackThreads | This is btCallbackThreads, a member of class TnxBasePooledTransport.
btClientConnections | This is btClientConnections, a member of class TnxBasePooledTransport.
btCmdHandler | This is btCmdHandler, a member of class TnxBaseTransport.
btCompressLimit | This is btCompressLimit, a member of class TnxBasePooledTransport.
btCompressTime | This is btCompressTime, a member of class TnxBaseTransport.
btCompressType | This is btCompressType, a member of class TnxBasePooledTransport.
btConcurrentIOCPThreads | This is btConcurrentIOCPThreads, a member of class TnxBasePooledTransport.
btFailed | This is btFailed, a member of class TnxBasePooledTransport.
btHeartbeatInterval | This is btHeartbeatInterval, a member of class TnxBasePooledTransport.
btHeartbeatThread | This is btHeartbeatThread, a member of class TnxBasePooledTransport.
btHeartbeatThreadPriority | This is btHeartbeatThreadPriority, a member of class TnxBasePooledTransport.
btHeartBeatTimer | This is btHeartBeatTimer, a member of class TnxBasePooledTransport.
btIoCompletionPortHandle | This is btIoCompletionPortHandle, a member of class TnxBasePooledTransport.
btIoCompletionQueueEvent | This is btIoCompletionQueueEvent, a member of class TnxBasePooledTransport.
btIoCompletionQueueHead | This is btIoCompletionQueueHead, a member of class TnxBasePooledTransport.
btIoCompletionQueueLock | This is btIoCompletionQueueLock, a member of class TnxBasePooledTransport.
btIoCompletionQueueTail | This is btIoCompletionQueueTail, a member of class TnxBasePooledTransport.
btKeepStats | This is btKeepStats, a member of class TnxBaseTransport.
btLastReceived | This is btLastReceived, a member of class TnxBaseTransport.
btLastSent | This is btLastSent, a member of class TnxBaseTransport.
btLogOptions | This is btLogOptions, a member of class TnxBaseTransport.
btLostConnectionTimeout | This is btLostConnectionTimeout, a member of class TnxBasePooledTransport.
btMaxBytesPerSecond | This is btMaxBytesPerSecond, a member of class TnxBaseTransport.
btMessagesReceived | This is btMessagesReceived, a member of class TnxBaseTransport.
btMessagesSent | This is btMessagesSent, a member of class TnxBaseTransport.
btMode | This is btMode, a member of class TnxBaseTransport.
btMsgCount | This is btMsgCount, a member of class TnxBaseTransport.
btOnAddSession | This is btOnAddSession, a member of class TnxBaseTransport.
btOnChooseServer | This is btOnChooseServer, a member of class TnxBaseTransport.
btOnConnectionLost | This is btOnConnectionLost, a member of class TnxBaseTransport.
btOnFindServers | This is btOnFindServers, a member of class TnxBaseTransport.
btOnRemoveSession | This is btOnRemoveSession, a member of class TnxBaseTransport.
btOverlappedClient | This is btOverlappedClient, a member of class TnxBasePooledTransport.
btPingTime | This is btPingTime, a member of class TnxBaseTransport.
btPort | This is btPort, a member of class TnxBasePooledTransport.
btProcessing | This is btProcessing, a member of class TnxBasePooledTransport.
btProcessingWatchdog | private
btReceivedThisSecond | This is btReceivedThisSecond, a member of class TnxBaseTransport.
btRemoteSessions | This is btRemoteSessions, a member of class TnxBasePooledTransport.
btRemoteTransports | This is btRemoteTransports, a member of class TnxBasePooledTransport.
btRespondToBroadcasts | This is btRespondToBroadcasts, a member of class TnxBaseTransport.
btSentThisSecond | private.
btServerConnections | This is btServerConnections, a member of class TnxBasePooledTransport.
btServerNameDesigntime | This is btServerNameDesigntime, a member of class TnxBaseTransport.
btServerNameRuntime | This is btServerNameRuntime, a member of class TnxBaseTransport.
btServerStarted | This is btServerStarted, a member of class TnxBasePooledTransport.
btServerThreadPriority | This is btServerThreadPriority, a member of class TnxBasePooledTransport.
btServerThreads | This is btServerThreads, a member of class TnxBasePooledTransport.
btStatsPadLock | This is btStatsPadLock, a member of class TnxBaseTransport.
btThreadPriorityMax | This is btThreadPriorityMax, a member of class TnxBaseTransport.
btThreadPriorityMin | This is btThreadPriorityMin, a member of class TnxBaseTransport.
btTimeout | This is btTimeout, a member of class TnxBaseTransport.
btUncompressedBytesReceived | This is btUncompressedBytesReceived, a member of class TnxBaseTransport.
btUncompressedBytesSent | This is btUncompressedBytesSent, a member of class TnxBaseTransport.
btUnCompressTime | This is btUnCompressTime, a member of class TnxBaseTransport.
btWaitingThreads | This is btWaitingThreads, a member of class TnxBasePooledTransport.
btWatchdogInterval | This is btWatchdogInterval, a member of class TnxBasePooledTransport.
btWatchdogThread | This is btWatchdogThread, a member of class TnxBasePooledTransport.
btWatchdogThreadPriority | This is btWatchdogThreadPriority, a member of class TnxBasePooledTransport.
btWatchDogTimer | This is btWatchDogTimer, a member of class TnxBasePooledTransport.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
btAddCallbackThread |
btAddConnection | This is the overview for the btAddConnection method overload.
btAddRemoteTransport |
btAddServerThread |
btAddSession | TnxBaseTransport
btAttachTransport |
btBreath |
btCheckHeartbeat |
btCheckListener |
btCheckSender |
btCheckServerName |
btCheckupServerName |
btCheckWaitingConnections |
btChooseServer |
btConnectionLost |
btCreateCallbackThread |
btDetectServer |
btDoReadThrottle |
btDoWriteThrottle |
btEstablishConnection |
btFindServerName |
btFindServers |
btGetActualBytesReceived |
btGetActualBytesSent |
btGetClientConnection |
btGetClientConnectionClass | This is btGetClientConnectionClass, a member of class TnxBasePooledTransport.
btGetCompressTime |
btGetConnectionsName |
btGetMaxBytesPerSecond |
btGetMessagesReceived |
btGetMessagesSent |
btGetPingTime |
btGetQueuedCompletionStatus |
btGetServerGUID |
btGetServername |
btGetUncompressedBytesReceived |
btGetUncompressedBytesSent |
btGetUncompressTime |
btHandleCompressedReply |
btHandleErrorMessage |
btHeartbeatReceived |
btIncStats |
btInternalGetSessionCallback |
btInternalReply | This method is called from TnxBasePooledTransport.Reply. It must send the reply to the client. The base implementation verifies the transport is started and is listening.
btLimitThreadPriority |
btMessageReceived |
btPayloadReceived |
btProcess |
btQueueIoCompleted |
btRemoveCallbackThread |
btRemoveConnection | This is the overview for the btRemoveConnection method overload.
btRemoveRemoteTransport |
btRemoveServerThread |
btRemoveSession |
btRequestTransport |
btSendHeartbeat |
btSessionFailed |
btSetAsCallback |
btSetCallbackThreadCount |
btSetCmdHandler |
btSetConcurrentIOCPThreads |
btSetMaxBytesPerSecond |
btSetMode |
btSetPingTime |
btSetPort |
btSetRespondToBroadcasts |
btSetServername |
btSetServerNameDesigntime |
btSetServerNameRuntime |
btStoreSelfInThreadvar |
btTerminateConnection |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded | This is Loaded, a member of class TnxStateComponent.
Loaded |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowLastStartErrorInStats |
scShowUpTime |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Fields
Name | Description
btTransportID | TEST DOM-IGNORE-BEGIN
btTransportMarker | This is btTransportMarker, a member of class TnxBasePooledTransport.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
BeginBroadcast | This function returns an InxActiveBroadcast and will start sending out server discovery broadcast every aInterval seconds. The broadcasting can be suspended or stopped using the returned InxActiveBroadcast interface. To get an event triggered for each reply received from a server, pass in an InxBroadcastReplyHandler. The ReplyReceived method of the passed in aHandler will be called.
Broadcast | TnxBasePooledTransport
btDoCallBack | This function executes a callback function with the given parameters.
ClearStats | Resets all internal stats.
ClearStats | This function resets all statistics for the transport.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
ConnectionCount |
Create | constructor
CurrentTransport | This function returns the currently active transport.
Destroy | destructor
DoLoadConfig | Loads persisted settings.
EstablishConnection |
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetBoundAddresses | This function returns a list of addresses for the transport.
GetComponentID |
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetName | This function returns the name of the transport.
GetNetIdle |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetServerNames | This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.
GetSessionCallback | This function returns an interface that can be used to send callbacks to the session that initiated the currently active call. May return nil.
GetStatsCaptions | see TnxComponent.GetStatsCaptions
GetStatsValues | see TnxComponent.GetStatsValues
IsConnected |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
Post |
ProtocolName | This function returns the name of the transport.
Reply | This function is called to reply to a request
Request |
ResetMsgCount | This function sets the MsgCount stats to 0.
SaveConfig |
SaveSettingsToStream |
SetNetIdle | DOM-IGNORE-BEGIN
Sleep | This function forces the transport to sleep for aTimeOut msec.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TerminateConnection |
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Write |
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
ActualBytesReceived | The number of bytes received since the last clearing.
ActualBytesSent | The number of bytes sent since the last clearing.
CallbackThreadCount | Number of active callback threads.
CallbackThreadPriority | Priority of the callback thread.
CompressTime | The total time used for compressing data.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
MessagesReceived | The number of Messages received since the last clearing.
MessagesSent | The number of Messages sent since the last clearing.
MsgCount | The total number of messages transferred.
SavedActive | Can be used to save a certain state.
ServerGUID | This is ServerGUID, a member of class TnxBaseTransport.
ServerName | The Server Name. If in listening mode it's the name of the clients have to connect to. In sending mode it's the name the transport gets connected to.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
UncompressedBytesReceived | The number of bytes received after uncompression since the last clearing.
UncompressedBytesSent | The number of bytes sent after uncompression since the last clearing.
UncompressTime | The total time used for uncompressing data.
Published Events
Name | Description
OnAddSession | OnAddSession is called every time a session connects to the transport if it is in listening mode.
OnChooseServer | OnChooseServer is called in sending mode, if more than one server was found for broadcast
OnConnectionLost | OnConnectionLost is called if the transport detects a drop of a connection.
OnFindServers | OnFindServers is called before and after broadcasting for servers.
OnRemoveSession | OnAddSession is called every time a session disconnects from a transport if it is in listening mode.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CommandHandler | This property points to the connected Command Handler.
CompressLimit | Number of minimum length of the message for compression. If the message is shorter, compression is not used.
CompressType | The type of compression to use. Must be a registered compression engine id! The registered IDs available in a standard NexusDB Server: 0 - No compression 1..9 - Zip compression, Level 1-9 (lower level is faster, compressed size of data slightly larger ) 10 - RLE compression (Run Length Encoding) 11..19 - Lz4 compression, Level 1 to 9 (lower level is faster, compressed size of data slightly larger ) The currently recommended CompressType is 11 (eg Lz4 level 1)
ConcurrentIOCPThreads | Number of IO Completion Port threads. Ideally the number of processors in the system.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
EventLogOptions | The log options for the event.
HeartbeatInterval | The interval between keep alive heartbeat checks in ms.
HeartbeatThreadPriority | The priority of the "Heartbeat" background thread.
KeepStats | Should the stats be updated or not. On high volume servers on the edge of capacity switch this off
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
LostConnectionTimeout | This is LostConnectionTimeout, a member of class TnxBasePooledTransport.
MaxBytesPerSecond | This is a maximum bytes per second setting for the transport. It is experimental and helps to test the transport for slow connections.
Mode | The mode of the transport.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
OverlappedClient | True if the transport uses/supports overlapped IO
PingTime | This is a minimum turnaround time setting in msec for the transport. It is experimental and helps to test the transport for slow connections.
Port | The "Port" of the thread.
RespondToBroadcasts | If the server is in listening it responds to broadcast requests if this property is set to true.
ServerNameDesigntime | This is the Server Name property at design time.
ServerNameRuntime | This is the Server Name property at runtime.
ServerThreadPriority | The priority of the server thread.
ThreadPriorityMax | Maximum possible Threadpriority
ThreadPriorityMin | Minimal possible Threadpriority
Timeout | The timeout of the transport in msec.
Version | Version of the component.
WatchdogInterval | The interval between keep alive watchdog checks in ms.
WatchdogThreadPriority | The priority of the "Watchdog" background thread.
Links
TnxBasePooledTransport Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties, Published Events, Published Properties


TnxBasePooledTransport.Create Constructor

TnxBasePooledTransport.Create Constructor
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Class Send Feedback
Syntax
Delphi
constructor Create(AOwner: TComponent); override;
Description

constructor

Class

TnxBasePooledTransport Class

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Class


TnxBasePooledTransport.Destroy Destructor

TnxBasePooledTransport.Destroy Destructor
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor

Class

TnxBasePooledTransport Class

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Class


TnxBasePooledTransport Fields

TnxBasePooledTransport Fields
TnxBasePooledTransport Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxBasePooledTransport class are listed here.

Class

TnxBasePooledTransport Class

Protected Fields
Name | Description
btAvailableConnections | This is btAvailableConnections, a member of class TnxBasePooledTransport.
btBlowFish | This is btBlowFish, a member of class TnxBasePooledTransport.
btBlowFishPadlock | This is btBlowFishPadlock, a member of class TnxBasePooledTransport.
btCallbackThreadCount | This is btCallbackThreadCount, a member of class TnxBasePooledTransport.
btCallbackThreadPriority | This is btCallbackThreadPriority, a member of class TnxBasePooledTransport.
btCallbackThreads | This is btCallbackThreads, a member of class TnxBasePooledTransport.
btClientConnections | This is btClientConnections, a member of class TnxBasePooledTransport.
btCompressLimit | This is btCompressLimit, a member of class TnxBasePooledTransport.
btCompressType | This is btCompressType, a member of class TnxBasePooledTransport.
btConcurrentIOCPThreads | This is btConcurrentIOCPThreads, a member of class TnxBasePooledTransport.
btFailed | This is btFailed, a member of class TnxBasePooledTransport.
btHeartbeatInterval | This is btHeartbeatInterval, a member of class TnxBasePooledTransport.
btHeartbeatThread | This is btHeartbeatThread, a member of class TnxBasePooledTransport.
btHeartbeatThreadPriority | This is btHeartbeatThreadPriority, a member of class TnxBasePooledTransport.
btHeartBeatTimer | This is btHeartBeatTimer, a member of class TnxBasePooledTransport.
btIoCompletionPortHandle | This is btIoCompletionPortHandle, a member of class TnxBasePooledTransport.
btIoCompletionQueueEvent | This is btIoCompletionQueueEvent, a member of class TnxBasePooledTransport.
btIoCompletionQueueHead | This is btIoCompletionQueueHead, a member of class TnxBasePooledTransport.
btIoCompletionQueueLock | This is btIoCompletionQueueLock, a member of class TnxBasePooledTransport.
btIoCompletionQueueTail | This is btIoCompletionQueueTail, a member of class TnxBasePooledTransport.
btLostConnectionTimeout | This is btLostConnectionTimeout, a member of class TnxBasePooledTransport.
btOverlappedClient | This is btOverlappedClient, a member of class TnxBasePooledTransport.
btPort | This is btPort, a member of class TnxBasePooledTransport.
btProcessing | This is btProcessing, a member of class TnxBasePooledTransport.
btProcessingWatchdog | private
btRemoteSessions | This is btRemoteSessions, a member of class TnxBasePooledTransport.
btRemoteTransports | This is btRemoteTransports, a member of class TnxBasePooledTransport.
btServerConnections | This is btServerConnections, a member of class TnxBasePooledTransport.
btServerStarted | This is btServerStarted, a member of class TnxBasePooledTransport.
btServerThreadPriority | This is btServerThreadPriority, a member of class TnxBasePooledTransport.
btServerThreads | This is btServerThreads, a member of class TnxBasePooledTransport.
btWaitingThreads | This is btWaitingThreads, a member of class TnxBasePooledTransport.
btWatchdogInterval | This is btWatchdogInterval, a member of class TnxBasePooledTransport.
btWatchdogThread | This is btWatchdogThread, a member of class TnxBasePooledTransport.
btWatchdogThreadPriority | This is btWatchdogThreadPriority, a member of class TnxBasePooledTransport.
btWatchDogTimer | This is btWatchDogTimer, a member of class TnxBasePooledTransport.
Public Fields
Name | Description
btTransportID | TEST DOM-IGNORE-BEGIN
btTransportMarker | This is btTransportMarker, a member of class TnxBasePooledTransport.
Links
TnxBasePooledTransport Class, Legend, Protected Fields, Public Fields


TnxBasePooledTransport.btAvailableConnections Field

TnxBasePooledTransport.btAvailableConnections Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btAvailableConnections: TnxThreadSafeStack;
Description

This is btAvailableConnections, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btBlowFish Field

TnxBasePooledTransport.btBlowFish Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btBlowFish: TnxBlowFishRC4;
Description

This is btBlowFish, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btBlowFishPadlock Field

TnxBasePooledTransport.btBlowFishPadlock Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btBlowFishPadlock: TnxPadlock;
Description

This is btBlowFishPadlock, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btCallbackThreadCount Field

TnxBasePooledTransport.btCallbackThreadCount Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btCallbackThreadCount: Byte;
Description

This is btCallbackThreadCount, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btCallbackThreadPriority Field

TnxBasePooledTransport.btCallbackThreadPriority Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btCallbackThreadPriority: TThreadPriority;
Description

This is btCallbackThreadPriority, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btCallbackThreads Field

TnxBasePooledTransport.btCallbackThreads Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btCallbackThreads: TnxListPadlock;
Description

This is btCallbackThreads, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btClientConnections Field

TnxBasePooledTransport.btClientConnections Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btClientConnections: TnxListPadlock;
Description

This is btClientConnections, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btCompressLimit Field

TnxBasePooledTransport.btCompressLimit Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btCompressLimit: TnxWord32;
Description

This is btCompressLimit, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btCompressType Field

TnxBasePooledTransport.btCompressType Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btCompressType: Byte;
Description

This is btCompressType, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btConcurrentIOCPThreads Field

TnxBasePooledTransport.btConcurrentIOCPThreads Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btConcurrentIOCPThreads: Byte;
Description

This is btConcurrentIOCPThreads, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btFailed Field

TnxBasePooledTransport.btFailed Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btFailed: Boolean;
Description

This is btFailed, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btHeartbeatInterval Field

TnxBasePooledTransport.btHeartbeatInterval Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btHeartbeatInterval: TnxWord32;
Description

This is btHeartbeatInterval, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btHeartbeatThread Field

TnxBasePooledTransport.btHeartbeatThread Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btHeartbeatThread: TnxHeartbeatThread;
Description

This is btHeartbeatThread, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btHeartbeatThreadPriority Field

TnxBasePooledTransport.btHeartbeatThreadPriority Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btHeartbeatThreadPriority: TThreadPriority;
Description

This is btHeartbeatThreadPriority, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btHeartBeatTimer Field

TnxBasePooledTransport.btHeartBeatTimer Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btHeartBeatTimer: THandle;
Description

This is btHeartBeatTimer, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btIoCompletionPortHandle Field

TnxBasePooledTransport.btIoCompletionPortHandle Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btIoCompletionPortHandle: THandle;
Description

This is btIoCompletionPortHandle, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btIoCompletionQueueEvent Field

TnxBasePooledTransport.btIoCompletionQueueEvent Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btIoCompletionQueueEvent: TnxEvent;
Description

This is btIoCompletionQueueEvent, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btIoCompletionQueueHead Field

TnxBasePooledTransport.btIoCompletionQueueHead Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btIoCompletionQueueHead: PnxIoCompletionQueueItem;
Description

This is btIoCompletionQueueHead, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btIoCompletionQueueLock Field

TnxBasePooledTransport.btIoCompletionQueueLock Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btIoCompletionQueueLock: TnxPadlock;
Description

This is btIoCompletionQueueLock, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btIoCompletionQueueTail Field

TnxBasePooledTransport.btIoCompletionQueueTail Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btIoCompletionQueueTail: PnxIoCompletionQueueItem;
Description

This is btIoCompletionQueueTail, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btLostConnectionTimeout Field

TnxBasePooledTransport.btLostConnectionTimeout Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btLostConnectionTimeout: TnxWord32;
Description

This is btLostConnectionTimeout, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btOverlappedClient Field

TnxBasePooledTransport.btOverlappedClient Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btOverlappedClient: Boolean;
Description

This is btOverlappedClient, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btPort Field

TnxBasePooledTransport.btPort Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btPort: TnxWord16;
Description

This is btPort, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btProcessing Field

TnxBasePooledTransport.btProcessing Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btProcessing: Integer;
Description

This is btProcessing, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btProcessingWatchdog Field

TnxBasePooledTransport.btProcessingWatchdog Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btProcessingWatchdog: Integer;
Description

private

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btRemoteSessions Field

TnxBasePooledTransport.btRemoteSessions Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btRemoteSessions: TnxListPortal;
Description

This is btRemoteSessions, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btRemoteTransports Field

TnxBasePooledTransport.btRemoteTransports Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btRemoteTransports: TnxListPadlock;
Description

This is btRemoteTransports, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btServerConnections Field

TnxBasePooledTransport.btServerConnections Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btServerConnections: TnxListPadlock;
Description

This is btServerConnections, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btServerStarted Field

TnxBasePooledTransport.btServerStarted Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btServerStarted: Boolean;
Description

This is btServerStarted, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btServerThreadPriority Field

TnxBasePooledTransport.btServerThreadPriority Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btServerThreadPriority: TThreadPriority;
Description

This is btServerThreadPriority, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btServerThreads Field

TnxBasePooledTransport.btServerThreads Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btServerThreads: TnxListPadlock;
Description

This is btServerThreads, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btTransportID Field

TnxBasePooledTransport.btTransportID Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btTransportID: TnxTransportID;
Description

TEST DOM-IGNORE-BEGIN

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btTransportMarker Field

TnxBasePooledTransport.btTransportMarker Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btTransportMarker: TnxWord32;
Description

This is btTransportMarker, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btWaitingThreads Field

TnxBasePooledTransport.btWaitingThreads Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btWaitingThreads: Integer;
Description

This is btWaitingThreads, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btWatchdogInterval Field

TnxBasePooledTransport.btWatchdogInterval Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btWatchdogInterval: TnxWord32;
Description

This is btWatchdogInterval, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btWatchdogThread Field

TnxBasePooledTransport.btWatchdogThread Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btWatchdogThread: TnxWatchdogThread;
Description

This is btWatchdogThread, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btWatchdogThreadPriority Field

TnxBasePooledTransport.btWatchdogThreadPriority Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btWatchdogThreadPriority: TThreadPriority;
Description

This is btWatchdogThreadPriority, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport.btWatchDogTimer Field

TnxBasePooledTransport.btWatchDogTimer Field
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Fields Send Feedback
Syntax
Delphi
btWatchDogTimer: THandle;
Description

This is btWatchDogTimer, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Fields

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Fields


TnxBasePooledTransport Methods

TnxBasePooledTransport Methods
TnxBasePooledTransport Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBasePooledTransport class are listed here.

Class

TnxBasePooledTransport Class

Protected Methods
Name | Description
btAddCallbackThread |
btAddConnection | This is the overview for the btAddConnection method overload.
btAddRemoteTransport |
btAddServerThread |
btAttachTransport |
btBreath |
btCheckHeartbeat |
btCheckWaitingConnections |
btCreateCallbackThread |
btEstablishConnection |
btGetClientConnection |
btGetClientConnectionClass | This is btGetClientConnectionClass, a member of class TnxBasePooledTransport.
btGetConnectionsName |
btGetQueuedCompletionStatus |
btHandleCompressedReply |
btHandleErrorMessage |
btHeartbeatReceived |
btInternalGetSessionCallback |
btInternalReply | This method is called from TnxBasePooledTransport.Reply. It must send the reply to the client. The base implementation verifies the transport is started and is listening.
btMessageReceived |
btPayloadReceived |
btQueueIoCompleted |
btRemoveCallbackThread |
btRemoveConnection | This is the overview for the btRemoveConnection method overload.
btRemoveRemoteTransport |
btRemoveServerThread |
btRequestTransport |
btSendHeartbeat |
btSetAsCallback |
btSetCallbackThreadCount |
btSetConcurrentIOCPThreads |
btSetPort |
btTerminateConnection |
nxcExceptionClass |
scStarting |
scStopping |
Public Methods
Name | Description
Broadcast | TnxBasePooledTransport
ConnectionCount |
EstablishConnection |
GetConfigSettings |
GetNetIdle |
GetStatsCaptions | see TnxComponent.GetStatsCaptions
GetStatsValues | see TnxComponent.GetStatsValues
IsConnected |
LoadConfig |
LoadSettingsFromStream |
Post |
Request |
SaveConfig |
SaveSettingsToStream |
SetNetIdle | DOM-IGNORE-BEGIN
TerminateConnection |
Write |
Links
TnxBasePooledTransport Class, Legend, Protected Methods, Public Methods


TnxBasePooledTransport.Broadcast Method

TnxBasePooledTransport.Broadcast Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure Broadcast(aMsgID: TnxMsgID; aThreadPriority: TnxThreadPriority; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer); override;
Description

TnxBasePooledTransport

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btAddCallbackThread Method

TnxBasePooledTransport.btAddCallbackThread Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btAddCallbackThread(aThread: TnxBaseCallbackThread);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


btAddConnection Method

btAddConnection Method
TnxBasePooledTransport Methods Send Feedback

This is the overview for the btAddConnection method overload.

Overload List
Name | Description
TnxBasePooledTransport.btAddConnection (TnxBaseClientConnection) |
TnxBasePooledTransport.btAddConnection (TnxBaseServerConnection) |
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Methods


TnxBasePooledTransport.btAddConnection Method (TnxBaseClientConnection)

TnxBasePooledTransport.btAddConnection Method (TnxBaseClientConnection)
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace btAddConnection Method Send Feedback
Syntax
Delphi
procedure btAddConnection(aConnection: TnxBaseClientConnection); overload;
Group

btAddConnection Method

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, btAddConnection Method


TnxBasePooledTransport.btAddConnection Method (TnxBaseServerConnection)

TnxBasePooledTransport.btAddConnection Method (TnxBaseServerConnection)
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace btAddConnection Method Send Feedback
Syntax
Delphi
procedure btAddConnection(aConnection: TnxBaseServerConnection); overload;
Group

btAddConnection Method

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, btAddConnection Method


TnxBasePooledTransport.btAddRemoteTransport Method

TnxBasePooledTransport.btAddRemoteTransport Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btAddRemoteTransport(aRemoteTransport: TnxBaseRemoteTransport);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btAddServerThread Method

TnxBasePooledTransport.btAddServerThread Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btAddServerThread(aThread: TnxBaseServerThread);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btAttachTransport Method

TnxBasePooledTransport.btAttachTransport Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btAttachTransport(aConnection: TnxBaseServerConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btBreath Method

TnxBasePooledTransport.btBreath Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btBreath; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btCheckHeartbeat Method

TnxBasePooledTransport.btCheckHeartbeat Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btCheckHeartbeat; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btCheckWaitingConnections Method

TnxBasePooledTransport.btCheckWaitingConnections Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btCheckWaitingConnections; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btCreateCallbackThread Method

TnxBasePooledTransport.btCreateCallbackThread Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btCreateCallbackThread; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btEstablishConnection Method

TnxBasePooledTransport.btEstablishConnection Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btEstablishConnection(aConnection: TnxBaseConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btGetClientConnection Method

TnxBasePooledTransport.btGetClientConnection Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btGetClientConnection: TnxBaseClientConnection;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btGetClientConnectionClass Method

TnxBasePooledTransport.btGetClientConnectionClass Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btGetClientConnectionClass: TnxBaseClientConnectionClass; virtual; abstract;
Description

This is btGetClientConnectionClass, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btGetConnectionsName Method

TnxBasePooledTransport.btGetConnectionsName Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btGetConnectionsName: string; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btGetQueuedCompletionStatus Method

TnxBasePooledTransport.btGetQueuedCompletionStatus Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btGetQueuedCompletionStatus(var aKey: TnxNativeUInt; var aBytes: TnxWord32; var aError: TnxWord32): Boolean;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btHandleCompressedReply Method

TnxBasePooledTransport.btHandleCompressedReply Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btHandleCompressedReply(aHeader: PnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btHandleErrorMessage Method

TnxBasePooledTransport.btHandleErrorMessage Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btHandleErrorMessage(aErrorCode: TnxResult; var aBuffer: Pointer; var aBufferSize: TnxWord32; aIsUnicode: Boolean): Boolean;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btHeartbeatReceived Method

TnxBasePooledTransport.btHeartbeatReceived Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btHeartbeatReceived(aConnection: TnxBaseConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btInternalGetSessionCallback Method

TnxBasePooledTransport.btInternalGetSessionCallback Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function btInternalGetSessionCallback: InxSessionCallback; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btInternalReply Method

TnxBasePooledTransport.btInternalReply Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btInternalReply(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReplyData: Pointer; aReplyDataLen: TnxWord32); override;
Description

This method is called from TnxBasePooledTransport.Reply. It must send the reply to the client. The base implementation verifies the transport is started and is listening.

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btMessageReceived Method

TnxBasePooledTransport.btMessageReceived Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btMessageReceived(aConnection: TnxBaseConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btPayloadReceived Method

TnxBasePooledTransport.btPayloadReceived Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btPayloadReceived(aConnection: TnxBaseConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btQueueIoCompleted Method

TnxBasePooledTransport.btQueueIoCompleted Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btQueueIoCompleted(aKey: TnxWord32; aBytesTransfered: TnxWord32; aError: TnxWord32);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btRemoveCallbackThread Method

TnxBasePooledTransport.btRemoveCallbackThread Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btRemoveCallbackThread(aThread: TnxBaseCallbackThread);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


btRemoveConnection Method

btRemoveConnection Method
TnxBasePooledTransport Methods Send Feedback

This is the overview for the btRemoveConnection method overload.

Overload List
Name | Description
TnxBasePooledTransport.btRemoveConnection (TnxBaseClientConnection) |
TnxBasePooledTransport.btRemoveConnection (TnxBaseServerConnection) |
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Methods


TnxBasePooledTransport.btRemoveConnection Method (TnxBaseClientConnection)

TnxBasePooledTransport.btRemoveConnection Method (TnxBaseClientConnection)
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace btRemoveConnection Method Send Feedback
Syntax
Delphi
procedure btRemoveConnection(aConnection: TnxBaseClientConnection); overload;
Group

btRemoveConnection Method

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, btRemoveConnection Method


TnxBasePooledTransport.btRemoveConnection Method (TnxBaseServerConnection)

TnxBasePooledTransport.btRemoveConnection Method (TnxBaseServerConnection)
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace btRemoveConnection Method Send Feedback
Syntax
Delphi
procedure btRemoveConnection(aConnection: TnxBaseServerConnection); overload;
Group

btRemoveConnection Method

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, btRemoveConnection Method


TnxBasePooledTransport.btRemoveRemoteTransport Method

TnxBasePooledTransport.btRemoveRemoteTransport Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btRemoveRemoteTransport(aRemoteTransport: TnxBaseRemoteTransport);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btRemoveServerThread Method

TnxBasePooledTransport.btRemoveServerThread Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btRemoveServerThread(aThread: TnxBaseServerThread);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btRequestTransport Method

TnxBasePooledTransport.btRequestTransport Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btRequestTransport(aConnection: TnxBaseServerConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btSendHeartbeat Method

TnxBasePooledTransport.btSendHeartbeat Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btSendHeartbeat; virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btSetAsCallback Method

TnxBasePooledTransport.btSetAsCallback Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btSetAsCallback(aConnection: TnxBaseServerConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btSetCallbackThreadCount Method

TnxBasePooledTransport.btSetCallbackThreadCount Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btSetCallbackThreadCount(const Value: Byte);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btSetConcurrentIOCPThreads Method

TnxBasePooledTransport.btSetConcurrentIOCPThreads Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btSetConcurrentIOCPThreads(const Value: Byte);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btSetPort Method

TnxBasePooledTransport.btSetPort Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btSetPort(const Value: TnxWord16);
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.btTerminateConnection Method

TnxBasePooledTransport.btTerminateConnection Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure btTerminateConnection(aConnection: TnxBaseConnection; const aHeader: TnxBaseHeader; aBuffer: Pointer; aBufferSize: TnxWord32); virtual;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.ConnectionCount Method

TnxBasePooledTransport.ConnectionCount Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function ConnectionCount: Integer; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.EstablishConnection Method

TnxBasePooledTransport.EstablishConnection Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function EstablishConnection(aTransportID: TnxTransportID; const aUserName: UnicodeString; const aPassword: UnicodeString; aTimeout: Integer; aClientVersion: Integer; out aServerVersion: Integer; out aSessionID: TnxSessionID): TnxResult; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.GetConfigSettings Method

TnxBasePooledTransport.GetConfigSettings Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.GetNetIdle Method

TnxBasePooledTransport.GetNetIdle Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
class function GetNetIdle(out aNetIdle: TnxNetIdleEvent; out aInterval: Cardinal; out aMask: Cardinal): Boolean;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.GetStatsCaptions Method

TnxBasePooledTransport.GetStatsCaptions Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); override;
Description

see TnxComponent.GetStatsCaptions

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.GetStatsValues Method

TnxBasePooledTransport.GetStatsValues Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); override;
Description

see TnxComponent.GetStatsValues

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.IsConnected Method

TnxBasePooledTransport.IsConnected Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
function IsConnected: Boolean; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.LoadConfig Method

TnxBasePooledTransport.LoadConfig Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.LoadSettingsFromStream Method

TnxBasePooledTransport.LoadSettingsFromStream Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.nxcExceptionClass Method

TnxBasePooledTransport.nxcExceptionClass Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.Post Method

TnxBasePooledTransport.Post Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure Post(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeout: Integer); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.Request Method

TnxBasePooledTransport.Request Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure Request(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.SaveConfig Method

TnxBasePooledTransport.SaveConfig Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.SaveSettingsToStream Method

TnxBasePooledTransport.SaveSettingsToStream Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.scStarting Method

TnxBasePooledTransport.scStarting Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.scStopping Method

TnxBasePooledTransport.scStopping Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.SetNetIdle Method

TnxBasePooledTransport.SetNetIdle Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
class procedure SetNetIdle(aNetIdle: TnxNetIdleEvent; aInterval: Cardinal; aMask: Cardinal);
Description

DOM-IGNORE-BEGIN

Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.TerminateConnection Method

TnxBasePooledTransport.TerminateConnection Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure TerminateConnection(aTransportID: TnxTransportID; aSessionID: TnxSessionID; aTimeout: Integer); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport.Write Method

TnxBasePooledTransport.Write Method
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Methods Send Feedback
Syntax
Delphi
procedure Write(aConnection: Pointer; aTransportID: TnxTransportID; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aMsgType: Byte; aErrorCode: TnxResult; aCompressType: Byte; aUncompressedSize: TnxWord32; aBuffer: Pointer; aBufferSize: TnxWord32); override;
Group

TnxBasePooledTransport Methods

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Methods


TnxBasePooledTransport Properties

TnxBasePooledTransport Properties
TnxBasePooledTransport Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxBasePooledTransport class are listed here.

Class

TnxBasePooledTransport Class

Public Properties
Name | Description
CallbackThreadCount | Number of active callback threads.
CallbackThreadPriority | Priority of the callback thread.
Published Properties
Name | Description
CompressLimit | Number of minimum length of the message for compression. If the message is shorter, compression is not used.
CompressType | The type of compression to use. Must be a registered compression engine id! The registered IDs available in a standard NexusDB Server: 0 - No compression 1..9 - Zip compression, Level 1-9 (lower level is faster, compressed size of data slightly larger ) 10 - RLE compression (Run Length Encoding) 11..19 - Lz4 compression, Level 1 to 9 (lower level is faster, compressed size of data slightly larger ) The currently recommended CompressType is 11 (eg Lz4 level 1)
ConcurrentIOCPThreads | Number of IO Completion Port threads. Ideally the number of processors in the system.
HeartbeatInterval | The interval between keep alive heartbeat checks in ms.
HeartbeatThreadPriority | The priority of the "Heartbeat" background thread.
LostConnectionTimeout | This is LostConnectionTimeout, a member of class TnxBasePooledTransport.
OverlappedClient | True if the transport uses/supports overlapped IO
Port | The "Port" of the thread.
ServerThreadPriority | The priority of the server thread.
WatchdogInterval | The interval between keep alive watchdog checks in ms.
WatchdogThreadPriority | The priority of the "Watchdog" background thread.
Links
TnxBasePooledTransport Class, Legend, Public Properties, Published Properties


TnxBasePooledTransport.CallbackThreadCount Property

TnxBasePooledTransport.CallbackThreadCount Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property CallbackThreadCount: Byte;
Description

Number of active callback threads.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.CallbackThreadPriority Property

TnxBasePooledTransport.CallbackThreadPriority Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property CallbackThreadPriority: TThreadPriority;
Description

Priority of the callback thread.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.CompressLimit Property

TnxBasePooledTransport.CompressLimit Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property CompressLimit: TnxWord32;
Description

Number of minimum length of the message for compression. If the message is shorter, compression is not used.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.CompressType Property

TnxBasePooledTransport.CompressType Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property CompressType: Byte;
Description

The type of compression to use. Must be a registered compression engine id! The registered IDs available in a standard NexusDB Server: 0 - No compression 1..9 - Zip compression, Level 1-9 (lower level is faster, compressed size of data slightly larger ) 10 - RLE compression (Run Length Encoding) 11..19 - Lz4 compression, Level 1 to 9 (lower level is faster, compressed size of data slightly larger )

The currently recommended CompressType is 11 (eg Lz4 level 1)

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.ConcurrentIOCPThreads Property

TnxBasePooledTransport.ConcurrentIOCPThreads Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property ConcurrentIOCPThreads: Byte;
Description

Number of IO Completion Port threads. Ideally the number of processors in the system.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.HeartbeatInterval Property

TnxBasePooledTransport.HeartbeatInterval Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property HeartbeatInterval: TnxWord32;
Description

The interval between keep alive heartbeat checks in ms.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.HeartbeatThreadPriority Property

TnxBasePooledTransport.HeartbeatThreadPriority Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property HeartbeatThreadPriority: TThreadPriority;
Description

The priority of the "Heartbeat" background thread.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.LostConnectionTimeout Property

TnxBasePooledTransport.LostConnectionTimeout Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property LostConnectionTimeout: TnxWord32;
Description

This is LostConnectionTimeout, a member of class TnxBasePooledTransport.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.OverlappedClient Property

TnxBasePooledTransport.OverlappedClient Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property OverlappedClient: Boolean;
Description

True if the transport uses/supports overlapped IO

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.Port Property

TnxBasePooledTransport.Port Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property Port: TnxWord16;
Description

The "Port" of the thread.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.ServerThreadPriority Property

TnxBasePooledTransport.ServerThreadPriority Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property ServerThreadPriority: TThreadPriority;
Description

The priority of the server thread.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.WatchdogInterval Property

TnxBasePooledTransport.WatchdogInterval Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property WatchdogInterval: TnxWord32;
Description

The interval between keep alive watchdog checks in ms.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBasePooledTransport.WatchdogThreadPriority Property

TnxBasePooledTransport.WatchdogThreadPriority Property
TnxBasePooledTransport Class TnxBasePooledTransport Members nxptBasePooledTransport Namespace TnxBasePooledTransport Properties Send Feedback
Syntax
Delphi
property WatchdogThreadPriority: TThreadPriority;
Description

The priority of the "Watchdog" background thread.

Group

TnxBasePooledTransport Properties

Links
TnxBasePooledTransport Class, TnxBasePooledTransport Members, nxptBasePooledTransport Namespace, TnxBasePooledTransport Properties


TnxBaseRemoteSession Class

TnxBaseRemoteSession Class
TnxBaseRemoteSession Fields TnxBaseRemoteSession Methods TnxBaseRemoteSession Properties TnxBaseRemoteSession Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseRemoteSessionnxptBasePooledTransport_TnxBaseRemoteSessionnxptBasePooledTransport_TnxBaseRemoteSession
Syntax
Delphi
TnxBaseRemoteSession = class(TnxLowObject);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseRemoteSession.

Group

Classes

Links
TnxBaseRemoteSession Fields, TnxBaseRemoteSession Methods, TnxBaseRemoteSession Properties, TnxBaseRemoteSession Members, nxptBasePooledTransport, Classes


TnxBaseRemoteSession Members

TnxBaseRemoteSession Members
TnxBaseRemoteSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseRemoteSession.

Class

TnxBaseRemoteSession Class

Protected Fields
Name | Description
brsAddedToRemoteTransport | This is brsAddedToRemoteTransport, a member of class TnxBaseRemoteSession.
brsAddedToTransport | This is brsAddedToTransport, a member of class TnxBaseRemoteSession.
brsCallback | This is brsCallback, a member of class TnxBaseRemoteSession.
brsClientVersion | This is brsClientVersion, a member of class TnxBaseRemoteSession.
brsDestroying | This is brsDestroying, a member of class TnxBaseRemoteSession.
brsFailed | This is brsFailed, a member of class TnxBaseRemoteSession.
brsFreeing | This is brsFreeing, a member of class TnxBaseRemoteSession.
brsLock | This is brsLock, a member of class TnxBaseRemoteSession.
brsMagicNumber | privat
brsRemoteTransport | This is brsRemoteTransport, a member of class TnxBaseRemoteSession.
brsServerVersion | This is brsServerVersion, a member of class TnxBaseRemoteSession.
brsSessionID | This is brsSessionID, a member of class TnxBaseRemoteSession.
brsTransport | This is brsTransport, a member of class TnxBaseRemoteSession.
Protected Methods
Name | Description
brsGetMinVersion |
brsHeartFailure |
brsRemoveFromTransports |
Public Methods
Name | Description
AfterConstruction | TnxBaseRemoteSession
BeforeDestruction |
Create |
Destroy |
Free |
FreeInstance |
GetSessionCallback |
Lock |
LookupByID |
NewInstance | TnxLowObject
NewInstance | TnxObject
Unlock |
Public Properties
Name | Description
MinVersion | This is MinVersion, a member of class TnxBaseRemoteSession.
Links
TnxBaseRemoteSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseRemoteSession.Create Constructor

TnxBaseRemoteSession.Create Constructor
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport; aRemoteTransport: TnxBaseRemoteTransport; aSessionID: TnxSessionID; aClientVersion: TnxWord32; aServerVersion: TnxWord32);
Class

TnxBaseRemoteSession Class

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Class


TnxBaseRemoteSession.Destroy Destructor

TnxBaseRemoteSession.Destroy Destructor
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseRemoteSession Class

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Class


TnxBaseRemoteSession Fields

TnxBaseRemoteSession Fields
TnxBaseRemoteSession Class Legend Protected Fields Send Feedback

The fields of the TnxBaseRemoteSession class are listed here.

Class

TnxBaseRemoteSession Class

Protected Fields
Name | Description
brsAddedToRemoteTransport | This is brsAddedToRemoteTransport, a member of class TnxBaseRemoteSession.
brsAddedToTransport | This is brsAddedToTransport, a member of class TnxBaseRemoteSession.
brsCallback | This is brsCallback, a member of class TnxBaseRemoteSession.
brsClientVersion | This is brsClientVersion, a member of class TnxBaseRemoteSession.
brsDestroying | This is brsDestroying, a member of class TnxBaseRemoteSession.
brsFailed | This is brsFailed, a member of class TnxBaseRemoteSession.
brsFreeing | This is brsFreeing, a member of class TnxBaseRemoteSession.
brsLock | This is brsLock, a member of class TnxBaseRemoteSession.
brsMagicNumber | privat
brsRemoteTransport | This is brsRemoteTransport, a member of class TnxBaseRemoteSession.
brsServerVersion | This is brsServerVersion, a member of class TnxBaseRemoteSession.
brsSessionID | This is brsSessionID, a member of class TnxBaseRemoteSession.
brsTransport | This is brsTransport, a member of class TnxBaseRemoteSession.
Links
TnxBaseRemoteSession Class, Legend, Protected Fields


TnxBaseRemoteSession.brsAddedToRemoteTransport Field

TnxBaseRemoteSession.brsAddedToRemoteTransport Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsAddedToRemoteTransport: Boolean;
Description

This is brsAddedToRemoteTransport, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsAddedToTransport Field

TnxBaseRemoteSession.brsAddedToTransport Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsAddedToTransport: Boolean;
Description

This is brsAddedToTransport, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsCallback Field

TnxBaseRemoteSession.brsCallback Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsCallback: InxInternalSessionCallback;
Description

This is brsCallback, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsClientVersion Field

TnxBaseRemoteSession.brsClientVersion Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsClientVersion: TnxWord32;
Description

This is brsClientVersion, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsDestroying Field

TnxBaseRemoteSession.brsDestroying Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsDestroying: Integer;
Description

This is brsDestroying, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsFailed Field

TnxBaseRemoteSession.brsFailed Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsFailed: Integer;
Description

This is brsFailed, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsFreeing Field

TnxBaseRemoteSession.brsFreeing Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsFreeing: Integer;
Description

This is brsFreeing, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsLock Field

TnxBaseRemoteSession.brsLock Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsLock: Integer;
Description

This is brsLock, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsMagicNumber Field

TnxBaseRemoteSession.brsMagicNumber Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsMagicNumber: TnxWord32;
Description

privat

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsRemoteTransport Field

TnxBaseRemoteSession.brsRemoteTransport Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsRemoteTransport: TnxBaseRemoteTransport;
Description

This is brsRemoteTransport, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsServerVersion Field

TnxBaseRemoteSession.brsServerVersion Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsServerVersion: TnxWord32;
Description

This is brsServerVersion, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsSessionID Field

TnxBaseRemoteSession.brsSessionID Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsSessionID: TnxSessionID;
Description

This is brsSessionID, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession.brsTransport Field

TnxBaseRemoteSession.brsTransport Field
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Fields Send Feedback
Syntax
Delphi
brsTransport: TnxBasePooledTransport;
Description

This is brsTransport, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Fields

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Fields


TnxBaseRemoteSession Methods

TnxBaseRemoteSession Methods
TnxBaseRemoteSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRemoteSession class are listed here.

Class

TnxBaseRemoteSession Class

Protected Methods
Name | Description
brsGetMinVersion |
brsHeartFailure |
brsRemoveFromTransports |
Public Methods
Name | Description
AfterConstruction | TnxBaseRemoteSession
BeforeDestruction |
Free |
GetSessionCallback |
Lock |
LookupByID |
Unlock |
Links
TnxBaseRemoteSession Class, Legend, Protected Methods, Public Methods


TnxBaseRemoteSession.AfterConstruction Method

TnxBaseRemoteSession.AfterConstruction Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxBaseRemoteSession

Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.BeforeDestruction Method

TnxBaseRemoteSession.BeforeDestruction Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.brsGetMinVersion Method

TnxBaseRemoteSession.brsGetMinVersion Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
function brsGetMinVersion: TnxWord32;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.brsHeartFailure Method

TnxBaseRemoteSession.brsHeartFailure Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure brsHeartFailure; virtual;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.brsRemoveFromTransports Method

TnxBaseRemoteSession.brsRemoveFromTransports Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure brsRemoveFromTransports;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.Free Method

TnxBaseRemoteSession.Free Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure Free;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.GetSessionCallback Method

TnxBaseRemoteSession.GetSessionCallback Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
function GetSessionCallback: InxSessionCallback;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.Lock Method

TnxBaseRemoteSession.Lock Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure Lock;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.LookupByID Method

TnxBaseRemoteSession.LookupByID Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
class function LookupByID(aRemoteTransport: TnxBaseRemoteTransport; aSessionID: TnxSessionID; out aSession: TnxBaseRemoteSession): TnxResult;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession.Unlock Method

TnxBaseRemoteSession.Unlock Method
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Methods Send Feedback
Syntax
Delphi
procedure Unlock;
Group

TnxBaseRemoteSession Methods

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Methods


TnxBaseRemoteSession Properties

TnxBaseRemoteSession Properties
TnxBaseRemoteSession Class Legend Public Properties Send Feedback

The properties of the TnxBaseRemoteSession class are listed here.

Class

TnxBaseRemoteSession Class

Public Properties
Name | Description
MinVersion | This is MinVersion, a member of class TnxBaseRemoteSession.
Links
TnxBaseRemoteSession Class, Legend, Public Properties


TnxBaseRemoteSession.MinVersion Property

TnxBaseRemoteSession.MinVersion Property
TnxBaseRemoteSession Class TnxBaseRemoteSession Members nxptBasePooledTransport Namespace TnxBaseRemoteSession Properties Send Feedback
Syntax
Delphi
property MinVersion: TnxWord32;
Description

This is MinVersion, a member of class TnxBaseRemoteSession.

Group

TnxBaseRemoteSession Properties

Links
TnxBaseRemoteSession Class, TnxBaseRemoteSession Members, nxptBasePooledTransport Namespace, TnxBaseRemoteSession Properties


TnxBaseRemoteTransport Class

TnxBaseRemoteTransport Class
TnxBaseRemoteTransport Fields TnxBaseRemoteTransport Methods TnxBaseRemoteTransport Properties TnxBaseRemoteTransport Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseRemoteTransportnxptBasePooledTransport_TnxBaseRemoteTransportnxptBasePooledTransport_TnxBaseRemoteTransport
Syntax
Delphi
TnxBaseRemoteTransport = class(TnxLowObject);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseRemoteTransport.

Group

Classes

Links
TnxBaseRemoteTransport Fields, TnxBaseRemoteTransport Methods, TnxBaseRemoteTransport Properties, TnxBaseRemoteTransport Members, nxptBasePooledTransport, Classes


TnxBaseRemoteTransport Members

TnxBaseRemoteTransport Members
TnxBaseRemoteTransport Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseRemoteTransport.

Class

TnxBaseRemoteTransport Class

Protected Fields
Name | Description
brtCallbackEvent | This is brtCallbackEvent, a member of class TnxBaseRemoteTransport.
brtCallbacks | This is brtCallbacks, a member of class TnxBaseRemoteTransport.
brtConnections | This is brtConnections, a member of class TnxBaseRemoteTransport.
brtDestroying | This is brtDestroying, a member of class TnxBaseRemoteTransport.
brtFailed | This is brtFailed, a member of class TnxBaseRemoteTransport.
brtFreeing | This is brtFreeing, a member of class TnxBaseRemoteTransport.
brtHeartbeatInterval | This is brtHeartbeatInterval, a member of class TnxBaseRemoteTransport.
brtIsLost | This is brtIsLost, a member of class TnxBaseRemoteTransport.
brtLastMessage | This is brtLastMessage, a member of class TnxBaseRemoteTransport.
brtLock | This is brtLock, a member of class TnxBaseRemoteTransport.
brtMagicNumber | privat
brtMarker | This is brtMarker, a member of class TnxBaseRemoteTransport.
brtRemoteAddress | This is brtRemoteAddress, a member of class TnxBaseRemoteTransport.
brtRemoteMsgVersion | This is brtRemoteMsgVersion, a member of class TnxBaseRemoteTransport.
brtSessions | This is brtSessions, a member of class TnxBaseRemoteTransport.
brtSupportsCallbacks | This is brtSupportsCallbacks, a member of class TnxBaseRemoteTransport.
brtTransport | This is brtTransport, a member of class TnxBaseRemoteTransport.
brtWaitingForCallbacks | This is brtWaitingForCallbacks, a member of class TnxBaseRemoteTransport.
Protected Methods
Name | Description
brtAddCallback |
brtAddConnection |
brtAddSession |
brtFreeSessions |
brtGetCallbackConnection |
brtHeartFailure |
brtInformSessionOfHeartFailure |
brtMessageReceived |
brtRemoveConnection |
brtRemoveSession |
brtTerminateCallbacks |
brtTerminateConnections |
Public Methods
Name | Description
AfterConstruction | TnxBaseRemoteTransport
BeforeDestruction |
Create |
Destroy |
EstablishConnection |
Free |
FreeInstance |
Lock |
LookupByID |
NewInstance | TnxLowObject
NewInstance | TnxObject
Post |
Request |
TerminateConnection |
Unlock |
Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseRemoteTransport.
RemoteMsgVersion | This is RemoteMsgVersion, a member of class TnxBaseRemoteTransport.
SessionsForThisTransport | This is SessionsForThisTransport, a member of class TnxBaseRemoteTransport.
Links
TnxBaseRemoteTransport Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseRemoteTransport.Create Constructor

TnxBaseRemoteTransport.Create Constructor
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport; const aRemoteAddress: string; aRemoteMsgVersion: Byte; aHeartbeatInterval: TnxWord32);
Class

TnxBaseRemoteTransport Class

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Class


TnxBaseRemoteTransport.Destroy Destructor

TnxBaseRemoteTransport.Destroy Destructor
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseRemoteTransport Class

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Class


TnxBaseRemoteTransport Fields

TnxBaseRemoteTransport Fields
TnxBaseRemoteTransport Class Legend Protected Fields Send Feedback

The fields of the TnxBaseRemoteTransport class are listed here.

Class

TnxBaseRemoteTransport Class

Protected Fields
Name | Description
brtCallbackEvent | This is brtCallbackEvent, a member of class TnxBaseRemoteTransport.
brtCallbacks | This is brtCallbacks, a member of class TnxBaseRemoteTransport.
brtConnections | This is brtConnections, a member of class TnxBaseRemoteTransport.
brtDestroying | This is brtDestroying, a member of class TnxBaseRemoteTransport.
brtFailed | This is brtFailed, a member of class TnxBaseRemoteTransport.
brtFreeing | This is brtFreeing, a member of class TnxBaseRemoteTransport.
brtHeartbeatInterval | This is brtHeartbeatInterval, a member of class TnxBaseRemoteTransport.
brtIsLost | This is brtIsLost, a member of class TnxBaseRemoteTransport.
brtLastMessage | This is brtLastMessage, a member of class TnxBaseRemoteTransport.
brtLock | This is brtLock, a member of class TnxBaseRemoteTransport.
brtMagicNumber | privat
brtMarker | This is brtMarker, a member of class TnxBaseRemoteTransport.
brtRemoteAddress | This is brtRemoteAddress, a member of class TnxBaseRemoteTransport.
brtRemoteMsgVersion | This is brtRemoteMsgVersion, a member of class TnxBaseRemoteTransport.
brtSessions | This is brtSessions, a member of class TnxBaseRemoteTransport.
brtSupportsCallbacks | This is brtSupportsCallbacks, a member of class TnxBaseRemoteTransport.
brtTransport | This is brtTransport, a member of class TnxBaseRemoteTransport.
brtWaitingForCallbacks | This is brtWaitingForCallbacks, a member of class TnxBaseRemoteTransport.
Links
TnxBaseRemoteTransport Class, Legend, Protected Fields


TnxBaseRemoteTransport.brtCallbackEvent Field

TnxBaseRemoteTransport.brtCallbackEvent Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtCallbackEvent: TnxEvent;
Description

This is brtCallbackEvent, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtCallbacks Field

TnxBaseRemoteTransport.brtCallbacks Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtCallbacks: TnxListPadlock;
Description

This is brtCallbacks, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtConnections Field

TnxBaseRemoteTransport.brtConnections Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtConnections: TnxListPadlock;
Description

This is brtConnections, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtDestroying Field

TnxBaseRemoteTransport.brtDestroying Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtDestroying: Integer;
Description

This is brtDestroying, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtFailed Field

TnxBaseRemoteTransport.brtFailed Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtFailed: Integer;
Description

This is brtFailed, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtFreeing Field

TnxBaseRemoteTransport.brtFreeing Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtFreeing: Integer;
Description

This is brtFreeing, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtHeartbeatInterval Field

TnxBaseRemoteTransport.brtHeartbeatInterval Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtHeartbeatInterval: TnxInt64;
Description

This is brtHeartbeatInterval, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtIsLost Field

TnxBaseRemoteTransport.brtIsLost Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtIsLost: Boolean;
Description

This is brtIsLost, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtLastMessage Field

TnxBaseRemoteTransport.brtLastMessage Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtLastMessage: TnxInt64;
Description

This is brtLastMessage, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtLock Field

TnxBaseRemoteTransport.brtLock Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtLock: Integer;
Description

This is brtLock, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtMagicNumber Field

TnxBaseRemoteTransport.brtMagicNumber Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtMagicNumber: TnxWord32;
Description

privat

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtMarker Field

TnxBaseRemoteTransport.brtMarker Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtMarker: TnxWord32;
Description

This is brtMarker, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtRemoteAddress Field

TnxBaseRemoteTransport.brtRemoteAddress Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtRemoteAddress: string;
Description

This is brtRemoteAddress, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtRemoteMsgVersion Field

TnxBaseRemoteTransport.brtRemoteMsgVersion Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtRemoteMsgVersion: Byte;
Description

This is brtRemoteMsgVersion, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtSessions Field

TnxBaseRemoteTransport.brtSessions Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtSessions: TnxListPadlock;
Description

This is brtSessions, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtSupportsCallbacks Field

TnxBaseRemoteTransport.brtSupportsCallbacks Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtSupportsCallbacks: Boolean;
Description

This is brtSupportsCallbacks, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtTransport Field

TnxBaseRemoteTransport.brtTransport Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtTransport: TnxBasePooledTransport;
Description

This is brtTransport, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport.brtWaitingForCallbacks Field

TnxBaseRemoteTransport.brtWaitingForCallbacks Field
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Fields Send Feedback
Syntax
Delphi
brtWaitingForCallbacks: Integer;
Description

This is brtWaitingForCallbacks, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Fields

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Fields


TnxBaseRemoteTransport Methods

TnxBaseRemoteTransport Methods
TnxBaseRemoteTransport Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRemoteTransport class are listed here.

Class

TnxBaseRemoteTransport Class

Protected Methods
Name | Description
brtAddCallback |
brtAddConnection |
brtAddSession |
brtFreeSessions |
brtGetCallbackConnection |
brtHeartFailure |
brtInformSessionOfHeartFailure |
brtMessageReceived |
brtRemoveConnection |
brtRemoveSession |
brtTerminateCallbacks |
brtTerminateConnections |
Public Methods
Name | Description
AfterConstruction | TnxBaseRemoteTransport
BeforeDestruction |
EstablishConnection |
Free |
Lock |
LookupByID |
Post |
Request |
TerminateConnection |
Unlock |
Links
TnxBaseRemoteTransport Class, Legend, Protected Methods, Public Methods


TnxBaseRemoteTransport.AfterConstruction Method

TnxBaseRemoteTransport.AfterConstruction Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxBaseRemoteTransport

Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.BeforeDestruction Method

TnxBaseRemoteTransport.BeforeDestruction Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtAddCallback Method

TnxBaseRemoteTransport.brtAddCallback Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtAddCallback(aConnection: TnxBaseServerConnection);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtAddConnection Method

TnxBaseRemoteTransport.brtAddConnection Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtAddConnection(aConnection: TnxBaseServerConnection);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtAddSession Method

TnxBaseRemoteTransport.brtAddSession Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtAddSession(aSession: TnxBaseRemoteSession);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtFreeSessions Method

TnxBaseRemoteTransport.brtFreeSessions Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtFreeSessions;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtGetCallbackConnection Method

TnxBaseRemoteTransport.brtGetCallbackConnection Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
function brtGetCallbackConnection(aTimeout: Integer): TnxBaseServerConnection;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtHeartFailure Method

TnxBaseRemoteTransport.brtHeartFailure Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtHeartFailure; virtual;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtInformSessionOfHeartFailure Method

TnxBaseRemoteTransport.brtInformSessionOfHeartFailure Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtInformSessionOfHeartFailure;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtMessageReceived Method

TnxBaseRemoteTransport.brtMessageReceived Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtMessageReceived; virtual;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtRemoveConnection Method

TnxBaseRemoteTransport.brtRemoveConnection Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtRemoveConnection(aConnection: TnxBaseServerConnection);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtRemoveSession Method

TnxBaseRemoteTransport.brtRemoveSession Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtRemoveSession(aSession: TnxBaseRemoteSession);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtTerminateCallbacks Method

TnxBaseRemoteTransport.brtTerminateCallbacks Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtTerminateCallbacks;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.brtTerminateConnections Method

TnxBaseRemoteTransport.brtTerminateConnections Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure brtTerminateConnections;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.EstablishConnection Method

TnxBaseRemoteTransport.EstablishConnection Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
function EstablishConnection(const aUserName: UnicodeString; const aPassword: UnicodeString; aTimeout: Integer; aClientVersion: Integer; out aServerVersion: Integer; out aSessionID: TnxSessionID): TnxResult;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.Free Method

TnxBaseRemoteTransport.Free Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure Free;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.Lock Method

TnxBaseRemoteTransport.Lock Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure Lock;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.LookupByID Method

TnxBaseRemoteTransport.LookupByID Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
class function LookupByID(aTransportID: TnxTransportID; out aTransport: TnxBaseRemoteTransport): TnxResult;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.Post Method

TnxBaseRemoteTransport.Post Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure Post(aCallback: Boolean; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeout: Integer);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.Request Method

TnxBaseRemoteTransport.Request Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure Request(aCallback: Boolean; aSessionID: TnxSessionID; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.TerminateConnection Method

TnxBaseRemoteTransport.TerminateConnection Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure TerminateConnection(aSessionID: TnxSessionID; aTimeout: Integer);
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport.Unlock Method

TnxBaseRemoteTransport.Unlock Method
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Methods Send Feedback
Syntax
Delphi
procedure Unlock;
Group

TnxBaseRemoteTransport Methods

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Methods


TnxBaseRemoteTransport Properties

TnxBaseRemoteTransport Properties
TnxBaseRemoteTransport Class Legend Public Properties Send Feedback

The properties of the TnxBaseRemoteTransport class are listed here.

Class

TnxBaseRemoteTransport Class

Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseRemoteTransport.
RemoteMsgVersion | This is RemoteMsgVersion, a member of class TnxBaseRemoteTransport.
SessionsForThisTransport | This is SessionsForThisTransport, a member of class TnxBaseRemoteTransport.
Links
TnxBaseRemoteTransport Class, Legend, Public Properties


TnxBaseRemoteTransport.RemoteAddress Property

TnxBaseRemoteTransport.RemoteAddress Property
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Properties Send Feedback
Syntax
Delphi
property RemoteAddress: string;
Description

This is RemoteAddress, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Properties

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Properties


TnxBaseRemoteTransport.RemoteMsgVersion Property

TnxBaseRemoteTransport.RemoteMsgVersion Property
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Properties Send Feedback
Syntax
Delphi
property RemoteMsgVersion: Byte;
Description

This is RemoteMsgVersion, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Properties

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Properties


TnxBaseRemoteTransport.SessionsForThisTransport Property

TnxBaseRemoteTransport.SessionsForThisTransport Property
TnxBaseRemoteTransport Class TnxBaseRemoteTransport Members nxptBasePooledTransport Namespace TnxBaseRemoteTransport Properties Send Feedback
Syntax
Delphi
property SessionsForThisTransport: TnxListPadlock;
Description

This is SessionsForThisTransport, a member of class TnxBaseRemoteTransport.

Group

TnxBaseRemoteTransport Properties

Links
TnxBaseRemoteTransport Class, TnxBaseRemoteTransport Members, nxptBasePooledTransport Namespace, TnxBaseRemoteTransport Properties


TnxBaseServerConnection Class

TnxBaseServerConnection Class
TnxBaseServerConnection Fields TnxBaseServerConnection Methods TnxBaseServerConnection Properties TnxBaseServerConnection Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseServerConnectionnxptBasePooledTransport_TnxBaseServerConnectionnxptBasePooledTransport_TnxBaseServerConnection
Syntax
Delphi
TnxBaseServerConnection = class(TnxBaseConnection);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseServerConnection.

Group

Classes

Links
TnxBaseServerConnection Fields, TnxBaseServerConnection Methods, TnxBaseServerConnection Properties, TnxBaseServerConnection Members, nxptBasePooledTransport, Classes


TnxBaseServerConnection Members

TnxBaseServerConnection Members
TnxBaseServerConnection Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseServerConnection.

Class

TnxBaseServerConnection Class

Protected Fields
Name | Description
bcActive | This is bcActive, a member of class TnxBaseConnection.
bcAlive | privat
bcDestroying | This is bcDestroying, a member of class TnxBaseConnection.
bcForcedDisconnect | This is bcForcedDisconnect, a member of class TnxBaseConnection.
bcNextFree | This is bcNextFree, a member of class TnxBaseConnection.
bcTransport | This is bcTransport, a member of class TnxBaseConnection.
bscClosing | This is bscClosing, a member of class TnxBaseServerConnection.
bscOverlapped | This is bscOverlapped, a member of class TnxBaseServerConnection.
bscRemoteTransport | privat
bscShutdownCount | This is bscShutdownCount, a member of class TnxBaseServerConnection.
Protected Methods
Name | Description
bcGetRemoteAddress | TnxBaseConnection
bcMessageReceived | TnxBaseServerConnection
bscDisposeOverlapped |
bscNewOverlapped |
ConnectionLost |
QueueIoCompleted |
Public Methods
Name | Description
BeforeDestruction |
Create |
Deactivate |
Destroy |
DoWrite | This is DoWrite, a member of class TnxBaseConnection.
ForceDisconnect | This is ForceDisconnect, a member of class TnxBaseConnection.
Free |
FreeInstance |
FreeInstance |
IoCompleted | This is IoCompleted, a member of class TnxBaseServerConnection.
NewInstance | TnxObject
NewInstance |
Read | This is the overview for the Read method overload.
SetAsCallback |
SetRemoteTransport |
Transact |
Public Properties
Name | Description
RemoteAddress | This is RemoteAddress, a member of class TnxBaseConnection.
RemoteTransportForConnection | This is RemoteTransportForConnection, a member of class TnxBaseServerConnection.
Transport | This is Transport, a member of class TnxBaseConnection.
Links
TnxBaseServerConnection Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseServerConnection.Create Constructor

TnxBaseServerConnection.Create Constructor
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport); override;
Class

TnxBaseServerConnection Class

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Class


TnxBaseServerConnection.Destroy Destructor

TnxBaseServerConnection.Destroy Destructor
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseServerConnection Class

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Class


TnxBaseServerConnection Fields

TnxBaseServerConnection Fields
TnxBaseServerConnection Class Legend Protected Fields Send Feedback

The fields of the TnxBaseServerConnection class are listed here.

Class

TnxBaseServerConnection Class

Protected Fields
Name | Description
bscClosing | This is bscClosing, a member of class TnxBaseServerConnection.
bscOverlapped | This is bscOverlapped, a member of class TnxBaseServerConnection.
bscRemoteTransport | privat
bscShutdownCount | This is bscShutdownCount, a member of class TnxBaseServerConnection.
Links
TnxBaseServerConnection Class, Legend, Protected Fields


TnxBaseServerConnection.bscClosing Field

TnxBaseServerConnection.bscClosing Field
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Fields Send Feedback
Syntax
Delphi
bscClosing: Integer;
Description

This is bscClosing, a member of class TnxBaseServerConnection.

Group

TnxBaseServerConnection Fields

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Fields


TnxBaseServerConnection.bscOverlapped Field

TnxBaseServerConnection.bscOverlapped Field
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Fields Send Feedback
Syntax
Delphi
bscOverlapped: POverlapped;
Description

This is bscOverlapped, a member of class TnxBaseServerConnection.

Group

TnxBaseServerConnection Fields

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Fields


TnxBaseServerConnection.bscRemoteTransport Field

TnxBaseServerConnection.bscRemoteTransport Field
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Fields Send Feedback
Syntax
Delphi
bscRemoteTransport: TnxBaseRemoteTransport;
Description

privat

Group

TnxBaseServerConnection Fields

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Fields


TnxBaseServerConnection.bscShutdownCount Field

TnxBaseServerConnection.bscShutdownCount Field
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Fields Send Feedback
Syntax
Delphi
bscShutdownCount: Integer;
Description

This is bscShutdownCount, a member of class TnxBaseServerConnection.

Group

TnxBaseServerConnection Fields

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Fields


TnxBaseServerConnection Methods

TnxBaseServerConnection Methods
TnxBaseServerConnection Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseServerConnection class are listed here.

Class

TnxBaseServerConnection Class

Protected Methods
Name | Description
bcMessageReceived | TnxBaseServerConnection
bscDisposeOverlapped |
bscNewOverlapped |
ConnectionLost |
QueueIoCompleted |
Public Methods
Name | Description
Deactivate |
IoCompleted | This is IoCompleted, a member of class TnxBaseServerConnection.
SetAsCallback |
SetRemoteTransport |
Links
TnxBaseServerConnection Class, Legend, Protected Methods, Public Methods


TnxBaseServerConnection.bcMessageReceived Method

TnxBaseServerConnection.bcMessageReceived Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure bcMessageReceived; override;
Description

TnxBaseServerConnection

Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.bscDisposeOverlapped Method

TnxBaseServerConnection.bscDisposeOverlapped Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure bscDisposeOverlapped;
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.bscNewOverlapped Method

TnxBaseServerConnection.bscNewOverlapped Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure bscNewOverlapped;
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.ConnectionLost Method

TnxBaseServerConnection.ConnectionLost Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure ConnectionLost; virtual;
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.Deactivate Method

TnxBaseServerConnection.Deactivate Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure Deactivate; override;
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.IoCompleted Method

TnxBaseServerConnection.IoCompleted Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure IoCompleted(aBytesTransfered: TnxWord32; aError: TnxWord32); virtual; abstract;
Description

This is IoCompleted, a member of class TnxBaseServerConnection.

Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.QueueIoCompleted Method

TnxBaseServerConnection.QueueIoCompleted Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure QueueIoCompleted(aBytesTransfered: TnxWord32; aError: TnxWord32);
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.SetAsCallback Method

TnxBaseServerConnection.SetAsCallback Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure SetAsCallback; virtual;
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection.SetRemoteTransport Method

TnxBaseServerConnection.SetRemoteTransport Method
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Methods Send Feedback
Syntax
Delphi
procedure SetRemoteTransport(aRemoteTransport: TnxBaseRemoteTransport);
Group

TnxBaseServerConnection Methods

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Methods


TnxBaseServerConnection Properties

TnxBaseServerConnection Properties
TnxBaseServerConnection Class Legend Public Properties Send Feedback

The properties of the TnxBaseServerConnection class are listed here.

Class

TnxBaseServerConnection Class

Public Properties
Name | Description
RemoteTransportForConnection | This is RemoteTransportForConnection, a member of class TnxBaseServerConnection.
Links
TnxBaseServerConnection Class, Legend, Public Properties


TnxBaseServerConnection.RemoteTransportForConnection Property

TnxBaseServerConnection.RemoteTransportForConnection Property
TnxBaseServerConnection Class TnxBaseServerConnection Members nxptBasePooledTransport Namespace TnxBaseServerConnection Properties Send Feedback
Syntax
Delphi
property RemoteTransportForConnection: TnxBaseRemoteTransport;
Description

This is RemoteTransportForConnection, a member of class TnxBaseServerConnection.

Group

TnxBaseServerConnection Properties

Links
TnxBaseServerConnection Class, TnxBaseServerConnection Members, nxptBasePooledTransport Namespace, TnxBaseServerConnection Properties


TnxBaseServerThread Class

TnxBaseServerThread Class
TnxBaseServerThread Fields TnxBaseServerThread Methods TnxBaseServerThread Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxBaseServerThreadnxptBasePooledTransport_TnxBaseServerThreadnxptBasePooledTransport_TnxBaseServerThreadnxptBasePooledTransport_TnxBaseServerThreadnxptBasePooledTransport_TnxBaseServerThread
Syntax
Delphi
TnxBaseServerThread = class(TnxInitThread);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxBaseServerThread.

Group

Classes

Links
TnxBaseServerThread Fields, TnxBaseServerThread Methods, TnxBaseServerThread Members, nxptBasePooledTransport, Classes


TnxBaseServerThread Members

TnxBaseServerThread Members
TnxBaseServerThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxBaseServerThread.

Class

TnxBaseServerThread Class

Protected Fields
Name | Description
bstTransport | privat
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxBaseServerThread
Destroy |
Destroy |
FreeInstance |
InnerExecute |
NewInstance |
WaitForEx |
Links
TnxBaseServerThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxBaseServerThread.Create Constructor

TnxBaseServerThread.Create Constructor
TnxBaseServerThread Class TnxBaseServerThread Members nxptBasePooledTransport Namespace TnxBaseServerThread Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport);
Description

TnxBaseServerThread

Class

TnxBaseServerThread Class

Links
TnxBaseServerThread Class, TnxBaseServerThread Members, nxptBasePooledTransport Namespace, TnxBaseServerThread Class


TnxBaseServerThread Fields

TnxBaseServerThread Fields
TnxBaseServerThread Class Legend Protected Fields Send Feedback

The fields of the TnxBaseServerThread class are listed here.

Class

TnxBaseServerThread Class

Protected Fields
Name | Description
bstTransport | privat
Links
TnxBaseServerThread Class, Legend, Protected Fields


TnxBaseServerThread.bstTransport Field

TnxBaseServerThread.bstTransport Field
TnxBaseServerThread Class TnxBaseServerThread Members nxptBasePooledTransport Namespace TnxBaseServerThread Fields Send Feedback
Syntax
Delphi
bstTransport: TnxBasePooledTransport;
Description

privat

Group

TnxBaseServerThread Fields

Links
TnxBaseServerThread Class, TnxBaseServerThread Members, nxptBasePooledTransport Namespace, TnxBaseServerThread Fields


TnxBaseServerThread Methods

TnxBaseServerThread Methods
TnxBaseServerThread Class Legend Public Methods Send Feedback

The methods of the TnxBaseServerThread class are listed here.

Class

TnxBaseServerThread Class

Public Methods
Name | Description
InnerExecute |
Links
TnxBaseServerThread Class, Legend, Public Methods


TnxBaseServerThread.InnerExecute Method

TnxBaseServerThread.InnerExecute Method
TnxBaseServerThread Class TnxBaseServerThread Members nxptBasePooledTransport Namespace TnxBaseServerThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxBaseServerThread Methods

Links
TnxBaseServerThread Class, TnxBaseServerThread Members, nxptBasePooledTransport Namespace, TnxBaseServerThread Methods


TnxFreedConnectionCleanupThread Class

TnxFreedConnectionCleanupThread Class
TnxFreedConnectionCleanupThread Methods TnxFreedConnectionCleanupThread Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxFreedConnectionCleanupThreadnxptBasePooledTransport_TnxFreedConnectionCleanupThreadnxptBasePooledTransport_TnxFreedConnectionCleanupThreadnxptBasePooledTransport_TnxFreedConnectionCleanupThreadnxptBasePooledTransport_TnxFreedConnectionCleanupThreadnxptBasePooledTransport_TnxFreedConnectionCleanupThread
Syntax
Delphi
TnxFreedConnectionCleanupThread = class(TnxTimerThread);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxFreedConnectionCleanupThread.

Group

Classes

Links
TnxFreedConnectionCleanupThread Methods, TnxFreedConnectionCleanupThread Members, nxptBasePooledTransport, Classes


TnxFreedConnectionCleanupThread Members

TnxFreedConnectionCleanupThread Members
TnxFreedConnectionCleanupThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxFreedConnectionCleanupThread.

Class

TnxFreedConnectionCleanupThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
ttTimerEvent | This is ttTimerEvent, a member of class TnxTimerThread.
ttTimerInterval | This is ttTimerInterval, a member of class TnxTimerThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
DoTimer |
Execute |
InnerExecute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxFreedConnectionCleanupThread
Destroy |
Destroy |
Destroy |
FreeInstance |
NewInstance |
WaitForEx |
Links
TnxFreedConnectionCleanupThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxFreedConnectionCleanupThread.Create Constructor

TnxFreedConnectionCleanupThread.Create Constructor
TnxFreedConnectionCleanupThread Class TnxFreedConnectionCleanupThread Members nxptBasePooledTransport Namespace TnxFreedConnectionCleanupThread Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxFreedConnectionCleanupThread

Class

TnxFreedConnectionCleanupThread Class

Links
TnxFreedConnectionCleanupThread Class, TnxFreedConnectionCleanupThread Members, nxptBasePooledTransport Namespace, TnxFreedConnectionCleanupThread Class


TnxFreedConnectionCleanupThread Methods

TnxFreedConnectionCleanupThread Methods
TnxFreedConnectionCleanupThread Class Legend Protected Methods Send Feedback

The methods of the TnxFreedConnectionCleanupThread class are listed here.

Class

TnxFreedConnectionCleanupThread Class

Protected Methods
Name | Description
DoTimer |
Links
TnxFreedConnectionCleanupThread Class, Legend, Protected Methods


TnxFreedConnectionCleanupThread.DoTimer Method

TnxFreedConnectionCleanupThread.DoTimer Method
TnxFreedConnectionCleanupThread Class TnxFreedConnectionCleanupThread Members nxptBasePooledTransport Namespace TnxFreedConnectionCleanupThread Methods Send Feedback
Syntax
Delphi
procedure DoTimer; override;
Group

TnxFreedConnectionCleanupThread Methods

Links
TnxFreedConnectionCleanupThread Class, TnxFreedConnectionCleanupThread Members, nxptBasePooledTransport Namespace, TnxFreedConnectionCleanupThread Methods


TnxHeartbeatThread Class

TnxHeartbeatThread Class
TnxHeartbeatThread Fields TnxHeartbeatThread Methods TnxHeartbeatThread Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxHeartbeatThreadnxptBasePooledTransport_TnxHeartbeatThreadnxptBasePooledTransport_TnxHeartbeatThreadnxptBasePooledTransport_TnxHeartbeatThreadnxptBasePooledTransport_TnxHeartbeatThread
Syntax
Delphi
TnxHeartbeatThread = class(TnxInitThread);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxHeartbeatThread.

Group

Classes

Links
TnxHeartbeatThread Fields, TnxHeartbeatThread Methods, TnxHeartbeatThread Members, nxptBasePooledTransport, Classes


TnxHeartbeatThread Members

TnxHeartbeatThread Members
TnxHeartbeatThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxHeartbeatThread.

Class

TnxHeartbeatThread Class

Protected Fields
Name | Description
hbtShutdownEvent | This is hbtShutdownEvent, a member of class TnxHeartbeatThread.
hbtTransport | privat
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
hbtSendHeartbeat |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxHeartbeatThread
Destroy |
FreeInstance |
NewInstance |
Shutdown |
WaitForEx |
Links
TnxHeartbeatThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxHeartbeatThread.Create Constructor

TnxHeartbeatThread.Create Constructor
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport); virtual;
Description

TnxHeartbeatThread

Class

TnxHeartbeatThread Class

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Class


TnxHeartbeatThread.Destroy Destructor

TnxHeartbeatThread.Destroy Destructor
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxHeartbeatThread Class

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Class


TnxHeartbeatThread Fields

TnxHeartbeatThread Fields
TnxHeartbeatThread Class Legend Protected Fields Send Feedback

The fields of the TnxHeartbeatThread class are listed here.

Class

TnxHeartbeatThread Class

Protected Fields
Name | Description
hbtShutdownEvent | This is hbtShutdownEvent, a member of class TnxHeartbeatThread.
hbtTransport | privat
Links
TnxHeartbeatThread Class, Legend, Protected Fields


TnxHeartbeatThread.hbtShutdownEvent Field

TnxHeartbeatThread.hbtShutdownEvent Field
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Fields Send Feedback
Syntax
Delphi
hbtShutdownEvent: THandle;
Description

This is hbtShutdownEvent, a member of class TnxHeartbeatThread.

Group

TnxHeartbeatThread Fields

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Fields


TnxHeartbeatThread.hbtTransport Field

TnxHeartbeatThread.hbtTransport Field
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Fields Send Feedback
Syntax
Delphi
hbtTransport: TnxBasePooledTransport;
Description

privat

Group

TnxHeartbeatThread Fields

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Fields


TnxHeartbeatThread Methods

TnxHeartbeatThread Methods
TnxHeartbeatThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxHeartbeatThread class are listed here.

Class

TnxHeartbeatThread Class

Protected Methods
Name | Description
DoBeforeExecute |
hbtSendHeartbeat |
InnerExecute |
Public Methods
Name | Description
Shutdown |
Links
TnxHeartbeatThread Class, Legend, Protected Methods, Public Methods


TnxHeartbeatThread.DoBeforeExecute Method

TnxHeartbeatThread.DoBeforeExecute Method
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Methods Send Feedback
Syntax
Delphi
procedure DoBeforeExecute; override;
Group

TnxHeartbeatThread Methods

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Methods


TnxHeartbeatThread.hbtSendHeartbeat Method

TnxHeartbeatThread.hbtSendHeartbeat Method
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Methods Send Feedback
Syntax
Delphi
procedure hbtSendHeartbeat; virtual;
Group

TnxHeartbeatThread Methods

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Methods


TnxHeartbeatThread.InnerExecute Method

TnxHeartbeatThread.InnerExecute Method
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxHeartbeatThread Methods

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Methods


TnxHeartbeatThread.Shutdown Method

TnxHeartbeatThread.Shutdown Method
TnxHeartbeatThread Class TnxHeartbeatThread Members nxptBasePooledTransport Namespace TnxHeartbeatThread Methods Send Feedback
Syntax
Delphi
procedure Shutdown;
Group

TnxHeartbeatThread Methods

Links
TnxHeartbeatThread Class, TnxHeartbeatThread Members, nxptBasePooledTransport Namespace, TnxHeartbeatThread Methods


TnxLocalSessionCallback Class

TnxLocalSessionCallback Class
TnxLocalSessionCallback Fields TnxLocalSessionCallback Methods TnxLocalSessionCallback Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxLocalSessionCallbacknxptBasePooledTransport_TnxLocalSessionCallbacknxptBasePooledTransport_TnxLocalSessionCallbacknxptBasePooledTransport_TnxLocalSessionCallbacknxptBasePooledTransport_TnxLocalSessionCallbacknxptBasePooledTransport_TnxLocalSessionCallback
Syntax
Delphi
TnxLocalSessionCallback = class(TnxInterfacedObject, InxSessionCallback, InxSessionRequests, InxSessionInfo);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxLocalSessionCallback.

Group

Classes

Links
TnxLocalSessionCallback Fields, TnxLocalSessionCallback Methods, TnxLocalSessionCallback Members, nxptBasePooledTransport, Classes


TnxLocalSessionCallback Members

TnxLocalSessionCallback Members
TnxLocalSessionCallback Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLocalSessionCallback.

Class

TnxLocalSessionCallback Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
lscSession | This is lscSession, a member of class TnxLocalSessionCallback.
lscTransport | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Create | TnxLocalSessionCallback
GetSessionID | InxSessionInfo
ioDeactivate |
Post |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect |
QueryInterface |
Request | InxSessionCallback
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxLocalSessionCallback Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLocalSessionCallback.Create Constructor

TnxLocalSessionCallback.Create Constructor
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBaseTransport; aSession: TnxSessionID);
Description

TnxLocalSessionCallback

Class

TnxLocalSessionCallback Class

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Class


TnxLocalSessionCallback.Destroy Destructor

TnxLocalSessionCallback.Destroy Destructor
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxLocalSessionCallback Class

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Class


TnxLocalSessionCallback Fields

TnxLocalSessionCallback Fields
TnxLocalSessionCallback Class Legend Protected Fields Send Feedback

The fields of the TnxLocalSessionCallback class are listed here.

Class

TnxLocalSessionCallback Class

Protected Fields
Name | Description
lscSession | This is lscSession, a member of class TnxLocalSessionCallback.
lscTransport | private
Links
TnxLocalSessionCallback Class, Legend, Protected Fields


TnxLocalSessionCallback.lscSession Field

TnxLocalSessionCallback.lscSession Field
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Fields Send Feedback
Syntax
Delphi
lscSession: TnxSessionID;
Description

This is lscSession, a member of class TnxLocalSessionCallback.

Group

TnxLocalSessionCallback Fields

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Fields


TnxLocalSessionCallback.lscTransport Field

TnxLocalSessionCallback.lscTransport Field
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Fields Send Feedback
Syntax
Delphi
lscTransport: TnxBaseTransport;
Description

private

Group

TnxLocalSessionCallback Fields

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Fields


TnxLocalSessionCallback Methods

TnxLocalSessionCallback Methods
TnxLocalSessionCallback Class Legend Protected Methods Send Feedback

The methods of the TnxLocalSessionCallback class are listed here.

Class

TnxLocalSessionCallback Class

Protected Methods
Name | Description
GetSessionID | InxSessionInfo
Post |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect |
Request | InxSessionCallback
Links
TnxLocalSessionCallback Class, Legend, Protected Methods


TnxLocalSessionCallback.GetSessionID Method

TnxLocalSessionCallback.GetSessionID Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
function GetSessionID: TnxSessionID;
Description

InxSessionInfo

Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxLocalSessionCallback.Post Method

TnxLocalSessionCallback.Post Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Post(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer);
Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxLocalSessionCallback.ProcessPost Method

TnxLocalSessionCallback.ProcessPost Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxLocalSessionCallback.ProcessRequest Method

TnxLocalSessionCallback.ProcessRequest Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

InxSessionRequests

Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxLocalSessionCallback.ProcessRequestDirect Method

TnxLocalSessionCallback.ProcessRequestDirect Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxLocalSessionCallback.Request Method

TnxLocalSessionCallback.Request Method
TnxLocalSessionCallback Class TnxLocalSessionCallback Members nxptBasePooledTransport Namespace TnxLocalSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Request(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeOut: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer);
Description

InxSessionCallback

Group

TnxLocalSessionCallback Methods

Links
TnxLocalSessionCallback Class, TnxLocalSessionCallback Members, nxptBasePooledTransport Namespace, TnxLocalSessionCallback Methods


TnxRemoteSessionCallback Class

TnxRemoteSessionCallback Class
TnxRemoteSessionCallback Fields TnxRemoteSessionCallback Methods TnxRemoteSessionCallback Properties TnxRemoteSessionCallback Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallbacknxptBasePooledTransport_TnxRemoteSessionCallback
Syntax
Delphi
TnxRemoteSessionCallback = class(TnxInterfacedObject, InxSessionCallback, InxInternalSessionCallback, InxSessionDataStore, InxSessionRequests, InxSessionInfo, InxSessionNotifications);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxRemoteSessionCallback.

Group

Classes

Links
TnxRemoteSessionCallback Fields, TnxRemoteSessionCallback Methods, TnxRemoteSessionCallback Properties, TnxRemoteSessionCallback Members, nxptBasePooledTransport, Classes


TnxRemoteSessionCallback Members

TnxRemoteSessionCallback Members
TnxRemoteSessionCallback Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteSessionCallback.

Class

TnxRemoteSessionCallback Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
rscData | This is rscData, a member of class TnxRemoteSessionCallback.
rscLock | private
rscNotifications | This is rscNotifications, a member of class TnxRemoteSessionCallback.
rscSession | This is rscSession, a member of class TnxRemoteSessionCallback.
rscTickCount | This is rscTickCount, a member of class TnxRemoteSessionCallback.
rscTransport | This is rscTransport, a member of class TnxRemoteSessionCallback.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
AddData | InxSessionDataStore TnxRemoteSessionCallback
Create |
Disconnect | InxInternalSessionCallback
GetData |
GetSessionID | InxSessionInfo
ioDeactivate |
Post |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect |
QueryInterface |
RemoveData |
Request | InxSessionCallback
Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
AfterConstruction |
BeforeDestruction |
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
Notifications | This is Notifications, a member of class TnxRemoteSessionCallback.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxRemoteSessionCallback Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteSessionCallback.Create Constructor

TnxRemoteSessionCallback.Create Constructor
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxTransportID; aSession: TnxSessionID);
Class

TnxRemoteSessionCallback Class

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Class


TnxRemoteSessionCallback.Destroy Destructor

TnxRemoteSessionCallback.Destroy Destructor
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteSessionCallback Class

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Class


TnxRemoteSessionCallback Fields

TnxRemoteSessionCallback Fields
TnxRemoteSessionCallback Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteSessionCallback class are listed here.

Class

TnxRemoteSessionCallback Class

Protected Fields
Name | Description
rscData | This is rscData, a member of class TnxRemoteSessionCallback.
rscLock | private
rscNotifications | This is rscNotifications, a member of class TnxRemoteSessionCallback.
rscSession | This is rscSession, a member of class TnxRemoteSessionCallback.
rscTickCount | This is rscTickCount, a member of class TnxRemoteSessionCallback.
rscTransport | This is rscTransport, a member of class TnxRemoteSessionCallback.
Links
TnxRemoteSessionCallback Class, Legend, Protected Fields


TnxRemoteSessionCallback.rscData Field

TnxRemoteSessionCallback.rscData Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscData: TStringList;
Description

This is rscData, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback.rscLock Field

TnxRemoteSessionCallback.rscLock Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscLock: TnxPadlock;
Description

private

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback.rscNotifications Field

TnxRemoteSessionCallback.rscNotifications Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscNotifications: TnxSessionNotifications;
Description

This is rscNotifications, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback.rscSession Field

TnxRemoteSessionCallback.rscSession Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscSession: TnxSessionID;
Description

This is rscSession, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback.rscTickCount Field

TnxRemoteSessionCallback.rscTickCount Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscTickCount: Cardinal;
Description

This is rscTickCount, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback.rscTransport Field

TnxRemoteSessionCallback.rscTransport Field
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Fields Send Feedback
Syntax
Delphi
rscTransport: TnxTransportID;
Description

This is rscTransport, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Fields

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Fields


TnxRemoteSessionCallback Methods

TnxRemoteSessionCallback Methods
TnxRemoteSessionCallback Class Legend Protected Methods Send Feedback

The methods of the TnxRemoteSessionCallback class are listed here.

Class

TnxRemoteSessionCallback Class

Protected Methods
Name | Description
AddData | InxSessionDataStore TnxRemoteSessionCallback
Disconnect | InxInternalSessionCallback
GetData |
GetSessionID | InxSessionInfo
Post |
ProcessPost |
ProcessRequest | InxSessionRequests
ProcessRequestDirect |
RemoveData |
Request | InxSessionCallback
Links
TnxRemoteSessionCallback Class, Legend, Protected Methods


TnxRemoteSessionCallback.AddData Method

TnxRemoteSessionCallback.AddData Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function AddData(aName: string; aData: InxInterface): InxInterface;
Description

InxSessionDataStore

TnxRemoteSessionCallback

Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.Disconnect Method

TnxRemoteSessionCallback.Disconnect Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

InxInternalSessionCallback

Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.GetData Method

TnxRemoteSessionCallback.GetData Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function GetData(aName: string): InxInterface;
Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.GetSessionID Method

TnxRemoteSessionCallback.GetSessionID Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function GetSessionID: TnxSessionID;
Description

InxSessionInfo

Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.Post Method

TnxRemoteSessionCallback.Post Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Post(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aRequestData: Pointer; aRequestDataLen: TnxWord32; aTimeOut: Integer);
Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.ProcessPost Method

TnxRemoteSessionCallback.ProcessPost Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.ProcessRequest Method

TnxRemoteSessionCallback.ProcessRequest Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Description

InxSessionRequests

Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.ProcessRequestDirect Method

TnxRemoteSessionCallback.ProcessRequestDirect Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.RemoveData Method

TnxRemoteSessionCallback.RemoveData Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
function RemoveData(aName: string): InxInterface;
Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback.Request Method

TnxRemoteSessionCallback.Request Method
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Request(aThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeOut: Integer; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReplyCallback: TnxReplyCallback; aReplyCookie: Pointer);
Description

InxSessionCallback

Group

TnxRemoteSessionCallback Methods

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Methods


TnxRemoteSessionCallback Properties

TnxRemoteSessionCallback Properties
TnxRemoteSessionCallback Class Legend Public Properties Send Feedback

The properties of the TnxRemoteSessionCallback class are listed here.

Class

TnxRemoteSessionCallback Class

Public Properties
Name | Description
Notifications | This is Notifications, a member of class TnxRemoteSessionCallback.
Links
TnxRemoteSessionCallback Class, Legend, Public Properties


TnxRemoteSessionCallback.Notifications Property

TnxRemoteSessionCallback.Notifications Property
TnxRemoteSessionCallback Class TnxRemoteSessionCallback Members nxptBasePooledTransport Namespace TnxRemoteSessionCallback Properties Send Feedback
Syntax
Delphi
property Notifications: InxSessionNotifications;
Description

This is Notifications, a member of class TnxRemoteSessionCallback.

Group

TnxRemoteSessionCallback Properties

Links
TnxRemoteSessionCallback Class, TnxRemoteSessionCallback Members, nxptBasePooledTransport Namespace, TnxRemoteSessionCallback Properties


TnxWatchdogThread Class

TnxWatchdogThread Class
TnxWatchdogThread Fields TnxWatchdogThread Methods TnxWatchdogThread Members nxptBasePooledTransport Classes Send Feedback
Class Hierarchy
nxptBasePooledTransport_TnxWatchdogThreadnxptBasePooledTransport_TnxWatchdogThreadnxptBasePooledTransport_TnxWatchdogThreadnxptBasePooledTransport_TnxWatchdogThreadnxptBasePooledTransport_TnxWatchdogThread
Syntax
Delphi
TnxWatchdogThread = class(TnxInitThread);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.TnxWatchdogThread.

Group

Classes

Links
TnxWatchdogThread Fields, TnxWatchdogThread Methods, TnxWatchdogThread Members, nxptBasePooledTransport, Classes


TnxWatchdogThread Members

TnxWatchdogThread Members
TnxWatchdogThread Class Legend Protected Fields Protected Methods Protected Properties Public Methods Send Feedback

The following tables list the members exposed by TnxWatchdogThread.

Class

TnxWatchdogThread Class

Protected Fields
Name | Description
itInitException | This is itInitException, a member of class TnxInternalInitThread.
itInitSemaphore | private
nxtName | private
nxtStartTime | This is nxtStartTime, a member of class TnxThread.
wdtShutdownEvent | This is wdtShutdownEvent, a member of class TnxWatchdogThread.
wdtTransport | privat
wtWaiting | private
wtWaitSemaphore | This is wtWaitSemaphore, a member of class TnxInternalWaitThread.
Protected Methods
Name | Description
AllowExit | TnxInternalWaitThread
DoAfterExecute |
DoAfterExecute |
DoBeforeExecute |
DoExecute |
DoExecute |
DoHandleException |
DoTerminate |
Execute |
InnerExecute |
nxtCheck |
nxtError | This is the overview for the nxtError method overload.
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
nxtExceptionClass |
SetName |
WaitForExit |
WaitForInit |
wdtCheckHeartbeat |
Protected Properties
Name | Description
Waiting | This is Waiting, a member of class TnxInternalWaitThread.
Public Methods
Name | Description
AfterConstruction | TnxInitThread
AfterConstruction | TnxInternalInitThread0
AfterConstruction | This is AfterConstruction, a member of class TnxThread.
Create | TnxWatchdogThread
Destroy |
FreeInstance |
NewInstance |
Shutdown |
WaitForEx |
Links
TnxWatchdogThread Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods


TnxWatchdogThread.Create Constructor

TnxWatchdogThread.Create Constructor
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Class Send Feedback
Syntax
Delphi
constructor Create(aTransport: TnxBasePooledTransport); virtual;
Description

TnxWatchdogThread

Class

TnxWatchdogThread Class

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Class


TnxWatchdogThread.Destroy Destructor

TnxWatchdogThread.Destroy Destructor
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxWatchdogThread Class

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Class


TnxWatchdogThread Fields

TnxWatchdogThread Fields
TnxWatchdogThread Class Legend Protected Fields Send Feedback

The fields of the TnxWatchdogThread class are listed here.

Class

TnxWatchdogThread Class

Protected Fields
Name | Description
wdtShutdownEvent | This is wdtShutdownEvent, a member of class TnxWatchdogThread.
wdtTransport | privat
Links
TnxWatchdogThread Class, Legend, Protected Fields


TnxWatchdogThread.wdtShutdownEvent Field

TnxWatchdogThread.wdtShutdownEvent Field
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Fields Send Feedback
Syntax
Delphi
wdtShutdownEvent: THandle;
Description

This is wdtShutdownEvent, a member of class TnxWatchdogThread.

Group

TnxWatchdogThread Fields

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Fields


TnxWatchdogThread.wdtTransport Field

TnxWatchdogThread.wdtTransport Field
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Fields Send Feedback
Syntax
Delphi
wdtTransport: TnxBasePooledTransport;
Description

privat

Group

TnxWatchdogThread Fields

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Fields


TnxWatchdogThread Methods

TnxWatchdogThread Methods
TnxWatchdogThread Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWatchdogThread class are listed here.

Class

TnxWatchdogThread Class

Protected Methods
Name | Description
InnerExecute |
wdtCheckHeartbeat |
Public Methods
Name | Description
Shutdown |
Links
TnxWatchdogThread Class, Legend, Protected Methods, Public Methods


TnxWatchdogThread.InnerExecute Method

TnxWatchdogThread.InnerExecute Method
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Methods Send Feedback
Syntax
Delphi
procedure InnerExecute; override;
Group

TnxWatchdogThread Methods

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Methods


TnxWatchdogThread.Shutdown Method

TnxWatchdogThread.Shutdown Method
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Methods Send Feedback
Syntax
Delphi
procedure Shutdown;
Group

TnxWatchdogThread Methods

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Methods


TnxWatchdogThread.wdtCheckHeartbeat Method

TnxWatchdogThread.wdtCheckHeartbeat Method
TnxWatchdogThread Class TnxWatchdogThread Members nxptBasePooledTransport Namespace TnxWatchdogThread Methods Send Feedback
Syntax
Delphi
procedure wdtCheckHeartbeat; virtual;
Group

TnxWatchdogThread Methods

Links
TnxWatchdogThread Class, TnxWatchdogThread Members, nxptBasePooledTransport Namespace, TnxWatchdogThread Methods


Interfaces

Interfaces
nxptBasePooledTransport Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxptBasePooledTransport Namespace

Interfaces
Name | Description
InxInternalSessionCallback | This is class nxptBasePooledTransport.InxInternalSessionCallback.
Links
nxptBasePooledTransport Namespace, Interfaces, Legend


InxInternalSessionCallback Interface

InxInternalSessionCallback Interface
InxInternalSessionCallback Methods InxInternalSessionCallback Members nxptBasePooledTransport Interfaces Send Feedback
Class Hierarchy
nxptBasePooledTransport_InxInternalSessionCallbacknxptBasePooledTransport_InxInternalSessionCallback
Syntax
Delphi
InxInternalSessionCallback = interface(InxSessionCallback);
File

nxptBasePooledTransport

Description

This is class nxptBasePooledTransport.InxInternalSessionCallback.

Group

Interfaces

Links
InxInternalSessionCallback Methods, InxInternalSessionCallback Members, nxptBasePooledTransport, Interfaces


InxInternalSessionCallback Members

InxInternalSessionCallback Members
InxInternalSessionCallback Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInternalSessionCallback.

Interface

InxInternalSessionCallback Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxInternalSessionCallback.
Post | This functions posts a request and does NOT wait for the answer.
Request | This functions sends a request and waits for the answer.
Links
InxInternalSessionCallback Interface, Legend, Public Methods


InxInternalSessionCallback Methods

InxInternalSessionCallback Methods
InxInternalSessionCallback Interface Legend Public Methods Send Feedback

The methods of the InxInternalSessionCallback class are listed here.

Interface

InxInternalSessionCallback Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxInternalSessionCallback.
Links
InxInternalSessionCallback Interface, Legend, Public Methods


InxInternalSessionCallback.Disconnect Method

InxInternalSessionCallback.Disconnect Method
InxInternalSessionCallback Interface InxInternalSessionCallback Members nxptBasePooledTransport Namespace InxInternalSessionCallback Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

This is Disconnect, a member of class InxInternalSessionCallback.

Group

InxInternalSessionCallback Methods

Links
InxInternalSessionCallback Interface, InxInternalSessionCallback Members, nxptBasePooledTransport Namespace, InxInternalSessionCallback Methods


Functions

Functions
Functions nxptBasePooledTransport Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxFreedConnectionCleanupAddRef |
nxFreedConnectionCleanupRelease |
nxPooledTransportCheckWaitingConnections | OS Thread Pool support
nxPooledTransportHeartBeat |
nxPooledTransportIoCompletionCallback | This is function nxptBasePooledTransport.nxPooledTransportIoCompletionCallback.
nxPooledTransportSetEvent |
nxPooledTransportStartConnection |
nxPooledTransportWatchdog |
Namespace

nxptBasePooledTransport Namespace

Links
Functions, nxptBasePooledTransport Namespace, Legend


nxptBasePooledTransport.nxFreedConnectionCleanupAddRef Function

nxptBasePooledTransport.nxFreedConnectionCleanupAddRef Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
procedure nxFreedConnectionCleanupAddRef;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxFreedConnectionCleanupRelease Function

nxptBasePooledTransport.nxFreedConnectionCleanupRelease Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
procedure nxFreedConnectionCleanupRelease;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportCheckWaitingConnections Function

nxptBasePooledTransport.nxPooledTransportCheckWaitingConnections Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
function nxPooledTransportCheckWaitingConnections(lpThreadParameter: Pointer): Cardinal; stdcall;
File

nxptBasePooledTransport

Description

OS Thread Pool support

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportHeartBeat Function

nxptBasePooledTransport.nxPooledTransportHeartBeat Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
function nxPooledTransportHeartBeat(lpThreadParameter: Pointer): Cardinal; stdcall;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportIoCompletionCallback Function

nxptBasePooledTransport.nxPooledTransportIoCompletionCallback Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
procedure nxPooledTransportIoCompletionCallback(dwErrorCode: Cardinal; dwNumberOfBytesTransfered: Cardinal; lpOverlapped: POverlapped); stdcall;
File

nxptBasePooledTransport

Description

This is function nxptBasePooledTransport.nxPooledTransportIoCompletionCallback.

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportSetEvent Function

nxptBasePooledTransport.nxPooledTransportSetEvent Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
function nxPooledTransportSetEvent(lpThreadParameter: Pointer): Cardinal; stdcall;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportStartConnection Function

nxptBasePooledTransport.nxPooledTransportStartConnection Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
function nxPooledTransportStartConnection(lpThreadParameter: Pointer): Cardinal; stdcall;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


nxptBasePooledTransport.nxPooledTransportWatchdog Function

nxptBasePooledTransport.nxPooledTransportWatchdog Function
nxptBasePooledTransport Functions Send Feedback
Syntax
Delphi
function nxPooledTransportWatchdog(lpThreadParameter: Pointer): Cardinal; stdcall;
File

nxptBasePooledTransport

Group

Functions

Links
nxptBasePooledTransport, Functions


Structs, Records, Enums

Structs, Records, Enums
nxptBasePooledTransport Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxptBasePooledTransport Namespace

Records
Name | Description
TnxIoCompletionQueueItem | This is record nxptBasePooledTransport.TnxIoCompletionQueueItem.
TnxnmAttachServerReq | This is record nxptBasePooledTransport.TnxnmAttachServerReq.
TnxnmAttachServerRpy | This is record nxptBasePooledTransport.TnxnmAttachServerRpy.
TnxReplyInfos | This is record nxptBasePooledTransport.TnxReplyInfos.
TnxServerConnectionOverlapped | This is record nxptBasePooledTransport.TnxServerConnectionOverlapped.
Links
nxptBasePooledTransport Namespace, Legend, Records


nxptBasePooledTransport.TnxIoCompletionQueueItem Record

nxptBasePooledTransport.TnxIoCompletionQueueItem Record
nxptBasePooledTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIoCompletionQueueItem = record
  icqiNext: PnxIoCompletionQueueItem;
  icqiKey: TnxWord32;
  icqiBytes: TnxWord32;
  icqiError: TnxWord32;
end;
File

nxptBasePooledTransport

Description

This is record nxptBasePooledTransport.TnxIoCompletionQueueItem.

Group

Structs, Records, Enums

Links
nxptBasePooledTransport, Structs, Records, Enums


nxptBasePooledTransport.TnxnmAttachServerReq Record

nxptBasePooledTransport.TnxnmAttachServerReq Record
nxptBasePooledTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxnmAttachServerReq = packed record
  UserName: TnxShStr;
  Password: TnxShStr;
  Timeout: Integer;
  ClientVersion: Integer;
  IV: TnxBlowfishBlock;
  MAC: TnxBlowfishBlock;
end;
File

nxptBasePooledTransport

Description

This is record nxptBasePooledTransport.TnxnmAttachServerReq.

Group

Structs, Records, Enums

Links
nxptBasePooledTransport, Structs, Records, Enums


nxptBasePooledTransport.TnxnmAttachServerRpy Record

nxptBasePooledTransport.TnxnmAttachServerRpy Record
nxptBasePooledTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxnmAttachServerRpy = packed record
  SessionID: TnxSessionID;
  ServerVersion: Integer;
end;
File

nxptBasePooledTransport

Description

This is record nxptBasePooledTransport.TnxnmAttachServerRpy.

Group

Structs, Records, Enums

Links
nxptBasePooledTransport, Structs, Records, Enums


nxptBasePooledTransport.TnxReplyInfos Record

nxptBasePooledTransport.TnxReplyInfos Record
nxptBasePooledTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxReplyInfos = record
  Header: PnxBaseHeader;
  Connection: TnxBaseConnection;
  Session: TnxBaseRemoteSession;
end;
File

nxptBasePooledTransport

Description

This is record nxptBasePooledTransport.TnxReplyInfos.

Group

Structs, Records, Enums

Links
nxptBasePooledTransport, Structs, Records, Enums


nxptBasePooledTransport.TnxServerConnectionOverlapped Record

nxptBasePooledTransport.TnxServerConnectionOverlapped Record
nxptBasePooledTransport Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxServerConnectionOverlapped = record
  Overlapped: TOverlapped;
  Connection: TnxBaseServerConnection;
end;
File

nxptBasePooledTransport

Description

This is record nxptBasePooledTransport.TnxServerConnectionOverlapped.

Group

Structs, Records, Enums

Links
nxptBasePooledTransport, Structs, Records, Enums


Types

Types
nxptBasePooledTransport Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxptBasePooledTransport Namespace

Types
Name | Description
PnxIoCompletionQueueItem | This is type nxptBasePooledTransport.PnxIoCompletionQueueItem.
PnxnmAttachServerReq | This is type nxptBasePooledTransport.PnxnmAttachServerReq.
PnxnmAttachServerRpy | This is type nxptBasePooledTransport.PnxnmAttachServerRpy.
PnxReplyInfos | DOM-IGNORE-BEGIN
PnxServerConnectionOverlapped | This is type nxptBasePooledTransport.PnxServerConnectionOverlapped.
TnxBaseClientConnectionClass | This is type nxptBasePooledTransport.TnxBaseClientConnectionClass.
TnxBasePooledTransportClass | Class of TnxBasePooledTransport
TnxMessageReceived | This is type nxptBasePooledTransport.TnxMessageReceived.
TnxNetIdleEvent | Event type for Idle Event
Links
nxptBasePooledTransport Namespace, Types


nxptBasePooledTransport.PnxIoCompletionQueueItem Type

nxptBasePooledTransport.PnxIoCompletionQueueItem Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
PnxIoCompletionQueueItem = ^TnxIoCompletionQueueItem;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.PnxIoCompletionQueueItem.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.PnxnmAttachServerReq Type

nxptBasePooledTransport.PnxnmAttachServerReq Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
PnxnmAttachServerReq = ^TnxnmAttachServerReq;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.PnxnmAttachServerReq.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.PnxnmAttachServerRpy Type

nxptBasePooledTransport.PnxnmAttachServerRpy Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
PnxnmAttachServerRpy = ^TnxnmAttachServerRpy;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.PnxnmAttachServerRpy.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.PnxReplyInfos Type

nxptBasePooledTransport.PnxReplyInfos Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
PnxReplyInfos = ^TnxReplyInfos;
File

nxptBasePooledTransport

Description

DOM-IGNORE-BEGIN

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.PnxServerConnectionOverlapped Type

nxptBasePooledTransport.PnxServerConnectionOverlapped Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
PnxServerConnectionOverlapped = ^TnxServerConnectionOverlapped;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.PnxServerConnectionOverlapped.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.TnxBaseClientConnectionClass Type

nxptBasePooledTransport.TnxBaseClientConnectionClass Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
TnxBaseClientConnectionClass = class of TnxBaseClientConnection;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.TnxBaseClientConnectionClass.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.TnxBasePooledTransportClass Type

nxptBasePooledTransport.TnxBasePooledTransportClass Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
TnxBasePooledTransportClass = class of TnxBasePooledTransport;
File

nxptBasePooledTransport

Description

Class of TnxBasePooledTransport

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.TnxMessageReceived Type

nxptBasePooledTransport.TnxMessageReceived Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
TnxMessageReceived = procedure (aConnection : TnxBaseConnection; const aHeader : TnxBaseHeader; aBuffer : Pointer; aBufferSize : TnxWord32) of object;
File

nxptBasePooledTransport

Description

This is type nxptBasePooledTransport.TnxMessageReceived.

Group

Types

Links
nxptBasePooledTransport, Types


nxptBasePooledTransport.TnxNetIdleEvent Type

nxptBasePooledTransport.TnxNetIdleEvent Type
nxptBasePooledTransport Types Send Feedback
Syntax
Delphi
TnxNetIdleEvent = procedure (aSender: TObject; aWaitEvent: THandle) of object;
File

nxptBasePooledTransport

Description

Event type for Idle Event

Group

Types

Links
nxptBasePooledTransport, Types


Variables

Variables
nxptBasePooledTransport Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxptBasePooledTransport Namespace

Variables
Name | Description
_FreedConnectionCleanup | This is variable nxptBasePooledTransport._FreedConnectionCleanup.
_FreedConnectionCleanupRefCount | This is variable nxptBasePooledTransport._FreedConnectionCleanupRefCount.
_FreedConnectionHeads | This is variable nxptBasePooledTransport._FreedConnectionHeads.
_FreedConnectionPadlock | This is variable nxptBasePooledTransport._FreedConnectionPadlock.
_Interval | This is variable nxptBasePooledTransport._Interval.
_Mask | This is variable nxptBasePooledTransport._Mask.
_NetIdle | This is variable nxptBasePooledTransport._NetIdle.
_RemoteSessionPortal | This is variable nxptBasePooledTransport._RemoteSessionPortal.
_RemoteTransportPortal | This is variable nxptBasePooledTransport._RemoteTransportPortal.
csConnectionKey | initialized from cConnectionKey to make sure system locale doesn't mix things up, see InitConnectionKey
nxitvReplyInfos | This is variable nxptBasePooledTransport.nxitvReplyInfos.
UseIOCP | This is variable nxptBasePooledTransport.UseIOCP.
UseThreadPool | This is variable nxptBasePooledTransport.UseThreadPool.
Links
nxptBasePooledTransport Namespace, Variables


nxptBasePooledTransport._FreedConnectionCleanup Variable

nxptBasePooledTransport._FreedConnectionCleanup Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_FreedConnectionCleanup: TnxFreedConnectionCleanupThread;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._FreedConnectionCleanup.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._FreedConnectionCleanupRefCount Variable

nxptBasePooledTransport._FreedConnectionCleanupRefCount Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_FreedConnectionCleanupRefCount: Integer;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._FreedConnectionCleanupRefCount.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._FreedConnectionHeads Variable

nxptBasePooledTransport._FreedConnectionHeads Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_FreedConnectionHeads: array[0..5] of TnxBaseConnection;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._FreedConnectionHeads.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._FreedConnectionPadlock Variable

nxptBasePooledTransport._FreedConnectionPadlock Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_FreedConnectionPadlock: TnxPadlock;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._FreedConnectionPadlock.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._Interval Variable

nxptBasePooledTransport._Interval Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_Interval: Cardinal;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._Interval.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._Mask Variable

nxptBasePooledTransport._Mask Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_Mask: Cardinal;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._Mask.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._NetIdle Variable

nxptBasePooledTransport._NetIdle Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_NetIdle: TnxNetIdleEvent;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._NetIdle.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._RemoteSessionPortal Variable

nxptBasePooledTransport._RemoteSessionPortal Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_RemoteSessionPortal: TnxReadWritePortal;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._RemoteSessionPortal.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport._RemoteTransportPortal Variable

nxptBasePooledTransport._RemoteTransportPortal Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
_RemoteTransportPortal: TnxReadWritePortal;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport._RemoteTransportPortal.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport.csConnectionKey Variable

nxptBasePooledTransport.csConnectionKey Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
csConnectionKey: AnsiString;
File

nxptBasePooledTransport

Description

initialized from cConnectionKey to make sure system locale doesn't mix things up, see InitConnectionKey

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport.nxitvReplyInfos Variable

nxptBasePooledTransport.nxitvReplyInfos Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
nxitvReplyInfos: PnxReplyInfos;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport.nxitvReplyInfos.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport.UseIOCP Variable

nxptBasePooledTransport.UseIOCP Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
UseIOCP: Boolean;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport.UseIOCP.

Group

Variables

Links
nxptBasePooledTransport, Variables


nxptBasePooledTransport.UseThreadPool Variable

nxptBasePooledTransport.UseThreadPool Variable
nxptBasePooledTransport Variables Send Feedback
Syntax
Delphi
UseThreadPool: Boolean;
File

nxptBasePooledTransport

Description

This is variable nxptBasePooledTransport.UseThreadPool.

Group

Variables

Links
nxptBasePooledTransport, Variables


Constants

Constants
Constants nxptBasePooledTransport Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cConnectionKey | This is constant nxptBasePooledTransport.cConnectionKey.
nxc_AliveMarker | ALIV
nxc_MagicNumber_Session | RSES
nxc_MagicNumber_Transport | TRAN
nxDefaultHeartbeatInterval | This is constant nxptBasePooledTransport.nxDefaultHeartbeatInterval.
nxDefaultLostConnectionTimeout | This is constant nxptBasePooledTransport.nxDefaultLostConnectionTimeout.
nxDefaultWatchdogInterval | This is constant nxptBasePooledTransport.nxDefaultWatchdogInterval.
nxmtAttachTransport | This is constant nxptBasePooledTransport.nxmtAttachTransport.
nxmtError | This is constant nxptBasePooledTransport.nxmtError.
nxmtEstablishConnectionReq | This is constant nxptBasePooledTransport.nxmtEstablishConnectionReq.
nxmtEstablishConnectionRpy | This is constant nxptBasePooledTransport.nxmtEstablishConnectionRpy.
nxmtHeartbeat | This is constant nxptBasePooledTransport.nxmtHeartbeat.
nxmtPost | This is constant nxptBasePooledTransport.nxmtPost.
nxmtReply | This is constant nxptBasePooledTransport.nxmtReply.
nxmtReplyTransport | This is constant nxptBasePooledTransport.nxmtReplyTransport.
nxmtRequest | This is constant nxptBasePooledTransport.nxmtRequest.
nxmtRequestTransport | This is constant nxptBasePooledTransport.nxmtRequestTransport.
nxmtSetAsCallbackReq | This is constant nxptBasePooledTransport.nxmtSetAsCallbackReq.
nxmtSetAsCallbackRpy | This is constant nxptBasePooledTransport.nxmtSetAsCallbackRpy.
nxmtTerminateConnection | This is constant nxptBasePooledTransport.nxmtTerminateConnection.
nxmvCurrentVersion | This is constant nxptBasePooledTransport.nxmvCurrentVersion.
nxnmAttachServer | This is constant nxptBasePooledTransport.nxnmAttachServer.
rsCallbacksAreNotSupported | This is constant nxptBasePooledTransport.rsCallbacksAreNotSupported.
rsExplicitThreadNotSupported | This is constant nxptBasePooledTransport.rsExplicitThreadNotSupported.
rsRemoteTransportIsClosing | DOM-IGNORE-BEGIN
Namespace

nxptBasePooledTransport Namespace

Links
Constants, nxptBasePooledTransport Namespace


nxptBasePooledTransport.cConnectionKey Constant

nxptBasePooledTransport.cConnectionKey Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
cConnectionKey: array[1..64] of byte = (118, 104, 110, 106, 111, 105, 110, 252, 49, 50, 52, 48, 37, 38, 34, 167, 246, 37, 57, 52, 56, 117, 55, 115, 100, 108, 106, 36, 37, 38, 86, 78, 81, 50, 51, 122, 104, 101, 105, 38, 106, 103, 119, 110, 119, 98, 103, 50, 49, 52, 54, 51, 228, 53, 110, 98, 68, 50, 48, 52, 57, 54, 85, 87);
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.cConnectionKey.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxc_AliveMarker Constant

nxptBasePooledTransport.nxc_AliveMarker Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxc_AliveMarker: Integer = Integer($FF0B85FF);
File

nxptBasePooledTransport

Description

ALIV

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxc_MagicNumber_Session Constant

nxptBasePooledTransport.nxc_MagicNumber_Session Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxc_MagicNumber_Session: TnxWord32 = $FF1242FF;
File

nxptBasePooledTransport

Description

RSES

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxc_MagicNumber_Transport Constant

nxptBasePooledTransport.nxc_MagicNumber_Transport Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxc_MagicNumber_Transport: TnxWord32 = $FF310DFF;
File

nxptBasePooledTransport

Description

TRAN

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxDefaultHeartbeatInterval Constant

nxptBasePooledTransport.nxDefaultHeartbeatInterval Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxDefaultHeartbeatInterval = 10000;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxDefaultHeartbeatInterval.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxDefaultLostConnectionTimeout Constant

nxptBasePooledTransport.nxDefaultLostConnectionTimeout Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxDefaultLostConnectionTimeout = 10000;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxDefaultLostConnectionTimeout.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxDefaultWatchdogInterval Constant

nxptBasePooledTransport.nxDefaultWatchdogInterval Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxDefaultWatchdogInterval = 10000;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxDefaultWatchdogInterval.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtAttachTransport Constant

nxptBasePooledTransport.nxmtAttachTransport Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtAttachTransport = 12;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtAttachTransport.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtError Constant

nxptBasePooledTransport.nxmtError Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtError = 255;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtError.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtEstablishConnectionReq Constant

nxptBasePooledTransport.nxmtEstablishConnectionReq Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtEstablishConnectionReq = 20;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtEstablishConnectionReq.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtEstablishConnectionRpy Constant

nxptBasePooledTransport.nxmtEstablishConnectionRpy Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtEstablishConnectionRpy = 21;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtEstablishConnectionRpy.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtHeartbeat Constant

nxptBasePooledTransport.nxmtHeartbeat Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtHeartbeat = 254;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtHeartbeat.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtPost Constant

nxptBasePooledTransport.nxmtPost Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtPost = 3;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtPost.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtReply Constant

nxptBasePooledTransport.nxmtReply Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtReply = 2;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtReply.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtReplyTransport Constant

nxptBasePooledTransport.nxmtReplyTransport Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtReplyTransport = 11;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtReplyTransport.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtRequest Constant

nxptBasePooledTransport.nxmtRequest Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtRequest = 1;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtRequest.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtRequestTransport Constant

nxptBasePooledTransport.nxmtRequestTransport Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtRequestTransport = 10;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtRequestTransport.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtSetAsCallbackReq Constant

nxptBasePooledTransport.nxmtSetAsCallbackReq Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtSetAsCallbackReq = 30;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtSetAsCallbackReq.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtSetAsCallbackRpy Constant

nxptBasePooledTransport.nxmtSetAsCallbackRpy Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtSetAsCallbackRpy = 31;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtSetAsCallbackRpy.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmtTerminateConnection Constant

nxptBasePooledTransport.nxmtTerminateConnection Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmtTerminateConnection = 22;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmtTerminateConnection.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxmvCurrentVersion Constant

nxptBasePooledTransport.nxmvCurrentVersion Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxmvCurrentVersion = 2;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxmvCurrentVersion.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.nxnmAttachServer Constant

nxptBasePooledTransport.nxnmAttachServer Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
nxnmAttachServer = $0001;
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.nxnmAttachServer.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.rsCallbacksAreNotSupported Constant

nxptBasePooledTransport.rsCallbacksAreNotSupported Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
rsCallbacksAreNotSupported = 'Callbacks are not supported by this connecti' + 'on';
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.rsCallbacksAreNotSupported.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.rsExplicitThreadNotSupported Constant

nxptBasePooledTransport.rsExplicitThreadNotSupported Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
rsExplicitThreadNotSupported = 'Explicit Thread creation is not supported ' + 'while UseThreadPool is true';
File

nxptBasePooledTransport

Description

This is constant nxptBasePooledTransport.rsExplicitThreadNotSupported.

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptBasePooledTransport.rsRemoteTransportIsClosing Constant

nxptBasePooledTransport.rsRemoteTransportIsClosing Constant
nxptBasePooledTransport Constants Send Feedback
Syntax
Delphi
rsRemoteTransportIsClosing = 'RemoteTransport is closing';
File

nxptBasePooledTransport

Description

DOM-IGNORE-BEGIN

Group

Constants

Links
nxptBasePooledTransport, Constants


nxptTCPRequestTransport Namespace

nxptTCPRequestTransport Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxptTCPRequestTransport.

Classes
Name | Description
TnxptTCPRequestTransport | This is class nxptTCPRequestTransport.TnxptTCPRequestTransport.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
_TChangeSetup | This is type nxptTCPRequestTransport._TChangeSetup.
_TFinalize | This is type nxptTCPRequestTransport._TFinalize.
_TGetStatsValues | This is type nxptTCPRequestTransport._TGetStatsValues.
_TInitialize | This is type nxptTCPRequestTransport._TInitialize.
_TIsActive | This is type nxptTCPRequestTransport._TIsActive.
_TStart | This is type nxptTCPRequestTransport._TStart.
_TStop | This is type nxptTCPRequestTransport._TStop.
Variables
Name | Description
_ChangeSetup | This is variable nxptTCPRequestTransport._ChangeSetup.
_DLLHandle | This is variable nxptTCPRequestTransport._DLLHandle.
_Finalize | This is variable nxptTCPRequestTransport._Finalize.
_GetStatsValues | This is variable nxptTCPRequestTransport._GetStatsValues.
_Initialize | This is variable nxptTCPRequestTransport._Initialize.
_IsActive | This is variable nxptTCPRequestTransport._IsActive.
_Start | This is variable nxptTCPRequestTransport._Start.
_Stop | This is variable nxptTCPRequestTransport._Stop.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxptTCPRequestTransport Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxptTCPRequestTransport | This is class nxptTCPRequestTransport.TnxptTCPRequestTransport.
Namespace

nxptTCPRequestTransport Namespace

Links
Classes, nxptTCPRequestTransport Namespace, Legend


TnxptTCPRequestTransport Class

TnxptTCPRequestTransport Class
TnxptTCPRequestTransport Fields TnxptTCPRequestTransport Methods TnxptTCPRequestTransport Properties TnxptTCPRequestTransport Members nxptTCPRequestTransport Classes Send Feedback
Class Hierarchy
nxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransportnxptTCPRequestTransport_TnxptTCPRequestTransport
Syntax
Delphi
TnxptTCPRequestTransport = class(TnxBaseDirectTransport);
File

nxptTCPRequestTransport

Description

This is class nxptTCPRequestTransport.TnxptTCPRequestTransport.

Group

Classes

Links
TnxptTCPRequestTransport Fields, TnxptTCPRequestTransport Methods, TnxptTCPRequestTransport Properties, TnxptTCPRequestTransport Members, nxptTCPRequestTransport, Classes


TnxptTCPRequestTransport Members

TnxptTCPRequestTransport Members
TnxptTCPRequestTransport Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxptTCPRequestTransport.

Class

TnxptTCPRequestTransport Class

Protected Fields
Name | Description
btActualBytesReceived | This is btActualBytesReceived, a member of class TnxBaseTransport.
btActualBytesSent | This is btActualBytesSent, a member of class TnxBaseTransport.
btCmdHandler | This is btCmdHandler, a member of class TnxBaseTransport.
btCompressTime | This is btCompressTime, a member of class TnxBaseTransport.
btKeepStats | This is btKeepStats, a member of class TnxBaseTransport.
btLastReceived | This is btLastReceived, a member of class TnxBaseTransport.
btLastSent | This is btLastSent, a member of class TnxBaseTransport.
btLogOptions | This is btLogOptions, a member of class TnxBaseTransport.
btMaxBytesPerSecond | This is btMaxBytesPerSecond, a member of class TnxBaseTransport.
btMessagesReceived | This is btMessagesReceived, a member of class TnxBaseTransport.
btMessagesSent | This is btMessagesSent, a member of class TnxBaseTransport.
btMode | This is btMode, a member of class TnxBaseTransport.
btMsgCount | This is btMsgCount, a member of class TnxBaseTransport.
btOnAddSession | This is btOnAddSession, a member of class TnxBaseTransport.
btOnChooseServer | This is btOnChooseServer, a member of class TnxBaseTransport.
btOnConnectionLost | This is btOnConnectionLost, a member of class TnxBaseTransport.
btOnFindServers | This is btOnFindServers, a member of class TnxBaseTransport.
btOnRemoveSession | This is btOnRemoveSession, a member of class TnxBaseTransport.
btPingTime | This is btPingTime, a member of class TnxBaseTransport.
btReceivedThisSecond | This is btReceivedThisSecond, a member of class TnxBaseTransport.
btRespondToBroadcasts | This is btRespondToBroadcasts, a member of class TnxBaseTransport.
btSentThisSecond | private.
btServerNameDesigntime | This is btServerNameDesigntime, a member of class TnxBaseTransport.
btServerNameRuntime | This is btServerNameRuntime, a member of class TnxBaseTransport.
btStatsPadLock | This is btStatsPadLock, a member of class TnxBaseTransport.
btThreadPriorityMax | This is btThreadPriorityMax, a member of class TnxBaseTransport.
btThreadPriorityMin | This is btThreadPriorityMin, a member of class TnxBaseTransport.
btTimeout | This is btTimeout, a member of class TnxBaseTransport.
btUncompressedBytesReceived | This is btUncompressedBytesReceived, a member of class TnxBaseTransport.
btUncompressedBytesSent | This is btUncompressedBytesSent, a member of class TnxBaseTransport.
btUnCompressTime | This is btUnCompressTime, a member of class TnxBaseTransport.
fAdditionalSettings | This is fAdditionalSettings, a member of class TnxptTCPRequestTransport.
fDLLLoaded | This is fDLLLoaded, a member of class TnxptTCPRequestTransport.
fError | This is fError, a member of class TnxptTCPRequestTransport.
fPort | This is fPort, a member of class TnxptTCPRequestTransport.
fRemoteServerName | This is fRemoteServerName, a member of class TnxptTCPRequestTransport.
fServerEngine | This is fServerEngine, a member of class TnxptTCPRequestTransport.
fServerPort | This is fServerPort, a member of class TnxptTCPRequestTransport.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
btAddSession | TnxBaseTransport
btCheckListener |
btCheckSender |
btCheckServerName |
btCheckupServerName |
btChooseServer |
btConnectionLost |
btDetectServer |
btDoReadThrottle |
btDoWriteThrottle |
btFindServerName |
btFindServers |
btGetActualBytesReceived |
btGetActualBytesSent |
btGetCompressTime |
btGetMaxBytesPerSecond |
btGetMessagesReceived |
btGetMessagesSent |
btGetPingTime |
btGetServerGUID |
btGetServername |
btGetUncompressedBytesReceived |
btGetUncompressedBytesSent |
btGetUncompressTime |
btIncStats |
btInternalGetSessionCallback |
btInternalReply |
btLimitThreadPriority |
btProcess |
btRemoveSession |
btSessionFailed |
btSetCmdHandler |
btSetMaxBytesPerSecond |
btSetMode |
btSetPingTime |
btSetRespondToBroadcasts |
btSetServername |
btSetServerNameDesigntime |
btSetServerNameRuntime |
btStoreSelfInThreadvar |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded | This is Loaded, a member of class TnxStateComponent.
Loaded |
LoadTransportDLL | This is LoadTransportDLL, a member of class TnxptTCPRequestTransport.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowLastStartErrorInStats |
scShowUpTime |
scShowUpTime |
scStarted |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
SetAdditionalSettings | This is SetAdditionalSettings, a member of class TnxptTCPRequestTransport.
SetPort | This is SetPort, a member of class TnxptTCPRequestTransport.
SetRemoteServerName | This is SetRemoteServerName, a member of class TnxptTCPRequestTransport.
SetServerEngine | This is SetServerEngine, a member of class TnxptTCPRequestTransport.
SetServerPort | This is SetServerPort, a member of class TnxptTCPRequestTransport.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
BeginBroadcast | This function returns an InxActiveBroadcast and will start sending out server discovery broadcast every aInterval seconds. The broadcasting can be suspended or stopped using the returned InxActiveBroadcast interface. To get an event triggered for each reply received from a server, pass in an InxBroadcastReplyHandler. The ReplyReceived method of the passed in aHandler will be called.
Broadcast | This function initiates a broadcast for servers.
btDoCallBack | This function executes a callback function with the given parameters.
ClearStats | Resets all internal stats.
ClearStats | This function resets all statistics for the transport.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
ConnectionCount | This function returns the number of physical connections.
Create | TnxptTCPRequestTransport
CurrentTransport | This function returns the currently active transport.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
EstablishConnection | This function establishes a connection and returns the session id. This function sends a request to the server and then waits for the reply.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetBoundAddresses | This function returns a list of addresses for the transport.
GetComponentID |
GetConfigSettings | Returns the Configuration settings for the UI
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetName | This function returns the name of the transport.
GetRegisteredClasses | Adds itself to the list of registered classes.
GetServerNames | This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.
GetSessionCallback | This function returns an interface that can be used to send callbacks to the session that initiated the currently active call. May return nil.
GetStatsCaptions | see TnxComponent.GetStatsCaptions
GetStatsValues | see TnxComponent.GetStatsValues
IsConnected | IsConnected returns true if the current transport has an open connection.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig | Loads the transport settings.
LoadSettingsFromStream | This function loads the Transport settings from a stream using aReader.
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
Post | This functions posts a request and does NOT wait for the answer.
ProtocolName | This function returns the name of the transport.
Reply | This function is called to reply to a request
Request | This functions sends a request and waits for the answer.
ResetMsgCount | This function sets the MsgCount stats to 0.
SaveConfig | Saves the transport settings.
SaveSettingsToStream | This function saves the Transport settings to a stream using aWriter.
scSetActive |
scStarting |
scStopping |
SettingsChanged | This is SettingsChanged, a member of class TnxptTCPRequestTransport.
Sleep | This function forces the transport to sleep for aTimeOut msec.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
TerminateConnection | This function closes a connection.
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Write | This functions transfers the given information to the other connection point by wrapping it into a TnxDataMessage and sending it over an open connection.
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
ActualBytesReceived | The number of bytes received since the last clearing.
ActualBytesSent | The number of bytes sent since the last clearing.
CompressTime | The total time used for compressing data.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
DllLoaded | This is DllLoaded, a member of class TnxptTCPRequestTransport.
MessagesReceived | The number of Messages received since the last clearing.
MessagesSent | The number of Messages sent since the last clearing.
MsgCount | The total number of messages transferred.
SavedActive | Can be used to save a certain state.
ServerGUID | This is ServerGUID, a member of class TnxBaseTransport.
ServerName | The Server Name. If in listening mode it's the name of the clients have to connect to. In sending mode it's the name the transport gets connected to.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
UncompressedBytesReceived | The number of bytes received after uncompression since the last clearing.
UncompressedBytesSent | The number of bytes sent after uncompression since the last clearing.
UncompressTime | The total time used for uncompressing data.
Published Events
Name | Description
OnAddSession | OnAddSession is called every time a session connects to the transport if it is in listening mode.
OnChooseServer | OnChooseServer is called in sending mode, if more than one server was found for broadcast
OnConnectionLost | OnConnectionLost is called if the transport detects a drop of a connection.
OnFindServers | OnFindServers is called before and after broadcasting for servers.
OnRemoveSession | OnAddSession is called every time a session disconnects from a transport if it is in listening mode.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
AdditionalSettings | This is AdditionalSettings, a member of class TnxptTCPRequestTransport.
CommandHandler | This property points to the connected Command Handler.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
Error | This is Error, a member of class TnxptTCPRequestTransport.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
EventLogOptions | The log options for the event.
KeepStats | Should the stats be updated or not. On high volume servers on the edge of capacity switch this off
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
MaxBytesPerSecond | This is a maximum bytes per second setting for the transport. It is experimental and helps to test the transport for slow connections.
Mode | The mode of the transport.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
PingTime | This is a minimum turnaround time setting in msec for the transport. It is experimental and helps to test the transport for slow connections.
Port | This is Port, a member of class TnxptTCPRequestTransport.
RemoteServerName | This is RemoteServerName, a member of class TnxptTCPRequestTransport.
RemoteServerPort | This is RemoteServerPort, a member of class TnxptTCPRequestTransport.
RespondToBroadcasts | If the server is in listening it responds to broadcast requests if this property is set to true.
ServerEngine | This is ServerEngine, a member of class TnxptTCPRequestTransport.
ServerNameDesigntime | This is the Server Name property at design time.
ServerNameRuntime | This is the Server Name property at runtime.
ThreadPriorityMax | Maximum possible Threadpriority
ThreadPriorityMin | Minimal possible Threadpriority
Timeout | The timeout of the transport in msec.
Version | Version of the component.
Links
TnxptTCPRequestTransport Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxptTCPRequestTransport.Create Constructor

TnxptTCPRequestTransport.Create Constructor
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

TnxptTCPRequestTransport

Class

TnxptTCPRequestTransport Class

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Class


TnxptTCPRequestTransport.Destroy Destructor

TnxptTCPRequestTransport.Destroy Destructor
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxptTCPRequestTransport Class

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Class


TnxptTCPRequestTransport Fields

TnxptTCPRequestTransport Fields
TnxptTCPRequestTransport Class Legend Protected Fields Send Feedback

The fields of the TnxptTCPRequestTransport class are listed here.

Class

TnxptTCPRequestTransport Class

Protected Fields
Name | Description
fAdditionalSettings | This is fAdditionalSettings, a member of class TnxptTCPRequestTransport.
fDLLLoaded | This is fDLLLoaded, a member of class TnxptTCPRequestTransport.
fError | This is fError, a member of class TnxptTCPRequestTransport.
fPort | This is fPort, a member of class TnxptTCPRequestTransport.
fRemoteServerName | This is fRemoteServerName, a member of class TnxptTCPRequestTransport.
fServerEngine | This is fServerEngine, a member of class TnxptTCPRequestTransport.
fServerPort | This is fServerPort, a member of class TnxptTCPRequestTransport.
Links
TnxptTCPRequestTransport Class, Legend, Protected Fields


TnxptTCPRequestTransport.fAdditionalSettings Field

TnxptTCPRequestTransport.fAdditionalSettings Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fAdditionalSettings: AnsiString;
Description

This is fAdditionalSettings, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fDLLLoaded Field

TnxptTCPRequestTransport.fDLLLoaded Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fDLLLoaded: Boolean;
Description

This is fDLLLoaded, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fError Field

TnxptTCPRequestTransport.fError Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fError: String;
Description

This is fError, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fPort Field

TnxptTCPRequestTransport.fPort Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fPort: integer;
Description

This is fPort, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fRemoteServerName Field

TnxptTCPRequestTransport.fRemoteServerName Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fRemoteServerName: AnsiString;
Description

This is fRemoteServerName, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fServerEngine Field

TnxptTCPRequestTransport.fServerEngine Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fServerEngine: TnxBaseServerEngine;
Description

This is fServerEngine, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport.fServerPort Field

TnxptTCPRequestTransport.fServerPort Field
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Fields Send Feedback
Syntax
Delphi
fServerPort: integer;
Description

This is fServerPort, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Fields

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Fields


TnxptTCPRequestTransport Methods

TnxptTCPRequestTransport Methods
TnxptTCPRequestTransport Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxptTCPRequestTransport class are listed here.

Class

TnxptTCPRequestTransport Class

Protected Methods
Name | Description
LoadTransportDLL | This is LoadTransportDLL, a member of class TnxptTCPRequestTransport.
SetAdditionalSettings | This is SetAdditionalSettings, a member of class TnxptTCPRequestTransport.
SetPort | This is SetPort, a member of class TnxptTCPRequestTransport.
SetRemoteServerName | This is SetRemoteServerName, a member of class TnxptTCPRequestTransport.
SetServerEngine | This is SetServerEngine, a member of class TnxptTCPRequestTransport.
SetServerPort | This is SetServerPort, a member of class TnxptTCPRequestTransport.
Public Methods
Name | Description
GetConfigSettings | Returns the Configuration settings for the UI
GetServerNames | This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.
GetStatsCaptions | see TnxComponent.GetStatsCaptions
GetStatsValues | see TnxComponent.GetStatsValues
LoadConfig | Loads the transport settings.
LoadSettingsFromStream | This function loads the Transport settings from a stream using aReader.
SaveConfig | Saves the transport settings.
SaveSettingsToStream | This function saves the Transport settings to a stream using aWriter.
scSetActive |
scStarting |
scStopping |
SettingsChanged | This is SettingsChanged, a member of class TnxptTCPRequestTransport.
Links
TnxptTCPRequestTransport Class, Legend, Protected Methods, Public Methods


TnxptTCPRequestTransport.GetConfigSettings Method

TnxptTCPRequestTransport.GetConfigSettings Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Description

Returns the Configuration settings for the UI

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.GetServerNames Method

TnxptTCPRequestTransport.GetServerNames Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure GetServerNames(aList: TStrings; aTimeOut: TnxWord32); override;
Description

This function returns the addresses of all servers found for the current transport by using broadcast. aTimeOut specifies the timeout in msec for the broadcast.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.GetStatsCaptions Method

TnxptTCPRequestTransport.GetStatsCaptions Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); override;
Description

see TnxComponent.GetStatsCaptions

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.GetStatsValues Method

TnxptTCPRequestTransport.GetStatsValues Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); override;
Description

see TnxComponent.GetStatsValues

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.LoadConfig Method

TnxptTCPRequestTransport.LoadConfig Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Description

Loads the transport settings.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.LoadSettingsFromStream Method

TnxptTCPRequestTransport.LoadSettingsFromStream Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure LoadSettingsFromStream(aReader: TnxReader); override;
Description

This function loads the Transport settings from a stream using aReader.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.LoadTransportDLL Method

TnxptTCPRequestTransport.LoadTransportDLL Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure LoadTransportDLL;
Description

This is LoadTransportDLL, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SaveConfig Method

TnxptTCPRequestTransport.SaveConfig Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Description

Saves the transport settings.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SaveSettingsToStream Method

TnxptTCPRequestTransport.SaveSettingsToStream Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SaveSettingsToStream(aWriter: TnxWriter); override;
Description

This function saves the Transport settings to a stream using aWriter.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.scSetActive Method

TnxptTCPRequestTransport.scSetActive Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure scSetActive(const aActive: Boolean); override;
Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.scStarting Method

TnxptTCPRequestTransport.scStarting Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.scStopping Method

TnxptTCPRequestTransport.scStopping Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SetAdditionalSettings Method

TnxptTCPRequestTransport.SetAdditionalSettings Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SetAdditionalSettings(const Value: AnsiString);
Description

This is SetAdditionalSettings, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SetPort Method

TnxptTCPRequestTransport.SetPort Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SetPort(const Value: integer); virtual;
Description

This is SetPort, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SetRemoteServerName Method

TnxptTCPRequestTransport.SetRemoteServerName Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SetRemoteServerName(const Value: AnsiString);
Description

This is SetRemoteServerName, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SetServerEngine Method

TnxptTCPRequestTransport.SetServerEngine Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SetServerEngine(const Value: TnxBaseServerEngine);
Description

This is SetServerEngine, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SetServerPort Method

TnxptTCPRequestTransport.SetServerPort Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SetServerPort(const Value: integer);
Description

This is SetServerPort, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport.SettingsChanged Method

TnxptTCPRequestTransport.SettingsChanged Method
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Methods Send Feedback
Syntax
Delphi
procedure SettingsChanged;
Description

This is SettingsChanged, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Methods

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Methods


TnxptTCPRequestTransport Properties

TnxptTCPRequestTransport Properties
TnxptTCPRequestTransport Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxptTCPRequestTransport class are listed here.

Class

TnxptTCPRequestTransport Class

Public Properties
Name | Description
DllLoaded | This is DllLoaded, a member of class TnxptTCPRequestTransport.
Published Properties
Name | Description
AdditionalSettings | This is AdditionalSettings, a member of class TnxptTCPRequestTransport.
Error | This is Error, a member of class TnxptTCPRequestTransport.
Port | This is Port, a member of class TnxptTCPRequestTransport.
RemoteServerName | This is RemoteServerName, a member of class TnxptTCPRequestTransport.
RemoteServerPort | This is RemoteServerPort, a member of class TnxptTCPRequestTransport.
ServerEngine | This is ServerEngine, a member of class TnxptTCPRequestTransport.
Links
TnxptTCPRequestTransport Class, Legend, Public Properties, Published Properties


TnxptTCPRequestTransport.AdditionalSettings Property

TnxptTCPRequestTransport.AdditionalSettings Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property AdditionalSettings: AnsiString;
Description

This is AdditionalSettings, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.DllLoaded Property

TnxptTCPRequestTransport.DllLoaded Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property DllLoaded: Boolean;
Description

This is DllLoaded, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.Error Property

TnxptTCPRequestTransport.Error Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property Error: string;
Description

This is Error, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.Port Property

TnxptTCPRequestTransport.Port Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property Port: integer;
Description

This is Port, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.RemoteServerName Property

TnxptTCPRequestTransport.RemoteServerName Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property RemoteServerName: AnsiString;
Description

This is RemoteServerName, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.RemoteServerPort Property

TnxptTCPRequestTransport.RemoteServerPort Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property RemoteServerPort: integer;
Description

This is RemoteServerPort, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


TnxptTCPRequestTransport.ServerEngine Property

TnxptTCPRequestTransport.ServerEngine Property
TnxptTCPRequestTransport Class TnxptTCPRequestTransport Members nxptTCPRequestTransport Namespace TnxptTCPRequestTransport Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

This is ServerEngine, a member of class TnxptTCPRequestTransport.

Group

TnxptTCPRequestTransport Properties

Links
TnxptTCPRequestTransport Class, TnxptTCPRequestTransport Members, nxptTCPRequestTransport Namespace, TnxptTCPRequestTransport Properties


Types

Types
nxptTCPRequestTransport Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxptTCPRequestTransport Namespace

Types
Name | Description
_TChangeSetup | This is type nxptTCPRequestTransport._TChangeSetup.
_TFinalize | This is type nxptTCPRequestTransport._TFinalize.
_TGetStatsValues | This is type nxptTCPRequestTransport._TGetStatsValues.
_TInitialize | This is type nxptTCPRequestTransport._TInitialize.
_TIsActive | This is type nxptTCPRequestTransport._TIsActive.
_TStart | This is type nxptTCPRequestTransport._TStart.
_TStop | This is type nxptTCPRequestTransport._TStop.
Links
nxptTCPRequestTransport Namespace, Types


nxptTCPRequestTransport._TChangeSetup Type

nxptTCPRequestTransport._TChangeSetup Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TChangeSetup = function (aSettings: PAnsiChar): integer;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TChangeSetup.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TFinalize Type

nxptTCPRequestTransport._TFinalize Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TFinalize = function : integer;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TFinalize.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TGetStatsValues Type

nxptTCPRequestTransport._TGetStatsValues Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TGetStatsValues = function (const aRecordVersion: Integer) : TGetStatsValuesRec;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TGetStatsValues.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TInitialize Type

nxptTCPRequestTransport._TInitialize Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TInitialize = function (aSettings: PAnsiChar): integer;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TInitialize.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TIsActive Type

nxptTCPRequestTransport._TIsActive Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TIsActive = function : boolean;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TIsActive.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TStart Type

nxptTCPRequestTransport._TStart Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TStart = function : integer;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TStart.

Group

Types

Links
nxptTCPRequestTransport, Types


nxptTCPRequestTransport._TStop Type

nxptTCPRequestTransport._TStop Type
nxptTCPRequestTransport Types Send Feedback
Syntax
Delphi
_TStop = function : integer;
File

nxptTCPRequestTransport

Description

This is type nxptTCPRequestTransport._TStop.

Group

Types

Links
nxptTCPRequestTransport, Types


Variables

Variables
nxptTCPRequestTransport Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxptTCPRequestTransport Namespace

Variables
Name | Description
_ChangeSetup | This is variable nxptTCPRequestTransport._ChangeSetup.
_DLLHandle | This is variable nxptTCPRequestTransport._DLLHandle.
_Finalize | This is variable nxptTCPRequestTransport._Finalize.
_GetStatsValues | This is variable nxptTCPRequestTransport._GetStatsValues.
_Initialize | This is variable nxptTCPRequestTransport._Initialize.
_IsActive | This is variable nxptTCPRequestTransport._IsActive.
_Start | This is variable nxptTCPRequestTransport._Start.
_Stop | This is variable nxptTCPRequestTransport._Stop.
Links
nxptTCPRequestTransport Namespace, Variables


nxptTCPRequestTransport._ChangeSetup Variable

nxptTCPRequestTransport._ChangeSetup Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_ChangeSetup: _TChangeSetup = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._ChangeSetup.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._DLLHandle Variable

nxptTCPRequestTransport._DLLHandle Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_DLLHandle: THandle = 0;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._DLLHandle.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._Finalize Variable

nxptTCPRequestTransport._Finalize Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_Finalize: _TFinalize = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._Finalize.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._GetStatsValues Variable

nxptTCPRequestTransport._GetStatsValues Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_GetStatsValues: _TGetStatsValues = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._GetStatsValues.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._Initialize Variable

nxptTCPRequestTransport._Initialize Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_Initialize: _TInitialize = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._Initialize.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._IsActive Variable

nxptTCPRequestTransport._IsActive Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_IsActive: _TIsActive = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._IsActive.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._Start Variable

nxptTCPRequestTransport._Start Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_Start: _TStart = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._Start.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxptTCPRequestTransport._Stop Variable

nxptTCPRequestTransport._Stop Variable
nxptTCPRequestTransport Variables Send Feedback
Syntax
Delphi
_Stop: _TStop = nil;
File

nxptTCPRequestTransport

Description

This is variable nxptTCPRequestTransport._Stop.

Group

Variables

Links
nxptTCPRequestTransport, Variables


nxpvAboutFrm Namespace

nxpvAboutFrm Namespace
Classes Constants Functions Legend Topics Send Feedback

This is namespace nxpvAboutFrm.

Classes
Name | Description
TLabel | This is class nxpvAboutFrm.TLabel.
TnxAboutFrm | This is class nxpvAboutFrm.TnxAboutFrm.
Constants
Name | Description
cnxBrowserError | This is constant nxpvAboutFrm.cnxBrowserError.
cnxNewsClientError | This is constant nxpvAboutFrm.cnxNewsClientError.
Domains | This is constant nxpvAboutFrm.Domains.
Functions
Name | Description
ShellToNews |
ShellToWWW | ShellTo functions
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Functions, Legend, Topics


Classes

Classes
Classes nxpvAboutFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TLabel | This is class nxpvAboutFrm.TLabel.
TnxAboutFrm | This is class nxpvAboutFrm.TnxAboutFrm.
Namespace

nxpvAboutFrm Namespace

Links
Classes, nxpvAboutFrm Namespace, Legend


TLabel Class

TLabel Class
TLabel Fields TLabel Methods TLabel Members nxpvAboutFrm Classes Send Feedback
Class Hierarchy
nxpvAboutFrm_TLabel
Syntax
Delphi
TLabel = class(StdCtrls.TLabel);
File

nxpvAboutFrm

Description

This is class nxpvAboutFrm.TLabel.

Group

Classes

Links
TLabel Fields, TLabel Methods, TLabel Members, nxpvAboutFrm, Classes


TLabel Members

TLabel Members
TLabel Class Legend Protected Fields Protected Methods Send Feedback

The following tables list the members exposed by TLabel.

Class

TLabel Class

Protected Fields
Name | Description
ShowHover | This is ShowHover, a member of class TLabel.
Protected Methods
Name | Description
CmMouseEnter | TLabel
CmMouseLeave | This is CmMouseLeave, a member of class TLabel.
Links
TLabel Class, Legend, Protected Fields, Protected Methods


TLabel Fields

TLabel Fields
TLabel Class Legend Protected Fields Send Feedback

The fields of the TLabel class are listed here.

Class

TLabel Class

Protected Fields
Name | Description
ShowHover | This is ShowHover, a member of class TLabel.
Links
TLabel Class, Legend, Protected Fields


TLabel.ShowHover Field

TLabel.ShowHover Field
TLabel Class TLabel Members nxpvAboutFrm Namespace TLabel Fields Send Feedback
Syntax
Delphi
ShowHover: Boolean;
Description

This is ShowHover, a member of class TLabel.

Group

TLabel Fields

Links
TLabel Class, TLabel Members, nxpvAboutFrm Namespace, TLabel Fields


TLabel Methods

TLabel Methods
TLabel Class Legend Protected Methods Send Feedback

The methods of the TLabel class are listed here.

Class

TLabel Class

Protected Methods
Name | Description
CmMouseEnter | TLabel
CmMouseLeave | This is CmMouseLeave, a member of class TLabel.
Links
TLabel Class, Legend, Protected Methods


TLabel.CmMouseEnter Method

TLabel.CmMouseEnter Method
TLabel Class TLabel Members nxpvAboutFrm Namespace TLabel Methods Send Feedback
Syntax
Delphi
procedure CmMouseEnter(var Msg: TMessage); message CM_MOUSEENTER;
Description

TLabel

Group

TLabel Methods

Links
TLabel Class, TLabel Members, nxpvAboutFrm Namespace, TLabel Methods


TLabel.CmMouseLeave Method

TLabel.CmMouseLeave Method
TLabel Class TLabel Members nxpvAboutFrm Namespace TLabel Methods Send Feedback
Syntax
Delphi
procedure CmMouseLeave(var Msg: TMessage); message CM_MOUSELEAVE;
Description

This is CmMouseLeave, a member of class TLabel.

Group

TLabel Methods

Links
TLabel Class, TLabel Members, nxpvAboutFrm Namespace, TLabel Methods


TnxAboutFrm Class

TnxAboutFrm Class
TnxAboutFrm Fields TnxAboutFrm Methods TnxAboutFrm Members nxpvAboutFrm Classes Send Feedback
Class Hierarchy
nxpvAboutFrm_TnxAboutFrm
Syntax
Delphi
TnxAboutFrm = class(TForm);
File

nxpvAboutFrm

Description

This is class nxpvAboutFrm.TnxAboutFrm.

Group

Classes

Links
TnxAboutFrm Fields, TnxAboutFrm Methods, TnxAboutFrm Members, nxpvAboutFrm, Classes


TnxAboutFrm Members

TnxAboutFrm Members
TnxAboutFrm Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxAboutFrm.

Class

TnxAboutFrm Class

Public Fields
Name | Description
DLLs | Public declarations
Image1 | This is Image1, a member of class TnxAboutFrm.
IsServer | This is IsServer, a member of class TnxAboutFrm.
Label3 | This is Label3, a member of class TnxAboutFrm.
Label4 | This is Label4, a member of class TnxAboutFrm.
laCopyright | This is laCopyright, a member of class TnxAboutFrm.
lbClose | This is lbClose, a member of class TnxAboutFrm.
lblNewsGeneral | This is lblNewsGeneral, a member of class TnxAboutFrm.
lblNexusLink | This is lblNexusLink, a member of class TnxAboutFrm.
Panel1 | This is Panel1, a member of class TnxAboutFrm.
Panel2 | This is Panel2, a member of class TnxAboutFrm.
ProgramName | This is ProgramName, a member of class TnxAboutFrm.
VersionNumber | This is VersionNumber, a member of class TnxAboutFrm.
Public Methods
Name | Description
FormActivate | This is FormActivate, a member of class TnxAboutFrm.
FormKeyPress | This is FormKeyPress, a member of class TnxAboutFrm.
FormMouseMove | This is FormMouseMove, a member of class TnxAboutFrm.
FormShow | This is FormShow, a member of class TnxAboutFrm.
lbCloseClick | This is lbCloseClick, a member of class TnxAboutFrm.
lblNewsGeneralClick | This is lblNewsGeneralClick, a member of class TnxAboutFrm.
lblNexusLinkClick | This is lblNexusLinkClick, a member of class TnxAboutFrm.
Panel2Click | This is Panel2Click, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Fields, Public Methods


TnxAboutFrm Fields

TnxAboutFrm Fields
TnxAboutFrm Class Legend Public Fields Send Feedback

The fields of the TnxAboutFrm class are listed here.

Class

TnxAboutFrm Class

Public Fields
Name | Description
DLLs | Public declarations
Image1 | This is Image1, a member of class TnxAboutFrm.
IsServer | This is IsServer, a member of class TnxAboutFrm.
Label3 | This is Label3, a member of class TnxAboutFrm.
Label4 | This is Label4, a member of class TnxAboutFrm.
laCopyright | This is laCopyright, a member of class TnxAboutFrm.
lbClose | This is lbClose, a member of class TnxAboutFrm.
lblNewsGeneral | This is lblNewsGeneral, a member of class TnxAboutFrm.
lblNexusLink | This is lblNexusLink, a member of class TnxAboutFrm.
Panel1 | This is Panel1, a member of class TnxAboutFrm.
Panel2 | This is Panel2, a member of class TnxAboutFrm.
ProgramName | This is ProgramName, a member of class TnxAboutFrm.
VersionNumber | This is VersionNumber, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Fields


TnxAboutFrm.DLLs Field

TnxAboutFrm.DLLs Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
DLLs: array of string;
Description

Public declarations

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Image1 Field

TnxAboutFrm.Image1 Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Image1: TImage;
Description

This is Image1, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.IsServer Field

TnxAboutFrm.IsServer Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
IsServer: boolean;
Description

This is IsServer, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Label3 Field

TnxAboutFrm.Label3 Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Label3: TLabel;
Description

This is Label3, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Label4 Field

TnxAboutFrm.Label4 Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Label4: TLabel;
Description

This is Label4, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.laCopyright Field

TnxAboutFrm.laCopyright Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
laCopyright: TLabel;
Description

This is laCopyright, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lbClose Field

TnxAboutFrm.lbClose Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lbClose: TLabel;
Description

This is lbClose, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lblNewsGeneral Field

TnxAboutFrm.lblNewsGeneral Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lblNewsGeneral: TLabel;
Description

This is lblNewsGeneral, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.lblNexusLink Field

TnxAboutFrm.lblNexusLink Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
lblNexusLink: TLabel;
Description

This is lblNexusLink, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Panel1 Field

TnxAboutFrm.Panel1 Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.Panel2 Field

TnxAboutFrm.Panel2 Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
Panel2: TPanel;
Description

This is Panel2, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.ProgramName Field

TnxAboutFrm.ProgramName Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
ProgramName: TLabel;
Description

This is ProgramName, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm.VersionNumber Field

TnxAboutFrm.VersionNumber Field
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Fields Send Feedback
Syntax
Delphi
VersionNumber: TLabel;
Description

This is VersionNumber, a member of class TnxAboutFrm.

Group

TnxAboutFrm Fields

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Fields


TnxAboutFrm Methods

TnxAboutFrm Methods
TnxAboutFrm Class Legend Public Methods Send Feedback

The methods of the TnxAboutFrm class are listed here.

Class

TnxAboutFrm Class

Public Methods
Name | Description
FormActivate | This is FormActivate, a member of class TnxAboutFrm.
FormKeyPress | This is FormKeyPress, a member of class TnxAboutFrm.
FormMouseMove | This is FormMouseMove, a member of class TnxAboutFrm.
FormShow | This is FormShow, a member of class TnxAboutFrm.
lbCloseClick | This is lbCloseClick, a member of class TnxAboutFrm.
lblNewsGeneralClick | This is lblNewsGeneralClick, a member of class TnxAboutFrm.
lblNexusLinkClick | This is lblNexusLinkClick, a member of class TnxAboutFrm.
Panel2Click | This is Panel2Click, a member of class TnxAboutFrm.
Links
TnxAboutFrm Class, Legend, Public Methods


TnxAboutFrm.FormActivate Method

TnxAboutFrm.FormActivate Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormActivate(Sender: TObject);
Description

This is FormActivate, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.FormKeyPress Method

TnxAboutFrm.FormKeyPress Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormKeyPress(Sender: TObject; var Key: Char);
Description

This is FormKeyPress, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.FormMouseMove Method

TnxAboutFrm.FormMouseMove Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormMouseMove(Sender: TObject; Shift: TShiftState; X: Integer; Y: Integer);
Description

This is FormMouseMove, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.FormShow Method

TnxAboutFrm.FormShow Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Description

This is FormShow, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lbCloseClick Method

TnxAboutFrm.lbCloseClick Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lbCloseClick(Sender: TObject);
Description

This is lbCloseClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNewsGeneralClick Method

TnxAboutFrm.lblNewsGeneralClick Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNewsGeneralClick(Sender: TObject);
Description

This is lblNewsGeneralClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.lblNexusLinkClick Method

TnxAboutFrm.lblNexusLinkClick Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure lblNexusLinkClick(Sender: TObject);
Description

This is lblNexusLinkClick, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


TnxAboutFrm.Panel2Click Method

TnxAboutFrm.Panel2Click Method
TnxAboutFrm Class TnxAboutFrm Members nxpvAboutFrm Namespace TnxAboutFrm Methods Send Feedback
Syntax
Delphi
procedure Panel2Click(Sender: TObject);
Description

This is Panel2Click, a member of class TnxAboutFrm.

Group

TnxAboutFrm Methods

Links
TnxAboutFrm Class, TnxAboutFrm Members, nxpvAboutFrm Namespace, TnxAboutFrm Methods


Functions

Functions
Functions nxpvAboutFrm Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ShellToNews |
ShellToWWW | ShellTo functions
Namespace

nxpvAboutFrm Namespace

Links
Functions, nxpvAboutFrm Namespace, Legend


nxpvAboutFrm.ShellToNews Function

nxpvAboutFrm.ShellToNews Function
nxpvAboutFrm Functions Send Feedback
Syntax
Delphi
procedure ShellToNews;
File

nxpvAboutFrm

Group

Functions

Links
nxpvAboutFrm, Functions


nxpvAboutFrm.ShellToWWW Function

nxpvAboutFrm.ShellToWWW Function
nxpvAboutFrm Functions Send Feedback
Syntax
Delphi
procedure ShellToWWW;
File

nxpvAboutFrm

Description

ShellTo functions

Group

Functions

Links
nxpvAboutFrm, Functions


Constants

Constants
Constants nxpvAboutFrm Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cnxBrowserError | This is constant nxpvAboutFrm.cnxBrowserError.
cnxNewsClientError | This is constant nxpvAboutFrm.cnxNewsClientError.
Domains | This is constant nxpvAboutFrm.Domains.
Namespace

nxpvAboutFrm Namespace

Links
Constants, nxpvAboutFrm Namespace


nxpvAboutFrm.cnxBrowserError Constant

nxpvAboutFrm.cnxBrowserError Constant
nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
cnxBrowserError = 'Unable to start Web browser. Make sure you have it properly setup on your system.';
File

nxpvAboutFrm

Description

This is constant nxpvAboutFrm.cnxBrowserError.

Group

Constants

Links
nxpvAboutFrm, Constants


nxpvAboutFrm.cnxNewsClientError Constant

nxpvAboutFrm.cnxNewsClientError Constant
nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
cnxNewsClientError = 'Unable to start News client. Make sure you have it properly setup on your system.';
File

nxpvAboutFrm

Description

This is constant nxpvAboutFrm.cnxNewsClientError.

Group

Constants

Links
nxpvAboutFrm, Constants


nxpvAboutFrm.Domains Constant

nxpvAboutFrm.Domains Constant
nxpvAboutFrm Constants Send Feedback
Syntax
Delphi
Domains: array [boolean] of string[6] = ('Client', 'Server');
File

nxpvAboutFrm

Description

This is constant nxpvAboutFrm.Domains.

Group

Constants

Links
nxpvAboutFrm, Constants


nxpvJournalFrm Namespace

nxpvJournalFrm Namespace
Classes Legend Topics Send Feedback

This is namespace nxpvJournalFrm.

Classes
Name | Description
TfrmJournal | This is class nxpvJournalFrm.TfrmJournal.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxpvJournalFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmJournal | This is class nxpvJournalFrm.TfrmJournal.
Namespace

nxpvJournalFrm Namespace

Links
Classes, nxpvJournalFrm Namespace, Legend


TfrmJournal Class

TfrmJournal Class
TfrmJournal Fields TfrmJournal Methods TfrmJournal Members nxpvJournalFrm Classes Send Feedback
Class Hierarchy
nxpvJournalFrm_TfrmJournal
Syntax
Delphi
TfrmJournal = class(TForm);
File

nxpvJournalFrm

Description

This is class nxpvJournalFrm.TfrmJournal.

Group

Classes

Links
TfrmJournal Fields, TfrmJournal Methods, TfrmJournal Members, nxpvJournalFrm, Classes


TfrmJournal.ActionLabel Field

TfrmJournal.ActionLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
ActionLabel: TLabel;
Description

This is ActionLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.AliasLabel Field

TfrmJournal.AliasLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
AliasLabel: TLabel;
Description

This is AliasLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Bevel1 Field

TfrmJournal.Bevel1 Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Bevel1: TBevel;
Description

This is Bevel1, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.CompletenessLabel Field

TfrmJournal.CompletenessLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
CompletenessLabel: TLabel;
Description

This is CompletenessLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.ExceptionLabel Field

TfrmJournal.ExceptionLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
ExceptionLabel: TLabel;
Description

This is ExceptionLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.FilenameLabel Field

TfrmJournal.FilenameLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
FilenameLabel: TLabel;
Description

This is FilenameLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.OKBtn Field

TfrmJournal.OKBtn Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
OKBtn: TButton;
Description

This is OKBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Panel1 Field

TfrmJournal.Panel1 Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.Panel2 Field

TfrmJournal.Panel2 Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
Panel2: TPanel;
Description

This is Panel2, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.PathLabel Field

TfrmJournal.PathLabel Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
PathLabel: TLabel;
Description

This is PathLabel, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.PrintBtn Field

TfrmJournal.PrintBtn Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
PrintBtn: TButton;
Description

This is PrintBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.RollbackBtn Field

TfrmJournal.RollbackBtn Field
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Fields Send Feedback
Syntax
Delphi
RollbackBtn: TButton;
Description

This is RollbackBtn, a member of class TfrmJournal.

Group

TfrmJournal Fields

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Fields


TfrmJournal.PrintBtnClick Method

TfrmJournal.PrintBtnClick Method
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Methods Send Feedback
Syntax
Delphi
procedure PrintBtnClick(Sender: TObject);
Description

This is PrintBtnClick, a member of class TfrmJournal.

Group

TfrmJournal Methods

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Methods


TfrmJournal.Setup Method

TfrmJournal.Setup Method
TfrmJournal Class TfrmJournal Members nxpvJournalFrm Namespace TfrmJournal Methods Send Feedback
Syntax
Delphi
procedure Setup(aJournalState: TnxJournalState; aAlias: string; aPath: string; aFilename: string; aExceptionString: string);
Description

Public declarations

Group

TfrmJournal Methods

Links
TfrmJournal Class, TfrmJournal Members, nxpvJournalFrm Namespace, TfrmJournal Methods


nxpvLoginFrm Namespace

nxpvLoginFrm Namespace
Classes Legend Topics Send Feedback

This is namespace nxpvLoginFrm.

Classes
Name | Description
TfrmLogin | This is class nxpvLoginFrm.TfrmLogin.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxpvLoginFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmLogin | This is class nxpvLoginFrm.TfrmLogin.
Namespace

nxpvLoginFrm Namespace

Links
Classes, nxpvLoginFrm Namespace, Legend


TfrmLogin Class

TfrmLogin Class
TfrmLogin Fields TfrmLogin Methods TfrmLogin Properties TfrmLogin Members nxpvLoginFrm Classes Send Feedback
Class Hierarchy
nxpvLoginFrm_TfrmLogin
Syntax
Delphi
TfrmLogin = class(TForm);
File

nxpvLoginFrm

Description

This is class nxpvLoginFrm.TfrmLogin.

Group

Classes

Links
TfrmLogin Fields, TfrmLogin Methods, TfrmLogin Properties, TfrmLogin Members, nxpvLoginFrm, Classes


TfrmLogin.btnCancel Field

TfrmLogin.btnCancel Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
btnCancel: TButton;
Description

This is btnCancel, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.btnOK Field

TfrmLogin.btnOK Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
btnOK: TButton;
Description

This is btnOK, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.edPassword Field

TfrmLogin.edPassword Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
edPassword: TEdit;
Description

This is edPassword, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.edUserName Field

TfrmLogin.edUserName Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
edUserName: TEdit;
Description

This is edUserName, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.laDescription Field

TfrmLogin.laDescription Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
laDescription: TLabel;
Description

This is laDescription, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.lbPassword Field

TfrmLogin.lbPassword Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
lbPassword: TLabel;
Description

This is lbPassword, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.lbUsername Field

TfrmLogin.lbUsername Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
lbUsername: TLabel;
Description

This is lbUsername, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.Panel1 Field

TfrmLogin.Panel1 Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.paTop Field

TfrmLogin.paTop Field
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Fields Send Feedback
Syntax
Delphi
paTop: TPanel;
Description

This is paTop, a member of class TfrmLogin.

Group

TfrmLogin Fields

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Fields


TfrmLogin.btnOKClick Method

TfrmLogin.btnOKClick Method
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Methods Send Feedback
Syntax
Delphi
procedure btnOKClick(Sender: TObject);
Description

TnxLoginDialog

Group

TfrmLogin Methods

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Methods


TfrmLogin.FormShow Method

TfrmLogin.FormShow Method
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Group

TfrmLogin Methods

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Methods


TfrmLogin.Password Property

TfrmLogin.Password Property
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is Password, a member of class TfrmLogin.

Group

TfrmLogin Properties

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Properties


TfrmLogin.UserName Property

TfrmLogin.UserName Property
TfrmLogin Class TfrmLogin Members nxpvLoginFrm Namespace TfrmLogin Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This is UserName, a member of class TfrmLogin.

Group

TfrmLogin Properties

Links
TfrmLogin Class, TfrmLogin Members, nxpvLoginFrm Namespace, TfrmLogin Properties


nxpvPickServerFrm Namespace

nxpvPickServerFrm Namespace
Classes Legend Topics Send Feedback

This is namespace nxpvPickServerFrm.

Classes
Name | Description
TfrmPickServer | This is class nxpvPickServerFrm.TfrmPickServer.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxpvPickServerFrm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmPickServer | This is class nxpvPickServerFrm.TfrmPickServer.
Namespace

nxpvPickServerFrm Namespace

Links
Classes, nxpvPickServerFrm Namespace, Legend


TfrmPickServer Class

TfrmPickServer Class
TfrmPickServer Fields TfrmPickServer Members nxpvPickServerFrm Classes Send Feedback
Class Hierarchy
nxpvPickServerFrm_TfrmPickServer
Syntax
Delphi
TfrmPickServer = class(TForm);
File

nxpvPickServerFrm

Description

This is class nxpvPickServerFrm.TfrmPickServer.

Group

Classes

Links
TfrmPickServer Fields, TfrmPickServer Members, nxpvPickServerFrm, Classes


TfrmPickServer.Bevel1 Field

TfrmPickServer.Bevel1 Field
TfrmPickServer Class TfrmPickServer Members nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Bevel1: TBevel;
Description

This is Bevel1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.Button1 Field

TfrmPickServer.Button1 Field
TfrmPickServer Class TfrmPickServer Members nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Button1: TButton;
Description

This is Button1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.CBNames Field

TfrmPickServer.CBNames Field
TfrmPickServer Class TfrmPickServer Members nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
CBNames: TComboBox;
Description

This is CBNames, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.Label1 Field

TfrmPickServer.Label1 Field
TfrmPickServer Class TfrmPickServer Members nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
Label1: TLabel;
Description

This is Label1, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, nxpvPickServerFrm Namespace, TfrmPickServer Fields


TfrmPickServer.OKBtn Field

TfrmPickServer.OKBtn Field
TfrmPickServer Class TfrmPickServer Members nxpvPickServerFrm Namespace TfrmPickServer Fields Send Feedback
Syntax
Delphi
OKBtn: TButton;
Description

This is OKBtn, a member of class TfrmPickServer.

Group

TfrmPickServer Fields

Links
TfrmPickServer Class, TfrmPickServer Members, nxpvPickServerFrm Namespace, TfrmPickServer Fields


nxpvPlatformImplementation Namespace

nxpvPlatformImplementation Namespace
Classes Functions Legend Topics Variables Send Feedback

This is namespace nxpvPlatformImplementation.

Classes
Name | Description
TnxTimer | TnxTimer
Functions
Name | Description
AddRef | This is function nxpvPlatformImplementation.AddRef.
Release | This is function nxpvPlatformImplementation.Release.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_RefCount | This is variable nxpvPlatformImplementation._RefCount.
Links
Classes, Functions, Legend, Topics, Variables


Classes

Classes
Classes nxpvPlatformImplementation Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxTimer | TnxTimer
Namespace

nxpvPlatformImplementation Namespace

Links
Classes, nxpvPlatformImplementation Namespace, Legend


TnxTimer Class

TnxTimer Class
TnxTimer Fields TnxTimer Methods TnxTimer Members nxpvPlatformImplementation Classes Send Feedback
Class Hierarchy
nxpvPlatformImplementation_TnxTimer
Syntax
Delphi
TnxTimer = class(TInterfacedObject, InxTimer);
File

nxpvPlatformImplementation

Description

TnxTimer

Group

Classes

Links
TnxTimer Fields, TnxTimer Methods, TnxTimer Members, nxpvPlatformImplementation, Classes


TnxTimer.Create Constructor

TnxTimer.Create Constructor
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxTimer Class

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Class


TnxTimer.Destroy Destructor

TnxTimer.Destroy Destructor
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTimer Class

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Class


TnxTimer.ftTimer Field

TnxTimer.ftTimer Field
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Fields Send Feedback
Syntax
Delphi
ftTimer: TTimer;
Description

private

Group

TnxTimer Fields

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Fields


TnxTimer.ftGetEnabled Method

TnxTimer.ftGetEnabled Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetEnabled: Boolean;
Description

InxTimer

Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftGetInterval Method

TnxTimer.ftGetInterval Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetInterval: Cardinal;
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftGetOnTimer Method

TnxTimer.ftGetOnTimer Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
function ftGetOnTimer: TNotifyEvent;
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetEnabled Method

TnxTimer.ftSetEnabled Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetEnabled(aEnabled: Boolean);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetInterval Method

TnxTimer.ftSetInterval Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetInterval(aInterval: Cardinal);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


TnxTimer.ftSetOnTimer Method

TnxTimer.ftSetOnTimer Method
TnxTimer Class TnxTimer Members nxpvPlatformImplementation Namespace TnxTimer Methods Send Feedback
Syntax
Delphi
procedure ftSetOnTimer(aOnTimer: TNotifyEvent);
Group

TnxTimer Methods

Links
TnxTimer Class, TnxTimer Members, nxpvPlatformImplementation Namespace, TnxTimer Methods


Functions

Functions
Functions nxpvPlatformImplementation Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxpvPlatformImplementation.AddRef.
Release | This is function nxpvPlatformImplementation.Release.
Namespace

nxpvPlatformImplementation Namespace

Links
Functions, nxpvPlatformImplementation Namespace, Legend


nxpvPlatformImplementation.AddRef Function

nxpvPlatformImplementation.AddRef Function
nxpvPlatformImplementation Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxpvPlatformImplementation

Description

This is function nxpvPlatformImplementation.AddRef.

Group

Functions

Links
nxpvPlatformImplementation, Functions


nxpvPlatformImplementation.Release Function

nxpvPlatformImplementation.Release Function
nxpvPlatformImplementation Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxpvPlatformImplementation

Description

This is function nxpvPlatformImplementation.Release.

Group

Functions

Links
nxpvPlatformImplementation, Functions


Variables

Variables
nxpvPlatformImplementation Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxpvPlatformImplementation Namespace

Variables
Name | Description
_RefCount | This is variable nxpvPlatformImplementation._RefCount.
Links
nxpvPlatformImplementation Namespace, Variables


nxpvPlatformImplementation._RefCount Variable

nxpvPlatformImplementation._RefCount Variable
nxpvPlatformImplementation Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxpvPlatformImplementation

Description

This is variable nxpvPlatformImplementation._RefCount.

Group

Variables

Links
nxpvPlatformImplementation, Variables


nxpvServiceInstallForm Namespace

nxpvServiceInstallForm Namespace
Classes Legend Topics Send Feedback

This is namespace nxpvServiceInstallForm.

Classes
Name | Description
TfrmServiceInstall | This is class nxpvServiceInstallForm.TfrmServiceInstall.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxpvServiceInstallForm Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TfrmServiceInstall | This is class nxpvServiceInstallForm.TfrmServiceInstall.
Namespace

nxpvServiceInstallForm Namespace

Links
Classes, nxpvServiceInstallForm Namespace, Legend


TfrmServiceInstall Class

TfrmServiceInstall Class
TfrmServiceInstall Fields TfrmServiceInstall Methods TfrmServiceInstall Properties TfrmServiceInstall Members nxpvServiceInstallForm Classes Send Feedback
Class Hierarchy
nxpvServiceInstallForm_TfrmServiceInstall
Syntax
Delphi
TfrmServiceInstall = class(TForm);
File

nxpvServiceInstallForm

Description

This is class nxpvServiceInstallForm.TfrmServiceInstall.

Group

Classes

Links
TfrmServiceInstall Fields, TfrmServiceInstall Methods, TfrmServiceInstall Properties, TfrmServiceInstall Members, nxpvServiceInstallForm, Classes


TfrmServiceInstall.btnCancel Field

TfrmServiceInstall.btnCancel Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
btnCancel: TButton;
Description

This is btnCancel, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.btnOK Field

TfrmServiceInstall.btnOK Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
btnOK: TButton;
Description

This is btnOK, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Button1 Field

TfrmServiceInstall.Button1 Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Button1: TButton;
Description

This is Button1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.cxLocalHost Field

TfrmServiceInstall.cxLocalHost Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
cxLocalHost: TCheckBox;
Description

This is cxLocalHost, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.edPassword Field

TfrmServiceInstall.edPassword Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
edPassword: TEdit;
Description

This is edPassword, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.edUserName Field

TfrmServiceInstall.edUserName Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
edUserName: TEdit;
Description

This is edUserName, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Label1 Field

TfrmServiceInstall.Label1 Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Label1: TLabel;
Description

This is Label1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.laDescription Field

TfrmServiceInstall.laDescription Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
laDescription: TLabel;
Description

This is laDescription, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.lbPassword Field

TfrmServiceInstall.lbPassword Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
lbPassword: TLabel;
Description

This is lbPassword, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.lbUsername Field

TfrmServiceInstall.lbUsername Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
lbUsername: TLabel;
Description

This is lbUsername, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.Panel1 Field

TfrmServiceInstall.Panel1 Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
Panel1: TPanel;
Description

This is Panel1, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.paTop Field

TfrmServiceInstall.paTop Field
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Fields Send Feedback
Syntax
Delphi
paTop: TPanel;
Description

This is paTop, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Fields

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Fields


TfrmServiceInstall.btnOKClick Method

TfrmServiceInstall.btnOKClick Method
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure btnOKClick(Sender: TObject);
Description

TnxLoginDialog

Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.Button1Click Method

TfrmServiceInstall.Button1Click Method
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure Button1Click(Sender: TObject);
Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.FormCreate Method

TfrmServiceInstall.FormCreate Method
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure FormCreate(Sender: TObject);
Description

This is FormCreate, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.FormShow Method

TfrmServiceInstall.FormShow Method
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Methods Send Feedback
Syntax
Delphi
procedure FormShow(Sender: TObject);
Group

TfrmServiceInstall Methods

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Methods


TfrmServiceInstall.Password Property

TfrmServiceInstall.Password Property
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is Password, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Properties

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Properties


TfrmServiceInstall.UserName Property

TfrmServiceInstall.UserName Property
TfrmServiceInstall Class TfrmServiceInstall Members nxpvServiceInstallForm Namespace TfrmServiceInstall Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This is UserName, a member of class TfrmServiceInstall.

Group

TfrmServiceInstall Properties

Links
TfrmServiceInstall Class, TfrmServiceInstall Members, nxpvServiceInstallForm Namespace, TfrmServiceInstall Properties


nxpvWindowHandle Namespace

nxpvWindowHandle Namespace
Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxpvWindowHandle.

Constants
Name | Description
CodeBytes | This is constant nxpvWindowHandle.CodeBytes.
InstanceCount | This is constant nxpvWindowHandle.InstanceCount.
Functions
Name | Description
nxAllocateHWnd | This is function nxpvWindowHandle.nxAllocateHWnd.
nxDeallocateHWnd | This is function nxpvWindowHandle.nxDeallocateHWnd.
nxDefWindowProc | This is function nxpvWindowHandle.nxDefWindowProc.
Structs, Records, Enums
Name | Description
TnxInstanceBlock | This is record nxpvWindowHandle.TnxInstanceBlock.
TnxObjectInstance | This is record nxpvWindowHandle.TnxObjectInstance.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxInstanceBlock | This is type nxpvWindowHandle.PnxInstanceBlock.
PnxObjectInstance | This is type nxpvWindowHandle.PnxObjectInstance.
Variables
Name | Description
_InstBlockList | This is variable nxpvWindowHandle._InstBlockList.
_InstFreeList | This is variable nxpvWindowHandle._InstFreeList.
_InstPadlock | This is variable nxpvWindowHandle._InstPadlock.
Msg | In R11 = Address of method pointer Out RAX = Result
nxUtilWindowClass | This is variable nxpvWindowHandle.nxUtilWindowClass.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Functions

Functions
Functions nxpvWindowHandle Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxAllocateHWnd | This is function nxpvWindowHandle.nxAllocateHWnd.
nxDeallocateHWnd | This is function nxpvWindowHandle.nxDeallocateHWnd.
nxDefWindowProc | This is function nxpvWindowHandle.nxDefWindowProc.
Namespace

nxpvWindowHandle Namespace

Links
Functions, nxpvWindowHandle Namespace, Legend


nxpvWindowHandle.nxAllocateHWnd Function

nxpvWindowHandle.nxAllocateHWnd Function
nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
function nxAllocateHWnd(aMethod: TWndMethod): HWND;
File

nxpvWindowHandle

Description

This is function nxpvWindowHandle.nxAllocateHWnd.

Group

Functions

Links
nxpvWindowHandle, Functions


nxpvWindowHandle.nxDeallocateHWnd Function

nxpvWindowHandle.nxDeallocateHWnd Function
nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
procedure nxDeallocateHWnd(aWnd: HWND);
File

nxpvWindowHandle

Description

This is function nxpvWindowHandle.nxDeallocateHWnd.

Group

Functions

Links
nxpvWindowHandle, Functions


nxpvWindowHandle.nxDefWindowProc Function

nxpvWindowHandle.nxDefWindowProc Function
nxpvWindowHandle Functions Send Feedback
Syntax
Delphi
function nxDefWindowProc(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): LRESULT; stdcall;
File

nxpvWindowHandle

Description

This is function nxpvWindowHandle.nxDefWindowProc.

Group

Functions

Links
nxpvWindowHandle, Functions


Structs, Records, Enums

Structs, Records, Enums
nxpvWindowHandle Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxpvWindowHandle Namespace

Records
Name | Description
TnxInstanceBlock | This is record nxpvWindowHandle.TnxInstanceBlock.
TnxObjectInstance | This is record nxpvWindowHandle.TnxObjectInstance.
Links
nxpvWindowHandle Namespace, Legend, Records


nxpvWindowHandle.TnxInstanceBlock Record

nxpvWindowHandle.TnxInstanceBlock Record
nxpvWindowHandle Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInstanceBlock = packed record
  ibNext: PnxInstanceBlock;
  ibCode: array[1..CodeBytes] of Byte;
  ibWndProcPtr: Pointer;
  ibInstances: array[0..InstanceCount] of TnxObjectInstance;
end;
File

nxpvWindowHandle

Description

This is record nxpvWindowHandle.TnxInstanceBlock.

Group

Structs, Records, Enums

Links
nxpvWindowHandle, Structs, Records, Enums


nxpvWindowHandle.TnxObjectInstance Record

nxpvWindowHandle.TnxObjectInstance Record
nxpvWindowHandle Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxObjectInstance = packed record
  oiThreadID: Cardinal;
  oiCode: Byte;
  oiOffset: Integer;
  case Integer of
    0: (oiNext: PnxObjectInstance;);
    1: (oiMethod: TWndMethod;);
end;
File

nxpvWindowHandle

Description

This is record nxpvWindowHandle.TnxObjectInstance.

Group

Structs, Records, Enums

Links
nxpvWindowHandle, Structs, Records, Enums


Types

Types
nxpvWindowHandle Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxpvWindowHandle Namespace

Types
Name | Description
PnxInstanceBlock | This is type nxpvWindowHandle.PnxInstanceBlock.
PnxObjectInstance | This is type nxpvWindowHandle.PnxObjectInstance.
Links
nxpvWindowHandle Namespace, Types


nxpvWindowHandle.PnxInstanceBlock Type

nxpvWindowHandle.PnxInstanceBlock Type
nxpvWindowHandle Types Send Feedback
Syntax
Delphi
PnxInstanceBlock = ^TnxInstanceBlock;
File

nxpvWindowHandle

Description

This is type nxpvWindowHandle.PnxInstanceBlock.

Group

Types

Links
nxpvWindowHandle, Types


nxpvWindowHandle.PnxObjectInstance Type

nxpvWindowHandle.PnxObjectInstance Type
nxpvWindowHandle Types Send Feedback
Syntax
Delphi
PnxObjectInstance = ^TnxObjectInstance;
File

nxpvWindowHandle

Description

This is type nxpvWindowHandle.PnxObjectInstance.

Group

Types

Links
nxpvWindowHandle, Types


Variables

Variables
nxpvWindowHandle Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxpvWindowHandle Namespace

Variables
Name | Description
_InstBlockList | This is variable nxpvWindowHandle._InstBlockList.
_InstFreeList | This is variable nxpvWindowHandle._InstFreeList.
_InstPadlock | This is variable nxpvWindowHandle._InstPadlock.
Msg | In R11 = Address of method pointer Out RAX = Result
nxUtilWindowClass | This is variable nxpvWindowHandle.nxUtilWindowClass.
Links
nxpvWindowHandle Namespace, Variables


nxpvWindowHandle._InstBlockList Variable

nxpvWindowHandle._InstBlockList Variable
nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstBlockList: PnxInstanceBlock;
File

nxpvWindowHandle

Description

This is variable nxpvWindowHandle._InstBlockList.

Group

Variables

Links
nxpvWindowHandle, Variables


nxpvWindowHandle._InstFreeList Variable

nxpvWindowHandle._InstFreeList Variable
nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstFreeList: PnxObjectInstance;
File

nxpvWindowHandle

Description

This is variable nxpvWindowHandle._InstFreeList.

Group

Variables

Links
nxpvWindowHandle, Variables


nxpvWindowHandle._InstPadlock Variable

nxpvWindowHandle._InstPadlock Variable
nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
_InstPadlock: TnxPadlock;
File

nxpvWindowHandle

Description

This is variable nxpvWindowHandle._InstPadlock.

Group

Variables

Links
nxpvWindowHandle, Variables


nxpvWindowHandle.Msg Variable

nxpvWindowHandle.Msg Variable
nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
Msg: TMessage;
File

nxpvWindowHandle

Description

In R11 = Address of method pointer Out RAX = Result

Group

Variables

Links
nxpvWindowHandle, Variables


nxpvWindowHandle.nxUtilWindowClass Variable

nxpvWindowHandle.nxUtilWindowClass Variable
nxpvWindowHandle Variables Send Feedback
Syntax
Delphi
nxUtilWindowClass: TWndClass = ( style: 0; lpfnWndProc: @nxDefWindowProc; cbClsExtra: 0; cbWndExtra: 0; hInstance: 0; hIcon: 0; hCursor: 0; hbrBackground: 0; lpszMenuName: nil; lpszClassName: 'nxUtilWindow');
File

nxpvWindowHandle

Description

This is variable nxpvWindowHandle.nxUtilWindowClass.

Group

Variables

Links
nxpvWindowHandle, Variables


Constants

Constants
Constants nxpvWindowHandle Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
CodeBytes | This is constant nxpvWindowHandle.CodeBytes.
InstanceCount | This is constant nxpvWindowHandle.InstanceCount.
Namespace

nxpvWindowHandle Namespace

Links
Constants, nxpvWindowHandle Namespace


nxpvWindowHandle.CodeBytes Constant

nxpvWindowHandle.CodeBytes Constant
nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
CodeBytes = 8;
File

nxpvWindowHandle

Description

This is constant nxpvWindowHandle.CodeBytes.

Group

Constants

Links
nxpvWindowHandle, Constants


nxpvWindowHandle.InstanceCount Constant

nxpvWindowHandle.InstanceCount Constant
nxpvWindowHandle Constants Send Feedback
Syntax
Delphi
InstanceCount = ((64 * 1024) - 64 ) div SizeOf(TnxObjectInstance);
File

nxpvWindowHandle

Description

This is constant nxpvWindowHandle.InstanceCount.

Group

Constants

Links
nxpvWindowHandle, Constants


nxrbCallContext Namespace

nxrbCallContext Namespace
Classes Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxrbCallContext.

Classes
Name | Description
TnxCallContext | This is class nxrbCallContext.TnxCallContext.
Functions
Name | Description
nxCallContextFromContext | This is function nxrbCallContext.nxCallContextFromContext.
nxCallContextFromReader | This is function nxrbCallContext.nxCallContextFromReader.
nxCurrentCallContext | This is function nxrbCallContext.nxCurrentCallContext.
nxThreadInContext | This is function nxrbCallContext.nxThreadInContext.
Structs, Records, Enums
Name | Description
TnxContextID | This is record nxrbCallContext.TnxContextID.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxContextID | This is type nxrbCallContext.PnxContextID.
Variables
Name | Description
_ReleasePadlock | This is variable nxrbCallContext._ReleasePadlock.
Links
Classes, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxrbCallContext Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxCallContext | This is class nxrbCallContext.TnxCallContext.
Namespace

nxrbCallContext Namespace

Links
Classes, nxrbCallContext Namespace, Legend


TnxCallContext Class

TnxCallContext Class
Create Constructor TnxCallContext Fields TnxCallContext Methods TnxCallContext Members nxrbCallContext Classes Send Feedback
Class Hierarchy
nxrbCallContext_TnxCallContextnxrbCallContext_TnxCallContextnxrbCallContext_TnxCallContext
Syntax
Delphi
TnxCallContext = class(TnxLowInterfacedObject, InxInterface, InxRoutingPath, InxCallContext);
File

nxrbCallContext

Description

This is class nxrbCallContext.TnxCallContext.

Group

Classes

Links
Create Constructor, TnxCallContext Fields, TnxCallContext Methods, TnxCallContext Members, nxrbCallContext, Classes


TnxCallContext Members

TnxCallContext Members
TnxCallContext Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCallContext.

Class

TnxCallContext Class

Protected Fields
Name | Description
ccInCall | This is ccInCall, a member of class TnxCallContext.
ccPath | This is ccPath, a member of class TnxCallContext.
ccPrevContext | This is ccPrevContext, a member of class TnxCallContext.
ccThreadID | This is ccThreadID, a member of class TnxCallContext.
ccThreadVar | This is ccThreadVar, a member of class TnxCallContext.
ccTickCount | private
Protected Methods
Name | Description
_Release | InxInterface
BeginCall | TnxCallContext
EndCall | This is EndCall, a member of class TnxCallContext.
GetContextID | TnxCallContext
GetInCall | This is GetInCall, a member of class TnxCallContext.
GetRoutingPath | InxRoutingPath
GetThreadID | This is GetThreadID, a member of class TnxCallContext.
IsSameCall | This is IsSameCall, a member of class TnxCallContext.
SaveToWriter | InxCallContext
Public Methods
Name | Description
Create | This is the overview for the Create constructor overload.
Destroy | This is Destroy, a member of class TnxCallContext.
Public Properties
Name | Description
InCall | This is InCall, a member of class InxCallContext.
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
ThreadID | This is ThreadID, a member of class InxCallContext.
Links
TnxCallContext Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxCallContext Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxCallContext.Create () | This is Create, a member of class TnxCallContext.
TnxCallContext.Create (TnxRoutingPath) | This is Create, a member of class TnxCallContext.
Class

TnxCallContext Class

Links
TnxCallContext Class


TnxCallContext.Create Constructor ()

TnxCallContext.Create Constructor ()
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create; overload;
Description

This is Create, a member of class TnxCallContext.

Group

Create Constructor

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, Create Constructor


TnxCallContext.Create Constructor (TnxRoutingPath)

TnxCallContext.Create Constructor (TnxRoutingPath)
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(const aPath: TnxRoutingPath); overload;
Description

This is Create, a member of class TnxCallContext.

Group

Create Constructor

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, Create Constructor


TnxCallContext.Destroy Destructor

TnxCallContext.Destroy Destructor
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxCallContext.

Class

TnxCallContext Class

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Class


TnxCallContext Fields

TnxCallContext Fields
TnxCallContext Class Legend Protected Fields Send Feedback

The fields of the TnxCallContext class are listed here.

Class

TnxCallContext Class

Protected Fields
Name | Description
ccInCall | This is ccInCall, a member of class TnxCallContext.
ccPath | This is ccPath, a member of class TnxCallContext.
ccPrevContext | This is ccPrevContext, a member of class TnxCallContext.
ccThreadID | This is ccThreadID, a member of class TnxCallContext.
ccThreadVar | This is ccThreadVar, a member of class TnxCallContext.
ccTickCount | private
Links
TnxCallContext Class, Legend, Protected Fields


TnxCallContext.ccInCall Field

TnxCallContext.ccInCall Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccInCall: Integer;
Description

This is ccInCall, a member of class TnxCallContext.

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext.ccPath Field

TnxCallContext.ccPath Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccPath: TnxRoutingPath;
Description

This is ccPath, a member of class TnxCallContext.

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext.ccPrevContext Field

TnxCallContext.ccPrevContext Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccPrevContext: InxCallContext;
Description

This is ccPrevContext, a member of class TnxCallContext.

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext.ccThreadID Field

TnxCallContext.ccThreadID Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccThreadID: Cardinal;
Description

This is ccThreadID, a member of class TnxCallContext.

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext.ccThreadVar Field

TnxCallContext.ccThreadVar Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccThreadVar: PPointer;
Description

This is ccThreadVar, a member of class TnxCallContext.

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext.ccTickCount Field

TnxCallContext.ccTickCount Field
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Fields Send Feedback
Syntax
Delphi
ccTickCount: Cardinal;
Description

private

Group

TnxCallContext Fields

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Fields


TnxCallContext Methods

TnxCallContext Methods
TnxCallContext Class Legend Protected Methods Send Feedback

The methods of the TnxCallContext class are listed here.

Class

TnxCallContext Class

Protected Methods
Name | Description
_Release | InxInterface
BeginCall | TnxCallContext
EndCall | This is EndCall, a member of class TnxCallContext.
GetContextID | TnxCallContext
GetInCall | This is GetInCall, a member of class TnxCallContext.
GetRoutingPath | InxRoutingPath
GetThreadID | This is GetThreadID, a member of class TnxCallContext.
IsSameCall | This is IsSameCall, a member of class TnxCallContext.
SaveToWriter | InxCallContext
Links
TnxCallContext Class, Legend, Protected Methods


TnxCallContext._Release Method

TnxCallContext._Release Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Description

InxInterface

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.BeginCall Method

TnxCallContext.BeginCall Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
procedure BeginCall;
Description

TnxCallContext

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.EndCall Method

TnxCallContext.EndCall Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
procedure EndCall;
Description

This is EndCall, a member of class TnxCallContext.

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.GetContextID Method

TnxCallContext.GetContextID Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function GetContextID: TnxGuid;
Description

TnxCallContext

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.GetInCall Method

TnxCallContext.GetInCall Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function GetInCall: Boolean;
Description

This is GetInCall, a member of class TnxCallContext.

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.GetRoutingPath Method

TnxCallContext.GetRoutingPath Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function GetRoutingPath: TnxRoutingPath;
Description

InxRoutingPath

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.GetThreadID Method

TnxCallContext.GetThreadID Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function GetThreadID: Cardinal;
Description

This is GetThreadID, a member of class TnxCallContext.

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.IsSameCall Method

TnxCallContext.IsSameCall Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function IsSameCall(const aContext: InxCallContext): HRESULT;
Description

This is IsSameCall, a member of class TnxCallContext.

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


TnxCallContext.SaveToWriter Method

TnxCallContext.SaveToWriter Method
TnxCallContext Class TnxCallContext Members nxrbCallContext Namespace TnxCallContext Methods Send Feedback
Syntax
Delphi
function SaveToWriter(aWriter: InxWriter): HRESULT;
Description

InxCallContext

Group

TnxCallContext Methods

Links
TnxCallContext Class, TnxCallContext Members, nxrbCallContext Namespace, TnxCallContext Methods


Functions

Functions
Functions nxrbCallContext Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCallContextFromContext | This is function nxrbCallContext.nxCallContextFromContext.
nxCallContextFromReader | This is function nxrbCallContext.nxCallContextFromReader.
nxCurrentCallContext | This is function nxrbCallContext.nxCurrentCallContext.
nxThreadInContext | This is function nxrbCallContext.nxThreadInContext.
Namespace

nxrbCallContext Namespace

Links
Functions, nxrbCallContext Namespace, Legend


nxrbCallContext.nxCallContextFromContext Function

nxrbCallContext.nxCallContextFromContext Function
nxrbCallContext Functions Send Feedback
Syntax
Delphi
function nxCallContextFromContext(const aOldContext: InxCallContext; out aNewContext: InxCallContext): HRESULT;
File

nxrbCallContext

Description

This is function nxrbCallContext.nxCallContextFromContext.

Group

Functions

Links
nxrbCallContext, Functions


nxrbCallContext.nxCallContextFromReader Function

nxrbCallContext.nxCallContextFromReader Function
nxrbCallContext Functions Send Feedback
Syntax
Delphi
function nxCallContextFromReader(const aReader: InxReader; out aContext: InxCallContext): HRESULT;
File

nxrbCallContext

Description

This is function nxrbCallContext.nxCallContextFromReader.

Group

Functions

Links
nxrbCallContext, Functions


nxrbCallContext.nxCurrentCallContext Function

nxrbCallContext.nxCurrentCallContext Function
nxrbCallContext Functions Send Feedback
Syntax
Delphi
function nxCurrentCallContext: InxCallContext;
File

nxrbCallContext

Description

This is function nxrbCallContext.nxCurrentCallContext.

Group

Functions

Links
nxrbCallContext, Functions


nxrbCallContext.nxThreadInContext Function

nxrbCallContext.nxThreadInContext Function
nxrbCallContext Functions Send Feedback
Syntax
Delphi
function nxThreadInContext(aThreadID: Cardinal; const aContext: InxCallContext): HRESULT;
File

nxrbCallContext

Description

This is function nxrbCallContext.nxThreadInContext.

Group

Functions

Links
nxrbCallContext, Functions


Structs, Records, Enums

Structs, Records, Enums
nxrbCallContext Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxrbCallContext Namespace

Records
Name | Description
TnxContextID | This is record nxrbCallContext.TnxContextID.
Links
nxrbCallContext Namespace, Legend, Records


nxrbCallContext.TnxContextID Record

nxrbCallContext.TnxContextID Record
nxrbCallContext Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxContextID = packed record
  ciCheckSum: Cardinal;
  ciContext: Cardinal;
  ciThreadID: Cardinal;
  ciTickCount: Cardinal;
end;
File

nxrbCallContext

Description

This is record nxrbCallContext.TnxContextID.

Group

Structs, Records, Enums

Links
nxrbCallContext, Structs, Records, Enums


Types

Types
nxrbCallContext Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrbCallContext Namespace

Types
Name | Description
PnxContextID | This is type nxrbCallContext.PnxContextID.
Links
nxrbCallContext Namespace, Types


nxrbCallContext.PnxContextID Type

nxrbCallContext.PnxContextID Type
nxrbCallContext Types Send Feedback
Syntax
Delphi
PnxContextID = ^TnxContextID;
File

nxrbCallContext

Description

This is type nxrbCallContext.PnxContextID.

Group

Types

Links
nxrbCallContext, Types


Variables

Variables
nxrbCallContext Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrbCallContext Namespace

Variables
Name | Description
_ReleasePadlock | This is variable nxrbCallContext._ReleasePadlock.
Links
nxrbCallContext Namespace, Variables


nxrbCallContext._ReleasePadlock Variable

nxrbCallContext._ReleasePadlock Variable
nxrbCallContext Variables Send Feedback
Syntax
Delphi
_ReleasePadlock: TnxPadlock;
File

nxrbCallContext

Description

This is variable nxrbCallContext._ReleasePadlock.

Group

Variables

Links
nxrbCallContext, Variables


nxrbClassActivatorIsolator Namespace

nxrbClassActivatorIsolator Namespace
Classes Legend Topics Send Feedback

This is namespace nxrbClassActivatorIsolator.

Classes
Name | Description
TnxClassActivatorIsolator | This is class nxrbClassActivatorIsolator.TnxClassActivatorIsolator.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrbClassActivatorIsolator Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassActivatorIsolator | This is class nxrbClassActivatorIsolator.TnxClassActivatorIsolator.
Namespace

nxrbClassActivatorIsolator Namespace

Links
Classes, nxrbClassActivatorIsolator Namespace, Legend


TnxClassActivatorIsolator Class

TnxClassActivatorIsolator Class
TnxClassActivatorIsolator Fields TnxClassActivatorIsolator Methods TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Classes Send Feedback
Class Hierarchy
nxrbClassActivatorIsolator_TnxClassActivatorIsolatornxrbClassActivatorIsolator_TnxClassActivatorIsolatornxrbClassActivatorIsolator_TnxClassActivatorIsolatornxrbClassActivatorIsolator_TnxClassActivatorIsolator
Syntax
Delphi
TnxClassActivatorIsolator = class(TnxInterfacedObject, InxInterface, InxClassActivator);
File

nxrbClassActivatorIsolator

Description

This is class nxrbClassActivatorIsolator.TnxClassActivatorIsolator.

Group

Classes

Links
TnxClassActivatorIsolator Fields, TnxClassActivatorIsolator Methods, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator, Classes


TnxClassActivatorIsolator Members

TnxClassActivatorIsolator Members
TnxClassActivatorIsolator Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassActivatorIsolator.

Class

TnxClassActivatorIsolator Class

Protected Fields
Name | Description
caiHost | private
caiHostReferences | This is caiHostReferences, a member of class TnxClassActivatorIsolator.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInstance |
InternalAddRef |
InternalQueryInterface | InxInterface methods ONLY for InxInterface
InternalRelease |
ioDeactivate |
QueryInterface | InxClassActivator
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassActivatorIsolator Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassActivatorIsolator.Create Constructor

TnxClassActivatorIsolator.Create Constructor
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Class Send Feedback
Syntax
Delphi
constructor Create(aHost: InxClassActivator);
Class

TnxClassActivatorIsolator Class

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Class


TnxClassActivatorIsolator Fields

TnxClassActivatorIsolator Fields
TnxClassActivatorIsolator Class Legend Protected Fields Send Feedback

The fields of the TnxClassActivatorIsolator class are listed here.

Class

TnxClassActivatorIsolator Class

Protected Fields
Name | Description
caiHost | private
caiHostReferences | This is caiHostReferences, a member of class TnxClassActivatorIsolator.
Links
TnxClassActivatorIsolator Class, Legend, Protected Fields


TnxClassActivatorIsolator.caiHost Field

TnxClassActivatorIsolator.caiHost Field
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Fields Send Feedback
Syntax
Delphi
caiHost: Pointer;
Description

private

Group

TnxClassActivatorIsolator Fields

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Fields


TnxClassActivatorIsolator.caiHostReferences Field

TnxClassActivatorIsolator.caiHostReferences Field
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Fields Send Feedback
Syntax
Delphi
caiHostReferences: Integer;
Description

This is caiHostReferences, a member of class TnxClassActivatorIsolator.

Group

TnxClassActivatorIsolator Fields

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Fields


TnxClassActivatorIsolator Methods

TnxClassActivatorIsolator Methods
TnxClassActivatorIsolator Class Legend Protected Methods Send Feedback

The methods of the TnxClassActivatorIsolator class are listed here.

Class

TnxClassActivatorIsolator Class

Protected Methods
Name | Description
CreateInstance |
InternalAddRef |
InternalQueryInterface | InxInterface methods ONLY for InxInterface
InternalRelease |
QueryInterface | InxClassActivator
Links
TnxClassActivatorIsolator Class, Legend, Protected Methods


TnxClassActivatorIsolator.CreateInstance Method

TnxClassActivatorIsolator.CreateInstance Method
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT;
Group

TnxClassActivatorIsolator Methods

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Methods


TnxClassActivatorIsolator.InternalAddRef Method

TnxClassActivatorIsolator.InternalAddRef Method
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Methods Send Feedback
Syntax
Delphi
function InternalAddRef: Integer; stdcall;
Group

TnxClassActivatorIsolator Methods

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Methods


TnxClassActivatorIsolator.InternalQueryInterface Method

TnxClassActivatorIsolator.InternalQueryInterface Method
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Methods Send Feedback
Syntax
Delphi
function InternalQueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface methods ONLY for InxInterface

Group

TnxClassActivatorIsolator Methods

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Methods


TnxClassActivatorIsolator.InternalRelease Method

TnxClassActivatorIsolator.InternalRelease Method
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Methods Send Feedback
Syntax
Delphi
function InternalRelease: Integer; stdcall;
Group

TnxClassActivatorIsolator Methods

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Methods


TnxClassActivatorIsolator.QueryInterface Method

TnxClassActivatorIsolator.QueryInterface Method
TnxClassActivatorIsolator Class TnxClassActivatorIsolator Members nxrbClassActivatorIsolator Namespace TnxClassActivatorIsolator Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxClassActivator

Group

TnxClassActivatorIsolator Methods

Links
TnxClassActivatorIsolator Class, TnxClassActivatorIsolator Members, nxrbClassActivatorIsolator Namespace, TnxClassActivatorIsolator Methods


nxrbClassFactoryRegistry Namespace

nxrbClassFactoryRegistry Namespace
Classes Legend Topics Send Feedback

This is namespace nxrbClassFactoryRegistry.

Classes
Name | Description
TnxClassFactoryControl | This is class nxrbClassFactoryRegistry.TnxClassFactoryControl.
TnxClassFactoryRegistry | This is class nxrbClassFactoryRegistry.TnxClassFactoryRegistry.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrbClassFactoryRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassFactoryControl | This is class nxrbClassFactoryRegistry.TnxClassFactoryControl.
TnxClassFactoryRegistry | This is class nxrbClassFactoryRegistry.TnxClassFactoryRegistry.
Namespace

nxrbClassFactoryRegistry Namespace

Links
Classes, nxrbClassFactoryRegistry Namespace, Legend


TnxClassFactoryControl Class

TnxClassFactoryControl Class
TnxClassFactoryControl Fields TnxClassFactoryControl Methods TnxClassFactoryControl Members nxrbClassFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassFactoryRegistry_TnxClassFactoryControlnxrbClassFactoryRegistry_TnxClassFactoryControlnxrbClassFactoryRegistry_TnxClassFactoryControlnxrbClassFactoryRegistry_TnxClassFactoryControlnxrbClassFactoryRegistry_TnxClassFactoryControl
Syntax
Delphi
TnxClassFactoryControl = class(TnxInterfacedObject, InxFactoryControl, InxClassFactoryControl);
File

nxrbClassFactoryRegistry

Description

This is class nxrbClassFactoryRegistry.TnxClassFactoryControl.

Group

Classes

Links
TnxClassFactoryControl Fields, TnxClassFactoryControl Methods, TnxClassFactoryControl Members, nxrbClassFactoryRegistry, Classes


TnxClassFactoryControl Members

TnxClassFactoryControl Members
TnxClassFactoryControl Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassFactoryControl.

Class

TnxClassFactoryControl Class

Protected Fields
Name | Description
cfcClassFactory | This is cfcClassFactory, a member of class TnxClassFactoryControl.
cfcClassID | This is cfcClassID, a member of class TnxClassFactoryControl.
cfcRegistered | This is cfcRegistered, a member of class TnxClassFactoryControl.
cfcRegistry | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
ReleaseSingelton | InxClassFactoryControl
Unregister | InxFactoryControl
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassFactoryControl
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassFactoryControl Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassFactoryControl.Create Constructor

TnxClassFactoryControl.Create Constructor
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Class Send Feedback
Syntax
Delphi
constructor Create(aClassFactoryRegistry: TnxClassFactoryRegistry; const aClassID: TnxGuid; const aClassFactory: InxClassFactory);
Description

TnxClassFactoryControl

Class

TnxClassFactoryControl Class

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Class


TnxClassFactoryControl.Destroy Destructor

TnxClassFactoryControl.Destroy Destructor
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassFactoryControl Class

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Class


TnxClassFactoryControl Fields

TnxClassFactoryControl Fields
TnxClassFactoryControl Class Legend Protected Fields Send Feedback

The fields of the TnxClassFactoryControl class are listed here.

Class

TnxClassFactoryControl Class

Protected Fields
Name | Description
cfcClassFactory | This is cfcClassFactory, a member of class TnxClassFactoryControl.
cfcClassID | This is cfcClassID, a member of class TnxClassFactoryControl.
cfcRegistered | This is cfcRegistered, a member of class TnxClassFactoryControl.
cfcRegistry | private
Links
TnxClassFactoryControl Class, Legend, Protected Fields


TnxClassFactoryControl.cfcClassFactory Field

TnxClassFactoryControl.cfcClassFactory Field
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Fields Send Feedback
Syntax
Delphi
cfcClassFactory: InxClassFactory;
Description

This is cfcClassFactory, a member of class TnxClassFactoryControl.

Group

TnxClassFactoryControl Fields

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Fields


TnxClassFactoryControl.cfcClassID Field

TnxClassFactoryControl.cfcClassID Field
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Fields Send Feedback
Syntax
Delphi
cfcClassID: TnxGuid;
Description

This is cfcClassID, a member of class TnxClassFactoryControl.

Group

TnxClassFactoryControl Fields

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Fields


TnxClassFactoryControl.cfcRegistered Field

TnxClassFactoryControl.cfcRegistered Field
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Fields Send Feedback
Syntax
Delphi
cfcRegistered: Boolean;
Description

This is cfcRegistered, a member of class TnxClassFactoryControl.

Group

TnxClassFactoryControl Fields

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Fields


TnxClassFactoryControl.cfcRegistry Field

TnxClassFactoryControl.cfcRegistry Field
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Fields Send Feedback
Syntax
Delphi
cfcRegistry: TnxClassFactoryRegistry;
Description

private

Group

TnxClassFactoryControl Fields

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Fields


TnxClassFactoryControl Methods

TnxClassFactoryControl Methods
TnxClassFactoryControl Class Legend Protected Methods Send Feedback

The methods of the TnxClassFactoryControl class are listed here.

Class

TnxClassFactoryControl Class

Protected Methods
Name | Description
ReleaseSingelton | InxClassFactoryControl
Unregister | InxFactoryControl
Links
TnxClassFactoryControl Class, Legend, Protected Methods


TnxClassFactoryControl.ReleaseSingelton Method

TnxClassFactoryControl.ReleaseSingelton Method
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Methods Send Feedback
Syntax
Delphi
function ReleaseSingelton: HRESULT;
Description

InxClassFactoryControl

Group

TnxClassFactoryControl Methods

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Methods


TnxClassFactoryControl.Unregister Method

TnxClassFactoryControl.Unregister Method
TnxClassFactoryControl Class TnxClassFactoryControl Members nxrbClassFactoryRegistry Namespace TnxClassFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

InxFactoryControl

Group

TnxClassFactoryControl Methods

Links
TnxClassFactoryControl Class, TnxClassFactoryControl Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryControl Methods


TnxClassFactoryRegistry Class

TnxClassFactoryRegistry Class
TnxClassFactoryRegistry Fields TnxClassFactoryRegistry Methods TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassFactoryRegistry_TnxClassFactoryRegistrynxrbClassFactoryRegistry_TnxClassFactoryRegistrynxrbClassFactoryRegistry_TnxClassFactoryRegistrynxrbClassFactoryRegistry_TnxClassFactoryRegistrynxrbClassFactoryRegistry_TnxClassFactoryRegistry
Syntax
Delphi
TnxClassFactoryRegistry = class(TnxInterfacedObject, InxClassActivator, InxClassFactoryRegistry);
File

nxrbClassFactoryRegistry

Description

This is class nxrbClassFactoryRegistry.TnxClassFactoryRegistry.

Group

Classes

Links
TnxClassFactoryRegistry Fields, TnxClassFactoryRegistry Methods, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry, Classes


TnxClassFactoryRegistry Members

TnxClassFactoryRegistry Members
TnxClassFactoryRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassFactoryRegistry.

Class

TnxClassFactoryRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
phrFactories | This is phrFactories, a member of class TnxClassFactoryRegistry.
phrPortal | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInstance | InxClassActivator
ioDeactivate |
QueryInterface |
RegisterFactory | InxClassFactoryRegistry
ReleaseSingeltons |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassFactoryRegistry
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassFactoryRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassFactoryRegistry.Create Constructor

TnxClassFactoryRegistry.Create Constructor
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxClassFactoryRegistry

Class

TnxClassFactoryRegistry Class

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Class


TnxClassFactoryRegistry.Destroy Destructor

TnxClassFactoryRegistry.Destroy Destructor
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassFactoryRegistry Class

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Class


TnxClassFactoryRegistry Fields

TnxClassFactoryRegistry Fields
TnxClassFactoryRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxClassFactoryRegistry class are listed here.

Class

TnxClassFactoryRegistry Class

Protected Fields
Name | Description
phrFactories | This is phrFactories, a member of class TnxClassFactoryRegistry.
phrPortal | private
Links
TnxClassFactoryRegistry Class, Legend, Protected Fields


TnxClassFactoryRegistry.phrFactories Field

TnxClassFactoryRegistry.phrFactories Field
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Fields Send Feedback
Syntax
Delphi
phrFactories: TnxFastStringListCS;
Description

This is phrFactories, a member of class TnxClassFactoryRegistry.

Group

TnxClassFactoryRegistry Fields

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Fields


TnxClassFactoryRegistry.phrPortal Field

TnxClassFactoryRegistry.phrPortal Field
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Fields Send Feedback
Syntax
Delphi
phrPortal: TnxReadWritePortal;
Description

private

Group

TnxClassFactoryRegistry Fields

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Fields


TnxClassFactoryRegistry Methods

TnxClassFactoryRegistry Methods
TnxClassFactoryRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxClassFactoryRegistry class are listed here.

Class

TnxClassFactoryRegistry Class

Protected Methods
Name | Description
CreateInstance | InxClassActivator
RegisterFactory | InxClassFactoryRegistry
ReleaseSingeltons |
Links
TnxClassFactoryRegistry Class, Legend, Protected Methods


TnxClassFactoryRegistry.CreateInstance Method

TnxClassFactoryRegistry.CreateInstance Method
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT;
Description

InxClassActivator

Group

TnxClassFactoryRegistry Methods

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Methods


TnxClassFactoryRegistry.RegisterFactory Method

TnxClassFactoryRegistry.RegisterFactory Method
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassID: TnxGuid; const aFactory: InxClassFactory; out aControl: InxClassFactoryControl): HRESULT;
Description

InxClassFactoryRegistry

Group

TnxClassFactoryRegistry Methods

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Methods


TnxClassFactoryRegistry.ReleaseSingeltons Method

TnxClassFactoryRegistry.ReleaseSingeltons Method
TnxClassFactoryRegistry Class TnxClassFactoryRegistry Members nxrbClassFactoryRegistry Namespace TnxClassFactoryRegistry Methods Send Feedback
Syntax
Delphi
function ReleaseSingeltons: HRESULT;
Group

TnxClassFactoryRegistry Methods

Links
TnxClassFactoryRegistry Class, TnxClassFactoryRegistry Members, nxrbClassFactoryRegistry Namespace, TnxClassFactoryRegistry Methods


nxrbClassProxyFactoryRegistry Namespace

nxrbClassProxyFactoryRegistry Namespace
Classes Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrbClassProxyFactoryRegistry.

Classes
Name | Description
TnxClassProxyFactoryControl | This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryControl.
TnxClassProxyFactoryRegistry | This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistry.
Structs, Records, Enums
Name | Description
TnxClassProxyFactoryRegistryRecord | This is record nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistryRecord.
TnxClassProxyRegType | This is record nxrbClassProxyFactoryRegistry.TnxClassProxyRegType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Links
Classes, Legend, Structs, Records, Enums, Topics


Classes

Classes
Classes nxrbClassProxyFactoryRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassProxyFactoryControl | This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryControl.
TnxClassProxyFactoryRegistry | This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistry.
Namespace

nxrbClassProxyFactoryRegistry Namespace

Links
Classes, nxrbClassProxyFactoryRegistry Namespace, Legend


TnxClassProxyFactoryControl Class

TnxClassProxyFactoryControl Class
TnxClassProxyFactoryControl Fields TnxClassProxyFactoryControl Methods TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassProxyFactoryRegistry_TnxClassProxyFactoryControlnxrbClassProxyFactoryRegistry_TnxClassProxyFactoryControlnxrbClassProxyFactoryRegistry_TnxClassProxyFactoryControlnxrbClassProxyFactoryRegistry_TnxClassProxyFactoryControlnxrbClassProxyFactoryRegistry_TnxClassProxyFactoryControl
Syntax
Delphi
TnxClassProxyFactoryControl = class(TnxInterfacedObject, InxFactoryControl, InxClassProxyFactoryControl);
File

nxrbClassProxyFactoryRegistry

Description

This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryControl.

Group

Classes

Links
TnxClassProxyFactoryControl Fields, TnxClassProxyFactoryControl Methods, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry, Classes


TnxClassProxyFactoryControl Members

TnxClassProxyFactoryControl Members
TnxClassProxyFactoryControl Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassProxyFactoryControl.

Class

TnxClassProxyFactoryControl Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
phfcClassProxyFactory | This is phfcClassProxyFactory, a member of class TnxClassProxyFactoryControl.
phfcClassProxyID | private
phfcRegGeneric | This is phfcRegGeneric, a member of class TnxClassProxyFactoryControl.
phfcRegistry | This is phfcRegistry, a member of class TnxClassProxyFactoryControl.
phfcRegistryRef | This is phfcRegistryRef, a member of class TnxClassProxyFactoryControl.
phfcRegLists | This is phfcRegLists, a member of class TnxClassProxyFactoryControl.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
RegisterForClass | InxClassProxyFactoryControl
RegisterGeneric |
RegisterType |
Unregister | InxFactoryControl
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassProxyFactoryControl
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassProxyFactoryControl Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassProxyFactoryControl.Create Constructor

TnxClassProxyFactoryControl.Create Constructor
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Class Send Feedback
Syntax
Delphi
constructor Create(aClassProxyFactoryRegistry: TnxClassProxyFactoryRegistry; const aClassProxyID: TnxGuid; const aClassProxyFactory: InxClassProxyFactory);
Description

TnxClassProxyFactoryControl

Class

TnxClassProxyFactoryControl Class

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Class


TnxClassProxyFactoryControl.Destroy Destructor

TnxClassProxyFactoryControl.Destroy Destructor
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassProxyFactoryControl Class

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Class


TnxClassProxyFactoryControl Fields

TnxClassProxyFactoryControl Fields
TnxClassProxyFactoryControl Class Legend Protected Fields Send Feedback

The fields of the TnxClassProxyFactoryControl class are listed here.

Class

TnxClassProxyFactoryControl Class

Protected Fields
Name | Description
phfcClassProxyFactory | This is phfcClassProxyFactory, a member of class TnxClassProxyFactoryControl.
phfcClassProxyID | private
phfcRegGeneric | This is phfcRegGeneric, a member of class TnxClassProxyFactoryControl.
phfcRegistry | This is phfcRegistry, a member of class TnxClassProxyFactoryControl.
phfcRegistryRef | This is phfcRegistryRef, a member of class TnxClassProxyFactoryControl.
phfcRegLists | This is phfcRegLists, a member of class TnxClassProxyFactoryControl.
Links
TnxClassProxyFactoryControl Class, Legend, Protected Fields


TnxClassProxyFactoryControl.phfcClassProxyFactory Field

TnxClassProxyFactoryControl.phfcClassProxyFactory Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcClassProxyFactory: InxClassProxyFactory;
Description

This is phfcClassProxyFactory, a member of class TnxClassProxyFactoryControl.

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl.phfcClassProxyID Field

TnxClassProxyFactoryControl.phfcClassProxyID Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcClassProxyID: TnxGuid;
Description

private

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl.phfcRegGeneric Field

TnxClassProxyFactoryControl.phfcRegGeneric Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcRegGeneric: Integer;
Description

This is phfcRegGeneric, a member of class TnxClassProxyFactoryControl.

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl.phfcRegistry Field

TnxClassProxyFactoryControl.phfcRegistry Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcRegistry: TnxClassProxyFactoryRegistry;
Description

This is phfcRegistry, a member of class TnxClassProxyFactoryControl.

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl.phfcRegistryRef Field

TnxClassProxyFactoryControl.phfcRegistryRef Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcRegistryRef: InxClassProxyFactoryRegistry;
Description

This is phfcRegistryRef, a member of class TnxClassProxyFactoryControl.

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl.phfcRegLists Field

TnxClassProxyFactoryControl.phfcRegLists Field
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Fields Send Feedback
Syntax
Delphi
phfcRegLists: array [TnxClassProxyRegType] of TnxFastStringListCS;
Description

This is phfcRegLists, a member of class TnxClassProxyFactoryControl.

Group

TnxClassProxyFactoryControl Fields

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Fields


TnxClassProxyFactoryControl Methods

TnxClassProxyFactoryControl Methods
TnxClassProxyFactoryControl Class Legend Protected Methods Send Feedback

The methods of the TnxClassProxyFactoryControl class are listed here.

Class

TnxClassProxyFactoryControl Class

Protected Methods
Name | Description
RegisterForClass | InxClassProxyFactoryControl
RegisterGeneric |
RegisterType |
Unregister | InxFactoryControl
Links
TnxClassProxyFactoryControl Class, Legend, Protected Methods


TnxClassProxyFactoryControl.RegisterForClass Method

TnxClassProxyFactoryControl.RegisterForClass Method
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

InxClassProxyFactoryControl

Group

TnxClassProxyFactoryControl Methods

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Methods


TnxClassProxyFactoryControl.RegisterGeneric Method

TnxClassProxyFactoryControl.RegisterGeneric Method
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Group

TnxClassProxyFactoryControl Methods

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Methods


TnxClassProxyFactoryControl.RegisterType Method

TnxClassProxyFactoryControl.RegisterType Method
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterType(aPriority: TnxRegisterPriority; aType: TnxClassProxyRegType; const aGuid: string): HRESULT;
Group

TnxClassProxyFactoryControl Methods

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Methods


TnxClassProxyFactoryControl.Unregister Method

TnxClassProxyFactoryControl.Unregister Method
TnxClassProxyFactoryControl Class TnxClassProxyFactoryControl Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

InxFactoryControl

Group

TnxClassProxyFactoryControl Methods

Links
TnxClassProxyFactoryControl Class, TnxClassProxyFactoryControl Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryControl Methods


TnxClassProxyFactoryRegistry Class

TnxClassProxyFactoryRegistry Class
TnxClassProxyFactoryRegistry Fields TnxClassProxyFactoryRegistry Methods TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassProxyFactoryRegistry_TnxClassProxyFactoryRegistrynxrbClassProxyFactoryRegistry_TnxClassProxyFactoryRegistrynxrbClassProxyFactoryRegistry_TnxClassProxyFactoryRegistrynxrbClassProxyFactoryRegistry_TnxClassProxyFactoryRegistry
Syntax
Delphi
TnxClassProxyFactoryRegistry = class(TnxInterfacedObject, InxClassProxyFactoryRegistry);
File

nxrbClassProxyFactoryRegistry

Description

This is class nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistry.

Group

Classes

Links
TnxClassProxyFactoryRegistry Fields, TnxClassProxyFactoryRegistry Methods, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry, Classes


TnxClassProxyFactoryRegistry Members

TnxClassProxyFactoryRegistry Members
TnxClassProxyFactoryRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassProxyFactoryRegistry.

Class

TnxClassProxyFactoryRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
phrFactories | This is phrFactories, a member of class TnxClassProxyFactoryRegistry.
phrPortal | private
phrRegistry | This is phrRegistry, a member of class TnxClassProxyFactoryRegistry.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateClassProxy |
ioDeactivate |
QueryClassProxys |
QueryInterface |
RegisterFactory | InxClassProxyFactoryRegistry
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassProxyFactoryRegistry
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassProxyFactoryRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassProxyFactoryRegistry.Create Constructor

TnxClassProxyFactoryRegistry.Create Constructor
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxClassProxyFactoryRegistry

Class

TnxClassProxyFactoryRegistry Class

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Class


TnxClassProxyFactoryRegistry.Destroy Destructor

TnxClassProxyFactoryRegistry.Destroy Destructor
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassProxyFactoryRegistry Class

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Class


TnxClassProxyFactoryRegistry Fields

TnxClassProxyFactoryRegistry Fields
TnxClassProxyFactoryRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxClassProxyFactoryRegistry class are listed here.

Class

TnxClassProxyFactoryRegistry Class

Protected Fields
Name | Description
phrFactories | This is phrFactories, a member of class TnxClassProxyFactoryRegistry.
phrPortal | private
phrRegistry | This is phrRegistry, a member of class TnxClassProxyFactoryRegistry.
Links
TnxClassProxyFactoryRegistry Class, Legend, Protected Fields


TnxClassProxyFactoryRegistry.phrFactories Field

TnxClassProxyFactoryRegistry.phrFactories Field
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
phrFactories: TnxFastStringListCS;
Description

This is phrFactories, a member of class TnxClassProxyFactoryRegistry.

Group

TnxClassProxyFactoryRegistry Fields

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Fields


TnxClassProxyFactoryRegistry.phrPortal Field

TnxClassProxyFactoryRegistry.phrPortal Field
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
phrPortal: TnxReadWritePortal;
Description

private

Group

TnxClassProxyFactoryRegistry Fields

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Fields


TnxClassProxyFactoryRegistry.phrRegistry Field

TnxClassProxyFactoryRegistry.phrRegistry Field
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
phrRegistry: array[TnxRegisterPriority] of TnxClassProxyFactoryRegistryRecord;
Description

This is phrRegistry, a member of class TnxClassProxyFactoryRegistry.

Group

TnxClassProxyFactoryRegistry Fields

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Fields


TnxClassProxyFactoryRegistry Methods

TnxClassProxyFactoryRegistry Methods
TnxClassProxyFactoryRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxClassProxyFactoryRegistry class are listed here.

Class

TnxClassProxyFactoryRegistry Class

Protected Methods
Name | Description
CreateClassProxy |
QueryClassProxys |
RegisterFactory | InxClassProxyFactoryRegistry
Links
TnxClassProxyFactoryRegistry Class, Legend, Protected Methods


TnxClassProxyFactoryRegistry.CreateClassProxy Method

TnxClassProxyFactoryRegistry.CreateClassProxy Method
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateClassProxy(const aOuter: InxInterface; const aClassProxyID: TnxGuid; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aReader: InxReader; out aClassProxy: InxClassProxy): HRESULT;
Group

TnxClassProxyFactoryRegistry Methods

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Methods


TnxClassProxyFactoryRegistry.QueryClassProxys Method

TnxClassProxyFactoryRegistry.QueryClassProxys Method
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryClassProxys(const aClassID: TnxGuid; aClassProxyIDs: PnxGuid; aClassProxyIDCountMax: Integer; out aClassProxyIDCount: Integer): HRESULT;
Group

TnxClassProxyFactoryRegistry Methods

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Methods


TnxClassProxyFactoryRegistry.RegisterFactory Method

TnxClassProxyFactoryRegistry.RegisterFactory Method
TnxClassProxyFactoryRegistry Class TnxClassProxyFactoryRegistry Members nxrbClassProxyFactoryRegistry Namespace TnxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassProxyID: TnxGuid; const aFactory: InxClassProxyFactory; out aControl: InxClassProxyFactoryControl): HRESULT;
Description

InxClassProxyFactoryRegistry

Group

TnxClassProxyFactoryRegistry Methods

Links
TnxClassProxyFactoryRegistry Class, TnxClassProxyFactoryRegistry Members, nxrbClassProxyFactoryRegistry Namespace, TnxClassProxyFactoryRegistry Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrbClassProxyFactoryRegistry Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxClassProxyRegType | This is record nxrbClassProxyFactoryRegistry.TnxClassProxyRegType.
Namespace

nxrbClassProxyFactoryRegistry Namespace

Records
Name | Description
TnxClassProxyFactoryRegistryRecord | This is record nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistryRecord.
Links
Enumerations, nxrbClassProxyFactoryRegistry Namespace, Legend, Records


nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistryRecord Record

nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistryRecord Record
nxrbClassProxyFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassProxyFactoryRegistryRecord = record
  phrrLists: array [TnxClassProxyRegType] of TnxFastStringListCS;
  phrrGeneric: TnxSortedList;
end;
File

nxrbClassProxyFactoryRegistry

Description

This is record nxrbClassProxyFactoryRegistry.TnxClassProxyFactoryRegistryRecord.

Group

Structs, Records, Enums

Links
nxrbClassProxyFactoryRegistry, Structs, Records, Enums


nxrbClassProxyFactoryRegistry.TnxClassProxyRegType Enumeration

nxrbClassProxyFactoryRegistry.TnxClassProxyRegType Enumeration
nxrbClassProxyFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassProxyRegType = ( phrtClass );
File

nxrbClassProxyFactoryRegistry

Description

This is record nxrbClassProxyFactoryRegistry.TnxClassProxyRegType.

Group

Structs, Records, Enums

Links
nxrbClassProxyFactoryRegistry, Structs, Records, Enums


nxrbClassStubFactoryRegistry Namespace

nxrbClassStubFactoryRegistry Namespace
Classes Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrbClassStubFactoryRegistry.

Classes
Name | Description
TnxClassStubFactoryControl | This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryControl.
TnxClassStubFactoryRegistry | This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistry.
Structs, Records, Enums
Name | Description
TnxClassStubFactoryRegistryRecord | This is record nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistryRecord.
TnxClassStubRegType | This is record nxrbClassStubFactoryRegistry.TnxClassStubRegType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Links
Classes, Legend, Structs, Records, Enums, Topics


Classes

Classes
Classes nxrbClassStubFactoryRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassStubFactoryControl | This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryControl.
TnxClassStubFactoryRegistry | This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistry.
Namespace

nxrbClassStubFactoryRegistry Namespace

Links
Classes, nxrbClassStubFactoryRegistry Namespace, Legend


TnxClassStubFactoryControl Class

TnxClassStubFactoryControl Class
TnxClassStubFactoryControl Fields TnxClassStubFactoryControl Methods TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassStubFactoryRegistry_TnxClassStubFactoryControlnxrbClassStubFactoryRegistry_TnxClassStubFactoryControlnxrbClassStubFactoryRegistry_TnxClassStubFactoryControlnxrbClassStubFactoryRegistry_TnxClassStubFactoryControlnxrbClassStubFactoryRegistry_TnxClassStubFactoryControl
Syntax
Delphi
TnxClassStubFactoryControl = class(TnxInterfacedObject, InxFactoryControl, InxClassStubFactoryControl);
File

nxrbClassStubFactoryRegistry

Description

This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryControl.

Group

Classes

Links
TnxClassStubFactoryControl Fields, TnxClassStubFactoryControl Methods, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry, Classes


TnxClassStubFactoryControl Members

TnxClassStubFactoryControl Members
TnxClassStubFactoryControl Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassStubFactoryControl.

Class

TnxClassStubFactoryControl Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
shfcClassStubFactory | This is shfcClassStubFactory, a member of class TnxClassStubFactoryControl.
shfcClassStubID | private
shfcRegGeneric | This is shfcRegGeneric, a member of class TnxClassStubFactoryControl.
shfcRegistry | This is shfcRegistry, a member of class TnxClassStubFactoryControl.
shfcRegistryRef | This is shfcRegistryRef, a member of class TnxClassStubFactoryControl.
shfcRegLists | This is shfcRegLists, a member of class TnxClassStubFactoryControl.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
RegisterForClass | InxClassStubFactoryControl
RegisterGeneric |
RegisterType |
Supports |
Unregister | InxFactoryControl
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassStubFactoryControl
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassStubFactoryControl Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassStubFactoryControl.Create Constructor

TnxClassStubFactoryControl.Create Constructor
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Class Send Feedback
Syntax
Delphi
constructor Create(aClassStubFactoryRegistry: TnxClassStubFactoryRegistry; const aClassStubID: TnxGuid; const aClassStubFactory: InxClassStubFactory);
Description

TnxClassStubFactoryControl

Class

TnxClassStubFactoryControl Class

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Class


TnxClassStubFactoryControl.Destroy Destructor

TnxClassStubFactoryControl.Destroy Destructor
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassStubFactoryControl Class

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Class


TnxClassStubFactoryControl Fields

TnxClassStubFactoryControl Fields
TnxClassStubFactoryControl Class Legend Protected Fields Send Feedback

The fields of the TnxClassStubFactoryControl class are listed here.

Class

TnxClassStubFactoryControl Class

Protected Fields
Name | Description
shfcClassStubFactory | This is shfcClassStubFactory, a member of class TnxClassStubFactoryControl.
shfcClassStubID | private
shfcRegGeneric | This is shfcRegGeneric, a member of class TnxClassStubFactoryControl.
shfcRegistry | This is shfcRegistry, a member of class TnxClassStubFactoryControl.
shfcRegistryRef | This is shfcRegistryRef, a member of class TnxClassStubFactoryControl.
shfcRegLists | This is shfcRegLists, a member of class TnxClassStubFactoryControl.
Links
TnxClassStubFactoryControl Class, Legend, Protected Fields


TnxClassStubFactoryControl.shfcClassStubFactory Field

TnxClassStubFactoryControl.shfcClassStubFactory Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcClassStubFactory: InxClassStubFactory;
Description

This is shfcClassStubFactory, a member of class TnxClassStubFactoryControl.

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl.shfcClassStubID Field

TnxClassStubFactoryControl.shfcClassStubID Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcClassStubID: TnxGuid;
Description

private

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl.shfcRegGeneric Field

TnxClassStubFactoryControl.shfcRegGeneric Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcRegGeneric: Integer;
Description

This is shfcRegGeneric, a member of class TnxClassStubFactoryControl.

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl.shfcRegistry Field

TnxClassStubFactoryControl.shfcRegistry Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcRegistry: TnxClassStubFactoryRegistry;
Description

This is shfcRegistry, a member of class TnxClassStubFactoryControl.

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl.shfcRegistryRef Field

TnxClassStubFactoryControl.shfcRegistryRef Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcRegistryRef: InxClassStubFactoryRegistry;
Description

This is shfcRegistryRef, a member of class TnxClassStubFactoryControl.

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl.shfcRegLists Field

TnxClassStubFactoryControl.shfcRegLists Field
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Fields Send Feedback
Syntax
Delphi
shfcRegLists: array [TnxClassStubRegType] of TnxFastStringListCS;
Description

This is shfcRegLists, a member of class TnxClassStubFactoryControl.

Group

TnxClassStubFactoryControl Fields

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Fields


TnxClassStubFactoryControl Methods

TnxClassStubFactoryControl Methods
TnxClassStubFactoryControl Class Legend Protected Methods Send Feedback

The methods of the TnxClassStubFactoryControl class are listed here.

Class

TnxClassStubFactoryControl Class

Protected Methods
Name | Description
RegisterForClass | InxClassStubFactoryControl
RegisterGeneric |
RegisterType |
Supports |
Unregister | InxFactoryControl
Links
TnxClassStubFactoryControl Class, Legend, Protected Methods


TnxClassStubFactoryControl.RegisterForClass Method

TnxClassStubFactoryControl.RegisterForClass Method
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

InxClassStubFactoryControl

Group

TnxClassStubFactoryControl Methods

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Methods


TnxClassStubFactoryControl.RegisterGeneric Method

TnxClassStubFactoryControl.RegisterGeneric Method
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Group

TnxClassStubFactoryControl Methods

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Methods


TnxClassStubFactoryControl.RegisterType Method

TnxClassStubFactoryControl.RegisterType Method
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterType(aPriority: TnxRegisterPriority; aType: TnxClassStubRegType; const aGuid: string): HRESULT;
Group

TnxClassStubFactoryControl Methods

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Methods


TnxClassStubFactoryControl.Supports Method

TnxClassStubFactoryControl.Supports Method
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function Supports(const aClassString: string; const aClassID: TnxGuid): HRESULT;
Group

TnxClassStubFactoryControl Methods

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Methods


TnxClassStubFactoryControl.Unregister Method

TnxClassStubFactoryControl.Unregister Method
TnxClassStubFactoryControl Class TnxClassStubFactoryControl Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

InxFactoryControl

Group

TnxClassStubFactoryControl Methods

Links
TnxClassStubFactoryControl Class, TnxClassStubFactoryControl Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryControl Methods


TnxClassStubFactoryRegistry Class

TnxClassStubFactoryRegistry Class
TnxClassStubFactoryRegistry Fields TnxClassStubFactoryRegistry Methods TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbClassStubFactoryRegistry_TnxClassStubFactoryRegistrynxrbClassStubFactoryRegistry_TnxClassStubFactoryRegistrynxrbClassStubFactoryRegistry_TnxClassStubFactoryRegistrynxrbClassStubFactoryRegistry_TnxClassStubFactoryRegistry
Syntax
Delphi
TnxClassStubFactoryRegistry = class(TnxInterfacedObject, InxClassStubFactoryRegistry);
File

nxrbClassStubFactoryRegistry

Description

This is class nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistry.

Group

Classes

Links
TnxClassStubFactoryRegistry Fields, TnxClassStubFactoryRegistry Methods, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry, Classes


TnxClassStubFactoryRegistry Members

TnxClassStubFactoryRegistry Members
TnxClassStubFactoryRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassStubFactoryRegistry.

Class

TnxClassStubFactoryRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
shrFactories | This is shrFactories, a member of class TnxClassStubFactoryRegistry.
shrPortal | private
shrRegistry | This is shrRegistry, a member of class TnxClassStubFactoryRegistry.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateClassStub |
FindInstance | This is the overview for the FindInstance method overload.
ioDeactivate |
MatchToProxies |
QueryClassStubs |
QueryInterface |
RegisterFactory | InxClassStubFactoryRegistry
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassStubFactoryRegistry
Destroy |
FindInstance | This is the overview for the FindInstance method overload.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassStubFactoryRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassStubFactoryRegistry.Create Constructor

TnxClassStubFactoryRegistry.Create Constructor
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxClassStubFactoryRegistry

Class

TnxClassStubFactoryRegistry Class

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Class


TnxClassStubFactoryRegistry.Destroy Destructor

TnxClassStubFactoryRegistry.Destroy Destructor
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassStubFactoryRegistry Class

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Class


TnxClassStubFactoryRegistry Fields

TnxClassStubFactoryRegistry Fields
TnxClassStubFactoryRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxClassStubFactoryRegistry class are listed here.

Class

TnxClassStubFactoryRegistry Class

Protected Fields
Name | Description
shrFactories | This is shrFactories, a member of class TnxClassStubFactoryRegistry.
shrPortal | private
shrRegistry | This is shrRegistry, a member of class TnxClassStubFactoryRegistry.
Links
TnxClassStubFactoryRegistry Class, Legend, Protected Fields


TnxClassStubFactoryRegistry.shrFactories Field

TnxClassStubFactoryRegistry.shrFactories Field
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
shrFactories: TnxFastStringListCS;
Description

This is shrFactories, a member of class TnxClassStubFactoryRegistry.

Group

TnxClassStubFactoryRegistry Fields

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Fields


TnxClassStubFactoryRegistry.shrPortal Field

TnxClassStubFactoryRegistry.shrPortal Field
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
shrPortal: TnxReadWritePortal;
Description

private

Group

TnxClassStubFactoryRegistry Fields

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Fields


TnxClassStubFactoryRegistry.shrRegistry Field

TnxClassStubFactoryRegistry.shrRegistry Field
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
shrRegistry: array[TnxRegisterPriority] of TnxClassStubFactoryRegistryRecord;
Description

This is shrRegistry, a member of class TnxClassStubFactoryRegistry.

Group

TnxClassStubFactoryRegistry Fields

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Fields


TnxClassStubFactoryRegistry Methods

TnxClassStubFactoryRegistry Methods
TnxClassStubFactoryRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxClassStubFactoryRegistry class are listed here.

Class

TnxClassStubFactoryRegistry Class

Protected Methods
Name | Description
CreateClassStub |
FindInstance | This is the overview for the FindInstance method overload.
MatchToProxies |
QueryClassStubs |
RegisterFactory | InxClassStubFactoryRegistry
Links
TnxClassStubFactoryRegistry Class, Legend, Protected Methods


TnxClassStubFactoryRegistry.CreateClassStub Method

TnxClassStubFactoryRegistry.CreateClassStub Method
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateClassStub(const aClassStubID: TnxGuid; const aClassID: TnxGuid; const aInterface: InxInterface; out aClassStub: InxClassStub): HRESULT;
Group

TnxClassStubFactoryRegistry Methods

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Methods


FindInstance Method

FindInstance Method
TnxClassStubFactoryRegistry Methods Send Feedback

This is the overview for the FindInstance method overload.

Overload List
Name | Description
TnxClassStubFactoryRegistry.FindInstance (InxInterface, InxClassStub) |
TnxClassStubFactoryRegistry.FindInstance (TnxGuid, TnxGuid, InxClassStub) |
Group

TnxClassStubFactoryRegistry Methods

Links
TnxClassStubFactoryRegistry Methods


TnxClassStubFactoryRegistry.FindInstance Method (InxInterface, InxClassStub)

TnxClassStubFactoryRegistry.FindInstance Method (InxInterface, InxClassStub)
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstance: InxInterface; out aClassStub: InxClassStub): HRESULT; overload;
Group

FindInstance Method

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, FindInstance Method


TnxClassStubFactoryRegistry.FindInstance Method (TnxGuid, TnxGuid, InxClassStub)

TnxClassStubFactoryRegistry.FindInstance Method (TnxGuid, TnxGuid, InxClassStub)
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aClassStubID: TnxGuid; const aInstanceID: TnxGuid; out aClassStub: InxClassStub): HRESULT; overload;
Group

FindInstance Method

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, FindInstance Method


TnxClassStubFactoryRegistry.MatchToProxies Method

TnxClassStubFactoryRegistry.MatchToProxies Method
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function MatchToProxies(const aClassID: TnxGuid; aClassProxyIDs: PnxGuid; aClassProxyIDCount: Integer; out aClassStubID: TnxGuid): HRESULT;
Group

TnxClassStubFactoryRegistry Methods

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Methods


TnxClassStubFactoryRegistry.QueryClassStubs Method

TnxClassStubFactoryRegistry.QueryClassStubs Method
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryClassStubs(const aClassID: TnxGuid; aClassStubIDs: PnxGuid; aClassStubIDCountMax: Integer; out aClassStubIDCount: Integer): HRESULT;
Group

TnxClassStubFactoryRegistry Methods

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Methods


TnxClassStubFactoryRegistry.RegisterFactory Method

TnxClassStubFactoryRegistry.RegisterFactory Method
TnxClassStubFactoryRegistry Class TnxClassStubFactoryRegistry Members nxrbClassStubFactoryRegistry Namespace TnxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassStubID: TnxGuid; const aFactory: InxClassStubFactory; out aControl: InxClassStubFactoryControl): HRESULT;
Description

InxClassStubFactoryRegistry

Group

TnxClassStubFactoryRegistry Methods

Links
TnxClassStubFactoryRegistry Class, TnxClassStubFactoryRegistry Members, nxrbClassStubFactoryRegistry Namespace, TnxClassStubFactoryRegistry Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrbClassStubFactoryRegistry Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxClassStubRegType | This is record nxrbClassStubFactoryRegistry.TnxClassStubRegType.
Namespace

nxrbClassStubFactoryRegistry Namespace

Records
Name | Description
TnxClassStubFactoryRegistryRecord | This is record nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistryRecord.
Links
Enumerations, nxrbClassStubFactoryRegistry Namespace, Legend, Records


nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistryRecord Record

nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistryRecord Record
nxrbClassStubFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassStubFactoryRegistryRecord = record
  shrrLists: array [TnxClassStubRegType] of TnxFastStringListCS;
  shrrGeneric: TnxSortedList;
end;
File

nxrbClassStubFactoryRegistry

Description

This is record nxrbClassStubFactoryRegistry.TnxClassStubFactoryRegistryRecord.

Group

Structs, Records, Enums

Links
nxrbClassStubFactoryRegistry, Structs, Records, Enums


nxrbClassStubFactoryRegistry.TnxClassStubRegType Enumeration

nxrbClassStubFactoryRegistry.TnxClassStubRegType Enumeration
nxrbClassStubFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassStubRegType = ( shrtClass );
File

nxrbClassStubFactoryRegistry

Description

This is record nxrbClassStubFactoryRegistry.TnxClassStubRegType.

Group

Structs, Records, Enums

Links
nxrbClassStubFactoryRegistry, Structs, Records, Enums


nxrbErrorConverter Namespace

nxrbErrorConverter Namespace
Functions Legend Topics Send Feedback

This is namespace nxrbErrorConverter.

Functions
Name | Description
nxResultToComResult | This is function nxrbErrorConverter.nxResultToComResult.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Links
Functions, Legend, Topics


Functions

Functions
Functions nxrbErrorConverter Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxResultToComResult | This is function nxrbErrorConverter.nxResultToComResult.
Namespace

nxrbErrorConverter Namespace

Links
Functions, nxrbErrorConverter Namespace, Legend


nxrbErrorConverter.nxResultToComResult Function

nxrbErrorConverter.nxResultToComResult Function
nxrbErrorConverter Functions Send Feedback
Syntax
Delphi
function nxResultToComResult(aResult: TnxResult): HRESULT;
File

nxrbErrorConverter

Description

This is function nxrbErrorConverter.nxResultToComResult.

Group

Functions

Links
nxrbErrorConverter, Functions


nxrbInterfaceProxyFactoryRegistry Namespace

nxrbInterfaceProxyFactoryRegistry Namespace
Classes Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrbInterfaceProxyFactoryRegistry.

Classes
Name | Description
TnxInterfaceProxyFactoryControl | This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryControl.
TnxInterfaceProxyFactoryRegistry | This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistry.
Structs, Records, Enums
Name | Description
TnxInterfaceProxyFactoryRegistryRecord | This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistryRecord.
TnxInterfaceProxyRegType | This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyRegType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Links
Classes, Legend, Structs, Records, Enums, Topics


Classes

Classes
Classes nxrbInterfaceProxyFactoryRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInterfaceProxyFactoryControl | This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryControl.
TnxInterfaceProxyFactoryRegistry | This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistry.
Namespace

nxrbInterfaceProxyFactoryRegistry Namespace

Links
Classes, nxrbInterfaceProxyFactoryRegistry Namespace, Legend


TnxInterfaceProxyFactoryControl Class

TnxInterfaceProxyFactoryControl Class
TnxInterfaceProxyFactoryControl Fields TnxInterfaceProxyFactoryControl Methods TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryControlnxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryControlnxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryControlnxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryControlnxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryControl
Syntax
Delphi
TnxInterfaceProxyFactoryControl = class(TnxInterfacedObject, InxFactoryControl, InxInterfaceProxyFactoryControl);
File

nxrbInterfaceProxyFactoryRegistry

Description

This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryControl.

Group

Classes

Links
TnxInterfaceProxyFactoryControl Fields, TnxInterfaceProxyFactoryControl Methods, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry, Classes


TnxInterfaceProxyFactoryControl Members

TnxInterfaceProxyFactoryControl Members
TnxInterfaceProxyFactoryControl Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceProxyFactoryControl.

Class

TnxInterfaceProxyFactoryControl Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
pfcProxyFactory | This is pfcProxyFactory, a member of class TnxInterfaceProxyFactoryControl.
pfcProxyID | private
pfcRegGeneric | This is pfcRegGeneric, a member of class TnxInterfaceProxyFactoryControl.
pfcRegistry | This is pfcRegistry, a member of class TnxInterfaceProxyFactoryControl.
pfcRegistryRef | This is pfcRegistryRef, a member of class TnxInterfaceProxyFactoryControl.
pfcRegLists | This is pfcRegLists, a member of class TnxInterfaceProxyFactoryControl.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
RegisterForClass |
RegisterForClassAndInterface | InxInterfaceProxyFactoryControl
RegisterForInterface |
RegisterGeneric |
RegisterType |
Unregister | InxFactoryControl
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceProxyFactoryControl
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceProxyFactoryControl Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceProxyFactoryControl.Create Constructor

TnxInterfaceProxyFactoryControl.Create Constructor
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Class Send Feedback
Syntax
Delphi
constructor Create(aInterfaceProxyFactoryRegistry: TnxInterfaceProxyFactoryRegistry; const aInterfaceProxyID: TnxGuid; const aInterfaceProxyFactory: InxInterfaceProxyFactory);
Description

TnxInterfaceProxyFactoryControl

Class

TnxInterfaceProxyFactoryControl Class

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Class


TnxInterfaceProxyFactoryControl.Destroy Destructor

TnxInterfaceProxyFactoryControl.Destroy Destructor
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfaceProxyFactoryControl Class

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Class


TnxInterfaceProxyFactoryControl Fields

TnxInterfaceProxyFactoryControl Fields
TnxInterfaceProxyFactoryControl Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceProxyFactoryControl class are listed here.

Class

TnxInterfaceProxyFactoryControl Class

Protected Fields
Name | Description
pfcProxyFactory | This is pfcProxyFactory, a member of class TnxInterfaceProxyFactoryControl.
pfcProxyID | private
pfcRegGeneric | This is pfcRegGeneric, a member of class TnxInterfaceProxyFactoryControl.
pfcRegistry | This is pfcRegistry, a member of class TnxInterfaceProxyFactoryControl.
pfcRegistryRef | This is pfcRegistryRef, a member of class TnxInterfaceProxyFactoryControl.
pfcRegLists | This is pfcRegLists, a member of class TnxInterfaceProxyFactoryControl.
Links
TnxInterfaceProxyFactoryControl Class, Legend, Protected Fields


TnxInterfaceProxyFactoryControl.pfcProxyFactory Field

TnxInterfaceProxyFactoryControl.pfcProxyFactory Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcProxyFactory: InxInterfaceProxyFactory;
Description

This is pfcProxyFactory, a member of class TnxInterfaceProxyFactoryControl.

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl.pfcProxyID Field

TnxInterfaceProxyFactoryControl.pfcProxyID Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcProxyID: TnxGuid;
Description

private

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl.pfcRegGeneric Field

TnxInterfaceProxyFactoryControl.pfcRegGeneric Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcRegGeneric: Integer;
Description

This is pfcRegGeneric, a member of class TnxInterfaceProxyFactoryControl.

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl.pfcRegistry Field

TnxInterfaceProxyFactoryControl.pfcRegistry Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcRegistry: TnxInterfaceProxyFactoryRegistry;
Description

This is pfcRegistry, a member of class TnxInterfaceProxyFactoryControl.

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl.pfcRegistryRef Field

TnxInterfaceProxyFactoryControl.pfcRegistryRef Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcRegistryRef: InxInterfaceProxyFactoryRegistry;
Description

This is pfcRegistryRef, a member of class TnxInterfaceProxyFactoryControl.

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl.pfcRegLists Field

TnxInterfaceProxyFactoryControl.pfcRegLists Field
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Fields Send Feedback
Syntax
Delphi
pfcRegLists: array [TnxInterfaceProxyRegType] of TnxFastStringListCS;
Description

This is pfcRegLists, a member of class TnxInterfaceProxyFactoryControl.

Group

TnxInterfaceProxyFactoryControl Fields

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Fields


TnxInterfaceProxyFactoryControl Methods

TnxInterfaceProxyFactoryControl Methods
TnxInterfaceProxyFactoryControl Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceProxyFactoryControl class are listed here.

Class

TnxInterfaceProxyFactoryControl Class

Protected Methods
Name | Description
RegisterForClass |
RegisterForClassAndInterface | InxInterfaceProxyFactoryControl
RegisterForInterface |
RegisterGeneric |
RegisterType |
Unregister | InxFactoryControl
Links
TnxInterfaceProxyFactoryControl Class, Legend, Protected Methods


TnxInterfaceProxyFactoryControl.RegisterForClass Method

TnxInterfaceProxyFactoryControl.RegisterForClass Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryControl.RegisterForClassAndInterface Method

TnxInterfaceProxyFactoryControl.RegisterForClassAndInterface Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClassAndInterface(aPriority: TnxRegisterPriority; const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

InxInterfaceProxyFactoryControl

Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryControl.RegisterForInterface Method

TnxInterfaceProxyFactoryControl.RegisterForInterface Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForInterface(aPriority: TnxRegisterPriority; const aInterfaceID: TnxGuid): HRESULT;
Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryControl.RegisterGeneric Method

TnxInterfaceProxyFactoryControl.RegisterGeneric Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryControl.RegisterType Method

TnxInterfaceProxyFactoryControl.RegisterType Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterType(aPriority: TnxRegisterPriority; aType: TnxInterfaceProxyRegType; const aGuid: string): HRESULT;
Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryControl.Unregister Method

TnxInterfaceProxyFactoryControl.Unregister Method
TnxInterfaceProxyFactoryControl Class TnxInterfaceProxyFactoryControl Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

InxFactoryControl

Group

TnxInterfaceProxyFactoryControl Methods

Links
TnxInterfaceProxyFactoryControl Class, TnxInterfaceProxyFactoryControl Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryControl Methods


TnxInterfaceProxyFactoryRegistry Class

TnxInterfaceProxyFactoryRegistry Class
TnxInterfaceProxyFactoryRegistry Fields TnxInterfaceProxyFactoryRegistry Methods TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryRegistrynxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryRegistrynxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryRegistrynxrbInterfaceProxyFactoryRegistry_TnxInterfaceProxyFactoryRegistry
Syntax
Delphi
TnxInterfaceProxyFactoryRegistry = class(TnxInterfacedObject, InxInterfaceProxyFactoryRegistry);
File

nxrbInterfaceProxyFactoryRegistry

Description

This is class nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistry.

Group

Classes

Links
TnxInterfaceProxyFactoryRegistry Fields, TnxInterfaceProxyFactoryRegistry Methods, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry, Classes


TnxInterfaceProxyFactoryRegistry Members

TnxInterfaceProxyFactoryRegistry Members
TnxInterfaceProxyFactoryRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceProxyFactoryRegistry.

Class

TnxInterfaceProxyFactoryRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
prFactories | This is prFactories, a member of class TnxInterfaceProxyFactoryRegistry.
prPortal | private
prRegistry | This is prRegistry, a member of class TnxInterfaceProxyFactoryRegistry.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInterfaceProxy |
ioDeactivate |
QueryInterface |
QueryProxies |
RegisterFactory | InxInterfaceProxyFactoryRegistry
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceProxyFactoryRegistry
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceProxyFactoryRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceProxyFactoryRegistry.Create Constructor

TnxInterfaceProxyFactoryRegistry.Create Constructor
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxInterfaceProxyFactoryRegistry

Class

TnxInterfaceProxyFactoryRegistry Class

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Class


TnxInterfaceProxyFactoryRegistry.Destroy Destructor

TnxInterfaceProxyFactoryRegistry.Destroy Destructor
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfaceProxyFactoryRegistry Class

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Class


TnxInterfaceProxyFactoryRegistry Fields

TnxInterfaceProxyFactoryRegistry Fields
TnxInterfaceProxyFactoryRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceProxyFactoryRegistry class are listed here.

Class

TnxInterfaceProxyFactoryRegistry Class

Protected Fields
Name | Description
prFactories | This is prFactories, a member of class TnxInterfaceProxyFactoryRegistry.
prPortal | private
prRegistry | This is prRegistry, a member of class TnxInterfaceProxyFactoryRegistry.
Links
TnxInterfaceProxyFactoryRegistry Class, Legend, Protected Fields


TnxInterfaceProxyFactoryRegistry.prFactories Field

TnxInterfaceProxyFactoryRegistry.prFactories Field
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
prFactories: TnxFastStringListCS;
Description

This is prFactories, a member of class TnxInterfaceProxyFactoryRegistry.

Group

TnxInterfaceProxyFactoryRegistry Fields

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Fields


TnxInterfaceProxyFactoryRegistry.prPortal Field

TnxInterfaceProxyFactoryRegistry.prPortal Field
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
prPortal: TnxReadWritePortal;
Description

private

Group

TnxInterfaceProxyFactoryRegistry Fields

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Fields


TnxInterfaceProxyFactoryRegistry.prRegistry Field

TnxInterfaceProxyFactoryRegistry.prRegistry Field
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Fields Send Feedback
Syntax
Delphi
prRegistry: array[TnxRegisterPriority] of TnxInterfaceProxyFactoryRegistryRecord;
Description

This is prRegistry, a member of class TnxInterfaceProxyFactoryRegistry.

Group

TnxInterfaceProxyFactoryRegistry Fields

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Fields


TnxInterfaceProxyFactoryRegistry Methods

TnxInterfaceProxyFactoryRegistry Methods
TnxInterfaceProxyFactoryRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceProxyFactoryRegistry class are listed here.

Class

TnxInterfaceProxyFactoryRegistry Class

Protected Methods
Name | Description
CreateInterfaceProxy |
QueryProxies |
RegisterFactory | InxInterfaceProxyFactoryRegistry
Links
TnxInterfaceProxyFactoryRegistry Class, Legend, Protected Methods


TnxInterfaceProxyFactoryRegistry.CreateInterfaceProxy Method

TnxInterfaceProxyFactoryRegistry.CreateInterfaceProxy Method
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateInterfaceProxy(const aInterfaceProxyID: TnxGuid; const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aInterfaceProxy: InxInterfaceProxy): HRESULT;
Group

TnxInterfaceProxyFactoryRegistry Methods

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Methods


TnxInterfaceProxyFactoryRegistry.QueryProxies Method

TnxInterfaceProxyFactoryRegistry.QueryProxies Method
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryProxies(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceProxyIDs: PnxGuid; aInterfaceProxyIDCountMax: Integer; out aInterfaceProxyIDCount: Integer): HRESULT;
Group

TnxInterfaceProxyFactoryRegistry Methods

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Methods


TnxInterfaceProxyFactoryRegistry.RegisterFactory Method

TnxInterfaceProxyFactoryRegistry.RegisterFactory Method
TnxInterfaceProxyFactoryRegistry Class TnxInterfaceProxyFactoryRegistry Members nxrbInterfaceProxyFactoryRegistry Namespace TnxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aInterfaceProxyID: TnxGuid; const aFactory: InxInterfaceProxyFactory; out aControl: InxInterfaceProxyFactoryControl): HRESULT;
Description

InxInterfaceProxyFactoryRegistry

Group

TnxInterfaceProxyFactoryRegistry Methods

Links
TnxInterfaceProxyFactoryRegistry Class, TnxInterfaceProxyFactoryRegistry Members, nxrbInterfaceProxyFactoryRegistry Namespace, TnxInterfaceProxyFactoryRegistry Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrbInterfaceProxyFactoryRegistry Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxInterfaceProxyRegType | This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyRegType.
Namespace

nxrbInterfaceProxyFactoryRegistry Namespace

Records
Name | Description
TnxInterfaceProxyFactoryRegistryRecord | This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistryRecord.
Links
Enumerations, nxrbInterfaceProxyFactoryRegistry Namespace, Legend, Records


nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistryRecord Record

nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistryRecord Record
nxrbInterfaceProxyFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInterfaceProxyFactoryRegistryRecord = record
  prrLists: array [TnxInterfaceProxyRegType] of TnxFastStringListCS;
  prrGeneric: TnxSortedList;
end;
File

nxrbInterfaceProxyFactoryRegistry

Description

This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyFactoryRegistryRecord.

Group

Structs, Records, Enums

Links
nxrbInterfaceProxyFactoryRegistry, Structs, Records, Enums


nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyRegType Enumeration

nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyRegType Enumeration
nxrbInterfaceProxyFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInterfaceProxyRegType = ( prtClassAndIntf, prtClass, prtIntf );
File

nxrbInterfaceProxyFactoryRegistry

Description

This is record nxrbInterfaceProxyFactoryRegistry.TnxInterfaceProxyRegType.

Group

Structs, Records, Enums

Links
nxrbInterfaceProxyFactoryRegistry, Structs, Records, Enums


nxrbInterfaceStubFactoryRegistry Namespace

nxrbInterfaceStubFactoryRegistry Namespace
Classes Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrbInterfaceStubFactoryRegistry.

Classes
Name | Description
TnxInterfaceStubFactoryControl | This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryControl.
TnxInterfaceStubFactoryRegistry | This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistry.
Structs, Records, Enums
Name | Description
TnxInterfaceStubFactoryRegistryRecord | This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistryRecord.
TnxInterfaceStubRegType | This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubRegType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Links
Classes, Legend, Structs, Records, Enums, Topics


Classes

Classes
Classes nxrbInterfaceStubFactoryRegistry Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInterfaceStubFactoryControl | This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryControl.
TnxInterfaceStubFactoryRegistry | This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistry.
Namespace

nxrbInterfaceStubFactoryRegistry Namespace

Links
Classes, nxrbInterfaceStubFactoryRegistry Namespace, Legend


TnxInterfaceStubFactoryControl Class

TnxInterfaceStubFactoryControl Class
TnxInterfaceStubFactoryControl Fields TnxInterfaceStubFactoryControl Methods TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryControlnxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryControlnxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryControlnxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryControlnxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryControl
Syntax
Delphi
TnxInterfaceStubFactoryControl = class(TnxInterfacedObject, InxFactoryControl, InxInterfaceStubFactoryControl);
File

nxrbInterfaceStubFactoryRegistry

Description

This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryControl.

Group

Classes

Links
TnxInterfaceStubFactoryControl Fields, TnxInterfaceStubFactoryControl Methods, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry, Classes


TnxInterfaceStubFactoryControl Members

TnxInterfaceStubFactoryControl Members
TnxInterfaceStubFactoryControl Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceStubFactoryControl.

Class

TnxInterfaceStubFactoryControl Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
sfcRegGeneric | This is sfcRegGeneric, a member of class TnxInterfaceStubFactoryControl.
sfcRegistry | This is sfcRegistry, a member of class TnxInterfaceStubFactoryControl.
sfcRegistryRef | This is sfcRegistryRef, a member of class TnxInterfaceStubFactoryControl.
sfcRegLists | This is sfcRegLists, a member of class TnxInterfaceStubFactoryControl.
sfcStubFactory | This is sfcStubFactory, a member of class TnxInterfaceStubFactoryControl.
sfcStubID | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
RegisterForClass |
RegisterForClassAndInterface | InxInterfaceStubFactoryControl
RegisterForInterface |
RegisterGeneric |
RegisterType |
Supports |
Unregister | InxFactoryControl
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceStubFactoryControl
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceStubFactoryControl Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceStubFactoryControl.Create Constructor

TnxInterfaceStubFactoryControl.Create Constructor
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Class Send Feedback
Syntax
Delphi
constructor Create(aInterfaceStubFactoryRegistry: TnxInterfaceStubFactoryRegistry; const aInterfaceStubID: TnxGuid; const aInterfaceStubFactory: InxInterfaceStubFactory);
Description

TnxInterfaceStubFactoryControl

Class

TnxInterfaceStubFactoryControl Class

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Class


TnxInterfaceStubFactoryControl.Destroy Destructor

TnxInterfaceStubFactoryControl.Destroy Destructor
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfaceStubFactoryControl Class

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Class


TnxInterfaceStubFactoryControl Fields

TnxInterfaceStubFactoryControl Fields
TnxInterfaceStubFactoryControl Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceStubFactoryControl class are listed here.

Class

TnxInterfaceStubFactoryControl Class

Protected Fields
Name | Description
sfcRegGeneric | This is sfcRegGeneric, a member of class TnxInterfaceStubFactoryControl.
sfcRegistry | This is sfcRegistry, a member of class TnxInterfaceStubFactoryControl.
sfcRegistryRef | This is sfcRegistryRef, a member of class TnxInterfaceStubFactoryControl.
sfcRegLists | This is sfcRegLists, a member of class TnxInterfaceStubFactoryControl.
sfcStubFactory | This is sfcStubFactory, a member of class TnxInterfaceStubFactoryControl.
sfcStubID | private
Links
TnxInterfaceStubFactoryControl Class, Legend, Protected Fields


TnxInterfaceStubFactoryControl.sfcRegGeneric Field

TnxInterfaceStubFactoryControl.sfcRegGeneric Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcRegGeneric: Integer;
Description

This is sfcRegGeneric, a member of class TnxInterfaceStubFactoryControl.

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl.sfcRegistry Field

TnxInterfaceStubFactoryControl.sfcRegistry Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcRegistry: TnxInterfaceStubFactoryRegistry;
Description

This is sfcRegistry, a member of class TnxInterfaceStubFactoryControl.

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl.sfcRegistryRef Field

TnxInterfaceStubFactoryControl.sfcRegistryRef Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcRegistryRef: InxInterfaceStubFactoryRegistry;
Description

This is sfcRegistryRef, a member of class TnxInterfaceStubFactoryControl.

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl.sfcRegLists Field

TnxInterfaceStubFactoryControl.sfcRegLists Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcRegLists: array [TnxInterfaceStubRegType] of TnxFastStringListCS;
Description

This is sfcRegLists, a member of class TnxInterfaceStubFactoryControl.

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl.sfcStubFactory Field

TnxInterfaceStubFactoryControl.sfcStubFactory Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcStubFactory: InxInterfaceStubFactory;
Description

This is sfcStubFactory, a member of class TnxInterfaceStubFactoryControl.

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl.sfcStubID Field

TnxInterfaceStubFactoryControl.sfcStubID Field
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Fields Send Feedback
Syntax
Delphi
sfcStubID: TnxGuid;
Description

private

Group

TnxInterfaceStubFactoryControl Fields

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Fields


TnxInterfaceStubFactoryControl Methods

TnxInterfaceStubFactoryControl Methods
TnxInterfaceStubFactoryControl Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceStubFactoryControl class are listed here.

Class

TnxInterfaceStubFactoryControl Class

Protected Methods
Name | Description
RegisterForClass |
RegisterForClassAndInterface | InxInterfaceStubFactoryControl
RegisterForInterface |
RegisterGeneric |
RegisterType |
Supports |
Unregister | InxFactoryControl
Links
TnxInterfaceStubFactoryControl Class, Legend, Protected Methods


TnxInterfaceStubFactoryControl.RegisterForClass Method

TnxInterfaceStubFactoryControl.RegisterForClass Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.RegisterForClassAndInterface Method

TnxInterfaceStubFactoryControl.RegisterForClassAndInterface Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClassAndInterface(aPriority: TnxRegisterPriority; const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

InxInterfaceStubFactoryControl

Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.RegisterForInterface Method

TnxInterfaceStubFactoryControl.RegisterForInterface Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForInterface(aPriority: TnxRegisterPriority; const aInterfaceID: TnxGuid): HRESULT;
Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.RegisterGeneric Method

TnxInterfaceStubFactoryControl.RegisterGeneric Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.RegisterType Method

TnxInterfaceStubFactoryControl.RegisterType Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterType(aPriority: TnxRegisterPriority; aType: TnxInterfaceStubRegType; const aGuid: string): HRESULT;
Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.Supports Method

TnxInterfaceStubFactoryControl.Supports Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function Supports(const aClassString: string; const aClassID: TnxGuid; const aInterfaceString: string; const aInterfaceID: TnxGuid): HRESULT;
Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryControl.Unregister Method

TnxInterfaceStubFactoryControl.Unregister Method
TnxInterfaceStubFactoryControl Class TnxInterfaceStubFactoryControl Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

InxFactoryControl

Group

TnxInterfaceStubFactoryControl Methods

Links
TnxInterfaceStubFactoryControl Class, TnxInterfaceStubFactoryControl Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryControl Methods


TnxInterfaceStubFactoryRegistry Class

TnxInterfaceStubFactoryRegistry Class
TnxInterfaceStubFactoryRegistry Fields TnxInterfaceStubFactoryRegistry Methods TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Classes Send Feedback
Class Hierarchy
nxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryRegistrynxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryRegistrynxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryRegistrynxrbInterfaceStubFactoryRegistry_TnxInterfaceStubFactoryRegistry
Syntax
Delphi
TnxInterfaceStubFactoryRegistry = class(TnxInterfacedObject, InxInterfaceStubFactoryRegistry);
File

nxrbInterfaceStubFactoryRegistry

Description

This is class nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistry.

Group

Classes

Links
TnxInterfaceStubFactoryRegistry Fields, TnxInterfaceStubFactoryRegistry Methods, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry, Classes


TnxInterfaceStubFactoryRegistry Members

TnxInterfaceStubFactoryRegistry Members
TnxInterfaceStubFactoryRegistry Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceStubFactoryRegistry.

Class

TnxInterfaceStubFactoryRegistry Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
srFactories | This is srFactories, a member of class TnxInterfaceStubFactoryRegistry.
srPortal | private
srRegistry | This is srRegistry, a member of class TnxInterfaceStubFactoryRegistry.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInterfaceStub |
ioDeactivate |
MatchToProxies |
QueryInterface |
QueryStubs |
RegisterFactory | InxInterfaceStubFactoryRegistry
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceStubFactoryRegistry
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceStubFactoryRegistry Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceStubFactoryRegistry.Create Constructor

TnxInterfaceStubFactoryRegistry.Create Constructor
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Class Send Feedback
Syntax
Delphi
constructor Create;
Description

TnxInterfaceStubFactoryRegistry

Class

TnxInterfaceStubFactoryRegistry Class

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Class


TnxInterfaceStubFactoryRegistry.Destroy Destructor

TnxInterfaceStubFactoryRegistry.Destroy Destructor
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfaceStubFactoryRegistry Class

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Class


TnxInterfaceStubFactoryRegistry Fields

TnxInterfaceStubFactoryRegistry Fields
TnxInterfaceStubFactoryRegistry Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceStubFactoryRegistry class are listed here.

Class

TnxInterfaceStubFactoryRegistry Class

Protected Fields
Name | Description
srFactories | This is srFactories, a member of class TnxInterfaceStubFactoryRegistry.
srPortal | private
srRegistry | This is srRegistry, a member of class TnxInterfaceStubFactoryRegistry.
Links
TnxInterfaceStubFactoryRegistry Class, Legend, Protected Fields


TnxInterfaceStubFactoryRegistry.srFactories Field

TnxInterfaceStubFactoryRegistry.srFactories Field
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
srFactories: TnxFastStringListCS;
Description

This is srFactories, a member of class TnxInterfaceStubFactoryRegistry.

Group

TnxInterfaceStubFactoryRegistry Fields

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Fields


TnxInterfaceStubFactoryRegistry.srPortal Field

TnxInterfaceStubFactoryRegistry.srPortal Field
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
srPortal: TnxReadWritePortal;
Description

private

Group

TnxInterfaceStubFactoryRegistry Fields

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Fields


TnxInterfaceStubFactoryRegistry.srRegistry Field

TnxInterfaceStubFactoryRegistry.srRegistry Field
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Fields Send Feedback
Syntax
Delphi
srRegistry: array[TnxRegisterPriority] of TnxInterfaceStubFactoryRegistryRecord;
Description

This is srRegistry, a member of class TnxInterfaceStubFactoryRegistry.

Group

TnxInterfaceStubFactoryRegistry Fields

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Fields


TnxInterfaceStubFactoryRegistry Methods

TnxInterfaceStubFactoryRegistry Methods
TnxInterfaceStubFactoryRegistry Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceStubFactoryRegistry class are listed here.

Class

TnxInterfaceStubFactoryRegistry Class

Protected Methods
Name | Description
CreateInterfaceStub |
MatchToProxies |
QueryStubs |
RegisterFactory | InxInterfaceStubFactoryRegistry
Links
TnxInterfaceStubFactoryRegistry Class, Legend, Protected Methods


TnxInterfaceStubFactoryRegistry.CreateInterfaceStub Method

TnxInterfaceStubFactoryRegistry.CreateInterfaceStub Method
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateInterfaceStub(const aInterfaceStubID: TnxGuid; const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInterfaceStub: InxInterfaceStub): HRESULT;
Group

TnxInterfaceStubFactoryRegistry Methods

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Methods


TnxInterfaceStubFactoryRegistry.MatchToProxies Method

TnxInterfaceStubFactoryRegistry.MatchToProxies Method
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function MatchToProxies(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceProxyIDs: PnxGuid; aInterfaceProxyIDCount: Integer; out aInterfaceStubID: TnxGuid): HRESULT;
Group

TnxInterfaceStubFactoryRegistry Methods

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Methods


TnxInterfaceStubFactoryRegistry.QueryStubs Method

TnxInterfaceStubFactoryRegistry.QueryStubs Method
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryStubs(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceStubIDs: PnxGuid; aInterfaceStubIDCountMax: Integer; out aInterfaceStubIDCount: Integer): HRESULT;
Group

TnxInterfaceStubFactoryRegistry Methods

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Methods


TnxInterfaceStubFactoryRegistry.RegisterFactory Method

TnxInterfaceStubFactoryRegistry.RegisterFactory Method
TnxInterfaceStubFactoryRegistry Class TnxInterfaceStubFactoryRegistry Members nxrbInterfaceStubFactoryRegistry Namespace TnxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aInterfaceStubID: TnxGuid; const aFactory: InxInterfaceStubFactory; out aControl: InxInterfaceStubFactoryControl): HRESULT;
Description

InxInterfaceStubFactoryRegistry

Group

TnxInterfaceStubFactoryRegistry Methods

Links
TnxInterfaceStubFactoryRegistry Class, TnxInterfaceStubFactoryRegistry Members, nxrbInterfaceStubFactoryRegistry Namespace, TnxInterfaceStubFactoryRegistry Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrbInterfaceStubFactoryRegistry Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxInterfaceStubRegType | This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubRegType.
Namespace

nxrbInterfaceStubFactoryRegistry Namespace

Records
Name | Description
TnxInterfaceStubFactoryRegistryRecord | This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistryRecord.
Links
Enumerations, nxrbInterfaceStubFactoryRegistry Namespace, Legend, Records


nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistryRecord Record

nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistryRecord Record
nxrbInterfaceStubFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInterfaceStubFactoryRegistryRecord = record
  srrLists: array [TnxInterfaceStubRegType] of TnxFastStringListCS;
  srrGeneric: TnxSortedList;
end;
File

nxrbInterfaceStubFactoryRegistry

Description

This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubFactoryRegistryRecord.

Group

Structs, Records, Enums

Links
nxrbInterfaceStubFactoryRegistry, Structs, Records, Enums


nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubRegType Enumeration

nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubRegType Enumeration
nxrbInterfaceStubFactoryRegistry Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInterfaceStubRegType = ( srtClassAndIntf, srtClass, srtIntf );
File

nxrbInterfaceStubFactoryRegistry

Description

This is record nxrbInterfaceStubFactoryRegistry.TnxInterfaceStubRegType.

Group

Structs, Records, Enums

Links
nxrbInterfaceStubFactoryRegistry, Structs, Records, Enums


nxrbRegistries Namespace

nxrbRegistries Namespace
Functions Legend Topics Variables Send Feedback

This is namespace nxrbRegistries.

Functions
Name | Description
nxClassFactoryRegistry |
nxClassProxyFactoryRegistry |
nxClassStubFactoryRegistry |
nxDisconnectObject |
nxInterfaceProxyFactoryRegistry |
nxInterfaceStubFactoryRegistry |
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_ClassFactoryRegistry |
_ClassProxyFactoryRegistry | This is variable nxrbRegistries._ClassProxyFactoryRegistry.
_ClassStubFactoryRegistry | This is variable nxrbRegistries._ClassStubFactoryRegistry.
_ProxyFactoryRegistry |
_StubFactoryRegistry |
Links
Functions, Legend, Topics, Variables


Functions

Functions
Functions nxrbRegistries Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxClassFactoryRegistry |
nxClassProxyFactoryRegistry |
nxClassStubFactoryRegistry |
nxDisconnectObject |
nxInterfaceProxyFactoryRegistry |
nxInterfaceStubFactoryRegistry |
Namespace

nxrbRegistries Namespace

Links
Functions, nxrbRegistries Namespace, Legend


nxrbRegistries.nxClassFactoryRegistry Function

nxrbRegistries.nxClassFactoryRegistry Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxClassFactoryRegistry: InxClassFactoryRegistry;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


nxrbRegistries.nxClassProxyFactoryRegistry Function

nxrbRegistries.nxClassProxyFactoryRegistry Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxClassProxyFactoryRegistry: InxClassProxyFactoryRegistry;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


nxrbRegistries.nxClassStubFactoryRegistry Function

nxrbRegistries.nxClassStubFactoryRegistry Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxClassStubFactoryRegistry: InxClassStubFactoryRegistry;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


nxrbRegistries.nxDisconnectObject Function

nxrbRegistries.nxDisconnectObject Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxDisconnectObject(const aInstance: InxInterface): HRESULT;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


nxrbRegistries.nxInterfaceProxyFactoryRegistry Function

nxrbRegistries.nxInterfaceProxyFactoryRegistry Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxInterfaceProxyFactoryRegistry: InxInterfaceProxyFactoryRegistry;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


nxrbRegistries.nxInterfaceStubFactoryRegistry Function

nxrbRegistries.nxInterfaceStubFactoryRegistry Function
nxrbRegistries Functions Send Feedback
Syntax
Delphi
function nxInterfaceStubFactoryRegistry: InxInterfaceStubFactoryRegistry;
File

nxrbRegistries

Group

Functions

Links
nxrbRegistries, Functions


Variables

Variables
nxrbRegistries Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrbRegistries Namespace

Variables
Name | Description
_ClassFactoryRegistry |
_ClassProxyFactoryRegistry | This is variable nxrbRegistries._ClassProxyFactoryRegistry.
_ClassStubFactoryRegistry | This is variable nxrbRegistries._ClassStubFactoryRegistry.
_ProxyFactoryRegistry |
_StubFactoryRegistry |
Links
nxrbRegistries Namespace, Variables


nxrbRegistries._ClassFactoryRegistry Variable

nxrbRegistries._ClassFactoryRegistry Variable
nxrbRegistries Variables Send Feedback
Syntax
Delphi
_ClassFactoryRegistry: InxClassFactoryRegistry;
File

nxrbRegistries

Group

Variables

Links
nxrbRegistries, Variables


nxrbRegistries._ClassProxyFactoryRegistry Variable

nxrbRegistries._ClassProxyFactoryRegistry Variable
nxrbRegistries Variables Send Feedback
Syntax
Delphi
_ClassProxyFactoryRegistry: InxClassProxyFactoryRegistry;
File

nxrbRegistries

Description

This is variable nxrbRegistries._ClassProxyFactoryRegistry.

Group

Variables

Links
nxrbRegistries, Variables


nxrbRegistries._ClassStubFactoryRegistry Variable

nxrbRegistries._ClassStubFactoryRegistry Variable
nxrbRegistries Variables Send Feedback
Syntax
Delphi
_ClassStubFactoryRegistry: InxClassStubFactoryRegistry;
File

nxrbRegistries

Description

This is variable nxrbRegistries._ClassStubFactoryRegistry.

Group

Variables

Links
nxrbRegistries, Variables


nxrbRegistries._ProxyFactoryRegistry Variable

nxrbRegistries._ProxyFactoryRegistry Variable
nxrbRegistries Variables Send Feedback
Syntax
Delphi
_ProxyFactoryRegistry: InxInterfaceProxyFactoryRegistry;
File

nxrbRegistries

Group

Variables

Links
nxrbRegistries, Variables


nxrbRegistries._StubFactoryRegistry Variable

nxrbRegistries._StubFactoryRegistry Variable
nxrbRegistries Variables Send Feedback
Syntax
Delphi
_StubFactoryRegistry: InxInterfaceStubFactoryRegistry;
File

nxrbRegistries

Group

Variables

Links
nxrbRegistries, Variables


nxrbTypeFiler Namespace

nxrbTypeFiler Namespace
Functions Legend Topics Send Feedback

This is namespace nxrbTypeFiler.

Functions
Name | Description
GetTypeData | This is function nxrbTypeFiler.GetTypeData.
nxCopyType | IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF
nxReadErrorInfo | This is function nxrbTypeFiler.nxReadErrorInfo.
nxReadException | This is function nxrbTypeFiler.nxReadException.
nxReadType | This is function nxrbTypeFiler.nxReadType.
nxWriteErrorInfo | This is function nxrbTypeFiler.nxWriteErrorInfo.
nxWriteException | This is function nxrbTypeFiler.nxWriteException.
nxWriteType | IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Links
Functions, Legend, Topics


Functions

Functions
Functions nxrbTypeFiler Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
GetTypeData | This is function nxrbTypeFiler.GetTypeData.
nxCopyType | IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF
nxReadErrorInfo | This is function nxrbTypeFiler.nxReadErrorInfo.
nxReadException | This is function nxrbTypeFiler.nxReadException.
nxReadType | This is function nxrbTypeFiler.nxReadType.
nxWriteErrorInfo | This is function nxrbTypeFiler.nxWriteErrorInfo.
nxWriteException | This is function nxrbTypeFiler.nxWriteException.
nxWriteType | IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF
Namespace

nxrbTypeFiler Namespace

Links
Functions, nxrbTypeFiler Namespace, Legend


nxrbTypeFiler.GetTypeData Function

nxrbTypeFiler.GetTypeData Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function GetTypeData(TypeInfo: PTypeInfo): PTypeData;
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.GetTypeData.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxCopyType Function

nxrbTypeFiler.nxCopyType Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxCopyType(aInfo: PTypeInfo; const aSource; var aTarget): HRESULT;
File

nxrbTypeFiler

Description

IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxReadErrorInfo Function

nxrbTypeFiler.nxReadErrorInfo Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxReadErrorInfo(const aReader: InxReader; out aErrorInfo: IErrorInfo): HRESULT;
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.nxReadErrorInfo.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxReadException Function

nxrbTypeFiler.nxReadException Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
procedure nxReadException(const aReader: InxReader);
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.nxReadException.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxReadType Function

nxrbTypeFiler.nxReadType Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxReadType(const aReader: InxReader; aInfo: PTypeInfo; out aData): HRESULT;
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.nxReadType.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxWriteErrorInfo Function

nxrbTypeFiler.nxWriteErrorInfo Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxWriteErrorInfo(const aWriter: InxWriter; const aErrorInfo: IErrorInfo): HRESULT;
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.nxWriteErrorInfo.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxWriteException Function

nxrbTypeFiler.nxWriteException Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxWriteException(const aWriter: InxWriter; const aException: Exception): HRESULT;
File

nxrbTypeFiler

Description

This is function nxrbTypeFiler.nxWriteException.

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypeFiler.nxWriteType Function

nxrbTypeFiler.nxWriteType Function
nxrbTypeFiler Functions Send Feedback
Syntax
Delphi
function nxWriteType(const aWriter: InxWriter; aInfo: PTypeInfo; const aData): HRESULT;
File

nxrbTypeFiler

Description

IFDEF OVERFLOWCHECKON}{$Q+}{$ENDIF IFDEF RANGECHECKON}{$R+}{$ENDIF

Group

Functions

Links
nxrbTypeFiler, Functions


nxrbTypes Namespace

nxrbTypes Namespace
Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxrbTypes.

Constants
Name | Description
IID_InxClassActivator | This is constant nxrbTypes.IID_InxClassActivator.
Functions
Name | Description
nxReadObjectIdentity |
nxReadRoutingPath |
nxRoutingPathFromStatic |
nxRoutingPathToStatic |
nxWriteObjectIdentity |
nxWriteRoutingPath |
Interfaces
Name | Description
InxCallContext | This is class nxrbTypes.InxCallContext.
InxChannel | This is class nxrbTypes.InxChannel.
InxChannelEntrance | This is class nxrbTypes.InxChannelEntrance.
InxChannelExit | This is class nxrbTypes.InxChannelExit.
InxChannelSink | This is class nxrbTypes.InxChannelSink.
InxClass | This is class nxrbTypes.InxClass.
InxClassFactory | This is class nxrbTypes.InxClassFactory.
InxClassFactoryControl | This is class nxrbTypes.InxClassFactoryControl.
InxClassFactoryRegistry | This is class nxrbTypes.InxClassFactoryRegistry.
InxClassProxy | This is class nxrbTypes.InxClassProxy.
InxClassProxyFactory | This is class nxrbTypes.InxClassProxyFactory.
InxClassProxyFactoryControl | This is class nxrbTypes.InxClassProxyFactoryControl.
InxClassProxyFactoryRegistry | This is class nxrbTypes.InxClassProxyFactoryRegistry.
InxClassStub | This is class nxrbTypes.InxClassStub.
InxClassStubFactory | This is class nxrbTypes.InxClassStubFactory.
InxClassStubFactoryControl | This is class nxrbTypes.InxClassStubFactoryControl.
InxClassStubFactoryRegistry | This is class nxrbTypes.InxClassStubFactoryRegistry.
InxFactoryControl | This is class nxrbTypes.InxFactoryControl.
InxInterfaceFilerInit | This is class nxrbTypes.InxInterfaceFilerInit.
InxInterfaceProxy | This is class nxrbTypes.InxInterfaceProxy.
InxInterfaceProxyFactory | This is class nxrbTypes.InxInterfaceProxyFactory.
InxInterfaceProxyFactoryControl | This is class nxrbTypes.InxInterfaceProxyFactoryControl.
InxInterfaceProxyFactoryRegistry | This is class nxrbTypes.InxInterfaceProxyFactoryRegistry.
InxInterfaceReader | This is class nxrbTypes.InxInterfaceReader.
InxInterfaceStub | This is class nxrbTypes.InxInterfaceStub.
InxInterfaceStubFactory | This is class nxrbTypes.InxInterfaceStubFactory.
InxInterfaceStubFactoryControl | This is class nxrbTypes.InxInterfaceStubFactoryControl.
InxInterfaceStubFactoryRegistry | This is class nxrbTypes.InxInterfaceStubFactoryRegistry.
InxInterfaceWriter | This is class nxrbTypes.InxInterfaceWriter.
InxReader | This is class nxrbTypes.InxReader.
InxRemoteableClass | This is class nxrbTypes.InxRemoteableClass.
InxRoutingPath | This is class nxrbTypes.InxRoutingPath.
InxSingeltonClassFactory | This is class nxrbTypes.InxSingeltonClassFactory.
InxWriter | This is class nxrbTypes.InxWriter.
Structs, Records, Enums
Name | Description
TnxObjectIdentity | This is record nxrbTypes.TnxObjectIdentity.
Topics
Name | Description
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
InxClassActivator | This is type nxrbTypes.InxClassActivator.
TnxRegisterPriority | This is type nxrbTypes.TnxRegisterPriority.
TnxRoutingPath | This is type nxrbTypes.TnxRoutingPath.
TnxStaticProxyIDs | This is type nxrbTypes.TnxStaticProxyIDs.
TnxStaticRoutingPath | This is type nxrbTypes.TnxStaticRoutingPath.
Variables
Name | Description
nxCurrentServerID | unique guid during the livetime of this process
Links
Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Interfaces

Interfaces
nxrbTypes Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxrbTypes Namespace

Interfaces
Name | Description
InxCallContext | This is class nxrbTypes.InxCallContext.
InxChannel | This is class nxrbTypes.InxChannel.
InxChannelEntrance | This is class nxrbTypes.InxChannelEntrance.
InxChannelExit | This is class nxrbTypes.InxChannelExit.
InxChannelSink | This is class nxrbTypes.InxChannelSink.
InxClass | This is class nxrbTypes.InxClass.
InxClassFactory | This is class nxrbTypes.InxClassFactory.
InxClassFactoryControl | This is class nxrbTypes.InxClassFactoryControl.
InxClassFactoryRegistry | This is class nxrbTypes.InxClassFactoryRegistry.
InxClassProxy | This is class nxrbTypes.InxClassProxy.
InxClassProxyFactory | This is class nxrbTypes.InxClassProxyFactory.
InxClassProxyFactoryControl | This is class nxrbTypes.InxClassProxyFactoryControl.
InxClassProxyFactoryRegistry | This is class nxrbTypes.InxClassProxyFactoryRegistry.
InxClassStub | This is class nxrbTypes.InxClassStub.
InxClassStubFactory | This is class nxrbTypes.InxClassStubFactory.
InxClassStubFactoryControl | This is class nxrbTypes.InxClassStubFactoryControl.
InxClassStubFactoryRegistry | This is class nxrbTypes.InxClassStubFactoryRegistry.
InxFactoryControl | This is class nxrbTypes.InxFactoryControl.
InxInterfaceFilerInit | This is class nxrbTypes.InxInterfaceFilerInit.
InxInterfaceProxy | This is class nxrbTypes.InxInterfaceProxy.
InxInterfaceProxyFactory | This is class nxrbTypes.InxInterfaceProxyFactory.
InxInterfaceProxyFactoryControl | This is class nxrbTypes.InxInterfaceProxyFactoryControl.
InxInterfaceProxyFactoryRegistry | This is class nxrbTypes.InxInterfaceProxyFactoryRegistry.
InxInterfaceReader | This is class nxrbTypes.InxInterfaceReader.
InxInterfaceStub | This is class nxrbTypes.InxInterfaceStub.
InxInterfaceStubFactory | This is class nxrbTypes.InxInterfaceStubFactory.
InxInterfaceStubFactoryControl | This is class nxrbTypes.InxInterfaceStubFactoryControl.
InxInterfaceStubFactoryRegistry | This is class nxrbTypes.InxInterfaceStubFactoryRegistry.
InxInterfaceWriter | This is class nxrbTypes.InxInterfaceWriter.
InxReader | This is class nxrbTypes.InxReader.
InxRemoteableClass | This is class nxrbTypes.InxRemoteableClass.
InxRoutingPath | This is class nxrbTypes.InxRoutingPath.
InxSingeltonClassFactory | This is class nxrbTypes.InxSingeltonClassFactory.
InxWriter | This is class nxrbTypes.InxWriter.
Links
nxrbTypes Namespace, Interfaces, Legend


InxCallContext Interface

InxCallContext Interface
InxCallContext Methods InxCallContext Properties InxCallContext Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxCallContextnxrbTypes_InxCallContext
Syntax
Delphi
InxCallContext = interface(InxRoutingPath);
File

nxrbTypes

Description

This is class nxrbTypes.InxCallContext.

Group

Interfaces

Links
InxCallContext Methods, InxCallContext Properties, InxCallContext Members, nxrbTypes, Interfaces


InxCallContext Members

InxCallContext Members
InxCallContext Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxCallContext.

Interface

InxCallContext Interface

Public Methods
Name | Description
BeginCall | This is BeginCall, a member of class InxCallContext.
EndCall | This is EndCall, a member of class InxCallContext.
GetInCall | This is GetInCall, a member of class InxCallContext.
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
GetThreadID | This is GetThreadID, a member of class InxCallContext.
IsSameCall | This is IsSameCall, a member of class InxCallContext.
SaveToWriter | This is SaveToWriter, a member of class InxCallContext.
Public Properties
Name | Description
InCall | This is InCall, a member of class InxCallContext.
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
ThreadID | This is ThreadID, a member of class InxCallContext.
Links
InxCallContext Interface, Legend, Public Methods, Public Properties


InxCallContext Methods

InxCallContext Methods
InxCallContext Interface Legend Public Methods Send Feedback

The methods of the InxCallContext class are listed here.

Interface

InxCallContext Interface

Public Methods
Name | Description
BeginCall | This is BeginCall, a member of class InxCallContext.
EndCall | This is EndCall, a member of class InxCallContext.
GetInCall | This is GetInCall, a member of class InxCallContext.
GetThreadID | This is GetThreadID, a member of class InxCallContext.
IsSameCall | This is IsSameCall, a member of class InxCallContext.
SaveToWriter | This is SaveToWriter, a member of class InxCallContext.
Links
InxCallContext Interface, Legend, Public Methods


InxCallContext.BeginCall Method

InxCallContext.BeginCall Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
procedure BeginCall;
Description

This is BeginCall, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext.EndCall Method

InxCallContext.EndCall Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
procedure EndCall;
Description

This is EndCall, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext.GetInCall Method

InxCallContext.GetInCall Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
function GetInCall: Boolean;
Description

This is GetInCall, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext.GetThreadID Method

InxCallContext.GetThreadID Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
function GetThreadID: Cardinal;
Description

This is GetThreadID, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext.IsSameCall Method

InxCallContext.IsSameCall Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
function IsSameCall(const aContext: InxCallContext): HRESULT;
Description

This is IsSameCall, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext.SaveToWriter Method

InxCallContext.SaveToWriter Method
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Methods Send Feedback
Syntax
Delphi
function SaveToWriter(aWriter: InxWriter): HRESULT;
Description

This is SaveToWriter, a member of class InxCallContext.

Group

InxCallContext Methods

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Methods


InxCallContext Properties

InxCallContext Properties
InxCallContext Interface Legend Public Properties Send Feedback

The properties of the InxCallContext class are listed here.

Interface

InxCallContext Interface

Public Properties
Name | Description
InCall | This is InCall, a member of class InxCallContext.
ThreadID | This is ThreadID, a member of class InxCallContext.
Links
InxCallContext Interface, Legend, Public Properties


InxCallContext.InCall Property

InxCallContext.InCall Property
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Properties Send Feedback
Syntax
Delphi
property InCall: Boolean;
Description

This is InCall, a member of class InxCallContext.

Group

InxCallContext Properties

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Properties


InxCallContext.ThreadID Property

InxCallContext.ThreadID Property
InxCallContext Interface InxCallContext Members nxrbTypes Namespace InxCallContext Properties Send Feedback
Syntax
Delphi
property ThreadID: Cardinal;
Description

This is ThreadID, a member of class InxCallContext.

Group

InxCallContext Properties

Links
InxCallContext Interface, InxCallContext Members, nxrbTypes Namespace, InxCallContext Properties


InxChannel Interface

InxChannel Interface
InxChannel Methods InxChannel Properties InxChannel Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxChannel
Syntax
Delphi
InxChannel = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxChannel.

Group

Interfaces

Links
InxChannel Methods, InxChannel Properties, InxChannel Members, nxrbTypes, Interfaces


InxChannel Members

InxChannel Members
InxChannel Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxChannel.

Interface

InxChannel Interface

Public Methods
Name | Description
GetChannelID | This is GetChannelID, a member of class InxChannel.
GetConnected | This is GetConnected, a member of class InxChannel.
GetServerID | This is GetServerID, a member of class InxChannel.
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
InxChannel Interface, Legend, Public Methods, Public Properties


InxChannel Methods

InxChannel Methods
InxChannel Interface Legend Public Methods Send Feedback

The methods of the InxChannel class are listed here.

Interface

InxChannel Interface

Public Methods
Name | Description
GetChannelID | This is GetChannelID, a member of class InxChannel.
GetConnected | This is GetConnected, a member of class InxChannel.
GetServerID | This is GetServerID, a member of class InxChannel.
Links
InxChannel Interface, Legend, Public Methods


InxChannel.GetChannelID Method

InxChannel.GetChannelID Method
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Methods Send Feedback
Syntax
Delphi
function GetChannelID: TnxGuid;
Description

This is GetChannelID, a member of class InxChannel.

Group

InxChannel Methods

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Methods


InxChannel.GetConnected Method

InxChannel.GetConnected Method
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Methods Send Feedback
Syntax
Delphi
function GetConnected: Boolean;
Description

This is GetConnected, a member of class InxChannel.

Group

InxChannel Methods

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Methods


InxChannel.GetServerID Method

InxChannel.GetServerID Method
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Methods Send Feedback
Syntax
Delphi
function GetServerID: TnxGuid;
Description

This is GetServerID, a member of class InxChannel.

Group

InxChannel Methods

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Methods


InxChannel Properties

InxChannel Properties
InxChannel Interface Legend Public Properties Send Feedback

The properties of the InxChannel class are listed here.

Interface

InxChannel Interface

Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
InxChannel Interface, Legend, Public Properties


InxChannel.ChannelID Property

InxChannel.ChannelID Property
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Properties Send Feedback
Syntax
Delphi
property ChannelID: TnxGuid;
Description

This is ChannelID, a member of class InxChannel.

Group

InxChannel Properties

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Properties


InxChannel.Connected Property

InxChannel.Connected Property
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Properties Send Feedback
Syntax
Delphi
property Connected: Boolean;
Description

This is Connected, a member of class InxChannel.

Group

InxChannel Properties

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Properties


InxChannel.ServerID Property

InxChannel.ServerID Property
InxChannel Interface InxChannel Members nxrbTypes Namespace InxChannel Properties Send Feedback
Syntax
Delphi
property ServerID: TnxGuid;
Description

This is ServerID, a member of class InxChannel.

Group

InxChannel Properties

Links
InxChannel Interface, InxChannel Members, nxrbTypes Namespace, InxChannel Properties


InxChannelEntrance Interface

InxChannelEntrance Interface
InxChannelEntrance Methods InxChannelEntrance Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxChannelEntrancenxrbTypes_InxChannelEntrance
Syntax
Delphi
InxChannelEntrance = interface(InxChannel);
File

nxrbTypes

Description

This is class nxrbTypes.InxChannelEntrance.

Group

Interfaces

Links
InxChannelEntrance Methods, InxChannelEntrance Members, nxrbTypes, Interfaces


InxChannelEntrance Members

InxChannelEntrance Members
InxChannelEntrance Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxChannelEntrance.

Interface

InxChannelEntrance Interface

Public Methods
Name | Description
GetChannelID | This is GetChannelID, a member of class InxChannel.
GetConnected | This is GetConnected, a member of class InxChannel.
GetServerID | This is GetServerID, a member of class InxChannel.
GetWriter | This is GetWriter, a member of class InxChannelEntrance.
Process | This is Process, a member of class InxChannelEntrance.
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
InxChannelEntrance Interface, Legend, Public Methods, Public Properties


InxChannelEntrance Methods

InxChannelEntrance Methods
InxChannelEntrance Interface Legend Public Methods Send Feedback

The methods of the InxChannelEntrance class are listed here.

Interface

InxChannelEntrance Interface

Public Methods
Name | Description
GetWriter | This is GetWriter, a member of class InxChannelEntrance.
Process | This is Process, a member of class InxChannelEntrance.
Links
InxChannelEntrance Interface, Legend, Public Methods


InxChannelEntrance.GetWriter Method

InxChannelEntrance.GetWriter Method
InxChannelEntrance Interface InxChannelEntrance Members nxrbTypes Namespace InxChannelEntrance Methods Send Feedback
Syntax
Delphi
function GetWriter(out aWriter: InxWriter): HRESULT;
Description

This is GetWriter, a member of class InxChannelEntrance.

Group

InxChannelEntrance Methods

Links
InxChannelEntrance Interface, InxChannelEntrance Members, nxrbTypes Namespace, InxChannelEntrance Methods


InxChannelEntrance.Process Method

InxChannelEntrance.Process Method
InxChannelEntrance Interface InxChannelEntrance Members nxrbTypes Namespace InxChannelEntrance Methods Send Feedback
Syntax
Delphi
function Process(const aWriter: InxWriter; out aReader: InxReader): HRESULT;
Description

This is Process, a member of class InxChannelEntrance.

Group

InxChannelEntrance Methods

Links
InxChannelEntrance Interface, InxChannelEntrance Members, nxrbTypes Namespace, InxChannelEntrance Methods


InxChannelExit Interface

InxChannelExit Interface
InxChannelExit Methods InxChannelExit Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxChannelExitnxrbTypes_InxChannelExit
Syntax
Delphi
InxChannelExit = interface(InxChannel);
File

nxrbTypes

Description

This is class nxrbTypes.InxChannelExit.

Group

Interfaces

Links
InxChannelExit Methods, InxChannelExit Members, nxrbTypes, Interfaces


InxChannelExit Members

InxChannelExit Members
InxChannelExit Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxChannelExit.

Interface

InxChannelExit Interface

Public Methods
Name | Description
ForceDisconnect | This is ForceDisconnect, a member of class InxChannelExit.
GetChannelID | This is GetChannelID, a member of class InxChannel.
GetConnected | This is GetConnected, a member of class InxChannel.
GetServerID | This is GetServerID, a member of class InxChannel.
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
InxChannelExit Interface, Legend, Public Methods, Public Properties


InxChannelExit Methods

InxChannelExit Methods
InxChannelExit Interface Legend Public Methods Send Feedback

The methods of the InxChannelExit class are listed here.

Interface

InxChannelExit Interface

Public Methods
Name | Description
ForceDisconnect | This is ForceDisconnect, a member of class InxChannelExit.
Links
InxChannelExit Interface, Legend, Public Methods


InxChannelExit.ForceDisconnect Method

InxChannelExit.ForceDisconnect Method
InxChannelExit Interface InxChannelExit Members nxrbTypes Namespace InxChannelExit Methods Send Feedback
Syntax
Delphi
function ForceDisconnect: HRESULT;
Description

This is ForceDisconnect, a member of class InxChannelExit.

Group

InxChannelExit Methods

Links
InxChannelExit Interface, InxChannelExit Members, nxrbTypes Namespace, InxChannelExit Methods


InxChannelSink Interface

InxChannelSink Interface
InxChannelSink Methods InxChannelSink Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxChannelSinknxrbTypes_InxChannelSink
Syntax
Delphi
InxChannelSink = interface(InxRoutingPath);
File

nxrbTypes

Description

This is class nxrbTypes.InxChannelSink.

Group

Interfaces

Links
InxChannelSink Methods, InxChannelSink Members, nxrbTypes, Interfaces


InxChannelSink Members

InxChannelSink Members
InxChannelSink Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxChannelSink.

Interface

InxChannelSink Interface

Public Methods
Name | Description
Connected | This is Connected, a member of class InxChannelSink.
Disconnected | This is Disconnected, a member of class InxChannelSink.
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
Process | This is Process, a member of class InxChannelSink.
Public Properties
Name | Description
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
InxChannelSink Interface, Legend, Public Methods, Public Properties


InxChannelSink Methods

InxChannelSink Methods
InxChannelSink Interface Legend Public Methods Send Feedback

The methods of the InxChannelSink class are listed here.

Interface

InxChannelSink Interface

Public Methods
Name | Description
Connected | This is Connected, a member of class InxChannelSink.
Disconnected | This is Disconnected, a member of class InxChannelSink.
Process | This is Process, a member of class InxChannelSink.
Links
InxChannelSink Interface, Legend, Public Methods


InxChannelSink.Connected Method

InxChannelSink.Connected Method
InxChannelSink Interface InxChannelSink Members nxrbTypes Namespace InxChannelSink Methods Send Feedback
Syntax
Delphi
procedure Connected(const aChannel: InxChannelExit);
Description

This is Connected, a member of class InxChannelSink.

Group

InxChannelSink Methods

Links
InxChannelSink Interface, InxChannelSink Members, nxrbTypes Namespace, InxChannelSink Methods


InxChannelSink.Disconnected Method

InxChannelSink.Disconnected Method
InxChannelSink Interface InxChannelSink Members nxrbTypes Namespace InxChannelSink Methods Send Feedback
Syntax
Delphi
procedure Disconnected(const aChannel: InxChannelExit);
Description

This is Disconnected, a member of class InxChannelSink.

Group

InxChannelSink Methods

Links
InxChannelSink Interface, InxChannelSink Members, nxrbTypes Namespace, InxChannelSink Methods


InxChannelSink.Process Method

InxChannelSink.Process Method
InxChannelSink Interface InxChannelSink Members nxrbTypes Namespace InxChannelSink Methods Send Feedback
Syntax
Delphi
function Process(const aChannel: InxChannelExit; const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

This is Process, a member of class InxChannelSink.

Group

InxChannelSink Methods

Links
InxChannelSink Interface, InxChannelSink Members, nxrbTypes Namespace, InxChannelSink Methods


InxClass Interface

InxClass Interface
InxClass Methods InxClass Properties InxClass Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClass
Syntax
Delphi
InxClass = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClass.

Group

Interfaces

Links
InxClass Methods, InxClass Properties, InxClass Members, nxrbTypes, Interfaces


InxClass Members

InxClass Members
InxClass Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxClass.

Interface

InxClass Interface

Public Methods
Name | Description
GetClassID | This is GetClassID, a member of class InxClass.
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Links
InxClass Interface, Legend, Public Methods, Public Properties


InxClass Methods

InxClass Methods
InxClass Interface Legend Public Methods Send Feedback

The methods of the InxClass class are listed here.

Interface

InxClass Interface

Public Methods
Name | Description
GetClassID | This is GetClassID, a member of class InxClass.
Links
InxClass Interface, Legend, Public Methods


InxClass.GetClassID Method

InxClass.GetClassID Method
InxClass Interface InxClass Members nxrbTypes Namespace InxClass Methods Send Feedback
Syntax
Delphi
function GetClassID: TnxGuid;
Description

This is GetClassID, a member of class InxClass.

Group

InxClass Methods

Links
InxClass Interface, InxClass Members, nxrbTypes Namespace, InxClass Methods


InxClass Properties

InxClass Properties
InxClass Interface Legend Public Properties Send Feedback

The properties of the InxClass class are listed here.

Interface

InxClass Interface

Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Links
InxClass Interface, Legend, Public Properties


InxClass.ClassID Property

InxClass.ClassID Property
InxClass Interface InxClass Members nxrbTypes Namespace InxClass Properties Send Feedback
Syntax
Delphi
property ClassID: TnxGuid;
Description

This is ClassID, a member of class InxClass.

Group

InxClass Properties

Links
InxClass Interface, InxClass Members, nxrbTypes Namespace, InxClass Properties


InxClassFactory Interface

InxClassFactory Interface
InxClassFactory Methods InxClassFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassFactory
Syntax
Delphi
InxClassFactory = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassFactory.

Group

Interfaces

Links
InxClassFactory Methods, InxClassFactory Members, nxrbTypes, Interfaces


InxClassFactory Members

InxClassFactory Members
InxClassFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassFactory.

Interface

InxClassFactory Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassFactory.
Links
InxClassFactory Interface, Legend, Public Methods


InxClassFactory Methods

InxClassFactory Methods
InxClassFactory Interface Legend Public Methods Send Feedback

The methods of the InxClassFactory class are listed here.

Interface

InxClassFactory Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassFactory.
Links
InxClassFactory Interface, Legend, Public Methods


InxClassFactory.CreateInstance Method

InxClassFactory.CreateInstance Method
InxClassFactory Interface InxClassFactory Members nxrbTypes Namespace InxClassFactory Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT;
Description

This is CreateInstance, a member of class InxClassFactory.

Group

InxClassFactory Methods

Links
InxClassFactory Interface, InxClassFactory Members, nxrbTypes Namespace, InxClassFactory Methods


InxClassFactoryControl Interface

InxClassFactoryControl Interface
InxClassFactoryControl Methods InxClassFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassFactoryControlnxrbTypes_InxClassFactoryControl
Syntax
Delphi
InxClassFactoryControl = interface(InxFactoryControl);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassFactoryControl.

Group

Interfaces

Links
InxClassFactoryControl Methods, InxClassFactoryControl Members, nxrbTypes, Interfaces


InxClassFactoryControl Members

InxClassFactoryControl Members
InxClassFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassFactoryControl.

Interface

InxClassFactoryControl Interface

Public Methods
Name | Description
ReleaseSingelton | This is ReleaseSingelton, a member of class InxClassFactoryControl.
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxClassFactoryControl Interface, Legend, Public Methods


InxClassFactoryControl Methods

InxClassFactoryControl Methods
InxClassFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxClassFactoryControl class are listed here.

Interface

InxClassFactoryControl Interface

Public Methods
Name | Description
ReleaseSingelton | This is ReleaseSingelton, a member of class InxClassFactoryControl.
Links
InxClassFactoryControl Interface, Legend, Public Methods


InxClassFactoryControl.ReleaseSingelton Method

InxClassFactoryControl.ReleaseSingelton Method
InxClassFactoryControl Interface InxClassFactoryControl Members nxrbTypes Namespace InxClassFactoryControl Methods Send Feedback
Syntax
Delphi
function ReleaseSingelton: HRESULT;
Description

This is ReleaseSingelton, a member of class InxClassFactoryControl.

Group

InxClassFactoryControl Methods

Links
InxClassFactoryControl Interface, InxClassFactoryControl Members, nxrbTypes Namespace, InxClassFactoryControl Methods


InxClassFactoryRegistry Interface

InxClassFactoryRegistry Interface
InxClassFactoryRegistry Methods InxClassFactoryRegistry Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassFactoryRegistrynxrbTypes_InxClassFactoryRegistry
Syntax
Delphi
InxClassFactoryRegistry = interface(InxClassActivator);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassFactoryRegistry.

Group

Interfaces

Links
InxClassFactoryRegistry Methods, InxClassFactoryRegistry Members, nxrbTypes, Interfaces


InxClassFactoryRegistry Members

InxClassFactoryRegistry Members
InxClassFactoryRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassFactoryRegistry.

Interface

InxClassFactoryRegistry Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassActivator.
RegisterFactory | This is RegisterFactory, a member of class InxClassFactoryRegistry.
ReleaseSingeltons | This is ReleaseSingeltons, a member of class InxClassFactoryRegistry.
Links
InxClassFactoryRegistry Interface, Legend, Public Methods


InxClassFactoryRegistry Methods

InxClassFactoryRegistry Methods
InxClassFactoryRegistry Interface Legend Public Methods Send Feedback

The methods of the InxClassFactoryRegistry class are listed here.

Interface

InxClassFactoryRegistry Interface

Public Methods
Name | Description
RegisterFactory | This is RegisterFactory, a member of class InxClassFactoryRegistry.
ReleaseSingeltons | This is ReleaseSingeltons, a member of class InxClassFactoryRegistry.
Links
InxClassFactoryRegistry Interface, Legend, Public Methods


InxClassFactoryRegistry.RegisterFactory Method

InxClassFactoryRegistry.RegisterFactory Method
InxClassFactoryRegistry Interface InxClassFactoryRegistry Members nxrbTypes Namespace InxClassFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassID: TnxGuid; const aFactory: InxClassFactory; out aControl: InxClassFactoryControl): HRESULT;
Description

This is RegisterFactory, a member of class InxClassFactoryRegistry.

Group

InxClassFactoryRegistry Methods

Links
InxClassFactoryRegistry Interface, InxClassFactoryRegistry Members, nxrbTypes Namespace, InxClassFactoryRegistry Methods


InxClassFactoryRegistry.ReleaseSingeltons Method

InxClassFactoryRegistry.ReleaseSingeltons Method
InxClassFactoryRegistry Interface InxClassFactoryRegistry Members nxrbTypes Namespace InxClassFactoryRegistry Methods Send Feedback
Syntax
Delphi
function ReleaseSingeltons: HRESULT;
Description

This is ReleaseSingeltons, a member of class InxClassFactoryRegistry.

Group

InxClassFactoryRegistry Methods

Links
InxClassFactoryRegistry Interface, InxClassFactoryRegistry Members, nxrbTypes Namespace, InxClassFactoryRegistry Methods


InxClassProxy Interface

InxClassProxy Interface
InxClassProxy Methods InxClassProxy Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassProxynxrbTypes_InxClassProxy
Syntax
Delphi
InxClassProxy = interface(InxRoutingPath);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassProxy.

Group

Interfaces

Links
InxClassProxy Methods, InxClassProxy Members, nxrbTypes, Interfaces


InxClassProxy Members

InxClassProxy Members
InxClassProxy Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxClassProxy.

Interface

InxClassProxy Interface

Public Methods
Name | Description
AddChannel | This is AddChannel, a member of class InxClassProxy.
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
GetWriter | This is GetWriter, a member of class InxClassProxy.
Process | This is Process, a member of class InxClassProxy.
Public Properties
Name | Description
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
InxClassProxy Interface, Legend, Public Methods, Public Properties


InxClassProxy Methods

InxClassProxy Methods
InxClassProxy Interface Legend Public Methods Send Feedback

The methods of the InxClassProxy class are listed here.

Interface

InxClassProxy Interface

Public Methods
Name | Description
AddChannel | This is AddChannel, a member of class InxClassProxy.
GetWriter | This is GetWriter, a member of class InxClassProxy.
Process | This is Process, a member of class InxClassProxy.
Links
InxClassProxy Interface, Legend, Public Methods


InxClassProxy.AddChannel Method

InxClassProxy.AddChannel Method
InxClassProxy Interface InxClassProxy Members nxrbTypes Namespace InxClassProxy Methods Send Feedback
Syntax
Delphi
function AddChannel(const aChannel: InxChannelEntrance; const aPath: TnxRoutingPath): HRESULT;
Description

This is AddChannel, a member of class InxClassProxy.

Group

InxClassProxy Methods

Links
InxClassProxy Interface, InxClassProxy Members, nxrbTypes Namespace, InxClassProxy Methods


InxClassProxy.GetWriter Method

InxClassProxy.GetWriter Method
InxClassProxy Interface InxClassProxy Members nxrbTypes Namespace InxClassProxy Methods Send Feedback
Syntax
Delphi
function GetWriter(out aWriter: InxWriter): HRESULT;
Description

This is GetWriter, a member of class InxClassProxy.

Group

InxClassProxy Methods

Links
InxClassProxy Interface, InxClassProxy Members, nxrbTypes Namespace, InxClassProxy Methods


InxClassProxy.Process Method

InxClassProxy.Process Method
InxClassProxy Interface InxClassProxy Members nxrbTypes Namespace InxClassProxy Methods Send Feedback
Syntax
Delphi
function Process(const aWriter: InxWriter; out aReader: InxReader): HRESULT;
Description

This is Process, a member of class InxClassProxy.

Group

InxClassProxy Methods

Links
InxClassProxy Interface, InxClassProxy Members, nxrbTypes Namespace, InxClassProxy Methods


InxClassProxyFactory Interface

InxClassProxyFactory Interface
InxClassProxyFactory Methods InxClassProxyFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassProxyFactory
Syntax
Delphi
InxClassProxyFactory = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassProxyFactory.

Group

Interfaces

Links
InxClassProxyFactory Methods, InxClassProxyFactory Members, nxrbTypes, Interfaces


InxClassProxyFactory Members

InxClassProxyFactory Members
InxClassProxyFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassProxyFactory.

Interface

InxClassProxyFactory Interface

Public Methods
Name | Description
CreateClassProxy | This is CreateClassProxy, a member of class InxClassProxyFactory.
Supports | This is Supports, a member of class InxClassProxyFactory.
Links
InxClassProxyFactory Interface, Legend, Public Methods


InxClassProxyFactory Methods

InxClassProxyFactory Methods
InxClassProxyFactory Interface Legend Public Methods Send Feedback

The methods of the InxClassProxyFactory class are listed here.

Interface

InxClassProxyFactory Interface

Public Methods
Name | Description
CreateClassProxy | This is CreateClassProxy, a member of class InxClassProxyFactory.
Supports | This is Supports, a member of class InxClassProxyFactory.
Links
InxClassProxyFactory Interface, Legend, Public Methods


InxClassProxyFactory.CreateClassProxy Method

InxClassProxyFactory.CreateClassProxy Method
InxClassProxyFactory Interface InxClassProxyFactory Members nxrbTypes Namespace InxClassProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateClassProxy(const aOuter: InxInterface; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aReader: InxReader; out aClassProxy: InxClassProxy): HRESULT;
Description

This is CreateClassProxy, a member of class InxClassProxyFactory.

Group

InxClassProxyFactory Methods

Links
InxClassProxyFactory Interface, InxClassProxyFactory Members, nxrbTypes Namespace, InxClassProxyFactory Methods


InxClassProxyFactory.Supports Method

InxClassProxyFactory.Supports Method
InxClassProxyFactory Interface InxClassProxyFactory Members nxrbTypes Namespace InxClassProxyFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid): HRESULT;
Description

This is Supports, a member of class InxClassProxyFactory.

Group

InxClassProxyFactory Methods

Links
InxClassProxyFactory Interface, InxClassProxyFactory Members, nxrbTypes Namespace, InxClassProxyFactory Methods


InxClassProxyFactoryControl Interface

InxClassProxyFactoryControl Interface
InxClassProxyFactoryControl Methods InxClassProxyFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassProxyFactoryControlnxrbTypes_InxClassProxyFactoryControl
Syntax
Delphi
InxClassProxyFactoryControl = interface(InxFactoryControl);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassProxyFactoryControl.

Group

Interfaces

Links
InxClassProxyFactoryControl Methods, InxClassProxyFactoryControl Members, nxrbTypes, Interfaces


InxClassProxyFactoryControl Members

InxClassProxyFactoryControl Members
InxClassProxyFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassProxyFactoryControl.

Interface

InxClassProxyFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxClassProxyFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxClassProxyFactoryControl.
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxClassProxyFactoryControl Interface, Legend, Public Methods


InxClassProxyFactoryControl Methods

InxClassProxyFactoryControl Methods
InxClassProxyFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxClassProxyFactoryControl class are listed here.

Interface

InxClassProxyFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxClassProxyFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxClassProxyFactoryControl.
Links
InxClassProxyFactoryControl Interface, Legend, Public Methods


InxClassProxyFactoryControl.RegisterForClass Method

InxClassProxyFactoryControl.RegisterForClass Method
InxClassProxyFactoryControl Interface InxClassProxyFactoryControl Members nxrbTypes Namespace InxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

This is RegisterForClass, a member of class InxClassProxyFactoryControl.

Group

InxClassProxyFactoryControl Methods

Links
InxClassProxyFactoryControl Interface, InxClassProxyFactoryControl Members, nxrbTypes Namespace, InxClassProxyFactoryControl Methods


InxClassProxyFactoryControl.RegisterGeneric Method

InxClassProxyFactoryControl.RegisterGeneric Method
InxClassProxyFactoryControl Interface InxClassProxyFactoryControl Members nxrbTypes Namespace InxClassProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Description

This is RegisterGeneric, a member of class InxClassProxyFactoryControl.

Group

InxClassProxyFactoryControl Methods

Links
InxClassProxyFactoryControl Interface, InxClassProxyFactoryControl Members, nxrbTypes Namespace, InxClassProxyFactoryControl Methods


InxClassProxyFactoryRegistry Interface

InxClassProxyFactoryRegistry Interface
InxClassProxyFactoryRegistry Methods InxClassProxyFactoryRegistry Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassProxyFactoryRegistry
Syntax
Delphi
InxClassProxyFactoryRegistry = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassProxyFactoryRegistry.

Group

Interfaces

Links
InxClassProxyFactoryRegistry Methods, InxClassProxyFactoryRegistry Members, nxrbTypes, Interfaces


InxClassProxyFactoryRegistry Members

InxClassProxyFactoryRegistry Members
InxClassProxyFactoryRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassProxyFactoryRegistry.

Interface

InxClassProxyFactoryRegistry Interface

Public Methods
Name | Description
CreateClassProxy | This is CreateClassProxy, a member of class InxClassProxyFactoryRegistry.
QueryClassProxys | This is QueryClassProxys, a member of class InxClassProxyFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxClassProxyFactoryRegistry.
Links
InxClassProxyFactoryRegistry Interface, Legend, Public Methods


InxClassProxyFactoryRegistry Methods

InxClassProxyFactoryRegistry Methods
InxClassProxyFactoryRegistry Interface Legend Public Methods Send Feedback

The methods of the InxClassProxyFactoryRegistry class are listed here.

Interface

InxClassProxyFactoryRegistry Interface

Public Methods
Name | Description
CreateClassProxy | This is CreateClassProxy, a member of class InxClassProxyFactoryRegistry.
QueryClassProxys | This is QueryClassProxys, a member of class InxClassProxyFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxClassProxyFactoryRegistry.
Links
InxClassProxyFactoryRegistry Interface, Legend, Public Methods


InxClassProxyFactoryRegistry.CreateClassProxy Method

InxClassProxyFactoryRegistry.CreateClassProxy Method
InxClassProxyFactoryRegistry Interface InxClassProxyFactoryRegistry Members nxrbTypes Namespace InxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateClassProxy(const aOuter: InxInterface; const aClassProxyID: TnxGuid; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aReader: InxReader; out aClassProxy: InxClassProxy): HRESULT;
Description

This is CreateClassProxy, a member of class InxClassProxyFactoryRegistry.

Group

InxClassProxyFactoryRegistry Methods

Links
InxClassProxyFactoryRegistry Interface, InxClassProxyFactoryRegistry Members, nxrbTypes Namespace, InxClassProxyFactoryRegistry Methods


InxClassProxyFactoryRegistry.QueryClassProxys Method

InxClassProxyFactoryRegistry.QueryClassProxys Method
InxClassProxyFactoryRegistry Interface InxClassProxyFactoryRegistry Members nxrbTypes Namespace InxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryClassProxys(const aClassID: TnxGuid; aClassProxyIDs: PnxGuid; aClassProxyIDCountMax: Integer; out aClassProxyIDCount: Integer): HRESULT;
Description

This is QueryClassProxys, a member of class InxClassProxyFactoryRegistry.

Group

InxClassProxyFactoryRegistry Methods

Links
InxClassProxyFactoryRegistry Interface, InxClassProxyFactoryRegistry Members, nxrbTypes Namespace, InxClassProxyFactoryRegistry Methods


InxClassProxyFactoryRegistry.RegisterFactory Method

InxClassProxyFactoryRegistry.RegisterFactory Method
InxClassProxyFactoryRegistry Interface InxClassProxyFactoryRegistry Members nxrbTypes Namespace InxClassProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassProxyID: TnxGuid; const aFactory: InxClassProxyFactory; out aControl: InxClassProxyFactoryControl): HRESULT;
Description

This is RegisterFactory, a member of class InxClassProxyFactoryRegistry.

Group

InxClassProxyFactoryRegistry Methods

Links
InxClassProxyFactoryRegistry Interface, InxClassProxyFactoryRegistry Members, nxrbTypes Namespace, InxClassProxyFactoryRegistry Methods


InxClassStub Interface

InxClassStub Interface
InxClassStub Methods InxClassStub Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassStubnxrbTypes_InxClassStubnxrbTypes_InxClassStub
Syntax
Delphi
InxClassStub = interface(InxChannelSink);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassStub.

Group

Interfaces

Links
InxClassStub Methods, InxClassStub Members, nxrbTypes, Interfaces


InxClassStub Members

InxClassStub Members
InxClassStub Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxClassStub.

Interface

InxClassStub Interface

Public Methods
Name | Description
Connected | This is Connected, a member of class InxChannelSink.
DisconnectAllChannels | This is DisconnectAllChannels, a member of class InxClassStub.
Disconnected | This is Disconnected, a member of class InxChannelSink.
DisconnectObject | This is DisconnectObject, a member of class InxClassStub.
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
Process | This is Process, a member of class InxChannelSink.
QueryContainedInterface | This is QueryContainedInterface, a member of class InxClassStub.
WriteClassProxyInfo | This is WriteClassProxyInfo, a member of class InxClassStub.
Public Properties
Name | Description
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
InxClassStub Interface, Legend, Public Methods, Public Properties


InxClassStub Methods

InxClassStub Methods
InxClassStub Interface Legend Public Methods Send Feedback

The methods of the InxClassStub class are listed here.

Interface

InxClassStub Interface

Public Methods
Name | Description
DisconnectAllChannels | This is DisconnectAllChannels, a member of class InxClassStub.
DisconnectObject | This is DisconnectObject, a member of class InxClassStub.
QueryContainedInterface | This is QueryContainedInterface, a member of class InxClassStub.
WriteClassProxyInfo | This is WriteClassProxyInfo, a member of class InxClassStub.
Links
InxClassStub Interface, Legend, Public Methods


InxClassStub.DisconnectAllChannels Method

InxClassStub.DisconnectAllChannels Method
InxClassStub Interface InxClassStub Members nxrbTypes Namespace InxClassStub Methods Send Feedback
Syntax
Delphi
function DisconnectAllChannels: HRESULT;
Description

This is DisconnectAllChannels, a member of class InxClassStub.

Group

InxClassStub Methods

Links
InxClassStub Interface, InxClassStub Members, nxrbTypes Namespace, InxClassStub Methods


InxClassStub.DisconnectObject Method

InxClassStub.DisconnectObject Method
InxClassStub Interface InxClassStub Members nxrbTypes Namespace InxClassStub Methods Send Feedback
Syntax
Delphi
function DisconnectObject: HRESULT;
Description

This is DisconnectObject, a member of class InxClassStub.

Group

InxClassStub Methods

Links
InxClassStub Interface, InxClassStub Members, nxrbTypes Namespace, InxClassStub Methods


InxClassStub.QueryContainedInterface Method

InxClassStub.QueryContainedInterface Method
InxClassStub Interface InxClassStub Members nxrbTypes Namespace InxClassStub Methods Send Feedback
Syntax
Delphi
function QueryContainedInterface(const IID: TGUID; out Obj): HResult; stdcall;
Description

This is QueryContainedInterface, a member of class InxClassStub.

Group

InxClassStub Methods

Links
InxClassStub Interface, InxClassStub Members, nxrbTypes Namespace, InxClassStub Methods


InxClassStub.WriteClassProxyInfo Method

InxClassStub.WriteClassProxyInfo Method
InxClassStub Interface InxClassStub Members nxrbTypes Namespace InxClassStub Methods Send Feedback
Syntax
Delphi
function WriteClassProxyInfo(const aWriter: InxWriter): HRESULT;
Description

This is WriteClassProxyInfo, a member of class InxClassStub.

Group

InxClassStub Methods

Links
InxClassStub Interface, InxClassStub Members, nxrbTypes Namespace, InxClassStub Methods


InxClassStubFactory Interface

InxClassStubFactory Interface
InxClassStubFactory Methods InxClassStubFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassStubFactory
Syntax
Delphi
InxClassStubFactory = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassStubFactory.

Group

Interfaces

Links
InxClassStubFactory Methods, InxClassStubFactory Members, nxrbTypes, Interfaces


InxClassStubFactory Members

InxClassStubFactory Members
InxClassStubFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassStubFactory.

Interface

InxClassStubFactory Interface

Public Methods
Name | Description
CreateClassStub | This is CreateClassStub, a member of class InxClassStubFactory.
FindInstance | This is the overview for the FindInstance method overload.
Supports | This is Supports, a member of class InxClassStubFactory.
Links
InxClassStubFactory Interface, Legend, Public Methods


InxClassStubFactory Methods

InxClassStubFactory Methods
InxClassStubFactory Interface Legend Public Methods Send Feedback

The methods of the InxClassStubFactory class are listed here.

Interface

InxClassStubFactory Interface

Public Methods
Name | Description
CreateClassStub | This is CreateClassStub, a member of class InxClassStubFactory.
FindInstance | This is the overview for the FindInstance method overload.
Supports | This is Supports, a member of class InxClassStubFactory.
Links
InxClassStubFactory Interface, Legend, Public Methods


InxClassStubFactory.CreateClassStub Method

InxClassStubFactory.CreateClassStub Method
InxClassStubFactory Interface InxClassStubFactory Members nxrbTypes Namespace InxClassStubFactory Methods Send Feedback
Syntax
Delphi
function CreateClassStub(const aClassID: TnxGuid; const aInterface: InxInterface; out aClassStub: InxClassStub): HRESULT;
Description

This is CreateClassStub, a member of class InxClassStubFactory.

Group

InxClassStubFactory Methods

Links
InxClassStubFactory Interface, InxClassStubFactory Members, nxrbTypes Namespace, InxClassStubFactory Methods


FindInstance Method

FindInstance Method
InxClassStubFactory Methods Send Feedback

This is the overview for the FindInstance method overload.

Overload List
Name | Description
InxClassStubFactory.FindInstance (InxInterface, InxClassStub) | This is FindInstance, a member of class InxClassStubFactory.
InxClassStubFactory.FindInstance (TnxGuid, InxClassStub) | This is FindInstance, a member of class InxClassStubFactory.
Group

InxClassStubFactory Methods

Links
InxClassStubFactory Methods


InxClassStubFactory.FindInstance Method (InxInterface, InxClassStub)

InxClassStubFactory.FindInstance Method (InxInterface, InxClassStub)
InxClassStubFactory Interface InxClassStubFactory Members nxrbTypes Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstance: InxInterface; out aClassStub: InxClassStub): HRESULT; overload;
Description

This is FindInstance, a member of class InxClassStubFactory.

Group

FindInstance Method

Links
InxClassStubFactory Interface, InxClassStubFactory Members, nxrbTypes Namespace, FindInstance Method


InxClassStubFactory.FindInstance Method (TnxGuid, InxClassStub)

InxClassStubFactory.FindInstance Method (TnxGuid, InxClassStub)
InxClassStubFactory Interface InxClassStubFactory Members nxrbTypes Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstanceID: TnxGuid; out aClassStub: InxClassStub): HRESULT; overload;
Description

This is FindInstance, a member of class InxClassStubFactory.

Group

FindInstance Method

Links
InxClassStubFactory Interface, InxClassStubFactory Members, nxrbTypes Namespace, FindInstance Method


InxClassStubFactory.Supports Method

InxClassStubFactory.Supports Method
InxClassStubFactory Interface InxClassStubFactory Members nxrbTypes Namespace InxClassStubFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid): HRESULT;
Description

This is Supports, a member of class InxClassStubFactory.

Group

InxClassStubFactory Methods

Links
InxClassStubFactory Interface, InxClassStubFactory Members, nxrbTypes Namespace, InxClassStubFactory Methods


InxClassStubFactoryControl Interface

InxClassStubFactoryControl Interface
InxClassStubFactoryControl Methods InxClassStubFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassStubFactoryControlnxrbTypes_InxClassStubFactoryControl
Syntax
Delphi
InxClassStubFactoryControl = interface(InxFactoryControl);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassStubFactoryControl.

Group

Interfaces

Links
InxClassStubFactoryControl Methods, InxClassStubFactoryControl Members, nxrbTypes, Interfaces


InxClassStubFactoryControl Members

InxClassStubFactoryControl Members
InxClassStubFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassStubFactoryControl.

Interface

InxClassStubFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxClassStubFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxClassStubFactoryControl.
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxClassStubFactoryControl Interface, Legend, Public Methods


InxClassStubFactoryControl Methods

InxClassStubFactoryControl Methods
InxClassStubFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxClassStubFactoryControl class are listed here.

Interface

InxClassStubFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxClassStubFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxClassStubFactoryControl.
Links
InxClassStubFactoryControl Interface, Legend, Public Methods


InxClassStubFactoryControl.RegisterForClass Method

InxClassStubFactoryControl.RegisterForClass Method
InxClassStubFactoryControl Interface InxClassStubFactoryControl Members nxrbTypes Namespace InxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

This is RegisterForClass, a member of class InxClassStubFactoryControl.

Group

InxClassStubFactoryControl Methods

Links
InxClassStubFactoryControl Interface, InxClassStubFactoryControl Members, nxrbTypes Namespace, InxClassStubFactoryControl Methods


InxClassStubFactoryControl.RegisterGeneric Method

InxClassStubFactoryControl.RegisterGeneric Method
InxClassStubFactoryControl Interface InxClassStubFactoryControl Members nxrbTypes Namespace InxClassStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Description

This is RegisterGeneric, a member of class InxClassStubFactoryControl.

Group

InxClassStubFactoryControl Methods

Links
InxClassStubFactoryControl Interface, InxClassStubFactoryControl Members, nxrbTypes Namespace, InxClassStubFactoryControl Methods


InxClassStubFactoryRegistry Interface

InxClassStubFactoryRegistry Interface
InxClassStubFactoryRegistry Methods InxClassStubFactoryRegistry Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxClassStubFactoryRegistry
Syntax
Delphi
InxClassStubFactoryRegistry = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxClassStubFactoryRegistry.

Group

Interfaces

Links
InxClassStubFactoryRegistry Methods, InxClassStubFactoryRegistry Members, nxrbTypes, Interfaces


InxClassStubFactoryRegistry Members

InxClassStubFactoryRegistry Members
InxClassStubFactoryRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxClassStubFactoryRegistry.

Interface

InxClassStubFactoryRegistry Interface

Public Methods
Name | Description
CreateClassStub | This is CreateClassStub, a member of class InxClassStubFactoryRegistry.
FindInstance | This is the overview for the FindInstance method overload.
MatchToProxies | This is MatchToProxies, a member of class InxClassStubFactoryRegistry.
QueryClassStubs | This is QueryClassStubs, a member of class InxClassStubFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxClassStubFactoryRegistry.
Links
InxClassStubFactoryRegistry Interface, Legend, Public Methods


InxClassStubFactoryRegistry Methods

InxClassStubFactoryRegistry Methods
InxClassStubFactoryRegistry Interface Legend Public Methods Send Feedback

The methods of the InxClassStubFactoryRegistry class are listed here.

Interface

InxClassStubFactoryRegistry Interface

Public Methods
Name | Description
CreateClassStub | This is CreateClassStub, a member of class InxClassStubFactoryRegistry.
FindInstance | This is the overview for the FindInstance method overload.
MatchToProxies | This is MatchToProxies, a member of class InxClassStubFactoryRegistry.
QueryClassStubs | This is QueryClassStubs, a member of class InxClassStubFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxClassStubFactoryRegistry.
Links
InxClassStubFactoryRegistry Interface, Legend, Public Methods


InxClassStubFactoryRegistry.CreateClassStub Method

InxClassStubFactoryRegistry.CreateClassStub Method
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace InxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateClassStub(const aClassStubID: TnxGuid; const aClassID: TnxGuid; const aInterface: InxInterface; out aClassStub: InxClassStub): HRESULT;
Description

This is CreateClassStub, a member of class InxClassStubFactoryRegistry.

Group

InxClassStubFactoryRegistry Methods

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, InxClassStubFactoryRegistry Methods


FindInstance Method

FindInstance Method
InxClassStubFactoryRegistry Methods Send Feedback

This is the overview for the FindInstance method overload.

Overload List
Name | Description
InxClassStubFactoryRegistry.FindInstance (InxInterface, InxClassStub) | This is FindInstance, a member of class InxClassStubFactoryRegistry.
InxClassStubFactoryRegistry.FindInstance (TnxGuid, TnxGuid, InxClassStub) | This is FindInstance, a member of class InxClassStubFactoryRegistry.
Group

InxClassStubFactoryRegistry Methods

Links
InxClassStubFactoryRegistry Methods


InxClassStubFactoryRegistry.FindInstance Method (InxInterface, InxClassStub)

InxClassStubFactoryRegistry.FindInstance Method (InxInterface, InxClassStub)
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstance: InxInterface; out aClassStub: InxClassStub): HRESULT; overload;
Description

This is FindInstance, a member of class InxClassStubFactoryRegistry.

Group

FindInstance Method

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, FindInstance Method


InxClassStubFactoryRegistry.FindInstance Method (TnxGuid, TnxGuid, InxClassStub)

InxClassStubFactoryRegistry.FindInstance Method (TnxGuid, TnxGuid, InxClassStub)
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aClassStubID: TnxGuid; const aInstanceID: TnxGuid; out aClassStub: InxClassStub): HRESULT; overload;
Description

This is FindInstance, a member of class InxClassStubFactoryRegistry.

Group

FindInstance Method

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, FindInstance Method


InxClassStubFactoryRegistry.MatchToProxies Method

InxClassStubFactoryRegistry.MatchToProxies Method
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace InxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function MatchToProxies(const aClassID: TnxGuid; aClassProxyIDs: PnxGuid; aClassProxyIDCount: Integer; out aClassStubID: TnxGuid): HRESULT;
Description

This is MatchToProxies, a member of class InxClassStubFactoryRegistry.

Group

InxClassStubFactoryRegistry Methods

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, InxClassStubFactoryRegistry Methods


InxClassStubFactoryRegistry.QueryClassStubs Method

InxClassStubFactoryRegistry.QueryClassStubs Method
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace InxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryClassStubs(const aClassID: TnxGuid; aClassStubIDs: PnxGuid; aClassStubIDCountMax: Integer; out aClassStubIDCount: Integer): HRESULT;
Description

This is QueryClassStubs, a member of class InxClassStubFactoryRegistry.

Group

InxClassStubFactoryRegistry Methods

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, InxClassStubFactoryRegistry Methods


InxClassStubFactoryRegistry.RegisterFactory Method

InxClassStubFactoryRegistry.RegisterFactory Method
InxClassStubFactoryRegistry Interface InxClassStubFactoryRegistry Members nxrbTypes Namespace InxClassStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aClassStubID: TnxGuid; const aFactory: InxClassStubFactory; out aControl: InxClassStubFactoryControl): HRESULT;
Description

This is RegisterFactory, a member of class InxClassStubFactoryRegistry.

Group

InxClassStubFactoryRegistry Methods

Links
InxClassStubFactoryRegistry Interface, InxClassStubFactoryRegistry Members, nxrbTypes Namespace, InxClassStubFactoryRegistry Methods


InxFactoryControl Interface

InxFactoryControl Interface
InxFactoryControl Methods InxFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxFactoryControl
Syntax
Delphi
InxFactoryControl = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxFactoryControl.

Group

Interfaces

Links
InxFactoryControl Methods, InxFactoryControl Members, nxrbTypes, Interfaces


InxFactoryControl Members

InxFactoryControl Members
InxFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxFactoryControl.

Interface

InxFactoryControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxFactoryControl Interface, Legend, Public Methods


InxFactoryControl Methods

InxFactoryControl Methods
InxFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxFactoryControl class are listed here.

Interface

InxFactoryControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxFactoryControl Interface, Legend, Public Methods


InxFactoryControl.Unregister Method

InxFactoryControl.Unregister Method
InxFactoryControl Interface InxFactoryControl Members nxrbTypes Namespace InxFactoryControl Methods Send Feedback
Syntax
Delphi
function Unregister: HRESULT;
Description

This is Unregister, a member of class InxFactoryControl.

Group

InxFactoryControl Methods

Links
InxFactoryControl Interface, InxFactoryControl Members, nxrbTypes Namespace, InxFactoryControl Methods


InxInterfaceFilerInit Interface

InxInterfaceFilerInit Interface
InxInterfaceFilerInit Methods InxInterfaceFilerInit Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceFilerInit
Syntax
Delphi
InxInterfaceFilerInit = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceFilerInit.

Group

Interfaces

Links
InxInterfaceFilerInit Methods, InxInterfaceFilerInit Members, nxrbTypes, Interfaces


InxInterfaceFilerInit Members

InxInterfaceFilerInit Members
InxInterfaceFilerInit Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceFilerInit.

Interface

InxInterfaceFilerInit Interface

Public Methods
Name | Description
SetServerID | This is SetServerID, a member of class InxInterfaceFilerInit.
Links
InxInterfaceFilerInit Interface, Legend, Public Methods


InxInterfaceFilerInit Methods

InxInterfaceFilerInit Methods
InxInterfaceFilerInit Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceFilerInit class are listed here.

Interface

InxInterfaceFilerInit Interface

Public Methods
Name | Description
SetServerID | This is SetServerID, a member of class InxInterfaceFilerInit.
Links
InxInterfaceFilerInit Interface, Legend, Public Methods


InxInterfaceFilerInit.SetServerID Method

InxInterfaceFilerInit.SetServerID Method
InxInterfaceFilerInit Interface InxInterfaceFilerInit Members nxrbTypes Namespace InxInterfaceFilerInit Methods Send Feedback
Syntax
Delphi
procedure SetServerID(aServerID: PnxGuid);
Description

This is SetServerID, a member of class InxInterfaceFilerInit.

Group

InxInterfaceFilerInit Methods

Links
InxInterfaceFilerInit Interface, InxInterfaceFilerInit Members, nxrbTypes Namespace, InxInterfaceFilerInit Methods


InxInterfaceProxy Interface

InxInterfaceProxy Interface
nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceProxy
Syntax
Delphi
InxInterfaceProxy = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceProxy.

Group

Interfaces

Links
nxrbTypes, Interfaces


InxInterfaceProxyFactory Interface

InxInterfaceProxyFactory Interface
InxInterfaceProxyFactory Methods InxInterfaceProxyFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceProxyFactory
Syntax
Delphi
InxInterfaceProxyFactory = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceProxyFactory.

Group

Interfaces

Links
InxInterfaceProxyFactory Methods, InxInterfaceProxyFactory Members, nxrbTypes, Interfaces


InxInterfaceProxyFactory Members

InxInterfaceProxyFactory Members
InxInterfaceProxyFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceProxyFactory.

Interface

InxInterfaceProxyFactory Interface

Public Methods
Name | Description
CreateInterfaceProxy | This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactory.
Supports | This is Supports, a member of class InxInterfaceProxyFactory.
Links
InxInterfaceProxyFactory Interface, Legend, Public Methods


InxInterfaceProxyFactory Methods

InxInterfaceProxyFactory Methods
InxInterfaceProxyFactory Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceProxyFactory class are listed here.

Interface

InxInterfaceProxyFactory Interface

Public Methods
Name | Description
CreateInterfaceProxy | This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactory.
Supports | This is Supports, a member of class InxInterfaceProxyFactory.
Links
InxInterfaceProxyFactory Interface, Legend, Public Methods


InxInterfaceProxyFactory.CreateInterfaceProxy Method

InxInterfaceProxyFactory.CreateInterfaceProxy Method
InxInterfaceProxyFactory Interface InxInterfaceProxyFactory Members nxrbTypes Namespace InxInterfaceProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateInterfaceProxy(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterfaceStubID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aInterfaceProxy: InxInterfaceProxy): HRESULT;
Description

This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactory.

Group

InxInterfaceProxyFactory Methods

Links
InxInterfaceProxyFactory Interface, InxInterfaceProxyFactory Members, nxrbTypes Namespace, InxInterfaceProxyFactory Methods


InxInterfaceProxyFactory.Supports Method

InxInterfaceProxyFactory.Supports Method
InxInterfaceProxyFactory Interface InxInterfaceProxyFactory Members nxrbTypes Namespace InxInterfaceProxyFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

This is Supports, a member of class InxInterfaceProxyFactory.

Group

InxInterfaceProxyFactory Methods

Links
InxInterfaceProxyFactory Interface, InxInterfaceProxyFactory Members, nxrbTypes Namespace, InxInterfaceProxyFactory Methods


InxInterfaceProxyFactoryControl Interface

InxInterfaceProxyFactoryControl Interface
InxInterfaceProxyFactoryControl Methods InxInterfaceProxyFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceProxyFactoryControlnxrbTypes_InxInterfaceProxyFactoryControl
Syntax
Delphi
InxInterfaceProxyFactoryControl = interface(InxFactoryControl);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceProxyFactoryControl.

Group

Interfaces

Links
InxInterfaceProxyFactoryControl Methods, InxInterfaceProxyFactoryControl Members, nxrbTypes, Interfaces


InxInterfaceProxyFactoryControl Members

InxInterfaceProxyFactoryControl Members
InxInterfaceProxyFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceProxyFactoryControl.

Interface

InxInterfaceProxyFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxInterfaceProxyFactoryControl.
RegisterForClassAndInterface | This is RegisterForClassAndInterface, a member of class InxInterfaceProxyFactoryControl.
RegisterForInterface | This is RegisterForInterface, a member of class InxInterfaceProxyFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxInterfaceProxyFactoryControl.
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxInterfaceProxyFactoryControl Interface, Legend, Public Methods


InxInterfaceProxyFactoryControl Methods

InxInterfaceProxyFactoryControl Methods
InxInterfaceProxyFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceProxyFactoryControl class are listed here.

Interface

InxInterfaceProxyFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxInterfaceProxyFactoryControl.
RegisterForClassAndInterface | This is RegisterForClassAndInterface, a member of class InxInterfaceProxyFactoryControl.
RegisterForInterface | This is RegisterForInterface, a member of class InxInterfaceProxyFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxInterfaceProxyFactoryControl.
Links
InxInterfaceProxyFactoryControl Interface, Legend, Public Methods


InxInterfaceProxyFactoryControl.RegisterForClass Method

InxInterfaceProxyFactoryControl.RegisterForClass Method
InxInterfaceProxyFactoryControl Interface InxInterfaceProxyFactoryControl Members nxrbTypes Namespace InxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

This is RegisterForClass, a member of class InxInterfaceProxyFactoryControl.

Group

InxInterfaceProxyFactoryControl Methods

Links
InxInterfaceProxyFactoryControl Interface, InxInterfaceProxyFactoryControl Members, nxrbTypes Namespace, InxInterfaceProxyFactoryControl Methods


InxInterfaceProxyFactoryControl.RegisterForClassAndInterface Method

InxInterfaceProxyFactoryControl.RegisterForClassAndInterface Method
InxInterfaceProxyFactoryControl Interface InxInterfaceProxyFactoryControl Members nxrbTypes Namespace InxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClassAndInterface(aPriority: TnxRegisterPriority; const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

This is RegisterForClassAndInterface, a member of class InxInterfaceProxyFactoryControl.

Group

InxInterfaceProxyFactoryControl Methods

Links
InxInterfaceProxyFactoryControl Interface, InxInterfaceProxyFactoryControl Members, nxrbTypes Namespace, InxInterfaceProxyFactoryControl Methods


InxInterfaceProxyFactoryControl.RegisterForInterface Method

InxInterfaceProxyFactoryControl.RegisterForInterface Method
InxInterfaceProxyFactoryControl Interface InxInterfaceProxyFactoryControl Members nxrbTypes Namespace InxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForInterface(aPriority: TnxRegisterPriority; const aInterfaceID: TnxGuid): HRESULT;
Description

This is RegisterForInterface, a member of class InxInterfaceProxyFactoryControl.

Group

InxInterfaceProxyFactoryControl Methods

Links
InxInterfaceProxyFactoryControl Interface, InxInterfaceProxyFactoryControl Members, nxrbTypes Namespace, InxInterfaceProxyFactoryControl Methods


InxInterfaceProxyFactoryControl.RegisterGeneric Method

InxInterfaceProxyFactoryControl.RegisterGeneric Method
InxInterfaceProxyFactoryControl Interface InxInterfaceProxyFactoryControl Members nxrbTypes Namespace InxInterfaceProxyFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Description

This is RegisterGeneric, a member of class InxInterfaceProxyFactoryControl.

Group

InxInterfaceProxyFactoryControl Methods

Links
InxInterfaceProxyFactoryControl Interface, InxInterfaceProxyFactoryControl Members, nxrbTypes Namespace, InxInterfaceProxyFactoryControl Methods


InxInterfaceProxyFactoryRegistry Interface

InxInterfaceProxyFactoryRegistry Interface
InxInterfaceProxyFactoryRegistry Methods InxInterfaceProxyFactoryRegistry Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceProxyFactoryRegistry
Syntax
Delphi
InxInterfaceProxyFactoryRegistry = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceProxyFactoryRegistry.

Group

Interfaces

Links
InxInterfaceProxyFactoryRegistry Methods, InxInterfaceProxyFactoryRegistry Members, nxrbTypes, Interfaces


InxInterfaceProxyFactoryRegistry Members

InxInterfaceProxyFactoryRegistry Members
InxInterfaceProxyFactoryRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceProxyFactoryRegistry.

Interface

InxInterfaceProxyFactoryRegistry Interface

Public Methods
Name | Description
CreateInterfaceProxy | This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactoryRegistry.
QueryProxies | This is QueryProxies, a member of class InxInterfaceProxyFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxInterfaceProxyFactoryRegistry.
Links
InxInterfaceProxyFactoryRegistry Interface, Legend, Public Methods


InxInterfaceProxyFactoryRegistry Methods

InxInterfaceProxyFactoryRegistry Methods
InxInterfaceProxyFactoryRegistry Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceProxyFactoryRegistry class are listed here.

Interface

InxInterfaceProxyFactoryRegistry Interface

Public Methods
Name | Description
CreateInterfaceProxy | This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactoryRegistry.
QueryProxies | This is QueryProxies, a member of class InxInterfaceProxyFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxInterfaceProxyFactoryRegistry.
Links
InxInterfaceProxyFactoryRegistry Interface, Legend, Public Methods


InxInterfaceProxyFactoryRegistry.CreateInterfaceProxy Method

InxInterfaceProxyFactoryRegistry.CreateInterfaceProxy Method
InxInterfaceProxyFactoryRegistry Interface InxInterfaceProxyFactoryRegistry Members nxrbTypes Namespace InxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateInterfaceProxy(const aInterfaceProxyID: TnxGuid; const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aInterfaceProxy: InxInterfaceProxy): HRESULT;
Description

This is CreateInterfaceProxy, a member of class InxInterfaceProxyFactoryRegistry.

Group

InxInterfaceProxyFactoryRegistry Methods

Links
InxInterfaceProxyFactoryRegistry Interface, InxInterfaceProxyFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceProxyFactoryRegistry Methods


InxInterfaceProxyFactoryRegistry.QueryProxies Method

InxInterfaceProxyFactoryRegistry.QueryProxies Method
InxInterfaceProxyFactoryRegistry Interface InxInterfaceProxyFactoryRegistry Members nxrbTypes Namespace InxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryProxies(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceProxyIDs: PnxGuid; aInterfaceProxyIDCountMax: Integer; out aInterfaceProxyIDCount: Integer): HRESULT;
Description

This is QueryProxies, a member of class InxInterfaceProxyFactoryRegistry.

Group

InxInterfaceProxyFactoryRegistry Methods

Links
InxInterfaceProxyFactoryRegistry Interface, InxInterfaceProxyFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceProxyFactoryRegistry Methods


InxInterfaceProxyFactoryRegistry.RegisterFactory Method

InxInterfaceProxyFactoryRegistry.RegisterFactory Method
InxInterfaceProxyFactoryRegistry Interface InxInterfaceProxyFactoryRegistry Members nxrbTypes Namespace InxInterfaceProxyFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aInterfaceProxyID: TnxGuid; const aFactory: InxInterfaceProxyFactory; out aControl: InxInterfaceProxyFactoryControl): HRESULT;
Description

This is RegisterFactory, a member of class InxInterfaceProxyFactoryRegistry.

Group

InxInterfaceProxyFactoryRegistry Methods

Links
InxInterfaceProxyFactoryRegistry Interface, InxInterfaceProxyFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceProxyFactoryRegistry Methods


InxInterfaceReader Interface

InxInterfaceReader Interface
InxInterfaceReader Methods InxInterfaceReader Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceReader
Syntax
Delphi
InxInterfaceReader = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceReader.

Group

Interfaces

Links
InxInterfaceReader Methods, InxInterfaceReader Members, nxrbTypes, Interfaces


InxInterfaceReader Members

InxInterfaceReader Members
InxInterfaceReader Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceReader.

Interface

InxInterfaceReader Interface

Public Methods
Name | Description
ReadInterface | This is ReadInterface, a member of class InxInterfaceReader.
Links
InxInterfaceReader Interface, Legend, Public Methods


InxInterfaceReader Methods

InxInterfaceReader Methods
InxInterfaceReader Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceReader class are listed here.

Interface

InxInterfaceReader Interface

Public Methods
Name | Description
ReadInterface | This is ReadInterface, a member of class InxInterfaceReader.
Links
InxInterfaceReader Interface, Legend, Public Methods


InxInterfaceReader.ReadInterface Method

InxInterfaceReader.ReadInterface Method
InxInterfaceReader Interface InxInterfaceReader Members nxrbTypes Namespace InxInterfaceReader Methods Send Feedback
Syntax
Delphi
function ReadInterface(const aInterfaceID: TnxGuid; out aInterface: InxInterface): HRESULT;
Description

This is ReadInterface, a member of class InxInterfaceReader.

Group

InxInterfaceReader Methods

Links
InxInterfaceReader Interface, InxInterfaceReader Members, nxrbTypes Namespace, InxInterfaceReader Methods


InxInterfaceStub Interface

InxInterfaceStub Interface
InxInterfaceStub Methods InxInterfaceStub Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceStub
Syntax
Delphi
InxInterfaceStub = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceStub.

Group

Interfaces

Links
InxInterfaceStub Methods, InxInterfaceStub Members, nxrbTypes, Interfaces


InxInterfaceStub Members

InxInterfaceStub Members
InxInterfaceStub Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceStub.

Interface

InxInterfaceStub Interface

Public Methods
Name | Description
ChannelAttached | This is ChannelAttached, a member of class InxInterfaceStub.
Process | This is Process, a member of class InxInterfaceStub.
Links
InxInterfaceStub Interface, Legend, Public Methods


InxInterfaceStub Methods

InxInterfaceStub Methods
InxInterfaceStub Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceStub class are listed here.

Interface

InxInterfaceStub Interface

Public Methods
Name | Description
ChannelAttached | This is ChannelAttached, a member of class InxInterfaceStub.
Process | This is Process, a member of class InxInterfaceStub.
Links
InxInterfaceStub Interface, Legend, Public Methods


InxInterfaceStub.ChannelAttached Method

InxInterfaceStub.ChannelAttached Method
InxInterfaceStub Interface InxInterfaceStub Members nxrbTypes Namespace InxInterfaceStub Methods Send Feedback
Syntax
Delphi
function ChannelAttached(const aChannel: InxChannelExit; const aClassStub: InxClassStub; const aReply: InxWriter): HRESULT;
Description

This is ChannelAttached, a member of class InxInterfaceStub.

Group

InxInterfaceStub Methods

Links
InxInterfaceStub Interface, InxInterfaceStub Members, nxrbTypes Namespace, InxInterfaceStub Methods


InxInterfaceStub.Process Method

InxInterfaceStub.Process Method
InxInterfaceStub Interface InxInterfaceStub Members nxrbTypes Namespace InxInterfaceStub Methods Send Feedback
Syntax
Delphi
function Process(const aChannel: InxChannelExit; const aClassStub: InxClassStub; const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

This is Process, a member of class InxInterfaceStub.

Group

InxInterfaceStub Methods

Links
InxInterfaceStub Interface, InxInterfaceStub Members, nxrbTypes Namespace, InxInterfaceStub Methods


InxInterfaceStubFactory Interface

InxInterfaceStubFactory Interface
InxInterfaceStubFactory Methods InxInterfaceStubFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceStubFactory
Syntax
Delphi
InxInterfaceStubFactory = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceStubFactory.

Group

Interfaces

Links
InxInterfaceStubFactory Methods, InxInterfaceStubFactory Members, nxrbTypes, Interfaces


InxInterfaceStubFactory Members

InxInterfaceStubFactory Members
InxInterfaceStubFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceStubFactory.

Interface

InxInterfaceStubFactory Interface

Public Methods
Name | Description
CreateInterfaceStub | This is CreateInterfaceStub, a member of class InxInterfaceStubFactory.
Supports | This is Supports, a member of class InxInterfaceStubFactory.
Links
InxInterfaceStubFactory Interface, Legend, Public Methods


InxInterfaceStubFactory Methods

InxInterfaceStubFactory Methods
InxInterfaceStubFactory Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceStubFactory class are listed here.

Interface

InxInterfaceStubFactory Interface

Public Methods
Name | Description
CreateInterfaceStub | This is CreateInterfaceStub, a member of class InxInterfaceStubFactory.
Supports | This is Supports, a member of class InxInterfaceStubFactory.
Links
InxInterfaceStubFactory Interface, Legend, Public Methods


InxInterfaceStubFactory.CreateInterfaceStub Method

InxInterfaceStubFactory.CreateInterfaceStub Method
InxInterfaceStubFactory Interface InxInterfaceStubFactory Members nxrbTypes Namespace InxInterfaceStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInterfaceStub(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInterfaceStub: InxInterfaceStub): HRESULT;
Description

This is CreateInterfaceStub, a member of class InxInterfaceStubFactory.

Group

InxInterfaceStubFactory Methods

Links
InxInterfaceStubFactory Interface, InxInterfaceStubFactory Members, nxrbTypes Namespace, InxInterfaceStubFactory Methods


InxInterfaceStubFactory.Supports Method

InxInterfaceStubFactory.Supports Method
InxInterfaceStubFactory Interface InxInterfaceStubFactory Members nxrbTypes Namespace InxInterfaceStubFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

This is Supports, a member of class InxInterfaceStubFactory.

Group

InxInterfaceStubFactory Methods

Links
InxInterfaceStubFactory Interface, InxInterfaceStubFactory Members, nxrbTypes Namespace, InxInterfaceStubFactory Methods


InxInterfaceStubFactoryControl Interface

InxInterfaceStubFactoryControl Interface
InxInterfaceStubFactoryControl Methods InxInterfaceStubFactoryControl Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceStubFactoryControlnxrbTypes_InxInterfaceStubFactoryControl
Syntax
Delphi
InxInterfaceStubFactoryControl = interface(InxFactoryControl);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceStubFactoryControl.

Group

Interfaces

Links
InxInterfaceStubFactoryControl Methods, InxInterfaceStubFactoryControl Members, nxrbTypes, Interfaces


InxInterfaceStubFactoryControl Members

InxInterfaceStubFactoryControl Members
InxInterfaceStubFactoryControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceStubFactoryControl.

Interface

InxInterfaceStubFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxInterfaceStubFactoryControl.
RegisterForClassAndInterface | This is RegisterForClassAndInterface, a member of class InxInterfaceStubFactoryControl.
RegisterForInterface | This is RegisterForInterface, a member of class InxInterfaceStubFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxInterfaceStubFactoryControl.
Unregister | This is Unregister, a member of class InxFactoryControl.
Links
InxInterfaceStubFactoryControl Interface, Legend, Public Methods


InxInterfaceStubFactoryControl Methods

InxInterfaceStubFactoryControl Methods
InxInterfaceStubFactoryControl Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceStubFactoryControl class are listed here.

Interface

InxInterfaceStubFactoryControl Interface

Public Methods
Name | Description
RegisterForClass | This is RegisterForClass, a member of class InxInterfaceStubFactoryControl.
RegisterForClassAndInterface | This is RegisterForClassAndInterface, a member of class InxInterfaceStubFactoryControl.
RegisterForInterface | This is RegisterForInterface, a member of class InxInterfaceStubFactoryControl.
RegisterGeneric | This is RegisterGeneric, a member of class InxInterfaceStubFactoryControl.
Links
InxInterfaceStubFactoryControl Interface, Legend, Public Methods


InxInterfaceStubFactoryControl.RegisterForClass Method

InxInterfaceStubFactoryControl.RegisterForClass Method
InxInterfaceStubFactoryControl Interface InxInterfaceStubFactoryControl Members nxrbTypes Namespace InxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClass(aPriority: TnxRegisterPriority; const aClassID: TnxGuid): HRESULT;
Description

This is RegisterForClass, a member of class InxInterfaceStubFactoryControl.

Group

InxInterfaceStubFactoryControl Methods

Links
InxInterfaceStubFactoryControl Interface, InxInterfaceStubFactoryControl Members, nxrbTypes Namespace, InxInterfaceStubFactoryControl Methods


InxInterfaceStubFactoryControl.RegisterForClassAndInterface Method

InxInterfaceStubFactoryControl.RegisterForClassAndInterface Method
InxInterfaceStubFactoryControl Interface InxInterfaceStubFactoryControl Members nxrbTypes Namespace InxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForClassAndInterface(aPriority: TnxRegisterPriority; const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

This is RegisterForClassAndInterface, a member of class InxInterfaceStubFactoryControl.

Group

InxInterfaceStubFactoryControl Methods

Links
InxInterfaceStubFactoryControl Interface, InxInterfaceStubFactoryControl Members, nxrbTypes Namespace, InxInterfaceStubFactoryControl Methods


InxInterfaceStubFactoryControl.RegisterForInterface Method

InxInterfaceStubFactoryControl.RegisterForInterface Method
InxInterfaceStubFactoryControl Interface InxInterfaceStubFactoryControl Members nxrbTypes Namespace InxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterForInterface(aPriority: TnxRegisterPriority; const aInterfaceID: TnxGuid): HRESULT;
Description

This is RegisterForInterface, a member of class InxInterfaceStubFactoryControl.

Group

InxInterfaceStubFactoryControl Methods

Links
InxInterfaceStubFactoryControl Interface, InxInterfaceStubFactoryControl Members, nxrbTypes Namespace, InxInterfaceStubFactoryControl Methods


InxInterfaceStubFactoryControl.RegisterGeneric Method

InxInterfaceStubFactoryControl.RegisterGeneric Method
InxInterfaceStubFactoryControl Interface InxInterfaceStubFactoryControl Members nxrbTypes Namespace InxInterfaceStubFactoryControl Methods Send Feedback
Syntax
Delphi
function RegisterGeneric(aPriority: TnxRegisterPriority): HRESULT;
Description

This is RegisterGeneric, a member of class InxInterfaceStubFactoryControl.

Group

InxInterfaceStubFactoryControl Methods

Links
InxInterfaceStubFactoryControl Interface, InxInterfaceStubFactoryControl Members, nxrbTypes Namespace, InxInterfaceStubFactoryControl Methods


InxInterfaceStubFactoryRegistry Interface

InxInterfaceStubFactoryRegistry Interface
InxInterfaceStubFactoryRegistry Methods InxInterfaceStubFactoryRegistry Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceStubFactoryRegistry
Syntax
Delphi
InxInterfaceStubFactoryRegistry = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceStubFactoryRegistry.

Group

Interfaces

Links
InxInterfaceStubFactoryRegistry Methods, InxInterfaceStubFactoryRegistry Members, nxrbTypes, Interfaces


InxInterfaceStubFactoryRegistry Members

InxInterfaceStubFactoryRegistry Members
InxInterfaceStubFactoryRegistry Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceStubFactoryRegistry.

Interface

InxInterfaceStubFactoryRegistry Interface

Public Methods
Name | Description
CreateInterfaceStub | This is CreateInterfaceStub, a member of class InxInterfaceStubFactoryRegistry.
MatchToProxies | This is MatchToProxies, a member of class InxInterfaceStubFactoryRegistry.
QueryStubs | This is QueryStubs, a member of class InxInterfaceStubFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxInterfaceStubFactoryRegistry.
Links
InxInterfaceStubFactoryRegistry Interface, Legend, Public Methods


InxInterfaceStubFactoryRegistry Methods

InxInterfaceStubFactoryRegistry Methods
InxInterfaceStubFactoryRegistry Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceStubFactoryRegistry class are listed here.

Interface

InxInterfaceStubFactoryRegistry Interface

Public Methods
Name | Description
CreateInterfaceStub | This is CreateInterfaceStub, a member of class InxInterfaceStubFactoryRegistry.
MatchToProxies | This is MatchToProxies, a member of class InxInterfaceStubFactoryRegistry.
QueryStubs | This is QueryStubs, a member of class InxInterfaceStubFactoryRegistry.
RegisterFactory | This is RegisterFactory, a member of class InxInterfaceStubFactoryRegistry.
Links
InxInterfaceStubFactoryRegistry Interface, Legend, Public Methods


InxInterfaceStubFactoryRegistry.CreateInterfaceStub Method

InxInterfaceStubFactoryRegistry.CreateInterfaceStub Method
InxInterfaceStubFactoryRegistry Interface InxInterfaceStubFactoryRegistry Members nxrbTypes Namespace InxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function CreateInterfaceStub(const aInterfaceStubID: TnxGuid; const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInterfaceStub: InxInterfaceStub): HRESULT;
Description

This is CreateInterfaceStub, a member of class InxInterfaceStubFactoryRegistry.

Group

InxInterfaceStubFactoryRegistry Methods

Links
InxInterfaceStubFactoryRegistry Interface, InxInterfaceStubFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceStubFactoryRegistry Methods


InxInterfaceStubFactoryRegistry.MatchToProxies Method

InxInterfaceStubFactoryRegistry.MatchToProxies Method
InxInterfaceStubFactoryRegistry Interface InxInterfaceStubFactoryRegistry Members nxrbTypes Namespace InxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function MatchToProxies(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceProxyIDs: PnxGuid; aInterfaceProxyIDCount: Integer; out aInterfaceStubID: TnxGuid): HRESULT;
Description

This is MatchToProxies, a member of class InxInterfaceStubFactoryRegistry.

Group

InxInterfaceStubFactoryRegistry Methods

Links
InxInterfaceStubFactoryRegistry Interface, InxInterfaceStubFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceStubFactoryRegistry Methods


InxInterfaceStubFactoryRegistry.QueryStubs Method

InxInterfaceStubFactoryRegistry.QueryStubs Method
InxInterfaceStubFactoryRegistry Interface InxInterfaceStubFactoryRegistry Members nxrbTypes Namespace InxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function QueryStubs(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; aInterfaceStubIDs: PnxGuid; aInterfaceStubIDCountMax: Integer; out aInterfaceStubIDCount: Integer): HRESULT;
Description

This is QueryStubs, a member of class InxInterfaceStubFactoryRegistry.

Group

InxInterfaceStubFactoryRegistry Methods

Links
InxInterfaceStubFactoryRegistry Interface, InxInterfaceStubFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceStubFactoryRegistry Methods


InxInterfaceStubFactoryRegistry.RegisterFactory Method

InxInterfaceStubFactoryRegistry.RegisterFactory Method
InxInterfaceStubFactoryRegistry Interface InxInterfaceStubFactoryRegistry Members nxrbTypes Namespace InxInterfaceStubFactoryRegistry Methods Send Feedback
Syntax
Delphi
function RegisterFactory(const aInterfaceStubID: TnxGuid; const aFactory: InxInterfaceStubFactory; out aControl: InxInterfaceStubFactoryControl): HRESULT;
Description

This is RegisterFactory, a member of class InxInterfaceStubFactoryRegistry.

Group

InxInterfaceStubFactoryRegistry Methods

Links
InxInterfaceStubFactoryRegistry Interface, InxInterfaceStubFactoryRegistry Members, nxrbTypes Namespace, InxInterfaceStubFactoryRegistry Methods


InxInterfaceWriter Interface

InxInterfaceWriter Interface
InxInterfaceWriter Methods InxInterfaceWriter Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxInterfaceWriter
Syntax
Delphi
InxInterfaceWriter = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxInterfaceWriter.

Group

Interfaces

Links
InxInterfaceWriter Methods, InxInterfaceWriter Members, nxrbTypes, Interfaces


InxInterfaceWriter Members

InxInterfaceWriter Members
InxInterfaceWriter Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxInterfaceWriter.

Interface

InxInterfaceWriter Interface

Public Methods
Name | Description
WriteInterface | This is WriteInterface, a member of class InxInterfaceWriter.
Links
InxInterfaceWriter Interface, Legend, Public Methods


InxInterfaceWriter Methods

InxInterfaceWriter Methods
InxInterfaceWriter Interface Legend Public Methods Send Feedback

The methods of the InxInterfaceWriter class are listed here.

Interface

InxInterfaceWriter Interface

Public Methods
Name | Description
WriteInterface | This is WriteInterface, a member of class InxInterfaceWriter.
Links
InxInterfaceWriter Interface, Legend, Public Methods


InxInterfaceWriter.WriteInterface Method

InxInterfaceWriter.WriteInterface Method
InxInterfaceWriter Interface InxInterfaceWriter Members nxrbTypes Namespace InxInterfaceWriter Methods Send Feedback
Syntax
Delphi
function WriteInterface(const aInterfaceID: TnxGuid; const aInterface: InxInterface): HRESULT;
Description

This is WriteInterface, a member of class InxInterfaceWriter.

Group

InxInterfaceWriter Methods

Links
InxInterfaceWriter Interface, InxInterfaceWriter Members, nxrbTypes Namespace, InxInterfaceWriter Methods


InxReader Interface

InxReader Interface
InxReader Methods InxReader Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxReader
Syntax
Delphi
InxReader = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxReader.

Group

Interfaces

Links
InxReader Methods, InxReader Members, nxrbTypes, Interfaces


InxReader Members

InxReader Members
InxReader Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxReader.

Interface

InxReader Interface

Public Methods
Name | Description
EndOfList | peek ahead
NextValue | This is NextValue, a member of class InxReader.
ReadAnsiChar | This is ReadAnsiChar, a member of class InxReader.
ReadBinary | This is ReadBinary, a member of class InxReader.
ReadBoolean | This is ReadBoolean, a member of class InxReader.
ReadChar | This is ReadChar, a member of class InxReader.
ReadCurrency | This is ReadCurrency, a member of class InxReader.
ReadDate | This is ReadDate, a member of class InxReader.
ReadDouble | This is ReadDouble, a member of class InxReader.
ReadFloat | This is ReadFloat, a member of class InxReader.
ReadGuid | This is ReadGuid, a member of class InxReader.
ReadIdent | This is ReadIdent, a member of class InxReader.
ReadInt64 | This is ReadInt64, a member of class InxReader.
ReadInteger | This is ReadInteger, a member of class InxReader.
ReadListBegin | This is ReadListBegin, a member of class InxReader.
ReadListEnd | This is ReadListEnd, a member of class InxReader.
ReadSingle | This is ReadSingle, a member of class InxReader.
ReadString | This is ReadString, a member of class InxReader.
ReadValue | This is ReadValue, a member of class InxReader.
ReadVariant | This is ReadVariant, a member of class InxReader.
ReadWideChar | This is ReadWideChar, a member of class InxReader.
ReadWideString_ | This is ReadWideString_, a member of class InxReader.
Links
InxReader Interface, Legend, Public Methods


InxReader Methods

InxReader Methods
InxReader Interface Legend Public Methods Send Feedback

The methods of the InxReader class are listed here.

Interface

InxReader Interface

Public Methods
Name | Description
EndOfList | peek ahead
NextValue | This is NextValue, a member of class InxReader.
ReadAnsiChar | This is ReadAnsiChar, a member of class InxReader.
ReadBinary | This is ReadBinary, a member of class InxReader.
ReadBoolean | This is ReadBoolean, a member of class InxReader.
ReadChar | This is ReadChar, a member of class InxReader.
ReadCurrency | This is ReadCurrency, a member of class InxReader.
ReadDate | This is ReadDate, a member of class InxReader.
ReadDouble | This is ReadDouble, a member of class InxReader.
ReadFloat | This is ReadFloat, a member of class InxReader.
ReadGuid | This is ReadGuid, a member of class InxReader.
ReadIdent | This is ReadIdent, a member of class InxReader.
ReadInt64 | This is ReadInt64, a member of class InxReader.
ReadInteger | This is ReadInteger, a member of class InxReader.
ReadListBegin | This is ReadListBegin, a member of class InxReader.
ReadListEnd | This is ReadListEnd, a member of class InxReader.
ReadSingle | This is ReadSingle, a member of class InxReader.
ReadString | This is ReadString, a member of class InxReader.
ReadValue | This is ReadValue, a member of class InxReader.
ReadVariant | This is ReadVariant, a member of class InxReader.
ReadWideChar | This is ReadWideChar, a member of class InxReader.
ReadWideString_ | This is ReadWideString_, a member of class InxReader.
Links
InxReader Interface, Legend, Public Methods


InxReader.EndOfList Method

InxReader.EndOfList Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function EndOfList: Boolean;
Description

peek ahead

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.NextValue Method

InxReader.NextValue Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function NextValue: TValueType;
Description

This is NextValue, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadAnsiChar Method

InxReader.ReadAnsiChar Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadAnsiChar: AnsiChar;
Description

This is ReadAnsiChar, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadBinary Method

InxReader.ReadBinary Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
procedure ReadBinary(out Value; Size: Integer);
Description

This is ReadBinary, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadBoolean Method

InxReader.ReadBoolean Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadBoolean: Boolean;
Description

This is ReadBoolean, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadChar Method

InxReader.ReadChar Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadChar: Char;
Description

This is ReadChar, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadCurrency Method

InxReader.ReadCurrency Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadCurrency: Currency;
Description

This is ReadCurrency, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadDate Method

InxReader.ReadDate Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadDate: TDateTime;
Description

This is ReadDate, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadDouble Method

InxReader.ReadDouble Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadDouble: Double;
Description

This is ReadDouble, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadFloat Method

InxReader.ReadFloat Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadFloat: Extended;
Description

This is ReadFloat, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadGuid Method

InxReader.ReadGuid Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadGuid: TnxGuid;
Description

This is ReadGuid, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadIdent Method

InxReader.ReadIdent Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadIdent: string;
Description

This is ReadIdent, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadInt64 Method

InxReader.ReadInt64 Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadInt64: Int64;
Description

This is ReadInt64, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadInteger Method

InxReader.ReadInteger Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadInteger: Integer;
Description

This is ReadInteger, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadListBegin Method

InxReader.ReadListBegin Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
procedure ReadListBegin;
Description

This is ReadListBegin, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadListEnd Method

InxReader.ReadListEnd Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
procedure ReadListEnd;
Description

This is ReadListEnd, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadSingle Method

InxReader.ReadSingle Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadSingle: Single;
Description

This is ReadSingle, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadString Method

InxReader.ReadString Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadString: string;
Description

This is ReadString, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadValue Method

InxReader.ReadValue Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadValue: TValueType;
Description

This is ReadValue, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadVariant Method

InxReader.ReadVariant Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadVariant: Variant;
Description

This is ReadVariant, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadWideChar Method

InxReader.ReadWideChar Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadWideChar: WideChar;
Description

This is ReadWideChar, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxReader.ReadWideString_ Method

InxReader.ReadWideString_ Method
InxReader Interface InxReader Members nxrbTypes Namespace InxReader Methods Send Feedback
Syntax
Delphi
function ReadWideString_: UnicodeString;
Description

This is ReadWideString_, a member of class InxReader.

Group

InxReader Methods

Links
InxReader Interface, InxReader Members, nxrbTypes Namespace, InxReader Methods


InxRemoteableClass Interface

InxRemoteableClass Interface
InxRemoteableClass Methods InxRemoteableClass Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxRemoteableClassnxrbTypes_InxRemoteableClass
Syntax
Delphi
InxRemoteableClass = interface(InxClass);
File

nxrbTypes

Description

This is class nxrbTypes.InxRemoteableClass.

Group

Interfaces

Links
InxRemoteableClass Methods, InxRemoteableClass Members, nxrbTypes, Interfaces


InxRemoteableClass Members

InxRemoteableClass Members
InxRemoteableClass Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxRemoteableClass.

Interface

InxRemoteableClass Interface

Public Methods
Name | Description
GetClassID | This is GetClassID, a member of class InxClass.
LoadFromReader | This is LoadFromReader, a member of class InxRemoteableClass.
SaveToWriter | This is SaveToWriter, a member of class InxRemoteableClass.
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Links
InxRemoteableClass Interface, Legend, Public Methods, Public Properties


InxRemoteableClass Methods

InxRemoteableClass Methods
InxRemoteableClass Interface Legend Public Methods Send Feedback

The methods of the InxRemoteableClass class are listed here.

Interface

InxRemoteableClass Interface

Public Methods
Name | Description
LoadFromReader | This is LoadFromReader, a member of class InxRemoteableClass.
SaveToWriter | This is SaveToWriter, a member of class InxRemoteableClass.
Links
InxRemoteableClass Interface, Legend, Public Methods


InxRemoteableClass.LoadFromReader Method

InxRemoteableClass.LoadFromReader Method
InxRemoteableClass Interface InxRemoteableClass Members nxrbTypes Namespace InxRemoteableClass Methods Send Feedback
Syntax
Delphi
function LoadFromReader(aReader: InxReader): HRESULT;
Description

This is LoadFromReader, a member of class InxRemoteableClass.

Group

InxRemoteableClass Methods

Links
InxRemoteableClass Interface, InxRemoteableClass Members, nxrbTypes Namespace, InxRemoteableClass Methods


InxRemoteableClass.SaveToWriter Method

InxRemoteableClass.SaveToWriter Method
InxRemoteableClass Interface InxRemoteableClass Members nxrbTypes Namespace InxRemoteableClass Methods Send Feedback
Syntax
Delphi
function SaveToWriter(aWriter: InxWriter): HRESULT;
Description

This is SaveToWriter, a member of class InxRemoteableClass.

Group

InxRemoteableClass Methods

Links
InxRemoteableClass Interface, InxRemoteableClass Members, nxrbTypes Namespace, InxRemoteableClass Methods


InxRoutingPath Interface

InxRoutingPath Interface
InxRoutingPath Methods InxRoutingPath Properties InxRoutingPath Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxRoutingPath
Syntax
Delphi
InxRoutingPath = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxRoutingPath.

Group

Interfaces

Links
InxRoutingPath Methods, InxRoutingPath Properties, InxRoutingPath Members, nxrbTypes, Interfaces


InxRoutingPath Members

InxRoutingPath Members
InxRoutingPath Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxRoutingPath.

Interface

InxRoutingPath Interface

Public Methods
Name | Description
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
Public Properties
Name | Description
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
InxRoutingPath Interface, Legend, Public Methods, Public Properties


InxRoutingPath Methods

InxRoutingPath Methods
InxRoutingPath Interface Legend Public Methods Send Feedback

The methods of the InxRoutingPath class are listed here.

Interface

InxRoutingPath Interface

Public Methods
Name | Description
GetRoutingPath | This is GetRoutingPath, a member of class InxRoutingPath.
Links
InxRoutingPath Interface, Legend, Public Methods


InxRoutingPath.GetRoutingPath Method

InxRoutingPath.GetRoutingPath Method
InxRoutingPath Interface InxRoutingPath Members nxrbTypes Namespace InxRoutingPath Methods Send Feedback
Syntax
Delphi
function GetRoutingPath: TnxRoutingPath;
Description

This is GetRoutingPath, a member of class InxRoutingPath.

Group

InxRoutingPath Methods

Links
InxRoutingPath Interface, InxRoutingPath Members, nxrbTypes Namespace, InxRoutingPath Methods


InxRoutingPath Properties

InxRoutingPath Properties
InxRoutingPath Interface Legend Public Properties Send Feedback

The properties of the InxRoutingPath class are listed here.

Interface

InxRoutingPath Interface

Public Properties
Name | Description
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
InxRoutingPath Interface, Legend, Public Properties


InxRoutingPath.RoutingPath Property

InxRoutingPath.RoutingPath Property
InxRoutingPath Interface InxRoutingPath Members nxrbTypes Namespace InxRoutingPath Properties Send Feedback
Syntax
Delphi
property RoutingPath: TnxRoutingPath;
Description

This is RoutingPath, a member of class InxRoutingPath.

Group

InxRoutingPath Properties

Links
InxRoutingPath Interface, InxRoutingPath Members, nxrbTypes Namespace, InxRoutingPath Properties


InxSingeltonClassFactory Interface

InxSingeltonClassFactory Interface
InxSingeltonClassFactory Methods InxSingeltonClassFactory Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxSingeltonClassFactorynxrbTypes_InxSingeltonClassFactory
Syntax
Delphi
InxSingeltonClassFactory = interface(InxClassFactory);
File

nxrbTypes

Description

This is class nxrbTypes.InxSingeltonClassFactory.

Group

Interfaces

Links
InxSingeltonClassFactory Methods, InxSingeltonClassFactory Members, nxrbTypes, Interfaces


InxSingeltonClassFactory Members

InxSingeltonClassFactory Members
InxSingeltonClassFactory Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSingeltonClassFactory.

Interface

InxSingeltonClassFactory Interface

Public Methods
Name | Description
CreateInstance | This is CreateInstance, a member of class InxClassFactory.
ReleaseSingelton | This is ReleaseSingelton, a member of class InxSingeltonClassFactory.
Links
InxSingeltonClassFactory Interface, Legend, Public Methods


InxSingeltonClassFactory Methods

InxSingeltonClassFactory Methods
InxSingeltonClassFactory Interface Legend Public Methods Send Feedback

The methods of the InxSingeltonClassFactory class are listed here.

Interface

InxSingeltonClassFactory Interface

Public Methods
Name | Description
ReleaseSingelton | This is ReleaseSingelton, a member of class InxSingeltonClassFactory.
Links
InxSingeltonClassFactory Interface, Legend, Public Methods


InxSingeltonClassFactory.ReleaseSingelton Method

InxSingeltonClassFactory.ReleaseSingelton Method
InxSingeltonClassFactory Interface InxSingeltonClassFactory Members nxrbTypes Namespace InxSingeltonClassFactory Methods Send Feedback
Syntax
Delphi
function ReleaseSingelton: HRESULT;
Description

This is ReleaseSingelton, a member of class InxSingeltonClassFactory.

Group

InxSingeltonClassFactory Methods

Links
InxSingeltonClassFactory Interface, InxSingeltonClassFactory Members, nxrbTypes Namespace, InxSingeltonClassFactory Methods


InxWriter Interface

InxWriter Interface
InxWriter Methods InxWriter Members nxrbTypes Interfaces Send Feedback
Class Hierarchy
nxrbTypes_InxWriter
Syntax
Delphi
InxWriter = interface(InxInterface);
File

nxrbTypes

Description

This is class nxrbTypes.InxWriter.

Group

Interfaces

Links
InxWriter Methods, InxWriter Members, nxrbTypes, Interfaces


InxWriter Members

InxWriter Members
InxWriter Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxWriter.

Interface

InxWriter Interface

Public Methods
Name | Description
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
Links
InxWriter Interface, Legend, Public Methods


InxWriter Methods

InxWriter Methods
InxWriter Interface Legend Public Methods Send Feedback

The methods of the InxWriter class are listed here.

Interface

InxWriter Interface

Public Methods
Name | Description
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
Links
InxWriter Interface, Legend, Public Methods


InxWriter.WriteAnsiChar Method

InxWriter.WriteAnsiChar Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteAnsiChar(Value: AnsiChar);
Description

This is WriteAnsiChar, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteBinary Method

InxWriter.WriteBinary Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBinary(const Value; Size: Integer);
Description

This is WriteBinary, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteBoolean Method

InxWriter.WriteBoolean Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteBoolean(Value: Boolean);
Description

This is WriteBoolean, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteCurrency Method

InxWriter.WriteCurrency Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteCurrency(const Value: Currency);
Description

This is WriteCurrency, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteDate Method

InxWriter.WriteDate Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteDate(const Value: TDateTime);
Description

This is WriteDate, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteDouble Method

InxWriter.WriteDouble Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteDouble(const Value: Double);
Description

This is WriteDouble, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteFloat Method

InxWriter.WriteFloat Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteFloat(const Value: Extended);
Description

This is WriteFloat, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteGuid Method

InxWriter.WriteGuid Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteGuid(const Value: TnxGuid);
Description

This is WriteGuid, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteIdent Method

InxWriter.WriteIdent Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteIdent(const Ident: string);
Description

This is WriteIdent, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


WriteInteger Method

WriteInteger Method
InxWriter Methods Send Feedback

This is the overview for the WriteInteger method overload.

Overload List
Name | Description
InxWriter.WriteInteger (Int64) | This is WriteInteger, a member of class InxWriter.
InxWriter.WriteInteger (Integer) | This is WriteInteger, a member of class InxWriter.
Group

InxWriter Methods

Links
InxWriter Methods


InxWriter.WriteInteger Method (Int64)

InxWriter.WriteInteger Method (Int64)
InxWriter Interface InxWriter Members nxrbTypes Namespace WriteInteger Method Send Feedback
Syntax
Delphi
procedure WriteInteger(Value: Int64); overload;
Description

This is WriteInteger, a member of class InxWriter.

Group

WriteInteger Method

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, WriteInteger Method


InxWriter.WriteInteger Method (Integer)

InxWriter.WriteInteger Method (Integer)
InxWriter Interface InxWriter Members nxrbTypes Namespace WriteInteger Method Send Feedback
Syntax
Delphi
procedure WriteInteger(Value: Integer); overload;
Description

This is WriteInteger, a member of class InxWriter.

Group

WriteInteger Method

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, WriteInteger Method


InxWriter.WriteListBegin Method

InxWriter.WriteListBegin Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteListBegin;
Description

This is WriteListBegin, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteListEnd Method

InxWriter.WriteListEnd Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteListEnd;
Description

This is WriteListEnd, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteSingle Method

InxWriter.WriteSingle Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteSingle(const Value: Single);
Description

This is WriteSingle, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteString Method

InxWriter.WriteString Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteString(const Value: string);
Description

This is WriteString, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteValue Method

InxWriter.WriteValue Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteValue(Value: TValueType);
Description

This is WriteValue, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteVariant Method

InxWriter.WriteVariant Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteVariant(const Value: Variant);
Description

This is WriteVariant, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteWideChar Method

InxWriter.WriteWideChar Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideChar(Value: WideChar);
Description

This is WriteWideChar, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


InxWriter.WriteWideString_ Method

InxWriter.WriteWideString_ Method
InxWriter Interface InxWriter Members nxrbTypes Namespace InxWriter Methods Send Feedback
Syntax
Delphi
procedure WriteWideString_(const Value: UnicodeString);
Description

This is WriteWideString_, a member of class InxWriter.

Group

InxWriter Methods

Links
InxWriter Interface, InxWriter Members, nxrbTypes Namespace, InxWriter Methods


Functions

Functions
Functions nxrbTypes Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxReadObjectIdentity |
nxReadRoutingPath |
nxRoutingPathFromStatic |
nxRoutingPathToStatic |
nxWriteObjectIdentity |
nxWriteRoutingPath |
Namespace

nxrbTypes Namespace

Links
Functions, nxrbTypes Namespace, Legend


nxrbTypes.nxReadObjectIdentity Function

nxrbTypes.nxReadObjectIdentity Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
procedure nxReadObjectIdentity(const aReader: InxReader; out aIdentity: TnxObjectIdentity);
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


nxrbTypes.nxReadRoutingPath Function

nxrbTypes.nxReadRoutingPath Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
procedure nxReadRoutingPath(const aReader: InxReader; out aPath: TnxRoutingPath);
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


nxrbTypes.nxRoutingPathFromStatic Function

nxrbTypes.nxRoutingPathFromStatic Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
function nxRoutingPathFromStatic(aLength: Integer; const aStatic: TnxStaticRoutingPath): TnxRoutingPath;
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


nxrbTypes.nxRoutingPathToStatic Function

nxrbTypes.nxRoutingPathToStatic Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
procedure nxRoutingPathToStatic(const aPath: TnxRoutingPath; out aLength: Integer; out aStatic: TnxStaticRoutingPath);
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


nxrbTypes.nxWriteObjectIdentity Function

nxrbTypes.nxWriteObjectIdentity Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
procedure nxWriteObjectIdentity(const aWriter: InxWriter; const aIdentity: TnxObjectIdentity);
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


nxrbTypes.nxWriteRoutingPath Function

nxrbTypes.nxWriteRoutingPath Function
nxrbTypes Functions Send Feedback
Syntax
Delphi
procedure nxWriteRoutingPath(const aWriter: InxWriter; const aPath: TnxRoutingPath);
File

nxrbTypes

Group

Functions

Links
nxrbTypes, Functions


Structs, Records, Enums

Structs, Records, Enums
nxrbTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxrbTypes Namespace

Records
Name | Description
TnxObjectIdentity | This is record nxrbTypes.TnxObjectIdentity.
Links
nxrbTypes Namespace, Legend, Records


nxrbTypes.TnxObjectIdentity Record

nxrbTypes.TnxObjectIdentity Record
nxrbTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxObjectIdentity = record
  oiServerID: TnxGuid;
  oiInstanceID: TnxGuid;
end;
File

nxrbTypes

Description

This is record nxrbTypes.TnxObjectIdentity.

Group

Structs, Records, Enums

Links
nxrbTypes, Structs, Records, Enums


Types

Types
nxrbTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrbTypes Namespace

Types
Name | Description
InxClassActivator | This is type nxrbTypes.InxClassActivator.
TnxRegisterPriority | This is type nxrbTypes.TnxRegisterPriority.
TnxRoutingPath | This is type nxrbTypes.TnxRoutingPath.
TnxStaticProxyIDs | This is type nxrbTypes.TnxStaticProxyIDs.
TnxStaticRoutingPath | This is type nxrbTypes.TnxStaticRoutingPath.
Links
nxrbTypes Namespace, Types


nxrbTypes.InxClassActivator Type

nxrbTypes.InxClassActivator Type
nxrbTypes Types Send Feedback
Syntax
Delphi
InxClassActivator = nxllTypes.InxClassActivator;
File

nxrbTypes

Description

This is type nxrbTypes.InxClassActivator.

Group

Types

Links
nxrbTypes, Types


nxrbTypes.TnxRegisterPriority Type

nxrbTypes.TnxRegisterPriority Type
nxrbTypes Types Send Feedback
Syntax
Delphi
TnxRegisterPriority = -5..5;
File

nxrbTypes

Description

This is type nxrbTypes.TnxRegisterPriority.

Group

Types

Links
nxrbTypes, Types


nxrbTypes.TnxRoutingPath Type

nxrbTypes.TnxRoutingPath Type
nxrbTypes Types Send Feedback
Syntax
Delphi
TnxRoutingPath = array of TnxObjectIdentity;
File

nxrbTypes

Description

This is type nxrbTypes.TnxRoutingPath.

Group

Types

Links
nxrbTypes, Types


nxrbTypes.TnxStaticProxyIDs Type

nxrbTypes.TnxStaticProxyIDs Type
nxrbTypes Types Send Feedback
Syntax
Delphi
TnxStaticProxyIDs = array[0..127] of TnxGuid;
File

nxrbTypes

Description

This is type nxrbTypes.TnxStaticProxyIDs.

Group

Types

Links
nxrbTypes, Types


nxrbTypes.TnxStaticRoutingPath Type

nxrbTypes.TnxStaticRoutingPath Type
nxrbTypes Types Send Feedback
Syntax
Delphi
TnxStaticRoutingPath = array[0..63] of TnxObjectIdentity;
File

nxrbTypes

Description

This is type nxrbTypes.TnxStaticRoutingPath.

Group

Types

Links
nxrbTypes, Types


Variables

Variables
nxrbTypes Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrbTypes Namespace

Variables
Name | Description
nxCurrentServerID | unique guid during the livetime of this process
Links
nxrbTypes Namespace, Variables


nxrbTypes.nxCurrentServerID Variable

nxrbTypes.nxCurrentServerID Variable
nxrbTypes Variables Send Feedback
Syntax
Delphi
nxCurrentServerID: TnxGuid;
File

nxrbTypes

Description

unique guid during the livetime of this process

Group

Variables

Links
nxrbTypes, Variables


Constants

Constants
Constants nxrbTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
IID_InxClassActivator | This is constant nxrbTypes.IID_InxClassActivator.
Namespace

nxrbTypes Namespace

Links
Constants, nxrbTypes Namespace


nxrbTypes.IID_InxClassActivator Constant

nxrbTypes.IID_InxClassActivator Constant
nxrbTypes Constants Send Feedback
Syntax
Delphi
IID_InxClassActivator: TGUID = '{2AF05701-C1AB-4259-BE37-571285940A81}';
File

nxrbTypes

Description

This is constant nxrbTypes.IID_InxClassActivator.

Group

Constants

Links
nxrbTypes, Constants


nxrbVariantFiler Namespace

nxrbVariantFiler Namespace
Constants Functions Legend Topics Types Send Feedback

This is namespace nxrbVariantFiler.

Constants
Name | Description
EasyArrayTypes | This is constant nxrbVariantFiler.EasyArrayTypes.
VariantSize | This is constant nxrbVariantFiler.VariantSize.
Functions
Name | Description
nxGetVariantPointer |
nxReadArray |
nxReadVariant |
nxVarCopyDataByRef |
nxWriteArray |
nxWriteVariant |
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxVarFlags | This is type nxrbVariantFiler.TnxVarFlags.
Links
Constants, Functions, Legend, Topics, Types


Functions

Functions
Functions nxrbVariantFiler Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxGetVariantPointer |
nxReadArray |
nxReadVariant |
nxVarCopyDataByRef |
nxWriteArray |
nxWriteVariant |
Namespace

nxrbVariantFiler Namespace

Links
Functions, nxrbVariantFiler Namespace, Legend


nxrbVariantFiler.nxGetVariantPointer Function

nxrbVariantFiler.nxGetVariantPointer Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
function nxGetVariantPointer(const Value: Variant): Pointer;
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


nxrbVariantFiler.nxReadArray Function

nxrbVariantFiler.nxReadArray Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
function nxReadArray(aVType: Integer; out aValue: Variant; const aReader: InxReader): HRESULT;
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


nxrbVariantFiler.nxReadVariant Function

nxrbVariantFiler.nxReadVariant Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
function nxReadVariant(out aFlags: TnxVarFlags; out aValue: Variant; const aReader: InxReader): HRESULT;
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


nxrbVariantFiler.nxVarCopyDataByRef Function

nxrbVariantFiler.nxVarCopyDataByRef Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
procedure nxVarCopyDataByRef(const Source: TVarData; var Dest: TVarData);
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


nxrbVariantFiler.nxWriteArray Function

nxrbVariantFiler.nxWriteArray Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
function nxWriteArray(const aValue: Variant; const aWriter: InxWriter): HRESULT;
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


nxrbVariantFiler.nxWriteVariant Function

nxrbVariantFiler.nxWriteVariant Function
nxrbVariantFiler Functions Send Feedback
Syntax
Delphi
function nxWriteVariant(const aValue: Variant; const aWriter: InxWriter): HRESULT;
File

nxrbVariantFiler

Group

Functions

Links
nxrbVariantFiler, Functions


Types

Types
nxrbVariantFiler Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrbVariantFiler Namespace

Types
Name | Description
TnxVarFlags | This is type nxrbVariantFiler.TnxVarFlags.
Links
nxrbVariantFiler Namespace, Types


nxrbVariantFiler.TnxVarFlags Type

nxrbVariantFiler.TnxVarFlags Type
nxrbVariantFiler Types Send Feedback
Syntax
Delphi
TnxVarFlags = set of (vfByRef, vfVariant);
File

nxrbVariantFiler

Description

This is type nxrbVariantFiler.TnxVarFlags.

Group

Types

Links
nxrbVariantFiler, Types


Constants

Constants
Constants nxrbVariantFiler Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
EasyArrayTypes | This is constant nxrbVariantFiler.EasyArrayTypes.
VariantSize | This is constant nxrbVariantFiler.VariantSize.
Namespace

nxrbVariantFiler Namespace

Links
Constants, nxrbVariantFiler Namespace


nxrbVariantFiler.EasyArrayTypes Constant

nxrbVariantFiler.EasyArrayTypes Constant
nxrbVariantFiler Constants Send Feedback
Syntax
Delphi
EasyArrayTypes = [varSmallInt, varInteger, varSingle, varDouble, varCurrency, varDate, varBoolean, varShortInt, varByte, varWord, varLongWord, varInt64, varUInt64];
File

nxrbVariantFiler

Description

This is constant nxrbVariantFiler.EasyArrayTypes.

Group

Constants

Links
nxrbVariantFiler, Constants


nxrbVariantFiler.VariantSize Constant

nxrbVariantFiler.VariantSize Constant
nxrbVariantFiler Constants Send Feedback
Syntax
Delphi
VariantSize: array[0..varUInt64] of Word = (0, 0, SizeOf(SmallInt), SizeOf(Integer), SizeOf(Single), SizeOf(Double), SizeOf(Currency), SizeOf(TDateTime), 0, 0, SizeOf(Integer), SizeOf(WordBool), 0, 0, 0, 0, SizeOf(ShortInt), SizeOf(Byte), SizeOf(Word), SizeOf(LongWord), SizeOf(Int64), SizeOf(Int64));
File

nxrbVariantFiler

Description

This is constant nxrbVariantFiler.VariantSize.

Group

Constants

Links
nxrbVariantFiler, Constants


nxrcBaseCommand Namespace

nxrcBaseCommand Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxrcBaseCommand.

Classes
Name | Description
TnxrcBaseCommand | This is class nxrcBaseCommand.TnxrcBaseCommand.
TnxrcEchoCommand | This is class nxrcBaseCommand.TnxrcEchoCommand.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxrcBaseCommandClass | This is type nxrcBaseCommand.TnxrcBaseCommandClass.
Variables
Name | Description
_CommandTypes | This is variable nxrcBaseCommand._CommandTypes.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxrcBaseCommand Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxrcBaseCommand | This is class nxrcBaseCommand.TnxrcBaseCommand.
TnxrcEchoCommand | This is class nxrcBaseCommand.TnxrcEchoCommand.
Namespace

nxrcBaseCommand Namespace

Links
Classes, nxrcBaseCommand Namespace, Legend


TnxrcBaseCommand Class

TnxrcBaseCommand Class
TnxrcBaseCommand Fields TnxrcBaseCommand Methods TnxrcBaseCommand Properties TnxrcBaseCommand Members nxrcBaseCommand Classes Send Feedback
Class Hierarchy
nxrcBaseCommand_TnxrcBaseCommandnxrcBaseCommand_TnxrcBaseCommand
Syntax
Delphi
TnxrcBaseCommand = class(TnxObject);
File

nxrcBaseCommand

Description

This is class nxrcBaseCommand.TnxrcBaseCommand.

Group

Classes

Links
TnxrcBaseCommand Fields, TnxrcBaseCommand Methods, TnxrcBaseCommand Properties, TnxrcBaseCommand Members, nxrcBaseCommand, Classes


TnxrcBaseCommand Members

TnxrcBaseCommand Members
TnxrcBaseCommand Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxrcBaseCommand.

Class

TnxrcBaseCommand Class

Protected Fields
Name | Description
bcOptions | This is bcOptions, a member of class TnxrcBaseCommand.
bcOutput | This is bcOutput, a member of class TnxrcBaseCommand.
Public Methods
Name | Description
Block | TnxrcBaseCommand
Create | This is Create, a member of class TnxrcBaseCommand.
Destroy | This is Destroy, a member of class TnxrcBaseCommand.
Execute | This is Execute, a member of class TnxrcBaseCommand.
FindCommand | This is FindCommand, a member of class TnxrcBaseCommand.
FreeInstance |
NewInstance | TnxObject
Register | This is Register, a member of class TnxrcBaseCommand.
Public Properties
Name | Description
Options | This is Options, a member of class TnxrcBaseCommand.
Output | This is Output, a member of class TnxrcBaseCommand.
Links
TnxrcBaseCommand Class, Legend, Protected Fields, Public Methods, Public Properties


TnxrcBaseCommand.Create Constructor

TnxrcBaseCommand.Create Constructor
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Class Send Feedback
Syntax
Delphi
constructor Create; virtual;
Description

This is Create, a member of class TnxrcBaseCommand.

Class

TnxrcBaseCommand Class

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Class


TnxrcBaseCommand.Destroy Destructor

TnxrcBaseCommand.Destroy Destructor
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxrcBaseCommand.

Class

TnxrcBaseCommand Class

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Class


TnxrcBaseCommand Fields

TnxrcBaseCommand Fields
TnxrcBaseCommand Class Legend Protected Fields Send Feedback

The fields of the TnxrcBaseCommand class are listed here.

Class

TnxrcBaseCommand Class

Protected Fields
Name | Description
bcOptions | This is bcOptions, a member of class TnxrcBaseCommand.
bcOutput | This is bcOutput, a member of class TnxrcBaseCommand.
Links
TnxrcBaseCommand Class, Legend, Protected Fields


TnxrcBaseCommand.bcOptions Field

TnxrcBaseCommand.bcOptions Field
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Fields Send Feedback
Syntax
Delphi
bcOptions: TStrings;
Description

This is bcOptions, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Fields

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Fields


TnxrcBaseCommand.bcOutput Field

TnxrcBaseCommand.bcOutput Field
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Fields Send Feedback
Syntax
Delphi
bcOutput: TnxSimpleOutputCache;
Description

This is bcOutput, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Fields

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Fields


TnxrcBaseCommand Methods

TnxrcBaseCommand Methods
TnxrcBaseCommand Class Legend Public Methods Send Feedback

The methods of the TnxrcBaseCommand class are listed here.

Class

TnxrcBaseCommand Class

Public Methods
Name | Description
Block | TnxrcBaseCommand
Execute | This is Execute, a member of class TnxrcBaseCommand.
FindCommand | This is FindCommand, a member of class TnxrcBaseCommand.
Register | This is Register, a member of class TnxrcBaseCommand.
Links
TnxrcBaseCommand Class, Legend, Public Methods


TnxrcBaseCommand.Block Method

TnxrcBaseCommand.Block Method
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Methods Send Feedback
Syntax
Delphi
class function Block: Boolean; virtual;
Description

TnxrcBaseCommand

Group

TnxrcBaseCommand Methods

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Methods


TnxrcBaseCommand.Execute Method

TnxrcBaseCommand.Execute Method
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Methods Send Feedback
Syntax
Delphi
procedure Execute(const aCommand: string; const aParams: string; out aErrorCode: Integer; out aErrorMessage: string); virtual; abstract;
Description

This is Execute, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Methods

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Methods


TnxrcBaseCommand.FindCommand Method

TnxrcBaseCommand.FindCommand Method
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Methods Send Feedback
Syntax
Delphi
class function FindCommand(const aDescriptor: string): TnxrcBaseCommandClass;
Description

This is FindCommand, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Methods

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Methods


TnxrcBaseCommand.Register Method

TnxrcBaseCommand.Register Method
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Methods Send Feedback
Syntax
Delphi
class procedure Register(const aDescriptor: string);
Description

This is Register, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Methods

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Methods


TnxrcBaseCommand Properties

TnxrcBaseCommand Properties
TnxrcBaseCommand Class Legend Public Properties Send Feedback

The properties of the TnxrcBaseCommand class are listed here.

Class

TnxrcBaseCommand Class

Public Properties
Name | Description
Options | This is Options, a member of class TnxrcBaseCommand.
Output | This is Output, a member of class TnxrcBaseCommand.
Links
TnxrcBaseCommand Class, Legend, Public Properties


TnxrcBaseCommand.Options Property

TnxrcBaseCommand.Options Property
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Properties Send Feedback
Syntax
Delphi
property Options: TStrings;
Description

This is Options, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Properties

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Properties


TnxrcBaseCommand.Output Property

TnxrcBaseCommand.Output Property
TnxrcBaseCommand Class TnxrcBaseCommand Members nxrcBaseCommand Namespace TnxrcBaseCommand Properties Send Feedback
Syntax
Delphi
property Output: TnxSimpleOutputCache;
Description

This is Output, a member of class TnxrcBaseCommand.

Group

TnxrcBaseCommand Properties

Links
TnxrcBaseCommand Class, TnxrcBaseCommand Members, nxrcBaseCommand Namespace, TnxrcBaseCommand Properties


TnxrcEchoCommand Class

TnxrcEchoCommand Class
TnxrcEchoCommand Methods TnxrcEchoCommand Members nxrcBaseCommand Classes Send Feedback
Class Hierarchy
nxrcBaseCommand_TnxrcEchoCommandnxrcBaseCommand_TnxrcEchoCommandnxrcBaseCommand_TnxrcEchoCommand
Syntax
Delphi
TnxrcEchoCommand = class(TnxrcBaseCommand);
File

nxrcBaseCommand

Description

This is class nxrcBaseCommand.TnxrcEchoCommand.

Group

Classes

Links
TnxrcEchoCommand Methods, TnxrcEchoCommand Members, nxrcBaseCommand, Classes


TnxrcEchoCommand Members

TnxrcEchoCommand Members
TnxrcEchoCommand Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxrcEchoCommand.

Class

TnxrcEchoCommand Class

Protected Fields
Name | Description
bcOptions | This is bcOptions, a member of class TnxrcBaseCommand.
bcOutput | This is bcOutput, a member of class TnxrcBaseCommand.
Public Methods
Name | Description
Block | TnxrcBaseCommand
Create | This is Create, a member of class TnxrcBaseCommand.
Destroy | This is Destroy, a member of class TnxrcBaseCommand.
Execute | TnxrcEchoCommand
FindCommand | This is FindCommand, a member of class TnxrcBaseCommand.
FreeInstance |
NewInstance | TnxObject
Register | This is Register, a member of class TnxrcBaseCommand.
Public Properties
Name | Description
Options | This is Options, a member of class TnxrcBaseCommand.
Output | This is Output, a member of class TnxrcBaseCommand.
Links
TnxrcEchoCommand Class, Legend, Protected Fields, Public Methods, Public Properties


TnxrcEchoCommand Methods

TnxrcEchoCommand Methods
TnxrcEchoCommand Class Legend Public Methods Send Feedback

The methods of the TnxrcEchoCommand class are listed here.

Class

TnxrcEchoCommand Class

Public Methods
Name | Description
Execute | TnxrcEchoCommand
Links
TnxrcEchoCommand Class, Legend, Public Methods


TnxrcEchoCommand.Execute Method

TnxrcEchoCommand.Execute Method
TnxrcEchoCommand Class TnxrcEchoCommand Members nxrcBaseCommand Namespace TnxrcEchoCommand Methods Send Feedback
Syntax
Delphi
procedure Execute(const aCommand: string; const aParams: string; out aErrorCode: Integer; out aErrorMessage: string); override;
Description

TnxrcEchoCommand

Group

TnxrcEchoCommand Methods

Links
TnxrcEchoCommand Class, TnxrcEchoCommand Members, nxrcBaseCommand Namespace, TnxrcEchoCommand Methods


Types

Types
nxrcBaseCommand Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrcBaseCommand Namespace

Types
Name | Description
TnxrcBaseCommandClass | This is type nxrcBaseCommand.TnxrcBaseCommandClass.
Links
nxrcBaseCommand Namespace, Types


nxrcBaseCommand.TnxrcBaseCommandClass Type

nxrcBaseCommand.TnxrcBaseCommandClass Type
nxrcBaseCommand Types Send Feedback
Syntax
Delphi
TnxrcBaseCommandClass = class of TnxrcBaseCommand;
File

nxrcBaseCommand

Description

This is type nxrcBaseCommand.TnxrcBaseCommandClass.

Group

Types

Links
nxrcBaseCommand, Types


Variables

Variables
nxrcBaseCommand Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrcBaseCommand Namespace

Variables
Name | Description
_CommandTypes | This is variable nxrcBaseCommand._CommandTypes.
Links
nxrcBaseCommand Namespace, Variables


nxrcBaseCommand._CommandTypes Variable

nxrcBaseCommand._CommandTypes Variable
nxrcBaseCommand Variables Send Feedback
Syntax
Delphi
_CommandTypes: TStringlist;
File

nxrcBaseCommand

Description

This is variable nxrcBaseCommand._CommandTypes.

Group

Variables

Links
nxrcBaseCommand, Variables


nxrcRemoteCommandsPluginBase Namespace

nxrcRemoteCommandsPluginBase Namespace
Classes Legend Topics Send Feedback

This is namespace nxrcRemoteCommandsPluginBase.

Classes
Name | Description
EnxBaseRemoteCommandsPluginException | This is class nxrcRemoteCommandsPluginBase.EnxBaseRemoteCommandsPluginException.
TnxBaseRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginBase.TnxBaseRemoteCommandsPlugin.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrcRemoteCommandsPluginBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseRemoteCommandsPluginException | This is class nxrcRemoteCommandsPluginBase.EnxBaseRemoteCommandsPluginException.
TnxBaseRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginBase.TnxBaseRemoteCommandsPlugin.
Namespace

nxrcRemoteCommandsPluginBase Namespace

Links
Classes, nxrcRemoteCommandsPluginBase Namespace, Legend


EnxBaseRemoteCommandsPluginException Class

EnxBaseRemoteCommandsPluginException Class
nxrcRemoteCommandsPluginBase Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginBase_EnxBaseRemoteCommandsPluginException
Syntax
Delphi
EnxBaseRemoteCommandsPluginException = class(EnxPluginEngineException);
File

nxrcRemoteCommandsPluginBase

Description

This is class nxrcRemoteCommandsPluginBase.EnxBaseRemoteCommandsPluginException.

Group

Classes

Links
nxrcRemoteCommandsPluginBase, Classes


TnxBaseRemoteCommandsPlugin Class

TnxBaseRemoteCommandsPlugin Class
TnxBaseRemoteCommandsPlugin Methods TnxBaseRemoteCommandsPlugin Members nxrcRemoteCommandsPluginBase Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPluginnxrcRemoteCommandsPluginBase_TnxBaseRemoteCommandsPlugin
Syntax
Delphi
TnxBaseRemoteCommandsPlugin = class(TnxBasePluginEngine);
File

nxrcRemoteCommandsPluginBase

Description

This is class nxrcRemoteCommandsPluginBase.TnxBaseRemoteCommandsPlugin.

Group

Classes

Links
TnxBaseRemoteCommandsPlugin Methods, TnxBaseRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginBase, Classes


TnxBaseRemoteCommandsPlugin Members

TnxBaseRemoteCommandsPlugin Members
TnxBaseRemoteCommandsPlugin Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseRemoteCommandsPlugin.

Class

TnxBaseRemoteCommandsPlugin Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxBasePluginEngine
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
ExecCommand | This is ExecCommand, a member of class TnxBaseRemoteCommandsPlugin.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBaseRemoteCommandsPlugin Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxBaseRemoteCommandsPlugin Methods

TnxBaseRemoteCommandsPlugin Methods
TnxBaseRemoteCommandsPlugin Class Legend Public Methods Send Feedback

The methods of the TnxBaseRemoteCommandsPlugin class are listed here.

Class

TnxBaseRemoteCommandsPlugin Class

Public Methods
Name | Description
ExecCommand | This is ExecCommand, a member of class TnxBaseRemoteCommandsPlugin.
Links
TnxBaseRemoteCommandsPlugin Class, Legend, Public Methods


TnxBaseRemoteCommandsPlugin.ExecCommand Method

TnxBaseRemoteCommandsPlugin.ExecCommand Method
TnxBaseRemoteCommandsPlugin Class TnxBaseRemoteCommandsPlugin Members nxrcRemoteCommandsPluginBase Namespace TnxBaseRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
function ExecCommand(const aCommandType: string; const aCommand: string; const aCmdLine: string; out aErrorCode: Integer; out aErrorString: string; out aTask: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This is ExecCommand, a member of class TnxBaseRemoteCommandsPlugin.

Group

TnxBaseRemoteCommandsPlugin Methods

Links
TnxBaseRemoteCommandsPlugin Class, TnxBaseRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginBase Namespace, TnxBaseRemoteCommandsPlugin Methods


nxrcRemoteCommandsPluginClient Namespace

nxrcRemoteCommandsPluginClient Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxrcRemoteCommandsPluginClient.

Classes
Name | Description
EnxRemoteRemoteCommandsPluginException | This is class nxrcRemoteCommandsPluginClient.EnxRemoteRemoteCommandsPluginException.
TnxRemoteRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginClient.TnxRemoteRemoteCommandsPlugin.
Constants
Name | Description
rsConnectionDidNotSupport | This is constant nxrcRemoteCommandsPluginClient.rsConnectionDidNotSupport.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxrcRemoteCommandsPluginClient Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxRemoteRemoteCommandsPluginException | This is class nxrcRemoteCommandsPluginClient.EnxRemoteRemoteCommandsPluginException.
TnxRemoteRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginClient.TnxRemoteRemoteCommandsPlugin.
Namespace

nxrcRemoteCommandsPluginClient Namespace

Links
Classes, nxrcRemoteCommandsPluginClient Namespace, Legend


EnxRemoteRemoteCommandsPluginException Class

EnxRemoteRemoteCommandsPluginException Class
nxrcRemoteCommandsPluginClient Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginExceptionnxrcRemoteCommandsPluginClient_EnxRemoteRemoteCommandsPluginException
Syntax
Delphi
EnxRemoteRemoteCommandsPluginException = class(EnxBaseRemoteCommandsPluginException);
File

nxrcRemoteCommandsPluginClient

Description

This is class nxrcRemoteCommandsPluginClient.EnxRemoteRemoteCommandsPluginException.

Group

Classes

Links
nxrcRemoteCommandsPluginClient, Classes


TnxRemoteRemoteCommandsPlugin Class

TnxRemoteRemoteCommandsPlugin Class
TnxRemoteRemoteCommandsPlugin Methods TnxRemoteRemoteCommandsPlugin Properties TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPluginnxrcRemoteCommandsPluginClient_TnxRemoteRemoteCommandsPlugin
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemoteRemoteCommandsPlugin = class(TnxBaseRemoteCommandsPlugin);
File

nxrcRemoteCommandsPluginClient

Description

This is class nxrcRemoteCommandsPluginClient.TnxRemoteRemoteCommandsPlugin.

Group

Classes

Links
TnxRemoteRemoteCommandsPlugin Methods, TnxRemoteRemoteCommandsPlugin Properties, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient, Classes


TnxRemoteRemoteCommandsPlugin Members

TnxRemoteRemoteCommandsPlugin Members
TnxRemoteRemoteCommandsPlugin Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemoteRemoteCommandsPlugin.

Class

TnxRemoteRemoteCommandsPlugin Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxRemoteRemoteCommandsPlugin
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRemoteTaskInfo |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
ExecCommand |
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Session | This is Session, a member of class TnxRemoteRemoteCommandsPlugin.
Timeout | This is Timeout, a member of class TnxRemoteRemoteCommandsPlugin.
Version | Version of the component.
Links
TnxRemoteRemoteCommandsPlugin Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemoteRemoteCommandsPlugin Methods

TnxRemoteRemoteCommandsPlugin Methods
TnxRemoteRemoteCommandsPlugin Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteRemoteCommandsPlugin class are listed here.

Class

TnxRemoteRemoteCommandsPlugin Class

Protected Methods
Name | Description
bpeIsRemote | TnxRemoteRemoteCommandsPlugin
CreateRemoteTaskInfo |
Public Methods
Name | Description
ExecCommand |
Links
TnxRemoteRemoteCommandsPlugin Class, Legend, Protected Methods, Public Methods


TnxRemoteRemoteCommandsPlugin.bpeIsRemote Method

TnxRemoteRemoteCommandsPlugin.bpeIsRemote Method
TnxRemoteRemoteCommandsPlugin Class TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Namespace TnxRemoteRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
class function bpeIsRemote: Boolean; override;
Description

TnxRemoteRemoteCommandsPlugin

Group

TnxRemoteRemoteCommandsPlugin Methods

Links
TnxRemoteRemoteCommandsPlugin Class, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient Namespace, TnxRemoteRemoteCommandsPlugin Methods


TnxRemoteRemoteCommandsPlugin.CreateRemoteTaskInfo Method

TnxRemoteRemoteCommandsPlugin.CreateRemoteTaskInfo Method
TnxRemoteRemoteCommandsPlugin Class TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Namespace TnxRemoteRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
function CreateRemoteTaskInfo(const aTaskID: TnxTaskID): TnxAbstractTaskInfo;
Group

TnxRemoteRemoteCommandsPlugin Methods

Links
TnxRemoteRemoteCommandsPlugin Class, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient Namespace, TnxRemoteRemoteCommandsPlugin Methods


TnxRemoteRemoteCommandsPlugin.ExecCommand Method

TnxRemoteRemoteCommandsPlugin.ExecCommand Method
TnxRemoteRemoteCommandsPlugin Class TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Namespace TnxRemoteRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
function ExecCommand(const aCommandType: string; const aCommand: string; const aCmdLine: string; out aErrorCode: Integer; out aErrorString: string; out aTask: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteRemoteCommandsPlugin Methods

Links
TnxRemoteRemoteCommandsPlugin Class, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient Namespace, TnxRemoteRemoteCommandsPlugin Methods


TnxRemoteRemoteCommandsPlugin Properties

TnxRemoteRemoteCommandsPlugin Properties
TnxRemoteRemoteCommandsPlugin Class Legend Published Properties Send Feedback

The properties of the TnxRemoteRemoteCommandsPlugin class are listed here.

Class

TnxRemoteRemoteCommandsPlugin Class

Published Properties
Name | Description
Session | This is Session, a member of class TnxRemoteRemoteCommandsPlugin.
Timeout | This is Timeout, a member of class TnxRemoteRemoteCommandsPlugin.
Links
TnxRemoteRemoteCommandsPlugin Class, Legend, Published Properties


TnxRemoteRemoteCommandsPlugin.Session Property

TnxRemoteRemoteCommandsPlugin.Session Property
TnxRemoteRemoteCommandsPlugin Class TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Namespace TnxRemoteRemoteCommandsPlugin Properties Send Feedback
Syntax
Delphi
property Session: TnxStateComponent;
Description

This is Session, a member of class TnxRemoteRemoteCommandsPlugin.

Group

TnxRemoteRemoteCommandsPlugin Properties

Links
TnxRemoteRemoteCommandsPlugin Class, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient Namespace, TnxRemoteRemoteCommandsPlugin Properties


TnxRemoteRemoteCommandsPlugin.Timeout Property

TnxRemoteRemoteCommandsPlugin.Timeout Property
TnxRemoteRemoteCommandsPlugin Class TnxRemoteRemoteCommandsPlugin Members nxrcRemoteCommandsPluginClient Namespace TnxRemoteRemoteCommandsPlugin Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

This is Timeout, a member of class TnxRemoteRemoteCommandsPlugin.

Group

TnxRemoteRemoteCommandsPlugin Properties

Links
TnxRemoteRemoteCommandsPlugin Class, TnxRemoteRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginClient Namespace, TnxRemoteRemoteCommandsPlugin Properties


Constants

Constants
Constants nxrcRemoteCommandsPluginClient Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsConnectionDidNotSupport | This is constant nxrcRemoteCommandsPluginClient.rsConnectionDidNotSupport.
Namespace

nxrcRemoteCommandsPluginClient Namespace

Links
Constants, nxrcRemoteCommandsPluginClient Namespace


nxrcRemoteCommandsPluginClient.rsConnectionDidNotSupport Constant

nxrcRemoteCommandsPluginClient.rsConnectionDidNotSupport Constant
nxrcRemoteCommandsPluginClient Constants Send Feedback
Syntax
Delphi
rsConnectionDidNotSupport = 'Connection did not support creation of a remo' + 'te task info';
File

nxrcRemoteCommandsPluginClient

Description

This is constant nxrcRemoteCommandsPluginClient.rsConnectionDidNotSupport.

Group

Constants

Links
nxrcRemoteCommandsPluginClient, Constants


nxrcRemoteCommandsPluginCommandHandler Namespace

nxrcRemoteCommandsPluginCommandHandler Namespace
Classes Legend Topics Send Feedback

This is namespace nxrcRemoteCommandsPluginCommandHandler.

Classes
Name | Description
TnxRemoteCommandsPluginCommandHandler | This is class nxrcRemoteCommandsPluginCommandHandler.TnxRemoteCommandsPluginCommandHandler.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrcRemoteCommandsPluginCommandHandler Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRemoteCommandsPluginCommandHandler | This is class nxrcRemoteCommandsPluginCommandHandler.TnxRemoteCommandsPluginCommandHandler.
Namespace

nxrcRemoteCommandsPluginCommandHandler Namespace

Links
Classes, nxrcRemoteCommandsPluginCommandHandler Namespace, Legend


TnxRemoteCommandsPluginCommandHandler Class

TnxRemoteCommandsPluginCommandHandler Class
TnxRemoteCommandsPluginCommandHandler Methods TnxRemoteCommandsPluginCommandHandler Properties TnxRemoteCommandsPluginCommandHandler Members nxrcRemoteCommandsPluginCommandHandler Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandlernxrcRemoteCommandsPluginCommandHandler_TnxRemoteCommandsPluginCommandHandler
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemoteCommandsPluginCommandHandler = class(TnxBasePluginCommandHandler);
File

nxrcRemoteCommandsPluginCommandHandler

Description

This is class nxrcRemoteCommandsPluginCommandHandler.TnxRemoteCommandsPluginCommandHandler.

Group

Classes

Links
TnxRemoteCommandsPluginCommandHandler Methods, TnxRemoteCommandsPluginCommandHandler Properties, TnxRemoteCommandsPluginCommandHandler Members, nxrcRemoteCommandsPluginCommandHandler, Classes


TnxRemoteCommandsPluginCommandHandler Members

TnxRemoteCommandsPluginCommandHandler Members
TnxRemoteCommandsPluginCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemoteCommandsPluginCommandHandler.

Class

TnxRemoteCommandsPluginCommandHandler Class

Protected Fields
Name | Description
bpchCmdHandler | private.
bpchPluginEngine | This is bpchPluginEngine, a member of class TnxBasePluginCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpchAddSession | TnxBasePluginCommandHandler
bpchRemoveSession |
bpchSessionFailed |
bpchSetCmdHandler |
bpchSetPluginEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nmRemoteRemoteCommand |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
bpchProcess | TnxRemoteCommandsPluginCommandHandler
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UISettingsVisible | This function always returns false, cause the settings should never be visible in the GUI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CommandHandler | This is the main command handler the plugin command handler is attached to.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
PluginEngine | This is PluginEngine, a member of class TnxRemoteCommandsPluginCommandHandler.
Version | Version of the component.
Links
TnxRemoteCommandsPluginCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemoteCommandsPluginCommandHandler Methods

TnxRemoteCommandsPluginCommandHandler Methods
TnxRemoteCommandsPluginCommandHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteCommandsPluginCommandHandler class are listed here.

Class

TnxRemoteCommandsPluginCommandHandler Class

Protected Methods
Name | Description
nmRemoteRemoteCommand |
Public Methods
Name | Description
bpchProcess | TnxRemoteCommandsPluginCommandHandler
Links
TnxRemoteCommandsPluginCommandHandler Class, Legend, Protected Methods, Public Methods


TnxRemoteCommandsPluginCommandHandler.bpchProcess Method

TnxRemoteCommandsPluginCommandHandler.bpchProcess Method
TnxRemoteCommandsPluginCommandHandler Class TnxRemoteCommandsPluginCommandHandler Members nxrcRemoteCommandsPluginCommandHandler Namespace TnxRemoteCommandsPluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchProcess(aMsg: PnxDataMessage; var aHandled: Boolean); override;
Description

TnxRemoteCommandsPluginCommandHandler

Group

TnxRemoteCommandsPluginCommandHandler Methods

Links
TnxRemoteCommandsPluginCommandHandler Class, TnxRemoteCommandsPluginCommandHandler Members, nxrcRemoteCommandsPluginCommandHandler Namespace, TnxRemoteCommandsPluginCommandHandler Methods


TnxRemoteCommandsPluginCommandHandler.nmRemoteRemoteCommand Method

TnxRemoteCommandsPluginCommandHandler.nmRemoteRemoteCommand Method
TnxRemoteCommandsPluginCommandHandler Class TnxRemoteCommandsPluginCommandHandler Members nxrcRemoteCommandsPluginCommandHandler Namespace TnxRemoteCommandsPluginCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmRemoteRemoteCommand(var Msg: TnxDataMessage);
Group

TnxRemoteCommandsPluginCommandHandler Methods

Links
TnxRemoteCommandsPluginCommandHandler Class, TnxRemoteCommandsPluginCommandHandler Members, nxrcRemoteCommandsPluginCommandHandler Namespace, TnxRemoteCommandsPluginCommandHandler Methods


TnxRemoteCommandsPluginCommandHandler Properties

TnxRemoteCommandsPluginCommandHandler Properties
TnxRemoteCommandsPluginCommandHandler Class Legend Published Properties Send Feedback

The properties of the TnxRemoteCommandsPluginCommandHandler class are listed here.

Class

TnxRemoteCommandsPluginCommandHandler Class

Published Properties
Name | Description
PluginEngine | This is PluginEngine, a member of class TnxRemoteCommandsPluginCommandHandler.
Links
TnxRemoteCommandsPluginCommandHandler Class, Legend, Published Properties


TnxRemoteCommandsPluginCommandHandler.PluginEngine Property

TnxRemoteCommandsPluginCommandHandler.PluginEngine Property
TnxRemoteCommandsPluginCommandHandler Class TnxRemoteCommandsPluginCommandHandler Members nxrcRemoteCommandsPluginCommandHandler Namespace TnxRemoteCommandsPluginCommandHandler Properties Send Feedback
Syntax
Delphi
property PluginEngine: TnxBaseRemoteCommandsPlugin;
Description

This is PluginEngine, a member of class TnxRemoteCommandsPluginCommandHandler.

Group

TnxRemoteCommandsPluginCommandHandler Properties

Links
TnxRemoteCommandsPluginCommandHandler Class, TnxRemoteCommandsPluginCommandHandler Members, nxrcRemoteCommandsPluginCommandHandler Namespace, TnxRemoteCommandsPluginCommandHandler Properties


nxrcRemoteCommandsPluginMessages Namespace

nxrcRemoteCommandsPluginMessages Namespace
Constants Topics Send Feedback

This is namespace nxrcRemoteCommandsPluginMessages.

Constants
Name | Description
nxnmRemoteCommand | This is constant nxrcRemoteCommandsPluginMessages.nxnmRemoteCommand.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxrcRemoteCommandsPluginMessages Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxnmRemoteCommand | This is constant nxrcRemoteCommandsPluginMessages.nxnmRemoteCommand.
Namespace

nxrcRemoteCommandsPluginMessages Namespace

Links
Constants, nxrcRemoteCommandsPluginMessages Namespace


nxrcRemoteCommandsPluginMessages.nxnmRemoteCommand Constant

nxrcRemoteCommandsPluginMessages.nxnmRemoteCommand Constant
nxrcRemoteCommandsPluginMessages Constants Send Feedback
Syntax
Delphi
nxnmRemoteCommand = $0A00;
File

nxrcRemoteCommandsPluginMessages

Description

This is constant nxrcRemoteCommandsPluginMessages.nxnmRemoteCommand.

Group

Constants

Links
nxrcRemoteCommandsPluginMessages, Constants


nxrcRemoteCommandsPluginServer Namespace

nxrcRemoteCommandsPluginServer Namespace
Classes Legend Topics Send Feedback

This is namespace nxrcRemoteCommandsPluginServer.

Classes
Name | Description
TnxServerRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandsPlugin.
TnxServerRemoteCommandTaskInfo | This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandTaskInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrcRemoteCommandsPluginServer Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxServerRemoteCommandsPlugin | This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandsPlugin.
TnxServerRemoteCommandTaskInfo | This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandTaskInfo.
Namespace

nxrcRemoteCommandsPluginServer Namespace

Links
Classes, nxrcRemoteCommandsPluginServer Namespace, Legend


TnxServerRemoteCommandsPlugin Class

TnxServerRemoteCommandsPlugin Class
TnxServerRemoteCommandsPlugin Fields TnxServerRemoteCommandsPlugin Methods TnxServerRemoteCommandsPlugin Properties TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPluginnxrcRemoteCommandsPluginServer_TnxServerRemoteCommandsPlugin
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxServerRemoteCommandsPlugin = class(TnxBaseRemoteCommandsPlugin);
File

nxrcRemoteCommandsPluginServer

Description

This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandsPlugin.

Group

Classes

Links
TnxServerRemoteCommandsPlugin Fields, TnxServerRemoteCommandsPlugin Methods, TnxServerRemoteCommandsPlugin Properties, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer, Classes


TnxServerRemoteCommandsPlugin Members

TnxServerRemoteCommandsPlugin Members
TnxServerRemoteCommandsPlugin Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxServerRemoteCommandsPlugin.

Class

TnxServerRemoteCommandsPlugin Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
srcpAllowedIP | This is srcpAllowedIP, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowedTransports | This is srcpAllowedTransports, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowIP | This is srcpAllowIP, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowTransport | This is srcpAllowTransport, a member of class TnxServerRemoteCommandsPlugin.
srcpScriptDir | private
Protected Methods
Name | Description
bpeIsRemote | TnxServerRemoteCommandsPlugin
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
srcpGetCurrentSession |
srcpSetAllowIP |
srcpSetAllowTransport |
Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
ExecCommand |
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
AllowIP | This is AllowIP, a member of class TnxServerRemoteCommandsPlugin.
AllowTransport | This is AllowTransport, a member of class TnxServerRemoteCommandsPlugin.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ScriptDir | This is ScriptDir, a member of class TnxServerRemoteCommandsPlugin.
Version | Version of the component.
Links
TnxServerRemoteCommandsPlugin Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxServerRemoteCommandsPlugin.Create Constructor

TnxServerRemoteCommandsPlugin.Create Constructor
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxServerRemoteCommandsPlugin Class

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Class


TnxServerRemoteCommandsPlugin.Destroy Destructor

TnxServerRemoteCommandsPlugin.Destroy Destructor
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxServerRemoteCommandsPlugin Class

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Class


TnxServerRemoteCommandsPlugin Fields

TnxServerRemoteCommandsPlugin Fields
TnxServerRemoteCommandsPlugin Class Legend Protected Fields Send Feedback

The fields of the TnxServerRemoteCommandsPlugin class are listed here.

Class

TnxServerRemoteCommandsPlugin Class

Protected Fields
Name | Description
srcpAllowedIP | This is srcpAllowedIP, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowedTransports | This is srcpAllowedTransports, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowIP | This is srcpAllowIP, a member of class TnxServerRemoteCommandsPlugin.
srcpAllowTransport | This is srcpAllowTransport, a member of class TnxServerRemoteCommandsPlugin.
srcpScriptDir | private
Links
TnxServerRemoteCommandsPlugin Class, Legend, Protected Fields


TnxServerRemoteCommandsPlugin.srcpAllowedIP Field

TnxServerRemoteCommandsPlugin.srcpAllowedIP Field
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Fields Send Feedback
Syntax
Delphi
srcpAllowedIP: TStringList;
Description

This is srcpAllowedIP, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Fields

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Fields


TnxServerRemoteCommandsPlugin.srcpAllowedTransports Field

TnxServerRemoteCommandsPlugin.srcpAllowedTransports Field
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Fields Send Feedback
Syntax
Delphi
srcpAllowedTransports: TStringList;
Description

This is srcpAllowedTransports, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Fields

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Fields


TnxServerRemoteCommandsPlugin.srcpAllowIP Field

TnxServerRemoteCommandsPlugin.srcpAllowIP Field
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Fields Send Feedback
Syntax
Delphi
srcpAllowIP: string;
Description

This is srcpAllowIP, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Fields

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Fields


TnxServerRemoteCommandsPlugin.srcpAllowTransport Field

TnxServerRemoteCommandsPlugin.srcpAllowTransport Field
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Fields Send Feedback
Syntax
Delphi
srcpAllowTransport: string;
Description

This is srcpAllowTransport, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Fields

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Fields


TnxServerRemoteCommandsPlugin.srcpScriptDir Field

TnxServerRemoteCommandsPlugin.srcpScriptDir Field
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Fields Send Feedback
Syntax
Delphi
srcpScriptDir: string;
Description

private

Group

TnxServerRemoteCommandsPlugin Fields

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Fields


TnxServerRemoteCommandsPlugin Methods

TnxServerRemoteCommandsPlugin Methods
TnxServerRemoteCommandsPlugin Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxServerRemoteCommandsPlugin class are listed here.

Class

TnxServerRemoteCommandsPlugin Class

Protected Methods
Name | Description
bpeIsRemote | TnxServerRemoteCommandsPlugin
srcpGetCurrentSession |
srcpSetAllowIP |
srcpSetAllowTransport |
Public Methods
Name | Description
ExecCommand |
GetConfigSettings |
LoadConfig |
SaveConfig |
Links
TnxServerRemoteCommandsPlugin Class, Legend, Protected Methods, Public Methods


TnxServerRemoteCommandsPlugin.bpeIsRemote Method

TnxServerRemoteCommandsPlugin.bpeIsRemote Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
class function bpeIsRemote: Boolean; override;
Description

TnxServerRemoteCommandsPlugin

Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.ExecCommand Method

TnxServerRemoteCommandsPlugin.ExecCommand Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
function ExecCommand(const aCommandType: string; const aCommand: string; const aCmdLine: string; out aErrorCode: Integer; out aErrorString: string; out aTask: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.GetConfigSettings Method

TnxServerRemoteCommandsPlugin.GetConfigSettings Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.LoadConfig Method

TnxServerRemoteCommandsPlugin.LoadConfig Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.SaveConfig Method

TnxServerRemoteCommandsPlugin.SaveConfig Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.srcpGetCurrentSession Method

TnxServerRemoteCommandsPlugin.srcpGetCurrentSession Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
function srcpGetCurrentSession(out aSession: TnxServerSession): Boolean;
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.srcpSetAllowIP Method

TnxServerRemoteCommandsPlugin.srcpSetAllowIP Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
procedure srcpSetAllowIP(const Value: string);
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin.srcpSetAllowTransport Method

TnxServerRemoteCommandsPlugin.srcpSetAllowTransport Method
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Methods Send Feedback
Syntax
Delphi
procedure srcpSetAllowTransport(const Value: string);
Group

TnxServerRemoteCommandsPlugin Methods

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Methods


TnxServerRemoteCommandsPlugin Properties

TnxServerRemoteCommandsPlugin Properties
TnxServerRemoteCommandsPlugin Class Legend Published Properties Send Feedback

The properties of the TnxServerRemoteCommandsPlugin class are listed here.

Class

TnxServerRemoteCommandsPlugin Class

Published Properties
Name | Description
AllowIP | This is AllowIP, a member of class TnxServerRemoteCommandsPlugin.
AllowTransport | This is AllowTransport, a member of class TnxServerRemoteCommandsPlugin.
ScriptDir | This is ScriptDir, a member of class TnxServerRemoteCommandsPlugin.
Links
TnxServerRemoteCommandsPlugin Class, Legend, Published Properties


TnxServerRemoteCommandsPlugin.AllowIP Property

TnxServerRemoteCommandsPlugin.AllowIP Property
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Properties Send Feedback
Syntax
Delphi
property AllowIP: string;
Description

This is AllowIP, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Properties

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Properties


TnxServerRemoteCommandsPlugin.AllowTransport Property

TnxServerRemoteCommandsPlugin.AllowTransport Property
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Properties Send Feedback
Syntax
Delphi
property AllowTransport: string;
Description

This is AllowTransport, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Properties

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Properties


TnxServerRemoteCommandsPlugin.ScriptDir Property

TnxServerRemoteCommandsPlugin.ScriptDir Property
TnxServerRemoteCommandsPlugin Class TnxServerRemoteCommandsPlugin Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandsPlugin Properties Send Feedback
Syntax
Delphi
property ScriptDir: string;
Description

This is ScriptDir, a member of class TnxServerRemoteCommandsPlugin.

Group

TnxServerRemoteCommandsPlugin Properties

Links
TnxServerRemoteCommandsPlugin Class, TnxServerRemoteCommandsPlugin Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandsPlugin Properties


TnxServerRemoteCommandTaskInfo Class

TnxServerRemoteCommandTaskInfo Class
TnxServerRemoteCommandTaskInfo Fields TnxServerRemoteCommandTaskInfo Methods TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Classes Send Feedback
Class Hierarchy
nxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfonxrcRemoteCommandsPluginServer_TnxServerRemoteCommandTaskInfo
Syntax
Delphi
TnxServerRemoteCommandTaskInfo = class(TnxServerTaskInfo);
File

nxrcRemoteCommandsPluginServer

Description

This is class nxrcRemoteCommandsPluginServer.TnxServerRemoteCommandTaskInfo.

Group

Classes

Links
TnxServerRemoteCommandTaskInfo Fields, TnxServerRemoteCommandTaskInfo Methods, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer, Classes


TnxServerRemoteCommandTaskInfo Members

TnxServerRemoteCommandTaskInfo Members
TnxServerRemoteCommandTaskInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxServerRemoteCommandTaskInfo.

Class

TnxServerRemoteCommandTaskInfo Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atiSessionNext | This is atiSessionNext, a member of class TnxAbstractTaskInfo.
atiSessionPrev | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
rctiCommand | This is rctiCommand, a member of class TnxServerRemoteCommandTaskInfo.
rctiCommandType | This is rctiCommandType, a member of class TnxServerRemoteCommandTaskInfo.
rctiCursor | This is rctiCursor, a member of class TnxServerRemoteCommandTaskInfo.
rctiDatabase | This is rctiDatabase, a member of class TnxServerRemoteCommandTaskInfo.
rctiErrorCode | This is rctiErrorCode, a member of class TnxServerRemoteCommandTaskInfo.
rctiErrorString | This is rctiErrorString, a member of class TnxServerRemoteCommandTaskInfo.
rctiHandlerClass | This is rctiHandlerClass, a member of class TnxServerRemoteCommandTaskInfo.
rctiOptions | This is rctiOptions, a member of class TnxServerRemoteCommandTaskInfo.
rctiPadlock | This is rctiPadlock, a member of class TnxServerRemoteCommandTaskInfo.
rctiParams | This is rctiParams, a member of class TnxServerRemoteCommandTaskInfo.
rctiSession | This is rctiSession, a member of class TnxServerRemoteCommandTaskInfo.
stiCancelled | This is stiCancelled, a member of class TnxServerTaskInfo.
stiExecuting | This is stiExecuting, a member of class TnxServerTaskInfo.
stiPadlock | This is stiPadlock, a member of class TnxServerTaskInfo.
stiStartEvt | This is stiStartEvt, a member of class TnxServerTaskInfo.
stiStatus | This is stiStatus, a member of class TnxServerTaskInfo.
stiThreadPriority | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atiAddToSession | TnxAbstractTaskInfo
atiRemoveFromSession |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Cancel | Call this method to cancel a Task. This method only triggers the cancel, the tasks may still be active until it reaches a safe state. The client-side taskinfo object should not be freed until the aCompleted parameter of GetStatus returns True, indicating task has ended.
Cancel | TnxServerTaskInfo
Close |
Create | TnxServerRemoteCommandTaskInfo
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
Destroy |
DoWrite |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Execute |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetStatus | This function returns the current status a server task.
GetStatus | TnxAbstractTaskInfo
Init | TnxServerTaskInfo
LookupByID |
MakeSnapshot |
MarkFinished |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxServerRemoteCommandTaskInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxServerRemoteCommandTaskInfo.Create Constructor

TnxServerRemoteCommandTaskInfo.Create Constructor
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxServerSession; aHandlerClass: TnxrcBaseCommandClass; aCommand: string; aParams: string; aOptions: string);
Description

TnxServerRemoteCommandTaskInfo

Class

TnxServerRemoteCommandTaskInfo Class

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Class


TnxServerRemoteCommandTaskInfo.Destroy Destructor

TnxServerRemoteCommandTaskInfo.Destroy Destructor
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxServerRemoteCommandTaskInfo Class

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Class


TnxServerRemoteCommandTaskInfo Fields

TnxServerRemoteCommandTaskInfo Fields
TnxServerRemoteCommandTaskInfo Class Legend Protected Fields Send Feedback

The fields of the TnxServerRemoteCommandTaskInfo class are listed here.

Class

TnxServerRemoteCommandTaskInfo Class

Protected Fields
Name | Description
rctiCommand | This is rctiCommand, a member of class TnxServerRemoteCommandTaskInfo.
rctiCommandType | This is rctiCommandType, a member of class TnxServerRemoteCommandTaskInfo.
rctiCursor | This is rctiCursor, a member of class TnxServerRemoteCommandTaskInfo.
rctiDatabase | This is rctiDatabase, a member of class TnxServerRemoteCommandTaskInfo.
rctiErrorCode | This is rctiErrorCode, a member of class TnxServerRemoteCommandTaskInfo.
rctiErrorString | This is rctiErrorString, a member of class TnxServerRemoteCommandTaskInfo.
rctiHandlerClass | This is rctiHandlerClass, a member of class TnxServerRemoteCommandTaskInfo.
rctiOptions | This is rctiOptions, a member of class TnxServerRemoteCommandTaskInfo.
rctiPadlock | This is rctiPadlock, a member of class TnxServerRemoteCommandTaskInfo.
rctiParams | This is rctiParams, a member of class TnxServerRemoteCommandTaskInfo.
rctiSession | This is rctiSession, a member of class TnxServerRemoteCommandTaskInfo.
Links
TnxServerRemoteCommandTaskInfo Class, Legend, Protected Fields


TnxServerRemoteCommandTaskInfo.rctiCommand Field

TnxServerRemoteCommandTaskInfo.rctiCommand Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiCommand: string;
Description

This is rctiCommand, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiCommandType Field

TnxServerRemoteCommandTaskInfo.rctiCommandType Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiCommandType: string;
Description

This is rctiCommandType, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiCursor Field

TnxServerRemoteCommandTaskInfo.rctiCursor Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiCursor: TnxAbstractCursor;
Description

This is rctiCursor, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiDatabase Field

TnxServerRemoteCommandTaskInfo.rctiDatabase Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiDatabase: TnxAbstractDatabase;
Description

This is rctiDatabase, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiErrorCode Field

TnxServerRemoteCommandTaskInfo.rctiErrorCode Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiErrorCode: Integer;
Description

This is rctiErrorCode, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiErrorString Field

TnxServerRemoteCommandTaskInfo.rctiErrorString Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiErrorString: string;
Description

This is rctiErrorString, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiHandlerClass Field

TnxServerRemoteCommandTaskInfo.rctiHandlerClass Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiHandlerClass: TnxrcBaseCommandClass;
Description

This is rctiHandlerClass, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiOptions Field

TnxServerRemoteCommandTaskInfo.rctiOptions Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiOptions: string;
Description

This is rctiOptions, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiPadlock Field

TnxServerRemoteCommandTaskInfo.rctiPadlock Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiPadlock: TnxPadlock;
Description

This is rctiPadlock, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiParams Field

TnxServerRemoteCommandTaskInfo.rctiParams Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiParams: string;
Description

This is rctiParams, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo.rctiSession Field

TnxServerRemoteCommandTaskInfo.rctiSession Field
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Fields Send Feedback
Syntax
Delphi
rctiSession: TnxServerSession;
Description

This is rctiSession, a member of class TnxServerRemoteCommandTaskInfo.

Group

TnxServerRemoteCommandTaskInfo Fields

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Fields


TnxServerRemoteCommandTaskInfo Methods

TnxServerRemoteCommandTaskInfo Methods
TnxServerRemoteCommandTaskInfo Class Legend Public Methods Send Feedback

The methods of the TnxServerRemoteCommandTaskInfo class are listed here.

Class

TnxServerRemoteCommandTaskInfo Class

Public Methods
Name | Description
DoWrite |
Execute |
Links
TnxServerRemoteCommandTaskInfo Class, Legend, Public Methods


TnxServerRemoteCommandTaskInfo.DoWrite Method

TnxServerRemoteCommandTaskInfo.DoWrite Method
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Methods Send Feedback
Syntax
Delphi
procedure DoWrite(aSender: TObject; const aText: string);
Group

TnxServerRemoteCommandTaskInfo Methods

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Methods


TnxServerRemoteCommandTaskInfo.Execute Method

TnxServerRemoteCommandTaskInfo.Execute Method
TnxServerRemoteCommandTaskInfo Class TnxServerRemoteCommandTaskInfo Members nxrcRemoteCommandsPluginServer Namespace TnxServerRemoteCommandTaskInfo Methods Send Feedback
Syntax
Delphi
procedure Execute; override;
Group

TnxServerRemoteCommandTaskInfo Methods

Links
TnxServerRemoteCommandTaskInfo Class, TnxServerRemoteCommandTaskInfo Members, nxrcRemoteCommandsPluginServer Namespace, TnxServerRemoteCommandTaskInfo Methods


nxrcRopsScriptCommand Namespace

nxrcRopsScriptCommand Namespace
Classes Legend Topics Send Feedback

This is namespace nxrcRopsScriptCommand.

Classes
Name | Description
TnxrcExecScriptCommand | This is class nxrcRopsScriptCommand.TnxrcExecScriptCommand.
TnxsrcScriptEngine | This is class nxrcRopsScriptCommand.TnxsrcScriptEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrcRopsScriptCommand Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxrcExecScriptCommand | This is class nxrcRopsScriptCommand.TnxrcExecScriptCommand.
TnxsrcScriptEngine | This is class nxrcRopsScriptCommand.TnxsrcScriptEngine.
Namespace

nxrcRopsScriptCommand Namespace

Links
Classes, nxrcRopsScriptCommand Namespace, Legend


TnxrcExecScriptCommand Class

TnxrcExecScriptCommand Class
TnxrcExecScriptCommand Fields TnxrcExecScriptCommand Methods TnxrcExecScriptCommand Properties TnxrcExecScriptCommand Members nxrcRopsScriptCommand Classes Send Feedback
Class Hierarchy
nxrcRopsScriptCommand_TnxrcExecScriptCommandnxrcRopsScriptCommand_TnxrcExecScriptCommandnxrcRopsScriptCommand_TnxrcExecScriptCommand
Syntax
Delphi
TnxrcExecScriptCommand = class(TnxrcBaseCommand);
File

nxrcRopsScriptCommand

Description

This is class nxrcRopsScriptCommand.TnxrcExecScriptCommand.

Group

Classes

Links
TnxrcExecScriptCommand Fields, TnxrcExecScriptCommand Methods, TnxrcExecScriptCommand Properties, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand, Classes


TnxrcExecScriptCommand Members

TnxrcExecScriptCommand Members
TnxrcExecScriptCommand Class Legend Protected Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxrcExecScriptCommand.

Class

TnxrcExecScriptCommand Class

Protected Fields
Name | Description
bcOptions | This is bcOptions, a member of class TnxrcBaseCommand.
bcOutput | This is bcOutput, a member of class TnxrcBaseCommand.
escScriptDir | private
escScriptEngine | This is escScriptEngine, a member of class TnxrcExecScriptCommand.
Public Methods
Name | Description
Block | TnxrcBaseCommand
Create | This is Create, a member of class TnxrcExecScriptCommand.
Destroy | This is Destroy, a member of class TnxrcExecScriptCommand.
Execute | This is Execute, a member of class TnxrcExecScriptCommand.
FindCommand | This is FindCommand, a member of class TnxrcBaseCommand.
FreeInstance |
NewInstance | TnxObject
Register | This is Register, a member of class TnxrcBaseCommand.
Public Properties
Name | Description
Options | This is Options, a member of class TnxrcBaseCommand.
Output | This is Output, a member of class TnxrcBaseCommand.
ScriptDir | This is ScriptDir, a member of class TnxrcExecScriptCommand.
Links
TnxrcExecScriptCommand Class, Legend, Protected Fields, Public Methods, Public Properties


TnxrcExecScriptCommand.Create Constructor

TnxrcExecScriptCommand.Create Constructor
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Class Send Feedback
Syntax
Delphi
constructor Create; override;
Description

This is Create, a member of class TnxrcExecScriptCommand.

Class

TnxrcExecScriptCommand Class

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Class


TnxrcExecScriptCommand.Destroy Destructor

TnxrcExecScriptCommand.Destroy Destructor
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

This is Destroy, a member of class TnxrcExecScriptCommand.

Class

TnxrcExecScriptCommand Class

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Class


TnxrcExecScriptCommand Fields

TnxrcExecScriptCommand Fields
TnxrcExecScriptCommand Class Legend Protected Fields Send Feedback

The fields of the TnxrcExecScriptCommand class are listed here.

Class

TnxrcExecScriptCommand Class

Protected Fields
Name | Description
escScriptDir | private
escScriptEngine | This is escScriptEngine, a member of class TnxrcExecScriptCommand.
Links
TnxrcExecScriptCommand Class, Legend, Protected Fields


TnxrcExecScriptCommand.escScriptDir Field

TnxrcExecScriptCommand.escScriptDir Field
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Fields Send Feedback
Syntax
Delphi
escScriptDir: string;
Description

private

Group

TnxrcExecScriptCommand Fields

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Fields


TnxrcExecScriptCommand.escScriptEngine Field

TnxrcExecScriptCommand.escScriptEngine Field
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Fields Send Feedback
Syntax
Delphi
escScriptEngine: TnxServerScriptEngine;
Description

This is escScriptEngine, a member of class TnxrcExecScriptCommand.

Group

TnxrcExecScriptCommand Fields

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Fields


TnxrcExecScriptCommand Methods

TnxrcExecScriptCommand Methods
TnxrcExecScriptCommand Class Legend Public Methods Send Feedback

The methods of the TnxrcExecScriptCommand class are listed here.

Class

TnxrcExecScriptCommand Class

Public Methods
Name | Description
Block | TnxrcBaseCommand
Execute | This is Execute, a member of class TnxrcExecScriptCommand.
Links
TnxrcExecScriptCommand Class, Legend, Public Methods


TnxrcExecScriptCommand.Block Method

TnxrcExecScriptCommand.Block Method
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Methods Send Feedback
Syntax
Delphi
class function Block: Boolean; override;
Description

TnxrcBaseCommand

Group

TnxrcExecScriptCommand Methods

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Methods


TnxrcExecScriptCommand.Execute Method

TnxrcExecScriptCommand.Execute Method
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Methods Send Feedback
Syntax
Delphi
procedure Execute(const aCommand: string; const aParams: string; out aErrorCode: Integer; out aErrorMessage: string); override;
Description

This is Execute, a member of class TnxrcExecScriptCommand.

Group

TnxrcExecScriptCommand Methods

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Methods


TnxrcExecScriptCommand Properties

TnxrcExecScriptCommand Properties
TnxrcExecScriptCommand Class Legend Public Properties Send Feedback

The properties of the TnxrcExecScriptCommand class are listed here.

Class

TnxrcExecScriptCommand Class

Public Properties
Name | Description
ScriptDir | This is ScriptDir, a member of class TnxrcExecScriptCommand.
Links
TnxrcExecScriptCommand Class, Legend, Public Properties


TnxrcExecScriptCommand.ScriptDir Property

TnxrcExecScriptCommand.ScriptDir Property
TnxrcExecScriptCommand Class TnxrcExecScriptCommand Members nxrcRopsScriptCommand Namespace TnxrcExecScriptCommand Properties Send Feedback
Syntax
Delphi
property ScriptDir: string;
Description

This is ScriptDir, a member of class TnxrcExecScriptCommand.

Group

TnxrcExecScriptCommand Properties

Links
TnxrcExecScriptCommand Class, TnxrcExecScriptCommand Members, nxrcRopsScriptCommand Namespace, TnxrcExecScriptCommand Properties


TnxsrcScriptEngine Class

TnxsrcScriptEngine Class
nxrcRopsScriptCommand Classes Send Feedback
Class Hierarchy
nxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEnginenxrcRopsScriptCommand_TnxsrcScriptEngine
Syntax
Delphi
TnxsrcScriptEngine = class(TnxPascalScriptEngine);
File

nxrcRopsScriptCommand

Description

This is class nxrcRopsScriptCommand.TnxsrcScriptEngine.

Group

Classes

Links
nxrcRopsScriptCommand, Classes


nxrdClass Namespace

nxrdClass Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxrdClass.

Classes
Name | Description
TnxClass | This is class nxrdClass.TnxClass.
TnxClassFactory | HPPEMIT '#pragma pack(pop)' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxClassFactory;' HPPEMIT '#pragma pack(push,4)' HPPEMIT 'class PASCALIMPLEMENTATION TnxClassFactory : public Nxllmemorymanager::TnxInterfacedObject' HPPEMIT '{' HPPEMIT ' typedef Nxllmemorymanager::TnxInterfacedObject inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' GUID cfClassID;' HPPEMIT ' TnxClassClass cfClassClass;' HPPEMIT ' virtual HRESULT __fastcall CreateInstance(const System::_di_IInterface aOuter, const GUID &aInterfaceID, /* out */ void *aClass);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' __fastcall virtual TnxClassFactory(const GUID &aClassID, TnxClassClass aClassClass);' HPPEMIT '#undef RegisterClass' HPPEMIT ' __classmethod virtual HRESULT __fastcall RegisterClass(const GUID &aClassID, TnxClassClass aClassClass, /* out */ Nxrbtypes::_di_InxClassFactoryControl &aControl);' HPPEMIT '#define RegisterClass RegisterClassW' HPPEMIT 'public:'... more
TnxSingletonClassFactory | This is class nxrdClass.TnxSingletonClassFactory.
TnxSingletonKeepAliveClassFactory | This is class nxrdClass.TnxSingletonKeepAliveClassFactory.
Structs, Records, Enums
Name | Description
TnxClassReferenceStore | This is record nxrdClass.TnxClassReferenceStore.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
PnxClassReferenceStore | This is type nxrdClass.PnxClassReferenceStore.
TnxClassClass | This is type nxrdClass.TnxClassClass.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxrdClass Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClass | This is class nxrdClass.TnxClass.
TnxClassFactory | HPPEMIT '#pragma pack(pop)' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxClassFactory;' HPPEMIT '#pragma pack(push,4)' HPPEMIT 'class PASCALIMPLEMENTATION TnxClassFactory : public Nxllmemorymanager::TnxInterfacedObject' HPPEMIT '{' HPPEMIT ' typedef Nxllmemorymanager::TnxInterfacedObject inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' GUID cfClassID;' HPPEMIT ' TnxClassClass cfClassClass;' HPPEMIT ' virtual HRESULT __fastcall CreateInstance(const System::_di_IInterface aOuter, const GUID &aInterfaceID, /* out */ void *aClass);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' __fastcall virtual TnxClassFactory(const GUID &aClassID, TnxClassClass aClassClass);' HPPEMIT '#undef RegisterClass' HPPEMIT ' __classmethod virtual HRESULT __fastcall RegisterClass(const GUID &aClassID, TnxClassClass aClassClass, /* out */ Nxrbtypes::_di_InxClassFactoryControl &aControl);' HPPEMIT '#define RegisterClass RegisterClassW' HPPEMIT 'public:'... more
TnxSingletonClassFactory | This is class nxrdClass.TnxSingletonClassFactory.
TnxSingletonKeepAliveClassFactory | This is class nxrdClass.TnxSingletonKeepAliveClassFactory.
Namespace

nxrdClass Namespace

Links
Classes, nxrdClass Namespace, Legend


TnxClass Class

TnxClass Class
TnxClass Fields TnxClass Methods TnxClass Properties TnxClass Members nxrdClass Classes Send Feedback
Class Hierarchy
nxrdClass_TnxClassnxrdClass_TnxClassnxrdClass_TnxClassnxrdClass_TnxClassnxrdClass_TnxClass
Syntax
Delphi
TnxClass = class(TnxAggregatableObject, InxClass);
File

nxrdClass

Description

This is class nxrdClass.TnxClass.

Group

Classes

Links
TnxClass Fields, TnxClass Methods, TnxClass Properties, TnxClass Members, nxrdClass, Classes


TnxClass Members

TnxClass Members
TnxClass Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClass.

Class

TnxClass Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
aoGetHost | TnxAggregatableObject
CreateInstance |
GetClassID | InxClass
InternalAddRef |
InternalQueryInterface |
InternalRelease | InxInterface methods ONLY for InxInterface
ioDeactivate |
QueryInterface |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClass
Destroy |
Free |
FreeInstance |
Initialize |
NewInstance |
NewInstance | TnxObject
SafeCallException |
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxClass Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClass.Create Constructor

TnxClass.Create Constructor
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Class Send Feedback
Syntax
Delphi
constructor Create(aClassID: PnxGuid; aRefStore: PnxClassReferenceStore; const aOuter: InxInterface; aKeepAlive: Boolean); virtual;
Description

TnxClass

Class

TnxClass Class

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Class


TnxClass.Destroy Destructor

TnxClass.Destroy Destructor
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClass Class

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Class


TnxClass Fields

TnxClass Fields
TnxClass Class Legend Protected Fields Send Feedback

The fields of the TnxClass class are listed here.

Class

TnxClass Class

Protected Fields
Name | Description
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
Links
TnxClass Class, Legend, Protected Fields


TnxClass.clClassID Field

TnxClass.clClassID Field
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Fields Send Feedback
Syntax
Delphi
clClassID: PnxGuid;
Description

This is clClassID, a member of class TnxClass.

Group

TnxClass Fields

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Fields


TnxClass.clRefStore Field

TnxClass.clRefStore Field
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Fields Send Feedback
Syntax
Delphi
clRefStore: PnxClassReferenceStore;
Description

private

Group

TnxClass Fields

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Fields


TnxClass.clServerExceptionHandler Field

TnxClass.clServerExceptionHandler Field
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Fields Send Feedback
Syntax
Delphi
clServerExceptionHandler: IServerExceptionHandler;
Description

This is clServerExceptionHandler, a member of class TnxClass.

Group

TnxClass Fields

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Fields


TnxClass Methods

TnxClass Methods
TnxClass Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxClass class are listed here.

Class

TnxClass Class

Protected Methods
Name | Description
CreateInstance |
GetClassID | InxClass
InternalRelease | InxInterface methods ONLY for InxInterface
Public Methods
Name | Description
Initialize |
SafeCallException |
Links
TnxClass Class, Legend, Protected Methods, Public Methods


TnxClass.CreateInstance Method

TnxClass.CreateInstance Method
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Methods Send Feedback
Syntax
Delphi
class function CreateInstance(aClassID: PnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; aRefStore: PnxClassReferenceStore; aKeepAlive: Boolean; out aClass): HRESULT; virtual;
Group

TnxClass Methods

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Methods


TnxClass.GetClassID Method

TnxClass.GetClassID Method
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Methods Send Feedback
Syntax
Delphi
function GetClassID: TnxGuid;
Description

InxClass

Group

TnxClass Methods

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Methods


TnxClass.Initialize Method

TnxClass.Initialize Method
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Methods Send Feedback
Syntax
Delphi
procedure Initialize; virtual;
Group

TnxClass Methods

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Methods


TnxClass.InternalRelease Method

TnxClass.InternalRelease Method
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Methods Send Feedback
Syntax
Delphi
function InternalRelease: Integer; override; stdcall;
Description

InxInterface methods ONLY for InxInterface

Group

TnxClass Methods

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Methods


TnxClass.SafeCallException Method

TnxClass.SafeCallException Method
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Methods Send Feedback
Syntax
Delphi
function SafeCallException(aExceptObject: TObject; aExceptAddr: Pointer): HResult; override;
Group

TnxClass Methods

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Methods


TnxClass Properties

TnxClass Properties
TnxClass Class Legend Public Properties Send Feedback

The properties of the TnxClass class are listed here.

Class

TnxClass Class

Public Properties
Name | Description
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxClass Class, Legend, Public Properties


TnxClass.ServerExceptionHandler Property

TnxClass.ServerExceptionHandler Property
TnxClass Class TnxClass Members nxrdClass Namespace TnxClass Properties Send Feedback
Syntax
Delphi
property ServerExceptionHandler: IServerExceptionHandler;
Description

This is ServerExceptionHandler, a member of class TnxClass.

Group

TnxClass Properties

Links
TnxClass Class, TnxClass Members, nxrdClass Namespace, TnxClass Properties


TnxClassFactory Class

TnxClassFactory Class
TnxClassFactory Fields TnxClassFactory Methods TnxClassFactory Members nxrdClass Classes Send Feedback
Class Hierarchy
nxrdClass_TnxClassFactorynxrdClass_TnxClassFactorynxrdClass_TnxClassFactorynxrdClass_TnxClassFactory
Syntax
Delphi
TnxClassFactory = class(TnxInterfacedObject, InxClassFactory);
File

nxrdClass

Description

HPPEMIT '#pragma pack(pop)' HPPEMIT '' HPPEMIT 'class DELPHICLASS TnxClassFactory;' HPPEMIT '#pragma pack(push,4)' HPPEMIT 'class PASCALIMPLEMENTATION TnxClassFactory : public Nxllmemorymanager::TnxInterfacedObject' HPPEMIT '{' HPPEMIT ' typedef Nxllmemorymanager::TnxInterfacedObject inherited;' HPPEMIT '' HPPEMIT 'protected:' HPPEMIT ' GUID cfClassID;' HPPEMIT ' TnxClassClass cfClassClass;' HPPEMIT ' virtual HRESULT __fastcall CreateInstance(const System::_di_IInterface aOuter, const GUID &aInterfaceID, /* out */ void *aClass);' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' __fastcall virtual TnxClassFactory(const GUID &aClassID, TnxClassClass aClassClass);' HPPEMIT '#undef RegisterClass' HPPEMIT ' __classmethod virtual HRESULT __fastcall RegisterClass(const GUID &aClassID, TnxClassClass aClassClass, /* out */ Nxrbtypes::_di_InxClassFactoryControl &aControl);' HPPEMIT '#define RegisterClass RegisterClassW' HPPEMIT 'public:' HPPEMIT ' /* TObject.Destroy */ inline __fastcall virtual ~TnxClassFactory(void) { }' HPPEMIT '' HPPEMIT 'private:' HPPEMIT ' void *__InxClassFactory; // Nxrbtypes::InxClassFactory' HPPEMIT '' HPPEMIT 'public:' HPPEMIT ' #if defined(MANAGED_INTERFACE_OPERATORS)' HPPEMIT ' // {4470B7A4-7E67-4013-ACDC-2C59E479141D}' HPPEMIT ' operator Nxrbtypes::_di_InxClassFactory()' HPPEMIT ' {' HPPEMIT ' Nxrbtypes::_di_InxClassFactory intf;' HPPEMIT ' GetInterface(intf);' HPPEMIT ' return intf;' HPPEMIT ' }' HPPEMIT ' #else' HPPEMIT ' operator Nxrbtypes::InxClassFactory*(void) { return (Nxrbtypes::InxClassFactory* )&__InxClassFactory; }' HPPEMIT ' #endif' HPPEMIT '' HPPEMIT '};'

Group

Classes

Links
TnxClassFactory Fields, TnxClassFactory Methods, TnxClassFactory Members, nxrdClass, Classes


TnxClassFactory Members

TnxClassFactory Members
TnxClassFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassFactory.

Class

TnxClassFactory Class

Protected Fields
Name | Description
cfClassClass | This is cfClassClass, a member of class TnxClassFactory.
cfClassID | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInstance | InxClassFactory
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassFactory
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
RegisterClass |
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassFactory.Create Constructor

TnxClassFactory.Create Constructor
TnxClassFactory Class TnxClassFactory Members nxrdClass Namespace TnxClassFactory Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; aClassClass: TnxClassClass); virtual;
Description

TnxClassFactory

Class

TnxClassFactory Class

Links
TnxClassFactory Class, TnxClassFactory Members, nxrdClass Namespace, TnxClassFactory Class


TnxClassFactory Fields

TnxClassFactory Fields
TnxClassFactory Class Legend Protected Fields Send Feedback

The fields of the TnxClassFactory class are listed here.

Class

TnxClassFactory Class

Protected Fields
Name | Description
cfClassClass | This is cfClassClass, a member of class TnxClassFactory.
cfClassID | private
Links
TnxClassFactory Class, Legend, Protected Fields


TnxClassFactory.cfClassClass Field

TnxClassFactory.cfClassClass Field
TnxClassFactory Class TnxClassFactory Members nxrdClass Namespace TnxClassFactory Fields Send Feedback
Syntax
Delphi
cfClassClass: TnxClassClass;
Description

This is cfClassClass, a member of class TnxClassFactory.

Group

TnxClassFactory Fields

Links
TnxClassFactory Class, TnxClassFactory Members, nxrdClass Namespace, TnxClassFactory Fields


TnxClassFactory.cfClassID Field

TnxClassFactory.cfClassID Field
TnxClassFactory Class TnxClassFactory Members nxrdClass Namespace TnxClassFactory Fields Send Feedback
Syntax
Delphi
cfClassID: TnxGuid;
Description

private

Group

TnxClassFactory Fields

Links
TnxClassFactory Class, TnxClassFactory Members, nxrdClass Namespace, TnxClassFactory Fields


TnxClassFactory Methods

TnxClassFactory Methods
TnxClassFactory Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxClassFactory class are listed here.

Class

TnxClassFactory Class

Protected Methods
Name | Description
CreateInstance | InxClassFactory
Public Methods
Name | Description
RegisterClass |
Links
TnxClassFactory Class, Legend, Protected Methods, Public Methods


TnxClassFactory.CreateInstance Method

TnxClassFactory.CreateInstance Method
TnxClassFactory Class TnxClassFactory Members nxrdClass Namespace TnxClassFactory Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT; virtual;
Description

InxClassFactory

Group

TnxClassFactory Methods

Links
TnxClassFactory Class, TnxClassFactory Members, nxrdClass Namespace, TnxClassFactory Methods


TnxClassFactory.RegisterClass Method

TnxClassFactory.RegisterClass Method
TnxClassFactory Class TnxClassFactory Members nxrdClass Namespace TnxClassFactory Methods Send Feedback
Syntax
Delphi
class function RegisterClass(const aClassID: TnxGuid; aClassClass: TnxClassClass; out aControl: InxClassFactoryControl): HRESULT; virtual;
Group

TnxClassFactory Methods

Links
TnxClassFactory Class, TnxClassFactory Members, nxrdClass Namespace, TnxClassFactory Methods


TnxSingletonClassFactory Class

TnxSingletonClassFactory Class
TnxSingletonClassFactory Fields TnxSingletonClassFactory Methods TnxSingletonClassFactory Members nxrdClass Classes Send Feedback
Class Hierarchy
nxrdClass_TnxSingletonClassFactorynxrdClass_TnxSingletonClassFactorynxrdClass_TnxSingletonClassFactorynxrdClass_TnxSingletonClassFactorynxrdClass_TnxSingletonClassFactorynxrdClass_TnxSingletonClassFactory
Syntax
Delphi
TnxSingletonClassFactory = class(TnxClassFactory, InxSingeltonClassFactory);
File

nxrdClass

Description

This is class nxrdClass.TnxSingletonClassFactory.

Group

Classes

Links
TnxSingletonClassFactory Fields, TnxSingletonClassFactory Methods, TnxSingletonClassFactory Members, nxrdClass, Classes


TnxSingletonClassFactory Members

TnxSingletonClassFactory Members
TnxSingletonClassFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSingletonClassFactory.

Class

TnxSingletonClassFactory Class

Protected Fields
Name | Description
cfClassClass | This is cfClassClass, a member of class TnxClassFactory.
cfClassID | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
scfRefStore | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInstance | InxClassFactory
ioDeactivate |
QueryInterface |
ReleaseSingelton | InxSingeltonClassFactory
scfKeepAlive |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxSingletonClassFactory
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
RegisterClass |
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxSingletonClassFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSingletonClassFactory.Create Constructor

TnxSingletonClassFactory.Create Constructor
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; aClassClass: TnxClassClass); override;
Description

TnxSingletonClassFactory

Class

TnxSingletonClassFactory Class

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Class


TnxSingletonClassFactory.Destroy Destructor

TnxSingletonClassFactory.Destroy Destructor
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSingletonClassFactory Class

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Class


TnxSingletonClassFactory Fields

TnxSingletonClassFactory Fields
TnxSingletonClassFactory Class Legend Protected Fields Send Feedback

The fields of the TnxSingletonClassFactory class are listed here.

Class

TnxSingletonClassFactory Class

Protected Fields
Name | Description
scfRefStore | private
Links
TnxSingletonClassFactory Class, Legend, Protected Fields


TnxSingletonClassFactory.scfRefStore Field

TnxSingletonClassFactory.scfRefStore Field
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Fields Send Feedback
Syntax
Delphi
scfRefStore: TnxClassReferenceStore;
Description

private

Group

TnxSingletonClassFactory Fields

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Fields


TnxSingletonClassFactory Methods

TnxSingletonClassFactory Methods
TnxSingletonClassFactory Class Legend Protected Methods Send Feedback

The methods of the TnxSingletonClassFactory class are listed here.

Class

TnxSingletonClassFactory Class

Protected Methods
Name | Description
CreateInstance | InxClassFactory
ReleaseSingelton | InxSingeltonClassFactory
scfKeepAlive |
Links
TnxSingletonClassFactory Class, Legend, Protected Methods


TnxSingletonClassFactory.CreateInstance Method

TnxSingletonClassFactory.CreateInstance Method
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT; override;
Description

InxClassFactory

Group

TnxSingletonClassFactory Methods

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Methods


TnxSingletonClassFactory.ReleaseSingelton Method

TnxSingletonClassFactory.ReleaseSingelton Method
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Methods Send Feedback
Syntax
Delphi
function ReleaseSingelton: HRESULT; virtual;
Description

InxSingeltonClassFactory

Group

TnxSingletonClassFactory Methods

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Methods


TnxSingletonClassFactory.scfKeepAlive Method

TnxSingletonClassFactory.scfKeepAlive Method
TnxSingletonClassFactory Class TnxSingletonClassFactory Members nxrdClass Namespace TnxSingletonClassFactory Methods Send Feedback
Syntax
Delphi
class function scfKeepAlive: Boolean; virtual;
Group

TnxSingletonClassFactory Methods

Links
TnxSingletonClassFactory Class, TnxSingletonClassFactory Members, nxrdClass Namespace, TnxSingletonClassFactory Methods


TnxSingletonKeepAliveClassFactory Class

TnxSingletonKeepAliveClassFactory Class
TnxSingletonKeepAliveClassFactory Methods TnxSingletonKeepAliveClassFactory Members nxrdClass Classes Send Feedback
Class Hierarchy
nxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactorynxrdClass_TnxSingletonKeepAliveClassFactory
Syntax
Delphi
TnxSingletonKeepAliveClassFactory = class(TnxSingletonClassFactory);
File

nxrdClass

Description

This is class nxrdClass.TnxSingletonKeepAliveClassFactory.

Group

Classes

Links
TnxSingletonKeepAliveClassFactory Methods, TnxSingletonKeepAliveClassFactory Members, nxrdClass, Classes


TnxSingletonKeepAliveClassFactory Members

TnxSingletonKeepAliveClassFactory Members
TnxSingletonKeepAliveClassFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSingletonKeepAliveClassFactory.

Class

TnxSingletonKeepAliveClassFactory Class

Protected Fields
Name | Description
cfClassClass | This is cfClassClass, a member of class TnxClassFactory.
cfClassID | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
scfRefStore | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInstance | InxClassFactory
CreateInstance | InxClassFactory
ioDeactivate |
QueryInterface |
ReleaseSingelton | InxSingeltonClassFactory
scfKeepAlive | TnxSingletonKeepAliveClassFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create | TnxClassFactory
Create | TnxSingletonClassFactory
CreateInstance | This is CreateInstance, a member of class InxClassFactory.
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
RegisterClass |
ReleaseSingelton | This is ReleaseSingelton, a member of class InxSingeltonClassFactory.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxSingletonKeepAliveClassFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSingletonKeepAliveClassFactory Methods

TnxSingletonKeepAliveClassFactory Methods
TnxSingletonKeepAliveClassFactory Class Legend Protected Methods Send Feedback

The methods of the TnxSingletonKeepAliveClassFactory class are listed here.

Class

TnxSingletonKeepAliveClassFactory Class

Protected Methods
Name | Description
scfKeepAlive | TnxSingletonKeepAliveClassFactory
Links
TnxSingletonKeepAliveClassFactory Class, Legend, Protected Methods


TnxSingletonKeepAliveClassFactory.scfKeepAlive Method

TnxSingletonKeepAliveClassFactory.scfKeepAlive Method
TnxSingletonKeepAliveClassFactory Class TnxSingletonKeepAliveClassFactory Members nxrdClass Namespace TnxSingletonKeepAliveClassFactory Methods Send Feedback
Syntax
Delphi
class function scfKeepAlive: Boolean; override;
Description

TnxSingletonKeepAliveClassFactory

Group

TnxSingletonKeepAliveClassFactory Methods

Links
TnxSingletonKeepAliveClassFactory Class, TnxSingletonKeepAliveClassFactory Members, nxrdClass Namespace, TnxSingletonKeepAliveClassFactory Methods


Structs, Records, Enums

Structs, Records, Enums
nxrdClass Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxrdClass Namespace

Records
Name | Description
TnxClassReferenceStore | This is record nxrdClass.TnxClassReferenceStore.
Links
nxrdClass Namespace, Legend, Records


nxrdClass.TnxClassReferenceStore Record

nxrdClass.TnxClassReferenceStore Record
nxrdClass Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassReferenceStore = record
  crsPadlock: TnxPadlock;
  crsRef: TnxClass;
end;
File

nxrdClass

Description

This is record nxrdClass.TnxClassReferenceStore.

Group

Structs, Records, Enums

Links
nxrdClass, Structs, Records, Enums


Types

Types
nxrdClass Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrdClass Namespace

Types
Name | Description
PnxClassReferenceStore | This is type nxrdClass.PnxClassReferenceStore.
TnxClassClass | This is type nxrdClass.TnxClassClass.
Links
nxrdClass Namespace, Types


nxrdClass.PnxClassReferenceStore Type

nxrdClass.PnxClassReferenceStore Type
nxrdClass Types Send Feedback
Syntax
Delphi
PnxClassReferenceStore = ^TnxClassReferenceStore;
File

nxrdClass

Description

This is type nxrdClass.PnxClassReferenceStore.

Group

Types

Links
nxrdClass, Types


nxrdClass.TnxClassClass Type

nxrdClass.TnxClassClass Type
nxrdClass Types Send Feedback
Syntax
Delphi
TnxClassClass = class of TnxClass;
File

nxrdClass

Description

This is type nxrdClass.TnxClassClass.

Group

Types

Links
nxrdClass, Types


nxrdClassProxy Namespace

nxrdClassProxy Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxrdClassProxy.

Classes
Name | Description
TnxClassProxy | This is class nxrdClassProxy.TnxClassProxy.
TnxClassProxyFactory | This is class nxrdClassProxy.TnxClassProxyFactory.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxClassProxyClass | This is type nxrdClassProxy.TnxClassProxyClass.
Variables
Name | Description
Control |
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxrdClassProxy Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassProxy | This is class nxrdClassProxy.TnxClassProxy.
TnxClassProxyFactory | This is class nxrdClassProxy.TnxClassProxyFactory.
Namespace

nxrdClassProxy Namespace

Links
Classes, nxrdClassProxy Namespace, Legend


TnxClassProxy Class

TnxClassProxy Class
TnxClassProxy Fields TnxClassProxy Methods TnxClassProxy Members nxrdClassProxy Classes Send Feedback
Class Hierarchy
nxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxynxrdClassProxy_TnxClassProxy
Syntax
Delphi
TnxClassProxy = class(TnxClass, IMultiQI, InxRoutingPath, InxClassProxy);
File

nxrdClassProxy

Description

This is class nxrdClassProxy.TnxClassProxy.

Group

Classes

Links
TnxClassProxy Fields, TnxClassProxy Methods, TnxClassProxy Members, nxrdClassProxy, Classes


TnxClassProxy Members

TnxClassProxy Members
TnxClassProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassProxy.

Class

TnxClassProxy Class

Protected Fields
Name | Description
aoHost | private
clClassID | This is clClassID, a member of class TnxClass.
clRefStore | private
clServerExceptionHandler | This is clServerExceptionHandler, a member of class TnxClass.
cpChannel | This is cpChannel, a member of class TnxClassProxy.
cpClassID | This is cpClassID, a member of class TnxClassProxy.
cpClassStubVersion | private
cpFactory | This is cpFactory, a member of class TnxClassProxy.
cpFactoryRef | This is cpFactoryRef, a member of class TnxClassProxy.
cpPath | This is cpPath, a member of class TnxClassProxy.
cpPortal | This is cpPortal, a member of class TnxClassProxy.
cpProxies | This is cpProxies, a member of class TnxClassProxy.
cpProxiesRefs | This is cpProxiesRefs, a member of class TnxClassProxy.
cpRegString | This is cpRegString, a member of class TnxClassProxy.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef |
_AddRef | TnxInterfacedObject
_Release |
_Release |
AddChannel | TnxClassProxy
aoGetHost | TnxAggregatableObject
CreateClassProxy |
CreateInstance |
GetClassID | InxClass
GetClassProxyVersion | TnxClassProxy
GetRoutingPath | InxRoutingPath
GetSharedVersion |
GetWriter |
InternalAddRef |
InternalQueryInterface | InxInterface
InternalRelease |
ioDeactivate |
Process |
QueryInterface |
QueryInterface |
QueryMultipleInterfaces | IMultiQI
Supports | InxClassProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Destroy |
Free |
FreeInstance |
GetClassID | This is GetClassID, a member of class InxClass.
Initialize |
NewInstance |
NewInstance | TnxObject
SafeCallException |
Public Properties
Name | Description
ClassID | This is ClassID, a member of class InxClass.
Host | This is Host, a member of class TnxAggregatableObject.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
ServerExceptionHandler | This is ServerExceptionHandler, a member of class TnxClass.
Links
TnxClassProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassProxy.Create Constructor

TnxClassProxy.Create Constructor
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Class Send Feedback
Syntax
Delphi
constructor Create(aFactory: TnxClassProxyFactory; const aOuter: InxInterface; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aReader: InxReader; const aRegString: string); virtual; reintroduce;
Class

TnxClassProxy Class

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Class


TnxClassProxy.Destroy Destructor

TnxClassProxy.Destroy Destructor
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassProxy Class

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Class


TnxClassProxy Fields

TnxClassProxy Fields
TnxClassProxy Class Legend Protected Fields Send Feedback

The fields of the TnxClassProxy class are listed here.

Class

TnxClassProxy Class

Protected Fields
Name | Description
cpChannel | This is cpChannel, a member of class TnxClassProxy.
cpClassID | This is cpClassID, a member of class TnxClassProxy.
cpClassStubVersion | private
cpFactory | This is cpFactory, a member of class TnxClassProxy.
cpFactoryRef | This is cpFactoryRef, a member of class TnxClassProxy.
cpPath | This is cpPath, a member of class TnxClassProxy.
cpPortal | This is cpPortal, a member of class TnxClassProxy.
cpProxies | This is cpProxies, a member of class TnxClassProxy.
cpProxiesRefs | This is cpProxiesRefs, a member of class TnxClassProxy.
cpRegString | This is cpRegString, a member of class TnxClassProxy.
Links
TnxClassProxy Class, Legend, Protected Fields


TnxClassProxy.cpChannel Field

TnxClassProxy.cpChannel Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpChannel: InxChannelEntrance;
Description

This is cpChannel, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpClassID Field

TnxClassProxy.cpClassID Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpClassID: TnxGuid;
Description

This is cpClassID, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpClassStubVersion Field

TnxClassProxy.cpClassStubVersion Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpClassStubVersion: Integer;
Description

private

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpFactory Field

TnxClassProxy.cpFactory Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpFactory: TnxClassProxyFactory;
Description

This is cpFactory, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpFactoryRef Field

TnxClassProxy.cpFactoryRef Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpFactoryRef: InxInterface;
Description

This is cpFactoryRef, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpPath Field

TnxClassProxy.cpPath Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpPath: TnxRoutingPath;
Description

This is cpPath, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpPortal Field

TnxClassProxy.cpPortal Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpPortal: TnxReadWritePortal;
Description

This is cpPortal, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpProxies Field

TnxClassProxy.cpProxies Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpProxies: TnxFastStringListCS;
Description

This is cpProxies, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpProxiesRefs Field

TnxClassProxy.cpProxiesRefs Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpProxiesRefs: array of InxInterfaceProxy;
Description

This is cpProxiesRefs, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy.cpRegString Field

TnxClassProxy.cpRegString Field
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Fields Send Feedback
Syntax
Delphi
cpRegString: string;
Description

This is cpRegString, a member of class TnxClassProxy.

Group

TnxClassProxy Fields

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Fields


TnxClassProxy Methods

TnxClassProxy Methods
TnxClassProxy Class Legend Protected Methods Send Feedback

The methods of the TnxClassProxy class are listed here.

Class

TnxClassProxy Class

Protected Methods
Name | Description
AddChannel | TnxClassProxy
CreateClassProxy |
GetClassProxyVersion | TnxClassProxy
GetRoutingPath | InxRoutingPath
GetSharedVersion |
GetWriter |
InternalQueryInterface | InxInterface
InternalRelease |
Process |
QueryMultipleInterfaces | IMultiQI
Supports | InxClassProxyFactory
Links
TnxClassProxy Class, Legend, Protected Methods


TnxClassProxy.AddChannel Method

TnxClassProxy.AddChannel Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function AddChannel(const aChannel: InxChannelEntrance; const aPath: TnxRoutingPath): HRESULT; virtual;
Description

TnxClassProxy

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.CreateClassProxy Method

TnxClassProxy.CreateClassProxy Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
class function CreateClassProxy(aFactory: TnxClassProxyFactory; const aOuter: InxInterface; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aRegString: string; const aReader: InxReader; out aClassProxy: InxClassProxy): HRESULT; virtual;
Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.GetClassProxyVersion Method

TnxClassProxy.GetClassProxyVersion Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function GetClassProxyVersion: Integer; virtual;
Description

TnxClassProxy

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.GetRoutingPath Method

TnxClassProxy.GetRoutingPath Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function GetRoutingPath: TnxRoutingPath;
Description

InxRoutingPath

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.GetSharedVersion Method

TnxClassProxy.GetSharedVersion Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function GetSharedVersion: Integer;
Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.GetWriter Method

TnxClassProxy.GetWriter Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function GetWriter(out aWriter: InxWriter): HRESULT; virtual;
Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.InternalQueryInterface Method

TnxClassProxy.InternalQueryInterface Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function InternalQueryInterface(constref const IID: TGUID; out Obj): HResult; override; stdcall;
Description

InxInterface

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.InternalRelease Method

TnxClassProxy.InternalRelease Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function InternalRelease: Integer; override; stdcall;
Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.Process Method

TnxClassProxy.Process Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function Process(const aWriter: InxWriter; out aReader: InxReader): HRESULT; virtual;
Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.QueryMultipleInterfaces Method

TnxClassProxy.QueryMultipleInterfaces Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
function QueryMultipleInterfaces(cMQIs: Cardinal; pMQIs: PMULTI_QI): HRESULT; stdcall;
Description

IMultiQI

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxy.Supports Method

TnxClassProxy.Supports Method
TnxClassProxy Class TnxClassProxy Members nxrdClassProxy Namespace TnxClassProxy Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid): HRESULT; virtual;
Description

InxClassProxyFactory

Group

TnxClassProxy Methods

Links
TnxClassProxy Class, TnxClassProxy Members, nxrdClassProxy Namespace, TnxClassProxy Methods


TnxClassProxyFactory Class

TnxClassProxyFactory Class
TnxClassProxyFactory Fields TnxClassProxyFactory Methods TnxClassProxyFactory Members nxrdClassProxy Classes Send Feedback
Class Hierarchy
nxrdClassProxy_TnxClassProxyFactorynxrdClassProxy_TnxClassProxyFactorynxrdClassProxy_TnxClassProxyFactorynxrdClassProxy_TnxClassProxyFactory
Syntax
Delphi
TnxClassProxyFactory = class(TnxInterfacedObject, InxClassProxyFactory);
File

nxrdClassProxy

Description

This is class nxrdClassProxy.TnxClassProxyFactory.

Group

Classes

Links
TnxClassProxyFactory Fields, TnxClassProxyFactory Methods, TnxClassProxyFactory Members, nxrdClassProxy, Classes


TnxClassProxyFactory Members

TnxClassProxyFactory Members
TnxClassProxyFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassProxyFactory.

Class

TnxClassProxyFactory Class

Protected Fields
Name | Description
cpfClassProxyClass | This is cpfClassProxyClass, a member of class TnxClassProxyFactory.
cpfMapping | This is cpfMapping, a member of class TnxClassProxyFactory.
cpfPadlock | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateClassProxy |
ioDeactivate |
QueryInterface |
Supports | InxClassProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassProxyFactory
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassProxyFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassProxyFactory.Create Constructor

TnxClassProxyFactory.Create Constructor
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Class Send Feedback
Syntax
Delphi
constructor Create(aClassProxyClass: TnxClassProxyClass);
Description

TnxClassProxyFactory

Class

TnxClassProxyFactory Class

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Class


TnxClassProxyFactory.Destroy Destructor

TnxClassProxyFactory.Destroy Destructor
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassProxyFactory Class

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Class


TnxClassProxyFactory Fields

TnxClassProxyFactory Fields
TnxClassProxyFactory Class Legend Protected Fields Send Feedback

The fields of the TnxClassProxyFactory class are listed here.

Class

TnxClassProxyFactory Class

Protected Fields
Name | Description
cpfClassProxyClass | This is cpfClassProxyClass, a member of class TnxClassProxyFactory.
cpfMapping | This is cpfMapping, a member of class TnxClassProxyFactory.
cpfPadlock | private
Links
TnxClassProxyFactory Class, Legend, Protected Fields


TnxClassProxyFactory.cpfClassProxyClass Field

TnxClassProxyFactory.cpfClassProxyClass Field
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Fields Send Feedback
Syntax
Delphi
cpfClassProxyClass: TnxClassProxyClass;
Description

This is cpfClassProxyClass, a member of class TnxClassProxyFactory.

Group

TnxClassProxyFactory Fields

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Fields


TnxClassProxyFactory.cpfMapping Field

TnxClassProxyFactory.cpfMapping Field
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Fields Send Feedback
Syntax
Delphi
cpfMapping: TnxFastStringListCS;
Description

This is cpfMapping, a member of class TnxClassProxyFactory.

Group

TnxClassProxyFactory Fields

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Fields


TnxClassProxyFactory.cpfPadlock Field

TnxClassProxyFactory.cpfPadlock Field
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Fields Send Feedback
Syntax
Delphi
cpfPadlock: TnxPadlock;
Description

private

Group

TnxClassProxyFactory Fields

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Fields


TnxClassProxyFactory Methods

TnxClassProxyFactory Methods
TnxClassProxyFactory Class Legend Protected Methods Send Feedback

The methods of the TnxClassProxyFactory class are listed here.

Class

TnxClassProxyFactory Class

Protected Methods
Name | Description
CreateClassProxy |
Supports | InxClassProxyFactory
Links
TnxClassProxyFactory Class, Legend, Protected Methods


TnxClassProxyFactory.CreateClassProxy Method

TnxClassProxyFactory.CreateClassProxy Method
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateClassProxy(const aOuter: InxInterface; const aChannel: InxChannelEntrance; const aClassID: TnxGuid; const aPath: TnxRoutingPath; const aReader: InxReader; out aClassProxy: InxClassProxy): HRESULT;
Group

TnxClassProxyFactory Methods

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Methods


TnxClassProxyFactory.Supports Method

TnxClassProxyFactory.Supports Method
TnxClassProxyFactory Class TnxClassProxyFactory Members nxrdClassProxy Namespace TnxClassProxyFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid): HRESULT;
Description

InxClassProxyFactory

Group

TnxClassProxyFactory Methods

Links
TnxClassProxyFactory Class, TnxClassProxyFactory Members, nxrdClassProxy Namespace, TnxClassProxyFactory Methods


Types

Types
nxrdClassProxy Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrdClassProxy Namespace

Types
Name | Description
TnxClassProxyClass | This is type nxrdClassProxy.TnxClassProxyClass.
Links
nxrdClassProxy Namespace, Types


nxrdClassProxy.TnxClassProxyClass Type

nxrdClassProxy.TnxClassProxyClass Type
nxrdClassProxy Types Send Feedback
Syntax
Delphi
TnxClassProxyClass = class of TnxClassProxy;
File

nxrdClassProxy

Description

This is type nxrdClassProxy.TnxClassProxyClass.

Group

Types

Links
nxrdClassProxy, Types


Variables

Variables
nxrdClassProxy Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrdClassProxy Namespace

Variables
Name | Description
Control |
Links
nxrdClassProxy Namespace, Variables


nxrdClassProxy.Control Variable

nxrdClassProxy.Control Variable
nxrdClassProxy Variables Send Feedback
Syntax
Delphi
Control: InxClassProxyFactoryControl;
File

nxrdClassProxy

Group

Variables

Links
nxrdClassProxy, Variables


nxrdClassShared Namespace

nxrdClassShared Namespace
Constants Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrdClassShared.

Constants
Name | Description
DefaultClassHandlerID | This is constant nxrdClassShared.DefaultClassHandlerID.
Structs, Records, Enums
Name | Description
TnxClassStubOp | This is record nxrdClassShared.TnxClassStubOp.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Constants | The following table lists constants in this documentation.
Links
Constants, Legend, Structs, Records, Enums, Topics


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrdClassShared Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxClassStubOp | This is record nxrdClassShared.TnxClassStubOp.
Namespace

nxrdClassShared Namespace

Links
Enumerations, nxrdClassShared Namespace, Legend


nxrdClassShared.TnxClassStubOp Enumeration

nxrdClassShared.TnxClassStubOp Enumeration
nxrdClassShared Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassStubOp = ( shoFindInterfaceStub, shoCallInterfaceStub, shoFindInterfaceStubs );
File

nxrdClassShared

Description

This is record nxrdClassShared.TnxClassStubOp.

Group

Structs, Records, Enums

Links
nxrdClassShared, Structs, Records, Enums


Constants

Constants
Constants nxrdClassShared Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DefaultClassHandlerID | This is constant nxrdClassShared.DefaultClassHandlerID.
Namespace

nxrdClassShared Namespace

Links
Constants, nxrdClassShared Namespace


nxrdClassShared.DefaultClassHandlerID Constant

nxrdClassShared.DefaultClassHandlerID Constant
nxrdClassShared Constants Send Feedback
Syntax
Delphi
DefaultClassHandlerID: TnxGuid = '{4DD40D56-402A-41A4-9D68-207A1B78768E}';
File

nxrdClassShared

Description

This is constant nxrdClassShared.DefaultClassHandlerID.

Group

Constants

Links
nxrdClassShared, Constants


nxrdClassStub Namespace

nxrdClassStub Namespace
Classes Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxrdClassStub.

Classes
Name | Description
TnxClassStub | This is class nxrdClassStub.TnxClassStub.
TnxClassStubFactory | This is class nxrdClassStub.TnxClassStubFactory.
Structs, Records, Enums
Name | Description
TnxInstanceID | This is record nxrdClassStub.TnxInstanceID.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxInstanceID | This is type nxrdClassStub.PnxInstanceID.
TnxClassStubClass | This is type nxrdClassStub.TnxClassStubClass.
Variables
Name | Description
Control |
Links
Classes, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxrdClassStub Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassStub | This is class nxrdClassStub.TnxClassStub.
TnxClassStubFactory | This is class nxrdClassStub.TnxClassStubFactory.
Namespace

nxrdClassStub Namespace

Links
Classes, nxrdClassStub Namespace, Legend


TnxClassStub Class

TnxClassStub Class
TnxClassStub Fields TnxClassStub Methods TnxClassStub Members nxrdClassStub Classes Send Feedback
Class Hierarchy
nxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStubnxrdClassStub_TnxClassStub
Syntax
Delphi
TnxClassStub = class(TnxLowInterfacedObject, InxInterface, InxRoutingPath, InxChannelSink, InxClassStub);
File

nxrdClassStub

Description

This is class nxrdClassStub.TnxClassStub.

Group

Classes

Links
TnxClassStub Fields, TnxClassStub Methods, TnxClassStub Members, nxrdClassStub, Classes


TnxClassStub Members

TnxClassStub Members
TnxClassStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassStub.

Class

TnxClassStub Class

Protected Fields
Name | Description
csChannels | This is csChannels, a member of class TnxClassStub.
csClassID | This is csClassID, a member of class TnxClassStub.
csDisconnected | This is csDisconnected, a member of class TnxClassStub.
csFactory | This is csFactory, a member of class TnxClassStub.
csFactoryRef | This is csFactoryRef, a member of class TnxClassStub.
csInCallCount | This is csInCallCount, a member of class TnxClassStub.
csInterface | This is csInterface, a member of class TnxClassStub.
csIntfId | This is csIntfId, a member of class TnxClassStub.
csIntfPtr | This is csIntfPtr, a member of class TnxClassStub.
csPath | This is csPath, a member of class TnxClassStub.
csPortal | private
csStubRefs | This is csStubRefs, a member of class TnxClassStub.
csStubs | This is csStubs, a member of class TnxClassStub.
csTickCount | This is csTickCount, a member of class TnxClassStub.
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release | InxInterface
Connected | InxChannelSink TnxClassStub
CreateClassStub |
csFinalizeDisconnect |
DisconnectAllChannels | InxClassStub
Disconnected |
DisconnectObject |
GetClassStubVersion |
GetInstanceID | TnxClassStub
GetRoutingPath | InxRoutingPath
ioDeactivate |
Process |
ProcessCallInterfaceStub |
ProcessFindInterfaceStub |
ProcessFindInterfaceStubs |
QueryContainedInterface |
QueryInterface |
Supports | InxClassStubFactory
WriteClassProxyInfo |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Destroy |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxLowInterfacedObject
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
RoutingPath | This is RoutingPath, a member of class InxRoutingPath.
Links
TnxClassStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassStub.Create Constructor

TnxClassStub.Create Constructor
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Class Send Feedback
Syntax
Delphi
constructor Create(aFactory: TnxClassStubFactory; const aClassID: TnxGuid; const aInterface: InxInterface); virtual;
Class

TnxClassStub Class

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Class


TnxClassStub.Destroy Destructor

TnxClassStub.Destroy Destructor
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassStub Class

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Class


TnxClassStub Fields

TnxClassStub Fields
TnxClassStub Class Legend Protected Fields Send Feedback

The fields of the TnxClassStub class are listed here.

Class

TnxClassStub Class

Protected Fields
Name | Description
csChannels | This is csChannels, a member of class TnxClassStub.
csClassID | This is csClassID, a member of class TnxClassStub.
csDisconnected | This is csDisconnected, a member of class TnxClassStub.
csFactory | This is csFactory, a member of class TnxClassStub.
csFactoryRef | This is csFactoryRef, a member of class TnxClassStub.
csInCallCount | This is csInCallCount, a member of class TnxClassStub.
csInterface | This is csInterface, a member of class TnxClassStub.
csIntfId | This is csIntfId, a member of class TnxClassStub.
csIntfPtr | This is csIntfPtr, a member of class TnxClassStub.
csPath | This is csPath, a member of class TnxClassStub.
csPortal | private
csStubRefs | This is csStubRefs, a member of class TnxClassStub.
csStubs | This is csStubs, a member of class TnxClassStub.
csTickCount | This is csTickCount, a member of class TnxClassStub.
Links
TnxClassStub Class, Legend, Protected Fields


TnxClassStub.csChannels Field

TnxClassStub.csChannels Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csChannels: TnxSortedList;
Description

This is csChannels, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csClassID Field

TnxClassStub.csClassID Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csClassID: TnxGuid;
Description

This is csClassID, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csDisconnected Field

TnxClassStub.csDisconnected Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csDisconnected: Boolean;
Description

This is csDisconnected, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csFactory Field

TnxClassStub.csFactory Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csFactory: TnxClassStubFactory;
Description

This is csFactory, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csFactoryRef Field

TnxClassStub.csFactoryRef Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csFactoryRef: InxInterface;
Description

This is csFactoryRef, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csInCallCount Field

TnxClassStub.csInCallCount Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csInCallCount: Integer;
Description

This is csInCallCount, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csInterface Field

TnxClassStub.csInterface Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csInterface: InxInterface;
Description

This is csInterface, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csIntfId Field

TnxClassStub.csIntfId Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csIntfId: Cardinal;
Description

This is csIntfId, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csIntfPtr Field

TnxClassStub.csIntfPtr Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csIntfPtr: Pointer;
Description

This is csIntfPtr, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csPath Field

TnxClassStub.csPath Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csPath: TnxRoutingPath;
Description

This is csPath, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csPortal Field

TnxClassStub.csPortal Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csPortal: TnxReadWritePortal;
Description

private

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csStubRefs Field

TnxClassStub.csStubRefs Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csStubRefs: array of InxInterfaceStub;
Description

This is csStubRefs, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csStubs Field

TnxClassStub.csStubs Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csStubs: TnxFastStringListCS;
Description

This is csStubs, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub.csTickCount Field

TnxClassStub.csTickCount Field
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Fields Send Feedback
Syntax
Delphi
csTickCount: Cardinal;
Description

This is csTickCount, a member of class TnxClassStub.

Group

TnxClassStub Fields

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Fields


TnxClassStub Methods

TnxClassStub Methods
TnxClassStub Class Legend Protected Methods Send Feedback

The methods of the TnxClassStub class are listed here.

Class

TnxClassStub Class

Protected Methods
Name | Description
_Release | InxInterface
Connected | InxChannelSink TnxClassStub
CreateClassStub |
csFinalizeDisconnect |
DisconnectAllChannels | InxClassStub
Disconnected |
DisconnectObject |
GetClassStubVersion |
GetInstanceID | TnxClassStub
GetRoutingPath | InxRoutingPath
Process |
ProcessCallInterfaceStub |
ProcessFindInterfaceStub |
ProcessFindInterfaceStubs |
QueryContainedInterface |
Supports | InxClassStubFactory
WriteClassProxyInfo |
Links
TnxClassStub Class, Legend, Protected Methods


TnxClassStub._Release Method

TnxClassStub._Release Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Description

InxInterface

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.Connected Method

TnxClassStub.Connected Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
procedure Connected(const aChannel: InxChannelExit); virtual;
Description

InxChannelSink

TnxClassStub

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.CreateClassStub Method

TnxClassStub.CreateClassStub Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
class function CreateClassStub(aFactory: TnxClassStubFactory; const aClassID: TnxGuid; const aInterface: InxInterface; out aClassStub: InxClassStub): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.csFinalizeDisconnect Method

TnxClassStub.csFinalizeDisconnect Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
procedure csFinalizeDisconnect;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.DisconnectAllChannels Method

TnxClassStub.DisconnectAllChannels Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function DisconnectAllChannels: HRESULT; virtual;
Description

InxClassStub

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.Disconnected Method

TnxClassStub.Disconnected Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
procedure Disconnected(const aChannel: InxChannelExit); virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.DisconnectObject Method

TnxClassStub.DisconnectObject Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function DisconnectObject: HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.GetClassStubVersion Method

TnxClassStub.GetClassStubVersion Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function GetClassStubVersion: Integer; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.GetInstanceID Method

TnxClassStub.GetInstanceID Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function GetInstanceID: TnxGuid;
Description

TnxClassStub

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.GetRoutingPath Method

TnxClassStub.GetRoutingPath Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function GetRoutingPath: TnxRoutingPath;
Description

InxRoutingPath

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.Process Method

TnxClassStub.Process Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function Process(const aChannel: InxChannelExit; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.ProcessCallInterfaceStub Method

TnxClassStub.ProcessCallInterfaceStub Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function ProcessCallInterfaceStub(const aChannel: InxChannelExit; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.ProcessFindInterfaceStub Method

TnxClassStub.ProcessFindInterfaceStub Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function ProcessFindInterfaceStub(const aChannel: InxChannelExit; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.ProcessFindInterfaceStubs Method

TnxClassStub.ProcessFindInterfaceStubs Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function ProcessFindInterfaceStubs(const aChannel: InxChannelExit; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.QueryContainedInterface Method

TnxClassStub.QueryContainedInterface Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function QueryContainedInterface(const IID: TGUID; out Obj): HResult; stdcall;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.Supports Method

TnxClassStub.Supports Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid): HRESULT; virtual;
Description

InxClassStubFactory

Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStub.WriteClassProxyInfo Method

TnxClassStub.WriteClassProxyInfo Method
TnxClassStub Class TnxClassStub Members nxrdClassStub Namespace TnxClassStub Methods Send Feedback
Syntax
Delphi
function WriteClassProxyInfo(const aWriter: InxWriter): HRESULT; virtual;
Group

TnxClassStub Methods

Links
TnxClassStub Class, TnxClassStub Members, nxrdClassStub Namespace, TnxClassStub Methods


TnxClassStubFactory Class

TnxClassStubFactory Class
TnxClassStubFactory Fields TnxClassStubFactory Methods TnxClassStubFactory Members nxrdClassStub Classes Send Feedback
Class Hierarchy
nxrdClassStub_TnxClassStubFactorynxrdClassStub_TnxClassStubFactorynxrdClassStub_TnxClassStubFactorynxrdClassStub_TnxClassStubFactory
Syntax
Delphi
TnxClassStubFactory = class(TnxInterfacedObject, InxClassStubFactory);
File

nxrdClassStub

Description

This is class nxrdClassStub.TnxClassStubFactory.

Group

Classes

Links
TnxClassStubFactory Fields, TnxClassStubFactory Methods, TnxClassStubFactory Members, nxrdClassStub, Classes


TnxClassStubFactory Members

TnxClassStubFactory Members
TnxClassStubFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassStubFactory.

Class

TnxClassStubFactory Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
shfClassStubClass | This is shfClassStubClass, a member of class TnxClassStubFactory.
shfMapping | This is shfMapping, a member of class TnxClassStubFactory.
shfPadlock | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateClassStub |
FindInstance | This is the overview for the FindInstance method overload.
ioDeactivate |
QueryInterface |
Supports | InxClassStubFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxClassStubFactory
Destroy |
FindInstance | This is the overview for the FindInstance method overload.
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassStubFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassStubFactory.Create Constructor

TnxClassStubFactory.Create Constructor
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Class Send Feedback
Syntax
Delphi
constructor Create(aClassStubClass: TnxClassStubClass);
Description

TnxClassStubFactory

Class

TnxClassStubFactory Class

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Class


TnxClassStubFactory.Destroy Destructor

TnxClassStubFactory.Destroy Destructor
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxClassStubFactory Class

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Class


TnxClassStubFactory Fields

TnxClassStubFactory Fields
TnxClassStubFactory Class Legend Protected Fields Send Feedback

The fields of the TnxClassStubFactory class are listed here.

Class

TnxClassStubFactory Class

Protected Fields
Name | Description
shfClassStubClass | This is shfClassStubClass, a member of class TnxClassStubFactory.
shfMapping | This is shfMapping, a member of class TnxClassStubFactory.
shfPadlock | private
Links
TnxClassStubFactory Class, Legend, Protected Fields


TnxClassStubFactory.shfClassStubClass Field

TnxClassStubFactory.shfClassStubClass Field
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Fields Send Feedback
Syntax
Delphi
shfClassStubClass: TnxClassStubClass;
Description

This is shfClassStubClass, a member of class TnxClassStubFactory.

Group

TnxClassStubFactory Fields

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Fields


TnxClassStubFactory.shfMapping Field

TnxClassStubFactory.shfMapping Field
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Fields Send Feedback
Syntax
Delphi
shfMapping: TnxSortedList;
Description

This is shfMapping, a member of class TnxClassStubFactory.

Group

TnxClassStubFactory Fields

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Fields


TnxClassStubFactory.shfPadlock Field

TnxClassStubFactory.shfPadlock Field
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Fields Send Feedback
Syntax
Delphi
shfPadlock: TnxPadlock;
Description

private

Group

TnxClassStubFactory Fields

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Fields


TnxClassStubFactory Methods

TnxClassStubFactory Methods
TnxClassStubFactory Class Legend Protected Methods Send Feedback

The methods of the TnxClassStubFactory class are listed here.

Class

TnxClassStubFactory Class

Protected Methods
Name | Description
CreateClassStub |
FindInstance | This is the overview for the FindInstance method overload.
Supports | InxClassStubFactory
Links
TnxClassStubFactory Class, Legend, Protected Methods


TnxClassStubFactory.CreateClassStub Method

TnxClassStubFactory.CreateClassStub Method
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Methods Send Feedback
Syntax
Delphi
function CreateClassStub(const aClassID: TnxGuid; const aInterface: InxInterface; out aClassStub: InxClassStub): HRESULT;
Group

TnxClassStubFactory Methods

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Methods


FindInstance Method

FindInstance Method
TnxClassStubFactory Methods Send Feedback

This is the overview for the FindInstance method overload.

Overload List
Name | Description
TnxClassStubFactory.FindInstance (InxInterface, InxClassStub) |
TnxClassStubFactory.FindInstance (TnxGuid, InxClassStub) |
Group

TnxClassStubFactory Methods

Links
TnxClassStubFactory Methods


TnxClassStubFactory.FindInstance Method (InxInterface, InxClassStub)

TnxClassStubFactory.FindInstance Method (InxInterface, InxClassStub)
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstance: InxInterface; out aClassStub: InxClassStub): HRESULT; overload;
Group

FindInstance Method

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, FindInstance Method


TnxClassStubFactory.FindInstance Method (TnxGuid, InxClassStub)

TnxClassStubFactory.FindInstance Method (TnxGuid, InxClassStub)
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace FindInstance Method Send Feedback
Syntax
Delphi
function FindInstance(const aInstanceID: TnxGuid; out aClassStub: InxClassStub): HRESULT; overload;
Group

FindInstance Method

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, FindInstance Method


TnxClassStubFactory.Supports Method

TnxClassStubFactory.Supports Method
TnxClassStubFactory Class TnxClassStubFactory Members nxrdClassStub Namespace TnxClassStubFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid): HRESULT;
Description

InxClassStubFactory

Group

TnxClassStubFactory Methods

Links
TnxClassStubFactory Class, TnxClassStubFactory Members, nxrdClassStub Namespace, TnxClassStubFactory Methods


Structs, Records, Enums

Structs, Records, Enums
nxrdClassStub Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxrdClassStub Namespace

Records
Name | Description
TnxInstanceID | This is record nxrdClassStub.TnxInstanceID.
Links
nxrdClassStub Namespace, Legend, Records


nxrdClassStub.TnxInstanceID Record

nxrdClassStub.TnxInstanceID Record
nxrdClassStub Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInstanceID = packed record
  iiClassStub: Cardinal;
  iiInterface: Cardinal;
  iiTickCount: Cardinal;
  iiCheckSum: Cardinal;
end;
File

nxrdClassStub

Description

This is record nxrdClassStub.TnxInstanceID.

Group

Structs, Records, Enums

Links
nxrdClassStub, Structs, Records, Enums


Types

Types
nxrdClassStub Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrdClassStub Namespace

Types
Name | Description
PnxInstanceID | This is type nxrdClassStub.PnxInstanceID.
TnxClassStubClass | This is type nxrdClassStub.TnxClassStubClass.
Links
nxrdClassStub Namespace, Types


nxrdClassStub.PnxInstanceID Type

nxrdClassStub.PnxInstanceID Type
nxrdClassStub Types Send Feedback
Syntax
Delphi
PnxInstanceID = ^TnxInstanceID;
File

nxrdClassStub

Description

This is type nxrdClassStub.PnxInstanceID.

Group

Types

Links
nxrdClassStub, Types


nxrdClassStub.TnxClassStubClass Type

nxrdClassStub.TnxClassStubClass Type
nxrdClassStub Types Send Feedback
Syntax
Delphi
TnxClassStubClass = class of TnxClassStub;
File

nxrdClassStub

Description

This is type nxrdClassStub.TnxClassStubClass.

Group

Types

Links
nxrdClassStub, Types


Variables

Variables
nxrdClassStub Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrdClassStub Namespace

Variables
Name | Description
Control |
Links
nxrdClassStub Namespace, Variables


nxrdClassStub.Control Variable

nxrdClassStub.Control Variable
nxrdClassStub Variables Send Feedback
Syntax
Delphi
Control: InxClassStubFactoryControl;
File

nxrdClassStub

Group

Variables

Links
nxrdClassStub, Variables


nxrdInterfaceHandlerClassActivator Namespace

nxrdInterfaceHandlerClassActivator Namespace
Classes Constants Legend Topics Variables Send Feedback

This is namespace nxrdInterfaceHandlerClassActivator.

Classes
Name | Description
TnxClassActivatorInterfaceProxy | This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceProxy.
TnxClassActivatorInterfaceStub | This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceStub.
Constants
Name | Description
DefaultClassActivatorInterfaceProxyID | RegisterFactories
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
ClassActivatorInterfaceProxyControl |
ClassActivatorInterfaceStubControl | This is variable nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceStubControl.
Links
Classes, Constants, Legend, Topics, Variables


Classes

Classes
Classes nxrdInterfaceHandlerClassActivator Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxClassActivatorInterfaceProxy | This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceProxy.
TnxClassActivatorInterfaceStub | This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceStub.
Namespace

nxrdInterfaceHandlerClassActivator Namespace

Links
Classes, nxrdInterfaceHandlerClassActivator Namespace, Legend


TnxClassActivatorInterfaceProxy Class

TnxClassActivatorInterfaceProxy Class
TnxClassActivatorInterfaceProxy Methods TnxClassActivatorInterfaceProxy Members nxrdInterfaceHandlerClassActivator Classes Send Feedback
Class Hierarchy
nxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxynxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxynxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxynxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxynxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxynxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceProxy
Syntax
Delphi
TnxClassActivatorInterfaceProxy = class(TnxInterfaceProxy, InxClassActivator);
File

nxrdInterfaceHandlerClassActivator

Description

This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceProxy.

Group

Classes

Links
TnxClassActivatorInterfaceProxy Methods, TnxClassActivatorInterfaceProxy Members, nxrdInterfaceHandlerClassActivator, Classes


TnxClassActivatorInterfaceProxy Members

TnxClassActivatorInterfaceProxy Members
TnxClassActivatorInterfaceProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassActivatorInterfaceProxy.

Class

TnxClassActivatorInterfaceProxy Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
pxClassID | private
pxClassProxy | This is pxClassProxy, a member of class TnxInterfaceProxy.
pxInterfaceID | This is pxInterfaceID, a member of class TnxInterfaceProxy.
pxStubID | This is pxStubID, a member of class TnxInterfaceProxy.
pxStubVersion | This is pxStubVersion, a member of class TnxInterfaceProxy.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_AddRef |
_ProxyAddRef |
_ProxyRelease |
_Release |
_Release |
CreateInstance | InxClassActivator TnxClassActivatorInterfaceProxy
CreateInterfaceProxy |
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
GetSharedVersion |
GetWriter |
ioDeactivate |
Process |
ProxyQueryInterface | InxInterfaceProxy
pxQueryInterface |
QueryInterface |
QueryInterface | InxInterface
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Create | TnxInterfaceProxy
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassActivatorInterfaceProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassActivatorInterfaceProxy Methods

TnxClassActivatorInterfaceProxy Methods
TnxClassActivatorInterfaceProxy Class Legend Protected Methods Send Feedback

The methods of the TnxClassActivatorInterfaceProxy class are listed here.

Class

TnxClassActivatorInterfaceProxy Class

Protected Methods
Name | Description
CreateInstance | InxClassActivator TnxClassActivatorInterfaceProxy
Links
TnxClassActivatorInterfaceProxy Class, Legend, Protected Methods


TnxClassActivatorInterfaceProxy.CreateInstance Method

TnxClassActivatorInterfaceProxy.CreateInstance Method
TnxClassActivatorInterfaceProxy Class TnxClassActivatorInterfaceProxy Members nxrdInterfaceHandlerClassActivator Namespace TnxClassActivatorInterfaceProxy Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aClass): HRESULT;
Description

InxClassActivator

TnxClassActivatorInterfaceProxy

Group

TnxClassActivatorInterfaceProxy Methods

Links
TnxClassActivatorInterfaceProxy Class, TnxClassActivatorInterfaceProxy Members, nxrdInterfaceHandlerClassActivator Namespace, TnxClassActivatorInterfaceProxy Methods


TnxClassActivatorInterfaceStub Class

TnxClassActivatorInterfaceStub Class
TnxClassActivatorInterfaceStub Methods TnxClassActivatorInterfaceStub Members nxrdInterfaceHandlerClassActivator Classes Send Feedback
Class Hierarchy
nxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceStubnxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceStubnxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceStubnxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceStubnxrdInterfaceHandlerClassActivator_TnxClassActivatorInterfaceStub
Syntax
Delphi
TnxClassActivatorInterfaceStub = class(TnxInterfaceStub);
File

nxrdInterfaceHandlerClassActivator

Description

This is class nxrdInterfaceHandlerClassActivator.TnxClassActivatorInterfaceStub.

Group

Classes

Links
TnxClassActivatorInterfaceStub Methods, TnxClassActivatorInterfaceStub Members, nxrdInterfaceHandlerClassActivator, Classes


TnxClassActivatorInterfaceStub Members

TnxClassActivatorInterfaceStub Members
TnxClassActivatorInterfaceStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClassActivatorInterfaceStub.

Class

TnxClassActivatorInterfaceStub Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
stClassID | private
stInterface | This is stInterface, a member of class TnxInterfaceStub.
stInterfaceID | This is stInterfaceID, a member of class TnxInterfaceStub.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ChannelAttached | TnxInterfaceStub
CreateInterfaceStub |
GetMinVersion |
GetStubVersion | TnxInterfaceStub
ioDeactivate |
Process | InxInterfaceStub
ProcessCallMethod | TnxInterfaceStub TnxClassActivatorInterfaceStub
ProcessCreateInstance | TnxClassActivatorInterfaceStub
QueryInterface |
Supports | InxInterfaceStubFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
ChannelAttached | This is ChannelAttached, a member of class InxInterfaceStub.
Create |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Process | This is Process, a member of class InxInterfaceStub.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxClassActivatorInterfaceStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClassActivatorInterfaceStub Methods

TnxClassActivatorInterfaceStub Methods
TnxClassActivatorInterfaceStub Class Legend Protected Methods Send Feedback

The methods of the TnxClassActivatorInterfaceStub class are listed here.

Class

TnxClassActivatorInterfaceStub Class

Protected Methods
Name | Description
ProcessCallMethod | TnxInterfaceStub TnxClassActivatorInterfaceStub
ProcessCreateInstance | TnxClassActivatorInterfaceStub
Links
TnxClassActivatorInterfaceStub Class, Legend, Protected Methods


TnxClassActivatorInterfaceStub.ProcessCallMethod Method

TnxClassActivatorInterfaceStub.ProcessCallMethod Method
TnxClassActivatorInterfaceStub Class TnxClassActivatorInterfaceStub Members nxrdInterfaceHandlerClassActivator Namespace TnxClassActivatorInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessCallMethod(const aChannel: InxChannelExit; const aClassStub: InxClassStub; aMessageVersion: Integer; aMethod: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT; override;
Description

TnxInterfaceStub

TnxClassActivatorInterfaceStub

Group

TnxClassActivatorInterfaceStub Methods

Links
TnxClassActivatorInterfaceStub Class, TnxClassActivatorInterfaceStub Members, nxrdInterfaceHandlerClassActivator Namespace, TnxClassActivatorInterfaceStub Methods


TnxClassActivatorInterfaceStub.ProcessCreateInstance Method

TnxClassActivatorInterfaceStub.ProcessCreateInstance Method
TnxClassActivatorInterfaceStub Class TnxClassActivatorInterfaceStub Members nxrdInterfaceHandlerClassActivator Namespace TnxClassActivatorInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessCreateInstance(aMessageVersion: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

TnxClassActivatorInterfaceStub

Group

TnxClassActivatorInterfaceStub Methods

Links
TnxClassActivatorInterfaceStub Class, TnxClassActivatorInterfaceStub Members, nxrdInterfaceHandlerClassActivator Namespace, TnxClassActivatorInterfaceStub Methods


Variables

Variables
nxrdInterfaceHandlerClassActivator Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrdInterfaceHandlerClassActivator Namespace

Variables
Name | Description
ClassActivatorInterfaceProxyControl |
ClassActivatorInterfaceStubControl | This is variable nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceStubControl.
Links
nxrdInterfaceHandlerClassActivator Namespace, Variables


nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceProxyControl Variable

nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceProxyControl Variable
nxrdInterfaceHandlerClassActivator Variables Send Feedback
Syntax
Delphi
ClassActivatorInterfaceProxyControl: InxInterfaceProxyFactoryControl;
File

nxrdInterfaceHandlerClassActivator

Group

Variables

Links
nxrdInterfaceHandlerClassActivator, Variables


nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceStubControl Variable

nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceStubControl Variable
nxrdInterfaceHandlerClassActivator Variables Send Feedback
Syntax
Delphi
ClassActivatorInterfaceStubControl: InxInterfaceStubFactoryControl;
File

nxrdInterfaceHandlerClassActivator

Description

This is variable nxrdInterfaceHandlerClassActivator.ClassActivatorInterfaceStubControl.

Group

Variables

Links
nxrdInterfaceHandlerClassActivator, Variables


Constants

Constants
Constants nxrdInterfaceHandlerClassActivator Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DefaultClassActivatorInterfaceProxyID | RegisterFactories
Namespace

nxrdInterfaceHandlerClassActivator Namespace

Links
Constants, nxrdInterfaceHandlerClassActivator Namespace


nxrdInterfaceHandlerClassActivator.DefaultClassActivatorInterfaceProxyID Constant

nxrdInterfaceHandlerClassActivator.DefaultClassActivatorInterfaceProxyID Constant
nxrdInterfaceHandlerClassActivator Constants Send Feedback
Syntax
Delphi
DefaultClassActivatorInterfaceProxyID: TnxGuid = '{EEFAEBEB-124E-4B84-9F0E-3A1388ED9A2A}';
File

nxrdInterfaceHandlerClassActivator

Description

RegisterFactories

Group

Constants

Links
nxrdInterfaceHandlerClassActivator, Constants


nxrdInterfaceProxy Namespace

nxrdInterfaceProxy Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxrdInterfaceProxy.

Classes
Name | Description
TnxInterfaceProxy | This is class nxrdInterfaceProxy.TnxInterfaceProxy.
TnxInterfaceProxyFactory | This is class nxrdInterfaceProxy.TnxInterfaceProxyFactory.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxInterfaceProxyClass | This is type nxrdInterfaceProxy.TnxInterfaceProxyClass.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxrdInterfaceProxy Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInterfaceProxy | This is class nxrdInterfaceProxy.TnxInterfaceProxy.
TnxInterfaceProxyFactory | This is class nxrdInterfaceProxy.TnxInterfaceProxyFactory.
Namespace

nxrdInterfaceProxy Namespace

Links
Classes, nxrdInterfaceProxy Namespace, Legend


TnxInterfaceProxy Class

TnxInterfaceProxy Class
TnxInterfaceProxy Fields TnxInterfaceProxy Methods TnxInterfaceProxy Members nxrdInterfaceProxy Classes Send Feedback
Class Hierarchy
nxrdInterfaceProxy_TnxInterfaceProxynxrdInterfaceProxy_TnxInterfaceProxynxrdInterfaceProxy_TnxInterfaceProxynxrdInterfaceProxy_TnxInterfaceProxy
Syntax
Delphi
TnxInterfaceProxy = class(TnxInterfacedObject, InxInterface, InxInterfaceProxy);
File

nxrdInterfaceProxy

Description

This is class nxrdInterfaceProxy.TnxInterfaceProxy.

Group

Classes

Links
TnxInterfaceProxy Fields, TnxInterfaceProxy Methods, TnxInterfaceProxy Members, nxrdInterfaceProxy, Classes


TnxInterfaceProxy Members

TnxInterfaceProxy Members
TnxInterfaceProxy Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceProxy.

Class

TnxInterfaceProxy Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
pxClassID | private
pxClassProxy | This is pxClassProxy, a member of class TnxInterfaceProxy.
pxInterfaceID | This is pxInterfaceID, a member of class TnxInterfaceProxy.
pxStubID | This is pxStubID, a member of class TnxInterfaceProxy.
pxStubVersion | This is pxStubVersion, a member of class TnxInterfaceProxy.
Protected Methods
Name | Description
_AddRef |
_ProxyAddRef |
_ProxyRelease |
_Release |
CreateInterfaceProxy |
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
GetSharedVersion |
GetWriter |
ioDeactivate |
Process |
ProxyQueryInterface | InxInterfaceProxy
pxQueryInterface |
QueryInterface | InxInterface
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceProxy
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceProxy Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceProxy.Create Constructor

TnxInterfaceProxy.Create Constructor
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterfaceStubID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aResult: HRESULT); virtual;
Description

TnxInterfaceProxy

Class

TnxInterfaceProxy Class

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Class


TnxInterfaceProxy Fields

TnxInterfaceProxy Fields
TnxInterfaceProxy Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceProxy class are listed here.

Class

TnxInterfaceProxy Class

Protected Fields
Name | Description
pxClassID | private
pxClassProxy | This is pxClassProxy, a member of class TnxInterfaceProxy.
pxInterfaceID | This is pxInterfaceID, a member of class TnxInterfaceProxy.
pxStubID | This is pxStubID, a member of class TnxInterfaceProxy.
pxStubVersion | This is pxStubVersion, a member of class TnxInterfaceProxy.
Links
TnxInterfaceProxy Class, Legend, Protected Fields


TnxInterfaceProxy.pxClassID Field

TnxInterfaceProxy.pxClassID Field
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Fields Send Feedback
Syntax
Delphi
pxClassID: TnxGuid;
Description

private

Group

TnxInterfaceProxy Fields

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Fields


TnxInterfaceProxy.pxClassProxy Field

TnxInterfaceProxy.pxClassProxy Field
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Fields Send Feedback
Syntax
Delphi
pxClassProxy: Pointer;
Description

This is pxClassProxy, a member of class TnxInterfaceProxy.

Group

TnxInterfaceProxy Fields

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Fields


TnxInterfaceProxy.pxInterfaceID Field

TnxInterfaceProxy.pxInterfaceID Field
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Fields Send Feedback
Syntax
Delphi
pxInterfaceID: TnxGuid;
Description

This is pxInterfaceID, a member of class TnxInterfaceProxy.

Group

TnxInterfaceProxy Fields

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Fields


TnxInterfaceProxy.pxStubID Field

TnxInterfaceProxy.pxStubID Field
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Fields Send Feedback
Syntax
Delphi
pxStubID: TnxGuid;
Description

This is pxStubID, a member of class TnxInterfaceProxy.

Group

TnxInterfaceProxy Fields

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Fields


TnxInterfaceProxy.pxStubVersion Field

TnxInterfaceProxy.pxStubVersion Field
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Fields Send Feedback
Syntax
Delphi
pxStubVersion: Integer;
Description

This is pxStubVersion, a member of class TnxInterfaceProxy.

Group

TnxInterfaceProxy Fields

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Fields


TnxInterfaceProxy Methods

TnxInterfaceProxy Methods
TnxInterfaceProxy Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceProxy class are listed here.

Class

TnxInterfaceProxy Class

Protected Methods
Name | Description
_AddRef |
_ProxyAddRef |
_ProxyRelease |
_Release |
CreateInterfaceProxy |
GetMinVersion |
GetProxyVersion | TnxInterfaceProxy
GetSharedVersion |
GetWriter |
Process |
ProxyQueryInterface | InxInterfaceProxy
pxQueryInterface |
QueryInterface | InxInterface
Supports | InxInterfaceProxyFactory
Links
TnxInterfaceProxy Class, Legend, Protected Methods


TnxInterfaceProxy._AddRef Method

TnxInterfaceProxy._AddRef Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy._ProxyAddRef Method

TnxInterfaceProxy._ProxyAddRef Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function _ProxyAddRef: Integer; stdcall;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy._ProxyRelease Method

TnxInterfaceProxy._ProxyRelease Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function _ProxyRelease: Integer; stdcall;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy._Release Method

TnxInterfaceProxy._Release Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.CreateInterfaceProxy Method

TnxInterfaceProxy.CreateInterfaceProxy Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
class function CreateInterfaceProxy(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterfaceStubID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aInterfaceProxy: InxInterfaceProxy): HRESULT; virtual;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.GetMinVersion Method

TnxInterfaceProxy.GetMinVersion Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetMinVersion: Integer; virtual;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.GetProxyVersion Method

TnxInterfaceProxy.GetProxyVersion Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetProxyVersion: Integer; virtual;
Description

TnxInterfaceProxy

Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.GetSharedVersion Method

TnxInterfaceProxy.GetSharedVersion Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetSharedVersion: Integer;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.GetWriter Method

TnxInterfaceProxy.GetWriter Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function GetWriter(aOperation: TnxInterfaceStubOp; out aMessageVersion: Integer; out aWriter: InxWriter): HRESULT; virtual;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.Process Method

TnxInterfaceProxy.Process Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function Process(const aWriter: InxWriter; out aReader: InxReader): HRESULT; virtual;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.ProxyQueryInterface Method

TnxInterfaceProxy.ProxyQueryInterface Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function ProxyQueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterfaceProxy

Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.pxQueryInterface Method

TnxInterfaceProxy.pxQueryInterface Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function pxQueryInterface(constref const IID: TGUID; out Obj): HResult; virtual; stdcall;
Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.QueryInterface Method

TnxInterfaceProxy.QueryInterface Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxy.Supports Method

TnxInterfaceProxy.Supports Method
TnxInterfaceProxy Class TnxInterfaceProxy Members nxrdInterfaceProxy Namespace TnxInterfaceProxy Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT; virtual;
Description

InxInterfaceProxyFactory

Group

TnxInterfaceProxy Methods

Links
TnxInterfaceProxy Class, TnxInterfaceProxy Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxy Methods


TnxInterfaceProxyFactory Class

TnxInterfaceProxyFactory Class
TnxInterfaceProxyFactory Fields TnxInterfaceProxyFactory Methods TnxInterfaceProxyFactory Members nxrdInterfaceProxy Classes Send Feedback
Class Hierarchy
nxrdInterfaceProxy_TnxInterfaceProxyFactorynxrdInterfaceProxy_TnxInterfaceProxyFactorynxrdInterfaceProxy_TnxInterfaceProxyFactorynxrdInterfaceProxy_TnxInterfaceProxyFactory
Syntax
Delphi
TnxInterfaceProxyFactory = class(TnxInterfacedObject, InxInterfaceProxyFactory);
File

nxrdInterfaceProxy

Description

This is class nxrdInterfaceProxy.TnxInterfaceProxyFactory.

Group

Classes

Links
TnxInterfaceProxyFactory Fields, TnxInterfaceProxyFactory Methods, TnxInterfaceProxyFactory Members, nxrdInterfaceProxy, Classes


TnxInterfaceProxyFactory Members

TnxInterfaceProxyFactory Members
TnxInterfaceProxyFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceProxyFactory.

Class

TnxInterfaceProxyFactory Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
pfProxyClass | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInterfaceProxy |
ioDeactivate |
QueryInterface |
Supports | InxInterfaceProxyFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceProxyFactory
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceProxyFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceProxyFactory.Create Constructor

TnxInterfaceProxyFactory.Create Constructor
TnxInterfaceProxyFactory Class TnxInterfaceProxyFactory Members nxrdInterfaceProxy Namespace TnxInterfaceProxyFactory Class Send Feedback
Syntax
Delphi
constructor Create(aInterfaceProxyClass: TnxInterfaceProxyClass);
Description

TnxInterfaceProxyFactory

Class

TnxInterfaceProxyFactory Class

Links
TnxInterfaceProxyFactory Class, TnxInterfaceProxyFactory Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxyFactory Class


TnxInterfaceProxyFactory Fields

TnxInterfaceProxyFactory Fields
TnxInterfaceProxyFactory Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceProxyFactory class are listed here.

Class

TnxInterfaceProxyFactory Class

Protected Fields
Name | Description
pfProxyClass | private
Links
TnxInterfaceProxyFactory Class, Legend, Protected Fields


TnxInterfaceProxyFactory.pfProxyClass Field

TnxInterfaceProxyFactory.pfProxyClass Field
TnxInterfaceProxyFactory Class TnxInterfaceProxyFactory Members nxrdInterfaceProxy Namespace TnxInterfaceProxyFactory Fields Send Feedback
Syntax
Delphi
pfProxyClass: TnxInterfaceProxyClass;
Description

private

Group

TnxInterfaceProxyFactory Fields

Links
TnxInterfaceProxyFactory Class, TnxInterfaceProxyFactory Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxyFactory Fields


TnxInterfaceProxyFactory Methods

TnxInterfaceProxyFactory Methods
TnxInterfaceProxyFactory Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceProxyFactory class are listed here.

Class

TnxInterfaceProxyFactory Class

Protected Methods
Name | Description
CreateInterfaceProxy |
Supports | InxInterfaceProxyFactory
Links
TnxInterfaceProxyFactory Class, Legend, Protected Methods


TnxInterfaceProxyFactory.CreateInterfaceProxy Method

TnxInterfaceProxyFactory.CreateInterfaceProxy Method
TnxInterfaceProxyFactory Class TnxInterfaceProxyFactory Members nxrdInterfaceProxy Namespace TnxInterfaceProxyFactory Methods Send Feedback
Syntax
Delphi
function CreateInterfaceProxy(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterfaceStubID: TnxGuid; const aClassProxy: InxClassProxy; const aReader: InxReader; out aInterfaceProxy: InxInterfaceProxy): HRESULT;
Group

TnxInterfaceProxyFactory Methods

Links
TnxInterfaceProxyFactory Class, TnxInterfaceProxyFactory Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxyFactory Methods


TnxInterfaceProxyFactory.Supports Method

TnxInterfaceProxyFactory.Supports Method
TnxInterfaceProxyFactory Class TnxInterfaceProxyFactory Members nxrdInterfaceProxy Namespace TnxInterfaceProxyFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

InxInterfaceProxyFactory

Group

TnxInterfaceProxyFactory Methods

Links
TnxInterfaceProxyFactory Class, TnxInterfaceProxyFactory Members, nxrdInterfaceProxy Namespace, TnxInterfaceProxyFactory Methods


Types

Types
nxrdInterfaceProxy Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrdInterfaceProxy Namespace

Types
Name | Description
TnxInterfaceProxyClass | This is type nxrdInterfaceProxy.TnxInterfaceProxyClass.
Links
nxrdInterfaceProxy Namespace, Types


nxrdInterfaceProxy.TnxInterfaceProxyClass Type

nxrdInterfaceProxy.TnxInterfaceProxyClass Type
nxrdInterfaceProxy Types Send Feedback
Syntax
Delphi
TnxInterfaceProxyClass = class of TnxInterfaceProxy;
File

nxrdInterfaceProxy

Description

This is type nxrdInterfaceProxy.TnxInterfaceProxyClass.

Group

Types

Links
nxrdInterfaceProxy, Types


nxrdInterfaceShared Namespace

nxrdInterfaceShared Namespace
Legend Structs, Records, Enums Topics Send Feedback

This is namespace nxrdInterfaceShared.

Structs, Records, Enums
Name | Description
TnxInterfaceStubOp | This is record nxrdInterfaceShared.TnxInterfaceStubOp.
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Links
Legend, Structs, Records, Enums, Topics


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrdInterfaceShared Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxInterfaceStubOp | This is record nxrdInterfaceShared.TnxInterfaceStubOp.
Namespace

nxrdInterfaceShared Namespace

Links
Enumerations, nxrdInterfaceShared Namespace, Legend


nxrdInterfaceShared.TnxInterfaceStubOp Enumeration

nxrdInterfaceShared.TnxInterfaceStubOp Enumeration
nxrdInterfaceShared Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInterfaceStubOp = ( soCallMethod );
File

nxrdInterfaceShared

Description

This is record nxrdInterfaceShared.TnxInterfaceStubOp.

Group

Structs, Records, Enums

Links
nxrdInterfaceShared, Structs, Records, Enums


nxrdInterfaceStub Namespace

nxrdInterfaceStub Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxrdInterfaceStub.

Classes
Name | Description
TnxInterfaceStub | This is class nxrdInterfaceStub.TnxInterfaceStub.
TnxInterfaceStubFactory | This is class nxrdInterfaceStub.TnxInterfaceStubFactory.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxInterfaceStubClass | This is type nxrdInterfaceStub.TnxInterfaceStubClass.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxrdInterfaceStub Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxInterfaceStub | This is class nxrdInterfaceStub.TnxInterfaceStub.
TnxInterfaceStubFactory | This is class nxrdInterfaceStub.TnxInterfaceStubFactory.
Namespace

nxrdInterfaceStub Namespace

Links
Classes, nxrdInterfaceStub Namespace, Legend


TnxInterfaceStub Class

TnxInterfaceStub Class
TnxInterfaceStub Fields TnxInterfaceStub Methods TnxInterfaceStub Members nxrdInterfaceStub Classes Send Feedback
Class Hierarchy
nxrdInterfaceStub_TnxInterfaceStubnxrdInterfaceStub_TnxInterfaceStubnxrdInterfaceStub_TnxInterfaceStubnxrdInterfaceStub_TnxInterfaceStub
Syntax
Delphi
TnxInterfaceStub = class(TnxInterfacedObject, InxInterface, InxInterfaceStub);
File

nxrdInterfaceStub

Description

This is class nxrdInterfaceStub.TnxInterfaceStub.

Group

Classes

Links
TnxInterfaceStub Fields, TnxInterfaceStub Methods, TnxInterfaceStub Members, nxrdInterfaceStub, Classes


TnxInterfaceStub Members

TnxInterfaceStub Members
TnxInterfaceStub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceStub.

Class

TnxInterfaceStub Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
stClassID | private
stInterface | This is stInterface, a member of class TnxInterfaceStub.
stInterfaceID | This is stInterfaceID, a member of class TnxInterfaceStub.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ChannelAttached | TnxInterfaceStub
CreateInterfaceStub |
GetMinVersion |
GetStubVersion | TnxInterfaceStub
ioDeactivate |
Process | InxInterfaceStub
ProcessCallMethod |
QueryInterface |
Supports | InxInterfaceStubFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceStub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceStub.Create Constructor

TnxInterfaceStub.Create Constructor
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Class Send Feedback
Syntax
Delphi
constructor Create(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; var aResult: HRESULT); virtual;
Class

TnxInterfaceStub Class

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Class


TnxInterfaceStub Fields

TnxInterfaceStub Fields
TnxInterfaceStub Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceStub class are listed here.

Class

TnxInterfaceStub Class

Protected Fields
Name | Description
stClassID | private
stInterface | This is stInterface, a member of class TnxInterfaceStub.
stInterfaceID | This is stInterfaceID, a member of class TnxInterfaceStub.
Links
TnxInterfaceStub Class, Legend, Protected Fields


TnxInterfaceStub.stClassID Field

TnxInterfaceStub.stClassID Field
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Fields Send Feedback
Syntax
Delphi
stClassID: TnxGuid;
Description

private

Group

TnxInterfaceStub Fields

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Fields


TnxInterfaceStub.stInterface Field

TnxInterfaceStub.stInterface Field
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Fields Send Feedback
Syntax
Delphi
stInterface: InxInterface;
Description

This is stInterface, a member of class TnxInterfaceStub.

Group

TnxInterfaceStub Fields

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Fields


TnxInterfaceStub.stInterfaceID Field

TnxInterfaceStub.stInterfaceID Field
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Fields Send Feedback
Syntax
Delphi
stInterfaceID: TnxGuid;
Description

This is stInterfaceID, a member of class TnxInterfaceStub.

Group

TnxInterfaceStub Fields

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Fields


TnxInterfaceStub Methods

TnxInterfaceStub Methods
TnxInterfaceStub Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceStub class are listed here.

Class

TnxInterfaceStub Class

Protected Methods
Name | Description
ChannelAttached | TnxInterfaceStub
CreateInterfaceStub |
GetMinVersion |
GetStubVersion | TnxInterfaceStub
Process | InxInterfaceStub
ProcessCallMethod |
Supports | InxInterfaceStubFactory
Links
TnxInterfaceStub Class, Legend, Protected Methods


TnxInterfaceStub.ChannelAttached Method

TnxInterfaceStub.ChannelAttached Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
function ChannelAttached(const aChannel: InxChannelExit; const aClassStub: InxClassStub; const aReply: InxWriter): HRESULT; virtual;
Description

TnxInterfaceStub

Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.CreateInterfaceStub Method

TnxInterfaceStub.CreateInterfaceStub Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
class function CreateInterfaceStub(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInterfaceStub: InxInterfaceStub): HRESULT; virtual;
Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.GetMinVersion Method

TnxInterfaceStub.GetMinVersion Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
function GetMinVersion: Integer; virtual;
Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.GetStubVersion Method

TnxInterfaceStub.GetStubVersion Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
function GetStubVersion: Integer; virtual;
Description

TnxInterfaceStub

Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.Process Method

TnxInterfaceStub.Process Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
function Process(const aChannel: InxChannelExit; const aClassStub: InxClassStub; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Description

InxInterfaceStub

Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.ProcessCallMethod Method

TnxInterfaceStub.ProcessCallMethod Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
function ProcessCallMethod(const aChannel: InxChannelExit; const aClassStub: InxClassStub; aMessageVersion: Integer; aMethod: Integer; const aRequest: InxReader; const aReply: InxWriter): HRESULT; virtual;
Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStub.Supports Method

TnxInterfaceStub.Supports Method
TnxInterfaceStub Class TnxInterfaceStub Members nxrdInterfaceStub Namespace TnxInterfaceStub Methods Send Feedback
Syntax
Delphi
class function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT; virtual;
Description

InxInterfaceStubFactory

Group

TnxInterfaceStub Methods

Links
TnxInterfaceStub Class, TnxInterfaceStub Members, nxrdInterfaceStub Namespace, TnxInterfaceStub Methods


TnxInterfaceStubFactory Class

TnxInterfaceStubFactory Class
TnxInterfaceStubFactory Fields TnxInterfaceStubFactory Methods TnxInterfaceStubFactory Members nxrdInterfaceStub Classes Send Feedback
Class Hierarchy
nxrdInterfaceStub_TnxInterfaceStubFactorynxrdInterfaceStub_TnxInterfaceStubFactorynxrdInterfaceStub_TnxInterfaceStubFactorynxrdInterfaceStub_TnxInterfaceStubFactory
Syntax
Delphi
TnxInterfaceStubFactory = class(TnxInterfacedObject, InxInterfaceStubFactory);
File

nxrdInterfaceStub

Description

This is class nxrdInterfaceStub.TnxInterfaceStubFactory.

Group

Classes

Links
TnxInterfaceStubFactory Fields, TnxInterfaceStubFactory Methods, TnxInterfaceStubFactory Members, nxrdInterfaceStub, Classes


TnxInterfaceStubFactory Members

TnxInterfaceStubFactory Members
TnxInterfaceStubFactory Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfaceStubFactory.

Class

TnxInterfaceStubFactory Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
sfStubClass | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
CreateInterfaceStub |
ioDeactivate |
QueryInterface |
Supports | InxInterfaceStubFactory
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | TnxInterfaceStubFactory
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxInterfaceStubFactory Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfaceStubFactory.Create Constructor

TnxInterfaceStubFactory.Create Constructor
TnxInterfaceStubFactory Class TnxInterfaceStubFactory Members nxrdInterfaceStub Namespace TnxInterfaceStubFactory Class Send Feedback
Syntax
Delphi
constructor Create(aInterfaceStubClass: TnxInterfaceStubClass);
Description

TnxInterfaceStubFactory

Class

TnxInterfaceStubFactory Class

Links
TnxInterfaceStubFactory Class, TnxInterfaceStubFactory Members, nxrdInterfaceStub Namespace, TnxInterfaceStubFactory Class


TnxInterfaceStubFactory Fields

TnxInterfaceStubFactory Fields
TnxInterfaceStubFactory Class Legend Protected Fields Send Feedback

The fields of the TnxInterfaceStubFactory class are listed here.

Class

TnxInterfaceStubFactory Class

Protected Fields
Name | Description
sfStubClass | private
Links
TnxInterfaceStubFactory Class, Legend, Protected Fields


TnxInterfaceStubFactory.sfStubClass Field

TnxInterfaceStubFactory.sfStubClass Field
TnxInterfaceStubFactory Class TnxInterfaceStubFactory Members nxrdInterfaceStub Namespace TnxInterfaceStubFactory Fields Send Feedback
Syntax
Delphi
sfStubClass: TnxInterfaceStubClass;
Description

private

Group

TnxInterfaceStubFactory Fields

Links
TnxInterfaceStubFactory Class, TnxInterfaceStubFactory Members, nxrdInterfaceStub Namespace, TnxInterfaceStubFactory Fields


TnxInterfaceStubFactory Methods

TnxInterfaceStubFactory Methods
TnxInterfaceStubFactory Class Legend Protected Methods Send Feedback

The methods of the TnxInterfaceStubFactory class are listed here.

Class

TnxInterfaceStubFactory Class

Protected Methods
Name | Description
CreateInterfaceStub |
Supports | InxInterfaceStubFactory
Links
TnxInterfaceStubFactory Class, Legend, Protected Methods


TnxInterfaceStubFactory.CreateInterfaceStub Method

TnxInterfaceStubFactory.CreateInterfaceStub Method
TnxInterfaceStubFactory Class TnxInterfaceStubFactory Members nxrdInterfaceStub Namespace TnxInterfaceStubFactory Methods Send Feedback
Syntax
Delphi
function CreateInterfaceStub(const aClassID: TnxGuid; const aInterfaceID: TnxGuid; const aInterface: InxInterface; out aInterfaceStub: InxInterfaceStub): HRESULT;
Group

TnxInterfaceStubFactory Methods

Links
TnxInterfaceStubFactory Class, TnxInterfaceStubFactory Members, nxrdInterfaceStub Namespace, TnxInterfaceStubFactory Methods


TnxInterfaceStubFactory.Supports Method

TnxInterfaceStubFactory.Supports Method
TnxInterfaceStubFactory Class TnxInterfaceStubFactory Members nxrdInterfaceStub Namespace TnxInterfaceStubFactory Methods Send Feedback
Syntax
Delphi
function Supports(const aClassID: TnxGuid; const aInterfaceID: TnxGuid): HRESULT;
Description

InxInterfaceStubFactory

Group

TnxInterfaceStubFactory Methods

Links
TnxInterfaceStubFactory Class, TnxInterfaceStubFactory Members, nxrdInterfaceStub Namespace, TnxInterfaceStubFactory Methods


Types

Types
nxrdInterfaceStub Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrdInterfaceStub Namespace

Types
Name | Description
TnxInterfaceStubClass | This is type nxrdInterfaceStub.TnxInterfaceStubClass.
Links
nxrdInterfaceStub Namespace, Types


nxrdInterfaceStub.TnxInterfaceStubClass Type

nxrdInterfaceStub.TnxInterfaceStubClass Type
nxrdInterfaceStub Types Send Feedback
Syntax
Delphi
TnxInterfaceStubClass = class of TnxInterfaceStub;
File

nxrdInterfaceStub

Description

This is type nxrdInterfaceStub.TnxInterfaceStubClass.

Group

Types

Links
nxrdInterfaceStub, Types


nxRemoteDBServer Namespace

nxRemoteDBServer Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxRemoteDBServer.

Classes
Name | Description
TnxNexusDBConnectionAdapter | This is class nxRemoteDBServer.TnxNexusDBConnectionAdapter.
TnxRemoteDBModule | This is class nxRemoteDBServer.TnxRemoteDBModule.
TnxRemoteDBServer | This is class nxRemoteDBServer.TnxRemoteDBServer.
Constants
Name | Description
nxDefaultBaseUrl | This is constant nxRemoteDBServer.nxDefaultBaseUrl.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxRemoteDBServer Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxNexusDBConnectionAdapter | This is class nxRemoteDBServer.TnxNexusDBConnectionAdapter.
TnxRemoteDBModule | This is class nxRemoteDBServer.TnxRemoteDBModule.
TnxRemoteDBServer | This is class nxRemoteDBServer.TnxRemoteDBServer.
Namespace

nxRemoteDBServer Namespace

Links
Classes, nxRemoteDBServer Namespace, Legend


TnxNexusDBConnectionAdapter Class

TnxNexusDBConnectionAdapter Class
TnxNexusDBConnectionAdapter Fields TnxNexusDBConnectionAdapter Members nxRemoteDBServer Classes Send Feedback
Class Hierarchy
nxRemoteDBServer_TnxNexusDBConnectionAdapter
Syntax
Delphi
TnxNexusDBConnectionAdapter = class(TNexusDBConnectionAdapter);
File

nxRemoteDBServer

Description

This is class nxRemoteDBServer.TnxNexusDBConnectionAdapter.

Group

Classes

Links
TnxNexusDBConnectionAdapter Fields, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer, Classes


TnxNexusDBConnectionAdapter Members

TnxNexusDBConnectionAdapter Members
TnxNexusDBConnectionAdapter Class Legend Protected Fields Public Methods Send Feedback

The following tables list the members exposed by TnxNexusDBConnectionAdapter.

Class

TnxNexusDBConnectionAdapter Class

Protected Fields
Name | Description
nxcaDatabase | This is nxcaDatabase, a member of class TnxNexusDBConnectionAdapter.
nxcaModule | private
nxcaSession | This is nxcaSession, a member of class TnxNexusDBConnectionAdapter.
Public Methods
Name | Description
Create | TnxNexusDBConnectionAdapter
Destroy |
Links
TnxNexusDBConnectionAdapter Class, Legend, Protected Fields, Public Methods


TnxNexusDBConnectionAdapter.Create Constructor

TnxNexusDBConnectionAdapter.Create Constructor
TnxNexusDBConnectionAdapter Class TnxNexusDBConnectionAdapter Members nxRemoteDBServer Namespace TnxNexusDBConnectionAdapter Class Send Feedback
Syntax
Delphi
constructor Create(aModule: TnxRemoteDBModule; const aUserName: string; const aPassword: string);
Description

TnxNexusDBConnectionAdapter

Class

TnxNexusDBConnectionAdapter Class

Links
TnxNexusDBConnectionAdapter Class, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer Namespace, TnxNexusDBConnectionAdapter Class


TnxNexusDBConnectionAdapter.Destroy Destructor

TnxNexusDBConnectionAdapter.Destroy Destructor
TnxNexusDBConnectionAdapter Class TnxNexusDBConnectionAdapter Members nxRemoteDBServer Namespace TnxNexusDBConnectionAdapter Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxNexusDBConnectionAdapter Class

Links
TnxNexusDBConnectionAdapter Class, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer Namespace, TnxNexusDBConnectionAdapter Class


TnxNexusDBConnectionAdapter Fields

TnxNexusDBConnectionAdapter Fields
TnxNexusDBConnectionAdapter Class Legend Protected Fields Send Feedback

The fields of the TnxNexusDBConnectionAdapter class are listed here.

Class

TnxNexusDBConnectionAdapter Class

Protected Fields
Name | Description
nxcaDatabase | This is nxcaDatabase, a member of class TnxNexusDBConnectionAdapter.
nxcaModule | private
nxcaSession | This is nxcaSession, a member of class TnxNexusDBConnectionAdapter.
Links
TnxNexusDBConnectionAdapter Class, Legend, Protected Fields


TnxNexusDBConnectionAdapter.nxcaDatabase Field

TnxNexusDBConnectionAdapter.nxcaDatabase Field
TnxNexusDBConnectionAdapter Class TnxNexusDBConnectionAdapter Members nxRemoteDBServer Namespace TnxNexusDBConnectionAdapter Fields Send Feedback
Syntax
Delphi
nxcaDatabase: TnxDatabase;
Description

This is nxcaDatabase, a member of class TnxNexusDBConnectionAdapter.

Group

TnxNexusDBConnectionAdapter Fields

Links
TnxNexusDBConnectionAdapter Class, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer Namespace, TnxNexusDBConnectionAdapter Fields


TnxNexusDBConnectionAdapter.nxcaModule Field

TnxNexusDBConnectionAdapter.nxcaModule Field
TnxNexusDBConnectionAdapter Class TnxNexusDBConnectionAdapter Members nxRemoteDBServer Namespace TnxNexusDBConnectionAdapter Fields Send Feedback
Syntax
Delphi
nxcaModule: TnxRemoteDBModule;
Description

private

Group

TnxNexusDBConnectionAdapter Fields

Links
TnxNexusDBConnectionAdapter Class, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer Namespace, TnxNexusDBConnectionAdapter Fields


TnxNexusDBConnectionAdapter.nxcaSession Field

TnxNexusDBConnectionAdapter.nxcaSession Field
TnxNexusDBConnectionAdapter Class TnxNexusDBConnectionAdapter Members nxRemoteDBServer Namespace TnxNexusDBConnectionAdapter Fields Send Feedback
Syntax
Delphi
nxcaSession: TnxSession;
Description

This is nxcaSession, a member of class TnxNexusDBConnectionAdapter.

Group

TnxNexusDBConnectionAdapter Fields

Links
TnxNexusDBConnectionAdapter Class, TnxNexusDBConnectionAdapter Members, nxRemoteDBServer Namespace, TnxNexusDBConnectionAdapter Fields


TnxRemoteDBModule Class

TnxRemoteDBModule Class
TnxRemoteDBModule Fields TnxRemoteDBModule Methods TnxRemoteDBModule Members nxRemoteDBServer Classes Send Feedback
Class Hierarchy
nxRemoteDBServer_TnxRemoteDBModule
Syntax
Delphi
TnxRemoteDBModule = class(TCustomRemoteDBModule);
File

nxRemoteDBServer

Description

This is class nxRemoteDBServer.TnxRemoteDBModule.

Group

Classes

Links
TnxRemoteDBModule Fields, TnxRemoteDBModule Methods, TnxRemoteDBModule Members, nxRemoteDBServer, Classes


TnxRemoteDBModule Members

TnxRemoteDBModule Members
TnxRemoteDBModule Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxRemoteDBModule.

Class

TnxRemoteDBModule Class

Protected Fields
Name | Description
rdbmAlias | This is rdbmAlias, a member of class TnxRemoteDBModule.
rdbmServer | private
Protected Methods
Name | Description
AuthenticateUser | TnxRemoteDBModule
CreateConnection |
EnableApiForUser |
LocalAuthenticationRequired |
Public Methods
Name | Description
Create |
Links
TnxRemoteDBModule Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxRemoteDBModule.Create Constructor

TnxRemoteDBModule.Create Constructor
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Class Send Feedback
Syntax
Delphi
constructor Create(aServer: TnxRemoteDBServer; const aAlias: string);
Class

TnxRemoteDBModule Class

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Class


TnxRemoteDBModule Fields

TnxRemoteDBModule Fields
TnxRemoteDBModule Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteDBModule class are listed here.

Class

TnxRemoteDBModule Class

Protected Fields
Name | Description
rdbmAlias | This is rdbmAlias, a member of class TnxRemoteDBModule.
rdbmServer | private
Links
TnxRemoteDBModule Class, Legend, Protected Fields


TnxRemoteDBModule.rdbmAlias Field

TnxRemoteDBModule.rdbmAlias Field
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Fields Send Feedback
Syntax
Delphi
rdbmAlias: string;
Description

This is rdbmAlias, a member of class TnxRemoteDBModule.

Group

TnxRemoteDBModule Fields

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Fields


TnxRemoteDBModule.rdbmServer Field

TnxRemoteDBModule.rdbmServer Field
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Fields Send Feedback
Syntax
Delphi
rdbmServer: TnxRemoteDBServer;
Description

private

Group

TnxRemoteDBModule Fields

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Fields


TnxRemoteDBModule Methods

TnxRemoteDBModule Methods
TnxRemoteDBModule Class Legend Protected Methods Send Feedback

The methods of the TnxRemoteDBModule class are listed here.

Class

TnxRemoteDBModule Class

Protected Methods
Name | Description
AuthenticateUser | TnxRemoteDBModule
CreateConnection |
EnableApiForUser |
LocalAuthenticationRequired |
Links
TnxRemoteDBModule Class, Legend, Protected Methods


TnxRemoteDBModule.AuthenticateUser Method

TnxRemoteDBModule.AuthenticateUser Method
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Methods Send Feedback
Syntax
Delphi
function AuthenticateUser(AUserName: string; APassword: string): Boolean; override;
Description

TnxRemoteDBModule

Group

TnxRemoteDBModule Methods

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Methods


TnxRemoteDBModule.CreateConnection Method

TnxRemoteDBModule.CreateConnection Method
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Methods Send Feedback
Syntax
Delphi
function CreateConnection(Context: THttpServerContext; const aUserName: string; const aPassword: string): IDBConnection; override;
Group

TnxRemoteDBModule Methods

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Methods


TnxRemoteDBModule.EnableApiForUser Method

TnxRemoteDBModule.EnableApiForUser Method
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Methods Send Feedback
Syntax
Delphi
function EnableApiForUser(const aUserName: string; const aPassword: string): Boolean; override;
Group

TnxRemoteDBModule Methods

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Methods


TnxRemoteDBModule.LocalAuthenticationRequired Method

TnxRemoteDBModule.LocalAuthenticationRequired Method
TnxRemoteDBModule Class TnxRemoteDBModule Members nxRemoteDBServer Namespace TnxRemoteDBModule Methods Send Feedback
Syntax
Delphi
function LocalAuthenticationRequired: Boolean; override;
Group

TnxRemoteDBModule Methods

Links
TnxRemoteDBModule Class, TnxRemoteDBModule Members, nxRemoteDBServer Namespace, TnxRemoteDBModule Methods


TnxRemoteDBServer Class

TnxRemoteDBServer Class
TnxRemoteDBServer Fields TnxRemoteDBServer Methods TnxRemoteDBServer Properties TnxRemoteDBServer Members nxRemoteDBServer Classes Send Feedback
Class Hierarchy
nxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServernxRemoteDBServer_TnxRemoteDBServer
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemoteDBServer = class(TnxBaseEngineMonitor);
File

nxRemoteDBServer

Description

This is class nxRemoteDBServer.TnxRemoteDBServer.

Group

Classes

Links
TnxRemoteDBServer Fields, TnxRemoteDBServer Methods, TnxRemoteDBServer Properties, TnxRemoteDBServer Members, nxRemoteDBServer, Classes


TnxRemoteDBServer Members

TnxRemoteDBServer Members
TnxRemoteDBServer Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemoteDBServer.

Class

TnxRemoteDBServer Class

Protected Fields
Name | Description
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
rdbsAliases | This is rdbsAliases, a member of class TnxRemoteDBServer.
rdbsBaseUrl | This is rdbsBaseUrl, a member of class TnxRemoteDBServer.
rdbsEnableApiForAdmin | This is rdbsEnableApiForAdmin, a member of class TnxRemoteDBServer.
rdbsSecurityMonitor | This is rdbsSecurityMonitor, a member of class TnxRemoteDBServer.
rdbsServer | private
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bemSetServerEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
rdbsSetAliases |
rdbsSetBaseUrl |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
ExtendableObjectCreated | This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Aliases | This is Aliases, a member of class TnxRemoteDBServer.
BaseUrl | This is BaseUrl, a member of class TnxRemoteDBServer.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | This property links the Monitor to a server engine.
Version | Version of the component.
Links
TnxRemoteDBServer Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemoteDBServer.Create Constructor

TnxRemoteDBServer.Create Constructor
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxRemoteDBServer Class

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Class


TnxRemoteDBServer.Destroy Destructor

TnxRemoteDBServer.Destroy Destructor
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteDBServer Class

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Class


TnxRemoteDBServer Fields

TnxRemoteDBServer Fields
TnxRemoteDBServer Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteDBServer class are listed here.

Class

TnxRemoteDBServer Class

Protected Fields
Name | Description
rdbsAliases | This is rdbsAliases, a member of class TnxRemoteDBServer.
rdbsBaseUrl | This is rdbsBaseUrl, a member of class TnxRemoteDBServer.
rdbsEnableApiForAdmin | This is rdbsEnableApiForAdmin, a member of class TnxRemoteDBServer.
rdbsSecurityMonitor | This is rdbsSecurityMonitor, a member of class TnxRemoteDBServer.
rdbsServer | private
Links
TnxRemoteDBServer Class, Legend, Protected Fields


TnxRemoteDBServer.rdbsAliases Field

TnxRemoteDBServer.rdbsAliases Field
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Fields Send Feedback
Syntax
Delphi
rdbsAliases: string;
Description

This is rdbsAliases, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Fields

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Fields


TnxRemoteDBServer.rdbsBaseUrl Field

TnxRemoteDBServer.rdbsBaseUrl Field
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Fields Send Feedback
Syntax
Delphi
rdbsBaseUrl: string;
Description

This is rdbsBaseUrl, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Fields

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Fields


TnxRemoteDBServer.rdbsEnableApiForAdmin Field

TnxRemoteDBServer.rdbsEnableApiForAdmin Field
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Fields Send Feedback
Syntax
Delphi
rdbsEnableApiForAdmin: Boolean;
Description

This is rdbsEnableApiForAdmin, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Fields

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Fields


TnxRemoteDBServer.rdbsSecurityMonitor Field

TnxRemoteDBServer.rdbsSecurityMonitor Field
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Fields Send Feedback
Syntax
Delphi
rdbsSecurityMonitor: TnxSecurityMonitor;
Description

This is rdbsSecurityMonitor, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Fields

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Fields


TnxRemoteDBServer.rdbsServer Field

TnxRemoteDBServer.rdbsServer Field
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Fields Send Feedback
Syntax
Delphi
rdbsServer: THttpSysServer;
Description

private

Group

TnxRemoteDBServer Fields

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Fields


TnxRemoteDBServer Methods

TnxRemoteDBServer Methods
TnxRemoteDBServer Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteDBServer class are listed here.

Class

TnxRemoteDBServer Class

Protected Methods
Name | Description
rdbsSetAliases |
rdbsSetBaseUrl |
scDeactivating |
scInitializing |
scShowLastStartErrorInStats |
scShowUpTime |
scStarting |
scStopping |
Public Methods
Name | Description
GetConfigSettings |
LoadConfig |
SaveConfig |
Links
TnxRemoteDBServer Class, Legend, Protected Methods, Public Methods


TnxRemoteDBServer.GetConfigSettings Method

TnxRemoteDBServer.GetConfigSettings Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure GetConfigSettings(aSettings: TnxBaseSettings); override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.LoadConfig Method

TnxRemoteDBServer.LoadConfig Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure LoadConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.rdbsSetAliases Method

TnxRemoteDBServer.rdbsSetAliases Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure rdbsSetAliases(const Value: string);
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.rdbsSetBaseUrl Method

TnxRemoteDBServer.rdbsSetBaseUrl Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure rdbsSetBaseUrl(const Value: string);
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.SaveConfig Method

TnxRemoteDBServer.SaveConfig Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure SaveConfig(aConfig: TnxBaseComponentConfiguration); override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scDeactivating Method

TnxRemoteDBServer.scDeactivating Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure scDeactivating; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scInitializing Method

TnxRemoteDBServer.scInitializing Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scShowLastStartErrorInStats Method

TnxRemoteDBServer.scShowLastStartErrorInStats Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
function scShowLastStartErrorInStats: Boolean; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scShowUpTime Method

TnxRemoteDBServer.scShowUpTime Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
function scShowUpTime: Boolean; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scStarting Method

TnxRemoteDBServer.scStarting Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure scStarting; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer.scStopping Method

TnxRemoteDBServer.scStopping Method
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxRemoteDBServer Methods

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Methods


TnxRemoteDBServer Properties

TnxRemoteDBServer Properties
TnxRemoteDBServer Class Legend Public Properties Send Feedback

The properties of the TnxRemoteDBServer class are listed here.

Class

TnxRemoteDBServer Class

Public Properties
Name | Description
Aliases | This is Aliases, a member of class TnxRemoteDBServer.
BaseUrl | This is BaseUrl, a member of class TnxRemoteDBServer.
Links
TnxRemoteDBServer Class, Legend, Public Properties


TnxRemoteDBServer.Aliases Property

TnxRemoteDBServer.Aliases Property
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Properties Send Feedback
Syntax
Delphi
property Aliases: string;
Description

This is Aliases, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Properties

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Properties


TnxRemoteDBServer.BaseUrl Property

TnxRemoteDBServer.BaseUrl Property
TnxRemoteDBServer Class TnxRemoteDBServer Members nxRemoteDBServer Namespace TnxRemoteDBServer Properties Send Feedback
Syntax
Delphi
property BaseUrl: string;
Description

This is BaseUrl, a member of class TnxRemoteDBServer.

Group

TnxRemoteDBServer Properties

Links
TnxRemoteDBServer Class, TnxRemoteDBServer Members, nxRemoteDBServer Namespace, TnxRemoteDBServer Properties


Constants

Constants
Constants nxRemoteDBServer Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxDefaultBaseUrl | This is constant nxRemoteDBServer.nxDefaultBaseUrl.
Namespace

nxRemoteDBServer Namespace

Links
Constants, nxRemoteDBServer Namespace


nxRemoteDBServer.nxDefaultBaseUrl Constant

nxRemoteDBServer.nxDefaultBaseUrl Constant
nxRemoteDBServer Constants Send Feedback
Syntax
Delphi
nxDefaultBaseUrl = 'http://localhost:2001/nexusdb/';
File

nxRemoteDBServer

Description

This is constant nxRemoteDBServer.nxDefaultBaseUrl.

Group

Constants

Links
nxRemoteDBServer, Constants


nxReplacementCoMalloc Namespace

nxReplacementCoMalloc Namespace
Classes Interfaces Legend Topics Types Variables Send Feedback

This is namespace nxReplacementCoMalloc.

Classes
Name | Description
TnxMalloc | ===TnxMalloc================================================================== Implementation of IMalloc, the object is "allocated" from a static block of memory from the data segment (_nxMallocMemory), it doesn't implement it's own reference counting, but active references to it are considered references to the heap manager. Only a single instance is ever created.
Interfaces
Name | Description
IMalloc | This is class nxReplacementCoMalloc.IMalloc.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TCoGetMalloc | This is type nxReplacementCoMalloc.TCoGetMalloc.
TCoTaskMemAlloc | This is type nxReplacementCoMalloc.TCoTaskMemAlloc.
TCoTaskMemFree | This is type nxReplacementCoMalloc.TCoTaskMemFree.
TCoTaskMemRealloc | This is type nxReplacementCoMalloc.TCoTaskMemRealloc.
Variables
Name | Description
_malloc | This is variable nxReplacementCoMalloc._malloc.
_nxMallocMemory |
NextCoCreateStandardMalloc | This is variable nxReplacementCoMalloc.NextCoCreateStandardMalloc.
NextCoGetMalloc | This is variable nxReplacementCoMalloc.NextCoGetMalloc.
NextCoTaskMemAlloc | This is variable nxReplacementCoMalloc.NextCoTaskMemAlloc.
NextCoTaskMemFree | This is variable nxReplacementCoMalloc.NextCoTaskMemFree.
NextCoTaskMemRealloc | This is variable nxReplacementCoMalloc.NextCoTaskMemRealloc.
Links
Classes, Interfaces, Legend, Topics, Types, Variables


Classes

Classes
Classes nxReplacementCoMalloc Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxMalloc | ===TnxMalloc================================================================== Implementation of IMalloc, the object is "allocated" from a static block of memory from the data segment (_nxMallocMemory), it doesn't implement it's own reference counting, but active references to it are considered references to the heap manager. Only a single instance is ever created.
Namespace

nxReplacementCoMalloc Namespace

Links
Classes, nxReplacementCoMalloc Namespace, Legend


TnxMalloc Class

TnxMalloc Class
TnxMalloc Methods TnxMalloc Members nxReplacementCoMalloc Classes Send Feedback
Class Hierarchy
nxReplacementCoMalloc_TnxMallocnxReplacementCoMalloc_TnxMalloc
Syntax
Delphi
TnxMalloc = class(TObject, IUnknown, IMalloc);
File

nxReplacementCoMalloc

Description

===TnxMalloc================================================================== Implementation of IMalloc, the object is "allocated" from a static block of memory from the data segment (_nxMallocMemory), it doesn't implement it's own reference counting, but active references to it are considered references to the heap manager. Only a single instance is ever created.

Group

Classes

Links
TnxMalloc Methods, TnxMalloc Members, nxReplacementCoMalloc, Classes


TnxMalloc Members

TnxMalloc Members
TnxMalloc Class Legend Public Methods Send Feedback

The following tables list the members exposed by TnxMalloc.

Class

TnxMalloc Class

Public Methods
Name | Description
_AddRef |
_Release |
Alloc | IMalloc
DidAlloc |
Free |
FreeInstance |
GetSize |
HeapMinimize |
NewInstance |
QueryInterface | IUnknown
Realloc | This is Realloc, a member of class TnxMalloc.
Links
TnxMalloc Class, Legend, Public Methods


TnxMalloc Methods

TnxMalloc Methods
TnxMalloc Class Legend Public Methods Send Feedback

The methods of the TnxMalloc class are listed here.

Class

TnxMalloc Class

Public Methods
Name | Description
_AddRef |
_Release |
Alloc | IMalloc
DidAlloc |
Free |
FreeInstance |
GetSize |
HeapMinimize |
NewInstance |
QueryInterface | IUnknown
Realloc | This is Realloc, a member of class TnxMalloc.
Links
TnxMalloc Class, Legend, Public Methods


TnxMalloc._AddRef Method

TnxMalloc._AddRef Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc._Release Method

TnxMalloc._Release Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.Alloc Method

TnxMalloc.Alloc Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function Alloc(cb: Longint): Pointer; stdcall;
Description

IMalloc

Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.DidAlloc Method

TnxMalloc.DidAlloc Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function DidAlloc(pv: Pointer): Integer; stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.Free Method

TnxMalloc.Free Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
procedure Free(pv: Pointer); stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.FreeInstance Method

TnxMalloc.FreeInstance Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.GetSize Method

TnxMalloc.GetSize Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function GetSize(pv: Pointer): Longint; stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.HeapMinimize Method

TnxMalloc.HeapMinimize Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
procedure HeapMinimize; stdcall;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.NewInstance Method

TnxMalloc.NewInstance Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.QueryInterface Method

TnxMalloc.QueryInterface Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

IUnknown

Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


TnxMalloc.Realloc Method

TnxMalloc.Realloc Method
TnxMalloc Class TnxMalloc Members nxReplacementCoMalloc Namespace TnxMalloc Methods Send Feedback
Syntax
Delphi
function Realloc(pv: Pointer; cb: Longint): Pointer; stdcall;
Description

This is Realloc, a member of class TnxMalloc.

Group

TnxMalloc Methods

Links
TnxMalloc Class, TnxMalloc Members, nxReplacementCoMalloc Namespace, TnxMalloc Methods


Interfaces

Interfaces
nxReplacementCoMalloc Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxReplacementCoMalloc Namespace

Interfaces
Name | Description
IMalloc | This is class nxReplacementCoMalloc.IMalloc.
Links
nxReplacementCoMalloc Namespace, Interfaces, Legend


IMalloc Interface

IMalloc Interface
IMalloc Methods IMalloc Members nxReplacementCoMalloc Interfaces Send Feedback
Class Hierarchy
nxReplacementCoMalloc_IMalloc
Syntax
Delphi
IMalloc = interface(IUnknown);
File

nxReplacementCoMalloc

Description

This is class nxReplacementCoMalloc.IMalloc.

Group

Interfaces

Links
IMalloc Methods, IMalloc Members, nxReplacementCoMalloc, Interfaces


IMalloc Members

IMalloc Members
IMalloc Interface Legend Public Methods Send Feedback

The following tables list the members exposed by IMalloc.

Interface

IMalloc Interface

Public Methods
Name | Description
Alloc | This is Alloc, a member of class IMalloc.
DidAlloc | This is DidAlloc, a member of class IMalloc.
Free | This is Free, a member of class IMalloc.
GetSize | This is GetSize, a member of class IMalloc.
HeapMinimize | This is HeapMinimize, a member of class IMalloc.
Realloc | This is Realloc, a member of class IMalloc.
Links
IMalloc Interface, Legend, Public Methods


IMalloc Methods

IMalloc Methods
IMalloc Interface Legend Public Methods Send Feedback

The methods of the IMalloc class are listed here.

Interface

IMalloc Interface

Public Methods
Name | Description
Alloc | This is Alloc, a member of class IMalloc.
DidAlloc | This is DidAlloc, a member of class IMalloc.
Free | This is Free, a member of class IMalloc.
GetSize | This is GetSize, a member of class IMalloc.
HeapMinimize | This is HeapMinimize, a member of class IMalloc.
Realloc | This is Realloc, a member of class IMalloc.
Links
IMalloc Interface, Legend, Public Methods


IMalloc.Alloc Method

IMalloc.Alloc Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
function Alloc(cb: Longint): Pointer; stdcall;
Description

This is Alloc, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


IMalloc.DidAlloc Method

IMalloc.DidAlloc Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
function DidAlloc(pv: Pointer): Integer; stdcall;
Description

This is DidAlloc, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


IMalloc.Free Method

IMalloc.Free Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
procedure Free(pv: Pointer); stdcall;
Description

This is Free, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


IMalloc.GetSize Method

IMalloc.GetSize Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
function GetSize(pv: Pointer): Longint; stdcall;
Description

This is GetSize, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


IMalloc.HeapMinimize Method

IMalloc.HeapMinimize Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
procedure HeapMinimize; stdcall;
Description

This is HeapMinimize, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


IMalloc.Realloc Method

IMalloc.Realloc Method
IMalloc Interface IMalloc Members nxReplacementCoMalloc Namespace IMalloc Methods Send Feedback
Syntax
Delphi
function Realloc(pv: Pointer; cb: Longint): Pointer; stdcall;
Description

This is Realloc, a member of class IMalloc.

Group

IMalloc Methods

Links
IMalloc Interface, IMalloc Members, nxReplacementCoMalloc Namespace, IMalloc Methods


Types

Types
nxReplacementCoMalloc Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxReplacementCoMalloc Namespace

Types
Name | Description
TCoGetMalloc | This is type nxReplacementCoMalloc.TCoGetMalloc.
TCoTaskMemAlloc | This is type nxReplacementCoMalloc.TCoTaskMemAlloc.
TCoTaskMemFree | This is type nxReplacementCoMalloc.TCoTaskMemFree.
TCoTaskMemRealloc | This is type nxReplacementCoMalloc.TCoTaskMemRealloc.
Links
nxReplacementCoMalloc Namespace, Types


nxReplacementCoMalloc.TCoGetMalloc Type

nxReplacementCoMalloc.TCoGetMalloc Type
nxReplacementCoMalloc Types Send Feedback
Syntax
Delphi
TCoGetMalloc = function (dwMemContext: Longint; out malloc: IMalloc): HResult;
File

nxReplacementCoMalloc

Description

This is type nxReplacementCoMalloc.TCoGetMalloc.

Group

Types

Links
nxReplacementCoMalloc, Types


nxReplacementCoMalloc.TCoTaskMemAlloc Type

nxReplacementCoMalloc.TCoTaskMemAlloc Type
nxReplacementCoMalloc Types Send Feedback
Syntax
Delphi
TCoTaskMemAlloc = function (cb: Longint): Pointer;
File

nxReplacementCoMalloc

Description

This is type nxReplacementCoMalloc.TCoTaskMemAlloc.

Group

Types

Links
nxReplacementCoMalloc, Types


nxReplacementCoMalloc.TCoTaskMemFree Type

nxReplacementCoMalloc.TCoTaskMemFree Type
nxReplacementCoMalloc Types Send Feedback
Syntax
Delphi
TCoTaskMemFree = procedure (pv: Pointer);
File

nxReplacementCoMalloc

Description

This is type nxReplacementCoMalloc.TCoTaskMemFree.

Group

Types

Links
nxReplacementCoMalloc, Types


nxReplacementCoMalloc.TCoTaskMemRealloc Type

nxReplacementCoMalloc.TCoTaskMemRealloc Type
nxReplacementCoMalloc Types Send Feedback
Syntax
Delphi
TCoTaskMemRealloc = function (pv: Pointer; cb: Longint): Pointer;
File

nxReplacementCoMalloc

Description

This is type nxReplacementCoMalloc.TCoTaskMemRealloc.

Group

Types

Links
nxReplacementCoMalloc, Types


Variables

Variables
nxReplacementCoMalloc Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxReplacementCoMalloc Namespace

Variables
Name | Description
_malloc | This is variable nxReplacementCoMalloc._malloc.
_nxMallocMemory |
NextCoCreateStandardMalloc | This is variable nxReplacementCoMalloc.NextCoCreateStandardMalloc.
NextCoGetMalloc | This is variable nxReplacementCoMalloc.NextCoGetMalloc.
NextCoTaskMemAlloc | This is variable nxReplacementCoMalloc.NextCoTaskMemAlloc.
NextCoTaskMemFree | This is variable nxReplacementCoMalloc.NextCoTaskMemFree.
NextCoTaskMemRealloc | This is variable nxReplacementCoMalloc.NextCoTaskMemRealloc.
Links
nxReplacementCoMalloc Namespace, Variables


nxReplacementCoMalloc._malloc Variable

nxReplacementCoMalloc._malloc Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
_malloc: IMalloc;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc._malloc.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc._nxMallocMemory Variable

nxReplacementCoMalloc._nxMallocMemory Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
_nxMallocMemory: array[0..31] of Byte;
File

nxReplacementCoMalloc

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc.NextCoCreateStandardMalloc Variable

nxReplacementCoMalloc.NextCoCreateStandardMalloc Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
NextCoCreateStandardMalloc: TCoGetMalloc;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc.NextCoCreateStandardMalloc.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc.NextCoGetMalloc Variable

nxReplacementCoMalloc.NextCoGetMalloc Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
NextCoGetMalloc: TCoGetMalloc;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc.NextCoGetMalloc.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc.NextCoTaskMemAlloc Variable

nxReplacementCoMalloc.NextCoTaskMemAlloc Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
NextCoTaskMemAlloc: TCoTaskMemAlloc;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc.NextCoTaskMemAlloc.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc.NextCoTaskMemFree Variable

nxReplacementCoMalloc.NextCoTaskMemFree Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
NextCoTaskMemFree: TCoTaskMemFree;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc.NextCoTaskMemFree.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementCoMalloc.NextCoTaskMemRealloc Variable

nxReplacementCoMalloc.NextCoTaskMemRealloc Variable
nxReplacementCoMalloc Variables Send Feedback
Syntax
Delphi
NextCoTaskMemRealloc: TCoTaskMemRealloc;
File

nxReplacementCoMalloc

Description

This is variable nxReplacementCoMalloc.NextCoTaskMemRealloc.

Group

Variables

Links
nxReplacementCoMalloc, Variables


nxReplacementMemoryManager Namespace

nxReplacementMemoryManager Namespace
Functions Legend Topics Variables Send Feedback

This is namespace nxReplacementMemoryManager.

Functions
Name | Description
AddRef | This is function nxReplacementMemoryManager.AddRef.
nxMMFinalization | This is function nxReplacementMemoryManager.nxMMFinalization.
nxMMInitialization | This is function nxReplacementMemoryManager.nxMMInitialization.
nxMMInitialized | This is function nxReplacementMemoryManager.nxMMInitialized.
Release | This is function nxReplacementMemoryManager.Release.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
_RefCount | This is variable nxReplacementMemoryManager._RefCount.
OrgMemoryManager | This is variable nxReplacementMemoryManager.OrgMemoryManager.
Links
Functions, Legend, Topics, Variables


Functions

Functions
Functions nxReplacementMemoryManager Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
AddRef | This is function nxReplacementMemoryManager.AddRef.
nxMMFinalization | This is function nxReplacementMemoryManager.nxMMFinalization.
nxMMInitialization | This is function nxReplacementMemoryManager.nxMMInitialization.
nxMMInitialized | This is function nxReplacementMemoryManager.nxMMInitialized.
Release | This is function nxReplacementMemoryManager.Release.
Namespace

nxReplacementMemoryManager Namespace

Links
Functions, nxReplacementMemoryManager Namespace, Legend


nxReplacementMemoryManager.AddRef Function

nxReplacementMemoryManager.AddRef Function
nxReplacementMemoryManager Functions Send Feedback
Syntax
Delphi
procedure AddRef;
File

nxReplacementMemoryManager

Description

This is function nxReplacementMemoryManager.AddRef.

Group

Functions

Links
nxReplacementMemoryManager, Functions


nxReplacementMemoryManager.nxMMFinalization Function

nxReplacementMemoryManager.nxMMFinalization Function
nxReplacementMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxMMFinalization;
File

nxReplacementMemoryManager

Description

This is function nxReplacementMemoryManager.nxMMFinalization.

Group

Functions

Links
nxReplacementMemoryManager, Functions


nxReplacementMemoryManager.nxMMInitialization Function

nxReplacementMemoryManager.nxMMInitialization Function
nxReplacementMemoryManager Functions Send Feedback
Syntax
Delphi
procedure nxMMInitialization;
File

nxReplacementMemoryManager

Description

This is function nxReplacementMemoryManager.nxMMInitialization.

Group

Functions

Links
nxReplacementMemoryManager, Functions


nxReplacementMemoryManager.nxMMInitialized Function

nxReplacementMemoryManager.nxMMInitialized Function
nxReplacementMemoryManager Functions Send Feedback
Syntax
Delphi
function nxMMInitialized: Boolean;
File

nxReplacementMemoryManager

Description

This is function nxReplacementMemoryManager.nxMMInitialized.

Group

Functions

Links
nxReplacementMemoryManager, Functions


nxReplacementMemoryManager.Release Function

nxReplacementMemoryManager.Release Function
nxReplacementMemoryManager Functions Send Feedback
Syntax
Delphi
procedure Release;
File

nxReplacementMemoryManager

Description

This is function nxReplacementMemoryManager.Release.

Group

Functions

Links
nxReplacementMemoryManager, Functions


Variables

Variables
nxReplacementMemoryManager Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxReplacementMemoryManager Namespace

Variables
Name | Description
_RefCount | This is variable nxReplacementMemoryManager._RefCount.
OrgMemoryManager | This is variable nxReplacementMemoryManager.OrgMemoryManager.
Links
nxReplacementMemoryManager Namespace, Variables


nxReplacementMemoryManager._RefCount Variable

nxReplacementMemoryManager._RefCount Variable
nxReplacementMemoryManager Variables Send Feedback
Syntax
Delphi
_RefCount: Integer;
File

nxReplacementMemoryManager

Description

This is variable nxReplacementMemoryManager._RefCount.

Group

Variables

Links
nxReplacementMemoryManager, Variables


nxReplacementMemoryManager.OrgMemoryManager Variable

nxReplacementMemoryManager.OrgMemoryManager Variable
nxReplacementMemoryManager Variables Send Feedback
Syntax
Delphi
OrgMemoryManager: TMemoryManager;
File

nxReplacementMemoryManager

Description

This is variable nxReplacementMemoryManager.OrgMemoryManager.

Group

Variables

Links
nxReplacementMemoryManager, Variables


nxreRemoteServerEngine Namespace

nxreRemoteServerEngine Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxreRemoteServerEngine.

Classes
Name | Description
EnxRemoteFilterEngineException | This is class nxreRemoteServerEngine.EnxRemoteFilterEngineException.
EnxRemoteKeyFilterEngineException | This is class nxreRemoteServerEngine.EnxRemoteKeyFilterEngineException.
EnxRemoteServerEngineException | This is class nxreRemoteServerEngine.EnxRemoteServerEngineException.
TnxRemoteCursor | This is class nxreRemoteServerEngine.TnxRemoteCursor.
TnxRemoteDatabase | This is class nxreRemoteServerEngine.TnxRemoteDatabase.
TnxRemoteFilterEngine | This is class nxreRemoteServerEngine.TnxRemoteFilterEngine.
TnxRemoteKeyFilterEngine | This is class nxreRemoteServerEngine.TnxRemoteKeyFilterEngine.
TnxRemoteServerEngine | Client-side proxy server engine component that allows calls to be made to a server engine in an external (remote) NexusDB Server, and results to be returned.
TnxRemoteSession | This is class nxreRemoteServerEngine.TnxRemoteSession.
TnxRemoteStatement | This is class nxreRemoteServerEngine.TnxRemoteStatement.
TnxRemoteTaskInfo | This is class nxreRemoteServerEngine.TnxRemoteTaskInfo.
TnxRemoteTransContext | This is class nxreRemoteServerEngine.TnxRemoteTransContext.
Constants
Name | Description
rsBlobModifiedNotSupported | This is constant nxreRemoteServerEngine.rsBlobModifiedNotSupported.
rsBookmarkAsVariantRequiresBookmarkHandler | This is constant nxreRemoteServerEngine.rsBookmarkAsVariantRequiresBookmarkHandler.
rsCreateDescriptorNotSupported | This is constant nxreRemoteServerEngine.rsCreateDescriptorNotSupported.
rsCreateLinkIsNotValid | This is constant nxreRemoteServerEngine.rsCreateLinkIsNotValid.
rsKeyFilterNotSupported | This is constant nxreRemoteServerEngine.rsKeyFilterNotSupported.
rsNotSupportedWithLocalFilter | This is constant nxreRemoteServerEngine.rsNotSupportedWithLocalFilter.
rsSetToFilterRequires | This is constant nxreRemoteServerEngine.rsSetToFilterRequires.
rsTransportRequired | This is constant nxreRemoteServerEngine.rsTransportRequired.
Functions
Name | Description
TransportRequestCallback | TransportRequestCallback
TransportRequestCallbackStreamLeavePositionShortcut |
TransportRequestCallbackStreamShortcut |
Structs, Records, Enums
Name | Description
TnxCallbackInfo | This is record nxreRemoteServerEngine.TnxCallbackInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxCallbackInfo | This is type nxreRemoteServerEngine.PnxCallbackInfo.
TnxProcessRequest | This is type nxreRemoteServerEngine.TnxProcessRequest.
TnxRemoteFilterEngineClass | This is type nxreRemoteServerEngine.TnxRemoteFilterEngineClass.
TnxRemoteKeyFilterEngineClass | This is type nxreRemoteServerEngine.TnxRemoteKeyFilterEngineClass.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxreRemoteServerEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxRemoteFilterEngineException | This is class nxreRemoteServerEngine.EnxRemoteFilterEngineException.
EnxRemoteKeyFilterEngineException | This is class nxreRemoteServerEngine.EnxRemoteKeyFilterEngineException.
EnxRemoteServerEngineException | This is class nxreRemoteServerEngine.EnxRemoteServerEngineException.
TnxRemoteCursor | This is class nxreRemoteServerEngine.TnxRemoteCursor.
TnxRemoteDatabase | This is class nxreRemoteServerEngine.TnxRemoteDatabase.
TnxRemoteFilterEngine | This is class nxreRemoteServerEngine.TnxRemoteFilterEngine.
TnxRemoteKeyFilterEngine | This is class nxreRemoteServerEngine.TnxRemoteKeyFilterEngine.
TnxRemoteServerEngine | Client-side proxy server engine component that allows calls to be made to a server engine in an external (remote) NexusDB Server, and results to be returned.
TnxRemoteSession | This is class nxreRemoteServerEngine.TnxRemoteSession.
TnxRemoteStatement | This is class nxreRemoteServerEngine.TnxRemoteStatement.
TnxRemoteTaskInfo | This is class nxreRemoteServerEngine.TnxRemoteTaskInfo.
TnxRemoteTransContext | This is class nxreRemoteServerEngine.TnxRemoteTransContext.
Namespace

nxreRemoteServerEngine Namespace

Links
Classes, nxreRemoteServerEngine Namespace, Legend


EnxRemoteFilterEngineException Class

EnxRemoteFilterEngineException Class
nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_EnxRemoteFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteFilterEngineException
Syntax
Delphi
EnxRemoteFilterEngineException = class(EnxBaseFilterEngineException);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.EnxRemoteFilterEngineException.

Group

Classes

Links
nxreRemoteServerEngine, Classes


EnxRemoteKeyFilterEngineException Class

EnxRemoteKeyFilterEngineException Class
nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_EnxRemoteKeyFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteKeyFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteKeyFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteKeyFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteKeyFilterEngineExceptionnxreRemoteServerEngine_EnxRemoteKeyFilterEngineException
Syntax
Delphi
EnxRemoteKeyFilterEngineException = class(EnxBaseFilterEngineException);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.EnxRemoteKeyFilterEngineException.

Group

Classes

Links
nxreRemoteServerEngine, Classes


EnxRemoteServerEngineException Class

EnxRemoteServerEngineException Class
nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_EnxRemoteServerEngineExceptionnxreRemoteServerEngine_EnxRemoteServerEngineExceptionnxreRemoteServerEngine_EnxRemoteServerEngineExceptionnxreRemoteServerEngine_EnxRemoteServerEngineException
Syntax
Delphi
EnxRemoteServerEngineException = class(EnxBaseException);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.EnxRemoteServerEngineException.

Group

Classes

Links
nxreRemoteServerEngine, Classes


TnxRemoteCursor Class

TnxRemoteCursor Class
TnxRemoteCursor Fields TnxRemoteCursor Methods TnxRemoteCursor Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursornxreRemoteServerEngine_TnxRemoteCursor
Syntax
Delphi
TnxRemoteCursor = class(TnxAbstractCursor);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteCursor.

Group

Classes

Links
TnxRemoteCursor Fields, TnxRemoteCursor Methods, TnxRemoteCursor Members, nxreRemoteServerEngine, Classes


TnxRemoteCursor Members

TnxRemoteCursor Members
TnxRemoteCursor Class Legend Protected Fields Protected Methods Protected Properties Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteCursor.

Class

TnxRemoteCursor Class

Protected Fields
Name | Description
acAutoFreeDatabase | This is acAutoFreeDatabase, a member of class TnxAbstractCursor.
acDatabase | private
acDatabaseNext | This is acDatabaseNext, a member of class TnxAbstractCursor.
acDatabasePrev | This is acDatabasePrev, a member of class TnxAbstractCursor.
acLockedIncDone | This is acLockedIncDone, a member of class TnxAbstractCursor.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
ProcessRequest | private
rc_Dictionary | This is rc_Dictionary, a member of class TnxRemoteCursor.
rcBookmarkHandlers | This is rcBookmarkHandlers, a member of class TnxRemoteCursor.
rcCursorID | This is rcCursorID, a member of class TnxRemoteCursor.
rcFilter | filter support
rcFilterTimeout | This is rcFilterTimeout, a member of class TnxRemoteCursor.
rcFilterTimeoutLock | This is rcFilterTimeoutLock, a member of class TnxRemoteCursor.
rcFilterUntil | This is rcFilterUntil, a member of class TnxRemoteCursor.
rcIndexID | This is rcIndexID, a member of class TnxRemoteCursor.
rcKeyEngines | This is rcKeyEngines, a member of class TnxRemoteCursor.
rcKeyFilter | key filter support
rcRecordLength | This is rcRecordLength, a member of class TnxRemoteCursor.
rcRemoteThreadPriority | This is rcRemoteThreadPriority, a member of class TnxRemoteCursor.
rcServerVersion | This is rcServerVersion, a member of class TnxRemoteCursor.
rcTableDescriptor | This is rcTableDescriptor, a member of class TnxRemoteCursor.
rcTableName | This is rcTableName, a member of class TnxRemoteCursor.
SessionRequests | This is SessionRequests, a member of class TnxRemoteCursor.
Protected Methods
Name | Description
_AddRef |
_Release |
ac_GetDictionary |
acAddToDatabase | TnxAbstractCursor
acGetFieldsDescriptor |
acGetFullName |
acGetTableDescriptor |
acRemoveFromDatabase |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout |
BlobsSupportedSelf |
CreateRequest |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetCursorSelf |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetFieldAsVariantSelf |
GetFieldCountRedirect |
GetFieldDescriptorRedirect |
GetFieldForFilterRedirect |
GetFieldFromNameRedirect |
GetFieldsOffsetRedirect |
ProcessStreamedRequest |
QueryInterface | InxInterface
rcCreateBookmarkHandlers |
rcCreateKeyEngines | key engines
rcDestroyBookmarkHandlers |
rcDestroyKeyEngines |
rcDisableFilterTimeout |
rcEnableFilterTimeout |
rcFilterBeginTimeout | filter support
rcFilterCheckTimeout |
RequestNoData |
RequestNoDataNoReply |
SetFieldAsVariantSelf |
Protected Properties
Name | Description
FieldsDescriptor | InxFieldsSource
Public Fields
Name | Description
IsResultSet | This is IsResultSet, a member of class TnxAbstractCursor.
IsUnnamed | This is IsUnnamed, a member of class TnxAbstractCursor.
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
AutoIncGet | autoinc
AutoIncSet |
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
BlobCreate | blob managment
BlobCreateFile |
BlobDelete |
BlobFree |
BlobGetLength |
BlobModified |
BlobRead |
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BlobTruncate |
BlobWrite |
BookmarkAsVariant |
ChangePassword |
Close |
Close |
CompareBookmarks |
CompareKeys |
CopyRecords |
CopyRecordsEx |
Create |
CreateInstanceFor | remoting integration
DeleteRecords |
Destroy |
Duplicate | misc
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
FilterActivate |
FilterAddCallback | Adds a new callback function to the filter valuation list.
FilterAddCustom | filters
FilterAddExpression | FilterAddExpression creates a new Filter instance for the given aExpression and returns its in aFilterID.
FilterDeactivate |
FilterRemove |
FilterSetTimeout |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetBookmark | bookmarks
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetIndexID |
GetLifetimeMontior |
GetRecordCount | information
GetRecordCountAsync |
GetRecordCountEx |
GetRecordCountExAsync |
KeyFilterActivate |
KeyFilterAddCallback | Adds a new callback function to the filter valuation list.
KeyFilterAddCustom | filters
KeyFilterAddExpression | KeyFilterAddExpression creates a new KeyFilter instance for the given aExpression and returns its in aKeyFilterID.
KeyFilterDeactivate |
KeyFilterRemove |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
RangeReset |
RangeSet |
RecNoGet |
RecNoSet |
RecNoSupported | recno support
RecordBufferAlloc | helper functions for record buffer management
RecordBufferClear |
RecordBufferFree |
RecordDelete |
RecordGet | record retrival
RecordGetBatch | batch operations
RecordGetForKey |
RecordGetNext |
RecordGetPrior |
RecordInsert | record manipulation
RecordInsertBatch |
RecordIsLocked | record locks
RecordLockRelease |
RecordModify |
RequestNestedTransactions | This function can be called from an extender to request that the cursor uses nested transactions for all operations. By default this is not supported.
SetFieldAsVariant | This is SetFieldAsVariant, a member of class InxFieldsAccess.
SetToBegin | navigation
SetToBookmark |
SetToCursor |
SetToEnd |
SetToFilter |
SetToFilterLocal |
SetToKey |
SwitchToIndex | index support
TableIsLocked | table locls
TableLockAcquire |
TableLockRelease |
TableStreamDelete |
TableStreamGetList | table streams
TableStreamRead |
TableStreamWrite |
Public Properties
Name | Description
_Dictionary | This property returns the data dictionary for this cursor.
Database | This property returns the database the cursor is linked to.
DatabaseNext | Returns the next cursor in the list of cursor of the current database.
DatabasePrev | Returns the previous cursor in the list of cursor of the current database.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsAccess.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FullName | Returns the full table name in relation to master and sub tables.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
TableDescriptor | Returns the TableDescriptor instance in the data dictionary associated with the cursor.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxRemoteCursor Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Fields, Public Methods, Public Properties


TnxRemoteCursor.Create Constructor

TnxRemoteCursor.Create Constructor
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Class Send Feedback
Syntax
Delphi
constructor Create(aDatabase: TnxRemoteDatabase; aTimeout: TnxWord32; aCursorID: TnxCursorID; aIndexID: Integer; aDictionary: TnxDataDictionary; const aTableName: string);
Class

TnxRemoteCursor Class

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Class


TnxRemoteCursor.Destroy Destructor

TnxRemoteCursor.Destroy Destructor
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteCursor Class

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Class


TnxRemoteCursor Fields

TnxRemoteCursor Fields
TnxRemoteCursor Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteCursor class are listed here.

Class

TnxRemoteCursor Class

Protected Fields
Name | Description
ProcessRequest | private
rc_Dictionary | This is rc_Dictionary, a member of class TnxRemoteCursor.
rcBookmarkHandlers | This is rcBookmarkHandlers, a member of class TnxRemoteCursor.
rcCursorID | This is rcCursorID, a member of class TnxRemoteCursor.
rcFilter | filter support
rcFilterTimeout | This is rcFilterTimeout, a member of class TnxRemoteCursor.
rcFilterTimeoutLock | This is rcFilterTimeoutLock, a member of class TnxRemoteCursor.
rcFilterUntil | This is rcFilterUntil, a member of class TnxRemoteCursor.
rcIndexID | This is rcIndexID, a member of class TnxRemoteCursor.
rcKeyEngines | This is rcKeyEngines, a member of class TnxRemoteCursor.
rcKeyFilter | key filter support
rcRecordLength | This is rcRecordLength, a member of class TnxRemoteCursor.
rcRemoteThreadPriority | This is rcRemoteThreadPriority, a member of class TnxRemoteCursor.
rcServerVersion | This is rcServerVersion, a member of class TnxRemoteCursor.
rcTableDescriptor | This is rcTableDescriptor, a member of class TnxRemoteCursor.
rcTableName | This is rcTableName, a member of class TnxRemoteCursor.
SessionRequests | This is SessionRequests, a member of class TnxRemoteCursor.
Links
TnxRemoteCursor Class, Legend, Protected Fields


TnxRemoteCursor.ProcessRequest Field

TnxRemoteCursor.ProcessRequest Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rc_Dictionary Field

TnxRemoteCursor.rc_Dictionary Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rc_Dictionary: TnxDataDictionary;
Description

This is rc_Dictionary, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcBookmarkHandlers Field

TnxRemoteCursor.rcBookmarkHandlers Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcBookmarkHandlers: array of TnxBookmarkHandler;
Description

This is rcBookmarkHandlers, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcCursorID Field

TnxRemoteCursor.rcCursorID Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcCursorID: TnxCursorID;
Description

This is rcCursorID, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcFilter Field

TnxRemoteCursor.rcFilter Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcFilter: TnxBaseFilterEngine;
Description

filter support

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcFilterTimeout Field

TnxRemoteCursor.rcFilterTimeout Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcFilterTimeout: TnxWord32;
Description

This is rcFilterTimeout, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcFilterTimeoutLock Field

TnxRemoteCursor.rcFilterTimeoutLock Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcFilterTimeoutLock: Integer;
Description

This is rcFilterTimeoutLock, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcFilterUntil Field

TnxRemoteCursor.rcFilterUntil Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcFilterUntil: TnxInt64;
Description

This is rcFilterUntil, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcIndexID Field

TnxRemoteCursor.rcIndexID Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcIndexID: Integer;
Description

This is rcIndexID, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcKeyEngines Field

TnxRemoteCursor.rcKeyEngines Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcKeyEngines: array of TnxBaseKeyEngine;
Description

This is rcKeyEngines, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcKeyFilter Field

TnxRemoteCursor.rcKeyFilter Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcKeyFilter: TnxBaseFilterEngine;
Description

key filter support

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcRecordLength Field

TnxRemoteCursor.rcRecordLength Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcRecordLength: Integer;
Description

This is rcRecordLength, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcRemoteThreadPriority Field

TnxRemoteCursor.rcRemoteThreadPriority Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcRemoteThreadPriority: TnxThreadPriority;
Description

This is rcRemoteThreadPriority, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcServerVersion Field

TnxRemoteCursor.rcServerVersion Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcServerVersion: Integer;
Description

This is rcServerVersion, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcTableDescriptor Field

TnxRemoteCursor.rcTableDescriptor Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcTableDescriptor: TnxBaseTableDescriptor;
Description

This is rcTableDescriptor, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.rcTableName Field

TnxRemoteCursor.rcTableName Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
rcTableName: string;
Description

This is rcTableName, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor.SessionRequests Field

TnxRemoteCursor.SessionRequests Field
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Fields Send Feedback
Syntax
Delphi
SessionRequests: InxSessionRequests;
Description

This is SessionRequests, a member of class TnxRemoteCursor.

Group

TnxRemoteCursor Fields

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Fields


TnxRemoteCursor Methods

TnxRemoteCursor Methods
TnxRemoteCursor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteCursor class are listed here.

Class

TnxRemoteCursor Class

Protected Methods
Name | Description
ac_GetDictionary |
acGetFullName |
acGetTableDescriptor |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
atoSetTimeout |
CreateRequest |
ProcessStreamedRequest |
rcCreateBookmarkHandlers |
rcCreateKeyEngines | key engines
rcDestroyBookmarkHandlers |
rcDestroyKeyEngines |
rcDisableFilterTimeout |
rcEnableFilterTimeout |
rcFilterBeginTimeout | filter support
rcFilterCheckTimeout |
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
AutoIncGet | autoinc
AutoIncSet |
BlobCreate | blob managment
BlobCreateFile |
BlobDelete |
BlobFree |
BlobGetLength |
BlobModified |
BlobRead |
BlobTruncate |
BlobWrite |
BookmarkAsVariant |
ChangePassword |
CompareBookmarks |
CompareKeys |
CopyRecords |
CopyRecordsEx |
CreateInstanceFor | remoting integration
DeleteRecords |
Duplicate | misc
FilterActivate |
FilterAddCustom | filters
FilterDeactivate |
FilterRemove |
FilterSetTimeout |
GetBookmark | bookmarks
GetIndexID |
GetRecordCount | information
GetRecordCountAsync |
GetRecordCountEx |
GetRecordCountExAsync |
KeyFilterActivate |
KeyFilterAddCustom | filters
KeyFilterDeactivate |
KeyFilterRemove |
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
RangeReset |
RangeSet |
RecNoGet |
RecNoSet |
RecNoSupported | recno support
RecordDelete |
RecordGet | record retrival
RecordGetBatch | batch operations
RecordGetForKey |
RecordGetNext |
RecordGetPrior |
RecordInsert | record manipulation
RecordInsertBatch |
RecordIsLocked | record locks
RecordLockRelease |
RecordModify |
SetToBegin | navigation
SetToBookmark |
SetToCursor |
SetToEnd |
SetToFilter |
SetToFilterLocal |
SetToKey |
SwitchToIndex | index support
TableIsLocked | table locls
TableLockAcquire |
TableLockRelease |
TableStreamDelete |
TableStreamGetList | table streams
TableStreamRead |
TableStreamWrite |
Links
TnxRemoteCursor Class, Legend, Protected Methods, Public Methods


TnxRemoteCursor.ac_GetDictionary Method

TnxRemoteCursor.ac_GetDictionary Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function ac_GetDictionary: TnxDataDictionary; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.acGetFullName Method

TnxRemoteCursor.acGetFullName Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function acGetFullName: string; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.acGetTableDescriptor Method

TnxRemoteCursor.acGetTableDescriptor Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function acGetTableDescriptor: TnxBaseTableDescriptor; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.asoGetRemoteID Method

TnxRemoteCursor.asoGetRemoteID Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.asoGetRemoteThreadPriority Method

TnxRemoteCursor.asoGetRemoteThreadPriority Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.asoSetRemoteThreadPriority Method

TnxRemoteCursor.asoSetRemoteThreadPriority Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.atoSetTimeout Method

TnxRemoteCursor.atoSetTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.AutoIncGet Method

TnxRemoteCursor.AutoIncGet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function AutoIncGet(out aValue: TnxWord32): TnxResult; override;
Description

autoinc

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.AutoIncSet Method

TnxRemoteCursor.AutoIncSet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function AutoIncSet(aValue: TnxWord32): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobCreate Method

TnxRemoteCursor.BlobCreate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobCreate(aFieldNo: TnxInt32; out aBlobNr: TnxInt64): TnxResult; override;
Description

blob managment

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobCreateFile Method

TnxRemoteCursor.BlobCreateFile Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobCreateFile(aFieldNo: TnxInt32; const aFileName: string; out aBlobNr: TnxInt64): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobDelete Method

TnxRemoteCursor.BlobDelete Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobDelete(aFieldNo: TnxInt32; const aBlobNr: TnxInt64): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobFree Method

TnxRemoteCursor.BlobFree Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobFree(aFieldNo: TnxInt32; const aBlobNr: TnxInt64): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobGetLength Method

TnxRemoteCursor.BlobGetLength Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobGetLength(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; out aLength: TnxWord32; aReadOrg: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobModified Method

TnxRemoteCursor.BlobModified Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobModified(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; out aModified: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobRead Method

TnxRemoteCursor.BlobRead Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobRead(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; aStream: TStream; aReadOrg: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobTruncate Method

TnxRemoteCursor.BlobTruncate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobTruncate(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aBlobLength: TnxWord32): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BlobWrite Method

TnxRemoteCursor.BlobWrite Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BlobWrite(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; const aBlob): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.BookmarkAsVariant Method

TnxRemoteCursor.BookmarkAsVariant Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function BookmarkAsVariant(aBookmark: PnxByteArray; aSize: TnxWord32; out aVariant: Variant): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.ChangePassword Method

TnxRemoteCursor.ChangePassword Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function ChangePassword(const aNewPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CompareBookmarks Method

TnxRemoteCursor.CompareBookmarks Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CompareBookmarks(aBookmark1: PnxByteArray; aBookmark2: PnxByteArray; aSize: TnxWord32; out aCompResult: TnxValueRelationship): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CompareKeys Method

TnxRemoteCursor.CompareKeys Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CompareKeys(aFieldCount: Integer; aPartialLen: Integer; aDirectKey1: Boolean; aKeyData1: PnxByteArray; aDirectKey2: Boolean; aKeyData2: PnxByteArray; out aResult: TnxValueRelationship): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CopyRecords Method

TnxRemoteCursor.CopyRecords Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CopyRecords(aDestCursor: TnxAbstractCursor; aBlobCopyMode: TnxBlobCopyMode; aMaxTransSize: Integer): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CopyRecordsEx Method

TnxRemoteCursor.CopyRecordsEx Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CopyRecordsEx(aDestCursor: TnxAbstractCursor; aBlobCopyMode: TnxBlobCopyMode; aMaxTransSize: Integer; aCheckValFields: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CreateInstanceFor Method

TnxRemoteCursor.CreateInstanceFor Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.CreateRequest Method

TnxRemoteCursor.CreateRequest Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.DeleteRecords Method

TnxRemoteCursor.DeleteRecords Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function DeleteRecords: TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.Duplicate Method

TnxRemoteCursor.Duplicate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function Duplicate(aOpenMode: TnxOpenMode; out aNewCursor: TnxAbstractCursor): TnxResult; override;
Description

misc

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.FilterActivate Method

TnxRemoteCursor.FilterActivate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function FilterActivate(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.FilterAddCustom Method

TnxRemoteCursor.FilterAddCustom Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function FilterAddCustom(aFilter: TnxBaseFilterDescriptor; out aFilterID: TnxFilterID): TnxResult; override;
Description

filters

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.FilterDeactivate Method

TnxRemoteCursor.FilterDeactivate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function FilterDeactivate(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.FilterRemove Method

TnxRemoteCursor.FilterRemove Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function FilterRemove(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.FilterSetTimeout Method

TnxRemoteCursor.FilterSetTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function FilterSetTimeout(aTimeout: TnxWord32): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetBookmark Method

TnxRemoteCursor.GetBookmark Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetBookmark(aBookmark: PnxByteArray; aSize: TnxWord32): TnxResult; override;
Description

bookmarks

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetIndexID Method

TnxRemoteCursor.GetIndexID Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetIndexID(out aIndexID: Integer): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetRecordCount Method

TnxRemoteCursor.GetRecordCount Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCount(out aRecCount: TnxWord32; aEstimate: Boolean = False): TnxResult; override;
Description

information

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetRecordCountAsync Method

TnxRemoteCursor.GetRecordCountAsync Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountAsync(out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetRecordCountEx Method

TnxRemoteCursor.GetRecordCountEx Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountEx(aOption: TnxRecordCountOption; out aRecCount: TnxWord32; aEstimate: Boolean = False): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.GetRecordCountExAsync Method

TnxRemoteCursor.GetRecordCountExAsync Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountExAsync(aOption: TnxRecordCountOption; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.KeyFilterActivate Method

TnxRemoteCursor.KeyFilterActivate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterActivate(aKeyFilterID: TnxKeyFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.KeyFilterAddCustom Method

TnxRemoteCursor.KeyFilterAddCustom Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterAddCustom(aKeyFilter: TnxBaseFilterDescriptor; out aKeyFilterID: TnxKeyFilterID): TnxResult; override;
Description

filters

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.KeyFilterDeactivate Method

TnxRemoteCursor.KeyFilterDeactivate Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterDeactivate(aKeyFilterID: TnxKeyFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.KeyFilterRemove Method

TnxRemoteCursor.KeyFilterRemove Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterRemove(aKeyFilterID: TnxKeyFilterID): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionClear Method

TnxRemoteCursor.OptionClear Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionGet Method

TnxRemoteCursor.OptionGet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionGetEffective Method

TnxRemoteCursor.OptionGetEffective Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionList Method

TnxRemoteCursor.OptionList Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionListEffective Method

TnxRemoteCursor.OptionListEffective Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.OptionSet Method

TnxRemoteCursor.OptionSet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.ProcessStreamedRequest Method

TnxRemoteCursor.ProcessStreamedRequest Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RangeReset Method

TnxRemoteCursor.RangeReset Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RangeReset: TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RangeSet Method

TnxRemoteCursor.RangeSet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RangeSet(aFieldCount1: Integer; aPartialLen1: Integer; aDirectKey1: Boolean; aKeyData1: PnxByteArray; aKeyIncl1: Boolean; aFieldCount2: Integer; aPartialLen2: Integer; aDirectKey2: Boolean; aKeyData2: PnxByteArray; aKeyIncl2: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcCreateBookmarkHandlers Method

TnxRemoteCursor.rcCreateBookmarkHandlers Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcCreateBookmarkHandlers;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcCreateKeyEngines Method

TnxRemoteCursor.rcCreateKeyEngines Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcCreateKeyEngines;
Description

key engines

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcDestroyBookmarkHandlers Method

TnxRemoteCursor.rcDestroyBookmarkHandlers Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcDestroyBookmarkHandlers;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcDestroyKeyEngines Method

TnxRemoteCursor.rcDestroyKeyEngines Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcDestroyKeyEngines;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcDisableFilterTimeout Method

TnxRemoteCursor.rcDisableFilterTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcDisableFilterTimeout;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcEnableFilterTimeout Method

TnxRemoteCursor.rcEnableFilterTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcEnableFilterTimeout;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcFilterBeginTimeout Method

TnxRemoteCursor.rcFilterBeginTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
procedure rcFilterBeginTimeout;
Description

filter support

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.rcFilterCheckTimeout Method

TnxRemoteCursor.rcFilterCheckTimeout Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function rcFilterCheckTimeout(var aResult: TnxResult): Boolean;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecNoGet Method

TnxRemoteCursor.RecNoGet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecNoGet(out aRecNo: TnxWord32; aFlipOrder: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecNoSet Method

TnxRemoteCursor.RecNoSet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecNoSet(aRecNo: TnxWord32; aFlipOrder: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecNoSupported Method

TnxRemoteCursor.RecNoSupported Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecNoSupported: TnxResult; override;
Description

recno support

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordDelete Method

TnxRemoteCursor.RecordDelete Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordDelete(aData: PnxByteArray): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordGet Method

TnxRemoteCursor.RecordGet Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordGet(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; override;
Description

record retrival

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordGetBatch Method

TnxRemoteCursor.RecordGetBatch Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordGetBatch(aCutoffSize: Integer; aOptions: TnxRecordGetBatchExOptions; aStream: TnxMemoryStream; aMaxRecords: Integer = -1; aForward: Boolean = True): TnxResult; override;
Description

batch operations

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordGetForKey Method

TnxRemoteCursor.RecordGetForKey Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordGetForKey(aFieldCount: Integer; aPartialLen: Integer; aDirectKey: Boolean; aKeyData: PnxByteArray; aData: PnxByteArray; aMatchFirst: Boolean; aFirstCall: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordGetNext Method

TnxRemoteCursor.RecordGetNext Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordGetNext(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordGetPrior Method

TnxRemoteCursor.RecordGetPrior Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordGetPrior(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordInsert Method

TnxRemoteCursor.RecordInsert Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordInsert(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; override;
Description

record manipulation

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordInsertBatch Method

TnxRemoteCursor.RecordInsertBatch Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordInsertBatch(aStream: TnxCustomMemoryStream): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordIsLocked Method

TnxRemoteCursor.RecordIsLocked Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordIsLocked(aLockType: TnxLockType; out aLockPresent: TnxLockPresent): TnxResult; override;
Description

record locks

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordLockRelease Method

TnxRemoteCursor.RecordLockRelease Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordLockRelease(aAllLocks: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RecordModify Method

TnxRemoteCursor.RecordModify Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RecordModify(aData: PnxByteArray; aReleaseLock: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RequestNoData Method

TnxRemoteCursor.RequestNoData Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.RequestNoDataNoReply Method

TnxRemoteCursor.RequestNoDataNoReply Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToBegin Method

TnxRemoteCursor.SetToBegin Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToBegin: TnxResult; override;
Description

navigation

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToBookmark Method

TnxRemoteCursor.SetToBookmark Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToBookmark(aBookmark: PnxByteArray; aSize: TnxWord32): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToCursor Method

TnxRemoteCursor.SetToCursor Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToCursor(aCursor: TnxAbstractCursor): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToEnd Method

TnxRemoteCursor.SetToEnd Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToEnd: TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToFilter Method

TnxRemoteCursor.SetToFilter Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToFilter(aFilter: TnxBaseFilterDescriptor; aKeyFilter: TnxBaseFilterDescriptor; aForward: TnxBoolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToFilterLocal Method

TnxRemoteCursor.SetToFilterLocal Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToFilterLocal(aFilter: TnxBaseFilterDescriptor; aKeyFilter: TnxBaseFilterDescriptor; aForward: TnxBoolean): TnxResult;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SetToKey Method

TnxRemoteCursor.SetToKey Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SetToKey(aSearchAction: TnxSearchKeyAction; aFieldCount: Integer; aPartialLen: Integer; aDirectKey: Boolean; aKeyData: PnxByteArray): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.SwitchToIndex Method

TnxRemoteCursor.SwitchToIndex Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function SwitchToIndex(const aIndexName: string; aIndexID: Integer; aPosnOnRec: Boolean): TnxResult; override;
Description

index support

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableIsLocked Method

TnxRemoteCursor.TableIsLocked Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableIsLocked(aLockType: TnxLockType; out aLockPresent: TnxLockPresent): TnxResult; override;
Description

table locls

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableLockAcquire Method

TnxRemoteCursor.TableLockAcquire Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableLockAcquire(aLockType: TnxLockType): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableLockRelease Method

TnxRemoteCursor.TableLockRelease Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableLockRelease(aLockType: TnxLockType; aAllLocks: Boolean): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableStreamDelete Method

TnxRemoteCursor.TableStreamDelete Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableStreamDelete(const aName: string): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableStreamGetList Method

TnxRemoteCursor.TableStreamGetList Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableStreamGetList(aStreams: TStrings): TnxResult; override;
Description

table streams

Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableStreamRead Method

TnxRemoteCursor.TableStreamRead Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableStreamRead(const aName: string; aStream: TStream): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteCursor.TableStreamWrite Method

TnxRemoteCursor.TableStreamWrite Method
TnxRemoteCursor Class TnxRemoteCursor Members nxreRemoteServerEngine Namespace TnxRemoteCursor Methods Send Feedback
Syntax
Delphi
function TableStreamWrite(const aName: string; aStream: TStream): TnxResult; override;
Group

TnxRemoteCursor Methods

Links
TnxRemoteCursor Class, TnxRemoteCursor Members, nxreRemoteServerEngine Namespace, TnxRemoteCursor Methods


TnxRemoteDatabase Class

TnxRemoteDatabase Class
TnxRemoteDatabase Fields TnxRemoteDatabase Methods TnxRemoteDatabase Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabasenxreRemoteServerEngine_TnxRemoteDatabase
Syntax
Delphi
TnxRemoteDatabase = class(TnxAbstractDatabase);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteDatabase.

Group

Classes

Links
TnxRemoteDatabase Fields, TnxRemoteDatabase Methods, TnxRemoteDatabase Members, nxreRemoteServerEngine, Classes


TnxRemoteDatabase Members

TnxRemoteDatabase Members
TnxRemoteDatabase Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteDatabase.

Class

TnxRemoteDatabase Class

Protected Fields
Name | Description
adCursorAutoFree | This is adCursorAutoFree, a member of class TnxAbstractDatabase.
adCursorsHead | This is adCursorsHead, a member of class TnxAbstractDatabase.
adCursorsPadlock | This is adCursorsPadlock, a member of class TnxAbstractDatabase.
adCursorsTail | This is adCursorsTail, a member of class TnxAbstractDatabase.
adLockedIncDone | This is adLockedIncDone, a member of class TnxAbstractDatabase.
adOwnedTransContext | This is adOwnedTransContext, a member of class TnxAbstractDatabase.
adSessionNext | This is adSessionNext, a member of class TnxAbstractDatabase.
adSessionPrev | private
adStatementsHead | This is adStatementsHead, a member of class TnxAbstractDatabase.
adStatementsPadlock | This is adStatementsPadlock, a member of class TnxAbstractDatabase.
adStatementsTail | This is adStatementsTail, a member of class TnxAbstractDatabase.
adTransContext | This is adTransContext, a member of class TnxAbstractDatabase.
adTransContextNext | This is adTransContextNext, a member of class TnxAbstractDatabase.
adTransContextPrev | This is adTransContextPrev, a member of class TnxAbstractDatabase.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
ProcessRequest | private
rdDatabaseID | This is rdDatabaseID, a member of class TnxRemoteDatabase.
rdOwnedTransContext | This is rdOwnedTransContext, a member of class TnxRemoteDatabase.
rdRemoteThreadPriority | This is rdRemoteThreadPriority, a member of class TnxRemoteDatabase.
rdServerVersion | This is rdServerVersion, a member of class TnxRemoteDatabase.
SessionRequests | This is SessionRequests, a member of class TnxRemoteDatabase.
Protected Methods
Name | Description
_AddRef |
_Release |
adAddToSession | TnxAbstractDatabase
adAddToTransContext |
adRemoveFromSession |
adRemoveFromTransContext |
adTransContextDestroying |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID | TnxRemoteDatabase
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout |
CreateRequest |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
ProcessStreamedRequest |
QueryInterface | InxInterface
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create |
CreateInstanceFor | remoting integration
CursorOpen | cursor
Destroy |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetChangedTables |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFreespace |
GetLifetimeMontior |
GetPath |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PrepareDestroy |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
RegisterCursorSource | cursor source
StatementAlloc | statement
StatementExecDirect |
TableAddField |
TableAddIndex |
TableAutoIncGet | This function returns the next AutoInc value for the specified table.
TableBackup |
TableBuild | table managmenet
TableChangePassword |
TableDelete |
TableDropIndex |
TableEmpty |
TableExists | table information
TableGetDictionary |
TableGetList |
TablePack |
TableRebuildIndex |
TableRecover |
TableRename |
TableRestructure |
TableVerifyChecksum |
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
ExplicitAllowSystem | This is ExplicitAllowSystem, a member of class TnxAbstractDatabase.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
TransContext | This property returns the transaction context the database is linked to.
Links
TnxRemoteDatabase Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteDatabase.Create Constructor

TnxRemoteDatabase.Create Constructor
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxRemoteSession; aTimeout: TnxWord32; aOwnsCtx: Boolean; aTransContext: TnxRemoteTransContext; aDatabaseID: TnxDatabaseID);
Class

TnxRemoteDatabase Class

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Class


TnxRemoteDatabase.Destroy Destructor

TnxRemoteDatabase.Destroy Destructor
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteDatabase Class

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Class


TnxRemoteDatabase Fields

TnxRemoteDatabase Fields
TnxRemoteDatabase Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteDatabase class are listed here.

Class

TnxRemoteDatabase Class

Protected Fields
Name | Description
ProcessRequest | private
rdDatabaseID | This is rdDatabaseID, a member of class TnxRemoteDatabase.
rdOwnedTransContext | This is rdOwnedTransContext, a member of class TnxRemoteDatabase.
rdRemoteThreadPriority | This is rdRemoteThreadPriority, a member of class TnxRemoteDatabase.
rdServerVersion | This is rdServerVersion, a member of class TnxRemoteDatabase.
SessionRequests | This is SessionRequests, a member of class TnxRemoteDatabase.
Links
TnxRemoteDatabase Class, Legend, Protected Fields


TnxRemoteDatabase.ProcessRequest Field

TnxRemoteDatabase.ProcessRequest Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase.rdDatabaseID Field

TnxRemoteDatabase.rdDatabaseID Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
rdDatabaseID: TnxDatabaseID;
Description

This is rdDatabaseID, a member of class TnxRemoteDatabase.

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase.rdOwnedTransContext Field

TnxRemoteDatabase.rdOwnedTransContext Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
rdOwnedTransContext: TnxRemoteTransContext;
Description

This is rdOwnedTransContext, a member of class TnxRemoteDatabase.

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase.rdRemoteThreadPriority Field

TnxRemoteDatabase.rdRemoteThreadPriority Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
rdRemoteThreadPriority: TnxThreadPriority;
Description

This is rdRemoteThreadPriority, a member of class TnxRemoteDatabase.

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase.rdServerVersion Field

TnxRemoteDatabase.rdServerVersion Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
rdServerVersion: Integer;
Description

This is rdServerVersion, a member of class TnxRemoteDatabase.

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase.SessionRequests Field

TnxRemoteDatabase.SessionRequests Field
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Fields Send Feedback
Syntax
Delphi
SessionRequests: InxSessionRequests;
Description

This is SessionRequests, a member of class TnxRemoteDatabase.

Group

TnxRemoteDatabase Fields

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Fields


TnxRemoteDatabase Methods

TnxRemoteDatabase Methods
TnxRemoteDatabase Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteDatabase class are listed here.

Class

TnxRemoteDatabase Class

Protected Methods
Name | Description
asoGetRemoteID | TnxRemoteDatabase
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
atoSetTimeout |
CreateRequest |
ProcessStreamedRequest |
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
CreateInstanceFor | remoting integration
CursorOpen | cursor
GetChangedTables |
GetFreespace |
GetPath |
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
StatementAlloc | statement
StatementExecDirect |
TableAddField |
TableAddIndex |
TableAutoIncGet | This function returns the next AutoInc value for the specified table.
TableBackup |
TableBuild | table managmenet
TableChangePassword |
TableDelete |
TableDropIndex |
TableEmpty |
TableExists | table information
TableGetDictionary |
TableGetList |
TablePack |
TableRebuildIndex |
TableRecover |
TableRename |
TableRestructure |
TableVerifyChecksum |
Links
TnxRemoteDatabase Class, Legend, Protected Methods, Public Methods


TnxRemoteDatabase.asoGetRemoteID Method

TnxRemoteDatabase.asoGetRemoteID Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Description

TnxRemoteDatabase

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.asoGetRemoteThreadPriority Method

TnxRemoteDatabase.asoGetRemoteThreadPriority Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.asoSetRemoteThreadPriority Method

TnxRemoteDatabase.asoSetRemoteThreadPriority Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.atoSetTimeout Method

TnxRemoteDatabase.atoSetTimeout Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.CreateInstanceFor Method

TnxRemoteDatabase.CreateInstanceFor Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.CreateRequest Method

TnxRemoteDatabase.CreateRequest Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.CursorOpen Method

TnxRemoteDatabase.CursorOpen Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function CursorOpen(out aCursor: TnxAbstractCursor; const aTableName: string; const aPassword: UnicodeString; aOpenMode: TnxOpenMode; aShareMode: TnxShareMode; aTimeout: TnxWord32; aAllowSystem: Boolean = False): TnxResult; override;
Description

cursor

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.GetChangedTables Method

TnxRemoteDatabase.GetChangedTables Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function GetChangedTables(aTables: TStrings): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.GetFreespace Method

TnxRemoteDatabase.GetFreespace Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function GetFreespace(out aFreeSpace: TnxInt64): TnxResult; override;
Description
- info -

Changed the name from GetFreeSpace to GetFreespace to avoid name clashing in BCB

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.GetPath Method

TnxRemoteDatabase.GetPath Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function GetPath(out aPath: string): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionClear Method

TnxRemoteDatabase.OptionClear Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionGet Method

TnxRemoteDatabase.OptionGet Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionGetEffective Method

TnxRemoteDatabase.OptionGetEffective Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionList Method

TnxRemoteDatabase.OptionList Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionListEffective Method

TnxRemoteDatabase.OptionListEffective Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.OptionSet Method

TnxRemoteDatabase.OptionSet Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.ProcessStreamedRequest Method

TnxRemoteDatabase.ProcessStreamedRequest Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.RequestNoData Method

TnxRemoteDatabase.RequestNoData Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.RequestNoDataNoReply Method

TnxRemoteDatabase.RequestNoDataNoReply Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.StatementAlloc Method

TnxRemoteDatabase.StatementAlloc Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function StatementAlloc(out aStatement: TnxAbstractStatement; aTimeout: TnxWord32): TnxResult; override;
Description

statement

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.StatementExecDirect Method

TnxRemoteDatabase.StatementExecDirect Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function StatementExecDirect(aTimeout: TnxWord32; aStatementType: TnxStatementType; const aQueryText: WideString; aPrepareStream: TStream; const aParams: TnxSqlParamList; aSetParamsStream: TStream; out aCursor: TnxAbstractCursor; aOpenMode: TnxOpenMode; aExecStream: TStream; aGetParamsStream: TStream; out aPhase: TnxStatementExecDirectPhase): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableAddField Method

TnxRemoteDatabase.TableAddField Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableAddField(const aTableName: string; const aPassword: UnicodeString; aFieldDesc: TnxFieldDescriptor): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableAddIndex Method

TnxRemoteDatabase.TableAddIndex Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableAddIndex(const aTableName: string; const aPassword: UnicodeString; aIndexDesc: TnxIndexDescriptor; aNewDefault: Boolean): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableAutoIncGet Method

TnxRemoteDatabase.TableAutoIncGet Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableAutoIncGet(const aTableName: string; const aPassword: UnicodeString; out aValue: TnxWord32): TnxResult; override;
Description

This function returns the next AutoInc value for the specified table.

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableBackup Method

TnxRemoteDatabase.TableBackup Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableBackup(const aTableName: string; const aPassword: UnicodeString; aTargetDatabase: TnxAbstractDataBase; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableBuild Method

TnxRemoteDatabase.TableBuild Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableBuild(aOverWrite: Boolean; const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aTableScope: TnxTableScope; aAllowSystem: Boolean = False): TnxResult; override;
Description

table managmenet

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableChangePassword Method

TnxRemoteDatabase.TableChangePassword Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableChangePassword(const aTableName: string; const aOldPassword: UnicodeString; const aNewPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableDelete Method

TnxRemoteDatabase.TableDelete Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableDelete(const aTableName: string; const aPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableDropIndex Method

TnxRemoteDatabase.TableDropIndex Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableDropIndex(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; aIndexID: Integer): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableEmpty Method

TnxRemoteDatabase.TableEmpty Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableEmpty(const aTableName: string; const aPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableExists Method

TnxRemoteDatabase.TableExists Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableExists(const aTableName: string; const aPassword: UnicodeString; out aExists: Boolean; aAllowSystem: Boolean = False): TnxResult; override;
Description

table information

Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableGetDictionary Method

TnxRemoteDatabase.TableGetDictionary Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableGetDictionary(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableGetList Method

TnxRemoteDatabase.TableGetList Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableGetList(aList: TStrings): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TablePack Method

TnxRemoteDatabase.TablePack Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TablePack(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableRebuildIndex Method

TnxRemoteDatabase.TableRebuildIndex Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableRebuildIndex(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; aIndexID: Integer; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableRecover Method

TnxRemoteDatabase.TableRecover Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableRecover(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableRename Method

TnxRemoteDatabase.TableRename Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableRename(const aOldName: string; const aNewName: string; const aPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableRestructure Method

TnxRemoteDatabase.TableRestructure Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableRestructure(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor; const aAllowSystem: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteDatabase.TableVerifyChecksum Method

TnxRemoteDatabase.TableVerifyChecksum Method
TnxRemoteDatabase Class TnxRemoteDatabase Members nxreRemoteServerEngine Namespace TnxRemoteDatabase Methods Send Feedback
Syntax
Delphi
function TableVerifyChecksum(const aTableName: string; const aPassword: UnicodeString; aRaw: Boolean; aForceRecheck: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; override;
Group

TnxRemoteDatabase Methods

Links
TnxRemoteDatabase Class, TnxRemoteDatabase Members, nxreRemoteServerEngine Namespace, TnxRemoteDatabase Methods


TnxRemoteFilterEngine Class

TnxRemoteFilterEngine Class
TnxRemoteFilterEngine Fields TnxRemoteFilterEngine Methods TnxRemoteFilterEngine Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteFilterEnginenxreRemoteServerEngine_TnxRemoteFilterEnginenxreRemoteServerEngine_TnxRemoteFilterEnginenxreRemoteServerEngine_TnxRemoteFilterEnginenxreRemoteServerEngine_TnxRemoteFilterEngine
Syntax
Delphi
TnxRemoteFilterEngine = class(TnxBaseFilterEngine);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteFilterEngine.

Group

Classes

Links
TnxRemoteFilterEngine Fields, TnxRemoteFilterEngine Methods, TnxRemoteFilterEngine Members, nxreRemoteServerEngine, Classes


TnxRemoteFilterEngine Members

TnxRemoteFilterEngine Members
TnxRemoteFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteFilterEngine.

Class

TnxRemoteFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
ProcessRequest | private
rfConnected | This is rfConnected, a member of class TnxRemoteFilterEngine.
rfCursor | This is rfCursor, a member of class TnxRemoteFilterEngine.
rfFilterID | This is rfFilterID, a member of class TnxRemoteFilterEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
DoRemove |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxRemoteFilterEngine
Create |
CreateDescriptor |
CreateFor |
DeactivateFilter |
Destroy |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxRemoteFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxRemoteFilterEngine.Create Constructor

TnxRemoteFilterEngine.Create Constructor
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aCursor: TnxRemoteCursor; aFilterID: TnxFilterID); reintroduce;
Class

TnxRemoteFilterEngine Class

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Class


TnxRemoteFilterEngine.Destroy Destructor

TnxRemoteFilterEngine.Destroy Destructor
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteFilterEngine Class

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Class


TnxRemoteFilterEngine Fields

TnxRemoteFilterEngine Fields
TnxRemoteFilterEngine Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteFilterEngine class are listed here.

Class

TnxRemoteFilterEngine Class

Protected Fields
Name | Description
ProcessRequest | private
rfConnected | This is rfConnected, a member of class TnxRemoteFilterEngine.
rfCursor | This is rfCursor, a member of class TnxRemoteFilterEngine.
rfFilterID | This is rfFilterID, a member of class TnxRemoteFilterEngine.
Links
TnxRemoteFilterEngine Class, Legend, Protected Fields


TnxRemoteFilterEngine.ProcessRequest Field

TnxRemoteFilterEngine.ProcessRequest Field
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteFilterEngine Fields

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Fields


TnxRemoteFilterEngine.rfConnected Field

TnxRemoteFilterEngine.rfConnected Field
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Fields Send Feedback
Syntax
Delphi
rfConnected: Boolean;
Description

This is rfConnected, a member of class TnxRemoteFilterEngine.

Group

TnxRemoteFilterEngine Fields

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Fields


TnxRemoteFilterEngine.rfCursor Field

TnxRemoteFilterEngine.rfCursor Field
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Fields Send Feedback
Syntax
Delphi
rfCursor: TnxRemoteCursor;
Description

This is rfCursor, a member of class TnxRemoteFilterEngine.

Group

TnxRemoteFilterEngine Fields

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Fields


TnxRemoteFilterEngine.rfFilterID Field

TnxRemoteFilterEngine.rfFilterID Field
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Fields Send Feedback
Syntax
Delphi
rfFilterID: TnxFilterID;
Description

This is rfFilterID, a member of class TnxRemoteFilterEngine.

Group

TnxRemoteFilterEngine Fields

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Fields


TnxRemoteFilterEngine Methods

TnxRemoteFilterEngine Methods
TnxRemoteFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteFilterEngine class are listed here.

Class

TnxRemoteFilterEngine Class

Protected Methods
Name | Description
DoRemove |
Public Methods
Name | Description
ActivateFilter | TnxRemoteFilterEngine
CreateDescriptor |
DeactivateFilter |
Disconnect |
Duplicate |
IsEvalLocal |
MatchesBuffer |
Links
TnxRemoteFilterEngine Class, Legend, Protected Methods, Public Methods


TnxRemoteFilterEngine.ActivateFilter Method

TnxRemoteFilterEngine.ActivateFilter Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function ActivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Description

TnxRemoteFilterEngine

Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.CreateDescriptor Method

TnxRemoteFilterEngine.CreateDescriptor Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.DeactivateFilter Method

TnxRemoteFilterEngine.DeactivateFilter Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function DeactivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.Disconnect Method

TnxRemoteFilterEngine.Disconnect Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
procedure Disconnect; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.DoRemove Method

TnxRemoteFilterEngine.DoRemove Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
procedure DoRemove;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.Duplicate Method

TnxRemoteFilterEngine.Duplicate Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function Duplicate(aFieldsSource: InxFieldsSource): TnxBaseFilterEngine; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.IsEvalLocal Method

TnxRemoteFilterEngine.IsEvalLocal Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function IsEvalLocal: Boolean; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteFilterEngine.MatchesBuffer Method

TnxRemoteFilterEngine.MatchesBuffer Method
TnxRemoteFilterEngine Class TnxRemoteFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxRemoteFilterEngine Methods

Links
TnxRemoteFilterEngine Class, TnxRemoteFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteFilterEngine Methods


TnxRemoteKeyFilterEngine Class

TnxRemoteKeyFilterEngine Class
TnxRemoteKeyFilterEngine Fields TnxRemoteKeyFilterEngine Methods TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteKeyFilterEnginenxreRemoteServerEngine_TnxRemoteKeyFilterEnginenxreRemoteServerEngine_TnxRemoteKeyFilterEnginenxreRemoteServerEngine_TnxRemoteKeyFilterEnginenxreRemoteServerEngine_TnxRemoteKeyFilterEngine
Syntax
Delphi
TnxRemoteKeyFilterEngine = class(TnxBaseFilterEngine);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteKeyFilterEngine.

Group

Classes

Links
TnxRemoteKeyFilterEngine Fields, TnxRemoteKeyFilterEngine Methods, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine, Classes


TnxRemoteKeyFilterEngine Members

TnxRemoteKeyFilterEngine Members
TnxRemoteKeyFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteKeyFilterEngine.

Class

TnxRemoteKeyFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
ProcessRequest | private
rfConnected | This is rfConnected, a member of class TnxRemoteKeyFilterEngine.
rfCursor | This is rfCursor, a member of class TnxRemoteKeyFilterEngine.
rfKeyFilterID | This is rfKeyFilterID, a member of class TnxRemoteKeyFilterEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
DoRemove |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxRemoteKeyFilterEngine
Create |
CreateDescriptor |
CreateFor |
DeactivateFilter |
Destroy |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxRemoteKeyFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxRemoteKeyFilterEngine.Create Constructor

TnxRemoteKeyFilterEngine.Create Constructor
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aCursor: TnxRemoteCursor; aKeyFilterID: TnxKeyFilterID); reintroduce;
Class

TnxRemoteKeyFilterEngine Class

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Class


TnxRemoteKeyFilterEngine.Destroy Destructor

TnxRemoteKeyFilterEngine.Destroy Destructor
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteKeyFilterEngine Class

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Class


TnxRemoteKeyFilterEngine Fields

TnxRemoteKeyFilterEngine Fields
TnxRemoteKeyFilterEngine Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteKeyFilterEngine class are listed here.

Class

TnxRemoteKeyFilterEngine Class

Protected Fields
Name | Description
ProcessRequest | private
rfConnected | This is rfConnected, a member of class TnxRemoteKeyFilterEngine.
rfCursor | This is rfCursor, a member of class TnxRemoteKeyFilterEngine.
rfKeyFilterID | This is rfKeyFilterID, a member of class TnxRemoteKeyFilterEngine.
Links
TnxRemoteKeyFilterEngine Class, Legend, Protected Fields


TnxRemoteKeyFilterEngine.ProcessRequest Field

TnxRemoteKeyFilterEngine.ProcessRequest Field
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteKeyFilterEngine Fields

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Fields


TnxRemoteKeyFilterEngine.rfConnected Field

TnxRemoteKeyFilterEngine.rfConnected Field
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Fields Send Feedback
Syntax
Delphi
rfConnected: Boolean;
Description

This is rfConnected, a member of class TnxRemoteKeyFilterEngine.

Group

TnxRemoteKeyFilterEngine Fields

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Fields


TnxRemoteKeyFilterEngine.rfCursor Field

TnxRemoteKeyFilterEngine.rfCursor Field
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Fields Send Feedback
Syntax
Delphi
rfCursor: TnxRemoteCursor;
Description

This is rfCursor, a member of class TnxRemoteKeyFilterEngine.

Group

TnxRemoteKeyFilterEngine Fields

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Fields


TnxRemoteKeyFilterEngine.rfKeyFilterID Field

TnxRemoteKeyFilterEngine.rfKeyFilterID Field
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Fields Send Feedback
Syntax
Delphi
rfKeyFilterID: TnxKeyFilterID;
Description

This is rfKeyFilterID, a member of class TnxRemoteKeyFilterEngine.

Group

TnxRemoteKeyFilterEngine Fields

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Fields


TnxRemoteKeyFilterEngine Methods

TnxRemoteKeyFilterEngine Methods
TnxRemoteKeyFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteKeyFilterEngine class are listed here.

Class

TnxRemoteKeyFilterEngine Class

Protected Methods
Name | Description
DoRemove |
Public Methods
Name | Description
ActivateFilter | TnxRemoteKeyFilterEngine
CreateDescriptor |
DeactivateFilter |
Disconnect |
Duplicate |
IsEvalLocal |
MatchesBuffer |
Links
TnxRemoteKeyFilterEngine Class, Legend, Protected Methods, Public Methods


TnxRemoteKeyFilterEngine.ActivateFilter Method

TnxRemoteKeyFilterEngine.ActivateFilter Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function ActivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Description

TnxRemoteKeyFilterEngine

Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.CreateDescriptor Method

TnxRemoteKeyFilterEngine.CreateDescriptor Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.DeactivateFilter Method

TnxRemoteKeyFilterEngine.DeactivateFilter Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function DeactivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.Disconnect Method

TnxRemoteKeyFilterEngine.Disconnect Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
procedure Disconnect; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.DoRemove Method

TnxRemoteKeyFilterEngine.DoRemove Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
procedure DoRemove;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.Duplicate Method

TnxRemoteKeyFilterEngine.Duplicate Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function Duplicate(aFieldsSource: InxFieldsSource): TnxBaseFilterEngine; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.IsEvalLocal Method

TnxRemoteKeyFilterEngine.IsEvalLocal Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function IsEvalLocal: Boolean; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteKeyFilterEngine.MatchesBuffer Method

TnxRemoteKeyFilterEngine.MatchesBuffer Method
TnxRemoteKeyFilterEngine Class TnxRemoteKeyFilterEngine Members nxreRemoteServerEngine Namespace TnxRemoteKeyFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxRemoteKeyFilterEngine Methods

Links
TnxRemoteKeyFilterEngine Class, TnxRemoteKeyFilterEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteKeyFilterEngine Methods


TnxRemoteServerEngine Class

TnxRemoteServerEngine Class
TnxRemoteServerEngine Fields TnxRemoteServerEngine Methods TnxRemoteServerEngine Properties TnxRemoteServerEngine Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEnginenxreRemoteServerEngine_TnxRemoteServerEngine
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemoteServerEngine = class(TnxBaseServerEngine);
File

nxreRemoteServerEngine

Description

Client-side proxy server engine component that allows calls to be made to a server engine in an external (remote) NexusDB Server, and results to be returned.

Group

Classes

Links
TnxRemoteServerEngine Fields, TnxRemoteServerEngine Methods, TnxRemoteServerEngine Properties, TnxRemoteServerEngine Members, nxreRemoteServerEngine, Classes


TnxRemoteServerEngine Members

TnxRemoteServerEngine Members
TnxRemoteServerEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemoteServerEngine.

Class

TnxRemoteServerEngine Class

Protected Fields
Name | Description
bseCursorCount | This is bseCursorCount, a member of class TnxBaseServerEngine.
bseDatabaseCount | This is bseDatabaseCount, a member of class TnxBaseServerEngine.
bseMonitors | This is bseMonitors, a member of class TnxBaseServerEngine.
bseSessionCount | This is bseSessionCount, a member of class TnxBaseServerEngine.
bseSessionsHead | This is bseSessionsHead, a member of class TnxBaseServerEngine.
bseSessionsPadlock | private
bseSessionsTail | This is bseSessionsTail, a member of class TnxBaseServerEngine.
bseStatementCount | This is bseStatementCount, a member of class TnxBaseServerEngine.
bseTransContextCount | This is bseTransContextCount, a member of class TnxBaseServerEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
rseCacheAliases | This is rseCacheAliases, a member of class TnxRemoteServerEngine.
rseRemoteThreadPriority | private
rseTimeout | This is rseTimeout, a member of class TnxRemoteServerEngine.
rseTransport | This is rseTransport, a member of class TnxRemoteServerEngine.
rseTransportID | This is rseTransportID, a member of class TnxRemoteServerEngine.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bseConvertException | TnxBaseServerEngine
bseCreateInstanceFor |
bseGetExceptionClass | TnxRemoteServerEngine
bseGetKeepSessionStats |
bseGetServerGuid |
bseGetServerName |
bseInactive |
bseInformMonitorsCreated |
bseInformMonitorsDestroyed |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData |
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
rseCheckTransport |
rseInvalidateAliasCache |
rseSetCacheAliases |
rseSetTransport |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
ClearStats | This function resets all statistical values.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | creation/destruction
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | This function returns the captions for the statistics page on the server gui.
GetStatsValues | Returns statistic values.
GetStatsValues |
GetStatsValues | This function returns the values for the statistics page on the server gui.
IsSecureServer |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
SessionOpen | This function opens creates a new session.
SessionOpenEx |
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
CursorCount | CursorCount returns the number of open cursors in this server engine
DatabaseCount | DatabaseCount returns the number of open databases in this server engine.
SavedActive | Can be used to save a certain state.
ServerGuid | Returns a unique ID for this server.
ServerName | This is ServerName, a member of class TnxBaseServerEngine.
SessionCount | SessionCount returns the number of open session in this server engine
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StatementCount | StatementCount returns the number of open (SQL) statements in this server engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TimeOut | This is TimeOut, a member of class TnxRemoteServerEngine.
TransContextCount | TransContextCount returns the number of transaction contexts in this server engine.
TransportID | properties
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CacheAliases | Set to True to reduce the number of calls made to the remote server to check existence of alias. If True, stores the list of aliases locally when opening.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
RemoteThreadPriority | This is RemoteThreadPriority, a member of class TnxRemoteServerEngine.
Transport | Set this property to the transport you wish to use.
Version | Version of the component.
Links
TnxRemoteServerEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemoteServerEngine.Create Constructor

TnxRemoteServerEngine.Create Constructor
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

creation/destruction

Class

TnxRemoteServerEngine Class

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Class


TnxRemoteServerEngine.Destroy Destructor

TnxRemoteServerEngine.Destroy Destructor
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteServerEngine Class

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Class


TnxRemoteServerEngine Fields

TnxRemoteServerEngine Fields
TnxRemoteServerEngine Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteServerEngine class are listed here.

Class

TnxRemoteServerEngine Class

Protected Fields
Name | Description
rseCacheAliases | This is rseCacheAliases, a member of class TnxRemoteServerEngine.
rseRemoteThreadPriority | private
rseTimeout | This is rseTimeout, a member of class TnxRemoteServerEngine.
rseTransport | This is rseTransport, a member of class TnxRemoteServerEngine.
rseTransportID | This is rseTransportID, a member of class TnxRemoteServerEngine.
Links
TnxRemoteServerEngine Class, Legend, Protected Fields


TnxRemoteServerEngine.rseCacheAliases Field

TnxRemoteServerEngine.rseCacheAliases Field
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Fields Send Feedback
Syntax
Delphi
rseCacheAliases: Boolean;
Description

This is rseCacheAliases, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Fields

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Fields


TnxRemoteServerEngine.rseRemoteThreadPriority Field

TnxRemoteServerEngine.rseRemoteThreadPriority Field
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Fields Send Feedback
Syntax
Delphi
rseRemoteThreadPriority: TnxThreadPriority;
Description

private

Group

TnxRemoteServerEngine Fields

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Fields


TnxRemoteServerEngine.rseTimeout Field

TnxRemoteServerEngine.rseTimeout Field
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Fields Send Feedback
Syntax
Delphi
rseTimeout: TnxWord32;
Description

This is rseTimeout, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Fields

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Fields


TnxRemoteServerEngine.rseTransport Field

TnxRemoteServerEngine.rseTransport Field
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Fields Send Feedback
Syntax
Delphi
rseTransport: TnxBaseTransport;
Description

This is rseTransport, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Fields

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Fields


TnxRemoteServerEngine.rseTransportID Field

TnxRemoteServerEngine.rseTransportID Field
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Fields Send Feedback
Syntax
Delphi
rseTransportID: TnxTransportID;
Description

This is rseTransportID, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Fields

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Fields


TnxRemoteServerEngine Methods

TnxRemoteServerEngine Methods
TnxRemoteServerEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteServerEngine class are listed here.

Class

TnxRemoteServerEngine Class

Protected Methods
Name | Description
bseGetExceptionClass | TnxRemoteServerEngine
bseGetServerGuid |
bseGetServerName |
nxcNotification |
rseCheckTransport |
rseInvalidateAliasCache |
rseSetCacheAliases |
rseSetTransport |
scInitializing |
scIsStateParent |
Public Methods
Name | Description
SessionOpenEx |
Links
TnxRemoteServerEngine Class, Legend, Protected Methods, Public Methods


TnxRemoteServerEngine.bseGetExceptionClass Method

TnxRemoteServerEngine.bseGetExceptionClass Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetExceptionClass: EnxExceptionClass; override;
Description

TnxRemoteServerEngine

Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.bseGetServerGuid Method

TnxRemoteServerEngine.bseGetServerGuid Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetServerGuid: TnxGuid; override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.bseGetServerName Method

TnxRemoteServerEngine.bseGetServerName Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetServerName: string; override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.nxcNotification Method

TnxRemoteServerEngine.nxcNotification Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.rseCheckTransport Method

TnxRemoteServerEngine.rseCheckTransport Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure rseCheckTransport;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.rseInvalidateAliasCache Method

TnxRemoteServerEngine.rseInvalidateAliasCache Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure rseInvalidateAliasCache;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.rseSetCacheAliases Method

TnxRemoteServerEngine.rseSetCacheAliases Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure rseSetCacheAliases(const aCacheAliases: Boolean);
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.rseSetTransport Method

TnxRemoteServerEngine.rseSetTransport Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure rseSetTransport(const Value: TnxBaseTransport);
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.scInitializing Method

TnxRemoteServerEngine.scInitializing Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.scIsStateParent Method

TnxRemoteServerEngine.scIsStateParent Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine.SessionOpenEx Method

TnxRemoteServerEngine.SessionOpenEx Method
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Methods Send Feedback
Syntax
Delphi
function SessionOpenEx(out aSession: TnxAbstractSession; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: TnxWord32; aClientVersion: Integer): TnxResult; override;
Group

TnxRemoteServerEngine Methods

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Methods


TnxRemoteServerEngine Properties

TnxRemoteServerEngine Properties
TnxRemoteServerEngine Class Legend Public Properties Published Properties Send Feedback

The properties of the TnxRemoteServerEngine class are listed here.

Class

TnxRemoteServerEngine Class

Public Properties
Name | Description
TimeOut | This is TimeOut, a member of class TnxRemoteServerEngine.
TransportID | properties
Published Properties
Name | Description
CacheAliases | Set to True to reduce the number of calls made to the remote server to check existence of alias. If True, stores the list of aliases locally when opening.
RemoteThreadPriority | This is RemoteThreadPriority, a member of class TnxRemoteServerEngine.
Transport | Set this property to the transport you wish to use.
Links
TnxRemoteServerEngine Class, Legend, Public Properties, Published Properties


TnxRemoteServerEngine.CacheAliases Property

TnxRemoteServerEngine.CacheAliases Property
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Properties Send Feedback
Syntax
Delphi
property CacheAliases: boolean;
Description

Set to True to reduce the number of calls made to the remote server to check existence of alias. If True, stores the list of aliases locally when opening.

Group

TnxRemoteServerEngine Properties

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Properties


TnxRemoteServerEngine.RemoteThreadPriority Property

TnxRemoteServerEngine.RemoteThreadPriority Property
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Properties Send Feedback
Syntax
Delphi
property RemoteThreadPriority: TnxThreadPriority;
Description

This is RemoteThreadPriority, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Properties

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Properties


TnxRemoteServerEngine.TimeOut Property

TnxRemoteServerEngine.TimeOut Property
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Properties Send Feedback
Syntax
Delphi
property TimeOut: TnxWord32;
Description

This is TimeOut, a member of class TnxRemoteServerEngine.

Group

TnxRemoteServerEngine Properties

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Properties


TnxRemoteServerEngine.Transport Property

TnxRemoteServerEngine.Transport Property
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Properties See Also Send Feedback
Syntax
Delphi
property Transport: TnxBaseTransport;
Description

Set this property to the transport you wish to use.

See Also

TnxWinsockTransport, TnxNamedPipeTransport, TnxRegisteredCOMTransport, TnxCustomCOMTransport, TnxBlowfishRC4SecuredTransport.

Group

TnxRemoteServerEngine Properties

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Properties, See Also


TnxRemoteServerEngine.TransportID Property

TnxRemoteServerEngine.TransportID Property
TnxRemoteServerEngine Class TnxRemoteServerEngine Members nxreRemoteServerEngine Namespace TnxRemoteServerEngine Properties Send Feedback
Syntax
Delphi
property TransportID: TnxTransportID;
Description

properties

Group

TnxRemoteServerEngine Properties

Links
TnxRemoteServerEngine Class, TnxRemoteServerEngine Members, nxreRemoteServerEngine Namespace, TnxRemoteServerEngine Properties


TnxRemoteSession Class

TnxRemoteSession Class
TnxRemoteSession Fields TnxRemoteSession Methods TnxRemoteSession Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSessionnxreRemoteServerEngine_TnxRemoteSession
Syntax
Delphi
TnxRemoteSession = class(TnxAbstractSession, InxInterface, InxSessionRequests, InxRemoteTaskInfoCreator);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteSession.

Group

Classes

Links
TnxRemoteSession Fields, TnxRemoteSession Methods, TnxRemoteSession Members, nxreRemoteServerEngine, Classes


TnxRemoteSession Members

TnxRemoteSession Members
TnxRemoteSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteSession.

Class

TnxRemoteSession Class

Protected Fields
Name | Description
asAuthenticated | This is asAuthenticated, a member of class TnxAbstractSession.
asCleanedUp | This is asCleanedUp, a member of class TnxAbstractSession.
asConnectedFrom | This is asConnectedFrom, a member of class TnxAbstractSession.
asConnectedSince | This is asConnectedSince, a member of class TnxAbstractSession.
asDatabasesHead | This is asDatabasesHead, a member of class TnxAbstractSession.
asDatabasesPadlock | This is asDatabasesPadlock, a member of class TnxAbstractSession.
asDatabasesTail | This is asDatabasesTail, a member of class TnxAbstractSession.
asLock | private
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractSession.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
asPassword | This is asPassword, a member of class TnxAbstractSession.
asServerEngine | This is asServerEngine, a member of class TnxAbstractSession.
asServerEngineNext | This is asServerEngineNext, a member of class TnxAbstractSession.
asServerEnginePrev | This is asServerEnginePrev, a member of class TnxAbstractSession.
asSessionNotifications | This is asSessionNotifications, a member of class TnxAbstractSession.
asTaskInfosHead | This is asTaskInfosHead, a member of class TnxAbstractSession.
asTaskInfosPadlock | This is asTaskInfosPadlock, a member of class TnxAbstractSession.
asTaskInfosTail | This is asTaskInfosTail, a member of class TnxAbstractSession.
asTransContextsHead | This is asTransContextsHead, a member of class TnxAbstractSession.
asTransContextsPadlock | This is asTransContextsPadlock, a member of class TnxAbstractSession.
asTransContextsTail | This is asTransContextsTail, a member of class TnxAbstractSession.
asUserName | This is asUserName, a member of class TnxAbstractSession.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
rsAliasCache | This is rsAliasCache, a member of class TnxRemoteSession.
rsAliasCacheValid | This is rsAliasCacheValid, a member of class TnxRemoteSession.
rsConnectionLost | This is rsConnectionLost, a member of class TnxRemoteSession.
rsMsgQueue | This is rsMsgQueue, a member of class TnxRemoteSession.
rsRemoteThreadPriority | private
rsServerVersion | This is rsServerVersion, a member of class TnxRemoteSession.
rsSessionID | This is rsSessionID, a member of class TnxRemoteSession.
Protected Methods
Name | Description
_AddRef |
_Release |
asAddToServerEngine |
asCleanup |
asCreateStats |
asDoCreateStats |
asFailed |
asGetClientDefaultLocale |
asGetClientVersion |
asGetServerVersion |
asGetSessionNotifications |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
asRemoveFromServerEngine |
atoSetTimeout |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
rsInvalidateAliasCache |
Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
AfterConstruction | see TObject.AfterConstruction TnxAbstractSession
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
AliasAdd | alias managment TnxRemoteSession
AliasDelete |
AliasGetList |
AliasGetPath |
AliasModify |
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
CloseInactiveFolders | table/folder managment
CloseInactiveTables |
Create |
CreateInstanceFor | remoting integration
CreateRemoteTaskInfo |
CreateRequest |
DatabaseOpen | database managment
Destroy |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Failed | Removes any failed locks and marks the session as failed.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetRegisteredClassList |
GetUserInfo | misc
LookupByID |
LookupByID | This is the class function that returns the object with a certain ID.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PasswordAdd | password management
PasswordRemove |
PasswordRemoveAll |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
PrepareDestroy |
ProcessPost |
ProcessRequest |
ProcessRequestDirect |
ProcessStreamedRequest |
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
RequestNoData |
RequestNoDataNoReply |
TransContextCreate | transaction context managment
Public Properties
Name | Description
Authenticated | This property returns true, it the session was logged on successfully with User Name and Password.
CleanedUp | This property returns true, it the session has failed and has been cleaned up. It no longer owns any databases.
ClientDefaultLocale | Returns the locale that the client wishes to use for string comparisons where no explicit locale is defined. NIL if no default is specified by the client.
ClientVersion | This property returns the version of the client that opened the session.
ConnectedFrom | This property returns the connection information for the session.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
Password | This property returns the password used to logon the session.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
ServerEngine | This property returns the server engine the session is attached to.
ServerVersion | This property returns the version of the server that runs the session.
Session | The session owning this server object (if any) or nil.
SessionNotifications | This is SessionNotifications, a member of class TnxAbstractSession.
Timeout | Property to read/write the timeout in msec for the object.
UserName | This property returns the user name used to logon the session.
Links
TnxRemoteSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteSession.Create Constructor

TnxRemoteSession.Create Constructor
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Class Send Feedback
Syntax
Delphi
constructor Create(aServerEngine: TnxRemoteServerEngine; aTimeout: TnxWord32; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aServerVersion: Integer; aSessionID: TnxSessionID);
Class

TnxRemoteSession Class

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Class


TnxRemoteSession.Destroy Destructor

TnxRemoteSession.Destroy Destructor
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteSession Class

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Class


TnxRemoteSession Fields

TnxRemoteSession Fields
TnxRemoteSession Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteSession class are listed here.

Class

TnxRemoteSession Class

Protected Fields
Name | Description
rsAliasCache | This is rsAliasCache, a member of class TnxRemoteSession.
rsAliasCacheValid | This is rsAliasCacheValid, a member of class TnxRemoteSession.
rsConnectionLost | This is rsConnectionLost, a member of class TnxRemoteSession.
rsMsgQueue | This is rsMsgQueue, a member of class TnxRemoteSession.
rsRemoteThreadPriority | private
rsServerVersion | This is rsServerVersion, a member of class TnxRemoteSession.
rsSessionID | This is rsSessionID, a member of class TnxRemoteSession.
Links
TnxRemoteSession Class, Legend, Protected Fields


TnxRemoteSession.rsAliasCache Field

TnxRemoteSession.rsAliasCache Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsAliasCache: TStringList;
Description

This is rsAliasCache, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsAliasCacheValid Field

TnxRemoteSession.rsAliasCacheValid Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsAliasCacheValid: Boolean;
Description

This is rsAliasCacheValid, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsConnectionLost Field

TnxRemoteSession.rsConnectionLost Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsConnectionLost: Boolean;
Description

This is rsConnectionLost, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsMsgQueue Field

TnxRemoteSession.rsMsgQueue Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsMsgQueue: TnxDataMessageQueue;
Description

This is rsMsgQueue, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsRemoteThreadPriority Field

TnxRemoteSession.rsRemoteThreadPriority Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsRemoteThreadPriority: TnxThreadPriority;
Description

private

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsServerVersion Field

TnxRemoteSession.rsServerVersion Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsServerVersion: Integer;
Description

This is rsServerVersion, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession.rsSessionID Field

TnxRemoteSession.rsSessionID Field
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Fields Send Feedback
Syntax
Delphi
rsSessionID: TnxSessionID;
Description

This is rsSessionID, a member of class TnxRemoteSession.

Group

TnxRemoteSession Fields

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Fields


TnxRemoteSession Methods

TnxRemoteSession Methods
TnxRemoteSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteSession class are listed here.

Class

TnxRemoteSession Class

Protected Methods
Name | Description
asFailed |
asGetServerVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
atoSetTimeout |
rsInvalidateAliasCache |
Public Methods
Name | Description
AliasAdd | alias managment TnxRemoteSession
AliasDelete |
AliasGetList |
AliasGetPath |
AliasModify |
CloseInactiveFolders | table/folder managment
CloseInactiveTables |
CreateInstanceFor | remoting integration
CreateRemoteTaskInfo |
CreateRequest |
DatabaseOpen | database managment
GetRegisteredClassList |
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PasswordAdd | password management
PasswordRemove |
PasswordRemoveAll |
ProcessPost |
ProcessRequest |
ProcessRequestDirect |
ProcessStreamedRequest |
RequestNoData |
RequestNoDataNoReply |
TransContextCreate | transaction context managment
Links
TnxRemoteSession Class, Legend, Protected Methods, Public Methods


TnxRemoteSession.AliasAdd Method

TnxRemoteSession.AliasAdd Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function AliasAdd(const aAlias: string; const aPath: string; aEnforce: Boolean): TnxResult; override;
Description

alias managment

TnxRemoteSession

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.AliasDelete Method

TnxRemoteSession.AliasDelete Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function AliasDelete(const aAlias: string): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.AliasGetList Method

TnxRemoteSession.AliasGetList Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function AliasGetList(aList: TObjectList): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.AliasGetPath Method

TnxRemoteSession.AliasGetPath Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function AliasGetPath(const aAlias: string; out aPath: string): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.AliasModify Method

TnxRemoteSession.AliasModify Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function AliasModify(const aAlias: string; const aNewName: string; const aNewPath: string; aEnforce: Boolean): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.asFailed Method

TnxRemoteSession.asFailed Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
procedure asFailed(aPermanent: Boolean; aWait: Boolean); override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.asGetServerVersion Method

TnxRemoteSession.asGetServerVersion Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function asGetServerVersion: Integer; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.asoGetRemoteID Method

TnxRemoteSession.asoGetRemoteID Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.asoGetRemoteThreadPriority Method

TnxRemoteSession.asoGetRemoteThreadPriority Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.asoSetRemoteThreadPriority Method

TnxRemoteSession.asoSetRemoteThreadPriority Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.atoSetTimeout Method

TnxRemoteSession.atoSetTimeout Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.CloseInactiveFolders Method

TnxRemoteSession.CloseInactiveFolders Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function CloseInactiveFolders: TnxResult; override;
Description

table/folder managment

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.CloseInactiveTables Method

TnxRemoteSession.CloseInactiveTables Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function CloseInactiveTables: TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.CreateInstanceFor Method

TnxRemoteSession.CreateInstanceFor Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.CreateRemoteTaskInfo Method

TnxRemoteSession.CreateRemoteTaskInfo Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function CreateRemoteTaskInfo(const aTaskID: TnxTaskID): TnxAbstractTaskInfo;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.CreateRequest Method

TnxRemoteSession.CreateRequest Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.DatabaseOpen Method

TnxRemoteSession.DatabaseOpen Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function DatabaseOpen(out aDatabase: TnxAbstractDatabase; const aAliasType: string; const aAlias: string; aTransContext: TnxAbstractTransContext; aOpenMode: TnxOpenMode; aShareMode: TnxShareMode; aTimeout: TnxWord32): TnxResult; override;
Description

database managment

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.GetRegisteredClassList Method

TnxRemoteSession.GetRegisteredClassList Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function GetRegisteredClassList(const aClassListType: TnxClassListType; aList: TStrings): TnxResult; override;
Description
- engine managment -

This function returns a list of registered engines of the requested type.

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionClear Method

TnxRemoteSession.OptionClear Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionGet Method

TnxRemoteSession.OptionGet Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionGetEffective Method

TnxRemoteSession.OptionGetEffective Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionList Method

TnxRemoteSession.OptionList Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionListEffective Method

TnxRemoteSession.OptionListEffective Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.OptionSet Method

TnxRemoteSession.OptionSet Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.PasswordAdd Method

TnxRemoteSession.PasswordAdd Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function PasswordAdd(const aPassword: UnicodeString): TnxResult; override;
Description

password management

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.PasswordRemove Method

TnxRemoteSession.PasswordRemove Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function PasswordRemove(const aPassword: UnicodeString): TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.PasswordRemoveAll Method

TnxRemoteSession.PasswordRemoveAll Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function PasswordRemoveAll: TnxResult; override;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.ProcessPost Method

TnxRemoteSession.ProcessPost Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
procedure ProcessPost(aSource: TObject; aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32);
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.ProcessRequest Method

TnxRemoteSession.ProcessRequest Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function ProcessRequest(aSource: TObject; aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.ProcessRequestDirect Method

TnxRemoteSession.ProcessRequestDirect Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function ProcessRequestDirect(aRemoteThreadPriority: TnxThreadPriority; aMsgID: TnxMsgID; aTimeout: TnxWord32; aRequestData: Pointer; aRequestDataLen: TnxWord32; aReply: PPointer; aReplyLen: PnxWord32; aReplyType: TnxNetMsgDataType): TnxResult;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.ProcessStreamedRequest Method

TnxRemoteSession.ProcessStreamedRequest Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.RequestNoData Method

TnxRemoteSession.RequestNoData Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.RequestNoDataNoReply Method

TnxRemoteSession.RequestNoDataNoReply Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.rsInvalidateAliasCache Method

TnxRemoteSession.rsInvalidateAliasCache Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
procedure rsInvalidateAliasCache;
Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteSession.TransContextCreate Method

TnxRemoteSession.TransContextCreate Method
TnxRemoteSession Class TnxRemoteSession Members nxreRemoteServerEngine Namespace TnxRemoteSession Methods Send Feedback
Syntax
Delphi
function TransContextCreate(out aTransContext: TnxAbstractTransContext; aTimeout: TnxWord32): TnxResult; override;
Description

transaction context managment

Group

TnxRemoteSession Methods

Links
TnxRemoteSession Class, TnxRemoteSession Members, nxreRemoteServerEngine Namespace, TnxRemoteSession Methods


TnxRemoteStatement Class

TnxRemoteStatement Class
TnxRemoteStatement Fields TnxRemoteStatement Methods TnxRemoteStatement Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatementnxreRemoteServerEngine_TnxRemoteStatement
Syntax
Delphi
TnxRemoteStatement = class(TnxAbstractStatement);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteStatement.

Group

Classes

Links
TnxRemoteStatement Fields, TnxRemoteStatement Methods, TnxRemoteStatement Members, nxreRemoteServerEngine, Classes


TnxRemoteStatement Members

TnxRemoteStatement Members
TnxRemoteStatement Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteStatement.

Class

TnxRemoteStatement Class

Protected Fields
Name | Description
asDatabase | private
asDatabaseNext | This is asDatabaseNext, a member of class TnxAbstractStatement.
asDatabasePrev | This is asDatabasePrev, a member of class TnxAbstractStatement.
asExecDirect | This is asExecDirect, a member of class TnxAbstractStatement.
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractStatement.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
ProcessRequest | private
rsRemoteThreadPriority | This is rsRemoteThreadPriority, a member of class TnxRemoteStatement.
rsServerVersion | This is rsServerVersion, a member of class TnxRemoteStatement.
rsStatementID | This is rsStatementID, a member of class TnxRemoteStatement.
SessionRequests | This is SessionRequests, a member of class TnxRemoteStatement.
Protected Methods
Name | Description
_AddRef |
_Release |
asAddToDatabase |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
asRemoveFromDatabase |
atoSetTimeout |
CreateRequest |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
ProcessStreamedRequest |
QueryInterface | InxInterface
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractStatement
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create |
CreateInstanceFor | remoting integration
Destroy |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Exec |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetParams |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
Prepare | statement
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
SetParams |
Public Properties
Name | Description
Database | This property returns the database the statement is linked to.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxRemoteStatement Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteStatement.Create Constructor

TnxRemoteStatement.Create Constructor
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Class Send Feedback
Syntax
Delphi
constructor Create(aDatabase: TnxRemoteDatabase; aTimeout: TnxWord32; aStatementID: TnxStatementID);
Class

TnxRemoteStatement Class

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Class


TnxRemoteStatement.Destroy Destructor

TnxRemoteStatement.Destroy Destructor
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteStatement Class

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Class


TnxRemoteStatement Fields

TnxRemoteStatement Fields
TnxRemoteStatement Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteStatement class are listed here.

Class

TnxRemoteStatement Class

Protected Fields
Name | Description
ProcessRequest | private
rsRemoteThreadPriority | This is rsRemoteThreadPriority, a member of class TnxRemoteStatement.
rsServerVersion | This is rsServerVersion, a member of class TnxRemoteStatement.
rsStatementID | This is rsStatementID, a member of class TnxRemoteStatement.
SessionRequests | This is SessionRequests, a member of class TnxRemoteStatement.
Links
TnxRemoteStatement Class, Legend, Protected Fields


TnxRemoteStatement.ProcessRequest Field

TnxRemoteStatement.ProcessRequest Field
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteStatement Fields

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Fields


TnxRemoteStatement.rsRemoteThreadPriority Field

TnxRemoteStatement.rsRemoteThreadPriority Field
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Fields Send Feedback
Syntax
Delphi
rsRemoteThreadPriority: TnxThreadPriority;
Description

This is rsRemoteThreadPriority, a member of class TnxRemoteStatement.

Group

TnxRemoteStatement Fields

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Fields


TnxRemoteStatement.rsServerVersion Field

TnxRemoteStatement.rsServerVersion Field
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Fields Send Feedback
Syntax
Delphi
rsServerVersion: Integer;
Description

This is rsServerVersion, a member of class TnxRemoteStatement.

Group

TnxRemoteStatement Fields

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Fields


TnxRemoteStatement.rsStatementID Field

TnxRemoteStatement.rsStatementID Field
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Fields Send Feedback
Syntax
Delphi
rsStatementID: TnxStatementID;
Description

This is rsStatementID, a member of class TnxRemoteStatement.

Group

TnxRemoteStatement Fields

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Fields


TnxRemoteStatement.SessionRequests Field

TnxRemoteStatement.SessionRequests Field
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Fields Send Feedback
Syntax
Delphi
SessionRequests: InxSessionRequests;
Description

This is SessionRequests, a member of class TnxRemoteStatement.

Group

TnxRemoteStatement Fields

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Fields


TnxRemoteStatement Methods

TnxRemoteStatement Methods
TnxRemoteStatement Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteStatement class are listed here.

Class

TnxRemoteStatement Class

Protected Methods
Name | Description
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
atoSetTimeout |
CreateRequest |
ProcessStreamedRequest |
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
CreateInstanceFor | remoting integration
Exec |
GetParams |
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
Prepare | statement
SetParams |
Links
TnxRemoteStatement Class, Legend, Protected Methods, Public Methods


TnxRemoteStatement.asoGetRemoteID Method

TnxRemoteStatement.asoGetRemoteID Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.asoGetRemoteThreadPriority Method

TnxRemoteStatement.asoGetRemoteThreadPriority Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.asoSetRemoteThreadPriority Method

TnxRemoteStatement.asoSetRemoteThreadPriority Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.atoSetTimeout Method

TnxRemoteStatement.atoSetTimeout Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.CreateInstanceFor Method

TnxRemoteStatement.CreateInstanceFor Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.CreateRequest Method

TnxRemoteStatement.CreateRequest Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.Exec Method

TnxRemoteStatement.Exec Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function Exec(out aCursor: TnxAbstractCursor; aOpenMode: TnxOpenMode; aStream: TStream): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.GetParams Method

TnxRemoteStatement.GetParams Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function GetParams(const aParams: TnxSqlParamList; aStream: TStream): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionClear Method

TnxRemoteStatement.OptionClear Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionGet Method

TnxRemoteStatement.OptionGet Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionGetEffective Method

TnxRemoteStatement.OptionGetEffective Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionList Method

TnxRemoteStatement.OptionList Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionListEffective Method

TnxRemoteStatement.OptionListEffective Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.OptionSet Method

TnxRemoteStatement.OptionSet Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.Prepare Method

TnxRemoteStatement.Prepare Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function Prepare(aStatementType: TnxStatementType; const aQueryText: WideString; aStream: TStream): TnxResult; override;
Description

statement

Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.ProcessStreamedRequest Method

TnxRemoteStatement.ProcessStreamedRequest Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.RequestNoData Method

TnxRemoteStatement.RequestNoData Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.RequestNoDataNoReply Method

TnxRemoteStatement.RequestNoDataNoReply Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteStatement.SetParams Method

TnxRemoteStatement.SetParams Method
TnxRemoteStatement Class TnxRemoteStatement Members nxreRemoteServerEngine Namespace TnxRemoteStatement Methods Send Feedback
Syntax
Delphi
function SetParams(const aParams: TnxSqlParamList; aStream: TStream): TnxResult; override;
Group

TnxRemoteStatement Methods

Links
TnxRemoteStatement Class, TnxRemoteStatement Members, nxreRemoteServerEngine Namespace, TnxRemoteStatement Methods


TnxRemoteTaskInfo Class

TnxRemoteTaskInfo Class
TnxRemoteTaskInfo Fields TnxRemoteTaskInfo Methods TnxRemoteTaskInfo Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfonxreRemoteServerEngine_TnxRemoteTaskInfo
Syntax
Delphi
TnxRemoteTaskInfo = class(TnxAbstractTaskInfo);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteTaskInfo.

Group

Classes

Links
TnxRemoteTaskInfo Fields, TnxRemoteTaskInfo Methods, TnxRemoteTaskInfo Members, nxreRemoteServerEngine, Classes


TnxRemoteTaskInfo Members

TnxRemoteTaskInfo Members
TnxRemoteTaskInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteTaskInfo.

Class

TnxRemoteTaskInfo Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atiSessionNext | This is atiSessionNext, a member of class TnxAbstractTaskInfo.
atiSessionPrev | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
ProcessRequest | private
rtiRemoteThreadPriority | This is rtiRemoteThreadPriority, a member of class TnxRemoteTaskInfo.
rtiServerVersion | This is rtiServerVersion, a member of class TnxRemoteTaskInfo.
rtiTaskID | This is rtiTaskID, a member of class TnxRemoteTaskInfo.
SessionRequests | This is SessionRequests, a member of class TnxRemoteTaskInfo.
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID | TnxRemoteTaskInfo
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atiAddToSession | TnxAbstractTaskInfo
atiRemoveFromSession |
CreateRequest |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
ProcessStreamedRequest |
QueryInterface | InxInterface
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Cancel |
Close |
Create |
CreateInstanceFor | remoting integration
Destroy |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetStatus | status
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxRemoteTaskInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteTaskInfo.Create Constructor

TnxRemoteTaskInfo.Create Constructor
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxRemoteSession; aTaskID: TnxTaskID);
Class

TnxRemoteTaskInfo Class

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Class


TnxRemoteTaskInfo.Destroy Destructor

TnxRemoteTaskInfo.Destroy Destructor
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteTaskInfo Class

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Class


TnxRemoteTaskInfo Fields

TnxRemoteTaskInfo Fields
TnxRemoteTaskInfo Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteTaskInfo class are listed here.

Class

TnxRemoteTaskInfo Class

Protected Fields
Name | Description
ProcessRequest | private
rtiRemoteThreadPriority | This is rtiRemoteThreadPriority, a member of class TnxRemoteTaskInfo.
rtiServerVersion | This is rtiServerVersion, a member of class TnxRemoteTaskInfo.
rtiTaskID | This is rtiTaskID, a member of class TnxRemoteTaskInfo.
SessionRequests | This is SessionRequests, a member of class TnxRemoteTaskInfo.
Links
TnxRemoteTaskInfo Class, Legend, Protected Fields


TnxRemoteTaskInfo.ProcessRequest Field

TnxRemoteTaskInfo.ProcessRequest Field
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteTaskInfo Fields

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Fields


TnxRemoteTaskInfo.rtiRemoteThreadPriority Field

TnxRemoteTaskInfo.rtiRemoteThreadPriority Field
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Fields Send Feedback
Syntax
Delphi
rtiRemoteThreadPriority: TnxThreadPriority;
Description

This is rtiRemoteThreadPriority, a member of class TnxRemoteTaskInfo.

Group

TnxRemoteTaskInfo Fields

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Fields


TnxRemoteTaskInfo.rtiServerVersion Field

TnxRemoteTaskInfo.rtiServerVersion Field
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Fields Send Feedback
Syntax
Delphi
rtiServerVersion: Integer;
Description

This is rtiServerVersion, a member of class TnxRemoteTaskInfo.

Group

TnxRemoteTaskInfo Fields

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Fields


TnxRemoteTaskInfo.rtiTaskID Field

TnxRemoteTaskInfo.rtiTaskID Field
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Fields Send Feedback
Syntax
Delphi
rtiTaskID: TnxTaskID;
Description

This is rtiTaskID, a member of class TnxRemoteTaskInfo.

Group

TnxRemoteTaskInfo Fields

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Fields


TnxRemoteTaskInfo.SessionRequests Field

TnxRemoteTaskInfo.SessionRequests Field
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Fields Send Feedback
Syntax
Delphi
SessionRequests: InxSessionRequests;
Description

This is SessionRequests, a member of class TnxRemoteTaskInfo.

Group

TnxRemoteTaskInfo Fields

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Fields


TnxRemoteTaskInfo Methods

TnxRemoteTaskInfo Methods
TnxRemoteTaskInfo Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteTaskInfo class are listed here.

Class

TnxRemoteTaskInfo Class

Protected Methods
Name | Description
asoGetRemoteID | TnxRemoteTaskInfo
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
CreateRequest |
ProcessStreamedRequest |
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
Cancel |
CreateInstanceFor | remoting integration
GetStatus | status
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
Links
TnxRemoteTaskInfo Class, Legend, Protected Methods, Public Methods


TnxRemoteTaskInfo.asoGetRemoteID Method

TnxRemoteTaskInfo.asoGetRemoteID Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Description

TnxRemoteTaskInfo

Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.asoGetRemoteThreadPriority Method

TnxRemoteTaskInfo.asoGetRemoteThreadPriority Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.asoSetRemoteThreadPriority Method

TnxRemoteTaskInfo.asoSetRemoteThreadPriority Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.Cancel Method

TnxRemoteTaskInfo.Cancel Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function Cancel: TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.CreateInstanceFor Method

TnxRemoteTaskInfo.CreateInstanceFor Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.CreateRequest Method

TnxRemoteTaskInfo.CreateRequest Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.GetStatus Method

TnxRemoteTaskInfo.GetStatus Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function GetStatus(out aCompleted: Boolean; out aStatus: TnxTaskStatus): TnxResult; override;
Description

status

Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionClear Method

TnxRemoteTaskInfo.OptionClear Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionGet Method

TnxRemoteTaskInfo.OptionGet Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionGetEffective Method

TnxRemoteTaskInfo.OptionGetEffective Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionList Method

TnxRemoteTaskInfo.OptionList Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionListEffective Method

TnxRemoteTaskInfo.OptionListEffective Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.OptionSet Method

TnxRemoteTaskInfo.OptionSet Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.ProcessStreamedRequest Method

TnxRemoteTaskInfo.ProcessStreamedRequest Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.RequestNoData Method

TnxRemoteTaskInfo.RequestNoData Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTaskInfo.RequestNoDataNoReply Method

TnxRemoteTaskInfo.RequestNoDataNoReply Method
TnxRemoteTaskInfo Class TnxRemoteTaskInfo Members nxreRemoteServerEngine Namespace TnxRemoteTaskInfo Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteTaskInfo Methods

Links
TnxRemoteTaskInfo Class, TnxRemoteTaskInfo Members, nxreRemoteServerEngine Namespace, TnxRemoteTaskInfo Methods


TnxRemoteTransContext Class

TnxRemoteTransContext Class
TnxRemoteTransContext Fields TnxRemoteTransContext Methods TnxRemoteTransContext Members nxreRemoteServerEngine Classes Send Feedback
Class Hierarchy
nxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContextnxreRemoteServerEngine_TnxRemoteTransContext
Syntax
Delphi
TnxRemoteTransContext = class(TnxAbstractTransContext);
File

nxreRemoteServerEngine

Description

This is class nxreRemoteServerEngine.TnxRemoteTransContext.

Group

Classes

Links
TnxRemoteTransContext Fields, TnxRemoteTransContext Methods, TnxRemoteTransContext Members, nxreRemoteServerEngine, Classes


TnxRemoteTransContext Members

TnxRemoteTransContext Members
TnxRemoteTransContext Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRemoteTransContext.

Class

TnxRemoteTransContext Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atcDatabasesHead | This is atcDatabasesHead, a member of class TnxAbstractTransContext.
atcDatabasesPadlock | This is atcDatabasesPadlock, a member of class TnxAbstractTransContext.
atcDatabasesTail | This is atcDatabasesTail, a member of class TnxAbstractTransContext.
atcFailed | private
atcLockedIncDone | This is atcLockedIncDone, a member of class TnxAbstractTransContext.
atcSessionNext | This is atcSessionNext, a member of class TnxAbstractTransContext.
atcSessionPrev | This is atcSessionPrev, a member of class TnxAbstractTransContext.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
ProcessRequest | private
rtcOwnsID | This is rtcOwnsID, a member of class TnxRemoteTransContext.
rtcRemoteThreadPriority | This is rtcRemoteThreadPriority, a member of class TnxRemoteTransContext.
rtcServerVersion | This is rtcServerVersion, a member of class TnxRemoteTransContext.
rtcTransContextID | This is rtcTransContextID, a member of class TnxRemoteTransContext.
SessionRequests | This is SessionRequests, a member of class TnxRemoteTransContext.
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID | TnxRemoteTransContext
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atcAddToSession |
atcForceRollback |
atcRemoveFromSession |
atoSetTimeout |
CreateRequest |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
ProcessStreamedRequest |
QueryInterface | InxInterface
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractTransContext
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create |
CreateInstanceFor | remoting integration
Destroy |
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Failed | internal
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
PrepareDestroy |
TransactionCommit |
TransactionCorrupted |
TransactionGetLevel |
TransactionRollback |
TransactionStart | transaction management
TransactionStartWith |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
SessionNext | Returns the next TransContext in the list of contexts for *this* session.
SessionPrev | Returns the previous TransContext in the list of contexts for *this* session.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxRemoteTransContext Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRemoteTransContext.Create Constructor

TnxRemoteTransContext.Create Constructor
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxRemoteSession; aTimeout: TnxWord32; aOwnsID: Boolean; aTransContextID: TnxTransContextID);
Class

TnxRemoteTransContext Class

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Class


TnxRemoteTransContext.Destroy Destructor

TnxRemoteTransContext.Destroy Destructor
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRemoteTransContext Class

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Class


TnxRemoteTransContext Fields

TnxRemoteTransContext Fields
TnxRemoteTransContext Class Legend Protected Fields Send Feedback

The fields of the TnxRemoteTransContext class are listed here.

Class

TnxRemoteTransContext Class

Protected Fields
Name | Description
ProcessRequest | private
rtcOwnsID | This is rtcOwnsID, a member of class TnxRemoteTransContext.
rtcRemoteThreadPriority | This is rtcRemoteThreadPriority, a member of class TnxRemoteTransContext.
rtcServerVersion | This is rtcServerVersion, a member of class TnxRemoteTransContext.
rtcTransContextID | This is rtcTransContextID, a member of class TnxRemoteTransContext.
SessionRequests | This is SessionRequests, a member of class TnxRemoteTransContext.
Links
TnxRemoteTransContext Class, Legend, Protected Fields


TnxRemoteTransContext.ProcessRequest Field

TnxRemoteTransContext.ProcessRequest Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
ProcessRequest: TnxProcessRequest;
Description

private

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext.rtcOwnsID Field

TnxRemoteTransContext.rtcOwnsID Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
rtcOwnsID: Boolean;
Description

This is rtcOwnsID, a member of class TnxRemoteTransContext.

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext.rtcRemoteThreadPriority Field

TnxRemoteTransContext.rtcRemoteThreadPriority Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
rtcRemoteThreadPriority: TnxThreadPriority;
Description

This is rtcRemoteThreadPriority, a member of class TnxRemoteTransContext.

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext.rtcServerVersion Field

TnxRemoteTransContext.rtcServerVersion Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
rtcServerVersion: Integer;
Description

This is rtcServerVersion, a member of class TnxRemoteTransContext.

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext.rtcTransContextID Field

TnxRemoteTransContext.rtcTransContextID Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
rtcTransContextID: TnxTransContextID;
Description

This is rtcTransContextID, a member of class TnxRemoteTransContext.

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext.SessionRequests Field

TnxRemoteTransContext.SessionRequests Field
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Fields Send Feedback
Syntax
Delphi
SessionRequests: InxSessionRequests;
Description

This is SessionRequests, a member of class TnxRemoteTransContext.

Group

TnxRemoteTransContext Fields

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Fields


TnxRemoteTransContext Methods

TnxRemoteTransContext Methods
TnxRemoteTransContext Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemoteTransContext class are listed here.

Class

TnxRemoteTransContext Class

Protected Methods
Name | Description
asoGetRemoteID | TnxRemoteTransContext
asoGetRemoteThreadPriority |
asoSetRemoteThreadPriority |
atoSetTimeout |
CreateRequest |
ProcessStreamedRequest |
RequestNoData |
RequestNoDataNoReply |
Public Methods
Name | Description
CreateInstanceFor | remoting integration
OptionClear | options
OptionGet |
OptionGetEffective |
OptionList |
OptionListEffective |
OptionSet |
TransactionCommit |
TransactionCorrupted |
TransactionGetLevel |
TransactionRollback |
TransactionStart | transaction management
TransactionStartWith |
Links
TnxRemoteTransContext Class, Legend, Protected Methods, Public Methods


TnxRemoteTransContext.asoGetRemoteID Method

TnxRemoteTransContext.asoGetRemoteID Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; override;
Description

TnxRemoteTransContext

Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.asoGetRemoteThreadPriority Method

TnxRemoteTransContext.asoGetRemoteThreadPriority Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.asoSetRemoteThreadPriority Method

TnxRemoteTransContext.asoSetRemoteThreadPriority Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.atoSetTimeout Method

TnxRemoteTransContext.atoSetTimeout Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.CreateInstanceFor Method

TnxRemoteTransContext.CreateInstanceFor Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.CreateRequest Method

TnxRemoteTransContext.CreateRequest Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function CreateRequest: TnxRequestWriter;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionClear Method

TnxRemoteTransContext.OptionClear Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

options

Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionGet Method

TnxRemoteTransContext.OptionGet Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionGetEffective Method

TnxRemoteTransContext.OptionGetEffective Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionList Method

TnxRemoteTransContext.OptionList Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionListEffective Method

TnxRemoteTransContext.OptionListEffective Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.OptionSet Method

TnxRemoteTransContext.OptionSet Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.ProcessStreamedRequest Method

TnxRemoteTransContext.ProcessStreamedRequest Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function ProcessStreamedRequest(aMsgID: TnxMsgID; aRequestStream: TnxMemoryStream; aReplyStream: PStream): TnxResult;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.RequestNoData Method

TnxRemoteTransContext.RequestNoData Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function RequestNoData(aMsgID: TnxMsgID; var aResult: TnxResult): TnxReplyReader;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.RequestNoDataNoReply Method

TnxRemoteTransContext.RequestNoDataNoReply Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function RequestNoDataNoReply(aMsgID: TnxMsgID): TnxResult;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionCommit Method

TnxRemoteTransContext.TransactionCommit Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionCommit: TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionCorrupted Method

TnxRemoteTransContext.TransactionCorrupted Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionCorrupted: TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionGetLevel Method

TnxRemoteTransContext.TransactionGetLevel Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionGetLevel(out aTransLevel: Integer): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionRollback Method

TnxRemoteTransContext.TransactionRollback Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionRollback: TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionStart Method

TnxRemoteTransContext.TransactionStart Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionStart(aFailSafe: Boolean; aSnapShot: Boolean): TnxResult; override;
Description

transaction management

Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


TnxRemoteTransContext.TransactionStartWith Method

TnxRemoteTransContext.TransactionStartWith Method
TnxRemoteTransContext Class TnxRemoteTransContext Members nxreRemoteServerEngine Namespace TnxRemoteTransContext Methods Send Feedback
Syntax
Delphi
function TransactionStartWith(aFailSafe: Boolean; aSnapShot: Boolean; const aCursors: array of TnxAbstractCursor): TnxResult; override;
Group

TnxRemoteTransContext Methods

Links
TnxRemoteTransContext Class, TnxRemoteTransContext Members, nxreRemoteServerEngine Namespace, TnxRemoteTransContext Methods


Functions

Functions
Functions nxreRemoteServerEngine Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
TransportRequestCallback | TransportRequestCallback
TransportRequestCallbackStreamLeavePositionShortcut |
TransportRequestCallbackStreamShortcut |
Namespace

nxreRemoteServerEngine Namespace

Links
Functions, nxreRemoteServerEngine Namespace, Legend


nxreRemoteServerEngine.TransportRequestCallback Function

nxreRemoteServerEngine.TransportRequestCallback Function
nxreRemoteServerEngine Functions Send Feedback
Syntax
Delphi
procedure TransportRequestCallback(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReply: Pointer; aReplyLen: Integer; aReplyCookie: Pointer);
File

nxreRemoteServerEngine

Description

TransportRequestCallback

Group

Functions

Links
nxreRemoteServerEngine, Functions


nxreRemoteServerEngine.TransportRequestCallbackStreamLeavePositionShortcut Function

nxreRemoteServerEngine.TransportRequestCallbackStreamLeavePositionShortcut Function
nxreRemoteServerEngine Functions Send Feedback
Syntax
Delphi
procedure TransportRequestCallbackStreamLeavePositionShortcut(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReply: Pointer; aReplyLen: Integer; aReplyCookie: Pointer);
File

nxreRemoteServerEngine

Group

Functions

Links
nxreRemoteServerEngine, Functions


nxreRemoteServerEngine.TransportRequestCallbackStreamShortcut Function

nxreRemoteServerEngine.TransportRequestCallbackStreamShortcut Function
nxreRemoteServerEngine Functions Send Feedback
Syntax
Delphi
procedure TransportRequestCallbackStreamShortcut(aMsgID: TnxMsgID; aErrorCode: TnxResult; aReply: Pointer; aReplyLen: Integer; aReplyCookie: Pointer);
File

nxreRemoteServerEngine

Group

Functions

Links
nxreRemoteServerEngine, Functions


Structs, Records, Enums

Structs, Records, Enums
nxreRemoteServerEngine Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxreRemoteServerEngine Namespace

Records
Name | Description
TnxCallbackInfo | This is record nxreRemoteServerEngine.TnxCallbackInfo.
Links
nxreRemoteServerEngine Namespace, Legend, Records


nxreRemoteServerEngine.TnxCallbackInfo Record

nxreRemoteServerEngine.TnxCallbackInfo Record
nxreRemoteServerEngine Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxCallbackInfo = record
  ciSession: TnxRemoteSession;
  ciSource: TObject;
  ciMsgID: TnxMsgID;
  ciStream: TStream;
end;
File

nxreRemoteServerEngine

Description

This is record nxreRemoteServerEngine.TnxCallbackInfo.

Group

Structs, Records, Enums

Links
nxreRemoteServerEngine, Structs, Records, Enums


Types

Types
nxreRemoteServerEngine Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxreRemoteServerEngine Namespace

Types
Name | Description
PnxCallbackInfo | This is type nxreRemoteServerEngine.PnxCallbackInfo.
TnxProcessRequest | This is type nxreRemoteServerEngine.TnxProcessRequest.
TnxRemoteFilterEngineClass | This is type nxreRemoteServerEngine.TnxRemoteFilterEngineClass.
TnxRemoteKeyFilterEngineClass | This is type nxreRemoteServerEngine.TnxRemoteKeyFilterEngineClass.
Links
nxreRemoteServerEngine Namespace, Types


nxreRemoteServerEngine.PnxCallbackInfo Type

nxreRemoteServerEngine.PnxCallbackInfo Type
nxreRemoteServerEngine Types Send Feedback
Syntax
Delphi
PnxCallbackInfo = ^TnxCallbackInfo;
File

nxreRemoteServerEngine

Description

This is type nxreRemoteServerEngine.PnxCallbackInfo.

Group

Types

Links
nxreRemoteServerEngine, Types


nxreRemoteServerEngine.TnxProcessRequest Type

nxreRemoteServerEngine.TnxProcessRequest Type
nxreRemoteServerEngine Types Send Feedback
Syntax
Delphi
TnxProcessRequest = function (aSource : TObject; aRemoteThreadPriority : TnxThreadPriority; aMsgID : TnxMsgID; aTimeout : TnxWord32; aRequestData : Pointer; aRequestDataLen : TnxWord32; aReply : PPointer; aReplyLen : PnxWord32; aReplyType : TnxNetMsgDataType) : TnxResult of object;
File

nxreRemoteServerEngine

Description

This is type nxreRemoteServerEngine.TnxProcessRequest.

Group

Types

Links
nxreRemoteServerEngine, Types


nxreRemoteServerEngine.TnxRemoteFilterEngineClass Type

nxreRemoteServerEngine.TnxRemoteFilterEngineClass Type
nxreRemoteServerEngine Types Send Feedback
Syntax
Delphi
TnxRemoteFilterEngineClass = class of TnxRemoteFilterEngine;
File

nxreRemoteServerEngine

Description

This is type nxreRemoteServerEngine.TnxRemoteFilterEngineClass.

Group

Types

Links
nxreRemoteServerEngine, Types


nxreRemoteServerEngine.TnxRemoteKeyFilterEngineClass Type

nxreRemoteServerEngine.TnxRemoteKeyFilterEngineClass Type
nxreRemoteServerEngine Types Send Feedback
Syntax
Delphi
TnxRemoteKeyFilterEngineClass = class of TnxRemoteKeyFilterEngine;
File

nxreRemoteServerEngine

Description

This is type nxreRemoteServerEngine.TnxRemoteKeyFilterEngineClass.

Group

Types

Links
nxreRemoteServerEngine, Types


Constants

Constants
Constants nxreRemoteServerEngine Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsBlobModifiedNotSupported | This is constant nxreRemoteServerEngine.rsBlobModifiedNotSupported.
rsBookmarkAsVariantRequiresBookmarkHandler | This is constant nxreRemoteServerEngine.rsBookmarkAsVariantRequiresBookmarkHandler.
rsCreateDescriptorNotSupported | This is constant nxreRemoteServerEngine.rsCreateDescriptorNotSupported.
rsCreateLinkIsNotValid | This is constant nxreRemoteServerEngine.rsCreateLinkIsNotValid.
rsKeyFilterNotSupported | This is constant nxreRemoteServerEngine.rsKeyFilterNotSupported.
rsNotSupportedWithLocalFilter | This is constant nxreRemoteServerEngine.rsNotSupportedWithLocalFilter.
rsSetToFilterRequires | This is constant nxreRemoteServerEngine.rsSetToFilterRequires.
rsTransportRequired | This is constant nxreRemoteServerEngine.rsTransportRequired.
Namespace

nxreRemoteServerEngine Namespace

Links
Constants, nxreRemoteServerEngine Namespace


nxreRemoteServerEngine.rsBlobModifiedNotSupported Constant

nxreRemoteServerEngine.rsBlobModifiedNotSupported Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsBlobModifiedNotSupported = 'BlobModified is not supported by TnxRemoteCu' + 'rsor';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsBlobModifiedNotSupported.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsBookmarkAsVariantRequiresBookmarkHandler Constant

nxreRemoteServerEngine.rsBookmarkAsVariantRequiresBookmarkHandler Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsBookmarkAsVariantRequiresBookmarkHandler = 'BookmarkAsVariant requires a' + ' BookmarkHandler';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsBookmarkAsVariantRequiresBookmarkHandler.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsCreateDescriptorNotSupported Constant

nxreRemoteServerEngine.rsCreateDescriptorNotSupported Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsCreateDescriptorNotSupported = 'CreateDescriptor is not supported by %s';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsCreateDescriptorNotSupported.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsCreateLinkIsNotValid Constant

nxreRemoteServerEngine.rsCreateLinkIsNotValid Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsCreateLinkIsNotValid = 'nxbcmCreateLink is not a valid BlobCopyMode for ' + 'TnxRemoteCursor';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsCreateLinkIsNotValid.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsKeyFilterNotSupported Constant

nxreRemoteServerEngine.rsKeyFilterNotSupported Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsKeyFilterNotSupported = '%s was not supported as a KeyFilter by the serv' + 'er';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsKeyFilterNotSupported.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsNotSupportedWithLocalFilter Constant

nxreRemoteServerEngine.rsNotSupportedWithLocalFilter Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsNotSupportedWithLocalFilter = '%s is not supported by %s when a local filter is active';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsNotSupportedWithLocalFilter.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsSetToFilterRequires Constant

nxreRemoteServerEngine.rsSetToFilterRequires Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsSetToFilterRequires = '%s.%s requires aFilter and ' + 'does not support aKeyFilter';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsSetToFilterRequires.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxreRemoteServerEngine.rsTransportRequired Constant

nxreRemoteServerEngine.rsTransportRequired Constant
nxreRemoteServerEngine Constants Send Feedback
Syntax
Delphi
rsTransportRequired = 'Transport required';
File

nxreRemoteServerEngine

Description

This is constant nxreRemoteServerEngine.rsTransportRequired.

Group

Constants

Links
nxreRemoteServerEngine, Constants


nxrpBase Namespace

nxrpBase Namespace
Classes Legend Topics Send Feedback

This is namespace nxrpBase.

Classes
Name | Description
TnxRemotingBase | This is class nxrpBase.TnxRemotingBase.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrpBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRemotingBase | This is class nxrpBase.TnxRemotingBase.
Namespace

nxrpBase Namespace

Links
Classes, nxrpBase Namespace, Legend


TnxRemotingBase Class

TnxRemotingBase Class
TnxRemotingBase Fields TnxRemotingBase Methods TnxRemotingBase Members nxrpBase Classes Send Feedback
Class Hierarchy
nxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBasenxrpBase_TnxRemotingBase
Syntax
Delphi
TnxRemotingBase = class(TnxBasePluginEngine, InxClassActivator);
File

nxrpBase

Description

This is class nxrpBase.TnxRemotingBase.

Group

Classes

Links
TnxRemotingBase Fields, TnxRemotingBase Methods, TnxRemotingBase Members, nxrpBase, Classes


TnxRemotingBase Members

TnxRemotingBase Members
TnxRemotingBase Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemotingBase.

Class

TnxRemotingBase Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
rbClassActivatorIsolator | private
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxBasePluginEngine
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
QueryInterface | IInterface TnxRemotingBase
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
CreateInstance | InxClassActivator
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxRemotingBase Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxRemotingBase Fields

TnxRemotingBase Fields
TnxRemotingBase Class Legend Protected Fields Send Feedback

The fields of the TnxRemotingBase class are listed here.

Class

TnxRemotingBase Class

Protected Fields
Name | Description
rbClassActivatorIsolator | private
Links
TnxRemotingBase Class, Legend, Protected Fields


TnxRemotingBase.rbClassActivatorIsolator Field

TnxRemotingBase.rbClassActivatorIsolator Field
TnxRemotingBase Class TnxRemotingBase Members nxrpBase Namespace TnxRemotingBase Fields Send Feedback
Syntax
Delphi
rbClassActivatorIsolator: InxInterface;
Description

private

Group

TnxRemotingBase Fields

Links
TnxRemotingBase Class, TnxRemotingBase Members, nxrpBase Namespace, TnxRemotingBase Fields


TnxRemotingBase Methods

TnxRemotingBase Methods
TnxRemotingBase Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemotingBase class are listed here.

Class

TnxRemotingBase Class

Protected Methods
Name | Description
QueryInterface | IInterface TnxRemotingBase
Public Methods
Name | Description
CreateInstance | InxClassActivator
Links
TnxRemotingBase Class, Legend, Protected Methods, Public Methods


TnxRemotingBase.CreateInstance Method

TnxRemotingBase.CreateInstance Method
TnxRemotingBase Class TnxRemotingBase Members nxrpBase Namespace TnxRemotingBase Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual; abstract;
Description

InxClassActivator

Group

TnxRemotingBase Methods

Links
TnxRemotingBase Class, TnxRemotingBase Members, nxrpBase Namespace, TnxRemotingBase Methods


TnxRemotingBase.QueryInterface Method

TnxRemotingBase.QueryInterface Method
TnxRemotingBase Class TnxRemotingBase Members nxrpBase Namespace TnxRemotingBase Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; override; stdcall;
Description

IInterface

TnxRemotingBase

Group

TnxRemotingBase Methods

Links
TnxRemotingBase Class, TnxRemotingBase Members, nxrpBase Namespace, TnxRemotingBase Methods


nxrpChannel Namespace

nxrpChannel Namespace
Classes Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxrpChannel.

Classes
Name | Description
TnxChannelEntrance |
TnxChannelExit | This is class nxrpChannel.TnxChannelExit.
TnxInterfacedReplyReader | This is class nxrpChannel.TnxInterfacedReplyReader.
TnxInterfacedReplyWriter | This is class nxrpChannel.TnxInterfacedReplyWriter.
TnxInterfacedRequestReader |
TnxInterfacedRequestWriter | This is class nxrpChannel.TnxInterfacedRequestWriter.
Functions
Name | Description
nxCreateRequestReaderReplyWriter |
nxCreateRequestWriter |
nxCreateTransportChannelEntrance | nxCreateTransportChannelEntrance
nxCreateTransportChannelExit |
nxTransportChannelExitProcess |
nxTransportChannelExitProcess |
Interfaces
Name | Description
InxReplyWriter | This is class nxrpChannel.InxReplyWriter.
InxRequestReader | This is class nxrpChannel.InxRequestReader.
InxRequestWriter | This is class nxrpChannel.InxRequestWriter.
InxTransportChannelExit | This is class nxrpChannel.InxTransportChannelExit.
Structs, Records, Enums
Name | Description
TnxChannelID | This is record nxrpChannel.TnxChannelID.
TnxChannelOp | This is record nxrpChannel.TnxChannelOp.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
PnxChannelID | This is type nxrpChannel.PnxChannelID.
Variables
Name | Description
_ReleasePadlock | This is variable nxrpChannel._ReleasePadlock.
Links
Classes, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxrpChannel Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxChannelEntrance |
TnxChannelExit | This is class nxrpChannel.TnxChannelExit.
TnxInterfacedReplyReader | This is class nxrpChannel.TnxInterfacedReplyReader.
TnxInterfacedReplyWriter | This is class nxrpChannel.TnxInterfacedReplyWriter.
TnxInterfacedRequestReader |
TnxInterfacedRequestWriter | This is class nxrpChannel.TnxInterfacedRequestWriter.
Namespace

nxrpChannel Namespace

Links
Classes, nxrpChannel Namespace, Legend


TnxChannelEntrance Class

TnxChannelEntrance Class
TnxChannelEntrance Fields TnxChannelEntrance Methods TnxChannelEntrance Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxChannelEntrancenxrpChannel_TnxChannelEntrancenxrpChannel_TnxChannelEntrancenxrpChannel_TnxChannelEntrance
Syntax
Delphi
TnxChannelEntrance = class(TnxInterfacedObject, InxInterface, InxChannel, InxChannelEntrance, InxSessionNotifier);
File

nxrpChannel

Group

Classes

Links
TnxChannelEntrance Fields, TnxChannelEntrance Methods, TnxChannelEntrance Members, nxrpChannel, Classes


TnxChannelEntrance Members

TnxChannelEntrance Members
TnxChannelEntrance Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxChannelEntrance.

Class

TnxChannelEntrance Class

Protected Fields
Name | Description
chChannelID | This is chChannelID, a member of class TnxChannelEntrance.
chNotifierIsolator | This is chNotifierIsolator, a member of class TnxChannelEntrance.
chServerID | This is chServerID, a member of class TnxChannelEntrance.
chSessionNotifications | This is chSessionNotifications, a member of class TnxChannelEntrance.
chSessionRequests | private
Protected Methods
Name | Description
Disconnected | InxSessionNotifier
GetChannelID |
GetConnected |
GetServerID | InxChannel
GetWriter | InxChannelEntrance
Process |
Public Methods
Name | Description
BeforeDestruction | TnxChannelEntrance
Create |
Destroy |
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
TnxChannelEntrance Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxChannelEntrance.Create Constructor

TnxChannelEntrance.Create Constructor
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Class Send Feedback
Syntax
Delphi
constructor Create(const aSessionRequests: InxSessionRequests; const aServerID: TnxGuid; const aChannelID: TnxGuid);
Class

TnxChannelEntrance Class

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Class


TnxChannelEntrance.Destroy Destructor

TnxChannelEntrance.Destroy Destructor
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxChannelEntrance Class

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Class


TnxChannelEntrance Fields

TnxChannelEntrance Fields
TnxChannelEntrance Class Legend Protected Fields Send Feedback

The fields of the TnxChannelEntrance class are listed here.

Class

TnxChannelEntrance Class

Protected Fields
Name | Description
chChannelID | This is chChannelID, a member of class TnxChannelEntrance.
chNotifierIsolator | This is chNotifierIsolator, a member of class TnxChannelEntrance.
chServerID | This is chServerID, a member of class TnxChannelEntrance.
chSessionNotifications | This is chSessionNotifications, a member of class TnxChannelEntrance.
chSessionRequests | private
Links
TnxChannelEntrance Class, Legend, Protected Fields


TnxChannelEntrance.chChannelID Field

TnxChannelEntrance.chChannelID Field
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Fields Send Feedback
Syntax
Delphi
chChannelID: TnxGuid;
Description

This is chChannelID, a member of class TnxChannelEntrance.

Group

TnxChannelEntrance Fields

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Fields


TnxChannelEntrance.chNotifierIsolator Field

TnxChannelEntrance.chNotifierIsolator Field
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Fields Send Feedback
Syntax
Delphi
chNotifierIsolator: InxSessionNotifierIsolator;
Description

This is chNotifierIsolator, a member of class TnxChannelEntrance.

Group

TnxChannelEntrance Fields

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Fields


TnxChannelEntrance.chServerID Field

TnxChannelEntrance.chServerID Field
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Fields Send Feedback
Syntax
Delphi
chServerID: TnxGuid;
Description

This is chServerID, a member of class TnxChannelEntrance.

Group

TnxChannelEntrance Fields

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Fields


TnxChannelEntrance.chSessionNotifications Field

TnxChannelEntrance.chSessionNotifications Field
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Fields Send Feedback
Syntax
Delphi
chSessionNotifications: InxSessionNotifications;
Description

This is chSessionNotifications, a member of class TnxChannelEntrance.

Group

TnxChannelEntrance Fields

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Fields


TnxChannelEntrance.chSessionRequests Field

TnxChannelEntrance.chSessionRequests Field
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Fields Send Feedback
Syntax
Delphi
chSessionRequests: InxSessionRequests;
Description

private

Group

TnxChannelEntrance Fields

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Fields


TnxChannelEntrance Methods

TnxChannelEntrance Methods
TnxChannelEntrance Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxChannelEntrance class are listed here.

Class

TnxChannelEntrance Class

Protected Methods
Name | Description
Disconnected | InxSessionNotifier
GetChannelID |
GetConnected |
GetServerID | InxChannel
GetWriter | InxChannelEntrance
Process |
Public Methods
Name | Description
BeforeDestruction | TnxChannelEntrance
Links
TnxChannelEntrance Class, Legend, Protected Methods, Public Methods


TnxChannelEntrance.BeforeDestruction Method

TnxChannelEntrance.BeforeDestruction Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

TnxChannelEntrance

Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.Disconnected Method

TnxChannelEntrance.Disconnected Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

InxSessionNotifier

Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.GetChannelID Method

TnxChannelEntrance.GetChannelID Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
function GetChannelID: TnxGuid;
Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.GetConnected Method

TnxChannelEntrance.GetConnected Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
function GetConnected: Boolean;
Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.GetServerID Method

TnxChannelEntrance.GetServerID Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
function GetServerID: TnxGuid;
Description

InxChannel

Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.GetWriter Method

TnxChannelEntrance.GetWriter Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
function GetWriter(out aWriter: InxWriter): HRESULT;
Description

InxChannelEntrance

Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelEntrance.Process Method

TnxChannelEntrance.Process Method
TnxChannelEntrance Class TnxChannelEntrance Members nxrpChannel Namespace TnxChannelEntrance Methods Send Feedback
Syntax
Delphi
function Process(const aWriter: InxWriter; out aReader: InxReader): HRESULT;
Group

TnxChannelEntrance Methods

Links
TnxChannelEntrance Class, TnxChannelEntrance Members, nxrpChannel Namespace, TnxChannelEntrance Methods


TnxChannelExit Class

TnxChannelExit Class
TnxChannelExit Fields TnxChannelExit Methods TnxChannelExit Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxChannelExitnxrpChannel_TnxChannelExitnxrpChannel_TnxChannelExitnxrpChannel_TnxChannelExitnxrpChannel_TnxChannelExit
Syntax
Delphi
TnxChannelExit = class(TnxLowInterfacedObject, InxInterface, InxChannel, InxChannelExit, InxTransportChannelExit, InxSessionNotifier);
File

nxrpChannel

Description

This is class nxrpChannel.TnxChannelExit.

Group

Classes

Links
TnxChannelExit Fields, TnxChannelExit Methods, TnxChannelExit Members, nxrpChannel, Classes


TnxChannelExit Members

TnxChannelExit Members
TnxChannelExit Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxChannelExit.

Class

TnxChannelExit Class

Protected Fields
Name | Description
chChannelID | This is chChannelID, a member of class TnxChannelExit.
chChannelSink | This is chChannelSink, a member of class TnxChannelExit.
chChannelSinkId | This is chChannelSinkId, a member of class TnxChannelExit.
chKeepAlive | This is chKeepAlive, a member of class TnxChannelExit.
chNotifierIsolator | This is chNotifierIsolator, a member of class TnxChannelExit.
chServerID | private
chSessionNotifications | This is chSessionNotifications, a member of class TnxChannelExit.
chTickCount | This is chTickCount, a member of class TnxChannelExit.
Protected Methods
Name | Description
_Release |
BuildChannelID | TnxChannelExit
Disconnected | InxSessionNotifier
ForceDisconnect | InxChannelExit
GetChannelID |
GetConnected |
GetServerID | InxChannel
Process | InxTransportChannelExit
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxChannelExit
Create |
Destroy |
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
TnxChannelExit Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxChannelExit.Create Constructor

TnxChannelExit.Create Constructor
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Class Send Feedback
Syntax
Delphi
constructor Create(const aServerID: TnxGuid; const aSessionNotifications: InxSessionNotifications; const aChannelSink: InxChannelSink);
Class

TnxChannelExit Class

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Class


TnxChannelExit.Destroy Destructor

TnxChannelExit.Destroy Destructor
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxChannelExit Class

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Class


TnxChannelExit Fields

TnxChannelExit Fields
TnxChannelExit Class Legend Protected Fields Send Feedback

The fields of the TnxChannelExit class are listed here.

Class

TnxChannelExit Class

Protected Fields
Name | Description
chChannelID | This is chChannelID, a member of class TnxChannelExit.
chChannelSink | This is chChannelSink, a member of class TnxChannelExit.
chChannelSinkId | This is chChannelSinkId, a member of class TnxChannelExit.
chKeepAlive | This is chKeepAlive, a member of class TnxChannelExit.
chNotifierIsolator | This is chNotifierIsolator, a member of class TnxChannelExit.
chServerID | private
chSessionNotifications | This is chSessionNotifications, a member of class TnxChannelExit.
chTickCount | This is chTickCount, a member of class TnxChannelExit.
Links
TnxChannelExit Class, Legend, Protected Fields


TnxChannelExit.chChannelID Field

TnxChannelExit.chChannelID Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chChannelID: TnxGuid;
Description

This is chChannelID, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chChannelSink Field

TnxChannelExit.chChannelSink Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chChannelSink: InxChannelSink;
Description

This is chChannelSink, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chChannelSinkId Field

TnxChannelExit.chChannelSinkId Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chChannelSinkId: Cardinal;
Description

This is chChannelSinkId, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chKeepAlive Field

TnxChannelExit.chKeepAlive Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chKeepAlive: InxChannelExit;
Description

This is chKeepAlive, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chNotifierIsolator Field

TnxChannelExit.chNotifierIsolator Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chNotifierIsolator: InxSessionNotifierIsolator;
Description

This is chNotifierIsolator, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chServerID Field

TnxChannelExit.chServerID Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chServerID: TnxGuid;
Description

private

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chSessionNotifications Field

TnxChannelExit.chSessionNotifications Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chSessionNotifications: InxSessionNotifications;
Description

This is chSessionNotifications, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit.chTickCount Field

TnxChannelExit.chTickCount Field
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Fields Send Feedback
Syntax
Delphi
chTickCount: Cardinal;
Description

This is chTickCount, a member of class TnxChannelExit.

Group

TnxChannelExit Fields

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Fields


TnxChannelExit Methods

TnxChannelExit Methods
TnxChannelExit Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxChannelExit class are listed here.

Class

TnxChannelExit Class

Protected Methods
Name | Description
_Release |
BuildChannelID | TnxChannelExit
Disconnected | InxSessionNotifier
ForceDisconnect | InxChannelExit
GetChannelID |
GetConnected |
GetServerID | InxChannel
Process | InxTransportChannelExit
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxChannelExit
Links
TnxChannelExit Class, Legend, Protected Methods, Public Methods


TnxChannelExit._Release Method

TnxChannelExit._Release Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.BeforeDestruction Method

TnxChannelExit.BeforeDestruction Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

TnxChannelExit

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.BuildChannelID Method

TnxChannelExit.BuildChannelID Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function BuildChannelID: TnxGuid;
Description

TnxChannelExit

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.Disconnected Method

TnxChannelExit.Disconnected Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
procedure Disconnected;
Description

InxSessionNotifier

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.ForceDisconnect Method

TnxChannelExit.ForceDisconnect Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function ForceDisconnect: HRESULT;
Description

InxChannelExit

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.GetChannelID Method

TnxChannelExit.GetChannelID Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function GetChannelID: TnxGuid;
Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.GetConnected Method

TnxChannelExit.GetConnected Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function GetConnected: Boolean;
Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.GetServerID Method

TnxChannelExit.GetServerID Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function GetServerID: TnxGuid;
Description

InxChannel

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.Process Method

TnxChannelExit.Process Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function Process(const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

InxTransportChannelExit

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxChannelExit.QueryInterface Method

TnxChannelExit.QueryInterface Method
TnxChannelExit Class TnxChannelExit Members nxrpChannel Namespace TnxChannelExit Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxChannelExit Methods

Links
TnxChannelExit Class, TnxChannelExit Members, nxrpChannel Namespace, TnxChannelExit Methods


TnxInterfacedReplyReader Class

TnxInterfacedReplyReader Class
TnxInterfacedReplyReader Fields TnxInterfacedReplyReader Methods TnxInterfacedReplyReader Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxInterfacedReplyReadernxrpChannel_TnxInterfacedReplyReadernxrpChannel_TnxInterfacedReplyReader
Syntax
Delphi
TnxInterfacedReplyReader = class(TnxReader, InxInterface, InxReader, InxInterfaceReader);
File

nxrpChannel

Description

This is class nxrpChannel.TnxInterfacedReplyReader.

Group

Classes

Links
TnxInterfacedReplyReader Fields, TnxInterfacedReplyReader Methods, TnxInterfacedReplyReader Members, nxrpChannel, Classes


TnxInterfacedReplyReader Members

TnxInterfacedReplyReader Members
TnxInterfacedReplyReader Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInterfacedReplyReader.

Class

TnxInterfacedReplyReader Class

Protected Fields
Name | Description
irrRefCount | This is irrRefCount, a member of class TnxInterfacedReplyReader.
irrReleased | This is irrReleased, a member of class TnxInterfacedReplyReader.
irrServerID | private
irrSession | This is irrSession, a member of class TnxInterfacedReplyReader.
irrStream | This is irrStream, a member of class TnxInterfacedReplyReader.
Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
ReadInterface | InxInterfaceReader
Public Methods
Name | Description
AfterConstruction | TnxInterfacedReplyReader
BeforeDestruction |
Create |
Destroy |
EndOfList | peek ahead
FreeInstance |
NewInstance |
NextValue | This is NextValue, a member of class InxReader.
ReadAnsiChar | This is ReadAnsiChar, a member of class InxReader.
ReadBinary | This is ReadBinary, a member of class InxReader.
ReadBoolean | This is ReadBoolean, a member of class InxReader.
ReadChar | This is ReadChar, a member of class InxReader.
ReadCurrency | This is ReadCurrency, a member of class InxReader.
ReadDate | This is ReadDate, a member of class InxReader.
ReadDouble | This is ReadDouble, a member of class InxReader.
ReadFloat | This is ReadFloat, a member of class InxReader.
ReadGuid | This is ReadGuid, a member of class InxReader.
ReadIdent | This is ReadIdent, a member of class InxReader.
ReadInt64 | This is ReadInt64, a member of class InxReader.
ReadInteger | This is ReadInteger, a member of class InxReader.
ReadListBegin | This is ReadListBegin, a member of class InxReader.
ReadListEnd | This is ReadListEnd, a member of class InxReader.
ReadSingle | This is ReadSingle, a member of class InxReader.
ReadString | This is ReadString, a member of class InxReader.
ReadValue | This is ReadValue, a member of class InxReader.
ReadVariant | This is ReadVariant, a member of class InxReader.
ReadWideChar | This is ReadWideChar, a member of class InxReader.
ReadWideString_ | This is ReadWideString_, a member of class InxReader.
Links
TnxInterfacedReplyReader Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInterfacedReplyReader.Create Constructor

TnxInterfacedReplyReader.Create Constructor
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Class Send Feedback
Syntax
Delphi
constructor Create(aServerID: PnxGuid; const aSessionRequests: InxSessionRequests; var aStream: TStream);
Class

TnxInterfacedReplyReader Class

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Class


TnxInterfacedReplyReader.Destroy Destructor

TnxInterfacedReplyReader.Destroy Destructor
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfacedReplyReader Class

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Class


TnxInterfacedReplyReader Fields

TnxInterfacedReplyReader Fields
TnxInterfacedReplyReader Class Legend Protected Fields Send Feedback

The fields of the TnxInterfacedReplyReader class are listed here.

Class

TnxInterfacedReplyReader Class

Protected Fields
Name | Description
irrRefCount | This is irrRefCount, a member of class TnxInterfacedReplyReader.
irrReleased | This is irrReleased, a member of class TnxInterfacedReplyReader.
irrServerID | private
irrSession | This is irrSession, a member of class TnxInterfacedReplyReader.
irrStream | This is irrStream, a member of class TnxInterfacedReplyReader.
Links
TnxInterfacedReplyReader Class, Legend, Protected Fields


TnxInterfacedReplyReader.irrRefCount Field

TnxInterfacedReplyReader.irrRefCount Field
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Fields Send Feedback
Syntax
Delphi
irrRefCount: Integer;
Description

This is irrRefCount, a member of class TnxInterfacedReplyReader.

Group

TnxInterfacedReplyReader Fields

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Fields


TnxInterfacedReplyReader.irrReleased Field

TnxInterfacedReplyReader.irrReleased Field
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Fields Send Feedback
Syntax
Delphi
irrReleased: Integer;
Description

This is irrReleased, a member of class TnxInterfacedReplyReader.

Group

TnxInterfacedReplyReader Fields

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Fields


TnxInterfacedReplyReader.irrServerID Field

TnxInterfacedReplyReader.irrServerID Field
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Fields Send Feedback
Syntax
Delphi
irrServerID: PnxGuid;
Description

private

Group

TnxInterfacedReplyReader Fields

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Fields


TnxInterfacedReplyReader.irrSession Field

TnxInterfacedReplyReader.irrSession Field
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Fields Send Feedback
Syntax
Delphi
irrSession: InxSessionRequests;
Description

This is irrSession, a member of class TnxInterfacedReplyReader.

Group

TnxInterfacedReplyReader Fields

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Fields


TnxInterfacedReplyReader.irrStream Field

TnxInterfacedReplyReader.irrStream Field
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Fields Send Feedback
Syntax
Delphi
irrStream: TStream;
Description

This is irrStream, a member of class TnxInterfacedReplyReader.

Group

TnxInterfacedReplyReader Fields

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Fields


TnxInterfacedReplyReader Methods

TnxInterfacedReplyReader Methods
TnxInterfacedReplyReader Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInterfacedReplyReader class are listed here.

Class

TnxInterfacedReplyReader Class

Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
ReadInterface | InxInterfaceReader
Public Methods
Name | Description
AfterConstruction | TnxInterfacedReplyReader
BeforeDestruction |
FreeInstance |
NewInstance |
Links
TnxInterfacedReplyReader Class, Legend, Protected Methods, Public Methods


TnxInterfacedReplyReader._AddRef Method

TnxInterfacedReplyReader._AddRef Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader._Release Method

TnxInterfacedReplyReader._Release Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.AfterConstruction Method

TnxInterfacedReplyReader.AfterConstruction Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxInterfacedReplyReader

Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.BeforeDestruction Method

TnxInterfacedReplyReader.BeforeDestruction Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.FreeInstance Method

TnxInterfacedReplyReader.FreeInstance Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.NewInstance Method

TnxInterfacedReplyReader.NewInstance Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.QueryInterface Method

TnxInterfacedReplyReader.QueryInterface Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyReader.ReadInterface Method

TnxInterfacedReplyReader.ReadInterface Method
TnxInterfacedReplyReader Class TnxInterfacedReplyReader Members nxrpChannel Namespace TnxInterfacedReplyReader Methods Send Feedback
Syntax
Delphi
function ReadInterface(const aInterfaceID: TnxGuid; out aInterface: InxInterface): HRESULT;
Description

InxInterfaceReader

Group

TnxInterfacedReplyReader Methods

Links
TnxInterfacedReplyReader Class, TnxInterfacedReplyReader Members, nxrpChannel Namespace, TnxInterfacedReplyReader Methods


TnxInterfacedReplyWriter Class

TnxInterfacedReplyWriter Class
TnxInterfacedReplyWriter Fields TnxInterfacedReplyWriter Methods TnxInterfacedReplyWriter Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriternxrpChannel_TnxInterfacedReplyWriter
Syntax
Delphi
TnxInterfacedReplyWriter = class(TnxReplyWriter, InxInterface, InxWriter, InxReplyWriter, InxInterfaceWriter, InxInterfaceFilerInit);
File

nxrpChannel

Description

This is class nxrpChannel.TnxInterfacedReplyWriter.

Group

Classes

Links
TnxInterfacedReplyWriter Fields, TnxInterfacedReplyWriter Methods, TnxInterfacedReplyWriter Members, nxrpChannel, Classes


TnxInterfacedReplyWriter Members

TnxInterfacedReplyWriter Members
TnxInterfacedReplyWriter Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfacedReplyWriter.

Class

TnxInterfacedReplyWriter Class

Protected Fields
Name | Description
irwController | This is irwController, a member of class TnxInterfacedReplyWriter.
irwServerID | private
rwMsgID | private
rwStream | This is rwStream, a member of class TnxReplyWriter.
Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
SendReply | InxReplyWriter
SetServerID | InxInterfaceFilerInit
WriteBinary | This is WriteBinary, a member of class TWriter.
WriteInterface | InxInterfaceWriter
WriteValue | This is WriteValue, a member of class TWriter.
Public Fields
Name | Description
Error | This is Error, a member of class TnxReplyWriter.
Public Methods
Name | Description
Create | TnxInterfacedReplyWriter
Destroy | This is Destroy, a member of class TFiler.
Destroy | TWriter
Destroy |
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TWriter.
Send |
TheWriter |
Write | This is Write, a member of class TWriter.
WriteAnsiChar |
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteAnsiString |
WriteAnsiStrings |
WriteBinary |
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class TWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteBytes |
WriteChar | This is WriteChar, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class TWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class TWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class TWriter.
WriteDouble |
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class TWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid |
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class TWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class TWriter.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class TWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class TWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteStr | This is WriteStr, a member of class TWriter.
WriteString | This is WriteString, a member of class TWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteStrings |
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class TWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class TWriter.
WriteWideChar |
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString | This is WriteWideString, a member of class TWriter.
WriteWideString_ |
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
WriteWideStrings |
Public Properties
Name | Description
Position | This is Position, a member of class TWriter.
Links
TnxInterfacedReplyWriter Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxInterfacedReplyWriter.Create Constructor

TnxInterfacedReplyWriter.Create Constructor
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Class Send Feedback
Syntax
Delphi
constructor Create(aMsgID: TnxMsgID; const aController: InxInterface);
Description

TnxInterfacedReplyWriter

Class

TnxInterfacedReplyWriter Class

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Class


TnxInterfacedReplyWriter Fields

TnxInterfacedReplyWriter Fields
TnxInterfacedReplyWriter Class Legend Protected Fields Send Feedback

The fields of the TnxInterfacedReplyWriter class are listed here.

Class

TnxInterfacedReplyWriter Class

Protected Fields
Name | Description
irwController | This is irwController, a member of class TnxInterfacedReplyWriter.
irwServerID | private
Links
TnxInterfacedReplyWriter Class, Legend, Protected Fields


TnxInterfacedReplyWriter.irwController Field

TnxInterfacedReplyWriter.irwController Field
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Fields Send Feedback
Syntax
Delphi
irwController: Pointer;
Description

This is irwController, a member of class TnxInterfacedReplyWriter.

Group

TnxInterfacedReplyWriter Fields

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Fields


TnxInterfacedReplyWriter.irwServerID Field

TnxInterfacedReplyWriter.irwServerID Field
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Fields Send Feedback
Syntax
Delphi
irwServerID: PnxGuid;
Description

private

Group

TnxInterfacedReplyWriter Fields

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Fields


TnxInterfacedReplyWriter Methods

TnxInterfacedReplyWriter Methods
TnxInterfacedReplyWriter Class Legend Protected Methods Send Feedback

The methods of the TnxInterfacedReplyWriter class are listed here.

Class

TnxInterfacedReplyWriter Class

Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
SendReply | InxReplyWriter
SetServerID | InxInterfaceFilerInit
WriteInterface | InxInterfaceWriter
Links
TnxInterfacedReplyWriter Class, Legend, Protected Methods


TnxInterfacedReplyWriter._AddRef Method

TnxInterfacedReplyWriter._AddRef Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedReplyWriter._Release Method

TnxInterfacedReplyWriter._Release Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedReplyWriter.QueryInterface Method

TnxInterfacedReplyWriter.QueryInterface Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedReplyWriter.SendReply Method

TnxInterfacedReplyWriter.SendReply Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
procedure SendReply(aResult: HRESULT);
Description

InxReplyWriter

Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedReplyWriter.SetServerID Method

TnxInterfacedReplyWriter.SetServerID Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
procedure SetServerID(aServerID: PnxGuid);
Description

InxInterfaceFilerInit

Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedReplyWriter.WriteInterface Method

TnxInterfacedReplyWriter.WriteInterface Method
TnxInterfacedReplyWriter Class TnxInterfacedReplyWriter Members nxrpChannel Namespace TnxInterfacedReplyWriter Methods Send Feedback
Syntax
Delphi
function WriteInterface(const aInterfaceID: TnxGuid; const aInterface: InxInterface): HRESULT;
Description

InxInterfaceWriter

Group

TnxInterfacedReplyWriter Methods

Links
TnxInterfacedReplyWriter Class, TnxInterfacedReplyWriter Members, nxrpChannel Namespace, TnxInterfacedReplyWriter Methods


TnxInterfacedRequestReader Class

TnxInterfacedRequestReader Class
TnxInterfacedRequestReader Fields TnxInterfacedRequestReader Methods TnxInterfacedRequestReader Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReadernxrpChannel_TnxInterfacedRequestReader
Syntax
Delphi
TnxInterfacedRequestReader = class(TnxRequestReader, InxInterface, InxReader, InxRequestReader, InxInterfaceReader, InxInterfaceFilerInit);
File

nxrpChannel

Group

Classes

Links
TnxInterfacedRequestReader Fields, TnxInterfacedRequestReader Methods, TnxInterfacedRequestReader Members, nxrpChannel, Classes


TnxInterfacedRequestReader Members

TnxInterfacedRequestReader Members
TnxInterfacedRequestReader Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxInterfacedRequestReader.

Class

TnxInterfacedRequestReader Class

Protected Fields
Name | Description
dmrStream | private.
irrContext | private
irrRefCount | This is irrRefCount, a member of class TnxInterfacedRequestReader.
irrReleased | This is irrReleased, a member of class TnxInterfacedRequestReader.
irrServerID | This is irrServerID, a member of class TnxInterfacedRequestReader.
rrWriter | private
Protected Methods
Name | Description
_AddRef |
_Release |
CreateWriter |
GetReply | InxRequestReader
QueryInterface | InxInterface
ReadInterface | InxInterfaceReader
SetPosition | This is SetPosition, a member of class TReader.
SetServerID | InxInterfaceFilerInit
Public Methods
Name | Description
AfterConstruction | TnxInterfacedRequestReader
BeforeDestruction |
CheckValue | This is CheckValue, a member of class TReader.
Create |
Destroy | This is Destroy, a member of class TFiler.
Destroy | This is Destroy, a member of class TReader.
Destroy | destructor.
Destroy |
EndOfList | This is EndOfList, a member of class TReader.
EndOfList | peek ahead
FlushBuffer | This is FlushBuffer, a member of class TFiler.
FlushBuffer | This is FlushBuffer, a member of class TReader.
FreeInstance |
NewInstance |
NextValue | This is NextValue, a member of class TReader.
NextValue | This is NextValue, a member of class InxReader.
Read | This is Read, a member of class TReader.
ReadAnsiChar |
ReadAnsiChar | This is ReadAnsiChar, a member of class InxReader.
ReadBinary |
ReadBinary | This is ReadBinary, a member of class InxReader.
ReadBoolean | This is ReadBoolean, a member of class TReader.
ReadBoolean | This is ReadBoolean, a member of class InxReader.
ReadBytes |
ReadChar | This is ReadChar, a member of class TReader.
ReadChar | This is ReadChar, a member of class InxReader.
ReadCurrency | This is ReadCurrency, a member of class TReader.
ReadCurrency | This is ReadCurrency, a member of class InxReader.
ReadDate | This is ReadDate, a member of class TReader.
ReadDate | This is ReadDate, a member of class InxReader.
ReadDouble | This is ReadDouble, a member of class TReader.
ReadDouble |
ReadDouble | This is ReadDouble, a member of class InxReader.
ReadFloat | This is ReadFloat, a member of class TReader.
ReadFloat | This is ReadFloat, a member of class InxReader.
ReadGuid |
ReadGuid | This is ReadGuid, a member of class InxReader.
ReadIdent | This is ReadIdent, a member of class TReader.
ReadIdent | This is ReadIdent, a member of class InxReader.
ReadInt64 | This is ReadInt64, a member of class TReader.
ReadInt64 | This is ReadInt64, a member of class InxReader.
ReadInteger | This is ReadInteger, a member of class TReader.
ReadInteger | This is ReadInteger, a member of class InxReader.
ReadInternal | This is ReadInternal, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class TReader.
ReadListBegin | This is ReadListBegin, a member of class InxReader.
ReadListEnd | This is ReadListEnd, a member of class TReader.
ReadListEnd | This is ReadListEnd, a member of class InxReader.
ReadSingle | This is ReadSingle, a member of class TReader.
ReadSingle | This is ReadSingle, a member of class InxReader.
ReadStr | This is ReadStr, a member of class TReader.
ReadString | This is ReadString, a member of class TReader.
ReadString | This is ReadString, a member of class InxReader.
ReadStrings |
ReadValue | This is ReadValue, a member of class TReader.
ReadValue | This is ReadValue, a member of class InxReader.
ReadVariant | This is ReadVariant, a member of class TReader.
ReadVariant | This is ReadVariant, a member of class InxReader.
ReadWideChar | This is ReadWideChar, a member of class TReader.
ReadWideChar |
ReadWideChar | This is ReadWideChar, a member of class InxReader.
ReadWideString | This is ReadWideString, a member of class TReader.
ReadWideString_ |
ReadWideString_ | This is ReadWideString_, a member of class InxReader.
TheReader |
Public Properties
Name | Description
DataMessageStream | A stream for reading/writing message data.
Position | This is Position, a member of class TReader.
Reply | This is Reply, a member of class TnxRequestReader.
Reply | This is Reply, a member of class InxRequestReader.
Links
TnxInterfacedRequestReader Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxInterfacedRequestReader.Create Constructor

TnxInterfacedRequestReader.Create Constructor
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Class Send Feedback
Syntax
Delphi
constructor Create(const aDataMessage: TnxDataMessage);
Class

TnxInterfacedRequestReader Class

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Class


TnxInterfacedRequestReader Fields

TnxInterfacedRequestReader Fields
TnxInterfacedRequestReader Class Legend Protected Fields Send Feedback

The fields of the TnxInterfacedRequestReader class are listed here.

Class

TnxInterfacedRequestReader Class

Protected Fields
Name | Description
irrContext | private
irrRefCount | This is irrRefCount, a member of class TnxInterfacedRequestReader.
irrReleased | This is irrReleased, a member of class TnxInterfacedRequestReader.
irrServerID | This is irrServerID, a member of class TnxInterfacedRequestReader.
Links
TnxInterfacedRequestReader Class, Legend, Protected Fields


TnxInterfacedRequestReader.irrContext Field

TnxInterfacedRequestReader.irrContext Field
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Fields Send Feedback
Syntax
Delphi
irrContext: InxCallContext;
Description

private

Group

TnxInterfacedRequestReader Fields

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Fields


TnxInterfacedRequestReader.irrRefCount Field

TnxInterfacedRequestReader.irrRefCount Field
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Fields Send Feedback
Syntax
Delphi
irrRefCount: Integer;
Description

This is irrRefCount, a member of class TnxInterfacedRequestReader.

Group

TnxInterfacedRequestReader Fields

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Fields


TnxInterfacedRequestReader.irrReleased Field

TnxInterfacedRequestReader.irrReleased Field
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Fields Send Feedback
Syntax
Delphi
irrReleased: Integer;
Description

This is irrReleased, a member of class TnxInterfacedRequestReader.

Group

TnxInterfacedRequestReader Fields

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Fields


TnxInterfacedRequestReader.irrServerID Field

TnxInterfacedRequestReader.irrServerID Field
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Fields Send Feedback
Syntax
Delphi
irrServerID: PnxGuid;
Description

This is irrServerID, a member of class TnxInterfacedRequestReader.

Group

TnxInterfacedRequestReader Fields

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Fields


TnxInterfacedRequestReader Methods

TnxInterfacedRequestReader Methods
TnxInterfacedRequestReader Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInterfacedRequestReader class are listed here.

Class

TnxInterfacedRequestReader Class

Protected Methods
Name | Description
_AddRef |
_Release |
CreateWriter |
GetReply | InxRequestReader
QueryInterface | InxInterface
ReadInterface | InxInterfaceReader
SetServerID | InxInterfaceFilerInit
Public Methods
Name | Description
AfterConstruction | TnxInterfacedRequestReader
BeforeDestruction |
FreeInstance |
NewInstance |
Links
TnxInterfacedRequestReader Class, Legend, Protected Methods, Public Methods


TnxInterfacedRequestReader._AddRef Method

TnxInterfacedRequestReader._AddRef Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader._Release Method

TnxInterfacedRequestReader._Release Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.AfterConstruction Method

TnxInterfacedRequestReader.AfterConstruction Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxInterfacedRequestReader

Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.BeforeDestruction Method

TnxInterfacedRequestReader.BeforeDestruction Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.CreateWriter Method

TnxInterfacedRequestReader.CreateWriter Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function CreateWriter(const aDataMessage: TnxDataMessage): TnxReplyWriter; override;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.FreeInstance Method

TnxInterfacedRequestReader.FreeInstance Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.GetReply Method

TnxInterfacedRequestReader.GetReply Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function GetReply: InxReplyWriter;
Description

InxRequestReader

Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.NewInstance Method

TnxInterfacedRequestReader.NewInstance Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.QueryInterface Method

TnxInterfacedRequestReader.QueryInterface Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.ReadInterface Method

TnxInterfacedRequestReader.ReadInterface Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
function ReadInterface(const aInterfaceID: TnxGuid; out aInterface: InxInterface): HRESULT;
Description

InxInterfaceReader

Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestReader.SetServerID Method

TnxInterfacedRequestReader.SetServerID Method
TnxInterfacedRequestReader Class TnxInterfacedRequestReader Members nxrpChannel Namespace TnxInterfacedRequestReader Methods Send Feedback
Syntax
Delphi
procedure SetServerID(aServerID: PnxGuid);
Description

InxInterfaceFilerInit

Group

TnxInterfacedRequestReader Methods

Links
TnxInterfacedRequestReader Class, TnxInterfacedRequestReader Members, nxrpChannel Namespace, TnxInterfacedRequestReader Methods


TnxInterfacedRequestWriter Class

TnxInterfacedRequestWriter Class
TnxInterfacedRequestWriter Fields TnxInterfacedRequestWriter Methods TnxInterfacedRequestWriter Members nxrpChannel Classes Send Feedback
Class Hierarchy
nxrpChannel_TnxInterfacedRequestWriternxrpChannel_TnxInterfacedRequestWriternxrpChannel_TnxInterfacedRequestWriternxrpChannel_TnxInterfacedRequestWriter
Syntax
Delphi
TnxInterfacedRequestWriter = class(TnxWriter, InxInterface, InxWriter, InxRequestWriter, InxInterfaceWriter);
File

nxrpChannel

Description

This is class nxrpChannel.TnxInterfacedRequestWriter.

Group

Classes

Links
TnxInterfacedRequestWriter Fields, TnxInterfacedRequestWriter Methods, TnxInterfacedRequestWriter Members, nxrpChannel, Classes


TnxInterfacedRequestWriter Members

TnxInterfacedRequestWriter Members
TnxInterfacedRequestWriter Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInterfacedRequestWriter.

Class

TnxInterfacedRequestWriter Class

Protected Fields
Name | Description
irwContext | private
irwRefCount | This is irwRefCount, a member of class TnxInterfacedRequestWriter.
irwReleased | This is irwReleased, a member of class TnxInterfacedRequestWriter.
irwServerID | This is irwServerID, a member of class TnxInterfacedRequestWriter.
irwSession | This is irwSession, a member of class TnxInterfacedRequestWriter.
irwStream | This is irwStream, a member of class TnxInterfacedRequestWriter.
Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
Send | InxRequestWriter
WriteInterface | InxInterfaceWriter
Public Methods
Name | Description
AfterConstruction | TnxInterfacedRequestWriter
BeforeDestruction |
Create |
Destroy |
FreeInstance |
NewInstance |
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
Links
TnxInterfacedRequestWriter Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInterfacedRequestWriter.Create Constructor

TnxInterfacedRequestWriter.Create Constructor
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Class Send Feedback
Syntax
Delphi
constructor Create(aServerID: PnxGuid; const aSession: InxSessionRequests);
Class

TnxInterfacedRequestWriter Class

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Class


TnxInterfacedRequestWriter.Destroy Destructor

TnxInterfacedRequestWriter.Destroy Destructor
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxInterfacedRequestWriter Class

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Class


TnxInterfacedRequestWriter Fields

TnxInterfacedRequestWriter Fields
TnxInterfacedRequestWriter Class Legend Protected Fields Send Feedback

The fields of the TnxInterfacedRequestWriter class are listed here.

Class

TnxInterfacedRequestWriter Class

Protected Fields
Name | Description
irwContext | private
irwRefCount | This is irwRefCount, a member of class TnxInterfacedRequestWriter.
irwReleased | This is irwReleased, a member of class TnxInterfacedRequestWriter.
irwServerID | This is irwServerID, a member of class TnxInterfacedRequestWriter.
irwSession | This is irwSession, a member of class TnxInterfacedRequestWriter.
irwStream | This is irwStream, a member of class TnxInterfacedRequestWriter.
Links
TnxInterfacedRequestWriter Class, Legend, Protected Fields


TnxInterfacedRequestWriter.irwContext Field

TnxInterfacedRequestWriter.irwContext Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwContext: InxCallContext;
Description

private

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter.irwRefCount Field

TnxInterfacedRequestWriter.irwRefCount Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwRefCount: Integer;
Description

This is irwRefCount, a member of class TnxInterfacedRequestWriter.

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter.irwReleased Field

TnxInterfacedRequestWriter.irwReleased Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwReleased: Integer;
Description

This is irwReleased, a member of class TnxInterfacedRequestWriter.

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter.irwServerID Field

TnxInterfacedRequestWriter.irwServerID Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwServerID: PnxGuid;
Description

This is irwServerID, a member of class TnxInterfacedRequestWriter.

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter.irwSession Field

TnxInterfacedRequestWriter.irwSession Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwSession: InxSessionRequests;
Description

This is irwSession, a member of class TnxInterfacedRequestWriter.

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter.irwStream Field

TnxInterfacedRequestWriter.irwStream Field
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Fields Send Feedback
Syntax
Delphi
irwStream: TnxMemoryStream;
Description

This is irwStream, a member of class TnxInterfacedRequestWriter.

Group

TnxInterfacedRequestWriter Fields

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Fields


TnxInterfacedRequestWriter Methods

TnxInterfacedRequestWriter Methods
TnxInterfacedRequestWriter Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxInterfacedRequestWriter class are listed here.

Class

TnxInterfacedRequestWriter Class

Protected Methods
Name | Description
_AddRef |
_Release |
QueryInterface | InxInterface
Send | InxRequestWriter
WriteInterface | InxInterfaceWriter
Public Methods
Name | Description
AfterConstruction | TnxInterfacedRequestWriter
BeforeDestruction |
FreeInstance |
NewInstance |
Links
TnxInterfacedRequestWriter Class, Legend, Protected Methods, Public Methods


TnxInterfacedRequestWriter._AddRef Method

TnxInterfacedRequestWriter._AddRef Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
function _AddRef: Integer; stdcall;
Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter._Release Method

TnxInterfacedRequestWriter._Release Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
function _Release: Integer; stdcall;
Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.AfterConstruction Method

TnxInterfacedRequestWriter.AfterConstruction Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

TnxInterfacedRequestWriter

Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.BeforeDestruction Method

TnxInterfacedRequestWriter.BeforeDestruction Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.FreeInstance Method

TnxInterfacedRequestWriter.FreeInstance Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.NewInstance Method

TnxInterfacedRequestWriter.NewInstance Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.QueryInterface Method

TnxInterfacedRequestWriter.QueryInterface Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
function QueryInterface(constref const IID: TGUID; out Obj): HResult; stdcall;
Description

InxInterface

Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.Send Method

TnxInterfacedRequestWriter.Send Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
function Send(aMsgID: TnxMsgID; out aReader: InxReader): HRESULT;
Description

InxRequestWriter

Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


TnxInterfacedRequestWriter.WriteInterface Method

TnxInterfacedRequestWriter.WriteInterface Method
TnxInterfacedRequestWriter Class TnxInterfacedRequestWriter Members nxrpChannel Namespace TnxInterfacedRequestWriter Methods Send Feedback
Syntax
Delphi
function WriteInterface(const aInterfaceID: TnxGuid; const aInterface: InxInterface): HRESULT;
Description

InxInterfaceWriter

Group

TnxInterfacedRequestWriter Methods

Links
TnxInterfacedRequestWriter Class, TnxInterfacedRequestWriter Members, nxrpChannel Namespace, TnxInterfacedRequestWriter Methods


Interfaces

Interfaces
nxrpChannel Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxrpChannel Namespace

Interfaces
Name | Description
InxReplyWriter | This is class nxrpChannel.InxReplyWriter.
InxRequestReader | This is class nxrpChannel.InxRequestReader.
InxRequestWriter | This is class nxrpChannel.InxRequestWriter.
InxTransportChannelExit | This is class nxrpChannel.InxTransportChannelExit.
Links
nxrpChannel Namespace, Interfaces, Legend


InxReplyWriter Interface

InxReplyWriter Interface
InxReplyWriter Methods InxReplyWriter Members nxrpChannel Interfaces Send Feedback
Class Hierarchy
nxrpChannel_InxReplyWriternxrpChannel_InxReplyWriter
Syntax
Delphi
InxReplyWriter = interface(InxWriter);
File

nxrpChannel

Description

This is class nxrpChannel.InxReplyWriter.

Group

Interfaces

Links
InxReplyWriter Methods, InxReplyWriter Members, nxrpChannel, Interfaces


InxReplyWriter Members

InxReplyWriter Members
InxReplyWriter Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxReplyWriter.

Interface

InxReplyWriter Interface

Public Methods
Name | Description
SendReply | This is SendReply, a member of class InxReplyWriter.
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
Links
InxReplyWriter Interface, Legend, Public Methods


InxReplyWriter Methods

InxReplyWriter Methods
InxReplyWriter Interface Legend Public Methods Send Feedback

The methods of the InxReplyWriter class are listed here.

Interface

InxReplyWriter Interface

Public Methods
Name | Description
SendReply | This is SendReply, a member of class InxReplyWriter.
Links
InxReplyWriter Interface, Legend, Public Methods


InxReplyWriter.SendReply Method

InxReplyWriter.SendReply Method
InxReplyWriter Interface InxReplyWriter Members nxrpChannel Namespace InxReplyWriter Methods Send Feedback
Syntax
Delphi
procedure SendReply(aResult: HRESULT);
Description

This is SendReply, a member of class InxReplyWriter.

Group

InxReplyWriter Methods

Links
InxReplyWriter Interface, InxReplyWriter Members, nxrpChannel Namespace, InxReplyWriter Methods


InxRequestReader Interface

InxRequestReader Interface
InxRequestReader Methods InxRequestReader Properties InxRequestReader Members nxrpChannel Interfaces Send Feedback
Class Hierarchy
nxrpChannel_InxRequestReadernxrpChannel_InxRequestReader
Syntax
Delphi
InxRequestReader = interface(InxReader);
File

nxrpChannel

Description

This is class nxrpChannel.InxRequestReader.

Group

Interfaces

Links
InxRequestReader Methods, InxRequestReader Properties, InxRequestReader Members, nxrpChannel, Interfaces


InxRequestReader Members

InxRequestReader Members
InxRequestReader Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxRequestReader.

Interface

InxRequestReader Interface

Public Methods
Name | Description
EndOfList | peek ahead
GetReply | This is GetReply, a member of class InxRequestReader.
NextValue | This is NextValue, a member of class InxReader.
ReadAnsiChar | This is ReadAnsiChar, a member of class InxReader.
ReadBinary | This is ReadBinary, a member of class InxReader.
ReadBoolean | This is ReadBoolean, a member of class InxReader.
ReadChar | This is ReadChar, a member of class InxReader.
ReadCurrency | This is ReadCurrency, a member of class InxReader.
ReadDate | This is ReadDate, a member of class InxReader.
ReadDouble | This is ReadDouble, a member of class InxReader.
ReadFloat | This is ReadFloat, a member of class InxReader.
ReadGuid | This is ReadGuid, a member of class InxReader.
ReadIdent | This is ReadIdent, a member of class InxReader.
ReadInt64 | This is ReadInt64, a member of class InxReader.
ReadInteger | This is ReadInteger, a member of class InxReader.
ReadListBegin | This is ReadListBegin, a member of class InxReader.
ReadListEnd | This is ReadListEnd, a member of class InxReader.
ReadSingle | This is ReadSingle, a member of class InxReader.
ReadString | This is ReadString, a member of class InxReader.
ReadValue | This is ReadValue, a member of class InxReader.
ReadVariant | This is ReadVariant, a member of class InxReader.
ReadWideChar | This is ReadWideChar, a member of class InxReader.
ReadWideString_ | This is ReadWideString_, a member of class InxReader.
Public Properties
Name | Description
Reply | This is Reply, a member of class InxRequestReader.
Links
InxRequestReader Interface, Legend, Public Methods, Public Properties


InxRequestReader Methods

InxRequestReader Methods
InxRequestReader Interface Legend Public Methods Send Feedback

The methods of the InxRequestReader class are listed here.

Interface

InxRequestReader Interface

Public Methods
Name | Description
GetReply | This is GetReply, a member of class InxRequestReader.
Links
InxRequestReader Interface, Legend, Public Methods


InxRequestReader.GetReply Method

InxRequestReader.GetReply Method
InxRequestReader Interface InxRequestReader Members nxrpChannel Namespace InxRequestReader Methods Send Feedback
Syntax
Delphi
function GetReply: InxReplyWriter;
Description

This is GetReply, a member of class InxRequestReader.

Group

InxRequestReader Methods

Links
InxRequestReader Interface, InxRequestReader Members, nxrpChannel Namespace, InxRequestReader Methods


InxRequestReader Properties

InxRequestReader Properties
InxRequestReader Interface Legend Public Properties Send Feedback

The properties of the InxRequestReader class are listed here.

Interface

InxRequestReader Interface

Public Properties
Name | Description
Reply | This is Reply, a member of class InxRequestReader.
Links
InxRequestReader Interface, Legend, Public Properties


InxRequestReader.Reply Property

InxRequestReader.Reply Property
InxRequestReader Interface InxRequestReader Members nxrpChannel Namespace InxRequestReader Properties Send Feedback
Syntax
Delphi
property Reply: InxReplyWriter;
Description

This is Reply, a member of class InxRequestReader.

Group

InxRequestReader Properties

Links
InxRequestReader Interface, InxRequestReader Members, nxrpChannel Namespace, InxRequestReader Properties


InxRequestWriter Interface

InxRequestWriter Interface
InxRequestWriter Methods InxRequestWriter Members nxrpChannel Interfaces Send Feedback
Class Hierarchy
nxrpChannel_InxRequestWriternxrpChannel_InxRequestWriter
Syntax
Delphi
InxRequestWriter = interface(InxWriter);
File

nxrpChannel

Description

This is class nxrpChannel.InxRequestWriter.

Group

Interfaces

Links
InxRequestWriter Methods, InxRequestWriter Members, nxrpChannel, Interfaces


InxRequestWriter Members

InxRequestWriter Members
InxRequestWriter Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxRequestWriter.

Interface

InxRequestWriter Interface

Public Methods
Name | Description
Send | This is Send, a member of class InxRequestWriter.
WriteAnsiChar | This is WriteAnsiChar, a member of class InxWriter.
WriteBinary | This is WriteBinary, a member of class InxWriter.
WriteBoolean | This is WriteBoolean, a member of class InxWriter.
WriteCurrency | This is WriteCurrency, a member of class InxWriter.
WriteDate | This is WriteDate, a member of class InxWriter.
WriteDouble | This is WriteDouble, a member of class InxWriter.
WriteFloat | This is WriteFloat, a member of class InxWriter.
WriteGuid | This is WriteGuid, a member of class InxWriter.
WriteIdent | This is WriteIdent, a member of class InxWriter.
WriteInteger | This is the overview for the WriteInteger method overload.
WriteListBegin | This is WriteListBegin, a member of class InxWriter.
WriteListEnd | This is WriteListEnd, a member of class InxWriter.
WriteSingle | This is WriteSingle, a member of class InxWriter.
WriteString | This is WriteString, a member of class InxWriter.
WriteValue | This is WriteValue, a member of class InxWriter.
WriteVariant | This is WriteVariant, a member of class InxWriter.
WriteWideChar | This is WriteWideChar, a member of class InxWriter.
WriteWideString_ | This is WriteWideString_, a member of class InxWriter.
Links
InxRequestWriter Interface, Legend, Public Methods


InxRequestWriter Methods

InxRequestWriter Methods
InxRequestWriter Interface Legend Public Methods Send Feedback

The methods of the InxRequestWriter class are listed here.

Interface

InxRequestWriter Interface

Public Methods
Name | Description
Send | This is Send, a member of class InxRequestWriter.
Links
InxRequestWriter Interface, Legend, Public Methods


InxRequestWriter.Send Method

InxRequestWriter.Send Method
InxRequestWriter Interface InxRequestWriter Members nxrpChannel Namespace InxRequestWriter Methods Send Feedback
Syntax
Delphi
function Send(aMsgID: TnxMsgID; out aReader: InxReader): HRESULT;
Description

This is Send, a member of class InxRequestWriter.

Group

InxRequestWriter Methods

Links
InxRequestWriter Interface, InxRequestWriter Members, nxrpChannel Namespace, InxRequestWriter Methods


InxTransportChannelExit Interface

InxTransportChannelExit Interface
InxTransportChannelExit Methods InxTransportChannelExit Members nxrpChannel Interfaces Send Feedback
Class Hierarchy
nxrpChannel_InxTransportChannelExitnxrpChannel_InxTransportChannelExitnxrpChannel_InxTransportChannelExit
Syntax
Delphi
InxTransportChannelExit = interface(InxChannelExit);
File

nxrpChannel

Description

This is class nxrpChannel.InxTransportChannelExit.

Group

Interfaces

Links
InxTransportChannelExit Methods, InxTransportChannelExit Members, nxrpChannel, Interfaces


InxTransportChannelExit Members

InxTransportChannelExit Members
InxTransportChannelExit Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxTransportChannelExit.

Interface

InxTransportChannelExit Interface

Public Methods
Name | Description
ForceDisconnect | This is ForceDisconnect, a member of class InxChannelExit.
GetChannelID | This is GetChannelID, a member of class InxChannel.
GetConnected | This is GetConnected, a member of class InxChannel.
GetServerID | This is GetServerID, a member of class InxChannel.
Process | This is Process, a member of class InxTransportChannelExit.
Public Properties
Name | Description
ChannelID | This is ChannelID, a member of class InxChannel.
Connected | This is Connected, a member of class InxChannel.
ServerID | This is ServerID, a member of class InxChannel.
Links
InxTransportChannelExit Interface, Legend, Public Methods, Public Properties


InxTransportChannelExit Methods

InxTransportChannelExit Methods
InxTransportChannelExit Interface Legend Public Methods Send Feedback

The methods of the InxTransportChannelExit class are listed here.

Interface

InxTransportChannelExit Interface

Public Methods
Name | Description
Process | This is Process, a member of class InxTransportChannelExit.
Links
InxTransportChannelExit Interface, Legend, Public Methods


InxTransportChannelExit.Process Method

InxTransportChannelExit.Process Method
InxTransportChannelExit Interface InxTransportChannelExit Members nxrpChannel Namespace InxTransportChannelExit Methods Send Feedback
Syntax
Delphi
function Process(const aRequest: InxReader; const aReply: InxWriter): HRESULT;
Description

This is Process, a member of class InxTransportChannelExit.

Group

InxTransportChannelExit Methods

Links
InxTransportChannelExit Interface, InxTransportChannelExit Members, nxrpChannel Namespace, InxTransportChannelExit Methods


Functions

Functions
Functions nxrpChannel Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxCreateRequestReaderReplyWriter |
nxCreateRequestWriter |
nxCreateTransportChannelEntrance | nxCreateTransportChannelEntrance
nxCreateTransportChannelExit |
nxTransportChannelExitProcess |
nxTransportChannelExitProcess |
Namespace

nxrpChannel Namespace

Links
Functions, nxrpChannel Namespace, Legend


nxrpChannel.nxCreateRequestReaderReplyWriter Function

nxrpChannel.nxCreateRequestReaderReplyWriter Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
function nxCreateRequestReaderReplyWriter(const aMsg: TnxDataMessage; out aRequest: InxReader; out aReply: InxReplyWriter): HRESULT;
File

nxrpChannel

Group

Functions

Links
nxrpChannel, Functions


nxrpChannel.nxCreateRequestWriter Function

nxrpChannel.nxCreateRequestWriter Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
function nxCreateRequestWriter(const aSession: InxSessionRequests; out aRequest: InxRequestWriter): HRESULT;
File

nxrpChannel

Group

Functions

Links
nxrpChannel, Functions


nxrpChannel.nxCreateTransportChannelEntrance Function

nxrpChannel.nxCreateTransportChannelEntrance Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
function nxCreateTransportChannelEntrance(const aSessionRequests: InxSessionRequests; const aServerID: TnxGuid; const aChannelID: TnxGuid; out aChannel: InxChannelEntrance): HRESULT;
File

nxrpChannel

Description

nxCreateTransportChannelEntrance

Group

Functions

Links
nxrpChannel, Functions


nxrpChannel.nxCreateTransportChannelExit Function

nxrpChannel.nxCreateTransportChannelExit Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
function nxCreateTransportChannelExit(const aServerID: TnxGuid; const aSessionNotifications: InxSessionNotifications; const aChannelSink: InxChannelSink; out aChannel: InxChannelExit): HRESULT;
File

nxrpChannel

Group

Functions

Links
nxrpChannel, Functions


nxrpChannel.nxTransportChannelExitProcess Function

nxrpChannel.nxTransportChannelExitProcess Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
function nxTransportChannelExitProcess(const aRequest: InxReader; const aReply: InxWriter): HRESULT; overload;
File

nxrpChannel

Group

Functions

Links
nxrpChannel, Functions


nxrpChannel.nxTransportChannelExitProcess Function

nxrpChannel.nxTransportChannelExitProcess Function
nxrpChannel Functions Send Feedback
Syntax
Delphi
procedure nxTransportChannelExitProcess(const aMsg: TnxDataMessage); overload;
File

nxrpChannel

Group

Functions

Links
nxrpChannel, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxrpChannel Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxChannelOp | This is record nxrpChannel.TnxChannelOp.
Namespace

nxrpChannel Namespace

Records
Name | Description
TnxChannelID | This is record nxrpChannel.TnxChannelID.
Links
Enumerations, nxrpChannel Namespace, Legend, Records


nxrpChannel.TnxChannelID Record

nxrpChannel.TnxChannelID Record
nxrpChannel Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxChannelID = packed record
  ciChannelExit: Cardinal;
  ciChannelSink: Cardinal;
  ciTickCount: Cardinal;
  ciCheckSum: Cardinal;
end;
File

nxrpChannel

Description

This is record nxrpChannel.TnxChannelID.

Group

Structs, Records, Enums

Links
nxrpChannel, Structs, Records, Enums


nxrpChannel.TnxChannelOp Enumeration

nxrpChannel.TnxChannelOp Enumeration
nxrpChannel Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxChannelOp = ( coRelease, coCallChannelSink );
File

nxrpChannel

Description

This is record nxrpChannel.TnxChannelOp.

Group

Structs, Records, Enums

Links
nxrpChannel, Structs, Records, Enums


Types

Types
nxrpChannel Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxrpChannel Namespace

Types
Name | Description
PnxChannelID | This is type nxrpChannel.PnxChannelID.
Links
nxrpChannel Namespace, Types


nxrpChannel.PnxChannelID Type

nxrpChannel.PnxChannelID Type
nxrpChannel Types Send Feedback
Syntax
Delphi
PnxChannelID = ^TnxChannelID;
File

nxrpChannel

Description

This is type nxrpChannel.PnxChannelID.

Group

Types

Links
nxrpChannel, Types


Variables

Variables
nxrpChannel Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxrpChannel Namespace

Variables
Name | Description
_ReleasePadlock | This is variable nxrpChannel._ReleasePadlock.
Links
nxrpChannel Namespace, Variables


nxrpChannel._ReleasePadlock Variable

nxrpChannel._ReleasePadlock Variable
nxrpChannel Variables Send Feedback
Syntax
Delphi
_ReleasePadlock: TnxPadlock;
File

nxrpChannel

Description

This is variable nxrpChannel._ReleasePadlock.

Group

Variables

Links
nxrpChannel, Variables


nxrpClient Namespace

nxrpClient Namespace
Classes Legend Topics Send Feedback

This is namespace nxrpClient.

Classes
Name | Description
TnxRemotingClient | This is class nxrpClient.TnxRemotingClient.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrpClient Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRemotingClient | This is class nxrpClient.TnxRemotingClient.
Namespace

nxrpClient Namespace

Links
Classes, nxrpClient Namespace, Legend


TnxRemotingClient Class

TnxRemotingClient Class
TnxRemotingClient Methods TnxRemotingClient Properties TnxRemotingClient Members nxrpClient Classes Send Feedback
Class Hierarchy
nxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClientnxrpClient_TnxRemotingClient
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemotingClient = class(TnxRemotingBase);
File

nxrpClient

Description

This is class nxrpClient.TnxRemotingClient.

Group

Classes

Links
TnxRemotingClient Methods, TnxRemotingClient Properties, TnxRemotingClient Members, nxrpClient, Classes


TnxRemotingClient Members

TnxRemotingClient Members
TnxRemotingClient Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemotingClient.

Class

TnxRemotingClient Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
rbClassActivatorIsolator | private
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxRemotingClient
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
QueryInterface | IInterface TnxRemotingBase
rcCreateChannel |
rcGetSessionRequests |
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
CreateInstance |
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Session | This is Session, a member of class TnxRemotingClient.
Timeout | This is Timeout, a member of class TnxRemotingClient.
Version | Version of the component.
Links
TnxRemotingClient Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemotingClient Methods

TnxRemotingClient Methods
TnxRemotingClient Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemotingClient class are listed here.

Class

TnxRemotingClient Class

Protected Methods
Name | Description
bpeIsRemote | TnxRemotingClient
rcCreateChannel |
rcGetSessionRequests |
Public Methods
Name | Description
CreateInstance |
Links
TnxRemotingClient Class, Legend, Protected Methods, Public Methods


TnxRemotingClient.bpeIsRemote Method

TnxRemotingClient.bpeIsRemote Method
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Methods Send Feedback
Syntax
Delphi
class function bpeIsRemote: Boolean; override;
Description

TnxRemotingClient

Group

TnxRemotingClient Methods

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Methods


TnxRemotingClient.CreateInstance Method

TnxRemotingClient.CreateInstance Method
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Group

TnxRemotingClient Methods

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Methods


TnxRemotingClient.rcCreateChannel Method

TnxRemotingClient.rcCreateChannel Method
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Methods Send Feedback
Syntax
Delphi
function rcCreateChannel(const aServerID: TnxGuid; const aChannelID: TnxGuid; out aChannel: InxChannelEntrance): HRESULT; virtual;
Group

TnxRemotingClient Methods

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Methods


TnxRemotingClient.rcGetSessionRequests Method

TnxRemotingClient.rcGetSessionRequests Method
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Methods Send Feedback
Syntax
Delphi
function rcGetSessionRequests: InxSessionRequests; virtual;
Group

TnxRemotingClient Methods

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Methods


TnxRemotingClient Properties

TnxRemotingClient Properties
TnxRemotingClient Class Legend Published Properties Send Feedback

The properties of the TnxRemotingClient class are listed here.

Class

TnxRemotingClient Class

Published Properties
Name | Description
Session | This is Session, a member of class TnxRemotingClient.
Timeout | This is Timeout, a member of class TnxRemotingClient.
Links
TnxRemotingClient Class, Legend, Published Properties


TnxRemotingClient.Session Property

TnxRemotingClient.Session Property
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Properties Send Feedback
Syntax
Delphi
property Session: TnxStateComponent;
Description

This is Session, a member of class TnxRemotingClient.

Group

TnxRemotingClient Properties

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Properties


TnxRemotingClient.Timeout Property

TnxRemotingClient.Timeout Property
TnxRemotingClient Class TnxRemotingClient Members nxrpClient Namespace TnxRemotingClient Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

This is Timeout, a member of class TnxRemotingClient.

Group

TnxRemotingClient Properties

Links
TnxRemotingClient Class, TnxRemotingClient Members, nxrpClient Namespace, TnxRemotingClient Properties


nxrpCommandHandler Namespace

nxrpCommandHandler Namespace
Classes Legend Topics Send Feedback

This is namespace nxrpCommandHandler.

Classes
Name | Description
TnxRemotingCommandHandler | This is class nxrpCommandHandler.TnxRemotingCommandHandler.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrpCommandHandler Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRemotingCommandHandler | This is class nxrpCommandHandler.TnxRemotingCommandHandler.
Namespace

nxrpCommandHandler Namespace

Links
Classes, nxrpCommandHandler Namespace, Legend


TnxRemotingCommandHandler Class

TnxRemotingCommandHandler Class
TnxRemotingCommandHandler Methods TnxRemotingCommandHandler Properties TnxRemotingCommandHandler Members nxrpCommandHandler Classes Send Feedback
Class Hierarchy
nxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandlernxrpCommandHandler_TnxRemotingCommandHandler
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemotingCommandHandler = class(TnxBasePluginCommandHandler);
File

nxrpCommandHandler

Description

This is class nxrpCommandHandler.TnxRemotingCommandHandler.

Group

Classes

Links
TnxRemotingCommandHandler Methods, TnxRemotingCommandHandler Properties, TnxRemotingCommandHandler Members, nxrpCommandHandler, Classes


TnxRemotingCommandHandler Members

TnxRemotingCommandHandler Members
TnxRemotingCommandHandler Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemotingCommandHandler.

Class

TnxRemotingCommandHandler Class

Protected Fields
Name | Description
bpchCmdHandler | private.
bpchPluginEngine | This is bpchPluginEngine, a member of class TnxBasePluginCommandHandler.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpchAddSession | TnxBasePluginCommandHandler
bpchRemoveSession |
bpchSessionFailed |
bpchSetCmdHandler |
bpchSetPluginEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nmRemotingCreateInstance |
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
bpchProcess | TnxRemotingCommandHandler
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UISettingsVisible | This function always returns false, cause the settings should never be visible in the GUI.
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
CommandHandler | This is the main command handler the plugin command handler is attached to.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
PluginEngine | This is PluginEngine, a member of class TnxRemotingCommandHandler.
Version | Version of the component.
Links
TnxRemotingCommandHandler Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxRemotingCommandHandler Methods

TnxRemotingCommandHandler Methods
TnxRemotingCommandHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRemotingCommandHandler class are listed here.

Class

TnxRemotingCommandHandler Class

Protected Methods
Name | Description
nmRemotingCreateInstance |
Public Methods
Name | Description
bpchProcess | TnxRemotingCommandHandler
Links
TnxRemotingCommandHandler Class, Legend, Protected Methods, Public Methods


TnxRemotingCommandHandler.bpchProcess Method

TnxRemotingCommandHandler.bpchProcess Method
TnxRemotingCommandHandler Class TnxRemotingCommandHandler Members nxrpCommandHandler Namespace TnxRemotingCommandHandler Methods Send Feedback
Syntax
Delphi
procedure bpchProcess(aMsg: PnxDataMessage; var aHandled: Boolean); override;
Description

TnxRemotingCommandHandler

Group

TnxRemotingCommandHandler Methods

Links
TnxRemotingCommandHandler Class, TnxRemotingCommandHandler Members, nxrpCommandHandler Namespace, TnxRemotingCommandHandler Methods


TnxRemotingCommandHandler.nmRemotingCreateInstance Method

TnxRemotingCommandHandler.nmRemotingCreateInstance Method
TnxRemotingCommandHandler Class TnxRemotingCommandHandler Members nxrpCommandHandler Namespace TnxRemotingCommandHandler Methods Send Feedback
Syntax
Delphi
procedure nmRemotingCreateInstance(var Msg: TnxDataMessage);
Group

TnxRemotingCommandHandler Methods

Links
TnxRemotingCommandHandler Class, TnxRemotingCommandHandler Members, nxrpCommandHandler Namespace, TnxRemotingCommandHandler Methods


TnxRemotingCommandHandler Properties

TnxRemotingCommandHandler Properties
TnxRemotingCommandHandler Class Legend Published Properties Send Feedback

The properties of the TnxRemotingCommandHandler class are listed here.

Class

TnxRemotingCommandHandler Class

Published Properties
Name | Description
PluginEngine | This is PluginEngine, a member of class TnxRemotingCommandHandler.
Links
TnxRemotingCommandHandler Class, Legend, Published Properties


TnxRemotingCommandHandler.PluginEngine Property

TnxRemotingCommandHandler.PluginEngine Property
TnxRemotingCommandHandler Class TnxRemotingCommandHandler Members nxrpCommandHandler Namespace TnxRemotingCommandHandler Properties Send Feedback
Syntax
Delphi
property PluginEngine: TnxRemotingBase;
Description

This is PluginEngine, a member of class TnxRemotingCommandHandler.

Group

TnxRemotingCommandHandler Properties

Links
TnxRemotingCommandHandler Class, TnxRemotingCommandHandler Members, nxrpCommandHandler Namespace, TnxRemotingCommandHandler Properties


nxrpMessages Namespace

nxrpMessages Namespace
Constants Topics Send Feedback

This is namespace nxrpMessages.

Constants
Name | Description
nxnmRemotingBase | This is constant nxrpMessages.nxnmRemotingBase.
nxnmRemotingChannelRequest | value has been duplicated in nxllTransport!
nxnmRemotingCreateInstance | This is constant nxrpMessages.nxnmRemotingCreateInstance.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxrpMessages Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxnmRemotingBase | This is constant nxrpMessages.nxnmRemotingBase.
nxnmRemotingChannelRequest | value has been duplicated in nxllTransport!
nxnmRemotingCreateInstance | This is constant nxrpMessages.nxnmRemotingCreateInstance.
Namespace

nxrpMessages Namespace

Links
Constants, nxrpMessages Namespace


nxrpMessages.nxnmRemotingBase Constant

nxrpMessages.nxnmRemotingBase Constant
nxrpMessages Constants Send Feedback
Syntax
Delphi
nxnmRemotingBase = $1200;
File

nxrpMessages

Description

This is constant nxrpMessages.nxnmRemotingBase.

Group

Constants

Links
nxrpMessages, Constants


nxrpMessages.nxnmRemotingChannelRequest Constant

nxrpMessages.nxnmRemotingChannelRequest Constant
nxrpMessages Constants Send Feedback
Syntax
Delphi
nxnmRemotingChannelRequest = nxnmRemotingBase + 1;
File

nxrpMessages

Description

value has been duplicated in nxllTransport!

Group

Constants

Links
nxrpMessages, Constants


nxrpMessages.nxnmRemotingCreateInstance Constant

nxrpMessages.nxnmRemotingCreateInstance Constant
nxrpMessages Constants Send Feedback
Syntax
Delphi
nxnmRemotingCreateInstance = nxnmRemotingBase + 0;
File

nxrpMessages

Description

This is constant nxrpMessages.nxnmRemotingCreateInstance.

Group

Constants

Links
nxrpMessages, Constants


nxrpServer Namespace

nxrpServer Namespace
Classes Legend Topics Send Feedback

This is namespace nxrpServer.

Classes
Name | Description
TnxRemotingServer | This is class nxrpServer.TnxRemotingServer.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxrpServer Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxRemotingServer | This is class nxrpServer.TnxRemotingServer.
Namespace

nxrpServer Namespace

Links
Classes, nxrpServer Namespace, Legend


TnxRemotingServer Class

TnxRemotingServer Class
TnxRemotingServer Methods TnxRemotingServer Members nxrpServer Classes Send Feedback
Class Hierarchy
nxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServernxrpServer_TnxRemotingServer
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxRemotingServer = class(TnxRemotingBase);
File

nxrpServer

Description

This is class nxrpServer.TnxRemotingServer.

Group

Classes

Links
TnxRemotingServer Methods, TnxRemotingServer Members, nxrpServer, Classes


TnxRemotingServer Members

TnxRemotingServer Members
TnxRemotingServer Class Legend Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxRemotingServer.

Class

TnxRemotingServer Class

Protected Fields
Name | Description
bpeSession | private.
bpeTimeout | This is bpeTimeout, a member of class TnxBasePluginEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
rbClassActivatorIsolator | private
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bpeIsRemote | TnxBasePluginEngine
bpeProcessPost |
bpeProcessRequest |
bpeProcessStreamedRequest |
bpeSetSession |
CreateRequest |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
QueryInterface | IInterface TnxRemotingBase
rcRegister |
rcUnregister |
RequestNoData |
RequestNoDataNoReply |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Protected Properties
Name | Description
Session | This is Session, a member of class TnxBasePluginEngine.
Timeout | This is Timeout, a member of class TnxBasePluginEngine.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
CreateInstance | TnxRemotingServer
Destroy | denstructor
Destroy | destructor
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxRemotingServer Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxRemotingServer Methods

TnxRemotingServer Methods
TnxRemotingServer Class Legend Public Methods Send Feedback

The methods of the TnxRemotingServer class are listed here.

Class

TnxRemotingServer Class

Public Methods
Name | Description
CreateInstance | TnxRemotingServer
Links
TnxRemotingServer Class, Legend, Public Methods


TnxRemotingServer.CreateInstance Method

TnxRemotingServer.CreateInstance Method
TnxRemotingServer Class TnxRemotingServer Members nxrpServer Namespace TnxRemotingServer Methods Send Feedback
Syntax
Delphi
function CreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

TnxRemotingServer

Group

TnxRemotingServer Methods

Links
TnxRemotingServer Class, TnxRemotingServer Members, nxrpServer Namespace, TnxRemotingServer Methods


nxscrBaseScriptingEngine Namespace

nxscrBaseScriptingEngine Namespace
Classes Legend Topics Send Feedback

This is namespace nxscrBaseScriptingEngine.

Classes
Name | Description
TnxPascalScriptEngine | This is class nxscrBaseScriptingEngine.TnxPascalScriptEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxscrBaseScriptingEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxPascalScriptEngine | This is class nxscrBaseScriptingEngine.TnxPascalScriptEngine.
Namespace

nxscrBaseScriptingEngine Namespace

Links
Classes, nxscrBaseScriptingEngine Namespace, Legend


TnxPascalScriptEngine Class

TnxPascalScriptEngine Class
TnxPascalScriptEngine Fields TnxPascalScriptEngine Methods TnxPascalScriptEngine Properties TnxPascalScriptEngine Members nxscrBaseScriptingEngine Classes Send Feedback
Class Hierarchy
nxscrBaseScriptingEngine_TnxPascalScriptEnginenxscrBaseScriptingEngine_TnxPascalScriptEnginenxscrBaseScriptingEngine_TnxPascalScriptEnginenxscrBaseScriptingEngine_TnxPascalScriptEnginenxscrBaseScriptingEngine_TnxPascalScriptEnginenxscrBaseScriptingEngine_TnxPascalScriptEngine
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxPascalScriptEngine = class(TnxLoggableComponent);
File

nxscrBaseScriptingEngine

Description

This is class nxscrBaseScriptingEngine.TnxPascalScriptEngine.

Group

Classes

Links
TnxPascalScriptEngine Fields, TnxPascalScriptEngine Methods, TnxPascalScriptEngine Properties, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine, Classes


TnxPascalScriptEngine Members

TnxPascalScriptEngine Members
TnxPascalScriptEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxPascalScriptEngine.

Class

TnxPascalScriptEngine Class

Protected Fields
Name | Description
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
pseErrorMessage | This is pseErrorMessage, a member of class TnxPascalScriptEngine.
pseOutput | This is pseOutput, a member of class TnxPascalScriptEngine.
pseParams | This is pseParams, a member of class TnxPascalScriptEngine.
psePSScript | private
pseScript | This is pseScript, a member of class TnxPascalScriptEngine.
Protected Methods
Name | Description
DoAddVariable |
DoCompile |
DoCompImport |
DoExecImport |
DoFindUnknownFile |
DoFreeVariable |
DoInitVariable |
DoProcess |
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
pseSetParams |
pseSetScript |
PSScriptCompile |
PSScriptCompImport |
PSScriptExecImport |
rcRegister |
rcUnregister |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
ClearStats | Resets all internal stats.
Compile |
Create |
Destroy |
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Process | TnxPascalScriptEngine
SaveConfig | Persists settings.
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
ErrorMessage | This is ErrorMessage, a member of class TnxPascalScriptEngine.
Output | This is Output, a member of class TnxPascalScriptEngine.
Params | This is Params, a member of class TnxPascalScriptEngine.
PSEngine | This is PSEngine, a member of class TnxPascalScriptEngine.
Script | This is Script, a member of class TnxPascalScriptEngine.
Published Properties
Name | Description
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
Version | Version of the component.
Links
TnxPascalScriptEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxPascalScriptEngine.Create Constructor

TnxPascalScriptEngine.Create Constructor
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Class

TnxPascalScriptEngine Class

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Class


TnxPascalScriptEngine.Destroy Destructor

TnxPascalScriptEngine.Destroy Destructor
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxPascalScriptEngine Class

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Class


TnxPascalScriptEngine Fields

TnxPascalScriptEngine Fields
TnxPascalScriptEngine Class Legend Protected Fields Send Feedback

The fields of the TnxPascalScriptEngine class are listed here.

Class

TnxPascalScriptEngine Class

Protected Fields
Name | Description
pseErrorMessage | This is pseErrorMessage, a member of class TnxPascalScriptEngine.
pseOutput | This is pseOutput, a member of class TnxPascalScriptEngine.
pseParams | This is pseParams, a member of class TnxPascalScriptEngine.
psePSScript | private
pseScript | This is pseScript, a member of class TnxPascalScriptEngine.
Links
TnxPascalScriptEngine Class, Legend, Protected Fields


TnxPascalScriptEngine.pseErrorMessage Field

TnxPascalScriptEngine.pseErrorMessage Field
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Fields Send Feedback
Syntax
Delphi
pseErrorMessage: string;
Description

This is pseErrorMessage, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Fields

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Fields


TnxPascalScriptEngine.pseOutput Field

TnxPascalScriptEngine.pseOutput Field
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Fields Send Feedback
Syntax
Delphi
pseOutput: TnxSimpleOutputCache;
Description

This is pseOutput, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Fields

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Fields


TnxPascalScriptEngine.pseParams Field

TnxPascalScriptEngine.pseParams Field
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Fields Send Feedback
Syntax
Delphi
pseParams: TStrings;
Description

This is pseParams, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Fields

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Fields


TnxPascalScriptEngine.psePSScript Field

TnxPascalScriptEngine.psePSScript Field
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Fields Send Feedback
Syntax
Delphi
psePSScript: TPSScript;
Description

private

Group

TnxPascalScriptEngine Fields

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Fields


TnxPascalScriptEngine.pseScript Field

TnxPascalScriptEngine.pseScript Field
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Fields Send Feedback
Syntax
Delphi
pseScript: TStrings;
Description

This is pseScript, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Fields

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Fields


TnxPascalScriptEngine Methods

TnxPascalScriptEngine Methods
TnxPascalScriptEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxPascalScriptEngine class are listed here.

Class

TnxPascalScriptEngine Class

Protected Methods
Name | Description
DoAddVariable |
DoCompile |
DoCompImport |
DoExecImport |
DoFindUnknownFile |
DoFreeVariable |
DoInitVariable |
DoProcess |
pseSetParams |
pseSetScript |
PSScriptCompile |
PSScriptCompImport |
PSScriptExecImport |
Public Methods
Name | Description
Compile |
Process | TnxPascalScriptEngine
Links
TnxPascalScriptEngine Class, Legend, Protected Methods, Public Methods


TnxPascalScriptEngine.Compile Method

TnxPascalScriptEngine.Compile Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
function Compile: Boolean;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoAddVariable Method

TnxPascalScriptEngine.DoAddVariable Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure DoAddVariable(aPSScript: TPSScript); virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoCompile Method

TnxPascalScriptEngine.DoCompile Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
function DoCompile: Boolean; virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoCompImport Method

TnxPascalScriptEngine.DoCompImport Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure DoCompImport(aCompiler: TIFPSPascalCompiler); virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoExecImport Method

TnxPascalScriptEngine.DoExecImport Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure DoExecImport(aExec: TIFPSExec; aImporter: TIFPSRuntimeClassImporter); virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoFindUnknownFile Method

TnxPascalScriptEngine.DoFindUnknownFile Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
function DoFindUnknownFile(Sender: TObject; const OrginFileName: AnsiString; var FileName: AnsiString; var Output: AnsiString): Boolean;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoFreeVariable Method

TnxPascalScriptEngine.DoFreeVariable Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure DoFreeVariable(aPSScript: TPSScript); virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoInitVariable Method

TnxPascalScriptEngine.DoInitVariable Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure DoInitVariable(aPSScript: TPSScript); virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.DoProcess Method

TnxPascalScriptEngine.DoProcess Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
function DoProcess: Boolean; virtual;
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.Process Method

TnxPascalScriptEngine.Process Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
function Process: Boolean;
Description

TnxPascalScriptEngine

Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.pseSetParams Method

TnxPascalScriptEngine.pseSetParams Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure pseSetParams(const aValue: TStrings);
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.pseSetScript Method

TnxPascalScriptEngine.pseSetScript Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure pseSetScript(const aValue: TStrings);
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.PSScriptCompile Method

TnxPascalScriptEngine.PSScriptCompile Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure PSScriptCompile(aSender: TPSScript);
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.PSScriptCompImport Method

TnxPascalScriptEngine.PSScriptCompImport Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure PSScriptCompImport(aSender: TObject; aCompiler: TIFPSPascalCompiler);
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine.PSScriptExecImport Method

TnxPascalScriptEngine.PSScriptExecImport Method
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Methods Send Feedback
Syntax
Delphi
procedure PSScriptExecImport(aSender: TObject; aExec: TIFPSExec; aImporter: TIFPSRuntimeClassImporter);
Group

TnxPascalScriptEngine Methods

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Methods


TnxPascalScriptEngine Properties

TnxPascalScriptEngine Properties
TnxPascalScriptEngine Class Legend Public Properties Send Feedback

The properties of the TnxPascalScriptEngine class are listed here.

Class

TnxPascalScriptEngine Class

Public Properties
Name | Description
ErrorMessage | This is ErrorMessage, a member of class TnxPascalScriptEngine.
Output | This is Output, a member of class TnxPascalScriptEngine.
Params | This is Params, a member of class TnxPascalScriptEngine.
PSEngine | This is PSEngine, a member of class TnxPascalScriptEngine.
Script | This is Script, a member of class TnxPascalScriptEngine.
Links
TnxPascalScriptEngine Class, Legend, Public Properties


TnxPascalScriptEngine.ErrorMessage Property

TnxPascalScriptEngine.ErrorMessage Property
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Properties Send Feedback
Syntax
Delphi
property ErrorMessage: string;
Description

This is ErrorMessage, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Properties

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Properties


TnxPascalScriptEngine.Output Property

TnxPascalScriptEngine.Output Property
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Properties Send Feedback
Syntax
Delphi
property Output: TnxSimpleOutputCache;
Description

This is Output, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Properties

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Properties


TnxPascalScriptEngine.Params Property

TnxPascalScriptEngine.Params Property
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Properties Send Feedback
Syntax
Delphi
property Params: TStrings;
Description

This is Params, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Properties

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Properties


TnxPascalScriptEngine.PSEngine Property

TnxPascalScriptEngine.PSEngine Property
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Properties Send Feedback
Syntax
Delphi
property PSEngine: TPSScript;
Description

This is PSEngine, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Properties

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Properties


TnxPascalScriptEngine.Script Property

TnxPascalScriptEngine.Script Property
TnxPascalScriptEngine Class TnxPascalScriptEngine Members nxscrBaseScriptingEngine Namespace TnxPascalScriptEngine Properties Send Feedback
Syntax
Delphi
property Script: TStrings;
Description

This is Script, a member of class TnxPascalScriptEngine.

Group

TnxPascalScriptEngine Properties

Links
TnxPascalScriptEngine Class, TnxPascalScriptEngine Members, nxscrBaseScriptingEngine Namespace, TnxPascalScriptEngine Properties


nxsdBookmarkHandling Namespace

nxsdBookmarkHandling Namespace
Classes Functions Legend Topics Variables Send Feedback

This is namespace nxsdBookmarkHandling.

Classes
Name | Description
TnxBookmarkHandler | This is class nxsdBookmarkHandling.TnxBookmarkHandler.
Functions
Name | Description
BookmarkFromGlobalBookmark |
BookmarkFromGlobalBookmark | This is function nxsdBookmarkHandling.BookmarkFromGlobalBookmark.
GlobalBookmarkFromBookmark |
GlobalBookmarkFromBookmark | This is function nxsdBookmarkHandling.GlobalBookmarkFromBookmark.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Variables
Name | Description
nxNullBookmarkHandler | This is variable nxsdBookmarkHandling.nxNullBookmarkHandler.
Links
Classes, Functions, Legend, Topics, Variables


Classes

Classes
Classes nxsdBookmarkHandling Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxBookmarkHandler | This is class nxsdBookmarkHandling.TnxBookmarkHandler.
Namespace

nxsdBookmarkHandling Namespace

Links
Classes, nxsdBookmarkHandling Namespace, Legend


TnxBookmarkHandler Class

TnxBookmarkHandler Class
TnxBookmarkHandler Fields TnxBookmarkHandler Methods TnxBookmarkHandler Properties TnxBookmarkHandler Members nxsdBookmarkHandling Classes Send Feedback
Class Hierarchy
nxsdBookmarkHandling_TnxBookmarkHandlernxsdBookmarkHandling_TnxBookmarkHandler
Syntax
Delphi
TnxBookmarkHandler = class(TnxObject);
File

nxsdBookmarkHandling

Description

This is class nxsdBookmarkHandling.TnxBookmarkHandler.

Group

Classes

Links
TnxBookmarkHandler Fields, TnxBookmarkHandler Methods, TnxBookmarkHandler Properties, TnxBookmarkHandler Members, nxsdBookmarkHandling, Classes


TnxBookmarkHandler Members

TnxBookmarkHandler Members
TnxBookmarkHandler Class Legend Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBookmarkHandler.

Class

TnxBookmarkHandler Class

Public Fields
Name | Description
bmhIndexID | private
bmhKeyEngine | This is bmhKeyEngine, a member of class TnxBookmarkHandler.
Public Methods
Name | Description
BookmarkAsVariant |
CheckBookmark |
CompareBookmarks |
Create |
FreeInstance |
NewInstance | TnxObject
Public Properties
Name | Description
BookmarkSize | This is BookmarkSize, a member of class TnxBookmarkHandler.
Links
TnxBookmarkHandler Class, Legend, Public Fields, Public Methods, Public Properties


TnxBookmarkHandler.Create Constructor

TnxBookmarkHandler.Create Constructor
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Class Send Feedback
Syntax
Delphi
constructor Create(aIndexID: Integer; aKeyEngine: TnxBaseKeyEngine);
Class

TnxBookmarkHandler Class

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Class


TnxBookmarkHandler Fields

TnxBookmarkHandler Fields
TnxBookmarkHandler Class Legend Public Fields Send Feedback

The fields of the TnxBookmarkHandler class are listed here.

Class

TnxBookmarkHandler Class

Public Fields
Name | Description
bmhIndexID | private
bmhKeyEngine | This is bmhKeyEngine, a member of class TnxBookmarkHandler.
Links
TnxBookmarkHandler Class, Legend, Public Fields


TnxBookmarkHandler.bmhIndexID Field

TnxBookmarkHandler.bmhIndexID Field
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Fields Send Feedback
Syntax
Delphi
bmhIndexID: Integer;
Description

private

Group

TnxBookmarkHandler Fields

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Fields


TnxBookmarkHandler.bmhKeyEngine Field

TnxBookmarkHandler.bmhKeyEngine Field
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Fields Send Feedback
Syntax
Delphi
bmhKeyEngine: TnxBaseKeyEngine;
Description

This is bmhKeyEngine, a member of class TnxBookmarkHandler.

Group

TnxBookmarkHandler Fields

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Fields


TnxBookmarkHandler Methods

TnxBookmarkHandler Methods
TnxBookmarkHandler Class Legend Public Methods Send Feedback

The methods of the TnxBookmarkHandler class are listed here.

Class

TnxBookmarkHandler Class

Public Methods
Name | Description
BookmarkAsVariant |
CheckBookmark |
CompareBookmarks |
Links
TnxBookmarkHandler Class, Legend, Public Methods


TnxBookmarkHandler.BookmarkAsVariant Method

TnxBookmarkHandler.BookmarkAsVariant Method
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Methods Send Feedback
Syntax
Delphi
function BookmarkAsVariant(aBookmark: PnxByteArray; aSize: TnxWord32; out aVariant: Variant): TnxResult;
Group

TnxBookmarkHandler Methods

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Methods


TnxBookmarkHandler.CheckBookmark Method

TnxBookmarkHandler.CheckBookmark Method
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Methods Send Feedback
Syntax
Delphi
function CheckBookmark(aBookmark: PnxByteArray; aSize: TnxWord32): TnxResult;
Group

TnxBookmarkHandler Methods

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Methods


TnxBookmarkHandler.CompareBookmarks Method

TnxBookmarkHandler.CompareBookmarks Method
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Methods Send Feedback
Syntax
Delphi
function CompareBookmarks(aBookmark1: PnxByteArray; aBookmark2: PnxByteArray; aSize: TnxWord32; out aCompResult: TnxValueRelationship): TnxResult;
Group

TnxBookmarkHandler Methods

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Methods


TnxBookmarkHandler Properties

TnxBookmarkHandler Properties
TnxBookmarkHandler Class Legend Public Properties Send Feedback

The properties of the TnxBookmarkHandler class are listed here.

Class

TnxBookmarkHandler Class

Public Properties
Name | Description
BookmarkSize | This is BookmarkSize, a member of class TnxBookmarkHandler.
Links
TnxBookmarkHandler Class, Legend, Public Properties


TnxBookmarkHandler.BookmarkSize Property

TnxBookmarkHandler.BookmarkSize Property
TnxBookmarkHandler Class TnxBookmarkHandler Members nxsdBookmarkHandling Namespace TnxBookmarkHandler Properties Send Feedback
Syntax
Delphi
property BookmarkSize: TnxWord32;
Description

This is BookmarkSize, a member of class TnxBookmarkHandler.

Group

TnxBookmarkHandler Properties

Links
TnxBookmarkHandler Class, TnxBookmarkHandler Members, nxsdBookmarkHandling Namespace, TnxBookmarkHandler Properties


Functions

Functions
Functions nxsdBookmarkHandling Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
BookmarkFromGlobalBookmark |
BookmarkFromGlobalBookmark | This is function nxsdBookmarkHandling.BookmarkFromGlobalBookmark.
GlobalBookmarkFromBookmark |
GlobalBookmarkFromBookmark | This is function nxsdBookmarkHandling.GlobalBookmarkFromBookmark.
Namespace

nxsdBookmarkHandling Namespace

Links
Functions, nxsdBookmarkHandling Namespace, Legend


nxsdBookmarkHandling.BookmarkFromGlobalBookmark Function

nxsdBookmarkHandling.BookmarkFromGlobalBookmark Function
nxsdBookmarkHandling Functions Send Feedback
Syntax
Delphi
function BookmarkFromGlobalBookmark(const Bookmark: TBytes; const GlobalBookmark: TBytes): TBytes;
File

nxsdBookmarkHandling

Group

Functions

Links
nxsdBookmarkHandling, Functions


nxsdBookmarkHandling.BookmarkFromGlobalBookmark Function

nxsdBookmarkHandling.BookmarkFromGlobalBookmark Function
nxsdBookmarkHandling Functions Send Feedback
Syntax
Delphi
function BookmarkFromGlobalBookmark(const BookmarkStr: string; const GlobalBookmarkStr: string): string;
File

nxsdBookmarkHandling

Description

This is function nxsdBookmarkHandling.BookmarkFromGlobalBookmark.

Group

Functions

Links
nxsdBookmarkHandling, Functions


nxsdBookmarkHandling.GlobalBookmarkFromBookmark Function

nxsdBookmarkHandling.GlobalBookmarkFromBookmark Function
nxsdBookmarkHandling Functions Send Feedback
Syntax
Delphi
function GlobalBookmarkFromBookmark(const Bookmark: TBytes): TBytes;
File

nxsdBookmarkHandling

Group

Functions

Links
nxsdBookmarkHandling, Functions


nxsdBookmarkHandling.GlobalBookmarkFromBookmark Function

nxsdBookmarkHandling.GlobalBookmarkFromBookmark Function
nxsdBookmarkHandling Functions Send Feedback
Syntax
Delphi
function GlobalBookmarkFromBookmark(const BookmarkStr: string): string;
File

nxsdBookmarkHandling

Description

This is function nxsdBookmarkHandling.GlobalBookmarkFromBookmark.

Group

Functions

Links
nxsdBookmarkHandling, Functions


Variables

Variables
nxsdBookmarkHandling Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdBookmarkHandling Namespace

Variables
Name | Description
nxNullBookmarkHandler | This is variable nxsdBookmarkHandling.nxNullBookmarkHandler.
Links
nxsdBookmarkHandling Namespace, Variables


nxsdBookmarkHandling.nxNullBookmarkHandler Variable

nxsdBookmarkHandling.nxNullBookmarkHandler Variable
nxsdBookmarkHandling Variables Send Feedback
Syntax
Delphi
nxNullBookmarkHandler: TnxBookmarkHandler;
File

nxsdBookmarkHandling

Description

This is variable nxsdBookmarkHandling.nxNullBookmarkHandler.

Group

Variables

Links
nxsdBookmarkHandling, Variables


nxsdConst Namespace

nxsdConst Namespace
Constants Functions Legend Structs, Records, Enums Topics Variables Send Feedback

This is namespace nxsdConst.

Constants
Name | Description
_Log2BlockSizes | This is constant nxsdConst._Log2BlockSizes.
FieldDataTypeNames | This is constant nxsdConst.FieldDataTypeNames.
FieldDataTypes | This is constant nxsdConst.FieldDataTypes.
lrConflictCursor | This is constant nxsdConst.lrConflictCursor.
lrFailed | This is constant nxsdConst.lrFailed.
lrGranted | This is constant nxsdConst.lrGranted.
lrMultiple | This is constant nxsdConst.lrMultiple.
nx1xDefault | Default engine names
nxc_ExtForSQL | extension for SQL text files
nxc_ExtForTrans | extension for Transaction file
nxc_W32NoValue | This is constant nxsdConst.nxc_W32NoValue.
nxcl_FixedBookmarkSize | size of fixed part of a bookmark (ie, without key value)
nxcl_MaxIndexes | maximum number of indexes per table nxcl_MaxIndexFlds = 16; no such limit maximum count of fields in a composite key
nxCommonType | This is constant nxsdConst.nxCommonType.
nxCompatibleFields | This is constant nxsdConst.nxCompatibleFields.
nxDefaultFilterTimeout | The default timeout for setting filters in ms.
nxLockConflictTypeNames | This is constant nxsdConst.nxLockConflictTypeNames.
nxLockRequestTypeNames | This is constant nxsdConst.nxLockRequestTypeNames.
nxLockResultToLockConflictType | This is constant nxsdConst.nxLockResultToLockConflictType.
nxSqlCompatibleFields | fields that can be combined in expressions. The result type is defined by the table following this one
ParamTypeNames | This is constant nxsdConst.ParamTypeNames.
Functions
Name | Description
FieldDataTypesMap | This is function nxsdConst.FieldDataTypesMap.
FieldDataTypesMapSQL | This is function nxsdConst.FieldDataTypesMapSQL.
nxStrToParamType | This is function nxsdConst.nxStrToParamType.
Structs, Records, Enums
Name | Description
TFieldDataTypeNames | This is record nxsdConst.TFieldDataTypeNames.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
_FieldDataTypesMap | This is variable nxsdConst._FieldDataTypesMap.
_FieldDataTypesMapSQL | This is variable nxsdConst._FieldDataTypesMapSQL.
Links
Constants, Functions, Legend, Structs, Records, Enums, Topics, Variables


Functions

Functions
Functions nxsdConst Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
FieldDataTypesMap | This is function nxsdConst.FieldDataTypesMap.
FieldDataTypesMapSQL | This is function nxsdConst.FieldDataTypesMapSQL.
nxStrToParamType | This is function nxsdConst.nxStrToParamType.
Namespace

nxsdConst Namespace

Links
Functions, nxsdConst Namespace, Legend


nxsdConst.FieldDataTypesMap Function

nxsdConst.FieldDataTypesMap Function
nxsdConst Functions Send Feedback
Syntax
Delphi
function FieldDataTypesMap(const s: string): TnxFieldType;
File

nxsdConst

Description

This is function nxsdConst.FieldDataTypesMap.

Group

Functions

Links
nxsdConst, Functions


nxsdConst.FieldDataTypesMapSQL Function

nxsdConst.FieldDataTypesMapSQL Function
nxsdConst Functions Send Feedback
Syntax
Delphi
function FieldDataTypesMapSQL(const s: string): TnxFieldType;
File

nxsdConst

Description

This is function nxsdConst.FieldDataTypesMapSQL.

Group

Functions

Links
nxsdConst, Functions


nxsdConst.nxStrToParamType Function

nxsdConst.nxStrToParamType Function
nxsdConst Functions Send Feedback
Syntax
Delphi
function nxStrToParamType(const s: string): TnxParamType;
File

nxsdConst

Description

This is function nxsdConst.nxStrToParamType.

Group

Functions

Links
nxsdConst, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdConst Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TFieldDataTypeNames | This is record nxsdConst.TFieldDataTypeNames.
Namespace

nxsdConst Namespace

Links
Enumerations, nxsdConst Namespace, Legend


nxsdConst.TFieldDataTypeNames Enumeration

nxsdConst.TFieldDataTypeNames Enumeration
nxsdConst Structs, Records, Enums Send Feedback
Syntax
Delphi
TFieldDataTypeNames = ( fdtnNexus, fdtnSqlFixed, fdtnSqlVariable );
File

nxsdConst

Description

This is record nxsdConst.TFieldDataTypeNames.

Group

Structs, Records, Enums

Links
nxsdConst, Structs, Records, Enums


Variables

Variables
nxsdConst Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdConst Namespace

Variables
Name | Description
_FieldDataTypesMap | This is variable nxsdConst._FieldDataTypesMap.
_FieldDataTypesMapSQL | This is variable nxsdConst._FieldDataTypesMapSQL.
Links
nxsdConst Namespace, Variables


nxsdConst._FieldDataTypesMap Variable

nxsdConst._FieldDataTypesMap Variable
nxsdConst Variables Send Feedback
Syntax
Delphi
_FieldDataTypesMap: TStringList;
File

nxsdConst

Description

This is variable nxsdConst._FieldDataTypesMap.

Group

Variables

Links
nxsdConst, Variables


nxsdConst._FieldDataTypesMapSQL Variable

nxsdConst._FieldDataTypesMapSQL Variable
nxsdConst Variables Send Feedback
Syntax
Delphi
_FieldDataTypesMapSQL: TStringList;
File

nxsdConst

Description

This is variable nxsdConst._FieldDataTypesMapSQL.

Group

Variables

Links
nxsdConst, Variables


Constants

Constants
Constants nxsdConst Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
_Log2BlockSizes | This is constant nxsdConst._Log2BlockSizes.
FieldDataTypeNames | This is constant nxsdConst.FieldDataTypeNames.
FieldDataTypes | This is constant nxsdConst.FieldDataTypes.
lrConflictCursor | This is constant nxsdConst.lrConflictCursor.
lrFailed | This is constant nxsdConst.lrFailed.
lrGranted | This is constant nxsdConst.lrGranted.
lrMultiple | This is constant nxsdConst.lrMultiple.
nx1xDefault | Default engine names
nxc_ExtForSQL | extension for SQL text files
nxc_ExtForTrans | extension for Transaction file
nxc_W32NoValue | This is constant nxsdConst.nxc_W32NoValue.
nxcl_FixedBookmarkSize | size of fixed part of a bookmark (ie, without key value)
nxcl_MaxIndexes | maximum number of indexes per table nxcl_MaxIndexFlds = 16; no such limit maximum count of fields in a composite key
nxCommonType | This is constant nxsdConst.nxCommonType.
nxCompatibleFields | This is constant nxsdConst.nxCompatibleFields.
nxDefaultFilterTimeout | The default timeout for setting filters in ms.
nxLockConflictTypeNames | This is constant nxsdConst.nxLockConflictTypeNames.
nxLockRequestTypeNames | This is constant nxsdConst.nxLockRequestTypeNames.
nxLockResultToLockConflictType | This is constant nxsdConst.nxLockResultToLockConflictType.
nxSqlCompatibleFields | fields that can be combined in expressions. The result type is defined by the table following this one
ParamTypeNames | This is constant nxsdConst.ParamTypeNames.
Namespace

nxsdConst Namespace

Links
Constants, nxsdConst Namespace


nxsdConst._Log2BlockSizes Constant

nxsdConst._Log2BlockSizes Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
_Log2BlockSizes: array[TnxBlockSize] of Byte = ( 12, 13, 14, 15, 16);
File

nxsdConst

Description

This is constant nxsdConst._Log2BlockSizes.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.FieldDataTypeNames Constant

nxsdConst.FieldDataTypeNames Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
FieldDataTypeNames: array[TnxFieldType, TFieldDataTypeNames] of string = ( ('nxtBoolean' , 'BOOLEAN' , 'BOOLEAN'), ('nxtChar' , 'SINGLECHAR' , 'SINGLECHAR'), ('nxtWideChar' , 'NSINGLECHAR' , 'NSINGLECHAR'), ('nxtByte' , 'BYTE' , 'BYTE'), ('nxtWord16' , 'WORD' , 'WORD'), ('nxtWord32' , 'DWORD' , 'DWORD'), ('nxtInt8' , 'SHORTINT' , 'SHORTINT'), ('nxtInt16' , 'SMALLINT' , 'SMALLINT'), ('nxtInt32' , 'INTEGER' , 'INTEGER'), ('nxtInt64' , 'BIGINT' , 'BIGINT'), ('nxtAutoInc' , 'AUTOINC' , 'AUTOINC'), ('nxtSingle' , 'FLOAT' , 'FLOAT'), ('nxtDouble' , 'DOUBLE PRECISION' , 'DOUBLE PRECISION'), ('nxtExtended' , 'EXTENDED' , 'EXTENDED'), ('nxtCurrency' , 'MONEY' , 'MONEY'), ('nxtDate' , 'DATE' , 'DATE'), ('nxtTime' , 'TIME' , 'TIME'), ('nxtDateTime' , 'TIMESTAMP' , 'TIMESTAMP'), ('nxtInterval' , '' , ''), ('nxtBLOB' , 'BINARY LARGE OBJECT' , 'BINARY LARGE OBJECT'), ('nxtBLOBMemo' , 'CHARACTER LARGE OBJECT' , 'CHARACTER LARGE OBJECT'), ('nxtBLOBGraphic' , 'IMAGE' , 'IMAGE'), ('nxtByteArray' , 'BYTEARRAY' , 'BYTEARRAY'), ('nxtShortString' , 'SHORTSTRING' , 'SHORTSTRING'), ('nxtNullString' , 'CHARACTER' , 'CHARACTER VARYING'), ('nxtWideString' , 'NATIONAL CHARACTER' , 'NATIONAL CHARACTER VARYING'), ('nxtRecRev' , 'RECREV' , 'RECREV'), ('nxtGUID' , 'GUID' , 'GUID'), ('nxtBCD' , 'DECIMAL' , 'DECIMAL'), ('nxtBLOBWideMemo', 'NATIONAL CHARACTER LARGE OBJECT', 'NATIONAL CHARACTER LARGE OBJECT'), ('nxtFmtBCD' , 'DECIMAL' , 'DECIMAL'));
File

nxsdConst

Description

This is constant nxsdConst.FieldDataTypeNames.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.FieldDataTypes Constant

nxsdConst.FieldDataTypes Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
FieldDataTypes: array[TnxFieldType] of string = ( 'Boolean', 'Char', 'Wide Char', 'Byte', 'Word16', 'Word32', 'Int8', 'Int16', 'Int32', 'Int64', 'AutoInc', 'Single', 'Double', 'Extended', 'Currency', 'Date', 'Time', 'DateTime', 'Interval', 'BLOB', 'BLOB Memo', 'BLOB Graphic', 'Byte Array', 'ShortString', 'NullString', 'WideString', 'RecRev', 'GUID', 'BCD', 'BLOB Wide Memo', 'Formatted BCD');
File

nxsdConst

Description

This is constant nxsdConst.FieldDataTypes.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.lrConflictCursor Constant

nxsdConst.lrConflictCursor Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
lrConflictCursor = [lrConflictCursorWriteLock..lrConflictCursorRecordLockMultiple];
File

nxsdConst

Description

This is constant nxsdConst.lrConflictCursor.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.lrFailed Constant

nxsdConst.lrFailed Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
lrFailed = [Low(TnxLockResult)..High(TnxLockResult)] - lrGranted;
File

nxsdConst

Description

This is constant nxsdConst.lrFailed.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.lrGranted Constant

nxsdConst.lrGranted Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
lrGranted = [lrGrantedNew, lrGrantedExisting];
File

nxsdConst

Description

This is constant nxsdConst.lrGranted.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.lrMultiple Constant

nxsdConst.lrMultiple Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
lrMultiple = [lrConflictCursorReadLockMultiple, lrConflictCursorRecordLockMultiple];
File

nxsdConst

Description

This is constant nxsdConst.lrMultiple.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nx1xDefault Constant

nxsdConst.nx1xDefault Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nx1xDefault = 'nx1xDefault';
File

nxsdConst

Description

Default engine names

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxc_ExtForSQL Constant

nxsdConst.nxc_ExtForSQL Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxc_ExtForSQL: string = 'sql';
File

nxsdConst

Description

extension for SQL text files

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxc_ExtForTrans Constant

nxsdConst.nxc_ExtForTrans Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxc_ExtForTrans: string = 'n$2';
File

nxsdConst

Description

extension for Transaction file

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxc_W32NoValue Constant

nxsdConst.nxc_W32NoValue Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxc_W32NoValue = $FFFFFFFF;
File

nxsdConst

Description

This is constant nxsdConst.nxc_W32NoValue.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxcl_FixedBookmarkSize Constant

nxsdConst.nxcl_FixedBookmarkSize Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxcl_FixedBookmarkSize = 24;
File

nxsdConst

Description

size of fixed part of a bookmark (ie, without key value)

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxcl_MaxIndexes Constant

nxsdConst.nxcl_MaxIndexes Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxcl_MaxIndexes = 256;
File

nxsdConst

Description

maximum number of indexes per table nxcl_MaxIndexFlds = 16; no such limit maximum count of fields in a composite key

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxCommonType Constant

nxsdConst.nxCommonType Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxCommonType: array[TnxFieldType, TnxFieldType] of TnxFieldType = ((nxtBoolean, nxtChar, nxtWideChar, nxtByte, nxtWord16, nxtWord32, nxtInt8, nxtInt16, nxtInt32, nxtInt64, nxtAutoInc, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtChar, nxtChar, nxtWideChar, nxtByte, nxtWord16, nxtWord32, nxtInt8, nxtInt16, nxtInt32, nxtInt64, nxtAutoInc, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtWideChar, nxtWideChar, nxtWideChar, nxtWord16, nxtWord32, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobMemo, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtByte, nxtByte, nxtWideChar, nxtWord16, nxtWord16, nxtWord32, nxtInt16, nxtInt16, nxtInt32, nxtInt64, nxtWord32, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtWord16, nxtWord16, nxtWideChar, nxtWord16, nxtWord16, nxtWord32, nxtInt32, nxtInt32, nxtInt32, nxtInt64, nxtWord32, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtWord32, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt64, nxtInt8, nxtInt16, nxtInt32, nxtInt64, nxtInt64, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt64, nxtInt16, nxtInt16, nxtInt32, nxtInt64, nxtInt64, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt32, nxtInt64, nxtInt32, nxtInt32, nxtInt32, nxtInt64, nxtInt64, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtDouble, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtWord32, nxtDouble, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtDouble, nxtBlobWideMemo, nxtDouble ), (nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtDouble, nxtBlobWideMemo, nxtDouble ), (nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtExtended, nxtBlobWideMemo, nxtExtended ), (nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDate, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtDateTime, nxtDateTime, nxtDate, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtTime, nxtDouble, nxtExtended, nxtCurrency, nxtDateTime, nxtTime, nxtDateTime, nxtTime, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtDouble, nxtExtended, nxtCurrency, nxtDateTime, nxtDateTime, nxtDateTime, nxtDateTime, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtInterval, nxtGuid, nxtBcd, nxtInterval, nxtFmtBcd ), (nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlob, nxtBlobWideMemo, nxtBlob ), (nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobMemo, nxtBlobWideMemo, nxtBlobMemo ), (nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic, nxtBlobGraphic ), (nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray, nxtByteArray ), (nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtShortString, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtShortString, nxtShortString, nxtShortString, nxtBlobWideMemo, nxtShortString ), (nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtNullString, nxtBlobMemo, nxtBlobMemo, nxtBlobGraphic, nxtNullString, nxtNullString, nxtWideString, nxtNullString, nxtNullString, nxtNullString, nxtBlobWideMemo, nxtNullString ), (nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobGraphic, nxtByteArray, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtWideString, nxtBlobWideMemo, nxtWideString ), (nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtWord32, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtInt64, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid, nxtGuid ), (nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtBcd, nxtDouble, nxtDouble, nxtExtended, nxtBcd, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBcd, nxtBlobWideMemo, nxtFmtBcd ), (nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo,nxtBlobWideMemo, nxtBlobWideMemo), (nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtFmtBcd, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtFmtBcd, nxtBlobWideMemo, nxtFmtBcd ));
File

nxsdConst

Description

This is constant nxsdConst.nxCommonType.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxCompatibleFields Constant

nxsdConst.nxCompatibleFields Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxCompatibleFields: array[TnxFieldType, TnxFieldType] of Boolean = ((True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, True, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, False, False, False), (False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, True, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, True ), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, True, False, False, False, False, False, False, False, True , False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, True, False, False, False, False, False, False, False, True , False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, True, False, False, False, False, False, False, False, True , False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False), (False, False, False, False, False, True, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, True ), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, True, False, False, False, False, False, False, False, True , False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, True ));
File

nxsdConst

Description

This is constant nxsdConst.nxCompatibleFields.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxDefaultFilterTimeout Constant

nxsdConst.nxDefaultFilterTimeout Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxDefaultFilterTimeout = 500;
File

nxsdConst

Description

The default timeout for setting filters in ms.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxLockConflictTypeNames Constant

nxsdConst.nxLockConflictTypeNames Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxLockConflictTypeNames: array[TnxLockConflictType] of string = ( 'unknown', 'record lock', 'read lock', 'write lock', 'transaction' );
File

nxsdConst

Description

This is constant nxsdConst.nxLockConflictTypeNames.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxLockRequestTypeNames Constant

nxsdConst.nxLockRequestTypeNames Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxLockRequestTypeNames: array[TnxLockRequestType] of string = ( 'record lock', 'read lock', 'write lock' );
File

nxsdConst

Description

This is constant nxsdConst.nxLockRequestTypeNames.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxLockResultToLockConflictType Constant

nxsdConst.nxLockResultToLockConflictType Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxLockResultToLockConflictType: array[TnxLockResult] of TnxLockConflictType = ( lctUnknown, lctUnknown, lctUnknown, lctWriteLock, lctReadLock, lctReadLock, lctRecordLock, lctRecordLock, lctTransaction );
File

nxsdConst

Description

This is constant nxsdConst.nxLockResultToLockConflictType.

Group

Constants

Links
nxsdConst, Constants


nxsdConst.nxSqlCompatibleFields Constant

nxsdConst.nxSqlCompatibleFields Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
nxSqlCompatibleFields: array[TnxFieldType, TnxFieldType] of Boolean = ((True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, True, False, False, False, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, False, False, False, False, False, False, False, False), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, False, False, False, False, False, False, False, False), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, False, False, False, False, False, False), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True , False, False, False), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True), (False, True, True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, True, False, False, True, True, True, False, False, False, True, False), (False, False, False, True, True, True, True, True, True, True, True, True, True, True, True, False, False, False, False, False, False, False, False, False, False, False, True, False, True, False, True));
File

nxsdConst

Description

fields that can be combined in expressions. The result type is defined by the table following this one

Group

Constants

Links
nxsdConst, Constants


nxsdConst.ParamTypeNames Constant

nxsdConst.ParamTypeNames Constant
nxsdConst Constants Send Feedback
Syntax
Delphi
ParamTypeNames: array[TnxParamType] of string = ( '', 'IN', 'OUT', 'INOUT', 'RESULT' );
File

nxsdConst

Description

This is constant nxsdConst.ParamTypeNames.

Group

Constants

Links
nxsdConst, Constants


nxsdDataDictionary Namespace

nxsdDataDictionary Namespace
Classes Constants Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

Basic data dictionary.

Classes
Name | Description
EnxAdvAutoIncDescriptorException | This is the Exception class for the Advanced AutoInc Descriptor. All errors raised because of a problem in a Advanced AutoInc Descriptor class use this or a descendent exception class.
EnxBaseAutoIncDescriptorException | This is the Exception class for the Base AutoInc Descriptor. All errors raised because of a problem in a Base AutoInc Descriptor class use this or a descendent exception class.
EnxBaseBlobDescriptorException | This is the Exception class for the Blob Descriptor. All errors raised because of a problem in a Blob Descriptor class use this or a descendent exception class.
EnxBaseBlockHeapDescriptorException | This is the Exception class for the Block Heap Descriptor. All errors raised because of a problem in a Block Heap Descriptor class use this or a descendent exception class.
EnxBaseCustomDescriptorException | This is the Exception class for Base Custom Descriptors. All errors raised because of a problem in a Base Custom Descriptor class use this or a descendent exception class.
EnxBaseDefaultValueDescriptorException | This is the Exception class for the Default Value Descriptor. All errors raised because of a problem in a Default Value Descriptor class use this or a descendent exception class.
EnxBaseDictionaryException | This is the base Exception class for the various data dictionary exceptions.
EnxBaseFieldValidationDescriptorException | This is the Exception class for the Validation Descriptor. All errors raised because of a problem in a Validation Descriptor class use this or a descendent exception class.
EnxBaseHeapDescriptorException | This is the Exception class for the Heap Descriptor. All errors raised because of a problem in a Heap Descriptor class use this or a descendent exception class.
EnxBaseIndicesDescriptorException | This is the Exception class for the Indices descriptor. All errors raised because of a problem in a Indices descriptor class use this or a descendent exception class.
EnxBaseKeyDescriptorException | This is the Exception class for the Key Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.
EnxBaseRecordCompressionDescriptorException | This is the Exception class for the Record Compression Descriptor. All errors raised because of a problem in a Record Compression Descriptor class use this or a descendent exception class.
EnxBaseRecordDescriptorException | This is the Exception class for the Record Descriptor. All errors raised because of a problem in a Record Descriptor class use this or a descendent exception class.
EnxBaseStreamDescriptorException | This is the Exception class for the Stream Descriptor. All errors raised because of a problem in a Stream Descriptor class use this or a descendent exception class.
EnxBaseTableDescriptorException | This is the Exception class for Table Descriptors. All errors raised because of a problem in a Table Descriptor class use this or a descendent exception class.
EnxCompKeyDescriptorException | This is the exception class used for Compound Key descriptors.
EnxConstDefaultValueDescriptorException | The Exception class for the Constant Default Value Descriptor.
EnxCustomDescsDescriptorException | This is the Exception class for Custom Descriptor Descriptors. All errors raised because of a problem in a Custom Descriptor Descriptor class use this or a descendent exception class.
EnxDataDictionaryException | This is the Exception class for general, not descriptor based, exceptions of the Data Dictionary.
EnxDictionaryItemException | All exceptions for descriptors are inherited from this.
EnxExtTextKeyFieldDescriptorException | This is the exception class used for Extended Text Key Field descriptors.
EnxFieldDescriptorException | This is the Exception class for the Field Descriptor. All errors raised because of a problem in a Field Descriptor class use this or a descendent exception class.
EnxFieldsDescriptorException | This is the Exception class for the Fields descriptor. All errors raised because of a problem in a Fields descriptor class use this or a descendent exception class.
EnxFieldValidationsDescriptorException | This is the Exception class for the Validations Descriptor. All errors raised because of a problem in a Validations Descriptor class use this or a descendent exception class.
EnxFileDescriptorException | This is the Exception class for the File descriptor. All errors raised because of a problem in a File descriptor class use this or a descendent exception class.
EnxFilesDescriptorException | This is the Exception class for the Files descriptor. All errors raised because of a problem in a Files descriptor class use this or a descendent exception class.
EnxHeapBlobDescriptorException | This is the exception class used for the Heap Blob Descriptor.
EnxHeapRecordDescriptorException | This is the exception class used for the Heap Record Descriptor.
EnxIndexDescriptorException | This is the Exception class for the Index Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.
EnxKeyFieldDescriptorException | This is the Exception class for the Key Field Descriptor. All errors raised because of a problem in a Key Field Descriptor class use this or a descendent exception class.
EnxLocaleDescriptorException | This is the Exception class for the Locale descriptor. All errors raised because of a problem in a Locale descriptor class use this or a descendent exception class.
EnxLocaleizedDictionaryItemException | This is the Exception class for a localeized dictionary item. All errors raised because of a problem in a localeized dictionary item class use this or a descendent exception class.
EnxMainIndicesDescriptorException | This is the Exception class for the Main Indices descriptor. All errors raised because of a problem in a Main Indices descriptor class use this or a descendent exception class.
EnxMappedKeyDescriptorException | This is the exception class used for Mapped Key descriptors.
EnxMinMaxValidationDescriptorException | This is the Exception class for the Min/Max Validation Descriptor. All errors raised because of a problem in a Min/Max Validation Descriptor class use this or a descendent exception class.
EnxNestedTableDescriptorException | This is the Exception class for Nested Table Descriptors. All errors raised because of a problem in a Nested Table Descriptor class use this or a descendent exception class.
EnxNoChangeValidationDescriptorException | This is the Exception class for the No Change Validation Descriptor. All errors raised because of a problem in a No Change Validation Descriptor class use this or a descendent exception class.
EnxNoNullCompKeyDescriptorException | This is the exception class used for Compound Key descriptors which don't allow null fields.
EnxRefKeyDescriptorException | This is the exception class used for Ref Key descriptors.
EnxSqlCheckValidationDescriptorException | This is the Exception class for the Sql Check Validation Descriptor. All errors raised because of a problem in a Sql Check Validation Descriptor class use this or a descendent exception class.
EnxTablesDescriptorException | This is the Exception class for Tables Descriptors. All errors raised because of a problem in a Tables Descriptor class use this or a descendent exception class.
EnxTextKeyFieldDescriptorException | This is the exception class used for Text Key Field descriptors.
TnxAdvAutoIncDescriptor | An advanced AutoInc descriptor with Step and IntialValue.
TnxAutoGuidDefaultValueDescriptor | This descriptor should be used if you want to set a Guid field to an automatically created new Guid.
TnxBaseAutoIncDescriptor | This is the base class for AutoInc Descriptors. A AutoInc descriptor specifies the sub-engine that generates the AutoIncs.
TnxBaseBlobDescriptor | This is the base class for BLOB Descriptors. A Blob descriptor specifies the sub-engine that accesses the blobs.
TnxBaseBlockHeapDescriptor | This is the base class for specifying Block management classes. BlockHeap descriptors are used by the Heap Descriptor
TnxBaseCustomDescriptor | A Custom Descriptor is the base class for Custom Descriptors. Developers should use this class as a base for creating their own Descriptors and store them with tables.
TnxBaseDefaultValueDescriptor | This is the base class for descriptor that describe how a default value of a Field is set. This is an abstract class and must be overridden!
TnxBaseFieldsValidationDescriptor | This is the Base class for descriptor that describe how a Table is validated. This is an abstract class and must be overridden!
TnxBaseFieldValidationDescriptor | This is the base class for descriptor that describe how a Field is validated. This is an abstract class and must be overridden!
TnxBaseHeapDescriptor | This is the base class for specifying the Heap management classes.
TnxBaseIndicesDescriptor | TnxBaseIndicesDescriptor manages a list of IndexDescriptor classes associated with the data dictionary
TnxBaseKeyDescriptor | The base class of all Key Descriptors. A Key descriptor is used to create a key out of a record. Mainly it is used for creating indexes, but can of course also be used for other purposes.
TnxBaseRecordCompressionDescriptor | A compression descriptor describes the compression engine used for the associated table.
TnxBaseRecordDescriptor | This is the base class for Record Descriptors. A record descriptor is used for specifying the Record Engine used to read records from a table.
TnxBaseStreamDescriptor | This is the base class for Stream Descriptors. A Stream descriptor specifies the sub-engine that generates the Streams.
TnxBaseTableDescriptor | A table decriptor holds all information about a table as well as an instance of TnxFieldsDescriptor, TnxCustomDescsDescriptor, TnxTablesDescriptor, TnxBaseRecordDescriptor, TnxMainIndicesDescriptor, TnxBaseAutoIncDescriptor to fully define a table and it's attributes.
TnxCompKeyDescriptor | The Compound Key descriptor uses a number of Key Field descriptor to create the keys.
TnxConstDefaultValueDescriptor | This is the implementation for constant default values.
TnxCurrentDateTimeDefaultValueDescriptor | This descriptor should be used if you want to set a DateTime field to the current server DateTime.
TnxCurrentUserDefaultValueDescriptor | This descriptor should be used if you want to set a string field to the current logged in user.
TnxCustomDescsDescriptor | Holds a list of CustomDescriptors.
TnxDataDictionary | The data dictionary is the heart of every NexusDB table. It describes the files, fields, indices, etc and even how to read/write the records. If you don't need the fine control that the data dictionary gives you, you can just use TIndexDefs, TFieldDefs and the CreateTable method of TDataset.
TnxDictionaryItem | The dictionary item class is the base class for all sub classes owned by a data dictionary. This includes all the different descriptor classes.
TnxEmptyDefaultValueDescriptor | This descriptor should be used if you want to set a fields default value to not null. The practical result: strings become '' (empty string), integers 0, etc. By default all fields are NULL if not otherwise set.
TnxExtTextKeyFieldDescriptor | This is an extended version of the Text Key Field descriptor that can also handle Multi bytes characters, locale support, etc.
TnxFieldDescriptor | This descriptor class describes fields. For each field added to the Data Dictionary one instance is created.
TnxFieldsDescriptor | The Fields Descriptor holds a list of FieldDescriptors for the associated Data Dictionary.
TnxFieldsValidationsDescriptor | Holds a list of Field validation Descriptors
TnxFieldValidationsDescriptor | Holds a list of Field validation Descriptors
TnxFileDescriptor | A file descriptor describes the attributes of a physical file.
TnxFilesDescriptor | A Files Descriptors is a list of associated FileDescriptors
TnxHeapBlobDescriptor | A Heap Blob Descriptor adds support to Blob Descriptors for specifying a Heap Descriptor to read/store blobs on a heap.
TnxHeapRecordDescriptor | This is a descendant of Record Descriptor that allows to specify a Heap Descriptor that is used by the specified engine.
TnxIndexDescriptor | An Index Descriptor describes how NexusDB creates an Index for a table. It uses Key Descriptor for creating the record keys and optionally a File Descriptor to describe a sperate file used for storing the index.
TnxKeyFieldDescriptor | A Key Field Descriptor is used by a Key Descriptor to describe how field values processed when creating the key.
TnxLocaleDescriptor | This is the basic locale descriptor. It can be added to the data dictionary, field descriptors and key field descriptors. If a key field descriptor has no locale descriptor attached falls back to the field descriptor. If the field descriptor has no locale descriptor attached it falls back to the data dictionary. If there is no locale descriptor available at all or if the Locale of the used locale descriptor is 0 all comparisons and sorting is performed by direct byte value comparison.
TnxLocalizedDictionaryItem | A dictionary item with Locale Descriptors for localization of strings.
TnxMainIndicesDescriptor | Holds a list of IndexDescriptors that are main indices. Main indices are user selectable indices (e.g. IndexName property) as opposed to internally used indices.
TnxMinMaxValidationDescriptor | A validation descriptor to check for Minimum/Maximum values
TnxNestedTableDescriptor | A nested (sub) Table Descriptor is a special descriptor that is used for defining the sub tables of a certain main table.
TnxNoChangeValidationDescriptor | A validation descriptor to disallow field changes once it was initially set.
TnxNoNullCompKeyDescriptor | Key descriptor used to ensure a field is NOT null.
TnxRefKeyDescriptor | This Key Descriptor returns the internal id of the record as Key. It is used for the Sequential Access Index.
TnxSqlCheckValidationDescriptor | A validation descriptor implementing SQL constraints.
TnxTablesDescriptor | Holds a list (main) of named Table Descriptors.
TnxTextKeyFieldDescriptor | This is a simple Text field version of Key Field descriptor.
Constants
Name | Description
nxc_SigHeaderBlockV1 | Signature for NX V1 tables
nxc_SigHeaderBlockV2 | Signature for NX V2 tables
rsConstraintNameAlreadyUsed | This is constant nxsdDataDictionary.rsConstraintNameAlreadyUsed.
Interfaces
Name | Description
InxFieldDescriptor | DOM-IGNORE-BEGIN documented in implementing classes.
InxFieldsAccess | This is class nxsdDataDictionary.InxFieldsAccess.
InxFieldsSource | DOM-IGNORE-BEGIN documented in implementing classes.
Structs, Records, Enums
Name | Description
Tnx1xFileType | File types for the data dictionary.
TnxApplyAt | Type used to indicate where a validation object should be applied.
TnxIndexDups | This is record nxsdDataDictionary.TnxIndexDups.
TnxIteratorResult | Result of an interator function.
TnxNullBehaviour | Type to define the Null behaviour of a key
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxApplyAtSet | Set of TnxApplyAt
TnxAutoIncStepRange | Valid Step sizes for TnxAdvAutoIncDescriptor.
TnxBaseAutoIncDescriptorClass | Class definition for AutoInc Descriptors.
TnxBaseBlobDescriptorClass | Class definition for Blob Descriptors.
TnxBaseBlockHeapDescriptorClass | Class definition for Block Heap Descriptors
TnxBaseCustomDescriptorClass | Class definition for Custom Descriptor
TnxBaseDefaultValueDescriptorClass | Class definition for TnxBaseDefaultValueDescriptor.
TnxBaseFieldsValidationDescriptorClass | Class definition for TnxBaseFieldsValidationDescriptor.
TnxBaseFieldValidationDescriptorClass | Class definition for TnxBaseFieldValidationDescriptor.
TnxBaseHeapDescriptorClass | Class definition for Heap Descriptors.
TnxBaseIndicesDescriptorClass | Class definition for the base class of Indices Descriptors.
TnxBaseRecordCompressionDescriptorClass | Class definition for Compression Descriptors
TnxBaseRecordDescriptorClass | Class definition for Record Descriptors
TnxBaseStreamDescriptorClass | Class definition for Stream Descriptors.
TnxBaseTableDescriptorClass | Class definition for base Table Descriptors.
TnxCustomDescsDescriptorClass | Class definition for Custom Descriptors.
TnxDictionaryItemClass | Class definition for dictionary items.
TnxDictionaryItemIterator | Definition for IterateReferencing event.
TnxDictionaryIterator | Defintion for dictionary iteration callbacks.
TnxFieldDescriptorClass | Class definition for Field Descriptors.
TnxFieldsDescriptorClass | Class definition for Fields Descriptors.
TnxFieldsValidationsDescriptorClass | Class of TnxFieldsValidationsDescriptor.
TnxFieldValidationsDescriptorClass | Class definition for Validation Descriptors.
TnxFileDescriptorClass | Class definition for File Descriptors
TnxFilesDescriptorClass | Class definition for Files Descriptors.
TnxHeapBlobDescriptorClass | Class definition for Heap Blob Descriptors.
TnxHeapRecordDescriptorClass | Class definition for Heap Record Descriptors.
TnxIndexDescriptorClass | Class definition for Index descriptors.
TnxKeyDescriptorClass | Class definition for Key descriptors.
TnxKeyFieldDescriptorClass | Class definition for Key Field descriptors.
TnxLocaleDescriptorClass | Class definition for TnxLocaleDescriptor.
TnxMainIndicesDescriptorClass | Class definition for the class of Main-Index Descriptors.
TnxNestedTableDescriptorClass | Class definition for Nested(Sub-) table Descriptors.
TnxTablesDescriptorClass | Class definition for (Main) Table Descriptors.
Variables
Name | Description
_AutoIncDescriptorList | This is variable nxsdDataDictionary._AutoIncDescriptorList.
_BlobDescriptorList | This is variable nxsdDataDictionary._BlobDescriptorList.
_BlockHeapDescriptorList | This is variable nxsdDataDictionary._BlockHeapDescriptorList.
_CustomDescriptorList | This is variable nxsdDataDictionary._CustomDescriptorList.
_CustomDescsDescriptorList | This is variable nxsdDataDictionary._CustomDescsDescriptorList.
_DefaultValueDescriptorList | This is variable nxsdDataDictionary._DefaultValueDescriptorList.
_FieldDescriptorList | This is variable nxsdDataDictionary._FieldDescriptorList.
_FieldsDescriptorList | This is variable nxsdDataDictionary._FieldsDescriptorList.
_FileDescriptorList | This is variable nxsdDataDictionary._FileDescriptorList.
_FilesDescriptorList | This is variable nxsdDataDictionary._FilesDescriptorList.
_HeapDescriptorList | This is variable nxsdDataDictionary._HeapDescriptorList.
_IndexDescriptorList | This is variable nxsdDataDictionary._IndexDescriptorList.
_IndicesDescriptorList | This is variable nxsdDataDictionary._IndicesDescriptorList.
_KeyDescriptorList | This is variable nxsdDataDictionary._KeyDescriptorList.
_KeyFieldDescriptorList | This is variable nxsdDataDictionary._KeyFieldDescriptorList.
_LocaleDescriptorList | This is variable nxsdDataDictionary._LocaleDescriptorList.
_MainIndicesDescriptorList | This is variable nxsdDataDictionary._MainIndicesDescriptorList.
_NestedTableDescriptorList | This is variable nxsdDataDictionary._NestedTableDescriptorList.
_RecordCompressionDescriptorList | This is variable nxsdDataDictionary._RecordCompressionDescriptorList.
_RecordDescriptorList | This is variable nxsdDataDictionary._RecordDescriptorList.
_StreamDescriptorList | This is variable nxsdDataDictionary._StreamDescriptorList.
_TablesDescriptorList | This is variable nxsdDataDictionary._TablesDescriptorList.
_ValidationDescriptorList | This is variable nxsdDataDictionary._ValidationDescriptorList.
_ValidationsDescriptorList | This is variable nxsdDataDictionary._ValidationsDescriptorList.
Disable30900LocaleFixes | This is variable nxsdDataDictionary.Disable30900LocaleFixes.
Links
Classes, Constants, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxsdDataDictionary Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxAdvAutoIncDescriptorException | This is the Exception class for the Advanced AutoInc Descriptor. All errors raised because of a problem in a Advanced AutoInc Descriptor class use this or a descendent exception class.
EnxBaseAutoIncDescriptorException | This is the Exception class for the Base AutoInc Descriptor. All errors raised because of a problem in a Base AutoInc Descriptor class use this or a descendent exception class.
EnxBaseBlobDescriptorException | This is the Exception class for the Blob Descriptor. All errors raised because of a problem in a Blob Descriptor class use this or a descendent exception class.
EnxBaseBlockHeapDescriptorException | This is the Exception class for the Block Heap Descriptor. All errors raised because of a problem in a Block Heap Descriptor class use this or a descendent exception class.
EnxBaseCustomDescriptorException | This is the Exception class for Base Custom Descriptors. All errors raised because of a problem in a Base Custom Descriptor class use this or a descendent exception class.
EnxBaseDefaultValueDescriptorException | This is the Exception class for the Default Value Descriptor. All errors raised because of a problem in a Default Value Descriptor class use this or a descendent exception class.
EnxBaseDictionaryException | This is the base Exception class for the various data dictionary exceptions.
EnxBaseFieldValidationDescriptorException | This is the Exception class for the Validation Descriptor. All errors raised because of a problem in a Validation Descriptor class use this or a descendent exception class.
EnxBaseHeapDescriptorException | This is the Exception class for the Heap Descriptor. All errors raised because of a problem in a Heap Descriptor class use this or a descendent exception class.
EnxBaseIndicesDescriptorException | This is the Exception class for the Indices descriptor. All errors raised because of a problem in a Indices descriptor class use this or a descendent exception class.
EnxBaseKeyDescriptorException | This is the Exception class for the Key Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.
EnxBaseRecordCompressionDescriptorException | This is the Exception class for the Record Compression Descriptor. All errors raised because of a problem in a Record Compression Descriptor class use this or a descendent exception class.
EnxBaseRecordDescriptorException | This is the Exception class for the Record Descriptor. All errors raised because of a problem in a Record Descriptor class use this or a descendent exception class.
EnxBaseStreamDescriptorException | This is the Exception class for the Stream Descriptor. All errors raised because of a problem in a Stream Descriptor class use this or a descendent exception class.
EnxBaseTableDescriptorException | This is the Exception class for Table Descriptors. All errors raised because of a problem in a Table Descriptor class use this or a descendent exception class.
EnxCompKeyDescriptorException | This is the exception class used for Compound Key descriptors.
EnxConstDefaultValueDescriptorException | The Exception class for the Constant Default Value Descriptor.
EnxCustomDescsDescriptorException | This is the Exception class for Custom Descriptor Descriptors. All errors raised because of a problem in a Custom Descriptor Descriptor class use this or a descendent exception class.
EnxDataDictionaryException | This is the Exception class for general, not descriptor based, exceptions of the Data Dictionary.
EnxDictionaryItemException | All exceptions for descriptors are inherited from this.
EnxExtTextKeyFieldDescriptorException | This is the exception class used for Extended Text Key Field descriptors.
EnxFieldDescriptorException | This is the Exception class for the Field Descriptor. All errors raised because of a problem in a Field Descriptor class use this or a descendent exception class.
EnxFieldsDescriptorException | This is the Exception class for the Fields descriptor. All errors raised because of a problem in a Fields descriptor class use this or a descendent exception class.
EnxFieldValidationsDescriptorException | This is the Exception class for the Validations Descriptor. All errors raised because of a problem in a Validations Descriptor class use this or a descendent exception class.
EnxFileDescriptorException | This is the Exception class for the File descriptor. All errors raised because of a problem in a File descriptor class use this or a descendent exception class.
EnxFilesDescriptorException | This is the Exception class for the Files descriptor. All errors raised because of a problem in a Files descriptor class use this or a descendent exception class.
EnxHeapBlobDescriptorException | This is the exception class used for the Heap Blob Descriptor.
EnxHeapRecordDescriptorException | This is the exception class used for the Heap Record Descriptor.
EnxIndexDescriptorException | This is the Exception class for the Index Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.
EnxKeyFieldDescriptorException | This is the Exception class for the Key Field Descriptor. All errors raised because of a problem in a Key Field Descriptor class use this or a descendent exception class.
EnxLocaleDescriptorException | This is the Exception class for the Locale descriptor. All errors raised because of a problem in a Locale descriptor class use this or a descendent exception class.
EnxLocaleizedDictionaryItemException | This is the Exception class for a localeized dictionary item. All errors raised because of a problem in a localeized dictionary item class use this or a descendent exception class.
EnxMainIndicesDescriptorException | This is the Exception class for the Main Indices descriptor. All errors raised because of a problem in a Main Indices descriptor class use this or a descendent exception class.
EnxMappedKeyDescriptorException | This is the exception class used for Mapped Key descriptors.
EnxMinMaxValidationDescriptorException | This is the Exception class for the Min/Max Validation Descriptor. All errors raised because of a problem in a Min/Max Validation Descriptor class use this or a descendent exception class.
EnxNestedTableDescriptorException | This is the Exception class for Nested Table Descriptors. All errors raised because of a problem in a Nested Table Descriptor class use this or a descendent exception class.
EnxNoChangeValidationDescriptorException | This is the Exception class for the No Change Validation Descriptor. All errors raised because of a problem in a No Change Validation Descriptor class use this or a descendent exception class.
EnxNoNullCompKeyDescriptorException | This is the exception class used for Compound Key descriptors which don't allow null fields.
EnxRefKeyDescriptorException | This is the exception class used for Ref Key descriptors.
EnxSqlCheckValidationDescriptorException | This is the Exception class for the Sql Check Validation Descriptor. All errors raised because of a problem in a Sql Check Validation Descriptor class use this or a descendent exception class.
EnxTablesDescriptorException | This is the Exception class for Tables Descriptors. All errors raised because of a problem in a Tables Descriptor class use this or a descendent exception class.
EnxTextKeyFieldDescriptorException | This is the exception class used for Text Key Field descriptors.
TnxAdvAutoIncDescriptor | An advanced AutoInc descriptor with Step and IntialValue.
TnxAutoGuidDefaultValueDescriptor | This descriptor should be used if you want to set a Guid field to an automatically created new Guid.
TnxBaseAutoIncDescriptor | This is the base class for AutoInc Descriptors. A AutoInc descriptor specifies the sub-engine that generates the AutoIncs.
TnxBaseBlobDescriptor | This is the base class for BLOB Descriptors. A Blob descriptor specifies the sub-engine that accesses the blobs.
TnxBaseBlockHeapDescriptor | This is the base class for specifying Block management classes. BlockHeap descriptors are used by the Heap Descriptor
TnxBaseCustomDescriptor | A Custom Descriptor is the base class for Custom Descriptors. Developers should use this class as a base for creating their own Descriptors and store them with tables.
TnxBaseDefaultValueDescriptor | This is the base class for descriptor that describe how a default value of a Field is set. This is an abstract class and must be overridden!
TnxBaseFieldsValidationDescriptor | This is the Base class for descriptor that describe how a Table is validated. This is an abstract class and must be overridden!
TnxBaseFieldValidationDescriptor | This is the base class for descriptor that describe how a Field is validated. This is an abstract class and must be overridden!
TnxBaseHeapDescriptor | This is the base class for specifying the Heap management classes.
TnxBaseIndicesDescriptor | TnxBaseIndicesDescriptor manages a list of IndexDescriptor classes associated with the data dictionary
TnxBaseKeyDescriptor | The base class of all Key Descriptors. A Key descriptor is used to create a key out of a record. Mainly it is used for creating indexes, but can of course also be used for other purposes.
TnxBaseRecordCompressionDescriptor | A compression descriptor describes the compression engine used for the associated table.
TnxBaseRecordDescriptor | This is the base class for Record Descriptors. A record descriptor is used for specifying the Record Engine used to read records from a table.
TnxBaseStreamDescriptor | This is the base class for Stream Descriptors. A Stream descriptor specifies the sub-engine that generates the Streams.
TnxBaseTableDescriptor | A table decriptor holds all information about a table as well as an instance of TnxFieldsDescriptor, TnxCustomDescsDescriptor, TnxTablesDescriptor, TnxBaseRecordDescriptor, TnxMainIndicesDescriptor, TnxBaseAutoIncDescriptor to fully define a table and it's attributes.
TnxCompKeyDescriptor | The Compound Key descriptor uses a number of Key Field descriptor to create the keys.
TnxConstDefaultValueDescriptor | This is the implementation for constant default values.
TnxCurrentDateTimeDefaultValueDescriptor | This descriptor should be used if you want to set a DateTime field to the current server DateTime.
TnxCurrentUserDefaultValueDescriptor | This descriptor should be used if you want to set a string field to the current logged in user.
TnxCustomDescsDescriptor | Holds a list of CustomDescriptors.
TnxDataDictionary | The data dictionary is the heart of every NexusDB table. It describes the files, fields, indices, etc and even how to read/write the records. If you don't need the fine control that the data dictionary gives you, you can just use TIndexDefs, TFieldDefs and the CreateTable method of TDataset.
TnxDictionaryItem | The dictionary item class is the base class for all sub classes owned by a data dictionary. This includes all the different descriptor classes.
TnxEmptyDefaultValueDescriptor | This descriptor should be used if you want to set a fields default value to not null. The practical result: strings become '' (empty string), integers 0, etc. By default all fields are NULL if not otherwise set.
TnxExtTextKeyFieldDescriptor | This is an extended version of the Text Key Field descriptor that can also handle Multi bytes characters, locale support, etc.
TnxFieldDescriptor | This descriptor class describes fields. For each field added to the Data Dictionary one instance is created.
TnxFieldsDescriptor | The Fields Descriptor holds a list of FieldDescriptors for the associated Data Dictionary.
TnxFieldsValidationsDescriptor | Holds a list of Field validation Descriptors
TnxFieldValidationsDescriptor | Holds a list of Field validation Descriptors
TnxFileDescriptor | A file descriptor describes the attributes of a physical file.
TnxFilesDescriptor | A Files Descriptors is a list of associated FileDescriptors
TnxHeapBlobDescriptor | A Heap Blob Descriptor adds support to Blob Descriptors for specifying a Heap Descriptor to read/store blobs on a heap.
TnxHeapRecordDescriptor | This is a descendant of Record Descriptor that allows to specify a Heap Descriptor that is used by the specified engine.
TnxIndexDescriptor | An Index Descriptor describes how NexusDB creates an Index for a table. It uses Key Descriptor for creating the record keys and optionally a File Descriptor to describe a sperate file used for storing the index.
TnxKeyFieldDescriptor | A Key Field Descriptor is used by a Key Descriptor to describe how field values processed when creating the key.
TnxLocaleDescriptor | This is the basic locale descriptor. It can be added to the data dictionary, field descriptors and key field descriptors. If a key field descriptor has no locale descriptor attached falls back to the field descriptor. If the field descriptor has no locale descriptor attached it falls back to the data dictionary. If there is no locale descriptor available at all or if the Locale of the used locale descriptor is 0 all comparisons and sorting is performed by direct byte value comparison.
TnxLocalizedDictionaryItem | A dictionary item with Locale Descriptors for localization of strings.
TnxMainIndicesDescriptor | Holds a list of IndexDescriptors that are main indices. Main indices are user selectable indices (e.g. IndexName property) as opposed to internally used indices.
TnxMinMaxValidationDescriptor | A validation descriptor to check for Minimum/Maximum values
TnxNestedTableDescriptor | A nested (sub) Table Descriptor is a special descriptor that is used for defining the sub tables of a certain main table.
TnxNoChangeValidationDescriptor | A validation descriptor to disallow field changes once it was initially set.
TnxNoNullCompKeyDescriptor | Key descriptor used to ensure a field is NOT null.
TnxRefKeyDescriptor | This Key Descriptor returns the internal id of the record as Key. It is used for the Sequential Access Index.
TnxSqlCheckValidationDescriptor | A validation descriptor implementing SQL constraints.
TnxTablesDescriptor | Holds a list (main) of named Table Descriptors.
TnxTextKeyFieldDescriptor | This is a simple Text field version of Key Field descriptor.
Namespace

nxsdDataDictionary Namespace

Links
Classes, nxsdDataDictionary Namespace, Legend


EnxAdvAutoIncDescriptorException Class

EnxAdvAutoIncDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorExceptionnxsdDataDictionary_EnxAdvAutoIncDescriptorException
Syntax
Delphi
EnxAdvAutoIncDescriptorException = class(EnxBaseAutoIncDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for the Advanced AutoInc Descriptor. All errors raised because of a problem in a Advanced AutoInc Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseAutoIncDescriptorException Class

EnxBaseAutoIncDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseAutoIncDescriptorExceptionnxsdDataDictionary_EnxBaseAutoIncDescriptorExceptionnxsdDataDictionary_EnxBaseAutoIncDescriptorExceptionnxsdDataDictionary_EnxBaseAutoIncDescriptorExceptionnxsdDataDictionary_EnxBaseAutoIncDescriptorExceptionnxsdDataDictionary_EnxBaseAutoIncDescriptorException
Syntax
Delphi
EnxBaseAutoIncDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Base AutoInc Descriptor. All errors raised because of a problem in a Base AutoInc Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseBlobDescriptorException Class

EnxBaseBlobDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseBlobDescriptorExceptionnxsdDataDictionary_EnxBaseBlobDescriptorExceptionnxsdDataDictionary_EnxBaseBlobDescriptorExceptionnxsdDataDictionary_EnxBaseBlobDescriptorExceptionnxsdDataDictionary_EnxBaseBlobDescriptorExceptionnxsdDataDictionary_EnxBaseBlobDescriptorException
Syntax
Delphi
EnxBaseBlobDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Blob Descriptor. All errors raised because of a problem in a Blob Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseBlockHeapDescriptorException Class

EnxBaseBlockHeapDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseBlockHeapDescriptorExceptionnxsdDataDictionary_EnxBaseBlockHeapDescriptorExceptionnxsdDataDictionary_EnxBaseBlockHeapDescriptorExceptionnxsdDataDictionary_EnxBaseBlockHeapDescriptorExceptionnxsdDataDictionary_EnxBaseBlockHeapDescriptorExceptionnxsdDataDictionary_EnxBaseBlockHeapDescriptorException
Syntax
Delphi
EnxBaseBlockHeapDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Block Heap Descriptor. All errors raised because of a problem in a Block Heap Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseCustomDescriptorException Class

EnxBaseCustomDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseCustomDescriptorExceptionnxsdDataDictionary_EnxBaseCustomDescriptorExceptionnxsdDataDictionary_EnxBaseCustomDescriptorExceptionnxsdDataDictionary_EnxBaseCustomDescriptorExceptionnxsdDataDictionary_EnxBaseCustomDescriptorExceptionnxsdDataDictionary_EnxBaseCustomDescriptorException
Syntax
Delphi
EnxBaseCustomDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for Base Custom Descriptors. All errors raised because of a problem in a Base Custom Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseDefaultValueDescriptorException Class

EnxBaseDefaultValueDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseDefaultValueDescriptorExceptionnxsdDataDictionary_EnxBaseDefaultValueDescriptorExceptionnxsdDataDictionary_EnxBaseDefaultValueDescriptorExceptionnxsdDataDictionary_EnxBaseDefaultValueDescriptorExceptionnxsdDataDictionary_EnxBaseDefaultValueDescriptorExceptionnxsdDataDictionary_EnxBaseDefaultValueDescriptorException
Syntax
Delphi
EnxBaseDefaultValueDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Default Value Descriptor. All errors raised because of a problem in a Default Value Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseDictionaryException Class

EnxBaseDictionaryException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseDictionaryExceptionnxsdDataDictionary_EnxBaseDictionaryExceptionnxsdDataDictionary_EnxBaseDictionaryExceptionnxsdDataDictionary_EnxBaseDictionaryException
Syntax
Delphi
EnxBaseDictionaryException = class(EnxBaseException);
File

nxsdDataDictionary

Description

This is the base Exception class for the various data dictionary exceptions.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseFieldValidationDescriptorException Class

EnxBaseFieldValidationDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseFieldValidationDescriptorExceptionnxsdDataDictionary_EnxBaseFieldValidationDescriptorExceptionnxsdDataDictionary_EnxBaseFieldValidationDescriptorExceptionnxsdDataDictionary_EnxBaseFieldValidationDescriptorExceptionnxsdDataDictionary_EnxBaseFieldValidationDescriptorExceptionnxsdDataDictionary_EnxBaseFieldValidationDescriptorException
Syntax
Delphi
EnxBaseFieldValidationDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Validation Descriptor. All errors raised because of a problem in a Validation Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseHeapDescriptorException Class

EnxBaseHeapDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseHeapDescriptorExceptionnxsdDataDictionary_EnxBaseHeapDescriptorExceptionnxsdDataDictionary_EnxBaseHeapDescriptorExceptionnxsdDataDictionary_EnxBaseHeapDescriptorExceptionnxsdDataDictionary_EnxBaseHeapDescriptorExceptionnxsdDataDictionary_EnxBaseHeapDescriptorException
Syntax
Delphi
EnxBaseHeapDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Heap Descriptor. All errors raised because of a problem in a Heap Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseIndicesDescriptorException Class

EnxBaseIndicesDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseIndicesDescriptorExceptionnxsdDataDictionary_EnxBaseIndicesDescriptorExceptionnxsdDataDictionary_EnxBaseIndicesDescriptorExceptionnxsdDataDictionary_EnxBaseIndicesDescriptorExceptionnxsdDataDictionary_EnxBaseIndicesDescriptorExceptionnxsdDataDictionary_EnxBaseIndicesDescriptorException
Syntax
Delphi
EnxBaseIndicesDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Indices descriptor. All errors raised because of a problem in a Indices descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseKeyDescriptorException Class

EnxBaseKeyDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseKeyDescriptorExceptionnxsdDataDictionary_EnxBaseKeyDescriptorExceptionnxsdDataDictionary_EnxBaseKeyDescriptorExceptionnxsdDataDictionary_EnxBaseKeyDescriptorExceptionnxsdDataDictionary_EnxBaseKeyDescriptorExceptionnxsdDataDictionary_EnxBaseKeyDescriptorException
Syntax
Delphi
EnxBaseKeyDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Key Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseRecordCompressionDescriptorException Class

EnxBaseRecordCompressionDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseRecordCompressionDescriptorExceptionnxsdDataDictionary_EnxBaseRecordCompressionDescriptorExceptionnxsdDataDictionary_EnxBaseRecordCompressionDescriptorExceptionnxsdDataDictionary_EnxBaseRecordCompressionDescriptorExceptionnxsdDataDictionary_EnxBaseRecordCompressionDescriptorExceptionnxsdDataDictionary_EnxBaseRecordCompressionDescriptorException
Syntax
Delphi
EnxBaseRecordCompressionDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Record Compression Descriptor. All errors raised because of a problem in a Record Compression Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseRecordDescriptorException Class

EnxBaseRecordDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseRecordDescriptorExceptionnxsdDataDictionary_EnxBaseRecordDescriptorExceptionnxsdDataDictionary_EnxBaseRecordDescriptorExceptionnxsdDataDictionary_EnxBaseRecordDescriptorExceptionnxsdDataDictionary_EnxBaseRecordDescriptorExceptionnxsdDataDictionary_EnxBaseRecordDescriptorException
Syntax
Delphi
EnxBaseRecordDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Record Descriptor. All errors raised because of a problem in a Record Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseStreamDescriptorException Class

EnxBaseStreamDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseStreamDescriptorExceptionnxsdDataDictionary_EnxBaseStreamDescriptorExceptionnxsdDataDictionary_EnxBaseStreamDescriptorExceptionnxsdDataDictionary_EnxBaseStreamDescriptorExceptionnxsdDataDictionary_EnxBaseStreamDescriptorExceptionnxsdDataDictionary_EnxBaseStreamDescriptorException
Syntax
Delphi
EnxBaseStreamDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Stream Descriptor. All errors raised because of a problem in a Stream Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxBaseTableDescriptorException Class

EnxBaseTableDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxBaseTableDescriptorExceptionnxsdDataDictionary_EnxBaseTableDescriptorExceptionnxsdDataDictionary_EnxBaseTableDescriptorExceptionnxsdDataDictionary_EnxBaseTableDescriptorExceptionnxsdDataDictionary_EnxBaseTableDescriptorExceptionnxsdDataDictionary_EnxBaseTableDescriptorException
Syntax
Delphi
EnxBaseTableDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for Table Descriptors. All errors raised because of a problem in a Table Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxCompKeyDescriptorException Class

EnxCompKeyDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorExceptionnxsdDataDictionary_EnxCompKeyDescriptorException
Syntax
Delphi
EnxCompKeyDescriptorException = class(EnxBaseKeyDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Compound Key descriptors.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxConstDefaultValueDescriptorException Class

EnxConstDefaultValueDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorExceptionnxsdDataDictionary_EnxConstDefaultValueDescriptorException
Syntax
Delphi
EnxConstDefaultValueDescriptorException = class(EnxBaseDefaultValueDescriptorException);
File

nxsdDataDictionary

Description

The Exception class for the Constant Default Value Descriptor.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxCustomDescsDescriptorException Class

EnxCustomDescsDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxCustomDescsDescriptorExceptionnxsdDataDictionary_EnxCustomDescsDescriptorExceptionnxsdDataDictionary_EnxCustomDescsDescriptorExceptionnxsdDataDictionary_EnxCustomDescsDescriptorExceptionnxsdDataDictionary_EnxCustomDescsDescriptorExceptionnxsdDataDictionary_EnxCustomDescsDescriptorException
Syntax
Delphi
EnxCustomDescsDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for Custom Descriptor Descriptors. All errors raised because of a problem in a Custom Descriptor Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxDataDictionaryException Class

EnxDataDictionaryException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxDataDictionaryExceptionnxsdDataDictionary_EnxDataDictionaryExceptionnxsdDataDictionary_EnxDataDictionaryExceptionnxsdDataDictionary_EnxDataDictionaryExceptionnxsdDataDictionary_EnxDataDictionaryExceptionnxsdDataDictionary_EnxDataDictionaryException
Syntax
Delphi
EnxDataDictionaryException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for general, not descriptor based, exceptions of the Data Dictionary.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxDictionaryItemException Class

EnxDictionaryItemException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxDictionaryItemExceptionnxsdDataDictionary_EnxDictionaryItemExceptionnxsdDataDictionary_EnxDictionaryItemExceptionnxsdDataDictionary_EnxDictionaryItemExceptionnxsdDataDictionary_EnxDictionaryItemException
Syntax
Delphi
EnxDictionaryItemException = class(EnxBaseDictionaryException);
File

nxsdDataDictionary

Description

All exceptions for descriptors are inherited from this.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxExtTextKeyFieldDescriptorException Class

EnxExtTextKeyFieldDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxExtTextKeyFieldDescriptorException
Syntax
Delphi
EnxExtTextKeyFieldDescriptorException = class(EnxTextKeyFieldDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Extended Text Key Field descriptors.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxFieldDescriptorException Class

EnxFieldDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorExceptionnxsdDataDictionary_EnxFieldDescriptorException
Syntax
Delphi
EnxFieldDescriptorException = class(EnxLocaleizedDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Field Descriptor. All errors raised because of a problem in a Field Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxFieldsDescriptorException Class

EnxFieldsDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxFieldsDescriptorExceptionnxsdDataDictionary_EnxFieldsDescriptorExceptionnxsdDataDictionary_EnxFieldsDescriptorExceptionnxsdDataDictionary_EnxFieldsDescriptorExceptionnxsdDataDictionary_EnxFieldsDescriptorExceptionnxsdDataDictionary_EnxFieldsDescriptorException
Syntax
Delphi
EnxFieldsDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Fields descriptor. All errors raised because of a problem in a Fields descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxFieldValidationsDescriptorException Class

EnxFieldValidationsDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxFieldValidationsDescriptorExceptionnxsdDataDictionary_EnxFieldValidationsDescriptorExceptionnxsdDataDictionary_EnxFieldValidationsDescriptorExceptionnxsdDataDictionary_EnxFieldValidationsDescriptorExceptionnxsdDataDictionary_EnxFieldValidationsDescriptorExceptionnxsdDataDictionary_EnxFieldValidationsDescriptorException
Syntax
Delphi
EnxFieldValidationsDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Validations Descriptor. All errors raised because of a problem in a Validations Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxFileDescriptorException Class

EnxFileDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxFileDescriptorExceptionnxsdDataDictionary_EnxFileDescriptorExceptionnxsdDataDictionary_EnxFileDescriptorExceptionnxsdDataDictionary_EnxFileDescriptorExceptionnxsdDataDictionary_EnxFileDescriptorExceptionnxsdDataDictionary_EnxFileDescriptorException
Syntax
Delphi
EnxFileDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the File descriptor. All errors raised because of a problem in a File descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxFilesDescriptorException Class

EnxFilesDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxFilesDescriptorExceptionnxsdDataDictionary_EnxFilesDescriptorExceptionnxsdDataDictionary_EnxFilesDescriptorExceptionnxsdDataDictionary_EnxFilesDescriptorExceptionnxsdDataDictionary_EnxFilesDescriptorExceptionnxsdDataDictionary_EnxFilesDescriptorException
Syntax
Delphi
EnxFilesDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Files descriptor. All errors raised because of a problem in a Files descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxHeapBlobDescriptorException Class

EnxHeapBlobDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorExceptionnxsdDataDictionary_EnxHeapBlobDescriptorException
Syntax
Delphi
EnxHeapBlobDescriptorException = class(EnxBaseBlobDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for the Heap Blob Descriptor.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxHeapRecordDescriptorException Class

EnxHeapRecordDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorExceptionnxsdDataDictionary_EnxHeapRecordDescriptorException
Syntax
Delphi
EnxHeapRecordDescriptorException = class(EnxBaseRecordDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for the Heap Record Descriptor.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxIndexDescriptorException Class

EnxIndexDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxIndexDescriptorExceptionnxsdDataDictionary_EnxIndexDescriptorExceptionnxsdDataDictionary_EnxIndexDescriptorExceptionnxsdDataDictionary_EnxIndexDescriptorExceptionnxsdDataDictionary_EnxIndexDescriptorExceptionnxsdDataDictionary_EnxIndexDescriptorException
Syntax
Delphi
EnxIndexDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Index Descriptor. All errors raised because of a problem in a Key Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxKeyFieldDescriptorException Class

EnxKeyFieldDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorExceptionnxsdDataDictionary_EnxKeyFieldDescriptorException
Syntax
Delphi
EnxKeyFieldDescriptorException = class(EnxLocaleizedDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Key Field Descriptor. All errors raised because of a problem in a Key Field Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxLocaleDescriptorException Class

EnxLocaleDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxLocaleDescriptorExceptionnxsdDataDictionary_EnxLocaleDescriptorExceptionnxsdDataDictionary_EnxLocaleDescriptorExceptionnxsdDataDictionary_EnxLocaleDescriptorExceptionnxsdDataDictionary_EnxLocaleDescriptorExceptionnxsdDataDictionary_EnxLocaleDescriptorException
Syntax
Delphi
EnxLocaleDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for the Locale descriptor. All errors raised because of a problem in a Locale descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxLocaleizedDictionaryItemException Class

EnxLocaleizedDictionaryItemException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxLocaleizedDictionaryItemExceptionnxsdDataDictionary_EnxLocaleizedDictionaryItemExceptionnxsdDataDictionary_EnxLocaleizedDictionaryItemExceptionnxsdDataDictionary_EnxLocaleizedDictionaryItemExceptionnxsdDataDictionary_EnxLocaleizedDictionaryItemExceptionnxsdDataDictionary_EnxLocaleizedDictionaryItemException
Syntax
Delphi
EnxLocaleizedDictionaryItemException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for a localeized dictionary item. All errors raised because of a problem in a localeized dictionary item class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxMainIndicesDescriptorException Class

EnxMainIndicesDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorExceptionnxsdDataDictionary_EnxMainIndicesDescriptorException
Syntax
Delphi
EnxMainIndicesDescriptorException = class(EnxBaseIndicesDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for the Main Indices descriptor. All errors raised because of a problem in a Main Indices descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxMappedKeyDescriptorException Class

EnxMappedKeyDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorExceptionnxsdDataDictionary_EnxMappedKeyDescriptorException
Syntax
Delphi
EnxMappedKeyDescriptorException = class(EnxBaseKeyDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Mapped Key descriptors.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxMinMaxValidationDescriptorException Class

EnxMinMaxValidationDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorExceptionnxsdDataDictionary_EnxMinMaxValidationDescriptorException
Syntax
Delphi
EnxMinMaxValidationDescriptorException = class(EnxBaseFieldValidationDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for the Min/Max Validation Descriptor. All errors raised because of a problem in a Min/Max Validation Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxNestedTableDescriptorException Class

EnxNestedTableDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorExceptionnxsdDataDictionary_EnxNestedTableDescriptorException
Syntax
Delphi
EnxNestedTableDescriptorException = class(EnxBaseTableDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for Nested Table Descriptors. All errors raised because of a problem in a Nested Table Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxNoChangeValidationDescriptorException Class

EnxNoChangeValidationDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorExceptionnxsdDataDictionary_EnxNoChangeValidationDescriptorException
Syntax
Delphi
EnxNoChangeValidationDescriptorException = class(EnxBaseFieldValidationDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for the No Change Validation Descriptor. All errors raised because of a problem in a No Change Validation Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxNoNullCompKeyDescriptorException Class

EnxNoNullCompKeyDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorExceptionnxsdDataDictionary_EnxNoNullCompKeyDescriptorException
Syntax
Delphi
EnxNoNullCompKeyDescriptorException = class(EnxCompKeyDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Compound Key descriptors which don't allow null fields.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxRefKeyDescriptorException Class

EnxRefKeyDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorExceptionnxsdDataDictionary_EnxRefKeyDescriptorException
Syntax
Delphi
EnxRefKeyDescriptorException = class(EnxBaseKeyDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Ref Key descriptors.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxSqlCheckValidationDescriptorException Class

EnxSqlCheckValidationDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorExceptionnxsdDataDictionary_EnxSqlCheckValidationDescriptorException
Syntax
Delphi
EnxSqlCheckValidationDescriptorException = class(EnxBaseFieldValidationDescriptorException);
File

nxsdDataDictionary

Description

This is the Exception class for the Sql Check Validation Descriptor. All errors raised because of a problem in a Sql Check Validation Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxTablesDescriptorException Class

EnxTablesDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxTablesDescriptorExceptionnxsdDataDictionary_EnxTablesDescriptorExceptionnxsdDataDictionary_EnxTablesDescriptorExceptionnxsdDataDictionary_EnxTablesDescriptorExceptionnxsdDataDictionary_EnxTablesDescriptorExceptionnxsdDataDictionary_EnxTablesDescriptorException
Syntax
Delphi
EnxTablesDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionary

Description

This is the Exception class for Tables Descriptors. All errors raised because of a problem in a Tables Descriptor class use this or a descendent exception class.

Group

Classes

Links
nxsdDataDictionary, Classes


EnxTextKeyFieldDescriptorException Class

EnxTextKeyFieldDescriptorException Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorExceptionnxsdDataDictionary_EnxTextKeyFieldDescriptorException
Syntax
Delphi
EnxTextKeyFieldDescriptorException = class(EnxKeyFieldDescriptorException);
File

nxsdDataDictionary

Description

This is the exception class used for Text Key Field descriptors.

Group

Classes

Links
nxsdDataDictionary, Classes


TnxAdvAutoIncDescriptor Class

TnxAdvAutoIncDescriptor Class
TnxAdvAutoIncDescriptor Fields TnxAdvAutoIncDescriptor Methods TnxAdvAutoIncDescriptor Properties TnxAdvAutoIncDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptornxsdDataDictionary_TnxAdvAutoIncDescriptor
Syntax
Delphi
TnxAdvAutoIncDescriptor = class(TnxBaseAutoIncDescriptor);
File

nxsdDataDictionary

Description

An advanced AutoInc descriptor with Step and IntialValue.

Group

Classes

Links
TnxAdvAutoIncDescriptor Fields, TnxAdvAutoIncDescriptor Methods, TnxAdvAutoIncDescriptor Properties, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary, Classes


TnxAdvAutoIncDescriptor Members

TnxAdvAutoIncDescriptor Members
TnxAdvAutoIncDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAdvAutoIncDescriptor.

Class

TnxAdvAutoIncDescriptor Class

Protected Fields
Name | Description
aaidInitialValue | private
aaidStep | This is aaidStep, a member of class TnxAdvAutoIncDescriptor.
baidAutoIncEngine | This is baidAutoIncEngine, a member of class TnxBaseAutoIncDescriptor.
baidFileNumber | private
baidHeaderSection | This is baidHeaderSection, a member of class TnxBaseAutoIncDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
aaidSetInitialValue | TnxAdvAutoIncDescriptor
aaidSetStep |
baidSetAutoIncEngine | TnxBaseAutoIncDescriptor
baidSetFileNumber |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
AutoIncEngine | The name of the AutoInc Engine.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the header of the descriptor as string.
ID | Unique ID of the dictionary item
InitialValue | The initial value of the AutoInc generation.
Step | The step between two AutoInc generations.
Links
TnxAdvAutoIncDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAdvAutoIncDescriptor.Create Constructor

TnxAdvAutoIncDescriptor.Create Constructor
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); override;
Class

TnxAdvAutoIncDescriptor Class

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Class


TnxAdvAutoIncDescriptor Fields

TnxAdvAutoIncDescriptor Fields
TnxAdvAutoIncDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxAdvAutoIncDescriptor class are listed here.

Class

TnxAdvAutoIncDescriptor Class

Protected Fields
Name | Description
aaidInitialValue | private
aaidStep | This is aaidStep, a member of class TnxAdvAutoIncDescriptor.
Links
TnxAdvAutoIncDescriptor Class, Legend, Protected Fields


TnxAdvAutoIncDescriptor.aaidInitialValue Field

TnxAdvAutoIncDescriptor.aaidInitialValue Field
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Fields Send Feedback
Syntax
Delphi
aaidInitialValue: TnxAutoIncStepRange;
Description

private

Group

TnxAdvAutoIncDescriptor Fields

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Fields


TnxAdvAutoIncDescriptor.aaidStep Field

TnxAdvAutoIncDescriptor.aaidStep Field
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Fields Send Feedback
Syntax
Delphi
aaidStep: TnxAutoIncStepRange;
Description

This is aaidStep, a member of class TnxAdvAutoIncDescriptor.

Group

TnxAdvAutoIncDescriptor Fields

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Fields


TnxAdvAutoIncDescriptor Methods

TnxAdvAutoIncDescriptor Methods
TnxAdvAutoIncDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAdvAutoIncDescriptor class are listed here.

Class

TnxAdvAutoIncDescriptor Class

Protected Methods
Name | Description
aaidSetInitialValue | TnxAdvAutoIncDescriptor
aaidSetStep |
Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxAdvAutoIncDescriptor Class, Legend, Protected Methods, Public Methods


TnxAdvAutoIncDescriptor.aaidSetInitialValue Method

TnxAdvAutoIncDescriptor.aaidSetInitialValue Method
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure aaidSetInitialValue(const Value: TnxAutoIncStepRange);
Description

TnxAdvAutoIncDescriptor

Group

TnxAdvAutoIncDescriptor Methods

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Methods


TnxAdvAutoIncDescriptor.aaidSetStep Method

TnxAdvAutoIncDescriptor.aaidSetStep Method
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure aaidSetStep(const Value: TnxAutoIncStepRange);
Group

TnxAdvAutoIncDescriptor Methods

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Methods


TnxAdvAutoIncDescriptor.IsEqual Method

TnxAdvAutoIncDescriptor.IsEqual Method
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxAdvAutoIncDescriptor Methods

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Methods


TnxAdvAutoIncDescriptor.LoadFromReader Method

TnxAdvAutoIncDescriptor.LoadFromReader Method
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxAdvAutoIncDescriptor Methods

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Methods


TnxAdvAutoIncDescriptor.SaveToWriter Method

TnxAdvAutoIncDescriptor.SaveToWriter Method
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxAdvAutoIncDescriptor Methods

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Methods


TnxAdvAutoIncDescriptor Properties

TnxAdvAutoIncDescriptor Properties
TnxAdvAutoIncDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxAdvAutoIncDescriptor class are listed here.

Class

TnxAdvAutoIncDescriptor Class

Public Properties
Name | Description
InitialValue | The initial value of the AutoInc generation.
Step | The step between two AutoInc generations.
Links
TnxAdvAutoIncDescriptor Class, Legend, Public Properties


TnxAdvAutoIncDescriptor.InitialValue Property

TnxAdvAutoIncDescriptor.InitialValue Property
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Properties Send Feedback
Syntax
Delphi
property InitialValue: TnxAutoIncStepRange;
Description

The initial value of the AutoInc generation.

Group

TnxAdvAutoIncDescriptor Properties

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Properties


TnxAdvAutoIncDescriptor.Step Property

TnxAdvAutoIncDescriptor.Step Property
TnxAdvAutoIncDescriptor Class TnxAdvAutoIncDescriptor Members nxsdDataDictionary Namespace TnxAdvAutoIncDescriptor Properties Send Feedback
Syntax
Delphi
property Step: TnxAutoIncStepRange;
Description

The step between two AutoInc generations.

Group

TnxAdvAutoIncDescriptor Properties

Links
TnxAdvAutoIncDescriptor Class, TnxAdvAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxAdvAutoIncDescriptor Properties


TnxAutoGuidDefaultValueDescriptor Class

TnxAutoGuidDefaultValueDescriptor Class
TnxAutoGuidDefaultValueDescriptor Methods TnxAutoGuidDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptornxsdDataDictionary_TnxAutoGuidDefaultValueDescriptor
Syntax
Delphi
TnxAutoGuidDefaultValueDescriptor = class(TnxBaseDefaultValueDescriptor);
File

nxsdDataDictionary

Description

This descriptor should be used if you want to set a Guid field to an automatically created new Guid.

Group

Classes

Links
TnxAutoGuidDefaultValueDescriptor Methods, TnxAutoGuidDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxAutoGuidDefaultValueDescriptor Members

TnxAutoGuidDefaultValueDescriptor Members
TnxAutoGuidDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAutoGuidDefaultValueDescriptor.

Class

TnxAutoGuidDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxAutoGuidDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxAutoGuidDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAutoGuidDefaultValueDescriptor Methods

TnxAutoGuidDefaultValueDescriptor Methods
TnxAutoGuidDefaultValueDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxAutoGuidDefaultValueDescriptor class are listed here.

Class

TnxAutoGuidDefaultValueDescriptor Class

Protected Methods
Name | Description
bdvGetInvalidFieldTypes | TnxAutoGuidDefaultValueDescriptor
Links
TnxAutoGuidDefaultValueDescriptor Class, Legend, Protected Methods


TnxAutoGuidDefaultValueDescriptor.bdvGetInvalidFieldTypes Method

TnxAutoGuidDefaultValueDescriptor.bdvGetInvalidFieldTypes Method
TnxAutoGuidDefaultValueDescriptor Class TnxAutoGuidDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxAutoGuidDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function bdvGetInvalidFieldTypes: TnxFieldTypes; override;
Description

TnxAutoGuidDefaultValueDescriptor

Group

TnxAutoGuidDefaultValueDescriptor Methods

Links
TnxAutoGuidDefaultValueDescriptor Class, TnxAutoGuidDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxAutoGuidDefaultValueDescriptor Methods


TnxBaseAutoIncDescriptor Class

TnxBaseAutoIncDescriptor Class
TnxBaseAutoIncDescriptor Fields TnxBaseAutoIncDescriptor Methods TnxBaseAutoIncDescriptor Properties TnxBaseAutoIncDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseAutoIncDescriptornxsdDataDictionary_TnxBaseAutoIncDescriptornxsdDataDictionary_TnxBaseAutoIncDescriptornxsdDataDictionary_TnxBaseAutoIncDescriptornxsdDataDictionary_TnxBaseAutoIncDescriptornxsdDataDictionary_TnxBaseAutoIncDescriptor
Syntax
Delphi
TnxBaseAutoIncDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for AutoInc Descriptors. A AutoInc descriptor specifies the sub-engine that generates the AutoIncs.

Group

Classes

Links
TnxBaseAutoIncDescriptor Fields, TnxBaseAutoIncDescriptor Methods, TnxBaseAutoIncDescriptor Properties, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary, Classes


TnxBaseAutoIncDescriptor Members

TnxBaseAutoIncDescriptor Members
TnxBaseAutoIncDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseAutoIncDescriptor.

Class

TnxBaseAutoIncDescriptor Class

Protected Fields
Name | Description
baidAutoIncEngine | This is baidAutoIncEngine, a member of class TnxBaseAutoIncDescriptor.
baidFileNumber | private
baidHeaderSection | This is baidHeaderSection, a member of class TnxBaseAutoIncDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
baidSetAutoIncEngine | TnxBaseAutoIncDescriptor
baidSetFileNumber |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
AutoIncEngine | The name of the AutoInc Engine.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the header of the descriptor as string.
ID | Unique ID of the dictionary item
Links
TnxBaseAutoIncDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseAutoIncDescriptor.Create Constructor

TnxBaseAutoIncDescriptor.Create Constructor
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); virtual;
Class

TnxBaseAutoIncDescriptor Class

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Class


TnxBaseAutoIncDescriptor.Destroy Destructor

TnxBaseAutoIncDescriptor.Destroy Destructor
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseAutoIncDescriptor Class

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Class


TnxBaseAutoIncDescriptor Fields

TnxBaseAutoIncDescriptor Fields
TnxBaseAutoIncDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseAutoIncDescriptor class are listed here.

Class

TnxBaseAutoIncDescriptor Class

Protected Fields
Name | Description
baidAutoIncEngine | This is baidAutoIncEngine, a member of class TnxBaseAutoIncDescriptor.
baidFileNumber | private
baidHeaderSection | This is baidHeaderSection, a member of class TnxBaseAutoIncDescriptor.
Links
TnxBaseAutoIncDescriptor Class, Legend, Protected Fields


TnxBaseAutoIncDescriptor.baidAutoIncEngine Field

TnxBaseAutoIncDescriptor.baidAutoIncEngine Field
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Fields Send Feedback
Syntax
Delphi
baidAutoIncEngine: string;
Description

This is baidAutoIncEngine, a member of class TnxBaseAutoIncDescriptor.

Group

TnxBaseAutoIncDescriptor Fields

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Fields


TnxBaseAutoIncDescriptor.baidFileNumber Field

TnxBaseAutoIncDescriptor.baidFileNumber Field
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Fields Send Feedback
Syntax
Delphi
baidFileNumber: Integer;
Description

private

Group

TnxBaseAutoIncDescriptor Fields

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Fields


TnxBaseAutoIncDescriptor.baidHeaderSection Field

TnxBaseAutoIncDescriptor.baidHeaderSection Field
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Fields Send Feedback
Syntax
Delphi
baidHeaderSection: AnsiString;
Description

This is baidHeaderSection, a member of class TnxBaseAutoIncDescriptor.

Group

TnxBaseAutoIncDescriptor Fields

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Fields


TnxBaseAutoIncDescriptor Methods

TnxBaseAutoIncDescriptor Methods
TnxBaseAutoIncDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseAutoIncDescriptor class are listed here.

Class

TnxBaseAutoIncDescriptor Class

Protected Methods
Name | Description
baidSetAutoIncEngine | TnxBaseAutoIncDescriptor
baidSetFileNumber |
diFileChangeNotify |
GetList |
Public Methods
Name | Description
CheckValid |
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseAutoIncDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseAutoIncDescriptor.baidSetAutoIncEngine Method

TnxBaseAutoIncDescriptor.baidSetAutoIncEngine Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure baidSetAutoIncEngine(const Value: string);
Description

TnxBaseAutoIncDescriptor

Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.baidSetFileNumber Method

TnxBaseAutoIncDescriptor.baidSetFileNumber Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure baidSetFileNumber(const Value: Integer);
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.CheckValid Method

TnxBaseAutoIncDescriptor.CheckValid Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.diFileChangeNotify Method

TnxBaseAutoIncDescriptor.diFileChangeNotify Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFileChangeNotify(aBefore: Boolean; aOldFile: Integer; aNewFile: Integer); override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.GetList Method

TnxBaseAutoIncDescriptor.GetList Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.IsEqual Method

TnxBaseAutoIncDescriptor.IsEqual Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.LoadFromReader Method

TnxBaseAutoIncDescriptor.LoadFromReader Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor.SaveToWriter Method

TnxBaseAutoIncDescriptor.SaveToWriter Method
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseAutoIncDescriptor Methods

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Methods


TnxBaseAutoIncDescriptor Properties

TnxBaseAutoIncDescriptor Properties
TnxBaseAutoIncDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseAutoIncDescriptor class are listed here.

Class

TnxBaseAutoIncDescriptor Class

Public Properties
Name | Description
AutoIncEngine | The name of the AutoInc Engine.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HeaderSection | Returns the header of the descriptor as string.
Links
TnxBaseAutoIncDescriptor Class, Legend, Public Properties


TnxBaseAutoIncDescriptor.AutoIncEngine Property

TnxBaseAutoIncDescriptor.AutoIncEngine Property
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Properties Send Feedback
Syntax
Delphi
property AutoIncEngine: string;
Description

The name of the AutoInc Engine.

Group

TnxBaseAutoIncDescriptor Properties

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Properties


TnxBaseAutoIncDescriptor.FileNumber Property

TnxBaseAutoIncDescriptor.FileNumber Property
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Properties Send Feedback
Syntax
Delphi
property FileNumber: Integer;
Description

Returns the index of the FileDescriptor of the associated file.

Group

TnxBaseAutoIncDescriptor Properties

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Properties


TnxBaseAutoIncDescriptor.HeaderSection Property

TnxBaseAutoIncDescriptor.HeaderSection Property
TnxBaseAutoIncDescriptor Class TnxBaseAutoIncDescriptor Members nxsdDataDictionary Namespace TnxBaseAutoIncDescriptor Properties Send Feedback
Syntax
Delphi
property HeaderSection: AnsiString;
Description

Returns the header of the descriptor as string.

Group

TnxBaseAutoIncDescriptor Properties

Links
TnxBaseAutoIncDescriptor Class, TnxBaseAutoIncDescriptor Members, nxsdDataDictionary Namespace, TnxBaseAutoIncDescriptor Properties


TnxBaseBlobDescriptor Class

TnxBaseBlobDescriptor Class
TnxBaseBlobDescriptor Fields TnxBaseBlobDescriptor Methods TnxBaseBlobDescriptor Properties TnxBaseBlobDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseBlobDescriptornxsdDataDictionary_TnxBaseBlobDescriptornxsdDataDictionary_TnxBaseBlobDescriptornxsdDataDictionary_TnxBaseBlobDescriptornxsdDataDictionary_TnxBaseBlobDescriptornxsdDataDictionary_TnxBaseBlobDescriptor
Syntax
Delphi
TnxBaseBlobDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for BLOB Descriptors. A Blob descriptor specifies the sub-engine that accesses the blobs.

Group

Classes

Links
TnxBaseBlobDescriptor Fields, TnxBaseBlobDescriptor Methods, TnxBaseBlobDescriptor Properties, TnxBaseBlobDescriptor Members, nxsdDataDictionary, Classes


TnxBaseBlobDescriptor Members

TnxBaseBlobDescriptor Members
TnxBaseBlobDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseBlobDescriptor.

Class

TnxBaseBlobDescriptor Class

Protected Fields
Name | Description
bbdBlobEngine | This is bbdBlobEngine, a member of class TnxBaseBlobDescriptor.
bbdFileNumber | private
bbdHeaderSection | This is bbdHeaderSection, a member of class TnxBaseBlobDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bbdSetBlobEngine | TnxBaseBlobDescriptor
bbdSetFileNumber |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlobEngine | The name of the Blob Engine used to read the blobs.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the header of the descriptor as string.
ID | Unique ID of the dictionary item
Links
TnxBaseBlobDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseBlobDescriptor.Create Constructor

TnxBaseBlobDescriptor.Create Constructor
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); virtual;
Description

constructor.

Class

TnxBaseBlobDescriptor Class

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Class


TnxBaseBlobDescriptor.Destroy Destructor

TnxBaseBlobDescriptor.Destroy Destructor
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseBlobDescriptor Class

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Class


TnxBaseBlobDescriptor Fields

TnxBaseBlobDescriptor Fields
TnxBaseBlobDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseBlobDescriptor class are listed here.

Class

TnxBaseBlobDescriptor Class

Protected Fields
Name | Description
bbdBlobEngine | This is bbdBlobEngine, a member of class TnxBaseBlobDescriptor.
bbdFileNumber | private
bbdHeaderSection | This is bbdHeaderSection, a member of class TnxBaseBlobDescriptor.
Links
TnxBaseBlobDescriptor Class, Legend, Protected Fields


TnxBaseBlobDescriptor.bbdBlobEngine Field

TnxBaseBlobDescriptor.bbdBlobEngine Field
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Fields Send Feedback
Syntax
Delphi
bbdBlobEngine: string;
Description

This is bbdBlobEngine, a member of class TnxBaseBlobDescriptor.

Group

TnxBaseBlobDescriptor Fields

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Fields


TnxBaseBlobDescriptor.bbdFileNumber Field

TnxBaseBlobDescriptor.bbdFileNumber Field
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Fields Send Feedback
Syntax
Delphi
bbdFileNumber: Integer;
Description

private

Group

TnxBaseBlobDescriptor Fields

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Fields


TnxBaseBlobDescriptor.bbdHeaderSection Field

TnxBaseBlobDescriptor.bbdHeaderSection Field
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Fields Send Feedback
Syntax
Delphi
bbdHeaderSection: AnsiString;
Description

This is bbdHeaderSection, a member of class TnxBaseBlobDescriptor.

Group

TnxBaseBlobDescriptor Fields

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Fields


TnxBaseBlobDescriptor Methods

TnxBaseBlobDescriptor Methods
TnxBaseBlobDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseBlobDescriptor class are listed here.

Class

TnxBaseBlobDescriptor Class

Protected Methods
Name | Description
bbdSetBlobEngine | TnxBaseBlobDescriptor
bbdSetFileNumber |
diFileChangeNotify |
Public Methods
Name | Description
CheckValid |
GetList | return the list of default value descriptors.
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseBlobDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseBlobDescriptor.bbdSetBlobEngine Method

TnxBaseBlobDescriptor.bbdSetBlobEngine Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure bbdSetBlobEngine(const Value: string);
Description

TnxBaseBlobDescriptor

Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.bbdSetFileNumber Method

TnxBaseBlobDescriptor.bbdSetFileNumber Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure bbdSetFileNumber(const Value: Integer);
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.CheckValid Method

TnxBaseBlobDescriptor.CheckValid Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.diFileChangeNotify Method

TnxBaseBlobDescriptor.diFileChangeNotify Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFileChangeNotify(aBefore: Boolean; aOldFile: Integer; aNewFile: Integer); override;
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.GetList Method

TnxBaseBlobDescriptor.GetList Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Description

return the list of default value descriptors.

Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.IsEqual Method

TnxBaseBlobDescriptor.IsEqual Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.LoadFromReader Method

TnxBaseBlobDescriptor.LoadFromReader Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor.SaveToWriter Method

TnxBaseBlobDescriptor.SaveToWriter Method
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseBlobDescriptor Methods

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Methods


TnxBaseBlobDescriptor Properties

TnxBaseBlobDescriptor Properties
TnxBaseBlobDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseBlobDescriptor class are listed here.

Class

TnxBaseBlobDescriptor Class

Public Properties
Name | Description
BlobEngine | The name of the Blob Engine used to read the blobs.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HeaderSection | Returns the header of the descriptor as string.
Links
TnxBaseBlobDescriptor Class, Legend, Public Properties


TnxBaseBlobDescriptor.BlobEngine Property

TnxBaseBlobDescriptor.BlobEngine Property
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Properties Send Feedback
Syntax
Delphi
property BlobEngine: string;
Description

The name of the Blob Engine used to read the blobs.

Group

TnxBaseBlobDescriptor Properties

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Properties


TnxBaseBlobDescriptor.FileNumber Property

TnxBaseBlobDescriptor.FileNumber Property
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Properties Send Feedback
Syntax
Delphi
property FileNumber: Integer;
Description

Returns the index of the FileDescriptor of the associated file.

Group

TnxBaseBlobDescriptor Properties

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Properties


TnxBaseBlobDescriptor.HeaderSection Property

TnxBaseBlobDescriptor.HeaderSection Property
TnxBaseBlobDescriptor Class TnxBaseBlobDescriptor Members nxsdDataDictionary Namespace TnxBaseBlobDescriptor Properties Send Feedback
Syntax
Delphi
property HeaderSection: AnsiString;
Description

Returns the header of the descriptor as string.

Group

TnxBaseBlobDescriptor Properties

Links
TnxBaseBlobDescriptor Class, TnxBaseBlobDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlobDescriptor Properties


TnxBaseBlockHeapDescriptor Class

TnxBaseBlockHeapDescriptor Class
TnxBaseBlockHeapDescriptor Fields TnxBaseBlockHeapDescriptor Methods TnxBaseBlockHeapDescriptor Properties TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseBlockHeapDescriptornxsdDataDictionary_TnxBaseBlockHeapDescriptornxsdDataDictionary_TnxBaseBlockHeapDescriptornxsdDataDictionary_TnxBaseBlockHeapDescriptornxsdDataDictionary_TnxBaseBlockHeapDescriptornxsdDataDictionary_TnxBaseBlockHeapDescriptor
Syntax
Delphi
TnxBaseBlockHeapDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for specifying Block management classes. BlockHeap descriptors are used by the Heap Descriptor

Group

Classes

Links
TnxBaseBlockHeapDescriptor Fields, TnxBaseBlockHeapDescriptor Methods, TnxBaseBlockHeapDescriptor Properties, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary, Classes


TnxBaseBlockHeapDescriptor Members

TnxBaseBlockHeapDescriptor Members
TnxBaseBlockHeapDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseBlockHeapDescriptor.

Class

TnxBaseBlockHeapDescriptor Class

Protected Fields
Name | Description
bbhdBlockHeapEngine | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | TnxBaseBlockHeapDescriptor
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlockHeapEngine | The name of the Block Heap Engine.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxBaseBlockHeapDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseBlockHeapDescriptor.Create Constructor

TnxBaseBlockHeapDescriptor.Create Constructor
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent);
Description

TnxBaseBlockHeapDescriptor

Class

TnxBaseBlockHeapDescriptor Class

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Class


TnxBaseBlockHeapDescriptor Fields

TnxBaseBlockHeapDescriptor Fields
TnxBaseBlockHeapDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseBlockHeapDescriptor class are listed here.

Class

TnxBaseBlockHeapDescriptor Class

Protected Fields
Name | Description
bbhdBlockHeapEngine | private
Links
TnxBaseBlockHeapDescriptor Class, Legend, Protected Fields


TnxBaseBlockHeapDescriptor.bbhdBlockHeapEngine Field

TnxBaseBlockHeapDescriptor.bbhdBlockHeapEngine Field
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Fields Send Feedback
Syntax
Delphi
bbhdBlockHeapEngine: string;
Description

private

Group

TnxBaseBlockHeapDescriptor Fields

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Fields


TnxBaseBlockHeapDescriptor Methods

TnxBaseBlockHeapDescriptor Methods
TnxBaseBlockHeapDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseBlockHeapDescriptor class are listed here.

Class

TnxBaseBlockHeapDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseBlockHeapDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseBlockHeapDescriptor.GetList Method

TnxBaseBlockHeapDescriptor.GetList Method
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseBlockHeapDescriptor Methods

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Methods


TnxBaseBlockHeapDescriptor.IsEqual Method

TnxBaseBlockHeapDescriptor.IsEqual Method
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseBlockHeapDescriptor Methods

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Methods


TnxBaseBlockHeapDescriptor.LoadFromReader Method

TnxBaseBlockHeapDescriptor.LoadFromReader Method
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseBlockHeapDescriptor Methods

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Methods


TnxBaseBlockHeapDescriptor.SaveToWriter Method

TnxBaseBlockHeapDescriptor.SaveToWriter Method
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseBlockHeapDescriptor Methods

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Methods


TnxBaseBlockHeapDescriptor Properties

TnxBaseBlockHeapDescriptor Properties
TnxBaseBlockHeapDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseBlockHeapDescriptor class are listed here.

Class

TnxBaseBlockHeapDescriptor Class

Public Properties
Name | Description
BlockHeapEngine | The name of the Block Heap Engine.
Links
TnxBaseBlockHeapDescriptor Class, Legend, Public Properties


TnxBaseBlockHeapDescriptor.BlockHeapEngine Property

TnxBaseBlockHeapDescriptor.BlockHeapEngine Property
TnxBaseBlockHeapDescriptor Class TnxBaseBlockHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseBlockHeapDescriptor Properties Send Feedback
Syntax
Delphi
property BlockHeapEngine: string;
Description

The name of the Block Heap Engine.

Group

TnxBaseBlockHeapDescriptor Properties

Links
TnxBaseBlockHeapDescriptor Class, TnxBaseBlockHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseBlockHeapDescriptor Properties


TnxBaseCustomDescriptor Class

TnxBaseCustomDescriptor Class
TnxBaseCustomDescriptor Fields TnxBaseCustomDescriptor Methods TnxBaseCustomDescriptor Properties TnxBaseCustomDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseCustomDescriptornxsdDataDictionary_TnxBaseCustomDescriptornxsdDataDictionary_TnxBaseCustomDescriptornxsdDataDictionary_TnxBaseCustomDescriptornxsdDataDictionary_TnxBaseCustomDescriptornxsdDataDictionary_TnxBaseCustomDescriptor
Syntax
Delphi
TnxBaseCustomDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

A Custom Descriptor is the base class for Custom Descriptors. Developers should use this class as a base for creating their own Descriptors and store them with tables.

Group

Classes

Links
TnxBaseCustomDescriptor Fields, TnxBaseCustomDescriptor Methods, TnxBaseCustomDescriptor Properties, TnxBaseCustomDescriptor Members, nxsdDataDictionary, Classes


TnxBaseCustomDescriptor Members

TnxBaseCustomDescriptor Members
TnxBaseCustomDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseCustomDescriptor.

Class

TnxBaseCustomDescriptor Class

Protected Fields
Name | Description
bcdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | constructor.
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxBaseCustomDescriptor
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Name | Returns the name of the Custom Descriptor.
Links
TnxBaseCustomDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseCustomDescriptor.Create Constructor

TnxBaseCustomDescriptor.Create Constructor
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; aName: string); virtual;
Description

constructor.

Class

TnxBaseCustomDescriptor Class

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Class


TnxBaseCustomDescriptor Fields

TnxBaseCustomDescriptor Fields
TnxBaseCustomDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseCustomDescriptor class are listed here.

Class

TnxBaseCustomDescriptor Class

Protected Fields
Name | Description
bcdName | private
Links
TnxBaseCustomDescriptor Class, Legend, Protected Fields


TnxBaseCustomDescriptor.bcdName Field

TnxBaseCustomDescriptor.bcdName Field
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Fields Send Feedback
Syntax
Delphi
bcdName: string;
Description

private

Group

TnxBaseCustomDescriptor Fields

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Fields


TnxBaseCustomDescriptor Methods

TnxBaseCustomDescriptor Methods
TnxBaseCustomDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseCustomDescriptor class are listed here.

Class

TnxBaseCustomDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
CheckValid | TnxBaseCustomDescriptor
IsEqual |
Links
TnxBaseCustomDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseCustomDescriptor.CheckValid Method

TnxBaseCustomDescriptor.CheckValid Method
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxBaseCustomDescriptor

Group

TnxBaseCustomDescriptor Methods

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Methods


TnxBaseCustomDescriptor.GetList Method

TnxBaseCustomDescriptor.GetList Method
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseCustomDescriptor Methods

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Methods


TnxBaseCustomDescriptor.IsEqual Method

TnxBaseCustomDescriptor.IsEqual Method
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseCustomDescriptor Methods

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Methods


TnxBaseCustomDescriptor Properties

TnxBaseCustomDescriptor Properties
TnxBaseCustomDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseCustomDescriptor class are listed here.

Class

TnxBaseCustomDescriptor Class

Public Properties
Name | Description
Name | Returns the name of the Custom Descriptor.
Links
TnxBaseCustomDescriptor Class, Legend, Public Properties


TnxBaseCustomDescriptor.Name Property

TnxBaseCustomDescriptor.Name Property
TnxBaseCustomDescriptor Class TnxBaseCustomDescriptor Members nxsdDataDictionary Namespace TnxBaseCustomDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

Returns the name of the Custom Descriptor.

Group

TnxBaseCustomDescriptor Properties

Links
TnxBaseCustomDescriptor Class, TnxBaseCustomDescriptor Members, nxsdDataDictionary Namespace, TnxBaseCustomDescriptor Properties


TnxBaseDefaultValueDescriptor Class

TnxBaseDefaultValueDescriptor Class
TnxBaseDefaultValueDescriptor Fields TnxBaseDefaultValueDescriptor Methods TnxBaseDefaultValueDescriptor Properties TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseDefaultValueDescriptornxsdDataDictionary_TnxBaseDefaultValueDescriptornxsdDataDictionary_TnxBaseDefaultValueDescriptornxsdDataDictionary_TnxBaseDefaultValueDescriptornxsdDataDictionary_TnxBaseDefaultValueDescriptornxsdDataDictionary_TnxBaseDefaultValueDescriptor
Syntax
Delphi
TnxBaseDefaultValueDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for descriptor that describe how a default value of a Field is set. This is an abstract class and must be overridden!

Group

Classes

Links
TnxBaseDefaultValueDescriptor Fields, TnxBaseDefaultValueDescriptor Methods, TnxBaseDefaultValueDescriptor Properties, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxBaseDefaultValueDescriptor Members

TnxBaseDefaultValueDescriptor Members
TnxBaseDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseDefaultValueDescriptor.

Class

TnxBaseDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxBaseDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxBaseDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseDefaultValueDescriptor.Create Constructor

TnxBaseDefaultValueDescriptor.Create Constructor
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseDefaultValueDescriptor Class

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Class


TnxBaseDefaultValueDescriptor Fields

TnxBaseDefaultValueDescriptor Fields
TnxBaseDefaultValueDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseDefaultValueDescriptor class are listed here.

Class

TnxBaseDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
Links
TnxBaseDefaultValueDescriptor Class, Legend, Protected Fields


TnxBaseDefaultValueDescriptor.bdvApplyAt Field

TnxBaseDefaultValueDescriptor.bdvApplyAt Field
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
bdvApplyAt: TnxApplyAtSet;
Description

This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.

Group

TnxBaseDefaultValueDescriptor Fields

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Fields


TnxBaseDefaultValueDescriptor.bdvApplyOnInsert Field

TnxBaseDefaultValueDescriptor.bdvApplyOnInsert Field
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
bdvApplyOnInsert: Boolean;
Description

This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.

Group

TnxBaseDefaultValueDescriptor Fields

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Fields


TnxBaseDefaultValueDescriptor.bdvApplyOnModify Field

TnxBaseDefaultValueDescriptor.bdvApplyOnModify Field
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
bdvApplyOnModify: Boolean;
Description

This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.

Group

TnxBaseDefaultValueDescriptor Fields

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Fields


TnxBaseDefaultValueDescriptor.bdvCachedEngineClass Field

TnxBaseDefaultValueDescriptor.bdvCachedEngineClass Field
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
bdvCachedEngineClass: TClass;
Description

private

Group

TnxBaseDefaultValueDescriptor Fields

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Fields


TnxBaseDefaultValueDescriptor.bdvOverwriteNonNull Field

TnxBaseDefaultValueDescriptor.bdvOverwriteNonNull Field
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
bdvOverwriteNonNull: Boolean;
Description

This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.

Group

TnxBaseDefaultValueDescriptor Fields

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Fields


TnxBaseDefaultValueDescriptor Methods

TnxBaseDefaultValueDescriptor Methods
TnxBaseDefaultValueDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseDefaultValueDescriptor class are listed here.

Class

TnxBaseDefaultValueDescriptor Class

Protected Methods
Name | Description
bdvGetInvalidFieldTypes | TnxBaseDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
Public Methods
Name | Description
CheckValid |
GetList | return the list of default value descriptors.
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseDefaultValueDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseDefaultValueDescriptor.bdvGetInvalidFieldTypes Method

TnxBaseDefaultValueDescriptor.bdvGetInvalidFieldTypes Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function bdvGetInvalidFieldTypes: TnxFieldTypes; virtual;
Description

TnxBaseDefaultValueDescriptor

Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.bdvSetApplyAt Method

TnxBaseDefaultValueDescriptor.bdvSetApplyAt Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure bdvSetApplyAt(const Value: TnxApplyAtSet);
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.bdvSetApplyOnInsert Method

TnxBaseDefaultValueDescriptor.bdvSetApplyOnInsert Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure bdvSetApplyOnInsert(const Value: Boolean);
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.bdvSetApplyOnModify Method

TnxBaseDefaultValueDescriptor.bdvSetApplyOnModify Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure bdvSetApplyOnModify(const Value: Boolean);
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.bdvSetOverwriteNonNull Method

TnxBaseDefaultValueDescriptor.bdvSetOverwriteNonNull Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure bdvSetOverwriteNonNull(const Value: Boolean);
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.CheckValid Method

TnxBaseDefaultValueDescriptor.CheckValid Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.GetList Method

TnxBaseDefaultValueDescriptor.GetList Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Description

return the list of default value descriptors.

Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.IsEqual Method

TnxBaseDefaultValueDescriptor.IsEqual Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.LoadFromReader Method

TnxBaseDefaultValueDescriptor.LoadFromReader Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor.SaveToWriter Method

TnxBaseDefaultValueDescriptor.SaveToWriter Method
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseDefaultValueDescriptor Methods

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Methods


TnxBaseDefaultValueDescriptor Properties

TnxBaseDefaultValueDescriptor Properties
TnxBaseDefaultValueDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseDefaultValueDescriptor class are listed here.

Class

TnxBaseDefaultValueDescriptor Class

Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
OverwriteNonNull | ???
Links
TnxBaseDefaultValueDescriptor Class, Legend, Public Properties


TnxBaseDefaultValueDescriptor.ApplyAt Property

TnxBaseDefaultValueDescriptor.ApplyAt Property
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyAt: TnxApplyAtSet;
Description

Apply the validation object on the server and/or client?

Group

TnxBaseDefaultValueDescriptor Properties

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Properties


TnxBaseDefaultValueDescriptor.ApplyOnInsert Property

TnxBaseDefaultValueDescriptor.ApplyOnInsert Property
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyOnInsert: Boolean;
Description

Should the check be applied on Insert of new record?

Group

TnxBaseDefaultValueDescriptor Properties

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Properties


TnxBaseDefaultValueDescriptor.ApplyOnModify Property

TnxBaseDefaultValueDescriptor.ApplyOnModify Property
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyOnModify: Boolean;
Description

Should the check be applied on record modification?

Group

TnxBaseDefaultValueDescriptor Properties

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Properties


TnxBaseDefaultValueDescriptor.CachedEngineClass Property

TnxBaseDefaultValueDescriptor.CachedEngineClass Property
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.

Group

TnxBaseDefaultValueDescriptor Properties

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Properties


TnxBaseDefaultValueDescriptor.OverwriteNonNull Property

TnxBaseDefaultValueDescriptor.OverwriteNonNull Property
TnxBaseDefaultValueDescriptor Class TnxBaseDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxBaseDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property OverwriteNonNull: Boolean;
Description

???

Group

TnxBaseDefaultValueDescriptor Properties

Links
TnxBaseDefaultValueDescriptor Class, TnxBaseDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxBaseDefaultValueDescriptor Properties


TnxBaseFieldsValidationDescriptor Class

TnxBaseFieldsValidationDescriptor Class
nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptornxsdDataDictionary_TnxBaseFieldsValidationDescriptor
Syntax
Delphi
TnxBaseFieldsValidationDescriptor = class(TnxBaseFieldValidationDescriptor);
File

nxsdDataDictionary

Description

This is the Base class for descriptor that describe how a Table is validated. This is an abstract class and must be overridden!

Group

Classes

Links
nxsdDataDictionary, Classes


TnxBaseFieldValidationDescriptor Class

TnxBaseFieldValidationDescriptor Class
TnxBaseFieldValidationDescriptor Fields TnxBaseFieldValidationDescriptor Methods TnxBaseFieldValidationDescriptor Properties TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseFieldValidationDescriptornxsdDataDictionary_TnxBaseFieldValidationDescriptornxsdDataDictionary_TnxBaseFieldValidationDescriptornxsdDataDictionary_TnxBaseFieldValidationDescriptornxsdDataDictionary_TnxBaseFieldValidationDescriptornxsdDataDictionary_TnxBaseFieldValidationDescriptor
Syntax
Delphi
TnxBaseFieldValidationDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for descriptor that describe how a Field is validated. This is an abstract class and must be overridden!

Group

Classes

Links
TnxBaseFieldValidationDescriptor Fields, TnxBaseFieldValidationDescriptor Methods, TnxBaseFieldValidationDescriptor Properties, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary, Classes


TnxBaseFieldValidationDescriptor Members

TnxBaseFieldValidationDescriptor Members
TnxBaseFieldValidationDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFieldValidationDescriptor.

Class

TnxBaseFieldValidationDescriptor Class

Protected Fields
Name | Description
bvdApplyAt | This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.
bvdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bvdGetApplyAt | TnxBaseFieldValidationDescriptor
bvdGetInvalidFieldTypes |
bvdSetApplyAt |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetInvalidFieldTypes |
GetLifetimeMontior |
GetList | Returns the internal List of Validation Descriptor classes.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Defines if the validation should be done at client and/or server side.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Name | Name of the Validation.
Links
TnxBaseFieldValidationDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseFieldValidationDescriptor.Create Constructor

TnxBaseFieldValidationDescriptor.Create Constructor
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aName: string); virtual;
Class

TnxBaseFieldValidationDescriptor Class

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Class


TnxBaseFieldValidationDescriptor Fields

TnxBaseFieldValidationDescriptor Fields
TnxBaseFieldValidationDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseFieldValidationDescriptor class are listed here.

Class

TnxBaseFieldValidationDescriptor Class

Protected Fields
Name | Description
bvdApplyAt | This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.
bvdName | private
Links
TnxBaseFieldValidationDescriptor Class, Legend, Protected Fields


TnxBaseFieldValidationDescriptor.bvdApplyAt Field

TnxBaseFieldValidationDescriptor.bvdApplyAt Field
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Fields Send Feedback
Syntax
Delphi
bvdApplyAt: TnxApplyAtSet;
Description

This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.

Group

TnxBaseFieldValidationDescriptor Fields

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Fields


TnxBaseFieldValidationDescriptor.bvdName Field

TnxBaseFieldValidationDescriptor.bvdName Field
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Fields Send Feedback
Syntax
Delphi
bvdName: string;
Description

private

Group

TnxBaseFieldValidationDescriptor Fields

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Fields


TnxBaseFieldValidationDescriptor Methods

TnxBaseFieldValidationDescriptor Methods
TnxBaseFieldValidationDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFieldValidationDescriptor class are listed here.

Class

TnxBaseFieldValidationDescriptor Class

Protected Methods
Name | Description
bvdGetApplyAt | TnxBaseFieldValidationDescriptor
bvdGetInvalidFieldTypes |
bvdSetApplyAt |
Public Methods
Name | Description
CheckValid |
GetInvalidFieldTypes |
GetList | Returns the internal List of Validation Descriptor classes.
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseFieldValidationDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseFieldValidationDescriptor.bvdGetApplyAt Method

TnxBaseFieldValidationDescriptor.bvdGetApplyAt Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
function bvdGetApplyAt: TnxApplyAtSet; virtual;
Description

TnxBaseFieldValidationDescriptor

Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.bvdGetInvalidFieldTypes Method

TnxBaseFieldValidationDescriptor.bvdGetInvalidFieldTypes Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
class function bvdGetInvalidFieldTypes: TnxFieldTypes; virtual;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.bvdSetApplyAt Method

TnxBaseFieldValidationDescriptor.bvdSetApplyAt Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure bvdSetApplyAt(const Value: TnxApplyAtSet); virtual;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.CheckValid Method

TnxBaseFieldValidationDescriptor.CheckValid Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.GetInvalidFieldTypes Method

TnxBaseFieldValidationDescriptor.GetInvalidFieldTypes Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
class function GetInvalidFieldTypes: TnxFieldTypes;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.GetList Method

TnxBaseFieldValidationDescriptor.GetList Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Description

Returns the internal List of Validation Descriptor classes.

Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.IsEqual Method

TnxBaseFieldValidationDescriptor.IsEqual Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.LoadFromReader Method

TnxBaseFieldValidationDescriptor.LoadFromReader Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor.SaveToWriter Method

TnxBaseFieldValidationDescriptor.SaveToWriter Method
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseFieldValidationDescriptor Methods

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Methods


TnxBaseFieldValidationDescriptor Properties

TnxBaseFieldValidationDescriptor Properties
TnxBaseFieldValidationDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseFieldValidationDescriptor class are listed here.

Class

TnxBaseFieldValidationDescriptor Class

Public Properties
Name | Description
ApplyAt | Defines if the validation should be done at client and/or server side.
Name | Name of the Validation.
Links
TnxBaseFieldValidationDescriptor Class, Legend, Public Properties


TnxBaseFieldValidationDescriptor.ApplyAt Property

TnxBaseFieldValidationDescriptor.ApplyAt Property
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyAt: TnxApplyAtSet;
Description

Defines if the validation should be done at client and/or server side.

Group

TnxBaseFieldValidationDescriptor Properties

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Properties


TnxBaseFieldValidationDescriptor.Name Property

TnxBaseFieldValidationDescriptor.Name Property
TnxBaseFieldValidationDescriptor Class TnxBaseFieldValidationDescriptor Members nxsdDataDictionary Namespace TnxBaseFieldValidationDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

Name of the Validation.

Group

TnxBaseFieldValidationDescriptor Properties

Links
TnxBaseFieldValidationDescriptor Class, TnxBaseFieldValidationDescriptor Members, nxsdDataDictionary Namespace, TnxBaseFieldValidationDescriptor Properties


TnxBaseHeapDescriptor Class

TnxBaseHeapDescriptor Class
TnxBaseHeapDescriptor Fields TnxBaseHeapDescriptor Methods TnxBaseHeapDescriptor Properties TnxBaseHeapDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseHeapDescriptornxsdDataDictionary_TnxBaseHeapDescriptornxsdDataDictionary_TnxBaseHeapDescriptornxsdDataDictionary_TnxBaseHeapDescriptornxsdDataDictionary_TnxBaseHeapDescriptornxsdDataDictionary_TnxBaseHeapDescriptor
Syntax
Delphi
TnxBaseHeapDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for specifying the Heap management classes.

Group

Classes

Links
TnxBaseHeapDescriptor Fields, TnxBaseHeapDescriptor Methods, TnxBaseHeapDescriptor Properties, TnxBaseHeapDescriptor Members, nxsdDataDictionary, Classes


TnxBaseHeapDescriptor Members

TnxBaseHeapDescriptor Members
TnxBaseHeapDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseHeapDescriptor.

Class

TnxBaseHeapDescriptor Class

Protected Fields
Name | Description
bhdBlockHeapDescriptor | This is bhdBlockHeapDescriptor, a member of class TnxBaseHeapDescriptor.
bhdHeapEngine | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddBlockHeapDescriptor | Sets the Block Heap Descriptor used for Block management
AddBlockHeapDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveBlockHeapDescriptor | Sets the Block Heap descriptor to nil.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlockHeapDescriptor | Returns the Block Heap Descriptor
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeapEngine | The name of the Heap Engine.
ID | Unique ID of the dictionary item
Links
TnxBaseHeapDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseHeapDescriptor.Create Constructor

TnxBaseHeapDescriptor.Create Constructor
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseHeapDescriptor Class

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Class


TnxBaseHeapDescriptor.Destroy Destructor

TnxBaseHeapDescriptor.Destroy Destructor
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseHeapDescriptor Class

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Class


TnxBaseHeapDescriptor Fields

TnxBaseHeapDescriptor Fields
TnxBaseHeapDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseHeapDescriptor class are listed here.

Class

TnxBaseHeapDescriptor Class

Protected Fields
Name | Description
bhdBlockHeapDescriptor | This is bhdBlockHeapDescriptor, a member of class TnxBaseHeapDescriptor.
bhdHeapEngine | private
Links
TnxBaseHeapDescriptor Class, Legend, Protected Fields


TnxBaseHeapDescriptor.bhdBlockHeapDescriptor Field

TnxBaseHeapDescriptor.bhdBlockHeapDescriptor Field
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Fields Send Feedback
Syntax
Delphi
bhdBlockHeapDescriptor: TnxBaseBlockHeapDescriptor;
Description

This is bhdBlockHeapDescriptor, a member of class TnxBaseHeapDescriptor.

Group

TnxBaseHeapDescriptor Fields

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Fields


TnxBaseHeapDescriptor.bhdHeapEngine Field

TnxBaseHeapDescriptor.bhdHeapEngine Field
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Fields Send Feedback
Syntax
Delphi
bhdHeapEngine: string;
Description

private

Group

TnxBaseHeapDescriptor Fields

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Fields


TnxBaseHeapDescriptor Methods

TnxBaseHeapDescriptor Methods
TnxBaseHeapDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseHeapDescriptor class are listed here.

Class

TnxBaseHeapDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
AddBlockHeapDescriptor | Sets the Block Heap Descriptor used for Block management
AddBlockHeapDescriptorT |
CheckValid |
IsEqual |
LoadFromReader |
RemoveBlockHeapDescriptor | Sets the Block Heap descriptor to nil.
SaveToWriter |
Links
TnxBaseHeapDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseHeapDescriptor.AddBlockHeapDescriptor Method

TnxBaseHeapDescriptor.AddBlockHeapDescriptor Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddBlockHeapDescriptor(aBlockHeapClass: TnxBaseBlockHeapDescriptorClass = nil): TnxBaseBlockHeapDescriptor;
Description

Sets the Block Heap Descriptor used for Block management

See Also

AddBlockHeapDescriptor, RemoveBlockHeapDescriptor, BlockHeapDescriptor

TnxBaseHeapDescriptor

Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods, See Also


TnxBaseHeapDescriptor.AddBlockHeapDescriptorT Method

TnxBaseHeapDescriptor.AddBlockHeapDescriptorT Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
function AddBlockHeapDescriptorT<T : TnxBaseBlockHeapDescriptor>: T;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor.CheckValid Method

TnxBaseHeapDescriptor.CheckValid Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor.GetList Method

TnxBaseHeapDescriptor.GetList Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor.IsEqual Method

TnxBaseHeapDescriptor.IsEqual Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor.LoadFromReader Method

TnxBaseHeapDescriptor.LoadFromReader Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor.RemoveBlockHeapDescriptor Method

TnxBaseHeapDescriptor.RemoveBlockHeapDescriptor Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveBlockHeapDescriptor;
Description

Sets the Block Heap descriptor to nil.

See Also

AddBlockHeapDescriptor, RemoveBlockHeapDescriptor, BlockHeapDescriptor.

Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods, See Also


TnxBaseHeapDescriptor.SaveToWriter Method

TnxBaseHeapDescriptor.SaveToWriter Method
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseHeapDescriptor Methods

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Methods


TnxBaseHeapDescriptor Properties

TnxBaseHeapDescriptor Properties
TnxBaseHeapDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseHeapDescriptor class are listed here.

Class

TnxBaseHeapDescriptor Class

Public Properties
Name | Description
BlockHeapDescriptor | Returns the Block Heap Descriptor
HeapEngine | The name of the Heap Engine.
Links
TnxBaseHeapDescriptor Class, Legend, Public Properties


TnxBaseHeapDescriptor.BlockHeapDescriptor Property

TnxBaseHeapDescriptor.BlockHeapDescriptor Property
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Properties See Also Send Feedback
Syntax
Delphi
property BlockHeapDescriptor: TnxBaseBlockHeapDescriptor;
Description

Returns the Block Heap Descriptor

See Also

AddBlockHeapDescriptor, RemoveBlockHeapDescriptor, BlockHeapDescriptor.

Group

TnxBaseHeapDescriptor Properties

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Properties, See Also


TnxBaseHeapDescriptor.HeapEngine Property

TnxBaseHeapDescriptor.HeapEngine Property
TnxBaseHeapDescriptor Class TnxBaseHeapDescriptor Members nxsdDataDictionary Namespace TnxBaseHeapDescriptor Properties Send Feedback
Syntax
Delphi
property HeapEngine: string;
Description

The name of the Heap Engine.

Group

TnxBaseHeapDescriptor Properties

Links
TnxBaseHeapDescriptor Class, TnxBaseHeapDescriptor Members, nxsdDataDictionary Namespace, TnxBaseHeapDescriptor Properties


TnxBaseIndicesDescriptor Class

TnxBaseIndicesDescriptor Class
TnxBaseIndicesDescriptor Fields TnxBaseIndicesDescriptor Methods TnxBaseIndicesDescriptor Properties TnxBaseIndicesDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseIndicesDescriptornxsdDataDictionary_TnxBaseIndicesDescriptornxsdDataDictionary_TnxBaseIndicesDescriptornxsdDataDictionary_TnxBaseIndicesDescriptornxsdDataDictionary_TnxBaseIndicesDescriptornxsdDataDictionary_TnxBaseIndicesDescriptor
Syntax
Delphi
TnxBaseIndicesDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

TnxBaseIndicesDescriptor manages a list of IndexDescriptor classes associated with the data dictionary

Group

Classes

Links
TnxBaseIndicesDescriptor Fields, TnxBaseIndicesDescriptor Methods, TnxBaseIndicesDescriptor Properties, TnxBaseIndicesDescriptor Members, nxsdDataDictionary, Classes


TnxBaseIndicesDescriptor Members

TnxBaseIndicesDescriptor Members
TnxBaseIndicesDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseIndicesDescriptor.

Class

TnxBaseIndicesDescriptor Class

Protected Fields
Name | Description
bidHeaderSection | private
bidIndexChangeNotifies | This is bidIndexChangeNotifies, a member of class TnxBaseIndicesDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bidAddToIndexChangeNotifies |
bidDefaultIndexClass |
bidDefaultKeyClass |
bidIndexChangeNotification |
bidRemoveFromIndexChangeNotifies |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
IndexCount | The number of index descriptors in the list.
IndexDescriptor | The index descriptors for this table.
IndicesEngine | The name of the Indices Engine used for this table.
Public Methods
Name | Description
AddIndex | This is the overview for the AddIndex method overload.
AddIndexT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | Empties the list of Index Descriptors
Create | constructor
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetDescriptorFromName | Return the index descriptor for a given index name, or nil if not found.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
InsertIndexAt | This is the overview for the InsertIndexAt method overload.
InsertIndexAtT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
MoveIndex | Moves an Index Descriptor in the list of descriptors from aFrom to the aTo position
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveIndex | This is the overview for the RemoveIndex method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the Header of the descriptor as string.
ID | Unique ID of the dictionary item
Links
TnxBaseIndicesDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxBaseIndicesDescriptor.Create Constructor

TnxBaseIndicesDescriptor.Create Constructor
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString);
Description

constructor

Class

TnxBaseIndicesDescriptor Class

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Class


TnxBaseIndicesDescriptor.Destroy Destructor

TnxBaseIndicesDescriptor.Destroy Destructor
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseIndicesDescriptor Class

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Class


TnxBaseIndicesDescriptor Fields

TnxBaseIndicesDescriptor Fields
TnxBaseIndicesDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxBaseIndicesDescriptor class are listed here.

Class

TnxBaseIndicesDescriptor Class

Protected Fields
Name | Description
bidHeaderSection | private
bidIndexChangeNotifies | This is bidIndexChangeNotifies, a member of class TnxBaseIndicesDescriptor.
Public Fields
Name | Description
IndexCount | The number of index descriptors in the list.
IndexDescriptor | The index descriptors for this table.
IndicesEngine | The name of the Indices Engine used for this table.
Links
TnxBaseIndicesDescriptor Class, Legend, Protected Fields, Public Fields


TnxBaseIndicesDescriptor.bidHeaderSection Field

TnxBaseIndicesDescriptor.bidHeaderSection Field
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Fields Send Feedback
Syntax
Delphi
bidHeaderSection: AnsiString;
Description

private

Group

TnxBaseIndicesDescriptor Fields

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Fields


TnxBaseIndicesDescriptor.bidIndexChangeNotifies Field

TnxBaseIndicesDescriptor.bidIndexChangeNotifies Field
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Fields Send Feedback
Syntax
Delphi
bidIndexChangeNotifies: TnxSortedList;
Description

This is bidIndexChangeNotifies, a member of class TnxBaseIndicesDescriptor.

Group

TnxBaseIndicesDescriptor Fields

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Fields


TnxBaseIndicesDescriptor.IndexCount Field

TnxBaseIndicesDescriptor.IndexCount Field
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Fields Send Feedback
Syntax
Delphi
IndexCount: Integer;
Description

The number of index descriptors in the list.

Group

TnxBaseIndicesDescriptor Fields

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Fields


TnxBaseIndicesDescriptor.IndexDescriptor Field

TnxBaseIndicesDescriptor.IndexDescriptor Field
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Fields Send Feedback
Syntax
Delphi
IndexDescriptor: array of TnxIndexDescriptor;
Description

The index descriptors for this table.

Group

TnxBaseIndicesDescriptor Fields

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Fields


TnxBaseIndicesDescriptor.IndicesEngine Field

TnxBaseIndicesDescriptor.IndicesEngine Field
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Fields Send Feedback
Syntax
Delphi
IndicesEngine: string;
Description

The name of the Indices Engine used for this table.

Group

TnxBaseIndicesDescriptor Fields

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Fields


TnxBaseIndicesDescriptor Methods

TnxBaseIndicesDescriptor Methods
TnxBaseIndicesDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseIndicesDescriptor class are listed here.

Class

TnxBaseIndicesDescriptor Class

Protected Methods
Name | Description
bidAddToIndexChangeNotifies |
bidDefaultIndexClass |
bidDefaultKeyClass |
bidIndexChangeNotification |
bidRemoveFromIndexChangeNotifies |
GetList |
Public Methods
Name | Description
AddIndex | This is the overview for the AddIndex method overload.
AddIndexT |
CheckValid |
Clear | Empties the list of Index Descriptors
GetDescriptorFromName | Return the index descriptor for a given index name, or nil if not found.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
InsertIndexAt | This is the overview for the InsertIndexAt method overload.
InsertIndexAtT |
IsEqual |
LoadFromReader |
MoveIndex | Moves an Index Descriptor in the list of descriptors from aFrom to the aTo position
RemoveIndex | This is the overview for the RemoveIndex method overload.
SaveToWriter |
Links
TnxBaseIndicesDescriptor Class, Legend, Protected Methods, Public Methods


AddIndex Method

AddIndex Method
TnxBaseIndicesDescriptor Methods Send Feedback

This is the overview for the AddIndex method overload.

Overload List
Name | Description
TnxBaseIndicesDescriptor.AddIndex (string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass) |
TnxBaseIndicesDescriptor.AddIndex (string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass) | This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance.
TnxBaseIndicesDescriptor.AddIndex (TnxIndexDescriptor) | This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance.
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.AddIndex Method (TnxIndexDescriptor)

TnxBaseIndicesDescriptor.AddIndex Method (TnxIndexDescriptor)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace AddIndex Method Send Feedback
Syntax
Delphi
function AddIndex(aIndexDescriptor: TnxIndexDescriptor): TnxIndexDescriptor; overload;
Parameters
Parameters | Description
aIndexClass | the class of the instance to be created.
Description

This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance.

Group

AddIndex Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, AddIndex Method


TnxBaseIndicesDescriptor.AddIndex Method (string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)

TnxBaseIndicesDescriptor.AddIndex Method (string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace AddIndex Method Send Feedback
Syntax
Delphi
function AddIndex(const aName: string; aFileNumber: Integer; aDups: Boolean; const aDesc: string = ''; aKeyClass: TnxKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor; dynamic; overload;
Group

AddIndex Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, AddIndex Method


TnxBaseIndicesDescriptor.AddIndex Method (string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)

TnxBaseIndicesDescriptor.AddIndex Method (string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace AddIndex Method Send Feedback
Syntax
Delphi
function AddIndex(const aName: string; aFileNumber: Integer; aDups: TnxIndexDups; const aDesc: string = ''; aKeyClass: TnxKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor; dynamic; overload;
Parameters
Parameters | Description
const aName: string | the name of the index
aFileNumber: Integer | the file the Index is stored in
aDups: TnxIndexDups | set to True if duplicates are allowed for this index
const aDesc: string = '' | a human readable description of the field
aKeyClass: TnxKeyDescriptorClass = nil | the class for the Key Descriptor to use
aIndexClass: TnxIndexDescriptorClass = nil | the class of the instance to be created. TnxBaseIndicesDescriptor
Description

This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance.

Group

AddIndex Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, AddIndex Method


TnxBaseIndicesDescriptor.AddIndexT Method

TnxBaseIndicesDescriptor.AddIndexT Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function AddIndexT<T: TnxBaseKeyDescriptor>(const aName: string; aFileNumber: Integer; aDups: TnxIndexDups; const aDesc: string = ''): TnxIndexDescriptor<T>;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.bidAddToIndexChangeNotifies Method

TnxBaseIndicesDescriptor.bidAddToIndexChangeNotifies Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure bidAddToIndexChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.bidDefaultIndexClass Method

TnxBaseIndicesDescriptor.bidDefaultIndexClass Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function bidDefaultIndexClass: TnxIndexDescriptorClass; virtual;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.bidDefaultKeyClass Method

TnxBaseIndicesDescriptor.bidDefaultKeyClass Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function bidDefaultKeyClass: TnxKeyDescriptorClass; virtual;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.bidIndexChangeNotification Method

TnxBaseIndicesDescriptor.bidIndexChangeNotification Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure bidIndexChangeNotification(aBefore: Boolean; aOldIndex: Integer; aNewIndex: Integer); virtual;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.bidRemoveFromIndexChangeNotifies Method

TnxBaseIndicesDescriptor.bidRemoveFromIndexChangeNotifies Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure bidRemoveFromIndexChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.CheckValid Method

TnxBaseIndicesDescriptor.CheckValid Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.Clear Method

TnxBaseIndicesDescriptor.Clear Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear(aNotify: Boolean); virtual;
Description

Empties the list of Index Descriptors

Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.GetDescriptorFromName Method

TnxBaseIndicesDescriptor.GetDescriptorFromName Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function GetDescriptorFromName(const aIndexName: string): TnxIndexDescriptor;
Description

Return the index descriptor for a given index name, or nil if not found.

Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.GetIndexFromName Method

TnxBaseIndicesDescriptor.GetIndexFromName Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function GetIndexFromName(const aIndexName: string): Integer;
Description

Return the index number for a given index name, or -1 if not found.

Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.GetList Method

TnxBaseIndicesDescriptor.GetList Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


InsertIndexAt Method

InsertIndexAt Method
TnxBaseIndicesDescriptor Methods Send Feedback

This is the overview for the InsertIndexAt method overload.

Overload List
Name | Description
TnxBaseIndicesDescriptor.InsertIndexAt (Integer, string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass) |
TnxBaseIndicesDescriptor.InsertIndexAt (Integer, string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass) | This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance. The index is inserted into the array at position aInx and the rest of the index array indexes are adjusted.
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.InsertIndexAt Method (Integer, string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)

TnxBaseIndicesDescriptor.InsertIndexAt Method (Integer, string, Integer, Boolean, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace InsertIndexAt Method Send Feedback
Syntax
Delphi
function InsertIndexAt(aInx: Integer; const aName: string; aFileNumber: Integer; aDups: Boolean; const aDesc: string = ''; aKeyClass: TnxKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor; overload;
Group

InsertIndexAt Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, InsertIndexAt Method


TnxBaseIndicesDescriptor.InsertIndexAt Method (Integer, string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)

TnxBaseIndicesDescriptor.InsertIndexAt Method (Integer, string, Integer, TnxIndexDups, string, TnxKeyDescriptorClass, TnxIndexDescriptorClass)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace InsertIndexAt Method Send Feedback
Syntax
Delphi
function InsertIndexAt(aInx: Integer; const aName: string; aFileNumber: Integer; aDups: TnxIndexDups; const aDesc: string = ''; aKeyClass: TnxKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor; overload;
Parameters
Parameters | Description
aInx: Integer | the index of the new field
const aName: string | the name of the index
aFileNumber: Integer | the file the Index is stored in
aDups: TnxIndexDups | set to True if duplicates are allowed for this index
const aDesc: string = '' | a human readable description of the field
aKeyClass: TnxKeyDescriptorClass = nil | the class for the Key Descriptor to use
aIndexClass: TnxIndexDescriptorClass = nil | the class of the instance to be created.
Description

This function adds a new instance of an Index Descriptor to the indices descriptor and returns the newly created Instance. The index is inserted into the array at position aInx and the rest of the index array indexes are adjusted.

Group

InsertIndexAt Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, InsertIndexAt Method


TnxBaseIndicesDescriptor.InsertIndexAtT Method

TnxBaseIndicesDescriptor.InsertIndexAtT Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function InsertIndexAtT<T: TnxIndexDescriptor>(aInx: Integer; const aName: string; aFileNumber: Integer; aDups: TnxIndexDups; const aDesc: string = ''; aKeyClass: TnxKeyDescriptorClass = nil): T;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.IsEqual Method

TnxBaseIndicesDescriptor.IsEqual Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.LoadFromReader Method

TnxBaseIndicesDescriptor.LoadFromReader Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.MoveIndex Method

TnxBaseIndicesDescriptor.MoveIndex Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure MoveIndex(aFrom: Integer; aTo: Integer);
Description

Moves an Index Descriptor in the list of descriptors from aFrom to the aTo position

Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


RemoveIndex Method

RemoveIndex Method
TnxBaseIndicesDescriptor Methods Send Feedback

This is the overview for the RemoveIndex method overload.

Overload List
Name | Description
TnxBaseIndicesDescriptor.RemoveIndex (Integer) | Remove an Index Descriptor from the Data Dictionary.
TnxBaseIndicesDescriptor.RemoveIndex (string) | Remove an Index Descriptor from the Data Dictionary.
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor.RemoveIndex Method (Integer)

TnxBaseIndicesDescriptor.RemoveIndex Method (Integer)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace RemoveIndex Method Send Feedback
Syntax
Delphi
procedure RemoveIndex(aInx: Integer); overload;
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of Index Descriptors.
Description

Remove an Index Descriptor from the Data Dictionary.

Group

RemoveIndex Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, RemoveIndex Method


TnxBaseIndicesDescriptor.RemoveIndex Method (string)

TnxBaseIndicesDescriptor.RemoveIndex Method (string)
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace RemoveIndex Method Send Feedback
Syntax
Delphi
procedure RemoveIndex(const aName: string); overload;
Parameters
Parameters | Description
const aName: string | the name of the descriptor to be removed in the list of Index Descriptors.
Description

Remove an Index Descriptor from the Data Dictionary.

Group

RemoveIndex Method

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, RemoveIndex Method


TnxBaseIndicesDescriptor.SaveToWriter Method

TnxBaseIndicesDescriptor.SaveToWriter Method
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseIndicesDescriptor Methods

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Methods


TnxBaseIndicesDescriptor Properties

TnxBaseIndicesDescriptor Properties
TnxBaseIndicesDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseIndicesDescriptor class are listed here.

Class

TnxBaseIndicesDescriptor Class

Public Properties
Name | Description
HeaderSection | Returns the Header of the descriptor as string.
Links
TnxBaseIndicesDescriptor Class, Legend, Public Properties


TnxBaseIndicesDescriptor.HeaderSection Property

TnxBaseIndicesDescriptor.HeaderSection Property
TnxBaseIndicesDescriptor Class TnxBaseIndicesDescriptor Members nxsdDataDictionary Namespace TnxBaseIndicesDescriptor Properties Send Feedback
Syntax
Delphi
property HeaderSection: AnsiString;
Description

Returns the Header of the descriptor as string.

Group

TnxBaseIndicesDescriptor Properties

Links
TnxBaseIndicesDescriptor Class, TnxBaseIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxBaseIndicesDescriptor Properties


TnxBaseKeyDescriptor Class

TnxBaseKeyDescriptor Class
TnxBaseKeyDescriptor Fields TnxBaseKeyDescriptor Methods TnxBaseKeyDescriptor Properties TnxBaseKeyDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseKeyDescriptornxsdDataDictionary_TnxBaseKeyDescriptornxsdDataDictionary_TnxBaseKeyDescriptornxsdDataDictionary_TnxBaseKeyDescriptornxsdDataDictionary_TnxBaseKeyDescriptornxsdDataDictionary_TnxBaseKeyDescriptor
Syntax
Delphi
TnxBaseKeyDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

The base class of all Key Descriptors. A Key descriptor is used to create a key out of a record. Mainly it is used for creating indexes, but can of course also be used for other purposes.

Group

Classes

Links
TnxBaseKeyDescriptor Fields, TnxBaseKeyDescriptor Methods, TnxBaseKeyDescriptor Properties, TnxBaseKeyDescriptor Members, nxsdDataDictionary, Classes


TnxBaseKeyDescriptor Members

TnxBaseKeyDescriptor Members
TnxBaseKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseKeyDescriptor.

Class

TnxBaseKeyDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bkdGetKeyLen | This is bkdGetKeyLen, a member of class TnxBaseKeyDescriptor.
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
IsValidFor |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls | TnxBaseKeyDescriptor
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyLen | This property returns the length of the created keys.
Links
TnxBaseKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxBaseKeyDescriptor.Create Constructor

TnxBaseKeyDescriptor.Create Constructor
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseKeyDescriptor Class

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Class


TnxBaseKeyDescriptor.Destroy Destructor

TnxBaseKeyDescriptor.Destroy Destructor
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseKeyDescriptor Class

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Class


TnxBaseKeyDescriptor Fields

TnxBaseKeyDescriptor Fields
TnxBaseKeyDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxBaseKeyDescriptor class are listed here.

Class

TnxBaseKeyDescriptor Class

Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Links
TnxBaseKeyDescriptor Class, Legend, Public Fields


TnxBaseKeyDescriptor.Filter Field

TnxBaseKeyDescriptor.Filter Field
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Fields Send Feedback
Syntax
Delphi
Filter: TnxBaseFilterDescriptor;
Description

Internal use only - The current Filter the key is used in (if any)

Group

TnxBaseKeyDescriptor Fields

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Fields


TnxBaseKeyDescriptor Methods

TnxBaseKeyDescriptor Methods
TnxBaseKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseKeyDescriptor class are listed here.

Class

TnxBaseKeyDescriptor Class

Protected Methods
Name | Description
bkdGetKeyLen | This is bkdGetKeyLen, a member of class TnxBaseKeyDescriptor.
GetList |
IsValidFor |
Public Methods
Name | Description
CanContainNulls | TnxBaseKeyDescriptor
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseKeyDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseKeyDescriptor.bkdGetKeyLen Method

TnxBaseKeyDescriptor.bkdGetKeyLen Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; virtual; abstract;
Description

This is bkdGetKeyLen, a member of class TnxBaseKeyDescriptor.

Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.CanContainNulls Method

TnxBaseKeyDescriptor.CanContainNulls Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; virtual;
Description

TnxBaseKeyDescriptor

Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.GetList Method

TnxBaseKeyDescriptor.GetList Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.IsEqual Method

TnxBaseKeyDescriptor.IsEqual Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.IsValidFor Method

TnxBaseKeyDescriptor.IsValidFor Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
function IsValidFor(aDescriptor: TnxBaseTableDescriptor): Boolean; virtual;
Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.LoadFromReader Method

TnxBaseKeyDescriptor.LoadFromReader Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor.SaveToWriter Method

TnxBaseKeyDescriptor.SaveToWriter Method
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseKeyDescriptor Methods

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Methods


TnxBaseKeyDescriptor Properties

TnxBaseKeyDescriptor Properties
TnxBaseKeyDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseKeyDescriptor class are listed here.

Class

TnxBaseKeyDescriptor Class

Public Properties
Name | Description
KeyLen | This property returns the length of the created keys.
Links
TnxBaseKeyDescriptor Class, Legend, Public Properties


TnxBaseKeyDescriptor.KeyLen Property

TnxBaseKeyDescriptor.KeyLen Property
TnxBaseKeyDescriptor Class TnxBaseKeyDescriptor Members nxsdDataDictionary Namespace TnxBaseKeyDescriptor Properties Send Feedback
Syntax
Delphi
property KeyLen: TnxWord32;
Description

This property returns the length of the created keys.

Group

TnxBaseKeyDescriptor Properties

Links
TnxBaseKeyDescriptor Class, TnxBaseKeyDescriptor Members, nxsdDataDictionary Namespace, TnxBaseKeyDescriptor Properties


TnxBaseRecordCompressionDescriptor Class

TnxBaseRecordCompressionDescriptor Class
TnxBaseRecordCompressionDescriptor Fields TnxBaseRecordCompressionDescriptor Methods TnxBaseRecordCompressionDescriptor Properties TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseRecordCompressionDescriptornxsdDataDictionary_TnxBaseRecordCompressionDescriptornxsdDataDictionary_TnxBaseRecordCompressionDescriptornxsdDataDictionary_TnxBaseRecordCompressionDescriptornxsdDataDictionary_TnxBaseRecordCompressionDescriptornxsdDataDictionary_TnxBaseRecordCompressionDescriptor
Syntax
Delphi
TnxBaseRecordCompressionDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

A compression descriptor describes the compression engine used for the associated table.

Group

Classes

Links
TnxBaseRecordCompressionDescriptor Fields, TnxBaseRecordCompressionDescriptor Methods, TnxBaseRecordCompressionDescriptor Properties, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary, Classes


TnxBaseRecordCompressionDescriptor Members

TnxBaseRecordCompressionDescriptor Members
TnxBaseRecordCompressionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseRecordCompressionDescriptor.

Class

TnxBaseRecordCompressionDescriptor Class

Protected Fields
Name | Description
brcdRecordCompressionEngine | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
brcdGetCompressType | TnxBaseRecordCompressionDescriptor
brcdSetCompressType |
brcdSetRecordCompressionEngine |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CompressType | This is CompressType, a member of class TnxBaseRecordCompressionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
RecordCompressionEngine | Returns the name name of the registered Record Compression Engine
Links
TnxBaseRecordCompressionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseRecordCompressionDescriptor.Create Constructor

TnxBaseRecordCompressionDescriptor.Create Constructor
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseRecordCompressionDescriptor Class

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Class


TnxBaseRecordCompressionDescriptor Fields

TnxBaseRecordCompressionDescriptor Fields
TnxBaseRecordCompressionDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseRecordCompressionDescriptor class are listed here.

Class

TnxBaseRecordCompressionDescriptor Class

Protected Fields
Name | Description
brcdRecordCompressionEngine | private
Links
TnxBaseRecordCompressionDescriptor Class, Legend, Protected Fields


TnxBaseRecordCompressionDescriptor.brcdRecordCompressionEngine Field

TnxBaseRecordCompressionDescriptor.brcdRecordCompressionEngine Field
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Fields Send Feedback
Syntax
Delphi
brcdRecordCompressionEngine: string;
Description

private

Group

TnxBaseRecordCompressionDescriptor Fields

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Fields


TnxBaseRecordCompressionDescriptor Methods

TnxBaseRecordCompressionDescriptor Methods
TnxBaseRecordCompressionDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRecordCompressionDescriptor class are listed here.

Class

TnxBaseRecordCompressionDescriptor Class

Protected Methods
Name | Description
brcdGetCompressType | TnxBaseRecordCompressionDescriptor
brcdSetCompressType |
brcdSetRecordCompressionEngine |
GetList |
Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseRecordCompressionDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseRecordCompressionDescriptor.brcdGetCompressType Method

TnxBaseRecordCompressionDescriptor.brcdGetCompressType Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
function brcdGetCompressType: Byte;
Description

TnxBaseRecordCompressionDescriptor

Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.brcdSetCompressType Method

TnxBaseRecordCompressionDescriptor.brcdSetCompressType Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
procedure brcdSetCompressType(const Value: Byte);
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.brcdSetRecordCompressionEngine Method

TnxBaseRecordCompressionDescriptor.brcdSetRecordCompressionEngine Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
procedure brcdSetRecordCompressionEngine(const Value: string);
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.GetList Method

TnxBaseRecordCompressionDescriptor.GetList Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.IsEqual Method

TnxBaseRecordCompressionDescriptor.IsEqual Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.LoadFromReader Method

TnxBaseRecordCompressionDescriptor.LoadFromReader Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor.SaveToWriter Method

TnxBaseRecordCompressionDescriptor.SaveToWriter Method
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseRecordCompressionDescriptor Methods

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Methods


TnxBaseRecordCompressionDescriptor Properties

TnxBaseRecordCompressionDescriptor Properties
TnxBaseRecordCompressionDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseRecordCompressionDescriptor class are listed here.

Class

TnxBaseRecordCompressionDescriptor Class

Public Properties
Name | Description
CompressType | This is CompressType, a member of class TnxBaseRecordCompressionDescriptor.
RecordCompressionEngine | Returns the name name of the registered Record Compression Engine
Links
TnxBaseRecordCompressionDescriptor Class, Legend, Public Properties


TnxBaseRecordCompressionDescriptor.CompressType Property

TnxBaseRecordCompressionDescriptor.CompressType Property
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Properties Send Feedback
Syntax
Delphi
property CompressType: Byte;
Description

This is CompressType, a member of class TnxBaseRecordCompressionDescriptor.

Group

TnxBaseRecordCompressionDescriptor Properties

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Properties


TnxBaseRecordCompressionDescriptor.RecordCompressionEngine Property

TnxBaseRecordCompressionDescriptor.RecordCompressionEngine Property
TnxBaseRecordCompressionDescriptor Class TnxBaseRecordCompressionDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordCompressionDescriptor Properties Send Feedback
Syntax
Delphi
property RecordCompressionEngine: string;
Description

Returns the name name of the registered Record Compression Engine

Group

TnxBaseRecordCompressionDescriptor Properties

Links
TnxBaseRecordCompressionDescriptor Class, TnxBaseRecordCompressionDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordCompressionDescriptor Properties


TnxBaseRecordDescriptor Class

TnxBaseRecordDescriptor Class
TnxBaseRecordDescriptor Fields TnxBaseRecordDescriptor Methods TnxBaseRecordDescriptor Properties TnxBaseRecordDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseRecordDescriptornxsdDataDictionary_TnxBaseRecordDescriptornxsdDataDictionary_TnxBaseRecordDescriptornxsdDataDictionary_TnxBaseRecordDescriptornxsdDataDictionary_TnxBaseRecordDescriptornxsdDataDictionary_TnxBaseRecordDescriptor
Syntax
Delphi
TnxBaseRecordDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for Record Descriptors. A record descriptor is used for specifying the Record Engine used to read records from a table.

Group

Classes

Links
TnxBaseRecordDescriptor Fields, TnxBaseRecordDescriptor Methods, TnxBaseRecordDescriptor Properties, TnxBaseRecordDescriptor Members, nxsdDataDictionary, Classes


TnxBaseRecordDescriptor Members

TnxBaseRecordDescriptor Members
TnxBaseRecordDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseRecordDescriptor.

Class

TnxBaseRecordDescriptor Class

Protected Fields
Name | Description
brdFileNumber | private
brdHeaderSection | This is brdHeaderSection, a member of class TnxBaseRecordDescriptor.
brdRecordEngine | This is brdRecordEngine, a member of class TnxBaseRecordDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
brdSetFileNumber | TnxBaseRecordDescriptor
brdSetRecordEngine |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor the record is associated with.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the descriptor Header as string.
ID | Unique ID of the dictionary item
RecordEngine | The Name of the Record Engine used.
Links
TnxBaseRecordDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseRecordDescriptor.Create Constructor

TnxBaseRecordDescriptor.Create Constructor
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); virtual;
Class

TnxBaseRecordDescriptor Class

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Class


TnxBaseRecordDescriptor.Destroy Destructor

TnxBaseRecordDescriptor.Destroy Destructor
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseRecordDescriptor Class

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Class


TnxBaseRecordDescriptor Fields

TnxBaseRecordDescriptor Fields
TnxBaseRecordDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseRecordDescriptor class are listed here.

Class

TnxBaseRecordDescriptor Class

Protected Fields
Name | Description
brdFileNumber | private
brdHeaderSection | This is brdHeaderSection, a member of class TnxBaseRecordDescriptor.
brdRecordEngine | This is brdRecordEngine, a member of class TnxBaseRecordDescriptor.
Links
TnxBaseRecordDescriptor Class, Legend, Protected Fields


TnxBaseRecordDescriptor.brdFileNumber Field

TnxBaseRecordDescriptor.brdFileNumber Field
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Fields Send Feedback
Syntax
Delphi
brdFileNumber: Integer;
Description

private

Group

TnxBaseRecordDescriptor Fields

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Fields


TnxBaseRecordDescriptor.brdHeaderSection Field

TnxBaseRecordDescriptor.brdHeaderSection Field
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Fields Send Feedback
Syntax
Delphi
brdHeaderSection: AnsiString;
Description

This is brdHeaderSection, a member of class TnxBaseRecordDescriptor.

Group

TnxBaseRecordDescriptor Fields

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Fields


TnxBaseRecordDescriptor.brdRecordEngine Field

TnxBaseRecordDescriptor.brdRecordEngine Field
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Fields Send Feedback
Syntax
Delphi
brdRecordEngine: string;
Description

This is brdRecordEngine, a member of class TnxBaseRecordDescriptor.

Group

TnxBaseRecordDescriptor Fields

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Fields


TnxBaseRecordDescriptor Methods

TnxBaseRecordDescriptor Methods
TnxBaseRecordDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRecordDescriptor class are listed here.

Class

TnxBaseRecordDescriptor Class

Protected Methods
Name | Description
brdSetFileNumber | TnxBaseRecordDescriptor
brdSetRecordEngine |
diFileChangeNotify |
GetList |
Public Methods
Name | Description
CheckValid |
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseRecordDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseRecordDescriptor.brdSetFileNumber Method

TnxBaseRecordDescriptor.brdSetFileNumber Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure brdSetFileNumber(const Value: Integer);
Description

TnxBaseRecordDescriptor

Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.brdSetRecordEngine Method

TnxBaseRecordDescriptor.brdSetRecordEngine Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure brdSetRecordEngine(const Value: string);
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.CheckValid Method

TnxBaseRecordDescriptor.CheckValid Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.diFileChangeNotify Method

TnxBaseRecordDescriptor.diFileChangeNotify Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFileChangeNotify(aBefore: Boolean; aOldFile: Integer; aNewFile: Integer); override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.GetList Method

TnxBaseRecordDescriptor.GetList Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.IsEqual Method

TnxBaseRecordDescriptor.IsEqual Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.LoadFromReader Method

TnxBaseRecordDescriptor.LoadFromReader Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor.SaveToWriter Method

TnxBaseRecordDescriptor.SaveToWriter Method
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseRecordDescriptor Methods

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Methods


TnxBaseRecordDescriptor Properties

TnxBaseRecordDescriptor Properties
TnxBaseRecordDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseRecordDescriptor class are listed here.

Class

TnxBaseRecordDescriptor Class

Public Properties
Name | Description
FileNumber | Returns the index of the FileDescriptor the record is associated with.
HeaderSection | Returns the descriptor Header as string.
RecordEngine | The Name of the Record Engine used.
Links
TnxBaseRecordDescriptor Class, Legend, Public Properties


TnxBaseRecordDescriptor.FileNumber Property

TnxBaseRecordDescriptor.FileNumber Property
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Properties Send Feedback
Syntax
Delphi
property FileNumber: Integer;
Description

Returns the index of the FileDescriptor the record is associated with.

Group

TnxBaseRecordDescriptor Properties

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Properties


TnxBaseRecordDescriptor.HeaderSection Property

TnxBaseRecordDescriptor.HeaderSection Property
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Properties Send Feedback
Syntax
Delphi
property HeaderSection: AnsiString;
Description

Returns the descriptor Header as string.

Group

TnxBaseRecordDescriptor Properties

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Properties


TnxBaseRecordDescriptor.RecordEngine Property

TnxBaseRecordDescriptor.RecordEngine Property
TnxBaseRecordDescriptor Class TnxBaseRecordDescriptor Members nxsdDataDictionary Namespace TnxBaseRecordDescriptor Properties Send Feedback
Syntax
Delphi
property RecordEngine: string;
Description

The Name of the Record Engine used.

Group

TnxBaseRecordDescriptor Properties

Links
TnxBaseRecordDescriptor Class, TnxBaseRecordDescriptor Members, nxsdDataDictionary Namespace, TnxBaseRecordDescriptor Properties


TnxBaseStreamDescriptor Class

TnxBaseStreamDescriptor Class
TnxBaseStreamDescriptor Fields TnxBaseStreamDescriptor Methods TnxBaseStreamDescriptor Properties TnxBaseStreamDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseStreamDescriptornxsdDataDictionary_TnxBaseStreamDescriptornxsdDataDictionary_TnxBaseStreamDescriptornxsdDataDictionary_TnxBaseStreamDescriptornxsdDataDictionary_TnxBaseStreamDescriptornxsdDataDictionary_TnxBaseStreamDescriptor
Syntax
Delphi
TnxBaseStreamDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the base class for Stream Descriptors. A Stream descriptor specifies the sub-engine that generates the Streams.

Group

Classes

Links
TnxBaseStreamDescriptor Fields, TnxBaseStreamDescriptor Methods, TnxBaseStreamDescriptor Properties, TnxBaseStreamDescriptor Members, nxsdDataDictionary, Classes


TnxBaseStreamDescriptor Members

TnxBaseStreamDescriptor Members
TnxBaseStreamDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseStreamDescriptor.

Class

TnxBaseStreamDescriptor Class

Protected Fields
Name | Description
bsdHeaderSection | This is bsdHeaderSection, a member of class TnxBaseStreamDescriptor.
bsdStreamEngine | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bsdSetStreamEngine | TnxBaseStreamDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the header of the descriptor as string.
ID | Unique ID of the dictionary item
StreamEngine | The name of the Stream Engine.
Links
TnxBaseStreamDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseStreamDescriptor.Create Constructor

TnxBaseStreamDescriptor.Create Constructor
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString);
Class

TnxBaseStreamDescriptor Class

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Class


TnxBaseStreamDescriptor Fields

TnxBaseStreamDescriptor Fields
TnxBaseStreamDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseStreamDescriptor class are listed here.

Class

TnxBaseStreamDescriptor Class

Protected Fields
Name | Description
bsdHeaderSection | This is bsdHeaderSection, a member of class TnxBaseStreamDescriptor.
bsdStreamEngine | private
Links
TnxBaseStreamDescriptor Class, Legend, Protected Fields


TnxBaseStreamDescriptor.bsdHeaderSection Field

TnxBaseStreamDescriptor.bsdHeaderSection Field
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Fields Send Feedback
Syntax
Delphi
bsdHeaderSection: AnsiString;
Description

This is bsdHeaderSection, a member of class TnxBaseStreamDescriptor.

Group

TnxBaseStreamDescriptor Fields

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Fields


TnxBaseStreamDescriptor.bsdStreamEngine Field

TnxBaseStreamDescriptor.bsdStreamEngine Field
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Fields Send Feedback
Syntax
Delphi
bsdStreamEngine: string;
Description

private

Group

TnxBaseStreamDescriptor Fields

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Fields


TnxBaseStreamDescriptor Methods

TnxBaseStreamDescriptor Methods
TnxBaseStreamDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseStreamDescriptor class are listed here.

Class

TnxBaseStreamDescriptor Class

Protected Methods
Name | Description
bsdSetStreamEngine | TnxBaseStreamDescriptor
GetList |
Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxBaseStreamDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseStreamDescriptor.bsdSetStreamEngine Method

TnxBaseStreamDescriptor.bsdSetStreamEngine Method
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Methods Send Feedback
Syntax
Delphi
procedure bsdSetStreamEngine(const Value: string);
Description

TnxBaseStreamDescriptor

Group

TnxBaseStreamDescriptor Methods

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Methods


TnxBaseStreamDescriptor.GetList Method

TnxBaseStreamDescriptor.GetList Method
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseStreamDescriptor Methods

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Methods


TnxBaseStreamDescriptor.IsEqual Method

TnxBaseStreamDescriptor.IsEqual Method
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseStreamDescriptor Methods

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Methods


TnxBaseStreamDescriptor.LoadFromReader Method

TnxBaseStreamDescriptor.LoadFromReader Method
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseStreamDescriptor Methods

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Methods


TnxBaseStreamDescriptor.SaveToWriter Method

TnxBaseStreamDescriptor.SaveToWriter Method
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseStreamDescriptor Methods

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Methods


TnxBaseStreamDescriptor Properties

TnxBaseStreamDescriptor Properties
TnxBaseStreamDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseStreamDescriptor class are listed here.

Class

TnxBaseStreamDescriptor Class

Public Properties
Name | Description
HeaderSection | Returns the header of the descriptor as string.
StreamEngine | The name of the Stream Engine.
Links
TnxBaseStreamDescriptor Class, Legend, Public Properties


TnxBaseStreamDescriptor.HeaderSection Property

TnxBaseStreamDescriptor.HeaderSection Property
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Properties Send Feedback
Syntax
Delphi
property HeaderSection: AnsiString;
Description

Returns the header of the descriptor as string.

Group

TnxBaseStreamDescriptor Properties

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Properties


TnxBaseStreamDescriptor.StreamEngine Property

TnxBaseStreamDescriptor.StreamEngine Property
TnxBaseStreamDescriptor Class TnxBaseStreamDescriptor Members nxsdDataDictionary Namespace TnxBaseStreamDescriptor Properties Send Feedback
Syntax
Delphi
property StreamEngine: string;
Description

The name of the Stream Engine.

Group

TnxBaseStreamDescriptor Properties

Links
TnxBaseStreamDescriptor Class, TnxBaseStreamDescriptor Members, nxsdDataDictionary Namespace, TnxBaseStreamDescriptor Properties


TnxBaseTableDescriptor Class

TnxBaseTableDescriptor Class
TnxBaseTableDescriptor Fields TnxBaseTableDescriptor Methods TnxBaseTableDescriptor Properties TnxBaseTableDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptornxsdDataDictionary_TnxBaseTableDescriptor
Syntax
Delphi
TnxBaseTableDescriptor = class(TnxLocalizedDictionaryItem);
File

nxsdDataDictionary

Description

A table decriptor holds all information about a table as well as an instance of TnxFieldsDescriptor, TnxCustomDescsDescriptor, TnxTablesDescriptor, TnxBaseRecordDescriptor, TnxMainIndicesDescriptor, TnxBaseAutoIncDescriptor to fully define a table and it's attributes.

Group

Classes

Links
TnxBaseTableDescriptor Fields, TnxBaseTableDescriptor Methods, TnxBaseTableDescriptor Properties, TnxBaseTableDescriptor Members, nxsdDataDictionary, Classes


TnxBaseTableDescriptor Members

TnxBaseTableDescriptor Members
TnxBaseTableDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTableDescriptor.

Class

TnxBaseTableDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
tdAutoIncDescriptor | This is tdAutoIncDescriptor, a member of class TnxBaseTableDescriptor.
tdBlobDescriptor | This is tdBlobDescriptor, a member of class TnxBaseTableDescriptor.
tdConstraints | This is tdConstraints, a member of class TnxBaseTableDescriptor.
tdCustomDescsDescriptor | This is tdCustomDescsDescriptor, a member of class TnxBaseTableDescriptor.
tdFieldsDescriptor | private
tdIndicesDescriptor | This is tdIndicesDescriptor, a member of class TnxBaseTableDescriptor.
tdRecordDescriptor | This is tdRecordDescriptor, a member of class TnxBaseTableDescriptor.
tdTablesDescriptor | This is tdTablesDescriptor, a member of class TnxBaseTableDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
ClearPrim |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tdGetBookmarkSize |
tdGetKeyLen |
Unregister |
Public Methods
Name | Description
AddAutoIncDescriptor | This function sets the AutoInc Descriptor class to the given aAutoIncClass, creates and instance, adds it to the data dictionary and returns the instance.
AddAutoIncDescriptorT |
AddBlobDescriptor | This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddBlobDescriptorT |
AddIndicesDescriptor | This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
AddIndicesDescriptorT |
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddRecordDescriptor | This function sets the Record Descriptor class to the given aRecordClass, creates and instance, adds it to the data dictionary and returns the instance.
AddRecordDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
AssignOnlyFields | Copy all fields from another table descriptor.
BeforeDestruction | TnxLifetimeTrackedPersistent
btdFullName | Returns the fully qualified name of a table.
CheckValid | Checks if the Data Dictionary is valid. Raises an exception if not.
Clear | This function clears the Data Dictionary.
Create | constructor.
Destroy | destructor.
EnsureIndicesDescriptor | This function ensures there is an indices descritor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetChild | Returns a named sub table descriptor.
GetConstraintByName | Returns the constraint descriptor for the named constraint.
GetConstraints | Returns the names of all constraints assigned to this table.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | Compares the current Data Dictionary to another. Returns true if they are equal.
IsFieldDescValid | Returns true if an Field Descriptor validates ok.
IsIndexDescValid | Returns true if an Index Descriptor validates ok.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveAutoIncDescriptor | This function frees the Instance of the associated AutoInc Descriptor.
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveRecordDescriptor | This function frees the Instance of the associated Record Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
AutoIncDescriptor | This property returns the associated AutoInc Descriptor.
BlobDescriptor | This property returns the associated Blob Descriptor.
BookmarkSize | The length of a bookmark for the given index.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomDescsDescriptor | Holds all CustomDescriptor items of the table
CustomStrings | A storage container for developers to store extra data with the descriptor.
FieldsDescriptor | Holds all FieldDescriptor items of the table
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IndicesDescriptor | This property returns the associated Indices Descriptor.
KeyLen | The length of the key for the given index.
LocaleDescriptor | This property returns the associated Locale Descriptor.
RecordDescriptor | This property returns the associated Record Descriptor.
TablesDescriptor | Holds all Sub TableDescriptor items of the table
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseTableDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTableDescriptor.Create Constructor

TnxBaseTableDescriptor.Create Constructor
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxBaseTableDescriptor Class

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Class


TnxBaseTableDescriptor.Destroy Destructor

TnxBaseTableDescriptor.Destroy Destructor
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseTableDescriptor Class

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Class


TnxBaseTableDescriptor Fields

TnxBaseTableDescriptor Fields
TnxBaseTableDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTableDescriptor class are listed here.

Class

TnxBaseTableDescriptor Class

Protected Fields
Name | Description
tdAutoIncDescriptor | This is tdAutoIncDescriptor, a member of class TnxBaseTableDescriptor.
tdBlobDescriptor | This is tdBlobDescriptor, a member of class TnxBaseTableDescriptor.
tdConstraints | This is tdConstraints, a member of class TnxBaseTableDescriptor.
tdCustomDescsDescriptor | This is tdCustomDescsDescriptor, a member of class TnxBaseTableDescriptor.
tdFieldsDescriptor | private
tdIndicesDescriptor | This is tdIndicesDescriptor, a member of class TnxBaseTableDescriptor.
tdRecordDescriptor | This is tdRecordDescriptor, a member of class TnxBaseTableDescriptor.
tdTablesDescriptor | This is tdTablesDescriptor, a member of class TnxBaseTableDescriptor.
Links
TnxBaseTableDescriptor Class, Legend, Protected Fields


TnxBaseTableDescriptor.tdAutoIncDescriptor Field

TnxBaseTableDescriptor.tdAutoIncDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdAutoIncDescriptor: TnxBaseAutoIncDescriptor;
Description

This is tdAutoIncDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdBlobDescriptor Field

TnxBaseTableDescriptor.tdBlobDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdBlobDescriptor: TnxBaseBlobDescriptor;
Description

This is tdBlobDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdConstraints Field

TnxBaseTableDescriptor.tdConstraints Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdConstraints: TStringList;
Description

This is tdConstraints, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdCustomDescsDescriptor Field

TnxBaseTableDescriptor.tdCustomDescsDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdCustomDescsDescriptor: TnxCustomDescsDescriptor;
Description

This is tdCustomDescsDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdFieldsDescriptor Field

TnxBaseTableDescriptor.tdFieldsDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdFieldsDescriptor: TnxFieldsDescriptor;
Description

private

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdIndicesDescriptor Field

TnxBaseTableDescriptor.tdIndicesDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdIndicesDescriptor: TnxMainIndicesDescriptor;
Description

This is tdIndicesDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdRecordDescriptor Field

TnxBaseTableDescriptor.tdRecordDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdRecordDescriptor: TnxBaseRecordDescriptor;
Description

This is tdRecordDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor.tdTablesDescriptor Field

TnxBaseTableDescriptor.tdTablesDescriptor Field
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Fields Send Feedback
Syntax
Delphi
tdTablesDescriptor: TnxTablesDescriptor;
Description

This is tdTablesDescriptor, a member of class TnxBaseTableDescriptor.

Group

TnxBaseTableDescriptor Fields

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Fields


TnxBaseTableDescriptor Methods

TnxBaseTableDescriptor Methods
TnxBaseTableDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTableDescriptor class are listed here.

Class

TnxBaseTableDescriptor Class

Protected Methods
Name | Description
ClearPrim |
diAddConstraint | constraint notifications
diRemoveConstraint |
tdGetBookmarkSize |
tdGetKeyLen |
Public Methods
Name | Description
AddAutoIncDescriptor | This function sets the AutoInc Descriptor class to the given aAutoIncClass, creates and instance, adds it to the data dictionary and returns the instance.
AddAutoIncDescriptorT |
AddBlobDescriptor | This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddBlobDescriptorT |
AddIndicesDescriptor | This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
AddIndicesDescriptorT |
AddRecordDescriptor | This function sets the Record Descriptor class to the given aRecordClass, creates and instance, adds it to the data dictionary and returns the instance.
AddRecordDescriptorT |
AssignOnlyFields | Copy all fields from another table descriptor.
btdFullName | Returns the fully qualified name of a table.
CheckValid | Checks if the Data Dictionary is valid. Raises an exception if not.
Clear | This function clears the Data Dictionary.
EnsureIndicesDescriptor | This function ensures there is an indices descritor.
FindRelatedDescriptorOfType |
GetChild | Returns a named sub table descriptor.
GetConstraintByName | Returns the constraint descriptor for the named constraint.
GetConstraints | Returns the names of all constraints assigned to this table.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
IsEqual | Compares the current Data Dictionary to another. Returns true if they are equal.
IsFieldDescValid | Returns true if an Field Descriptor validates ok.
IsIndexDescValid | Returns true if an Index Descriptor validates ok.
LoadFromReader |
RemoveAutoIncDescriptor | This function frees the Instance of the associated AutoInc Descriptor.
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
RemoveRecordDescriptor | This function frees the Instance of the associated Record Descriptor.
SaveToWriter |
Links
TnxBaseTableDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTableDescriptor.AddAutoIncDescriptor Method

TnxBaseTableDescriptor.AddAutoIncDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddAutoIncDescriptor(aAutoIncClass: TnxBaseAutoIncDescriptorClass = nil): TnxBaseAutoIncDescriptor;
Description

This function sets the AutoInc Descriptor class to the given aAutoIncClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddAutoIncDescriptor, RemoveAutoIncDescriptor, AutoIncDescriptor

TnxBaseTableDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.AddAutoIncDescriptorT Method

TnxBaseTableDescriptor.AddAutoIncDescriptorT Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function AddAutoIncDescriptorT<T : TnxBaseAutoIncDescriptor>: T;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.AddBlobDescriptor Method

TnxBaseTableDescriptor.AddBlobDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddBlobDescriptor(aBlobClass: TnxBaseBlobDescriptorClass = nil): TnxBaseBlobDescriptor;
Description

This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.AddBlobDescriptorT Method

TnxBaseTableDescriptor.AddBlobDescriptorT Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function AddBlobDescriptorT<T: TnxBaseBlobDescriptor>: T;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.AddIndicesDescriptor Method

TnxBaseTableDescriptor.AddIndicesDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddIndicesDescriptor(aIndicesClass: TnxMainIndicesDescriptorClass = nil): TnxMainIndicesDescriptor;
Description

This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.AddIndicesDescriptorT Method

TnxBaseTableDescriptor.AddIndicesDescriptorT Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function AddIndicesDescriptorT<T: TnxMainIndicesDescriptor>: T;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.AddRecordDescriptor Method

TnxBaseTableDescriptor.AddRecordDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddRecordDescriptor(aRecordClass: TnxBaseRecordDescriptorClass = nil): TnxBaseRecordDescriptor;
Description

This function sets the Record Descriptor class to the given aRecordClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddRecordDescriptor, RemoveRecordDescriptor, RecordDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.AddRecordDescriptorT Method

TnxBaseTableDescriptor.AddRecordDescriptorT Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function AddRecordDescriptorT<T: TnxBaseRecordDescriptor>: T;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.AssignOnlyFields Method

TnxBaseTableDescriptor.AssignOnlyFields Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure AssignOnlyFields(aSource: TnxBaseTableDescriptor); virtual;
Description

Copy all fields from another table descriptor.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.btdFullName Method

TnxBaseTableDescriptor.btdFullName Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function btdFullName: string; virtual; abstract;
Description

Returns the fully qualified name of a table.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.CheckValid Method

TnxBaseTableDescriptor.CheckValid Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

Checks if the Data Dictionary is valid. Raises an exception if not.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.Clear Method

TnxBaseTableDescriptor.Clear Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

This function clears the Data Dictionary.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.ClearPrim Method

TnxBaseTableDescriptor.ClearPrim Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearPrim(InclFileZero: Boolean); virtual;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.diAddConstraint Method

TnxBaseTableDescriptor.diAddConstraint Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure diAddConstraint(aItem: TnxDictionaryItem; const aName: string); override;
Description

constraint notifications

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.diRemoveConstraint Method

TnxBaseTableDescriptor.diRemoveConstraint Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure diRemoveConstraint(aItem: TnxDictionaryItem; const aName: string); override;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.EnsureIndicesDescriptor Method

TnxBaseTableDescriptor.EnsureIndicesDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
function EnsureIndicesDescriptor: TnxMainIndicesDescriptor;
Description

This function ensures there is an indices descritor.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.FindRelatedDescriptorOfType Method

TnxBaseTableDescriptor.FindRelatedDescriptorOfType Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; override;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.GetChild Method

TnxBaseTableDescriptor.GetChild Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function GetChild(const aChildName: string): TnxBaseTableDescriptor;
Description

Returns a named sub table descriptor.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.GetConstraintByName Method

TnxBaseTableDescriptor.GetConstraintByName Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function GetConstraintByName(const aName: string): TnxDictionaryItem;
Description

Returns the constraint descriptor for the named constraint.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.GetConstraints Method

TnxBaseTableDescriptor.GetConstraints Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure GetConstraints(aStrings: TStrings);
Description

Returns the names of all constraints assigned to this table.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.GetFieldFromName Method

TnxBaseTableDescriptor.GetFieldFromName Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer;
Description

Return the field number for a given field name, or -1 if not found.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.GetIndexFromName Method

TnxBaseTableDescriptor.GetIndexFromName Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function GetIndexFromName(const aIndexName: string): Integer;
Description

Return the index number for a given index name, or -1 if not found.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.IsEqual Method

TnxBaseTableDescriptor.IsEqual Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Parameters
Parameters | Description
aDataDictionary | the Data Dictionary to compare the current one to.
Description

Compares the current Data Dictionary to another. Returns true if they are equal.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.IsFieldDescValid Method

TnxBaseTableDescriptor.IsFieldDescValid Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function IsFieldDescValid(aFieldDesc: TnxFieldDescriptor): Boolean; virtual;
Parameters
Parameters | Description
aFieldDesc: TnxFieldDescriptor | The Field Descriptor to check.
Description

Returns true if an Field Descriptor validates ok.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.IsIndexDescValid Method

TnxBaseTableDescriptor.IsIndexDescValid Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function IsIndexDescValid(aIndexDesc: TnxIndexDescriptor): Boolean; virtual;
Parameters
Parameters | Description
aIndexDesc: TnxIndexDescriptor | The Index Descriptor to check.
Description

Returns true if an Index Descriptor validates ok.

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.LoadFromReader Method

TnxBaseTableDescriptor.LoadFromReader Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.RemoveAutoIncDescriptor Method

TnxBaseTableDescriptor.RemoveAutoIncDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveAutoIncDescriptor;
Description

This function frees the Instance of the associated AutoInc Descriptor.

See Also

AddAutoIncDescriptor, RemoveAutoIncDescriptor, AutoIncDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.RemoveBlobDescriptor Method

TnxBaseTableDescriptor.RemoveBlobDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveBlobDescriptor;
Description

This function frees the Instance of the associated Blob Descriptor.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.RemoveIndicesDescriptor Method

TnxBaseTableDescriptor.RemoveIndicesDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveIndicesDescriptor;
Description

This function frees the Instance of the associated Indices Descriptor.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.RemoveRecordDescriptor Method

TnxBaseTableDescriptor.RemoveRecordDescriptor Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveRecordDescriptor;
Description

This function frees the Instance of the associated Record Descriptor.

See Also

AddRecordDescriptor, RemoveRecordDescriptor, RecordDescriptor

Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods, See Also


TnxBaseTableDescriptor.SaveToWriter Method

TnxBaseTableDescriptor.SaveToWriter Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.tdGetBookmarkSize Method

TnxBaseTableDescriptor.tdGetBookmarkSize Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function tdGetBookmarkSize(aInx: Integer): TnxWord32;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor.tdGetKeyLen Method

TnxBaseTableDescriptor.tdGetKeyLen Method
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Methods Send Feedback
Syntax
Delphi
function tdGetKeyLen(aInx: Integer): TnxWord32;
Group

TnxBaseTableDescriptor Methods

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Methods


TnxBaseTableDescriptor Properties

TnxBaseTableDescriptor Properties
TnxBaseTableDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTableDescriptor class are listed here.

Class

TnxBaseTableDescriptor Class

Public Properties
Name | Description
AutoIncDescriptor | This property returns the associated AutoInc Descriptor.
BlobDescriptor | This property returns the associated Blob Descriptor.
BookmarkSize | The length of a bookmark for the given index.
CustomDescsDescriptor | Holds all CustomDescriptor items of the table
FieldsDescriptor | Holds all FieldDescriptor items of the table
IndicesDescriptor | This property returns the associated Indices Descriptor.
KeyLen | The length of the key for the given index.
RecordDescriptor | This property returns the associated Record Descriptor.
TablesDescriptor | Holds all Sub TableDescriptor items of the table
Links
TnxBaseTableDescriptor Class, Legend, Public Properties


TnxBaseTableDescriptor.AutoIncDescriptor Property

TnxBaseTableDescriptor.AutoIncDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties See Also Send Feedback
Syntax
Delphi
property AutoIncDescriptor: TnxBaseAutoIncDescriptor;
Description

This property returns the associated AutoInc Descriptor.

See Also

AddAutoIncDescriptor, RemoveAutoIncDescriptor, AutoIncDescriptor

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties, See Also


TnxBaseTableDescriptor.BlobDescriptor Property

TnxBaseTableDescriptor.BlobDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties See Also Send Feedback
Syntax
Delphi
property BlobDescriptor: TnxBaseBlobDescriptor;
Description

This property returns the associated Blob Descriptor.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties, See Also


TnxBaseTableDescriptor.BookmarkSize Property

TnxBaseTableDescriptor.BookmarkSize Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties Send Feedback
Syntax
Delphi
property BookmarkSize [aInx : Integer]: TnxWord32;
Description

The length of a bookmark for the given index.

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties


TnxBaseTableDescriptor.CustomDescsDescriptor Property

TnxBaseTableDescriptor.CustomDescsDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties Send Feedback
Syntax
Delphi
property CustomDescsDescriptor: TnxCustomDescsDescriptor;
Description

Holds all CustomDescriptor items of the table

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties


TnxBaseTableDescriptor.FieldsDescriptor Property

TnxBaseTableDescriptor.FieldsDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties Send Feedback
Syntax
Delphi
property FieldsDescriptor: TnxFieldsDescriptor;
Description

Holds all FieldDescriptor items of the table

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties


TnxBaseTableDescriptor.IndicesDescriptor Property

TnxBaseTableDescriptor.IndicesDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties See Also Send Feedback
Syntax
Delphi
property IndicesDescriptor: TnxMainIndicesDescriptor;
Description

This property returns the associated Indices Descriptor.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties, See Also


TnxBaseTableDescriptor.KeyLen Property

TnxBaseTableDescriptor.KeyLen Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties Send Feedback
Syntax
Delphi
property KeyLen [aInx : Integer]: TnxWord32;
Description

The length of the key for the given index.

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties


TnxBaseTableDescriptor.RecordDescriptor Property

TnxBaseTableDescriptor.RecordDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties See Also Send Feedback
Syntax
Delphi
property RecordDescriptor: TnxBaseRecordDescriptor;
Description

This property returns the associated Record Descriptor.

See Also

AddRecordDescriptor, RemoveRecordDescriptor, RecordDescriptor

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties, See Also


TnxBaseTableDescriptor.TablesDescriptor Property

TnxBaseTableDescriptor.TablesDescriptor Property
TnxBaseTableDescriptor Class TnxBaseTableDescriptor Members nxsdDataDictionary Namespace TnxBaseTableDescriptor Properties Send Feedback
Syntax
Delphi
property TablesDescriptor: TnxTablesDescriptor;
Description

Holds all Sub TableDescriptor items of the table

Group

TnxBaseTableDescriptor Properties

Links
TnxBaseTableDescriptor Class, TnxBaseTableDescriptor Members, nxsdDataDictionary Namespace, TnxBaseTableDescriptor Properties


TnxCompKeyDescriptor Class

TnxCompKeyDescriptor Class
TnxCompKeyDescriptor Fields TnxCompKeyDescriptor Methods TnxCompKeyDescriptor Properties TnxCompKeyDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptornxsdDataDictionary_TnxCompKeyDescriptor
Syntax
Delphi
TnxCompKeyDescriptor = class(TnxBaseKeyDescriptor);
File

nxsdDataDictionary

Description

The Compound Key descriptor uses a number of Key Field descriptor to create the keys.

Group

Classes

Links
TnxCompKeyDescriptor Fields, TnxCompKeyDescriptor Methods, TnxCompKeyDescriptor Properties, TnxCompKeyDescriptor Members, nxsdDataDictionary, Classes


TnxCompKeyDescriptor Members

TnxCompKeyDescriptor Members
TnxCompKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCompKeyDescriptor.

Class

TnxCompKeyDescriptor Class

Protected Fields
Name | Description
ckdKeyFields | private
ckdKeyLen | This is ckdKeyLen, a member of class TnxCompKeyDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bkdGetKeyLen |
CheckReadOnly |
ckdGetKeyField |
ckdGetKeyFieldCount |
ckdGetKeyFieldDescriptorClass |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddT | This is the overview for the AddT method overload.
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls |
CheckValid |
Clear | Clears the list of Key Field Descriptors.
Delete | This function deletes a descriptor from the list of processed Key Field Descriptors.
Destroy | public comes before protected to fix problem with BCB destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
Insert | This is the overview for the Insert method overload.
InsertT | This is the overview for the InsertT method overload.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
Move | Moves a Key Field Descriptor in the list of descriptors from aFrom to the aTo position
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyFieldCount | This property returns the number of items in the Key Field descriptor List.
KeyFields | This property return the Key Field descriptor with the given index out of the Key Field Descriptor list.
KeyLen | This property returns the length of the created keys.
Links
TnxCompKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxCompKeyDescriptor.Create Constructor

TnxCompKeyDescriptor.Create Constructor
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxCompKeyDescriptor Class

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Class


TnxCompKeyDescriptor.Destroy Destructor

TnxCompKeyDescriptor.Destroy Destructor
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

public comes before protected to fix problem with BCB destructor.

Class

TnxCompKeyDescriptor Class

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Class


TnxCompKeyDescriptor Fields

TnxCompKeyDescriptor Fields
TnxCompKeyDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxCompKeyDescriptor class are listed here.

Class

TnxCompKeyDescriptor Class

Protected Fields
Name | Description
ckdKeyFields | private
ckdKeyLen | This is ckdKeyLen, a member of class TnxCompKeyDescriptor.
Links
TnxCompKeyDescriptor Class, Legend, Protected Fields


TnxCompKeyDescriptor.ckdKeyFields Field

TnxCompKeyDescriptor.ckdKeyFields Field
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Fields Send Feedback
Syntax
Delphi
ckdKeyFields: TnxList;
Description

private

Group

TnxCompKeyDescriptor Fields

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Fields


TnxCompKeyDescriptor.ckdKeyLen Field

TnxCompKeyDescriptor.ckdKeyLen Field
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Fields Send Feedback
Syntax
Delphi
ckdKeyLen: Integer;
Description

This is ckdKeyLen, a member of class TnxCompKeyDescriptor.

Group

TnxCompKeyDescriptor Fields

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Fields


TnxCompKeyDescriptor Methods

TnxCompKeyDescriptor Methods
TnxCompKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCompKeyDescriptor class are listed here.

Class

TnxCompKeyDescriptor Class

Protected Methods
Name | Description
bkdGetKeyLen |
ckdGetKeyField |
ckdGetKeyFieldCount |
ckdGetKeyFieldDescriptorClass |
IsValidFor |
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddT | This is the overview for the AddT method overload.
CanContainNulls |
CheckValid |
Clear | Clears the list of Key Field Descriptors.
Delete | This function deletes a descriptor from the list of processed Key Field Descriptors.
Insert | This is the overview for the Insert method overload.
InsertT | This is the overview for the InsertT method overload.
IsEqual |
LoadFromReader |
Move | Moves a Key Field Descriptor in the list of descriptors from aFrom to the aTo position
SaveToWriter |
Links
TnxCompKeyDescriptor Class, Legend, Protected Methods, Public Methods


Add Method

Add Method
TnxCompKeyDescriptor Methods Send Feedback

This is the overview for the Add method overload.

Overload List
Name | Description
TnxCompKeyDescriptor.Add (Integer, TnxKeyFieldDescriptorClass) | This function adds a new descriptor to the list of processed Key Field Descriptors.
TnxCompKeyDescriptor.Add (string, TnxKeyFieldDescriptorClass) |
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.Add Method (Integer, TnxKeyFieldDescriptorClass)

TnxCompKeyDescriptor.Add Method (Integer, TnxKeyFieldDescriptorClass)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace Add Method See Also Send Feedback
Syntax
Delphi
function Add(aFieldNumber: Integer; aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor; virtual; overload;
Description

This function adds a new descriptor to the list of processed Key Field Descriptors.

See Also

Delete, Clear, KeyFieldCount, KeyFields

TnxCompKeyDescriptor

Group

Add Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, Add Method, See Also


TnxCompKeyDescriptor.Add Method (string, TnxKeyFieldDescriptorClass)

TnxCompKeyDescriptor.Add Method (string, TnxKeyFieldDescriptorClass)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace Add Method Send Feedback
Syntax
Delphi
function Add(const aFieldName: string; aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor; overload;
Group

Add Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, Add Method


AddT Method

AddT Method
TnxCompKeyDescriptor Methods Send Feedback

This is the overview for the AddT method overload.

Overload List
Name | Description
TnxCompKeyDescriptor.AddT (Integer) |
TnxCompKeyDescriptor.AddT (string) |
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.AddT Method (Integer)

TnxCompKeyDescriptor.AddT Method (Integer)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace AddT Method Send Feedback
Syntax
Delphi
function AddT<T: TnxKeyFieldDescriptor>(aFieldNumber: Integer): T; overload;
Group

AddT Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, AddT Method


TnxCompKeyDescriptor.AddT Method (string)

TnxCompKeyDescriptor.AddT Method (string)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace AddT Method Send Feedback
Syntax
Delphi
function AddT<T: TnxKeyFieldDescriptor>(const aFieldName: string): T; overload;
Group

AddT Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, AddT Method


TnxCompKeyDescriptor.bkdGetKeyLen Method

TnxCompKeyDescriptor.bkdGetKeyLen Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.CanContainNulls Method

TnxCompKeyDescriptor.CanContainNulls Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.CheckValid Method

TnxCompKeyDescriptor.CheckValid Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.ckdGetKeyField Method

TnxCompKeyDescriptor.ckdGetKeyField Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function ckdGetKeyField(aInx: Integer): TnxKeyFieldDescriptor;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.ckdGetKeyFieldCount Method

TnxCompKeyDescriptor.ckdGetKeyFieldCount Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function ckdGetKeyFieldCount: Integer;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.ckdGetKeyFieldDescriptorClass Method

TnxCompKeyDescriptor.ckdGetKeyFieldDescriptorClass Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function ckdGetKeyFieldDescriptorClass: TnxKeyFieldDescriptorClass; virtual;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.Clear Method

TnxCompKeyDescriptor.Clear Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure Clear;
Description

Clears the list of Key Field Descriptors.

See Also

Add, Delete, Clear, KeyFieldCount, KeyFields

Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods, See Also


TnxCompKeyDescriptor.Delete Method

TnxCompKeyDescriptor.Delete Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure Delete(aInx: Integer);
Description

This function deletes a descriptor from the list of processed Key Field Descriptors.

See Also

Add, Delete, Clear, KeyFieldCount, KeyFields

Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods, See Also


Insert Method

Insert Method
TnxCompKeyDescriptor Methods Send Feedback

This is the overview for the Insert method overload.

Overload List
Name | Description
TnxCompKeyDescriptor.Insert (Integer, Integer, TnxKeyFieldDescriptorClass) | This function adds a new descriptor to the list of processed Key Field Descriptors at the specified index.
TnxCompKeyDescriptor.Insert (Integer, string, TnxKeyFieldDescriptorClass) |
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.Insert Method (Integer, Integer, TnxKeyFieldDescriptorClass)

TnxCompKeyDescriptor.Insert Method (Integer, Integer, TnxKeyFieldDescriptorClass)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace Insert Method See Also Send Feedback
Syntax
Delphi
function Insert(aInx: Integer; aFieldNumber: Integer; aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor; virtual; overload;
Description

This function adds a new descriptor to the list of processed Key Field Descriptors at the specified index.

See Also

Delete, Clear, KeyFieldCount, KeyFields

Group

Insert Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, Insert Method, See Also


TnxCompKeyDescriptor.Insert Method (Integer, string, TnxKeyFieldDescriptorClass)

TnxCompKeyDescriptor.Insert Method (Integer, string, TnxKeyFieldDescriptorClass)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace Insert Method Send Feedback
Syntax
Delphi
function Insert(aInx: Integer; const aFieldName: string; aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor; overload;
Group

Insert Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, Insert Method


InsertT Method

InsertT Method
TnxCompKeyDescriptor Methods Send Feedback

This is the overview for the InsertT method overload.

Overload List
Name | Description
TnxCompKeyDescriptor.InsertT (Integer, Integer) |
TnxCompKeyDescriptor.InsertT (Integer, string) |
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.InsertT Method (Integer, Integer)

TnxCompKeyDescriptor.InsertT Method (Integer, Integer)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace InsertT Method Send Feedback
Syntax
Delphi
function InsertT<T: TnxKeyFieldDescriptor>(aInx: Integer; aFieldNumber: Integer): T; overload;
Group

InsertT Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, InsertT Method


TnxCompKeyDescriptor.InsertT Method (Integer, string)

TnxCompKeyDescriptor.InsertT Method (Integer, string)
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace InsertT Method Send Feedback
Syntax
Delphi
function InsertT<T: TnxKeyFieldDescriptor>(aInx: Integer; const aFieldName: string): T; overload;
Group

InsertT Method

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, InsertT Method


TnxCompKeyDescriptor.IsEqual Method

TnxCompKeyDescriptor.IsEqual Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.IsValidFor Method

TnxCompKeyDescriptor.IsValidFor Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function IsValidFor(aDescriptor: TnxBaseTableDescriptor): Boolean; override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.LoadFromReader Method

TnxCompKeyDescriptor.LoadFromReader Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.Move Method

TnxCompKeyDescriptor.Move Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure Move(aFrom: Integer; aTo: Integer);
Description

Moves a Key Field Descriptor in the list of descriptors from aFrom to the aTo position

Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor.SaveToWriter Method

TnxCompKeyDescriptor.SaveToWriter Method
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCompKeyDescriptor Methods

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Methods


TnxCompKeyDescriptor Properties

TnxCompKeyDescriptor Properties
TnxCompKeyDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxCompKeyDescriptor class are listed here.

Class

TnxCompKeyDescriptor Class

Public Properties
Name | Description
KeyFieldCount | This property returns the number of items in the Key Field descriptor List.
KeyFields | This property return the Key Field descriptor with the given index out of the Key Field Descriptor list.
Links
TnxCompKeyDescriptor Class, Legend, Public Properties


TnxCompKeyDescriptor.KeyFieldCount Property

TnxCompKeyDescriptor.KeyFieldCount Property
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Properties See Also Send Feedback
Syntax
Delphi
property KeyFieldCount: Integer;
Description

This property returns the number of items in the Key Field descriptor List.

See Also

Add, Delete, Clear, KeyFieldCount, KeyFields

Group

TnxCompKeyDescriptor Properties

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Properties, See Also


TnxCompKeyDescriptor.KeyFields Property

TnxCompKeyDescriptor.KeyFields Property
TnxCompKeyDescriptor Class TnxCompKeyDescriptor Members nxsdDataDictionary Namespace TnxCompKeyDescriptor Properties See Also Send Feedback
Syntax
Delphi
property KeyFields [aInx: Integer]: TnxKeyFieldDescriptor;
Description

This property return the Key Field descriptor with the given index out of the Key Field Descriptor list.

See Also

Add, Delete, Clear, KeyFieldCount, KeyFields

Group

TnxCompKeyDescriptor Properties

Links
TnxCompKeyDescriptor Class, TnxCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxCompKeyDescriptor Properties, See Also


TnxConstDefaultValueDescriptor Class

TnxConstDefaultValueDescriptor Class
TnxConstDefaultValueDescriptor Fields TnxConstDefaultValueDescriptor Methods TnxConstDefaultValueDescriptor Properties TnxConstDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptornxsdDataDictionary_TnxConstDefaultValueDescriptor
Syntax
Delphi
TnxConstDefaultValueDescriptor = class(TnxBaseDefaultValueDescriptor);
File

nxsdDataDictionary

Description

This is the implementation for constant default values.

Group

Classes

Links
TnxConstDefaultValueDescriptor Fields, TnxConstDefaultValueDescriptor Methods, TnxConstDefaultValueDescriptor Properties, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxConstDefaultValueDescriptor Members

TnxConstDefaultValueDescriptor Members
TnxConstDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxConstDefaultValueDescriptor.

Class

TnxConstDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxBaseDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
cdvDefaultValue | fields are public for speed reasons The default value a field should be set to.
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
AsVariant | Gets/Sets the constant value as Variant.
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxConstDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxConstDefaultValueDescriptor.Create Constructor

TnxConstDefaultValueDescriptor.Create Constructor
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxConstDefaultValueDescriptor Class

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Class


TnxConstDefaultValueDescriptor Fields

TnxConstDefaultValueDescriptor Fields
TnxConstDefaultValueDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxConstDefaultValueDescriptor class are listed here.

Class

TnxConstDefaultValueDescriptor Class

Public Fields
Name | Description
cdvDefaultValue | fields are public for speed reasons The default value a field should be set to.
Links
TnxConstDefaultValueDescriptor Class, Legend, Public Fields


TnxConstDefaultValueDescriptor.cdvDefaultValue Field

TnxConstDefaultValueDescriptor.cdvDefaultValue Field
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Fields Send Feedback
Syntax
Delphi
cdvDefaultValue: TnxDynByteArray;
Description

fields are public for speed reasons The default value a field should be set to.

Group

TnxConstDefaultValueDescriptor Fields

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Fields


TnxConstDefaultValueDescriptor Methods

TnxConstDefaultValueDescriptor Methods
TnxConstDefaultValueDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxConstDefaultValueDescriptor class are listed here.

Class

TnxConstDefaultValueDescriptor Class

Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxConstDefaultValueDescriptor Class, Legend, Public Methods


TnxConstDefaultValueDescriptor.IsEqual Method

TnxConstDefaultValueDescriptor.IsEqual Method
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxConstDefaultValueDescriptor Methods

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Methods


TnxConstDefaultValueDescriptor.LoadFromReader Method

TnxConstDefaultValueDescriptor.LoadFromReader Method
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxConstDefaultValueDescriptor Methods

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Methods


TnxConstDefaultValueDescriptor.SaveToWriter Method

TnxConstDefaultValueDescriptor.SaveToWriter Method
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxConstDefaultValueDescriptor Methods

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Methods


TnxConstDefaultValueDescriptor Properties

TnxConstDefaultValueDescriptor Properties
TnxConstDefaultValueDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxConstDefaultValueDescriptor class are listed here.

Class

TnxConstDefaultValueDescriptor Class

Public Properties
Name | Description
AsVariant | Gets/Sets the constant value as Variant.
Links
TnxConstDefaultValueDescriptor Class, Legend, Public Properties


TnxConstDefaultValueDescriptor.AsVariant Property

TnxConstDefaultValueDescriptor.AsVariant Property
TnxConstDefaultValueDescriptor Class TnxConstDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxConstDefaultValueDescriptor Properties Send Feedback
Syntax
Delphi
property AsVariant: OleVariant;
Description

Gets/Sets the constant value as Variant.

Group

TnxConstDefaultValueDescriptor Properties

Links
TnxConstDefaultValueDescriptor Class, TnxConstDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxConstDefaultValueDescriptor Properties


TnxCurrentDateTimeDefaultValueDescriptor Class

TnxCurrentDateTimeDefaultValueDescriptor Class
TnxCurrentDateTimeDefaultValueDescriptor Methods TnxCurrentDateTimeDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptornxsdDataDictionary_TnxCurrentDateTimeDefaultValueDescriptor
Syntax
Delphi
TnxCurrentDateTimeDefaultValueDescriptor = class(TnxBaseDefaultValueDescriptor);
File

nxsdDataDictionary

Description

This descriptor should be used if you want to set a DateTime field to the current server DateTime.

Group

Classes

Links
TnxCurrentDateTimeDefaultValueDescriptor Methods, TnxCurrentDateTimeDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxCurrentDateTimeDefaultValueDescriptor Members

TnxCurrentDateTimeDefaultValueDescriptor Members
TnxCurrentDateTimeDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCurrentDateTimeDefaultValueDescriptor.

Class

TnxCurrentDateTimeDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxCurrentDateTimeDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxCurrentDateTimeDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCurrentDateTimeDefaultValueDescriptor Methods

TnxCurrentDateTimeDefaultValueDescriptor Methods
TnxCurrentDateTimeDefaultValueDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxCurrentDateTimeDefaultValueDescriptor class are listed here.

Class

TnxCurrentDateTimeDefaultValueDescriptor Class

Protected Methods
Name | Description
bdvGetInvalidFieldTypes | TnxCurrentDateTimeDefaultValueDescriptor
Links
TnxCurrentDateTimeDefaultValueDescriptor Class, Legend, Protected Methods


TnxCurrentDateTimeDefaultValueDescriptor.bdvGetInvalidFieldTypes Method

TnxCurrentDateTimeDefaultValueDescriptor.bdvGetInvalidFieldTypes Method
TnxCurrentDateTimeDefaultValueDescriptor Class TnxCurrentDateTimeDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxCurrentDateTimeDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function bdvGetInvalidFieldTypes: TnxFieldTypes; override;
Description

TnxCurrentDateTimeDefaultValueDescriptor

Group

TnxCurrentDateTimeDefaultValueDescriptor Methods

Links
TnxCurrentDateTimeDefaultValueDescriptor Class, TnxCurrentDateTimeDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxCurrentDateTimeDefaultValueDescriptor Methods


TnxCurrentUserDefaultValueDescriptor Class

TnxCurrentUserDefaultValueDescriptor Class
TnxCurrentUserDefaultValueDescriptor Methods TnxCurrentUserDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptornxsdDataDictionary_TnxCurrentUserDefaultValueDescriptor
Syntax
Delphi
TnxCurrentUserDefaultValueDescriptor = class(TnxBaseDefaultValueDescriptor);
File

nxsdDataDictionary

Description

This descriptor should be used if you want to set a string field to the current logged in user.

Group

Classes

Links
TnxCurrentUserDefaultValueDescriptor Methods, TnxCurrentUserDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxCurrentUserDefaultValueDescriptor Members

TnxCurrentUserDefaultValueDescriptor Members
TnxCurrentUserDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCurrentUserDefaultValueDescriptor.

Class

TnxCurrentUserDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxCurrentUserDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxCurrentUserDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCurrentUserDefaultValueDescriptor Methods

TnxCurrentUserDefaultValueDescriptor Methods
TnxCurrentUserDefaultValueDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxCurrentUserDefaultValueDescriptor class are listed here.

Class

TnxCurrentUserDefaultValueDescriptor Class

Protected Methods
Name | Description
bdvGetInvalidFieldTypes | TnxCurrentUserDefaultValueDescriptor
Links
TnxCurrentUserDefaultValueDescriptor Class, Legend, Protected Methods


TnxCurrentUserDefaultValueDescriptor.bdvGetInvalidFieldTypes Method

TnxCurrentUserDefaultValueDescriptor.bdvGetInvalidFieldTypes Method
TnxCurrentUserDefaultValueDescriptor Class TnxCurrentUserDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxCurrentUserDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function bdvGetInvalidFieldTypes: TnxFieldTypes; override;
Description

TnxCurrentUserDefaultValueDescriptor

Group

TnxCurrentUserDefaultValueDescriptor Methods

Links
TnxCurrentUserDefaultValueDescriptor Class, TnxCurrentUserDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxCurrentUserDefaultValueDescriptor Methods


TnxCustomDescsDescriptor Class

TnxCustomDescsDescriptor Class
TnxCustomDescsDescriptor Fields TnxCustomDescsDescriptor Methods TnxCustomDescsDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxCustomDescsDescriptornxsdDataDictionary_TnxCustomDescsDescriptornxsdDataDictionary_TnxCustomDescsDescriptornxsdDataDictionary_TnxCustomDescsDescriptornxsdDataDictionary_TnxCustomDescsDescriptornxsdDataDictionary_TnxCustomDescsDescriptor
Syntax
Delphi
TnxCustomDescsDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

Holds a list of CustomDescriptors.

Group

Classes

Links
TnxCustomDescsDescriptor Fields, TnxCustomDescsDescriptor Methods, TnxCustomDescsDescriptor Members, nxsdDataDictionary, Classes


TnxCustomDescsDescriptor Members

TnxCustomDescsDescriptor Members
TnxCustomDescsDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCustomDescsDescriptor.

Class

TnxCustomDescsDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
CustomCount | The number Custom Descriptors for this table.
CustomDescriptor | fields are public for speed reasons The Custom Descriptors defined for this table.
Public Methods
Name | Description
AddCustom | This function adds a new instance of a Custom Descriptor to the data dictionary and returns the newly created Instance.
AddCustomT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | This function clears the Custom Descriptors Descriptor.
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetCustomDescriptorFromName | Return the custom number for a given custom name, or -1 if not found.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveCustom | This is the overview for the RemoveCustom method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxCustomDescsDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxCustomDescsDescriptor.Create Constructor

TnxCustomDescsDescriptor.Create Constructor
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxCustomDescsDescriptor Class

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Class


TnxCustomDescsDescriptor.Destroy Destructor

TnxCustomDescsDescriptor.Destroy Destructor
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxCustomDescsDescriptor Class

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Class


TnxCustomDescsDescriptor Fields

TnxCustomDescsDescriptor Fields
TnxCustomDescsDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxCustomDescsDescriptor class are listed here.

Class

TnxCustomDescsDescriptor Class

Public Fields
Name | Description
CustomCount | The number Custom Descriptors for this table.
CustomDescriptor | fields are public for speed reasons The Custom Descriptors defined for this table.
Links
TnxCustomDescsDescriptor Class, Legend, Public Fields


TnxCustomDescsDescriptor.CustomCount Field

TnxCustomDescsDescriptor.CustomCount Field
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Fields Send Feedback
Syntax
Delphi
CustomCount: Integer;
Description

The number Custom Descriptors for this table.

Group

TnxCustomDescsDescriptor Fields

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Fields


TnxCustomDescsDescriptor.CustomDescriptor Field

TnxCustomDescsDescriptor.CustomDescriptor Field
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Fields Send Feedback
Syntax
Delphi
CustomDescriptor: array of TnxBaseCustomDescriptor;
Description

fields are public for speed reasons The Custom Descriptors defined for this table.

Group

TnxCustomDescsDescriptor Fields

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Fields


TnxCustomDescsDescriptor Methods

TnxCustomDescsDescriptor Methods
TnxCustomDescsDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomDescsDescriptor class are listed here.

Class

TnxCustomDescsDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
AddCustom | This function adds a new instance of a Custom Descriptor to the data dictionary and returns the newly created Instance.
AddCustomT |
CheckValid |
Clear | This function clears the Custom Descriptors Descriptor.
GetCustomDescriptorFromName | Return the custom number for a given custom name, or -1 if not found.
IsEqual |
LoadFromReader |
RemoveCustom | This is the overview for the RemoveCustom method overload.
SaveToWriter |
Links
TnxCustomDescsDescriptor Class, Legend, Protected Methods, Public Methods


TnxCustomDescsDescriptor.AddCustom Method

TnxCustomDescsDescriptor.AddCustom Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
function AddCustom(const aName: string; aClass: TnxBaseCustomDescriptorClass = nil): TnxBaseCustomDescriptor;
Parameters
Parameters | Description
const aName: string | the name of the Custom Descriptor
aClass: TnxBaseCustomDescriptorClass = nil | the class of the instance to be created. TnxCustomDescsDescriptor
Description

This function adds a new instance of a Custom Descriptor to the data dictionary and returns the newly created Instance.

Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.AddCustomT Method

TnxCustomDescsDescriptor.AddCustomT Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
function AddCustomT<T: TnxBaseCustomDescriptor>(const aName: string): T;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.CheckValid Method

TnxCustomDescsDescriptor.CheckValid Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.Clear Method

TnxCustomDescsDescriptor.Clear Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

This function clears the Custom Descriptors Descriptor.

Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.GetCustomDescriptorFromName Method

TnxCustomDescsDescriptor.GetCustomDescriptorFromName Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
function GetCustomDescriptorFromName(const aCustomDescriptorName: string): Integer;
Description

Return the custom number for a given custom name, or -1 if not found.

Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.GetList Method

TnxCustomDescsDescriptor.GetList Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.IsEqual Method

TnxCustomDescsDescriptor.IsEqual Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.LoadFromReader Method

TnxCustomDescsDescriptor.LoadFromReader Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


RemoveCustom Method

RemoveCustom Method
TnxCustomDescsDescriptor Methods Send Feedback

This is the overview for the RemoveCustom method overload.

Overload List
Name | Description
TnxCustomDescsDescriptor.RemoveCustom (Integer) | Remove a Custom Descriptor from the Data Dictionary.
TnxCustomDescsDescriptor.RemoveCustom (string) | Remove a Custom Descriptor from the Data Dictionary.
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Methods


TnxCustomDescsDescriptor.RemoveCustom Method (Integer)

TnxCustomDescsDescriptor.RemoveCustom Method (Integer)
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace RemoveCustom Method Send Feedback
Syntax
Delphi
procedure RemoveCustom(aInx: Integer); overload;
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of Custom Descriptors.
Description

Remove a Custom Descriptor from the Data Dictionary.

Group

RemoveCustom Method

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, RemoveCustom Method


TnxCustomDescsDescriptor.RemoveCustom Method (string)

TnxCustomDescsDescriptor.RemoveCustom Method (string)
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace RemoveCustom Method Send Feedback
Syntax
Delphi
procedure RemoveCustom(const aName: string); overload;
Parameters
Parameters | Description
const aName: string | the name of the descriptor to be removed.
Description

Remove a Custom Descriptor from the Data Dictionary.

Group

RemoveCustom Method

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, RemoveCustom Method


TnxCustomDescsDescriptor.SaveToWriter Method

TnxCustomDescsDescriptor.SaveToWriter Method
TnxCustomDescsDescriptor Class TnxCustomDescsDescriptor Members nxsdDataDictionary Namespace TnxCustomDescsDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCustomDescsDescriptor Methods

Links
TnxCustomDescsDescriptor Class, TnxCustomDescsDescriptor Members, nxsdDataDictionary Namespace, TnxCustomDescsDescriptor Methods


TnxDataDictionary Class

TnxDataDictionary Class
TnxDataDictionary Fields TnxDataDictionary Methods TnxDataDictionary Properties TnxDataDictionary Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionarynxsdDataDictionary_TnxDataDictionary
Syntax
Delphi
TnxDataDictionary = class(TnxBaseTableDescriptor);
File

nxsdDataDictionary

Description

The data dictionary is the heart of every NexusDB table. It describes the files, fields, indices, etc and even how to read/write the records.

If you don't need the fine control that the data dictionary gives you, you can just use TIndexDefs, TFieldDefs and the CreateTable method of TDataset.

Group

Classes

Links
TnxDataDictionary Fields, TnxDataDictionary Methods, TnxDataDictionary Properties, TnxDataDictionary Members, nxsdDataDictionary, Classes


TnxDataDictionary Members

TnxDataDictionary Members
TnxDataDictionary Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDataDictionary.

Class

TnxDataDictionary Class

Protected Fields
Name | Description
ddBaseName | This is ddBaseName, a member of class TnxDataDictionary.
ddCurrentID | This is ddCurrentID, a member of class TnxDataDictionary.
ddFilesDescriptor | This is ddFilesDescriptor, a member of class TnxDataDictionary.
ddReadOnly | True if the dictionary cannot be updated.
ddStreamDescriptor | This is ddStreamDescriptor, a member of class TnxDataDictionary.
ddUseByteOrderForWideString | This is ddUseByteOrderForWideString, a member of class TnxDataDictionary.
ddVersion | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
tdAutoIncDescriptor | This is tdAutoIncDescriptor, a member of class TnxBaseTableDescriptor.
tdBlobDescriptor | This is tdBlobDescriptor, a member of class TnxBaseTableDescriptor.
tdConstraints | This is tdConstraints, a member of class TnxBaseTableDescriptor.
tdCustomDescsDescriptor | This is tdCustomDescsDescriptor, a member of class TnxBaseTableDescriptor.
tdFieldsDescriptor | private
tdIndicesDescriptor | This is tdIndicesDescriptor, a member of class TnxBaseTableDescriptor.
tdRecordDescriptor | This is tdRecordDescriptor, a member of class TnxBaseTableDescriptor.
tdTablesDescriptor | This is tdTablesDescriptor, a member of class TnxBaseTableDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
ClearPrim |
ddGetUniqueID |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack |
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tdGetBookmarkSize |
tdGetKeyLen |
Unregister |
Public Fields
Name | Description
EncryptionEngine | The name of the Encryption Engine used for this table.
HeaderSignature | The header signature for this file. In NexusDB V2 this is "NX!2
Public Methods
Name | Description
AddAutoIncDescriptor | This function sets the AutoInc Descriptor class to the given aAutoIncClass, creates and instance, adds it to the data dictionary and returns the instance.
AddAutoIncDescriptorT |
AddBlobDescriptor | This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddBlobDescriptorT |
AddIndicesDescriptor | This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
AddIndicesDescriptorT |
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddRecordDescriptor | This function sets the Record Descriptor class to the given aRecordClass, creates and instance, adds it to the data dictionary and returns the instance.
AddRecordDescriptorT |
AddStreamDescriptor | This function sets the Stream Descriptor class to the given aStreamClass, creates and instance, adds it to the data dictionary and returns the instance.
AddStreamDescriptorT |
Assign | This methods copies the settings of the given Source to the current Data Dictionary, if Source is of the same type.
AssignOnlyFields |
BeforeDestruction | TnxLifetimeTrackedPersistent
btdFullName |
CheckReadOnly | Checks if the Data Dictionary is read-only. Raises an exception if true.
CheckValid | Checks if the Data Dictionary is valid. Raises an exception if not.
Clear | This function clears the Data Dictionary.
Create | constructor.
Destroy | destructor.
EnsureIndicesDescriptor | This function ensures there is an indices descritor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetChild | Returns a named sub table descriptor.
GetConstraintByName | Returns the constraint descriptor for the named constraint.
GetConstraints | Returns the names of all constraints assigned to this table.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetFileFromExt | Return the file number for a given file extension, or -1 if not found.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | Compares the current Data Dictionary to another. Returns true if they are equal.
IsFieldDescValid | Returns true if an Field Descriptor validates ok.
IsIndexDescValid | Returns true if an Index Descriptor validates ok.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
MakeReadOnly | marks the dictionary as readonly
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReadFromReader | Reads the whole Data Dictionary settings (data) from aReader.
ReadFromStream | Reads the whole Data Dictionary settings (data) from aStream.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveAutoIncDescriptor | This function frees the Instance of the associated AutoInc Descriptor.
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveRecordDescriptor | This function frees the Instance of the associated Record Descriptor.
RemoveStreamDescriptor | This function frees the Instance of the associated Stream Descriptor.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
UsableBlockSize | This function calculates the number of bytes that can be used for storing data per block by subtracting the header size from the block size in bytes
WriteToStream | Writes the whole Data Dictionary settings (data) to aStream.
WriteToWriter | Writes the whole Data Dictionary settings (data) to aWriter.
Public Properties
Name | Description
_BaseName | Allows setting the base name. INTERNAL USE ONLY!
AutoIncDescriptor | This property returns the associated AutoInc Descriptor.
BaseName | Returns the base name of this data dictionary.
BlobDescriptor | This property returns the associated Blob Descriptor.
BookmarkSize | The length of a bookmark for the given index.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CurrentID | Read-only access to the highest ID value currently used in the dictionary.
CustomDescsDescriptor | Holds all CustomDescriptor items of the table
CustomStrings | A storage container for developers to store extra data with the descriptor.
FieldsDescriptor | Holds all FieldDescriptor items of the table
FilesDescriptor | Returns the FilesDescriptor for this dictionary.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IndicesDescriptor | This property returns the associated Indices Descriptor.
KeyLen | The length of the key for the given index.
LocaleDescriptor | This property returns the associated Locale Descriptor.
RecordDescriptor | This property returns the associated Record Descriptor.
StreamDescriptor | This property returns the associated Stream Descriptor.
TablesDescriptor | Holds all Sub TableDescriptor items of the table
UseByteOrderForWideString | Indicates that this table was created/restructured in 3.09.00 or later and that Disable30900LocaleFixes was not true. WideString fields should use a byte order comparison if locale is 0.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Version | Returns the Version of the Data Dictionary implementation and thus the table.
Links
TnxDataDictionary Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDataDictionary.Create Constructor

TnxDataDictionary.Create Constructor
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Class Send Feedback
Syntax
Delphi
constructor Create; reintroduce;
Description

constructor.

Class

TnxDataDictionary Class

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Class


TnxDataDictionary.Destroy Destructor

TnxDataDictionary.Destroy Destructor
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxDataDictionary Class

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Class


TnxDataDictionary Fields

TnxDataDictionary Fields
TnxDataDictionary Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxDataDictionary class are listed here.

Class

TnxDataDictionary Class

Protected Fields
Name | Description
ddBaseName | This is ddBaseName, a member of class TnxDataDictionary.
ddCurrentID | This is ddCurrentID, a member of class TnxDataDictionary.
ddFilesDescriptor | This is ddFilesDescriptor, a member of class TnxDataDictionary.
ddReadOnly | True if the dictionary cannot be updated.
ddStreamDescriptor | This is ddStreamDescriptor, a member of class TnxDataDictionary.
ddUseByteOrderForWideString | This is ddUseByteOrderForWideString, a member of class TnxDataDictionary.
ddVersion | private
Public Fields
Name | Description
EncryptionEngine | The name of the Encryption Engine used for this table.
HeaderSignature | The header signature for this file. In NexusDB V2 this is "NX!2
Links
TnxDataDictionary Class, Legend, Protected Fields, Public Fields


TnxDataDictionary.ddBaseName Field

TnxDataDictionary.ddBaseName Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddBaseName: string;
Description

This is ddBaseName, a member of class TnxDataDictionary.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddCurrentID Field

TnxDataDictionary.ddCurrentID Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddCurrentID: Integer;
Description

This is ddCurrentID, a member of class TnxDataDictionary.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddFilesDescriptor Field

TnxDataDictionary.ddFilesDescriptor Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddFilesDescriptor: TnxFilesDescriptor;
Description

This is ddFilesDescriptor, a member of class TnxDataDictionary.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddReadOnly Field

TnxDataDictionary.ddReadOnly Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddReadOnly: Boolean;
Description

True if the dictionary cannot be updated.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddStreamDescriptor Field

TnxDataDictionary.ddStreamDescriptor Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddStreamDescriptor: TnxBaseStreamDescriptor;
Description

This is ddStreamDescriptor, a member of class TnxDataDictionary.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddUseByteOrderForWideString Field

TnxDataDictionary.ddUseByteOrderForWideString Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddUseByteOrderForWideString: Boolean;
Description

This is ddUseByteOrderForWideString, a member of class TnxDataDictionary.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.ddVersion Field

TnxDataDictionary.ddVersion Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
ddVersion: Integer;
Description

private

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.EncryptionEngine Field

TnxDataDictionary.EncryptionEngine Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
EncryptionEngine: string;
Description

The name of the Encryption Engine used for this table.

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary.HeaderSignature Field

TnxDataDictionary.HeaderSignature Field
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Fields Send Feedback
Syntax
Delphi
HeaderSignature: TnxBlockSignature;
Description

The header signature for this file. In NexusDB V2 this is "NX!2

Group

TnxDataDictionary Fields

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Fields


TnxDataDictionary Methods

TnxDataDictionary Methods
TnxDataDictionary Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDataDictionary class are listed here.

Class

TnxDataDictionary Class

Protected Methods
Name | Description
ClearPrim |
ddGetUniqueID |
diRequiresPack |
Public Methods
Name | Description
AddStreamDescriptor | This function sets the Stream Descriptor class to the given aStreamClass, creates and instance, adds it to the data dictionary and returns the instance.
AddStreamDescriptorT |
Assign | This methods copies the settings of the given Source to the current Data Dictionary, if Source is of the same type.
AssignOnlyFields |
btdFullName |
CheckReadOnly | Checks if the Data Dictionary is read-only. Raises an exception if true.
CheckValid | Checks if the Data Dictionary is valid. Raises an exception if not.
FindRelatedDescriptorOfType |
GetFileFromExt | Return the file number for a given file extension, or -1 if not found.
IsEqual | Compares the current Data Dictionary to another. Returns true if they are equal.
MakeReadOnly | marks the dictionary as readonly
ReadFromReader | Reads the whole Data Dictionary settings (data) from aReader.
ReadFromStream | Reads the whole Data Dictionary settings (data) from aStream.
RemoveStreamDescriptor | This function frees the Instance of the associated Stream Descriptor.
UsableBlockSize | This function calculates the number of bytes that can be used for storing data per block by subtracting the header size from the block size in bytes
WriteToStream | Writes the whole Data Dictionary settings (data) to aStream.
WriteToWriter | Writes the whole Data Dictionary settings (data) to aWriter.
Links
TnxDataDictionary Class, Legend, Protected Methods, Public Methods


TnxDataDictionary.AddStreamDescriptor Method

TnxDataDictionary.AddStreamDescriptor Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods See Also Send Feedback
Syntax
Delphi
function AddStreamDescriptor(aStreamClass: TnxBaseStreamDescriptorClass = nil): TnxBaseStreamDescriptor;
Description

This function sets the Stream Descriptor class to the given aStreamClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddStreamDescriptor, RemoveStreamDescriptor, StreamDescriptor

TnxDataDictionary

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods, See Also


TnxDataDictionary.AddStreamDescriptorT Method

TnxDataDictionary.AddStreamDescriptorT Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function AddStreamDescriptorT<T: TnxBaseStreamDescriptor>: T;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.Assign Method

TnxDataDictionary.Assign Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure Assign(Source: TPersistent); override;
Parameters
Parameters | Description
Source: TPersistent | the source Data Dictionary to copy the settings from.
Description

This methods copies the settings of the given Source to the current Data Dictionary, if Source is of the same type.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.AssignOnlyFields Method

TnxDataDictionary.AssignOnlyFields Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure AssignOnlyFields(aSource: TnxBaseTableDescriptor); override;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.btdFullName Method

TnxDataDictionary.btdFullName Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function btdFullName: string; override;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.CheckReadOnly Method

TnxDataDictionary.CheckReadOnly Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure CheckReadOnly; override;
Description

Checks if the Data Dictionary is read-only. Raises an exception if true.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.CheckValid Method

TnxDataDictionary.CheckValid Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

Checks if the Data Dictionary is valid. Raises an exception if not.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.ClearPrim Method

TnxDataDictionary.ClearPrim Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure ClearPrim(InclFileZero: Boolean); override;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.ddGetUniqueID Method

TnxDataDictionary.ddGetUniqueID Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function ddGetUniqueID: Integer;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.diRequiresPack Method

TnxDataDictionary.diRequiresPack Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function diRequiresPack: Boolean; override;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.FindRelatedDescriptorOfType Method

TnxDataDictionary.FindRelatedDescriptorOfType Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; override;
Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.GetFileFromExt Method

TnxDataDictionary.GetFileFromExt Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function GetFileFromExt(const aFileExt: string): Integer;
Parameters
Parameters | Description
const aFileExt: string | the file extension (attached to the base name) to look for.
Description

Return the file number for a given file extension, or -1 if not found.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.IsEqual Method

TnxDataDictionary.IsEqual Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Parameters
Parameters | Description
aDataDictionary | the Data Dictionary to compare the current one to.
Description

Compares the current Data Dictionary to another. Returns true if they are equal.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.MakeReadOnly Method

TnxDataDictionary.MakeReadOnly Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure MakeReadOnly;
Description

marks the dictionary as readonly

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.ReadFromReader Method

TnxDataDictionary.ReadFromReader Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure ReadFromReader(aReader: TnxReader);
Description

Reads the whole Data Dictionary settings (data) from aReader.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.ReadFromStream Method

TnxDataDictionary.ReadFromStream Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure ReadFromStream(aStream: TStream; const aBaseName: string);
Description

Reads the whole Data Dictionary settings (data) from aStream.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.RemoveStreamDescriptor Method

TnxDataDictionary.RemoveStreamDescriptor Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveStreamDescriptor;
Description

This function frees the Instance of the associated Stream Descriptor.

See Also

AddStreamDescriptor, RemoveStreamDescriptor, StreamDescriptor

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods, See Also


TnxDataDictionary.UsableBlockSize Method

TnxDataDictionary.UsableBlockSize Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
function UsableBlockSize(aBlockSize: TnxBlockSize): TnxWord32; virtual;
Parameters
Parameters | Description
aBlockSize: TnxBlockSize | block size the calculation should be based on.
Description

This function calculates the number of bytes that can be used for storing data per block by subtracting the header size from the block size in bytes

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.WriteToStream Method

TnxDataDictionary.WriteToStream Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure WriteToStream(aStream: TStream; aClientVersion: Integer);
Description

Writes the whole Data Dictionary settings (data) to aStream.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary.WriteToWriter Method

TnxDataDictionary.WriteToWriter Method
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Methods Send Feedback
Syntax
Delphi
procedure WriteToWriter(aWriter: TnxWriter; aClientVersion: Integer);
Description

Writes the whole Data Dictionary settings (data) to aWriter.

Group

TnxDataDictionary Methods

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Methods


TnxDataDictionary Properties

TnxDataDictionary Properties
TnxDataDictionary Class Legend Public Properties Send Feedback

The properties of the TnxDataDictionary class are listed here.

Class

TnxDataDictionary Class

Public Properties
Name | Description
_BaseName | Allows setting the base name. INTERNAL USE ONLY!
BaseName | Returns the base name of this data dictionary.
CurrentID | Read-only access to the highest ID value currently used in the dictionary.
FilesDescriptor | Returns the FilesDescriptor for this dictionary.
StreamDescriptor | This property returns the associated Stream Descriptor.
UseByteOrderForWideString | Indicates that this table was created/restructured in 3.09.00 or later and that Disable30900LocaleFixes was not true. WideString fields should use a byte order comparison if locale is 0.
Version | Returns the Version of the Data Dictionary implementation and thus the table.
Links
TnxDataDictionary Class, Legend, Public Properties


TnxDataDictionary._BaseName Property

TnxDataDictionary._BaseName Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property _BaseName: string;
Description

Allows setting the base name. INTERNAL USE ONLY!

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDataDictionary.BaseName Property

TnxDataDictionary.BaseName Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property BaseName: string;
Description

Returns the base name of this data dictionary.

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDataDictionary.CurrentID Property

TnxDataDictionary.CurrentID Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property CurrentID: Integer;
Description

Read-only access to the highest ID value currently used in the dictionary.

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDataDictionary.FilesDescriptor Property

TnxDataDictionary.FilesDescriptor Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property FilesDescriptor: TnxFilesDescriptor;
Description

Returns the FilesDescriptor for this dictionary.

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDataDictionary.StreamDescriptor Property

TnxDataDictionary.StreamDescriptor Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties See Also Send Feedback
Syntax
Delphi
property StreamDescriptor: TnxBaseStreamDescriptor;
Description

This property returns the associated Stream Descriptor.

See Also

AddStreamDescriptor, RemoveStreamDescriptor, StreamDescriptor

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties, See Also


TnxDataDictionary.UseByteOrderForWideString Property

TnxDataDictionary.UseByteOrderForWideString Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property UseByteOrderForWideString: Boolean;
Description

Indicates that this table was created/restructured in 3.09.00 or later and that Disable30900LocaleFixes was not true. WideString fields should use a byte order comparison if locale is 0.

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDataDictionary.Version Property

TnxDataDictionary.Version Property
TnxDataDictionary Class TnxDataDictionary Members nxsdDataDictionary Namespace TnxDataDictionary Properties Send Feedback
Syntax
Delphi
property Version: Integer;
Description

Returns the Version of the Data Dictionary implementation and thus the table.

Group

TnxDataDictionary Properties

Links
TnxDataDictionary Class, TnxDataDictionary Members, nxsdDataDictionary Namespace, TnxDataDictionary Properties


TnxDictionaryItem Class

TnxDictionaryItem Class
TnxDictionaryItem Fields TnxDictionaryItem Methods TnxDictionaryItem Properties TnxDictionaryItem Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxDictionaryItemnxsdDataDictionary_TnxDictionaryItemnxsdDataDictionary_TnxDictionaryItemnxsdDataDictionary_TnxDictionaryItemnxsdDataDictionary_TnxDictionaryItem
Syntax
Delphi
TnxDictionaryItem = class(TnxBaseRegisterableDescriptor);
File

nxsdDataDictionary

Description

The dictionary item class is the base class for all sub classes owned by a data dictionary. This includes all the different descriptor classes.

Group

Classes

Links
TnxDictionaryItem Fields, TnxDictionaryItem Methods, TnxDictionaryItem Properties, TnxDictionaryItem Members, nxsdDataDictionary, Classes


TnxDictionaryItem Members

TnxDictionaryItem Members
TnxDictionaryItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDictionaryItem.

Class

TnxDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxDictionaryItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDictionaryItem.Create Constructor

TnxDictionaryItem.Create Constructor
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent);
Class

TnxDictionaryItem Class

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Class


TnxDictionaryItem.Destroy Destructor

TnxDictionaryItem.Destroy Destructor
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxDictionaryItem Class

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Class


TnxDictionaryItem Fields

TnxDictionaryItem Fields
TnxDictionaryItem Class Legend Protected Fields Send Feedback

The fields of the TnxDictionaryItem class are listed here.

Class

TnxDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
Links
TnxDictionaryItem Class, Legend, Protected Fields


TnxDictionaryItem.diCacheActive Field

TnxDictionaryItem.diCacheActive Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diCacheActive: Boolean;
Description

This is diCacheActive, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem.diChilds Field

TnxDictionaryItem.diChilds Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diChilds: TnxSortedList;
Description

This is diChilds, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem.diConstraintName Field

TnxDictionaryItem.diConstraintName Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diConstraintName: string;
Description

This is diConstraintName, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem.diCustomStrings Field

TnxDictionaryItem.diCustomStrings Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diCustomStrings: TStrings;
Description

This is diCustomStrings, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem.diID Field

TnxDictionaryItem.diID Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diID: Integer;
Description

This is diID, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem.diParent Field

TnxDictionaryItem.diParent Field
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Fields Send Feedback
Syntax
Delphi
diParent: TPersistent;
Description

private

Group

TnxDictionaryItem Fields

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Fields


TnxDictionaryItem Methods

TnxDictionaryItem Methods
TnxDictionaryItem Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxDictionaryItem class are listed here.

Class

TnxDictionaryItem Class

Protected Methods
Name | Description
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetOwner |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
Links
TnxDictionaryItem Class, Legend, Protected Methods, Public Methods


TnxDictionaryItem.Assign Method

TnxDictionaryItem.Assign Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure Assign(Source: TPersistent); override;
Description

Assigns the settings of a Source item to the current Item

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.CheckReadOnly Method

TnxDictionaryItem.CheckReadOnly Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure CheckReadOnly; virtual;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.CheckValid Method

TnxDictionaryItem.CheckValid Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); virtual;
Description

This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diActivateCaching Method

TnxDictionaryItem.diActivateCaching Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diActivateCaching; virtual;
Description

caching

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diAddChild Method

TnxDictionaryItem.diAddChild Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diAddChild(aChild: TnxDictionaryItem); virtual;
Description

child notifications

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diAddConstraint Method

TnxDictionaryItem.diAddConstraint Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diAddConstraint(aItem: TnxDictionaryItem; const aName: string); virtual;
Description

constraint notifications

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diAddToFieldChangeNotifies Method

TnxDictionaryItem.diAddToFieldChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diAddToFieldChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diAddToFileChangeNotifies Method

TnxDictionaryItem.diAddToFileChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diAddToFileChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diAddToIndexChangeNotifies Method

TnxDictionaryItem.diAddToIndexChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diAddToIndexChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diDeactivateCaching Method

TnxDictionaryItem.diDeactivateCaching Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diDeactivateCaching; virtual;
Description

This is diDeactivateCaching, a member of class TnxDictionaryItem.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diFieldChangeNotify Method

TnxDictionaryItem.diFieldChangeNotify Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diFieldChangeNotify(aBefore: Boolean; aOldField: Integer; aNewField: Integer); virtual;
Description

field removal notification

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diFileChangeNotify Method

TnxDictionaryItem.diFileChangeNotify Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diFileChangeNotify(aBefore: Boolean; aOldFile: Integer; aNewFile: Integer); virtual;
Description

file removal notification

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diGetCustomStrings Method

TnxDictionaryItem.diGetCustomStrings Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function diGetCustomStrings: TStrings;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diIndexChangeNotify Method

TnxDictionaryItem.diIndexChangeNotify Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diIndexChangeNotify(aBefore: Boolean; aOldIndex: Integer; aNewIndex: Integer); virtual;
Description

index removal notification

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diIsCustomStringsStored Method

TnxDictionaryItem.diIsCustomStringsStored Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function diIsCustomStringsStored: Boolean;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diIsSameClass Method

TnxDictionaryItem.diIsSameClass Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function diIsSameClass(aItem: TnxDictionaryItem): Boolean; virtual;
Description

helper function to allow fuzzy class matching

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRemoveChild Method

TnxDictionaryItem.diRemoveChild Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diRemoveChild(aChild: TnxDictionaryItem); virtual;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRemoveConstraint Method

TnxDictionaryItem.diRemoveConstraint Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diRemoveConstraint(aItem: TnxDictionaryItem; const aName: string); virtual;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRemoveFromFieldChangeNotifies Method

TnxDictionaryItem.diRemoveFromFieldChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diRemoveFromFieldChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRemoveFromFileChangeNotifies Method

TnxDictionaryItem.diRemoveFromFileChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diRemoveFromFileChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRemoveFromIndexChangeNotifies Method

TnxDictionaryItem.diRemoveFromIndexChangeNotifies Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diRemoveFromIndexChangeNotifies;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diRequiresPack Method

TnxDictionaryItem.diRequiresPack Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function diRequiresPack: Boolean; virtual;
Description

determine if a pack is required

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diSetConstraintName Method

TnxDictionaryItem.diSetConstraintName Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diSetConstraintName(const Value: string);
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.diSetCustomStrings Method

TnxDictionaryItem.diSetCustomStrings Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diSetCustomStrings(aCustomStrings: TStrings);
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.FindDescriptorClass Method

TnxDictionaryItem.FindDescriptorClass Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
class function FindDescriptorClass(const aName: string): TnxDictionaryItemClass; virtual;
Description

Returns the class for the given named Descriptor class

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.FindParentOfType Method

TnxDictionaryItem.FindParentOfType Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function FindParentOfType(aType: TPersistentClass; out aParent): Boolean;
Description

Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.FindRelatedDescriptorOfType Method

TnxDictionaryItem.FindRelatedDescriptorOfType Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; virtual;
Description

Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.GetOwner Method

TnxDictionaryItem.GetOwner Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function GetOwner: TPersistent; override;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.GetParentOfType Method

TnxDictionaryItem.GetParentOfType Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function GetParentOfType(aType: TPersistentClass): TPersistent;
Description

Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.GetRelatedDescriptorOfType Method

TnxDictionaryItem.GetRelatedDescriptorOfType Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function GetRelatedDescriptorOfType(aType: TnxDictionaryItemClass): TnxDictionaryItem;
Description

Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.GetRelatedDescriptorOfTypeT Method

TnxDictionaryItem.GetRelatedDescriptorOfTypeT Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function GetRelatedDescriptorOfTypeT<T: TnxBaseRegisterableDescriptor>: T;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.IsEqual Method

TnxDictionaryItem.IsEqual Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; virtual;
Description

The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.IterateReferencing Method

TnxDictionaryItem.IterateReferencing Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function IterateReferencing(aIterator: TnxDictionaryItemIterator; aCookie: Pointer; aItem: TnxDictionaryItem; aRecursive: Boolean): TnxIteratorResult;
Description

Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.LoadFromReader Method

TnxDictionaryItem.LoadFromReader Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); virtual;
Parameters
Parameters | Description
aReader: TnxReader | the TnxReader to read the information from; must be able to cope with different versions!
Description

Loads the item settings from a Reader/Stream

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.References Method

TnxDictionaryItem.References Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function References(aDictionaryItem: TnxDictionaryItem): Boolean; virtual;
Description

The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.RequiresPack Method

TnxDictionaryItem.RequiresPack Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
function RequiresPack: Boolean;
Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem.SaveToWriter Method

TnxDictionaryItem.SaveToWriter Method
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); virtual;
Parameters
Parameters | Description
aWriter: TnxWriter | the TnxWriter to write to
aClientVersion: Integer | the Version of the information to write
Description

Saves the item settings to a Writer/Stream

Group

TnxDictionaryItem Methods

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Methods


TnxDictionaryItem Properties

TnxDictionaryItem Properties
TnxDictionaryItem Class Legend Public Properties Send Feedback

The properties of the TnxDictionaryItem class are listed here.

Class

TnxDictionaryItem Class

Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxDictionaryItem Class, Legend, Public Properties


TnxDictionaryItem.ConstraintName Property

TnxDictionaryItem.ConstraintName Property
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Properties Send Feedback
Syntax
Delphi
property ConstraintName: string;
Description

Set to the name of the constraint this dictionary item represents.

Group

TnxDictionaryItem Properties

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Properties


TnxDictionaryItem.CustomStrings Property

TnxDictionaryItem.CustomStrings Property
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Properties See Also Send Feedback
Syntax
Delphi
property CustomStrings: TStrings;
Description

A storage container for developers to store extra data with the descriptor.

See Also

HasCustomStrings

Group

TnxDictionaryItem Properties

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Properties, See Also


TnxDictionaryItem.HasCustomStrings Property

TnxDictionaryItem.HasCustomStrings Property
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Properties See Also Send Feedback
Syntax
Delphi
property HasCustomStrings: Boolean;
Description

This property indicates if the item has CustomStrings assigned.

See Also

HasCustomStrings

Group

TnxDictionaryItem Properties

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Properties, See Also


TnxDictionaryItem.ID Property

TnxDictionaryItem.ID Property
TnxDictionaryItem Class TnxDictionaryItem Members nxsdDataDictionary Namespace TnxDictionaryItem Properties Send Feedback
Syntax
Delphi
property ID: Integer;
Description

Unique ID of the dictionary item

Group

TnxDictionaryItem Properties

Links
TnxDictionaryItem Class, TnxDictionaryItem Members, nxsdDataDictionary Namespace, TnxDictionaryItem Properties


TnxEmptyDefaultValueDescriptor Class

TnxEmptyDefaultValueDescriptor Class
TnxEmptyDefaultValueDescriptor Methods TnxEmptyDefaultValueDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptornxsdDataDictionary_TnxEmptyDefaultValueDescriptor
Syntax
Delphi
TnxEmptyDefaultValueDescriptor = class(TnxBaseDefaultValueDescriptor);
File

nxsdDataDictionary

Description

This descriptor should be used if you want to set a fields default value to not null. The practical result: strings become '' (empty string), integers 0, etc.

By default all fields are NULL if not otherwise set.

Group

Classes

Links
TnxEmptyDefaultValueDescriptor Methods, TnxEmptyDefaultValueDescriptor Members, nxsdDataDictionary, Classes


TnxEmptyDefaultValueDescriptor Members

TnxEmptyDefaultValueDescriptor Members
TnxEmptyDefaultValueDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxEmptyDefaultValueDescriptor.

Class

TnxEmptyDefaultValueDescriptor Class

Protected Fields
Name | Description
bdvApplyAt | This is bdvApplyAt, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnInsert | This is bdvApplyOnInsert, a member of class TnxBaseDefaultValueDescriptor.
bdvApplyOnModify | This is bdvApplyOnModify, a member of class TnxBaseDefaultValueDescriptor.
bdvCachedEngineClass | private
bdvOverwriteNonNull | This is bdvOverwriteNonNull, a member of class TnxBaseDefaultValueDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bdvGetInvalidFieldTypes | TnxEmptyDefaultValueDescriptor
bdvSetApplyAt |
bdvSetApplyOnInsert |
bdvSetApplyOnModify |
bdvSetOverwriteNonNull |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ApplyAt | Apply the validation object on the server and/or client?
ApplyOnInsert | Should the check be applied on Insert of new record?
ApplyOnModify | Should the check be applied on record modification?
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseDefaultValueDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
OverwriteNonNull | ???
Links
TnxEmptyDefaultValueDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxEmptyDefaultValueDescriptor Methods

TnxEmptyDefaultValueDescriptor Methods
TnxEmptyDefaultValueDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxEmptyDefaultValueDescriptor class are listed here.

Class

TnxEmptyDefaultValueDescriptor Class

Protected Methods
Name | Description
bdvGetInvalidFieldTypes | TnxEmptyDefaultValueDescriptor
Links
TnxEmptyDefaultValueDescriptor Class, Legend, Protected Methods


TnxEmptyDefaultValueDescriptor.bdvGetInvalidFieldTypes Method

TnxEmptyDefaultValueDescriptor.bdvGetInvalidFieldTypes Method
TnxEmptyDefaultValueDescriptor Class TnxEmptyDefaultValueDescriptor Members nxsdDataDictionary Namespace TnxEmptyDefaultValueDescriptor Methods Send Feedback
Syntax
Delphi
function bdvGetInvalidFieldTypes: TnxFieldTypes; override;
Description

TnxEmptyDefaultValueDescriptor

Group

TnxEmptyDefaultValueDescriptor Methods

Links
TnxEmptyDefaultValueDescriptor Class, TnxEmptyDefaultValueDescriptor Members, nxsdDataDictionary Namespace, TnxEmptyDefaultValueDescriptor Methods


TnxExtTextKeyFieldDescriptor Class

TnxExtTextKeyFieldDescriptor Class
TnxExtTextKeyFieldDescriptor Methods TnxExtTextKeyFieldDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptornxsdDataDictionary_TnxExtTextKeyFieldDescriptor
Syntax
Delphi
TnxExtTextKeyFieldDescriptor = class(TnxTextKeyFieldDescriptor);
File

nxsdDataDictionary

Description

This is an extended version of the Text Key Field descriptor that can also handle Multi bytes characters, locale support, etc.

Group

Classes

Links
TnxExtTextKeyFieldDescriptor Methods, TnxExtTextKeyFieldDescriptor Members, nxsdDataDictionary, Classes


TnxExtTextKeyFieldDescriptor Members

TnxExtTextKeyFieldDescriptor Members
TnxExtTextKeyFieldDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExtTextKeyFieldDescriptor.

Class

TnxExtTextKeyFieldDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
kfdAscend | ..0=descending keys; 1=ascending keys.
kfdDesc | ..description of key field.
kfdFieldNumber | ..field number.
kfdKeyFieldEngine | ..name of the key field engine.
kfdNullBehaviour | This is kfdNullBehaviour, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthBytes | This is kfdOverrideLengthBytes, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthChars | This is kfdOverrideLengthChars, a member of class TnxKeyFieldDescriptor.
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
tkfIgnoreCase | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFieldChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diRequiresPack |
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
kfdGetField |
kfdGetKeyChars |
kfdGetKeyLength |
kfdSetFieldNumber |
kfdSetOverrideLengthBytes |
kfdSetOverrideLengthChars |
ldiGetUsedLocaleDescriptor |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls | TnxKeyFieldDescriptor
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
CheckValid |
Destroy | destructor.
Destroy |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IsEqual |
IsEqual | TnxTextKeyFieldDescriptor
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxExtTextKeyFieldDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
Ascend | If true the keys should be sorted ascending otherwise descending.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Desc | Used to store the description for this descriptor.
Field | This is a pointer to the associated Field descriptor.
FieldNumber | This property returns the index of the associated field in the field list of the Data Dictionary.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IgnoreCase | Set this to true if the sorting should not be case sensitive.
KeyChars | Returns the number of chars in tke key
KeyFieldEngine | The name of the Key Field Engine to create the Keys for each field.
KeyLength | Returns the length of the key
LocaleDescriptor | This property returns the associated Locale Descriptor.
NullBehaviour | defines what happens with NULLs in the key.
OverrideLengthBytes | Restricts the number of bytes used for the key generation. The index key will be built with this number of bytes only, irrespective of the actual field length. Applies to nxtWideString and nxtByteArray only! Use OverrideLengthChars for character based fields.
OverrideLengthChars | Restricts the number of chars used for the key generation. The index key will be built with this number of chars only, irrespective of the actual field length. Applies to nxtShortString and nxtNullString only! Use OverrideLengthBytes for byte based fields.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxExtTextKeyFieldDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExtTextKeyFieldDescriptor Methods

TnxExtTextKeyFieldDescriptor Methods
TnxExtTextKeyFieldDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxExtTextKeyFieldDescriptor class are listed here.

Class

TnxExtTextKeyFieldDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxExtTextKeyFieldDescriptor
SaveToWriter |
Links
TnxExtTextKeyFieldDescriptor Class, Legend, Public Methods


TnxExtTextKeyFieldDescriptor.LoadFromReader Method

TnxExtTextKeyFieldDescriptor.LoadFromReader Method
TnxExtTextKeyFieldDescriptor Class TnxExtTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxExtTextKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxExtTextKeyFieldDescriptor

Group

TnxExtTextKeyFieldDescriptor Methods

Links
TnxExtTextKeyFieldDescriptor Class, TnxExtTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxExtTextKeyFieldDescriptor Methods


TnxExtTextKeyFieldDescriptor.SaveToWriter Method

TnxExtTextKeyFieldDescriptor.SaveToWriter Method
TnxExtTextKeyFieldDescriptor Class TnxExtTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxExtTextKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxExtTextKeyFieldDescriptor Methods

Links
TnxExtTextKeyFieldDescriptor Class, TnxExtTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxExtTextKeyFieldDescriptor Methods


TnxFieldDescriptor Class

TnxFieldDescriptor Class
TnxFieldDescriptor Fields TnxFieldDescriptor Methods TnxFieldDescriptor Properties TnxFieldDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptornxsdDataDictionary_TnxFieldDescriptor
Syntax
Delphi
TnxFieldDescriptor = class(TnxLocalizedDictionaryItem, InxFieldDescriptor);
File

nxsdDataDictionary

Description

This descriptor class describes fields. For each field added to the Data Dictionary one instance is created.

Group

Classes

Links
TnxFieldDescriptor Fields, TnxFieldDescriptor Methods, TnxFieldDescriptor Properties, TnxFieldDescriptor Members, nxsdDataDictionary, Classes


TnxFieldDescriptor Members

TnxFieldDescriptor Members
TnxFieldDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldDescriptor.

Class

TnxFieldDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fdName | ..name of field
fdNameLowerCase | This is fdNameLowerCase, a member of class TnxFieldDescriptor.
fdNumber | This is fdNumber, a member of class TnxFieldDescriptor.
fdSameHashNext | This is fdSameHashNext, a member of class TnxFieldDescriptor.
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fdGetBufferAsVariant |
fdSetBufferAsVariant |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType |
GetFieldUnits |
GetList |
GetOwner |
IsValidFor |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
fdDecPl | The number of decimal places for the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdDefaultValue | The Default value descriptor assigned to this field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdDesc | fields are public for speed reasons !NEVER! change any of these values directly Description of the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdLength | The length of the field in bytes. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdNoClientAccess | True if this is a developer internal field. Fields marked like this will be ignored at TDataset level. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdOffset | The offset of the field in the record !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdRequired | True, if field must have a value to be stored !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdType | Type of the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdUnits | The number of characters/digits etc. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdValidations | The Validations descriptor assigned to this field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
Public Methods
Name | Description
AddDefaultValue | Sets the Default Value Descriptor class of the field. And instance of this descriptor will be used to generate the Default value of the field for every new record. TnxFieldDescriptor
AddDefaultValueT |
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddValidations | Sets the Validations Descriptor class of the field.
AddValidationsT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
ChangeName | Changes the name of the field.
CheckValid |
CreateStandaloneFromReader |
Destroy | destructor.
EnsureValidations | Sets the Validations Descriptor class of the field.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveDefaultValue | This method sets the Default Value Descriptor class to nil thus disabling default values for this field.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveValidations | This method sets the Validations Descriptor class to nil thus disabling validation for this field.
RequiresPack |
SaveStandalone |
SaveToWriter |
SetupField | This function returns the correct values for the various field types.
ToString |
UpdateSetup | Ensures that changed internal fields are applied correctly by recalculating Internal pointer, offsets, etc. Must be called after changing any of above fd... fields!
Public Properties
Name | Description
BufferAsVariant | Gets/Sets a FieldBuffer as OleVariant.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is the name of the field.
Number | The index in the list of fields of the ParentDataDictionary.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxFieldDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxFieldDescriptor.Create Constructor

TnxFieldDescriptor.Create Constructor
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aName: string; const aDesc: string; aType: TnxFieldType; aUnits: Integer; aDecPl: Integer; aRequired: Boolean); virtual;
Class

TnxFieldDescriptor Class

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Class


TnxFieldDescriptor.Destroy Destructor

TnxFieldDescriptor.Destroy Destructor
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxFieldDescriptor Class

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Class


TnxFieldDescriptor Fields

TnxFieldDescriptor Fields
TnxFieldDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxFieldDescriptor class are listed here.

Class

TnxFieldDescriptor Class

Protected Fields
Name | Description
fdName | ..name of field
fdNameLowerCase | This is fdNameLowerCase, a member of class TnxFieldDescriptor.
fdNumber | This is fdNumber, a member of class TnxFieldDescriptor.
fdSameHashNext | This is fdSameHashNext, a member of class TnxFieldDescriptor.
Public Fields
Name | Description
fdDecPl | The number of decimal places for the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdDefaultValue | The Default value descriptor assigned to this field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdDesc | fields are public for speed reasons !NEVER! change any of these values directly Description of the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdLength | The length of the field in bytes. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdNoClientAccess | True if this is a developer internal field. Fields marked like this will be ignored at TDataset level. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdOffset | The offset of the field in the record !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdRequired | True, if field must have a value to be stored !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdType | Type of the field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdUnits | The number of characters/digits etc. !NEVER! change this field directly, but use the Data Dictionary methods instead!
fdValidations | The Validations descriptor assigned to this field. !NEVER! change this field directly, but use the Data Dictionary methods instead!
Links
TnxFieldDescriptor Class, Legend, Protected Fields, Public Fields


TnxFieldDescriptor.fdDecPl Field

TnxFieldDescriptor.fdDecPl Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdDecPl: Integer;
Description

The number of decimal places for the field.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdDefaultValue Field

TnxFieldDescriptor.fdDefaultValue Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdDefaultValue: TnxBaseDefaultValueDescriptor;
Description

The Default value descriptor assigned to this field.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdDesc Field

TnxFieldDescriptor.fdDesc Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdDesc: string;
Description

fields are public for speed reasons !NEVER! change any of these values directly Description of the field.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdLength Field

TnxFieldDescriptor.fdLength Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdLength: Integer;
Description

The length of the field in bytes.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdName Field

TnxFieldDescriptor.fdName Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdName: string;
Description

..name of field

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdNameLowerCase Field

TnxFieldDescriptor.fdNameLowerCase Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdNameLowerCase: string;
Description

This is fdNameLowerCase, a member of class TnxFieldDescriptor.

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdNoClientAccess Field

TnxFieldDescriptor.fdNoClientAccess Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdNoClientAccess: Boolean;
Description

True if this is a developer internal field. Fields marked like this will be ignored at TDataset level.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdNumber Field

TnxFieldDescriptor.fdNumber Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdNumber: Integer;
Description

This is fdNumber, a member of class TnxFieldDescriptor.

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdOffset Field

TnxFieldDescriptor.fdOffset Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdOffset: Integer;
Description

The offset of the field in the record

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdRequired Field

TnxFieldDescriptor.fdRequired Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdRequired: Boolean;
Description

True, if field must have a value to be stored

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdSameHashNext Field

TnxFieldDescriptor.fdSameHashNext Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdSameHashNext: TnxFieldDescriptor;
Description

This is fdSameHashNext, a member of class TnxFieldDescriptor.

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdType Field

TnxFieldDescriptor.fdType Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdType: TnxFieldType;
Description

Type of the field.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdUnits Field

TnxFieldDescriptor.fdUnits Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdUnits: Integer;
Description

The number of characters/digits etc.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor.fdValidations Field

TnxFieldDescriptor.fdValidations Field
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Fields Send Feedback
Syntax
Delphi
fdValidations: TnxFieldValidationsDescriptor;
Description

The Validations descriptor assigned to this field.

!NEVER! change this field directly, but use the Data Dictionary methods instead!

Group

TnxFieldDescriptor Fields

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Fields


TnxFieldDescriptor Methods

TnxFieldDescriptor Methods
TnxFieldDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldDescriptor class are listed here.

Class

TnxFieldDescriptor Class

Protected Methods
Name | Description
fdGetBufferAsVariant |
fdSetBufferAsVariant |
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType |
GetFieldUnits |
GetList |
IsValidFor |
Public Methods
Name | Description
AddDefaultValue | Sets the Default Value Descriptor class of the field. And instance of this descriptor will be used to generate the Default value of the field for every new record. TnxFieldDescriptor
AddDefaultValueT |
AddValidations | Sets the Validations Descriptor class of the field.
AddValidationsT |
ChangeName | Changes the name of the field.
CheckValid |
CreateStandaloneFromReader |
EnsureValidations | Sets the Validations Descriptor class of the field.
FindRelatedDescriptorOfType |
IsEqual |
LoadFromReader |
RemoveDefaultValue | This method sets the Default Value Descriptor class to nil thus disabling default values for this field.
RemoveValidations | This method sets the Validations Descriptor class to nil thus disabling validation for this field.
SaveStandalone |
SaveToWriter |
SetupField | This function returns the correct values for the various field types.
ToString |
UpdateSetup | Ensures that changed internal fields are applied correctly by recalculating Internal pointer, offsets, etc. Must be called after changing any of above fd... fields!
Links
TnxFieldDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldDescriptor.AddDefaultValue Method

TnxFieldDescriptor.AddDefaultValue Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function AddDefaultValue(aClass: TnxBaseDefaultValueDescriptorClass = nil): TnxBaseDefaultValueDescriptor;
Description

Sets the Default Value Descriptor class of the field. And instance of this descriptor will be used to generate the Default value of the field for every new record.

TnxFieldDescriptor

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.AddDefaultValueT Method

TnxFieldDescriptor.AddDefaultValueT Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function AddDefaultValueT<T: TnxBaseDefaultValueDescriptor>: T;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.AddValidations Method

TnxFieldDescriptor.AddValidations Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidations(aClass: TnxFieldValidationsDescriptorClass = nil): TnxFieldValidationsDescriptor;
Description

Sets the Validations Descriptor class of the field.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.AddValidationsT Method

TnxFieldDescriptor.AddValidationsT Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidationsT<T: TnxFieldValidationsDescriptor>: T;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.ChangeName Method

TnxFieldDescriptor.ChangeName Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure ChangeName(const aNewName: string);
Description

Changes the name of the field.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.CheckValid Method

TnxFieldDescriptor.CheckValid Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.CreateStandaloneFromReader Method

TnxFieldDescriptor.CreateStandaloneFromReader Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
class function CreateStandaloneFromReader(aReader: TnxReader): TnxFieldDescriptor;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.EnsureValidations Method

TnxFieldDescriptor.EnsureValidations Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function EnsureValidations: TnxFieldValidationsDescriptor;
Description

Sets the Validations Descriptor class of the field.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.fdGetBufferAsVariant Method

TnxFieldDescriptor.fdGetBufferAsVariant Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function fdGetBufferAsVariant(aFieldBuffer: PnxByteArray): OleVariant;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.fdSetBufferAsVariant Method

TnxFieldDescriptor.fdSetBufferAsVariant Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure fdSetBufferAsVariant(aFieldBuffer: PnxByteArray; const aValue: OleVariant);
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.FindRelatedDescriptorOfType Method

TnxFieldDescriptor.FindRelatedDescriptorOfType Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.GetFieldDecPl Method

TnxFieldDescriptor.GetFieldDecPl Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldDecPl: Integer;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.GetFieldName Method

TnxFieldDescriptor.GetFieldName Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldName: string;
Description

InxFieldDescriptor

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.GetFieldType Method

TnxFieldDescriptor.GetFieldType Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldType: TnxFieldType;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.GetFieldUnits Method

TnxFieldDescriptor.GetFieldUnits Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldUnits: Integer;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.GetList Method

TnxFieldDescriptor.GetList Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.IsEqual Method

TnxFieldDescriptor.IsEqual Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.IsValidFor Method

TnxFieldDescriptor.IsValidFor Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function IsValidFor(aDescriptor: TnxBaseTableDescriptor): Boolean; virtual;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.LoadFromReader Method

TnxFieldDescriptor.LoadFromReader Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.RemoveDefaultValue Method

TnxFieldDescriptor.RemoveDefaultValue Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveDefaultValue;
Description

This method sets the Default Value Descriptor class to nil thus disabling default values for this field.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.RemoveValidations Method

TnxFieldDescriptor.RemoveValidations Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveValidations;
Description

This method sets the Validations Descriptor class to nil thus disabling validation for this field.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.SaveStandalone Method

TnxFieldDescriptor.SaveStandalone Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveStandalone(aWriter: TnxWriter; aVersion: Integer);
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.SaveToWriter Method

TnxFieldDescriptor.SaveToWriter Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.SetupField Method

TnxFieldDescriptor.SetupField Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
class procedure SetupField(aType: TnxFieldType; var aUnits: Integer; var aDecPl: Integer; var aRequired: Boolean; out aLength: Integer); virtual;
Parameters
Parameters | Description
aType: TnxFieldType | the Field type you need the values for
var aUnits: Integer | the units wanted/needed for the given field type. Will be changed if invalid!
var aDecPl: Integer | the number of decimal places wanted. Will be changed if invalid!
var aRequired: Boolean | set to true if you want the field to be required. Will be changed if invalid!
out aLength: Integer | this will be the length in bytes needed for this field.
Description

This function returns the correct values for the various field types.

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.ToString Method

TnxFieldDescriptor.ToString Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function ToString: string; override;
Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor.UpdateSetup Method

TnxFieldDescriptor.UpdateSetup Method
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure UpdateSetup;
Description

Ensures that changed internal fields are applied correctly by recalculating Internal pointer, offsets, etc. Must be called after changing any of above fd... fields!

Group

TnxFieldDescriptor Methods

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Methods


TnxFieldDescriptor Properties

TnxFieldDescriptor Properties
TnxFieldDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFieldDescriptor class are listed here.

Class

TnxFieldDescriptor Class

Public Properties
Name | Description
BufferAsVariant | Gets/Sets a FieldBuffer as OleVariant.
Name | This is the name of the field.
Number | The index in the list of fields of the ParentDataDictionary.
Links
TnxFieldDescriptor Class, Legend, Public Properties


TnxFieldDescriptor.BufferAsVariant Property

TnxFieldDescriptor.BufferAsVariant Property
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property BufferAsVariant [aFieldBuffer: PnxByteArray]: OleVariant;
Description

Gets/Sets a FieldBuffer as OleVariant.

Group

TnxFieldDescriptor Properties

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Properties


TnxFieldDescriptor.Name Property

TnxFieldDescriptor.Name Property
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is the name of the field.

Group

TnxFieldDescriptor Properties

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Properties


TnxFieldDescriptor.Number Property

TnxFieldDescriptor.Number Property
TnxFieldDescriptor Class TnxFieldDescriptor Members nxsdDataDictionary Namespace TnxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property Number: Integer;
Description

The index in the list of fields of the ParentDataDictionary.

Group

TnxFieldDescriptor Properties

Links
TnxFieldDescriptor Class, TnxFieldDescriptor Members, nxsdDataDictionary Namespace, TnxFieldDescriptor Properties


TnxFieldsDescriptor Class

TnxFieldsDescriptor Class
TnxFieldsDescriptor Fields TnxFieldsDescriptor Methods TnxFieldsDescriptor Properties TnxFieldsDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptornxsdDataDictionary_TnxFieldsDescriptor
Syntax
Delphi
TnxFieldsDescriptor = class(TnxDictionaryItem, InxFieldsSource);
File

nxsdDataDictionary

Description

The Fields Descriptor holds a list of FieldDescriptors for the associated Data Dictionary.

Group

Classes

Links
TnxFieldsDescriptor Fields, TnxFieldsDescriptor Methods, TnxFieldsDescriptor Properties, TnxFieldsDescriptor Members, nxsdDataDictionary, Classes


TnxFieldsDescriptor Members

TnxFieldsDescriptor Members
TnxFieldsDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldsDescriptor.

Class

TnxFieldsDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fsdCachedEngineClass | This is fsdCachedEngineClass, a member of class TnxFieldsDescriptor.
fsdCachedGetRecordLength | This is fsdCachedGetRecordLength, a member of class TnxFieldsDescriptor.
fsdFieldChangeNotifies | This is fsdFieldChangeNotifies, a member of class TnxFieldsDescriptor.
fsdFieldHashList | This is fsdFieldHashList, a member of class TnxFieldsDescriptor.
fsdLogRecLen | logical rec length.
fsdLogRecLenAlign | logical rec length incl. alignment.
fsdValidations | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxFieldsDescriptor.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fsdAddToFieldChangeNotifies |
fsdGetBaseRecordLength |
fsdGetFieldByIndexAsVariant |
fsdGetFieldByNameAsVariant |
fsdGetOriginalFieldCount |
fsdGetRecordLength |
fsdRemoveFromFieldChangeNotifies |
fsdSetFieldByIndexAsVariant |
fsdSetFieldByNameAsVariant |
fsdSetOriginalFieldCount |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldCount |
GetFieldDescriptor |
GetFieldsOffset |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
FieldCount | The number of field descriptors in the list.
FieldDescriptor | fields are public for speed reasons The field descriptors for this table.
Public Methods
Name | Description
AddField | This is the overview for the AddField method overload.
AddFieldT |
AddValidations | Sets the Validations Descriptor class of the field.
AddValidationsT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | This function clears the Data Dictionary.
Create | constructor.
Destroy | destructor.
EnsureValidations | Sets the Validations Descriptor class of the field.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
fsdFieldChangeNotification | Notifies all Fields registered for change notification about a field change.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldForFilter | Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetFieldFromNameFast | Return the field number for a given field name, or -1 if not found. Requires that the passed in field name is all lower case
GetFields | Fills a TStrings object with a list of all fields and references to the TnxFieldDescriptor objects.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRecordField | Given a record buffer, reads the field data.
GetRecordFieldForFilter | This is the overview for the GetRecordFieldForFilter method overload.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
HasAutoIncField | Return True and the index of the first autoinc field in the dictionary.
HasBlobFields | Returns True if the table contains any Blob fields.
HasRecRevField | Return True and the index of the first recrev field in the dictionary.
HasSameFields | Use this method to verify a dictionary has the same field types, sizes, and ordering as a source dictionary. Returns True if the field information matches otherwise returns False. Note that the fields may have different names. If the record contains any Blob fields, the number of each Blob field is stored in output parameter aBlobFields.
InitRecord | Given a record buffer, initialize it so that all fields are null
InsertFieldAt | This function adds a new instance of a Field Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.
InsertFieldAtT |
IsEqual |
IsRecordFieldNull | Given a record buffer, return True if the field is null.
IsRecordFieldNullFast |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
MoveField | Moves a FieldDescriptor from position aFrom to aTo in the list of Field Descriptors.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
RecordBufferToString |
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveField | Remove a Field Descriptor from the Data Dictionary.
RemoveValidations | This method sets the Validations Descriptor class to nil thus disabling validation for this field.
RequiresPack |
SaveToWriter |
SetRecordField | Given a record buffer, write the required field from the buffer pointed to by aValue; if aValue is nil, the field is set to null.
SetRecordFieldNull | Given a record buffer, set the required field to null or non-null. Set the field in the record to binary zeros.
UpdateLogRecLenAlign | Updates the Record Alignment
UpdateSetupAndOffsets | calls UpdateSetup on all fields and recalculates field offsets then calls UpdateLogRecLenAlign
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxFieldsDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldByIndexAsVariant | Gets/Sets the value of the field on position aIndex as OleVariant in the given aRecordBuffer.
FieldByNameAsVariant | Gets/Sets the value of a named field as OleVariant in the given aRecordBuffer.
FieldsOffset | This is FieldsOffset, a member of class TnxFieldsDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LogicalRecordLength | The length of the logical record for the data dictionary (ie just the total size of the fields.
OriginalFieldCount | This is OriginalFieldCount, a member of class TnxFieldsDescriptor.
RecordLength | The length of the physical record for the data dictionary. Includes trailing byte array to identify null fields.
Validations | Gives access to all Field validation descriptors.
Links
TnxFieldsDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxFieldsDescriptor.Create Constructor

TnxFieldsDescriptor.Create Constructor
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxFieldsDescriptor Class

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Class


TnxFieldsDescriptor.Destroy Destructor

TnxFieldsDescriptor.Destroy Destructor
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxFieldsDescriptor Class

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Class


TnxFieldsDescriptor Fields

TnxFieldsDescriptor Fields
TnxFieldsDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxFieldsDescriptor class are listed here.

Class

TnxFieldsDescriptor Class

Protected Fields
Name | Description
fsdCachedEngineClass | This is fsdCachedEngineClass, a member of class TnxFieldsDescriptor.
fsdCachedGetRecordLength | This is fsdCachedGetRecordLength, a member of class TnxFieldsDescriptor.
fsdFieldChangeNotifies | This is fsdFieldChangeNotifies, a member of class TnxFieldsDescriptor.
fsdFieldHashList | This is fsdFieldHashList, a member of class TnxFieldsDescriptor.
fsdLogRecLen | logical rec length.
fsdLogRecLenAlign | logical rec length incl. alignment.
fsdValidations | private
Public Fields
Name | Description
FieldCount | The number of field descriptors in the list.
FieldDescriptor | fields are public for speed reasons The field descriptors for this table.
Links
TnxFieldsDescriptor Class, Legend, Protected Fields, Public Fields


TnxFieldsDescriptor.FieldCount Field

TnxFieldsDescriptor.FieldCount Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
FieldCount: Integer;
Description

The number of field descriptors in the list.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.FieldDescriptor Field

TnxFieldsDescriptor.FieldDescriptor Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
FieldDescriptor: array of TnxFieldDescriptor;
Description

fields are public for speed reasons The field descriptors for this table.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdCachedEngineClass Field

TnxFieldsDescriptor.fsdCachedEngineClass Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdCachedEngineClass: TClass;
Description

This is fsdCachedEngineClass, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdCachedGetRecordLength Field

TnxFieldsDescriptor.fsdCachedGetRecordLength Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdCachedGetRecordLength: Integer;
Description

This is fsdCachedGetRecordLength, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdFieldChangeNotifies Field

TnxFieldsDescriptor.fsdFieldChangeNotifies Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdFieldChangeNotifies: TnxSortedList;
Description

This is fsdFieldChangeNotifies, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdFieldHashList Field

TnxFieldsDescriptor.fsdFieldHashList Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdFieldHashList: array of TnxFieldDescriptor;
Description

This is fsdFieldHashList, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdLogRecLen Field

TnxFieldsDescriptor.fsdLogRecLen Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdLogRecLen: Integer;
Description

logical rec length.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdLogRecLenAlign Field

TnxFieldsDescriptor.fsdLogRecLenAlign Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdLogRecLenAlign: Integer;
Description

logical rec length incl. alignment.

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor.fsdValidations Field

TnxFieldsDescriptor.fsdValidations Field
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Fields Send Feedback
Syntax
Delphi
fsdValidations: TnxFieldsValidationsDescriptor;
Description

private

Group

TnxFieldsDescriptor Fields

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Fields


TnxFieldsDescriptor Methods

TnxFieldsDescriptor Methods
TnxFieldsDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldsDescriptor class are listed here.

Class

TnxFieldsDescriptor Class

Protected Methods
Name | Description
BlobsSupported |
diActivateCaching | caching
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxFieldsDescriptor.
fsdAddToFieldChangeNotifies |
fsdGetBaseRecordLength |
fsdGetFieldByIndexAsVariant |
fsdGetFieldByNameAsVariant |
fsdGetOriginalFieldCount |
fsdGetRecordLength |
fsdRemoveFromFieldChangeNotifies |
fsdSetFieldByIndexAsVariant |
fsdSetFieldByNameAsVariant |
fsdSetOriginalFieldCount |
GetCursor |
GetFieldCount |
GetFieldDescriptor |
GetFieldsOffset |
GetList |
Public Methods
Name | Description
AddField | This is the overview for the AddField method overload.
AddFieldT |
AddValidations | Sets the Validations Descriptor class of the field.
AddValidationsT |
CheckValid |
Clear | This function clears the Data Dictionary.
EnsureValidations | Sets the Validations Descriptor class of the field.
fsdFieldChangeNotification | Notifies all Fields registered for change notification about a field change.
GetFieldForFilter | Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetFieldFromNameFast | Return the field number for a given field name, or -1 if not found. Requires that the passed in field name is all lower case
GetFields | Fills a TStrings object with a list of all fields and references to the TnxFieldDescriptor objects.
GetRecordField | Given a record buffer, reads the field data.
GetRecordFieldForFilter | This is the overview for the GetRecordFieldForFilter method overload.
HasAutoIncField | Return True and the index of the first autoinc field in the dictionary.
HasBlobFields | Returns True if the table contains any Blob fields.
HasRecRevField | Return True and the index of the first recrev field in the dictionary.
HasSameFields | Use this method to verify a dictionary has the same field types, sizes, and ordering as a source dictionary. Returns True if the field information matches otherwise returns False. Note that the fields may have different names. If the record contains any Blob fields, the number of each Blob field is stored in output parameter aBlobFields.
InitRecord | Given a record buffer, initialize it so that all fields are null
InsertFieldAt | This function adds a new instance of a Field Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.
InsertFieldAtT |
IsEqual |
IsRecordFieldNull | Given a record buffer, return True if the field is null.
IsRecordFieldNullFast |
LoadFromReader |
MoveField | Moves a FieldDescriptor from position aFrom to aTo in the list of Field Descriptors.
RecordBufferToString |
RemoveField | Remove a Field Descriptor from the Data Dictionary.
RemoveValidations | This method sets the Validations Descriptor class to nil thus disabling validation for this field.
SaveToWriter |
SetRecordField | Given a record buffer, write the required field from the buffer pointed to by aValue; if aValue is nil, the field is set to null.
SetRecordFieldNull | Given a record buffer, set the required field to null or non-null. Set the field in the record to binary zeros.
UpdateLogRecLenAlign | Updates the Record Alignment
UpdateSetupAndOffsets | calls UpdateSetup on all fields and recalculates field offsets then calls UpdateLogRecLenAlign
Links
TnxFieldsDescriptor Class, Legend, Protected Methods, Public Methods


AddField Method

AddField Method
TnxFieldsDescriptor Methods Send Feedback

This is the overview for the AddField method overload.

Overload List
Name | Description
TnxFieldsDescriptor.AddField (string, string, TnxFieldType, Integer, Integer, Boolean, TnxFieldDescriptorClass) | This function adds a new instance of a Field Descriptor to the data dictionary and returns the newly created Instance.
TnxFieldsDescriptor.AddField (TnxFieldDescriptor) | This function adds a new instance of an Field Descriptor to the indices descriptor and returns the newly created Instance.
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Methods


TnxFieldsDescriptor.AddField Method (TnxFieldDescriptor)

TnxFieldsDescriptor.AddField Method (TnxFieldDescriptor)
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace AddField Method Send Feedback
Syntax
Delphi
function AddField(aFieldDescriptor: TnxFieldDescriptor): TnxFieldDescriptor; overload;
Parameters
Parameters | Description
aFieldDescriptor: TnxFieldDescriptor | the descriptor of which a copy is to be added.
Description

This function adds a new instance of an Field Descriptor to the indices descriptor and returns the newly created Instance.

Group

AddField Method

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, AddField Method


TnxFieldsDescriptor.AddField Method (string, string, TnxFieldType, Integer, Integer, Boolean, TnxFieldDescriptorClass)

TnxFieldsDescriptor.AddField Method (string, string, TnxFieldType, Integer, Integer, Boolean, TnxFieldDescriptorClass)
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace AddField Method Send Feedback
Syntax
Delphi
function AddField(const aName: string; const aDesc: string; aType: TnxFieldType; aUnits: Integer; aDecPl: Integer; aRequired: Boolean; aClass: TnxFieldDescriptorClass = nil): TnxFieldDescriptor; overload;
Parameters
Parameters | Description
const aName: string | the field name
const aDesc: string | a human readable description of the field
aType: TnxFieldType | the field type
aUnits: Integer | Units needed/wanted for the field
aDecPl: Integer | the number of decimal places for the field (if applicable)
aRequired: Boolean | set to True if the field needs a value.
aClass: TnxFieldDescriptorClass = nil | the class of the instance to be created. TnxFieldsDescriptor
Description

This function adds a new instance of a Field Descriptor to the data dictionary and returns the newly created Instance.

Group

AddField Method

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, AddField Method


TnxFieldsDescriptor.AddFieldT Method

TnxFieldsDescriptor.AddFieldT Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function AddFieldT<T: TnxFieldDescriptor>(const aName: string; const aDesc: string; aType: TnxFieldType; aUnits: Integer; aDecPl: Integer; aRequired: Boolean): T;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.AddValidations Method

TnxFieldsDescriptor.AddValidations Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidations(aClass: TnxFieldsValidationsDescriptorClass = nil): TnxFieldsValidationsDescriptor;
Description

Sets the Validations Descriptor class of the field.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.AddValidationsT Method

TnxFieldsDescriptor.AddValidationsT Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidationsT<T: TnxFieldsValidationsDescriptor>: T;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.BlobsSupported Method

TnxFieldsDescriptor.BlobsSupported Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function BlobsSupported: Boolean;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.CheckValid Method

TnxFieldsDescriptor.CheckValid Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.Clear Method

TnxFieldsDescriptor.Clear Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear(aNotify: Boolean); virtual;
Description

This function clears the Data Dictionary.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.diActivateCaching Method

TnxFieldsDescriptor.diActivateCaching Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure diActivateCaching; override;
Description

caching

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.diDeactivateCaching Method

TnxFieldsDescriptor.diDeactivateCaching Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure diDeactivateCaching; override;
Description

This is diDeactivateCaching, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.EnsureValidations Method

TnxFieldsDescriptor.EnsureValidations Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function EnsureValidations: TnxFieldsValidationsDescriptor;
Description

Sets the Validations Descriptor class of the field.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdAddToFieldChangeNotifies Method

TnxFieldsDescriptor.fsdAddToFieldChangeNotifies Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdAddToFieldChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdFieldChangeNotification Method

TnxFieldsDescriptor.fsdFieldChangeNotification Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdFieldChangeNotification(aBefore: Boolean; aOldField: Integer; aNewField: Integer);
Description

Notifies all Fields registered for change notification about a field change.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdGetBaseRecordLength Method

TnxFieldsDescriptor.fsdGetBaseRecordLength Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetBaseRecordLength: Integer;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdGetFieldByIndexAsVariant Method

TnxFieldsDescriptor.fsdGetFieldByIndexAsVariant Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetFieldByIndexAsVariant(aRecordBuffer: PnxByteArray; aIndex: Integer): OleVariant;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdGetFieldByNameAsVariant Method

TnxFieldsDescriptor.fsdGetFieldByNameAsVariant Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetFieldByNameAsVariant(aRecordBuffer: PnxByteArray; const aName: string): OleVariant;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdGetOriginalFieldCount Method

TnxFieldsDescriptor.fsdGetOriginalFieldCount Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetOriginalFieldCount: Integer;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdGetRecordLength Method

TnxFieldsDescriptor.fsdGetRecordLength Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetRecordLength: Integer;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdRemoveFromFieldChangeNotifies Method

TnxFieldsDescriptor.fsdRemoveFromFieldChangeNotifies Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdRemoveFromFieldChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdSetFieldByIndexAsVariant Method

TnxFieldsDescriptor.fsdSetFieldByIndexAsVariant Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdSetFieldByIndexAsVariant(aRecordBuffer: PnxByteArray; aIndex: Integer; const aValue: OleVariant);
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdSetFieldByNameAsVariant Method

TnxFieldsDescriptor.fsdSetFieldByNameAsVariant Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdSetFieldByNameAsVariant(aRecordBuffer: PnxByteArray; const aName: string; const aValue: OleVariant);
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.fsdSetOriginalFieldCount Method

TnxFieldsDescriptor.fsdSetOriginalFieldCount Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure fsdSetOriginalFieldCount(aCount: Integer);
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetCursor Method

TnxFieldsDescriptor.GetCursor Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetCursor: TObject;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldCount Method

TnxFieldsDescriptor.GetFieldCount Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldDescriptor Method

TnxFieldsDescriptor.GetFieldDescriptor Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldForFilter Method

TnxFieldsDescriptor.GetFieldForFilter Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aData: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean;
Parameters
Parameters | Description
aField: Integer | the index of the field in the list of Field Descriptors.
aName: PAnsiChar | the name of the field.
aData: PnxByteArray | a pointer to the record buffer.
out aType: TnxWord16 | returns the field type.
out aSize: TnxWord16 | returns the data size of the field.
out aIsNull: Boolean | is set to true if the field is null. no data is written to aValue in this case
out aValue: Pointer | a pointer to a buffer to receive the field data.
Description

Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldFromName Method

TnxFieldsDescriptor.GetFieldFromName Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer;
Description

Return the field number for a given field name, or -1 if not found.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldFromNameFast Method

TnxFieldsDescriptor.GetFieldFromNameFast Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldFromNameFast(const aFieldName: string): Integer;
Description

Return the field number for a given field name, or -1 if not found. Requires that the passed in field name is all lower case

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFields Method

TnxFieldsDescriptor.GetFields Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure GetFields(aStrings: TStrings);
Parameters
Parameters | Description
aStrings: TStrings | non nil reference to a TStrings object which will be filled with a list of all fieldnames.
Description

Fills a TStrings object with a list of all fields and references to the TnxFieldDescriptor objects.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetFieldsOffset Method

TnxFieldsDescriptor.GetFieldsOffset Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldsOffset: integer;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetList Method

TnxFieldsDescriptor.GetList Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetRecordField Method

TnxFieldsDescriptor.GetRecordField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure GetRecordField(aField: Integer; aData: PnxByteArray; var aIsNull: Boolean; aValue: Pointer);
Parameters
Parameters | Description
aField: Integer | the index of the field in the list of Field Descriptors.
aData: PnxByteArray | a pointer to the record buffer
var aIsNull: Boolean | is set to true if the field is null. no data is written to aValue in this case
aValue: Pointer | a pointer to a buffer to receive the field data.
Description

Given a record buffer, reads the field data.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


GetRecordFieldForFilter Method

GetRecordFieldForFilter Method
TnxFieldsDescriptor Methods Send Feedback

This is the overview for the GetRecordFieldForFilter method overload.

Overload List
Name | Description
TnxFieldsDescriptor.GetRecordFieldForFilter (Integer, PnxByteArray) | Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.
TnxFieldsDescriptor.GetRecordFieldForFilter (Integer, PnxByteArray, TnxFieldType, TnxWord16, Pointer) | Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Methods


TnxFieldsDescriptor.GetRecordFieldForFilter Method (Integer, PnxByteArray)

TnxFieldsDescriptor.GetRecordFieldForFilter Method (Integer, PnxByteArray)
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace GetRecordFieldForFilter Method Send Feedback
Syntax
Delphi
function GetRecordFieldForFilter(aField: Integer; aData: PnxByteArray): Pointer; overload;
Parameters
Parameters | Description
aField: Integer | edx
Description

Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.

Group

GetRecordFieldForFilter Method

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, GetRecordFieldForFilter Method


TnxFieldsDescriptor.GetRecordFieldForFilter Method (Integer, PnxByteArray, TnxFieldType, TnxWord16, Pointer)

TnxFieldsDescriptor.GetRecordFieldForFilter Method (Integer, PnxByteArray, TnxFieldType, TnxWord16, Pointer)
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace GetRecordFieldForFilter Method Send Feedback
Syntax
Delphi
function GetRecordFieldForFilter(aField: Integer; aData: PnxByteArray; out aType: TnxFieldType; out aSize: TnxWord16; out aValue: Pointer): Boolean; overload;
Description

Given a record buffer, returns the pointer to the field data. Be careful because aValue is NOT a copy of the data but a pointer into the actual record buffer. This is a VERY fast method to access the raw field data.

Group

GetRecordFieldForFilter Method

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, GetRecordFieldForFilter Method


TnxFieldsDescriptor.HasAutoIncField Method

TnxFieldsDescriptor.HasAutoIncField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function HasAutoIncField(var aField: Integer): Boolean;
Description

Return True and the index of the first autoinc field in the dictionary.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.HasBlobFields Method

TnxFieldsDescriptor.HasBlobFields Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function HasBlobFields(aBlobFields: TnxList = nil): Boolean;
Description

Returns True if the table contains any Blob fields.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.HasRecRevField Method

TnxFieldsDescriptor.HasRecRevField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function HasRecRevField(var aField: Integer): Boolean;
Description

Return True and the index of the first recrev field in the dictionary.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.HasSameFields Method

TnxFieldsDescriptor.HasSameFields Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function HasSameFields(aSource: TnxFieldsDescriptor; aBlobFields: TnxList): Boolean;
Description

Use this method to verify a dictionary has the same field types, sizes, and ordering as a source dictionary. Returns True if the field information matches otherwise returns False. Note that the fields may have different names. If the record contains any Blob fields, the number of each Blob field is stored in output parameter aBlobFields.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.InitRecord Method

TnxFieldsDescriptor.InitRecord Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure InitRecord(aData: PnxByteArray);
Description

Given a record buffer, initialize it so that all fields are null

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.InsertFieldAt Method

TnxFieldsDescriptor.InsertFieldAt Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function InsertFieldAt(aInx: Integer; const aName: string; const aDesc: string; aType: TnxFieldType; aUnits: Integer; aDecPl: Integer; aRequired: Boolean; aClass: TnxFieldDescriptorClass = nil): TnxFieldDescriptor;
Parameters
Parameters | Description
aInx: Integer | the index of the new field
const aName: string | the field name
const aDesc: string | a human readable description of the field
aType: TnxFieldType | the field type
aUnits: Integer | Units needed/wanted for the field
aDecPl: Integer | the number of decimal places for the field (if applicable)
aRequired: Boolean | set to True if the field needs a value.
aClass: TnxFieldDescriptorClass = nil | the class of the instance to be created.
Description

This function adds a new instance of a Field Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.InsertFieldAtT Method

TnxFieldsDescriptor.InsertFieldAtT Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function InsertFieldAtT<T: TnxFieldDescriptor>(aInx: Integer; const aName: string; const aDesc: string; aType: TnxFieldType; aUnits: Integer; aDecPl: Integer; aRequired: Boolean): T;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.IsEqual Method

TnxFieldsDescriptor.IsEqual Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.IsRecordFieldNull Method

TnxFieldsDescriptor.IsRecordFieldNull Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function IsRecordFieldNull(aField: Integer; aData: PnxByteArray): Boolean;
Description

Given a record buffer, return True if the field is null.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.IsRecordFieldNullFast Method

TnxFieldsDescriptor.IsRecordFieldNullFast Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function IsRecordFieldNullFast(aField: Integer; aData: PnxByteArray): Boolean;
Parameters
Parameters | Description
aField: Integer | edx ecx
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.LoadFromReader Method

TnxFieldsDescriptor.LoadFromReader Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.MoveField Method

TnxFieldsDescriptor.MoveField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure MoveField(aFrom: Integer; aTo: Integer);
Description

Moves a FieldDescriptor from position aFrom to aTo in the list of Field Descriptors.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.RecordBufferToString Method

TnxFieldsDescriptor.RecordBufferToString Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
function RecordBufferToString(aRecordBuffer: PnxByteArray): string;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.RemoveField Method

TnxFieldsDescriptor.RemoveField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveField(aInx: Integer);
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of Field Descriptors.
Description

Remove a Field Descriptor from the Data Dictionary.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.RemoveValidations Method

TnxFieldsDescriptor.RemoveValidations Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveValidations;
Description

This method sets the Validations Descriptor class to nil thus disabling validation for this field.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.SaveToWriter Method

TnxFieldsDescriptor.SaveToWriter Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.SetRecordField Method

TnxFieldsDescriptor.SetRecordField Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure SetRecordField(aField: Integer; aData: Pointer; aValue: Pointer);
Description

Given a record buffer, write the required field from the buffer pointed to by aValue; if aValue is nil, the field is set to null.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.SetRecordFieldNull Method

TnxFieldsDescriptor.SetRecordFieldNull Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure SetRecordFieldNull(aField: Integer; aData: PnxByteArray; aIsNull: Boolean);
Description

Given a record buffer, set the required field to null or non-null. Set the field in the record to binary zeros.

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.UpdateLogRecLenAlign Method

TnxFieldsDescriptor.UpdateLogRecLenAlign Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure UpdateLogRecLenAlign;
Description

Updates the Record Alignment

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor.UpdateSetupAndOffsets Method

TnxFieldsDescriptor.UpdateSetupAndOffsets Method
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Methods Send Feedback
Syntax
Delphi
procedure UpdateSetupAndOffsets;
Description

calls UpdateSetup on all fields and recalculates field offsets then calls UpdateLogRecLenAlign

Group

TnxFieldsDescriptor Methods

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Methods


TnxFieldsDescriptor Properties

TnxFieldsDescriptor Properties
TnxFieldsDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFieldsDescriptor class are listed here.

Class

TnxFieldsDescriptor Class

Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxFieldsDescriptor.
FieldByIndexAsVariant | Gets/Sets the value of the field on position aIndex as OleVariant in the given aRecordBuffer.
FieldByNameAsVariant | Gets/Sets the value of a named field as OleVariant in the given aRecordBuffer.
FieldsOffset | This is FieldsOffset, a member of class TnxFieldsDescriptor.
LogicalRecordLength | The length of the logical record for the data dictionary (ie just the total size of the fields.
OriginalFieldCount | This is OriginalFieldCount, a member of class TnxFieldsDescriptor.
RecordLength | The length of the physical record for the data dictionary. Includes trailing byte array to identify null fields.
Validations | Gives access to all Field validation descriptors.
Links
TnxFieldsDescriptor Class, Legend, Public Properties


TnxFieldsDescriptor.CachedEngineClass Property

TnxFieldsDescriptor.CachedEngineClass Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.FieldByIndexAsVariant Property

TnxFieldsDescriptor.FieldByIndexAsVariant Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property FieldByIndexAsVariant [aRecordBuffer: PnxByteArray; aIndex: Integer]: OleVariant;
Description

Gets/Sets the value of the field on position aIndex as OleVariant in the given aRecordBuffer.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.FieldByNameAsVariant Property

TnxFieldsDescriptor.FieldByNameAsVariant Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property FieldByNameAsVariant [aRecordBuffer: PnxByteArray; const aName: string]: OleVariant;
Description

Gets/Sets the value of a named field as OleVariant in the given aRecordBuffer.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.FieldsOffset Property

TnxFieldsDescriptor.FieldsOffset Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property FieldsOffset: integer;
Description

This is FieldsOffset, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.LogicalRecordLength Property

TnxFieldsDescriptor.LogicalRecordLength Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property LogicalRecordLength: Integer;
Description

The length of the logical record for the data dictionary (ie just the total size of the fields.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.OriginalFieldCount Property

TnxFieldsDescriptor.OriginalFieldCount Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property OriginalFieldCount: Integer;
Description

This is OriginalFieldCount, a member of class TnxFieldsDescriptor.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.RecordLength Property

TnxFieldsDescriptor.RecordLength Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property RecordLength: Integer;
Description

The length of the physical record for the data dictionary. Includes trailing byte array to identify null fields.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsDescriptor.Validations Property

TnxFieldsDescriptor.Validations Property
TnxFieldsDescriptor Class TnxFieldsDescriptor Members nxsdDataDictionary Namespace TnxFieldsDescriptor Properties Send Feedback
Syntax
Delphi
property Validations: TnxFieldsValidationsDescriptor;
Description

Gives access to all Field validation descriptors.

Group

TnxFieldsDescriptor Properties

Links
TnxFieldsDescriptor Class, TnxFieldsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsDescriptor Properties


TnxFieldsValidationsDescriptor Class

TnxFieldsValidationsDescriptor Class
TnxFieldsValidationsDescriptor Methods TnxFieldsValidationsDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptornxsdDataDictionary_TnxFieldsValidationsDescriptor
Syntax
Delphi
TnxFieldsValidationsDescriptor = class(TnxFieldValidationsDescriptor);
File

nxsdDataDictionary

Description

Holds a list of Field validation Descriptors

Group

Classes

Links
TnxFieldsValidationsDescriptor Methods, TnxFieldsValidationsDescriptor Members, nxsdDataDictionary, Classes


TnxFieldsValidationsDescriptor Members

TnxFieldsValidationsDescriptor Members
TnxFieldsValidationsDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldsValidationsDescriptor.

Class

TnxFieldsValidationsDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
BaseValidationClass |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
ValidationCount | The number Validation Descriptors for this table.
ValidationDescriptor | fields are public for speed reasons The Validation Descriptors defined for this table.
Public Methods
Name | Description
AddValidation | This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.
AddValidationT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Clear | This function clears the Validation Descriptors Descriptor.
Create | constructor.
Destroy | destructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
GetValidationDescriptorFromClassName | Return the Validation array index for a given Validation Classname, or -1 if not found.
GetValidationDescriptorFromName | Return the Validation array index for a given Validation name, or -1 if not found.
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveValidation | This is the overview for the RemoveValidation method overload.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxFieldsValidationsDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxFieldsValidationsDescriptor Methods

TnxFieldsValidationsDescriptor Methods
TnxFieldsValidationsDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldsValidationsDescriptor class are listed here.

Class

TnxFieldsValidationsDescriptor Class

Protected Methods
Name | Description
BaseValidationClass |
Public Methods
Name | Description
AddValidation | This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.
AddValidationT |
Links
TnxFieldsValidationsDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldsValidationsDescriptor.AddValidation Method

TnxFieldsValidationsDescriptor.AddValidation Method
TnxFieldsValidationsDescriptor Class TnxFieldsValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldsValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidation(const aName: string; aClass: TnxBaseFieldsValidationDescriptorClass = nil): TnxBaseFieldValidationDescriptor;
Parameters
Parameters | Description
const aName: string | the name of the Validation Descriptor
aClass: TnxBaseFieldsValidationDescriptorClass = nil | the class of the instance to be created. TnxFieldsValidationsDescriptor
Description

This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.

Group

TnxFieldsValidationsDescriptor Methods

Links
TnxFieldsValidationsDescriptor Class, TnxFieldsValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsValidationsDescriptor Methods


TnxFieldsValidationsDescriptor.AddValidationT Method

TnxFieldsValidationsDescriptor.AddValidationT Method
TnxFieldsValidationsDescriptor Class TnxFieldsValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldsValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidationT<T: TnxBaseFieldValidationDescriptor>(const aName: string): T;
Group

TnxFieldsValidationsDescriptor Methods

Links
TnxFieldsValidationsDescriptor Class, TnxFieldsValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsValidationsDescriptor Methods


TnxFieldsValidationsDescriptor.BaseValidationClass Method

TnxFieldsValidationsDescriptor.BaseValidationClass Method
TnxFieldsValidationsDescriptor Class TnxFieldsValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldsValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function BaseValidationClass: TnxBaseFieldValidationDescriptorClass; override;
Group

TnxFieldsValidationsDescriptor Methods

Links
TnxFieldsValidationsDescriptor Class, TnxFieldsValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldsValidationsDescriptor Methods


TnxFieldValidationsDescriptor Class

TnxFieldValidationsDescriptor Class
TnxFieldValidationsDescriptor Fields TnxFieldValidationsDescriptor Methods TnxFieldValidationsDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFieldValidationsDescriptornxsdDataDictionary_TnxFieldValidationsDescriptornxsdDataDictionary_TnxFieldValidationsDescriptornxsdDataDictionary_TnxFieldValidationsDescriptornxsdDataDictionary_TnxFieldValidationsDescriptornxsdDataDictionary_TnxFieldValidationsDescriptor
Syntax
Delphi
TnxFieldValidationsDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

Holds a list of Field validation Descriptors

Group

Classes

Links
TnxFieldValidationsDescriptor Fields, TnxFieldValidationsDescriptor Methods, TnxFieldValidationsDescriptor Members, nxsdDataDictionary, Classes


TnxFieldValidationsDescriptor Members

TnxFieldValidationsDescriptor Members
TnxFieldValidationsDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldValidationsDescriptor.

Class

TnxFieldValidationsDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
BaseValidationClass |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
ValidationCount | The number Validation Descriptors for this table.
ValidationDescriptor | fields are public for speed reasons The Validation Descriptors defined for this table.
Public Methods
Name | Description
AddValidation | This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.
AddValidationT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | This function clears the Validation Descriptors Descriptor.
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
GetValidationDescriptorFromClassName | Return the Validation array index for a given Validation Classname, or -1 if not found.
GetValidationDescriptorFromName | Return the Validation array index for a given Validation name, or -1 if not found.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveValidation | This is the overview for the RemoveValidation method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxFieldValidationsDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxFieldValidationsDescriptor.Create Constructor

TnxFieldValidationsDescriptor.Create Constructor
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxFieldValidationsDescriptor Class

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Class


TnxFieldValidationsDescriptor.Destroy Destructor

TnxFieldValidationsDescriptor.Destroy Destructor
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxFieldValidationsDescriptor Class

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Class


TnxFieldValidationsDescriptor Fields

TnxFieldValidationsDescriptor Fields
TnxFieldValidationsDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxFieldValidationsDescriptor class are listed here.

Class

TnxFieldValidationsDescriptor Class

Public Fields
Name | Description
ValidationCount | The number Validation Descriptors for this table.
ValidationDescriptor | fields are public for speed reasons The Validation Descriptors defined for this table.
Links
TnxFieldValidationsDescriptor Class, Legend, Public Fields


TnxFieldValidationsDescriptor.ValidationCount Field

TnxFieldValidationsDescriptor.ValidationCount Field
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Fields Send Feedback
Syntax
Delphi
ValidationCount: Integer;
Description

The number Validation Descriptors for this table.

Group

TnxFieldValidationsDescriptor Fields

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Fields


TnxFieldValidationsDescriptor.ValidationDescriptor Field

TnxFieldValidationsDescriptor.ValidationDescriptor Field
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Fields Send Feedback
Syntax
Delphi
ValidationDescriptor: array of TnxBaseFieldValidationDescriptor;
Description

fields are public for speed reasons The Validation Descriptors defined for this table.

Group

TnxFieldValidationsDescriptor Fields

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Fields


TnxFieldValidationsDescriptor Methods

TnxFieldValidationsDescriptor Methods
TnxFieldValidationsDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldValidationsDescriptor class are listed here.

Class

TnxFieldValidationsDescriptor Class

Protected Methods
Name | Description
BaseValidationClass |
GetList |
Public Methods
Name | Description
AddValidation | This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.
AddValidationT |
CheckValid |
Clear | This function clears the Validation Descriptors Descriptor.
GetValidationDescriptorFromClassName | Return the Validation array index for a given Validation Classname, or -1 if not found.
GetValidationDescriptorFromName | Return the Validation array index for a given Validation name, or -1 if not found.
IsEqual |
LoadFromReader |
RemoveValidation | This is the overview for the RemoveValidation method overload.
SaveToWriter |
Links
TnxFieldValidationsDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldValidationsDescriptor.AddValidation Method

TnxFieldValidationsDescriptor.AddValidation Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidation(const aName: string; aClass: TnxBaseFieldValidationDescriptorClass = nil): TnxBaseFieldValidationDescriptor;
Parameters
Parameters | Description
const aName: string | the name of the Validation Descriptor
aClass: TnxBaseFieldValidationDescriptorClass = nil | the class of the instance to be created. TnxFieldValidationsDescriptor
Description

This function adds a new instance of a Validation Descriptor to the data dictionary and returns the newly created Instance.

Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.AddValidationT Method

TnxFieldValidationsDescriptor.AddValidationT Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function AddValidationT<T: TnxBaseFieldValidationDescriptor>(const aName: string): T;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.BaseValidationClass Method

TnxFieldValidationsDescriptor.BaseValidationClass Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function BaseValidationClass: TnxBaseFieldValidationDescriptorClass; virtual;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.CheckValid Method

TnxFieldValidationsDescriptor.CheckValid Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.Clear Method

TnxFieldValidationsDescriptor.Clear Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

This function clears the Validation Descriptors Descriptor.

Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.GetList Method

TnxFieldValidationsDescriptor.GetList Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.GetValidationDescriptorFromClassName Method

TnxFieldValidationsDescriptor.GetValidationDescriptorFromClassName Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function GetValidationDescriptorFromClassName(const aValidationDescriptorClassName: string): Integer;
Description

Return the Validation array index for a given Validation Classname, or -1 if not found.

Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.GetValidationDescriptorFromName Method

TnxFieldValidationsDescriptor.GetValidationDescriptorFromName Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function GetValidationDescriptorFromName(const aValidationDescriptorName: string): Integer;
Description

Return the Validation array index for a given Validation name, or -1 if not found.

Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.IsEqual Method

TnxFieldValidationsDescriptor.IsEqual Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.LoadFromReader Method

TnxFieldValidationsDescriptor.LoadFromReader Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


RemoveValidation Method

RemoveValidation Method
TnxFieldValidationsDescriptor Methods Send Feedback

This is the overview for the RemoveValidation method overload.

Overload List
Name | Description
TnxFieldValidationsDescriptor.RemoveValidation (Integer) | Remove a Validation Descriptor from the Data Dictionary.
TnxFieldValidationsDescriptor.RemoveValidation (string) | Remove a Validation Descriptor from the Data Dictionary.
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Methods


TnxFieldValidationsDescriptor.RemoveValidation Method (Integer)

TnxFieldValidationsDescriptor.RemoveValidation Method (Integer)
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace RemoveValidation Method Send Feedback
Syntax
Delphi
procedure RemoveValidation(aInx: Integer); overload;
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of Validation Descriptors.
Description

Remove a Validation Descriptor from the Data Dictionary.

Group

RemoveValidation Method

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, RemoveValidation Method


TnxFieldValidationsDescriptor.RemoveValidation Method (string)

TnxFieldValidationsDescriptor.RemoveValidation Method (string)
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace RemoveValidation Method Send Feedback
Syntax
Delphi
procedure RemoveValidation(const aName: string); overload;
Parameters
Parameters | Description
const aName: string | the name of the descriptor to be removed.
Description

Remove a Validation Descriptor from the Data Dictionary.

Group

RemoveValidation Method

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, RemoveValidation Method


TnxFieldValidationsDescriptor.SaveToWriter Method

TnxFieldValidationsDescriptor.SaveToWriter Method
TnxFieldValidationsDescriptor Class TnxFieldValidationsDescriptor Members nxsdDataDictionary Namespace TnxFieldValidationsDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFieldValidationsDescriptor Methods

Links
TnxFieldValidationsDescriptor Class, TnxFieldValidationsDescriptor Members, nxsdDataDictionary Namespace, TnxFieldValidationsDescriptor Methods


TnxFileDescriptor Class

TnxFileDescriptor Class
TnxFileDescriptor Fields TnxFileDescriptor Methods TnxFileDescriptor Properties TnxFileDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFileDescriptornxsdDataDictionary_TnxFileDescriptornxsdDataDictionary_TnxFileDescriptornxsdDataDictionary_TnxFileDescriptornxsdDataDictionary_TnxFileDescriptornxsdDataDictionary_TnxFileDescriptor
Syntax
Delphi
TnxFileDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

A file descriptor describes the attributes of a physical file.

Group

Classes

Links
TnxFileDescriptor Fields, TnxFileDescriptor Methods, TnxFileDescriptor Properties, TnxFileDescriptor Members, nxsdDataDictionary, Classes


TnxFileDescriptor Members

TnxFileDescriptor Members
TnxFileDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFileDescriptor.

Class

TnxFileDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fdBlockSize | ..block size for file.
fdDesc | ..description of file.
fdExtension | ..extension for file.
fdGrowSize | ..grow size in blocks.
fdInitialSize | ..initial file size in blocks.
fdNumber | This is fdNumber, a member of class TnxFileDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fdGetBlockSizeBytes |
fdGetUsableBlockSize |
fdSetBlockSize |
fdSetBlockSizeBytes |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxFileDescriptor
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlockSize | The block size of the file. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.
BlockSizeBytes | The block size of the file in bytes. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Desc | This can be filled with a human readable description of the file.
Extension | The file extension used for the file.
GrowSize | This is the size, in numbers of blocks, the file will grow when needed.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
InitialSize | This is the initial size, in numbers of blocks, of the file described.
Number | This number holds the index of this descriptor in the list of File descriptors in the ParentDataDictionary.
UsableBlockSize | The number of bytes that can be used per Block. That is calculated by subtracting the header size from the total BlockSize.
Links
TnxFileDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFileDescriptor.Create Constructor

TnxFileDescriptor.Create Constructor
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aExtension: string); virtual;
Class

TnxFileDescriptor Class

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Class


TnxFileDescriptor Fields

TnxFileDescriptor Fields
TnxFileDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFileDescriptor class are listed here.

Class

TnxFileDescriptor Class

Protected Fields
Name | Description
fdBlockSize | ..block size for file.
fdDesc | ..description of file.
fdExtension | ..extension for file.
fdGrowSize | ..grow size in blocks.
fdInitialSize | ..initial file size in blocks.
fdNumber | This is fdNumber, a member of class TnxFileDescriptor.
Links
TnxFileDescriptor Class, Legend, Protected Fields


TnxFileDescriptor.fdBlockSize Field

TnxFileDescriptor.fdBlockSize Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdBlockSize: TnxBlockSize;
Description

..block size for file.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor.fdDesc Field

TnxFileDescriptor.fdDesc Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdDesc: string;
Description

..description of file.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor.fdExtension Field

TnxFileDescriptor.fdExtension Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdExtension: string;
Description

..extension for file.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor.fdGrowSize Field

TnxFileDescriptor.fdGrowSize Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdGrowSize: TnxGrowSize;
Description

..grow size in blocks.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor.fdInitialSize Field

TnxFileDescriptor.fdInitialSize Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdInitialSize: TnxGrowSize;
Description

..initial file size in blocks.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor.fdNumber Field

TnxFileDescriptor.fdNumber Field
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Fields Send Feedback
Syntax
Delphi
fdNumber: Integer;
Description

This is fdNumber, a member of class TnxFileDescriptor.

Group

TnxFileDescriptor Fields

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Fields


TnxFileDescriptor Methods

TnxFileDescriptor Methods
TnxFileDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFileDescriptor class are listed here.

Class

TnxFileDescriptor Class

Protected Methods
Name | Description
fdGetBlockSizeBytes |
fdGetUsableBlockSize |
fdSetBlockSize |
fdSetBlockSizeBytes |
GetList |
Public Methods
Name | Description
CheckValid | TnxFileDescriptor
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxFileDescriptor Class, Legend, Protected Methods, Public Methods


TnxFileDescriptor.CheckValid Method

TnxFileDescriptor.CheckValid Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxFileDescriptor

Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.fdGetBlockSizeBytes Method

TnxFileDescriptor.fdGetBlockSizeBytes Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
function fdGetBlockSizeBytes: TnxWord32;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.fdGetUsableBlockSize Method

TnxFileDescriptor.fdGetUsableBlockSize Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
function fdGetUsableBlockSize: TnxWord32;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.fdSetBlockSize Method

TnxFileDescriptor.fdSetBlockSize Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
procedure fdSetBlockSize(aValue: TnxBlockSize);
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.fdSetBlockSizeBytes Method

TnxFileDescriptor.fdSetBlockSizeBytes Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
procedure fdSetBlockSizeBytes(aValue: TnxWord32);
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.GetList Method

TnxFileDescriptor.GetList Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.IsEqual Method

TnxFileDescriptor.IsEqual Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.LoadFromReader Method

TnxFileDescriptor.LoadFromReader Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor.SaveToWriter Method

TnxFileDescriptor.SaveToWriter Method
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFileDescriptor Methods

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Methods


TnxFileDescriptor Properties

TnxFileDescriptor Properties
TnxFileDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFileDescriptor class are listed here.

Class

TnxFileDescriptor Class

Public Properties
Name | Description
BlockSize | The block size of the file. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.
BlockSizeBytes | The block size of the file in bytes. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.
Desc | This can be filled with a human readable description of the file.
Extension | The file extension used for the file.
GrowSize | This is the size, in numbers of blocks, the file will grow when needed.
InitialSize | This is the initial size, in numbers of blocks, of the file described.
Number | This number holds the index of this descriptor in the list of File descriptors in the ParentDataDictionary.
UsableBlockSize | The number of bytes that can be used per Block. That is calculated by subtracting the header size from the total BlockSize.
Links
TnxFileDescriptor Class, Legend, Public Properties


TnxFileDescriptor.BlockSize Property

TnxFileDescriptor.BlockSize Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties See Also Send Feedback
Syntax
Delphi
property BlockSize: TnxBlockSize;
Description

The block size of the file. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.

See Also

BlockSize, BlockSizeBytes, UsableBlockSize

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties, See Also


TnxFileDescriptor.BlockSizeBytes Property

TnxFileDescriptor.BlockSizeBytes Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties See Also Send Feedback
Syntax
Delphi
property BlockSizeBytes: TnxWord32;
Description

The block size of the file in bytes. Please note that for table files (with the NexusDB default engines) each record has to fit into 1 block.

See Also

BlockSize, BlockSizeBytes, UsableBlockSize

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties, See Also


TnxFileDescriptor.Desc Property

TnxFileDescriptor.Desc Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties Send Feedback
Syntax
Delphi
property Desc: string;
Description

This can be filled with a human readable description of the file.

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties


TnxFileDescriptor.Extension Property

TnxFileDescriptor.Extension Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties Send Feedback
Syntax
Delphi
property Extension: string;
Description

The file extension used for the file.

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties


TnxFileDescriptor.GrowSize Property

TnxFileDescriptor.GrowSize Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties See Also Send Feedback
Syntax
Delphi
property GrowSize: TnxGrowSize;
Description

This is the size, in numbers of blocks, the file will grow when needed.

See Also

InitialSize

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties, See Also


TnxFileDescriptor.InitialSize Property

TnxFileDescriptor.InitialSize Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties See Also Send Feedback
Syntax
Delphi
property InitialSize: TnxGrowSize;
Description

This is the initial size, in numbers of blocks, of the file described.

See Also

GrowSize

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties, See Also


TnxFileDescriptor.Number Property

TnxFileDescriptor.Number Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties Send Feedback
Syntax
Delphi
property Number: Integer;
Description

This number holds the index of this descriptor in the list of File descriptors in the ParentDataDictionary.

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties


TnxFileDescriptor.UsableBlockSize Property

TnxFileDescriptor.UsableBlockSize Property
TnxFileDescriptor Class TnxFileDescriptor Members nxsdDataDictionary Namespace TnxFileDescriptor Properties Send Feedback
Syntax
Delphi
property UsableBlockSize: TnxWord32;
Description

The number of bytes that can be used per Block. That is calculated by subtracting the header size from the total BlockSize.

Group

TnxFileDescriptor Properties

Links
TnxFileDescriptor Class, TnxFileDescriptor Members, nxsdDataDictionary Namespace, TnxFileDescriptor Properties


TnxFilesDescriptor Class

TnxFilesDescriptor Class
TnxFilesDescriptor Fields TnxFilesDescriptor Methods TnxFilesDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxFilesDescriptornxsdDataDictionary_TnxFilesDescriptornxsdDataDictionary_TnxFilesDescriptornxsdDataDictionary_TnxFilesDescriptornxsdDataDictionary_TnxFilesDescriptornxsdDataDictionary_TnxFilesDescriptor
Syntax
Delphi
TnxFilesDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

A Files Descriptors is a list of associated FileDescriptors

Group

Classes

Links
TnxFilesDescriptor Fields, TnxFilesDescriptor Methods, TnxFilesDescriptor Members, nxsdDataDictionary, Classes


TnxFilesDescriptor Members

TnxFilesDescriptor Members
TnxFilesDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFilesDescriptor.

Class

TnxFilesDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fidFileChangeNotifies | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fidAddToFileChangeNotifies |
fidFileChangeNotification |
fidRemoveFromFileChangeNotifies |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
FileCount | The number of file descriptors in the list.
FileDescriptor | The list of File Descriptors for this table.
Public Methods
Name | Description
AddFile | This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance.
AddFileT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | This function clears the Files Descriptor.
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFileFromExt | Return the file number for a given file extension, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
InsertFileAt | This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.
InsertFileAtT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
MoveFile | Moves a FileDescriptor in the list of descriptors from aFrom to the aTo position
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveFile | Remove a File Descriptor from the Data Dictionary.
RenameFile | This is the overview for the RenameFile method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxFilesDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxFilesDescriptor.Create Constructor

TnxFilesDescriptor.Create Constructor
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxFilesDescriptor Class

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Class


TnxFilesDescriptor.Destroy Destructor

TnxFilesDescriptor.Destroy Destructor
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxFilesDescriptor Class

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Class


TnxFilesDescriptor Fields

TnxFilesDescriptor Fields
TnxFilesDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxFilesDescriptor class are listed here.

Class

TnxFilesDescriptor Class

Protected Fields
Name | Description
fidFileChangeNotifies | private
Public Fields
Name | Description
FileCount | The number of file descriptors in the list.
FileDescriptor | The list of File Descriptors for this table.
Links
TnxFilesDescriptor Class, Legend, Protected Fields, Public Fields


TnxFilesDescriptor.fidFileChangeNotifies Field

TnxFilesDescriptor.fidFileChangeNotifies Field
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Fields Send Feedback
Syntax
Delphi
fidFileChangeNotifies: TnxSortedList;
Description

private

Group

TnxFilesDescriptor Fields

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Fields


TnxFilesDescriptor.FileCount Field

TnxFilesDescriptor.FileCount Field
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Fields Send Feedback
Syntax
Delphi
FileCount: Integer;
Description

The number of file descriptors in the list.

Group

TnxFilesDescriptor Fields

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Fields


TnxFilesDescriptor.FileDescriptor Field

TnxFilesDescriptor.FileDescriptor Field
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Fields Send Feedback
Syntax
Delphi
FileDescriptor: array of TnxFileDescriptor;
Description

The list of File Descriptors for this table.

Group

TnxFilesDescriptor Fields

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Fields


TnxFilesDescriptor Methods

TnxFilesDescriptor Methods
TnxFilesDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFilesDescriptor class are listed here.

Class

TnxFilesDescriptor Class

Protected Methods
Name | Description
fidAddToFileChangeNotifies |
fidFileChangeNotification |
fidRemoveFromFileChangeNotifies |
GetList |
Public Methods
Name | Description
AddFile | This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance.
AddFileT |
CheckValid |
Clear | This function clears the Files Descriptor.
GetFileFromExt | Return the file number for a given file extension, or -1 if not found.
InsertFileAt | This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.
InsertFileAtT |
IsEqual |
LoadFromReader |
MoveFile | Moves a FileDescriptor in the list of descriptors from aFrom to the aTo position
RemoveFile | Remove a File Descriptor from the Data Dictionary.
RenameFile | This is the overview for the RenameFile method overload.
SaveToWriter |
Links
TnxFilesDescriptor Class, Legend, Protected Methods, Public Methods


TnxFilesDescriptor.AddFile Method

TnxFilesDescriptor.AddFile Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function AddFile(const aExtension: string; aBlockSize: TnxBlockSize; const aDesc: string = ''; aClass: TnxFileDescriptorClass = nil): TnxFileDescriptor;
Parameters
Parameters | Description
const aExtension: string | the file extension to use.
aBlockSize: TnxBlockSize | the block size for the new File Descriptor
const aDesc: string = '' | a human readable description
aClass: TnxFileDescriptorClass = nil | the class of the instance to be created TnxFilesDescriptor
Description

This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance.

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.AddFileT Method

TnxFilesDescriptor.AddFileT Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function AddFileT<T: TnxFileDescriptor>(const aExtension: string; aBlockSize: TnxBlockSize; const aDesc: string = ''): T;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.CheckValid Method

TnxFilesDescriptor.CheckValid Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.Clear Method

TnxFilesDescriptor.Clear Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear(aNotify: Boolean); virtual;
Description

This function clears the Files Descriptor.

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.fidAddToFileChangeNotifies Method

TnxFilesDescriptor.fidAddToFileChangeNotifies Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure fidAddToFileChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.fidFileChangeNotification Method

TnxFilesDescriptor.fidFileChangeNotification Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure fidFileChangeNotification(aBefore: Boolean; aOldFile: Integer; aNewFile: Integer);
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.fidRemoveFromFileChangeNotifies Method

TnxFilesDescriptor.fidRemoveFromFileChangeNotifies Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure fidRemoveFromFileChangeNotifies(aDictionaryItem: TnxDictionaryItem);
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.GetFileFromExt Method

TnxFilesDescriptor.GetFileFromExt Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function GetFileFromExt(const aFileExt: string): Integer;
Parameters
Parameters | Description
const aFileExt: string | the file extension (attached to the base name) to look for.
Description

Return the file number for a given file extension, or -1 if not found.

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.GetList Method

TnxFilesDescriptor.GetList Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.InsertFileAt Method

TnxFilesDescriptor.InsertFileAt Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function InsertFileAt(aInx: Integer; const aExtension: string; aBlockSize: TnxBlockSize; const aDesc: string = ''; aClass: TnxFileDescriptorClass = nil): TnxFileDescriptor;
Parameters
Parameters | Description
aInx: Integer | the index of the new field
const aExtension: string | the file extension to use.
aBlockSize: TnxBlockSize | the block size for the new File Descriptor
const aDesc: string = '' | a human readable description
aClass: TnxFileDescriptorClass = nil | the class of the instance to be created
Description

This function adds a new instance of a File Descriptor to the data dictionary and returns the newly created Instance. The field is inserted into the array at position aInx and the rest of the field array indexes are adjusted.

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.InsertFileAtT Method

TnxFilesDescriptor.InsertFileAtT Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function InsertFileAtT<T: TnxFileDescriptor>(aInx: Integer; const aExtension: string; aBlockSize: TnxBlockSize; const aDesc: string = ''): T;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.IsEqual Method

TnxFilesDescriptor.IsEqual Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.LoadFromReader Method

TnxFilesDescriptor.LoadFromReader Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.MoveFile Method

TnxFilesDescriptor.MoveFile Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure MoveFile(aFrom: Integer; aTo: Integer);
Description

Moves a FileDescriptor in the list of descriptors from aFrom to the aTo position

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxFilesDescriptor.RemoveFile Method

TnxFilesDescriptor.RemoveFile Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveFile(aInx: Integer);
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of File Descriptors.
Description

Remove a File Descriptor from the Data Dictionary.

Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


RenameFile Method

RenameFile Method
TnxFilesDescriptor Methods Send Feedback

This is the overview for the RenameFile method overload.

Overload List
Name | Description
TnxFilesDescriptor.RenameFile (Integer, string) |
TnxFilesDescriptor.RenameFile (string, string) |
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Methods


TnxFilesDescriptor.RenameFile Method (Integer, string)

TnxFilesDescriptor.RenameFile Method (Integer, string)
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace RenameFile Method Send Feedback
Syntax
Delphi
procedure RenameFile(aInx: Integer; aNewExtension: string); overload;
Group

RenameFile Method

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, RenameFile Method


TnxFilesDescriptor.RenameFile Method (string, string)

TnxFilesDescriptor.RenameFile Method (string, string)
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace RenameFile Method Send Feedback
Syntax
Delphi
procedure RenameFile(aOldExtension: string; aNewExtension: string); overload;
Group

RenameFile Method

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, RenameFile Method


TnxFilesDescriptor.SaveToWriter Method

TnxFilesDescriptor.SaveToWriter Method
TnxFilesDescriptor Class TnxFilesDescriptor Members nxsdDataDictionary Namespace TnxFilesDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFilesDescriptor Methods

Links
TnxFilesDescriptor Class, TnxFilesDescriptor Members, nxsdDataDictionary Namespace, TnxFilesDescriptor Methods


TnxHeapBlobDescriptor Class

TnxHeapBlobDescriptor Class
TnxHeapBlobDescriptor Fields TnxHeapBlobDescriptor Methods TnxHeapBlobDescriptor Properties TnxHeapBlobDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptornxsdDataDictionary_TnxHeapBlobDescriptor
Syntax
Delphi
TnxHeapBlobDescriptor = class(TnxBaseBlobDescriptor);
File

nxsdDataDictionary

Description

A Heap Blob Descriptor adds support to Blob Descriptors for specifying a Heap Descriptor to read/store blobs on a heap.

Group

Classes

Links
TnxHeapBlobDescriptor Fields, TnxHeapBlobDescriptor Methods, TnxHeapBlobDescriptor Properties, TnxHeapBlobDescriptor Members, nxsdDataDictionary, Classes


TnxHeapBlobDescriptor Members

TnxHeapBlobDescriptor Members
TnxHeapBlobDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxHeapBlobDescriptor.

Class

TnxHeapBlobDescriptor Class

Protected Fields
Name | Description
bbdBlobEngine | This is bbdBlobEngine, a member of class TnxBaseBlobDescriptor.
bbdFileNumber | private
bbdHeaderSection | This is bbdHeaderSection, a member of class TnxBaseBlobDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
hbdHeapDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bbdSetBlobEngine | TnxBaseBlobDescriptor
bbdSetFileNumber |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddHeapDescriptor | Sets the associated Heap Descriptor.
AddHeapDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList | return the list of default value descriptors.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveHeapDescriptor | Sets the associated Heap Descriptor back to nil.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlobEngine | The name of the Blob Engine used to read the blobs.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor of the associated file.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the header of the descriptor as string.
HeapDescriptor | Returns the associated Heap Descriptor.
ID | Unique ID of the dictionary item
Links
TnxHeapBlobDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxHeapBlobDescriptor.Create Constructor

TnxHeapBlobDescriptor.Create Constructor
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); override;
Description

constructor.

Class

TnxHeapBlobDescriptor Class

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Class


TnxHeapBlobDescriptor.Destroy Destructor

TnxHeapBlobDescriptor.Destroy Destructor
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxHeapBlobDescriptor Class

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Class


TnxHeapBlobDescriptor Fields

TnxHeapBlobDescriptor Fields
TnxHeapBlobDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxHeapBlobDescriptor class are listed here.

Class

TnxHeapBlobDescriptor Class

Protected Fields
Name | Description
hbdHeapDescriptor | private
Links
TnxHeapBlobDescriptor Class, Legend, Protected Fields


TnxHeapBlobDescriptor.hbdHeapDescriptor Field

TnxHeapBlobDescriptor.hbdHeapDescriptor Field
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Fields Send Feedback
Syntax
Delphi
hbdHeapDescriptor: TnxBaseHeapDescriptor;
Description

private

Group

TnxHeapBlobDescriptor Fields

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Fields


TnxHeapBlobDescriptor Methods

TnxHeapBlobDescriptor Methods
TnxHeapBlobDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxHeapBlobDescriptor class are listed here.

Class

TnxHeapBlobDescriptor Class

Public Methods
Name | Description
AddHeapDescriptor | Sets the associated Heap Descriptor.
AddHeapDescriptorT |
CheckValid |
IsEqual |
LoadFromReader |
RemoveHeapDescriptor | Sets the associated Heap Descriptor back to nil.
SaveToWriter |
Links
TnxHeapBlobDescriptor Class, Legend, Public Methods


TnxHeapBlobDescriptor.AddHeapDescriptor Method

TnxHeapBlobDescriptor.AddHeapDescriptor Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddHeapDescriptor(aHeapClass: TnxBaseHeapDescriptorClass = nil): TnxBaseHeapDescriptor;
Description

Sets the associated Heap Descriptor.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

TnxHeapBlobDescriptor

Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods, See Also


TnxHeapBlobDescriptor.AddHeapDescriptorT Method

TnxHeapBlobDescriptor.AddHeapDescriptorT Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods Send Feedback
Syntax
Delphi
function AddHeapDescriptorT<T : TnxBaseHeapDescriptor>: T;
Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods


TnxHeapBlobDescriptor.CheckValid Method

TnxHeapBlobDescriptor.CheckValid Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods


TnxHeapBlobDescriptor.IsEqual Method

TnxHeapBlobDescriptor.IsEqual Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods


TnxHeapBlobDescriptor.LoadFromReader Method

TnxHeapBlobDescriptor.LoadFromReader Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods


TnxHeapBlobDescriptor.RemoveHeapDescriptor Method

TnxHeapBlobDescriptor.RemoveHeapDescriptor Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveHeapDescriptor;
Description

Sets the associated Heap Descriptor back to nil.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods, See Also


TnxHeapBlobDescriptor.SaveToWriter Method

TnxHeapBlobDescriptor.SaveToWriter Method
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxHeapBlobDescriptor Methods

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Methods


TnxHeapBlobDescriptor Properties

TnxHeapBlobDescriptor Properties
TnxHeapBlobDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxHeapBlobDescriptor class are listed here.

Class

TnxHeapBlobDescriptor Class

Public Properties
Name | Description
HeapDescriptor | Returns the associated Heap Descriptor.
Links
TnxHeapBlobDescriptor Class, Legend, Public Properties


TnxHeapBlobDescriptor.HeapDescriptor Property

TnxHeapBlobDescriptor.HeapDescriptor Property
TnxHeapBlobDescriptor Class TnxHeapBlobDescriptor Members nxsdDataDictionary Namespace TnxHeapBlobDescriptor Properties See Also Send Feedback
Syntax
Delphi
property HeapDescriptor: TnxBaseHeapDescriptor;
Description

Returns the associated Heap Descriptor.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

Group

TnxHeapBlobDescriptor Properties

Links
TnxHeapBlobDescriptor Class, TnxHeapBlobDescriptor Members, nxsdDataDictionary Namespace, TnxHeapBlobDescriptor Properties, See Also


TnxHeapRecordDescriptor Class

TnxHeapRecordDescriptor Class
TnxHeapRecordDescriptor Fields TnxHeapRecordDescriptor Methods TnxHeapRecordDescriptor Properties TnxHeapRecordDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptornxsdDataDictionary_TnxHeapRecordDescriptor
Syntax
Delphi
TnxHeapRecordDescriptor = class(TnxBaseRecordDescriptor);
File

nxsdDataDictionary

Description

This is a descendant of Record Descriptor that allows to specify a Heap Descriptor that is used by the specified engine.

Group

Classes

Links
TnxHeapRecordDescriptor Fields, TnxHeapRecordDescriptor Methods, TnxHeapRecordDescriptor Properties, TnxHeapRecordDescriptor Members, nxsdDataDictionary, Classes


TnxHeapRecordDescriptor Members

TnxHeapRecordDescriptor Members
TnxHeapRecordDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxHeapRecordDescriptor.

Class

TnxHeapRecordDescriptor Class

Protected Fields
Name | Description
brdFileNumber | private
brdHeaderSection | This is brdHeaderSection, a member of class TnxBaseRecordDescriptor.
brdRecordEngine | This is brdRecordEngine, a member of class TnxBaseRecordDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
hrdHeapDescriptor | private
hrdRecordCompressionDescriptor | This is hrdRecordCompressionDescriptor, a member of class TnxHeapRecordDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
brdSetFileNumber | TnxBaseRecordDescriptor
brdSetRecordEngine |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddHeapDescriptor | Set the associated Heap Descriptor.
AddHeapDescriptorT |
AddRecordCompressionDescriptor | Set the associated RecordCompression Descriptor.
AddRecordCompressionDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveHeapDescriptor | Sets the associated Heap Descriptor to nil.
RemoveRecordCompressionDescriptor | Sets the associated RecordCompression Descriptor to nil.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
FileNumber | Returns the index of the FileDescriptor the record is associated with.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the descriptor Header as string.
HeapDescriptor | Returns the associated Heap Descriptor.
ID | Unique ID of the dictionary item
RecordCompressionDescriptor | Returns the associated RecordCompression Descriptor.
RecordEngine | The Name of the Record Engine used.
Links
TnxHeapRecordDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxHeapRecordDescriptor.Create Constructor

TnxHeapRecordDescriptor.Create Constructor
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); override;
Class

TnxHeapRecordDescriptor Class

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Class


TnxHeapRecordDescriptor.Destroy Destructor

TnxHeapRecordDescriptor.Destroy Destructor
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxHeapRecordDescriptor Class

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Class


TnxHeapRecordDescriptor Fields

TnxHeapRecordDescriptor Fields
TnxHeapRecordDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxHeapRecordDescriptor class are listed here.

Class

TnxHeapRecordDescriptor Class

Protected Fields
Name | Description
hrdHeapDescriptor | private
hrdRecordCompressionDescriptor | This is hrdRecordCompressionDescriptor, a member of class TnxHeapRecordDescriptor.
Links
TnxHeapRecordDescriptor Class, Legend, Protected Fields


TnxHeapRecordDescriptor.hrdHeapDescriptor Field

TnxHeapRecordDescriptor.hrdHeapDescriptor Field
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Fields Send Feedback
Syntax
Delphi
hrdHeapDescriptor: TnxBaseHeapDescriptor;
Description

private

Group

TnxHeapRecordDescriptor Fields

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Fields


TnxHeapRecordDescriptor.hrdRecordCompressionDescriptor Field

TnxHeapRecordDescriptor.hrdRecordCompressionDescriptor Field
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Fields Send Feedback
Syntax
Delphi
hrdRecordCompressionDescriptor: TnxBaseRecordCompressionDescriptor;
Description

This is hrdRecordCompressionDescriptor, a member of class TnxHeapRecordDescriptor.

Group

TnxHeapRecordDescriptor Fields

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Fields


TnxHeapRecordDescriptor Methods

TnxHeapRecordDescriptor Methods
TnxHeapRecordDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxHeapRecordDescriptor class are listed here.

Class

TnxHeapRecordDescriptor Class

Public Methods
Name | Description
AddHeapDescriptor | Set the associated Heap Descriptor.
AddHeapDescriptorT |
AddRecordCompressionDescriptor | Set the associated RecordCompression Descriptor.
AddRecordCompressionDescriptorT |
CheckValid |
IsEqual |
LoadFromReader |
RemoveHeapDescriptor | Sets the associated Heap Descriptor to nil.
RemoveRecordCompressionDescriptor | Sets the associated RecordCompression Descriptor to nil.
SaveToWriter |
Links
TnxHeapRecordDescriptor Class, Legend, Public Methods


TnxHeapRecordDescriptor.AddHeapDescriptor Method

TnxHeapRecordDescriptor.AddHeapDescriptor Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddHeapDescriptor(aHeapClass: TnxBaseHeapDescriptorClass = nil): TnxBaseHeapDescriptor;
Description

Set the associated Heap Descriptor.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

TnxHeapRecordDescriptor

Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods, See Also


TnxHeapRecordDescriptor.AddHeapDescriptorT Method

TnxHeapRecordDescriptor.AddHeapDescriptorT Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
function AddHeapDescriptorT<T : TnxBaseHeapDescriptor>: T;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor.AddRecordCompressionDescriptor Method

TnxHeapRecordDescriptor.AddRecordCompressionDescriptor Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddRecordCompressionDescriptor(aRecordCompressionClass: TnxBaseRecordCompressionDescriptorClass = nil): TnxBaseRecordCompressionDescriptor;
Description

Set the associated RecordCompression Descriptor.

See Also

AddRecordCompressionDescriptor, RemoveRecordCompressionDescriptor, RecordCompressionDescriptor

Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods, See Also


TnxHeapRecordDescriptor.AddRecordCompressionDescriptorT Method

TnxHeapRecordDescriptor.AddRecordCompressionDescriptorT Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
function AddRecordCompressionDescriptorT<T: TnxBaseRecordCompressionDescriptor>: T;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor.CheckValid Method

TnxHeapRecordDescriptor.CheckValid Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor.IsEqual Method

TnxHeapRecordDescriptor.IsEqual Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor.LoadFromReader Method

TnxHeapRecordDescriptor.LoadFromReader Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor.RemoveHeapDescriptor Method

TnxHeapRecordDescriptor.RemoveHeapDescriptor Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveHeapDescriptor;
Description

Sets the associated Heap Descriptor to nil.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods, See Also


TnxHeapRecordDescriptor.RemoveRecordCompressionDescriptor Method

TnxHeapRecordDescriptor.RemoveRecordCompressionDescriptor Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveRecordCompressionDescriptor;
Description

Sets the associated RecordCompression Descriptor to nil.

See Also

AddRecordCompressionDescriptor, RemoveRecordCompressionDescriptor, RecordCompressionDescriptor

Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods, See Also


TnxHeapRecordDescriptor.SaveToWriter Method

TnxHeapRecordDescriptor.SaveToWriter Method
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxHeapRecordDescriptor Methods

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Methods


TnxHeapRecordDescriptor Properties

TnxHeapRecordDescriptor Properties
TnxHeapRecordDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxHeapRecordDescriptor class are listed here.

Class

TnxHeapRecordDescriptor Class

Public Properties
Name | Description
HeapDescriptor | Returns the associated Heap Descriptor.
RecordCompressionDescriptor | Returns the associated RecordCompression Descriptor.
Links
TnxHeapRecordDescriptor Class, Legend, Public Properties


TnxHeapRecordDescriptor.HeapDescriptor Property

TnxHeapRecordDescriptor.HeapDescriptor Property
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Properties See Also Send Feedback
Syntax
Delphi
property HeapDescriptor: TnxBaseHeapDescriptor;
Description

Returns the associated Heap Descriptor.

See Also

AddHeapDescriptor, RemoveHeapDescriptor, HeapDescriptor

Group

TnxHeapRecordDescriptor Properties

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Properties, See Also


TnxHeapRecordDescriptor.RecordCompressionDescriptor Property

TnxHeapRecordDescriptor.RecordCompressionDescriptor Property
TnxHeapRecordDescriptor Class TnxHeapRecordDescriptor Members nxsdDataDictionary Namespace TnxHeapRecordDescriptor Properties See Also Send Feedback
Syntax
Delphi
property RecordCompressionDescriptor: TnxBaseRecordCompressionDescriptor;
Description

Returns the associated RecordCompression Descriptor.

See Also

AddRecordCompressionDescriptor, RemoveRecordCompressionDescriptor, RecordCompressionDescriptor

Group

TnxHeapRecordDescriptor Properties

Links
TnxHeapRecordDescriptor Class, TnxHeapRecordDescriptor Members, nxsdDataDictionary Namespace, TnxHeapRecordDescriptor Properties, See Also


TnxIndexDescriptor Class

TnxIndexDescriptor Class
TnxIndexDescriptor Methods TnxIndexDescriptor Properties TnxIndexDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxIndexDescriptor
Syntax
Delphi
TnxIndexDescriptor<TKey: TnxBaseKeyDescriptor> = class(TnxIndexDescriptor);
File

nxsdDataDictionary

Description

An Index Descriptor describes how NexusDB creates an Index for a table. It uses Key Descriptor for creating the record keys and optionally a File Descriptor to describe a sperate file used for storing the index.

Group

Classes

Links
TnxIndexDescriptor Methods, TnxIndexDescriptor Properties, TnxIndexDescriptor Members, nxsdDataDictionary, Classes


TnxIndexDescriptor Members

TnxIndexDescriptor Members
TnxIndexDescriptor Class Legend Protected Methods Public Properties Send Feedback

The following tables list the members exposed by TnxIndexDescriptor.

Class

TnxIndexDescriptor Class

Protected Methods
Name | Description
Create | TnxIndexDescriptor
idGetKeyDescriptor | private
Public Properties
Name | Description
KeyDescriptor | The Key Descriptor used to create the record keys.
Links
TnxIndexDescriptor Class, Legend, Protected Methods, Public Properties


TnxIndexDescriptor.Create Constructor

TnxIndexDescriptor.Create Constructor
TnxIndexDescriptor Class TnxIndexDescriptor Members nxsdDataDictionary Namespace TnxIndexDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aName: string; aFileNumber: Integer; aKeyClass: TnxKeyDescriptorClass = nil); virtual; override;
Description

TnxIndexDescriptor

Class

TnxIndexDescriptor Class

Links
TnxIndexDescriptor Class, TnxIndexDescriptor Members, nxsdDataDictionary Namespace, TnxIndexDescriptor Class


TnxIndexDescriptor Methods

TnxIndexDescriptor Methods
TnxIndexDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxIndexDescriptor class are listed here.

Class

TnxIndexDescriptor Class

Protected Methods
Name | Description
idGetKeyDescriptor | private
Links
TnxIndexDescriptor Class, Legend, Protected Methods


TnxIndexDescriptor.idGetKeyDescriptor Method

TnxIndexDescriptor.idGetKeyDescriptor Method
TnxIndexDescriptor Class TnxIndexDescriptor Members nxsdDataDictionary Namespace TnxIndexDescriptor Methods Send Feedback
Syntax
Delphi
function idGetKeyDescriptor: TKey;
Description

private

Group

TnxIndexDescriptor Methods

Links
TnxIndexDescriptor Class, TnxIndexDescriptor Members, nxsdDataDictionary Namespace, TnxIndexDescriptor Methods


TnxIndexDescriptor Properties

TnxIndexDescriptor Properties
TnxIndexDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxIndexDescriptor class are listed here.

Class

TnxIndexDescriptor Class

Public Properties
Name | Description
KeyDescriptor | The Key Descriptor used to create the record keys.
Links
TnxIndexDescriptor Class, Legend, Public Properties


TnxIndexDescriptor.KeyDescriptor Property

TnxIndexDescriptor.KeyDescriptor Property
TnxIndexDescriptor Class TnxIndexDescriptor Members nxsdDataDictionary Namespace TnxIndexDescriptor Properties Send Feedback
Syntax
Delphi
property KeyDescriptor: TKey;
Description

The Key Descriptor used to create the record keys.

Group

TnxIndexDescriptor Properties

Links
TnxIndexDescriptor Class, TnxIndexDescriptor Members, nxsdDataDictionary Namespace, TnxIndexDescriptor Properties


TnxKeyFieldDescriptor Class

TnxKeyFieldDescriptor Class
TnxKeyFieldDescriptor Fields TnxKeyFieldDescriptor Methods TnxKeyFieldDescriptor Properties TnxKeyFieldDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptornxsdDataDictionary_TnxKeyFieldDescriptor
Syntax
Delphi
TnxKeyFieldDescriptor = class(TnxLocalizedDictionaryItem);
File

nxsdDataDictionary

Description

A Key Field Descriptor is used by a Key Descriptor to describe how field values processed when creating the key.

Group

Classes

Links
TnxKeyFieldDescriptor Fields, TnxKeyFieldDescriptor Methods, TnxKeyFieldDescriptor Properties, TnxKeyFieldDescriptor Members, nxsdDataDictionary, Classes


TnxKeyFieldDescriptor Members

TnxKeyFieldDescriptor Members
TnxKeyFieldDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxKeyFieldDescriptor.

Class

TnxKeyFieldDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
kfdAscend | ..0=descending keys; 1=ascending keys.
kfdDesc | ..description of key field.
kfdFieldNumber | ..field number.
kfdKeyFieldEngine | ..name of the key field engine.
kfdNullBehaviour | This is kfdNullBehaviour, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthBytes | This is kfdOverrideLengthBytes, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthChars | This is kfdOverrideLengthChars, a member of class TnxKeyFieldDescriptor.
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack |
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
IsValidFor |
kfdGetField |
kfdGetKeyChars |
kfdGetKeyLength |
kfdSetFieldNumber |
kfdSetOverrideLengthBytes |
kfdSetOverrideLengthChars |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls | TnxKeyFieldDescriptor
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
Ascend | If true the keys should be sorted ascending otherwise descending.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Desc | Used to store the description for this descriptor.
Field | This is a pointer to the associated Field descriptor.
FieldNumber | This property returns the index of the associated field in the field list of the Data Dictionary.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyChars | Returns the number of chars in tke key
KeyFieldEngine | The name of the Key Field Engine to create the Keys for each field.
KeyLength | Returns the length of the key
LocaleDescriptor | This property returns the associated Locale Descriptor.
NullBehaviour | defines what happens with NULLs in the key.
OverrideLengthBytes | Restricts the number of bytes used for the key generation. The index key will be built with this number of bytes only, irrespective of the actual field length. Applies to nxtWideString and nxtByteArray only! Use OverrideLengthChars for character based fields.
OverrideLengthChars | Restricts the number of chars used for the key generation. The index key will be built with this number of chars only, irrespective of the actual field length. Applies to nxtShortString and nxtNullString only! Use OverrideLengthBytes for byte based fields.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxKeyFieldDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxKeyFieldDescriptor.Create Constructor

TnxKeyFieldDescriptor.Create Constructor
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; aFieldNumber: Integer); virtual;
Class

TnxKeyFieldDescriptor Class

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Class


TnxKeyFieldDescriptor.Destroy Destructor

TnxKeyFieldDescriptor.Destroy Destructor
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxKeyFieldDescriptor Class

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Class


TnxKeyFieldDescriptor Fields

TnxKeyFieldDescriptor Fields
TnxKeyFieldDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxKeyFieldDescriptor class are listed here.

Class

TnxKeyFieldDescriptor Class

Protected Fields
Name | Description
kfdAscend | ..0=descending keys; 1=ascending keys.
kfdDesc | ..description of key field.
kfdFieldNumber | ..field number.
kfdKeyFieldEngine | ..name of the key field engine.
kfdNullBehaviour | This is kfdNullBehaviour, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthBytes | This is kfdOverrideLengthBytes, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthChars | This is kfdOverrideLengthChars, a member of class TnxKeyFieldDescriptor.
Links
TnxKeyFieldDescriptor Class, Legend, Protected Fields


TnxKeyFieldDescriptor.kfdAscend Field

TnxKeyFieldDescriptor.kfdAscend Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdAscend: Boolean;
Description

..0=descending keys; 1=ascending keys.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdDesc Field

TnxKeyFieldDescriptor.kfdDesc Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdDesc: string;
Description

..description of key field.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdFieldNumber Field

TnxKeyFieldDescriptor.kfdFieldNumber Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdFieldNumber: Integer;
Description

..field number.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdKeyFieldEngine Field

TnxKeyFieldDescriptor.kfdKeyFieldEngine Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdKeyFieldEngine: string;
Description

..name of the key field engine.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdNullBehaviour Field

TnxKeyFieldDescriptor.kfdNullBehaviour Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdNullBehaviour: TnxNullBehaviour;
Description

This is kfdNullBehaviour, a member of class TnxKeyFieldDescriptor.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdOverrideLengthBytes Field

TnxKeyFieldDescriptor.kfdOverrideLengthBytes Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdOverrideLengthBytes: Integer;
Description

This is kfdOverrideLengthBytes, a member of class TnxKeyFieldDescriptor.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor.kfdOverrideLengthChars Field

TnxKeyFieldDescriptor.kfdOverrideLengthChars Field
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
kfdOverrideLengthChars: Integer;
Description

This is kfdOverrideLengthChars, a member of class TnxKeyFieldDescriptor.

Group

TnxKeyFieldDescriptor Fields

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Fields


TnxKeyFieldDescriptor Methods

TnxKeyFieldDescriptor Methods
TnxKeyFieldDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxKeyFieldDescriptor class are listed here.

Class

TnxKeyFieldDescriptor Class

Protected Methods
Name | Description
diFieldChangeNotify |
diRequiresPack |
GetList |
IsValidFor |
kfdGetField |
kfdGetKeyChars |
kfdGetKeyLength |
kfdSetFieldNumber |
kfdSetOverrideLengthBytes |
kfdSetOverrideLengthChars |
ldiGetUsedLocaleDescriptor |
Public Methods
Name | Description
CanContainNulls | TnxKeyFieldDescriptor
CheckValid |
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxKeyFieldDescriptor Class, Legend, Protected Methods, Public Methods


TnxKeyFieldDescriptor.CanContainNulls Method

TnxKeyFieldDescriptor.CanContainNulls Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; virtual;
Description

TnxKeyFieldDescriptor

Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.CheckValid Method

TnxKeyFieldDescriptor.CheckValid Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.diFieldChangeNotify Method

TnxKeyFieldDescriptor.diFieldChangeNotify Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFieldChangeNotify(aBefore: Boolean; aOldField: Integer; aNewField: Integer); override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.diRequiresPack Method

TnxKeyFieldDescriptor.diRequiresPack Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function diRequiresPack: Boolean; override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.GetList Method

TnxKeyFieldDescriptor.GetList Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.IsEqual Method

TnxKeyFieldDescriptor.IsEqual Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.IsValidFor Method

TnxKeyFieldDescriptor.IsValidFor Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function IsValidFor(aDescriptor: TnxBaseTableDescriptor): Boolean; virtual;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdGetField Method

TnxKeyFieldDescriptor.kfdGetField Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function kfdGetField: TnxFieldDescriptor;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdGetKeyChars Method

TnxKeyFieldDescriptor.kfdGetKeyChars Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function kfdGetKeyChars: Integer;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdGetKeyLength Method

TnxKeyFieldDescriptor.kfdGetKeyLength Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function kfdGetKeyLength: Integer;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdSetFieldNumber Method

TnxKeyFieldDescriptor.kfdSetFieldNumber Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure kfdSetFieldNumber(const Value: Integer);
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdSetOverrideLengthBytes Method

TnxKeyFieldDescriptor.kfdSetOverrideLengthBytes Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure kfdSetOverrideLengthBytes(Value: Integer);
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.kfdSetOverrideLengthChars Method

TnxKeyFieldDescriptor.kfdSetOverrideLengthChars Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure kfdSetOverrideLengthChars(Value: Integer);
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.ldiGetUsedLocaleDescriptor Method

TnxKeyFieldDescriptor.ldiGetUsedLocaleDescriptor Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function ldiGetUsedLocaleDescriptor: TnxLocaleDescriptor; override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.LoadFromReader Method

TnxKeyFieldDescriptor.LoadFromReader Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor.SaveToWriter Method

TnxKeyFieldDescriptor.SaveToWriter Method
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxKeyFieldDescriptor Methods

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Methods


TnxKeyFieldDescriptor Properties

TnxKeyFieldDescriptor Properties
TnxKeyFieldDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxKeyFieldDescriptor class are listed here.

Class

TnxKeyFieldDescriptor Class

Public Properties
Name | Description
Ascend | If true the keys should be sorted ascending otherwise descending.
Desc | Used to store the description for this descriptor.
Field | This is a pointer to the associated Field descriptor.
FieldNumber | This property returns the index of the associated field in the field list of the Data Dictionary.
KeyChars | Returns the number of chars in tke key
KeyFieldEngine | The name of the Key Field Engine to create the Keys for each field.
KeyLength | Returns the length of the key
NullBehaviour | defines what happens with NULLs in the key.
OverrideLengthBytes | Restricts the number of bytes used for the key generation. The index key will be built with this number of bytes only, irrespective of the actual field length. Applies to nxtWideString and nxtByteArray only! Use OverrideLengthChars for character based fields.
OverrideLengthChars | Restricts the number of chars used for the key generation. The index key will be built with this number of chars only, irrespective of the actual field length. Applies to nxtShortString and nxtNullString only! Use OverrideLengthBytes for byte based fields.
Links
TnxKeyFieldDescriptor Class, Legend, Public Properties


TnxKeyFieldDescriptor.Ascend Property

TnxKeyFieldDescriptor.Ascend Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property Ascend: Boolean;
Description

If true the keys should be sorted ascending otherwise descending.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.Desc Property

TnxKeyFieldDescriptor.Desc Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property Desc: string;
Description

Used to store the description for this descriptor.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.Field Property

TnxKeyFieldDescriptor.Field Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property Field: TnxFieldDescriptor;
Description

This is a pointer to the associated Field descriptor.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.FieldNumber Property

TnxKeyFieldDescriptor.FieldNumber Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldNumber: Integer;
Description

This property returns the index of the associated field in the field list of the Data Dictionary.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.KeyChars Property

TnxKeyFieldDescriptor.KeyChars Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property KeyChars: Integer;
Description

Returns the number of chars in tke key

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.KeyFieldEngine Property

TnxKeyFieldDescriptor.KeyFieldEngine Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property KeyFieldEngine: string;
Description

The name of the Key Field Engine to create the Keys for each field.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.KeyLength Property

TnxKeyFieldDescriptor.KeyLength Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property KeyLength: Integer;
Description

Returns the length of the key

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.NullBehaviour Property

TnxKeyFieldDescriptor.NullBehaviour Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property NullBehaviour: TnxNullBehaviour;
Description

defines what happens with NULLs in the key.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.OverrideLengthBytes Property

TnxKeyFieldDescriptor.OverrideLengthBytes Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property OverrideLengthBytes: Integer;
Description

Restricts the number of bytes used for the key generation. The index key will be built with this number of bytes only, irrespective of the actual field length. Applies to nxtWideString and nxtByteArray only! Use OverrideLengthChars for character based fields.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxKeyFieldDescriptor.OverrideLengthChars Property

TnxKeyFieldDescriptor.OverrideLengthChars Property
TnxKeyFieldDescriptor Class TnxKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property OverrideLengthChars: Integer;
Description

Restricts the number of chars used for the key generation. The index key will be built with this number of chars only, irrespective of the actual field length. Applies to nxtShortString and nxtNullString only! Use OverrideLengthBytes for byte based fields.

Group

TnxKeyFieldDescriptor Properties

Links
TnxKeyFieldDescriptor Class, TnxKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxKeyFieldDescriptor Properties


TnxLocaleDescriptor Class

TnxLocaleDescriptor Class
TnxLocaleDescriptor Fields TnxLocaleDescriptor Methods TnxLocaleDescriptor Properties TnxLocaleDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxLocaleDescriptornxsdDataDictionary_TnxLocaleDescriptornxsdDataDictionary_TnxLocaleDescriptornxsdDataDictionary_TnxLocaleDescriptornxsdDataDictionary_TnxLocaleDescriptornxsdDataDictionary_TnxLocaleDescriptor
Syntax
Delphi
TnxLocaleDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

This is the basic locale descriptor. It can be added to the data dictionary, field descriptors and key field descriptors. If a key field descriptor has no locale descriptor attached falls back to the field descriptor. If the field descriptor has no locale descriptor attached it falls back to the data dictionary. If there is no locale descriptor available at all or if the Locale of the used locale descriptor is 0 all comparisons and sorting is performed by direct byte value comparison.

Group

Classes

Links
TnxLocaleDescriptor Fields, TnxLocaleDescriptor Methods, TnxLocaleDescriptor Properties, TnxLocaleDescriptor Members, nxsdDataDictionary, Classes


TnxLocaleDescriptor Members

TnxLocaleDescriptor Members
TnxLocaleDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLocaleDescriptor.

Class

TnxLocaleDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldIgnoreKanaType | This is ldIgnoreKanaType, a member of class TnxLocaleDescriptor.
ldIgnoreNonSpace | This is ldIgnoreNonSpace, a member of class TnxLocaleDescriptor.
ldIgnoreSymbols | This is ldIgnoreSymbols, a member of class TnxLocaleDescriptor.
ldIgnoreWidth | This is ldIgnoreWidth, a member of class TnxLocaleDescriptor.
ldIsDefaultStringLiteralLocale | This is ldIsDefaultStringLiteralLocale, a member of class TnxLocaleDescriptor.
ldLocale | This is ldLocale, a member of class TnxLocaleDescriptor.
ldNLSVersionInfoBuild | This is ldNLSVersionInfoBuild, a member of class TnxLocaleDescriptor.
ldNLSVersionInfoCurrent | This is ldNLSVersionInfoCurrent, a member of class TnxLocaleDescriptor.
ldOverrideStorageCodepage | This is ldOverrideStorageCodepage, a member of class TnxLocaleDescriptor.
ldUseStringSort | This is ldUseStringSort, a member of class TnxLocaleDescriptor.
ldVersion | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldGetCompareCodepage |
ldGetCurrentLocaleVersionEqualToBuildVersion |
ldGetFlags |
ldGetStorageCodepage |
ldSetFlags |
ldSetLocale |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxLocaleDescriptor
Create | constructor
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsCompareable |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CompareCodepage | Default Codepage derived from the Locale, used to compare strings. If this is different from StorageCodepage the strings need to be transformed before comparison.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CurrentLocaleVersionEqualToBuildVersion | This is CurrentLocaleVersionEqualToBuildVersion, a member of class TnxLocaleDescriptor.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | Returns the string flags as defined by the API (NORM_*).
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IgnoreKanaType | Set to true, to not differentiate between Hiragana and Katakana characters. Corresponding Hiragana and Katakana characters compare as equal.
IgnoreNonSpace | Set to true to ignore non spacing characters.
IgnoreSymbols | Set to true to ignore symbols.
IgnoreWidth | Set to true to differentiate between a single-byte character and the same character as a double-byte character.
IsDefaultStringLiteralLocale | When true, indicates that this is the server default locale.
Locale | This specifies the Locale ID to use. Use LOCALE_SYSTEM_DEFAULT or LOCALE_USER_DEFAULT for the defaults or create an id by using MAKELCID. The value is converted into a specific locale via ConvertDefaultLocale on assignment.
OverrideStorageCodepage | Set to a valid codepage to store strings in a non default codepage. e.g. CP_UTF8. To store strings in the default codepage for the locale use 0.
StorageCodepage | Codepage for storing strings in record buffers.
UseStringSort | Set to true to treat punctuation the same as symbols.
Links
TnxLocaleDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLocaleDescriptor.Create Constructor

TnxLocaleDescriptor.Create Constructor
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); overload;
Description

constructor

Class

TnxLocaleDescriptor Class

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Class


TnxLocaleDescriptor.Destroy Destructor

TnxLocaleDescriptor.Destroy Destructor
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxLocaleDescriptor Class

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Class


TnxLocaleDescriptor Fields

TnxLocaleDescriptor Fields
TnxLocaleDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxLocaleDescriptor class are listed here.

Class

TnxLocaleDescriptor Class

Protected Fields
Name | Description
ldIgnoreKanaType | This is ldIgnoreKanaType, a member of class TnxLocaleDescriptor.
ldIgnoreNonSpace | This is ldIgnoreNonSpace, a member of class TnxLocaleDescriptor.
ldIgnoreSymbols | This is ldIgnoreSymbols, a member of class TnxLocaleDescriptor.
ldIgnoreWidth | This is ldIgnoreWidth, a member of class TnxLocaleDescriptor.
ldIsDefaultStringLiteralLocale | This is ldIsDefaultStringLiteralLocale, a member of class TnxLocaleDescriptor.
ldLocale | This is ldLocale, a member of class TnxLocaleDescriptor.
ldNLSVersionInfoBuild | This is ldNLSVersionInfoBuild, a member of class TnxLocaleDescriptor.
ldNLSVersionInfoCurrent | This is ldNLSVersionInfoCurrent, a member of class TnxLocaleDescriptor.
ldOverrideStorageCodepage | This is ldOverrideStorageCodepage, a member of class TnxLocaleDescriptor.
ldUseStringSort | This is ldUseStringSort, a member of class TnxLocaleDescriptor.
ldVersion | private
Links
TnxLocaleDescriptor Class, Legend, Protected Fields


TnxLocaleDescriptor.ldIgnoreKanaType Field

TnxLocaleDescriptor.ldIgnoreKanaType Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldIgnoreKanaType: Boolean;
Description

This is ldIgnoreKanaType, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldIgnoreNonSpace Field

TnxLocaleDescriptor.ldIgnoreNonSpace Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldIgnoreNonSpace: Boolean;
Description

This is ldIgnoreNonSpace, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldIgnoreSymbols Field

TnxLocaleDescriptor.ldIgnoreSymbols Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldIgnoreSymbols: Boolean;
Description

This is ldIgnoreSymbols, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldIgnoreWidth Field

TnxLocaleDescriptor.ldIgnoreWidth Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldIgnoreWidth: Boolean;
Description

This is ldIgnoreWidth, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldIsDefaultStringLiteralLocale Field

TnxLocaleDescriptor.ldIsDefaultStringLiteralLocale Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldIsDefaultStringLiteralLocale: Boolean;
Description

This is ldIsDefaultStringLiteralLocale, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldLocale Field

TnxLocaleDescriptor.ldLocale Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldLocale: LCID;
Description

This is ldLocale, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldNLSVersionInfoBuild Field

TnxLocaleDescriptor.ldNLSVersionInfoBuild Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldNLSVersionInfoBuild: PNLSVersionInfoEx;
Description

This is ldNLSVersionInfoBuild, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldNLSVersionInfoCurrent Field

TnxLocaleDescriptor.ldNLSVersionInfoCurrent Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldNLSVersionInfoCurrent: PNLSVersionInfoEx;
Description

This is ldNLSVersionInfoCurrent, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldOverrideStorageCodepage Field

TnxLocaleDescriptor.ldOverrideStorageCodepage Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldOverrideStorageCodepage: Word;
Description

This is ldOverrideStorageCodepage, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldUseStringSort Field

TnxLocaleDescriptor.ldUseStringSort Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldUseStringSort: Boolean;
Description

This is ldUseStringSort, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor.ldVersion Field

TnxLocaleDescriptor.ldVersion Field
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Fields Send Feedback
Syntax
Delphi
ldVersion: Integer;
Description

private

Group

TnxLocaleDescriptor Fields

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Fields


TnxLocaleDescriptor Methods

TnxLocaleDescriptor Methods
TnxLocaleDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxLocaleDescriptor class are listed here.

Class

TnxLocaleDescriptor Class

Protected Methods
Name | Description
GetList |
ldGetCompareCodepage |
ldGetCurrentLocaleVersionEqualToBuildVersion |
ldGetFlags |
ldGetStorageCodepage |
ldSetFlags |
ldSetLocale |
Public Methods
Name | Description
CheckValid | TnxLocaleDescriptor
IsCompareable |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
LoadFromReader |
SaveToWriter |
Links
TnxLocaleDescriptor Class, Legend, Protected Methods, Public Methods


TnxLocaleDescriptor.CheckValid Method

TnxLocaleDescriptor.CheckValid Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxLocaleDescriptor

Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.GetList Method

TnxLocaleDescriptor.GetList Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.IsCompareable Method

TnxLocaleDescriptor.IsCompareable Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function IsCompareable(aLocaleDescriptor: TnxLocaleDescriptor): Boolean; virtual;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.IsEqual Method

TnxLocaleDescriptor.IsEqual Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Description

The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.

Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldGetCompareCodepage Method

TnxLocaleDescriptor.ldGetCompareCodepage Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function ldGetCompareCodepage: Word;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldGetCurrentLocaleVersionEqualToBuildVersion Method

TnxLocaleDescriptor.ldGetCurrentLocaleVersionEqualToBuildVersion Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function ldGetCurrentLocaleVersionEqualToBuildVersion: Boolean;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldGetFlags Method

TnxLocaleDescriptor.ldGetFlags Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function ldGetFlags: Cardinal;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldGetStorageCodepage Method

TnxLocaleDescriptor.ldGetStorageCodepage Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
function ldGetStorageCodepage: Word;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldSetFlags Method

TnxLocaleDescriptor.ldSetFlags Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
procedure ldSetFlags(const Value: Cardinal);
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.ldSetLocale Method

TnxLocaleDescriptor.ldSetLocale Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
procedure ldSetLocale(const Value: LCID);
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.LoadFromReader Method

TnxLocaleDescriptor.LoadFromReader Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor.SaveToWriter Method

TnxLocaleDescriptor.SaveToWriter Method
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxLocaleDescriptor Methods

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Methods


TnxLocaleDescriptor Properties

TnxLocaleDescriptor Properties
TnxLocaleDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxLocaleDescriptor class are listed here.

Class

TnxLocaleDescriptor Class

Public Properties
Name | Description
CompareCodepage | Default Codepage derived from the Locale, used to compare strings. If this is different from StorageCodepage the strings need to be transformed before comparison.
CurrentLocaleVersionEqualToBuildVersion | This is CurrentLocaleVersionEqualToBuildVersion, a member of class TnxLocaleDescriptor.
Flags | Returns the string flags as defined by the API (NORM_*).
IgnoreKanaType | Set to true, to not differentiate between Hiragana and Katakana characters. Corresponding Hiragana and Katakana characters compare as equal.
IgnoreNonSpace | Set to true to ignore non spacing characters.
IgnoreSymbols | Set to true to ignore symbols.
IgnoreWidth | Set to true to differentiate between a single-byte character and the same character as a double-byte character.
IsDefaultStringLiteralLocale | When true, indicates that this is the server default locale.
Locale | This specifies the Locale ID to use. Use LOCALE_SYSTEM_DEFAULT or LOCALE_USER_DEFAULT for the defaults or create an id by using MAKELCID. The value is converted into a specific locale via ConvertDefaultLocale on assignment.
OverrideStorageCodepage | Set to a valid codepage to store strings in a non default codepage. e.g. CP_UTF8. To store strings in the default codepage for the locale use 0.
StorageCodepage | Codepage for storing strings in record buffers.
UseStringSort | Set to true to treat punctuation the same as symbols.
Links
TnxLocaleDescriptor Class, Legend, Public Properties


TnxLocaleDescriptor.CompareCodepage Property

TnxLocaleDescriptor.CompareCodepage Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property CompareCodepage: Word;
Description

Default Codepage derived from the Locale, used to compare strings. If this is different from StorageCodepage the strings need to be transformed before comparison.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.CurrentLocaleVersionEqualToBuildVersion Property

TnxLocaleDescriptor.CurrentLocaleVersionEqualToBuildVersion Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property CurrentLocaleVersionEqualToBuildVersion: Boolean;
Description

This is CurrentLocaleVersionEqualToBuildVersion, a member of class TnxLocaleDescriptor.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.Flags Property

TnxLocaleDescriptor.Flags Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

Returns the string flags as defined by the API (NORM_*).

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.IgnoreKanaType Property

TnxLocaleDescriptor.IgnoreKanaType Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreKanaType: Boolean;
Description

Set to true, to not differentiate between Hiragana and Katakana characters. Corresponding Hiragana and Katakana characters compare as equal.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.IgnoreNonSpace Property

TnxLocaleDescriptor.IgnoreNonSpace Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreNonSpace: Boolean;
Description

Set to true to ignore non spacing characters.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.IgnoreSymbols Property

TnxLocaleDescriptor.IgnoreSymbols Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreSymbols: Boolean;
Description

Set to true to ignore symbols.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.IgnoreWidth Property

TnxLocaleDescriptor.IgnoreWidth Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreWidth: Boolean;
Description

Set to true to differentiate between a single-byte character and the same character as a double-byte character.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.IsDefaultStringLiteralLocale Property

TnxLocaleDescriptor.IsDefaultStringLiteralLocale Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property IsDefaultStringLiteralLocale: Boolean;
Description

When true, indicates that this is the server default locale.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.Locale Property

TnxLocaleDescriptor.Locale Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property Locale: LCID;
Description

This specifies the Locale ID to use. Use LOCALE_SYSTEM_DEFAULT or LOCALE_USER_DEFAULT for the defaults or create an id by using MAKELCID. The value is converted into a specific locale via ConvertDefaultLocale on assignment.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.OverrideStorageCodepage Property

TnxLocaleDescriptor.OverrideStorageCodepage Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property OverrideStorageCodepage: Word;
Description

Set to a valid codepage to store strings in a non default codepage. e.g. CP_UTF8. To store strings in the default codepage for the locale use 0.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.StorageCodepage Property

TnxLocaleDescriptor.StorageCodepage Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property StorageCodepage: Word;
Description

Codepage for storing strings in record buffers.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocaleDescriptor.UseStringSort Property

TnxLocaleDescriptor.UseStringSort Property
TnxLocaleDescriptor Class TnxLocaleDescriptor Members nxsdDataDictionary Namespace TnxLocaleDescriptor Properties Send Feedback
Syntax
Delphi
property UseStringSort: Boolean;
Description

Set to true to treat punctuation the same as symbols.

Group

TnxLocaleDescriptor Properties

Links
TnxLocaleDescriptor Class, TnxLocaleDescriptor Members, nxsdDataDictionary Namespace, TnxLocaleDescriptor Properties


TnxLocalizedDictionaryItem Class

TnxLocalizedDictionaryItem Class
TnxLocalizedDictionaryItem Fields TnxLocalizedDictionaryItem Methods TnxLocalizedDictionaryItem Properties TnxLocalizedDictionaryItem Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxLocalizedDictionaryItemnxsdDataDictionary_TnxLocalizedDictionaryItemnxsdDataDictionary_TnxLocalizedDictionaryItemnxsdDataDictionary_TnxLocalizedDictionaryItemnxsdDataDictionary_TnxLocalizedDictionaryItemnxsdDataDictionary_TnxLocalizedDictionaryItem
Syntax
Delphi
TnxLocalizedDictionaryItem = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

A dictionary item with Locale Descriptors for localization of strings.

Group

Classes

Links
TnxLocalizedDictionaryItem Fields, TnxLocalizedDictionaryItem Methods, TnxLocalizedDictionaryItem Properties, TnxLocalizedDictionaryItem Members, nxsdDataDictionary, Classes


TnxLocalizedDictionaryItem Members

TnxLocalizedDictionaryItem Members
TnxLocalizedDictionaryItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLocalizedDictionaryItem.

Class

TnxLocalizedDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxLocalizedDictionaryItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLocalizedDictionaryItem.Destroy Destructor

TnxLocalizedDictionaryItem.Destroy Destructor
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxLocalizedDictionaryItem Class

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Class


TnxLocalizedDictionaryItem Fields

TnxLocalizedDictionaryItem Fields
TnxLocalizedDictionaryItem Class Legend Protected Fields Send Feedback

The fields of the TnxLocalizedDictionaryItem class are listed here.

Class

TnxLocalizedDictionaryItem Class

Protected Fields
Name | Description
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
Links
TnxLocalizedDictionaryItem Class, Legend, Protected Fields


TnxLocalizedDictionaryItem.ldiCachedLocaleDescriptor Field

TnxLocalizedDictionaryItem.ldiCachedLocaleDescriptor Field
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Fields Send Feedback
Syntax
Delphi
ldiCachedLocaleDescriptor: TnxLocaleDescriptor;
Description

This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.

Group

TnxLocalizedDictionaryItem Fields

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Fields


TnxLocalizedDictionaryItem.ldiCachedStorageCodePage Field

TnxLocalizedDictionaryItem.ldiCachedStorageCodePage Field
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Fields Send Feedback
Syntax
Delphi
ldiCachedStorageCodePage: Word;
Description

This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.

Group

TnxLocalizedDictionaryItem Fields

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Fields


TnxLocalizedDictionaryItem.ldiLocaleDescriptor Field

TnxLocalizedDictionaryItem.ldiLocaleDescriptor Field
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Fields Send Feedback
Syntax
Delphi
ldiLocaleDescriptor: TnxLocaleDescriptor;
Description

private

Group

TnxLocalizedDictionaryItem Fields

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Fields


TnxLocalizedDictionaryItem Methods

TnxLocalizedDictionaryItem Methods
TnxLocalizedDictionaryItem Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxLocalizedDictionaryItem class are listed here.

Class

TnxLocalizedDictionaryItem Class

Protected Methods
Name | Description
diActivateCaching |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
CheckValid |
FindRelatedDescriptorOfType |
IsEqual |
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
Links
TnxLocalizedDictionaryItem Class, Legend, Protected Methods, Public Methods


TnxLocalizedDictionaryItem.AddLocaleDescriptor Method

TnxLocalizedDictionaryItem.AddLocaleDescriptor Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods See Also Send Feedback
Syntax
Delphi
function AddLocaleDescriptor(aLocaleClass: TnxLocaleDescriptorClass = nil): TnxLocaleDescriptor;
Description

This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.

See Also

AddLocaleDescriptor, RemoveLocaleDescriptor, LocaleDescriptor

TnxLocalizedDictionaryItem

Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods, See Also


TnxLocalizedDictionaryItem.AddLocaleDescriptorT Method

TnxLocalizedDictionaryItem.AddLocaleDescriptorT Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function AddLocaleDescriptorT<T: TnxLocaleDescriptor>: T;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.CheckValid Method

TnxLocalizedDictionaryItem.CheckValid Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.diActivateCaching Method

TnxLocalizedDictionaryItem.diActivateCaching Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure diActivateCaching; override;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.FindRelatedDescriptorOfType Method

TnxLocalizedDictionaryItem.FindRelatedDescriptorOfType Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; override;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.IsEqual Method

TnxLocalizedDictionaryItem.IsEqual Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.ldiGetUsedLocaleDescriptor Method

TnxLocalizedDictionaryItem.ldiGetUsedLocaleDescriptor Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function ldiGetUsedLocaleDescriptor: TnxLocaleDescriptor; virtual;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.ldiGetUsedStorageCodePage Method

TnxLocalizedDictionaryItem.ldiGetUsedStorageCodePage Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function ldiGetUsedStorageCodePage: Word;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.ldiLoadFromReader Method

TnxLocalizedDictionaryItem.ldiLoadFromReader Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure ldiLoadFromReader(aReader: TnxReader); virtual;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.ldiOuterGetUsedLocaleDescriptor Method

TnxLocalizedDictionaryItem.ldiOuterGetUsedLocaleDescriptor Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
function ldiOuterGetUsedLocaleDescriptor: TnxLocaleDescriptor; virtual;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.ldiSaveToWriter Method

TnxLocalizedDictionaryItem.ldiSaveToWriter Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure ldiSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); virtual;
Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods


TnxLocalizedDictionaryItem.RemoveLocaleDescriptor Method

TnxLocalizedDictionaryItem.RemoveLocaleDescriptor Method
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveLocaleDescriptor;
Description

This function frees the Instance of the associated Locale Descriptor.

See Also

AddLocaleDescriptor, RemoveLocaleDescriptor, LocaleDescriptor

Group

TnxLocalizedDictionaryItem Methods

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Methods, See Also


TnxLocalizedDictionaryItem Properties

TnxLocalizedDictionaryItem Properties
TnxLocalizedDictionaryItem Class Legend Public Properties Send Feedback

The properties of the TnxLocalizedDictionaryItem class are listed here.

Class

TnxLocalizedDictionaryItem Class

Public Properties
Name | Description
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxLocalizedDictionaryItem Class, Legend, Public Properties


TnxLocalizedDictionaryItem.LocaleDescriptor Property

TnxLocalizedDictionaryItem.LocaleDescriptor Property
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Properties See Also Send Feedback
Syntax
Delphi
property LocaleDescriptor: TnxLocaleDescriptor;
Description

This property returns the associated Locale Descriptor.

See Also

AddLocaleDescriptor, RemoveLocaleDescriptor, LocaleDescriptor

Group

TnxLocalizedDictionaryItem Properties

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Properties, See Also


TnxLocalizedDictionaryItem.UsedLocaleDescriptor Property

TnxLocalizedDictionaryItem.UsedLocaleDescriptor Property
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Properties See Also Send Feedback
Syntax
Delphi
property UsedLocaleDescriptor: TnxLocaleDescriptor;
Description

This property returns the Locale Descriptor currently in use.

See Also

AddLocaleDescriptor, RemoveLocaleDescriptor, LocaleDescriptor

Group

TnxLocalizedDictionaryItem Properties

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Properties, See Also


TnxLocalizedDictionaryItem.UsedStorageCodePage Property

TnxLocalizedDictionaryItem.UsedStorageCodePage Property
TnxLocalizedDictionaryItem Class TnxLocalizedDictionaryItem Members nxsdDataDictionary Namespace TnxLocalizedDictionaryItem Properties See Also Send Feedback
Syntax
Delphi
property UsedStorageCodePage: Word;
Description

This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.

See Also

AddLocaleDescriptor, RemoveLocaleDescriptor, LocaleDescriptor

Group

TnxLocalizedDictionaryItem Properties

Links
TnxLocalizedDictionaryItem Class, TnxLocalizedDictionaryItem Members, nxsdDataDictionary Namespace, TnxLocalizedDictionaryItem Properties, See Also


TnxMainIndicesDescriptor Class

TnxMainIndicesDescriptor Class
TnxMainIndicesDescriptor Fields TnxMainIndicesDescriptor Methods TnxMainIndicesDescriptor Properties TnxMainIndicesDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptornxsdDataDictionary_TnxMainIndicesDescriptor
Syntax
Delphi
TnxMainIndicesDescriptor = class(TnxBaseIndicesDescriptor);
File

nxsdDataDictionary

Description

Holds a list of IndexDescriptors that are main indices. Main indices are user selectable indices (e.g. IndexName property) as opposed to internally used indices.

Group

Classes

Links
TnxMainIndicesDescriptor Fields, TnxMainIndicesDescriptor Methods, TnxMainIndicesDescriptor Properties, TnxMainIndicesDescriptor Members, nxsdDataDictionary, Classes


TnxMainIndicesDescriptor Members

TnxMainIndicesDescriptor Members
TnxMainIndicesDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMainIndicesDescriptor.

Class

TnxMainIndicesDescriptor Class

Protected Fields
Name | Description
bidHeaderSection | private
bidIndexChangeNotifies | This is bidIndexChangeNotifies, a member of class TnxBaseIndicesDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
midDefaultIndex | private
Protected Methods
Name | Description
_AddRef |
_Release |
bidAddToIndexChangeNotifies |
bidDefaultIndexClass |
bidDefaultKeyClass |
bidIndexChangeNotification | TnxMainIndicesDescriptor
bidRemoveFromIndexChangeNotifies |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
midSetDefaultIndex |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
IndexCount | The number of index descriptors in the list.
IndexDescriptor | The index descriptors for this table.
IndicesEngine | The name of the Indices Engine used for this table.
Public Methods
Name | Description
AddIndex | This is the overview for the AddIndex method overload.
AddIndexT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | Clears the list of descriptors.
Destroy | destructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetDescriptorFromName | Return the index descriptor for a given index name, or nil if not found.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
InsertIndexAt | This is the overview for the InsertIndexAt method overload.
InsertIndexAtT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
MoveIndex | Moves an Index Descriptor in the list of descriptors from aFrom to the aTo position
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveIndex | This is the overview for the RemoveIndex method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
DefaultIndex | The number of the Default index used for the table.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
HeaderSection | Returns the Header of the descriptor as string.
ID | Unique ID of the dictionary item
Links
TnxMainIndicesDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxMainIndicesDescriptor.Create Constructor

TnxMainIndicesDescriptor.Create Constructor
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aHeaderSection: AnsiString); virtual;
Class

TnxMainIndicesDescriptor Class

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Class


TnxMainIndicesDescriptor Fields

TnxMainIndicesDescriptor Fields
TnxMainIndicesDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxMainIndicesDescriptor class are listed here.

Class

TnxMainIndicesDescriptor Class

Protected Fields
Name | Description
midDefaultIndex | private
Links
TnxMainIndicesDescriptor Class, Legend, Protected Fields


TnxMainIndicesDescriptor.midDefaultIndex Field

TnxMainIndicesDescriptor.midDefaultIndex Field
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Fields Send Feedback
Syntax
Delphi
midDefaultIndex: Integer;
Description

private

Group

TnxMainIndicesDescriptor Fields

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Fields


TnxMainIndicesDescriptor Methods

TnxMainIndicesDescriptor Methods
TnxMainIndicesDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMainIndicesDescriptor class are listed here.

Class

TnxMainIndicesDescriptor Class

Protected Methods
Name | Description
bidIndexChangeNotification | TnxMainIndicesDescriptor
GetList |
midSetDefaultIndex |
Public Methods
Name | Description
CheckValid |
Clear | Clears the list of descriptors.
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxMainIndicesDescriptor Class, Legend, Protected Methods, Public Methods


TnxMainIndicesDescriptor.bidIndexChangeNotification Method

TnxMainIndicesDescriptor.bidIndexChangeNotification Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure bidIndexChangeNotification(aBefore: Boolean; aOldIndex: Integer; aNewIndex: Integer); override;
Description

TnxMainIndicesDescriptor

Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.CheckValid Method

TnxMainIndicesDescriptor.CheckValid Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.Clear Method

TnxMainIndicesDescriptor.Clear Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear(aNotify: Boolean); override;
Description

Clears the list of descriptors.

Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.GetList Method

TnxMainIndicesDescriptor.GetList Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.IsEqual Method

TnxMainIndicesDescriptor.IsEqual Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.LoadFromReader Method

TnxMainIndicesDescriptor.LoadFromReader Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.midSetDefaultIndex Method

TnxMainIndicesDescriptor.midSetDefaultIndex Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure midSetDefaultIndex(Value: Integer);
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor.SaveToWriter Method

TnxMainIndicesDescriptor.SaveToWriter Method
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxMainIndicesDescriptor Methods

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Methods


TnxMainIndicesDescriptor Properties

TnxMainIndicesDescriptor Properties
TnxMainIndicesDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxMainIndicesDescriptor class are listed here.

Class

TnxMainIndicesDescriptor Class

Public Properties
Name | Description
DefaultIndex | The number of the Default index used for the table.
Links
TnxMainIndicesDescriptor Class, Legend, Public Properties


TnxMainIndicesDescriptor.DefaultIndex Property

TnxMainIndicesDescriptor.DefaultIndex Property
TnxMainIndicesDescriptor Class TnxMainIndicesDescriptor Members nxsdDataDictionary Namespace TnxMainIndicesDescriptor Properties Send Feedback
Syntax
Delphi
property DefaultIndex: Integer;
Description

The number of the Default index used for the table.

Group

TnxMainIndicesDescriptor Properties

Links
TnxMainIndicesDescriptor Class, TnxMainIndicesDescriptor Members, nxsdDataDictionary Namespace, TnxMainIndicesDescriptor Properties


TnxMinMaxValidationDescriptor Class

TnxMinMaxValidationDescriptor Class
TnxMinMaxValidationDescriptor Fields TnxMinMaxValidationDescriptor Methods TnxMinMaxValidationDescriptor Properties TnxMinMaxValidationDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptornxsdDataDictionary_TnxMinMaxValidationDescriptor
Syntax
Delphi
TnxMinMaxValidationDescriptor = class(TnxBaseFieldValidationDescriptor);
File

nxsdDataDictionary

Description

A validation descriptor to check for Minimum/Maximum values

Group

Classes

Links
TnxMinMaxValidationDescriptor Fields, TnxMinMaxValidationDescriptor Methods, TnxMinMaxValidationDescriptor Properties, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary, Classes


TnxMinMaxValidationDescriptor Members

TnxMinMaxValidationDescriptor Members
TnxMinMaxValidationDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMinMaxValidationDescriptor.

Class

TnxMinMaxValidationDescriptor Class

Protected Fields
Name | Description
bvdApplyAt | This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.
bvdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
mmvdKeyField | This is mmvdKeyField, a member of class TnxMinMaxValidationDescriptor.
mmvdMax | This is mmvdMax, a member of class TnxMinMaxValidationDescriptor.
mmvdMin | private
Protected Methods
Name | Description
_AddRef |
_Release |
bvdGetApplyAt | TnxBaseFieldValidationDescriptor
bvdGetInvalidFieldTypes |
bvdSetApplyAt |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
mmvdGetMaxAsVariant |
mmvdGetMinAsVariant |
mmvdSetMaxAsVariant |
mmvdSetMinAsVariant |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddKeyField | Associates the descriptor with a Field. TnxMinMaxValidationDescriptor
AddKeyFieldT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetInvalidFieldTypes |
GetLifetimeMontior |
GetList | Returns the internal List of Validation Descriptor classes.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveKeyField | Removes the field association iow disables the validation.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Defines if the validation should be done at client and/or server side.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyField | Returns the descriptor of the associated Key field.
Max | Gets the maximum value as raw data.
MaxAsVariant | Gets/Sets the maximum value as OleVariant.
Min | Gets the minimum value as raw data.
MinAsVariant | Gets/Sets the minimum value as OleVariant.
Name | Name of the Validation.
Links
TnxMinMaxValidationDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMinMaxValidationDescriptor.Destroy Destructor

TnxMinMaxValidationDescriptor.Destroy Destructor
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMinMaxValidationDescriptor Class

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Class


TnxMinMaxValidationDescriptor Fields

TnxMinMaxValidationDescriptor Fields
TnxMinMaxValidationDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxMinMaxValidationDescriptor class are listed here.

Class

TnxMinMaxValidationDescriptor Class

Protected Fields
Name | Description
mmvdKeyField | This is mmvdKeyField, a member of class TnxMinMaxValidationDescriptor.
mmvdMax | This is mmvdMax, a member of class TnxMinMaxValidationDescriptor.
mmvdMin | private
Links
TnxMinMaxValidationDescriptor Class, Legend, Protected Fields


TnxMinMaxValidationDescriptor.mmvdKeyField Field

TnxMinMaxValidationDescriptor.mmvdKeyField Field
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Fields Send Feedback
Syntax
Delphi
mmvdKeyField: TnxKeyFieldDescriptor;
Description

This is mmvdKeyField, a member of class TnxMinMaxValidationDescriptor.

Group

TnxMinMaxValidationDescriptor Fields

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Fields


TnxMinMaxValidationDescriptor.mmvdMax Field

TnxMinMaxValidationDescriptor.mmvdMax Field
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Fields Send Feedback
Syntax
Delphi
mmvdMax: TnxDynByteArray;
Description

This is mmvdMax, a member of class TnxMinMaxValidationDescriptor.

Group

TnxMinMaxValidationDescriptor Fields

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Fields


TnxMinMaxValidationDescriptor.mmvdMin Field

TnxMinMaxValidationDescriptor.mmvdMin Field
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Fields Send Feedback
Syntax
Delphi
mmvdMin: TnxDynByteArray;
Description

private

Group

TnxMinMaxValidationDescriptor Fields

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Fields


TnxMinMaxValidationDescriptor Methods

TnxMinMaxValidationDescriptor Methods
TnxMinMaxValidationDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMinMaxValidationDescriptor class are listed here.

Class

TnxMinMaxValidationDescriptor Class

Protected Methods
Name | Description
mmvdGetMaxAsVariant |
mmvdGetMinAsVariant |
mmvdSetMaxAsVariant |
mmvdSetMinAsVariant |
Public Methods
Name | Description
AddKeyField | Associates the descriptor with a Field. TnxMinMaxValidationDescriptor
AddKeyFieldT |
CheckValid |
IsEqual |
LoadFromReader |
RemoveKeyField | Removes the field association iow disables the validation.
SaveToWriter |
Links
TnxMinMaxValidationDescriptor Class, Legend, Protected Methods, Public Methods


TnxMinMaxValidationDescriptor.AddKeyField Method

TnxMinMaxValidationDescriptor.AddKeyField Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
function AddKeyField(aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor;
Description

Associates the descriptor with a Field.

TnxMinMaxValidationDescriptor

Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.AddKeyFieldT Method

TnxMinMaxValidationDescriptor.AddKeyFieldT Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
function AddKeyFieldT<T: TnxKeyFieldDescriptor>: T;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.CheckValid Method

TnxMinMaxValidationDescriptor.CheckValid Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.IsEqual Method

TnxMinMaxValidationDescriptor.IsEqual Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.LoadFromReader Method

TnxMinMaxValidationDescriptor.LoadFromReader Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.mmvdGetMaxAsVariant Method

TnxMinMaxValidationDescriptor.mmvdGetMaxAsVariant Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
function mmvdGetMaxAsVariant: OleVariant;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.mmvdGetMinAsVariant Method

TnxMinMaxValidationDescriptor.mmvdGetMinAsVariant Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
function mmvdGetMinAsVariant: OleVariant;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.mmvdSetMaxAsVariant Method

TnxMinMaxValidationDescriptor.mmvdSetMaxAsVariant Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure mmvdSetMaxAsVariant(const Value: OleVariant);
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.mmvdSetMinAsVariant Method

TnxMinMaxValidationDescriptor.mmvdSetMinAsVariant Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure mmvdSetMinAsVariant(const Value: OleVariant);
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.RemoveKeyField Method

TnxMinMaxValidationDescriptor.RemoveKeyField Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveKeyField;
Description

Removes the field association iow disables the validation.

Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor.SaveToWriter Method

TnxMinMaxValidationDescriptor.SaveToWriter Method
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxMinMaxValidationDescriptor Methods

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Methods


TnxMinMaxValidationDescriptor Properties

TnxMinMaxValidationDescriptor Properties
TnxMinMaxValidationDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxMinMaxValidationDescriptor class are listed here.

Class

TnxMinMaxValidationDescriptor Class

Public Properties
Name | Description
KeyField | Returns the descriptor of the associated Key field.
Max | Gets the maximum value as raw data.
MaxAsVariant | Gets/Sets the maximum value as OleVariant.
Min | Gets the minimum value as raw data.
MinAsVariant | Gets/Sets the minimum value as OleVariant.
Links
TnxMinMaxValidationDescriptor Class, Legend, Public Properties


TnxMinMaxValidationDescriptor.KeyField Property

TnxMinMaxValidationDescriptor.KeyField Property
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Properties Send Feedback
Syntax
Delphi
property KeyField: TnxKeyFieldDescriptor;
Description

Returns the descriptor of the associated Key field.

Group

TnxMinMaxValidationDescriptor Properties

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Properties


TnxMinMaxValidationDescriptor.Max Property

TnxMinMaxValidationDescriptor.Max Property
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Properties Send Feedback
Syntax
Delphi
property Max: TnxDynByteArray;
Description

Gets the maximum value as raw data.

Group

TnxMinMaxValidationDescriptor Properties

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Properties


TnxMinMaxValidationDescriptor.MaxAsVariant Property

TnxMinMaxValidationDescriptor.MaxAsVariant Property
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Properties Send Feedback
Syntax
Delphi
property MaxAsVariant: OleVariant;
Description

Gets/Sets the maximum value as OleVariant.

Group

TnxMinMaxValidationDescriptor Properties

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Properties


TnxMinMaxValidationDescriptor.Min Property

TnxMinMaxValidationDescriptor.Min Property
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Properties Send Feedback
Syntax
Delphi
property Min: TnxDynByteArray;
Description

Gets the minimum value as raw data.

Group

TnxMinMaxValidationDescriptor Properties

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Properties


TnxMinMaxValidationDescriptor.MinAsVariant Property

TnxMinMaxValidationDescriptor.MinAsVariant Property
TnxMinMaxValidationDescriptor Class TnxMinMaxValidationDescriptor Members nxsdDataDictionary Namespace TnxMinMaxValidationDescriptor Properties Send Feedback
Syntax
Delphi
property MinAsVariant: OleVariant;
Description

Gets/Sets the minimum value as OleVariant.

Group

TnxMinMaxValidationDescriptor Properties

Links
TnxMinMaxValidationDescriptor Class, TnxMinMaxValidationDescriptor Members, nxsdDataDictionary Namespace, TnxMinMaxValidationDescriptor Properties


TnxNestedTableDescriptor Class

TnxNestedTableDescriptor Class
TnxNestedTableDescriptor Fields TnxNestedTableDescriptor Methods TnxNestedTableDescriptor Properties TnxNestedTableDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptornxsdDataDictionary_TnxNestedTableDescriptor
Syntax
Delphi
TnxNestedTableDescriptor = class(TnxBaseTableDescriptor);
File

nxsdDataDictionary

Description

A nested (sub) Table Descriptor is a special descriptor that is used for defining the sub tables of a certain main table.

Group

Classes

Links
TnxNestedTableDescriptor Fields, TnxNestedTableDescriptor Methods, TnxNestedTableDescriptor Properties, TnxNestedTableDescriptor Members, nxsdDataDictionary, Classes


TnxNestedTableDescriptor Members

TnxNestedTableDescriptor Members
TnxNestedTableDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNestedTableDescriptor.

Class

TnxNestedTableDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
ntdName | private
tdAutoIncDescriptor | This is tdAutoIncDescriptor, a member of class TnxBaseTableDescriptor.
tdBlobDescriptor | This is tdBlobDescriptor, a member of class TnxBaseTableDescriptor.
tdConstraints | This is tdConstraints, a member of class TnxBaseTableDescriptor.
tdCustomDescsDescriptor | This is tdCustomDescsDescriptor, a member of class TnxBaseTableDescriptor.
tdFieldsDescriptor | private
tdIndicesDescriptor | This is tdIndicesDescriptor, a member of class TnxBaseTableDescriptor.
tdRecordDescriptor | This is tdRecordDescriptor, a member of class TnxBaseTableDescriptor.
tdTablesDescriptor | This is tdTablesDescriptor, a member of class TnxBaseTableDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
ClearPrim |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tdGetBookmarkSize |
tdGetKeyLen |
Unregister |
Public Methods
Name | Description
AddAutoIncDescriptor | This function sets the AutoInc Descriptor class to the given aAutoIncClass, creates and instance, adds it to the data dictionary and returns the instance.
AddAutoIncDescriptorT |
AddBlobDescriptor | This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddBlobDescriptorT |
AddIndicesDescriptor | This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
AddIndicesDescriptorT |
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddRecordDescriptor | This function sets the Record Descriptor class to the given aRecordClass, creates and instance, adds it to the data dictionary and returns the instance.
AddRecordDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
AssignOnlyFields | Copy all fields from another table descriptor.
BeforeDestruction | TnxLifetimeTrackedPersistent
btdFullName |
CheckValid | Checks if the Data Dictionary is valid. Raises an exception if not.
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Clear | This function clears the Data Dictionary.
Create | constructor - needs the main table as parent and it's Name TnxNestedTableDescriptor
Destroy | destructor.
Destroy | destructor.
Destroy |
EnsureIndicesDescriptor | This function ensures there is an indices descritor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetChild | Returns a named sub table descriptor.
GetConstraintByName | Returns the constraint descriptor for the named constraint.
GetConstraints | Returns the names of all constraints assigned to this table.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldFromName | Return the field number for a given field name, or -1 if not found.
GetIndexFromName | Return the index number for a given index name, or -1 if not found.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsFieldDescValid | Returns true if an Field Descriptor validates ok.
IsIndexDescValid | Returns true if an Index Descriptor validates ok.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
LoadFromReader | Loads the item settings from a Reader/Stream
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveAutoIncDescriptor | This function frees the Instance of the associated AutoInc Descriptor.
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveRecordDescriptor | This function frees the Instance of the associated Record Descriptor.
RequiresPack |
SaveToWriter |
SaveToWriter | Saves the item settings to a Writer/Stream
Public Properties
Name | Description
AutoIncDescriptor | This property returns the associated AutoInc Descriptor.
BlobDescriptor | This property returns the associated Blob Descriptor.
BookmarkSize | The length of a bookmark for the given index.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomDescsDescriptor | Holds all CustomDescriptor items of the table
CustomStrings | A storage container for developers to store extra data with the descriptor.
FieldsDescriptor | Holds all FieldDescriptor items of the table
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IndicesDescriptor | This property returns the associated Indices Descriptor.
KeyLen | The length of the key for the given index.
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | Returns the Name of the table.
RecordDescriptor | This property returns the associated Record Descriptor.
TablesDescriptor | Holds all Sub TableDescriptor items of the table
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxNestedTableDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxNestedTableDescriptor.Create Constructor

TnxNestedTableDescriptor.Create Constructor
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; const aName: string); virtual; reintroduce;
Description

constructor - needs the main table as parent and it's Name

TnxNestedTableDescriptor

Class

TnxNestedTableDescriptor Class

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Class


TnxNestedTableDescriptor Fields

TnxNestedTableDescriptor Fields
TnxNestedTableDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxNestedTableDescriptor class are listed here.

Class

TnxNestedTableDescriptor Class

Protected Fields
Name | Description
ntdName | private
Links
TnxNestedTableDescriptor Class, Legend, Protected Fields


TnxNestedTableDescriptor.ntdName Field

TnxNestedTableDescriptor.ntdName Field
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Fields Send Feedback
Syntax
Delphi
ntdName: string;
Description

private

Group

TnxNestedTableDescriptor Fields

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Fields


TnxNestedTableDescriptor Methods

TnxNestedTableDescriptor Methods
TnxNestedTableDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNestedTableDescriptor class are listed here.

Class

TnxNestedTableDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
btdFullName |
IsEqual |
Links
TnxNestedTableDescriptor Class, Legend, Protected Methods, Public Methods


TnxNestedTableDescriptor.btdFullName Method

TnxNestedTableDescriptor.btdFullName Method
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Methods Send Feedback
Syntax
Delphi
function btdFullName: string; override;
Group

TnxNestedTableDescriptor Methods

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Methods


TnxNestedTableDescriptor.GetList Method

TnxNestedTableDescriptor.GetList Method
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxNestedTableDescriptor Methods

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Methods


TnxNestedTableDescriptor.IsEqual Method

TnxNestedTableDescriptor.IsEqual Method
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxNestedTableDescriptor Methods

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Methods


TnxNestedTableDescriptor Properties

TnxNestedTableDescriptor Properties
TnxNestedTableDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxNestedTableDescriptor class are listed here.

Class

TnxNestedTableDescriptor Class

Public Properties
Name | Description
Name | Returns the Name of the table.
Links
TnxNestedTableDescriptor Class, Legend, Public Properties


TnxNestedTableDescriptor.Name Property

TnxNestedTableDescriptor.Name Property
TnxNestedTableDescriptor Class TnxNestedTableDescriptor Members nxsdDataDictionary Namespace TnxNestedTableDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

Returns the Name of the table.

Group

TnxNestedTableDescriptor Properties

Links
TnxNestedTableDescriptor Class, TnxNestedTableDescriptor Members, nxsdDataDictionary Namespace, TnxNestedTableDescriptor Properties


TnxNoChangeValidationDescriptor Class

TnxNoChangeValidationDescriptor Class
TnxNoChangeValidationDescriptor Fields TnxNoChangeValidationDescriptor Methods TnxNoChangeValidationDescriptor Properties TnxNoChangeValidationDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptornxsdDataDictionary_TnxNoChangeValidationDescriptor
Syntax
Delphi
TnxNoChangeValidationDescriptor = class(TnxBaseFieldValidationDescriptor);
File

nxsdDataDictionary

Description

A validation descriptor to disallow field changes once it was initially set.

Group

Classes

Links
TnxNoChangeValidationDescriptor Fields, TnxNoChangeValidationDescriptor Methods, TnxNoChangeValidationDescriptor Properties, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary, Classes


TnxNoChangeValidationDescriptor Members

TnxNoChangeValidationDescriptor Members
TnxNoChangeValidationDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNoChangeValidationDescriptor.

Class

TnxNoChangeValidationDescriptor Class

Protected Fields
Name | Description
bvdApplyAt | This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.
bvdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
ncvdKeyField | private
Protected Methods
Name | Description
_AddRef |
_Release |
bvdGetApplyAt | TnxBaseFieldValidationDescriptor
bvdGetInvalidFieldTypes |
bvdSetApplyAt |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddKeyField | Associates the descriptor with a Field. TnxNoChangeValidationDescriptor
AddKeyFieldT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetInvalidFieldTypes |
GetLifetimeMontior |
GetList | Returns the internal List of Validation Descriptor classes.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveKeyField | Removes the field association iow disables the validation.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Defines if the validation should be done at client and/or server side.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyField | Returns the descriptor of the associated Key field.
Name | Name of the Validation.
Links
TnxNoChangeValidationDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxNoChangeValidationDescriptor.Destroy Destructor

TnxNoChangeValidationDescriptor.Destroy Destructor
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxNoChangeValidationDescriptor Class

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Class


TnxNoChangeValidationDescriptor Fields

TnxNoChangeValidationDescriptor Fields
TnxNoChangeValidationDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxNoChangeValidationDescriptor class are listed here.

Class

TnxNoChangeValidationDescriptor Class

Protected Fields
Name | Description
ncvdKeyField | private
Links
TnxNoChangeValidationDescriptor Class, Legend, Protected Fields


TnxNoChangeValidationDescriptor.ncvdKeyField Field

TnxNoChangeValidationDescriptor.ncvdKeyField Field
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Fields Send Feedback
Syntax
Delphi
ncvdKeyField: TnxKeyFieldDescriptor;
Description

private

Group

TnxNoChangeValidationDescriptor Fields

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Fields


TnxNoChangeValidationDescriptor Methods

TnxNoChangeValidationDescriptor Methods
TnxNoChangeValidationDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxNoChangeValidationDescriptor class are listed here.

Class

TnxNoChangeValidationDescriptor Class

Public Methods
Name | Description
AddKeyField | Associates the descriptor with a Field. TnxNoChangeValidationDescriptor
AddKeyFieldT |
CheckValid |
IsEqual |
LoadFromReader |
RemoveKeyField | Removes the field association iow disables the validation.
SaveToWriter |
Links
TnxNoChangeValidationDescriptor Class, Legend, Public Methods


TnxNoChangeValidationDescriptor.AddKeyField Method

TnxNoChangeValidationDescriptor.AddKeyField Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
function AddKeyField(aClass: TnxKeyFieldDescriptorClass = nil): TnxKeyFieldDescriptor;
Description

Associates the descriptor with a Field.

TnxNoChangeValidationDescriptor

Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.AddKeyFieldT Method

TnxNoChangeValidationDescriptor.AddKeyFieldT Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
function AddKeyFieldT<T: TnxKeyFieldDescriptor>: T;
Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.CheckValid Method

TnxNoChangeValidationDescriptor.CheckValid Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.IsEqual Method

TnxNoChangeValidationDescriptor.IsEqual Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.LoadFromReader Method

TnxNoChangeValidationDescriptor.LoadFromReader Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.RemoveKeyField Method

TnxNoChangeValidationDescriptor.RemoveKeyField Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveKeyField;
Description

Removes the field association iow disables the validation.

Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor.SaveToWriter Method

TnxNoChangeValidationDescriptor.SaveToWriter Method
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxNoChangeValidationDescriptor Methods

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Methods


TnxNoChangeValidationDescriptor Properties

TnxNoChangeValidationDescriptor Properties
TnxNoChangeValidationDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxNoChangeValidationDescriptor class are listed here.

Class

TnxNoChangeValidationDescriptor Class

Public Properties
Name | Description
KeyField | Returns the descriptor of the associated Key field.
Links
TnxNoChangeValidationDescriptor Class, Legend, Public Properties


TnxNoChangeValidationDescriptor.KeyField Property

TnxNoChangeValidationDescriptor.KeyField Property
TnxNoChangeValidationDescriptor Class TnxNoChangeValidationDescriptor Members nxsdDataDictionary Namespace TnxNoChangeValidationDescriptor Properties Send Feedback
Syntax
Delphi
property KeyField: TnxKeyFieldDescriptor;
Description

Returns the descriptor of the associated Key field.

Group

TnxNoChangeValidationDescriptor Properties

Links
TnxNoChangeValidationDescriptor Class, TnxNoChangeValidationDescriptor Members, nxsdDataDictionary Namespace, TnxNoChangeValidationDescriptor Properties


TnxNoNullCompKeyDescriptor Class

TnxNoNullCompKeyDescriptor Class
TnxNoNullCompKeyDescriptor Methods TnxNoNullCompKeyDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptornxsdDataDictionary_TnxNoNullCompKeyDescriptor
Syntax
Delphi
TnxNoNullCompKeyDescriptor = class(TnxCompKeyDescriptor);
File

nxsdDataDictionary

Description

Key descriptor used to ensure a field is NOT null.

Group

Classes

Links
TnxNoNullCompKeyDescriptor Methods, TnxNoNullCompKeyDescriptor Members, nxsdDataDictionary, Classes


TnxNoNullCompKeyDescriptor Members

TnxNoNullCompKeyDescriptor Members
TnxNoNullCompKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNoNullCompKeyDescriptor.

Class

TnxNoNullCompKeyDescriptor Class

Protected Fields
Name | Description
ckdKeyFields | private
ckdKeyLen | This is ckdKeyLen, a member of class TnxCompKeyDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bkdGetKeyLen | TnxNoNullCompKeyDescriptor
CheckReadOnly |
ckdGetKeyField |
ckdGetKeyFieldCount |
ckdGetKeyFieldDescriptorClass |
Create |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
IsValidFor |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddT | This is the overview for the AddT method overload.
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls | TnxBaseKeyDescriptor
CanContainNulls |
CheckValid |
Clear | Clears the list of Key Field Descriptors.
Delete | This function deletes a descriptor from the list of processed Key Field Descriptors.
Destroy |
Destroy | public comes before protected to fix problem with BCB destructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
Insert | This is the overview for the Insert method overload.
InsertT | This is the overview for the InsertT method overload.
IsEqual |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
Move | Moves a Key Field Descriptor in the list of descriptors from aFrom to the aTo position
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyFieldCount | This property returns the number of items in the Key Field descriptor List.
KeyFields | This property return the Key Field descriptor with the given index out of the Key Field Descriptor list.
KeyLen | This property returns the length of the created keys.
Links
TnxNoNullCompKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxNoNullCompKeyDescriptor Methods

TnxNoNullCompKeyDescriptor Methods
TnxNoNullCompKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNoNullCompKeyDescriptor class are listed here.

Class

TnxNoNullCompKeyDescriptor Class

Protected Methods
Name | Description
bkdGetKeyLen | TnxNoNullCompKeyDescriptor
Public Methods
Name | Description
CheckValid |
LoadFromReader |
SaveToWriter |
Links
TnxNoNullCompKeyDescriptor Class, Legend, Protected Methods, Public Methods


TnxNoNullCompKeyDescriptor.bkdGetKeyLen Method

TnxNoNullCompKeyDescriptor.bkdGetKeyLen Method
TnxNoNullCompKeyDescriptor Class TnxNoNullCompKeyDescriptor Members nxsdDataDictionary Namespace TnxNoNullCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; override;
Description

TnxNoNullCompKeyDescriptor

Group

TnxNoNullCompKeyDescriptor Methods

Links
TnxNoNullCompKeyDescriptor Class, TnxNoNullCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxNoNullCompKeyDescriptor Methods


TnxNoNullCompKeyDescriptor.CheckValid Method

TnxNoNullCompKeyDescriptor.CheckValid Method
TnxNoNullCompKeyDescriptor Class TnxNoNullCompKeyDescriptor Members nxsdDataDictionary Namespace TnxNoNullCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxNoNullCompKeyDescriptor Methods

Links
TnxNoNullCompKeyDescriptor Class, TnxNoNullCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxNoNullCompKeyDescriptor Methods


TnxNoNullCompKeyDescriptor.LoadFromReader Method

TnxNoNullCompKeyDescriptor.LoadFromReader Method
TnxNoNullCompKeyDescriptor Class TnxNoNullCompKeyDescriptor Members nxsdDataDictionary Namespace TnxNoNullCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxNoNullCompKeyDescriptor Methods

Links
TnxNoNullCompKeyDescriptor Class, TnxNoNullCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxNoNullCompKeyDescriptor Methods


TnxNoNullCompKeyDescriptor.SaveToWriter Method

TnxNoNullCompKeyDescriptor.SaveToWriter Method
TnxNoNullCompKeyDescriptor Class TnxNoNullCompKeyDescriptor Members nxsdDataDictionary Namespace TnxNoNullCompKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxNoNullCompKeyDescriptor Methods

Links
TnxNoNullCompKeyDescriptor Class, TnxNoNullCompKeyDescriptor Members, nxsdDataDictionary Namespace, TnxNoNullCompKeyDescriptor Methods


TnxRefKeyDescriptor Class

TnxRefKeyDescriptor Class
TnxRefKeyDescriptor Methods TnxRefKeyDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptornxsdDataDictionary_TnxRefKeyDescriptor
Syntax
Delphi
TnxRefKeyDescriptor = class(TnxBaseKeyDescriptor);
File

nxsdDataDictionary

Description

This Key Descriptor returns the internal id of the record as Key. It is used for the Sequential Access Index.

Group

Classes

Links
TnxRefKeyDescriptor Methods, TnxRefKeyDescriptor Members, nxsdDataDictionary, Classes


TnxRefKeyDescriptor Members

TnxRefKeyDescriptor Members
TnxRefKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRefKeyDescriptor.

Class

TnxRefKeyDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bkdGetKeyLen | TnxRefKeyDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyLen | This property returns the length of the created keys.
Links
TnxRefKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxRefKeyDescriptor Methods

TnxRefKeyDescriptor Methods
TnxRefKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRefKeyDescriptor class are listed here.

Class

TnxRefKeyDescriptor Class

Protected Methods
Name | Description
bkdGetKeyLen | TnxRefKeyDescriptor
Public Methods
Name | Description
CanContainNulls |
LoadFromReader |
SaveToWriter |
Links
TnxRefKeyDescriptor Class, Legend, Protected Methods, Public Methods


TnxRefKeyDescriptor.bkdGetKeyLen Method

TnxRefKeyDescriptor.bkdGetKeyLen Method
TnxRefKeyDescriptor Class TnxRefKeyDescriptor Members nxsdDataDictionary Namespace TnxRefKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; override;
Description

TnxRefKeyDescriptor

Group

TnxRefKeyDescriptor Methods

Links
TnxRefKeyDescriptor Class, TnxRefKeyDescriptor Members, nxsdDataDictionary Namespace, TnxRefKeyDescriptor Methods


TnxRefKeyDescriptor.CanContainNulls Method

TnxRefKeyDescriptor.CanContainNulls Method
TnxRefKeyDescriptor Class TnxRefKeyDescriptor Members nxsdDataDictionary Namespace TnxRefKeyDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; override;
Group

TnxRefKeyDescriptor Methods

Links
TnxRefKeyDescriptor Class, TnxRefKeyDescriptor Members, nxsdDataDictionary Namespace, TnxRefKeyDescriptor Methods


TnxRefKeyDescriptor.LoadFromReader Method

TnxRefKeyDescriptor.LoadFromReader Method
TnxRefKeyDescriptor Class TnxRefKeyDescriptor Members nxsdDataDictionary Namespace TnxRefKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxRefKeyDescriptor Methods

Links
TnxRefKeyDescriptor Class, TnxRefKeyDescriptor Members, nxsdDataDictionary Namespace, TnxRefKeyDescriptor Methods


TnxRefKeyDescriptor.SaveToWriter Method

TnxRefKeyDescriptor.SaveToWriter Method
TnxRefKeyDescriptor Class TnxRefKeyDescriptor Members nxsdDataDictionary Namespace TnxRefKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxRefKeyDescriptor Methods

Links
TnxRefKeyDescriptor Class, TnxRefKeyDescriptor Members, nxsdDataDictionary Namespace, TnxRefKeyDescriptor Methods


TnxSqlCheckValidationDescriptor Class

TnxSqlCheckValidationDescriptor Class
TnxSqlCheckValidationDescriptor Fields TnxSqlCheckValidationDescriptor Methods TnxSqlCheckValidationDescriptor Properties TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptornxsdDataDictionary_TnxSqlCheckValidationDescriptor
Syntax
Delphi
TnxSqlCheckValidationDescriptor = class(TnxBaseFieldsValidationDescriptor);
File

nxsdDataDictionary

Description

A validation descriptor implementing SQL constraints.

Group

Classes

Links
TnxSqlCheckValidationDescriptor Fields, TnxSqlCheckValidationDescriptor Methods, TnxSqlCheckValidationDescriptor Properties, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary, Classes


TnxSqlCheckValidationDescriptor Members

TnxSqlCheckValidationDescriptor Members
TnxSqlCheckValidationDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlCheckValidationDescriptor.

Class

TnxSqlCheckValidationDescriptor Class

Protected Fields
Name | Description
bvdApplyAt | This is bvdApplyAt, a member of class TnxBaseFieldValidationDescriptor.
bvdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
scvdConstraint | private
scvdErrorMessage | This is scvdErrorMessage, a member of class TnxSqlCheckValidationDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
bvdGetApplyAt | TnxSqlCheckValidationDescriptor
bvdGetInvalidFieldTypes |
bvdSetApplyAt |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
scvdSetConstraint |
scvdSetErrorMessage |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetInvalidFieldTypes |
GetLifetimeMontior |
GetList | Returns the internal List of Validation Descriptor classes.
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ApplyAt | Defines if the validation should be done at client and/or server side.
Constraint | The SQL source of the constraint.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
ErrorMessage | The readable error message for this contraint.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Name | Name of the Validation.
Links
TnxSqlCheckValidationDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSqlCheckValidationDescriptor Fields

TnxSqlCheckValidationDescriptor Fields
TnxSqlCheckValidationDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxSqlCheckValidationDescriptor class are listed here.

Class

TnxSqlCheckValidationDescriptor Class

Protected Fields
Name | Description
scvdConstraint | private
scvdErrorMessage | This is scvdErrorMessage, a member of class TnxSqlCheckValidationDescriptor.
Links
TnxSqlCheckValidationDescriptor Class, Legend, Protected Fields


TnxSqlCheckValidationDescriptor.scvdConstraint Field

TnxSqlCheckValidationDescriptor.scvdConstraint Field
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Fields Send Feedback
Syntax
Delphi
scvdConstraint: WideString;
Description

private

Group

TnxSqlCheckValidationDescriptor Fields

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Fields


TnxSqlCheckValidationDescriptor.scvdErrorMessage Field

TnxSqlCheckValidationDescriptor.scvdErrorMessage Field
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Fields Send Feedback
Syntax
Delphi
scvdErrorMessage: string;
Description

This is scvdErrorMessage, a member of class TnxSqlCheckValidationDescriptor.

Group

TnxSqlCheckValidationDescriptor Fields

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Fields


TnxSqlCheckValidationDescriptor Methods

TnxSqlCheckValidationDescriptor Methods
TnxSqlCheckValidationDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSqlCheckValidationDescriptor class are listed here.

Class

TnxSqlCheckValidationDescriptor Class

Protected Methods
Name | Description
bvdGetApplyAt | TnxSqlCheckValidationDescriptor
bvdSetApplyAt |
scvdSetConstraint |
scvdSetErrorMessage |
Public Methods
Name | Description
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxSqlCheckValidationDescriptor Class, Legend, Protected Methods, Public Methods


TnxSqlCheckValidationDescriptor.bvdGetApplyAt Method

TnxSqlCheckValidationDescriptor.bvdGetApplyAt Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
function bvdGetApplyAt: TnxApplyAtSet; override;
Description

TnxSqlCheckValidationDescriptor

Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.bvdSetApplyAt Method

TnxSqlCheckValidationDescriptor.bvdSetApplyAt Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure bvdSetApplyAt(const Value: TnxApplyAtSet); override;
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.IsEqual Method

TnxSqlCheckValidationDescriptor.IsEqual Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.LoadFromReader Method

TnxSqlCheckValidationDescriptor.LoadFromReader Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.SaveToWriter Method

TnxSqlCheckValidationDescriptor.SaveToWriter Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.scvdSetConstraint Method

TnxSqlCheckValidationDescriptor.scvdSetConstraint Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure scvdSetConstraint(const Value: WideString);
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor.scvdSetErrorMessage Method

TnxSqlCheckValidationDescriptor.scvdSetErrorMessage Method
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Methods Send Feedback
Syntax
Delphi
procedure scvdSetErrorMessage(const Value: string);
Group

TnxSqlCheckValidationDescriptor Methods

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Methods


TnxSqlCheckValidationDescriptor Properties

TnxSqlCheckValidationDescriptor Properties
TnxSqlCheckValidationDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxSqlCheckValidationDescriptor class are listed here.

Class

TnxSqlCheckValidationDescriptor Class

Public Properties
Name | Description
Constraint | The SQL source of the constraint.
ErrorMessage | The readable error message for this contraint.
Links
TnxSqlCheckValidationDescriptor Class, Legend, Public Properties


TnxSqlCheckValidationDescriptor.Constraint Property

TnxSqlCheckValidationDescriptor.Constraint Property
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Properties Send Feedback
Syntax
Delphi
property Constraint: WideString;
Description

The SQL source of the constraint.

Group

TnxSqlCheckValidationDescriptor Properties

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Properties


TnxSqlCheckValidationDescriptor.ErrorMessage Property

TnxSqlCheckValidationDescriptor.ErrorMessage Property
TnxSqlCheckValidationDescriptor Class TnxSqlCheckValidationDescriptor Members nxsdDataDictionary Namespace TnxSqlCheckValidationDescriptor Properties Send Feedback
Syntax
Delphi
property ErrorMessage: string;
Description

The readable error message for this contraint.

Group

TnxSqlCheckValidationDescriptor Properties

Links
TnxSqlCheckValidationDescriptor Class, TnxSqlCheckValidationDescriptor Members, nxsdDataDictionary Namespace, TnxSqlCheckValidationDescriptor Properties


TnxTablesDescriptor Class

TnxTablesDescriptor Class
TnxTablesDescriptor Fields TnxTablesDescriptor Methods TnxTablesDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxTablesDescriptornxsdDataDictionary_TnxTablesDescriptornxsdDataDictionary_TnxTablesDescriptornxsdDataDictionary_TnxTablesDescriptornxsdDataDictionary_TnxTablesDescriptornxsdDataDictionary_TnxTablesDescriptor
Syntax
Delphi
TnxTablesDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionary

Description

Holds a list (main) of named Table Descriptors.

Group

Classes

Links
TnxTablesDescriptor Fields, TnxTablesDescriptor Methods, TnxTablesDescriptor Members, nxsdDataDictionary, Classes


TnxTablesDescriptor Members

TnxTablesDescriptor Members
TnxTablesDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTablesDescriptor.

Class

TnxTablesDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
TableCount | The number Table Descriptors for this table.
TableDescriptor | fields are public for speed reasons The Table Descriptors defined for this table.
Public Methods
Name | Description
AddTable | This function adds a new instance of a Table Descriptor to the data dictionary and returns the newly created Instance.
AddTableT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear | This function clears the Table Descriptors Descriptor.
Create | constructor.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
GetTableDescriptorFromName | Returns the Table descriptor with the given aName.
GetTableIndexFromName | Return the Table number for a given Table name, or -1 if not found.
GetTables | Returns a list of names of Table descriptors.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveTable | This is the overview for the RemoveTable method overload.
RenameTable | Renames an existing Table Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxTablesDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxTablesDescriptor.Create Constructor

TnxTablesDescriptor.Create Constructor
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

constructor.

Class

TnxTablesDescriptor Class

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Class


TnxTablesDescriptor.Destroy Destructor

TnxTablesDescriptor.Destroy Destructor
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxTablesDescriptor Class

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Class


TnxTablesDescriptor Fields

TnxTablesDescriptor Fields
TnxTablesDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxTablesDescriptor class are listed here.

Class

TnxTablesDescriptor Class

Public Fields
Name | Description
TableCount | The number Table Descriptors for this table.
TableDescriptor | fields are public for speed reasons The Table Descriptors defined for this table.
Links
TnxTablesDescriptor Class, Legend, Public Fields


TnxTablesDescriptor.TableCount Field

TnxTablesDescriptor.TableCount Field
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Fields Send Feedback
Syntax
Delphi
TableCount: Integer;
Description

The number Table Descriptors for this table.

Group

TnxTablesDescriptor Fields

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Fields


TnxTablesDescriptor.TableDescriptor Field

TnxTablesDescriptor.TableDescriptor Field
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Fields Send Feedback
Syntax
Delphi
TableDescriptor: array of TnxNestedTableDescriptor;
Description

fields are public for speed reasons The Table Descriptors defined for this table.

Group

TnxTablesDescriptor Fields

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Fields


TnxTablesDescriptor Methods

TnxTablesDescriptor Methods
TnxTablesDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTablesDescriptor class are listed here.

Class

TnxTablesDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
AddTable | This function adds a new instance of a Table Descriptor to the data dictionary and returns the newly created Instance.
AddTableT |
CheckValid |
Clear | This function clears the Table Descriptors Descriptor.
GetTableDescriptorFromName | Returns the Table descriptor with the given aName.
GetTableIndexFromName | Return the Table number for a given Table name, or -1 if not found.
GetTables | Returns a list of names of Table descriptors.
IsEqual |
LoadFromReader |
RemoveTable | This is the overview for the RemoveTable method overload.
RenameTable | Renames an existing Table Descriptor.
SaveToWriter |
Links
TnxTablesDescriptor Class, Legend, Protected Methods, Public Methods


TnxTablesDescriptor.AddTable Method

TnxTablesDescriptor.AddTable Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
function AddTable(const aName: string; aClass: TnxNestedTableDescriptorClass = nil): TnxNestedTableDescriptor;
Parameters
Parameters | Description
const aName: string | the name of the Table Descriptor
aClass: TnxNestedTableDescriptorClass = nil | the class of the instance to be created. TnxTablesDescriptor
Description

This function adds a new instance of a Table Descriptor to the data dictionary and returns the newly created Instance.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.AddTableT Method

TnxTablesDescriptor.AddTableT Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
function AddTableT<T: TnxNestedTableDescriptor>(const aName: string): T;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.CheckValid Method

TnxTablesDescriptor.CheckValid Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.Clear Method

TnxTablesDescriptor.Clear Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Description

This function clears the Table Descriptors Descriptor.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.GetList Method

TnxTablesDescriptor.GetList Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.GetTableDescriptorFromName Method

TnxTablesDescriptor.GetTableDescriptorFromName Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
function GetTableDescriptorFromName(const aName: string): TnxNestedTableDescriptor;
Description

Returns the Table descriptor with the given aName.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.GetTableIndexFromName Method

TnxTablesDescriptor.GetTableIndexFromName Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
function GetTableIndexFromName(const aName: string): Integer;
Description

Return the Table number for a given Table name, or -1 if not found.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.GetTables Method

TnxTablesDescriptor.GetTables Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure GetTables(aStrings: TStrings);
Description

Returns a list of names of Table descriptors.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.IsEqual Method

TnxTablesDescriptor.IsEqual Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.LoadFromReader Method

TnxTablesDescriptor.LoadFromReader Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


RemoveTable Method

RemoveTable Method
TnxTablesDescriptor Methods Send Feedback

This is the overview for the RemoveTable method overload.

Overload List
Name | Description
TnxTablesDescriptor.RemoveTable (Integer) | Remove a Table Descriptor from the Data Dictionary.
TnxTablesDescriptor.RemoveTable (string) | Remove a Table Descriptor from the Data Dictionary.
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Methods


TnxTablesDescriptor.RemoveTable Method (Integer)

TnxTablesDescriptor.RemoveTable Method (Integer)
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace RemoveTable Method Send Feedback
Syntax
Delphi
procedure RemoveTable(aInx: Integer); overload;
Parameters
Parameters | Description
aInx: Integer | the index of the descriptor to be removed in the list of Table Descriptors.
Description

Remove a Table Descriptor from the Data Dictionary.

Group

RemoveTable Method

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, RemoveTable Method


TnxTablesDescriptor.RemoveTable Method (string)

TnxTablesDescriptor.RemoveTable Method (string)
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace RemoveTable Method Send Feedback
Syntax
Delphi
procedure RemoveTable(const aName: string); overload;
Parameters
Parameters | Description
const aName: string | the name of the descriptor to be removed.
Description

Remove a Table Descriptor from the Data Dictionary.

Group

RemoveTable Method

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, RemoveTable Method


TnxTablesDescriptor.RenameTable Method

TnxTablesDescriptor.RenameTable Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure RenameTable(const aOldName: string; const aNewName: string); overload;
Parameters
Parameters | Description
const aOldName: string | the name of the descriptor to be renamed.
const aNewName: string | the new name of the descriptor.
Description

Renames an existing Table Descriptor.

Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTablesDescriptor.SaveToWriter Method

TnxTablesDescriptor.SaveToWriter Method
TnxTablesDescriptor Class TnxTablesDescriptor Members nxsdDataDictionary Namespace TnxTablesDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTablesDescriptor Methods

Links
TnxTablesDescriptor Class, TnxTablesDescriptor Members, nxsdDataDictionary Namespace, TnxTablesDescriptor Methods


TnxTextKeyFieldDescriptor Class

TnxTextKeyFieldDescriptor Class
TnxTextKeyFieldDescriptor Fields TnxTextKeyFieldDescriptor Methods TnxTextKeyFieldDescriptor Properties TnxTextKeyFieldDescriptor Members nxsdDataDictionary Classes Send Feedback
Class Hierarchy
nxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptornxsdDataDictionary_TnxTextKeyFieldDescriptor
Syntax
Delphi
TnxTextKeyFieldDescriptor = class(TnxKeyFieldDescriptor);
File

nxsdDataDictionary

Description

This is a simple Text field version of Key Field descriptor.

Group

Classes

Links
TnxTextKeyFieldDescriptor Fields, TnxTextKeyFieldDescriptor Methods, TnxTextKeyFieldDescriptor Properties, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary, Classes


TnxTextKeyFieldDescriptor Members

TnxTextKeyFieldDescriptor Members
TnxTextKeyFieldDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTextKeyFieldDescriptor.

Class

TnxTextKeyFieldDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
kfdAscend | ..0=descending keys; 1=ascending keys.
kfdDesc | ..description of key field.
kfdFieldNumber | ..field number.
kfdKeyFieldEngine | ..name of the key field engine.
kfdNullBehaviour | This is kfdNullBehaviour, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthBytes | This is kfdOverrideLengthBytes, a member of class TnxKeyFieldDescriptor.
kfdOverrideLengthChars | This is kfdOverrideLengthChars, a member of class TnxKeyFieldDescriptor.
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
tkfIgnoreCase | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFieldChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diRequiresPack |
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
kfdGetField |
kfdGetKeyChars |
kfdGetKeyLength |
kfdSetFieldNumber |
kfdSetOverrideLengthBytes |
kfdSetOverrideLengthChars |
ldiGetUsedLocaleDescriptor |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls | TnxKeyFieldDescriptor
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
CheckValid |
Destroy | destructor.
Destroy |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | TnxTextKeyFieldDescriptor
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
Ascend | If true the keys should be sorted ascending otherwise descending.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Desc | Used to store the description for this descriptor.
Field | This is a pointer to the associated Field descriptor.
FieldNumber | This property returns the index of the associated field in the field list of the Data Dictionary.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IgnoreCase | Set this to true if the sorting should not be case sensitive.
KeyChars | Returns the number of chars in tke key
KeyFieldEngine | The name of the Key Field Engine to create the Keys for each field.
KeyLength | Returns the length of the key
LocaleDescriptor | This property returns the associated Locale Descriptor.
NullBehaviour | defines what happens with NULLs in the key.
OverrideLengthBytes | Restricts the number of bytes used for the key generation. The index key will be built with this number of bytes only, irrespective of the actual field length. Applies to nxtWideString and nxtByteArray only! Use OverrideLengthChars for character based fields.
OverrideLengthChars | Restricts the number of chars used for the key generation. The index key will be built with this number of chars only, irrespective of the actual field length. Applies to nxtShortString and nxtNullString only! Use OverrideLengthBytes for byte based fields.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxTextKeyFieldDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTextKeyFieldDescriptor Fields

TnxTextKeyFieldDescriptor Fields
TnxTextKeyFieldDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxTextKeyFieldDescriptor class are listed here.

Class

TnxTextKeyFieldDescriptor Class

Protected Fields
Name | Description
tkfIgnoreCase | private
Links
TnxTextKeyFieldDescriptor Class, Legend, Protected Fields


TnxTextKeyFieldDescriptor.tkfIgnoreCase Field

TnxTextKeyFieldDescriptor.tkfIgnoreCase Field
TnxTextKeyFieldDescriptor Class TnxTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxTextKeyFieldDescriptor Fields Send Feedback
Syntax
Delphi
tkfIgnoreCase: Boolean;
Description

private

Group

TnxTextKeyFieldDescriptor Fields

Links
TnxTextKeyFieldDescriptor Class, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxTextKeyFieldDescriptor Fields


TnxTextKeyFieldDescriptor Methods

TnxTextKeyFieldDescriptor Methods
TnxTextKeyFieldDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxTextKeyFieldDescriptor class are listed here.

Class

TnxTextKeyFieldDescriptor Class

Public Methods
Name | Description
IsEqual | TnxTextKeyFieldDescriptor
LoadFromReader |
SaveToWriter |
Links
TnxTextKeyFieldDescriptor Class, Legend, Public Methods


TnxTextKeyFieldDescriptor.IsEqual Method

TnxTextKeyFieldDescriptor.IsEqual Method
TnxTextKeyFieldDescriptor Class TnxTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxTextKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Description

TnxTextKeyFieldDescriptor

Group

TnxTextKeyFieldDescriptor Methods

Links
TnxTextKeyFieldDescriptor Class, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxTextKeyFieldDescriptor Methods


TnxTextKeyFieldDescriptor.LoadFromReader Method

TnxTextKeyFieldDescriptor.LoadFromReader Method
TnxTextKeyFieldDescriptor Class TnxTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxTextKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTextKeyFieldDescriptor Methods

Links
TnxTextKeyFieldDescriptor Class, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxTextKeyFieldDescriptor Methods


TnxTextKeyFieldDescriptor.SaveToWriter Method

TnxTextKeyFieldDescriptor.SaveToWriter Method
TnxTextKeyFieldDescriptor Class TnxTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxTextKeyFieldDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTextKeyFieldDescriptor Methods

Links
TnxTextKeyFieldDescriptor Class, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxTextKeyFieldDescriptor Methods


TnxTextKeyFieldDescriptor Properties

TnxTextKeyFieldDescriptor Properties
TnxTextKeyFieldDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxTextKeyFieldDescriptor class are listed here.

Class

TnxTextKeyFieldDescriptor Class

Public Properties
Name | Description
IgnoreCase | Set this to true if the sorting should not be case sensitive.
Links
TnxTextKeyFieldDescriptor Class, Legend, Public Properties


TnxTextKeyFieldDescriptor.IgnoreCase Property

TnxTextKeyFieldDescriptor.IgnoreCase Property
TnxTextKeyFieldDescriptor Class TnxTextKeyFieldDescriptor Members nxsdDataDictionary Namespace TnxTextKeyFieldDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreCase: Boolean;
Description

Set this to true if the sorting should not be case sensitive.

Group

TnxTextKeyFieldDescriptor Properties

Links
TnxTextKeyFieldDescriptor Class, TnxTextKeyFieldDescriptor Members, nxsdDataDictionary Namespace, TnxTextKeyFieldDescriptor Properties


Interfaces

Interfaces
nxsdDataDictionary Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxsdDataDictionary Namespace

Interfaces
Name | Description
InxFieldDescriptor | DOM-IGNORE-BEGIN documented in implementing classes.
InxFieldsAccess | This is class nxsdDataDictionary.InxFieldsAccess.
InxFieldsSource | DOM-IGNORE-BEGIN documented in implementing classes.
Links
nxsdDataDictionary Namespace, Interfaces, Legend


InxFieldDescriptor Interface

InxFieldDescriptor Interface
InxFieldDescriptor Methods InxFieldDescriptor Properties InxFieldDescriptor Members nxsdDataDictionary Interfaces Send Feedback
Class Hierarchy
nxsdDataDictionary_InxFieldDescriptor
Syntax
Delphi
InxFieldDescriptor = interface(InxInterface);
File

nxsdDataDictionary

Description

DOM-IGNORE-BEGIN documented in implementing classes.

Group

Interfaces

Links
InxFieldDescriptor Methods, InxFieldDescriptor Properties, InxFieldDescriptor Members, nxsdDataDictionary, Interfaces


InxFieldDescriptor Members

InxFieldDescriptor Members
InxFieldDescriptor Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxFieldDescriptor.

Interface

InxFieldDescriptor Interface

Public Methods
Name | Description
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
Links
InxFieldDescriptor Interface, Legend, Public Methods, Public Properties


InxFieldDescriptor Methods

InxFieldDescriptor Methods
InxFieldDescriptor Interface Legend Public Methods Send Feedback

The methods of the InxFieldDescriptor class are listed here.

Interface

InxFieldDescriptor Interface

Public Methods
Name | Description
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
Links
InxFieldDescriptor Interface, Legend, Public Methods


InxFieldDescriptor.GetFieldDecPl Method

InxFieldDescriptor.GetFieldDecPl Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldDecPl: Integer;
Description

This is GetFieldDecPl, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor.GetFieldName Method

InxFieldDescriptor.GetFieldName Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldName: string;
Description

This is GetFieldName, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor.GetFieldType Method

InxFieldDescriptor.GetFieldType Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldType: TnxFieldType;
Description

This is GetFieldType, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor.GetFieldUnits Method

InxFieldDescriptor.GetFieldUnits Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function GetFieldUnits: Integer;
Description

This is GetFieldUnits, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor.ldiGetUsedStorageCodePage Method

InxFieldDescriptor.ldiGetUsedStorageCodePage Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function ldiGetUsedStorageCodePage: Word;
Description

This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor.ldiOuterGetUsedLocaleDescriptor Method

InxFieldDescriptor.ldiOuterGetUsedLocaleDescriptor Method
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Methods Send Feedback
Syntax
Delphi
function ldiOuterGetUsedLocaleDescriptor: TnxLocaleDescriptor;
Description

This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Methods

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Methods


InxFieldDescriptor Properties

InxFieldDescriptor Properties
InxFieldDescriptor Interface Legend Public Properties Send Feedback

The properties of the InxFieldDescriptor class are listed here.

Interface

InxFieldDescriptor Interface

Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
Links
InxFieldDescriptor Interface, Legend, Public Properties


InxFieldDescriptor.FieldDecPl Property

InxFieldDescriptor.FieldDecPl Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldDecPl: Integer;
Description

This is FieldDecPl, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldDescriptor.FieldName Property

InxFieldDescriptor.FieldName Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldName: string;
Description

This is FieldName, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldDescriptor.FieldType Property

InxFieldDescriptor.FieldType Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldType: TnxFieldType;
Description

This is FieldType, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldDescriptor.FieldUnits Property

InxFieldDescriptor.FieldUnits Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldUnits: Integer;
Description

This is FieldUnits, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldDescriptor.FieldUsedLocaleDescriptor Property

InxFieldDescriptor.FieldUsedLocaleDescriptor Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldUsedLocaleDescriptor: TnxLocaleDescriptor;
Description

This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldDescriptor.FieldUsedStorageCodePage Property

InxFieldDescriptor.FieldUsedStorageCodePage Property
InxFieldDescriptor Interface InxFieldDescriptor Members nxsdDataDictionary Namespace InxFieldDescriptor Properties Send Feedback
Syntax
Delphi
property FieldUsedStorageCodePage: Word;
Description

This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.

Group

InxFieldDescriptor Properties

Links
InxFieldDescriptor Interface, InxFieldDescriptor Members, nxsdDataDictionary Namespace, InxFieldDescriptor Properties


InxFieldsAccess Interface

InxFieldsAccess Interface
InxFieldsAccess Methods InxFieldsAccess Properties InxFieldsAccess Members nxsdDataDictionary Interfaces Send Feedback
Class Hierarchy
nxsdDataDictionary_InxFieldsAccessnxsdDataDictionary_InxFieldsAccess
Syntax
Delphi
InxFieldsAccess = interface(InxFieldsSource);
File

nxsdDataDictionary

Description

This is class nxsdDataDictionary.InxFieldsAccess.

Group

Interfaces

Links
InxFieldsAccess Methods, InxFieldsAccess Properties, InxFieldsAccess Members, nxsdDataDictionary, Interfaces


InxFieldsAccess Members

InxFieldsAccess Members
InxFieldsAccess Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxFieldsAccess.

Interface

InxFieldsAccess Interface

Public Methods
Name | Description
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
SetFieldAsVariant | This is SetFieldAsVariant, a member of class InxFieldsAccess.
Public Properties
Name | Description
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsAccess.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
Links
InxFieldsAccess Interface, Legend, Public Methods, Public Properties


InxFieldsAccess Methods

InxFieldsAccess Methods
InxFieldsAccess Interface Legend Public Methods Send Feedback

The methods of the InxFieldsAccess class are listed here.

Interface

InxFieldsAccess Interface

Public Methods
Name | Description
SetFieldAsVariant | This is SetFieldAsVariant, a member of class InxFieldsAccess.
Links
InxFieldsAccess Interface, Legend, Public Methods


InxFieldsAccess.SetFieldAsVariant Method

InxFieldsAccess.SetFieldAsVariant Method
InxFieldsAccess Interface InxFieldsAccess Members nxsdDataDictionary Namespace InxFieldsAccess Methods Send Feedback
Syntax
Delphi
procedure SetFieldAsVariant(aBuffer: PnxByteArray; aField: Integer; const aValue: OleVariant);
Description

This is SetFieldAsVariant, a member of class InxFieldsAccess.

Group

InxFieldsAccess Methods

Links
InxFieldsAccess Interface, InxFieldsAccess Members, nxsdDataDictionary Namespace, InxFieldsAccess Methods


InxFieldsAccess Properties

InxFieldsAccess Properties
InxFieldsAccess Interface Legend Public Properties Send Feedback

The properties of the InxFieldsAccess class are listed here.

Interface

InxFieldsAccess Interface

Public Properties
Name | Description
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsAccess.
Links
InxFieldsAccess Interface, Legend, Public Properties


InxFieldsAccess.FieldAsVariant Property

InxFieldsAccess.FieldAsVariant Property
InxFieldsAccess Interface InxFieldsAccess Members nxsdDataDictionary Namespace InxFieldsAccess Properties Send Feedback
Syntax
Delphi
property FieldAsVariant [aBuffer : PnxByteArray; aField : Integer]: OleVariant;
Description

This is FieldAsVariant, a member of class InxFieldsAccess.

Group

InxFieldsAccess Properties

Links
InxFieldsAccess Interface, InxFieldsAccess Members, nxsdDataDictionary Namespace, InxFieldsAccess Properties


InxFieldsSource Interface

InxFieldsSource Interface
InxFieldsSource Methods InxFieldsSource Properties InxFieldsSource Members nxsdDataDictionary Interfaces Send Feedback
Class Hierarchy
nxsdDataDictionary_InxFieldsSource
Syntax
Delphi
InxFieldsSource = interface(InxInterface);
File

nxsdDataDictionary

Description

DOM-IGNORE-BEGIN documented in implementing classes.

Group

Interfaces

Links
InxFieldsSource Methods, InxFieldsSource Properties, InxFieldsSource Members, nxsdDataDictionary, Interfaces


InxFieldsSource Members

InxFieldsSource Members
InxFieldsSource Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxFieldsSource.

Interface

InxFieldsSource Interface

Public Methods
Name | Description
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
Public Properties
Name | Description
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
Links
InxFieldsSource Interface, Legend, Public Methods, Public Properties


InxFieldsSource Methods

InxFieldsSource Methods
InxFieldsSource Interface Legend Public Methods Send Feedback

The methods of the InxFieldsSource class are listed here.

Interface

InxFieldsSource Interface

Public Methods
Name | Description
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
Links
InxFieldsSource Interface, Legend, Public Methods


InxFieldsSource.BlobsSupported Method

InxFieldsSource.BlobsSupported Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function BlobsSupported: Boolean;
Description

This is BlobsSupported, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetCursor Method

InxFieldsSource.GetCursor Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetCursor: TObject;
Description

This is GetCursor, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldAsVariant Method

InxFieldsSource.GetFieldAsVariant Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldAsVariant(aBuffer: PnxByteArray; aField: Integer): OleVariant;
Description

This is GetFieldAsVariant, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldCount Method

InxFieldsSource.GetFieldCount Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer;
Description

This is GetFieldCount, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldDescriptor Method

InxFieldsSource.GetFieldDescriptor Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor;
Description

This is GetFieldDescriptor, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldForFilter Method

InxFieldsSource.GetFieldForFilter Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aData: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean;
Description

This is GetFieldForFilter, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldFromName Method

InxFieldsSource.GetFieldFromName Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer;
Description

This is GetFieldFromName, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource.GetFieldsOffset Method

InxFieldsSource.GetFieldsOffset Method
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Methods Send Feedback
Syntax
Delphi
function GetFieldsOffset: integer;
Description

This is GetFieldsOffset, a member of class InxFieldsSource.

Group

InxFieldsSource Methods

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Methods


InxFieldsSource Properties

InxFieldsSource Properties
InxFieldsSource Interface Legend Public Properties Send Feedback

The properties of the InxFieldsSource class are listed here.

Interface

InxFieldsSource Interface

Public Properties
Name | Description
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
Links
InxFieldsSource Interface, Legend, Public Properties


InxFieldsSource.FieldAsVariant Property

InxFieldsSource.FieldAsVariant Property
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Properties Send Feedback
Syntax
Delphi
property FieldAsVariant [aBuffer : PnxByteArray; aField : Integer]: OleVariant;
Description

This is FieldAsVariant, a member of class InxFieldsSource.

Group

InxFieldsSource Properties

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Properties


InxFieldsSource.FieldCount Property

InxFieldsSource.FieldCount Property
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Properties Send Feedback
Syntax
Delphi
property FieldCount: Integer;
Description

This is FieldCount, a member of class InxFieldsSource.

Group

InxFieldsSource Properties

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Properties


InxFieldsSource.FieldDescriptor Property

InxFieldsSource.FieldDescriptor Property
InxFieldsSource Interface InxFieldsSource Members nxsdDataDictionary Namespace InxFieldsSource Properties Send Feedback
Syntax
Delphi
property FieldDescriptor [aIndex: Integer]: InxFieldDescriptor;
Description

This is FieldDescriptor, a member of class InxFieldsSource.

Group

InxFieldsSource Properties

Links
InxFieldsSource Interface, InxFieldsSource Members, nxsdDataDictionary Namespace, InxFieldsSource Properties


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdDataDictionary Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
Tnx1xFileType | File types for the data dictionary.
TnxApplyAt | Type used to indicate where a validation object should be applied.
TnxIndexDups | This is record nxsdDataDictionary.TnxIndexDups.
TnxIteratorResult | Result of an interator function.
TnxNullBehaviour | Type to define the Null behaviour of a key
Namespace

nxsdDataDictionary Namespace

Links
Enumerations, nxsdDataDictionary Namespace, Legend


nxsdDataDictionary.Tnx1xFileType Enumeration

nxsdDataDictionary.Tnx1xFileType Enumeration
nxsdDataDictionary Structs, Records, Enums Send Feedback
Syntax
Delphi
Tnx1xFileType = ( ftBaseFile, ftIndexFile, ftBlobFile );
File

nxsdDataDictionary

Members
Members | Description
ftBaseFile | ..base file: at least data & dictionary.
ftIndexFile | ..index file.
ftBlobFile | ..Blob file.
Description

File types for the data dictionary.

Group

Structs, Records, Enums

Links
nxsdDataDictionary, Structs, Records, Enums


nxsdDataDictionary.TnxApplyAt Enumeration

nxsdDataDictionary.TnxApplyAt Enumeration
nxsdDataDictionary Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxApplyAt = ( aaServer, aaClient );
File

nxsdDataDictionary

Members
Members | Description
aaServer | on the server
aaClient | on the client
Description

Type used to indicate where a validation object should be applied.

Group

Structs, Records, Enums

Links
nxsdDataDictionary, Structs, Records, Enums


nxsdDataDictionary.TnxIndexDups Enumeration

nxsdDataDictionary.TnxIndexDups Enumeration
nxsdDataDictionary Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIndexDups = ( idNone, idNull, idAll );
File

nxsdDataDictionary

Description

This is record nxsdDataDictionary.TnxIndexDups.

Group

Structs, Records, Enums

Links
nxsdDataDictionary, Structs, Records, Enums


nxsdDataDictionary.TnxIteratorResult Enumeration

nxsdDataDictionary.TnxIteratorResult Enumeration
nxsdDataDictionary Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIteratorResult = ( irContinue, irStop );
File

nxsdDataDictionary

Description

Result of an interator function.

Group

Structs, Records, Enums

Links
nxsdDataDictionary, Structs, Records, Enums


nxsdDataDictionary.TnxNullBehaviour Enumeration

nxsdDataDictionary.TnxNullBehaviour Enumeration
nxsdDataDictionary Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxNullBehaviour = ( nbTop, nbBottom, nbAsAscend, nbFilterNull, nbFilterNonNull );
File

nxsdDataDictionary

Members
Members | Description
nbTop | sort to top
nbBottom | sort to bottom
nbAsAscend | sort first if index is Ascending, last if Descending
nbFilterNull | dont include records that have NULL in a field in the index
nbFilterNonNull | only records with the NULL value in the field is included in the index
Description

Type to define the Null behaviour of a key

Group

Structs, Records, Enums

Links
nxsdDataDictionary, Structs, Records, Enums


Types

Types
nxsdDataDictionary Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdDataDictionary Namespace

Types
Name | Description
TnxApplyAtSet | Set of TnxApplyAt
TnxAutoIncStepRange | Valid Step sizes for TnxAdvAutoIncDescriptor.
TnxBaseAutoIncDescriptorClass | Class definition for AutoInc Descriptors.
TnxBaseBlobDescriptorClass | Class definition for Blob Descriptors.
TnxBaseBlockHeapDescriptorClass | Class definition for Block Heap Descriptors
TnxBaseCustomDescriptorClass | Class definition for Custom Descriptor
TnxBaseDefaultValueDescriptorClass | Class definition for TnxBaseDefaultValueDescriptor.
TnxBaseFieldsValidationDescriptorClass | Class definition for TnxBaseFieldsValidationDescriptor.
TnxBaseFieldValidationDescriptorClass | Class definition for TnxBaseFieldValidationDescriptor.
TnxBaseHeapDescriptorClass | Class definition for Heap Descriptors.
TnxBaseIndicesDescriptorClass | Class definition for the base class of Indices Descriptors.
TnxBaseRecordCompressionDescriptorClass | Class definition for Compression Descriptors
TnxBaseRecordDescriptorClass | Class definition for Record Descriptors
TnxBaseStreamDescriptorClass | Class definition for Stream Descriptors.
TnxBaseTableDescriptorClass | Class definition for base Table Descriptors.
TnxCustomDescsDescriptorClass | Class definition for Custom Descriptors.
TnxDictionaryItemClass | Class definition for dictionary items.
TnxDictionaryItemIterator | Definition for IterateReferencing event.
TnxDictionaryIterator | Defintion for dictionary iteration callbacks.
TnxFieldDescriptorClass | Class definition for Field Descriptors.
TnxFieldsDescriptorClass | Class definition for Fields Descriptors.
TnxFieldsValidationsDescriptorClass | Class of TnxFieldsValidationsDescriptor.
TnxFieldValidationsDescriptorClass | Class definition for Validation Descriptors.
TnxFileDescriptorClass | Class definition for File Descriptors
TnxFilesDescriptorClass | Class definition for Files Descriptors.
TnxHeapBlobDescriptorClass | Class definition for Heap Blob Descriptors.
TnxHeapRecordDescriptorClass | Class definition for Heap Record Descriptors.
TnxIndexDescriptorClass | Class definition for Index descriptors.
TnxKeyDescriptorClass | Class definition for Key descriptors.
TnxKeyFieldDescriptorClass | Class definition for Key Field descriptors.
TnxLocaleDescriptorClass | Class definition for TnxLocaleDescriptor.
TnxMainIndicesDescriptorClass | Class definition for the class of Main-Index Descriptors.
TnxNestedTableDescriptorClass | Class definition for Nested(Sub-) table Descriptors.
TnxTablesDescriptorClass | Class definition for (Main) Table Descriptors.
Links
nxsdDataDictionary Namespace, Types


nxsdDataDictionary.TnxApplyAtSet Type

nxsdDataDictionary.TnxApplyAtSet Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxApplyAtSet = set of TnxApplyAt;
File

nxsdDataDictionary

Description

Set of TnxApplyAt

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxAutoIncStepRange Type

nxsdDataDictionary.TnxAutoIncStepRange Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxAutoIncStepRange = 1..High(TnxWord32);
File

nxsdDataDictionary

Description

Valid Step sizes for TnxAdvAutoIncDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseAutoIncDescriptorClass Type

nxsdDataDictionary.TnxBaseAutoIncDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseAutoIncDescriptorClass = class of TnxBaseAutoIncDescriptor;
File

nxsdDataDictionary

Description

Class definition for AutoInc Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseBlobDescriptorClass Type

nxsdDataDictionary.TnxBaseBlobDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseBlobDescriptorClass = class of TnxBaseBlobDescriptor;
File

nxsdDataDictionary

Description

Class definition for Blob Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseBlockHeapDescriptorClass Type

nxsdDataDictionary.TnxBaseBlockHeapDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseBlockHeapDescriptorClass = class of TnxBaseBlockHeapDescriptor;
File

nxsdDataDictionary

Description

Class definition for Block Heap Descriptors

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseCustomDescriptorClass Type

nxsdDataDictionary.TnxBaseCustomDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseCustomDescriptorClass = class of TnxBaseCustomDescriptor;
File

nxsdDataDictionary

Description

Class definition for Custom Descriptor

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseDefaultValueDescriptorClass Type

nxsdDataDictionary.TnxBaseDefaultValueDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseDefaultValueDescriptorClass = class of TnxBaseDefaultValueDescriptor;
File

nxsdDataDictionary

Description

Class definition for TnxBaseDefaultValueDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseFieldsValidationDescriptorClass Type

nxsdDataDictionary.TnxBaseFieldsValidationDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseFieldsValidationDescriptorClass = class of TnxBaseFieldsValidationDescriptor;
File

nxsdDataDictionary

Description

Class definition for TnxBaseFieldsValidationDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseFieldValidationDescriptorClass Type

nxsdDataDictionary.TnxBaseFieldValidationDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseFieldValidationDescriptorClass = class of TnxBaseFieldValidationDescriptor;
File

nxsdDataDictionary

Description

Class definition for TnxBaseFieldValidationDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseHeapDescriptorClass Type

nxsdDataDictionary.TnxBaseHeapDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseHeapDescriptorClass = class of TnxBaseHeapDescriptor;
File

nxsdDataDictionary

Description

Class definition for Heap Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseIndicesDescriptorClass Type

nxsdDataDictionary.TnxBaseIndicesDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseIndicesDescriptorClass = class of TnxBaseIndicesDescriptor;
File

nxsdDataDictionary

Description

Class definition for the base class of Indices Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseRecordCompressionDescriptorClass Type

nxsdDataDictionary.TnxBaseRecordCompressionDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseRecordCompressionDescriptorClass = class of TnxBaseRecordCompressionDescriptor;
File

nxsdDataDictionary

Description

Class definition for Compression Descriptors

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseRecordDescriptorClass Type

nxsdDataDictionary.TnxBaseRecordDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseRecordDescriptorClass = class of TnxBaseRecordDescriptor;
File

nxsdDataDictionary

Description

Class definition for Record Descriptors

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseStreamDescriptorClass Type

nxsdDataDictionary.TnxBaseStreamDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseStreamDescriptorClass = class of TnxBaseStreamDescriptor;
File

nxsdDataDictionary

Description

Class definition for Stream Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxBaseTableDescriptorClass Type

nxsdDataDictionary.TnxBaseTableDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxBaseTableDescriptorClass = class of TnxBaseTableDescriptor;
File

nxsdDataDictionary

Description

Class definition for base Table Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxCustomDescsDescriptorClass Type

nxsdDataDictionary.TnxCustomDescsDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxCustomDescsDescriptorClass = class of TnxCustomDescsDescriptor;
File

nxsdDataDictionary

Description

Class definition for Custom Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxDictionaryItemClass Type

nxsdDataDictionary.TnxDictionaryItemClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxDictionaryItemClass = class of TnxDictionaryItem;
File

nxsdDataDictionary

Description

Class definition for dictionary items.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxDictionaryItemIterator Type

nxsdDataDictionary.TnxDictionaryItemIterator Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxDictionaryItemIterator = function (aItem: TnxDictionaryItem; aCookie: Pointer): TnxIteratorResult of object;
File

nxsdDataDictionary

Description

Definition for IterateReferencing event.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxDictionaryIterator Type

nxsdDataDictionary.TnxDictionaryIterator Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxDictionaryIterator = function (aDictionary: TnxDataDictionary; aCookie: Pointer): TnxIteratorResult of object;
File

nxsdDataDictionary

Description

Defintion for dictionary iteration callbacks.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFieldDescriptorClass Type

nxsdDataDictionary.TnxFieldDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFieldDescriptorClass = class of TnxFieldDescriptor;
File

nxsdDataDictionary

Description

Class definition for Field Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFieldsDescriptorClass Type

nxsdDataDictionary.TnxFieldsDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFieldsDescriptorClass = class of TnxFieldsDescriptor;
File

nxsdDataDictionary

Description

Class definition for Fields Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFieldsValidationsDescriptorClass Type

nxsdDataDictionary.TnxFieldsValidationsDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFieldsValidationsDescriptorClass = class of TnxFieldsValidationsDescriptor;
File

nxsdDataDictionary

Description

Class of TnxFieldsValidationsDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFieldValidationsDescriptorClass Type

nxsdDataDictionary.TnxFieldValidationsDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFieldValidationsDescriptorClass = class of TnxFieldValidationsDescriptor;
File

nxsdDataDictionary

Description

Class definition for Validation Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFileDescriptorClass Type

nxsdDataDictionary.TnxFileDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFileDescriptorClass = class of TnxFileDescriptor;
File

nxsdDataDictionary

Description

Class definition for File Descriptors

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxFilesDescriptorClass Type

nxsdDataDictionary.TnxFilesDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxFilesDescriptorClass = class of TnxFilesDescriptor;
File

nxsdDataDictionary

Description

Class definition for Files Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxHeapBlobDescriptorClass Type

nxsdDataDictionary.TnxHeapBlobDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxHeapBlobDescriptorClass = class of TnxHeapBlobDescriptor;
File

nxsdDataDictionary

Description

Class definition for Heap Blob Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxHeapRecordDescriptorClass Type

nxsdDataDictionary.TnxHeapRecordDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxHeapRecordDescriptorClass = class of TnxHeapRecordDescriptor;
File

nxsdDataDictionary

Description

Class definition for Heap Record Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxIndexDescriptorClass Type

nxsdDataDictionary.TnxIndexDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxIndexDescriptorClass = class of TnxIndexDescriptor;
File

nxsdDataDictionary

Description

Class definition for Index descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxKeyDescriptorClass Type

nxsdDataDictionary.TnxKeyDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxKeyDescriptorClass = class of TnxBaseKeyDescriptor;
File

nxsdDataDictionary

Description

Class definition for Key descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxKeyFieldDescriptorClass Type

nxsdDataDictionary.TnxKeyFieldDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxKeyFieldDescriptorClass = class of TnxKeyFieldDescriptor;
File

nxsdDataDictionary

Description

Class definition for Key Field descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxLocaleDescriptorClass Type

nxsdDataDictionary.TnxLocaleDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxLocaleDescriptorClass = class of TnxLocaleDescriptor;
File

nxsdDataDictionary

Description

Class definition for TnxLocaleDescriptor.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxMainIndicesDescriptorClass Type

nxsdDataDictionary.TnxMainIndicesDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxMainIndicesDescriptorClass = class of TnxMainIndicesDescriptor;
File

nxsdDataDictionary

Description

Class definition for the class of Main-Index Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxNestedTableDescriptorClass Type

nxsdDataDictionary.TnxNestedTableDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxNestedTableDescriptorClass = class of TnxNestedTableDescriptor;
File

nxsdDataDictionary

Description

Class definition for Nested(Sub-) table Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


nxsdDataDictionary.TnxTablesDescriptorClass Type

nxsdDataDictionary.TnxTablesDescriptorClass Type
nxsdDataDictionary Types Send Feedback
Syntax
Delphi
TnxTablesDescriptorClass = class of TnxTablesDescriptor;
File

nxsdDataDictionary

Description

Class definition for (Main) Table Descriptors.

Group

Types

Links
nxsdDataDictionary, Types


Variables

Variables
nxsdDataDictionary Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdDataDictionary Namespace

Variables
Name | Description
_AutoIncDescriptorList | This is variable nxsdDataDictionary._AutoIncDescriptorList.
_BlobDescriptorList | This is variable nxsdDataDictionary._BlobDescriptorList.
_BlockHeapDescriptorList | This is variable nxsdDataDictionary._BlockHeapDescriptorList.
_CustomDescriptorList | This is variable nxsdDataDictionary._CustomDescriptorList.
_CustomDescsDescriptorList | This is variable nxsdDataDictionary._CustomDescsDescriptorList.
_DefaultValueDescriptorList | This is variable nxsdDataDictionary._DefaultValueDescriptorList.
_FieldDescriptorList | This is variable nxsdDataDictionary._FieldDescriptorList.
_FieldsDescriptorList | This is variable nxsdDataDictionary._FieldsDescriptorList.
_FileDescriptorList | This is variable nxsdDataDictionary._FileDescriptorList.
_FilesDescriptorList | This is variable nxsdDataDictionary._FilesDescriptorList.
_HeapDescriptorList | This is variable nxsdDataDictionary._HeapDescriptorList.
_IndexDescriptorList | This is variable nxsdDataDictionary._IndexDescriptorList.
_IndicesDescriptorList | This is variable nxsdDataDictionary._IndicesDescriptorList.
_KeyDescriptorList | This is variable nxsdDataDictionary._KeyDescriptorList.
_KeyFieldDescriptorList | This is variable nxsdDataDictionary._KeyFieldDescriptorList.
_LocaleDescriptorList | This is variable nxsdDataDictionary._LocaleDescriptorList.
_MainIndicesDescriptorList | This is variable nxsdDataDictionary._MainIndicesDescriptorList.
_NestedTableDescriptorList | This is variable nxsdDataDictionary._NestedTableDescriptorList.
_RecordCompressionDescriptorList | This is variable nxsdDataDictionary._RecordCompressionDescriptorList.
_RecordDescriptorList | This is variable nxsdDataDictionary._RecordDescriptorList.
_StreamDescriptorList | This is variable nxsdDataDictionary._StreamDescriptorList.
_TablesDescriptorList | This is variable nxsdDataDictionary._TablesDescriptorList.
_ValidationDescriptorList | This is variable nxsdDataDictionary._ValidationDescriptorList.
_ValidationsDescriptorList | This is variable nxsdDataDictionary._ValidationsDescriptorList.
Disable30900LocaleFixes | This is variable nxsdDataDictionary.Disable30900LocaleFixes.
Links
nxsdDataDictionary Namespace, Variables


nxsdDataDictionary._AutoIncDescriptorList Variable

nxsdDataDictionary._AutoIncDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_AutoIncDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._AutoIncDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._BlobDescriptorList Variable

nxsdDataDictionary._BlobDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_BlobDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._BlobDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._BlockHeapDescriptorList Variable

nxsdDataDictionary._BlockHeapDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_BlockHeapDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._BlockHeapDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._CustomDescriptorList Variable

nxsdDataDictionary._CustomDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_CustomDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._CustomDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._CustomDescsDescriptorList Variable

nxsdDataDictionary._CustomDescsDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_CustomDescsDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._CustomDescsDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._DefaultValueDescriptorList Variable

nxsdDataDictionary._DefaultValueDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_DefaultValueDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._DefaultValueDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._FieldDescriptorList Variable

nxsdDataDictionary._FieldDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_FieldDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._FieldDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._FieldsDescriptorList Variable

nxsdDataDictionary._FieldsDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_FieldsDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._FieldsDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._FileDescriptorList Variable

nxsdDataDictionary._FileDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_FileDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._FileDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._FilesDescriptorList Variable

nxsdDataDictionary._FilesDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_FilesDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._FilesDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._HeapDescriptorList Variable

nxsdDataDictionary._HeapDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_HeapDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._HeapDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._IndexDescriptorList Variable

nxsdDataDictionary._IndexDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_IndexDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._IndexDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._IndicesDescriptorList Variable

nxsdDataDictionary._IndicesDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_IndicesDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._IndicesDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._KeyDescriptorList Variable

nxsdDataDictionary._KeyDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_KeyDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._KeyDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._KeyFieldDescriptorList Variable

nxsdDataDictionary._KeyFieldDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_KeyFieldDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._KeyFieldDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._LocaleDescriptorList Variable

nxsdDataDictionary._LocaleDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_LocaleDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._LocaleDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._MainIndicesDescriptorList Variable

nxsdDataDictionary._MainIndicesDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_MainIndicesDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._MainIndicesDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._NestedTableDescriptorList Variable

nxsdDataDictionary._NestedTableDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_NestedTableDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._NestedTableDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._RecordCompressionDescriptorList Variable

nxsdDataDictionary._RecordCompressionDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_RecordCompressionDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._RecordCompressionDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._RecordDescriptorList Variable

nxsdDataDictionary._RecordDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_RecordDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._RecordDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._StreamDescriptorList Variable

nxsdDataDictionary._StreamDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_StreamDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._StreamDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._TablesDescriptorList Variable

nxsdDataDictionary._TablesDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_TablesDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._TablesDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._ValidationDescriptorList Variable

nxsdDataDictionary._ValidationDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_ValidationDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._ValidationDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary._ValidationsDescriptorList Variable

nxsdDataDictionary._ValidationsDescriptorList Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
_ValidationsDescriptorList: TStringList;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary._ValidationsDescriptorList.

Group

Variables

Links
nxsdDataDictionary, Variables


nxsdDataDictionary.Disable30900LocaleFixes Variable

nxsdDataDictionary.Disable30900LocaleFixes Variable
nxsdDataDictionary Variables Send Feedback
Syntax
Delphi
Disable30900LocaleFixes: Boolean = False;
File

nxsdDataDictionary

Description

This is variable nxsdDataDictionary.Disable30900LocaleFixes.

Group

Variables

Links
nxsdDataDictionary, Variables


Constants

Constants
Constants nxsdDataDictionary Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_SigHeaderBlockV1 | Signature for NX V1 tables
nxc_SigHeaderBlockV2 | Signature for NX V2 tables
rsConstraintNameAlreadyUsed | This is constant nxsdDataDictionary.rsConstraintNameAlreadyUsed.
Namespace

nxsdDataDictionary Namespace

Links
Constants, nxsdDataDictionary Namespace


nxsdDataDictionary.nxc_SigHeaderBlockV1 Constant

nxsdDataDictionary.nxc_SigHeaderBlockV1 Constant
nxsdDataDictionary Constants Send Feedback
Syntax
Delphi
nxc_SigHeaderBlockV1: TnxBlockSignature = 'NX!1';
File

nxsdDataDictionary

Description

Signature for NX V1 tables

Group

Constants

Links
nxsdDataDictionary, Constants


nxsdDataDictionary.nxc_SigHeaderBlockV2 Constant

nxsdDataDictionary.nxc_SigHeaderBlockV2 Constant
nxsdDataDictionary Constants Send Feedback
Syntax
Delphi
nxc_SigHeaderBlockV2: TnxBlockSignature = 'NX!2';
File

nxsdDataDictionary

Description

Signature for NX V2 tables

Group

Constants

Links
nxsdDataDictionary, Constants


nxsdDataDictionary.rsConstraintNameAlreadyUsed Constant

nxsdDataDictionary.rsConstraintNameAlreadyUsed Constant
nxsdDataDictionary Constants Send Feedback
Syntax
Delphi
rsConstraintNameAlreadyUsed = 'Constraint name already in use: "%s"';
File

nxsdDataDictionary

Description

This is constant nxsdDataDictionary.rsConstraintNameAlreadyUsed.

Group

Constants

Links
nxsdDataDictionary, Constants


nxsdDataDictionaryAudit Namespace

nxsdDataDictionaryAudit Namespace
Classes Constants Legend Topics Types Send Feedback

This is namespace nxsdDataDictionaryAudit.

Classes
Name | Description
EnxAuditDescriptorException | This is class nxsdDataDictionaryAudit.EnxAuditDescriptorException.
TnxAuditDescriptor | This is class nxsdDataDictionaryAudit.TnxAuditDescriptor.
Constants
Name | Description
AuditUpdateType | This is constant nxsdDataDictionaryAudit.AuditUpdateType.
cAuditCustomDataLength | This is constant nxsdDataDictionaryAudit.cAuditCustomDataLength.
cAuditUserIDLength | This is constant nxsdDataDictionaryAudit.cAuditUserIDLength.
cCustomFieldCount | This is constant nxsdDataDictionaryAudit.cCustomFieldCount.
csAuditByChangedAtandUserID | This is constant nxsdDataDictionaryAudit.csAuditByChangedAtandUserID.
csAuditByUserIDandChangedAt | This is constant nxsdDataDictionaryAudit.csAuditByUserIDandChangedAt.
csAuditChangedAtDesc | This is constant nxsdDataDictionaryAudit.csAuditChangedAtDesc.
csAuditChangedAtFieldName | This is constant nxsdDataDictionaryAudit.csAuditChangedAtFieldName.
csAuditCustomDataDesc | This is constant nxsdDataDictionaryAudit.csAuditCustomDataDesc.
csAuditCustomDataFieldName | This is constant nxsdDataDictionaryAudit.csAuditCustomDataFieldName.
csAuditCustomDataOptionName | This is constant nxsdDataDictionaryAudit.csAuditCustomDataOptionName.
csAuditDescriptorName | This is constant nxsdDataDictionaryAudit.csAuditDescriptorName.
csAuditOldTableName | This is constant nxsdDataDictionaryAudit.csAuditOldTableName.
csAuditTableName | This is constant nxsdDataDictionaryAudit.csAuditTableName.
csAuditUpdateTypeDesc | This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeDesc.
csAuditUpdateTypeFieldName | This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeFieldName.
csAuditUserIDDesc | This is constant nxsdDataDictionaryAudit.csAuditUserIDDesc.
csAuditUserIDFieldName | This is constant nxsdDataDictionaryAudit.csAuditUserIDFieldName.
csAuditUserIDOptionName | This is constant nxsdDataDictionaryAudit.csAuditUserIDOptionName.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxAuditOnCanDiscardAuditTable | This is type nxsdDataDictionaryAudit.TnxAuditOnCanDiscardAuditTable.
TnxAuditOnChildtableCreated | This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableCreated.
TnxAuditOnChildtableRenamed | This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableRenamed.
Links
Classes, Constants, Legend, Topics, Types


Classes

Classes
Classes nxsdDataDictionaryAudit Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxAuditDescriptorException | This is class nxsdDataDictionaryAudit.EnxAuditDescriptorException.
TnxAuditDescriptor | This is class nxsdDataDictionaryAudit.TnxAuditDescriptor.
Namespace

nxsdDataDictionaryAudit Namespace

Links
Classes, nxsdDataDictionaryAudit Namespace, Legend


EnxAuditDescriptorException Class

EnxAuditDescriptorException Class
nxsdDataDictionaryAudit Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorExceptionnxsdDataDictionaryAudit_EnxAuditDescriptorException
Syntax
Delphi
EnxAuditDescriptorException = class(EnxBaseCustomDescriptorException);
File

nxsdDataDictionaryAudit

Description

This is class nxsdDataDictionaryAudit.EnxAuditDescriptorException.

Group

Classes

Links
nxsdDataDictionaryAudit, Classes


TnxAuditDescriptor Class

TnxAuditDescriptor Class
TnxAuditDescriptor Methods TnxAuditDescriptor Properties TnxAuditDescriptor Events TnxAuditDescriptor Members nxsdDataDictionaryAudit Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptornxsdDataDictionaryAudit_TnxAuditDescriptor
Syntax
Delphi
TnxAuditDescriptor = class(TnxBaseCustomDescriptor);
File

nxsdDataDictionaryAudit

Description

This is class nxsdDataDictionaryAudit.TnxAuditDescriptor.

Group

Classes

Links
TnxAuditDescriptor Methods, TnxAuditDescriptor Properties, TnxAuditDescriptor Events, TnxAuditDescriptor Members, nxsdDataDictionaryAudit, Classes


TnxAuditDescriptor Members

TnxAuditDescriptor Members
TnxAuditDescriptor Class Legend Protected Fields Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAuditDescriptor.

Class

TnxAuditDescriptor Class

Protected Fields
Name | Description
bcdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | constructor.
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Events
Name | Description
OnCanDiscardAuditTable | This is OnCanDiscardAuditTable, a member of class TnxAuditDescriptor.
OnChildtableCreated | This is OnChildtableCreated, a member of class TnxAuditDescriptor.
OnChildtableRenamed | This is OnChildtableRenamed, a member of class TnxAuditDescriptor.
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy | destructor.
FieldsDescriptorContainsAllFields |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IncludeBlobFields | This is IncludeBlobFields, a member of class TnxAuditDescriptor.
Name | Returns the name of the Custom Descriptor.
UseAudit | This is UseAudit, a member of class TnxAuditDescriptor.
Links
TnxAuditDescriptor Class, Legend, Protected Fields, Protected Methods, Public Events, Public Methods, Public Properties


TnxAuditDescriptor Methods

TnxAuditDescriptor Methods
TnxAuditDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxAuditDescriptor class are listed here.

Class

TnxAuditDescriptor Class

Public Methods
Name | Description
CheckValid |
FieldsDescriptorContainsAllFields |
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxAuditDescriptor Class, Legend, Public Methods


TnxAuditDescriptor.CheckValid Method

TnxAuditDescriptor.CheckValid Method
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxAuditDescriptor Methods

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Methods


TnxAuditDescriptor.FieldsDescriptorContainsAllFields Method

TnxAuditDescriptor.FieldsDescriptorContainsAllFields Method
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Methods Send Feedback
Syntax
Delphi
function FieldsDescriptorContainsAllFields(aAuditFieldsDescriptor: TnxFieldsDescriptor; aOriginalFieldsDescriptor: TnxFieldsDescriptor): Boolean;
Group

TnxAuditDescriptor Methods

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Methods


TnxAuditDescriptor.IsEqual Method

TnxAuditDescriptor.IsEqual Method
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxAuditDescriptor Methods

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Methods


TnxAuditDescriptor.LoadFromReader Method

TnxAuditDescriptor.LoadFromReader Method
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxAuditDescriptor Methods

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Methods


TnxAuditDescriptor.SaveToWriter Method

TnxAuditDescriptor.SaveToWriter Method
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxAuditDescriptor Methods

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Methods


TnxAuditDescriptor Properties

TnxAuditDescriptor Properties
TnxAuditDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxAuditDescriptor class are listed here.

Class

TnxAuditDescriptor Class

Public Properties
Name | Description
IncludeBlobFields | This is IncludeBlobFields, a member of class TnxAuditDescriptor.
UseAudit | This is UseAudit, a member of class TnxAuditDescriptor.
Links
TnxAuditDescriptor Class, Legend, Public Properties


TnxAuditDescriptor.IncludeBlobFields Property

TnxAuditDescriptor.IncludeBlobFields Property
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Properties Send Feedback
Syntax
Delphi
property IncludeBlobFields: Boolean;
Description

This is IncludeBlobFields, a member of class TnxAuditDescriptor.

Group

TnxAuditDescriptor Properties

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Properties


TnxAuditDescriptor.UseAudit Property

TnxAuditDescriptor.UseAudit Property
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Properties Send Feedback
Syntax
Delphi
property UseAudit: Boolean;
Description

This is UseAudit, a member of class TnxAuditDescriptor.

Group

TnxAuditDescriptor Properties

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Properties


TnxAuditDescriptor Events

TnxAuditDescriptor Events
TnxAuditDescriptor Class Legend Public Events Send Feedback

The events of the TnxAuditDescriptor class are listed here.

Class

TnxAuditDescriptor Class

Public Events
Name | Description
OnCanDiscardAuditTable | This is OnCanDiscardAuditTable, a member of class TnxAuditDescriptor.
OnChildtableCreated | This is OnChildtableCreated, a member of class TnxAuditDescriptor.
OnChildtableRenamed | This is OnChildtableRenamed, a member of class TnxAuditDescriptor.
Links
TnxAuditDescriptor Class, Legend, Public Events


TnxAuditDescriptor.OnCanDiscardAuditTable Event

TnxAuditDescriptor.OnCanDiscardAuditTable Event
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Events Send Feedback
Syntax
Delphi
property OnCanDiscardAuditTable: TnxAuditOnCanDiscardAuditTable;
Description

This is OnCanDiscardAuditTable, a member of class TnxAuditDescriptor.

Group

TnxAuditDescriptor Events

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Events


TnxAuditDescriptor.OnChildtableCreated Event

TnxAuditDescriptor.OnChildtableCreated Event
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Events Send Feedback
Syntax
Delphi
property OnChildtableCreated: TnxAuditOnChildtableCreated;
Description

This is OnChildtableCreated, a member of class TnxAuditDescriptor.

Group

TnxAuditDescriptor Events

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Events


TnxAuditDescriptor.OnChildtableRenamed Event

TnxAuditDescriptor.OnChildtableRenamed Event
TnxAuditDescriptor Class TnxAuditDescriptor Members nxsdDataDictionaryAudit Namespace TnxAuditDescriptor Events Send Feedback
Syntax
Delphi
property OnChildtableRenamed: TnxAuditOnChildtableRenamed;
Description

This is OnChildtableRenamed, a member of class TnxAuditDescriptor.

Group

TnxAuditDescriptor Events

Links
TnxAuditDescriptor Class, TnxAuditDescriptor Members, nxsdDataDictionaryAudit Namespace, TnxAuditDescriptor Events


Types

Types
nxsdDataDictionaryAudit Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdDataDictionaryAudit Namespace

Types
Name | Description
TnxAuditOnCanDiscardAuditTable | This is type nxsdDataDictionaryAudit.TnxAuditOnCanDiscardAuditTable.
TnxAuditOnChildtableCreated | This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableCreated.
TnxAuditOnChildtableRenamed | This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableRenamed.
Links
nxsdDataDictionaryAudit Namespace, Types


nxsdDataDictionaryAudit.TnxAuditOnCanDiscardAuditTable Type

nxsdDataDictionaryAudit.TnxAuditOnCanDiscardAuditTable Type
nxsdDataDictionaryAudit Types Send Feedback
Syntax
Delphi
TnxAuditOnCanDiscardAuditTable = procedure (var aCanDiscard : Boolean) of object;
File

nxsdDataDictionaryAudit

Description

This is type nxsdDataDictionaryAudit.TnxAuditOnCanDiscardAuditTable.

Group

Types

Links
nxsdDataDictionaryAudit, Types


nxsdDataDictionaryAudit.TnxAuditOnChildtableCreated Type

nxsdDataDictionaryAudit.TnxAuditOnChildtableCreated Type
nxsdDataDictionaryAudit Types Send Feedback
Syntax
Delphi
TnxAuditOnChildtableCreated = procedure (aChildname : string) of object;
File

nxsdDataDictionaryAudit

Description

This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableCreated.

Group

Types

Links
nxsdDataDictionaryAudit, Types


nxsdDataDictionaryAudit.TnxAuditOnChildtableRenamed Type

nxsdDataDictionaryAudit.TnxAuditOnChildtableRenamed Type
nxsdDataDictionaryAudit Types Send Feedback
Syntax
Delphi
TnxAuditOnChildtableRenamed = procedure (aOldChildname, aNewChildname : string) of object;
File

nxsdDataDictionaryAudit

Description

This is type nxsdDataDictionaryAudit.TnxAuditOnChildtableRenamed.

Group

Types

Links
nxsdDataDictionaryAudit, Types


Constants

Constants
Constants nxsdDataDictionaryAudit Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
AuditUpdateType | This is constant nxsdDataDictionaryAudit.AuditUpdateType.
cAuditCustomDataLength | This is constant nxsdDataDictionaryAudit.cAuditCustomDataLength.
cAuditUserIDLength | This is constant nxsdDataDictionaryAudit.cAuditUserIDLength.
cCustomFieldCount | This is constant nxsdDataDictionaryAudit.cCustomFieldCount.
csAuditByChangedAtandUserID | This is constant nxsdDataDictionaryAudit.csAuditByChangedAtandUserID.
csAuditByUserIDandChangedAt | This is constant nxsdDataDictionaryAudit.csAuditByUserIDandChangedAt.
csAuditChangedAtDesc | This is constant nxsdDataDictionaryAudit.csAuditChangedAtDesc.
csAuditChangedAtFieldName | This is constant nxsdDataDictionaryAudit.csAuditChangedAtFieldName.
csAuditCustomDataDesc | This is constant nxsdDataDictionaryAudit.csAuditCustomDataDesc.
csAuditCustomDataFieldName | This is constant nxsdDataDictionaryAudit.csAuditCustomDataFieldName.
csAuditCustomDataOptionName | This is constant nxsdDataDictionaryAudit.csAuditCustomDataOptionName.
csAuditDescriptorName | This is constant nxsdDataDictionaryAudit.csAuditDescriptorName.
csAuditOldTableName | This is constant nxsdDataDictionaryAudit.csAuditOldTableName.
csAuditTableName | This is constant nxsdDataDictionaryAudit.csAuditTableName.
csAuditUpdateTypeDesc | This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeDesc.
csAuditUpdateTypeFieldName | This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeFieldName.
csAuditUserIDDesc | This is constant nxsdDataDictionaryAudit.csAuditUserIDDesc.
csAuditUserIDFieldName | This is constant nxsdDataDictionaryAudit.csAuditUserIDFieldName.
csAuditUserIDOptionName | This is constant nxsdDataDictionaryAudit.csAuditUserIDOptionName.
Namespace

nxsdDataDictionaryAudit Namespace

Links
Constants, nxsdDataDictionaryAudit Namespace


nxsdDataDictionaryAudit.AuditUpdateType Constant

nxsdDataDictionaryAudit.AuditUpdateType Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
AuditUpdateType: array[eaRecordInsert..eaRecordDelete] of TnxWideChar = ('I', 'U', 'D');
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.AuditUpdateType.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.cAuditCustomDataLength Constant

nxsdDataDictionaryAudit.cAuditCustomDataLength Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
cAuditCustomDataLength = 100;
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.cAuditCustomDataLength.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.cAuditUserIDLength Constant

nxsdDataDictionaryAudit.cAuditUserIDLength Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
cAuditUserIDLength = 100;
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.cAuditUserIDLength.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.cCustomFieldCount Constant

nxsdDataDictionaryAudit.cCustomFieldCount Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
cCustomFieldCount = 4;
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.cCustomFieldCount.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditByChangedAtandUserID Constant

nxsdDataDictionaryAudit.csAuditByChangedAtandUserID Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditByChangedAtandUserID = 'By Changed At and User ID';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditByChangedAtandUserID.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditByUserIDandChangedAt Constant

nxsdDataDictionaryAudit.csAuditByUserIDandChangedAt Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditByUserIDandChangedAt = 'By User ID and Changed At';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditByUserIDandChangedAt.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditChangedAtDesc Constant

nxsdDataDictionaryAudit.csAuditChangedAtDesc Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditChangedAtDesc = 'Audit Timestamp';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditChangedAtDesc.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditChangedAtFieldName Constant

nxsdDataDictionaryAudit.csAuditChangedAtFieldName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditChangedAtFieldName = 'Audit Changed At';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditChangedAtFieldName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditCustomDataDesc Constant

nxsdDataDictionaryAudit.csAuditCustomDataDesc Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditCustomDataDesc = csAuditCustomDataFieldName;
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditCustomDataDesc.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditCustomDataFieldName Constant

nxsdDataDictionaryAudit.csAuditCustomDataFieldName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditCustomDataFieldName = 'Audit Custom Data';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditCustomDataFieldName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditCustomDataOptionName Constant

nxsdDataDictionaryAudit.csAuditCustomDataOptionName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditCustomDataOptionName = 'AuditCustomData';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditCustomDataOptionName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditDescriptorName Constant

nxsdDataDictionaryAudit.csAuditDescriptorName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditDescriptorName = 'Auditing';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditDescriptorName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditOldTableName Constant

nxsdDataDictionaryAudit.csAuditOldTableName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditOldTableName = 'Audit Log Old_';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditOldTableName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditTableName Constant

nxsdDataDictionaryAudit.csAuditTableName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditTableName = 'Audit Log';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditTableName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditUpdateTypeDesc Constant

nxsdDataDictionaryAudit.csAuditUpdateTypeDesc Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditUpdateTypeDesc = csAuditUpdateTypeFieldName;
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeDesc.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditUpdateTypeFieldName Constant

nxsdDataDictionaryAudit.csAuditUpdateTypeFieldName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditUpdateTypeFieldName = 'Audit Update Type';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditUpdateTypeFieldName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditUserIDDesc Constant

nxsdDataDictionaryAudit.csAuditUserIDDesc Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditUserIDDesc = 'Audit User Identification';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditUserIDDesc.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditUserIDFieldName Constant

nxsdDataDictionaryAudit.csAuditUserIDFieldName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditUserIDFieldName = 'Audit User ID';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditUserIDFieldName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryAudit.csAuditUserIDOptionName Constant

nxsdDataDictionaryAudit.csAuditUserIDOptionName Constant
nxsdDataDictionaryAudit Constants Send Feedback
Syntax
Delphi
csAuditUserIDOptionName = 'AuditUserID';
File

nxsdDataDictionaryAudit

Description

This is constant nxsdDataDictionaryAudit.csAuditUserIDOptionName.

Group

Constants

Links
nxsdDataDictionaryAudit, Constants


nxsdDataDictionaryFulltext Namespace

nxsdDataDictionaryFulltext Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

Fulltext specific data dictionary.

Classes
Name | Description
EnxBaseBitArrayStorageHandlerDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseBitArrayStorageHandlerDescriptorException.
EnxBaseFoldStringTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseFoldStringTokenFilterDescriptorException.
EnxBaseFulltextDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxBaseFulltextDictionaryItemException.
EnxBaseFulltextIndexDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxBaseFulltextIndexDictionaryItemException.
EnxBaseLocaleMappingTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseLocaleMappingTokenFilterDescriptorException.
EnxBaseSeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseSeparatorTokenFilterDescriptorException.
EnxBaseTokenExtractorDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenExtractorDescriptorException.
EnxBaseTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenFilterDescriptorException.
EnxBaseTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenIndexDescriptorException.
EnxBaseTokenSourceDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenSourceDescriptorException.
EnxBitArrayTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenIndexDescriptorException.
EnxBitArrayTokenKeyDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenKeyDescriptorException.
EnxCategorySeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCategorySeparatorTokenFilterDescriptorException.
EnxCustomFoldStringTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCustomFoldStringTokenFilterDescriptorException.
EnxCustomLocaleMappingTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCustomLocaleMappingTokenFilterDescriptorException.
EnxFieldTokenExtractorDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFieldTokenExtractorDescriptorException.
EnxFulltextDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFulltextDescriptorException.
EnxFulltextIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFulltextIndexDescriptorException.
EnxMainIndexTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenIndexDescriptorException.
EnxMainIndexTokenKeyDescriptorException | This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenKeyDescriptorException.
EnxNumberedFulltextIndexDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxNumberedFulltextIndexDictionaryItemException.
EnxSimpleBitArrayStorageHandlerDescriptorException | This is class nxsdDataDictionaryFulltext.EnxSimpleBitArrayStorageHandlerDescriptorException.
EnxStringReplaceTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxStringReplaceTokenFilterDescriptorException.
EnxTokenExtractorHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenExtractorHubDescriptorException.
EnxTokenFilterHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenFilterHubDescriptorException.
EnxTokenIndexHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenIndexHubDescriptorException.
EnxWideCharSeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxWideCharSeparatorTokenFilterDescriptorException.
TnxBaseBitArrayStorageHandlerDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptor.
TnxBaseFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseFoldStringTokenFilterDescriptor.
TnxBaseFulltextDictionaryItem | This is class nxsdDataDictionaryFulltext.TnxBaseFulltextDictionaryItem.
TnxBaseFulltextIndexDictionaryItem | econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddatadictionaryfulltext' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxFulltextIndexDescriptor;' $HPPEMIT '} /* namespace Nxsddatadictionaryfulltext */'
TnxBaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseLocaleMappingTokenFilterDescriptor.
TnxBaseSeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseSeparatorTokenFilterDescriptor.
TnxBaseTokenExtractorDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptor.
TnxBaseTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptor.
TnxBaseTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptor.
TnxBaseTokenSourceDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenSourceDescriptor.
TnxBitArrayTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptor.
TnxBitArrayTokenKeyDescriptor | This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptor.
TnxCategorySeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCategorySeparatorTokenFilterDescriptor.
TnxCustomFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCustomFoldStringTokenFilterDescriptor.
TnxCustomLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCustomLocaleMappingTokenFilterDescriptor.
TnxDecomposeFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxDecomposeFoldStringTokenFilterDescriptor.
TnxFieldTokenExtractorDescriptor | This is class nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptor.
TnxFulltextDescriptor | This is class nxsdDataDictionaryFulltext.TnxFulltextDescriptor.
TnxFulltextIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptor.
TnxLowercaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxLowercaseLocaleMappingTokenFilterDescriptor.
TnxMainIndexTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenIndexDescriptor.
TnxMainIndexTokenKeyDescriptor | This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptor.
TnxNumberedFulltextIndexDictionaryItem | This is class nxsdDataDictionaryFulltext.TnxNumberedFulltextIndexDictionaryItem.
TnxPreComposeFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxPreComposeFoldStringTokenFilterDescriptor.
TnxSimpleBitArrayStorageHandlerDescriptor | This is class nxsdDataDictionaryFulltext.TnxSimpleBitArrayStorageHandlerDescriptor.
TnxStringReplaceTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterDescriptor.
TnxTokenExtractorHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptor.
TnxTokenFilterHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptor.
TnxTokenIndexHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptor.
TnxTokenIndicesDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenIndicesDescriptor.
TnxUppercaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxUppercaseLocaleMappingTokenFilterDescriptor.
TnxWideCharSeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxWideCharSeparatorTokenFilterDescriptor.
Constants
Name | Description
nxcClassDefaultSeparators | This is constant nxsdDataDictionaryFulltext.nxcClassDefaultSeparators.
Functions
Name | Description
EnsureFulltextDescriptor |
GetFulltextDescriptor |
Structs, Records, Enums
Name | Description
TnxStringReplaceKind | don't change order, only add new entries at end, ordinal value saved in stream
TnxStringReplaceTokenFilterItem | This is record nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItem.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBaseBitArrayStorageHandlerDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptorClass.
TnxBaseTokenExtractorDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptorClass.
TnxBaseTokenFilterDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptorClass.
TnxBaseTokenIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptorClass.
TnxBitArrayTokenIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptorClass.
TnxBitArrayTokenKeyDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptorClass.
TnxFieldTokenExtractorDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptorClass.
TnxFulltextDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFulltextDescriptorClass.
TnxFulltextIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptorClass.
TnxFulltextIndexDescriptors | This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptors.
TnxMainIndexTokenKeyDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptorClass.
TnxStringReplaceTokenFilterItems | This is type nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItems.
TnxTokenExtractorHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptorClass.
TnxTokenFilterHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptorClass.
TnxTokenIndexHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptorClass.
TnxTokenIndicesDescriptorClass | HPPEMIT '#define TnxFulltextIndexDescriptors DynamicArray
Variables
Name | Description
_BitArrayStorageHandlerList | This is variable nxsdDataDictionaryFulltext._BitArrayStorageHandlerList.
_FulltextIndexDescriptorList | This is variable nxsdDataDictionaryFulltext._FulltextIndexDescriptorList.
_TokenExtractorDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenExtractorDescriptorList.
_TokenFilterDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenFilterDescriptorList.
_TokenIndexDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenIndexDescriptorList.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxsdDataDictionaryFulltext Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseBitArrayStorageHandlerDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseBitArrayStorageHandlerDescriptorException.
EnxBaseFoldStringTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseFoldStringTokenFilterDescriptorException.
EnxBaseFulltextDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxBaseFulltextDictionaryItemException.
EnxBaseFulltextIndexDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxBaseFulltextIndexDictionaryItemException.
EnxBaseLocaleMappingTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseLocaleMappingTokenFilterDescriptorException.
EnxBaseSeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseSeparatorTokenFilterDescriptorException.
EnxBaseTokenExtractorDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenExtractorDescriptorException.
EnxBaseTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenFilterDescriptorException.
EnxBaseTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenIndexDescriptorException.
EnxBaseTokenSourceDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBaseTokenSourceDescriptorException.
EnxBitArrayTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenIndexDescriptorException.
EnxBitArrayTokenKeyDescriptorException | This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenKeyDescriptorException.
EnxCategorySeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCategorySeparatorTokenFilterDescriptorException.
EnxCustomFoldStringTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCustomFoldStringTokenFilterDescriptorException.
EnxCustomLocaleMappingTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxCustomLocaleMappingTokenFilterDescriptorException.
EnxFieldTokenExtractorDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFieldTokenExtractorDescriptorException.
EnxFulltextDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFulltextDescriptorException.
EnxFulltextIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxFulltextIndexDescriptorException.
EnxMainIndexTokenIndexDescriptorException | This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenIndexDescriptorException.
EnxMainIndexTokenKeyDescriptorException | This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenKeyDescriptorException.
EnxNumberedFulltextIndexDictionaryItemException | This is class nxsdDataDictionaryFulltext.EnxNumberedFulltextIndexDictionaryItemException.
EnxSimpleBitArrayStorageHandlerDescriptorException | This is class nxsdDataDictionaryFulltext.EnxSimpleBitArrayStorageHandlerDescriptorException.
EnxStringReplaceTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxStringReplaceTokenFilterDescriptorException.
EnxTokenExtractorHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenExtractorHubDescriptorException.
EnxTokenFilterHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenFilterHubDescriptorException.
EnxTokenIndexHubDescriptorException | This is class nxsdDataDictionaryFulltext.EnxTokenIndexHubDescriptorException.
EnxWideCharSeparatorTokenFilterDescriptorException | This is class nxsdDataDictionaryFulltext.EnxWideCharSeparatorTokenFilterDescriptorException.
TnxBaseBitArrayStorageHandlerDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptor.
TnxBaseFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseFoldStringTokenFilterDescriptor.
TnxBaseFulltextDictionaryItem | This is class nxsdDataDictionaryFulltext.TnxBaseFulltextDictionaryItem.
TnxBaseFulltextIndexDictionaryItem | econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddatadictionaryfulltext' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxFulltextIndexDescriptor;' $HPPEMIT '} /* namespace Nxsddatadictionaryfulltext */'
TnxBaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseLocaleMappingTokenFilterDescriptor.
TnxBaseSeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseSeparatorTokenFilterDescriptor.
TnxBaseTokenExtractorDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptor.
TnxBaseTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptor.
TnxBaseTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptor.
TnxBaseTokenSourceDescriptor | This is class nxsdDataDictionaryFulltext.TnxBaseTokenSourceDescriptor.
TnxBitArrayTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptor.
TnxBitArrayTokenKeyDescriptor | This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptor.
TnxCategorySeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCategorySeparatorTokenFilterDescriptor.
TnxCustomFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCustomFoldStringTokenFilterDescriptor.
TnxCustomLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxCustomLocaleMappingTokenFilterDescriptor.
TnxDecomposeFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxDecomposeFoldStringTokenFilterDescriptor.
TnxFieldTokenExtractorDescriptor | This is class nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptor.
TnxFulltextDescriptor | This is class nxsdDataDictionaryFulltext.TnxFulltextDescriptor.
TnxFulltextIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptor.
TnxLowercaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxLowercaseLocaleMappingTokenFilterDescriptor.
TnxMainIndexTokenIndexDescriptor | This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenIndexDescriptor.
TnxMainIndexTokenKeyDescriptor | This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptor.
TnxNumberedFulltextIndexDictionaryItem | This is class nxsdDataDictionaryFulltext.TnxNumberedFulltextIndexDictionaryItem.
TnxPreComposeFoldStringTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxPreComposeFoldStringTokenFilterDescriptor.
TnxSimpleBitArrayStorageHandlerDescriptor | This is class nxsdDataDictionaryFulltext.TnxSimpleBitArrayStorageHandlerDescriptor.
TnxStringReplaceTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterDescriptor.
TnxTokenExtractorHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptor.
TnxTokenFilterHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptor.
TnxTokenIndexHubDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptor.
TnxTokenIndicesDescriptor | This is class nxsdDataDictionaryFulltext.TnxTokenIndicesDescriptor.
TnxUppercaseLocaleMappingTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxUppercaseLocaleMappingTokenFilterDescriptor.
TnxWideCharSeparatorTokenFilterDescriptor | This is class nxsdDataDictionaryFulltext.TnxWideCharSeparatorTokenFilterDescriptor.
Namespace

nxsdDataDictionaryFulltext Namespace

Links
Classes, nxsdDataDictionaryFulltext Namespace, Legend


EnxBaseBitArrayStorageHandlerDescriptorException Class

EnxBaseBitArrayStorageHandlerDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseBitArrayStorageHandlerDescriptorException
Syntax
Delphi
EnxBaseBitArrayStorageHandlerDescriptorException = class(EnxBaseFulltextIndexDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseBitArrayStorageHandlerDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseFoldStringTokenFilterDescriptorException Class

EnxBaseFoldStringTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseFoldStringTokenFilterDescriptorException
Syntax
Delphi
EnxBaseFoldStringTokenFilterDescriptorException = class(EnxBaseTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseFoldStringTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseFulltextDictionaryItemException Class

EnxBaseFulltextDictionaryItemException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextDictionaryItemException
Syntax
Delphi
EnxBaseFulltextDictionaryItemException = class(EnxDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseFulltextDictionaryItemException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseFulltextIndexDictionaryItemException Class

EnxBaseFulltextIndexDictionaryItemException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxBaseFulltextIndexDictionaryItemException
Syntax
Delphi
EnxBaseFulltextIndexDictionaryItemException = class(EnxBaseFulltextDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseFulltextIndexDictionaryItemException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseLocaleMappingTokenFilterDescriptorException Class

EnxBaseLocaleMappingTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseLocaleMappingTokenFilterDescriptorException
Syntax
Delphi
EnxBaseLocaleMappingTokenFilterDescriptorException = class(EnxBaseTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseLocaleMappingTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseSeparatorTokenFilterDescriptorException Class

EnxBaseSeparatorTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseSeparatorTokenFilterDescriptorException
Syntax
Delphi
EnxBaseSeparatorTokenFilterDescriptorException = class(EnxBaseTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseSeparatorTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseTokenExtractorDescriptorException Class

EnxBaseTokenExtractorDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenExtractorDescriptorException
Syntax
Delphi
EnxBaseTokenExtractorDescriptorException = class(EnxBaseTokenSourceDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseTokenExtractorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseTokenFilterDescriptorException Class

EnxBaseTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenFilterDescriptorException
Syntax
Delphi
EnxBaseTokenFilterDescriptorException = class(EnxBaseTokenSourceDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseTokenIndexDescriptorException Class

EnxBaseTokenIndexDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenIndexDescriptorException
Syntax
Delphi
EnxBaseTokenIndexDescriptorException = class(EnxNumberedFulltextIndexDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseTokenIndexDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBaseTokenSourceDescriptorException Class

EnxBaseTokenSourceDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorExceptionnxsdDataDictionaryFulltext_EnxBaseTokenSourceDescriptorException
Syntax
Delphi
EnxBaseTokenSourceDescriptorException = class(EnxNumberedFulltextIndexDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBaseTokenSourceDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBitArrayTokenIndexDescriptorException Class

EnxBitArrayTokenIndexDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenIndexDescriptorException
Syntax
Delphi
EnxBitArrayTokenIndexDescriptorException = class(EnxBaseTokenIndexDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenIndexDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxBitArrayTokenKeyDescriptorException Class

EnxBitArrayTokenKeyDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxBitArrayTokenKeyDescriptorException
Syntax
Delphi
EnxBitArrayTokenKeyDescriptorException = class(EnxBaseKeyDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxBitArrayTokenKeyDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxCategorySeparatorTokenFilterDescriptorException Class

EnxCategorySeparatorTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCategorySeparatorTokenFilterDescriptorException
Syntax
Delphi
EnxCategorySeparatorTokenFilterDescriptorException = class(EnxBaseSeparatorTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxCategorySeparatorTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxCustomFoldStringTokenFilterDescriptorException Class

EnxCustomFoldStringTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomFoldStringTokenFilterDescriptorException
Syntax
Delphi
EnxCustomFoldStringTokenFilterDescriptorException = class(EnxBaseFoldStringTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxCustomFoldStringTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxCustomLocaleMappingTokenFilterDescriptorException Class

EnxCustomLocaleMappingTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxCustomLocaleMappingTokenFilterDescriptorException
Syntax
Delphi
EnxCustomLocaleMappingTokenFilterDescriptorException = class(EnxBaseLocaleMappingTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxCustomLocaleMappingTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxFieldTokenExtractorDescriptorException Class

EnxFieldTokenExtractorDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorExceptionnxsdDataDictionaryFulltext_EnxFieldTokenExtractorDescriptorException
Syntax
Delphi
EnxFieldTokenExtractorDescriptorException = class(EnxBaseTokenExtractorDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxFieldTokenExtractorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxFulltextDescriptorException Class

EnxFulltextDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextDescriptorException
Syntax
Delphi
EnxFulltextDescriptorException = class(EnxBaseCustomDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxFulltextDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxFulltextIndexDescriptorException Class

EnxFulltextIndexDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxFulltextIndexDescriptorException
Syntax
Delphi
EnxFulltextIndexDescriptorException = class(EnxBaseFulltextDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxFulltextIndexDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxMainIndexTokenIndexDescriptorException Class

EnxMainIndexTokenIndexDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenIndexDescriptorException
Syntax
Delphi
EnxMainIndexTokenIndexDescriptorException = class(EnxBaseTokenIndexDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenIndexDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxMainIndexTokenKeyDescriptorException Class

EnxMainIndexTokenKeyDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorExceptionnxsdDataDictionaryFulltext_EnxMainIndexTokenKeyDescriptorException
Syntax
Delphi
EnxMainIndexTokenKeyDescriptorException = class(EnxBaseKeyDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxMainIndexTokenKeyDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxNumberedFulltextIndexDictionaryItemException Class

EnxNumberedFulltextIndexDictionaryItemException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemExceptionnxsdDataDictionaryFulltext_EnxNumberedFulltextIndexDictionaryItemException
Syntax
Delphi
EnxNumberedFulltextIndexDictionaryItemException = class(EnxBaseFulltextIndexDictionaryItemException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxNumberedFulltextIndexDictionaryItemException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxSimpleBitArrayStorageHandlerDescriptorException Class

EnxSimpleBitArrayStorageHandlerDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorExceptionnxsdDataDictionaryFulltext_EnxSimpleBitArrayStorageHandlerDescriptorException
Syntax
Delphi
EnxSimpleBitArrayStorageHandlerDescriptorException = class(EnxBaseBitArrayStorageHandlerDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxSimpleBitArrayStorageHandlerDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxStringReplaceTokenFilterDescriptorException Class

EnxStringReplaceTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxStringReplaceTokenFilterDescriptorException
Syntax
Delphi
EnxStringReplaceTokenFilterDescriptorException = class(EnxBaseTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxStringReplaceTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxTokenExtractorHubDescriptorException Class

EnxTokenExtractorHubDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenExtractorHubDescriptorException
Syntax
Delphi
EnxTokenExtractorHubDescriptorException = class(EnxBaseTokenExtractorDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxTokenExtractorHubDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxTokenFilterHubDescriptorException Class

EnxTokenFilterHubDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenFilterHubDescriptorException
Syntax
Delphi
EnxTokenFilterHubDescriptorException = class(EnxBaseTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxTokenFilterHubDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxTokenIndexHubDescriptorException Class

EnxTokenIndexHubDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorExceptionnxsdDataDictionaryFulltext_EnxTokenIndexHubDescriptorException
Syntax
Delphi
EnxTokenIndexHubDescriptorException = class(EnxBaseTokenIndexDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxTokenIndexHubDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


EnxWideCharSeparatorTokenFilterDescriptorException Class

EnxWideCharSeparatorTokenFilterDescriptorException Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorExceptionnxsdDataDictionaryFulltext_EnxWideCharSeparatorTokenFilterDescriptorException
Syntax
Delphi
EnxWideCharSeparatorTokenFilterDescriptorException = class(EnxBaseSeparatorTokenFilterDescriptorException);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.EnxWideCharSeparatorTokenFilterDescriptorException.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


TnxBaseBitArrayStorageHandlerDescriptor Class

TnxBaseBitArrayStorageHandlerDescriptor Class
TnxBaseBitArrayStorageHandlerDescriptor Methods TnxBaseBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxBaseBitArrayStorageHandlerDescriptor
Syntax
Delphi
TnxBaseBitArrayStorageHandlerDescriptor = class(TnxBaseFulltextIndexDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptor.

Group

Classes

Links
TnxBaseBitArrayStorageHandlerDescriptor Methods, TnxBaseBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseBitArrayStorageHandlerDescriptor Members

TnxBaseBitArrayStorageHandlerDescriptor Members
TnxBaseBitArrayStorageHandlerDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseBitArrayStorageHandlerDescriptor.

Class

TnxBaseBitArrayStorageHandlerDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | TnxBaseBitArrayStorageHandlerDescriptor
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseBitArrayStorageHandlerDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseBitArrayStorageHandlerDescriptor.Create Constructor

TnxBaseBitArrayStorageHandlerDescriptor.Create Constructor
TnxBaseBitArrayStorageHandlerDescriptor Class TnxBaseBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseBitArrayStorageHandlerDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Description

TnxBaseBitArrayStorageHandlerDescriptor

Class

TnxBaseBitArrayStorageHandlerDescriptor Class

Links
TnxBaseBitArrayStorageHandlerDescriptor Class, TnxBaseBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseBitArrayStorageHandlerDescriptor Class


TnxBaseBitArrayStorageHandlerDescriptor Methods

TnxBaseBitArrayStorageHandlerDescriptor Methods
TnxBaseBitArrayStorageHandlerDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseBitArrayStorageHandlerDescriptor class are listed here.

Class

TnxBaseBitArrayStorageHandlerDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseBitArrayStorageHandlerDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseBitArrayStorageHandlerDescriptor.GetList Method

TnxBaseBitArrayStorageHandlerDescriptor.GetList Method
TnxBaseBitArrayStorageHandlerDescriptor Class TnxBaseBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseBitArrayStorageHandlerDescriptor Methods

Links
TnxBaseBitArrayStorageHandlerDescriptor Class, TnxBaseBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseBitArrayStorageHandlerDescriptor Methods


TnxBaseBitArrayStorageHandlerDescriptor.LoadFromReader Method

TnxBaseBitArrayStorageHandlerDescriptor.LoadFromReader Method
TnxBaseBitArrayStorageHandlerDescriptor Class TnxBaseBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseBitArrayStorageHandlerDescriptor Methods

Links
TnxBaseBitArrayStorageHandlerDescriptor Class, TnxBaseBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseBitArrayStorageHandlerDescriptor Methods


TnxBaseBitArrayStorageHandlerDescriptor.SaveToWriter Method

TnxBaseBitArrayStorageHandlerDescriptor.SaveToWriter Method
TnxBaseBitArrayStorageHandlerDescriptor Class TnxBaseBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseBitArrayStorageHandlerDescriptor Methods

Links
TnxBaseBitArrayStorageHandlerDescriptor Class, TnxBaseBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseBitArrayStorageHandlerDescriptor Methods


TnxBaseFoldStringTokenFilterDescriptor Class

TnxBaseFoldStringTokenFilterDescriptor Class
TnxBaseFoldStringTokenFilterDescriptor Methods TnxBaseFoldStringTokenFilterDescriptor Properties TnxBaseFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseFoldStringTokenFilterDescriptor
Syntax
Delphi
TnxBaseFoldStringTokenFilterDescriptor = class(TnxBaseTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseFoldStringTokenFilterDescriptor.

Group

Classes

Links
TnxBaseFoldStringTokenFilterDescriptor Methods, TnxBaseFoldStringTokenFilterDescriptor Properties, TnxBaseFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseFoldStringTokenFilterDescriptor Members

TnxBaseFoldStringTokenFilterDescriptor Members
TnxBaseFoldStringTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFoldStringTokenFilterDescriptor.

Class

TnxBaseFoldStringTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfstfdGetFlags | This is bfstfdGetFlags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxBaseFoldStringTokenFilterDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseFoldStringTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseFoldStringTokenFilterDescriptor Methods

TnxBaseFoldStringTokenFilterDescriptor Methods
TnxBaseFoldStringTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFoldStringTokenFilterDescriptor class are listed here.

Class

TnxBaseFoldStringTokenFilterDescriptor Class

Protected Methods
Name | Description
bfstfdGetFlags | This is bfstfdGetFlags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
Public Methods
Name | Description
LoadFromReader | TnxBaseFoldStringTokenFilterDescriptor
SaveToWriter |
Links
TnxBaseFoldStringTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseFoldStringTokenFilterDescriptor.bfstfdGetFlags Method

TnxBaseFoldStringTokenFilterDescriptor.bfstfdGetFlags Method
TnxBaseFoldStringTokenFilterDescriptor Class TnxBaseFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function bfstfdGetFlags: Cardinal; virtual; abstract;
Description

This is bfstfdGetFlags, a member of class TnxBaseFoldStringTokenFilterDescriptor.

Group

TnxBaseFoldStringTokenFilterDescriptor Methods

Links
TnxBaseFoldStringTokenFilterDescriptor Class, TnxBaseFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFoldStringTokenFilterDescriptor Methods


TnxBaseFoldStringTokenFilterDescriptor.LoadFromReader Method

TnxBaseFoldStringTokenFilterDescriptor.LoadFromReader Method
TnxBaseFoldStringTokenFilterDescriptor Class TnxBaseFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxBaseFoldStringTokenFilterDescriptor

Group

TnxBaseFoldStringTokenFilterDescriptor Methods

Links
TnxBaseFoldStringTokenFilterDescriptor Class, TnxBaseFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFoldStringTokenFilterDescriptor Methods


TnxBaseFoldStringTokenFilterDescriptor.SaveToWriter Method

TnxBaseFoldStringTokenFilterDescriptor.SaveToWriter Method
TnxBaseFoldStringTokenFilterDescriptor Class TnxBaseFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseFoldStringTokenFilterDescriptor Methods

Links
TnxBaseFoldStringTokenFilterDescriptor Class, TnxBaseFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFoldStringTokenFilterDescriptor Methods


TnxBaseFoldStringTokenFilterDescriptor Properties

TnxBaseFoldStringTokenFilterDescriptor Properties
TnxBaseFoldStringTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseFoldStringTokenFilterDescriptor class are listed here.

Class

TnxBaseFoldStringTokenFilterDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
Links
TnxBaseFoldStringTokenFilterDescriptor Class, Legend, Public Properties


TnxBaseFoldStringTokenFilterDescriptor.Flags Property

TnxBaseFoldStringTokenFilterDescriptor.Flags Property
TnxBaseFoldStringTokenFilterDescriptor Class TnxBaseFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseFoldStringTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxBaseFoldStringTokenFilterDescriptor.

Group

TnxBaseFoldStringTokenFilterDescriptor Properties

Links
TnxBaseFoldStringTokenFilterDescriptor Class, TnxBaseFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFoldStringTokenFilterDescriptor Properties


TnxBaseFulltextDictionaryItem Class

TnxBaseFulltextDictionaryItem Class
TnxBaseFulltextDictionaryItem Methods TnxBaseFulltextDictionaryItem Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextDictionaryItem
Syntax
Delphi
TnxBaseFulltextDictionaryItem = class(TnxLocalizedDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseFulltextDictionaryItem.

Group

Classes

Links
TnxBaseFulltextDictionaryItem Methods, TnxBaseFulltextDictionaryItem Members, nxsdDataDictionaryFulltext, Classes


TnxBaseFulltextDictionaryItem Members

TnxBaseFulltextDictionaryItem Members
TnxBaseFulltextDictionaryItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFulltextDictionaryItem.

Class

TnxBaseFulltextDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | TnxBaseFulltextDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseFulltextDictionaryItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseFulltextDictionaryItem.Create Constructor

TnxBaseFulltextDictionaryItem.Create Constructor
TnxBaseFulltextDictionaryItem Class TnxBaseFulltextDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextDictionaryItem Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent);
Description

TnxBaseFulltextDictionaryItem

Class

TnxBaseFulltextDictionaryItem Class

Links
TnxBaseFulltextDictionaryItem Class, TnxBaseFulltextDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextDictionaryItem Class


TnxBaseFulltextDictionaryItem Methods

TnxBaseFulltextDictionaryItem Methods
TnxBaseFulltextDictionaryItem Class Legend Public Methods Send Feedback

The methods of the TnxBaseFulltextDictionaryItem class are listed here.

Class

TnxBaseFulltextDictionaryItem Class

Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseFulltextDictionaryItem Class, Legend, Public Methods


TnxBaseFulltextDictionaryItem.LoadFromReader Method

TnxBaseFulltextDictionaryItem.LoadFromReader Method
TnxBaseFulltextDictionaryItem Class TnxBaseFulltextDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseFulltextDictionaryItem Methods

Links
TnxBaseFulltextDictionaryItem Class, TnxBaseFulltextDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextDictionaryItem Methods


TnxBaseFulltextDictionaryItem.SaveToWriter Method

TnxBaseFulltextDictionaryItem.SaveToWriter Method
TnxBaseFulltextDictionaryItem Class TnxBaseFulltextDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseFulltextDictionaryItem Methods

Links
TnxBaseFulltextDictionaryItem Class, TnxBaseFulltextDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextDictionaryItem Methods


TnxBaseFulltextIndexDictionaryItem Class

TnxBaseFulltextIndexDictionaryItem Class
TnxBaseFulltextIndexDictionaryItem Methods TnxBaseFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxBaseFulltextIndexDictionaryItem
Syntax
Delphi
TnxBaseFulltextIndexDictionaryItem = class(TnxBaseFulltextDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddatadictionaryfulltext' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxFulltextIndexDescriptor;' $HPPEMIT '} /* namespace Nxsddatadictionaryfulltext */'

Group

Classes

Links
TnxBaseFulltextIndexDictionaryItem Methods, TnxBaseFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext, Classes


TnxBaseFulltextIndexDictionaryItem Members

TnxBaseFulltextIndexDictionaryItem Members
TnxBaseFulltextIndexDictionaryItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFulltextIndexDictionaryItem.

Class

TnxBaseFulltextIndexDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseFulltextIndexDictionaryItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseFulltextIndexDictionaryItem.Create Constructor

TnxBaseFulltextIndexDictionaryItem.Create Constructor
TnxBaseFulltextIndexDictionaryItem Class TnxBaseFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextIndexDictionaryItem Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Description

TnxBaseFulltextIndexDictionaryItem

Class

TnxBaseFulltextIndexDictionaryItem Class

Links
TnxBaseFulltextIndexDictionaryItem Class, TnxBaseFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextIndexDictionaryItem Class


TnxBaseFulltextIndexDictionaryItem Methods

TnxBaseFulltextIndexDictionaryItem Methods
TnxBaseFulltextIndexDictionaryItem Class Legend Public Methods Send Feedback

The methods of the TnxBaseFulltextIndexDictionaryItem class are listed here.

Class

TnxBaseFulltextIndexDictionaryItem Class

Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseFulltextIndexDictionaryItem Class, Legend, Public Methods


TnxBaseFulltextIndexDictionaryItem.LoadFromReader Method

TnxBaseFulltextIndexDictionaryItem.LoadFromReader Method
TnxBaseFulltextIndexDictionaryItem Class TnxBaseFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextIndexDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseFulltextIndexDictionaryItem Methods

Links
TnxBaseFulltextIndexDictionaryItem Class, TnxBaseFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextIndexDictionaryItem Methods


TnxBaseFulltextIndexDictionaryItem.SaveToWriter Method

TnxBaseFulltextIndexDictionaryItem.SaveToWriter Method
TnxBaseFulltextIndexDictionaryItem Class TnxBaseFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxBaseFulltextIndexDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseFulltextIndexDictionaryItem Methods

Links
TnxBaseFulltextIndexDictionaryItem Class, TnxBaseFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxBaseFulltextIndexDictionaryItem Methods


TnxBaseLocaleMappingTokenFilterDescriptor Class

TnxBaseLocaleMappingTokenFilterDescriptor Class
TnxBaseLocaleMappingTokenFilterDescriptor Methods TnxBaseLocaleMappingTokenFilterDescriptor Properties TnxBaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseLocaleMappingTokenFilterDescriptor
Syntax
Delphi
TnxBaseLocaleMappingTokenFilterDescriptor = class(TnxBaseTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseLocaleMappingTokenFilterDescriptor.

Group

Classes

Links
TnxBaseLocaleMappingTokenFilterDescriptor Methods, TnxBaseLocaleMappingTokenFilterDescriptor Properties, TnxBaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseLocaleMappingTokenFilterDescriptor Members

TnxBaseLocaleMappingTokenFilterDescriptor Members
TnxBaseLocaleMappingTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseLocaleMappingTokenFilterDescriptor.

Class

TnxBaseLocaleMappingTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
blmtfdGetFlags | This is blmtfdGetFlags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxBaseLocaleMappingTokenFilterDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseLocaleMappingTokenFilterDescriptor Methods

TnxBaseLocaleMappingTokenFilterDescriptor Methods
TnxBaseLocaleMappingTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxBaseLocaleMappingTokenFilterDescriptor Class

Protected Methods
Name | Description
blmtfdGetFlags | This is blmtfdGetFlags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
Public Methods
Name | Description
LoadFromReader | TnxBaseLocaleMappingTokenFilterDescriptor
SaveToWriter |
Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method

TnxBaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method
TnxBaseLocaleMappingTokenFilterDescriptor Class TnxBaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function blmtfdGetFlags: Cardinal; virtual; abstract;
Description

This is blmtfdGetFlags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.

Group

TnxBaseLocaleMappingTokenFilterDescriptor Methods

Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, TnxBaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseLocaleMappingTokenFilterDescriptor Methods


TnxBaseLocaleMappingTokenFilterDescriptor.LoadFromReader Method

TnxBaseLocaleMappingTokenFilterDescriptor.LoadFromReader Method
TnxBaseLocaleMappingTokenFilterDescriptor Class TnxBaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxBaseLocaleMappingTokenFilterDescriptor

Group

TnxBaseLocaleMappingTokenFilterDescriptor Methods

Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, TnxBaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseLocaleMappingTokenFilterDescriptor Methods


TnxBaseLocaleMappingTokenFilterDescriptor.SaveToWriter Method

TnxBaseLocaleMappingTokenFilterDescriptor.SaveToWriter Method
TnxBaseLocaleMappingTokenFilterDescriptor Class TnxBaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseLocaleMappingTokenFilterDescriptor Methods

Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, TnxBaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseLocaleMappingTokenFilterDescriptor Methods


TnxBaseLocaleMappingTokenFilterDescriptor Properties

TnxBaseLocaleMappingTokenFilterDescriptor Properties
TnxBaseLocaleMappingTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxBaseLocaleMappingTokenFilterDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, Legend, Public Properties


TnxBaseLocaleMappingTokenFilterDescriptor.Flags Property

TnxBaseLocaleMappingTokenFilterDescriptor.Flags Property
TnxBaseLocaleMappingTokenFilterDescriptor Class TnxBaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseLocaleMappingTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.

Group

TnxBaseLocaleMappingTokenFilterDescriptor Properties

Links
TnxBaseLocaleMappingTokenFilterDescriptor Class, TnxBaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseLocaleMappingTokenFilterDescriptor Properties


TnxBaseSeparatorTokenFilterDescriptor Class

TnxBaseSeparatorTokenFilterDescriptor Class
TnxBaseSeparatorTokenFilterDescriptor Fields TnxBaseSeparatorTokenFilterDescriptor Methods TnxBaseSeparatorTokenFilterDescriptor Properties TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseSeparatorTokenFilterDescriptor
Syntax
Delphi
TnxBaseSeparatorTokenFilterDescriptor = class(TnxBaseTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseSeparatorTokenFilterDescriptor.

Group

Classes

Links
TnxBaseSeparatorTokenFilterDescriptor Fields, TnxBaseSeparatorTokenFilterDescriptor Methods, TnxBaseSeparatorTokenFilterDescriptor Properties, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseSeparatorTokenFilterDescriptor Members

TnxBaseSeparatorTokenFilterDescriptor Members
TnxBaseSeparatorTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSeparatorTokenFilterDescriptor.

Class

TnxBaseSeparatorTokenFilterDescriptor Class

Protected Fields
Name | Description
bstfsSeparatorDistance | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bstfsSetSeparatorDistance | TnxBaseSeparatorTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
SeparatorDistance | This is SeparatorDistance, a member of class TnxBaseSeparatorTokenFilterDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseSeparatorTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseSeparatorTokenFilterDescriptor.Create Constructor

TnxBaseSeparatorTokenFilterDescriptor.Create Constructor
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxBaseSeparatorTokenFilterDescriptor Class

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Class


TnxBaseSeparatorTokenFilterDescriptor Fields

TnxBaseSeparatorTokenFilterDescriptor Fields
TnxBaseSeparatorTokenFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSeparatorTokenFilterDescriptor class are listed here.

Class

TnxBaseSeparatorTokenFilterDescriptor Class

Protected Fields
Name | Description
bstfsSeparatorDistance | private
Links
TnxBaseSeparatorTokenFilterDescriptor Class, Legend, Protected Fields


TnxBaseSeparatorTokenFilterDescriptor.bstfsSeparatorDistance Field

TnxBaseSeparatorTokenFilterDescriptor.bstfsSeparatorDistance Field
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Fields Send Feedback
Syntax
Delphi
bstfsSeparatorDistance: Integer;
Description

private

Group

TnxBaseSeparatorTokenFilterDescriptor Fields

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Fields


TnxBaseSeparatorTokenFilterDescriptor Methods

TnxBaseSeparatorTokenFilterDescriptor Methods
TnxBaseSeparatorTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSeparatorTokenFilterDescriptor class are listed here.

Class

TnxBaseSeparatorTokenFilterDescriptor Class

Protected Methods
Name | Description
bstfsSetSeparatorDistance | TnxBaseSeparatorTokenFilterDescriptor
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseSeparatorTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseSeparatorTokenFilterDescriptor.bstfsSetSeparatorDistance Method

TnxBaseSeparatorTokenFilterDescriptor.bstfsSetSeparatorDistance Method
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure bstfsSetSeparatorDistance(const Value: Integer);
Description

TnxBaseSeparatorTokenFilterDescriptor

Group

TnxBaseSeparatorTokenFilterDescriptor Methods

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Methods


TnxBaseSeparatorTokenFilterDescriptor.LoadFromReader Method

TnxBaseSeparatorTokenFilterDescriptor.LoadFromReader Method
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseSeparatorTokenFilterDescriptor Methods

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Methods


TnxBaseSeparatorTokenFilterDescriptor.SaveToWriter Method

TnxBaseSeparatorTokenFilterDescriptor.SaveToWriter Method
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseSeparatorTokenFilterDescriptor Methods

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Methods


TnxBaseSeparatorTokenFilterDescriptor Properties

TnxBaseSeparatorTokenFilterDescriptor Properties
TnxBaseSeparatorTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseSeparatorTokenFilterDescriptor class are listed here.

Class

TnxBaseSeparatorTokenFilterDescriptor Class

Public Properties
Name | Description
SeparatorDistance | This is SeparatorDistance, a member of class TnxBaseSeparatorTokenFilterDescriptor.
Links
TnxBaseSeparatorTokenFilterDescriptor Class, Legend, Public Properties


TnxBaseSeparatorTokenFilterDescriptor.SeparatorDistance Property

TnxBaseSeparatorTokenFilterDescriptor.SeparatorDistance Property
TnxBaseSeparatorTokenFilterDescriptor Class TnxBaseSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseSeparatorTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property SeparatorDistance: Integer;
Description

This is SeparatorDistance, a member of class TnxBaseSeparatorTokenFilterDescriptor.

Group

TnxBaseSeparatorTokenFilterDescriptor Properties

Links
TnxBaseSeparatorTokenFilterDescriptor Class, TnxBaseSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseSeparatorTokenFilterDescriptor Properties


TnxBaseTokenExtractorDescriptor Class

TnxBaseTokenExtractorDescriptor Class
TnxBaseTokenExtractorDescriptor Fields TnxBaseTokenExtractorDescriptor Methods TnxBaseTokenExtractorDescriptor Properties TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxBaseTokenExtractorDescriptor
Syntax
Delphi
TnxBaseTokenExtractorDescriptor = class(TnxBaseTokenSourceDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptor.

Group

Classes

Links
TnxBaseTokenExtractorDescriptor Fields, TnxBaseTokenExtractorDescriptor Methods, TnxBaseTokenExtractorDescriptor Properties, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseTokenExtractorDescriptor Members

TnxBaseTokenExtractorDescriptor Members
TnxBaseTokenExtractorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenExtractorDescriptor.

Class

TnxBaseTokenExtractorDescriptor Class

Protected Fields
Name | Description
btedTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
btedGetName |
btedGetTokenFilter |
btedGetTokenFilterCount |
btedGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxBaseTokenExtractorDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenExtractorDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseTokenExtractorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTokenExtractorDescriptor.Create Constructor

TnxBaseTokenExtractorDescriptor.Create Constructor
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxBaseTokenExtractorDescriptor Class

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Class


TnxBaseTokenExtractorDescriptor.Destroy Destructor

TnxBaseTokenExtractorDescriptor.Destroy Destructor
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseTokenExtractorDescriptor Class

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Class


TnxBaseTokenExtractorDescriptor Fields

TnxBaseTokenExtractorDescriptor Fields
TnxBaseTokenExtractorDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenExtractorDescriptor class are listed here.

Class

TnxBaseTokenExtractorDescriptor Class

Protected Fields
Name | Description
btedTokenFilterHub | private
Links
TnxBaseTokenExtractorDescriptor Class, Legend, Protected Fields


TnxBaseTokenExtractorDescriptor.btedTokenFilterHub Field

TnxBaseTokenExtractorDescriptor.btedTokenFilterHub Field
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Fields Send Feedback
Syntax
Delphi
btedTokenFilterHub: TnxTokenFilterHubDescriptor;
Description

private

Group

TnxBaseTokenExtractorDescriptor Fields

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Fields


TnxBaseTokenExtractorDescriptor Methods

TnxBaseTokenExtractorDescriptor Methods
TnxBaseTokenExtractorDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenExtractorDescriptor class are listed here.

Class

TnxBaseTokenExtractorDescriptor Class

Protected Methods
Name | Description
btedGetName |
btedGetTokenFilter |
btedGetTokenFilterCount |
btedGetTokenFilterName |
GetList |
Public Methods
Name | Description
AddTokenFilter | TnxBaseTokenExtractorDescriptor
CheckValid |
ClearTokenFilter |
IsEqual |
LoadFromReader |
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
SaveToWriter |
Links
TnxBaseTokenExtractorDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTokenExtractorDescriptor.AddTokenFilter Method

TnxBaseTokenExtractorDescriptor.AddTokenFilter Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenFilter(const aName: string = ''; aTokenFilterClass: TnxBaseTokenFilterDescriptorClass = nil): TnxBaseTokenFilterDescriptor;
Description

TnxBaseTokenExtractorDescriptor

Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.btedGetName Method

TnxBaseTokenExtractorDescriptor.btedGetName Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function btedGetName: string;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.btedGetTokenFilter Method

TnxBaseTokenExtractorDescriptor.btedGetTokenFilter Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function btedGetTokenFilter(aInx: Integer): TnxBaseTokenFilterDescriptor;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.btedGetTokenFilterCount Method

TnxBaseTokenExtractorDescriptor.btedGetTokenFilterCount Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function btedGetTokenFilterCount: Integer;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.btedGetTokenFilterName Method

TnxBaseTokenExtractorDescriptor.btedGetTokenFilterName Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function btedGetTokenFilterName(aInx: Integer): string;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.CheckValid Method

TnxBaseTokenExtractorDescriptor.CheckValid Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.ClearTokenFilter Method

TnxBaseTokenExtractorDescriptor.ClearTokenFilter Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearTokenFilter;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.GetList Method

TnxBaseTokenExtractorDescriptor.GetList Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.IsEqual Method

TnxBaseTokenExtractorDescriptor.IsEqual Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.LoadFromReader Method

TnxBaseTokenExtractorDescriptor.LoadFromReader Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


RemoveTokenFilter Method

RemoveTokenFilter Method
TnxBaseTokenExtractorDescriptor Methods Send Feedback

This is the overview for the RemoveTokenFilter method overload.

Overload List
Name | Description
TnxBaseTokenExtractorDescriptor.RemoveTokenFilter (Integer) |
TnxBaseTokenExtractorDescriptor.RemoveTokenFilter (string) |
TnxBaseTokenExtractorDescriptor.RemoveTokenFilter (TnxBaseTokenFilterDescriptor) |
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (Integer)

TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (Integer)
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aIndex: Integer); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)

TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aDescriptor: TnxBaseTokenFilterDescriptor); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (string)

TnxBaseTokenExtractorDescriptor.RemoveTokenFilter Method (string)
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(const aName: string); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenExtractorDescriptor.SaveToWriter Method

TnxBaseTokenExtractorDescriptor.SaveToWriter Method
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTokenExtractorDescriptor Methods

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Methods


TnxBaseTokenExtractorDescriptor Properties

TnxBaseTokenExtractorDescriptor Properties
TnxBaseTokenExtractorDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenExtractorDescriptor class are listed here.

Class

TnxBaseTokenExtractorDescriptor Class

Public Properties
Name | Description
Name |
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenExtractorDescriptor.
Links
TnxBaseTokenExtractorDescriptor Class, Legend, Public Properties


TnxBaseTokenExtractorDescriptor.Name Property

TnxBaseTokenExtractorDescriptor.Name Property
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Group

TnxBaseTokenExtractorDescriptor Properties

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Properties


TnxBaseTokenExtractorDescriptor.TokenFilter Property

TnxBaseTokenExtractorDescriptor.TokenFilter Property
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilter [aInx : Integer]: TnxBaseTokenFilterDescriptor;
Description

This is TokenFilter, a member of class TnxBaseTokenExtractorDescriptor.

Group

TnxBaseTokenExtractorDescriptor Properties

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Properties


TnxBaseTokenExtractorDescriptor.TokenFilterCount Property

TnxBaseTokenExtractorDescriptor.TokenFilterCount Property
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterCount: Integer;
Description

This is TokenFilterCount, a member of class TnxBaseTokenExtractorDescriptor.

Group

TnxBaseTokenExtractorDescriptor Properties

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Properties


TnxBaseTokenExtractorDescriptor.TokenFilterHub Property

TnxBaseTokenExtractorDescriptor.TokenFilterHub Property
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterHub: TnxTokenFilterHubDescriptor;
Description

Filter

Group

TnxBaseTokenExtractorDescriptor Properties

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Properties


TnxBaseTokenExtractorDescriptor.TokenFilterName Property

TnxBaseTokenExtractorDescriptor.TokenFilterName Property
TnxBaseTokenExtractorDescriptor Class TnxBaseTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterName [aInx : Integer]: string;
Description

This is TokenFilterName, a member of class TnxBaseTokenExtractorDescriptor.

Group

TnxBaseTokenExtractorDescriptor Properties

Links
TnxBaseTokenExtractorDescriptor Class, TnxBaseTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenExtractorDescriptor Properties


TnxBaseTokenFilterDescriptor Class

TnxBaseTokenFilterDescriptor Class
TnxBaseTokenFilterDescriptor Methods TnxBaseTokenFilterDescriptor Properties TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptornxsdDataDictionaryFulltext_TnxBaseTokenFilterDescriptor
Syntax
Delphi
TnxBaseTokenFilterDescriptor = class(TnxBaseTokenSourceDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptor.

Group

Classes

Links
TnxBaseTokenFilterDescriptor Methods, TnxBaseTokenFilterDescriptor Properties, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseTokenFilterDescriptor Members

TnxBaseTokenFilterDescriptor Members
TnxBaseTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenFilterDescriptor.

Class

TnxBaseTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTokenFilterDescriptor Methods

TnxBaseTokenFilterDescriptor Methods
TnxBaseTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenFilterDescriptor class are listed here.

Class

TnxBaseTokenFilterDescriptor Class

Protected Methods
Name | Description
btfdGetName | private TnxBaseTokenFilterDescriptor
GetList |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTokenFilterDescriptor.btfdGetName Method

TnxBaseTokenFilterDescriptor.btfdGetName Method
TnxBaseTokenFilterDescriptor Class TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function btfdGetName: string;
Description

private

TnxBaseTokenFilterDescriptor

Group

TnxBaseTokenFilterDescriptor Methods

Links
TnxBaseTokenFilterDescriptor Class, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenFilterDescriptor Methods


TnxBaseTokenFilterDescriptor.GetList Method

TnxBaseTokenFilterDescriptor.GetList Method
TnxBaseTokenFilterDescriptor Class TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenFilterDescriptor Methods

Links
TnxBaseTokenFilterDescriptor Class, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenFilterDescriptor Methods


TnxBaseTokenFilterDescriptor.LoadFromReader Method

TnxBaseTokenFilterDescriptor.LoadFromReader Method
TnxBaseTokenFilterDescriptor Class TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseTokenFilterDescriptor Methods

Links
TnxBaseTokenFilterDescriptor Class, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenFilterDescriptor Methods


TnxBaseTokenFilterDescriptor.SaveToWriter Method

TnxBaseTokenFilterDescriptor.SaveToWriter Method
TnxBaseTokenFilterDescriptor Class TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTokenFilterDescriptor Methods

Links
TnxBaseTokenFilterDescriptor Class, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenFilterDescriptor Methods


TnxBaseTokenFilterDescriptor Properties

TnxBaseTokenFilterDescriptor Properties
TnxBaseTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenFilterDescriptor class are listed here.

Class

TnxBaseTokenFilterDescriptor Class

Public Properties
Name | Description
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Links
TnxBaseTokenFilterDescriptor Class, Legend, Public Properties


TnxBaseTokenFilterDescriptor.Name Property

TnxBaseTokenFilterDescriptor.Name Property
TnxBaseTokenFilterDescriptor Class TnxBaseTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is Name, a member of class TnxBaseTokenFilterDescriptor.

Group

TnxBaseTokenFilterDescriptor Properties

Links
TnxBaseTokenFilterDescriptor Class, TnxBaseTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenFilterDescriptor Properties


TnxBaseTokenIndexDescriptor Class

TnxBaseTokenIndexDescriptor Class
TnxBaseTokenIndexDescriptor Fields TnxBaseTokenIndexDescriptor Methods TnxBaseTokenIndexDescriptor Properties TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBaseTokenIndexDescriptor
Syntax
Delphi
TnxBaseTokenIndexDescriptor = class(TnxNumberedFulltextIndexDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptor.

Group

Classes

Links
TnxBaseTokenIndexDescriptor Fields, TnxBaseTokenIndexDescriptor Methods, TnxBaseTokenIndexDescriptor Properties, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseTokenIndexDescriptor Members

TnxBaseTokenIndexDescriptor Members
TnxBaseTokenIndexDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenIndexDescriptor.

Class

TnxBaseTokenIndexDescriptor Class

Protected Fields
Name | Description
btidTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
btidGetName |
btidGetTokenFilter |
btidGetTokenFilterCount |
btidGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxBaseTokenIndexDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseTokenIndexDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTokenIndexDescriptor.Create Constructor

TnxBaseTokenIndexDescriptor.Create Constructor
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxBaseTokenIndexDescriptor Class

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Class


TnxBaseTokenIndexDescriptor.Destroy Destructor

TnxBaseTokenIndexDescriptor.Destroy Destructor
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseTokenIndexDescriptor Class

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Class


TnxBaseTokenIndexDescriptor Fields

TnxBaseTokenIndexDescriptor Fields
TnxBaseTokenIndexDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenIndexDescriptor class are listed here.

Class

TnxBaseTokenIndexDescriptor Class

Protected Fields
Name | Description
btidTokenFilterHub | private
Links
TnxBaseTokenIndexDescriptor Class, Legend, Protected Fields


TnxBaseTokenIndexDescriptor.btidTokenFilterHub Field

TnxBaseTokenIndexDescriptor.btidTokenFilterHub Field
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
btidTokenFilterHub: TnxTokenFilterHubDescriptor;
Description

private

Group

TnxBaseTokenIndexDescriptor Fields

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Fields


TnxBaseTokenIndexDescriptor Methods

TnxBaseTokenIndexDescriptor Methods
TnxBaseTokenIndexDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenIndexDescriptor class are listed here.

Class

TnxBaseTokenIndexDescriptor Class

Protected Methods
Name | Description
btidGetName |
btidGetTokenFilter |
btidGetTokenFilterCount |
btidGetTokenFilterName |
GetList |
Public Methods
Name | Description
AddTokenFilter | TnxBaseTokenIndexDescriptor
CheckValid |
ClearTokenFilter |
IsEqual |
LoadFromReader |
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
SaveToWriter |
Links
TnxBaseTokenIndexDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTokenIndexDescriptor.AddTokenFilter Method

TnxBaseTokenIndexDescriptor.AddTokenFilter Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenFilter(const aName: string = ''; aTokenFilterClass: TnxBaseTokenFilterDescriptorClass = nil): TnxBaseTokenFilterDescriptor;
Description

TnxBaseTokenIndexDescriptor

Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.btidGetName Method

TnxBaseTokenIndexDescriptor.btidGetName Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function btidGetName: string;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.btidGetTokenFilter Method

TnxBaseTokenIndexDescriptor.btidGetTokenFilter Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function btidGetTokenFilter(aInx: Integer): TnxBaseTokenFilterDescriptor;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.btidGetTokenFilterCount Method

TnxBaseTokenIndexDescriptor.btidGetTokenFilterCount Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function btidGetTokenFilterCount: Integer;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.btidGetTokenFilterName Method

TnxBaseTokenIndexDescriptor.btidGetTokenFilterName Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function btidGetTokenFilterName(aInx: Integer): string;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.CheckValid Method

TnxBaseTokenIndexDescriptor.CheckValid Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.ClearTokenFilter Method

TnxBaseTokenIndexDescriptor.ClearTokenFilter Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearTokenFilter;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.GetList Method

TnxBaseTokenIndexDescriptor.GetList Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.IsEqual Method

TnxBaseTokenIndexDescriptor.IsEqual Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.LoadFromReader Method

TnxBaseTokenIndexDescriptor.LoadFromReader Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


RemoveTokenFilter Method

RemoveTokenFilter Method
TnxBaseTokenIndexDescriptor Methods Send Feedback

This is the overview for the RemoveTokenFilter method overload.

Overload List
Name | Description
TnxBaseTokenIndexDescriptor.RemoveTokenFilter (Integer) |
TnxBaseTokenIndexDescriptor.RemoveTokenFilter (string) |
TnxBaseTokenIndexDescriptor.RemoveTokenFilter (TnxBaseTokenFilterDescriptor) |
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (Integer)

TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (Integer)
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aIndex: Integer); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)

TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aDescriptor: TnxBaseTokenFilterDescriptor); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (string)

TnxBaseTokenIndexDescriptor.RemoveTokenFilter Method (string)
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(const aName: string); overload;
Group

RemoveTokenFilter Method

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxBaseTokenIndexDescriptor.SaveToWriter Method

TnxBaseTokenIndexDescriptor.SaveToWriter Method
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTokenIndexDescriptor Methods

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Methods


TnxBaseTokenIndexDescriptor Properties

TnxBaseTokenIndexDescriptor Properties
TnxBaseTokenIndexDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenIndexDescriptor class are listed here.

Class

TnxBaseTokenIndexDescriptor Class

Public Properties
Name | Description
Name |
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.
Links
TnxBaseTokenIndexDescriptor Class, Legend, Public Properties


TnxBaseTokenIndexDescriptor.Name Property

TnxBaseTokenIndexDescriptor.Name Property
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Group

TnxBaseTokenIndexDescriptor Properties

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Properties


TnxBaseTokenIndexDescriptor.TokenFilter Property

TnxBaseTokenIndexDescriptor.TokenFilter Property
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilter [aInx : Integer]: TnxBaseTokenFilterDescriptor;
Description

This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.

Group

TnxBaseTokenIndexDescriptor Properties

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Properties


TnxBaseTokenIndexDescriptor.TokenFilterCount Property

TnxBaseTokenIndexDescriptor.TokenFilterCount Property
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterCount: Integer;
Description

This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.

Group

TnxBaseTokenIndexDescriptor Properties

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Properties


TnxBaseTokenIndexDescriptor.TokenFilterHub Property

TnxBaseTokenIndexDescriptor.TokenFilterHub Property
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterHub: TnxTokenFilterHubDescriptor;
Description

Filter

Group

TnxBaseTokenIndexDescriptor Properties

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Properties


TnxBaseTokenIndexDescriptor.TokenFilterName Property

TnxBaseTokenIndexDescriptor.TokenFilterName Property
TnxBaseTokenIndexDescriptor Class TnxBaseTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterName [aInx : Integer]: string;
Description

This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.

Group

TnxBaseTokenIndexDescriptor Properties

Links
TnxBaseTokenIndexDescriptor Class, TnxBaseTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenIndexDescriptor Properties


TnxBaseTokenSourceDescriptor Class

TnxBaseTokenSourceDescriptor Class
TnxBaseTokenSourceDescriptor Methods TnxBaseTokenSourceDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptornxsdDataDictionaryFulltext_TnxBaseTokenSourceDescriptor
Syntax
Delphi
TnxBaseTokenSourceDescriptor = class(TnxNumberedFulltextIndexDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBaseTokenSourceDescriptor.

Group

Classes

Links
TnxBaseTokenSourceDescriptor Methods, TnxBaseTokenSourceDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBaseTokenSourceDescriptor Members

TnxBaseTokenSourceDescriptor Members
TnxBaseTokenSourceDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenSourceDescriptor.

Class

TnxBaseTokenSourceDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxBaseTokenSourceDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBaseTokenSourceDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTokenSourceDescriptor Methods

TnxBaseTokenSourceDescriptor Methods
TnxBaseTokenSourceDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxBaseTokenSourceDescriptor class are listed here.

Class

TnxBaseTokenSourceDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxBaseTokenSourceDescriptor
SaveToWriter |
Links
TnxBaseTokenSourceDescriptor Class, Legend, Public Methods


TnxBaseTokenSourceDescriptor.LoadFromReader Method

TnxBaseTokenSourceDescriptor.LoadFromReader Method
TnxBaseTokenSourceDescriptor Class TnxBaseTokenSourceDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxBaseTokenSourceDescriptor

Group

TnxBaseTokenSourceDescriptor Methods

Links
TnxBaseTokenSourceDescriptor Class, TnxBaseTokenSourceDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenSourceDescriptor Methods


TnxBaseTokenSourceDescriptor.SaveToWriter Method

TnxBaseTokenSourceDescriptor.SaveToWriter Method
TnxBaseTokenSourceDescriptor Class TnxBaseTokenSourceDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBaseTokenSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTokenSourceDescriptor Methods

Links
TnxBaseTokenSourceDescriptor Class, TnxBaseTokenSourceDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBaseTokenSourceDescriptor Methods


TnxBitArrayTokenIndexDescriptor Class

TnxBitArrayTokenIndexDescriptor Class
TnxBitArrayTokenIndexDescriptor Fields TnxBitArrayTokenIndexDescriptor Methods TnxBitArrayTokenIndexDescriptor Properties TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenIndexDescriptor
Syntax
Delphi
TnxBitArrayTokenIndexDescriptor = class(TnxBaseTokenIndexDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptor.

Group

Classes

Links
TnxBitArrayTokenIndexDescriptor Fields, TnxBitArrayTokenIndexDescriptor Methods, TnxBitArrayTokenIndexDescriptor Properties, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBitArrayTokenIndexDescriptor Members

TnxBitArrayTokenIndexDescriptor Members
TnxBitArrayTokenIndexDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBitArrayTokenIndexDescriptor.

Class

TnxBitArrayTokenIndexDescriptor Class

Protected Fields
Name | Description
batidBitArrayStorageHandler | private
batidMaxTokenSize | This is batidMaxTokenSize, a member of class TnxBitArrayTokenIndexDescriptor.
batidPerFieldIndex | This is batidPerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.
batidPerLocationIndex | This is batidPerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.
batidSegmentIndex | This is batidSegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.
btidTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
batidAddIndex |
batidBuildIndexName |
batidGetIndex |
batidGetIndexDescriptor |
batidGetReverseIndexDescriptor |
batidRemoveIndex |
batidSetMaxTokenSize |
batidSetPerFieldIndex |
batidSetPerLocationIndex |
batidSetSegmentIndex |
btidGetName |
btidGetTokenFilter |
btidGetTokenFilterCount |
btidGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddBitArrayStorageHandler | bit array storage handler TnxBitArrayTokenIndexDescriptor
AddIndex | index (used for token indexing)
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddReverseIndex | reverse index (used for token indexing to speed up )
AddTokenFilter | TnxBaseTokenIndexDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveBitArrayStorageHandler |
RemoveIndex |
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveReverseIndex |
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BitArrayStorageHandler | This is BitArrayStorageHandler, a member of class TnxBitArrayTokenIndexDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IndexDescriptor | This is IndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.
LocaleDescriptor | This property returns the associated Locale Descriptor.
MaxTokenSize | general properties
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
PerFieldIndex | This is PerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.
PerLocationIndex | This is PerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.
ReverseIndexDescriptor | This is ReverseIndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.
SegmentIndex | This is SegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxBitArrayTokenIndexDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBitArrayTokenIndexDescriptor.Create Constructor

TnxBitArrayTokenIndexDescriptor.Create Constructor
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxBitArrayTokenIndexDescriptor Class

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Class


TnxBitArrayTokenIndexDescriptor.Destroy Destructor

TnxBitArrayTokenIndexDescriptor.Destroy Destructor
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBitArrayTokenIndexDescriptor Class

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Class


TnxBitArrayTokenIndexDescriptor Fields

TnxBitArrayTokenIndexDescriptor Fields
TnxBitArrayTokenIndexDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBitArrayTokenIndexDescriptor class are listed here.

Class

TnxBitArrayTokenIndexDescriptor Class

Protected Fields
Name | Description
batidBitArrayStorageHandler | private
batidMaxTokenSize | This is batidMaxTokenSize, a member of class TnxBitArrayTokenIndexDescriptor.
batidPerFieldIndex | This is batidPerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.
batidPerLocationIndex | This is batidPerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.
batidSegmentIndex | This is batidSegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.
Links
TnxBitArrayTokenIndexDescriptor Class, Legend, Protected Fields


TnxBitArrayTokenIndexDescriptor.batidBitArrayStorageHandler Field

TnxBitArrayTokenIndexDescriptor.batidBitArrayStorageHandler Field
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
batidBitArrayStorageHandler: TnxBaseBitArrayStorageHandlerDescriptor;
Description

private

Group

TnxBitArrayTokenIndexDescriptor Fields

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Fields


TnxBitArrayTokenIndexDescriptor.batidMaxTokenSize Field

TnxBitArrayTokenIndexDescriptor.batidMaxTokenSize Field
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
batidMaxTokenSize: Integer;
Description

This is batidMaxTokenSize, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Fields

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Fields


TnxBitArrayTokenIndexDescriptor.batidPerFieldIndex Field

TnxBitArrayTokenIndexDescriptor.batidPerFieldIndex Field
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
batidPerFieldIndex: Boolean;
Description

This is batidPerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Fields

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Fields


TnxBitArrayTokenIndexDescriptor.batidPerLocationIndex Field

TnxBitArrayTokenIndexDescriptor.batidPerLocationIndex Field
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
batidPerLocationIndex: Boolean;
Description

This is batidPerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Fields

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Fields


TnxBitArrayTokenIndexDescriptor.batidSegmentIndex Field

TnxBitArrayTokenIndexDescriptor.batidSegmentIndex Field
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
batidSegmentIndex: Boolean;
Description

This is batidSegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Fields

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Fields


TnxBitArrayTokenIndexDescriptor Methods

TnxBitArrayTokenIndexDescriptor Methods
TnxBitArrayTokenIndexDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBitArrayTokenIndexDescriptor class are listed here.

Class

TnxBitArrayTokenIndexDescriptor Class

Protected Methods
Name | Description
batidAddIndex |
batidBuildIndexName |
batidGetIndex |
batidGetIndexDescriptor |
batidGetReverseIndexDescriptor |
batidRemoveIndex |
batidSetMaxTokenSize |
batidSetPerFieldIndex |
batidSetPerLocationIndex |
batidSetSegmentIndex |
Public Methods
Name | Description
AddBitArrayStorageHandler | bit array storage handler TnxBitArrayTokenIndexDescriptor
AddIndex | index (used for token indexing)
AddReverseIndex | reverse index (used for token indexing to speed up )
CheckValid |
IsEqual |
LoadFromReader |
RemoveBitArrayStorageHandler |
RemoveIndex |
RemoveReverseIndex |
SaveToWriter |
Links
TnxBitArrayTokenIndexDescriptor Class, Legend, Protected Methods, Public Methods


TnxBitArrayTokenIndexDescriptor.AddBitArrayStorageHandler Method

TnxBitArrayTokenIndexDescriptor.AddBitArrayStorageHandler Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddBitArrayStorageHandler(aHandlerClass: TnxBaseBitArrayStorageHandlerDescriptorClass = nil): TnxBaseBitArrayStorageHandlerDescriptor;
Description

bit array storage handler

TnxBitArrayTokenIndexDescriptor

Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.AddIndex Method

TnxBitArrayTokenIndexDescriptor.AddIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddIndex(aFileNumber: Integer = 0; aKeyClass: TnxBitArrayTokenKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor;
Description

index (used for token indexing)

Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.AddReverseIndex Method

TnxBitArrayTokenIndexDescriptor.AddReverseIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddReverseIndex(aFileNumber: Integer = 0; aKeyClass: TnxBitArrayTokenKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor;
Description

reverse index (used for token indexing to speed up )

Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidAddIndex Method

TnxBitArrayTokenIndexDescriptor.batidAddIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function batidAddIndex(const aName: string; aFileNumber: Integer = 0; aKeyClass: TnxBitArrayTokenKeyDescriptorClass = nil; aIndexClass: TnxIndexDescriptorClass = nil): TnxIndexDescriptor;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidBuildIndexName Method

TnxBitArrayTokenIndexDescriptor.batidBuildIndexName Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function batidBuildIndexName(const aName: string): string;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidGetIndex Method

TnxBitArrayTokenIndexDescriptor.batidGetIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function batidGetIndex(const aName: string): TnxIndexDescriptor;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidGetIndexDescriptor Method

TnxBitArrayTokenIndexDescriptor.batidGetIndexDescriptor Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function batidGetIndexDescriptor: TnxIndexDescriptor;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidGetReverseIndexDescriptor Method

TnxBitArrayTokenIndexDescriptor.batidGetReverseIndexDescriptor Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function batidGetReverseIndexDescriptor: TnxIndexDescriptor;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidRemoveIndex Method

TnxBitArrayTokenIndexDescriptor.batidRemoveIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure batidRemoveIndex(const aName: string);
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidSetMaxTokenSize Method

TnxBitArrayTokenIndexDescriptor.batidSetMaxTokenSize Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure batidSetMaxTokenSize(const Value: Integer);
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidSetPerFieldIndex Method

TnxBitArrayTokenIndexDescriptor.batidSetPerFieldIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure batidSetPerFieldIndex(const Value: Boolean);
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidSetPerLocationIndex Method

TnxBitArrayTokenIndexDescriptor.batidSetPerLocationIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure batidSetPerLocationIndex(const Value: Boolean);
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.batidSetSegmentIndex Method

TnxBitArrayTokenIndexDescriptor.batidSetSegmentIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure batidSetSegmentIndex(const Value: Boolean);
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.CheckValid Method

TnxBitArrayTokenIndexDescriptor.CheckValid Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.IsEqual Method

TnxBitArrayTokenIndexDescriptor.IsEqual Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.LoadFromReader Method

TnxBitArrayTokenIndexDescriptor.LoadFromReader Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.RemoveBitArrayStorageHandler Method

TnxBitArrayTokenIndexDescriptor.RemoveBitArrayStorageHandler Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveBitArrayStorageHandler;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.RemoveIndex Method

TnxBitArrayTokenIndexDescriptor.RemoveIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveIndex;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.RemoveReverseIndex Method

TnxBitArrayTokenIndexDescriptor.RemoveReverseIndex Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveReverseIndex;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor.SaveToWriter Method

TnxBitArrayTokenIndexDescriptor.SaveToWriter Method
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBitArrayTokenIndexDescriptor Methods

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Methods


TnxBitArrayTokenIndexDescriptor Properties

TnxBitArrayTokenIndexDescriptor Properties
TnxBitArrayTokenIndexDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBitArrayTokenIndexDescriptor class are listed here.

Class

TnxBitArrayTokenIndexDescriptor Class

Public Properties
Name | Description
BitArrayStorageHandler | This is BitArrayStorageHandler, a member of class TnxBitArrayTokenIndexDescriptor.
IndexDescriptor | This is IndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.
MaxTokenSize | general properties
PerFieldIndex | This is PerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.
PerLocationIndex | This is PerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.
ReverseIndexDescriptor | This is ReverseIndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.
SegmentIndex | This is SegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.
Links
TnxBitArrayTokenIndexDescriptor Class, Legend, Public Properties


TnxBitArrayTokenIndexDescriptor.BitArrayStorageHandler Property

TnxBitArrayTokenIndexDescriptor.BitArrayStorageHandler Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property BitArrayStorageHandler: TnxBaseBitArrayStorageHandlerDescriptor;
Description

This is BitArrayStorageHandler, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.IndexDescriptor Property

TnxBitArrayTokenIndexDescriptor.IndexDescriptor Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property IndexDescriptor: TnxIndexDescriptor;
Description

This is IndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.MaxTokenSize Property

TnxBitArrayTokenIndexDescriptor.MaxTokenSize Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property MaxTokenSize: Integer;
Description

general properties

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.PerFieldIndex Property

TnxBitArrayTokenIndexDescriptor.PerFieldIndex Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property PerFieldIndex: Boolean;
Description

This is PerFieldIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.PerLocationIndex Property

TnxBitArrayTokenIndexDescriptor.PerLocationIndex Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property PerLocationIndex: Boolean;
Description

This is PerLocationIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.ReverseIndexDescriptor Property

TnxBitArrayTokenIndexDescriptor.ReverseIndexDescriptor Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property ReverseIndexDescriptor: TnxIndexDescriptor;
Description

This is ReverseIndexDescriptor, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenIndexDescriptor.SegmentIndex Property

TnxBitArrayTokenIndexDescriptor.SegmentIndex Property
TnxBitArrayTokenIndexDescriptor Class TnxBitArrayTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property SegmentIndex: Boolean;
Description

This is SegmentIndex, a member of class TnxBitArrayTokenIndexDescriptor.

Group

TnxBitArrayTokenIndexDescriptor Properties

Links
TnxBitArrayTokenIndexDescriptor Class, TnxBitArrayTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenIndexDescriptor Properties


TnxBitArrayTokenKeyDescriptor Class

TnxBitArrayTokenKeyDescriptor Class
TnxBitArrayTokenKeyDescriptor Fields TnxBitArrayTokenKeyDescriptor Methods TnxBitArrayTokenKeyDescriptor Properties TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptornxsdDataDictionaryFulltext_TnxBitArrayTokenKeyDescriptor
Syntax
Delphi
TnxBitArrayTokenKeyDescriptor = class(TnxBaseKeyDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptor.

Group

Classes

Links
TnxBitArrayTokenKeyDescriptor Fields, TnxBitArrayTokenKeyDescriptor Methods, TnxBitArrayTokenKeyDescriptor Properties, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxBitArrayTokenKeyDescriptor Members

TnxBitArrayTokenKeyDescriptor Members
TnxBitArrayTokenKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBitArrayTokenKeyDescriptor.

Class

TnxBitArrayTokenKeyDescriptor Class

Protected Fields
Name | Description
batkdFlags | This is batkdFlags, a member of class TnxBitArrayTokenKeyDescriptor.
batkdLocale | This is batkdLocale, a member of class TnxBitArrayTokenKeyDescriptor.
batkdMaxTokenSize | private
batkdPerFieldIndex | This is batkdPerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.
batkdReverse | This is batkdReverse, a member of class TnxBitArrayTokenKeyDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
batkdSetFlags |
batkdSetLocale |
batkdSetMaxTokenSize |
batkdSetPerFieldIndex |
batkdSetReverse |
bkdGetKeyLen | TnxBitArrayTokenKeyDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBitArrayTokenKeyDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
KeyLen | This property returns the length of the created keys.
Locale | This is Locale, a member of class TnxBitArrayTokenKeyDescriptor.
MaxTokenSize | This is MaxTokenSize, a member of class TnxBitArrayTokenKeyDescriptor.
PerFieldIndex | This is PerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.
Reverse | This is Reverse, a member of class TnxBitArrayTokenKeyDescriptor.
Links
TnxBitArrayTokenKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxBitArrayTokenKeyDescriptor.Create Constructor

TnxBitArrayTokenKeyDescriptor.Create Constructor
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxBitArrayTokenKeyDescriptor Class

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Class


TnxBitArrayTokenKeyDescriptor Fields

TnxBitArrayTokenKeyDescriptor Fields
TnxBitArrayTokenKeyDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBitArrayTokenKeyDescriptor class are listed here.

Class

TnxBitArrayTokenKeyDescriptor Class

Protected Fields
Name | Description
batkdFlags | This is batkdFlags, a member of class TnxBitArrayTokenKeyDescriptor.
batkdLocale | This is batkdLocale, a member of class TnxBitArrayTokenKeyDescriptor.
batkdMaxTokenSize | private
batkdPerFieldIndex | This is batkdPerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.
batkdReverse | This is batkdReverse, a member of class TnxBitArrayTokenKeyDescriptor.
Links
TnxBitArrayTokenKeyDescriptor Class, Legend, Protected Fields


TnxBitArrayTokenKeyDescriptor.batkdFlags Field

TnxBitArrayTokenKeyDescriptor.batkdFlags Field
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
batkdFlags: Cardinal;
Description

This is batkdFlags, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Fields

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Fields


TnxBitArrayTokenKeyDescriptor.batkdLocale Field

TnxBitArrayTokenKeyDescriptor.batkdLocale Field
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
batkdLocale: LCID;
Description

This is batkdLocale, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Fields

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Fields


TnxBitArrayTokenKeyDescriptor.batkdMaxTokenSize Field

TnxBitArrayTokenKeyDescriptor.batkdMaxTokenSize Field
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
batkdMaxTokenSize: Integer;
Description

private

Group

TnxBitArrayTokenKeyDescriptor Fields

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Fields


TnxBitArrayTokenKeyDescriptor.batkdPerFieldIndex Field

TnxBitArrayTokenKeyDescriptor.batkdPerFieldIndex Field
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
batkdPerFieldIndex: Boolean;
Description

This is batkdPerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Fields

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Fields


TnxBitArrayTokenKeyDescriptor.batkdReverse Field

TnxBitArrayTokenKeyDescriptor.batkdReverse Field
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
batkdReverse: Boolean;
Description

This is batkdReverse, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Fields

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Fields


TnxBitArrayTokenKeyDescriptor Methods

TnxBitArrayTokenKeyDescriptor Methods
TnxBitArrayTokenKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBitArrayTokenKeyDescriptor class are listed here.

Class

TnxBitArrayTokenKeyDescriptor Class

Protected Methods
Name | Description
batkdSetFlags |
batkdSetLocale |
batkdSetMaxTokenSize |
batkdSetPerFieldIndex |
batkdSetReverse |
bkdGetKeyLen | TnxBitArrayTokenKeyDescriptor
Public Methods
Name | Description
CanContainNulls |
LoadFromReader |
SaveToWriter |
Links
TnxBitArrayTokenKeyDescriptor Class, Legend, Protected Methods, Public Methods


TnxBitArrayTokenKeyDescriptor.batkdSetFlags Method

TnxBitArrayTokenKeyDescriptor.batkdSetFlags Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure batkdSetFlags(const Value: Cardinal);
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.batkdSetLocale Method

TnxBitArrayTokenKeyDescriptor.batkdSetLocale Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure batkdSetLocale(const Value: LCID);
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.batkdSetMaxTokenSize Method

TnxBitArrayTokenKeyDescriptor.batkdSetMaxTokenSize Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure batkdSetMaxTokenSize(const Value: Integer);
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.batkdSetPerFieldIndex Method

TnxBitArrayTokenKeyDescriptor.batkdSetPerFieldIndex Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure batkdSetPerFieldIndex(const Value: Boolean);
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.batkdSetReverse Method

TnxBitArrayTokenKeyDescriptor.batkdSetReverse Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure batkdSetReverse(const Value: Boolean);
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.bkdGetKeyLen Method

TnxBitArrayTokenKeyDescriptor.bkdGetKeyLen Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; override;
Description

TnxBitArrayTokenKeyDescriptor

Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.CanContainNulls Method

TnxBitArrayTokenKeyDescriptor.CanContainNulls Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; override;
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.LoadFromReader Method

TnxBitArrayTokenKeyDescriptor.LoadFromReader Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor.SaveToWriter Method

TnxBitArrayTokenKeyDescriptor.SaveToWriter Method
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBitArrayTokenKeyDescriptor Methods

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Methods


TnxBitArrayTokenKeyDescriptor Properties

TnxBitArrayTokenKeyDescriptor Properties
TnxBitArrayTokenKeyDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBitArrayTokenKeyDescriptor class are listed here.

Class

TnxBitArrayTokenKeyDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxBitArrayTokenKeyDescriptor.
Locale | This is Locale, a member of class TnxBitArrayTokenKeyDescriptor.
MaxTokenSize | This is MaxTokenSize, a member of class TnxBitArrayTokenKeyDescriptor.
PerFieldIndex | This is PerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.
Reverse | This is Reverse, a member of class TnxBitArrayTokenKeyDescriptor.
Links
TnxBitArrayTokenKeyDescriptor Class, Legend, Public Properties


TnxBitArrayTokenKeyDescriptor.Flags Property

TnxBitArrayTokenKeyDescriptor.Flags Property
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Properties

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Properties


TnxBitArrayTokenKeyDescriptor.Locale Property

TnxBitArrayTokenKeyDescriptor.Locale Property
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property Locale: LCID;
Description

This is Locale, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Properties

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Properties


TnxBitArrayTokenKeyDescriptor.MaxTokenSize Property

TnxBitArrayTokenKeyDescriptor.MaxTokenSize Property
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property MaxTokenSize: Integer;
Description

This is MaxTokenSize, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Properties

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Properties


TnxBitArrayTokenKeyDescriptor.PerFieldIndex Property

TnxBitArrayTokenKeyDescriptor.PerFieldIndex Property
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property PerFieldIndex: Boolean;
Description

This is PerFieldIndex, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Properties

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Properties


TnxBitArrayTokenKeyDescriptor.Reverse Property

TnxBitArrayTokenKeyDescriptor.Reverse Property
TnxBitArrayTokenKeyDescriptor Class TnxBitArrayTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxBitArrayTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property Reverse: Boolean;
Description

This is Reverse, a member of class TnxBitArrayTokenKeyDescriptor.

Group

TnxBitArrayTokenKeyDescriptor Properties

Links
TnxBitArrayTokenKeyDescriptor Class, TnxBitArrayTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxBitArrayTokenKeyDescriptor Properties


TnxCategorySeparatorTokenFilterDescriptor Class

TnxCategorySeparatorTokenFilterDescriptor Class
TnxCategorySeparatorTokenFilterDescriptor Methods TnxCategorySeparatorTokenFilterDescriptor Properties TnxCategorySeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCategorySeparatorTokenFilterDescriptor
Syntax
Delphi
TnxCategorySeparatorTokenFilterDescriptor = class(TnxBaseSeparatorTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxCategorySeparatorTokenFilterDescriptor.

Group

Classes

Links
TnxCategorySeparatorTokenFilterDescriptor Methods, TnxCategorySeparatorTokenFilterDescriptor Properties, TnxCategorySeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxCategorySeparatorTokenFilterDescriptor Members

TnxCategorySeparatorTokenFilterDescriptor Members
TnxCategorySeparatorTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCategorySeparatorTokenFilterDescriptor.

Class

TnxCategorySeparatorTokenFilterDescriptor Class

Protected Fields
Name | Description
bstfsSeparatorDistance | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bstfsSetSeparatorDistance | TnxBaseSeparatorTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create | TnxCategorySeparatorTokenFilterDescriptor
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
SeparatorCategories | This is SeparatorCategories, a member of class TnxCategorySeparatorTokenFilterDescriptor.
SeparatorDistance | This is SeparatorDistance, a member of class TnxBaseSeparatorTokenFilterDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxCategorySeparatorTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCategorySeparatorTokenFilterDescriptor.Create Constructor

TnxCategorySeparatorTokenFilterDescriptor.Create Constructor
TnxCategorySeparatorTokenFilterDescriptor Class TnxCategorySeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCategorySeparatorTokenFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Description

TnxCategorySeparatorTokenFilterDescriptor

Class

TnxCategorySeparatorTokenFilterDescriptor Class

Links
TnxCategorySeparatorTokenFilterDescriptor Class, TnxCategorySeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCategorySeparatorTokenFilterDescriptor Class


TnxCategorySeparatorTokenFilterDescriptor Methods

TnxCategorySeparatorTokenFilterDescriptor Methods
TnxCategorySeparatorTokenFilterDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxCategorySeparatorTokenFilterDescriptor class are listed here.

Class

TnxCategorySeparatorTokenFilterDescriptor Class

Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxCategorySeparatorTokenFilterDescriptor Class, Legend, Public Methods


TnxCategorySeparatorTokenFilterDescriptor.LoadFromReader Method

TnxCategorySeparatorTokenFilterDescriptor.LoadFromReader Method
TnxCategorySeparatorTokenFilterDescriptor Class TnxCategorySeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCategorySeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCategorySeparatorTokenFilterDescriptor Methods

Links
TnxCategorySeparatorTokenFilterDescriptor Class, TnxCategorySeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCategorySeparatorTokenFilterDescriptor Methods


TnxCategorySeparatorTokenFilterDescriptor.SaveToWriter Method

TnxCategorySeparatorTokenFilterDescriptor.SaveToWriter Method
TnxCategorySeparatorTokenFilterDescriptor Class TnxCategorySeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCategorySeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCategorySeparatorTokenFilterDescriptor Methods

Links
TnxCategorySeparatorTokenFilterDescriptor Class, TnxCategorySeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCategorySeparatorTokenFilterDescriptor Methods


TnxCategorySeparatorTokenFilterDescriptor Properties

TnxCategorySeparatorTokenFilterDescriptor Properties
TnxCategorySeparatorTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxCategorySeparatorTokenFilterDescriptor class are listed here.

Class

TnxCategorySeparatorTokenFilterDescriptor Class

Public Properties
Name | Description
SeparatorCategories | This is SeparatorCategories, a member of class TnxCategorySeparatorTokenFilterDescriptor.
Links
TnxCategorySeparatorTokenFilterDescriptor Class, Legend, Public Properties


TnxCategorySeparatorTokenFilterDescriptor.SeparatorCategories Property

TnxCategorySeparatorTokenFilterDescriptor.SeparatorCategories Property
TnxCategorySeparatorTokenFilterDescriptor Class TnxCategorySeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCategorySeparatorTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property SeparatorCategories: TnxCharacterCategories;
Description

This is SeparatorCategories, a member of class TnxCategorySeparatorTokenFilterDescriptor.

Group

TnxCategorySeparatorTokenFilterDescriptor Properties

Links
TnxCategorySeparatorTokenFilterDescriptor Class, TnxCategorySeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCategorySeparatorTokenFilterDescriptor Properties


TnxCustomFoldStringTokenFilterDescriptor Class

TnxCustomFoldStringTokenFilterDescriptor Class
TnxCustomFoldStringTokenFilterDescriptor Fields TnxCustomFoldStringTokenFilterDescriptor Methods TnxCustomFoldStringTokenFilterDescriptor Properties TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomFoldStringTokenFilterDescriptor
Syntax
Delphi
TnxCustomFoldStringTokenFilterDescriptor = class(TnxBaseFoldStringTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxCustomFoldStringTokenFilterDescriptor.

Group

Classes

Links
TnxCustomFoldStringTokenFilterDescriptor Fields, TnxCustomFoldStringTokenFilterDescriptor Methods, TnxCustomFoldStringTokenFilterDescriptor Properties, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxCustomFoldStringTokenFilterDescriptor Members

TnxCustomFoldStringTokenFilterDescriptor Members
TnxCustomFoldStringTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCustomFoldStringTokenFilterDescriptor.

Class

TnxCustomFoldStringTokenFilterDescriptor Class

Protected Fields
Name | Description
cfstfdFlags | This is cfstfdFlags, a member of class TnxCustomFoldStringTokenFilterDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfstfdGetFlags | TnxCustomFoldStringTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
cfstfdSetFlags |
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxCustomFoldStringTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxCustomFoldStringTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCustomFoldStringTokenFilterDescriptor Fields

TnxCustomFoldStringTokenFilterDescriptor Fields
TnxCustomFoldStringTokenFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxCustomFoldStringTokenFilterDescriptor class are listed here.

Class

TnxCustomFoldStringTokenFilterDescriptor Class

Protected Fields
Name | Description
cfstfdFlags | This is cfstfdFlags, a member of class TnxCustomFoldStringTokenFilterDescriptor.
Links
TnxCustomFoldStringTokenFilterDescriptor Class, Legend, Protected Fields


TnxCustomFoldStringTokenFilterDescriptor.cfstfdFlags Field

TnxCustomFoldStringTokenFilterDescriptor.cfstfdFlags Field
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Fields Send Feedback
Syntax
Delphi
cfstfdFlags: Cardinal;
Description

This is cfstfdFlags, a member of class TnxCustomFoldStringTokenFilterDescriptor.

Group

TnxCustomFoldStringTokenFilterDescriptor Fields

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Fields


TnxCustomFoldStringTokenFilterDescriptor Methods

TnxCustomFoldStringTokenFilterDescriptor Methods
TnxCustomFoldStringTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomFoldStringTokenFilterDescriptor class are listed here.

Class

TnxCustomFoldStringTokenFilterDescriptor Class

Protected Methods
Name | Description
bfstfdGetFlags | TnxCustomFoldStringTokenFilterDescriptor
cfstfdSetFlags |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxCustomFoldStringTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxCustomFoldStringTokenFilterDescriptor.bfstfdGetFlags Method

TnxCustomFoldStringTokenFilterDescriptor.bfstfdGetFlags Method
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function bfstfdGetFlags: Cardinal; override;
Description

TnxCustomFoldStringTokenFilterDescriptor

Group

TnxCustomFoldStringTokenFilterDescriptor Methods

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Methods


TnxCustomFoldStringTokenFilterDescriptor.cfstfdSetFlags Method

TnxCustomFoldStringTokenFilterDescriptor.cfstfdSetFlags Method
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure cfstfdSetFlags(aFlags: Cardinal);
Group

TnxCustomFoldStringTokenFilterDescriptor Methods

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Methods


TnxCustomFoldStringTokenFilterDescriptor.LoadFromReader Method

TnxCustomFoldStringTokenFilterDescriptor.LoadFromReader Method
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCustomFoldStringTokenFilterDescriptor Methods

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Methods


TnxCustomFoldStringTokenFilterDescriptor.SaveToWriter Method

TnxCustomFoldStringTokenFilterDescriptor.SaveToWriter Method
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCustomFoldStringTokenFilterDescriptor Methods

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Methods


TnxCustomFoldStringTokenFilterDescriptor Properties

TnxCustomFoldStringTokenFilterDescriptor Properties
TnxCustomFoldStringTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxCustomFoldStringTokenFilterDescriptor class are listed here.

Class

TnxCustomFoldStringTokenFilterDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxCustomFoldStringTokenFilterDescriptor.
Links
TnxCustomFoldStringTokenFilterDescriptor Class, Legend, Public Properties


TnxCustomFoldStringTokenFilterDescriptor.Flags Property

TnxCustomFoldStringTokenFilterDescriptor.Flags Property
TnxCustomFoldStringTokenFilterDescriptor Class TnxCustomFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomFoldStringTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxCustomFoldStringTokenFilterDescriptor.

Group

TnxCustomFoldStringTokenFilterDescriptor Properties

Links
TnxCustomFoldStringTokenFilterDescriptor Class, TnxCustomFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomFoldStringTokenFilterDescriptor Properties


TnxCustomLocaleMappingTokenFilterDescriptor Class

TnxCustomLocaleMappingTokenFilterDescriptor Class
TnxCustomLocaleMappingTokenFilterDescriptor Fields TnxCustomLocaleMappingTokenFilterDescriptor Methods TnxCustomLocaleMappingTokenFilterDescriptor Properties TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxCustomLocaleMappingTokenFilterDescriptor
Syntax
Delphi
TnxCustomLocaleMappingTokenFilterDescriptor = class(TnxBaseLocaleMappingTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxCustomLocaleMappingTokenFilterDescriptor.

Group

Classes

Links
TnxCustomLocaleMappingTokenFilterDescriptor Fields, TnxCustomLocaleMappingTokenFilterDescriptor Methods, TnxCustomLocaleMappingTokenFilterDescriptor Properties, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxCustomLocaleMappingTokenFilterDescriptor Members

TnxCustomLocaleMappingTokenFilterDescriptor Members
TnxCustomLocaleMappingTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCustomLocaleMappingTokenFilterDescriptor.

Class

TnxCustomLocaleMappingTokenFilterDescriptor Class

Protected Fields
Name | Description
clmtfdFlags | This is clmtfdFlags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
blmtfdGetFlags | TnxCustomLocaleMappingTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
clmtfdSetFlags |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCustomLocaleMappingTokenFilterDescriptor Fields

TnxCustomLocaleMappingTokenFilterDescriptor Fields
TnxCustomLocaleMappingTokenFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxCustomLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxCustomLocaleMappingTokenFilterDescriptor Class

Protected Fields
Name | Description
clmtfdFlags | This is clmtfdFlags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.
Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, Legend, Protected Fields


TnxCustomLocaleMappingTokenFilterDescriptor.clmtfdFlags Field

TnxCustomLocaleMappingTokenFilterDescriptor.clmtfdFlags Field
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Fields Send Feedback
Syntax
Delphi
clmtfdFlags: Cardinal;
Description

This is clmtfdFlags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.

Group

TnxCustomLocaleMappingTokenFilterDescriptor Fields

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Fields


TnxCustomLocaleMappingTokenFilterDescriptor Methods

TnxCustomLocaleMappingTokenFilterDescriptor Methods
TnxCustomLocaleMappingTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxCustomLocaleMappingTokenFilterDescriptor Class

Protected Methods
Name | Description
blmtfdGetFlags | TnxCustomLocaleMappingTokenFilterDescriptor
clmtfdSetFlags |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxCustomLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method

TnxCustomLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function blmtfdGetFlags: Cardinal; override;
Description

TnxCustomLocaleMappingTokenFilterDescriptor

Group

TnxCustomLocaleMappingTokenFilterDescriptor Methods

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Methods


TnxCustomLocaleMappingTokenFilterDescriptor.clmtfdSetFlags Method

TnxCustomLocaleMappingTokenFilterDescriptor.clmtfdSetFlags Method
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure clmtfdSetFlags(aFlags: Cardinal);
Group

TnxCustomLocaleMappingTokenFilterDescriptor Methods

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Methods


TnxCustomLocaleMappingTokenFilterDescriptor.LoadFromReader Method

TnxCustomLocaleMappingTokenFilterDescriptor.LoadFromReader Method
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCustomLocaleMappingTokenFilterDescriptor Methods

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Methods


TnxCustomLocaleMappingTokenFilterDescriptor.SaveToWriter Method

TnxCustomLocaleMappingTokenFilterDescriptor.SaveToWriter Method
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCustomLocaleMappingTokenFilterDescriptor Methods

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Methods


TnxCustomLocaleMappingTokenFilterDescriptor Properties

TnxCustomLocaleMappingTokenFilterDescriptor Properties
TnxCustomLocaleMappingTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxCustomLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxCustomLocaleMappingTokenFilterDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.
Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, Legend, Public Properties


TnxCustomLocaleMappingTokenFilterDescriptor.Flags Property

TnxCustomLocaleMappingTokenFilterDescriptor.Flags Property
TnxCustomLocaleMappingTokenFilterDescriptor Class TnxCustomLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxCustomLocaleMappingTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxCustomLocaleMappingTokenFilterDescriptor.

Group

TnxCustomLocaleMappingTokenFilterDescriptor Properties

Links
TnxCustomLocaleMappingTokenFilterDescriptor Class, TnxCustomLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxCustomLocaleMappingTokenFilterDescriptor Properties


TnxDecomposeFoldStringTokenFilterDescriptor Class

TnxDecomposeFoldStringTokenFilterDescriptor Class
TnxDecomposeFoldStringTokenFilterDescriptor Methods TnxDecomposeFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxDecomposeFoldStringTokenFilterDescriptor
Syntax
Delphi
TnxDecomposeFoldStringTokenFilterDescriptor = class(TnxBaseFoldStringTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxDecomposeFoldStringTokenFilterDescriptor.

Group

Classes

Links
TnxDecomposeFoldStringTokenFilterDescriptor Methods, TnxDecomposeFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxDecomposeFoldStringTokenFilterDescriptor Members

TnxDecomposeFoldStringTokenFilterDescriptor Members
TnxDecomposeFoldStringTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDecomposeFoldStringTokenFilterDescriptor.

Class

TnxDecomposeFoldStringTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfstfdGetFlags | TnxDecomposeFoldStringTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
LoadFromReader | TnxBaseFoldStringTokenFilterDescriptor
LoadFromReader |
LoadFromReader |
LoadFromReader |
LoadFromReader | TnxBaseTokenSourceDescriptor
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxDecomposeFoldStringTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxDecomposeFoldStringTokenFilterDescriptor Methods

TnxDecomposeFoldStringTokenFilterDescriptor Methods
TnxDecomposeFoldStringTokenFilterDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxDecomposeFoldStringTokenFilterDescriptor class are listed here.

Class

TnxDecomposeFoldStringTokenFilterDescriptor Class

Protected Methods
Name | Description
bfstfdGetFlags | TnxDecomposeFoldStringTokenFilterDescriptor
Links
TnxDecomposeFoldStringTokenFilterDescriptor Class, Legend, Protected Methods


TnxDecomposeFoldStringTokenFilterDescriptor.bfstfdGetFlags Method

TnxDecomposeFoldStringTokenFilterDescriptor.bfstfdGetFlags Method
TnxDecomposeFoldStringTokenFilterDescriptor Class TnxDecomposeFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxDecomposeFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function bfstfdGetFlags: Cardinal; override;
Description

TnxDecomposeFoldStringTokenFilterDescriptor

Group

TnxDecomposeFoldStringTokenFilterDescriptor Methods

Links
TnxDecomposeFoldStringTokenFilterDescriptor Class, TnxDecomposeFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxDecomposeFoldStringTokenFilterDescriptor Methods


TnxFieldTokenExtractorDescriptor Class

TnxFieldTokenExtractorDescriptor Class
TnxFieldTokenExtractorDescriptor Fields TnxFieldTokenExtractorDescriptor Methods TnxFieldTokenExtractorDescriptor Properties TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptornxsdDataDictionaryFulltext_TnxFieldTokenExtractorDescriptor
Syntax
Delphi
TnxFieldTokenExtractorDescriptor = class(TnxBaseTokenExtractorDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptor.

Group

Classes

Links
TnxFieldTokenExtractorDescriptor Fields, TnxFieldTokenExtractorDescriptor Methods, TnxFieldTokenExtractorDescriptor Properties, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxFieldTokenExtractorDescriptor Members

TnxFieldTokenExtractorDescriptor Members
TnxFieldTokenExtractorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldTokenExtractorDescriptor.

Class

TnxFieldTokenExtractorDescriptor Class

Protected Fields
Name | Description
btedTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ftedFieldNumber | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
btedGetName |
btedGetTokenFilter |
btedGetTokenFilterCount |
btedGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
ftedGetField |
ftedSetFieldNumber |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxBaseTokenExtractorDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxFieldTokenExtractorDescriptor
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Field | This is Field, a member of class TnxFieldTokenExtractorDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxFieldTokenExtractorDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenExtractorDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxFieldTokenExtractorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFieldTokenExtractorDescriptor.Create Constructor

TnxFieldTokenExtractorDescriptor.Create Constructor
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxFieldTokenExtractorDescriptor Class

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Class


TnxFieldTokenExtractorDescriptor.Destroy Destructor

TnxFieldTokenExtractorDescriptor.Destroy Destructor
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFieldTokenExtractorDescriptor Class

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Class


TnxFieldTokenExtractorDescriptor Fields

TnxFieldTokenExtractorDescriptor Fields
TnxFieldTokenExtractorDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFieldTokenExtractorDescriptor class are listed here.

Class

TnxFieldTokenExtractorDescriptor Class

Protected Fields
Name | Description
ftedFieldNumber | private
Links
TnxFieldTokenExtractorDescriptor Class, Legend, Protected Fields


TnxFieldTokenExtractorDescriptor.ftedFieldNumber Field

TnxFieldTokenExtractorDescriptor.ftedFieldNumber Field
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Fields Send Feedback
Syntax
Delphi
ftedFieldNumber: Integer;
Description

private

Group

TnxFieldTokenExtractorDescriptor Fields

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Fields


TnxFieldTokenExtractorDescriptor Methods

TnxFieldTokenExtractorDescriptor Methods
TnxFieldTokenExtractorDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldTokenExtractorDescriptor class are listed here.

Class

TnxFieldTokenExtractorDescriptor Class

Protected Methods
Name | Description
diFieldChangeNotify |
ftedGetField |
ftedSetFieldNumber |
Public Methods
Name | Description
CheckValid | TnxFieldTokenExtractorDescriptor
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxFieldTokenExtractorDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldTokenExtractorDescriptor.CheckValid Method

TnxFieldTokenExtractorDescriptor.CheckValid Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxFieldTokenExtractorDescriptor

Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.diFieldChangeNotify Method

TnxFieldTokenExtractorDescriptor.diFieldChangeNotify Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFieldChangeNotify(aBefore: Boolean; aOldField: Integer; aNewField: Integer); override;
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.ftedGetField Method

TnxFieldTokenExtractorDescriptor.ftedGetField Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function ftedGetField: TnxFieldDescriptor;
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.ftedSetFieldNumber Method

TnxFieldTokenExtractorDescriptor.ftedSetFieldNumber Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure ftedSetFieldNumber(aFieldNumber: Integer);
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.IsEqual Method

TnxFieldTokenExtractorDescriptor.IsEqual Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.LoadFromReader Method

TnxFieldTokenExtractorDescriptor.LoadFromReader Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor.SaveToWriter Method

TnxFieldTokenExtractorDescriptor.SaveToWriter Method
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFieldTokenExtractorDescriptor Methods

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Methods


TnxFieldTokenExtractorDescriptor Properties

TnxFieldTokenExtractorDescriptor Properties
TnxFieldTokenExtractorDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFieldTokenExtractorDescriptor class are listed here.

Class

TnxFieldTokenExtractorDescriptor Class

Public Properties
Name | Description
Field | This is Field, a member of class TnxFieldTokenExtractorDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxFieldTokenExtractorDescriptor.
Links
TnxFieldTokenExtractorDescriptor Class, Legend, Public Properties


TnxFieldTokenExtractorDescriptor.Field Property

TnxFieldTokenExtractorDescriptor.Field Property
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property Field: TnxFieldDescriptor;
Description

This is Field, a member of class TnxFieldTokenExtractorDescriptor.

Group

TnxFieldTokenExtractorDescriptor Properties

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Properties


TnxFieldTokenExtractorDescriptor.FieldNumber Property

TnxFieldTokenExtractorDescriptor.FieldNumber Property
TnxFieldTokenExtractorDescriptor Class TnxFieldTokenExtractorDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFieldTokenExtractorDescriptor Properties Send Feedback
Syntax
Delphi
property FieldNumber: Integer;
Description

This is FieldNumber, a member of class TnxFieldTokenExtractorDescriptor.

Group

TnxFieldTokenExtractorDescriptor Properties

Links
TnxFieldTokenExtractorDescriptor Class, TnxFieldTokenExtractorDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFieldTokenExtractorDescriptor Properties


TnxFulltextDescriptor Class

TnxFulltextDescriptor Class
TnxFulltextDescriptor Fields TnxFulltextDescriptor Methods TnxFulltextDescriptor Properties TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptornxsdDataDictionaryFulltext_TnxFulltextDescriptor
Syntax
Delphi
TnxFulltextDescriptor = class(TnxBaseCustomDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxFulltextDescriptor.

Group

Classes

Links
TnxFulltextDescriptor Fields, TnxFulltextDescriptor Methods, TnxFulltextDescriptor Properties, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxFulltextDescriptor Members

TnxFulltextDescriptor Members
TnxFulltextDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFulltextDescriptor.

Class

TnxFulltextDescriptor Class

Protected Fields
Name | Description
bcdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ftdBlobDescriptor | This is ftdBlobDescriptor, a member of class TnxFulltextDescriptor.
ftdFulltextIndices | private
ftdIndicesDescriptor | This is ftdIndicesDescriptor, a member of class TnxFulltextDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | constructor.
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
ftdForceIndicesDescriptor |
ftdGetFulltextIndexCount |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddBlobDescriptor | blob descriptor This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddFulltextIndex |
AddIndicesDescriptor | indices descriptor This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | fulltext indics
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveFulltextIndex | This is the overview for the RemoveFulltextIndex method overload.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
BlobDescriptor | This property returns the associated Blob Descriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
ForceIndicesDescriptor | This is ForceIndicesDescriptor, a member of class TnxFulltextDescriptor.
FulltextIndex | This is FulltextIndex, a member of class TnxFulltextDescriptor.
FulltextIndexCount | This is FulltextIndexCount, a member of class TnxFulltextDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IndicesDescriptor | This property returns the associated Indices Descriptor.
Name | Returns the name of the Custom Descriptor.
Links
TnxFulltextDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFulltextDescriptor.Destroy Destructor

TnxFulltextDescriptor.Destroy Destructor
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFulltextDescriptor Class

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Class


TnxFulltextDescriptor Fields

TnxFulltextDescriptor Fields
TnxFulltextDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFulltextDescriptor class are listed here.

Class

TnxFulltextDescriptor Class

Protected Fields
Name | Description
ftdBlobDescriptor | This is ftdBlobDescriptor, a member of class TnxFulltextDescriptor.
ftdFulltextIndices | private
ftdIndicesDescriptor | This is ftdIndicesDescriptor, a member of class TnxFulltextDescriptor.
Links
TnxFulltextDescriptor Class, Legend, Protected Fields


TnxFulltextDescriptor.ftdBlobDescriptor Field

TnxFulltextDescriptor.ftdBlobDescriptor Field
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Fields Send Feedback
Syntax
Delphi
ftdBlobDescriptor: TnxBaseBlobDescriptor;
Description

This is ftdBlobDescriptor, a member of class TnxFulltextDescriptor.

Group

TnxFulltextDescriptor Fields

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Fields


TnxFulltextDescriptor.ftdFulltextIndices Field

TnxFulltextDescriptor.ftdFulltextIndices Field
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Fields Send Feedback
Syntax
Delphi
ftdFulltextIndices: TnxFulltextIndexDescriptors;
Description

private

Group

TnxFulltextDescriptor Fields

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Fields


TnxFulltextDescriptor.ftdIndicesDescriptor Field

TnxFulltextDescriptor.ftdIndicesDescriptor Field
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Fields Send Feedback
Syntax
Delphi
ftdIndicesDescriptor: TnxTokenIndicesDescriptor;
Description

This is ftdIndicesDescriptor, a member of class TnxFulltextDescriptor.

Group

TnxFulltextDescriptor Fields

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Fields


TnxFulltextDescriptor Methods

TnxFulltextDescriptor Methods
TnxFulltextDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFulltextDescriptor class are listed here.

Class

TnxFulltextDescriptor Class

Protected Methods
Name | Description
ftdForceIndicesDescriptor |
ftdGetFulltextIndexCount |
Public Methods
Name | Description
AddBlobDescriptor | blob descriptor This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.
AddFulltextIndex |
AddIndicesDescriptor | indices descriptor This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.
CheckValid |
FindRelatedDescriptorOfType | fulltext indics
IsEqual |
LoadFromReader |
RemoveBlobDescriptor | This function frees the Instance of the associated Blob Descriptor.
RemoveFulltextIndex | This is the overview for the RemoveFulltextIndex method overload.
RemoveIndicesDescriptor | This function frees the Instance of the associated Indices Descriptor.
SaveToWriter |
Links
TnxFulltextDescriptor Class, Legend, Protected Methods, Public Methods


TnxFulltextDescriptor.AddBlobDescriptor Method

TnxFulltextDescriptor.AddBlobDescriptor Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddBlobDescriptor(aBlobClass: TnxBaseBlobDescriptorClass = nil): TnxBaseBlobDescriptor;
Description

blob descriptor This function sets the Blob Descriptor class to the given aBlobClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

TnxFulltextDescriptor

Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods, See Also


TnxFulltextDescriptor.AddFulltextIndex Method

TnxFulltextDescriptor.AddFulltextIndex Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
function AddFulltextIndex(aName: string = ''; aFulltextIndexClass: TnxFulltextIndexDescriptorClass = nil; aLocationIndexNumber: Integer = -1): TnxFulltextIndexDescriptor;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.AddIndicesDescriptor Method

TnxFulltextDescriptor.AddIndicesDescriptor Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods See Also Send Feedback
Syntax
Delphi
function AddIndicesDescriptor(aIndicesClass: TnxTokenIndicesDescriptorClass = nil): TnxTokenIndicesDescriptor;
Description

indices descriptor This function sets the Indices Descriptor class to the given aIndicesClass, creates and instance, adds it to the data dictionary and returns the instance.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods, See Also


TnxFulltextDescriptor.CheckValid Method

TnxFulltextDescriptor.CheckValid Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.FindRelatedDescriptorOfType Method

TnxFulltextDescriptor.FindRelatedDescriptorOfType Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
function FindRelatedDescriptorOfType(aType: TnxDictionaryItemClass; out aDescriptor; aFrom: TnxDictionaryItem = nil): Boolean; override;
Description

fulltext indics

Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.ftdForceIndicesDescriptor Method

TnxFulltextDescriptor.ftdForceIndicesDescriptor Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
function ftdForceIndicesDescriptor: TnxTokenIndicesDescriptor;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.ftdGetFulltextIndexCount Method

TnxFulltextDescriptor.ftdGetFulltextIndexCount Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
function ftdGetFulltextIndexCount: Integer;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.IsEqual Method

TnxFulltextDescriptor.IsEqual Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.LoadFromReader Method

TnxFulltextDescriptor.LoadFromReader Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor.RemoveBlobDescriptor Method

TnxFulltextDescriptor.RemoveBlobDescriptor Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveBlobDescriptor;
Description

This function frees the Instance of the associated Blob Descriptor.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods, See Also


RemoveFulltextIndex Method

RemoveFulltextIndex Method
TnxFulltextDescriptor Methods Send Feedback

This is the overview for the RemoveFulltextIndex method overload.

Overload List
Name | Description
TnxFulltextDescriptor.RemoveFulltextIndex (Integer) |
TnxFulltextDescriptor.RemoveFulltextIndex (string) |
TnxFulltextDescriptor.RemoveFulltextIndex (TnxFulltextIndexDescriptor) |
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Methods


TnxFulltextDescriptor.RemoveFulltextIndex Method (Integer)

TnxFulltextDescriptor.RemoveFulltextIndex Method (Integer)
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveFulltextIndex Method Send Feedback
Syntax
Delphi
procedure RemoveFulltextIndex(aIndex: Integer); overload;
Group

RemoveFulltextIndex Method

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveFulltextIndex Method


TnxFulltextDescriptor.RemoveFulltextIndex Method (TnxFulltextIndexDescriptor)

TnxFulltextDescriptor.RemoveFulltextIndex Method (TnxFulltextIndexDescriptor)
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveFulltextIndex Method Send Feedback
Syntax
Delphi
procedure RemoveFulltextIndex(aDescriptor: TnxFulltextIndexDescriptor); overload;
Group

RemoveFulltextIndex Method

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveFulltextIndex Method


TnxFulltextDescriptor.RemoveFulltextIndex Method (string)

TnxFulltextDescriptor.RemoveFulltextIndex Method (string)
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveFulltextIndex Method Send Feedback
Syntax
Delphi
procedure RemoveFulltextIndex(const aName: string); overload;
Group

RemoveFulltextIndex Method

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveFulltextIndex Method


TnxFulltextDescriptor.RemoveIndicesDescriptor Method

TnxFulltextDescriptor.RemoveIndicesDescriptor Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods See Also Send Feedback
Syntax
Delphi
procedure RemoveIndicesDescriptor;
Description

This function frees the Instance of the associated Indices Descriptor.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods, See Also


TnxFulltextDescriptor.SaveToWriter Method

TnxFulltextDescriptor.SaveToWriter Method
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFulltextDescriptor Methods

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Methods


TnxFulltextDescriptor Properties

TnxFulltextDescriptor Properties
TnxFulltextDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFulltextDescriptor class are listed here.

Class

TnxFulltextDescriptor Class

Public Properties
Name | Description
BlobDescriptor | This property returns the associated Blob Descriptor.
ForceIndicesDescriptor | This is ForceIndicesDescriptor, a member of class TnxFulltextDescriptor.
FulltextIndex | This is FulltextIndex, a member of class TnxFulltextDescriptor.
FulltextIndexCount | This is FulltextIndexCount, a member of class TnxFulltextDescriptor.
IndicesDescriptor | This property returns the associated Indices Descriptor.
Links
TnxFulltextDescriptor Class, Legend, Public Properties


TnxFulltextDescriptor.BlobDescriptor Property

TnxFulltextDescriptor.BlobDescriptor Property
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Properties See Also Send Feedback
Syntax
Delphi
property BlobDescriptor: TnxBaseBlobDescriptor;
Description

This property returns the associated Blob Descriptor.

See Also

AddBlobDescriptor, RemoveBlobDescriptor, BlobDescriptor

Group

TnxFulltextDescriptor Properties

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Properties, See Also


TnxFulltextDescriptor.ForceIndicesDescriptor Property

TnxFulltextDescriptor.ForceIndicesDescriptor Property
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Properties Send Feedback
Syntax
Delphi
property ForceIndicesDescriptor: TnxTokenIndicesDescriptor;
Description

This is ForceIndicesDescriptor, a member of class TnxFulltextDescriptor.

Group

TnxFulltextDescriptor Properties

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Properties


TnxFulltextDescriptor.FulltextIndex Property

TnxFulltextDescriptor.FulltextIndex Property
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Properties Send Feedback
Syntax
Delphi
property FulltextIndex: TnxFulltextIndexDescriptors;
Description

This is FulltextIndex, a member of class TnxFulltextDescriptor.

Group

TnxFulltextDescriptor Properties

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Properties


TnxFulltextDescriptor.FulltextIndexCount Property

TnxFulltextDescriptor.FulltextIndexCount Property
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Properties Send Feedback
Syntax
Delphi
property FulltextIndexCount: Integer;
Description

This is FulltextIndexCount, a member of class TnxFulltextDescriptor.

Group

TnxFulltextDescriptor Properties

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Properties


TnxFulltextDescriptor.IndicesDescriptor Property

TnxFulltextDescriptor.IndicesDescriptor Property
TnxFulltextDescriptor Class TnxFulltextDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextDescriptor Properties See Also Send Feedback
Syntax
Delphi
property IndicesDescriptor: TnxTokenIndicesDescriptor;
Description

This property returns the associated Indices Descriptor.

See Also

AddIndicesDescriptor, RemoveIndicesDescriptor, IndicesDescriptor

Group

TnxFulltextDescriptor Properties

Links
TnxFulltextDescriptor Class, TnxFulltextDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextDescriptor Properties, See Also


TnxFulltextIndexDescriptor Class

TnxFulltextIndexDescriptor Class
TnxFulltextIndexDescriptor Fields TnxFulltextIndexDescriptor Methods TnxFulltextIndexDescriptor Properties TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptornxsdDataDictionaryFulltext_TnxFulltextIndexDescriptor
Syntax
Delphi
TnxFulltextIndexDescriptor = class(TnxBaseFulltextDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptor.

Group

Classes

Links
TnxFulltextIndexDescriptor Fields, TnxFulltextIndexDescriptor Methods, TnxFulltextIndexDescriptor Properties, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxFulltextIndexDescriptor Members

TnxFulltextIndexDescriptor Members
TnxFulltextIndexDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFulltextIndexDescriptor.

Class

TnxFulltextIndexDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fidLocationIndexNumber | This is fidLocationIndexNumber, a member of class TnxFulltextIndexDescriptor.
fidName | private
fidTokenExtractorHub | This is fidTokenExtractorHub, a member of class TnxFulltextIndexDescriptor.
fidTokenFilterHub | This is fidTokenFilterHub, a member of class TnxFulltextIndexDescriptor.
fidTokenIndexHub | This is fidTokenIndexHub, a member of class TnxFulltextIndexDescriptor.
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify |
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fidCheckValidLocationIndex |
fidFindValidLocationIndex |
fidGetLocationIndex |
fidGetTokenExtractor |
fidGetTokenExtractorCount |
fidGetTokenExtractorName |
fidGetTokenFilter |
fidGetTokenFilterCount |
fidGetTokenFilterName |
fidGetTokenIndex |
fidGetTokenIndexCount |
fidGetTokenIndexName |
fidIsValidLocationIndex |
fidSetLocationIndex |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddFieldTokenExtractor | TnxFulltextIndexDescriptor
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenExtractor |
AddTokenExtractorHub |
AddTokenFilter |
AddTokenIndex |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
ClearTokenExtractor |
ClearTokenFilter |
ClearTokenIndex |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenExtractor | This is the overview for the RemoveTokenExtractor method overload.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RemoveTokenIndex | This is the overview for the RemoveTokenIndex method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
LocationIndex | This is LocationIndex, a member of class TnxFulltextIndexDescriptor.
LocationIndexNumber | This is LocationIndexNumber, a member of class TnxFulltextIndexDescriptor.
Name | This is Name, a member of class TnxFulltextIndexDescriptor.
TokenExtractor | This is TokenExtractor, a member of class TnxFulltextIndexDescriptor.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxFulltextIndexDescriptor.
TokenExtractorHub | Extractor
TokenExtractorName | This is TokenExtractorName, a member of class TnxFulltextIndexDescriptor.
TokenFilter | This is TokenFilter, a member of class TnxFulltextIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxFulltextIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxFulltextIndexDescriptor.
TokenIndex | This is TokenIndex, a member of class TnxFulltextIndexDescriptor.
TokenIndexCount | This is TokenIndexCount, a member of class TnxFulltextIndexDescriptor.
TokenIndexHub | Index
TokenIndexName | This is TokenIndexName, a member of class TnxFulltextIndexDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxFulltextIndexDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFulltextIndexDescriptor.Create Constructor

TnxFulltextIndexDescriptor.Create Constructor
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; aName: string; aLocationIndexNumber: Integer = -1); virtual;
Class

TnxFulltextIndexDescriptor Class

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Class


TnxFulltextIndexDescriptor.Destroy Destructor

TnxFulltextIndexDescriptor.Destroy Destructor
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFulltextIndexDescriptor Class

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Class


TnxFulltextIndexDescriptor Fields

TnxFulltextIndexDescriptor Fields
TnxFulltextIndexDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFulltextIndexDescriptor class are listed here.

Class

TnxFulltextIndexDescriptor Class

Protected Fields
Name | Description
fidLocationIndexNumber | This is fidLocationIndexNumber, a member of class TnxFulltextIndexDescriptor.
fidName | private
fidTokenExtractorHub | This is fidTokenExtractorHub, a member of class TnxFulltextIndexDescriptor.
fidTokenFilterHub | This is fidTokenFilterHub, a member of class TnxFulltextIndexDescriptor.
fidTokenIndexHub | This is fidTokenIndexHub, a member of class TnxFulltextIndexDescriptor.
Links
TnxFulltextIndexDescriptor Class, Legend, Protected Fields


TnxFulltextIndexDescriptor.fidLocationIndexNumber Field

TnxFulltextIndexDescriptor.fidLocationIndexNumber Field
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Fields Send Feedback
Syntax
Delphi
fidLocationIndexNumber: Integer;
Description

This is fidLocationIndexNumber, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Fields

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Fields


TnxFulltextIndexDescriptor.fidName Field

TnxFulltextIndexDescriptor.fidName Field
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Fields Send Feedback
Syntax
Delphi
fidName: string;
Description

private

Group

TnxFulltextIndexDescriptor Fields

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Fields


TnxFulltextIndexDescriptor.fidTokenExtractorHub Field

TnxFulltextIndexDescriptor.fidTokenExtractorHub Field
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Fields Send Feedback
Syntax
Delphi
fidTokenExtractorHub: TnxTokenExtractorHubDescriptor;
Description

This is fidTokenExtractorHub, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Fields

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Fields


TnxFulltextIndexDescriptor.fidTokenFilterHub Field

TnxFulltextIndexDescriptor.fidTokenFilterHub Field
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Fields Send Feedback
Syntax
Delphi
fidTokenFilterHub: TnxTokenFilterHubDescriptor;
Description

This is fidTokenFilterHub, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Fields

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Fields


TnxFulltextIndexDescriptor.fidTokenIndexHub Field

TnxFulltextIndexDescriptor.fidTokenIndexHub Field
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Fields Send Feedback
Syntax
Delphi
fidTokenIndexHub: TnxTokenIndexHubDescriptor;
Description

This is fidTokenIndexHub, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Fields

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Fields


TnxFulltextIndexDescriptor Methods

TnxFulltextIndexDescriptor Methods
TnxFulltextIndexDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFulltextIndexDescriptor class are listed here.

Class

TnxFulltextIndexDescriptor Class

Protected Methods
Name | Description
diIndexChangeNotify |
fidCheckValidLocationIndex |
fidFindValidLocationIndex |
fidGetLocationIndex |
fidGetTokenExtractor |
fidGetTokenExtractorCount |
fidGetTokenExtractorName |
fidGetTokenFilter |
fidGetTokenFilterCount |
fidGetTokenFilterName |
fidGetTokenIndex |
fidGetTokenIndexCount |
fidGetTokenIndexName |
fidIsValidLocationIndex |
fidSetLocationIndex |
GetList |
Public Methods
Name | Description
AddFieldTokenExtractor | TnxFulltextIndexDescriptor
AddTokenExtractor |
AddTokenExtractorHub |
AddTokenFilter |
AddTokenIndex |
CheckValid |
ClearTokenExtractor |
ClearTokenFilter |
ClearTokenIndex |
IsEqual |
LoadFromReader |
RemoveTokenExtractor | This is the overview for the RemoveTokenExtractor method overload.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RemoveTokenIndex | This is the overview for the RemoveTokenIndex method overload.
SaveToWriter |
Links
TnxFulltextIndexDescriptor Class, Legend, Protected Methods, Public Methods


TnxFulltextIndexDescriptor.AddFieldTokenExtractor Method

TnxFulltextIndexDescriptor.AddFieldTokenExtractor Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddFieldTokenExtractor(aFieldNumber: Integer; aName: string = ''; aTokenExtractorClass: TnxFieldTokenExtractorDescriptorClass = nil): TnxFieldTokenExtractorDescriptor;
Description

TnxFulltextIndexDescriptor

Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.AddTokenExtractor Method

TnxFulltextIndexDescriptor.AddTokenExtractor Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenExtractor(const aName: string; aTokenExtractorClass: TnxBaseTokenExtractorDescriptorClass = nil): TnxBaseTokenExtractorDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.AddTokenExtractorHub Method

TnxFulltextIndexDescriptor.AddTokenExtractorHub Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenExtractorHub(aName: string; aTokenExtractorClass: TnxTokenExtractorHubDescriptorClass = nil): TnxTokenExtractorHubDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.AddTokenFilter Method

TnxFulltextIndexDescriptor.AddTokenFilter Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenFilter(const aName: string = ''; aTokenFilterClass: TnxBaseTokenFilterDescriptorClass = nil): TnxBaseTokenFilterDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.AddTokenIndex Method

TnxFulltextIndexDescriptor.AddTokenIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenIndex(const aName: string = ''; aTokenIndexClass: TnxBaseTokenIndexDescriptorClass = nil): TnxBaseTokenIndexDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.CheckValid Method

TnxFulltextIndexDescriptor.CheckValid Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.ClearTokenExtractor Method

TnxFulltextIndexDescriptor.ClearTokenExtractor Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearTokenExtractor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.ClearTokenFilter Method

TnxFulltextIndexDescriptor.ClearTokenFilter Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearTokenFilter;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.ClearTokenIndex Method

TnxFulltextIndexDescriptor.ClearTokenIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure ClearTokenIndex;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.diIndexChangeNotify Method

TnxFulltextIndexDescriptor.diIndexChangeNotify Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure diIndexChangeNotify(aBefore: Boolean; aOldIndex: Integer; aNewIndex: Integer); override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidCheckValidLocationIndex Method

TnxFulltextIndexDescriptor.fidCheckValidLocationIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure fidCheckValidLocationIndex(aIndex: Integer);
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidFindValidLocationIndex Method

TnxFulltextIndexDescriptor.fidFindValidLocationIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidFindValidLocationIndex: Integer;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetLocationIndex Method

TnxFulltextIndexDescriptor.fidGetLocationIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetLocationIndex: TnxIndexDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenExtractor Method

TnxFulltextIndexDescriptor.fidGetTokenExtractor Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenExtractor(aInx: Integer): TnxBaseTokenExtractorDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenExtractorCount Method

TnxFulltextIndexDescriptor.fidGetTokenExtractorCount Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenExtractorCount: Integer;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenExtractorName Method

TnxFulltextIndexDescriptor.fidGetTokenExtractorName Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenExtractorName(aInx: Integer): string;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenFilter Method

TnxFulltextIndexDescriptor.fidGetTokenFilter Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenFilter(aInx: Integer): TnxBaseTokenFilterDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenFilterCount Method

TnxFulltextIndexDescriptor.fidGetTokenFilterCount Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenFilterCount: Integer;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenFilterName Method

TnxFulltextIndexDescriptor.fidGetTokenFilterName Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenFilterName(aInx: Integer): string;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenIndex Method

TnxFulltextIndexDescriptor.fidGetTokenIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenIndex(aInx: Integer): TnxBaseTokenIndexDescriptor;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenIndexCount Method

TnxFulltextIndexDescriptor.fidGetTokenIndexCount Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenIndexCount: Integer;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidGetTokenIndexName Method

TnxFulltextIndexDescriptor.fidGetTokenIndexName Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidGetTokenIndexName(aInx: Integer): string;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidIsValidLocationIndex Method

TnxFulltextIndexDescriptor.fidIsValidLocationIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function fidIsValidLocationIndex(aIndex: Integer): Boolean;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.fidSetLocationIndex Method

TnxFulltextIndexDescriptor.fidSetLocationIndex Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure fidSetLocationIndex(aIndex: Integer);
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.GetList Method

TnxFulltextIndexDescriptor.GetList Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.IsEqual Method

TnxFulltextIndexDescriptor.IsEqual Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.LoadFromReader Method

TnxFulltextIndexDescriptor.LoadFromReader Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


RemoveTokenExtractor Method

RemoveTokenExtractor Method
TnxFulltextIndexDescriptor Methods Send Feedback

This is the overview for the RemoveTokenExtractor method overload.

Overload List
Name | Description
TnxFulltextIndexDescriptor.RemoveTokenExtractor (Integer) |
TnxFulltextIndexDescriptor.RemoveTokenExtractor (string) |
TnxFulltextIndexDescriptor.RemoveTokenExtractor (TnxBaseTokenExtractorDescriptor) |
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (Integer)

TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (Integer)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(aIndex: Integer); overload;
Group

RemoveTokenExtractor Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (TnxBaseTokenExtractorDescriptor)

TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (TnxBaseTokenExtractorDescriptor)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(aDescriptor: TnxBaseTokenExtractorDescriptor); overload;
Group

RemoveTokenExtractor Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (string)

TnxFulltextIndexDescriptor.RemoveTokenExtractor Method (string)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(const aName: string); overload;
Group

RemoveTokenExtractor Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


RemoveTokenFilter Method

RemoveTokenFilter Method
TnxFulltextIndexDescriptor Methods Send Feedback

This is the overview for the RemoveTokenFilter method overload.

Overload List
Name | Description
TnxFulltextIndexDescriptor.RemoveTokenFilter (Integer) |
TnxFulltextIndexDescriptor.RemoveTokenFilter (string) |
TnxFulltextIndexDescriptor.RemoveTokenFilter (TnxBaseTokenFilterDescriptor) |
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.RemoveTokenFilter Method (Integer)

TnxFulltextIndexDescriptor.RemoveTokenFilter Method (Integer)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aIndex: Integer); overload;
Group

RemoveTokenFilter Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxFulltextIndexDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)

TnxFulltextIndexDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aDescriptor: TnxBaseTokenFilterDescriptor); overload;
Group

RemoveTokenFilter Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxFulltextIndexDescriptor.RemoveTokenFilter Method (string)

TnxFulltextIndexDescriptor.RemoveTokenFilter Method (string)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(const aName: string); overload;
Group

RemoveTokenFilter Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


RemoveTokenIndex Method

RemoveTokenIndex Method
TnxFulltextIndexDescriptor Methods Send Feedback

This is the overview for the RemoveTokenIndex method overload.

Overload List
Name | Description
TnxFulltextIndexDescriptor.RemoveTokenIndex (Integer) |
TnxFulltextIndexDescriptor.RemoveTokenIndex (string) |
TnxFulltextIndexDescriptor.RemoveTokenIndex (TnxBaseTokenIndexDescriptor) |
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor.RemoveTokenIndex Method (Integer)

TnxFulltextIndexDescriptor.RemoveTokenIndex Method (Integer)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(aIndex: Integer); overload;
Group

RemoveTokenIndex Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxFulltextIndexDescriptor.RemoveTokenIndex Method (TnxBaseTokenIndexDescriptor)

TnxFulltextIndexDescriptor.RemoveTokenIndex Method (TnxBaseTokenIndexDescriptor)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(aDescriptor: TnxBaseTokenIndexDescriptor); overload;
Group

RemoveTokenIndex Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxFulltextIndexDescriptor.RemoveTokenIndex Method (string)

TnxFulltextIndexDescriptor.RemoveTokenIndex Method (string)
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(const aName: string); overload;
Group

RemoveTokenIndex Method

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxFulltextIndexDescriptor.SaveToWriter Method

TnxFulltextIndexDescriptor.SaveToWriter Method
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFulltextIndexDescriptor Methods

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Methods


TnxFulltextIndexDescriptor Properties

TnxFulltextIndexDescriptor Properties
TnxFulltextIndexDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFulltextIndexDescriptor class are listed here.

Class

TnxFulltextIndexDescriptor Class

Public Properties
Name | Description
LocationIndex | This is LocationIndex, a member of class TnxFulltextIndexDescriptor.
LocationIndexNumber | This is LocationIndexNumber, a member of class TnxFulltextIndexDescriptor.
Name | This is Name, a member of class TnxFulltextIndexDescriptor.
TokenExtractor | This is TokenExtractor, a member of class TnxFulltextIndexDescriptor.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxFulltextIndexDescriptor.
TokenExtractorHub | Extractor
TokenExtractorName | This is TokenExtractorName, a member of class TnxFulltextIndexDescriptor.
TokenFilter | This is TokenFilter, a member of class TnxFulltextIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxFulltextIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxFulltextIndexDescriptor.
TokenIndex | This is TokenIndex, a member of class TnxFulltextIndexDescriptor.
TokenIndexCount | This is TokenIndexCount, a member of class TnxFulltextIndexDescriptor.
TokenIndexHub | Index
TokenIndexName | This is TokenIndexName, a member of class TnxFulltextIndexDescriptor.
Links
TnxFulltextIndexDescriptor Class, Legend, Public Properties


TnxFulltextIndexDescriptor.LocationIndex Property

TnxFulltextIndexDescriptor.LocationIndex Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property LocationIndex: TnxIndexDescriptor;
Description

This is LocationIndex, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.LocationIndexNumber Property

TnxFulltextIndexDescriptor.LocationIndexNumber Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property LocationIndexNumber: Integer;
Description

This is LocationIndexNumber, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.Name Property

TnxFulltextIndexDescriptor.Name Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property Name: String;
Description

This is Name, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenExtractor Property

TnxFulltextIndexDescriptor.TokenExtractor Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractor [aInx : Integer]: TnxBaseTokenExtractorDescriptor;
Description

This is TokenExtractor, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenExtractorCount Property

TnxFulltextIndexDescriptor.TokenExtractorCount Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractorCount: Integer;
Description

This is TokenExtractorCount, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenExtractorHub Property

TnxFulltextIndexDescriptor.TokenExtractorHub Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractorHub: TnxTokenExtractorHubDescriptor;
Description

Extractor

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenExtractorName Property

TnxFulltextIndexDescriptor.TokenExtractorName Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractorName [aInx : Integer]: string;
Description

This is TokenExtractorName, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenFilter Property

TnxFulltextIndexDescriptor.TokenFilter Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilter [aInx : Integer]: TnxBaseTokenFilterDescriptor;
Description

This is TokenFilter, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenFilterCount Property

TnxFulltextIndexDescriptor.TokenFilterCount Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterCount: Integer;
Description

This is TokenFilterCount, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenFilterHub Property

TnxFulltextIndexDescriptor.TokenFilterHub Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterHub: TnxTokenFilterHubDescriptor;
Description

Filter

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenFilterName Property

TnxFulltextIndexDescriptor.TokenFilterName Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterName [aInx : Integer]: string;
Description

This is TokenFilterName, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenIndex Property

TnxFulltextIndexDescriptor.TokenIndex Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndex [aInx : Integer]: TnxBaseTokenIndexDescriptor;
Description

This is TokenIndex, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenIndexCount Property

TnxFulltextIndexDescriptor.TokenIndexCount Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndexCount: Integer;
Description

This is TokenIndexCount, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenIndexHub Property

TnxFulltextIndexDescriptor.TokenIndexHub Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndexHub: TnxTokenIndexHubDescriptor;
Description

Index

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxFulltextIndexDescriptor.TokenIndexName Property

TnxFulltextIndexDescriptor.TokenIndexName Property
TnxFulltextIndexDescriptor Class TnxFulltextIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxFulltextIndexDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndexName [aInx : Integer]: string;
Description

This is TokenIndexName, a member of class TnxFulltextIndexDescriptor.

Group

TnxFulltextIndexDescriptor Properties

Links
TnxFulltextIndexDescriptor Class, TnxFulltextIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxFulltextIndexDescriptor Properties


TnxLowercaseLocaleMappingTokenFilterDescriptor Class

TnxLowercaseLocaleMappingTokenFilterDescriptor Class
TnxLowercaseLocaleMappingTokenFilterDescriptor Methods TnxLowercaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxLowercaseLocaleMappingTokenFilterDescriptor
Syntax
Delphi
TnxLowercaseLocaleMappingTokenFilterDescriptor = class(TnxBaseLocaleMappingTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxLowercaseLocaleMappingTokenFilterDescriptor.

Group

Classes

Links
TnxLowercaseLocaleMappingTokenFilterDescriptor Methods, TnxLowercaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxLowercaseLocaleMappingTokenFilterDescriptor Members

TnxLowercaseLocaleMappingTokenFilterDescriptor Members
TnxLowercaseLocaleMappingTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLowercaseLocaleMappingTokenFilterDescriptor.

Class

TnxLowercaseLocaleMappingTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
blmtfdGetFlags | TnxLowercaseLocaleMappingTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
LoadFromReader |
LoadFromReader |
LoadFromReader | TnxBaseLocaleMappingTokenFilterDescriptor
LoadFromReader |
LoadFromReader | TnxBaseTokenSourceDescriptor
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxLowercaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLowercaseLocaleMappingTokenFilterDescriptor Methods

TnxLowercaseLocaleMappingTokenFilterDescriptor Methods
TnxLowercaseLocaleMappingTokenFilterDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxLowercaseLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxLowercaseLocaleMappingTokenFilterDescriptor Class

Protected Methods
Name | Description
blmtfdGetFlags | TnxLowercaseLocaleMappingTokenFilterDescriptor
Links
TnxLowercaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Methods


TnxLowercaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method

TnxLowercaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method
TnxLowercaseLocaleMappingTokenFilterDescriptor Class TnxLowercaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxLowercaseLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function blmtfdGetFlags: Cardinal; override;
Description

TnxLowercaseLocaleMappingTokenFilterDescriptor

Group

TnxLowercaseLocaleMappingTokenFilterDescriptor Methods

Links
TnxLowercaseLocaleMappingTokenFilterDescriptor Class, TnxLowercaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxLowercaseLocaleMappingTokenFilterDescriptor Methods


TnxMainIndexTokenIndexDescriptor Class

TnxMainIndexTokenIndexDescriptor Class
TnxMainIndexTokenIndexDescriptor Fields TnxMainIndexTokenIndexDescriptor Methods TnxMainIndexTokenIndexDescriptor Properties TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenIndexDescriptor
Syntax
Delphi
TnxMainIndexTokenIndexDescriptor = class(TnxBaseTokenIndexDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenIndexDescriptor.

Group

Classes

Links
TnxMainIndexTokenIndexDescriptor Fields, TnxMainIndexTokenIndexDescriptor Methods, TnxMainIndexTokenIndexDescriptor Properties, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxMainIndexTokenIndexDescriptor Members

TnxMainIndexTokenIndexDescriptor Members
TnxMainIndexTokenIndexDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMainIndexTokenIndexDescriptor.

Class

TnxMainIndexTokenIndexDescriptor Class

Protected Fields
Name | Description
btidTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
mitidIgnoreCase | This is mitidIgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.
mitidMainIndexNumber | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
btidGetName |
btidGetTokenFilter |
btidGetTokenFilterCount |
btidGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify |
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
mitidCheckValidMainIndex |
mitidGetMainIndex |
mitidSetIgnoreCase |
mitidSetMainIndexNumber |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxBaseTokenIndexDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxMainIndexTokenIndexDescriptor
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IgnoreCase | This is IgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.
LocaleDescriptor | This property returns the associated Locale Descriptor.
MainIndex | This is MainIndex, a member of class TnxMainIndexTokenIndexDescriptor.
MainIndexNumber | general properties
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxMainIndexTokenIndexDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMainIndexTokenIndexDescriptor.Create Constructor

TnxMainIndexTokenIndexDescriptor.Create Constructor
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxMainIndexTokenIndexDescriptor Class

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Class


TnxMainIndexTokenIndexDescriptor.Destroy Destructor

TnxMainIndexTokenIndexDescriptor.Destroy Destructor
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMainIndexTokenIndexDescriptor Class

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Class


TnxMainIndexTokenIndexDescriptor Fields

TnxMainIndexTokenIndexDescriptor Fields
TnxMainIndexTokenIndexDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxMainIndexTokenIndexDescriptor class are listed here.

Class

TnxMainIndexTokenIndexDescriptor Class

Protected Fields
Name | Description
mitidIgnoreCase | This is mitidIgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.
mitidMainIndexNumber | private
Links
TnxMainIndexTokenIndexDescriptor Class, Legend, Protected Fields


TnxMainIndexTokenIndexDescriptor.mitidIgnoreCase Field

TnxMainIndexTokenIndexDescriptor.mitidIgnoreCase Field
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
mitidIgnoreCase: Boolean;
Description

This is mitidIgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.

Group

TnxMainIndexTokenIndexDescriptor Fields

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Fields


TnxMainIndexTokenIndexDescriptor.mitidMainIndexNumber Field

TnxMainIndexTokenIndexDescriptor.mitidMainIndexNumber Field
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Fields Send Feedback
Syntax
Delphi
mitidMainIndexNumber: Integer;
Description

private

Group

TnxMainIndexTokenIndexDescriptor Fields

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Fields


TnxMainIndexTokenIndexDescriptor Methods

TnxMainIndexTokenIndexDescriptor Methods
TnxMainIndexTokenIndexDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMainIndexTokenIndexDescriptor class are listed here.

Class

TnxMainIndexTokenIndexDescriptor Class

Protected Methods
Name | Description
diIndexChangeNotify |
mitidCheckValidMainIndex |
mitidGetMainIndex |
mitidSetIgnoreCase |
mitidSetMainIndexNumber |
Public Methods
Name | Description
CheckValid | TnxMainIndexTokenIndexDescriptor
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxMainIndexTokenIndexDescriptor Class, Legend, Protected Methods, Public Methods


TnxMainIndexTokenIndexDescriptor.CheckValid Method

TnxMainIndexTokenIndexDescriptor.CheckValid Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxMainIndexTokenIndexDescriptor

Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.diIndexChangeNotify Method

TnxMainIndexTokenIndexDescriptor.diIndexChangeNotify Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure diIndexChangeNotify(aBefore: Boolean; aOldIndex: Integer; aNewIndex: Integer); override;
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.IsEqual Method

TnxMainIndexTokenIndexDescriptor.IsEqual Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.LoadFromReader Method

TnxMainIndexTokenIndexDescriptor.LoadFromReader Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.mitidCheckValidMainIndex Method

TnxMainIndexTokenIndexDescriptor.mitidCheckValidMainIndex Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitidCheckValidMainIndex(aIndex: Integer);
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.mitidGetMainIndex Method

TnxMainIndexTokenIndexDescriptor.mitidGetMainIndex Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
function mitidGetMainIndex: TnxIndexDescriptor;
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.mitidSetIgnoreCase Method

TnxMainIndexTokenIndexDescriptor.mitidSetIgnoreCase Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitidSetIgnoreCase(const Value: Boolean);
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.mitidSetMainIndexNumber Method

TnxMainIndexTokenIndexDescriptor.mitidSetMainIndexNumber Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitidSetMainIndexNumber(const Value: Integer);
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor.SaveToWriter Method

TnxMainIndexTokenIndexDescriptor.SaveToWriter Method
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxMainIndexTokenIndexDescriptor Methods

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Methods


TnxMainIndexTokenIndexDescriptor Properties

TnxMainIndexTokenIndexDescriptor Properties
TnxMainIndexTokenIndexDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxMainIndexTokenIndexDescriptor class are listed here.

Class

TnxMainIndexTokenIndexDescriptor Class

Public Properties
Name | Description
IgnoreCase | This is IgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.
MainIndex | This is MainIndex, a member of class TnxMainIndexTokenIndexDescriptor.
MainIndexNumber | general properties
Links
TnxMainIndexTokenIndexDescriptor Class, Legend, Public Properties


TnxMainIndexTokenIndexDescriptor.IgnoreCase Property

TnxMainIndexTokenIndexDescriptor.IgnoreCase Property
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreCase: Boolean;
Description

This is IgnoreCase, a member of class TnxMainIndexTokenIndexDescriptor.

Group

TnxMainIndexTokenIndexDescriptor Properties

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Properties


TnxMainIndexTokenIndexDescriptor.MainIndex Property

TnxMainIndexTokenIndexDescriptor.MainIndex Property
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property MainIndex: TnxIndexDescriptor;
Description

This is MainIndex, a member of class TnxMainIndexTokenIndexDescriptor.

Group

TnxMainIndexTokenIndexDescriptor Properties

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Properties


TnxMainIndexTokenIndexDescriptor.MainIndexNumber Property

TnxMainIndexTokenIndexDescriptor.MainIndexNumber Property
TnxMainIndexTokenIndexDescriptor Class TnxMainIndexTokenIndexDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenIndexDescriptor Properties Send Feedback
Syntax
Delphi
property MainIndexNumber: Integer;
Description

general properties

Group

TnxMainIndexTokenIndexDescriptor Properties

Links
TnxMainIndexTokenIndexDescriptor Class, TnxMainIndexTokenIndexDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenIndexDescriptor Properties


TnxMainIndexTokenKeyDescriptor Class

TnxMainIndexTokenKeyDescriptor Class
TnxMainIndexTokenKeyDescriptor Fields TnxMainIndexTokenKeyDescriptor Methods TnxMainIndexTokenKeyDescriptor Properties TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptornxsdDataDictionaryFulltext_TnxMainIndexTokenKeyDescriptor
Syntax
Delphi
TnxMainIndexTokenKeyDescriptor = class(TnxBaseKeyDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptor.

Group

Classes

Links
TnxMainIndexTokenKeyDescriptor Fields, TnxMainIndexTokenKeyDescriptor Methods, TnxMainIndexTokenKeyDescriptor Properties, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxMainIndexTokenKeyDescriptor Members

TnxMainIndexTokenKeyDescriptor Members
TnxMainIndexTokenKeyDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMainIndexTokenKeyDescriptor.

Class

TnxMainIndexTokenKeyDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
mitkdFlags | This is mitkdFlags, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdIncludeLocation | This is mitkdIncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdLocale | This is mitkdLocale, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdMaxTokenSize | private
Protected Methods
Name | Description
_AddRef |
_Release |
bkdGetKeyLen | TnxMainIndexTokenKeyDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
IsValidFor |
mitkdSetFlags |
mitkdSetIncludeLocation |
mitkdSetLocale |
mitkdSetMaxTokenSize |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
Filter | Internal use only - The current Filter the key is used in (if any)
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CanContainNulls |
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy |
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxMainIndexTokenKeyDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IncludeLocation | This is IncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.
KeyLen | This property returns the length of the created keys.
Locale | This is Locale, a member of class TnxMainIndexTokenKeyDescriptor.
MaxTokenSize | This is MaxTokenSize, a member of class TnxMainIndexTokenKeyDescriptor.
Links
TnxMainIndexTokenKeyDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxMainIndexTokenKeyDescriptor.Create Constructor

TnxMainIndexTokenKeyDescriptor.Create Constructor
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxMainIndexTokenKeyDescriptor Class

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Class


TnxMainIndexTokenKeyDescriptor Fields

TnxMainIndexTokenKeyDescriptor Fields
TnxMainIndexTokenKeyDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxMainIndexTokenKeyDescriptor class are listed here.

Class

TnxMainIndexTokenKeyDescriptor Class

Protected Fields
Name | Description
mitkdFlags | This is mitkdFlags, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdIncludeLocation | This is mitkdIncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdLocale | This is mitkdLocale, a member of class TnxMainIndexTokenKeyDescriptor.
mitkdMaxTokenSize | private
Links
TnxMainIndexTokenKeyDescriptor Class, Legend, Protected Fields


TnxMainIndexTokenKeyDescriptor.mitkdFlags Field

TnxMainIndexTokenKeyDescriptor.mitkdFlags Field
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
mitkdFlags: Cardinal;
Description

This is mitkdFlags, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Fields

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Fields


TnxMainIndexTokenKeyDescriptor.mitkdIncludeLocation Field

TnxMainIndexTokenKeyDescriptor.mitkdIncludeLocation Field
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
mitkdIncludeLocation: Boolean;
Description

This is mitkdIncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Fields

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Fields


TnxMainIndexTokenKeyDescriptor.mitkdLocale Field

TnxMainIndexTokenKeyDescriptor.mitkdLocale Field
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
mitkdLocale: LCID;
Description

This is mitkdLocale, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Fields

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Fields


TnxMainIndexTokenKeyDescriptor.mitkdMaxTokenSize Field

TnxMainIndexTokenKeyDescriptor.mitkdMaxTokenSize Field
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Fields Send Feedback
Syntax
Delphi
mitkdMaxTokenSize: Integer;
Description

private

Group

TnxMainIndexTokenKeyDescriptor Fields

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Fields


TnxMainIndexTokenKeyDescriptor Methods

TnxMainIndexTokenKeyDescriptor Methods
TnxMainIndexTokenKeyDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMainIndexTokenKeyDescriptor class are listed here.

Class

TnxMainIndexTokenKeyDescriptor Class

Protected Methods
Name | Description
bkdGetKeyLen | TnxMainIndexTokenKeyDescriptor
mitkdSetFlags |
mitkdSetIncludeLocation |
mitkdSetLocale |
mitkdSetMaxTokenSize |
Public Methods
Name | Description
CanContainNulls |
LoadFromReader |
SaveToWriter |
Links
TnxMainIndexTokenKeyDescriptor Class, Legend, Protected Methods, Public Methods


TnxMainIndexTokenKeyDescriptor.bkdGetKeyLen Method

TnxMainIndexTokenKeyDescriptor.bkdGetKeyLen Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
function bkdGetKeyLen: TnxWord32; override;
Description

TnxMainIndexTokenKeyDescriptor

Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.CanContainNulls Method

TnxMainIndexTokenKeyDescriptor.CanContainNulls Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
function CanContainNulls: Boolean; override;
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.LoadFromReader Method

TnxMainIndexTokenKeyDescriptor.LoadFromReader Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.mitkdSetFlags Method

TnxMainIndexTokenKeyDescriptor.mitkdSetFlags Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitkdSetFlags(const Value: Cardinal);
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.mitkdSetIncludeLocation Method

TnxMainIndexTokenKeyDescriptor.mitkdSetIncludeLocation Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitkdSetIncludeLocation(const Value: Boolean);
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.mitkdSetLocale Method

TnxMainIndexTokenKeyDescriptor.mitkdSetLocale Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitkdSetLocale(const Value: LCID);
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.mitkdSetMaxTokenSize Method

TnxMainIndexTokenKeyDescriptor.mitkdSetMaxTokenSize Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure mitkdSetMaxTokenSize(const Value: Integer);
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor.SaveToWriter Method

TnxMainIndexTokenKeyDescriptor.SaveToWriter Method
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxMainIndexTokenKeyDescriptor Methods

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Methods


TnxMainIndexTokenKeyDescriptor Properties

TnxMainIndexTokenKeyDescriptor Properties
TnxMainIndexTokenKeyDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxMainIndexTokenKeyDescriptor class are listed here.

Class

TnxMainIndexTokenKeyDescriptor Class

Public Properties
Name | Description
Flags | This is Flags, a member of class TnxMainIndexTokenKeyDescriptor.
IncludeLocation | This is IncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.
Locale | This is Locale, a member of class TnxMainIndexTokenKeyDescriptor.
MaxTokenSize | This is MaxTokenSize, a member of class TnxMainIndexTokenKeyDescriptor.
Links
TnxMainIndexTokenKeyDescriptor Class, Legend, Public Properties


TnxMainIndexTokenKeyDescriptor.Flags Property

TnxMainIndexTokenKeyDescriptor.Flags Property
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property Flags: Cardinal;
Description

This is Flags, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Properties

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Properties


TnxMainIndexTokenKeyDescriptor.IncludeLocation Property

TnxMainIndexTokenKeyDescriptor.IncludeLocation Property
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property IncludeLocation: Boolean;
Description

This is IncludeLocation, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Properties

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Properties


TnxMainIndexTokenKeyDescriptor.Locale Property

TnxMainIndexTokenKeyDescriptor.Locale Property
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property Locale: LCID;
Description

This is Locale, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Properties

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Properties


TnxMainIndexTokenKeyDescriptor.MaxTokenSize Property

TnxMainIndexTokenKeyDescriptor.MaxTokenSize Property
TnxMainIndexTokenKeyDescriptor Class TnxMainIndexTokenKeyDescriptor Members nxsdDataDictionaryFulltext Namespace TnxMainIndexTokenKeyDescriptor Properties Send Feedback
Syntax
Delphi
property MaxTokenSize: Integer;
Description

This is MaxTokenSize, a member of class TnxMainIndexTokenKeyDescriptor.

Group

TnxMainIndexTokenKeyDescriptor Properties

Links
TnxMainIndexTokenKeyDescriptor Class, TnxMainIndexTokenKeyDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxMainIndexTokenKeyDescriptor Properties


TnxNumberedFulltextIndexDictionaryItem Class

TnxNumberedFulltextIndexDictionaryItem Class
TnxNumberedFulltextIndexDictionaryItem Fields TnxNumberedFulltextIndexDictionaryItem Methods TnxNumberedFulltextIndexDictionaryItem Properties TnxNumberedFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItemnxsdDataDictionaryFulltext_TnxNumberedFulltextIndexDictionaryItem
Syntax
Delphi
TnxNumberedFulltextIndexDictionaryItem = class(TnxBaseFulltextIndexDictionaryItem);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxNumberedFulltextIndexDictionaryItem.

Group

Classes

Links
TnxNumberedFulltextIndexDictionaryItem Fields, TnxNumberedFulltextIndexDictionaryItem Methods, TnxNumberedFulltextIndexDictionaryItem Properties, TnxNumberedFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext, Classes


TnxNumberedFulltextIndexDictionaryItem Members

TnxNumberedFulltextIndexDictionaryItem Members
TnxNumberedFulltextIndexDictionaryItem Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNumberedFulltextIndexDictionaryItem.

Class

TnxNumberedFulltextIndexDictionaryItem Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxNumberedFulltextIndexDictionaryItem Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxNumberedFulltextIndexDictionaryItem Fields

TnxNumberedFulltextIndexDictionaryItem Fields
TnxNumberedFulltextIndexDictionaryItem Class Legend Protected Fields Send Feedback

The fields of the TnxNumberedFulltextIndexDictionaryItem class are listed here.

Class

TnxNumberedFulltextIndexDictionaryItem Class

Protected Fields
Name | Description
nfidiNumber | private
Links
TnxNumberedFulltextIndexDictionaryItem Class, Legend, Protected Fields


TnxNumberedFulltextIndexDictionaryItem.nfidiNumber Field

TnxNumberedFulltextIndexDictionaryItem.nfidiNumber Field
TnxNumberedFulltextIndexDictionaryItem Class TnxNumberedFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxNumberedFulltextIndexDictionaryItem Fields Send Feedback
Syntax
Delphi
nfidiNumber: Integer;
Description

private

Group

TnxNumberedFulltextIndexDictionaryItem Fields

Links
TnxNumberedFulltextIndexDictionaryItem Class, TnxNumberedFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxNumberedFulltextIndexDictionaryItem Fields


TnxNumberedFulltextIndexDictionaryItem Methods

TnxNumberedFulltextIndexDictionaryItem Methods
TnxNumberedFulltextIndexDictionaryItem Class Legend Public Methods Send Feedback

The methods of the TnxNumberedFulltextIndexDictionaryItem class are listed here.

Class

TnxNumberedFulltextIndexDictionaryItem Class

Public Methods
Name | Description
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
SaveToWriter |
Links
TnxNumberedFulltextIndexDictionaryItem Class, Legend, Public Methods


TnxNumberedFulltextIndexDictionaryItem.LoadFromReader Method

TnxNumberedFulltextIndexDictionaryItem.LoadFromReader Method
TnxNumberedFulltextIndexDictionaryItem Class TnxNumberedFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxNumberedFulltextIndexDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxNumberedFulltextIndexDictionaryItem

Group

TnxNumberedFulltextIndexDictionaryItem Methods

Links
TnxNumberedFulltextIndexDictionaryItem Class, TnxNumberedFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxNumberedFulltextIndexDictionaryItem Methods


TnxNumberedFulltextIndexDictionaryItem.SaveToWriter Method

TnxNumberedFulltextIndexDictionaryItem.SaveToWriter Method
TnxNumberedFulltextIndexDictionaryItem Class TnxNumberedFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxNumberedFulltextIndexDictionaryItem Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxNumberedFulltextIndexDictionaryItem Methods

Links
TnxNumberedFulltextIndexDictionaryItem Class, TnxNumberedFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxNumberedFulltextIndexDictionaryItem Methods


TnxNumberedFulltextIndexDictionaryItem Properties

TnxNumberedFulltextIndexDictionaryItem Properties
TnxNumberedFulltextIndexDictionaryItem Class Legend Public Properties Send Feedback

The properties of the TnxNumberedFulltextIndexDictionaryItem class are listed here.

Class

TnxNumberedFulltextIndexDictionaryItem Class

Public Properties
Name | Description
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
Links
TnxNumberedFulltextIndexDictionaryItem Class, Legend, Public Properties


TnxNumberedFulltextIndexDictionaryItem.Number Property

TnxNumberedFulltextIndexDictionaryItem.Number Property
TnxNumberedFulltextIndexDictionaryItem Class TnxNumberedFulltextIndexDictionaryItem Members nxsdDataDictionaryFulltext Namespace TnxNumberedFulltextIndexDictionaryItem Properties Send Feedback
Syntax
Delphi
property Number: Integer;
Description

This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.

Group

TnxNumberedFulltextIndexDictionaryItem Properties

Links
TnxNumberedFulltextIndexDictionaryItem Class, TnxNumberedFulltextIndexDictionaryItem Members, nxsdDataDictionaryFulltext Namespace, TnxNumberedFulltextIndexDictionaryItem Properties


TnxPreComposeFoldStringTokenFilterDescriptor Class

TnxPreComposeFoldStringTokenFilterDescriptor Class
TnxPreComposeFoldStringTokenFilterDescriptor Methods TnxPreComposeFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptornxsdDataDictionaryFulltext_TnxPreComposeFoldStringTokenFilterDescriptor
Syntax
Delphi
TnxPreComposeFoldStringTokenFilterDescriptor = class(TnxBaseFoldStringTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxPreComposeFoldStringTokenFilterDescriptor.

Group

Classes

Links
TnxPreComposeFoldStringTokenFilterDescriptor Methods, TnxPreComposeFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxPreComposeFoldStringTokenFilterDescriptor Members

TnxPreComposeFoldStringTokenFilterDescriptor Members
TnxPreComposeFoldStringTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxPreComposeFoldStringTokenFilterDescriptor.

Class

TnxPreComposeFoldStringTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfstfdGetFlags | TnxPreComposeFoldStringTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
LoadFromReader | TnxBaseFoldStringTokenFilterDescriptor
LoadFromReader |
LoadFromReader |
LoadFromReader |
LoadFromReader | TnxBaseTokenSourceDescriptor
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseFoldStringTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxPreComposeFoldStringTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxPreComposeFoldStringTokenFilterDescriptor Methods

TnxPreComposeFoldStringTokenFilterDescriptor Methods
TnxPreComposeFoldStringTokenFilterDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxPreComposeFoldStringTokenFilterDescriptor class are listed here.

Class

TnxPreComposeFoldStringTokenFilterDescriptor Class

Protected Methods
Name | Description
bfstfdGetFlags | TnxPreComposeFoldStringTokenFilterDescriptor
Links
TnxPreComposeFoldStringTokenFilterDescriptor Class, Legend, Protected Methods


TnxPreComposeFoldStringTokenFilterDescriptor.bfstfdGetFlags Method

TnxPreComposeFoldStringTokenFilterDescriptor.bfstfdGetFlags Method
TnxPreComposeFoldStringTokenFilterDescriptor Class TnxPreComposeFoldStringTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxPreComposeFoldStringTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function bfstfdGetFlags: Cardinal; override;
Description

TnxPreComposeFoldStringTokenFilterDescriptor

Group

TnxPreComposeFoldStringTokenFilterDescriptor Methods

Links
TnxPreComposeFoldStringTokenFilterDescriptor Class, TnxPreComposeFoldStringTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxPreComposeFoldStringTokenFilterDescriptor Methods


TnxSimpleBitArrayStorageHandlerDescriptor Class

TnxSimpleBitArrayStorageHandlerDescriptor Class
TnxSimpleBitArrayStorageHandlerDescriptor Methods TnxSimpleBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptornxsdDataDictionaryFulltext_TnxSimpleBitArrayStorageHandlerDescriptor
Syntax
Delphi
TnxSimpleBitArrayStorageHandlerDescriptor = class(TnxBaseBitArrayStorageHandlerDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxSimpleBitArrayStorageHandlerDescriptor.

Group

Classes

Links
TnxSimpleBitArrayStorageHandlerDescriptor Methods, TnxSimpleBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxSimpleBitArrayStorageHandlerDescriptor Members

TnxSimpleBitArrayStorageHandlerDescriptor Members
TnxSimpleBitArrayStorageHandlerDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleBitArrayStorageHandlerDescriptor.

Class

TnxSimpleBitArrayStorageHandlerDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create | TnxBaseBitArrayStorageHandlerDescriptor
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxSimpleBitArrayStorageHandlerDescriptor
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxSimpleBitArrayStorageHandlerDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSimpleBitArrayStorageHandlerDescriptor Methods

TnxSimpleBitArrayStorageHandlerDescriptor Methods
TnxSimpleBitArrayStorageHandlerDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxSimpleBitArrayStorageHandlerDescriptor class are listed here.

Class

TnxSimpleBitArrayStorageHandlerDescriptor Class

Public Methods
Name | Description
CheckValid | TnxSimpleBitArrayStorageHandlerDescriptor
LoadFromReader |
SaveToWriter |
Links
TnxSimpleBitArrayStorageHandlerDescriptor Class, Legend, Public Methods


TnxSimpleBitArrayStorageHandlerDescriptor.CheckValid Method

TnxSimpleBitArrayStorageHandlerDescriptor.CheckValid Method
TnxSimpleBitArrayStorageHandlerDescriptor Class TnxSimpleBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxSimpleBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxSimpleBitArrayStorageHandlerDescriptor

Group

TnxSimpleBitArrayStorageHandlerDescriptor Methods

Links
TnxSimpleBitArrayStorageHandlerDescriptor Class, TnxSimpleBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxSimpleBitArrayStorageHandlerDescriptor Methods


TnxSimpleBitArrayStorageHandlerDescriptor.LoadFromReader Method

TnxSimpleBitArrayStorageHandlerDescriptor.LoadFromReader Method
TnxSimpleBitArrayStorageHandlerDescriptor Class TnxSimpleBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxSimpleBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxSimpleBitArrayStorageHandlerDescriptor Methods

Links
TnxSimpleBitArrayStorageHandlerDescriptor Class, TnxSimpleBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxSimpleBitArrayStorageHandlerDescriptor Methods


TnxSimpleBitArrayStorageHandlerDescriptor.SaveToWriter Method

TnxSimpleBitArrayStorageHandlerDescriptor.SaveToWriter Method
TnxSimpleBitArrayStorageHandlerDescriptor Class TnxSimpleBitArrayStorageHandlerDescriptor Members nxsdDataDictionaryFulltext Namespace TnxSimpleBitArrayStorageHandlerDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxSimpleBitArrayStorageHandlerDescriptor Methods

Links
TnxSimpleBitArrayStorageHandlerDescriptor Class, TnxSimpleBitArrayStorageHandlerDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxSimpleBitArrayStorageHandlerDescriptor Methods


TnxStringReplaceTokenFilterDescriptor Class

TnxStringReplaceTokenFilterDescriptor Class
TnxStringReplaceTokenFilterDescriptor Fields TnxStringReplaceTokenFilterDescriptor Methods TnxStringReplaceTokenFilterDescriptor Properties TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptornxsdDataDictionaryFulltext_TnxStringReplaceTokenFilterDescriptor
Syntax
Delphi
TnxStringReplaceTokenFilterDescriptor = class(TnxBaseTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterDescriptor.

Group

Classes

Links
TnxStringReplaceTokenFilterDescriptor Fields, TnxStringReplaceTokenFilterDescriptor Methods, TnxStringReplaceTokenFilterDescriptor Properties, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxStringReplaceTokenFilterDescriptor Members

TnxStringReplaceTokenFilterDescriptor Members
TnxStringReplaceTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxStringReplaceTokenFilterDescriptor.

Class

TnxStringReplaceTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
srtfdItems | This is srtfdItems, a member of class TnxStringReplaceTokenFilterDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
srtfdGetIgnoreCase | private
srtfdGetItemCount |
srtfdGetNewPattern |
srtfdGetOldPattern |
srtfdGetReplaceKind |
srtfdSetIgnoreCase |
srtfdSetNewPattern |
srtfdSetOldPattern |
srtfdSetReplaceKind |
srtfdValidateIndex |
Unregister |
Public Methods
Name | Description
AddItem | TnxStringReplaceTokenFilterDescriptor
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
MoveItem |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveItem |
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
IgnoreCase | This is IgnoreCase, a member of class TnxStringReplaceTokenFilterDescriptor.
ItemCount | This is ItemCount, a member of class TnxStringReplaceTokenFilterDescriptor.
Items | This is Items, a member of class TnxStringReplaceTokenFilterDescriptor.
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
NewPattern | This is NewPattern, a member of class TnxStringReplaceTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
OldPattern | This is OldPattern, a member of class TnxStringReplaceTokenFilterDescriptor.
ReplaceKind | This is ReplaceKind, a member of class TnxStringReplaceTokenFilterDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxStringReplaceTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxStringReplaceTokenFilterDescriptor Fields

TnxStringReplaceTokenFilterDescriptor Fields
TnxStringReplaceTokenFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxStringReplaceTokenFilterDescriptor class are listed here.

Class

TnxStringReplaceTokenFilterDescriptor Class

Protected Fields
Name | Description
srtfdItems | This is srtfdItems, a member of class TnxStringReplaceTokenFilterDescriptor.
Links
TnxStringReplaceTokenFilterDescriptor Class, Legend, Protected Fields


TnxStringReplaceTokenFilterDescriptor.srtfdItems Field

TnxStringReplaceTokenFilterDescriptor.srtfdItems Field
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Fields Send Feedback
Syntax
Delphi
srtfdItems: TnxStringReplaceTokenFilterItems;
Description

This is srtfdItems, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Fields

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Fields


TnxStringReplaceTokenFilterDescriptor Methods

TnxStringReplaceTokenFilterDescriptor Methods
TnxStringReplaceTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxStringReplaceTokenFilterDescriptor class are listed here.

Class

TnxStringReplaceTokenFilterDescriptor Class

Protected Methods
Name | Description
srtfdGetIgnoreCase | private
srtfdGetItemCount |
srtfdGetNewPattern |
srtfdGetOldPattern |
srtfdGetReplaceKind |
srtfdSetIgnoreCase |
srtfdSetNewPattern |
srtfdSetOldPattern |
srtfdSetReplaceKind |
srtfdValidateIndex |
Public Methods
Name | Description
AddItem | TnxStringReplaceTokenFilterDescriptor
LoadFromReader |
MoveItem |
RemoveItem |
SaveToWriter |
Links
TnxStringReplaceTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxStringReplaceTokenFilterDescriptor.AddItem Method

TnxStringReplaceTokenFilterDescriptor.AddItem Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function AddItem(const aOldPattern: string; const aNewPattern: string; aReplaceKind: TnxStringReplaceKind; aIgnoreCase: Boolean): Integer;
Description

TnxStringReplaceTokenFilterDescriptor

Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.LoadFromReader Method

TnxStringReplaceTokenFilterDescriptor.LoadFromReader Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.MoveItem Method

TnxStringReplaceTokenFilterDescriptor.MoveItem Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure MoveItem(aFrom: Integer; aTo: Integer);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.RemoveItem Method

TnxStringReplaceTokenFilterDescriptor.RemoveItem Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveItem(aIndex: Integer);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.SaveToWriter Method

TnxStringReplaceTokenFilterDescriptor.SaveToWriter Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdGetIgnoreCase Method

TnxStringReplaceTokenFilterDescriptor.srtfdGetIgnoreCase Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function srtfdGetIgnoreCase(aIndex: Integer): Boolean;
Description

private

Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdGetItemCount Method

TnxStringReplaceTokenFilterDescriptor.srtfdGetItemCount Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function srtfdGetItemCount: Integer;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdGetNewPattern Method

TnxStringReplaceTokenFilterDescriptor.srtfdGetNewPattern Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function srtfdGetNewPattern(aIndex: Integer): string;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdGetOldPattern Method

TnxStringReplaceTokenFilterDescriptor.srtfdGetOldPattern Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function srtfdGetOldPattern(aIndex: Integer): string;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdGetReplaceKind Method

TnxStringReplaceTokenFilterDescriptor.srtfdGetReplaceKind Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function srtfdGetReplaceKind(aIndex: Integer): TnxStringReplaceKind;
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdSetIgnoreCase Method

TnxStringReplaceTokenFilterDescriptor.srtfdSetIgnoreCase Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure srtfdSetIgnoreCase(aIndex: Integer; const Value: Boolean);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdSetNewPattern Method

TnxStringReplaceTokenFilterDescriptor.srtfdSetNewPattern Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure srtfdSetNewPattern(aIndex: Integer; const Value: string);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdSetOldPattern Method

TnxStringReplaceTokenFilterDescriptor.srtfdSetOldPattern Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure srtfdSetOldPattern(aIndex: Integer; const Value: string);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdSetReplaceKind Method

TnxStringReplaceTokenFilterDescriptor.srtfdSetReplaceKind Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure srtfdSetReplaceKind(aIndex: Integer; const Value: TnxStringReplaceKind);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor.srtfdValidateIndex Method

TnxStringReplaceTokenFilterDescriptor.srtfdValidateIndex Method
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure srtfdValidateIndex(aIndex: Integer);
Group

TnxStringReplaceTokenFilterDescriptor Methods

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Methods


TnxStringReplaceTokenFilterDescriptor Properties

TnxStringReplaceTokenFilterDescriptor Properties
TnxStringReplaceTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxStringReplaceTokenFilterDescriptor class are listed here.

Class

TnxStringReplaceTokenFilterDescriptor Class

Public Properties
Name | Description
IgnoreCase | This is IgnoreCase, a member of class TnxStringReplaceTokenFilterDescriptor.
ItemCount | This is ItemCount, a member of class TnxStringReplaceTokenFilterDescriptor.
Items | This is Items, a member of class TnxStringReplaceTokenFilterDescriptor.
NewPattern | This is NewPattern, a member of class TnxStringReplaceTokenFilterDescriptor.
OldPattern | This is OldPattern, a member of class TnxStringReplaceTokenFilterDescriptor.
ReplaceKind | This is ReplaceKind, a member of class TnxStringReplaceTokenFilterDescriptor.
Links
TnxStringReplaceTokenFilterDescriptor Class, Legend, Public Properties


TnxStringReplaceTokenFilterDescriptor.IgnoreCase Property

TnxStringReplaceTokenFilterDescriptor.IgnoreCase Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property IgnoreCase [aIndex: Integer]: Boolean;
Description

This is IgnoreCase, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxStringReplaceTokenFilterDescriptor.ItemCount Property

TnxStringReplaceTokenFilterDescriptor.ItemCount Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property ItemCount: Integer;
Description

This is ItemCount, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxStringReplaceTokenFilterDescriptor.Items Property

TnxStringReplaceTokenFilterDescriptor.Items Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Items: TnxStringReplaceTokenFilterItems;
Description

This is Items, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxStringReplaceTokenFilterDescriptor.NewPattern Property

TnxStringReplaceTokenFilterDescriptor.NewPattern Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property NewPattern [aIndex: Integer]: string;
Description

This is NewPattern, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxStringReplaceTokenFilterDescriptor.OldPattern Property

TnxStringReplaceTokenFilterDescriptor.OldPattern Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property OldPattern [aIndex: Integer]: string;
Description

This is OldPattern, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxStringReplaceTokenFilterDescriptor.ReplaceKind Property

TnxStringReplaceTokenFilterDescriptor.ReplaceKind Property
TnxStringReplaceTokenFilterDescriptor Class TnxStringReplaceTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxStringReplaceTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property ReplaceKind [aIndex: Integer]: TnxStringReplaceKind;
Description

This is ReplaceKind, a member of class TnxStringReplaceTokenFilterDescriptor.

Group

TnxStringReplaceTokenFilterDescriptor Properties

Links
TnxStringReplaceTokenFilterDescriptor Class, TnxStringReplaceTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxStringReplaceTokenFilterDescriptor Properties


TnxTokenExtractorHubDescriptor Class

TnxTokenExtractorHubDescriptor Class
TnxTokenExtractorHubDescriptor Fields TnxTokenExtractorHubDescriptor Methods TnxTokenExtractorHubDescriptor Properties TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptornxsdDataDictionaryFulltext_TnxTokenExtractorHubDescriptor
Syntax
Delphi
TnxTokenExtractorHubDescriptor = class(TnxBaseTokenExtractorDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptor.

Group

Classes

Links
TnxTokenExtractorHubDescriptor Fields, TnxTokenExtractorHubDescriptor Methods, TnxTokenExtractorHubDescriptor Properties, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxTokenExtractorHubDescriptor Members

TnxTokenExtractorHubDescriptor Members
TnxTokenExtractorHubDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenExtractorHubDescriptor.

Class

TnxTokenExtractorHubDescriptor Class

Protected Fields
Name | Description
btedTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
tehdTokenExtractors | private
Protected Methods
Name | Description
_AddRef |
_Release |
btedGetName |
btedGetTokenFilter |
btedGetTokenFilterCount |
btedGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tehdGetNameFor |
tehdGetTokenExtractor |
tehdGetTokenExtractorCount |
tehdGetTokenExtractorName |
Unregister |
Public Methods
Name | Description
AddFieldTokenExtractor | TnxTokenExtractorHubDescriptor
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenExtractor |
AddTokenExtractorHub |
AddTokenFilter | TnxBaseTokenExtractorDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear |
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenExtractor | This is the overview for the RemoveTokenExtractor method overload.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenExtractor | This is TokenExtractor, a member of class TnxTokenExtractorHubDescriptor.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxTokenExtractorHubDescriptor.
TokenExtractorName | This is TokenExtractorName, a member of class TnxTokenExtractorHubDescriptor.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenExtractorDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenExtractorDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxTokenExtractorHubDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenExtractorHubDescriptor.Create Constructor

TnxTokenExtractorHubDescriptor.Create Constructor
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxTokenExtractorHubDescriptor Class

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Class


TnxTokenExtractorHubDescriptor.Destroy Destructor

TnxTokenExtractorHubDescriptor.Destroy Destructor
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTokenExtractorHubDescriptor Class

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Class


TnxTokenExtractorHubDescriptor Fields

TnxTokenExtractorHubDescriptor Fields
TnxTokenExtractorHubDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxTokenExtractorHubDescriptor class are listed here.

Class

TnxTokenExtractorHubDescriptor Class

Protected Fields
Name | Description
tehdTokenExtractors | private
Links
TnxTokenExtractorHubDescriptor Class, Legend, Protected Fields


TnxTokenExtractorHubDescriptor.tehdTokenExtractors Field

TnxTokenExtractorHubDescriptor.tehdTokenExtractors Field
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Fields Send Feedback
Syntax
Delphi
tehdTokenExtractors: TStringList;
Description

private

Group

TnxTokenExtractorHubDescriptor Fields

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Fields


TnxTokenExtractorHubDescriptor Methods

TnxTokenExtractorHubDescriptor Methods
TnxTokenExtractorHubDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTokenExtractorHubDescriptor class are listed here.

Class

TnxTokenExtractorHubDescriptor Class

Protected Methods
Name | Description
tehdGetNameFor |
tehdGetTokenExtractor |
tehdGetTokenExtractorCount |
tehdGetTokenExtractorName |
Public Methods
Name | Description
AddFieldTokenExtractor | TnxTokenExtractorHubDescriptor
AddTokenExtractor |
AddTokenExtractorHub |
CheckValid |
Clear |
IsEqual |
LoadFromReader |
RemoveTokenExtractor | This is the overview for the RemoveTokenExtractor method overload.
SaveToWriter |
Links
TnxTokenExtractorHubDescriptor Class, Legend, Protected Methods, Public Methods


TnxTokenExtractorHubDescriptor.AddFieldTokenExtractor Method

TnxTokenExtractorHubDescriptor.AddFieldTokenExtractor Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function AddFieldTokenExtractor(aFieldNumber: Integer; aName: string = ''; aTokenExtractorClass: TnxFieldTokenExtractorDescriptorClass = nil): TnxFieldTokenExtractorDescriptor;
Description

TnxTokenExtractorHubDescriptor

Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.AddTokenExtractor Method

TnxTokenExtractorHubDescriptor.AddTokenExtractor Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenExtractor(const aName: string; aTokenExtractorClass: TnxBaseTokenExtractorDescriptorClass = nil): TnxBaseTokenExtractorDescriptor;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.AddTokenExtractorHub Method

TnxTokenExtractorHubDescriptor.AddTokenExtractorHub Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenExtractorHub(aName: string; aTokenExtractorClass: TnxTokenExtractorHubDescriptorClass = nil): TnxTokenExtractorHubDescriptor;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.CheckValid Method

TnxTokenExtractorHubDescriptor.CheckValid Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.Clear Method

TnxTokenExtractorHubDescriptor.Clear Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.IsEqual Method

TnxTokenExtractorHubDescriptor.IsEqual Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.LoadFromReader Method

TnxTokenExtractorHubDescriptor.LoadFromReader Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


RemoveTokenExtractor Method

RemoveTokenExtractor Method
TnxTokenExtractorHubDescriptor Methods Send Feedback

This is the overview for the RemoveTokenExtractor method overload.

Overload List
Name | Description
TnxTokenExtractorHubDescriptor.RemoveTokenExtractor (Integer) |
TnxTokenExtractorHubDescriptor.RemoveTokenExtractor (string) |
TnxTokenExtractorHubDescriptor.RemoveTokenExtractor (TnxBaseTokenExtractorDescriptor) |
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (Integer)

TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (Integer)
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(aIndex: Integer); overload;
Group

RemoveTokenExtractor Method

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (TnxBaseTokenExtractorDescriptor)

TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (TnxBaseTokenExtractorDescriptor)
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(aDescriptor: TnxBaseTokenExtractorDescriptor); overload;
Group

RemoveTokenExtractor Method

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (string)

TnxTokenExtractorHubDescriptor.RemoveTokenExtractor Method (string)
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenExtractor Method Send Feedback
Syntax
Delphi
procedure RemoveTokenExtractor(const aName: string); overload;
Group

RemoveTokenExtractor Method

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenExtractor Method


TnxTokenExtractorHubDescriptor.SaveToWriter Method

TnxTokenExtractorHubDescriptor.SaveToWriter Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.tehdGetNameFor Method

TnxTokenExtractorHubDescriptor.tehdGetNameFor Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function tehdGetNameFor(aDescriptor: TnxBaseTokenExtractorDescriptor): string;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.tehdGetTokenExtractor Method

TnxTokenExtractorHubDescriptor.tehdGetTokenExtractor Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function tehdGetTokenExtractor(aInx: Integer): TnxBaseTokenExtractorDescriptor;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.tehdGetTokenExtractorCount Method

TnxTokenExtractorHubDescriptor.tehdGetTokenExtractorCount Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function tehdGetTokenExtractorCount: Integer;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor.tehdGetTokenExtractorName Method

TnxTokenExtractorHubDescriptor.tehdGetTokenExtractorName Method
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Methods Send Feedback
Syntax
Delphi
function tehdGetTokenExtractorName(aInx: Integer): string;
Group

TnxTokenExtractorHubDescriptor Methods

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Methods


TnxTokenExtractorHubDescriptor Properties

TnxTokenExtractorHubDescriptor Properties
TnxTokenExtractorHubDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxTokenExtractorHubDescriptor class are listed here.

Class

TnxTokenExtractorHubDescriptor Class

Public Properties
Name | Description
TokenExtractor | This is TokenExtractor, a member of class TnxTokenExtractorHubDescriptor.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxTokenExtractorHubDescriptor.
TokenExtractorName | This is TokenExtractorName, a member of class TnxTokenExtractorHubDescriptor.
Links
TnxTokenExtractorHubDescriptor Class, Legend, Public Properties


TnxTokenExtractorHubDescriptor.TokenExtractor Property

TnxTokenExtractorHubDescriptor.TokenExtractor Property
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractor [aInx : Integer]: TnxBaseTokenExtractorDescriptor;
Description

This is TokenExtractor, a member of class TnxTokenExtractorHubDescriptor.

Group

TnxTokenExtractorHubDescriptor Properties

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Properties


TnxTokenExtractorHubDescriptor.TokenExtractorCount Property

TnxTokenExtractorHubDescriptor.TokenExtractorCount Property
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractorCount: Integer;
Description

This is TokenExtractorCount, a member of class TnxTokenExtractorHubDescriptor.

Group

TnxTokenExtractorHubDescriptor Properties

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Properties


TnxTokenExtractorHubDescriptor.TokenExtractorName Property

TnxTokenExtractorHubDescriptor.TokenExtractorName Property
TnxTokenExtractorHubDescriptor Class TnxTokenExtractorHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenExtractorHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenExtractorName [aInx : Integer]: string;
Description

This is TokenExtractorName, a member of class TnxTokenExtractorHubDescriptor.

Group

TnxTokenExtractorHubDescriptor Properties

Links
TnxTokenExtractorHubDescriptor Class, TnxTokenExtractorHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenExtractorHubDescriptor Properties


TnxTokenFilterHubDescriptor Class

TnxTokenFilterHubDescriptor Class
TnxTokenFilterHubDescriptor Fields TnxTokenFilterHubDescriptor Methods TnxTokenFilterHubDescriptor Properties TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptornxsdDataDictionaryFulltext_TnxTokenFilterHubDescriptor
Syntax
Delphi
TnxTokenFilterHubDescriptor = class(TnxBaseTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptor.

Group

Classes

Links
TnxTokenFilterHubDescriptor Fields, TnxTokenFilterHubDescriptor Methods, TnxTokenFilterHubDescriptor Properties, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxTokenFilterHubDescriptor Members

TnxTokenFilterHubDescriptor Members
TnxTokenFilterHubDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenFilterHubDescriptor.

Class

TnxTokenFilterHubDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
tfhdTokenFilters | private
Protected Methods
Name | Description
_AddRef |
_Release |
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tfhdGetNameFor |
tfhdGetTokenFilter |
tfhdGetTokenFilterCount |
tfhdGetTokenFilterName |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxTokenFilterHubDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxTokenFilterHubDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxTokenFilterHubDescriptor.
TokenFilterName | This is TokenFilterName, a member of class TnxTokenFilterHubDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxTokenFilterHubDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenFilterHubDescriptor.Create Constructor

TnxTokenFilterHubDescriptor.Create Constructor
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxTokenFilterHubDescriptor Class

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Class


TnxTokenFilterHubDescriptor.Destroy Destructor

TnxTokenFilterHubDescriptor.Destroy Destructor
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTokenFilterHubDescriptor Class

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Class


TnxTokenFilterHubDescriptor Fields

TnxTokenFilterHubDescriptor Fields
TnxTokenFilterHubDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxTokenFilterHubDescriptor class are listed here.

Class

TnxTokenFilterHubDescriptor Class

Protected Fields
Name | Description
tfhdTokenFilters | private
Links
TnxTokenFilterHubDescriptor Class, Legend, Protected Fields


TnxTokenFilterHubDescriptor.tfhdTokenFilters Field

TnxTokenFilterHubDescriptor.tfhdTokenFilters Field
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Fields Send Feedback
Syntax
Delphi
tfhdTokenFilters: TStringList;
Description

private

Group

TnxTokenFilterHubDescriptor Fields

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Fields


TnxTokenFilterHubDescriptor Methods

TnxTokenFilterHubDescriptor Methods
TnxTokenFilterHubDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTokenFilterHubDescriptor class are listed here.

Class

TnxTokenFilterHubDescriptor Class

Protected Methods
Name | Description
tfhdGetNameFor |
tfhdGetTokenFilter |
tfhdGetTokenFilterCount |
tfhdGetTokenFilterName |
Public Methods
Name | Description
AddTokenFilter | TnxTokenFilterHubDescriptor
CheckValid |
Clear |
IsEqual |
LoadFromReader |
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
SaveToWriter |
Links
TnxTokenFilterHubDescriptor Class, Legend, Protected Methods, Public Methods


TnxTokenFilterHubDescriptor.AddTokenFilter Method

TnxTokenFilterHubDescriptor.AddTokenFilter Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenFilter(aName: string = ''; aTokenFilterClass: TnxBaseTokenFilterDescriptorClass = nil): TnxBaseTokenFilterDescriptor;
Description

TnxTokenFilterHubDescriptor

Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.CheckValid Method

TnxTokenFilterHubDescriptor.CheckValid Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.Clear Method

TnxTokenFilterHubDescriptor.Clear Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.IsEqual Method

TnxTokenFilterHubDescriptor.IsEqual Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.LoadFromReader Method

TnxTokenFilterHubDescriptor.LoadFromReader Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


RemoveTokenFilter Method

RemoveTokenFilter Method
TnxTokenFilterHubDescriptor Methods Send Feedback

This is the overview for the RemoveTokenFilter method overload.

Overload List
Name | Description
TnxTokenFilterHubDescriptor.RemoveTokenFilter (Integer) |
TnxTokenFilterHubDescriptor.RemoveTokenFilter (string) |
TnxTokenFilterHubDescriptor.RemoveTokenFilter (TnxBaseTokenFilterDescriptor) |
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (Integer)

TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (Integer)
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aIndex: Integer); overload;
Group

RemoveTokenFilter Method

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)

TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (TnxBaseTokenFilterDescriptor)
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(aDescriptor: TnxBaseTokenFilterDescriptor); overload;
Group

RemoveTokenFilter Method

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (string)

TnxTokenFilterHubDescriptor.RemoveTokenFilter Method (string)
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenFilter Method Send Feedback
Syntax
Delphi
procedure RemoveTokenFilter(const aName: string); overload;
Group

RemoveTokenFilter Method

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenFilter Method


TnxTokenFilterHubDescriptor.SaveToWriter Method

TnxTokenFilterHubDescriptor.SaveToWriter Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.tfhdGetNameFor Method

TnxTokenFilterHubDescriptor.tfhdGetNameFor Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function tfhdGetNameFor(aDescriptor: TnxBaseTokenFilterDescriptor): string;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.tfhdGetTokenFilter Method

TnxTokenFilterHubDescriptor.tfhdGetTokenFilter Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function tfhdGetTokenFilter(aInx: Integer): TnxBaseTokenFilterDescriptor;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.tfhdGetTokenFilterCount Method

TnxTokenFilterHubDescriptor.tfhdGetTokenFilterCount Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function tfhdGetTokenFilterCount: Integer;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor.tfhdGetTokenFilterName Method

TnxTokenFilterHubDescriptor.tfhdGetTokenFilterName Method
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Methods Send Feedback
Syntax
Delphi
function tfhdGetTokenFilterName(aInx: Integer): string;
Group

TnxTokenFilterHubDescriptor Methods

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Methods


TnxTokenFilterHubDescriptor Properties

TnxTokenFilterHubDescriptor Properties
TnxTokenFilterHubDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxTokenFilterHubDescriptor class are listed here.

Class

TnxTokenFilterHubDescriptor Class

Public Properties
Name | Description
TokenFilter | This is TokenFilter, a member of class TnxTokenFilterHubDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxTokenFilterHubDescriptor.
TokenFilterName | This is TokenFilterName, a member of class TnxTokenFilterHubDescriptor.
Links
TnxTokenFilterHubDescriptor Class, Legend, Public Properties


TnxTokenFilterHubDescriptor.TokenFilter Property

TnxTokenFilterHubDescriptor.TokenFilter Property
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilter [aInx : Integer]: TnxBaseTokenFilterDescriptor;
Description

This is TokenFilter, a member of class TnxTokenFilterHubDescriptor.

Group

TnxTokenFilterHubDescriptor Properties

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Properties


TnxTokenFilterHubDescriptor.TokenFilterCount Property

TnxTokenFilterHubDescriptor.TokenFilterCount Property
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterCount: Integer;
Description

This is TokenFilterCount, a member of class TnxTokenFilterHubDescriptor.

Group

TnxTokenFilterHubDescriptor Properties

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Properties


TnxTokenFilterHubDescriptor.TokenFilterName Property

TnxTokenFilterHubDescriptor.TokenFilterName Property
TnxTokenFilterHubDescriptor Class TnxTokenFilterHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenFilterHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenFilterName [aInx : Integer]: string;
Description

This is TokenFilterName, a member of class TnxTokenFilterHubDescriptor.

Group

TnxTokenFilterHubDescriptor Properties

Links
TnxTokenFilterHubDescriptor Class, TnxTokenFilterHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenFilterHubDescriptor Properties


TnxTokenIndexHubDescriptor Class

TnxTokenIndexHubDescriptor Class
TnxTokenIndexHubDescriptor Fields TnxTokenIndexHubDescriptor Methods TnxTokenIndexHubDescriptor Properties TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptornxsdDataDictionaryFulltext_TnxTokenIndexHubDescriptor
Syntax
Delphi
TnxTokenIndexHubDescriptor = class(TnxBaseTokenIndexDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptor.

Group

Classes

Links
TnxTokenIndexHubDescriptor Fields, TnxTokenIndexHubDescriptor Methods, TnxTokenIndexHubDescriptor Properties, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxTokenIndexHubDescriptor Members

TnxTokenIndexHubDescriptor Members
TnxTokenIndexHubDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenIndexHubDescriptor.

Class

TnxTokenIndexHubDescriptor Class

Protected Fields
Name | Description
btidTokenFilterHub | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
tihdTokenIndexes | private
Protected Methods
Name | Description
_AddRef |
_Release |
btidGetName |
btidGetTokenFilter |
btidGetTokenFilterCount |
btidGetTokenFilterName |
CheckReadOnly |
Create |
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
tihdGetNameFor |
tihdGetTokenIndex |
tihdGetTokenIndexCount |
tihdGetTokenIndexName |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
AddTokenFilter | TnxBaseTokenIndexDescriptor
AddTokenIndex | TnxTokenIndexHubDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Clear |
ClearTokenFilter |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RemoveTokenFilter | This is the overview for the RemoveTokenFilter method overload.
RemoveTokenIndex | This is the overview for the RemoveTokenIndex method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name |
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterCount | This is TokenFilterCount, a member of class TnxBaseTokenIndexDescriptor.
TokenFilterHub | Filter
TokenFilterName | This is TokenFilterName, a member of class TnxBaseTokenIndexDescriptor.
TokenIndex | This is TokenIndex, a member of class TnxTokenIndexHubDescriptor.
TokenIndexCount | This is TokenIndexCount, a member of class TnxTokenIndexHubDescriptor.
TokenIndexName | This is TokenIndexName, a member of class TnxTokenIndexHubDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxTokenIndexHubDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenIndexHubDescriptor.Create Constructor

TnxTokenIndexHubDescriptor.Create Constructor
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxTokenIndexHubDescriptor Class

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Class


TnxTokenIndexHubDescriptor.Destroy Destructor

TnxTokenIndexHubDescriptor.Destroy Destructor
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTokenIndexHubDescriptor Class

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Class


TnxTokenIndexHubDescriptor Fields

TnxTokenIndexHubDescriptor Fields
TnxTokenIndexHubDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxTokenIndexHubDescriptor class are listed here.

Class

TnxTokenIndexHubDescriptor Class

Protected Fields
Name | Description
tihdTokenIndexes | private
Links
TnxTokenIndexHubDescriptor Class, Legend, Protected Fields


TnxTokenIndexHubDescriptor.tihdTokenIndexes Field

TnxTokenIndexHubDescriptor.tihdTokenIndexes Field
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Fields Send Feedback
Syntax
Delphi
tihdTokenIndexes: TStringList;
Description

private

Group

TnxTokenIndexHubDescriptor Fields

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Fields


TnxTokenIndexHubDescriptor Methods

TnxTokenIndexHubDescriptor Methods
TnxTokenIndexHubDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTokenIndexHubDescriptor class are listed here.

Class

TnxTokenIndexHubDescriptor Class

Protected Methods
Name | Description
tihdGetNameFor |
tihdGetTokenIndex |
tihdGetTokenIndexCount |
tihdGetTokenIndexName |
Public Methods
Name | Description
AddTokenIndex | TnxTokenIndexHubDescriptor
CheckValid |
Clear |
IsEqual |
LoadFromReader |
RemoveTokenIndex | This is the overview for the RemoveTokenIndex method overload.
SaveToWriter |
Links
TnxTokenIndexHubDescriptor Class, Legend, Protected Methods, Public Methods


TnxTokenIndexHubDescriptor.AddTokenIndex Method

TnxTokenIndexHubDescriptor.AddTokenIndex Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function AddTokenIndex(aName: string = ''; aTokenIndexClass: TnxBaseTokenIndexDescriptorClass = nil): TnxBaseTokenIndexDescriptor;
Description

TnxTokenIndexHubDescriptor

Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.CheckValid Method

TnxTokenIndexHubDescriptor.CheckValid Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.Clear Method

TnxTokenIndexHubDescriptor.Clear Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.IsEqual Method

TnxTokenIndexHubDescriptor.IsEqual Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.LoadFromReader Method

TnxTokenIndexHubDescriptor.LoadFromReader Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


RemoveTokenIndex Method

RemoveTokenIndex Method
TnxTokenIndexHubDescriptor Methods Send Feedback

This is the overview for the RemoveTokenIndex method overload.

Overload List
Name | Description
TnxTokenIndexHubDescriptor.RemoveTokenIndex (Integer) |
TnxTokenIndexHubDescriptor.RemoveTokenIndex (string) |
TnxTokenIndexHubDescriptor.RemoveTokenIndex (TnxBaseTokenIndexDescriptor) |
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (Integer)

TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (Integer)
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(aIndex: Integer); overload;
Group

RemoveTokenIndex Method

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (TnxBaseTokenIndexDescriptor)

TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (TnxBaseTokenIndexDescriptor)
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(aDescriptor: TnxBaseTokenIndexDescriptor); overload;
Group

RemoveTokenIndex Method

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (string)

TnxTokenIndexHubDescriptor.RemoveTokenIndex Method (string)
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace RemoveTokenIndex Method Send Feedback
Syntax
Delphi
procedure RemoveTokenIndex(const aName: string); overload;
Group

RemoveTokenIndex Method

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, RemoveTokenIndex Method


TnxTokenIndexHubDescriptor.SaveToWriter Method

TnxTokenIndexHubDescriptor.SaveToWriter Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.tihdGetNameFor Method

TnxTokenIndexHubDescriptor.tihdGetNameFor Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function tihdGetNameFor(aDescriptor: TnxBaseTokenIndexDescriptor): string;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.tihdGetTokenIndex Method

TnxTokenIndexHubDescriptor.tihdGetTokenIndex Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function tihdGetTokenIndex(aInx: Integer): TnxBaseTokenIndexDescriptor;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.tihdGetTokenIndexCount Method

TnxTokenIndexHubDescriptor.tihdGetTokenIndexCount Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function tihdGetTokenIndexCount: Integer;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor.tihdGetTokenIndexName Method

TnxTokenIndexHubDescriptor.tihdGetTokenIndexName Method
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Methods Send Feedback
Syntax
Delphi
function tihdGetTokenIndexName(aInx: Integer): string;
Group

TnxTokenIndexHubDescriptor Methods

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Methods


TnxTokenIndexHubDescriptor Properties

TnxTokenIndexHubDescriptor Properties
TnxTokenIndexHubDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxTokenIndexHubDescriptor class are listed here.

Class

TnxTokenIndexHubDescriptor Class

Public Properties
Name | Description
TokenIndex | This is TokenIndex, a member of class TnxTokenIndexHubDescriptor.
TokenIndexCount | This is TokenIndexCount, a member of class TnxTokenIndexHubDescriptor.
TokenIndexName | This is TokenIndexName, a member of class TnxTokenIndexHubDescriptor.
Links
TnxTokenIndexHubDescriptor Class, Legend, Public Properties


TnxTokenIndexHubDescriptor.TokenIndex Property

TnxTokenIndexHubDescriptor.TokenIndex Property
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndex [aInx : Integer]: TnxBaseTokenIndexDescriptor;
Description

This is TokenIndex, a member of class TnxTokenIndexHubDescriptor.

Group

TnxTokenIndexHubDescriptor Properties

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Properties


TnxTokenIndexHubDescriptor.TokenIndexCount Property

TnxTokenIndexHubDescriptor.TokenIndexCount Property
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndexCount: Integer;
Description

This is TokenIndexCount, a member of class TnxTokenIndexHubDescriptor.

Group

TnxTokenIndexHubDescriptor Properties

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Properties


TnxTokenIndexHubDescriptor.TokenIndexName Property

TnxTokenIndexHubDescriptor.TokenIndexName Property
TnxTokenIndexHubDescriptor Class TnxTokenIndexHubDescriptor Members nxsdDataDictionaryFulltext Namespace TnxTokenIndexHubDescriptor Properties Send Feedback
Syntax
Delphi
property TokenIndexName [aInx : Integer]: string;
Description

This is TokenIndexName, a member of class TnxTokenIndexHubDescriptor.

Group

TnxTokenIndexHubDescriptor Properties

Links
TnxTokenIndexHubDescriptor Class, TnxTokenIndexHubDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxTokenIndexHubDescriptor Properties


TnxTokenIndicesDescriptor Class

TnxTokenIndicesDescriptor Class
nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptornxsdDataDictionaryFulltext_TnxTokenIndicesDescriptor
Syntax
Delphi
TnxTokenIndicesDescriptor = class(TnxBaseIndicesDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxTokenIndicesDescriptor.

Group

Classes

Links
nxsdDataDictionaryFulltext, Classes


TnxUppercaseLocaleMappingTokenFilterDescriptor Class

TnxUppercaseLocaleMappingTokenFilterDescriptor Class
TnxUppercaseLocaleMappingTokenFilterDescriptor Methods TnxUppercaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptornxsdDataDictionaryFulltext_TnxUppercaseLocaleMappingTokenFilterDescriptor
Syntax
Delphi
TnxUppercaseLocaleMappingTokenFilterDescriptor = class(TnxBaseLocaleMappingTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxUppercaseLocaleMappingTokenFilterDescriptor.

Group

Classes

Links
TnxUppercaseLocaleMappingTokenFilterDescriptor Methods, TnxUppercaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxUppercaseLocaleMappingTokenFilterDescriptor Members

TnxUppercaseLocaleMappingTokenFilterDescriptor Members
TnxUppercaseLocaleMappingTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxUppercaseLocaleMappingTokenFilterDescriptor.

Class

TnxUppercaseLocaleMappingTokenFilterDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
Protected Methods
Name | Description
_AddRef |
_Release |
blmtfdGetFlags | TnxUppercaseLocaleMappingTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create |
Create | TnxBaseFulltextDictionaryItem
Create | TnxBaseFulltextIndexDictionaryItem
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | Loads the item settings from a Reader/Stream
LoadFromReader |
LoadFromReader |
LoadFromReader | TnxBaseLocaleMappingTokenFilterDescriptor
LoadFromReader |
LoadFromReader | TnxBaseTokenSourceDescriptor
LoadFromReader | TnxNumberedFulltextIndexDictionaryItem
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter | Saves the item settings to a Writer/Stream
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Flags | This is Flags, a member of class TnxBaseLocaleMappingTokenFilterDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxUppercaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxUppercaseLocaleMappingTokenFilterDescriptor Methods

TnxUppercaseLocaleMappingTokenFilterDescriptor Methods
TnxUppercaseLocaleMappingTokenFilterDescriptor Class Legend Protected Methods Send Feedback

The methods of the TnxUppercaseLocaleMappingTokenFilterDescriptor class are listed here.

Class

TnxUppercaseLocaleMappingTokenFilterDescriptor Class

Protected Methods
Name | Description
blmtfdGetFlags | TnxUppercaseLocaleMappingTokenFilterDescriptor
Links
TnxUppercaseLocaleMappingTokenFilterDescriptor Class, Legend, Protected Methods


TnxUppercaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method

TnxUppercaseLocaleMappingTokenFilterDescriptor.blmtfdGetFlags Method
TnxUppercaseLocaleMappingTokenFilterDescriptor Class TnxUppercaseLocaleMappingTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxUppercaseLocaleMappingTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
function blmtfdGetFlags: Cardinal; override;
Description

TnxUppercaseLocaleMappingTokenFilterDescriptor

Group

TnxUppercaseLocaleMappingTokenFilterDescriptor Methods

Links
TnxUppercaseLocaleMappingTokenFilterDescriptor Class, TnxUppercaseLocaleMappingTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxUppercaseLocaleMappingTokenFilterDescriptor Methods


TnxWideCharSeparatorTokenFilterDescriptor Class

TnxWideCharSeparatorTokenFilterDescriptor Class
TnxWideCharSeparatorTokenFilterDescriptor Fields TnxWideCharSeparatorTokenFilterDescriptor Methods TnxWideCharSeparatorTokenFilterDescriptor Properties TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptornxsdDataDictionaryFulltext_TnxWideCharSeparatorTokenFilterDescriptor
Syntax
Delphi
TnxWideCharSeparatorTokenFilterDescriptor = class(TnxBaseSeparatorTokenFilterDescriptor);
File

nxsdDataDictionaryFulltext

Description

This is class nxsdDataDictionaryFulltext.TnxWideCharSeparatorTokenFilterDescriptor.

Group

Classes

Links
TnxWideCharSeparatorTokenFilterDescriptor Fields, TnxWideCharSeparatorTokenFilterDescriptor Methods, TnxWideCharSeparatorTokenFilterDescriptor Properties, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext, Classes


TnxWideCharSeparatorTokenFilterDescriptor Members

TnxWideCharSeparatorTokenFilterDescriptor Members
TnxWideCharSeparatorTokenFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxWideCharSeparatorTokenFilterDescriptor.

Class

TnxWideCharSeparatorTokenFilterDescriptor Class

Protected Fields
Name | Description
bstfsSeparatorDistance | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ldiCachedLocaleDescriptor | This is ldiCachedLocaleDescriptor, a member of class TnxLocalizedDictionaryItem.
ldiCachedStorageCodePage | This is ldiCachedStorageCodePage, a member of class TnxLocalizedDictionaryItem.
ldiLocaleDescriptor | private
ltpLifetimeMonitor | private
nfidiNumber | private
wcstfsSeparatorChar | private
Protected Methods
Name | Description
_AddRef |
_Release |
bstfsSetSeparatorDistance | TnxBaseSeparatorTokenFilterDescriptor
btfdGetName | private TnxBaseTokenFilterDescriptor
CheckReadOnly |
Create | TnxWideCharSeparatorTokenFilterDescriptor
diActivateCaching | caching
diActivateCaching |
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
ldiGetUsedLocaleDescriptor |
ldiGetUsedStorageCodePage |
ldiLoadFromReader |
ldiOuterGetUsedLocaleDescriptor |
ldiSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
wcstfsSetSeparatorChar |
Public Methods
Name | Description
AddLocaleDescriptor | This function sets the Locale Descriptor class to the given aLocaleClass, (or a default localeclass implementation if the parameter is nil), creates an instance, adds it to the data dictionary and returns the instance.
AddLocaleDescriptorT |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
CheckValid |
Destroy | destructor.
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveLocaleDescriptor | This function frees the Instance of the associated Locale Descriptor.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
LocaleDescriptor | This property returns the associated Locale Descriptor.
Name | This is Name, a member of class TnxBaseTokenFilterDescriptor.
Number | This is Number, a member of class TnxNumberedFulltextIndexDictionaryItem.
SeparatorChar | This is SeparatorChar, a member of class TnxWideCharSeparatorTokenFilterDescriptor.
SeparatorDistance | This is SeparatorDistance, a member of class TnxBaseSeparatorTokenFilterDescriptor.
UsedLocaleDescriptor | This property returns the Locale Descriptor currently in use.
UsedStorageCodePage | This property returns the StorageCodePage of the Locale Descriptor currently in use or 0.
Links
TnxWideCharSeparatorTokenFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxWideCharSeparatorTokenFilterDescriptor.Create Constructor

TnxWideCharSeparatorTokenFilterDescriptor.Create Constructor
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Description

TnxWideCharSeparatorTokenFilterDescriptor

Class

TnxWideCharSeparatorTokenFilterDescriptor Class

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Class


TnxWideCharSeparatorTokenFilterDescriptor Fields

TnxWideCharSeparatorTokenFilterDescriptor Fields
TnxWideCharSeparatorTokenFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxWideCharSeparatorTokenFilterDescriptor class are listed here.

Class

TnxWideCharSeparatorTokenFilterDescriptor Class

Protected Fields
Name | Description
wcstfsSeparatorChar | private
Links
TnxWideCharSeparatorTokenFilterDescriptor Class, Legend, Protected Fields


TnxWideCharSeparatorTokenFilterDescriptor.wcstfsSeparatorChar Field

TnxWideCharSeparatorTokenFilterDescriptor.wcstfsSeparatorChar Field
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Fields Send Feedback
Syntax
Delphi
wcstfsSeparatorChar: TnxWideChar;
Description

private

Group

TnxWideCharSeparatorTokenFilterDescriptor Fields

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Fields


TnxWideCharSeparatorTokenFilterDescriptor Methods

TnxWideCharSeparatorTokenFilterDescriptor Methods
TnxWideCharSeparatorTokenFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxWideCharSeparatorTokenFilterDescriptor class are listed here.

Class

TnxWideCharSeparatorTokenFilterDescriptor Class

Protected Methods
Name | Description
wcstfsSetSeparatorChar |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxWideCharSeparatorTokenFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxWideCharSeparatorTokenFilterDescriptor.LoadFromReader Method

TnxWideCharSeparatorTokenFilterDescriptor.LoadFromReader Method
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxWideCharSeparatorTokenFilterDescriptor Methods

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Methods


TnxWideCharSeparatorTokenFilterDescriptor.SaveToWriter Method

TnxWideCharSeparatorTokenFilterDescriptor.SaveToWriter Method
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxWideCharSeparatorTokenFilterDescriptor Methods

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Methods


TnxWideCharSeparatorTokenFilterDescriptor.wcstfsSetSeparatorChar Method

TnxWideCharSeparatorTokenFilterDescriptor.wcstfsSetSeparatorChar Method
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Methods Send Feedback
Syntax
Delphi
procedure wcstfsSetSeparatorChar(const Value: TnxWideChar);
Group

TnxWideCharSeparatorTokenFilterDescriptor Methods

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Methods


TnxWideCharSeparatorTokenFilterDescriptor Properties

TnxWideCharSeparatorTokenFilterDescriptor Properties
TnxWideCharSeparatorTokenFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxWideCharSeparatorTokenFilterDescriptor class are listed here.

Class

TnxWideCharSeparatorTokenFilterDescriptor Class

Public Properties
Name | Description
SeparatorChar | This is SeparatorChar, a member of class TnxWideCharSeparatorTokenFilterDescriptor.
Links
TnxWideCharSeparatorTokenFilterDescriptor Class, Legend, Public Properties


TnxWideCharSeparatorTokenFilterDescriptor.SeparatorChar Property

TnxWideCharSeparatorTokenFilterDescriptor.SeparatorChar Property
TnxWideCharSeparatorTokenFilterDescriptor Class TnxWideCharSeparatorTokenFilterDescriptor Members nxsdDataDictionaryFulltext Namespace TnxWideCharSeparatorTokenFilterDescriptor Properties Send Feedback
Syntax
Delphi
property SeparatorChar: TnxWideChar;
Description

This is SeparatorChar, a member of class TnxWideCharSeparatorTokenFilterDescriptor.

Group

TnxWideCharSeparatorTokenFilterDescriptor Properties

Links
TnxWideCharSeparatorTokenFilterDescriptor Class, TnxWideCharSeparatorTokenFilterDescriptor Members, nxsdDataDictionaryFulltext Namespace, TnxWideCharSeparatorTokenFilterDescriptor Properties


Functions

Functions
Functions nxsdDataDictionaryFulltext Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
EnsureFulltextDescriptor |
GetFulltextDescriptor |
Namespace

nxsdDataDictionaryFulltext Namespace

Links
Functions, nxsdDataDictionaryFulltext Namespace, Legend


nxsdDataDictionaryFulltext.EnsureFulltextDescriptor Function

nxsdDataDictionaryFulltext.EnsureFulltextDescriptor Function
nxsdDataDictionaryFulltext Functions Send Feedback
Syntax
Delphi
function EnsureFulltextDescriptor(aTable: TnxBaseTableDescriptor; aClass: TnxFulltextDescriptorClass = nil): TnxFulltextDescriptor;
File

nxsdDataDictionaryFulltext

Group

Functions

Links
nxsdDataDictionaryFulltext, Functions


nxsdDataDictionaryFulltext.GetFulltextDescriptor Function

nxsdDataDictionaryFulltext.GetFulltextDescriptor Function
nxsdDataDictionaryFulltext Functions Send Feedback
Syntax
Delphi
function GetFulltextDescriptor(aTable: TnxBaseTableDescriptor; aClass: TnxFulltextDescriptorClass = nil): TnxFulltextDescriptor;
File

nxsdDataDictionaryFulltext

Group

Functions

Links
nxsdDataDictionaryFulltext, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdDataDictionaryFulltext Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxStringReplaceKind | don't change order, only add new entries at end, ordinal value saved in stream
Namespace

nxsdDataDictionaryFulltext Namespace

Records
Name | Description
TnxStringReplaceTokenFilterItem | This is record nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItem.
Links
Enumerations, nxsdDataDictionaryFulltext Namespace, Legend, Records


nxsdDataDictionaryFulltext.TnxStringReplaceKind Enumeration

nxsdDataDictionaryFulltext.TnxStringReplaceKind Enumeration
nxsdDataDictionaryFulltext Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStringReplaceKind = ( srkWhole, srkOne, srkAll );
File

nxsdDataDictionaryFulltext

Description

don't change order, only add new entries at end, ordinal value saved in stream

Group

Structs, Records, Enums

Links
nxsdDataDictionaryFulltext, Structs, Records, Enums


nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItem Record

nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItem Record
nxsdDataDictionaryFulltext Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStringReplaceTokenFilterItem = record
  srtfiOldPattern: string;
  srtfiNewPattern: string;
  srtfiReplaceKind: TnxStringReplaceKind;
  srtfiIgnoreCase: Boolean;
end;
File

nxsdDataDictionaryFulltext

Description

This is record nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItem.

Group

Structs, Records, Enums

Links
nxsdDataDictionaryFulltext, Structs, Records, Enums


Types

Types
nxsdDataDictionaryFulltext Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdDataDictionaryFulltext Namespace

Types
Name | Description
TnxBaseBitArrayStorageHandlerDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptorClass.
TnxBaseTokenExtractorDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptorClass.
TnxBaseTokenFilterDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptorClass.
TnxBaseTokenIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptorClass.
TnxBitArrayTokenIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptorClass.
TnxBitArrayTokenKeyDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptorClass.
TnxFieldTokenExtractorDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptorClass.
TnxFulltextDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFulltextDescriptorClass.
TnxFulltextIndexDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptorClass.
TnxFulltextIndexDescriptors | This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptors.
TnxMainIndexTokenKeyDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptorClass.
TnxStringReplaceTokenFilterItems | This is type nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItems.
TnxTokenExtractorHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptorClass.
TnxTokenFilterHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptorClass.
TnxTokenIndexHubDescriptorClass | This is type nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptorClass.
TnxTokenIndicesDescriptorClass | HPPEMIT '#define TnxFulltextIndexDescriptors DynamicArray
Links
nxsdDataDictionaryFulltext Namespace, Types


nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBaseBitArrayStorageHandlerDescriptorClass = class of TnxBaseBitArrayStorageHandlerDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBaseBitArrayStorageHandlerDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBaseTokenExtractorDescriptorClass = class of TnxBaseTokenExtractorDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBaseTokenExtractorDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBaseTokenFilterDescriptorClass = class of TnxBaseTokenFilterDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBaseTokenFilterDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBaseTokenIndexDescriptorClass = class of TnxBaseTokenIndexDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBaseTokenIndexDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBitArrayTokenIndexDescriptorClass = class of TnxBitArrayTokenIndexDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenIndexDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptorClass Type

nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxBitArrayTokenKeyDescriptorClass = class of TnxBitArrayTokenKeyDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxBitArrayTokenKeyDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptorClass Type

nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxFieldTokenExtractorDescriptorClass = class of TnxFieldTokenExtractorDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxFieldTokenExtractorDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxFulltextDescriptorClass Type

nxsdDataDictionaryFulltext.TnxFulltextDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxFulltextDescriptorClass = class of TnxFulltextDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxFulltextDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptorClass Type

nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxFulltextIndexDescriptorClass = class of TnxFulltextIndexDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptors Type

nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptors Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxFulltextIndexDescriptors = array of TnxFulltextIndexDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxFulltextIndexDescriptors.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptorClass Type

nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxMainIndexTokenKeyDescriptorClass = class of TnxMainIndexTokenKeyDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxMainIndexTokenKeyDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItems Type

nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItems Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxStringReplaceTokenFilterItems = array of TnxStringReplaceTokenFilterItem;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxStringReplaceTokenFilterItems.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptorClass Type

nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxTokenExtractorHubDescriptorClass = class of TnxTokenExtractorHubDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxTokenExtractorHubDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptorClass Type

nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxTokenFilterHubDescriptorClass = class of TnxTokenFilterHubDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxTokenFilterHubDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptorClass Type

nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxTokenIndexHubDescriptorClass = class of TnxTokenIndexHubDescriptor;
File

nxsdDataDictionaryFulltext

Description

This is type nxsdDataDictionaryFulltext.TnxTokenIndexHubDescriptorClass.

Group

Types

Links
nxsdDataDictionaryFulltext, Types


nxsdDataDictionaryFulltext.TnxTokenIndicesDescriptorClass Type

nxsdDataDictionaryFulltext.TnxTokenIndicesDescriptorClass Type
nxsdDataDictionaryFulltext Types Send Feedback
Syntax
Delphi
TnxTokenIndicesDescriptorClass = class of TnxTokenIndicesDescriptor;
File

nxsdDataDictionaryFulltext

Description

HPPEMIT '#define TnxFulltextIndexDescriptors DynamicArray

Group

Types

Links
nxsdDataDictionaryFulltext, Types


Variables

Variables
nxsdDataDictionaryFulltext Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdDataDictionaryFulltext Namespace

Variables
Name | Description
_BitArrayStorageHandlerList | This is variable nxsdDataDictionaryFulltext._BitArrayStorageHandlerList.
_FulltextIndexDescriptorList | This is variable nxsdDataDictionaryFulltext._FulltextIndexDescriptorList.
_TokenExtractorDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenExtractorDescriptorList.
_TokenFilterDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenFilterDescriptorList.
_TokenIndexDescriptorList | This is variable nxsdDataDictionaryFulltext._TokenIndexDescriptorList.
Links
nxsdDataDictionaryFulltext Namespace, Variables


nxsdDataDictionaryFulltext._BitArrayStorageHandlerList Variable

nxsdDataDictionaryFulltext._BitArrayStorageHandlerList Variable
nxsdDataDictionaryFulltext Variables Send Feedback
Syntax
Delphi
_BitArrayStorageHandlerList: TStringList;
File

nxsdDataDictionaryFulltext

Description

This is variable nxsdDataDictionaryFulltext._BitArrayStorageHandlerList.

Group

Variables

Links
nxsdDataDictionaryFulltext, Variables


nxsdDataDictionaryFulltext._FulltextIndexDescriptorList Variable

nxsdDataDictionaryFulltext._FulltextIndexDescriptorList Variable
nxsdDataDictionaryFulltext Variables Send Feedback
Syntax
Delphi
_FulltextIndexDescriptorList: TStringList;
File

nxsdDataDictionaryFulltext

Description

This is variable nxsdDataDictionaryFulltext._FulltextIndexDescriptorList.

Group

Variables

Links
nxsdDataDictionaryFulltext, Variables


nxsdDataDictionaryFulltext._TokenExtractorDescriptorList Variable

nxsdDataDictionaryFulltext._TokenExtractorDescriptorList Variable
nxsdDataDictionaryFulltext Variables Send Feedback
Syntax
Delphi
_TokenExtractorDescriptorList: TStringList;
File

nxsdDataDictionaryFulltext

Description

This is variable nxsdDataDictionaryFulltext._TokenExtractorDescriptorList.

Group

Variables

Links
nxsdDataDictionaryFulltext, Variables


nxsdDataDictionaryFulltext._TokenFilterDescriptorList Variable

nxsdDataDictionaryFulltext._TokenFilterDescriptorList Variable
nxsdDataDictionaryFulltext Variables Send Feedback
Syntax
Delphi
_TokenFilterDescriptorList: TStringList;
File

nxsdDataDictionaryFulltext

Description

This is variable nxsdDataDictionaryFulltext._TokenFilterDescriptorList.

Group

Variables

Links
nxsdDataDictionaryFulltext, Variables


nxsdDataDictionaryFulltext._TokenIndexDescriptorList Variable

nxsdDataDictionaryFulltext._TokenIndexDescriptorList Variable
nxsdDataDictionaryFulltext Variables Send Feedback
Syntax
Delphi
_TokenIndexDescriptorList: TStringList;
File

nxsdDataDictionaryFulltext

Description

This is variable nxsdDataDictionaryFulltext._TokenIndexDescriptorList.

Group

Variables

Links
nxsdDataDictionaryFulltext, Variables


Constants

Constants
Constants nxsdDataDictionaryFulltext Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxcClassDefaultSeparators | This is constant nxsdDataDictionaryFulltext.nxcClassDefaultSeparators.
Namespace

nxsdDataDictionaryFulltext Namespace

Links
Constants, nxsdDataDictionaryFulltext Namespace


nxsdDataDictionaryFulltext.nxcClassDefaultSeparators Constant

nxsdDataDictionaryFulltext.nxcClassDefaultSeparators Constant
nxsdDataDictionaryFulltext Constants Send Feedback
Syntax
Delphi
nxcClassDefaultSeparators = [ ccSeparatorSpace, ccSeparatorLine, ccSeparatorParagraph, ccSegmentSeparator, ccWhiteSpace, ccPunctuationOpen, ccPunctuationClose, ccPunctuationInitialQuote, ccPunctuationFinalQuote, ccPunctuationOther, ccSpaceOther ];
File

nxsdDataDictionaryFulltext

Description

This is constant nxsdDataDictionaryFulltext.nxcClassDefaultSeparators.

Group

Constants

Links
nxsdDataDictionaryFulltext, Constants


nxsdDataDictionaryRefInt Namespace

nxsdDataDictionaryRefInt Namespace
Classes Functions Legend Topics Types Variables Send Feedback

RI specific data dictionary.

Classes
Name | Description
EnxBaseActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseActionDescriptorException.
EnxBaseDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseDeleteActionDescriptorException.
EnxBaseModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseModifyActionDescriptorException.
EnxBaseSourceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseSourceDescriptorException.
EnxBaseTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseTargetCursorDescriptorException.
EnxBlockDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBlockDeleteActionDescriptorException.
EnxBlockModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBlockModifyActionDescriptorException.
EnxCascadeDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCascadeDeleteActionDescriptorException.
EnxCascadeModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCascadeModifyActionDescriptorException.
EnxClearDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxClearDeleteActionDescriptorException.
EnxClearModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxClearModifyActionDescriptorException.
EnxCloneTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCloneTargetCursorDescriptorException.
EnxFieldSourceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxFieldSourceDescriptorException.
EnxReferenceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxReferenceDescriptorException.
EnxRefIntegrityDescriptorException | This is class nxsdDataDictionaryRefInt.EnxRefIntegrityDescriptorException.
EnxRelativeTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxRelativeTargetCursorDescriptorException.
EnxSetDefaultDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxSetDefaultDeleteActionDescriptorException.
EnxSetDefaultModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxSetDefaultModifyActionDescriptorException.
EnxTableTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxTableTargetCursorDescriptorException.
EnxTargetRequiredActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxTargetRequiredActionDescriptorException.
TnxBaseActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBaseActionDescriptor.
TnxBaseSourceDescriptor | This is class nxsdDataDictionaryRefInt.TnxBaseSourceDescriptor.
TnxBaseTargetCursorDescriptor | No need for this with Delphi10, it translates correctly the class. $HPPEMIT 'namespace Nxsddatadictionaryrefint' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxReferenceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseSourceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseActionDescriptor;' $HPPEMIT '}'
TnxBlockDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBlockDeleteActionDescriptor.
TnxBlockModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBlockModifyActionDescriptor.
TnxCascadeDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxCascadeDeleteActionDescriptor.
TnxCascadeModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxCascadeModifyActionDescriptor.
TnxClearDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxClearDeleteActionDescriptor.
TnxClearModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxClearModifyActionDescriptor.
TnxCloneTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxCloneTargetCursorDescriptor.
TnxFieldSourceDescriptor | This is class nxsdDataDictionaryRefInt.TnxFieldSourceDescriptor.
TnxReferenceDescriptor | This is class nxsdDataDictionaryRefInt.TnxReferenceDescriptor.
TnxRefIntegrityDescriptor | This is class nxsdDataDictionaryRefInt.TnxRefIntegrityDescriptor.
TnxRelativeTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxRelativeTargetCursorDescriptor.
TnxSetDefaultDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxSetDefaultDeleteActionDescriptor.
TnxSetDefaultModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxSetDefaultModifyActionDescriptor.
TnxTableTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxTableTargetCursorDescriptor.
TnxTargetRequiredActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxTargetRequiredActionDescriptor.
Functions
Name | Description
EnsureRefIntegrityDescriptor |
GetRefIntegrityDescriptor |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxBaseActionDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseActionDescriptorClass.
TnxBaseSourceDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseSourceDescriptorClass.
TnxBaseTargetCursorDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseTargetCursorDescriptorClass.
TnxReferenceDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxReferenceDescriptorClass.
Variables
Name | Description
_ActionDescriptorList | This is variable nxsdDataDictionaryRefInt._ActionDescriptorList.
_ReferenceDescriptorList | This is variable nxsdDataDictionaryRefInt._ReferenceDescriptorList.
_SourceDescriptorList | This is variable nxsdDataDictionaryRefInt._SourceDescriptorList.
_TargetCursorDescriptorList | This is variable nxsdDataDictionaryRefInt._TargetCursorDescriptorList.
Links
Classes, Functions, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdDataDictionaryRefInt Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseActionDescriptorException.
EnxBaseDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseDeleteActionDescriptorException.
EnxBaseModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseModifyActionDescriptorException.
EnxBaseSourceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseSourceDescriptorException.
EnxBaseTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBaseTargetCursorDescriptorException.
EnxBlockDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBlockDeleteActionDescriptorException.
EnxBlockModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxBlockModifyActionDescriptorException.
EnxCascadeDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCascadeDeleteActionDescriptorException.
EnxCascadeModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCascadeModifyActionDescriptorException.
EnxClearDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxClearDeleteActionDescriptorException.
EnxClearModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxClearModifyActionDescriptorException.
EnxCloneTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxCloneTargetCursorDescriptorException.
EnxFieldSourceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxFieldSourceDescriptorException.
EnxReferenceDescriptorException | This is class nxsdDataDictionaryRefInt.EnxReferenceDescriptorException.
EnxRefIntegrityDescriptorException | This is class nxsdDataDictionaryRefInt.EnxRefIntegrityDescriptorException.
EnxRelativeTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxRelativeTargetCursorDescriptorException.
EnxSetDefaultDeleteActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxSetDefaultDeleteActionDescriptorException.
EnxSetDefaultModifyActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxSetDefaultModifyActionDescriptorException.
EnxTableTargetCursorDescriptorException | This is class nxsdDataDictionaryRefInt.EnxTableTargetCursorDescriptorException.
EnxTargetRequiredActionDescriptorException | This is class nxsdDataDictionaryRefInt.EnxTargetRequiredActionDescriptorException.
TnxBaseActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBaseActionDescriptor.
TnxBaseSourceDescriptor | This is class nxsdDataDictionaryRefInt.TnxBaseSourceDescriptor.
TnxBaseTargetCursorDescriptor | No need for this with Delphi10, it translates correctly the class. $HPPEMIT 'namespace Nxsddatadictionaryrefint' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxReferenceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseSourceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseActionDescriptor;' $HPPEMIT '}'
TnxBlockDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBlockDeleteActionDescriptor.
TnxBlockModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxBlockModifyActionDescriptor.
TnxCascadeDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxCascadeDeleteActionDescriptor.
TnxCascadeModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxCascadeModifyActionDescriptor.
TnxClearDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxClearDeleteActionDescriptor.
TnxClearModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxClearModifyActionDescriptor.
TnxCloneTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxCloneTargetCursorDescriptor.
TnxFieldSourceDescriptor | This is class nxsdDataDictionaryRefInt.TnxFieldSourceDescriptor.
TnxReferenceDescriptor | This is class nxsdDataDictionaryRefInt.TnxReferenceDescriptor.
TnxRefIntegrityDescriptor | This is class nxsdDataDictionaryRefInt.TnxRefIntegrityDescriptor.
TnxRelativeTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxRelativeTargetCursorDescriptor.
TnxSetDefaultDeleteActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxSetDefaultDeleteActionDescriptor.
TnxSetDefaultModifyActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxSetDefaultModifyActionDescriptor.
TnxTableTargetCursorDescriptor | This is class nxsdDataDictionaryRefInt.TnxTableTargetCursorDescriptor.
TnxTargetRequiredActionDescriptor | This is class nxsdDataDictionaryRefInt.TnxTargetRequiredActionDescriptor.
Namespace

nxsdDataDictionaryRefInt Namespace

Links
Classes, nxsdDataDictionaryRefInt Namespace, Legend


EnxBaseActionDescriptorException Class

EnxBaseActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBaseActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseActionDescriptorException
Syntax
Delphi
EnxBaseActionDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBaseActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBaseDeleteActionDescriptorException Class

EnxBaseDeleteActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseDeleteActionDescriptorException
Syntax
Delphi
EnxBaseDeleteActionDescriptorException = class(EnxBaseActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBaseDeleteActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBaseModifyActionDescriptorException Class

EnxBaseModifyActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseModifyActionDescriptorException
Syntax
Delphi
EnxBaseModifyActionDescriptorException = class(EnxBaseActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBaseModifyActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBaseSourceDescriptorException Class

EnxBaseSourceDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBaseSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseSourceDescriptorException
Syntax
Delphi
EnxBaseSourceDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBaseSourceDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBaseTargetCursorDescriptorException Class

EnxBaseTargetCursorDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxBaseTargetCursorDescriptorException
Syntax
Delphi
EnxBaseTargetCursorDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBaseTargetCursorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBlockDeleteActionDescriptorException Class

EnxBlockDeleteActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockDeleteActionDescriptorException
Syntax
Delphi
EnxBlockDeleteActionDescriptorException = class(EnxBaseDeleteActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBlockDeleteActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxBlockModifyActionDescriptorException Class

EnxBlockModifyActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxBlockModifyActionDescriptorException
Syntax
Delphi
EnxBlockModifyActionDescriptorException = class(EnxBaseModifyActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxBlockModifyActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxCascadeDeleteActionDescriptorException Class

EnxCascadeDeleteActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeDeleteActionDescriptorException
Syntax
Delphi
EnxCascadeDeleteActionDescriptorException = class(EnxBaseDeleteActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxCascadeDeleteActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxCascadeModifyActionDescriptorException Class

EnxCascadeModifyActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxCascadeModifyActionDescriptorException
Syntax
Delphi
EnxCascadeModifyActionDescriptorException = class(EnxBaseModifyActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxCascadeModifyActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxClearDeleteActionDescriptorException Class

EnxClearDeleteActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearDeleteActionDescriptorException
Syntax
Delphi
EnxClearDeleteActionDescriptorException = class(EnxBaseDeleteActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxClearDeleteActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxClearModifyActionDescriptorException Class

EnxClearModifyActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxClearModifyActionDescriptorException
Syntax
Delphi
EnxClearModifyActionDescriptorException = class(EnxBaseModifyActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxClearModifyActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxCloneTargetCursorDescriptorException Class

EnxCloneTargetCursorDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxCloneTargetCursorDescriptorException
Syntax
Delphi
EnxCloneTargetCursorDescriptorException = class(EnxBaseTargetCursorDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxCloneTargetCursorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxFieldSourceDescriptorException Class

EnxFieldSourceDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorExceptionnxsdDataDictionaryRefInt_EnxFieldSourceDescriptorException
Syntax
Delphi
EnxFieldSourceDescriptorException = class(EnxBaseSourceDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxFieldSourceDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxReferenceDescriptorException Class

EnxReferenceDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxReferenceDescriptorExceptionnxsdDataDictionaryRefInt_EnxReferenceDescriptorExceptionnxsdDataDictionaryRefInt_EnxReferenceDescriptorExceptionnxsdDataDictionaryRefInt_EnxReferenceDescriptorExceptionnxsdDataDictionaryRefInt_EnxReferenceDescriptorExceptionnxsdDataDictionaryRefInt_EnxReferenceDescriptorException
Syntax
Delphi
EnxReferenceDescriptorException = class(EnxDictionaryItemException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxReferenceDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxRefIntegrityDescriptorException Class

EnxRefIntegrityDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorExceptionnxsdDataDictionaryRefInt_EnxRefIntegrityDescriptorException
Syntax
Delphi
EnxRefIntegrityDescriptorException = class(EnxBaseCustomDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxRefIntegrityDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxRelativeTargetCursorDescriptorException Class

EnxRelativeTargetCursorDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxRelativeTargetCursorDescriptorException
Syntax
Delphi
EnxRelativeTargetCursorDescriptorException = class(EnxBaseTargetCursorDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxRelativeTargetCursorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxSetDefaultDeleteActionDescriptorException Class

EnxSetDefaultDeleteActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultDeleteActionDescriptorException
Syntax
Delphi
EnxSetDefaultDeleteActionDescriptorException = class(EnxBaseDeleteActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxSetDefaultDeleteActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxSetDefaultModifyActionDescriptorException Class

EnxSetDefaultModifyActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxSetDefaultModifyActionDescriptorException
Syntax
Delphi
EnxSetDefaultModifyActionDescriptorException = class(EnxBaseModifyActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxSetDefaultModifyActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxTableTargetCursorDescriptorException Class

EnxTableTargetCursorDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorExceptionnxsdDataDictionaryRefInt_EnxTableTargetCursorDescriptorException
Syntax
Delphi
EnxTableTargetCursorDescriptorException = class(EnxBaseTargetCursorDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxTableTargetCursorDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


EnxTargetRequiredActionDescriptorException Class

EnxTargetRequiredActionDescriptorException Class
nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorExceptionnxsdDataDictionaryRefInt_EnxTargetRequiredActionDescriptorException
Syntax
Delphi
EnxTargetRequiredActionDescriptorException = class(EnxBaseActionDescriptorException);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.EnxTargetRequiredActionDescriptorException.

Group

Classes

Links
nxsdDataDictionaryRefInt, Classes


TnxBaseActionDescriptor Class

TnxBaseActionDescriptor Class
TnxBaseActionDescriptor Fields TnxBaseActionDescriptor Methods TnxBaseActionDescriptor Properties TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxBaseActionDescriptornxsdDataDictionaryRefInt_TnxBaseActionDescriptornxsdDataDictionaryRefInt_TnxBaseActionDescriptornxsdDataDictionaryRefInt_TnxBaseActionDescriptornxsdDataDictionaryRefInt_TnxBaseActionDescriptornxsdDataDictionaryRefInt_TnxBaseActionDescriptor
Syntax
Delphi
TnxBaseActionDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxBaseActionDescriptor.

Group

Classes

Links
TnxBaseActionDescriptor Fields, TnxBaseActionDescriptor Methods, TnxBaseActionDescriptor Properties, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxBaseActionDescriptor Members

TnxBaseActionDescriptor Members
TnxBaseActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseActionDescriptor.

Class

TnxBaseActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxBaseActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseActionDescriptor.Create Constructor

TnxBaseActionDescriptor.Create Constructor
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseActionDescriptor Class

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Class


TnxBaseActionDescriptor Fields

TnxBaseActionDescriptor Fields
TnxBaseActionDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseActionDescriptor class are listed here.

Class

TnxBaseActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
Links
TnxBaseActionDescriptor Class, Legend, Protected Fields


TnxBaseActionDescriptor.badCachedEngineClass Field

TnxBaseActionDescriptor.badCachedEngineClass Field
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Fields Send Feedback
Syntax
Delphi
badCachedEngineClass: TClass;
Description

This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.

Group

TnxBaseActionDescriptor Fields

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Fields


TnxBaseActionDescriptor.badSkipOnNull Field

TnxBaseActionDescriptor.badSkipOnNull Field
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Fields Send Feedback
Syntax
Delphi
badSkipOnNull: Boolean;
Description

private

Group

TnxBaseActionDescriptor Fields

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Fields


TnxBaseActionDescriptor Methods

TnxBaseActionDescriptor Methods
TnxBaseActionDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseActionDescriptor class are listed here.

Class

TnxBaseActionDescriptor Class

Protected Methods
Name | Description
badSetSkipOnNull | TnxBaseActionDescriptor
Public Methods
Name | Description
GetList |
LoadFromReader |
SaveToWriter |
Links
TnxBaseActionDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseActionDescriptor.badSetSkipOnNull Method

TnxBaseActionDescriptor.badSetSkipOnNull Method
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure badSetSkipOnNull(const Value: Boolean);
Description

TnxBaseActionDescriptor

Group

TnxBaseActionDescriptor Methods

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Methods


TnxBaseActionDescriptor.GetList Method

TnxBaseActionDescriptor.GetList Method
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseActionDescriptor Methods

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Methods


TnxBaseActionDescriptor.LoadFromReader Method

TnxBaseActionDescriptor.LoadFromReader Method
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseActionDescriptor Methods

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Methods


TnxBaseActionDescriptor.SaveToWriter Method

TnxBaseActionDescriptor.SaveToWriter Method
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseActionDescriptor Methods

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Methods


TnxBaseActionDescriptor Properties

TnxBaseActionDescriptor Properties
TnxBaseActionDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseActionDescriptor class are listed here.

Class

TnxBaseActionDescriptor Class

Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxBaseActionDescriptor Class, Legend, Public Properties


TnxBaseActionDescriptor.CachedEngineClass Property

TnxBaseActionDescriptor.CachedEngineClass Property
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxBaseActionDescriptor.

Group

TnxBaseActionDescriptor Properties

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Properties


TnxBaseActionDescriptor.SkipOnNull Property

TnxBaseActionDescriptor.SkipOnNull Property
TnxBaseActionDescriptor Class TnxBaseActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseActionDescriptor Properties Send Feedback
Syntax
Delphi
property SkipOnNull: Boolean;
Description

skip application of this action descriptor if any of the source fields is null

Group

TnxBaseActionDescriptor Properties

Links
TnxBaseActionDescriptor Class, TnxBaseActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseActionDescriptor Properties


TnxBaseSourceDescriptor Class

TnxBaseSourceDescriptor Class
TnxBaseSourceDescriptor Methods TnxBaseSourceDescriptor Properties TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxBaseSourceDescriptornxsdDataDictionaryRefInt_TnxBaseSourceDescriptornxsdDataDictionaryRefInt_TnxBaseSourceDescriptornxsdDataDictionaryRefInt_TnxBaseSourceDescriptornxsdDataDictionaryRefInt_TnxBaseSourceDescriptornxsdDataDictionaryRefInt_TnxBaseSourceDescriptor
Syntax
Delphi
TnxBaseSourceDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxBaseSourceDescriptor.

Group

Classes

Links
TnxBaseSourceDescriptor Methods, TnxBaseSourceDescriptor Properties, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxBaseSourceDescriptor Members

TnxBaseSourceDescriptor Members
TnxBaseSourceDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSourceDescriptor.

Class

TnxBaseSourceDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseSourceDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of all actions if this source fields is null
Links
TnxBaseSourceDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseSourceDescriptor.Create Constructor

TnxBaseSourceDescriptor.Create Constructor
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseSourceDescriptor Class

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Class


TnxBaseSourceDescriptor Methods

TnxBaseSourceDescriptor Methods
TnxBaseSourceDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSourceDescriptor class are listed here.

Class

TnxBaseSourceDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
LoadFromReader |
SaveToWriter |
Links
TnxBaseSourceDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseSourceDescriptor.GetList Method

TnxBaseSourceDescriptor.GetList Method
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseSourceDescriptor Methods

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Methods


TnxBaseSourceDescriptor.LoadFromReader Method

TnxBaseSourceDescriptor.LoadFromReader Method
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseSourceDescriptor Methods

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Methods


TnxBaseSourceDescriptor.SaveToWriter Method

TnxBaseSourceDescriptor.SaveToWriter Method
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseSourceDescriptor Methods

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Methods


TnxBaseSourceDescriptor Properties

TnxBaseSourceDescriptor Properties
TnxBaseSourceDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseSourceDescriptor class are listed here.

Class

TnxBaseSourceDescriptor Class

Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseSourceDescriptor.
SkipOnNull | skip application of all actions if this source fields is null
Links
TnxBaseSourceDescriptor Class, Legend, Public Properties


TnxBaseSourceDescriptor.CachedEngineClass Property

TnxBaseSourceDescriptor.CachedEngineClass Property
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxBaseSourceDescriptor.

Group

TnxBaseSourceDescriptor Properties

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Properties


TnxBaseSourceDescriptor.SkipOnNull Property

TnxBaseSourceDescriptor.SkipOnNull Property
TnxBaseSourceDescriptor Class TnxBaseSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseSourceDescriptor Properties Send Feedback
Syntax
Delphi
property SkipOnNull: Boolean;
Description

skip application of all actions if this source fields is null

Group

TnxBaseSourceDescriptor Properties

Links
TnxBaseSourceDescriptor Class, TnxBaseSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseSourceDescriptor Properties


TnxBaseTargetCursorDescriptor Class

TnxBaseTargetCursorDescriptor Class
TnxBaseTargetCursorDescriptor Fields TnxBaseTargetCursorDescriptor Methods TnxBaseTargetCursorDescriptor Properties TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptornxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptornxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptornxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptornxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptornxsdDataDictionaryRefInt_TnxBaseTargetCursorDescriptor
Syntax
Delphi
TnxBaseTargetCursorDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionaryRefInt

Description

No need for this with Delphi10, it translates correctly the class. $HPPEMIT 'namespace Nxsddatadictionaryrefint' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxReferenceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseSourceDescriptor;' $HPPEMIT 'class DELPHICLASS TnxBaseActionDescriptor;' $HPPEMIT '}'

Group

Classes

Links
TnxBaseTargetCursorDescriptor Fields, TnxBaseTargetCursorDescriptor Methods, TnxBaseTargetCursorDescriptor Properties, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxBaseTargetCursorDescriptor Members

TnxBaseTargetCursorDescriptor Members
TnxBaseTargetCursorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTargetCursorDescriptor.

Class

TnxBaseTargetCursorDescriptor Class

Protected Fields
Name | Description
btcCachedEngineClass | This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReferencedTableName | This is ReferencedTableName, a member of class TnxBaseTargetCursorDescriptor.
References |
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxBaseTargetCursorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTargetCursorDescriptor.Create Constructor

TnxBaseTargetCursorDescriptor.Create Constructor
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); virtual;
Class

TnxBaseTargetCursorDescriptor Class

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Class


TnxBaseTargetCursorDescriptor Fields

TnxBaseTargetCursorDescriptor Fields
TnxBaseTargetCursorDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTargetCursorDescriptor class are listed here.

Class

TnxBaseTargetCursorDescriptor Class

Protected Fields
Name | Description
btcCachedEngineClass | This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
Links
TnxBaseTargetCursorDescriptor Class, Legend, Protected Fields


TnxBaseTargetCursorDescriptor.btcCachedEngineClass Field

TnxBaseTargetCursorDescriptor.btcCachedEngineClass Field
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Fields Send Feedback
Syntax
Delphi
btcCachedEngineClass: TClass;
Description

This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.

Group

TnxBaseTargetCursorDescriptor Fields

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Fields


TnxBaseTargetCursorDescriptor Methods

TnxBaseTargetCursorDescriptor Methods
TnxBaseTargetCursorDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTargetCursorDescriptor class are listed here.

Class

TnxBaseTargetCursorDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
LoadFromReader |
ReferencedTableName | This is ReferencedTableName, a member of class TnxBaseTargetCursorDescriptor.
References |
SaveToWriter |
Links
TnxBaseTargetCursorDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTargetCursorDescriptor.GetList Method

TnxBaseTargetCursorDescriptor.GetList Method
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTargetCursorDescriptor Methods

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Methods


TnxBaseTargetCursorDescriptor.LoadFromReader Method

TnxBaseTargetCursorDescriptor.LoadFromReader Method
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxBaseTargetCursorDescriptor Methods

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Methods


TnxBaseTargetCursorDescriptor.ReferencedTableName Method

TnxBaseTargetCursorDescriptor.ReferencedTableName Method
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function ReferencedTableName: string; virtual; abstract;
Description

This is ReferencedTableName, a member of class TnxBaseTargetCursorDescriptor.

Group

TnxBaseTargetCursorDescriptor Methods

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Methods


TnxBaseTargetCursorDescriptor.References Method

TnxBaseTargetCursorDescriptor.References Method
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function References(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxBaseTargetCursorDescriptor Methods

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Methods


TnxBaseTargetCursorDescriptor.SaveToWriter Method

TnxBaseTargetCursorDescriptor.SaveToWriter Method
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBaseTargetCursorDescriptor Methods

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Methods


TnxBaseTargetCursorDescriptor Properties

TnxBaseTargetCursorDescriptor Properties
TnxBaseTargetCursorDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTargetCursorDescriptor class are listed here.

Class

TnxBaseTargetCursorDescriptor Class

Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
Links
TnxBaseTargetCursorDescriptor Class, Legend, Public Properties


TnxBaseTargetCursorDescriptor.CachedEngineClass Property

TnxBaseTargetCursorDescriptor.CachedEngineClass Property
TnxBaseTargetCursorDescriptor Class TnxBaseTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBaseTargetCursorDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.

Group

TnxBaseTargetCursorDescriptor Properties

Links
TnxBaseTargetCursorDescriptor Class, TnxBaseTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBaseTargetCursorDescriptor Properties


TnxBlockDeleteActionDescriptor Class

TnxBlockDeleteActionDescriptor Class
TnxBlockDeleteActionDescriptor Methods TnxBlockDeleteActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptornxsdDataDictionaryRefInt_TnxBlockDeleteActionDescriptor
Syntax
Delphi
TnxBlockDeleteActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxBlockDeleteActionDescriptor.

Group

Classes

Links
TnxBlockDeleteActionDescriptor Methods, TnxBlockDeleteActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxBlockDeleteActionDescriptor Members

TnxBlockDeleteActionDescriptor Members
TnxBlockDeleteActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBlockDeleteActionDescriptor.

Class

TnxBlockDeleteActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxBlockDeleteActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxBlockDeleteActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBlockDeleteActionDescriptor Methods

TnxBlockDeleteActionDescriptor Methods
TnxBlockDeleteActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxBlockDeleteActionDescriptor class are listed here.

Class

TnxBlockDeleteActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxBlockDeleteActionDescriptor
SaveToWriter |
Links
TnxBlockDeleteActionDescriptor Class, Legend, Public Methods


TnxBlockDeleteActionDescriptor.LoadFromReader Method

TnxBlockDeleteActionDescriptor.LoadFromReader Method
TnxBlockDeleteActionDescriptor Class TnxBlockDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBlockDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxBlockDeleteActionDescriptor

Group

TnxBlockDeleteActionDescriptor Methods

Links
TnxBlockDeleteActionDescriptor Class, TnxBlockDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBlockDeleteActionDescriptor Methods


TnxBlockDeleteActionDescriptor.SaveToWriter Method

TnxBlockDeleteActionDescriptor.SaveToWriter Method
TnxBlockDeleteActionDescriptor Class TnxBlockDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBlockDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBlockDeleteActionDescriptor Methods

Links
TnxBlockDeleteActionDescriptor Class, TnxBlockDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBlockDeleteActionDescriptor Methods


TnxBlockModifyActionDescriptor Class

TnxBlockModifyActionDescriptor Class
TnxBlockModifyActionDescriptor Methods TnxBlockModifyActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptornxsdDataDictionaryRefInt_TnxBlockModifyActionDescriptor
Syntax
Delphi
TnxBlockModifyActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxBlockModifyActionDescriptor.

Group

Classes

Links
TnxBlockModifyActionDescriptor Methods, TnxBlockModifyActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxBlockModifyActionDescriptor Members

TnxBlockModifyActionDescriptor Members
TnxBlockModifyActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBlockModifyActionDescriptor.

Class

TnxBlockModifyActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxBlockModifyActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxBlockModifyActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBlockModifyActionDescriptor Methods

TnxBlockModifyActionDescriptor Methods
TnxBlockModifyActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxBlockModifyActionDescriptor class are listed here.

Class

TnxBlockModifyActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxBlockModifyActionDescriptor
SaveToWriter |
Links
TnxBlockModifyActionDescriptor Class, Legend, Public Methods


TnxBlockModifyActionDescriptor.LoadFromReader Method

TnxBlockModifyActionDescriptor.LoadFromReader Method
TnxBlockModifyActionDescriptor Class TnxBlockModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBlockModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxBlockModifyActionDescriptor

Group

TnxBlockModifyActionDescriptor Methods

Links
TnxBlockModifyActionDescriptor Class, TnxBlockModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBlockModifyActionDescriptor Methods


TnxBlockModifyActionDescriptor.SaveToWriter Method

TnxBlockModifyActionDescriptor.SaveToWriter Method
TnxBlockModifyActionDescriptor Class TnxBlockModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxBlockModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxBlockModifyActionDescriptor Methods

Links
TnxBlockModifyActionDescriptor Class, TnxBlockModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxBlockModifyActionDescriptor Methods


TnxCascadeDeleteActionDescriptor Class

TnxCascadeDeleteActionDescriptor Class
TnxCascadeDeleteActionDescriptor Methods TnxCascadeDeleteActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptornxsdDataDictionaryRefInt_TnxCascadeDeleteActionDescriptor
Syntax
Delphi
TnxCascadeDeleteActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxCascadeDeleteActionDescriptor.

Group

Classes

Links
TnxCascadeDeleteActionDescriptor Methods, TnxCascadeDeleteActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxCascadeDeleteActionDescriptor Members

TnxCascadeDeleteActionDescriptor Members
TnxCascadeDeleteActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCascadeDeleteActionDescriptor.

Class

TnxCascadeDeleteActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxCascadeDeleteActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxCascadeDeleteActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCascadeDeleteActionDescriptor Methods

TnxCascadeDeleteActionDescriptor Methods
TnxCascadeDeleteActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxCascadeDeleteActionDescriptor class are listed here.

Class

TnxCascadeDeleteActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxCascadeDeleteActionDescriptor
SaveToWriter |
Links
TnxCascadeDeleteActionDescriptor Class, Legend, Public Methods


TnxCascadeDeleteActionDescriptor.LoadFromReader Method

TnxCascadeDeleteActionDescriptor.LoadFromReader Method
TnxCascadeDeleteActionDescriptor Class TnxCascadeDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCascadeDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxCascadeDeleteActionDescriptor

Group

TnxCascadeDeleteActionDescriptor Methods

Links
TnxCascadeDeleteActionDescriptor Class, TnxCascadeDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCascadeDeleteActionDescriptor Methods


TnxCascadeDeleteActionDescriptor.SaveToWriter Method

TnxCascadeDeleteActionDescriptor.SaveToWriter Method
TnxCascadeDeleteActionDescriptor Class TnxCascadeDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCascadeDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCascadeDeleteActionDescriptor Methods

Links
TnxCascadeDeleteActionDescriptor Class, TnxCascadeDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCascadeDeleteActionDescriptor Methods


TnxCascadeModifyActionDescriptor Class

TnxCascadeModifyActionDescriptor Class
TnxCascadeModifyActionDescriptor Methods TnxCascadeModifyActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptornxsdDataDictionaryRefInt_TnxCascadeModifyActionDescriptor
Syntax
Delphi
TnxCascadeModifyActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxCascadeModifyActionDescriptor.

Group

Classes

Links
TnxCascadeModifyActionDescriptor Methods, TnxCascadeModifyActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxCascadeModifyActionDescriptor Members

TnxCascadeModifyActionDescriptor Members
TnxCascadeModifyActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCascadeModifyActionDescriptor.

Class

TnxCascadeModifyActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxCascadeModifyActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxCascadeModifyActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCascadeModifyActionDescriptor Methods

TnxCascadeModifyActionDescriptor Methods
TnxCascadeModifyActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxCascadeModifyActionDescriptor class are listed here.

Class

TnxCascadeModifyActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxCascadeModifyActionDescriptor
SaveToWriter |
Links
TnxCascadeModifyActionDescriptor Class, Legend, Public Methods


TnxCascadeModifyActionDescriptor.LoadFromReader Method

TnxCascadeModifyActionDescriptor.LoadFromReader Method
TnxCascadeModifyActionDescriptor Class TnxCascadeModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCascadeModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxCascadeModifyActionDescriptor

Group

TnxCascadeModifyActionDescriptor Methods

Links
TnxCascadeModifyActionDescriptor Class, TnxCascadeModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCascadeModifyActionDescriptor Methods


TnxCascadeModifyActionDescriptor.SaveToWriter Method

TnxCascadeModifyActionDescriptor.SaveToWriter Method
TnxCascadeModifyActionDescriptor Class TnxCascadeModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCascadeModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCascadeModifyActionDescriptor Methods

Links
TnxCascadeModifyActionDescriptor Class, TnxCascadeModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCascadeModifyActionDescriptor Methods


TnxClearDeleteActionDescriptor Class

TnxClearDeleteActionDescriptor Class
TnxClearDeleteActionDescriptor Methods TnxClearDeleteActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptornxsdDataDictionaryRefInt_TnxClearDeleteActionDescriptor
Syntax
Delphi
TnxClearDeleteActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxClearDeleteActionDescriptor.

Group

Classes

Links
TnxClearDeleteActionDescriptor Methods, TnxClearDeleteActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxClearDeleteActionDescriptor Members

TnxClearDeleteActionDescriptor Members
TnxClearDeleteActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClearDeleteActionDescriptor.

Class

TnxClearDeleteActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxClearDeleteActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxClearDeleteActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClearDeleteActionDescriptor Methods

TnxClearDeleteActionDescriptor Methods
TnxClearDeleteActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxClearDeleteActionDescriptor class are listed here.

Class

TnxClearDeleteActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxClearDeleteActionDescriptor
SaveToWriter |
Links
TnxClearDeleteActionDescriptor Class, Legend, Public Methods


TnxClearDeleteActionDescriptor.LoadFromReader Method

TnxClearDeleteActionDescriptor.LoadFromReader Method
TnxClearDeleteActionDescriptor Class TnxClearDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxClearDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxClearDeleteActionDescriptor

Group

TnxClearDeleteActionDescriptor Methods

Links
TnxClearDeleteActionDescriptor Class, TnxClearDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxClearDeleteActionDescriptor Methods


TnxClearDeleteActionDescriptor.SaveToWriter Method

TnxClearDeleteActionDescriptor.SaveToWriter Method
TnxClearDeleteActionDescriptor Class TnxClearDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxClearDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxClearDeleteActionDescriptor Methods

Links
TnxClearDeleteActionDescriptor Class, TnxClearDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxClearDeleteActionDescriptor Methods


TnxClearModifyActionDescriptor Class

TnxClearModifyActionDescriptor Class
TnxClearModifyActionDescriptor Methods TnxClearModifyActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptornxsdDataDictionaryRefInt_TnxClearModifyActionDescriptor
Syntax
Delphi
TnxClearModifyActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxClearModifyActionDescriptor.

Group

Classes

Links
TnxClearModifyActionDescriptor Methods, TnxClearModifyActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxClearModifyActionDescriptor Members

TnxClearModifyActionDescriptor Members
TnxClearModifyActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxClearModifyActionDescriptor.

Class

TnxClearModifyActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxClearModifyActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxClearModifyActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxClearModifyActionDescriptor Methods

TnxClearModifyActionDescriptor Methods
TnxClearModifyActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxClearModifyActionDescriptor class are listed here.

Class

TnxClearModifyActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxClearModifyActionDescriptor
SaveToWriter |
Links
TnxClearModifyActionDescriptor Class, Legend, Public Methods


TnxClearModifyActionDescriptor.LoadFromReader Method

TnxClearModifyActionDescriptor.LoadFromReader Method
TnxClearModifyActionDescriptor Class TnxClearModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxClearModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxClearModifyActionDescriptor

Group

TnxClearModifyActionDescriptor Methods

Links
TnxClearModifyActionDescriptor Class, TnxClearModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxClearModifyActionDescriptor Methods


TnxClearModifyActionDescriptor.SaveToWriter Method

TnxClearModifyActionDescriptor.SaveToWriter Method
TnxClearModifyActionDescriptor Class TnxClearModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxClearModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxClearModifyActionDescriptor Methods

Links
TnxClearModifyActionDescriptor Class, TnxClearModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxClearModifyActionDescriptor Methods


TnxCloneTargetCursorDescriptor Class

TnxCloneTargetCursorDescriptor Class
TnxCloneTargetCursorDescriptor Methods TnxCloneTargetCursorDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptornxsdDataDictionaryRefInt_TnxCloneTargetCursorDescriptor
Syntax
Delphi
TnxCloneTargetCursorDescriptor = class(TnxBaseTargetCursorDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxCloneTargetCursorDescriptor.

Group

Classes

Links
TnxCloneTargetCursorDescriptor Methods, TnxCloneTargetCursorDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxCloneTargetCursorDescriptor Members

TnxCloneTargetCursorDescriptor Members
TnxCloneTargetCursorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCloneTargetCursorDescriptor.

Class

TnxCloneTargetCursorDescriptor Class

Protected Fields
Name | Description
btcCachedEngineClass | This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReferencedTableName |
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
References |
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Links
TnxCloneTargetCursorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCloneTargetCursorDescriptor Methods

TnxCloneTargetCursorDescriptor Methods
TnxCloneTargetCursorDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxCloneTargetCursorDescriptor class are listed here.

Class

TnxCloneTargetCursorDescriptor Class

Public Methods
Name | Description
LoadFromReader |
ReferencedTableName |
SaveToWriter |
Links
TnxCloneTargetCursorDescriptor Class, Legend, Public Methods


TnxCloneTargetCursorDescriptor.LoadFromReader Method

TnxCloneTargetCursorDescriptor.LoadFromReader Method
TnxCloneTargetCursorDescriptor Class TnxCloneTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCloneTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxCloneTargetCursorDescriptor Methods

Links
TnxCloneTargetCursorDescriptor Class, TnxCloneTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCloneTargetCursorDescriptor Methods


TnxCloneTargetCursorDescriptor.ReferencedTableName Method

TnxCloneTargetCursorDescriptor.ReferencedTableName Method
TnxCloneTargetCursorDescriptor Class TnxCloneTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCloneTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function ReferencedTableName: string; override;
Group

TnxCloneTargetCursorDescriptor Methods

Links
TnxCloneTargetCursorDescriptor Class, TnxCloneTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCloneTargetCursorDescriptor Methods


TnxCloneTargetCursorDescriptor.SaveToWriter Method

TnxCloneTargetCursorDescriptor.SaveToWriter Method
TnxCloneTargetCursorDescriptor Class TnxCloneTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxCloneTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxCloneTargetCursorDescriptor Methods

Links
TnxCloneTargetCursorDescriptor Class, TnxCloneTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxCloneTargetCursorDescriptor Methods


TnxFieldSourceDescriptor Class

TnxFieldSourceDescriptor Class
TnxFieldSourceDescriptor Fields TnxFieldSourceDescriptor Methods TnxFieldSourceDescriptor Properties TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptornxsdDataDictionaryRefInt_TnxFieldSourceDescriptor
Syntax
Delphi
TnxFieldSourceDescriptor = class(TnxBaseSourceDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxFieldSourceDescriptor.

Group

Classes

Links
TnxFieldSourceDescriptor Fields, TnxFieldSourceDescriptor Methods, TnxFieldSourceDescriptor Properties, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxFieldSourceDescriptor Members

TnxFieldSourceDescriptor Members
TnxFieldSourceDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldSourceDescriptor.

Class

TnxFieldSourceDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
fsdFieldNumber | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify |
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
fsdGetField |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxFieldSourceDescriptor
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseSourceDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
Field | This is Field, a member of class TnxFieldSourceDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxFieldSourceDescriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of all actions if this source fields is null
Links
TnxFieldSourceDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFieldSourceDescriptor.Create Constructor

TnxFieldSourceDescriptor.Create Constructor
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent); override;
Class

TnxFieldSourceDescriptor Class

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Class


TnxFieldSourceDescriptor.Destroy Destructor

TnxFieldSourceDescriptor.Destroy Destructor
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFieldSourceDescriptor Class

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Class


TnxFieldSourceDescriptor Fields

TnxFieldSourceDescriptor Fields
TnxFieldSourceDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFieldSourceDescriptor class are listed here.

Class

TnxFieldSourceDescriptor Class

Protected Fields
Name | Description
fsdFieldNumber | private
Links
TnxFieldSourceDescriptor Class, Legend, Protected Fields


TnxFieldSourceDescriptor.fsdFieldNumber Field

TnxFieldSourceDescriptor.fsdFieldNumber Field
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Fields Send Feedback
Syntax
Delphi
fsdFieldNumber: Integer;
Description

private

Group

TnxFieldSourceDescriptor Fields

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Fields


TnxFieldSourceDescriptor Methods

TnxFieldSourceDescriptor Methods
TnxFieldSourceDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldSourceDescriptor class are listed here.

Class

TnxFieldSourceDescriptor Class

Protected Methods
Name | Description
diFieldChangeNotify |
fsdGetField |
Public Methods
Name | Description
CheckValid | TnxFieldSourceDescriptor
IsEqual |
LoadFromReader |
SaveToWriter |
Links
TnxFieldSourceDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldSourceDescriptor.CheckValid Method

TnxFieldSourceDescriptor.CheckValid Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxFieldSourceDescriptor

Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor.diFieldChangeNotify Method

TnxFieldSourceDescriptor.diFieldChangeNotify Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure diFieldChangeNotify(aBefore: Boolean; aOldField: Integer; aNewField: Integer); override;
Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor.fsdGetField Method

TnxFieldSourceDescriptor.fsdGetField Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
function fsdGetField: TnxFieldDescriptor;
Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor.IsEqual Method

TnxFieldSourceDescriptor.IsEqual Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor.LoadFromReader Method

TnxFieldSourceDescriptor.LoadFromReader Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor.SaveToWriter Method

TnxFieldSourceDescriptor.SaveToWriter Method
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxFieldSourceDescriptor Methods

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Methods


TnxFieldSourceDescriptor Properties

TnxFieldSourceDescriptor Properties
TnxFieldSourceDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFieldSourceDescriptor class are listed here.

Class

TnxFieldSourceDescriptor Class

Public Properties
Name | Description
Field | This is Field, a member of class TnxFieldSourceDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxFieldSourceDescriptor.
Links
TnxFieldSourceDescriptor Class, Legend, Public Properties


TnxFieldSourceDescriptor.Field Property

TnxFieldSourceDescriptor.Field Property
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Properties Send Feedback
Syntax
Delphi
property Field: TnxFieldDescriptor;
Description

This is Field, a member of class TnxFieldSourceDescriptor.

Group

TnxFieldSourceDescriptor Properties

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Properties


TnxFieldSourceDescriptor.FieldNumber Property

TnxFieldSourceDescriptor.FieldNumber Property
TnxFieldSourceDescriptor Class TnxFieldSourceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxFieldSourceDescriptor Properties Send Feedback
Syntax
Delphi
property FieldNumber: Integer;
Description

This is FieldNumber, a member of class TnxFieldSourceDescriptor.

Group

TnxFieldSourceDescriptor Properties

Links
TnxFieldSourceDescriptor Class, TnxFieldSourceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxFieldSourceDescriptor Properties


TnxReferenceDescriptor Class

TnxReferenceDescriptor Class
TnxReferenceDescriptor Fields TnxReferenceDescriptor Methods TnxReferenceDescriptor Properties TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxReferenceDescriptornxsdDataDictionaryRefInt_TnxReferenceDescriptornxsdDataDictionaryRefInt_TnxReferenceDescriptornxsdDataDictionaryRefInt_TnxReferenceDescriptornxsdDataDictionaryRefInt_TnxReferenceDescriptornxsdDataDictionaryRefInt_TnxReferenceDescriptor
Syntax
Delphi
TnxReferenceDescriptor = class(TnxDictionaryItem);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxReferenceDescriptor.

Group

Classes

Links
TnxReferenceDescriptor Fields, TnxReferenceDescriptor Methods, TnxReferenceDescriptor Properties, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxReferenceDescriptor Members

TnxReferenceDescriptor Members
TnxReferenceDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxReferenceDescriptor.

Class

TnxReferenceDescriptor Class

Protected Fields
Name | Description
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
rdCachedEngineClass | private
rdTargetCursor | This is rdTargetCursor, a member of class TnxReferenceDescriptor.
rdTargetIndex | This is rdTargetIndex, a member of class TnxReferenceDescriptor.
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
rdActionCount | This is rdActionCount, a member of class TnxReferenceDescriptor.
rdActions | for speed
rdSourceCount | This is rdSourceCount, a member of class TnxReferenceDescriptor.
rdSources | for speed
Public Methods
Name | Description
AddAction | TnxReferenceDescriptor
AddSource |
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References |
RemoveAction | This is the overview for the RemoveAction method overload.
RemoveSource | This is the overview for the RemoveSource method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxReferenceDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
TargetCursor | This is TargetCursor, a member of class TnxReferenceDescriptor.
TargetIndex | This is TargetIndex, a member of class TnxReferenceDescriptor.
Links
TnxReferenceDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxReferenceDescriptor.Create Constructor

TnxReferenceDescriptor.Create Constructor
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TPersistent; aTargetCursorClass: TnxBaseTargetCursorDescriptorClass = nil); virtual;
Class

TnxReferenceDescriptor Class

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Class


TnxReferenceDescriptor.Destroy Destructor

TnxReferenceDescriptor.Destroy Destructor
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxReferenceDescriptor Class

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Class


TnxReferenceDescriptor Fields

TnxReferenceDescriptor Fields
TnxReferenceDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxReferenceDescriptor class are listed here.

Class

TnxReferenceDescriptor Class

Protected Fields
Name | Description
rdCachedEngineClass | private
rdTargetCursor | This is rdTargetCursor, a member of class TnxReferenceDescriptor.
rdTargetIndex | This is rdTargetIndex, a member of class TnxReferenceDescriptor.
Public Fields
Name | Description
rdActionCount | This is rdActionCount, a member of class TnxReferenceDescriptor.
rdActions | for speed
rdSourceCount | This is rdSourceCount, a member of class TnxReferenceDescriptor.
rdSources | for speed
Links
TnxReferenceDescriptor Class, Legend, Protected Fields, Public Fields


TnxReferenceDescriptor.rdActionCount Field

TnxReferenceDescriptor.rdActionCount Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdActionCount: Integer;
Description

This is rdActionCount, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdActions Field

TnxReferenceDescriptor.rdActions Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdActions: array of TnxBaseActionDescriptor;
Description

for speed

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdCachedEngineClass Field

TnxReferenceDescriptor.rdCachedEngineClass Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdCachedEngineClass: TClass;
Description

private

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdSourceCount Field

TnxReferenceDescriptor.rdSourceCount Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdSourceCount: Integer;
Description

This is rdSourceCount, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdSources Field

TnxReferenceDescriptor.rdSources Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdSources: array of TnxBaseSourceDescriptor;
Description

for speed

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdTargetCursor Field

TnxReferenceDescriptor.rdTargetCursor Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdTargetCursor: TnxBaseTargetCursorDescriptor;
Description

This is rdTargetCursor, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor.rdTargetIndex Field

TnxReferenceDescriptor.rdTargetIndex Field
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Fields Send Feedback
Syntax
Delphi
rdTargetIndex: string;
Description

This is rdTargetIndex, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Fields

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Fields


TnxReferenceDescriptor Methods

TnxReferenceDescriptor Methods
TnxReferenceDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxReferenceDescriptor class are listed here.

Class

TnxReferenceDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
AddAction | TnxReferenceDescriptor
AddSource |
CheckValid |
IsEqual |
LoadFromReader |
References |
RemoveAction | This is the overview for the RemoveAction method overload.
RemoveSource | This is the overview for the RemoveSource method overload.
SaveToWriter |
Links
TnxReferenceDescriptor Class, Legend, Protected Methods, Public Methods


TnxReferenceDescriptor.AddAction Method

TnxReferenceDescriptor.AddAction Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
function AddAction(aActionDescriptorClass: TnxBaseActionDescriptorClass): TnxBaseActionDescriptor;
Description

TnxReferenceDescriptor

Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.AddSource Method

TnxReferenceDescriptor.AddSource Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
function AddSource(aSourceDescriptorClass: TnxBaseSourceDescriptorClass = nil): TnxBaseSourceDescriptor;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.CheckValid Method

TnxReferenceDescriptor.CheckValid Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.GetList Method

TnxReferenceDescriptor.GetList Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.IsEqual Method

TnxReferenceDescriptor.IsEqual Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.LoadFromReader Method

TnxReferenceDescriptor.LoadFromReader Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor.References Method

TnxReferenceDescriptor.References Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
function References(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


RemoveAction Method

RemoveAction Method
TnxReferenceDescriptor Methods Send Feedback

This is the overview for the RemoveAction method overload.

Overload List
Name | Description
TnxReferenceDescriptor.RemoveAction (Integer) |
TnxReferenceDescriptor.RemoveAction (TnxBaseActionDescriptor) |
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Methods


TnxReferenceDescriptor.RemoveAction Method (Integer)

TnxReferenceDescriptor.RemoveAction Method (Integer)
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveAction Method Send Feedback
Syntax
Delphi
procedure RemoveAction(aIndex: Integer); overload;
Group

RemoveAction Method

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveAction Method


TnxReferenceDescriptor.RemoveAction Method (TnxBaseActionDescriptor)

TnxReferenceDescriptor.RemoveAction Method (TnxBaseActionDescriptor)
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveAction Method Send Feedback
Syntax
Delphi
procedure RemoveAction(aDescriptor: TnxBaseActionDescriptor); overload;
Group

RemoveAction Method

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveAction Method


RemoveSource Method

RemoveSource Method
TnxReferenceDescriptor Methods Send Feedback

This is the overview for the RemoveSource method overload.

Overload List
Name | Description
TnxReferenceDescriptor.RemoveSource (Integer) |
TnxReferenceDescriptor.RemoveSource (TnxBaseSourceDescriptor) |
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Methods


TnxReferenceDescriptor.RemoveSource Method (Integer)

TnxReferenceDescriptor.RemoveSource Method (Integer)
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveSource Method Send Feedback
Syntax
Delphi
procedure RemoveSource(aIndex: Integer); overload;
Group

RemoveSource Method

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveSource Method


TnxReferenceDescriptor.RemoveSource Method (TnxBaseSourceDescriptor)

TnxReferenceDescriptor.RemoveSource Method (TnxBaseSourceDescriptor)
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveSource Method Send Feedback
Syntax
Delphi
procedure RemoveSource(aDescriptor: TnxBaseSourceDescriptor); overload;
Group

RemoveSource Method

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveSource Method


TnxReferenceDescriptor.SaveToWriter Method

TnxReferenceDescriptor.SaveToWriter Method
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxReferenceDescriptor Methods

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Methods


TnxReferenceDescriptor Properties

TnxReferenceDescriptor Properties
TnxReferenceDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxReferenceDescriptor class are listed here.

Class

TnxReferenceDescriptor Class

Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxReferenceDescriptor.
TargetCursor | This is TargetCursor, a member of class TnxReferenceDescriptor.
TargetIndex | This is TargetIndex, a member of class TnxReferenceDescriptor.
Links
TnxReferenceDescriptor Class, Legend, Public Properties


TnxReferenceDescriptor.CachedEngineClass Property

TnxReferenceDescriptor.CachedEngineClass Property
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Properties Send Feedback
Syntax
Delphi
property CachedEngineClass: TClass;
Description

This is CachedEngineClass, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Properties

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Properties


TnxReferenceDescriptor.TargetCursor Property

TnxReferenceDescriptor.TargetCursor Property
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Properties Send Feedback
Syntax
Delphi
property TargetCursor: TnxBaseTargetCursorDescriptor;
Description

This is TargetCursor, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Properties

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Properties


TnxReferenceDescriptor.TargetIndex Property

TnxReferenceDescriptor.TargetIndex Property
TnxReferenceDescriptor Class TnxReferenceDescriptor Members nxsdDataDictionaryRefInt Namespace TnxReferenceDescriptor Properties Send Feedback
Syntax
Delphi
property TargetIndex: string;
Description

This is TargetIndex, a member of class TnxReferenceDescriptor.

Group

TnxReferenceDescriptor Properties

Links
TnxReferenceDescriptor Class, TnxReferenceDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxReferenceDescriptor Properties


TnxRefIntegrityDescriptor Class

TnxRefIntegrityDescriptor Class
TnxRefIntegrityDescriptor Fields TnxRefIntegrityDescriptor Methods TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptornxsdDataDictionaryRefInt_TnxRefIntegrityDescriptor
Syntax
Delphi
TnxRefIntegrityDescriptor = class(TnxBaseCustomDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxRefIntegrityDescriptor.

Group

Classes

Links
TnxRefIntegrityDescriptor Fields, TnxRefIntegrityDescriptor Methods, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxRefIntegrityDescriptor Members

TnxRefIntegrityDescriptor Members
TnxRefIntegrityDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRefIntegrityDescriptor.

Class

TnxRefIntegrityDescriptor Class

Protected Fields
Name | Description
bcdName | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create | constructor.
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
ridReferenceCount | This is ridReferenceCount, a member of class TnxRefIntegrityDescriptor.
ridReferences | for speed
Public Methods
Name | Description
AddReference | TnxRefIntegrityDescriptor
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid |
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RemoveReference | This is the overview for the RemoveReference method overload.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Name | Returns the name of the Custom Descriptor.
Links
TnxRefIntegrityDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxRefIntegrityDescriptor.Destroy Destructor

TnxRefIntegrityDescriptor.Destroy Destructor
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRefIntegrityDescriptor Class

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Class


TnxRefIntegrityDescriptor Fields

TnxRefIntegrityDescriptor Fields
TnxRefIntegrityDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxRefIntegrityDescriptor class are listed here.

Class

TnxRefIntegrityDescriptor Class

Public Fields
Name | Description
ridReferenceCount | This is ridReferenceCount, a member of class TnxRefIntegrityDescriptor.
ridReferences | for speed
Links
TnxRefIntegrityDescriptor Class, Legend, Public Fields


TnxRefIntegrityDescriptor.ridReferenceCount Field

TnxRefIntegrityDescriptor.ridReferenceCount Field
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Fields Send Feedback
Syntax
Delphi
ridReferenceCount: Integer;
Description

This is ridReferenceCount, a member of class TnxRefIntegrityDescriptor.

Group

TnxRefIntegrityDescriptor Fields

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Fields


TnxRefIntegrityDescriptor.ridReferences Field

TnxRefIntegrityDescriptor.ridReferences Field
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Fields Send Feedback
Syntax
Delphi
ridReferences: array of TnxReferenceDescriptor;
Description

for speed

Group

TnxRefIntegrityDescriptor Fields

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Fields


TnxRefIntegrityDescriptor Methods

TnxRefIntegrityDescriptor Methods
TnxRefIntegrityDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxRefIntegrityDescriptor class are listed here.

Class

TnxRefIntegrityDescriptor Class

Public Methods
Name | Description
AddReference | TnxRefIntegrityDescriptor
CheckValid |
IsEqual |
LoadFromReader |
RemoveReference | This is the overview for the RemoveReference method overload.
SaveToWriter |
Links
TnxRefIntegrityDescriptor Class, Legend, Public Methods


TnxRefIntegrityDescriptor.AddReference Method

TnxRefIntegrityDescriptor.AddReference Method
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Methods Send Feedback
Syntax
Delphi
function AddReference(aReferenceClass: TnxReferenceDescriptorClass = nil; aTargetCursorClass: TnxBaseTargetCursorDescriptorClass = nil): TnxReferenceDescriptor;
Description

TnxRefIntegrityDescriptor

Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Methods


TnxRefIntegrityDescriptor.CheckValid Method

TnxRefIntegrityDescriptor.CheckValid Method
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Methods


TnxRefIntegrityDescriptor.IsEqual Method

TnxRefIntegrityDescriptor.IsEqual Method
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Methods


TnxRefIntegrityDescriptor.LoadFromReader Method

TnxRefIntegrityDescriptor.LoadFromReader Method
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Methods


RemoveReference Method

RemoveReference Method
TnxRefIntegrityDescriptor Methods Send Feedback

This is the overview for the RemoveReference method overload.

Overload List
Name | Description
TnxRefIntegrityDescriptor.RemoveReference (Integer) |
TnxRefIntegrityDescriptor.RemoveReference (TnxReferenceDescriptor) |
Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Methods


TnxRefIntegrityDescriptor.RemoveReference Method (Integer)

TnxRefIntegrityDescriptor.RemoveReference Method (Integer)
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveReference Method Send Feedback
Syntax
Delphi
procedure RemoveReference(aIndex: Integer); overload;
Group

RemoveReference Method

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveReference Method


TnxRefIntegrityDescriptor.RemoveReference Method (TnxReferenceDescriptor)

TnxRefIntegrityDescriptor.RemoveReference Method (TnxReferenceDescriptor)
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace RemoveReference Method Send Feedback
Syntax
Delphi
procedure RemoveReference(aDescriptor: TnxReferenceDescriptor); overload;
Group

RemoveReference Method

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, RemoveReference Method


TnxRefIntegrityDescriptor.SaveToWriter Method

TnxRefIntegrityDescriptor.SaveToWriter Method
TnxRefIntegrityDescriptor Class TnxRefIntegrityDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRefIntegrityDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxRefIntegrityDescriptor Methods

Links
TnxRefIntegrityDescriptor Class, TnxRefIntegrityDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRefIntegrityDescriptor Methods


TnxRelativeTargetCursorDescriptor Class

TnxRelativeTargetCursorDescriptor Class
TnxRelativeTargetCursorDescriptor Fields TnxRelativeTargetCursorDescriptor Methods TnxRelativeTargetCursorDescriptor Properties TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptornxsdDataDictionaryRefInt_TnxRelativeTargetCursorDescriptor
Syntax
Delphi
TnxRelativeTargetCursorDescriptor = class(TnxBaseTargetCursorDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxRelativeTargetCursorDescriptor.

Group

Classes

Links
TnxRelativeTargetCursorDescriptor Fields, TnxRelativeTargetCursorDescriptor Methods, TnxRelativeTargetCursorDescriptor Properties, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxRelativeTargetCursorDescriptor Members

TnxRelativeTargetCursorDescriptor Members
TnxRelativeTargetCursorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRelativeTargetCursorDescriptor.

Class

TnxRelativeTargetCursorDescriptor Class

Protected Fields
Name | Description
btcCachedEngineClass | This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
rtcTableName | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
rtcSetTableName |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxRelativeTargetCursorDescriptor
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReferencedTableName |
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
References |
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
TableName | This is TableName, a member of class TnxRelativeTargetCursorDescriptor.
Links
TnxRelativeTargetCursorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRelativeTargetCursorDescriptor Fields

TnxRelativeTargetCursorDescriptor Fields
TnxRelativeTargetCursorDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxRelativeTargetCursorDescriptor class are listed here.

Class

TnxRelativeTargetCursorDescriptor Class

Protected Fields
Name | Description
rtcTableName | private
Links
TnxRelativeTargetCursorDescriptor Class, Legend, Protected Fields


TnxRelativeTargetCursorDescriptor.rtcTableName Field

TnxRelativeTargetCursorDescriptor.rtcTableName Field
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Fields Send Feedback
Syntax
Delphi
rtcTableName: string;
Description

private

Group

TnxRelativeTargetCursorDescriptor Fields

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Fields


TnxRelativeTargetCursorDescriptor Methods

TnxRelativeTargetCursorDescriptor Methods
TnxRelativeTargetCursorDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRelativeTargetCursorDescriptor class are listed here.

Class

TnxRelativeTargetCursorDescriptor Class

Protected Methods
Name | Description
rtcSetTableName |
Public Methods
Name | Description
CheckValid | TnxRelativeTargetCursorDescriptor
IsEqual |
LoadFromReader |
ReferencedTableName |
SaveToWriter |
Links
TnxRelativeTargetCursorDescriptor Class, Legend, Protected Methods, Public Methods


TnxRelativeTargetCursorDescriptor.CheckValid Method

TnxRelativeTargetCursorDescriptor.CheckValid Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxRelativeTargetCursorDescriptor

Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor.IsEqual Method

TnxRelativeTargetCursorDescriptor.IsEqual Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor.LoadFromReader Method

TnxRelativeTargetCursorDescriptor.LoadFromReader Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor.ReferencedTableName Method

TnxRelativeTargetCursorDescriptor.ReferencedTableName Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function ReferencedTableName: string; override;
Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor.rtcSetTableName Method

TnxRelativeTargetCursorDescriptor.rtcSetTableName Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure rtcSetTableName(const aValue: string);
Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor.SaveToWriter Method

TnxRelativeTargetCursorDescriptor.SaveToWriter Method
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxRelativeTargetCursorDescriptor Methods

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Methods


TnxRelativeTargetCursorDescriptor Properties

TnxRelativeTargetCursorDescriptor Properties
TnxRelativeTargetCursorDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxRelativeTargetCursorDescriptor class are listed here.

Class

TnxRelativeTargetCursorDescriptor Class

Public Properties
Name | Description
TableName | This is TableName, a member of class TnxRelativeTargetCursorDescriptor.
Links
TnxRelativeTargetCursorDescriptor Class, Legend, Public Properties


TnxRelativeTargetCursorDescriptor.TableName Property

TnxRelativeTargetCursorDescriptor.TableName Property
TnxRelativeTargetCursorDescriptor Class TnxRelativeTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxRelativeTargetCursorDescriptor Properties Send Feedback
Syntax
Delphi
property TableName: string;
Description

This is TableName, a member of class TnxRelativeTargetCursorDescriptor.

Group

TnxRelativeTargetCursorDescriptor Properties

Links
TnxRelativeTargetCursorDescriptor Class, TnxRelativeTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxRelativeTargetCursorDescriptor Properties


TnxSetDefaultDeleteActionDescriptor Class

TnxSetDefaultDeleteActionDescriptor Class
TnxSetDefaultDeleteActionDescriptor Methods TnxSetDefaultDeleteActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultDeleteActionDescriptor
Syntax
Delphi
TnxSetDefaultDeleteActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxSetDefaultDeleteActionDescriptor.

Group

Classes

Links
TnxSetDefaultDeleteActionDescriptor Methods, TnxSetDefaultDeleteActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxSetDefaultDeleteActionDescriptor Members

TnxSetDefaultDeleteActionDescriptor Members
TnxSetDefaultDeleteActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSetDefaultDeleteActionDescriptor.

Class

TnxSetDefaultDeleteActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxSetDefaultDeleteActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxSetDefaultDeleteActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSetDefaultDeleteActionDescriptor Methods

TnxSetDefaultDeleteActionDescriptor Methods
TnxSetDefaultDeleteActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxSetDefaultDeleteActionDescriptor class are listed here.

Class

TnxSetDefaultDeleteActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxSetDefaultDeleteActionDescriptor
SaveToWriter |
Links
TnxSetDefaultDeleteActionDescriptor Class, Legend, Public Methods


TnxSetDefaultDeleteActionDescriptor.LoadFromReader Method

TnxSetDefaultDeleteActionDescriptor.LoadFromReader Method
TnxSetDefaultDeleteActionDescriptor Class TnxSetDefaultDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxSetDefaultDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxSetDefaultDeleteActionDescriptor

Group

TnxSetDefaultDeleteActionDescriptor Methods

Links
TnxSetDefaultDeleteActionDescriptor Class, TnxSetDefaultDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxSetDefaultDeleteActionDescriptor Methods


TnxSetDefaultDeleteActionDescriptor.SaveToWriter Method

TnxSetDefaultDeleteActionDescriptor.SaveToWriter Method
TnxSetDefaultDeleteActionDescriptor Class TnxSetDefaultDeleteActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxSetDefaultDeleteActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxSetDefaultDeleteActionDescriptor Methods

Links
TnxSetDefaultDeleteActionDescriptor Class, TnxSetDefaultDeleteActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxSetDefaultDeleteActionDescriptor Methods


TnxSetDefaultModifyActionDescriptor Class

TnxSetDefaultModifyActionDescriptor Class
TnxSetDefaultModifyActionDescriptor Methods TnxSetDefaultModifyActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptornxsdDataDictionaryRefInt_TnxSetDefaultModifyActionDescriptor
Syntax
Delphi
TnxSetDefaultModifyActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxSetDefaultModifyActionDescriptor.

Group

Classes

Links
TnxSetDefaultModifyActionDescriptor Methods, TnxSetDefaultModifyActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxSetDefaultModifyActionDescriptor Members

TnxSetDefaultModifyActionDescriptor Members
TnxSetDefaultModifyActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSetDefaultModifyActionDescriptor.

Class

TnxSetDefaultModifyActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxSetDefaultModifyActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxSetDefaultModifyActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSetDefaultModifyActionDescriptor Methods

TnxSetDefaultModifyActionDescriptor Methods
TnxSetDefaultModifyActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxSetDefaultModifyActionDescriptor class are listed here.

Class

TnxSetDefaultModifyActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxSetDefaultModifyActionDescriptor
SaveToWriter |
Links
TnxSetDefaultModifyActionDescriptor Class, Legend, Public Methods


TnxSetDefaultModifyActionDescriptor.LoadFromReader Method

TnxSetDefaultModifyActionDescriptor.LoadFromReader Method
TnxSetDefaultModifyActionDescriptor Class TnxSetDefaultModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxSetDefaultModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxSetDefaultModifyActionDescriptor

Group

TnxSetDefaultModifyActionDescriptor Methods

Links
TnxSetDefaultModifyActionDescriptor Class, TnxSetDefaultModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxSetDefaultModifyActionDescriptor Methods


TnxSetDefaultModifyActionDescriptor.SaveToWriter Method

TnxSetDefaultModifyActionDescriptor.SaveToWriter Method
TnxSetDefaultModifyActionDescriptor Class TnxSetDefaultModifyActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxSetDefaultModifyActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxSetDefaultModifyActionDescriptor Methods

Links
TnxSetDefaultModifyActionDescriptor Class, TnxSetDefaultModifyActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxSetDefaultModifyActionDescriptor Methods


TnxTableTargetCursorDescriptor Class

TnxTableTargetCursorDescriptor Class
TnxTableTargetCursorDescriptor Fields TnxTableTargetCursorDescriptor Methods TnxTableTargetCursorDescriptor Properties TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptornxsdDataDictionaryRefInt_TnxTableTargetCursorDescriptor
Syntax
Delphi
TnxTableTargetCursorDescriptor = class(TnxBaseTargetCursorDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxTableTargetCursorDescriptor.

Group

Classes

Links
TnxTableTargetCursorDescriptor Fields, TnxTableTargetCursorDescriptor Methods, TnxTableTargetCursorDescriptor Properties, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxTableTargetCursorDescriptor Members

TnxTableTargetCursorDescriptor Members
TnxTableTargetCursorDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTableTargetCursorDescriptor.

Class

TnxTableTargetCursorDescriptor Class

Protected Fields
Name | Description
btcCachedEngineClass | This is btcCachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
ttcPassword | This is ttcPassword, a member of class TnxTableTargetCursorDescriptor.
ttcTableName | private
Protected Methods
Name | Description
_AddRef |
_Release |
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | TnxTableTargetCursorDescriptor
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual |
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReferencedTableName |
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
References |
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseTargetCursorDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
Password | This is Password, a member of class TnxTableTargetCursorDescriptor.
TableName | This is TableName, a member of class TnxTableTargetCursorDescriptor.
Links
TnxTableTargetCursorDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTableTargetCursorDescriptor Fields

TnxTableTargetCursorDescriptor Fields
TnxTableTargetCursorDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxTableTargetCursorDescriptor class are listed here.

Class

TnxTableTargetCursorDescriptor Class

Protected Fields
Name | Description
ttcPassword | This is ttcPassword, a member of class TnxTableTargetCursorDescriptor.
ttcTableName | private
Links
TnxTableTargetCursorDescriptor Class, Legend, Protected Fields


TnxTableTargetCursorDescriptor.ttcPassword Field

TnxTableTargetCursorDescriptor.ttcPassword Field
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Fields Send Feedback
Syntax
Delphi
ttcPassword: UnicodeString;
Description

This is ttcPassword, a member of class TnxTableTargetCursorDescriptor.

Group

TnxTableTargetCursorDescriptor Fields

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Fields


TnxTableTargetCursorDescriptor.ttcTableName Field

TnxTableTargetCursorDescriptor.ttcTableName Field
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Fields Send Feedback
Syntax
Delphi
ttcTableName: string;
Description

private

Group

TnxTableTargetCursorDescriptor Fields

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Fields


TnxTableTargetCursorDescriptor Methods

TnxTableTargetCursorDescriptor Methods
TnxTableTargetCursorDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxTableTargetCursorDescriptor class are listed here.

Class

TnxTableTargetCursorDescriptor Class

Public Methods
Name | Description
CheckValid | TnxTableTargetCursorDescriptor
IsEqual |
LoadFromReader |
ReferencedTableName |
SaveToWriter |
Links
TnxTableTargetCursorDescriptor Class, Legend, Public Methods


TnxTableTargetCursorDescriptor.CheckValid Method

TnxTableTargetCursorDescriptor.CheckValid Method
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure CheckValid(aForBuild: Boolean); override;
Description

TnxTableTargetCursorDescriptor

Group

TnxTableTargetCursorDescriptor Methods

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Methods


TnxTableTargetCursorDescriptor.IsEqual Method

TnxTableTargetCursorDescriptor.IsEqual Method
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function IsEqual(aDictionaryItem: TnxDictionaryItem): Boolean; override;
Group

TnxTableTargetCursorDescriptor Methods

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Methods


TnxTableTargetCursorDescriptor.LoadFromReader Method

TnxTableTargetCursorDescriptor.LoadFromReader Method
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Group

TnxTableTargetCursorDescriptor Methods

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Methods


TnxTableTargetCursorDescriptor.ReferencedTableName Method

TnxTableTargetCursorDescriptor.ReferencedTableName Method
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
function ReferencedTableName: string; override;
Group

TnxTableTargetCursorDescriptor Methods

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Methods


TnxTableTargetCursorDescriptor.SaveToWriter Method

TnxTableTargetCursorDescriptor.SaveToWriter Method
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTableTargetCursorDescriptor Methods

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Methods


TnxTableTargetCursorDescriptor Properties

TnxTableTargetCursorDescriptor Properties
TnxTableTargetCursorDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxTableTargetCursorDescriptor class are listed here.

Class

TnxTableTargetCursorDescriptor Class

Public Properties
Name | Description
Password | This is Password, a member of class TnxTableTargetCursorDescriptor.
TableName | This is TableName, a member of class TnxTableTargetCursorDescriptor.
Links
TnxTableTargetCursorDescriptor Class, Legend, Public Properties


TnxTableTargetCursorDescriptor.Password Property

TnxTableTargetCursorDescriptor.Password Property
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This is Password, a member of class TnxTableTargetCursorDescriptor.

Group

TnxTableTargetCursorDescriptor Properties

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Properties


TnxTableTargetCursorDescriptor.TableName Property

TnxTableTargetCursorDescriptor.TableName Property
TnxTableTargetCursorDescriptor Class TnxTableTargetCursorDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTableTargetCursorDescriptor Properties Send Feedback
Syntax
Delphi
property TableName: string;
Description

This is TableName, a member of class TnxTableTargetCursorDescriptor.

Group

TnxTableTargetCursorDescriptor Properties

Links
TnxTableTargetCursorDescriptor Class, TnxTableTargetCursorDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTableTargetCursorDescriptor Properties


TnxTargetRequiredActionDescriptor Class

TnxTargetRequiredActionDescriptor Class
TnxTargetRequiredActionDescriptor Methods TnxTargetRequiredActionDescriptor Members nxsdDataDictionaryRefInt Classes Send Feedback
Class Hierarchy
nxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptornxsdDataDictionaryRefInt_TnxTargetRequiredActionDescriptor
Syntax
Delphi
TnxTargetRequiredActionDescriptor = class(TnxBaseActionDescriptor);
File

nxsdDataDictionaryRefInt

Description

This is class nxsdDataDictionaryRefInt.TnxTargetRequiredActionDescriptor.

Group

Classes

Links
TnxTargetRequiredActionDescriptor Methods, TnxTargetRequiredActionDescriptor Members, nxsdDataDictionaryRefInt, Classes


TnxTargetRequiredActionDescriptor Members

TnxTargetRequiredActionDescriptor Members
TnxTargetRequiredActionDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTargetRequiredActionDescriptor.

Class

TnxTargetRequiredActionDescriptor Class

Protected Fields
Name | Description
badCachedEngineClass | This is badCachedEngineClass, a member of class TnxBaseActionDescriptor.
badSkipOnNull | private
diCacheActive | This is diCacheActive, a member of class TnxDictionaryItem.
diChilds | This is diChilds, a member of class TnxDictionaryItem.
diConstraintName | This is diConstraintName, a member of class TnxDictionaryItem.
diCustomStrings | This is diCustomStrings, a member of class TnxDictionaryItem.
diID | This is diID, a member of class TnxDictionaryItem.
diParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
badSetSkipOnNull | TnxBaseActionDescriptor
CheckReadOnly |
Create |
Create |
diActivateCaching | caching
diAddChild | child notifications
diAddConstraint | constraint notifications
diAddToFieldChangeNotifies |
diAddToFileChangeNotifies |
diAddToIndexChangeNotifies |
diDeactivateCaching | This is diDeactivateCaching, a member of class TnxDictionaryItem.
diFieldChangeNotify | field removal notification
diFileChangeNotify | file removal notification
diGetCustomStrings |
diIndexChangeNotify | index removal notification
diIsCustomStringsStored |
diIsSameClass | helper function to allow fuzzy class matching
diRemoveChild |
diRemoveConstraint |
diRemoveFromFieldChangeNotifies |
diRemoveFromFileChangeNotifies |
diRemoveFromIndexChangeNotifies |
diRequiresPack | determine if a pack is required
diSetConstraintName |
diSetCustomStrings |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetOwner |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
Assign | Assigns the settings of a Source item to the current Item
BeforeDestruction | TnxLifetimeTrackedPersistent
CheckValid | This method is called to check the validity of the item. If a descendant needs to validate settings, this method should be overridden and on error raise a an exception.
Destroy | destructor.
FindDescriptorClass | TnxBaseRegisterableDescriptor
FindDescriptorClass | Returns the class for the given named Descriptor class
FindParentOfType | Iterates the parents of the current item and returns the first found instance of a certain class type. Returns true if one is found.
FindRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Returns true if one is found.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetList |
GetParentOfType | Iterates the parents of the item and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRegisteredDescriptors |
GetRelatedDescriptorOfType | Iterates the parents of the given item aFrom and returns the first found instance of a certain class type. Raises an exception if none is found.
GetRelatedDescriptorOfTypeT |
IsEqual | The IsEqual function should return true if the given aDictionaryItem is of the same type and has *exactly* the same settings. Should be overridden by all descendants.
IterateReferencing | Iterates all dictionary items that reference a certain Item. Paremeters: aIterator: the Iterator function aCookie: user defined data that is passed on aItem: the item to check aRecursive: recursively call into all child items
LoadFromReader | TnxTargetRequiredActionDescriptor
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
References | The References function should return true if the given aDictionaryItem in the table named aTableName is referenced by this item.
RequiresPack |
SaveToWriter |
Public Properties
Name | Description
CachedEngineClass | This is CachedEngineClass, a member of class TnxBaseActionDescriptor.
ConstraintName | Set to the name of the constraint this dictionary item represents.
CustomStrings | A storage container for developers to store extra data with the descriptor.
HasCustomStrings | This property indicates if the item has CustomStrings assigned.
ID | Unique ID of the dictionary item
SkipOnNull | skip application of this action descriptor if any of the source fields is null
Links
TnxTargetRequiredActionDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTargetRequiredActionDescriptor Methods

TnxTargetRequiredActionDescriptor Methods
TnxTargetRequiredActionDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxTargetRequiredActionDescriptor class are listed here.

Class

TnxTargetRequiredActionDescriptor Class

Public Methods
Name | Description
LoadFromReader | TnxTargetRequiredActionDescriptor
SaveToWriter |
Links
TnxTargetRequiredActionDescriptor Class, Legend, Public Methods


TnxTargetRequiredActionDescriptor.LoadFromReader Method

TnxTargetRequiredActionDescriptor.LoadFromReader Method
TnxTargetRequiredActionDescriptor Class TnxTargetRequiredActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTargetRequiredActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure LoadFromReader(aReader: TnxReader); override;
Description

TnxTargetRequiredActionDescriptor

Group

TnxTargetRequiredActionDescriptor Methods

Links
TnxTargetRequiredActionDescriptor Class, TnxTargetRequiredActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTargetRequiredActionDescriptor Methods


TnxTargetRequiredActionDescriptor.SaveToWriter Method

TnxTargetRequiredActionDescriptor.SaveToWriter Method
TnxTargetRequiredActionDescriptor Class TnxTargetRequiredActionDescriptor Members nxsdDataDictionaryRefInt Namespace TnxTargetRequiredActionDescriptor Methods Send Feedback
Syntax
Delphi
procedure SaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTargetRequiredActionDescriptor Methods

Links
TnxTargetRequiredActionDescriptor Class, TnxTargetRequiredActionDescriptor Members, nxsdDataDictionaryRefInt Namespace, TnxTargetRequiredActionDescriptor Methods


Functions

Functions
Functions nxsdDataDictionaryRefInt Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
EnsureRefIntegrityDescriptor |
GetRefIntegrityDescriptor |
Namespace

nxsdDataDictionaryRefInt Namespace

Links
Functions, nxsdDataDictionaryRefInt Namespace, Legend


nxsdDataDictionaryRefInt.EnsureRefIntegrityDescriptor Function

nxsdDataDictionaryRefInt.EnsureRefIntegrityDescriptor Function
nxsdDataDictionaryRefInt Functions Send Feedback
Syntax
Delphi
function EnsureRefIntegrityDescriptor(aTable: TnxBaseTableDescriptor): TnxRefIntegrityDescriptor;
File

nxsdDataDictionaryRefInt

Group

Functions

Links
nxsdDataDictionaryRefInt, Functions


nxsdDataDictionaryRefInt.GetRefIntegrityDescriptor Function

nxsdDataDictionaryRefInt.GetRefIntegrityDescriptor Function
nxsdDataDictionaryRefInt Functions Send Feedback
Syntax
Delphi
function GetRefIntegrityDescriptor(aTable: TnxBaseTableDescriptor): TnxRefIntegrityDescriptor;
File

nxsdDataDictionaryRefInt

Group

Functions

Links
nxsdDataDictionaryRefInt, Functions


Types

Types
nxsdDataDictionaryRefInt Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdDataDictionaryRefInt Namespace

Types
Name | Description
TnxBaseActionDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseActionDescriptorClass.
TnxBaseSourceDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseSourceDescriptorClass.
TnxBaseTargetCursorDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxBaseTargetCursorDescriptorClass.
TnxReferenceDescriptorClass | This is type nxsdDataDictionaryRefInt.TnxReferenceDescriptorClass.
Links
nxsdDataDictionaryRefInt Namespace, Types


nxsdDataDictionaryRefInt.TnxBaseActionDescriptorClass Type

nxsdDataDictionaryRefInt.TnxBaseActionDescriptorClass Type
nxsdDataDictionaryRefInt Types Send Feedback
Syntax
Delphi
TnxBaseActionDescriptorClass = class of TnxBaseActionDescriptor;
File

nxsdDataDictionaryRefInt

Description

This is type nxsdDataDictionaryRefInt.TnxBaseActionDescriptorClass.

Group

Types

Links
nxsdDataDictionaryRefInt, Types


nxsdDataDictionaryRefInt.TnxBaseSourceDescriptorClass Type

nxsdDataDictionaryRefInt.TnxBaseSourceDescriptorClass Type
nxsdDataDictionaryRefInt Types Send Feedback
Syntax
Delphi
TnxBaseSourceDescriptorClass = class of TnxBaseSourceDescriptor;
File

nxsdDataDictionaryRefInt

Description

This is type nxsdDataDictionaryRefInt.TnxBaseSourceDescriptorClass.

Group

Types

Links
nxsdDataDictionaryRefInt, Types


nxsdDataDictionaryRefInt.TnxBaseTargetCursorDescriptorClass Type

nxsdDataDictionaryRefInt.TnxBaseTargetCursorDescriptorClass Type
nxsdDataDictionaryRefInt Types Send Feedback
Syntax
Delphi
TnxBaseTargetCursorDescriptorClass = class of TnxBaseTargetCursorDescriptor;
File

nxsdDataDictionaryRefInt

Description

This is type nxsdDataDictionaryRefInt.TnxBaseTargetCursorDescriptorClass.

Group

Types

Links
nxsdDataDictionaryRefInt, Types


nxsdDataDictionaryRefInt.TnxReferenceDescriptorClass Type

nxsdDataDictionaryRefInt.TnxReferenceDescriptorClass Type
nxsdDataDictionaryRefInt Types Send Feedback
Syntax
Delphi
TnxReferenceDescriptorClass = class of TnxReferenceDescriptor;
File

nxsdDataDictionaryRefInt

Description

This is type nxsdDataDictionaryRefInt.TnxReferenceDescriptorClass.

Group

Types

Links
nxsdDataDictionaryRefInt, Types


Variables

Variables
nxsdDataDictionaryRefInt Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdDataDictionaryRefInt Namespace

Variables
Name | Description
_ActionDescriptorList | This is variable nxsdDataDictionaryRefInt._ActionDescriptorList.
_ReferenceDescriptorList | This is variable nxsdDataDictionaryRefInt._ReferenceDescriptorList.
_SourceDescriptorList | This is variable nxsdDataDictionaryRefInt._SourceDescriptorList.
_TargetCursorDescriptorList | This is variable nxsdDataDictionaryRefInt._TargetCursorDescriptorList.
Links
nxsdDataDictionaryRefInt Namespace, Variables


nxsdDataDictionaryRefInt._ActionDescriptorList Variable

nxsdDataDictionaryRefInt._ActionDescriptorList Variable
nxsdDataDictionaryRefInt Variables Send Feedback
Syntax
Delphi
_ActionDescriptorList: TStringList;
File

nxsdDataDictionaryRefInt

Description

This is variable nxsdDataDictionaryRefInt._ActionDescriptorList.

Group

Variables

Links
nxsdDataDictionaryRefInt, Variables


nxsdDataDictionaryRefInt._ReferenceDescriptorList Variable

nxsdDataDictionaryRefInt._ReferenceDescriptorList Variable
nxsdDataDictionaryRefInt Variables Send Feedback
Syntax
Delphi
_ReferenceDescriptorList: TStringList;
File

nxsdDataDictionaryRefInt

Description

This is variable nxsdDataDictionaryRefInt._ReferenceDescriptorList.

Group

Variables

Links
nxsdDataDictionaryRefInt, Variables


nxsdDataDictionaryRefInt._SourceDescriptorList Variable

nxsdDataDictionaryRefInt._SourceDescriptorList Variable
nxsdDataDictionaryRefInt Variables Send Feedback
Syntax
Delphi
_SourceDescriptorList: TStringList;
File

nxsdDataDictionaryRefInt

Description

This is variable nxsdDataDictionaryRefInt._SourceDescriptorList.

Group

Variables

Links
nxsdDataDictionaryRefInt, Variables


nxsdDataDictionaryRefInt._TargetCursorDescriptorList Variable

nxsdDataDictionaryRefInt._TargetCursorDescriptorList Variable
nxsdDataDictionaryRefInt Variables Send Feedback
Syntax
Delphi
_TargetCursorDescriptorList: TStringList;
File

nxsdDataDictionaryRefInt

Description

This is variable nxsdDataDictionaryRefInt._TargetCursorDescriptorList.

Group

Variables

Links
nxsdDataDictionaryRefInt, Variables


nxsdDataDictionaryStrings Namespace

nxsdDataDictionaryStrings Namespace
Constants Topics Send Feedback

This is namespace nxsdDataDictionaryStrings.

Constants
Name | Description
csActionDescriptor | This is constant nxsdDataDictionaryStrings.csActionDescriptor.
csAuditLog | This is constant nxsdDataDictionaryStrings.csAuditLog.
csAutoInc | This is constant nxsdDataDictionaryStrings.csAutoInc.
csAutoIncDescriptor | This is constant nxsdDataDictionaryStrings.csAutoIncDescriptor.
csBDVD | This is constant nxsdDataDictionaryStrings.csBDVD.
csBKD | This is constant nxsdDataDictionaryStrings.csBKD.
csBlob | This is constant nxsdDataDictionaryStrings.csBlob.
csBlobDescriptor | This is constant nxsdDataDictionaryStrings.csBlobDescriptor.
csBlockHeapDescriptor | This is constant nxsdDataDictionaryStrings.csBlockHeapDescriptor.
csCurrentID | This is constant nxsdDataDictionaryStrings.csCurrentID.
csCustomDescriptor | This is constant nxsdDataDictionaryStrings.csCustomDescriptor.
csCustomDescsDescriptor | This is constant nxsdDataDictionaryStrings.csCustomDescsDescriptor.
csDefault | This is constant nxsdDataDictionaryStrings.csDefault.
csDefaultValueDescriptor | This is constant nxsdDataDictionaryStrings.csDefaultValueDescriptor.
csFieldDescriptor | This is constant nxsdDataDictionaryStrings.csFieldDescriptor.
csFieldsDescriptor | This is constant nxsdDataDictionaryStrings.csFieldsDescriptor.
csFileDescriptor | This is constant nxsdDataDictionaryStrings.csFileDescriptor.
csFilesDescriptor | This is constant nxsdDataDictionaryStrings.csFilesDescriptor.
csFulltext | This is constant nxsdDataDictionaryStrings.csFulltext.
csFulltextBlob | This is constant nxsdDataDictionaryStrings.csFulltextBlob.
csFulltextIndexDescriptor | This is constant nxsdDataDictionaryStrings.csFulltextIndexDescriptor.
csFulltextIndices | This is constant nxsdDataDictionaryStrings.csFulltextIndices.
csHeapDescriptor | This is constant nxsdDataDictionaryStrings.csHeapDescriptor.
csIndexDescriptor | This is constant nxsdDataDictionaryStrings.csIndexDescriptor.
csIndices | This is constant nxsdDataDictionaryStrings.csIndices.
csIndicesDescriptor | This is constant nxsdDataDictionaryStrings.csIndicesDescriptor.
csKeyDescriptor | This is constant nxsdDataDictionaryStrings.csKeyDescriptor.
csKeyFieldDescriptor | This is constant nxsdDataDictionaryStrings.csKeyFieldDescriptor.
csLocaleDescriptor | This is constant nxsdDataDictionaryStrings.csLocaleDescriptor.
csNexusDB | This is constant nxsdDataDictionaryStrings.csNexusDB.
csRecord | This is constant nxsdDataDictionaryStrings.csRecord.
csRecordCompressionDescriptor | This is constant nxsdDataDictionaryStrings.csRecordCompressionDescriptor.
csRecordDescriptor | This is constant nxsdDataDictionaryStrings.csRecordDescriptor.
csReferenceDescriptor | This is constant nxsdDataDictionaryStrings.csReferenceDescriptor.
csRefIntegrity | This is constant nxsdDataDictionaryStrings.csRefIntegrity.
csReverse | This is constant nxsdDataDictionaryStrings.csReverse.
csSeqAccessIndexName | This is constant nxsdDataDictionaryStrings.csSeqAccessIndexName.
csSourceDescriptor | This is constant nxsdDataDictionaryStrings.csSourceDescriptor.
csStream | This is constant nxsdDataDictionaryStrings.csStream.
csStreamDescriptor | This is constant nxsdDataDictionaryStrings.csStreamDescriptor.
csTableDescriptor | This is constant nxsdDataDictionaryStrings.csTableDescriptor.
csTablesDescriptor | This is constant nxsdDataDictionaryStrings.csTablesDescriptor.
csTargetCursorDescriptor | This is constant nxsdDataDictionaryStrings.csTargetCursorDescriptor.
csTokenExtractorDescriptor | This is constant nxsdDataDictionaryStrings.csTokenExtractorDescriptor.
csTokenFilterDescriptor | This is constant nxsdDataDictionaryStrings.csTokenFilterDescriptor.
csTokenIndexDescriptor | This is constant nxsdDataDictionaryStrings.csTokenIndexDescriptor.
csValidationDescriptor | This is constant nxsdDataDictionaryStrings.csValidationDescriptor.
csValidationsDescriptor | This is constant nxsdDataDictionaryStrings.csValidationsDescriptor.
rsARecordDescriptorIsRequired | This is constant nxsdDataDictionaryStrings.rsARecordDescriptorIsRequired.
rsAStreamDescriptorIsRequired | This is constant nxsdDataDictionaryStrings.rsAStreamDescriptorIsRequired.
rsATablenameIsRequired | This is constant nxsdDataDictionaryStrings.rsATablenameIsRequired.
rsBadExtension | This is constant nxsdDataDictionaryStrings.rsBadExtension.
rsBaseFileDuplicated | This is constant nxsdDataDictionaryStrings.rsBaseFileDuplicated.
rsBlobFileDuplicated | This is constant nxsdDataDictionaryStrings.rsBlobFileDuplicated.
rsCantRemoveBaseFile | This is constant nxsdDataDictionaryStrings.rsCantRemoveBaseFile.
rsClassNotSupported | This is constant nxsdDataDictionaryStrings.rsClassNotSupported.
rsCompKeyReqMinOneField | This is constant nxsdDataDictionaryStrings.rsCompKeyReqMinOneField.
rsDuplicatedCustomDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedCustomDescriptor.
rsDuplicatedExtension | This is constant nxsdDataDictionaryStrings.rsDuplicatedExtension.
rsDuplicatedFieldName | This is constant nxsdDataDictionaryStrings.rsDuplicatedFieldName.
rsDuplicatedIndexName | This is constant nxsdDataDictionaryStrings.rsDuplicatedIndexName.
rsDuplicatedTableDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedTableDescriptor.
rsDuplicatedTableName | This is constant nxsdDataDictionaryStrings.rsDuplicatedTableName.
rsDuplicatedValidationDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedValidationDescriptor.
rsFieldInUse | This is constant nxsdDataDictionaryStrings.rsFieldInUse.
rsFieldIsNotMarkedAsRequired | This is constant nxsdDataDictionaryStrings.rsFieldIsNotMarkedAsRequired.
rsFieldsDescriptorReqMinOneField | This is constant nxsdDataDictionaryStrings.rsFieldsDescriptorReqMinOneField.
rsFileInUseByAutoInc | This is constant nxsdDataDictionaryStrings.rsFileInUseByAutoInc.
rsFileInUseByBlob | This is constant nxsdDataDictionaryStrings.rsFileInUseByBlob.
rsFileInUseByIndex | This is constant nxsdDataDictionaryStrings.rsFileInUseByIndex.
rsFileInUseByRecord | This is constant nxsdDataDictionaryStrings.rsFileInUseByRecord.
rsFilesDescriptorReqMinOneFile | This is constant nxsdDataDictionaryStrings.rsFilesDescriptorReqMinOneFile.
rsFmtBcdNotSupportedInD5 | This is constant nxsdDataDictionaryStrings.rsFmtBcdNotSupportedInD5.
rsHigherDictVersionRequired | This is constant nxsdDataDictionaryStrings.rsHigherDictVersionRequired.
rsIndexInUse | This is constant nxsdDataDictionaryStrings.rsIndexInUse.
rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor | This is constant nxsdDataDictionaryStrings.rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor.
rsIndicesDescriptorReqMinOneIndex | This is constant nxsdDataDictionaryStrings.rsIndicesDescriptorReqMinOneIndex.
rsIntervalNotSupported | This is constant nxsdDataDictionaryStrings.rsIntervalNotSupported.
rsInvalidBlockSize | This is constant nxsdDataDictionaryStrings.rsInvalidBlockSize.
rsInvalidDefaultIndexNumber | This is constant nxsdDataDictionaryStrings.rsInvalidDefaultIndexNumber.
rsInvalidFieldNumber | This is constant nxsdDataDictionaryStrings.rsInvalidFieldNumber.
rsInvalidFileNumber | This is constant nxsdDataDictionaryStrings.rsInvalidFileNumber.
rsInvalidLocale | This is constant nxsdDataDictionaryStrings.rsInvalidLocale.
rsInvalidLocationIndex | This is constant nxsdDataDictionaryStrings.rsInvalidLocationIndex.
rsInvalidOverrideStorageCodepage | This is constant nxsdDataDictionaryStrings.rsInvalidOverrideStorageCodepage.
rsMainTableFileDesc | This is constant nxsdDataDictionaryStrings.rsMainTableFileDesc.
rsNoParentOfTypeCouldBeFound | This is constant nxsdDataDictionaryStrings.rsNoParentOfTypeCouldBeFound.
rsNoRelatedDescriptorOfTypeCouldBeFound | This is constant nxsdDataDictionaryStrings.rsNoRelatedDescriptorOfTypeCouldBeFound.
rsNotSupportedForFieldType | This is constant nxsdDataDictionaryStrings.rsNotSupportedForFieldType.
rsOutOfBounds | This is constant nxsdDataDictionaryStrings.rsOutOfBounds.
rsUnitsMustBeLargerThan0 | This is constant nxsdDataDictionaryStrings.rsUnitsMustBeLargerThan0.
Topics
Name | Description
Constants | The following table lists constants in this documentation.
Links
Constants, Topics


Constants

Constants
Constants nxsdDataDictionaryStrings Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csActionDescriptor | This is constant nxsdDataDictionaryStrings.csActionDescriptor.
csAuditLog | This is constant nxsdDataDictionaryStrings.csAuditLog.
csAutoInc | This is constant nxsdDataDictionaryStrings.csAutoInc.
csAutoIncDescriptor | This is constant nxsdDataDictionaryStrings.csAutoIncDescriptor.
csBDVD | This is constant nxsdDataDictionaryStrings.csBDVD.
csBKD | This is constant nxsdDataDictionaryStrings.csBKD.
csBlob | This is constant nxsdDataDictionaryStrings.csBlob.
csBlobDescriptor | This is constant nxsdDataDictionaryStrings.csBlobDescriptor.
csBlockHeapDescriptor | This is constant nxsdDataDictionaryStrings.csBlockHeapDescriptor.
csCurrentID | This is constant nxsdDataDictionaryStrings.csCurrentID.
csCustomDescriptor | This is constant nxsdDataDictionaryStrings.csCustomDescriptor.
csCustomDescsDescriptor | This is constant nxsdDataDictionaryStrings.csCustomDescsDescriptor.
csDefault | This is constant nxsdDataDictionaryStrings.csDefault.
csDefaultValueDescriptor | This is constant nxsdDataDictionaryStrings.csDefaultValueDescriptor.
csFieldDescriptor | This is constant nxsdDataDictionaryStrings.csFieldDescriptor.
csFieldsDescriptor | This is constant nxsdDataDictionaryStrings.csFieldsDescriptor.
csFileDescriptor | This is constant nxsdDataDictionaryStrings.csFileDescriptor.
csFilesDescriptor | This is constant nxsdDataDictionaryStrings.csFilesDescriptor.
csFulltext | This is constant nxsdDataDictionaryStrings.csFulltext.
csFulltextBlob | This is constant nxsdDataDictionaryStrings.csFulltextBlob.
csFulltextIndexDescriptor | This is constant nxsdDataDictionaryStrings.csFulltextIndexDescriptor.
csFulltextIndices | This is constant nxsdDataDictionaryStrings.csFulltextIndices.
csHeapDescriptor | This is constant nxsdDataDictionaryStrings.csHeapDescriptor.
csIndexDescriptor | This is constant nxsdDataDictionaryStrings.csIndexDescriptor.
csIndices | This is constant nxsdDataDictionaryStrings.csIndices.
csIndicesDescriptor | This is constant nxsdDataDictionaryStrings.csIndicesDescriptor.
csKeyDescriptor | This is constant nxsdDataDictionaryStrings.csKeyDescriptor.
csKeyFieldDescriptor | This is constant nxsdDataDictionaryStrings.csKeyFieldDescriptor.
csLocaleDescriptor | This is constant nxsdDataDictionaryStrings.csLocaleDescriptor.
csNexusDB | This is constant nxsdDataDictionaryStrings.csNexusDB.
csRecord | This is constant nxsdDataDictionaryStrings.csRecord.
csRecordCompressionDescriptor | This is constant nxsdDataDictionaryStrings.csRecordCompressionDescriptor.
csRecordDescriptor | This is constant nxsdDataDictionaryStrings.csRecordDescriptor.
csReferenceDescriptor | This is constant nxsdDataDictionaryStrings.csReferenceDescriptor.
csRefIntegrity | This is constant nxsdDataDictionaryStrings.csRefIntegrity.
csReverse | This is constant nxsdDataDictionaryStrings.csReverse.
csSeqAccessIndexName | This is constant nxsdDataDictionaryStrings.csSeqAccessIndexName.
csSourceDescriptor | This is constant nxsdDataDictionaryStrings.csSourceDescriptor.
csStream | This is constant nxsdDataDictionaryStrings.csStream.
csStreamDescriptor | This is constant nxsdDataDictionaryStrings.csStreamDescriptor.
csTableDescriptor | This is constant nxsdDataDictionaryStrings.csTableDescriptor.
csTablesDescriptor | This is constant nxsdDataDictionaryStrings.csTablesDescriptor.
csTargetCursorDescriptor | This is constant nxsdDataDictionaryStrings.csTargetCursorDescriptor.
csTokenExtractorDescriptor | This is constant nxsdDataDictionaryStrings.csTokenExtractorDescriptor.
csTokenFilterDescriptor | This is constant nxsdDataDictionaryStrings.csTokenFilterDescriptor.
csTokenIndexDescriptor | This is constant nxsdDataDictionaryStrings.csTokenIndexDescriptor.
csValidationDescriptor | This is constant nxsdDataDictionaryStrings.csValidationDescriptor.
csValidationsDescriptor | This is constant nxsdDataDictionaryStrings.csValidationsDescriptor.
rsARecordDescriptorIsRequired | This is constant nxsdDataDictionaryStrings.rsARecordDescriptorIsRequired.
rsAStreamDescriptorIsRequired | This is constant nxsdDataDictionaryStrings.rsAStreamDescriptorIsRequired.
rsATablenameIsRequired | This is constant nxsdDataDictionaryStrings.rsATablenameIsRequired.
rsBadExtension | This is constant nxsdDataDictionaryStrings.rsBadExtension.
rsBaseFileDuplicated | This is constant nxsdDataDictionaryStrings.rsBaseFileDuplicated.
rsBlobFileDuplicated | This is constant nxsdDataDictionaryStrings.rsBlobFileDuplicated.
rsCantRemoveBaseFile | This is constant nxsdDataDictionaryStrings.rsCantRemoveBaseFile.
rsClassNotSupported | This is constant nxsdDataDictionaryStrings.rsClassNotSupported.
rsCompKeyReqMinOneField | This is constant nxsdDataDictionaryStrings.rsCompKeyReqMinOneField.
rsDuplicatedCustomDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedCustomDescriptor.
rsDuplicatedExtension | This is constant nxsdDataDictionaryStrings.rsDuplicatedExtension.
rsDuplicatedFieldName | This is constant nxsdDataDictionaryStrings.rsDuplicatedFieldName.
rsDuplicatedIndexName | This is constant nxsdDataDictionaryStrings.rsDuplicatedIndexName.
rsDuplicatedTableDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedTableDescriptor.
rsDuplicatedTableName | This is constant nxsdDataDictionaryStrings.rsDuplicatedTableName.
rsDuplicatedValidationDescriptor | This is constant nxsdDataDictionaryStrings.rsDuplicatedValidationDescriptor.
rsFieldInUse | This is constant nxsdDataDictionaryStrings.rsFieldInUse.
rsFieldIsNotMarkedAsRequired | This is constant nxsdDataDictionaryStrings.rsFieldIsNotMarkedAsRequired.
rsFieldsDescriptorReqMinOneField | This is constant nxsdDataDictionaryStrings.rsFieldsDescriptorReqMinOneField.
rsFileInUseByAutoInc | This is constant nxsdDataDictionaryStrings.rsFileInUseByAutoInc.
rsFileInUseByBlob | This is constant nxsdDataDictionaryStrings.rsFileInUseByBlob.
rsFileInUseByIndex | This is constant nxsdDataDictionaryStrings.rsFileInUseByIndex.
rsFileInUseByRecord | This is constant nxsdDataDictionaryStrings.rsFileInUseByRecord.
rsFilesDescriptorReqMinOneFile | This is constant nxsdDataDictionaryStrings.rsFilesDescriptorReqMinOneFile.
rsFmtBcdNotSupportedInD5 | This is constant nxsdDataDictionaryStrings.rsFmtBcdNotSupportedInD5.
rsHigherDictVersionRequired | This is constant nxsdDataDictionaryStrings.rsHigherDictVersionRequired.
rsIndexInUse | This is constant nxsdDataDictionaryStrings.rsIndexInUse.
rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor | This is constant nxsdDataDictionaryStrings.rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor.
rsIndicesDescriptorReqMinOneIndex | This is constant nxsdDataDictionaryStrings.rsIndicesDescriptorReqMinOneIndex.
rsIntervalNotSupported | This is constant nxsdDataDictionaryStrings.rsIntervalNotSupported.
rsInvalidBlockSize | This is constant nxsdDataDictionaryStrings.rsInvalidBlockSize.
rsInvalidDefaultIndexNumber | This is constant nxsdDataDictionaryStrings.rsInvalidDefaultIndexNumber.
rsInvalidFieldNumber | This is constant nxsdDataDictionaryStrings.rsInvalidFieldNumber.
rsInvalidFileNumber | This is constant nxsdDataDictionaryStrings.rsInvalidFileNumber.
rsInvalidLocale | This is constant nxsdDataDictionaryStrings.rsInvalidLocale.
rsInvalidLocationIndex | This is constant nxsdDataDictionaryStrings.rsInvalidLocationIndex.
rsInvalidOverrideStorageCodepage | This is constant nxsdDataDictionaryStrings.rsInvalidOverrideStorageCodepage.
rsMainTableFileDesc | This is constant nxsdDataDictionaryStrings.rsMainTableFileDesc.
rsNoParentOfTypeCouldBeFound | This is constant nxsdDataDictionaryStrings.rsNoParentOfTypeCouldBeFound.
rsNoRelatedDescriptorOfTypeCouldBeFound | This is constant nxsdDataDictionaryStrings.rsNoRelatedDescriptorOfTypeCouldBeFound.
rsNotSupportedForFieldType | This is constant nxsdDataDictionaryStrings.rsNotSupportedForFieldType.
rsOutOfBounds | This is constant nxsdDataDictionaryStrings.rsOutOfBounds.
rsUnitsMustBeLargerThan0 | This is constant nxsdDataDictionaryStrings.rsUnitsMustBeLargerThan0.
Namespace

nxsdDataDictionaryStrings Namespace

Links
Constants, nxsdDataDictionaryStrings Namespace


nxsdDataDictionaryStrings.csActionDescriptor Constant

nxsdDataDictionaryStrings.csActionDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csActionDescriptor = 'ActionDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csActionDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csAuditLog Constant

nxsdDataDictionaryStrings.csAuditLog Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csAuditLog = 'AuditLog';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csAuditLog.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csAutoInc Constant

nxsdDataDictionaryStrings.csAutoInc Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csAutoInc = 'AutoInc';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csAutoInc.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csAutoIncDescriptor Constant

nxsdDataDictionaryStrings.csAutoIncDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csAutoIncDescriptor = 'AutoIncDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csAutoIncDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csBDVD Constant

nxsdDataDictionaryStrings.csBDVD Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csBDVD = 'BDVD';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csBDVD.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csBKD Constant

nxsdDataDictionaryStrings.csBKD Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csBKD = 'BKD';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csBKD.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csBlob Constant

nxsdDataDictionaryStrings.csBlob Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csBlob = 'Blob';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csBlob.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csBlobDescriptor Constant

nxsdDataDictionaryStrings.csBlobDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csBlobDescriptor = 'BlobDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csBlobDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csBlockHeapDescriptor Constant

nxsdDataDictionaryStrings.csBlockHeapDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csBlockHeapDescriptor = 'BlockHeapDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csBlockHeapDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csCurrentID Constant

nxsdDataDictionaryStrings.csCurrentID Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csCurrentID = 'CurrentID';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csCurrentID.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csCustomDescriptor Constant

nxsdDataDictionaryStrings.csCustomDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csCustomDescriptor = 'CustomDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csCustomDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csCustomDescsDescriptor Constant

nxsdDataDictionaryStrings.csCustomDescsDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csCustomDescsDescriptor = 'CustomDescsDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csCustomDescsDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csDefault Constant

nxsdDataDictionaryStrings.csDefault Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csDefault = 'Default';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csDefault.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csDefaultValueDescriptor Constant

nxsdDataDictionaryStrings.csDefaultValueDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csDefaultValueDescriptor = 'DefaultValueDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csDefaultValueDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFieldDescriptor Constant

nxsdDataDictionaryStrings.csFieldDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFieldDescriptor = 'FieldDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFieldDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFieldsDescriptor Constant

nxsdDataDictionaryStrings.csFieldsDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFieldsDescriptor = 'FieldsDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFieldsDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFileDescriptor Constant

nxsdDataDictionaryStrings.csFileDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFileDescriptor = 'FileDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFileDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFilesDescriptor Constant

nxsdDataDictionaryStrings.csFilesDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFilesDescriptor = 'FilesDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFilesDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFulltext Constant

nxsdDataDictionaryStrings.csFulltext Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFulltext = 'Fulltext';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFulltext.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFulltextBlob Constant

nxsdDataDictionaryStrings.csFulltextBlob Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFulltextBlob = 'Fulltext$Blob';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFulltextBlob.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFulltextIndexDescriptor Constant

nxsdDataDictionaryStrings.csFulltextIndexDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFulltextIndexDescriptor = 'FulltextIndexDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFulltextIndexDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csFulltextIndices Constant

nxsdDataDictionaryStrings.csFulltextIndices Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csFulltextIndices = 'Fulltext$Indices';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csFulltextIndices.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csHeapDescriptor Constant

nxsdDataDictionaryStrings.csHeapDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csHeapDescriptor = 'HeapDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csHeapDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csIndexDescriptor Constant

nxsdDataDictionaryStrings.csIndexDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csIndexDescriptor = 'IndexDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csIndexDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csIndices Constant

nxsdDataDictionaryStrings.csIndices Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csIndices = 'Indices';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csIndices.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csIndicesDescriptor Constant

nxsdDataDictionaryStrings.csIndicesDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csIndicesDescriptor = 'IndicesDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csIndicesDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csKeyDescriptor Constant

nxsdDataDictionaryStrings.csKeyDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csKeyDescriptor = 'KeyDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csKeyDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csKeyFieldDescriptor Constant

nxsdDataDictionaryStrings.csKeyFieldDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csKeyFieldDescriptor = 'KeyFieldDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csKeyFieldDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csLocaleDescriptor Constant

nxsdDataDictionaryStrings.csLocaleDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csLocaleDescriptor = 'LocaleDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csLocaleDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csNexusDB Constant

nxsdDataDictionaryStrings.csNexusDB Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csNexusDB = 'NexusDB';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csNexusDB.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csRecord Constant

nxsdDataDictionaryStrings.csRecord Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csRecord = 'Record';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csRecord.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csRecordCompressionDescriptor Constant

nxsdDataDictionaryStrings.csRecordCompressionDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csRecordCompressionDescriptor = 'RecordCompressionDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csRecordCompressionDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csRecordDescriptor Constant

nxsdDataDictionaryStrings.csRecordDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csRecordDescriptor = 'RecordDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csRecordDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csReferenceDescriptor Constant

nxsdDataDictionaryStrings.csReferenceDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csReferenceDescriptor = 'ReferenceDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csReferenceDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csRefIntegrity Constant

nxsdDataDictionaryStrings.csRefIntegrity Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csRefIntegrity = 'RefIntegrity';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csRefIntegrity.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csReverse Constant

nxsdDataDictionaryStrings.csReverse Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csReverse = 'Reverse';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csReverse.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csSeqAccessIndexName Constant

nxsdDataDictionaryStrings.csSeqAccessIndexName Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csSeqAccessIndexName = 'Sequential Access Index';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csSeqAccessIndexName.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csSourceDescriptor Constant

nxsdDataDictionaryStrings.csSourceDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csSourceDescriptor = 'SourceDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csSourceDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csStream Constant

nxsdDataDictionaryStrings.csStream Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csStream = 'Stream';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csStream.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csStreamDescriptor Constant

nxsdDataDictionaryStrings.csStreamDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csStreamDescriptor = 'StreamDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csStreamDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTableDescriptor Constant

nxsdDataDictionaryStrings.csTableDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTableDescriptor = 'TableDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTableDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTablesDescriptor Constant

nxsdDataDictionaryStrings.csTablesDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTablesDescriptor = 'TablesDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTablesDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTargetCursorDescriptor Constant

nxsdDataDictionaryStrings.csTargetCursorDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTargetCursorDescriptor = 'TargetCursorDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTargetCursorDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTokenExtractorDescriptor Constant

nxsdDataDictionaryStrings.csTokenExtractorDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTokenExtractorDescriptor = 'TokenExtractorDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTokenExtractorDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTokenFilterDescriptor Constant

nxsdDataDictionaryStrings.csTokenFilterDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTokenFilterDescriptor = 'TokenFilterDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTokenFilterDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csTokenIndexDescriptor Constant

nxsdDataDictionaryStrings.csTokenIndexDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csTokenIndexDescriptor = 'TokenIndexDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csTokenIndexDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csValidationDescriptor Constant

nxsdDataDictionaryStrings.csValidationDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csValidationDescriptor = 'ValidationDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csValidationDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.csValidationsDescriptor Constant

nxsdDataDictionaryStrings.csValidationsDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
csValidationsDescriptor = 'ValidationsDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.csValidationsDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsARecordDescriptorIsRequired Constant

nxsdDataDictionaryStrings.rsARecordDescriptorIsRequired Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsARecordDescriptorIsRequired = 'A record descriptor is required';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsARecordDescriptorIsRequired.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsAStreamDescriptorIsRequired Constant

nxsdDataDictionaryStrings.rsAStreamDescriptorIsRequired Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsAStreamDescriptorIsRequired = 'A stream descriptor is required';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsAStreamDescriptorIsRequired.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsATablenameIsRequired Constant

nxsdDataDictionaryStrings.rsATablenameIsRequired Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsATablenameIsRequired = 'A tablename is required';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsATablenameIsRequired.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsBadExtension Constant

nxsdDataDictionaryStrings.rsBadExtension Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsBadExtension = 'Invalid file extension: "%s"';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsBadExtension.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsBaseFileDuplicated Constant

nxsdDataDictionaryStrings.rsBaseFileDuplicated Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsBaseFileDuplicated = 'A data file has already been defined';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsBaseFileDuplicated.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsBlobFileDuplicated Constant

nxsdDataDictionaryStrings.rsBlobFileDuplicated Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsBlobFileDuplicated = 'A BLOB file has already been defined';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsBlobFileDuplicated.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsCantRemoveBaseFile Constant

nxsdDataDictionaryStrings.rsCantRemoveBaseFile Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsCantRemoveBaseFile = 'Cannot remove the base file descriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsCantRemoveBaseFile.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsClassNotSupported Constant

nxsdDataDictionaryStrings.rsClassNotSupported Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsClassNotSupported = '%s class is not supported: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsClassNotSupported.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsCompKeyReqMinOneField Constant

nxsdDataDictionaryStrings.rsCompKeyReqMinOneField Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsCompKeyReqMinOneField = 'Composite key requires a minimum of one field';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsCompKeyReqMinOneField.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedCustomDescriptor Constant

nxsdDataDictionaryStrings.rsDuplicatedCustomDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedCustomDescriptor = 'Duplicated custom descriptor name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedCustomDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedExtension Constant

nxsdDataDictionaryStrings.rsDuplicatedExtension Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedExtension = 'Duplicated file extension: "%s"';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedExtension.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedFieldName Constant

nxsdDataDictionaryStrings.rsDuplicatedFieldName Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedFieldName = 'Duplicated field name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedFieldName.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedIndexName Constant

nxsdDataDictionaryStrings.rsDuplicatedIndexName Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedIndexName = 'Duplicated index name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedIndexName.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedTableDescriptor Constant

nxsdDataDictionaryStrings.rsDuplicatedTableDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedTableDescriptor = 'Duplicated table descriptor name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedTableDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedTableName Constant

nxsdDataDictionaryStrings.rsDuplicatedTableName Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedTableName = 'Duplicated table name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedTableName.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsDuplicatedValidationDescriptor Constant

nxsdDataDictionaryStrings.rsDuplicatedValidationDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsDuplicatedValidationDescriptor = 'Duplicated validation descriptor name: %s';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsDuplicatedValidationDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFieldInUse Constant

nxsdDataDictionaryStrings.rsFieldInUse Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFieldInUse = 'Cannot remove field %s because it is still referenced by an index';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFieldInUse.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFieldIsNotMarkedAsRequired Constant

nxsdDataDictionaryStrings.rsFieldIsNotMarkedAsRequired Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFieldIsNotMarkedAsRequired = 'Field "%s" is not marked as required';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFieldIsNotMarkedAsRequired.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFieldsDescriptorReqMinOneField Constant

nxsdDataDictionaryStrings.rsFieldsDescriptorReqMinOneField Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFieldsDescriptorReqMinOneField = 'FieldsDescriptor requires a minimum of one field';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFieldsDescriptorReqMinOneField.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFileInUseByAutoInc Constant

nxsdDataDictionaryStrings.rsFileInUseByAutoInc Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFileInUseByAutoInc = 'Cannot remove file %d because it is still referenced by an autoinc engine';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFileInUseByAutoInc.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFileInUseByBlob Constant

nxsdDataDictionaryStrings.rsFileInUseByBlob Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFileInUseByBlob = 'Cannot remove file %d because it is still referenced by a blob engine';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFileInUseByBlob.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFileInUseByIndex Constant

nxsdDataDictionaryStrings.rsFileInUseByIndex Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFileInUseByIndex = 'Cannot remove file %d because it is still referenced by an index';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFileInUseByIndex.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFileInUseByRecord Constant

nxsdDataDictionaryStrings.rsFileInUseByRecord Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFileInUseByRecord = 'Cannot remove file %d because it is still referenced by a record engine';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFileInUseByRecord.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFilesDescriptorReqMinOneFile Constant

nxsdDataDictionaryStrings.rsFilesDescriptorReqMinOneFile Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFilesDescriptorReqMinOneFile = 'FilesDescriptor requires a minimum of one file';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFilesDescriptorReqMinOneFile.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsFmtBcdNotSupportedInD5 Constant

nxsdDataDictionaryStrings.rsFmtBcdNotSupportedInD5 Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsFmtBcdNotSupportedInD5 = 'FmtBcd is not supported in Delphi 5';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsFmtBcdNotSupportedInD5.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsHigherDictVersionRequired Constant

nxsdDataDictionaryStrings.rsHigherDictVersionRequired Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsHigherDictVersionRequired = 'Higher dictionary version required';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsHigherDictVersionRequired.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsIndexInUse Constant

nxsdDataDictionaryStrings.rsIndexInUse Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsIndexInUse = 'Cannot remove index %s because it is still referenced by a fulltext index';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsIndexInUse.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor Constant

nxsdDataDictionaryStrings.rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor = 'Index must use a TnxMainIndexTokenIndexKeyDescriptor';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsIndexMustUseATnxMainIndexTokenIndexKeyDescriptor.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsIndicesDescriptorReqMinOneIndex Constant

nxsdDataDictionaryStrings.rsIndicesDescriptorReqMinOneIndex Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsIndicesDescriptorReqMinOneIndex = 'IndicesDescriptor requires a minimum of one index';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsIndicesDescriptorReqMinOneIndex.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsIntervalNotSupported Constant

nxsdDataDictionaryStrings.rsIntervalNotSupported Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsIntervalNotSupported = 'Interval is not supported as a field type';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsIntervalNotSupported.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidBlockSize Constant

nxsdDataDictionaryStrings.rsInvalidBlockSize Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidBlockSize = '%d is not a valid BlockSize';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidBlockSize.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidDefaultIndexNumber Constant

nxsdDataDictionaryStrings.rsInvalidDefaultIndexNumber Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidDefaultIndexNumber = 'Invalid default index number: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidDefaultIndexNumber.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidFieldNumber Constant

nxsdDataDictionaryStrings.rsInvalidFieldNumber Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidFieldNumber = 'Invalid field number: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidFieldNumber.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidFileNumber Constant

nxsdDataDictionaryStrings.rsInvalidFileNumber Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidFileNumber = 'Invalid file number: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidFileNumber.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidLocale Constant

nxsdDataDictionaryStrings.rsInvalidLocale Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidLocale = 'Locale not supported/installed: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidLocale.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidLocationIndex Constant

nxsdDataDictionaryStrings.rsInvalidLocationIndex Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidLocationIndex = 'Invalid location index (%d)';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidLocationIndex.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsInvalidOverrideStorageCodepage Constant

nxsdDataDictionaryStrings.rsInvalidOverrideStorageCodepage Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsInvalidOverrideStorageCodepage = 'Invalid codepage: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsInvalidOverrideStorageCodepage.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsMainTableFileDesc Constant

nxsdDataDictionaryStrings.rsMainTableFileDesc Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsMainTableFileDesc = 'Data/DataDict File';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsMainTableFileDesc.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsNoParentOfTypeCouldBeFound Constant

nxsdDataDictionaryStrings.rsNoParentOfTypeCouldBeFound Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsNoParentOfTypeCouldBeFound = 'No Parent of type %s could be found';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsNoParentOfTypeCouldBeFound.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsNoRelatedDescriptorOfTypeCouldBeFound Constant

nxsdDataDictionaryStrings.rsNoRelatedDescriptorOfTypeCouldBeFound Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsNoRelatedDescriptorOfTypeCouldBeFound = 'No related Descriptor of type %s could be found';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsNoRelatedDescriptorOfTypeCouldBeFound.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsNotSupportedForFieldType Constant

nxsdDataDictionaryStrings.rsNotSupportedForFieldType Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsNotSupportedForFieldType = '"%s" is not supported for field type "%s"';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsNotSupportedForFieldType.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsOutOfBounds Constant

nxsdDataDictionaryStrings.rsOutOfBounds Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsOutOfBounds = 'Index out of bounds: %d';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsOutOfBounds.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDataDictionaryStrings.rsUnitsMustBeLargerThan0 Constant

nxsdDataDictionaryStrings.rsUnitsMustBeLargerThan0 Constant
nxsdDataDictionaryStrings Constants Send Feedback
Syntax
Delphi
rsUnitsMustBeLargerThan0 = 'Units must be > 0';
File

nxsdDataDictionaryStrings

Description

This is constant nxsdDataDictionaryStrings.rsUnitsMustBeLargerThan0.

Group

Constants

Links
nxsdDataDictionaryStrings, Constants


nxsdDateTimeParser Namespace

nxsdDateTimeParser Namespace
Constants Functions Legend Topics Send Feedback

This is namespace nxsdDateTimeParser.

Constants
Name | Description
rsInvalidDateFormat | This is constant nxsdDateTimeParser.rsInvalidDateFormat.
rsInvalidDateTimeFormat | This is constant nxsdDateTimeParser.rsInvalidDateTimeFormat.
rsInvalidTimeFormat | This is constant nxsdDateTimeParser.rsInvalidTimeFormat.
Functions
Name | Description
ConvertDate | This is function nxsdDateTimeParser.ConvertDate.
ConvertTime | This is function nxsdDateTimeParser.ConvertTime.
ConvertTimestamp | This is function nxsdDateTimeParser.ConvertTimestamp.
ExtractInt | This is function nxsdDateTimeParser.ExtractInt.
IsValidDate | This is function nxsdDateTimeParser.IsValidDate.
IsValidTime | This is function nxsdDateTimeParser.IsValidTime.
IsValidTimestamp | This is function nxsdDateTimeParser.IsValidTimestamp.
ParseDate | This is function nxsdDateTimeParser.ParseDate.
ParseTime | This is function nxsdDateTimeParser.ParseTime.
ParseTimestamp | This is function nxsdDateTimeParser.ParseTimestamp.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Constants, Functions, Legend, Topics


Functions

Functions
Functions nxsdDateTimeParser Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ConvertDate | This is function nxsdDateTimeParser.ConvertDate.
ConvertTime | This is function nxsdDateTimeParser.ConvertTime.
ConvertTimestamp | This is function nxsdDateTimeParser.ConvertTimestamp.
ExtractInt | This is function nxsdDateTimeParser.ExtractInt.
IsValidDate | This is function nxsdDateTimeParser.IsValidDate.
IsValidTime | This is function nxsdDateTimeParser.IsValidTime.
IsValidTimestamp | This is function nxsdDateTimeParser.IsValidTimestamp.
ParseDate | This is function nxsdDateTimeParser.ParseDate.
ParseTime | This is function nxsdDateTimeParser.ParseTime.
ParseTimestamp | This is function nxsdDateTimeParser.ParseTimestamp.
Namespace

nxsdDateTimeParser Namespace

Links
Functions, nxsdDateTimeParser Namespace, Legend


nxsdDateTimeParser.ConvertDate Function

nxsdDateTimeParser.ConvertDate Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ConvertDate(const V: OleVariant): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ConvertDate.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ConvertTime Function

nxsdDateTimeParser.ConvertTime Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ConvertTime(const V: OleVariant): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ConvertTime.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ConvertTimestamp Function

nxsdDateTimeParser.ConvertTimestamp Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ConvertTimestamp(const V: OleVariant): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ConvertTimestamp.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ExtractInt Function

nxsdDateTimeParser.ExtractInt Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ExtractInt(const S: string; Start: Integer; Length: Integer): Integer;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ExtractInt.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.IsValidDate Function

nxsdDateTimeParser.IsValidDate Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function IsValidDate(const S: string): Boolean;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.IsValidDate.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.IsValidTime Function

nxsdDateTimeParser.IsValidTime Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function IsValidTime(const S: string): Boolean;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.IsValidTime.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.IsValidTimestamp Function

nxsdDateTimeParser.IsValidTimestamp Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function IsValidTimestamp(const S: string): Boolean;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.IsValidTimestamp.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ParseDate Function

nxsdDateTimeParser.ParseDate Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ParseDate(const S: string): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ParseDate.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ParseTime Function

nxsdDateTimeParser.ParseTime Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ParseTime(const S: string): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ParseTime.

Group

Functions

Links
nxsdDateTimeParser, Functions


nxsdDateTimeParser.ParseTimestamp Function

nxsdDateTimeParser.ParseTimestamp Function
nxsdDateTimeParser Functions Send Feedback
Syntax
Delphi
function ParseTimestamp(const S: string): TDateTime;
File

nxsdDateTimeParser

Description

This is function nxsdDateTimeParser.ParseTimestamp.

Group

Functions

Links
nxsdDateTimeParser, Functions


Constants

Constants
Constants nxsdDateTimeParser Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsInvalidDateFormat | This is constant nxsdDateTimeParser.rsInvalidDateFormat.
rsInvalidDateTimeFormat | This is constant nxsdDateTimeParser.rsInvalidDateTimeFormat.
rsInvalidTimeFormat | This is constant nxsdDateTimeParser.rsInvalidTimeFormat.
Namespace

nxsdDateTimeParser Namespace

Links
Constants, nxsdDateTimeParser Namespace


nxsdDateTimeParser.rsInvalidDateFormat Constant

nxsdDateTimeParser.rsInvalidDateFormat Constant
nxsdDateTimeParser Constants Send Feedback
Syntax
Delphi
rsInvalidDateFormat = 'Invalid date format %s';
File

nxsdDateTimeParser

Description

This is constant nxsdDateTimeParser.rsInvalidDateFormat.

Group

Constants

Links
nxsdDateTimeParser, Constants


nxsdDateTimeParser.rsInvalidDateTimeFormat Constant

nxsdDateTimeParser.rsInvalidDateTimeFormat Constant
nxsdDateTimeParser Constants Send Feedback
Syntax
Delphi
rsInvalidDateTimeFormat = 'Invalid date/time format %s';
File

nxsdDateTimeParser

Description

This is constant nxsdDateTimeParser.rsInvalidDateTimeFormat.

Group

Constants

Links
nxsdDateTimeParser, Constants


nxsdDateTimeParser.rsInvalidTimeFormat Constant

nxsdDateTimeParser.rsInvalidTimeFormat Constant
nxsdDateTimeParser Constants Send Feedback
Syntax
Delphi
rsInvalidTimeFormat = 'Invalid time format %s';
File

nxsdDateTimeParser

Description

This is constant nxsdDateTimeParser.rsInvalidTimeFormat.

Group

Constants

Links
nxsdDateTimeParser, Constants


nxsdDefaultValueEngine Namespace

nxsdDefaultValueEngine Namespace
Classes Constants Legend Topics Types Variables Send Feedback

RI Engines.

Classes
Name | Description
EnxAutoGuidDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxAutoGuidDefaultValueEngineException.
EnxBaseDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxBaseDefaultValueEngineException.
EnxConstDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxConstDefaultValueEngineException.
EnxCurrentDateTimeDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCurrentDateTimeDefaultValueEngineException.
EnxCurrentUserDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCurrentUserDefaultValueEngineException.
EnxCursorDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCursorDefaultValueEngineException.
EnxEmptyDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxEmptyDefaultValueEngineException.
TnxAutoGuidDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxAutoGuidDefaultValueEngine.
TnxBaseDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxBaseDefaultValueEngine.
TnxConstDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxConstDefaultValueEngine.
TnxCurrentDateTimeDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxCurrentDateTimeDefaultValueEngine.
TnxCurrentUserDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxCurrentUserDefaultValueEngine.
TnxCursorDefaultValueEngine | No need for this with Delphi10, it translates correctly the class. econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddefaultvalueengine' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxBaseDefaultValueEngine;' $HPPEMIT '} /* namespace Nxsddefaultvalueengine */'
TnxDefaultValueHandler | This is class nxsdDefaultValueEngine.TnxDefaultValueHandler.
TnxEmptyDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxEmptyDefaultValueEngine.
Constants
Name | Description
csDefaultValue | This is constant nxsdDefaultValueEngine.csDefaultValue.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBaseDefaultValueEngineClass | This is type nxsdDefaultValueEngine.TnxBaseDefaultValueEngineClass.
Variables
Name | Description
_BaseDefaultValueEngineList | This is variable nxsdDefaultValueEngine._BaseDefaultValueEngineList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdDefaultValueEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxAutoGuidDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxAutoGuidDefaultValueEngineException.
EnxBaseDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxBaseDefaultValueEngineException.
EnxConstDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxConstDefaultValueEngineException.
EnxCurrentDateTimeDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCurrentDateTimeDefaultValueEngineException.
EnxCurrentUserDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCurrentUserDefaultValueEngineException.
EnxCursorDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxCursorDefaultValueEngineException.
EnxEmptyDefaultValueEngineException | This is class nxsdDefaultValueEngine.EnxEmptyDefaultValueEngineException.
TnxAutoGuidDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxAutoGuidDefaultValueEngine.
TnxBaseDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxBaseDefaultValueEngine.
TnxConstDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxConstDefaultValueEngine.
TnxCurrentDateTimeDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxCurrentDateTimeDefaultValueEngine.
TnxCurrentUserDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxCurrentUserDefaultValueEngine.
TnxCursorDefaultValueEngine | No need for this with Delphi10, it translates correctly the class. econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddefaultvalueengine' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxBaseDefaultValueEngine;' $HPPEMIT '} /* namespace Nxsddefaultvalueengine */'
TnxDefaultValueHandler | This is class nxsdDefaultValueEngine.TnxDefaultValueHandler.
TnxEmptyDefaultValueEngine | This is class nxsdDefaultValueEngine.TnxEmptyDefaultValueEngine.
Namespace

nxsdDefaultValueEngine Namespace

Links
Classes, nxsdDefaultValueEngine Namespace, Legend


EnxAutoGuidDefaultValueEngineException Class

EnxAutoGuidDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxAutoGuidDefaultValueEngineException
Syntax
Delphi
EnxAutoGuidDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxAutoGuidDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxBaseDefaultValueEngineException Class

EnxBaseDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxBaseDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxBaseDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxBaseDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxBaseDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxBaseDefaultValueEngineException
Syntax
Delphi
EnxBaseDefaultValueEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxBaseDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxConstDefaultValueEngineException Class

EnxConstDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxConstDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxConstDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxConstDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxConstDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxConstDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxConstDefaultValueEngineException
Syntax
Delphi
EnxConstDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxConstDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxCurrentDateTimeDefaultValueEngineException Class

EnxCurrentDateTimeDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentDateTimeDefaultValueEngineException
Syntax
Delphi
EnxCurrentDateTimeDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxCurrentDateTimeDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxCurrentUserDefaultValueEngineException Class

EnxCurrentUserDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCurrentUserDefaultValueEngineException
Syntax
Delphi
EnxCurrentUserDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxCurrentUserDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxCursorDefaultValueEngineException Class

EnxCursorDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxCursorDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCursorDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCursorDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCursorDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCursorDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxCursorDefaultValueEngineException
Syntax
Delphi
EnxCursorDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxCursorDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


EnxEmptyDefaultValueEngineException Class

EnxEmptyDefaultValueEngineException Class
nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_EnxEmptyDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxEmptyDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxEmptyDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxEmptyDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxEmptyDefaultValueEngineExceptionnxsdDefaultValueEngine_EnxEmptyDefaultValueEngineException
Syntax
Delphi
EnxEmptyDefaultValueEngineException = class(EnxBaseDefaultValueEngineException);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.EnxEmptyDefaultValueEngineException.

Group

Classes

Links
nxsdDefaultValueEngine, Classes


TnxAutoGuidDefaultValueEngine Class

TnxAutoGuidDefaultValueEngine Class
TnxAutoGuidDefaultValueEngine Methods TnxAutoGuidDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxAutoGuidDefaultValueEnginenxsdDefaultValueEngine_TnxAutoGuidDefaultValueEnginenxsdDefaultValueEngine_TnxAutoGuidDefaultValueEnginenxsdDefaultValueEngine_TnxAutoGuidDefaultValueEnginenxsdDefaultValueEngine_TnxAutoGuidDefaultValueEngine
Syntax
Delphi
TnxAutoGuidDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxAutoGuidDefaultValueEngine.

Group

Classes

Links
TnxAutoGuidDefaultValueEngine Methods, TnxAutoGuidDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxAutoGuidDefaultValueEngine Members

TnxAutoGuidDefaultValueEngine Members
TnxAutoGuidDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAutoGuidDefaultValueEngine.

Class

TnxAutoGuidDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | TnxAutoGuidDefaultValueEngine
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxAutoGuidDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAutoGuidDefaultValueEngine Methods

TnxAutoGuidDefaultValueEngine Methods
TnxAutoGuidDefaultValueEngine Class Legend Public Methods Send Feedback

The methods of the TnxAutoGuidDefaultValueEngine class are listed here.

Class

TnxAutoGuidDefaultValueEngine Class

Public Methods
Name | Description
SetDefaultValue | TnxAutoGuidDefaultValueEngine
Links
TnxAutoGuidDefaultValueEngine Class, Legend, Public Methods


TnxAutoGuidDefaultValueEngine.SetDefaultValue Method

TnxAutoGuidDefaultValueEngine.SetDefaultValue Method
TnxAutoGuidDefaultValueEngine Class TnxAutoGuidDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxAutoGuidDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; override;
Description

TnxAutoGuidDefaultValueEngine

Group

TnxAutoGuidDefaultValueEngine Methods

Links
TnxAutoGuidDefaultValueEngine Class, TnxAutoGuidDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxAutoGuidDefaultValueEngine Methods


TnxBaseDefaultValueEngine Class

TnxBaseDefaultValueEngine Class
TnxBaseDefaultValueEngine Fields TnxBaseDefaultValueEngine Methods TnxBaseDefaultValueEngine Properties TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxBaseDefaultValueEnginenxsdDefaultValueEngine_TnxBaseDefaultValueEnginenxsdDefaultValueEngine_TnxBaseDefaultValueEnginenxsdDefaultValueEngine_TnxBaseDefaultValueEngine
Syntax
Delphi
TnxBaseDefaultValueEngine = class(TnxBaseRegisterableEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxBaseDefaultValueEngine.

Group

Classes

Links
TnxBaseDefaultValueEngine Fields, TnxBaseDefaultValueEngine Methods, TnxBaseDefaultValueEngine Properties, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxBaseDefaultValueEngine Members

TnxBaseDefaultValueEngine Members
TnxBaseDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseDefaultValueEngine.

Class

TnxBaseDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | This is SetDefaultValue, a member of class TnxBaseDefaultValueEngine.
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxBaseDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseDefaultValueEngine.Create Constructor

TnxBaseDefaultValueEngine.Create Constructor
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseDefaultValueDescriptor; aCursor: TnxAbstractCursor); virtual;
Class

TnxBaseDefaultValueEngine Class

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Class


TnxBaseDefaultValueEngine Fields

TnxBaseDefaultValueEngine Fields
TnxBaseDefaultValueEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseDefaultValueEngine class are listed here.

Class

TnxBaseDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxBaseDefaultValueEngine Class, Legend, Protected Fields


TnxBaseDefaultValueEngine.bdceDescriptor Field

TnxBaseDefaultValueEngine.bdceDescriptor Field
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Fields Send Feedback
Syntax
Delphi
bdceDescriptor: TnxBaseDefaultValueDescriptor;
Description

private

Group

TnxBaseDefaultValueEngine Fields

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Fields


TnxBaseDefaultValueEngine.bdceFieldDescriptor Field

TnxBaseDefaultValueEngine.bdceFieldDescriptor Field
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Fields Send Feedback
Syntax
Delphi
bdceFieldDescriptor: TnxFieldDescriptor;
Description

This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.

Group

TnxBaseDefaultValueEngine Fields

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Fields


TnxBaseDefaultValueEngine Methods

TnxBaseDefaultValueEngine Methods
TnxBaseDefaultValueEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseDefaultValueEngine class are listed here.

Class

TnxBaseDefaultValueEngine Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
CreateFor |
SetDefaultValue | This is SetDefaultValue, a member of class TnxBaseDefaultValueEngine.
Links
TnxBaseDefaultValueEngine Class, Legend, Protected Methods, Public Methods


TnxBaseDefaultValueEngine.CreateFor Method

TnxBaseDefaultValueEngine.CreateFor Method
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aDescriptor: TnxBaseDefaultValueDescriptor; aCursor: TnxAbstractCursor): TnxBaseDefaultValueEngine;
Group

TnxBaseDefaultValueEngine Methods

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Methods


TnxBaseDefaultValueEngine.GetList Method

TnxBaseDefaultValueEngine.GetList Method
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseDefaultValueEngine Methods

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Methods


TnxBaseDefaultValueEngine.SetDefaultValue Method

TnxBaseDefaultValueEngine.SetDefaultValue Method
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; virtual; abstract;
Description

This is SetDefaultValue, a member of class TnxBaseDefaultValueEngine.

Group

TnxBaseDefaultValueEngine Methods

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Methods


TnxBaseDefaultValueEngine Properties

TnxBaseDefaultValueEngine Properties
TnxBaseDefaultValueEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseDefaultValueEngine class are listed here.

Class

TnxBaseDefaultValueEngine Class

Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxBaseDefaultValueEngine Class, Legend, Public Properties


TnxBaseDefaultValueEngine.Descriptor Property

TnxBaseDefaultValueEngine.Descriptor Property
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Properties Send Feedback
Syntax
Delphi
property Descriptor: TnxBaseDefaultValueDescriptor;
Description

This is Descriptor, a member of class TnxBaseDefaultValueEngine.

Group

TnxBaseDefaultValueEngine Properties

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Properties


TnxBaseDefaultValueEngine.FieldDescriptor Property

TnxBaseDefaultValueEngine.FieldDescriptor Property
TnxBaseDefaultValueEngine Class TnxBaseDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxBaseDefaultValueEngine Properties Send Feedback
Syntax
Delphi
property FieldDescriptor: TnxFieldDescriptor;
Description

This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.

Group

TnxBaseDefaultValueEngine Properties

Links
TnxBaseDefaultValueEngine Class, TnxBaseDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxBaseDefaultValueEngine Properties


TnxConstDefaultValueEngine Class

TnxConstDefaultValueEngine Class
TnxConstDefaultValueEngine Methods TnxConstDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxConstDefaultValueEnginenxsdDefaultValueEngine_TnxConstDefaultValueEnginenxsdDefaultValueEngine_TnxConstDefaultValueEnginenxsdDefaultValueEngine_TnxConstDefaultValueEnginenxsdDefaultValueEngine_TnxConstDefaultValueEngine
Syntax
Delphi
TnxConstDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxConstDefaultValueEngine.

Group

Classes

Links
TnxConstDefaultValueEngine Methods, TnxConstDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxConstDefaultValueEngine Members

TnxConstDefaultValueEngine Members
TnxConstDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxConstDefaultValueEngine.

Class

TnxConstDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | TnxConstDefaultValueEngine
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxConstDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxConstDefaultValueEngine Methods

TnxConstDefaultValueEngine Methods
TnxConstDefaultValueEngine Class Legend Public Methods Send Feedback

The methods of the TnxConstDefaultValueEngine class are listed here.

Class

TnxConstDefaultValueEngine Class

Public Methods
Name | Description
SetDefaultValue | TnxConstDefaultValueEngine
Links
TnxConstDefaultValueEngine Class, Legend, Public Methods


TnxConstDefaultValueEngine.SetDefaultValue Method

TnxConstDefaultValueEngine.SetDefaultValue Method
TnxConstDefaultValueEngine Class TnxConstDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxConstDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; override;
Description

TnxConstDefaultValueEngine

Group

TnxConstDefaultValueEngine Methods

Links
TnxConstDefaultValueEngine Class, TnxConstDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxConstDefaultValueEngine Methods


TnxCurrentDateTimeDefaultValueEngine Class

TnxCurrentDateTimeDefaultValueEngine Class
TnxCurrentDateTimeDefaultValueEngine Methods TnxCurrentDateTimeDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxCurrentDateTimeDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentDateTimeDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentDateTimeDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentDateTimeDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentDateTimeDefaultValueEngine
Syntax
Delphi
TnxCurrentDateTimeDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxCurrentDateTimeDefaultValueEngine.

Group

Classes

Links
TnxCurrentDateTimeDefaultValueEngine Methods, TnxCurrentDateTimeDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxCurrentDateTimeDefaultValueEngine Members

TnxCurrentDateTimeDefaultValueEngine Members
TnxCurrentDateTimeDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCurrentDateTimeDefaultValueEngine.

Class

TnxCurrentDateTimeDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | TnxCurrentDateTimeDefaultValueEngine
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxCurrentDateTimeDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCurrentDateTimeDefaultValueEngine Methods

TnxCurrentDateTimeDefaultValueEngine Methods
TnxCurrentDateTimeDefaultValueEngine Class Legend Public Methods Send Feedback

The methods of the TnxCurrentDateTimeDefaultValueEngine class are listed here.

Class

TnxCurrentDateTimeDefaultValueEngine Class

Public Methods
Name | Description
SetDefaultValue | TnxCurrentDateTimeDefaultValueEngine
Links
TnxCurrentDateTimeDefaultValueEngine Class, Legend, Public Methods


TnxCurrentDateTimeDefaultValueEngine.SetDefaultValue Method

TnxCurrentDateTimeDefaultValueEngine.SetDefaultValue Method
TnxCurrentDateTimeDefaultValueEngine Class TnxCurrentDateTimeDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCurrentDateTimeDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; override;
Description

TnxCurrentDateTimeDefaultValueEngine

Group

TnxCurrentDateTimeDefaultValueEngine Methods

Links
TnxCurrentDateTimeDefaultValueEngine Class, TnxCurrentDateTimeDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCurrentDateTimeDefaultValueEngine Methods


TnxCurrentUserDefaultValueEngine Class

TnxCurrentUserDefaultValueEngine Class
TnxCurrentUserDefaultValueEngine Fields TnxCurrentUserDefaultValueEngine Methods TnxCurrentUserDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxCurrentUserDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentUserDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentUserDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentUserDefaultValueEnginenxsdDefaultValueEngine_TnxCurrentUserDefaultValueEngine
Syntax
Delphi
TnxCurrentUserDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxCurrentUserDefaultValueEngine.

Group

Classes

Links
TnxCurrentUserDefaultValueEngine Fields, TnxCurrentUserDefaultValueEngine Methods, TnxCurrentUserDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxCurrentUserDefaultValueEngine Members

TnxCurrentUserDefaultValueEngine Members
TnxCurrentUserDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCurrentUserDefaultValueEngine.

Class

TnxCurrentUserDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
cudveUserName | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxCurrentUserDefaultValueEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue |
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxCurrentUserDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCurrentUserDefaultValueEngine.Create Constructor

TnxCurrentUserDefaultValueEngine.Create Constructor
TnxCurrentUserDefaultValueEngine Class TnxCurrentUserDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCurrentUserDefaultValueEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseDefaultValueDescriptor; aCursor: TnxAbstractCursor); override;
Description

TnxCurrentUserDefaultValueEngine

Class

TnxCurrentUserDefaultValueEngine Class

Links
TnxCurrentUserDefaultValueEngine Class, TnxCurrentUserDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCurrentUserDefaultValueEngine Class


TnxCurrentUserDefaultValueEngine Fields

TnxCurrentUserDefaultValueEngine Fields
TnxCurrentUserDefaultValueEngine Class Legend Protected Fields Send Feedback

The fields of the TnxCurrentUserDefaultValueEngine class are listed here.

Class

TnxCurrentUserDefaultValueEngine Class

Protected Fields
Name | Description
cudveUserName | private
Links
TnxCurrentUserDefaultValueEngine Class, Legend, Protected Fields


TnxCurrentUserDefaultValueEngine.cudveUserName Field

TnxCurrentUserDefaultValueEngine.cudveUserName Field
TnxCurrentUserDefaultValueEngine Class TnxCurrentUserDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCurrentUserDefaultValueEngine Fields Send Feedback
Syntax
Delphi
cudveUserName: TnxDynByteArray;
Description

private

Group

TnxCurrentUserDefaultValueEngine Fields

Links
TnxCurrentUserDefaultValueEngine Class, TnxCurrentUserDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCurrentUserDefaultValueEngine Fields


TnxCurrentUserDefaultValueEngine Methods

TnxCurrentUserDefaultValueEngine Methods
TnxCurrentUserDefaultValueEngine Class Legend Public Methods Send Feedback

The methods of the TnxCurrentUserDefaultValueEngine class are listed here.

Class

TnxCurrentUserDefaultValueEngine Class

Public Methods
Name | Description
SetDefaultValue |
Links
TnxCurrentUserDefaultValueEngine Class, Legend, Public Methods


TnxCurrentUserDefaultValueEngine.SetDefaultValue Method

TnxCurrentUserDefaultValueEngine.SetDefaultValue Method
TnxCurrentUserDefaultValueEngine Class TnxCurrentUserDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCurrentUserDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; override;
Group

TnxCurrentUserDefaultValueEngine Methods

Links
TnxCurrentUserDefaultValueEngine Class, TnxCurrentUserDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCurrentUserDefaultValueEngine Methods


TnxCursorDefaultValueEngine Class

TnxCursorDefaultValueEngine Class
TnxCursorDefaultValueEngine Fields TnxCursorDefaultValueEngine Properties TnxCursorDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxCursorDefaultValueEnginenxsdDefaultValueEngine_TnxCursorDefaultValueEnginenxsdDefaultValueEngine_TnxCursorDefaultValueEnginenxsdDefaultValueEngine_TnxCursorDefaultValueEnginenxsdDefaultValueEngine_TnxCursorDefaultValueEngine
Syntax
Delphi
TnxCursorDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

No need for this with Delphi10, it translates correctly the class. econs4 BCB support - 10-Feb-2005 $HPPEMIT 'namespace Nxsddefaultvalueengine' $HPPEMIT '{' $HPPEMIT 'class DELPHICLASS TnxBaseDefaultValueEngine;' $HPPEMIT '} /* namespace Nxsddefaultvalueengine */'

Group

Classes

Links
TnxCursorDefaultValueEngine Fields, TnxCursorDefaultValueEngine Properties, TnxCursorDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxCursorDefaultValueEngine Members

TnxCursorDefaultValueEngine Members
TnxCursorDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCursorDefaultValueEngine.

Class

TnxCursorDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
cdceCursor | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxCursorDefaultValueEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | This is SetDefaultValue, a member of class TnxBaseDefaultValueEngine.
Public Properties
Name | Description
Cursor | This is Cursor, a member of class TnxCursorDefaultValueEngine.
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxCursorDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCursorDefaultValueEngine.Create Constructor

TnxCursorDefaultValueEngine.Create Constructor
TnxCursorDefaultValueEngine Class TnxCursorDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCursorDefaultValueEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseDefaultValueDescriptor; aCursor: TnxAbstractCursor); override;
Description

TnxCursorDefaultValueEngine

Class

TnxCursorDefaultValueEngine Class

Links
TnxCursorDefaultValueEngine Class, TnxCursorDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCursorDefaultValueEngine Class


TnxCursorDefaultValueEngine Fields

TnxCursorDefaultValueEngine Fields
TnxCursorDefaultValueEngine Class Legend Protected Fields Send Feedback

The fields of the TnxCursorDefaultValueEngine class are listed here.

Class

TnxCursorDefaultValueEngine Class

Protected Fields
Name | Description
cdceCursor | private
Links
TnxCursorDefaultValueEngine Class, Legend, Protected Fields


TnxCursorDefaultValueEngine.cdceCursor Field

TnxCursorDefaultValueEngine.cdceCursor Field
TnxCursorDefaultValueEngine Class TnxCursorDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCursorDefaultValueEngine Fields Send Feedback
Syntax
Delphi
cdceCursor: TnxAbstractCursor;
Description

private

Group

TnxCursorDefaultValueEngine Fields

Links
TnxCursorDefaultValueEngine Class, TnxCursorDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCursorDefaultValueEngine Fields


TnxCursorDefaultValueEngine Properties

TnxCursorDefaultValueEngine Properties
TnxCursorDefaultValueEngine Class Legend Public Properties Send Feedback

The properties of the TnxCursorDefaultValueEngine class are listed here.

Class

TnxCursorDefaultValueEngine Class

Public Properties
Name | Description
Cursor | This is Cursor, a member of class TnxCursorDefaultValueEngine.
Links
TnxCursorDefaultValueEngine Class, Legend, Public Properties


TnxCursorDefaultValueEngine.Cursor Property

TnxCursorDefaultValueEngine.Cursor Property
TnxCursorDefaultValueEngine Class TnxCursorDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxCursorDefaultValueEngine Properties Send Feedback
Syntax
Delphi
property Cursor: TnxAbstractCursor;
Description

This is Cursor, a member of class TnxCursorDefaultValueEngine.

Group

TnxCursorDefaultValueEngine Properties

Links
TnxCursorDefaultValueEngine Class, TnxCursorDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxCursorDefaultValueEngine Properties


TnxDefaultValueHandler Class

TnxDefaultValueHandler Class
TnxDefaultValueHandler Fields TnxDefaultValueHandler Methods TnxDefaultValueHandler Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxDefaultValueHandlernxsdDefaultValueEngine_TnxDefaultValueHandler
Syntax
Delphi
TnxDefaultValueHandler = class(TnxObject);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxDefaultValueHandler.

Group

Classes

Links
TnxDefaultValueHandler Fields, TnxDefaultValueHandler Methods, TnxDefaultValueHandler Members, nxsdDefaultValueEngine, Classes


TnxDefaultValueHandler Members

TnxDefaultValueHandler Members
TnxDefaultValueHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDefaultValueHandler.

Class

TnxDefaultValueHandler Class

Protected Fields
Name | Description
dvhEngines | This is dvhEngines, a member of class TnxDefaultValueHandler.
dvhEnginesByIndex | This is dvhEnginesByIndex, a member of class TnxDefaultValueHandler.
dvhEnginesInsert | This is dvhEnginesInsert, a member of class TnxDefaultValueHandler.
dvhEnginesModify | This is dvhEnginesModify, a member of class TnxDefaultValueHandler.
dvhFieldsDescriptor | This is dvhFieldsDescriptor, a member of class TnxDefaultValueHandler.
Protected Methods
Name | Description
Create |
Public Methods
Name | Description
CreateFor |
Destroy |
FreeInstance |
NewInstance | TnxObject
SetDefaultValue |
SetDefaultValuesInsert |
SetDefaultValuesModify |
Links
TnxDefaultValueHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDefaultValueHandler.Create Constructor

TnxDefaultValueHandler.Create Constructor
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsDescriptor: TnxFieldsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor);
Class

TnxDefaultValueHandler Class

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Class


TnxDefaultValueHandler.Destroy Destructor

TnxDefaultValueHandler.Destroy Destructor
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxDefaultValueHandler Class

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Class


TnxDefaultValueHandler Fields

TnxDefaultValueHandler Fields
TnxDefaultValueHandler Class Legend Protected Fields Send Feedback

The fields of the TnxDefaultValueHandler class are listed here.

Class

TnxDefaultValueHandler Class

Protected Fields
Name | Description
dvhEngines | This is dvhEngines, a member of class TnxDefaultValueHandler.
dvhEnginesByIndex | This is dvhEnginesByIndex, a member of class TnxDefaultValueHandler.
dvhEnginesInsert | This is dvhEnginesInsert, a member of class TnxDefaultValueHandler.
dvhEnginesModify | This is dvhEnginesModify, a member of class TnxDefaultValueHandler.
dvhFieldsDescriptor | This is dvhFieldsDescriptor, a member of class TnxDefaultValueHandler.
Links
TnxDefaultValueHandler Class, Legend, Protected Fields


TnxDefaultValueHandler.dvhEngines Field

TnxDefaultValueHandler.dvhEngines Field
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Fields Send Feedback
Syntax
Delphi
dvhEngines: TObjectList;
Description

This is dvhEngines, a member of class TnxDefaultValueHandler.

Group

TnxDefaultValueHandler Fields

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Fields


TnxDefaultValueHandler.dvhEnginesByIndex Field

TnxDefaultValueHandler.dvhEnginesByIndex Field
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Fields Send Feedback
Syntax
Delphi
dvhEnginesByIndex: array of TnxBaseDefaultValueEngine;
Description

This is dvhEnginesByIndex, a member of class TnxDefaultValueHandler.

Group

TnxDefaultValueHandler Fields

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Fields


TnxDefaultValueHandler.dvhEnginesInsert Field

TnxDefaultValueHandler.dvhEnginesInsert Field
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Fields Send Feedback
Syntax
Delphi
dvhEnginesInsert: array [Boolean] of array of TnxBaseDefaultValueEngine;
Description

This is dvhEnginesInsert, a member of class TnxDefaultValueHandler.

Group

TnxDefaultValueHandler Fields

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Fields


TnxDefaultValueHandler.dvhEnginesModify Field

TnxDefaultValueHandler.dvhEnginesModify Field
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Fields Send Feedback
Syntax
Delphi
dvhEnginesModify: array [Boolean] of array of TnxBaseDefaultValueEngine;
Description

This is dvhEnginesModify, a member of class TnxDefaultValueHandler.

Group

TnxDefaultValueHandler Fields

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Fields


TnxDefaultValueHandler.dvhFieldsDescriptor Field

TnxDefaultValueHandler.dvhFieldsDescriptor Field
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Fields Send Feedback
Syntax
Delphi
dvhFieldsDescriptor: TnxFieldsDescriptor;
Description

This is dvhFieldsDescriptor, a member of class TnxDefaultValueHandler.

Group

TnxDefaultValueHandler Fields

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Fields


TnxDefaultValueHandler Methods

TnxDefaultValueHandler Methods
TnxDefaultValueHandler Class Legend Public Methods Send Feedback

The methods of the TnxDefaultValueHandler class are listed here.

Class

TnxDefaultValueHandler Class

Public Methods
Name | Description
CreateFor |
SetDefaultValue |
SetDefaultValuesInsert |
SetDefaultValuesModify |
Links
TnxDefaultValueHandler Class, Legend, Public Methods


TnxDefaultValueHandler.CreateFor Method

TnxDefaultValueHandler.CreateFor Method
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Methods Send Feedback
Syntax
Delphi
class function CreateFor(aFieldsDescriptor: TnxFieldsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor): TnxDefaultValueHandler;
Group

TnxDefaultValueHandler Methods

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Methods


TnxDefaultValueHandler.SetDefaultValue Method

TnxDefaultValueHandler.SetDefaultValue Method
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aRecord: PnxByteArray; aField: Integer): Boolean;
Group

TnxDefaultValueHandler Methods

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Methods


TnxDefaultValueHandler.SetDefaultValuesInsert Method

TnxDefaultValueHandler.SetDefaultValuesInsert Method
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Methods Send Feedback
Syntax
Delphi
procedure SetDefaultValuesInsert(aRecord: PnxByteArray);
Group

TnxDefaultValueHandler Methods

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Methods


TnxDefaultValueHandler.SetDefaultValuesModify Method

TnxDefaultValueHandler.SetDefaultValuesModify Method
TnxDefaultValueHandler Class TnxDefaultValueHandler Members nxsdDefaultValueEngine Namespace TnxDefaultValueHandler Methods Send Feedback
Syntax
Delphi
procedure SetDefaultValuesModify(aRecord: PnxByteArray);
Group

TnxDefaultValueHandler Methods

Links
TnxDefaultValueHandler Class, TnxDefaultValueHandler Members, nxsdDefaultValueEngine Namespace, TnxDefaultValueHandler Methods


TnxEmptyDefaultValueEngine Class

TnxEmptyDefaultValueEngine Class
TnxEmptyDefaultValueEngine Methods TnxEmptyDefaultValueEngine Members nxsdDefaultValueEngine Classes Send Feedback
Class Hierarchy
nxsdDefaultValueEngine_TnxEmptyDefaultValueEnginenxsdDefaultValueEngine_TnxEmptyDefaultValueEnginenxsdDefaultValueEngine_TnxEmptyDefaultValueEnginenxsdDefaultValueEngine_TnxEmptyDefaultValueEnginenxsdDefaultValueEngine_TnxEmptyDefaultValueEngine
Syntax
Delphi
TnxEmptyDefaultValueEngine = class(TnxBaseDefaultValueEngine);
File

nxsdDefaultValueEngine

Description

This is class nxsdDefaultValueEngine.TnxEmptyDefaultValueEngine.

Group

Classes

Links
TnxEmptyDefaultValueEngine Methods, TnxEmptyDefaultValueEngine Members, nxsdDefaultValueEngine, Classes


TnxEmptyDefaultValueEngine Members

TnxEmptyDefaultValueEngine Members
TnxEmptyDefaultValueEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxEmptyDefaultValueEngine.

Class

TnxEmptyDefaultValueEngine Class

Protected Fields
Name | Description
bdceDescriptor | private
bdceFieldDescriptor | This is bdceFieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SetDefaultValue | TnxEmptyDefaultValueEngine
Public Properties
Name | Description
Descriptor | This is Descriptor, a member of class TnxBaseDefaultValueEngine.
FieldDescriptor | This is FieldDescriptor, a member of class TnxBaseDefaultValueEngine.
Links
TnxEmptyDefaultValueEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxEmptyDefaultValueEngine Methods

TnxEmptyDefaultValueEngine Methods
TnxEmptyDefaultValueEngine Class Legend Public Methods Send Feedback

The methods of the TnxEmptyDefaultValueEngine class are listed here.

Class

TnxEmptyDefaultValueEngine Class

Public Methods
Name | Description
SetDefaultValue | TnxEmptyDefaultValueEngine
Links
TnxEmptyDefaultValueEngine Class, Legend, Public Methods


TnxEmptyDefaultValueEngine.SetDefaultValue Method

TnxEmptyDefaultValueEngine.SetDefaultValue Method
TnxEmptyDefaultValueEngine Class TnxEmptyDefaultValueEngine Members nxsdDefaultValueEngine Namespace TnxEmptyDefaultValueEngine Methods Send Feedback
Syntax
Delphi
function SetDefaultValue(aFieldValue: PnxByteArray): Boolean; override;
Description

TnxEmptyDefaultValueEngine

Group

TnxEmptyDefaultValueEngine Methods

Links
TnxEmptyDefaultValueEngine Class, TnxEmptyDefaultValueEngine Members, nxsdDefaultValueEngine Namespace, TnxEmptyDefaultValueEngine Methods


Types

Types
nxsdDefaultValueEngine Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdDefaultValueEngine Namespace

Types
Name | Description
TnxBaseDefaultValueEngineClass | This is type nxsdDefaultValueEngine.TnxBaseDefaultValueEngineClass.
Links
nxsdDefaultValueEngine Namespace, Types


nxsdDefaultValueEngine.TnxBaseDefaultValueEngineClass Type

nxsdDefaultValueEngine.TnxBaseDefaultValueEngineClass Type
nxsdDefaultValueEngine Types Send Feedback
Syntax
Delphi
TnxBaseDefaultValueEngineClass = class of TnxBaseDefaultValueEngine;
File

nxsdDefaultValueEngine

Description

This is type nxsdDefaultValueEngine.TnxBaseDefaultValueEngineClass.

Group

Types

Links
nxsdDefaultValueEngine, Types


Variables

Variables
nxsdDefaultValueEngine Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdDefaultValueEngine Namespace

Variables
Name | Description
_BaseDefaultValueEngineList | This is variable nxsdDefaultValueEngine._BaseDefaultValueEngineList.
Links
nxsdDefaultValueEngine Namespace, Variables


nxsdDefaultValueEngine._BaseDefaultValueEngineList Variable

nxsdDefaultValueEngine._BaseDefaultValueEngineList Variable
nxsdDefaultValueEngine Variables Send Feedback
Syntax
Delphi
_BaseDefaultValueEngineList: TStringList;
File

nxsdDefaultValueEngine

Description

This is variable nxsdDefaultValueEngine._BaseDefaultValueEngineList.

Group

Variables

Links
nxsdDefaultValueEngine, Variables


Constants

Constants
Constants nxsdDefaultValueEngine Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csDefaultValue | This is constant nxsdDefaultValueEngine.csDefaultValue.
Namespace

nxsdDefaultValueEngine Namespace

Links
Constants, nxsdDefaultValueEngine Namespace


nxsdDefaultValueEngine.csDefaultValue Constant

nxsdDefaultValueEngine.csDefaultValue Constant
nxsdDefaultValueEngine Constants Send Feedback
Syntax
Delphi
csDefaultValue = 'DefaultValue';
File

nxsdDefaultValueEngine

Description

This is constant nxsdDefaultValueEngine.csDefaultValue.

Group

Constants

Links
nxsdDefaultValueEngine, Constants


nxsdFieldMapper Namespace

nxsdFieldMapper Namespace
Classes Legend Topics Send Feedback

This is namespace nxsdFieldMapper.

Classes
Name | Description
TnxAnsiStringToWideStringMapper | This is class nxsdFieldMapper.TnxAnsiStringToWideStringMapper.
TnxBooleanMapper | This is class nxsdFieldMapper.TnxBooleanMapper.
TnxByte8Mapper | This is class nxsdFieldMapper.TnxByte8Mapper.
TnxByteArrayMapper | This is class nxsdFieldMapper.TnxByteArrayMapper.
TnxCharMapper | This is class nxsdFieldMapper.TnxCharMapper.
TnxCurrencyMapper | This is class nxsdFieldMapper.TnxCurrencyMapper.
TnxDateMapper | This is class nxsdFieldMapper.TnxDateMapper.
TnxDateTimeMapper | This is class nxsdFieldMapper.TnxDateTimeMapper.
TnxDoubleMapper | This is class nxsdFieldMapper.TnxDoubleMapper.
TnxExtendedMapper | This is class nxsdFieldMapper.TnxExtendedMapper.
TnxFmtBCDMapper | This is class nxsdFieldMapper.TnxFmtBCDMapper.
TnxGuidMapper | This is class nxsdFieldMapper.TnxGuidMapper.
TnxInt16Mapper | This is class nxsdFieldMapper.TnxInt16Mapper.
TnxInt32Mapper | This is class nxsdFieldMapper.TnxInt32Mapper.
TnxInt64Mapper | This is class nxsdFieldMapper.TnxInt64Mapper.
TnxInt8Mapper | This is class nxsdFieldMapper.TnxInt8Mapper.
TnxNullStringMapper | This is class nxsdFieldMapper.TnxNullStringMapper.
TnxNullStringToNullStringMapper | This is class nxsdFieldMapper.TnxNullStringToNullStringMapper.
TnxNullStringToShortStringMapper | This is class nxsdFieldMapper.TnxNullStringToShortStringMapper.
TnxShortStringMapper | This is class nxsdFieldMapper.TnxShortStringMapper.
TnxShortStringToNullStringMapper | This is class nxsdFieldMapper.TnxShortStringToNullStringMapper.
TnxShortStringToShortStringMapper | This is class nxsdFieldMapper.TnxShortStringToShortStringMapper.
TnxSingleMapper | This is class nxsdFieldMapper.TnxSingleMapper.
TnxTimeMapper | This is class nxsdFieldMapper.TnxTimeMapper.
TnxWideCharMapper | This is class nxsdFieldMapper.TnxWideCharMapper.
TnxWideStringMapper | This is class nxsdFieldMapper.TnxWideStringMapper.
TnxWideStringToAnsiStringMapper | This is class nxsdFieldMapper.TnxWideStringToAnsiStringMapper.
TnxWideStringToWideStringMapper | This is class nxsdFieldMapper.TnxWideStringToWideStringMapper.
TnxWord16Mapper | This is class nxsdFieldMapper.TnxWord16Mapper.
TnxWord32Mapper | This is class nxsdFieldMapper.TnxWord32Mapper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxsdFieldMapper Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxAnsiStringToWideStringMapper | This is class nxsdFieldMapper.TnxAnsiStringToWideStringMapper.
TnxBooleanMapper | This is class nxsdFieldMapper.TnxBooleanMapper.
TnxByte8Mapper | This is class nxsdFieldMapper.TnxByte8Mapper.
TnxByteArrayMapper | This is class nxsdFieldMapper.TnxByteArrayMapper.
TnxCharMapper | This is class nxsdFieldMapper.TnxCharMapper.
TnxCurrencyMapper | This is class nxsdFieldMapper.TnxCurrencyMapper.
TnxDateMapper | This is class nxsdFieldMapper.TnxDateMapper.
TnxDateTimeMapper | This is class nxsdFieldMapper.TnxDateTimeMapper.
TnxDoubleMapper | This is class nxsdFieldMapper.TnxDoubleMapper.
TnxExtendedMapper | This is class nxsdFieldMapper.TnxExtendedMapper.
TnxFmtBCDMapper | This is class nxsdFieldMapper.TnxFmtBCDMapper.
TnxGuidMapper | This is class nxsdFieldMapper.TnxGuidMapper.
TnxInt16Mapper | This is class nxsdFieldMapper.TnxInt16Mapper.
TnxInt32Mapper | This is class nxsdFieldMapper.TnxInt32Mapper.
TnxInt64Mapper | This is class nxsdFieldMapper.TnxInt64Mapper.
TnxInt8Mapper | This is class nxsdFieldMapper.TnxInt8Mapper.
TnxNullStringMapper | This is class nxsdFieldMapper.TnxNullStringMapper.
TnxNullStringToNullStringMapper | This is class nxsdFieldMapper.TnxNullStringToNullStringMapper.
TnxNullStringToShortStringMapper | This is class nxsdFieldMapper.TnxNullStringToShortStringMapper.
TnxShortStringMapper | This is class nxsdFieldMapper.TnxShortStringMapper.
TnxShortStringToNullStringMapper | This is class nxsdFieldMapper.TnxShortStringToNullStringMapper.
TnxShortStringToShortStringMapper | This is class nxsdFieldMapper.TnxShortStringToShortStringMapper.
TnxSingleMapper | This is class nxsdFieldMapper.TnxSingleMapper.
TnxTimeMapper | This is class nxsdFieldMapper.TnxTimeMapper.
TnxWideCharMapper | This is class nxsdFieldMapper.TnxWideCharMapper.
TnxWideStringMapper | This is class nxsdFieldMapper.TnxWideStringMapper.
TnxWideStringToAnsiStringMapper | This is class nxsdFieldMapper.TnxWideStringToAnsiStringMapper.
TnxWideStringToWideStringMapper | This is class nxsdFieldMapper.TnxWideStringToWideStringMapper.
TnxWord16Mapper | This is class nxsdFieldMapper.TnxWord16Mapper.
TnxWord32Mapper | This is class nxsdFieldMapper.TnxWord32Mapper.
Namespace

nxsdFieldMapper Namespace

Links
Classes, nxsdFieldMapper Namespace, Legend


TnxAnsiStringToWideStringMapper Class

TnxAnsiStringToWideStringMapper Class
TnxAnsiStringToWideStringMapper Fields TnxAnsiStringToWideStringMapper Methods TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxAnsiStringToWideStringMappernxsdFieldMapper_TnxAnsiStringToWideStringMappernxsdFieldMapper_TnxAnsiStringToWideStringMapper
Syntax
Delphi
TnxAnsiStringToWideStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxAnsiStringToWideStringMapper.

Group

Classes

Links
TnxAnsiStringToWideStringMapper Fields, TnxAnsiStringToWideStringMapper Methods, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper, Classes


TnxAnsiStringToWideStringMapper Members

TnxAnsiStringToWideStringMapper Members
TnxAnsiStringToWideStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxAnsiStringToWideStringMapper.

Class

TnxAnsiStringToWideStringMapper Class

Protected Fields
Name | Description
atwSourceCodepage | This is atwSourceCodepage, a member of class TnxAnsiStringToWideStringMapper.
atwTargetLength | private
Protected Methods
Name | Description
FromNullStringConvert |
FromNullStringConvertCheck |
FromNullStringConvertCheckPadding |
FromNullStringConvertPadding | This is FromNullStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.
FromShortStringConvert | This is FromShortStringConvert, a member of class TnxAnsiStringToWideStringMapper.
FromShortStringConvertCheck |
FromShortStringConvertCheckPadding |
FromShortStringConvertPadding | This is FromShortStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.
InternalCreateMapper |
Register |
Unregister |
Public Methods
Name | Description
Create |
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxAnsiStringToWideStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxAnsiStringToWideStringMapper.Create Constructor

TnxAnsiStringToWideStringMapper.Create Constructor
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxAnsiStringToWideStringMapper Class

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Class


TnxAnsiStringToWideStringMapper Fields

TnxAnsiStringToWideStringMapper Fields
TnxAnsiStringToWideStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxAnsiStringToWideStringMapper class are listed here.

Class

TnxAnsiStringToWideStringMapper Class

Protected Fields
Name | Description
atwSourceCodepage | This is atwSourceCodepage, a member of class TnxAnsiStringToWideStringMapper.
atwTargetLength | private
Links
TnxAnsiStringToWideStringMapper Class, Legend, Protected Fields


TnxAnsiStringToWideStringMapper.atwSourceCodepage Field

TnxAnsiStringToWideStringMapper.atwSourceCodepage Field
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Fields Send Feedback
Syntax
Delphi
atwSourceCodepage: Word;
Description

This is atwSourceCodepage, a member of class TnxAnsiStringToWideStringMapper.

Group

TnxAnsiStringToWideStringMapper Fields

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Fields


TnxAnsiStringToWideStringMapper.atwTargetLength Field

TnxAnsiStringToWideStringMapper.atwTargetLength Field
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Fields Send Feedback
Syntax
Delphi
atwTargetLength: Integer;
Description

private

Group

TnxAnsiStringToWideStringMapper Fields

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Fields


TnxAnsiStringToWideStringMapper Methods

TnxAnsiStringToWideStringMapper Methods
TnxAnsiStringToWideStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxAnsiStringToWideStringMapper class are listed here.

Class

TnxAnsiStringToWideStringMapper Class

Protected Methods
Name | Description
FromNullStringConvert |
FromNullStringConvertCheck |
FromNullStringConvertCheckPadding |
FromNullStringConvertPadding | This is FromNullStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.
FromShortStringConvert | This is FromShortStringConvert, a member of class TnxAnsiStringToWideStringMapper.
FromShortStringConvertCheck |
FromShortStringConvertCheckPadding |
FromShortStringConvertPadding | This is FromShortStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.
InternalCreateMapper |
Links
TnxAnsiStringToWideStringMapper Class, Legend, Protected Methods


TnxAnsiStringToWideStringMapper.FromNullStringConvert Method

TnxAnsiStringToWideStringMapper.FromNullStringConvert Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromNullStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromNullStringConvertCheck Method

TnxAnsiStringToWideStringMapper.FromNullStringConvertCheck Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromNullStringConvertCheckPadding Method

TnxAnsiStringToWideStringMapper.FromNullStringConvertCheckPadding Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromNullStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromNullStringConvertPadding Method

TnxAnsiStringToWideStringMapper.FromNullStringConvertPadding Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromNullStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

This is FromNullStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.

Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromShortStringConvert Method

TnxAnsiStringToWideStringMapper.FromShortStringConvert Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromShortStringConvert(const aSource; var aTarget): TnxResult;
Description

This is FromShortStringConvert, a member of class TnxAnsiStringToWideStringMapper.

Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromShortStringConvertCheck Method

TnxAnsiStringToWideStringMapper.FromShortStringConvertCheck Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromShortStringConvertCheckPadding Method

TnxAnsiStringToWideStringMapper.FromShortStringConvertCheckPadding Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromShortStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.FromShortStringConvertPadding Method

TnxAnsiStringToWideStringMapper.FromShortStringConvertPadding Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function FromShortStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

This is FromShortStringConvertPadding, a member of class TnxAnsiStringToWideStringMapper.

Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxAnsiStringToWideStringMapper.InternalCreateMapper Method

TnxAnsiStringToWideStringMapper.InternalCreateMapper Method
TnxAnsiStringToWideStringMapper Class TnxAnsiStringToWideStringMapper Members nxsdFieldMapper Namespace TnxAnsiStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxAnsiStringToWideStringMapper Methods

Links
TnxAnsiStringToWideStringMapper Class, TnxAnsiStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxAnsiStringToWideStringMapper Methods


TnxBooleanMapper Class

TnxBooleanMapper Class
TnxBooleanMapper Methods TnxBooleanMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxBooleanMappernxsdFieldMapper_TnxBooleanMappernxsdFieldMapper_TnxBooleanMapper
Syntax
Delphi
TnxBooleanMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxBooleanMapper.

Group

Classes

Links
TnxBooleanMapper Methods, TnxBooleanMapper Members, nxsdFieldMapper, Classes


TnxBooleanMapper Members

TnxBooleanMapper Members
TnxBooleanMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBooleanMapper.

Class

TnxBooleanMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
Register |
ToAnsiChar | This is ToAnsiChar, a member of class TnxBooleanMapper.
ToBoolean | This is ToBoolean, a member of class TnxBooleanMapper.
ToByte8 | This is ToByte8, a member of class TnxBooleanMapper.
ToByteArray | This is ToByteArray, a member of class TnxBooleanMapper.
ToCurrency | This is ToCurrency, a member of class TnxBooleanMapper.
ToDouble | This is ToDouble, a member of class TnxBooleanMapper.
ToExtended | This is ToExtended, a member of class TnxBooleanMapper.
ToInt16 | This is ToInt16, a member of class TnxBooleanMapper.
ToInt32 | This is ToInt32, a member of class TnxBooleanMapper.
ToInt64 | This is ToInt64, a member of class TnxBooleanMapper.
ToInt8 | This is ToInt8, a member of class TnxBooleanMapper.
ToNullString | This is ToNullString, a member of class TnxBooleanMapper.
ToShortString | This is ToShortString, a member of class TnxBooleanMapper.
ToSingle | This is ToSingle, a member of class TnxBooleanMapper.
ToWideChar | This is ToWideChar, a member of class TnxBooleanMapper.
ToWideString | This is ToWideString, a member of class TnxBooleanMapper.
ToWord16 | This is ToWord16, a member of class TnxBooleanMapper.
ToWord32 | This is ToWord32, a member of class TnxBooleanMapper.
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxBooleanMapper Class, Legend, Protected Methods, Public Methods


TnxBooleanMapper Methods

TnxBooleanMapper Methods
TnxBooleanMapper Class Legend Protected Methods Send Feedback

The methods of the TnxBooleanMapper class are listed here.

Class

TnxBooleanMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar | This is ToAnsiChar, a member of class TnxBooleanMapper.
ToBoolean | This is ToBoolean, a member of class TnxBooleanMapper.
ToByte8 | This is ToByte8, a member of class TnxBooleanMapper.
ToByteArray | This is ToByteArray, a member of class TnxBooleanMapper.
ToCurrency | This is ToCurrency, a member of class TnxBooleanMapper.
ToDouble | This is ToDouble, a member of class TnxBooleanMapper.
ToExtended | This is ToExtended, a member of class TnxBooleanMapper.
ToInt16 | This is ToInt16, a member of class TnxBooleanMapper.
ToInt32 | This is ToInt32, a member of class TnxBooleanMapper.
ToInt64 | This is ToInt64, a member of class TnxBooleanMapper.
ToInt8 | This is ToInt8, a member of class TnxBooleanMapper.
ToNullString | This is ToNullString, a member of class TnxBooleanMapper.
ToShortString | This is ToShortString, a member of class TnxBooleanMapper.
ToSingle | This is ToSingle, a member of class TnxBooleanMapper.
ToWideChar | This is ToWideChar, a member of class TnxBooleanMapper.
ToWideString | This is ToWideString, a member of class TnxBooleanMapper.
ToWord16 | This is ToWord16, a member of class TnxBooleanMapper.
ToWord32 | This is ToWord32, a member of class TnxBooleanMapper.
Links
TnxBooleanMapper Class, Legend, Protected Methods


TnxBooleanMapper.InternalCreateMapper Method

TnxBooleanMapper.InternalCreateMapper Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToAnsiChar Method

TnxBooleanMapper.ToAnsiChar Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToAnsiChar(const aSource; var aTarget): TnxResult;
Description

This is ToAnsiChar, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToBoolean Method

TnxBooleanMapper.ToBoolean Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Description

This is ToBoolean, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToByte8 Method

TnxBooleanMapper.ToByte8 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Description

This is ToByte8, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToByteArray Method

TnxBooleanMapper.ToByteArray Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Description

This is ToByteArray, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToCurrency Method

TnxBooleanMapper.ToCurrency Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Description

This is ToCurrency, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToDouble Method

TnxBooleanMapper.ToDouble Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Description

This is ToDouble, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToExtended Method

TnxBooleanMapper.ToExtended Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Description

This is ToExtended, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToInt16 Method

TnxBooleanMapper.ToInt16 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Description

This is ToInt16, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToInt32 Method

TnxBooleanMapper.ToInt32 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Description

This is ToInt32, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToInt64 Method

TnxBooleanMapper.ToInt64 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Description

This is ToInt64, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToInt8 Method

TnxBooleanMapper.ToInt8 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Description

This is ToInt8, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToNullString Method

TnxBooleanMapper.ToNullString Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToNullString(const aSource; var aTarget): TnxResult;
Description

This is ToNullString, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToShortString Method

TnxBooleanMapper.ToShortString Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToShortString(const aSource; var aTarget): TnxResult;
Description

This is ToShortString, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToSingle Method

TnxBooleanMapper.ToSingle Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Description

This is ToSingle, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToWideChar Method

TnxBooleanMapper.ToWideChar Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToWideChar(const aSource; var aTarget): TnxResult;
Description

This is ToWideChar, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToWideString Method

TnxBooleanMapper.ToWideString Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToWideString(const aSource; var aTarget): TnxResult;
Description

This is ToWideString, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToWord16 Method

TnxBooleanMapper.ToWord16 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Description

This is ToWord16, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxBooleanMapper.ToWord32 Method

TnxBooleanMapper.ToWord32 Method
TnxBooleanMapper Class TnxBooleanMapper Members nxsdFieldMapper Namespace TnxBooleanMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Description

This is ToWord32, a member of class TnxBooleanMapper.

Group

TnxBooleanMapper Methods

Links
TnxBooleanMapper Class, TnxBooleanMapper Members, nxsdFieldMapper Namespace, TnxBooleanMapper Methods


TnxByte8Mapper Class

TnxByte8Mapper Class
TnxByte8Mapper Fields TnxByte8Mapper Methods TnxByte8Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxByte8MappernxsdFieldMapper_TnxByte8MappernxsdFieldMapper_TnxByte8Mapper
Syntax
Delphi
TnxByte8Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxByte8Mapper.

Group

Classes

Links
TnxByte8Mapper Fields, TnxByte8Mapper Methods, TnxByte8Mapper Members, nxsdFieldMapper, Classes


TnxByte8Mapper Members

TnxByte8Mapper Members
TnxByte8Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxByte8Mapper.

Class

TnxByte8Mapper Class

Protected Fields
Name | Description
b8mTargetDecPl | This is b8mTargetDecPl, a member of class TnxByte8Mapper.
b8mTargetLength | private
b8mTargetUnits | This is b8mTargetUnits, a member of class TnxByte8Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord32 |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxByte8Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxByte8Mapper.Create Constructor

TnxByte8Mapper.Create Constructor
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxByte8Mapper Class

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Class


TnxByte8Mapper Fields

TnxByte8Mapper Fields
TnxByte8Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxByte8Mapper class are listed here.

Class

TnxByte8Mapper Class

Protected Fields
Name | Description
b8mTargetDecPl | This is b8mTargetDecPl, a member of class TnxByte8Mapper.
b8mTargetLength | private
b8mTargetUnits | This is b8mTargetUnits, a member of class TnxByte8Mapper.
Links
TnxByte8Mapper Class, Legend, Protected Fields


TnxByte8Mapper.b8mTargetDecPl Field

TnxByte8Mapper.b8mTargetDecPl Field
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Fields Send Feedback
Syntax
Delphi
b8mTargetDecPl: Integer;
Description

This is b8mTargetDecPl, a member of class TnxByte8Mapper.

Group

TnxByte8Mapper Fields

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Fields


TnxByte8Mapper.b8mTargetLength Field

TnxByte8Mapper.b8mTargetLength Field
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Fields Send Feedback
Syntax
Delphi
b8mTargetLength: Integer;
Description

private

Group

TnxByte8Mapper Fields

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Fields


TnxByte8Mapper.b8mTargetUnits Field

TnxByte8Mapper.b8mTargetUnits Field
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Fields Send Feedback
Syntax
Delphi
b8mTargetUnits: Integer;
Description

This is b8mTargetUnits, a member of class TnxByte8Mapper.

Group

TnxByte8Mapper Fields

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Fields


TnxByte8Mapper Methods

TnxByte8Mapper Methods
TnxByte8Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxByte8Mapper class are listed here.

Class

TnxByte8Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord32 |
Links
TnxByte8Mapper Class, Legend, Protected Methods


TnxByte8Mapper.InternalCreateMapper Method

TnxByte8Mapper.InternalCreateMapper Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToAnsiChar Method

TnxByte8Mapper.ToAnsiChar Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToAnsiCharCheck Method

TnxByte8Mapper.ToAnsiCharCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToBcd Method

TnxByte8Mapper.ToBcd Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToBcdCheck Method

TnxByte8Mapper.ToBcdCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToBcdTrunc Method

TnxByte8Mapper.ToBcdTrunc Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToBoolean Method

TnxByte8Mapper.ToBoolean Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToBooleanCheck Method

TnxByte8Mapper.ToBooleanCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToByte8 Method

TnxByte8Mapper.ToByte8 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToByteArray Method

TnxByte8Mapper.ToByteArray Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToCurrency Method

TnxByte8Mapper.ToCurrency Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToDouble Method

TnxByte8Mapper.ToDouble Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToExtended Method

TnxByte8Mapper.ToExtended Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToInt16 Method

TnxByte8Mapper.ToInt16 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToInt32 Method

TnxByte8Mapper.ToInt32 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToInt64 Method

TnxByte8Mapper.ToInt64 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToInt8 Method

TnxByte8Mapper.ToInt8 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToInt8Check Method

TnxByte8Mapper.ToInt8Check Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToNullString Method

TnxByte8Mapper.ToNullString Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToNullStringCheck Method

TnxByte8Mapper.ToNullStringCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToShortString Method

TnxByte8Mapper.ToShortString Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToShortStringCheck Method

TnxByte8Mapper.ToShortStringCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToSingle Method

TnxByte8Mapper.ToSingle Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWideChar Method

TnxByte8Mapper.ToWideChar Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWideCharCheck Method

TnxByte8Mapper.ToWideCharCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWideString Method

TnxByte8Mapper.ToWideString Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWideStringCheck Method

TnxByte8Mapper.ToWideStringCheck Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWord16 Method

TnxByte8Mapper.ToWord16 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByte8Mapper.ToWord32 Method

TnxByte8Mapper.ToWord32 Method
TnxByte8Mapper Class TnxByte8Mapper Members nxsdFieldMapper Namespace TnxByte8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxByte8Mapper Methods

Links
TnxByte8Mapper Class, TnxByte8Mapper Members, nxsdFieldMapper Namespace, TnxByte8Mapper Methods


TnxByteArrayMapper Class

TnxByteArrayMapper Class
TnxByteArrayMapper Fields TnxByteArrayMapper Methods TnxByteArrayMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxByteArrayMappernxsdFieldMapper_TnxByteArrayMappernxsdFieldMapper_TnxByteArrayMapper
Syntax
Delphi
TnxByteArrayMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxByteArrayMapper.

Group

Classes

Links
TnxByteArrayMapper Fields, TnxByteArrayMapper Methods, TnxByteArrayMapper Members, nxsdFieldMapper, Classes


TnxByteArrayMapper Members

TnxByteArrayMapper Members
TnxByteArrayMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxByteArrayMapper.

Class

TnxByteArrayMapper Class

Protected Fields
Name | Description
bamFormatSettings | private
bamSourceCodepage | This is bamSourceCodepage, a member of class TnxByteArrayMapper.
bamSourceLength | This is bamSourceLength, a member of class TnxByteArrayMapper.
bamTargetCodepage | This is bamTargetCodepage, a member of class TnxByteArrayMapper.
bamTargetLength | This is bamTargetLength, a member of class TnxByteArrayMapper.
Protected Methods
Name | Description
Create | TnxByteArrayMapper
InternalCreateMapper |
Register |
ToByteArray |
ToGuid |
ToNullString |
ToNullStringConvert | target has same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortString | target requires codepage translation
ToShortStringConvert | target has same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToWideString | target requires codepage translation
ToWideStringCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxByteArrayMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxByteArrayMapper.Create Constructor

TnxByteArrayMapper.Create Constructor
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Description

TnxByteArrayMapper

Class

TnxByteArrayMapper Class

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Class


TnxByteArrayMapper Fields

TnxByteArrayMapper Fields
TnxByteArrayMapper Class Legend Protected Fields Send Feedback

The fields of the TnxByteArrayMapper class are listed here.

Class

TnxByteArrayMapper Class

Protected Fields
Name | Description
bamFormatSettings | private
bamSourceCodepage | This is bamSourceCodepage, a member of class TnxByteArrayMapper.
bamSourceLength | This is bamSourceLength, a member of class TnxByteArrayMapper.
bamTargetCodepage | This is bamTargetCodepage, a member of class TnxByteArrayMapper.
bamTargetLength | This is bamTargetLength, a member of class TnxByteArrayMapper.
Links
TnxByteArrayMapper Class, Legend, Protected Fields


TnxByteArrayMapper.bamFormatSettings Field

TnxByteArrayMapper.bamFormatSettings Field
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Fields Send Feedback
Syntax
Delphi
bamFormatSettings: TFormatSettings;
Description

private

Group

TnxByteArrayMapper Fields

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Fields


TnxByteArrayMapper.bamSourceCodepage Field

TnxByteArrayMapper.bamSourceCodepage Field
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Fields Send Feedback
Syntax
Delphi
bamSourceCodepage: Word;
Description

This is bamSourceCodepage, a member of class TnxByteArrayMapper.

Group

TnxByteArrayMapper Fields

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Fields


TnxByteArrayMapper.bamSourceLength Field

TnxByteArrayMapper.bamSourceLength Field
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Fields Send Feedback
Syntax
Delphi
bamSourceLength: Integer;
Description

This is bamSourceLength, a member of class TnxByteArrayMapper.

Group

TnxByteArrayMapper Fields

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Fields


TnxByteArrayMapper.bamTargetCodepage Field

TnxByteArrayMapper.bamTargetCodepage Field
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Fields Send Feedback
Syntax
Delphi
bamTargetCodepage: Word;
Description

This is bamTargetCodepage, a member of class TnxByteArrayMapper.

Group

TnxByteArrayMapper Fields

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Fields


TnxByteArrayMapper.bamTargetLength Field

TnxByteArrayMapper.bamTargetLength Field
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Fields Send Feedback
Syntax
Delphi
bamTargetLength: Integer;
Description

This is bamTargetLength, a member of class TnxByteArrayMapper.

Group

TnxByteArrayMapper Fields

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Fields


TnxByteArrayMapper Methods

TnxByteArrayMapper Methods
TnxByteArrayMapper Class Legend Protected Methods Send Feedback

The methods of the TnxByteArrayMapper class are listed here.

Class

TnxByteArrayMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToByteArray |
ToGuid |
ToNullString |
ToNullStringConvert | target has same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortString | target requires codepage translation
ToShortStringConvert | target has same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToWideString | target requires codepage translation
ToWideStringCheck |
Links
TnxByteArrayMapper Class, Legend, Protected Methods


TnxByteArrayMapper.InternalCreateMapper Method

TnxByteArrayMapper.InternalCreateMapper Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToByteArray Method

TnxByteArrayMapper.ToByteArray Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToGuid Method

TnxByteArrayMapper.ToGuid Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToGuid(const aSource; var aTarget): TnxResult;
Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToNullString Method

TnxByteArrayMapper.ToNullString Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToNullStringConvert Method

TnxByteArrayMapper.ToNullStringConvert Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Description

target has same codepage

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToNullStringConvertCheck Method

TnxByteArrayMapper.ToNullStringConvertCheck Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToShortString Method

TnxByteArrayMapper.ToShortString Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToShortStringConvert Method

TnxByteArrayMapper.ToShortStringConvert Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Description

target has same codepage

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToShortStringConvertCheck Method

TnxByteArrayMapper.ToShortStringConvertCheck Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToWideString Method

TnxByteArrayMapper.ToWideString Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxByteArrayMapper.ToWideStringCheck Method

TnxByteArrayMapper.ToWideStringCheck Method
TnxByteArrayMapper Class TnxByteArrayMapper Members nxsdFieldMapper Namespace TnxByteArrayMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxByteArrayMapper Methods

Links
TnxByteArrayMapper Class, TnxByteArrayMapper Members, nxsdFieldMapper Namespace, TnxByteArrayMapper Methods


TnxCharMapper Class

TnxCharMapper Class
TnxCharMapper Fields TnxCharMapper Methods TnxCharMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxCharMappernxsdFieldMapper_TnxCharMappernxsdFieldMapper_TnxCharMapper
Syntax
Delphi
TnxCharMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxCharMapper.

Group

Classes

Links
TnxCharMapper Fields, TnxCharMapper Methods, TnxCharMapper Members, nxsdFieldMapper, Classes


TnxCharMapper Members

TnxCharMapper Members
TnxCharMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCharMapper.

Class

TnxCharMapper Class

Protected Fields
Name | Description
ccSourceCodepage | This is ccSourceCodepage, a member of class TnxCharMapper.
ccTargetCodepage | This is ccTargetCodepage, a member of class TnxCharMapper.
ccTargetLength | private
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharConvert |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringConvert |
ToNullStringConvertCheck |
ToShortString |
ToShortStringConvert |
ToShortStringConvertCheck |
ToSingle |
ToSingleCheck |
ToWideCharConvert |
ToWideCharConvertCheck |
ToWideStringConvert |
ToWideStringConvertCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxCharMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCharMapper.Create Constructor

TnxCharMapper.Create Constructor
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxCharMapper Class

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Class


TnxCharMapper Fields

TnxCharMapper Fields
TnxCharMapper Class Legend Protected Fields Send Feedback

The fields of the TnxCharMapper class are listed here.

Class

TnxCharMapper Class

Protected Fields
Name | Description
ccSourceCodepage | This is ccSourceCodepage, a member of class TnxCharMapper.
ccTargetCodepage | This is ccTargetCodepage, a member of class TnxCharMapper.
ccTargetLength | private
Links
TnxCharMapper Class, Legend, Protected Fields


TnxCharMapper.ccSourceCodepage Field

TnxCharMapper.ccSourceCodepage Field
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Fields Send Feedback
Syntax
Delphi
ccSourceCodepage: Word;
Description

This is ccSourceCodepage, a member of class TnxCharMapper.

Group

TnxCharMapper Fields

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Fields


TnxCharMapper.ccTargetCodepage Field

TnxCharMapper.ccTargetCodepage Field
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Fields Send Feedback
Syntax
Delphi
ccTargetCodepage: Word;
Description

This is ccTargetCodepage, a member of class TnxCharMapper.

Group

TnxCharMapper Fields

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Fields


TnxCharMapper.ccTargetLength Field

TnxCharMapper.ccTargetLength Field
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Fields Send Feedback
Syntax
Delphi
ccTargetLength: Integer;
Description

private

Group

TnxCharMapper Fields

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Fields


TnxCharMapper Methods

TnxCharMapper Methods
TnxCharMapper Class Legend Protected Methods Send Feedback

The methods of the TnxCharMapper class are listed here.

Class

TnxCharMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharConvert |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringConvert |
ToNullStringConvertCheck |
ToShortString |
ToShortStringConvert |
ToShortStringConvertCheck |
ToSingle |
ToSingleCheck |
ToWideCharConvert |
ToWideCharConvertCheck |
ToWideStringConvert |
ToWideStringConvertCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxCharMapper Class, Legend, Protected Methods


TnxCharMapper.InternalCreateMapper Method

TnxCharMapper.InternalCreateMapper Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToAnsiChar Method

TnxCharMapper.ToAnsiChar Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToAnsiCharConvert Method

TnxCharMapper.ToAnsiCharConvert Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToBoolean Method

TnxCharMapper.ToBoolean Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToBooleanCheck Method

TnxCharMapper.ToBooleanCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToByte8 Method

TnxCharMapper.ToByte8 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToByteArray Method

TnxCharMapper.ToByteArray Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToByteCheck Method

TnxCharMapper.ToByteCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToCurrency Method

TnxCharMapper.ToCurrency Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToCurrencyCheck Method

TnxCharMapper.ToCurrencyCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToDouble Method

TnxCharMapper.ToDouble Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToDoubleCheck Method

TnxCharMapper.ToDoubleCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToExtended Method

TnxCharMapper.ToExtended Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToExtendedCheck Method

TnxCharMapper.ToExtendedCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt16 Method

TnxCharMapper.ToInt16 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt16Check Method

TnxCharMapper.ToInt16Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt32 Method

TnxCharMapper.ToInt32 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt32Check Method

TnxCharMapper.ToInt32Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt64 Method

TnxCharMapper.ToInt64 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt64Check Method

TnxCharMapper.ToInt64Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt8 Method

TnxCharMapper.ToInt8 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToInt8Check Method

TnxCharMapper.ToInt8Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToNullString Method

TnxCharMapper.ToNullString Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToNullStringConvert Method

TnxCharMapper.ToNullStringConvert Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToNullStringConvertCheck Method

TnxCharMapper.ToNullStringConvertCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToShortString Method

TnxCharMapper.ToShortString Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToShortStringConvert Method

TnxCharMapper.ToShortStringConvert Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToShortStringConvertCheck Method

TnxCharMapper.ToShortStringConvertCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToSingle Method

TnxCharMapper.ToSingle Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToSingleCheck Method

TnxCharMapper.ToSingleCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWideCharConvert Method

TnxCharMapper.ToWideCharConvert Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWideCharConvertCheck Method

TnxCharMapper.ToWideCharConvertCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWideStringConvert Method

TnxCharMapper.ToWideStringConvert Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWideStringConvertCheck Method

TnxCharMapper.ToWideStringConvertCheck Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWord16 Method

TnxCharMapper.ToWord16 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWord16Check Method

TnxCharMapper.ToWord16Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWord32 Method

TnxCharMapper.ToWord32 Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCharMapper.ToWord32Check Method

TnxCharMapper.ToWord32Check Method
TnxCharMapper Class TnxCharMapper Members nxsdFieldMapper Namespace TnxCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxCharMapper Methods

Links
TnxCharMapper Class, TnxCharMapper Members, nxsdFieldMapper Namespace, TnxCharMapper Methods


TnxCurrencyMapper Class

TnxCurrencyMapper Class
TnxCurrencyMapper Fields TnxCurrencyMapper Methods TnxCurrencyMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxCurrencyMappernxsdFieldMapper_TnxCurrencyMappernxsdFieldMapper_TnxCurrencyMapper
Syntax
Delphi
TnxCurrencyMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxCurrencyMapper.

Group

Classes

Links
TnxCurrencyMapper Fields, TnxCurrencyMapper Methods, TnxCurrencyMapper Members, nxsdFieldMapper, Classes


TnxCurrencyMapper Members

TnxCurrencyMapper Members
TnxCurrencyMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCurrencyMapper.

Class

TnxCurrencyMapper Class

Protected Fields
Name | Description
cmFormatSettings | This is cmFormatSettings, a member of class TnxCurrencyMapper.
cmTargetDecPl | This is cmTargetDecPl, a member of class TnxCurrencyMapper.
cmTargetLength | This is cmTargetLength, a member of class TnxCurrencyMapper.
cmTargetUnits | This is cmTargetUnits, a member of class TnxCurrencyMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck | This is ToAnsiCharCheck, a member of class TnxCurrencyMapper.
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxCurrencyMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCurrencyMapper.Create Constructor

TnxCurrencyMapper.Create Constructor
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxCurrencyMapper Class

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Class


TnxCurrencyMapper Fields

TnxCurrencyMapper Fields
TnxCurrencyMapper Class Legend Protected Fields Send Feedback

The fields of the TnxCurrencyMapper class are listed here.

Class

TnxCurrencyMapper Class

Protected Fields
Name | Description
cmFormatSettings | This is cmFormatSettings, a member of class TnxCurrencyMapper.
cmTargetDecPl | This is cmTargetDecPl, a member of class TnxCurrencyMapper.
cmTargetLength | This is cmTargetLength, a member of class TnxCurrencyMapper.
cmTargetUnits | This is cmTargetUnits, a member of class TnxCurrencyMapper.
Links
TnxCurrencyMapper Class, Legend, Protected Fields


TnxCurrencyMapper.cmFormatSettings Field

TnxCurrencyMapper.cmFormatSettings Field
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Fields Send Feedback
Syntax
Delphi
cmFormatSettings: TFormatSettings;
Description

This is cmFormatSettings, a member of class TnxCurrencyMapper.

Group

TnxCurrencyMapper Fields

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Fields


TnxCurrencyMapper.cmTargetDecPl Field

TnxCurrencyMapper.cmTargetDecPl Field
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Fields Send Feedback
Syntax
Delphi
cmTargetDecPl: Integer;
Description

This is cmTargetDecPl, a member of class TnxCurrencyMapper.

Group

TnxCurrencyMapper Fields

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Fields


TnxCurrencyMapper.cmTargetLength Field

TnxCurrencyMapper.cmTargetLength Field
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Fields Send Feedback
Syntax
Delphi
cmTargetLength: Integer;
Description

This is cmTargetLength, a member of class TnxCurrencyMapper.

Group

TnxCurrencyMapper Fields

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Fields


TnxCurrencyMapper.cmTargetUnits Field

TnxCurrencyMapper.cmTargetUnits Field
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Fields Send Feedback
Syntax
Delphi
cmTargetUnits: Integer;
Description

This is cmTargetUnits, a member of class TnxCurrencyMapper.

Group

TnxCurrencyMapper Fields

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Fields


TnxCurrencyMapper Methods

TnxCurrencyMapper Methods
TnxCurrencyMapper Class Legend Protected Methods Send Feedback

The methods of the TnxCurrencyMapper class are listed here.

Class

TnxCurrencyMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck | This is ToAnsiCharCheck, a member of class TnxCurrencyMapper.
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxCurrencyMapper Class, Legend, Protected Methods


TnxCurrencyMapper.InternalCreateMapper Method

TnxCurrencyMapper.InternalCreateMapper Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToAnsiChar Method

TnxCurrencyMapper.ToAnsiChar Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToAnsiCharCheck Method

TnxCurrencyMapper.ToAnsiCharCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Description

This is ToAnsiCharCheck, a member of class TnxCurrencyMapper.

Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToBcdCheck Method

TnxCurrencyMapper.ToBcdCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToBcdTrunc Method

TnxCurrencyMapper.ToBcdTrunc Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToBoolean Method

TnxCurrencyMapper.ToBoolean Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToBooleanCheck Method

TnxCurrencyMapper.ToBooleanCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToByte8 Method

TnxCurrencyMapper.ToByte8 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToByteArray Method

TnxCurrencyMapper.ToByteArray Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToByteCheck Method

TnxCurrencyMapper.ToByteCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToCurrency Method

TnxCurrencyMapper.ToCurrency Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToDouble Method

TnxCurrencyMapper.ToDouble Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToDoubleCheck Method

TnxCurrencyMapper.ToDoubleCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToExtended Method

TnxCurrencyMapper.ToExtended Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToExtendedCheck Method

TnxCurrencyMapper.ToExtendedCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt16 Method

TnxCurrencyMapper.ToInt16 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt16Check Method

TnxCurrencyMapper.ToInt16Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt32 Method

TnxCurrencyMapper.ToInt32 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt32Check Method

TnxCurrencyMapper.ToInt32Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt64 Method

TnxCurrencyMapper.ToInt64 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt64Check Method

TnxCurrencyMapper.ToInt64Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt8 Method

TnxCurrencyMapper.ToInt8 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToInt8Check Method

TnxCurrencyMapper.ToInt8Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToNullString Method

TnxCurrencyMapper.ToNullString Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToNullStringCheck Method

TnxCurrencyMapper.ToNullStringCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToShortString Method

TnxCurrencyMapper.ToShortString Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToShortStringCheck Method

TnxCurrencyMapper.ToShortStringCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToSingle Method

TnxCurrencyMapper.ToSingle Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToSingleCheck Method

TnxCurrencyMapper.ToSingleCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWideChar Method

TnxCurrencyMapper.ToWideChar Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWideCharCheck Method

TnxCurrencyMapper.ToWideCharCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWideString Method

TnxCurrencyMapper.ToWideString Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWideStringCheck Method

TnxCurrencyMapper.ToWideStringCheck Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWord16 Method

TnxCurrencyMapper.ToWord16 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWord16Check Method

TnxCurrencyMapper.ToWord16Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWord32 Method

TnxCurrencyMapper.ToWord32 Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxCurrencyMapper.ToWord32Check Method

TnxCurrencyMapper.ToWord32Check Method
TnxCurrencyMapper Class TnxCurrencyMapper Members nxsdFieldMapper Namespace TnxCurrencyMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxCurrencyMapper Methods

Links
TnxCurrencyMapper Class, TnxCurrencyMapper Members, nxsdFieldMapper Namespace, TnxCurrencyMapper Methods


TnxDateMapper Class

TnxDateMapper Class
TnxDateMapper Fields TnxDateMapper Methods TnxDateMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxDateMappernxsdFieldMapper_TnxDateMappernxsdFieldMapper_TnxDateMapper
Syntax
Delphi
TnxDateMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxDateMapper.

Group

Classes

Links
TnxDateMapper Fields, TnxDateMapper Methods, TnxDateMapper Members, nxsdFieldMapper, Classes


TnxDateMapper Members

TnxDateMapper Members
TnxDateMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDateMapper.

Class

TnxDateMapper Class

Protected Fields
Name | Description
dmFormatSettings | This is dmFormatSettings, a member of class TnxDateMapper.
dmSourceType | This is dmSourceType, a member of class TnxDateMapper.
dmTargetField | This is dmTargetField, a member of class TnxDateMapper.
dmTargetLength | This is dmTargetLength, a member of class TnxDateMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToByteArray |
ToDate |
ToDateTime |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToWideString |
ToWideStringCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxDateMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDateMapper.Create Constructor

TnxDateMapper.Create Constructor
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxDateMapper Class

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Class


TnxDateMapper Fields

TnxDateMapper Fields
TnxDateMapper Class Legend Protected Fields Send Feedback

The fields of the TnxDateMapper class are listed here.

Class

TnxDateMapper Class

Protected Fields
Name | Description
dmFormatSettings | This is dmFormatSettings, a member of class TnxDateMapper.
dmSourceType | This is dmSourceType, a member of class TnxDateMapper.
dmTargetField | This is dmTargetField, a member of class TnxDateMapper.
dmTargetLength | This is dmTargetLength, a member of class TnxDateMapper.
Links
TnxDateMapper Class, Legend, Protected Fields


TnxDateMapper.dmFormatSettings Field

TnxDateMapper.dmFormatSettings Field
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Fields Send Feedback
Syntax
Delphi
dmFormatSettings: TFormatSettings;
Description

This is dmFormatSettings, a member of class TnxDateMapper.

Group

TnxDateMapper Fields

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Fields


TnxDateMapper.dmSourceType Field

TnxDateMapper.dmSourceType Field
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Fields Send Feedback
Syntax
Delphi
dmSourceType: TnxFieldType;
Description

This is dmSourceType, a member of class TnxDateMapper.

Group

TnxDateMapper Fields

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Fields


TnxDateMapper.dmTargetField Field

TnxDateMapper.dmTargetField Field
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Fields Send Feedback
Syntax
Delphi
dmTargetField: TnxFieldDescriptor;
Description

This is dmTargetField, a member of class TnxDateMapper.

Group

TnxDateMapper Fields

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Fields


TnxDateMapper.dmTargetLength Field

TnxDateMapper.dmTargetLength Field
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Fields Send Feedback
Syntax
Delphi
dmTargetLength: Integer;
Description

This is dmTargetLength, a member of class TnxDateMapper.

Group

TnxDateMapper Fields

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Fields


TnxDateMapper Methods

TnxDateMapper Methods
TnxDateMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDateMapper class are listed here.

Class

TnxDateMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToByteArray |
ToDate |
ToDateTime |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToWideString |
ToWideStringCheck |
Links
TnxDateMapper Class, Legend, Protected Methods


TnxDateMapper.InternalCreateMapper Method

TnxDateMapper.InternalCreateMapper Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToByteArray Method

TnxDateMapper.ToByteArray Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToDate Method

TnxDateMapper.ToDate Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
class function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToDateTime Method

TnxDateMapper.ToDateTime Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
class function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToNullString Method

TnxDateMapper.ToNullString Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToNullStringCheck Method

TnxDateMapper.ToNullStringCheck Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToShortString Method

TnxDateMapper.ToShortString Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToShortStringCheck Method

TnxDateMapper.ToShortStringCheck Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToTime Method

TnxDateMapper.ToTime Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToWideString Method

TnxDateMapper.ToWideString Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateMapper.ToWideStringCheck Method

TnxDateMapper.ToWideStringCheck Method
TnxDateMapper Class TnxDateMapper Members nxsdFieldMapper Namespace TnxDateMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateMapper Methods

Links
TnxDateMapper Class, TnxDateMapper Members, nxsdFieldMapper Namespace, TnxDateMapper Methods


TnxDateTimeMapper Class

TnxDateTimeMapper Class
TnxDateTimeMapper Fields TnxDateTimeMapper Methods TnxDateTimeMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxDateTimeMappernxsdFieldMapper_TnxDateTimeMappernxsdFieldMapper_TnxDateTimeMapper
Syntax
Delphi
TnxDateTimeMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxDateTimeMapper.

Group

Classes

Links
TnxDateTimeMapper Fields, TnxDateTimeMapper Methods, TnxDateTimeMapper Members, nxsdFieldMapper, Classes


TnxDateTimeMapper Members

TnxDateTimeMapper Members
TnxDateTimeMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDateTimeMapper.

Class

TnxDateTimeMapper Class

Protected Fields
Name | Description
dtmFormatSettings | This is dtmFormatSettings, a member of class TnxDateTimeMapper.
dtmSourceType | This is dtmSourceType, a member of class TnxDateTimeMapper.
dtmTargetLength | This is dtmTargetLength, a member of class TnxDateTimeMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToByteArray |
ToDate |
ToDateCheck |
ToDateTime |
ToDouble |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToTimeCheck |
ToWideString |
ToWideStringCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxDateTimeMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDateTimeMapper.Create Constructor

TnxDateTimeMapper.Create Constructor
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxDateTimeMapper Class

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Class


TnxDateTimeMapper Fields

TnxDateTimeMapper Fields
TnxDateTimeMapper Class Legend Protected Fields Send Feedback

The fields of the TnxDateTimeMapper class are listed here.

Class

TnxDateTimeMapper Class

Protected Fields
Name | Description
dtmFormatSettings | This is dtmFormatSettings, a member of class TnxDateTimeMapper.
dtmSourceType | This is dtmSourceType, a member of class TnxDateTimeMapper.
dtmTargetLength | This is dtmTargetLength, a member of class TnxDateTimeMapper.
Links
TnxDateTimeMapper Class, Legend, Protected Fields


TnxDateTimeMapper.dtmFormatSettings Field

TnxDateTimeMapper.dtmFormatSettings Field
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Fields Send Feedback
Syntax
Delphi
dtmFormatSettings: TFormatSettings;
Description

This is dtmFormatSettings, a member of class TnxDateTimeMapper.

Group

TnxDateTimeMapper Fields

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Fields


TnxDateTimeMapper.dtmSourceType Field

TnxDateTimeMapper.dtmSourceType Field
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Fields Send Feedback
Syntax
Delphi
dtmSourceType: TnxFieldType;
Description

This is dtmSourceType, a member of class TnxDateTimeMapper.

Group

TnxDateTimeMapper Fields

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Fields


TnxDateTimeMapper.dtmTargetLength Field

TnxDateTimeMapper.dtmTargetLength Field
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Fields Send Feedback
Syntax
Delphi
dtmTargetLength: Integer;
Description

This is dtmTargetLength, a member of class TnxDateTimeMapper.

Group

TnxDateTimeMapper Fields

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Fields


TnxDateTimeMapper Methods

TnxDateTimeMapper Methods
TnxDateTimeMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDateTimeMapper class are listed here.

Class

TnxDateTimeMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToByteArray |
ToDate |
ToDateCheck |
ToDateTime |
ToDouble |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToTimeCheck |
ToWideString |
ToWideStringCheck |
Links
TnxDateTimeMapper Class, Legend, Protected Methods


TnxDateTimeMapper.InternalCreateMapper Method

TnxDateTimeMapper.InternalCreateMapper Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToByteArray Method

TnxDateTimeMapper.ToByteArray Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToDate Method

TnxDateTimeMapper.ToDate Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToDateCheck Method

TnxDateTimeMapper.ToDateCheck Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToDateCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToDateTime Method

TnxDateTimeMapper.ToDateTime Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToDouble Method

TnxDateTimeMapper.ToDouble Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToNullString Method

TnxDateTimeMapper.ToNullString Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToNullStringCheck Method

TnxDateTimeMapper.ToNullStringCheck Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToShortString Method

TnxDateTimeMapper.ToShortString Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToShortStringCheck Method

TnxDateTimeMapper.ToShortStringCheck Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToTime Method

TnxDateTimeMapper.ToTime Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToTimeCheck Method

TnxDateTimeMapper.ToTimeCheck Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToWideString Method

TnxDateTimeMapper.ToWideString Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDateTimeMapper.ToWideStringCheck Method

TnxDateTimeMapper.ToWideStringCheck Method
TnxDateTimeMapper Class TnxDateTimeMapper Members nxsdFieldMapper Namespace TnxDateTimeMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDateTimeMapper Methods

Links
TnxDateTimeMapper Class, TnxDateTimeMapper Members, nxsdFieldMapper Namespace, TnxDateTimeMapper Methods


TnxDoubleMapper Class

TnxDoubleMapper Class
TnxDoubleMapper Fields TnxDoubleMapper Methods TnxDoubleMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxDoubleMappernxsdFieldMapper_TnxDoubleMappernxsdFieldMapper_TnxDoubleMapper
Syntax
Delphi
TnxDoubleMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxDoubleMapper.

Group

Classes

Links
TnxDoubleMapper Fields, TnxDoubleMapper Methods, TnxDoubleMapper Members, nxsdFieldMapper, Classes


TnxDoubleMapper Members

TnxDoubleMapper Members
TnxDoubleMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxDoubleMapper.

Class

TnxDoubleMapper Class

Protected Fields
Name | Description
dmFormatSettings | This is dmFormatSettings, a member of class TnxDoubleMapper.
dmTargetDecPl | This is dmTargetDecPl, a member of class TnxDoubleMapper.
dmTargetLength | This is dmTargetLength, a member of class TnxDoubleMapper.
dmTargetUnits | This is dmTargetUnits, a member of class TnxDoubleMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDateTime |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxDoubleMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxDoubleMapper.Create Constructor

TnxDoubleMapper.Create Constructor
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxDoubleMapper Class

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Class


TnxDoubleMapper Fields

TnxDoubleMapper Fields
TnxDoubleMapper Class Legend Protected Fields Send Feedback

The fields of the TnxDoubleMapper class are listed here.

Class

TnxDoubleMapper Class

Protected Fields
Name | Description
dmFormatSettings | This is dmFormatSettings, a member of class TnxDoubleMapper.
dmTargetDecPl | This is dmTargetDecPl, a member of class TnxDoubleMapper.
dmTargetLength | This is dmTargetLength, a member of class TnxDoubleMapper.
dmTargetUnits | This is dmTargetUnits, a member of class TnxDoubleMapper.
Links
TnxDoubleMapper Class, Legend, Protected Fields


TnxDoubleMapper.dmFormatSettings Field

TnxDoubleMapper.dmFormatSettings Field
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Fields Send Feedback
Syntax
Delphi
dmFormatSettings: TFormatSettings;
Description

This is dmFormatSettings, a member of class TnxDoubleMapper.

Group

TnxDoubleMapper Fields

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Fields


TnxDoubleMapper.dmTargetDecPl Field

TnxDoubleMapper.dmTargetDecPl Field
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Fields Send Feedback
Syntax
Delphi
dmTargetDecPl: Integer;
Description

This is dmTargetDecPl, a member of class TnxDoubleMapper.

Group

TnxDoubleMapper Fields

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Fields


TnxDoubleMapper.dmTargetLength Field

TnxDoubleMapper.dmTargetLength Field
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Fields Send Feedback
Syntax
Delphi
dmTargetLength: Integer;
Description

This is dmTargetLength, a member of class TnxDoubleMapper.

Group

TnxDoubleMapper Fields

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Fields


TnxDoubleMapper.dmTargetUnits Field

TnxDoubleMapper.dmTargetUnits Field
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Fields Send Feedback
Syntax
Delphi
dmTargetUnits: Integer;
Description

This is dmTargetUnits, a member of class TnxDoubleMapper.

Group

TnxDoubleMapper Fields

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Fields


TnxDoubleMapper Methods

TnxDoubleMapper Methods
TnxDoubleMapper Class Legend Protected Methods Send Feedback

The methods of the TnxDoubleMapper class are listed here.

Class

TnxDoubleMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDateTime |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxDoubleMapper Class, Legend, Protected Methods


TnxDoubleMapper.InternalCreateMapper Method

TnxDoubleMapper.InternalCreateMapper Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToAnsiChar Method

TnxDoubleMapper.ToAnsiChar Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToAnsiCharCheck Method

TnxDoubleMapper.ToAnsiCharCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToBcdCheck Method

TnxDoubleMapper.ToBcdCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToBcdTrunc Method

TnxDoubleMapper.ToBcdTrunc Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToBoolean Method

TnxDoubleMapper.ToBoolean Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToBooleanCheck Method

TnxDoubleMapper.ToBooleanCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToByte8 Method

TnxDoubleMapper.ToByte8 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToByteArray Method

TnxDoubleMapper.ToByteArray Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToByteCheck Method

TnxDoubleMapper.ToByteCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToCurrency Method

TnxDoubleMapper.ToCurrency Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToCurrencyCheck Method

TnxDoubleMapper.ToCurrencyCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToDateTime Method

TnxDoubleMapper.ToDateTime Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToDouble Method

TnxDoubleMapper.ToDouble Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToExtended Method

TnxDoubleMapper.ToExtended Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt16 Method

TnxDoubleMapper.ToInt16 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt16Check Method

TnxDoubleMapper.ToInt16Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt32 Method

TnxDoubleMapper.ToInt32 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt32Check Method

TnxDoubleMapper.ToInt32Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt64 Method

TnxDoubleMapper.ToInt64 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt64Check Method

TnxDoubleMapper.ToInt64Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt8 Method

TnxDoubleMapper.ToInt8 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToInt8Check Method

TnxDoubleMapper.ToInt8Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToNullString Method

TnxDoubleMapper.ToNullString Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToNullStringCheck Method

TnxDoubleMapper.ToNullStringCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToShortString Method

TnxDoubleMapper.ToShortString Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToShortStringCheck Method

TnxDoubleMapper.ToShortStringCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToSingle Method

TnxDoubleMapper.ToSingle Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToSingleCheck Method

TnxDoubleMapper.ToSingleCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWideChar Method

TnxDoubleMapper.ToWideChar Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWideCharCheck Method

TnxDoubleMapper.ToWideCharCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWideString Method

TnxDoubleMapper.ToWideString Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWideStringCheck Method

TnxDoubleMapper.ToWideStringCheck Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWord16 Method

TnxDoubleMapper.ToWord16 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWord16Check Method

TnxDoubleMapper.ToWord16Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWord32 Method

TnxDoubleMapper.ToWord32 Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxDoubleMapper.ToWord32Check Method

TnxDoubleMapper.ToWord32Check Method
TnxDoubleMapper Class TnxDoubleMapper Members nxsdFieldMapper Namespace TnxDoubleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxDoubleMapper Methods

Links
TnxDoubleMapper Class, TnxDoubleMapper Members, nxsdFieldMapper Namespace, TnxDoubleMapper Methods


TnxExtendedMapper Class

TnxExtendedMapper Class
TnxExtendedMapper Fields TnxExtendedMapper Methods TnxExtendedMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxExtendedMappernxsdFieldMapper_TnxExtendedMappernxsdFieldMapper_TnxExtendedMapper
Syntax
Delphi
TnxExtendedMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxExtendedMapper.

Group

Classes

Links
TnxExtendedMapper Fields, TnxExtendedMapper Methods, TnxExtendedMapper Members, nxsdFieldMapper, Classes


TnxExtendedMapper Members

TnxExtendedMapper Members
TnxExtendedMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxExtendedMapper.

Class

TnxExtendedMapper Class

Protected Fields
Name | Description
emFormatSettings | This is emFormatSettings, a member of class TnxExtendedMapper.
emTargetDecPl | This is emTargetDecPl, a member of class TnxExtendedMapper.
emTargetLength | This is emTargetLength, a member of class TnxExtendedMapper.
emTargetUnits | This is emTargetUnits, a member of class TnxExtendedMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxExtendedMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxExtendedMapper.Create Constructor

TnxExtendedMapper.Create Constructor
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxExtendedMapper Class

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Class


TnxExtendedMapper Fields

TnxExtendedMapper Fields
TnxExtendedMapper Class Legend Protected Fields Send Feedback

The fields of the TnxExtendedMapper class are listed here.

Class

TnxExtendedMapper Class

Protected Fields
Name | Description
emFormatSettings | This is emFormatSettings, a member of class TnxExtendedMapper.
emTargetDecPl | This is emTargetDecPl, a member of class TnxExtendedMapper.
emTargetLength | This is emTargetLength, a member of class TnxExtendedMapper.
emTargetUnits | This is emTargetUnits, a member of class TnxExtendedMapper.
Links
TnxExtendedMapper Class, Legend, Protected Fields


TnxExtendedMapper.emFormatSettings Field

TnxExtendedMapper.emFormatSettings Field
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Fields Send Feedback
Syntax
Delphi
emFormatSettings: TFormatSettings;
Description

This is emFormatSettings, a member of class TnxExtendedMapper.

Group

TnxExtendedMapper Fields

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Fields


TnxExtendedMapper.emTargetDecPl Field

TnxExtendedMapper.emTargetDecPl Field
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Fields Send Feedback
Syntax
Delphi
emTargetDecPl: Integer;
Description

This is emTargetDecPl, a member of class TnxExtendedMapper.

Group

TnxExtendedMapper Fields

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Fields


TnxExtendedMapper.emTargetLength Field

TnxExtendedMapper.emTargetLength Field
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Fields Send Feedback
Syntax
Delphi
emTargetLength: Integer;
Description

This is emTargetLength, a member of class TnxExtendedMapper.

Group

TnxExtendedMapper Fields

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Fields


TnxExtendedMapper.emTargetUnits Field

TnxExtendedMapper.emTargetUnits Field
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Fields Send Feedback
Syntax
Delphi
emTargetUnits: Integer;
Description

This is emTargetUnits, a member of class TnxExtendedMapper.

Group

TnxExtendedMapper Fields

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Fields


TnxExtendedMapper Methods

TnxExtendedMapper Methods
TnxExtendedMapper Class Legend Protected Methods Send Feedback

The methods of the TnxExtendedMapper class are listed here.

Class

TnxExtendedMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxExtendedMapper Class, Legend, Protected Methods


TnxExtendedMapper.InternalCreateMapper Method

TnxExtendedMapper.InternalCreateMapper Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToAnsiChar Method

TnxExtendedMapper.ToAnsiChar Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToAnsiCharCheck Method

TnxExtendedMapper.ToAnsiCharCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToBcdCheck Method

TnxExtendedMapper.ToBcdCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToBcdTrunc Method

TnxExtendedMapper.ToBcdTrunc Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToBoolean Method

TnxExtendedMapper.ToBoolean Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToBooleanCheck Method

TnxExtendedMapper.ToBooleanCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToByte8 Method

TnxExtendedMapper.ToByte8 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToByteArray Method

TnxExtendedMapper.ToByteArray Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToByteCheck Method

TnxExtendedMapper.ToByteCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToCurrency Method

TnxExtendedMapper.ToCurrency Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToCurrencyCheck Method

TnxExtendedMapper.ToCurrencyCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToDouble Method

TnxExtendedMapper.ToDouble Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToDoubleCheck Method

TnxExtendedMapper.ToDoubleCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToExtended Method

TnxExtendedMapper.ToExtended Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt16 Method

TnxExtendedMapper.ToInt16 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt16Check Method

TnxExtendedMapper.ToInt16Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt32 Method

TnxExtendedMapper.ToInt32 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt32Check Method

TnxExtendedMapper.ToInt32Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt64 Method

TnxExtendedMapper.ToInt64 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt64Check Method

TnxExtendedMapper.ToInt64Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt8 Method

TnxExtendedMapper.ToInt8 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToInt8Check Method

TnxExtendedMapper.ToInt8Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToNullString Method

TnxExtendedMapper.ToNullString Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToNullStringCheck Method

TnxExtendedMapper.ToNullStringCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToShortString Method

TnxExtendedMapper.ToShortString Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToShortStringCheck Method

TnxExtendedMapper.ToShortStringCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToSingle Method

TnxExtendedMapper.ToSingle Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToSingleCheck Method

TnxExtendedMapper.ToSingleCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWideChar Method

TnxExtendedMapper.ToWideChar Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWideCharCheck Method

TnxExtendedMapper.ToWideCharCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWideString Method

TnxExtendedMapper.ToWideString Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWideStringCheck Method

TnxExtendedMapper.ToWideStringCheck Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWord16 Method

TnxExtendedMapper.ToWord16 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWord16Check Method

TnxExtendedMapper.ToWord16Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWord32 Method

TnxExtendedMapper.ToWord32 Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxExtendedMapper.ToWord32Check Method

TnxExtendedMapper.ToWord32Check Method
TnxExtendedMapper Class TnxExtendedMapper Members nxsdFieldMapper Namespace TnxExtendedMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxExtendedMapper Methods

Links
TnxExtendedMapper Class, TnxExtendedMapper Members, nxsdFieldMapper Namespace, TnxExtendedMapper Methods


TnxFmtBCDMapper Class

TnxFmtBCDMapper Class
TnxFmtBCDMapper Fields TnxFmtBCDMapper Methods TnxFmtBCDMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxFmtBCDMappernxsdFieldMapper_TnxFmtBCDMappernxsdFieldMapper_TnxFmtBCDMapper
Syntax
Delphi
TnxFmtBCDMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxFmtBCDMapper.

Group

Classes

Links
TnxFmtBCDMapper Fields, TnxFmtBCDMapper Methods, TnxFmtBCDMapper Members, nxsdFieldMapper, Classes


TnxFmtBCDMapper Members

TnxFmtBCDMapper Members
TnxFmtBCDMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFmtBCDMapper.

Class

TnxFmtBCDMapper Class

Protected Fields
Name | Description
fbmSourceDecPl | This is fbmSourceDecPl, a member of class TnxFmtBCDMapper.
fbmSourceFormatSettings | This is fbmSourceFormatSettings, a member of class TnxFmtBCDMapper.
fbmSourceLength | This is fbmSourceLength, a member of class TnxFmtBCDMapper.
fbmSourceType | This is fbmSourceType, a member of class TnxFmtBCDMapper.
fbmSourceUnits | This is fbmSourceUnits, a member of class TnxFmtBCDMapper.
fbmTargetDecPl | This is fbmTargetDecPl, a member of class TnxFmtBCDMapper.
fbmTargetFormatSettings | This is fbmTargetFormatSettings, a member of class TnxFmtBCDMapper.
fbmTargetLength | This is fbmTargetLength, a member of class TnxFmtBCDMapper.
fbmTargetMaxInt | This is fbmTargetMaxInt, a member of class TnxFmtBCDMapper.
fbmTargetMinInt | This is fbmTargetMinInt, a member of class TnxFmtBCDMapper.
fbmTargetType | This is fbmTargetType, a member of class TnxFmtBCDMapper.
fbmTargetUnits | This is fbmTargetUnits, a member of class TnxFmtBCDMapper.
Protected Methods
Name | Description
Create | TnxFmtBCDMapper
FromBcdCheck | This is FromBcdCheck, a member of class TnxFmtBCDMapper.
FromBcdTrunc | This is FromBcdTrunc, a member of class TnxFmtBCDMapper.
FromFloatCheck | This is FromFloatCheck, a member of class TnxFmtBCDMapper.
FromFloatTrunc | This is FromFloatTrunc, a member of class TnxFmtBCDMapper.
FromIntegerCheck | This is FromIntegerCheck, a member of class TnxFmtBCDMapper.
FromIntegerTrunc | This is FromIntegerTrunc, a member of class TnxFmtBCDMapper.
InternalCreateMapper |
Register |
ToBcdCheck | This is ToBcdCheck, a member of class TnxFmtBCDMapper.
ToBcdTrunc | This is ToBcdTrunc, a member of class TnxFmtBCDMapper.
ToFloatCheck | This is ToFloatCheck, a member of class TnxFmtBCDMapper.
ToFloatTrunc | This is ToFloatTrunc, a member of class TnxFmtBCDMapper.
ToFmtBcdCheck | This is ToFmtBcdCheck, a member of class TnxFmtBCDMapper.
ToFmtBcdCopy | This is ToFmtBcdCopy, a member of class TnxFmtBCDMapper.
ToFmtBcdTrunc | This is ToFmtBcdTrunc, a member of class TnxFmtBCDMapper.
ToIntegerCheck | This is ToIntegerCheck, a member of class TnxFmtBCDMapper.
ToIntegerTrunc | This is ToIntegerTrunc, a member of class TnxFmtBCDMapper.
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxFmtBCDMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxFmtBCDMapper.Create Constructor

TnxFmtBCDMapper.Create Constructor
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Description

TnxFmtBCDMapper

Class

TnxFmtBCDMapper Class

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Class


TnxFmtBCDMapper Fields

TnxFmtBCDMapper Fields
TnxFmtBCDMapper Class Legend Protected Fields Send Feedback

The fields of the TnxFmtBCDMapper class are listed here.

Class

TnxFmtBCDMapper Class

Protected Fields
Name | Description
fbmSourceDecPl | This is fbmSourceDecPl, a member of class TnxFmtBCDMapper.
fbmSourceFormatSettings | This is fbmSourceFormatSettings, a member of class TnxFmtBCDMapper.
fbmSourceLength | This is fbmSourceLength, a member of class TnxFmtBCDMapper.
fbmSourceType | This is fbmSourceType, a member of class TnxFmtBCDMapper.
fbmSourceUnits | This is fbmSourceUnits, a member of class TnxFmtBCDMapper.
fbmTargetDecPl | This is fbmTargetDecPl, a member of class TnxFmtBCDMapper.
fbmTargetFormatSettings | This is fbmTargetFormatSettings, a member of class TnxFmtBCDMapper.
fbmTargetLength | This is fbmTargetLength, a member of class TnxFmtBCDMapper.
fbmTargetMaxInt | This is fbmTargetMaxInt, a member of class TnxFmtBCDMapper.
fbmTargetMinInt | This is fbmTargetMinInt, a member of class TnxFmtBCDMapper.
fbmTargetType | This is fbmTargetType, a member of class TnxFmtBCDMapper.
fbmTargetUnits | This is fbmTargetUnits, a member of class TnxFmtBCDMapper.
Links
TnxFmtBCDMapper Class, Legend, Protected Fields


TnxFmtBCDMapper.fbmSourceDecPl Field

TnxFmtBCDMapper.fbmSourceDecPl Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmSourceDecPl: Integer;
Description

This is fbmSourceDecPl, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmSourceFormatSettings Field

TnxFmtBCDMapper.fbmSourceFormatSettings Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmSourceFormatSettings: TFormatSettings;
Description

This is fbmSourceFormatSettings, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmSourceLength Field

TnxFmtBCDMapper.fbmSourceLength Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmSourceLength: Integer;
Description

This is fbmSourceLength, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmSourceType Field

TnxFmtBCDMapper.fbmSourceType Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmSourceType: TnxFieldType;
Description

This is fbmSourceType, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmSourceUnits Field

TnxFmtBCDMapper.fbmSourceUnits Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmSourceUnits: Integer;
Description

This is fbmSourceUnits, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetDecPl Field

TnxFmtBCDMapper.fbmTargetDecPl Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetDecPl: Integer;
Description

This is fbmTargetDecPl, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetFormatSettings Field

TnxFmtBCDMapper.fbmTargetFormatSettings Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetFormatSettings: TFormatSettings;
Description

This is fbmTargetFormatSettings, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetLength Field

TnxFmtBCDMapper.fbmTargetLength Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetLength: Integer;
Description

This is fbmTargetLength, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetMaxInt Field

TnxFmtBCDMapper.fbmTargetMaxInt Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetMaxInt: Int64;
Description

This is fbmTargetMaxInt, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetMinInt Field

TnxFmtBCDMapper.fbmTargetMinInt Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetMinInt: Int64;
Description

This is fbmTargetMinInt, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetType Field

TnxFmtBCDMapper.fbmTargetType Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetType: TnxFieldType;
Description

This is fbmTargetType, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper.fbmTargetUnits Field

TnxFmtBCDMapper.fbmTargetUnits Field
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Fields Send Feedback
Syntax
Delphi
fbmTargetUnits: Integer;
Description

This is fbmTargetUnits, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Fields

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Fields


TnxFmtBCDMapper Methods

TnxFmtBCDMapper Methods
TnxFmtBCDMapper Class Legend Protected Methods Send Feedback

The methods of the TnxFmtBCDMapper class are listed here.

Class

TnxFmtBCDMapper Class

Protected Methods
Name | Description
FromBcdCheck | This is FromBcdCheck, a member of class TnxFmtBCDMapper.
FromBcdTrunc | This is FromBcdTrunc, a member of class TnxFmtBCDMapper.
FromFloatCheck | This is FromFloatCheck, a member of class TnxFmtBCDMapper.
FromFloatTrunc | This is FromFloatTrunc, a member of class TnxFmtBCDMapper.
FromIntegerCheck | This is FromIntegerCheck, a member of class TnxFmtBCDMapper.
FromIntegerTrunc | This is FromIntegerTrunc, a member of class TnxFmtBCDMapper.
InternalCreateMapper |
ToBcdCheck | This is ToBcdCheck, a member of class TnxFmtBCDMapper.
ToBcdTrunc | This is ToBcdTrunc, a member of class TnxFmtBCDMapper.
ToFloatCheck | This is ToFloatCheck, a member of class TnxFmtBCDMapper.
ToFloatTrunc | This is ToFloatTrunc, a member of class TnxFmtBCDMapper.
ToFmtBcdCheck | This is ToFmtBcdCheck, a member of class TnxFmtBCDMapper.
ToFmtBcdCopy | This is ToFmtBcdCopy, a member of class TnxFmtBCDMapper.
ToFmtBcdTrunc | This is ToFmtBcdTrunc, a member of class TnxFmtBCDMapper.
ToIntegerCheck | This is ToIntegerCheck, a member of class TnxFmtBCDMapper.
ToIntegerTrunc | This is ToIntegerTrunc, a member of class TnxFmtBCDMapper.
Links
TnxFmtBCDMapper Class, Legend, Protected Methods


TnxFmtBCDMapper.FromBcdCheck Method

TnxFmtBCDMapper.FromBcdCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromBcdCheck(const aSource; var aTarget): TnxResult;
Description

This is FromBcdCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.FromBcdTrunc Method

TnxFmtBCDMapper.FromBcdTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromBcdTrunc(const aSource; var aTarget): TnxResult;
Description

This is FromBcdTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.FromFloatCheck Method

TnxFmtBCDMapper.FromFloatCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromFloatCheck(const aSource; var aTarget): TnxResult;
Description

This is FromFloatCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.FromFloatTrunc Method

TnxFmtBCDMapper.FromFloatTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromFloatTrunc(const aSource; var aTarget): TnxResult;
Description

This is FromFloatTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.FromIntegerCheck Method

TnxFmtBCDMapper.FromIntegerCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromIntegerCheck(const aSource; var aTarget): TnxResult;
Description

This is FromIntegerCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.FromIntegerTrunc Method

TnxFmtBCDMapper.FromIntegerTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function FromIntegerTrunc(const aSource; var aTarget): TnxResult;
Description

This is FromIntegerTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.InternalCreateMapper Method

TnxFmtBCDMapper.InternalCreateMapper Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToBcdCheck Method

TnxFmtBCDMapper.ToBcdCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Description

This is ToBcdCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToBcdTrunc Method

TnxFmtBCDMapper.ToBcdTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Description

This is ToBcdTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToFloatCheck Method

TnxFmtBCDMapper.ToFloatCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToFloatCheck(const aSource; var aTarget): TnxResult;
Description

This is ToFloatCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToFloatTrunc Method

TnxFmtBCDMapper.ToFloatTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToFloatTrunc(const aSource; var aTarget): TnxResult;
Description

This is ToFloatTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToFmtBcdCheck Method

TnxFmtBCDMapper.ToFmtBcdCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToFmtBcdCheck(const aSource; var aTarget): TnxResult;
Description

This is ToFmtBcdCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToFmtBcdCopy Method

TnxFmtBCDMapper.ToFmtBcdCopy Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToFmtBcdCopy(const aSource; var aTarget): TnxResult;
Description

This is ToFmtBcdCopy, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToFmtBcdTrunc Method

TnxFmtBCDMapper.ToFmtBcdTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToFmtBcdTrunc(const aSource; var aTarget): TnxResult;
Description

This is ToFmtBcdTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToIntegerCheck Method

TnxFmtBCDMapper.ToIntegerCheck Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToIntegerCheck(const aSource; var aTarget): TnxResult;
Description

This is ToIntegerCheck, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxFmtBCDMapper.ToIntegerTrunc Method

TnxFmtBCDMapper.ToIntegerTrunc Method
TnxFmtBCDMapper Class TnxFmtBCDMapper Members nxsdFieldMapper Namespace TnxFmtBCDMapper Methods Send Feedback
Syntax
Delphi
function ToIntegerTrunc(const aSource; var aTarget): TnxResult;
Description

This is ToIntegerTrunc, a member of class TnxFmtBCDMapper.

Group

TnxFmtBCDMapper Methods

Links
TnxFmtBCDMapper Class, TnxFmtBCDMapper Members, nxsdFieldMapper Namespace, TnxFmtBCDMapper Methods


TnxGuidMapper Class

TnxGuidMapper Class
TnxGuidMapper Fields TnxGuidMapper Methods TnxGuidMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxGuidMappernxsdFieldMapper_TnxGuidMappernxsdFieldMapper_TnxGuidMapper
Syntax
Delphi
TnxGuidMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxGuidMapper.

Group

Classes

Links
TnxGuidMapper Fields, TnxGuidMapper Methods, TnxGuidMapper Members, nxsdFieldMapper, Classes


TnxGuidMapper Members

TnxGuidMapper Members
TnxGuidMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxGuidMapper.

Class

TnxGuidMapper Class

Protected Fields
Name | Description
gmFormatSettings | This is gmFormatSettings, a member of class TnxGuidMapper.
gmTargetLength | This is gmTargetLength, a member of class TnxGuidMapper.
Protected Methods
Name | Description
InternalCreateMapper | TnxGuidMapper
Register |
ToByteArray |
ToGuid |
ToNullString |
ToShortString |
ToWideString |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxGuidMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxGuidMapper Fields

TnxGuidMapper Fields
TnxGuidMapper Class Legend Protected Fields Send Feedback

The fields of the TnxGuidMapper class are listed here.

Class

TnxGuidMapper Class

Protected Fields
Name | Description
gmFormatSettings | This is gmFormatSettings, a member of class TnxGuidMapper.
gmTargetLength | This is gmTargetLength, a member of class TnxGuidMapper.
Links
TnxGuidMapper Class, Legend, Protected Fields


TnxGuidMapper.gmFormatSettings Field

TnxGuidMapper.gmFormatSettings Field
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Fields Send Feedback
Syntax
Delphi
gmFormatSettings: TFormatSettings;
Description

This is gmFormatSettings, a member of class TnxGuidMapper.

Group

TnxGuidMapper Fields

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Fields


TnxGuidMapper.gmTargetLength Field

TnxGuidMapper.gmTargetLength Field
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Fields Send Feedback
Syntax
Delphi
gmTargetLength: Integer;
Description

This is gmTargetLength, a member of class TnxGuidMapper.

Group

TnxGuidMapper Fields

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Fields


TnxGuidMapper Methods

TnxGuidMapper Methods
TnxGuidMapper Class Legend Protected Methods Send Feedback

The methods of the TnxGuidMapper class are listed here.

Class

TnxGuidMapper Class

Protected Methods
Name | Description
InternalCreateMapper | TnxGuidMapper
ToByteArray |
ToGuid |
ToNullString |
ToShortString |
ToWideString |
Links
TnxGuidMapper Class, Legend, Protected Methods


TnxGuidMapper.InternalCreateMapper Method

TnxGuidMapper.InternalCreateMapper Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Description

TnxGuidMapper

Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxGuidMapper.ToByteArray Method

TnxGuidMapper.ToByteArray Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxGuidMapper.ToGuid Method

TnxGuidMapper.ToGuid Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function ToGuid(const aSource; var aTarget): TnxResult;
Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxGuidMapper.ToNullString Method

TnxGuidMapper.ToNullString Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxGuidMapper.ToShortString Method

TnxGuidMapper.ToShortString Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxGuidMapper.ToWideString Method

TnxGuidMapper.ToWideString Method
TnxGuidMapper Class TnxGuidMapper Members nxsdFieldMapper Namespace TnxGuidMapper Methods Send Feedback
Syntax
Delphi
class function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxGuidMapper Methods

Links
TnxGuidMapper Class, TnxGuidMapper Members, nxsdFieldMapper Namespace, TnxGuidMapper Methods


TnxInt16Mapper Class

TnxInt16Mapper Class
TnxInt16Mapper Fields TnxInt16Mapper Methods TnxInt16Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxInt16MappernxsdFieldMapper_TnxInt16MappernxsdFieldMapper_TnxInt16Mapper
Syntax
Delphi
TnxInt16Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxInt16Mapper.

Group

Classes

Links
TnxInt16Mapper Fields, TnxInt16Mapper Methods, TnxInt16Mapper Members, nxsdFieldMapper, Classes


TnxInt16Mapper Members

TnxInt16Mapper Members
TnxInt16Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt16Mapper.

Class

TnxInt16Mapper Class

Protected Fields
Name | Description
i16mTargetDecPl | This is i16mTargetDecPl, a member of class TnxInt16Mapper.
i16mTargetLength | private
i16mTargetUnits | This is i16mTargetUnits, a member of class TnxInt16Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxInt16Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInt16Mapper.Create Constructor

TnxInt16Mapper.Create Constructor
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxInt16Mapper Class

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Class


TnxInt16Mapper Fields

TnxInt16Mapper Fields
TnxInt16Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxInt16Mapper class are listed here.

Class

TnxInt16Mapper Class

Protected Fields
Name | Description
i16mTargetDecPl | This is i16mTargetDecPl, a member of class TnxInt16Mapper.
i16mTargetLength | private
i16mTargetUnits | This is i16mTargetUnits, a member of class TnxInt16Mapper.
Links
TnxInt16Mapper Class, Legend, Protected Fields


TnxInt16Mapper.i16mTargetDecPl Field

TnxInt16Mapper.i16mTargetDecPl Field
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Fields Send Feedback
Syntax
Delphi
i16mTargetDecPl: Integer;
Description

This is i16mTargetDecPl, a member of class TnxInt16Mapper.

Group

TnxInt16Mapper Fields

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Fields


TnxInt16Mapper.i16mTargetLength Field

TnxInt16Mapper.i16mTargetLength Field
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Fields Send Feedback
Syntax
Delphi
i16mTargetLength: Integer;
Description

private

Group

TnxInt16Mapper Fields

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Fields


TnxInt16Mapper.i16mTargetUnits Field

TnxInt16Mapper.i16mTargetUnits Field
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Fields Send Feedback
Syntax
Delphi
i16mTargetUnits: Integer;
Description

This is i16mTargetUnits, a member of class TnxInt16Mapper.

Group

TnxInt16Mapper Fields

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Fields


TnxInt16Mapper Methods

TnxInt16Mapper Methods
TnxInt16Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt16Mapper class are listed here.

Class

TnxInt16Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxInt16Mapper Class, Legend, Protected Methods


TnxInt16Mapper.InternalCreateMapper Method

TnxInt16Mapper.InternalCreateMapper Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToAnsiChar Method

TnxInt16Mapper.ToAnsiChar Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToAnsiCharCheck Method

TnxInt16Mapper.ToAnsiCharCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToBcd Method

TnxInt16Mapper.ToBcd Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToBcdCheck Method

TnxInt16Mapper.ToBcdCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToBcdTrunc Method

TnxInt16Mapper.ToBcdTrunc Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToBoolean Method

TnxInt16Mapper.ToBoolean Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToBooleanCheck Method

TnxInt16Mapper.ToBooleanCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToByte8 Method

TnxInt16Mapper.ToByte8 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToByteArray Method

TnxInt16Mapper.ToByteArray Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToByteCheck Method

TnxInt16Mapper.ToByteCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToCurrency Method

TnxInt16Mapper.ToCurrency Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToDouble Method

TnxInt16Mapper.ToDouble Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToExtended Method

TnxInt16Mapper.ToExtended Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToInt16 Method

TnxInt16Mapper.ToInt16 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToInt32 Method

TnxInt16Mapper.ToInt32 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToInt64 Method

TnxInt16Mapper.ToInt64 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToInt8 Method

TnxInt16Mapper.ToInt8 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToInt8Check Method

TnxInt16Mapper.ToInt8Check Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToNullString Method

TnxInt16Mapper.ToNullString Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToNullStringCheck Method

TnxInt16Mapper.ToNullStringCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToShortString Method

TnxInt16Mapper.ToShortString Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToShortStringCheck Method

TnxInt16Mapper.ToShortStringCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToSingle Method

TnxInt16Mapper.ToSingle Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWideChar Method

TnxInt16Mapper.ToWideChar Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWideCharCheck Method

TnxInt16Mapper.ToWideCharCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWideString Method

TnxInt16Mapper.ToWideString Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWideStringCheck Method

TnxInt16Mapper.ToWideStringCheck Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWord16 Method

TnxInt16Mapper.ToWord16 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWord16Check Method

TnxInt16Mapper.ToWord16Check Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWord32 Method

TnxInt16Mapper.ToWord32 Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt16Mapper.ToWord32Check Method

TnxInt16Mapper.ToWord32Check Method
TnxInt16Mapper Class TnxInt16Mapper Members nxsdFieldMapper Namespace TnxInt16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxInt16Mapper Methods

Links
TnxInt16Mapper Class, TnxInt16Mapper Members, nxsdFieldMapper Namespace, TnxInt16Mapper Methods


TnxInt32Mapper Class

TnxInt32Mapper Class
TnxInt32Mapper Fields TnxInt32Mapper Methods TnxInt32Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxInt32MappernxsdFieldMapper_TnxInt32MappernxsdFieldMapper_TnxInt32Mapper
Syntax
Delphi
TnxInt32Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxInt32Mapper.

Group

Classes

Links
TnxInt32Mapper Fields, TnxInt32Mapper Methods, TnxInt32Mapper Members, nxsdFieldMapper, Classes


TnxInt32Mapper Members

TnxInt32Mapper Members
TnxInt32Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt32Mapper.

Class

TnxInt32Mapper Class

Protected Fields
Name | Description
i32mTargetDecPl | This is i32mTargetDecPl, a member of class TnxInt32Mapper.
i32mTargetLength | private
i32mTargetUnits | This is i32mTargetUnits, a member of class TnxInt32Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxInt32Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInt32Mapper.Create Constructor

TnxInt32Mapper.Create Constructor
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxInt32Mapper Class

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Class


TnxInt32Mapper Fields

TnxInt32Mapper Fields
TnxInt32Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxInt32Mapper class are listed here.

Class

TnxInt32Mapper Class

Protected Fields
Name | Description
i32mTargetDecPl | This is i32mTargetDecPl, a member of class TnxInt32Mapper.
i32mTargetLength | private
i32mTargetUnits | This is i32mTargetUnits, a member of class TnxInt32Mapper.
Links
TnxInt32Mapper Class, Legend, Protected Fields


TnxInt32Mapper.i32mTargetDecPl Field

TnxInt32Mapper.i32mTargetDecPl Field
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Fields Send Feedback
Syntax
Delphi
i32mTargetDecPl: Integer;
Description

This is i32mTargetDecPl, a member of class TnxInt32Mapper.

Group

TnxInt32Mapper Fields

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Fields


TnxInt32Mapper.i32mTargetLength Field

TnxInt32Mapper.i32mTargetLength Field
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Fields Send Feedback
Syntax
Delphi
i32mTargetLength: Integer;
Description

private

Group

TnxInt32Mapper Fields

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Fields


TnxInt32Mapper.i32mTargetUnits Field

TnxInt32Mapper.i32mTargetUnits Field
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Fields Send Feedback
Syntax
Delphi
i32mTargetUnits: Integer;
Description

This is i32mTargetUnits, a member of class TnxInt32Mapper.

Group

TnxInt32Mapper Fields

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Fields


TnxInt32Mapper Methods

TnxInt32Mapper Methods
TnxInt32Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt32Mapper class are listed here.

Class

TnxInt32Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxInt32Mapper Class, Legend, Protected Methods


TnxInt32Mapper.InternalCreateMapper Method

TnxInt32Mapper.InternalCreateMapper Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToAnsiChar Method

TnxInt32Mapper.ToAnsiChar Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToAnsiCharCheck Method

TnxInt32Mapper.ToAnsiCharCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToBcd Method

TnxInt32Mapper.ToBcd Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToBcdCheck Method

TnxInt32Mapper.ToBcdCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToBcdTrunc Method

TnxInt32Mapper.ToBcdTrunc Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToBoolean Method

TnxInt32Mapper.ToBoolean Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToBooleanCheck Method

TnxInt32Mapper.ToBooleanCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToByte8 Method

TnxInt32Mapper.ToByte8 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToByteArray Method

TnxInt32Mapper.ToByteArray Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToByteCheck Method

TnxInt32Mapper.ToByteCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToCurrency Method

TnxInt32Mapper.ToCurrency Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToDouble Method

TnxInt32Mapper.ToDouble Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToExtended Method

TnxInt32Mapper.ToExtended Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt16 Method

TnxInt32Mapper.ToInt16 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt16Check Method

TnxInt32Mapper.ToInt16Check Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt32 Method

TnxInt32Mapper.ToInt32 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt64 Method

TnxInt32Mapper.ToInt64 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt8 Method

TnxInt32Mapper.ToInt8 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToInt8Check Method

TnxInt32Mapper.ToInt8Check Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToNullString Method

TnxInt32Mapper.ToNullString Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToNullStringCheck Method

TnxInt32Mapper.ToNullStringCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToShortString Method

TnxInt32Mapper.ToShortString Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToShortStringCheck Method

TnxInt32Mapper.ToShortStringCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToSingle Method

TnxInt32Mapper.ToSingle Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWideChar Method

TnxInt32Mapper.ToWideChar Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWideCharCheck Method

TnxInt32Mapper.ToWideCharCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWideString Method

TnxInt32Mapper.ToWideString Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWideStringCheck Method

TnxInt32Mapper.ToWideStringCheck Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWord16 Method

TnxInt32Mapper.ToWord16 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWord16Check Method

TnxInt32Mapper.ToWord16Check Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWord32 Method

TnxInt32Mapper.ToWord32 Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt32Mapper.ToWord32Check Method

TnxInt32Mapper.ToWord32Check Method
TnxInt32Mapper Class TnxInt32Mapper Members nxsdFieldMapper Namespace TnxInt32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxInt32Mapper Methods

Links
TnxInt32Mapper Class, TnxInt32Mapper Members, nxsdFieldMapper Namespace, TnxInt32Mapper Methods


TnxInt64Mapper Class

TnxInt64Mapper Class
TnxInt64Mapper Fields TnxInt64Mapper Methods TnxInt64Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxInt64MappernxsdFieldMapper_TnxInt64MappernxsdFieldMapper_TnxInt64Mapper
Syntax
Delphi
TnxInt64Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxInt64Mapper.

Group

Classes

Links
TnxInt64Mapper Fields, TnxInt64Mapper Methods, TnxInt64Mapper Members, nxsdFieldMapper, Classes


TnxInt64Mapper Members

TnxInt64Mapper Members
TnxInt64Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt64Mapper.

Class

TnxInt64Mapper Class

Protected Fields
Name | Description
i64mTargetDecPl | This is i64mTargetDecPl, a member of class TnxInt64Mapper.
i64mTargetLength | private
i64mTargetUnits | This is i64mTargetUnits, a member of class TnxInt64Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxInt64Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInt64Mapper.Create Constructor

TnxInt64Mapper.Create Constructor
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxInt64Mapper Class

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Class


TnxInt64Mapper Fields

TnxInt64Mapper Fields
TnxInt64Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxInt64Mapper class are listed here.

Class

TnxInt64Mapper Class

Protected Fields
Name | Description
i64mTargetDecPl | This is i64mTargetDecPl, a member of class TnxInt64Mapper.
i64mTargetLength | private
i64mTargetUnits | This is i64mTargetUnits, a member of class TnxInt64Mapper.
Links
TnxInt64Mapper Class, Legend, Protected Fields


TnxInt64Mapper.i64mTargetDecPl Field

TnxInt64Mapper.i64mTargetDecPl Field
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Fields Send Feedback
Syntax
Delphi
i64mTargetDecPl: Integer;
Description

This is i64mTargetDecPl, a member of class TnxInt64Mapper.

Group

TnxInt64Mapper Fields

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Fields


TnxInt64Mapper.i64mTargetLength Field

TnxInt64Mapper.i64mTargetLength Field
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Fields Send Feedback
Syntax
Delphi
i64mTargetLength: Integer;
Description

private

Group

TnxInt64Mapper Fields

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Fields


TnxInt64Mapper.i64mTargetUnits Field

TnxInt64Mapper.i64mTargetUnits Field
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Fields Send Feedback
Syntax
Delphi
i64mTargetUnits: Integer;
Description

This is i64mTargetUnits, a member of class TnxInt64Mapper.

Group

TnxInt64Mapper Fields

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Fields


TnxInt64Mapper Methods

TnxInt64Mapper Methods
TnxInt64Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt64Mapper class are listed here.

Class

TnxInt64Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxInt64Mapper Class, Legend, Protected Methods


TnxInt64Mapper.InternalCreateMapper Method

TnxInt64Mapper.InternalCreateMapper Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToAnsiChar Method

TnxInt64Mapper.ToAnsiChar Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToAnsiCharCheck Method

TnxInt64Mapper.ToAnsiCharCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToBcdCheck Method

TnxInt64Mapper.ToBcdCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToBcdTrunc Method

TnxInt64Mapper.ToBcdTrunc Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToBoolean Method

TnxInt64Mapper.ToBoolean Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToBooleanCheck Method

TnxInt64Mapper.ToBooleanCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToByte8 Method

TnxInt64Mapper.ToByte8 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToByteArray Method

TnxInt64Mapper.ToByteArray Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToByteCheck Method

TnxInt64Mapper.ToByteCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToCurrency Method

TnxInt64Mapper.ToCurrency Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToCurrencyCheck Method

TnxInt64Mapper.ToCurrencyCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToDouble Method

TnxInt64Mapper.ToDouble Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToExtended Method

TnxInt64Mapper.ToExtended Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt16 Method

TnxInt64Mapper.ToInt16 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt16Check Method

TnxInt64Mapper.ToInt16Check Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt32 Method

TnxInt64Mapper.ToInt32 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt32Check Method

TnxInt64Mapper.ToInt32Check Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt64 Method

TnxInt64Mapper.ToInt64 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt8 Method

TnxInt64Mapper.ToInt8 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToInt8Check Method

TnxInt64Mapper.ToInt8Check Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToNullString Method

TnxInt64Mapper.ToNullString Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToNullStringCheck Method

TnxInt64Mapper.ToNullStringCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToShortString Method

TnxInt64Mapper.ToShortString Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToShortStringCheck Method

TnxInt64Mapper.ToShortStringCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToSingle Method

TnxInt64Mapper.ToSingle Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWideChar Method

TnxInt64Mapper.ToWideChar Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWideCharCheck Method

TnxInt64Mapper.ToWideCharCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWideString Method

TnxInt64Mapper.ToWideString Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWideStringCheck Method

TnxInt64Mapper.ToWideStringCheck Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWord16 Method

TnxInt64Mapper.ToWord16 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWord16Check Method

TnxInt64Mapper.ToWord16Check Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWord32 Method

TnxInt64Mapper.ToWord32 Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt64Mapper.ToWord32Check Method

TnxInt64Mapper.ToWord32Check Method
TnxInt64Mapper Class TnxInt64Mapper Members nxsdFieldMapper Namespace TnxInt64Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxInt64Mapper Methods

Links
TnxInt64Mapper Class, TnxInt64Mapper Members, nxsdFieldMapper Namespace, TnxInt64Mapper Methods


TnxInt8Mapper Class

TnxInt8Mapper Class
TnxInt8Mapper Fields TnxInt8Mapper Methods TnxInt8Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxInt8MappernxsdFieldMapper_TnxInt8MappernxsdFieldMapper_TnxInt8Mapper
Syntax
Delphi
TnxInt8Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxInt8Mapper.

Group

Classes

Links
TnxInt8Mapper Fields, TnxInt8Mapper Methods, TnxInt8Mapper Members, nxsdFieldMapper, Classes


TnxInt8Mapper Members

TnxInt8Mapper Members
TnxInt8Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxInt8Mapper.

Class

TnxInt8Mapper Class

Protected Fields
Name | Description
i8mTargetDecPl | This is i8mTargetDecPl, a member of class TnxInt8Mapper.
i8mTargetLength | private
i8mTargetUnits | This is i8mTargetUnits, a member of class TnxInt8Mapper.
Protected Methods
Name | Description
Create | This is Create, a member of class TnxInt8Mapper.
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxInt8Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxInt8Mapper.Create Constructor

TnxInt8Mapper.Create Constructor
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Description

This is Create, a member of class TnxInt8Mapper.

Class

TnxInt8Mapper Class

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Class


TnxInt8Mapper Fields

TnxInt8Mapper Fields
TnxInt8Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxInt8Mapper class are listed here.

Class

TnxInt8Mapper Class

Protected Fields
Name | Description
i8mTargetDecPl | This is i8mTargetDecPl, a member of class TnxInt8Mapper.
i8mTargetLength | private
i8mTargetUnits | This is i8mTargetUnits, a member of class TnxInt8Mapper.
Links
TnxInt8Mapper Class, Legend, Protected Fields


TnxInt8Mapper.i8mTargetDecPl Field

TnxInt8Mapper.i8mTargetDecPl Field
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Fields Send Feedback
Syntax
Delphi
i8mTargetDecPl: Integer;
Description

This is i8mTargetDecPl, a member of class TnxInt8Mapper.

Group

TnxInt8Mapper Fields

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Fields


TnxInt8Mapper.i8mTargetLength Field

TnxInt8Mapper.i8mTargetLength Field
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Fields Send Feedback
Syntax
Delphi
i8mTargetLength: Integer;
Description

private

Group

TnxInt8Mapper Fields

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Fields


TnxInt8Mapper.i8mTargetUnits Field

TnxInt8Mapper.i8mTargetUnits Field
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Fields Send Feedback
Syntax
Delphi
i8mTargetUnits: Integer;
Description

This is i8mTargetUnits, a member of class TnxInt8Mapper.

Group

TnxInt8Mapper Fields

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Fields


TnxInt8Mapper Methods

TnxInt8Mapper Methods
TnxInt8Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxInt8Mapper class are listed here.

Class

TnxInt8Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt32 |
ToInt64 |
ToInt8 |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxInt8Mapper Class, Legend, Protected Methods


TnxInt8Mapper.InternalCreateMapper Method

TnxInt8Mapper.InternalCreateMapper Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToAnsiChar Method

TnxInt8Mapper.ToAnsiChar Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToAnsiCharCheck Method

TnxInt8Mapper.ToAnsiCharCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToBcd Method

TnxInt8Mapper.ToBcd Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToBcdCheck Method

TnxInt8Mapper.ToBcdCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToBcdTrunc Method

TnxInt8Mapper.ToBcdTrunc Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToBoolean Method

TnxInt8Mapper.ToBoolean Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToBooleanCheck Method

TnxInt8Mapper.ToBooleanCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToByte8 Method

TnxInt8Mapper.ToByte8 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToByteArray Method

TnxInt8Mapper.ToByteArray Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToByteCheck Method

TnxInt8Mapper.ToByteCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToCurrency Method

TnxInt8Mapper.ToCurrency Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToDouble Method

TnxInt8Mapper.ToDouble Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToExtended Method

TnxInt8Mapper.ToExtended Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToInt16 Method

TnxInt8Mapper.ToInt16 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToInt32 Method

TnxInt8Mapper.ToInt32 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToInt64 Method

TnxInt8Mapper.ToInt64 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToInt8 Method

TnxInt8Mapper.ToInt8 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToNullString Method

TnxInt8Mapper.ToNullString Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToNullStringCheck Method

TnxInt8Mapper.ToNullStringCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToShortString Method

TnxInt8Mapper.ToShortString Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToShortStringCheck Method

TnxInt8Mapper.ToShortStringCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToSingle Method

TnxInt8Mapper.ToSingle Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWideChar Method

TnxInt8Mapper.ToWideChar Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWideCharCheck Method

TnxInt8Mapper.ToWideCharCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWideString Method

TnxInt8Mapper.ToWideString Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWideStringCheck Method

TnxInt8Mapper.ToWideStringCheck Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWord16 Method

TnxInt8Mapper.ToWord16 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWord16Check Method

TnxInt8Mapper.ToWord16Check Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWord32 Method

TnxInt8Mapper.ToWord32 Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxInt8Mapper.ToWord32Check Method

TnxInt8Mapper.ToWord32Check Method
TnxInt8Mapper Class TnxInt8Mapper Members nxsdFieldMapper Namespace TnxInt8Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxInt8Mapper Methods

Links
TnxInt8Mapper Class, TnxInt8Mapper Members, nxsdFieldMapper Namespace, TnxInt8Mapper Methods


TnxNullStringMapper Class

TnxNullStringMapper Class
TnxNullStringMapper Fields TnxNullStringMapper Methods TnxNullStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxNullStringMappernxsdFieldMapper_TnxNullStringMappernxsdFieldMapper_TnxNullStringMapper
Syntax
Delphi
TnxNullStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxNullStringMapper.

Group

Classes

Links
TnxNullStringMapper Fields, TnxNullStringMapper Methods, TnxNullStringMapper Members, nxsdFieldMapper, Classes


TnxNullStringMapper Members

TnxNullStringMapper Members
TnxNullStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNullStringMapper.

Class

TnxNullStringMapper Class

Protected Fields
Name | Description
nsmFormatSettings | private
nsmSourceCodepage | This is nsmSourceCodepage, a member of class TnxNullStringMapper.
nsmSourceLength | This is nsmSourceLength, a member of class TnxNullStringMapper.
nsmTargetCodepage | This is nsmTargetCodepage, a member of class TnxNullStringMapper.
nsmTargetDecPl | This is nsmTargetDecPl, a member of class TnxNullStringMapper.
nsmTargetLength | This is nsmTargetLength, a member of class TnxNullStringMapper.
nsmTargetUnits | This is nsmTargetUnits, a member of class TnxNullStringMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharConvert |
ToBcd |
ToBcdCheck |
ToBcdConvert |
ToBcdConvertCheck |
ToBoolean |
ToBooleanCheck |
ToBooleanConvert |
ToBooleanConvertCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToByteConvert |
ToByteConvertCheck |
ToCurrency |
ToCurrencyCheck |
ToCurrencyConvert |
ToCurrencyConvertCheck |
ToDate |
ToDateCheck |
ToDateConvert |
ToDateConvertCheck |
ToDateTime |
ToDateTimeCheck |
ToDateTimeConvert |
ToDateTimeConvertCheck |
ToDouble |
ToDoubleCheck |
ToDoubleConvert |
ToDoubleConvertCheck |
ToExtended |
ToExtendedCheck |
ToExtendedConvert |
ToExtendedConvertCheck |
ToGuid |
ToGuidCheck |
ToGuidConvert |
ToGuidConvertCheck |
ToInt16 |
ToInt16Check |
ToInt16Convert |
ToInt16ConvertCheck |
ToInt32 |
ToInt32Check |
ToInt32Convert |
ToInt32ConvertCheck |
ToInt64 |
ToInt64Check |
ToInt64Convert |
ToInt64ConvertCheck |
ToInt8 |
ToInt8Check |
ToInt8Convert |
ToInt8ConvertCheck |
ToSingle |
ToSingleCheck |
ToSingleConvert |
ToSingleConvertCheck |
ToTime |
ToTimeCheck |
ToTimeConvert |
ToTimeConvertCheck |
ToWideCharConvert |
ToWord16 |
ToWord16Check |
ToWord16Convert |
ToWord16ConvertCheck |
ToWord32 |
ToWord32Check |
ToWord32Convert |
ToWord32ConvertCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxNullStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNullStringMapper.Create Constructor

TnxNullStringMapper.Create Constructor
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxNullStringMapper Class

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Class


TnxNullStringMapper Fields

TnxNullStringMapper Fields
TnxNullStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxNullStringMapper class are listed here.

Class

TnxNullStringMapper Class

Protected Fields
Name | Description
nsmFormatSettings | private
nsmSourceCodepage | This is nsmSourceCodepage, a member of class TnxNullStringMapper.
nsmSourceLength | This is nsmSourceLength, a member of class TnxNullStringMapper.
nsmTargetCodepage | This is nsmTargetCodepage, a member of class TnxNullStringMapper.
nsmTargetDecPl | This is nsmTargetDecPl, a member of class TnxNullStringMapper.
nsmTargetLength | This is nsmTargetLength, a member of class TnxNullStringMapper.
nsmTargetUnits | This is nsmTargetUnits, a member of class TnxNullStringMapper.
Links
TnxNullStringMapper Class, Legend, Protected Fields


TnxNullStringMapper.nsmFormatSettings Field

TnxNullStringMapper.nsmFormatSettings Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmFormatSettings: TFormatSettings;
Description

private

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmSourceCodepage Field

TnxNullStringMapper.nsmSourceCodepage Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmSourceCodepage: Word;
Description

This is nsmSourceCodepage, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmSourceLength Field

TnxNullStringMapper.nsmSourceLength Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmSourceLength: Integer;
Description

This is nsmSourceLength, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmTargetCodepage Field

TnxNullStringMapper.nsmTargetCodepage Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmTargetCodepage: Word;
Description

This is nsmTargetCodepage, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmTargetDecPl Field

TnxNullStringMapper.nsmTargetDecPl Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmTargetDecPl: Integer;
Description

This is nsmTargetDecPl, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmTargetLength Field

TnxNullStringMapper.nsmTargetLength Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmTargetLength: Integer;
Description

This is nsmTargetLength, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper.nsmTargetUnits Field

TnxNullStringMapper.nsmTargetUnits Field
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Fields Send Feedback
Syntax
Delphi
nsmTargetUnits: Integer;
Description

This is nsmTargetUnits, a member of class TnxNullStringMapper.

Group

TnxNullStringMapper Fields

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Fields


TnxNullStringMapper Methods

TnxNullStringMapper Methods
TnxNullStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxNullStringMapper class are listed here.

Class

TnxNullStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharConvert |
ToBcd |
ToBcdCheck |
ToBcdConvert |
ToBcdConvertCheck |
ToBoolean |
ToBooleanCheck |
ToBooleanConvert |
ToBooleanConvertCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToByteConvert |
ToByteConvertCheck |
ToCurrency |
ToCurrencyCheck |
ToCurrencyConvert |
ToCurrencyConvertCheck |
ToDate |
ToDateCheck |
ToDateConvert |
ToDateConvertCheck |
ToDateTime |
ToDateTimeCheck |
ToDateTimeConvert |
ToDateTimeConvertCheck |
ToDouble |
ToDoubleCheck |
ToDoubleConvert |
ToDoubleConvertCheck |
ToExtended |
ToExtendedCheck |
ToExtendedConvert |
ToExtendedConvertCheck |
ToGuid |
ToGuidCheck |
ToGuidConvert |
ToGuidConvertCheck |
ToInt16 |
ToInt16Check |
ToInt16Convert |
ToInt16ConvertCheck |
ToInt32 |
ToInt32Check |
ToInt32Convert |
ToInt32ConvertCheck |
ToInt64 |
ToInt64Check |
ToInt64Convert |
ToInt64ConvertCheck |
ToInt8 |
ToInt8Check |
ToInt8Convert |
ToInt8ConvertCheck |
ToSingle |
ToSingleCheck |
ToSingleConvert |
ToSingleConvertCheck |
ToTime |
ToTimeCheck |
ToTimeConvert |
ToTimeConvertCheck |
ToWideCharConvert |
ToWord16 |
ToWord16Check |
ToWord16Convert |
ToWord16ConvertCheck |
ToWord32 |
ToWord32Check |
ToWord32Convert |
ToWord32ConvertCheck |
Links
TnxNullStringMapper Class, Legend, Protected Methods


TnxNullStringMapper.InternalCreateMapper Method

TnxNullStringMapper.InternalCreateMapper Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToAnsiChar Method

TnxNullStringMapper.ToAnsiChar Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToAnsiCharConvert Method

TnxNullStringMapper.ToAnsiCharConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBcd Method

TnxNullStringMapper.ToBcd Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBcdCheck Method

TnxNullStringMapper.ToBcdCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBcdConvert Method

TnxNullStringMapper.ToBcdConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBcdConvertCheck Method

TnxNullStringMapper.ToBcdConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBoolean Method

TnxNullStringMapper.ToBoolean Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBooleanCheck Method

TnxNullStringMapper.ToBooleanCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBooleanConvert Method

TnxNullStringMapper.ToBooleanConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBooleanConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToBooleanConvertCheck Method

TnxNullStringMapper.ToBooleanConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToBooleanConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByte8 Method

TnxNullStringMapper.ToByte8 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByteArray Method

TnxNullStringMapper.ToByteArray Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByteArrayCheck Method

TnxNullStringMapper.ToByteArrayCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArrayCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByteCheck Method

TnxNullStringMapper.ToByteCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByteConvert Method

TnxNullStringMapper.ToByteConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToByteConvertCheck Method

TnxNullStringMapper.ToByteConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToCurrency Method

TnxNullStringMapper.ToCurrency Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToCurrencyCheck Method

TnxNullStringMapper.ToCurrencyCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToCurrencyConvert Method

TnxNullStringMapper.ToCurrencyConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToCurrencyConvertCheck Method

TnxNullStringMapper.ToCurrencyConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDate Method

TnxNullStringMapper.ToDate Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateCheck Method

TnxNullStringMapper.ToDateCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateConvert Method

TnxNullStringMapper.ToDateConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateConvertCheck Method

TnxNullStringMapper.ToDateConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateTime Method

TnxNullStringMapper.ToDateTime Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateTimeCheck Method

TnxNullStringMapper.ToDateTimeCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateTimeConvert Method

TnxNullStringMapper.ToDateTimeConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDateTimeConvertCheck Method

TnxNullStringMapper.ToDateTimeConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDouble Method

TnxNullStringMapper.ToDouble Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDoubleCheck Method

TnxNullStringMapper.ToDoubleCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDoubleConvert Method

TnxNullStringMapper.ToDoubleConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDoubleConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToDoubleConvertCheck Method

TnxNullStringMapper.ToDoubleConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToDoubleConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToExtended Method

TnxNullStringMapper.ToExtended Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToExtendedCheck Method

TnxNullStringMapper.ToExtendedCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToExtendedConvert Method

TnxNullStringMapper.ToExtendedConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToExtendedConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToExtendedConvertCheck Method

TnxNullStringMapper.ToExtendedConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToExtendedConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToGuid Method

TnxNullStringMapper.ToGuid Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuid(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToGuidCheck Method

TnxNullStringMapper.ToGuidCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuidCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToGuidConvert Method

TnxNullStringMapper.ToGuidConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToGuidConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToGuidConvertCheck Method

TnxNullStringMapper.ToGuidConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToGuidConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt16 Method

TnxNullStringMapper.ToInt16 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt16Check Method

TnxNullStringMapper.ToInt16Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt16Convert Method

TnxNullStringMapper.ToInt16Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt16Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt16ConvertCheck Method

TnxNullStringMapper.ToInt16ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt16ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt32 Method

TnxNullStringMapper.ToInt32 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt32Check Method

TnxNullStringMapper.ToInt32Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt32Convert Method

TnxNullStringMapper.ToInt32Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt32Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt32ConvertCheck Method

TnxNullStringMapper.ToInt32ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt32ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt64 Method

TnxNullStringMapper.ToInt64 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt64Check Method

TnxNullStringMapper.ToInt64Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt64Convert Method

TnxNullStringMapper.ToInt64Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt64Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt64ConvertCheck Method

TnxNullStringMapper.ToInt64ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt64ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt8 Method

TnxNullStringMapper.ToInt8 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt8Check Method

TnxNullStringMapper.ToInt8Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt8Convert Method

TnxNullStringMapper.ToInt8Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt8Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToInt8ConvertCheck Method

TnxNullStringMapper.ToInt8ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt8ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToSingle Method

TnxNullStringMapper.ToSingle Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToSingleCheck Method

TnxNullStringMapper.ToSingleCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToSingleConvert Method

TnxNullStringMapper.ToSingleConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToSingleConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToSingleConvertCheck Method

TnxNullStringMapper.ToSingleConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToSingleConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToTime Method

TnxNullStringMapper.ToTime Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToTimeCheck Method

TnxNullStringMapper.ToTimeCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToTimeConvert Method

TnxNullStringMapper.ToTimeConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToTimeConvertCheck Method

TnxNullStringMapper.ToTimeConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWideCharConvert Method

TnxNullStringMapper.ToWideCharConvert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord16 Method

TnxNullStringMapper.ToWord16 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord16Check Method

TnxNullStringMapper.ToWord16Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord16Convert Method

TnxNullStringMapper.ToWord16Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord16Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord16ConvertCheck Method

TnxNullStringMapper.ToWord16ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord16ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord32 Method

TnxNullStringMapper.ToWord32 Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord32Check Method

TnxNullStringMapper.ToWord32Check Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord32Convert Method

TnxNullStringMapper.ToWord32Convert Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord32Convert(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringMapper.ToWord32ConvertCheck Method

TnxNullStringMapper.ToWord32ConvertCheck Method
TnxNullStringMapper Class TnxNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord32ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxNullStringMapper Methods

Links
TnxNullStringMapper Class, TnxNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringMapper Methods


TnxNullStringToNullStringMapper Class

TnxNullStringToNullStringMapper Class
TnxNullStringToNullStringMapper Fields TnxNullStringToNullStringMapper Methods TnxNullStringToNullStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxNullStringToNullStringMappernxsdFieldMapper_TnxNullStringToNullStringMappernxsdFieldMapper_TnxNullStringToNullStringMapper
Syntax
Delphi
TnxNullStringToNullStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxNullStringToNullStringMapper.

Group

Classes

Links
TnxNullStringToNullStringMapper Fields, TnxNullStringToNullStringMapper Methods, TnxNullStringToNullStringMapper Members, nxsdFieldMapper, Classes


TnxNullStringToNullStringMapper Members

TnxNullStringToNullStringMapper Members
TnxNullStringToNullStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNullStringToNullStringMapper.

Class

TnxNullStringToNullStringMapper Class

Protected Fields
Name | Description
ntnSourceCodepage | This is ntnSourceCodepage, a member of class TnxNullStringToNullStringMapper.
ntnTargetCodepage | This is ntnTargetCodepage, a member of class TnxNullStringToNullStringMapper.
ntnTargetLength | private
Protected Methods
Name | Description
InternalCreateMapper |
Register |
ToNullString |
ToNullStringConvert | target has lower number of characters and same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToNullStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToNullStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToNullStringPadding | target requires codepage translation
ToNullStringTruncCheck | target has same codepage
ToNullStringTruncCheckPadding | target has same codepage, removes padding
Unregister |
Public Methods
Name | Description
Create |
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxNullStringToNullStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNullStringToNullStringMapper.Create Constructor

TnxNullStringToNullStringMapper.Create Constructor
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxNullStringToNullStringMapper Class

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Class


TnxNullStringToNullStringMapper Fields

TnxNullStringToNullStringMapper Fields
TnxNullStringToNullStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxNullStringToNullStringMapper class are listed here.

Class

TnxNullStringToNullStringMapper Class

Protected Fields
Name | Description
ntnSourceCodepage | This is ntnSourceCodepage, a member of class TnxNullStringToNullStringMapper.
ntnTargetCodepage | This is ntnTargetCodepage, a member of class TnxNullStringToNullStringMapper.
ntnTargetLength | private
Links
TnxNullStringToNullStringMapper Class, Legend, Protected Fields


TnxNullStringToNullStringMapper.ntnSourceCodepage Field

TnxNullStringToNullStringMapper.ntnSourceCodepage Field
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
ntnSourceCodepage: Word;
Description

This is ntnSourceCodepage, a member of class TnxNullStringToNullStringMapper.

Group

TnxNullStringToNullStringMapper Fields

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Fields


TnxNullStringToNullStringMapper.ntnTargetCodepage Field

TnxNullStringToNullStringMapper.ntnTargetCodepage Field
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
ntnTargetCodepage: Word;
Description

This is ntnTargetCodepage, a member of class TnxNullStringToNullStringMapper.

Group

TnxNullStringToNullStringMapper Fields

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Fields


TnxNullStringToNullStringMapper.ntnTargetLength Field

TnxNullStringToNullStringMapper.ntnTargetLength Field
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
ntnTargetLength: Integer;
Description

private

Group

TnxNullStringToNullStringMapper Fields

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Fields


TnxNullStringToNullStringMapper Methods

TnxNullStringToNullStringMapper Methods
TnxNullStringToNullStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxNullStringToNullStringMapper class are listed here.

Class

TnxNullStringToNullStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToNullString |
ToNullStringConvert | target has lower number of characters and same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToNullStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToNullStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToNullStringPadding | target requires codepage translation
ToNullStringTruncCheck | target has same codepage
ToNullStringTruncCheckPadding | target has same codepage, removes padding
Links
TnxNullStringToNullStringMapper Class, Legend, Protected Methods


TnxNullStringToNullStringMapper.InternalCreateMapper Method

TnxNullStringToNullStringMapper.InternalCreateMapper Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullString Method

TnxNullStringToNullStringMapper.ToNullString Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringConvert Method

TnxNullStringToNullStringMapper.ToNullStringConvert Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringConvertCheck Method

TnxNullStringToNullStringMapper.ToNullStringConvertCheck Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringConvertCheckPadding Method

TnxNullStringToNullStringMapper.ToNullStringConvertCheckPadding Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS, removes padding

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringConvertPadding Method

TnxNullStringToNullStringMapper.ToNullStringConvertPadding Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage, removes padding

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringPadding Method

TnxNullStringToNullStringMapper.ToNullStringPadding Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringTruncCheck Method

TnxNullStringToNullStringMapper.ToNullStringTruncCheck Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringTruncCheck(const aSource; var aTarget): TnxResult;
Description

target has same codepage

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToNullStringMapper.ToNullStringTruncCheckPadding Method

TnxNullStringToNullStringMapper.ToNullStringTruncCheckPadding Method
TnxNullStringToNullStringMapper Class TnxNullStringToNullStringMapper Members nxsdFieldMapper Namespace TnxNullStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringTruncCheckPadding(const aSource; var aTarget): TnxResult;
Description

target has same codepage, removes padding

Group

TnxNullStringToNullStringMapper Methods

Links
TnxNullStringToNullStringMapper Class, TnxNullStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToNullStringMapper Methods


TnxNullStringToShortStringMapper Class

TnxNullStringToShortStringMapper Class
TnxNullStringToShortStringMapper Fields TnxNullStringToShortStringMapper Methods TnxNullStringToShortStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxNullStringToShortStringMappernxsdFieldMapper_TnxNullStringToShortStringMappernxsdFieldMapper_TnxNullStringToShortStringMapper
Syntax
Delphi
TnxNullStringToShortStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxNullStringToShortStringMapper.

Group

Classes

Links
TnxNullStringToShortStringMapper Fields, TnxNullStringToShortStringMapper Methods, TnxNullStringToShortStringMapper Members, nxsdFieldMapper, Classes


TnxNullStringToShortStringMapper Members

TnxNullStringToShortStringMapper Members
TnxNullStringToShortStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNullStringToShortStringMapper.

Class

TnxNullStringToShortStringMapper Class

Protected Fields
Name | Description
ntsSourceCodepage | This is ntsSourceCodepage, a member of class TnxNullStringToShortStringMapper.
ntsTargetCodepage | This is ntsTargetCodepage, a member of class TnxNullStringToShortStringMapper.
ntsTargetLength | private
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToShortString |
ToShortStringConvert | target has lower number of characters and same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToShortStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToShortStringPadding | target requires codepage translation
ToShortStringTruncCheck | target has same codepage
ToShortStringTruncCheckPadding | target has same codepage, removes padding
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxNullStringToShortStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNullStringToShortStringMapper.Create Constructor

TnxNullStringToShortStringMapper.Create Constructor
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxNullStringToShortStringMapper Class

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Class


TnxNullStringToShortStringMapper Fields

TnxNullStringToShortStringMapper Fields
TnxNullStringToShortStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxNullStringToShortStringMapper class are listed here.

Class

TnxNullStringToShortStringMapper Class

Protected Fields
Name | Description
ntsSourceCodepage | This is ntsSourceCodepage, a member of class TnxNullStringToShortStringMapper.
ntsTargetCodepage | This is ntsTargetCodepage, a member of class TnxNullStringToShortStringMapper.
ntsTargetLength | private
Links
TnxNullStringToShortStringMapper Class, Legend, Protected Fields


TnxNullStringToShortStringMapper.ntsSourceCodepage Field

TnxNullStringToShortStringMapper.ntsSourceCodepage Field
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
ntsSourceCodepage: Word;
Description

This is ntsSourceCodepage, a member of class TnxNullStringToShortStringMapper.

Group

TnxNullStringToShortStringMapper Fields

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Fields


TnxNullStringToShortStringMapper.ntsTargetCodepage Field

TnxNullStringToShortStringMapper.ntsTargetCodepage Field
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
ntsTargetCodepage: Word;
Description

This is ntsTargetCodepage, a member of class TnxNullStringToShortStringMapper.

Group

TnxNullStringToShortStringMapper Fields

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Fields


TnxNullStringToShortStringMapper.ntsTargetLength Field

TnxNullStringToShortStringMapper.ntsTargetLength Field
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
ntsTargetLength: Integer;
Description

private

Group

TnxNullStringToShortStringMapper Fields

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Fields


TnxNullStringToShortStringMapper Methods

TnxNullStringToShortStringMapper Methods
TnxNullStringToShortStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxNullStringToShortStringMapper class are listed here.

Class

TnxNullStringToShortStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToShortString |
ToShortStringConvert | target has lower number of characters and same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToShortStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToShortStringPadding | target requires codepage translation
ToShortStringTruncCheck | target has same codepage
ToShortStringTruncCheckPadding | target has same codepage, removes padding
Links
TnxNullStringToShortStringMapper Class, Legend, Protected Methods


TnxNullStringToShortStringMapper.InternalCreateMapper Method

TnxNullStringToShortStringMapper.InternalCreateMapper Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortString Method

TnxNullStringToShortStringMapper.ToShortString Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringConvert Method

TnxNullStringToShortStringMapper.ToShortStringConvert Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringConvertCheck Method

TnxNullStringToShortStringMapper.ToShortStringConvertCheck Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringConvertCheckPadding Method

TnxNullStringToShortStringMapper.ToShortStringConvertCheckPadding Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS, removes padding

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringConvertPadding Method

TnxNullStringToShortStringMapper.ToShortStringConvertPadding Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage, removes padding

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringPadding Method

TnxNullStringToShortStringMapper.ToShortStringPadding Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringTruncCheck Method

TnxNullStringToShortStringMapper.ToShortStringTruncCheck Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTruncCheck(const aSource; var aTarget): TnxResult;
Description

target has same codepage

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxNullStringToShortStringMapper.ToShortStringTruncCheckPadding Method

TnxNullStringToShortStringMapper.ToShortStringTruncCheckPadding Method
TnxNullStringToShortStringMapper Class TnxNullStringToShortStringMapper Members nxsdFieldMapper Namespace TnxNullStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTruncCheckPadding(const aSource; var aTarget): TnxResult;
Description

target has same codepage, removes padding

Group

TnxNullStringToShortStringMapper Methods

Links
TnxNullStringToShortStringMapper Class, TnxNullStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxNullStringToShortStringMapper Methods


TnxShortStringMapper Class

TnxShortStringMapper Class
TnxShortStringMapper Fields TnxShortStringMapper Methods TnxShortStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxShortStringMappernxsdFieldMapper_TnxShortStringMappernxsdFieldMapper_TnxShortStringMapper
Syntax
Delphi
TnxShortStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxShortStringMapper.

Group

Classes

Links
TnxShortStringMapper Fields, TnxShortStringMapper Methods, TnxShortStringMapper Members, nxsdFieldMapper, Classes


TnxShortStringMapper Members

TnxShortStringMapper Members
TnxShortStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxShortStringMapper.

Class

TnxShortStringMapper Class

Protected Fields
Name | Description
ssmFormatSettings | private
ssmSourceCodepage | This is ssmSourceCodepage, a member of class TnxShortStringMapper.
ssmSourceLength | This is ssmSourceLength, a member of class TnxShortStringMapper.
ssmTargetCodepage | This is ssmTargetCodepage, a member of class TnxShortStringMapper.
ssmTargetDecPl | This is ssmTargetDecPl, a member of class TnxShortStringMapper.
ssmTargetLength | This is ssmTargetLength, a member of class TnxShortStringMapper.
ssmTargetUnits | This is ssmTargetUnits, a member of class TnxShortStringMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharConvert |
ToBcd |
ToBcdCheck |
ToBcdConvert |
ToBcdConvertCheck |
ToBoolean |
ToBooleanCheck |
ToBooleanConvert |
ToBooleanConvertCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToByteConvert |
ToByteConvertCheck |
ToCurrency |
ToCurrencyCheck |
ToCurrencyConvert |
ToCurrencyConvertCheck |
ToDate |
ToDateCheck |
ToDateConvert |
ToDateConvertCheck |
ToDateTime |
ToDateTimeCheck |
ToDateTimeConvert |
ToDateTimeConvertCheck |
ToDouble |
ToDoubleCheck |
ToDoubleConvert |
ToDoubleConvertCheck |
ToExtended |
ToExtendedCheck |
ToExtendedConvert |
ToExtendedConvertCheck |
ToGuid |
ToGuidCheck |
ToGuidConvert |
ToGuidConvertCheck |
ToInt16 |
ToInt16Check |
ToInt16Convert |
ToInt16ConvertCheck |
ToInt32 |
ToInt32Check |
ToInt32Convert |
ToInt32ConvertCheck |
ToInt64 |
ToInt64Check |
ToInt64Convert |
ToInt64ConvertCheck |
ToInt8 |
ToInt8Check |
ToInt8Convert |
ToInt8ConvertCheck |
ToSingle |
ToSingleCheck |
ToSingleConvert |
ToSingleConvertCheck |
ToTime |
ToTimeCheck |
ToTimeConvert |
ToTimeConvertCheck |
ToWideCharConvert |
ToWord16 |
ToWord16Check |
ToWord16Convert |
ToWord16ConvertCheck |
ToWord32 |
ToWord32Check |
ToWord32Convert |
ToWord32ConvertCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxShortStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxShortStringMapper.Create Constructor

TnxShortStringMapper.Create Constructor
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxShortStringMapper Class

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Class


TnxShortStringMapper Fields

TnxShortStringMapper Fields
TnxShortStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxShortStringMapper class are listed here.

Class

TnxShortStringMapper Class

Protected Fields
Name | Description
ssmFormatSettings | private
ssmSourceCodepage | This is ssmSourceCodepage, a member of class TnxShortStringMapper.
ssmSourceLength | This is ssmSourceLength, a member of class TnxShortStringMapper.
ssmTargetCodepage | This is ssmTargetCodepage, a member of class TnxShortStringMapper.
ssmTargetDecPl | This is ssmTargetDecPl, a member of class TnxShortStringMapper.
ssmTargetLength | This is ssmTargetLength, a member of class TnxShortStringMapper.
ssmTargetUnits | This is ssmTargetUnits, a member of class TnxShortStringMapper.
Links
TnxShortStringMapper Class, Legend, Protected Fields


TnxShortStringMapper.ssmFormatSettings Field

TnxShortStringMapper.ssmFormatSettings Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmFormatSettings: TFormatSettings;
Description

private

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmSourceCodepage Field

TnxShortStringMapper.ssmSourceCodepage Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmSourceCodepage: Word;
Description

This is ssmSourceCodepage, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmSourceLength Field

TnxShortStringMapper.ssmSourceLength Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmSourceLength: Integer;
Description

This is ssmSourceLength, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmTargetCodepage Field

TnxShortStringMapper.ssmTargetCodepage Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmTargetCodepage: Word;
Description

This is ssmTargetCodepage, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmTargetDecPl Field

TnxShortStringMapper.ssmTargetDecPl Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmTargetDecPl: Integer;
Description

This is ssmTargetDecPl, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmTargetLength Field

TnxShortStringMapper.ssmTargetLength Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmTargetLength: Integer;
Description

This is ssmTargetLength, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper.ssmTargetUnits Field

TnxShortStringMapper.ssmTargetUnits Field
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Fields Send Feedback
Syntax
Delphi
ssmTargetUnits: Integer;
Description

This is ssmTargetUnits, a member of class TnxShortStringMapper.

Group

TnxShortStringMapper Fields

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Fields


TnxShortStringMapper Methods

TnxShortStringMapper Methods
TnxShortStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxShortStringMapper class are listed here.

Class

TnxShortStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharConvert |
ToBcd |
ToBcdCheck |
ToBcdConvert |
ToBcdConvertCheck |
ToBoolean |
ToBooleanCheck |
ToBooleanConvert |
ToBooleanConvertCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToByteConvert |
ToByteConvertCheck |
ToCurrency |
ToCurrencyCheck |
ToCurrencyConvert |
ToCurrencyConvertCheck |
ToDate |
ToDateCheck |
ToDateConvert |
ToDateConvertCheck |
ToDateTime |
ToDateTimeCheck |
ToDateTimeConvert |
ToDateTimeConvertCheck |
ToDouble |
ToDoubleCheck |
ToDoubleConvert |
ToDoubleConvertCheck |
ToExtended |
ToExtendedCheck |
ToExtendedConvert |
ToExtendedConvertCheck |
ToGuid |
ToGuidCheck |
ToGuidConvert |
ToGuidConvertCheck |
ToInt16 |
ToInt16Check |
ToInt16Convert |
ToInt16ConvertCheck |
ToInt32 |
ToInt32Check |
ToInt32Convert |
ToInt32ConvertCheck |
ToInt64 |
ToInt64Check |
ToInt64Convert |
ToInt64ConvertCheck |
ToInt8 |
ToInt8Check |
ToInt8Convert |
ToInt8ConvertCheck |
ToSingle |
ToSingleCheck |
ToSingleConvert |
ToSingleConvertCheck |
ToTime |
ToTimeCheck |
ToTimeConvert |
ToTimeConvertCheck |
ToWideCharConvert |
ToWord16 |
ToWord16Check |
ToWord16Convert |
ToWord16ConvertCheck |
ToWord32 |
ToWord32Check |
ToWord32Convert |
ToWord32ConvertCheck |
Links
TnxShortStringMapper Class, Legend, Protected Methods


TnxShortStringMapper.InternalCreateMapper Method

TnxShortStringMapper.InternalCreateMapper Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToAnsiChar Method

TnxShortStringMapper.ToAnsiChar Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToAnsiCharConvert Method

TnxShortStringMapper.ToAnsiCharConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBcd Method

TnxShortStringMapper.ToBcd Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBcdCheck Method

TnxShortStringMapper.ToBcdCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBcdConvert Method

TnxShortStringMapper.ToBcdConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBcdConvertCheck Method

TnxShortStringMapper.ToBcdConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBoolean Method

TnxShortStringMapper.ToBoolean Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBooleanCheck Method

TnxShortStringMapper.ToBooleanCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBooleanConvert Method

TnxShortStringMapper.ToBooleanConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBooleanConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToBooleanConvertCheck Method

TnxShortStringMapper.ToBooleanConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToBooleanConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByte8 Method

TnxShortStringMapper.ToByte8 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByteArray Method

TnxShortStringMapper.ToByteArray Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByteArrayCheck Method

TnxShortStringMapper.ToByteArrayCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArrayCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByteCheck Method

TnxShortStringMapper.ToByteCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByteConvert Method

TnxShortStringMapper.ToByteConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToByteConvertCheck Method

TnxShortStringMapper.ToByteConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToCurrency Method

TnxShortStringMapper.ToCurrency Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToCurrencyCheck Method

TnxShortStringMapper.ToCurrencyCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToCurrencyConvert Method

TnxShortStringMapper.ToCurrencyConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToCurrencyConvertCheck Method

TnxShortStringMapper.ToCurrencyConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToCurrencyConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDate Method

TnxShortStringMapper.ToDate Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateCheck Method

TnxShortStringMapper.ToDateCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateConvert Method

TnxShortStringMapper.ToDateConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateConvertCheck Method

TnxShortStringMapper.ToDateConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateTime Method

TnxShortStringMapper.ToDateTime Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateTimeCheck Method

TnxShortStringMapper.ToDateTimeCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateTimeConvert Method

TnxShortStringMapper.ToDateTimeConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDateTimeConvertCheck Method

TnxShortStringMapper.ToDateTimeConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDouble Method

TnxShortStringMapper.ToDouble Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDoubleCheck Method

TnxShortStringMapper.ToDoubleCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDoubleConvert Method

TnxShortStringMapper.ToDoubleConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDoubleConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToDoubleConvertCheck Method

TnxShortStringMapper.ToDoubleConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToDoubleConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToExtended Method

TnxShortStringMapper.ToExtended Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToExtendedCheck Method

TnxShortStringMapper.ToExtendedCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToExtendedConvert Method

TnxShortStringMapper.ToExtendedConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToExtendedConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToExtendedConvertCheck Method

TnxShortStringMapper.ToExtendedConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToExtendedConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToGuid Method

TnxShortStringMapper.ToGuid Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuid(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToGuidCheck Method

TnxShortStringMapper.ToGuidCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuidCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToGuidConvert Method

TnxShortStringMapper.ToGuidConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToGuidConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToGuidConvertCheck Method

TnxShortStringMapper.ToGuidConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToGuidConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt16 Method

TnxShortStringMapper.ToInt16 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt16Check Method

TnxShortStringMapper.ToInt16Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt16Convert Method

TnxShortStringMapper.ToInt16Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt16Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt16ConvertCheck Method

TnxShortStringMapper.ToInt16ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt16ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt32 Method

TnxShortStringMapper.ToInt32 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt32Check Method

TnxShortStringMapper.ToInt32Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt32Convert Method

TnxShortStringMapper.ToInt32Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt32Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt32ConvertCheck Method

TnxShortStringMapper.ToInt32ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt32ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt64 Method

TnxShortStringMapper.ToInt64 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt64Check Method

TnxShortStringMapper.ToInt64Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt64Convert Method

TnxShortStringMapper.ToInt64Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt64Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt64ConvertCheck Method

TnxShortStringMapper.ToInt64ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt64ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt8 Method

TnxShortStringMapper.ToInt8 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt8Check Method

TnxShortStringMapper.ToInt8Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt8Convert Method

TnxShortStringMapper.ToInt8Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt8Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToInt8ConvertCheck Method

TnxShortStringMapper.ToInt8ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToInt8ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToSingle Method

TnxShortStringMapper.ToSingle Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToSingleCheck Method

TnxShortStringMapper.ToSingleCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToSingleConvert Method

TnxShortStringMapper.ToSingleConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToSingleConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToSingleConvertCheck Method

TnxShortStringMapper.ToSingleConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToSingleConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToTime Method

TnxShortStringMapper.ToTime Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToTimeCheck Method

TnxShortStringMapper.ToTimeCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToTimeConvert Method

TnxShortStringMapper.ToTimeConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToTimeConvertCheck Method

TnxShortStringMapper.ToTimeConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWideCharConvert Method

TnxShortStringMapper.ToWideCharConvert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord16 Method

TnxShortStringMapper.ToWord16 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord16Check Method

TnxShortStringMapper.ToWord16Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord16Convert Method

TnxShortStringMapper.ToWord16Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord16Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord16ConvertCheck Method

TnxShortStringMapper.ToWord16ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord16ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord32 Method

TnxShortStringMapper.ToWord32 Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord32Check Method

TnxShortStringMapper.ToWord32Check Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord32Convert Method

TnxShortStringMapper.ToWord32Convert Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord32Convert(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringMapper.ToWord32ConvertCheck Method

TnxShortStringMapper.ToWord32ConvertCheck Method
TnxShortStringMapper Class TnxShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToWord32ConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxShortStringMapper Methods

Links
TnxShortStringMapper Class, TnxShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringMapper Methods


TnxShortStringToNullStringMapper Class

TnxShortStringToNullStringMapper Class
TnxShortStringToNullStringMapper Fields TnxShortStringToNullStringMapper Methods TnxShortStringToNullStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxShortStringToNullStringMappernxsdFieldMapper_TnxShortStringToNullStringMappernxsdFieldMapper_TnxShortStringToNullStringMapper
Syntax
Delphi
TnxShortStringToNullStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxShortStringToNullStringMapper.

Group

Classes

Links
TnxShortStringToNullStringMapper Fields, TnxShortStringToNullStringMapper Methods, TnxShortStringToNullStringMapper Members, nxsdFieldMapper, Classes


TnxShortStringToNullStringMapper Members

TnxShortStringToNullStringMapper Members
TnxShortStringToNullStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxShortStringToNullStringMapper.

Class

TnxShortStringToNullStringMapper Class

Protected Fields
Name | Description
stnSourceCodepage | This is stnSourceCodepage, a member of class TnxShortStringToNullStringMapper.
stnTargetCodepage | This is stnTargetCodepage, a member of class TnxShortStringToNullStringMapper.
stnTargetLength | private
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToNullString |
ToNullStringConvert | target has lower number of characters and same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToNullStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToNullStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToNullStringPadding | target requires codepage translation
ToNullStringTruncCheck | target has same codepage
ToNullStringTruncCheckPadding | target has same codepage, removes padding
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxShortStringToNullStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxShortStringToNullStringMapper.Create Constructor

TnxShortStringToNullStringMapper.Create Constructor
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxShortStringToNullStringMapper Class

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Class


TnxShortStringToNullStringMapper Fields

TnxShortStringToNullStringMapper Fields
TnxShortStringToNullStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxShortStringToNullStringMapper class are listed here.

Class

TnxShortStringToNullStringMapper Class

Protected Fields
Name | Description
stnSourceCodepage | This is stnSourceCodepage, a member of class TnxShortStringToNullStringMapper.
stnTargetCodepage | This is stnTargetCodepage, a member of class TnxShortStringToNullStringMapper.
stnTargetLength | private
Links
TnxShortStringToNullStringMapper Class, Legend, Protected Fields


TnxShortStringToNullStringMapper.stnSourceCodepage Field

TnxShortStringToNullStringMapper.stnSourceCodepage Field
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
stnSourceCodepage: Word;
Description

This is stnSourceCodepage, a member of class TnxShortStringToNullStringMapper.

Group

TnxShortStringToNullStringMapper Fields

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Fields


TnxShortStringToNullStringMapper.stnTargetCodepage Field

TnxShortStringToNullStringMapper.stnTargetCodepage Field
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
stnTargetCodepage: Word;
Description

This is stnTargetCodepage, a member of class TnxShortStringToNullStringMapper.

Group

TnxShortStringToNullStringMapper Fields

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Fields


TnxShortStringToNullStringMapper.stnTargetLength Field

TnxShortStringToNullStringMapper.stnTargetLength Field
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Fields Send Feedback
Syntax
Delphi
stnTargetLength: Integer;
Description

private

Group

TnxShortStringToNullStringMapper Fields

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Fields


TnxShortStringToNullStringMapper Methods

TnxShortStringToNullStringMapper Methods
TnxShortStringToNullStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxShortStringToNullStringMapper class are listed here.

Class

TnxShortStringToNullStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToNullString |
ToNullStringConvert | target has lower number of characters and same codepage
ToNullStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToNullStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToNullStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToNullStringPadding | target requires codepage translation
ToNullStringTruncCheck | target has same codepage
ToNullStringTruncCheckPadding | target has same codepage, removes padding
Links
TnxShortStringToNullStringMapper Class, Legend, Protected Methods


TnxShortStringToNullStringMapper.InternalCreateMapper Method

TnxShortStringToNullStringMapper.InternalCreateMapper Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullString Method

TnxShortStringToNullStringMapper.ToNullString Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringConvert Method

TnxShortStringToNullStringMapper.ToNullStringConvert Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringConvertCheck Method

TnxShortStringToNullStringMapper.ToNullStringConvertCheck Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringConvertCheckPadding Method

TnxShortStringToNullStringMapper.ToNullStringConvertCheckPadding Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS, removes padding

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringConvertPadding Method

TnxShortStringToNullStringMapper.ToNullStringConvertPadding Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage, removes padding

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringPadding Method

TnxShortStringToNullStringMapper.ToNullStringPadding Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringTruncCheck Method

TnxShortStringToNullStringMapper.ToNullStringTruncCheck Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringTruncCheck(const aSource; var aTarget): TnxResult;
Description

target has same codepage

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToNullStringMapper.ToNullStringTruncCheckPadding Method

TnxShortStringToNullStringMapper.ToNullStringTruncCheckPadding Method
TnxShortStringToNullStringMapper Class TnxShortStringToNullStringMapper Members nxsdFieldMapper Namespace TnxShortStringToNullStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringTruncCheckPadding(const aSource; var aTarget): TnxResult;
Description

target has same codepage, removes padding

Group

TnxShortStringToNullStringMapper Methods

Links
TnxShortStringToNullStringMapper Class, TnxShortStringToNullStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToNullStringMapper Methods


TnxShortStringToShortStringMapper Class

TnxShortStringToShortStringMapper Class
TnxShortStringToShortStringMapper Fields TnxShortStringToShortStringMapper Methods TnxShortStringToShortStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxShortStringToShortStringMappernxsdFieldMapper_TnxShortStringToShortStringMappernxsdFieldMapper_TnxShortStringToShortStringMapper
Syntax
Delphi
TnxShortStringToShortStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxShortStringToShortStringMapper.

Group

Classes

Links
TnxShortStringToShortStringMapper Fields, TnxShortStringToShortStringMapper Methods, TnxShortStringToShortStringMapper Members, nxsdFieldMapper, Classes


TnxShortStringToShortStringMapper Members

TnxShortStringToShortStringMapper Members
TnxShortStringToShortStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxShortStringToShortStringMapper.

Class

TnxShortStringToShortStringMapper Class

Protected Fields
Name | Description
stsSourceCodepage | This is stsSourceCodepage, a member of class TnxShortStringToShortStringMapper.
stsTargetCodepage | This is stsTargetCodepage, a member of class TnxShortStringToShortStringMapper.
stsTargetLength | private
Protected Methods
Name | Description
InternalCreateMapper |
Register |
ToShortStringConvert | target has lower number of characters and same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToShortStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToShortStringExpand |
ToShortStringExpandPadding | target requires codepage translation
ToShortStringTrunc | target has same or higher number of characters/bytes and same codepage
ToShortStringTruncCheck | target has lower number of characters and same SBCS codepage
ToShortStringTruncCheckPadding | target has lower number of characters and same SBCS codepage, removes padding
ToShortStringTruncPadding | target has same or higher number of characters/bytes and same codepage, removes padding
Unregister |
Public Methods
Name | Description
Create |
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxShortStringToShortStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxShortStringToShortStringMapper.Create Constructor

TnxShortStringToShortStringMapper.Create Constructor
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxShortStringToShortStringMapper Class

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Class


TnxShortStringToShortStringMapper Fields

TnxShortStringToShortStringMapper Fields
TnxShortStringToShortStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxShortStringToShortStringMapper class are listed here.

Class

TnxShortStringToShortStringMapper Class

Protected Fields
Name | Description
stsSourceCodepage | This is stsSourceCodepage, a member of class TnxShortStringToShortStringMapper.
stsTargetCodepage | This is stsTargetCodepage, a member of class TnxShortStringToShortStringMapper.
stsTargetLength | private
Links
TnxShortStringToShortStringMapper Class, Legend, Protected Fields


TnxShortStringToShortStringMapper.stsSourceCodepage Field

TnxShortStringToShortStringMapper.stsSourceCodepage Field
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
stsSourceCodepage: Word;
Description

This is stsSourceCodepage, a member of class TnxShortStringToShortStringMapper.

Group

TnxShortStringToShortStringMapper Fields

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Fields


TnxShortStringToShortStringMapper.stsTargetCodepage Field

TnxShortStringToShortStringMapper.stsTargetCodepage Field
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
stsTargetCodepage: Word;
Description

This is stsTargetCodepage, a member of class TnxShortStringToShortStringMapper.

Group

TnxShortStringToShortStringMapper Fields

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Fields


TnxShortStringToShortStringMapper.stsTargetLength Field

TnxShortStringToShortStringMapper.stsTargetLength Field
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Fields Send Feedback
Syntax
Delphi
stsTargetLength: Integer;
Description

private

Group

TnxShortStringToShortStringMapper Fields

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Fields


TnxShortStringToShortStringMapper Methods

TnxShortStringToShortStringMapper Methods
TnxShortStringToShortStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxShortStringToShortStringMapper class are listed here.

Class

TnxShortStringToShortStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToShortStringConvert | target has lower number of characters and same codepage
ToShortStringConvertCheck | target requires codepage translation or truncation of the same MBCS
ToShortStringConvertCheckPadding | target requires codepage translation or truncation of the same MBCS, removes padding
ToShortStringConvertPadding | target has lower number of characters and same codepage, removes padding
ToShortStringExpand |
ToShortStringExpandPadding | target requires codepage translation
ToShortStringTrunc | target has same or higher number of characters/bytes and same codepage
ToShortStringTruncCheck | target has lower number of characters and same SBCS codepage
ToShortStringTruncCheckPadding | target has lower number of characters and same SBCS codepage, removes padding
ToShortStringTruncPadding | target has same or higher number of characters/bytes and same codepage, removes padding
Links
TnxShortStringToShortStringMapper Class, Legend, Protected Methods


TnxShortStringToShortStringMapper.InternalCreateMapper Method

TnxShortStringToShortStringMapper.InternalCreateMapper Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringConvert Method

TnxShortStringToShortStringMapper.ToShortStringConvert Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringConvertCheck Method

TnxShortStringToShortStringMapper.ToShortStringConvertCheck Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringConvertCheckPadding Method

TnxShortStringToShortStringMapper.ToShortStringConvertCheckPadding Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation or truncation of the same MBCS, removes padding

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringConvertPadding Method

TnxShortStringToShortStringMapper.ToShortStringConvertPadding Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same codepage, removes padding

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringExpand Method

TnxShortStringToShortStringMapper.ToShortStringExpand Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringExpand(const aSource; var aTarget): TnxResult;
Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringExpandPadding Method

TnxShortStringToShortStringMapper.ToShortStringExpandPadding Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringExpandPadding(const aSource; var aTarget): TnxResult;
Description

target requires codepage translation

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringTrunc Method

TnxShortStringToShortStringMapper.ToShortStringTrunc Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTrunc(const aSource; var aTarget): TnxResult;
Description

target has same or higher number of characters/bytes and same codepage

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringTruncCheck Method

TnxShortStringToShortStringMapper.ToShortStringTruncCheck Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTruncCheck(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same SBCS codepage

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringTruncCheckPadding Method

TnxShortStringToShortStringMapper.ToShortStringTruncCheckPadding Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTruncCheckPadding(const aSource; var aTarget): TnxResult;
Description

target has lower number of characters and same SBCS codepage, removes padding

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxShortStringToShortStringMapper.ToShortStringTruncPadding Method

TnxShortStringToShortStringMapper.ToShortStringTruncPadding Method
TnxShortStringToShortStringMapper Class TnxShortStringToShortStringMapper Members nxsdFieldMapper Namespace TnxShortStringToShortStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringTruncPadding(const aSource; var aTarget): TnxResult;
Description

target has same or higher number of characters/bytes and same codepage, removes padding

Group

TnxShortStringToShortStringMapper Methods

Links
TnxShortStringToShortStringMapper Class, TnxShortStringToShortStringMapper Members, nxsdFieldMapper Namespace, TnxShortStringToShortStringMapper Methods


TnxSingleMapper Class

TnxSingleMapper Class
TnxSingleMapper Fields TnxSingleMapper Methods TnxSingleMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxSingleMappernxsdFieldMapper_TnxSingleMappernxsdFieldMapper_TnxSingleMapper
Syntax
Delphi
TnxSingleMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxSingleMapper.

Group

Classes

Links
TnxSingleMapper Fields, TnxSingleMapper Methods, TnxSingleMapper Members, nxsdFieldMapper, Classes


TnxSingleMapper Members

TnxSingleMapper Members
TnxSingleMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSingleMapper.

Class

TnxSingleMapper Class

Protected Fields
Name | Description
smFormatSettings | This is smFormatSettings, a member of class TnxSingleMapper.
smTargetDecPl | This is smTargetDecPl, a member of class TnxSingleMapper.
smTargetLength | This is smTargetLength, a member of class TnxSingleMapper.
smTargetUnits | This is smTargetUnits, a member of class TnxSingleMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxSingleMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSingleMapper.Create Constructor

TnxSingleMapper.Create Constructor
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxSingleMapper Class

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Class


TnxSingleMapper Fields

TnxSingleMapper Fields
TnxSingleMapper Class Legend Protected Fields Send Feedback

The fields of the TnxSingleMapper class are listed here.

Class

TnxSingleMapper Class

Protected Fields
Name | Description
smFormatSettings | This is smFormatSettings, a member of class TnxSingleMapper.
smTargetDecPl | This is smTargetDecPl, a member of class TnxSingleMapper.
smTargetLength | This is smTargetLength, a member of class TnxSingleMapper.
smTargetUnits | This is smTargetUnits, a member of class TnxSingleMapper.
Links
TnxSingleMapper Class, Legend, Protected Fields


TnxSingleMapper.smFormatSettings Field

TnxSingleMapper.smFormatSettings Field
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Fields Send Feedback
Syntax
Delphi
smFormatSettings: TFormatSettings;
Description

This is smFormatSettings, a member of class TnxSingleMapper.

Group

TnxSingleMapper Fields

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Fields


TnxSingleMapper.smTargetDecPl Field

TnxSingleMapper.smTargetDecPl Field
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Fields Send Feedback
Syntax
Delphi
smTargetDecPl: Integer;
Description

This is smTargetDecPl, a member of class TnxSingleMapper.

Group

TnxSingleMapper Fields

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Fields


TnxSingleMapper.smTargetLength Field

TnxSingleMapper.smTargetLength Field
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Fields Send Feedback
Syntax
Delphi
smTargetLength: Integer;
Description

This is smTargetLength, a member of class TnxSingleMapper.

Group

TnxSingleMapper Fields

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Fields


TnxSingleMapper.smTargetUnits Field

TnxSingleMapper.smTargetUnits Field
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Fields Send Feedback
Syntax
Delphi
smTargetUnits: Integer;
Description

This is smTargetUnits, a member of class TnxSingleMapper.

Group

TnxSingleMapper Fields

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Fields


TnxSingleMapper Methods

TnxSingleMapper Methods
TnxSingleMapper Class Legend Protected Methods Send Feedback

The methods of the TnxSingleMapper class are listed here.

Class

TnxSingleMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxSingleMapper Class, Legend, Protected Methods


TnxSingleMapper.InternalCreateMapper Method

TnxSingleMapper.InternalCreateMapper Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToAnsiChar Method

TnxSingleMapper.ToAnsiChar Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToAnsiCharCheck Method

TnxSingleMapper.ToAnsiCharCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToBcdCheck Method

TnxSingleMapper.ToBcdCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToBcdTrunc Method

TnxSingleMapper.ToBcdTrunc Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToBoolean Method

TnxSingleMapper.ToBoolean Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToBooleanCheck Method

TnxSingleMapper.ToBooleanCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToByte8 Method

TnxSingleMapper.ToByte8 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToByteArray Method

TnxSingleMapper.ToByteArray Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToByteCheck Method

TnxSingleMapper.ToByteCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToCurrency Method

TnxSingleMapper.ToCurrency Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToCurrencyCheck Method

TnxSingleMapper.ToCurrencyCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToDouble Method

TnxSingleMapper.ToDouble Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToExtended Method

TnxSingleMapper.ToExtended Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt16 Method

TnxSingleMapper.ToInt16 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt16Check Method

TnxSingleMapper.ToInt16Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt32 Method

TnxSingleMapper.ToInt32 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt32Check Method

TnxSingleMapper.ToInt32Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt64 Method

TnxSingleMapper.ToInt64 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt64Check Method

TnxSingleMapper.ToInt64Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt8 Method

TnxSingleMapper.ToInt8 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToInt8Check Method

TnxSingleMapper.ToInt8Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToNullString Method

TnxSingleMapper.ToNullString Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToNullStringCheck Method

TnxSingleMapper.ToNullStringCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToShortString Method

TnxSingleMapper.ToShortString Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToShortStringCheck Method

TnxSingleMapper.ToShortStringCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToSingle Method

TnxSingleMapper.ToSingle Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWideChar Method

TnxSingleMapper.ToWideChar Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWideCharCheck Method

TnxSingleMapper.ToWideCharCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWideString Method

TnxSingleMapper.ToWideString Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWideStringCheck Method

TnxSingleMapper.ToWideStringCheck Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWord16 Method

TnxSingleMapper.ToWord16 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWord16Check Method

TnxSingleMapper.ToWord16Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWord32 Method

TnxSingleMapper.ToWord32 Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxSingleMapper.ToWord32Check Method

TnxSingleMapper.ToWord32Check Method
TnxSingleMapper Class TnxSingleMapper Members nxsdFieldMapper Namespace TnxSingleMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxSingleMapper Methods

Links
TnxSingleMapper Class, TnxSingleMapper Members, nxsdFieldMapper Namespace, TnxSingleMapper Methods


TnxTimeMapper Class

TnxTimeMapper Class
TnxTimeMapper Fields TnxTimeMapper Methods TnxTimeMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxTimeMappernxsdFieldMapper_TnxTimeMappernxsdFieldMapper_TnxTimeMapper
Syntax
Delphi
TnxTimeMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxTimeMapper.

Group

Classes

Links
TnxTimeMapper Fields, TnxTimeMapper Methods, TnxTimeMapper Members, nxsdFieldMapper, Classes


TnxTimeMapper Members

TnxTimeMapper Members
TnxTimeMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxTimeMapper.

Class

TnxTimeMapper Class

Protected Fields
Name | Description
tmFormatSettings | This is tmFormatSettings, a member of class TnxTimeMapper.
tmSourceType | This is tmSourceType, a member of class TnxTimeMapper.
tmTargetField | This is tmTargetField, a member of class TnxTimeMapper.
tmTargetLength | This is tmTargetLength, a member of class TnxTimeMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToByteArray |
ToDate |
ToDateTime |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToWideString |
ToWideStringCheck |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxTimeMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxTimeMapper.Create Constructor

TnxTimeMapper.Create Constructor
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxTimeMapper Class

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Class


TnxTimeMapper Fields

TnxTimeMapper Fields
TnxTimeMapper Class Legend Protected Fields Send Feedback

The fields of the TnxTimeMapper class are listed here.

Class

TnxTimeMapper Class

Protected Fields
Name | Description
tmFormatSettings | This is tmFormatSettings, a member of class TnxTimeMapper.
tmSourceType | This is tmSourceType, a member of class TnxTimeMapper.
tmTargetField | This is tmTargetField, a member of class TnxTimeMapper.
tmTargetLength | This is tmTargetLength, a member of class TnxTimeMapper.
Links
TnxTimeMapper Class, Legend, Protected Fields


TnxTimeMapper.tmFormatSettings Field

TnxTimeMapper.tmFormatSettings Field
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Fields Send Feedback
Syntax
Delphi
tmFormatSettings: TFormatSettings;
Description

This is tmFormatSettings, a member of class TnxTimeMapper.

Group

TnxTimeMapper Fields

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Fields


TnxTimeMapper.tmSourceType Field

TnxTimeMapper.tmSourceType Field
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Fields Send Feedback
Syntax
Delphi
tmSourceType: TnxFieldType;
Description

This is tmSourceType, a member of class TnxTimeMapper.

Group

TnxTimeMapper Fields

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Fields


TnxTimeMapper.tmTargetField Field

TnxTimeMapper.tmTargetField Field
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Fields Send Feedback
Syntax
Delphi
tmTargetField: TnxFieldDescriptor;
Description

This is tmTargetField, a member of class TnxTimeMapper.

Group

TnxTimeMapper Fields

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Fields


TnxTimeMapper.tmTargetLength Field

TnxTimeMapper.tmTargetLength Field
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Fields Send Feedback
Syntax
Delphi
tmTargetLength: Integer;
Description

This is tmTargetLength, a member of class TnxTimeMapper.

Group

TnxTimeMapper Fields

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Fields


TnxTimeMapper Methods

TnxTimeMapper Methods
TnxTimeMapper Class Legend Protected Methods Send Feedback

The methods of the TnxTimeMapper class are listed here.

Class

TnxTimeMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToByteArray |
ToDate |
ToDateTime |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToTime |
ToWideString |
ToWideStringCheck |
Links
TnxTimeMapper Class, Legend, Protected Methods


TnxTimeMapper.InternalCreateMapper Method

TnxTimeMapper.InternalCreateMapper Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToByteArray Method

TnxTimeMapper.ToByteArray Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToDate Method

TnxTimeMapper.ToDate Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToDateTime Method

TnxTimeMapper.ToDateTime Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToNullString Method

TnxTimeMapper.ToNullString Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToNullStringCheck Method

TnxTimeMapper.ToNullStringCheck Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToShortString Method

TnxTimeMapper.ToShortString Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToShortStringCheck Method

TnxTimeMapper.ToShortStringCheck Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToTime Method

TnxTimeMapper.ToTime Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
class function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToWideString Method

TnxTimeMapper.ToWideString Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxTimeMapper.ToWideStringCheck Method

TnxTimeMapper.ToWideStringCheck Method
TnxTimeMapper Class TnxTimeMapper Members nxsdFieldMapper Namespace TnxTimeMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxTimeMapper Methods

Links
TnxTimeMapper Class, TnxTimeMapper Members, nxsdFieldMapper Namespace, TnxTimeMapper Methods


TnxWideCharMapper Class

TnxWideCharMapper Class
TnxWideCharMapper Fields TnxWideCharMapper Methods TnxWideCharMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWideCharMappernxsdFieldMapper_TnxWideCharMappernxsdFieldMapper_TnxWideCharMapper
Syntax
Delphi
TnxWideCharMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWideCharMapper.

Group

Classes

Links
TnxWideCharMapper Fields, TnxWideCharMapper Methods, TnxWideCharMapper Members, nxsdFieldMapper, Classes


TnxWideCharMapper Members

TnxWideCharMapper Members
TnxWideCharMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideCharMapper.

Class

TnxWideCharMapper Class

Protected Fields
Name | Description
wccSourceCodepage | This is wccSourceCodepage, a member of class TnxWideCharMapper.
wccTargetCodepage | This is wccTargetCodepage, a member of class TnxWideCharMapper.
wccTargetLength | private
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiCharConvert |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullStringConvert |
ToNullStringConvertCheck |
ToShortStringConvert |
ToShortStringConvertCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideString |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWideCharMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWideCharMapper.Create Constructor

TnxWideCharMapper.Create Constructor
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWideCharMapper Class

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Class


TnxWideCharMapper Fields

TnxWideCharMapper Fields
TnxWideCharMapper Class Legend Protected Fields Send Feedback

The fields of the TnxWideCharMapper class are listed here.

Class

TnxWideCharMapper Class

Protected Fields
Name | Description
wccSourceCodepage | This is wccSourceCodepage, a member of class TnxWideCharMapper.
wccTargetCodepage | This is wccTargetCodepage, a member of class TnxWideCharMapper.
wccTargetLength | private
Links
TnxWideCharMapper Class, Legend, Protected Fields


TnxWideCharMapper.wccSourceCodepage Field

TnxWideCharMapper.wccSourceCodepage Field
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Fields Send Feedback
Syntax
Delphi
wccSourceCodepage: Word;
Description

This is wccSourceCodepage, a member of class TnxWideCharMapper.

Group

TnxWideCharMapper Fields

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Fields


TnxWideCharMapper.wccTargetCodepage Field

TnxWideCharMapper.wccTargetCodepage Field
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Fields Send Feedback
Syntax
Delphi
wccTargetCodepage: Word;
Description

This is wccTargetCodepage, a member of class TnxWideCharMapper.

Group

TnxWideCharMapper Fields

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Fields


TnxWideCharMapper.wccTargetLength Field

TnxWideCharMapper.wccTargetLength Field
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Fields Send Feedback
Syntax
Delphi
wccTargetLength: Integer;
Description

private

Group

TnxWideCharMapper Fields

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Fields


TnxWideCharMapper Methods

TnxWideCharMapper Methods
TnxWideCharMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideCharMapper class are listed here.

Class

TnxWideCharMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiCharConvert |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToNullStringConvert |
ToNullStringConvertCheck |
ToShortStringConvert |
ToShortStringConvertCheck |
ToSingle |
ToSingleCheck |
ToWideChar |
ToWideString |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxWideCharMapper Class, Legend, Protected Methods


TnxWideCharMapper.InternalCreateMapper Method

TnxWideCharMapper.InternalCreateMapper Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToAnsiCharConvert Method

TnxWideCharMapper.ToAnsiCharConvert Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToBoolean Method

TnxWideCharMapper.ToBoolean Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToBooleanCheck Method

TnxWideCharMapper.ToBooleanCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToByte8 Method

TnxWideCharMapper.ToByte8 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToByteArray Method

TnxWideCharMapper.ToByteArray Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToByteCheck Method

TnxWideCharMapper.ToByteCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToCurrency Method

TnxWideCharMapper.ToCurrency Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToCurrencyCheck Method

TnxWideCharMapper.ToCurrencyCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToDouble Method

TnxWideCharMapper.ToDouble Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToDoubleCheck Method

TnxWideCharMapper.ToDoubleCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToExtended Method

TnxWideCharMapper.ToExtended Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToExtendedCheck Method

TnxWideCharMapper.ToExtendedCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt16 Method

TnxWideCharMapper.ToInt16 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt16Check Method

TnxWideCharMapper.ToInt16Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt32 Method

TnxWideCharMapper.ToInt32 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt32Check Method

TnxWideCharMapper.ToInt32Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt64 Method

TnxWideCharMapper.ToInt64 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt64Check Method

TnxWideCharMapper.ToInt64Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt8 Method

TnxWideCharMapper.ToInt8 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToInt8Check Method

TnxWideCharMapper.ToInt8Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToNullStringConvert Method

TnxWideCharMapper.ToNullStringConvert Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToNullStringConvertCheck Method

TnxWideCharMapper.ToNullStringConvertCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToShortStringConvert Method

TnxWideCharMapper.ToShortStringConvert Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToShortStringConvertCheck Method

TnxWideCharMapper.ToShortStringConvertCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToSingle Method

TnxWideCharMapper.ToSingle Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToSingleCheck Method

TnxWideCharMapper.ToSingleCheck Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWideChar Method

TnxWideCharMapper.ToWideChar Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWideString Method

TnxWideCharMapper.ToWideString Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWord16 Method

TnxWideCharMapper.ToWord16 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWord16Check Method

TnxWideCharMapper.ToWord16Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWord32 Method

TnxWideCharMapper.ToWord32 Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideCharMapper.ToWord32Check Method

TnxWideCharMapper.ToWord32Check Method
TnxWideCharMapper Class TnxWideCharMapper Members nxsdFieldMapper Namespace TnxWideCharMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxWideCharMapper Methods

Links
TnxWideCharMapper Class, TnxWideCharMapper Members, nxsdFieldMapper Namespace, TnxWideCharMapper Methods


TnxWideStringMapper Class

TnxWideStringMapper Class
TnxWideStringMapper Fields TnxWideStringMapper Methods TnxWideStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWideStringMappernxsdFieldMapper_TnxWideStringMappernxsdFieldMapper_TnxWideStringMapper
Syntax
Delphi
TnxWideStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWideStringMapper.

Group

Classes

Links
TnxWideStringMapper Fields, TnxWideStringMapper Methods, TnxWideStringMapper Members, nxsdFieldMapper, Classes


TnxWideStringMapper Members

TnxWideStringMapper Members
TnxWideStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideStringMapper.

Class

TnxWideStringMapper Class

Protected Fields
Name | Description
wsmFormatSettings | private
wsmMaxCharSize | This is wsmMaxCharSize, a member of class TnxWideStringMapper.
wsmSourceLength | This is wsmSourceLength, a member of class TnxWideStringMapper.
wsmTargetCodepage | This is wsmTargetCodepage, a member of class TnxWideStringMapper.
wsmTargetDecPl | This is wsmTargetDecPl, a member of class TnxWideStringMapper.
wsmTargetLength | This is wsmTargetLength, a member of class TnxWideStringMapper.
wsmTargetUnits | This is wsmTargetUnits, a member of class TnxWideStringMapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToAnsiCharConvert |
ToAnsiCharConvertCheck |
ToBcd |
ToBcdCheck |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDate |
ToDateCheck |
ToDateTime |
ToDateTimeCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToGuid |
ToGuidCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToSingle |
ToSingleCheck |
ToTime |
ToTimeCheck |
ToWideChar |
ToWideCharCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWideStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWideStringMapper.Create Constructor

TnxWideStringMapper.Create Constructor
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWideStringMapper Class

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Class


TnxWideStringMapper Fields

TnxWideStringMapper Fields
TnxWideStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringMapper class are listed here.

Class

TnxWideStringMapper Class

Protected Fields
Name | Description
wsmFormatSettings | private
wsmMaxCharSize | This is wsmMaxCharSize, a member of class TnxWideStringMapper.
wsmSourceLength | This is wsmSourceLength, a member of class TnxWideStringMapper.
wsmTargetCodepage | This is wsmTargetCodepage, a member of class TnxWideStringMapper.
wsmTargetDecPl | This is wsmTargetDecPl, a member of class TnxWideStringMapper.
wsmTargetLength | This is wsmTargetLength, a member of class TnxWideStringMapper.
wsmTargetUnits | This is wsmTargetUnits, a member of class TnxWideStringMapper.
Links
TnxWideStringMapper Class, Legend, Protected Fields


TnxWideStringMapper.wsmFormatSettings Field

TnxWideStringMapper.wsmFormatSettings Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmFormatSettings: TFormatSettings;
Description

private

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmMaxCharSize Field

TnxWideStringMapper.wsmMaxCharSize Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmMaxCharSize: Integer;
Description

This is wsmMaxCharSize, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmSourceLength Field

TnxWideStringMapper.wsmSourceLength Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmSourceLength: Integer;
Description

This is wsmSourceLength, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmTargetCodepage Field

TnxWideStringMapper.wsmTargetCodepage Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmTargetCodepage: Word;
Description

This is wsmTargetCodepage, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmTargetDecPl Field

TnxWideStringMapper.wsmTargetDecPl Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmTargetDecPl: Integer;
Description

This is wsmTargetDecPl, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmTargetLength Field

TnxWideStringMapper.wsmTargetLength Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmTargetLength: Integer;
Description

This is wsmTargetLength, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper.wsmTargetUnits Field

TnxWideStringMapper.wsmTargetUnits Field
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Fields Send Feedback
Syntax
Delphi
wsmTargetUnits: Integer;
Description

This is wsmTargetUnits, a member of class TnxWideStringMapper.

Group

TnxWideStringMapper Fields

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Fields


TnxWideStringMapper Methods

TnxWideStringMapper Methods
TnxWideStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringMapper class are listed here.

Class

TnxWideStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToAnsiCharConvert |
ToAnsiCharConvertCheck |
ToBcd |
ToBcdCheck |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteArrayCheck |
ToByteCheck |
ToCurrency |
ToCurrencyCheck |
ToDate |
ToDateCheck |
ToDateTime |
ToDateTimeCheck |
ToDouble |
ToDoubleCheck |
ToExtended |
ToExtendedCheck |
ToGuid |
ToGuidCheck |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt64Check |
ToInt8 |
ToInt8Check |
ToSingle |
ToSingleCheck |
ToTime |
ToTimeCheck |
ToWideChar |
ToWideCharCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
ToWord32Check |
Links
TnxWideStringMapper Class, Legend, Protected Methods


TnxWideStringMapper.InternalCreateMapper Method

TnxWideStringMapper.InternalCreateMapper Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToAnsiChar Method

TnxWideStringMapper.ToAnsiChar Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToAnsiCharCheck Method

TnxWideStringMapper.ToAnsiCharCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToAnsiCharConvert Method

TnxWideStringMapper.ToAnsiCharConvert Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvert(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToAnsiCharConvertCheck Method

TnxWideStringMapper.ToAnsiCharConvertCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToBcd Method

TnxWideStringMapper.ToBcd Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToBcdCheck Method

TnxWideStringMapper.ToBcdCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToBoolean Method

TnxWideStringMapper.ToBoolean Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToBooleanCheck Method

TnxWideStringMapper.ToBooleanCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToByte8 Method

TnxWideStringMapper.ToByte8 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToByteArray Method

TnxWideStringMapper.ToByteArray Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToByteArrayCheck Method

TnxWideStringMapper.ToByteArrayCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToByteArrayCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToByteCheck Method

TnxWideStringMapper.ToByteCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToCurrency Method

TnxWideStringMapper.ToCurrency Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToCurrencyCheck Method

TnxWideStringMapper.ToCurrencyCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToCurrencyCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDate Method

TnxWideStringMapper.ToDate Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToDate(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDateCheck Method

TnxWideStringMapper.ToDateCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDateTime Method

TnxWideStringMapper.ToDateTime Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTime(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDateTimeCheck Method

TnxWideStringMapper.ToDateTimeCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToDateTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDouble Method

TnxWideStringMapper.ToDouble Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToDoubleCheck Method

TnxWideStringMapper.ToDoubleCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToDoubleCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToExtended Method

TnxWideStringMapper.ToExtended Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToExtendedCheck Method

TnxWideStringMapper.ToExtendedCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToExtendedCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToGuid Method

TnxWideStringMapper.ToGuid Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuid(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToGuidCheck Method

TnxWideStringMapper.ToGuidCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToGuidCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt16 Method

TnxWideStringMapper.ToInt16 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt16Check Method

TnxWideStringMapper.ToInt16Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt32 Method

TnxWideStringMapper.ToInt32 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt32Check Method

TnxWideStringMapper.ToInt32Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt64 Method

TnxWideStringMapper.ToInt64 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt64Check Method

TnxWideStringMapper.ToInt64Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt64Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt8 Method

TnxWideStringMapper.ToInt8 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToInt8Check Method

TnxWideStringMapper.ToInt8Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToSingle Method

TnxWideStringMapper.ToSingle Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToSingleCheck Method

TnxWideStringMapper.ToSingleCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToSingleCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToTime Method

TnxWideStringMapper.ToTime Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToTime(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToTimeCheck Method

TnxWideStringMapper.ToTimeCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToTimeCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWideChar Method

TnxWideStringMapper.ToWideChar Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWideCharCheck Method

TnxWideStringMapper.ToWideCharCheck Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWord16 Method

TnxWideStringMapper.ToWord16 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWord16Check Method

TnxWideStringMapper.ToWord16Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWord32 Method

TnxWideStringMapper.ToWord32 Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringMapper.ToWord32Check Method

TnxWideStringMapper.ToWord32Check Method
TnxWideStringMapper Class TnxWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWord32Check(const aSource; var aTarget): TnxResult;
Group

TnxWideStringMapper Methods

Links
TnxWideStringMapper Class, TnxWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringMapper Methods


TnxWideStringToAnsiStringMapper Class

TnxWideStringToAnsiStringMapper Class
TnxWideStringToAnsiStringMapper Fields TnxWideStringToAnsiStringMapper Methods TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWideStringToAnsiStringMappernxsdFieldMapper_TnxWideStringToAnsiStringMappernxsdFieldMapper_TnxWideStringToAnsiStringMapper
Syntax
Delphi
TnxWideStringToAnsiStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWideStringToAnsiStringMapper.

Group

Classes

Links
TnxWideStringToAnsiStringMapper Fields, TnxWideStringToAnsiStringMapper Methods, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper, Classes


TnxWideStringToAnsiStringMapper Members

TnxWideStringToAnsiStringMapper Members
TnxWideStringToAnsiStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideStringToAnsiStringMapper.

Class

TnxWideStringToAnsiStringMapper Class

Protected Fields
Name | Description
wtaTargetCodepage | This is wtaTargetCodepage, a member of class TnxWideStringToAnsiStringMapper.
wtaTargetLength | private
Protected Methods
Name | Description
InternalCreateMapper |
Register |
ToNullStringConvert |
ToNullStringConvertCheck |
ToNullStringConvertCheckPadding |
ToNullStringConvertPadding | This is ToNullStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvert | This is ToShortStringConvert, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvertCheck |
ToShortStringConvertCheckPadding | This is ToShortStringConvertCheckPadding, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvertPadding | This is ToShortStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.
Unregister |
Public Methods
Name | Description
Create |
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWideStringToAnsiStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWideStringToAnsiStringMapper.Create Constructor

TnxWideStringToAnsiStringMapper.Create Constructor
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWideStringToAnsiStringMapper Class

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Class


TnxWideStringToAnsiStringMapper Fields

TnxWideStringToAnsiStringMapper Fields
TnxWideStringToAnsiStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringToAnsiStringMapper class are listed here.

Class

TnxWideStringToAnsiStringMapper Class

Protected Fields
Name | Description
wtaTargetCodepage | This is wtaTargetCodepage, a member of class TnxWideStringToAnsiStringMapper.
wtaTargetLength | private
Links
TnxWideStringToAnsiStringMapper Class, Legend, Protected Fields


TnxWideStringToAnsiStringMapper.wtaTargetCodepage Field

TnxWideStringToAnsiStringMapper.wtaTargetCodepage Field
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Fields Send Feedback
Syntax
Delphi
wtaTargetCodepage: Word;
Description

This is wtaTargetCodepage, a member of class TnxWideStringToAnsiStringMapper.

Group

TnxWideStringToAnsiStringMapper Fields

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Fields


TnxWideStringToAnsiStringMapper.wtaTargetLength Field

TnxWideStringToAnsiStringMapper.wtaTargetLength Field
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Fields Send Feedback
Syntax
Delphi
wtaTargetLength: Integer;
Description

private

Group

TnxWideStringToAnsiStringMapper Fields

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Fields


TnxWideStringToAnsiStringMapper Methods

TnxWideStringToAnsiStringMapper Methods
TnxWideStringToAnsiStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringToAnsiStringMapper class are listed here.

Class

TnxWideStringToAnsiStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToNullStringConvert |
ToNullStringConvertCheck |
ToNullStringConvertCheckPadding |
ToNullStringConvertPadding | This is ToNullStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvert | This is ToShortStringConvert, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvertCheck |
ToShortStringConvertCheckPadding | This is ToShortStringConvertCheckPadding, a member of class TnxWideStringToAnsiStringMapper.
ToShortStringConvertPadding | This is ToShortStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.
Links
TnxWideStringToAnsiStringMapper Class, Legend, Protected Methods


TnxWideStringToAnsiStringMapper.InternalCreateMapper Method

TnxWideStringToAnsiStringMapper.InternalCreateMapper Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToNullStringConvert Method

TnxWideStringToAnsiStringMapper.ToNullStringConvert Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvert(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToNullStringConvertCheck Method

TnxWideStringToAnsiStringMapper.ToNullStringConvertCheck Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToNullStringConvertCheckPadding Method

TnxWideStringToAnsiStringMapper.ToNullStringConvertCheckPadding Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToNullStringConvertPadding Method

TnxWideStringToAnsiStringMapper.ToNullStringConvertPadding Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToNullStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

This is ToNullStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.

Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToShortStringConvert Method

TnxWideStringToAnsiStringMapper.ToShortStringConvert Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvert(const aSource; var aTarget): TnxResult;
Description

This is ToShortStringConvert, a member of class TnxWideStringToAnsiStringMapper.

Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToShortStringConvertCheck Method

TnxWideStringToAnsiStringMapper.ToShortStringConvertCheck Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToShortStringConvertCheckPadding Method

TnxWideStringToAnsiStringMapper.ToShortStringConvertCheckPadding Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertCheckPadding(const aSource; var aTarget): TnxResult;
Description

This is ToShortStringConvertCheckPadding, a member of class TnxWideStringToAnsiStringMapper.

Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToAnsiStringMapper.ToShortStringConvertPadding Method

TnxWideStringToAnsiStringMapper.ToShortStringConvertPadding Method
TnxWideStringToAnsiStringMapper Class TnxWideStringToAnsiStringMapper Members nxsdFieldMapper Namespace TnxWideStringToAnsiStringMapper Methods Send Feedback
Syntax
Delphi
function ToShortStringConvertPadding(const aSource; var aTarget): TnxResult;
Description

This is ToShortStringConvertPadding, a member of class TnxWideStringToAnsiStringMapper.

Group

TnxWideStringToAnsiStringMapper Methods

Links
TnxWideStringToAnsiStringMapper Class, TnxWideStringToAnsiStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToAnsiStringMapper Methods


TnxWideStringToWideStringMapper Class

TnxWideStringToWideStringMapper Class
TnxWideStringToWideStringMapper Fields TnxWideStringToWideStringMapper Methods TnxWideStringToWideStringMapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWideStringToWideStringMappernxsdFieldMapper_TnxWideStringToWideStringMappernxsdFieldMapper_TnxWideStringToWideStringMapper
Syntax
Delphi
TnxWideStringToWideStringMapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWideStringToWideStringMapper.

Group

Classes

Links
TnxWideStringToWideStringMapper Fields, TnxWideStringToWideStringMapper Methods, TnxWideStringToWideStringMapper Members, nxsdFieldMapper, Classes


TnxWideStringToWideStringMapper Members

TnxWideStringToWideStringMapper Members
TnxWideStringToWideStringMapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWideStringToWideStringMapper.

Class

TnxWideStringToWideStringMapper Class

Protected Fields
Name | Description
wtwTargetLength | private
wtwTargetUnits | This is wtwTargetUnits, a member of class TnxWideStringToWideStringMapper.
Protected Methods
Name | Description
InternalCreateMapper |
Register |
ToWideString |
ToWideStringCheck |
ToWideStringCheckPadding |
ToWideStringPadding | This is ToWideStringPadding, a member of class TnxWideStringToWideStringMapper.
ToWideStringTrunc | This is ToWideStringTrunc, a member of class TnxWideStringToWideStringMapper.
ToWideStringTruncPadding | This is ToWideStringTruncPadding, a member of class TnxWideStringToWideStringMapper.
Unregister |
Public Methods
Name | Description
Create |
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWideStringToWideStringMapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWideStringToWideStringMapper.Create Constructor

TnxWideStringToWideStringMapper.Create Constructor
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWideStringToWideStringMapper Class

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Class


TnxWideStringToWideStringMapper Fields

TnxWideStringToWideStringMapper Fields
TnxWideStringToWideStringMapper Class Legend Protected Fields Send Feedback

The fields of the TnxWideStringToWideStringMapper class are listed here.

Class

TnxWideStringToWideStringMapper Class

Protected Fields
Name | Description
wtwTargetLength | private
wtwTargetUnits | This is wtwTargetUnits, a member of class TnxWideStringToWideStringMapper.
Links
TnxWideStringToWideStringMapper Class, Legend, Protected Fields


TnxWideStringToWideStringMapper.wtwTargetLength Field

TnxWideStringToWideStringMapper.wtwTargetLength Field
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Fields Send Feedback
Syntax
Delphi
wtwTargetLength: Integer;
Description

private

Group

TnxWideStringToWideStringMapper Fields

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Fields


TnxWideStringToWideStringMapper.wtwTargetUnits Field

TnxWideStringToWideStringMapper.wtwTargetUnits Field
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Fields Send Feedback
Syntax
Delphi
wtwTargetUnits: Integer;
Description

This is wtwTargetUnits, a member of class TnxWideStringToWideStringMapper.

Group

TnxWideStringToWideStringMapper Fields

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Fields


TnxWideStringToWideStringMapper Methods

TnxWideStringToWideStringMapper Methods
TnxWideStringToWideStringMapper Class Legend Protected Methods Send Feedback

The methods of the TnxWideStringToWideStringMapper class are listed here.

Class

TnxWideStringToWideStringMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToWideString |
ToWideStringCheck |
ToWideStringCheckPadding |
ToWideStringPadding | This is ToWideStringPadding, a member of class TnxWideStringToWideStringMapper.
ToWideStringTrunc | This is ToWideStringTrunc, a member of class TnxWideStringToWideStringMapper.
ToWideStringTruncPadding | This is ToWideStringTruncPadding, a member of class TnxWideStringToWideStringMapper.
Links
TnxWideStringToWideStringMapper Class, Legend, Protected Methods


TnxWideStringToWideStringMapper.InternalCreateMapper Method

TnxWideStringToWideStringMapper.InternalCreateMapper Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideString Method

TnxWideStringToWideStringMapper.ToWideString Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideStringCheck Method

TnxWideStringToWideStringMapper.ToWideStringCheck Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideStringCheckPadding Method

TnxWideStringToWideStringMapper.ToWideStringCheckPadding Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheckPadding(const aSource; var aTarget): TnxResult;
Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideStringPadding Method

TnxWideStringToWideStringMapper.ToWideStringPadding Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
class function ToWideStringPadding(const aSource; var aTarget): TnxResult;
Description

This is ToWideStringPadding, a member of class TnxWideStringToWideStringMapper.

Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideStringTrunc Method

TnxWideStringToWideStringMapper.ToWideStringTrunc Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringTrunc(const aSource; var aTarget): TnxResult;
Description

This is ToWideStringTrunc, a member of class TnxWideStringToWideStringMapper.

Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWideStringToWideStringMapper.ToWideStringTruncPadding Method

TnxWideStringToWideStringMapper.ToWideStringTruncPadding Method
TnxWideStringToWideStringMapper Class TnxWideStringToWideStringMapper Members nxsdFieldMapper Namespace TnxWideStringToWideStringMapper Methods Send Feedback
Syntax
Delphi
function ToWideStringTruncPadding(const aSource; var aTarget): TnxResult;
Description

This is ToWideStringTruncPadding, a member of class TnxWideStringToWideStringMapper.

Group

TnxWideStringToWideStringMapper Methods

Links
TnxWideStringToWideStringMapper Class, TnxWideStringToWideStringMapper Members, nxsdFieldMapper Namespace, TnxWideStringToWideStringMapper Methods


TnxWord16Mapper Class

TnxWord16Mapper Class
TnxWord16Mapper Fields TnxWord16Mapper Methods TnxWord16Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWord16MappernxsdFieldMapper_TnxWord16MappernxsdFieldMapper_TnxWord16Mapper
Syntax
Delphi
TnxWord16Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWord16Mapper.

Group

Classes

Links
TnxWord16Mapper Fields, TnxWord16Mapper Methods, TnxWord16Mapper Members, nxsdFieldMapper, Classes


TnxWord16Mapper Members

TnxWord16Mapper Members
TnxWord16Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWord16Mapper.

Class

TnxWord16Mapper Class

Protected Fields
Name | Description
w16mTargetDecPl | This is w16mTargetDecPl, a member of class TnxWord16Mapper.
w16mTargetLength | private
w16mTargetUnits | This is w16mTargetUnits, a member of class TnxWord16Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord32 |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWord16Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWord16Mapper.Create Constructor

TnxWord16Mapper.Create Constructor
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWord16Mapper Class

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Class


TnxWord16Mapper Fields

TnxWord16Mapper Fields
TnxWord16Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxWord16Mapper class are listed here.

Class

TnxWord16Mapper Class

Protected Fields
Name | Description
w16mTargetDecPl | This is w16mTargetDecPl, a member of class TnxWord16Mapper.
w16mTargetLength | private
w16mTargetUnits | This is w16mTargetUnits, a member of class TnxWord16Mapper.
Links
TnxWord16Mapper Class, Legend, Protected Fields


TnxWord16Mapper.w16mTargetDecPl Field

TnxWord16Mapper.w16mTargetDecPl Field
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Fields Send Feedback
Syntax
Delphi
w16mTargetDecPl: Integer;
Description

This is w16mTargetDecPl, a member of class TnxWord16Mapper.

Group

TnxWord16Mapper Fields

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Fields


TnxWord16Mapper.w16mTargetLength Field

TnxWord16Mapper.w16mTargetLength Field
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Fields Send Feedback
Syntax
Delphi
w16mTargetLength: Integer;
Description

private

Group

TnxWord16Mapper Fields

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Fields


TnxWord16Mapper.w16mTargetUnits Field

TnxWord16Mapper.w16mTargetUnits Field
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Fields Send Feedback
Syntax
Delphi
w16mTargetUnits: Integer;
Description

This is w16mTargetUnits, a member of class TnxWord16Mapper.

Group

TnxWord16Mapper Fields

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Fields


TnxWord16Mapper Methods

TnxWord16Mapper Methods
TnxWord16Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxWord16Mapper class are listed here.

Class

TnxWord16Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord32 |
Links
TnxWord16Mapper Class, Legend, Protected Methods


TnxWord16Mapper.InternalCreateMapper Method

TnxWord16Mapper.InternalCreateMapper Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToAnsiChar Method

TnxWord16Mapper.ToAnsiChar Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToAnsiCharCheck Method

TnxWord16Mapper.ToAnsiCharCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToBcd Method

TnxWord16Mapper.ToBcd Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToBcdCheck Method

TnxWord16Mapper.ToBcdCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToBcdTrunc Method

TnxWord16Mapper.ToBcdTrunc Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToBoolean Method

TnxWord16Mapper.ToBoolean Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToBooleanCheck Method

TnxWord16Mapper.ToBooleanCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToByte8 Method

TnxWord16Mapper.ToByte8 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToByteArray Method

TnxWord16Mapper.ToByteArray Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToByteCheck Method

TnxWord16Mapper.ToByteCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToCurrency Method

TnxWord16Mapper.ToCurrency Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToDouble Method

TnxWord16Mapper.ToDouble Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToExtended Method

TnxWord16Mapper.ToExtended Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt16 Method

TnxWord16Mapper.ToInt16 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt16Check Method

TnxWord16Mapper.ToInt16Check Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt32 Method

TnxWord16Mapper.ToInt32 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt64 Method

TnxWord16Mapper.ToInt64 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt8 Method

TnxWord16Mapper.ToInt8 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToInt8Check Method

TnxWord16Mapper.ToInt8Check Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToNullString Method

TnxWord16Mapper.ToNullString Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToNullStringCheck Method

TnxWord16Mapper.ToNullStringCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToShortString Method

TnxWord16Mapper.ToShortString Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToShortStringCheck Method

TnxWord16Mapper.ToShortStringCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToSingle Method

TnxWord16Mapper.ToSingle Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWideChar Method

TnxWord16Mapper.ToWideChar Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWideCharCheck Method

TnxWord16Mapper.ToWideCharCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWideString Method

TnxWord16Mapper.ToWideString Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWideStringCheck Method

TnxWord16Mapper.ToWideStringCheck Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWord16 Method

TnxWord16Mapper.ToWord16 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord16Mapper.ToWord32 Method

TnxWord16Mapper.ToWord32 Method
TnxWord16Mapper Class TnxWord16Mapper Members nxsdFieldMapper Namespace TnxWord16Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxWord16Mapper Methods

Links
TnxWord16Mapper Class, TnxWord16Mapper Members, nxsdFieldMapper Namespace, TnxWord16Mapper Methods


TnxWord32Mapper Class

TnxWord32Mapper Class
TnxWord32Mapper Fields TnxWord32Mapper Methods TnxWord32Mapper Members nxsdFieldMapper Classes Send Feedback
Class Hierarchy
nxsdFieldMapper_TnxWord32MappernxsdFieldMapper_TnxWord32MappernxsdFieldMapper_TnxWord32Mapper
Syntax
Delphi
TnxWord32Mapper = class(TnxBaseFieldMapper);
File

nxsdFieldMapper

Description

This is class nxsdFieldMapper.TnxWord32Mapper.

Group

Classes

Links
TnxWord32Mapper Fields, TnxWord32Mapper Methods, TnxWord32Mapper Members, nxsdFieldMapper, Classes


TnxWord32Mapper Members

TnxWord32Mapper Members
TnxWord32Mapper Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxWord32Mapper.

Class

TnxWord32Mapper Class

Protected Fields
Name | Description
w32mTargetDecPl | This is w32mTargetDecPl, a member of class TnxWord32Mapper.
w32mTargetLength | private
w32mTargetUnits | This is w32mTargetUnits, a member of class TnxWord32Mapper.
Protected Methods
Name | Description
Create |
InternalCreateMapper |
Register |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxWord32Mapper Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxWord32Mapper.Create Constructor

TnxWord32Mapper.Create Constructor
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Class Send Feedback
Syntax
Delphi
constructor Create(aSourceField: TnxFieldDescriptor; aTargetField: TnxFieldDescriptor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod);
Class

TnxWord32Mapper Class

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Class


TnxWord32Mapper Fields

TnxWord32Mapper Fields
TnxWord32Mapper Class Legend Protected Fields Send Feedback

The fields of the TnxWord32Mapper class are listed here.

Class

TnxWord32Mapper Class

Protected Fields
Name | Description
w32mTargetDecPl | This is w32mTargetDecPl, a member of class TnxWord32Mapper.
w32mTargetLength | private
w32mTargetUnits | This is w32mTargetUnits, a member of class TnxWord32Mapper.
Links
TnxWord32Mapper Class, Legend, Protected Fields


TnxWord32Mapper.w32mTargetDecPl Field

TnxWord32Mapper.w32mTargetDecPl Field
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Fields Send Feedback
Syntax
Delphi
w32mTargetDecPl: Integer;
Description

This is w32mTargetDecPl, a member of class TnxWord32Mapper.

Group

TnxWord32Mapper Fields

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Fields


TnxWord32Mapper.w32mTargetLength Field

TnxWord32Mapper.w32mTargetLength Field
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Fields Send Feedback
Syntax
Delphi
w32mTargetLength: Integer;
Description

private

Group

TnxWord32Mapper Fields

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Fields


TnxWord32Mapper.w32mTargetUnits Field

TnxWord32Mapper.w32mTargetUnits Field
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Fields Send Feedback
Syntax
Delphi
w32mTargetUnits: Integer;
Description

This is w32mTargetUnits, a member of class TnxWord32Mapper.

Group

TnxWord32Mapper Fields

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Fields


TnxWord32Mapper Methods

TnxWord32Mapper Methods
TnxWord32Mapper Class Legend Protected Methods Send Feedback

The methods of the TnxWord32Mapper class are listed here.

Class

TnxWord32Mapper Class

Protected Methods
Name | Description
InternalCreateMapper |
ToAnsiChar |
ToAnsiCharCheck |
ToBcd |
ToBcdCheck |
ToBcdTrunc |
ToBoolean |
ToBooleanCheck |
ToByte8 |
ToByteArray |
ToByteCheck |
ToCurrency |
ToDouble |
ToExtended |
ToInt16 |
ToInt16Check |
ToInt32 |
ToInt32Check |
ToInt64 |
ToInt8 |
ToInt8Check |
ToNullString |
ToNullStringCheck |
ToShortString |
ToShortStringCheck |
ToSingle |
ToWideChar |
ToWideCharCheck |
ToWideString |
ToWideStringCheck |
ToWord16 |
ToWord16Check |
ToWord32 |
Links
TnxWord32Mapper Class, Legend, Protected Methods


TnxWord32Mapper.InternalCreateMapper Method

TnxWord32Mapper.InternalCreateMapper Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; override;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToAnsiChar Method

TnxWord32Mapper.ToAnsiChar Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiChar(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToAnsiCharCheck Method

TnxWord32Mapper.ToAnsiCharCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToAnsiCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToBcd Method

TnxWord32Mapper.ToBcd Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcd(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToBcdCheck Method

TnxWord32Mapper.ToBcdCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToBcdTrunc Method

TnxWord32Mapper.ToBcdTrunc Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToBcdTrunc(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToBoolean Method

TnxWord32Mapper.ToBoolean Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToBoolean(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToBooleanCheck Method

TnxWord32Mapper.ToBooleanCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToBooleanCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToByte8 Method

TnxWord32Mapper.ToByte8 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByte8(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToByteArray Method

TnxWord32Mapper.ToByteArray Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteArray(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToByteCheck Method

TnxWord32Mapper.ToByteCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToByteCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToCurrency Method

TnxWord32Mapper.ToCurrency Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToCurrency(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToDouble Method

TnxWord32Mapper.ToDouble Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToDouble(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToExtended Method

TnxWord32Mapper.ToExtended Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToExtended(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt16 Method

TnxWord32Mapper.ToInt16 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt16Check Method

TnxWord32Mapper.ToInt16Check Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt16Check(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt32 Method

TnxWord32Mapper.ToInt32 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt32Check Method

TnxWord32Mapper.ToInt32Check Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt32Check(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt64 Method

TnxWord32Mapper.ToInt64 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt64(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt8 Method

TnxWord32Mapper.ToInt8 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToInt8Check Method

TnxWord32Mapper.ToInt8Check Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToInt8Check(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToNullString Method

TnxWord32Mapper.ToNullString Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToNullString(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToNullStringCheck Method

TnxWord32Mapper.ToNullStringCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToNullStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToShortString Method

TnxWord32Mapper.ToShortString Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToShortString(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToShortStringCheck Method

TnxWord32Mapper.ToShortStringCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToShortStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToSingle Method

TnxWord32Mapper.ToSingle Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToSingle(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWideChar Method

TnxWord32Mapper.ToWideChar Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideChar(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWideCharCheck Method

TnxWord32Mapper.ToWideCharCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideCharCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWideString Method

TnxWord32Mapper.ToWideString Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideString(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWideStringCheck Method

TnxWord32Mapper.ToWideStringCheck Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
function ToWideStringCheck(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWord16 Method

TnxWord32Mapper.ToWord16 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWord16Check Method

TnxWord32Mapper.ToWord16Check Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord16Check(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


TnxWord32Mapper.ToWord32 Method

TnxWord32Mapper.ToWord32 Method
TnxWord32Mapper Class TnxWord32Mapper Members nxsdFieldMapper Namespace TnxWord32Mapper Methods Send Feedback
Syntax
Delphi
class function ToWord32(const aSource; var aTarget): TnxResult;
Group

TnxWord32Mapper Methods

Links
TnxWord32Mapper Class, TnxWord32Mapper Members, nxsdFieldMapper Namespace, TnxWord32Mapper Methods


nxsdFieldMapperBase Namespace

nxsdFieldMapperBase Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxsdFieldMapperBase.

Classes
Name | Description
EnxBaseFieldMapperException | This is class nxsdFieldMapperBase.EnxBaseFieldMapperException.
TnxBaseFieldMapper | This is class nxsdFieldMapperBase.TnxBaseFieldMapper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxBaseFieldMapperClass | This is type nxsdFieldMapperBase.TnxBaseFieldMapperClass.
Variables
Name | Description
_Mappers | This is variable nxsdFieldMapperBase._Mappers.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdFieldMapperBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseFieldMapperException | This is class nxsdFieldMapperBase.EnxBaseFieldMapperException.
TnxBaseFieldMapper | This is class nxsdFieldMapperBase.TnxBaseFieldMapper.
Namespace

nxsdFieldMapperBase Namespace

Links
Classes, nxsdFieldMapperBase Namespace, Legend


EnxBaseFieldMapperException Class

EnxBaseFieldMapperException Class
nxsdFieldMapperBase Classes Send Feedback
Class Hierarchy
nxsdFieldMapperBase_EnxBaseFieldMapperExceptionnxsdFieldMapperBase_EnxBaseFieldMapperExceptionnxsdFieldMapperBase_EnxBaseFieldMapperExceptionnxsdFieldMapperBase_EnxBaseFieldMapperException
Syntax
Delphi
EnxBaseFieldMapperException = class(EnxBaseException);
File

nxsdFieldMapperBase

Description

This is class nxsdFieldMapperBase.EnxBaseFieldMapperException.

Group

Classes

Links
nxsdFieldMapperBase, Classes


TnxBaseFieldMapper Class

TnxBaseFieldMapper Class
TnxBaseFieldMapper Methods TnxBaseFieldMapper Members nxsdFieldMapperBase Classes Send Feedback
Class Hierarchy
nxsdFieldMapperBase_TnxBaseFieldMappernxsdFieldMapperBase_TnxBaseFieldMapper
Syntax
Delphi
TnxBaseFieldMapper = class(TnxObject);
File

nxsdFieldMapperBase

Description

This is class nxsdFieldMapperBase.TnxBaseFieldMapper.

Group

Classes

Links
TnxBaseFieldMapper Methods, TnxBaseFieldMapper Members, nxsdFieldMapperBase, Classes


TnxBaseFieldMapper Members

TnxBaseFieldMapper Members
TnxBaseFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFieldMapper.

Class

TnxBaseFieldMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
Register |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
FreeInstance |
NewInstance | TnxObject
Links
TnxBaseFieldMapper Class, Legend, Protected Methods, Public Methods


TnxBaseFieldMapper Methods

TnxBaseFieldMapper Methods
TnxBaseFieldMapper Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFieldMapper class are listed here.

Class

TnxBaseFieldMapper Class

Protected Methods
Name | Description
InternalCreateMapper |
Register |
Unregister |
Public Methods
Name | Description
CreateMapper | This is the overview for the CreateMapper method overload.
Links
TnxBaseFieldMapper Class, Legend, Protected Methods, Public Methods


CreateMapper Method

CreateMapper Method
TnxBaseFieldMapper Methods Send Feedback

This is the overview for the CreateMapper method overload.

Overload List
Name | Description
TnxBaseFieldMapper.CreateMapper (TnxAbstractCursor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod) |
TnxBaseFieldMapper.CreateMapper (TnxFieldDescriptor, TnxAbstractCursor, TnxFieldDescriptor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod) | TnxBaseFieldMapper
Group

TnxBaseFieldMapper Methods

Links
TnxBaseFieldMapper Methods


TnxBaseFieldMapper.CreateMapper Method (TnxAbstractCursor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod)

TnxBaseFieldMapper.CreateMapper Method (TnxAbstractCursor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod)
TnxBaseFieldMapper Class TnxBaseFieldMapper Members nxsdFieldMapperBase Namespace CreateMapper Method Send Feedback
Syntax
Delphi
class function CreateMapper(aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; overload;
Group

CreateMapper Method

Links
TnxBaseFieldMapper Class, TnxBaseFieldMapper Members, nxsdFieldMapperBase Namespace, CreateMapper Method


TnxBaseFieldMapper.CreateMapper Method (TnxFieldDescriptor, TnxAbstractCursor, TnxFieldDescriptor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod)

TnxBaseFieldMapper.CreateMapper Method (TnxFieldDescriptor, TnxAbstractCursor, TnxFieldDescriptor, TnxAbstractCursor, TnxFieldMapperDescriptor, TnxMappingMethod)
TnxBaseFieldMapper Class TnxBaseFieldMapper Members nxsdFieldMapperBase Namespace CreateMapper Method Send Feedback
Syntax
Delphi
class function CreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; overload;
Description

TnxBaseFieldMapper

Group

CreateMapper Method

Links
TnxBaseFieldMapper Class, TnxBaseFieldMapper Members, nxsdFieldMapperBase Namespace, CreateMapper Method


TnxBaseFieldMapper.InternalCreateMapper Method

TnxBaseFieldMapper.InternalCreateMapper Method
TnxBaseFieldMapper Class TnxBaseFieldMapper Members nxsdFieldMapperBase Namespace TnxBaseFieldMapper Methods Send Feedback
Syntax
Delphi
class function InternalCreateMapper(aSourceField: TnxFieldDescriptor; aSourceCursor: TnxAbstractCursor; aTargetField: TnxFieldDescriptor; aTargetCursor: TnxAbstractCursor; aMapperDesc: TnxFieldMapperDescriptor; out aMapper: TnxMappingMethod): TnxBaseFieldMapper; virtual;
Group

TnxBaseFieldMapper Methods

Links
TnxBaseFieldMapper Class, TnxBaseFieldMapper Members, nxsdFieldMapperBase Namespace, TnxBaseFieldMapper Methods


TnxBaseFieldMapper.Register Method

TnxBaseFieldMapper.Register Method
TnxBaseFieldMapper Class TnxBaseFieldMapper Members nxsdFieldMapperBase Namespace TnxBaseFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure Register(aSourceType: TnxFieldType; aTargetType: TnxFieldType);
Group

TnxBaseFieldMapper Methods

Links
TnxBaseFieldMapper Class, TnxBaseFieldMapper Members, nxsdFieldMapperBase Namespace, TnxBaseFieldMapper Methods


TnxBaseFieldMapper.Unregister Method

TnxBaseFieldMapper.Unregister Method
TnxBaseFieldMapper Class TnxBaseFieldMapper Members nxsdFieldMapperBase Namespace TnxBaseFieldMapper Methods Send Feedback
Syntax
Delphi
class procedure Unregister(aSourceType: TnxFieldType; aTargetType: TnxFieldType);
Group

TnxBaseFieldMapper Methods

Links
TnxBaseFieldMapper Class, TnxBaseFieldMapper Members, nxsdFieldMapperBase Namespace, TnxBaseFieldMapper Methods


Types

Types
nxsdFieldMapperBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFieldMapperBase Namespace

Types
Name | Description
TnxBaseFieldMapperClass | This is type nxsdFieldMapperBase.TnxBaseFieldMapperClass.
Links
nxsdFieldMapperBase Namespace, Types


nxsdFieldMapperBase.TnxBaseFieldMapperClass Type

nxsdFieldMapperBase.TnxBaseFieldMapperClass Type
nxsdFieldMapperBase Types Send Feedback
Syntax
Delphi
TnxBaseFieldMapperClass = class of TnxBaseFieldMapper;
File

nxsdFieldMapperBase

Description

This is type nxsdFieldMapperBase.TnxBaseFieldMapperClass.

Group

Types

Links
nxsdFieldMapperBase, Types


Variables

Variables
nxsdFieldMapperBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFieldMapperBase Namespace

Variables
Name | Description
_Mappers | This is variable nxsdFieldMapperBase._Mappers.
Links
nxsdFieldMapperBase Namespace, Variables


nxsdFieldMapperBase._Mappers Variable

nxsdFieldMapperBase._Mappers Variable
nxsdFieldMapperBase Variables Send Feedback
Syntax
Delphi
_Mappers: array [TnxFieldType, TnxFieldType] of array of TnxBaseFieldMapperClass;
File

nxsdFieldMapperBase

Description

This is variable nxsdFieldMapperBase._Mappers.

Group

Variables

Links
nxsdFieldMapperBase, Variables


nxsdFieldMapperDescriptor Namespace

nxsdFieldMapperDescriptor Namespace
Classes Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxsdFieldMapperDescriptor.

Classes
Name | Description
EnxFieldMapperDescriptorException | This is class nxsdFieldMapperDescriptor.EnxFieldMapperDescriptorException.
TnxFieldMapperDescriptor | This is class nxsdFieldMapperDescriptor.TnxFieldMapperDescriptor.
Structs, Records, Enums
Name | Description
TnxDataLossAction | This is record nxsdFieldMapperDescriptor.TnxDataLossAction.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxFieldMapperDescriptorClass | This is type nxsdFieldMapperDescriptor.TnxFieldMapperDescriptorClass.
Variables
Name | Description
_FieldMapperDescriptorList | This is variable nxsdFieldMapperDescriptor._FieldMapperDescriptorList.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxsdFieldMapperDescriptor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxFieldMapperDescriptorException | This is class nxsdFieldMapperDescriptor.EnxFieldMapperDescriptorException.
TnxFieldMapperDescriptor | This is class nxsdFieldMapperDescriptor.TnxFieldMapperDescriptor.
Namespace

nxsdFieldMapperDescriptor Namespace

Links
Classes, nxsdFieldMapperDescriptor Namespace, Legend


EnxFieldMapperDescriptorException Class

EnxFieldMapperDescriptorException Class
nxsdFieldMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdFieldMapperDescriptor_EnxFieldMapperDescriptorExceptionnxsdFieldMapperDescriptor_EnxFieldMapperDescriptorExceptionnxsdFieldMapperDescriptor_EnxFieldMapperDescriptorExceptionnxsdFieldMapperDescriptor_EnxFieldMapperDescriptorExceptionnxsdFieldMapperDescriptor_EnxFieldMapperDescriptorException
Syntax
Delphi
EnxFieldMapperDescriptorException = class(EnxBaseRegisterableDescriptorException);
File

nxsdFieldMapperDescriptor

Description

This is class nxsdFieldMapperDescriptor.EnxFieldMapperDescriptorException.

Group

Classes

Links
nxsdFieldMapperDescriptor, Classes


TnxFieldMapperDescriptor Class

TnxFieldMapperDescriptor Class
TnxFieldMapperDescriptor Fields TnxFieldMapperDescriptor Methods TnxFieldMapperDescriptor Properties TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdFieldMapperDescriptor_TnxFieldMapperDescriptornxsdFieldMapperDescriptor_TnxFieldMapperDescriptornxsdFieldMapperDescriptor_TnxFieldMapperDescriptornxsdFieldMapperDescriptor_TnxFieldMapperDescriptornxsdFieldMapperDescriptor_TnxFieldMapperDescriptor
Syntax
Delphi
TnxFieldMapperDescriptor = class(TnxBaseRegisterableDescriptor);
File

nxsdFieldMapperDescriptor

Description

This is class nxsdFieldMapperDescriptor.TnxFieldMapperDescriptor.

Group

Classes

Links
TnxFieldMapperDescriptor Fields, TnxFieldMapperDescriptor Methods, TnxFieldMapperDescriptor Properties, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor, Classes


TnxFieldMapperDescriptor Members

TnxFieldMapperDescriptor Members
TnxFieldMapperDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldMapperDescriptor.

Class

TnxFieldMapperDescriptor Class

Protected Fields
Name | Description
bfcdApplyDefault | This is bfcdApplyDefault, a member of class TnxFieldMapperDescriptor.
bfcdDataLossAction | This is bfcdDataLossAction, a member of class TnxFieldMapperDescriptor.
bfcdSourceName | private
bfcdTargetName | This is bfcdTargetName, a member of class TnxFieldMapperDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxFieldMapperDescriptor
CreateFromReader |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToWriter |
Public Properties
Name | Description
ApplyDefault | This is ApplyDefault, a member of class TnxFieldMapperDescriptor.
DataLossAction | This is DataLossAction, a member of class TnxFieldMapperDescriptor.
SourceName | This is SourceName, a member of class TnxFieldMapperDescriptor.
TargetName | This is TargetName, a member of class TnxFieldMapperDescriptor.
Links
TnxFieldMapperDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFieldMapperDescriptor.Create Constructor

TnxFieldMapperDescriptor.Create Constructor
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(const aSourceName: string; const aTargetName: string; aDataLossAction: TnxDataLossAction = dlaFail); virtual;
Description

TnxFieldMapperDescriptor

Class

TnxFieldMapperDescriptor Class

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Class


TnxFieldMapperDescriptor Fields

TnxFieldMapperDescriptor Fields
TnxFieldMapperDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxFieldMapperDescriptor class are listed here.

Class

TnxFieldMapperDescriptor Class

Protected Fields
Name | Description
bfcdApplyDefault | This is bfcdApplyDefault, a member of class TnxFieldMapperDescriptor.
bfcdDataLossAction | This is bfcdDataLossAction, a member of class TnxFieldMapperDescriptor.
bfcdSourceName | private
bfcdTargetName | This is bfcdTargetName, a member of class TnxFieldMapperDescriptor.
Links
TnxFieldMapperDescriptor Class, Legend, Protected Fields


TnxFieldMapperDescriptor.bfcdApplyDefault Field

TnxFieldMapperDescriptor.bfcdApplyDefault Field
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Fields Send Feedback
Syntax
Delphi
bfcdApplyDefault: Boolean;
Description

This is bfcdApplyDefault, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Fields

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Fields


TnxFieldMapperDescriptor.bfcdDataLossAction Field

TnxFieldMapperDescriptor.bfcdDataLossAction Field
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Fields Send Feedback
Syntax
Delphi
bfcdDataLossAction: TnxDataLossAction;
Description

This is bfcdDataLossAction, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Fields

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Fields


TnxFieldMapperDescriptor.bfcdSourceName Field

TnxFieldMapperDescriptor.bfcdSourceName Field
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Fields Send Feedback
Syntax
Delphi
bfcdSourceName: string;
Description

private

Group

TnxFieldMapperDescriptor Fields

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Fields


TnxFieldMapperDescriptor.bfcdTargetName Field

TnxFieldMapperDescriptor.bfcdTargetName Field
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Fields Send Feedback
Syntax
Delphi
bfcdTargetName: string;
Description

This is bfcdTargetName, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Fields

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Fields


TnxFieldMapperDescriptor Methods

TnxFieldMapperDescriptor Methods
TnxFieldMapperDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldMapperDescriptor class are listed here.

Class

TnxFieldMapperDescriptor Class

Protected Methods
Name | Description
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
Public Methods
Name | Description
CreateFromReader |
WriteToWriter |
Links
TnxFieldMapperDescriptor Class, Legend, Protected Methods, Public Methods


TnxFieldMapperDescriptor.CreateFromReader Method

TnxFieldMapperDescriptor.CreateFromReader Method
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function CreateFromReader(aReader: TnxReader): TnxFieldMapperDescriptor;
Group

TnxFieldMapperDescriptor Methods

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Methods


TnxFieldMapperDescriptor.GetList Method

TnxFieldMapperDescriptor.GetList Method
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldMapperDescriptor Methods

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Methods


TnxFieldMapperDescriptor.InternalLoadFromReader Method

TnxFieldMapperDescriptor.InternalLoadFromReader Method
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalLoadFromReader(aReader: TnxReader); virtual;
Group

TnxFieldMapperDescriptor Methods

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Methods


TnxFieldMapperDescriptor.InternalSaveToWriter Method

TnxFieldMapperDescriptor.InternalSaveToWriter Method
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); virtual;
Group

TnxFieldMapperDescriptor Methods

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Methods


TnxFieldMapperDescriptor.WriteToWriter Method

TnxFieldMapperDescriptor.WriteToWriter Method
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure WriteToWriter(aWriter: TnxWriter; aClientVersion: Integer);
Group

TnxFieldMapperDescriptor Methods

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Methods


TnxFieldMapperDescriptor Properties

TnxFieldMapperDescriptor Properties
TnxFieldMapperDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxFieldMapperDescriptor class are listed here.

Class

TnxFieldMapperDescriptor Class

Public Properties
Name | Description
ApplyDefault | This is ApplyDefault, a member of class TnxFieldMapperDescriptor.
DataLossAction | This is DataLossAction, a member of class TnxFieldMapperDescriptor.
SourceName | This is SourceName, a member of class TnxFieldMapperDescriptor.
TargetName | This is TargetName, a member of class TnxFieldMapperDescriptor.
Links
TnxFieldMapperDescriptor Class, Legend, Public Properties


TnxFieldMapperDescriptor.ApplyDefault Property

TnxFieldMapperDescriptor.ApplyDefault Property
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyDefault: Boolean;
Description

This is ApplyDefault, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Properties

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Properties


TnxFieldMapperDescriptor.DataLossAction Property

TnxFieldMapperDescriptor.DataLossAction Property
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Properties Send Feedback
Syntax
Delphi
property DataLossAction: TnxDataLossAction;
Description

This is DataLossAction, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Properties

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Properties


TnxFieldMapperDescriptor.SourceName Property

TnxFieldMapperDescriptor.SourceName Property
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Properties Send Feedback
Syntax
Delphi
property SourceName: string;
Description

This is SourceName, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Properties

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Properties


TnxFieldMapperDescriptor.TargetName Property

TnxFieldMapperDescriptor.TargetName Property
TnxFieldMapperDescriptor Class TnxFieldMapperDescriptor Members nxsdFieldMapperDescriptor Namespace TnxFieldMapperDescriptor Properties Send Feedback
Syntax
Delphi
property TargetName: string;
Description

This is TargetName, a member of class TnxFieldMapperDescriptor.

Group

TnxFieldMapperDescriptor Properties

Links
TnxFieldMapperDescriptor Class, TnxFieldMapperDescriptor Members, nxsdFieldMapperDescriptor Namespace, TnxFieldMapperDescriptor Properties


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdFieldMapperDescriptor Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxDataLossAction | This is record nxsdFieldMapperDescriptor.TnxDataLossAction.
Namespace

nxsdFieldMapperDescriptor Namespace

Links
Enumerations, nxsdFieldMapperDescriptor Namespace, Legend


nxsdFieldMapperDescriptor.TnxDataLossAction Enumeration

nxsdFieldMapperDescriptor.TnxDataLossAction Enumeration
nxsdFieldMapperDescriptor Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxDataLossAction = ( dlaFail, dlaNull, dlaBestFit );
File

nxsdFieldMapperDescriptor

Description

This is record nxsdFieldMapperDescriptor.TnxDataLossAction.

Group

Structs, Records, Enums

Links
nxsdFieldMapperDescriptor, Structs, Records, Enums


Types

Types
nxsdFieldMapperDescriptor Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFieldMapperDescriptor Namespace

Types
Name | Description
TnxFieldMapperDescriptorClass | This is type nxsdFieldMapperDescriptor.TnxFieldMapperDescriptorClass.
Links
nxsdFieldMapperDescriptor Namespace, Types


nxsdFieldMapperDescriptor.TnxFieldMapperDescriptorClass Type

nxsdFieldMapperDescriptor.TnxFieldMapperDescriptorClass Type
nxsdFieldMapperDescriptor Types Send Feedback
Syntax
Delphi
TnxFieldMapperDescriptorClass = class of TnxFieldMapperDescriptor;
File

nxsdFieldMapperDescriptor

Description

This is type nxsdFieldMapperDescriptor.TnxFieldMapperDescriptorClass.

Group

Types

Links
nxsdFieldMapperDescriptor, Types


Variables

Variables
nxsdFieldMapperDescriptor Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFieldMapperDescriptor Namespace

Variables
Name | Description
_FieldMapperDescriptorList | This is variable nxsdFieldMapperDescriptor._FieldMapperDescriptorList.
Links
nxsdFieldMapperDescriptor Namespace, Variables


nxsdFieldMapperDescriptor._FieldMapperDescriptorList Variable

nxsdFieldMapperDescriptor._FieldMapperDescriptorList Variable
nxsdFieldMapperDescriptor Variables Send Feedback
Syntax
Delphi
_FieldMapperDescriptorList: TStringList;
File

nxsdFieldMapperDescriptor

Description

This is variable nxsdFieldMapperDescriptor._FieldMapperDescriptorList.

Group

Variables

Links
nxsdFieldMapperDescriptor, Variables


nxsdFieldMapperEngineBase Namespace

nxsdFieldMapperEngineBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdFieldMapperEngineBase.

Classes
Name | Description
EnxBaseFieldMapperEngineException | This is class nxsdFieldMapperEngineBase.EnxBaseFieldMapperEngineException.
TnxBaseFieldMapperEngine | This is class nxsdFieldMapperEngineBase.TnxBaseFieldMapperEngine.
Constants
Name | Description
csFieldMapper | This is constant nxsdFieldMapperEngineBase.csFieldMapper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxFieldMapperEngineClass | This is type nxsdFieldMapperEngineBase.TnxFieldMapperEngineClass.
Variables
Name | Description
_FieldMapperEngineList | This is variable nxsdFieldMapperEngineBase._FieldMapperEngineList.
_SpecialFieldMapperEngines | This is variable nxsdFieldMapperEngineBase._SpecialFieldMapperEngines.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdFieldMapperEngineBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseFieldMapperEngineException | This is class nxsdFieldMapperEngineBase.EnxBaseFieldMapperEngineException.
TnxBaseFieldMapperEngine | This is class nxsdFieldMapperEngineBase.TnxBaseFieldMapperEngine.
Namespace

nxsdFieldMapperEngineBase Namespace

Links
Classes, nxsdFieldMapperEngineBase Namespace, Legend


EnxBaseFieldMapperEngineException Class

EnxBaseFieldMapperEngineException Class
nxsdFieldMapperEngineBase Classes Send Feedback
Class Hierarchy
nxsdFieldMapperEngineBase_EnxBaseFieldMapperEngineExceptionnxsdFieldMapperEngineBase_EnxBaseFieldMapperEngineExceptionnxsdFieldMapperEngineBase_EnxBaseFieldMapperEngineExceptionnxsdFieldMapperEngineBase_EnxBaseFieldMapperEngineExceptionnxsdFieldMapperEngineBase_EnxBaseFieldMapperEngineException
Syntax
Delphi
EnxBaseFieldMapperEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdFieldMapperEngineBase

Description

This is class nxsdFieldMapperEngineBase.EnxBaseFieldMapperEngineException.

Group

Classes

Links
nxsdFieldMapperEngineBase, Classes


TnxBaseFieldMapperEngine Class

TnxBaseFieldMapperEngine Class
TnxBaseFieldMapperEngine Methods TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Classes Send Feedback
Class Hierarchy
nxsdFieldMapperEngineBase_TnxBaseFieldMapperEnginenxsdFieldMapperEngineBase_TnxBaseFieldMapperEnginenxsdFieldMapperEngineBase_TnxBaseFieldMapperEnginenxsdFieldMapperEngineBase_TnxBaseFieldMapperEngine
Syntax
Delphi
TnxBaseFieldMapperEngine = class(TnxBaseRegisterableEngine);
File

nxsdFieldMapperEngineBase

Description

This is class nxsdFieldMapperEngineBase.TnxBaseFieldMapperEngine.

Group

Classes

Links
TnxBaseFieldMapperEngine Methods, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase, Classes


TnxBaseFieldMapperEngine Members

TnxBaseFieldMapperEngine Members
TnxBaseFieldMapperEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFieldMapperEngine.

Class

TnxBaseFieldMapperEngine Class

Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxBaseFieldMapperEngine
CreateSpecial |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
RegisterSpecial |
Unregister |
UnregisterSpecial |
Public Methods
Name | Description
BeforeCommit | This is BeforeCommit, a member of class TnxBaseFieldMapperEngine.
BeforeFirstRecord | This is BeforeFirstRecord, a member of class TnxBaseFieldMapperEngine.
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
HasSpecialMapper |
MapField | This is MapField, a member of class TnxBaseFieldMapperEngine.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxBaseFieldMapperEngine Class, Legend, Protected Methods, Public Methods


TnxBaseFieldMapperEngine.Create Constructor

TnxBaseFieldMapperEngine.Create Constructor
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxFieldMapperDescriptor; aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor); virtual;
Description

TnxBaseFieldMapperEngine

Class

TnxBaseFieldMapperEngine Class

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Class


TnxBaseFieldMapperEngine Methods

TnxBaseFieldMapperEngine Methods
TnxBaseFieldMapperEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFieldMapperEngine class are listed here.

Class

TnxBaseFieldMapperEngine Class

Protected Methods
Name | Description
CreateSpecial |
GetList |
RegisterSpecial |
UnregisterSpecial |
Public Methods
Name | Description
BeforeCommit | This is BeforeCommit, a member of class TnxBaseFieldMapperEngine.
BeforeFirstRecord | This is BeforeFirstRecord, a member of class TnxBaseFieldMapperEngine.
CreateFor |
HasSpecialMapper |
MapField | This is MapField, a member of class TnxBaseFieldMapperEngine.
Links
TnxBaseFieldMapperEngine Class, Legend, Protected Methods, Public Methods


TnxBaseFieldMapperEngine.BeforeCommit Method

TnxBaseFieldMapperEngine.BeforeCommit Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
procedure BeforeCommit; virtual; abstract;
Description

This is BeforeCommit, a member of class TnxBaseFieldMapperEngine.

Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.BeforeFirstRecord Method

TnxBaseFieldMapperEngine.BeforeFirstRecord Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
procedure BeforeFirstRecord; virtual; abstract;
Description

This is BeforeFirstRecord, a member of class TnxBaseFieldMapperEngine.

Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.CreateFor Method

TnxBaseFieldMapperEngine.CreateFor Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aDescriptor: TnxFieldMapperDescriptor; aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor): TnxBaseFieldMapperEngine;
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.CreateSpecial Method

TnxBaseFieldMapperEngine.CreateSpecial Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class function CreateSpecial(aFieldType: TnxFieldType; aDescriptor: TnxFieldMapperDescriptor; aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor): TnxBaseFieldMapperEngine;
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.GetList Method

TnxBaseFieldMapperEngine.GetList Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.HasSpecialMapper Method

TnxBaseFieldMapperEngine.HasSpecialMapper Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class function HasSpecialMapper(aFieldType: TnxFieldType): Boolean;
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.MapField Method

TnxBaseFieldMapperEngine.MapField Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
function MapField(const aSource; var aTarget): TnxResult; virtual; abstract;
Description

This is MapField, a member of class TnxBaseFieldMapperEngine.

Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.RegisterSpecial Method

TnxBaseFieldMapperEngine.RegisterSpecial Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class procedure RegisterSpecial(aFieldType: TnxFieldType);
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


TnxBaseFieldMapperEngine.UnregisterSpecial Method

TnxBaseFieldMapperEngine.UnregisterSpecial Method
TnxBaseFieldMapperEngine Class TnxBaseFieldMapperEngine Members nxsdFieldMapperEngineBase Namespace TnxBaseFieldMapperEngine Methods Send Feedback
Syntax
Delphi
class procedure UnregisterSpecial(aFieldType: TnxFieldType);
Group

TnxBaseFieldMapperEngine Methods

Links
TnxBaseFieldMapperEngine Class, TnxBaseFieldMapperEngine Members, nxsdFieldMapperEngineBase Namespace, TnxBaseFieldMapperEngine Methods


Types

Types
nxsdFieldMapperEngineBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFieldMapperEngineBase Namespace

Types
Name | Description
TnxFieldMapperEngineClass | This is type nxsdFieldMapperEngineBase.TnxFieldMapperEngineClass.
Links
nxsdFieldMapperEngineBase Namespace, Types


nxsdFieldMapperEngineBase.TnxFieldMapperEngineClass Type

nxsdFieldMapperEngineBase.TnxFieldMapperEngineClass Type
nxsdFieldMapperEngineBase Types Send Feedback
Syntax
Delphi
TnxFieldMapperEngineClass = class of TnxBaseFieldMapperEngine;
File

nxsdFieldMapperEngineBase

Description

This is type nxsdFieldMapperEngineBase.TnxFieldMapperEngineClass.

Group

Types

Links
nxsdFieldMapperEngineBase, Types


Variables

Variables
nxsdFieldMapperEngineBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFieldMapperEngineBase Namespace

Variables
Name | Description
_FieldMapperEngineList | This is variable nxsdFieldMapperEngineBase._FieldMapperEngineList.
_SpecialFieldMapperEngines | This is variable nxsdFieldMapperEngineBase._SpecialFieldMapperEngines.
Links
nxsdFieldMapperEngineBase Namespace, Variables


nxsdFieldMapperEngineBase._FieldMapperEngineList Variable

nxsdFieldMapperEngineBase._FieldMapperEngineList Variable
nxsdFieldMapperEngineBase Variables Send Feedback
Syntax
Delphi
_FieldMapperEngineList: TStringList;
File

nxsdFieldMapperEngineBase

Description

This is variable nxsdFieldMapperEngineBase._FieldMapperEngineList.

Group

Variables

Links
nxsdFieldMapperEngineBase, Variables


nxsdFieldMapperEngineBase._SpecialFieldMapperEngines Variable

nxsdFieldMapperEngineBase._SpecialFieldMapperEngines Variable
nxsdFieldMapperEngineBase Variables Send Feedback
Syntax
Delphi
_SpecialFieldMapperEngines: array[TnxFieldType] of TnxFieldMapperEngineClass;
File

nxsdFieldMapperEngineBase

Description

This is variable nxsdFieldMapperEngineBase._SpecialFieldMapperEngines.

Group

Variables

Links
nxsdFieldMapperEngineBase, Variables


Constants

Constants
Constants nxsdFieldMapperEngineBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csFieldMapper | This is constant nxsdFieldMapperEngineBase.csFieldMapper.
Namespace

nxsdFieldMapperEngineBase Namespace

Links
Constants, nxsdFieldMapperEngineBase Namespace


nxsdFieldMapperEngineBase.csFieldMapper Constant

nxsdFieldMapperEngineBase.csFieldMapper Constant
nxsdFieldMapperEngineBase Constants Send Feedback
Syntax
Delphi
csFieldMapper = 'FieldMapper';
File

nxsdFieldMapperEngineBase

Description

This is constant nxsdFieldMapperEngineBase.csFieldMapper.

Group

Constants

Links
nxsdFieldMapperEngineBase, Constants


nxsdFilterDescriptorBase Namespace

nxsdFilterDescriptorBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdFilterDescriptorBase.

Classes
Name | Description
EnxBaseFilterDescriptorException | This is class nxsdFilterDescriptorBase.EnxBaseFilterDescriptorException.
TnxBaseFilterDescriptor | This is class nxsdFilterDescriptorBase.TnxBaseFilterDescriptor.
Constants
Name | Description
rsCanNotBeCreateFromStream | This is constant nxsdFilterDescriptorBase.rsCanNotBeCreateFromStream.
rsFilterDescriptorNotSupported | This is constant nxsdFilterDescriptorBase.rsFilterDescriptorNotSupported.
rsWriteToStreamIsNotSupported | This is constant nxsdFilterDescriptorBase.rsWriteToStreamIsNotSupported.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxFilterDescriptorClass | This is type nxsdFilterDescriptorBase.TnxFilterDescriptorClass.
Variables
Name | Description
_FilterList | This is variable nxsdFilterDescriptorBase._FilterList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdFilterDescriptorBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseFilterDescriptorException | This is class nxsdFilterDescriptorBase.EnxBaseFilterDescriptorException.
TnxBaseFilterDescriptor | This is class nxsdFilterDescriptorBase.TnxBaseFilterDescriptor.
Namespace

nxsdFilterDescriptorBase Namespace

Links
Classes, nxsdFilterDescriptorBase Namespace, Legend


EnxBaseFilterDescriptorException Class

EnxBaseFilterDescriptorException Class
nxsdFilterDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdFilterDescriptorBase_EnxBaseFilterDescriptorExceptionnxsdFilterDescriptorBase_EnxBaseFilterDescriptorExceptionnxsdFilterDescriptorBase_EnxBaseFilterDescriptorExceptionnxsdFilterDescriptorBase_EnxBaseFilterDescriptorExceptionnxsdFilterDescriptorBase_EnxBaseFilterDescriptorException
Syntax
Delphi
EnxBaseFilterDescriptorException = class(EnxBaseRegisterableDescriptorException);
File

nxsdFilterDescriptorBase

Description

This is class nxsdFilterDescriptorBase.EnxBaseFilterDescriptorException.

Group

Classes

Links
nxsdFilterDescriptorBase, Classes


TnxBaseFilterDescriptor Class

TnxBaseFilterDescriptor Class
TnxBaseFilterDescriptor Methods TnxBaseFilterDescriptor Members nxsdFilterDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdFilterDescriptorBase_TnxBaseFilterDescriptornxsdFilterDescriptorBase_TnxBaseFilterDescriptornxsdFilterDescriptorBase_TnxBaseFilterDescriptornxsdFilterDescriptorBase_TnxBaseFilterDescriptornxsdFilterDescriptorBase_TnxBaseFilterDescriptor
Syntax
Delphi
TnxBaseFilterDescriptor = class(TnxBaseRegisterableDescriptor);
File

nxsdFilterDescriptorBase

Description

This is class nxsdFilterDescriptorBase.TnxBaseFilterDescriptor.

Group

Classes

Links
TnxBaseFilterDescriptor Methods, TnxBaseFilterDescriptor Members, nxsdFilterDescriptorBase, Classes


TnxBaseFilterDescriptor Members

TnxBaseFilterDescriptor Members
TnxBaseFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFilterDescriptor.

Class

TnxBaseFilterDescriptor Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
InternalCreateFromStream |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Links
TnxBaseFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseFilterDescriptor.InternalCreateFromStream Constructor

TnxBaseFilterDescriptor.InternalCreateFromStream Constructor
TnxBaseFilterDescriptor Class TnxBaseFilterDescriptor Members nxsdFilterDescriptorBase Namespace TnxBaseFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromStream(aStream: TStream); virtual;
Class

TnxBaseFilterDescriptor Class

Links
TnxBaseFilterDescriptor Class, TnxBaseFilterDescriptor Members, nxsdFilterDescriptorBase Namespace, TnxBaseFilterDescriptor Class


TnxBaseFilterDescriptor Methods

TnxBaseFilterDescriptor Methods
TnxBaseFilterDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFilterDescriptor class are listed here.

Class

TnxBaseFilterDescriptor Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
CreateFromStream | TnxBaseFilterDescriptor
WriteToStream |
Links
TnxBaseFilterDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseFilterDescriptor.CreateFromStream Method

TnxBaseFilterDescriptor.CreateFromStream Method
TnxBaseFilterDescriptor Class TnxBaseFilterDescriptor Members nxsdFilterDescriptorBase Namespace TnxBaseFilterDescriptor Methods Send Feedback
Syntax
Delphi
class function CreateFromStream(aStream: TStream; out aFilter: TnxBaseFilterDescriptor): TnxResult;
Description

TnxBaseFilterDescriptor

Group

TnxBaseFilterDescriptor Methods

Links
TnxBaseFilterDescriptor Class, TnxBaseFilterDescriptor Members, nxsdFilterDescriptorBase Namespace, TnxBaseFilterDescriptor Methods


TnxBaseFilterDescriptor.GetList Method

TnxBaseFilterDescriptor.GetList Method
TnxBaseFilterDescriptor Class TnxBaseFilterDescriptor Members nxsdFilterDescriptorBase Namespace TnxBaseFilterDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseFilterDescriptor Methods

Links
TnxBaseFilterDescriptor Class, TnxBaseFilterDescriptor Members, nxsdFilterDescriptorBase Namespace, TnxBaseFilterDescriptor Methods


TnxBaseFilterDescriptor.WriteToStream Method

TnxBaseFilterDescriptor.WriteToStream Method
TnxBaseFilterDescriptor Class TnxBaseFilterDescriptor Members nxsdFilterDescriptorBase Namespace TnxBaseFilterDescriptor Methods Send Feedback
Syntax
Delphi
function WriteToStream(aStream: TStream; aVersion: Integer): TnxResult; virtual;
Group

TnxBaseFilterDescriptor Methods

Links
TnxBaseFilterDescriptor Class, TnxBaseFilterDescriptor Members, nxsdFilterDescriptorBase Namespace, TnxBaseFilterDescriptor Methods


Types

Types
nxsdFilterDescriptorBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterDescriptorBase Namespace

Types
Name | Description
TnxFilterDescriptorClass | This is type nxsdFilterDescriptorBase.TnxFilterDescriptorClass.
Links
nxsdFilterDescriptorBase Namespace, Types


nxsdFilterDescriptorBase.TnxFilterDescriptorClass Type

nxsdFilterDescriptorBase.TnxFilterDescriptorClass Type
nxsdFilterDescriptorBase Types Send Feedback
Syntax
Delphi
TnxFilterDescriptorClass = class of TnxBaseFilterDescriptor;
File

nxsdFilterDescriptorBase

Description

This is type nxsdFilterDescriptorBase.TnxFilterDescriptorClass.

Group

Types

Links
nxsdFilterDescriptorBase, Types


Variables

Variables
nxsdFilterDescriptorBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFilterDescriptorBase Namespace

Variables
Name | Description
_FilterList | This is variable nxsdFilterDescriptorBase._FilterList.
Links
nxsdFilterDescriptorBase Namespace, Variables


nxsdFilterDescriptorBase._FilterList Variable

nxsdFilterDescriptorBase._FilterList Variable
nxsdFilterDescriptorBase Variables Send Feedback
Syntax
Delphi
_FilterList: TStringList;
File

nxsdFilterDescriptorBase

Description

This is variable nxsdFilterDescriptorBase._FilterList.

Group

Variables

Links
nxsdFilterDescriptorBase, Variables


Constants

Constants
Constants nxsdFilterDescriptorBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsCanNotBeCreateFromStream | This is constant nxsdFilterDescriptorBase.rsCanNotBeCreateFromStream.
rsFilterDescriptorNotSupported | This is constant nxsdFilterDescriptorBase.rsFilterDescriptorNotSupported.
rsWriteToStreamIsNotSupported | This is constant nxsdFilterDescriptorBase.rsWriteToStreamIsNotSupported.
Namespace

nxsdFilterDescriptorBase Namespace

Links
Constants, nxsdFilterDescriptorBase Namespace


nxsdFilterDescriptorBase.rsCanNotBeCreateFromStream Constant

nxsdFilterDescriptorBase.rsCanNotBeCreateFromStream Constant
nxsdFilterDescriptorBase Constants Send Feedback
Syntax
Delphi
rsCanNotBeCreateFromStream = '%s can not be created from a stream';
File

nxsdFilterDescriptorBase

Description

This is constant nxsdFilterDescriptorBase.rsCanNotBeCreateFromStream.

Group

Constants

Links
nxsdFilterDescriptorBase, Constants


nxsdFilterDescriptorBase.rsFilterDescriptorNotSupported Constant

nxsdFilterDescriptorBase.rsFilterDescriptorNotSupported Constant
nxsdFilterDescriptorBase Constants Send Feedback
Syntax
Delphi
rsFilterDescriptorNotSupported = 'Filter descriptor not supported: %s';
File

nxsdFilterDescriptorBase

Description

This is constant nxsdFilterDescriptorBase.rsFilterDescriptorNotSupported.

Group

Constants

Links
nxsdFilterDescriptorBase, Constants


nxsdFilterDescriptorBase.rsWriteToStreamIsNotSupported Constant

nxsdFilterDescriptorBase.rsWriteToStreamIsNotSupported Constant
nxsdFilterDescriptorBase Constants Send Feedback
Syntax
Delphi
rsWriteToStreamIsNotSupported = 'WriteToStream is not supported by %s';
File

nxsdFilterDescriptorBase

Description

This is constant nxsdFilterDescriptorBase.rsWriteToStreamIsNotSupported.

Group

Constants

Links
nxsdFilterDescriptorBase, Constants


nxsdFilterEngineBase Namespace

nxsdFilterEngineBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdFilterEngineBase.

Classes
Name | Description
EnxBaseFilterEngineException | This is class nxsdFilterEngineBase.EnxBaseFilterEngineException.
TnxBaseFilterEngine | This is class nxsdFilterEngineBase.TnxBaseFilterEngine.
Constants
Name | Description
csFilter | This is constant nxsdFilterEngineBase.csFilter.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxFilterCheckTimeOut | This is type nxsdFilterEngineBase.TnxFilterCheckTimeOut.
TnxFilterEngineClass | This is type nxsdFilterEngineBase.TnxFilterEngineClass.
Variables
Name | Description
_FilterList | This is variable nxsdFilterEngineBase._FilterList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdFilterEngineBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseFilterEngineException | This is class nxsdFilterEngineBase.EnxBaseFilterEngineException.
TnxBaseFilterEngine | This is class nxsdFilterEngineBase.TnxBaseFilterEngine.
Namespace

nxsdFilterEngineBase Namespace

Links
Classes, nxsdFilterEngineBase Namespace, Legend


EnxBaseFilterEngineException Class

EnxBaseFilterEngineException Class
nxsdFilterEngineBase Classes Send Feedback
Class Hierarchy
nxsdFilterEngineBase_EnxBaseFilterEngineExceptionnxsdFilterEngineBase_EnxBaseFilterEngineExceptionnxsdFilterEngineBase_EnxBaseFilterEngineExceptionnxsdFilterEngineBase_EnxBaseFilterEngineExceptionnxsdFilterEngineBase_EnxBaseFilterEngineException
Syntax
Delphi
EnxBaseFilterEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdFilterEngineBase

Description

This is class nxsdFilterEngineBase.EnxBaseFilterEngineException.

Group

Classes

Links
nxsdFilterEngineBase, Classes


TnxBaseFilterEngine Class

TnxBaseFilterEngine Class
TnxBaseFilterEngine Fields TnxBaseFilterEngine Methods TnxBaseFilterEngine Properties TnxBaseFilterEngine Members nxsdFilterEngineBase Classes Send Feedback
Class Hierarchy
nxsdFilterEngineBase_TnxBaseFilterEnginenxsdFilterEngineBase_TnxBaseFilterEnginenxsdFilterEngineBase_TnxBaseFilterEnginenxsdFilterEngineBase_TnxBaseFilterEngine
Syntax
Delphi
TnxBaseFilterEngine = class(TnxBaseRegisterableEngine);
File

nxsdFilterEngineBase

Description

This is class nxsdFilterEngineBase.TnxBaseFilterEngine.

Group

Classes

Links
TnxBaseFilterEngine Fields, TnxBaseFilterEngine Methods, TnxBaseFilterEngine Properties, TnxBaseFilterEngine Members, nxsdFilterEngineBase, Classes


TnxBaseFilterEngine Members

TnxBaseFilterEngine Members
TnxBaseFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFilterEngine.

Class

TnxBaseFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
Create |
GetExceptionData | InxExceptionData
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxBaseFilterEngine
CreateDescriptor | This is CreateDescriptor, a member of class TnxBaseFilterEngine.
CreateFor |
DeactivateFilter |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer | This is MatchesBuffer, a member of class TnxBaseFilterEngine.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxBaseFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxBaseFilterEngine.Create Constructor

TnxBaseFilterEngine.Create Constructor
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource); virtual;
Class

TnxBaseFilterEngine Class

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Class


TnxBaseFilterEngine Fields

TnxBaseFilterEngine Fields
TnxBaseFilterEngine Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxBaseFilterEngine class are listed here.

Class

TnxBaseFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Links
TnxBaseFilterEngine Class, Legend, Protected Fields, Public Fields


TnxBaseFilterEngine.bfActive Field

TnxBaseFilterEngine.bfActive Field
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Fields Send Feedback
Syntax
Delphi
bfActive: Boolean;
Description

This is bfActive, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Fields

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Fields


TnxBaseFilterEngine.bfFieldsSource Field

TnxBaseFilterEngine.bfFieldsSource Field
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Fields Send Feedback
Syntax
Delphi
bfFieldsSource: InxFieldsSource;
Description

private

Group

TnxBaseFilterEngine Fields

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Fields


TnxBaseFilterEngine.kfCheckTimeOut Field

TnxBaseFilterEngine.kfCheckTimeOut Field
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Fields Send Feedback
Syntax
Delphi
kfCheckTimeOut: TnxFilterCheckTimeOut;
Description

used inside the server engine if filter is used as key filter:

Group

TnxBaseFilterEngine Fields

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Fields


TnxBaseFilterEngine.kfResult Field

TnxBaseFilterEngine.kfResult Field
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Fields Send Feedback
Syntax
Delphi
kfResult: PnxResult;
Description

This is kfResult, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Fields

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Fields


TnxBaseFilterEngine Methods

TnxBaseFilterEngine Methods
TnxBaseFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFilterEngine class are listed here.

Class

TnxBaseFilterEngine Class

Protected Methods
Name | Description
bfGetActive |
bfSetActive |
GetExceptionData | InxExceptionData
GetList |
Public Methods
Name | Description
ActivateFilter | TnxBaseFilterEngine
CreateDescriptor | This is CreateDescriptor, a member of class TnxBaseFilterEngine.
CreateFor |
DeactivateFilter |
Disconnect |
Duplicate |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer | This is MatchesBuffer, a member of class TnxBaseFilterEngine.
NewInstance |
RemoveFilter |
Links
TnxBaseFilterEngine Class, Legend, Protected Methods, Public Methods


TnxBaseFilterEngine.ActivateFilter Method

TnxBaseFilterEngine.ActivateFilter Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function ActivateFilter(aFilterID: TnxFilterID): TnxResult; virtual;
Description

TnxBaseFilterEngine

Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.bfGetActive Method

TnxBaseFilterEngine.bfGetActive Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function bfGetActive: Boolean; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.bfSetActive Method

TnxBaseFilterEngine.bfSetActive Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
procedure bfSetActive(Value: Boolean); virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.CreateDescriptor Method

TnxBaseFilterEngine.CreateDescriptor Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; virtual; abstract;
Description

This is CreateDescriptor, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.CreateFor Method

TnxBaseFilterEngine.CreateFor Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource): TnxBaseFilterEngine;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.DeactivateFilter Method

TnxBaseFilterEngine.DeactivateFilter Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function DeactivateFilter(aFilterID: TnxFilterID): TnxResult; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.Disconnect Method

TnxBaseFilterEngine.Disconnect Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
procedure Disconnect; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.Duplicate Method

TnxBaseFilterEngine.Duplicate Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function Duplicate(aFieldsSource: InxFieldsSource): TnxBaseFilterEngine; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.GetExceptionData Method

TnxBaseFilterEngine.GetExceptionData Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.GetList Method

TnxBaseFilterEngine.GetList Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.IsEvalLocal Method

TnxBaseFilterEngine.IsEvalLocal Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function IsEvalLocal: Boolean; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.IsEvalRemote Method

TnxBaseFilterEngine.IsEvalRemote Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function IsEvalRemote: Boolean; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.MatchesBuffer Method

TnxBaseFilterEngine.MatchesBuffer Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; virtual; abstract;
Description

This is MatchesBuffer, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.NewInstance Method

TnxBaseFilterEngine.NewInstance Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine.RemoveFilter Method

TnxBaseFilterEngine.RemoveFilter Method
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Methods Send Feedback
Syntax
Delphi
function RemoveFilter(aFilterID: TnxFilterID; var aFilterVar: TnxBaseFilterEngine): TnxResult; virtual;
Group

TnxBaseFilterEngine Methods

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Methods


TnxBaseFilterEngine Properties

TnxBaseFilterEngine Properties
TnxBaseFilterEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseFilterEngine class are listed here.

Class

TnxBaseFilterEngine Class

Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxBaseFilterEngine Class, Legend, Public Properties


TnxBaseFilterEngine.Active Property

TnxBaseFilterEngine.Active Property
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Properties Send Feedback
Syntax
Delphi
property Active: Boolean;
Description

This is Active, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Properties

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Properties


TnxBaseFilterEngine.FieldsSource Property

TnxBaseFilterEngine.FieldsSource Property
TnxBaseFilterEngine Class TnxBaseFilterEngine Members nxsdFilterEngineBase Namespace TnxBaseFilterEngine Properties Send Feedback
Syntax
Delphi
property FieldsSource: InxFieldsSource;
Description

This is FieldsSource, a member of class TnxBaseFilterEngine.

Group

TnxBaseFilterEngine Properties

Links
TnxBaseFilterEngine Class, TnxBaseFilterEngine Members, nxsdFilterEngineBase Namespace, TnxBaseFilterEngine Properties


Types

Types
nxsdFilterEngineBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterEngineBase Namespace

Types
Name | Description
TnxFilterCheckTimeOut | This is type nxsdFilterEngineBase.TnxFilterCheckTimeOut.
TnxFilterEngineClass | This is type nxsdFilterEngineBase.TnxFilterEngineClass.
Links
nxsdFilterEngineBase Namespace, Types


nxsdFilterEngineBase.TnxFilterCheckTimeOut Type

nxsdFilterEngineBase.TnxFilterCheckTimeOut Type
nxsdFilterEngineBase Types Send Feedback
Syntax
Delphi
TnxFilterCheckTimeOut = function (var aResult : TnxResult) : Boolean of object;
File

nxsdFilterEngineBase

Description

This is type nxsdFilterEngineBase.TnxFilterCheckTimeOut.

Group

Types

Links
nxsdFilterEngineBase, Types


nxsdFilterEngineBase.TnxFilterEngineClass Type

nxsdFilterEngineBase.TnxFilterEngineClass Type
nxsdFilterEngineBase Types Send Feedback
Syntax
Delphi
TnxFilterEngineClass = class of TnxBaseFilterEngine;
File

nxsdFilterEngineBase

Description

This is type nxsdFilterEngineBase.TnxFilterEngineClass.

Group

Types

Links
nxsdFilterEngineBase, Types


Variables

Variables
nxsdFilterEngineBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFilterEngineBase Namespace

Variables
Name | Description
_FilterList | This is variable nxsdFilterEngineBase._FilterList.
Links
nxsdFilterEngineBase Namespace, Variables


nxsdFilterEngineBase._FilterList Variable

nxsdFilterEngineBase._FilterList Variable
nxsdFilterEngineBase Variables Send Feedback
Syntax
Delphi
_FilterList: TStringList;
File

nxsdFilterEngineBase

Description

This is variable nxsdFilterEngineBase._FilterList.

Group

Variables

Links
nxsdFilterEngineBase, Variables


Constants

Constants
Constants nxsdFilterEngineBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csFilter | This is constant nxsdFilterEngineBase.csFilter.
Namespace

nxsdFilterEngineBase Namespace

Links
Constants, nxsdFilterEngineBase Namespace


nxsdFilterEngineBase.csFilter Constant

nxsdFilterEngineBase.csFilter Constant
nxsdFilterEngineBase Constants Send Feedback
Syntax
Delphi
csFilter = 'Filter';
File

nxsdFilterEngineBase

Description

This is constant nxsdFilterEngineBase.csFilter.

Group

Constants

Links
nxsdFilterEngineBase, Constants


nxsdFilterEngineCallback Namespace

nxsdFilterEngineCallback Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxsdFilterEngineCallback.

Classes
Name | Description
TnxCallbackFilterDescriptor | This is class nxsdFilterEngineCallback.TnxCallbackFilterDescriptor.
TnxCallbackFilterEngine | This is class nxsdFilterEngineCallback.TnxCallbackFilterEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxCallbackFilterDescriptorClass | This is type nxsdFilterEngineCallback.TnxCallbackFilterDescriptorClass.
TnxCallbackFilterEngineClass | This is type nxsdFilterEngineCallback.TnxCallbackFilterEngineClass.
TnxFilterCallback | This is type nxsdFilterEngineCallback.TnxFilterCallback.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxsdFilterEngineCallback Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxCallbackFilterDescriptor | This is class nxsdFilterEngineCallback.TnxCallbackFilterDescriptor.
TnxCallbackFilterEngine | This is class nxsdFilterEngineCallback.TnxCallbackFilterEngine.
Namespace

nxsdFilterEngineCallback Namespace

Links
Classes, nxsdFilterEngineCallback Namespace, Legend


TnxCallbackFilterDescriptor Class

TnxCallbackFilterDescriptor Class
TnxCallbackFilterDescriptor Fields TnxCallbackFilterDescriptor Members nxsdFilterEngineCallback Classes Send Feedback
Class Hierarchy
nxsdFilterEngineCallback_TnxCallbackFilterDescriptornxsdFilterEngineCallback_TnxCallbackFilterDescriptornxsdFilterEngineCallback_TnxCallbackFilterDescriptornxsdFilterEngineCallback_TnxCallbackFilterDescriptornxsdFilterEngineCallback_TnxCallbackFilterDescriptornxsdFilterEngineCallback_TnxCallbackFilterDescriptor
Syntax
Delphi
TnxCallbackFilterDescriptor = class(TnxBaseFilterDescriptor);
File

nxsdFilterEngineCallback

Description

This is class nxsdFilterEngineCallback.TnxCallbackFilterDescriptor.

Group

Classes

Links
TnxCallbackFilterDescriptor Fields, TnxCallbackFilterDescriptor Members, nxsdFilterEngineCallback, Classes


TnxCallbackFilterDescriptor Members

TnxCallbackFilterDescriptor Members
TnxCallbackFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxCallbackFilterDescriptor.

Class

TnxCallbackFilterDescriptor Class

Protected Fields
Name | Description
cbfdCallback | private
cbfdCookie | This is cbfdCookie, a member of class TnxCallbackFilterDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalCreateFromStream |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxCallbackFilterDescriptor
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Links
TnxCallbackFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxCallbackFilterDescriptor.Create Constructor

TnxCallbackFilterDescriptor.Create Constructor
TnxCallbackFilterDescriptor Class TnxCallbackFilterDescriptor Members nxsdFilterEngineCallback Namespace TnxCallbackFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aCookie: Pointer; aCallback: TnxFilterCallback);
Description

TnxCallbackFilterDescriptor

Class

TnxCallbackFilterDescriptor Class

Links
TnxCallbackFilterDescriptor Class, TnxCallbackFilterDescriptor Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterDescriptor Class


TnxCallbackFilterDescriptor Fields

TnxCallbackFilterDescriptor Fields
TnxCallbackFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxCallbackFilterDescriptor class are listed here.

Class

TnxCallbackFilterDescriptor Class

Protected Fields
Name | Description
cbfdCallback | private
cbfdCookie | This is cbfdCookie, a member of class TnxCallbackFilterDescriptor.
Links
TnxCallbackFilterDescriptor Class, Legend, Protected Fields


TnxCallbackFilterDescriptor.cbfdCallback Field

TnxCallbackFilterDescriptor.cbfdCallback Field
TnxCallbackFilterDescriptor Class TnxCallbackFilterDescriptor Members nxsdFilterEngineCallback Namespace TnxCallbackFilterDescriptor Fields Send Feedback
Syntax
Delphi
cbfdCallback: TnxFilterCallback;
Description

private

Group

TnxCallbackFilterDescriptor Fields

Links
TnxCallbackFilterDescriptor Class, TnxCallbackFilterDescriptor Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterDescriptor Fields


TnxCallbackFilterDescriptor.cbfdCookie Field

TnxCallbackFilterDescriptor.cbfdCookie Field
TnxCallbackFilterDescriptor Class TnxCallbackFilterDescriptor Members nxsdFilterEngineCallback Namespace TnxCallbackFilterDescriptor Fields Send Feedback
Syntax
Delphi
cbfdCookie: Pointer;
Description

This is cbfdCookie, a member of class TnxCallbackFilterDescriptor.

Group

TnxCallbackFilterDescriptor Fields

Links
TnxCallbackFilterDescriptor Class, TnxCallbackFilterDescriptor Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterDescriptor Fields


TnxCallbackFilterEngine Class

TnxCallbackFilterEngine Class
TnxCallbackFilterEngine Fields TnxCallbackFilterEngine Methods TnxCallbackFilterEngine Members nxsdFilterEngineCallback Classes Send Feedback
Class Hierarchy
nxsdFilterEngineCallback_TnxCallbackFilterEnginenxsdFilterEngineCallback_TnxCallbackFilterEnginenxsdFilterEngineCallback_TnxCallbackFilterEnginenxsdFilterEngineCallback_TnxCallbackFilterEnginenxsdFilterEngineCallback_TnxCallbackFilterEngine
Syntax
Delphi
TnxCallbackFilterEngine = class(TnxBaseFilterEngine);
File

nxsdFilterEngineCallback

Description

This is class nxsdFilterEngineCallback.TnxCallbackFilterEngine.

Group

Classes

Links
TnxCallbackFilterEngine Fields, TnxCallbackFilterEngine Methods, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback, Classes


TnxCallbackFilterEngine Members

TnxCallbackFilterEngine Members
TnxCallbackFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCallbackFilterEngine.

Class

TnxCallbackFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
cbfeCallback | private
cbfeCookie | This is cbfeCookie, a member of class TnxCallbackFilterEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
Create | TnxCallbackFilterEngine
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxBaseFilterEngine
CreateDescriptor |
CreateFor |
DeactivateFilter |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxCallbackFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxCallbackFilterEngine.Create Constructor

TnxCallbackFilterEngine.Create Constructor
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource); override;
Description

TnxCallbackFilterEngine

Class

TnxCallbackFilterEngine Class

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Class


TnxCallbackFilterEngine Fields

TnxCallbackFilterEngine Fields
TnxCallbackFilterEngine Class Legend Protected Fields Send Feedback

The fields of the TnxCallbackFilterEngine class are listed here.

Class

TnxCallbackFilterEngine Class

Protected Fields
Name | Description
cbfeCallback | private
cbfeCookie | This is cbfeCookie, a member of class TnxCallbackFilterEngine.
Links
TnxCallbackFilterEngine Class, Legend, Protected Fields


TnxCallbackFilterEngine.cbfeCallback Field

TnxCallbackFilterEngine.cbfeCallback Field
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Fields Send Feedback
Syntax
Delphi
cbfeCallback: TnxFilterCallback;
Description

private

Group

TnxCallbackFilterEngine Fields

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Fields


TnxCallbackFilterEngine.cbfeCookie Field

TnxCallbackFilterEngine.cbfeCookie Field
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Fields Send Feedback
Syntax
Delphi
cbfeCookie: Pointer;
Description

This is cbfeCookie, a member of class TnxCallbackFilterEngine.

Group

TnxCallbackFilterEngine Fields

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Fields


TnxCallbackFilterEngine Methods

TnxCallbackFilterEngine Methods
TnxCallbackFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCallbackFilterEngine class are listed here.

Class

TnxCallbackFilterEngine Class

Protected Methods
Name | Description
GetExceptionData | InxExceptionData
Public Methods
Name | Description
CreateDescriptor |
MatchesBuffer |
Links
TnxCallbackFilterEngine Class, Legend, Protected Methods, Public Methods


TnxCallbackFilterEngine.CreateDescriptor Method

TnxCallbackFilterEngine.CreateDescriptor Method
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxCallbackFilterEngine Methods

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Methods


TnxCallbackFilterEngine.GetExceptionData Method

TnxCallbackFilterEngine.GetExceptionData Method
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxCallbackFilterEngine Methods

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Methods


TnxCallbackFilterEngine.MatchesBuffer Method

TnxCallbackFilterEngine.MatchesBuffer Method
TnxCallbackFilterEngine Class TnxCallbackFilterEngine Members nxsdFilterEngineCallback Namespace TnxCallbackFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxCallbackFilterEngine Methods

Links
TnxCallbackFilterEngine Class, TnxCallbackFilterEngine Members, nxsdFilterEngineCallback Namespace, TnxCallbackFilterEngine Methods


Types

Types
nxsdFilterEngineCallback Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterEngineCallback Namespace

Types
Name | Description
TnxCallbackFilterDescriptorClass | This is type nxsdFilterEngineCallback.TnxCallbackFilterDescriptorClass.
TnxCallbackFilterEngineClass | This is type nxsdFilterEngineCallback.TnxCallbackFilterEngineClass.
TnxFilterCallback | This is type nxsdFilterEngineCallback.TnxFilterCallback.
Links
nxsdFilterEngineCallback Namespace, Types


nxsdFilterEngineCallback.TnxCallbackFilterDescriptorClass Type

nxsdFilterEngineCallback.TnxCallbackFilterDescriptorClass Type
nxsdFilterEngineCallback Types Send Feedback
Syntax
Delphi
TnxCallbackFilterDescriptorClass = class of TnxCallbackFilterDescriptor;
File

nxsdFilterEngineCallback

Description

This is type nxsdFilterEngineCallback.TnxCallbackFilterDescriptorClass.

Group

Types

Links
nxsdFilterEngineCallback, Types


nxsdFilterEngineCallback.TnxCallbackFilterEngineClass Type

nxsdFilterEngineCallback.TnxCallbackFilterEngineClass Type
nxsdFilterEngineCallback Types Send Feedback
Syntax
Delphi
TnxCallbackFilterEngineClass = class of TnxCallbackFilterEngine;
File

nxsdFilterEngineCallback

Description

This is type nxsdFilterEngineCallback.TnxCallbackFilterEngineClass.

Group

Types

Links
nxsdFilterEngineCallback, Types


nxsdFilterEngineCallback.TnxFilterCallback Type

nxsdFilterEngineCallback.TnxFilterCallback Type
nxsdFilterEngineCallback Types Send Feedback
Syntax
Delphi
TnxFilterCallback = function (aCookie : Pointer; aBuffer : PnxByteArray) : Boolean;
File

nxsdFilterEngineCallback

Description

This is type nxsdFilterEngineCallback.TnxFilterCallback.

Group

Types

Links
nxsdFilterEngineCallback, Types


nxsdFilterEngineHub Namespace

nxsdFilterEngineHub Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxsdFilterEngineHub.

Classes
Name | Description
TnxFilterDescriptorHub | This is class nxsdFilterEngineHub.TnxFilterDescriptorHub.
TnxFilterEngineHub | This is class nxsdFilterEngineHub.TnxFilterEngineHub.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxFilterDescriptorHubClass | This is type nxsdFilterEngineHub.TnxFilterDescriptorHubClass.
TnxFilterEngineHubClass | This is type nxsdFilterEngineHub.TnxFilterEngineHubClass.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxsdFilterEngineHub Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TnxFilterDescriptorHub | This is class nxsdFilterEngineHub.TnxFilterDescriptorHub.
TnxFilterEngineHub | This is class nxsdFilterEngineHub.TnxFilterEngineHub.
Namespace

nxsdFilterEngineHub Namespace

Links
Classes, nxsdFilterEngineHub Namespace, Legend


TnxFilterDescriptorHub Class

TnxFilterDescriptorHub Class
TnxFilterDescriptorHub Fields TnxFilterDescriptorHub Methods TnxFilterDescriptorHub Properties TnxFilterDescriptorHub Members nxsdFilterEngineHub Classes Send Feedback
Class Hierarchy
nxsdFilterEngineHub_TnxFilterDescriptorHubnxsdFilterEngineHub_TnxFilterDescriptorHubnxsdFilterEngineHub_TnxFilterDescriptorHubnxsdFilterEngineHub_TnxFilterDescriptorHubnxsdFilterEngineHub_TnxFilterDescriptorHubnxsdFilterEngineHub_TnxFilterDescriptorHub
Syntax
Delphi
TnxFilterDescriptorHub = class(TnxBaseFilterDescriptor);
File

nxsdFilterEngineHub

Description

This is class nxsdFilterEngineHub.TnxFilterDescriptorHub.

Group

Classes

Links
TnxFilterDescriptorHub Fields, TnxFilterDescriptorHub Methods, TnxFilterDescriptorHub Properties, TnxFilterDescriptorHub Members, nxsdFilterEngineHub, Classes


TnxFilterDescriptorHub Members

TnxFilterDescriptorHub Members
TnxFilterDescriptorHub Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFilterDescriptorHub.

Class

TnxFilterDescriptorHub Class

Protected Fields
Name | Description
fdhList | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
fdhGetFilter |
fdhGetFilterCount |
GetExceptionData | InxExceptionData
GetList |
GetList |
InternalCreateFromStream |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AddFilter | TnxFilterDescriptorHub
BeforeDestruction | TnxLifetimeTrackedPersistent
Create |
CreateFromStream | TnxBaseFilterDescriptor
Destroy |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
RemoveFilter | This is the overview for the RemoveFilter method overload.
WriteToStream |
Public Properties
Name | Description
FilterCount | This is FilterCount, a member of class TnxFilterDescriptorHub.
Filters | This is Filters, a member of class TnxFilterDescriptorHub.
Links
TnxFilterDescriptorHub Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFilterDescriptorHub.Create Constructor

TnxFilterDescriptorHub.Create Constructor
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Class Send Feedback
Syntax
Delphi
constructor Create;
Class

TnxFilterDescriptorHub Class

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Class


TnxFilterDescriptorHub.Destroy Destructor

TnxFilterDescriptorHub.Destroy Destructor
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFilterDescriptorHub Class

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Class


TnxFilterDescriptorHub Fields

TnxFilterDescriptorHub Fields
TnxFilterDescriptorHub Class Legend Protected Fields Send Feedback

The fields of the TnxFilterDescriptorHub class are listed here.

Class

TnxFilterDescriptorHub Class

Protected Fields
Name | Description
fdhList | private
Links
TnxFilterDescriptorHub Class, Legend, Protected Fields


TnxFilterDescriptorHub.fdhList Field

TnxFilterDescriptorHub.fdhList Field
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Fields Send Feedback
Syntax
Delphi
fdhList: TnxList;
Description

private

Group

TnxFilterDescriptorHub Fields

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Fields


TnxFilterDescriptorHub Methods

TnxFilterDescriptorHub Methods
TnxFilterDescriptorHub Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFilterDescriptorHub class are listed here.

Class

TnxFilterDescriptorHub Class

Protected Methods
Name | Description
fdhGetFilter |
fdhGetFilterCount |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AddFilter | TnxFilterDescriptorHub
RemoveFilter | This is the overview for the RemoveFilter method overload.
Links
TnxFilterDescriptorHub Class, Legend, Protected Methods, Public Methods


TnxFilterDescriptorHub.AddFilter Method

TnxFilterDescriptorHub.AddFilter Method
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Methods Send Feedback
Syntax
Delphi
procedure AddFilter(aFilter: TnxBaseFilterDescriptor);
Description

TnxFilterDescriptorHub

Group

TnxFilterDescriptorHub Methods

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Methods


TnxFilterDescriptorHub.fdhGetFilter Method

TnxFilterDescriptorHub.fdhGetFilter Method
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Methods Send Feedback
Syntax
Delphi
function fdhGetFilter(aInx: Integer): TnxBaseFilterDescriptor;
Group

TnxFilterDescriptorHub Methods

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Methods


TnxFilterDescriptorHub.fdhGetFilterCount Method

TnxFilterDescriptorHub.fdhGetFilterCount Method
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Methods Send Feedback
Syntax
Delphi
function fdhGetFilterCount: Integer;
Group

TnxFilterDescriptorHub Methods

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Methods


TnxFilterDescriptorHub.GetExceptionData Method

TnxFilterDescriptorHub.GetExceptionData Method
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxFilterDescriptorHub Methods

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Methods


RemoveFilter Method

RemoveFilter Method
TnxFilterDescriptorHub Methods Send Feedback

This is the overview for the RemoveFilter method overload.

Overload List
Name | Description
TnxFilterDescriptorHub.RemoveFilter (Integer) |
TnxFilterDescriptorHub.RemoveFilter (TnxBaseFilterDescriptor) |
Group

TnxFilterDescriptorHub Methods

Links
TnxFilterDescriptorHub Methods


TnxFilterDescriptorHub.RemoveFilter Method (Integer)

TnxFilterDescriptorHub.RemoveFilter Method (Integer)
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace RemoveFilter Method Send Feedback
Syntax
Delphi
procedure RemoveFilter(aInx: Integer); overload;
Group

RemoveFilter Method

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, RemoveFilter Method


TnxFilterDescriptorHub.RemoveFilter Method (TnxBaseFilterDescriptor)

TnxFilterDescriptorHub.RemoveFilter Method (TnxBaseFilterDescriptor)
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace RemoveFilter Method Send Feedback
Syntax
Delphi
procedure RemoveFilter(aFilter: TnxBaseFilterDescriptor); overload;
Group

RemoveFilter Method

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, RemoveFilter Method


TnxFilterDescriptorHub Properties

TnxFilterDescriptorHub Properties
TnxFilterDescriptorHub Class Legend Public Properties Send Feedback

The properties of the TnxFilterDescriptorHub class are listed here.

Class

TnxFilterDescriptorHub Class

Public Properties
Name | Description
FilterCount | This is FilterCount, a member of class TnxFilterDescriptorHub.
Filters | This is Filters, a member of class TnxFilterDescriptorHub.
Links
TnxFilterDescriptorHub Class, Legend, Public Properties


TnxFilterDescriptorHub.FilterCount Property

TnxFilterDescriptorHub.FilterCount Property
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Properties Send Feedback
Syntax
Delphi
property FilterCount: Integer;
Description

This is FilterCount, a member of class TnxFilterDescriptorHub.

Group

TnxFilterDescriptorHub Properties

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Properties


TnxFilterDescriptorHub.Filters Property

TnxFilterDescriptorHub.Filters Property
TnxFilterDescriptorHub Class TnxFilterDescriptorHub Members nxsdFilterEngineHub Namespace TnxFilterDescriptorHub Properties Send Feedback
Syntax
Delphi
property Filters [aInx: Integer]: TnxBaseFilterDescriptor;
Description

This is Filters, a member of class TnxFilterDescriptorHub.

Group

TnxFilterDescriptorHub Properties

Links
TnxFilterDescriptorHub Class, TnxFilterDescriptorHub Members, nxsdFilterEngineHub Namespace, TnxFilterDescriptorHub Properties


TnxFilterEngineHub Class

TnxFilterEngineHub Class
Create Constructor TnxFilterEngineHub Fields TnxFilterEngineHub Methods TnxFilterEngineHub Properties TnxFilterEngineHub Members nxsdFilterEngineHub Classes Send Feedback
Class Hierarchy
nxsdFilterEngineHub_TnxFilterEngineHubnxsdFilterEngineHub_TnxFilterEngineHubnxsdFilterEngineHub_TnxFilterEngineHubnxsdFilterEngineHub_TnxFilterEngineHubnxsdFilterEngineHub_TnxFilterEngineHub
Syntax
Delphi
TnxFilterEngineHub = class(TnxBaseFilterEngine);
File

nxsdFilterEngineHub

Description

This is class nxsdFilterEngineHub.TnxFilterEngineHub.

Group

Classes

Links
Create Constructor, TnxFilterEngineHub Fields, TnxFilterEngineHub Methods, TnxFilterEngineHub Properties, TnxFilterEngineHub Members, nxsdFilterEngineHub, Classes


TnxFilterEngineHub Members

TnxFilterEngineHub Members
TnxFilterEngineHub Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFilterEngineHub.

Class

TnxFilterEngineHub Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
fehList | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
fehGetFilter |
fehGetFilterCount |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxFilterEngineHub
AddFilter |
Create | This is the overview for the Create constructor overload.
CreateDescriptor |
CreateFor |
DeactivateFilter |
Destroy |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
FilterCount | This is FilterCount, a member of class TnxFilterEngineHub.
Filters | This is Filters, a member of class TnxFilterEngineHub.
Links
TnxFilterEngineHub Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxFilterEngineHub Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxFilterEngineHub.Create (TnxBaseFilterDescriptor, InxFieldsSource) | AV on DCC32.dll - econs4 BCB support - 10-Feb-2005
TnxFilterEngineHub.Create (TnxBaseFilterEngine, TnxBaseFilterEngine) |
Class

TnxFilterEngineHub Class

Links
TnxFilterEngineHub Class


TnxFilterEngineHub.Create Constructor (TnxBaseFilterDescriptor, InxFieldsSource)

TnxFilterEngineHub.Create Constructor (TnxBaseFilterDescriptor, InxFieldsSource)
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource); override; overload;
Description

AV on DCC32.dll - econs4 BCB support - 10-Feb-2005

Group

Create Constructor

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, Create Constructor


TnxFilterEngineHub.Create Constructor (TnxBaseFilterEngine, TnxBaseFilterEngine)

TnxFilterEngineHub.Create Constructor (TnxBaseFilterEngine, TnxBaseFilterEngine)
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aFilter1: TnxBaseFilterEngine; aFilter2: TnxBaseFilterEngine); overload; reintroduce;
Group

Create Constructor

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, Create Constructor


TnxFilterEngineHub.Destroy Destructor

TnxFilterEngineHub.Destroy Destructor
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFilterEngineHub Class

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Class


TnxFilterEngineHub Fields

TnxFilterEngineHub Fields
TnxFilterEngineHub Class Legend Protected Fields Send Feedback

The fields of the TnxFilterEngineHub class are listed here.

Class

TnxFilterEngineHub Class

Protected Fields
Name | Description
fehList | private
Links
TnxFilterEngineHub Class, Legend, Protected Fields


TnxFilterEngineHub.fehList Field

TnxFilterEngineHub.fehList Field
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Fields Send Feedback
Syntax
Delphi
fehList: TnxList;
Description

private

Group

TnxFilterEngineHub Fields

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Fields


TnxFilterEngineHub Methods

TnxFilterEngineHub Methods
TnxFilterEngineHub Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFilterEngineHub class are listed here.

Class

TnxFilterEngineHub Class

Protected Methods
Name | Description
bfGetActive |
fehGetFilter |
fehGetFilterCount |
Public Methods
Name | Description
ActivateFilter | TnxFilterEngineHub
AddFilter |
CreateDescriptor |
DeactivateFilter |
Disconnect |
Duplicate |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
RemoveFilter |
Links
TnxFilterEngineHub Class, Legend, Protected Methods, Public Methods


TnxFilterEngineHub.ActivateFilter Method

TnxFilterEngineHub.ActivateFilter Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function ActivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Description

TnxFilterEngineHub

Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.AddFilter Method

TnxFilterEngineHub.AddFilter Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
procedure AddFilter(aFilter: TnxBaseFilterEngine);
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.bfGetActive Method

TnxFilterEngineHub.bfGetActive Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function bfGetActive: Boolean; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.CreateDescriptor Method

TnxFilterEngineHub.CreateDescriptor Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.DeactivateFilter Method

TnxFilterEngineHub.DeactivateFilter Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function DeactivateFilter(aFilterID: TnxFilterID): TnxResult; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.Disconnect Method

TnxFilterEngineHub.Disconnect Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
procedure Disconnect; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.Duplicate Method

TnxFilterEngineHub.Duplicate Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function Duplicate(aFieldsSource: InxFieldsSource): TnxBaseFilterEngine; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.fehGetFilter Method

TnxFilterEngineHub.fehGetFilter Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function fehGetFilter(aInx: Integer): TnxBaseFilterEngine;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.fehGetFilterCount Method

TnxFilterEngineHub.fehGetFilterCount Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function fehGetFilterCount: Integer;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.IsEvalLocal Method

TnxFilterEngineHub.IsEvalLocal Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function IsEvalLocal: Boolean; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.IsEvalRemote Method

TnxFilterEngineHub.IsEvalRemote Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function IsEvalRemote: Boolean; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.MatchesBuffer Method

TnxFilterEngineHub.MatchesBuffer Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub.RemoveFilter Method

TnxFilterEngineHub.RemoveFilter Method
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Methods Send Feedback
Syntax
Delphi
function RemoveFilter(aFilterID: TnxFilterID; var aFilterVar: TnxBaseFilterEngine): TnxResult; override;
Group

TnxFilterEngineHub Methods

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Methods


TnxFilterEngineHub Properties

TnxFilterEngineHub Properties
TnxFilterEngineHub Class Legend Public Properties Send Feedback

The properties of the TnxFilterEngineHub class are listed here.

Class

TnxFilterEngineHub Class

Public Properties
Name | Description
FilterCount | This is FilterCount, a member of class TnxFilterEngineHub.
Filters | This is Filters, a member of class TnxFilterEngineHub.
Links
TnxFilterEngineHub Class, Legend, Public Properties


TnxFilterEngineHub.FilterCount Property

TnxFilterEngineHub.FilterCount Property
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Properties Send Feedback
Syntax
Delphi
property FilterCount: Integer;
Description

This is FilterCount, a member of class TnxFilterEngineHub.

Group

TnxFilterEngineHub Properties

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Properties


TnxFilterEngineHub.Filters Property

TnxFilterEngineHub.Filters Property
TnxFilterEngineHub Class TnxFilterEngineHub Members nxsdFilterEngineHub Namespace TnxFilterEngineHub Properties Send Feedback
Syntax
Delphi
property Filters [aInx: Integer]: TnxBaseFilterEngine;
Description

This is Filters, a member of class TnxFilterEngineHub.

Group

TnxFilterEngineHub Properties

Links
TnxFilterEngineHub Class, TnxFilterEngineHub Members, nxsdFilterEngineHub Namespace, TnxFilterEngineHub Properties


Types

Types
nxsdFilterEngineHub Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterEngineHub Namespace

Types
Name | Description
TnxFilterDescriptorHubClass | This is type nxsdFilterEngineHub.TnxFilterDescriptorHubClass.
TnxFilterEngineHubClass | This is type nxsdFilterEngineHub.TnxFilterEngineHubClass.
Links
nxsdFilterEngineHub Namespace, Types


nxsdFilterEngineHub.TnxFilterDescriptorHubClass Type

nxsdFilterEngineHub.TnxFilterDescriptorHubClass Type
nxsdFilterEngineHub Types Send Feedback
Syntax
Delphi
TnxFilterDescriptorHubClass = class of TnxFilterDescriptorHub;
File

nxsdFilterEngineHub

Description

This is type nxsdFilterEngineHub.TnxFilterDescriptorHubClass.

Group

Types

Links
nxsdFilterEngineHub, Types


nxsdFilterEngineHub.TnxFilterEngineHubClass Type

nxsdFilterEngineHub.TnxFilterEngineHubClass Type
nxsdFilterEngineHub Types Send Feedback
Syntax
Delphi
TnxFilterEngineHubClass = class of TnxFilterEngineHub;
File

nxsdFilterEngineHub

Description

This is type nxsdFilterEngineHub.TnxFilterEngineHubClass.

Group

Types

Links
nxsdFilterEngineHub, Types


nxsdFilterEngineSimpleExpression Namespace

nxsdFilterEngineSimpleExpression Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxsdFilterEngineSimpleExpression.

Classes
Name | Description
EnxBaseSimpleExpressionFilterDescriptorException | This is class nxsdFilterEngineSimpleExpression.EnxBaseSimpleExpressionFilterDescriptorException.
EnxSimpleExpressionFilterDescriptorException | This is class nxsdFilterEngineSimpleExpression.EnxSimpleExpressionFilterDescriptorException.
TnxBaseSimpleExpressionFilterDescriptor | This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterDescriptor.
TnxBaseSimpleExpressionFilterEngine | This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterEngine.
TnxSimpleExpressionFilterDescriptor | This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptor.
TnxSimpleExpressionFilterEngine | This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngine.
Structs, Records, Enums
Name | Description
TnxFilterNode | This is record nxsdFilterEngineSimpleExpression.TnxFilterNode.
TnxNodeValue | This is record nxsdFilterEngineSimpleExpression.TnxNodeValue.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
PnxFilterNode | This is type nxsdFilterEngineSimpleExpression.PnxFilterNode.
PnxNodeValue | This is type nxsdFilterEngineSimpleExpression.PnxNodeValue.
TnxCANExpr | This is type nxsdFilterEngineSimpleExpression.TnxCANExpr.
TnxSimpleExpressionFilterDescriptorClass | This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptorClass.
TnxSimpleExpressionFilterEngineClass | This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngineClass.
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxsdFilterEngineSimpleExpression Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseSimpleExpressionFilterDescriptorException | This is class nxsdFilterEngineSimpleExpression.EnxBaseSimpleExpressionFilterDescriptorException.
EnxSimpleExpressionFilterDescriptorException | This is class nxsdFilterEngineSimpleExpression.EnxSimpleExpressionFilterDescriptorException.
TnxBaseSimpleExpressionFilterDescriptor | This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterDescriptor.
TnxBaseSimpleExpressionFilterEngine | This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterEngine.
TnxSimpleExpressionFilterDescriptor | This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptor.
TnxSimpleExpressionFilterEngine | This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngine.
Namespace

nxsdFilterEngineSimpleExpression Namespace

Links
Classes, nxsdFilterEngineSimpleExpression Namespace, Legend


EnxBaseSimpleExpressionFilterDescriptorException Class

EnxBaseSimpleExpressionFilterDescriptorException Class
nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxBaseSimpleExpressionFilterDescriptorException
Syntax
Delphi
EnxBaseSimpleExpressionFilterDescriptorException = class(EnxBaseFilterDescriptorException);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.EnxBaseSimpleExpressionFilterDescriptorException.

Group

Classes

Links
nxsdFilterEngineSimpleExpression, Classes


EnxSimpleExpressionFilterDescriptorException Class

EnxSimpleExpressionFilterDescriptorException Class
nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorExceptionnxsdFilterEngineSimpleExpression_EnxSimpleExpressionFilterDescriptorException
Syntax
Delphi
EnxSimpleExpressionFilterDescriptorException = class(EnxBaseSimpleExpressionFilterDescriptorException);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.EnxSimpleExpressionFilterDescriptorException.

Group

Classes

Links
nxsdFilterEngineSimpleExpression, Classes


TnxBaseSimpleExpressionFilterDescriptor Class

TnxBaseSimpleExpressionFilterDescriptor Class
Create Constructor TnxBaseSimpleExpressionFilterDescriptor Fields TnxBaseSimpleExpressionFilterDescriptor Properties TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterDescriptor
Syntax
Delphi
TnxBaseSimpleExpressionFilterDescriptor = class(TnxBaseFilterDescriptor);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterDescriptor.

Group

Classes

Links
Create Constructor, TnxBaseSimpleExpressionFilterDescriptor Fields, TnxBaseSimpleExpressionFilterDescriptor Properties, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression, Classes


TnxBaseSimpleExpressionFilterDescriptor Members

TnxBaseSimpleExpressionFilterDescriptor Members
TnxBaseSimpleExpressionFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSimpleExpressionFilterDescriptor.

Class

TnxBaseSimpleExpressionFilterDescriptor Class

Protected Fields
Name | Description
bsfdCodePage | This is bsfdCodePage, a member of class TnxBaseSimpleExpressionFilterDescriptor.
bsfdExpression | private
bsfdFilterText | This is bsfdFilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalCreateFromStream |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | This is the overview for the Create constructor overload.
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Public Properties
Name | Description
FilterText | This is FilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
Links
TnxBaseSimpleExpressionFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBaseSimpleExpressionFilterDescriptor Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBaseSimpleExpressionFilterDescriptor.Create (pCANExpr, Integer) | TnxBaseSimpleExpressionFilterDescriptor
TnxBaseSimpleExpressionFilterDescriptor.Create (pCANExpr, String, Integer) |
TnxBaseSimpleExpressionFilterDescriptor.Create (TnxCANExpr, Integer) |
TnxBaseSimpleExpressionFilterDescriptor.Create (TnxCANExpr, String, Integer) |
Class

TnxBaseSimpleExpressionFilterDescriptor Class

Links
TnxBaseSimpleExpressionFilterDescriptor Class


TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (TnxCANExpr, Integer)

TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (TnxCANExpr, Integer)
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aExpression: TnxCANExpr; aCodePage: Integer); overload;
Group

Create Constructor

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, Create Constructor


TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (TnxCANExpr, String, Integer)

TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (TnxCANExpr, String, Integer)
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aExpression: TnxCANExpr; aFilterText: String; aCodePage: Integer); overload;
Group

Create Constructor

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, Create Constructor


TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (pCANExpr, Integer)

TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (pCANExpr, Integer)
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aExpression: pCANExpr; aCodePage: Integer); overload;
Description

TnxBaseSimpleExpressionFilterDescriptor

Group

Create Constructor

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, Create Constructor


TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (pCANExpr, String, Integer)

TnxBaseSimpleExpressionFilterDescriptor.Create Constructor (pCANExpr, String, Integer)
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aExpression: pCANExpr; aFilterText: String; aCodePage: Integer); overload;
Group

Create Constructor

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, Create Constructor


TnxBaseSimpleExpressionFilterDescriptor Fields

TnxBaseSimpleExpressionFilterDescriptor Fields
TnxBaseSimpleExpressionFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSimpleExpressionFilterDescriptor class are listed here.

Class

TnxBaseSimpleExpressionFilterDescriptor Class

Protected Fields
Name | Description
bsfdCodePage | This is bsfdCodePage, a member of class TnxBaseSimpleExpressionFilterDescriptor.
bsfdExpression | private
bsfdFilterText | This is bsfdFilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
Links
TnxBaseSimpleExpressionFilterDescriptor Class, Legend, Protected Fields


TnxBaseSimpleExpressionFilterDescriptor.bsfdCodePage Field

TnxBaseSimpleExpressionFilterDescriptor.bsfdCodePage Field
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxBaseSimpleExpressionFilterDescriptor Fields Send Feedback
Syntax
Delphi
bsfdCodePage: Integer;
Description

This is bsfdCodePage, a member of class TnxBaseSimpleExpressionFilterDescriptor.

Group

TnxBaseSimpleExpressionFilterDescriptor Fields

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxBaseSimpleExpressionFilterDescriptor Fields


TnxBaseSimpleExpressionFilterDescriptor.bsfdExpression Field

TnxBaseSimpleExpressionFilterDescriptor.bsfdExpression Field
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxBaseSimpleExpressionFilterDescriptor Fields Send Feedback
Syntax
Delphi
bsfdExpression: TnxCANExpr;
Description

private

Group

TnxBaseSimpleExpressionFilterDescriptor Fields

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxBaseSimpleExpressionFilterDescriptor Fields


TnxBaseSimpleExpressionFilterDescriptor.bsfdFilterText Field

TnxBaseSimpleExpressionFilterDescriptor.bsfdFilterText Field
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxBaseSimpleExpressionFilterDescriptor Fields Send Feedback
Syntax
Delphi
bsfdFilterText: String;
Description

This is bsfdFilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.

Group

TnxBaseSimpleExpressionFilterDescriptor Fields

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxBaseSimpleExpressionFilterDescriptor Fields


TnxBaseSimpleExpressionFilterDescriptor Properties

TnxBaseSimpleExpressionFilterDescriptor Properties
TnxBaseSimpleExpressionFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseSimpleExpressionFilterDescriptor class are listed here.

Class

TnxBaseSimpleExpressionFilterDescriptor Class

Public Properties
Name | Description
FilterText | This is FilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
Links
TnxBaseSimpleExpressionFilterDescriptor Class, Legend, Public Properties


TnxBaseSimpleExpressionFilterDescriptor.FilterText Property

TnxBaseSimpleExpressionFilterDescriptor.FilterText Property
TnxBaseSimpleExpressionFilterDescriptor Class TnxBaseSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxBaseSimpleExpressionFilterDescriptor Properties Send Feedback
Syntax
Delphi
property FilterText: String;
Description

This is FilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.

Group

TnxBaseSimpleExpressionFilterDescriptor Properties

Links
TnxBaseSimpleExpressionFilterDescriptor Class, TnxBaseSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxBaseSimpleExpressionFilterDescriptor Properties


TnxBaseSimpleExpressionFilterEngine Class

TnxBaseSimpleExpressionFilterEngine Class
nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxBaseSimpleExpressionFilterEngine
Syntax
Delphi
TnxBaseSimpleExpressionFilterEngine = class(TnxBaseFilterEngine);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.TnxBaseSimpleExpressionFilterEngine.

Group

Classes

Links
nxsdFilterEngineSimpleExpression, Classes


TnxSimpleExpressionFilterDescriptor Class

TnxSimpleExpressionFilterDescriptor Class
TnxSimpleExpressionFilterDescriptor Methods TnxSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptornxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterDescriptor
Syntax
Delphi
TnxSimpleExpressionFilterDescriptor = class(TnxBaseSimpleExpressionFilterDescriptor);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptor.

Group

Classes

Links
TnxSimpleExpressionFilterDescriptor Methods, TnxSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression, Classes


TnxSimpleExpressionFilterDescriptor Members

TnxSimpleExpressionFilterDescriptor Members
TnxSimpleExpressionFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleExpressionFilterDescriptor.

Class

TnxSimpleExpressionFilterDescriptor Class

Protected Fields
Name | Description
bsfdCodePage | This is bsfdCodePage, a member of class TnxBaseSimpleExpressionFilterDescriptor.
bsfdExpression | private
bsfdFilterText | This is bsfdFilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalCreateFromStream | TnxSimpleExpressionFilterDescriptor
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | This is the overview for the Create constructor overload.
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Public Properties
Name | Description
FilterText | This is FilterText, a member of class TnxBaseSimpleExpressionFilterDescriptor.
Links
TnxSimpleExpressionFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSimpleExpressionFilterDescriptor.InternalCreateFromStream Constructor

TnxSimpleExpressionFilterDescriptor.InternalCreateFromStream Constructor
TnxSimpleExpressionFilterDescriptor Class TnxSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromStream(aStream: TStream); override;
Description

TnxSimpleExpressionFilterDescriptor

Class

TnxSimpleExpressionFilterDescriptor Class

Links
TnxSimpleExpressionFilterDescriptor Class, TnxSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterDescriptor Class


TnxSimpleExpressionFilterDescriptor Methods

TnxSimpleExpressionFilterDescriptor Methods
TnxSimpleExpressionFilterDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxSimpleExpressionFilterDescriptor class are listed here.

Class

TnxSimpleExpressionFilterDescriptor Class

Public Methods
Name | Description
WriteToStream |
Links
TnxSimpleExpressionFilterDescriptor Class, Legend, Public Methods


TnxSimpleExpressionFilterDescriptor.WriteToStream Method

TnxSimpleExpressionFilterDescriptor.WriteToStream Method
TnxSimpleExpressionFilterDescriptor Class TnxSimpleExpressionFilterDescriptor Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterDescriptor Methods Send Feedback
Syntax
Delphi
function WriteToStream(aStream: TStream; aVersion: Integer): TnxResult; override;
Group

TnxSimpleExpressionFilterDescriptor Methods

Links
TnxSimpleExpressionFilterDescriptor Class, TnxSimpleExpressionFilterDescriptor Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterDescriptor Methods


TnxSimpleExpressionFilterEngine Class

TnxSimpleExpressionFilterEngine Class
TnxSimpleExpressionFilterEngine Fields TnxSimpleExpressionFilterEngine Methods TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEnginenxsdFilterEngineSimpleExpression_TnxSimpleExpressionFilterEngine
Syntax
Delphi
TnxSimpleExpressionFilterEngine = class(TnxBaseSimpleExpressionFilterEngine);
File

nxsdFilterEngineSimpleExpression

Description

This is class nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngine.

Group

Classes

Links
TnxSimpleExpressionFilterEngine Fields, TnxSimpleExpressionFilterEngine Methods, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression, Classes


TnxSimpleExpressionFilterEngine Members

TnxSimpleExpressionFilterEngine Members
TnxSimpleExpressionFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleExpressionFilterEngine.

Class

TnxSimpleExpressionFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
sfeCodePage | This is sfeCodePage, a member of class TnxSimpleExpressionFilterEngine.
sfeExpression | private
sfeFilterText | This is sfeFilterText, a member of class TnxSimpleExpressionFilterEngine.
sfeHasCodePage | This is sfeHasCodePage, a member of class TnxSimpleExpressionFilterEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
Create | TnxSimpleExpressionFilterEngine
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
sfCompareValue |
sfCompareValues |
sfEvaluateBinaryNode |
sfEvaluateConstNode |
sfEvaluateFieldNode |
sfEvaluateLogicalNode |
sfEvaluateNode |
sfEvaluateUnaryNode |
sfGetLiteralPtr |
sfGetNodePtr |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxBaseFilterEngine
CreateDescriptor |
CreateFor |
DeactivateFilter |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxSimpleExpressionFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxSimpleExpressionFilterEngine.Create Constructor

TnxSimpleExpressionFilterEngine.Create Constructor
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource); override;
Description

TnxSimpleExpressionFilterEngine

Class

TnxSimpleExpressionFilterEngine Class

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Class


TnxSimpleExpressionFilterEngine Fields

TnxSimpleExpressionFilterEngine Fields
TnxSimpleExpressionFilterEngine Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleExpressionFilterEngine class are listed here.

Class

TnxSimpleExpressionFilterEngine Class

Protected Fields
Name | Description
sfeCodePage | This is sfeCodePage, a member of class TnxSimpleExpressionFilterEngine.
sfeExpression | private
sfeFilterText | This is sfeFilterText, a member of class TnxSimpleExpressionFilterEngine.
sfeHasCodePage | This is sfeHasCodePage, a member of class TnxSimpleExpressionFilterEngine.
Links
TnxSimpleExpressionFilterEngine Class, Legend, Protected Fields


TnxSimpleExpressionFilterEngine.sfeCodePage Field

TnxSimpleExpressionFilterEngine.sfeCodePage Field
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Fields Send Feedback
Syntax
Delphi
sfeCodePage: Word;
Description

This is sfeCodePage, a member of class TnxSimpleExpressionFilterEngine.

Group

TnxSimpleExpressionFilterEngine Fields

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Fields


TnxSimpleExpressionFilterEngine.sfeExpression Field

TnxSimpleExpressionFilterEngine.sfeExpression Field
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Fields Send Feedback
Syntax
Delphi
sfeExpression: TnxCANExpr;
Description

private

Group

TnxSimpleExpressionFilterEngine Fields

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Fields


TnxSimpleExpressionFilterEngine.sfeFilterText Field

TnxSimpleExpressionFilterEngine.sfeFilterText Field
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Fields Send Feedback
Syntax
Delphi
sfeFilterText: string;
Description

This is sfeFilterText, a member of class TnxSimpleExpressionFilterEngine.

Group

TnxSimpleExpressionFilterEngine Fields

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Fields


TnxSimpleExpressionFilterEngine.sfeHasCodePage Field

TnxSimpleExpressionFilterEngine.sfeHasCodePage Field
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Fields Send Feedback
Syntax
Delphi
sfeHasCodePage: Boolean;
Description

This is sfeHasCodePage, a member of class TnxSimpleExpressionFilterEngine.

Group

TnxSimpleExpressionFilterEngine Fields

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Fields


TnxSimpleExpressionFilterEngine Methods

TnxSimpleExpressionFilterEngine Methods
TnxSimpleExpressionFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSimpleExpressionFilterEngine class are listed here.

Class

TnxSimpleExpressionFilterEngine Class

Protected Methods
Name | Description
GetExceptionData | InxExceptionData
sfCompareValue |
sfCompareValues |
sfEvaluateBinaryNode |
sfEvaluateConstNode |
sfEvaluateFieldNode |
sfEvaluateLogicalNode |
sfEvaluateNode |
sfEvaluateUnaryNode |
sfGetLiteralPtr |
sfGetNodePtr |
Public Methods
Name | Description
CreateDescriptor |
MatchesBuffer |
Links
TnxSimpleExpressionFilterEngine Class, Legend, Protected Methods, Public Methods


TnxSimpleExpressionFilterEngine.CreateDescriptor Method

TnxSimpleExpressionFilterEngine.CreateDescriptor Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.GetExceptionData Method

TnxSimpleExpressionFilterEngine.GetExceptionData Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.MatchesBuffer Method

TnxSimpleExpressionFilterEngine.MatchesBuffer Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfCompareValue Method

TnxSimpleExpressionFilterEngine.sfCompareValue Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfCompareValue(const aFirst: TnxNodeValue; const aSecond: TnxNodeValue; aIgnoreCase: Boolean; aPartLen: Integer; aOperator: TnxCANOp; aCanLike: Boolean): TnxValueRelationship;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfCompareValues Method

TnxSimpleExpressionFilterEngine.sfCompareValues Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfCompareValues(out aCompareResult: TnxValueRelationship; const aFirst: TnxNodeValue; const aSecond: TnxNodeValue; aIgnoreCase: Boolean; aPartLen: Integer; aOperator: TnxCANOp; aCanLike: Boolean): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateBinaryNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateBinaryNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateBinaryNode(aNode: PnxFilterNode; aBuffer: Pointer; aNoCase: Boolean; aPartial: TnxWord16): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateConstNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateConstNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateConstNode(aNode: PnxFilterNode; aValue: PnxNodeValue; aBuffer: Pointer): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateFieldNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateFieldNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateFieldNode(aNode: PnxFilterNode; aValue: PnxNodeValue; aBuffer: Pointer): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateLogicalNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateLogicalNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateLogicalNode(aNode: PnxFilterNode; aBuffer: Pointer): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateNode(aNode: PnxFilterNode; aValue: PnxNodeValue; aBuffer: Pointer): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfEvaluateUnaryNode Method

TnxSimpleExpressionFilterEngine.sfEvaluateUnaryNode Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfEvaluateUnaryNode(aNode: PnxFilterNode; aBuffer: Pointer): Boolean;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfGetLiteralPtr Method

TnxSimpleExpressionFilterEngine.sfGetLiteralPtr Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfGetLiteralPtr(aOffset: TnxWord16): Pointer;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


TnxSimpleExpressionFilterEngine.sfGetNodePtr Method

TnxSimpleExpressionFilterEngine.sfGetNodePtr Method
TnxSimpleExpressionFilterEngine Class TnxSimpleExpressionFilterEngine Members nxsdFilterEngineSimpleExpression Namespace TnxSimpleExpressionFilterEngine Methods Send Feedback
Syntax
Delphi
function sfGetNodePtr(aOffset: TnxWord16): PnxFilterNode;
Group

TnxSimpleExpressionFilterEngine Methods

Links
TnxSimpleExpressionFilterEngine Class, TnxSimpleExpressionFilterEngine Members, nxsdFilterEngineSimpleExpression Namespace, TnxSimpleExpressionFilterEngine Methods


Structs, Records, Enums

Structs, Records, Enums
nxsdFilterEngineSimpleExpression Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxsdFilterEngineSimpleExpression Namespace

Records
Name | Description
TnxFilterNode | This is record nxsdFilterEngineSimpleExpression.TnxFilterNode.
TnxNodeValue | This is record nxsdFilterEngineSimpleExpression.TnxNodeValue.
Links
nxsdFilterEngineSimpleExpression Namespace, Legend, Records


nxsdFilterEngineSimpleExpression.TnxFilterNode Record

nxsdFilterEngineSimpleExpression.TnxFilterNode Record
nxsdFilterEngineSimpleExpression Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxFilterNode = packed record
  case Integer of
    1: (fnHdr: CANHdr;);
    2: (fnUnary: CANUnary;);
    3: (fnBinary: CANBinary;);
    4: (fnField: CANField;);
    5: (fnConst: CANConst;);
    7: (fnContinue: CANContinue;);
    8: (fnCompare: CANCompare;);
end;
File

nxsdFilterEngineSimpleExpression

Description

This is record nxsdFilterEngineSimpleExpression.TnxFilterNode.

Group

Structs, Records, Enums

Links
nxsdFilterEngineSimpleExpression, Structs, Records, Enums


nxsdFilterEngineSimpleExpression.TnxNodeValue Record

nxsdFilterEngineSimpleExpression.TnxNodeValue Record
nxsdFilterEngineSimpleExpression Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxNodeValue = record
  nvType: TnxWord16;
  nvSize: TnxWord16;
  nvValue: Pointer;
  nvCodePage: TnxWord16;
  nvIsNull: Boolean;
  nvIsConst: Boolean;
end;
File

nxsdFilterEngineSimpleExpression

Description

This is record nxsdFilterEngineSimpleExpression.TnxNodeValue.

Group

Structs, Records, Enums

Links
nxsdFilterEngineSimpleExpression, Structs, Records, Enums


Types

Types
nxsdFilterEngineSimpleExpression Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterEngineSimpleExpression Namespace

Types
Name | Description
PnxFilterNode | This is type nxsdFilterEngineSimpleExpression.PnxFilterNode.
PnxNodeValue | This is type nxsdFilterEngineSimpleExpression.PnxNodeValue.
TnxCANExpr | This is type nxsdFilterEngineSimpleExpression.TnxCANExpr.
TnxSimpleExpressionFilterDescriptorClass | This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptorClass.
TnxSimpleExpressionFilterEngineClass | This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngineClass.
Links
nxsdFilterEngineSimpleExpression Namespace, Types


nxsdFilterEngineSimpleExpression.PnxFilterNode Type

nxsdFilterEngineSimpleExpression.PnxFilterNode Type
nxsdFilterEngineSimpleExpression Types Send Feedback
Syntax
Delphi
PnxFilterNode = ^TnxFilterNode;
File

nxsdFilterEngineSimpleExpression

Description

This is type nxsdFilterEngineSimpleExpression.PnxFilterNode.

Group

Types

Links
nxsdFilterEngineSimpleExpression, Types


nxsdFilterEngineSimpleExpression.PnxNodeValue Type

nxsdFilterEngineSimpleExpression.PnxNodeValue Type
nxsdFilterEngineSimpleExpression Types Send Feedback
Syntax
Delphi
PnxNodeValue = ^TnxNodeValue;
File

nxsdFilterEngineSimpleExpression

Description

This is type nxsdFilterEngineSimpleExpression.PnxNodeValue.

Group

Types

Links
nxsdFilterEngineSimpleExpression, Types


nxsdFilterEngineSimpleExpression.TnxCANExpr Type

nxsdFilterEngineSimpleExpression.TnxCANExpr Type
nxsdFilterEngineSimpleExpression Types Send Feedback
Syntax
Delphi
TnxCANExpr = array of Byte;
File

nxsdFilterEngineSimpleExpression

Description

This is type nxsdFilterEngineSimpleExpression.TnxCANExpr.

Group

Types

Links
nxsdFilterEngineSimpleExpression, Types


nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptorClass Type

nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptorClass Type
nxsdFilterEngineSimpleExpression Types Send Feedback
Syntax
Delphi
TnxSimpleExpressionFilterDescriptorClass = class of TnxBaseSimpleExpressionFilterDescriptor;
File

nxsdFilterEngineSimpleExpression

Description

This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterDescriptorClass.

Group

Types

Links
nxsdFilterEngineSimpleExpression, Types


nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngineClass Type

nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngineClass Type
nxsdFilterEngineSimpleExpression Types Send Feedback
Syntax
Delphi
TnxSimpleExpressionFilterEngineClass = class of TnxBaseSimpleExpressionFilterEngine;
File

nxsdFilterEngineSimpleExpression

Description

This is type nxsdFilterEngineSimpleExpression.TnxSimpleExpressionFilterEngineClass.

Group

Types

Links
nxsdFilterEngineSimpleExpression, Types


nxsdFilterEngineSQL Namespace

nxsdFilterEngineSQL Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdFilterEngineSQL.

Classes
Name | Description
EnxBaseSqlFilterDescriptorException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterDescriptorException.
EnxBaseSqlFilterEngineException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterEngineException.
EnxBaseSqlFilterStatementException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterStatementException.
EnxSqlFilterDescriptorException | This is class nxsdFilterEngineSQL.EnxSqlFilterDescriptorException.
EnxSqlFilterEngineException | This is class nxsdFilterEngineSQL.EnxSqlFilterEngineException.
TnxBaseSqlFilterDescriptor | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterDescriptor.
TnxBaseSqlFilterEngine | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterEngine.
TnxBaseSqlFilterStatement | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterStatement.
TnxSqlFilterDescriptor | This is class nxsdFilterEngineSQL.TnxSqlFilterDescriptor.
TnxSqlFilterEngine | This is class nxsdFilterEngineSQL.TnxSqlFilterEngine.
Constants
Name | Description
rsMatchesBufferNotSupported | This is constant nxsdFilterEngineSQL.rsMatchesBufferNotSupported.
rsSQLFiltersRequireSqlFilterStatementClass | This is constant nxsdFilterEngineSQL.rsSQLFiltersRequireSqlFilterStatementClass.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxSqlFilterDescriptorClass | This is type nxsdFilterEngineSQL.TnxSqlFilterDescriptorClass.
TnxSqlFilterEngineClass | This is type nxsdFilterEngineSQL.TnxSqlFilterEngineClass.
TnxSqlFilterStatementClass | This is type nxsdFilterEngineSQL.TnxSqlFilterStatementClass.
Variables
Name | Description
SqlFilterStatementClass | This is variable nxsdFilterEngineSQL.SqlFilterStatementClass.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdFilterEngineSQL Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseSqlFilterDescriptorException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterDescriptorException.
EnxBaseSqlFilterEngineException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterEngineException.
EnxBaseSqlFilterStatementException | This is class nxsdFilterEngineSQL.EnxBaseSqlFilterStatementException.
EnxSqlFilterDescriptorException | This is class nxsdFilterEngineSQL.EnxSqlFilterDescriptorException.
EnxSqlFilterEngineException | This is class nxsdFilterEngineSQL.EnxSqlFilterEngineException.
TnxBaseSqlFilterDescriptor | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterDescriptor.
TnxBaseSqlFilterEngine | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterEngine.
TnxBaseSqlFilterStatement | This is class nxsdFilterEngineSQL.TnxBaseSqlFilterStatement.
TnxSqlFilterDescriptor | This is class nxsdFilterEngineSQL.TnxSqlFilterDescriptor.
TnxSqlFilterEngine | This is class nxsdFilterEngineSQL.TnxSqlFilterEngine.
Namespace

nxsdFilterEngineSQL Namespace

Links
Classes, nxsdFilterEngineSQL Namespace, Legend


EnxBaseSqlFilterDescriptorException Class

EnxBaseSqlFilterDescriptorException Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterDescriptorException
Syntax
Delphi
EnxBaseSqlFilterDescriptorException = class(EnxBaseFilterDescriptorException);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.EnxBaseSqlFilterDescriptorException.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


EnxBaseSqlFilterEngineException Class

EnxBaseSqlFilterEngineException Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_EnxBaseSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterEngineException
Syntax
Delphi
EnxBaseSqlFilterEngineException = class(EnxBaseFilterEngineException);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.EnxBaseSqlFilterEngineException.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


EnxBaseSqlFilterStatementException Class

EnxBaseSqlFilterStatementException Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_EnxBaseSqlFilterStatementExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterStatementExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterStatementExceptionnxsdFilterEngineSQL_EnxBaseSqlFilterStatementException
Syntax
Delphi
EnxBaseSqlFilterStatementException = class(EnxBaseException);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.EnxBaseSqlFilterStatementException.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


EnxSqlFilterDescriptorException Class

EnxSqlFilterDescriptorException Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorExceptionnxsdFilterEngineSQL_EnxSqlFilterDescriptorException
Syntax
Delphi
EnxSqlFilterDescriptorException = class(EnxBaseSqlFilterDescriptorException);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.EnxSqlFilterDescriptorException.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


EnxSqlFilterEngineException Class

EnxSqlFilterEngineException Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineExceptionnxsdFilterEngineSQL_EnxSqlFilterEngineException
Syntax
Delphi
EnxSqlFilterEngineException = class(EnxBaseSqlFilterEngineException);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.EnxSqlFilterEngineException.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


TnxBaseSqlFilterDescriptor Class

TnxBaseSqlFilterDescriptor Class
TnxBaseSqlFilterDescriptor Fields TnxBaseSqlFilterDescriptor Properties TnxBaseSqlFilterDescriptor Members nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_TnxBaseSqlFilterDescriptornxsdFilterEngineSQL_TnxBaseSqlFilterDescriptornxsdFilterEngineSQL_TnxBaseSqlFilterDescriptornxsdFilterEngineSQL_TnxBaseSqlFilterDescriptornxsdFilterEngineSQL_TnxBaseSqlFilterDescriptornxsdFilterEngineSQL_TnxBaseSqlFilterDescriptor
Syntax
Delphi
TnxBaseSqlFilterDescriptor = class(TnxBaseFilterDescriptor);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.TnxBaseSqlFilterDescriptor.

Group

Classes

Links
TnxBaseSqlFilterDescriptor Fields, TnxBaseSqlFilterDescriptor Properties, TnxBaseSqlFilterDescriptor Members, nxsdFilterEngineSQL, Classes


TnxBaseSqlFilterDescriptor Members

TnxBaseSqlFilterDescriptor Members
TnxBaseSqlFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSqlFilterDescriptor.

Class

TnxBaseSqlFilterDescriptor Class

Protected Fields
Name | Description
bsfdExpression | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalCreateFromStream |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxSqlFilterDescriptor
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Public Properties
Name | Description
Expression | This is Expression, a member of class TnxBaseSqlFilterDescriptor.
Links
TnxBaseSqlFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseSqlFilterDescriptor.Create Constructor

TnxBaseSqlFilterDescriptor.Create Constructor
TnxBaseSqlFilterDescriptor Class TnxBaseSqlFilterDescriptor Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor Create(aExpression: WideString); virtual;
Description

TnxSqlFilterDescriptor

Class

TnxBaseSqlFilterDescriptor Class

Links
TnxBaseSqlFilterDescriptor Class, TnxBaseSqlFilterDescriptor Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterDescriptor Class


TnxBaseSqlFilterDescriptor Fields

TnxBaseSqlFilterDescriptor Fields
TnxBaseSqlFilterDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSqlFilterDescriptor class are listed here.

Class

TnxBaseSqlFilterDescriptor Class

Protected Fields
Name | Description
bsfdExpression | private
Links
TnxBaseSqlFilterDescriptor Class, Legend, Protected Fields


TnxBaseSqlFilterDescriptor.bsfdExpression Field

TnxBaseSqlFilterDescriptor.bsfdExpression Field
TnxBaseSqlFilterDescriptor Class TnxBaseSqlFilterDescriptor Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterDescriptor Fields Send Feedback
Syntax
Delphi
bsfdExpression: WideString;
Description

private

Group

TnxBaseSqlFilterDescriptor Fields

Links
TnxBaseSqlFilterDescriptor Class, TnxBaseSqlFilterDescriptor Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterDescriptor Fields


TnxBaseSqlFilterDescriptor Properties

TnxBaseSqlFilterDescriptor Properties
TnxBaseSqlFilterDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseSqlFilterDescriptor class are listed here.

Class

TnxBaseSqlFilterDescriptor Class

Public Properties
Name | Description
Expression | This is Expression, a member of class TnxBaseSqlFilterDescriptor.
Links
TnxBaseSqlFilterDescriptor Class, Legend, Public Properties


TnxBaseSqlFilterDescriptor.Expression Property

TnxBaseSqlFilterDescriptor.Expression Property
TnxBaseSqlFilterDescriptor Class TnxBaseSqlFilterDescriptor Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterDescriptor Properties Send Feedback
Syntax
Delphi
property Expression: Widestring;
Description

This is Expression, a member of class TnxBaseSqlFilterDescriptor.

Group

TnxBaseSqlFilterDescriptor Properties

Links
TnxBaseSqlFilterDescriptor Class, TnxBaseSqlFilterDescriptor Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterDescriptor Properties


TnxBaseSqlFilterEngine Class

TnxBaseSqlFilterEngine Class
nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_TnxBaseSqlFilterEnginenxsdFilterEngineSQL_TnxBaseSqlFilterEnginenxsdFilterEngineSQL_TnxBaseSqlFilterEnginenxsdFilterEngineSQL_TnxBaseSqlFilterEnginenxsdFilterEngineSQL_TnxBaseSqlFilterEngine
Syntax
Delphi
TnxBaseSqlFilterEngine = class(TnxBaseFilterEngine);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.TnxBaseSqlFilterEngine.

Group

Classes

Links
nxsdFilterEngineSQL, Classes


TnxBaseSqlFilterStatement Class

TnxBaseSqlFilterStatement Class
TnxBaseSqlFilterStatement Fields TnxBaseSqlFilterStatement Methods TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_TnxBaseSqlFilterStatementnxsdFilterEngineSQL_TnxBaseSqlFilterStatement
Syntax
Delphi
TnxBaseSqlFilterStatement = class(TnxObject);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.TnxBaseSqlFilterStatement.

Group

Classes

Links
TnxBaseSqlFilterStatement Fields, TnxBaseSqlFilterStatement Methods, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL, Classes


TnxBaseSqlFilterStatement Members

TnxBaseSqlFilterStatement Members
TnxBaseSqlFilterStatement Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseSqlFilterStatement.

Class

TnxBaseSqlFilterStatement Class

Protected Fields
Name | Description
bsfsBuffer | This is bsfsBuffer, a member of class TnxBaseSqlFilterStatement.
bsfsFieldsSource | This is bsfsFieldsSource, a member of class TnxBaseSqlFilterStatement.
Protected Methods
Name | Description
Evaluate | This is Evaluate, a member of class TnxBaseSqlFilterStatement.
GetExtColumnDef |
GetExtColumnValue |
Public Methods
Name | Description
Create | TnxBaseSqlFilterStatement
FreeInstance |
MatchesBuffer |
NewInstance | TnxObject
Links
TnxBaseSqlFilterStatement Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseSqlFilterStatement.Create Constructor

TnxBaseSqlFilterStatement.Create Constructor
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsSource: InxFieldsSource; const aSqlText: WideString); virtual;
Description

TnxBaseSqlFilterStatement

Class

TnxBaseSqlFilterStatement Class

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Class


TnxBaseSqlFilterStatement Fields

TnxBaseSqlFilterStatement Fields
TnxBaseSqlFilterStatement Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSqlFilterStatement class are listed here.

Class

TnxBaseSqlFilterStatement Class

Protected Fields
Name | Description
bsfsBuffer | This is bsfsBuffer, a member of class TnxBaseSqlFilterStatement.
bsfsFieldsSource | This is bsfsFieldsSource, a member of class TnxBaseSqlFilterStatement.
Links
TnxBaseSqlFilterStatement Class, Legend, Protected Fields


TnxBaseSqlFilterStatement.bsfsBuffer Field

TnxBaseSqlFilterStatement.bsfsBuffer Field
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Fields Send Feedback
Syntax
Delphi
bsfsBuffer: PnxByteArray;
Description

This is bsfsBuffer, a member of class TnxBaseSqlFilterStatement.

Group

TnxBaseSqlFilterStatement Fields

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Fields


TnxBaseSqlFilterStatement.bsfsFieldsSource Field

TnxBaseSqlFilterStatement.bsfsFieldsSource Field
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Fields Send Feedback
Syntax
Delphi
bsfsFieldsSource: InxFieldsSource;
Description

This is bsfsFieldsSource, a member of class TnxBaseSqlFilterStatement.

Group

TnxBaseSqlFilterStatement Fields

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Fields


TnxBaseSqlFilterStatement Methods

TnxBaseSqlFilterStatement Methods
TnxBaseSqlFilterStatement Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSqlFilterStatement class are listed here.

Class

TnxBaseSqlFilterStatement Class

Protected Methods
Name | Description
Evaluate | This is Evaluate, a member of class TnxBaseSqlFilterStatement.
GetExtColumnDef |
GetExtColumnValue |
Public Methods
Name | Description
MatchesBuffer |
Links
TnxBaseSqlFilterStatement Class, Legend, Protected Methods, Public Methods


TnxBaseSqlFilterStatement.Evaluate Method

TnxBaseSqlFilterStatement.Evaluate Method
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Methods Send Feedback
Syntax
Delphi
function Evaluate: Boolean; virtual; abstract;
Description

This is Evaluate, a member of class TnxBaseSqlFilterStatement.

Group

TnxBaseSqlFilterStatement Methods

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Methods


TnxBaseSqlFilterStatement.GetExtColumnDef Method

TnxBaseSqlFilterStatement.GetExtColumnDef Method
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Methods Send Feedback
Syntax
Delphi
function GetExtColumnDef(const aColumnName: string; var aColType: TnxFieldType; var aColSize: Integer; var aColDec: Integer; var aColLocDesc: TnxLocaleDescriptor): Integer;
Group

TnxBaseSqlFilterStatement Methods

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Methods


TnxBaseSqlFilterStatement.GetExtColumnValue Method

TnxBaseSqlFilterStatement.GetExtColumnValue Method
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Methods Send Feedback
Syntax
Delphi
function GetExtColumnValue(aIndex: Integer): Variant;
Group

TnxBaseSqlFilterStatement Methods

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Methods


TnxBaseSqlFilterStatement.MatchesBuffer Method

TnxBaseSqlFilterStatement.MatchesBuffer Method
TnxBaseSqlFilterStatement Class TnxBaseSqlFilterStatement Members nxsdFilterEngineSQL Namespace TnxBaseSqlFilterStatement Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean;
Group

TnxBaseSqlFilterStatement Methods

Links
TnxBaseSqlFilterStatement Class, TnxBaseSqlFilterStatement Members, nxsdFilterEngineSQL Namespace, TnxBaseSqlFilterStatement Methods


TnxSqlFilterDescriptor Class

TnxSqlFilterDescriptor Class
TnxSqlFilterDescriptor Methods TnxSqlFilterDescriptor Members nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptornxsdFilterEngineSQL_TnxSqlFilterDescriptor
Syntax
Delphi
TnxSqlFilterDescriptor = class(TnxBaseSqlFilterDescriptor);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.TnxSqlFilterDescriptor.

Group

Classes

Links
TnxSqlFilterDescriptor Methods, TnxSqlFilterDescriptor Members, nxsdFilterEngineSQL, Classes


TnxSqlFilterDescriptor Members

TnxSqlFilterDescriptor Members
TnxSqlFilterDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlFilterDescriptor.

Class

TnxSqlFilterDescriptor Class

Protected Fields
Name | Description
bsfdExpression | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalCreateFromStream | TnxSqlFilterDescriptor
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxSqlFilterDescriptor
CreateFromStream | TnxBaseFilterDescriptor
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToStream |
Public Properties
Name | Description
Expression | This is Expression, a member of class TnxBaseSqlFilterDescriptor.
Links
TnxSqlFilterDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSqlFilterDescriptor.InternalCreateFromStream Constructor

TnxSqlFilterDescriptor.InternalCreateFromStream Constructor
TnxSqlFilterDescriptor Class TnxSqlFilterDescriptor Members nxsdFilterEngineSQL Namespace TnxSqlFilterDescriptor Class Send Feedback
Syntax
Delphi
constructor InternalCreateFromStream(aStream: TStream); override;
Description

TnxSqlFilterDescriptor

Class

TnxSqlFilterDescriptor Class

Links
TnxSqlFilterDescriptor Class, TnxSqlFilterDescriptor Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterDescriptor Class


TnxSqlFilterDescriptor Methods

TnxSqlFilterDescriptor Methods
TnxSqlFilterDescriptor Class Legend Public Methods Send Feedback

The methods of the TnxSqlFilterDescriptor class are listed here.

Class

TnxSqlFilterDescriptor Class

Public Methods
Name | Description
WriteToStream |
Links
TnxSqlFilterDescriptor Class, Legend, Public Methods


TnxSqlFilterDescriptor.WriteToStream Method

TnxSqlFilterDescriptor.WriteToStream Method
TnxSqlFilterDescriptor Class TnxSqlFilterDescriptor Members nxsdFilterEngineSQL Namespace TnxSqlFilterDescriptor Methods Send Feedback
Syntax
Delphi
function WriteToStream(aStream: TStream; aVersion: Integer): TnxResult; override;
Group

TnxSqlFilterDescriptor Methods

Links
TnxSqlFilterDescriptor Class, TnxSqlFilterDescriptor Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterDescriptor Methods


TnxSqlFilterEngine Class

TnxSqlFilterEngine Class
TnxSqlFilterEngine Fields TnxSqlFilterEngine Methods TnxSqlFilterEngine Members nxsdFilterEngineSQL Classes Send Feedback
Class Hierarchy
nxsdFilterEngineSQL_TnxSqlFilterEnginenxsdFilterEngineSQL_TnxSqlFilterEnginenxsdFilterEngineSQL_TnxSqlFilterEnginenxsdFilterEngineSQL_TnxSqlFilterEnginenxsdFilterEngineSQL_TnxSqlFilterEnginenxsdFilterEngineSQL_TnxSqlFilterEngine
Syntax
Delphi
TnxSqlFilterEngine = class(TnxBaseSqlFilterEngine);
File

nxsdFilterEngineSQL

Description

This is class nxsdFilterEngineSQL.TnxSqlFilterEngine.

Group

Classes

Links
TnxSqlFilterEngine Fields, TnxSqlFilterEngine Methods, TnxSqlFilterEngine Members, nxsdFilterEngineSQL, Classes


TnxSqlFilterEngine Members

TnxSqlFilterEngine Members
TnxSqlFilterEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlFilterEngine.

Class

TnxSqlFilterEngine Class

Protected Fields
Name | Description
bfActive | This is bfActive, a member of class TnxBaseFilterEngine.
bfFieldsSource | private
sfeExpression | private
sfeStatement | This is sfeStatement, a member of class TnxSqlFilterEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfGetActive |
bfSetActive |
Create | TnxSqlFilterEngine
GetExceptionData | InxExceptionData
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
kfCheckTimeOut | used inside the server engine if filter is used as key filter:
kfResult | This is kfResult, a member of class TnxBaseFilterEngine.
Public Methods
Name | Description
ActivateFilter | TnxBaseFilterEngine
CreateDescriptor |
CreateFor |
DeactivateFilter |
Destroy |
Disconnect |
Duplicate |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetRegisteredEngines |
IsEvalLocal |
IsEvalRemote |
MatchesBuffer |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
RemoveFilter |
Public Properties
Name | Description
Active | This is Active, a member of class TnxBaseFilterEngine.
FieldsSource | This is FieldsSource, a member of class TnxBaseFilterEngine.
Links
TnxSqlFilterEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxSqlFilterEngine.Create Constructor

TnxSqlFilterEngine.Create Constructor
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseFilterDescriptor; aFieldsSource: InxFieldsSource); override;
Description

TnxSqlFilterEngine

Class

TnxSqlFilterEngine Class

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Class


TnxSqlFilterEngine.Destroy Destructor

TnxSqlFilterEngine.Destroy Destructor
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSqlFilterEngine Class

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Class


TnxSqlFilterEngine Fields

TnxSqlFilterEngine Fields
TnxSqlFilterEngine Class Legend Protected Fields Send Feedback

The fields of the TnxSqlFilterEngine class are listed here.

Class

TnxSqlFilterEngine Class

Protected Fields
Name | Description
sfeExpression | private
sfeStatement | This is sfeStatement, a member of class TnxSqlFilterEngine.
Links
TnxSqlFilterEngine Class, Legend, Protected Fields


TnxSqlFilterEngine.sfeExpression Field

TnxSqlFilterEngine.sfeExpression Field
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Fields Send Feedback
Syntax
Delphi
sfeExpression: WideString;
Description

private

Group

TnxSqlFilterEngine Fields

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Fields


TnxSqlFilterEngine.sfeStatement Field

TnxSqlFilterEngine.sfeStatement Field
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Fields Send Feedback
Syntax
Delphi
sfeStatement: TnxBaseSqlFilterStatement;
Description

This is sfeStatement, a member of class TnxSqlFilterEngine.

Group

TnxSqlFilterEngine Fields

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Fields


TnxSqlFilterEngine Methods

TnxSqlFilterEngine Methods
TnxSqlFilterEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSqlFilterEngine class are listed here.

Class

TnxSqlFilterEngine Class

Protected Methods
Name | Description
GetExceptionData | InxExceptionData
Public Methods
Name | Description
CreateDescriptor |
MatchesBuffer |
Links
TnxSqlFilterEngine Class, Legend, Protected Methods, Public Methods


TnxSqlFilterEngine.CreateDescriptor Method

TnxSqlFilterEngine.CreateDescriptor Method
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Methods Send Feedback
Syntax
Delphi
function CreateDescriptor: TnxBaseFilterDescriptor; override;
Group

TnxSqlFilterEngine Methods

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Methods


TnxSqlFilterEngine.GetExceptionData Method

TnxSqlFilterEngine.GetExceptionData Method
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxSqlFilterEngine Methods

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Methods


TnxSqlFilterEngine.MatchesBuffer Method

TnxSqlFilterEngine.MatchesBuffer Method
TnxSqlFilterEngine Class TnxSqlFilterEngine Members nxsdFilterEngineSQL Namespace TnxSqlFilterEngine Methods Send Feedback
Syntax
Delphi
function MatchesBuffer(aBuffer: PnxByteArray): Boolean; override;
Group

TnxSqlFilterEngine Methods

Links
TnxSqlFilterEngine Class, TnxSqlFilterEngine Members, nxsdFilterEngineSQL Namespace, TnxSqlFilterEngine Methods


Types

Types
nxsdFilterEngineSQL Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFilterEngineSQL Namespace

Types
Name | Description
TnxSqlFilterDescriptorClass | This is type nxsdFilterEngineSQL.TnxSqlFilterDescriptorClass.
TnxSqlFilterEngineClass | This is type nxsdFilterEngineSQL.TnxSqlFilterEngineClass.
TnxSqlFilterStatementClass | This is type nxsdFilterEngineSQL.TnxSqlFilterStatementClass.
Links
nxsdFilterEngineSQL Namespace, Types


nxsdFilterEngineSQL.TnxSqlFilterDescriptorClass Type

nxsdFilterEngineSQL.TnxSqlFilterDescriptorClass Type
nxsdFilterEngineSQL Types Send Feedback
Syntax
Delphi
TnxSqlFilterDescriptorClass = class of TnxBaseSqlFilterDescriptor;
File

nxsdFilterEngineSQL

Description

This is type nxsdFilterEngineSQL.TnxSqlFilterDescriptorClass.

Group

Types

Links
nxsdFilterEngineSQL, Types


nxsdFilterEngineSQL.TnxSqlFilterEngineClass Type

nxsdFilterEngineSQL.TnxSqlFilterEngineClass Type
nxsdFilterEngineSQL Types Send Feedback
Syntax
Delphi
TnxSqlFilterEngineClass = class of TnxBaseSqlFilterEngine;
File

nxsdFilterEngineSQL

Description

This is type nxsdFilterEngineSQL.TnxSqlFilterEngineClass.

Group

Types

Links
nxsdFilterEngineSQL, Types


nxsdFilterEngineSQL.TnxSqlFilterStatementClass Type

nxsdFilterEngineSQL.TnxSqlFilterStatementClass Type
nxsdFilterEngineSQL Types Send Feedback
Syntax
Delphi
TnxSqlFilterStatementClass = class of TnxBaseSqlFilterStatement;
File

nxsdFilterEngineSQL

Description

This is type nxsdFilterEngineSQL.TnxSqlFilterStatementClass.

Group

Types

Links
nxsdFilterEngineSQL, Types


Variables

Variables
nxsdFilterEngineSQL Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFilterEngineSQL Namespace

Variables
Name | Description
SqlFilterStatementClass | This is variable nxsdFilterEngineSQL.SqlFilterStatementClass.
Links
nxsdFilterEngineSQL Namespace, Variables


nxsdFilterEngineSQL.SqlFilterStatementClass Variable

nxsdFilterEngineSQL.SqlFilterStatementClass Variable
nxsdFilterEngineSQL Variables Send Feedback
Syntax
Delphi
SqlFilterStatementClass: TnxSqlFilterStatementClass;
File

nxsdFilterEngineSQL

Description

This is variable nxsdFilterEngineSQL.SqlFilterStatementClass.

Group

Variables

Links
nxsdFilterEngineSQL, Variables


Constants

Constants
Constants nxsdFilterEngineSQL Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsMatchesBufferNotSupported | This is constant nxsdFilterEngineSQL.rsMatchesBufferNotSupported.
rsSQLFiltersRequireSqlFilterStatementClass | This is constant nxsdFilterEngineSQL.rsSQLFiltersRequireSqlFilterStatementClass.
Namespace

nxsdFilterEngineSQL Namespace

Links
Constants, nxsdFilterEngineSQL Namespace


nxsdFilterEngineSQL.rsMatchesBufferNotSupported Constant

nxsdFilterEngineSQL.rsMatchesBufferNotSupported Constant
nxsdFilterEngineSQL Constants Send Feedback
Syntax
Delphi
rsMatchesBufferNotSupported = 'TnxSqlFilterEngine.MatchesBuffer requires s' + 'feStatement to be assigned';
File

nxsdFilterEngineSQL

Description

This is constant nxsdFilterEngineSQL.rsMatchesBufferNotSupported.

Group

Constants

Links
nxsdFilterEngineSQL, Constants


nxsdFilterEngineSQL.rsSQLFiltersRequireSqlFilterStatementClass Constant

nxsdFilterEngineSQL.rsSQLFiltersRequireSqlFilterStatementClass Constant
nxsdFilterEngineSQL Constants Send Feedback
Syntax
Delphi
rsSQLFiltersRequireSqlFilterStatementClass = 'SQL Filters require SqlFilte' + 'rStatementClass to be assigned';
File

nxsdFilterEngineSQL

Description

This is constant nxsdFilterEngineSQL.rsSQLFiltersRequireSqlFilterStatementClass.

Group

Constants

Links
nxsdFilterEngineSQL, Constants


nxsdFmtBcd Namespace

nxsdFmtBcd Namespace
Classes Constants Functions Legend Structs, Records, Enums Topics Types Variables Send Feedback

This is namespace nxsdFmtBcd.

Classes
Name | Description
EBcdException | This is class nxsdFmtBcd.EBcdException.
EBcdOverflowException | This is class nxsdFmtBcd.EBcdOverflowException.
EnxBcdException | This is class nxsdFmtBcd.EnxBcdException.
EnxBcdOverflow | This is class nxsdFmtBcd.EnxBcdOverflow.
TFMTBcdVariantTypeFix | This is class nxsdFmtBcd.TFMTBcdVariantTypeFix.
Constants
Name | Description
MaxFMTBcdFractionSize | This is constant nxsdFmtBcd.MaxFMTBcdFractionSize.
nxAllTrunc | This is constant nxsdFmtBcd.nxAllTrunc.
nxNoTrunc | This is constant nxsdFmtBcd.nxNoTrunc.
nxNullBcd | This is constant nxsdFmtBcd.nxNullBcd.
rsBcdOverflow | This is constant nxsdFmtBcd.rsBcdOverflow.
SBcdOverflow | This is constant nxsdFmtBcd.SBcdOverflow.
SInvalidBcdValue | This is constant nxsdFmtBcd.SInvalidBcdValue.
Functions
Name | Description
nxBcdToInt64 | This is function nxsdFmtBcd.nxBcdToInt64.
nxCurrencyToFmtBcd | This is function nxsdFmtBcd.nxCurrencyToFmtBcd.
nxCurrencyToFmtBcd | This is function nxsdFmtBcd.nxCurrencyToFmtBcd.
nxFloatRecToFmtBCD | This is function nxsdFmtBcd.nxFloatRecToFmtBCD.
nxFmtBcdToVariant | This is function nxsdFmtBcd.nxFmtBcdToVariant.
nxNormalizeBcd | This is function nxsdFmtBcd.nxNormalizeBcd.
nxNormalizeBcd | This is function nxsdFmtBcd.nxNormalizeBcd.
nxVariantToBcd | This is function nxsdFmtBcd.nxVariantToBcd.
nxVariantToFmtBcd | This is function nxsdFmtBcd.nxVariantToFmtBcd.
Structs, Records, Enums
Name | Description
TnxBcdTruncInfo | This is record nxsdFmtBcd.TnxBcdTruncInfo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBcdTruncInfos | This is type nxsdFmtBcd.TnxBcdTruncInfos.
Variables
Name | Description
Format | This is variable nxsdFmtBcd.Format.
nxDoubleToFmtBcd | This is variable nxsdFmtBcd.nxDoubleToFmtBcd.
nxFmtBcdCompare | This is variable nxsdFmtBcd.nxFmtBcdCompare.
nxFmtBcdToCurrency | This is variable nxsdFmtBcd.nxFmtBcdToCurrency.
nxFmtBcdToDouble | This is variable nxsdFmtBcd.nxFmtBcdToDouble.
nxStrToFmtBcd | This is variable nxsdFmtBcd.nxStrToFmtBcd.
nxStrToFmtBcdDS | This is variable nxsdFmtBcd.nxStrToFmtBcdDS.
nxTryStrToFmtBcd | This is variable nxsdFmtBcd.nxTryStrToFmtBcd.
nxTryStrToFmtBcdDS | This is variable nxsdFmtBcd.nxTryStrToFmtBcdDS.
Links
Classes, Constants, Functions, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxsdFmtBcd Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EBcdException | This is class nxsdFmtBcd.EBcdException.
EBcdOverflowException | This is class nxsdFmtBcd.EBcdOverflowException.
EnxBcdException | This is class nxsdFmtBcd.EnxBcdException.
EnxBcdOverflow | This is class nxsdFmtBcd.EnxBcdOverflow.
TFMTBcdVariantTypeFix | This is class nxsdFmtBcd.TFMTBcdVariantTypeFix.
Namespace

nxsdFmtBcd Namespace

Links
Classes, nxsdFmtBcd Namespace, Legend


EBcdException Class

EBcdException Class
nxsdFmtBcd Classes Send Feedback
Class Hierarchy
nxsdFmtBcd_EBcdException
Syntax
Delphi
EBcdException = class(Exception);
File

nxsdFmtBcd

Description

This is class nxsdFmtBcd.EBcdException.

Group

Classes

Links
nxsdFmtBcd, Classes


EBcdOverflowException Class

EBcdOverflowException Class
nxsdFmtBcd Classes Send Feedback
Class Hierarchy
nxsdFmtBcd_EBcdOverflowExceptionnxsdFmtBcd_EBcdOverflowException
Syntax
Delphi
EBcdOverflowException = class(EBcdException);
File

nxsdFmtBcd

Description

This is class nxsdFmtBcd.EBcdOverflowException.

Group

Classes

Links
nxsdFmtBcd, Classes


EnxBcdException Class

EnxBcdException Class
nxsdFmtBcd Classes Send Feedback
Class Hierarchy
nxsdFmtBcd_EnxBcdExceptionnxsdFmtBcd_EnxBcdExceptionnxsdFmtBcd_EnxBcdExceptionnxsdFmtBcd_EnxBcdException
Syntax
Delphi
EnxBcdException = class(EnxBaseException);
File

nxsdFmtBcd

Description

This is class nxsdFmtBcd.EnxBcdException.

Group

Classes

Links
nxsdFmtBcd, Classes


EnxBcdOverflow Class

EnxBcdOverflow Class
nxsdFmtBcd Classes Send Feedback
Class Hierarchy
nxsdFmtBcd_EnxBcdOverflownxsdFmtBcd_EnxBcdOverflownxsdFmtBcd_EnxBcdOverflownxsdFmtBcd_EnxBcdOverflownxsdFmtBcd_EnxBcdOverflow
Syntax
Delphi
EnxBcdOverflow = class(EnxBcdException);
File

nxsdFmtBcd

Description

This is class nxsdFmtBcd.EnxBcdOverflow.

Group

Classes

Links
nxsdFmtBcd, Classes


TFMTBcdVariantTypeFix Class

TFMTBcdVariantTypeFix Class
TFMTBcdVariantTypeFix Methods TFMTBcdVariantTypeFix Members nxsdFmtBcd Classes Send Feedback
Class Hierarchy
nxsdFmtBcd_TFMTBcdVariantTypeFix
Syntax
Delphi
TFMTBcdVariantTypeFix = class(TCustomVariantType);
File

nxsdFmtBcd

Description

This is class nxsdFmtBcd.TFMTBcdVariantTypeFix.

Group

Classes

Links
TFMTBcdVariantTypeFix Methods, TFMTBcdVariantTypeFix Members, nxsdFmtBcd, Classes


TFMTBcdVariantTypeFix Members

TFMTBcdVariantTypeFix Members
TFMTBcdVariantTypeFix Class Legend Public Methods Send Feedback

The following tables list the members exposed by TFMTBcdVariantTypeFix.

Class

TFMTBcdVariantTypeFix Class

Public Methods
Name | Description
UnaryOp | TFMTBcdVariantTypeFix
Links
TFMTBcdVariantTypeFix Class, Legend, Public Methods


TFMTBcdVariantTypeFix Methods

TFMTBcdVariantTypeFix Methods
TFMTBcdVariantTypeFix Class Legend Public Methods Send Feedback

The methods of the TFMTBcdVariantTypeFix class are listed here.

Class

TFMTBcdVariantTypeFix Class

Public Methods
Name | Description
UnaryOp | TFMTBcdVariantTypeFix
Links
TFMTBcdVariantTypeFix Class, Legend, Public Methods


TFMTBcdVariantTypeFix.UnaryOp Method

TFMTBcdVariantTypeFix.UnaryOp Method
TFMTBcdVariantTypeFix Class TFMTBcdVariantTypeFix Members nxsdFmtBcd Namespace TFMTBcdVariantTypeFix Methods Send Feedback
Syntax
Delphi
procedure UnaryOp(var Right: TVarData; const TheOperator: TVarOp); override;
Description

TFMTBcdVariantTypeFix

Group

TFMTBcdVariantTypeFix Methods

Links
TFMTBcdVariantTypeFix Class, TFMTBcdVariantTypeFix Members, nxsdFmtBcd Namespace, TFMTBcdVariantTypeFix Methods


Functions

Functions
Functions nxsdFmtBcd Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
nxBcdToInt64 | This is function nxsdFmtBcd.nxBcdToInt64.
nxCurrencyToFmtBcd | This is function nxsdFmtBcd.nxCurrencyToFmtBcd.
nxCurrencyToFmtBcd | This is function nxsdFmtBcd.nxCurrencyToFmtBcd.
nxFloatRecToFmtBCD | This is function nxsdFmtBcd.nxFloatRecToFmtBCD.
nxFmtBcdToVariant | This is function nxsdFmtBcd.nxFmtBcdToVariant.
nxNormalizeBcd | This is function nxsdFmtBcd.nxNormalizeBcd.
nxNormalizeBcd | This is function nxsdFmtBcd.nxNormalizeBcd.
nxVariantToBcd | This is function nxsdFmtBcd.nxVariantToBcd.
nxVariantToFmtBcd | This is function nxsdFmtBcd.nxVariantToFmtBcd.
Namespace

nxsdFmtBcd Namespace

Links
Functions, nxsdFmtBcd Namespace, Legend


nxsdFmtBcd.nxBcdToInt64 Function

nxsdFmtBcd.nxBcdToInt64 Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxBcdToInt64(const aBCD: TnxFmtBCD; Truncate: Boolean = False): Int64;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxBcdToInt64.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxCurrencyToFmtBcd Function

nxsdFmtBcd.nxCurrencyToFmtBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxCurrencyToFmtBcd(const aCurrency: Currency; aPrecision: Integer = 32; aDecimals: Integer = 4; aAllowedTrunc: TnxBcdTruncInfos = nxNoTrunc): TnxFmtBcd; overload;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxCurrencyToFmtBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxCurrencyToFmtBcd Function

nxsdFmtBcd.nxCurrencyToFmtBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxCurrencyToFmtBcd(const aCurrency: Currency; var aFmtBcd: TnxFmtBcd; aPrecision: Integer = 32; aDecimals: Integer = 4): TnxBcdTruncInfos; overload;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxCurrencyToFmtBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxFloatRecToFmtBCD Function

nxsdFmtBcd.nxFloatRecToFmtBCD Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
procedure nxFloatRecToFmtBCD(const aIn: TFloatRec; out aOut: TnxFmtBcd);
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxFloatRecToFmtBCD.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxFmtBcdToVariant Function

nxsdFmtBcd.nxFmtBcdToVariant Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxFmtBcdToVariant(const aFmtBcd: TnxFmtBcd): Variant;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxFmtBcdToVariant.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxNormalizeBcd Function

nxsdFmtBcd.nxNormalizeBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxNormalizeBcd(const InBcd: TnxFmtBcd; var OutBcd: TnxFmtBcd; const Prec: Word; const OutScale: Word): TnxBcdTruncInfos; overload;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxNormalizeBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxNormalizeBcd Function

nxsdFmtBcd.nxNormalizeBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxNormalizeBcd(const InBcd: TnxFmtBcd; const Prec: Word; const Scale: Word; aAllowedTrunc: TnxBcdTruncInfos = nxNoTrunc): TnxFmtBcd; overload;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxNormalizeBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxVariantToBcd Function

nxsdFmtBcd.nxVariantToBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
function nxVariantToBcd(const aVariant: Variant; aPrecision: Integer = 32; aDecimals: Integer = 4): TnxBcd;
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxVariantToBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


nxsdFmtBcd.nxVariantToFmtBcd Function

nxsdFmtBcd.nxVariantToFmtBcd Function
nxsdFmtBcd Functions Send Feedback
Syntax
Delphi
procedure nxVariantToFmtBcd(const aVariant: Variant; aPrecision: Integer; aDecimals: Integer; aLength: Integer; var aFmtBcd: TnxFmtBcd);
File

nxsdFmtBcd

Description

This is function nxsdFmtBcd.nxVariantToFmtBcd.

Group

Functions

Links
nxsdFmtBcd, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdFmtBcd Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBcdTruncInfo | This is record nxsdFmtBcd.TnxBcdTruncInfo.
Namespace

nxsdFmtBcd Namespace

Links
Enumerations, nxsdFmtBcd Namespace, Legend


nxsdFmtBcd.TnxBcdTruncInfo Enumeration

nxsdFmtBcd.TnxBcdTruncInfo Enumeration
nxsdFmtBcd Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBcdTruncInfo = ( tiLeading, tiTrailing );
File

nxsdFmtBcd

Description

This is record nxsdFmtBcd.TnxBcdTruncInfo.

Group

Structs, Records, Enums

Links
nxsdFmtBcd, Structs, Records, Enums


Types

Types
nxsdFmtBcd Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdFmtBcd Namespace

Types
Name | Description
TnxBcdTruncInfos | This is type nxsdFmtBcd.TnxBcdTruncInfos.
Links
nxsdFmtBcd Namespace, Types


nxsdFmtBcd.TnxBcdTruncInfos Type

nxsdFmtBcd.TnxBcdTruncInfos Type
nxsdFmtBcd Types Send Feedback
Syntax
Delphi
TnxBcdTruncInfos = set of TnxBcdTruncInfo;
File

nxsdFmtBcd

Description

This is type nxsdFmtBcd.TnxBcdTruncInfos.

Group

Types

Links
nxsdFmtBcd, Types


Variables

Variables
nxsdFmtBcd Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdFmtBcd Namespace

Variables
Name | Description
Format | This is variable nxsdFmtBcd.Format.
nxDoubleToFmtBcd | This is variable nxsdFmtBcd.nxDoubleToFmtBcd.
nxFmtBcdCompare | This is variable nxsdFmtBcd.nxFmtBcdCompare.
nxFmtBcdToCurrency | This is variable nxsdFmtBcd.nxFmtBcdToCurrency.
nxFmtBcdToDouble | This is variable nxsdFmtBcd.nxFmtBcdToDouble.
nxStrToFmtBcd | This is variable nxsdFmtBcd.nxStrToFmtBcd.
nxStrToFmtBcdDS | This is variable nxsdFmtBcd.nxStrToFmtBcdDS.
nxTryStrToFmtBcd | This is variable nxsdFmtBcd.nxTryStrToFmtBcd.
nxTryStrToFmtBcdDS | This is variable nxsdFmtBcd.nxTryStrToFmtBcdDS.
Links
nxsdFmtBcd Namespace, Variables


nxsdFmtBcd.Format Variable

nxsdFmtBcd.Format Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
Format: TFormatSettings;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.Format.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxDoubleToFmtBcd Variable

nxsdFmtBcd.nxDoubleToFmtBcd Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxDoubleToFmtBcd: function(const aValue: Double): TnxFmtBcd;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxDoubleToFmtBcd.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxFmtBcdCompare Variable

nxsdFmtBcd.nxFmtBcdCompare Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxFmtBcdCompare: function(const Bcd1, Bcd2: TnxFmtBcd): TnxValueRelationship;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxFmtBcdCompare.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxFmtBcdToCurrency Variable

nxsdFmtBcd.nxFmtBcdToCurrency Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxFmtBcdToCurrency: function(const aFmtBcd: TnxFmtBcd; var aCurrency: Currency): Boolean;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxFmtBcdToCurrency.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxFmtBcdToDouble Variable

nxsdFmtBcd.nxFmtBcdToDouble Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxFmtBcdToDouble: function(const aFmtBcd: TnxFmtBcd): Double;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxFmtBcdToDouble.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxStrToFmtBcd Variable

nxsdFmtBcd.nxStrToFmtBcd Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxStrToFmtBcd: function(const aValue: AnsiString): TnxFmtBcd;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxStrToFmtBcd.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxStrToFmtBcdDS Variable

nxsdFmtBcd.nxStrToFmtBcdDS Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxStrToFmtBcdDS: function(const aValue: AnsiString; aDecimalSeparator: AnsiChar): TnxFmtBcd;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxStrToFmtBcdDS.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxTryStrToFmtBcd Variable

nxsdFmtBcd.nxTryStrToFmtBcd Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxTryStrToFmtBcd: function(const aValue: AnsiString; var aFmtBcd: TnxFmtBcd): Boolean;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxTryStrToFmtBcd.

Group

Variables

Links
nxsdFmtBcd, Variables


nxsdFmtBcd.nxTryStrToFmtBcdDS Variable

nxsdFmtBcd.nxTryStrToFmtBcdDS Variable
nxsdFmtBcd Variables Send Feedback
Syntax
Delphi
nxTryStrToFmtBcdDS: function(const aValue: AnsiString; var aFmtBcd: TnxFmtBcd; aDecimalSeparator: AnsiChar): Boolean;
File

nxsdFmtBcd

Description

This is variable nxsdFmtBcd.nxTryStrToFmtBcdDS.

Group

Variables

Links
nxsdFmtBcd, Variables


Constants

Constants
Constants nxsdFmtBcd Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
MaxFMTBcdFractionSize | This is constant nxsdFmtBcd.MaxFMTBcdFractionSize.
nxAllTrunc | This is constant nxsdFmtBcd.nxAllTrunc.
nxNoTrunc | This is constant nxsdFmtBcd.nxNoTrunc.
nxNullBcd | This is constant nxsdFmtBcd.nxNullBcd.
rsBcdOverflow | This is constant nxsdFmtBcd.rsBcdOverflow.
SBcdOverflow | This is constant nxsdFmtBcd.SBcdOverflow.
SInvalidBcdValue | This is constant nxsdFmtBcd.SInvalidBcdValue.
Namespace

nxsdFmtBcd Namespace

Links
Constants, nxsdFmtBcd Namespace


nxsdFmtBcd.MaxFMTBcdFractionSize Constant

nxsdFmtBcd.MaxFMTBcdFractionSize Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
MaxFMTBcdFractionSize = 64;
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.MaxFMTBcdFractionSize.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.nxAllTrunc Constant

nxsdFmtBcd.nxAllTrunc Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
nxAllTrunc = [tiLeading..tiTrailing];
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.nxAllTrunc.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.nxNoTrunc Constant

nxsdFmtBcd.nxNoTrunc Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
nxNoTrunc = nxAllTrunc - nxAllTrunc;
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.nxNoTrunc.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.nxNullBcd Constant

nxsdFmtBcd.nxNullBcd Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
nxNullBcd: TnxFmtBcd = (Precision: 0; SignSpecialPlaces: 0; Fraction: (0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0));
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.nxNullBcd.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.rsBcdOverflow Constant

nxsdFmtBcd.rsBcdOverflow Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
rsBcdOverflow = 'BCD overflow';
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.rsBcdOverflow.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.SBcdOverflow Constant

nxsdFmtBcd.SBcdOverflow Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
SBcdOverflow = 'BCD overflow';
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.SBcdOverflow.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdFmtBcd.SInvalidBcdValue Constant

nxsdFmtBcd.SInvalidBcdValue Constant
nxsdFmtBcd Constants Send Feedback
Syntax
Delphi
SInvalidBcdValue = '%s is not a valid BCD value';
File

nxsdFmtBcd

Description

This is constant nxsdFmtBcd.SInvalidBcdValue.

Group

Constants

Links
nxsdFmtBcd, Constants


nxsdKeyEngineBase Namespace

nxsdKeyEngineBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdKeyEngineBase.

Classes
Name | Description
EnxBaseKeyEngineException | This is class nxsdKeyEngineBase.EnxBaseKeyEngineException.
TnxBaseKeyEngine | This is class nxsdKeyEngineBase.TnxBaseKeyEngine.
Constants
Name | Description
csKey | This is constant nxsdKeyEngineBase.csKey.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxKeyEngineClass | This is type nxsdKeyEngineBase.TnxKeyEngineClass.
Variables
Name | Description
_KeyEngineList | This is variable nxsdKeyEngineBase._KeyEngineList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdKeyEngineBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseKeyEngineException | This is class nxsdKeyEngineBase.EnxBaseKeyEngineException.
TnxBaseKeyEngine | This is class nxsdKeyEngineBase.TnxBaseKeyEngine.
Namespace

nxsdKeyEngineBase Namespace

Links
Classes, nxsdKeyEngineBase Namespace, Legend


EnxBaseKeyEngineException Class

EnxBaseKeyEngineException Class
nxsdKeyEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyEngineBase_EnxBaseKeyEngineExceptionnxsdKeyEngineBase_EnxBaseKeyEngineExceptionnxsdKeyEngineBase_EnxBaseKeyEngineExceptionnxsdKeyEngineBase_EnxBaseKeyEngineExceptionnxsdKeyEngineBase_EnxBaseKeyEngineException
Syntax
Delphi
EnxBaseKeyEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdKeyEngineBase

Description

This is class nxsdKeyEngineBase.EnxBaseKeyEngineException.

Group

Classes

Links
nxsdKeyEngineBase, Classes


TnxBaseKeyEngine Class

TnxBaseKeyEngine Class
TnxBaseKeyEngine Fields TnxBaseKeyEngine Methods TnxBaseKeyEngine Properties TnxBaseKeyEngine Members nxsdKeyEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyEngineBase_TnxBaseKeyEnginenxsdKeyEngineBase_TnxBaseKeyEnginenxsdKeyEngineBase_TnxBaseKeyEnginenxsdKeyEngineBase_TnxBaseKeyEnginenxsdKeyEngineBase_TnxBaseKeyEngine
Syntax
Delphi
TnxBaseKeyEngine = class(TnxBaseRegisterableEngine, InxFieldsSource);
File

nxsdKeyEngineBase

Description

This is class nxsdKeyEngineBase.TnxBaseKeyEngine.

Group

Classes

Links
TnxBaseKeyEngine Fields, TnxBaseKeyEngine Methods, TnxBaseKeyEngine Properties, TnxBaseKeyEngine Members, nxsdKeyEngineBase, Classes


TnxBaseKeyEngine Members

TnxBaseKeyEngine Members
TnxBaseKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseKeyEngine.

Class

TnxBaseKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
Create |
GetCursor |
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount | This is GetFieldCount, a member of class TnxBaseKeyEngine.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class TnxBaseKeyEngine.
GetFieldForFilter | InxFieldsSource
GetFieldFromName | This is GetFieldFromName, a member of class TnxBaseKeyEngine.
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetKeyFieldOffset |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BuildKey | This is BuildKey, a member of class TnxBaseKeyEngine.
CheckValidBaseFromDescriptor |
ClearKey | This is ClearKey, a member of class TnxBaseKeyEngine.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetRegisteredEngines |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant | This is KeyAsVariant, a member of class TnxBaseKeyEngine.
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxBaseKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseKeyEngine.Create Constructor

TnxBaseKeyEngine.Create Constructor
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseKeyDescriptor); virtual;
Class

TnxBaseKeyEngine Class

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Class


TnxBaseKeyEngine.Destroy Destructor

TnxBaseKeyEngine.Destroy Destructor
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseKeyEngine Class

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Class


TnxBaseKeyEngine Fields

TnxBaseKeyEngine Fields
TnxBaseKeyEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseKeyEngine class are listed here.

Class

TnxBaseKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxBaseKeyEngine Class, Legend, Protected Fields


TnxBaseKeyEngine.bkeContainsExtended Field

TnxBaseKeyEngine.bkeContainsExtended Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeContainsExtended: Boolean;
Description

This is bkeContainsExtended, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine.bkeFilter Field

TnxBaseKeyEngine.bkeFilter Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeFilter: TnxBaseFilterEngine;
Description

This is bkeFilter, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine.bkeKeyDescriptor Field

TnxBaseKeyEngine.bkeKeyDescriptor Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeKeyDescriptor: TnxBaseKeyDescriptor;
Description

private

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine.bkeKeyLength Field

TnxBaseKeyEngine.bkeKeyLength Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeKeyLength: TnxWord16;
Description

This is bkeKeyLength, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine.bkeMemoryPool Field

TnxBaseKeyEngine.bkeMemoryPool Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeMemoryPool: TnxMemoryPool;
Description

This is bkeMemoryPool, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine.bkeNLSVersionChanged Field

TnxBaseKeyEngine.bkeNLSVersionChanged Field
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Fields Send Feedback
Syntax
Delphi
bkeNLSVersionChanged: Boolean;
Description

This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Fields

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Fields


TnxBaseKeyEngine Methods

TnxBaseKeyEngine Methods
TnxBaseKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseKeyEngine class are listed here.

Class

TnxBaseKeyEngine Class

Protected Methods
Name | Description
BlobsSupported |
CheckValid |
GetCursor |
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount | This is GetFieldCount, a member of class TnxBaseKeyEngine.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class TnxBaseKeyEngine.
GetFieldForFilter | InxFieldsSource
GetFieldFromName | This is GetFieldFromName, a member of class TnxBaseKeyEngine.
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetKeyFieldOffset |
GetList |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BuildKey | This is BuildKey, a member of class TnxBaseKeyEngine.
CheckValidBaseFromDescriptor |
ClearKey | This is ClearKey, a member of class TnxBaseKeyEngine.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
FreeKey |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant | This is KeyAsVariant, a member of class TnxBaseKeyEngine.
KeyContainsNulls |
SupportsReindex |
TryCreateFor |
Links
TnxBaseKeyEngine Class, Legend, Protected Methods, Public Methods


TnxBaseKeyEngine.AllocKey Method

TnxBaseKeyEngine.AllocKey Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function AllocKey: PnxByteArray; virtual;
Description

TnxBaseKeyEngine

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.BlobsSupported Method

TnxBaseKeyEngine.BlobsSupported Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function BlobsSupported: Boolean; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.BuildKey Method

TnxBaseKeyEngine.BuildKey Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; virtual; abstract;
Description

This is BuildKey, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.CheckValid Method

TnxBaseKeyEngine.CheckValid Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseKeyDescriptor); virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.CheckValidBaseFromDescriptor Method

TnxBaseKeyEngine.CheckValidBaseFromDescriptor Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValidBaseFromDescriptor(aDescriptor: TnxBaseKeyDescriptor); virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.ClearKey Method

TnxBaseKeyEngine.ClearKey Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); virtual; abstract;
Description

This is ClearKey, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


CompareKey Method

CompareKey Method
TnxBaseKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxBaseKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxBaseKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) | This is CompareKey, a member of class TnxBaseKeyEngine.
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Methods


TnxBaseKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxBaseKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; virtual; overload;
Group

CompareKey Method

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, CompareKey Method


TnxBaseKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxBaseKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; virtual; abstract; overload;
Description

This is CompareKey, a member of class TnxBaseKeyEngine.

Group

CompareKey Method

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, CompareKey Method


CompareRecord Method

CompareRecord Method
TnxBaseKeyEngine Methods Send Feedback

This is the overview for the CompareRecord method overload.

Overload List
Name | Description
TnxBaseKeyEngine.CompareRecord (PnxByteArray, PnxByteArray) |
TnxBaseKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64) |
TnxBaseKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer) |
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Methods


TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)

TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRecord2: PnxByteArray): TnxValueRelationship; virtual; overload;
Group

CompareRecord Method

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, CompareRecord Method


TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)

TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64): TnxValueRelationship; virtual; overload;
Group

CompareRecord Method

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, CompareRecord Method


TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)

TnxBaseKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; virtual; overload;
Group

CompareRecord Method

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, CompareRecord Method


TnxBaseKeyEngine.CopyKey Method

TnxBaseKeyEngine.CopyKey Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
procedure CopyKey(aFrom: PnxByteArray; aTo: PnxByteArray); virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.CreateFor Method

TnxBaseKeyEngine.CreateFor Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aDescriptor: TnxBaseKeyDescriptor): TnxBaseKeyEngine;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.FreeKey Method

TnxBaseKeyEngine.FreeKey Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
procedure FreeKey(var aKey: PnxByteArray); virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetCursor Method

TnxBaseKeyEngine.GetCursor Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetCursor: TObject; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetExceptionData Method

TnxBaseKeyEngine.GetExceptionData Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldAsVariant Method

TnxBaseKeyEngine.GetFieldAsVariant Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldAsVariant(aBuffer: PnxByteArray; aField: Integer): OleVariant; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldCount Method

TnxBaseKeyEngine.GetFieldCount Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer; virtual; abstract;
Description

This is GetFieldCount, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldDescriptor Method

TnxBaseKeyEngine.GetFieldDescriptor Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor; virtual; abstract;
Description

This is GetFieldDescriptor, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldForFilter Method

TnxBaseKeyEngine.GetFieldForFilter Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aData: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean; virtual; abstract;
Description

InxFieldsSource

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldFromName Method

TnxBaseKeyEngine.GetFieldFromName Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer; virtual; abstract;
Description

This is GetFieldFromName, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetFieldsOffset Method

TnxBaseKeyEngine.GetFieldsOffset Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldsOffset: integer; virtual; abstract;
Description

This is GetFieldsOffset, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetKeyFieldOffset Method

TnxBaseKeyEngine.GetKeyFieldOffset Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function GetKeyFieldOffset(Index: integer): Integer; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.GetList Method

TnxBaseKeyEngine.GetList Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.KeyAsExceptionData Method

TnxBaseKeyEngine.KeyAsExceptionData Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
procedure KeyAsExceptionData(aKey: PnxByteArray; const aContainer: InxExceptionDataContainer); virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.KeyAsString Method

TnxBaseKeyEngine.KeyAsString Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsString(aKey: PnxByteArray): string; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.KeyAsVariant Method

TnxBaseKeyEngine.KeyAsVariant Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; virtual; abstract;
Description

This is KeyAsVariant, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.KeyContainsNulls Method

TnxBaseKeyEngine.KeyContainsNulls Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.SupportsReindex Method

TnxBaseKeyEngine.SupportsReindex Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class function SupportsReindex: Boolean; virtual;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine.TryCreateFor Method

TnxBaseKeyEngine.TryCreateFor Method
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Methods Send Feedback
Syntax
Delphi
class function TryCreateFor(aDescriptor: TnxBaseKeyDescriptor; out aKeyEngine: TnxBaseKeyEngine): TnxResult;
Group

TnxBaseKeyEngine Methods

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Methods


TnxBaseKeyEngine Properties

TnxBaseKeyEngine Properties
TnxBaseKeyEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseKeyEngine class are listed here.

Class

TnxBaseKeyEngine Class

Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxBaseKeyEngine Class, Legend, Public Properties


TnxBaseKeyEngine.ContainsExtended Property

TnxBaseKeyEngine.ContainsExtended Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property ContainsExtended: Boolean;
Description

This is ContainsExtended, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.FieldsOffset Property

TnxBaseKeyEngine.FieldsOffset Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property FieldsOffset: integer;
Description

This is FieldsOffset, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.Filter Property

TnxBaseKeyEngine.Filter Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property Filter: TnxBaseFilterEngine;
Description

This is Filter, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.KeyDescriptor Property

TnxBaseKeyEngine.KeyDescriptor Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property KeyDescriptor: TnxBaseKeyDescriptor;
Description

This is KeyDescriptor, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.KeyFieldOffset Property

TnxBaseKeyEngine.KeyFieldOffset Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property KeyFieldOffset [Index:integer]: Integer;
Description

This is KeyFieldOffset, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.KeyLength Property

TnxBaseKeyEngine.KeyLength Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property KeyLength: TnxWord16;
Description

This is KeyLength, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.MaxFieldCount Property

TnxBaseKeyEngine.MaxFieldCount Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property MaxFieldCount: Integer;
Description

This is MaxFieldCount, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


TnxBaseKeyEngine.NLSVersionChanged Property

TnxBaseKeyEngine.NLSVersionChanged Property
TnxBaseKeyEngine Class TnxBaseKeyEngine Members nxsdKeyEngineBase Namespace TnxBaseKeyEngine Properties Send Feedback
Syntax
Delphi
property NLSVersionChanged: Boolean;
Description

This is NLSVersionChanged, a member of class TnxBaseKeyEngine.

Group

TnxBaseKeyEngine Properties

Links
TnxBaseKeyEngine Class, TnxBaseKeyEngine Members, nxsdKeyEngineBase Namespace, TnxBaseKeyEngine Properties


Types

Types
nxsdKeyEngineBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdKeyEngineBase Namespace

Types
Name | Description
TnxKeyEngineClass | This is type nxsdKeyEngineBase.TnxKeyEngineClass.
Links
nxsdKeyEngineBase Namespace, Types


nxsdKeyEngineBase.TnxKeyEngineClass Type

nxsdKeyEngineBase.TnxKeyEngineClass Type
nxsdKeyEngineBase Types Send Feedback
Syntax
Delphi
TnxKeyEngineClass = class of TnxBaseKeyEngine;
File

nxsdKeyEngineBase

Description

This is type nxsdKeyEngineBase.TnxKeyEngineClass.

Group

Types

Links
nxsdKeyEngineBase, Types


Variables

Variables
nxsdKeyEngineBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdKeyEngineBase Namespace

Variables
Name | Description
_KeyEngineList | This is variable nxsdKeyEngineBase._KeyEngineList.
Links
nxsdKeyEngineBase Namespace, Variables


nxsdKeyEngineBase._KeyEngineList Variable

nxsdKeyEngineBase._KeyEngineList Variable
nxsdKeyEngineBase Variables Send Feedback
Syntax
Delphi
_KeyEngineList: TStringList;
File

nxsdKeyEngineBase

Description

This is variable nxsdKeyEngineBase._KeyEngineList.

Group

Variables

Links
nxsdKeyEngineBase, Variables


Constants

Constants
Constants nxsdKeyEngineBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csKey | This is constant nxsdKeyEngineBase.csKey.
Namespace

nxsdKeyEngineBase Namespace

Links
Constants, nxsdKeyEngineBase Namespace


nxsdKeyEngineBase.csKey Constant

nxsdKeyEngineBase.csKey Constant
nxsdKeyEngineBase Constants Send Feedback
Syntax
Delphi
csKey = 'Key';
File

nxsdKeyEngineBase

Description

This is constant nxsdKeyEngineBase.csKey.

Group

Constants

Links
nxsdKeyEngineBase, Constants


nxsdKeyEngineComp Namespace

nxsdKeyEngineComp Namespace
Classes Legend Topics Types Send Feedback

This is namespace nxsdKeyEngineComp.

Classes
Name | Description
EnxCompositeKeyEngineException | This is class nxsdKeyEngineComp.EnxCompositeKeyEngineException.
TnxCompKeyEngine | This is class nxsdKeyEngineComp.TnxCompKeyEngine.
TnxNoNullCompKeyEngine | This is class nxsdKeyEngineComp.TnxNoNullCompKeyEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxCompositeKeyFieldEngineArray | This is type nxsdKeyEngineComp.TnxCompositeKeyFieldEngineArray.
Links
Classes, Legend, Topics, Types


Classes

Classes
Classes nxsdKeyEngineComp Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxCompositeKeyEngineException | This is class nxsdKeyEngineComp.EnxCompositeKeyEngineException.
TnxCompKeyEngine | This is class nxsdKeyEngineComp.TnxCompKeyEngine.
TnxNoNullCompKeyEngine | This is class nxsdKeyEngineComp.TnxNoNullCompKeyEngine.
Namespace

nxsdKeyEngineComp Namespace

Links
Classes, nxsdKeyEngineComp Namespace, Legend


EnxCompositeKeyEngineException Class

EnxCompositeKeyEngineException Class
nxsdKeyEngineComp Classes Send Feedback
Class Hierarchy
nxsdKeyEngineComp_EnxCompositeKeyEngineExceptionnxsdKeyEngineComp_EnxCompositeKeyEngineExceptionnxsdKeyEngineComp_EnxCompositeKeyEngineExceptionnxsdKeyEngineComp_EnxCompositeKeyEngineExceptionnxsdKeyEngineComp_EnxCompositeKeyEngineExceptionnxsdKeyEngineComp_EnxCompositeKeyEngineException
Syntax
Delphi
EnxCompositeKeyEngineException = class(EnxBaseKeyEngineException);
File

nxsdKeyEngineComp

Description

This is class nxsdKeyEngineComp.EnxCompositeKeyEngineException.

Group

Classes

Links
nxsdKeyEngineComp, Classes


TnxCompKeyEngine Class

TnxCompKeyEngine Class
TnxCompKeyEngine Fields TnxCompKeyEngine Methods TnxCompKeyEngine Properties TnxCompKeyEngine Members nxsdKeyEngineComp Classes Send Feedback
Class Hierarchy
nxsdKeyEngineComp_TnxCompKeyEnginenxsdKeyEngineComp_TnxCompKeyEnginenxsdKeyEngineComp_TnxCompKeyEnginenxsdKeyEngineComp_TnxCompKeyEnginenxsdKeyEngineComp_TnxCompKeyEnginenxsdKeyEngineComp_TnxCompKeyEngine
Syntax
Delphi
TnxCompKeyEngine = class(TnxBaseKeyEngine);
File

nxsdKeyEngineComp

Description

This is class nxsdKeyEngineComp.TnxCompKeyEngine.

Group

Classes

Links
TnxCompKeyEngine Fields, TnxCompKeyEngine Methods, TnxCompKeyEngine Properties, TnxCompKeyEngine Members, nxsdKeyEngineComp, Classes


TnxCompKeyEngine Members

TnxCompKeyEngine Members
TnxCompKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCompKeyEngine.

Class

TnxCompKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
ckeFieldsDescriptor | private
ckeKeyFieldCount | This is ckeKeyFieldCount, a member of class TnxCompKeyEngine.
ckeKeyFieldEngines | This is ckeKeyFieldEngines, a member of class TnxCompKeyEngine.
ckeKeyFieldInvertNull | This is ckeKeyFieldInvertNull, a member of class TnxCompKeyEngine.
ckeKeyFieldNames | This is ckeKeyFieldNames, a member of class TnxCompKeyEngine.
ckeKeyFieldOffset | This is ckeKeyFieldOffset, a member of class TnxCompKeyEngine.
ckeKeyOffset | This is ckeKeyOffset, a member of class TnxCompKeyEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
Create |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldsOffset |
GetKeyFieldOffset |
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BuildKey | TnxCompKeyEngine
CheckValidBaseFromDescriptor |
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetRegisteredEngines |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant |
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldEngine | This is KeyFieldEngine, a member of class TnxCompKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxCompKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCompKeyEngine.Create Constructor

TnxCompKeyEngine.Create Constructor
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseKeyDescriptor); override;
Class

TnxCompKeyEngine Class

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Class


TnxCompKeyEngine.Destroy Destructor

TnxCompKeyEngine.Destroy Destructor
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxCompKeyEngine Class

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Class


TnxCompKeyEngine Fields

TnxCompKeyEngine Fields
TnxCompKeyEngine Class Legend Protected Fields Send Feedback

The fields of the TnxCompKeyEngine class are listed here.

Class

TnxCompKeyEngine Class

Protected Fields
Name | Description
ckeFieldsDescriptor | private
ckeKeyFieldCount | This is ckeKeyFieldCount, a member of class TnxCompKeyEngine.
ckeKeyFieldEngines | This is ckeKeyFieldEngines, a member of class TnxCompKeyEngine.
ckeKeyFieldInvertNull | This is ckeKeyFieldInvertNull, a member of class TnxCompKeyEngine.
ckeKeyFieldNames | This is ckeKeyFieldNames, a member of class TnxCompKeyEngine.
ckeKeyFieldOffset | This is ckeKeyFieldOffset, a member of class TnxCompKeyEngine.
ckeKeyOffset | This is ckeKeyOffset, a member of class TnxCompKeyEngine.
Links
TnxCompKeyEngine Class, Legend, Protected Fields


TnxCompKeyEngine.ckeFieldsDescriptor Field

TnxCompKeyEngine.ckeFieldsDescriptor Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeFieldsDescriptor: TnxFieldsDescriptor;
Description

private

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyFieldCount Field

TnxCompKeyEngine.ckeKeyFieldCount Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyFieldCount: Integer;
Description

This is ckeKeyFieldCount, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyFieldEngines Field

TnxCompKeyEngine.ckeKeyFieldEngines Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyFieldEngines: TnxCompositeKeyFieldEngineArray;
Description

This is ckeKeyFieldEngines, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyFieldInvertNull Field

TnxCompKeyEngine.ckeKeyFieldInvertNull Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyFieldInvertNull: array of TnxValueRelationship;
Description

This is ckeKeyFieldInvertNull, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyFieldNames Field

TnxCompKeyEngine.ckeKeyFieldNames Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyFieldNames: TStringList;
Description

This is ckeKeyFieldNames, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyFieldOffset Field

TnxCompKeyEngine.ckeKeyFieldOffset Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyFieldOffset: array of Integer;
Description

This is ckeKeyFieldOffset, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine.ckeKeyOffset Field

TnxCompKeyEngine.ckeKeyOffset Field
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Fields Send Feedback
Syntax
Delphi
ckeKeyOffset: Integer;
Description

This is ckeKeyOffset, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Fields

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Fields


TnxCompKeyEngine Methods

TnxCompKeyEngine Methods
TnxCompKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCompKeyEngine class are listed here.

Class

TnxCompKeyEngine Class

Protected Methods
Name | Description
CheckValid |
GetFieldCount |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldsOffset |
GetKeyFieldOffset |
Public Methods
Name | Description
BuildKey | TnxCompKeyEngine
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
KeyAsVariant |
KeyContainsNulls |
Links
TnxCompKeyEngine Class, Legend, Protected Methods, Public Methods


TnxCompKeyEngine.BuildKey Method

TnxCompKeyEngine.BuildKey Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; override;
Description

TnxCompKeyEngine

Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.CheckValid Method

TnxCompKeyEngine.CheckValid Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseKeyDescriptor); override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.ClearKey Method

TnxCompKeyEngine.ClearKey Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


CompareKey Method

CompareKey Method
TnxCompKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxCompKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxCompKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) |
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Methods


TnxCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareKey Method


TnxCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareKey Method


CompareRecord Method

CompareRecord Method
TnxCompKeyEngine Methods Send Feedback

This is the overview for the CompareRecord method overload.

Overload List
Name | Description
TnxCompKeyEngine.CompareRecord (PnxByteArray, PnxByteArray) |
TnxCompKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64) |
TnxCompKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer) |
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Methods


TnxCompKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)

TnxCompKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRecord2: PnxByteArray): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)

TnxCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)

TnxCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxCompKeyEngine.GetFieldCount Method

TnxCompKeyEngine.GetFieldCount Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.GetFieldDescriptor Method

TnxCompKeyEngine.GetFieldDescriptor Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.GetFieldForFilter Method

TnxCompKeyEngine.GetFieldForFilter Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aKey: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean; override;
Description

InxFieldsSource

Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.GetFieldFromName Method

TnxCompKeyEngine.GetFieldFromName Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.GetFieldsOffset Method

TnxCompKeyEngine.GetFieldsOffset Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldsOffset: integer; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.GetKeyFieldOffset Method

TnxCompKeyEngine.GetKeyFieldOffset Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetKeyFieldOffset(Index: integer): Integer; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.KeyAsVariant Method

TnxCompKeyEngine.KeyAsVariant Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine.KeyContainsNulls Method

TnxCompKeyEngine.KeyContainsNulls Method
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; override;
Group

TnxCompKeyEngine Methods

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Methods


TnxCompKeyEngine Properties

TnxCompKeyEngine Properties
TnxCompKeyEngine Class Legend Public Properties Send Feedback

The properties of the TnxCompKeyEngine class are listed here.

Class

TnxCompKeyEngine Class

Public Properties
Name | Description
KeyFieldEngine | This is KeyFieldEngine, a member of class TnxCompKeyEngine.
Links
TnxCompKeyEngine Class, Legend, Public Properties


TnxCompKeyEngine.KeyFieldEngine Property

TnxCompKeyEngine.KeyFieldEngine Property
TnxCompKeyEngine Class TnxCompKeyEngine Members nxsdKeyEngineComp Namespace TnxCompKeyEngine Properties Send Feedback
Syntax
Delphi
property KeyFieldEngine [Index:integer]: TnxCompositeKeyFieldEngine;
Description

This is KeyFieldEngine, a member of class TnxCompKeyEngine.

Group

TnxCompKeyEngine Properties

Links
TnxCompKeyEngine Class, TnxCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxCompKeyEngine Properties


TnxNoNullCompKeyEngine Class

TnxNoNullCompKeyEngine Class
TnxNoNullCompKeyEngine Methods TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Classes Send Feedback
Class Hierarchy
nxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEnginenxsdKeyEngineComp_TnxNoNullCompKeyEngine
Syntax
Delphi
TnxNoNullCompKeyEngine = class(TnxCompKeyEngine);
File

nxsdKeyEngineComp

Description

This is class nxsdKeyEngineComp.TnxNoNullCompKeyEngine.

Group

Classes

Links
TnxNoNullCompKeyEngine Methods, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp, Classes


TnxNoNullCompKeyEngine Members

TnxNoNullCompKeyEngine Members
TnxNoNullCompKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNoNullCompKeyEngine.

Class

TnxNoNullCompKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
ckeFieldsDescriptor | private
ckeKeyFieldCount | This is ckeKeyFieldCount, a member of class TnxCompKeyEngine.
ckeKeyFieldEngines | This is ckeKeyFieldEngines, a member of class TnxCompKeyEngine.
ckeKeyFieldInvertNull | This is ckeKeyFieldInvertNull, a member of class TnxCompKeyEngine.
ckeKeyFieldNames | This is ckeKeyFieldNames, a member of class TnxCompKeyEngine.
ckeKeyFieldOffset | This is ckeKeyFieldOffset, a member of class TnxCompKeyEngine.
ckeKeyOffset | This is ckeKeyOffset, a member of class TnxCompKeyEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
CheckValid |
Create |
Create |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount | This is GetFieldCount, a member of class TnxBaseKeyEngine.
GetFieldCount |
GetFieldDescriptor | This is GetFieldDescriptor, a member of class TnxBaseKeyEngine.
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName | This is GetFieldFromName, a member of class TnxBaseKeyEngine.
GetFieldFromName |
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetFieldsOffset |
GetKeyFieldOffset |
GetKeyFieldOffset |
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BuildKey | TnxNoNullCompKeyEngine
CheckValidBaseFromDescriptor |
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetRegisteredEngines |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant |
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldEngine | This is KeyFieldEngine, a member of class TnxCompKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxNoNullCompKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxNoNullCompKeyEngine Methods

TnxNoNullCompKeyEngine Methods
TnxNoNullCompKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNoNullCompKeyEngine class are listed here.

Class

TnxNoNullCompKeyEngine Class

Protected Methods
Name | Description
GetFieldForFilter | InxFieldsSource
Public Methods
Name | Description
BuildKey | TnxNoNullCompKeyEngine
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
KeyAsVariant |
KeyContainsNulls |
Links
TnxNoNullCompKeyEngine Class, Legend, Protected Methods, Public Methods


TnxNoNullCompKeyEngine.BuildKey Method

TnxNoNullCompKeyEngine.BuildKey Method
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace TnxNoNullCompKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; override;
Description

TnxNoNullCompKeyEngine

Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxNoNullCompKeyEngine Methods


TnxNoNullCompKeyEngine.ClearKey Method

TnxNoNullCompKeyEngine.ClearKey Method
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace TnxNoNullCompKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); override;
Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxNoNullCompKeyEngine Methods


CompareKey Method

CompareKey Method
TnxNoNullCompKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxNoNullCompKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxNoNullCompKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) |
Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Methods


TnxNoNullCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxNoNullCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareKey Method


TnxNoNullCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxNoNullCompKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareKey Method


CompareRecord Method

CompareRecord Method
TnxNoNullCompKeyEngine Methods Send Feedback

This is the overview for the CompareRecord method overload.

Overload List
Name | Description
TnxNoNullCompKeyEngine.CompareRecord (PnxByteArray, PnxByteArray) |
TnxNoNullCompKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64) |
TnxNoNullCompKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer) |
Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Methods


TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)

TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, PnxByteArray)
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRecord2: PnxByteArray): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)

TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)

TnxNoNullCompKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, CompareRecord Method


TnxNoNullCompKeyEngine.GetFieldForFilter Method

TnxNoNullCompKeyEngine.GetFieldForFilter Method
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace TnxNoNullCompKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aKey: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean; override;
Description

InxFieldsSource

Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxNoNullCompKeyEngine Methods


TnxNoNullCompKeyEngine.KeyAsVariant Method

TnxNoNullCompKeyEngine.KeyAsVariant Method
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace TnxNoNullCompKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; override;
Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxNoNullCompKeyEngine Methods


TnxNoNullCompKeyEngine.KeyContainsNulls Method

TnxNoNullCompKeyEngine.KeyContainsNulls Method
TnxNoNullCompKeyEngine Class TnxNoNullCompKeyEngine Members nxsdKeyEngineComp Namespace TnxNoNullCompKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; override;
Group

TnxNoNullCompKeyEngine Methods

Links
TnxNoNullCompKeyEngine Class, TnxNoNullCompKeyEngine Members, nxsdKeyEngineComp Namespace, TnxNoNullCompKeyEngine Methods


Types

Types
nxsdKeyEngineComp Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdKeyEngineComp Namespace

Types
Name | Description
TnxCompositeKeyFieldEngineArray | This is type nxsdKeyEngineComp.TnxCompositeKeyFieldEngineArray.
Links
nxsdKeyEngineComp Namespace, Types


nxsdKeyEngineComp.TnxCompositeKeyFieldEngineArray Type

nxsdKeyEngineComp.TnxCompositeKeyFieldEngineArray Type
nxsdKeyEngineComp Types Send Feedback
Syntax
Delphi
TnxCompositeKeyFieldEngineArray = array of TnxCompositeKeyFieldEngine;
File

nxsdKeyEngineComp

Description

This is type nxsdKeyEngineComp.TnxCompositeKeyFieldEngineArray.

Group

Types

Links
nxsdKeyEngineComp, Types


nxsdKeyEngineRef Namespace

nxsdKeyEngineRef Namespace
Classes Legend Topics Send Feedback

This is namespace nxsdKeyEngineRef.

Classes
Name | Description
EnxRefKeyEngineException | This is class nxsdKeyEngineRef.EnxRefKeyEngineException.
TnxRefKeyEngine | This is class nxsdKeyEngineRef.TnxRefKeyEngine.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxsdKeyEngineRef Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxRefKeyEngineException | This is class nxsdKeyEngineRef.EnxRefKeyEngineException.
TnxRefKeyEngine | This is class nxsdKeyEngineRef.TnxRefKeyEngine.
Namespace

nxsdKeyEngineRef Namespace

Links
Classes, nxsdKeyEngineRef Namespace, Legend


EnxRefKeyEngineException Class

EnxRefKeyEngineException Class
nxsdKeyEngineRef Classes Send Feedback
Class Hierarchy
nxsdKeyEngineRef_EnxRefKeyEngineExceptionnxsdKeyEngineRef_EnxRefKeyEngineExceptionnxsdKeyEngineRef_EnxRefKeyEngineExceptionnxsdKeyEngineRef_EnxRefKeyEngineExceptionnxsdKeyEngineRef_EnxRefKeyEngineExceptionnxsdKeyEngineRef_EnxRefKeyEngineException
Syntax
Delphi
EnxRefKeyEngineException = class(EnxBaseKeyEngineException);
File

nxsdKeyEngineRef

Description

This is class nxsdKeyEngineRef.EnxRefKeyEngineException.

Group

Classes

Links
nxsdKeyEngineRef, Classes


TnxRefKeyEngine Class

TnxRefKeyEngine Class
TnxRefKeyEngine Methods TnxRefKeyEngine Members nxsdKeyEngineRef Classes Send Feedback
Class Hierarchy
nxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEnginenxsdKeyEngineRef_TnxRefKeyEngine
Syntax
Delphi
TnxRefKeyEngine = class(TnxBaseKeyEngine, InxFieldDescriptor);
File

nxsdKeyEngineRef

Description

This is class nxsdKeyEngineRef.TnxRefKeyEngine.

Group

Classes

Links
TnxRefKeyEngine Methods, TnxRefKeyEngine Members, nxsdKeyEngineRef, Classes


TnxRefKeyEngine Members

TnxRefKeyEngine Members
TnxRefKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRefKeyEngine.

Class

TnxRefKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
Create |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount |
GetFieldDecPl |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldName | InxFieldDescriptor
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetFieldType |
GetFieldUnits |
GetKeyFieldOffset |
GetList |
GetList |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxRefKeyEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxRefKeyEngine.
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BuildKey | TnxRefKeyEngine
CheckValidBaseFromDescriptor |
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetRegisteredEngines |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant |
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxRefKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRefKeyEngine.Create Constructor

TnxRefKeyEngine.Create Constructor
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseKeyDescriptor); override;
Class

TnxRefKeyEngine Class

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Class


TnxRefKeyEngine Methods

TnxRefKeyEngine Methods
TnxRefKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRefKeyEngine class are listed here.

Class

TnxRefKeyEngine Class

Protected Methods
Name | Description
CheckValid |
GetFieldCount |
GetFieldDecPl |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldName | InxFieldDescriptor
GetFieldType |
GetFieldUnits |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxRefKeyEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxRefKeyEngine.
Public Methods
Name | Description
BuildKey | TnxRefKeyEngine
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
KeyAsVariant |
KeyContainsNulls |
Links
TnxRefKeyEngine Class, Legend, Protected Methods, Public Methods


TnxRefKeyEngine.BuildKey Method

TnxRefKeyEngine.BuildKey Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; override;
Description

TnxRefKeyEngine

Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.CheckValid Method

TnxRefKeyEngine.CheckValid Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseKeyDescriptor); override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.ClearKey Method

TnxRefKeyEngine.ClearKey Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


CompareKey Method

CompareKey Method
TnxRefKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxRefKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxRefKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) |
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Methods


TnxRefKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxRefKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, CompareKey Method


TnxRefKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxRefKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, CompareKey Method


CompareRecord Method

CompareRecord Method
TnxRefKeyEngine Methods Send Feedback

This is the overview for the CompareRecord method overload.

Overload List
Name | Description
TnxRefKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64) |
TnxRefKeyEngine.CompareRecord (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer) |
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Methods


TnxRefKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)

TnxRefKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64)
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, CompareRecord Method


TnxRefKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)

TnxRefKeyEngine.CompareRecord Method (PnxByteArray, TnxInt64, PnxByteArray, TnxInt64, Integer, Integer)
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace CompareRecord Method Send Feedback
Syntax
Delphi
function CompareRecord(aRecord1: PnxByteArray; aRefNr1: TnxInt64; aRecord2: PnxByteArray; aRefNr2: TnxInt64; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareRecord Method

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, CompareRecord Method


TnxRefKeyEngine.CopyKey Method

TnxRefKeyEngine.CopyKey Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
procedure CopyKey(aFrom: PnxByteArray; aTo: PnxByteArray); override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldCount Method

TnxRefKeyEngine.GetFieldCount Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer; override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldDecPl Method

TnxRefKeyEngine.GetFieldDecPl Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDecPl: Integer;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldDescriptor Method

TnxRefKeyEngine.GetFieldDescriptor Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor; override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldForFilter Method

TnxRefKeyEngine.GetFieldForFilter Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aKey: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean; override;
Description

InxFieldsSource

Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldFromName Method

TnxRefKeyEngine.GetFieldFromName Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer; override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldName Method

TnxRefKeyEngine.GetFieldName Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldName: string;
Description

InxFieldDescriptor

Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldType Method

TnxRefKeyEngine.GetFieldType Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldType: TnxFieldType;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.GetFieldUnits Method

TnxRefKeyEngine.GetFieldUnits Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldUnits: Integer;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.KeyAsVariant Method

TnxRefKeyEngine.KeyAsVariant Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.KeyContainsNulls Method

TnxRefKeyEngine.KeyContainsNulls Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; override;
Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.ldiGetUsedStorageCodePage Method

TnxRefKeyEngine.ldiGetUsedStorageCodePage Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function ldiGetUsedStorageCodePage: Word;
Description

This is ldiGetUsedStorageCodePage, a member of class TnxRefKeyEngine.

Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


TnxRefKeyEngine.ldiOuterGetUsedLocaleDescriptor Method

TnxRefKeyEngine.ldiOuterGetUsedLocaleDescriptor Method
TnxRefKeyEngine Class TnxRefKeyEngine Members nxsdKeyEngineRef Namespace TnxRefKeyEngine Methods Send Feedback
Syntax
Delphi
function ldiOuterGetUsedLocaleDescriptor: TnxLocaleDescriptor;
Description

This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxRefKeyEngine.

Group

TnxRefKeyEngine Methods

Links
TnxRefKeyEngine Class, TnxRefKeyEngine Members, nxsdKeyEngineRef Namespace, TnxRefKeyEngine Methods


nxsdKeyEngineToken Namespace

nxsdKeyEngineToken Namespace
Classes Constants Interfaces Legend Topics Send Feedback

This is namespace nxsdKeyEngineToken.

Classes
Name | Description
EnxBitArrayTokenKeyEngineException | This is class nxsdKeyEngineToken.EnxBitArrayTokenKeyEngineException.
EnxMainIndexTokenKeyEngineException | This is class nxsdKeyEngineToken.EnxMainIndexTokenKeyEngineException.
TnxBitArrayTokenKeyEngine | This is class nxsdKeyEngineToken.TnxBitArrayTokenKeyEngine.
TnxMainIndexTokenKeyEngine | This is class nxsdKeyEngineToken.TnxMainIndexTokenKeyEngine.
Constants
Name | Description
rsBuildKeyIsNotSupported | This is constant nxsdKeyEngineToken.rsBuildKeyIsNotSupported.
Interfaces
Name | Description
InxFieldDescriptor2 | This is class nxsdKeyEngineToken.InxFieldDescriptor2.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Interfaces, Legend, Topics


Classes

Classes
Classes nxsdKeyEngineToken Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBitArrayTokenKeyEngineException | This is class nxsdKeyEngineToken.EnxBitArrayTokenKeyEngineException.
EnxMainIndexTokenKeyEngineException | This is class nxsdKeyEngineToken.EnxMainIndexTokenKeyEngineException.
TnxBitArrayTokenKeyEngine | This is class nxsdKeyEngineToken.TnxBitArrayTokenKeyEngine.
TnxMainIndexTokenKeyEngine | This is class nxsdKeyEngineToken.TnxMainIndexTokenKeyEngine.
Namespace

nxsdKeyEngineToken Namespace

Links
Classes, nxsdKeyEngineToken Namespace, Legend


EnxBitArrayTokenKeyEngineException Class

EnxBitArrayTokenKeyEngineException Class
nxsdKeyEngineToken Classes Send Feedback
Class Hierarchy
nxsdKeyEngineToken_EnxBitArrayTokenKeyEngineExceptionnxsdKeyEngineToken_EnxBitArrayTokenKeyEngineExceptionnxsdKeyEngineToken_EnxBitArrayTokenKeyEngineExceptionnxsdKeyEngineToken_EnxBitArrayTokenKeyEngineExceptionnxsdKeyEngineToken_EnxBitArrayTokenKeyEngineExceptionnxsdKeyEngineToken_EnxBitArrayTokenKeyEngineException
Syntax
Delphi
EnxBitArrayTokenKeyEngineException = class(EnxBaseKeyEngineException);
File

nxsdKeyEngineToken

Description

This is class nxsdKeyEngineToken.EnxBitArrayTokenKeyEngineException.

Group

Classes

Links
nxsdKeyEngineToken, Classes


EnxMainIndexTokenKeyEngineException Class

EnxMainIndexTokenKeyEngineException Class
nxsdKeyEngineToken Classes Send Feedback
Class Hierarchy
nxsdKeyEngineToken_EnxMainIndexTokenKeyEngineExceptionnxsdKeyEngineToken_EnxMainIndexTokenKeyEngineExceptionnxsdKeyEngineToken_EnxMainIndexTokenKeyEngineExceptionnxsdKeyEngineToken_EnxMainIndexTokenKeyEngineExceptionnxsdKeyEngineToken_EnxMainIndexTokenKeyEngineExceptionnxsdKeyEngineToken_EnxMainIndexTokenKeyEngineException
Syntax
Delphi
EnxMainIndexTokenKeyEngineException = class(EnxBaseKeyEngineException);
File

nxsdKeyEngineToken

Description

This is class nxsdKeyEngineToken.EnxMainIndexTokenKeyEngineException.

Group

Classes

Links
nxsdKeyEngineToken, Classes


TnxBitArrayTokenKeyEngine Class

TnxBitArrayTokenKeyEngine Class
TnxBitArrayTokenKeyEngine Fields TnxBitArrayTokenKeyEngine Methods TnxBitArrayTokenKeyEngine Properties TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Classes Send Feedback
Class Hierarchy
nxsdKeyEngineToken_TnxBitArrayTokenKeyEnginenxsdKeyEngineToken_TnxBitArrayTokenKeyEnginenxsdKeyEngineToken_TnxBitArrayTokenKeyEnginenxsdKeyEngineToken_TnxBitArrayTokenKeyEnginenxsdKeyEngineToken_TnxBitArrayTokenKeyEnginenxsdKeyEngineToken_TnxBitArrayTokenKeyEngine
Syntax
Delphi
TnxBitArrayTokenKeyEngine = class(TnxBaseKeyEngine);
File

nxsdKeyEngineToken

Description

This is class nxsdKeyEngineToken.TnxBitArrayTokenKeyEngine.

Group

Classes

Links
TnxBitArrayTokenKeyEngine Fields, TnxBitArrayTokenKeyEngine Methods, TnxBitArrayTokenKeyEngine Properties, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken, Classes


TnxBitArrayTokenKeyEngine Members

TnxBitArrayTokenKeyEngine Members
TnxBitArrayTokenKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBitArrayTokenKeyEngine.

Class

TnxBitArrayTokenKeyEngine Class

Protected Fields
Name | Description
batkeFlags | This is batkeFlags, a member of class TnxBitArrayTokenKeyEngine.
batkeLocale | This is batkeLocale, a member of class TnxBitArrayTokenKeyEngine.
batkeMaxTokenSize | This is batkeMaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.
batkePerField | private
batkeReverse | This is batkeReverse, a member of class TnxBitArrayTokenKeyEngine.
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
Create |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount | This is GetFieldCount, a member of class TnxBaseKeyEngine.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class TnxBaseKeyEngine.
GetFieldForFilter | InxFieldsSource
GetFieldFromName | This is GetFieldFromName, a member of class TnxBaseKeyEngine.
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetKeyFieldOffset |
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BuildKey | TnxBitArrayTokenKeyEngine
CheckValidBaseFromDescriptor |
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetRegisteredEngines |
InternalBuildKey |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant |
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
MaxTokenSize | This is MaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxBitArrayTokenKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBitArrayTokenKeyEngine.Create Constructor

TnxBitArrayTokenKeyEngine.Create Constructor
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseKeyDescriptor); override;
Class

TnxBitArrayTokenKeyEngine Class

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Class


TnxBitArrayTokenKeyEngine Fields

TnxBitArrayTokenKeyEngine Fields
TnxBitArrayTokenKeyEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBitArrayTokenKeyEngine class are listed here.

Class

TnxBitArrayTokenKeyEngine Class

Protected Fields
Name | Description
batkeFlags | This is batkeFlags, a member of class TnxBitArrayTokenKeyEngine.
batkeLocale | This is batkeLocale, a member of class TnxBitArrayTokenKeyEngine.
batkeMaxTokenSize | This is batkeMaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.
batkePerField | private
batkeReverse | This is batkeReverse, a member of class TnxBitArrayTokenKeyEngine.
Links
TnxBitArrayTokenKeyEngine Class, Legend, Protected Fields


TnxBitArrayTokenKeyEngine.batkeFlags Field

TnxBitArrayTokenKeyEngine.batkeFlags Field
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Fields Send Feedback
Syntax
Delphi
batkeFlags: Cardinal;
Description

This is batkeFlags, a member of class TnxBitArrayTokenKeyEngine.

Group

TnxBitArrayTokenKeyEngine Fields

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Fields


TnxBitArrayTokenKeyEngine.batkeLocale Field

TnxBitArrayTokenKeyEngine.batkeLocale Field
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Fields Send Feedback
Syntax
Delphi
batkeLocale: LCID;
Description

This is batkeLocale, a member of class TnxBitArrayTokenKeyEngine.

Group

TnxBitArrayTokenKeyEngine Fields

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Fields


TnxBitArrayTokenKeyEngine.batkeMaxTokenSize Field

TnxBitArrayTokenKeyEngine.batkeMaxTokenSize Field
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Fields Send Feedback
Syntax
Delphi
batkeMaxTokenSize: Integer;
Description

This is batkeMaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.

Group

TnxBitArrayTokenKeyEngine Fields

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Fields


TnxBitArrayTokenKeyEngine.batkePerField Field

TnxBitArrayTokenKeyEngine.batkePerField Field
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Fields Send Feedback
Syntax
Delphi
batkePerField: Boolean;
Description

private

Group

TnxBitArrayTokenKeyEngine Fields

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Fields


TnxBitArrayTokenKeyEngine.batkeReverse Field

TnxBitArrayTokenKeyEngine.batkeReverse Field
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Fields Send Feedback
Syntax
Delphi
batkeReverse: Boolean;
Description

This is batkeReverse, a member of class TnxBitArrayTokenKeyEngine.

Group

TnxBitArrayTokenKeyEngine Fields

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Fields


TnxBitArrayTokenKeyEngine Methods

TnxBitArrayTokenKeyEngine Methods
TnxBitArrayTokenKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBitArrayTokenKeyEngine class are listed here.

Class

TnxBitArrayTokenKeyEngine Class

Protected Methods
Name | Description
CheckValid |
Public Methods
Name | Description
BuildKey | TnxBitArrayTokenKeyEngine
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
InternalBuildKey |
KeyAsVariant |
KeyContainsNulls |
Links
TnxBitArrayTokenKeyEngine Class, Legend, Protected Methods, Public Methods


TnxBitArrayTokenKeyEngine.BuildKey Method

TnxBitArrayTokenKeyEngine.BuildKey Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; override;
Description

TnxBitArrayTokenKeyEngine

Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine.CheckValid Method

TnxBitArrayTokenKeyEngine.CheckValid Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseKeyDescriptor); override;
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine.ClearKey Method

TnxBitArrayTokenKeyEngine.ClearKey Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); override;
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


CompareKey Method

CompareKey Method
TnxBitArrayTokenKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxBitArrayTokenKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxBitArrayTokenKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) |
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxBitArrayTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, CompareKey Method


TnxBitArrayTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxBitArrayTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, CompareKey Method


TnxBitArrayTokenKeyEngine.InternalBuildKey Method

TnxBitArrayTokenKeyEngine.InternalBuildKey Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
procedure InternalBuildKey(aSegment: TnxWord16; const aToken: TnxWideString; aField: TnxInt16; aKey: PnxByteArray); virtual;
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine.KeyAsVariant Method

TnxBitArrayTokenKeyEngine.KeyAsVariant Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; override;
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine.KeyContainsNulls Method

TnxBitArrayTokenKeyEngine.KeyContainsNulls Method
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; override;
Group

TnxBitArrayTokenKeyEngine Methods

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Methods


TnxBitArrayTokenKeyEngine Properties

TnxBitArrayTokenKeyEngine Properties
TnxBitArrayTokenKeyEngine Class Legend Public Properties Send Feedback

The properties of the TnxBitArrayTokenKeyEngine class are listed here.

Class

TnxBitArrayTokenKeyEngine Class

Public Properties
Name | Description
MaxTokenSize | This is MaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.
Links
TnxBitArrayTokenKeyEngine Class, Legend, Public Properties


TnxBitArrayTokenKeyEngine.MaxTokenSize Property

TnxBitArrayTokenKeyEngine.MaxTokenSize Property
TnxBitArrayTokenKeyEngine Class TnxBitArrayTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxBitArrayTokenKeyEngine Properties Send Feedback
Syntax
Delphi
property MaxTokenSize: Integer;
Description

This is MaxTokenSize, a member of class TnxBitArrayTokenKeyEngine.

Group

TnxBitArrayTokenKeyEngine Properties

Links
TnxBitArrayTokenKeyEngine Class, TnxBitArrayTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxBitArrayTokenKeyEngine Properties


TnxMainIndexTokenKeyEngine Class

TnxMainIndexTokenKeyEngine Class
TnxMainIndexTokenKeyEngine Fields TnxMainIndexTokenKeyEngine Methods TnxMainIndexTokenKeyEngine Properties TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Classes Send Feedback
Class Hierarchy
nxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEnginenxsdKeyEngineToken_TnxMainIndexTokenKeyEngine
Syntax
Delphi
TnxMainIndexTokenKeyEngine = class(TnxBaseKeyEngine, InxFieldDescriptor, InxFieldDescriptor2);
File

nxsdKeyEngineToken

Description

This is class nxsdKeyEngineToken.TnxMainIndexTokenKeyEngine.

Group

Classes

Links
TnxMainIndexTokenKeyEngine Fields, TnxMainIndexTokenKeyEngine Methods, TnxMainIndexTokenKeyEngine Properties, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken, Classes


TnxMainIndexTokenKeyEngine Members

TnxMainIndexTokenKeyEngine Members
TnxMainIndexTokenKeyEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMainIndexTokenKeyEngine.

Class

TnxMainIndexTokenKeyEngine Class

Protected Fields
Name | Description
bkeContainsExtended | This is bkeContainsExtended, a member of class TnxBaseKeyEngine.
bkeFilter | This is bkeFilter, a member of class TnxBaseKeyEngine.
bkeKeyDescriptor | private
bkeKeyLength | This is bkeKeyLength, a member of class TnxBaseKeyEngine.
bkeMemoryPool | This is bkeMemoryPool, a member of class TnxBaseKeyEngine.
bkeNLSVersionChanged | This is bkeNLSVersionChanged, a member of class TnxBaseKeyEngine.
mitkeFlags | This is mitkeFlags, a member of class TnxMainIndexTokenKeyEngine.
mitkeIncludeLocation | This is mitkeIncludeLocation, a member of class TnxMainIndexTokenKeyEngine.
mitkeLocale | This is mitkeLocale, a member of class TnxMainIndexTokenKeyEngine.
mitkeLocaleDescriptor | This is mitkeLocaleDescriptor, a member of class TnxMainIndexTokenKeyEngine.
mitkeMaxTokenSize | private
Protected Methods
Name | Description
_AddRef |
_Release |
BlobsSupported |
CheckValid |
Create |
GetCursor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetFieldAsVariant |
GetFieldCount |
GetFieldDecPl |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldName0 | InxFieldDescriptor
GetFieldName1 |
GetFieldsOffset | This is GetFieldsOffset, a member of class TnxBaseKeyEngine.
GetFieldType0 |
GetFieldType1 |
GetFieldUnits0 |
GetFieldUnits1 |
GetKeyFieldOffset |
GetList |
GetList |
ldiGetUsedStorageCodePage |
ldiOuterGetUsedLocaleDescriptor |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
AllocKey | TnxBaseKeyEngine
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BuildKey | TnxMainIndexTokenKeyEngine
CheckValidBaseFromDescriptor |
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
CompareKey | This is the overview for the CompareKey method overload.
CompareRecord | This is the overview for the CompareRecord method overload.
CopyKey |
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeKey |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
GetRegisteredEngines |
InternalBuildKey |
KeyAsExceptionData |
KeyAsString |
KeyAsVariant |
KeyContainsNulls |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
SupportsReindex |
TryCreateFor |
Public Properties
Name | Description
ContainsExtended | This is ContainsExtended, a member of class TnxBaseKeyEngine.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldsOffset | This is FieldsOffset, a member of class TnxBaseKeyEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
Filter | This is Filter, a member of class TnxBaseKeyEngine.
IncludeLocation | This is IncludeLocation, a member of class TnxMainIndexTokenKeyEngine.
KeyDescriptor | This is KeyDescriptor, a member of class TnxBaseKeyEngine.
KeyFieldOffset | This is KeyFieldOffset, a member of class TnxBaseKeyEngine.
KeyLength | This is KeyLength, a member of class TnxBaseKeyEngine.
MaxFieldCount | This is MaxFieldCount, a member of class TnxBaseKeyEngine.
MaxTokenSize | This is MaxTokenSize, a member of class TnxMainIndexTokenKeyEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxBaseKeyEngine.
Links
TnxMainIndexTokenKeyEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMainIndexTokenKeyEngine.Create Constructor

TnxMainIndexTokenKeyEngine.Create Constructor
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseKeyDescriptor); override;
Class

TnxMainIndexTokenKeyEngine Class

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Class


TnxMainIndexTokenKeyEngine.Destroy Destructor

TnxMainIndexTokenKeyEngine.Destroy Destructor
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMainIndexTokenKeyEngine Class

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Class


TnxMainIndexTokenKeyEngine Fields

TnxMainIndexTokenKeyEngine Fields
TnxMainIndexTokenKeyEngine Class Legend Protected Fields Send Feedback

The fields of the TnxMainIndexTokenKeyEngine class are listed here.

Class

TnxMainIndexTokenKeyEngine Class

Protected Fields
Name | Description
mitkeFlags | This is mitkeFlags, a member of class TnxMainIndexTokenKeyEngine.
mitkeIncludeLocation | This is mitkeIncludeLocation, a member of class TnxMainIndexTokenKeyEngine.
mitkeLocale | This is mitkeLocale, a member of class TnxMainIndexTokenKeyEngine.
mitkeLocaleDescriptor | This is mitkeLocaleDescriptor, a member of class TnxMainIndexTokenKeyEngine.
mitkeMaxTokenSize | private
Links
TnxMainIndexTokenKeyEngine Class, Legend, Protected Fields


TnxMainIndexTokenKeyEngine.mitkeFlags Field

TnxMainIndexTokenKeyEngine.mitkeFlags Field
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Fields Send Feedback
Syntax
Delphi
mitkeFlags: Cardinal;
Description

This is mitkeFlags, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Fields

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Fields


TnxMainIndexTokenKeyEngine.mitkeIncludeLocation Field

TnxMainIndexTokenKeyEngine.mitkeIncludeLocation Field
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Fields Send Feedback
Syntax
Delphi
mitkeIncludeLocation: Boolean;
Description

This is mitkeIncludeLocation, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Fields

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Fields


TnxMainIndexTokenKeyEngine.mitkeLocale Field

TnxMainIndexTokenKeyEngine.mitkeLocale Field
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Fields Send Feedback
Syntax
Delphi
mitkeLocale: LCID;
Description

This is mitkeLocale, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Fields

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Fields


TnxMainIndexTokenKeyEngine.mitkeLocaleDescriptor Field

TnxMainIndexTokenKeyEngine.mitkeLocaleDescriptor Field
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Fields Send Feedback
Syntax
Delphi
mitkeLocaleDescriptor: TnxLocaleDescriptor;
Description

This is mitkeLocaleDescriptor, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Fields

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Fields


TnxMainIndexTokenKeyEngine.mitkeMaxTokenSize Field

TnxMainIndexTokenKeyEngine.mitkeMaxTokenSize Field
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Fields Send Feedback
Syntax
Delphi
mitkeMaxTokenSize: Integer;
Description

private

Group

TnxMainIndexTokenKeyEngine Fields

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Fields


TnxMainIndexTokenKeyEngine Methods

TnxMainIndexTokenKeyEngine Methods
TnxMainIndexTokenKeyEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMainIndexTokenKeyEngine class are listed here.

Class

TnxMainIndexTokenKeyEngine Class

Protected Methods
Name | Description
CheckValid |
GetFieldCount |
GetFieldDecPl |
GetFieldDescriptor |
GetFieldForFilter | InxFieldsSource
GetFieldFromName |
GetFieldName0 | InxFieldDescriptor
GetFieldName1 |
GetFieldType0 |
GetFieldType1 |
GetFieldUnits0 |
GetFieldUnits1 |
ldiGetUsedStorageCodePage |
ldiOuterGetUsedLocaleDescriptor |
Public Methods
Name | Description
BuildKey | TnxMainIndexTokenKeyEngine
ClearKey |
CompareKey | This is the overview for the CompareKey method overload.
InternalBuildKey |
KeyAsVariant |
KeyContainsNulls |
SupportsReindex |
Links
TnxMainIndexTokenKeyEngine Class, Legend, Protected Methods, Public Methods


TnxMainIndexTokenKeyEngine.BuildKey Method

TnxMainIndexTokenKeyEngine.BuildKey Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function BuildKey(aRecord: PnxByteArray; aKey: PnxByteArray; aRefNr: TnxInt64; aIgnoreFilter: Boolean): TnxResult; override;
Description

TnxMainIndexTokenKeyEngine

Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.CheckValid Method

TnxMainIndexTokenKeyEngine.CheckValid Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseKeyDescriptor); override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.ClearKey Method

TnxMainIndexTokenKeyEngine.ClearKey Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
procedure ClearKey(aKey: PnxByteArray); override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


CompareKey Method

CompareKey Method
TnxMainIndexTokenKeyEngine Methods Send Feedback

This is the overview for the CompareKey method overload.

Overload List
Name | Description
TnxMainIndexTokenKeyEngine.CompareKey (PnxByteArray, PnxByteArray) |
TnxMainIndexTokenKeyEngine.CompareKey (PnxByteArray, PnxByteArray, Integer, Integer) |
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)

TnxMainIndexTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray)
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, CompareKey Method


TnxMainIndexTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)

TnxMainIndexTokenKeyEngine.CompareKey Method (PnxByteArray, PnxByteArray, Integer, Integer)
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace CompareKey Method Send Feedback
Syntax
Delphi
function CompareKey(aKey1: PnxByteArray; aKey2: PnxByteArray; aFieldCount: Integer; aPartialLen: Integer): TnxValueRelationship; override;
Group

CompareKey Method

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, CompareKey Method


TnxMainIndexTokenKeyEngine.GetFieldCount Method

TnxMainIndexTokenKeyEngine.GetFieldCount Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldCount: Integer; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldDecPl Method

TnxMainIndexTokenKeyEngine.GetFieldDecPl Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDecPl: Integer;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldDescriptor Method

TnxMainIndexTokenKeyEngine.GetFieldDescriptor Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptor(aIndex: Integer): InxFieldDescriptor; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldForFilter Method

TnxMainIndexTokenKeyEngine.GetFieldForFilter Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldForFilter(aField: Integer; aName: PAnsiChar; aKey: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean; override;
Description

InxFieldsSource

Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldFromName Method

TnxMainIndexTokenKeyEngine.GetFieldFromName Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldFromName(const aFieldName: string): Integer; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldName0 Method

TnxMainIndexTokenKeyEngine.GetFieldName0 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldName0: string;
Description

InxFieldDescriptor

Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldName1 Method

TnxMainIndexTokenKeyEngine.GetFieldName1 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldName1: string;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldType0 Method

TnxMainIndexTokenKeyEngine.GetFieldType0 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldType0: TnxFieldType;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldType1 Method

TnxMainIndexTokenKeyEngine.GetFieldType1 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldType1: TnxFieldType;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldUnits0 Method

TnxMainIndexTokenKeyEngine.GetFieldUnits0 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldUnits0: Integer;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.GetFieldUnits1 Method

TnxMainIndexTokenKeyEngine.GetFieldUnits1 Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function GetFieldUnits1: Integer;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.InternalBuildKey Method

TnxMainIndexTokenKeyEngine.InternalBuildKey Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
procedure InternalBuildKey(const aToken: TnxWideString; aLocation: TnxWord32; aKey: PnxByteArray); virtual;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.KeyAsVariant Method

TnxMainIndexTokenKeyEngine.KeyAsVariant Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyAsVariant(aKey: PnxByteArray; aField: Integer = -1): Variant; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.KeyContainsNulls Method

TnxMainIndexTokenKeyEngine.KeyContainsNulls Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function KeyContainsNulls(aKey: PnxByteArray): Boolean; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.ldiGetUsedStorageCodePage Method

TnxMainIndexTokenKeyEngine.ldiGetUsedStorageCodePage Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function ldiGetUsedStorageCodePage: Word;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.ldiOuterGetUsedLocaleDescriptor Method

TnxMainIndexTokenKeyEngine.ldiOuterGetUsedLocaleDescriptor Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
function ldiOuterGetUsedLocaleDescriptor: TnxLocaleDescriptor;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine.SupportsReindex Method

TnxMainIndexTokenKeyEngine.SupportsReindex Method
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Methods Send Feedback
Syntax
Delphi
class function SupportsReindex: Boolean; override;
Group

TnxMainIndexTokenKeyEngine Methods

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Methods


TnxMainIndexTokenKeyEngine Properties

TnxMainIndexTokenKeyEngine Properties
TnxMainIndexTokenKeyEngine Class Legend Public Properties Send Feedback

The properties of the TnxMainIndexTokenKeyEngine class are listed here.

Class

TnxMainIndexTokenKeyEngine Class

Public Properties
Name | Description
IncludeLocation | This is IncludeLocation, a member of class TnxMainIndexTokenKeyEngine.
MaxTokenSize | This is MaxTokenSize, a member of class TnxMainIndexTokenKeyEngine.
Links
TnxMainIndexTokenKeyEngine Class, Legend, Public Properties


TnxMainIndexTokenKeyEngine.IncludeLocation Property

TnxMainIndexTokenKeyEngine.IncludeLocation Property
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Properties Send Feedback
Syntax
Delphi
property IncludeLocation: Boolean;
Description

This is IncludeLocation, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Properties

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Properties


TnxMainIndexTokenKeyEngine.MaxTokenSize Property

TnxMainIndexTokenKeyEngine.MaxTokenSize Property
TnxMainIndexTokenKeyEngine Class TnxMainIndexTokenKeyEngine Members nxsdKeyEngineToken Namespace TnxMainIndexTokenKeyEngine Properties Send Feedback
Syntax
Delphi
property MaxTokenSize: Integer;
Description

This is MaxTokenSize, a member of class TnxMainIndexTokenKeyEngine.

Group

TnxMainIndexTokenKeyEngine Properties

Links
TnxMainIndexTokenKeyEngine Class, TnxMainIndexTokenKeyEngine Members, nxsdKeyEngineToken Namespace, TnxMainIndexTokenKeyEngine Properties


Interfaces

Interfaces
nxsdKeyEngineToken Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxsdKeyEngineToken Namespace

Interfaces
Name | Description
InxFieldDescriptor2 | This is class nxsdKeyEngineToken.InxFieldDescriptor2.
Links
nxsdKeyEngineToken Namespace, Interfaces, Legend


InxFieldDescriptor2 Interface

InxFieldDescriptor2 Interface
nxsdKeyEngineToken Interfaces Send Feedback
Class Hierarchy
nxsdKeyEngineToken_InxFieldDescriptor2nxsdKeyEngineToken_InxFieldDescriptor2
Syntax
Delphi
InxFieldDescriptor2 = interface(InxFieldDescriptor);
File

nxsdKeyEngineToken

Description

This is class nxsdKeyEngineToken.InxFieldDescriptor2.

Group

Interfaces

Links
nxsdKeyEngineToken, Interfaces


Constants

Constants
Constants nxsdKeyEngineToken Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsBuildKeyIsNotSupported | This is constant nxsdKeyEngineToken.rsBuildKeyIsNotSupported.
Namespace

nxsdKeyEngineToken Namespace

Links
Constants, nxsdKeyEngineToken Namespace


nxsdKeyEngineToken.rsBuildKeyIsNotSupported Constant

nxsdKeyEngineToken.rsBuildKeyIsNotSupported Constant
nxsdKeyEngineToken Constants Send Feedback
Syntax
Delphi
rsBuildKeyIsNotSupported = 'BuildKey is not supported by TnxBitArrayTokenK' + 'eyEngine';
File

nxsdKeyEngineToken

Description

This is constant nxsdKeyEngineToken.rsBuildKeyIsNotSupported.

Group

Constants

Links
nxsdKeyEngineToken, Constants


nxsdKeyFieldEngineBase Namespace

nxsdKeyFieldEngineBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdKeyFieldEngineBase.

Classes
Name | Description
EnxCompositeKeyFieldEngineException | This is class nxsdKeyFieldEngineBase.EnxCompositeKeyFieldEngineException.
TnxCompositeKeyFieldEngine | This is class nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngine.
TnxDateOnlyCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyCKFE.
TnxDateOnlyMonthCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyMonthCKFE.
TnxDateOnlyProcessCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyProcessCKFE.
TnxDateOnlyWeekCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyWeekCKFE.
TnxDateOnlyYearCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyYearCKFE.
TnxNumbersOnlyCKFE | This is class nxsdKeyFieldEngineBase.TnxNumbersOnlyCKFE.
Constants
Name | Description
nxc_CKFE_DateOnly | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnly.
nxc_CKFE_DateOnlyMonth | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyMonth.
nxc_CKFE_DateOnlyWeek | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyWeek.
nxc_CKFE_DateOnlyYear | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyYear.
nxc_CKFE_NumbersOnly | Pre-defined helper names
rsCKFENotReg | This is constant nxsdKeyFieldEngineBase.rsCKFENotReg.
rsFieldTypeNotSupported | This is constant nxsdKeyFieldEngineBase.rsFieldTypeNotSupported.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxCompositeKeyFieldEngineClass | This is type nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngineClass.
Variables
Name | Description
_HelperList | TnxCompositeKeyFieldEngine
_HelperListPadlock | This is variable nxsdKeyFieldEngineBase._HelperListPadlock.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdKeyFieldEngineBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxCompositeKeyFieldEngineException | This is class nxsdKeyFieldEngineBase.EnxCompositeKeyFieldEngineException.
TnxCompositeKeyFieldEngine | This is class nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngine.
TnxDateOnlyCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyCKFE.
TnxDateOnlyMonthCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyMonthCKFE.
TnxDateOnlyProcessCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyProcessCKFE.
TnxDateOnlyWeekCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyWeekCKFE.
TnxDateOnlyYearCKFE | This is class nxsdKeyFieldEngineBase.TnxDateOnlyYearCKFE.
TnxNumbersOnlyCKFE | This is class nxsdKeyFieldEngineBase.TnxNumbersOnlyCKFE.
Namespace

nxsdKeyFieldEngineBase Namespace

Links
Classes, nxsdKeyFieldEngineBase Namespace, Legend


EnxCompositeKeyFieldEngineException Class

EnxCompositeKeyFieldEngineException Class
nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_EnxCompositeKeyFieldEngineExceptionnxsdKeyFieldEngineBase_EnxCompositeKeyFieldEngineExceptionnxsdKeyFieldEngineBase_EnxCompositeKeyFieldEngineExceptionnxsdKeyFieldEngineBase_EnxCompositeKeyFieldEngineException
Syntax
Delphi
EnxCompositeKeyFieldEngineException = class(EnxBaseException);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.EnxCompositeKeyFieldEngineException.

Group

Classes

Links
nxsdKeyFieldEngineBase, Classes


TnxCompositeKeyFieldEngine Class

TnxCompositeKeyFieldEngine Class
TnxCompositeKeyFieldEngine Fields TnxCompositeKeyFieldEngine Methods TnxCompositeKeyFieldEngine Properties TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxCompositeKeyFieldEnginenxsdKeyFieldEngineBase_TnxCompositeKeyFieldEnginenxsdKeyFieldEngineBase_TnxCompositeKeyFieldEnginenxsdKeyFieldEngineBase_TnxCompositeKeyFieldEngine
Syntax
Delphi
TnxCompositeKeyFieldEngine = class(TnxPersistent, InxFieldDescriptor);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngine.

Group

Classes

Links
TnxCompositeKeyFieldEngine Fields, TnxCompositeKeyFieldEngine Methods, TnxCompositeKeyFieldEngine Properties, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase, Classes


TnxCompositeKeyFieldEngine Members

TnxCompositeKeyFieldEngine Members
TnxCompositeKeyFieldEngine Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCompositeKeyFieldEngine.

Class

TnxCompositeKeyFieldEngine Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
Create |
CurrencyCompareKey |
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxCompositeKeyFieldEngine Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxCompositeKeyFieldEngine.Create Constructor

TnxCompositeKeyFieldEngine.Create Constructor
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Class Send Feedback
Syntax
Delphi
constructor Create(aKeyFieldDescriptor: TnxKeyFieldDescriptor); virtual;
Class

TnxCompositeKeyFieldEngine Class

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Class


TnxCompositeKeyFieldEngine Fields

TnxCompositeKeyFieldEngine Fields
TnxCompositeKeyFieldEngine Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxCompositeKeyFieldEngine class are listed here.

Class

TnxCompositeKeyFieldEngine Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Links
TnxCompositeKeyFieldEngine Class, Legend, Protected Fields, Public Fields


TnxCompositeKeyFieldEngine.BuildKey Field

TnxCompositeKeyFieldEngine.BuildKey Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
BuildKey: procedure(const aFieldBuffer; var aKeyBuffer) of object;
Description

compares the keys for a specific field up to a particular length

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeBuildKeyLength Field

TnxCompositeKeyFieldEngine.ckfeBuildKeyLength Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeBuildKeyLength: Integer;
Description

This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeCompareCodepage Field

TnxCompositeKeyFieldEngine.ckfeCompareCodepage Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeCompareCodepage: Word;
Description

This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeCompareFlags Field

TnxCompositeKeyFieldEngine.ckfeCompareFlags Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeCompareFlags: Cardinal;
Description

This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldDecPl Field

TnxCompositeKeyFieldEngine.ckfeFieldDecPl Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldDecPl: Integer;
Description

This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldLength Field

TnxCompositeKeyFieldEngine.ckfeFieldLength Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldLength: Integer;
Description

This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldName Field

TnxCompositeKeyFieldEngine.ckfeFieldName Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldName: string;
Description

private

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldNumber Field

TnxCompositeKeyFieldEngine.ckfeFieldNumber Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldNumber: Integer;
Description

This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldOffset Field

TnxCompositeKeyFieldEngine.ckfeFieldOffset Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldOffset: Integer;
Description

This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeFieldType Field

TnxCompositeKeyFieldEngine.ckfeFieldType Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeFieldType: TnxFieldType;
Description

This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeKeyChars Field

TnxCompositeKeyFieldEngine.ckfeKeyChars Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeKeyChars: Integer;
Description

This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeKeyLength Field

TnxCompositeKeyFieldEngine.ckfeKeyLength Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeKeyLength: Integer;
Description

This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeKeyUnits Field

TnxCompositeKeyFieldEngine.ckfeKeyUnits Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeKeyUnits: Integer;
Description

This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeLocale Field

TnxCompositeKeyFieldEngine.ckfeLocale Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeLocale: LCID;
Description

This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeLocaleDescriptor Field

TnxCompositeKeyFieldEngine.ckfeLocaleDescriptor Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeLocaleDescriptor: TnxLocaleDescriptor;
Description

This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeNLSVersionChanged Field

TnxCompositeKeyFieldEngine.ckfeNLSVersionChanged Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeNLSVersionChanged: Boolean;
Description

This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeStorageCodepage Field

TnxCompositeKeyFieldEngine.ckfeStorageCodepage Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeStorageCodepage: Word;
Description

This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.ckfeUseByteOrder Field

TnxCompositeKeyFieldEngine.ckfeUseByteOrder Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
ckfeUseByteOrder: Boolean;
Description

This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.CompareFieldDirect Field

TnxCompositeKeyFieldEngine.CompareFieldDirect Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
CompareFieldDirect: function(const aField1; const aField2) : TnxValueRelationship of object;
Description

compares the keys for a specific field

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.CompareKey Field

TnxCompositeKeyFieldEngine.CompareKey Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
CompareKey: function(const aKey1; const aKey2) : TnxValueRelationship of object;
Description

This is CompareKey, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.FilterNonNull Field

TnxCompositeKeyFieldEngine.FilterNonNull Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
FilterNonNull: Boolean;
Description

This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.FilterNull Field

TnxCompositeKeyFieldEngine.FilterNull Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
FilterNull: Boolean;
Description

This is FilterNull, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.InvertNull Field

TnxCompositeKeyFieldEngine.InvertNull Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
InvertNull: Boolean;
Description

This is InvertNull, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.KeyAsVariant Field

TnxCompositeKeyFieldEngine.KeyAsVariant Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
KeyAsVariant: function(const aKey): OleVariant of object;
Description

This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.KeySameAsRecordFormat Field

TnxCompositeKeyFieldEngine.KeySameAsRecordFormat Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
KeySameAsRecordFormat: Boolean;
Description

builds the key for a specific field

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.PartialCompareFieldDirect Field

TnxCompositeKeyFieldEngine.PartialCompareFieldDirect Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
PartialCompareFieldDirect: function(const aField1; const aField2; aPartialLen : Integer) : TnxValueRelationship of object;
Description

compares the keys for a specific field up to a particular length

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine.PartialCompareKey Field

TnxCompositeKeyFieldEngine.PartialCompareKey Field
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Fields Send Feedback
Syntax
Delphi
PartialCompareKey: function(const aKey1; const aKey2; aPartialLen : Integer) : TnxValueRelationship of object;
Description

compares the field buffers directly

Group

TnxCompositeKeyFieldEngine Fields

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Fields


TnxCompositeKeyFieldEngine Methods

TnxCompositeKeyFieldEngine Methods
TnxCompositeKeyFieldEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCompositeKeyFieldEngine class are listed here.

Class

TnxCompositeKeyFieldEngine Class

Protected Methods
Name | Description
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
CurrencyCompareKey |
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
CreateEngine | removes this class from the internal list
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Links
TnxCompositeKeyFieldEngine Class, Legend, Protected Methods, Public Methods


TnxCompositeKeyFieldEngine.AnsiCharCompareKey Method

TnxCompositeKeyFieldEngine.AnsiCharCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function AnsiCharCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.AnsiCharCompareKeyCS Method

TnxCompositeKeyFieldEngine.AnsiCharCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function AnsiCharCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.AnsiCharCompareKeyIC Method

TnxCompositeKeyFieldEngine.AnsiCharCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function AnsiCharCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.BooleanCompareKey Method

TnxCompositeKeyFieldEngine.BooleanCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function BooleanCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ByteArrayCompareKey Method

TnxCompositeKeyFieldEngine.ByteArrayCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ByteArrayCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ByteArrayPartialCompareKey Method

TnxCompositeKeyFieldEngine.ByteArrayPartialCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ByteArrayPartialCompareKey(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ByteCompareKey Method

TnxCompositeKeyFieldEngine.ByteCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ByteCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CheckSupportsFieldType Method

TnxCompositeKeyFieldEngine.CheckSupportsFieldType Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class function CheckSupportsFieldType(const aEngineName: string; const aFieldType: TnxFieldType): Boolean;
Description

returns comma separated list of engine names

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CheckValid Method

TnxCompositeKeyFieldEngine.CheckValid Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aKeyFieldDescriptor: TnxKeyFieldDescriptor); virtual;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CheckValidBase Method

TnxCompositeKeyFieldEngine.CheckValidBase Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValidBase(aKeyFieldDescriptor: TnxKeyFieldDescriptor);
Description

returns the key buffer as a variant

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CompareFieldDirectBuildKeys Method

TnxCompositeKeyFieldEngine.CompareFieldDirectBuildKeys Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function CompareFieldDirectBuildKeys(const aField1; const aField2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CreateEngine Method

TnxCompositeKeyFieldEngine.CreateEngine Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class function CreateEngine(aKeyFieldDescriptor: TnxKeyFieldDescriptor): TnxCompositeKeyFieldEngine;
Description

removes this class from the internal list

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.CurrencyCompareKey Method

TnxCompositeKeyFieldEngine.CurrencyCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function CurrencyCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DefaultBuildKey Method

TnxCompositeKeyFieldEngine.DefaultBuildKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure DefaultBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DefaultKeyAsVariant Method

TnxCompositeKeyFieldEngine.DefaultKeyAsVariant Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DefaultKeyAsVariant(const aKey): OleVariant;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKey Method

TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendAnsiCharCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendAnsiCharCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendAnsiCharCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendAnsiCharCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendBooleanCompareKey Method

TnxCompositeKeyFieldEngine.DescendBooleanCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendBooleanCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendByteArrayCompareKey Method

TnxCompositeKeyFieldEngine.DescendByteArrayCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendByteArrayCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendByteArrayPartialCompareKey Method

TnxCompositeKeyFieldEngine.DescendByteArrayPartialCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendByteArrayPartialCompareKey(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendByteCompareKey Method

TnxCompositeKeyFieldEngine.DescendByteCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendByteCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendCurrencyCompareKey Method

TnxCompositeKeyFieldEngine.DescendCurrencyCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendCurrencyCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendDoubleCompareKey Method

TnxCompositeKeyFieldEngine.DescendDoubleCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendDoubleCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendExtendedCompareKey Method

TnxCompositeKeyFieldEngine.DescendExtendedCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendExtendedCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendFmtBcdCompareKey Method

TnxCompositeKeyFieldEngine.DescendFmtBcdCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendFmtBcdCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendGuidCompareKey Method

TnxCompositeKeyFieldEngine.DescendGuidCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendGuidCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendInt16CompareKey Method

TnxCompositeKeyFieldEngine.DescendInt16CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendInt16CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendInt32CompareKey Method

TnxCompositeKeyFieldEngine.DescendInt32CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendInt32CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendInt64CompareKey Method

TnxCompositeKeyFieldEngine.DescendInt64CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendInt64CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendInt8CompareKey Method

TnxCompositeKeyFieldEngine.DescendInt8CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendInt8CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullAnsiStrCompareKey Method

TnxCompositeKeyFieldEngine.DescendNullAnsiStrCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullAnsiStrCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullAnsiStrPartialCompareKeyMBCS Method

TnxCompositeKeyFieldEngine.DescendNullAnsiStrPartialCompareKeyMBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullAnsiStrPartialCompareKeyMBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullAnsiStrPartialCompareKeySBCS Method

TnxCompositeKeyFieldEngine.DescendNullAnsiStrPartialCompareKeySBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullAnsiStrPartialCompareKeySBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendNullStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendNullStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendNullStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendNullStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendNullStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendNullStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortAnsiStrCompareKey Method

TnxCompositeKeyFieldEngine.DescendShortAnsiStrCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortAnsiStrCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortAnsiStrPartialCompareKeyMBCS Method

TnxCompositeKeyFieldEngine.DescendShortAnsiStrPartialCompareKeyMBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortAnsiStrPartialCompareKeyMBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortAnsiStrPartialCompareKeySBCS Method

TnxCompositeKeyFieldEngine.DescendShortAnsiStrPartialCompareKeySBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortAnsiStrPartialCompareKeySBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendShortStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendShortStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendShortStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendShortStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendShortStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendShortStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendSingleCompareKey Method

TnxCompositeKeyFieldEngine.DescendSingleCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendSingleCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideCharCompareKey Method

TnxCompositeKeyFieldEngine.DescendWideCharCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideCharCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideCharCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendWideCharCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideCharCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideCharCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendWideCharCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideCharCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringCompareKey Method

TnxCompositeKeyFieldEngine.DescendWideStringCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendWideStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendWideStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKey Method

TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringPartialCompareKey(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.DescendWideStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWideStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWord16CompareKey Method

TnxCompositeKeyFieldEngine.DescendWord16CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWord16CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DescendWord32CompareKey Method

TnxCompositeKeyFieldEngine.DescendWord32CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DescendWord32CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.DoubleCompareKey Method

TnxCompositeKeyFieldEngine.DoubleCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function DoubleCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ExtendedCompareKey Method

TnxCompositeKeyFieldEngine.ExtendedCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ExtendedCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.FmtBcdCompareKey Method

TnxCompositeKeyFieldEngine.FmtBcdCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function FmtBcdCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.GetFieldDecPl Method

TnxCompositeKeyFieldEngine.GetFieldDecPl Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function GetFieldDecPl: Integer;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.GetFieldName Method

TnxCompositeKeyFieldEngine.GetFieldName Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function GetFieldName: string;
Description

InxFieldDescriptor

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.GetFieldType Method

TnxCompositeKeyFieldEngine.GetFieldType Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function GetFieldType: TnxFieldType;
Description

This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.GetFieldUnits Method

TnxCompositeKeyFieldEngine.GetFieldUnits Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function GetFieldUnits: Integer;
Description

This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.GuidCompareKey Method

TnxCompositeKeyFieldEngine.GuidCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function GuidCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Int16CompareKey Method

TnxCompositeKeyFieldEngine.Int16CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Int16CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Int32CompareKey Method

TnxCompositeKeyFieldEngine.Int32CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Int32CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Int64CompareKey Method

TnxCompositeKeyFieldEngine.Int64CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Int64CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Int8CompareKey Method

TnxCompositeKeyFieldEngine.Int8CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Int8CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ldiGetUsedStorageCodePage Method

TnxCompositeKeyFieldEngine.ldiGetUsedStorageCodePage Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ldiGetUsedStorageCodePage: Word;
Description

This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ldiOuterGetUsedLocaleDescriptor Method

TnxCompositeKeyFieldEngine.ldiOuterGetUsedLocaleDescriptor Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ldiOuterGetUsedLocaleDescriptor: TnxLocaleDescriptor;
Description

This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullAnsiStrCompareKey Method

TnxCompositeKeyFieldEngine.NullAnsiStrCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullAnsiStrCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullAnsiStrPartialCompareKeyMBCS Method

TnxCompositeKeyFieldEngine.NullAnsiStrPartialCompareKeyMBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullAnsiStrPartialCompareKeyMBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullAnsiStrPartialCompareKeySBCS Method

TnxCompositeKeyFieldEngine.NullAnsiStrPartialCompareKeySBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullAnsiStrPartialCompareKeySBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStrBuildKey Method

TnxCompositeKeyFieldEngine.NullStrBuildKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure NullStrBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStrBuildKeyConvert Method

TnxCompositeKeyFieldEngine.NullStrBuildKeyConvert Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure NullStrBuildKeyConvert(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStrBuildKeyTruncate Method

TnxCompositeKeyFieldEngine.NullStrBuildKeyTruncate Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure NullStrBuildKeyTruncate(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.NullStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.NullStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.NullStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.NullStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.NullStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function NullStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.PartialCompareFieldDirectBuildKeys Method

TnxCompositeKeyFieldEngine.PartialCompareFieldDirectBuildKeys Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function PartialCompareFieldDirectBuildKeys(const aField1; const aField2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Register Method

TnxCompositeKeyFieldEngine.Register Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class procedure Register(const aName: string; aFieldTypes: TnxFieldTypes; const aParams: array of const);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.RegisteredEngines Method

TnxCompositeKeyFieldEngine.RegisteredEngines Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class function RegisteredEngines: string;
Description

searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortAnsiStrCompareKey Method

TnxCompositeKeyFieldEngine.ShortAnsiStrCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortAnsiStrCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortAnsiStrPartialCompareKeyMBCS Method

TnxCompositeKeyFieldEngine.ShortAnsiStrPartialCompareKeyMBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortAnsiStrPartialCompareKeyMBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortAnsiStrPartialCompareKeySBCS Method

TnxCompositeKeyFieldEngine.ShortAnsiStrPartialCompareKeySBCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortAnsiStrPartialCompareKeySBCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStrBuildKey Method

TnxCompositeKeyFieldEngine.ShortStrBuildKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure ShortStrBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStrBuildKeyConvert Method

TnxCompositeKeyFieldEngine.ShortStrBuildKeyConvert Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure ShortStrBuildKeyConvert(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStrBuildKeyTruncate Method

TnxCompositeKeyFieldEngine.ShortStrBuildKeyTruncate Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure ShortStrBuildKeyTruncate(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.ShortStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.ShortStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.ShortStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.ShortStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.ShortStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function ShortStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.SingleCompareKey Method

TnxCompositeKeyFieldEngine.SingleCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function SingleCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.SupportsFieldType Method

TnxCompositeKeyFieldEngine.SupportsFieldType Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class function SupportsFieldType(const aFieldType: TnxFieldType): Boolean; virtual;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Unregister Method

TnxCompositeKeyFieldEngine.Unregister Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
class procedure Unregister;
Description

registeres this class in the internal list of KeyFieldEngines

Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideCharCompareKey Method

TnxCompositeKeyFieldEngine.WideCharCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideCharCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideCharCompareKeyCS Method

TnxCompositeKeyFieldEngine.WideCharCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideCharCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideCharCompareKeyIC Method

TnxCompositeKeyFieldEngine.WideCharCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideCharCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringBuildKey Method

TnxCompositeKeyFieldEngine.WideStringBuildKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
procedure WideStringBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringCompareKey Method

TnxCompositeKeyFieldEngine.WideStringCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringCompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringCompareKeyCS Method

TnxCompositeKeyFieldEngine.WideStringCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringCompareKeyCS(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringCompareKeyIC Method

TnxCompositeKeyFieldEngine.WideStringCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringCompareKeyIC(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringPartialCompareKey Method

TnxCompositeKeyFieldEngine.WideStringPartialCompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringPartialCompareKey(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringPartialCompareKeyCS Method

TnxCompositeKeyFieldEngine.WideStringPartialCompareKeyCS Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringPartialCompareKeyCS(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.WideStringPartialCompareKeyIC Method

TnxCompositeKeyFieldEngine.WideStringPartialCompareKeyIC Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function WideStringPartialCompareKeyIC(const aKey1; const aKey2; aPartialLen: Integer): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Word16CompareKey Method

TnxCompositeKeyFieldEngine.Word16CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Word16CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine.Word32CompareKey Method

TnxCompositeKeyFieldEngine.Word32CompareKey Method
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Methods Send Feedback
Syntax
Delphi
function Word32CompareKey(const aKey1; const aKey2): TnxValueRelationship;
Group

TnxCompositeKeyFieldEngine Methods

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Methods


TnxCompositeKeyFieldEngine Properties

TnxCompositeKeyFieldEngine Properties
TnxCompositeKeyFieldEngine Class Legend Public Properties Send Feedback

The properties of the TnxCompositeKeyFieldEngine class are listed here.

Class

TnxCompositeKeyFieldEngine Class

Public Properties
Name | Description
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxCompositeKeyFieldEngine Class, Legend, Public Properties


TnxCompositeKeyFieldEngine.FieldNumber Property

TnxCompositeKeyFieldEngine.FieldNumber Property
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Properties Send Feedback
Syntax
Delphi
property FieldNumber: Integer;
Description

This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Properties

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Properties


TnxCompositeKeyFieldEngine.FieldOffset Property

TnxCompositeKeyFieldEngine.FieldOffset Property
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Properties Send Feedback
Syntax
Delphi
property FieldOffset: Integer;
Description

This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Properties

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Properties


TnxCompositeKeyFieldEngine.FieldType Property

TnxCompositeKeyFieldEngine.FieldType Property
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Properties Send Feedback
Syntax
Delphi
property FieldType: TnxFieldType;
Description

returns true if engine supports field type, without raising exceptions or asserts

Group

TnxCompositeKeyFieldEngine Properties

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Properties


TnxCompositeKeyFieldEngine.KeyLength Property

TnxCompositeKeyFieldEngine.KeyLength Property
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Properties Send Feedback
Syntax
Delphi
property KeyLength: Integer;
Description

This is KeyLength, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Properties

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Properties


TnxCompositeKeyFieldEngine.NLSVersionChanged Property

TnxCompositeKeyFieldEngine.NLSVersionChanged Property
TnxCompositeKeyFieldEngine Class TnxCompositeKeyFieldEngine Members nxsdKeyFieldEngineBase Namespace TnxCompositeKeyFieldEngine Properties Send Feedback
Syntax
Delphi
property NLSVersionChanged: Boolean;
Description

This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.

Group

TnxCompositeKeyFieldEngine Properties

Links
TnxCompositeKeyFieldEngine Class, TnxCompositeKeyFieldEngine Members, nxsdKeyFieldEngineBase Namespace, TnxCompositeKeyFieldEngine Properties


TnxDateOnlyCKFE Class

TnxDateOnlyCKFE Class
TnxDateOnlyCKFE Methods TnxDateOnlyCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxDateOnlyCKFEnxsdKeyFieldEngineBase_TnxDateOnlyCKFEnxsdKeyFieldEngineBase_TnxDateOnlyCKFEnxsdKeyFieldEngineBase_TnxDateOnlyCKFEnxsdKeyFieldEngineBase_TnxDateOnlyCKFE
Syntax
Delphi
TnxDateOnlyCKFE = class(TnxCompositeKeyFieldEngine);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxDateOnlyCKFE.

Group

Classes

Links
TnxDateOnlyCKFE Methods, TnxDateOnlyCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxDateOnlyCKFE Members

TnxDateOnlyCKFE Members
TnxDateOnlyCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDateOnlyCKFE.

Class

TnxDateOnlyCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
CurrencyCompareKey |
DateTimeBuildKey | private
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxDateOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxDateOnlyCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDateOnlyCKFE.Create Constructor

TnxDateOnlyCKFE.Create Constructor
TnxDateOnlyCKFE Class TnxDateOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyCKFE Class Send Feedback
Syntax
Delphi
constructor Create(aKeyFieldDescriptor: TnxKeyFieldDescriptor); override;
Description

TnxDateOnlyCKFE

Class

TnxDateOnlyCKFE Class

Links
TnxDateOnlyCKFE Class, TnxDateOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyCKFE Class


TnxDateOnlyCKFE Methods

TnxDateOnlyCKFE Methods
TnxDateOnlyCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxDateOnlyCKFE class are listed here.

Class

TnxDateOnlyCKFE Class

Protected Methods
Name | Description
DateTimeBuildKey | private
SupportsFieldType |
Links
TnxDateOnlyCKFE Class, Legend, Protected Methods


TnxDateOnlyCKFE.DateTimeBuildKey Method

TnxDateOnlyCKFE.DateTimeBuildKey Method
TnxDateOnlyCKFE Class TnxDateOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyCKFE Methods Send Feedback
Syntax
Delphi
procedure DateTimeBuildKey(const aFieldBuffer; var aKeyBuffer);
Description

private

Group

TnxDateOnlyCKFE Methods

Links
TnxDateOnlyCKFE Class, TnxDateOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyCKFE Methods


TnxDateOnlyCKFE.SupportsFieldType Method

TnxDateOnlyCKFE.SupportsFieldType Method
TnxDateOnlyCKFE Class TnxDateOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyCKFE Methods Send Feedback
Syntax
Delphi
class function SupportsFieldType(const aFieldType: TnxFieldType): Boolean; override;
Group

TnxDateOnlyCKFE Methods

Links
TnxDateOnlyCKFE Class, TnxDateOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyCKFE Methods


TnxDateOnlyMonthCKFE Class

TnxDateOnlyMonthCKFE Class
TnxDateOnlyMonthCKFE Methods TnxDateOnlyMonthCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFEnxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFEnxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFEnxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFEnxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFEnxsdKeyFieldEngineBase_TnxDateOnlyMonthCKFE
Syntax
Delphi
TnxDateOnlyMonthCKFE = class(TnxDateOnlyProcessCKFE);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxDateOnlyMonthCKFE.

Group

Classes

Links
TnxDateOnlyMonthCKFE Methods, TnxDateOnlyMonthCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxDateOnlyMonthCKFE Members

TnxDateOnlyMonthCKFE Members
TnxDateOnlyMonthCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDateOnlyMonthCKFE.

Class

TnxDateOnlyMonthCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
Create |
CurrencyCompareKey |
DateTimeBuildKey | private
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
Process | private TnxDateOnlyMonthCKFE
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxDateOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxDateOnlyMonthCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDateOnlyMonthCKFE Methods

TnxDateOnlyMonthCKFE Methods
TnxDateOnlyMonthCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxDateOnlyMonthCKFE class are listed here.

Class

TnxDateOnlyMonthCKFE Class

Protected Methods
Name | Description
Process | private TnxDateOnlyMonthCKFE
Links
TnxDateOnlyMonthCKFE Class, Legend, Protected Methods


TnxDateOnlyMonthCKFE.Process Method

TnxDateOnlyMonthCKFE.Process Method
TnxDateOnlyMonthCKFE Class TnxDateOnlyMonthCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyMonthCKFE Methods Send Feedback
Syntax
Delphi
function Process(aTimeStamp: TTimeStamp): TTimeStamp; override;
Description

private

TnxDateOnlyMonthCKFE

Group

TnxDateOnlyMonthCKFE Methods

Links
TnxDateOnlyMonthCKFE Class, TnxDateOnlyMonthCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyMonthCKFE Methods


TnxDateOnlyProcessCKFE Class

TnxDateOnlyProcessCKFE Class
TnxDateOnlyProcessCKFE Methods TnxDateOnlyProcessCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxDateOnlyProcessCKFEnxsdKeyFieldEngineBase_TnxDateOnlyProcessCKFEnxsdKeyFieldEngineBase_TnxDateOnlyProcessCKFEnxsdKeyFieldEngineBase_TnxDateOnlyProcessCKFEnxsdKeyFieldEngineBase_TnxDateOnlyProcessCKFE
Syntax
Delphi
TnxDateOnlyProcessCKFE = class(TnxCompositeKeyFieldEngine);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxDateOnlyProcessCKFE.

Group

Classes

Links
TnxDateOnlyProcessCKFE Methods, TnxDateOnlyProcessCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxDateOnlyProcessCKFE Members

TnxDateOnlyProcessCKFE Members
TnxDateOnlyProcessCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDateOnlyProcessCKFE.

Class

TnxDateOnlyProcessCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
CurrencyCompareKey |
DateTimeBuildKey | private
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
Process | This is Process, a member of class TnxDateOnlyProcessCKFE.
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxDateOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxDateOnlyProcessCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDateOnlyProcessCKFE.Create Constructor

TnxDateOnlyProcessCKFE.Create Constructor
TnxDateOnlyProcessCKFE Class TnxDateOnlyProcessCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyProcessCKFE Class Send Feedback
Syntax
Delphi
constructor Create(aKeyFieldDescriptor: TnxKeyFieldDescriptor); override;
Description

TnxDateOnlyCKFE

Class

TnxDateOnlyProcessCKFE Class

Links
TnxDateOnlyProcessCKFE Class, TnxDateOnlyProcessCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyProcessCKFE Class


TnxDateOnlyProcessCKFE Methods

TnxDateOnlyProcessCKFE Methods
TnxDateOnlyProcessCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxDateOnlyProcessCKFE class are listed here.

Class

TnxDateOnlyProcessCKFE Class

Protected Methods
Name | Description
DateTimeBuildKey | private
Process | This is Process, a member of class TnxDateOnlyProcessCKFE.
Links
TnxDateOnlyProcessCKFE Class, Legend, Protected Methods


TnxDateOnlyProcessCKFE.DateTimeBuildKey Method

TnxDateOnlyProcessCKFE.DateTimeBuildKey Method
TnxDateOnlyProcessCKFE Class TnxDateOnlyProcessCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyProcessCKFE Methods Send Feedback
Syntax
Delphi
procedure DateTimeBuildKey(const aFieldBuffer; var aKeyBuffer);
Description

private

Group

TnxDateOnlyProcessCKFE Methods

Links
TnxDateOnlyProcessCKFE Class, TnxDateOnlyProcessCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyProcessCKFE Methods


TnxDateOnlyProcessCKFE.Process Method

TnxDateOnlyProcessCKFE.Process Method
TnxDateOnlyProcessCKFE Class TnxDateOnlyProcessCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyProcessCKFE Methods Send Feedback
Syntax
Delphi
function Process(aTimeStamp: TTimeStamp): TTimeStamp; virtual;
Description

This is Process, a member of class TnxDateOnlyProcessCKFE.

Group

TnxDateOnlyProcessCKFE Methods

Links
TnxDateOnlyProcessCKFE Class, TnxDateOnlyProcessCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyProcessCKFE Methods


TnxDateOnlyWeekCKFE Class

TnxDateOnlyWeekCKFE Class
TnxDateOnlyWeekCKFE Methods TnxDateOnlyWeekCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFEnxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFEnxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFEnxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFEnxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFEnxsdKeyFieldEngineBase_TnxDateOnlyWeekCKFE
Syntax
Delphi
TnxDateOnlyWeekCKFE = class(TnxDateOnlyProcessCKFE);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxDateOnlyWeekCKFE.

Group

Classes

Links
TnxDateOnlyWeekCKFE Methods, TnxDateOnlyWeekCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxDateOnlyWeekCKFE Members

TnxDateOnlyWeekCKFE Members
TnxDateOnlyWeekCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDateOnlyWeekCKFE.

Class

TnxDateOnlyWeekCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
Create |
CurrencyCompareKey |
DateTimeBuildKey | private
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
Process | private TnxDateOnlyWeekCKFE
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxDateOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxDateOnlyWeekCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDateOnlyWeekCKFE Methods

TnxDateOnlyWeekCKFE Methods
TnxDateOnlyWeekCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxDateOnlyWeekCKFE class are listed here.

Class

TnxDateOnlyWeekCKFE Class

Protected Methods
Name | Description
Process | private TnxDateOnlyWeekCKFE
Links
TnxDateOnlyWeekCKFE Class, Legend, Protected Methods


TnxDateOnlyWeekCKFE.Process Method

TnxDateOnlyWeekCKFE.Process Method
TnxDateOnlyWeekCKFE Class TnxDateOnlyWeekCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyWeekCKFE Methods Send Feedback
Syntax
Delphi
function Process(aTimeStamp: TTimeStamp): TTimeStamp; override;
Description

private

TnxDateOnlyWeekCKFE

Group

TnxDateOnlyWeekCKFE Methods

Links
TnxDateOnlyWeekCKFE Class, TnxDateOnlyWeekCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyWeekCKFE Methods


TnxDateOnlyYearCKFE Class

TnxDateOnlyYearCKFE Class
TnxDateOnlyYearCKFE Methods TnxDateOnlyYearCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxDateOnlyYearCKFEnxsdKeyFieldEngineBase_TnxDateOnlyYearCKFEnxsdKeyFieldEngineBase_TnxDateOnlyYearCKFEnxsdKeyFieldEngineBase_TnxDateOnlyYearCKFEnxsdKeyFieldEngineBase_TnxDateOnlyYearCKFEnxsdKeyFieldEngineBase_TnxDateOnlyYearCKFE
Syntax
Delphi
TnxDateOnlyYearCKFE = class(TnxDateOnlyProcessCKFE);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxDateOnlyYearCKFE.

Group

Classes

Links
TnxDateOnlyYearCKFE Methods, TnxDateOnlyYearCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxDateOnlyYearCKFE Members

TnxDateOnlyYearCKFE Members
TnxDateOnlyYearCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxDateOnlyYearCKFE.

Class

TnxDateOnlyYearCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
Create |
CurrencyCompareKey |
DateTimeBuildKey | private
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
Process | private TnxDateOnlyYearCKFE
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey |
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxDateOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxDateOnlyYearCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxDateOnlyYearCKFE Methods

TnxDateOnlyYearCKFE Methods
TnxDateOnlyYearCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxDateOnlyYearCKFE class are listed here.

Class

TnxDateOnlyYearCKFE Class

Protected Methods
Name | Description
Process | private TnxDateOnlyYearCKFE
Links
TnxDateOnlyYearCKFE Class, Legend, Protected Methods


TnxDateOnlyYearCKFE.Process Method

TnxDateOnlyYearCKFE.Process Method
TnxDateOnlyYearCKFE Class TnxDateOnlyYearCKFE Members nxsdKeyFieldEngineBase Namespace TnxDateOnlyYearCKFE Methods Send Feedback
Syntax
Delphi
function Process(aTimeStamp: TTimeStamp): TTimeStamp; override;
Description

private

TnxDateOnlyYearCKFE

Group

TnxDateOnlyYearCKFE Methods

Links
TnxDateOnlyYearCKFE Class, TnxDateOnlyYearCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxDateOnlyYearCKFE Methods


TnxNumbersOnlyCKFE Class

TnxNumbersOnlyCKFE Class
TnxNumbersOnlyCKFE Methods TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Classes Send Feedback
Class Hierarchy
nxsdKeyFieldEngineBase_TnxNumbersOnlyCKFEnxsdKeyFieldEngineBase_TnxNumbersOnlyCKFEnxsdKeyFieldEngineBase_TnxNumbersOnlyCKFEnxsdKeyFieldEngineBase_TnxNumbersOnlyCKFEnxsdKeyFieldEngineBase_TnxNumbersOnlyCKFE
Syntax
Delphi
TnxNumbersOnlyCKFE = class(TnxCompositeKeyFieldEngine);
File

nxsdKeyFieldEngineBase

Description

This is class nxsdKeyFieldEngineBase.TnxNumbersOnlyCKFE.

Group

Classes

Links
TnxNumbersOnlyCKFE Methods, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase, Classes


TnxNumbersOnlyCKFE Members

TnxNumbersOnlyCKFE Members
TnxNumbersOnlyCKFE Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNumbersOnlyCKFE.

Class

TnxNumbersOnlyCKFE Class

Protected Fields
Name | Description
ckfeBuildKeyLength | This is ckfeBuildKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareCodepage | This is ckfeCompareCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeCompareFlags | This is ckfeCompareFlags, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldDecPl | This is ckfeFieldDecPl, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldLength | This is ckfeFieldLength, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldName | private
ckfeFieldNumber | This is ckfeFieldNumber, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldOffset | This is ckfeFieldOffset, a member of class TnxCompositeKeyFieldEngine.
ckfeFieldType | This is ckfeFieldType, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyChars | This is ckfeKeyChars, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyLength | This is ckfeKeyLength, a member of class TnxCompositeKeyFieldEngine.
ckfeKeyUnits | This is ckfeKeyUnits, a member of class TnxCompositeKeyFieldEngine.
ckfeLocale | This is ckfeLocale, a member of class TnxCompositeKeyFieldEngine.
ckfeLocaleDescriptor | This is ckfeLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
ckfeNLSVersionChanged | This is ckfeNLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
ckfeStorageCodepage | This is ckfeStorageCodepage, a member of class TnxCompositeKeyFieldEngine.
ckfeUseByteOrder | This is ckfeUseByteOrder, a member of class TnxCompositeKeyFieldEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
AnsiCharCompareKey |
AnsiCharCompareKeyCS |
AnsiCharCompareKeyIC |
BooleanCompareKey |
ByteArrayCompareKey |
ByteArrayPartialCompareKey |
ByteCompareKey |
CheckValid |
CompareFieldDirectBuildKeys |
CurrencyCompareKey |
DefaultBuildKey |
DefaultKeyAsVariant |
DescendAnsiCharCompareKey |
DescendAnsiCharCompareKeyCS |
DescendAnsiCharCompareKeyIC |
DescendBooleanCompareKey |
DescendByteArrayCompareKey |
DescendByteArrayPartialCompareKey |
DescendByteCompareKey |
DescendCurrencyCompareKey |
DescendDoubleCompareKey |
DescendExtendedCompareKey |
DescendFmtBcdCompareKey |
DescendGuidCompareKey |
DescendInt16CompareKey |
DescendInt32CompareKey |
DescendInt64CompareKey |
DescendInt8CompareKey |
DescendNullAnsiStrCompareKey |
DescendNullAnsiStrPartialCompareKeyMBCS |
DescendNullAnsiStrPartialCompareKeySBCS |
DescendNullStringCompareKeyCS |
DescendNullStringCompareKeyIC |
DescendNullStringPartialCompareKeyCS |
DescendNullStringPartialCompareKeyIC |
DescendShortAnsiStrCompareKey |
DescendShortAnsiStrPartialCompareKeyMBCS |
DescendShortAnsiStrPartialCompareKeySBCS |
DescendShortStringCompareKeyCS |
DescendShortStringCompareKeyIC |
DescendShortStringPartialCompareKeyCS |
DescendShortStringPartialCompareKeyIC |
DescendSingleCompareKey |
DescendWideCharCompareKey |
DescendWideCharCompareKeyCS |
DescendWideCharCompareKeyIC |
DescendWideStringCompareKey |
DescendWideStringCompareKeyCS |
DescendWideStringCompareKeyIC |
DescendWideStringPartialCompareKey |
DescendWideStringPartialCompareKeyCS |
DescendWideStringPartialCompareKeyIC |
DescendWord16CompareKey |
DescendWord32CompareKey |
DoubleCompareKey |
ExtendedCompareKey |
FmtBcdCompareKey |
GetExceptionData | InxExceptionData TnxPersistent
GetFieldDecPl |
GetFieldName | InxFieldDescriptor
GetFieldType | This is GetFieldType, a member of class TnxCompositeKeyFieldEngine.
GetFieldUnits | This is GetFieldUnits, a member of class TnxCompositeKeyFieldEngine.
GuidCompareKey |
Int16CompareKey |
Int32CompareKey |
Int64CompareKey |
Int8CompareKey |
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class TnxCompositeKeyFieldEngine.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class TnxCompositeKeyFieldEngine.
NullAnsiStrCompareKey |
NullAnsiStrPartialCompareKeyMBCS |
NullAnsiStrPartialCompareKeySBCS |
NullStrBuildKey |
NullStrBuildKeyConvert |
NullStrBuildKeyTruncate |
NullStringCompareKeyCS |
NullStringCompareKeyIC |
NullStringPartialCompareKeyCS |
NullStringPartialCompareKeyIC |
PartialCompareFieldDirectBuildKeys |
QueryInterface | InxInterface
ShortAnsiStrCompareKey |
ShortAnsiStrPartialCompareKeyMBCS |
ShortAnsiStrPartialCompareKeySBCS |
ShortStrBuildKey | private
ShortStrBuildKeyConvert |
ShortStrBuildKeyTruncate |
ShortStringCompareKeyCS |
ShortStringCompareKeyIC |
ShortStringPartialCompareKeyCS |
ShortStringPartialCompareKeyIC |
SingleCompareKey |
SupportsFieldType |
WideCharCompareKey |
WideCharCompareKeyCS |
WideCharCompareKeyIC |
WideStringBuildKey |
WideStringCompareKey |
WideStringCompareKeyCS |
WideStringCompareKeyIC |
WideStringPartialCompareKey |
WideStringPartialCompareKeyCS |
WideStringPartialCompareKeyIC |
Word16CompareKey |
Word32CompareKey |
Public Fields
Name | Description
BuildKey | compares the keys for a specific field up to a particular length
CompareFieldDirect | compares the keys for a specific field
CompareKey | This is CompareKey, a member of class TnxCompositeKeyFieldEngine.
FilterNonNull | This is FilterNonNull, a member of class TnxCompositeKeyFieldEngine.
FilterNull | This is FilterNull, a member of class TnxCompositeKeyFieldEngine.
InvertNull | This is InvertNull, a member of class TnxCompositeKeyFieldEngine.
KeyAsVariant | This is KeyAsVariant, a member of class TnxCompositeKeyFieldEngine.
KeySameAsRecordFormat | builds the key for a specific field
PartialCompareFieldDirect | compares the keys for a specific field up to a particular length
PartialCompareKey | compares the field buffers directly
Public Methods
Name | Description
CheckSupportsFieldType | returns comma separated list of engine names
CheckValidBase | returns the key buffer as a variant
Create | TnxNumbersOnlyCKFE
CreateEngine | removes this class from the internal list
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFieldDecPl | This is GetFieldDecPl, a member of class InxFieldDescriptor.
GetFieldName | This is GetFieldName, a member of class InxFieldDescriptor.
GetFieldType | This is GetFieldType, a member of class InxFieldDescriptor.
GetFieldUnits | This is GetFieldUnits, a member of class InxFieldDescriptor.
ldiGetUsedStorageCodePage | This is ldiGetUsedStorageCodePage, a member of class InxFieldDescriptor.
ldiOuterGetUsedLocaleDescriptor | This is ldiOuterGetUsedLocaleDescriptor, a member of class InxFieldDescriptor.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Register |
RegisteredEngines | searches the internal list for a engine with the specified name and checks if the fieldtype is supported by that engine and returns an instance of that engine
Unregister | registeres this class in the internal list of KeyFieldEngines
Public Properties
Name | Description
FieldDecPl | This is FieldDecPl, a member of class InxFieldDescriptor.
FieldName | This is FieldName, a member of class InxFieldDescriptor.
FieldNumber | This is FieldNumber, a member of class TnxCompositeKeyFieldEngine.
FieldOffset | This is FieldOffset, a member of class TnxCompositeKeyFieldEngine.
FieldType | This is FieldType, a member of class InxFieldDescriptor.
FieldType | returns true if engine supports field type, without raising exceptions or asserts
FieldUnits | This is FieldUnits, a member of class InxFieldDescriptor.
FieldUsedLocaleDescriptor | This is FieldUsedLocaleDescriptor, a member of class InxFieldDescriptor.
FieldUsedStorageCodePage | This is FieldUsedStorageCodePage, a member of class InxFieldDescriptor.
KeyLength | This is KeyLength, a member of class TnxCompositeKeyFieldEngine.
NLSVersionChanged | This is NLSVersionChanged, a member of class TnxCompositeKeyFieldEngine.
Links
TnxNumbersOnlyCKFE Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxNumbersOnlyCKFE.Create Constructor

TnxNumbersOnlyCKFE.Create Constructor
TnxNumbersOnlyCKFE Class TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxNumbersOnlyCKFE Class Send Feedback
Syntax
Delphi
constructor Create(aKeyFieldDescriptor: TnxKeyFieldDescriptor); override;
Description

TnxNumbersOnlyCKFE

Class

TnxNumbersOnlyCKFE Class

Links
TnxNumbersOnlyCKFE Class, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxNumbersOnlyCKFE Class


TnxNumbersOnlyCKFE Methods

TnxNumbersOnlyCKFE Methods
TnxNumbersOnlyCKFE Class Legend Protected Methods Send Feedback

The methods of the TnxNumbersOnlyCKFE class are listed here.

Class

TnxNumbersOnlyCKFE Class

Protected Methods
Name | Description
NullStrBuildKey |
ShortStrBuildKey | private
SupportsFieldType |
WideStringBuildKey |
Links
TnxNumbersOnlyCKFE Class, Legend, Protected Methods


TnxNumbersOnlyCKFE.NullStrBuildKey Method

TnxNumbersOnlyCKFE.NullStrBuildKey Method
TnxNumbersOnlyCKFE Class TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxNumbersOnlyCKFE Methods Send Feedback
Syntax
Delphi
procedure NullStrBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxNumbersOnlyCKFE Methods

Links
TnxNumbersOnlyCKFE Class, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxNumbersOnlyCKFE Methods


TnxNumbersOnlyCKFE.ShortStrBuildKey Method

TnxNumbersOnlyCKFE.ShortStrBuildKey Method
TnxNumbersOnlyCKFE Class TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxNumbersOnlyCKFE Methods Send Feedback
Syntax
Delphi
procedure ShortStrBuildKey(const aFieldBuffer; var aKeyBuffer);
Description

private

Group

TnxNumbersOnlyCKFE Methods

Links
TnxNumbersOnlyCKFE Class, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxNumbersOnlyCKFE Methods


TnxNumbersOnlyCKFE.SupportsFieldType Method

TnxNumbersOnlyCKFE.SupportsFieldType Method
TnxNumbersOnlyCKFE Class TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxNumbersOnlyCKFE Methods Send Feedback
Syntax
Delphi
class function SupportsFieldType(const aFieldType: TnxFieldType): Boolean; override;
Group

TnxNumbersOnlyCKFE Methods

Links
TnxNumbersOnlyCKFE Class, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxNumbersOnlyCKFE Methods


TnxNumbersOnlyCKFE.WideStringBuildKey Method

TnxNumbersOnlyCKFE.WideStringBuildKey Method
TnxNumbersOnlyCKFE Class TnxNumbersOnlyCKFE Members nxsdKeyFieldEngineBase Namespace TnxNumbersOnlyCKFE Methods Send Feedback
Syntax
Delphi
procedure WideStringBuildKey(const aFieldBuffer; var aKeyBuffer);
Group

TnxNumbersOnlyCKFE Methods

Links
TnxNumbersOnlyCKFE Class, TnxNumbersOnlyCKFE Members, nxsdKeyFieldEngineBase Namespace, TnxNumbersOnlyCKFE Methods


Types

Types
nxsdKeyFieldEngineBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdKeyFieldEngineBase Namespace

Types
Name | Description
TnxCompositeKeyFieldEngineClass | This is type nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngineClass.
Links
nxsdKeyFieldEngineBase Namespace, Types


nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngineClass Type

nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngineClass Type
nxsdKeyFieldEngineBase Types Send Feedback
Syntax
Delphi
TnxCompositeKeyFieldEngineClass = class of TnxCompositeKeyFieldEngine;
File

nxsdKeyFieldEngineBase

Description

This is type nxsdKeyFieldEngineBase.TnxCompositeKeyFieldEngineClass.

Group

Types

Links
nxsdKeyFieldEngineBase, Types


Variables

Variables
nxsdKeyFieldEngineBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdKeyFieldEngineBase Namespace

Variables
Name | Description
_HelperList | TnxCompositeKeyFieldEngine
_HelperListPadlock | This is variable nxsdKeyFieldEngineBase._HelperListPadlock.
Links
nxsdKeyFieldEngineBase Namespace, Variables


nxsdKeyFieldEngineBase._HelperList Variable

nxsdKeyFieldEngineBase._HelperList Variable
nxsdKeyFieldEngineBase Variables Send Feedback
Syntax
Delphi
_HelperList: TStringList;
File

nxsdKeyFieldEngineBase

Description

TnxCompositeKeyFieldEngine

Group

Variables

Links
nxsdKeyFieldEngineBase, Variables


nxsdKeyFieldEngineBase._HelperListPadlock Variable

nxsdKeyFieldEngineBase._HelperListPadlock Variable
nxsdKeyFieldEngineBase Variables Send Feedback
Syntax
Delphi
_HelperListPadlock: TnxPadlock;
File

nxsdKeyFieldEngineBase

Description

This is variable nxsdKeyFieldEngineBase._HelperListPadlock.

Group

Variables

Links
nxsdKeyFieldEngineBase, Variables


Constants

Constants
Constants nxsdKeyFieldEngineBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_CKFE_DateOnly | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnly.
nxc_CKFE_DateOnlyMonth | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyMonth.
nxc_CKFE_DateOnlyWeek | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyWeek.
nxc_CKFE_DateOnlyYear | This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyYear.
nxc_CKFE_NumbersOnly | Pre-defined helper names
rsCKFENotReg | This is constant nxsdKeyFieldEngineBase.rsCKFENotReg.
rsFieldTypeNotSupported | This is constant nxsdKeyFieldEngineBase.rsFieldTypeNotSupported.
Namespace

nxsdKeyFieldEngineBase Namespace

Links
Constants, nxsdKeyFieldEngineBase Namespace


nxsdKeyFieldEngineBase.nxc_CKFE_DateOnly Constant

nxsdKeyFieldEngineBase.nxc_CKFE_DateOnly Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
nxc_CKFE_DateOnly = 'DateOnly';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnly.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyMonth Constant

nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyMonth Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
nxc_CKFE_DateOnlyMonth = 'DateOnlyMonth';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyMonth.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyWeek Constant

nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyWeek Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
nxc_CKFE_DateOnlyWeek = 'DateOnlyWeek';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyWeek.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyYear Constant

nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyYear Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
nxc_CKFE_DateOnlyYear = 'DateOnlyYear';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.nxc_CKFE_DateOnlyYear.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.nxc_CKFE_NumbersOnly Constant

nxsdKeyFieldEngineBase.nxc_CKFE_NumbersOnly Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
nxc_CKFE_NumbersOnly = 'NumbersOnly';
File

nxsdKeyFieldEngineBase

Description

Pre-defined helper names

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.rsCKFENotReg Constant

nxsdKeyFieldEngineBase.rsCKFENotReg Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
rsCKFENotReg = 'CompositeKeyFieldEngine "%s" is not registered';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.rsCKFENotReg.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdKeyFieldEngineBase.rsFieldTypeNotSupported Constant

nxsdKeyFieldEngineBase.rsFieldTypeNotSupported Constant
nxsdKeyFieldEngineBase Constants Send Feedback
Syntax
Delphi
rsFieldTypeNotSupported = 'FieldType "%s" not supported by TnxCompositeKeyField' + 'Engine';
File

nxsdKeyFieldEngineBase

Description

This is constant nxsdKeyFieldEngineBase.rsFieldTypeNotSupported.

Group

Constants

Links
nxsdKeyFieldEngineBase, Constants


nxsdNativeVariantConverter Namespace

nxsdNativeVariantConverter Namespace
Constants Functions Legend Topics Send Feedback

This is namespace nxsdNativeVariantConverter.

Constants
Name | Description
oleaut | This is constant nxsdNativeVariantConverter.oleaut.
rs0ZeroIsNotAValidTimestamp | This is constant nxsdNativeVariantConverter.rs0ZeroIsNotAValidTimestamp.
rsBadCharFormat | This is constant nxsdNativeVariantConverter.rsBadCharFormat.
Functions
Name | Description
CheckByteRange | This is function nxsdNativeVariantConverter.CheckByteRange.
CheckDWordRange | This is function nxsdNativeVariantConverter.CheckDWordRange.
CheckIntegerRange | This is function nxsdNativeVariantConverter.CheckIntegerRange.
CheckShortintRange | This is function nxsdNativeVariantConverter.CheckShortintRange.
CheckSmallintRange | This is function nxsdNativeVariantConverter.CheckSmallintRange.
CheckWordRange | This is function nxsdNativeVariantConverter.CheckWordRange.
ConvertBLOBToString | This is function nxsdNativeVariantConverter.ConvertBLOBToString.
nxVarIsEmpty | This is function nxsdNativeVariantConverter.nxVarIsEmpty.
nxVarIsTrue | This is function nxsdNativeVariantConverter.nxVarIsTrue.
VariantFromNative | This is function nxsdNativeVariantConverter.VariantFromNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
Topics
Name | Description
Functions | The following table lists functions in this documentation.
Constants | The following table lists constants in this documentation.
Links
Constants, Functions, Legend, Topics


Functions

Functions
Functions nxsdNativeVariantConverter Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
CheckByteRange | This is function nxsdNativeVariantConverter.CheckByteRange.
CheckDWordRange | This is function nxsdNativeVariantConverter.CheckDWordRange.
CheckIntegerRange | This is function nxsdNativeVariantConverter.CheckIntegerRange.
CheckShortintRange | This is function nxsdNativeVariantConverter.CheckShortintRange.
CheckSmallintRange | This is function nxsdNativeVariantConverter.CheckSmallintRange.
CheckWordRange | This is function nxsdNativeVariantConverter.CheckWordRange.
ConvertBLOBToString | This is function nxsdNativeVariantConverter.ConvertBLOBToString.
nxVarIsEmpty | This is function nxsdNativeVariantConverter.nxVarIsEmpty.
nxVarIsTrue | This is function nxsdNativeVariantConverter.nxVarIsTrue.
VariantFromNative | This is function nxsdNativeVariantConverter.VariantFromNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
VariantToNative | This is function nxsdNativeVariantConverter.VariantToNative.
Namespace

nxsdNativeVariantConverter Namespace

Links
Functions, nxsdNativeVariantConverter Namespace, Legend


nxsdNativeVariantConverter.CheckByteRange Function

nxsdNativeVariantConverter.CheckByteRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckByteRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckByteRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.CheckDWordRange Function

nxsdNativeVariantConverter.CheckDWordRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckDWordRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckDWordRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.CheckIntegerRange Function

nxsdNativeVariantConverter.CheckIntegerRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckIntegerRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckIntegerRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.CheckShortintRange Function

nxsdNativeVariantConverter.CheckShortintRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckShortintRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckShortintRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.CheckSmallintRange Function

nxsdNativeVariantConverter.CheckSmallintRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckSmallintRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckSmallintRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.CheckWordRange Function

nxsdNativeVariantConverter.CheckWordRange Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function CheckWordRange(const l: int64; const RaiseException: Boolean = true): boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.CheckWordRange.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.ConvertBLOBToString Function

nxsdNativeVariantConverter.ConvertBLOBToString Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function ConvertBLOBToString(const Value: OleVariant): string;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.ConvertBLOBToString.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.nxVarIsEmpty Function

nxsdNativeVariantConverter.nxVarIsEmpty Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function nxVarIsEmpty(const V: Variant): Boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.nxVarIsEmpty.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.nxVarIsTrue Function

nxsdNativeVariantConverter.nxVarIsTrue Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function nxVarIsTrue(const V: Variant): Boolean;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.nxVarIsTrue.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.VariantFromNative Function

nxsdNativeVariantConverter.VariantFromNative Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
function VariantFromNative(FieldType: TnxFieldType; CodePage: Word; Units: Integer; DecPl: Integer; Buffer: PnxByteArray; BufferLength: Integer): OleVariant;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.VariantFromNative.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.VariantToNative Function

nxsdNativeVariantConverter.VariantToNative Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
procedure VariantToNative(const FormatSettings: TFormatSettings; FieldType: TnxFieldType; CodePage: Word; Units: Integer; DecPl: Integer; const V: Variant; Buffer: PnxByteArray; BufferLength: Integer; Truncate: Boolean = False); overload;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.VariantToNative.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.VariantToNative Function

nxsdNativeVariantConverter.VariantToNative Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
procedure VariantToNative(const FormatSettings: TFormatSettings; FieldType: TnxFieldType; CodePage: Word; Units: Integer; DecPl: Integer; const V: Variant; var Buffer: TnxDynByteArray); overload;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.VariantToNative.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.VariantToNative Function

nxsdNativeVariantConverter.VariantToNative Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
procedure VariantToNative(FieldType: TnxFieldType; CodePage: Word; Units: Integer; DecPl: Integer; const V: Variant; Buffer: PnxByteArray; BufferLength: Integer); overload;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.VariantToNative.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


nxsdNativeVariantConverter.VariantToNative Function

nxsdNativeVariantConverter.VariantToNative Function
nxsdNativeVariantConverter Functions Send Feedback
Syntax
Delphi
procedure VariantToNative(FieldType: TnxFieldType; CodePage: Word; Units: Integer; DecPl: Integer; const V: Variant; var Buffer: TnxDynByteArray); overload;
File

nxsdNativeVariantConverter

Description

This is function nxsdNativeVariantConverter.VariantToNative.

Group

Functions

Links
nxsdNativeVariantConverter, Functions


Constants

Constants
Constants nxsdNativeVariantConverter Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
oleaut | This is constant nxsdNativeVariantConverter.oleaut.
rs0ZeroIsNotAValidTimestamp | This is constant nxsdNativeVariantConverter.rs0ZeroIsNotAValidTimestamp.
rsBadCharFormat | This is constant nxsdNativeVariantConverter.rsBadCharFormat.
Namespace

nxsdNativeVariantConverter Namespace

Links
Constants, nxsdNativeVariantConverter Namespace


nxsdNativeVariantConverter.oleaut Constant

nxsdNativeVariantConverter.oleaut Constant
nxsdNativeVariantConverter Constants Send Feedback
Syntax
Delphi
oleaut = 'oleaut32.dll';
File

nxsdNativeVariantConverter

Description

This is constant nxsdNativeVariantConverter.oleaut.

Group

Constants

Links
nxsdNativeVariantConverter, Constants


nxsdNativeVariantConverter.rs0ZeroIsNotAValidTimestamp Constant

nxsdNativeVariantConverter.rs0ZeroIsNotAValidTimestamp Constant
nxsdNativeVariantConverter Constants Send Feedback
Syntax
Delphi
rs0ZeroIsNotAValidTimestamp = '0 (zero) is not a valid timestamp';
File

nxsdNativeVariantConverter

Description

This is constant nxsdNativeVariantConverter.rs0ZeroIsNotAValidTimestamp.

Group

Constants

Links
nxsdNativeVariantConverter, Constants


nxsdNativeVariantConverter.rsBadCharFormat Constant

nxsdNativeVariantConverter.rsBadCharFormat Constant
nxsdNativeVariantConverter Constants Send Feedback
Syntax
Delphi
rsBadCharFormat = 'Invalid char format (length must be exactly 1)';
File

nxsdNativeVariantConverter

Description

This is constant nxsdNativeVariantConverter.rsBadCharFormat.

Group

Constants

Links
nxsdNativeVariantConverter, Constants


nxsdRecordMapperDescriptor Namespace

nxsdRecordMapperDescriptor Namespace
Classes Legend Topics Send Feedback

This is namespace nxsdRecordMapperDescriptor.

Classes
Name | Description
EnxRecordMapperDescriptorException | This is class nxsdRecordMapperDescriptor.EnxRecordMapperDescriptorException.
TnxFieldMapperDescriptorHack |
TnxRecordMapperDescriptor | This is class nxsdRecordMapperDescriptor.TnxRecordMapperDescriptor.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxsdRecordMapperDescriptor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxRecordMapperDescriptorException | This is class nxsdRecordMapperDescriptor.EnxRecordMapperDescriptorException.
TnxFieldMapperDescriptorHack |
TnxRecordMapperDescriptor | This is class nxsdRecordMapperDescriptor.TnxRecordMapperDescriptor.
Namespace

nxsdRecordMapperDescriptor Namespace

Links
Classes, nxsdRecordMapperDescriptor Namespace, Legend


EnxRecordMapperDescriptorException Class

EnxRecordMapperDescriptorException Class
nxsdRecordMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdRecordMapperDescriptor_EnxRecordMapperDescriptorExceptionnxsdRecordMapperDescriptor_EnxRecordMapperDescriptorExceptionnxsdRecordMapperDescriptor_EnxRecordMapperDescriptorExceptionnxsdRecordMapperDescriptor_EnxRecordMapperDescriptorExceptionnxsdRecordMapperDescriptor_EnxRecordMapperDescriptorExceptionnxsdRecordMapperDescriptor_EnxRecordMapperDescriptorException
Syntax
Delphi
EnxRecordMapperDescriptorException = class(EnxBaseRecordMapperDescriptorException);
File

nxsdRecordMapperDescriptor

Description

This is class nxsdRecordMapperDescriptor.EnxRecordMapperDescriptorException.

Group

Classes

Links
nxsdRecordMapperDescriptor, Classes


TnxFieldMapperDescriptorHack Class

TnxFieldMapperDescriptorHack Class
nxsdRecordMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHacknxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHacknxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHacknxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHacknxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHacknxsdRecordMapperDescriptor_TnxFieldMapperDescriptorHack
Syntax
Delphi
TnxFieldMapperDescriptorHack = class(TnxFieldMapperDescriptor);
File

nxsdRecordMapperDescriptor

Group

Classes

Links
nxsdRecordMapperDescriptor, Classes


TnxRecordMapperDescriptor Class

TnxRecordMapperDescriptor Class
TnxRecordMapperDescriptor Fields TnxRecordMapperDescriptor Methods TnxRecordMapperDescriptor Properties TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdRecordMapperDescriptor_TnxRecordMapperDescriptornxsdRecordMapperDescriptor_TnxRecordMapperDescriptornxsdRecordMapperDescriptor_TnxRecordMapperDescriptornxsdRecordMapperDescriptor_TnxRecordMapperDescriptornxsdRecordMapperDescriptor_TnxRecordMapperDescriptornxsdRecordMapperDescriptor_TnxRecordMapperDescriptor
Syntax
Delphi
TnxRecordMapperDescriptor = class(TnxBaseRecordMapperDescriptor);
File

nxsdRecordMapperDescriptor

Description

This is class nxsdRecordMapperDescriptor.TnxRecordMapperDescriptor.

Group

Classes

Links
TnxRecordMapperDescriptor Fields, TnxRecordMapperDescriptor Methods, TnxRecordMapperDescriptor Properties, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor, Classes


TnxRecordMapperDescriptor Members

TnxRecordMapperDescriptor Members
TnxRecordMapperDescriptor Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRecordMapperDescriptor.

Class

TnxRecordMapperDescriptor Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
rmdApplyDefaultForUnmapped | This is rmdApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.
rmdFieldMapperDescriptors | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
QueryInterface | InxInterface
Register |
rmdGetMapper |
rmdGetMapperCount |
Unregister |
Public Methods
Name | Description
AddMapping | TnxRecordMapperDescriptor
BeforeDestruction | TnxLifetimeTrackedPersistent
Create |
CreateFromReader |
DeleteMapping |
Destroy |
Duplicate |
FieldMapperIndexOf |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
MapAllFieldsByName |
MapAllFieldsByPosition |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
UpdateSourceName |
UpdateTargetName |
WriteToWriter |
Public Properties
Name | Description
ApplyDefaultForUnmapped | This is ApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.
FieldMapper | This is FieldMapper, a member of class TnxRecordMapperDescriptor.
FieldMapperCount | This is FieldMapperCount, a member of class TnxRecordMapperDescriptor.
Links
TnxRecordMapperDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRecordMapperDescriptor.Create Constructor

TnxRecordMapperDescriptor.Create Constructor
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Class Send Feedback
Syntax
Delphi
constructor Create; override;
Class

TnxRecordMapperDescriptor Class

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Class


TnxRecordMapperDescriptor.Destroy Destructor

TnxRecordMapperDescriptor.Destroy Destructor
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxRecordMapperDescriptor Class

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Class


TnxRecordMapperDescriptor Fields

TnxRecordMapperDescriptor Fields
TnxRecordMapperDescriptor Class Legend Protected Fields Send Feedback

The fields of the TnxRecordMapperDescriptor class are listed here.

Class

TnxRecordMapperDescriptor Class

Protected Fields
Name | Description
rmdApplyDefaultForUnmapped | This is rmdApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.
rmdFieldMapperDescriptors | private
Links
TnxRecordMapperDescriptor Class, Legend, Protected Fields


TnxRecordMapperDescriptor.rmdApplyDefaultForUnmapped Field

TnxRecordMapperDescriptor.rmdApplyDefaultForUnmapped Field
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Fields Send Feedback
Syntax
Delphi
rmdApplyDefaultForUnmapped: Boolean;
Description

This is rmdApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.

Group

TnxRecordMapperDescriptor Fields

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Fields


TnxRecordMapperDescriptor.rmdFieldMapperDescriptors Field

TnxRecordMapperDescriptor.rmdFieldMapperDescriptors Field
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Fields Send Feedback
Syntax
Delphi
rmdFieldMapperDescriptors: TStringList;
Description

private

Group

TnxRecordMapperDescriptor Fields

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Fields


TnxRecordMapperDescriptor Methods

TnxRecordMapperDescriptor Methods
TnxRecordMapperDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxRecordMapperDescriptor class are listed here.

Class

TnxRecordMapperDescriptor Class

Protected Methods
Name | Description
InternalLoadFromReader |
InternalSaveToWriter |
rmdGetMapper |
rmdGetMapperCount |
Public Methods
Name | Description
AddMapping | TnxRecordMapperDescriptor
DeleteMapping |
FieldMapperIndexOf |
MapAllFieldsByName |
MapAllFieldsByPosition |
UpdateSourceName |
UpdateTargetName |
Links
TnxRecordMapperDescriptor Class, Legend, Protected Methods, Public Methods


TnxRecordMapperDescriptor.AddMapping Method

TnxRecordMapperDescriptor.AddMapping Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function AddMapping(const aSourceName: string; const aTargetName: string; aDataLossAction: TnxDataLossAction = dlaFail; aDescriptorClass: TnxFieldMapperDescriptorClass = nil): TnxFieldMapperDescriptor;
Description

TnxRecordMapperDescriptor

Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.DeleteMapping Method

TnxRecordMapperDescriptor.DeleteMapping Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure DeleteMapping(const aTargetName: string);
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.FieldMapperIndexOf Method

TnxRecordMapperDescriptor.FieldMapperIndexOf Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function FieldMapperIndexOf(const aTargetName: String): Integer;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.InternalLoadFromReader Method

TnxRecordMapperDescriptor.InternalLoadFromReader Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalLoadFromReader(aReader: TnxReader); override;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.InternalSaveToWriter Method

TnxRecordMapperDescriptor.InternalSaveToWriter Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.MapAllFieldsByName Method

TnxRecordMapperDescriptor.MapAllFieldsByName Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure MapAllFieldsByName(aOldFields: TnxFieldsDescriptor; aNewFields: TnxFieldsDescriptor; aDataLossAction: TnxDataLossAction = dlaFail);
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.MapAllFieldsByPosition Method

TnxRecordMapperDescriptor.MapAllFieldsByPosition Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure MapAllFieldsByPosition(aOldFields: TnxFieldsDescriptor; aNewFields: TnxFieldsDescriptor; aDataLossAction: TnxDataLossAction = dlaFail);
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.rmdGetMapper Method

TnxRecordMapperDescriptor.rmdGetMapper Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function rmdGetMapper(aInx: Integer): TnxFieldMapperDescriptor;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.rmdGetMapperCount Method

TnxRecordMapperDescriptor.rmdGetMapperCount Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function rmdGetMapperCount: Integer;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.UpdateSourceName Method

TnxRecordMapperDescriptor.UpdateSourceName Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function UpdateSourceName(const aTargetName: string; const aNewSourceName: string): TnxFieldMapperDescriptor;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor.UpdateTargetName Method

TnxRecordMapperDescriptor.UpdateTargetName Method
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function UpdateTargetName(const aOldTargetName: string; const aNewTargetName: string): TnxFieldMapperDescriptor;
Group

TnxRecordMapperDescriptor Methods

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Methods


TnxRecordMapperDescriptor Properties

TnxRecordMapperDescriptor Properties
TnxRecordMapperDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxRecordMapperDescriptor class are listed here.

Class

TnxRecordMapperDescriptor Class

Public Properties
Name | Description
ApplyDefaultForUnmapped | This is ApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.
FieldMapper | This is FieldMapper, a member of class TnxRecordMapperDescriptor.
FieldMapperCount | This is FieldMapperCount, a member of class TnxRecordMapperDescriptor.
Links
TnxRecordMapperDescriptor Class, Legend, Public Properties


TnxRecordMapperDescriptor.ApplyDefaultForUnmapped Property

TnxRecordMapperDescriptor.ApplyDefaultForUnmapped Property
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Properties Send Feedback
Syntax
Delphi
property ApplyDefaultForUnmapped: Boolean;
Description

This is ApplyDefaultForUnmapped, a member of class TnxRecordMapperDescriptor.

Group

TnxRecordMapperDescriptor Properties

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Properties


TnxRecordMapperDescriptor.FieldMapper Property

TnxRecordMapperDescriptor.FieldMapper Property
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Properties Send Feedback
Syntax
Delphi
property FieldMapper [aInx: Integer]: TnxFieldMapperDescriptor;
Description

This is FieldMapper, a member of class TnxRecordMapperDescriptor.

Group

TnxRecordMapperDescriptor Properties

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Properties


TnxRecordMapperDescriptor.FieldMapperCount Property

TnxRecordMapperDescriptor.FieldMapperCount Property
TnxRecordMapperDescriptor Class TnxRecordMapperDescriptor Members nxsdRecordMapperDescriptor Namespace TnxRecordMapperDescriptor Properties Send Feedback
Syntax
Delphi
property FieldMapperCount: Integer;
Description

This is FieldMapperCount, a member of class TnxRecordMapperDescriptor.

Group

TnxRecordMapperDescriptor Properties

Links
TnxRecordMapperDescriptor Class, TnxRecordMapperDescriptor Members, nxsdRecordMapperDescriptor Namespace, TnxRecordMapperDescriptor Properties


nxsdRecordMapperDescriptorBase Namespace

nxsdRecordMapperDescriptorBase Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxsdRecordMapperDescriptorBase.

Classes
Name | Description
EnxBaseRecordMapperDescriptorException | This is class nxsdRecordMapperDescriptorBase.EnxBaseRecordMapperDescriptorException.
TnxBaseRecordMapperDescriptor | This is class nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptor.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxBaseRecordMapperDescriptorClass | This is type nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptorClass.
Variables
Name | Description
_RecordMapperDescriptorList | This is variable nxsdRecordMapperDescriptorBase._RecordMapperDescriptorList.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdRecordMapperDescriptorBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseRecordMapperDescriptorException | This is class nxsdRecordMapperDescriptorBase.EnxBaseRecordMapperDescriptorException.
TnxBaseRecordMapperDescriptor | This is class nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptor.
Namespace

nxsdRecordMapperDescriptorBase Namespace

Links
Classes, nxsdRecordMapperDescriptorBase Namespace, Legend


EnxBaseRecordMapperDescriptorException Class

EnxBaseRecordMapperDescriptorException Class
nxsdRecordMapperDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdRecordMapperDescriptorBase_EnxBaseRecordMapperDescriptorExceptionnxsdRecordMapperDescriptorBase_EnxBaseRecordMapperDescriptorExceptionnxsdRecordMapperDescriptorBase_EnxBaseRecordMapperDescriptorExceptionnxsdRecordMapperDescriptorBase_EnxBaseRecordMapperDescriptorExceptionnxsdRecordMapperDescriptorBase_EnxBaseRecordMapperDescriptorException
Syntax
Delphi
EnxBaseRecordMapperDescriptorException = class(EnxBaseRegisterableDescriptorException);
File

nxsdRecordMapperDescriptorBase

Description

This is class nxsdRecordMapperDescriptorBase.EnxBaseRecordMapperDescriptorException.

Group

Classes

Links
nxsdRecordMapperDescriptorBase, Classes


TnxBaseRecordMapperDescriptor Class

TnxBaseRecordMapperDescriptor Class
TnxBaseRecordMapperDescriptor Methods TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdRecordMapperDescriptorBase_TnxBaseRecordMapperDescriptornxsdRecordMapperDescriptorBase_TnxBaseRecordMapperDescriptornxsdRecordMapperDescriptorBase_TnxBaseRecordMapperDescriptornxsdRecordMapperDescriptorBase_TnxBaseRecordMapperDescriptornxsdRecordMapperDescriptorBase_TnxBaseRecordMapperDescriptor
Syntax
Delphi
TnxBaseRecordMapperDescriptor = class(TnxBaseRegisterableDescriptor);
File

nxsdRecordMapperDescriptorBase

Description

This is class nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptor.

Group

Classes

Links
TnxBaseRecordMapperDescriptor Methods, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase, Classes


TnxBaseRecordMapperDescriptor Members

TnxBaseRecordMapperDescriptor Members
TnxBaseRecordMapperDescriptor Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseRecordMapperDescriptor.

Class

TnxBaseRecordMapperDescriptor Class

Protected Fields
Name | Description
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | TnxBaseRecordMapperDescriptor
CreateFromReader |
Duplicate |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
WriteToWriter |
Links
TnxBaseRecordMapperDescriptor Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseRecordMapperDescriptor.Create Constructor

TnxBaseRecordMapperDescriptor.Create Constructor
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Class Send Feedback
Syntax
Delphi
constructor Create; virtual;
Description

TnxBaseRecordMapperDescriptor

Class

TnxBaseRecordMapperDescriptor Class

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Class


TnxBaseRecordMapperDescriptor Methods

TnxBaseRecordMapperDescriptor Methods
TnxBaseRecordMapperDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRecordMapperDescriptor class are listed here.

Class

TnxBaseRecordMapperDescriptor Class

Protected Methods
Name | Description
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
Public Methods
Name | Description
CreateFromReader |
Duplicate |
WriteToWriter |
Links
TnxBaseRecordMapperDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseRecordMapperDescriptor.CreateFromReader Method

TnxBaseRecordMapperDescriptor.CreateFromReader Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function CreateFromReader(aReader: TnxReader): TnxBaseRecordMapperDescriptor;
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


TnxBaseRecordMapperDescriptor.Duplicate Method

TnxBaseRecordMapperDescriptor.Duplicate Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
function Duplicate: TnxBaseRecordMapperDescriptor;
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


TnxBaseRecordMapperDescriptor.GetList Method

TnxBaseRecordMapperDescriptor.GetList Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


TnxBaseRecordMapperDescriptor.InternalLoadFromReader Method

TnxBaseRecordMapperDescriptor.InternalLoadFromReader Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalLoadFromReader(aReader: TnxReader); virtual;
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


TnxBaseRecordMapperDescriptor.InternalSaveToWriter Method

TnxBaseRecordMapperDescriptor.InternalSaveToWriter Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); virtual;
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


TnxBaseRecordMapperDescriptor.WriteToWriter Method

TnxBaseRecordMapperDescriptor.WriteToWriter Method
TnxBaseRecordMapperDescriptor Class TnxBaseRecordMapperDescriptor Members nxsdRecordMapperDescriptorBase Namespace TnxBaseRecordMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure WriteToWriter(aWriter: TnxWriter; aClientVersion: Integer);
Group

TnxBaseRecordMapperDescriptor Methods

Links
TnxBaseRecordMapperDescriptor Class, TnxBaseRecordMapperDescriptor Members, nxsdRecordMapperDescriptorBase Namespace, TnxBaseRecordMapperDescriptor Methods


Types

Types
nxsdRecordMapperDescriptorBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdRecordMapperDescriptorBase Namespace

Types
Name | Description
TnxBaseRecordMapperDescriptorClass | This is type nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptorClass.
Links
nxsdRecordMapperDescriptorBase Namespace, Types


nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptorClass Type

nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptorClass Type
nxsdRecordMapperDescriptorBase Types Send Feedback
Syntax
Delphi
TnxBaseRecordMapperDescriptorClass = class of TnxBaseRecordMapperDescriptor;
File

nxsdRecordMapperDescriptorBase

Description

This is type nxsdRecordMapperDescriptorBase.TnxBaseRecordMapperDescriptorClass.

Group

Types

Links
nxsdRecordMapperDescriptorBase, Types


Variables

Variables
nxsdRecordMapperDescriptorBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdRecordMapperDescriptorBase Namespace

Variables
Name | Description
_RecordMapperDescriptorList | This is variable nxsdRecordMapperDescriptorBase._RecordMapperDescriptorList.
Links
nxsdRecordMapperDescriptorBase Namespace, Variables


nxsdRecordMapperDescriptorBase._RecordMapperDescriptorList Variable

nxsdRecordMapperDescriptorBase._RecordMapperDescriptorList Variable
nxsdRecordMapperDescriptorBase Variables Send Feedback
Syntax
Delphi
_RecordMapperDescriptorList: TStringList;
File

nxsdRecordMapperDescriptorBase

Description

This is variable nxsdRecordMapperDescriptorBase._RecordMapperDescriptorList.

Group

Variables

Links
nxsdRecordMapperDescriptorBase, Variables


nxsdRecordMapperEngineBase Namespace

nxsdRecordMapperEngineBase Namespace
Classes Constants Legend Topics Types Variables Send Feedback

This is namespace nxsdRecordMapperEngineBase.

Classes
Name | Description
EnxBaseRecordMapperEngineException | This is class nxsdRecordMapperEngineBase.EnxBaseRecordMapperEngineException.
TnxBaseRecordMapperEngine | This is class nxsdRecordMapperEngineBase.TnxBaseRecordMapperEngine.
Constants
Name | Description
csRecordMapper | This is constant nxsdRecordMapperEngineBase.csRecordMapper.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxRecordMapperEngineClass | This is type nxsdRecordMapperEngineBase.TnxRecordMapperEngineClass.
Variables
Name | Description
_RecordMapperEngineList | This is variable nxsdRecordMapperEngineBase._RecordMapperEngineList.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdRecordMapperEngineBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseRecordMapperEngineException | This is class nxsdRecordMapperEngineBase.EnxBaseRecordMapperEngineException.
TnxBaseRecordMapperEngine | This is class nxsdRecordMapperEngineBase.TnxBaseRecordMapperEngine.
Namespace

nxsdRecordMapperEngineBase Namespace

Links
Classes, nxsdRecordMapperEngineBase Namespace, Legend


EnxBaseRecordMapperEngineException Class

EnxBaseRecordMapperEngineException Class
nxsdRecordMapperEngineBase Classes Send Feedback
Class Hierarchy
nxsdRecordMapperEngineBase_EnxBaseRecordMapperEngineExceptionnxsdRecordMapperEngineBase_EnxBaseRecordMapperEngineExceptionnxsdRecordMapperEngineBase_EnxBaseRecordMapperEngineExceptionnxsdRecordMapperEngineBase_EnxBaseRecordMapperEngineExceptionnxsdRecordMapperEngineBase_EnxBaseRecordMapperEngineException
Syntax
Delphi
EnxBaseRecordMapperEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdRecordMapperEngineBase

Description

This is class nxsdRecordMapperEngineBase.EnxBaseRecordMapperEngineException.

Group

Classes

Links
nxsdRecordMapperEngineBase, Classes


TnxBaseRecordMapperEngine Class

TnxBaseRecordMapperEngine Class
TnxBaseRecordMapperEngine Methods TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Classes Send Feedback
Class Hierarchy
nxsdRecordMapperEngineBase_TnxBaseRecordMapperEnginenxsdRecordMapperEngineBase_TnxBaseRecordMapperEnginenxsdRecordMapperEngineBase_TnxBaseRecordMapperEnginenxsdRecordMapperEngineBase_TnxBaseRecordMapperEngine
Syntax
Delphi
TnxBaseRecordMapperEngine = class(TnxBaseRegisterableEngine);
File

nxsdRecordMapperEngineBase

Description

This is class nxsdRecordMapperEngineBase.TnxBaseRecordMapperEngine.

Group

Classes

Links
TnxBaseRecordMapperEngine Methods, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase, Classes


TnxBaseRecordMapperEngine Members

TnxBaseRecordMapperEngine Members
TnxBaseRecordMapperEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseRecordMapperEngine.

Class

TnxBaseRecordMapperEngine Class

Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxBaseRecordMapperEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
BeforeCommit | This is BeforeCommit, a member of class TnxBaseRecordMapperEngine.
BeforeFirstRecord | This is BeforeFirstRecord, a member of class TnxBaseRecordMapperEngine.
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
MapRecord | This is MapRecord, a member of class TnxBaseRecordMapperEngine.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxBaseRecordMapperEngine Class, Legend, Protected Methods, Public Methods


TnxBaseRecordMapperEngine.Create Constructor

TnxBaseRecordMapperEngine.Create Constructor
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseRecordMapperDescriptor; aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor); virtual;
Description

TnxBaseRecordMapperEngine

Class

TnxBaseRecordMapperEngine Class

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Class


TnxBaseRecordMapperEngine Methods

TnxBaseRecordMapperEngine Methods
TnxBaseRecordMapperEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseRecordMapperEngine class are listed here.

Class

TnxBaseRecordMapperEngine Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
BeforeCommit | This is BeforeCommit, a member of class TnxBaseRecordMapperEngine.
BeforeFirstRecord | This is BeforeFirstRecord, a member of class TnxBaseRecordMapperEngine.
CreateFor |
MapRecord | This is MapRecord, a member of class TnxBaseRecordMapperEngine.
Links
TnxBaseRecordMapperEngine Class, Legend, Protected Methods, Public Methods


TnxBaseRecordMapperEngine.BeforeCommit Method

TnxBaseRecordMapperEngine.BeforeCommit Method
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Methods Send Feedback
Syntax
Delphi
procedure BeforeCommit; virtual; abstract;
Description

This is BeforeCommit, a member of class TnxBaseRecordMapperEngine.

Group

TnxBaseRecordMapperEngine Methods

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Methods


TnxBaseRecordMapperEngine.BeforeFirstRecord Method

TnxBaseRecordMapperEngine.BeforeFirstRecord Method
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Methods Send Feedback
Syntax
Delphi
procedure BeforeFirstRecord; virtual; abstract;
Description

This is BeforeFirstRecord, a member of class TnxBaseRecordMapperEngine.

Group

TnxBaseRecordMapperEngine Methods

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Methods


TnxBaseRecordMapperEngine.CreateFor Method

TnxBaseRecordMapperEngine.CreateFor Method
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aDescriptor: TnxBaseRecordMapperDescriptor; aSourceCursor: TnxAbstractCursor; aTargetCursor: TnxAbstractCursor): TnxBaseRecordMapperEngine;
Group

TnxBaseRecordMapperEngine Methods

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Methods


TnxBaseRecordMapperEngine.GetList Method

TnxBaseRecordMapperEngine.GetList Method
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseRecordMapperEngine Methods

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Methods


TnxBaseRecordMapperEngine.MapRecord Method

TnxBaseRecordMapperEngine.MapRecord Method
TnxBaseRecordMapperEngine Class TnxBaseRecordMapperEngine Members nxsdRecordMapperEngineBase Namespace TnxBaseRecordMapperEngine Methods Send Feedback
Syntax
Delphi
function MapRecord(const aSource; var aTarget): TnxResult; virtual; abstract;
Description

This is MapRecord, a member of class TnxBaseRecordMapperEngine.

Group

TnxBaseRecordMapperEngine Methods

Links
TnxBaseRecordMapperEngine Class, TnxBaseRecordMapperEngine Members, nxsdRecordMapperEngineBase Namespace, TnxBaseRecordMapperEngine Methods


Types

Types
nxsdRecordMapperEngineBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdRecordMapperEngineBase Namespace

Types
Name | Description
TnxRecordMapperEngineClass | This is type nxsdRecordMapperEngineBase.TnxRecordMapperEngineClass.
Links
nxsdRecordMapperEngineBase Namespace, Types


nxsdRecordMapperEngineBase.TnxRecordMapperEngineClass Type

nxsdRecordMapperEngineBase.TnxRecordMapperEngineClass Type
nxsdRecordMapperEngineBase Types Send Feedback
Syntax
Delphi
TnxRecordMapperEngineClass = class of TnxBaseRecordMapperEngine;
File

nxsdRecordMapperEngineBase

Description

This is type nxsdRecordMapperEngineBase.TnxRecordMapperEngineClass.

Group

Types

Links
nxsdRecordMapperEngineBase, Types


Variables

Variables
nxsdRecordMapperEngineBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdRecordMapperEngineBase Namespace

Variables
Name | Description
_RecordMapperEngineList | This is variable nxsdRecordMapperEngineBase._RecordMapperEngineList.
Links
nxsdRecordMapperEngineBase Namespace, Variables


nxsdRecordMapperEngineBase._RecordMapperEngineList Variable

nxsdRecordMapperEngineBase._RecordMapperEngineList Variable
nxsdRecordMapperEngineBase Variables Send Feedback
Syntax
Delphi
_RecordMapperEngineList: TStringList;
File

nxsdRecordMapperEngineBase

Description

This is variable nxsdRecordMapperEngineBase._RecordMapperEngineList.

Group

Variables

Links
nxsdRecordMapperEngineBase, Variables


Constants

Constants
Constants nxsdRecordMapperEngineBase Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csRecordMapper | This is constant nxsdRecordMapperEngineBase.csRecordMapper.
Namespace

nxsdRecordMapperEngineBase Namespace

Links
Constants, nxsdRecordMapperEngineBase Namespace


nxsdRecordMapperEngineBase.csRecordMapper Constant

nxsdRecordMapperEngineBase.csRecordMapper Constant
nxsdRecordMapperEngineBase Constants Send Feedback
Syntax
Delphi
csRecordMapper = 'RecordMapper';
File

nxsdRecordMapperEngineBase

Description

This is constant nxsdRecordMapperEngineBase.csRecordMapper.

Group

Constants

Links
nxsdRecordMapperEngineBase, Constants


nxsdServerEngine Namespace

nxsdServerEngine Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

Base server engine classes.

Classes
Name | Description
EnxAbstractSecurityMonitorException | This is class nxsdServerEngine.EnxAbstractSecurityMonitorException.
TnxAbstractCursor | The abstract declaration of a Server cursor. All actual cursor implementations must be descended from this class. This is the server side version of TnxCursor.
TnxAbstractDatabase | The abstract declaration of a Server Database. All actual database implementations MUST be descendent from this class. This is the server side version of TnxDatabase.
TnxAbstractSecurityMonitor | This is the base for all security monitors used in NexusDB.
TnxAbstractSecurityMonitorComponentInfo | This is class nxsdServerEngine.TnxAbstractSecurityMonitorComponentInfo.
TnxAbstractServerObject | The base class for all server dependent objects.
TnxAbstractSession | The abstract declaration of a Server Session. All actual session implementations MUST be descendent from this class. This is the server side version of TnxSession.
TnxAbstractStatement | The abstract declaration of a server statement. All actual statement implementations MUST be descendent from this class. This is the server side version of TnxQuery.
TnxAbstractTaskInfo | An instance of a descendant of this class is created for every task executed and on the server. It will be freed once the task is finished.
TnxAbstractTimeoutObject | The base class for all server classes that support timeout.
TnxAbstractTransContext | The abstract declaration of a Server transaction context. All actual transaction context implementations MUST be descendent from this class. This is the server side version of TnxTransContext.
TnxAliasDescriptor | A Database Alias descriptor.
TnxBaseEngineExtender | This is the base for all Extenders used in NexusDB. An extender gets notified about actions in the database core and can change or extend the default behavior. It is generally always created from a TnxBaseEngineMonitor.
TnxBaseEngineMonitor | This is the base engine monitor. An engine monitor is responsible for creating and freeing engine extenders. A monitor is notified about every creation and destruction of a server object.
TnxBaseServerEngine | This is the base for all Server Engine implementations in NexusDB. All actual server engines are descendent from this class. Please note that a server engine does not do a lot of stuff on its own. It's a mainly a center point that holds together all engines and their instances of server objects.
TnxBaseTransContext | The base class for transaction contexts, both TnxAbstractTransContext and TnxAbstractDatabase derive from this class.
TnxExtendableServerObject | The base class for Server objects that can be extended with an Extender.
TnxLockedOptionsExtendableServerObject | The base class for extendable objects that require a locked named options list.
TnxRequestCloseHandlerEvent | TnxRequestCloseHandlerEvent
TnxSessionStats | This is class nxsdServerEngine.TnxSessionStats.
TnxSimpleLock | A 100% thread safe lock used for counter based NexusDB locks.
TnxSqlAbstractCursor | This is class nxsdServerEngine.TnxSqlAbstractCursor.
TnxSqlAbstractDatabase | This is class nxsdServerEngine.TnxSqlAbstractDatabase.
TnxSqlAbstractTaskInfo | This is class nxsdServerEngine.TnxSqlAbstractTaskInfo.
TnxTableDescriptor | A Table descriptor.
Constants
Name | Description
CLSID_AbstractDatabase | This is constant nxsdServerEngine.CLSID_AbstractDatabase.
CLSID_AbstractServerObject | This is constant nxsdServerEngine.CLSID_AbstractServerObject.
CLSID_SecurityExtender | This is constant nxsdServerEngine.CLSID_SecurityExtender.
nxatAliasName | Alias Type - Name.
nxatAliasPath | Alias Type - Path.
nxcl_FailedTimeout | This is constant nxsdServerEngine.nxcl_FailedTimeout.
rsFailedPermanent | This is constant nxsdServerEngine.rsFailedPermanent.
rsProcessingCancelled | This is constant nxsdServerEngine.rsProcessingCancelled.
rsProcessingCancelledSuccess | This is constant nxsdServerEngine.rsProcessingCancelledSuccess.
rsRequestNestedTransactionsNotSupported | This is constant nxsdServerEngine.rsRequestNestedTransactionsNotSupported.
TnxBeforeAfterString | This is constant nxsdServerEngine.TnxBeforeAfterString.
TnxEngineActionStrings | This is constant nxsdServerEngine.TnxEngineActionStrings.
Functions
Name | Description
_DoNothingStub | internal use only
_DoNothingStub2 | internal use only
nxCheckValidAliasName | returns 0 if the given aAliasName is valid
nxCheckValidRelativeTableName | returns 0 if the given aTableName is a valid name for a sub table
nxCheckValidRootTableName | returns 0 if the given aTableName is a valid name for a root table
nxCheckValidStoredProcName | returns 0 if the given aAliasName is valid
nxCheckValidTableName | returns true if the given aTableName is a valid name for a table
nxRequestCloseHandlerEvent |
nxTableNameIsInMem | returns true if the given aTableName is not persistent nxTableNameIsInMem
nxTableNameIsTempDatabase | returns true if the given aTableName is a database specific temp table nxTableNameIsTempDatabase
nxTableNameIsTempGlobal | returns true if the given aTableName is a global temp table nxTableNameIsTempGlobal
nxTableNameIsTempStatement | returns true if the given aTableName is a temp statement nxTableNameIsTempStatement
Interfaces
Name | Description
InxAbstractDatabase31000 | This is class nxsdServerEngine.InxAbstractDatabase31000.
InxAbstractSecurityMonitorComponentInfo31000 | This is class nxsdServerEngine.InxAbstractSecurityMonitorComponentInfo31000.
InxAbstractServerObject41100 | This is class nxsdServerEngine.InxAbstractServerObject41100.
InxDatabaseCursorSource | This is class nxsdServerEngine.InxDatabaseCursorSource.
InxDatabaseCursorSourceControl | This is class nxsdServerEngine.InxDatabaseCursorSourceControl.
InxLoggedInAdministrator31000 | This is class nxsdServerEngine.InxLoggedInAdministrator31000.
InxLoggedInUser31000 | This is class nxsdServerEngine.InxLoggedInUser31000.
InxModifyUser31000 | This is class nxsdServerEngine.InxModifyUser31000.
InxRemoteTaskInfoCreator | This is class nxsdServerEngine.InxRemoteTaskInfoCreator.
InxRequestCloseHandler | This is class nxsdServerEngine.InxRequestCloseHandler.
InxRequestCloseHandlerEvent | This is class nxsdServerEngine.InxRequestCloseHandlerEvent.
InxSecurityExtender31000 | This is class nxsdServerEngine.InxSecurityExtender31000.
InxSimpleLock | This is class nxsdServerEngine.InxSimpleLock.
Structs, Records, Enums
Name | Description
TnxEngineAction | Action types for Engine based actions. These types are fired and passed on to Extenders.
TnxSessionStatsCounter | This is record nxsdServerEngine.TnxSessionStatsCounter.
TnxStatementExecDirectPhase | The state of the currently executed Statement
TnxTableScope | Scope of a table
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxTableScope | This is type nxsdServerEngine.PnxTableScope.
TnxAbstractServerObjectClass | Class definition for Server Objects.
TnxAbstractSessionClass | Class of TnxAbstractSession.
TnxBaseEngineExtenderClass | class definition for Server Extenders
TnxEngineActions | Set of Engine Actions
TnxMappingMethod | Abstract Prototype for MappingMethods
TnxSessionStatsCounters | This is type nxsdServerEngine.TnxSessionStatsCounters.
TQueryThreadCycleTime | This is type nxsdServerEngine.TQueryThreadCycleTime.
Variables
Name | Description
_CounterFrequencey | This is variable nxsdServerEngine._CounterFrequencey.
_QueryThreadCycleTime | This is variable nxsdServerEngine._QueryThreadCycleTime.
_SessionStatsHead | This is variable nxsdServerEngine._SessionStatsHead.
_SessionStatsHeadLock | This is variable nxsdServerEngine._SessionStatsHeadLock.
_SessionStatsNextNumber | This is variable nxsdServerEngine._SessionStatsNextNumber.
nxGetFailedFlag | callback function called to get failure specific flags
nxLockTimeout | callback function called when a locktimeout occurs
nxUnlockTimeout | callback function called when a unlocktimeout occurs
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxsdServerEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxAbstractSecurityMonitorException | This is class nxsdServerEngine.EnxAbstractSecurityMonitorException.
TnxAbstractCursor | The abstract declaration of a Server cursor. All actual cursor implementations must be descended from this class. This is the server side version of TnxCursor.
TnxAbstractDatabase | The abstract declaration of a Server Database. All actual database implementations MUST be descendent from this class. This is the server side version of TnxDatabase.
TnxAbstractSecurityMonitor | This is the base for all security monitors used in NexusDB.
TnxAbstractSecurityMonitorComponentInfo | This is class nxsdServerEngine.TnxAbstractSecurityMonitorComponentInfo.
TnxAbstractServerObject | The base class for all server dependent objects.
TnxAbstractSession | The abstract declaration of a Server Session. All actual session implementations MUST be descendent from this class. This is the server side version of TnxSession.
TnxAbstractStatement | The abstract declaration of a server statement. All actual statement implementations MUST be descendent from this class. This is the server side version of TnxQuery.
TnxAbstractTaskInfo | An instance of a descendant of this class is created for every task executed and on the server. It will be freed once the task is finished.
TnxAbstractTimeoutObject | The base class for all server classes that support timeout.
TnxAbstractTransContext | The abstract declaration of a Server transaction context. All actual transaction context implementations MUST be descendent from this class. This is the server side version of TnxTransContext.
TnxAliasDescriptor | A Database Alias descriptor.
TnxBaseEngineExtender | This is the base for all Extenders used in NexusDB. An extender gets notified about actions in the database core and can change or extend the default behavior. It is generally always created from a TnxBaseEngineMonitor.
TnxBaseEngineMonitor | This is the base engine monitor. An engine monitor is responsible for creating and freeing engine extenders. A monitor is notified about every creation and destruction of a server object.
TnxBaseServerEngine | This is the base for all Server Engine implementations in NexusDB. All actual server engines are descendent from this class. Please note that a server engine does not do a lot of stuff on its own. It's a mainly a center point that holds together all engines and their instances of server objects.
TnxBaseTransContext | The base class for transaction contexts, both TnxAbstractTransContext and TnxAbstractDatabase derive from this class.
TnxExtendableServerObject | The base class for Server objects that can be extended with an Extender.
TnxLockedOptionsExtendableServerObject | The base class for extendable objects that require a locked named options list.
TnxRequestCloseHandlerEvent | TnxRequestCloseHandlerEvent
TnxSessionStats | This is class nxsdServerEngine.TnxSessionStats.
TnxSimpleLock | A 100% thread safe lock used for counter based NexusDB locks.
TnxSqlAbstractCursor | This is class nxsdServerEngine.TnxSqlAbstractCursor.
TnxSqlAbstractDatabase | This is class nxsdServerEngine.TnxSqlAbstractDatabase.
TnxSqlAbstractTaskInfo | This is class nxsdServerEngine.TnxSqlAbstractTaskInfo.
TnxTableDescriptor | A Table descriptor.
Namespace

nxsdServerEngine Namespace

Links
Classes, nxsdServerEngine Namespace, Legend


EnxAbstractSecurityMonitorException Class

EnxAbstractSecurityMonitorException Class
nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorExceptionnxsdServerEngine_EnxAbstractSecurityMonitorException
Syntax
Delphi
EnxAbstractSecurityMonitorException = class(EnxStateComponentException);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.EnxAbstractSecurityMonitorException.

Group

Classes

Links
nxsdServerEngine, Classes


TnxAbstractCursor Class

TnxAbstractCursor Class
TnxAbstractCursor Fields TnxAbstractCursor Methods TnxAbstractCursor Properties TnxAbstractCursor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursornxsdServerEngine_TnxAbstractCursor
Syntax
Delphi
TnxAbstractCursor = class(TnxAbstractTimeoutObject, InxFieldsSource, InxFieldsAccess);
File

nxsdServerEngine

Description

The abstract declaration of a Server cursor. All actual cursor implementations must be descended from this class. This is the server side version of TnxCursor.

Group

Classes

Links
TnxAbstractCursor Fields, TnxAbstractCursor Methods, TnxAbstractCursor Properties, TnxAbstractCursor Members, nxsdServerEngine, Classes


TnxAbstractCursor Members

TnxAbstractCursor Members
TnxAbstractCursor Class Legend Protected Fields Protected Methods Protected Properties Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractCursor.

Class

TnxAbstractCursor Class

Protected Fields
Name | Description
acAutoFreeDatabase | This is acAutoFreeDatabase, a member of class TnxAbstractCursor.
acDatabase | private
acDatabaseNext | This is acDatabaseNext, a member of class TnxAbstractCursor.
acDatabasePrev | This is acDatabasePrev, a member of class TnxAbstractCursor.
acLockedIncDone | This is acLockedIncDone, a member of class TnxAbstractCursor.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
ac_GetDictionary | This is ac_GetDictionary, a member of class TnxAbstractCursor.
acAddToDatabase | TnxAbstractCursor
acGetFieldsDescriptor |
acGetFullName | This is acGetFullName, a member of class TnxAbstractCursor.
acGetTableDescriptor | This is acGetTableDescriptor, a member of class TnxAbstractCursor.
acRemoveFromDatabase |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout | TnxAbstractTimeoutObject
BlobsSupportedSelf |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetCursorSelf |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
GetFieldAsVariantSelf |
GetFieldCountRedirect |
GetFieldDescriptorRedirect |
GetFieldForFilterRedirect |
GetFieldFromNameRedirect |
GetFieldsOffsetRedirect |
QueryInterface | InxInterface
SetFieldAsVariantSelf |
Protected Properties
Name | Description
FieldsDescriptor | InxFieldsSource
Public Fields
Name | Description
IsResultSet | This is IsResultSet, a member of class TnxAbstractCursor.
IsUnnamed | This is IsUnnamed, a member of class TnxAbstractCursor.
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
asoConvertException | TnxAbstractServerObject
AutoIncGet |
AutoIncSet | This function sets the next AutoInc value for the current table.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
BlobCreate | This function creates a new blob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobCreateFile | This creates a new FileBlob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobDelete | This function deletes the blob with the given aBlobNr.
BlobFree | This function frees all temporary buffers for this blob.
BlobGetLength | This function returns the length of the blob in aLengt as bytes.
BlobModified | Checks if the given Blob Buffer was modified
BlobRead | This function reads data from a blob.
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BlobTruncate | This function truncates the given blob at aBlobLength bytes.
BlobWrite | This function writes data to a blob.
BookmarkAsVariant | Return a given bookmark as Variant
ChangePassword | This function changes the password of the table. It fails if the table doesn't us an encryption engine.
Close |
Close |
CompareBookmarks | This function compares two bookmarks.
CompareKeys | CompareKeys compares 2 keys.
CopyRecords | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed.
CopyRecordsEx | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed. aCheckValFields determines wether a check is done for required fields having a value.
Create | Constructor
CreateInstanceFor | remoting integration
DeleteRecords | This function deletes *all* visible (in regards of ranges and filters) records.
Destroy | destructor.
Duplicate | This function clones the current cursor and returns a new instance in aNewCursor. The new cursor can be opened with a different mode by specifying the aOpenMode accordingly.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
FilterActivate | This function sets the given Filter to active.
FilterAddCallback | Adds a new callback function to the filter valuation list.
FilterAddCustom | Adds a new filter to the filter evaluation list.
FilterAddExpression | FilterAddExpression creates a new Filter instance for the given aExpression and returns its in aFilterID.
FilterDeactivate | This function sets the given Filter to inactive.
FilterRemove | This function removes the given Filter from the internal list.
FilterSetTimeout | This function sets the timeout for the filter evaluation in msec.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetBookmark |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetIndexID | This function returns the id of the current index.
GetLifetimeMontior |
GetRecordCount | GetRecordCount returns the number of currently "visible" records. It obeys set ranges and filters.
GetRecordCountAsync | This function is an asynchronous version of GetRecordCount.
GetRecordCountEx | GetRecordCountEx returns the number of records or keys based on the value of aOption.
GetRecordCountExAsync | This function is an asynchronous version of GetRecordCountEx.
KeyFilterActivate | This function sets the given KeyFilter to active.
KeyFilterAddCallback | Adds a new callback function to the filter valuation list.
KeyFilterAddCustom | Adds a new filter to the filter evaluation list.
KeyFilterAddExpression | KeyFilterAddExpression creates a new KeyFilter instance for the given aExpression and returns its in aKeyFilterID.
KeyFilterDeactivate | This function sets the given KeyFilter to inactive.
KeyFilterRemove | This function removes the given KeyFilter from the internal list.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
RangeReset | This function cancels the active range.
RangeSet | Sets a range on the current cursor
RecNoGet | Returns the RecNo (Position) of the current record according to the current Index, Range and Filter(s). (using filters/indices is not recommended if that table (subset) contains more than a few data pages of records!).
RecNoSet | Sets the current position according to the RecNo
RecNoSupported | Returns DBIERR_NONE if RecNo is supported.
RecordBufferAlloc | helper functions for record buffer management
RecordBufferClear |
RecordBufferFree |
RecordDelete | RecordDelete deletes the current record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGet | RecordGet returns a pointer to the current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetBatch | This function returns a batch of record data in a Stream. aCutoffSize - the maximum length to return in bytes. aOptions - the (blob/bookmark) options to use for filling the stream aStream - the stream that receives the data aMaxRecords - the maximum number of records to return.
RecordGetForKey | RecordGetForKey positions the cursor on the first/last record that matches the passed in key and returns the record.
RecordGetNext | RecordGet moves to the next valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetPrior | RecordGet moves to the prior valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsert | RecordInsert creates a new record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsertBatch | This function adds the data in a aStream as new records. Please note that the size of aStream must be a multiple of the record size.
RecordIsLocked | RecordIsLocked returns the current record lock state for a certain lock type.
RecordLockRelease | This function releases the last lock or alternatively all locks in the record.
RecordModify | RecordInsert sets the record buffer to the given data. The record must have a proper lock acquired for this function to succeed. If aReleaseLock is true all locks on the current record are released.
RequestNestedTransactions | This function can be called from an extender to request that the cursor uses nested transactions for all operations. By default this is not supported.
SetFieldAsVariant | This is SetFieldAsVariant, a member of class InxFieldsAccess.
SetToBegin |
SetToBookmark | This function will position the cursor on the given bookmark
SetToCursor | This function synchronizes the position with the given aCursor. Please note that the two cursor have to point to the same dataset.
SetToEnd | This function sets the cursor position to the end of the dataset. This is NOT the last record but after it!
SetToFilter | This function sets the cursor position before the first record that meets the filter criteria in aFilter.
SetToKey | SetToKey positions the cursor relative to a specific key, The cursor is always positioned on a crack. For skaEqualLast, skaSmallerEqual and skaSmaller it's the crack after the matching key, otherwise the crack before.
SwitchToIndex | SwitchToIndex activates the given index. It aPosOnRec it repositions the cursor to the record active before changing the index, otherwise it jumps to the first record.
TableIsLocked | TableIsLocked returns the current table lock state for a certain lock type.
TableLockAcquire | This function will try to acquire a table lock with the given aLockType.
TableLockRelease | This function will release an acquired lock with the given aLockType or alternatively (if aAllLocks is true) all locks on the table.
TableStreamDelete | This function deletes the table stream with the given aName.
TableStreamGetList | This function returns the names of all streams stored with the table.
TableStreamRead | This function reads the WHOLE stream with the given name into aStream.
TableStreamWrite | This function rewrites the WHOLE stream with the given name.
Public Properties
Name | Description
_Dictionary | This property returns the data dictionary for this cursor.
Database | This property returns the database the cursor is linked to.
DatabaseNext | Returns the next cursor in the list of cursor of the current database.
DatabasePrev | Returns the previous cursor in the list of cursor of the current database.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsAccess.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FullName | Returns the full table name in relation to master and sub tables.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
TableDescriptor | Returns the TableDescriptor instance in the data dictionary associated with the cursor.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxAbstractCursor Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Fields, Public Methods, Public Properties


TnxAbstractCursor.Create Constructor

TnxAbstractCursor.Create Constructor
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Class Send Feedback
Syntax
Delphi
constructor Create(aDatabase: TnxAbstractDatabase; aTimeout: TnxWord32);
Parameters
Parameters | Description
aDatabase: TnxAbstractDatabase | the database object the cursor belongs to.
aTimeout: TnxWord32 | the timeout for this cursor in msec.
Description

Constructor

Class

TnxAbstractCursor Class

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Class


TnxAbstractCursor.Destroy Destructor

TnxAbstractCursor.Destroy Destructor
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractCursor Class

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Class


TnxAbstractCursor Fields

TnxAbstractCursor Fields
TnxAbstractCursor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxAbstractCursor class are listed here.

Class

TnxAbstractCursor Class

Protected Fields
Name | Description
acAutoFreeDatabase | This is acAutoFreeDatabase, a member of class TnxAbstractCursor.
acDatabase | private
acDatabaseNext | This is acDatabaseNext, a member of class TnxAbstractCursor.
acDatabasePrev | This is acDatabasePrev, a member of class TnxAbstractCursor.
acLockedIncDone | This is acLockedIncDone, a member of class TnxAbstractCursor.
Public Fields
Name | Description
IsResultSet | This is IsResultSet, a member of class TnxAbstractCursor.
IsUnnamed | This is IsUnnamed, a member of class TnxAbstractCursor.
Links
TnxAbstractCursor Class, Legend, Protected Fields, Public Fields


TnxAbstractCursor.acAutoFreeDatabase Field

TnxAbstractCursor.acAutoFreeDatabase Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
acAutoFreeDatabase: Boolean;
Description

This is acAutoFreeDatabase, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.acDatabase Field

TnxAbstractCursor.acDatabase Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
acDatabase: TnxAbstractDatabase;
Description

private

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.acDatabaseNext Field

TnxAbstractCursor.acDatabaseNext Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
acDatabaseNext: TnxAbstractCursor;
Description

This is acDatabaseNext, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.acDatabasePrev Field

TnxAbstractCursor.acDatabasePrev Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
acDatabasePrev: TnxAbstractCursor;
Description

This is acDatabasePrev, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.acLockedIncDone Field

TnxAbstractCursor.acLockedIncDone Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
acLockedIncDone: Boolean;
Description

This is acLockedIncDone, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.IsResultSet Field

TnxAbstractCursor.IsResultSet Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
IsResultSet: Boolean;
Description

This is IsResultSet, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor.IsUnnamed Field

TnxAbstractCursor.IsUnnamed Field
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Fields Send Feedback
Syntax
Delphi
IsUnnamed: Boolean;
Description

This is IsUnnamed, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Fields

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Fields


TnxAbstractCursor Methods

TnxAbstractCursor Methods
TnxAbstractCursor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractCursor class are listed here.

Class

TnxAbstractCursor Class

Protected Methods
Name | Description
ac_GetDictionary | This is ac_GetDictionary, a member of class TnxAbstractCursor.
acAddToDatabase | TnxAbstractCursor
acGetFieldsDescriptor |
acGetFullName | This is acGetFullName, a member of class TnxAbstractCursor.
acGetTableDescriptor | This is acGetTableDescriptor, a member of class TnxAbstractCursor.
acRemoveFromDatabase |
BlobsSupportedSelf |
GetCursorSelf |
GetExceptionData | InxExceptionData
GetFieldAsVariantSelf |
GetFieldCountRedirect |
GetFieldDescriptorRedirect |
GetFieldForFilterRedirect |
GetFieldFromNameRedirect |
GetFieldsOffsetRedirect |
SetFieldAsVariantSelf |
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
AutoIncGet |
AutoIncSet | This function sets the next AutoInc value for the current table.
BeforeDestruction | see TObject.BeforeConstruction
BlobCreate | This function creates a new blob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobCreateFile | This creates a new FileBlob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobDelete | This function deletes the blob with the given aBlobNr.
BlobFree | This function frees all temporary buffers for this blob.
BlobGetLength | This function returns the length of the blob in aLengt as bytes.
BlobModified | Checks if the given Blob Buffer was modified
BlobRead | This function reads data from a blob.
BlobTruncate | This function truncates the given blob at aBlobLength bytes.
BlobWrite | This function writes data to a blob.
BookmarkAsVariant | Return a given bookmark as Variant
ChangePassword | This function changes the password of the table. It fails if the table doesn't us an encryption engine.
CompareBookmarks | This function compares two bookmarks.
CompareKeys | CompareKeys compares 2 keys.
CopyRecords | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed.
CopyRecordsEx | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed. aCheckValFields determines wether a check is done for required fields having a value.
CreateInstanceFor | remoting integration
DeleteRecords | This function deletes *all* visible (in regards of ranges and filters) records.
Duplicate | This function clones the current cursor and returns a new instance in aNewCursor. The new cursor can be opened with a different mode by specifying the aOpenMode accordingly.
FilterActivate | This function sets the given Filter to active.
FilterAddCallback | Adds a new callback function to the filter valuation list.
FilterAddCustom | Adds a new filter to the filter evaluation list.
FilterAddExpression | FilterAddExpression creates a new Filter instance for the given aExpression and returns its in aFilterID.
FilterDeactivate | This function sets the given Filter to inactive.
FilterRemove | This function removes the given Filter from the internal list.
FilterSetTimeout | This function sets the timeout for the filter evaluation in msec.
GetBookmark |
GetIndexID | This function returns the id of the current index.
GetRecordCount | GetRecordCount returns the number of currently "visible" records. It obeys set ranges and filters.
GetRecordCountAsync | This function is an asynchronous version of GetRecordCount.
GetRecordCountEx | GetRecordCountEx returns the number of records or keys based on the value of aOption.
GetRecordCountExAsync | This function is an asynchronous version of GetRecordCountEx.
KeyFilterActivate | This function sets the given KeyFilter to active.
KeyFilterAddCallback | Adds a new callback function to the filter valuation list.
KeyFilterAddCustom | Adds a new filter to the filter evaluation list.
KeyFilterAddExpression | KeyFilterAddExpression creates a new KeyFilter instance for the given aExpression and returns its in aKeyFilterID.
KeyFilterDeactivate | This function sets the given KeyFilter to inactive.
KeyFilterRemove | This function removes the given KeyFilter from the internal list.
RangeReset | This function cancels the active range.
RangeSet | Sets a range on the current cursor
RecNoGet | Returns the RecNo (Position) of the current record according to the current Index, Range and Filter(s). (using filters/indices is not recommended if that table (subset) contains more than a few data pages of records!).
RecNoSet | Sets the current position according to the RecNo
RecNoSupported | Returns DBIERR_NONE if RecNo is supported.
RecordBufferAlloc | helper functions for record buffer management
RecordBufferClear |
RecordBufferFree |
RecordDelete | RecordDelete deletes the current record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGet | RecordGet returns a pointer to the current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetBatch | This function returns a batch of record data in a Stream. aCutoffSize - the maximum length to return in bytes. aOptions - the (blob/bookmark) options to use for filling the stream aStream - the stream that receives the data aMaxRecords - the maximum number of records to return.
RecordGetForKey | RecordGetForKey positions the cursor on the first/last record that matches the passed in key and returns the record.
RecordGetNext | RecordGet moves to the next valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetPrior | RecordGet moves to the prior valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsert | RecordInsert creates a new record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsertBatch | This function adds the data in a aStream as new records. Please note that the size of aStream must be a multiple of the record size.
RecordIsLocked | RecordIsLocked returns the current record lock state for a certain lock type.
RecordLockRelease | This function releases the last lock or alternatively all locks in the record.
RecordModify | RecordInsert sets the record buffer to the given data. The record must have a proper lock acquired for this function to succeed. If aReleaseLock is true all locks on the current record are released.
RequestNestedTransactions | This function can be called from an extender to request that the cursor uses nested transactions for all operations. By default this is not supported.
SetToBegin |
SetToBookmark | This function will position the cursor on the given bookmark
SetToCursor | This function synchronizes the position with the given aCursor. Please note that the two cursor have to point to the same dataset.
SetToEnd | This function sets the cursor position to the end of the dataset. This is NOT the last record but after it!
SetToFilter | This function sets the cursor position before the first record that meets the filter criteria in aFilter.
SetToKey | SetToKey positions the cursor relative to a specific key, The cursor is always positioned on a crack. For skaEqualLast, skaSmallerEqual and skaSmaller it's the crack after the matching key, otherwise the crack before.
SwitchToIndex | SwitchToIndex activates the given index. It aPosOnRec it repositions the cursor to the record active before changing the index, otherwise it jumps to the first record.
TableIsLocked | TableIsLocked returns the current table lock state for a certain lock type.
TableLockAcquire | This function will try to acquire a table lock with the given aLockType.
TableLockRelease | This function will release an acquired lock with the given aLockType or alternatively (if aAllLocks is true) all locks on the table.
TableStreamDelete | This function deletes the table stream with the given aName.
TableStreamGetList | This function returns the names of all streams stored with the table.
TableStreamRead | This function reads the WHOLE stream with the given name into aStream.
TableStreamWrite | This function rewrites the WHOLE stream with the given name.
Links
TnxAbstractCursor Class, Legend, Protected Methods, Public Methods


TnxAbstractCursor.ac_GetDictionary Method

TnxAbstractCursor.ac_GetDictionary Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function ac_GetDictionary: TnxDataDictionary; virtual; abstract;
Description

This is ac_GetDictionary, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.acAddToDatabase Method

TnxAbstractCursor.acAddToDatabase Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure acAddToDatabase;
Description

TnxAbstractCursor

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.acGetFieldsDescriptor Method

TnxAbstractCursor.acGetFieldsDescriptor Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function acGetFieldsDescriptor: TnxFieldsDescriptor;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.acGetFullName Method

TnxAbstractCursor.acGetFullName Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function acGetFullName: string; virtual; abstract;
Description

This is acGetFullName, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.acGetTableDescriptor Method

TnxAbstractCursor.acGetTableDescriptor Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function acGetTableDescriptor: TnxBaseTableDescriptor; virtual; abstract;
Description

This is acGetTableDescriptor, a member of class TnxAbstractCursor.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.acRemoveFromDatabase Method

TnxAbstractCursor.acRemoveFromDatabase Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure acRemoveFromDatabase;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.AfterConstruction Method

TnxAbstractCursor.AfterConstruction Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.AutoIncGet Method

TnxAbstractCursor.AutoIncGet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function AutoIncGet(out aValue: TnxWord32): TnxResult; virtual; abstract;
Description
- autoinc -

This function returns the next AutoInc value for the current table.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.AutoIncSet Method

TnxAbstractCursor.AutoIncSet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function AutoIncSet(aValue: TnxWord32): TnxResult; virtual; abstract;
Description

This function sets the next AutoInc value for the current table.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BeforeDestruction Method

TnxAbstractCursor.BeforeDestruction Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobCreate Method

TnxAbstractCursor.BlobCreate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobCreate(aFieldNo: TnxInt32; out aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

This function creates a new blob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobCreateFile Method

TnxAbstractCursor.BlobCreateFile Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobCreateFile(aFieldNo: TnxInt32; const aFileName: string; out aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

This creates a new FileBlob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobDelete Method

TnxAbstractCursor.BlobDelete Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobDelete(aFieldNo: TnxInt32; const aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

This function deletes the blob with the given aBlobNr.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobFree Method

TnxAbstractCursor.BlobFree Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobFree(aFieldNo: TnxInt32; const aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

This function frees all temporary buffers for this blob.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobGetLength Method

TnxAbstractCursor.BlobGetLength Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobGetLength(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; out aLength: TnxWord32; aReadOrg: Boolean): TnxResult; virtual; abstract;
Description

This function returns the length of the blob in aLengt as bytes.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobModified Method

TnxAbstractCursor.BlobModified Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobModified(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; out aModified: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFieldNo: TnxInt32 | of the field in FieldsDescriptor
const aBlobNr: TnxInt64 | the blob reference number
out aModified: Boolean | will be set to true if the blob has changed
Description

Checks if the given Blob Buffer was modified

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobRead Method

TnxAbstractCursor.BlobRead Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobRead(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; aStream: TStream; aReadOrg: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aBlobNr: TnxInt64 | the blob reference number
aOffset: TnxWord32 | a offset in bytes where to start to read
aLen: TnxWord32 | the number of bytes to read
aBlob | the buffer to receive the data
aBytesRead | the number of bytes returned
Description

This function reads data from a blob.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobsSupportedSelf Method

TnxAbstractCursor.BlobsSupportedSelf Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobsSupportedSelf: Boolean;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobTruncate Method

TnxAbstractCursor.BlobTruncate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobTruncate(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aBlobLength: TnxWord32): TnxResult; virtual; abstract;
Description

This function truncates the given blob at aBlobLength bytes.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BlobWrite Method

TnxAbstractCursor.BlobWrite Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BlobWrite(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; const aBlob): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aBlobNr: TnxInt64 | the blob reference number
aOffset: TnxWord32 | a offset in bytes where to start to write
aLen: TnxWord32 | the number of bytes to write
const aBlob | the data to write
Description

This function writes data to a blob.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.BookmarkAsVariant Method

TnxAbstractCursor.BookmarkAsVariant Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function BookmarkAsVariant(aBookmark: PnxByteArray; aSize: TnxWord32; out aVariant: Variant): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aBookmark: PnxByteArray | the data of the bookmark
aSize: TnxWord32 | size of the bookmark data
out aVariant: Variant | the new variant value returned
Description

Return a given bookmark as Variant

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.ChangePassword Method

TnxAbstractCursor.ChangePassword Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function ChangePassword(const aNewPassword: UnicodeString): TnxResult; virtual; abstract;
Description

This function changes the password of the table. It fails if the table doesn't us an encryption engine.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.CompareBookmarks Method

TnxAbstractCursor.CompareBookmarks Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function CompareBookmarks(aBookmark1: PnxByteArray; aBookmark2: PnxByteArray; aSize: TnxWord32; out aCompResult: TnxValueRelationship): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aBookmark1: PnxByteArray | first Bookmark
aBookmark2: PnxByteArray | second Bookmark
aSize: TnxWord32 | the size of the bookmarks
out aCompResult: TnxValueRelationship | the var that will receive the result
Description

This function compares two bookmarks.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.CompareKeys Method

TnxAbstractCursor.CompareKeys Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function CompareKeys(aFieldCount: Integer; aPartialLen: Integer; aDirectKey1: Boolean; aKeyData1: PnxByteArray; aDirectKey2: Boolean; aKeyData2: PnxByteArray; out aResult: TnxValueRelationship): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFieldCount: Integer | number of fields to be compared. 0 = all fields
aPartialLen: Integer | number of characters yo compare for the last field. 0 = no partial compare
aDirectKey1: Boolean | True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData1: PnxByteArray | The data according to the format defined by aDirectKey1.
aDirectKey2: Boolean | True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData2: PnxByteArray | The data according to the format defined by aDirectKey2.
out aResult: TnxValueRelationship | returns the result of the comparison.
Description

CompareKeys compares 2 keys.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.CopyRecords Method

TnxAbstractCursor.CopyRecords Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function CopyRecords(aDestCursor: TnxAbstractCursor; aBlobCopyMode: TnxBlobCopyMode; aMaxTransSize: Integer): TnxResult; virtual; abstract;
Description

This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.CopyRecordsEx Method

TnxAbstractCursor.CopyRecordsEx Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function CopyRecordsEx(aDestCursor: TnxAbstractCursor; aBlobCopyMode: TnxBlobCopyMode; aMaxTransSize: Integer; aCheckValFields: Boolean): TnxResult; virtual; abstract;
Description

This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed. aCheckValFields determines wether a check is done for required fields having a value.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.CreateInstanceFor Method

TnxAbstractCursor.CreateInstanceFor Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.DeleteRecords Method

TnxAbstractCursor.DeleteRecords Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function DeleteRecords: TnxResult; virtual; abstract;
Description

This function deletes *all* visible (in regards of ranges and filters) records.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.Duplicate Method

TnxAbstractCursor.Duplicate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function Duplicate(aOpenMode: TnxOpenMode; out aNewCursor: TnxAbstractCursor): TnxResult; virtual; abstract;
Description

This function clones the current cursor and returns a new instance in aNewCursor. The new cursor can be opened with a different mode by specifying the aOpenMode accordingly.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterActivate Method

TnxAbstractCursor.FilterActivate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterActivate(aFilterID: TnxFilterID): TnxResult; virtual; abstract;
Description

This function sets the given Filter to active.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterAddCallback Method

TnxAbstractCursor.FilterAddCallback Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterAddCallback(aCookie: Pointer; aCallback: TnxFilterCallback; out aFilterID: TnxFilterID): TnxResult; virtual;
Description

Adds a new callback function to the filter valuation list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterAddCustom Method

TnxAbstractCursor.FilterAddCustom Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterAddCustom(aFilter: TnxBaseFilterDescriptor; out aFilterID: TnxFilterID): TnxResult; virtual; abstract;
Description

Adds a new filter to the filter evaluation list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterAddExpression Method

TnxAbstractCursor.FilterAddExpression Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterAddExpression(aExpression: pCANExpr; out aFilterID: TnxFilterID): TnxResult; virtual;
Description

FilterAddExpression creates a new Filter instance for the given aExpression and returns its in aFilterID.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterDeactivate Method

TnxAbstractCursor.FilterDeactivate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterDeactivate(aFilterID: TnxFilterID): TnxResult; virtual; abstract;
Description

This function sets the given Filter to inactive.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterRemove Method

TnxAbstractCursor.FilterRemove Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterRemove(aFilterID: TnxFilterID): TnxResult; virtual; abstract;
Description

This function removes the given Filter from the internal list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.FilterSetTimeout Method

TnxAbstractCursor.FilterSetTimeout Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function FilterSetTimeout(aTimeout: TnxWord32): TnxResult; virtual; abstract;
Description

This function sets the timeout for the filter evaluation in msec.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetBookmark Method

TnxAbstractCursor.GetBookmark Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetBookmark(aBookmark: PnxByteArray; aSize: TnxWord32): TnxResult; virtual; abstract;
Description
- bookmarks -

This function creates a new bookmark Paremeters: aBookmark - a buffer to receive the Bookmark data aSize - the size of the given buffer

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetCursorSelf Method

TnxAbstractCursor.GetCursorSelf Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetCursorSelf: TObject;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetExceptionData Method

TnxAbstractCursor.GetExceptionData Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldAsVariantSelf Method

TnxAbstractCursor.GetFieldAsVariantSelf Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldAsVariantSelf(aBuffer: PnxByteArray; aField: Integer): OleVariant; virtual;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldCountRedirect Method

TnxAbstractCursor.GetFieldCountRedirect Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldCountRedirect: Integer;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldDescriptorRedirect Method

TnxAbstractCursor.GetFieldDescriptorRedirect Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldDescriptorRedirect(aIndex: Integer): InxFieldDescriptor;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldForFilterRedirect Method

TnxAbstractCursor.GetFieldForFilterRedirect Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldForFilterRedirect(aField: Integer; aName: PAnsiChar; aData: PnxByteArray; out aType: TnxWord16; out aSize: TnxWord16; out aIsNull: Boolean; out aValue: Pointer; out aCodePage: TnxWord16): Boolean;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldFromNameRedirect Method

TnxAbstractCursor.GetFieldFromNameRedirect Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldFromNameRedirect(const aFieldName: string): Integer;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetFieldsOffsetRedirect Method

TnxAbstractCursor.GetFieldsOffsetRedirect Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetFieldsOffsetRedirect: integer;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetIndexID Method

TnxAbstractCursor.GetIndexID Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetIndexID(out aIndexID: Integer): TnxResult; virtual; abstract;
Description

This function returns the id of the current index.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetRecordCount Method

TnxAbstractCursor.GetRecordCount Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCount(out aRecCount: TnxWord32; aEstimate: Boolean = False): TnxResult; virtual; abstract;
Description

GetRecordCount returns the number of currently "visible" records. It obeys set ranges and filters.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetRecordCountAsync Method

TnxAbstractCursor.GetRecordCountAsync Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountAsync(out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This function is an asynchronous version of GetRecordCount.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetRecordCountEx Method

TnxAbstractCursor.GetRecordCountEx Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountEx(aOption: TnxRecordCountOption; out aRecCount: TnxWord32; aEstimate: Boolean = False): TnxResult; virtual; abstract;
Description

GetRecordCountEx returns the number of records or keys based on the value of aOption.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.GetRecordCountExAsync Method

TnxAbstractCursor.GetRecordCountExAsync Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function GetRecordCountExAsync(aOption: TnxRecordCountOption; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This function is an asynchronous version of GetRecordCountEx.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterActivate Method

TnxAbstractCursor.KeyFilterActivate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterActivate(aKeyFilterID: TnxKeyFilterID): TnxResult; virtual; abstract;
Description

This function sets the given KeyFilter to active.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterAddCallback Method

TnxAbstractCursor.KeyFilterAddCallback Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterAddCallback(aCookie: Pointer; aCallback: TnxFilterCallback; out aKeyFilterID: TnxKeyFilterID): TnxResult; virtual;
Description

Adds a new callback function to the filter valuation list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterAddCustom Method

TnxAbstractCursor.KeyFilterAddCustom Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterAddCustom(aKeyFilter: TnxBaseFilterDescriptor; out aKeyFilterID: TnxKeyFilterID): TnxResult; virtual; abstract;
Description

Adds a new filter to the filter evaluation list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterAddExpression Method

TnxAbstractCursor.KeyFilterAddExpression Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterAddExpression(aExpression: pCANExpr; out aKeyFilterID: TnxKeyFilterID): TnxResult; virtual;
Description

KeyFilterAddExpression creates a new KeyFilter instance for the given aExpression and returns its in aKeyFilterID.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterDeactivate Method

TnxAbstractCursor.KeyFilterDeactivate Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterDeactivate(aKeyFilterID: TnxKeyFilterID): TnxResult; virtual; abstract;
Description

This function sets the given KeyFilter to inactive.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.KeyFilterRemove Method

TnxAbstractCursor.KeyFilterRemove Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function KeyFilterRemove(aKeyFilterID: TnxKeyFilterID): TnxResult; virtual; abstract;
Description

This function removes the given KeyFilter from the internal list.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RangeReset Method

TnxAbstractCursor.RangeReset Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RangeReset: TnxResult; virtual; abstract;
Description

This function cancels the active range.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RangeSet Method

TnxAbstractCursor.RangeSet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RangeSet(aFieldCount1: Integer; aPartialLen1: Integer; aDirectKey1: Boolean; aKeyData1: PnxByteArray; aKeyIncl1: Boolean; aFieldCount2: Integer; aPartialLen2: Integer; aDirectKey2: Boolean; aKeyData2: PnxByteArray; aKeyIncl2: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFieldCount1: Integer | For start of the range, number of fields to be compared. 0 = all fields
aPartialLen1: Integer | For start of the range, number of characters yo compare for the last field. 0 = no partial compare
aDirectKey1: Boolean | For start of the range, True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData1: PnxByteArray | For start of the range, The data according to the format defined by aDirectKey1.
aKeyIncl1: Boolean | For start of the range, does the range include the key or starts after the key?
aFieldCount2: Integer | For end of the range, number of fields to be compared. 0 = all fields
aPartialLen2: Integer | For end of the range, number of characters yo compare for the last field. 0 = no partial compare
aDirectKey2: Boolean | For end of the range, True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData2: PnxByteArray | For end of the range, The data according to the format defined by aDirectKey2.
aKeyIncl2: Boolean | For end of the range, does the range include the key or starts after the key?
Description

Sets a range on the current cursor

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecNoGet Method

TnxAbstractCursor.RecNoGet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecNoGet(out aRecNo: TnxWord32; aFlipOrder: Boolean): TnxResult; virtual; abstract;
Description

Returns the RecNo (Position) of the current record according to the current Index, Range and Filter(s). (using filters/indices is not recommended if that table (subset) contains more than a few data pages of records!).

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecNoSet Method

TnxAbstractCursor.RecNoSet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecNoSet(aRecNo: TnxWord32; aFlipOrder: Boolean): TnxResult; virtual; abstract;
Description

Sets the current position according to the RecNo

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecNoSupported Method

TnxAbstractCursor.RecNoSupported Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecNoSupported: TnxResult; virtual; abstract;
Description

Returns DBIERR_NONE if RecNo is supported.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordBufferAlloc Method

TnxAbstractCursor.RecordBufferAlloc Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordBufferAlloc: PnxByteArray; virtual;
Description

helper functions for record buffer management

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordBufferClear Method

TnxAbstractCursor.RecordBufferClear Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure RecordBufferClear(aBuffer: PnxByteArray); virtual;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordBufferFree Method

TnxAbstractCursor.RecordBufferFree Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure RecordBufferFree(aBuffer: PnxByteArray); virtual;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordDelete Method

TnxAbstractCursor.RecordDelete Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordDelete(aData: PnxByteArray): TnxResult; virtual; abstract;
Description

RecordDelete deletes the current record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordGet Method

TnxAbstractCursor.RecordGet Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordGet(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

RecordGet returns a pointer to the current record buffer. It needs to be able to acquire the given lock type for this function to be successful.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordGetBatch Method

TnxAbstractCursor.RecordGetBatch Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordGetBatch(aCutoffSize: Integer; aOptions: TnxRecordGetBatchExOptions; aStream: TnxMemoryStream; aMaxRecords: Integer = -1; aForward: Boolean = True): TnxResult; virtual; abstract;
Description

This function returns a batch of record data in a Stream. aCutoffSize - the maximum length to return in bytes. aOptions - the (blob/bookmark) options to use for filling the stream aStream - the stream that receives the data aMaxRecords - the maximum number of records to return.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordGetForKey Method

TnxAbstractCursor.RecordGetForKey Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordGetForKey(aFieldCount: Integer; aPartialLen: Integer; aDirectKey: Boolean; aKeyData: PnxByteArray; aData: PnxByteArray; aMatchFirst: Boolean; aFirstCall: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFieldCount: Integer | number of fields to be compared. 0 = all fields
aPartialLen: Integer | number of characters yo compare for the last field. 0 = no partial compare
aDirectKey: Boolean | True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData: PnxByteArray | The data according to the format defined by aDirectKey.
aData: PnxByteArray | used to return the record once it has been found. can be nil.
aMatchFirst: Boolean | matches the first (True) or lsat (False) record that matches the key.
aFirstCall: Boolean | must be true on the first call. If the function returns DBIERR_NX_FILTERTIMEOUT keep calling the function with the same parameters and aFirstCall set to false till another result is returned.
Description

RecordGetForKey positions the cursor on the first/last record that matches the passed in key and returns the record.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordGetNext Method

TnxAbstractCursor.RecordGetNext Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordGetNext(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

RecordGet moves to the next valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordGetPrior Method

TnxAbstractCursor.RecordGetPrior Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordGetPrior(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

RecordGet moves to the prior valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordInsert Method

TnxAbstractCursor.RecordInsert Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordInsert(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

RecordInsert creates a new record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordInsertBatch Method

TnxAbstractCursor.RecordInsertBatch Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordInsertBatch(aStream: TnxCustomMemoryStream): TnxResult; virtual; abstract;
Description

This function adds the data in a aStream as new records. Please note that the size of aStream must be a multiple of the record size.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordIsLocked Method

TnxAbstractCursor.RecordIsLocked Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordIsLocked(aLockType: TnxLockType; out aLockPresent: TnxLockPresent): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aLockType: TnxLockType | the type of lock you want to check.
out aLockPresent: TnxLockPresent | the state of the given lock type
Description

RecordIsLocked returns the current record lock state for a certain lock type.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordLockRelease Method

TnxAbstractCursor.RecordLockRelease Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordLockRelease(aAllLocks: Boolean): TnxResult; virtual; abstract;
Description

This function releases the last lock or alternatively all locks in the record.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RecordModify Method

TnxAbstractCursor.RecordModify Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function RecordModify(aData: PnxByteArray; aReleaseLock: boolean): TnxResult; virtual; abstract;
Description

RecordInsert sets the record buffer to the given data. The record must have a proper lock acquired for this function to succeed. If aReleaseLock is true all locks on the current record are released.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.RequestNestedTransactions Method

TnxAbstractCursor.RequestNestedTransactions Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure RequestNestedTransactions; virtual;
Description

This function can be called from an extender to request that the cursor uses nested transactions for all operations. By default this is not supported.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetFieldAsVariantSelf Method

TnxAbstractCursor.SetFieldAsVariantSelf Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure SetFieldAsVariantSelf(aBuffer: PnxByteArray; aField: Integer; const aValue: OleVariant); virtual;
Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToBegin Method

TnxAbstractCursor.SetToBegin Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToBegin: TnxResult; virtual; abstract;
Description
- navigation -

This function sets the cursor position to the begin of the dataset. This is not the first record but before it!

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToBookmark Method

TnxAbstractCursor.SetToBookmark Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToBookmark(aBookmark: PnxByteArray; aSize: TnxWord32): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aBookmark: PnxByteArray | the data of the bookmark
aSize: TnxWord32 | size of the bookmark data
Description

This function will position the cursor on the given bookmark

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToCursor Method

TnxAbstractCursor.SetToCursor Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToCursor(aCursor: TnxAbstractCursor): TnxResult; virtual; abstract;
Description

This function synchronizes the position with the given aCursor. Please note that the two cursor have to point to the same dataset.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToEnd Method

TnxAbstractCursor.SetToEnd Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToEnd: TnxResult; virtual; abstract;
Description

This function sets the cursor position to the end of the dataset. This is NOT the last record but after it!

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToFilter Method

TnxAbstractCursor.SetToFilter Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToFilter(aFilter: TnxBaseFilterDescriptor; aKeyFilter: TnxBaseFilterDescriptor; aForward: TnxBoolean): TnxResult; virtual; abstract;
Description

This function sets the cursor position before the first record that meets the filter criteria in aFilter.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SetToKey Method

TnxAbstractCursor.SetToKey Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SetToKey(aSearchAction: TnxSearchKeyAction; aFieldCount: Integer; aPartialLen: Integer; aDirectKey: Boolean; aKeyData: PnxByteArray): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aSearchAction: TnxSearchKeyAction | defines the relationship between the passed in key and the key the cursor is positioned on.
aFieldCount: Integer | number of fields to be compared. 0 = all fields
aPartialLen: Integer | number of characters yo compare for the last field. 0 = no partial compare
aDirectKey: Boolean | True = passed in data is directly a key, False = passed in data is a record and the key is extracted.
aKeyData: PnxByteArray | The data according to the format defined by aDirectKey.
Description

SetToKey positions the cursor relative to a specific key, The cursor is always positioned on a crack. For skaEqualLast, skaSmallerEqual and skaSmaller it's the crack after the matching key, otherwise the crack before.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.SwitchToIndex Method

TnxAbstractCursor.SwitchToIndex Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function SwitchToIndex(const aIndexName: string; aIndexID: Integer; aPosnOnRec: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aIndexName: string | the name of the index
aIndexID: Integer | the id of the index in the dictionary
aPosnOnRec: Boolean | if true it keeps the current record active
Description

SwitchToIndex activates the given index. It aPosOnRec it repositions the cursor to the record active before changing the index, otherwise it jumps to the first record.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableIsLocked Method

TnxAbstractCursor.TableIsLocked Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableIsLocked(aLockType: TnxLockType; out aLockPresent: TnxLockPresent): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aLockType: TnxLockType | the type of lock you want to check.
out aLockPresent: TnxLockPresent | the state of the given lock type
Description

TableIsLocked returns the current table lock state for a certain lock type.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableLockAcquire Method

TnxAbstractCursor.TableLockAcquire Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableLockAcquire(aLockType: TnxLockType): TnxResult; virtual; abstract;
Description

This function will try to acquire a table lock with the given aLockType.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableLockRelease Method

TnxAbstractCursor.TableLockRelease Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableLockRelease(aLockType: TnxLockType; aAllLocks: Boolean): TnxResult; virtual; abstract;
Description

This function will release an acquired lock with the given aLockType or alternatively (if aAllLocks is true) all locks on the table.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableStreamDelete Method

TnxAbstractCursor.TableStreamDelete Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableStreamDelete(const aName: string): TnxResult; virtual; abstract;
Description

This function deletes the table stream with the given aName.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableStreamGetList Method

TnxAbstractCursor.TableStreamGetList Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableStreamGetList(aStreams: TStrings): TnxResult; virtual; abstract;
Description

This function returns the names of all streams stored with the table.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableStreamRead Method

TnxAbstractCursor.TableStreamRead Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableStreamRead(const aName: string; aStream: TStream): TnxResult; virtual; abstract;
Description

This function reads the WHOLE stream with the given name into aStream.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor.TableStreamWrite Method

TnxAbstractCursor.TableStreamWrite Method
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Methods Send Feedback
Syntax
Delphi
function TableStreamWrite(const aName: string; aStream: TStream): TnxResult; virtual; abstract;
Description

This function rewrites the WHOLE stream with the given name.

Group

TnxAbstractCursor Methods

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Methods


TnxAbstractCursor Properties

TnxAbstractCursor Properties
TnxAbstractCursor Class Legend Protected Properties Public Properties Send Feedback

The properties of the TnxAbstractCursor class are listed here.

Class

TnxAbstractCursor Class

Protected Properties
Name | Description
FieldsDescriptor | InxFieldsSource
Public Properties
Name | Description
_Dictionary | This property returns the data dictionary for this cursor.
Database | This property returns the database the cursor is linked to.
DatabaseNext | Returns the next cursor in the list of cursor of the current database.
DatabasePrev | Returns the previous cursor in the list of cursor of the current database.
FullName | Returns the full table name in relation to master and sub tables.
TableDescriptor | Returns the TableDescriptor instance in the data dictionary associated with the cursor.
Links
TnxAbstractCursor Class, Legend, Protected Properties, Public Properties


TnxAbstractCursor._Dictionary Property

TnxAbstractCursor._Dictionary Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property _Dictionary: TnxDataDictionary;
Description

This property returns the data dictionary for this cursor.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.Database Property

TnxAbstractCursor.Database Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property Database: TnxAbstractDatabase;
Description

This property returns the database the cursor is linked to.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.DatabaseNext Property

TnxAbstractCursor.DatabaseNext Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property DatabaseNext: TnxAbstractCursor;
Description

Returns the next cursor in the list of cursor of the current database.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.DatabasePrev Property

TnxAbstractCursor.DatabasePrev Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property DatabasePrev: TnxAbstractCursor;
Description

Returns the previous cursor in the list of cursor of the current database.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.FieldsDescriptor Property

TnxAbstractCursor.FieldsDescriptor Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property FieldsDescriptor: TnxFieldsDescriptor;
Description

InxFieldsSource

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.FullName Property

TnxAbstractCursor.FullName Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property FullName: string;
Description

Returns the full table name in relation to master and sub tables.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractCursor.TableDescriptor Property

TnxAbstractCursor.TableDescriptor Property
TnxAbstractCursor Class TnxAbstractCursor Members nxsdServerEngine Namespace TnxAbstractCursor Properties Send Feedback
Syntax
Delphi
property TableDescriptor: TnxBaseTableDescriptor;
Description

Returns the TableDescriptor instance in the data dictionary associated with the cursor.

Group

TnxAbstractCursor Properties

Links
TnxAbstractCursor Class, TnxAbstractCursor Members, nxsdServerEngine Namespace, TnxAbstractCursor Properties


TnxAbstractDatabase Class

TnxAbstractDatabase Class
TnxAbstractDatabase Fields TnxAbstractDatabase Methods TnxAbstractDatabase Properties TnxAbstractDatabase Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabasenxsdServerEngine_TnxAbstractDatabase
Syntax
Delphi
TnxAbstractDatabase = class(TnxBaseTransContext);
File

nxsdServerEngine

Description

The abstract declaration of a Server Database. All actual database implementations MUST be descendent from this class. This is the server side version of TnxDatabase.

Group

Classes

Links
TnxAbstractDatabase Fields, TnxAbstractDatabase Methods, TnxAbstractDatabase Properties, TnxAbstractDatabase Members, nxsdServerEngine, Classes


TnxAbstractDatabase Members

TnxAbstractDatabase Members
TnxAbstractDatabase Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractDatabase.

Class

TnxAbstractDatabase Class

Protected Fields
Name | Description
adCursorAutoFree | This is adCursorAutoFree, a member of class TnxAbstractDatabase.
adCursorsHead | This is adCursorsHead, a member of class TnxAbstractDatabase.
adCursorsPadlock | This is adCursorsPadlock, a member of class TnxAbstractDatabase.
adCursorsTail | This is adCursorsTail, a member of class TnxAbstractDatabase.
adLockedIncDone | This is adLockedIncDone, a member of class TnxAbstractDatabase.
adOwnedTransContext | This is adOwnedTransContext, a member of class TnxAbstractDatabase.
adSessionNext | This is adSessionNext, a member of class TnxAbstractDatabase.
adSessionPrev | private
adStatementsHead | This is adStatementsHead, a member of class TnxAbstractDatabase.
adStatementsPadlock | This is adStatementsPadlock, a member of class TnxAbstractDatabase.
adStatementsTail | This is adStatementsTail, a member of class TnxAbstractDatabase.
adTransContext | This is adTransContext, a member of class TnxAbstractDatabase.
adTransContextNext | This is adTransContextNext, a member of class TnxAbstractDatabase.
adTransContextPrev | This is adTransContextPrev, a member of class TnxAbstractDatabase.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
adAddToSession | TnxAbstractDatabase
adAddToTransContext |
adRemoveFromSession |
adRemoveFromTransContext |
adTransContextDestroying |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent | options
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create | constructor
CreateInstanceFor | remoting integration
CursorOpen | This function opens a new cursor for a table and returns an instance of a descendent of TnxAbstractCursor. Each table can have as many Cursors as wanted active at the same time
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetChangedTables | Returns the names of tables the have been changed since this function was last called.
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFreespace | This function returns the free space of the device the database is stored on. Result is in bytes.
GetLifetimeMontior |
GetPath | Returns the (file) path of the current database.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
RegisterCursorSource | cursor source
StatementAlloc | This function creates a new instance of a SQL statement. It does NOT execute the query! Paremeters: aStatement: the returned statement instance aTimeout: the timeout for the new statement in msec
StatementExecDirect | This function creates and exexutes a given SQL query or stored procedure and returns a cursor to the result set.
TableAddField | With TableAddField you can add a new field without restructure. May fail.
TableAddIndex | With TableAddIndex you can create a new index.
TableAutoIncGet | This function returns the next AutoInc value for the specified table.
TableBackup | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. The original data dictionary is added as a tablestream.
TableBuild | This function creates a new table.
TableChangePassword | This function changes the password of the table with the given aTableName.
TableDelete | This function deletes the table with the given aTableName.
TableDropIndex | This function deletes an index.
TableEmpty | This function deletes all records from the table with the given aTableName.
TableExists |
TableGetDictionary | With TableGetDictionary you can fill a TnxDataDictionary instance with the information about an existing table.
TableGetList | TableGetList fills the given aList with all table names of the current database.
TablePack | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one.
TableRebuildIndex | ReIndexTable starts an asynchronous re indexing of a certain index of a table.
TableRecover | This function walks all the blocks in the table on disk, and copies healthy records to aTableName_recovered, and copies bad records to aTableName_Failed.
TableRename | This function renames a table from aOldName to aNewName, it the table is not in use.
TableRestructure | With this method you can start an asynchronous restructure of a given table.
TableVerifyChecksum | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
ExplicitAllowSystem | This is ExplicitAllowSystem, a member of class TnxAbstractDatabase.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
TransContext | This property returns the transaction context the database is linked to.
Links
TnxAbstractDatabase Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractDatabase.Create Constructor

TnxAbstractDatabase.Create Constructor
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxAbstractSession; aTransContext: TnxAbstractTransContext; aTimeout: TnxWord32);
Parameters
Parameters | Description
aSession: TnxAbstractSession | the session object the database belongs to
aTransContext: TnxAbstractTransContext | the transaction context this database belongs to. If no transaction context is passed in a new one will be created.
aTimeout: TnxWord32 | the timeout for this database in msec
Description

constructor

Class

TnxAbstractDatabase Class

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Class


TnxAbstractDatabase.Destroy Destructor

TnxAbstractDatabase.Destroy Destructor
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractDatabase Class

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Class


TnxAbstractDatabase Fields

TnxAbstractDatabase Fields
TnxAbstractDatabase Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractDatabase class are listed here.

Class

TnxAbstractDatabase Class

Protected Fields
Name | Description
adCursorAutoFree | This is adCursorAutoFree, a member of class TnxAbstractDatabase.
adCursorsHead | This is adCursorsHead, a member of class TnxAbstractDatabase.
adCursorsPadlock | This is adCursorsPadlock, a member of class TnxAbstractDatabase.
adCursorsTail | This is adCursorsTail, a member of class TnxAbstractDatabase.
adLockedIncDone | This is adLockedIncDone, a member of class TnxAbstractDatabase.
adOwnedTransContext | This is adOwnedTransContext, a member of class TnxAbstractDatabase.
adSessionNext | This is adSessionNext, a member of class TnxAbstractDatabase.
adSessionPrev | private
adStatementsHead | This is adStatementsHead, a member of class TnxAbstractDatabase.
adStatementsPadlock | This is adStatementsPadlock, a member of class TnxAbstractDatabase.
adStatementsTail | This is adStatementsTail, a member of class TnxAbstractDatabase.
adTransContext | This is adTransContext, a member of class TnxAbstractDatabase.
adTransContextNext | This is adTransContextNext, a member of class TnxAbstractDatabase.
adTransContextPrev | This is adTransContextPrev, a member of class TnxAbstractDatabase.
Links
TnxAbstractDatabase Class, Legend, Protected Fields


TnxAbstractDatabase.adCursorAutoFree Field

TnxAbstractDatabase.adCursorAutoFree Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adCursorAutoFree: Boolean;
Description

This is adCursorAutoFree, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adCursorsHead Field

TnxAbstractDatabase.adCursorsHead Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adCursorsHead: TnxAbstractCursor;
Description

This is adCursorsHead, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adCursorsPadlock Field

TnxAbstractDatabase.adCursorsPadlock Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adCursorsPadlock: TnxPadlock;
Description

This is adCursorsPadlock, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adCursorsTail Field

TnxAbstractDatabase.adCursorsTail Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adCursorsTail: TnxAbstractCursor;
Description

This is adCursorsTail, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adLockedIncDone Field

TnxAbstractDatabase.adLockedIncDone Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adLockedIncDone: Boolean;
Description

This is adLockedIncDone, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adOwnedTransContext Field

TnxAbstractDatabase.adOwnedTransContext Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adOwnedTransContext: TnxAbstractTransContext;
Description

This is adOwnedTransContext, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adSessionNext Field

TnxAbstractDatabase.adSessionNext Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adSessionNext: TnxAbstractDatabase;
Description

This is adSessionNext, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adSessionPrev Field

TnxAbstractDatabase.adSessionPrev Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adSessionPrev: TnxAbstractDatabase;
Description

private

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adStatementsHead Field

TnxAbstractDatabase.adStatementsHead Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adStatementsHead: TnxAbstractStatement;
Description

This is adStatementsHead, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adStatementsPadlock Field

TnxAbstractDatabase.adStatementsPadlock Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adStatementsPadlock: TnxPadlock;
Description

This is adStatementsPadlock, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adStatementsTail Field

TnxAbstractDatabase.adStatementsTail Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adStatementsTail: TnxAbstractStatement;
Description

This is adStatementsTail, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adTransContext Field

TnxAbstractDatabase.adTransContext Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adTransContext: TnxAbstractTransContext;
Description

This is adTransContext, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adTransContextNext Field

TnxAbstractDatabase.adTransContextNext Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adTransContextNext: TnxAbstractDatabase;
Description

This is adTransContextNext, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase.adTransContextPrev Field

TnxAbstractDatabase.adTransContextPrev Field
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Fields Send Feedback
Syntax
Delphi
adTransContextPrev: TnxAbstractDatabase;
Description

This is adTransContextPrev, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Fields

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Fields


TnxAbstractDatabase Methods

TnxAbstractDatabase Methods
TnxAbstractDatabase Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractDatabase class are listed here.

Class

TnxAbstractDatabase Class

Protected Methods
Name | Description
adAddToSession | TnxAbstractDatabase
adAddToTransContext |
adRemoveFromSession |
adRemoveFromTransContext |
adTransContextDestroying |
atoSetTimeout |
esoGetOptionsParent | options
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
BeforeDestruction | see TObject.BeforeConstruction
CreateInstanceFor | remoting integration
CursorOpen | This function opens a new cursor for a table and returns an instance of a descendent of TnxAbstractCursor. Each table can have as many Cursors as wanted active at the same time
GetChangedTables | Returns the names of tables the have been changed since this function was last called.
GetFreespace | This function returns the free space of the device the database is stored on. Result is in bytes.
GetPath | Returns the (file) path of the current database.
PrepareDestroy |
RegisterCursorSource | cursor source
StatementAlloc | This function creates a new instance of a SQL statement. It does NOT execute the query! Paremeters: aStatement: the returned statement instance aTimeout: the timeout for the new statement in msec
StatementExecDirect | This function creates and exexutes a given SQL query or stored procedure and returns a cursor to the result set.
TableAddField | With TableAddField you can add a new field without restructure. May fail.
TableAddIndex | With TableAddIndex you can create a new index.
TableAutoIncGet | This function returns the next AutoInc value for the specified table.
TableBackup | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. The original data dictionary is added as a tablestream.
TableBuild | This function creates a new table.
TableChangePassword | This function changes the password of the table with the given aTableName.
TableDelete | This function deletes the table with the given aTableName.
TableDropIndex | This function deletes an index.
TableEmpty | This function deletes all records from the table with the given aTableName.
TableExists |
TableGetDictionary | With TableGetDictionary you can fill a TnxDataDictionary instance with the information about an existing table.
TableGetList | TableGetList fills the given aList with all table names of the current database.
TablePack | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one.
TableRebuildIndex | ReIndexTable starts an asynchronous re indexing of a certain index of a table.
TableRecover | This function walks all the blocks in the table on disk, and copies healthy records to aTableName_recovered, and copies bad records to aTableName_Failed.
TableRename | This function renames a table from aOldName to aNewName, it the table is not in use.
TableRestructure | With this method you can start an asynchronous restructure of a given table.
TableVerifyChecksum | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Links
TnxAbstractDatabase Class, Legend, Protected Methods, Public Methods


TnxAbstractDatabase.adAddToSession Method

TnxAbstractDatabase.adAddToSession Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure adAddToSession;
Description

TnxAbstractDatabase

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.adAddToTransContext Method

TnxAbstractDatabase.adAddToTransContext Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure adAddToTransContext;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.adRemoveFromSession Method

TnxAbstractDatabase.adRemoveFromSession Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure adRemoveFromSession;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.adRemoveFromTransContext Method

TnxAbstractDatabase.adRemoveFromTransContext Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure adRemoveFromTransContext;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.adTransContextDestroying Method

TnxAbstractDatabase.adTransContextDestroying Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure adTransContextDestroying;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.AfterConstruction Method

TnxAbstractDatabase.AfterConstruction Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.atoSetTimeout Method

TnxAbstractDatabase.atoSetTimeout Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); override;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.BeforeDestruction Method

TnxAbstractDatabase.BeforeDestruction Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.CreateInstanceFor Method

TnxAbstractDatabase.CreateInstanceFor Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.CursorOpen Method

TnxAbstractDatabase.CursorOpen Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function CursorOpen(out aCursor: TnxAbstractCursor; const aTableName: string; const aPassword: UnicodeString; aOpenMode: TnxOpenMode; aShareMode: TnxShareMode; aTimeout: TnxWord32; aAllowSystem: Boolean = False): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aCursor: TnxAbstractCursor | the returned instance
const aTableName: string | the name of the table the cursor should be created for
aOpenMode: TnxOpenMode | the mode you want to open the cursor for
aShareMode: TnxShareMode | defines how the Cursor should handle sharing
aTimeout: TnxWord32 | the timeout for the cursor in msec
aDictionary | the dictionary of the table the cursor is created for
Description

This function opens a new cursor for a table and returns an instance of a descendent of TnxAbstractCursor. Each table can have as many Cursors as wanted active at the same time

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.esoGetOptionsParent Method

TnxAbstractDatabase.esoGetOptionsParent Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function esoGetOptionsParent: TnxExtendableServerObject; override;
Description

options

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.GetChangedTables Method

TnxAbstractDatabase.GetChangedTables Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function GetChangedTables(aTables: TStrings): TnxResult; virtual; abstract;
Description

Returns the names of tables the have been changed since this function was last called.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.GetExceptionData Method

TnxAbstractDatabase.GetExceptionData Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.GetFreespace Method

TnxAbstractDatabase.GetFreespace Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function GetFreespace(out aFreeSpace: TnxInt64): TnxResult; virtual; abstract;
Description

This function returns the free space of the device the database is stored on. Result is in bytes.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.GetPath Method

TnxAbstractDatabase.GetPath Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function GetPath(out aPath: string): TnxResult; virtual; abstract;
Description

Returns the (file) path of the current database.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.PrepareDestroy Method

TnxAbstractDatabase.PrepareDestroy Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; override;
Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.RegisterCursorSource Method

TnxAbstractDatabase.RegisterCursorSource Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function RegisterCursorSource(aSource: InxDatabaseCursorSource; out aControl: InxDatabaseCursorSourceControl): TnxResult; virtual;
Description

cursor source

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.StatementAlloc Method

TnxAbstractDatabase.StatementAlloc Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function StatementAlloc(out aStatement: TnxAbstractStatement; aTimeout: TnxWord32): TnxResult; virtual; abstract;
Description

This function creates a new instance of a SQL statement. It does NOT execute the query! Paremeters: aStatement: the returned statement instance aTimeout: the timeout for the new statement in msec

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.StatementExecDirect Method

TnxAbstractDatabase.StatementExecDirect Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function StatementExecDirect(aTimeout: TnxWord32; aStatementType: TnxStatementType; const aQueryText: WideString; aPrepareStream: TStream; const aParams: TnxSqlParamList; aSetParamsStream: TStream; out aCursor: TnxAbstractCursor; aOpenMode: TnxOpenMode; aExecStream: TStream; aGetParamsStream: TStream; out aPhase: TnxStatementExecDirectPhase): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aTimeout: TnxWord32 | Timeout in ms
aStatementType: TnxStatementType | indicates if this is a stored procedure or standard query
const aQueryText: WideString | the SQL query
aPrepareStream: TStream | data returned by the prepare phase
const aParams: TnxSqlParamList | the list of parameter defintions used for preparing and executing
aSetParamsStream: TStream | data returned by the setparams phase
out aCursor: TnxAbstractCursor | the new cursor returned
aOpenMode: TnxOpenMode | the open mode for the cursor
aExecStream: TStream | data returned by the exec phase
aGetParamsStream: TStream | out-parameter stream
out aPhase: TnxStatementExecDirectPhase | returns the phase the query is in
Description

This function creates and exexutes a given SQL query or stored procedure and returns a cursor to the result set.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableAddField Method

TnxAbstractDatabase.TableAddField Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableAddField(const aTableName: string; const aPassword: UnicodeString; aFieldDesc: TnxFieldDescriptor): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | table name
aFieldDesc: TnxFieldDescriptor | a full field descriptor for the new field
Description

With TableAddField you can add a new field without restructure. May fail.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableAddIndex Method

TnxAbstractDatabase.TableAddIndex Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableAddIndex(const aTableName: string; const aPassword: UnicodeString; aIndexDesc: TnxIndexDescriptor; aNewDefault: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | table name
aIndexDesc: TnxIndexDescriptor | a full index descriptor for the new index
Description

With TableAddIndex you can create a new index.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableAutoIncGet Method

TnxAbstractDatabase.TableAutoIncGet Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableAutoIncGet(const aTableName: string; const aPassword: UnicodeString; out aValue: TnxWord32): TnxResult; virtual; abstract;
Description

This function returns the next AutoInc value for the specified table.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableBackup Method

TnxAbstractDatabase.TableBackup Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableBackup(const aTableName: string; const aPassword: UnicodeString; aTargetDatabase: TnxAbstractDataBase; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aTargetDatabase: TnxAbstractDataBase | The database where the new table with identical name is created
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. The original data dictionary is added as a tablestream.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableBuild Method

TnxAbstractDatabase.TableBuild Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableBuild(aOverWrite: Boolean; const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aTableScope: TnxTableScope; aAllowSystem: Boolean = False): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aOverWrite: Boolean | if true, an existing table is overwritten if it is not in use
const aTableName: string | the name of the new table
aDictionary: TnxDataDictionary | the dictionary that defines the table and index structure
Description

This function creates a new table.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableChangePassword Method

TnxAbstractDatabase.TableChangePassword Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableChangePassword(const aTableName: string; const aOldPassword: UnicodeString; const aNewPassword: UnicodeString): TnxResult; virtual; abstract;
Description

This function changes the password of the table with the given aTableName.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableDelete Method

TnxAbstractDatabase.TableDelete Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableDelete(const aTableName: string; const aPassword: UnicodeString): TnxResult; virtual; abstract;
Description

This function deletes the table with the given aTableName.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableDropIndex Method

TnxAbstractDatabase.TableDropIndex Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableDropIndex(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; aIndexID: Integer): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | the name of the table that holds the index to be deleted.
const aIndexName: string | the name of the index to be deleted
aIndexID: Integer | the id in the list of index descriptors of the index to be deleted.
Description

This function deletes an index.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableEmpty Method

TnxAbstractDatabase.TableEmpty Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableEmpty(const aTableName: string; const aPassword: UnicodeString): TnxResult; virtual; abstract;
Description

This function deletes all records from the table with the given aTableName.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableExists Method

TnxAbstractDatabase.TableExists Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableExists(const aTableName: string; const aPassword: UnicodeString; out aExists: Boolean; aAllowSystem: Boolean = False): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | the table name to check
out aExists: Boolean | the var to be filled with the result.
Description
- table information -

TableExists checks if a table exists.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableGetDictionary Method

TnxAbstractDatabase.TableGetDictionary Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableGetDictionary(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | the name of the source table
aDictionary: TnxDataDictionary | the instance of TnxDataDictionary that should be filled with the information.
Description

With TableGetDictionary you can fill a TnxDataDictionary instance with the information about an existing table.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableGetList Method

TnxAbstractDatabase.TableGetList Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableGetList(aList: TStrings): TnxResult; virtual; abstract;
Description

TableGetList fills the given aList with all table names of the current database.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TablePack Method

TnxAbstractDatabase.TablePack Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TablePack(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableRebuildIndex Method

TnxAbstractDatabase.TableRebuildIndex Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableRebuildIndex(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; aIndexID: Integer; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aIndexName: string | the name of the index
aIndexID: Integer | the id of the index in the index descriptor list.
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aName | table name
Description

ReIndexTable starts an asynchronous re indexing of a certain index of a table.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableRecover Method

TnxAbstractDatabase.TableRecover Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableRecover(const aTableName: string; const aPassword: UnicodeString; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This function walks all the blocks in the table on disk, and copies healthy records to aTableName_recovered, and copies bad records to aTableName_Failed.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableRename Method

TnxAbstractDatabase.TableRename Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableRename(const aOldName: string; const aNewName: string; const aPassword: UnicodeString): TnxResult; virtual; abstract;
Description

This function renames a table from aOldName to aNewName, it the table is not in use.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableRestructure Method

TnxAbstractDatabase.TableRestructure Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableRestructure(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor; const aAllowSystem: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aTableName: string | table name
aDictionary: TnxDataDictionary | new dictionary of the table
const aAllowSystem: Boolean | set to true to allow restructure of system table
out aTaskInfo: TnxAbstractTaskInfo | Task information instance; use TaskInfo.GetStatus to find out the status of the operation.
aFieldMap | defines how fields are mapped from the old to the new structure
Description

With this method you can start an asynchronous restructure of a given table.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TableVerifyChecksum Method

TnxAbstractDatabase.TableVerifyChecksum Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TableVerifyChecksum(const aTableName: string; const aPassword: UnicodeString; aRaw: Boolean; aForceRecheck: Boolean; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionCommit Method

TnxAbstractDatabase.TransactionCommit Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionCommit: TnxResult; override;
Description

This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionCorrupted Method

TnxAbstractDatabase.TransactionCorrupted Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionCorrupted: TnxResult; override;
Description

This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionGetLevel Method

TnxAbstractDatabase.TransactionGetLevel Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionGetLevel(out aTransLevel: Integer): TnxResult; override;
Description

This method returns the nesting level of the current transaction.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionRollback Method

TnxAbstractDatabase.TransactionRollback Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionRollback: TnxResult; override;
Description

Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionStart Method

TnxAbstractDatabase.TransactionStart Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionStart(aFailSafe: Boolean; aSnapShot: Boolean): TnxResult; override;
Parameters
Parameters | Description
aFailSafe: Boolean | if true it must be handled as fail safe.
aSnapShot: Boolean | if true it is handled as a SnapshotTransaction
Description
- transaction management -

StartTransaction tries to start a transaction. If it fails an exception is triggered.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase.TransactionStartWith Method

TnxAbstractDatabase.TransactionStartWith Method
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Methods Send Feedback
Syntax
Delphi
function TransactionStartWith(aFailSafe: Boolean; aSnapShot: Boolean; const aCursors: array of TnxAbstractCursor): TnxResult; override;
Parameters
Parameters | Description
aFailSafe: Boolean | if true it must be handled as fail safe.
aSnapShot: Boolean | if true it is handled as a SnapshotTransaction
const aCursors: array of TnxAbstractCursor | the cursors that should be part of the transaction
Description

Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.

Group

TnxAbstractDatabase Methods

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Methods


TnxAbstractDatabase Properties

TnxAbstractDatabase Properties
TnxAbstractDatabase Class Legend Public Properties Send Feedback

The properties of the TnxAbstractDatabase class are listed here.

Class

TnxAbstractDatabase Class

Public Properties
Name | Description
ExplicitAllowSystem | This is ExplicitAllowSystem, a member of class TnxAbstractDatabase.
TransContext | This property returns the transaction context the database is linked to.
Links
TnxAbstractDatabase Class, Legend, Public Properties


TnxAbstractDatabase.ExplicitAllowSystem Property

TnxAbstractDatabase.ExplicitAllowSystem Property
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Properties Send Feedback
Syntax
Delphi
property ExplicitAllowSystem: boolean;
Description

This is ExplicitAllowSystem, a member of class TnxAbstractDatabase.

Group

TnxAbstractDatabase Properties

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Properties


TnxAbstractDatabase.TransContext Property

TnxAbstractDatabase.TransContext Property
TnxAbstractDatabase Class TnxAbstractDatabase Members nxsdServerEngine Namespace TnxAbstractDatabase Properties Send Feedback
Syntax
Delphi
property TransContext: TnxAbstractTransContext;
Description

This property returns the transaction context the database is linked to.

Group

TnxAbstractDatabase Properties

Links
TnxAbstractDatabase Class, TnxAbstractDatabase Members, nxsdServerEngine Namespace, TnxAbstractDatabase Properties


TnxAbstractSecurityMonitor Class

TnxAbstractSecurityMonitor Class
TnxAbstractSecurityMonitor Fields TnxAbstractSecurityMonitor Methods TnxAbstractSecurityMonitor Properties TnxAbstractSecurityMonitor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitornxsdServerEngine_TnxAbstractSecurityMonitor
Syntax
Delphi
TnxAbstractSecurityMonitor = class(TnxBaseEngineMonitor);
File

nxsdServerEngine

Description

This is the base for all security monitors used in NexusDB.

Group

Classes

Links
TnxAbstractSecurityMonitor Fields, TnxAbstractSecurityMonitor Methods, TnxAbstractSecurityMonitor Properties, TnxAbstractSecurityMonitor Members, nxsdServerEngine, Classes


TnxAbstractSecurityMonitor Members

TnxAbstractSecurityMonitor Members
TnxAbstractSecurityMonitor Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxAbstractSecurityMonitor.

Class

TnxAbstractSecurityMonitor Class

Protected Fields
Name | Description
aseAlwaysLoginAdmins | This is aseAlwaysLoginAdmins, a member of class TnxAbstractSecurityMonitor.
aseMaxSessionCount | This is aseMaxSessionCount, a member of class TnxAbstractSecurityMonitor.
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bemSetServerEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo | TnxAbstractSecurityMonitor
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
Destroy | denstructor
Destroy | destructor
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
ExtendableObjectCreated | This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
HasAdmins | HasAdmins returns true if there are any users defined.
HasUsers | HasUSers returns true if there are any users defined.
IsAdmin | This function returns true if there is an Admin user with the given aUserName and aPassword.
IsUser | This function returns true if there is an User user with the given aUserName and aPassword.
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LogIn | Returns a InxLoggedInUser for the specified UserName and Password, check InxLoggedInUser.IsUser to verify that the username and password could be authenticated.
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | returns always true, cause the User Interface for a Security Monitor should always be visible.
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
AlwaysLoginAdmins | If this is set to true admins can always log in, even though MaxSessionCount is reached.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
MaxSessionCount | Sets the maximum number of users that can be logged in at any given time.
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | This property links the Monitor to a server engine.
Version | Version of the component.
Links
TnxAbstractSecurityMonitor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxAbstractSecurityMonitor Fields

TnxAbstractSecurityMonitor Fields
TnxAbstractSecurityMonitor Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractSecurityMonitor class are listed here.

Class

TnxAbstractSecurityMonitor Class

Protected Fields
Name | Description
aseAlwaysLoginAdmins | This is aseAlwaysLoginAdmins, a member of class TnxAbstractSecurityMonitor.
aseMaxSessionCount | This is aseMaxSessionCount, a member of class TnxAbstractSecurityMonitor.
Links
TnxAbstractSecurityMonitor Class, Legend, Protected Fields


TnxAbstractSecurityMonitor.aseAlwaysLoginAdmins Field

TnxAbstractSecurityMonitor.aseAlwaysLoginAdmins Field
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Fields Send Feedback
Syntax
Delphi
aseAlwaysLoginAdmins: boolean;
Description

This is aseAlwaysLoginAdmins, a member of class TnxAbstractSecurityMonitor.

Group

TnxAbstractSecurityMonitor Fields

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Fields


TnxAbstractSecurityMonitor.aseMaxSessionCount Field

TnxAbstractSecurityMonitor.aseMaxSessionCount Field
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Fields Send Feedback
Syntax
Delphi
aseMaxSessionCount: integer;
Description

This is aseMaxSessionCount, a member of class TnxAbstractSecurityMonitor.

Group

TnxAbstractSecurityMonitor Fields

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Fields


TnxAbstractSecurityMonitor Methods

TnxAbstractSecurityMonitor Methods
TnxAbstractSecurityMonitor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractSecurityMonitor class are listed here.

Class

TnxAbstractSecurityMonitor Class

Protected Methods
Name | Description
nxcCreateComponentInfo | TnxAbstractSecurityMonitor
nxcExceptionClass |
Public Methods
Name | Description
HasAdmins | HasAdmins returns true if there are any users defined.
HasUsers | HasUSers returns true if there are any users defined.
IsAdmin | This function returns true if there is an Admin user with the given aUserName and aPassword.
IsUser | This function returns true if there is an User user with the given aUserName and aPassword.
LogIn | Returns a InxLoggedInUser for the specified UserName and Password, check InxLoggedInUser.IsUser to verify that the username and password could be authenticated.
UIStateVisible | returns always true, cause the User Interface for a Security Monitor should always be visible.
Links
TnxAbstractSecurityMonitor Class, Legend, Protected Methods, Public Methods


TnxAbstractSecurityMonitor.HasAdmins Method

TnxAbstractSecurityMonitor.HasAdmins Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function HasAdmins: Boolean; virtual; abstract;
Description

HasAdmins returns true if there are any users defined.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.HasUsers Method

TnxAbstractSecurityMonitor.HasUsers Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function HasUsers: Boolean; virtual; abstract;
Description

HasUSers returns true if there are any users defined.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.IsAdmin Method

TnxAbstractSecurityMonitor.IsAdmin Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function IsAdmin(const aUserName: UnicodeString; const aPassword: UnicodeString): Boolean; virtual; abstract;
Description

This function returns true if there is an Admin user with the given aUserName and aPassword.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.IsUser Method

TnxAbstractSecurityMonitor.IsUser Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function IsUser(const aUserName: UnicodeString; const aPassword: UnicodeString): Boolean; virtual; abstract;
Description

This function returns true if there is an User user with the given aUserName and aPassword.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.LogIn Method

TnxAbstractSecurityMonitor.LogIn Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function LogIn(const aUserName: UnicodeString; const aPassword: UnicodeString): InxLoggedInUser31000; virtual; abstract;
Description

Returns a InxLoggedInUser for the specified UserName and Password, check InxLoggedInUser.IsUser to verify that the username and password could be authenticated.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.nxcCreateComponentInfo Method

TnxAbstractSecurityMonitor.nxcCreateComponentInfo Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function nxcCreateComponentInfo: InxInterface; override;
Description

TnxAbstractSecurityMonitor

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.nxcExceptionClass Method

TnxAbstractSecurityMonitor.nxcExceptionClass Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
class function nxcExceptionClass: EnxComponentExceptionClass; override;
Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor.UIStateVisible Method

TnxAbstractSecurityMonitor.UIStateVisible Method
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Methods Send Feedback
Syntax
Delphi
function UIStateVisible: Boolean; override;
Description

returns always true, cause the User Interface for a Security Monitor should always be visible.

Group

TnxAbstractSecurityMonitor Methods

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Methods


TnxAbstractSecurityMonitor Properties

TnxAbstractSecurityMonitor Properties
TnxAbstractSecurityMonitor Class Legend Published Properties Send Feedback

The properties of the TnxAbstractSecurityMonitor class are listed here.

Class

TnxAbstractSecurityMonitor Class

Published Properties
Name | Description
AlwaysLoginAdmins | If this is set to true admins can always log in, even though MaxSessionCount is reached.
MaxSessionCount | Sets the maximum number of users that can be logged in at any given time.
Links
TnxAbstractSecurityMonitor Class, Legend, Published Properties


TnxAbstractSecurityMonitor.AlwaysLoginAdmins Property

TnxAbstractSecurityMonitor.AlwaysLoginAdmins Property
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Properties Send Feedback
Syntax
Delphi
property AlwaysLoginAdmins: boolean;
Description

If this is set to true admins can always log in, even though MaxSessionCount is reached.

Group

TnxAbstractSecurityMonitor Properties

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Properties


TnxAbstractSecurityMonitor.MaxSessionCount Property

TnxAbstractSecurityMonitor.MaxSessionCount Property
TnxAbstractSecurityMonitor Class TnxAbstractSecurityMonitor Members nxsdServerEngine Namespace TnxAbstractSecurityMonitor Properties Send Feedback
Syntax
Delphi
property MaxSessionCount: integer;
Description

Sets the maximum number of users that can be logged in at any given time.

Group

TnxAbstractSecurityMonitor Properties

Links
TnxAbstractSecurityMonitor Class, TnxAbstractSecurityMonitor Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitor Properties


TnxAbstractSecurityMonitorComponentInfo Class

TnxAbstractSecurityMonitorComponentInfo Class
TnxAbstractSecurityMonitorComponentInfo Methods TnxAbstractSecurityMonitorComponentInfo Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfonxsdServerEngine_TnxAbstractSecurityMonitorComponentInfo
Syntax
Delphi
TnxAbstractSecurityMonitorComponentInfo = class(TnxStateComponentInfo, InxAbstractSecurityMonitorComponentInfo31000);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.TnxAbstractSecurityMonitorComponentInfo.

Group

Classes

Links
TnxAbstractSecurityMonitorComponentInfo Methods, TnxAbstractSecurityMonitorComponentInfo Members, nxsdServerEngine, Classes


TnxAbstractSecurityMonitorComponentInfo Members

TnxAbstractSecurityMonitorComponentInfo Members
TnxAbstractSecurityMonitorComponentInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractSecurityMonitorComponentInfo.

Class

TnxAbstractSecurityMonitorComponentInfo Class

Protected Fields
Name | Description
ciComponent | private
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Create | TnxAbstractSecurityMonitorComponentInfo
Disconnect | InxComponentInfoDisconnect
GetClassName | InxComponentInfo31000
GetDisplayCategory |
GetDisplayName |
GetEventLogInfo |
GetLogEnabled | InxLoggableComponentInfo31000
GetName |
GetState | InxStateComponentInfo31000
GetStatsCaptions |
GetStatsValues |
ioDeactivate |
LogIn | InxAbstractSecurityMonitorComponentInfo31000
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Disconnect | This is Disconnect, a member of class InxComponentInfoDisconnect.
Free |
FreeInstance |
GetClassName | This is GetClassName, a member of class InxComponentInfo31000.
GetDisplayCategory | This is GetDisplayCategory, a member of class InxComponentInfo31000.
GetDisplayName | This is GetDisplayName, a member of class InxComponentInfo31000.
GetEventLogInfo | This is GetEventLogInfo, a member of class InxLoggableComponentInfo31000.
GetLogEnabled | This is GetLogEnabled, a member of class InxLoggableComponentInfo31000.
GetName | This is GetName, a member of class InxComponentInfo31000.
GetState | This is GetState, a member of class InxStateComponentInfo31000.
GetStatsCaptions | This is GetStatsCaptions, a member of class InxComponentInfo31000.
GetStatsValues | This is GetStatsValues, a member of class InxComponentInfo31000.
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
ClassName | This is ClassName, a member of class InxComponentInfo31000.
DisplayCategory | This is DisplayCategory, a member of class InxComponentInfo31000.
DisplayName | This is DisplayName, a member of class InxComponentInfo31000.
EventLogInfo | This is EventLogInfo, a member of class InxLoggableComponentInfo31000.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
LogEnabled | This is LogEnabled, a member of class InxLoggableComponentInfo31000.
Name | This is Name, a member of class InxComponentInfo31000.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
State | This is State, a member of class InxStateComponentInfo31000.
Links
TnxAbstractSecurityMonitorComponentInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractSecurityMonitorComponentInfo.Create Constructor

TnxAbstractSecurityMonitorComponentInfo.Create Constructor
TnxAbstractSecurityMonitorComponentInfo Class TnxAbstractSecurityMonitorComponentInfo Members nxsdServerEngine Namespace TnxAbstractSecurityMonitorComponentInfo Class Send Feedback
Syntax
Delphi
constructor Create(aAbstractSecurityMonitor: TnxAbstractSecurityMonitor);
Description

TnxAbstractSecurityMonitorComponentInfo

Class

TnxAbstractSecurityMonitorComponentInfo Class

Links
TnxAbstractSecurityMonitorComponentInfo Class, TnxAbstractSecurityMonitorComponentInfo Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitorComponentInfo Class


TnxAbstractSecurityMonitorComponentInfo Methods

TnxAbstractSecurityMonitorComponentInfo Methods
TnxAbstractSecurityMonitorComponentInfo Class Legend Protected Methods Send Feedback

The methods of the TnxAbstractSecurityMonitorComponentInfo class are listed here.

Class

TnxAbstractSecurityMonitorComponentInfo Class

Protected Methods
Name | Description
LogIn | InxAbstractSecurityMonitorComponentInfo31000
Links
TnxAbstractSecurityMonitorComponentInfo Class, Legend, Protected Methods


TnxAbstractSecurityMonitorComponentInfo.LogIn Method

TnxAbstractSecurityMonitorComponentInfo.LogIn Method
TnxAbstractSecurityMonitorComponentInfo Class TnxAbstractSecurityMonitorComponentInfo Members nxsdServerEngine Namespace TnxAbstractSecurityMonitorComponentInfo Methods Send Feedback
Syntax
Delphi
function LogIn(const aUserName: UnicodeString; const aPassword: UnicodeString): InxLoggedInUser31000;
Description

InxAbstractSecurityMonitorComponentInfo31000

Group

TnxAbstractSecurityMonitorComponentInfo Methods

Links
TnxAbstractSecurityMonitorComponentInfo Class, TnxAbstractSecurityMonitorComponentInfo Members, nxsdServerEngine Namespace, TnxAbstractSecurityMonitorComponentInfo Methods


TnxAbstractServerObject Class

TnxAbstractServerObject Class
TnxAbstractServerObject Fields TnxAbstractServerObject Methods TnxAbstractServerObject Properties TnxAbstractServerObject Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractServerObjectnxsdServerEngine_TnxAbstractServerObjectnxsdServerEngine_TnxAbstractServerObjectnxsdServerEngine_TnxAbstractServerObjectnxsdServerEngine_TnxAbstractServerObject
Syntax
Delphi
TnxAbstractServerObject = class(TnxLifetimeTrackedPersistent, InxAbstractServerObject41100);
File

nxsdServerEngine

Description

The base class for all server dependent objects.

Group

Classes

Links
TnxAbstractServerObject Fields, TnxAbstractServerObject Methods, TnxAbstractServerObject Properties, TnxAbstractServerObject Members, nxsdServerEngine, Classes


TnxAbstractServerObject Members

TnxAbstractServerObject Members
TnxAbstractServerObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractServerObject.

Class

TnxAbstractServerObject Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoSetRemoteThreadPriority |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeDestruction.
Close |
Create |
CreateInstanceFor | remoting integration
Free | Reintroduction of the Free method
FreeInstance |
GetLifetimeMontior |
LookupByID |
NewInstance |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxAbstractServerObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractServerObject.Create Constructor

TnxAbstractServerObject.Create Constructor
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxAbstractSession);
Class

TnxAbstractServerObject Class

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Class


TnxAbstractServerObject Fields

TnxAbstractServerObject Fields
TnxAbstractServerObject Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractServerObject class are listed here.

Class

TnxAbstractServerObject Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
Links
TnxAbstractServerObject Class, Legend, Protected Fields


TnxAbstractServerObject.asoDestroyFlag Field

TnxAbstractServerObject.asoDestroyFlag Field
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Fields Send Feedback
Syntax
Delphi
asoDestroyFlag: PLongBool;
Description

This is asoDestroyFlag, a member of class TnxAbstractServerObject.

Group

TnxAbstractServerObject Fields

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Fields


TnxAbstractServerObject.asoDestroying Field

TnxAbstractServerObject.asoDestroying Field
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Fields Send Feedback
Syntax
Delphi
asoDestroying: LongBool;
Description

private

Group

TnxAbstractServerObject Fields

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Fields


TnxAbstractServerObject.asoSession Field

TnxAbstractServerObject.asoSession Field
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Fields Send Feedback
Syntax
Delphi
asoSession: TnxAbstractSession;
Description

This is asoSession, a member of class TnxAbstractServerObject.

Group

TnxAbstractServerObject Fields

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Fields


TnxAbstractServerObject Methods

TnxAbstractServerObject Methods
TnxAbstractServerObject Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractServerObject class are listed here.

Class

TnxAbstractServerObject Class

Protected Methods
Name | Description
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoSetRemoteThreadPriority |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
Public Methods
Name | Description
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeDestruction.
Close |
CreateInstanceFor | remoting integration
Free | Reintroduction of the Free method
FreeInstance |
LookupByID |
NewInstance |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Links
TnxAbstractServerObject Class, Legend, Protected Methods, Public Methods


TnxAbstractServerObject.asoConvertException Method

TnxAbstractServerObject.asoConvertException Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoConvertException(aException: Exception): TnxResult; virtual;
Description

TnxAbstractServerObject

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoCreateInstance Method

TnxAbstractServerObject.asoCreateInstance Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoCreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Description

remoting integration

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoGetMinVersion Method

TnxAbstractServerObject.asoGetMinVersion Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoGetMinVersion: Integer; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoGetRemoteID Method

TnxAbstractServerObject.asoGetRemoteID Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoGetRemoteID: TnxBaseID; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoGetRemoteThreadPriority Method

TnxAbstractServerObject.asoGetRemoteThreadPriority Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoGetRemoteThreadPriority: TnxThreadPriority; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoGetServerEngine Method

TnxAbstractServerObject.asoGetServerEngine Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function asoGetServerEngine: TnxBaseServerEngine; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.asoSetRemoteThreadPriority Method

TnxAbstractServerObject.asoSetRemoteThreadPriority Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure asoSetRemoteThreadPriority(const Value: TnxThreadPriority); virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.BeforeDestruction Method

TnxAbstractServerObject.BeforeDestruction Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeDestruction.

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.Close Method

TnxAbstractServerObject.Close Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function Close: TnxResult; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.CreateInstanceFor Method

TnxAbstractServerObject.CreateInstanceFor Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Description

remoting integration

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.Free Method

TnxAbstractServerObject.Free Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure Free;
Description

Reintroduction of the Free method

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.FreeInstance Method

TnxAbstractServerObject.FreeInstance Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure FreeInstance; override;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.GetEncodedExceptionData Method

TnxAbstractServerObject.GetEncodedExceptionData Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
function GetEncodedExceptionData(aIncludeChildren: Boolean): string;
Description

InxAbstractServerObject41100

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.GetExceptionData Method

TnxAbstractServerObject.GetExceptionData Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.LookupByID Method

TnxAbstractServerObject.LookupByID Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
class function LookupByID(aSessionID: TnxSessionID; aBaseID: TnxBaseID; out aBase): TnxResult; virtual;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.NewInstance Method

TnxAbstractServerObject.NewInstance Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
class function NewInstance: TObject; override;
Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject.PrepareDestroy Method

TnxAbstractServerObject.PrepareDestroy Method
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; virtual;
Description

called just before the destructor is called to allow for removal of dependencies between components.

Group

TnxAbstractServerObject Methods

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Methods


TnxAbstractServerObject Properties

TnxAbstractServerObject Properties
TnxAbstractServerObject Class Legend Public Properties Send Feedback

The properties of the TnxAbstractServerObject class are listed here.

Class

TnxAbstractServerObject Class

Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxAbstractServerObject Class, Legend, Public Properties


TnxAbstractServerObject.Destroying Property

TnxAbstractServerObject.Destroying Property
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Properties Send Feedback
Syntax
Delphi
property Destroying: LongBool;
Description

This is Destroying, a member of class TnxAbstractServerObject.

Group

TnxAbstractServerObject Properties

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Properties


TnxAbstractServerObject.MinVersion Property

TnxAbstractServerObject.MinVersion Property
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Properties Send Feedback
Syntax
Delphi
property MinVersion: Integer;
Description

This is MinVersion, a member of class TnxAbstractServerObject.

Group

TnxAbstractServerObject Properties

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Properties


TnxAbstractServerObject.RemoteID Property

TnxAbstractServerObject.RemoteID Property
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Properties Send Feedback
Syntax
Delphi
property RemoteID: TnxBaseID;
Description

This is RemoteID, a member of class TnxAbstractServerObject.

Group

TnxAbstractServerObject Properties

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Properties


TnxAbstractServerObject.RemoteThreadPriority Property

TnxAbstractServerObject.RemoteThreadPriority Property
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Properties Send Feedback
Syntax
Delphi
property RemoteThreadPriority: TnxThreadPriority;
Description

RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.

Group

TnxAbstractServerObject Properties

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Properties


TnxAbstractServerObject.Session Property

TnxAbstractServerObject.Session Property
TnxAbstractServerObject Class TnxAbstractServerObject Members nxsdServerEngine Namespace TnxAbstractServerObject Properties Send Feedback
Syntax
Delphi
property Session: TnxAbstractSession;
Description

The session owning this server object (if any) or nil.

Group

TnxAbstractServerObject Properties

Links
TnxAbstractServerObject Class, TnxAbstractServerObject Members, nxsdServerEngine Namespace, TnxAbstractServerObject Properties


TnxAbstractSession Class

TnxAbstractSession Class
TnxAbstractSession Fields TnxAbstractSession Methods TnxAbstractSession Properties TnxAbstractSession Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSessionnxsdServerEngine_TnxAbstractSession
Syntax
Delphi
TnxAbstractSession = class(TnxAbstractTimeoutObject, InxSessionNotifications);
File

nxsdServerEngine

Description

The abstract declaration of a Server Session. All actual session implementations MUST be descendent from this class. This is the server side version of TnxSession.

Group

Classes

Links
TnxAbstractSession Fields, TnxAbstractSession Methods, TnxAbstractSession Properties, TnxAbstractSession Members, nxsdServerEngine, Classes


TnxAbstractSession Members

TnxAbstractSession Members
TnxAbstractSession Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractSession.

Class

TnxAbstractSession Class

Protected Fields
Name | Description
asAuthenticated | This is asAuthenticated, a member of class TnxAbstractSession.
asCleanedUp | This is asCleanedUp, a member of class TnxAbstractSession.
asConnectedFrom | This is asConnectedFrom, a member of class TnxAbstractSession.
asConnectedSince | This is asConnectedSince, a member of class TnxAbstractSession.
asDatabasesHead | This is asDatabasesHead, a member of class TnxAbstractSession.
asDatabasesPadlock | This is asDatabasesPadlock, a member of class TnxAbstractSession.
asDatabasesTail | This is asDatabasesTail, a member of class TnxAbstractSession.
asLock | private
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractSession.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
asPassword | This is asPassword, a member of class TnxAbstractSession.
asServerEngine | This is asServerEngine, a member of class TnxAbstractSession.
asServerEngineNext | This is asServerEngineNext, a member of class TnxAbstractSession.
asServerEnginePrev | This is asServerEnginePrev, a member of class TnxAbstractSession.
asSessionNotifications | This is asSessionNotifications, a member of class TnxAbstractSession.
asTaskInfosHead | This is asTaskInfosHead, a member of class TnxAbstractSession.
asTaskInfosPadlock | This is asTaskInfosPadlock, a member of class TnxAbstractSession.
asTaskInfosTail | This is asTaskInfosTail, a member of class TnxAbstractSession.
asTransContextsHead | This is asTransContextsHead, a member of class TnxAbstractSession.
asTransContextsPadlock | This is asTransContextsPadlock, a member of class TnxAbstractSession.
asTransContextsTail | This is asTransContextsTail, a member of class TnxAbstractSession.
asUserName | This is asUserName, a member of class TnxAbstractSession.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asAddToServerEngine |
asCleanup |
asCreateStats |
asDoCreateStats |
asFailed |
asGetClientDefaultLocale |
asGetClientVersion |
asGetServerVersion |
asGetSessionNotifications |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoSetRemoteThreadPriority |
asRemoveFromServerEngine |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AddNotifier | This is AddNotifier, a member of class InxSessionNotifications.
AfterConstruction | see TObject.AfterConstruction TnxAbstractSession
AliasAdd | This function implements the addition of a new Alias to the session.
AliasDelete | This function implements the removal of an Alias from the session.
AliasGetList | This function needs to return the List of Aliases as a list of TnxAliasDescriptor objects.
AliasGetPath | This function returns the Path of a directory. The format of aPath is specific to the actual implementation, in the default implementation it is a directory.
AliasModify | This function implements the modification of a an Alias. The function supports modifying name and/or path of the Alias.
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
CloseInactiveFolders | This function uncaches and closes all unused folders/directories.
CloseInactiveTables | This function uncaches and closes all unused tables.
Create | Constructor
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
DatabaseOpen | This function will open a alias/database and return the TnxAbstractDatabase object created it for it.
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Failed | Removes any failed locks and marks the session as failed.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetRegisteredClassList | This function returns a list of registered engines of the requested type.
GetUserInfo | misc
LookupByID | This is the class function that returns the object with a certain ID.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PasswordAdd | Adds a password to the Session internal password list.
PasswordRemove | Removes a password from the Session internal password list.
PasswordRemoveAll | Clears the password list.
PrepareDestroy |
RemoveNotifier | This is RemoveNotifier, a member of class InxSessionNotifications.
TransContextCreate | This function will create a transaction context and return the TnxAbstractTransContext object created it for it. The transaction context can then be passed into DatabaseOpen.
Public Properties
Name | Description
Authenticated | This property returns true, it the session was logged on successfully with User Name and Password.
CleanedUp | This property returns true, it the session has failed and has been cleaned up. It no longer owns any databases.
ClientDefaultLocale | Returns the locale that the client wishes to use for string comparisons where no explicit locale is defined. NIL if no default is specified by the client.
ClientVersion | This property returns the version of the client that opened the session.
ConnectedFrom | This property returns the connection information for the session.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
Password | This property returns the password used to logon the session.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
ServerEngine | This property returns the server engine the session is attached to.
ServerVersion | This property returns the version of the server that runs the session.
Session | The session owning this server object (if any) or nil.
SessionNotifications | This is SessionNotifications, a member of class TnxAbstractSession.
Timeout | Property to read/write the timeout in msec for the object.
UserName | This property returns the user name used to logon the session.
Links
TnxAbstractSession Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractSession.Create Constructor

TnxAbstractSession.Create Constructor
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Class Send Feedback
Syntax
Delphi
constructor Create(aServerEngine: TnxBaseServerEngine; aTimeout: TnxWord32; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string);
Parameters
Parameters | Description
aServerEngine: TnxBaseServerEngine | the server engine that owns the session
aTimeout: TnxWord32 | the timeout in msec for the session
const aUserName: UnicodeString | the user name used to logon to the server
const aPassword: UnicodeString | the password used to logon to the server
Description

Constructor

Class

TnxAbstractSession Class

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Class


TnxAbstractSession.Destroy Destructor

TnxAbstractSession.Destroy Destructor
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractSession Class

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Class


TnxAbstractSession Fields

TnxAbstractSession Fields
TnxAbstractSession Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractSession class are listed here.

Class

TnxAbstractSession Class

Protected Fields
Name | Description
asAuthenticated | This is asAuthenticated, a member of class TnxAbstractSession.
asCleanedUp | This is asCleanedUp, a member of class TnxAbstractSession.
asConnectedFrom | This is asConnectedFrom, a member of class TnxAbstractSession.
asConnectedSince | This is asConnectedSince, a member of class TnxAbstractSession.
asDatabasesHead | This is asDatabasesHead, a member of class TnxAbstractSession.
asDatabasesPadlock | This is asDatabasesPadlock, a member of class TnxAbstractSession.
asDatabasesTail | This is asDatabasesTail, a member of class TnxAbstractSession.
asLock | private
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractSession.
asPassword | This is asPassword, a member of class TnxAbstractSession.
asServerEngine | This is asServerEngine, a member of class TnxAbstractSession.
asServerEngineNext | This is asServerEngineNext, a member of class TnxAbstractSession.
asServerEnginePrev | This is asServerEnginePrev, a member of class TnxAbstractSession.
asSessionNotifications | This is asSessionNotifications, a member of class TnxAbstractSession.
asTaskInfosHead | This is asTaskInfosHead, a member of class TnxAbstractSession.
asTaskInfosPadlock | This is asTaskInfosPadlock, a member of class TnxAbstractSession.
asTaskInfosTail | This is asTaskInfosTail, a member of class TnxAbstractSession.
asTransContextsHead | This is asTransContextsHead, a member of class TnxAbstractSession.
asTransContextsPadlock | This is asTransContextsPadlock, a member of class TnxAbstractSession.
asTransContextsTail | This is asTransContextsTail, a member of class TnxAbstractSession.
asUserName | This is asUserName, a member of class TnxAbstractSession.
Links
TnxAbstractSession Class, Legend, Protected Fields


TnxAbstractSession.asAuthenticated Field

TnxAbstractSession.asAuthenticated Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asAuthenticated: Boolean;
Description

This is asAuthenticated, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asCleanedUp Field

TnxAbstractSession.asCleanedUp Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asCleanedUp: Boolean;
Description

This is asCleanedUp, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asConnectedFrom Field

TnxAbstractSession.asConnectedFrom Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asConnectedFrom: string;
Description

This is asConnectedFrom, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asConnectedSince Field

TnxAbstractSession.asConnectedSince Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asConnectedSince: TDateTime;
Description

This is asConnectedSince, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asDatabasesHead Field

TnxAbstractSession.asDatabasesHead Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asDatabasesHead: TnxAbstractDatabase;
Description

This is asDatabasesHead, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asDatabasesPadlock Field

TnxAbstractSession.asDatabasesPadlock Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asDatabasesPadlock: TnxPadlock;
Description

This is asDatabasesPadlock, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asDatabasesTail Field

TnxAbstractSession.asDatabasesTail Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asDatabasesTail: TnxAbstractDatabase;
Description

This is asDatabasesTail, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asLock Field

TnxAbstractSession.asLock Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asLock: TnxSimpleLock;
Description

private

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asLockedIncDone Field

TnxAbstractSession.asLockedIncDone Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asLockedIncDone: Boolean;
Description

This is asLockedIncDone, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asPassword Field

TnxAbstractSession.asPassword Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asPassword: UnicodeString;
Description

This is asPassword, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asServerEngine Field

TnxAbstractSession.asServerEngine Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asServerEngine: TnxBaseServerEngine;
Description

This is asServerEngine, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asServerEngineNext Field

TnxAbstractSession.asServerEngineNext Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asServerEngineNext: TnxAbstractSession;
Description

This is asServerEngineNext, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asServerEnginePrev Field

TnxAbstractSession.asServerEnginePrev Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asServerEnginePrev: TnxAbstractSession;
Description

This is asServerEnginePrev, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asSessionNotifications Field

TnxAbstractSession.asSessionNotifications Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asSessionNotifications: TnxSessionNotifications;
Description

This is asSessionNotifications, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTaskInfosHead Field

TnxAbstractSession.asTaskInfosHead Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTaskInfosHead: TnxAbstractTaskInfo;
Description

This is asTaskInfosHead, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTaskInfosPadlock Field

TnxAbstractSession.asTaskInfosPadlock Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTaskInfosPadlock: TnxPadlock;
Description

This is asTaskInfosPadlock, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTaskInfosTail Field

TnxAbstractSession.asTaskInfosTail Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTaskInfosTail: TnxAbstractTaskInfo;
Description

This is asTaskInfosTail, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTransContextsHead Field

TnxAbstractSession.asTransContextsHead Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTransContextsHead: TnxAbstractTransContext;
Description

This is asTransContextsHead, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTransContextsPadlock Field

TnxAbstractSession.asTransContextsPadlock Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTransContextsPadlock: TnxPadlock;
Description

This is asTransContextsPadlock, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asTransContextsTail Field

TnxAbstractSession.asTransContextsTail Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asTransContextsTail: TnxAbstractTransContext;
Description

This is asTransContextsTail, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession.asUserName Field

TnxAbstractSession.asUserName Field
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Fields Send Feedback
Syntax
Delphi
asUserName: UnicodeString;
Description

This is asUserName, a member of class TnxAbstractSession.

Group

TnxAbstractSession Fields

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Fields


TnxAbstractSession Methods

TnxAbstractSession Methods
TnxAbstractSession Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractSession class are listed here.

Class

TnxAbstractSession Class

Protected Methods
Name | Description
asAddToServerEngine |
asCleanup |
asCreateStats |
asDoCreateStats |
asFailed |
asGetClientDefaultLocale |
asGetClientVersion |
asGetServerVersion |
asGetSessionNotifications |
asoGetMinVersion |
asoGetServerEngine |
asRemoveFromServerEngine |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractSession
AliasAdd | This function implements the addition of a new Alias to the session.
AliasDelete | This function implements the removal of an Alias from the session.
AliasGetList | This function needs to return the List of Aliases as a list of TnxAliasDescriptor objects.
AliasGetPath | This function returns the Path of a directory. The format of aPath is specific to the actual implementation, in the default implementation it is a directory.
AliasModify | This function implements the modification of a an Alias. The function supports modifying name and/or path of the Alias.
BeforeDestruction | see TObject.BeforeConstruction
CloseInactiveFolders | This function uncaches and closes all unused folders/directories.
CloseInactiveTables | This function uncaches and closes all unused tables.
DatabaseOpen | This function will open a alias/database and return the TnxAbstractDatabase object created it for it.
Failed | Removes any failed locks and marks the session as failed.
GetRegisteredClassList | This function returns a list of registered engines of the requested type.
GetUserInfo | misc
LookupByID | This is the class function that returns the object with a certain ID.
OptionSet | Sets an Option in named option list to a certain value.
PasswordAdd | Adds a password to the Session internal password list.
PasswordRemove | Removes a password from the Session internal password list.
PasswordRemoveAll | Clears the password list.
PrepareDestroy |
TransContextCreate | This function will create a transaction context and return the TnxAbstractTransContext object created it for it. The transaction context can then be passed into DatabaseOpen.
Links
TnxAbstractSession Class, Legend, Protected Methods, Public Methods


TnxAbstractSession.AfterConstruction Method

TnxAbstractSession.AfterConstruction Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

TnxAbstractSession

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.AliasAdd Method

TnxAbstractSession.AliasAdd Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function AliasAdd(const aAlias: string; const aPath: string; aEnforce: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aAlias: string | the name of the Alias.
const aPath: string | the directory the Alias points to. The format is specific to the actual implementation
Description

This function implements the addition of a new Alias to the session.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.AliasDelete Method

TnxAbstractSession.AliasDelete Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function AliasDelete(const aAlias: string): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aAlias: string | the name of the Alias to be removed.
Description

This function implements the removal of an Alias from the session.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.AliasGetList Method

TnxAbstractSession.AliasGetList Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function AliasGetList(aList: TObjectList): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aList: TObjectList | The list that will be filled with descriptors.
Description

This function needs to return the List of Aliases as a list of TnxAliasDescriptor objects.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.AliasGetPath Method

TnxAbstractSession.AliasGetPath Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function AliasGetPath(const aAlias: string; out aPath: string): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aAlias: string | the name of the alias
out aPath: string | the variable that will be set to the path.
Description

This function returns the Path of a directory. The format of aPath is specific to the actual implementation, in the default implementation it is a directory.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.AliasModify Method

TnxAbstractSession.AliasModify Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function AliasModify(const aAlias: string; const aNewName: string; const aNewPath: string; aEnforce: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aAlias: string | the name of the Alias.
const aNewName: string | a new name for the alias.
aPath | the directory the Alias points to. The format is specific to the actual implementation
Description

This function implements the modification of a an Alias. The function supports modifying name and/or path of the Alias.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asAddToServerEngine Method

TnxAbstractSession.asAddToServerEngine Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure asAddToServerEngine;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asCleanup Method

TnxAbstractSession.asCleanup Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure asCleanup(aSender: TObject); virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asCreateStats Method

TnxAbstractSession.asCreateStats Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asCreateStats: TnxSessionStats;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asDoCreateStats Method

TnxAbstractSession.asDoCreateStats Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asDoCreateStats: TnxSessionStats; virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asFailed Method

TnxAbstractSession.asFailed Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure asFailed(aPermanent: Boolean; aWait: Boolean); virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asGetClientDefaultLocale Method

TnxAbstractSession.asGetClientDefaultLocale Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asGetClientDefaultLocale: TnxLocaleDescriptor; virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asGetClientVersion Method

TnxAbstractSession.asGetClientVersion Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asGetClientVersion: Integer; virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asGetServerVersion Method

TnxAbstractSession.asGetServerVersion Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asGetServerVersion: Integer; virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asGetSessionNotifications Method

TnxAbstractSession.asGetSessionNotifications Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asGetSessionNotifications: InxSessionNotifications;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asoGetMinVersion Method

TnxAbstractSession.asoGetMinVersion Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asoGetMinVersion: Integer; override;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asoGetServerEngine Method

TnxAbstractSession.asoGetServerEngine Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function asoGetServerEngine: TnxBaseServerEngine; override;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.asRemoveFromServerEngine Method

TnxAbstractSession.asRemoveFromServerEngine Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure asRemoveFromServerEngine; virtual;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.BeforeDestruction Method

TnxAbstractSession.BeforeDestruction Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.CloseInactiveFolders Method

TnxAbstractSession.CloseInactiveFolders Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function CloseInactiveFolders: TnxResult; virtual; abstract;
Description

This function uncaches and closes all unused folders/directories.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.CloseInactiveTables Method

TnxAbstractSession.CloseInactiveTables Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function CloseInactiveTables: TnxResult; virtual; abstract;
Description

This function uncaches and closes all unused tables.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.DatabaseOpen Method

TnxAbstractSession.DatabaseOpen Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function DatabaseOpen(out aDatabase: TnxAbstractDatabase; const aAliasType: string; const aAlias: string; aTransContext: TnxAbstractTransContext; aOpenMode: TnxOpenMode; aShareMode: TnxShareMode; aTimeout: TnxWord32): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aDatabase: TnxAbstractDatabase | the variable to receive the resulting instance.
const aAliasType: string | the type of the alias. Currently nxatAliasName and nxatAliasPath
const aAlias: string | the name of the alias to open
aTransContext: TnxAbstractTransContext | the transaction context this database belongs to. If this is nil the database creates it's own transaction context.
aOpenMode: TnxOpenMode | the mode the database should be opened in
aShareMode: TnxShareMode | Share mode for opening the database
aTimeout: TnxWord32 | the timeout in msec for the database
Description

This function will open a alias/database and return the TnxAbstractDatabase object created it for it.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.Failed Method

TnxAbstractSession.Failed Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure Failed(aPermanent: Boolean);
Description

Removes any failed locks and marks the session as failed.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.GetExceptionData Method

TnxAbstractSession.GetExceptionData Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.GetRegisteredClassList Method

TnxAbstractSession.GetRegisteredClassList Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function GetRegisteredClassList(const aClassListType: TnxClassListType; aList: TStrings): TnxResult; virtual; abstract;
Description

This function returns a list of registered engines of the requested type.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.GetUserInfo Method

TnxAbstractSession.GetUserInfo Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure GetUserInfo(aStrings: TStrings); virtual;
Description

misc

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.LookupByID Method

TnxAbstractSession.LookupByID Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
class function LookupByID(aSessionID: TnxSessionID; out aSession): TnxResult; virtual; overload; reintroduce;
Parameters
Parameters | Description
aSessionID: TnxSessionID | the ID to look for
out aSession | a var that will hold the class if found
Description

This is the class function that returns the object with a certain ID.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.OptionSet Method

TnxAbstractSession.OptionSet Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Description

Sets an Option in named option list to a certain value.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.PasswordAdd Method

TnxAbstractSession.PasswordAdd Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function PasswordAdd(const aPassword: UnicodeString): TnxResult; virtual; abstract;
Description

Adds a password to the Session internal password list.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.PasswordRemove Method

TnxAbstractSession.PasswordRemove Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function PasswordRemove(const aPassword: UnicodeString): TnxResult; virtual; abstract;
Description

Removes a password from the Session internal password list.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.PasswordRemoveAll Method

TnxAbstractSession.PasswordRemoveAll Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function PasswordRemoveAll: TnxResult; virtual; abstract;
Description

Clears the password list.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.PrepareDestroy Method

TnxAbstractSession.PrepareDestroy Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; override;
Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession.TransContextCreate Method

TnxAbstractSession.TransContextCreate Method
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Methods Send Feedback
Syntax
Delphi
function TransContextCreate(out aTransContext: TnxAbstractTransContext; aTimeout: TnxWord32): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aTransContext: TnxAbstractTransContext | the variable to receive the resulting instance.
aTimeout: TnxWord32 | the timeout in msec for the transaction context
Description

This function will create a transaction context and return the TnxAbstractTransContext object created it for it. The transaction context can then be passed into DatabaseOpen.

Group

TnxAbstractSession Methods

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Methods


TnxAbstractSession Properties

TnxAbstractSession Properties
TnxAbstractSession Class Legend Public Properties Send Feedback

The properties of the TnxAbstractSession class are listed here.

Class

TnxAbstractSession Class

Public Properties
Name | Description
Authenticated | This property returns true, it the session was logged on successfully with User Name and Password.
CleanedUp | This property returns true, it the session has failed and has been cleaned up. It no longer owns any databases.
ClientDefaultLocale | Returns the locale that the client wishes to use for string comparisons where no explicit locale is defined. NIL if no default is specified by the client.
ClientVersion | This property returns the version of the client that opened the session.
ConnectedFrom | This property returns the connection information for the session.
Password | This property returns the password used to logon the session.
ServerEngine | This property returns the server engine the session is attached to.
ServerVersion | This property returns the version of the server that runs the session.
SessionNotifications | This is SessionNotifications, a member of class TnxAbstractSession.
UserName | This property returns the user name used to logon the session.
Links
TnxAbstractSession Class, Legend, Public Properties


TnxAbstractSession.Authenticated Property

TnxAbstractSession.Authenticated Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property Authenticated: Boolean;
Description

This property returns true, it the session was logged on successfully with User Name and Password.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.CleanedUp Property

TnxAbstractSession.CleanedUp Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property CleanedUp: Boolean;
Description

This property returns true, it the session has failed and has been cleaned up. It no longer owns any databases.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.ClientDefaultLocale Property

TnxAbstractSession.ClientDefaultLocale Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property ClientDefaultLocale: TnxLocaleDescriptor;
Description

Returns the locale that the client wishes to use for string comparisons where no explicit locale is defined. NIL if no default is specified by the client.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.ClientVersion Property

TnxAbstractSession.ClientVersion Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property ClientVersion: Integer;
Description

This property returns the version of the client that opened the session.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.ConnectedFrom Property

TnxAbstractSession.ConnectedFrom Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property ConnectedFrom: string;
Description

This property returns the connection information for the session.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.Password Property

TnxAbstractSession.Password Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property Password: UnicodeString;
Description

This property returns the password used to logon the session.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.ServerEngine Property

TnxAbstractSession.ServerEngine Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

This property returns the server engine the session is attached to.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.ServerVersion Property

TnxAbstractSession.ServerVersion Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property ServerVersion: Integer;
Description

This property returns the version of the server that runs the session.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.SessionNotifications Property

TnxAbstractSession.SessionNotifications Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property SessionNotifications: InxSessionNotifications;
Description

This is SessionNotifications, a member of class TnxAbstractSession.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractSession.UserName Property

TnxAbstractSession.UserName Property
TnxAbstractSession Class TnxAbstractSession Members nxsdServerEngine Namespace TnxAbstractSession Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This property returns the user name used to logon the session.

Group

TnxAbstractSession Properties

Links
TnxAbstractSession Class, TnxAbstractSession Members, nxsdServerEngine Namespace, TnxAbstractSession Properties


TnxAbstractStatement Class

TnxAbstractStatement Class
TnxAbstractStatement Fields TnxAbstractStatement Methods TnxAbstractStatement Properties TnxAbstractStatement Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatementnxsdServerEngine_TnxAbstractStatement
Syntax
Delphi
TnxAbstractStatement = class(TnxAbstractTimeoutObject);
File

nxsdServerEngine

Description

The abstract declaration of a server statement. All actual statement implementations MUST be descendent from this class. This is the server side version of TnxQuery.

Group

Classes

Links
TnxAbstractStatement Fields, TnxAbstractStatement Methods, TnxAbstractStatement Properties, TnxAbstractStatement Members, nxsdServerEngine, Classes


TnxAbstractStatement Members

TnxAbstractStatement Members
TnxAbstractStatement Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractStatement.

Class

TnxAbstractStatement Class

Protected Fields
Name | Description
asDatabase | private
asDatabaseNext | This is asDatabaseNext, a member of class TnxAbstractStatement.
asDatabasePrev | This is asDatabasePrev, a member of class TnxAbstractStatement.
asExecDirect | This is asExecDirect, a member of class TnxAbstractStatement.
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractStatement.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asAddToDatabase |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
asRemoveFromDatabase |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractStatement
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create | constructor Paremeters: aDatabase - the database instance the statement is linked to aTimeout - the timeout of the statement in msec
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Exec | This method execute the query and returns a cursor for it.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetParams | Returns the given Parameters as stream.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
Prepare | This method prepares the sql query. It does NOT execute the query.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
SetParams | With SetParams the parameters of the query will be set.
Public Properties
Name | Description
Database | This property returns the database the statement is linked to.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxAbstractStatement Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractStatement.Create Constructor

TnxAbstractStatement.Create Constructor
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Class Send Feedback
Syntax
Delphi
constructor Create(aDatabase: TnxAbstractDatabase; aTimeout: TnxWord32);
Description

constructor Paremeters: aDatabase - the database instance the statement is linked to aTimeout - the timeout of the statement in msec

Class

TnxAbstractStatement Class

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Class


TnxAbstractStatement.Destroy Destructor

TnxAbstractStatement.Destroy Destructor
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractStatement Class

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Class


TnxAbstractStatement Fields

TnxAbstractStatement Fields
TnxAbstractStatement Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractStatement class are listed here.

Class

TnxAbstractStatement Class

Protected Fields
Name | Description
asDatabase | private
asDatabaseNext | This is asDatabaseNext, a member of class TnxAbstractStatement.
asDatabasePrev | This is asDatabasePrev, a member of class TnxAbstractStatement.
asExecDirect | This is asExecDirect, a member of class TnxAbstractStatement.
asLockedIncDone | This is asLockedIncDone, a member of class TnxAbstractStatement.
Links
TnxAbstractStatement Class, Legend, Protected Fields


TnxAbstractStatement.asDatabase Field

TnxAbstractStatement.asDatabase Field
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Fields Send Feedback
Syntax
Delphi
asDatabase: TnxAbstractDatabase;
Description

private

Group

TnxAbstractStatement Fields

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Fields


TnxAbstractStatement.asDatabaseNext Field

TnxAbstractStatement.asDatabaseNext Field
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Fields Send Feedback
Syntax
Delphi
asDatabaseNext: TnxAbstractStatement;
Description

This is asDatabaseNext, a member of class TnxAbstractStatement.

Group

TnxAbstractStatement Fields

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Fields


TnxAbstractStatement.asDatabasePrev Field

TnxAbstractStatement.asDatabasePrev Field
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Fields Send Feedback
Syntax
Delphi
asDatabasePrev: TnxAbstractStatement;
Description

This is asDatabasePrev, a member of class TnxAbstractStatement.

Group

TnxAbstractStatement Fields

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Fields


TnxAbstractStatement.asExecDirect Field

TnxAbstractStatement.asExecDirect Field
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Fields Send Feedback
Syntax
Delphi
asExecDirect: Boolean;
Description

This is asExecDirect, a member of class TnxAbstractStatement.

Group

TnxAbstractStatement Fields

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Fields


TnxAbstractStatement.asLockedIncDone Field

TnxAbstractStatement.asLockedIncDone Field
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Fields Send Feedback
Syntax
Delphi
asLockedIncDone: Boolean;
Description

This is asLockedIncDone, a member of class TnxAbstractStatement.

Group

TnxAbstractStatement Fields

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Fields


TnxAbstractStatement Methods

TnxAbstractStatement Methods
TnxAbstractStatement Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractStatement class are listed here.

Class

TnxAbstractStatement Class

Protected Methods
Name | Description
asAddToDatabase |
asRemoveFromDatabase |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractStatement
BeforeDestruction | see TObject.BeforeConstruction
CreateInstanceFor | remoting integration
Exec | This method execute the query and returns a cursor for it.
GetParams | Returns the given Parameters as stream.
Prepare | This method prepares the sql query. It does NOT execute the query.
SetParams | With SetParams the parameters of the query will be set.
Links
TnxAbstractStatement Class, Legend, Protected Methods, Public Methods


TnxAbstractStatement.AfterConstruction Method

TnxAbstractStatement.AfterConstruction Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

TnxAbstractStatement

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.asAddToDatabase Method

TnxAbstractStatement.asAddToDatabase Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
procedure asAddToDatabase;
Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.asRemoveFromDatabase Method

TnxAbstractStatement.asRemoveFromDatabase Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
procedure asRemoveFromDatabase;
Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.BeforeDestruction Method

TnxAbstractStatement.BeforeDestruction Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.CreateInstanceFor Method

TnxAbstractStatement.CreateInstanceFor Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.Exec Method

TnxAbstractStatement.Exec Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
function Exec(out aCursor: TnxAbstractCursor; aOpenMode: TnxOpenMode; aStream: TStream): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aCursor: TnxAbstractCursor | the resulting cursor
aOpenMode: TnxOpenMode | the mode you want the cursor to be opened
aStream: TStream | a stream instance that will be filled with result/reply
Description

This method execute the query and returns a cursor for it.

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.GetExceptionData Method

TnxAbstractStatement.GetExceptionData Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.GetParams Method

TnxAbstractStatement.GetParams Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
function GetParams(const aParams: TnxSqlParamList; aStream: TStream): TnxResult; virtual; abstract;
Description

Returns the given Parameters as stream.

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.Prepare Method

TnxAbstractStatement.Prepare Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
function Prepare(aStatementType: TnxStatementType; const aQueryText: WideString; aStream: TStream): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aQueryText: WideString | the SQL query to be executed
aStream: TStream | a stream instance that will be filled with result/reply
Description

This method prepares the sql query. It does NOT execute the query.

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement.SetParams Method

TnxAbstractStatement.SetParams Method
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Methods Send Feedback
Syntax
Delphi
function SetParams(const aParams: TnxSqlParamList; aStream: TStream): TnxResult; virtual; abstract;
Parameters
Parameters | Description
const aParams: TnxSqlParamList | the list of parameters
aStream: TStream | a stream instance that will be filled with result/reply.
Description

With SetParams the parameters of the query will be set.

Group

TnxAbstractStatement Methods

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Methods


TnxAbstractStatement Properties

TnxAbstractStatement Properties
TnxAbstractStatement Class Legend Public Properties Send Feedback

The properties of the TnxAbstractStatement class are listed here.

Class

TnxAbstractStatement Class

Public Properties
Name | Description
Database | This property returns the database the statement is linked to.
Links
TnxAbstractStatement Class, Legend, Public Properties


TnxAbstractStatement.Database Property

TnxAbstractStatement.Database Property
TnxAbstractStatement Class TnxAbstractStatement Members nxsdServerEngine Namespace TnxAbstractStatement Properties Send Feedback
Syntax
Delphi
property Database: TnxAbstractDatabase;
Description

This property returns the database the statement is linked to.

Group

TnxAbstractStatement Properties

Links
TnxAbstractStatement Class, TnxAbstractStatement Members, nxsdServerEngine Namespace, TnxAbstractStatement Properties


TnxAbstractTaskInfo Class

TnxAbstractTaskInfo Class
TnxAbstractTaskInfo Fields TnxAbstractTaskInfo Methods TnxAbstractTaskInfo Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfonxsdServerEngine_TnxAbstractTaskInfo
Syntax
Delphi
TnxAbstractTaskInfo = class(TnxExtendableServerObject);
File

nxsdServerEngine

Description

An instance of a descendant of this class is created for every task executed and on the server. It will be freed once the task is finished.

Group

Classes

Links
TnxAbstractTaskInfo Fields, TnxAbstractTaskInfo Methods, TnxAbstractTaskInfo Members, nxsdServerEngine, Classes


TnxAbstractTaskInfo Members

TnxAbstractTaskInfo Members
TnxAbstractTaskInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractTaskInfo.

Class

TnxAbstractTaskInfo Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atiSessionNext | This is atiSessionNext, a member of class TnxAbstractTaskInfo.
atiSessionPrev | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atiAddToSession | TnxAbstractTaskInfo
atiRemoveFromSession |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Cancel | Call this method to cancel a Task. This method only triggers the cancel, the tasks may still be active until it reaches a safe state. The client-side taskinfo object should not be freed until the aCompleted parameter of GetStatus returns True, indicating task has ended.
Close |
Create | public comes before protected to fix problem with BCB constructor.
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetStatus | This function returns the current status a server task.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxAbstractTaskInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractTaskInfo.Create Constructor

TnxAbstractTaskInfo.Create Constructor
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxAbstractSession);
Description

public comes before protected to fix problem with BCB constructor.

Class

TnxAbstractTaskInfo Class

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Class


TnxAbstractTaskInfo.Destroy Destructor

TnxAbstractTaskInfo.Destroy Destructor
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractTaskInfo Class

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Class


TnxAbstractTaskInfo Fields

TnxAbstractTaskInfo Fields
TnxAbstractTaskInfo Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractTaskInfo class are listed here.

Class

TnxAbstractTaskInfo Class

Protected Fields
Name | Description
atiSessionNext | This is atiSessionNext, a member of class TnxAbstractTaskInfo.
atiSessionPrev | private
Links
TnxAbstractTaskInfo Class, Legend, Protected Fields


TnxAbstractTaskInfo.atiSessionNext Field

TnxAbstractTaskInfo.atiSessionNext Field
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Fields Send Feedback
Syntax
Delphi
atiSessionNext: TnxAbstractTaskInfo;
Description

This is atiSessionNext, a member of class TnxAbstractTaskInfo.

Group

TnxAbstractTaskInfo Fields

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Fields


TnxAbstractTaskInfo.atiSessionPrev Field

TnxAbstractTaskInfo.atiSessionPrev Field
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Fields Send Feedback
Syntax
Delphi
atiSessionPrev: TnxAbstractTaskInfo;
Description

private

Group

TnxAbstractTaskInfo Fields

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Fields


TnxAbstractTaskInfo Methods

TnxAbstractTaskInfo Methods
TnxAbstractTaskInfo Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractTaskInfo class are listed here.

Class

TnxAbstractTaskInfo Class

Protected Methods
Name | Description
atiAddToSession | TnxAbstractTaskInfo
atiRemoveFromSession |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
Cancel | Call this method to cancel a Task. This method only triggers the cancel, the tasks may still be active until it reaches a safe state. The client-side taskinfo object should not be freed until the aCompleted parameter of GetStatus returns True, indicating task has ended.
CreateInstanceFor | remoting integration
GetStatus | This function returns the current status a server task.
PrepareDestroy |
Links
TnxAbstractTaskInfo Class, Legend, Protected Methods, Public Methods


TnxAbstractTaskInfo.atiAddToSession Method

TnxAbstractTaskInfo.atiAddToSession Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
procedure atiAddToSession;
Description

TnxAbstractTaskInfo

Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.atiRemoveFromSession Method

TnxAbstractTaskInfo.atiRemoveFromSession Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
procedure atiRemoveFromSession;
Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.Cancel Method

TnxAbstractTaskInfo.Cancel Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
function Cancel: TnxResult; virtual; abstract;
Description

Call this method to cancel a Task. This method only triggers the cancel, the tasks may still be active until it reaches a safe state. The client-side taskinfo object should not be freed until the aCompleted parameter of GetStatus returns True, indicating task has ended.

Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.CreateInstanceFor Method

TnxAbstractTaskInfo.CreateInstanceFor Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.GetExceptionData Method

TnxAbstractTaskInfo.GetExceptionData Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.GetStatus Method

TnxAbstractTaskInfo.GetStatus Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
function GetStatus(out aCompleted: Boolean; out aStatus: TnxTaskStatus): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aCompleted: Boolean | is set to true if the task is completed
out aStatus: TnxTaskStatus | is set to the task status
Description

This function returns the current status a server task.

Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTaskInfo.PrepareDestroy Method

TnxAbstractTaskInfo.PrepareDestroy Method
TnxAbstractTaskInfo Class TnxAbstractTaskInfo Members nxsdServerEngine Namespace TnxAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; override;
Group

TnxAbstractTaskInfo Methods

Links
TnxAbstractTaskInfo Class, TnxAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxAbstractTaskInfo Methods


TnxAbstractTimeoutObject Class

TnxAbstractTimeoutObject Class
TnxAbstractTimeoutObject Fields TnxAbstractTimeoutObject Methods TnxAbstractTimeoutObject Properties TnxAbstractTimeoutObject Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObjectnxsdServerEngine_TnxAbstractTimeoutObject
Syntax
Delphi
TnxAbstractTimeoutObject = class(TnxExtendableServerObject);
File

nxsdServerEngine

Description

The base class for all server classes that support timeout.

Group

Classes

Links
TnxAbstractTimeoutObject Fields, TnxAbstractTimeoutObject Methods, TnxAbstractTimeoutObject Properties, TnxAbstractTimeoutObject Members, nxsdServerEngine, Classes


TnxAbstractTimeoutObject Members

TnxAbstractTimeoutObject Members
TnxAbstractTimeoutObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractTimeoutObject.

Class

TnxAbstractTimeoutObject Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxAbstractTimeoutObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractTimeoutObject.Create Constructor

TnxAbstractTimeoutObject.Create Constructor
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxExtendableServerObject; aTimeout: TnxWord32);
Description

constructor.

Class

TnxAbstractTimeoutObject Class

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Class


TnxAbstractTimeoutObject Fields

TnxAbstractTimeoutObject Fields
TnxAbstractTimeoutObject Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractTimeoutObject class are listed here.

Class

TnxAbstractTimeoutObject Class

Protected Fields
Name | Description
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
Links
TnxAbstractTimeoutObject Class, Legend, Protected Fields


TnxAbstractTimeoutObject.atoLock Field

TnxAbstractTimeoutObject.atoLock Field
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Fields Send Feedback
Syntax
Delphi
atoLock: InxSimpleLock;
Description

This is atoLock, a member of class TnxAbstractTimeoutObject.

Group

TnxAbstractTimeoutObject Fields

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Fields


TnxAbstractTimeoutObject.atoTimeout Field

TnxAbstractTimeoutObject.atoTimeout Field
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Fields Send Feedback
Syntax
Delphi
atoTimeout: TnxWord32;
Description

private

Group

TnxAbstractTimeoutObject Fields

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Fields


TnxAbstractTimeoutObject Methods

TnxAbstractTimeoutObject Methods
TnxAbstractTimeoutObject Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractTimeoutObject class are listed here.

Class

TnxAbstractTimeoutObject Class

Protected Methods
Name | Description
atoSetTimeout | TnxAbstractTimeoutObject
GetExceptionData | InxExceptionData
Public Methods
Name | Description
Close |
OptionClear | Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
Links
TnxAbstractTimeoutObject Class, Legend, Protected Methods, Public Methods


TnxAbstractTimeoutObject.atoSetTimeout Method

TnxAbstractTimeoutObject.atoSetTimeout Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
procedure atoSetTimeout(aTimeout: TnxWord32); virtual;
Description

TnxAbstractTimeoutObject

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.Close Method

TnxAbstractTimeoutObject.Close Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function Close: TnxResult; override;
Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.GetExceptionData Method

TnxAbstractTimeoutObject.GetExceptionData Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionClear Method

TnxAbstractTimeoutObject.OptionClear Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; override;
Description

Removes an Option from the named option list

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionGet Method

TnxAbstractTimeoutObject.OptionGet Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; override;
Description

Returns the value of an Option in named option list of *this* object only.

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionGetEffective Method

TnxAbstractTimeoutObject.OptionGetEffective Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; override;
Description

Returns the value of an Option in named option by walking the parent hierarchy until a value is found.

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionList Method

TnxAbstractTimeoutObject.OptionList Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; override;
Description

Returns all options as value list (name=value) of this object.

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionListEffective Method

TnxAbstractTimeoutObject.OptionListEffective Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; override;
Description

Returns all options as value list (name=value) of the whole parent hierarchy.

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject.OptionSet Method

TnxAbstractTimeoutObject.OptionSet Method
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; override;
Description

Sets an Option in named option list to a certain value.

Group

TnxAbstractTimeoutObject Methods

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Methods


TnxAbstractTimeoutObject Properties

TnxAbstractTimeoutObject Properties
TnxAbstractTimeoutObject Class Legend Public Properties Send Feedback

The properties of the TnxAbstractTimeoutObject class are listed here.

Class

TnxAbstractTimeoutObject Class

Public Properties
Name | Description
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxAbstractTimeoutObject Class, Legend, Public Properties


TnxAbstractTimeoutObject.Timeout Property

TnxAbstractTimeoutObject.Timeout Property
TnxAbstractTimeoutObject Class TnxAbstractTimeoutObject Members nxsdServerEngine Namespace TnxAbstractTimeoutObject Properties Send Feedback
Syntax
Delphi
property Timeout: TnxWord32;
Description

Property to read/write the timeout in msec for the object.

Group

TnxAbstractTimeoutObject Properties

Links
TnxAbstractTimeoutObject Class, TnxAbstractTimeoutObject Members, nxsdServerEngine Namespace, TnxAbstractTimeoutObject Properties


TnxAbstractTransContext Class

TnxAbstractTransContext Class
TnxAbstractTransContext Fields TnxAbstractTransContext Methods TnxAbstractTransContext Properties TnxAbstractTransContext Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContextnxsdServerEngine_TnxAbstractTransContext
Syntax
Delphi
TnxAbstractTransContext = class(TnxBaseTransContext);
File

nxsdServerEngine

Description

The abstract declaration of a Server transaction context. All actual transaction context implementations MUST be descendent from this class. This is the server side version of TnxTransContext.

Group

Classes

Links
TnxAbstractTransContext Fields, TnxAbstractTransContext Methods, TnxAbstractTransContext Properties, TnxAbstractTransContext Members, nxsdServerEngine, Classes


TnxAbstractTransContext Members

TnxAbstractTransContext Members
TnxAbstractTransContext Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxAbstractTransContext.

Class

TnxAbstractTransContext Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atcDatabasesHead | This is atcDatabasesHead, a member of class TnxAbstractTransContext.
atcDatabasesPadlock | This is atcDatabasesPadlock, a member of class TnxAbstractTransContext.
atcDatabasesTail | This is atcDatabasesTail, a member of class TnxAbstractTransContext.
atcFailed | private
atcLockedIncDone | This is atcLockedIncDone, a member of class TnxAbstractTransContext.
atcSessionNext | This is atcSessionNext, a member of class TnxAbstractTransContext.
atcSessionPrev | This is atcSessionPrev, a member of class TnxAbstractTransContext.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atcAddToSession |
atcForceRollback |
atcRemoveFromSession |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractTransContext
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create | constructor
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Failed | internal
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
SessionNext | Returns the next TransContext in the list of contexts for *this* session.
SessionPrev | Returns the previous TransContext in the list of contexts for *this* session.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxAbstractTransContext Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxAbstractTransContext.Create Constructor

TnxAbstractTransContext.Create Constructor
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Class Send Feedback
Syntax
Delphi
constructor Create(aSession: TnxAbstractSession; aTimeout: TnxWord32);
Parameters
Parameters | Description
aSession: TnxAbstractSession | the session object the transaction context belongs to
aTimeout: TnxWord32 | the timeout for this TransContext in msec
Description

constructor

Class

TnxAbstractTransContext Class

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Class


TnxAbstractTransContext.Destroy Destructor

TnxAbstractTransContext.Destroy Destructor
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxAbstractTransContext Class

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Class


TnxAbstractTransContext Fields

TnxAbstractTransContext Fields
TnxAbstractTransContext Class Legend Protected Fields Send Feedback

The fields of the TnxAbstractTransContext class are listed here.

Class

TnxAbstractTransContext Class

Protected Fields
Name | Description
atcDatabasesHead | This is atcDatabasesHead, a member of class TnxAbstractTransContext.
atcDatabasesPadlock | This is atcDatabasesPadlock, a member of class TnxAbstractTransContext.
atcDatabasesTail | This is atcDatabasesTail, a member of class TnxAbstractTransContext.
atcFailed | private
atcLockedIncDone | This is atcLockedIncDone, a member of class TnxAbstractTransContext.
atcSessionNext | This is atcSessionNext, a member of class TnxAbstractTransContext.
atcSessionPrev | This is atcSessionPrev, a member of class TnxAbstractTransContext.
Links
TnxAbstractTransContext Class, Legend, Protected Fields


TnxAbstractTransContext.atcDatabasesHead Field

TnxAbstractTransContext.atcDatabasesHead Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcDatabasesHead: TnxAbstractDatabase;
Description

This is atcDatabasesHead, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcDatabasesPadlock Field

TnxAbstractTransContext.atcDatabasesPadlock Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcDatabasesPadlock: TnxPadlock;
Description

This is atcDatabasesPadlock, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcDatabasesTail Field

TnxAbstractTransContext.atcDatabasesTail Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcDatabasesTail: TnxAbstractDatabase;
Description

This is atcDatabasesTail, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcFailed Field

TnxAbstractTransContext.atcFailed Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcFailed: Boolean;
Description

private

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcLockedIncDone Field

TnxAbstractTransContext.atcLockedIncDone Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcLockedIncDone: Boolean;
Description

This is atcLockedIncDone, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcSessionNext Field

TnxAbstractTransContext.atcSessionNext Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcSessionNext: TnxAbstractTransContext;
Description

This is atcSessionNext, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext.atcSessionPrev Field

TnxAbstractTransContext.atcSessionPrev Field
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Fields Send Feedback
Syntax
Delphi
atcSessionPrev: TnxAbstractTransContext;
Description

This is atcSessionPrev, a member of class TnxAbstractTransContext.

Group

TnxAbstractTransContext Fields

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Fields


TnxAbstractTransContext Methods

TnxAbstractTransContext Methods
TnxAbstractTransContext Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxAbstractTransContext class are listed here.

Class

TnxAbstractTransContext Class

Protected Methods
Name | Description
atcAddToSession |
atcForceRollback |
atcRemoveFromSession |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxAbstractTransContext
BeforeDestruction | see TObject.BeforeConstruction
CreateInstanceFor | remoting integration
Failed | internal
PrepareDestroy |
Links
TnxAbstractTransContext Class, Legend, Protected Methods, Public Methods


TnxAbstractTransContext.AfterConstruction Method

TnxAbstractTransContext.AfterConstruction Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

TnxAbstractTransContext

Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.atcAddToSession Method

TnxAbstractTransContext.atcAddToSession Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure atcAddToSession;
Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.atcForceRollback Method

TnxAbstractTransContext.atcForceRollback Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure atcForceRollback; virtual;
Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.atcRemoveFromSession Method

TnxAbstractTransContext.atcRemoveFromSession Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure atcRemoveFromSession;
Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.BeforeDestruction Method

TnxAbstractTransContext.BeforeDestruction Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.CreateInstanceFor Method

TnxAbstractTransContext.CreateInstanceFor Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.Failed Method

TnxAbstractTransContext.Failed Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure Failed; virtual;
Description

internal

Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.GetExceptionData Method

TnxAbstractTransContext.GetExceptionData Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext.PrepareDestroy Method

TnxAbstractTransContext.PrepareDestroy Method
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; override;
Group

TnxAbstractTransContext Methods

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Methods


TnxAbstractTransContext Properties

TnxAbstractTransContext Properties
TnxAbstractTransContext Class Legend Public Properties Send Feedback

The properties of the TnxAbstractTransContext class are listed here.

Class

TnxAbstractTransContext Class

Public Properties
Name | Description
SessionNext | Returns the next TransContext in the list of contexts for *this* session.
SessionPrev | Returns the previous TransContext in the list of contexts for *this* session.
Links
TnxAbstractTransContext Class, Legend, Public Properties


TnxAbstractTransContext.SessionNext Property

TnxAbstractTransContext.SessionNext Property
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Properties Send Feedback
Syntax
Delphi
property SessionNext: TnxAbstractTransContext;
Description

Returns the next TransContext in the list of contexts for *this* session.

Group

TnxAbstractTransContext Properties

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Properties


TnxAbstractTransContext.SessionPrev Property

TnxAbstractTransContext.SessionPrev Property
TnxAbstractTransContext Class TnxAbstractTransContext Members nxsdServerEngine Namespace TnxAbstractTransContext Properties Send Feedback
Syntax
Delphi
property SessionPrev: TnxAbstractTransContext;
Description

Returns the previous TransContext in the list of contexts for *this* session.

Group

TnxAbstractTransContext Properties

Links
TnxAbstractTransContext Class, TnxAbstractTransContext Members, nxsdServerEngine Namespace, TnxAbstractTransContext Properties


TnxAliasDescriptor Class

TnxAliasDescriptor Class
TnxAliasDescriptor Fields TnxAliasDescriptor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxAliasDescriptornxsdServerEngine_TnxAliasDescriptor
Syntax
Delphi
TnxAliasDescriptor = class(TnxObject);
File

nxsdServerEngine

Description

A Database Alias descriptor.

Group

Classes

Links
TnxAliasDescriptor Fields, TnxAliasDescriptor Members, nxsdServerEngine, Classes


TnxAliasDescriptor Members

TnxAliasDescriptor Members
TnxAliasDescriptor Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxAliasDescriptor.

Class

TnxAliasDescriptor Class

Public Fields
Name | Description
adAlias | Alias name
adPath | Directory path for database.
Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxAliasDescriptor Class, Legend, Public Fields, Public Methods


TnxAliasDescriptor Fields

TnxAliasDescriptor Fields
TnxAliasDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxAliasDescriptor class are listed here.

Class

TnxAliasDescriptor Class

Public Fields
Name | Description
adAlias | Alias name
adPath | Directory path for database.
Links
TnxAliasDescriptor Class, Legend, Public Fields


TnxAliasDescriptor.adAlias Field

TnxAliasDescriptor.adAlias Field
TnxAliasDescriptor Class TnxAliasDescriptor Members nxsdServerEngine Namespace TnxAliasDescriptor Fields Send Feedback
Syntax
Delphi
adAlias: string;
Description

Alias name

Group

TnxAliasDescriptor Fields

Links
TnxAliasDescriptor Class, TnxAliasDescriptor Members, nxsdServerEngine Namespace, TnxAliasDescriptor Fields


TnxAliasDescriptor.adPath Field

TnxAliasDescriptor.adPath Field
TnxAliasDescriptor Class TnxAliasDescriptor Members nxsdServerEngine Namespace TnxAliasDescriptor Fields Send Feedback
Syntax
Delphi
adPath: string;
Description

Directory path for database.

Group

TnxAliasDescriptor Fields

Links
TnxAliasDescriptor Class, TnxAliasDescriptor Members, nxsdServerEngine Namespace, TnxAliasDescriptor Fields


TnxBaseEngineExtender Class

TnxBaseEngineExtender Class
TnxBaseEngineExtender Fields TnxBaseEngineExtender Methods TnxBaseEngineExtender Properties TnxBaseEngineExtender Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxBaseEngineExtendernxsdServerEngine_TnxBaseEngineExtendernxsdServerEngine_TnxBaseEngineExtendernxsdServerEngine_TnxBaseEngineExtender
Syntax
Delphi
TnxBaseEngineExtender = class(TnxLifetimeTrackedPersistent);
File

nxsdServerEngine

Description

This is the base for all Extenders used in NexusDB. An extender gets notified about actions in the database core and can change or extend the default behavior. It is generally always created from a TnxBaseEngineMonitor.

Group

Classes

Links
TnxBaseEngineExtender Fields, TnxBaseEngineExtender Methods, TnxBaseEngineExtender Properties, TnxBaseEngineExtender Members, nxsdServerEngine, Classes


TnxBaseEngineExtender Members

TnxBaseEngineExtender Members
TnxBaseEngineExtender Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseEngineExtender.

Class

TnxBaseEngineExtender Class

Protected Fields
Name | Description
beeActions | This is beeActions, a member of class TnxBaseEngineExtender.
beeExtendableObject | This is beeExtendableObject, a member of class TnxBaseEngineExtender.
beeExtendableObjectNext | This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.
beeExtendableObjectPrev | This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.
beeMonitor | private
beeMonitorNext | This is beeMonitorNext, a member of class TnxBaseEngineExtender.
beeMonitorPrev | This is beeMonitorPrev, a member of class TnxBaseEngineExtender.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
beeAddToExtendableObject |
beeAddToMonitor |
beeCreateInstance |
beeRemoveFromExtendableObject |
beeRemoveFromMonitor |
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | constructor
Destroy | destructor.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetLifetimeMontior |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Notify | This function is called for all actions executed in the extended server object ExtendableObject.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Public Properties
Name | Description
ExtendableObject | This property returns the server object the extender extends.
Monitor | This property returns the Monitor the extender was created from.
Links
TnxBaseEngineExtender Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseEngineExtender.Create Constructor

TnxBaseEngineExtender.Create Constructor
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Class Send Feedback
Syntax
Delphi
constructor Create(aMonitor: TnxBaseEngineMonitor; aExtendableObject: TnxExtendableServerObject);
Parameters
Parameters | Description
aMonitor: TnxBaseEngineMonitor | the Monitor that creates the Extender
aExtendableObject: TnxExtendableServerObject | the object the Extender extends.
Description

constructor

Class

TnxBaseEngineExtender Class

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Class


TnxBaseEngineExtender.Destroy Destructor

TnxBaseEngineExtender.Destroy Destructor
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseEngineExtender Class

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Class


TnxBaseEngineExtender Fields

TnxBaseEngineExtender Fields
TnxBaseEngineExtender Class Legend Protected Fields Send Feedback

The fields of the TnxBaseEngineExtender class are listed here.

Class

TnxBaseEngineExtender Class

Protected Fields
Name | Description
beeActions | This is beeActions, a member of class TnxBaseEngineExtender.
beeExtendableObject | This is beeExtendableObject, a member of class TnxBaseEngineExtender.
beeExtendableObjectNext | This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.
beeExtendableObjectPrev | This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.
beeMonitor | private
beeMonitorNext | This is beeMonitorNext, a member of class TnxBaseEngineExtender.
beeMonitorPrev | This is beeMonitorPrev, a member of class TnxBaseEngineExtender.
Links
TnxBaseEngineExtender Class, Legend, Protected Fields


TnxBaseEngineExtender.beeActions Field

TnxBaseEngineExtender.beeActions Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeActions: TnxEngineActions;
Description

This is beeActions, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeExtendableObject Field

TnxBaseEngineExtender.beeExtendableObject Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeExtendableObject: TnxExtendableServerObject;
Description

This is beeExtendableObject, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeExtendableObjectNext Field

TnxBaseEngineExtender.beeExtendableObjectNext Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeExtendableObjectNext: TnxBaseEngineExtender;
Description

This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeExtendableObjectPrev Field

TnxBaseEngineExtender.beeExtendableObjectPrev Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeExtendableObjectPrev: TnxBaseEngineExtender;
Description

This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeMonitor Field

TnxBaseEngineExtender.beeMonitor Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeMonitor: TnxBaseEngineMonitor;
Description

private

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeMonitorNext Field

TnxBaseEngineExtender.beeMonitorNext Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeMonitorNext: TnxBaseEngineExtender;
Description

This is beeMonitorNext, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender.beeMonitorPrev Field

TnxBaseEngineExtender.beeMonitorPrev Field
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Fields Send Feedback
Syntax
Delphi
beeMonitorPrev: TnxBaseEngineExtender;
Description

This is beeMonitorPrev, a member of class TnxBaseEngineExtender.

Group

TnxBaseEngineExtender Fields

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Fields


TnxBaseEngineExtender Methods

TnxBaseEngineExtender Methods
TnxBaseEngineExtender Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseEngineExtender class are listed here.

Class

TnxBaseEngineExtender Class

Protected Methods
Name | Description
beeAddToExtendableObject |
beeAddToMonitor |
beeCreateInstance |
beeRemoveFromExtendableObject |
beeRemoveFromMonitor |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
Notify | This function is called for all actions executed in the extended server object ExtendableObject.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Links
TnxBaseEngineExtender Class, Legend, Protected Methods, Public Methods


TnxBaseEngineExtender.beeAddToExtendableObject Method

TnxBaseEngineExtender.beeAddToExtendableObject Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure beeAddToExtendableObject;
Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.beeAddToMonitor Method

TnxBaseEngineExtender.beeAddToMonitor Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure beeAddToMonitor;
Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.beeCreateInstance Method

TnxBaseEngineExtender.beeCreateInstance Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
function beeCreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.beeRemoveFromExtendableObject Method

TnxBaseEngineExtender.beeRemoveFromExtendableObject Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure beeRemoveFromExtendableObject;
Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.beeRemoveFromMonitor Method

TnxBaseEngineExtender.beeRemoveFromMonitor Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure beeRemoveFromMonitor;
Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.GetExceptionData Method

TnxBaseEngineExtender.GetExceptionData Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.Notify Method

TnxBaseEngineExtender.Notify Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
function Notify(aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aAction: TnxEngineAction | the type of action executed
aBefore: Boolean | if this is true then the server engine is just about to execute the given action, otherwise it was just executed.
const aArgs: array of const | the parameters used for the given action type.
Description

This function is called for all actions executed in the extended server object ExtendableObject.

Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender.PrepareDestroy Method

TnxBaseEngineExtender.PrepareDestroy Method
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; virtual;
Description

called just before the destructor is called to allow for removal of dependencies between components.

Group

TnxBaseEngineExtender Methods

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Methods


TnxBaseEngineExtender Properties

TnxBaseEngineExtender Properties
TnxBaseEngineExtender Class Legend Public Properties Send Feedback

The properties of the TnxBaseEngineExtender class are listed here.

Class

TnxBaseEngineExtender Class

Public Properties
Name | Description
ExtendableObject | This property returns the server object the extender extends.
Monitor | This property returns the Monitor the extender was created from.
Links
TnxBaseEngineExtender Class, Legend, Public Properties


TnxBaseEngineExtender.ExtendableObject Property

TnxBaseEngineExtender.ExtendableObject Property
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Properties Send Feedback
Syntax
Delphi
property ExtendableObject: TnxExtendableServerObject;
Description

This property returns the server object the extender extends.

Group

TnxBaseEngineExtender Properties

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Properties


TnxBaseEngineExtender.Monitor Property

TnxBaseEngineExtender.Monitor Property
TnxBaseEngineExtender Class TnxBaseEngineExtender Members nxsdServerEngine Namespace TnxBaseEngineExtender Properties Send Feedback
Syntax
Delphi
property Monitor: TnxBaseEngineMonitor;
Description

This property returns the Monitor the extender was created from.

Group

TnxBaseEngineExtender Properties

Links
TnxBaseEngineExtender Class, TnxBaseEngineExtender Members, nxsdServerEngine Namespace, TnxBaseEngineExtender Properties


TnxBaseEngineMonitor Class

TnxBaseEngineMonitor Class
TnxBaseEngineMonitor Fields TnxBaseEngineMonitor Methods TnxBaseEngineMonitor Properties TnxBaseEngineMonitor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitornxsdServerEngine_TnxBaseEngineMonitor
Syntax
Delphi
TnxBaseEngineMonitor = class(TnxStateComponent);
File

nxsdServerEngine

Description

This is the base engine monitor. An engine monitor is responsible for creating and freeing engine extenders. A monitor is notified about every creation and destruction of a server object.

Group

Classes

Links
TnxBaseEngineMonitor Fields, TnxBaseEngineMonitor Methods, TnxBaseEngineMonitor Properties, TnxBaseEngineMonitor Members, nxsdServerEngine, Classes


TnxBaseEngineMonitor Members

TnxBaseEngineMonitor Members
TnxBaseEngineMonitor Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseEngineMonitor.

Class

TnxBaseEngineMonitor Class

Protected Fields
Name | Description
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bemSetServerEngine |
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
ExtendableObjectCreated | This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | This property links the Monitor to a server engine.
Version | Version of the component.
Links
TnxBaseEngineMonitor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseEngineMonitor.Create Constructor

TnxBaseEngineMonitor.Create Constructor
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

Class

TnxBaseEngineMonitor Class

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Class


TnxBaseEngineMonitor.Destroy Destructor

TnxBaseEngineMonitor.Destroy Destructor
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseEngineMonitor Class

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Class


TnxBaseEngineMonitor Fields

TnxBaseEngineMonitor Fields
TnxBaseEngineMonitor Class Legend Protected Fields Send Feedback

The fields of the TnxBaseEngineMonitor class are listed here.

Class

TnxBaseEngineMonitor Class

Protected Fields
Name | Description
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
Links
TnxBaseEngineMonitor Class, Legend, Protected Fields


TnxBaseEngineMonitor.bemExtendersHead Field

TnxBaseEngineMonitor.bemExtendersHead Field
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Fields Send Feedback
Syntax
Delphi
bemExtendersHead: TnxBaseEngineExtender;
Description

This is bemExtendersHead, a member of class TnxBaseEngineMonitor.

Group

TnxBaseEngineMonitor Fields

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Fields


TnxBaseEngineMonitor.bemExtendersLock Field

TnxBaseEngineMonitor.bemExtendersLock Field
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Fields Send Feedback
Syntax
Delphi
bemExtendersLock: TnxPadlock;
Description

This is bemExtendersLock, a member of class TnxBaseEngineMonitor.

Group

TnxBaseEngineMonitor Fields

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Fields


TnxBaseEngineMonitor.bemExtendersTail Field

TnxBaseEngineMonitor.bemExtendersTail Field
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Fields Send Feedback
Syntax
Delphi
bemExtendersTail: TnxBaseEngineExtender;
Description

This is bemExtendersTail, a member of class TnxBaseEngineMonitor.

Group

TnxBaseEngineMonitor Fields

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Fields


TnxBaseEngineMonitor.bemServerEngine Field

TnxBaseEngineMonitor.bemServerEngine Field
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Fields Send Feedback
Syntax
Delphi
bemServerEngine: TnxBaseServerEngine;
Description

private

Group

TnxBaseEngineMonitor Fields

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Fields


TnxBaseEngineMonitor Methods

TnxBaseEngineMonitor Methods
TnxBaseEngineMonitor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseEngineMonitor class are listed here.

Class

TnxBaseEngineMonitor Class

Protected Methods
Name | Description
bemSetServerEngine |
nxcNotification |
scDependentStateChange |
scIsStateParent |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Public Methods
Name | Description
ExtendableObjectCreated | This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
Links
TnxBaseEngineMonitor Class, Legend, Protected Methods, Public Methods


TnxBaseEngineMonitor.bemSetServerEngine Method

TnxBaseEngineMonitor.bemSetServerEngine Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure bemSetServerEngine(aEngine: TnxBaseServerEngine); virtual;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.ExtendableObjectCreated Method

TnxBaseEngineMonitor.ExtendableObjectCreated Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure ExtendableObjectCreated(aExtendableObject: TnxExtendableServerObject); virtual;
Parameters
Parameters | Description
aExtendableObject: TnxExtendableServerObject | This is the pointer to the object that was just created.
Description

This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.

Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.ExtendableObjectDestroyed Method

TnxBaseEngineMonitor.ExtendableObjectDestroyed Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure ExtendableObjectDestroyed(aExtendableObject: TnxExtendableServerObject); virtual;
Parameters
Parameters | Description
aExtendableObject: TnxExtendableServerObject | This is the pointer to the object that was just created.
Description

This method is called every time a server object is destroyed within the linked Server engine.

Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.nxcNotification Method

TnxBaseEngineMonitor.nxcNotification Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure nxcNotification(aSender: TnxComponent; aOperation: TnxNotifyOp; aParam: Pointer); override;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.scDependentStateChange Method

TnxBaseEngineMonitor.scDependentStateChange Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure scDependentStateChange(aSender: TnxStateComponent; aBefore: Boolean; aOldState: TnxState; aNewState: TnxState); override;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.scIsStateParent Method

TnxBaseEngineMonitor.scIsStateParent Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
function scIsStateParent(aComponent: TnxStateComponent): Boolean; override;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.scStopping Method

TnxBaseEngineMonitor.scStopping Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.ServerEngineStarting Method

TnxBaseEngineMonitor.ServerEngineStarting Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure ServerEngineStarting; virtual;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor.ServerEngineStopped Method

TnxBaseEngineMonitor.ServerEngineStopped Method
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Methods Send Feedback
Syntax
Delphi
procedure ServerEngineStopped; virtual;
Group

TnxBaseEngineMonitor Methods

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Methods


TnxBaseEngineMonitor Properties

TnxBaseEngineMonitor Properties
TnxBaseEngineMonitor Class Legend Published Properties Send Feedback

The properties of the TnxBaseEngineMonitor class are listed here.

Class

TnxBaseEngineMonitor Class

Published Properties
Name | Description
ServerEngine | This property links the Monitor to a server engine.
Links
TnxBaseEngineMonitor Class, Legend, Published Properties


TnxBaseEngineMonitor.ServerEngine Property

TnxBaseEngineMonitor.ServerEngine Property
TnxBaseEngineMonitor Class TnxBaseEngineMonitor Members nxsdServerEngine Namespace TnxBaseEngineMonitor Properties Send Feedback
Syntax
Delphi
property ServerEngine: TnxBaseServerEngine;
Description

This property links the Monitor to a server engine.

Group

TnxBaseEngineMonitor Properties

Links
TnxBaseEngineMonitor Class, TnxBaseEngineMonitor Members, nxsdServerEngine Namespace, TnxBaseEngineMonitor Properties


TnxBaseServerEngine Class

TnxBaseServerEngine Class
TnxBaseServerEngine Fields TnxBaseServerEngine Methods TnxBaseServerEngine Properties TnxBaseServerEngine Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEnginenxsdServerEngine_TnxBaseServerEngine
Syntax
Delphi
TnxBaseServerEngine = class(TnxStateComponent);
File

nxsdServerEngine

Description

This is the base for all Server Engine implementations in NexusDB. All actual server engines are descendent from this class. Please note that a server engine does not do a lot of stuff on its own. It's a mainly a center point that holds together all engines and their instances of server objects.

Group

Classes

Links
TnxBaseServerEngine Fields, TnxBaseServerEngine Methods, TnxBaseServerEngine Properties, TnxBaseServerEngine Members, nxsdServerEngine, Classes


TnxBaseServerEngine Members

TnxBaseServerEngine Members
TnxBaseServerEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxBaseServerEngine.

Class

TnxBaseServerEngine Class

Protected Fields
Name | Description
bseCursorCount | This is bseCursorCount, a member of class TnxBaseServerEngine.
bseDatabaseCount | This is bseDatabaseCount, a member of class TnxBaseServerEngine.
bseMonitors | This is bseMonitors, a member of class TnxBaseServerEngine.
bseSessionCount | This is bseSessionCount, a member of class TnxBaseServerEngine.
bseSessionsHead | This is bseSessionsHead, a member of class TnxBaseServerEngine.
bseSessionsPadlock | private
bseSessionsTail | This is bseSessionsTail, a member of class TnxBaseServerEngine.
bseStatementCount | This is bseStatementCount, a member of class TnxBaseServerEngine.
bseTransContextCount | This is bseTransContextCount, a member of class TnxBaseServerEngine.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bseConvertException | TnxBaseServerEngine
bseCreateInstanceFor |
bseGetExceptionClass | This is bseGetExceptionClass, a member of class TnxBaseServerEngine.
bseGetKeepSessionStats |
bseGetServerGuid | This is bseGetServerGuid, a member of class TnxBaseServerEngine.
bseGetServerName | This is bseGetServerName, a member of class TnxBaseServerEngine.
bseInactive |
bseInformMonitorsCreated |
bseInformMonitorsDestroyed |
GetExceptionData |
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | This function resets all statistical values.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor.
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | This function returns the captions for the statistics page on the server gui.
GetStatsValues | This function returns the values for the statistics page on the server gui.
IsSecureServer |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
SessionOpen | This function opens creates a new session.
SessionOpenEx | This function opens creates a new session. It additionally passes the Client Version. This function can be used to support older clients on a newer version on the server.
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
CursorCount | CursorCount returns the number of open cursors in this server engine
DatabaseCount | DatabaseCount returns the number of open databases in this server engine.
SavedActive | Can be used to save a certain state.
ServerGuid | Returns a unique ID for this server.
ServerName | This is ServerName, a member of class TnxBaseServerEngine.
SessionCount | SessionCount returns the number of open session in this server engine
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StatementCount | StatementCount returns the number of open (SQL) statements in this server engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
TransContextCount | TransContextCount returns the number of transaction contexts in this server engine.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
Version | Version of the component.
Links
TnxBaseServerEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Properties


TnxBaseServerEngine.Create Constructor

TnxBaseServerEngine.Create Constructor
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TComponent); override;
Description

constructor.

Class

TnxBaseServerEngine Class

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Class


TnxBaseServerEngine.Destroy Destructor

TnxBaseServerEngine.Destroy Destructor
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxBaseServerEngine Class

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Class


TnxBaseServerEngine Fields

TnxBaseServerEngine Fields
TnxBaseServerEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseServerEngine class are listed here.

Class

TnxBaseServerEngine Class

Protected Fields
Name | Description
bseCursorCount | This is bseCursorCount, a member of class TnxBaseServerEngine.
bseDatabaseCount | This is bseDatabaseCount, a member of class TnxBaseServerEngine.
bseMonitors | This is bseMonitors, a member of class TnxBaseServerEngine.
bseSessionCount | This is bseSessionCount, a member of class TnxBaseServerEngine.
bseSessionsHead | This is bseSessionsHead, a member of class TnxBaseServerEngine.
bseSessionsPadlock | private
bseSessionsTail | This is bseSessionsTail, a member of class TnxBaseServerEngine.
bseStatementCount | This is bseStatementCount, a member of class TnxBaseServerEngine.
bseTransContextCount | This is bseTransContextCount, a member of class TnxBaseServerEngine.
Links
TnxBaseServerEngine Class, Legend, Protected Fields


TnxBaseServerEngine.bseCursorCount Field

TnxBaseServerEngine.bseCursorCount Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseCursorCount: Integer;
Description

This is bseCursorCount, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseDatabaseCount Field

TnxBaseServerEngine.bseDatabaseCount Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseDatabaseCount: Integer;
Description

This is bseDatabaseCount, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseMonitors Field

TnxBaseServerEngine.bseMonitors Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseMonitors: TnxListPortal;
Description

This is bseMonitors, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseSessionCount Field

TnxBaseServerEngine.bseSessionCount Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseSessionCount: Integer;
Description

This is bseSessionCount, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseSessionsHead Field

TnxBaseServerEngine.bseSessionsHead Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseSessionsHead: TnxAbstractSession;
Description

This is bseSessionsHead, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseSessionsPadlock Field

TnxBaseServerEngine.bseSessionsPadlock Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseSessionsPadlock: TnxPadlock;
Description

private

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseSessionsTail Field

TnxBaseServerEngine.bseSessionsTail Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseSessionsTail: TnxAbstractSession;
Description

This is bseSessionsTail, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseStatementCount Field

TnxBaseServerEngine.bseStatementCount Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseStatementCount: Integer;
Description

This is bseStatementCount, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine.bseTransContextCount Field

TnxBaseServerEngine.bseTransContextCount Field
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Fields Send Feedback
Syntax
Delphi
bseTransContextCount: Integer;
Description

This is bseTransContextCount, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Fields

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Fields


TnxBaseServerEngine Methods

TnxBaseServerEngine Methods
TnxBaseServerEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseServerEngine class are listed here.

Class

TnxBaseServerEngine Class

Protected Methods
Name | Description
bseConvertException | TnxBaseServerEngine
bseCreateInstanceFor |
bseGetExceptionClass | This is bseGetExceptionClass, a member of class TnxBaseServerEngine.
bseGetKeepSessionStats |
bseGetServerGuid | This is bseGetServerGuid, a member of class TnxBaseServerEngine.
bseGetServerName | This is bseGetServerName, a member of class TnxBaseServerEngine.
bseInactive |
bseInformMonitorsCreated |
bseInformMonitorsDestroyed |
GetExceptionData |
nxcAddDependent |
nxcRemoveDependent |
scInitializing |
scShowUpTime |
scStopping |
Public Methods
Name | Description
ClearStats | This function resets all statistical values.
GetStatsCaptions | This function returns the captions for the statistics page on the server gui.
GetStatsValues | This function returns the values for the statistics page on the server gui.
IsSecureServer |
SessionOpen | This function opens creates a new session.
SessionOpenEx | This function opens creates a new session. It additionally passes the Client Version. This function can be used to support older clients on a newer version on the server.
Links
TnxBaseServerEngine Class, Legend, Protected Methods, Public Methods


TnxBaseServerEngine.bseConvertException Method

TnxBaseServerEngine.bseConvertException Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseConvertException(aException: Exception; aSource: TnxAbstractServerObject): TnxResult; virtual;
Description

TnxBaseServerEngine

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseCreateInstanceFor Method

TnxBaseServerEngine.bseCreateInstanceFor Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseCreateInstanceFor(aSession: TnxAbstractSession; const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseGetExceptionClass Method

TnxBaseServerEngine.bseGetExceptionClass Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetExceptionClass: EnxExceptionClass; virtual; abstract;
Description

This is bseGetExceptionClass, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseGetKeepSessionStats Method

TnxBaseServerEngine.bseGetKeepSessionStats Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetKeepSessionStats: Boolean; virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseGetServerGuid Method

TnxBaseServerEngine.bseGetServerGuid Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetServerGuid: TnxGuid; virtual; abstract;
Description

This is bseGetServerGuid, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseGetServerName Method

TnxBaseServerEngine.bseGetServerName Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function bseGetServerName: string; virtual; abstract;
Description

This is bseGetServerName, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseInactive Method

TnxBaseServerEngine.bseInactive Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure bseInactive; virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseInformMonitorsCreated Method

TnxBaseServerEngine.bseInformMonitorsCreated Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure bseInformMonitorsCreated(aExtendableObject: TnxExtendableServerObject); virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.bseInformMonitorsDestroyed Method

TnxBaseServerEngine.bseInformMonitorsDestroyed Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure bseInformMonitorsDestroyed(aExtendableObject: TnxExtendableServerObject); virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.ClearStats Method

TnxBaseServerEngine.ClearStats Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure ClearStats; override;
Description

This function resets all statistical values.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.GetExceptionData Method

TnxBaseServerEngine.GetExceptionData Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.GetStatsCaptions Method

TnxBaseServerEngine.GetStatsCaptions Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure GetStatsCaptions(const aList: TStrings); override;
Description

This function returns the captions for the statistics page on the server gui.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.GetStatsValues Method

TnxBaseServerEngine.GetStatsValues Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure GetStatsValues(const aList: TStrings); override;
Description

This function returns the values for the statistics page on the server gui.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.IsSecureServer Method

TnxBaseServerEngine.IsSecureServer Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function IsSecureServer: Boolean; virtual;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.nxcAddDependent Method

TnxBaseServerEngine.nxcAddDependent Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure nxcAddDependent(aComponent: TnxComponent); override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.nxcRemoveDependent Method

TnxBaseServerEngine.nxcRemoveDependent Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure nxcRemoveDependent(aComponent: TnxComponent); override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.scInitializing Method

TnxBaseServerEngine.scInitializing Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure scInitializing; override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.scShowUpTime Method

TnxBaseServerEngine.scShowUpTime Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function scShowUpTime: Boolean; override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.scStopping Method

TnxBaseServerEngine.scStopping Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
procedure scStopping; override;
Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.SessionOpen Method

TnxBaseServerEngine.SessionOpen Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function SessionOpen(out aSession: TnxAbstractSession; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: TnxWord32): TnxResult; virtual;
Parameters
Parameters | Description
out aSession: TnxAbstractSession | the returned instance of a TnxAbstractSession descendant
const aUserName: UnicodeString | the user name used to authenticate the session if security is enabled. A security monitor needs to be attached for this to work.
const aPassword: UnicodeString | the password used to authenticate the session if security is enabled
aTimeout: TnxWord32 | the timeout for the newly created session in msec
Description

This function opens creates a new session.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine.SessionOpenEx Method

TnxBaseServerEngine.SessionOpenEx Method
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Methods Send Feedback
Syntax
Delphi
function SessionOpenEx(out aSession: TnxAbstractSession; const aUserName: UnicodeString; const aPassword: UnicodeString; const aConnectedFrom: string; aTimeout: TnxWord32; aClientVersion: Integer): TnxResult; virtual; abstract;
Parameters
Parameters | Description
out aSession: TnxAbstractSession | the returned instance of a TnxAbstractSession descendant
const aUserName: UnicodeString | the user name used to authenticate the session if security is enabled. A security monitor needs to be attached for this to work.
const aPassword: UnicodeString | the password used to authenticate the session if security is enabled
aTimeout: TnxWord32 | the timeout for the newly created session in msec
aClientVersion: Integer | the version of the NexusDB core on the client side
Description

This function opens creates a new session. It additionally passes the Client Version. This function can be used to support older clients on a newer version on the server.

Group

TnxBaseServerEngine Methods

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Methods


TnxBaseServerEngine Properties

TnxBaseServerEngine Properties
TnxBaseServerEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseServerEngine class are listed here.

Class

TnxBaseServerEngine Class

Public Properties
Name | Description
CursorCount | CursorCount returns the number of open cursors in this server engine
DatabaseCount | DatabaseCount returns the number of open databases in this server engine.
ServerGuid | Returns a unique ID for this server.
ServerName | This is ServerName, a member of class TnxBaseServerEngine.
SessionCount | SessionCount returns the number of open session in this server engine
StatementCount | StatementCount returns the number of open (SQL) statements in this server engine.
TransContextCount | TransContextCount returns the number of transaction contexts in this server engine.
Links
TnxBaseServerEngine Class, Legend, Public Properties


TnxBaseServerEngine.CursorCount Property

TnxBaseServerEngine.CursorCount Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property CursorCount: Integer;
Description

CursorCount returns the number of open cursors in this server engine

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.DatabaseCount Property

TnxBaseServerEngine.DatabaseCount Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property DatabaseCount: Integer;
Description

DatabaseCount returns the number of open databases in this server engine.

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.ServerGuid Property

TnxBaseServerEngine.ServerGuid Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property ServerGuid: TnxGuid;
Description

Returns a unique ID for this server.

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.ServerName Property

TnxBaseServerEngine.ServerName Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property ServerName: string;
Description

This is ServerName, a member of class TnxBaseServerEngine.

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.SessionCount Property

TnxBaseServerEngine.SessionCount Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property SessionCount: Integer;
Description

SessionCount returns the number of open session in this server engine

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.StatementCount Property

TnxBaseServerEngine.StatementCount Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property StatementCount: Integer;
Description

StatementCount returns the number of open (SQL) statements in this server engine.

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseServerEngine.TransContextCount Property

TnxBaseServerEngine.TransContextCount Property
TnxBaseServerEngine Class TnxBaseServerEngine Members nxsdServerEngine Namespace TnxBaseServerEngine Properties Send Feedback
Syntax
Delphi
property TransContextCount: Integer;
Description

TransContextCount returns the number of transaction contexts in this server engine.

Group

TnxBaseServerEngine Properties

Links
TnxBaseServerEngine Class, TnxBaseServerEngine Members, nxsdServerEngine Namespace, TnxBaseServerEngine Properties


TnxBaseTransContext Class

TnxBaseTransContext Class
TnxBaseTransContext Methods TnxBaseTransContext Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContextnxsdServerEngine_TnxBaseTransContext
Syntax
Delphi
TnxBaseTransContext = class(TnxAbstractTimeoutObject);
File

nxsdServerEngine

Description

The base class for transaction contexts, both TnxAbstractTransContext and TnxAbstractDatabase derive from this class.

Group

Classes

Links
TnxBaseTransContext Methods, TnxBaseTransContext Members, nxsdServerEngine, Classes


TnxBaseTransContext Members

TnxBaseTransContext Members
TnxBaseTransContext Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTransContext.

Class

TnxBaseTransContext Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create |
Create | constructor.
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxBaseTransContext Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTransContext Methods

TnxBaseTransContext Methods
TnxBaseTransContext Class Legend Public Methods Send Feedback

The methods of the TnxBaseTransContext class are listed here.

Class

TnxBaseTransContext Class

Public Methods
Name | Description
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Links
TnxBaseTransContext Class, Legend, Public Methods


TnxBaseTransContext.TransactionCommit Method

TnxBaseTransContext.TransactionCommit Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionCommit: TnxResult; virtual; abstract;
Description

This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxBaseTransContext.TransactionCorrupted Method

TnxBaseTransContext.TransactionCorrupted Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionCorrupted: TnxResult; virtual; abstract;
Description

This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxBaseTransContext.TransactionGetLevel Method

TnxBaseTransContext.TransactionGetLevel Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionGetLevel(out aTransLevel: Integer): TnxResult; virtual; abstract;
Description

This method returns the nesting level of the current transaction.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxBaseTransContext.TransactionRollback Method

TnxBaseTransContext.TransactionRollback Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionRollback: TnxResult; virtual; abstract;
Description

Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxBaseTransContext.TransactionStart Method

TnxBaseTransContext.TransactionStart Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionStart(aFailSafe: Boolean; aSnapShot: Boolean): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFailSafe: Boolean | if true it must be handled as fail safe.
aSnapShot: Boolean | if true it is handled as a SnapshotTransaction
Description
- transaction management -

StartTransaction tries to start a transaction. If it fails an exception is triggered.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxBaseTransContext.TransactionStartWith Method

TnxBaseTransContext.TransactionStartWith Method
TnxBaseTransContext Class TnxBaseTransContext Members nxsdServerEngine Namespace TnxBaseTransContext Methods Send Feedback
Syntax
Delphi
function TransactionStartWith(aFailSafe: Boolean; aSnapShot: Boolean; const aCursors: array of TnxAbstractCursor): TnxResult; virtual; abstract;
Parameters
Parameters | Description
aFailSafe: Boolean | if true it must be handled as fail safe.
aSnapShot: Boolean | if true it is handled as a SnapshotTransaction
const aCursors: array of TnxAbstractCursor | the cursors that should be part of the transaction
Description

Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.

Group

TnxBaseTransContext Methods

Links
TnxBaseTransContext Class, TnxBaseTransContext Members, nxsdServerEngine Namespace, TnxBaseTransContext Methods


TnxExtendableServerObject Class

TnxExtendableServerObject Class
TnxExtendableServerObject Fields TnxExtendableServerObject Methods TnxExtendableServerObject Properties TnxExtendableServerObject Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxExtendableServerObjectnxsdServerEngine_TnxExtendableServerObjectnxsdServerEngine_TnxExtendableServerObjectnxsdServerEngine_TnxExtendableServerObjectnxsdServerEngine_TnxExtendableServerObjectnxsdServerEngine_TnxExtendableServerObject
Syntax
Delphi
TnxExtendableServerObject = class(TnxAbstractServerObject);
File

nxsdServerEngine

Description

The base class for Server objects that can be extended with an Extender.

Group

Classes

Links
TnxExtendableServerObject Fields, TnxExtendableServerObject Methods, TnxExtendableServerObject Properties, TnxExtendableServerObject Members, nxsdServerEngine, Classes


TnxExtendableServerObject Members

TnxExtendableServerObject Members
TnxExtendableServerObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxExtendableServerObject.

Class

TnxExtendableServerObject Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoSetRemoteThreadPriority |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Create | constructor.
CreateInstanceFor | remoting integration
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxExtendableServerObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxExtendableServerObject.Create Constructor

TnxExtendableServerObject.Create Constructor
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxExtendableServerObject);
Description

constructor.

Class

TnxExtendableServerObject Class

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Class


TnxExtendableServerObject.Destroy Destructor

TnxExtendableServerObject.Destroy Destructor
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxExtendableServerObject Class

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Class


TnxExtendableServerObject Fields

TnxExtendableServerObject Fields
TnxExtendableServerObject Class Legend Protected Fields Send Feedback

The fields of the TnxExtendableServerObject class are listed here.

Class

TnxExtendableServerObject Class

Protected Fields
Name | Description
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
Links
TnxExtendableServerObject Class, Legend, Protected Fields


TnxExtendableServerObject.esoExtendersActions Field

TnxExtendableServerObject.esoExtendersActions Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoExtendersActions: TnxEngineActions;
Description

This is esoExtendersActions, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoExtendersHead Field

TnxExtendableServerObject.esoExtendersHead Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoExtendersHead: TnxBaseEngineExtender;
Description

This is esoExtendersHead, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoExtendersLock Field

TnxExtendableServerObject.esoExtendersLock Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoExtendersLock: TnxPadlock;
Description

This is esoExtendersLock, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoExtendersTail Field

TnxExtendableServerObject.esoExtendersTail Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoExtendersTail: TnxBaseEngineExtender;
Description

This is esoExtendersTail, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoIgnoreSecurity Field

TnxExtendableServerObject.esoIgnoreSecurity Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoIgnoreSecurity: Integer;
Description

This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoOptions Field

TnxExtendableServerObject.esoOptions Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoOptions: TStringList;
Description

This is esoOptions, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject.esoParent Field

TnxExtendableServerObject.esoParent Field
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Fields Send Feedback
Syntax
Delphi
esoParent: TnxExtendableServerObject;
Description

private

Group

TnxExtendableServerObject Fields

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Fields


TnxExtendableServerObject Methods

TnxExtendableServerObject Methods
TnxExtendableServerObject Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxExtendableServerObject class are listed here.

Class

TnxExtendableServerObject Class

Protected Methods
Name | Description
asoGetServerEngine |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetExceptionData | InxExceptionData
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
CreateInstanceFor | remoting integration
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
Links
TnxExtendableServerObject Class, Legend, Protected Methods, Public Methods


TnxExtendableServerObject.AfterConstruction Method

TnxExtendableServerObject.AfterConstruction Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure AfterConstruction; override;
Description

see TObject.AfterConstruction

TnxExtendableServerObject

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.asoGetServerEngine Method

TnxExtendableServerObject.asoGetServerEngine Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function asoGetServerEngine: TnxBaseServerEngine; override;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.BeforeDestruction Method

TnxExtendableServerObject.BeforeDestruction Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure BeforeDestruction; override;
Description

see TObject.BeforeConstruction

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.BeginIgnoreSecurity Method

TnxExtendableServerObject.BeginIgnoreSecurity Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure BeginIgnoreSecurity;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.CreateInstanceFor Method

TnxExtendableServerObject.CreateInstanceFor Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function CreateInstanceFor(const aName: string; const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; override;
Description

remoting integration

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.EndIgnoreSecurity Method

TnxExtendableServerObject.EndIgnoreSecurity Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure EndIgnoreSecurity;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoCreateInstance Method

TnxExtendableServerObject.esoCreateInstance Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoCreateInstance(const aClassID: TnxGuid; const aOuter: InxInterface; const aInterfaceID: TnxGuid; out aInterface): HRESULT; virtual;
Description

remoting integration

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoGetOptions Method

TnxExtendableServerObject.esoGetOptions Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoGetOptions: TStringList;
Description

options

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoGetOptionsParent Method

TnxExtendableServerObject.esoGetOptionsParent Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoGetOptionsParent: TnxExtendableServerObject; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoInformMonitors Method

TnxExtendableServerObject.esoInformMonitors Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoInformMonitors: Boolean; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionChanged Method

TnxExtendableServerObject.esoOptionChanged Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure esoOptionChanged(const aName: string; const aValue: string); virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionClear Method

TnxExtendableServerObject.esoOptionClear Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionClear(const aName: string): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionGet Method

TnxExtendableServerObject.esoOptionGet Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionGet(const aName: string; out aValue: string): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionGetEffective Method

TnxExtendableServerObject.esoOptionGetEffective Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionGetEffective(const aName: string; out aValue: string): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionGetParent Method

TnxExtendableServerObject.esoOptionGetParent Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionGetParent(const aName: string; out aValue: string): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionList Method

TnxExtendableServerObject.esoOptionList Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionList(aList: TStrings): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionListEffective Method

TnxExtendableServerObject.esoOptionListEffective Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionListEffective(aList: TStrings): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionListMerge Method

TnxExtendableServerObject.esoOptionListMerge Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionListMerge(aOwnList: TStrings; aParentList: TStrings): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionListParent Method

TnxExtendableServerObject.esoOptionListParent Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionListParent(aList: TStrings): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.esoOptionSet Method

TnxExtendableServerObject.esoOptionSet Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionSet(const aName: string; const aValue: string): TnxResult; virtual;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.GetExceptionData Method

TnxExtendableServerObject.GetExceptionData Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure GetExceptionData(const aContainer: InxExceptionDataContainer; aIncludeChildren: Boolean = False); override;
Description

InxExceptionData

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.GetExtenderOfType Method

TnxExtendableServerObject.GetExtenderOfType Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function GetExtenderOfType(aExtenderClass: TnxBaseEngineExtenderClass): TnxBaseEngineExtender;
Description

returns the first Extender of a certain class type of the registered Extender list

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.NotifyExtenders Method

TnxExtendableServerObject.NotifyExtenders Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function NotifyExtenders(aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult; virtual;
Parameters
Parameters | Description
aAction: TnxEngineAction | The action that is going to be executed or was executed.
aBefore: Boolean | This Parameter is true if the Action is going to be executed.
const aArgs: array of const | a number of Arguments passed in and/or out of the function
Description

This function is called to notify all Monitors attached to the owning Server Engine of an Action.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionClear Method

TnxExtendableServerObject.OptionClear Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionClear(const aName: string): TnxResult; virtual;
Description

=== options === Removes an Option from the named option list

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionGet Method

TnxExtendableServerObject.OptionGet Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionGet(const aName: string; out aValue: string): TnxResult; virtual;
Description

Returns the value of an Option in named option list of *this* object only.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionGetEffective Method

TnxExtendableServerObject.OptionGetEffective Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionGetEffective(const aName: string; out aValue: string): TnxResult; virtual;
Description

Returns the value of an Option in named option by walking the parent hierarchy until a value is found.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionList Method

TnxExtendableServerObject.OptionList Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionList(aList: TStrings): TnxResult; virtual;
Description

Returns all options as value list (name=value) of this object.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionListEffective Method

TnxExtendableServerObject.OptionListEffective Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionListEffective(aList: TStrings): TnxResult; virtual;
Description

Returns all options as value list (name=value) of the whole parent hierarchy.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.OptionSet Method

TnxExtendableServerObject.OptionSet Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
function OptionSet(const aName: string; const aValue: string): TnxResult; virtual;
Description

Sets an Option in named option list to a certain value.

Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject.PrepareDestroy Method

TnxExtendableServerObject.PrepareDestroy Method
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Methods Send Feedback
Syntax
Delphi
procedure PrepareDestroy; override;
Group

TnxExtendableServerObject Methods

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Methods


TnxExtendableServerObject Properties

TnxExtendableServerObject Properties
TnxExtendableServerObject Class Legend Public Properties Send Feedback

The properties of the TnxExtendableServerObject class are listed here.

Class

TnxExtendableServerObject Class

Public Properties
Name | Description
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
Links
TnxExtendableServerObject Class, Legend, Public Properties


TnxExtendableServerObject.IgnoreSecurity Property

TnxExtendableServerObject.IgnoreSecurity Property
TnxExtendableServerObject Class TnxExtendableServerObject Members nxsdServerEngine Namespace TnxExtendableServerObject Properties Send Feedback
Syntax
Delphi
property IgnoreSecurity: Boolean;
Description

This is IgnoreSecurity, a member of class TnxExtendableServerObject.

Group

TnxExtendableServerObject Properties

Links
TnxExtendableServerObject Class, TnxExtendableServerObject Members, nxsdServerEngine Namespace, TnxExtendableServerObject Properties


TnxLockedOptionsExtendableServerObject Class

TnxLockedOptionsExtendableServerObject Class
TnxLockedOptionsExtendableServerObject Fields TnxLockedOptionsExtendableServerObject Methods TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObjectnxsdServerEngine_TnxLockedOptionsExtendableServerObject
Syntax
Delphi
TnxLockedOptionsExtendableServerObject = class(TnxExtendableServerObject);
File

nxsdServerEngine

Description

The base class for extendable objects that require a locked named options list.

Group

Classes

Links
TnxLockedOptionsExtendableServerObject Fields, TnxLockedOptionsExtendableServerObject Methods, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine, Classes


TnxLockedOptionsExtendableServerObject Members

TnxLockedOptionsExtendableServerObject Members
TnxLockedOptionsExtendableServerObject Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxLockedOptionsExtendableServerObject.

Class

TnxLockedOptionsExtendableServerObject Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
loesoOptionsLock | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Create |
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
Destroy | destructor. TnxLockedOptionsExtendableServerObject
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear | DOM-IGNORE-BEGIN
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxLockedOptionsExtendableServerObject Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxLockedOptionsExtendableServerObject.Destroy Destructor

TnxLockedOptionsExtendableServerObject.Destroy Destructor
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

TnxLockedOptionsExtendableServerObject

Class

TnxLockedOptionsExtendableServerObject Class

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Class


TnxLockedOptionsExtendableServerObject Fields

TnxLockedOptionsExtendableServerObject Fields
TnxLockedOptionsExtendableServerObject Class Legend Protected Fields Send Feedback

The fields of the TnxLockedOptionsExtendableServerObject class are listed here.

Class

TnxLockedOptionsExtendableServerObject Class

Protected Fields
Name | Description
loesoOptionsLock | private
Links
TnxLockedOptionsExtendableServerObject Class, Legend, Protected Fields


TnxLockedOptionsExtendableServerObject.loesoOptionsLock Field

TnxLockedOptionsExtendableServerObject.loesoOptionsLock Field
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Fields Send Feedback
Syntax
Delphi
loesoOptionsLock: TnxPadlock;
Description

private

Group

TnxLockedOptionsExtendableServerObject Fields

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Fields


TnxLockedOptionsExtendableServerObject Methods

TnxLockedOptionsExtendableServerObject Methods
TnxLockedOptionsExtendableServerObject Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxLockedOptionsExtendableServerObject class are listed here.

Class

TnxLockedOptionsExtendableServerObject Class

Protected Methods
Name | Description
esoOptionGet |
esoOptionList |
Public Methods
Name | Description
esoOptionClear | DOM-IGNORE-BEGIN
esoOptionSet |
Links
TnxLockedOptionsExtendableServerObject Class, Legend, Protected Methods, Public Methods


TnxLockedOptionsExtendableServerObject.esoOptionClear Method

TnxLockedOptionsExtendableServerObject.esoOptionClear Method
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionClear(const aName: string): TnxResult; override;
Description

DOM-IGNORE-BEGIN

Group

TnxLockedOptionsExtendableServerObject Methods

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Methods


TnxLockedOptionsExtendableServerObject.esoOptionGet Method

TnxLockedOptionsExtendableServerObject.esoOptionGet Method
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionGet(const aName: string; out aValue: string): TnxResult; override;
Group

TnxLockedOptionsExtendableServerObject Methods

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Methods


TnxLockedOptionsExtendableServerObject.esoOptionList Method

TnxLockedOptionsExtendableServerObject.esoOptionList Method
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionList(aList: TStrings): TnxResult; override;
Group

TnxLockedOptionsExtendableServerObject Methods

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Methods


TnxLockedOptionsExtendableServerObject.esoOptionSet Method

TnxLockedOptionsExtendableServerObject.esoOptionSet Method
TnxLockedOptionsExtendableServerObject Class TnxLockedOptionsExtendableServerObject Members nxsdServerEngine Namespace TnxLockedOptionsExtendableServerObject Methods Send Feedback
Syntax
Delphi
function esoOptionSet(const aName: string; const aValue: string): TnxResult; override;
Group

TnxLockedOptionsExtendableServerObject Methods

Links
TnxLockedOptionsExtendableServerObject Class, TnxLockedOptionsExtendableServerObject Members, nxsdServerEngine Namespace, TnxLockedOptionsExtendableServerObject Methods


TnxRequestCloseHandlerEvent Class

TnxRequestCloseHandlerEvent Class
TnxRequestCloseHandlerEvent Fields TnxRequestCloseHandlerEvent Methods TnxRequestCloseHandlerEvent Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxRequestCloseHandlerEventnxsdServerEngine_TnxRequestCloseHandlerEventnxsdServerEngine_TnxRequestCloseHandlerEventnxsdServerEngine_TnxRequestCloseHandlerEventnxsdServerEngine_TnxRequestCloseHandlerEvent
Syntax
Delphi
TnxRequestCloseHandlerEvent = class(TnxInterfacedObject, InxRequestCloseHandler, InxRequestCloseHandlerEvent);
File

nxsdServerEngine

Description

TnxRequestCloseHandlerEvent

Group

Classes

Links
TnxRequestCloseHandlerEvent Fields, TnxRequestCloseHandlerEvent Methods, TnxRequestCloseHandlerEvent Members, nxsdServerEngine, Classes


TnxRequestCloseHandlerEvent Members

TnxRequestCloseHandlerEvent Members
TnxRequestCloseHandlerEvent Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxRequestCloseHandlerEvent.

Class

TnxRequestCloseHandlerEvent Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
rcheDisconnected | This is rcheDisconnected, a member of class TnxRequestCloseHandlerEvent.
rcheEvent | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
Disconnect | InxRequestCloseHandlerEvent
ioDeactivate |
QueryInterface |
RequestClose | InxRequestCloseHandler
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxRequestCloseHandlerEvent Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxRequestCloseHandlerEvent.Create Constructor

TnxRequestCloseHandlerEvent.Create Constructor
TnxRequestCloseHandlerEvent Class TnxRequestCloseHandlerEvent Members nxsdServerEngine Namespace TnxRequestCloseHandlerEvent Class Send Feedback
Syntax
Delphi
constructor Create(aEvent: TNotifyEvent);
Class

TnxRequestCloseHandlerEvent Class

Links
TnxRequestCloseHandlerEvent Class, TnxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, TnxRequestCloseHandlerEvent Class


TnxRequestCloseHandlerEvent Fields

TnxRequestCloseHandlerEvent Fields
TnxRequestCloseHandlerEvent Class Legend Protected Fields Send Feedback

The fields of the TnxRequestCloseHandlerEvent class are listed here.

Class

TnxRequestCloseHandlerEvent Class

Protected Fields
Name | Description
rcheDisconnected | This is rcheDisconnected, a member of class TnxRequestCloseHandlerEvent.
rcheEvent | private
Links
TnxRequestCloseHandlerEvent Class, Legend, Protected Fields


TnxRequestCloseHandlerEvent.rcheDisconnected Field

TnxRequestCloseHandlerEvent.rcheDisconnected Field
TnxRequestCloseHandlerEvent Class TnxRequestCloseHandlerEvent Members nxsdServerEngine Namespace TnxRequestCloseHandlerEvent Fields Send Feedback
Syntax
Delphi
rcheDisconnected: Boolean;
Description

This is rcheDisconnected, a member of class TnxRequestCloseHandlerEvent.

Group

TnxRequestCloseHandlerEvent Fields

Links
TnxRequestCloseHandlerEvent Class, TnxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, TnxRequestCloseHandlerEvent Fields


TnxRequestCloseHandlerEvent.rcheEvent Field

TnxRequestCloseHandlerEvent.rcheEvent Field
TnxRequestCloseHandlerEvent Class TnxRequestCloseHandlerEvent Members nxsdServerEngine Namespace TnxRequestCloseHandlerEvent Fields Send Feedback
Syntax
Delphi
rcheEvent: TNotifyEvent;
Description

private

Group

TnxRequestCloseHandlerEvent Fields

Links
TnxRequestCloseHandlerEvent Class, TnxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, TnxRequestCloseHandlerEvent Fields


TnxRequestCloseHandlerEvent Methods

TnxRequestCloseHandlerEvent Methods
TnxRequestCloseHandlerEvent Class Legend Protected Methods Send Feedback

The methods of the TnxRequestCloseHandlerEvent class are listed here.

Class

TnxRequestCloseHandlerEvent Class

Protected Methods
Name | Description
Disconnect | InxRequestCloseHandlerEvent
RequestClose | InxRequestCloseHandler
Links
TnxRequestCloseHandlerEvent Class, Legend, Protected Methods


TnxRequestCloseHandlerEvent.Disconnect Method

TnxRequestCloseHandlerEvent.Disconnect Method
TnxRequestCloseHandlerEvent Class TnxRequestCloseHandlerEvent Members nxsdServerEngine Namespace TnxRequestCloseHandlerEvent Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

InxRequestCloseHandlerEvent

Group

TnxRequestCloseHandlerEvent Methods

Links
TnxRequestCloseHandlerEvent Class, TnxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, TnxRequestCloseHandlerEvent Methods


TnxRequestCloseHandlerEvent.RequestClose Method

TnxRequestCloseHandlerEvent.RequestClose Method
TnxRequestCloseHandlerEvent Class TnxRequestCloseHandlerEvent Members nxsdServerEngine Namespace TnxRequestCloseHandlerEvent Methods Send Feedback
Syntax
Delphi
procedure RequestClose(Sender: TObject);
Description

InxRequestCloseHandler

Group

TnxRequestCloseHandlerEvent Methods

Links
TnxRequestCloseHandlerEvent Class, TnxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, TnxRequestCloseHandlerEvent Methods


TnxSessionStats Class

TnxSessionStats Class
TnxSessionStats Fields TnxSessionStats Methods TnxSessionStats Properties TnxSessionStats Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxSessionStatsnxsdServerEngine_TnxSessionStats
Syntax
Delphi
TnxSessionStats = class(TnxObject);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.TnxSessionStats.

Group

Classes

Links
TnxSessionStats Fields, TnxSessionStats Methods, TnxSessionStats Properties, TnxSessionStats Members, nxsdServerEngine, Classes


TnxSessionStats Members

TnxSessionStats Members
TnxSessionStats Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSessionStats.

Class

TnxSessionStats Class

Protected Fields
Name | Description
assClosed | This is assClosed, a member of class TnxSessionStats.
assConnectedFrom | This is assConnectedFrom, a member of class TnxSessionStats.
assCounters | This is assCounters, a member of class TnxSessionStats.
assCurrentThread | This is assCurrentThread, a member of class TnxSessionStats.
assEnterThreadCycle | This is assEnterThreadCycle, a member of class TnxSessionStats.
assEnterTime | This is assEnterTime, a member of class TnxSessionStats.
assExtClosed | This is assExtClosed, a member of class TnxSessionStats.
assExtCounters | This is assExtCounters, a member of class TnxSessionStats.
assLock | private
assNext | This is assNext, a member of class TnxSessionStats.
assSessionNumber | This is assSessionNumber, a member of class TnxSessionStats.
assStarted | This is assStarted, a member of class TnxSessionStats.
assUserName | This is assUserName, a member of class TnxSessionStats.
Protected Methods
Name | Description
assUpdateFromThread |
Close | This is Close, a member of class TnxSessionStats.
Enter |
Leave |
Public Methods
Name | Description
Count |
Create |
Current |
FreeInstance |
Head |
NewInstance | TnxObject
Update |
Public Properties
Name | Description
Closed | This is Closed, a member of class TnxSessionStats.
ConnectedFrom | This is ConnectedFrom, a member of class TnxSessionStats.
Next | This is Next, a member of class TnxSessionStats.
SessionNumber | This is SessionNumber, a member of class TnxSessionStats.
Started | This is Started, a member of class TnxSessionStats.
UserName | This is UserName, a member of class TnxSessionStats.
Links
TnxSessionStats Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSessionStats.Create Constructor

TnxSessionStats.Create Constructor
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Class Send Feedback
Syntax
Delphi
constructor Create(const aUserName: string; const aConnectedFrom: string);
Class

TnxSessionStats Class

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Class


TnxSessionStats Fields

TnxSessionStats Fields
TnxSessionStats Class Legend Protected Fields Send Feedback

The fields of the TnxSessionStats class are listed here.

Class

TnxSessionStats Class

Protected Fields
Name | Description
assClosed | This is assClosed, a member of class TnxSessionStats.
assConnectedFrom | This is assConnectedFrom, a member of class TnxSessionStats.
assCounters | This is assCounters, a member of class TnxSessionStats.
assCurrentThread | This is assCurrentThread, a member of class TnxSessionStats.
assEnterThreadCycle | This is assEnterThreadCycle, a member of class TnxSessionStats.
assEnterTime | This is assEnterTime, a member of class TnxSessionStats.
assExtClosed | This is assExtClosed, a member of class TnxSessionStats.
assExtCounters | This is assExtCounters, a member of class TnxSessionStats.
assLock | private
assNext | This is assNext, a member of class TnxSessionStats.
assSessionNumber | This is assSessionNumber, a member of class TnxSessionStats.
assStarted | This is assStarted, a member of class TnxSessionStats.
assUserName | This is assUserName, a member of class TnxSessionStats.
Links
TnxSessionStats Class, Legend, Protected Fields


TnxSessionStats.assClosed Field

TnxSessionStats.assClosed Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assClosed: TDateTime;
Description

This is assClosed, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assConnectedFrom Field

TnxSessionStats.assConnectedFrom Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assConnectedFrom: string;
Description

This is assConnectedFrom, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assCounters Field

TnxSessionStats.assCounters Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assCounters: TnxSessionStatsCounters;
Description

This is assCounters, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assCurrentThread Field

TnxSessionStats.assCurrentThread Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assCurrentThread: THandle;
Description

This is assCurrentThread, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assEnterThreadCycle Field

TnxSessionStats.assEnterThreadCycle Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assEnterThreadCycle: UInt64;
Description

This is assEnterThreadCycle, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assEnterTime Field

TnxSessionStats.assEnterTime Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assEnterTime: Int64;
Description

This is assEnterTime, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assExtClosed Field

TnxSessionStats.assExtClosed Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assExtClosed: TDateTime;
Description

This is assExtClosed, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assExtCounters Field

TnxSessionStats.assExtCounters Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assExtCounters: TnxSessionStatsCounters;
Description

This is assExtCounters, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assLock Field

TnxSessionStats.assLock Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assLock: TnxPadlock;
Description

private

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assNext Field

TnxSessionStats.assNext Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assNext: TnxSessionStats;
Description

This is assNext, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assSessionNumber Field

TnxSessionStats.assSessionNumber Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assSessionNumber: Integer;
Description

This is assSessionNumber, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assStarted Field

TnxSessionStats.assStarted Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assStarted: TDateTime;
Description

This is assStarted, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats.assUserName Field

TnxSessionStats.assUserName Field
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Fields Send Feedback
Syntax
Delphi
assUserName: string;
Description

This is assUserName, a member of class TnxSessionStats.

Group

TnxSessionStats Fields

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Fields


TnxSessionStats Methods

TnxSessionStats Methods
TnxSessionStats Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSessionStats class are listed here.

Class

TnxSessionStats Class

Protected Methods
Name | Description
assUpdateFromThread |
Close | This is Close, a member of class TnxSessionStats.
Enter |
Leave |
Public Methods
Name | Description
Count |
Current |
Head |
Update |
Links
TnxSessionStats Class, Legend, Protected Methods, Public Methods


TnxSessionStats.assUpdateFromThread Method

TnxSessionStats.assUpdateFromThread Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
procedure assUpdateFromThread(aKeepCounting: Boolean);
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Close Method

TnxSessionStats.Close Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
procedure Close; virtual;
Description

This is Close, a member of class TnxSessionStats.

Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Count Method

TnxSessionStats.Count Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
class procedure Count(aCounter: TnxSessionStatsCounter; aCount: Int64 = 1);
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Current Method

TnxSessionStats.Current Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
class function Current: TnxSessionStats;
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Enter Method

TnxSessionStats.Enter Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
procedure Enter; virtual;
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Head Method

TnxSessionStats.Head Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
class function Head: TnxSessionStats;
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Leave Method

TnxSessionStats.Leave Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
procedure Leave; virtual;
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats.Update Method

TnxSessionStats.Update Method
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Methods Send Feedback
Syntax
Delphi
function Update: TnxSessionStatsCounters;
Group

TnxSessionStats Methods

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Methods


TnxSessionStats Properties

TnxSessionStats Properties
TnxSessionStats Class Legend Public Properties Send Feedback

The properties of the TnxSessionStats class are listed here.

Class

TnxSessionStats Class

Public Properties
Name | Description
Closed | This is Closed, a member of class TnxSessionStats.
ConnectedFrom | This is ConnectedFrom, a member of class TnxSessionStats.
Next | This is Next, a member of class TnxSessionStats.
SessionNumber | This is SessionNumber, a member of class TnxSessionStats.
Started | This is Started, a member of class TnxSessionStats.
UserName | This is UserName, a member of class TnxSessionStats.
Links
TnxSessionStats Class, Legend, Public Properties


TnxSessionStats.Closed Property

TnxSessionStats.Closed Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property Closed: TDateTime;
Description

This is Closed, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSessionStats.ConnectedFrom Property

TnxSessionStats.ConnectedFrom Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property ConnectedFrom: string;
Description

This is ConnectedFrom, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSessionStats.Next Property

TnxSessionStats.Next Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property Next: TnxSessionStats;
Description

This is Next, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSessionStats.SessionNumber Property

TnxSessionStats.SessionNumber Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property SessionNumber: Integer;
Description

This is SessionNumber, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSessionStats.Started Property

TnxSessionStats.Started Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property Started: TDateTime;
Description

This is Started, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSessionStats.UserName Property

TnxSessionStats.UserName Property
TnxSessionStats Class TnxSessionStats Members nxsdServerEngine Namespace TnxSessionStats Properties Send Feedback
Syntax
Delphi
property UserName: string;
Description

This is UserName, a member of class TnxSessionStats.

Group

TnxSessionStats Properties

Links
TnxSessionStats Class, TnxSessionStats Members, nxsdServerEngine Namespace, TnxSessionStats Properties


TnxSimpleLock Class

TnxSimpleLock Class
TnxSimpleLock Fields TnxSimpleLock Methods TnxSimpleLock Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxSimpleLocknxsdServerEngine_TnxSimpleLocknxsdServerEngine_TnxSimpleLocknxsdServerEngine_TnxSimpleLock
Syntax
Delphi
TnxSimpleLock = class(TnxInterfacedObject, InxSimpleLock);
File

nxsdServerEngine

Description

A 100% thread safe lock used for counter based NexusDB locks.

Group

Classes

Links
TnxSimpleLock Fields, TnxSimpleLock Methods, TnxSimpleLock Members, nxsdServerEngine, Classes


TnxSimpleLock Members

TnxSimpleLock Members
TnxSimpleLock Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleLock.

Class

TnxSimpleLock Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
slFailed | This is slFailed, a member of class TnxSimpleLock.
slFailedCleanedup | This is slFailedCleanedup, a member of class TnxSimpleLock.
slFailedCleanup | This is slFailedCleanup, a member of class TnxSimpleLock.
slFailedCleanupDone | This is slFailedCleanupDone, a member of class TnxSimpleLock.
slFailedFlag | This is slFailedFlag, a member of class TnxSimpleLock.
slFailedOrg | This is slFailedOrg, a member of class TnxSimpleLock.
slFailedPermanent | This is slFailedPermanent, a member of class TnxSimpleLock.
slFailedSpinlock | This is slFailedSpinlock, a member of class TnxSimpleLock.
slLockCount | This is slLockCount, a member of class TnxSimpleLock.
slLockingThread | This is slLockingThread, a member of class TnxSimpleLock.
slStats | This is slStats, a member of class TnxSimpleLock.
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
ioDeactivate |
QueryInterface |
Public Fields
Name | Description
slExceptionHookInfo | This is slExceptionHookInfo, a member of class TnxSimpleLock.
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create | Constructor. Parameter: aFailedCleanup - an Event that is called if the lock can't be cleaned up due to a failed Lock attempt.
Destroy | destructor.
Failed | Internally used to coordinate long running operations and lost connections at the transport level... stoping e.g. running SQL statements after a few sec max if the connection is lost.
Free |
FreeInstance |
IsFailedPermanent |
Lock | Increases the lock count.
NewInstance |
NewInstance | TnxObject
SetFailedCleanupDone |
Unlock | Decreases the lock count.
Public Properties
Name | Description
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Links
TnxSimpleLock Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxSimpleLock.Create Constructor

TnxSimpleLock.Create Constructor
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Class Send Feedback
Syntax
Delphi
constructor Create(aFailedCleanup: TNotifyEvent; aStats: TnxSessionStats);
Description

Constructor. Parameter: aFailedCleanup - an Event that is called if the lock can't be cleaned up due to a failed Lock attempt.

Class

TnxSimpleLock Class

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Class


TnxSimpleLock.Destroy Destructor

TnxSimpleLock.Destroy Destructor
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

destructor.

Class

TnxSimpleLock Class

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Class


TnxSimpleLock Fields

TnxSimpleLock Fields
TnxSimpleLock Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxSimpleLock class are listed here.

Class

TnxSimpleLock Class

Protected Fields
Name | Description
slFailed | This is slFailed, a member of class TnxSimpleLock.
slFailedCleanedup | This is slFailedCleanedup, a member of class TnxSimpleLock.
slFailedCleanup | This is slFailedCleanup, a member of class TnxSimpleLock.
slFailedCleanupDone | This is slFailedCleanupDone, a member of class TnxSimpleLock.
slFailedFlag | This is slFailedFlag, a member of class TnxSimpleLock.
slFailedOrg | This is slFailedOrg, a member of class TnxSimpleLock.
slFailedPermanent | This is slFailedPermanent, a member of class TnxSimpleLock.
slFailedSpinlock | This is slFailedSpinlock, a member of class TnxSimpleLock.
slLockCount | This is slLockCount, a member of class TnxSimpleLock.
slLockingThread | This is slLockingThread, a member of class TnxSimpleLock.
slStats | This is slStats, a member of class TnxSimpleLock.
Public Fields
Name | Description
slExceptionHookInfo | This is slExceptionHookInfo, a member of class TnxSimpleLock.
Links
TnxSimpleLock Class, Legend, Protected Fields, Public Fields


TnxSimpleLock.slExceptionHookInfo Field

TnxSimpleLock.slExceptionHookInfo Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slExceptionHookInfo: TnxExceptionHookInfo;
Description

This is slExceptionHookInfo, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailed Field

TnxSimpleLock.slFailed Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailed: TnxBoolean;
Description

This is slFailed, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedCleanedup Field

TnxSimpleLock.slFailedCleanedup Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedCleanedup: Boolean;
Description

This is slFailedCleanedup, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedCleanup Field

TnxSimpleLock.slFailedCleanup Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedCleanup: TNotifyEvent;
Description

This is slFailedCleanup, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedCleanupDone Field

TnxSimpleLock.slFailedCleanupDone Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedCleanupDone: THandle;
Description

This is slFailedCleanupDone, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedFlag Field

TnxSimpleLock.slFailedFlag Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedFlag: PnxBoolean;
Description

This is slFailedFlag, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedOrg Field

TnxSimpleLock.slFailedOrg Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedOrg: TnxBoolean;
Description

This is slFailedOrg, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedPermanent Field

TnxSimpleLock.slFailedPermanent Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedPermanent: TnxBoolean;
Description

This is slFailedPermanent, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slFailedSpinlock Field

TnxSimpleLock.slFailedSpinlock Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slFailedSpinlock: Integer;
Description

This is slFailedSpinlock, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slLockCount Field

TnxSimpleLock.slLockCount Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slLockCount: Integer;
Description

This is slLockCount, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slLockingThread Field

TnxSimpleLock.slLockingThread Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slLockingThread: Integer;
Description

This is slLockingThread, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock.slStats Field

TnxSimpleLock.slStats Field
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Fields Send Feedback
Syntax
Delphi
slStats: TnxSessionStats;
Description

This is slStats, a member of class TnxSimpleLock.

Group

TnxSimpleLock Fields

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Fields


TnxSimpleLock Methods

TnxSimpleLock Methods
TnxSimpleLock Class Legend Public Methods Send Feedback

The methods of the TnxSimpleLock class are listed here.

Class

TnxSimpleLock Class

Public Methods
Name | Description
Failed | Internally used to coordinate long running operations and lost connections at the transport level... stoping e.g. running SQL statements after a few sec max if the connection is lost.
IsFailedPermanent |
Lock | Increases the lock count.
SetFailedCleanupDone |
Unlock | Decreases the lock count.
Links
TnxSimpleLock Class, Legend, Public Methods


TnxSimpleLock.Failed Method

TnxSimpleLock.Failed Method
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Failed(aPermanent: Boolean; aWait: Boolean);
Description

Internally used to coordinate long running operations and lost connections at the transport level... stoping e.g. running SQL statements after a few sec max if the connection is lost.

Group

TnxSimpleLock Methods

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Methods


TnxSimpleLock.IsFailedPermanent Method

TnxSimpleLock.IsFailedPermanent Method
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Methods Send Feedback
Syntax
Delphi
function IsFailedPermanent: Boolean;
Group

TnxSimpleLock Methods

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Methods


TnxSimpleLock.Lock Method

TnxSimpleLock.Lock Method
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Lock;
Description

Increases the lock count.

Group

TnxSimpleLock Methods

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Methods


TnxSimpleLock.SetFailedCleanupDone Method

TnxSimpleLock.SetFailedCleanupDone Method
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure SetFailedCleanupDone;
Group

TnxSimpleLock Methods

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Methods


TnxSimpleLock.Unlock Method

TnxSimpleLock.Unlock Method
TnxSimpleLock Class TnxSimpleLock Members nxsdServerEngine Namespace TnxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Unlock(var aResult: TnxResult);
Description

Decreases the lock count.

Group

TnxSimpleLock Methods

Links
TnxSimpleLock Class, TnxSimpleLock Members, nxsdServerEngine Namespace, TnxSimpleLock Methods


TnxSqlAbstractCursor Class

TnxSqlAbstractCursor Class
TnxSqlAbstractCursor Fields TnxSqlAbstractCursor Methods TnxSqlAbstractCursor Properties TnxSqlAbstractCursor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursornxsdServerEngine_TnxSqlAbstractCursor
Syntax
Delphi
TnxSqlAbstractCursor = class(TnxAbstractCursor);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.TnxSqlAbstractCursor.

Group

Classes

Links
TnxSqlAbstractCursor Fields, TnxSqlAbstractCursor Methods, TnxSqlAbstractCursor Properties, TnxSqlAbstractCursor Members, nxsdServerEngine, Classes


TnxSqlAbstractCursor Members

TnxSqlAbstractCursor Members
TnxSqlAbstractCursor Class Legend Protected Fields Protected Methods Protected Properties Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlAbstractCursor.

Class

TnxSqlAbstractCursor Class

Protected Fields
Name | Description
acAutoFreeDatabase | This is acAutoFreeDatabase, a member of class TnxAbstractCursor.
acDatabase | private
acDatabaseNext | This is acDatabaseNext, a member of class TnxAbstractCursor.
acDatabasePrev | This is acDatabasePrev, a member of class TnxAbstractCursor.
acLockedIncDone | This is acLockedIncDone, a member of class TnxAbstractCursor.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
sbcOnRequestClose | This is sbcOnRequestClose, a member of class TnxSqlAbstractCursor.
sbcOnRequestCloseLock | This is sbcOnRequestCloseLock, a member of class TnxSqlAbstractCursor.
Protected Methods
Name | Description
_AddRef |
_Release |
ac_GetDictionary | This is ac_GetDictionary, a member of class TnxAbstractCursor.
acAddToDatabase | TnxAbstractCursor
acGetFieldsDescriptor |
acGetFullName | This is acGetFullName, a member of class TnxAbstractCursor.
acGetTableDescriptor | This is acGetTableDescriptor, a member of class TnxAbstractCursor.
acRemoveFromDatabase |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout | TnxAbstractTimeoutObject
BlobsSupportedSelf |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetCursorSelf |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetFieldAsVariantSelf |
GetFieldCountRedirect |
GetFieldDescriptorRedirect |
GetFieldForFilterRedirect |
GetFieldFromNameRedirect |
GetFieldsOffsetRedirect |
QueryInterface | InxInterface
SetFieldAsVariantSelf |
Protected Properties
Name | Description
FieldsDescriptor | InxFieldsSource
Public Fields
Name | Description
IsResultSet | This is IsResultSet, a member of class TnxAbstractCursor.
IsUnnamed | This is IsUnnamed, a member of class TnxAbstractCursor.
sbcUseNestedTransaction | This is sbcUseNestedTransaction, a member of class TnxSqlAbstractCursor.
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
AutoIncGet |
AutoIncSet | This function sets the next AutoInc value for the current table.
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
BlobCreate | This function creates a new blob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobCreateFile | This creates a new FileBlob and returns the new blob reference number in aBlobNr. This number is unique for any blob and is needed to access the blob.
BlobDelete | This function deletes the blob with the given aBlobNr.
BlobFree | This function frees all temporary buffers for this blob.
BlobGetLength | This function returns the length of the blob in aLengt as bytes.
BlobModified | Checks if the given Blob Buffer was modified
BlobRead | This function reads data from a blob.
BlobsSupported | This is BlobsSupported, a member of class InxFieldsSource.
BlobTruncate | This function truncates the given blob at aBlobLength bytes.
BlobWrite | This function writes data to a blob.
BookmarkAsVariant | Return a given bookmark as Variant
ChangePassword | This function changes the password of the table. It fails if the table doesn't us an encryption engine.
Close |
Close |
CompareBookmarks | This function compares two bookmarks.
CompareKeys | CompareKeys compares 2 keys.
CopyRecords | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed.
CopyRecordsEx | This function copies *all* visible (in regards of ranges and filters) records to the cursor given in aDestCursor. aMaxTransSize specifies the maximum number of dirty transaction bytes before the transaction is committed. aCheckValFields determines wether a check is done for required fields having a value.
Create | Constructor
Create |
Create | constructor.
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
DeleteRecords | This function deletes *all* visible (in regards of ranges and filters) records.
Destroy | TnxSqlAbstractCursor
Duplicate | This function clones the current cursor and returns a new instance in aNewCursor. The new cursor can be opened with a different mode by specifying the aOpenMode accordingly.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
FilterActivate | This function sets the given Filter to active.
FilterAddCallback | Adds a new callback function to the filter valuation list.
FilterAddCustom | Adds a new filter to the filter evaluation list.
FilterAddExpression | FilterAddExpression creates a new Filter instance for the given aExpression and returns its in aFilterID.
FilterDeactivate | This function sets the given Filter to inactive.
FilterRemove | This function removes the given Filter from the internal list.
FilterSetTimeout | This function sets the timeout for the filter evaluation in msec.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetBookmark |
GetCursor | This is GetCursor, a member of class InxFieldsSource.
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFieldAsVariant | This is GetFieldAsVariant, a member of class InxFieldsSource.
GetFieldCount | This is GetFieldCount, a member of class InxFieldsSource.
GetFieldDescriptor | This is GetFieldDescriptor, a member of class InxFieldsSource.
GetFieldForFilter | This is GetFieldForFilter, a member of class InxFieldsSource.
GetFieldFromName | This is GetFieldFromName, a member of class InxFieldsSource.
GetFieldsOffset | This is GetFieldsOffset, a member of class InxFieldsSource.
GetIndexID | This function returns the id of the current index.
GetLifetimeMontior |
GetRecordCount | GetRecordCount returns the number of currently "visible" records. It obeys set ranges and filters.
GetRecordCountAsync | This function is an asynchronous version of GetRecordCount.
GetRecordCountEx | GetRecordCountEx returns the number of records or keys based on the value of aOption.
GetRecordCountExAsync | This function is an asynchronous version of GetRecordCountEx.
KeyFilterActivate | This function sets the given KeyFilter to active.
KeyFilterAddCallback | Adds a new callback function to the filter valuation list.
KeyFilterAddCustom | Adds a new filter to the filter evaluation list.
KeyFilterAddExpression | KeyFilterAddExpression creates a new KeyFilter instance for the given aExpression and returns its in aKeyFilterID.
KeyFilterDeactivate | This function sets the given KeyFilter to inactive.
KeyFilterRemove | This function removes the given KeyFilter from the internal list.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
RangeReset | This function cancels the active range.
RangeSet | Sets a range on the current cursor
RecNoGet | Returns the RecNo (Position) of the current record according to the current Index, Range and Filter(s). (using filters/indices is not recommended if that table (subset) contains more than a few data pages of records!).
RecNoSet | Sets the current position according to the RecNo
RecNoSupported | Returns DBIERR_NONE if RecNo is supported.
RecordBufferAlloc | helper functions for record buffer management
RecordBufferClear |
RecordBufferFree |
RecordDelete | RecordDelete deletes the current record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGet | RecordGet returns a pointer to the current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetBatch | This function returns a batch of record data in a Stream. aCutoffSize - the maximum length to return in bytes. aOptions - the (blob/bookmark) options to use for filling the stream aStream - the stream that receives the data aMaxRecords - the maximum number of records to return.
RecordGetForKey | RecordGetForKey positions the cursor on the first/last record that matches the passed in key and returns the record.
RecordGetNext | RecordGet moves to the next valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordGetPrior | RecordGet moves to the prior valid (in regards of ranges and filters) record returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsert | RecordInsert creates a new record and returns a pointer to the then current record buffer. It needs to be able to acquire the given lock type for this function to be successful.
RecordInsertBatch | This function adds the data in a aStream as new records. Please note that the size of aStream must be a multiple of the record size.
RecordIsLocked | RecordIsLocked returns the current record lock state for a certain lock type.
RecordLockRelease | This function releases the last lock or alternatively all locks in the record.
RecordModify | RecordInsert sets the record buffer to the given data. The record must have a proper lock acquired for this function to succeed. If aReleaseLock is true all locks on the current record are released.
RequestNestedTransactions | This function can be called from an extender to request that the cursor uses nested transactions for all operations. By default this is not supported.
sacGetOpenMode |
sacGetRecordByID | This is sacGetRecordByID, a member of class TnxSqlAbstractCursor.
sacGetRefNr | This is sacGetRefNr, a member of class TnxSqlAbstractCursor.
sacHasKey | This is sacHasKey, a member of class TnxSqlAbstractCursor.
sacIsWrapper |
sacSetDefault | This is sacSetDefault, a member of class TnxSqlAbstractCursor.
sacSetDefaultsInsert | This is sacSetDefaultsInsert, a member of class TnxSqlAbstractCursor.
sacSetRefNr | This is sacSetRefNr, a member of class TnxSqlAbstractCursor.
sbcAutoIncGet | autoinc
sbcBlobCreateLink | blob managment
sbcBlobDelete | This is sbcBlobDelete, a member of class TnxSqlAbstractCursor.
sbcBlobGetLength | This is sbcBlobGetLength, a member of class TnxSqlAbstractCursor.
sbcBlobIsLink | This is sbcBlobIsLink, a member of class TnxSqlAbstractCursor.
sbcBlobRead | This is sbcBlobRead, a member of class TnxSqlAbstractCursor.
sbcBlobTruncate | This is sbcBlobTruncate, a member of class TnxSqlAbstractCursor.
sbcBlobWrite | This is sbcBlobWrite, a member of class TnxSqlAbstractCursor.
sbcChangePassword | misc
sbcCopyRecords | This is sbcCopyRecords, a member of class TnxSqlAbstractCursor.
sbcDeleteRecords | This is sbcDeleteRecords, a member of class TnxSqlAbstractCursor.
sbcDuplicate | This is sbcDuplicate, a member of class TnxSqlAbstractCursor.
sbcGetIndexID | This is sbcGetIndexID, a member of class TnxSqlAbstractCursor.
sbcGetOnRequestClose |
sbcGetPosition | This is sbcGetPosition, a member of class TnxSqlAbstractCursor.
sbcGetRecordCount | information
sbcGetRootName | This is sbcGetRootName, a member of class TnxSqlAbstractCursor.
sbcIterate | sql engine support
sbcMarkReadonly | This is sbcMarkReadonly, a member of class TnxSqlAbstractCursor.
sbcRangeReset | This is sbcRangeReset, a member of class TnxSqlAbstractCursor.
sbcRangeSet | This is sbcRangeSet, a member of class TnxSqlAbstractCursor.
sbcRecordDelete | This is sbcRecordDelete, a member of class TnxSqlAbstractCursor.
sbcRecordGet | record retrival
sbcRecordGetNext | This is sbcRecordGetNext, a member of class TnxSqlAbstractCursor.
sbcRecordGetPrior | This is sbcRecordGetPrior, a member of class TnxSqlAbstractCursor.
sbcRecordInsert | record manipulation
sbcRecordInsertBatch | batch operations
sbcRecordModify | This is sbcRecordModify, a member of class TnxSqlAbstractCursor.
sbcSetOnRequestClose |
sbcSetToBegin | navigation
sbcSetToEnd | This is sbcSetToEnd, a member of class TnxSqlAbstractCursor.
sbcSwitchToIndex | index support
SetFieldAsVariant | This is SetFieldAsVariant, a member of class InxFieldsAccess.
SetToBegin |
SetToBookmark | This function will position the cursor on the given bookmark
SetToCursor | This function synchronizes the position with the given aCursor. Please note that the two cursor have to point to the same dataset.
SetToEnd | This function sets the cursor position to the end of the dataset. This is NOT the last record but after it!
SetToFilter | This function sets the cursor position before the first record that meets the filter criteria in aFilter.
SetToKey | SetToKey positions the cursor relative to a specific key, The cursor is always positioned on a crack. For skaEqualLast, skaSmallerEqual and skaSmaller it's the crack after the matching key, otherwise the crack before.
SwitchToIndex | SwitchToIndex activates the given index. It aPosOnRec it repositions the cursor to the record active before changing the index, otherwise it jumps to the first record.
TableIsLocked | TableIsLocked returns the current table lock state for a certain lock type.
TableLockAcquire | This function will try to acquire a table lock with the given aLockType.
TableLockRelease | This function will release an acquired lock with the given aLockType or alternatively (if aAllLocks is true) all locks on the table.
TableStreamDelete | This function deletes the table stream with the given aName.
TableStreamGetList | This function returns the names of all streams stored with the table.
TableStreamRead | This function reads the WHOLE stream with the given name into aStream.
TableStreamWrite | This function rewrites the WHOLE stream with the given name.
Public Properties
Name | Description
_Dictionary | This property returns the data dictionary for this cursor.
Database | This property returns the database the cursor is linked to.
DatabaseNext | Returns the next cursor in the list of cursor of the current database.
DatabasePrev | Returns the previous cursor in the list of cursor of the current database.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsAccess.
FieldAsVariant | This is FieldAsVariant, a member of class InxFieldsSource.
FieldCount | This is FieldCount, a member of class InxFieldsSource.
FieldDescriptor | This is FieldDescriptor, a member of class InxFieldsSource.
FullName | Returns the full table name in relation to master and sub tables.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
OnRequestClose | This is OnRequestClose, a member of class TnxSqlAbstractCursor.
OpenMode | This is OpenMode, a member of class TnxSqlAbstractCursor.
Position | This is Position, a member of class TnxSqlAbstractCursor.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
RootName | This is RootName, a member of class TnxSqlAbstractCursor.
Session | The session owning this server object (if any) or nil.
TableDescriptor | Returns the TableDescriptor instance in the data dictionary associated with the cursor.
Timeout | Property to read/write the timeout in msec for the object.
Links
TnxSqlAbstractCursor Class, Legend, Protected Fields, Protected Methods, Protected Properties, Public Fields, Public Methods, Public Properties


TnxSqlAbstractCursor.Destroy Destructor

TnxSqlAbstractCursor.Destroy Destructor
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Description

TnxSqlAbstractCursor

Class

TnxSqlAbstractCursor Class

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Class


TnxSqlAbstractCursor Fields

TnxSqlAbstractCursor Fields
TnxSqlAbstractCursor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxSqlAbstractCursor class are listed here.

Class

TnxSqlAbstractCursor Class

Protected Fields
Name | Description
sbcOnRequestClose | This is sbcOnRequestClose, a member of class TnxSqlAbstractCursor.
sbcOnRequestCloseLock | This is sbcOnRequestCloseLock, a member of class TnxSqlAbstractCursor.
Public Fields
Name | Description
sbcUseNestedTransaction | This is sbcUseNestedTransaction, a member of class TnxSqlAbstractCursor.
Links
TnxSqlAbstractCursor Class, Legend, Protected Fields, Public Fields


TnxSqlAbstractCursor.sbcOnRequestClose Field

TnxSqlAbstractCursor.sbcOnRequestClose Field
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Fields Send Feedback
Syntax
Delphi
sbcOnRequestClose: InxRequestCloseHandler;
Description

This is sbcOnRequestClose, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Fields

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Fields


TnxSqlAbstractCursor.sbcOnRequestCloseLock Field

TnxSqlAbstractCursor.sbcOnRequestCloseLock Field
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Fields Send Feedback
Syntax
Delphi
sbcOnRequestCloseLock: TnxPadlock;
Description

This is sbcOnRequestCloseLock, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Fields

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Fields


TnxSqlAbstractCursor.sbcUseNestedTransaction Field

TnxSqlAbstractCursor.sbcUseNestedTransaction Field
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Fields Send Feedback
Syntax
Delphi
sbcUseNestedTransaction: Boolean;
Description

This is sbcUseNestedTransaction, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Fields

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Fields


TnxSqlAbstractCursor Methods

TnxSqlAbstractCursor Methods
TnxSqlAbstractCursor Class Legend Public Methods Send Feedback

The methods of the TnxSqlAbstractCursor class are listed here.

Class

TnxSqlAbstractCursor Class

Public Methods
Name | Description
sacGetOpenMode |
sacGetRecordByID | This is sacGetRecordByID, a member of class TnxSqlAbstractCursor.
sacGetRefNr | This is sacGetRefNr, a member of class TnxSqlAbstractCursor.
sacHasKey | This is sacHasKey, a member of class TnxSqlAbstractCursor.
sacIsWrapper |
sacSetDefault | This is sacSetDefault, a member of class TnxSqlAbstractCursor.
sacSetDefaultsInsert | This is sacSetDefaultsInsert, a member of class TnxSqlAbstractCursor.
sacSetRefNr | This is sacSetRefNr, a member of class TnxSqlAbstractCursor.
sbcAutoIncGet | autoinc
sbcBlobCreateLink | blob managment
sbcBlobDelete | This is sbcBlobDelete, a member of class TnxSqlAbstractCursor.
sbcBlobGetLength | This is sbcBlobGetLength, a member of class TnxSqlAbstractCursor.
sbcBlobIsLink | This is sbcBlobIsLink, a member of class TnxSqlAbstractCursor.
sbcBlobRead | This is sbcBlobRead, a member of class TnxSqlAbstractCursor.
sbcBlobTruncate | This is sbcBlobTruncate, a member of class TnxSqlAbstractCursor.
sbcBlobWrite | This is sbcBlobWrite, a member of class TnxSqlAbstractCursor.
sbcChangePassword | misc
sbcCopyRecords | This is sbcCopyRecords, a member of class TnxSqlAbstractCursor.
sbcDeleteRecords | This is sbcDeleteRecords, a member of class TnxSqlAbstractCursor.
sbcDuplicate | This is sbcDuplicate, a member of class TnxSqlAbstractCursor.
sbcGetIndexID | This is sbcGetIndexID, a member of class TnxSqlAbstractCursor.
sbcGetOnRequestClose |
sbcGetPosition | This is sbcGetPosition, a member of class TnxSqlAbstractCursor.
sbcGetRecordCount | information
sbcGetRootName | This is sbcGetRootName, a member of class TnxSqlAbstractCursor.
sbcIterate | sql engine support
sbcMarkReadonly | This is sbcMarkReadonly, a member of class TnxSqlAbstractCursor.
sbcRangeReset | This is sbcRangeReset, a member of class TnxSqlAbstractCursor.
sbcRangeSet | This is sbcRangeSet, a member of class TnxSqlAbstractCursor.
sbcRecordDelete | This is sbcRecordDelete, a member of class TnxSqlAbstractCursor.
sbcRecordGet | record retrival
sbcRecordGetNext | This is sbcRecordGetNext, a member of class TnxSqlAbstractCursor.
sbcRecordGetPrior | This is sbcRecordGetPrior, a member of class TnxSqlAbstractCursor.
sbcRecordInsert | record manipulation
sbcRecordInsertBatch | batch operations
sbcRecordModify | This is sbcRecordModify, a member of class TnxSqlAbstractCursor.
sbcSetOnRequestClose |
sbcSetToBegin | navigation
sbcSetToEnd | This is sbcSetToEnd, a member of class TnxSqlAbstractCursor.
sbcSwitchToIndex | index support
Links
TnxSqlAbstractCursor Class, Legend, Public Methods


TnxSqlAbstractCursor.sacGetOpenMode Method

TnxSqlAbstractCursor.sacGetOpenMode Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sacGetOpenMode: TnxOpenMode; virtual;
Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacGetRecordByID Method

TnxSqlAbstractCursor.sacGetRecordByID Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sacGetRecordByID(const aRefNr: TnxInt64; aRecordBuffer: PnxByteArray): TnxResult; virtual; abstract;
Description

This is sacGetRecordByID, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacGetRefNr Method

TnxSqlAbstractCursor.sacGetRefNr Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sacGetRefNr: TnxInt64; virtual; abstract;
Description

This is sacGetRefNr, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacHasKey Method

TnxSqlAbstractCursor.sacHasKey Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sacHasKey(aIndex: Integer; aValue: Variant): Boolean; virtual; abstract;
Description

This is sacHasKey, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacIsWrapper Method

TnxSqlAbstractCursor.sacIsWrapper Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sacIsWrapper: Boolean; virtual;
Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacSetDefault Method

TnxSqlAbstractCursor.sacSetDefault Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sacSetDefault(aRecordBuffer: PnxByteArray; aIndex: Integer); virtual; abstract;
Description

This is sacSetDefault, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacSetDefaultsInsert Method

TnxSqlAbstractCursor.sacSetDefaultsInsert Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sacSetDefaultsInsert(aRecordBuffer: PnxByteArray); virtual; abstract;
Description

This is sacSetDefaultsInsert, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sacSetRefNr Method

TnxSqlAbstractCursor.sacSetRefNr Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sacSetRefNr(const aRefNr: TnxInt64); virtual; abstract;
Description

This is sacSetRefNr, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcAutoIncGet Method

TnxSqlAbstractCursor.sbcAutoIncGet Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcAutoIncGet: TnxWord32; virtual; abstract;
Description

autoinc

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobCreateLink Method

TnxSqlAbstractCursor.sbcBlobCreateLink Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobCreateLink(aFieldNo: TnxInt32; const aTableName: string; const aTableBlobNr: TnxInt64; out aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

blob managment

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobDelete Method

TnxSqlAbstractCursor.sbcBlobDelete Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobDelete(aFieldNo: TnxInt32; const aBlobNr: TnxInt64): TnxResult; virtual; abstract;
Description

This is sbcBlobDelete, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobGetLength Method

TnxSqlAbstractCursor.sbcBlobGetLength Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobGetLength(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; out aLength: TnxWord32; aReadOrg: Boolean): TnxResult; virtual; abstract;
Description

This is sbcBlobGetLength, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobIsLink Method

TnxSqlAbstractCursor.sbcBlobIsLink Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobIsLink(aFieldNo: TnxInt32; aBlobNr: TnxInt64; out aSrcTableName: string; out aSrcTableBlobNr: TnxInt64): Boolean; virtual; abstract;
Description

This is sbcBlobIsLink, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobRead Method

TnxSqlAbstractCursor.sbcBlobRead Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobRead(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; aStream: TStream; aReadOrg: Boolean): TnxResult; virtual; abstract;
Description

This is sbcBlobRead, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobTruncate Method

TnxSqlAbstractCursor.sbcBlobTruncate Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobTruncate(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aBlobLength: TnxWord32): TnxResult; virtual; abstract;
Description

This is sbcBlobTruncate, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcBlobWrite Method

TnxSqlAbstractCursor.sbcBlobWrite Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcBlobWrite(aFieldNo: TnxInt32; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; const aBlob): TnxResult; virtual; abstract;
Description

This is sbcBlobWrite, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcChangePassword Method

TnxSqlAbstractCursor.sbcChangePassword Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcChangePassword(const aNewPassword: UnicodeString): TnxResult; virtual; abstract;
Description

misc

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcCopyRecords Method

TnxSqlAbstractCursor.sbcCopyRecords Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcCopyRecords(aDestCursor: TnxAbstractCursor; aBlobCopyMode: TnxBlobCopyMode; aMaxTransSize: Integer; aCheckValFields: Boolean): TnxResult; virtual; abstract;
Description

This is sbcCopyRecords, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcDeleteRecords Method

TnxSqlAbstractCursor.sbcDeleteRecords Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcDeleteRecords: TnxResult; virtual; abstract;
Description

This is sbcDeleteRecords, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcDuplicate Method

TnxSqlAbstractCursor.sbcDuplicate Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcDuplicate(aOpenMode: TnxOpenMode; out aNewCursorID: TnxAbstractCursor; aForceWrite: Boolean = False): TnxResult; virtual; abstract;
Description

This is sbcDuplicate, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcGetIndexID Method

TnxSqlAbstractCursor.sbcGetIndexID Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcGetIndexID(out aIndexID: Integer): TnxResult; virtual; abstract;
Description

This is sbcGetIndexID, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcGetOnRequestClose Method

TnxSqlAbstractCursor.sbcGetOnRequestClose Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcGetOnRequestClose: InxRequestCloseHandler;
Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcGetPosition Method

TnxSqlAbstractCursor.sbcGetPosition Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcGetPosition: TnxIndexPathPosition; virtual; abstract;
Description

This is sbcGetPosition, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcGetRecordCount Method

TnxSqlAbstractCursor.sbcGetRecordCount Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcGetRecordCount(aOption: TnxRecordCountOption; out aRecCount: TnxWord32; aEstimate: Boolean = False): TnxResult; virtual; abstract;
Description

information

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcGetRootName Method

TnxSqlAbstractCursor.sbcGetRootName Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcGetRootName: string; virtual; abstract;
Description

This is sbcGetRootName, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcIterate Method

TnxSqlAbstractCursor.sbcIterate Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcIterate(aData: PPnxByteArray; aKeyIterator: TnxKeyIterator; aRecIterator: TnxRecordIterator; aBackward: Boolean; aCookie: Pointer); virtual; abstract;
Description

sql engine support

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcMarkReadonly Method

TnxSqlAbstractCursor.sbcMarkReadonly Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcMarkReadonly; virtual; abstract;
Description

This is sbcMarkReadonly, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRangeReset Method

TnxSqlAbstractCursor.sbcRangeReset Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcRangeReset; virtual; abstract;
Description

This is sbcRangeReset, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRangeSet Method

TnxSqlAbstractCursor.sbcRangeSet Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRangeSet(aFieldCount1: Integer; aPartialLen1: Integer; aDirectKey1: Boolean; aKeyData1: PnxByteArray; aKeyIncl1: Boolean; aFieldCount2: Integer; aPartialLen2: Integer; aDirectKey2: Boolean; aKeyData2: PnxByteArray; aKeyIncl2: Boolean): TnxResult; virtual; abstract;
Description

This is sbcRangeSet, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordDelete Method

TnxSqlAbstractCursor.sbcRecordDelete Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordDelete(aData: PnxByteArray): TnxResult; virtual; abstract;
Description

This is sbcRecordDelete, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordGet Method

TnxSqlAbstractCursor.sbcRecordGet Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordGet(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

record retrival

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordGetNext Method

TnxSqlAbstractCursor.sbcRecordGetNext Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordGetNext(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

This is sbcRecordGetNext, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordGetPrior Method

TnxSqlAbstractCursor.sbcRecordGetPrior Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordGetPrior(aLockType: TnxLockType; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

This is sbcRecordGetPrior, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordInsert Method

TnxSqlAbstractCursor.sbcRecordInsert Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordInsert(aLockType: TnxLockType; aInsertOptions: TnxInsertOptions; aData: PnxByteArray): TnxResult; virtual; abstract;
Description

record manipulation

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordInsertBatch Method

TnxSqlAbstractCursor.sbcRecordInsertBatch Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordInsertBatch(aStream: TnxCustomMemoryStream): TnxResult; virtual; abstract;
Description

batch operations

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcRecordModify Method

TnxSqlAbstractCursor.sbcRecordModify Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcRecordModify(aData: PnxByteArray; aReleaseLock: Boolean): TnxResult; virtual; abstract;
Description

This is sbcRecordModify, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcSetOnRequestClose Method

TnxSqlAbstractCursor.sbcSetOnRequestClose Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcSetOnRequestClose(aHandler: InxRequestCloseHandler); virtual;
Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcSetToBegin Method

TnxSqlAbstractCursor.sbcSetToBegin Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcSetToBegin; virtual; abstract;
Description

navigation

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcSetToEnd Method

TnxSqlAbstractCursor.sbcSetToEnd Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
procedure sbcSetToEnd; virtual; abstract;
Description

This is sbcSetToEnd, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor.sbcSwitchToIndex Method

TnxSqlAbstractCursor.sbcSwitchToIndex Method
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Methods Send Feedback
Syntax
Delphi
function sbcSwitchToIndex(const aIndexName: string; aIndexID: Integer; aPosnOnRec: Boolean): TnxResult; virtual; abstract;
Description

index support

Group

TnxSqlAbstractCursor Methods

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Methods


TnxSqlAbstractCursor Properties

TnxSqlAbstractCursor Properties
TnxSqlAbstractCursor Class Legend Public Properties Send Feedback

The properties of the TnxSqlAbstractCursor class are listed here.

Class

TnxSqlAbstractCursor Class

Public Properties
Name | Description
OnRequestClose | This is OnRequestClose, a member of class TnxSqlAbstractCursor.
OpenMode | This is OpenMode, a member of class TnxSqlAbstractCursor.
Position | This is Position, a member of class TnxSqlAbstractCursor.
RootName | This is RootName, a member of class TnxSqlAbstractCursor.
Links
TnxSqlAbstractCursor Class, Legend, Public Properties


TnxSqlAbstractCursor.OnRequestClose Property

TnxSqlAbstractCursor.OnRequestClose Property
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Properties Send Feedback
Syntax
Delphi
property OnRequestClose: InxRequestCloseHandler;
Description

This is OnRequestClose, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Properties

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Properties


TnxSqlAbstractCursor.OpenMode Property

TnxSqlAbstractCursor.OpenMode Property
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Properties Send Feedback
Syntax
Delphi
property OpenMode: TnxOpenMode;
Description

This is OpenMode, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Properties

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Properties


TnxSqlAbstractCursor.Position Property

TnxSqlAbstractCursor.Position Property
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Properties Send Feedback
Syntax
Delphi
property Position: TnxIndexPathPosition;
Description

This is Position, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Properties

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Properties


TnxSqlAbstractCursor.RootName Property

TnxSqlAbstractCursor.RootName Property
TnxSqlAbstractCursor Class TnxSqlAbstractCursor Members nxsdServerEngine Namespace TnxSqlAbstractCursor Properties Send Feedback
Syntax
Delphi
property RootName: string;
Description

This is RootName, a member of class TnxSqlAbstractCursor.

Group

TnxSqlAbstractCursor Properties

Links
TnxSqlAbstractCursor Class, TnxSqlAbstractCursor Members, nxsdServerEngine Namespace, TnxSqlAbstractCursor Properties


TnxSqlAbstractDatabase Class

TnxSqlAbstractDatabase Class
TnxSqlAbstractDatabase Fields TnxSqlAbstractDatabase Methods TnxSqlAbstractDatabase Properties TnxSqlAbstractDatabase Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabasenxsdServerEngine_TnxSqlAbstractDatabase
Syntax
Delphi
TnxSqlAbstractDatabase = class(TnxAbstractDatabase);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.TnxSqlAbstractDatabase.

Group

Classes

Links
TnxSqlAbstractDatabase Fields, TnxSqlAbstractDatabase Methods, TnxSqlAbstractDatabase Properties, TnxSqlAbstractDatabase Members, nxsdServerEngine, Classes


TnxSqlAbstractDatabase Members

TnxSqlAbstractDatabase Members
TnxSqlAbstractDatabase Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlAbstractDatabase.

Class

TnxSqlAbstractDatabase Class

Protected Fields
Name | Description
adCursorAutoFree | This is adCursorAutoFree, a member of class TnxAbstractDatabase.
adCursorsHead | This is adCursorsHead, a member of class TnxAbstractDatabase.
adCursorsPadlock | This is adCursorsPadlock, a member of class TnxAbstractDatabase.
adCursorsTail | This is adCursorsTail, a member of class TnxAbstractDatabase.
adLockedIncDone | This is adLockedIncDone, a member of class TnxAbstractDatabase.
adOwnedTransContext | This is adOwnedTransContext, a member of class TnxAbstractDatabase.
adSessionNext | This is adSessionNext, a member of class TnxAbstractDatabase.
adSessionPrev | private
adStatementsHead | This is adStatementsHead, a member of class TnxAbstractDatabase.
adStatementsPadlock | This is adStatementsPadlock, a member of class TnxAbstractDatabase.
adStatementsTail | This is adStatementsTail, a member of class TnxAbstractDatabase.
adTransContext | This is adTransContext, a member of class TnxAbstractDatabase.
adTransContextNext | This is adTransContextNext, a member of class TnxAbstractDatabase.
adTransContextPrev | This is adTransContextPrev, a member of class TnxAbstractDatabase.
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atoLock | This is atoLock, a member of class TnxAbstractTimeoutObject.
atoTimeout | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
sadLastAutoInc | This is sadLastAutoInc, a member of class TnxSqlAbstractDatabase.
sdOpenMode | This is sdOpenMode, a member of class TnxSqlAbstractDatabase.
sdShareMode | This is sdShareMode, a member of class TnxSqlAbstractDatabase.
Protected Methods
Name | Description
_AddRef |
_Release |
adAddToSession | TnxAbstractDatabase
adAddToTransContext |
adRemoveFromSession |
adRemoveFromTransContext |
adTransContextDestroying |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atoSetTimeout |
atoSetTimeout | TnxAbstractTimeoutObject
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
sadGetAlias | TnxSqlAbstractDatabase
Public Fields
Name | Description
sadMasterDatabase | for testing only
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeConstruction
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Close |
Close |
Create | constructor
Create |
Create | constructor.
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
CursorOpen | This function opens a new cursor for a table and returns an instance of a descendent of TnxAbstractCursor. Each table can have as many Cursors as wanted active at the same time
Destroy | destructor.
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetChangedTables | Returns the names of tables the have been changed since this function was last called.
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetFreespace | This function returns the free space of the device the database is stored on. Result is in bytes.
GetLifetimeMontior |
GetPath | Returns the (file) path of the current database.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | Removes an Option from the named option list
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy |
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
RegisterCursorSource | cursor source
sadCreateResultSet | This is sadCreateResultSet, a member of class TnxSqlAbstractDatabase.
sadLockTables | This is sadLockTables, a member of class TnxSqlAbstractDatabase.
sadUnlockTables | This is sadUnlockTables, a member of class TnxSqlAbstractDatabase.
sdIterateDictionaries | This is sdIterateDictionaries, a member of class TnxSqlAbstractDatabase.
sdTableRebuildIndex | table managmenet
sdTableRestructure | This is sdTableRestructure, a member of class TnxSqlAbstractDatabase.
StatementAlloc | This function creates a new instance of a SQL statement. It does NOT execute the query! Paremeters: aStatement: the returned statement instance aTimeout: the timeout for the new statement in msec
StatementExecDirect | This function creates and exexutes a given SQL query or stored procedure and returns a cursor to the result set.
TableAddField | With TableAddField you can add a new field without restructure. May fail.
TableAddIndex | With TableAddIndex you can create a new index.
TableAutoIncGet | This function returns the next AutoInc value for the specified table.
TableBackup | This method starts an asynchronous backup of the table. For this purpose a new table with identical fields is created and the records are copied over from the old one. The original data dictionary is added as a tablestream.
TableBuild | This function creates a new table.
TableChangePassword | This function changes the password of the table with the given aTableName.
TableDelete | This function deletes the table with the given aTableName.
TableDropIndex | This function deletes an index.
TableEmpty | This function deletes all records from the table with the given aTableName.
TableExists |
TableGetDictionary | With TableGetDictionary you can fill a TnxDataDictionary instance with the information about an existing table.
TableGetList | TableGetList fills the given aList with all table names of the current database.
TablePack | This method starts an asynchronous packing of the table. For this purpose a new identical table is created and the records are copied over from the old one.
TableRebuildIndex | ReIndexTable starts an asynchronous re indexing of a certain index of a table.
TableRecover | This function walks all the blocks in the table on disk, and copies healthy records to aTableName_recovered, and copies bad records to aTableName_Failed.
TableRename | This function renames a table from aOldName to aNewName, it the table is not in use.
TableRestructure | With this method you can start an asynchronous restructure of a given table.
TableVerifyChecksum | This function walks all the blocks in the table on disk, and verifies the whole table checksum in the header (if the table is encrypted using an encryption engine which supports whole table checksums).
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCommit | This method commits a pending transaction (level). If an error occurs (e.g. deadlock detected or transaction level has been marked as corrupted) the transaction is not automatically rolled back.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionCorrupted | This method marks the transaction (level) as corrupted and thus preventing it from ever being committed.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionGetLevel | This method returns the nesting level of the current transaction.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionRollback | Rollback rolls (as the name says) back a pending transaction (level). All changes since the last StartTransaction (or equivalent) call are lost.
TransactionStart |
TransactionStart |
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
TransactionStartWith | Start a transaction if an exclusive lock can be granted on all specified cursors. If the grant fails one or more tables or an error occurs, an error code is returned.
Public Properties
Name | Description
Alias | This is Alias, a member of class TnxSqlAbstractDatabase.
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
ExplicitAllowSystem | This is ExplicitAllowSystem, a member of class TnxAbstractDatabase.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
LastAutoInc | This is LastAutoInc, a member of class TnxSqlAbstractDatabase.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
OpenMode | This is OpenMode, a member of class TnxSqlAbstractDatabase.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
ShareMode | This is ShareMode, a member of class TnxSqlAbstractDatabase.
Timeout | Property to read/write the timeout in msec for the object.
TransContext | This property returns the transaction context the database is linked to.
Links
TnxSqlAbstractDatabase Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxSqlAbstractDatabase Fields

TnxSqlAbstractDatabase Fields
TnxSqlAbstractDatabase Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxSqlAbstractDatabase class are listed here.

Class

TnxSqlAbstractDatabase Class

Protected Fields
Name | Description
sadLastAutoInc | This is sadLastAutoInc, a member of class TnxSqlAbstractDatabase.
sdOpenMode | This is sdOpenMode, a member of class TnxSqlAbstractDatabase.
sdShareMode | This is sdShareMode, a member of class TnxSqlAbstractDatabase.
Public Fields
Name | Description
sadMasterDatabase | for testing only
Links
TnxSqlAbstractDatabase Class, Legend, Protected Fields, Public Fields


TnxSqlAbstractDatabase.sadLastAutoInc Field

TnxSqlAbstractDatabase.sadLastAutoInc Field
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Fields Send Feedback
Syntax
Delphi
sadLastAutoInc: TnxWord32;
Description

This is sadLastAutoInc, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Fields

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Fields


TnxSqlAbstractDatabase.sadMasterDatabase Field

TnxSqlAbstractDatabase.sadMasterDatabase Field
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Fields Send Feedback
Syntax
Delphi
sadMasterDatabase: TnxSqlAbstractDatabase;
Description

for testing only

Group

TnxSqlAbstractDatabase Fields

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Fields


TnxSqlAbstractDatabase.sdOpenMode Field

TnxSqlAbstractDatabase.sdOpenMode Field
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Fields Send Feedback
Syntax
Delphi
sdOpenMode: TnxOpenMode;
Description

This is sdOpenMode, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Fields

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Fields


TnxSqlAbstractDatabase.sdShareMode Field

TnxSqlAbstractDatabase.sdShareMode Field
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Fields Send Feedback
Syntax
Delphi
sdShareMode: TnxShareMode;
Description

This is sdShareMode, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Fields

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Fields


TnxSqlAbstractDatabase Methods

TnxSqlAbstractDatabase Methods
TnxSqlAbstractDatabase Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSqlAbstractDatabase class are listed here.

Class

TnxSqlAbstractDatabase Class

Protected Methods
Name | Description
sadGetAlias | TnxSqlAbstractDatabase
Public Methods
Name | Description
sadCreateResultSet | This is sadCreateResultSet, a member of class TnxSqlAbstractDatabase.
sadLockTables | This is sadLockTables, a member of class TnxSqlAbstractDatabase.
sadUnlockTables | This is sadUnlockTables, a member of class TnxSqlAbstractDatabase.
sdIterateDictionaries | This is sdIterateDictionaries, a member of class TnxSqlAbstractDatabase.
sdTableRebuildIndex | table managmenet
sdTableRestructure | This is sdTableRestructure, a member of class TnxSqlAbstractDatabase.
Links
TnxSqlAbstractDatabase Class, Legend, Protected Methods, Public Methods


TnxSqlAbstractDatabase.sadCreateResultSet Method

TnxSqlAbstractDatabase.sadCreateResultSet Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
function sadCreateResultSet(aDictionary: TnxDataDictionary; aTimeout: TnxWord32): TnxSqlAbstractCursor; virtual; abstract;
Description

This is sadCreateResultSet, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sadGetAlias Method

TnxSqlAbstractDatabase.sadGetAlias Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
function sadGetAlias: UnicodeString; virtual;
Description

TnxSqlAbstractDatabase

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sadLockTables Method

TnxSqlAbstractDatabase.sadLockTables Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure sadLockTables; virtual; abstract;
Description

This is sadLockTables, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sadUnlockTables Method

TnxSqlAbstractDatabase.sadUnlockTables Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
procedure sadUnlockTables; virtual; abstract;
Description

This is sadUnlockTables, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sdIterateDictionaries Method

TnxSqlAbstractDatabase.sdIterateDictionaries Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
function sdIterateDictionaries(aIterator: TnxDictionaryIterator; aAllowSystem: Boolean; aIgnoreError: Boolean; aCookie: Pointer): TnxIteratorResult; virtual; abstract;
Description

This is sdIterateDictionaries, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sdTableRebuildIndex Method

TnxSqlAbstractDatabase.sdTableRebuildIndex Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
function sdTableRebuildIndex(const aTableName: string; const aPassword: UnicodeString; const aIndexName: string; aIndexID: Integer; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

table managmenet

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase.sdTableRestructure Method

TnxSqlAbstractDatabase.sdTableRestructure Method
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Methods Send Feedback
Syntax
Delphi
function sdTableRestructure(const aTableName: string; const aPassword: UnicodeString; aDictionary: TnxDataDictionary; aMapperDesc: TnxBaseTableMapperDescriptor; out aTaskInfo: TnxAbstractTaskInfo): TnxResult; virtual; abstract;
Description

This is sdTableRestructure, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Methods

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Methods


TnxSqlAbstractDatabase Properties

TnxSqlAbstractDatabase Properties
TnxSqlAbstractDatabase Class Legend Public Properties Send Feedback

The properties of the TnxSqlAbstractDatabase class are listed here.

Class

TnxSqlAbstractDatabase Class

Public Properties
Name | Description
Alias | This is Alias, a member of class TnxSqlAbstractDatabase.
LastAutoInc | This is LastAutoInc, a member of class TnxSqlAbstractDatabase.
OpenMode | This is OpenMode, a member of class TnxSqlAbstractDatabase.
ShareMode | This is ShareMode, a member of class TnxSqlAbstractDatabase.
Links
TnxSqlAbstractDatabase Class, Legend, Public Properties


TnxSqlAbstractDatabase.Alias Property

TnxSqlAbstractDatabase.Alias Property
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Properties Send Feedback
Syntax
Delphi
property Alias: UnicodeString;
Description

This is Alias, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Properties

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Properties


TnxSqlAbstractDatabase.LastAutoInc Property

TnxSqlAbstractDatabase.LastAutoInc Property
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Properties Send Feedback
Syntax
Delphi
property LastAutoInc: TnxWord32;
Description

This is LastAutoInc, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Properties

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Properties


TnxSqlAbstractDatabase.OpenMode Property

TnxSqlAbstractDatabase.OpenMode Property
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Properties Send Feedback
Syntax
Delphi
property OpenMode: TnxOpenMode;
Description

This is OpenMode, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Properties

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Properties


TnxSqlAbstractDatabase.ShareMode Property

TnxSqlAbstractDatabase.ShareMode Property
TnxSqlAbstractDatabase Class TnxSqlAbstractDatabase Members nxsdServerEngine Namespace TnxSqlAbstractDatabase Properties Send Feedback
Syntax
Delphi
property ShareMode: TnxShareMode;
Description

This is ShareMode, a member of class TnxSqlAbstractDatabase.

Group

TnxSqlAbstractDatabase Properties

Links
TnxSqlAbstractDatabase Class, TnxSqlAbstractDatabase Members, nxsdServerEngine Namespace, TnxSqlAbstractDatabase Properties


TnxSqlAbstractTaskInfo Class

TnxSqlAbstractTaskInfo Class
TnxSqlAbstractTaskInfo Methods TnxSqlAbstractTaskInfo Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfonxsdServerEngine_TnxSqlAbstractTaskInfo
Syntax
Delphi
TnxSqlAbstractTaskInfo = class(TnxAbstractTaskInfo);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.TnxSqlAbstractTaskInfo.

Group

Classes

Links
TnxSqlAbstractTaskInfo Methods, TnxSqlAbstractTaskInfo Members, nxsdServerEngine, Classes


TnxSqlAbstractTaskInfo Members

TnxSqlAbstractTaskInfo Members
TnxSqlAbstractTaskInfo Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSqlAbstractTaskInfo.

Class

TnxSqlAbstractTaskInfo Class

Protected Fields
Name | Description
asoDestroyFlag | This is asoDestroyFlag, a member of class TnxAbstractServerObject.
asoDestroying | private
asoSession | This is asoSession, a member of class TnxAbstractServerObject.
atiSessionNext | This is atiSessionNext, a member of class TnxAbstractTaskInfo.
atiSessionPrev | private
esoExtendersActions | This is esoExtendersActions, a member of class TnxExtendableServerObject.
esoExtendersHead | This is esoExtendersHead, a member of class TnxExtendableServerObject.
esoExtendersLock | This is esoExtendersLock, a member of class TnxExtendableServerObject.
esoExtendersTail | This is esoExtendersTail, a member of class TnxExtendableServerObject.
esoIgnoreSecurity | This is esoIgnoreSecurity, a member of class TnxExtendableServerObject.
esoOptions | This is esoOptions, a member of class TnxExtendableServerObject.
esoParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
asoCreateInstance | remoting integration
asoGetMinVersion |
asoGetRemoteID |
asoGetRemoteThreadPriority |
asoGetServerEngine |
asoGetServerEngine |
asoSetRemoteThreadPriority |
atiAddToSession | TnxAbstractTaskInfo
atiRemoveFromSession |
esoCreateInstance | remoting integration
esoGetOptions | options
esoGetOptionsParent |
esoInformMonitors |
esoOptionGet |
esoOptionGetParent |
esoOptionList |
esoOptionListEffective |
esoOptionListMerge |
esoOptionListParent |
GetEncodedExceptionData | InxAbstractServerObject41100
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
AfterConstruction | see TObject.AfterConstruction TnxExtendableServerObject
asoConvertException | TnxAbstractServerObject
BeforeDestruction | TnxLifetimeTrackedPersistent
BeforeDestruction | see TObject.BeforeDestruction.
BeforeDestruction | see TObject.BeforeConstruction
BeginIgnoreSecurity |
Cancel | Call this method to cancel a Task. This method only triggers the cancel, the tasks may still be active until it reaches a safe state. The client-side taskinfo object should not be freed until the aCompleted parameter of GetStatus returns True, indicating task has ended.
Close |
Create |
Create | public comes before protected to fix problem with BCB constructor.
Create | constructor.
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
CreateInstanceFor | remoting integration
Destroy | destructor.
Destroy | destructor.
EndIgnoreSecurity |
esoOptionChanged |
esoOptionClear |
esoOptionGetEffective |
esoOptionSet |
Execute | This is Execute, a member of class TnxSqlAbstractTaskInfo.
Free | Reintroduction of the Free method
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeInstance |
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetExtenderOfType | returns the first Extender of a certain class type of the registered Extender list
GetLifetimeMontior |
GetStatus | This function returns the current status a server task.
LookupByID |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NewInstance |
NotifyExtenders | This function is called to notify all Monitors attached to the owning Server Engine of an Action.
OptionClear | === options === Removes an Option from the named option list
OptionGet | Returns the value of an Option in named option list of *this* object only.
OptionGetEffective | Returns the value of an Option in named option by walking the parent hierarchy until a value is found.
OptionList | Returns all options as value list (name=value) of this object.
OptionListEffective | Returns all options as value list (name=value) of the whole parent hierarchy.
OptionSet | Sets an Option in named option list to a certain value.
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
PrepareDestroy |
PrepareDestroy |
Public Properties
Name | Description
Destroying | This is Destroying, a member of class TnxAbstractServerObject.
IgnoreSecurity | This is IgnoreSecurity, a member of class TnxExtendableServerObject.
MinVersion | This is MinVersion, a member of class TnxAbstractServerObject.
RemoteID | This is RemoteID, a member of class TnxAbstractServerObject.
RemoteThreadPriority | RemoteThreadPriority is the thread priority send to the server in case the object is living on a remote machine.
Session | The session owning this server object (if any) or nil.
Links
TnxSqlAbstractTaskInfo Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSqlAbstractTaskInfo Methods

TnxSqlAbstractTaskInfo Methods
TnxSqlAbstractTaskInfo Class Legend Public Methods Send Feedback

The methods of the TnxSqlAbstractTaskInfo class are listed here.

Class

TnxSqlAbstractTaskInfo Class

Public Methods
Name | Description
Execute | This is Execute, a member of class TnxSqlAbstractTaskInfo.
Links
TnxSqlAbstractTaskInfo Class, Legend, Public Methods


TnxSqlAbstractTaskInfo.Execute Method

TnxSqlAbstractTaskInfo.Execute Method
TnxSqlAbstractTaskInfo Class TnxSqlAbstractTaskInfo Members nxsdServerEngine Namespace TnxSqlAbstractTaskInfo Methods Send Feedback
Syntax
Delphi
procedure Execute; virtual; abstract;
Description

This is Execute, a member of class TnxSqlAbstractTaskInfo.

Group

TnxSqlAbstractTaskInfo Methods

Links
TnxSqlAbstractTaskInfo Class, TnxSqlAbstractTaskInfo Members, nxsdServerEngine Namespace, TnxSqlAbstractTaskInfo Methods


TnxTableDescriptor Class

TnxTableDescriptor Class
TnxTableDescriptor Fields TnxTableDescriptor Members nxsdServerEngine Classes Send Feedback
Class Hierarchy
nxsdServerEngine_TnxTableDescriptornxsdServerEngine_TnxTableDescriptor
Syntax
Delphi
TnxTableDescriptor = class(TnxObject);
File

nxsdServerEngine

Description

A Table descriptor.

Group

Classes

Links
TnxTableDescriptor Fields, TnxTableDescriptor Members, nxsdServerEngine, Classes


TnxTableDescriptor Members

TnxTableDescriptor Members
TnxTableDescriptor Class Legend Public Fields Public Methods Send Feedback

The following tables list the members exposed by TnxTableDescriptor.

Class

TnxTableDescriptor Class

Public Fields
Name | Description
tdExt | File extension.
tdSize | File Size.
tdTableName | Table Name.
tdTimeStamp | Not used currently.
Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxTableDescriptor Class, Legend, Public Fields, Public Methods


TnxTableDescriptor Fields

TnxTableDescriptor Fields
TnxTableDescriptor Class Legend Public Fields Send Feedback

The fields of the TnxTableDescriptor class are listed here.

Class

TnxTableDescriptor Class

Public Fields
Name | Description
tdExt | File extension.
tdSize | File Size.
tdTableName | Table Name.
tdTimeStamp | Not used currently.
Links
TnxTableDescriptor Class, Legend, Public Fields


TnxTableDescriptor.tdExt Field

TnxTableDescriptor.tdExt Field
TnxTableDescriptor Class TnxTableDescriptor Members nxsdServerEngine Namespace TnxTableDescriptor Fields Send Feedback
Syntax
Delphi
tdExt: string;
Description

File extension.

Group

TnxTableDescriptor Fields

Links
TnxTableDescriptor Class, TnxTableDescriptor Members, nxsdServerEngine Namespace, TnxTableDescriptor Fields


TnxTableDescriptor.tdSize Field

TnxTableDescriptor.tdSize Field
TnxTableDescriptor Class TnxTableDescriptor Members nxsdServerEngine Namespace TnxTableDescriptor Fields Send Feedback
Syntax
Delphi
tdSize: TnxInt64;
Description

File Size.

Group

TnxTableDescriptor Fields

Links
TnxTableDescriptor Class, TnxTableDescriptor Members, nxsdServerEngine Namespace, TnxTableDescriptor Fields


TnxTableDescriptor.tdTableName Field

TnxTableDescriptor.tdTableName Field
TnxTableDescriptor Class TnxTableDescriptor Members nxsdServerEngine Namespace TnxTableDescriptor Fields Send Feedback
Syntax
Delphi
tdTableName: string;
Description

Table Name.

Group

TnxTableDescriptor Fields

Links
TnxTableDescriptor Class, TnxTableDescriptor Members, nxsdServerEngine Namespace, TnxTableDescriptor Fields


TnxTableDescriptor.tdTimeStamp Field

TnxTableDescriptor.tdTimeStamp Field
TnxTableDescriptor Class TnxTableDescriptor Members nxsdServerEngine Namespace TnxTableDescriptor Fields Send Feedback
Syntax
Delphi
tdTimeStamp: TnxWord32;
Description

Not used currently.

Group

TnxTableDescriptor Fields

Links
TnxTableDescriptor Class, TnxTableDescriptor Members, nxsdServerEngine Namespace, TnxTableDescriptor Fields


Interfaces

Interfaces
nxsdServerEngine Namespace Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Namespace

nxsdServerEngine Namespace

Interfaces
Name | Description
InxAbstractDatabase31000 | This is class nxsdServerEngine.InxAbstractDatabase31000.
InxAbstractSecurityMonitorComponentInfo31000 | This is class nxsdServerEngine.InxAbstractSecurityMonitorComponentInfo31000.
InxAbstractServerObject41100 | This is class nxsdServerEngine.InxAbstractServerObject41100.
InxDatabaseCursorSource | This is class nxsdServerEngine.InxDatabaseCursorSource.
InxDatabaseCursorSourceControl | This is class nxsdServerEngine.InxDatabaseCursorSourceControl.
InxLoggedInAdministrator31000 | This is class nxsdServerEngine.InxLoggedInAdministrator31000.
InxLoggedInUser31000 | This is class nxsdServerEngine.InxLoggedInUser31000.
InxModifyUser31000 | This is class nxsdServerEngine.InxModifyUser31000.
InxRemoteTaskInfoCreator | This is class nxsdServerEngine.InxRemoteTaskInfoCreator.
InxRequestCloseHandler | This is class nxsdServerEngine.InxRequestCloseHandler.
InxRequestCloseHandlerEvent | This is class nxsdServerEngine.InxRequestCloseHandlerEvent.
InxSecurityExtender31000 | This is class nxsdServerEngine.InxSecurityExtender31000.
InxSimpleLock | This is class nxsdServerEngine.InxSimpleLock.
Links
nxsdServerEngine Namespace, Interfaces, Legend


InxAbstractDatabase31000 Interface

InxAbstractDatabase31000 Interface
InxAbstractDatabase31000 Methods InxAbstractDatabase31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxAbstractDatabase31000
Syntax
Delphi
InxAbstractDatabase31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxAbstractDatabase31000.

Group

Interfaces

Links
InxAbstractDatabase31000 Methods, InxAbstractDatabase31000 Members, nxsdServerEngine, Interfaces


InxAbstractDatabase31000 Members

InxAbstractDatabase31000 Members
InxAbstractDatabase31000 Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxAbstractDatabase31000.

Interface

InxAbstractDatabase31000 Interface

Public Methods
Name | Description
GetTablesNeedingPack | This is GetTablesNeedingPack, a member of class InxAbstractDatabase31000.
Links
InxAbstractDatabase31000 Interface, Legend, Public Methods


InxAbstractDatabase31000 Methods

InxAbstractDatabase31000 Methods
InxAbstractDatabase31000 Interface Legend Public Methods Send Feedback

The methods of the InxAbstractDatabase31000 class are listed here.

Interface

InxAbstractDatabase31000 Interface

Public Methods
Name | Description
GetTablesNeedingPack | This is GetTablesNeedingPack, a member of class InxAbstractDatabase31000.
Links
InxAbstractDatabase31000 Interface, Legend, Public Methods


InxAbstractDatabase31000.GetTablesNeedingPack Method

InxAbstractDatabase31000.GetTablesNeedingPack Method
InxAbstractDatabase31000 Interface InxAbstractDatabase31000 Members nxsdServerEngine Namespace InxAbstractDatabase31000 Methods Send Feedback
Syntax
Delphi
function GetTablesNeedingPack: TnxUnicodeStrings;
Description

This is GetTablesNeedingPack, a member of class InxAbstractDatabase31000.

Group

InxAbstractDatabase31000 Methods

Links
InxAbstractDatabase31000 Interface, InxAbstractDatabase31000 Members, nxsdServerEngine Namespace, InxAbstractDatabase31000 Methods


InxAbstractSecurityMonitorComponentInfo31000 Interface

InxAbstractSecurityMonitorComponentInfo31000 Interface
InxAbstractSecurityMonitorComponentInfo31000 Methods InxAbstractSecurityMonitorComponentInfo31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxAbstractSecurityMonitorComponentInfo31000
Syntax
Delphi
InxAbstractSecurityMonitorComponentInfo31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxAbstractSecurityMonitorComponentInfo31000.

Group

Interfaces

Links
InxAbstractSecurityMonitorComponentInfo31000 Methods, InxAbstractSecurityMonitorComponentInfo31000 Members, nxsdServerEngine, Interfaces


InxAbstractSecurityMonitorComponentInfo31000 Members

InxAbstractSecurityMonitorComponentInfo31000 Members
InxAbstractSecurityMonitorComponentInfo31000 Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxAbstractSecurityMonitorComponentInfo31000.

Interface

InxAbstractSecurityMonitorComponentInfo31000 Interface

Public Methods
Name | Description
LogIn | This is LogIn, a member of class InxAbstractSecurityMonitorComponentInfo31000.
Links
InxAbstractSecurityMonitorComponentInfo31000 Interface, Legend, Public Methods


InxAbstractSecurityMonitorComponentInfo31000 Methods

InxAbstractSecurityMonitorComponentInfo31000 Methods
InxAbstractSecurityMonitorComponentInfo31000 Interface Legend Public Methods Send Feedback

The methods of the InxAbstractSecurityMonitorComponentInfo31000 class are listed here.

Interface

InxAbstractSecurityMonitorComponentInfo31000 Interface

Public Methods
Name | Description
LogIn | This is LogIn, a member of class InxAbstractSecurityMonitorComponentInfo31000.
Links
InxAbstractSecurityMonitorComponentInfo31000 Interface, Legend, Public Methods


InxAbstractSecurityMonitorComponentInfo31000.LogIn Method

InxAbstractSecurityMonitorComponentInfo31000.LogIn Method
InxAbstractSecurityMonitorComponentInfo31000 Interface InxAbstractSecurityMonitorComponentInfo31000 Members nxsdServerEngine Namespace InxAbstractSecurityMonitorComponentInfo31000 Methods Send Feedback
Syntax
Delphi
function LogIn(const aUserName: UnicodeString; const aPassword: UnicodeString): InxLoggedInUser31000;
Description

This is LogIn, a member of class InxAbstractSecurityMonitorComponentInfo31000.

Group

InxAbstractSecurityMonitorComponentInfo31000 Methods

Links
InxAbstractSecurityMonitorComponentInfo31000 Interface, InxAbstractSecurityMonitorComponentInfo31000 Members, nxsdServerEngine Namespace, InxAbstractSecurityMonitorComponentInfo31000 Methods


InxAbstractServerObject41100 Interface

InxAbstractServerObject41100 Interface
InxAbstractServerObject41100 Methods InxAbstractServerObject41100 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxAbstractServerObject41100
Syntax
Delphi
InxAbstractServerObject41100 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxAbstractServerObject41100.

Group

Interfaces

Links
InxAbstractServerObject41100 Methods, InxAbstractServerObject41100 Members, nxsdServerEngine, Interfaces


InxAbstractServerObject41100 Members

InxAbstractServerObject41100 Members
InxAbstractServerObject41100 Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxAbstractServerObject41100.

Interface

InxAbstractServerObject41100 Interface

Public Methods
Name | Description
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
Links
InxAbstractServerObject41100 Interface, Legend, Public Methods


InxAbstractServerObject41100 Methods

InxAbstractServerObject41100 Methods
InxAbstractServerObject41100 Interface Legend Public Methods Send Feedback

The methods of the InxAbstractServerObject41100 class are listed here.

Interface

InxAbstractServerObject41100 Interface

Public Methods
Name | Description
GetEncodedExceptionData | This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.
Links
InxAbstractServerObject41100 Interface, Legend, Public Methods


InxAbstractServerObject41100.GetEncodedExceptionData Method

InxAbstractServerObject41100.GetEncodedExceptionData Method
InxAbstractServerObject41100 Interface InxAbstractServerObject41100 Members nxsdServerEngine Namespace InxAbstractServerObject41100 Methods Send Feedback
Syntax
Delphi
function GetEncodedExceptionData(aIncludeChildren: Boolean): string;
Description

This is GetEncodedExceptionData, a member of class InxAbstractServerObject41100.

Group

InxAbstractServerObject41100 Methods

Links
InxAbstractServerObject41100 Interface, InxAbstractServerObject41100 Members, nxsdServerEngine Namespace, InxAbstractServerObject41100 Methods


InxDatabaseCursorSource Interface

InxDatabaseCursorSource Interface
InxDatabaseCursorSource Methods InxDatabaseCursorSource Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxDatabaseCursorSource
Syntax
Delphi
InxDatabaseCursorSource = interface(InxInterface);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxDatabaseCursorSource.

Group

Interfaces

Links
InxDatabaseCursorSource Methods, InxDatabaseCursorSource Members, nxsdServerEngine, Interfaces


InxDatabaseCursorSource Members

InxDatabaseCursorSource Members
InxDatabaseCursorSource Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxDatabaseCursorSource.

Interface

InxDatabaseCursorSource Interface

Public Methods
Name | Description
CursorOpen | This is CursorOpen, a member of class InxDatabaseCursorSource.
Links
InxDatabaseCursorSource Interface, Legend, Public Methods


InxDatabaseCursorSource Methods

InxDatabaseCursorSource Methods
InxDatabaseCursorSource Interface Legend Public Methods Send Feedback

The methods of the InxDatabaseCursorSource class are listed here.

Interface

InxDatabaseCursorSource Interface

Public Methods
Name | Description
CursorOpen | This is CursorOpen, a member of class InxDatabaseCursorSource.
Links
InxDatabaseCursorSource Interface, Legend, Public Methods


InxDatabaseCursorSource.CursorOpen Method

InxDatabaseCursorSource.CursorOpen Method
InxDatabaseCursorSource Interface InxDatabaseCursorSource Members nxsdServerEngine Namespace InxDatabaseCursorSource Methods Send Feedback
Syntax
Delphi
function CursorOpen(const aTableName: string): TnxAbstractCursor;
Description

This is CursorOpen, a member of class InxDatabaseCursorSource.

Group

InxDatabaseCursorSource Methods

Links
InxDatabaseCursorSource Interface, InxDatabaseCursorSource Members, nxsdServerEngine Namespace, InxDatabaseCursorSource Methods


InxDatabaseCursorSourceControl Interface

InxDatabaseCursorSourceControl Interface
InxDatabaseCursorSourceControl Methods InxDatabaseCursorSourceControl Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxDatabaseCursorSourceControl
Syntax
Delphi
InxDatabaseCursorSourceControl = interface(InxInterface);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxDatabaseCursorSourceControl.

Group

Interfaces

Links
InxDatabaseCursorSourceControl Methods, InxDatabaseCursorSourceControl Members, nxsdServerEngine, Interfaces


InxDatabaseCursorSourceControl Members

InxDatabaseCursorSourceControl Members
InxDatabaseCursorSourceControl Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxDatabaseCursorSourceControl.

Interface

InxDatabaseCursorSourceControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxDatabaseCursorSourceControl.
Links
InxDatabaseCursorSourceControl Interface, Legend, Public Methods


InxDatabaseCursorSourceControl Methods

InxDatabaseCursorSourceControl Methods
InxDatabaseCursorSourceControl Interface Legend Public Methods Send Feedback

The methods of the InxDatabaseCursorSourceControl class are listed here.

Interface

InxDatabaseCursorSourceControl Interface

Public Methods
Name | Description
Unregister | This is Unregister, a member of class InxDatabaseCursorSourceControl.
Links
InxDatabaseCursorSourceControl Interface, Legend, Public Methods


InxDatabaseCursorSourceControl.Unregister Method

InxDatabaseCursorSourceControl.Unregister Method
InxDatabaseCursorSourceControl Interface InxDatabaseCursorSourceControl Members nxsdServerEngine Namespace InxDatabaseCursorSourceControl Methods Send Feedback
Syntax
Delphi
function Unregister: TnxResult;
Description

This is Unregister, a member of class InxDatabaseCursorSourceControl.

Group

InxDatabaseCursorSourceControl Methods

Links
InxDatabaseCursorSourceControl Interface, InxDatabaseCursorSourceControl Members, nxsdServerEngine Namespace, InxDatabaseCursorSourceControl Methods


InxLoggedInAdministrator31000 Interface

InxLoggedInAdministrator31000 Interface
InxLoggedInAdministrator31000 Methods InxLoggedInAdministrator31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxLoggedInAdministrator31000
Syntax
Delphi
InxLoggedInAdministrator31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxLoggedInAdministrator31000.

Group

Interfaces

Links
InxLoggedInAdministrator31000 Methods, InxLoggedInAdministrator31000 Members, nxsdServerEngine, Interfaces


InxLoggedInAdministrator31000 Members

InxLoggedInAdministrator31000 Members
InxLoggedInAdministrator31000 Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxLoggedInAdministrator31000.

Interface

InxLoggedInAdministrator31000 Interface

Public Methods
Name | Description
AddUser | This is AddUser, a member of class InxLoggedInAdministrator31000.
AdminList | This is AdminList, a member of class InxLoggedInAdministrator31000.
GrantAdminKey | This is GrantAdminKey, a member of class InxLoggedInAdministrator31000.
ModifyUser | This is ModifyUser, a member of class InxLoggedInAdministrator31000.
RemoveUser | This is RemoveUser, a member of class InxLoggedInAdministrator31000.
RevokeAdminKey | This is RevokeAdminKey, a member of class InxLoggedInAdministrator31000.
SetUserDisabled | This is SetUserDisabled, a member of class InxLoggedInAdministrator31000.
SetUserPassword | This is SetUserPassword, a member of class InxLoggedInAdministrator31000.
UserExists | This is UserExists, a member of class InxLoggedInAdministrator31000.
UserList | This is UserList, a member of class InxLoggedInAdministrator31000.
Links
InxLoggedInAdministrator31000 Interface, Legend, Public Methods


InxLoggedInAdministrator31000 Methods

InxLoggedInAdministrator31000 Methods
InxLoggedInAdministrator31000 Interface Legend Public Methods Send Feedback

The methods of the InxLoggedInAdministrator31000 class are listed here.

Interface

InxLoggedInAdministrator31000 Interface

Public Methods
Name | Description
AddUser | This is AddUser, a member of class InxLoggedInAdministrator31000.
AdminList | This is AdminList, a member of class InxLoggedInAdministrator31000.
GrantAdminKey | This is GrantAdminKey, a member of class InxLoggedInAdministrator31000.
ModifyUser | This is ModifyUser, a member of class InxLoggedInAdministrator31000.
RemoveUser | This is RemoveUser, a member of class InxLoggedInAdministrator31000.
RevokeAdminKey | This is RevokeAdminKey, a member of class InxLoggedInAdministrator31000.
SetUserDisabled | This is SetUserDisabled, a member of class InxLoggedInAdministrator31000.
SetUserPassword | This is SetUserPassword, a member of class InxLoggedInAdministrator31000.
UserExists | This is UserExists, a member of class InxLoggedInAdministrator31000.
UserList | This is UserList, a member of class InxLoggedInAdministrator31000.
Links
InxLoggedInAdministrator31000 Interface, Legend, Public Methods


InxLoggedInAdministrator31000.AddUser Method

InxLoggedInAdministrator31000.AddUser Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure AddUser(const aUserName: UnicodeString; const aPassword: UnicodeString; aAsAdmin: Boolean; aReadAccess: Boolean; aWriteAccess: Boolean);
Description

This is AddUser, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.AdminList Method

InxLoggedInAdministrator31000.AdminList Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
function AdminList: TnxUnicodeStrings;
Description

This is AdminList, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.GrantAdminKey Method

InxLoggedInAdministrator31000.GrantAdminKey Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure GrantAdminKey(const aUserName: UnicodeString);
Description

This is GrantAdminKey, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.ModifyUser Method

InxLoggedInAdministrator31000.ModifyUser Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
function ModifyUser(const aUserName: UnicodeString): InxModifyUser31000;
Description

This is ModifyUser, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.RemoveUser Method

InxLoggedInAdministrator31000.RemoveUser Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure RemoveUser(const aUserName: UnicodeString);
Description

This is RemoveUser, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.RevokeAdminKey Method

InxLoggedInAdministrator31000.RevokeAdminKey Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure RevokeAdminKey(const aUserName: UnicodeString);
Description

This is RevokeAdminKey, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.SetUserDisabled Method

InxLoggedInAdministrator31000.SetUserDisabled Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure SetUserDisabled(const aUserName: UnicodeString; aDisabled: Boolean);
Description

This is SetUserDisabled, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.SetUserPassword Method

InxLoggedInAdministrator31000.SetUserPassword Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
procedure SetUserPassword(const aUserName: UnicodeString; const aPassword: UnicodeString);
Description

This is SetUserPassword, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.UserExists Method

InxLoggedInAdministrator31000.UserExists Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
function UserExists(const aUserName: UnicodeString): Boolean;
Description

This is UserExists, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInAdministrator31000.UserList Method

InxLoggedInAdministrator31000.UserList Method
InxLoggedInAdministrator31000 Interface InxLoggedInAdministrator31000 Members nxsdServerEngine Namespace InxLoggedInAdministrator31000 Methods Send Feedback
Syntax
Delphi
function UserList: TnxUnicodeStrings;
Description

This is UserList, a member of class InxLoggedInAdministrator31000.

Group

InxLoggedInAdministrator31000 Methods

Links
InxLoggedInAdministrator31000 Interface, InxLoggedInAdministrator31000 Members, nxsdServerEngine Namespace, InxLoggedInAdministrator31000 Methods


InxLoggedInUser31000 Interface

InxLoggedInUser31000 Interface
InxLoggedInUser31000 Methods InxLoggedInUser31000 Properties InxLoggedInUser31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxLoggedInUser31000
Syntax
Delphi
InxLoggedInUser31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxLoggedInUser31000.

Group

Interfaces

Links
InxLoggedInUser31000 Methods, InxLoggedInUser31000 Properties, InxLoggedInUser31000 Members, nxsdServerEngine, Interfaces


InxLoggedInUser31000 Members

InxLoggedInUser31000 Members
InxLoggedInUser31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxLoggedInUser31000.

Interface

InxLoggedInUser31000 Interface

Public Methods
Name | Description
ChangePassword | This is ChangePassword, a member of class InxLoggedInUser31000.
GetHasReadAccess | This is GetHasReadAccess, a member of class InxLoggedInUser31000.
GetHasWriteAccess | This is GetHasWriteAccess, a member of class InxLoggedInUser31000.
GetIsAdmin | This is GetIsAdmin, a member of class InxLoggedInUser31000.
GetIsUser | This is GetIsUser, a member of class InxLoggedInUser31000.
GetUserName | This is GetUserName, a member of class InxLoggedInUser31000.
Public Properties
Name | Description
HasReadAccess | This is HasReadAccess, a member of class InxLoggedInUser31000.
HasWriteAccess | This is HasWriteAccess, a member of class InxLoggedInUser31000.
IsAdmin | This is IsAdmin, a member of class InxLoggedInUser31000.
IsUser | This is IsUser, a member of class InxLoggedInUser31000.
UserName | This is UserName, a member of class InxLoggedInUser31000.
Links
InxLoggedInUser31000 Interface, Legend, Public Methods, Public Properties


InxLoggedInUser31000 Methods

InxLoggedInUser31000 Methods
InxLoggedInUser31000 Interface Legend Public Methods Send Feedback

The methods of the InxLoggedInUser31000 class are listed here.

Interface

InxLoggedInUser31000 Interface

Public Methods
Name | Description
ChangePassword | This is ChangePassword, a member of class InxLoggedInUser31000.
GetHasReadAccess | This is GetHasReadAccess, a member of class InxLoggedInUser31000.
GetHasWriteAccess | This is GetHasWriteAccess, a member of class InxLoggedInUser31000.
GetIsAdmin | This is GetIsAdmin, a member of class InxLoggedInUser31000.
GetIsUser | This is GetIsUser, a member of class InxLoggedInUser31000.
GetUserName | This is GetUserName, a member of class InxLoggedInUser31000.
Links
InxLoggedInUser31000 Interface, Legend, Public Methods


InxLoggedInUser31000.ChangePassword Method

InxLoggedInUser31000.ChangePassword Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
procedure ChangePassword(aPassword: UnicodeString);
Description

This is ChangePassword, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000.GetHasReadAccess Method

InxLoggedInUser31000.GetHasReadAccess Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
function GetHasReadAccess: Boolean;
Description

This is GetHasReadAccess, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000.GetHasWriteAccess Method

InxLoggedInUser31000.GetHasWriteAccess Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
function GetHasWriteAccess: Boolean;
Description

This is GetHasWriteAccess, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000.GetIsAdmin Method

InxLoggedInUser31000.GetIsAdmin Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
function GetIsAdmin: Boolean;
Description

This is GetIsAdmin, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000.GetIsUser Method

InxLoggedInUser31000.GetIsUser Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
function GetIsUser: Boolean;
Description

This is GetIsUser, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000.GetUserName Method

InxLoggedInUser31000.GetUserName Method
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Methods Send Feedback
Syntax
Delphi
function GetUserName: UnicodeString;
Description

This is GetUserName, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Methods

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Methods


InxLoggedInUser31000 Properties

InxLoggedInUser31000 Properties
InxLoggedInUser31000 Interface Legend Public Properties Send Feedback

The properties of the InxLoggedInUser31000 class are listed here.

Interface

InxLoggedInUser31000 Interface

Public Properties
Name | Description
HasReadAccess | This is HasReadAccess, a member of class InxLoggedInUser31000.
HasWriteAccess | This is HasWriteAccess, a member of class InxLoggedInUser31000.
IsAdmin | This is IsAdmin, a member of class InxLoggedInUser31000.
IsUser | This is IsUser, a member of class InxLoggedInUser31000.
UserName | This is UserName, a member of class InxLoggedInUser31000.
Links
InxLoggedInUser31000 Interface, Legend, Public Properties


InxLoggedInUser31000.HasReadAccess Property

InxLoggedInUser31000.HasReadAccess Property
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Properties Send Feedback
Syntax
Delphi
property HasReadAccess: Boolean;
Description

This is HasReadAccess, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Properties

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Properties


InxLoggedInUser31000.HasWriteAccess Property

InxLoggedInUser31000.HasWriteAccess Property
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Properties Send Feedback
Syntax
Delphi
property HasWriteAccess: Boolean;
Description

This is HasWriteAccess, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Properties

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Properties


InxLoggedInUser31000.IsAdmin Property

InxLoggedInUser31000.IsAdmin Property
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Properties Send Feedback
Syntax
Delphi
property IsAdmin: Boolean;
Description

This is IsAdmin, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Properties

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Properties


InxLoggedInUser31000.IsUser Property

InxLoggedInUser31000.IsUser Property
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Properties Send Feedback
Syntax
Delphi
property IsUser: Boolean;
Description

This is IsUser, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Properties

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Properties


InxLoggedInUser31000.UserName Property

InxLoggedInUser31000.UserName Property
InxLoggedInUser31000 Interface InxLoggedInUser31000 Members nxsdServerEngine Namespace InxLoggedInUser31000 Properties Send Feedback
Syntax
Delphi
property UserName: UnicodeString;
Description

This is UserName, a member of class InxLoggedInUser31000.

Group

InxLoggedInUser31000 Properties

Links
InxLoggedInUser31000 Interface, InxLoggedInUser31000 Members, nxsdServerEngine Namespace, InxLoggedInUser31000 Properties


InxModifyUser31000 Interface

InxModifyUser31000 Interface
InxModifyUser31000 Methods InxModifyUser31000 Properties InxModifyUser31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxModifyUser31000
Syntax
Delphi
InxModifyUser31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxModifyUser31000.

Group

Interfaces

Links
InxModifyUser31000 Methods, InxModifyUser31000 Properties, InxModifyUser31000 Members, nxsdServerEngine, Interfaces


InxModifyUser31000 Members

InxModifyUser31000 Members
InxModifyUser31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxModifyUser31000.

Interface

InxModifyUser31000 Interface

Public Methods
Name | Description
AddTablePassword | This is AddTablePassword, a member of class InxModifyUser31000.
GetHasReadAccess | procedure SetIsAdmin(aValue: Boolean);
GetHasWriteAccess | This is GetHasWriteAccess, a member of class InxModifyUser31000.
GetIsAdmin | This is GetIsAdmin, a member of class InxModifyUser31000.
RemoveAllTablePasswords | This is RemoveAllTablePasswords, a member of class InxModifyUser31000.
RemoveTablePassword | This is RemoveTablePassword, a member of class InxModifyUser31000.
SetHasReadAccess | This is SetHasReadAccess, a member of class InxModifyUser31000.
SetHasWriteAccess | This is SetHasWriteAccess, a member of class InxModifyUser31000.
Public Properties
Name | Description
HasReadAccess | This is HasReadAccess, a member of class InxModifyUser31000.
HasWriteAccess | This is HasWriteAccess, a member of class InxModifyUser31000.
IsAdmin | This is IsAdmin, a member of class InxModifyUser31000.
Links
InxModifyUser31000 Interface, Legend, Public Methods, Public Properties


InxModifyUser31000 Methods

InxModifyUser31000 Methods
InxModifyUser31000 Interface Legend Public Methods Send Feedback

The methods of the InxModifyUser31000 class are listed here.

Interface

InxModifyUser31000 Interface

Public Methods
Name | Description
AddTablePassword | This is AddTablePassword, a member of class InxModifyUser31000.
GetHasReadAccess | procedure SetIsAdmin(aValue: Boolean);
GetHasWriteAccess | This is GetHasWriteAccess, a member of class InxModifyUser31000.
GetIsAdmin | This is GetIsAdmin, a member of class InxModifyUser31000.
RemoveAllTablePasswords | This is RemoveAllTablePasswords, a member of class InxModifyUser31000.
RemoveTablePassword | This is RemoveTablePassword, a member of class InxModifyUser31000.
SetHasReadAccess | This is SetHasReadAccess, a member of class InxModifyUser31000.
SetHasWriteAccess | This is SetHasWriteAccess, a member of class InxModifyUser31000.
Links
InxModifyUser31000 Interface, Legend, Public Methods


InxModifyUser31000.AddTablePassword Method

InxModifyUser31000.AddTablePassword Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
procedure AddTablePassword(const aAlias: UnicodeString; const aTable: UnicodeString; const aPassword: UnicodeString);
Description

This is AddTablePassword, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.GetHasReadAccess Method

InxModifyUser31000.GetHasReadAccess Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
function GetHasReadAccess: Boolean;
Description

procedure SetIsAdmin(aValue: Boolean);

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.GetHasWriteAccess Method

InxModifyUser31000.GetHasWriteAccess Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
function GetHasWriteAccess: Boolean;
Description

This is GetHasWriteAccess, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.GetIsAdmin Method

InxModifyUser31000.GetIsAdmin Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
function GetIsAdmin: Boolean;
Description

This is GetIsAdmin, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.RemoveAllTablePasswords Method

InxModifyUser31000.RemoveAllTablePasswords Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
procedure RemoveAllTablePasswords;
Description

This is RemoveAllTablePasswords, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.RemoveTablePassword Method

InxModifyUser31000.RemoveTablePassword Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
procedure RemoveTablePassword(const aAlias: UnicodeString; const aTable: UnicodeString; const aPassword: UnicodeString);
Description

This is RemoveTablePassword, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.SetHasReadAccess Method

InxModifyUser31000.SetHasReadAccess Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
procedure SetHasReadAccess(aValue: Boolean);
Description

This is SetHasReadAccess, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000.SetHasWriteAccess Method

InxModifyUser31000.SetHasWriteAccess Method
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Methods Send Feedback
Syntax
Delphi
procedure SetHasWriteAccess(aValue: Boolean);
Description

This is SetHasWriteAccess, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Methods

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Methods


InxModifyUser31000 Properties

InxModifyUser31000 Properties
InxModifyUser31000 Interface Legend Public Properties Send Feedback

The properties of the InxModifyUser31000 class are listed here.

Interface

InxModifyUser31000 Interface

Public Properties
Name | Description
HasReadAccess | This is HasReadAccess, a member of class InxModifyUser31000.
HasWriteAccess | This is HasWriteAccess, a member of class InxModifyUser31000.
IsAdmin | This is IsAdmin, a member of class InxModifyUser31000.
Links
InxModifyUser31000 Interface, Legend, Public Properties


InxModifyUser31000.HasReadAccess Property

InxModifyUser31000.HasReadAccess Property
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Properties Send Feedback
Syntax
Delphi
property HasReadAccess: Boolean;
Description

This is HasReadAccess, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Properties

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Properties


InxModifyUser31000.HasWriteAccess Property

InxModifyUser31000.HasWriteAccess Property
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Properties Send Feedback
Syntax
Delphi
property HasWriteAccess: Boolean;
Description

This is HasWriteAccess, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Properties

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Properties


InxModifyUser31000.IsAdmin Property

InxModifyUser31000.IsAdmin Property
InxModifyUser31000 Interface InxModifyUser31000 Members nxsdServerEngine Namespace InxModifyUser31000 Properties Send Feedback
Syntax
Delphi
property IsAdmin: Boolean;
Description

This is IsAdmin, a member of class InxModifyUser31000.

Group

InxModifyUser31000 Properties

Links
InxModifyUser31000 Interface, InxModifyUser31000 Members, nxsdServerEngine Namespace, InxModifyUser31000 Properties


InxRemoteTaskInfoCreator Interface

InxRemoteTaskInfoCreator Interface
InxRemoteTaskInfoCreator Methods InxRemoteTaskInfoCreator Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxRemoteTaskInfoCreator
Syntax
Delphi
InxRemoteTaskInfoCreator = interface(InxInterface);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxRemoteTaskInfoCreator.

Group

Interfaces

Links
InxRemoteTaskInfoCreator Methods, InxRemoteTaskInfoCreator Members, nxsdServerEngine, Interfaces


InxRemoteTaskInfoCreator Members

InxRemoteTaskInfoCreator Members
InxRemoteTaskInfoCreator Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxRemoteTaskInfoCreator.

Interface

InxRemoteTaskInfoCreator Interface

Public Methods
Name | Description
CreateRemoteTaskInfo | This is CreateRemoteTaskInfo, a member of class InxRemoteTaskInfoCreator.
Links
InxRemoteTaskInfoCreator Interface, Legend, Public Methods


InxRemoteTaskInfoCreator Methods

InxRemoteTaskInfoCreator Methods
InxRemoteTaskInfoCreator Interface Legend Public Methods Send Feedback

The methods of the InxRemoteTaskInfoCreator class are listed here.

Interface

InxRemoteTaskInfoCreator Interface

Public Methods
Name | Description
CreateRemoteTaskInfo | This is CreateRemoteTaskInfo, a member of class InxRemoteTaskInfoCreator.
Links
InxRemoteTaskInfoCreator Interface, Legend, Public Methods


InxRemoteTaskInfoCreator.CreateRemoteTaskInfo Method

InxRemoteTaskInfoCreator.CreateRemoteTaskInfo Method
InxRemoteTaskInfoCreator Interface InxRemoteTaskInfoCreator Members nxsdServerEngine Namespace InxRemoteTaskInfoCreator Methods Send Feedback
Syntax
Delphi
function CreateRemoteTaskInfo(const aTaskID: TnxTaskID): TnxAbstractTaskInfo;
Description

This is CreateRemoteTaskInfo, a member of class InxRemoteTaskInfoCreator.

Group

InxRemoteTaskInfoCreator Methods

Links
InxRemoteTaskInfoCreator Interface, InxRemoteTaskInfoCreator Members, nxsdServerEngine Namespace, InxRemoteTaskInfoCreator Methods


InxRequestCloseHandler Interface

InxRequestCloseHandler Interface
InxRequestCloseHandler Methods InxRequestCloseHandler Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxRequestCloseHandler
Syntax
Delphi
InxRequestCloseHandler = interface(InxInterface);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxRequestCloseHandler.

Group

Interfaces

Links
InxRequestCloseHandler Methods, InxRequestCloseHandler Members, nxsdServerEngine, Interfaces


InxRequestCloseHandler Members

InxRequestCloseHandler Members
InxRequestCloseHandler Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxRequestCloseHandler.

Interface

InxRequestCloseHandler Interface

Public Methods
Name | Description
RequestClose | This is RequestClose, a member of class InxRequestCloseHandler.
Links
InxRequestCloseHandler Interface, Legend, Public Methods


InxRequestCloseHandler Methods

InxRequestCloseHandler Methods
InxRequestCloseHandler Interface Legend Public Methods Send Feedback

The methods of the InxRequestCloseHandler class are listed here.

Interface

InxRequestCloseHandler Interface

Public Methods
Name | Description
RequestClose | This is RequestClose, a member of class InxRequestCloseHandler.
Links
InxRequestCloseHandler Interface, Legend, Public Methods


InxRequestCloseHandler.RequestClose Method

InxRequestCloseHandler.RequestClose Method
InxRequestCloseHandler Interface InxRequestCloseHandler Members nxsdServerEngine Namespace InxRequestCloseHandler Methods Send Feedback
Syntax
Delphi
procedure RequestClose(Sender: TObject);
Description

This is RequestClose, a member of class InxRequestCloseHandler.

Group

InxRequestCloseHandler Methods

Links
InxRequestCloseHandler Interface, InxRequestCloseHandler Members, nxsdServerEngine Namespace, InxRequestCloseHandler Methods


InxRequestCloseHandlerEvent Interface

InxRequestCloseHandlerEvent Interface
InxRequestCloseHandlerEvent Methods InxRequestCloseHandlerEvent Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxRequestCloseHandlerEventnxsdServerEngine_InxRequestCloseHandlerEvent
Syntax
Delphi
InxRequestCloseHandlerEvent = interface(InxRequestCloseHandler);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxRequestCloseHandlerEvent.

Group

Interfaces

Links
InxRequestCloseHandlerEvent Methods, InxRequestCloseHandlerEvent Members, nxsdServerEngine, Interfaces


InxRequestCloseHandlerEvent Members

InxRequestCloseHandlerEvent Members
InxRequestCloseHandlerEvent Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxRequestCloseHandlerEvent.

Interface

InxRequestCloseHandlerEvent Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxRequestCloseHandlerEvent.
RequestClose | This is RequestClose, a member of class InxRequestCloseHandler.
Links
InxRequestCloseHandlerEvent Interface, Legend, Public Methods


InxRequestCloseHandlerEvent Methods

InxRequestCloseHandlerEvent Methods
InxRequestCloseHandlerEvent Interface Legend Public Methods Send Feedback

The methods of the InxRequestCloseHandlerEvent class are listed here.

Interface

InxRequestCloseHandlerEvent Interface

Public Methods
Name | Description
Disconnect | This is Disconnect, a member of class InxRequestCloseHandlerEvent.
Links
InxRequestCloseHandlerEvent Interface, Legend, Public Methods


InxRequestCloseHandlerEvent.Disconnect Method

InxRequestCloseHandlerEvent.Disconnect Method
InxRequestCloseHandlerEvent Interface InxRequestCloseHandlerEvent Members nxsdServerEngine Namespace InxRequestCloseHandlerEvent Methods Send Feedback
Syntax
Delphi
procedure Disconnect;
Description

This is Disconnect, a member of class InxRequestCloseHandlerEvent.

Group

InxRequestCloseHandlerEvent Methods

Links
InxRequestCloseHandlerEvent Interface, InxRequestCloseHandlerEvent Members, nxsdServerEngine Namespace, InxRequestCloseHandlerEvent Methods


InxSecurityExtender31000 Interface

InxSecurityExtender31000 Interface
InxSecurityExtender31000 Methods InxSecurityExtender31000 Properties InxSecurityExtender31000 Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxSecurityExtender31000
Syntax
Delphi
InxSecurityExtender31000 = interface(InxInvokable);
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxSecurityExtender31000.

Group

Interfaces

Links
InxSecurityExtender31000 Methods, InxSecurityExtender31000 Properties, InxSecurityExtender31000 Members, nxsdServerEngine, Interfaces


InxSecurityExtender31000 Members

InxSecurityExtender31000 Members
InxSecurityExtender31000 Interface Legend Public Methods Public Properties Send Feedback

The following tables list the members exposed by InxSecurityExtender31000.

Interface

InxSecurityExtender31000 Interface

Public Methods
Name | Description
GetLoggedInUser | This is GetLoggedInUser, a member of class InxSecurityExtender31000.
GetSecurityMonitor | This is GetSecurityMonitor, a member of class InxSecurityExtender31000.
Public Properties
Name | Description
LoggedInUser | This is LoggedInUser, a member of class InxSecurityExtender31000.
SecurityMonitor | This is SecurityMonitor, a member of class InxSecurityExtender31000.
Links
InxSecurityExtender31000 Interface, Legend, Public Methods, Public Properties


InxSecurityExtender31000 Methods

InxSecurityExtender31000 Methods
InxSecurityExtender31000 Interface Legend Public Methods Send Feedback

The methods of the InxSecurityExtender31000 class are listed here.

Interface

InxSecurityExtender31000 Interface

Public Methods
Name | Description
GetLoggedInUser | This is GetLoggedInUser, a member of class InxSecurityExtender31000.
GetSecurityMonitor | This is GetSecurityMonitor, a member of class InxSecurityExtender31000.
Links
InxSecurityExtender31000 Interface, Legend, Public Methods


InxSecurityExtender31000.GetLoggedInUser Method

InxSecurityExtender31000.GetLoggedInUser Method
InxSecurityExtender31000 Interface InxSecurityExtender31000 Members nxsdServerEngine Namespace InxSecurityExtender31000 Methods Send Feedback
Syntax
Delphi
function GetLoggedInUser: InxLoggedInUser31000;
Description

This is GetLoggedInUser, a member of class InxSecurityExtender31000.

Group

InxSecurityExtender31000 Methods

Links
InxSecurityExtender31000 Interface, InxSecurityExtender31000 Members, nxsdServerEngine Namespace, InxSecurityExtender31000 Methods


InxSecurityExtender31000.GetSecurityMonitor Method

InxSecurityExtender31000.GetSecurityMonitor Method
InxSecurityExtender31000 Interface InxSecurityExtender31000 Members nxsdServerEngine Namespace InxSecurityExtender31000 Methods Send Feedback
Syntax
Delphi
function GetSecurityMonitor: InxAbstractSecurityMonitorComponentInfo31000;
Description

This is GetSecurityMonitor, a member of class InxSecurityExtender31000.

Group

InxSecurityExtender31000 Methods

Links
InxSecurityExtender31000 Interface, InxSecurityExtender31000 Members, nxsdServerEngine Namespace, InxSecurityExtender31000 Methods


InxSecurityExtender31000 Properties

InxSecurityExtender31000 Properties
InxSecurityExtender31000 Interface Legend Public Properties Send Feedback

The properties of the InxSecurityExtender31000 class are listed here.

Interface

InxSecurityExtender31000 Interface

Public Properties
Name | Description
LoggedInUser | This is LoggedInUser, a member of class InxSecurityExtender31000.
SecurityMonitor | This is SecurityMonitor, a member of class InxSecurityExtender31000.
Links
InxSecurityExtender31000 Interface, Legend, Public Properties


InxSecurityExtender31000.LoggedInUser Property

InxSecurityExtender31000.LoggedInUser Property
InxSecurityExtender31000 Interface InxSecurityExtender31000 Members nxsdServerEngine Namespace InxSecurityExtender31000 Properties Send Feedback
Syntax
Delphi
property LoggedInUser: InxLoggedInUser31000;
Description

This is LoggedInUser, a member of class InxSecurityExtender31000.

Group

InxSecurityExtender31000 Properties

Links
InxSecurityExtender31000 Interface, InxSecurityExtender31000 Members, nxsdServerEngine Namespace, InxSecurityExtender31000 Properties


InxSecurityExtender31000.SecurityMonitor Property

InxSecurityExtender31000.SecurityMonitor Property
InxSecurityExtender31000 Interface InxSecurityExtender31000 Members nxsdServerEngine Namespace InxSecurityExtender31000 Properties Send Feedback
Syntax
Delphi
property SecurityMonitor: InxAbstractSecurityMonitorComponentInfo31000;
Description

This is SecurityMonitor, a member of class InxSecurityExtender31000.

Group

InxSecurityExtender31000 Properties

Links
InxSecurityExtender31000 Interface, InxSecurityExtender31000 Members, nxsdServerEngine Namespace, InxSecurityExtender31000 Properties


InxSimpleLock Interface

InxSimpleLock Interface
InxSimpleLock Methods InxSimpleLock Members nxsdServerEngine Interfaces Send Feedback
Class Hierarchy
nxsdServerEngine_InxSimpleLock
Syntax
Delphi
InxSimpleLock = interface;
File

nxsdServerEngine

Description

This is class nxsdServerEngine.InxSimpleLock.

Group

Interfaces

Links
InxSimpleLock Methods, InxSimpleLock Members, nxsdServerEngine, Interfaces


InxSimpleLock Members

InxSimpleLock Members
InxSimpleLock Interface Legend Public Methods Send Feedback

The following tables list the members exposed by InxSimpleLock.

Interface

InxSimpleLock Interface

Public Methods
Name | Description
Failed | Internally used to coordinate long running operations and lost connections at the transport level... stopping e.g. running SQL statements after a few sec max if the connection is lost.
IsFailedPermanent | This is IsFailedPermanent, a member of class InxSimpleLock.
Lock | Increases the lock count.
SetFailedCleanupDone | This is SetFailedCleanupDone, a member of class InxSimpleLock.
Unlock | Decreases the lock count.
Links
InxSimpleLock Interface, Legend, Public Methods


InxSimpleLock Methods

InxSimpleLock Methods
InxSimpleLock Interface Legend Public Methods Send Feedback

The methods of the InxSimpleLock class are listed here.

Interface

InxSimpleLock Interface

Public Methods
Name | Description
Failed | Internally used to coordinate long running operations and lost connections at the transport level... stopping e.g. running SQL statements after a few sec max if the connection is lost.
IsFailedPermanent | This is IsFailedPermanent, a member of class InxSimpleLock.
Lock | Increases the lock count.
SetFailedCleanupDone | This is SetFailedCleanupDone, a member of class InxSimpleLock.
Unlock | Decreases the lock count.
Links
InxSimpleLock Interface, Legend, Public Methods


InxSimpleLock.Failed Method

InxSimpleLock.Failed Method
InxSimpleLock Interface InxSimpleLock Members nxsdServerEngine Namespace InxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Failed(aPermanent: Boolean; aWait: Boolean);
Description

Internally used to coordinate long running operations and lost connections at the transport level... stopping e.g. running SQL statements after a few sec max if the connection is lost.

Group

InxSimpleLock Methods

Links
InxSimpleLock Interface, InxSimpleLock Members, nxsdServerEngine Namespace, InxSimpleLock Methods


InxSimpleLock.IsFailedPermanent Method

InxSimpleLock.IsFailedPermanent Method
InxSimpleLock Interface InxSimpleLock Members nxsdServerEngine Namespace InxSimpleLock Methods Send Feedback
Syntax
Delphi
function IsFailedPermanent: Boolean;
Description

This is IsFailedPermanent, a member of class InxSimpleLock.

Group

InxSimpleLock Methods

Links
InxSimpleLock Interface, InxSimpleLock Members, nxsdServerEngine Namespace, InxSimpleLock Methods


InxSimpleLock.Lock Method

InxSimpleLock.Lock Method
InxSimpleLock Interface InxSimpleLock Members nxsdServerEngine Namespace InxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Lock;
Description

Increases the lock count.

Group

InxSimpleLock Methods

Links
InxSimpleLock Interface, InxSimpleLock Members, nxsdServerEngine Namespace, InxSimpleLock Methods


InxSimpleLock.SetFailedCleanupDone Method

InxSimpleLock.SetFailedCleanupDone Method
InxSimpleLock Interface InxSimpleLock Members nxsdServerEngine Namespace InxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure SetFailedCleanupDone;
Description

This is SetFailedCleanupDone, a member of class InxSimpleLock.

Group

InxSimpleLock Methods

Links
InxSimpleLock Interface, InxSimpleLock Members, nxsdServerEngine Namespace, InxSimpleLock Methods


InxSimpleLock.Unlock Method

InxSimpleLock.Unlock Method
InxSimpleLock Interface InxSimpleLock Members nxsdServerEngine Namespace InxSimpleLock Methods Send Feedback
Syntax
Delphi
procedure Unlock(var aResult: TnxResult);
Description

Decreases the lock count.

Group

InxSimpleLock Methods

Links
InxSimpleLock Interface, InxSimpleLock Members, nxsdServerEngine Namespace, InxSimpleLock Methods


Functions

Functions
Functions nxsdServerEngine Namespace Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
_DoNothingStub | internal use only
_DoNothingStub2 | internal use only
nxCheckValidAliasName | returns 0 if the given aAliasName is valid
nxCheckValidRelativeTableName | returns 0 if the given aTableName is a valid name for a sub table
nxCheckValidRootTableName | returns 0 if the given aTableName is a valid name for a root table
nxCheckValidStoredProcName | returns 0 if the given aAliasName is valid
nxCheckValidTableName | returns true if the given aTableName is a valid name for a table
nxRequestCloseHandlerEvent |
nxTableNameIsInMem | returns true if the given aTableName is not persistent nxTableNameIsInMem
nxTableNameIsTempDatabase | returns true if the given aTableName is a database specific temp table nxTableNameIsTempDatabase
nxTableNameIsTempGlobal | returns true if the given aTableName is a global temp table nxTableNameIsTempGlobal
nxTableNameIsTempStatement | returns true if the given aTableName is a temp statement nxTableNameIsTempStatement
Namespace

nxsdServerEngine Namespace

Links
Functions, nxsdServerEngine Namespace, Legend


nxsdServerEngine._DoNothingStub Function

nxsdServerEngine._DoNothingStub Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
procedure _DoNothingStub;
File

nxsdServerEngine

Description

internal use only

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine._DoNothingStub2 Function

nxsdServerEngine._DoNothingStub2 Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function _DoNothingStub2: PnxBoolean;
File

nxsdServerEngine

Description

internal use only

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxCheckValidAliasName Function

nxsdServerEngine.nxCheckValidAliasName Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxCheckValidAliasName(const aAliasName: string; aEmptyAsUnknown: Boolean): TnxResult;
File

nxsdServerEngine

Description

returns 0 if the given aAliasName is valid

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxCheckValidRelativeTableName Function

nxsdServerEngine.nxCheckValidRelativeTableName Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxCheckValidRelativeTableName(const aTableName: string): TnxResult;
File

nxsdServerEngine

Description

returns 0 if the given aTableName is a valid name for a sub table

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxCheckValidRootTableName Function

nxsdServerEngine.nxCheckValidRootTableName Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxCheckValidRootTableName(const aTableName: string; aEmptyAsUnknown: Boolean; aAllowSystem: Boolean = False): TnxResult;
File

nxsdServerEngine

Description

returns 0 if the given aTableName is a valid name for a root table

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxCheckValidStoredProcName Function

nxsdServerEngine.nxCheckValidStoredProcName Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxCheckValidStoredProcName(const aStoredProcName: string; aEmptyAsUnknown: Boolean): TnxResult;
File

nxsdServerEngine

Description

returns 0 if the given aAliasName is valid

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxCheckValidTableName Function

nxsdServerEngine.nxCheckValidTableName Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxCheckValidTableName(const aTableName: string; aEmptyAsUnknown: Boolean; aAllowSystem: Boolean = False): TnxResult;
File

nxsdServerEngine

Description

returns true if the given aTableName is a valid name for a table

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxRequestCloseHandlerEvent Function

nxsdServerEngine.nxRequestCloseHandlerEvent Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxRequestCloseHandlerEvent(aEvent: TNotifyEvent): InxRequestCloseHandlerEvent;
File

nxsdServerEngine

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxTableNameIsInMem Function

nxsdServerEngine.nxTableNameIsInMem Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxTableNameIsInMem(const aTableName: string): Boolean;
File

nxsdServerEngine

Description

returns true if the given aTableName is not persistent

nxTableNameIsInMem

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxTableNameIsTempDatabase Function

nxsdServerEngine.nxTableNameIsTempDatabase Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxTableNameIsTempDatabase(const aTableName: string): Boolean;
File

nxsdServerEngine

Description

returns true if the given aTableName is a database specific temp table

nxTableNameIsTempDatabase

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxTableNameIsTempGlobal Function

nxsdServerEngine.nxTableNameIsTempGlobal Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxTableNameIsTempGlobal(const aTableName: string): Boolean;
File

nxsdServerEngine

Description

returns true if the given aTableName is a global temp table

nxTableNameIsTempGlobal

Group

Functions

Links
nxsdServerEngine, Functions


nxsdServerEngine.nxTableNameIsTempStatement Function

nxsdServerEngine.nxTableNameIsTempStatement Function
nxsdServerEngine Functions Send Feedback
Syntax
Delphi
function nxTableNameIsTempStatement(const aTableName: string): Boolean;
File

nxsdServerEngine

Description

returns true if the given aTableName is a temp statement

nxTableNameIsTempStatement

Group

Functions

Links
nxsdServerEngine, Functions


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdServerEngine Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxEngineAction | Action types for Engine based actions. These types are fired and passed on to Extenders.
TnxSessionStatsCounter | This is record nxsdServerEngine.TnxSessionStatsCounter.
TnxStatementExecDirectPhase | The state of the currently executed Statement
TnxTableScope | Scope of a table
Namespace

nxsdServerEngine Namespace

Links
Enumerations, nxsdServerEngine Namespace, Legend


nxsdServerEngine.TnxEngineAction Enumeration

nxsdServerEngine.TnxEngineAction Enumeration
nxsdServerEngine Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxEngineAction = ( eaCreate, eaDestroy, eaChildCreate, eaChildDestroy, eaAliasAdd, eaAliasDelete, eaAliasModify, eaAliasGetList, eaAliasGetPath, eaCloseInactiveFolders, eaCloseInactiveTables, eaBuildPasswords, eaGetRegisteredClassList, eaTransactionStart, eaTransactionCommit, eaTransactionRollback, eaTableBuild, eaTablePack, eaTableBackup, eaTableRebuildIndex, eaTableRestructure, eaTableAddField, eaTableAddIndex, eaTableDropIndex, eaTableRename, eaTableRecover, eaTableVerifyChecksum, eaTableDelete, eaTableEmpty, eaTableExists, eaTableGetDictionary, eaTableGetList, eaGetChangedTables, eaOpenFile, eaOpenFiles, eaRecordGet, eaRecordInsert, eaRecordModify, eaRecordDelete, eaStatementPrepare, eaStatementExec, eaStatementSetParams, eaStatementGetParams );
File

nxsdServerEngine

Members
Members | Description
eaCreate | After
eaDestroy | Before
eaChildCreate | After | Child: TnxExtendableServerObject
eaChildDestroy | Before | | Child: TnxExtendableServerObject
eaAliasAdd | Before | After | Alias, Path : string; Enforce: Boolean
eaAliasDelete | Before | After | Alias : string
eaAliasModify | Before | After | Alias, NewName, NewPath : string; Enforce: Boolean
eaAliasGetList | Before | After | List : TObjectList
eaAliasGetPath | Before | After | Alias : string Path : PString
eaCloseInactiveFolders | Before | After
eaCloseInactiveTables | Before | After
eaBuildPasswords | After | Alias, Table: UnicodeString; aPasswords: PnxUnicodeStrings
eaGetRegisteredClassList | Before | After | ClassListType : TnxClassListType List : TStrings -- database
eaTransactionStart | Before | After | FailSafe, SnapShot : Boolean
eaTransactionCommit | Before | After
eaTransactionRollback | Before | After
eaTableBuild | Before | After | OverWrite : Boolean TableName : string Dictionary : TnxDataDictionary; TableScope : PnxTableScope
eaTablePack | Before | | TableName : string optional TableScope : PnxTableScope
eaTableBackup | Before | | TableName : string TargetDB : TnxAbstractDatabase
eaTableRebuildIndex | Before | | TableName : string IndexID : Integer optional TableScope : PnxTableScope
eaTableRestructure | Before | | TableName : string Dictionary : TnxDataDictionary FieldMap : TStrings optional TableScope : PnxTableScope
eaTableAddField | Before | | TableName : string FieldDesc : TnxFieldDescriptor optional TableScope : PnxTableScope
eaTableAddIndex | Before | | TableName : string IndexDesc : TnxIndexDescriptor IsNewDefault: Boolean optional TableScope : PnxTableScope
eaTableDropIndex | Before | | TableName : string IndexName : string IndexID : Integer optional TableScope : PnxTableScope
eaTableRename | Before | After | OldName : string NewName : string optional TableScope : PnxTableScope
eaTableRecover | Before | | TableName : string
eaTableVerifyChecksum | Before | After | TableName : string Raw : PBoolean ForceRecheck: PBoolean
eaTableDelete | Before | After | TableName : string optional TableScope : PnxTableScope
eaTableEmpty | Before | After | TableName : string optional TableScope : PnxTableScope
eaTableExists | Before | After | TableName : string Exists : PBoolean
eaTableGetDictionary | Before | After | TableName : string Dictionary : TnxDataDictionary
eaTableGetList | Before | After | List : TStrings
eaGetChangedTables | Before | After | Tables : TStrings
eaOpenFile | After | BaseFile : TnxBaseFile
eaOpenFiles | After
eaRecordGet | | After | LockType : TnxLockType Data : PnxByteArray RefNr : TnxInt64 -> only valid server side
eaRecordInsert | Before | After | LockType : TnxLockType Data : PnxByteArray RefNr : TnxInt64 -> only valid after & server side
eaRecordModify | Before | After | NewData : PnxByteArray OldData : PnxByteArray -> nil@client side ReleaseLock : Boolean RefNr : TnxInt64 -> only valid server side
eaRecordDelete | Before | After | OldData : PnxByteArray RefNr : TnxInt64 -> only valid before & server side
eaStatementPrepare | Before | After | StatementType : TnxStatementType QueryText : WideString Stream : TStream
eaStatementExec | Before | After | Cursor : PnxAbstractCursor OpenMode : TnxOpenMode Stream : TStream
eaStatementSetParams | Before | After | Params : PnxSqlParamList (const!) Stream : TStream
eaStatementGetParams | Before | After | Params : PnxSqlParamList (const!) Stream : TStream
Description

Action types for Engine based actions. These types are fired and passed on to Extenders.

Group

Structs, Records, Enums

Links
nxsdServerEngine, Structs, Records, Enums


nxsdServerEngine.TnxSessionStatsCounter Enumeration

nxsdServerEngine.TnxSessionStatsCounter Enumeration
nxsdServerEngine Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSessionStatsCounter = ( sscCalls, sscStatements, sscTime, sscCycles, sscBlocksRead, sscBlocksWritten, sscTransCommit, sscTransRollback, sscTransNestedCommit, sscTransNestedRollback, sscTransDeadlock, sscTransCorrupted );
File

nxsdServerEngine

Description

This is record nxsdServerEngine.TnxSessionStatsCounter.

Group

Structs, Records, Enums

Links
nxsdServerEngine, Structs, Records, Enums


nxsdServerEngine.TnxStatementExecDirectPhase Enumeration

nxsdServerEngine.TnxStatementExecDirectPhase Enumeration
nxsdServerEngine Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStatementExecDirectPhase = ( sedAlloc, sedPrepare, sedSetParams, sedExec, sedGetParams, sedFree );
File

nxsdServerEngine

Members
Members | Description
sedAlloc | Allocating resources
sedPrepare | Preparing
sedSetParams | Setting Parameters
sedExec | Executing
sedGetParams | Getting Parameters
sedFree | Destroying
Description

The state of the currently executed Statement

Group

Structs, Records, Enums

Links
nxsdServerEngine, Structs, Records, Enums


nxsdServerEngine.TnxTableScope Enumeration

nxsdServerEngine.TnxTableScope Enumeration
nxsdServerEngine Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTableScope = ( tsPersistent, tsTempGlobal, tsTempDatabase, tsTempUnnamed );
File

nxsdServerEngine

Members
Members | Description
tsPersistent | Persistent Table
tsTempGlobal | Global Temporary Table
tsTempDatabase | Database based Temporary Table
tsTempUnnamed | Unnamed Table - not visible to clients
Description

Scope of a table

Group

Structs, Records, Enums

Links
nxsdServerEngine, Structs, Records, Enums


Types

Types
nxsdServerEngine Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdServerEngine Namespace

Types
Name | Description
PnxTableScope | This is type nxsdServerEngine.PnxTableScope.
TnxAbstractServerObjectClass | Class definition for Server Objects.
TnxAbstractSessionClass | Class of TnxAbstractSession.
TnxBaseEngineExtenderClass | class definition for Server Extenders
TnxEngineActions | Set of Engine Actions
TnxMappingMethod | Abstract Prototype for MappingMethods
TnxSessionStatsCounters | This is type nxsdServerEngine.TnxSessionStatsCounters.
TQueryThreadCycleTime | This is type nxsdServerEngine.TQueryThreadCycleTime.
Links
nxsdServerEngine Namespace, Types


nxsdServerEngine.PnxTableScope Type

nxsdServerEngine.PnxTableScope Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
PnxTableScope = ^TnxTableScope;
File

nxsdServerEngine

Description

This is type nxsdServerEngine.PnxTableScope.

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxAbstractServerObjectClass Type

nxsdServerEngine.TnxAbstractServerObjectClass Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxAbstractServerObjectClass = class of TnxAbstractServerObject;
File

nxsdServerEngine

Description

Class definition for Server Objects.

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxAbstractSessionClass Type

nxsdServerEngine.TnxAbstractSessionClass Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxAbstractSessionClass = class of TnxAbstractSession;
File

nxsdServerEngine

Description

Class of TnxAbstractSession.

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxBaseEngineExtenderClass Type

nxsdServerEngine.TnxBaseEngineExtenderClass Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxBaseEngineExtenderClass = class of TnxBaseEngineExtender;
File

nxsdServerEngine

Description

class definition for Server Extenders

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxEngineActions Type

nxsdServerEngine.TnxEngineActions Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxEngineActions = set of TnxEngineAction;
File

nxsdServerEngine

Description

Set of Engine Actions

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxMappingMethod Type

nxsdServerEngine.TnxMappingMethod Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxMappingMethod = function (const aSource; var aTarget) : TnxResult of object;
File

nxsdServerEngine

Description

Abstract Prototype for MappingMethods

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TnxSessionStatsCounters Type

nxsdServerEngine.TnxSessionStatsCounters Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TnxSessionStatsCounters = array[TnxSessionStatsCounter] of Int64;
File

nxsdServerEngine

Description

This is type nxsdServerEngine.TnxSessionStatsCounters.

Group

Types

Links
nxsdServerEngine, Types


nxsdServerEngine.TQueryThreadCycleTime Type

nxsdServerEngine.TQueryThreadCycleTime Type
nxsdServerEngine Types Send Feedback
Syntax
Delphi
TQueryThreadCycleTime = function (ThreadHandle: THandle; var CycleTime: UInt64): Boolean;
File

nxsdServerEngine

Description

This is type nxsdServerEngine.TQueryThreadCycleTime.

Group

Types

Links
nxsdServerEngine, Types


Variables

Variables
nxsdServerEngine Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdServerEngine Namespace

Variables
Name | Description
_CounterFrequencey | This is variable nxsdServerEngine._CounterFrequencey.
_QueryThreadCycleTime | This is variable nxsdServerEngine._QueryThreadCycleTime.
_SessionStatsHead | This is variable nxsdServerEngine._SessionStatsHead.
_SessionStatsHeadLock | This is variable nxsdServerEngine._SessionStatsHeadLock.
_SessionStatsNextNumber | This is variable nxsdServerEngine._SessionStatsNextNumber.
nxGetFailedFlag | callback function called to get failure specific flags
nxLockTimeout | callback function called when a locktimeout occurs
nxUnlockTimeout | callback function called when a unlocktimeout occurs
Links
nxsdServerEngine Namespace, Variables


nxsdServerEngine._CounterFrequencey Variable

nxsdServerEngine._CounterFrequencey Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
_CounterFrequencey: Int64;
File

nxsdServerEngine

Description

This is variable nxsdServerEngine._CounterFrequencey.

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine._QueryThreadCycleTime Variable

nxsdServerEngine._QueryThreadCycleTime Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
_QueryThreadCycleTime: TQueryThreadCycleTime;
File

nxsdServerEngine

Description

This is variable nxsdServerEngine._QueryThreadCycleTime.

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine._SessionStatsHead Variable

nxsdServerEngine._SessionStatsHead Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
_SessionStatsHead: TnxSessionStats;
File

nxsdServerEngine

Description

This is variable nxsdServerEngine._SessionStatsHead.

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine._SessionStatsHeadLock Variable

nxsdServerEngine._SessionStatsHeadLock Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
_SessionStatsHeadLock: TnxPadlock;
File

nxsdServerEngine

Description

This is variable nxsdServerEngine._SessionStatsHeadLock.

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine._SessionStatsNextNumber Variable

nxsdServerEngine._SessionStatsNextNumber Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
_SessionStatsNextNumber: Integer;
File

nxsdServerEngine

Description

This is variable nxsdServerEngine._SessionStatsNextNumber.

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine.nxGetFailedFlag Variable

nxsdServerEngine.nxGetFailedFlag Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
nxGetFailedFlag: function : PnxBoolean = _DoNothingStub2;
File

nxsdServerEngine

Description

callback function called to get failure specific flags

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine.nxLockTimeout Variable

nxsdServerEngine.nxLockTimeout Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
nxLockTimeout: procedure = _DoNothingStub;
File

nxsdServerEngine

Description

callback function called when a locktimeout occurs

Group

Variables

Links
nxsdServerEngine, Variables


nxsdServerEngine.nxUnlockTimeout Variable

nxsdServerEngine.nxUnlockTimeout Variable
nxsdServerEngine Variables Send Feedback
Syntax
Delphi
nxUnlockTimeout: procedure = _DoNothingStub;
File

nxsdServerEngine

Description

callback function called when a unlocktimeout occurs

Group

Variables

Links
nxsdServerEngine, Variables


Constants

Constants
Constants nxsdServerEngine Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
CLSID_AbstractDatabase | This is constant nxsdServerEngine.CLSID_AbstractDatabase.
CLSID_AbstractServerObject | This is constant nxsdServerEngine.CLSID_AbstractServerObject.
CLSID_SecurityExtender | This is constant nxsdServerEngine.CLSID_SecurityExtender.
nxatAliasName | Alias Type - Name.
nxatAliasPath | Alias Type - Path.
nxcl_FailedTimeout | This is constant nxsdServerEngine.nxcl_FailedTimeout.
rsFailedPermanent | This is constant nxsdServerEngine.rsFailedPermanent.
rsProcessingCancelled | This is constant nxsdServerEngine.rsProcessingCancelled.
rsProcessingCancelledSuccess | This is constant nxsdServerEngine.rsProcessingCancelledSuccess.
rsRequestNestedTransactionsNotSupported | This is constant nxsdServerEngine.rsRequestNestedTransactionsNotSupported.
TnxBeforeAfterString | This is constant nxsdServerEngine.TnxBeforeAfterString.
TnxEngineActionStrings | This is constant nxsdServerEngine.TnxEngineActionStrings.
Namespace

nxsdServerEngine Namespace

Links
Constants, nxsdServerEngine Namespace


nxsdServerEngine.CLSID_AbstractDatabase Constant

nxsdServerEngine.CLSID_AbstractDatabase Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
CLSID_AbstractDatabase: TGUID = '{5C00AAC9-F6CE-4ECB-BE82-FBED01C2CCE6}';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.CLSID_AbstractDatabase.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.CLSID_AbstractServerObject Constant

nxsdServerEngine.CLSID_AbstractServerObject Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
CLSID_AbstractServerObject: TGUID = '{762A2DA1-44B8-447A-8CCA-74EBEAA4E9F1}';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.CLSID_AbstractServerObject.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.CLSID_SecurityExtender Constant

nxsdServerEngine.CLSID_SecurityExtender Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
CLSID_SecurityExtender: TGUID = '{AB65C05B-90BA-44BC-8D73-09132DE3D55B}';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.CLSID_SecurityExtender.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.nxatAliasName Constant

nxsdServerEngine.nxatAliasName Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
nxatAliasName = 'Name';
File

nxsdServerEngine

Description

Alias Type - Name.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.nxatAliasPath Constant

nxsdServerEngine.nxatAliasPath Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
nxatAliasPath = 'Path';
File

nxsdServerEngine

Description

Alias Type - Path.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.nxcl_FailedTimeout Constant

nxsdServerEngine.nxcl_FailedTimeout Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
nxcl_FailedTimeout = 60000;
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.nxcl_FailedTimeout.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.rsFailedPermanent Constant

nxsdServerEngine.rsFailedPermanent Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
rsFailedPermanent = 'This session has been marked as permanently failed';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.rsFailedPermanent.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.rsProcessingCancelled Constant

nxsdServerEngine.rsProcessingCancelled Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
rsProcessingCancelled = 'Processing cancelled';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.rsProcessingCancelled.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.rsProcessingCancelledSuccess Constant

nxsdServerEngine.rsProcessingCancelledSuccess Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
rsProcessingCancelledSuccess = 'Processing cancelled. Operation may have partially or fully succeeded';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.rsProcessingCancelledSuccess.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.rsRequestNestedTransactionsNotSupported Constant

nxsdServerEngine.rsRequestNestedTransactionsNotSupported Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
rsRequestNestedTransactionsNotSupported = 'RequestNestedTransactions is not supported by %s';
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.rsRequestNestedTransactionsNotSupported.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.TnxBeforeAfterString Constant

nxsdServerEngine.TnxBeforeAfterString Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
TnxBeforeAfterString: array[boolean] of string = ('After', 'Before');
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.TnxBeforeAfterString.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdServerEngine.TnxEngineActionStrings Constant

nxsdServerEngine.TnxEngineActionStrings Constant
nxsdServerEngine Constants Send Feedback
Syntax
Delphi
TnxEngineActionStrings: array[TnxEngineAction] of string = ( 'Create', 'Destroy', 'ChildCreate', 'ChildDestroy', 'AliasAdd', 'AliasDelete', 'AliasModify', 'AliasGetList', 'AliasGetPath', 'CloseInactiveFolders', 'CloseInactiveTables', 'BuildPasswords', 'RegisteredEngines', 'TransactionStart', 'TransactionCommit', 'TransactionRollback', 'TableBuild', 'TablePack', 'TableBackup', 'TableRebuildIndex', 'TableRestructure', 'TableAddField', 'TableAddIndex', 'TableDropIndex', 'TableRename', 'TableRecover', 'TableVerifyChecksum', 'TableDelete', 'TableEmpty', 'TableExists', 'TableGetDictionary', 'TableGetList', 'GetChangedTables', 'OpenFile', 'OpenFiles', 'RecordGet', 'RecordInsert', 'RecordModify', 'RecordDelete', 'StatementPrepare', 'StatementExec', 'StatementSetParams', 'StatementGetParams');
File

nxsdServerEngine

Description

This is constant nxsdServerEngine.TnxEngineActionStrings.

Group

Constants

Links
nxsdServerEngine, Constants


nxsdSimpleMonitor Namespace

nxsdSimpleMonitor Namespace
Classes Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxsdSimpleMonitor.

Classes
Name
Description
TnxCustomSimpleMonitor
This is class nxsdSimpleMonitor.TnxCustomSimpleMonitor.
TnxSimpleMonitor
The SimpleMonitor monitors system events and allows you to:
  • react to them
  • detect if they were successful or not
  • selectively abort the event

To use, place the component on your custom server datamodule, hook the ServerEngine property to the TnxServerEngine on the datamodule, and set AttachTo to include the objects whose events you wish to handle.
There are two ways of hooking the events: either use the catch-all OnAction event, which is called for every event, or use the separate event handlers for each system event type.
TnxSimpleMonitorExtender
Internal helper class for TnxSimpleMonitor
Structs, Records, Enums
Name | Description
TnxAttachTo | This is record nxsdSimpleMonitor.TnxAttachTo.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TnxAttachToSet | This is type nxsdSimpleMonitor.TnxAttachToSet.
TnxeaAliasAdd | This is type nxsdSimpleMonitor.TnxeaAliasAdd.
TnxeaAliasDelete | This is type nxsdSimpleMonitor.TnxeaAliasDelete.
TnxeaAliasGetList | This is type nxsdSimpleMonitor.TnxeaAliasGetList.
TnxeaAliasGetPath | This is type nxsdSimpleMonitor.TnxeaAliasGetPath.
TnxeaAliasModify | This is type nxsdSimpleMonitor.TnxeaAliasModify.
TnxeaCloseInactiveFolders | This is type nxsdSimpleMonitor.TnxeaCloseInactiveFolders.
TnxeaCloseInactiveTables | This is type nxsdSimpleMonitor.TnxeaCloseInactiveTables.
TnxeaCreate | HPPEMIT '#define _ARRAYOF /**/' HPPEMIT 'namespace Nxsdsimplemonitor' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxSimpleMonitorExtender;' HPPEMIT 'typedef void __fastcall (__closure *TnxExtenderAction)(TnxSimpleMonitorExtender* aExtender, Nxsdserverengine::TnxEngineAction aAction, bool aBefore, const System::TVarRec * aArgs, const int aArgs_Size,const int dummy);' HPPEMIT '} /* namespace Nxsdsimplemonitor */'
TnxeaDestroy | This is type nxsdSimpleMonitor.TnxeaDestroy.
TnxeaGetRegisteredClassList | This is type nxsdSimpleMonitor.TnxeaGetRegisteredClassList.
TnxeaRecordDelete | This is type nxsdSimpleMonitor.TnxeaRecordDelete.
TnxeaRecordGet | This is type nxsdSimpleMonitor.TnxeaRecordGet.
TnxeaRecordInsert | This is type nxsdSimpleMonitor.TnxeaRecordInsert.
TnxeaRecordModify | This is type nxsdSimpleMonitor.TnxeaRecordModify.
TnxeaTableAddIndex | This is type nxsdSimpleMonitor.TnxeaTableAddIndex.
TnxeaTableBuild | This is type nxsdSimpleMonitor.TnxeaTableBuild.
TnxeaTableDelete | This is type nxsdSimpleMonitor.TnxeaTableDelete.
TnxeaTableDropIndex | This is type nxsdSimpleMonitor.TnxeaTableDropIndex.
TnxeaTableEmpty | This is type nxsdSimpleMonitor.TnxeaTableEmpty.
TnxeaTableExists | This is type nxsdSimpleMonitor.TnxeaTableExists.
TnxeaTableGetDictionary | This is type nxsdSimpleMonitor.TnxeaTableGetDictionary.
TnxeaTableGetList | This is type nxsdSimpleMonitor.TnxeaTableGetList.
TnxeaTablePack | This is type nxsdSimpleMonitor.TnxeaTablePack.
TnxeaTableRebuildIndex | This is type nxsdSimpleMonitor.TnxeaTableRebuildIndex.
TnxeaTableRecover | This is type nxsdSimpleMonitor.TnxeaTableRecover.
TnxeaTableRename | This is type nxsdSimpleMonitor.TnxeaTableRename.
TnxeaTableRestructure | This is type nxsdSimpleMonitor.TnxeaTableRestructure.
TnxeaTransactionCommit | This is type nxsdSimpleMonitor.TnxeaTransactionCommit.
TnxeaTransactionRollback | This is type nxsdSimpleMonitor.TnxeaTransactionRollback.
TnxeaTransactionStart | This is type nxsdSimpleMonitor.TnxeaTransactionStart.
TnxExtenderAction | econs4 BCB support - 10-Feb-2005
Links
Classes, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxsdSimpleMonitor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name
Description
TnxCustomSimpleMonitor
This is class nxsdSimpleMonitor.TnxCustomSimpleMonitor.
TnxSimpleMonitor
The SimpleMonitor monitors system events and allows you to:
  • react to them
  • detect if they were successful or not
  • selectively abort the event

To use, place the component on your custom server datamodule, hook the ServerEngine property to the TnxServerEngine on the datamodule, and set AttachTo to include the objects whose events you wish to handle.
There are two ways of hooking the events: either use the catch-all OnAction event, which is called for every event, or use the separate event handlers for each system event type.
TnxSimpleMonitorExtender
Internal helper class for TnxSimpleMonitor
Namespace

nxsdSimpleMonitor Namespace

Links
Classes, nxsdSimpleMonitor Namespace, Legend


TnxCustomSimpleMonitor Class

TnxCustomSimpleMonitor Class
TnxCustomSimpleMonitor Fields TnxCustomSimpleMonitor Methods TnxCustomSimpleMonitor Properties TnxCustomSimpleMonitor Events TnxCustomSimpleMonitor Members nxsdSimpleMonitor Classes Send Feedback
Class Hierarchy
nxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitornxsdSimpleMonitor_TnxCustomSimpleMonitor
Syntax
Delphi
TnxCustomSimpleMonitor = class(TnxBaseEngineMonitor);
File

nxsdSimpleMonitor

Description

This is class nxsdSimpleMonitor.TnxCustomSimpleMonitor.

Group

Classes

Links
TnxCustomSimpleMonitor Fields, TnxCustomSimpleMonitor Methods, TnxCustomSimpleMonitor Properties, TnxCustomSimpleMonitor Events, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor, Classes


TnxCustomSimpleMonitor Members

TnxCustomSimpleMonitor Members
TnxCustomSimpleMonitor Class Legend Protected Events Protected Fields Protected Methods Protected Properties Public Methods Public Properties Published Properties Send Feedback

The following tables list the members exposed by TnxCustomSimpleMonitor.

Class

TnxCustomSimpleMonitor Class

Protected Events
Name | Description
OnAction | This is OnAction, a member of class TnxCustomSimpleMonitor.
OnAliasAdd | This is OnAliasAdd, a member of class TnxCustomSimpleMonitor.
OnAliasDelete | This is OnAliasDelete, a member of class TnxCustomSimpleMonitor.
OnAliasGetList | This is OnAliasGetList, a member of class TnxCustomSimpleMonitor.
OnAliasGetPath | This is OnAliasGetPath, a member of class TnxCustomSimpleMonitor.
OnAliasModify | This is OnAliasModify, a member of class TnxCustomSimpleMonitor.
OnCloseInactiveFolders | This is OnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.
OnCloseInactiveTables | This is OnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.
OnCreate | This is OnCreate, a member of class TnxCustomSimpleMonitor.
OnDestroy | This is OnDestroy, a member of class TnxCustomSimpleMonitor.
OnGetRegisteredClassList | This is OnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.
OnRecordDelete | This is OnRecordDelete, a member of class TnxCustomSimpleMonitor.
OnRecordGet | This is OnRecordGet, a member of class TnxCustomSimpleMonitor.
OnRecordInsert | This is OnRecordInsert, a member of class TnxCustomSimpleMonitor.
OnRecordModify | This is OnRecordModify, a member of class TnxCustomSimpleMonitor.
OnTableAddIndex | This is OnTableAddIndex, a member of class TnxCustomSimpleMonitor.
OnTableBuild | This is OnTableBuild, a member of class TnxCustomSimpleMonitor.
OnTableDelete | This is OnTableDelete, a member of class TnxCustomSimpleMonitor.
OnTableDropIndex | This is OnTableDropIndex, a member of class TnxCustomSimpleMonitor.
OnTableEmpty | This is OnTableEmpty, a member of class TnxCustomSimpleMonitor.
OnTableExists | This is OnTableExists, a member of class TnxCustomSimpleMonitor.
OnTableGetDictionary | This is OnTableGetDictionary, a member of class TnxCustomSimpleMonitor.
OnTableGetList | This is OnTableGetList, a member of class TnxCustomSimpleMonitor.
OnTablePack | This is OnTablePack, a member of class TnxCustomSimpleMonitor.
OnTableRebuildIndex | This is OnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.
OnTableRecover | This is OnTableRecover, a member of class TnxCustomSimpleMonitor.
OnTableRename | This is OnTableRename, a member of class TnxCustomSimpleMonitor.
OnTableRestructure | This is OnTableRestructure, a member of class TnxCustomSimpleMonitor.
OnTransactionCommit | This is OnTransactionCommit, a member of class TnxCustomSimpleMonitor.
OnTransactionRollback | This is OnTransactionRollback, a member of class TnxCustomSimpleMonitor.
OnTransactionStart | This is OnTransactionStart, a member of class TnxCustomSimpleMonitor.
Protected Fields
Name | Description
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
csmAttachTo | private
csmOnAction | This is csmOnAction, a member of class TnxCustomSimpleMonitor.
csmOnAliasAdd | This is csmOnAliasAdd, a member of class TnxCustomSimpleMonitor.
csmOnAliasDelete | This is csmOnAliasDelete, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetList | This is csmOnAliasGetList, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetPath | This is csmOnAliasGetPath, a member of class TnxCustomSimpleMonitor.
csmOnAliasModify | This is csmOnAliasModify, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveFolders | This is csmOnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveTables | This is csmOnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.
csmOnCreate | This is csmOnCreate, a member of class TnxCustomSimpleMonitor.
csmOnDestroy | This is csmOnDestroy, a member of class TnxCustomSimpleMonitor.
csmOnGetRegisteredClassList | This is csmOnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.
csmOnRecordDelete | This is csmOnRecordDelete, a member of class TnxCustomSimpleMonitor.
csmOnRecordGet | This is csmOnRecordGet, a member of class TnxCustomSimpleMonitor.
csmOnRecordInsert | This is csmOnRecordInsert, a member of class TnxCustomSimpleMonitor.
csmOnRecordModify | This is csmOnRecordModify, a member of class TnxCustomSimpleMonitor.
csmOnTableAddIndex | This is csmOnTableAddIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableBuild | This is csmOnTableBuild, a member of class TnxCustomSimpleMonitor.
csmOnTableDelete | This is csmOnTableDelete, a member of class TnxCustomSimpleMonitor.
csmOnTableDropIndex | This is csmOnTableDropIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableEmpty | This is csmOnTableEmpty, a member of class TnxCustomSimpleMonitor.
csmOnTableExists | This is csmOnTableExists, a member of class TnxCustomSimpleMonitor.
csmOnTableGetDictionary | This is csmOnTableGetDictionary, a member of class TnxCustomSimpleMonitor.
csmOnTableGetList | This is csmOnTableGetList, a member of class TnxCustomSimpleMonitor.
csmOnTablePack | This is csmOnTablePack, a member of class TnxCustomSimpleMonitor.
csmOnTableRebuildIndex | This is csmOnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableRecover | This is csmOnTableRecover, a member of class TnxCustomSimpleMonitor.
csmOnTableRename | This is csmOnTableRename, a member of class TnxCustomSimpleMonitor.
csmOnTableRestructure | This is csmOnTableRestructure, a member of class TnxCustomSimpleMonitor.
csmOnTransactionCommit | This is csmOnTransactionCommit, a member of class TnxCustomSimpleMonitor.
csmOnTransactionRollback | This is csmOnTransactionRollback, a member of class TnxCustomSimpleMonitor.
csmOnTransactionStart | This is csmOnTransactionStart, a member of class TnxCustomSimpleMonitor.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bemSetServerEngine |
DoNotification | TnxCustomSimpleMonitor
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Protected Properties
Name | Description
AttachTo | This is AttachTo, a member of class TnxCustomSimpleMonitor.
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
Destroy | denstructor
Destroy | destructor
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
ExtendableObjectCreated |
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | This property links the Monitor to a server engine.
Version | Version of the component.
Links
TnxCustomSimpleMonitor Class, Legend, Protected Events, Protected Fields, Protected Methods, Protected Properties, Public Methods, Public Properties, Published Properties


TnxCustomSimpleMonitor Fields

TnxCustomSimpleMonitor Fields
TnxCustomSimpleMonitor Class Legend Protected Fields Send Feedback

The fields of the TnxCustomSimpleMonitor class are listed here.

Class

TnxCustomSimpleMonitor Class

Protected Fields
Name | Description
csmAttachTo | private
csmOnAction | This is csmOnAction, a member of class TnxCustomSimpleMonitor.
csmOnAliasAdd | This is csmOnAliasAdd, a member of class TnxCustomSimpleMonitor.
csmOnAliasDelete | This is csmOnAliasDelete, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetList | This is csmOnAliasGetList, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetPath | This is csmOnAliasGetPath, a member of class TnxCustomSimpleMonitor.
csmOnAliasModify | This is csmOnAliasModify, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveFolders | This is csmOnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveTables | This is csmOnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.
csmOnCreate | This is csmOnCreate, a member of class TnxCustomSimpleMonitor.
csmOnDestroy | This is csmOnDestroy, a member of class TnxCustomSimpleMonitor.
csmOnGetRegisteredClassList | This is csmOnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.
csmOnRecordDelete | This is csmOnRecordDelete, a member of class TnxCustomSimpleMonitor.
csmOnRecordGet | This is csmOnRecordGet, a member of class TnxCustomSimpleMonitor.
csmOnRecordInsert | This is csmOnRecordInsert, a member of class TnxCustomSimpleMonitor.
csmOnRecordModify | This is csmOnRecordModify, a member of class TnxCustomSimpleMonitor.
csmOnTableAddIndex | This is csmOnTableAddIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableBuild | This is csmOnTableBuild, a member of class TnxCustomSimpleMonitor.
csmOnTableDelete | This is csmOnTableDelete, a member of class TnxCustomSimpleMonitor.
csmOnTableDropIndex | This is csmOnTableDropIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableEmpty | This is csmOnTableEmpty, a member of class TnxCustomSimpleMonitor.
csmOnTableExists | This is csmOnTableExists, a member of class TnxCustomSimpleMonitor.
csmOnTableGetDictionary | This is csmOnTableGetDictionary, a member of class TnxCustomSimpleMonitor.
csmOnTableGetList | This is csmOnTableGetList, a member of class TnxCustomSimpleMonitor.
csmOnTablePack | This is csmOnTablePack, a member of class TnxCustomSimpleMonitor.
csmOnTableRebuildIndex | This is csmOnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableRecover | This is csmOnTableRecover, a member of class TnxCustomSimpleMonitor.
csmOnTableRename | This is csmOnTableRename, a member of class TnxCustomSimpleMonitor.
csmOnTableRestructure | This is csmOnTableRestructure, a member of class TnxCustomSimpleMonitor.
csmOnTransactionCommit | This is csmOnTransactionCommit, a member of class TnxCustomSimpleMonitor.
csmOnTransactionRollback | This is csmOnTransactionRollback, a member of class TnxCustomSimpleMonitor.
csmOnTransactionStart | This is csmOnTransactionStart, a member of class TnxCustomSimpleMonitor.
Links
TnxCustomSimpleMonitor Class, Legend, Protected Fields


TnxCustomSimpleMonitor.csmAttachTo Field

TnxCustomSimpleMonitor.csmAttachTo Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmAttachTo: TnxAttachToSet;
Description

private

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAction Field

TnxCustomSimpleMonitor.csmOnAction Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAction: TnxExtenderAction;
Description

This is csmOnAction, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAliasAdd Field

TnxCustomSimpleMonitor.csmOnAliasAdd Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAliasAdd: TnxeaAliasAdd;
Description

This is csmOnAliasAdd, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAliasDelete Field

TnxCustomSimpleMonitor.csmOnAliasDelete Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAliasDelete: TnxeaAliasDelete;
Description

This is csmOnAliasDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAliasGetList Field

TnxCustomSimpleMonitor.csmOnAliasGetList Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAliasGetList: TnxeaAliasGetList;
Description

This is csmOnAliasGetList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAliasGetPath Field

TnxCustomSimpleMonitor.csmOnAliasGetPath Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAliasGetPath: TnxeaAliasGetPath;
Description

This is csmOnAliasGetPath, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnAliasModify Field

TnxCustomSimpleMonitor.csmOnAliasModify Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnAliasModify: TnxeaAliasModify;
Description

This is csmOnAliasModify, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnCloseInactiveFolders Field

TnxCustomSimpleMonitor.csmOnCloseInactiveFolders Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnCloseInactiveFolders: TnxeaCloseInactiveFolders;
Description

This is csmOnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnCloseInactiveTables Field

TnxCustomSimpleMonitor.csmOnCloseInactiveTables Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnCloseInactiveTables: TnxeaCloseInactiveTables;
Description

This is csmOnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnCreate Field

TnxCustomSimpleMonitor.csmOnCreate Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnCreate: TnxeaCreate;
Description

This is csmOnCreate, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnDestroy Field

TnxCustomSimpleMonitor.csmOnDestroy Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnDestroy: TnxeaDestroy;
Description

This is csmOnDestroy, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnGetRegisteredClassList Field

TnxCustomSimpleMonitor.csmOnGetRegisteredClassList Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnGetRegisteredClassList: TnxeaGetRegisteredClassList;
Description

This is csmOnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnRecordDelete Field

TnxCustomSimpleMonitor.csmOnRecordDelete Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnRecordDelete: TnxeaRecordDelete;
Description

This is csmOnRecordDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnRecordGet Field

TnxCustomSimpleMonitor.csmOnRecordGet Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnRecordGet: TnxeaRecordGet;
Description

This is csmOnRecordGet, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnRecordInsert Field

TnxCustomSimpleMonitor.csmOnRecordInsert Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnRecordInsert: TnxeaRecordInsert;
Description

This is csmOnRecordInsert, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnRecordModify Field

TnxCustomSimpleMonitor.csmOnRecordModify Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnRecordModify: TnxeaRecordModify;
Description

This is csmOnRecordModify, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableAddIndex Field

TnxCustomSimpleMonitor.csmOnTableAddIndex Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableAddIndex: TnxeaTableAddIndex;
Description

This is csmOnTableAddIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableBuild Field

TnxCustomSimpleMonitor.csmOnTableBuild Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableBuild: TnxeaTableBuild;
Description

This is csmOnTableBuild, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableDelete Field

TnxCustomSimpleMonitor.csmOnTableDelete Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableDelete: TnxeaTableDelete;
Description

This is csmOnTableDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableDropIndex Field

TnxCustomSimpleMonitor.csmOnTableDropIndex Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableDropIndex: TnxeaTableDropIndex;
Description

This is csmOnTableDropIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableEmpty Field

TnxCustomSimpleMonitor.csmOnTableEmpty Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableEmpty: TnxeaTableEmpty;
Description

This is csmOnTableEmpty, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableExists Field

TnxCustomSimpleMonitor.csmOnTableExists Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableExists: TnxeaTableExists;
Description

This is csmOnTableExists, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableGetDictionary Field

TnxCustomSimpleMonitor.csmOnTableGetDictionary Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableGetDictionary: TnxeaTableGetDictionary;
Description

This is csmOnTableGetDictionary, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableGetList Field

TnxCustomSimpleMonitor.csmOnTableGetList Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableGetList: TnxeaTableGetList;
Description

This is csmOnTableGetList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTablePack Field

TnxCustomSimpleMonitor.csmOnTablePack Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTablePack: TnxeaTablePack;
Description

This is csmOnTablePack, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableRebuildIndex Field

TnxCustomSimpleMonitor.csmOnTableRebuildIndex Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableRebuildIndex: TnxeaTableRebuildIndex;
Description

This is csmOnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableRecover Field

TnxCustomSimpleMonitor.csmOnTableRecover Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableRecover: TnxeaTableRecover;
Description

This is csmOnTableRecover, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableRename Field

TnxCustomSimpleMonitor.csmOnTableRename Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableRename: TnxeaTableRename;
Description

This is csmOnTableRename, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTableRestructure Field

TnxCustomSimpleMonitor.csmOnTableRestructure Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTableRestructure: TnxeaTableRestructure;
Description

This is csmOnTableRestructure, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTransactionCommit Field

TnxCustomSimpleMonitor.csmOnTransactionCommit Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTransactionCommit: TnxeaTransactionCommit;
Description

This is csmOnTransactionCommit, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTransactionRollback Field

TnxCustomSimpleMonitor.csmOnTransactionRollback Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTransactionRollback: TnxeaTransactionRollback;
Description

This is csmOnTransactionRollback, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor.csmOnTransactionStart Field

TnxCustomSimpleMonitor.csmOnTransactionStart Field
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Fields Send Feedback
Syntax
Delphi
csmOnTransactionStart: TnxeaTransactionStart;
Description

This is csmOnTransactionStart, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Fields

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Fields


TnxCustomSimpleMonitor Methods

TnxCustomSimpleMonitor Methods
TnxCustomSimpleMonitor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxCustomSimpleMonitor class are listed here.

Class

TnxCustomSimpleMonitor Class

Protected Methods
Name | Description
DoNotification | TnxCustomSimpleMonitor
Public Methods
Name | Description
ExtendableObjectCreated |
Links
TnxCustomSimpleMonitor Class, Legend, Protected Methods, Public Methods


TnxCustomSimpleMonitor.DoNotification Method

TnxCustomSimpleMonitor.DoNotification Method
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Methods Send Feedback
Syntax
Delphi
function DoNotification(aExtender: TnxSimpleMonitorExtender; aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult;
Description

TnxCustomSimpleMonitor

Group

TnxCustomSimpleMonitor Methods

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Methods


TnxCustomSimpleMonitor.ExtendableObjectCreated Method

TnxCustomSimpleMonitor.ExtendableObjectCreated Method
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Methods Send Feedback
Syntax
Delphi
procedure ExtendableObjectCreated(aExtendableObject: TnxExtendableServerObject); override;
Group

TnxCustomSimpleMonitor Methods

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Methods


TnxCustomSimpleMonitor Properties

TnxCustomSimpleMonitor Properties
TnxCustomSimpleMonitor Class Legend Protected Properties Send Feedback

The properties of the TnxCustomSimpleMonitor class are listed here.

Class

TnxCustomSimpleMonitor Class

Protected Properties
Name | Description
AttachTo | This is AttachTo, a member of class TnxCustomSimpleMonitor.
Links
TnxCustomSimpleMonitor Class, Legend, Protected Properties


TnxCustomSimpleMonitor.AttachTo Property

TnxCustomSimpleMonitor.AttachTo Property
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Properties Send Feedback
Syntax
Delphi
property AttachTo: TnxAttachToSet;
Description

This is AttachTo, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Properties

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Properties


TnxCustomSimpleMonitor Events

TnxCustomSimpleMonitor Events
TnxCustomSimpleMonitor Class Legend Protected Events Send Feedback

The events of the TnxCustomSimpleMonitor class are listed here.

Class

TnxCustomSimpleMonitor Class

Protected Events
Name | Description
OnAction | This is OnAction, a member of class TnxCustomSimpleMonitor.
OnAliasAdd | This is OnAliasAdd, a member of class TnxCustomSimpleMonitor.
OnAliasDelete | This is OnAliasDelete, a member of class TnxCustomSimpleMonitor.
OnAliasGetList | This is OnAliasGetList, a member of class TnxCustomSimpleMonitor.
OnAliasGetPath | This is OnAliasGetPath, a member of class TnxCustomSimpleMonitor.
OnAliasModify | This is OnAliasModify, a member of class TnxCustomSimpleMonitor.
OnCloseInactiveFolders | This is OnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.
OnCloseInactiveTables | This is OnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.
OnCreate | This is OnCreate, a member of class TnxCustomSimpleMonitor.
OnDestroy | This is OnDestroy, a member of class TnxCustomSimpleMonitor.
OnGetRegisteredClassList | This is OnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.
OnRecordDelete | This is OnRecordDelete, a member of class TnxCustomSimpleMonitor.
OnRecordGet | This is OnRecordGet, a member of class TnxCustomSimpleMonitor.
OnRecordInsert | This is OnRecordInsert, a member of class TnxCustomSimpleMonitor.
OnRecordModify | This is OnRecordModify, a member of class TnxCustomSimpleMonitor.
OnTableAddIndex | This is OnTableAddIndex, a member of class TnxCustomSimpleMonitor.
OnTableBuild | This is OnTableBuild, a member of class TnxCustomSimpleMonitor.
OnTableDelete | This is OnTableDelete, a member of class TnxCustomSimpleMonitor.
OnTableDropIndex | This is OnTableDropIndex, a member of class TnxCustomSimpleMonitor.
OnTableEmpty | This is OnTableEmpty, a member of class TnxCustomSimpleMonitor.
OnTableExists | This is OnTableExists, a member of class TnxCustomSimpleMonitor.
OnTableGetDictionary | This is OnTableGetDictionary, a member of class TnxCustomSimpleMonitor.
OnTableGetList | This is OnTableGetList, a member of class TnxCustomSimpleMonitor.
OnTablePack | This is OnTablePack, a member of class TnxCustomSimpleMonitor.
OnTableRebuildIndex | This is OnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.
OnTableRecover | This is OnTableRecover, a member of class TnxCustomSimpleMonitor.
OnTableRename | This is OnTableRename, a member of class TnxCustomSimpleMonitor.
OnTableRestructure | This is OnTableRestructure, a member of class TnxCustomSimpleMonitor.
OnTransactionCommit | This is OnTransactionCommit, a member of class TnxCustomSimpleMonitor.
OnTransactionRollback | This is OnTransactionRollback, a member of class TnxCustomSimpleMonitor.
OnTransactionStart | This is OnTransactionStart, a member of class TnxCustomSimpleMonitor.
Links
TnxCustomSimpleMonitor Class, Legend, Protected Events


TnxCustomSimpleMonitor.OnAction Event

TnxCustomSimpleMonitor.OnAction Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAction: TnxExtenderAction;
Description

This is OnAction, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnAliasAdd Event

TnxCustomSimpleMonitor.OnAliasAdd Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasAdd: TnxeaAliasAdd;
Description

This is OnAliasAdd, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnAliasDelete Event

TnxCustomSimpleMonitor.OnAliasDelete Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasDelete: TnxeaAliasDelete;
Description

This is OnAliasDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnAliasGetList Event

TnxCustomSimpleMonitor.OnAliasGetList Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasGetList: TnxeaAliasGetList;
Description

This is OnAliasGetList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnAliasGetPath Event

TnxCustomSimpleMonitor.OnAliasGetPath Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasGetPath: TnxeaAliasGetPath;
Description

This is OnAliasGetPath, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnAliasModify Event

TnxCustomSimpleMonitor.OnAliasModify Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasModify: TnxeaAliasModify;
Description

This is OnAliasModify, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnCloseInactiveFolders Event

TnxCustomSimpleMonitor.OnCloseInactiveFolders Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCloseInactiveFolders: TnxeaCloseInactiveFolders;
Description

This is OnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnCloseInactiveTables Event

TnxCustomSimpleMonitor.OnCloseInactiveTables Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCloseInactiveTables: TnxeaCloseInactiveTables;
Description

This is OnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnCreate Event

TnxCustomSimpleMonitor.OnCreate Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCreate: TnxeaCreate;
Description

This is OnCreate, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnDestroy Event

TnxCustomSimpleMonitor.OnDestroy Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnDestroy: TnxeaDestroy;
Description

This is OnDestroy, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnGetRegisteredClassList Event

TnxCustomSimpleMonitor.OnGetRegisteredClassList Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnGetRegisteredClassList: TnxeaGetRegisteredClassList;
Description

This is OnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnRecordDelete Event

TnxCustomSimpleMonitor.OnRecordDelete Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordDelete: TnxeaRecordDelete;
Description

This is OnRecordDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnRecordGet Event

TnxCustomSimpleMonitor.OnRecordGet Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordGet: TnxeaRecordGet;
Description

This is OnRecordGet, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnRecordInsert Event

TnxCustomSimpleMonitor.OnRecordInsert Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordInsert: TnxeaRecordInsert;
Description

This is OnRecordInsert, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnRecordModify Event

TnxCustomSimpleMonitor.OnRecordModify Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordModify: TnxeaRecordModify;
Description

This is OnRecordModify, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableAddIndex Event

TnxCustomSimpleMonitor.OnTableAddIndex Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableAddIndex: TnxeaTableAddIndex;
Description

This is OnTableAddIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableBuild Event

TnxCustomSimpleMonitor.OnTableBuild Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableBuild: TnxeaTableBuild;
Description

This is OnTableBuild, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableDelete Event

TnxCustomSimpleMonitor.OnTableDelete Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableDelete: TnxeaTableDelete;
Description

This is OnTableDelete, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableDropIndex Event

TnxCustomSimpleMonitor.OnTableDropIndex Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableDropIndex: TnxeaTableDropIndex;
Description

This is OnTableDropIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableEmpty Event

TnxCustomSimpleMonitor.OnTableEmpty Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableEmpty: TnxeaTableEmpty;
Description

This is OnTableEmpty, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableExists Event

TnxCustomSimpleMonitor.OnTableExists Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableExists: TnxeaTableExists;
Description

This is OnTableExists, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableGetDictionary Event

TnxCustomSimpleMonitor.OnTableGetDictionary Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableGetDictionary: TnxeaTableGetDictionary;
Description

This is OnTableGetDictionary, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableGetList Event

TnxCustomSimpleMonitor.OnTableGetList Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableGetList: TnxeaTableGetList;
Description

This is OnTableGetList, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTablePack Event

TnxCustomSimpleMonitor.OnTablePack Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTablePack: TnxeaTablePack;
Description

This is OnTablePack, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableRebuildIndex Event

TnxCustomSimpleMonitor.OnTableRebuildIndex Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRebuildIndex: TnxeaTableRebuildIndex;
Description

This is OnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableRecover Event

TnxCustomSimpleMonitor.OnTableRecover Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRecover: TnxeaTableRecover;
Description

This is OnTableRecover, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableRename Event

TnxCustomSimpleMonitor.OnTableRename Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRename: TnxeaTableRename;
Description

This is OnTableRename, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTableRestructure Event

TnxCustomSimpleMonitor.OnTableRestructure Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRestructure: TnxeaTableRestructure;
Description

This is OnTableRestructure, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTransactionCommit Event

TnxCustomSimpleMonitor.OnTransactionCommit Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionCommit: TnxeaTransactionCommit;
Description

This is OnTransactionCommit, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTransactionRollback Event

TnxCustomSimpleMonitor.OnTransactionRollback Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionRollback: TnxeaTransactionRollback;
Description

This is OnTransactionRollback, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxCustomSimpleMonitor.OnTransactionStart Event

TnxCustomSimpleMonitor.OnTransactionStart Event
TnxCustomSimpleMonitor Class TnxCustomSimpleMonitor Members nxsdSimpleMonitor Namespace TnxCustomSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionStart: TnxeaTransactionStart;
Description

This is OnTransactionStart, a member of class TnxCustomSimpleMonitor.

Group

TnxCustomSimpleMonitor Events

Links
TnxCustomSimpleMonitor Class, TnxCustomSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxCustomSimpleMonitor Events


TnxSimpleMonitor Class

TnxSimpleMonitor Class
TnxSimpleMonitor Properties TnxSimpleMonitor Events TnxSimpleMonitor Members nxsdSimpleMonitor Classes See Also Send Feedback
Class Hierarchy
nxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitornxsdSimpleMonitor_TnxSimpleMonitor
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxSimpleMonitor = class(TnxCustomSimpleMonitor);
File

nxsdSimpleMonitor

Description

The SimpleMonitor monitors system events and allows you to:

  • react to them
  • detect if they were successful or not
  • selectively abort the event

To use, place the component on your custom server datamodule, hook the ServerEngine property to the TnxServerEngine on the datamodule, and set AttachTo to include the objects whose events you wish to handle.

There are two ways of hooking the events: either use the catch-all OnAction event, which is called for every event, or use the separate event handlers for each system event type.

See Also

AttachTo, TnxServerEngine, OnAction

Group

Classes

Links
TnxSimpleMonitor Properties, TnxSimpleMonitor Events, TnxSimpleMonitor Members, nxsdSimpleMonitor, Classes, See Also


TnxSimpleMonitor Members

TnxSimpleMonitor Members
TnxSimpleMonitor Class Legend Protected Fields Protected Methods Public Methods Public Properties Published Events Published Properties Send Feedback

The following tables list the members exposed by TnxSimpleMonitor.

Class

TnxSimpleMonitor Class

Protected Fields
Name | Description
bemExtendersHead | This is bemExtendersHead, a member of class TnxBaseEngineMonitor.
bemExtendersLock | This is bemExtendersLock, a member of class TnxBaseEngineMonitor.
bemExtendersTail | This is bemExtendersTail, a member of class TnxBaseEngineMonitor.
bemServerEngine | private
csmAttachTo | private
csmOnAction | This is csmOnAction, a member of class TnxCustomSimpleMonitor.
csmOnAliasAdd | This is csmOnAliasAdd, a member of class TnxCustomSimpleMonitor.
csmOnAliasDelete | This is csmOnAliasDelete, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetList | This is csmOnAliasGetList, a member of class TnxCustomSimpleMonitor.
csmOnAliasGetPath | This is csmOnAliasGetPath, a member of class TnxCustomSimpleMonitor.
csmOnAliasModify | This is csmOnAliasModify, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveFolders | This is csmOnCloseInactiveFolders, a member of class TnxCustomSimpleMonitor.
csmOnCloseInactiveTables | This is csmOnCloseInactiveTables, a member of class TnxCustomSimpleMonitor.
csmOnCreate | This is csmOnCreate, a member of class TnxCustomSimpleMonitor.
csmOnDestroy | This is csmOnDestroy, a member of class TnxCustomSimpleMonitor.
csmOnGetRegisteredClassList | This is csmOnGetRegisteredClassList, a member of class TnxCustomSimpleMonitor.
csmOnRecordDelete | This is csmOnRecordDelete, a member of class TnxCustomSimpleMonitor.
csmOnRecordGet | This is csmOnRecordGet, a member of class TnxCustomSimpleMonitor.
csmOnRecordInsert | This is csmOnRecordInsert, a member of class TnxCustomSimpleMonitor.
csmOnRecordModify | This is csmOnRecordModify, a member of class TnxCustomSimpleMonitor.
csmOnTableAddIndex | This is csmOnTableAddIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableBuild | This is csmOnTableBuild, a member of class TnxCustomSimpleMonitor.
csmOnTableDelete | This is csmOnTableDelete, a member of class TnxCustomSimpleMonitor.
csmOnTableDropIndex | This is csmOnTableDropIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableEmpty | This is csmOnTableEmpty, a member of class TnxCustomSimpleMonitor.
csmOnTableExists | This is csmOnTableExists, a member of class TnxCustomSimpleMonitor.
csmOnTableGetDictionary | This is csmOnTableGetDictionary, a member of class TnxCustomSimpleMonitor.
csmOnTableGetList | This is csmOnTableGetList, a member of class TnxCustomSimpleMonitor.
csmOnTablePack | This is csmOnTablePack, a member of class TnxCustomSimpleMonitor.
csmOnTableRebuildIndex | This is csmOnTableRebuildIndex, a member of class TnxCustomSimpleMonitor.
csmOnTableRecover | This is csmOnTableRecover, a member of class TnxCustomSimpleMonitor.
csmOnTableRename | This is csmOnTableRename, a member of class TnxCustomSimpleMonitor.
csmOnTableRestructure | This is csmOnTableRestructure, a member of class TnxCustomSimpleMonitor.
csmOnTransactionCommit | This is csmOnTransactionCommit, a member of class TnxCustomSimpleMonitor.
csmOnTransactionRollback | This is csmOnTransactionRollback, a member of class TnxCustomSimpleMonitor.
csmOnTransactionStart | This is csmOnTransactionStart, a member of class TnxCustomSimpleMonitor.
lcEventLog | private
lcLogEnabled | This is lcLogEnabled, a member of class TnxLoggableComponent.
nxcDependentList | This is nxcDependentList, a member of class TnxComponent.
nxcDestroying | This is nxcDestroying, a member of class TnxComponent.
nxcDisplayCategory | This is nxcDisplayCategory, a member of class TnxComponent.
nxcDisplayName | This is nxcDisplayName, a member of class TnxComponent.
nxcOnSettingsLoaded | This is nxcOnSettingsLoaded, a member of class TnxComponent.
scActiveDesigntime | This is scActiveDesigntime, a member of class TnxStateComponent.
scActiveRuntime | This is scActiveRuntime, a member of class TnxStateComponent.
scEnabled | This is scEnabled, a member of class TnxStateComponent.
scLastStartError | This is scLastStartError, a member of class TnxStateComponent.
scOnStateChanged | This is scOnStateChanged, a member of class TnxStateComponent.
scOnStateTransChanged | This is scOnStateTransChanged, a member of class TnxStateComponent.
scSavedActive | (-1 false, 1 true, 0 not used);
scStartTime | private
scState | This is scState, a member of class TnxStateComponent.
scStateTransition | This is scStateTransition, a member of class TnxStateComponent.
Protected Methods
Name | Description
bemSetServerEngine |
DoNotification | TnxCustomSimpleMonitor
GetExceptionData | InxExceptionData
GetExceptionData | InxExceptionData
GetExceptionDataStats |
lcGetLogEnabled | TnxLoggableComponent
lcSetEventLog |
lcSetLogEnabled |
LoadConfig | Loads persisted settings.
Loaded | This is Loaded, a member of class TnxStateComponent.
nxcAddDependent |
nxcAddDependingOn |
nxcCheck |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcCreateComponentInfo |
nxcError | This is the overview for the nxcError method overload.
nxcExceptionClass | TnxComponent
nxcExceptionClass |
nxcExceptionClass |
nxcExceptionClass |
nxcGetDisplayName |
nxcIsDisplayNameStored |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotification |
nxcNotifyBroadcast |
nxcNotifyDependents |
nxcRemoveDependent |
nxcRemoveDependingOn |
rcRegister |
rcUnregister |
scCheckInactive |
scCheckInactiveOrStopped |
scCheckStarted |
scDeactivating |
scDependentStateChange |
scDependentStateChange |
scGetActive |
scInitializing |
scIsStateParent |
scIsStateParent |
scSetActive |
scSetActiveDesigntime |
scSetActiveRuntime |
scSetEnabled |
scSetState |
scShouldFollowTransition |
scShowLastStartErrorInStats |
scShowUpTime |
scStarted |
scStarting |
scStateChanged |
scStateChanging |
scStateTransitionChanged |
scStopped |
scStopping |
scStopping |
ServerEngineStarting |
ServerEngineStopped |
Public Methods
Name | Description
BeforeDestruction | see TComponent.BeforeDestruction
BeforeDestruction | see TComponent.BeforeDestruction TnxStateComponent
ClearStats | Resets all internal stats.
Close | Calling the close method is equivalent to setting Active to false.
Connect | Calling the connect method is equivalent to setting Active to true.
Create | constructor
Create | constructor
Create | constructor.
Destroy | denstructor
Destroy | destructor
Destroy | destructor.
DoLoadConfig | Loads persisted settings.
ExtendableObjectCreated | This method is called every time a server object is created within the linked Server engine. Override this function to create an Extender or manipulate the initial settings of a server object.
ExtendableObjectCreated |
ExtendableObjectDestroyed | This method is called every time a server object is destroyed within the linked Server engine.
FindClassRecursive | Tries to find the highest class in the class hierarchy with a certain suffix added to the current classname.
FindRegisteredClass | Returns it's class definition if the classname matches.
FreeInstance | Overriden to take advantage of the NexusDB Memory Manager.
GetComponentID |
GetConfigSettings | Returns the defintion of all persistable settings.
GetConfigSettings |
GetDisplayOnlyValue | returns readonly/displayonly value; eg information values displayed in server config
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredClasses | Adds itself to the list of registered classes.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsCaptions | Returns the captions for the returned statistic values.
GetStatsValues | Returns statistic values.
GetStatsValues |
IterateDependents | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
IterateDependentsEx | Adds all dependent classes toa TnxIterarionList. You can enforce the usage of an alternative Iteration List class that can e.g. do some filtering for certain class types.
lcLog | This is the overview for the lcLog method overload.
lcLogs | Log a number of strings.
LoadConfig |
LoadSettingsFromStream | Loads persisted settings. (legacy V1)
LoadSettingsFromStream |
LookupByComponentID |
NewInstance |
nxcCreateInstance |
Open | Calling the open method is equivalent to setting Active to true.
SaveConfig | Persists settings.
SaveConfig |
SaveSettingsToStream | Persists settings. (legacy V1)
SaveSettingsToStream | Persists settings. (legacy V1)
Supported | This function returns true if the component is supported in the current environment (e.g. windows version)
SwitchToSavedActive | A special command that can set the Active state to a before saved one. Also see: SavedActive
UISettingsVisible | Are there UI settings visible for this component? (legacy V1)
UIStateVisible | Set this to true if the state of this component should be visible in UI (legacy V1)
UIStatsVisible | Are there UI statistics visible for this component? (legacy V1)
Public Properties
Name | Description
Active | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
Connected | (De)Activate the component. This is done y switching it through the state engine until the Active state is reached or an error occurs.
SavedActive | Can be used to save a certain state.
StartTime | Time the componenet was last set to active.
State | Get/Sets the state of the component. When setting the state that must be in conformance to the state engine.
StateTransition | Returns the current StateTransition the component is in. If it is in a proper state this will return none.
Published Events
Name | Description
OnAction | Determines which system object events will be handled.
OnAliasAdd | Event called when an alias is added.
OnAliasDelete | Event called when an alias is deleted.
OnAliasGetList | Event called when client requests alias list.
OnAliasGetPath | Event called when client requests alias path.
OnAliasModify | Event called when an alias is modified.
OnCloseInactiveFolders | Event called when client calls CloseInactiveFolders.
OnCloseInactiveTables | Event called when client calls CloseInactiveTables.
OnCreate | Event called when an object is created.
OnDestroy | Event called when an object is destroyed.
OnGetRegisteredClassList | Event called when a list of registered common classes is retrieved.
OnRecordDelete | Event called when a client deletes a record.
OnRecordGet | Event called when a client reads a record.
OnRecordInsert | Event called when a client inserts a record.
OnRecordModify | Event called when a client modifies a record.
OnTableAddIndex | Event called when an index is added.
OnTableBuild | Event called when a table is created.
OnTableDelete | Event called when a table is deleted.
OnTableDropIndex | Event called when an index is dropped.
OnTableEmpty | Event called when a table is emptied.
OnTableExists | Event called when a client calls table.Exists.
OnTableGetDictionary | Event called when a client gets a table dictionary.
OnTableGetList | Event called when a client requests a list of tables.
OnTablePack | Event called when a table is packed.
OnTableRebuildIndex | Event called when a table index is rebuilt.
OnTableRecover | Event called when a client calls table.RecoverRecords.
OnTableRename | Event called when a table is renamed.
OnTableRestructure | Event called when a table is restructured.
OnTransactionCommit | Event called when a transaction is commited.
OnTransactionRollback | Event called when a transaction is rolled back.
OnTransactionStart | Event called when a transaction starts.
Published Properties
Name | Description
ActiveDesigntime | Set this to true if you want the component to start automatically in design mode.
ActiveRuntime | Set this to true if you want the component to start automatically on application startup.
AttachTo | Set AttachTo to include the objects whose events you wish to handle.
DisplayCategory | Name of the category if used in a UI. Can be multiple hierarchies by using / (legacy V1)
DisplayName | Name of the component if used in a UI. (legacy V1)
Enabled | Enable/Disable this component.
EventLog | The Event log associated with this component. If none set the lcLog calls will do nothing.
EventLogEnabled | True if logging is enabled for this component.
LastStartError | Error message (if any) the last time the component tried to set it's state to nxsStarted
OnSettingsLoaded | This is OnSettingsLoaded, a member of class TnxComponent.
OnStateChanged | This event is triggered every time the state of the component changed.
OnStateTransChanged | This event is triggered every time the state transition of the component changed.
ServerEngine | This property links the Monitor to a server engine.
Version | Version of the component.
Links
TnxSimpleMonitor Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties, Published Events, Published Properties


TnxSimpleMonitor Properties

TnxSimpleMonitor Properties
TnxSimpleMonitor Class Legend Published Properties Send Feedback

The properties of the TnxSimpleMonitor class are listed here.

Class

TnxSimpleMonitor Class

Published Properties
Name | Description
AttachTo | Set AttachTo to include the objects whose events you wish to handle.
Links
TnxSimpleMonitor Class, Legend, Published Properties


TnxSimpleMonitor.AttachTo Property

TnxSimpleMonitor.AttachTo Property
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Properties Send Feedback
Syntax
Delphi
property AttachTo: TnxAttachToSet;
Description

Set AttachTo to include the objects whose events you wish to handle.

Group

TnxSimpleMonitor Properties

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Properties


TnxSimpleMonitor Events

TnxSimpleMonitor Events
TnxSimpleMonitor Class Legend Published Events Send Feedback

The events of the TnxSimpleMonitor class are listed here.

Class

TnxSimpleMonitor Class

Published Events
Name | Description
OnAction | Determines which system object events will be handled.
OnAliasAdd | Event called when an alias is added.
OnAliasDelete | Event called when an alias is deleted.
OnAliasGetList | Event called when client requests alias list.
OnAliasGetPath | Event called when client requests alias path.
OnAliasModify | Event called when an alias is modified.
OnCloseInactiveFolders | Event called when client calls CloseInactiveFolders.
OnCloseInactiveTables | Event called when client calls CloseInactiveTables.
OnCreate | Event called when an object is created.
OnDestroy | Event called when an object is destroyed.
OnGetRegisteredClassList | Event called when a list of registered common classes is retrieved.
OnRecordDelete | Event called when a client deletes a record.
OnRecordGet | Event called when a client reads a record.
OnRecordInsert | Event called when a client inserts a record.
OnRecordModify | Event called when a client modifies a record.
OnTableAddIndex | Event called when an index is added.
OnTableBuild | Event called when a table is created.
OnTableDelete | Event called when a table is deleted.
OnTableDropIndex | Event called when an index is dropped.
OnTableEmpty | Event called when a table is emptied.
OnTableExists | Event called when a client calls table.Exists.
OnTableGetDictionary | Event called when a client gets a table dictionary.
OnTableGetList | Event called when a client requests a list of tables.
OnTablePack | Event called when a table is packed.
OnTableRebuildIndex | Event called when a table index is rebuilt.
OnTableRecover | Event called when a client calls table.RecoverRecords.
OnTableRename | Event called when a table is renamed.
OnTableRestructure | Event called when a table is restructured.
OnTransactionCommit | Event called when a transaction is commited.
OnTransactionRollback | Event called when a transaction is rolled back.
OnTransactionStart | Event called when a transaction starts.
Links
TnxSimpleMonitor Class, Legend, Published Events


TnxSimpleMonitor.OnAction Event

TnxSimpleMonitor.OnAction Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAction: TnxExtenderAction;
Parameters
Parameters | Description
aExtender | the extender sending the notification
aAction | the type of action
aBefore | True if the event is called before the action is performed
aArgs | event arguments, depending on event type
Description

Determines which system object events will be handled.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnAliasAdd Event

TnxSimpleMonitor.OnAliasAdd Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasAdd: TnxeaAliasAdd;
Description

Event called when an alias is added.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnAliasDelete Event

TnxSimpleMonitor.OnAliasDelete Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasDelete: TnxeaAliasDelete;
Description

Event called when an alias is deleted.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnAliasGetList Event

TnxSimpleMonitor.OnAliasGetList Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasGetList: TnxeaAliasGetList;
Description

Event called when client requests alias list.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnAliasGetPath Event

TnxSimpleMonitor.OnAliasGetPath Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasGetPath: TnxeaAliasGetPath;
Description

Event called when client requests alias path.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnAliasModify Event

TnxSimpleMonitor.OnAliasModify Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnAliasModify: TnxeaAliasModify;
Description

Event called when an alias is modified.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnCloseInactiveFolders Event

TnxSimpleMonitor.OnCloseInactiveFolders Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCloseInactiveFolders: TnxeaCloseInactiveFolders;
Description

Event called when client calls CloseInactiveFolders.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnCloseInactiveTables Event

TnxSimpleMonitor.OnCloseInactiveTables Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCloseInactiveTables: TnxeaCloseInactiveTables;
Description

Event called when client calls CloseInactiveTables.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnCreate Event

TnxSimpleMonitor.OnCreate Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnCreate: TnxeaCreate;
Description

Event called when an object is created.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnDestroy Event

TnxSimpleMonitor.OnDestroy Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnDestroy: TnxeaDestroy;
Description

Event called when an object is destroyed.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnGetRegisteredClassList Event

TnxSimpleMonitor.OnGetRegisteredClassList Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnGetRegisteredClassList: TnxeaGetRegisteredClassList;
Description

Event called when a list of registered common classes is retrieved.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnRecordDelete Event

TnxSimpleMonitor.OnRecordDelete Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordDelete: TnxeaRecordDelete;
Description

Event called when a client deletes a record.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnRecordGet Event

TnxSimpleMonitor.OnRecordGet Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordGet: TnxeaRecordGet;
Description

Event called when a client reads a record.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnRecordInsert Event

TnxSimpleMonitor.OnRecordInsert Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordInsert: TnxeaRecordInsert;
Description

Event called when a client inserts a record.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnRecordModify Event

TnxSimpleMonitor.OnRecordModify Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnRecordModify: TnxeaRecordModify;
Description

Event called when a client modifies a record.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableAddIndex Event

TnxSimpleMonitor.OnTableAddIndex Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableAddIndex: TnxeaTableAddIndex;
Description

Event called when an index is added.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableBuild Event

TnxSimpleMonitor.OnTableBuild Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableBuild: TnxeaTableBuild;
Description

Event called when a table is created.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableDelete Event

TnxSimpleMonitor.OnTableDelete Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableDelete: TnxeaTableDelete;
Description

Event called when a table is deleted.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableDropIndex Event

TnxSimpleMonitor.OnTableDropIndex Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableDropIndex: TnxeaTableDropIndex;
Description

Event called when an index is dropped.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableEmpty Event

TnxSimpleMonitor.OnTableEmpty Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableEmpty: TnxeaTableEmpty;
Description

Event called when a table is emptied.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableExists Event

TnxSimpleMonitor.OnTableExists Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableExists: TnxeaTableExists;
Description

Event called when a client calls table.Exists.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableGetDictionary Event

TnxSimpleMonitor.OnTableGetDictionary Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableGetDictionary: TnxeaTableGetDictionary;
Description

Event called when a client gets a table dictionary.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableGetList Event

TnxSimpleMonitor.OnTableGetList Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableGetList: TnxeaTableGetList;
Description

Event called when a client requests a list of tables.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTablePack Event

TnxSimpleMonitor.OnTablePack Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTablePack: TnxeaTablePack;
Description

Event called when a table is packed.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableRebuildIndex Event

TnxSimpleMonitor.OnTableRebuildIndex Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRebuildIndex: TnxeaTableRebuildIndex;
Description

Event called when a table index is rebuilt.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableRecover Event

TnxSimpleMonitor.OnTableRecover Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRecover: TnxeaTableRecover;
Description

Event called when a client calls table.RecoverRecords.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableRename Event

TnxSimpleMonitor.OnTableRename Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRename: TnxeaTableRename;
Description

Event called when a table is renamed.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTableRestructure Event

TnxSimpleMonitor.OnTableRestructure Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTableRestructure: TnxeaTableRestructure;
Description

Event called when a table is restructured.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTransactionCommit Event

TnxSimpleMonitor.OnTransactionCommit Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionCommit: TnxeaTransactionCommit;
Description

Event called when a transaction is commited.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTransactionRollback Event

TnxSimpleMonitor.OnTransactionRollback Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionRollback: TnxeaTransactionRollback;
Description

Event called when a transaction is rolled back.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitor.OnTransactionStart Event

TnxSimpleMonitor.OnTransactionStart Event
TnxSimpleMonitor Class TnxSimpleMonitor Members nxsdSimpleMonitor Namespace TnxSimpleMonitor Events Send Feedback
Syntax
Delphi
property OnTransactionStart: TnxeaTransactionStart;
Description

Event called when a transaction starts.

Group

TnxSimpleMonitor Events

Links
TnxSimpleMonitor Class, TnxSimpleMonitor Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitor Events


TnxSimpleMonitorExtender Class

TnxSimpleMonitorExtender Class
TnxSimpleMonitorExtender Methods TnxSimpleMonitorExtender Members nxsdSimpleMonitor Classes Send Feedback
Class Hierarchy
nxsdSimpleMonitor_TnxSimpleMonitorExtendernxsdSimpleMonitor_TnxSimpleMonitorExtendernxsdSimpleMonitor_TnxSimpleMonitorExtendernxsdSimpleMonitor_TnxSimpleMonitorExtendernxsdSimpleMonitor_TnxSimpleMonitorExtender
Syntax
Delphi
TnxSimpleMonitorExtender = class(TnxBaseEngineExtender);
File

nxsdSimpleMonitor

Description

Internal helper class for TnxSimpleMonitor

Group

Classes

Links
TnxSimpleMonitorExtender Methods, TnxSimpleMonitorExtender Members, nxsdSimpleMonitor, Classes


TnxSimpleMonitorExtender Members

TnxSimpleMonitorExtender Members
TnxSimpleMonitorExtender Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleMonitorExtender.

Class

TnxSimpleMonitorExtender Class

Protected Fields
Name | Description
beeActions | This is beeActions, a member of class TnxBaseEngineExtender.
beeExtendableObject | This is beeExtendableObject, a member of class TnxBaseEngineExtender.
beeExtendableObjectNext | This is beeExtendableObjectNext, a member of class TnxBaseEngineExtender.
beeExtendableObjectPrev | This is beeExtendableObjectPrev, a member of class TnxBaseEngineExtender.
beeMonitor | private
beeMonitorNext | This is beeMonitorNext, a member of class TnxBaseEngineExtender.
beeMonitorPrev | This is beeMonitorPrev, a member of class TnxBaseEngineExtender.
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
beeAddToExtendableObject |
beeAddToMonitor |
beeCreateInstance |
beeRemoveFromExtendableObject |
beeRemoveFromMonitor |
GetExceptionData | InxExceptionData TnxPersistent
GetExceptionData | InxExceptionData
QueryInterface | InxInterface
Public Methods
Name | Description
BeforeDestruction | TnxLifetimeTrackedPersistent
Create | constructor
Destroy | destructor.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Notify | TnxSimpleMonitorExtender
PrepareDestroy | called just before the destructor is called to allow for removal of dependencies between components.
Public Properties
Name | Description
ExtendableObject | This property returns the server object the extender extends.
Monitor | This property returns the Monitor the extender was created from.
Links
TnxSimpleMonitorExtender Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSimpleMonitorExtender Methods

TnxSimpleMonitorExtender Methods
TnxSimpleMonitorExtender Class Legend Public Methods Send Feedback

The methods of the TnxSimpleMonitorExtender class are listed here.

Class

TnxSimpleMonitorExtender Class

Public Methods
Name | Description
Notify | TnxSimpleMonitorExtender
Links
TnxSimpleMonitorExtender Class, Legend, Public Methods


TnxSimpleMonitorExtender.Notify Method

TnxSimpleMonitorExtender.Notify Method
TnxSimpleMonitorExtender Class TnxSimpleMonitorExtender Members nxsdSimpleMonitor Namespace TnxSimpleMonitorExtender Methods Send Feedback
Syntax
Delphi
function Notify(aAction: TnxEngineAction; aBefore: Boolean; const aArgs: array of const): TnxResult; override;
Description

TnxSimpleMonitorExtender

Group

TnxSimpleMonitorExtender Methods

Links
TnxSimpleMonitorExtender Class, TnxSimpleMonitorExtender Members, nxsdSimpleMonitor Namespace, TnxSimpleMonitorExtender Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdSimpleMonitor Namespace Legend Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxAttachTo | This is record nxsdSimpleMonitor.TnxAttachTo.
Namespace

nxsdSimpleMonitor Namespace

Links
Enumerations, nxsdSimpleMonitor Namespace, Legend


nxsdSimpleMonitor.TnxAttachTo Enumeration

nxsdSimpleMonitor.TnxAttachTo Enumeration
nxsdSimpleMonitor Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxAttachTo = ( natSession, natDatabase, natCursor, natTransContext );
File

nxsdSimpleMonitor

Description

This is record nxsdSimpleMonitor.TnxAttachTo.

Group

Structs, Records, Enums

Links
nxsdSimpleMonitor, Structs, Records, Enums


Types

Types
nxsdSimpleMonitor Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdSimpleMonitor Namespace

Types
Name | Description
TnxAttachToSet | This is type nxsdSimpleMonitor.TnxAttachToSet.
TnxeaAliasAdd | This is type nxsdSimpleMonitor.TnxeaAliasAdd.
TnxeaAliasDelete | This is type nxsdSimpleMonitor.TnxeaAliasDelete.
TnxeaAliasGetList | This is type nxsdSimpleMonitor.TnxeaAliasGetList.
TnxeaAliasGetPath | This is type nxsdSimpleMonitor.TnxeaAliasGetPath.
TnxeaAliasModify | This is type nxsdSimpleMonitor.TnxeaAliasModify.
TnxeaCloseInactiveFolders | This is type nxsdSimpleMonitor.TnxeaCloseInactiveFolders.
TnxeaCloseInactiveTables | This is type nxsdSimpleMonitor.TnxeaCloseInactiveTables.
TnxeaCreate | HPPEMIT '#define _ARRAYOF /**/' HPPEMIT 'namespace Nxsdsimplemonitor' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxSimpleMonitorExtender;' HPPEMIT 'typedef void __fastcall (__closure *TnxExtenderAction)(TnxSimpleMonitorExtender* aExtender, Nxsdserverengine::TnxEngineAction aAction, bool aBefore, const System::TVarRec * aArgs, const int aArgs_Size,const int dummy);' HPPEMIT '} /* namespace Nxsdsimplemonitor */'
TnxeaDestroy | This is type nxsdSimpleMonitor.TnxeaDestroy.
TnxeaGetRegisteredClassList | This is type nxsdSimpleMonitor.TnxeaGetRegisteredClassList.
TnxeaRecordDelete | This is type nxsdSimpleMonitor.TnxeaRecordDelete.
TnxeaRecordGet | This is type nxsdSimpleMonitor.TnxeaRecordGet.
TnxeaRecordInsert | This is type nxsdSimpleMonitor.TnxeaRecordInsert.
TnxeaRecordModify | This is type nxsdSimpleMonitor.TnxeaRecordModify.
TnxeaTableAddIndex | This is type nxsdSimpleMonitor.TnxeaTableAddIndex.
TnxeaTableBuild | This is type nxsdSimpleMonitor.TnxeaTableBuild.
TnxeaTableDelete | This is type nxsdSimpleMonitor.TnxeaTableDelete.
TnxeaTableDropIndex | This is type nxsdSimpleMonitor.TnxeaTableDropIndex.
TnxeaTableEmpty | This is type nxsdSimpleMonitor.TnxeaTableEmpty.
TnxeaTableExists | This is type nxsdSimpleMonitor.TnxeaTableExists.
TnxeaTableGetDictionary | This is type nxsdSimpleMonitor.TnxeaTableGetDictionary.
TnxeaTableGetList | This is type nxsdSimpleMonitor.TnxeaTableGetList.
TnxeaTablePack | This is type nxsdSimpleMonitor.TnxeaTablePack.
TnxeaTableRebuildIndex | This is type nxsdSimpleMonitor.TnxeaTableRebuildIndex.
TnxeaTableRecover | This is type nxsdSimpleMonitor.TnxeaTableRecover.
TnxeaTableRename | This is type nxsdSimpleMonitor.TnxeaTableRename.
TnxeaTableRestructure | This is type nxsdSimpleMonitor.TnxeaTableRestructure.
TnxeaTransactionCommit | This is type nxsdSimpleMonitor.TnxeaTransactionCommit.
TnxeaTransactionRollback | This is type nxsdSimpleMonitor.TnxeaTransactionRollback.
TnxeaTransactionStart | This is type nxsdSimpleMonitor.TnxeaTransactionStart.
TnxExtenderAction | econs4 BCB support - 10-Feb-2005
Links
nxsdSimpleMonitor Namespace, Types


nxsdSimpleMonitor.TnxAttachToSet Type

nxsdSimpleMonitor.TnxAttachToSet Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxAttachToSet = set of TnxAttachTo;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxAttachToSet.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaAliasAdd Type

nxsdSimpleMonitor.TnxeaAliasAdd Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaAliasAdd = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aAlias: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaAliasAdd.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaAliasDelete Type

nxsdSimpleMonitor.TnxeaAliasDelete Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaAliasDelete = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aAlias: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaAliasDelete.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaAliasGetList Type

nxsdSimpleMonitor.TnxeaAliasGetList Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaAliasGetList = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aList: TObjectList) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaAliasGetList.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaAliasGetPath Type

nxsdSimpleMonitor.TnxeaAliasGetPath Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaAliasGetPath = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aAlias: string; aPath: pstring) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaAliasGetPath.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaAliasModify Type

nxsdSimpleMonitor.TnxeaAliasModify Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaAliasModify = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aAlias, aNewName, aNewPath: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaAliasModify.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaCloseInactiveFolders Type

nxsdSimpleMonitor.TnxeaCloseInactiveFolders Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaCloseInactiveFolders = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaCloseInactiveFolders.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaCloseInactiveTables Type

nxsdSimpleMonitor.TnxeaCloseInactiveTables Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaCloseInactiveTables = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaCloseInactiveTables.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaCreate Type

nxsdSimpleMonitor.TnxeaCreate Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaCreate = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

HPPEMIT '#define _ARRAYOF /**/' HPPEMIT 'namespace Nxsdsimplemonitor' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxSimpleMonitorExtender;' HPPEMIT 'typedef void __fastcall (__closure *TnxExtenderAction)(TnxSimpleMonitorExtender* aExtender, Nxsdserverengine::TnxEngineAction aAction, bool aBefore, const System::TVarRec * aArgs, const int aArgs_Size,const int dummy);' HPPEMIT '} /* namespace Nxsdsimplemonitor */'

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaDestroy Type

nxsdSimpleMonitor.TnxeaDestroy Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaDestroy = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaDestroy.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaGetRegisteredClassList Type

nxsdSimpleMonitor.TnxeaGetRegisteredClassList Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaGetRegisteredClassList = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aEngineType: TnxClassListType; aList: TStrings) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaGetRegisteredClassList.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaRecordDelete Type

nxsdSimpleMonitor.TnxeaRecordDelete Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaRecordDelete = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aOldData: PnxByteArray) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaRecordDelete.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaRecordGet Type

nxsdSimpleMonitor.TnxeaRecordGet Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaRecordGet = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aLockType: TnxLockType; aData: PnxByteArray) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaRecordGet.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaRecordInsert Type

nxsdSimpleMonitor.TnxeaRecordInsert Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaRecordInsert = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aLockType: TnxLockType; aData: PnxByteArray) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaRecordInsert.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaRecordModify Type

nxsdSimpleMonitor.TnxeaRecordModify Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaRecordModify = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aNewData: PnxByteArray; aOldData: PnxByteArray; aReleaseLock: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaRecordModify.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableAddIndex Type

nxsdSimpleMonitor.TnxeaTableAddIndex Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableAddIndex = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; aIndexDesc: TnxIndexDescriptor) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableAddIndex.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableBuild Type

nxsdSimpleMonitor.TnxeaTableBuild Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableBuild = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aOverWrite: Boolean; const aTableName: string; aDictionary: TnxDataDictionary) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableBuild.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableDelete Type

nxsdSimpleMonitor.TnxeaTableDelete Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableDelete = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableDelete.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableDropIndex Type

nxsdSimpleMonitor.TnxeaTableDropIndex Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableDropIndex = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; const aIndexName: string; IndexID: Integer) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableDropIndex.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableEmpty Type

nxsdSimpleMonitor.TnxeaTableEmpty Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableEmpty = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableEmpty.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableExists Type

nxsdSimpleMonitor.TnxeaTableExists Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableExists = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; aExists: PnxBoolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableExists.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableGetDictionary Type

nxsdSimpleMonitor.TnxeaTableGetDictionary Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableGetDictionary = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; aDictionary: TnxDataDictionary) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableGetDictionary.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableGetList Type

nxsdSimpleMonitor.TnxeaTableGetList Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableGetList = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aList: TStrings) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableGetList.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTablePack Type

nxsdSimpleMonitor.TnxeaTablePack Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTablePack = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTablePack.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableRebuildIndex Type

nxsdSimpleMonitor.TnxeaTableRebuildIndex Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableRebuildIndex = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; aIndexID: Integer) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableRebuildIndex.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableRecover Type

nxsdSimpleMonitor.TnxeaTableRecover Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableRecover = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableRecover.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableRename Type

nxsdSimpleMonitor.TnxeaTableRename Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableRename = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aOldName: string; const aNewName: string) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableRename.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTableRestructure Type

nxsdSimpleMonitor.TnxeaTableRestructure Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTableRestructure = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; const aTableName: string; aDictionary: TnxDataDictionary; aFieldMap: TStrings) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTableRestructure.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTransactionCommit Type

nxsdSimpleMonitor.TnxeaTransactionCommit Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTransactionCommit = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTransactionCommit.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTransactionRollback Type

nxsdSimpleMonitor.TnxeaTransactionRollback Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTransactionRollback = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTransactionRollback.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxeaTransactionStart Type

nxsdSimpleMonitor.TnxeaTransactionStart Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxeaTransactionStart = procedure (aExtender: TnxSimpleMonitorExtender; aBefore: Boolean; aFailSafe, aSnapShot: Boolean) of object;
File

nxsdSimpleMonitor

Description

This is type nxsdSimpleMonitor.TnxeaTransactionStart.

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdSimpleMonitor.TnxExtenderAction Type

nxsdSimpleMonitor.TnxExtenderAction Type
nxsdSimpleMonitor Types Send Feedback
Syntax
Delphi
TnxExtenderAction = procedure (aExtender: TnxSimpleMonitorExtender; aAction: TnxEngineAction; aBefore: Boolean; const aArgs : array of const ; dummy : integer = 0 ) of object;
File

nxsdSimpleMonitor

Description

econs4 BCB support - 10-Feb-2005

Group

Types

Links
nxsdSimpleMonitor, Types


nxsdTableMapperDescriptor Namespace

nxsdTableMapperDescriptor Namespace
Classes Legend Topics Send Feedback

This is namespace nxsdTableMapperDescriptor.

Classes
Name | Description
EnxTableMapperDescriptorException | This is class nxsdTableMapperDescriptor.EnxTableMapperDescriptorException.
TnxTableMapperDescriptor | This is class nxsdTableMapperDescriptor.TnxTableMapperDescriptor.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxsdTableMapperDescriptor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxTableMapperDescriptorException | This is class nxsdTableMapperDescriptor.EnxTableMapperDescriptorException.
TnxTableMapperDescriptor | This is class nxsdTableMapperDescriptor.TnxTableMapperDescriptor.
Namespace

nxsdTableMapperDescriptor Namespace

Links
Classes, nxsdTableMapperDescriptor Namespace, Legend


EnxTableMapperDescriptorException Class

EnxTableMapperDescriptorException Class
nxsdTableMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdTableMapperDescriptor_EnxTableMapperDescriptorExceptionnxsdTableMapperDescriptor_EnxTableMapperDescriptorExceptionnxsdTableMapperDescriptor_EnxTableMapperDescriptorExceptionnxsdTableMapperDescriptor_EnxTableMapperDescriptorExceptionnxsdTableMapperDescriptor_EnxTableMapperDescriptorExceptionnxsdTableMapperDescriptor_EnxTableMapperDescriptorException
Syntax
Delphi
EnxTableMapperDescriptorException = class(EnxBaseTableMapperDescriptorException);
File

nxsdTableMapperDescriptor

Description

This is class nxsdTableMapperDescriptor.EnxTableMapperDescriptorException.

Group

Classes

Links
nxsdTableMapperDescriptor, Classes


TnxTableMapperDescriptor Class

TnxTableMapperDescriptor Class
TnxTableMapperDescriptor Methods TnxTableMapperDescriptor Members nxsdTableMapperDescriptor Classes Send Feedback
Class Hierarchy
nxsdTableMapperDescriptor_TnxTableMapperDescriptornxsdTableMapperDescriptor_TnxTableMapperDescriptornxsdTableMapperDescriptor_TnxTableMapperDescriptornxsdTableMapperDescriptor_TnxTableMapperDescriptornxsdTableMapperDescriptor_TnxTableMapperDescriptornxsdTableMapperDescriptor_TnxTableMapperDescriptor
Syntax
Delphi
TnxTableMapperDescriptor = class(TnxBaseTableMapperDescriptor);
File

nxsdTableMapperDescriptor

Description

This is class nxsdTableMapperDescriptor.TnxTableMapperDescriptor.

Group

Classes

Links
TnxTableMapperDescriptor Methods, TnxTableMapperDescriptor Members, nxsdTableMapperDescriptor, Classes


TnxTableMapperDescriptor Members

TnxTableMapperDescriptor Members
TnxTableMapperDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTableMapperDescriptor.

Class

TnxTableMapperDescriptor Class

Protected Fields
Name | Description
btmdMapTo | This is btmdMapTo, a member of class TnxBaseTableMapperDescriptor.
btmdName | This is btmdName, a member of class TnxBaseTableMapperDescriptor.
btmdParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
InternalLoadFromReader | TnxTableMapperDescriptor
InternalSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
RecordMapper | This is RecordMapper, a member of class TnxBaseTableMapperDescriptor.
TableCount | This is TableCount, a member of class TnxBaseTableMapperDescriptor.
TableDescriptor | fields are public for speed reasons
Public Methods
Name | Description
AddRecordMapper | TnxBaseTableMapperDescriptor
AddTable |
BeforeDestruction | TnxLifetimeTrackedPersistent
Clear |
Create |
CreateFromReader |
Destroy |
Duplicate |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
GetTableDescriptorFromName |
GetTableIndexFromName |
MapAllTablesAndFieldsByName |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
RemoveRecordMapper |
RemoveTable | This is the overview for the RemoveTable method overload.
WriteToWriter |
Public Properties
Name | Description
MapTo | This is MapTo, a member of class TnxBaseTableMapperDescriptor.
Name | This is Name, a member of class TnxBaseTableMapperDescriptor.
Parent | This is Parent, a member of class TnxBaseTableMapperDescriptor.
Links
TnxTableMapperDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxTableMapperDescriptor Methods

TnxTableMapperDescriptor Methods
TnxTableMapperDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTableMapperDescriptor class are listed here.

Class

TnxTableMapperDescriptor Class

Protected Methods
Name | Description
InternalLoadFromReader | TnxTableMapperDescriptor
InternalSaveToWriter |
Public Methods
Name | Description
MapAllTablesAndFieldsByName |
Links
TnxTableMapperDescriptor Class, Legend, Protected Methods, Public Methods


TnxTableMapperDescriptor.InternalLoadFromReader Method

TnxTableMapperDescriptor.InternalLoadFromReader Method
TnxTableMapperDescriptor Class TnxTableMapperDescriptor Members nxsdTableMapperDescriptor Namespace TnxTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalLoadFromReader(aReader: TnxReader); override;
Description

TnxTableMapperDescriptor

Group

TnxTableMapperDescriptor Methods

Links
TnxTableMapperDescriptor Class, TnxTableMapperDescriptor Members, nxsdTableMapperDescriptor Namespace, TnxTableMapperDescriptor Methods


TnxTableMapperDescriptor.InternalSaveToWriter Method

TnxTableMapperDescriptor.InternalSaveToWriter Method
TnxTableMapperDescriptor Class TnxTableMapperDescriptor Members nxsdTableMapperDescriptor Namespace TnxTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); override;
Group

TnxTableMapperDescriptor Methods

Links
TnxTableMapperDescriptor Class, TnxTableMapperDescriptor Members, nxsdTableMapperDescriptor Namespace, TnxTableMapperDescriptor Methods


TnxTableMapperDescriptor.MapAllTablesAndFieldsByName Method

TnxTableMapperDescriptor.MapAllTablesAndFieldsByName Method
TnxTableMapperDescriptor Class TnxTableMapperDescriptor Members nxsdTableMapperDescriptor Namespace TnxTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure MapAllTablesAndFieldsByName(aOldTable: TnxBaseTableDescriptor; aNewTable: TnxBaseTableDescriptor; aDataLossAction: TnxDataLossAction = dlaFail);
Group

TnxTableMapperDescriptor Methods

Links
TnxTableMapperDescriptor Class, TnxTableMapperDescriptor Members, nxsdTableMapperDescriptor Namespace, TnxTableMapperDescriptor Methods


nxsdTableMapperDescriptorBase Namespace

nxsdTableMapperDescriptorBase Namespace
Classes Legend Topics Types Variables Send Feedback

This is namespace nxsdTableMapperDescriptorBase.

Classes
Name | Description
EnxBaseTableMapperDescriptorException | This is class nxsdTableMapperDescriptorBase.EnxBaseTableMapperDescriptorException.
TnxBaseTableMapperDescriptor | This is class nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptor.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Types
Name | Description
TnxBaseTableMapperDescriptorClass | This is type nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptorClass.
Variables
Name | Description
_TableMapperDescriptorList | This is variable nxsdTableMapperDescriptorBase._TableMapperDescriptorList.
Links
Classes, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdTableMapperDescriptorBase Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseTableMapperDescriptorException | This is class nxsdTableMapperDescriptorBase.EnxBaseTableMapperDescriptorException.
TnxBaseTableMapperDescriptor | This is class nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptor.
Namespace

nxsdTableMapperDescriptorBase Namespace

Links
Classes, nxsdTableMapperDescriptorBase Namespace, Legend


EnxBaseTableMapperDescriptorException Class

EnxBaseTableMapperDescriptorException Class
nxsdTableMapperDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdTableMapperDescriptorBase_EnxBaseTableMapperDescriptorExceptionnxsdTableMapperDescriptorBase_EnxBaseTableMapperDescriptorExceptionnxsdTableMapperDescriptorBase_EnxBaseTableMapperDescriptorExceptionnxsdTableMapperDescriptorBase_EnxBaseTableMapperDescriptorExceptionnxsdTableMapperDescriptorBase_EnxBaseTableMapperDescriptorException
Syntax
Delphi
EnxBaseTableMapperDescriptorException = class(EnxBaseRegisterableDescriptorException);
File

nxsdTableMapperDescriptorBase

Description

This is class nxsdTableMapperDescriptorBase.EnxBaseTableMapperDescriptorException.

Group

Classes

Links
nxsdTableMapperDescriptorBase, Classes


TnxBaseTableMapperDescriptor Class

TnxBaseTableMapperDescriptor Class
TnxBaseTableMapperDescriptor Fields TnxBaseTableMapperDescriptor Methods TnxBaseTableMapperDescriptor Properties TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Classes Send Feedback
Class Hierarchy
nxsdTableMapperDescriptorBase_TnxBaseTableMapperDescriptornxsdTableMapperDescriptorBase_TnxBaseTableMapperDescriptornxsdTableMapperDescriptorBase_TnxBaseTableMapperDescriptornxsdTableMapperDescriptorBase_TnxBaseTableMapperDescriptornxsdTableMapperDescriptorBase_TnxBaseTableMapperDescriptor
Syntax
Delphi
TnxBaseTableMapperDescriptor = class(TnxBaseRegisterableDescriptor);
File

nxsdTableMapperDescriptorBase

Description

This is class nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptor.

Group

Classes

Links
TnxBaseTableMapperDescriptor Fields, TnxBaseTableMapperDescriptor Methods, TnxBaseTableMapperDescriptor Properties, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase, Classes


TnxBaseTableMapperDescriptor Members

TnxBaseTableMapperDescriptor Members
TnxBaseTableMapperDescriptor Class Legend Protected Fields Protected Methods Public Fields Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTableMapperDescriptor.

Class

TnxBaseTableMapperDescriptor Class

Protected Fields
Name | Description
btmdMapTo | This is btmdMapTo, a member of class TnxBaseTableMapperDescriptor.
btmdName | This is btmdName, a member of class TnxBaseTableMapperDescriptor.
btmdParent | private
ltpLifetimeMonitor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
QueryInterface | InxInterface
Register |
Unregister |
Public Fields
Name | Description
RecordMapper | This is RecordMapper, a member of class TnxBaseTableMapperDescriptor.
TableCount | This is TableCount, a member of class TnxBaseTableMapperDescriptor.
TableDescriptor | fields are public for speed reasons
Public Methods
Name | Description
AddRecordMapper | TnxBaseTableMapperDescriptor
AddTable |
BeforeDestruction | TnxLifetimeTrackedPersistent
Clear |
Create |
CreateFromReader |
Destroy |
Duplicate |
FindDescriptorClass | TnxBaseRegisterableDescriptor
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetLifetimeMontior |
GetRegisteredDescriptors |
GetTableDescriptorFromName |
GetTableIndexFromName |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
RemoveRecordMapper |
RemoveTable | This is the overview for the RemoveTable method overload.
WriteToWriter |
Public Properties
Name | Description
MapTo | This is MapTo, a member of class TnxBaseTableMapperDescriptor.
Name | This is Name, a member of class TnxBaseTableMapperDescriptor.
Parent | This is Parent, a member of class TnxBaseTableMapperDescriptor.
Links
TnxBaseTableMapperDescriptor Class, Legend, Protected Fields, Protected Methods, Public Fields, Public Methods, Public Properties


TnxBaseTableMapperDescriptor.Create Constructor

TnxBaseTableMapperDescriptor.Create Constructor
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Class Send Feedback
Syntax
Delphi
constructor Create; virtual;
Class

TnxBaseTableMapperDescriptor Class

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Class


TnxBaseTableMapperDescriptor.Destroy Destructor

TnxBaseTableMapperDescriptor.Destroy Destructor
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseTableMapperDescriptor Class

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Class


TnxBaseTableMapperDescriptor Fields

TnxBaseTableMapperDescriptor Fields
TnxBaseTableMapperDescriptor Class Legend Protected Fields Public Fields Send Feedback

The fields of the TnxBaseTableMapperDescriptor class are listed here.

Class

TnxBaseTableMapperDescriptor Class

Protected Fields
Name | Description
btmdMapTo | This is btmdMapTo, a member of class TnxBaseTableMapperDescriptor.
btmdName | This is btmdName, a member of class TnxBaseTableMapperDescriptor.
btmdParent | private
Public Fields
Name | Description
RecordMapper | This is RecordMapper, a member of class TnxBaseTableMapperDescriptor.
TableCount | This is TableCount, a member of class TnxBaseTableMapperDescriptor.
TableDescriptor | fields are public for speed reasons
Links
TnxBaseTableMapperDescriptor Class, Legend, Protected Fields, Public Fields


TnxBaseTableMapperDescriptor.btmdMapTo Field

TnxBaseTableMapperDescriptor.btmdMapTo Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
btmdMapTo: string;
Description

This is btmdMapTo, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor.btmdName Field

TnxBaseTableMapperDescriptor.btmdName Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
btmdName: string;
Description

This is btmdName, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor.btmdParent Field

TnxBaseTableMapperDescriptor.btmdParent Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
btmdParent: TnxBaseTableMapperDescriptor;
Description

private

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor.RecordMapper Field

TnxBaseTableMapperDescriptor.RecordMapper Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
RecordMapper: TnxBaseRecordMapperDescriptor;
Description

This is RecordMapper, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor.TableCount Field

TnxBaseTableMapperDescriptor.TableCount Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
TableCount: Integer;
Description

This is TableCount, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor.TableDescriptor Field

TnxBaseTableMapperDescriptor.TableDescriptor Field
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Fields Send Feedback
Syntax
Delphi
TableDescriptor: array of TnxBaseTableMapperDescriptor;
Description

fields are public for speed reasons

Group

TnxBaseTableMapperDescriptor Fields

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Fields


TnxBaseTableMapperDescriptor Methods

TnxBaseTableMapperDescriptor Methods
TnxBaseTableMapperDescriptor Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTableMapperDescriptor class are listed here.

Class

TnxBaseTableMapperDescriptor Class

Protected Methods
Name | Description
GetList |
InternalLoadFromReader |
InternalSaveToWriter |
Public Methods
Name | Description
AddRecordMapper | TnxBaseTableMapperDescriptor
AddTable |
Clear |
CreateFromReader |
Duplicate |
GetTableDescriptorFromName |
GetTableIndexFromName |
RemoveRecordMapper |
RemoveTable | This is the overview for the RemoveTable method overload.
WriteToWriter |
Links
TnxBaseTableMapperDescriptor Class, Legend, Protected Methods, Public Methods


TnxBaseTableMapperDescriptor.AddRecordMapper Method

TnxBaseTableMapperDescriptor.AddRecordMapper Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
function AddRecordMapper(aClass: TnxBaseRecordMapperDescriptorClass): TnxBaseRecordMapperDescriptor;
Description

TnxBaseTableMapperDescriptor

Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.AddTable Method

TnxBaseTableMapperDescriptor.AddTable Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
function AddTable(const aName: string; aClass: TnxBaseTableMapperDescriptorClass = nil): TnxBaseTableMapperDescriptor;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.Clear Method

TnxBaseTableMapperDescriptor.Clear Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure Clear;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.CreateFromReader Method

TnxBaseTableMapperDescriptor.CreateFromReader Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function CreateFromReader(aReader: TnxReader): TnxBaseTableMapperDescriptor;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.Duplicate Method

TnxBaseTableMapperDescriptor.Duplicate Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
function Duplicate: TnxBaseTableMapperDescriptor;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.GetList Method

TnxBaseTableMapperDescriptor.GetList Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.GetTableDescriptorFromName Method

TnxBaseTableMapperDescriptor.GetTableDescriptorFromName Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
function GetTableDescriptorFromName(const aName: string): TnxBaseTableMapperDescriptor;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.GetTableIndexFromName Method

TnxBaseTableMapperDescriptor.GetTableIndexFromName Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
function GetTableIndexFromName(const aName: string): Integer;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.InternalLoadFromReader Method

TnxBaseTableMapperDescriptor.InternalLoadFromReader Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalLoadFromReader(aReader: TnxReader); virtual;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.InternalSaveToWriter Method

TnxBaseTableMapperDescriptor.InternalSaveToWriter Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure InternalSaveToWriter(aWriter: TnxWriter; aClientVersion: Integer); virtual;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.RemoveRecordMapper Method

TnxBaseTableMapperDescriptor.RemoveRecordMapper Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure RemoveRecordMapper;
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


RemoveTable Method

RemoveTable Method
TnxBaseTableMapperDescriptor Methods Send Feedback

This is the overview for the RemoveTable method overload.

Overload List
Name | Description
TnxBaseTableMapperDescriptor.RemoveTable (Integer) |
TnxBaseTableMapperDescriptor.RemoveTable (string) |
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor.RemoveTable Method (Integer)

TnxBaseTableMapperDescriptor.RemoveTable Method (Integer)
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace RemoveTable Method Send Feedback
Syntax
Delphi
procedure RemoveTable(aInx: Integer); overload;
Group

RemoveTable Method

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, RemoveTable Method


TnxBaseTableMapperDescriptor.RemoveTable Method (string)

TnxBaseTableMapperDescriptor.RemoveTable Method (string)
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace RemoveTable Method Send Feedback
Syntax
Delphi
procedure RemoveTable(const aName: string); overload;
Group

RemoveTable Method

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, RemoveTable Method


TnxBaseTableMapperDescriptor.WriteToWriter Method

TnxBaseTableMapperDescriptor.WriteToWriter Method
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Methods Send Feedback
Syntax
Delphi
procedure WriteToWriter(aWriter: TnxWriter; aClientVersion: Integer);
Group

TnxBaseTableMapperDescriptor Methods

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Methods


TnxBaseTableMapperDescriptor Properties

TnxBaseTableMapperDescriptor Properties
TnxBaseTableMapperDescriptor Class Legend Public Properties Send Feedback

The properties of the TnxBaseTableMapperDescriptor class are listed here.

Class

TnxBaseTableMapperDescriptor Class

Public Properties
Name | Description
MapTo | This is MapTo, a member of class TnxBaseTableMapperDescriptor.
Name | This is Name, a member of class TnxBaseTableMapperDescriptor.
Parent | This is Parent, a member of class TnxBaseTableMapperDescriptor.
Links
TnxBaseTableMapperDescriptor Class, Legend, Public Properties


TnxBaseTableMapperDescriptor.MapTo Property

TnxBaseTableMapperDescriptor.MapTo Property
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Properties Send Feedback
Syntax
Delphi
property MapTo: string;
Description

This is MapTo, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Properties

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Properties


TnxBaseTableMapperDescriptor.Name Property

TnxBaseTableMapperDescriptor.Name Property
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Properties Send Feedback
Syntax
Delphi
property Name: string;
Description

This is Name, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Properties

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Properties


TnxBaseTableMapperDescriptor.Parent Property

TnxBaseTableMapperDescriptor.Parent Property
TnxBaseTableMapperDescriptor Class TnxBaseTableMapperDescriptor Members nxsdTableMapperDescriptorBase Namespace TnxBaseTableMapperDescriptor Properties Send Feedback
Syntax
Delphi
property Parent: TnxBaseTableMapperDescriptor;
Description

This is Parent, a member of class TnxBaseTableMapperDescriptor.

Group

TnxBaseTableMapperDescriptor Properties

Links
TnxBaseTableMapperDescriptor Class, TnxBaseTableMapperDescriptor Members, nxsdTableMapperDescriptorBase Namespace, TnxBaseTableMapperDescriptor Properties


Types

Types
nxsdTableMapperDescriptorBase Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdTableMapperDescriptorBase Namespace

Types
Name | Description
TnxBaseTableMapperDescriptorClass | This is type nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptorClass.
Links
nxsdTableMapperDescriptorBase Namespace, Types


nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptorClass Type

nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptorClass Type
nxsdTableMapperDescriptorBase Types Send Feedback
Syntax
Delphi
TnxBaseTableMapperDescriptorClass = class of TnxBaseTableMapperDescriptor;
File

nxsdTableMapperDescriptorBase

Description

This is type nxsdTableMapperDescriptorBase.TnxBaseTableMapperDescriptorClass.

Group

Types

Links
nxsdTableMapperDescriptorBase, Types


Variables

Variables
nxsdTableMapperDescriptorBase Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdTableMapperDescriptorBase Namespace

Variables
Name | Description
_TableMapperDescriptorList | This is variable nxsdTableMapperDescriptorBase._TableMapperDescriptorList.
Links
nxsdTableMapperDescriptorBase Namespace, Variables


nxsdTableMapperDescriptorBase._TableMapperDescriptorList Variable

nxsdTableMapperDescriptorBase._TableMapperDescriptorList Variable
nxsdTableMapperDescriptorBase Variables Send Feedback
Syntax
Delphi
_TableMapperDescriptorList: TStringList;
File

nxsdTableMapperDescriptorBase

Description

This is variable nxsdTableMapperDescriptorBase._TableMapperDescriptorList.

Group

Variables

Links
nxsdTableMapperDescriptorBase, Variables


nxsdTypes Namespace

nxsdTypes Namespace
Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxsdTypes.

Constants
Name | Description
nxcBlobTypes | Constant for pointing to the last Blob field in the field types. For performance reasons.
nxcLocaleTypes | This is constant nxsdTypes.nxcLocaleTypes.
nxcStringTypes | This is constant nxsdTypes.nxcStringTypes.
nxcVariableLengthTypes | This is constant nxsdTypes.nxcVariableLengthTypes.
skaAnyActions | This is constant nxsdTypes.skaAnyActions.
Structs, Records, Enums
Name | Description
TnxBlobCopyMode | Defines if Blobs should be linked, copied or left out of SQL results.
TnxBookmark | Bookmark data definition
TnxClassListType | possible types for class lists
TnxFieldType | NexusDB field types.
TnxIndexPathPosition | Possible positions in an index
TnxInsertOption | This is record nxsdTypes.TnxInsertOption.
TnxKeyIteratorResult | This is record nxsdTypes.TnxKeyIteratorResult.
TnxLockConflictType | Lock type that created a conflict
TnxLockPresent | Used to indicate whether a lock is present in a certain server object.
TnxLockRequestType | Lock request Types
TnxLockResult | Result for lock requests
TnxLockType | Lock Types for NexusDB.
TnxOpenMode | Open modes for opening databases, tables.
TnxParamType | Parameter Types
TnxRecordCountOption | Options for GetRecordCountEx.
TnxRecordGetBatchExOption | Options for the batch mode.
TnxRecordIteratorResult | This is record nxsdTypes.TnxRecordIteratorResult.
TnxSearchKeyAction | Used for quick locating/marking of keys in the SQL and filter engines.
TnxShareMode | Share modes for opening databases, tables.
TnxSqlParamDesc | The following type defines the data needed for a SQL parameter.
TnxStatementType | Type of a Statement
TnxStoredProcParamDesc | The following type defines the data needed for a designtime Stored Proc parameter.
TnxTaskStatus | Task operation status info, the first fields must be identical to TnxTaskStatusPre30500
TnxTaskStatusPre30500 | Task operation status info as send over the wire for versions before 30500
Topics
Name | Description
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBookmark | Pointer to bookmark data
PnxLockResult | Pointer to TnxLockResult
PnxSqlParamDesc | Pointer to TnxSqlParamDesc.
PnxSqlParamList | Pointer to TnxSqlParamList.
TnxBlockSignature | Type for the table block signature. The first 4 characters hold engine and Version information.
TnxCursorID | Strong type for Cursor IDs
TnxDatabaseID | Strong type for Database IDs
TnxFieldTypes | NexusDB field types.
TnxFilterID | Strong type for Filter IDs.
TnxGrowSize | Type for the table grow size.
TnxInsertOptions | This is type nxsdTypes.TnxInsertOptions.
TnxKeyFilterID | Strong type for KeyFilter IDs.
TnxKeyIterator | This is type nxsdTypes.TnxKeyIterator.
TnxRecordGetBatchExOptions | Options for the batch mode.
TnxRecordIterator | This is type nxsdTypes.TnxRecordIterator.
TnxSqlParamList | SQL Parameters.
TnxStatementID | Strong type for Statement IDs.
TnxStoredProcParamList | Stored Proc Parameters.
TnxTaskID | Strong type for Task IDs.
TnxTransContextID | Strong type for transaction context IDs
TnxTransID | Strong type for Transaction IDs.
Links
Constants, Legend, Structs, Records, Enums, Topics, Types


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxsdTypes Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBlobCopyMode | Defines if Blobs should be linked, copied or left out of SQL results.
TnxClassListType | possible types for class lists
TnxFieldType | NexusDB field types.
TnxIndexPathPosition | Possible positions in an index
TnxInsertOption | This is record nxsdTypes.TnxInsertOption.
TnxKeyIteratorResult | This is record nxsdTypes.TnxKeyIteratorResult.
TnxLockConflictType | Lock type that created a conflict
TnxLockPresent | Used to indicate whether a lock is present in a certain server object.
TnxLockRequestType | Lock request Types
TnxLockResult | Result for lock requests
TnxLockType | Lock Types for NexusDB.
TnxOpenMode | Open modes for opening databases, tables.
TnxParamType | Parameter Types
TnxRecordCountOption | Options for GetRecordCountEx.
TnxRecordGetBatchExOption | Options for the batch mode.
TnxRecordIteratorResult | This is record nxsdTypes.TnxRecordIteratorResult.
TnxSearchKeyAction | Used for quick locating/marking of keys in the SQL and filter engines.
TnxShareMode | Share modes for opening databases, tables.
TnxStatementType | Type of a Statement
Namespace

nxsdTypes Namespace

Records
Name | Description
TnxBookmark | Bookmark data definition
TnxSqlParamDesc | The following type defines the data needed for a SQL parameter.
TnxStoredProcParamDesc | The following type defines the data needed for a designtime Stored Proc parameter.
TnxTaskStatus | Task operation status info, the first fields must be identical to TnxTaskStatusPre30500
TnxTaskStatusPre30500 | Task operation status info as send over the wire for versions before 30500
Links
Enumerations, nxsdTypes Namespace, Legend, Records


nxsdTypes.TnxBlobCopyMode Enumeration

nxsdTypes.TnxBlobCopyMode Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlobCopyMode = ( nxbcmNoCopy, nxbcmCopyFull, nxbcmCreateLink );
File

nxsdTypes

Members
Members | Description
nxbcmNoCopy | .. do not handle blobs.
nxbcmCopyFull | .. copy blobs into result set.
nxbcmCreateLink | .. copy reference to blob into result set.
Description

Defines if Blobs should be linked, copied or left out of SQL results.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxBookmark Record

nxsdTypes.TnxBookmark Record
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBookmark = packed record
  bmHash: TnxWord32;
  bmIndexID: Integer;
  bmPos: TnxIndexPathPosition;
  bmKeyValid: Boolean;
  bmDeleted: Boolean;
  bmFill1: Byte;
  bmRefNr: TnxInt64;
  bmKeyLen: Integer;
  bmKey: array [0..1] of Byte;
end;
File

nxsdTypes

Members
Members | Description
bmHash: TnxWord32; | Bookmark Hashcode
bmIndexID: Integer; | ID of index the bookmark belongs to
bmPos: TnxIndexPathPosition; | current position in the index
bmKeyValid: Boolean; | true if the bookmark key is valid
bmDeleted: Boolean; | true if the record of the bookmark was deleted
bmFill1: Byte; | filler byte for alignment
bmRefNr: TnxInt64; | ref nr of the record
bmKeyLen: Integer; | length of bookmark key
bmKey: array [0..1] of Byte; | bookmark key
Description

Bookmark data definition

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxClassListType Enumeration

nxsdTypes.TnxClassListType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxClassListType = ( setAutoIncEngines, setBlobEngines, setIndicesEngines, setEncryptionEngines, setDefaultDescriptors, setValidationDescriptors, setRecordDescriptors, setRIActionDescriptors );
File

nxsdTypes

Members
Members | Description
setAutoIncEngines | list holds AutoInc Engines
setBlobEngines | list holds Blob Engines
setIndicesEngines | list holds Index Engines
setEncryptionEngines | list holds Encryption Engines
setDefaultDescriptors | list holds Default Descriptors
setValidationDescriptors | list holds Validation Descriptors
setRecordDescriptors | list holds Record Descriptors
setRIActionDescriptors | list holds Ref Integrity Action Descriptors
Description

possible types for class lists

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxFieldType Enumeration

nxsdTypes.TnxFieldType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxFieldType = ( nxtBoolean, nxtChar, nxtWideChar, nxtByte, nxtWord16, nxtWord32, nxtInt8, nxtInt16, nxtInt32, nxtInt64, nxtAutoInc, nxtSingle, nxtDouble, nxtExtended, nxtCurrency, nxtDate, nxtTime, nxtDateTime, nxtInterval, nxtBlob, nxtBlobMemo, nxtBlobGraphic, nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtRecRev, nxtGuid, nxtBCD, nxtBlobWideMemo, nxtFmtBCD );
File

nxsdTypes

Members
Members | Description
nxtBoolean | ..8-bit Boolean flag.
nxtChar | ..8-bit character.
nxtWideChar | ..16-bit character (UNICODE).
nxtByte | ..8-bit unsigned Integer).
nxtWord16 | ..16-bit unsigned Integer).
nxtWord32 | ..32-bit unsigned Integer.
nxtInt8 | ..8-bit signed Integer.
nxtInt16 | ..16-bit signed Integer.
nxtInt32 | ..32-bit signed Integer.
nxtInt64 | ..64-bit signed Integer.
nxtAutoInc | ..32-bit unsigned Integer; auto incrementing
nxtSingle | ..IEEE single (4 bytes).
nxtDouble | ..IEEE double (8 bytes).
nxtExtended | ..IEEE extended (10 bytes).
nxtCurrency | ..Delphi currency type (8 bytes, scaled Integer).
nxtDate | ..date type (4 bytes).
nxtTime | ..time type (4 bytes).
nxtDateTime | ..date/time type (8 bytes).
nxtInterval | ..date/time interval type (8 bytes).
nxtBlob | ..variable length BLOB field - general binary data
nxtBlobMemo | ..variable length BLOB field - text memo.
nxtBlobGraphic | ..variable length BLOB field - graphics object
nxtByteArray | ..array of bytes.
nxtShortString | ..length byte string.
nxtNullString | ..null-terminated string.
nxtWideString | ..null-terminated string of wide chars.
nxtRecRev | ..32-bit unsigned Integer; auto incrementing on every record update.
nxtGuid | ..128-bit byte array.
nxtBCD | ..identical to Delphi currency type (8 bytes, scaled Integer).
nxtBlobWideMemo | ..variable length BLOB field - unicode memo.
nxtFmtBCD | ..variable length BCD field
Description

NexusDB field types.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxIndexPathPosition Enumeration

nxsdTypes.TnxIndexPathPosition Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxIndexPathPosition = ( ippUnknown, ippBof, ippOnCrackBefore, ippOnCrackAfter, ippOnKey, ippEof );
File

nxsdTypes

Members
Members | Description
ippUnknown | ..unknown
ippBof | ..before all keys
ippOnCrackBefore | ..in between two keys
ippOnCrackAfter | ..in between two keys
ippOnKey | ..on a key
ippEof | ..after all keys
Description

Possible positions in an index

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxInsertOption Enumeration

nxsdTypes.TnxInsertOption Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxInsertOption = ( ioSetDefault, ioSetAutoInc, ioValidate );
File

nxsdTypes

Description

This is record nxsdTypes.TnxInsertOption.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxKeyIteratorResult Enumeration

nxsdTypes.TnxKeyIteratorResult Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxKeyIteratorResult = ( kirContinue, kirSkipKey, kirStop );
File

nxsdTypes

Description

This is record nxsdTypes.TnxKeyIteratorResult.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxLockConflictType Enumeration

nxsdTypes.TnxLockConflictType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLockConflictType = ( lctUnknown, lctRecordLock, lctReadLock, lctWriteLock, lctTransaction );
File

nxsdTypes

Members
Members | Description
lctUnknown | Unknown
lctRecordLock | Record lock
lctReadLock | Read lock
lctWriteLock | Write Lock
lctTransaction | Transaction based lock
Description

Lock type that created a conflict

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxLockPresent Enumeration

nxsdTypes.TnxLockPresent Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLockPresent = ( lpNotAtAll, lpYesByUs, lpYesByAnother );
File

nxsdTypes

Members
Members | Description
lpNotAtAll | ..no, not at all.
lpYesByUs | ..yes, and by current session.
lpYesByAnother | ..yes, and by another session.
Description

Used to indicate whether a lock is present in a certain server object.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxLockRequestType Enumeration

nxsdTypes.TnxLockRequestType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLockRequestType = ( lrtRecordLock, lrtReadLock, lrtWriteLock );
File

nxsdTypes

Members
Members | Description
lrtRecordLock | Full record lock
lrtReadLock | read only lock
lrtWriteLock | write lock
Description

Lock request Types

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxLockResult Enumeration

nxsdTypes.TnxLockResult Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLockResult = ( lrGrantedNew, lrGrantedExisting, lrConflictUnknown, lrConflictCursorWriteLock, lrConflictCursorReadLockSingle, lrConflictCursorReadLockMultiple, lrConflictCursorRecordLockSingle, lrConflictCursorRecordLockMultiple, lrConflictTransaction );
File

nxsdTypes

Members
Members | Description
lrGrantedNew | new lock granted
lrGrantedExisting | attached to existing lock
lrConflictUnknown | conflich of unknown type
lrConflictCursorWriteLock | conflict due to a write lock
lrConflictCursorReadLockSingle | conflict due to a single read lock
lrConflictCursorReadLockMultiple | conflict due to a multiple read lock
lrConflictCursorRecordLockSingle | conflict due to a record lock
lrConflictCursorRecordLockMultiple | conflict due to a multiple record lock
lrConflictTransaction | conflict due to an open transaction
Description

Result for lock requests

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxLockType Enumeration

nxsdTypes.TnxLockType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxLockType = ( nxltNoLock, nxltReadLock, nxltWriteLock );
File

nxsdTypes

Members
Members | Description
nxltNoLock | ..no lock at all.
nxltReadLock | ..read lock (not for record locks).
nxltWriteLock | ..write lock.
Description

Lock Types for NexusDB.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxOpenMode Enumeration

nxsdTypes.TnxOpenMode Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxOpenMode = ( omReadOnly, omWriteOnly, omReadWrite, omNone );
File

nxsdTypes

Members
Members | Description
omReadOnly | ..read only mode.
omWriteOnly | ..write only mode.
omReadWrite | ..read/write mode.
omNone | ..only valid when executing SQL, if possible, don't return a result set
Description

Open modes for opening databases, tables.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxParamType Enumeration

nxsdTypes.TnxParamType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxParamType = ( nxptUnknown, nxptInput, nxptOutput, nxptInputOutput, nxptResult );
File

nxsdTypes

Members
Members | Description
nxptUnknown | unknown
nxptInput | Input only parameter
nxptOutput | Output only parameter
nxptInputOutput | Input/Output parameter
nxptResult | Parameter defines result
Description

Parameter Types

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxRecordCountOption Enumeration

nxsdTypes.TnxRecordCountOption Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRecordCountOption = ( rcoTotalRecordCount, rcoTotalKeyCount, rcoRangedKeyCount, rcoServerFilteredKeyCount, rcoClientFilteredKeyCount );
File

nxsdTypes

Members
Members | Description
rcoTotalRecordCount | ..total number of records in this table.
rcoTotalKeyCount | ..total number of keys in the current index.
rcoRangedKeyCount | ..number of keys in the current range.
rcoServerFilteredKeyCount | ..number of keys in the current range that have records matching the current server-side filter.
rcoClientFilteredKeyCount | ..number of keys in the current range that have records matching the current server- and client-side filter.
Description

Options for GetRecordCountEx.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxRecordGetBatchExOption Enumeration

nxsdTypes.TnxRecordGetBatchExOption Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRecordGetBatchExOption = ( gboBlobs, gboBookmarks, gboBackwards );
File

nxsdTypes

Members
Members | Description
gboBlobs | handle blobs in batch operation.
gboBookmarks | copy bookmarks in batch operation.
gboBackwards | read backwards instead of forward
Description

Options for the batch mode.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxRecordIteratorResult Enumeration

nxsdTypes.TnxRecordIteratorResult Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxRecordIteratorResult = ( rirContinue, rirStop );
File

nxsdTypes

Description

This is record nxsdTypes.TnxRecordIteratorResult.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxSearchKeyAction Enumeration

nxsdTypes.TnxSearchKeyAction Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSearchKeyAction = ( skaEqualFirst, skaGreaterEqual, skaGreater, skaEqualLast, skaSmallerEqual, skaSmaller, skaAnyEqual, skaAnyGreaterEqual, skaAnyGreater, skaAnySmallerEqual, skaAnySmaller );
File

nxsdTypes

Members
Members | Description
skaEqualFirst | ..first key in index order that is equal.
skaGreaterEqual | ..first key in index order that is equal or greater.
skaGreater | ..first key in index order that is greater.
skaEqualLast | ..last key in index order that is equal.
skaSmallerEqual | ..last key in index order that is equal or smaller.
skaSmaller | ..last key in index order that is smaller.
skaAnyEqual | ..any key that is equal.
skaAnyGreaterEqual | ..any key that is equal or greater.
skaAnyGreater | ..any key that is greater.
skaAnySmallerEqual | ..any key that is equal or smaller.
skaAnySmaller | ..any key that is smaller.
Description

Used for quick locating/marking of keys in the SQL and filter engines.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxShareMode Enumeration

nxsdTypes.TnxShareMode Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxShareMode = ( smExclusive, smShared, smShareRead );
File

nxsdTypes

Members
Members | Description
smExclusive | ..exclusive, no sharing.
smShared | ..allows others to Read or Write.
smShareRead | ..allows others to Read only.
Description

Share modes for opening databases, tables.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxSqlParamDesc Record

nxsdTypes.TnxSqlParamDesc Record
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSqlParamDesc = record
  piParamName: string;
  piParamType: TnxParamType;
  piDataType: TnxFieldType;
  piData: TnxDynByteArray;
end;
File

nxsdTypes

Members
Members | Description
piParamName: string; | ..parameter name.
piParamType: TnxParamType; | ..parameter type.
piDataType: TnxFieldType; | ..data type.
piData: TnxDynByteArray; | ..data.
Description

The following type defines the data needed for a SQL parameter.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxStatementType Enumeration

nxsdTypes.TnxStatementType Enumeration
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStatementType = ( stQuery, stStoredProcedure );
File

nxsdTypes

Members
Members | Description
stQuery | normal Query
stStoredProcedure | Stored Procedure
Description

Type of a Statement

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxStoredProcParamDesc Record

nxsdTypes.TnxStoredProcParamDesc Record
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxStoredProcParamDesc = record
  piParamName: string;
  piParamType: TnxParamType;
  piDataType: TnxFieldType;
  piSize: Integer;
end;
File

nxsdTypes

Members
Members | Description
piParamName: string; | ..parameter name.
piParamType: TnxParamType; | ..parameter type.
piDataType: TnxFieldType; | ..data type.
piSize: Integer; | ..size.
Description

The following type defines the data needed for a designtime Stored Proc parameter.

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxTaskStatus Record

nxsdTypes.TnxTaskStatus Record
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTaskStatus = packed record
  tsStartTime: TnxWord32;
  tsSnapshotTime: TnxWord32;
  tsTotalRecs: TnxWord32;
  tsRecsRead: TnxWord32;
  tsRecsWritten: TnxWord32;
  tsErrorCode: TnxResult;
  tsPercentDone: Byte;
  tsFinished: Boolean;
  tsErrorMessage: string;
end;
File

nxsdTypes

Members
Members | Description
tsStartTime: TnxWord32; | ..start time (tick count from server).
tsSnapshotTime: TnxWord32; | ..snapshot time (tick count from server).
tsTotalRecs: TnxWord32; | ..total count of records to read.
tsRecsRead: TnxWord32; | ..count of records read.
tsRecsWritten: TnxWord32; | ..count of records written.
tsErrorCode: TnxResult; | ..error result for process.
tsPercentDone: Byte; | ..RecsRead*100/TotalRecs.
tsFinished: Boolean; | ..process has finished.
tsErrorMessage: string; | ..error message for error code (if any) NEW IN 3.05.00
Description

Task operation status info, the first fields must be identical to TnxTaskStatusPre30500

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


nxsdTypes.TnxTaskStatusPre30500 Record

nxsdTypes.TnxTaskStatusPre30500 Record
nxsdTypes Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxTaskStatusPre30500 = packed record
  tsStartTime: TnxWord32;
  tsSnapshotTime: TnxWord32;
  tsTotalRecs: TnxWord32;
  tsRecsRead: TnxWord32;
  tsRecsWritten: TnxWord32;
  tsErrorCode: TnxResult;
  tsPercentDone: Byte;
  tsFinished: Boolean;
end;
File

nxsdTypes

Members
Members | Description
tsStartTime: TnxWord32; | ..start time (tick count from server).
tsSnapshotTime: TnxWord32; | ..snapshot time (tick count from server).
tsTotalRecs: TnxWord32; | ..total count of records to read.
tsRecsRead: TnxWord32; | ..count of records read.
tsRecsWritten: TnxWord32; | ..count of records written.
tsErrorCode: TnxResult; | ..error result for process.
tsPercentDone: Byte; | ..RecsRead*100/TotalRecs.
tsFinished: Boolean; | ..process has finished.
Description

Task operation status info as send over the wire for versions before 30500

Group

Structs, Records, Enums

Links
nxsdTypes, Structs, Records, Enums


Types

Types
nxsdTypes Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdTypes Namespace

Types
Name | Description
PnxBookmark | Pointer to bookmark data
PnxLockResult | Pointer to TnxLockResult
PnxSqlParamDesc | Pointer to TnxSqlParamDesc.
PnxSqlParamList | Pointer to TnxSqlParamList.
TnxBlockSignature | Type for the table block signature. The first 4 characters hold engine and Version information.
TnxCursorID | Strong type for Cursor IDs
TnxDatabaseID | Strong type for Database IDs
TnxFieldTypes | NexusDB field types.
TnxFilterID | Strong type for Filter IDs.
TnxGrowSize | Type for the table grow size.
TnxInsertOptions | This is type nxsdTypes.TnxInsertOptions.
TnxKeyFilterID | Strong type for KeyFilter IDs.
TnxKeyIterator | This is type nxsdTypes.TnxKeyIterator.
TnxRecordGetBatchExOptions | Options for the batch mode.
TnxRecordIterator | This is type nxsdTypes.TnxRecordIterator.
TnxSqlParamList | SQL Parameters.
TnxStatementID | Strong type for Statement IDs.
TnxStoredProcParamList | Stored Proc Parameters.
TnxTaskID | Strong type for Task IDs.
TnxTransContextID | Strong type for transaction context IDs
TnxTransID | Strong type for Transaction IDs.
Links
nxsdTypes Namespace, Types


nxsdTypes.PnxBookmark Type

nxsdTypes.PnxBookmark Type
nxsdTypes Types Send Feedback
Syntax
Delphi
PnxBookmark = ^TnxBookmark;
File

nxsdTypes

Description

Pointer to bookmark data

Group

Types

Links
nxsdTypes, Types


nxsdTypes.PnxLockResult Type

nxsdTypes.PnxLockResult Type
nxsdTypes Types Send Feedback
Syntax
Delphi
PnxLockResult = ^TnxLockResult;
File

nxsdTypes

Description

Pointer to TnxLockResult

Group

Types

Links
nxsdTypes, Types


nxsdTypes.PnxSqlParamDesc Type

nxsdTypes.PnxSqlParamDesc Type
nxsdTypes Types Send Feedback
Syntax
Delphi
PnxSqlParamDesc = ^TnxSqlParamDesc;
File

nxsdTypes

Description

Pointer to TnxSqlParamDesc.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.PnxSqlParamList Type

nxsdTypes.PnxSqlParamList Type
nxsdTypes Types Send Feedback
Syntax
Delphi
PnxSqlParamList = ^TnxSqlParamList;
File

nxsdTypes

Description

Pointer to TnxSqlParamList.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxBlockSignature Type

nxsdTypes.TnxBlockSignature Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxBlockSignature = array [0..3] of AnsiChar;
File

nxsdTypes

Description

Type for the table block signature. The first 4 characters hold engine and Version information.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxCursorID Type

nxsdTypes.TnxCursorID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxCursorID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Cursor IDs

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxDatabaseID Type

nxsdTypes.TnxDatabaseID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxDatabaseID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Database IDs

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxFieldTypes Type

nxsdTypes.TnxFieldTypes Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxFieldTypes = set of TnxFieldType;
File

nxsdTypes

Description

NexusDB field types.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxFilterID Type

nxsdTypes.TnxFilterID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxFilterID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Filter IDs.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxGrowSize Type

nxsdTypes.TnxGrowSize Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxGrowSize = 1..High(Integer);
File

nxsdTypes

Description

Type for the table grow size.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxInsertOptions Type

nxsdTypes.TnxInsertOptions Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxInsertOptions = set of TnxInsertOption;
File

nxsdTypes

Description

This is type nxsdTypes.TnxInsertOptions.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxKeyFilterID Type

nxsdTypes.TnxKeyFilterID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxKeyFilterID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for KeyFilter IDs.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxKeyIterator Type

nxsdTypes.TnxKeyIterator Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxKeyIterator = function (aCookie: Pointer; aRefNr: TnxInt64; aKey: PnxByteArray): TnxKeyIteratorResult of object;
File

nxsdTypes

Description

This is type nxsdTypes.TnxKeyIterator.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxRecordGetBatchExOptions Type

nxsdTypes.TnxRecordGetBatchExOptions Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxRecordGetBatchExOptions = set of TnxRecordGetBatchExOption;
File

nxsdTypes

Description

Options for the batch mode.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxRecordIterator Type

nxsdTypes.TnxRecordIterator Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxRecordIterator = function (aCookie: Pointer; aRefNr: TnxInt64; aRecord: PnxByteArray): TnxRecordIteratorResult of object;
File

nxsdTypes

Description

This is type nxsdTypes.TnxRecordIterator.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxSqlParamList Type

nxsdTypes.TnxSqlParamList Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxSqlParamList = array of TnxSqlParamDesc;
File

nxsdTypes

Description

SQL Parameters.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxStatementID Type

nxsdTypes.TnxStatementID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxStatementID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Statement IDs.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxStoredProcParamList Type

nxsdTypes.TnxStoredProcParamList Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxStoredProcParamList = array of TnxStoredProcParamDesc;
File

nxsdTypes

Description

Stored Proc Parameters.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxTaskID Type

nxsdTypes.TnxTaskID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxTaskID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Task IDs.

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxTransContextID Type

nxsdTypes.TnxTransContextID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxTransContextID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for transaction context IDs

Group

Types

Links
nxsdTypes, Types


nxsdTypes.TnxTransID Type

nxsdTypes.TnxTransID Type
nxsdTypes Types Send Feedback
Syntax
Delphi
TnxTransID = type TnxBaseID;
File

nxsdTypes

Description

Strong type for Transaction IDs.

Group

Types

Links
nxsdTypes, Types


Constants

Constants
Constants nxsdTypes Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxcBlobTypes | Constant for pointing to the last Blob field in the field types. For performance reasons.
nxcLocaleTypes | This is constant nxsdTypes.nxcLocaleTypes.
nxcStringTypes | This is constant nxsdTypes.nxcStringTypes.
nxcVariableLengthTypes | This is constant nxsdTypes.nxcVariableLengthTypes.
skaAnyActions | This is constant nxsdTypes.skaAnyActions.
Namespace

nxsdTypes Namespace

Links
Constants, nxsdTypes Namespace


nxsdTypes.nxcBlobTypes Constant

nxsdTypes.nxcBlobTypes Constant
nxsdTypes Constants Send Feedback
Syntax
Delphi
nxcBlobTypes = [nxtBlob..nxtBlobGraphic, nxtBlobWideMemo];
File

nxsdTypes

Description

Constant for pointing to the last Blob field in the field types. For performance reasons.

Group

Constants

Links
nxsdTypes, Constants


nxsdTypes.nxcLocaleTypes Constant

nxsdTypes.nxcLocaleTypes Constant
nxsdTypes Constants Send Feedback
Syntax
Delphi
nxcLocaleTypes = nxcStringTypes + [nxtChar, nxtWideChar];
File

nxsdTypes

Description

This is constant nxsdTypes.nxcLocaleTypes.

Group

Constants

Links
nxsdTypes, Constants


nxsdTypes.nxcStringTypes Constant

nxsdTypes.nxcStringTypes Constant
nxsdTypes Constants Send Feedback
Syntax
Delphi
nxcStringTypes = [nxtShortString, nxtNullString, nxtWideString, nxtBlobMemo, nxtBlobWideMemo];
File

nxsdTypes

Description

This is constant nxsdTypes.nxcStringTypes.

Group

Constants

Links
nxsdTypes, Constants


nxsdTypes.nxcVariableLengthTypes Constant

nxsdTypes.nxcVariableLengthTypes Constant
nxsdTypes Constants Send Feedback
Syntax
Delphi
nxcVariableLengthTypes = [nxtByteArray, nxtShortString, nxtNullString, nxtWideString, nxtFmtBCD];
File

nxsdTypes

Description

This is constant nxsdTypes.nxcVariableLengthTypes.

Group

Constants

Links
nxsdTypes, Constants


nxsdTypes.skaAnyActions Constant

nxsdTypes.skaAnyActions Constant
nxsdTypes Constants Send Feedback
Syntax
Delphi
skaAnyActions = [skaAnyEqual..skaAnySmaller];
File

nxsdTypes

Description

This is constant nxsdTypes.skaAnyActions.

Group

Constants

Links
nxsdTypes, Constants


nxsdValidationEngine Namespace

nxsdValidationEngine Namespace
Classes Constants Legend Topics Types Variables Send Feedback

Validation Engines.

Classes
Name | Description
EnxBaseFieldValidationEngineException | This is class nxsdValidationEngine.EnxBaseFieldValidationEngineException.
EnxBaseSqlCheckStatementException | This is class nxsdValidationEngine.EnxBaseSqlCheckStatementException.
EnxBaseValidationsEngineException | This is class nxsdValidationEngine.EnxBaseValidationsEngineException.
EnxFieldsValidationsEngineException | This is class nxsdValidationEngine.EnxFieldsValidationsEngineException.
EnxFieldValidationsEngineException | This is class nxsdValidationEngine.EnxFieldValidationsEngineException.
EnxMinMaxValidationEngineException | This is class nxsdValidationEngine.EnxMinMaxValidationEngineException.
EnxNoChangeValidationEngineException | This is class nxsdValidationEngine.EnxNoChangeValidationEngineException.
EnxNotNullValidationEngineException | This is class nxsdValidationEngine.EnxNotNullValidationEngineException.
EnxSqlCheckValidationEngineException | This is class nxsdValidationEngine.EnxSqlCheckValidationEngineException.
TnxBaseFieldsValidationEngine | This is class nxsdValidationEngine.TnxBaseFieldsValidationEngine.
TnxBaseFieldValidationEngine | This is class nxsdValidationEngine.TnxBaseFieldValidationEngine.
TnxBaseSqlCheckStatement | This is class nxsdValidationEngine.TnxBaseSqlCheckStatement.
TnxBaseValidationEngine | This is class nxsdValidationEngine.TnxBaseValidationEngine.
TnxBaseValidationsEngine | This is class nxsdValidationEngine.TnxBaseValidationsEngine.
TnxFieldsValidationsEngine | This is class nxsdValidationEngine.TnxFieldsValidationsEngine.
TnxFieldValidationsEngine | This is class nxsdValidationEngine.TnxFieldValidationsEngine.
TnxMinMaxValidationEngine | This is class nxsdValidationEngine.TnxMinMaxValidationEngine.
TnxNoChangeValidationEngine | This is class nxsdValidationEngine.TnxNoChangeValidationEngine.
TnxNotNullValidationEngine | This is class nxsdValidationEngine.TnxNotNullValidationEngine.
TnxSqlCheckValidationEngine | This is class nxsdValidationEngine.TnxSqlCheckValidationEngine.
TnxValidationsHandler | HPPEMIT 'namespace Nxsdvalidationengine' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxBaseValidationsEngine;' HPPEMIT 'class DELPHICLASS TnxFieldValidationsEngine;' HPPEMIT '}'
Constants
Name | Description
csValidation | This is constant nxsdValidationEngine.csValidation.
csValidations | This is constant nxsdValidationEngine.csValidations.
rsSqlCheckNotSupported | This is constant nxsdValidationEngine.rsSqlCheckNotSupported.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
EnxBaseFieldValidationEngineExceptionClass | This is type nxsdValidationEngine.EnxBaseFieldValidationEngineExceptionClass.
TnxBaseValidationEngineClass | This is type nxsdValidationEngine.TnxBaseValidationEngineClass.
TnxFieldsValidationsEngineClass | This is type nxsdValidationEngine.TnxFieldsValidationsEngineClass.
TnxFieldValidationsEngineClass | This is type nxsdValidationEngine.TnxFieldValidationsEngineClass.
TnxSqlCheckStatementClass | This is type nxsdValidationEngine.TnxSqlCheckStatementClass.
Variables
Name | Description
_FieldsValidationsEngineList | This is variable nxsdValidationEngine._FieldsValidationsEngineList.
_FieldValidationsEngineList | This is variable nxsdValidationEngine._FieldValidationsEngineList.
_ValidationEngineList | This is variable nxsdValidationEngine._ValidationEngineList.
SqlCheckStatementClass | This is variable nxsdValidationEngine.SqlCheckStatementClass.
Links
Classes, Constants, Legend, Topics, Types, Variables


Classes

Classes
Classes nxsdValidationEngine Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseFieldValidationEngineException | This is class nxsdValidationEngine.EnxBaseFieldValidationEngineException.
EnxBaseSqlCheckStatementException | This is class nxsdValidationEngine.EnxBaseSqlCheckStatementException.
EnxBaseValidationsEngineException | This is class nxsdValidationEngine.EnxBaseValidationsEngineException.
EnxFieldsValidationsEngineException | This is class nxsdValidationEngine.EnxFieldsValidationsEngineException.
EnxFieldValidationsEngineException | This is class nxsdValidationEngine.EnxFieldValidationsEngineException.
EnxMinMaxValidationEngineException | This is class nxsdValidationEngine.EnxMinMaxValidationEngineException.
EnxNoChangeValidationEngineException | This is class nxsdValidationEngine.EnxNoChangeValidationEngineException.
EnxNotNullValidationEngineException | This is class nxsdValidationEngine.EnxNotNullValidationEngineException.
EnxSqlCheckValidationEngineException | This is class nxsdValidationEngine.EnxSqlCheckValidationEngineException.
TnxBaseFieldsValidationEngine | This is class nxsdValidationEngine.TnxBaseFieldsValidationEngine.
TnxBaseFieldValidationEngine | This is class nxsdValidationEngine.TnxBaseFieldValidationEngine.
TnxBaseSqlCheckStatement | This is class nxsdValidationEngine.TnxBaseSqlCheckStatement.
TnxBaseValidationEngine | This is class nxsdValidationEngine.TnxBaseValidationEngine.
TnxBaseValidationsEngine | This is class nxsdValidationEngine.TnxBaseValidationsEngine.
TnxFieldsValidationsEngine | This is class nxsdValidationEngine.TnxFieldsValidationsEngine.
TnxFieldValidationsEngine | This is class nxsdValidationEngine.TnxFieldValidationsEngine.
TnxMinMaxValidationEngine | This is class nxsdValidationEngine.TnxMinMaxValidationEngine.
TnxNoChangeValidationEngine | This is class nxsdValidationEngine.TnxNoChangeValidationEngine.
TnxNotNullValidationEngine | This is class nxsdValidationEngine.TnxNotNullValidationEngine.
TnxSqlCheckValidationEngine | This is class nxsdValidationEngine.TnxSqlCheckValidationEngine.
TnxValidationsHandler | HPPEMIT 'namespace Nxsdvalidationengine' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxBaseValidationsEngine;' HPPEMIT 'class DELPHICLASS TnxFieldValidationsEngine;' HPPEMIT '}'
Namespace

nxsdValidationEngine Namespace

Links
Classes, nxsdValidationEngine Namespace, Legend


EnxBaseFieldValidationEngineException Class

EnxBaseFieldValidationEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxBaseFieldValidationEngineExceptionnxsdValidationEngine_EnxBaseFieldValidationEngineExceptionnxsdValidationEngine_EnxBaseFieldValidationEngineExceptionnxsdValidationEngine_EnxBaseFieldValidationEngineExceptionnxsdValidationEngine_EnxBaseFieldValidationEngineException
Syntax
Delphi
EnxBaseFieldValidationEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxBaseFieldValidationEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxBaseSqlCheckStatementException Class

EnxBaseSqlCheckStatementException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxBaseSqlCheckStatementExceptionnxsdValidationEngine_EnxBaseSqlCheckStatementExceptionnxsdValidationEngine_EnxBaseSqlCheckStatementExceptionnxsdValidationEngine_EnxBaseSqlCheckStatementException
Syntax
Delphi
EnxBaseSqlCheckStatementException = class(EnxBaseException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxBaseSqlCheckStatementException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxBaseValidationsEngineException Class

EnxBaseValidationsEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxBaseValidationsEngineExceptionnxsdValidationEngine_EnxBaseValidationsEngineExceptionnxsdValidationEngine_EnxBaseValidationsEngineExceptionnxsdValidationEngine_EnxBaseValidationsEngineExceptionnxsdValidationEngine_EnxBaseValidationsEngineException
Syntax
Delphi
EnxBaseValidationsEngineException = class(EnxBaseRegisterableEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxBaseValidationsEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxFieldsValidationsEngineException Class

EnxFieldsValidationsEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxFieldsValidationsEngineExceptionnxsdValidationEngine_EnxFieldsValidationsEngineExceptionnxsdValidationEngine_EnxFieldsValidationsEngineExceptionnxsdValidationEngine_EnxFieldsValidationsEngineExceptionnxsdValidationEngine_EnxFieldsValidationsEngineExceptionnxsdValidationEngine_EnxFieldsValidationsEngineException
Syntax
Delphi
EnxFieldsValidationsEngineException = class(EnxBaseValidationsEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxFieldsValidationsEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxFieldValidationsEngineException Class

EnxFieldValidationsEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxFieldValidationsEngineExceptionnxsdValidationEngine_EnxFieldValidationsEngineExceptionnxsdValidationEngine_EnxFieldValidationsEngineExceptionnxsdValidationEngine_EnxFieldValidationsEngineExceptionnxsdValidationEngine_EnxFieldValidationsEngineExceptionnxsdValidationEngine_EnxFieldValidationsEngineException
Syntax
Delphi
EnxFieldValidationsEngineException = class(EnxBaseValidationsEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxFieldValidationsEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxMinMaxValidationEngineException Class

EnxMinMaxValidationEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxMinMaxValidationEngineExceptionnxsdValidationEngine_EnxMinMaxValidationEngineExceptionnxsdValidationEngine_EnxMinMaxValidationEngineExceptionnxsdValidationEngine_EnxMinMaxValidationEngineExceptionnxsdValidationEngine_EnxMinMaxValidationEngineExceptionnxsdValidationEngine_EnxMinMaxValidationEngineException
Syntax
Delphi
EnxMinMaxValidationEngineException = class(EnxBaseFieldValidationEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxMinMaxValidationEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxNoChangeValidationEngineException Class

EnxNoChangeValidationEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxNoChangeValidationEngineExceptionnxsdValidationEngine_EnxNoChangeValidationEngineExceptionnxsdValidationEngine_EnxNoChangeValidationEngineExceptionnxsdValidationEngine_EnxNoChangeValidationEngineExceptionnxsdValidationEngine_EnxNoChangeValidationEngineExceptionnxsdValidationEngine_EnxNoChangeValidationEngineException
Syntax
Delphi
EnxNoChangeValidationEngineException = class(EnxBaseFieldValidationEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxNoChangeValidationEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxNotNullValidationEngineException Class

EnxNotNullValidationEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxNotNullValidationEngineExceptionnxsdValidationEngine_EnxNotNullValidationEngineExceptionnxsdValidationEngine_EnxNotNullValidationEngineExceptionnxsdValidationEngine_EnxNotNullValidationEngineExceptionnxsdValidationEngine_EnxNotNullValidationEngineExceptionnxsdValidationEngine_EnxNotNullValidationEngineException
Syntax
Delphi
EnxNotNullValidationEngineException = class(EnxBaseFieldValidationEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxNotNullValidationEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


EnxSqlCheckValidationEngineException Class

EnxSqlCheckValidationEngineException Class
nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_EnxSqlCheckValidationEngineExceptionnxsdValidationEngine_EnxSqlCheckValidationEngineExceptionnxsdValidationEngine_EnxSqlCheckValidationEngineExceptionnxsdValidationEngine_EnxSqlCheckValidationEngineExceptionnxsdValidationEngine_EnxSqlCheckValidationEngineExceptionnxsdValidationEngine_EnxSqlCheckValidationEngineException
Syntax
Delphi
EnxSqlCheckValidationEngineException = class(EnxBaseFieldValidationEngineException);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.EnxSqlCheckValidationEngineException.

Group

Classes

Links
nxsdValidationEngine, Classes


TnxBaseFieldsValidationEngine Class

TnxBaseFieldsValidationEngine Class
TnxBaseFieldsValidationEngine Methods TnxBaseFieldsValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxBaseFieldsValidationEnginenxsdValidationEngine_TnxBaseFieldsValidationEnginenxsdValidationEngine_TnxBaseFieldsValidationEnginenxsdValidationEngine_TnxBaseFieldsValidationEnginenxsdValidationEngine_TnxBaseFieldsValidationEnginenxsdValidationEngine_TnxBaseFieldsValidationEngine
Syntax
Delphi
TnxBaseFieldsValidationEngine = class(TnxBaseFieldValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxBaseFieldsValidationEngine.

Group

Classes

Links
TnxBaseFieldsValidationEngine Methods, TnxBaseFieldsValidationEngine Members, nxsdValidationEngine, Classes


TnxBaseFieldsValidationEngine Members

TnxBaseFieldsValidationEngine Members
TnxBaseFieldsValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFieldsValidationEngine.

Class

TnxBaseFieldsValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | This is bfvGetExceptionClass, a member of class TnxBaseFieldValidationEngine.
bfvRaiseValidationError | TnxBaseFieldsValidationEngine
Create |
Create | TnxBaseValidationEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField | This is ValidateField, a member of class TnxBaseFieldValidationEngine.
ValidateRecord | This is ValidateRecord, a member of class TnxBaseFieldsValidationEngine.
Links
TnxBaseFieldsValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseFieldsValidationEngine Methods

TnxBaseFieldsValidationEngine Methods
TnxBaseFieldsValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFieldsValidationEngine class are listed here.

Class

TnxBaseFieldsValidationEngine Class

Protected Methods
Name | Description
bfvRaiseValidationError | TnxBaseFieldsValidationEngine
Public Methods
Name | Description
ValidateRecord | This is ValidateRecord, a member of class TnxBaseFieldsValidationEngine.
Links
TnxBaseFieldsValidationEngine Class, Legend, Protected Methods, Public Methods


TnxBaseFieldsValidationEngine.bfvRaiseValidationError Method

TnxBaseFieldsValidationEngine.bfvRaiseValidationError Method
TnxBaseFieldsValidationEngine Class TnxBaseFieldsValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldsValidationEngine Methods Send Feedback
Syntax
Delphi
procedure bfvRaiseValidationError(aError: TnxResult); override;
Description

TnxBaseFieldsValidationEngine

Group

TnxBaseFieldsValidationEngine Methods

Links
TnxBaseFieldsValidationEngine Class, TnxBaseFieldsValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldsValidationEngine Methods


TnxBaseFieldsValidationEngine.ValidateRecord Method

TnxBaseFieldsValidationEngine.ValidateRecord Method
TnxBaseFieldsValidationEngine Class TnxBaseFieldsValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldsValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); virtual; abstract;
Description

This is ValidateRecord, a member of class TnxBaseFieldsValidationEngine.

Group

TnxBaseFieldsValidationEngine Methods

Links
TnxBaseFieldsValidationEngine Class, TnxBaseFieldsValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldsValidationEngine Methods


TnxBaseFieldValidationEngine Class

TnxBaseFieldValidationEngine Class
TnxBaseFieldValidationEngine Fields TnxBaseFieldValidationEngine Methods TnxBaseFieldValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxBaseFieldValidationEnginenxsdValidationEngine_TnxBaseFieldValidationEnginenxsdValidationEngine_TnxBaseFieldValidationEnginenxsdValidationEngine_TnxBaseFieldValidationEnginenxsdValidationEngine_TnxBaseFieldValidationEngine
Syntax
Delphi
TnxBaseFieldValidationEngine = class(TnxBaseValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxBaseFieldValidationEngine.

Group

Classes

Links
TnxBaseFieldValidationEngine Fields, TnxBaseFieldValidationEngine Methods, TnxBaseFieldValidationEngine Members, nxsdValidationEngine, Classes


TnxBaseFieldValidationEngine Members

TnxBaseFieldValidationEngine Members
TnxBaseFieldValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseFieldValidationEngine.

Class

TnxBaseFieldValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | This is bfvGetExceptionClass, a member of class TnxBaseFieldValidationEngine.
bfvRaiseValidationError |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField | This is ValidateField, a member of class TnxBaseFieldValidationEngine.
Links
TnxBaseFieldValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseFieldValidationEngine.Create Constructor

TnxBaseFieldValidationEngine.Create Constructor
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); override;
Class

TnxBaseFieldValidationEngine Class

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Class


TnxBaseFieldValidationEngine Fields

TnxBaseFieldValidationEngine Fields
TnxBaseFieldValidationEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseFieldValidationEngine class are listed here.

Class

TnxBaseFieldValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
Links
TnxBaseFieldValidationEngine Class, Legend, Protected Fields


TnxBaseFieldValidationEngine.bfvFieldName Field

TnxBaseFieldValidationEngine.bfvFieldName Field
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Fields Send Feedback
Syntax
Delphi
bfvFieldName: string;
Description

private

Group

TnxBaseFieldValidationEngine Fields

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Fields


TnxBaseFieldValidationEngine Methods

TnxBaseFieldValidationEngine Methods
TnxBaseFieldValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseFieldValidationEngine class are listed here.

Class

TnxBaseFieldValidationEngine Class

Protected Methods
Name | Description
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | This is bfvGetExceptionClass, a member of class TnxBaseFieldValidationEngine.
bfvRaiseValidationError |
Public Methods
Name | Description
ValidateField | This is ValidateField, a member of class TnxBaseFieldValidationEngine.
Links
TnxBaseFieldValidationEngine Class, Legend, Protected Methods, Public Methods


TnxBaseFieldValidationEngine.bfvGetErrorMessage Method

TnxBaseFieldValidationEngine.bfvGetErrorMessage Method
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetErrorMessage: string; virtual;
Description

TnxBaseFieldValidationEngine

Group

TnxBaseFieldValidationEngine Methods

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Methods


TnxBaseFieldValidationEngine.bfvGetExceptionClass Method

TnxBaseFieldValidationEngine.bfvGetExceptionClass Method
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetExceptionClass: EnxBaseFieldValidationEngineExceptionClass; virtual; abstract;
Description

This is bfvGetExceptionClass, a member of class TnxBaseFieldValidationEngine.

Group

TnxBaseFieldValidationEngine Methods

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Methods


TnxBaseFieldValidationEngine.bfvRaiseValidationError Method

TnxBaseFieldValidationEngine.bfvRaiseValidationError Method
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Methods Send Feedback
Syntax
Delphi
procedure bfvRaiseValidationError(aError: TnxResult); virtual;
Group

TnxBaseFieldValidationEngine Methods

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Methods


TnxBaseFieldValidationEngine.ValidateField Method

TnxBaseFieldValidationEngine.ValidateField Method
TnxBaseFieldValidationEngine Class TnxBaseFieldValidationEngine Members nxsdValidationEngine Namespace TnxBaseFieldValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray); virtual; abstract;
Description

This is ValidateField, a member of class TnxBaseFieldValidationEngine.

Group

TnxBaseFieldValidationEngine Methods

Links
TnxBaseFieldValidationEngine Class, TnxBaseFieldValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseFieldValidationEngine Methods


TnxBaseSqlCheckStatement Class

TnxBaseSqlCheckStatement Class
TnxBaseSqlCheckStatement Fields TnxBaseSqlCheckStatement Methods TnxBaseSqlCheckStatement Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxBaseSqlCheckStatementnxsdValidationEngine_TnxBaseSqlCheckStatement
Syntax
Delphi
TnxBaseSqlCheckStatement = class(TnxObject);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxBaseSqlCheckStatement.

Group

Classes

Links
TnxBaseSqlCheckStatement Fields, TnxBaseSqlCheckStatement Methods, TnxBaseSqlCheckStatement Members, nxsdValidationEngine, Classes


TnxBaseSqlCheckStatement Members

TnxBaseSqlCheckStatement Members
TnxBaseSqlCheckStatement Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseSqlCheckStatement.

Class

TnxBaseSqlCheckStatement Class

Protected Fields
Name | Description
bscsCursor | This is bscsCursor, a member of class TnxBaseSqlCheckStatement.
bscsFieldCodepage | This is bscsFieldCodepage, a member of class TnxBaseSqlCheckStatement.
bscsFieldDecPl | This is bscsFieldDecPl, a member of class TnxBaseSqlCheckStatement.
bscsFieldDescriptor | This is bscsFieldDescriptor, a member of class TnxBaseSqlCheckStatement.
bscsFieldIndex | This is bscsFieldIndex, a member of class TnxBaseSqlCheckStatement.
bscsFieldsDescriptor | This is bscsFieldsDescriptor, a member of class TnxBaseSqlCheckStatement.
bscsFieldSize | This is bscsFieldSize, a member of class TnxBaseSqlCheckStatement.
bscsFieldType | This is bscsFieldType, a member of class TnxBaseSqlCheckStatement.
bscsFieldUnits | This is bscsFieldUnits, a member of class TnxBaseSqlCheckStatement.
bscsNewField | This is bscsNewField, a member of class TnxBaseSqlCheckStatement.
bscsNewRecord | This is bscsNewRecord, a member of class TnxBaseSqlCheckStatement.
bscsOldField | This is bscsOldField, a member of class TnxBaseSqlCheckStatement.
bscsOldRecord | This is bscsOldRecord, a member of class TnxBaseSqlCheckStatement.
Protected Methods
Name | Description
BlobAsVariant | TnxBaseSqlCheckStatement
BlobsSupported |
Evaluate | This is Evaluate, a member of class TnxBaseSqlCheckStatement.
GetExtColumnDef |
GetExtColumnValue |
Public Methods
Name | Description
Create |
FreeInstance |
NewInstance | TnxObject
ValidateField |
Links
TnxBaseSqlCheckStatement Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseSqlCheckStatement.Create Constructor

TnxBaseSqlCheckStatement.Create Constructor
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDescriptor: TnxFieldDescriptor; aCursor: TnxAbstractCursor; const aSqlText: WideString); virtual;
Class

TnxBaseSqlCheckStatement Class

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Class


TnxBaseSqlCheckStatement Fields

TnxBaseSqlCheckStatement Fields
TnxBaseSqlCheckStatement Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSqlCheckStatement class are listed here.

Class

TnxBaseSqlCheckStatement Class

Protected Fields
Name | Description
bscsCursor | This is bscsCursor, a member of class TnxBaseSqlCheckStatement.
bscsFieldCodepage | This is bscsFieldCodepage, a member of class TnxBaseSqlCheckStatement.
bscsFieldDecPl | This is bscsFieldDecPl, a member of class TnxBaseSqlCheckStatement.
bscsFieldDescriptor | This is bscsFieldDescriptor, a member of class TnxBaseSqlCheckStatement.
bscsFieldIndex | This is bscsFieldIndex, a member of class TnxBaseSqlCheckStatement.
bscsFieldsDescriptor | This is bscsFieldsDescriptor, a member of class TnxBaseSqlCheckStatement.
bscsFieldSize | This is bscsFieldSize, a member of class TnxBaseSqlCheckStatement.
bscsFieldType | This is bscsFieldType, a member of class TnxBaseSqlCheckStatement.
bscsFieldUnits | This is bscsFieldUnits, a member of class TnxBaseSqlCheckStatement.
bscsNewField | This is bscsNewField, a member of class TnxBaseSqlCheckStatement.
bscsNewRecord | This is bscsNewRecord, a member of class TnxBaseSqlCheckStatement.
bscsOldField | This is bscsOldField, a member of class TnxBaseSqlCheckStatement.
bscsOldRecord | This is bscsOldRecord, a member of class TnxBaseSqlCheckStatement.
Links
TnxBaseSqlCheckStatement Class, Legend, Protected Fields


TnxBaseSqlCheckStatement.bscsCursor Field

TnxBaseSqlCheckStatement.bscsCursor Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsCursor: TnxAbstractCursor;
Description

This is bscsCursor, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldCodepage Field

TnxBaseSqlCheckStatement.bscsFieldCodepage Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldCodepage: TnxWord16;
Description

This is bscsFieldCodepage, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldDecPl Field

TnxBaseSqlCheckStatement.bscsFieldDecPl Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldDecPl: Integer;
Description

This is bscsFieldDecPl, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldDescriptor Field

TnxBaseSqlCheckStatement.bscsFieldDescriptor Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldDescriptor: TnxFieldDescriptor;
Description

This is bscsFieldDescriptor, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldIndex Field

TnxBaseSqlCheckStatement.bscsFieldIndex Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldIndex: Integer;
Description

This is bscsFieldIndex, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldsDescriptor Field

TnxBaseSqlCheckStatement.bscsFieldsDescriptor Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldsDescriptor: TnxFieldsDescriptor;
Description

This is bscsFieldsDescriptor, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldSize Field

TnxBaseSqlCheckStatement.bscsFieldSize Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldSize: Integer;
Description

This is bscsFieldSize, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldType Field

TnxBaseSqlCheckStatement.bscsFieldType Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldType: TnxFieldType;
Description

This is bscsFieldType, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsFieldUnits Field

TnxBaseSqlCheckStatement.bscsFieldUnits Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsFieldUnits: Integer;
Description

This is bscsFieldUnits, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsNewField Field

TnxBaseSqlCheckStatement.bscsNewField Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsNewField: PnxByteArray;
Description

This is bscsNewField, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsNewRecord Field

TnxBaseSqlCheckStatement.bscsNewRecord Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsNewRecord: PnxByteArray;
Description

This is bscsNewRecord, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsOldField Field

TnxBaseSqlCheckStatement.bscsOldField Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsOldField: PnxByteArray;
Description

This is bscsOldField, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement.bscsOldRecord Field

TnxBaseSqlCheckStatement.bscsOldRecord Field
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Fields Send Feedback
Syntax
Delphi
bscsOldRecord: PnxByteArray;
Description

This is bscsOldRecord, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Fields

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Fields


TnxBaseSqlCheckStatement Methods

TnxBaseSqlCheckStatement Methods
TnxBaseSqlCheckStatement Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSqlCheckStatement class are listed here.

Class

TnxBaseSqlCheckStatement Class

Protected Methods
Name | Description
BlobAsVariant | TnxBaseSqlCheckStatement
BlobsSupported |
Evaluate | This is Evaluate, a member of class TnxBaseSqlCheckStatement.
GetExtColumnDef |
GetExtColumnValue |
Public Methods
Name | Description
ValidateField |
Links
TnxBaseSqlCheckStatement Class, Legend, Protected Methods, Public Methods


TnxBaseSqlCheckStatement.BlobAsVariant Method

TnxBaseSqlCheckStatement.BlobAsVariant Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function BlobAsVariant(aField: TnxFieldDescriptor; aRefNr: TnxInt64; aOldValue: Boolean): Variant; virtual;
Description

TnxBaseSqlCheckStatement

Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseSqlCheckStatement.BlobsSupported Method

TnxBaseSqlCheckStatement.BlobsSupported Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function BlobsSupported: Boolean; virtual;
Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseSqlCheckStatement.Evaluate Method

TnxBaseSqlCheckStatement.Evaluate Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function Evaluate: Boolean; virtual; abstract;
Description

This is Evaluate, a member of class TnxBaseSqlCheckStatement.

Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseSqlCheckStatement.GetExtColumnDef Method

TnxBaseSqlCheckStatement.GetExtColumnDef Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function GetExtColumnDef(const aColumnName: string; var aColType: TnxFieldType; var aColSize: Integer; var aColDec: Integer; var aColLocDesc: TnxLocaleDescriptor): Integer;
Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseSqlCheckStatement.GetExtColumnValue Method

TnxBaseSqlCheckStatement.GetExtColumnValue Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function GetExtColumnValue(aIndex: Integer): Variant;
Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseSqlCheckStatement.ValidateField Method

TnxBaseSqlCheckStatement.ValidateField Method
TnxBaseSqlCheckStatement Class TnxBaseSqlCheckStatement Members nxsdValidationEngine Namespace TnxBaseSqlCheckStatement Methods Send Feedback
Syntax
Delphi
function ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray): Boolean;
Group

TnxBaseSqlCheckStatement Methods

Links
TnxBaseSqlCheckStatement Class, TnxBaseSqlCheckStatement Members, nxsdValidationEngine Namespace, TnxBaseSqlCheckStatement Methods


TnxBaseValidationEngine Class

TnxBaseValidationEngine Class
TnxBaseValidationEngine Fields TnxBaseValidationEngine Methods TnxBaseValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxBaseValidationEnginenxsdValidationEngine_TnxBaseValidationEnginenxsdValidationEngine_TnxBaseValidationEnginenxsdValidationEngine_TnxBaseValidationEngine
Syntax
Delphi
TnxBaseValidationEngine = class(TnxBaseRegisterableEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxBaseValidationEngine.

Group

Classes

Links
TnxBaseValidationEngine Fields, TnxBaseValidationEngine Methods, TnxBaseValidationEngine Members, nxsdValidationEngine, Classes


TnxBaseValidationEngine Members

TnxBaseValidationEngine Members
TnxBaseValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseValidationEngine.

Class

TnxBaseValidationEngine Class

Protected Fields
Name | Description
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxBaseValidationEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Links
TnxBaseValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseValidationEngine.Create Constructor

TnxBaseValidationEngine.Create Constructor
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); virtual;
Description

TnxBaseValidationEngine

Class

TnxBaseValidationEngine Class

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Class


TnxBaseValidationEngine Fields

TnxBaseValidationEngine Fields
TnxBaseValidationEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseValidationEngine class are listed here.

Class

TnxBaseValidationEngine Class

Protected Fields
Name | Description
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
Links
TnxBaseValidationEngine Class, Legend, Protected Fields


TnxBaseValidationEngine.bveCursor Field

TnxBaseValidationEngine.bveCursor Field
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Fields Send Feedback
Syntax
Delphi
bveCursor: TnxAbstractCursor;
Description

This is bveCursor, a member of class TnxBaseValidationEngine.

Group

TnxBaseValidationEngine Fields

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Fields


TnxBaseValidationEngine.bveDescriptor Field

TnxBaseValidationEngine.bveDescriptor Field
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Fields Send Feedback
Syntax
Delphi
bveDescriptor: TnxBaseFieldValidationDescriptor;
Description

This is bveDescriptor, a member of class TnxBaseValidationEngine.

Group

TnxBaseValidationEngine Fields

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Fields


TnxBaseValidationEngine.bveName Field

TnxBaseValidationEngine.bveName Field
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Fields Send Feedback
Syntax
Delphi
bveName: string;
Description

This is bveName, a member of class TnxBaseValidationEngine.

Group

TnxBaseValidationEngine Fields

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Fields


TnxBaseValidationEngine.bveParent Field

TnxBaseValidationEngine.bveParent Field
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Fields Send Feedback
Syntax
Delphi
bveParent: TnxBaseValidationsEngine;
Description

private

Group

TnxBaseValidationEngine Fields

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Fields


TnxBaseValidationEngine Methods

TnxBaseValidationEngine Methods
TnxBaseValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseValidationEngine class are listed here.

Class

TnxBaseValidationEngine Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
CreateFor |
Links
TnxBaseValidationEngine Class, Legend, Protected Methods, Public Methods


TnxBaseValidationEngine.CreateFor Method

TnxBaseValidationEngine.CreateFor Method
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor): TnxBaseValidationEngine;
Group

TnxBaseValidationEngine Methods

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Methods


TnxBaseValidationEngine.GetList Method

TnxBaseValidationEngine.GetList Method
TnxBaseValidationEngine Class TnxBaseValidationEngine Members nxsdValidationEngine Namespace TnxBaseValidationEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseValidationEngine Methods

Links
TnxBaseValidationEngine Class, TnxBaseValidationEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationEngine Methods


TnxBaseValidationsEngine Class

TnxBaseValidationsEngine Class
TnxBaseValidationsEngine Fields TnxBaseValidationsEngine Methods TnxBaseValidationsEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxBaseValidationsEnginenxsdValidationEngine_TnxBaseValidationsEnginenxsdValidationEngine_TnxBaseValidationsEnginenxsdValidationEngine_TnxBaseValidationsEngine
Syntax
Delphi
TnxBaseValidationsEngine = class(TnxBaseRegisterableEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxBaseValidationsEngine.

Group

Classes

Links
TnxBaseValidationsEngine Fields, TnxBaseValidationsEngine Methods, TnxBaseValidationsEngine Members, nxsdValidationEngine, Classes


TnxBaseValidationsEngine Members

TnxBaseValidationsEngine Members
TnxBaseValidationsEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBaseValidationsEngine.

Class

TnxBaseValidationsEngine Class

Protected Fields
Name | Description
bveFieldsDescriptor | private
Protected Methods
Name | Description
_AddRef |
_Release |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateRecord | This is ValidateRecord, a member of class TnxBaseValidationsEngine.
Links
TnxBaseValidationsEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxBaseValidationsEngine Fields

TnxBaseValidationsEngine Fields
TnxBaseValidationsEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseValidationsEngine class are listed here.

Class

TnxBaseValidationsEngine Class

Protected Fields
Name | Description
bveFieldsDescriptor | private
Links
TnxBaseValidationsEngine Class, Legend, Protected Fields


TnxBaseValidationsEngine.bveFieldsDescriptor Field

TnxBaseValidationsEngine.bveFieldsDescriptor Field
TnxBaseValidationsEngine Class TnxBaseValidationsEngine Members nxsdValidationEngine Namespace TnxBaseValidationsEngine Fields Send Feedback
Syntax
Delphi
bveFieldsDescriptor: TnxFieldsDescriptor;
Description

private

Group

TnxBaseValidationsEngine Fields

Links
TnxBaseValidationsEngine Class, TnxBaseValidationsEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationsEngine Fields


TnxBaseValidationsEngine Methods

TnxBaseValidationsEngine Methods
TnxBaseValidationsEngine Class Legend Public Methods Send Feedback

The methods of the TnxBaseValidationsEngine class are listed here.

Class

TnxBaseValidationsEngine Class

Public Methods
Name | Description
ValidateRecord | This is ValidateRecord, a member of class TnxBaseValidationsEngine.
Links
TnxBaseValidationsEngine Class, Legend, Public Methods


TnxBaseValidationsEngine.ValidateRecord Method

TnxBaseValidationsEngine.ValidateRecord Method
TnxBaseValidationsEngine Class TnxBaseValidationsEngine Members nxsdValidationEngine Namespace TnxBaseValidationsEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); virtual; abstract;
Description

This is ValidateRecord, a member of class TnxBaseValidationsEngine.

Group

TnxBaseValidationsEngine Methods

Links
TnxBaseValidationsEngine Class, TnxBaseValidationsEngine Members, nxsdValidationEngine Namespace, TnxBaseValidationsEngine Methods


TnxFieldsValidationsEngine Class

TnxFieldsValidationsEngine Class
TnxFieldsValidationsEngine Fields TnxFieldsValidationsEngine Methods TnxFieldsValidationsEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxFieldsValidationsEnginenxsdValidationEngine_TnxFieldsValidationsEnginenxsdValidationEngine_TnxFieldsValidationsEnginenxsdValidationEngine_TnxFieldsValidationsEnginenxsdValidationEngine_TnxFieldsValidationsEngine
Syntax
Delphi
TnxFieldsValidationsEngine = class(TnxBaseValidationsEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxFieldsValidationsEngine.

Group

Classes

Links
TnxFieldsValidationsEngine Fields, TnxFieldsValidationsEngine Methods, TnxFieldsValidationsEngine Members, nxsdValidationEngine, Classes


TnxFieldsValidationsEngine Members

TnxFieldsValidationsEngine Members
TnxFieldsValidationsEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFieldsValidationsEngine.

Class

TnxFieldsValidationsEngine Class

Protected Fields
Name | Description
bveFieldsDescriptor | private
veEngines | This is veEngines, a member of class TnxFieldsValidationsEngine.
veFieldsValidationsDescriptor | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxFieldsValidationsEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
veCreateEngines |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateRecord |
Links
TnxFieldsValidationsEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxFieldsValidationsEngine.Create Constructor

TnxFieldsValidationsEngine.Create Constructor
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsDescriptor: TnxFieldsDescriptor; aFieldsValidationsDescriptor: TnxFieldsValidationsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor); virtual;
Description

TnxFieldsValidationsEngine

Class

TnxFieldsValidationsEngine Class

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Class


TnxFieldsValidationsEngine.Destroy Destructor

TnxFieldsValidationsEngine.Destroy Destructor
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFieldsValidationsEngine Class

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Class


TnxFieldsValidationsEngine Fields

TnxFieldsValidationsEngine Fields
TnxFieldsValidationsEngine Class Legend Protected Fields Send Feedback

The fields of the TnxFieldsValidationsEngine class are listed here.

Class

TnxFieldsValidationsEngine Class

Protected Fields
Name | Description
veEngines | This is veEngines, a member of class TnxFieldsValidationsEngine.
veFieldsValidationsDescriptor | private
Links
TnxFieldsValidationsEngine Class, Legend, Protected Fields


TnxFieldsValidationsEngine.veEngines Field

TnxFieldsValidationsEngine.veEngines Field
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Fields Send Feedback
Syntax
Delphi
veEngines: TObjectList;
Description

This is veEngines, a member of class TnxFieldsValidationsEngine.

Group

TnxFieldsValidationsEngine Fields

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Fields


TnxFieldsValidationsEngine.veFieldsValidationsDescriptor Field

TnxFieldsValidationsEngine.veFieldsValidationsDescriptor Field
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Fields Send Feedback
Syntax
Delphi
veFieldsValidationsDescriptor: TnxFieldsValidationsDescriptor;
Description

private

Group

TnxFieldsValidationsEngine Fields

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Fields


TnxFieldsValidationsEngine Methods

TnxFieldsValidationsEngine Methods
TnxFieldsValidationsEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldsValidationsEngine class are listed here.

Class

TnxFieldsValidationsEngine Class

Protected Methods
Name | Description
GetList |
veCreateEngines |
Public Methods
Name | Description
CreateFor |
ValidateRecord |
Links
TnxFieldsValidationsEngine Class, Legend, Protected Methods, Public Methods


TnxFieldsValidationsEngine.CreateFor Method

TnxFieldsValidationsEngine.CreateFor Method
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aFieldsDescriptor: TnxFieldsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor): TnxFieldsValidationsEngine;
Group

TnxFieldsValidationsEngine Methods

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Methods


TnxFieldsValidationsEngine.GetList Method

TnxFieldsValidationsEngine.GetList Method
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldsValidationsEngine Methods

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Methods


TnxFieldsValidationsEngine.ValidateRecord Method

TnxFieldsValidationsEngine.ValidateRecord Method
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxFieldsValidationsEngine Methods

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Methods


TnxFieldsValidationsEngine.veCreateEngines Method

TnxFieldsValidationsEngine.veCreateEngines Method
TnxFieldsValidationsEngine Class TnxFieldsValidationsEngine Members nxsdValidationEngine Namespace TnxFieldsValidationsEngine Methods Send Feedback
Syntax
Delphi
procedure veCreateEngines(aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor);
Group

TnxFieldsValidationsEngine Methods

Links
TnxFieldsValidationsEngine Class, TnxFieldsValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldsValidationsEngine Methods


TnxFieldValidationsEngine Class

TnxFieldValidationsEngine Class
TnxFieldValidationsEngine Fields TnxFieldValidationsEngine Methods TnxFieldValidationsEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxFieldValidationsEnginenxsdValidationEngine_TnxFieldValidationsEnginenxsdValidationEngine_TnxFieldValidationsEnginenxsdValidationEngine_TnxFieldValidationsEnginenxsdValidationEngine_TnxFieldValidationsEngine
Syntax
Delphi
TnxFieldValidationsEngine = class(TnxBaseValidationsEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxFieldValidationsEngine.

Group

Classes

Links
TnxFieldValidationsEngine Fields, TnxFieldValidationsEngine Methods, TnxFieldValidationsEngine Members, nxsdValidationEngine, Classes


TnxFieldValidationsEngine Members

TnxFieldValidationsEngine Members
TnxFieldValidationsEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxFieldValidationsEngine.

Class

TnxFieldValidationsEngine Class

Protected Fields
Name | Description
bveFieldsDescriptor | private
veEngines | This is veEngines, a member of class TnxFieldValidationsEngine.
veFieldDescriptor | private
veFieldIndex | This is veFieldIndex, a member of class TnxFieldValidationsEngine.
veFieldValidationsDescriptor | This is veFieldValidationsDescriptor, a member of class TnxFieldValidationsEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxFieldValidationsEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
veCreateEngines |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateRecord |
Links
TnxFieldValidationsEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxFieldValidationsEngine.Create Constructor

TnxFieldValidationsEngine.Create Constructor
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsDescriptor: TnxFieldsDescriptor; aFieldDescriptor: TnxFieldDescriptor; aFieldValidationsDescriptor: TnxFieldValidationsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor); virtual;
Description

TnxFieldValidationsEngine

Class

TnxFieldValidationsEngine Class

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Class


TnxFieldValidationsEngine.Destroy Destructor

TnxFieldValidationsEngine.Destroy Destructor
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFieldValidationsEngine Class

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Class


TnxFieldValidationsEngine Fields

TnxFieldValidationsEngine Fields
TnxFieldValidationsEngine Class Legend Protected Fields Send Feedback

The fields of the TnxFieldValidationsEngine class are listed here.

Class

TnxFieldValidationsEngine Class

Protected Fields
Name | Description
veEngines | This is veEngines, a member of class TnxFieldValidationsEngine.
veFieldDescriptor | private
veFieldIndex | This is veFieldIndex, a member of class TnxFieldValidationsEngine.
veFieldValidationsDescriptor | This is veFieldValidationsDescriptor, a member of class TnxFieldValidationsEngine.
Links
TnxFieldValidationsEngine Class, Legend, Protected Fields


TnxFieldValidationsEngine.veEngines Field

TnxFieldValidationsEngine.veEngines Field
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Fields Send Feedback
Syntax
Delphi
veEngines: TObjectList;
Description

This is veEngines, a member of class TnxFieldValidationsEngine.

Group

TnxFieldValidationsEngine Fields

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Fields


TnxFieldValidationsEngine.veFieldDescriptor Field

TnxFieldValidationsEngine.veFieldDescriptor Field
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Fields Send Feedback
Syntax
Delphi
veFieldDescriptor: TnxFieldDescriptor;
Description

private

Group

TnxFieldValidationsEngine Fields

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Fields


TnxFieldValidationsEngine.veFieldIndex Field

TnxFieldValidationsEngine.veFieldIndex Field
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Fields Send Feedback
Syntax
Delphi
veFieldIndex: Integer;
Description

This is veFieldIndex, a member of class TnxFieldValidationsEngine.

Group

TnxFieldValidationsEngine Fields

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Fields


TnxFieldValidationsEngine.veFieldValidationsDescriptor Field

TnxFieldValidationsEngine.veFieldValidationsDescriptor Field
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Fields Send Feedback
Syntax
Delphi
veFieldValidationsDescriptor: TnxFieldValidationsDescriptor;
Description

This is veFieldValidationsDescriptor, a member of class TnxFieldValidationsEngine.

Group

TnxFieldValidationsEngine Fields

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Fields


TnxFieldValidationsEngine Methods

TnxFieldValidationsEngine Methods
TnxFieldValidationsEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldValidationsEngine class are listed here.

Class

TnxFieldValidationsEngine Class

Protected Methods
Name | Description
GetList |
veCreateEngines |
Public Methods
Name | Description
CreateFor |
ValidateRecord |
Links
TnxFieldValidationsEngine Class, Legend, Protected Methods, Public Methods


TnxFieldValidationsEngine.CreateFor Method

TnxFieldValidationsEngine.CreateFor Method
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aFieldsDescriptor: TnxFieldsDescriptor; aFieldIndex: Integer; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor): TnxFieldValidationsEngine;
Group

TnxFieldValidationsEngine Methods

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Methods


TnxFieldValidationsEngine.GetList Method

TnxFieldValidationsEngine.GetList Method
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFieldValidationsEngine Methods

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Methods


TnxFieldValidationsEngine.ValidateRecord Method

TnxFieldValidationsEngine.ValidateRecord Method
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxFieldValidationsEngine Methods

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Methods


TnxFieldValidationsEngine.veCreateEngines Method

TnxFieldValidationsEngine.veCreateEngines Method
TnxFieldValidationsEngine Class TnxFieldValidationsEngine Members nxsdValidationEngine Namespace TnxFieldValidationsEngine Methods Send Feedback
Syntax
Delphi
procedure veCreateEngines(aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor);
Group

TnxFieldValidationsEngine Methods

Links
TnxFieldValidationsEngine Class, TnxFieldValidationsEngine Members, nxsdValidationEngine Namespace, TnxFieldValidationsEngine Methods


TnxMinMaxValidationEngine Class

TnxMinMaxValidationEngine Class
TnxMinMaxValidationEngine Fields TnxMinMaxValidationEngine Methods TnxMinMaxValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxMinMaxValidationEnginenxsdValidationEngine_TnxMinMaxValidationEnginenxsdValidationEngine_TnxMinMaxValidationEnginenxsdValidationEngine_TnxMinMaxValidationEnginenxsdValidationEngine_TnxMinMaxValidationEnginenxsdValidationEngine_TnxMinMaxValidationEngine
Syntax
Delphi
TnxMinMaxValidationEngine = class(TnxBaseFieldValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxMinMaxValidationEngine.

Group

Classes

Links
TnxMinMaxValidationEngine Fields, TnxMinMaxValidationEngine Methods, TnxMinMaxValidationEngine Members, nxsdValidationEngine, Classes


TnxMinMaxValidationEngine Members

TnxMinMaxValidationEngine Members
TnxMinMaxValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxMinMaxValidationEngine.

Class

TnxMinMaxValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
mmveKeyFieldEngine | This is mmveKeyFieldEngine, a member of class TnxMinMaxValidationEngine.
mmveMax | This is mmveMax, a member of class TnxMinMaxValidationEngine.
mmveMin | This is mmveMin, a member of class TnxMinMaxValidationEngine.
mmveMinMaxDescriptor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | TnxMinMaxValidationEngine
bfvRaiseValidationError |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField |
Links
TnxMinMaxValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxMinMaxValidationEngine.Create Constructor

TnxMinMaxValidationEngine.Create Constructor
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); override;
Class

TnxMinMaxValidationEngine Class

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Class


TnxMinMaxValidationEngine.Destroy Destructor

TnxMinMaxValidationEngine.Destroy Destructor
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMinMaxValidationEngine Class

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Class


TnxMinMaxValidationEngine Fields

TnxMinMaxValidationEngine Fields
TnxMinMaxValidationEngine Class Legend Protected Fields Send Feedback

The fields of the TnxMinMaxValidationEngine class are listed here.

Class

TnxMinMaxValidationEngine Class

Protected Fields
Name | Description
mmveKeyFieldEngine | This is mmveKeyFieldEngine, a member of class TnxMinMaxValidationEngine.
mmveMax | This is mmveMax, a member of class TnxMinMaxValidationEngine.
mmveMin | This is mmveMin, a member of class TnxMinMaxValidationEngine.
mmveMinMaxDescriptor | private
Links
TnxMinMaxValidationEngine Class, Legend, Protected Fields


TnxMinMaxValidationEngine.mmveKeyFieldEngine Field

TnxMinMaxValidationEngine.mmveKeyFieldEngine Field
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Fields Send Feedback
Syntax
Delphi
mmveKeyFieldEngine: TnxCompositeKeyFieldEngine;
Description

This is mmveKeyFieldEngine, a member of class TnxMinMaxValidationEngine.

Group

TnxMinMaxValidationEngine Fields

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Fields


TnxMinMaxValidationEngine.mmveMax Field

TnxMinMaxValidationEngine.mmveMax Field
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Fields Send Feedback
Syntax
Delphi
mmveMax: Pointer;
Description

This is mmveMax, a member of class TnxMinMaxValidationEngine.

Group

TnxMinMaxValidationEngine Fields

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Fields


TnxMinMaxValidationEngine.mmveMin Field

TnxMinMaxValidationEngine.mmveMin Field
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Fields Send Feedback
Syntax
Delphi
mmveMin: Pointer;
Description

This is mmveMin, a member of class TnxMinMaxValidationEngine.

Group

TnxMinMaxValidationEngine Fields

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Fields


TnxMinMaxValidationEngine.mmveMinMaxDescriptor Field

TnxMinMaxValidationEngine.mmveMinMaxDescriptor Field
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Fields Send Feedback
Syntax
Delphi
mmveMinMaxDescriptor: TnxMinMaxValidationDescriptor;
Description

private

Group

TnxMinMaxValidationEngine Fields

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Fields


TnxMinMaxValidationEngine Methods

TnxMinMaxValidationEngine Methods
TnxMinMaxValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxMinMaxValidationEngine class are listed here.

Class

TnxMinMaxValidationEngine Class

Protected Methods
Name | Description
bfvGetExceptionClass | TnxMinMaxValidationEngine
Public Methods
Name | Description
ValidateField |
Links
TnxMinMaxValidationEngine Class, Legend, Protected Methods, Public Methods


TnxMinMaxValidationEngine.bfvGetExceptionClass Method

TnxMinMaxValidationEngine.bfvGetExceptionClass Method
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetExceptionClass: EnxBaseFieldValidationEngineExceptionClass; override;
Description

TnxMinMaxValidationEngine

Group

TnxMinMaxValidationEngine Methods

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Methods


TnxMinMaxValidationEngine.ValidateField Method

TnxMinMaxValidationEngine.ValidateField Method
TnxMinMaxValidationEngine Class TnxMinMaxValidationEngine Members nxsdValidationEngine Namespace TnxMinMaxValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxMinMaxValidationEngine Methods

Links
TnxMinMaxValidationEngine Class, TnxMinMaxValidationEngine Members, nxsdValidationEngine Namespace, TnxMinMaxValidationEngine Methods


TnxNoChangeValidationEngine Class

TnxNoChangeValidationEngine Class
TnxNoChangeValidationEngine Fields TnxNoChangeValidationEngine Methods TnxNoChangeValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxNoChangeValidationEnginenxsdValidationEngine_TnxNoChangeValidationEnginenxsdValidationEngine_TnxNoChangeValidationEnginenxsdValidationEngine_TnxNoChangeValidationEnginenxsdValidationEngine_TnxNoChangeValidationEnginenxsdValidationEngine_TnxNoChangeValidationEngine
Syntax
Delphi
TnxNoChangeValidationEngine = class(TnxBaseFieldValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxNoChangeValidationEngine.

Group

Classes

Links
TnxNoChangeValidationEngine Fields, TnxNoChangeValidationEngine Methods, TnxNoChangeValidationEngine Members, nxsdValidationEngine, Classes


TnxNoChangeValidationEngine Members

TnxNoChangeValidationEngine Members
TnxNoChangeValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNoChangeValidationEngine.

Class

TnxNoChangeValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
ncveKeyFieldEngine | This is ncveKeyFieldEngine, a member of class TnxNoChangeValidationEngine.
ncveNoChangeDescriptor | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | TnxNoChangeValidationEngine
bfvRaiseValidationError |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField |
Links
TnxNoChangeValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNoChangeValidationEngine.Create Constructor

TnxNoChangeValidationEngine.Create Constructor
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); override;
Class

TnxNoChangeValidationEngine Class

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Class


TnxNoChangeValidationEngine.Destroy Destructor

TnxNoChangeValidationEngine.Destroy Destructor
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxNoChangeValidationEngine Class

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Class


TnxNoChangeValidationEngine Fields

TnxNoChangeValidationEngine Fields
TnxNoChangeValidationEngine Class Legend Protected Fields Send Feedback

The fields of the TnxNoChangeValidationEngine class are listed here.

Class

TnxNoChangeValidationEngine Class

Protected Fields
Name | Description
ncveKeyFieldEngine | This is ncveKeyFieldEngine, a member of class TnxNoChangeValidationEngine.
ncveNoChangeDescriptor | private
Links
TnxNoChangeValidationEngine Class, Legend, Protected Fields


TnxNoChangeValidationEngine.ncveKeyFieldEngine Field

TnxNoChangeValidationEngine.ncveKeyFieldEngine Field
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Fields Send Feedback
Syntax
Delphi
ncveKeyFieldEngine: TnxCompositeKeyFieldEngine;
Description

This is ncveKeyFieldEngine, a member of class TnxNoChangeValidationEngine.

Group

TnxNoChangeValidationEngine Fields

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Fields


TnxNoChangeValidationEngine.ncveNoChangeDescriptor Field

TnxNoChangeValidationEngine.ncveNoChangeDescriptor Field
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Fields Send Feedback
Syntax
Delphi
ncveNoChangeDescriptor: TnxNoChangeValidationDescriptor;
Description

private

Group

TnxNoChangeValidationEngine Fields

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Fields


TnxNoChangeValidationEngine Methods

TnxNoChangeValidationEngine Methods
TnxNoChangeValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNoChangeValidationEngine class are listed here.

Class

TnxNoChangeValidationEngine Class

Protected Methods
Name | Description
bfvGetExceptionClass | TnxNoChangeValidationEngine
Public Methods
Name | Description
ValidateField |
Links
TnxNoChangeValidationEngine Class, Legend, Protected Methods, Public Methods


TnxNoChangeValidationEngine.bfvGetExceptionClass Method

TnxNoChangeValidationEngine.bfvGetExceptionClass Method
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetExceptionClass: EnxBaseFieldValidationEngineExceptionClass; override;
Description

TnxNoChangeValidationEngine

Group

TnxNoChangeValidationEngine Methods

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Methods


TnxNoChangeValidationEngine.ValidateField Method

TnxNoChangeValidationEngine.ValidateField Method
TnxNoChangeValidationEngine Class TnxNoChangeValidationEngine Members nxsdValidationEngine Namespace TnxNoChangeValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxNoChangeValidationEngine Methods

Links
TnxNoChangeValidationEngine Class, TnxNoChangeValidationEngine Members, nxsdValidationEngine Namespace, TnxNoChangeValidationEngine Methods


TnxNotNullValidationEngine Class

TnxNotNullValidationEngine Class
TnxNotNullValidationEngine Methods TnxNotNullValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxNotNullValidationEnginenxsdValidationEngine_TnxNotNullValidationEnginenxsdValidationEngine_TnxNotNullValidationEnginenxsdValidationEngine_TnxNotNullValidationEnginenxsdValidationEngine_TnxNotNullValidationEnginenxsdValidationEngine_TnxNotNullValidationEngine
Syntax
Delphi
TnxNotNullValidationEngine = class(TnxBaseFieldValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxNotNullValidationEngine.

Group

Classes

Links
TnxNotNullValidationEngine Methods, TnxNotNullValidationEngine Members, nxsdValidationEngine, Classes


TnxNotNullValidationEngine Members

TnxNotNullValidationEngine Members
TnxNotNullValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxNotNullValidationEngine.

Class

TnxNotNullValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxBaseFieldValidationEngine
bfvGetExceptionClass | TnxNotNullValidationEngine
bfvRaiseValidationError |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField |
Links
TnxNotNullValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxNotNullValidationEngine.Create Constructor

TnxNotNullValidationEngine.Create Constructor
TnxNotNullValidationEngine Class TnxNotNullValidationEngine Members nxsdValidationEngine Namespace TnxNotNullValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); override;
Class

TnxNotNullValidationEngine Class

Links
TnxNotNullValidationEngine Class, TnxNotNullValidationEngine Members, nxsdValidationEngine Namespace, TnxNotNullValidationEngine Class


TnxNotNullValidationEngine Methods

TnxNotNullValidationEngine Methods
TnxNotNullValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNotNullValidationEngine class are listed here.

Class

TnxNotNullValidationEngine Class

Protected Methods
Name | Description
bfvGetExceptionClass | TnxNotNullValidationEngine
Public Methods
Name | Description
ValidateField |
Links
TnxNotNullValidationEngine Class, Legend, Protected Methods, Public Methods


TnxNotNullValidationEngine.bfvGetExceptionClass Method

TnxNotNullValidationEngine.bfvGetExceptionClass Method
TnxNotNullValidationEngine Class TnxNotNullValidationEngine Members nxsdValidationEngine Namespace TnxNotNullValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetExceptionClass: EnxBaseFieldValidationEngineExceptionClass; override;
Description

TnxNotNullValidationEngine

Group

TnxNotNullValidationEngine Methods

Links
TnxNotNullValidationEngine Class, TnxNotNullValidationEngine Members, nxsdValidationEngine Namespace, TnxNotNullValidationEngine Methods


TnxNotNullValidationEngine.ValidateField Method

TnxNotNullValidationEngine.ValidateField Method
TnxNotNullValidationEngine Class TnxNotNullValidationEngine Members nxsdValidationEngine Namespace TnxNotNullValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxNotNullValidationEngine Methods

Links
TnxNotNullValidationEngine Class, TnxNotNullValidationEngine Members, nxsdValidationEngine Namespace, TnxNotNullValidationEngine Methods


TnxSqlCheckValidationEngine Class

TnxSqlCheckValidationEngine Class
TnxSqlCheckValidationEngine Fields TnxSqlCheckValidationEngine Methods TnxSqlCheckValidationEngine Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEnginenxsdValidationEngine_TnxSqlCheckValidationEngine
Syntax
Delphi
TnxSqlCheckValidationEngine = class(TnxBaseFieldsValidationEngine);
File

nxsdValidationEngine

Description

This is class nxsdValidationEngine.TnxSqlCheckValidationEngine.

Group

Classes

Links
TnxSqlCheckValidationEngine Fields, TnxSqlCheckValidationEngine Methods, TnxSqlCheckValidationEngine Members, nxsdValidationEngine, Classes


TnxSqlCheckValidationEngine Members

TnxSqlCheckValidationEngine Members
TnxSqlCheckValidationEngine Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSqlCheckValidationEngine.

Class

TnxSqlCheckValidationEngine Class

Protected Fields
Name | Description
bfvFieldName | private
bveCursor | This is bveCursor, a member of class TnxBaseValidationEngine.
bveDescriptor | This is bveDescriptor, a member of class TnxBaseValidationEngine.
bveName | This is bveName, a member of class TnxBaseValidationEngine.
bveParent | private
scveSqlCheckDescriptor | private
scveSqlCheckStatement | This is scveSqlCheckStatement, a member of class TnxSqlCheckValidationEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bfvGetErrorMessage | TnxSqlCheckValidationEngine
bfvGetExceptionClass |
bfvRaiseValidationError | TnxBaseFieldsValidationEngine
bfvRaiseValidationError |
Create |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ValidateField |
ValidateRecord |
Links
TnxSqlCheckValidationEngine Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSqlCheckValidationEngine.Create Constructor

TnxSqlCheckValidationEngine.Create Constructor
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseValidationsEngine; aDescriptor: TnxBaseFieldValidationDescriptor; aCursor: TnxAbstractCursor); override;
Class

TnxSqlCheckValidationEngine Class

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Class


TnxSqlCheckValidationEngine.Destroy Destructor

TnxSqlCheckValidationEngine.Destroy Destructor
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSqlCheckValidationEngine Class

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Class


TnxSqlCheckValidationEngine Fields

TnxSqlCheckValidationEngine Fields
TnxSqlCheckValidationEngine Class Legend Protected Fields Send Feedback

The fields of the TnxSqlCheckValidationEngine class are listed here.

Class

TnxSqlCheckValidationEngine Class

Protected Fields
Name | Description
scveSqlCheckDescriptor | private
scveSqlCheckStatement | This is scveSqlCheckStatement, a member of class TnxSqlCheckValidationEngine.
Links
TnxSqlCheckValidationEngine Class, Legend, Protected Fields


TnxSqlCheckValidationEngine.scveSqlCheckDescriptor Field

TnxSqlCheckValidationEngine.scveSqlCheckDescriptor Field
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Fields Send Feedback
Syntax
Delphi
scveSqlCheckDescriptor: TnxSqlCheckValidationDescriptor;
Description

private

Group

TnxSqlCheckValidationEngine Fields

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Fields


TnxSqlCheckValidationEngine.scveSqlCheckStatement Field

TnxSqlCheckValidationEngine.scveSqlCheckStatement Field
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Fields Send Feedback
Syntax
Delphi
scveSqlCheckStatement: TnxBaseSqlCheckStatement;
Description

This is scveSqlCheckStatement, a member of class TnxSqlCheckValidationEngine.

Group

TnxSqlCheckValidationEngine Fields

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Fields


TnxSqlCheckValidationEngine Methods

TnxSqlCheckValidationEngine Methods
TnxSqlCheckValidationEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSqlCheckValidationEngine class are listed here.

Class

TnxSqlCheckValidationEngine Class

Protected Methods
Name | Description
bfvGetErrorMessage | TnxSqlCheckValidationEngine
bfvGetExceptionClass |
Public Methods
Name | Description
ValidateField |
ValidateRecord |
Links
TnxSqlCheckValidationEngine Class, Legend, Protected Methods, Public Methods


TnxSqlCheckValidationEngine.bfvGetErrorMessage Method

TnxSqlCheckValidationEngine.bfvGetErrorMessage Method
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetErrorMessage: string; override;
Description

TnxSqlCheckValidationEngine

Group

TnxSqlCheckValidationEngine Methods

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Methods


TnxSqlCheckValidationEngine.bfvGetExceptionClass Method

TnxSqlCheckValidationEngine.bfvGetExceptionClass Method
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Methods Send Feedback
Syntax
Delphi
function bfvGetExceptionClass: EnxBaseFieldValidationEngineExceptionClass; override;
Group

TnxSqlCheckValidationEngine Methods

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Methods


TnxSqlCheckValidationEngine.ValidateField Method

TnxSqlCheckValidationEngine.ValidateField Method
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldField: PnxByteArray; aOldRecord: PnxByteArray; aNewField: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxSqlCheckValidationEngine Methods

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Methods


TnxSqlCheckValidationEngine.ValidateRecord Method

TnxSqlCheckValidationEngine.ValidateRecord Method
TnxSqlCheckValidationEngine Class TnxSqlCheckValidationEngine Members nxsdValidationEngine Namespace TnxSqlCheckValidationEngine Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray); override;
Group

TnxSqlCheckValidationEngine Methods

Links
TnxSqlCheckValidationEngine Class, TnxSqlCheckValidationEngine Members, nxsdValidationEngine Namespace, TnxSqlCheckValidationEngine Methods


TnxValidationsHandler Class

TnxValidationsHandler Class
TnxValidationsHandler Fields TnxValidationsHandler Methods TnxValidationsHandler Members nxsdValidationEngine Classes Send Feedback
Class Hierarchy
nxsdValidationEngine_TnxValidationsHandlernxsdValidationEngine_TnxValidationsHandler
Syntax
Delphi
TnxValidationsHandler = class(TnxObject);
File

nxsdValidationEngine

Description

HPPEMIT 'namespace Nxsdvalidationengine' HPPEMIT '{' HPPEMIT 'class DELPHICLASS TnxBaseValidationsEngine;' HPPEMIT 'class DELPHICLASS TnxFieldValidationsEngine;' HPPEMIT '}'

Group

Classes

Links
TnxValidationsHandler Fields, TnxValidationsHandler Methods, TnxValidationsHandler Members, nxsdValidationEngine, Classes


TnxValidationsHandler Members

TnxValidationsHandler Members
TnxValidationsHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxValidationsHandler.

Class

TnxValidationsHandler Class

Protected Fields
Name | Description
vhEngines | This is vhEngines, a member of class TnxValidationsHandler.
vhEnginesByIndex | This is vhEnginesByIndex, a member of class TnxValidationsHandler.
vhFieldsDescriptor | private
vhFieldsEngine | This is vhFieldsEngine, a member of class TnxValidationsHandler.
Protected Methods
Name | Description
Create | TnxValidationsHandler
vhCreateEngines |
Public Methods
Name | Description
CreateFor |
Destroy |
FreeInstance |
NewInstance | TnxObject
ValidateField |
ValidateRecord |
Links
TnxValidationsHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxValidationsHandler.Create Constructor

TnxValidationsHandler.Create Constructor
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Class Send Feedback
Syntax
Delphi
constructor Create(aFieldsDescriptor: TnxFieldsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor);
Description

TnxValidationsHandler

Class

TnxValidationsHandler Class

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Class


TnxValidationsHandler.Destroy Destructor

TnxValidationsHandler.Destroy Destructor
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxValidationsHandler Class

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Class


TnxValidationsHandler Fields

TnxValidationsHandler Fields
TnxValidationsHandler Class Legend Protected Fields Send Feedback

The fields of the TnxValidationsHandler class are listed here.

Class

TnxValidationsHandler Class

Protected Fields
Name | Description
vhEngines | This is vhEngines, a member of class TnxValidationsHandler.
vhEnginesByIndex | This is vhEnginesByIndex, a member of class TnxValidationsHandler.
vhFieldsDescriptor | private
vhFieldsEngine | This is vhFieldsEngine, a member of class TnxValidationsHandler.
Links
TnxValidationsHandler Class, Legend, Protected Fields


TnxValidationsHandler.vhEngines Field

TnxValidationsHandler.vhEngines Field
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Fields Send Feedback
Syntax
Delphi
vhEngines: TObjectList;
Description

This is vhEngines, a member of class TnxValidationsHandler.

Group

TnxValidationsHandler Fields

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Fields


TnxValidationsHandler.vhEnginesByIndex Field

TnxValidationsHandler.vhEnginesByIndex Field
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Fields Send Feedback
Syntax
Delphi
vhEnginesByIndex: array of TnxFieldValidationsEngine;
Description

This is vhEnginesByIndex, a member of class TnxValidationsHandler.

Group

TnxValidationsHandler Fields

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Fields


TnxValidationsHandler.vhFieldsDescriptor Field

TnxValidationsHandler.vhFieldsDescriptor Field
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Fields Send Feedback
Syntax
Delphi
vhFieldsDescriptor: TnxFieldsDescriptor;
Description

private

Group

TnxValidationsHandler Fields

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Fields


TnxValidationsHandler.vhFieldsEngine Field

TnxValidationsHandler.vhFieldsEngine Field
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Fields Send Feedback
Syntax
Delphi
vhFieldsEngine: TnxFieldsValidationsEngine;
Description

This is vhFieldsEngine, a member of class TnxValidationsHandler.

Group

TnxValidationsHandler Fields

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Fields


TnxValidationsHandler Methods

TnxValidationsHandler Methods
TnxValidationsHandler Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxValidationsHandler class are listed here.

Class

TnxValidationsHandler Class

Protected Methods
Name | Description
vhCreateEngines |
Public Methods
Name | Description
CreateFor |
ValidateField |
ValidateRecord |
Links
TnxValidationsHandler Class, Legend, Protected Methods, Public Methods


TnxValidationsHandler.CreateFor Method

TnxValidationsHandler.CreateFor Method
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Methods Send Feedback
Syntax
Delphi
class function CreateFor(aFieldsDescriptor: TnxFieldsDescriptor; aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor): TnxValidationsHandler;
Group

TnxValidationsHandler Methods

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Methods


TnxValidationsHandler.ValidateField Method

TnxValidationsHandler.ValidateField Method
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Methods Send Feedback
Syntax
Delphi
procedure ValidateField(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray; aField: Integer);
Group

TnxValidationsHandler Methods

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Methods


TnxValidationsHandler.ValidateRecord Method

TnxValidationsHandler.ValidateRecord Method
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Methods Send Feedback
Syntax
Delphi
procedure ValidateRecord(aOldRecord: PnxByteArray; aNewRecord: PnxByteArray);
Group

TnxValidationsHandler Methods

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Methods


TnxValidationsHandler.vhCreateEngines Method

TnxValidationsHandler.vhCreateEngines Method
TnxValidationsHandler Class TnxValidationsHandler Members nxsdValidationEngine Namespace TnxValidationsHandler Methods Send Feedback
Syntax
Delphi
procedure vhCreateEngines(aApplyAt: TnxApplyAt; aCursor: TnxAbstractCursor);
Group

TnxValidationsHandler Methods

Links
TnxValidationsHandler Class, TnxValidationsHandler Members, nxsdValidationEngine Namespace, TnxValidationsHandler Methods


Types

Types
nxsdValidationEngine Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxsdValidationEngine Namespace

Types
Name | Description
EnxBaseFieldValidationEngineExceptionClass | This is type nxsdValidationEngine.EnxBaseFieldValidationEngineExceptionClass.
TnxBaseValidationEngineClass | This is type nxsdValidationEngine.TnxBaseValidationEngineClass.
TnxFieldsValidationsEngineClass | This is type nxsdValidationEngine.TnxFieldsValidationsEngineClass.
TnxFieldValidationsEngineClass | This is type nxsdValidationEngine.TnxFieldValidationsEngineClass.
TnxSqlCheckStatementClass | This is type nxsdValidationEngine.TnxSqlCheckStatementClass.
Links
nxsdValidationEngine Namespace, Types


nxsdValidationEngine.EnxBaseFieldValidationEngineExceptionClass Type

nxsdValidationEngine.EnxBaseFieldValidationEngineExceptionClass Type
nxsdValidationEngine Types Send Feedback
Syntax
Delphi
EnxBaseFieldValidationEngineExceptionClass = class of EnxBaseFieldValidationEngineException;
File

nxsdValidationEngine

Description

This is type nxsdValidationEngine.EnxBaseFieldValidationEngineExceptionClass.

Group

Types

Links
nxsdValidationEngine, Types


nxsdValidationEngine.TnxBaseValidationEngineClass Type

nxsdValidationEngine.TnxBaseValidationEngineClass Type
nxsdValidationEngine Types Send Feedback
Syntax
Delphi
TnxBaseValidationEngineClass = class of TnxBaseValidationEngine;
File

nxsdValidationEngine

Description

This is type nxsdValidationEngine.TnxBaseValidationEngineClass.

Group

Types

Links
nxsdValidationEngine, Types


nxsdValidationEngine.TnxFieldsValidationsEngineClass Type

nxsdValidationEngine.TnxFieldsValidationsEngineClass Type
nxsdValidationEngine Types Send Feedback
Syntax
Delphi
TnxFieldsValidationsEngineClass = class of TnxFieldsValidationsEngine;
File

nxsdValidationEngine

Description

This is type nxsdValidationEngine.TnxFieldsValidationsEngineClass.

Group

Types

Links
nxsdValidationEngine, Types


nxsdValidationEngine.TnxFieldValidationsEngineClass Type

nxsdValidationEngine.TnxFieldValidationsEngineClass Type
nxsdValidationEngine Types Send Feedback
Syntax
Delphi
TnxFieldValidationsEngineClass = class of TnxFieldValidationsEngine;
File

nxsdValidationEngine

Description

This is type nxsdValidationEngine.TnxFieldValidationsEngineClass.

Group

Types

Links
nxsdValidationEngine, Types


nxsdValidationEngine.TnxSqlCheckStatementClass Type

nxsdValidationEngine.TnxSqlCheckStatementClass Type
nxsdValidationEngine Types Send Feedback
Syntax
Delphi
TnxSqlCheckStatementClass = class of TnxBaseSqlCheckStatement;
File

nxsdValidationEngine

Description

This is type nxsdValidationEngine.TnxSqlCheckStatementClass.

Group

Types

Links
nxsdValidationEngine, Types


Variables

Variables
nxsdValidationEngine Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxsdValidationEngine Namespace

Variables
Name | Description
_FieldsValidationsEngineList | This is variable nxsdValidationEngine._FieldsValidationsEngineList.
_FieldValidationsEngineList | This is variable nxsdValidationEngine._FieldValidationsEngineList.
_ValidationEngineList | This is variable nxsdValidationEngine._ValidationEngineList.
SqlCheckStatementClass | This is variable nxsdValidationEngine.SqlCheckStatementClass.
Links
nxsdValidationEngine Namespace, Variables


nxsdValidationEngine._FieldsValidationsEngineList Variable

nxsdValidationEngine._FieldsValidationsEngineList Variable
nxsdValidationEngine Variables Send Feedback
Syntax
Delphi
_FieldsValidationsEngineList: TStringList;
File

nxsdValidationEngine

Description

This is variable nxsdValidationEngine._FieldsValidationsEngineList.

Group

Variables

Links
nxsdValidationEngine, Variables


nxsdValidationEngine._FieldValidationsEngineList Variable

nxsdValidationEngine._FieldValidationsEngineList Variable
nxsdValidationEngine Variables Send Feedback
Syntax
Delphi
_FieldValidationsEngineList: TStringList;
File

nxsdValidationEngine

Description

This is variable nxsdValidationEngine._FieldValidationsEngineList.

Group

Variables

Links
nxsdValidationEngine, Variables


nxsdValidationEngine._ValidationEngineList Variable

nxsdValidationEngine._ValidationEngineList Variable
nxsdValidationEngine Variables Send Feedback
Syntax
Delphi
_ValidationEngineList: TStringList;
File

nxsdValidationEngine

Description

This is variable nxsdValidationEngine._ValidationEngineList.

Group

Variables

Links
nxsdValidationEngine, Variables


nxsdValidationEngine.SqlCheckStatementClass Variable

nxsdValidationEngine.SqlCheckStatementClass Variable
nxsdValidationEngine Variables Send Feedback
Syntax
Delphi
SqlCheckStatementClass: TnxSqlCheckStatementClass;
File

nxsdValidationEngine

Description

This is variable nxsdValidationEngine.SqlCheckStatementClass.

Group

Variables

Links
nxsdValidationEngine, Variables


Constants

Constants
Constants nxsdValidationEngine Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
csValidation | This is constant nxsdValidationEngine.csValidation.
csValidations | This is constant nxsdValidationEngine.csValidations.
rsSqlCheckNotSupported | This is constant nxsdValidationEngine.rsSqlCheckNotSupported.
Namespace

nxsdValidationEngine Namespace

Links
Constants, nxsdValidationEngine Namespace


nxsdValidationEngine.csValidation Constant

nxsdValidationEngine.csValidation Constant
nxsdValidationEngine Constants Send Feedback
Syntax
Delphi
csValidation = 'Validation';
File

nxsdValidationEngine

Description

This is constant nxsdValidationEngine.csValidation.

Group

Constants

Links
nxsdValidationEngine, Constants


nxsdValidationEngine.csValidations Constant

nxsdValidationEngine.csValidations Constant
nxsdValidationEngine Constants Send Feedback
Syntax
Delphi
csValidations = 'Validations';
File

nxsdValidationEngine

Description

This is constant nxsdValidationEngine.csValidations.

Group

Constants

Links
nxsdValidationEngine, Constants


nxsdValidationEngine.rsSqlCheckNotSupported Constant

nxsdValidationEngine.rsSqlCheckNotSupported Constant
nxsdValidationEngine Constants Send Feedback
Syntax
Delphi
rsSqlCheckNotSupported = 'Evaluation of CHECK constraint requires an SQL e' + 'ngine';
File

nxsdValidationEngine

Description

This is constant nxsdValidationEngine.rsSqlCheckNotSupported.

Group

Constants

Links
nxsdValidationEngine, Constants


nxseAutoComponent Namespace

nxseAutoComponent Namespace
Classes Legend Topics Send Feedback

This is namespace nxseAutoComponent.

Classes
Name | Description
Tnx1xAllEngines | Adding this component to a form or datamodule automatically adds the nxseAllEngines unit to your project. It is a more visual (and more cumbersome :) way of adding the engines to the uses clause. The engines unit are required for projects that use an embedded server engine and any of the default engines.
TnxseAllEngines | This is class nxseAutoComponent.TnxseAllEngines.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Links
Classes, Legend, Topics


Classes

Classes
Classes nxseAutoComponent Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
Tnx1xAllEngines | Adding this component to a form or datamodule automatically adds the nxseAllEngines unit to your project. It is a more visual (and more cumbersome :) way of adding the engines to the uses clause. The engines unit are required for projects that use an embedded server engine and any of the default engines.
TnxseAllEngines | This is class nxseAutoComponent.TnxseAllEngines.
Namespace

nxseAutoComponent Namespace

Links
Classes, nxseAutoComponent Namespace, Legend


Tnx1xAllEngines Class

Tnx1xAllEngines Class
nxseAutoComponent Classes Send Feedback
Class Hierarchy
nxseAutoComponent_Tnx1xAllEnginesnxseAutoComponent_Tnx1xAllEnginesnxseAutoComponent_Tnx1xAllEnginesnxseAutoComponent_Tnx1xAllEngines
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] Tnx1xAllEngines = class(TnxComponent);
File

nxseAutoComponent

Description

Adding this component to a form or datamodule automatically adds the nxseAllEngines unit to your project. It is a more visual (and more cumbersome :) way of adding the engines to the uses clause. The engines unit are required for projects that use an embedded server engine and any of the default engines.

Group

Classes

Links
nxseAutoComponent, Classes


TnxseAllEngines Class

TnxseAllEngines Class
nxseAutoComponent Classes Send Feedback
Class Hierarchy
nxseAutoComponent_TnxseAllEnginesnxseAutoComponent_TnxseAllEnginesnxseAutoComponent_TnxseAllEnginesnxseAutoComponent_TnxseAllEngines
Syntax
Delphi
[ComponentPlatformsAttribute(pidWin32 or pidWin64 )] TnxseAllEngines = class(TnxComponent);
File

nxseAutoComponent

Description

This is class nxseAutoComponent.TnxseAllEngines.

Group

Classes

Links
nxseAutoComponent, Classes


nxseAutoIncEngineSimple Namespace

nxseAutoIncEngineSimple Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

no overflow checking!

Classes
Name | Description
EnxseAutoIncEngineException | This is class nxseAutoIncEngineSimple.EnxseAutoIncEngineException.
TnxSimpleAutoIncEngine | This is class nxseAutoIncEngineSimple.TnxSimpleAutoIncEngine.
Constants
Name | Description
rsMaxAutoInc | This is constant nxseAutoIncEngineSimple.rsMaxAutoInc.
Structs, Records, Enums
Name | Description
TnxSimpleAutoIncSubHeader | This is record nxseAutoIncEngineSimple.TnxSimpleAutoIncSubHeader.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxSimpleAutoIncSubHeader | This is type nxseAutoIncEngineSimple.PnxSimpleAutoIncSubHeader.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxseAutoIncEngineSimple Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxseAutoIncEngineException | This is class nxseAutoIncEngineSimple.EnxseAutoIncEngineException.
TnxSimpleAutoIncEngine | This is class nxseAutoIncEngineSimple.TnxSimpleAutoIncEngine.
Namespace

nxseAutoIncEngineSimple Namespace

Links
Classes, nxseAutoIncEngineSimple Namespace, Legend


EnxseAutoIncEngineException Class

EnxseAutoIncEngineException Class
nxseAutoIncEngineSimple Classes Send Feedback
Class Hierarchy
nxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineExceptionnxseAutoIncEngineSimple_EnxseAutoIncEngineException
Syntax
Delphi
EnxseAutoIncEngineException = class(EnxBaseAutoIncEngineException);
File

nxseAutoIncEngineSimple

Description

This is class nxseAutoIncEngineSimple.EnxseAutoIncEngineException.

Group

Classes

Links
nxseAutoIncEngineSimple, Classes


TnxSimpleAutoIncEngine Class

TnxSimpleAutoIncEngine Class
TnxSimpleAutoIncEngine Fields TnxSimpleAutoIncEngine Methods TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Classes Send Feedback
Class Hierarchy
nxseAutoIncEngineSimple_TnxSimpleAutoIncEnginenxseAutoIncEngineSimple_TnxSimpleAutoIncEnginenxseAutoIncEngineSimple_TnxSimpleAutoIncEnginenxseAutoIncEngineSimple_TnxSimpleAutoIncEnginenxseAutoIncEngineSimple_TnxSimpleAutoIncEngine
Syntax
Delphi
TnxSimpleAutoIncEngine = class(TnxBaseAutoIncEngine);
File

nxseAutoIncEngineSimple

Description

This is class nxseAutoIncEngineSimple.TnxSimpleAutoIncEngine.

Group

Classes

Links
TnxSimpleAutoIncEngine Fields, TnxSimpleAutoIncEngine Methods, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple, Classes


TnxSimpleAutoIncEngine Members

TnxSimpleAutoIncEngine Members
TnxSimpleAutoIncEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleAutoIncEngine.

Class

TnxSimpleAutoIncEngine Class

Protected Fields
Name | Description
aieHeaderSection | private
aieInitialValue | This is aieInitialValue, a member of class TnxSimpleAutoIncEngine.
aieStep | This is aieStep, a member of class TnxSimpleAutoIncEngine.
baieDataFile | private
bseID | private
bseTableVersion | This is bseTableVersion, a member of class TnxBaseSubEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
CheckValid | TnxBaseAutoIncEngine
CheckValidBase |
CheckValidBase |
Create | TnxSimpleAutoIncEngine
FindSubEngineClass |
GetExceptionData | InxExceptionData TnxPersistent
GetList | abstract;
QueryInterface | InxInterface
Register |
RegisterBaseClass |
Unregister |
UnregisterBaseClass |
Public Methods
Name | Description
CheckValidAll | TnxBaseSubEngine
CheckValidFromDescriptor |
CreateEngine | This is the overview for the CreateEngine method overload.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetList |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextAutoIncValue |
ReadAutoIncValue | Return the next autoinc value.
SetAutoIncValue | Return the current autoinc value; this is read-only, it does not modify the autoinc value.
Public Properties
Name | Description
ID | This is ID, a member of class TnxBaseSubEngine.
TableVersion | This is TableVersion, a member of class TnxBaseSubEngine.
Links
TnxSimpleAutoIncEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSimpleAutoIncEngine.Create Constructor

TnxSimpleAutoIncEngine.Create Constructor
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseAutoIncDescriptor; const aFiles: TnxBlockAccessList; aTrans: TnxBaseTransaction); override;
Description

TnxSimpleAutoIncEngine

Class

TnxSimpleAutoIncEngine Class

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Class


TnxSimpleAutoIncEngine Fields

TnxSimpleAutoIncEngine Fields
TnxSimpleAutoIncEngine Class Legend Protected Fields Send Feedback

The fields of the TnxSimpleAutoIncEngine class are listed here.

Class

TnxSimpleAutoIncEngine Class

Protected Fields
Name | Description
aieHeaderSection | private
aieInitialValue | This is aieInitialValue, a member of class TnxSimpleAutoIncEngine.
aieStep | This is aieStep, a member of class TnxSimpleAutoIncEngine.
Links
TnxSimpleAutoIncEngine Class, Legend, Protected Fields


TnxSimpleAutoIncEngine.aieHeaderSection Field

TnxSimpleAutoIncEngine.aieHeaderSection Field
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Fields Send Feedback
Syntax
Delphi
aieHeaderSection: TnxWord16;
Description

private

Group

TnxSimpleAutoIncEngine Fields

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Fields


TnxSimpleAutoIncEngine.aieInitialValue Field

TnxSimpleAutoIncEngine.aieInitialValue Field
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Fields Send Feedback
Syntax
Delphi
aieInitialValue: TnxWord32;
Description

This is aieInitialValue, a member of class TnxSimpleAutoIncEngine.

Group

TnxSimpleAutoIncEngine Fields

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Fields


TnxSimpleAutoIncEngine.aieStep Field

TnxSimpleAutoIncEngine.aieStep Field
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Fields Send Feedback
Syntax
Delphi
aieStep: TnxAutoIncStepRange;
Description

This is aieStep, a member of class TnxSimpleAutoIncEngine.

Group

TnxSimpleAutoIncEngine Fields

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Fields


TnxSimpleAutoIncEngine Methods

TnxSimpleAutoIncEngine Methods
TnxSimpleAutoIncEngine Class Legend Public Methods Send Feedback

The methods of the TnxSimpleAutoIncEngine class are listed here.

Class

TnxSimpleAutoIncEngine Class

Public Methods
Name | Description
NextAutoIncValue |
ReadAutoIncValue | Return the next autoinc value.
SetAutoIncValue | Return the current autoinc value; this is read-only, it does not modify the autoinc value.
Links
TnxSimpleAutoIncEngine Class, Legend, Public Methods


TnxSimpleAutoIncEngine.NextAutoIncValue Method

TnxSimpleAutoIncEngine.NextAutoIncValue Method
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Methods Send Feedback
Syntax
Delphi
function NextAutoIncValue(aTrans: TnxBaseTransaction): TnxWord32; override;
Group

TnxSimpleAutoIncEngine Methods

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Methods


TnxSimpleAutoIncEngine.ReadAutoIncValue Method

TnxSimpleAutoIncEngine.ReadAutoIncValue Method
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Methods Send Feedback
Syntax
Delphi
function ReadAutoIncValue(aTrans: TnxBaseTransaction): TnxWord32; override;
Description

Return the next autoinc value.

Group

TnxSimpleAutoIncEngine Methods

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Methods


TnxSimpleAutoIncEngine.SetAutoIncValue Method

TnxSimpleAutoIncEngine.SetAutoIncValue Method
TnxSimpleAutoIncEngine Class TnxSimpleAutoIncEngine Members nxseAutoIncEngineSimple Namespace TnxSimpleAutoIncEngine Methods Send Feedback
Syntax
Delphi
procedure SetAutoIncValue(aTrans: TnxBaseTransaction; aValue: TnxWord32); override;
Description

Return the current autoinc value; this is read-only, it does not modify the autoinc value.

Group

TnxSimpleAutoIncEngine Methods

Links
TnxSimpleAutoIncEngine Class, TnxSimpleAutoIncEngine Members, nxseAutoIncEngineSimple Namespace, TnxSimpleAutoIncEngine Methods


Structs, Records, Enums

Structs, Records, Enums
nxseAutoIncEngineSimple Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Namespace

nxseAutoIncEngineSimple Namespace

Records
Name | Description
TnxSimpleAutoIncSubHeader | This is record nxseAutoIncEngineSimple.TnxSimpleAutoIncSubHeader.
Links
nxseAutoIncEngineSimple Namespace, Legend, Records


nxseAutoIncEngineSimple.TnxSimpleAutoIncSubHeader Record

nxseAutoIncEngineSimple.TnxSimpleAutoIncSubHeader Record
nxseAutoIncEngineSimple Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSimpleAutoIncSubHeader = packed record
  aishAutoIncValue: TnxWord32;
end;
File

nxseAutoIncEngineSimple

Description

This is record nxseAutoIncEngineSimple.TnxSimpleAutoIncSubHeader.

Group

Structs, Records, Enums

Links
nxseAutoIncEngineSimple, Structs, Records, Enums


Types

Types
nxseAutoIncEngineSimple Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxseAutoIncEngineSimple Namespace

Types
Name | Description
PnxSimpleAutoIncSubHeader | This is type nxseAutoIncEngineSimple.PnxSimpleAutoIncSubHeader.
Links
nxseAutoIncEngineSimple Namespace, Types


nxseAutoIncEngineSimple.PnxSimpleAutoIncSubHeader Type

nxseAutoIncEngineSimple.PnxSimpleAutoIncSubHeader Type
nxseAutoIncEngineSimple Types Send Feedback
Syntax
Delphi
PnxSimpleAutoIncSubHeader = ^TnxSimpleAutoIncSubHeader;
File

nxseAutoIncEngineSimple

Description

This is type nxseAutoIncEngineSimple.PnxSimpleAutoIncSubHeader.

Group

Types

Links
nxseAutoIncEngineSimple, Types


Constants

Constants
Constants nxseAutoIncEngineSimple Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
rsMaxAutoInc | This is constant nxseAutoIncEngineSimple.rsMaxAutoInc.
Namespace

nxseAutoIncEngineSimple Namespace

Links
Constants, nxseAutoIncEngineSimple Namespace


nxseAutoIncEngineSimple.rsMaxAutoInc Constant

nxseAutoIncEngineSimple.rsMaxAutoInc Constant
nxseAutoIncEngineSimple Constants Send Feedback
Syntax
Delphi
rsMaxAutoInc = 'Maximum AutoInc value has been reached';
File

nxseAutoIncEngineSimple

Description

This is constant nxseAutoIncEngineSimple.rsMaxAutoInc.

Group

Constants

Links
nxseAutoIncEngineSimple, Constants


nxseBlobEngineSegmented Namespace

nxseBlobEngineSegmented Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxseBlobEngineSegmented.

Classes
Name | Description
EnxSegmentedBlobEngineException | This is class nxseBlobEngineSegmented.EnxSegmentedBlobEngineException.
TnxSegmentedBlobEngine | This is class nxseBlobEngineSegmented.TnxSegmentedBlobEngine.
TnxSegmentedBlobHeapHeaderHandler | This is class nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandler.
Constants
Name | Description
cstDataSegment | This is constant nxseBlobEngineSegmented.cstDataSegment.
cstFileBlob | This is constant nxseBlobEngineSegmented.cstFileBlob.
cstFileBlobWide | This is constant nxseBlobEngineSegmented.cstFileBlobWide.
cstLinkBlob | This is constant nxseBlobEngineSegmented.cstLinkBlob.
cstLinkBlobWide | This is constant nxseBlobEngineSegmented.cstLinkBlobWide.
cstNullBlob | This is constant nxseBlobEngineSegmented.cstNullBlob.
cstSegmentLinks | This is constant nxseBlobEngineSegmented.cstSegmentLinks.
rsBadBlobBlock | This is constant nxseBlobEngineSegmented.rsBadBlobBlock.
rsBadBlobNr | This is constant nxseBlobEngineSegmented.rsBadBlobNr.
rsBlobDeleted | This is constant nxseBlobEngineSegmented.rsBlobDeleted.
rsFileBlobWrite | This is constant nxseBlobEngineSegmented.rsFileBlobWrite.
rsLenMismatch | This is constant nxseBlobEngineSegmented.rsLenMismatch.
rsOfsNotInBlob | This is constant nxseBlobEngineSegmented.rsOfsNotInBlob.
Structs, Records, Enums
Name | Description
TnxBlobSegmentLinkItem | This is record nxseBlobEngineSegmented.TnxBlobSegmentLinkItem.
TnxSegmentedBlobSubHeader | This is record nxseBlobEngineSegmented.TnxSegmentedBlobSubHeader.
TnxSegmentType | This is record nxseBlobEngineSegmented.TnxSegmentType.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBlobSegmentLinkItem | This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItem.
PnxBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItems.
PnxSegmentedBlobSubHeader | This is type nxseBlobEngineSegmented.PnxSegmentedBlobSubHeader.
PnxSegmentType | This is type nxseBlobEngineSegmented.PnxSegmentType.
TnxBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.TnxBlobSegmentLinkItems.
TnxDynBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.TnxDynBlobSegmentLinkItems.
TnxSegmentedBlobHeapHeaderHandlerClass | This is type nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandlerClass.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxseBlobEngineSegmented Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxSegmentedBlobEngineException | This is class nxseBlobEngineSegmented.EnxSegmentedBlobEngineException.
TnxSegmentedBlobEngine | This is class nxseBlobEngineSegmented.TnxSegmentedBlobEngine.
TnxSegmentedBlobHeapHeaderHandler | This is class nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandler.
Namespace

nxseBlobEngineSegmented Namespace

Links
Classes, nxseBlobEngineSegmented Namespace, Legend


EnxSegmentedBlobEngineException Class

EnxSegmentedBlobEngineException Class
nxseBlobEngineSegmented Classes Send Feedback
Class Hierarchy
nxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineExceptionnxseBlobEngineSegmented_EnxSegmentedBlobEngineException
Syntax
Delphi
EnxSegmentedBlobEngineException = class(EnxBaseBlobEngineException);
File

nxseBlobEngineSegmented

Description

This is class nxseBlobEngineSegmented.EnxSegmentedBlobEngineException.

Group

Classes

Links
nxseBlobEngineSegmented, Classes


TnxSegmentedBlobEngine Class

TnxSegmentedBlobEngine Class
TnxSegmentedBlobEngine Fields TnxSegmentedBlobEngine Methods TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Classes Send Feedback
Class Hierarchy
nxseBlobEngineSegmented_TnxSegmentedBlobEnginenxseBlobEngineSegmented_TnxSegmentedBlobEnginenxseBlobEngineSegmented_TnxSegmentedBlobEnginenxseBlobEngineSegmented_TnxSegmentedBlobEnginenxseBlobEngineSegmented_TnxSegmentedBlobEngine
Syntax
Delphi
TnxSegmentedBlobEngine = class(TnxBaseBlobEngine);
File

nxseBlobEngineSegmented

Description

This is class nxseBlobEngineSegmented.TnxSegmentedBlobEngine.

Group

Classes

Links
TnxSegmentedBlobEngine Fields, TnxSegmentedBlobEngine Methods, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented, Classes


TnxSegmentedBlobEngine Members

TnxSegmentedBlobEngine Members
TnxSegmentedBlobEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSegmentedBlobEngine.

Class

TnxSegmentedBlobEngine Class

Protected Fields
Name | Description
bbeBlobFile | private
beHeaderSection | private
beHeapEngine | This is beHeapEngine, a member of class TnxSegmentedBlobEngine.
bseID | private
bseTableVersion | This is bseTableVersion, a member of class TnxBaseSubEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bbeBlobReadFile | TnxBaseBlobEngine
bbeGetBlobLengthFile |
beCompactSegmentLinks |
beCreateBlobHeapHeaderHandler |
beGetBlobHeapHeaderHandlerClass |
beReadFrom |
beTruncDownTo |
beVerifyBlob |
beWriteInto |
CheckValid |
CheckValidBase |
CheckValidBase |
Create |
FindSubEngineClass |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList | abstract;
QueryInterface | InxInterface
Register |
RegisterBaseClass |
Unregister |
UnregisterBaseClass |
Public Methods
Name | Description
AddBlob | TnxSegmentedBlobEngine
AddBlobLink | Add a new, empty (length 0) Blob, return new Blob number
AddFileBlob | Add a new Blob link, return new Blob number.
CheckValidAll | TnxBaseSubEngine
CheckValidFromDescriptor | Returns the engine instance to be used for the specified file.
CreateEngine | This is the overview for the CreateEngine method overload.
DeleteBlob | Add a new file Blob, return new Blob number.
Destroy |
FreeBlob | Delete a Blob; Blob number will no longer be valid after this.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetBlobLength | If the Blob length is zero, delete it; return true if deleted.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
IsBlobLink | Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.
IsFileBlob | Return the length of the Blob.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Read | Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.
Rollback | Write to or append to a Blob.
Truncate | Read all or part of a Blob
Write | Truncate the Blob to the specified length. Does *not* delete Blob if length 0.
Public Properties
Name | Description
ID | This is ID, a member of class TnxBaseSubEngine.
TableVersion | This is TableVersion, a member of class TnxBaseSubEngine.
Links
TnxSegmentedBlobEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSegmentedBlobEngine.Create Constructor

TnxSegmentedBlobEngine.Create Constructor
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseBlobDescriptor; const aFiles: TnxBlockAccessList; aTrans: TnxBaseTransaction); override;
Class

TnxSegmentedBlobEngine Class

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Class


TnxSegmentedBlobEngine.Destroy Destructor

TnxSegmentedBlobEngine.Destroy Destructor
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxSegmentedBlobEngine Class

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Class


TnxSegmentedBlobEngine Fields

TnxSegmentedBlobEngine Fields
TnxSegmentedBlobEngine Class Legend Protected Fields Send Feedback

The fields of the TnxSegmentedBlobEngine class are listed here.

Class

TnxSegmentedBlobEngine Class

Protected Fields
Name | Description
beHeaderSection | private
beHeapEngine | This is beHeapEngine, a member of class TnxSegmentedBlobEngine.
Links
TnxSegmentedBlobEngine Class, Legend, Protected Fields


TnxSegmentedBlobEngine.beHeaderSection Field

TnxSegmentedBlobEngine.beHeaderSection Field
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Fields Send Feedback
Syntax
Delphi
beHeaderSection: TnxWord16;
Description

private

Group

TnxSegmentedBlobEngine Fields

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Fields


TnxSegmentedBlobEngine.beHeapEngine Field

TnxSegmentedBlobEngine.beHeapEngine Field
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Fields Send Feedback
Syntax
Delphi
beHeapEngine: TnxBaseHeapEngine;
Description

This is beHeapEngine, a member of class TnxSegmentedBlobEngine.

Group

TnxSegmentedBlobEngine Fields

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Fields


TnxSegmentedBlobEngine Methods

TnxSegmentedBlobEngine Methods
TnxSegmentedBlobEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSegmentedBlobEngine class are listed here.

Class

TnxSegmentedBlobEngine Class

Protected Methods
Name | Description
beCompactSegmentLinks |
beCreateBlobHeapHeaderHandler |
beGetBlobHeapHeaderHandlerClass |
beReadFrom |
beTruncDownTo |
beVerifyBlob |
beWriteInto |
CheckValid |
Public Methods
Name | Description
AddBlob | TnxSegmentedBlobEngine
AddBlobLink | Add a new, empty (length 0) Blob, return new Blob number
AddFileBlob | Add a new Blob link, return new Blob number.
DeleteBlob | Add a new file Blob, return new Blob number.
FreeBlob | Delete a Blob; Blob number will no longer be valid after this.
GetBlobLength | If the Blob length is zero, delete it; return true if deleted.
IsBlobLink | Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.
IsFileBlob | Return the length of the Blob.
Read | Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.
Rollback | Write to or append to a Blob.
Truncate | Read all or part of a Blob
Write | Truncate the Blob to the specified length. Does *not* delete Blob if length 0.
Links
TnxSegmentedBlobEngine Class, Legend, Protected Methods, Public Methods


TnxSegmentedBlobEngine.AddBlob Method

TnxSegmentedBlobEngine.AddBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddBlob(aTrans: TnxBaseTransaction; out aBlobNr: TnxInt64); override;
Description

TnxSegmentedBlobEngine

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.AddBlobLink Method

TnxSegmentedBlobEngine.AddBlobLink Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddBlobLink(aTrans: TnxBaseTransaction; const aTableName: string; const aTableBlobNr: TnxInt64; out aBlobNr: TnxInt64); override;
Description

Add a new, empty (length 0) Blob, return new Blob number

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.AddFileBlob Method

TnxSegmentedBlobEngine.AddFileBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddFileBlob(aTrans: TnxBaseTransaction; const aFileName: string; out aBlobNr: TnxInt64); override;
Description

Add a new Blob link, return new Blob number.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beCompactSegmentLinks Method

TnxSegmentedBlobEngine.beCompactSegmentLinks Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure beCompactSegmentLinks(aTrans: TnxBaseTransaction; var aSegmentLinks: TnxDynBlobSegmentLinkItems);
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beCreateBlobHeapHeaderHandler Method

TnxSegmentedBlobEngine.beCreateBlobHeapHeaderHandler Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function beCreateBlobHeapHeaderHandler: TnxSegmentedBlobHeapHeaderHandler; virtual;
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beGetBlobHeapHeaderHandlerClass Method

TnxSegmentedBlobEngine.beGetBlobHeapHeaderHandlerClass Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function beGetBlobHeapHeaderHandlerClass: TnxSegmentedBlobHeapHeaderHandlerClass; virtual;
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beReadFrom Method

TnxSegmentedBlobEngine.beReadFrom Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure beReadFrom(aTrans: TnxBaseTransaction; const aHeapRef: TnxHeapRef; const aSegmentSize: TnxWord32; var aOffset: TnxWord32; var aSize: TnxWord32; aStream: TStream);
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beTruncDownTo Method

TnxSegmentedBlobEngine.beTruncDownTo Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure beTruncDownTo(aTrans: TnxBaseTransaction; var aHeapRef: TnxHeapRef; var aSegmentSize: TnxWord32; aSize: TnxWord32);
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beVerifyBlob Method

TnxSegmentedBlobEngine.beVerifyBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure beVerifyBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64);
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.beWriteInto Method

TnxSegmentedBlobEngine.beWriteInto Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure beWriteInto(aTrans: TnxBaseTransaction; var aHeapRef: TnxHeapRef; var aSegmentSize: TnxWord32; var aOffset: TnxWord32; var aBlob: PAnsiChar; var aSize: TnxWord32; aIsLast: Boolean; var aSegmentLinks: TnxDynBlobSegmentLinkItems);
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.CheckValid Method

TnxSegmentedBlobEngine.CheckValid Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
class procedure CheckValid(aDescriptor: TnxBaseBlobDescriptor); override;
Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.DeleteBlob Method

TnxSegmentedBlobEngine.DeleteBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure DeleteBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64); override;
Description

Add a new file Blob, return new Blob number.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.FreeBlob Method

TnxSegmentedBlobEngine.FreeBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function FreeBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64): Boolean; override;
Description

Delete a Blob; Blob number will no longer be valid after this.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.GetBlobLength Method

TnxSegmentedBlobEngine.GetBlobLength Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function GetBlobLength(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aLengthMethod: TnxBlobLinkGetLength; out aLength: TnxWord32): TnxResult; override;
Description

If the Blob length is zero, delete it; return true if deleted.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.IsBlobLink Method

TnxSegmentedBlobEngine.IsBlobLink Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function IsBlobLink(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; out aSrcTableName: string; out aSrcTableBlobNr: TnxInt64): Boolean; override;
Description

Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.IsFileBlob Method

TnxSegmentedBlobEngine.IsFileBlob Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function IsFileBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; out aFileName: string): Boolean; override;
Description

Return the length of the Blob.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.Read Method

TnxSegmentedBlobEngine.Read Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
function Read(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; aReadMethod: TnxBlobLinkRead; aStream: TStream): TnxResult; override;
Description

Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.Rollback Method

TnxSegmentedBlobEngine.Rollback Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure Rollback(aTrans: TnxBaseTransaction); override;
Description

Write to or append to a Blob.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.Truncate Method

TnxSegmentedBlobEngine.Truncate Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure Truncate(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aLen: TnxWord32); override;
Description

Read all or part of a Blob

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobEngine.Write Method

TnxSegmentedBlobEngine.Write Method
TnxSegmentedBlobEngine Class TnxSegmentedBlobEngine Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobEngine Methods Send Feedback
Syntax
Delphi
procedure Write(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; const aBlob); override;
Description

Truncate the Blob to the specified length. Does *not* delete Blob if length 0.

Group

TnxSegmentedBlobEngine Methods

Links
TnxSegmentedBlobEngine Class, TnxSegmentedBlobEngine Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobEngine Methods


TnxSegmentedBlobHeapHeaderHandler Class

TnxSegmentedBlobHeapHeaderHandler Class
TnxSegmentedBlobHeapHeaderHandler Fields TnxSegmentedBlobHeapHeaderHandler Methods TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Classes Send Feedback
Class Hierarchy
nxseBlobEngineSegmented_TnxSegmentedBlobHeapHeaderHandlernxseBlobEngineSegmented_TnxSegmentedBlobHeapHeaderHandlernxseBlobEngineSegmented_TnxSegmentedBlobHeapHeaderHandler
Syntax
Delphi
TnxSegmentedBlobHeapHeaderHandler = class(TnxHeapHeaderHandler);
File

nxseBlobEngineSegmented

Description

This is class nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandler.

Group

Classes

Links
TnxSegmentedBlobHeapHeaderHandler Fields, TnxSegmentedBlobHeapHeaderHandler Methods, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented, Classes


TnxSegmentedBlobHeapHeaderHandler Members

TnxSegmentedBlobHeapHeaderHandler Members
TnxSegmentedBlobHeapHeaderHandler Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxSegmentedBlobHeapHeaderHandler.

Class

TnxSegmentedBlobHeapHeaderHandler Class

Protected Fields
Name | Description
bhhhHeaderSection | private
hhhEngine | private
Protected Methods
Name | Description
Create | TnxSegmentedBlobHeapHeaderHandler
hhhAfterAllocHeapBlock | managment of additional block header fields
hhhBeforeFreeHeapBlock |
hhhGetFirstManagmentBlock | head of management block chain
hhhGetHeaderSize | TnxHeapHeaderHandler
hhhSetFirstManagmentBlock |
Public Methods
Name | Description
FreeInstance |
NewInstance | TnxObject
Links
TnxSegmentedBlobHeapHeaderHandler Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxSegmentedBlobHeapHeaderHandler.Create Constructor

TnxSegmentedBlobHeapHeaderHandler.Create Constructor
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Class Send Feedback
Syntax
Delphi
constructor Create(aBlobEngine: TnxSegmentedBlobEngine); virtual;
Description

TnxSegmentedBlobHeapHeaderHandler

Class

TnxSegmentedBlobHeapHeaderHandler Class

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Class


TnxSegmentedBlobHeapHeaderHandler Fields

TnxSegmentedBlobHeapHeaderHandler Fields
TnxSegmentedBlobHeapHeaderHandler Class Legend Protected Fields Send Feedback

The fields of the TnxSegmentedBlobHeapHeaderHandler class are listed here.

Class

TnxSegmentedBlobHeapHeaderHandler Class

Protected Fields
Name | Description
bhhhHeaderSection | private
Links
TnxSegmentedBlobHeapHeaderHandler Class, Legend, Protected Fields


TnxSegmentedBlobHeapHeaderHandler.bhhhHeaderSection Field

TnxSegmentedBlobHeapHeaderHandler.bhhhHeaderSection Field
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Fields Send Feedback
Syntax
Delphi
bhhhHeaderSection: TnxWord16;
Description

private

Group

TnxSegmentedBlobHeapHeaderHandler Fields

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Fields


TnxSegmentedBlobHeapHeaderHandler Methods

TnxSegmentedBlobHeapHeaderHandler Methods
TnxSegmentedBlobHeapHeaderHandler Class Legend Protected Methods Send Feedback

The methods of the TnxSegmentedBlobHeapHeaderHandler class are listed here.

Class

TnxSegmentedBlobHeapHeaderHandler Class

Protected Methods
Name | Description
hhhAfterAllocHeapBlock | managment of additional block header fields
hhhBeforeFreeHeapBlock |
hhhGetFirstManagmentBlock | head of management block chain
hhhSetFirstManagmentBlock |
Links
TnxSegmentedBlobHeapHeaderHandler Class, Legend, Protected Methods


TnxSegmentedBlobHeapHeaderHandler.hhhAfterAllocHeapBlock Method

TnxSegmentedBlobHeapHeaderHandler.hhhAfterAllocHeapBlock Method
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Methods Send Feedback
Syntax
Delphi
procedure hhhAfterAllocHeapBlock(aTrans: TnxBaseTransaction; aFileHeader: TnxBaseFileHeaderAccess; aBlock: PnxBlock); override;
Description

managment of additional block header fields

Group

TnxSegmentedBlobHeapHeaderHandler Methods

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Methods


TnxSegmentedBlobHeapHeaderHandler.hhhBeforeFreeHeapBlock Method

TnxSegmentedBlobHeapHeaderHandler.hhhBeforeFreeHeapBlock Method
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Methods Send Feedback
Syntax
Delphi
procedure hhhBeforeFreeHeapBlock(aTrans: TnxBaseTransaction; aFileHeader: TnxBaseFileHeaderAccess; aBlock: PnxBlock); override;
Group

TnxSegmentedBlobHeapHeaderHandler Methods

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Methods


TnxSegmentedBlobHeapHeaderHandler.hhhGetFirstManagmentBlock Method

TnxSegmentedBlobHeapHeaderHandler.hhhGetFirstManagmentBlock Method
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Methods Send Feedback
Syntax
Delphi
function hhhGetFirstManagmentBlock(aFileHeader: TnxBaseFileHeaderAccess): TnxWord32; override;
Description

head of management block chain

Group

TnxSegmentedBlobHeapHeaderHandler Methods

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Methods


TnxSegmentedBlobHeapHeaderHandler.hhhSetFirstManagmentBlock Method

TnxSegmentedBlobHeapHeaderHandler.hhhSetFirstManagmentBlock Method
TnxSegmentedBlobHeapHeaderHandler Class TnxSegmentedBlobHeapHeaderHandler Members nxseBlobEngineSegmented Namespace TnxSegmentedBlobHeapHeaderHandler Methods Send Feedback
Syntax
Delphi
procedure hhhSetFirstManagmentBlock(aFileHeader: TnxBaseFileHeaderAccess; aBlockNumber: TnxBlockNumber); override;
Group

TnxSegmentedBlobHeapHeaderHandler Methods

Links
TnxSegmentedBlobHeapHeaderHandler Class, TnxSegmentedBlobHeapHeaderHandler Members, nxseBlobEngineSegmented Namespace, TnxSegmentedBlobHeapHeaderHandler Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxseBlobEngineSegmented Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxSegmentType | This is record nxseBlobEngineSegmented.TnxSegmentType.
Namespace

nxseBlobEngineSegmented Namespace

Records
Name | Description
TnxBlobSegmentLinkItem | This is record nxseBlobEngineSegmented.TnxBlobSegmentLinkItem.
TnxSegmentedBlobSubHeader | This is record nxseBlobEngineSegmented.TnxSegmentedBlobSubHeader.
Links
Enumerations, nxseBlobEngineSegmented Namespace, Legend, Records


nxseBlobEngineSegmented.TnxBlobSegmentLinkItem Record

nxseBlobEngineSegmented.TnxBlobSegmentLinkItem Record
nxseBlobEngineSegmented Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlobSegmentLinkItem = packed record
  bsliSegmentRef: TnxHeapRef;
  bsliSegmentSize: TnxWord32;
end;
File

nxseBlobEngineSegmented

Description

This is record nxseBlobEngineSegmented.TnxBlobSegmentLinkItem.

Group

Structs, Records, Enums

Links
nxseBlobEngineSegmented, Structs, Records, Enums


nxseBlobEngineSegmented.TnxSegmentedBlobSubHeader Record

nxseBlobEngineSegmented.TnxSegmentedBlobSubHeader Record
nxseBlobEngineSegmented Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSegmentedBlobSubHeader = packed record
  bshFirstManagementBlock: TnxWord32;
end;
File

nxseBlobEngineSegmented

Description

This is record nxseBlobEngineSegmented.TnxSegmentedBlobSubHeader.

Group

Structs, Records, Enums

Links
nxseBlobEngineSegmented, Structs, Records, Enums


nxseBlobEngineSegmented.TnxSegmentType Enumeration

nxseBlobEngineSegmented.TnxSegmentType Enumeration
nxseBlobEngineSegmented Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSegmentType = ( stNullBlob, stFileBlob, stLinkBlob, stPaddedDataSegment, stDataSegment, stSegmentLinks, stFileBlobWide, stLinkBlobWide );
File

nxseBlobEngineSegmented

Description

This is record nxseBlobEngineSegmented.TnxSegmentType.

Group

Structs, Records, Enums

Links
nxseBlobEngineSegmented, Structs, Records, Enums


Types

Types
nxseBlobEngineSegmented Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxseBlobEngineSegmented Namespace

Types
Name | Description
PnxBlobSegmentLinkItem | This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItem.
PnxBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItems.
PnxSegmentedBlobSubHeader | This is type nxseBlobEngineSegmented.PnxSegmentedBlobSubHeader.
PnxSegmentType | This is type nxseBlobEngineSegmented.PnxSegmentType.
TnxBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.TnxBlobSegmentLinkItems.
TnxDynBlobSegmentLinkItems | This is type nxseBlobEngineSegmented.TnxDynBlobSegmentLinkItems.
TnxSegmentedBlobHeapHeaderHandlerClass | This is type nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandlerClass.
Links
nxseBlobEngineSegmented Namespace, Types


nxseBlobEngineSegmented.PnxBlobSegmentLinkItem Type

nxseBlobEngineSegmented.PnxBlobSegmentLinkItem Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
PnxBlobSegmentLinkItem = ^TnxBlobSegmentLinkItem;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItem.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.PnxBlobSegmentLinkItems Type

nxseBlobEngineSegmented.PnxBlobSegmentLinkItems Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
PnxBlobSegmentLinkItems = ^TnxBlobSegmentLinkItems;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.PnxBlobSegmentLinkItems.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.PnxSegmentedBlobSubHeader Type

nxseBlobEngineSegmented.PnxSegmentedBlobSubHeader Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
PnxSegmentedBlobSubHeader = ^TnxSegmentedBlobSubHeader;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.PnxSegmentedBlobSubHeader.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.PnxSegmentType Type

nxseBlobEngineSegmented.PnxSegmentType Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
PnxSegmentType = ^TnxSegmentType;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.PnxSegmentType.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.TnxBlobSegmentLinkItems Type

nxseBlobEngineSegmented.TnxBlobSegmentLinkItems Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
TnxBlobSegmentLinkItems = array[0..Pred(High(Integer) div SizeOf(TnxBlobSegmentLinkItem))] of TnxBlobSegmentLinkItem;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.TnxBlobSegmentLinkItems.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.TnxDynBlobSegmentLinkItems Type

nxseBlobEngineSegmented.TnxDynBlobSegmentLinkItems Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
TnxDynBlobSegmentLinkItems = array of TnxBlobSegmentLinkItem;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.TnxDynBlobSegmentLinkItems.

Group

Types

Links
nxseBlobEngineSegmented, Types


nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandlerClass Type

nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandlerClass Type
nxseBlobEngineSegmented Types Send Feedback
Syntax
Delphi
TnxSegmentedBlobHeapHeaderHandlerClass = class of TnxSegmentedBlobHeapHeaderHandler;
File

nxseBlobEngineSegmented

Description

This is type nxseBlobEngineSegmented.TnxSegmentedBlobHeapHeaderHandlerClass.

Group

Types

Links
nxseBlobEngineSegmented, Types


Constants

Constants
Constants nxseBlobEngineSegmented Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cstDataSegment | This is constant nxseBlobEngineSegmented.cstDataSegment.
cstFileBlob | This is constant nxseBlobEngineSegmented.cstFileBlob.
cstFileBlobWide | This is constant nxseBlobEngineSegmented.cstFileBlobWide.
cstLinkBlob | This is constant nxseBlobEngineSegmented.cstLinkBlob.
cstLinkBlobWide | This is constant nxseBlobEngineSegmented.cstLinkBlobWide.
cstNullBlob | This is constant nxseBlobEngineSegmented.cstNullBlob.
cstSegmentLinks | This is constant nxseBlobEngineSegmented.cstSegmentLinks.
rsBadBlobBlock | This is constant nxseBlobEngineSegmented.rsBadBlobBlock.
rsBadBlobNr | This is constant nxseBlobEngineSegmented.rsBadBlobNr.
rsBlobDeleted | This is constant nxseBlobEngineSegmented.rsBlobDeleted.
rsFileBlobWrite | This is constant nxseBlobEngineSegmented.rsFileBlobWrite.
rsLenMismatch | This is constant nxseBlobEngineSegmented.rsLenMismatch.
rsOfsNotInBlob | This is constant nxseBlobEngineSegmented.rsOfsNotInBlob.
Namespace

nxseBlobEngineSegmented Namespace

Links
Constants, nxseBlobEngineSegmented Namespace


nxseBlobEngineSegmented.cstDataSegment Constant

nxseBlobEngineSegmented.cstDataSegment Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstDataSegment: TnxSegmentType = stDataSegment;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstDataSegment.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstFileBlob Constant

nxseBlobEngineSegmented.cstFileBlob Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstFileBlob: TnxSegmentType = stFileBlob;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstFileBlob.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstFileBlobWide Constant

nxseBlobEngineSegmented.cstFileBlobWide Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstFileBlobWide: TnxSegmentType = stFileBlobWide;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstFileBlobWide.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstLinkBlob Constant

nxseBlobEngineSegmented.cstLinkBlob Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstLinkBlob: TnxSegmentType = stLinkBlob;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstLinkBlob.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstLinkBlobWide Constant

nxseBlobEngineSegmented.cstLinkBlobWide Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstLinkBlobWide: TnxSegmentType = stLinkBlobWide;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstLinkBlobWide.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstNullBlob Constant

nxseBlobEngineSegmented.cstNullBlob Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstNullBlob: TnxSegmentType = stNullBlob;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstNullBlob.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.cstSegmentLinks Constant

nxseBlobEngineSegmented.cstSegmentLinks Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
cstSegmentLinks: TnxSegmentType = stSegmentLinks;
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.cstSegmentLinks.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsBadBlobBlock Constant

nxseBlobEngineSegmented.rsBadBlobBlock Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsBadBlobBlock = 'Block just read from file is not a valid BLOB data block [%s, %d]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsBadBlobBlock.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsBadBlobNr Constant

nxseBlobEngineSegmented.rsBadBlobNr Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsBadBlobNr = 'Number is not a valid NexusDB BLOB number [%s, (%d)]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsBadBlobNr.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsBlobDeleted Constant

nxseBlobEngineSegmented.rsBlobDeleted Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsBlobDeleted = 'BLOB has been deleted, cannot read/delete it [%s, (%d)]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsBlobDeleted.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsFileBlobWrite Constant

nxseBlobEngineSegmented.rsFileBlobWrite Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsFileBlobWrite = 'Cannot write to a file BLOB [%s, (%d)]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsFileBlobWrite.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsLenMismatch Constant

nxseBlobEngineSegmented.rsLenMismatch Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsLenMismatch = 'Truncate length is greater than length of BLOB [%s, (%d), offset %d, length %d]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsLenMismatch.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSegmented.rsOfsNotInBlob Constant

nxseBlobEngineSegmented.rsOfsNotInBlob Constant
nxseBlobEngineSegmented Constants Send Feedback
Syntax
Delphi
rsOfsNotInBlob = 'Offset value is greater than the length of the BLOB [%s, (%d), offset %d, length %d]';
File

nxseBlobEngineSegmented

Description

This is constant nxseBlobEngineSegmented.rsOfsNotInBlob.

Group

Constants

Links
nxseBlobEngineSegmented, Constants


nxseBlobEngineSimple Namespace

nxseBlobEngineSimple Namespace
Classes Constants Legend Structs, Records, Enums Topics Types Send Feedback

This is namespace nxseBlobEngineSimple.

Classes
Name | Description
EnxSimpleBlobEngineException | This is class nxseBlobEngineSimple.EnxSimpleBlobEngineException.
TnxSimpleBlobEngine | This is class nxseBlobEngineSimple.TnxSimpleBlobEngine.
Constants
Name | Description
nxc_SigBlobBlock | block signature
nxcl_MaxBLOBLength | maximum BLOB length(i.e., 2^31)
rsBadBlobBlock | This is constant nxseBlobEngineSimple.rsBadBlobBlock.
rsBadBlobNr | This is constant nxseBlobEngineSimple.rsBadBlobNr.
rsBlobDeleted | This is constant nxseBlobEngineSimple.rsBlobDeleted.
rsFileBlobWrite | This is constant nxseBlobEngineSimple.rsFileBlobWrite.
rsLenMismatch | This is constant nxseBlobEngineSimple.rsLenMismatch.
rsOfsNotInBlob | This is constant nxseBlobEngineSimple.rsOfsNotInBlob.
Structs, Records, Enums
Name | Description
TnxBlobType | This is record nxseBlobEngineSimple.TnxBlobType.
TnxSimpleBlockHeaderBlob | Block header for Blob
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
PnxBlobArray | This is type nxseBlobEngineSimple.PnxBlobArray.
PnxSimpleBlockHeaderBlob | This is type nxseBlobEngineSimple.PnxSimpleBlockHeaderBlob.
TnxBLOBArray | This is type nxseBlobEngineSimple.TnxBLOBArray.
Links
Classes, Constants, Legend, Structs, Records, Enums, Topics, Types


Classes

Classes
Classes nxseBlobEngineSimple Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxSimpleBlobEngineException | This is class nxseBlobEngineSimple.EnxSimpleBlobEngineException.
TnxSimpleBlobEngine | This is class nxseBlobEngineSimple.TnxSimpleBlobEngine.
Namespace

nxseBlobEngineSimple Namespace

Links
Classes, nxseBlobEngineSimple Namespace, Legend


EnxSimpleBlobEngineException Class

EnxSimpleBlobEngineException Class
nxseBlobEngineSimple Classes Send Feedback
Class Hierarchy
nxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineExceptionnxseBlobEngineSimple_EnxSimpleBlobEngineException
Syntax
Delphi
EnxSimpleBlobEngineException = class(EnxBaseBlobEngineException);
File

nxseBlobEngineSimple

Description

This is class nxseBlobEngineSimple.EnxSimpleBlobEngineException.

Group

Classes

Links
nxseBlobEngineSimple, Classes


TnxSimpleBlobEngine Class

TnxSimpleBlobEngine Class
TnxSimpleBlobEngine Methods TnxSimpleBlobEngine Members nxseBlobEngineSimple Classes Send Feedback
Class Hierarchy
nxseBlobEngineSimple_TnxSimpleBlobEnginenxseBlobEngineSimple_TnxSimpleBlobEnginenxseBlobEngineSimple_TnxSimpleBlobEnginenxseBlobEngineSimple_TnxSimpleBlobEnginenxseBlobEngineSimple_TnxSimpleBlobEngine
Syntax
Delphi
TnxSimpleBlobEngine = class(TnxBaseBlobEngine);
File

nxseBlobEngineSimple

Description

This is class nxseBlobEngineSimple.TnxSimpleBlobEngine.

Group

Classes

Links
TnxSimpleBlobEngine Methods, TnxSimpleBlobEngine Members, nxseBlobEngineSimple, Classes


TnxSimpleBlobEngine Members

TnxSimpleBlobEngine Members
TnxSimpleBlobEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxSimpleBlobEngine.

Class

TnxSimpleBlobEngine Class

Protected Fields
Name | Description
bbeBlobFile | private
bseID | private
bseTableVersion | This is bseTableVersion, a member of class TnxBaseSubEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bbeBlobReadFile | TnxBaseBlobEngine
bbeGetBlobLengthFile |
BlobLinkGetLength |
BlobLinkGetTableNameAndRefNr |
BlobLinkRead |
CheckValid |
CheckValidBase |
CheckValidBase |
Create |
Create |
FileBlobLength |
FileBlobRead |
FindSubEngineClass |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList | abstract;
GetNewBlobBlock |
QueryInterface | InxInterface
ReadVfyBlobBlock | Blob retrieval & verificaTranson routines
Register |
RegisterBaseClass |
Unregister |
UnregisterBaseClass |
Public Methods
Name | Description
AddBlob | TnxSimpleBlobEngine
AddBlobLink | Add a new, empty (length 0) Blob, return new Blob number
AddFileBlob | Add a new Blob link, return new Blob number.
CheckValidAll | TnxBaseSubEngine
CheckValidFromDescriptor | Returns the engine instance to be used for the specified file.
CreateEngine | This is the overview for the CreateEngine method overload.
DeleteBlob | Add a new file Blob, return new Blob number.
FreeBlob | Delete a Blob; Blob number will no longer be valid after this.
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetBlobLength | If the Blob length is zero, delete it; return true if deleted.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
IsBlobLink | Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.
IsFileBlob | Return the length of the Blob.
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Read | Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.
Rollback | Write to or append to a Blob.
Truncate | Read all or part of a Blob
Write | Truncate the Blob to the specified length. Does *not* delete Blob if length 0.
Public Properties
Name | Description
ID | This is ID, a member of class TnxBaseSubEngine.
TableVersion | This is TableVersion, a member of class TnxBaseSubEngine.
Links
TnxSimpleBlobEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxSimpleBlobEngine Methods

TnxSimpleBlobEngine Methods
TnxSimpleBlobEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxSimpleBlobEngine class are listed here.

Class

TnxSimpleBlobEngine Class

Protected Methods
Name | Description
BlobLinkGetLength |
BlobLinkGetTableNameAndRefNr |
BlobLinkRead |
FileBlobLength |
FileBlobRead |
GetNewBlobBlock |
ReadVfyBlobBlock | Blob retrieval & verificaTranson routines
Public Methods
Name | Description
AddBlob | TnxSimpleBlobEngine
AddBlobLink | Add a new, empty (length 0) Blob, return new Blob number
AddFileBlob | Add a new Blob link, return new Blob number.
DeleteBlob | Add a new file Blob, return new Blob number.
FreeBlob | Delete a Blob; Blob number will no longer be valid after this.
GetBlobLength | If the Blob length is zero, delete it; return true if deleted.
IsBlobLink | Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.
IsFileBlob | Return the length of the Blob.
Read | Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.
Truncate | Read all or part of a Blob
Write | Truncate the Blob to the specified length. Does *not* delete Blob if length 0.
Links
TnxSimpleBlobEngine Class, Legend, Protected Methods, Public Methods


TnxSimpleBlobEngine.AddBlob Method

TnxSimpleBlobEngine.AddBlob Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddBlob(aTrans: TnxBaseTransaction; out aBlobNr: TnxInt64); override;
Description

TnxSimpleBlobEngine

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.AddBlobLink Method

TnxSimpleBlobEngine.AddBlobLink Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddBlobLink(aTrans: TnxBaseTransaction; const aTableName: string; const aTableBlobNr: TnxInt64; out aBlobNr: TnxInt64); override;
Description

Add a new, empty (length 0) Blob, return new Blob number

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.AddFileBlob Method

TnxSimpleBlobEngine.AddFileBlob Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure AddFileBlob(aTrans: TnxBaseTransaction; const aFileName: string; out aBlobNr: TnxInt64); override;
Description

Add a new Blob link, return new Blob number.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.BlobLinkGetLength Method

TnxSimpleBlobEngine.BlobLinkGetLength Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function BlobLinkGetLength(aBlobHeader: PnxByteArray; aGetLengthMethod: TnxBlobLinkGetLength; out aLength: TnxWord32): TnxResult;
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.BlobLinkGetTableNameAndRefNr Method

TnxSimpleBlobEngine.BlobLinkGetTableNameAndRefNr Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure BlobLinkGetTableNameAndRefNr(aBlobBlock: PnxBlock; out aTableName: string; out aBlobNr: TnxInt64);
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.BlobLinkRead Method

TnxSimpleBlobEngine.BlobLinkRead Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function BlobLinkRead(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: Integer; aLen: Integer; aReadMethod: TnxBlobLinkRead; aStream: TStream): TnxResult;
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.DeleteBlob Method

TnxSimpleBlobEngine.DeleteBlob Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure DeleteBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64); override;
Description

Add a new file Blob, return new Blob number.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.FileBlobLength Method

TnxSimpleBlobEngine.FileBlobLength Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function FileBlobLength(aBlobHeader: PnxByteArray; out aLength: TnxWord32): TnxResult;
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.FileBlobRead Method

TnxSimpleBlobEngine.FileBlobRead Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function FileBlobRead(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: Integer; aLen: Integer; aStream: TStream): TnxResult;
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.FreeBlob Method

TnxSimpleBlobEngine.FreeBlob Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function FreeBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64): Boolean; override;
Description

Delete a Blob; Blob number will no longer be valid after this.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.GetBlobLength Method

TnxSimpleBlobEngine.GetBlobLength Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function GetBlobLength(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aLengthMethod: TnxBlobLinkGetLength; out aLength: TnxWord32): TnxResult; override;
Description

If the Blob length is zero, delete it; return true if deleted.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.GetNewBlobBlock Method

TnxSimpleBlobEngine.GetNewBlobBlock Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function GetNewBlobBlock(aTrans: TnxBaseTransaction; aBlobHeaderAccess: TnxBaseFileHeaderAccess; out aReleaseMethod: TnxReleaseMethod): PnxBlock;
Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.IsBlobLink Method

TnxSimpleBlobEngine.IsBlobLink Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function IsBlobLink(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; out aSrcTableName: string; out aSrcTableBlobNr: TnxInt64): Boolean; override;
Description

Return True if the given Blob nr refers to a file Blob, and the filename is returned in aFileName.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.IsFileBlob Method

TnxSimpleBlobEngine.IsFileBlob Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function IsFileBlob(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; out aFileName: string): Boolean; override;
Description

Return the length of the Blob.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.Read Method

TnxSimpleBlobEngine.Read Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function Read(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; aReadMethod: TnxBlobLinkRead; aStream: TStream): TnxResult; override;
Description

Checks to see if aBlobNr is a Blob Link. If it is, it returns the the offset of the source as aSrcTableBlobNr in aSrcTableName.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.ReadVfyBlobBlock Method

TnxSimpleBlobEngine.ReadVfyBlobBlock Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
function ReadVfyBlobBlock(aTrans: TnxBaseTransaction; aMarkDirty: Boolean; aBlockNumber: TnxBlockNumber; out aReleaseMethod: TnxReleaseMethod): PnxBlock;
Description

Blob retrieval & verificaTranson routines

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.Truncate Method

TnxSimpleBlobEngine.Truncate Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure Truncate(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aLen: TnxWord32); override;
Description

Read all or part of a Blob

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


TnxSimpleBlobEngine.Write Method

TnxSimpleBlobEngine.Write Method
TnxSimpleBlobEngine Class TnxSimpleBlobEngine Members nxseBlobEngineSimple Namespace TnxSimpleBlobEngine Methods Send Feedback
Syntax
Delphi
procedure Write(aTrans: TnxBaseTransaction; const aBlobNr: TnxInt64; aOffset: TnxWord32; aLen: TnxWord32; const aBlob); override;
Description

Truncate the Blob to the specified length. Does *not* delete Blob if length 0.

Group

TnxSimpleBlobEngine Methods

Links
TnxSimpleBlobEngine Class, TnxSimpleBlobEngine Members, nxseBlobEngineSimple Namespace, TnxSimpleBlobEngine Methods


Structs, Records, Enums

Structs, Records, Enums
Enumerations nxseBlobEngineSimple Namespace Legend Records Send Feedback

The following table lists structs, records, enums in this documentation.

Enumerations
Name | Description
TnxBlobType | This is record nxseBlobEngineSimple.TnxBlobType.
Namespace

nxseBlobEngineSimple Namespace

Records
Name | Description
TnxSimpleBlockHeaderBlob | Block header for Blob
Links
Enumerations, nxseBlobEngineSimple Namespace, Legend, Records


nxseBlobEngineSimple.TnxBlobType Enumeration

nxseBlobEngineSimple.TnxBlobType Enumeration
nxseBlobEngineSimple Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxBlobType = ( btBlob, btFileBlob, btBlobLink );
File

nxseBlobEngineSimple

Description

This is record nxseBlobEngineSimple.TnxBlobType.

Group

Structs, Records, Enums

Links
nxseBlobEngineSimple, Structs, Records, Enums


nxseBlobEngineSimple.TnxSimpleBlockHeaderBlob Record

nxseBlobEngineSimple.TnxSimpleBlockHeaderBlob Record
nxseBlobEngineSimple Structs, Records, Enums Send Feedback
Syntax
Delphi
TnxSimpleBlockHeaderBlob = packed record
  bhbCommonHeader: TnxBlockCommonHeader;
  bhbBlobType: TnxBlobType;
  bhbNextBlock: TnxWord32;
  bhbBlobSize: TnxWord32;
  bhbSizeThisBlock: TnxWord16;
end;
File

nxseBlobEngineSimple

Members
Members | Description
bhbNextBlock: TnxWord32; | number of next block in chain, or -1
Description

Block header for Blob

Group

Structs, Records, Enums

Links
nxseBlobEngineSimple, Structs, Records, Enums


Types

Types
nxseBlobEngineSimple Namespace Types Send Feedback

The following table lists types in this documentation.

Namespace

nxseBlobEngineSimple Namespace

Types
Name | Description
PnxBlobArray | This is type nxseBlobEngineSimple.PnxBlobArray.
PnxSimpleBlockHeaderBlob | This is type nxseBlobEngineSimple.PnxSimpleBlockHeaderBlob.
TnxBLOBArray | This is type nxseBlobEngineSimple.TnxBLOBArray.
Links
nxseBlobEngineSimple Namespace, Types


nxseBlobEngineSimple.PnxBlobArray Type

nxseBlobEngineSimple.PnxBlobArray Type
nxseBlobEngineSimple Types Send Feedback
Syntax
Delphi
PnxBlobArray = ^TnxBLOBArray;
File

nxseBlobEngineSimple

Description

This is type nxseBlobEngineSimple.PnxBlobArray.

Group

Types

Links
nxseBlobEngineSimple, Types


nxseBlobEngineSimple.PnxSimpleBlockHeaderBlob Type

nxseBlobEngineSimple.PnxSimpleBlockHeaderBlob Type
nxseBlobEngineSimple Types Send Feedback
Syntax
Delphi
PnxSimpleBlockHeaderBlob = ^TnxSimpleBlockHeaderBlob;
File

nxseBlobEngineSimple

Description

This is type nxseBlobEngineSimple.PnxSimpleBlockHeaderBlob.

Group

Types

Links
nxseBlobEngineSimple, Types


nxseBlobEngineSimple.TnxBLOBArray Type

nxseBlobEngineSimple.TnxBLOBArray Type
nxseBlobEngineSimple Types Send Feedback
Syntax
Delphi
TnxBLOBArray = array [0..pred(nxcl_MaxBLOBLength)] of Byte;
File

nxseBlobEngineSimple

Description

This is type nxseBlobEngineSimple.TnxBLOBArray.

Group

Types

Links
nxseBlobEngineSimple, Types


Constants

Constants
Constants nxseBlobEngineSimple Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
nxc_SigBlobBlock | block signature
nxcl_MaxBLOBLength | maximum BLOB length(i.e., 2^31)
rsBadBlobBlock | This is constant nxseBlobEngineSimple.rsBadBlobBlock.
rsBadBlobNr | This is constant nxseBlobEngineSimple.rsBadBlobNr.
rsBlobDeleted | This is constant nxseBlobEngineSimple.rsBlobDeleted.
rsFileBlobWrite | This is constant nxseBlobEngineSimple.rsFileBlobWrite.
rsLenMismatch | This is constant nxseBlobEngineSimple.rsLenMismatch.
rsOfsNotInBlob | This is constant nxseBlobEngineSimple.rsOfsNotInBlob.
Namespace

nxseBlobEngineSimple Namespace

Links
Constants, nxseBlobEngineSimple Namespace


nxseBlobEngineSimple.nxc_SigBlobBlock Constant

nxseBlobEngineSimple.nxc_SigBlobBlock Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
nxc_SigBlobBlock: TnxBlockSignature = 'NXBH';
File

nxseBlobEngineSimple

Description

block signature

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.nxcl_MaxBLOBLength Constant

nxseBlobEngineSimple.nxcl_MaxBLOBLength Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
nxcl_MaxBLOBLength = Longword(High(Integer));
File

nxseBlobEngineSimple

Description

maximum BLOB length(i.e., 2^31)

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsBadBlobBlock Constant

nxseBlobEngineSimple.rsBadBlobBlock Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsBadBlobBlock = 'Block just read from file is not a valid BLOB data block [%s, %d]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsBadBlobBlock.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsBadBlobNr Constant

nxseBlobEngineSimple.rsBadBlobNr Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsBadBlobNr = 'Number is not a valid NexusDB BLOB number [%s, (%d)]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsBadBlobNr.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsBlobDeleted Constant

nxseBlobEngineSimple.rsBlobDeleted Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsBlobDeleted = 'BLOB has been deleted, cannot read/delete it [%s, (%d)]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsBlobDeleted.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsFileBlobWrite Constant

nxseBlobEngineSimple.rsFileBlobWrite Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsFileBlobWrite = 'Cannot write to a file BLOB [%s, (%d)]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsFileBlobWrite.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsLenMismatch Constant

nxseBlobEngineSimple.rsLenMismatch Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsLenMismatch = 'Truncate length is greater than length of BLOB [%s, (%d), offset %d, length %d]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsLenMismatch.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlobEngineSimple.rsOfsNotInBlob Constant

nxseBlobEngineSimple.rsOfsNotInBlob Constant
nxseBlobEngineSimple Constants Send Feedback
Syntax
Delphi
rsOfsNotInBlob = 'Offset value is greater than the length of the BLOB [%s, (%d), offset %d, length %d]';
File

nxseBlobEngineSimple

Description

This is constant nxseBlobEngineSimple.rsOfsNotInBlob.

Group

Constants

Links
nxseBlobEngineSimple, Constants


nxseBlockHeapEngineNonfragmenting Namespace

nxseBlockHeapEngineNonfragmenting Namespace
Classes Constants Legend Topics Send Feedback

This is namespace nxseBlockHeapEngineNonfragmenting.

Classes
Name | Description
EnxNonfragmentingBlockHeapEngineException | This is class nxseBlockHeapEngineNonfragmenting.EnxNonfragmentingBlockHeapEngineException.
TnxNonfragmentingBlockHeapEngine | This is class nxseBlockHeapEngineNonfragmenting.TnxNonfragmentingBlockHeapEngine.
Constants
Name | Description
DebugBlock | This is constant nxseBlockHeapEngineNonfragmenting.DebugBlock.
NullSize | This is constant nxseBlockHeapEngineNonfragmenting.NullSize.
rsInvalidSegmentNumber | This is constant nxseBlockHeapEngineNonfragmenting.rsInvalidSegmentNumber.
rsSegmentAlreadyDeleted | This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentAlreadyDeleted.
rsSegmentDeleted | This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentDeleted.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Constants | The following table lists constants in this documentation.
Links
Classes, Constants, Legend, Topics


Classes

Classes
Classes nxseBlockHeapEngineNonfragmenting Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxNonfragmentingBlockHeapEngineException | This is class nxseBlockHeapEngineNonfragmenting.EnxNonfragmentingBlockHeapEngineException.
TnxNonfragmentingBlockHeapEngine | This is class nxseBlockHeapEngineNonfragmenting.TnxNonfragmentingBlockHeapEngine.
Namespace

nxseBlockHeapEngineNonfragmenting Namespace

Links
Classes, nxseBlockHeapEngineNonfragmenting Namespace, Legend


EnxNonfragmentingBlockHeapEngineException Class

EnxNonfragmentingBlockHeapEngineException Class
nxseBlockHeapEngineNonfragmenting Classes Send Feedback
Class Hierarchy
nxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineExceptionnxseBlockHeapEngineNonfragmenting_EnxNonfragmentingBlockHeapEngineException
Syntax
Delphi
EnxNonfragmentingBlockHeapEngineException = class(EnxBaseBlockHeapEngineException);
File

nxseBlockHeapEngineNonfragmenting

Description

This is class nxseBlockHeapEngineNonfragmenting.EnxNonfragmentingBlockHeapEngineException.

Group

Classes

Links
nxseBlockHeapEngineNonfragmenting, Classes


TnxNonfragmentingBlockHeapEngine Class

TnxNonfragmentingBlockHeapEngine Class
TnxNonfragmentingBlockHeapEngine Fields TnxNonfragmentingBlockHeapEngine Methods TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Classes Send Feedback
Class Hierarchy
nxseBlockHeapEngineNonfragmenting_TnxNonfragmentingBlockHeapEnginenxseBlockHeapEngineNonfragmenting_TnxNonfragmentingBlockHeapEnginenxseBlockHeapEngineNonfragmenting_TnxNonfragmentingBlockHeapEnginenxseBlockHeapEngineNonfragmenting_TnxNonfragmentingBlockHeapEnginenxseBlockHeapEngineNonfragmenting_TnxNonfragmentingBlockHeapEngine
Syntax
Delphi
TnxNonfragmentingBlockHeapEngine = class(TnxBaseBlockHeapEngine);
File

nxseBlockHeapEngineNonfragmenting

Description

This is class nxseBlockHeapEngineNonfragmenting.TnxNonfragmentingBlockHeapEngine.

Group

Classes

Links
TnxNonfragmentingBlockHeapEngine Fields, TnxNonfragmentingBlockHeapEngine Methods, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting, Classes


TnxNonfragmentingBlockHeapEngine Members

TnxNonfragmentingBlockHeapEngine Members
TnxNonfragmentingBlockHeapEngine Class Legend Protected Fields Protected Methods Public Events Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxNonfragmentingBlockHeapEngine.

Class

TnxNonfragmentingBlockHeapEngine Class

Protected Fields
Name | Description
bbheBlockSize | private
bbheHeaderSize | This is bbheHeaderSize, a member of class TnxBaseBlockHeapEngine.
bbheMaxSegmentSize | This is bbheMaxSegmentSize, a member of class TnxBaseBlockHeapEngine.
bbheOnChanged | This is bbheOnChanged, a member of class TnxBaseBlockHeapEngine.
bheHeaderSize | private
bheTempBlock | This is bheTempBlock, a member of class TnxNonfragmentingBlockHeapEngine.
bseID | private
bseTableVersion | This is bseTableVersion, a member of class TnxBaseSubEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bbheChanged |
bheSendStateToCodeSide |
CheckValid |
CheckValidBase |
Create |
FindSubEngineClass |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList | abstract;
QueryInterface | InxInterface
Register |
RegisterBaseClass |
Unregister |
UnregisterBaseClass |
Public Events
Name | Description
OnChanged | This is OnChanged, a member of class TnxBaseBlockHeapEngine.
Public Methods
Name | Description
AllocSegment | TnxNonfragmentingBlockHeapEngine
CheckValidAll | TnxBaseSubEngine
CheckValidBaseFromDescriptor |
CompactBlock |
CreateEngine |
Destroy |
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
FreeSegment |
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetFreespace | Changed the name from GetFreeSpace to GetFreespace to avoid name clashing in BCB
GetNextSegment |
GetPrevSegment |
GetSegment |
InitBlock |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
ReAllocSegment |
VerifyBlock |
Public Properties
Name | Description
ID | This is ID, a member of class TnxBaseSubEngine.
MaxSegmentSize | This is MaxSegmentSize, a member of class TnxBaseBlockHeapEngine.
TableVersion | This is TableVersion, a member of class TnxBaseSubEngine.
Links
TnxNonfragmentingBlockHeapEngine Class, Legend, Protected Fields, Protected Methods, Public Events, Public Methods, Public Properties


TnxNonfragmentingBlockHeapEngine.Create Constructor

TnxNonfragmentingBlockHeapEngine.Create Constructor
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Class Send Feedback
Syntax
Delphi
constructor Create(aDescriptor: TnxBaseBlockHeapDescriptor; aBlockSize: TnxWord32; aHeaderSize: TnxWord16; aTableVersion: Integer); override;
Class

TnxNonfragmentingBlockHeapEngine Class

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Class


TnxNonfragmentingBlockHeapEngine.Destroy Destructor

TnxNonfragmentingBlockHeapEngine.Destroy Destructor
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxNonfragmentingBlockHeapEngine Class

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Class


TnxNonfragmentingBlockHeapEngine Fields

TnxNonfragmentingBlockHeapEngine Fields
TnxNonfragmentingBlockHeapEngine Class Legend Protected Fields Send Feedback

The fields of the TnxNonfragmentingBlockHeapEngine class are listed here.

Class

TnxNonfragmentingBlockHeapEngine Class

Protected Fields
Name | Description
bheHeaderSize | private
bheTempBlock | This is bheTempBlock, a member of class TnxNonfragmentingBlockHeapEngine.
Links
TnxNonfragmentingBlockHeapEngine Class, Legend, Protected Fields


TnxNonfragmentingBlockHeapEngine.bheHeaderSize Field

TnxNonfragmentingBlockHeapEngine.bheHeaderSize Field
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Fields Send Feedback
Syntax
Delphi
bheHeaderSize: TnxWord16;
Description

private

Group

TnxNonfragmentingBlockHeapEngine Fields

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Fields


TnxNonfragmentingBlockHeapEngine.bheTempBlock Field

TnxNonfragmentingBlockHeapEngine.bheTempBlock Field
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Fields Send Feedback
Syntax
Delphi
bheTempBlock: PnxByteArray;
Description

This is bheTempBlock, a member of class TnxNonfragmentingBlockHeapEngine.

Group

TnxNonfragmentingBlockHeapEngine Fields

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Fields


TnxNonfragmentingBlockHeapEngine Methods

TnxNonfragmentingBlockHeapEngine Methods
TnxNonfragmentingBlockHeapEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxNonfragmentingBlockHeapEngine class are listed here.

Class

TnxNonfragmentingBlockHeapEngine Class

Protected Methods
Name | Description
bbheChanged |
bheSendStateToCodeSide |
Public Methods
Name | Description
AllocSegment | TnxNonfragmentingBlockHeapEngine
CompactBlock |
FreeSegment |
GetFreespace | Changed the name from GetFreeSpace to GetFreespace to avoid name clashing in BCB
GetNextSegment |
GetPrevSegment |
GetSegment |
InitBlock |
ReAllocSegment |
VerifyBlock |
Links
TnxNonfragmentingBlockHeapEngine Class, Legend, Protected Methods, Public Methods


TnxNonfragmentingBlockHeapEngine.AllocSegment Method

TnxNonfragmentingBlockHeapEngine.AllocSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function AllocSegment(aBlock: PnxBlock; aSegmentSize: TnxSegmentSize; out aSegment: TnxSegmentRef): PnxHeapSegment; override;
Description

TnxNonfragmentingBlockHeapEngine

Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.bbheChanged Method

TnxNonfragmentingBlockHeapEngine.bbheChanged Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure bbheChanged(aBlock: PnxBlock; aSegmentCount: TnxWord16; aFreeSpaceSize: TnxWord16; aRecoverableSpace: TnxWord16); override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.bheSendStateToCodeSide Method

TnxNonfragmentingBlockHeapEngine.bheSendStateToCodeSide Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure bheSendStateToCodeSide(aBlock: PnxBlock);
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.CompactBlock Method

TnxNonfragmentingBlockHeapEngine.CompactBlock Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure CompactBlock(aBlock: PnxBlock; aResizeSegment: TnxSegmentRef = 0; aNewSegmentSize: TnxSegmentSize = 0);
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.FreeSegment Method

TnxNonfragmentingBlockHeapEngine.FreeSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure FreeSegment(aBlock: PnxBlock; aSegment: TnxSegmentRef); override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.GetFreespace Method

TnxNonfragmentingBlockHeapEngine.GetFreespace Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function GetFreespace(aBlock: PnxBlock): TnxSegmentSize; override;
Description

Changed the name from GetFreeSpace to GetFreespace to avoid name clashing in BCB

Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.GetNextSegment Method

TnxNonfragmentingBlockHeapEngine.GetNextSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function GetNextSegment(aBlock: PnxBlock; var aSegment: TnxSegmentRef; out aSegmentSize: TnxSegmentSize): PnxHeapSegment; override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.GetPrevSegment Method

TnxNonfragmentingBlockHeapEngine.GetPrevSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function GetPrevSegment(aBlock: PnxBlock; var aSegment: TnxSegmentRef; out aSegmentSize: TnxSegmentSize): PnxHeapSegment; override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.GetSegment Method

TnxNonfragmentingBlockHeapEngine.GetSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function GetSegment(aBlock: PnxBlock; aSegment: TnxSegmentRef; out aSegmentSize: TnxSegmentSize): PnxHeapSegment; override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.InitBlock Method

TnxNonfragmentingBlockHeapEngine.InitBlock Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure InitBlock(aBlock: PnxBlock); override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.ReAllocSegment Method

TnxNonfragmentingBlockHeapEngine.ReAllocSegment Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
function ReAllocSegment(aBlock: PnxBlock; aNewSegmentSize: TnxSegmentSize; aSegment: TnxSegmentRef): PnxHeapSegment; override;
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


TnxNonfragmentingBlockHeapEngine.VerifyBlock Method

TnxNonfragmentingBlockHeapEngine.VerifyBlock Method
TnxNonfragmentingBlockHeapEngine Class TnxNonfragmentingBlockHeapEngine Members nxseBlockHeapEngineNonfragmenting Namespace TnxNonfragmentingBlockHeapEngine Methods Send Feedback
Syntax
Delphi
procedure VerifyBlock(aBlock: PnxBlock; aBefore: Boolean);
Group

TnxNonfragmentingBlockHeapEngine Methods

Links
TnxNonfragmentingBlockHeapEngine Class, TnxNonfragmentingBlockHeapEngine Members, nxseBlockHeapEngineNonfragmenting Namespace, TnxNonfragmentingBlockHeapEngine Methods


Constants

Constants
Constants nxseBlockHeapEngineNonfragmenting Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
DebugBlock | This is constant nxseBlockHeapEngineNonfragmenting.DebugBlock.
NullSize | This is constant nxseBlockHeapEngineNonfragmenting.NullSize.
rsInvalidSegmentNumber | This is constant nxseBlockHeapEngineNonfragmenting.rsInvalidSegmentNumber.
rsSegmentAlreadyDeleted | This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentAlreadyDeleted.
rsSegmentDeleted | This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentDeleted.
Namespace

nxseBlockHeapEngineNonfragmenting Namespace

Links
Constants, nxseBlockHeapEngineNonfragmenting Namespace


nxseBlockHeapEngineNonfragmenting.DebugBlock Constant

nxseBlockHeapEngineNonfragmenting.DebugBlock Constant
nxseBlockHeapEngineNonfragmenting Constants Send Feedback
Syntax
Delphi
DebugBlock = 10;
File

nxseBlockHeapEngineNonfragmenting

Description

This is constant nxseBlockHeapEngineNonfragmenting.DebugBlock.

Group

Constants

Links
nxseBlockHeapEngineNonfragmenting, Constants


nxseBlockHeapEngineNonfragmenting.NullSize Constant

nxseBlockHeapEngineNonfragmenting.NullSize Constant
nxseBlockHeapEngineNonfragmenting Constants Send Feedback
Syntax
Delphi
NullSize: TnxWord16 = 0;
File

nxseBlockHeapEngineNonfragmenting

Description

This is constant nxseBlockHeapEngineNonfragmenting.NullSize.

Group

Constants

Links
nxseBlockHeapEngineNonfragmenting, Constants


nxseBlockHeapEngineNonfragmenting.rsInvalidSegmentNumber Constant

nxseBlockHeapEngineNonfragmenting.rsInvalidSegmentNumber Constant
nxseBlockHeapEngineNonfragmenting Constants Send Feedback
Syntax
Delphi
rsInvalidSegmentNumber = 'invalid segment number (%d)';
File

nxseBlockHeapEngineNonfragmenting

Description

This is constant nxseBlockHeapEngineNonfragmenting.rsInvalidSegmentNumber.

Group

Constants

Links
nxseBlockHeapEngineNonfragmenting, Constants


nxseBlockHeapEngineNonfragmenting.rsSegmentAlreadyDeleted Constant

nxseBlockHeapEngineNonfragmenting.rsSegmentAlreadyDeleted Constant
nxseBlockHeapEngineNonfragmenting Constants Send Feedback
Syntax
Delphi
rsSegmentAlreadyDeleted = 'segment already deleted (%d)';
File

nxseBlockHeapEngineNonfragmenting

Description

This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentAlreadyDeleted.

Group

Constants

Links
nxseBlockHeapEngineNonfragmenting, Constants


nxseBlockHeapEngineNonfragmenting.rsSegmentDeleted Constant

nxseBlockHeapEngineNonfragmenting.rsSegmentDeleted Constant
nxseBlockHeapEngineNonfragmenting Constants Send Feedback
Syntax
Delphi
rsSegmentDeleted = 'segment deleted (%d)';
File

nxseBlockHeapEngineNonfragmenting

Description

This is constant nxseBlockHeapEngineNonfragmenting.rsSegmentDeleted.

Group

Constants

Links
nxseBlockHeapEngineNonfragmenting, Constants


nxseEncryptionEngineBlowfishRC4 Namespace

nxseEncryptionEngineBlowfishRC4 Namespace
Classes Constants Legend Topics Variables Send Feedback

This is namespace nxseEncryptionEngineBlowfishRC4.

Classes
Name | Description
EnxBlowfishRC4EncryptionEngineException | This is class nxseEncryptionEngineBlowfishRC4.EnxBlowfishRC4EncryptionEngineException.
TnxBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxBlowfishRC4EncryptionEngine.
TnxOwnedBlowFishRC4 | This is class nxseEncryptionEngineBlowfishRC4.TnxOwnedBlowFishRC4.
TnxServerBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxServerBlowfishRC4EncryptionEngine.
TnxUserBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxUserBlowfishRC4EncryptionEngine.
Constants
Name | Description
cServerKey | TnxServerBlowfishRC4EncryptionEngine
cUserKey | TnxUserBlowfishRC4EncryptionEngine
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Variables
Name | Description
csServerKey | This is variable nxseEncryptionEngineBlowfishRC4.csServerKey.
csUserKey | This is variable nxseEncryptionEngineBlowfishRC4.csUserKey.
Links
Classes, Constants, Legend, Topics, Variables


Classes

Classes
Classes nxseEncryptionEngineBlowfishRC4 Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBlowfishRC4EncryptionEngineException | This is class nxseEncryptionEngineBlowfishRC4.EnxBlowfishRC4EncryptionEngineException.
TnxBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxBlowfishRC4EncryptionEngine.
TnxOwnedBlowFishRC4 | This is class nxseEncryptionEngineBlowfishRC4.TnxOwnedBlowFishRC4.
TnxServerBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxServerBlowfishRC4EncryptionEngine.
TnxUserBlowfishRC4EncryptionEngine | This is class nxseEncryptionEngineBlowfishRC4.TnxUserBlowfishRC4EncryptionEngine.
Namespace

nxseEncryptionEngineBlowfishRC4 Namespace

Links
Classes, nxseEncryptionEngineBlowfishRC4 Namespace, Legend


EnxBlowfishRC4EncryptionEngineException Class

EnxBlowfishRC4EncryptionEngineException Class
nxseEncryptionEngineBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxseEncryptionEngineBlowfishRC4_EnxBlowfishRC4EncryptionEngineExceptionnxseEncryptionEngineBlowfishRC4_EnxBlowfishRC4EncryptionEngineExceptionnxseEncryptionEngineBlowfishRC4_EnxBlowfishRC4EncryptionEngineExceptionnxseEncryptionEngineBlowfishRC4_EnxBlowfishRC4EncryptionEngineExceptionnxseEncryptionEngineBlowfishRC4_EnxBlowfishRC4EncryptionEngineException
Syntax
Delphi
EnxBlowfishRC4EncryptionEngineException = class(EnxBaseEncryptionEngineException);
File

nxseEncryptionEngineBlowfishRC4

Description

This is class nxseEncryptionEngineBlowfishRC4.EnxBlowfishRC4EncryptionEngineException.

Group

Classes

Links
nxseEncryptionEngineBlowfishRC4, Classes


TnxBlowfishRC4EncryptionEngine Class

TnxBlowfishRC4EncryptionEngine Class
TnxBlowfishRC4EncryptionEngine Methods TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxseEncryptionEngineBlowfishRC4_TnxBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxBlowfishRC4EncryptionEngine
Syntax
Delphi
TnxBlowfishRC4EncryptionEngine = class(TnxBaseEncryptionEngine);
File

nxseEncryptionEngineBlowfishRC4

Description

This is class nxseEncryptionEngineBlowfishRC4.TnxBlowfishRC4EncryptionEngine.

Group

Classes

Links
TnxBlowfishRC4EncryptionEngine Methods, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4, Classes


TnxBlowfishRC4EncryptionEngine Members

TnxBlowfishRC4EncryptionEngine Members
TnxBlowfishRC4EncryptionEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxBlowfishRC4EncryptionEngine.

Class

TnxBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeClearCache |
beeGetBlowfish |
beeGetKey | This is beeGetKey, a member of class TnxBlowfishRC4EncryptionEngine.
beePrepareHeader |
beeVerifyHeader |
Create |
DoCreateEngine |
Public Methods
Name | Description
AuthenticatePassword | TnxBlowfishRC4EncryptionEngine
beeAddChecksumForBlock |
beeAddChecksumForCookie |
beeChecksumSize |
beeReservedHeaderSpace |
beeReservedSpacePerBlock |
ChangePassword |
CodeBlock |
CodeBlockEx |
CreateEngine |
DecodeBlock |
DecodeBlockEx |
Destroy |
ExtractPassword |
FreeInstance |
GetRegisteredEngines |
HasEngine |
NewInstance | TnxObject
Register |
ReservedHeaderSpace |
ReservedSpacePerBlock |
Unregister |
UpdateHeaderChecksum |
VerifyHeaderChecksum |
Links
TnxBlowfishRC4EncryptionEngine Class, Legend, Protected Methods, Public Methods


TnxBlowfishRC4EncryptionEngine.Destroy Destructor

TnxBlowfishRC4EncryptionEngine.Destroy Destructor
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBlowfishRC4EncryptionEngine Class

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Class


TnxBlowfishRC4EncryptionEngine Methods

TnxBlowfishRC4EncryptionEngine Methods
TnxBlowfishRC4EncryptionEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBlowfishRC4EncryptionEngine class are listed here.

Class

TnxBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeClearCache |
beeGetBlowfish |
beeGetKey | This is beeGetKey, a member of class TnxBlowfishRC4EncryptionEngine.
beePrepareHeader |
beeVerifyHeader |
DoCreateEngine |
Public Methods
Name | Description
AuthenticatePassword | TnxBlowfishRC4EncryptionEngine
beeReservedHeaderSpace |
beeReservedSpacePerBlock |
ChangePassword |
CodeBlock |
DecodeBlock |
ExtractPassword |
Links
TnxBlowfishRC4EncryptionEngine Class, Legend, Protected Methods, Public Methods


TnxBlowfishRC4EncryptionEngine.AuthenticatePassword Method

TnxBlowfishRC4EncryptionEngine.AuthenticatePassword Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function AuthenticatePassword(aPasswords: TnxUnicodeStrings): TnxResult; override;
Description

TnxBlowfishRC4EncryptionEngine

Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeClearCache Method

TnxBlowfishRC4EncryptionEngine.beeClearCache Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
procedure beeClearCache;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeGetBlowfish Method

TnxBlowfishRC4EncryptionEngine.beeGetBlowfish Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function beeGetBlowfish: TnxOwnedBlowFishRC4;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeGetKey Method

TnxBlowfishRC4EncryptionEngine.beeGetKey Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function beeGetKey: AnsiString; virtual; abstract;
Description

This is beeGetKey, a member of class TnxBlowfishRC4EncryptionEngine.

Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beePrepareHeader Method

TnxBlowfishRC4EncryptionEngine.beePrepareHeader Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
procedure beePrepareHeader(aHeader: PnxByteArray; const aKey: RawByteString);
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeReservedHeaderSpace Method

TnxBlowfishRC4EncryptionEngine.beeReservedHeaderSpace Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
class function beeReservedHeaderSpace: TnxWord32; override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeReservedSpacePerBlock Method

TnxBlowfishRC4EncryptionEngine.beeReservedSpacePerBlock Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
class function beeReservedSpacePerBlock(aBlockSize: TnxBlockSize): TnxWord32; override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.beeVerifyHeader Method

TnxBlowfishRC4EncryptionEngine.beeVerifyHeader Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function beeVerifyHeader(aHeader: PnxByteArray; const aKey: RawByteString): Boolean;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.ChangePassword Method

TnxBlowfishRC4EncryptionEngine.ChangePassword Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
procedure ChangePassword(aHeader: PnxByteArray; const aNewPassword: UnicodeString); override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.CodeBlock Method

TnxBlowfishRC4EncryptionEngine.CodeBlock Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
procedure CodeBlock(const aBlockIn; out aBlockOut; aBlockLen: TnxWord32; aRandomizer: TnxWord32); override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.DecodeBlock Method

TnxBlowfishRC4EncryptionEngine.DecodeBlock Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
procedure DecodeBlock(var aBlock; aBlockLen: TnxWord32; aRandomizer: TnxWord32); override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.DoCreateEngine Method

TnxBlowfishRC4EncryptionEngine.DoCreateEngine Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
class function DoCreateEngine(const aName: string; aPasswords: TnxUnicodeStrings; aHeader: PnxByteArray; aCreating: Boolean; aForServer: Boolean; out aEngine: TnxBaseEncryptionEngine): TnxResult; override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxBlowfishRC4EncryptionEngine.ExtractPassword Method

TnxBlowfishRC4EncryptionEngine.ExtractPassword Method
TnxBlowfishRC4EncryptionEngine Class TnxBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function ExtractPassword: UnicodeString; override;
Group

TnxBlowfishRC4EncryptionEngine Methods

Links
TnxBlowfishRC4EncryptionEngine Class, TnxBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxBlowfishRC4EncryptionEngine Methods


TnxOwnedBlowFishRC4 Class

TnxOwnedBlowFishRC4 Class
TnxOwnedBlowFishRC4 Fields TnxOwnedBlowFishRC4 Methods TnxOwnedBlowFishRC4 Members nxseEncryptionEngineBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxseEncryptionEngineBlowfishRC4_TnxOwnedBlowFishRC4nxseEncryptionEngineBlowfishRC4_TnxOwnedBlowFishRC4nxseEncryptionEngineBlowfishRC4_TnxOwnedBlowFishRC4nxseEncryptionEngineBlowfishRC4_TnxOwnedBlowFishRC4
Syntax
Delphi
TnxOwnedBlowFishRC4 = class(TnxBlowFishRC4);
File

nxseEncryptionEngineBlowfishRC4

Description

This is class nxseEncryptionEngineBlowfishRC4.TnxOwnedBlowFishRC4.

Group

Classes

Links
TnxOwnedBlowFishRC4 Fields, TnxOwnedBlowFishRC4 Methods, TnxOwnedBlowFishRC4 Members, nxseEncryptionEngineBlowfishRC4, Classes


TnxOwnedBlowFishRC4 Members

TnxOwnedBlowFishRC4 Members
TnxOwnedBlowFishRC4 Class Legend Protected Fields Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxOwnedBlowFishRC4.

Class

TnxOwnedBlowFishRC4 Class

Protected Fields
Name | Description
bfChk | This is bfChk, a member of class TnxBlowFishRC4.
bfIVl | This is bfIVl, a member of class TnxBlowFishRC4.
bfIVr | This is bfIVr, a member of class TnxBlowFishRC4.
bfKey | private
bfKSF | This is bfKSF, a member of class TnxBlowFishRC4.
bfMustReset | This is bfMustReset, a member of class TnxBlowFishRC4.
bfP | This is bfP, a member of class TnxBlowFishRC4.
bfRC4 | This is bfRC4, a member of class TnxBlowFishRC4.
bfS | This is bfS, a member of class TnxBlowFishRC4.
obfOwner | private
Protected Methods
Name | Description
bfCreateRandom | This is bfCreateRandom, a member of class TnxBlowFishRC4.
bfDecipher |
bfDecodeAlt |
bfEncipher |
bfEncodeAlt |
bfInitialize |
bfPrepare |
bfReset |
bfWrapDecode |
bfWrapEncode |
cbDecodeAlt |
cbDecodeAlt |
cbEncodeAlt |
cbEncodeAlt |
RegisterKeyWrap |
Unregister |
Public Methods
Name | Description
AltLock | TnxCipherBase
AltPriority |
AltPriority |
AltRegister |
AltUnLock |
AltUnregister |
BlockLength | The length of a single block in bytes. Determines the expected size of the actual parameters of RandomIV, ResetIV, GetRandomBlock, Final.
BlockLength |
Create | TnxOwnedBlowFishRC4
Decode | Decrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
Decode |
DecodeAlt | Decrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
DecodeKey |
DecodeStorage | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeStorage is intended to be used by an EncryptionEngine. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DecodeTransport | Decrypt aLen bytes of aData using the default mode of the implementation. DecodeTransport is intended to be used by a SecuredTransport. This method will also process the IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
DeriveKey |
DeriveKey |
Destroy |
Encode | Encrypt aLen bytes of aData using the default mode of the implementation. aLen must be a multiple of BlockLength.
Encode |
EncodeAlt | Encrypt aLen bytes of aData using the alternative mode of the implementation and a random key. EncodeAlt/DecodeAlt are used for instance specific encryption of temporary data. aLen must be a multiple of BlockLength.
EncodeKey |
EncodeStorage | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeStorage is intended to be used by an EncryptionEngine. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
EncodeTransport | Encrypt aLen bytes of aData using the default mode of the implementation. EncodeTransport is intended to be used by a SecuredTransport. This method will also generate an IV and the MAC. Descendant classes might override this method to provide a stateless implementation.
Final | Call Final to get the Message Authentication Code corresponding to the aData previously passed to Encode or Decode. The size of the variable passed as aIV must be at least BlockLength.
Final |
FindKeyWrapClass |
FreeInstance |
GenerateRandom | GenerateRandom is the default method for generating keys for the cipher.
GetRandom64 |
GetRandomBlock | Generate a fresh random block using the implementation specific default random bit generator and store it in aData. The size of the variable passed as aData must be at least BlockLength.
GetRandomBlock |
GetRegisteredKeyWrapClasses |
KeyWrapName |
KeyWrapName |
KeyWrapPriority |
KeyWrapPriority |
MustFindKeyWrapClass |
NewInstance | TnxObject
PreferredKeyWrapClass |
RandomIV |
RandomIVBlock | Generate a fresh IV using the implementation specific default random bit generator and store it in aIV. RandomIV automatically calls ResetIV. RandomIV is typically called prior to a call to Encode. The size of the variable passed as aIV must be at least BlockLength.
RandomIVBlock |
Recycle |
ResetIV |
ResetIVBlock | Reset the state of the cipher chaining mode with aIV. ResetIV is typically called prior to a call to Decode. The size of the variable passed as aIV must be at least BlockLength.
ResetIVBlock |
SelfTest |
SetKeys | Initialize the cipher with aKey as key.
SetKeys |
TheCipher |
Links
TnxOwnedBlowFishRC4 Class, Legend, Protected Fields, Protected Methods, Public Methods


TnxOwnedBlowFishRC4.Create Constructor

TnxOwnedBlowFishRC4.Create Constructor
TnxOwnedBlowFishRC4 Class TnxOwnedBlowFishRC4 Members nxseEncryptionEngineBlowfishRC4 Namespace TnxOwnedBlowFishRC4 Class Send Feedback
Syntax
Delphi
constructor Create(aOwner: TnxBlowfishRC4EncryptionEngine); reintroduce;
Description

TnxOwnedBlowFishRC4

Class

TnxOwnedBlowFishRC4 Class

Links
TnxOwnedBlowFishRC4 Class, TnxOwnedBlowFishRC4 Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxOwnedBlowFishRC4 Class


TnxOwnedBlowFishRC4 Fields

TnxOwnedBlowFishRC4 Fields
TnxOwnedBlowFishRC4 Class Legend Protected Fields Send Feedback

The fields of the TnxOwnedBlowFishRC4 class are listed here.

Class

TnxOwnedBlowFishRC4 Class

Protected Fields
Name | Description
obfOwner | private
Links
TnxOwnedBlowFishRC4 Class, Legend, Protected Fields


TnxOwnedBlowFishRC4.obfOwner Field

TnxOwnedBlowFishRC4.obfOwner Field
TnxOwnedBlowFishRC4 Class TnxOwnedBlowFishRC4 Members nxseEncryptionEngineBlowfishRC4 Namespace TnxOwnedBlowFishRC4 Fields Send Feedback
Syntax
Delphi
obfOwner: TnxBlowfishRC4EncryptionEngine;
Description

private

Group

TnxOwnedBlowFishRC4 Fields

Links
TnxOwnedBlowFishRC4 Class, TnxOwnedBlowFishRC4 Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxOwnedBlowFishRC4 Fields


TnxOwnedBlowFishRC4 Methods

TnxOwnedBlowFishRC4 Methods
TnxOwnedBlowFishRC4 Class Legend Public Methods Send Feedback

The methods of the TnxOwnedBlowFishRC4 class are listed here.

Class

TnxOwnedBlowFishRC4 Class

Public Methods
Name | Description
Recycle |
Links
TnxOwnedBlowFishRC4 Class, Legend, Public Methods


TnxOwnedBlowFishRC4.Recycle Method

TnxOwnedBlowFishRC4.Recycle Method
TnxOwnedBlowFishRC4 Class TnxOwnedBlowFishRC4 Members nxseEncryptionEngineBlowfishRC4 Namespace TnxOwnedBlowFishRC4 Methods Send Feedback
Syntax
Delphi
procedure Recycle;
Group

TnxOwnedBlowFishRC4 Methods

Links
TnxOwnedBlowFishRC4 Class, TnxOwnedBlowFishRC4 Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxOwnedBlowFishRC4 Methods


TnxServerBlowfishRC4EncryptionEngine Class

TnxServerBlowfishRC4EncryptionEngine Class
TnxServerBlowfishRC4EncryptionEngine Methods TnxServerBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxseEncryptionEngineBlowfishRC4_TnxServerBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxServerBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxServerBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxServerBlowfishRC4EncryptionEngine
Syntax
Delphi
TnxServerBlowfishRC4EncryptionEngine = class(TnxBlowfishRC4EncryptionEngine);
File

nxseEncryptionEngineBlowfishRC4

Description

This is class nxseEncryptionEngineBlowfishRC4.TnxServerBlowfishRC4EncryptionEngine.

Group

Classes

Links
TnxServerBlowfishRC4EncryptionEngine Methods, TnxServerBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4, Classes


TnxServerBlowfishRC4EncryptionEngine Members

TnxServerBlowfishRC4EncryptionEngine Members
TnxServerBlowfishRC4EncryptionEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxServerBlowfishRC4EncryptionEngine.

Class

TnxServerBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeClearCache |
beeGetBlowfish |
beeGetKey |
beePrepareHeader |
beeVerifyHeader |
CodeBlock | these 2 methods are only for source compatibility with old encryption engines. Overwrite CodeBlockEx and DecodeBlockEx instead.
Create |
DecodeBlock | This is DecodeBlock, a member of class TnxBaseEncryptionEngine.
DoCreateEngine |
DoCreateEngine |
Public Methods
Name | Description
AuthenticatePassword | TnxBlowfishRC4EncryptionEngine
AuthenticatePassword | TnxBaseEncryptionEngine
beeAddChecksumForBlock |
beeAddChecksumForCookie |
beeChecksumSize |
beeReservedHeaderSpace |
beeReservedHeaderSpace |
beeReservedSpacePerBlock |
beeReservedSpacePerBlock |
ChangePassword |
ChangePassword |
CodeBlock |
CodeBlockEx |
CreateEngine |
DecodeBlock |
DecodeBlockEx |
Destroy |
ExtractPassword |
ExtractPassword |
FreeInstance |
GetRegisteredEngines |
HasEngine |
NewInstance | TnxObject
Register |
ReservedHeaderSpace |
ReservedSpacePerBlock |
Unregister |
UpdateHeaderChecksum |
VerifyHeaderChecksum |
Links
TnxServerBlowfishRC4EncryptionEngine Class, Legend, Protected Methods, Public Methods


TnxServerBlowfishRC4EncryptionEngine Methods

TnxServerBlowfishRC4EncryptionEngine Methods
TnxServerBlowfishRC4EncryptionEngine Class Legend Protected Methods Send Feedback

The methods of the TnxServerBlowfishRC4EncryptionEngine class are listed here.

Class

TnxServerBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeGetKey |
Links
TnxServerBlowfishRC4EncryptionEngine Class, Legend, Protected Methods


TnxServerBlowfishRC4EncryptionEngine.beeGetKey Method

TnxServerBlowfishRC4EncryptionEngine.beeGetKey Method
TnxServerBlowfishRC4EncryptionEngine Class TnxServerBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxServerBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function beeGetKey: AnsiString; override;
Group

TnxServerBlowfishRC4EncryptionEngine Methods

Links
TnxServerBlowfishRC4EncryptionEngine Class, TnxServerBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxServerBlowfishRC4EncryptionEngine Methods


TnxUserBlowfishRC4EncryptionEngine Class

TnxUserBlowfishRC4EncryptionEngine Class
TnxUserBlowfishRC4EncryptionEngine Methods TnxUserBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Classes Send Feedback
Class Hierarchy
nxseEncryptionEngineBlowfishRC4_TnxUserBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxUserBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxUserBlowfishRC4EncryptionEnginenxseEncryptionEngineBlowfishRC4_TnxUserBlowfishRC4EncryptionEngine
Syntax
Delphi
TnxUserBlowfishRC4EncryptionEngine = class(TnxBlowfishRC4EncryptionEngine);
File

nxseEncryptionEngineBlowfishRC4

Description

This is class nxseEncryptionEngineBlowfishRC4.TnxUserBlowfishRC4EncryptionEngine.

Group

Classes

Links
TnxUserBlowfishRC4EncryptionEngine Methods, TnxUserBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4, Classes


TnxUserBlowfishRC4EncryptionEngine Members

TnxUserBlowfishRC4EncryptionEngine Members
TnxUserBlowfishRC4EncryptionEngine Class Legend Protected Methods Public Methods Send Feedback

The following tables list the members exposed by TnxUserBlowfishRC4EncryptionEngine.

Class

TnxUserBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeClearCache |
beeGetBlowfish |
beeGetKey |
beePrepareHeader |
beeVerifyHeader |
CodeBlock | these 2 methods are only for source compatibility with old encryption engines. Overwrite CodeBlockEx and DecodeBlockEx instead.
Create |
DecodeBlock | This is DecodeBlock, a member of class TnxBaseEncryptionEngine.
DoCreateEngine |
DoCreateEngine |
Public Methods
Name | Description
AuthenticatePassword | TnxBlowfishRC4EncryptionEngine
AuthenticatePassword | TnxBaseEncryptionEngine
beeAddChecksumForBlock |
beeAddChecksumForCookie |
beeChecksumSize |
beeReservedHeaderSpace |
beeReservedHeaderSpace |
beeReservedSpacePerBlock |
beeReservedSpacePerBlock |
ChangePassword |
ChangePassword |
CodeBlock |
CodeBlockEx |
CreateEngine |
DecodeBlock |
DecodeBlockEx |
Destroy |
ExtractPassword |
ExtractPassword |
FreeInstance |
GetRegisteredEngines |
HasEngine |
NewInstance | TnxObject
Register |
ReservedHeaderSpace |
ReservedSpacePerBlock |
Unregister |
UpdateHeaderChecksum |
VerifyHeaderChecksum |
Links
TnxUserBlowfishRC4EncryptionEngine Class, Legend, Protected Methods, Public Methods


TnxUserBlowfishRC4EncryptionEngine Methods

TnxUserBlowfishRC4EncryptionEngine Methods
TnxUserBlowfishRC4EncryptionEngine Class Legend Protected Methods Send Feedback

The methods of the TnxUserBlowfishRC4EncryptionEngine class are listed here.

Class

TnxUserBlowfishRC4EncryptionEngine Class

Protected Methods
Name | Description
beeGetKey |
Links
TnxUserBlowfishRC4EncryptionEngine Class, Legend, Protected Methods


TnxUserBlowfishRC4EncryptionEngine.beeGetKey Method

TnxUserBlowfishRC4EncryptionEngine.beeGetKey Method
TnxUserBlowfishRC4EncryptionEngine Class TnxUserBlowfishRC4EncryptionEngine Members nxseEncryptionEngineBlowfishRC4 Namespace TnxUserBlowfishRC4EncryptionEngine Methods Send Feedback
Syntax
Delphi
function beeGetKey: AnsiString; override;
Group

TnxUserBlowfishRC4EncryptionEngine Methods

Links
TnxUserBlowfishRC4EncryptionEngine Class, TnxUserBlowfishRC4EncryptionEngine Members, nxseEncryptionEngineBlowfishRC4 Namespace, TnxUserBlowfishRC4EncryptionEngine Methods


Variables

Variables
nxseEncryptionEngineBlowfishRC4 Namespace Variables Send Feedback

The following table lists variables in this documentation.

Namespace

nxseEncryptionEngineBlowfishRC4 Namespace

Variables
Name | Description
csServerKey | This is variable nxseEncryptionEngineBlowfishRC4.csServerKey.
csUserKey | This is variable nxseEncryptionEngineBlowfishRC4.csUserKey.
Links
nxseEncryptionEngineBlowfishRC4 Namespace, Variables


nxseEncryptionEngineBlowfishRC4.csServerKey Variable

nxseEncryptionEngineBlowfishRC4.csServerKey Variable
nxseEncryptionEngineBlowfishRC4 Variables Send Feedback
Syntax
Delphi
csServerKey: AnsiString;
File

nxseEncryptionEngineBlowfishRC4

Description

This is variable nxseEncryptionEngineBlowfishRC4.csServerKey.

Group

Variables

Links
nxseEncryptionEngineBlowfishRC4, Variables


nxseEncryptionEngineBlowfishRC4.csUserKey Variable

nxseEncryptionEngineBlowfishRC4.csUserKey Variable
nxseEncryptionEngineBlowfishRC4 Variables Send Feedback
Syntax
Delphi
csUserKey: AnsiString;
File

nxseEncryptionEngineBlowfishRC4

Description

This is variable nxseEncryptionEngineBlowfishRC4.csUserKey.

Group

Variables

Links
nxseEncryptionEngineBlowfishRC4, Variables


Constants

Constants
Constants nxseEncryptionEngineBlowfishRC4 Namespace Send Feedback

The following table lists constants in this documentation.

Constants
Name | Description
cServerKey | TnxServerBlowfishRC4EncryptionEngine
cUserKey | TnxUserBlowfishRC4EncryptionEngine
Namespace

nxseEncryptionEngineBlowfishRC4 Namespace

Links
Constants, nxseEncryptionEngineBlowfishRC4 Namespace


nxseEncryptionEngineBlowfishRC4.cServerKey Constant

nxseEncryptionEngineBlowfishRC4.cServerKey Constant
nxseEncryptionEngineBlowfishRC4 Constants Send Feedback
Syntax
Delphi
cServerKey: array [1..64] of Byte = (120, 51, 50, 53, 99, 54, 52, 110, 56, 57, 54, 109, 57, 48, 47, 86, 88, 36, 71, 89, 36, 167, 99, 53, 118, 55, 56, 110, 56, 98, 57, 56, 54, 107, 86, 38, 120, 50, 53, 49, 121, 97, 120, 98, 55, 116, 103, 105, 107, 116, 103, 110, 110, 113, 51, 120, 118, 52, 53, 98, 118, 51, 99, 104);
File

nxseEncryptionEngineBlowfishRC4

Description

TnxServerBlowfishRC4EncryptionEngine

Group

Constants

Links
nxseEncryptionEngineBlowfishRC4, Constants


nxseEncryptionEngineBlowfishRC4.cUserKey Constant

nxseEncryptionEngineBlowfishRC4.cUserKey Constant
nxseEncryptionEngineBlowfishRC4 Constants Send Feedback
Syntax
Delphi
cUserKey: array [1..64] of Byte = (104, 54, 56, 52, 118, 102, 53, 52, 53, 99, 38, 47, 72, 66, 53, 54, 104, 167, 37, 51, 50, 52, 52, 98, 57, 223, 108, 252, 44, 109, 48, 110, 57, 120, 102, 60, 51, 100, 122, 120, 104, 55, 54, 111, 246, 104, 56, 57, 104, 55, 111, 44, 118, 109, 99, 54, 52, 53, 103, 51, 101, 117, 53, 111);
File

nxseEncryptionEngineBlowfishRC4

Description

TnxUserBlowfishRC4EncryptionEngine

Group

Constants

Links
nxseEncryptionEngineBlowfishRC4, Constants


nxseFulltextEngineCursor Namespace

nxseFulltextEngineCursor Namespace
Classes Constants Functions Interfaces Legend Structs, Records, Enums Topics Types Variables Send Feedback

Fulltext specific engines.

Classes
Name | Description
EnxBaseSeparatorTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseSeparatorTokenFilterCursorEngineException.
EnxBaseTokenExtractorCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenExtractorCursorEngineException.
EnxBaseTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenFilterCursorEngineException.
EnxBaseTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenIndexCursorEngineException.
EnxBaseTokenSourceCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenSourceCursorEngineException.
EnxBitArrayTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxBitArrayTokenIndexCursorEngineException.
EnxFieldTokenExtractorCursorEngineException | This is class nxseFulltextEngineCursor.EnxFieldTokenExtractorCursorEngineException.
EnxFulltextCursorEngineException | This is class nxseFulltextEngineCursor.EnxFulltextCursorEngineException.
EnxFulltextIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxFulltextIndexCursorEngineException.
EnxMainIndexTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxMainIndexTokenIndexCursorEngineException.
EnxTokenExtractorHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenExtractorHubCursorEngineException.
EnxTokenFilterHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenFilterHubCursorEngineException.
EnxTokenIndexHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenIndexHubCursorEngineException.
EnxWideCharSeparatorTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxWideCharSeparatorTokenFilterCursorEngineException.
TnxBaseFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseFoldStringTokenFilterCursorEngine.
TnxBaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseLocaleMappingTokenFilterCursorEngine.
TnxBaseProcessingTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseProcessingTokenIndexCursorEngine.
TnxBaseSeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseSeparatorTokenFilterCursorEngine.
TnxBaseTokenExtractorCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenExtractorCursorEngine.
TnxBaseTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenFilterCursorEngine.
TnxBaseTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenIndexCursorEngine.
TnxBaseTokenSourceCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenSourceCursorEngine.
TnxBitArrayTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBitArrayTokenIndexCursorEngine.
TnxCategorySeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCategorySeparatorTokenFilterCursorEngine.
TnxCustomFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCustomFoldStringTokenFilterCursorEngine.
TnxCustomLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCustomLocaleMappingTokenFilterCursorEngine.
TnxDecomposeFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxDecomposeFoldStringTokenFilterCursorEngine.
TnxFieldTokenExtractorCursorEngine | This is class nxseFulltextEngineCursor.TnxFieldTokenExtractorCursorEngine.
TnxFulltextCursorEngine | This is class nxseFulltextEngineCursor.TnxFulltextCursorEngine.
TnxFulltextIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxFulltextIndexCursorEngine.
TnxLowercaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxLowercaseLocaleMappingTokenFilterCursorEngine.
TnxMainIndexTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxMainIndexTokenIndexCursorEngine.
TnxPreComposeFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxPreComposeFoldStringTokenFilterCursorEngine.
TnxStringReplaceTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxStringReplaceTokenFilterCursorEngine.
TnxToken | TnxToken
TnxTokenExtractorHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenExtractorHubCursorEngine.
TnxTokenExtractorSourceRedirectorCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenExtractorSourceRedirectorCursorEngine.
TnxTokenFilterHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenFilterHubCursorEngine.
TnxTokenIndexHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenIndexHubCursorEngine.
TnxTransformerTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxTransformerTokenFilterCursorEngine.
TnxUniqueTokenContainer | This is class nxseFulltextEngineCursor.TnxUniqueTokenContainer.
TnxUppercaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxUppercaseLocaleMappingTokenFilterCursorEngine.
TnxWideCharSeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxWideCharSeparatorTokenFilterCursorEngine.
Constants
Name | Description
csCursorEngine | This is constant nxseFulltextEngineCursor.csCursorEngine.
csFulltext | This is constant nxseFulltextEngineCursor.csFulltext.
csFulltextIndex | This is constant nxseFulltextEngineCursor.csFulltextIndex.
csTableEngine | This is constant nxseFulltextEngineCursor.csTableEngine.
csTokenExtractor | This is constant nxseFulltextEngineCursor.csTokenExtractor.
csTokenFilter | This is constant nxseFulltextEngineCursor.csTokenFilter.
csTokenIndex | This is constant nxseFulltextEngineCursor.csTokenIndex.
rsBticeUpdateIndexNotSupported | This is constant nxseFulltextEngineCursor.rsBticeUpdateIndexNotSupported.
Functions
Name | Description
nxCreateToken | nxCreateToken
Interfaces
Name | Description
InxToken | This is class nxseFulltextEngineCursor.InxToken.
Structs, Records, Enums
Name | Description
TnxMainIndexTokenIndexCursorEngineLocation |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Functions | The following table lists functions in this documentation.
Structs, Records, Enums | The following table lists structs, records, enums in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Constants | The following table lists constants in this documentation.
Types
Name | Description
TnxBaseTokenExtractorCursorEngineClass | This is type nxseFulltextEngineCursor.TnxBaseTokenExtractorCursorEngineClass.
TnxBaseTokenExtractorCursorEngines | This is type nxseFulltextEngineCursor.TnxBaseTokenExtractorCursorEngines.
TnxBaseTokenFilterCursorEngineClass | This is type nxseFulltextEngineCursor.TnxBaseTokenFilterCursorEngineClass.
TnxBaseTokenFilterCursorEngines | This is type nxseFulltextEngineCursor.TnxBaseTokenFilterCursorEngines.
TnxBaseTokenIndexCursorEngineClass | This is type nxseFulltextEngineCursor.TnxBaseTokenIndexCursorEngineClass.
TnxBaseTokenIndexCursorEngines | This is type nxseFulltextEngineCursor.TnxBaseTokenIndexCursorEngines.
TnxBitArrayTokenIndexCursorEngineClass | This is type nxseFulltextEngineCursor.TnxBitArrayTokenIndexCursorEngineClass.
TnxFieldTokenExtractorCursorEngineClass | This is type nxseFulltextEngineCursor.TnxFieldTokenExtractorCursorEngineClass.
TnxFulltextCursorEngineClass | This is type nxseFulltextEngineCursor.TnxFulltextCursorEngineClass.
TnxFulltextIndexCursorEngineClass | This is type nxseFulltextEngineCursor.TnxFulltextIndexCursorEngineClass.
TnxFulltextIndexCursorEngines | This is type nxseFulltextEngineCursor.TnxFulltextIndexCursorEngines.
TnxTokenExtractorHubCursorEngineClass | This is type nxseFulltextEngineCursor.TnxTokenExtractorHubCursorEngineClass.
TnxTokenFilterHubCursorEngineClass | This is type nxseFulltextEngineCursor.TnxTokenFilterHubCursorEngineClass.
TnxTokenIndexHubCursorEngineClass | This is type nxseFulltextEngineCursor.TnxTokenIndexHubCursorEngineClass.
TnxTokenMethod | This is type nxseFulltextEngineCursor.TnxTokenMethod.
Variables
Name | Description
_FulltextIndexCursorEngineList | This is variable nxseFulltextEngineCursor._FulltextIndexCursorEngineList.
_TokenExtractorCursorEngineList | This is variable nxseFulltextEngineCursor._TokenExtractorCursorEngineList.
_TokenFilterCursorEngineList | This is variable nxseFulltextEngineCursor._TokenFilterCursorEngineList.
_TokenIndexCursorEngineList | This is variable nxseFulltextEngineCursor._TokenIndexCursorEngineList.
Links
Classes, Constants, Functions, Interfaces, Legend, Structs, Records, Enums, Topics, Types, Variables


Classes

Classes
Classes nxseFulltextEngineCursor Namespace Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
EnxBaseSeparatorTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseSeparatorTokenFilterCursorEngineException.
EnxBaseTokenExtractorCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenExtractorCursorEngineException.
EnxBaseTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenFilterCursorEngineException.
EnxBaseTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenIndexCursorEngineException.
EnxBaseTokenSourceCursorEngineException | This is class nxseFulltextEngineCursor.EnxBaseTokenSourceCursorEngineException.
EnxBitArrayTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxBitArrayTokenIndexCursorEngineException.
EnxFieldTokenExtractorCursorEngineException | This is class nxseFulltextEngineCursor.EnxFieldTokenExtractorCursorEngineException.
EnxFulltextCursorEngineException | This is class nxseFulltextEngineCursor.EnxFulltextCursorEngineException.
EnxFulltextIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxFulltextIndexCursorEngineException.
EnxMainIndexTokenIndexCursorEngineException | This is class nxseFulltextEngineCursor.EnxMainIndexTokenIndexCursorEngineException.
EnxTokenExtractorHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenExtractorHubCursorEngineException.
EnxTokenFilterHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenFilterHubCursorEngineException.
EnxTokenIndexHubCursorEngineException | This is class nxseFulltextEngineCursor.EnxTokenIndexHubCursorEngineException.
EnxWideCharSeparatorTokenFilterCursorEngineException | This is class nxseFulltextEngineCursor.EnxWideCharSeparatorTokenFilterCursorEngineException.
TnxBaseFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseFoldStringTokenFilterCursorEngine.
TnxBaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseLocaleMappingTokenFilterCursorEngine.
TnxBaseProcessingTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseProcessingTokenIndexCursorEngine.
TnxBaseSeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseSeparatorTokenFilterCursorEngine.
TnxBaseTokenExtractorCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenExtractorCursorEngine.
TnxBaseTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenFilterCursorEngine.
TnxBaseTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenIndexCursorEngine.
TnxBaseTokenSourceCursorEngine | This is class nxseFulltextEngineCursor.TnxBaseTokenSourceCursorEngine.
TnxBitArrayTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxBitArrayTokenIndexCursorEngine.
TnxCategorySeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCategorySeparatorTokenFilterCursorEngine.
TnxCustomFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCustomFoldStringTokenFilterCursorEngine.
TnxCustomLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxCustomLocaleMappingTokenFilterCursorEngine.
TnxDecomposeFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxDecomposeFoldStringTokenFilterCursorEngine.
TnxFieldTokenExtractorCursorEngine | This is class nxseFulltextEngineCursor.TnxFieldTokenExtractorCursorEngine.
TnxFulltextCursorEngine | This is class nxseFulltextEngineCursor.TnxFulltextCursorEngine.
TnxFulltextIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxFulltextIndexCursorEngine.
TnxLowercaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxLowercaseLocaleMappingTokenFilterCursorEngine.
TnxMainIndexTokenIndexCursorEngine | This is class nxseFulltextEngineCursor.TnxMainIndexTokenIndexCursorEngine.
TnxPreComposeFoldStringTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxPreComposeFoldStringTokenFilterCursorEngine.
TnxStringReplaceTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxStringReplaceTokenFilterCursorEngine.
TnxToken | TnxToken
TnxTokenExtractorHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenExtractorHubCursorEngine.
TnxTokenExtractorSourceRedirectorCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenExtractorSourceRedirectorCursorEngine.
TnxTokenFilterHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenFilterHubCursorEngine.
TnxTokenIndexHubCursorEngine | This is class nxseFulltextEngineCursor.TnxTokenIndexHubCursorEngine.
TnxTransformerTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxTransformerTokenFilterCursorEngine.
TnxUniqueTokenContainer | This is class nxseFulltextEngineCursor.TnxUniqueTokenContainer.
TnxUppercaseLocaleMappingTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxUppercaseLocaleMappingTokenFilterCursorEngine.
TnxWideCharSeparatorTokenFilterCursorEngine | This is class nxseFulltextEngineCursor.TnxWideCharSeparatorTokenFilterCursorEngine.
Namespace

nxseFulltextEngineCursor Namespace

Links
Classes, nxseFulltextEngineCursor Namespace, Legend


EnxBaseSeparatorTokenFilterCursorEngineException Class

EnxBaseSeparatorTokenFilterCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseSeparatorTokenFilterCursorEngineException
Syntax
Delphi
EnxBaseSeparatorTokenFilterCursorEngineException = class(EnxBaseTokenFilterCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBaseSeparatorTokenFilterCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxBaseTokenExtractorCursorEngineException Class

EnxBaseTokenExtractorCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenExtractorCursorEngineException
Syntax
Delphi
EnxBaseTokenExtractorCursorEngineException = class(EnxBaseTokenSourceCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBaseTokenExtractorCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxBaseTokenFilterCursorEngineException Class

EnxBaseTokenFilterCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenFilterCursorEngineException
Syntax
Delphi
EnxBaseTokenFilterCursorEngineException = class(EnxBaseTokenSourceCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBaseTokenFilterCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxBaseTokenIndexCursorEngineException Class

EnxBaseTokenIndexCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBaseTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenIndexCursorEngineException
Syntax
Delphi
EnxBaseTokenIndexCursorEngineException = class(EnxBaseRegisterableEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBaseTokenIndexCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxBaseTokenSourceCursorEngineException Class

EnxBaseTokenSourceCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBaseTokenSourceCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenSourceCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenSourceCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenSourceCursorEngineExceptionnxseFulltextEngineCursor_EnxBaseTokenSourceCursorEngineException
Syntax
Delphi
EnxBaseTokenSourceCursorEngineException = class(EnxBaseRegisterableEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBaseTokenSourceCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxBitArrayTokenIndexCursorEngineException Class

EnxBitArrayTokenIndexCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxBitArrayTokenIndexCursorEngineException
Syntax
Delphi
EnxBitArrayTokenIndexCursorEngineException = class(EnxBaseTokenIndexCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxBitArrayTokenIndexCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxFieldTokenExtractorCursorEngineException Class

EnxFieldTokenExtractorCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineExceptionnxseFulltextEngineCursor_EnxFieldTokenExtractorCursorEngineException
Syntax
Delphi
EnxFieldTokenExtractorCursorEngineException = class(EnxBaseTokenExtractorCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxFieldTokenExtractorCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxFulltextCursorEngineException Class

EnxFulltextCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxFulltextCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextCursorEngineException
Syntax
Delphi
EnxFulltextCursorEngineException = class(EnxBaseFulltextCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxFulltextCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxFulltextIndexCursorEngineException Class

EnxFulltextIndexCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxFulltextIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxFulltextIndexCursorEngineException
Syntax
Delphi
EnxFulltextIndexCursorEngineException = class(EnxBaseRegisterableEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxFulltextIndexCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxMainIndexTokenIndexCursorEngineException Class

EnxMainIndexTokenIndexCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineExceptionnxseFulltextEngineCursor_EnxMainIndexTokenIndexCursorEngineException
Syntax
Delphi
EnxMainIndexTokenIndexCursorEngineException = class(EnxBaseTokenIndexCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxMainIndexTokenIndexCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxTokenExtractorHubCursorEngineException Class

EnxTokenExtractorHubCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenExtractorHubCursorEngineException
Syntax
Delphi
EnxTokenExtractorHubCursorEngineException = class(EnxBaseTokenExtractorCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxTokenExtractorHubCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxTokenFilterHubCursorEngineException Class

EnxTokenFilterHubCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenFilterHubCursorEngineException
Syntax
Delphi
EnxTokenFilterHubCursorEngineException = class(EnxBaseTokenFilterCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxTokenFilterHubCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxTokenIndexHubCursorEngineException Class

EnxTokenIndexHubCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineExceptionnxseFulltextEngineCursor_EnxTokenIndexHubCursorEngineException
Syntax
Delphi
EnxTokenIndexHubCursorEngineException = class(EnxBaseTokenIndexCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxTokenIndexHubCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


EnxWideCharSeparatorTokenFilterCursorEngineException Class

EnxWideCharSeparatorTokenFilterCursorEngineException Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineExceptionnxseFulltextEngineCursor_EnxWideCharSeparatorTokenFilterCursorEngineException
Syntax
Delphi
EnxWideCharSeparatorTokenFilterCursorEngineException = class(EnxBaseSeparatorTokenFilterCursorEngineException);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.EnxWideCharSeparatorTokenFilterCursorEngineException.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxBaseFoldStringTokenFilterCursorEngine Class

TnxBaseFoldStringTokenFilterCursorEngine Class
TnxBaseFoldStringTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseFoldStringTokenFilterCursorEngine
Syntax
Delphi
TnxBaseFoldStringTokenFilterCursorEngine = class(TnxTransformerTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseFoldStringTokenFilterCursorEngine.

Group

Classes

Links
TnxBaseFoldStringTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseFoldStringTokenFilterCursorEngine Members

TnxBaseFoldStringTokenFilterCursorEngine Members
TnxBaseFoldStringTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseFoldStringTokenFilterCursorEngine.

Class

TnxBaseFoldStringTokenFilterCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
ttfceTransformer | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextToken | TnxTransformerTokenFilterCursorEngine
Reset |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseFoldStringTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseFoldStringTokenFilterCursorEngine.Create Constructor

TnxBaseFoldStringTokenFilterCursorEngine.Create Constructor
TnxBaseFoldStringTokenFilterCursorEngine Class TnxBaseFoldStringTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseFoldStringTokenFilterCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Class

TnxBaseFoldStringTokenFilterCursorEngine Class

Links
TnxBaseFoldStringTokenFilterCursorEngine Class, TnxBaseFoldStringTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseFoldStringTokenFilterCursorEngine Class


TnxBaseLocaleMappingTokenFilterCursorEngine Class

TnxBaseLocaleMappingTokenFilterCursorEngine Class
TnxBaseLocaleMappingTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseLocaleMappingTokenFilterCursorEngine
Syntax
Delphi
TnxBaseLocaleMappingTokenFilterCursorEngine = class(TnxTransformerTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseLocaleMappingTokenFilterCursorEngine.

Group

Classes

Links
TnxBaseLocaleMappingTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseLocaleMappingTokenFilterCursorEngine Members

TnxBaseLocaleMappingTokenFilterCursorEngine Members
TnxBaseLocaleMappingTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseLocaleMappingTokenFilterCursorEngine.

Class

TnxBaseLocaleMappingTokenFilterCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
ttfceTransformer | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextToken | TnxTransformerTokenFilterCursorEngine
Reset |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseLocaleMappingTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseLocaleMappingTokenFilterCursorEngine.Create Constructor

TnxBaseLocaleMappingTokenFilterCursorEngine.Create Constructor
TnxBaseLocaleMappingTokenFilterCursorEngine Class TnxBaseLocaleMappingTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseLocaleMappingTokenFilterCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Class

TnxBaseLocaleMappingTokenFilterCursorEngine Class

Links
TnxBaseLocaleMappingTokenFilterCursorEngine Class, TnxBaseLocaleMappingTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseLocaleMappingTokenFilterCursorEngine Class


TnxBaseProcessingTokenIndexCursorEngine Class

TnxBaseProcessingTokenIndexCursorEngine Class
TnxBaseProcessingTokenIndexCursorEngine Fields TnxBaseProcessingTokenIndexCursorEngine Methods TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseProcessingTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseProcessingTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseProcessingTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseProcessingTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseProcessingTokenIndexCursorEngine
Syntax
Delphi
TnxBaseProcessingTokenIndexCursorEngine = class(TnxBaseTokenIndexCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseProcessingTokenIndexCursorEngine.

Group

Classes

Links
TnxBaseProcessingTokenIndexCursorEngine Fields, TnxBaseProcessingTokenIndexCursorEngine Methods, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseProcessingTokenIndexCursorEngine Members

TnxBaseProcessingTokenIndexCursorEngine Members
TnxBaseProcessingTokenIndexCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseProcessingTokenIndexCursorEngine.

Class

TnxBaseProcessingTokenIndexCursorEngine Class

Protected Fields
Name | Description
bpticeComparer | private
bpticeTransformer | This is bpticeTransformer, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bticeParentFulltextIndexCursorEngine | private
bticeParentTokenIndexHubCursorEngine | This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubNew | This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubOld | This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenIndexTableEngine | This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceNew | This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceOld | This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bpticeAdditionalCompareFlags |
bpticeGetMaxTokenLength | This is bpticeGetMaxTokenLength, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bpticeUpdateToken | This is bpticeUpdateToken, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bpticeUpdateTokens | This is the overview for the bpticeUpdateTokens method overload.
bpticeUpdateTokensForField | This is the overview for the bpticeUpdateTokensForField method overload.
bticeGetTokenFilterNew | TnxBaseTokenIndexCursorEngine
bticeGetTokenFilterNewCount |
bticeGetTokenFilterOld |
bticeGetTokenFilterOldCount |
bticeUpdateIndex |
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
ParentTokenIndexHubCursorEngine | This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNew | This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndexTableEngine | This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxBaseProcessingTokenIndexCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseProcessingTokenIndexCursorEngine.Create Constructor

TnxBaseProcessingTokenIndexCursorEngine.Create Constructor
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine); override;
Class

TnxBaseProcessingTokenIndexCursorEngine Class

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Class


TnxBaseProcessingTokenIndexCursorEngine Fields

TnxBaseProcessingTokenIndexCursorEngine Fields
TnxBaseProcessingTokenIndexCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseProcessingTokenIndexCursorEngine class are listed here.

Class

TnxBaseProcessingTokenIndexCursorEngine Class

Protected Fields
Name | Description
bpticeComparer | private
bpticeTransformer | This is bpticeTransformer, a member of class TnxBaseProcessingTokenIndexCursorEngine.
Links
TnxBaseProcessingTokenIndexCursorEngine Class, Legend, Protected Fields


TnxBaseProcessingTokenIndexCursorEngine.bpticeComparer Field

TnxBaseProcessingTokenIndexCursorEngine.bpticeComparer Field
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bpticeComparer: InxWideStringComparer;
Description

private

Group

TnxBaseProcessingTokenIndexCursorEngine Fields

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Fields


TnxBaseProcessingTokenIndexCursorEngine.bpticeTransformer Field

TnxBaseProcessingTokenIndexCursorEngine.bpticeTransformer Field
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bpticeTransformer: InxWideStringTransformer;
Description

This is bpticeTransformer, a member of class TnxBaseProcessingTokenIndexCursorEngine.

Group

TnxBaseProcessingTokenIndexCursorEngine Fields

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Fields


TnxBaseProcessingTokenIndexCursorEngine Methods

TnxBaseProcessingTokenIndexCursorEngine Methods
TnxBaseProcessingTokenIndexCursorEngine Class Legend Protected Methods Send Feedback

The methods of the TnxBaseProcessingTokenIndexCursorEngine class are listed here.

Class

TnxBaseProcessingTokenIndexCursorEngine Class

Protected Methods
Name | Description
bpticeAdditionalCompareFlags |
bpticeGetMaxTokenLength | This is bpticeGetMaxTokenLength, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bpticeUpdateToken | This is bpticeUpdateToken, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bpticeUpdateTokens | This is the overview for the bpticeUpdateTokens method overload.
bpticeUpdateTokensForField | This is the overview for the bpticeUpdateTokensForField method overload.
Links
TnxBaseProcessingTokenIndexCursorEngine Class, Legend, Protected Methods


TnxBaseProcessingTokenIndexCursorEngine.bpticeAdditionalCompareFlags Method

TnxBaseProcessingTokenIndexCursorEngine.bpticeAdditionalCompareFlags Method
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bpticeAdditionalCompareFlags: Cardinal; virtual;
Group

TnxBaseProcessingTokenIndexCursorEngine Methods

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Methods


TnxBaseProcessingTokenIndexCursorEngine.bpticeGetMaxTokenLength Method

TnxBaseProcessingTokenIndexCursorEngine.bpticeGetMaxTokenLength Method
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bpticeGetMaxTokenLength: Integer; virtual; abstract;
Description

This is bpticeGetMaxTokenLength, a member of class TnxBaseProcessingTokenIndexCursorEngine.

Group

TnxBaseProcessingTokenIndexCursorEngine Methods

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Methods


TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateToken Method

TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateToken Method
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseProcessingTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
procedure bpticeUpdateToken(aTrans: TnxBaseTransaction; aToken: TnxWideString; aField: TnxInt16; const aLocation; aNew: Boolean); virtual; abstract;
Description

This is bpticeUpdateToken, a member of class TnxBaseProcessingTokenIndexCursorEngine.

Group

TnxBaseProcessingTokenIndexCursorEngine Methods

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseProcessingTokenIndexCursorEngine Methods


bpticeUpdateTokens Method

bpticeUpdateTokens Method
TnxBaseProcessingTokenIndexCursorEngine Methods Send Feedback

This is the overview for the bpticeUpdateTokens method overload.

Overload List
Name | Description
TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens (TnxBaseTransaction, TnxUniqueTokenContainer, , Boolean) |
TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens (TnxBaseTransaction, TnxUniqueTokenContainer, TnxUniqueTokenContainer, ) | TnxBaseProcessingTokenIndexCursorEngine
Group

TnxBaseProcessingTokenIndexCursorEngine Methods

Links
TnxBaseProcessingTokenIndexCursorEngine Methods


TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens Method (TnxBaseTransaction, TnxUniqueTokenContainer, , Boolean)

TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens Method (TnxBaseTransaction, TnxUniqueTokenContainer, , Boolean)
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace bpticeUpdateTokens Method Send Feedback
Syntax
Delphi
procedure bpticeUpdateTokens(aTrans: TnxBaseTransaction; aTokens: TnxUniqueTokenContainer; const aLocation; aNew: Boolean); overload;
Group

bpticeUpdateTokens Method

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, bpticeUpdateTokens Method


TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens Method (TnxBaseTransaction, TnxUniqueTokenContainer, TnxUniqueTokenContainer, )

TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokens Method (TnxBaseTransaction, TnxUniqueTokenContainer, TnxUniqueTokenContainer, )
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace bpticeUpdateTokens Method Send Feedback
Syntax
Delphi
procedure bpticeUpdateTokens(aTrans: TnxBaseTransaction; aOldTokens: TnxUniqueTokenContainer; aNewTokens: TnxUniqueTokenContainer; const aLocation); overload;
Description

TnxBaseProcessingTokenIndexCursorEngine

Group

bpticeUpdateTokens Method

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, bpticeUpdateTokens Method


bpticeUpdateTokensForField Method

bpticeUpdateTokensForField Method
TnxBaseProcessingTokenIndexCursorEngine Methods Send Feedback

This is the overview for the bpticeUpdateTokensForField method overload.

Overload List
Name | Description
TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField (TnxBaseTransaction, TnxWideStrings, TnxInt16, , Boolean) |
TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField (TnxBaseTransaction, TnxWideStrings, TnxWideStrings, TnxInt16, ) |
Group

TnxBaseProcessingTokenIndexCursorEngine Methods

Links
TnxBaseProcessingTokenIndexCursorEngine Methods


TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField Method (TnxBaseTransaction, TnxWideStrings, TnxInt16, , Boolean)

TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField Method (TnxBaseTransaction, TnxWideStrings, TnxInt16, , Boolean)
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace bpticeUpdateTokensForField Method Send Feedback
Syntax
Delphi
procedure bpticeUpdateTokensForField(aTrans: TnxBaseTransaction; aTokens: TnxWideStrings; aField: TnxInt16; const aLocation; aNew: Boolean); overload;
Group

bpticeUpdateTokensForField Method

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, bpticeUpdateTokensForField Method


TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField Method (TnxBaseTransaction, TnxWideStrings, TnxWideStrings, TnxInt16, )

TnxBaseProcessingTokenIndexCursorEngine.bpticeUpdateTokensForField Method (TnxBaseTransaction, TnxWideStrings, TnxWideStrings, TnxInt16, )
TnxBaseProcessingTokenIndexCursorEngine Class TnxBaseProcessingTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace bpticeUpdateTokensForField Method Send Feedback
Syntax
Delphi
procedure bpticeUpdateTokensForField(aTrans: TnxBaseTransaction; aOldTokens: TnxWideStrings; aNewTokens: TnxWideStrings; aField: TnxInt16; const aLocation); overload;
Group

bpticeUpdateTokensForField Method

Links
TnxBaseProcessingTokenIndexCursorEngine Class, TnxBaseProcessingTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, bpticeUpdateTokensForField Method


TnxBaseSeparatorTokenFilterCursorEngine Class

TnxBaseSeparatorTokenFilterCursorEngine Class
TnxBaseSeparatorTokenFilterCursorEngine Fields TnxBaseSeparatorTokenFilterCursorEngine Methods TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseSeparatorTokenFilterCursorEngine
Syntax
Delphi
TnxBaseSeparatorTokenFilterCursorEngine = class(TnxBaseTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseSeparatorTokenFilterCursorEngine.

Group

Classes

Links
TnxBaseSeparatorTokenFilterCursorEngine Fields, TnxBaseSeparatorTokenFilterCursorEngine Methods, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseSeparatorTokenFilterCursorEngine Members

TnxBaseSeparatorTokenFilterCursorEngine Members
TnxBaseSeparatorTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseSeparatorTokenFilterCursorEngine.

Class

TnxBaseSeparatorTokenFilterCursorEngine Class

Protected Fields
Name | Description
bstfceInputPos | This is bstfceInputPos, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceInputToken | private
bstfceNextDistance | This is bstfceNextDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceSeparatorDistance | This is bstfceSeparatorDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
Protected Methods
Name | Description
_AddRef |
_Release |
bstfceIsSeparator | This is bstfceIsSeparator, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
Create | TnxBaseSeparatorTokenFilterCursorEngine
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseSeparatorTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseSeparatorTokenFilterCursorEngine.Create Constructor

TnxBaseSeparatorTokenFilterCursorEngine.Create Constructor
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Description

TnxBaseSeparatorTokenFilterCursorEngine

Class

TnxBaseSeparatorTokenFilterCursorEngine Class

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Class


TnxBaseSeparatorTokenFilterCursorEngine Fields

TnxBaseSeparatorTokenFilterCursorEngine Fields
TnxBaseSeparatorTokenFilterCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseSeparatorTokenFilterCursorEngine class are listed here.

Class

TnxBaseSeparatorTokenFilterCursorEngine Class

Protected Fields
Name | Description
bstfceInputPos | This is bstfceInputPos, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceInputToken | private
bstfceNextDistance | This is bstfceNextDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceSeparatorDistance | This is bstfceSeparatorDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
Links
TnxBaseSeparatorTokenFilterCursorEngine Class, Legend, Protected Fields


TnxBaseSeparatorTokenFilterCursorEngine.bstfceInputPos Field

TnxBaseSeparatorTokenFilterCursorEngine.bstfceInputPos Field
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
bstfceInputPos: Integer;
Description

This is bstfceInputPos, a member of class TnxBaseSeparatorTokenFilterCursorEngine.

Group

TnxBaseSeparatorTokenFilterCursorEngine Fields

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Fields


TnxBaseSeparatorTokenFilterCursorEngine.bstfceInputToken Field

TnxBaseSeparatorTokenFilterCursorEngine.bstfceInputToken Field
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
bstfceInputToken: InxToken;
Description

private

Group

TnxBaseSeparatorTokenFilterCursorEngine Fields

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Fields


TnxBaseSeparatorTokenFilterCursorEngine.bstfceNextDistance Field

TnxBaseSeparatorTokenFilterCursorEngine.bstfceNextDistance Field
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
bstfceNextDistance: Integer;
Description

This is bstfceNextDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.

Group

TnxBaseSeparatorTokenFilterCursorEngine Fields

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Fields


TnxBaseSeparatorTokenFilterCursorEngine.bstfceSeparatorDistance Field

TnxBaseSeparatorTokenFilterCursorEngine.bstfceSeparatorDistance Field
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
bstfceSeparatorDistance: Integer;
Description

This is bstfceSeparatorDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.

Group

TnxBaseSeparatorTokenFilterCursorEngine Fields

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Fields


TnxBaseSeparatorTokenFilterCursorEngine Methods

TnxBaseSeparatorTokenFilterCursorEngine Methods
TnxBaseSeparatorTokenFilterCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseSeparatorTokenFilterCursorEngine class are listed here.

Class

TnxBaseSeparatorTokenFilterCursorEngine Class

Protected Methods
Name | Description
bstfceIsSeparator | This is bstfceIsSeparator, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
Public Methods
Name | Description
NextToken |
Reset |
Links
TnxBaseSeparatorTokenFilterCursorEngine Class, Legend, Protected Methods, Public Methods


TnxBaseSeparatorTokenFilterCursorEngine.bstfceIsSeparator Method

TnxBaseSeparatorTokenFilterCursorEngine.bstfceIsSeparator Method
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
function bstfceIsSeparator(aWideChar: TnxWideChar): Boolean; virtual; abstract;
Description

This is bstfceIsSeparator, a member of class TnxBaseSeparatorTokenFilterCursorEngine.

Group

TnxBaseSeparatorTokenFilterCursorEngine Methods

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Methods


TnxBaseSeparatorTokenFilterCursorEngine.NextToken Method

TnxBaseSeparatorTokenFilterCursorEngine.NextToken Method
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
function NextToken: InxToken; override;
Group

TnxBaseSeparatorTokenFilterCursorEngine Methods

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Methods


TnxBaseSeparatorTokenFilterCursorEngine.Reset Method

TnxBaseSeparatorTokenFilterCursorEngine.Reset Method
TnxBaseSeparatorTokenFilterCursorEngine Class TnxBaseSeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseSeparatorTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Reset; override;
Group

TnxBaseSeparatorTokenFilterCursorEngine Methods

Links
TnxBaseSeparatorTokenFilterCursorEngine Class, TnxBaseSeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseSeparatorTokenFilterCursorEngine Methods


TnxBaseTokenExtractorCursorEngine Class

TnxBaseTokenExtractorCursorEngine Class
Create Constructor TnxBaseTokenExtractorCursorEngine Fields TnxBaseTokenExtractorCursorEngine Methods TnxBaseTokenExtractorCursorEngine Properties TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxBaseTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxBaseTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxBaseTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxBaseTokenExtractorCursorEngine
Syntax
Delphi
TnxBaseTokenExtractorCursorEngine = class(TnxBaseTokenSourceCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseTokenExtractorCursorEngine.

Group

Classes

Links
Create Constructor, TnxBaseTokenExtractorCursorEngine Fields, TnxBaseTokenExtractorCursorEngine Methods, TnxBaseTokenExtractorCursorEngine Properties, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseTokenExtractorCursorEngine Members

TnxBaseTokenExtractorCursorEngine Members
TnxBaseTokenExtractorCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenExtractorCursorEngine.

Class

TnxBaseTokenExtractorCursorEngine Class

Protected Fields
Name | Description
bteceParentTokenExtractorHubCursorEngine | private
bteceTokenExtractorTableEngine | This is bteceTokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHub | This is bteceTokenFilterHub, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHubSource | This is bteceTokenFilterHubSource, a member of class TnxBaseTokenExtractorCursorEngine.
btsceParentFulltextIndexCursorEngine | private
Protected Methods
Name | Description
_AddRef |
_Release |
bteceGetTokenFilter | TnxBaseTokenExtractorCursorEngine
bteceGetTokenFilterCount |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
Initialize |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextTokenInternal |
Reset |
ResetInternal |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenExtractorHubCursorEngine | This is ParentTokenExtractorHubCursorEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenExtractorTableEngine | This is TokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilterCount | Filter
Links
TnxBaseTokenExtractorCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBaseTokenExtractorCursorEngine Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBaseTokenExtractorCursorEngine.Create (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine) |
TnxBaseTokenExtractorCursorEngine.Create (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine) |
Class

TnxBaseTokenExtractorCursorEngine Class

Links
TnxBaseTokenExtractorCursorEngine Class


TnxBaseTokenExtractorCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine)

TnxBaseTokenExtractorCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine)
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine); virtual; overload;
Group

Create Constructor

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenExtractorCursorEngine.Create Constructor (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine)

TnxBaseTokenExtractorCursorEngine.Create Constructor (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine)
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxTokenExtractorHubCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine); overload;
Group

Create Constructor

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenExtractorCursorEngine.Destroy Destructor

TnxBaseTokenExtractorCursorEngine.Destroy Destructor
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseTokenExtractorCursorEngine Class

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Class


TnxBaseTokenExtractorCursorEngine Fields

TnxBaseTokenExtractorCursorEngine Fields
TnxBaseTokenExtractorCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenExtractorCursorEngine class are listed here.

Class

TnxBaseTokenExtractorCursorEngine Class

Protected Fields
Name | Description
bteceParentTokenExtractorHubCursorEngine | private
bteceTokenExtractorTableEngine | This is bteceTokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHub | This is bteceTokenFilterHub, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHubSource | This is bteceTokenFilterHubSource, a member of class TnxBaseTokenExtractorCursorEngine.
Links
TnxBaseTokenExtractorCursorEngine Class, Legend, Protected Fields


TnxBaseTokenExtractorCursorEngine.bteceParentTokenExtractorHubCursorEngine Field

TnxBaseTokenExtractorCursorEngine.bteceParentTokenExtractorHubCursorEngine Field
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
bteceParentTokenExtractorHubCursorEngine: TnxTokenExtractorHubCursorEngine;
Description

private

Group

TnxBaseTokenExtractorCursorEngine Fields

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Fields


TnxBaseTokenExtractorCursorEngine.bteceTokenExtractorTableEngine Field

TnxBaseTokenExtractorCursorEngine.bteceTokenExtractorTableEngine Field
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
bteceTokenExtractorTableEngine: TnxBaseTokenExtractorTableEngine;
Description

This is bteceTokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Fields

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Fields


TnxBaseTokenExtractorCursorEngine.bteceTokenFilterHub Field

TnxBaseTokenExtractorCursorEngine.bteceTokenFilterHub Field
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
bteceTokenFilterHub: TnxTokenFilterHubCursorEngine;
Description

This is bteceTokenFilterHub, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Fields

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Fields


TnxBaseTokenExtractorCursorEngine.bteceTokenFilterHubSource Field

TnxBaseTokenExtractorCursorEngine.bteceTokenFilterHubSource Field
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
bteceTokenFilterHubSource: TnxBaseTokenSourceCursorEngine;
Description

This is bteceTokenFilterHubSource, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Fields

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Fields


TnxBaseTokenExtractorCursorEngine Methods

TnxBaseTokenExtractorCursorEngine Methods
TnxBaseTokenExtractorCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenExtractorCursorEngine class are listed here.

Class

TnxBaseTokenExtractorCursorEngine Class

Protected Methods
Name | Description
bteceGetTokenFilter | TnxBaseTokenExtractorCursorEngine
bteceGetTokenFilterCount |
GetList |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Initialize |
NextToken |
NextTokenInternal |
Reset |
ResetInternal |
Links
TnxBaseTokenExtractorCursorEngine Class, Legend, Protected Methods, Public Methods


TnxBaseTokenExtractorCursorEngine.bteceGetTokenFilter Method

TnxBaseTokenExtractorCursorEngine.bteceGetTokenFilter Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function bteceGetTokenFilter(aInx: Integer): TnxBaseTokenFilterCursorEngine;
Description

TnxBaseTokenExtractorCursorEngine

Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.bteceGetTokenFilterCount Method

TnxBaseTokenExtractorCursorEngine.bteceGetTokenFilterCount Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function bteceGetTokenFilterCount: Integer;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


CreateFor Method

CreateFor Method
TnxBaseTokenExtractorCursorEngine Methods Send Feedback

This is the overview for the CreateFor method overload.

Overload List
Name | Description
TnxBaseTokenExtractorCursorEngine.CreateFor (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine) |
TnxBaseTokenExtractorCursorEngine.CreateFor (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine) |
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine)

TnxBaseTokenExtractorCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenExtractorTableEngine)
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine): TnxBaseTokenExtractorCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenExtractorCursorEngine.CreateFor Method (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine)

TnxBaseTokenExtractorCursorEngine.CreateFor Method (TnxTokenExtractorHubCursorEngine, TnxBaseTokenExtractorTableEngine)
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxTokenExtractorHubCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine): TnxBaseTokenExtractorCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenExtractorCursorEngine.GetList Method

TnxBaseTokenExtractorCursorEngine.GetList Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.Initialize Method

TnxBaseTokenExtractorCursorEngine.Initialize Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Initialize(aRecord: PnxByteArray; const aRefNr: TnxInt64; aReadOrg: Boolean); virtual;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.NextToken Method

TnxBaseTokenExtractorCursorEngine.NextToken Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function NextToken: InxToken; override;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.NextTokenInternal Method

TnxBaseTokenExtractorCursorEngine.NextTokenInternal Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function NextTokenInternal: InxToken; virtual;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.Reset Method

TnxBaseTokenExtractorCursorEngine.Reset Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Reset; override;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine.ResetInternal Method

TnxBaseTokenExtractorCursorEngine.ResetInternal Method
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure ResetInternal; virtual;
Group

TnxBaseTokenExtractorCursorEngine Methods

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Methods


TnxBaseTokenExtractorCursorEngine Properties

TnxBaseTokenExtractorCursorEngine Properties
TnxBaseTokenExtractorCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenExtractorCursorEngine class are listed here.

Class

TnxBaseTokenExtractorCursorEngine Class

Public Properties
Name | Description
ParentTokenExtractorHubCursorEngine | This is ParentTokenExtractorHubCursorEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenExtractorTableEngine | This is TokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilterCount | Filter
Links
TnxBaseTokenExtractorCursorEngine Class, Legend, Public Properties


TnxBaseTokenExtractorCursorEngine.ParentTokenExtractorHubCursorEngine Property

TnxBaseTokenExtractorCursorEngine.ParentTokenExtractorHubCursorEngine Property
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentTokenExtractorHubCursorEngine: TnxTokenExtractorHubCursorEngine;
Description

This is ParentTokenExtractorHubCursorEngine, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Properties

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Properties


TnxBaseTokenExtractorCursorEngine.TokenExtractorTableEngine Property

TnxBaseTokenExtractorCursorEngine.TokenExtractorTableEngine Property
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorTableEngine: TnxBaseTokenExtractorTableEngine;
Description

This is TokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Properties

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Properties


TnxBaseTokenExtractorCursorEngine.TokenFilter Property

TnxBaseTokenExtractorCursorEngine.TokenFilter Property
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilter [aInx : Integer]: TnxBaseTokenFilterCursorEngine;
Description

This is TokenFilter, a member of class TnxBaseTokenExtractorCursorEngine.

Group

TnxBaseTokenExtractorCursorEngine Properties

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Properties


TnxBaseTokenExtractorCursorEngine.TokenFilterCount Property

TnxBaseTokenExtractorCursorEngine.TokenFilterCount Property
TnxBaseTokenExtractorCursorEngine Class TnxBaseTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenExtractorCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterCount: Integer;
Description

Filter

Group

TnxBaseTokenExtractorCursorEngine Properties

Links
TnxBaseTokenExtractorCursorEngine Class, TnxBaseTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenExtractorCursorEngine Properties


TnxBaseTokenFilterCursorEngine Class

TnxBaseTokenFilterCursorEngine Class
Create Constructor TnxBaseTokenFilterCursorEngine Fields TnxBaseTokenFilterCursorEngine Methods TnxBaseTokenFilterCursorEngine Properties TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseTokenFilterCursorEnginenxseFulltextEngineCursor_TnxBaseTokenFilterCursorEngine
Syntax
Delphi
TnxBaseTokenFilterCursorEngine = class(TnxBaseTokenSourceCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseTokenFilterCursorEngine.

Group

Classes

Links
Create Constructor, TnxBaseTokenFilterCursorEngine Fields, TnxBaseTokenFilterCursorEngine Methods, TnxBaseTokenFilterCursorEngine Properties, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseTokenFilterCursorEngine Members

TnxBaseTokenFilterCursorEngine Members
TnxBaseTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenFilterCursorEngine.

Class

TnxBaseTokenFilterCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBaseTokenFilterCursorEngine Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBaseTokenFilterCursorEngine.Create (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine) | TnxBaseTokenFilterCursorEngine
TnxBaseTokenFilterCursorEngine.Create (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine) |
Class

TnxBaseTokenFilterCursorEngine Class

Links
TnxBaseTokenFilterCursorEngine Class


TnxBaseTokenFilterCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenFilterCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); virtual; overload;
Description

TnxBaseTokenFilterCursorEngine

Group

Create Constructor

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenFilterCursorEngine.Create Constructor (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenFilterCursorEngine.Create Constructor (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxTokenFilterHubCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); overload;
Group

Create Constructor

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenFilterCursorEngine Fields

TnxBaseTokenFilterCursorEngine Fields
TnxBaseTokenFilterCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenFilterCursorEngine class are listed here.

Class

TnxBaseTokenFilterCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseTokenFilterCursorEngine Class, Legend, Protected Fields


TnxBaseTokenFilterCursorEngine.btfceParentTokenFilterHubCursorEngine Field

TnxBaseTokenFilterCursorEngine.btfceParentTokenFilterHubCursorEngine Field
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
btfceParentTokenFilterHubCursorEngine: TnxTokenFilterHubCursorEngine;
Description

private

Group

TnxBaseTokenFilterCursorEngine Fields

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Fields


TnxBaseTokenFilterCursorEngine.btfceTokenFilterTableEngine Field

TnxBaseTokenFilterCursorEngine.btfceTokenFilterTableEngine Field
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
btfceTokenFilterTableEngine: TnxBaseTokenFilterTableEngine;
Description

This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.

Group

TnxBaseTokenFilterCursorEngine Fields

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Fields


TnxBaseTokenFilterCursorEngine.btfceTokenSource Field

TnxBaseTokenFilterCursorEngine.btfceTokenSource Field
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
btfceTokenSource: TnxBaseTokenSourceCursorEngine;
Description

This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.

Group

TnxBaseTokenFilterCursorEngine Fields

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Fields


TnxBaseTokenFilterCursorEngine Methods

TnxBaseTokenFilterCursorEngine Methods
TnxBaseTokenFilterCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenFilterCursorEngine class are listed here.

Class

TnxBaseTokenFilterCursorEngine Class

Protected Methods
Name | Description
GetList |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Reset |
Links
TnxBaseTokenFilterCursorEngine Class, Legend, Protected Methods, Public Methods


CreateFor Method

CreateFor Method
TnxBaseTokenFilterCursorEngine Methods Send Feedback

This is the overview for the CreateFor method overload.

Overload List
Name | Description
TnxBaseTokenFilterCursorEngine.CreateFor (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine) |
TnxBaseTokenFilterCursorEngine.CreateFor (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine) |
Group

TnxBaseTokenFilterCursorEngine Methods

Links
TnxBaseTokenFilterCursorEngine Methods


TnxBaseTokenFilterCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenFilterCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine): TnxBaseTokenFilterCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenFilterCursorEngine.CreateFor Method (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenFilterCursorEngine.CreateFor Method (TnxTokenFilterHubCursorEngine, TnxBaseTokenFilterTableEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxTokenFilterHubCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine): TnxBaseTokenFilterCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenFilterCursorEngine.GetList Method

TnxBaseTokenFilterCursorEngine.GetList Method
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenFilterCursorEngine Methods

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Methods


TnxBaseTokenFilterCursorEngine.Reset Method

TnxBaseTokenFilterCursorEngine.Reset Method
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Reset; override;
Group

TnxBaseTokenFilterCursorEngine Methods

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Methods


TnxBaseTokenFilterCursorEngine Properties

TnxBaseTokenFilterCursorEngine Properties
TnxBaseTokenFilterCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenFilterCursorEngine class are listed here.

Class

TnxBaseTokenFilterCursorEngine Class

Public Properties
Name | Description
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxBaseTokenFilterCursorEngine Class, Legend, Public Properties


TnxBaseTokenFilterCursorEngine.ParentTokenFilterHubCursorEngine Property

TnxBaseTokenFilterCursorEngine.ParentTokenFilterHubCursorEngine Property
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentTokenFilterHubCursorEngine: TnxTokenFilterHubCursorEngine;
Description

This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.

Group

TnxBaseTokenFilterCursorEngine Properties

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Properties


TnxBaseTokenFilterCursorEngine.TokenFilterTableEngine Property

TnxBaseTokenFilterCursorEngine.TokenFilterTableEngine Property
TnxBaseTokenFilterCursorEngine Class TnxBaseTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenFilterCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterTableEngine: TnxBaseTokenFilterTableEngine;
Description

This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.

Group

TnxBaseTokenFilterCursorEngine Properties

Links
TnxBaseTokenFilterCursorEngine Class, TnxBaseTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenFilterCursorEngine Properties


TnxBaseTokenIndexCursorEngine Class

TnxBaseTokenIndexCursorEngine Class
Create Constructor TnxBaseTokenIndexCursorEngine Fields TnxBaseTokenIndexCursorEngine Methods TnxBaseTokenIndexCursorEngine Properties TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBaseTokenIndexCursorEngine
Syntax
Delphi
TnxBaseTokenIndexCursorEngine = class(TnxBaseRegisterableEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseTokenIndexCursorEngine.

Group

Classes

Links
Create Constructor, TnxBaseTokenIndexCursorEngine Fields, TnxBaseTokenIndexCursorEngine Methods, TnxBaseTokenIndexCursorEngine Properties, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseTokenIndexCursorEngine Members

TnxBaseTokenIndexCursorEngine Members
TnxBaseTokenIndexCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenIndexCursorEngine.

Class

TnxBaseTokenIndexCursorEngine Class

Protected Fields
Name | Description
bticeParentFulltextIndexCursorEngine | private
bticeParentTokenIndexHubCursorEngine | This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubNew | This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubOld | This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenIndexTableEngine | This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceNew | This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceOld | This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bticeGetTokenFilterNew | TnxBaseTokenIndexCursorEngine
bticeGetTokenFilterNewCount |
bticeGetTokenFilterOld |
bticeGetTokenFilterOldCount |
bticeUpdateIndex |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
ParentTokenIndexHubCursorEngine | This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNew | This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndexTableEngine | This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxBaseTokenIndexCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


Create Constructor

Create Constructor
TnxBaseTokenIndexCursorEngine Class Send Feedback

This is the overview for the Create constructor overload.

Overload List
Name | Description
TnxBaseTokenIndexCursorEngine.Create (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine) |
TnxBaseTokenIndexCursorEngine.Create (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine) |
Class

TnxBaseTokenIndexCursorEngine Class

Links
TnxBaseTokenIndexCursorEngine Class


TnxBaseTokenIndexCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenIndexCursorEngine.Create Constructor (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine); virtual; overload;
Group

Create Constructor

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenIndexCursorEngine.Create Constructor (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenIndexCursorEngine.Create Constructor (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace Create Constructor Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxTokenIndexHubCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine); overload;
Group

Create Constructor

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, Create Constructor


TnxBaseTokenIndexCursorEngine.Destroy Destructor

TnxBaseTokenIndexCursorEngine.Destroy Destructor
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBaseTokenIndexCursorEngine Class

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Class


TnxBaseTokenIndexCursorEngine Fields

TnxBaseTokenIndexCursorEngine Fields
TnxBaseTokenIndexCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenIndexCursorEngine class are listed here.

Class

TnxBaseTokenIndexCursorEngine Class

Protected Fields
Name | Description
bticeParentFulltextIndexCursorEngine | private
bticeParentTokenIndexHubCursorEngine | This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubNew | This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubOld | This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenIndexTableEngine | This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceNew | This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceOld | This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxBaseTokenIndexCursorEngine Class, Legend, Protected Fields


TnxBaseTokenIndexCursorEngine.bticeParentFulltextIndexCursorEngine Field

TnxBaseTokenIndexCursorEngine.bticeParentFulltextIndexCursorEngine Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeParentFulltextIndexCursorEngine: TnxFulltextIndexCursorEngine;
Description

private

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeParentTokenIndexHubCursorEngine Field

TnxBaseTokenIndexCursorEngine.bticeParentTokenIndexHubCursorEngine Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeParentTokenIndexHubCursorEngine: TnxTokenIndexHubCursorEngine;
Description

This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeTokenFilterHubNew Field

TnxBaseTokenIndexCursorEngine.bticeTokenFilterHubNew Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeTokenFilterHubNew: TnxTokenFilterHubCursorEngine;
Description

This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeTokenFilterHubOld Field

TnxBaseTokenIndexCursorEngine.bticeTokenFilterHubOld Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeTokenFilterHubOld: TnxTokenFilterHubCursorEngine;
Description

This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeTokenIndexTableEngine Field

TnxBaseTokenIndexCursorEngine.bticeTokenIndexTableEngine Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeTokenIndexTableEngine: TnxBaseTokenIndexTableEngine;
Description

This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeTokenSourceNew Field

TnxBaseTokenIndexCursorEngine.bticeTokenSourceNew Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeTokenSourceNew: TnxBaseTokenSourceCursorEngine;
Description

This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine.bticeTokenSourceOld Field

TnxBaseTokenIndexCursorEngine.bticeTokenSourceOld Field
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
bticeTokenSourceOld: TnxBaseTokenSourceCursorEngine;
Description

This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Fields

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Fields


TnxBaseTokenIndexCursorEngine Methods

TnxBaseTokenIndexCursorEngine Methods
TnxBaseTokenIndexCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxBaseTokenIndexCursorEngine class are listed here.

Class

TnxBaseTokenIndexCursorEngine Class

Protected Methods
Name | Description
bticeGetTokenFilterNew | TnxBaseTokenIndexCursorEngine
bticeGetTokenFilterNewCount |
bticeGetTokenFilterOld |
bticeGetTokenFilterOldCount |
bticeUpdateIndex |
GetList |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Links
TnxBaseTokenIndexCursorEngine Class, Legend, Protected Methods, Public Methods


TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterNew Method

TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterNew Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeGetTokenFilterNew(aInx: Integer): TnxBaseTokenFilterCursorEngine;
Description

TnxBaseTokenIndexCursorEngine

Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterNewCount Method

TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterNewCount Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeGetTokenFilterNewCount: Integer;
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterOld Method

TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterOld Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeGetTokenFilterOld(aInx: Integer): TnxBaseTokenFilterCursorEngine;
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterOldCount Method

TnxBaseTokenIndexCursorEngine.bticeGetTokenFilterOldCount Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeGetTokenFilterOldCount: Integer;
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine.bticeUpdateIndex Method

TnxBaseTokenIndexCursorEngine.bticeUpdateIndex Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeUpdateIndex(aTrans: TnxBaseTransaction; aOldRecord: PnxByteArray; const aOldRefNr: TnxInt64; aNewRecord: PnxByteArray; const aNewRefNr: TnxInt64): TnxResult; virtual;
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


CreateFor Method

CreateFor Method
TnxBaseTokenIndexCursorEngine Methods Send Feedback

This is the overview for the CreateFor method overload.

Overload List
Name | Description
TnxBaseTokenIndexCursorEngine.CreateFor (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine) |
TnxBaseTokenIndexCursorEngine.CreateFor (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine) |
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenIndexCursorEngine.CreateFor Method (TnxFulltextIndexCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine): TnxBaseTokenIndexCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenIndexCursorEngine.CreateFor Method (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)

TnxBaseTokenIndexCursorEngine.CreateFor Method (TnxTokenIndexHubCursorEngine, TnxBaseTokenIndexTableEngine, TnxBaseTokenSourceCursorEngine, TnxBaseTokenSourceCursorEngine)
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace CreateFor Method Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxTokenIndexHubCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine): TnxBaseTokenIndexCursorEngine; overload;
Group

CreateFor Method

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, CreateFor Method


TnxBaseTokenIndexCursorEngine.GetList Method

TnxBaseTokenIndexCursorEngine.GetList Method
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxBaseTokenIndexCursorEngine Methods

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Methods


TnxBaseTokenIndexCursorEngine Properties

TnxBaseTokenIndexCursorEngine Properties
TnxBaseTokenIndexCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenIndexCursorEngine class are listed here.

Class

TnxBaseTokenIndexCursorEngine Class

Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
ParentTokenIndexHubCursorEngine | This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNew | This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndexTableEngine | This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxBaseTokenIndexCursorEngine Class, Legend, Public Properties


TnxBaseTokenIndexCursorEngine.ParentFulltextIndexCursorEngine Property

TnxBaseTokenIndexCursorEngine.ParentFulltextIndexCursorEngine Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentFulltextIndexCursorEngine: TnxFulltextIndexCursorEngine;
Description

This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.ParentTokenIndexHubCursorEngine Property

TnxBaseTokenIndexCursorEngine.ParentTokenIndexHubCursorEngine Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentTokenIndexHubCursorEngine: TnxTokenIndexHubCursorEngine;
Description

This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.TokenFilterNew Property

TnxBaseTokenIndexCursorEngine.TokenFilterNew Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterNew [aInx : Integer]: TnxBaseTokenFilterCursorEngine;
Description

This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.TokenFilterNewCount Property

TnxBaseTokenIndexCursorEngine.TokenFilterNewCount Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterNewCount: Integer;
Description

This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.TokenFilterOld Property

TnxBaseTokenIndexCursorEngine.TokenFilterOld Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterOld [aInx : Integer]: TnxBaseTokenFilterCursorEngine;
Description

This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.TokenFilterOldCount Property

TnxBaseTokenIndexCursorEngine.TokenFilterOldCount Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterOldCount: Integer;
Description

Filter

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenIndexCursorEngine.TokenIndexTableEngine Property

TnxBaseTokenIndexCursorEngine.TokenIndexTableEngine Property
TnxBaseTokenIndexCursorEngine Class TnxBaseTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenIndexTableEngine: TnxBaseTokenIndexTableEngine;
Description

This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.

Group

TnxBaseTokenIndexCursorEngine Properties

Links
TnxBaseTokenIndexCursorEngine Class, TnxBaseTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenIndexCursorEngine Properties


TnxBaseTokenSourceCursorEngine Class

TnxBaseTokenSourceCursorEngine Class
TnxBaseTokenSourceCursorEngine Fields TnxBaseTokenSourceCursorEngine Methods TnxBaseTokenSourceCursorEngine Properties TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBaseTokenSourceCursorEnginenxseFulltextEngineCursor_TnxBaseTokenSourceCursorEnginenxseFulltextEngineCursor_TnxBaseTokenSourceCursorEnginenxseFulltextEngineCursor_TnxBaseTokenSourceCursorEngine
Syntax
Delphi
TnxBaseTokenSourceCursorEngine = class(TnxBaseRegisterableEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBaseTokenSourceCursorEngine.

Group

Classes

Links
TnxBaseTokenSourceCursorEngine Fields, TnxBaseTokenSourceCursorEngine Methods, TnxBaseTokenSourceCursorEngine Properties, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBaseTokenSourceCursorEngine Members

TnxBaseTokenSourceCursorEngine Members
TnxBaseTokenSourceCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBaseTokenSourceCursorEngine.

Class

TnxBaseTokenSourceCursorEngine Class

Protected Fields
Name | Description
btsceParentFulltextIndexCursorEngine | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxBaseTokenSourceCursorEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
Links
TnxBaseTokenSourceCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBaseTokenSourceCursorEngine.Create Constructor

TnxBaseTokenSourceCursorEngine.Create Constructor
TnxBaseTokenSourceCursorEngine Class TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenSourceCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine);
Description

TnxBaseTokenSourceCursorEngine

Class

TnxBaseTokenSourceCursorEngine Class

Links
TnxBaseTokenSourceCursorEngine Class, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenSourceCursorEngine Class


TnxBaseTokenSourceCursorEngine Fields

TnxBaseTokenSourceCursorEngine Fields
TnxBaseTokenSourceCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBaseTokenSourceCursorEngine class are listed here.

Class

TnxBaseTokenSourceCursorEngine Class

Protected Fields
Name | Description
btsceParentFulltextIndexCursorEngine | private
Links
TnxBaseTokenSourceCursorEngine Class, Legend, Protected Fields


TnxBaseTokenSourceCursorEngine.btsceParentFulltextIndexCursorEngine Field

TnxBaseTokenSourceCursorEngine.btsceParentFulltextIndexCursorEngine Field
TnxBaseTokenSourceCursorEngine Class TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenSourceCursorEngine Fields Send Feedback
Syntax
Delphi
btsceParentFulltextIndexCursorEngine: TnxFulltextIndexCursorEngine;
Description

private

Group

TnxBaseTokenSourceCursorEngine Fields

Links
TnxBaseTokenSourceCursorEngine Class, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenSourceCursorEngine Fields


TnxBaseTokenSourceCursorEngine Methods

TnxBaseTokenSourceCursorEngine Methods
TnxBaseTokenSourceCursorEngine Class Legend Public Methods Send Feedback

The methods of the TnxBaseTokenSourceCursorEngine class are listed here.

Class

TnxBaseTokenSourceCursorEngine Class

Public Methods
Name | Description
NextToken |
Reset |
Links
TnxBaseTokenSourceCursorEngine Class, Legend, Public Methods


TnxBaseTokenSourceCursorEngine.NextToken Method

TnxBaseTokenSourceCursorEngine.NextToken Method
TnxBaseTokenSourceCursorEngine Class TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenSourceCursorEngine Methods Send Feedback
Syntax
Delphi
function NextToken: InxToken; virtual;
Group

TnxBaseTokenSourceCursorEngine Methods

Links
TnxBaseTokenSourceCursorEngine Class, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenSourceCursorEngine Methods


TnxBaseTokenSourceCursorEngine.Reset Method

TnxBaseTokenSourceCursorEngine.Reset Method
TnxBaseTokenSourceCursorEngine Class TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenSourceCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Reset; virtual;
Group

TnxBaseTokenSourceCursorEngine Methods

Links
TnxBaseTokenSourceCursorEngine Class, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenSourceCursorEngine Methods


TnxBaseTokenSourceCursorEngine Properties

TnxBaseTokenSourceCursorEngine Properties
TnxBaseTokenSourceCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxBaseTokenSourceCursorEngine class are listed here.

Class

TnxBaseTokenSourceCursorEngine Class

Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
Links
TnxBaseTokenSourceCursorEngine Class, Legend, Public Properties


TnxBaseTokenSourceCursorEngine.ParentFulltextIndexCursorEngine Property

TnxBaseTokenSourceCursorEngine.ParentFulltextIndexCursorEngine Property
TnxBaseTokenSourceCursorEngine Class TnxBaseTokenSourceCursorEngine Members nxseFulltextEngineCursor Namespace TnxBaseTokenSourceCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentFulltextIndexCursorEngine: TnxFulltextIndexCursorEngine;
Description

This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.

Group

TnxBaseTokenSourceCursorEngine Properties

Links
TnxBaseTokenSourceCursorEngine Class, TnxBaseTokenSourceCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBaseTokenSourceCursorEngine Properties


TnxBitArrayTokenIndexCursorEngine Class

TnxBitArrayTokenIndexCursorEngine Class
TnxBitArrayTokenIndexCursorEngine Fields TnxBitArrayTokenIndexCursorEngine Methods TnxBitArrayTokenIndexCursorEngine Properties TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEnginenxseFulltextEngineCursor_TnxBitArrayTokenIndexCursorEngine
Syntax
Delphi
TnxBitArrayTokenIndexCursorEngine = class(TnxBaseProcessingTokenIndexCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxBitArrayTokenIndexCursorEngine.

Group

Classes

Links
TnxBitArrayTokenIndexCursorEngine Fields, TnxBitArrayTokenIndexCursorEngine Methods, TnxBitArrayTokenIndexCursorEngine Properties, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxBitArrayTokenIndexCursorEngine Members

TnxBitArrayTokenIndexCursorEngine Members
TnxBitArrayTokenIndexCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxBitArrayTokenIndexCursorEngine.

Class

TnxBitArrayTokenIndexCursorEngine Class

Protected Fields
Name | Description
baticeBitArrayStorageHandlerTableEngine | This is baticeBitArrayStorageHandlerTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeBitArrayTokenIndexTableEngine | private
baticeFieldsDescriptor | This is baticeFieldsDescriptor, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeIndexEngine | This is baticeIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeIndexPath | This is baticeIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeKeyBuffer | This is baticeKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeKeyEngine | This is baticeKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeLocationField | This is baticeLocationField, a member of class TnxBitArrayTokenIndexCursorEngine.
baticePerFieldIndex | This is baticePerFieldIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
baticePerLocationIndex | This is baticePerLocationIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseIndexEngine | This is baticeReverseIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseIndexPath | This is baticeReverseIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseKeyBuffer | This is baticeReverseKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseKeyEngine | This is baticeReverseKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeSegmentIndex | This is baticeSegmentIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
bpticeComparer | private
bpticeTransformer | This is bpticeTransformer, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bticeParentFulltextIndexCursorEngine | private
bticeParentTokenIndexHubCursorEngine | This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubNew | This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubOld | This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenIndexTableEngine | This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceNew | This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceOld | This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bpticeAdditionalCompareFlags |
bpticeGetMaxTokenLength | TnxBitArrayTokenIndexCursorEngine
bpticeUpdateToken |
bpticeUpdateTokens | This is the overview for the bpticeUpdateTokens method overload.
bpticeUpdateTokensForField | This is the overview for the bpticeUpdateTokensForField method overload.
bticeGetTokenFilterNew | TnxBaseTokenIndexCursorEngine
bticeGetTokenFilterNewCount |
bticeGetTokenFilterOld |
bticeGetTokenFilterOldCount |
bticeUpdateIndex |
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Public Properties
Name | Description
BitArrayTokenIndexTableEngine | This is BitArrayTokenIndexTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
ParentTokenIndexHubCursorEngine | This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNew | This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndexTableEngine | This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxBitArrayTokenIndexCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxBitArrayTokenIndexCursorEngine.Create Constructor

TnxBitArrayTokenIndexCursorEngine.Create Constructor
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine); override;
Class

TnxBitArrayTokenIndexCursorEngine Class

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Class


TnxBitArrayTokenIndexCursorEngine.Destroy Destructor

TnxBitArrayTokenIndexCursorEngine.Destroy Destructor
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxBitArrayTokenIndexCursorEngine Class

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Class


TnxBitArrayTokenIndexCursorEngine Fields

TnxBitArrayTokenIndexCursorEngine Fields
TnxBitArrayTokenIndexCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxBitArrayTokenIndexCursorEngine class are listed here.

Class

TnxBitArrayTokenIndexCursorEngine Class

Protected Fields
Name | Description
baticeBitArrayStorageHandlerTableEngine | This is baticeBitArrayStorageHandlerTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeBitArrayTokenIndexTableEngine | private
baticeFieldsDescriptor | This is baticeFieldsDescriptor, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeIndexEngine | This is baticeIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeIndexPath | This is baticeIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeKeyBuffer | This is baticeKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeKeyEngine | This is baticeKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeLocationField | This is baticeLocationField, a member of class TnxBitArrayTokenIndexCursorEngine.
baticePerFieldIndex | This is baticePerFieldIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
baticePerLocationIndex | This is baticePerLocationIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseIndexEngine | This is baticeReverseIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseIndexPath | This is baticeReverseIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseKeyBuffer | This is baticeReverseKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeReverseKeyEngine | This is baticeReverseKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
baticeSegmentIndex | This is baticeSegmentIndex, a member of class TnxBitArrayTokenIndexCursorEngine.
Links
TnxBitArrayTokenIndexCursorEngine Class, Legend, Protected Fields


TnxBitArrayTokenIndexCursorEngine.baticeBitArrayStorageHandlerTableEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeBitArrayStorageHandlerTableEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeBitArrayStorageHandlerTableEngine: TnxBaseBitArrayStorageHandlerTableEngine;
Description

This is baticeBitArrayStorageHandlerTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeBitArrayTokenIndexTableEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeBitArrayTokenIndexTableEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeBitArrayTokenIndexTableEngine: TnxBitArrayTokenIndexTableEngine;
Description

private

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeFieldsDescriptor Field

TnxBitArrayTokenIndexCursorEngine.baticeFieldsDescriptor Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeFieldsDescriptor: TnxFieldsDescriptor;
Description

This is baticeFieldsDescriptor, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeIndexEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeIndexEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeIndexEngine: TnxBaseIndexEngine;
Description

This is baticeIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeIndexPath Field

TnxBitArrayTokenIndexCursorEngine.baticeIndexPath Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeIndexPath: TnxBaseIndexPath;
Description

This is baticeIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeKeyBuffer Field

TnxBitArrayTokenIndexCursorEngine.baticeKeyBuffer Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeKeyBuffer: PnxByteArray;
Description

This is baticeKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeKeyEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeKeyEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeKeyEngine: TnxBitArrayTokenKeyEngine;
Description

This is baticeKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeLocationField Field

TnxBitArrayTokenIndexCursorEngine.baticeLocationField Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeLocationField: TnxFieldDescriptor;
Description

This is baticeLocationField, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticePerFieldIndex Field

TnxBitArrayTokenIndexCursorEngine.baticePerFieldIndex Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticePerFieldIndex: Boolean;
Description

This is baticePerFieldIndex, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticePerLocationIndex Field

TnxBitArrayTokenIndexCursorEngine.baticePerLocationIndex Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticePerLocationIndex: Boolean;
Description

This is baticePerLocationIndex, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeReverseIndexEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeReverseIndexEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeReverseIndexEngine: TnxBaseIndexEngine;
Description

This is baticeReverseIndexEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeReverseIndexPath Field

TnxBitArrayTokenIndexCursorEngine.baticeReverseIndexPath Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeReverseIndexPath: TnxBaseIndexPath;
Description

This is baticeReverseIndexPath, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeReverseKeyBuffer Field

TnxBitArrayTokenIndexCursorEngine.baticeReverseKeyBuffer Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeReverseKeyBuffer: PnxByteArray;
Description

This is baticeReverseKeyBuffer, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeReverseKeyEngine Field

TnxBitArrayTokenIndexCursorEngine.baticeReverseKeyEngine Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeReverseKeyEngine: TnxBitArrayTokenKeyEngine;
Description

This is baticeReverseKeyEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine.baticeSegmentIndex Field

TnxBitArrayTokenIndexCursorEngine.baticeSegmentIndex Field
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
baticeSegmentIndex: Boolean;
Description

This is baticeSegmentIndex, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Fields

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Fields


TnxBitArrayTokenIndexCursorEngine Methods

TnxBitArrayTokenIndexCursorEngine Methods
TnxBitArrayTokenIndexCursorEngine Class Legend Protected Methods Send Feedback

The methods of the TnxBitArrayTokenIndexCursorEngine class are listed here.

Class

TnxBitArrayTokenIndexCursorEngine Class

Protected Methods
Name | Description
bpticeGetMaxTokenLength | TnxBitArrayTokenIndexCursorEngine
bpticeUpdateToken |
bticeUpdateIndex |
Links
TnxBitArrayTokenIndexCursorEngine Class, Legend, Protected Methods


TnxBitArrayTokenIndexCursorEngine.bpticeGetMaxTokenLength Method

TnxBitArrayTokenIndexCursorEngine.bpticeGetMaxTokenLength Method
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bpticeGetMaxTokenLength: Integer; override;
Description

TnxBitArrayTokenIndexCursorEngine

Group

TnxBitArrayTokenIndexCursorEngine Methods

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Methods


TnxBitArrayTokenIndexCursorEngine.bpticeUpdateToken Method

TnxBitArrayTokenIndexCursorEngine.bpticeUpdateToken Method
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
procedure bpticeUpdateToken(aTrans: TnxBaseTransaction; aToken: TnxWideString; aField: TnxInt16; const aLocation; aNew: Boolean); override;
Group

TnxBitArrayTokenIndexCursorEngine Methods

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Methods


TnxBitArrayTokenIndexCursorEngine.bticeUpdateIndex Method

TnxBitArrayTokenIndexCursorEngine.bticeUpdateIndex Method
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeUpdateIndex(aTrans: TnxBaseTransaction; aOldRecord: PnxByteArray; const aOldRefNr: TnxInt64; aNewRecord: PnxByteArray; const aNewRefNr: TnxInt64): TnxResult; override;
Group

TnxBitArrayTokenIndexCursorEngine Methods

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Methods


TnxBitArrayTokenIndexCursorEngine Properties

TnxBitArrayTokenIndexCursorEngine Properties
TnxBitArrayTokenIndexCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxBitArrayTokenIndexCursorEngine class are listed here.

Class

TnxBitArrayTokenIndexCursorEngine Class

Public Properties
Name | Description
BitArrayTokenIndexTableEngine | This is BitArrayTokenIndexTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.
Links
TnxBitArrayTokenIndexCursorEngine Class, Legend, Public Properties


TnxBitArrayTokenIndexCursorEngine.BitArrayTokenIndexTableEngine Property

TnxBitArrayTokenIndexCursorEngine.BitArrayTokenIndexTableEngine Property
TnxBitArrayTokenIndexCursorEngine Class TnxBitArrayTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxBitArrayTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property BitArrayTokenIndexTableEngine: TnxBitArrayTokenIndexTableEngine;
Description

This is BitArrayTokenIndexTableEngine, a member of class TnxBitArrayTokenIndexCursorEngine.

Group

TnxBitArrayTokenIndexCursorEngine Properties

Links
TnxBitArrayTokenIndexCursorEngine Class, TnxBitArrayTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxBitArrayTokenIndexCursorEngine Properties


TnxCategorySeparatorTokenFilterCursorEngine Class

TnxCategorySeparatorTokenFilterCursorEngine Class
TnxCategorySeparatorTokenFilterCursorEngine Fields TnxCategorySeparatorTokenFilterCursorEngine Methods TnxCategorySeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCategorySeparatorTokenFilterCursorEngine
Syntax
Delphi
TnxCategorySeparatorTokenFilterCursorEngine = class(TnxBaseSeparatorTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxCategorySeparatorTokenFilterCursorEngine.

Group

Classes

Links
TnxCategorySeparatorTokenFilterCursorEngine Fields, TnxCategorySeparatorTokenFilterCursorEngine Methods, TnxCategorySeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxCategorySeparatorTokenFilterCursorEngine Members

TnxCategorySeparatorTokenFilterCursorEngine Members
TnxCategorySeparatorTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxCategorySeparatorTokenFilterCursorEngine.

Class

TnxCategorySeparatorTokenFilterCursorEngine Class

Protected Fields
Name | Description
bstfceInputPos | This is bstfceInputPos, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceInputToken | private
bstfceNextDistance | This is bstfceNextDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
bstfceSeparatorDistance | This is bstfceSeparatorDistance, a member of class TnxBaseSeparatorTokenFilterCursorEngine.
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
cstfceSeparatorCategories | private
Protected Methods
Name | Description
_AddRef |
_Release |
bstfceIsSeparator | TnxCategorySeparatorTokenFilterCursorEngine
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextToken |
Reset |
Reset |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxCategorySeparatorTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxCategorySeparatorTokenFilterCursorEngine.Create Constructor

TnxCategorySeparatorTokenFilterCursorEngine.Create Constructor
TnxCategorySeparatorTokenFilterCursorEngine Class TnxCategorySeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxCategorySeparatorTokenFilterCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Class

TnxCategorySeparatorTokenFilterCursorEngine Class

Links
TnxCategorySeparatorTokenFilterCursorEngine Class, TnxCategorySeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxCategorySeparatorTokenFilterCursorEngine Class


TnxCategorySeparatorTokenFilterCursorEngine Fields

TnxCategorySeparatorTokenFilterCursorEngine Fields
TnxCategorySeparatorTokenFilterCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxCategorySeparatorTokenFilterCursorEngine class are listed here.

Class

TnxCategorySeparatorTokenFilterCursorEngine Class

Protected Fields
Name | Description
cstfceSeparatorCategories | private
Links
TnxCategorySeparatorTokenFilterCursorEngine Class, Legend, Protected Fields


TnxCategorySeparatorTokenFilterCursorEngine.cstfceSeparatorCategories Field

TnxCategorySeparatorTokenFilterCursorEngine.cstfceSeparatorCategories Field
TnxCategorySeparatorTokenFilterCursorEngine Class TnxCategorySeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxCategorySeparatorTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
cstfceSeparatorCategories: TnxCharacterCategories;
Description

private

Group

TnxCategorySeparatorTokenFilterCursorEngine Fields

Links
TnxCategorySeparatorTokenFilterCursorEngine Class, TnxCategorySeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxCategorySeparatorTokenFilterCursorEngine Fields


TnxCategorySeparatorTokenFilterCursorEngine Methods

TnxCategorySeparatorTokenFilterCursorEngine Methods
TnxCategorySeparatorTokenFilterCursorEngine Class Legend Protected Methods Send Feedback

The methods of the TnxCategorySeparatorTokenFilterCursorEngine class are listed here.

Class

TnxCategorySeparatorTokenFilterCursorEngine Class

Protected Methods
Name | Description
bstfceIsSeparator | TnxCategorySeparatorTokenFilterCursorEngine
Links
TnxCategorySeparatorTokenFilterCursorEngine Class, Legend, Protected Methods


TnxCategorySeparatorTokenFilterCursorEngine.bstfceIsSeparator Method

TnxCategorySeparatorTokenFilterCursorEngine.bstfceIsSeparator Method
TnxCategorySeparatorTokenFilterCursorEngine Class TnxCategorySeparatorTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxCategorySeparatorTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
function bstfceIsSeparator(aWideChar: TnxWideChar): Boolean; override;
Description

TnxCategorySeparatorTokenFilterCursorEngine

Group

TnxCategorySeparatorTokenFilterCursorEngine Methods

Links
TnxCategorySeparatorTokenFilterCursorEngine Class, TnxCategorySeparatorTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxCategorySeparatorTokenFilterCursorEngine Methods


TnxCustomFoldStringTokenFilterCursorEngine Class

TnxCustomFoldStringTokenFilterCursorEngine Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomFoldStringTokenFilterCursorEngine
Syntax
Delphi
TnxCustomFoldStringTokenFilterCursorEngine = class(TnxBaseFoldStringTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxCustomFoldStringTokenFilterCursorEngine.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxCustomLocaleMappingTokenFilterCursorEngine Class

TnxCustomLocaleMappingTokenFilterCursorEngine Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxCustomLocaleMappingTokenFilterCursorEngine
Syntax
Delphi
TnxCustomLocaleMappingTokenFilterCursorEngine = class(TnxBaseLocaleMappingTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxCustomLocaleMappingTokenFilterCursorEngine.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxDecomposeFoldStringTokenFilterCursorEngine Class

TnxDecomposeFoldStringTokenFilterCursorEngine Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxDecomposeFoldStringTokenFilterCursorEngine
Syntax
Delphi
TnxDecomposeFoldStringTokenFilterCursorEngine = class(TnxBaseFoldStringTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxDecomposeFoldStringTokenFilterCursorEngine.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxFieldTokenExtractorCursorEngine Class

TnxFieldTokenExtractorCursorEngine Class
TnxFieldTokenExtractorCursorEngine Fields TnxFieldTokenExtractorCursorEngine Methods TnxFieldTokenExtractorCursorEngine Properties TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEnginenxseFulltextEngineCursor_TnxFieldTokenExtractorCursorEngine
Syntax
Delphi
TnxFieldTokenExtractorCursorEngine = class(TnxBaseTokenExtractorCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxFieldTokenExtractorCursorEngine.

Group

Classes

Links
TnxFieldTokenExtractorCursorEngine Fields, TnxFieldTokenExtractorCursorEngine Methods, TnxFieldTokenExtractorCursorEngine Properties, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxFieldTokenExtractorCursorEngine Members

TnxFieldTokenExtractorCursorEngine Members
TnxFieldTokenExtractorCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFieldTokenExtractorCursorEngine.

Class

TnxFieldTokenExtractorCursorEngine Class

Protected Fields
Name | Description
bteceParentTokenExtractorHubCursorEngine | private
bteceTokenExtractorTableEngine | This is bteceTokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHub | This is bteceTokenFilterHub, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHubSource | This is bteceTokenFilterHubSource, a member of class TnxBaseTokenExtractorCursorEngine.
btsceParentFulltextIndexCursorEngine | private
fteceCodepage | This is fteceCodepage, a member of class TnxFieldTokenExtractorCursorEngine.
fteceDistance | This is fteceDistance, a member of class TnxFieldTokenExtractorCursorEngine.
fteceField | This is fteceField, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldNumber | This is fteceFieldNumber, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldsDescriptor | This is fteceFieldsDescriptor, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldTokenExtractorTableEngine | private
fteceFieldToToken | This is fteceFieldToToken, a member of class TnxFieldTokenExtractorCursorEngine.
fteceReadOrg | This is fteceReadOrg, a member of class TnxFieldTokenExtractorCursorEngine.
fteceRecord | This is fteceRecord, a member of class TnxFieldTokenExtractorCursorEngine.
fteceUsed | This is fteceUsed, a member of class TnxFieldTokenExtractorCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bteceGetTokenFilter | TnxBaseTokenExtractorCursorEngine
bteceGetTokenFilterCount |
Create | TnxFieldTokenExtractorCursorEngine
Create | This is the overview for the Create constructor overload.
fteceBlobAsAnsiString |
fteceBlobAsWideString |
fteceBlobMemoConvert |
fteceBlobMemoExpand |
fteceBlobWideMemo |
fteceNullStringConvert |
fteceNullStringExpand |
fteceShortStringConvert |
fteceShortStringExpand |
fteceWideStringCopy |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
Initialize |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextToken |
NextTokenInternal |
Reset |
Reset |
ResetInternal |
Public Properties
Name | Description
FieldTokenExtractorTableEngine | This is FieldTokenExtractorTableEngine, a member of class TnxFieldTokenExtractorCursorEngine.
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenExtractorHubCursorEngine | This is ParentTokenExtractorHubCursorEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenExtractorTableEngine | This is TokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilterCount | Filter
Links
TnxFieldTokenExtractorCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFieldTokenExtractorCursorEngine.Create Constructor

TnxFieldTokenExtractorCursorEngine.Create Constructor
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine); override;
Description

TnxFieldTokenExtractorCursorEngine

Class

TnxFieldTokenExtractorCursorEngine Class

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Class


TnxFieldTokenExtractorCursorEngine Fields

TnxFieldTokenExtractorCursorEngine Fields
TnxFieldTokenExtractorCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxFieldTokenExtractorCursorEngine class are listed here.

Class

TnxFieldTokenExtractorCursorEngine Class

Protected Fields
Name | Description
fteceCodepage | This is fteceCodepage, a member of class TnxFieldTokenExtractorCursorEngine.
fteceDistance | This is fteceDistance, a member of class TnxFieldTokenExtractorCursorEngine.
fteceField | This is fteceField, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldNumber | This is fteceFieldNumber, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldsDescriptor | This is fteceFieldsDescriptor, a member of class TnxFieldTokenExtractorCursorEngine.
fteceFieldTokenExtractorTableEngine | private
fteceFieldToToken | This is fteceFieldToToken, a member of class TnxFieldTokenExtractorCursorEngine.
fteceReadOrg | This is fteceReadOrg, a member of class TnxFieldTokenExtractorCursorEngine.
fteceRecord | This is fteceRecord, a member of class TnxFieldTokenExtractorCursorEngine.
fteceUsed | This is fteceUsed, a member of class TnxFieldTokenExtractorCursorEngine.
Links
TnxFieldTokenExtractorCursorEngine Class, Legend, Protected Fields


TnxFieldTokenExtractorCursorEngine.fteceCodepage Field

TnxFieldTokenExtractorCursorEngine.fteceCodepage Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceCodepage: TnxWord16;
Description

This is fteceCodepage, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceDistance Field

TnxFieldTokenExtractorCursorEngine.fteceDistance Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceDistance: Integer;
Description

This is fteceDistance, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceField Field

TnxFieldTokenExtractorCursorEngine.fteceField Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceField: TnxFieldDescriptor;
Description

This is fteceField, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceFieldNumber Field

TnxFieldTokenExtractorCursorEngine.fteceFieldNumber Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceFieldNumber: Integer;
Description

This is fteceFieldNumber, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceFieldsDescriptor Field

TnxFieldTokenExtractorCursorEngine.fteceFieldsDescriptor Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceFieldsDescriptor: TnxFieldsDescriptor;
Description

This is fteceFieldsDescriptor, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceFieldTokenExtractorTableEngine Field

TnxFieldTokenExtractorCursorEngine.fteceFieldTokenExtractorTableEngine Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceFieldTokenExtractorTableEngine: TnxFieldTokenExtractorTableEngine;
Description

private

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceFieldToToken Field

TnxFieldTokenExtractorCursorEngine.fteceFieldToToken Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceFieldToToken: TnxTokenMethod;
Description

This is fteceFieldToToken, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceReadOrg Field

TnxFieldTokenExtractorCursorEngine.fteceReadOrg Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceReadOrg: Boolean;
Description

This is fteceReadOrg, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceRecord Field

TnxFieldTokenExtractorCursorEngine.fteceRecord Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceRecord: PnxByteArray;
Description

This is fteceRecord, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine.fteceUsed Field

TnxFieldTokenExtractorCursorEngine.fteceUsed Field
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Fields Send Feedback
Syntax
Delphi
fteceUsed: Boolean;
Description

This is fteceUsed, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Fields

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Fields


TnxFieldTokenExtractorCursorEngine Methods

TnxFieldTokenExtractorCursorEngine Methods
TnxFieldTokenExtractorCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFieldTokenExtractorCursorEngine class are listed here.

Class

TnxFieldTokenExtractorCursorEngine Class

Protected Methods
Name | Description
fteceBlobAsAnsiString |
fteceBlobAsWideString |
fteceBlobMemoConvert |
fteceBlobMemoExpand |
fteceBlobWideMemo |
fteceNullStringConvert |
fteceNullStringExpand |
fteceShortStringConvert |
fteceShortStringExpand |
fteceWideStringCopy |
Public Methods
Name | Description
Initialize |
NextTokenInternal |
ResetInternal |
Links
TnxFieldTokenExtractorCursorEngine Class, Legend, Protected Methods, Public Methods


TnxFieldTokenExtractorCursorEngine.fteceBlobAsAnsiString Method

TnxFieldTokenExtractorCursorEngine.fteceBlobAsAnsiString Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceBlobAsAnsiString: AnsiString;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceBlobAsWideString Method

TnxFieldTokenExtractorCursorEngine.fteceBlobAsWideString Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceBlobAsWideString: TnxWideString;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceBlobMemoConvert Method

TnxFieldTokenExtractorCursorEngine.fteceBlobMemoConvert Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceBlobMemoConvert: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceBlobMemoExpand Method

TnxFieldTokenExtractorCursorEngine.fteceBlobMemoExpand Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceBlobMemoExpand: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceBlobWideMemo Method

TnxFieldTokenExtractorCursorEngine.fteceBlobWideMemo Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceBlobWideMemo: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceNullStringConvert Method

TnxFieldTokenExtractorCursorEngine.fteceNullStringConvert Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceNullStringConvert: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceNullStringExpand Method

TnxFieldTokenExtractorCursorEngine.fteceNullStringExpand Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceNullStringExpand: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceShortStringConvert Method

TnxFieldTokenExtractorCursorEngine.fteceShortStringConvert Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceShortStringConvert: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceShortStringExpand Method

TnxFieldTokenExtractorCursorEngine.fteceShortStringExpand Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceShortStringExpand: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.fteceWideStringCopy Method

TnxFieldTokenExtractorCursorEngine.fteceWideStringCopy Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function fteceWideStringCopy: InxToken;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.Initialize Method

TnxFieldTokenExtractorCursorEngine.Initialize Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Initialize(aRecord: PnxByteArray; const aRefNr: TnxInt64; aReadOrg: Boolean); override;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.NextTokenInternal Method

TnxFieldTokenExtractorCursorEngine.NextTokenInternal Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
function NextTokenInternal: InxToken; override;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine.ResetInternal Method

TnxFieldTokenExtractorCursorEngine.ResetInternal Method
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure ResetInternal; override;
Group

TnxFieldTokenExtractorCursorEngine Methods

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Methods


TnxFieldTokenExtractorCursorEngine Properties

TnxFieldTokenExtractorCursorEngine Properties
TnxFieldTokenExtractorCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxFieldTokenExtractorCursorEngine class are listed here.

Class

TnxFieldTokenExtractorCursorEngine Class

Public Properties
Name | Description
FieldTokenExtractorTableEngine | This is FieldTokenExtractorTableEngine, a member of class TnxFieldTokenExtractorCursorEngine.
Links
TnxFieldTokenExtractorCursorEngine Class, Legend, Public Properties


TnxFieldTokenExtractorCursorEngine.FieldTokenExtractorTableEngine Property

TnxFieldTokenExtractorCursorEngine.FieldTokenExtractorTableEngine Property
TnxFieldTokenExtractorCursorEngine Class TnxFieldTokenExtractorCursorEngine Members nxseFulltextEngineCursor Namespace TnxFieldTokenExtractorCursorEngine Properties Send Feedback
Syntax
Delphi
property FieldTokenExtractorTableEngine: TnxFieldTokenExtractorTableEngine;
Description

This is FieldTokenExtractorTableEngine, a member of class TnxFieldTokenExtractorCursorEngine.

Group

TnxFieldTokenExtractorCursorEngine Properties

Links
TnxFieldTokenExtractorCursorEngine Class, TnxFieldTokenExtractorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFieldTokenExtractorCursorEngine Properties


TnxFulltextCursorEngine Class

TnxFulltextCursorEngine Class
TnxFulltextCursorEngine Fields TnxFulltextCursorEngine Methods TnxFulltextCursorEngine Properties TnxFulltextCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxFulltextCursorEnginenxseFulltextEngineCursor_TnxFulltextCursorEnginenxseFulltextEngineCursor_TnxFulltextCursorEnginenxseFulltextEngineCursor_TnxFulltextCursorEnginenxseFulltextEngineCursor_TnxFulltextCursorEngine
Syntax
Delphi
TnxFulltextCursorEngine = class(TnxBaseFulltextCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxFulltextCursorEngine.

Group

Classes

Links
TnxFulltextCursorEngine Fields, TnxFulltextCursorEngine Methods, TnxFulltextCursorEngine Properties, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxFulltextCursorEngine Members

TnxFulltextCursorEngine Members
TnxFulltextCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFulltextCursorEngine.

Class

TnxFulltextCursorEngine Class

Protected Fields
Name | Description
ftceFulltextCursor | This is ftceFulltextCursor, a member of class TnxFulltextCursorEngine.
ftceFulltextIndices | This is ftceFulltextIndices, a member of class TnxFulltextCursorEngine.
ftceFulltextTableEngine | private
ftceUpdateHelpers | This is ftceUpdateHelpers, a member of class TnxFulltextCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxFulltextCursorEngine
CreateFulltextIndices |
ftceGetTempUpdateHelper |
ftceSetTempUpdateHelper |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
UpdateIndex |
Public Properties
Name | Description
FulltextCursor | This is FulltextCursor, a member of class TnxFulltextCursorEngine.
FulltextIndices | This is FulltextIndices, a member of class TnxFulltextCursorEngine.
FulltextTableEngine | This is FulltextTableEngine, a member of class TnxFulltextCursorEngine.
TempUpdateHelper | This is TempUpdateHelper, a member of class TnxFulltextCursorEngine.
Links
TnxFulltextCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFulltextCursorEngine.Create Constructor

TnxFulltextCursorEngine.Create Constructor
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aTableEngine: TnxBaseFulltextTableEngine; aCursor: TnxAbstractCursor); override;
Description

TnxFulltextCursorEngine

Class

TnxFulltextCursorEngine Class

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Class


TnxFulltextCursorEngine.Destroy Destructor

TnxFulltextCursorEngine.Destroy Destructor
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFulltextCursorEngine Class

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Class


TnxFulltextCursorEngine Fields

TnxFulltextCursorEngine Fields
TnxFulltextCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxFulltextCursorEngine class are listed here.

Class

TnxFulltextCursorEngine Class

Protected Fields
Name | Description
ftceFulltextCursor | This is ftceFulltextCursor, a member of class TnxFulltextCursorEngine.
ftceFulltextIndices | This is ftceFulltextIndices, a member of class TnxFulltextCursorEngine.
ftceFulltextTableEngine | private
ftceUpdateHelpers | This is ftceUpdateHelpers, a member of class TnxFulltextCursorEngine.
Links
TnxFulltextCursorEngine Class, Legend, Protected Fields


TnxFulltextCursorEngine.ftceFulltextCursor Field

TnxFulltextCursorEngine.ftceFulltextCursor Field
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Fields Send Feedback
Syntax
Delphi
ftceFulltextCursor: TnxAbstractCursor;
Description

This is ftceFulltextCursor, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Fields

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Fields


TnxFulltextCursorEngine.ftceFulltextIndices Field

TnxFulltextCursorEngine.ftceFulltextIndices Field
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Fields Send Feedback
Syntax
Delphi
ftceFulltextIndices: TnxFulltextIndexCursorEngines;
Description

This is ftceFulltextIndices, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Fields

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Fields


TnxFulltextCursorEngine.ftceFulltextTableEngine Field

TnxFulltextCursorEngine.ftceFulltextTableEngine Field
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Fields Send Feedback
Syntax
Delphi
ftceFulltextTableEngine: TnxFulltextTableEngine;
Description

private

Group

TnxFulltextCursorEngine Fields

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Fields


TnxFulltextCursorEngine.ftceUpdateHelpers Field

TnxFulltextCursorEngine.ftceUpdateHelpers Field
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Fields Send Feedback
Syntax
Delphi
ftceUpdateHelpers: TStringList;
Description

This is ftceUpdateHelpers, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Fields

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Fields


TnxFulltextCursorEngine Methods

TnxFulltextCursorEngine Methods
TnxFulltextCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFulltextCursorEngine class are listed here.

Class

TnxFulltextCursorEngine Class

Protected Methods
Name | Description
CreateFulltextIndices |
ftceGetTempUpdateHelper |
ftceSetTempUpdateHelper |
Public Methods
Name | Description
UpdateIndex |
Links
TnxFulltextCursorEngine Class, Legend, Protected Methods, Public Methods


TnxFulltextCursorEngine.CreateFulltextIndices Method

TnxFulltextCursorEngine.CreateFulltextIndices Method
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Methods Send Feedback
Syntax
Delphi
procedure CreateFulltextIndices; virtual;
Group

TnxFulltextCursorEngine Methods

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Methods


TnxFulltextCursorEngine.ftceGetTempUpdateHelper Method

TnxFulltextCursorEngine.ftceGetTempUpdateHelper Method
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Methods Send Feedback
Syntax
Delphi
function ftceGetTempUpdateHelper(aName: string): TObject;
Group

TnxFulltextCursorEngine Methods

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Methods


TnxFulltextCursorEngine.ftceSetTempUpdateHelper Method

TnxFulltextCursorEngine.ftceSetTempUpdateHelper Method
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Methods Send Feedback
Syntax
Delphi
procedure ftceSetTempUpdateHelper(aName: string; aObject: TObject);
Group

TnxFulltextCursorEngine Methods

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Methods


TnxFulltextCursorEngine.UpdateIndex Method

TnxFulltextCursorEngine.UpdateIndex Method
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Methods Send Feedback
Syntax
Delphi
function UpdateIndex(aTrans: TnxBaseTransaction; aOldRecord: PnxByteArray; const aOldRefNr: TnxInt64; aNewRecord: PnxByteArray; const aNewRefNr: TnxInt64): TnxResult; override;
Group

TnxFulltextCursorEngine Methods

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Methods


TnxFulltextCursorEngine Properties

TnxFulltextCursorEngine Properties
TnxFulltextCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxFulltextCursorEngine class are listed here.

Class

TnxFulltextCursorEngine Class

Public Properties
Name | Description
FulltextCursor | This is FulltextCursor, a member of class TnxFulltextCursorEngine.
FulltextIndices | This is FulltextIndices, a member of class TnxFulltextCursorEngine.
FulltextTableEngine | This is FulltextTableEngine, a member of class TnxFulltextCursorEngine.
TempUpdateHelper | This is TempUpdateHelper, a member of class TnxFulltextCursorEngine.
Links
TnxFulltextCursorEngine Class, Legend, Public Properties


TnxFulltextCursorEngine.FulltextCursor Property

TnxFulltextCursorEngine.FulltextCursor Property
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Properties Send Feedback
Syntax
Delphi
property FulltextCursor: TnxAbstractCursor;
Description

This is FulltextCursor, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Properties

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Properties


TnxFulltextCursorEngine.FulltextIndices Property

TnxFulltextCursorEngine.FulltextIndices Property
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Properties Send Feedback
Syntax
Delphi
property FulltextIndices: TnxFulltextIndexCursorEngines;
Description

This is FulltextIndices, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Properties

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Properties


TnxFulltextCursorEngine.FulltextTableEngine Property

TnxFulltextCursorEngine.FulltextTableEngine Property
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Properties Send Feedback
Syntax
Delphi
property FulltextTableEngine: TnxFulltextTableEngine;
Description

This is FulltextTableEngine, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Properties

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Properties


TnxFulltextCursorEngine.TempUpdateHelper Property

TnxFulltextCursorEngine.TempUpdateHelper Property
TnxFulltextCursorEngine Class TnxFulltextCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextCursorEngine Properties Send Feedback
Syntax
Delphi
property TempUpdateHelper [aName: string]: TObject;
Description

This is TempUpdateHelper, a member of class TnxFulltextCursorEngine.

Group

TnxFulltextCursorEngine Properties

Links
TnxFulltextCursorEngine Class, TnxFulltextCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextCursorEngine Properties


TnxFulltextIndexCursorEngine Class

TnxFulltextIndexCursorEngine Class
TnxFulltextIndexCursorEngine Fields TnxFulltextIndexCursorEngine Methods TnxFulltextIndexCursorEngine Properties TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxFulltextIndexCursorEnginenxseFulltextEngineCursor_TnxFulltextIndexCursorEnginenxseFulltextEngineCursor_TnxFulltextIndexCursorEnginenxseFulltextEngineCursor_TnxFulltextIndexCursorEngine
Syntax
Delphi
TnxFulltextIndexCursorEngine = class(TnxBaseRegisterableEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxFulltextIndexCursorEngine.

Group

Classes

Links
TnxFulltextIndexCursorEngine Fields, TnxFulltextIndexCursorEngine Methods, TnxFulltextIndexCursorEngine Properties, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxFulltextIndexCursorEngine Members

TnxFulltextIndexCursorEngine Members
TnxFulltextIndexCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxFulltextIndexCursorEngine.

Class

TnxFulltextIndexCursorEngine Class

Protected Fields
Name | Description
ficeFulltextIndexTableEngine | This is ficeFulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.
ficeParentFulltextCursorEngine | private
ficeTokenExtractorHubNew | This is ficeTokenExtractorHubNew, a member of class TnxFulltextIndexCursorEngine.
ficeTokenExtractorHubOld | This is ficeTokenExtractorHubOld, a member of class TnxFulltextIndexCursorEngine.
ficeTokenFilterHubNew | This is ficeTokenFilterHubNew, a member of class TnxFulltextIndexCursorEngine.
ficeTokenFilterHubOld | This is ficeTokenFilterHubOld, a member of class TnxFulltextIndexCursorEngine.
ficeTokenIndexHub | This is ficeTokenIndexHub, a member of class TnxFulltextIndexCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxFulltextIndexCursorEngine
ficeGetTokenExtractorNew |
ficeGetTokenExtractorNewCount |
ficeGetTokenExtractorOld |
ficeGetTokenExtractorOldCount |
ficeGetTokenFilterNew |
ficeGetTokenFilterNewCount |
ficeGetTokenFilterOld |
ficeGetTokenFilterOldCount |
ficeGetTokenIndex |
ficeGetTokenIndexCount |
ficeUpdateIndex |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor |
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Public Properties
Name | Description
FulltextIndexTableEngine | This is FulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.
ParentFulltextCursorEngine | This is ParentFulltextCursorEngine, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorNew | This is TokenExtractorNew, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorNewCount | This is TokenExtractorNewCount, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorOld | This is TokenExtractorOld, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorOldCount | Extractor
TokenFilterNew | This is TokenFilterNew, a member of class TnxFulltextIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxFulltextIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxFulltextIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndex | This is TokenIndex, a member of class TnxFulltextIndexCursorEngine.
TokenIndexCount | Index
Links
TnxFulltextIndexCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxFulltextIndexCursorEngine.Create Constructor

TnxFulltextIndexCursorEngine.Create Constructor
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextCursorEngine; aTableEngine: TnxFulltextIndexTableEngine);
Description

TnxFulltextIndexCursorEngine

Class

TnxFulltextIndexCursorEngine Class

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Class


TnxFulltextIndexCursorEngine.Destroy Destructor

TnxFulltextIndexCursorEngine.Destroy Destructor
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxFulltextIndexCursorEngine Class

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Class


TnxFulltextIndexCursorEngine Fields

TnxFulltextIndexCursorEngine Fields
TnxFulltextIndexCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxFulltextIndexCursorEngine class are listed here.

Class

TnxFulltextIndexCursorEngine Class

Protected Fields
Name | Description
ficeFulltextIndexTableEngine | This is ficeFulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.
ficeParentFulltextCursorEngine | private
ficeTokenExtractorHubNew | This is ficeTokenExtractorHubNew, a member of class TnxFulltextIndexCursorEngine.
ficeTokenExtractorHubOld | This is ficeTokenExtractorHubOld, a member of class TnxFulltextIndexCursorEngine.
ficeTokenFilterHubNew | This is ficeTokenFilterHubNew, a member of class TnxFulltextIndexCursorEngine.
ficeTokenFilterHubOld | This is ficeTokenFilterHubOld, a member of class TnxFulltextIndexCursorEngine.
ficeTokenIndexHub | This is ficeTokenIndexHub, a member of class TnxFulltextIndexCursorEngine.
Links
TnxFulltextIndexCursorEngine Class, Legend, Protected Fields


TnxFulltextIndexCursorEngine.ficeFulltextIndexTableEngine Field

TnxFulltextIndexCursorEngine.ficeFulltextIndexTableEngine Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeFulltextIndexTableEngine: TnxFulltextIndexTableEngine;
Description

This is ficeFulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeParentFulltextCursorEngine Field

TnxFulltextIndexCursorEngine.ficeParentFulltextCursorEngine Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeParentFulltextCursorEngine: TnxFulltextCursorEngine;
Description

private

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeTokenExtractorHubNew Field

TnxFulltextIndexCursorEngine.ficeTokenExtractorHubNew Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeTokenExtractorHubNew: TnxTokenExtractorHubCursorEngine;
Description

This is ficeTokenExtractorHubNew, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeTokenExtractorHubOld Field

TnxFulltextIndexCursorEngine.ficeTokenExtractorHubOld Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeTokenExtractorHubOld: TnxTokenExtractorHubCursorEngine;
Description

This is ficeTokenExtractorHubOld, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeTokenFilterHubNew Field

TnxFulltextIndexCursorEngine.ficeTokenFilterHubNew Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeTokenFilterHubNew: TnxTokenFilterHubCursorEngine;
Description

This is ficeTokenFilterHubNew, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeTokenFilterHubOld Field

TnxFulltextIndexCursorEngine.ficeTokenFilterHubOld Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeTokenFilterHubOld: TnxTokenFilterHubCursorEngine;
Description

This is ficeTokenFilterHubOld, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine.ficeTokenIndexHub Field

TnxFulltextIndexCursorEngine.ficeTokenIndexHub Field
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Fields Send Feedback
Syntax
Delphi
ficeTokenIndexHub: TnxTokenIndexHubCursorEngine;
Description

This is ficeTokenIndexHub, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Fields

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Fields


TnxFulltextIndexCursorEngine Methods

TnxFulltextIndexCursorEngine Methods
TnxFulltextIndexCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxFulltextIndexCursorEngine class are listed here.

Class

TnxFulltextIndexCursorEngine Class

Protected Methods
Name | Description
ficeGetTokenExtractorNew |
ficeGetTokenExtractorNewCount |
ficeGetTokenExtractorOld |
ficeGetTokenExtractorOldCount |
ficeGetTokenFilterNew |
ficeGetTokenFilterNewCount |
ficeGetTokenFilterOld |
ficeGetTokenFilterOldCount |
ficeGetTokenIndex |
ficeGetTokenIndexCount |
ficeUpdateIndex |
GetList |
Public Methods
Name | Description
CreateFor |
Links
TnxFulltextIndexCursorEngine Class, Legend, Protected Methods, Public Methods


TnxFulltextIndexCursorEngine.CreateFor Method

TnxFulltextIndexCursorEngine.CreateFor Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxFulltextCursorEngine; aTableEngine: TnxFulltextIndexTableEngine): TnxFulltextIndexCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenExtractorNew Method

TnxFulltextIndexCursorEngine.ficeGetTokenExtractorNew Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenExtractorNew(aInx: Integer): TnxBaseTokenExtractorCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenExtractorNewCount Method

TnxFulltextIndexCursorEngine.ficeGetTokenExtractorNewCount Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenExtractorNewCount: Integer;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenExtractorOld Method

TnxFulltextIndexCursorEngine.ficeGetTokenExtractorOld Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenExtractorOld(aInx: Integer): TnxBaseTokenExtractorCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenExtractorOldCount Method

TnxFulltextIndexCursorEngine.ficeGetTokenExtractorOldCount Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenExtractorOldCount: Integer;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenFilterNew Method

TnxFulltextIndexCursorEngine.ficeGetTokenFilterNew Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenFilterNew(aInx: Integer): TnxBaseTokenFilterCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenFilterNewCount Method

TnxFulltextIndexCursorEngine.ficeGetTokenFilterNewCount Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenFilterNewCount: Integer;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenFilterOld Method

TnxFulltextIndexCursorEngine.ficeGetTokenFilterOld Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenFilterOld(aInx: Integer): TnxBaseTokenFilterCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenFilterOldCount Method

TnxFulltextIndexCursorEngine.ficeGetTokenFilterOldCount Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenFilterOldCount: Integer;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenIndex Method

TnxFulltextIndexCursorEngine.ficeGetTokenIndex Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenIndex(aInx: Integer): TnxBaseTokenIndexCursorEngine;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeGetTokenIndexCount Method

TnxFulltextIndexCursorEngine.ficeGetTokenIndexCount Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeGetTokenIndexCount: Integer;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.ficeUpdateIndex Method

TnxFulltextIndexCursorEngine.ficeUpdateIndex Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function ficeUpdateIndex(aTrans: TnxBaseTransaction; aOldRecord: PnxByteArray; const aOldRefNr: TnxInt64; aNewRecord: PnxByteArray; const aNewRefNr: TnxInt64): TnxResult; virtual;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine.GetList Method

TnxFulltextIndexCursorEngine.GetList Method
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Methods Send Feedback
Syntax
Delphi
class function GetList: PStringList; override;
Group

TnxFulltextIndexCursorEngine Methods

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Methods


TnxFulltextIndexCursorEngine Properties

TnxFulltextIndexCursorEngine Properties
TnxFulltextIndexCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxFulltextIndexCursorEngine class are listed here.

Class

TnxFulltextIndexCursorEngine Class

Public Properties
Name | Description
FulltextIndexTableEngine | This is FulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.
ParentFulltextCursorEngine | This is ParentFulltextCursorEngine, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorNew | This is TokenExtractorNew, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorNewCount | This is TokenExtractorNewCount, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorOld | This is TokenExtractorOld, a member of class TnxFulltextIndexCursorEngine.
TokenExtractorOldCount | Extractor
TokenFilterNew | This is TokenFilterNew, a member of class TnxFulltextIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxFulltextIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxFulltextIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndex | This is TokenIndex, a member of class TnxFulltextIndexCursorEngine.
TokenIndexCount | Index
Links
TnxFulltextIndexCursorEngine Class, Legend, Public Properties


TnxFulltextIndexCursorEngine.FulltextIndexTableEngine Property

TnxFulltextIndexCursorEngine.FulltextIndexTableEngine Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property FulltextIndexTableEngine: TnxFulltextIndexTableEngine;
Description

This is FulltextIndexTableEngine, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.ParentFulltextCursorEngine Property

TnxFulltextIndexCursorEngine.ParentFulltextCursorEngine Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property ParentFulltextCursorEngine: TnxFulltextCursorEngine;
Description

This is ParentFulltextCursorEngine, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenExtractorNew Property

TnxFulltextIndexCursorEngine.TokenExtractorNew Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorNew [aInx : Integer]: TnxBaseTokenExtractorCursorEngine;
Description

This is TokenExtractorNew, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenExtractorNewCount Property

TnxFulltextIndexCursorEngine.TokenExtractorNewCount Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorNewCount: Integer;
Description

This is TokenExtractorNewCount, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenExtractorOld Property

TnxFulltextIndexCursorEngine.TokenExtractorOld Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorOld [aInx : Integer]: TnxBaseTokenExtractorCursorEngine;
Description

This is TokenExtractorOld, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenExtractorOldCount Property

TnxFulltextIndexCursorEngine.TokenExtractorOldCount Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorOldCount: Integer;
Description

Extractor

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenFilterNew Property

TnxFulltextIndexCursorEngine.TokenFilterNew Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterNew [aInx : Integer]: TnxBaseTokenFilterCursorEngine;
Description

This is TokenFilterNew, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenFilterNewCount Property

TnxFulltextIndexCursorEngine.TokenFilterNewCount Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterNewCount: Integer;
Description

This is TokenFilterNewCount, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenFilterOld Property

TnxFulltextIndexCursorEngine.TokenFilterOld Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterOld [aInx : Integer]: TnxBaseTokenFilterCursorEngine;
Description

This is TokenFilterOld, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenFilterOldCount Property

TnxFulltextIndexCursorEngine.TokenFilterOldCount Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenFilterOldCount: Integer;
Description

Filter

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenIndex Property

TnxFulltextIndexCursorEngine.TokenIndex Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenIndex [aInx : Integer]: TnxBaseTokenIndexCursorEngine;
Description

This is TokenIndex, a member of class TnxFulltextIndexCursorEngine.

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxFulltextIndexCursorEngine.TokenIndexCount Property

TnxFulltextIndexCursorEngine.TokenIndexCount Property
TnxFulltextIndexCursorEngine Class TnxFulltextIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxFulltextIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenIndexCount: Integer;
Description

Index

Group

TnxFulltextIndexCursorEngine Properties

Links
TnxFulltextIndexCursorEngine Class, TnxFulltextIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxFulltextIndexCursorEngine Properties


TnxLowercaseLocaleMappingTokenFilterCursorEngine Class

TnxLowercaseLocaleMappingTokenFilterCursorEngine Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEnginenxseFulltextEngineCursor_TnxLowercaseLocaleMappingTokenFilterCursorEngine
Syntax
Delphi
TnxLowercaseLocaleMappingTokenFilterCursorEngine = class(TnxBaseLocaleMappingTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxLowercaseLocaleMappingTokenFilterCursorEngine.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxMainIndexTokenIndexCursorEngine Class

TnxMainIndexTokenIndexCursorEngine Class
TnxMainIndexTokenIndexCursorEngine Fields TnxMainIndexTokenIndexCursorEngine Methods TnxMainIndexTokenIndexCursorEngine Properties TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEnginenxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEnginenxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEnginenxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEnginenxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEnginenxseFulltextEngineCursor_TnxMainIndexTokenIndexCursorEngine
Syntax
Delphi
TnxMainIndexTokenIndexCursorEngine = class(TnxBaseProcessingTokenIndexCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxMainIndexTokenIndexCursorEngine.

Group

Classes

Links
TnxMainIndexTokenIndexCursorEngine Fields, TnxMainIndexTokenIndexCursorEngine Methods, TnxMainIndexTokenIndexCursorEngine Properties, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxMainIndexTokenIndexCursorEngine Members

TnxMainIndexTokenIndexCursorEngine Members
TnxMainIndexTokenIndexCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxMainIndexTokenIndexCursorEngine.

Class

TnxMainIndexTokenIndexCursorEngine Class

Protected Fields
Name | Description
bpticeComparer | private
bpticeTransformer | This is bpticeTransformer, a member of class TnxBaseProcessingTokenIndexCursorEngine.
bticeParentFulltextIndexCursorEngine | private
bticeParentTokenIndexHubCursorEngine | This is bticeParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubNew | This is bticeTokenFilterHubNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenFilterHubOld | This is bticeTokenFilterHubOld, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenIndexTableEngine | This is bticeTokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceNew | This is bticeTokenSourceNew, a member of class TnxBaseTokenIndexCursorEngine.
bticeTokenSourceOld | This is bticeTokenSourceOld, a member of class TnxBaseTokenIndexCursorEngine.
miticeFieldsDescriptor | This is miticeFieldsDescriptor, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeIndexEngine | This is miticeIndexEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeIndexPath | This is miticeIndexPath, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeKeyBuffer | This is miticeKeyBuffer, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeKeyEngine | This is miticeKeyEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeLocationField | This is miticeLocationField, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeMainIndexTokenIndexTableEngine | private
Protected Methods
Name | Description
_AddRef |
_Release |
bpticeAdditionalCompareFlags |
bpticeGetMaxTokenLength |
bpticeUpdateToken |
bpticeUpdateTokens | This is the overview for the bpticeUpdateTokens method overload.
bpticeUpdateTokensForField | This is the overview for the bpticeUpdateTokensForField method overload.
bticeGetTokenFilterNew | TnxBaseTokenIndexCursorEngine
bticeGetTokenFilterNewCount |
bticeGetTokenFilterOld |
bticeGetTokenFilterOldCount |
bticeUpdateIndex |
Create |
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
Public Properties
Name | Description
MainIndexTokenIndexTableEngine | This is MainIndexTokenIndexTableEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
ParentTokenIndexHubCursorEngine | This is ParentTokenIndexHubCursorEngine, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNew | This is TokenFilterNew, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterNewCount | This is TokenFilterNewCount, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOld | This is TokenFilterOld, a member of class TnxBaseTokenIndexCursorEngine.
TokenFilterOldCount | Filter
TokenIndexTableEngine | This is TokenIndexTableEngine, a member of class TnxBaseTokenIndexCursorEngine.
Links
TnxMainIndexTokenIndexCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxMainIndexTokenIndexCursorEngine.Create Constructor

TnxMainIndexTokenIndexCursorEngine.Create Constructor
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenIndexTableEngine; aTokenSourceOld: TnxBaseTokenSourceCursorEngine; aTokenSourceNew: TnxBaseTokenSourceCursorEngine); override;
Class

TnxMainIndexTokenIndexCursorEngine Class

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Class


TnxMainIndexTokenIndexCursorEngine.Destroy Destructor

TnxMainIndexTokenIndexCursorEngine.Destroy Destructor
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxMainIndexTokenIndexCursorEngine Class

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Class


TnxMainIndexTokenIndexCursorEngine Fields

TnxMainIndexTokenIndexCursorEngine Fields
TnxMainIndexTokenIndexCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxMainIndexTokenIndexCursorEngine class are listed here.

Class

TnxMainIndexTokenIndexCursorEngine Class

Protected Fields
Name | Description
miticeFieldsDescriptor | This is miticeFieldsDescriptor, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeIndexEngine | This is miticeIndexEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeIndexPath | This is miticeIndexPath, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeKeyBuffer | This is miticeKeyBuffer, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeKeyEngine | This is miticeKeyEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeLocationField | This is miticeLocationField, a member of class TnxMainIndexTokenIndexCursorEngine.
miticeMainIndexTokenIndexTableEngine | private
Links
TnxMainIndexTokenIndexCursorEngine Class, Legend, Protected Fields


TnxMainIndexTokenIndexCursorEngine.miticeFieldsDescriptor Field

TnxMainIndexTokenIndexCursorEngine.miticeFieldsDescriptor Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeFieldsDescriptor: TnxFieldsDescriptor;
Description

This is miticeFieldsDescriptor, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeIndexEngine Field

TnxMainIndexTokenIndexCursorEngine.miticeIndexEngine Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeIndexEngine: TnxBaseIndexEngine;
Description

This is miticeIndexEngine, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeIndexPath Field

TnxMainIndexTokenIndexCursorEngine.miticeIndexPath Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeIndexPath: TnxBaseIndexPath;
Description

This is miticeIndexPath, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeKeyBuffer Field

TnxMainIndexTokenIndexCursorEngine.miticeKeyBuffer Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeKeyBuffer: PnxByteArray;
Description

This is miticeKeyBuffer, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeKeyEngine Field

TnxMainIndexTokenIndexCursorEngine.miticeKeyEngine Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeKeyEngine: TnxMainIndexTokenKeyEngine;
Description

This is miticeKeyEngine, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeLocationField Field

TnxMainIndexTokenIndexCursorEngine.miticeLocationField Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeLocationField: TnxFieldDescriptor;
Description

This is miticeLocationField, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine.miticeMainIndexTokenIndexTableEngine Field

TnxMainIndexTokenIndexCursorEngine.miticeMainIndexTokenIndexTableEngine Field
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Fields Send Feedback
Syntax
Delphi
miticeMainIndexTokenIndexTableEngine: TnxMainIndexTokenIndexTableEngine;
Description

private

Group

TnxMainIndexTokenIndexCursorEngine Fields

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Fields


TnxMainIndexTokenIndexCursorEngine Methods

TnxMainIndexTokenIndexCursorEngine Methods
TnxMainIndexTokenIndexCursorEngine Class Legend Protected Methods Send Feedback

The methods of the TnxMainIndexTokenIndexCursorEngine class are listed here.

Class

TnxMainIndexTokenIndexCursorEngine Class

Protected Methods
Name | Description
bpticeAdditionalCompareFlags |
bpticeGetMaxTokenLength |
bpticeUpdateToken |
bticeUpdateIndex |
Links
TnxMainIndexTokenIndexCursorEngine Class, Legend, Protected Methods


TnxMainIndexTokenIndexCursorEngine.bpticeAdditionalCompareFlags Method

TnxMainIndexTokenIndexCursorEngine.bpticeAdditionalCompareFlags Method
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bpticeAdditionalCompareFlags: Cardinal; override;
Group

TnxMainIndexTokenIndexCursorEngine Methods

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Methods


TnxMainIndexTokenIndexCursorEngine.bpticeGetMaxTokenLength Method

TnxMainIndexTokenIndexCursorEngine.bpticeGetMaxTokenLength Method
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bpticeGetMaxTokenLength: Integer; override;
Group

TnxMainIndexTokenIndexCursorEngine Methods

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Methods


TnxMainIndexTokenIndexCursorEngine.bpticeUpdateToken Method

TnxMainIndexTokenIndexCursorEngine.bpticeUpdateToken Method
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
procedure bpticeUpdateToken(aTrans: TnxBaseTransaction; aToken: TnxWideString; aField: TnxInt16; const aLocation; aNew: Boolean); override;
Group

TnxMainIndexTokenIndexCursorEngine Methods

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Methods


TnxMainIndexTokenIndexCursorEngine.bticeUpdateIndex Method

TnxMainIndexTokenIndexCursorEngine.bticeUpdateIndex Method
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Methods Send Feedback
Syntax
Delphi
function bticeUpdateIndex(aTrans: TnxBaseTransaction; aOldRecord: PnxByteArray; const aOldRefNr: TnxInt64; aNewRecord: PnxByteArray; const aNewRefNr: TnxInt64): TnxResult; override;
Group

TnxMainIndexTokenIndexCursorEngine Methods

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Methods


TnxMainIndexTokenIndexCursorEngine Properties

TnxMainIndexTokenIndexCursorEngine Properties
TnxMainIndexTokenIndexCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxMainIndexTokenIndexCursorEngine class are listed here.

Class

TnxMainIndexTokenIndexCursorEngine Class

Public Properties
Name | Description
MainIndexTokenIndexTableEngine | This is MainIndexTokenIndexTableEngine, a member of class TnxMainIndexTokenIndexCursorEngine.
Links
TnxMainIndexTokenIndexCursorEngine Class, Legend, Public Properties


TnxMainIndexTokenIndexCursorEngine.MainIndexTokenIndexTableEngine Property

TnxMainIndexTokenIndexCursorEngine.MainIndexTokenIndexTableEngine Property
TnxMainIndexTokenIndexCursorEngine Class TnxMainIndexTokenIndexCursorEngine Members nxseFulltextEngineCursor Namespace TnxMainIndexTokenIndexCursorEngine Properties Send Feedback
Syntax
Delphi
property MainIndexTokenIndexTableEngine: TnxMainIndexTokenIndexTableEngine;
Description

This is MainIndexTokenIndexTableEngine, a member of class TnxMainIndexTokenIndexCursorEngine.

Group

TnxMainIndexTokenIndexCursorEngine Properties

Links
TnxMainIndexTokenIndexCursorEngine Class, TnxMainIndexTokenIndexCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxMainIndexTokenIndexCursorEngine Properties


TnxPreComposeFoldStringTokenFilterCursorEngine Class

TnxPreComposeFoldStringTokenFilterCursorEngine Class
nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEnginenxseFulltextEngineCursor_TnxPreComposeFoldStringTokenFilterCursorEngine
Syntax
Delphi
TnxPreComposeFoldStringTokenFilterCursorEngine = class(TnxBaseFoldStringTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxPreComposeFoldStringTokenFilterCursorEngine.

Group

Classes

Links
nxseFulltextEngineCursor, Classes


TnxStringReplaceTokenFilterCursorEngine Class

TnxStringReplaceTokenFilterCursorEngine Class
TnxStringReplaceTokenFilterCursorEngine Fields TnxStringReplaceTokenFilterCursorEngine Methods TnxStringReplaceTokenFilterCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEnginenxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEnginenxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEnginenxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEnginenxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEnginenxseFulltextEngineCursor_TnxStringReplaceTokenFilterCursorEngine
Syntax
Delphi
TnxStringReplaceTokenFilterCursorEngine = class(TnxBaseTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxStringReplaceTokenFilterCursorEngine.

Group

Classes

Links
TnxStringReplaceTokenFilterCursorEngine Fields, TnxStringReplaceTokenFilterCursorEngine Methods, TnxStringReplaceTokenFilterCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxStringReplaceTokenFilterCursorEngine Members

TnxStringReplaceTokenFilterCursorEngine Members
TnxStringReplaceTokenFilterCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxStringReplaceTokenFilterCursorEngine.

Class

TnxStringReplaceTokenFilterCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
srtfceItems | This is srtfceItems, a member of class TnxStringReplaceTokenFilterCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxStringReplaceTokenFilterCursorEngine
Create | This is the overview for the Create constructor overload.
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
CreateFor | This is the overview for the CreateFor method overload.
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxStringReplaceTokenFilterCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxStringReplaceTokenFilterCursorEngine.Create Constructor

TnxStringReplaceTokenFilterCursorEngine.Create Constructor
TnxStringReplaceTokenFilterCursorEngine Class TnxStringReplaceTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxStringReplaceTokenFilterCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Description

TnxStringReplaceTokenFilterCursorEngine

Class

TnxStringReplaceTokenFilterCursorEngine Class

Links
TnxStringReplaceTokenFilterCursorEngine Class, TnxStringReplaceTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxStringReplaceTokenFilterCursorEngine Class


TnxStringReplaceTokenFilterCursorEngine Fields

TnxStringReplaceTokenFilterCursorEngine Fields
TnxStringReplaceTokenFilterCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxStringReplaceTokenFilterCursorEngine class are listed here.

Class

TnxStringReplaceTokenFilterCursorEngine Class

Protected Fields
Name | Description
srtfceItems | This is srtfceItems, a member of class TnxStringReplaceTokenFilterCursorEngine.
Links
TnxStringReplaceTokenFilterCursorEngine Class, Legend, Protected Fields


TnxStringReplaceTokenFilterCursorEngine.srtfceItems Field

TnxStringReplaceTokenFilterCursorEngine.srtfceItems Field
TnxStringReplaceTokenFilterCursorEngine Class TnxStringReplaceTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxStringReplaceTokenFilterCursorEngine Fields Send Feedback
Syntax
Delphi
srtfceItems: TnxStringReplaceTokenFilterItems;
Description

This is srtfceItems, a member of class TnxStringReplaceTokenFilterCursorEngine.

Group

TnxStringReplaceTokenFilterCursorEngine Fields

Links
TnxStringReplaceTokenFilterCursorEngine Class, TnxStringReplaceTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxStringReplaceTokenFilterCursorEngine Fields


TnxStringReplaceTokenFilterCursorEngine Methods

TnxStringReplaceTokenFilterCursorEngine Methods
TnxStringReplaceTokenFilterCursorEngine Class Legend Public Methods Send Feedback

The methods of the TnxStringReplaceTokenFilterCursorEngine class are listed here.

Class

TnxStringReplaceTokenFilterCursorEngine Class

Public Methods
Name | Description
NextToken |
Links
TnxStringReplaceTokenFilterCursorEngine Class, Legend, Public Methods


TnxStringReplaceTokenFilterCursorEngine.NextToken Method

TnxStringReplaceTokenFilterCursorEngine.NextToken Method
TnxStringReplaceTokenFilterCursorEngine Class TnxStringReplaceTokenFilterCursorEngine Members nxseFulltextEngineCursor Namespace TnxStringReplaceTokenFilterCursorEngine Methods Send Feedback
Syntax
Delphi
function NextToken: InxToken; override;
Group

TnxStringReplaceTokenFilterCursorEngine Methods

Links
TnxStringReplaceTokenFilterCursorEngine Class, TnxStringReplaceTokenFilterCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxStringReplaceTokenFilterCursorEngine Methods


TnxToken Class

TnxToken Class
TnxToken Fields TnxToken Methods TnxToken Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxTokennxseFulltextEngineCursor_TnxTokennxseFulltextEngineCursor_TnxTokennxseFulltextEngineCursor_TnxToken
Syntax
Delphi
TnxToken = class(TnxInterfacedObject, InxToken);
File

nxseFulltextEngineCursor

Description

TnxToken

Group

Classes

Links
TnxToken Fields, TnxToken Methods, TnxToken Members, nxseFulltextEngineCursor, Classes


TnxToken Members

TnxToken Members
TnxToken Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxToken.

Class

TnxToken Class

Protected Fields
Name | Description
ioKeepAlive | This is ioKeepAlive, a member of class TnxInterfacedObject.
ioRefCount | This is ioRefCount, a member of class TnxInterfacedObject.
ioReleased | This is ioReleased, a member of class TnxInterfacedObject.
tknDistance | This is tknDistance, a member of class TnxToken.
tknField | This is tknField, a member of class TnxToken.
tknToken | private
Protected Methods
Name | Description
_AddRef | TnxInterfacedObject
_Release |
GetDistance |
GetField |
GetToken | InxToken
ioDeactivate |
QueryInterface |
Public Methods
Name | Description
AfterConstruction |
BeforeDestruction |
Create |
Free |
FreeInstance |
NewInstance |
NewInstance | TnxObject
Public Properties
Name | Description
Distance | This is Distance, a member of class InxToken.
Field | This is Field, a member of class InxToken.
KeptAlive | This is KeptAlive, a member of class TnxInterfacedObject.
RefCount | This is RefCount, a member of class TnxInterfacedObject.
Token | This is Token, a member of class InxToken.
Links
TnxToken Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxToken.Create Constructor

TnxToken.Create Constructor
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Class Send Feedback
Syntax
Delphi
constructor Create(const aToken: TnxWideString; aDistance: Integer; aField: TnxInt16);
Class

TnxToken Class

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Class


TnxToken Fields

TnxToken Fields
TnxToken Class Legend Protected Fields Send Feedback

The fields of the TnxToken class are listed here.

Class

TnxToken Class

Protected Fields
Name | Description
tknDistance | This is tknDistance, a member of class TnxToken.
tknField | This is tknField, a member of class TnxToken.
tknToken | private
Links
TnxToken Class, Legend, Protected Fields


TnxToken.tknDistance Field

TnxToken.tknDistance Field
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Fields Send Feedback
Syntax
Delphi
tknDistance: Integer;
Description

This is tknDistance, a member of class TnxToken.

Group

TnxToken Fields

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Fields


TnxToken.tknField Field

TnxToken.tknField Field
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Fields Send Feedback
Syntax
Delphi
tknField: TnxInt16;
Description

This is tknField, a member of class TnxToken.

Group

TnxToken Fields

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Fields


TnxToken.tknToken Field

TnxToken.tknToken Field
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Fields Send Feedback
Syntax
Delphi
tknToken: TnxWideString;
Description

private

Group

TnxToken Fields

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Fields


TnxToken Methods

TnxToken Methods
TnxToken Class Legend Protected Methods Send Feedback

The methods of the TnxToken class are listed here.

Class

TnxToken Class

Protected Methods
Name | Description
GetDistance |
GetField |
GetToken | InxToken
Links
TnxToken Class, Legend, Protected Methods


TnxToken.GetDistance Method

TnxToken.GetDistance Method
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Methods Send Feedback
Syntax
Delphi
function GetDistance: Integer;
Group

TnxToken Methods

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Methods


TnxToken.GetField Method

TnxToken.GetField Method
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Methods Send Feedback
Syntax
Delphi
function GetField: TnxInt16;
Group

TnxToken Methods

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Methods


TnxToken.GetToken Method

TnxToken.GetToken Method
TnxToken Class TnxToken Members nxseFulltextEngineCursor Namespace TnxToken Methods Send Feedback
Syntax
Delphi
function GetToken: TnxWideString;
Description

InxToken

Group

TnxToken Methods

Links
TnxToken Class, TnxToken Members, nxseFulltextEngineCursor Namespace, TnxToken Methods


TnxTokenExtractorHubCursorEngine Class

TnxTokenExtractorHubCursorEngine Class
TnxTokenExtractorHubCursorEngine Fields TnxTokenExtractorHubCursorEngine Methods TnxTokenExtractorHubCursorEngine Properties TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxTokenExtractorHubCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorHubCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorHubCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorHubCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorHubCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorHubCursorEngine
Syntax
Delphi
TnxTokenExtractorHubCursorEngine = class(TnxBaseTokenExtractorCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxTokenExtractorHubCursorEngine.

Group

Classes

Links
TnxTokenExtractorHubCursorEngine Fields, TnxTokenExtractorHubCursorEngine Methods, TnxTokenExtractorHubCursorEngine Properties, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxTokenExtractorHubCursorEngine Members

TnxTokenExtractorHubCursorEngine Members
TnxTokenExtractorHubCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenExtractorHubCursorEngine.

Class

TnxTokenExtractorHubCursorEngine Class

Protected Fields
Name | Description
bteceParentTokenExtractorHubCursorEngine | private
bteceTokenExtractorTableEngine | This is bteceTokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHub | This is bteceTokenFilterHub, a member of class TnxBaseTokenExtractorCursorEngine.
bteceTokenFilterHubSource | This is bteceTokenFilterHubSource, a member of class TnxBaseTokenExtractorCursorEngine.
btsceParentFulltextIndexCursorEngine | private
tehceCurrentExtractor | This is tehceCurrentExtractor, a member of class TnxTokenExtractorHubCursorEngine.
tehceTokenExtractorHubTableEngine | private
tehceTokenExtractors | This is tehceTokenExtractors, a member of class TnxTokenExtractorHubCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
bteceGetTokenFilter | TnxBaseTokenExtractorCursorEngine
bteceGetTokenFilterCount |
Create | TnxTokenExtractorHubCursorEngine
Create | This is the overview for the Create constructor overload.
CreateTokenExtractors |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
tehceGetTokenExtractor |
tehceGetTokenExtractorCount |
Unregister |
Public Methods
Name | Description
CreateFor |
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
Initialize |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
NextToken |
NextTokenInternal |
Reset |
Reset |
ResetInternal |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenExtractorHubCursorEngine | This is ParentTokenExtractorHubCursorEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenExtractor | This is TokenExtractor, a member of class TnxTokenExtractorHubCursorEngine.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxTokenExtractorHubCursorEngine.
TokenExtractorHubTableEngine | This is TokenExtractorHubTableEngine, a member of class TnxTokenExtractorHubCursorEngine.
TokenExtractorTableEngine | This is TokenExtractorTableEngine, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilter | This is TokenFilter, a member of class TnxBaseTokenExtractorCursorEngine.
TokenFilterCount | Filter
Links
TnxTokenExtractorHubCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenExtractorHubCursorEngine.Create Constructor

TnxTokenExtractorHubCursorEngine.Create Constructor
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenExtractorTableEngine); override;
Description

TnxTokenExtractorHubCursorEngine

Class

TnxTokenExtractorHubCursorEngine Class

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Class


TnxTokenExtractorHubCursorEngine.Destroy Destructor

TnxTokenExtractorHubCursorEngine.Destroy Destructor
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Class Send Feedback
Syntax
Delphi
destructor Destroy; override;
Class

TnxTokenExtractorHubCursorEngine Class

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Class


TnxTokenExtractorHubCursorEngine Fields

TnxTokenExtractorHubCursorEngine Fields
TnxTokenExtractorHubCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxTokenExtractorHubCursorEngine class are listed here.

Class

TnxTokenExtractorHubCursorEngine Class

Protected Fields
Name | Description
tehceCurrentExtractor | This is tehceCurrentExtractor, a member of class TnxTokenExtractorHubCursorEngine.
tehceTokenExtractorHubTableEngine | private
tehceTokenExtractors | This is tehceTokenExtractors, a member of class TnxTokenExtractorHubCursorEngine.
Links
TnxTokenExtractorHubCursorEngine Class, Legend, Protected Fields


TnxTokenExtractorHubCursorEngine.tehceCurrentExtractor Field

TnxTokenExtractorHubCursorEngine.tehceCurrentExtractor Field
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Fields Send Feedback
Syntax
Delphi
tehceCurrentExtractor: Integer;
Description

This is tehceCurrentExtractor, a member of class TnxTokenExtractorHubCursorEngine.

Group

TnxTokenExtractorHubCursorEngine Fields

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Fields


TnxTokenExtractorHubCursorEngine.tehceTokenExtractorHubTableEngine Field

TnxTokenExtractorHubCursorEngine.tehceTokenExtractorHubTableEngine Field
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Fields Send Feedback
Syntax
Delphi
tehceTokenExtractorHubTableEngine: TnxTokenExtractorHubTableEngine;
Description

private

Group

TnxTokenExtractorHubCursorEngine Fields

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Fields


TnxTokenExtractorHubCursorEngine.tehceTokenExtractors Field

TnxTokenExtractorHubCursorEngine.tehceTokenExtractors Field
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Fields Send Feedback
Syntax
Delphi
tehceTokenExtractors: TnxBaseTokenExtractorCursorEngines;
Description

This is tehceTokenExtractors, a member of class TnxTokenExtractorHubCursorEngine.

Group

TnxTokenExtractorHubCursorEngine Fields

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Fields


TnxTokenExtractorHubCursorEngine Methods

TnxTokenExtractorHubCursorEngine Methods
TnxTokenExtractorHubCursorEngine Class Legend Protected Methods Public Methods Send Feedback

The methods of the TnxTokenExtractorHubCursorEngine class are listed here.

Class

TnxTokenExtractorHubCursorEngine Class

Protected Methods
Name | Description
CreateTokenExtractors |
tehceGetTokenExtractor |
tehceGetTokenExtractorCount |
Public Methods
Name | Description
CreateFor |
Initialize |
NextTokenInternal |
ResetInternal |
Links
TnxTokenExtractorHubCursorEngine Class, Legend, Protected Methods, Public Methods


TnxTokenExtractorHubCursorEngine.CreateFor Method

TnxTokenExtractorHubCursorEngine.CreateFor Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
class function CreateFor(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxTokenExtractorHubTableEngine): TnxTokenExtractorHubCursorEngine; overload;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.CreateTokenExtractors Method

TnxTokenExtractorHubCursorEngine.CreateTokenExtractors Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
procedure CreateTokenExtractors; virtual;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.Initialize Method

TnxTokenExtractorHubCursorEngine.Initialize Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Initialize(aRecord: PnxByteArray; const aRefNr: TnxInt64; aReadOrg: Boolean); override;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.NextTokenInternal Method

TnxTokenExtractorHubCursorEngine.NextTokenInternal Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
function NextTokenInternal: InxToken; override;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.ResetInternal Method

TnxTokenExtractorHubCursorEngine.ResetInternal Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
procedure ResetInternal; override;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.tehceGetTokenExtractor Method

TnxTokenExtractorHubCursorEngine.tehceGetTokenExtractor Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
function tehceGetTokenExtractor(aInx: Integer): TnxBaseTokenExtractorCursorEngine;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine.tehceGetTokenExtractorCount Method

TnxTokenExtractorHubCursorEngine.tehceGetTokenExtractorCount Method
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Methods Send Feedback
Syntax
Delphi
function tehceGetTokenExtractorCount: Integer;
Group

TnxTokenExtractorHubCursorEngine Methods

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Methods


TnxTokenExtractorHubCursorEngine Properties

TnxTokenExtractorHubCursorEngine Properties
TnxTokenExtractorHubCursorEngine Class Legend Public Properties Send Feedback

The properties of the TnxTokenExtractorHubCursorEngine class are listed here.

Class

TnxTokenExtractorHubCursorEngine Class

Public Properties
Name | Description
TokenExtractor | This is TokenExtractor, a member of class TnxTokenExtractorHubCursorEngine.
TokenExtractorCount | This is TokenExtractorCount, a member of class TnxTokenExtractorHubCursorEngine.
TokenExtractorHubTableEngine | This is TokenExtractorHubTableEngine, a member of class TnxTokenExtractorHubCursorEngine.
Links
TnxTokenExtractorHubCursorEngine Class, Legend, Public Properties


TnxTokenExtractorHubCursorEngine.TokenExtractor Property

TnxTokenExtractorHubCursorEngine.TokenExtractor Property
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractor [aInx : Integer]: TnxBaseTokenExtractorCursorEngine;
Description

This is TokenExtractor, a member of class TnxTokenExtractorHubCursorEngine.

Group

TnxTokenExtractorHubCursorEngine Properties

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Properties


TnxTokenExtractorHubCursorEngine.TokenExtractorCount Property

TnxTokenExtractorHubCursorEngine.TokenExtractorCount Property
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorCount: Integer;
Description

This is TokenExtractorCount, a member of class TnxTokenExtractorHubCursorEngine.

Group

TnxTokenExtractorHubCursorEngine Properties

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Properties


TnxTokenExtractorHubCursorEngine.TokenExtractorHubTableEngine Property

TnxTokenExtractorHubCursorEngine.TokenExtractorHubTableEngine Property
TnxTokenExtractorHubCursorEngine Class TnxTokenExtractorHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorHubCursorEngine Properties Send Feedback
Syntax
Delphi
property TokenExtractorHubTableEngine: TnxTokenExtractorHubTableEngine;
Description

This is TokenExtractorHubTableEngine, a member of class TnxTokenExtractorHubCursorEngine.

Group

TnxTokenExtractorHubCursorEngine Properties

Links
TnxTokenExtractorHubCursorEngine Class, TnxTokenExtractorHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorHubCursorEngine Properties


TnxTokenExtractorSourceRedirectorCursorEngine Class

TnxTokenExtractorSourceRedirectorCursorEngine Class
TnxTokenExtractorSourceRedirectorCursorEngine Fields TnxTokenExtractorSourceRedirectorCursorEngine Methods TnxTokenExtractorSourceRedirectorCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxTokenExtractorSourceRedirectorCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorSourceRedirectorCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorSourceRedirectorCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorSourceRedirectorCursorEnginenxseFulltextEngineCursor_TnxTokenExtractorSourceRedirectorCursorEngine
Syntax
Delphi
TnxTokenExtractorSourceRedirectorCursorEngine = class(TnxBaseTokenSourceCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxTokenExtractorSourceRedirectorCursorEngine.

Group

Classes

Links
TnxTokenExtractorSourceRedirectorCursorEngine Fields, TnxTokenExtractorSourceRedirectorCursorEngine Methods, TnxTokenExtractorSourceRedirectorCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxTokenExtractorSourceRedirectorCursorEngine Members

TnxTokenExtractorSourceRedirectorCursorEngine Members
TnxTokenExtractorSourceRedirectorCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenExtractorSourceRedirectorCursorEngine.

Class

TnxTokenExtractorSourceRedirectorCursorEngine Class

Protected Fields
Name | Description
btsceParentFulltextIndexCursorEngine | private
tesrceParent | private
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxTokenExtractorSourceRedirectorCursorEngine
GetExceptionData | InxExceptionData TnxPersistent
GetList |
QueryInterface | InxInterface
Register |
Unregister |
Public Methods
Name | Description
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenExtractorSourceRedirectorCursorEngine.Create Constructor

TnxTokenExtractorSourceRedirectorCursorEngine.Create Constructor
TnxTokenExtractorSourceRedirectorCursorEngine Class TnxTokenExtractorSourceRedirectorCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorSourceRedirectorCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxBaseTokenExtractorCursorEngine);
Description

TnxTokenExtractorSourceRedirectorCursorEngine

Class

TnxTokenExtractorSourceRedirectorCursorEngine Class

Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, TnxTokenExtractorSourceRedirectorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorSourceRedirectorCursorEngine Class


TnxTokenExtractorSourceRedirectorCursorEngine Fields

TnxTokenExtractorSourceRedirectorCursorEngine Fields
TnxTokenExtractorSourceRedirectorCursorEngine Class Legend Protected Fields Send Feedback

The fields of the TnxTokenExtractorSourceRedirectorCursorEngine class are listed here.

Class

TnxTokenExtractorSourceRedirectorCursorEngine Class

Protected Fields
Name | Description
tesrceParent | private
Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, Legend, Protected Fields


TnxTokenExtractorSourceRedirectorCursorEngine.tesrceParent Field

TnxTokenExtractorSourceRedirectorCursorEngine.tesrceParent Field
TnxTokenExtractorSourceRedirectorCursorEngine Class TnxTokenExtractorSourceRedirectorCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorSourceRedirectorCursorEngine Fields Send Feedback
Syntax
Delphi
tesrceParent: TnxBaseTokenExtractorCursorEngine;
Description

private

Group

TnxTokenExtractorSourceRedirectorCursorEngine Fields

Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, TnxTokenExtractorSourceRedirectorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorSourceRedirectorCursorEngine Fields


TnxTokenExtractorSourceRedirectorCursorEngine Methods

TnxTokenExtractorSourceRedirectorCursorEngine Methods
TnxTokenExtractorSourceRedirectorCursorEngine Class Legend Public Methods Send Feedback

The methods of the TnxTokenExtractorSourceRedirectorCursorEngine class are listed here.

Class

TnxTokenExtractorSourceRedirectorCursorEngine Class

Public Methods
Name | Description
NextToken |
Reset |
Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, Legend, Public Methods


TnxTokenExtractorSourceRedirectorCursorEngine.NextToken Method

TnxTokenExtractorSourceRedirectorCursorEngine.NextToken Method
TnxTokenExtractorSourceRedirectorCursorEngine Class TnxTokenExtractorSourceRedirectorCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorSourceRedirectorCursorEngine Methods Send Feedback
Syntax
Delphi
function NextToken: InxToken; override;
Group

TnxTokenExtractorSourceRedirectorCursorEngine Methods

Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, TnxTokenExtractorSourceRedirectorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorSourceRedirectorCursorEngine Methods


TnxTokenExtractorSourceRedirectorCursorEngine.Reset Method

TnxTokenExtractorSourceRedirectorCursorEngine.Reset Method
TnxTokenExtractorSourceRedirectorCursorEngine Class TnxTokenExtractorSourceRedirectorCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenExtractorSourceRedirectorCursorEngine Methods Send Feedback
Syntax
Delphi
procedure Reset; override;
Group

TnxTokenExtractorSourceRedirectorCursorEngine Methods

Links
TnxTokenExtractorSourceRedirectorCursorEngine Class, TnxTokenExtractorSourceRedirectorCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenExtractorSourceRedirectorCursorEngine Methods


TnxTokenFilterHubCursorEngine Class

TnxTokenFilterHubCursorEngine Class
TnxTokenFilterHubCursorEngine Fields TnxTokenFilterHubCursorEngine Methods TnxTokenFilterHubCursorEngine Properties TnxTokenFilterHubCursorEngine Members nxseFulltextEngineCursor Classes Send Feedback
Class Hierarchy
nxseFulltextEngineCursor_TnxTokenFilterHubCursorEnginenxseFulltextEngineCursor_TnxTokenFilterHubCursorEnginenxseFulltextEngineCursor_TnxTokenFilterHubCursorEnginenxseFulltextEngineCursor_TnxTokenFilterHubCursorEnginenxseFulltextEngineCursor_TnxTokenFilterHubCursorEnginenxseFulltextEngineCursor_TnxTokenFilterHubCursorEngine
Syntax
Delphi
TnxTokenFilterHubCursorEngine = class(TnxBaseTokenFilterCursorEngine);
File

nxseFulltextEngineCursor

Description

This is class nxseFulltextEngineCursor.TnxTokenFilterHubCursorEngine.

Group

Classes

Links
TnxTokenFilterHubCursorEngine Fields, TnxTokenFilterHubCursorEngine Methods, TnxTokenFilterHubCursorEngine Properties, TnxTokenFilterHubCursorEngine Members, nxseFulltextEngineCursor, Classes


TnxTokenFilterHubCursorEngine Members

TnxTokenFilterHubCursorEngine Members
TnxTokenFilterHubCursorEngine Class Legend Protected Fields Protected Methods Public Methods Public Properties Send Feedback

The following tables list the members exposed by TnxTokenFilterHubCursorEngine.

Class

TnxTokenFilterHubCursorEngine Class

Protected Fields
Name | Description
btfceParentTokenFilterHubCursorEngine | private
btfceTokenFilterTableEngine | This is btfceTokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
btfceTokenSource | This is btfceTokenSource, a member of class TnxBaseTokenFilterCursorEngine.
btsceParentFulltextIndexCursorEngine | private
tfhceTokenFilterHubTableEngine | private
tfhceTokenFilters | This is tfhceTokenFilters, a member of class TnxTokenFilterHubCursorEngine.
tfhceTokenSource | This is tfhceTokenSource, a member of class TnxTokenFilterHubCursorEngine.
Protected Methods
Name | Description
_AddRef |
_Release |
Create | TnxTokenFilterHubCursorEngine
Create | This is the overview for the Create constructor overload.
CreateTokenFilters |
GetExceptionData | InxExceptionData TnxPersistent
GetList |
GetList |
QueryInterface | InxInterface
Register |
tfhceGetTokenFilter |
tfhceGetTokenFilterCount |
Unregister |
Public Methods
Name | Description
CreateFor |
CreateFor | This is the overview for the CreateFor method overload.
Destroy |
FindEngineClass | TnxBaseRegisterableEngine
FreeInstance | Overidden to take advatange of the NexusDB Memory Manager.
GetExceptionData | This is GetExceptionData, a member of class InxExceptionData.
GetRegisteredEngines |
NewInstance | Overidden to take advatange of the NexusDB Memory Manager.
NextToken |
Reset |
Public Properties
Name | Description
ParentFulltextIndexCursorEngine | This is ParentFulltextIndexCursorEngine, a member of class TnxBaseTokenSourceCursorEngine.
ParentTokenFilterHubCursorEngine | This is ParentTokenFilterHubCursorEngine, a member of class TnxBaseTokenFilterCursorEngine.
TokenFilter | This is TokenFilter, a member of class TnxTokenFilterHubCursorEngine.
TokenFilterCount | This is TokenFilterCount, a member of class TnxTokenFilterHubCursorEngine.
TokenFilterHubTableEngine | This is TokenFilterHubTableEngine, a member of class TnxTokenFilterHubCursorEngine.
TokenFilterTableEngine | This is TokenFilterTableEngine, a member of class TnxBaseTokenFilterCursorEngine.
Links
TnxTokenFilterHubCursorEngine Class, Legend, Protected Fields, Protected Methods, Public Methods, Public Properties


TnxTokenFilterHubCursorEngine.Create Constructor

TnxTokenFilterHubCursorEngine.Create Constructor
TnxTokenFilterHubCursorEngine Class TnxTokenFilterHubCursorEngine Members nxseFulltextEngineCursor Namespace TnxTokenFilterHubCursorEngine Class Send Feedback
Syntax
Delphi
constructor Create(aParent: TnxFulltextIndexCursorEngine; aTableEngine: TnxBaseTokenFilterTableEngine; aTokenSource: TnxBaseTokenSourceCursorEngine); override;
Description

TnxTokenFilterHubCursorEngine

Class

TnxTokenFilterHubCursorEngine Class

Links
TnxTokenFilterHubCursorEngine Class, TnxTokenFilterHubCursorEngine Members, nxseFulltextEngineCursor Namespace, TnxTokenFilterHubCursorEngine Class